Autodesk.Revit.ApplicationServices Namespace

[image]

Revit 2024 API
Autodesk.Revit.ApplicationServices Namespace
Send Feedback

Classes

 | Class | Description
Public class | Application | Represents the Autodesk Revit Application, providing access to documents, options and other application wide data and settings.
Public class | ControlledApplication | Represents the Autodesk Revit Application with no access to documents. It provides options and other application wide data and settings for external applications OnStartup/OnShutdown.

Enumerations

 | Enumeration | Description
Public enumeration | LanguageType | An enumerated type containing the supported Revit product languages.
Public enumeration | ProductType | An enumerated type containing the possible Revit product types.

Send comments on this topic to Autodesk


Application Class

[image]

Revit 2024 API
Application Class
Members Example See Also Send Feedback
Represents the Autodesk Revit Application, providing access to documents, options and other application wide data and settings.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class Application : IDisposable
Visual Basic
Public Class Application _
    Implements IDisposable
Visual C++
public ref class Application : IDisposable

Examples

CopyC#
string versionInfo = application.VersionBuild + "\n"
                    + application.VersionName + "\n"
                    + application.VersionNumber;
CopyVB.NET
Dim versionInfo As String = (application.VersionBuild + vbLf + application.VersionName & vbLf) + application.VersionNumber

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.ApplicationServices..::..Application
Autodesk.Revit.DB.Macros..::..ApplicationEntryPoint

See Also

Application Members
Autodesk.Revit.ApplicationServices Namespace


Application Methods

[image] [image]

Revit 2024 API
Application Methods
Application Class See Also Send Feedback

The Application type exposes the following members.

Methods

 | Name | Description
Public method | CopyModel | Copies an existing model to a new file. Overwriting a file of the same name is allowed.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExtractPartAtomFromFamilyFile | Writes a PartAtom XML from the contents of a family file.
Public method | GetAssets | Gets all the Assets of the specified type.
 | GetFailureDefinitionRegistry | Returns the instance of FailureDefinitionRegistry.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLibraryPaths | Returns path information identifying where Revit searches for content.
Public method | GetRevitServerNetworkHosts | Gets the list of all Revit Server Network hosts in current session.
Public method | GetSystemsAnalysisWorkflowNames | Returns names for systems analysis workflows.
Public method | GetSystemsAnalysisWorkflows | Returns name and path information identifying systems analysis workflow files.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWorksharingCentralGUID | Gets the worksharing central GUID of the given server-based model.
Public method | IsJournalPlaying | Determines if the application is currently in journal playback mode.
 | IsValidThickness | Checks if the input value is valid to be supplied as a thickness (for an extrusion, or blend, or wall layer, or similar geometric construct).
Public method | NewFamilyDocument | New family document, including family, titleblock, and annotation symbol
Public method | NewProjectDocument(String) | New project document
Public method | NewProjectDocument(UnitSystem) | Creates a new project document with no template file specified.
Public method | NewProjectTemplateDocument | New project template document
Public method | OpenDocumentFile(String) | Opens a document from disk.
Public method | OpenDocumentFile(ModelPath, OpenOptions) | Opens a document from disk or cloud.
Public method | OpenDocumentFile(ModelPath, OpenOptions, IOpenFromCloudCallback) | Opens a document from disk or cloud.
Public method | OpenIFCDocument(String) | Opens an IFC document from disk using default options.
Public method | OpenIFCDocument(String, IFCImportOptions) | Opens an IFC document from disk using custom options.
Public method | OpenSharedParameterFile | Enables access to shared parameter groups and definitions that are maintained on disk.
Public method | PurgeReleasedAPIObjects | Explicitly purges all API objects that have been released but are still awaiting to be finalized
 | RegisterFailuresProcessor | Replaces Revit's default user interface (if present) with alternative handling for all warnings and errors (including those not generated by your application) for the rest of the Revit session; if your application is not prepared to respond to all warnings and errors, consider use of IFailuresPreprocessor (in your opened Transaction) or the FailuresProcessing event instead of this interface.
Public method | SetLibraryPaths | Sets path information identifying where Revit searches for content.
Public method | SetSystemsAnalysisWorkflows | Sets name and path information identifying systems analysis workflow files.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateRenderAppearanceLibrary | Updates the stored render appearance library, giving the Revit session access to any new RPC content.
Public method | WriteJournalComment | Writes a comment to the Revit journal file.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


CopyModel Method

[image]

Revit 2024 API
Application..::..CopyModel Method
Application Class See Also Send Feedback
Copies an existing model to a new file. Overwriting a file of the same name is allowed.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public void CopyModel(
    ModelPath sourceModelPath,
    string destFilePath,
    bool overwrite
)
Visual Basic
Public Sub CopyModel ( _
    sourceModelPath As ModelPath, _
    destFilePath As String, _
    overwrite As Boolean _
)
Visual C++
public:
void CopyModel(
    ModelPath^ sourceModelPath,
    String^ destFilePath,
    bool overwrite
)

Parameters

sourceModelPath
Type: Autodesk.Revit.DB..::..ModelPath
The path of the file-based or server-based source model.
destFilePath
Type: System..::..String
The path of the destination file.
overwrite
Type: System..::..Boolean
True if the destination file can be overwritten; otherwise, false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given path sourceModelPath is a cloud path which is not supported in this method.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..CentralModelAccessDeniedException | Access to the central model was denied. A possible reason is because the model was under maintenance.
Autodesk.Revit.Exceptions..::..CentralModelException | The central model is missing. -or- An internal error happened on the central model, please contact the server administrator.
Autodesk.Revit.Exceptions..::..DirectoryNotFoundException | Thrown when the directory of destination file doesn't exist.
Autodesk.Revit.Exceptions..::..FileArgumentAlreadyExistsException | The destination file exists and can't be overwritten. -or- destFilePath is pointing to a folder that already exists and cannot be deleted.
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | The Revit model specified by sourceModelPath doesn't exist.
Autodesk.Revit.Exceptions..::..InvalidPathArgumentException | The destination file name includes one or more invalid characters.
Autodesk.Revit.Exceptions..::..RevitServerCommunicationException | The server-based central model could not be accessed because of a network communication error.
Autodesk.Revit.Exceptions..::..RevitServerInternalException | An internal error happened on the server, please contact the server administrator.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


Dispose Method

[image]

Revit 2024 API
Application..::..Dispose Method
Application Class See Also Send Feedback
Releases all resources used by the Application

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


ExtractPartAtomFromFamilyFile Method

[image]

Revit 2024 API
Application..::..ExtractPartAtomFromFamilyFile Method
Application Class See Also Send Feedback
Writes a PartAtom XML from the contents of a family file.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void ExtractPartAtomFromFamilyFile(
    string familyFilePath,
    string xmlFilePath
)
Visual Basic
Public Sub ExtractPartAtomFromFamilyFile ( _
    familyFilePath As String, _
    xmlFilePath As String _
)
Visual C++
public:
void ExtractPartAtomFromFamilyFile(
    String^ familyFilePath,
    String^ xmlFilePath
)

Parameters

familyFilePath
Type: System..::..String
The family file to be processed.
xmlFilePath
Type: System..::..String
The xml file to be saved.

Remarks

If there is a TXT type catalog next to the family file (a TXT file with the same name as the RFA file), the function will read it as well and process its contents into PartAtom. To extract a PartAtom XML from a family loaded into a document in session, use Family.ExtractPartAtom().

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | If 'familyFilePath' or 'xmlFilePath' is nullNothingnullptra null reference (Nothing in Visual Basic) or an empty string or if the family file doesn't exist on disk.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


GetAssets Method

[image]

Revit 2024 API
Application..::..GetAssets Method
Application Class See Also Send Feedback
Gets all the Assets of the specified type.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018.1

Syntax

C#
public IList<Asset> GetAssets(
    AssetType assetType
)
Visual Basic
Public Function GetAssets ( _
    assetType As AssetType _
) As IList(Of Asset)
Visual C++
public:
IList<Asset^>^ GetAssets(
    AssetType assetType
)

Parameters

assetType
Type: Autodesk.Revit.DB.Visual..::..AssetType
The asset type.

Return Value

Returns an array of all the Assets within Revit of the specified type.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


GetFailureDefinitionRegistry Method

[image]

Revit 2024 API
Application..::..GetFailureDefinitionRegistry Method
Application Class See Also Send Feedback
Returns the instance of FailureDefinitionRegistry.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static FailureDefinitionRegistry GetFailureDefinitionRegistry()
Visual Basic
Public Shared Function GetFailureDefinitionRegistry As FailureDefinitionRegistry
Visual C++
public:
static FailureDefinitionRegistry^ GetFailureDefinitionRegistry()

Return Value

The instance of FailureDefinitionRegistry.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


GetLibraryPaths Method

[image]

Revit 2024 API
Application..::..GetLibraryPaths Method
Application Class Example See Also Send Feedback
Returns path information identifying where Revit searches for content.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public IDictionary<string, string> GetLibraryPaths()
Visual Basic
Public Function GetLibraryPaths As IDictionary(Of String, String)
Visual C++
public:
IDictionary<String^, String^>^ GetLibraryPaths()

Return Value

The map of library paths.

Remarks

The map that is returned contains a key that is purpose of the path, such as Material Libraries and the value in the map is the fully qualified path that is used for that search path.

Examples

CopyC#
string strLibPaths = "";
foreach (String path in application.GetLibraryPaths().Values)
{
    strLibPaths += path + "\n";
}
CopyVB.NET
Dim strLibPaths As String = ""
For Each path As [String] In application.GetLibraryPaths().Values
    strLibPaths += path & vbLf
Next

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


GetRevitServerNetworkHosts Method

[image]

Revit 2024 API
Application..::..GetRevitServerNetworkHosts Method
Application Class See Also Send Feedback
Gets the list of all Revit Server Network hosts in current session.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public IList<string> GetRevitServerNetworkHosts()
Visual Basic
Public Function GetRevitServerNetworkHosts As IList(Of String)
Visual C++
public:
IList<String^>^ GetRevitServerNetworkHosts()

Return Value

An array of names of all Revit Server Network hosts in current session.

Remarks

The list of Revit Server Network hosts is stored externally in the RSN[version].ini file.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


GetSystemsAnalysisWorkflowNames Method

[image]

Revit 2024 API
Application..::..GetSystemsAnalysisWorkflowNames Method
Application Class See Also Send Feedback
Returns names for systems analysis workflows.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020.1

Syntax

C#
public IList<string> GetSystemsAnalysisWorkflowNames()
Visual Basic
Public Function GetSystemsAnalysisWorkflowNames As IList(Of String)
Visual C++
public:
IList<String^>^ GetSystemsAnalysisWorkflowNames()

Return Value

An array of names of systems analysis workflows.

Remarks

The array that is returned contains the name of the systems analysis workflow, in the order they are specified in Options.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


GetWorksharingCentralGUID Method

[image]

Revit 2024 API
Application..::..GetWorksharingCentralGUID Method
Application Class See Also Send Feedback
Gets the worksharing central GUID of the given server-based model.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public Guid GetWorksharingCentralGUID(
    ServerPath serverModelPath
)
Visual Basic
Public Function GetWorksharingCentralGUID ( _
    serverModelPath As ServerPath _
) As Guid
Visual C++
public:
Guid GetWorksharingCentralGUID(
    ServerPath^ serverModelPath
)

Parameters

serverModelPath
Type: Autodesk.Revit.DB..::..ServerPath
The server-based model path.

Return Value

The worksharing central GUID.

Remarks

The given server-based model saved in a release prior to Revit 2013 did not have this GUID. Only the given server-based model saved in Revit 2013 or later will be able to provide this value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..CentralModelException | The central model is missing. -or- An internal error happened on the central model, please contact the server administrator.
Autodesk.Revit.Exceptions..::..InapplicableDataException | Thrown when the given model is not created in Revit 2013 or later release.
Autodesk.Revit.Exceptions..::..RevitServerCommunicationException | The server-based central model could not be accessed because of a network communication error.
Autodesk.Revit.Exceptions..::..RevitServerInternalException | An internal error happened on the server, please contact the server administrator.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


IsJournalPlaying Method

[image]

Revit 2024 API
Application..::..IsJournalPlaying Method
Application Class See Also Send Feedback
Determines if the application is currently in journal playback mode.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public bool IsJournalPlaying()
Visual Basic
Public Function IsJournalPlaying As Boolean
Visual C++
public:
bool IsJournalPlaying()

Return Value

true if a journal is currently playing back, false otherwise.

Remarks

Determines if Revit is in the process of playing back a journal. It can be used to help prevent any user interaction that may cause issues during playback. For more information on Revit's journaling features contact the Autodesk Developer Network.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


IsValidThickness Method

[image]

Revit 2024 API
Application..::..IsValidThickness Method
Application Class See Also Send Feedback
Checks if the input value is valid to be supplied as a thickness (for an extrusion, or blend, or wall layer, or similar geometric construct).

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static bool IsValidThickness(
    double thickness
)
Visual Basic
Public Shared Function IsValidThickness ( _
    thickness As Double _
) As Boolean
Visual C++
public:
static bool IsValidThickness(
    double thickness
)

Parameters

thickness
Type: System..::..Double
The input value.

Return Value

True if the input value is valid for thickness; false otherwise.

Remarks

This checks two conditions:
  • The value is greater than or equal to the minimum thickness allowed in Revit for these types of geometric constructs.
  • The value is less than or equal to the maximum length/distance allowed by Revit for elements.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


NewFamilyDocument Method

[image]

Revit 2024 API
Application..::..NewFamilyDocument Method
Application Class Example See Also Send Feedback
New family document, including family, titleblock, and annotation symbol

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Document NewFamilyDocument(
    string templateFileName
)
Visual Basic
Public Overridable Function NewFamilyDocument ( _
    templateFileName As String _
) As Document
Visual C++
public:
virtual Document^ NewFamilyDocument(
    String^ templateFileName
)

Parameters

templateFileName
Type: System..::..String
The template file name.

Remarks

This command corresponds to File->New->Family.../TitleBlock.../Annotation Symbol....

Examples

CopyC#
// create a new family document using Generic Model.rft template
string templateFileName = @"C:\Documents and Settings\All Users\Application Data\Autodesk\RST 2010\Imperial Templates\Generic Model.rft";
Document familyDocument = application.NewFamilyDocument(templateFileName);
if (null == familyDocument)
{
    throw new Exception("Cannot open family document");
}
CopyVB.NET
' create a new family document using Generic Model.rft template
Dim templateFileName As String = "C:\Documents and Settings\All Users\Application Data\Autodesk\RST 2010\Imperial Templates\Generic Model.rft"
Dim familyDocument As Document = application.NewFamilyDocument(templateFileName)
If familyDocument Is Nothing Then
    Throw New Exception("Cannot open family document")
End If

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | If 'templateFileName' is nullNothingnullptra null reference (Nothing in Visual Basic) or an empty string.
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the new family document cannot be created.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


NewProjectDocument Method (String)

[image]

Revit 2024 API
Application..::..NewProjectDocument Method (String)
Application Class See Also Send Feedback
New project document

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Document NewProjectDocument(
    string templateFileName
)
Visual Basic
Public Overridable Function NewProjectDocument ( _
    templateFileName As String _
) As Document
Visual C++
public:
virtual Document^ NewProjectDocument(
    String^ templateFileName
)

Parameters

templateFileName
Type: System..::..String
The template file name.

Remarks

This command corresponds to New->Project command in the user-interface.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | If 'templateFileName' is nullNothingnullptra null reference (Nothing in Visual Basic) or an empty string.
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the new project document cannot be created.

See Also

Application Class
NewProjectDocument Overload
Autodesk.Revit.ApplicationServices Namespace


NewProjectDocument Method (UnitSystem)

[image]

Revit 2024 API
Application..::..NewProjectDocument Method (UnitSystem)
Application Class See Also Send Feedback
Creates a new project document with no template file specified.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public Document NewProjectDocument(
    UnitSystem unitSystem
)
Visual Basic
Public Function NewProjectDocument ( _
    unitSystem As UnitSystem _
) As Document
Visual C++
public:
Document^ NewProjectDocument(
    UnitSystem unitSystem
)

Parameters

unitSystem
Type: Autodesk.Revit.DB..::..UnitSystem
The unit system used for the new document.

Return Value

The newly created document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

Application Class
NewProjectDocument Overload
Autodesk.Revit.ApplicationServices Namespace


NewProjectTemplateDocument Method

[image]

Revit 2024 API
Application..::..NewProjectTemplateDocument Method
Application Class See Also Send Feedback
New project template document

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Document NewProjectTemplateDocument(
    string templateFilename
)
Visual Basic
Public Overridable Function NewProjectTemplateDocument ( _
    templateFilename As String _
) As Document
Visual C++
public:
virtual Document^ NewProjectTemplateDocument(
    String^ templateFilename
)

Parameters

templateFilename
Type: System..::..String
The template file name.

Remarks

This command corresponds to New->Project->Project Template command in the user-interface.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | If 'templateFileName' is nullNothingnullptra null reference (Nothing in Visual Basic) or an empty string.
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the project template document cannot be created.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


OpenDocumentFile Method

[image] [image]

Revit 2024 API
Application..::..OpenDocumentFile Method
Application Class See Also Send Feedback

Overload List

 | Name | Description
Public method | OpenDocumentFile(String) | Opens a document from disk.
Public method | OpenDocumentFile(ModelPath, OpenOptions) | Opens a document from disk or cloud.
Public method | OpenDocumentFile(ModelPath, OpenOptions, IOpenFromCloudCallback) | Opens a document from disk or cloud.

See Also

Application Class
Application Members
Autodesk.Revit.ApplicationServices Namespace


OpenDocumentFile Method (String)

[image]

Revit 2024 API
Application..::..OpenDocumentFile Method (String)
Application Class See Also Send Feedback
Opens a document from disk.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public Document OpenDocumentFile(
    string fileName
)
Visual Basic
Public Function OpenDocumentFile ( _
    fileName As String _
) As Document
Visual C++
public:
Document^ OpenDocumentFile(
    String^ fileName
)

Parameters

fileName
Type: System..::..String
The file to be opened.

Return Value

The opened document.

Remarks

This method opens the document into memory but does not make it visible to the user in any way.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The fileName to be opened is empty.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..CannotOpenBothCentralAndLocalException | Cannot open the local model and the central model in the same Revit session. You can close one to open the other in the same Revit session.
Autodesk.Revit.Exceptions..::..CentralModelException | Revit encountered serious errors while trying to open the central model.
Autodesk.Revit.Exceptions..::..CorruptModelException | There are too many corrupt elements to open this model.
Autodesk.Revit.Exceptions..::..FileAccessException | File cannot be opened in Revit LT because it was last saved in a version of Revit prior to 8.1. -or- File has an invalid extension. Try changing the file's extension and opening it again.
Autodesk.Revit.Exceptions..::..FileNotFoundException | The fileName to be opened doesn't exist. -or- File Not Found
Autodesk.Revit.Exceptions..::..InsufficientResourcesException | This computer does not have enough memory, disk space, or other necessary resource to open the model.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Open is temporarily disabled. -or- The document can not be opened.
Autodesk.Revit.Exceptions..::..OperationCanceledException | Opening was canceled by the user or by an API event callback.

See Also

Application Class
OpenDocumentFile Overload
Autodesk.Revit.ApplicationServices Namespace


OpenDocumentFile Method (ModelPath, OpenOptions)

[image]

Revit 2024 API
Application..::..OpenDocumentFile Method (ModelPath, OpenOptions)
Application Class Example See Also Send Feedback
Opens a document from disk or cloud.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public Document OpenDocumentFile(
    ModelPath modelPath,
    OpenOptions openOptions
)
Visual Basic
Public Function OpenDocumentFile ( _
    modelPath As ModelPath, _
    openOptions As OpenOptions _
) As Document
Visual C++
public:
Document^ OpenDocumentFile(
    ModelPath^ modelPath,
    OpenOptions^ openOptions
)

Parameters

modelPath
Type: Autodesk.Revit.DB..::..ModelPath
The file to be opened.
openOptions
Type: Autodesk.Revit.DB..::..OpenOptions
Options for opening the file.

Return Value

The opened document.

Remarks

This method opens the document into memory but does not make it visible to the user in any way. If the user currently has ownership of elements in this model and there is no local model on this machine, Revit will post a warning.

Examples

CopyC#
private static Document OpenDetached(Application application, ModelPath modelPath)
{
    OpenOptions options1 = new OpenOptions();

    options1.DetachFromCentralOption = DetachFromCentralOption.DetachAndDiscardWorksets;
    Document openedDoc = application.OpenDocumentFile(modelPath, options1);

    return openedDoc;
}
CopyVB.NET
Private Shared Function OpenDetached(application As Application, modelPath As ModelPath) As Document
    Dim options1 As New OpenOptions()

    options1.DetachFromCentralOption = DetachFromCentralOption.DetachAndDiscardWorksets
    Dim openedDoc As Document = application.OpenDocumentFile(modelPath, options1)

    Return openedDoc
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The modelPath to be opened is empty.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..CannotOpenBothCentralAndLocalException | Cannot open the local model and the central model in the same Revit session. You can close one to open the other in the same Revit session.
Autodesk.Revit.Exceptions..::..CentralModelAccessDeniedException | Access to the central model was denied. A possible reason is because the model was under maintenance.
Autodesk.Revit.Exceptions..::..CentralModelContentionException | The model on the RevitServer is being accessed by other users. -or- The central model is locked by another client.
Autodesk.Revit.Exceptions..::..CentralModelException | Revit encountered serious errors while trying to open the central model. -or- An internal error happened on the central model, please contact the server administrator.
Autodesk.Revit.Exceptions..::..CorruptModelException | There are too many corrupt elements to open this model.
Autodesk.Revit.Exceptions..::..FileAccessException | File cannot be opened in Revit LT because it was last saved in a version of Revit prior to 8.1. -or- File has an invalid extension. Try changing the file's extension and opening it again. -or- File was saved by an application that was not developed or licensed by Autodesk.
Autodesk.Revit.Exceptions..::..FileNotFoundException | The modelPath to be opened doesn't exist. -or- File Not Found
Autodesk.Revit.Exceptions..::..InsufficientResourcesException | This computer does not have enough memory, disk space, or other necessary resource to open the model.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Open is temporarily disabled. -or- The cloud model is not saved in current release of Revit. -or- The model is not allowed to access. -or- The document can not be opened. -or- Revit cannot save the transmitted model as a new central because it is already opened.
Autodesk.Revit.Exceptions..::..OperationCanceledException | Opening was canceled by the user or by an API event callback.
Autodesk.Revit.Exceptions..::..RevitServerCommunicationException | The server-based central model could not be accessed because of a network communication error.
Autodesk.Revit.Exceptions..::..RevitServerInternalException | An internal error happened on the server, please contact the server administrator.
Autodesk.Revit.Exceptions..::..RevitServerUnauthorizedException | User is not authorized to access the cloud model.
Autodesk.Revit.Exceptions..::..WrongUserException | The local file is not owned by the current user, who therefore is not allowed to modify it.

See Also

Application Class
OpenDocumentFile Overload
Autodesk.Revit.ApplicationServices Namespace


OpenIFCDocument Method

[image] [image]

Revit 2024 API
Application..::..OpenIFCDocument Method
Application Class See Also Send Feedback

Overload List

 | Name | Description
Public method | OpenIFCDocument(String) | Opens an IFC document from disk using default options.
Public method | OpenIFCDocument(String, IFCImportOptions) | Opens an IFC document from disk using custom options.

See Also

Application Class
Application Members
Autodesk.Revit.ApplicationServices Namespace


OpenIFCDocument Method (String)

[image]

Revit 2024 API
Application..::..OpenIFCDocument Method (String)
Application Class See Also Send Feedback
Opens an IFC document from disk using default options.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Document OpenIFCDocument(
    string fileName
)
Visual Basic
Public Function OpenIFCDocument ( _
    fileName As String _
) As Document
Visual C++
public:
Document^ OpenIFCDocument(
    String^ fileName
)

Parameters

fileName
Type: System..::..String
The IFC file to be opened.

Return Value

The newly created document containing the IFC file.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | If 'fileName' is an empty string.
Autodesk.Revit.Exceptions..::..ArgumentNullException | If nullNothingnullptra null reference (Nothing in Visual Basic) is passed as 'fileName' -or- A non-optional argument was null
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | If the file specified by 'fileName' cannot be found.
Autodesk.Revit.Exceptions..::..InvalidOperationException | If Revit is missing document templates or if the file cannot be opened.

See Also

Application Class
OpenIFCDocument Overload
Autodesk.Revit.ApplicationServices Namespace


OpenIFCDocument Method (String, IFCImportOptions)

[image]

Revit 2024 API
Application..::..OpenIFCDocument Method (String, IFCImportOptions)
Application Class See Also Send Feedback
Opens an IFC document from disk using custom options.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public Document OpenIFCDocument(
    string fileName,
    IFCImportOptions importOptions
)
Visual Basic
Public Function OpenIFCDocument ( _
    fileName As String, _
    importOptions As IFCImportOptions _
) As Document
Visual C++
public:
Document^ OpenIFCDocument(
    String^ fileName,
    IFCImportOptions^ importOptions
)

Parameters

fileName
Type: System..::..String
The IFC file to be opened.
importOptions
Type: Autodesk.Revit.DB.IFC..::..IFCImportOptions
The options for this import.

Return Value

The newly created document containing the IFC file.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | If 'fileName' is an empty string.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | If the file specified by 'fileName' cannot be found.
Autodesk.Revit.Exceptions..::..InvalidOperationException | If Revit is missing document templates or if the file cannot be opened.

See Also

Application Class
OpenIFCDocument Overload
Autodesk.Revit.ApplicationServices Namespace


SetLibraryPaths Method

[image]

Revit 2024 API
Application..::..SetLibraryPaths Method
Application Class See Also Send Feedback
Sets path information identifying where Revit searches for content.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public void SetLibraryPaths(
    IDictionary<string, string> paths
)
Visual Basic
Public Sub SetLibraryPaths ( _
    paths As IDictionary(Of String, String) _
)
Visual C++
public:
void SetLibraryPaths(
    IDictionary<String^, String^>^ paths
)

Parameters

paths
Type: System.Collections.Generic..::..IDictionary<(Of <(<'String, String>)>)>
The map of library paths.

Remarks

The map that is returned should contain a key that is purpose of the path, such as Material Libraries and the value in the map is the fully qualified path to be used for that search path.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


SetSystemsAnalysisWorkflows Method

[image]

Revit 2024 API
Application..::..SetSystemsAnalysisWorkflows Method
Application Class See Also Send Feedback
Sets name and path information identifying systems analysis workflow files.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020.1

Syntax

C#
public void SetSystemsAnalysisWorkflows(
    IDictionary<string, string> paths
)
Visual Basic
Public Sub SetSystemsAnalysisWorkflows ( _
    paths As IDictionary(Of String, String) _
)
Visual C++
public:
void SetSystemsAnalysisWorkflows(
    IDictionary<String^, String^>^ paths
)

Parameters

paths
Type: System.Collections.Generic..::..IDictionary<(Of <(<'String, String>)>)>
The map of systems analysis workflows.

Remarks

The map should be specified as a key that is the name of the systems analysis workflow, and a value that is the path to the workflow file.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


UpdateRenderAppearanceLibrary Method

[image]

Revit 2024 API
Application..::..UpdateRenderAppearanceLibrary Method
Application Class See Also Send Feedback
Updates the stored render appearance library, giving the Revit session access to any new RPC content.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void UpdateRenderAppearanceLibrary()
Visual Basic
Public Sub UpdateRenderAppearanceLibrary
Visual C++
public:
void UpdateRenderAppearanceLibrary()

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


WriteJournalComment Method

[image]

Revit 2024 API
Application..::..WriteJournalComment Method
Application Class See Also Send Feedback
Writes a comment to the Revit journal file.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public void WriteJournalComment(
    string comment,
    bool timeStamp
)
Visual Basic
Public Sub WriteJournalComment ( _
    comment As String, _
    timeStamp As Boolean _
)
Visual C++
public:
void WriteJournalComment(
    String^ comment,
    bool timeStamp
)

Parameters

comment
Type: System..::..String
Text for journal comment.
timeStamp
Type: System..::..Boolean
If a time stamp should be included in the journal comment.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


ActiveAddInId Property

[image]

Revit 2024 API
Application..::..ActiveAddInId Property
Application Class See Also Send Feedback
Retrieves the Id of the currently running external application.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public AddInId ActiveAddInId { get; }
Visual Basic
Public ReadOnly Property ActiveAddInId As AddInId
    Get
Visual C++
public:
property AddInId^ ActiveAddInId {
    AddInId^ get ();
}

Remarks

The application can be either a UI application, DB application, or an external command. If no addin is active, this property will return nullNothingnullptra null reference (Nothing in Visual Basic). If an event handler is currently being executed, the returned value will be the Id of the application or command in which the event handler was registered.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


AllowNavigationDuringRedraw Property

[image]

Revit 2024 API
Application..::..AllowNavigationDuringRedraw Property
Application Class See Also Send Feedback
Checks whether or not the navigation during redraw is enabled, and enable or disable it.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool AllowNavigationDuringRedraw { get; set; }
Visual Basic
Public Property AllowNavigationDuringRedraw As Boolean
    Get
    Set
Visual C++
public:
property bool AllowNavigationDuringRedraw {
    bool get ();
    void set (bool value);
}

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


AllUsersAddinsLocation Property

[image]

Revit 2024 API
Application..::..AllUsersAddinsLocation Property
Application Class See Also Send Feedback
The folder location for .addin files for all users.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public string AllUsersAddinsLocation { get; }
Visual Basic
Public ReadOnly Property AllUsersAddinsLocation As String
    Get
Visual C++
public:
property String^ AllUsersAddinsLocation {
    String^ get ();
}

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


AngleTolerance Property

[image]

Revit 2024 API
Application..::..AngleTolerance Property
Application Class See Also Send Feedback
Angle tolerance.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public double AngleTolerance { get; }
Visual Basic
Public ReadOnly Property AngleTolerance As Double
    Get
Visual C++
public:
property double AngleTolerance {
    double get ();
}

Remarks

Value is in radians. Two angle measurements closer than this value are considered identical. Do not use this value for any purpose other than its intended purpose, which is to check if two angles are the same within this tolerance value. Do not use this value to set the value of an angle. Doing so will result in unstable behavior.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


BackgroundColor Property

[image]

Revit 2024 API
Application..::..BackgroundColor Property
Application Class See Also Send Feedback
The background color to use for model views in this session.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public Color BackgroundColor { get; set; }
Visual Basic
Public Property BackgroundColor As Color
    Get
    Set
Visual C++
public:
property Color^ BackgroundColor {
    Color^ get ();
    void set (Color^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The backgroundColor argument does not represent a valid color.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


Cities Property

[image]

Revit 2024 API
Application..::..Cities Property
Application Class Example See Also Send Feedback
Returns a set of all the known city locations within Revit.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CitySet Cities { get; }
Visual Basic
Public ReadOnly Property Cities As CitySet
    Get
Visual C++
public:
property CitySet^ Cities {
    CitySet^ get ();
}

Remarks

Each city has information about longitude, latitude etc.

Examples

CopyC#
// Get all Revit support cities
Autodesk.Revit.DB.CitySet cities = application.Cities;

// Set all Revit support cities into an ArrayList
System.Collections.ArrayList cityList = new System.Collections.ArrayList();
foreach (Autodesk.Revit.DB.City city in cities)
{
    cityList.Add(city);
}
CopyVB.NET
' Get all Revit support cities
Dim cities As Autodesk.Revit.DB.CitySet = application.Cities

' Set all Revit support cities into an ArrayList
Dim cityList As New System.Collections.ArrayList()
For Each city As Autodesk.Revit.DB.City In cities
    cityList.Add(city)
Next

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


Create Property

[image]

Revit 2024 API
Application..::..Create Property
Application Class See Also Send Feedback
Provides an object that can be used to create new instances of Autodesk Revit API objects.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Application Create { get; }
Visual Basic
Public ReadOnly Property Create As Application
    Get
Visual C++
public:
property Application^ Create {
    Application^ get ();
}

Remarks

The Create property returns an object that is used to create application wide utility and geometric objects within the Autodesk Revit API, such as arrays, sets, lines. This object should be used when you wish to create an object within the Autodesk Revit application memory, rather than your own application's memory. If you are performing your own memory management techniques then it is advisable to create any utility objects via the Create object. For example: Instead of Dim set As New Autodesk_Revit_ElementSet do Set set = application.Create.NewElementSet()

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


CurrentRevitServerAccelerator Property

[image]

Revit 2024 API
Application..::..CurrentRevitServerAccelerator Property
Application Class See Also Send Feedback
Current Revit Server accelerator.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public string CurrentRevitServerAccelerator { get; set; }
Visual Basic
Public Property CurrentRevitServerAccelerator As String
    Get
    Set
Visual C++
public:
property String^ CurrentRevitServerAccelerator {
    String^ get ();
    void set (String^ value);
}

Remarks

Revit connects with Revit Server hosts via current Revit Server accelerator. If current Revit Server accelerator is not set, this will be an empty string.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The server name can not be used to construct a well formed Uri string.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: When setting the value, Revit failed to write current Revit Server accelerator to the user environment.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


CurrentUserAddinsLocation Property

[image]

Revit 2024 API
Application..::..CurrentUserAddinsLocation Property
Application Class See Also Send Feedback
The folder location for .addin files for the current user.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public string CurrentUserAddinsLocation { get; }
Visual Basic
Public ReadOnly Property CurrentUserAddinsLocation As String
    Get
Visual C++
public:
property String^ CurrentUserAddinsLocation {
    String^ get ();
}

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


CurrentUsersDataFolderPath Property

[image]

Revit 2024 API
Application..::..CurrentUsersDataFolderPath Property
Application Class See Also Send Feedback
Path to data folder for the current user.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public string CurrentUsersDataFolderPath { get; }
Visual Basic
Public ReadOnly Property CurrentUsersDataFolderPath As String
    Get
Visual C++
public:
property String^ CurrentUsersDataFolderPath {
    String^ get ();
}

Remarks

Similar to C:\Users\[UserName]\AppData\Roaming\Autodesk\[ProductType]\[ReleaseName]

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


DefaultIFCProjectTemplate Property

[image]

Revit 2024 API
Application..::..DefaultIFCProjectTemplate Property
Application Class See Also Send Feedback
Full path to the default template file for new IFC project documents. It may be empty, in which case the DefaultProjectTemplate should be used.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public string DefaultIFCProjectTemplate { get; }
Visual Basic
Public ReadOnly Property DefaultIFCProjectTemplate As String
    Get
Visual C++
public:
property String^ DefaultIFCProjectTemplate {
    String^ get ();
}

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


DefaultProjectTemplate Property

[image]

Revit 2024 API
Application..::..DefaultProjectTemplate Property
Application Class See Also Send Feedback
Full path to the default template file for new project documents.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public string DefaultProjectTemplate { get; }
Visual Basic
Public ReadOnly Property DefaultProjectTemplate As String
    Get
Visual C++
public:
property String^ DefaultProjectTemplate {
    String^ get ();
}

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


Documents Property

[image]

Revit 2024 API
Application..::..Documents Property
Application Class See Also Send Feedback
Returns a set of documents within Revit.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual DocumentSet Documents { get; }
Visual Basic
Public Overridable ReadOnly Property Documents As DocumentSet
    Get
Visual C++
public:
virtual property DocumentSet^ Documents {
    DocumentSet^ get ();
}

Remarks

This property can be used for the user to find all the document inside Revit.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


FamilyTemplatePath Property

[image]

Revit 2024 API
Application..::..FamilyTemplatePath Property
Application Class See Also Send Feedback
Default path for family template files.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public string FamilyTemplatePath { get; }
Visual Basic
Public ReadOnly Property FamilyTemplatePath As String
    Get
Visual C++
public:
property String^ FamilyTemplatePath {
    String^ get ();
}

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


IsArchitectureEnabled Property

[image]

Revit 2024 API
Application..::..IsArchitectureEnabled Property
Application Class See Also Send Feedback
Checks whether or not the architecture discipline is enabled, and enable or disable it.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool IsArchitectureEnabled { get; set; }
Visual Basic
Public Property IsArchitectureEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsArchitectureEnabled {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The current product type is not ProductType.Revit and discipline controls are not enabled.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


IsElectricalAnalysisEnabled Property

[image]

Revit 2024 API
Application..::..IsElectricalAnalysisEnabled Property
Application Class See Also Send Feedback
Checks whether or not electrical analysis is enabled, and enable or disable it.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool IsElectricalAnalysisEnabled { get; set; }
Visual Basic
Public Property IsElectricalAnalysisEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsElectricalAnalysisEnabled {
    bool get ();
    void set (bool value);
}

Remarks

Enabling electrical analysis will not take effect unless the electrical discipline is also enabled.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The current product type is not ProductType.Revit and discipline controls are not enabled.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


IsElectricalEnabled Property

[image]

Revit 2024 API
Application..::..IsElectricalEnabled Property
Application Class See Also Send Feedback
Checks whether or not the electrical discipline is enabled, and enable or disable it.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool IsElectricalEnabled { get; set; }
Visual Basic
Public Property IsElectricalEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsElectricalEnabled {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The current product type is not ProductType.Revit and discipline controls are not enabled.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


IsEnergyAnalysisEnabled Property

[image]

Revit 2024 API
Application..::..IsEnergyAnalysisEnabled Property
Application Class See Also Send Feedback
Checks whether or not energy analysis is enabled, and enable or disable it.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool IsEnergyAnalysisEnabled { get; set; }
Visual Basic
Public Property IsEnergyAnalysisEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsEnergyAnalysisEnabled {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The current product type is not ProductType.Revit and discipline controls are not enabled.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


IsLoggedIn Property

[image]

Revit 2024 API
Application..::..IsLoggedIn Property
Application Class See Also Send Feedback
Checks if the user is logged in from this session to their Autodesk account.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public static bool IsLoggedIn { get; }
Visual Basic
Public Shared ReadOnly Property IsLoggedIn As Boolean
    Get
Visual C++
public:
static property bool IsLoggedIn {
    bool get ();
}

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


IsMassingEnabled Property

[image]

Revit 2024 API
Application..::..IsMassingEnabled Property
Application Class See Also Send Feedback
Checks whether or not the massing and site tools are enabled, and enable or disable them.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool IsMassingEnabled { get; set; }
Visual Basic
Public Property IsMassingEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsMassingEnabled {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The current product type is not ProductType.Revit and discipline controls are not enabled.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


IsMechanicalAnalysisEnabled Property

[image]

Revit 2024 API
Application..::..IsMechanicalAnalysisEnabled Property
Application Class See Also Send Feedback
Checks whether or not mechanical analysis is enabled, and enable or disable it.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool IsMechanicalAnalysisEnabled { get; set; }
Visual Basic
Public Property IsMechanicalAnalysisEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsMechanicalAnalysisEnabled {
    bool get ();
    void set (bool value);
}

Remarks

Enabling mechanical analysis will not take effect unless the mechanical discipline is also enabled.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The current product type is not ProductType.Revit and discipline controls are not enabled.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


IsMechanicalEnabled Property

[image]

Revit 2024 API
Application..::..IsMechanicalEnabled Property
Application Class See Also Send Feedback
Checks whether or not the mechanical discipline is enabled, and enable or disable it.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool IsMechanicalEnabled { get; set; }
Visual Basic
Public Property IsMechanicalEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsMechanicalEnabled {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The current product type is not ProductType.Revit and discipline controls are not enabled.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


IsPipingAnalysisEnabled Property

[image]

Revit 2024 API
Application..::..IsPipingAnalysisEnabled Property
Application Class See Also Send Feedback
Checks whether or not piping analysis is enabled, and enable or disable it.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool IsPipingAnalysisEnabled { get; set; }
Visual Basic
Public Property IsPipingAnalysisEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsPipingAnalysisEnabled {
    bool get ();
    void set (bool value);
}

Remarks

Enabling piping analysis will not take effect unless the piping discipline is also enabled.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The current product type is not ProductType.Revit and discipline controls are not enabled.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


IsPipingEnabled Property

[image]

Revit 2024 API
Application..::..IsPipingEnabled Property
Application Class See Also Send Feedback
Checks whether or not the piping discipline is enabled, and enable or disable it.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool IsPipingEnabled { get; set; }
Visual Basic
Public Property IsPipingEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsPipingEnabled {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The current product type is not ProductType.Revit and discipline controls are not enabled.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


IsRouteAnalysisEnabled Property

[image]

Revit 2024 API
Application..::..IsRouteAnalysisEnabled Property
Application Class See Also Send Feedback
Checks whether or not route analysis is enabled, and enable or disable it.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public bool IsRouteAnalysisEnabled { get; set; }
Visual Basic
Public Property IsRouteAnalysisEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsRouteAnalysisEnabled {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The current product type is not ProductType.Revit and discipline controls are not enabled.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


IsStructureEnabled Property

[image]

Revit 2024 API
Application..::..IsStructureEnabled Property
Application Class See Also Send Feedback
Checks whether or not the structure discipline is enabled, and enable or disable it.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool IsStructureEnabled { get; set; }
Visual Basic
Public Property IsStructureEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsStructureEnabled {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The current product type is not ProductType.Revit and discipline controls are not enabled.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


IsSystemsEnabled Property

[image]

Revit 2024 API
Application..::..IsSystemsEnabled Property
Application Class See Also Send Feedback
Checks whether or not any systems disciplines (mechanical, electrical, or piping) are enabled.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool IsSystemsEnabled { get; }
Visual Basic
Public ReadOnly Property IsSystemsEnabled As Boolean
    Get
Visual C++
public:
property bool IsSystemsEnabled {
    bool get ();
}

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


IsValidObject Property

[image]

Revit 2024 API
Application..::..IsValidObject Property
Application Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


Language Property

[image]

Revit 2024 API
Application..::..Language Property
Application Class See Also Send Feedback
The language used in the current session of Revit.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public LanguageType Language { get; }
Visual Basic
Public ReadOnly Property Language As LanguageType
    Get
Visual C++
public:
property LanguageType Language {
    LanguageType get ();
}

Remarks

Use this property to determine the language used by Revit; this can allow your application to load the appropriate resources.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


LoginUserId Property

[image]

Revit 2024 API
Application..::..LoginUserId Property
Application Class See Also Send Feedback
The user id of the user currently logged in. The user id will be empty if the user is not logged in.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public string LoginUserId { get; }
Visual Basic
Public ReadOnly Property LoginUserId As String
    Get
Visual C++
public:
property String^ LoginUserId {
    String^ get ();
}

Remarks

The internal id of Autodesk ID that the current user has logged in to A360. This user id is in human unrecognizable form. In conjunction with the Store Entitlement REST API, a publisher of Autodesk Exchange Store app can verify if the current user has purchased their app from the store. For more information about Store Entitlement API, please refer to www.autodesk.com/developapps.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


MinimumThickness Property

[image]

Revit 2024 API
Application..::..MinimumThickness Property
Application Class See Also Send Feedback
The minimum thickness allowed in Revit for a variety of geometric constructs. These include blends, extrusions, and wall layers.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static double MinimumThickness { get; }
Visual Basic
Public Shared ReadOnly Property MinimumThickness As Double
    Get
Visual C++
public:
static property double MinimumThickness {
    double get ();
}

Remarks

Do not use this value for any purpose other than its intended purpose. If you want to check for valid thickness value, use the function isValidThickness.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


Product Property

[image]

Revit 2024 API
Application..::..Product Property
Application Class See Also Send Feedback
The product type for the current session of Revit.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ProductType Product { get; }
Visual Basic
Public ReadOnly Property Product As ProductType
    Get
Visual C++
public:
property ProductType Product {
    ProductType get ();
}

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


RecordingJournalFilename Property

[image]

Revit 2024 API
Application..::..RecordingJournalFilename Property
Application Class See Also Send Feedback
Retrieve the name of the journal file the Revit is currently recording to.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string RecordingJournalFilename { get; }
Visual Basic
Public ReadOnly Property RecordingJournalFilename As String
    Get
Visual C++
public:
property String^ RecordingJournalFilename {
    String^ get ();
}

Remarks

As Revit operates it keeps a log of operations that the user performs within a file, known as a journal file. These files provide information about the actions performed in a session and the state of Revit when a problem occurs. These files are included during error reporting to Autodesk.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


ShortCurveTolerance Property

[image]

Revit 2024 API
Application..::..ShortCurveTolerance Property
Application Class See Also Send Feedback
The enforced minimum length for any curve created by Revit.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public double ShortCurveTolerance { get; }
Visual Basic
Public ReadOnly Property ShortCurveTolerance As Double
    Get
Visual C++
public:
property double ShortCurveTolerance {
    double get ();
}

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


ShowGraphicalOpenEndsAreaBasedLoadBoundaryDisconnects Property

[image]

Revit 2024 API
Application..::..ShowGraphicalOpenEndsAreaBasedLoadBoundaryDisconnects Property
Application Class See Also Send Feedback
Whether or not to show the graphical open ends for Area Based Load Boundary disconnects.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public bool ShowGraphicalOpenEndsAreaBasedLoadBoundaryDisconnects { get; set; }
Visual Basic
Public Property ShowGraphicalOpenEndsAreaBasedLoadBoundaryDisconnects As Boolean
    Get
    Set
Visual C++
public:
property bool ShowGraphicalOpenEndsAreaBasedLoadBoundaryDisconnects {
    bool get ();
    void set (bool value);
}

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


ShowGraphicalWarningCableTrayConduitDisconnects Property

[image]

Revit 2024 API
Application..::..ShowGraphicalWarningCableTrayConduitDisconnects Property
Application Class See Also Send Feedback
Whether or not to show the graphical warnings for CTC disconnects.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public bool ShowGraphicalWarningCableTrayConduitDisconnects { get; set; }
Visual Basic
Public Property ShowGraphicalWarningCableTrayConduitDisconnects As Boolean
    Get
    Set
Visual C++
public:
property bool ShowGraphicalWarningCableTrayConduitDisconnects {
    bool get ();
    void set (bool value);
}

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


ShowGraphicalWarningElectricalDisconnects Property

[image]

Revit 2024 API
Application..::..ShowGraphicalWarningElectricalDisconnects Property
Application Class See Also Send Feedback
Whether or not to show the graphical warnings for Electrical disconnects.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public bool ShowGraphicalWarningElectricalDisconnects { get; set; }
Visual Basic
Public Property ShowGraphicalWarningElectricalDisconnects As Boolean
    Get
    Set
Visual C++
public:
property bool ShowGraphicalWarningElectricalDisconnects {
    bool get ();
    void set (bool value);
}

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


ShowGraphicalWarningHangerDisconnects Property

[image]

Revit 2024 API
Application..::..ShowGraphicalWarningHangerDisconnects Property
Application Class See Also Send Feedback
Whether or not to show the graphical warnings for Fabrication Hanger disconnects.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool ShowGraphicalWarningHangerDisconnects { get; set; }
Visual Basic
Public Property ShowGraphicalWarningHangerDisconnects As Boolean
    Get
    Set
Visual C++
public:
property bool ShowGraphicalWarningHangerDisconnects {
    bool get ();
    void set (bool value);
}

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


ShowGraphicalWarningPipeDisconnects Property

[image]

Revit 2024 API
Application..::..ShowGraphicalWarningPipeDisconnects Property
Application Class See Also Send Feedback
Whether or not to show the graphical warnings for Pipe disconnects.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public bool ShowGraphicalWarningPipeDisconnects { get; set; }
Visual Basic
Public Property ShowGraphicalWarningPipeDisconnects As Boolean
    Get
    Set
Visual C++
public:
property bool ShowGraphicalWarningPipeDisconnects {
    bool get ();
    void set (bool value);
}

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


SubVersionNumber Property

[image]

Revit 2024 API
Application..::..SubVersionNumber Property
Application Class See Also Send Feedback
The minor version number of Revit

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public string SubVersionNumber { get; }
Visual Basic
Public ReadOnly Property SubVersionNumber As String
    Get
Visual C++
public:
property String^ SubVersionNumber {
    String^ get ();
}

Remarks

SubVersionNumber of Revit may have additional APIs and functionality not available in the standard customer releases. Add-ins written to support standard Revit releases should be compatible with SubVersionNumber releases, but add-ins written specifically targeting new features in SubVersionNumber releases would not be compatible with the standard releases.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


SystemsAnalysisWorkfilesRootPath Property

[image]

Revit 2024 API
Application..::..SystemsAnalysisWorkfilesRootPath Property
Application Class See Also Send Feedback
Root path for systems analysis workfiles

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public string SystemsAnalysisWorkfilesRootPath { get; }
Visual Basic
Public ReadOnly Property SystemsAnalysisWorkfilesRootPath As String
    Get
Visual C++
public:
property String^ SystemsAnalysisWorkfilesRootPath {
    String^ get ();
}

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


Username Property

[image]

Revit 2024 API
Application..::..Username Property
Application Class See Also Send Feedback
Gets the user name for the current Revit session.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public string Username { get; }
Visual Basic
Public ReadOnly Property Username As String
    Get
Visual C++
public:
property String^ Username {
    String^ get ();
}

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


VersionBuild Property

[image]

Revit 2024 API
Application..::..VersionBuild Property
Application Class See Also Send Feedback
Returns the internal build number of the Autodesk Revit application.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string VersionBuild { get; }
Visual Basic
Public ReadOnly Property VersionBuild As String
    Get
Visual C++
public:
property String^ VersionBuild {
    String^ get ();
}

Remarks

This property can be used by your application to find the version of Autodesk Revit against which your application is running. Based on this information your application can report if it is able to work correctly with that version of Autodesk Revit.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


VersionName Property

[image]

Revit 2024 API
Application..::..VersionName Property
Application Class See Also Send Feedback
Returns the name of the Revit application.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string VersionName { get; }
Visual Basic
Public ReadOnly Property VersionName As String
    Get
Visual C++
public:
property String^ VersionName {
    String^ get ();
}

Remarks

This property can be used by your application to find the version of Revit against which your application is running. Based on this information your application can report if it is able to work correctly with that version of Revit.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


VersionNumber Property

[image]

Revit 2024 API
Application..::..VersionNumber Property
Application Class See Also Send Feedback
Return the primary version of the Revit application.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string VersionNumber { get; }
Visual Basic
Public ReadOnly Property VersionNumber As String
    Get
Visual C++
public:
property String^ VersionNumber {
    String^ get ();
}

Remarks

This property can be used by your application to find the version of Revit against which your application is running. Based on this information your application can report if it is able to work correctly with that version of Revit.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


VertexTolerance Property

[image]

Revit 2024 API
Application..::..VertexTolerance Property
Application Class See Also Send Feedback
Vertex tolerance.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public double VertexTolerance { get; }
Visual Basic
Public ReadOnly Property VertexTolerance As Double
    Get
Visual C++
public:
property double VertexTolerance {
    double get ();
}

Remarks

Two points within this distance are considered coincident. Do not use this value for any purpose other than its intended purpose, which is to check if two points are the same within this tolerance value. Do not use this value to set the distance between two points. Doing so will result in unstable behavior.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application Events

[image] [image]

Revit 2024 API
Application Events
Application Class See Also Send Feedback

The Application type exposes the following members.

Events

 | Name | Description
Public event | ApplicationInitialized | Subscribe to this event to get notified after the Revit application has been initialized
Public event | DocumentChanged | Subscribe to the DocumentChanged event to be notified when Revit document has changed.
Public event | DocumentClosed | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
Public event | DocumentClosing | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
Public event | DocumentCreated | Subscribe to the DocumentCreated event to be notified immediately after Revit has finished creating a new document.
Public event | DocumentCreating | Subscribe to the DocumentCreating event to be notified when Revit is just about to create a new document.
Public event | DocumentOpened | Subscribe to the DocumentOpened event to be notified immediately after Revit has finished opening a document.
Public event | DocumentOpening | Subscribe to the DocumentOpening event to be notified when Revit is just about to open a document.
Public event | DocumentPrinted | Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.
Public event | DocumentPrinting | Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.
Public event | DocumentReloadedLatest | Subscribe to the DocumentReloadedLatestEventArgs event to be notified immediately after Revit has finished reloading a document with central model.
Public event | DocumentReloadingLatest | Subscribe to the DocumentReloadingLatestEventArgs event to be notified when Revit is just about to reload latest changes from a central model.
Public event | DocumentSaved | Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving a document.
Public event | DocumentSavedAs | Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.
Public event | DocumentSaving | Subscribe to the DocumentSaving event to be notified when Revit is just about to save a document.
Public event | DocumentSavingAs | Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.
Public event | DocumentSynchronizedWithCentral | Subscribe to the DocumentSynchronizedWithCentral event to be notified immediately after Revit has finished synchronizing a document with central model.
Public event | DocumentSynchronizingWithCentral | Subscribe to the DocumentSynchronizingWithCentral event to be notified when Revit is just about to synchronize a document with central model.
Public event | DocumentWorksharingEnabled | Subscribe to the DocumentWorksharingEnabled event to be notified when a document has become workshared.
Public event | ElementTypeDuplicated | Subscribe to the ElementTypeDuplicated event to be notified immediately after Revit has finished duplicating an element type.
Public event | ElementTypeDuplicating | Subscribe to the ElementTypeDuplicating event to be notified when Revit is just about to duplicate an element type.
Public event | FailuresProcessing | Subscribe to the FailuresProcessing event to be notified when failures are being processed at the end of transaction.
Public event | FamilyLoadedIntoDocument | Subscribe to the FamilyLoadedInto event to be notified after Revit loaded a family into a document.
Public event | FamilyLoadingIntoDocument | Subscribe to the FamilyLoadingInto event to be notified when Revit is just about to load a family into a document.
Public event | FileExported | Subscribe to the FileExported event to be notified immediately after Revit has finished exporting files of formats supported by the API.
Public event | FileExporting | Subscribe to the FileExporting event to be notified when Revit is just about to export files of formats supported by the API.
Public event | FileImported | Subscribe to the FileImported event to be notified immediately after Revit has finished importing a file of format supported by the API.
Public event | FileImporting | Subscribe to the FileImporting event to be notified when Revit is just about to import a file of format supported by the API.
Public event | LinkedResourceOpened | Subscribe to the LinkedResourceOpened event to be notified immediately after Revit has finished opening a linked resource.
Public event | LinkedResourceOpening | Subscribe to the LinkedResourceOpening event to be notified when Revit is just about to open a linked resource.
Public event | ProgressChanged | Subscribe to the ProgressChanged event to be notified when an operation in Revit has progress bar data available.
Public event | ViewExported | Subscribe to the ViewExported event to be notified immediately after Revit has finished exporting a view of the document.
Public event | ViewExporting | Subscribe to the ViewExporting event to be notified when Revit is just about to export a view of the document.
Public event | ViewPrinted | Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.
Public event | ViewPrinting | Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.
Public event | ViewsExportedByContext | Subscribe to the ViewsExportedByContext event to be notified immediately after Revit has finished exporting one or more views of the document via an export context by CustomExporter.
Public event | ViewsExportingByContext | Subscribe to the ViewsExportingByContext event to be notified when Revit is just about to export one or more views of the document via an export context by CustomExporter.
Public event | WorksharedOperationProgressChanged | Subscribe to the WorksharedOperationProgressChanged to be notified when progress has changed during Collaboration for Revit's workshared operations: open model and synchronize with central.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


DocumentChanged Event

[image]

Revit 2024 API
Application..::..DocumentChanged Event
Application Class See Also Send Feedback
Subscribe to the DocumentChanged event to be notified when Revit document has changed.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public event EventHandler<DocumentChangedEventArgs> DocumentChanged
Visual Basic
Public Event DocumentChanged As EventHandler(Of DocumentChangedEventArgs)
Visual C++
public:
 event EventHandler<DocumentChangedEventArgs^>^ DocumentChanged {
    void add (EventHandler<DocumentChangedEventArgs^>^ value);
    void remove (EventHandler<DocumentChangedEventArgs^>^ value);
}

Remarks

This event is raised whenever a Revit transaction is either committed, undone or redone. This is a readonly event, designed to allow you to keep external data in synch with the state of the Revit database. To update the Revit database in response to changes in elements, use the IUpdater framework.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


DocumentCreated Event

[image]

Revit 2024 API
Application..::..DocumentCreated Event
Application Class See Also Send Feedback
Subscribe to the DocumentCreated event to be notified immediately after Revit has finished creating a new document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2010

Syntax

C#
public event EventHandler<DocumentCreatedEventArgs> DocumentCreated
Visual Basic
Public Event DocumentCreated As EventHandler(Of DocumentCreatedEventArgs)
Visual C++
public:
 event EventHandler<DocumentCreatedEventArgs^>^ DocumentCreated {
    void add (EventHandler<DocumentCreatedEventArgs^>^ value);
    void remove (EventHandler<DocumentCreatedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished creating a new document. It is raised even when document creation failed or was cancelled (during DocumentCreating event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event's argument to see whether the action itself was successful or not. This event is not cancellable, for the process of document creation has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


DocumentCreating Event

[image]

Revit 2024 API
Application..::..DocumentCreating Event
Application Class See Also Send Feedback
Subscribe to the DocumentCreating event to be notified when Revit is just about to create a new document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2010

Syntax

C#
public event EventHandler<DocumentCreatingEventArgs> DocumentCreating
Visual Basic
Public Event DocumentCreating As EventHandler(Of DocumentCreatingEventArgs)
Visual C++
public:
 event EventHandler<DocumentCreatingEventArgs^>^ DocumentCreating {
    void add (EventHandler<DocumentCreatingEventArgs^>^ value);
    void remove (EventHandler<DocumentCreatingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to create a new document.

Event is cancellable. To cancel it, call the 'Cancel()' method of event's argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document cannot be modified, for it is not created yet at the time of the event.

The following API functions are not available for the current document during this event:

  • [!:Autodesk::Revit::ApplicationServices::Application::NewProjectDocument()]
  • NewFamilyDocument(String)
  • NewProjectTemplateDocument(String)
  • OpenDocumentFile(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another DocumentCreated event will be raised immediately after document creation is finished.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


DocumentOpened Event

[image]

Revit 2024 API
Application..::..DocumentOpened Event
Application Class Example See Also Send Feedback
Subscribe to the DocumentOpened event to be notified immediately after Revit has finished opening a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2010

Syntax

C#
public event EventHandler<DocumentOpenedEventArgs> DocumentOpened
Visual Basic
Public Event DocumentOpened As EventHandler(Of DocumentOpenedEventArgs)
Visual C++
public:
 event EventHandler<DocumentOpenedEventArgs^>^ DocumentOpened {
    void add (EventHandler<DocumentOpenedEventArgs^>^ value);
    void remove (EventHandler<DocumentOpenedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished opening a document. It is raised even when document opening failed or was cancelled (during DocumentOpening event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event's argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of opening document has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Examples

CopyC#
public class Application_DocumentOpened : IExternalApplication
{
    /// <ExampleMethod>
    /// <summary>
    /// Implement this method to subscribe to event.
    /// </summary>
    public Result OnStartup(UIControlledApplication application)
    {
        try
        {
            // Register event.
           application.ControlledApplication.DocumentOpened += new EventHandler
                <Autodesk.Revit.DB.Events.DocumentOpenedEventArgs>(application_DocumentOpened);
        }
        catch (Exception)
        {
            return Result.Failed;
        }

        return Result.Succeeded;
    }

    /// <summary>
    /// Implement OnShutdown method of IExternalApplication interface to unregister subscribed event
    /// </summary>
    public Result OnShutdown(UIControlledApplication application)
    {
        // remove the event.
       application.ControlledApplication.DocumentOpened -= application_DocumentOpened;
        return Result.Succeeded;
    }

    /// <TrivialCode>
    /// Code ID: 501
    /// For DocumentOpened class description
    /// </TrivialCode>

    /// <description>
    /// This sample demonstrates how to subscribe to the DocumentOpened event and modify the model in the event handler method.
    /// </description>
    /// <summary>
    /// This is the event handler. We modify the model.
    /// </summary>
    /// <param name="sender">Event sender.</param>
    /// <param name="args"></param>
    public void application_DocumentOpened(object sender, DocumentOpenedEventArgs args)
    {
        // get document from event args.
        Document doc = args.Document;

        // Following code snippet demonstrates support of DocumentOpened event to modify the model.
        // Because DocumentOpened supports model changes, it allows user to update document data.
        // Here, this sample assigns a specified value to ProjectInformation.Address property.
        // User can change other properties of document or create(delete) something as he likes.
        //
        // Please note that ProjectInformation property is empty for family document.
        // So please don't run this sample on family document.
        using (Transaction transaction = new Transaction(doc, "Edit Address"))
        {
           if (transaction.Start() == TransactionStatus.Started)
           {
              doc.ProjectInformation.Address =
                  "United States - Massachusetts - Waltham - 1560 Trapelo Road";
              transaction.Commit();
           }
        }
    }

    /// </ExampleMethod>
}
CopyVB.NET
Public Class Application_DocumentOpened
    Implements IExternalApplication
    ' <ExampleMethod>
    ' <summary>
    ' Implement this method to subscribe to event.
    ' </summary>
    Public Function OnStartup(application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnStartup
        Try
            ' Register event.
            AddHandler application.ControlledApplication.DocumentOpened, AddressOf application_DocumentOpened
        Catch generatedExceptionName As Exception
            Return Result.Failed
        End Try

        Return Result.Succeeded
    End Function

    ' <summary>
    ' Implement OnShutdown method of IExternalApplication interface to unregister subscribed event
    ' </summary>
    Public Function OnShutdown(application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnShutdown
        ' remove the event.
        RemoveHandler application.ControlledApplication.DocumentOpened, AddressOf application_DocumentOpened
        Return Result.Succeeded
    End Function

    ' <TrivialCode>
    ' Code ID: 501
    ' For DocumentOpened class description
    ' </TrivialCode>

    ' <description>
    ' This sample demonstrates how to subscribe to the DocumentOpened event and modify the model in the event handler method.
    ' </description>
    ' <summary>
    ' This is the event handler. We modify the model.
    ' </summary>
    ' <param name="sender">Event sender.</param>
    ' <param name="args"></param>
    Public Sub application_DocumentOpened(sender As Object, args As DocumentOpenedEventArgs)
        ' get document from event args.
        Dim doc As Document = args.Document

        ' Following code snippet demonstrates support of DocumentOpened event to modify the model.
        ' Because DocumentOpened supports model changes, it allows user to update document data.
        ' Here, this sample assigns a specified value to ProjectInformation.Address property.
        ' User can change other properties of document or create(delete) something as he likes.
        '
        ' Please note that ProjectInformation property is empty for family document.
        ' So please don't run this sample on family document.
        Using transaction As New Transaction(doc, "Edit Address")
            If transaction.Start() = TransactionStatus.Started Then
                doc.ProjectInformation.Address = "United States - Massachusetts - Waltham - 1560 Trapelo Road"
                transaction.Commit()
            End If
        End Using
    End Sub

    ' </ExampleMethod>
End Class

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


DocumentPrinted Event

[image]

Revit 2024 API
Application..::..DocumentPrinted Event
Application Class Example See Also Send Feedback
Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2010

Syntax

C#
public event EventHandler<DocumentPrintedEventArgs> DocumentPrinted
Visual Basic
Public Event DocumentPrinted As EventHandler(Of DocumentPrintedEventArgs)
Visual C++
public:
 event EventHandler<DocumentPrintedEventArgs^>^ DocumentPrinted {
    void add (EventHandler<DocumentPrintedEventArgs^>^ value);
    void remove (EventHandler<DocumentPrintedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished printing a view or ViewSet of the document. It is raised even when document printing failed or was cancelled (during DocumentPriting event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event's argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of printing has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Examples

CopyC#
public class Application_DocumentPrinted : IExternalApplication
{
    /// <ExampleMethod>
    /// <summary>
    /// Implement the OnStartup method to register events when Revit starts.
    /// </summary>
    public Result OnStartup(UIControlledApplication application)
    {
        // Register related events
       application.ControlledApplication.DocumentPrinted += new EventHandler<Autodesk.Revit.DB.Events.DocumentPrintedEventArgs>(AppDocumentPrinted);
        return Result.Succeeded;
    }

    /// <summary>
    /// Implement this method to unregister the subscribed events when Revit exits.
    /// </summary>
    public Result OnShutdown(UIControlledApplication application)
    {
        // unregister events
       application.ControlledApplication.DocumentPrinted -= new EventHandler<Autodesk.Revit.DB.Events.DocumentPrintedEventArgs>(AppDocumentPrinted);
        return Result.Succeeded;
    }
    /// <TrivialCode>
    /// Code ID: 501
    /// For DocumentPrinted class description
    /// </TrivialCode>

    /// <summary>
    /// Handler method for DocumentPrinted event, it will display some event arguments.
    /// </summary>
    public void AppDocumentPrinted(object sender, Autodesk.Revit.DB.Events.DocumentPrintedEventArgs args)
    {
        StringBuilder info = new StringBuilder();
        Application app = sender as Application;
        info.AppendLine("DocumentPrintedEventArgs Parameters ------>");
        info.AppendLine("    Event Status      : " + args.Status.ToString());
        info.AppendLine("    Event Cancellable : " + args.Cancellable);
        //
        // PrintedViews
        if (0 == args.GetFailedViewElementIds().Count || 0 == args.GetPrintedViewElementIds().Count)
        {
            info.AppendLine("    Views been printed: <null>");
        }
        else
        {
            info.AppendLine("    Views been printed: ");
            DumpViewsInfo(app, args.GetPrintedViewElementIds(), "      ", ref info);
        }
        //
        // FailedViews
        if (0 == args.GetFailedViewElementIds().Count)
        {
            info.AppendLine("    Views failed: <null>");
        }
        else
        {
            info.AppendLine("    Views Failed : ");
            DumpViewsInfo(app, args.GetFailedViewElementIds(), "      ", ref info);
        }

        TaskDialog.Show("Revit",info.ToString());
    }

    /// <summary>
    /// Dump information of views: ViewType, Id and ViewName.
    /// </summary>
    /// <param name="views">Views to be displayed in message box.</param>
    /// <param name="prefix">Prefix mark for each line added to message box.</param>
    /// <param name="info">String where data is stored for display</param>
    private static void DumpViewsInfo(Application app, System.Collections.Generic.IList<ElementId> viewIds, String prefix, ref StringBuilder info)
    {
        int index = 0;
        UIApplication uiApp = new UIApplication(app);
        foreach (ElementId curViewId in viewIds)
        {
            Autodesk.Revit.DB.View curView = uiApp.ActiveUIDocument.Document.GetElement(curViewId) as Autodesk.Revit.DB.View;
                DumpViewInfo(curView, String.Format("{0}#{1}", prefix, index++), ref info);
        }
    }

    /// <summary>
    /// Dump information of single view: ViewType, Id and ViewName.
    /// </summary>
    /// <param name="view">View element to be displayed in message box.</param>
    /// <param name="prefix">Prefix mark for each line added to message box.</param>
    /// <param name="info">String where data is stored for display</param>
    private static void DumpViewInfo(Autodesk.Revit.DB.View view, String prefix, ref StringBuilder info)
    {
        info.AppendLine(String.Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}",
            prefix, view.Id.ToString(), view.Name, view.ViewType));
    }
    /// </ExampleMethod>
}
CopyVB.NET
Public Class Application_DocumentPrinted
    Implements IExternalApplication
    ' <ExampleMethod>
    ' <summary>
    ' Implement the OnStartup method to register events when Revit starts.
    ' </summary>
    Public Function OnStartup(application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnStartup
        ' Register related events
        AddHandler application.ControlledApplication.DocumentPrinted, AddressOf AppDocumentPrinted
        Return Result.Succeeded
    End Function

    ' <summary>
    ' Implement this method to unregister the subscribed events when Revit exits.
    ' </summary>
    Public Function OnShutdown(application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnShutdown
        ' unregister events
        RemoveHandler application.ControlledApplication.DocumentPrinted, AddressOf AppDocumentPrinted
        Return Result.Succeeded
    End Function
    ' <TrivialCode>
    ' Code ID: 501
    ' For DocumentPrinted class description
    ' </TrivialCode>

    ' <summary>
    ' Handler method for DocumentPrinted event, it will display some event arguments.
    ' </summary>
    Public Sub AppDocumentPrinted(sender As Object, args As Autodesk.Revit.DB.Events.DocumentPrintedEventArgs)
        Dim info As New StringBuilder()
        Dim app As Application = TryCast(sender, Application)
        info.AppendLine("DocumentPrintedEventArgs Parameters ------>")
        info.AppendLine("    Event Status      : " & args.Status.ToString())
        info.AppendLine("    Event Cancellable : " & Convert.ToString(args.Cancellable))
        '
        ' PrintedViews
        If 0 = args.GetFailedViewElementIds().Count OrElse 0 = args.GetPrintedViewElementIds().Count Then
            info.AppendLine("    Views been printed: <null>")
        Else
            info.AppendLine("    Views been printed: ")
            DumpViewsInfo(app, args.GetPrintedViewElementIds(), "      ", info)
        End If
        '
        ' FailedViews
        If 0 = args.GetFailedViewElementIds().Count Then
            info.AppendLine("    Views failed: <null>")
        Else
            info.AppendLine("    Views Failed : ")
            DumpViewsInfo(app, args.GetFailedViewElementIds(), "      ", info)
        End If

        TaskDialog.Show("Revit", info.ToString())
    End Sub

    ' <summary>
    ' Dump information of views: ViewType, Id and ViewName.
    ' </summary>
    ' <param name="views">Views to be displayed in message box.</param>
    ' <param name="prefix">Prefix mark for each line added to message box.</param>
    ' <param name="info">String where data is stored for display</param>
    Private Shared Sub DumpViewsInfo(app As Application, viewIds As System.Collections.Generic.IList(Of ElementId), prefix As [String], ByRef info As StringBuilder)
        Dim index As Integer = 0
        Dim uiApp As New UIApplication(app)
        For Each curViewId As ElementId In viewIds
            Dim curView As Autodesk.Revit.DB.View = TryCast(uiApp.ActiveUIDocument.Document.GetElement(curViewId), Autodesk.Revit.DB.View)
            DumpViewInfo(curView, [String].Format("{0}#{1}", prefix, System.Math.Max(System.Threading.Interlocked.Increment(index), index - 1)), info)
        Next
    End Sub

    ' <summary>
    ' Dump information of single view: ViewType, Id and ViewName.
    ' </summary>
    ' <param name="view">View element to be displayed in message box.</param>
    ' <param name="prefix">Prefix mark for each line added to message box.</param>
    ' <param name="info">String where data is stored for display</param>
    Private Shared Sub DumpViewInfo(view As Autodesk.Revit.DB.View, prefix As [String], ByRef info As StringBuilder)
        info.AppendLine([String].Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}", prefix, view.Id.ToString(), view.Name, view.ViewType))
    End Sub
    ' </ExampleMethod>
End Class

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


DocumentPrinting Event

[image]

Revit 2024 API
Application..::..DocumentPrinting Event
Application Class Example See Also Send Feedback
Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2010

Syntax

C#
public event EventHandler<DocumentPrintingEventArgs> DocumentPrinting
Visual Basic
Public Event DocumentPrinting As EventHandler(Of DocumentPrintingEventArgs)
Visual C++
public:
 event EventHandler<DocumentPrintingEventArgs^>^ DocumentPrinting {
    void add (EventHandler<DocumentPrintingEventArgs^>^ value);
    void remove (EventHandler<DocumentPrintingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to print a view or ViewSet of the document.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is cancellable. To cancel it, call the 'Cancel()' method of event's argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for current document during this event:

  • All overloads of Autodesk.Revit.DB.Document.Export()
  • Autodesk::Revit::DB::Document::Print
  • Print()()()() and similar overloads.
  • SubmitPrint()()()() and similar overloads.
  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

After this event, for each view being printed, ViewPrinting and ViewPrinted events will be raised. Another event DocumentPrinted will be raised immediately after document printing is finished.

Examples

CopyC#
public class Application_DocumentPrinting : IExternalApplication
{
    /// <ExampleMethod>
    /// <summary>
    /// Implement the OnStartup method to register events when Revit starts.
    /// </summary>
    public Result OnStartup(UIControlledApplication application)
    {
        // Register related events
       application.ControlledApplication.DocumentPrinting += new EventHandler<Autodesk.Revit.DB.Events.DocumentPrintingEventArgs>(AppDocumentPrinting);
        return Result.Succeeded;
    }

    /// <summary>
    /// Implement this method to unregister the subscribed events when Revit exits.
    /// </summary>
    public Result OnShutdown(UIControlledApplication application)
    {
        // unregister events
       application.ControlledApplication.DocumentPrinting -= new EventHandler<Autodesk.Revit.DB.Events.DocumentPrintingEventArgs>(AppDocumentPrinting);
        return Result.Succeeded;
    }
    /// <TrivialCode>
    /// Code ID: 501
    /// For DocumentPrinting class description
    /// </TrivialCode>

    /// <summary>
    /// Handler method for DocumentPrinting event, it will display some event arguments.
    /// </summary>
    public void AppDocumentPrinting(object sender, Autodesk.Revit.DB.Events.DocumentPrintingEventArgs args)
    {
        StringBuilder info = new StringBuilder();
        info.AppendLine("DocumentPrintingEventArgs Parameters ------>");

        info.AppendLine("    Event Cancellable   : " + args.Cancellable);
        info.AppendLine("    Views to be printed : "); // Views
        Application app = sender as Application;
        DumpViewsInfo(app, args.GetViewElementIds(), "    ", ref info);

        TaskDialog.Show("Revit",info.ToString());
    }

    /// <summary>
    /// Dump information of views: ViewType, Id and ViewName.
    /// </summary>
    /// <param name="views">Views to be displayed in message box.</param>
    /// <param name="prefix">Prefix mark for each line added to message box.</param>
    /// <param name="info">String where data is stored for display</param>
    private static void DumpViewsInfo(Application app, System.Collections.Generic.IList<ElementId> viewIds, String prefix, ref StringBuilder info)
    {
        int index = 0;
        UIApplication uiApp = new UIApplication(app);
        foreach (ElementId curViewId in viewIds)
        {
            Autodesk.Revit.DB.View curView = uiApp.ActiveUIDocument.Document.GetElement(curViewId) as Autodesk.Revit.DB.View;
            DumpViewInfo(curView, String.Format("{0}#{1}", prefix, index++), ref info);
        }
    }

    /// <summary>
    /// Dump information of single view: ViewType, Id and ViewName.
    /// </summary>
    /// <param name="view">View element to be displayed in message box.</param>
    /// <param name="prefix">Prefix mark for each line sent to message box.</param>
    /// <param name="info">String where data is stored for display</param>
    private static void DumpViewInfo(Autodesk.Revit.DB.View view, String prefix, ref StringBuilder info)
    {
        info.AppendLine(String.Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}",
            prefix, view.Id.ToString(), view.Name, view.ViewType));
    }
    /// </ExampleMethod>
}
CopyVB.NET
Public Class Application_DocumentPrinting
    Implements IExternalApplication
    ' <ExampleMethod>
    ' <summary>
    ' Implement the OnStartup method to register events when Revit starts.
    ' </summary>
    Public Function OnStartup(application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnStartup
        ' Register related events
        AddHandler application.ControlledApplication.DocumentPrinting, AddressOf AppDocumentPrinting
        Return Result.Succeeded
    End Function

    ' <summary>
    ' Implement this method to unregister the subscribed events when Revit exits.
    ' </summary>
    Public Function OnShutdown(application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnShutdown
        ' unregister events
        RemoveHandler application.ControlledApplication.DocumentPrinting, AddressOf AppDocumentPrinting
        Return Result.Succeeded
    End Function
    ' <TrivialCode>
    ' Code ID: 501
    ' For DocumentPrinting class description
    ' </TrivialCode>

    ' <summary>
    ' Handler method for DocumentPrinting event, it will display some event arguments.
    ' </summary>
    Public Sub AppDocumentPrinting(sender As Object, args As Autodesk.Revit.DB.Events.DocumentPrintingEventArgs)
        Dim info As New StringBuilder()
        info.AppendLine("DocumentPrintingEventArgs Parameters ------>")

        info.AppendLine("    Event Cancellable   : " & Convert.ToString(args.Cancellable))
        info.AppendLine("    Views to be printed : ")
        ' Views
        Dim app As Application = TryCast(sender, Application)
        DumpViewsInfo(app, args.GetViewElementIds(), "    ", info)

        TaskDialog.Show("Revit", info.ToString())
    End Sub

    ' <summary>
    ' Dump information of views: ViewType, Id and ViewName.
    ' </summary>
    ' <param name="views">Views to be displayed in message box.</param>
    ' <param name="prefix">Prefix mark for each line added to message box.</param>
    ' <param name="info">String where data is stored for display</param>
    Private Shared Sub DumpViewsInfo(app As Application, viewIds As System.Collections.Generic.IList(Of ElementId), prefix As [String], ByRef info As StringBuilder)
        Dim index As Integer = 0
        Dim uiApp As New UIApplication(app)
        For Each curViewId As ElementId In viewIds
            Dim curView As Autodesk.Revit.DB.View = TryCast(uiApp.ActiveUIDocument.Document.GetElement(curViewId), Autodesk.Revit.DB.View)
            DumpViewInfo(curView, [String].Format("{0}#{1}", prefix, System.Math.Max(System.Threading.Interlocked.Increment(index), index - 1)), info)
        Next
    End Sub

    ' <summary>
    ' Dump information of single view: ViewType, Id and ViewName.
    ' </summary>
    ' <param name="view">View element to be displayed in message box.</param>
    ' <param name="prefix">Prefix mark for each line sent to message box.</param>
    ' <param name="info">String where data is stored for display</param>
    Private Shared Sub DumpViewInfo(view As Autodesk.Revit.DB.View, prefix As [String], ByRef info As StringBuilder)
        info.AppendLine([String].Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}", prefix, view.Id.ToString(), view.Name, view.ViewType))
    End Sub
    ' </ExampleMethod>
End Class

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


DocumentReloadedLatest Event

[image]

Revit 2024 API
Application..::..DocumentReloadedLatest Event
Application Class See Also Send Feedback
Subscribe to the DocumentReloadedLatestEventArgs event to be notified immediately after Revit has finished reloading a document with central model.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public event EventHandler<DocumentReloadedLatestEventArgs> DocumentReloadedLatest
Visual Basic
Public Event DocumentReloadedLatest As EventHandler(Of DocumentReloadedLatestEventArgs)
Visual C++
public:
 event EventHandler<DocumentReloadedLatestEventArgs^>^ DocumentReloadedLatest {
    void add (EventHandler<DocumentReloadedLatestEventArgs^>^ value);
    void remove (EventHandler<DocumentReloadedLatestEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished reloading latest changes from a central model. It is raised even when document reloading latest changes from a central model failed or was cancelled (during DocumentReloadingLatest event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event's argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of reloading latest changes from a central model has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


DocumentSaved Event

[image]

Revit 2024 API
Application..::..DocumentSaved Event
Application Class See Also Send Feedback
Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2010

Syntax

C#
public event EventHandler<DocumentSavedEventArgs> DocumentSaved
Visual Basic
Public Event DocumentSaved As EventHandler(Of DocumentSavedEventArgs)
Visual C++
public:
 event EventHandler<DocumentSavedEventArgs^>^ DocumentSaved {
    void add (EventHandler<DocumentSavedEventArgs^>^ value);
    void remove (EventHandler<DocumentSavedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished saving a document. Note that the first save of a newly created document will raise DocumentSavedAs rather than the DocumentSaved event. It is raised even when document saving failed or was cancelled (during DocumentSaving event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' property in event's argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of saving document has already been finished.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


DocumentSavedAs Event

[image]

Revit 2024 API
Application..::..DocumentSavedAs Event
Application Class See Also Send Feedback
Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2010

Syntax

C#
public event EventHandler<DocumentSavedAsEventArgs> DocumentSavedAs
Visual Basic
Public Event DocumentSavedAs As EventHandler(Of DocumentSavedAsEventArgs)
Visual C++
public:
 event EventHandler<DocumentSavedAsEventArgs^>^ DocumentSavedAs {
    void add (EventHandler<DocumentSavedAsEventArgs^>^ value);
    void remove (EventHandler<DocumentSavedAsEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished saving document with a new file name. Note that the first save of a newly created document will raise DocumentSavedAs rather than DocumentSaved event. It is raised even when document saving failed or was cancelled (during DocumentSavingAs event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' property in event's argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of saving document has already been finished.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


DocumentSaving Event

[image]

Revit 2024 API
Application..::..DocumentSaving Event
Application Class See Also Send Feedback
Subscribe to the DocumentSaving event to be notified when Revit is just about to save a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2010

Syntax

C#
public event EventHandler<DocumentSavingEventArgs> DocumentSaving
Visual Basic
Public Event DocumentSaving As EventHandler(Of DocumentSavingEventArgs)
Visual C++
public:
 event EventHandler<DocumentSavingEventArgs^>^ DocumentSaving {
    void add (EventHandler<DocumentSavingEventArgs^>^ value);
    void remove (EventHandler<DocumentSavingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to save the document. Note that the first save of a newly created document will raise DocumentSavingAs rather than the DocumentSaving event.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

This event is cancellable, except when it is raised during close of the application. Check the 'Cancellable' property of event's argument to see whether it is cancellable or not. When it is cancellable, call the 'Cancel()' method of event's argument to cancel it. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event DocumentSaved will be raised immediately after the document has been saved.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


DocumentSavingAs Event

[image]

Revit 2024 API
Application..::..DocumentSavingAs Event
Application Class Example See Also Send Feedback
Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2010

Syntax

C#
public event EventHandler<DocumentSavingAsEventArgs> DocumentSavingAs
Visual Basic
Public Event DocumentSavingAs As EventHandler(Of DocumentSavingAsEventArgs)
Visual C++
public:
 event EventHandler<DocumentSavingAsEventArgs^>^ DocumentSavingAs {
    void add (EventHandler<DocumentSavingAsEventArgs^>^ value);
    void remove (EventHandler<DocumentSavingAsEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to save the document with a new file name. Note that the first save of a newly created document will raise DocumentSavingAs rather than DocumentSaving event.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

This event is cancellable, except when it is raised during close of the application. Check the 'Cancellable' property of event's argument to see whether it is cancellable or not. When it is cancellable, call the 'Cancel()' method of event's argument to cancel it. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event DocumentSavedAs will be raised immediately after the document has been saved with a new file name.

Examples

CopyC#
public class DocumentSavingAs : IExternalApplication
{
    /// <ExampleMethod>
    /// <summary>
    /// This method subscribes to DocumentSavingAs event.
    /// </summary>
    public Result OnStartup(UIControlledApplication application)
    {
       application.ControlledApplication.DocumentSavingAs += new EventHandler<DocumentSavingAsEventArgs>(CheckProjectStatusInitial);
        return Result.Succeeded;
    }

    /// <summary>
    /// Implement OnShutdown method of IExternalApplication interface to unregister subscribed event
    /// </summary>
    public Result OnShutdown(UIControlledApplication application)
    {
        // unregister subscribed event
       application.ControlledApplication.DocumentSavingAs -= new EventHandler<DocumentSavingAsEventArgs>(CheckProjectStatusInitial);
        return Result.Succeeded;
    }

    /// <summary>
    /// Event handler method for DocumentSavingAs event. This method will check the "Project Status" value,
    /// if it is null or empty string cancel the save as process.
    /// </summary>
    /// <param name="sender">The source of the event.</param>
    /// <param name="args">Event arguments that contains the event data.</param>
    private void CheckProjectStatusInitial(Object sender, DocumentSavingAsEventArgs args)
    {
        Document doc = args.Document;
        ProjectInfo proInfo = doc.ProjectInformation;

        // Project information is only available for project document.
        if (null != proInfo)
        {
            if (string.IsNullOrEmpty(proInfo.Status))
            {
                // cancel the save as process.
                args.Cancel();
                TaskDialog.Show("Revit","Status project parameter is not set.  Save is aborted.");
            }
        }
    }
    /// </ExampleMethod>
}
CopyVB.NET
Public Class DocumentSavingAs
    Implements IExternalApplication
    ' <ExampleMethod>
    ' <summary>
    ' This method subscribes to DocumentSavingAs event.
    ' </summary>
    Public Function OnStartup(application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnStartup
        AddHandler application.ControlledApplication.DocumentSavingAs, AddressOf CheckProjectStatusInitial
        Return Result.Succeeded
    End Function

    ' <summary>
    ' Implement OnShutdown method of IExternalApplication interface to unregister subscribed event
    ' </summary>
    Public Function OnShutdown(application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnShutdown
        ' unregister subscribed event
        RemoveHandler application.ControlledApplication.DocumentSavingAs, AddressOf CheckProjectStatusInitial
        Return Result.Succeeded
    End Function

    ' <summary>
    ' Event handler method for DocumentSavingAs event. This method will check the "Project Status" value,
    ' if it is null or empty string cancel the save as process.
    ' </summary>
    ' <param name="sender">The source of the event.</param>
    ' <param name="args">Event arguments that contains the event data.</param>
    Private Sub CheckProjectStatusInitial(sender As [Object], args As DocumentSavingAsEventArgs)
        Dim doc As Document = args.Document
        Dim proInfo As ProjectInfo = doc.ProjectInformation

        ' Project information is only available for project document.
        If proInfo IsNot Nothing Then
            If String.IsNullOrEmpty(proInfo.Status) Then
                ' cancel the save as process.
                args.Cancel()
                TaskDialog.Show("Revit", "Status project parameter is not set.  Save is aborted.")
            End If
        End If
    End Sub
    ' </ExampleMethod>
End Class

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


DocumentSynchronizedWithCentral Event

[image]

Revit 2024 API
Application..::..DocumentSynchronizedWithCentral Event
Application Class See Also Send Feedback
Subscribe to the DocumentSynchronizedWithCentral event to be notified immediately after Revit has finished synchronizing a document with central model.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2010

Syntax

C#
public event EventHandler<DocumentSynchronizedWithCentralEventArgs> DocumentSynchronizedWithCentral
Visual Basic
Public Event DocumentSynchronizedWithCentral As EventHandler(Of DocumentSynchronizedWithCentralEventArgs)
Visual C++
public:
 event EventHandler<DocumentSynchronizedWithCentralEventArgs^>^ DocumentSynchronizedWithCentral {
    void add (EventHandler<DocumentSynchronizedWithCentralEventArgs^>^ value);
    void remove (EventHandler<DocumentSynchronizedWithCentralEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished synchronizing a document with central model. It is raised even when document synchronizing with central model failed or was cancelled (during DocumentSynchronizingWithCentral event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event's argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of synchronizing a document with central model has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


DocumentSynchronizingWithCentral Event

[image]

Revit 2024 API
Application..::..DocumentSynchronizingWithCentral Event
Application Class See Also Send Feedback
Subscribe to the DocumentSynchronizingWithCentral event to be notified when Revit is just about to synchronize a document with central model.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2010

Syntax

C#
public event EventHandler<DocumentSynchronizingWithCentralEventArgs> DocumentSynchronizingWithCentral
Visual Basic
Public Event DocumentSynchronizingWithCentral As EventHandler(Of DocumentSynchronizingWithCentralEventArgs)
Visual C++
public:
 event EventHandler<DocumentSynchronizingWithCentralEventArgs^>^ DocumentSynchronizingWithCentral {
    void add (EventHandler<DocumentSynchronizingWithCentralEventArgs^>^ value);
    void remove (EventHandler<DocumentSynchronizingWithCentralEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to synchronize a document with central model.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is cancellable. To cancel it, call the 'Cancel()' method in event's argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another DocumentSynchronizedWithCentral event will be raised immediately after document synchronizing with central model is finished.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


DocumentWorksharingEnabled Event

[image]

Revit 2024 API
Application..::..DocumentWorksharingEnabled Event
Application Class See Also Send Feedback
Subscribe to the DocumentWorksharingEnabled event to be notified when a document has become workshared.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public event EventHandler<DocumentWorksharingEnabledEventArgs> DocumentWorksharingEnabled
Visual Basic
Public Event DocumentWorksharingEnabled As EventHandler(Of DocumentWorksharingEnabledEventArgs)
Visual C++
public:
 event EventHandler<DocumentWorksharingEnabledEventArgs^>^ DocumentWorksharingEnabled {
    void add (EventHandler<DocumentWorksharingEnabledEventArgs^>^ value);
    void remove (EventHandler<DocumentWorksharingEnabledEventArgs^>^ value);
}

Remarks

This event is raised when Revit has just enabled worksharing in the document.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


ElementTypeDuplicated Event

[image]

Revit 2024 API
Application..::..ElementTypeDuplicated Event
Application Class See Also Send Feedback
Subscribe to the ElementTypeDuplicated event to be notified immediately after Revit has finished duplicating an element type.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public event EventHandler<ElementTypeDuplicatedEventArgs> ElementTypeDuplicated
Visual Basic
Public Event ElementTypeDuplicated As EventHandler(Of ElementTypeDuplicatedEventArgs)
Visual C++
public:
 event EventHandler<ElementTypeDuplicatedEventArgs^>^ ElementTypeDuplicated {
    void add (EventHandler<ElementTypeDuplicatedEventArgs^>^ value);
    void remove (EventHandler<ElementTypeDuplicatedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished duplicating an element type. It is raised even when duplicating an element type failed or was cancelled (during ElementTypeDuplicating event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in the event's argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of duplicating an element type has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


FailuresProcessing Event

[image]

Revit 2024 API
Application..::..FailuresProcessing Event
Application Class Example See Also Send Feedback
Subscribe to the FailuresProcessing event to be notified when failures are being processed at the end of transaction.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public event EventHandler<FailuresProcessingEventArgs> FailuresProcessing
Visual Basic
Public Event FailuresProcessing As EventHandler(Of FailuresProcessingEventArgs)
Visual C++
public:
 event EventHandler<FailuresProcessingEventArgs^>^ FailuresProcessing {
    void add (EventHandler<FailuresProcessingEventArgs^>^ value);
    void remove (EventHandler<FailuresProcessingEventArgs^>^ value);
}

Remarks

This event is raised when failures are being processed during transaction commit or rollback operations. Handlers of this event have a limited ability to modify the document and/or failures in it, using the provided restricted failures accessor interface.

The event arguments provide access to the FailuresAccessor via [!:Autodesk::Revit::DB::FailuresProcessingEventArgs::GetFailuresAccessor()] which contains the details of the errors and/or warnings that caused the event to trigger.

The arguments also allow you to set a processing result via [!:Autodesk::Revit::DB::FailuresProcessingEventArgs::SetProcessingResult()]. The processing result determines if Revit will attempt to recommit the currently failing transaction, roll it back, or continue. If you are explicitly dismissing warnings from the event callback, a processing result of Continue is sufficient. But if you are explicitly resolving errors from the event callback, you must change the processing result to ProceedWithCommit to ensure that the user is not shown the dismissed errors. If you wish to cancel the transaction silently without showing the errors to the user, set the processing result to ProceedWithRollback, however you must also call SetClearAfterRollback(Boolean) in order to dismiss the errors and silently cancel the transaction.

Examples

CopyC#
[Autodesk.Revit.Attributes.Transaction(Autodesk.Revit.Attributes.TransactionMode.Manual)]

 public class NoUnenclosedRoomWarnings : IExternalApplication
 {
     static AddInId m_appId = new AddInId(new Guid("EB296268-8364-4d25-96E6-F664C608503C"));

     public Result OnStartup(UIControlledApplication application)
     {
         //Create an API application that subscribes to FailuresProcessing event for the lifetime of the session.
         application.ControlledApplication.FailuresProcessing += new EventHandler<FailuresProcessingEventArgs>(CheckWarnings);
         return Result.Succeeded;
     }

     public Result OnShutdown(UIControlledApplication application)
     {
         return Result.Succeeded;
     }

     private void CheckWarnings(object sender, FailuresProcessingEventArgs e)
     {
         FailuresAccessor fa = e.GetFailuresAccessor();
         IList<FailureMessageAccessor> failList = new List<FailureMessageAccessor>();
         failList = fa.GetFailureMessages(); // Inside event handler, get all warnings
         foreach (FailureMessageAccessor failure in failList)
         {
             // check FailureDefinitionIds against ones that you want to dismiss,
             FailureDefinitionId failID = failure.GetFailureDefinitionId();
             // prevent Revit from showing Unenclosed room warnings
             if (failID == BuiltInFailures.RoomFailures.RoomNotEnclosed)
             {
                 fa.DeleteWarning(failure);
             }
         }
     }
 }
CopyVB.NET
<Autodesk.Revit.Attributes.Transaction(Autodesk.Revit.Attributes.TransactionMode.Manual)> _
Public Class NoUnenclosedRoomWarnings
    Implements IExternalApplication
    Shared m_appId As New AddInId(New Guid("EB296268-8364-4d25-96E6-F664C608503C"))

    Public Function OnStartup(application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnStartup
        'Create an API application that subscribes to FailuresProcessing event for the lifetime of the session.
        AddHandler application.ControlledApplication.FailuresProcessing, AddressOf CheckWarnings
        Return Result.Succeeded
    End Function

    Public Function OnShutdown(application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnShutdown
        Return Result.Succeeded
    End Function

    Private Sub CheckWarnings(sender As Object, e As FailuresProcessingEventArgs)
        Dim fa As FailuresAccessor = e.GetFailuresAccessor()
        Dim failList As IList(Of FailureMessageAccessor) = New List(Of FailureMessageAccessor)()
        failList = fa.GetFailureMessages()
        ' Inside event handler, get all warnings
        For Each failure As FailureMessageAccessor In failList
            ' check FailureDefinitionIds against ones that you want to dismiss,
            Dim failID As FailureDefinitionId = failure.GetFailureDefinitionId()
            ' prevent Revit from showing Unenclosed room warnings
            If failID = BuiltInFailures.RoomFailures.RoomNotEnclosed Then
                fa.DeleteWarning(failure)
            End If
        Next
    End Sub
End Class

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


FamilyLoadedIntoDocument Event

[image]

Revit 2024 API
Application..::..FamilyLoadedIntoDocument Event
Application Class See Also Send Feedback
Subscribe to the FamilyLoadedInto event to be notified after Revit loaded a family into a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public event EventHandler<FamilyLoadedIntoDocumentEventArgs> FamilyLoadedIntoDocument
Visual Basic
Public Event FamilyLoadedIntoDocument As EventHandler(Of FamilyLoadedIntoDocumentEventArgs)
Visual C++
public:
 event EventHandler<FamilyLoadedIntoDocumentEventArgs^>^ FamilyLoadedIntoDocument {
    void add (EventHandler<FamilyLoadedIntoDocumentEventArgs^>^ value);
    void remove (EventHandler<FamilyLoadedIntoDocumentEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished loading a family into a document. It is raised even when family loading failed or was cancelled (during FamilyLoadingIntoDocument event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event's argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of importing has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


FileExported Event

[image]

Revit 2024 API
Application..::..FileExported Event
Application Class See Also Send Feedback
Subscribe to the FileExported event to be notified immediately after Revit has finished exporting files of formats supported by the API.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2010

Syntax

C#
public event EventHandler<FileExportedEventArgs> FileExported
Visual Basic
Public Event FileExported As EventHandler(Of FileExportedEventArgs)
Visual C++
public:
 event EventHandler<FileExportedEventArgs^>^ FileExported {
    void add (EventHandler<FileExportedEventArgs^>^ value);
    void remove (EventHandler<FileExportedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished exporting files of formats supported by the API. It is raised even when file exporting failed or was cancelled (during FileExporting event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event's argument to see whether the action itself was successful or not. If export is a part of 'Publish to Buzzsaw' command which consists of two parts â€“ export of a document followed by publishing it to a BuzzSaw server, the event status only reflects the result of the Export action. The publishing part of the command could still be cancelled or could fail after FileExported event is raised.

This event is not cancellable, for the process of exporting file has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


FileImporting Event

[image]

Revit 2024 API
Application..::..FileImporting Event
Application Class See Also Send Feedback
Subscribe to the FileImporting event to be notified when Revit is just about to import a file of format supported by the API.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2010

Syntax

C#
public event EventHandler<FileImportingEventArgs> FileImporting
Visual Basic
Public Event FileImporting As EventHandler(Of FileImportingEventArgs)
Visual C++
public:
 event EventHandler<FileImportingEventArgs^>^ FileImporting {
    void add (EventHandler<FileImportingEventArgs^>^ value);
    void remove (EventHandler<FileImportingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to import a file of format supported by the API.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is cancellable. To cancel it, call the 'Cancel()' method in event's argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • All overloads of Autodesk.Revit.DB.Document.Import()
  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another FileImported event will be raised immediately after file importing is finished.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


LinkedResourceOpened Event

[image]

Revit 2024 API
Application..::..LinkedResourceOpened Event
Application Class See Also Send Feedback
Subscribe to the LinkedResourceOpened event to be notified immediately after Revit has finished opening a linked resource.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public event EventHandler<LinkedResourceOpenedEventArgs> LinkedResourceOpened
Visual Basic
Public Event LinkedResourceOpened As EventHandler(Of LinkedResourceOpenedEventArgs)
Visual C++
public:
 event EventHandler<LinkedResourceOpenedEventArgs^>^ LinkedResourceOpened {
    void add (EventHandler<LinkedResourceOpenedEventArgs^>^ value);
    void remove (EventHandler<LinkedResourceOpenedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished opening a linked resource. Only supports linked resources for following types : Revit; IFC; CAD(dwg, dxf, dgn, sat); Topography; It is raised even when a linked resource opening failed. The LinkedResourceOpened events would not raised if there are no update on linked CAD, IFC resources.

Check the 'Status' field in event's argument to see whether the action itself was successful or not.

Another LinkedResourceOpening event will be raised when Revit is just about to open a linked resource.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


LinkedResourceOpening Event

[image]

Revit 2024 API
Application..::..LinkedResourceOpening Event
Application Class See Also Send Feedback
Subscribe to the LinkedResourceOpening event to be notified when Revit is just about to open a linked resource.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public event EventHandler<LinkedResourceOpeningEventArgs> LinkedResourceOpening
Visual Basic
Public Event LinkedResourceOpening As EventHandler(Of LinkedResourceOpeningEventArgs)
Visual C++
public:
 event EventHandler<LinkedResourceOpeningEventArgs^>^ LinkedResourceOpening {
    void add (EventHandler<LinkedResourceOpeningEventArgs^>^ value);
    void remove (EventHandler<LinkedResourceOpeningEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to open a linked resource. Only supports linked resources for following types : Revit; IFC; CAD(dwg, dxf, dgn, sat); This event would not be raised if there are no update on linked CAD, IFC resources.

Event is not cancellable.

The linked resource cannot be modified, for it is not opened yet at the time of the event.

Another LinkedResourceOpened event will be raised immediately after linked resource is opened.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


ViewExported Event

[image]

Revit 2024 API
Application..::..ViewExported Event
Application Class See Also Send Feedback
Subscribe to the ViewExported event to be notified immediately after Revit has finished exporting a view of the document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public event EventHandler<ViewExportedEventArgs> ViewExported
Visual Basic
Public Event ViewExported As EventHandler(Of ViewExportedEventArgs)
Visual C++
public:
 event EventHandler<ViewExportedEventArgs^>^ ViewExported {
    void add (EventHandler<ViewExportedEventArgs^>^ value);
    void remove (EventHandler<ViewExportedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished exporting a view of the document. It is raised only during accelerated export jobs, in which views are exported in parallel using a background process. Accelerated export only occurs when exporting to DWF formats and not combining views into a single file.

It is raised even when view exporting failed.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event's argument to see whether the action was successful or not.

This event is not cancellable, for the process of view exporting has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


ViewExporting Event

[image]

Revit 2024 API
Application..::..ViewExporting Event
Application Class See Also Send Feedback
Subscribe to the ViewExporting event to be notified when Revit is just about to export a view of the document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public event EventHandler<ViewExportingEventArgs> ViewExporting
Visual Basic
Public Event ViewExporting As EventHandler(Of ViewExportingEventArgs)
Visual C++
public:
 event EventHandler<ViewExportingEventArgs^>^ ViewExporting {
    void add (EventHandler<ViewExportingEventArgs^>^ value);
    void remove (EventHandler<ViewExportingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to export a view of the document. It is raised only during accelerated export jobs, in which views are exported in parallel using a background process. Accelerated export only occurs when exporting to DWF formats and not combining views into a single file.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is not cancellable. The 'Cancellable' property of event's argument is always False.

The following API functions are not available for the current document during this event:

  • All overloads of Autodesk.Revit.DB.Document.Export()
  • Autodesk.Revit.DB.Document.Print()
  • Print()()()() and similar overloads.
  • SubmitPrint()()()() and similar overloads.
  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event ViewExported will be raised immediately after view exporting is finished.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


ViewPrinted Event

[image]

Revit 2024 API
Application..::..ViewPrinted Event
Application Class Example See Also Send Feedback
Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2010

Syntax

C#
public event EventHandler<ViewPrintedEventArgs> ViewPrinted
Visual Basic
Public Event ViewPrinted As EventHandler(Of ViewPrintedEventArgs)
Visual C++
public:
 event EventHandler<ViewPrintedEventArgs^>^ ViewPrinted {
    void add (EventHandler<ViewPrintedEventArgs^>^ value);
    void remove (EventHandler<ViewPrintedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished printing a view of the document. If multiple views are combined to a single file, this event will be raised only once. It is raised even when view printing failed.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event's argument to see whether the action was successful or not.

This event is not cancellable, for the process of view printing has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Examples

CopyC#
public class Application_ViewPrinted : IExternalApplication
{
    /// <ExampleMethod>
    /// <summary>
    /// Implement the OnStartup method to register events when Revit starts.
    /// </summary>
    public Result OnStartup(UIControlledApplication application)
    {
        // Register related events
        application.ControlledApplication.ViewPrinted += new EventHandler<Autodesk.Revit.DB.Events.ViewPrintedEventArgs>(AppViewPrinted);
        return Result.Succeeded;
    }

    /// <summary>
    /// Implement this method to unregister the subscribed events when Revit exits.
    /// </summary>
    public Result OnShutdown(UIControlledApplication application)
    {
        // unregister events
       application.ControlledApplication.ViewPrinted -= new EventHandler<Autodesk.Revit.DB.Events.ViewPrintedEventArgs>(AppViewPrinted);
        return Result.Succeeded;
    }
    /// <TrivialCode>
    /// Code ID: 501
    /// For ViewPrinted class description
    /// </TrivialCode>

    /// <summary>
    /// Handler method for ViewPrinting event, it will dump some event arguments.
    /// </summary>
    public void AppViewPrinted(object sender, Autodesk.Revit.DB.Events.ViewPrintedEventArgs args)
    {
        StringBuilder info = new StringBuilder();
        info.AppendLine("ViewPrintedEventArgs Parameters ------>");
        info.AppendLine("    Event Status        : " + args.Status);
        info.AppendLine("    TotalViews          : " + args.TotalViews);
        info.AppendLine("    View Index          : " + args.Index);
        info.AppendLine("    View Information    :");
        DumpViewInfo(args.View, "      ", ref info);

        TaskDialog.Show("Revit",info.ToString());
    }

    /// <summary>
    /// Dump information of single view: ViewType, Id and ViewName.
    /// </summary>
    /// <param name="view">View element to be displayed in message box.</param>
    /// <param name="prefix">Prefix mark for each line added to message box string.</param>
    /// <param name="info">String where data is stored for display</param>
    private static void DumpViewInfo(Autodesk.Revit.DB.View view, String prefix, ref StringBuilder info)
    {
        info.AppendLine(String.Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}",
            prefix, view.Id.ToString(), view.Name, view.ViewType));
    }
    /// </ExampleMethod>
}
CopyVB.NET
Public Class Application_ViewPrinted
    Implements IExternalApplication
    ' <ExampleMethod>
    ' <summary>
    ' Implement the OnStartup method to register events when Revit starts.
    ' </summary>
    Public Function OnStartup(application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnStartup
        ' Register related events
        AddHandler application.ControlledApplication.ViewPrinted, AddressOf AppViewPrinted
        Return Result.Succeeded
    End Function

    ' <summary>
    ' Implement this method to unregister the subscribed events when Revit exits.
    ' </summary>
    Public Function OnShutdown(application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnShutdown
        ' unregister events
        RemoveHandler application.ControlledApplication.ViewPrinted, AddressOf AppViewPrinted
        Return Result.Succeeded
    End Function
    ' <TrivialCode>
    ' Code ID: 501
    ' For ViewPrinted class description
    ' </TrivialCode>

    ' <summary>
    ' Handler method for ViewPrinting event, it will dump some event arguments.
    ' </summary>
    Public Sub AppViewPrinted(sender As Object, args As Autodesk.Revit.DB.Events.ViewPrintedEventArgs)
        Dim info As New StringBuilder()
        info.AppendLine("ViewPrintedEventArgs Parameters ------>")
        info.AppendLine("    Event Status        : " & Convert.ToString(args.Status))
        info.AppendLine("    TotalViews          : " & Convert.ToString(args.TotalViews))
        info.AppendLine("    View Index          : " & Convert.ToString(args.Index))
        info.AppendLine("    View Information    :")
        DumpViewInfo(args.View, "      ", info)

        TaskDialog.Show("Revit", info.ToString())
    End Sub

    ' <summary>
    ' Dump information of single view: ViewType, Id and ViewName.
    ' </summary>
    ' <param name="view">View element to be displayed in message box.</param>
    ' <param name="prefix">Prefix mark for each line added to message box string.</param>
    ' <param name="info">String where data is stored for display</param>
    Private Shared Sub DumpViewInfo(view As Autodesk.Revit.DB.View, prefix As [String], ByRef info As StringBuilder)
        info.AppendLine([String].Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}", prefix, view.Id.ToString(), view.Name, view.ViewType))
    End Sub
    ' </ExampleMethod>
End Class

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


ViewPrinting Event

[image]

Revit 2024 API
Application..::..ViewPrinting Event
Application Class Example See Also Send Feedback
Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2010

Syntax

C#
public event EventHandler<ViewPrintingEventArgs> ViewPrinting
Visual Basic
Public Event ViewPrinting As EventHandler(Of ViewPrintingEventArgs)
Visual C++
public:
 event EventHandler<ViewPrintingEventArgs^>^ ViewPrinting {
    void add (EventHandler<ViewPrintingEventArgs^>^ value);
    void remove (EventHandler<ViewPrintingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to print a view of the document. If multiple views are combined to a single file, this event will be raised only once.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is not cancellable. The 'Cancellable' property of event's argument is always False.

The following API functions are not available for the current document during this event:

  • All overloads of Autodesk.Revit.DB.Document.Export()
  • Autodesk.Revit.DB.Document.Print()
  • Print()()()() and similar overloads.
  • SubmitPrint()()()() and similar overloads.
  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event ViewPrinted will be raised immediately after view printing is finished.

Examples

CopyC#
public class Application_ViewPrinting : IExternalApplication
{
    /// <ExampleMethod>
    /// <summary>
    /// Implement the OnStartup method to register events when Revit starts.
    /// </summary>
    public Result OnStartup(UIControlledApplication application)
    {
        // Register related events
       application.ControlledApplication.ViewPrinting += new EventHandler<Autodesk.Revit.DB.Events.ViewPrintingEventArgs>(AppViewPrinting);
        return Result.Succeeded;
    }

    /// <summary>
    /// Implement this method to unregister the subscribed events when Revit exits.
    /// </summary>
    public Result OnShutdown(UIControlledApplication application)
    {
        // unregister events
       application.ControlledApplication.ViewPrinting -= new EventHandler<Autodesk.Revit.DB.Events.ViewPrintingEventArgs>(AppViewPrinting);
        return Result.Succeeded;
    }
    /// <TrivialCode>
    /// Code ID: 501
    /// For ViewPrinting class description
    /// </TrivialCode>

    /// <summary>
    /// Handler method for ViewPrinting event, it will display some event arguments.
    /// </summary>
    public void AppViewPrinting(object sender, Autodesk.Revit.DB.Events.ViewPrintingEventArgs args)
    {
        StringBuilder info = new StringBuilder();
        info.AppendLine("ViewPrintingEventArgs Parameters ------>");
        info.AppendLine("    Event Cancellable   : " + args.Cancellable);
        info.AppendLine("    TotalViews          : " + args.TotalViews);
        info.AppendLine("    View Index          : " + args.Index);
        info.AppendLine("    View Information    :"); // View
        DumpViewInfo(args.View, "      ", ref info);

        TaskDialog.Show("Revit",info.ToString());
    }

    /// <summary>
    /// Dump information of single view: ViewType, Id and ViewName.
    /// </summary>
    /// <param name="view">View element to be displayed in message box.</param>
    /// <param name="prefix">Prefix mark for each line added to message box string.</param>
    /// <param name="info">String where data is stored for display</param>
    private static void DumpViewInfo(Autodesk.Revit.DB.View view, String prefix, ref StringBuilder info)
    {
        info.AppendLine(String.Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}",
            prefix, view.Id.ToString(), view.Name, view.ViewType));
    }
    /// </ExampleMethod>
}
CopyVB.NET
Public Class Application_ViewPrinting
    Implements IExternalApplication
    ' <ExampleMethod>
    ' <summary>
    ' Implement the OnStartup method to register events when Revit starts.
    ' </summary>
    Public Function OnStartup(application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnStartup
        ' Register related events
        AddHandler application.ControlledApplication.ViewPrinting, AddressOf AppViewPrinting
        Return Result.Succeeded
    End Function

    ' <summary>
    ' Implement this method to unregister the subscribed events when Revit exits.
    ' </summary>
    Public Function OnShutdown(application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnShutdown
        ' unregister events
        RemoveHandler application.ControlledApplication.ViewPrinting, AddressOf AppViewPrinting
        Return Result.Succeeded
    End Function
    ' <TrivialCode>
    ' Code ID: 501
    ' For ViewPrinting class description
    ' </TrivialCode>

    ' <summary>
    ' Handler method for ViewPrinting event, it will display some event arguments.
    ' </summary>
    Public Sub AppViewPrinting(sender As Object, args As Autodesk.Revit.DB.Events.ViewPrintingEventArgs)
        Dim info As New StringBuilder()
        info.AppendLine("ViewPrintingEventArgs Parameters ------>")
        info.AppendLine("    Event Cancellable   : " & Convert.ToString(args.Cancellable))
        info.AppendLine("    TotalViews          : " & Convert.ToString(args.TotalViews))
        info.AppendLine("    View Index          : " & Convert.ToString(args.Index))
        info.AppendLine("    View Information    :")
        ' View
        DumpViewInfo(args.View, "      ", info)

        TaskDialog.Show("Revit", info.ToString())
    End Sub

    ' <summary>
    ' Dump information of single view: ViewType, Id and ViewName.
    ' </summary>
    ' <param name="view">View element to be displayed in message box.</param>
    ' <param name="prefix">Prefix mark for each line added to message box string.</param>
    ' <param name="info">String where data is stored for display</param>
    Private Shared Sub DumpViewInfo(view As Autodesk.Revit.DB.View, prefix As [String], ByRef info As StringBuilder)
        info.AppendLine([String].Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}", prefix, view.Id.ToString(), view.Name, view.ViewType))
    End Sub
    ' </ExampleMethod>
End Class

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


ViewsExportedByContext Event

[image]

Revit 2024 API
Application..::..ViewsExportedByContext Event
Application Class See Also Send Feedback
Subscribe to the ViewsExportedByContext event to be notified immediately after Revit has finished exporting one or more views of the document via an export context by CustomExporter.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public event EventHandler<ViewsExportedByContextEventArgs> ViewsExportedByContext
Visual Basic
Public Event ViewsExportedByContext As EventHandler(Of ViewsExportedByContextEventArgs)
Visual C++
public:
 event EventHandler<ViewsExportedByContextEventArgs^>^ ViewsExportedByContext {
    void add (EventHandler<ViewsExportedByContextEventArgs^>^ value);
    void remove (EventHandler<ViewsExportedByContextEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished exporting views of the document via an export context by CustomExporter.

It is raised even when view exporting via export context by CustomExporter failed.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event's argument to see whether the action was successful or not.

This event is not cancellable, for the process of view exporting by CustomExporter has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


ViewsExportingByContext Event

[image]

Revit 2024 API
Application..::..ViewsExportingByContext Event
Application Class See Also Send Feedback
Subscribe to the ViewsExportingByContext event to be notified when Revit is just about to export one or more views of the document via an export context by CustomExporter.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public event EventHandler<ViewsExportingByContextEventArgs> ViewsExportingByContext
Visual Basic
Public Event ViewsExportingByContext As EventHandler(Of ViewsExportingByContextEventArgs)
Visual C++
public:
 event EventHandler<ViewsExportingByContextEventArgs^>^ ViewsExportingByContext {
    void add (EventHandler<ViewsExportingByContextEventArgs^>^ value);
    void remove (EventHandler<ViewsExportingByContextEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to export views of the document via an export context by CustomExporter.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is cancellable. To cancel it, call the 'Cancel()' method in event's argument to True.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event ViewsExportedByContext will be raised immediately after view exporting by CustomExporter is finished.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


WorksharedOperationProgressChanged Event

[image]

Revit 2024 API
Application..::..WorksharedOperationProgressChanged Event
Application Class See Also Send Feedback
Subscribe to the WorksharedOperationProgressChanged to be notified when progress has changed during Collaboration for Revit's workshared operations: open model and synchronize with central.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update

Syntax

C#
public event EventHandler<WorksharedOperationProgressChangedEventArgs> WorksharedOperationProgressChanged
Visual Basic
Public Event WorksharedOperationProgressChanged As EventHandler(Of WorksharedOperationProgressChangedEventArgs)
Visual C++
public:
 event EventHandler<WorksharedOperationProgressChangedEventArgs^>^ WorksharedOperationProgressChanged {
    void add (EventHandler<WorksharedOperationProgressChangedEventArgs^>^ value);
    void remove (EventHandler<WorksharedOperationProgressChangedEventArgs^>^ value);
}

Remarks

This event is only supported for Collaboration for Revit and will not be raised for those operations occurring in local-worksharing and Revit Server workflow. Users may not change the document in the handler for this event. It is NOT recommended to do any time-consuming work when handling WorksharedOperationProgressChanged event. This can increase workshared operation time." Exception ModificationForbiddenException will be thrown if any document-modifying method is called during this event's handler.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication Class

[image]

Revit 2024 API
ControlledApplication Class
Members See Also Send Feedback
Represents the Autodesk Revit Application with no access to documents. It provides options and other application wide data and settings for external applications OnStartup/OnShutdown.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class ControlledApplication
Visual Basic
Public Class ControlledApplication
Visual C++
public ref class ControlledApplication

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.ApplicationServices..::..ControlledApplication

See Also

ControlledApplication Members
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication Members

[image] [image]

Revit 2024 API
ControlledApplication Members
ControlledApplication Class Methods Properties Events See Also Send Feedback

The ControlledApplication type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetFailureDefinitionRegistry | Returns the instance of FailureDefinitionRegistry.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLibraryPaths | Returns path information identifying where Revit searches for content.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsJournalPlaying | Determines if the application is currently in journal playback mode.
Public method | OpenSharedParameterFile | Enables access to shared parameter groups and definitions that are maintained on disk.
 | RegisterFailuresProcessor | Replaces Revit's default user interface (if present) with alternative handling for all warnings and errors (including those not generated by your application) for the rest of the Revit session; if your application is not prepared to respond to all warnings and errors, consider use of IFailuresPreprocessor (in your opened Transaction) or the FailuresProcessing event instead of this interface.
Public method | SetLibraryPaths | Sets path information identifying where Revit searches for content.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteJournalComment | Writes a comment to the Revit journal file.

Properties

 | Name | Description
Public property | ActiveAddInId | Retrieves the Id of the currently running external application.
Public property | AllUsersAddinsLocation | The folder location for .addin files for all users.
Public property | Cities | Returns a set of all the known city locations within Revit.
Public property | Create | Provides an object that can be used to create new instances of Autodesk Revit API objects.
Public property | CurrentUserAddinsLocation | The folder location for .addin files for the current user.
Public property | CurrentUsersAddinsDataFolderPath | Path to AddinsData folder for the current user.
Public property | CurrentUsersDataFolderPath | Path to data folder for the current user.
Public property | IsLateAddinLoading | Indicates whether this add-in is loaded on the fly or not. If it is loaded when is Revit starting up, it is false, otherwise it should be true.
Public property | Language | The language used in the current session of Revit.
Public property | Product | The product type for the current session of Revit.
Public property | RecordingJournalFilename | Retrieve the name of the journal file the Revit is currently recording to.
Public property | SharedParametersFilename | Contains the fully qualified path to a shared parameters file.
Public property | SubVersionNumber | The minor version number of Revit
Public property | VersionBuild | Returns the internal build number of the Autodesk Revit application.
Public property | VersionName | Returns the name of the Revit application.
Public property | VersionNumber | Return the primary version of the Revit application.

Events

 | Name | Description
Public event | ApplicationInitialized | Subscribe to this event to get notified after the Revit application has been initialized
Public event | DocumentChanged | Subscribe to the DocumentChanged event to be notified when Revit document has changed.
Public event | DocumentClosed | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
Public event | DocumentClosing | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
Public event | DocumentCreated | Subscribe to the DocumentCreated event to be notified immediately after Revit has finished creating a new document.
Public event | DocumentCreating | Subscribe to the DocumentCreating event to be notified when Revit is just about to create a new document.
Public event | DocumentOpened | Subscribe to the DocumentOpened event to be notified immediately after Revit has finished opening a document.
Public event | DocumentOpening | Subscribe to the DocumentOpening event to be notified when Revit is just about to open a document.
Public event | DocumentPrinted | Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.
Public event | DocumentPrinting | Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.
Public event | DocumentReloadedLatest | Subscribe to the DocumentReloadedLatestEventArgs event to be notified immediately after Revit has finished reloading a document with central model.
Public event | DocumentReloadingLatest | Subscribe to the DocumentReloadingLatestEventArgs event to be notified when Revit is just about to reload latest changes from a central model.
Public event | DocumentSaved | Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving a document.
Public event | DocumentSavedAs | Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.
Public event | DocumentSaving | Subscribe to the DocumentSaving event to be notified when Revit is just about to save a document.
Public event | DocumentSavingAs | Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.
Public event | DocumentSynchronizedWithCentral | Subscribe to the DocumentSynchronizedWithCentral event to be notified immediately after Revit has finished synchronizing a document with central model.
Public event | DocumentSynchronizingWithCentral | Subscribe to the DocumentSynchronizingWithCentral event to be notified when Revit is just about to synchronize a document with central model.
Public event | ElementTypeDuplicated | Subscribe to the ElementTypeDuplicated event to be notified immediately after Revit has finished duplicating an element type.
Public event | ElementTypeDuplicating | Subscribe to the ElementTypeDuplicating event to be notified when Revit is just about to duplicate an element type.
Public event | FailuresProcessing | Subscribe to the FailuresProcessing event to be notified when failures are being processed at the end of transaction.
Public event | FamilyLoadedIntoDocument | Subscribe to the FamilyLoadedInto event to be notified after Revit loaded a family into a document.
Public event | FamilyLoadingIntoDocument | Subscribe to the FamilyLoadingInto event to be notified when Revit is just about to load a family into a document.
Public event | FileExported | Subscribe to the FileExported event to be notified immediately after Revit has finished exporting files of formats supported by the API.
Public event | FileExporting | Subscribe to the FileExporting event to be notified when Revit is just about to export files of formats supported by the API.
Public event | FileImported | Subscribe to the FileImported event to be notified immediately after Revit has finished importing a file of format supported by the API.
Public event | FileImporting | Subscribe to the FileImporting event to be notified when Revit is just about to import a file of format supported by the API.
Public event | LinkedResourceOpened | Subscribe to the LinkedResourceOpened event to be notified immediately after Revit has finished opening a linked resource.
Public event | LinkedResourceOpening | Subscribe to the LinkedResourceOpening event to be notified when Revit is just about to open a linked resource.
Public event | ProgressChanged | Subscribe to the ProgressChanged event to be notified when an operation in Revit has progress bar data available.
Public event | ViewPrinted | Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.
Public event | ViewPrinting | Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.
Public event | WorksharedOperationProgressChanged | Subscribe to the WorksharedOperationProgressChanged to be notified when progress has changed during Collaboration for Revit's workshared operations: open model and synchronize with central.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication Methods

[image] [image]

Revit 2024 API
ControlledApplication Methods
ControlledApplication Class See Also Send Feedback

The ControlledApplication type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetFailureDefinitionRegistry | Returns the instance of FailureDefinitionRegistry.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLibraryPaths | Returns path information identifying where Revit searches for content.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsJournalPlaying | Determines if the application is currently in journal playback mode.
Public method | OpenSharedParameterFile | Enables access to shared parameter groups and definitions that are maintained on disk.
 | RegisterFailuresProcessor | Replaces Revit's default user interface (if present) with alternative handling for all warnings and errors (including those not generated by your application) for the rest of the Revit session; if your application is not prepared to respond to all warnings and errors, consider use of IFailuresPreprocessor (in your opened Transaction) or the FailuresProcessing event instead of this interface.
Public method | SetLibraryPaths | Sets path information identifying where Revit searches for content.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteJournalComment | Writes a comment to the Revit journal file.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


GetFailureDefinitionRegistry Method

[image]

Revit 2024 API
ControlledApplication..::..GetFailureDefinitionRegistry Method
ControlledApplication Class See Also Send Feedback
Returns the instance of FailureDefinitionRegistry.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static FailureDefinitionRegistry GetFailureDefinitionRegistry()
Visual Basic
Public Shared Function GetFailureDefinitionRegistry As FailureDefinitionRegistry
Visual C++
public:
static FailureDefinitionRegistry^ GetFailureDefinitionRegistry()

Return Value

The instance of FailureDefinitionRegistry.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


GetLibraryPaths Method

[image]

Revit 2024 API
ControlledApplication..::..GetLibraryPaths Method
ControlledApplication Class See Also Send Feedback
Returns path information identifying where Revit searches for content.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public IDictionary<string, string> GetLibraryPaths()
Visual Basic
Public Function GetLibraryPaths As IDictionary(Of String, String)
Visual C++
public:
IDictionary<String^, String^>^ GetLibraryPaths()

Return Value

The map of library paths.

Remarks

The map that is returned contains a key that is purpose of the path, such as Material Libraries and the value in the map is the fully qualified path that is used for that search path.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


OpenSharedParameterFile Method

[image]

Revit 2024 API
ControlledApplication..::..OpenSharedParameterFile Method
ControlledApplication Class See Also Send Feedback
Enables access to shared parameter groups and definitions that are maintained on disk.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public DefinitionFile OpenSharedParameterFile()
Visual Basic
Public Function OpenSharedParameterFile As DefinitionFile
Visual C++
public:
DefinitionFile^ OpenSharedParameterFile()

Return Value

An object that represents a shared parameters file that exists on disk. Returns nullNothingnullptra null reference (Nothing in Visual Basic) if the file does not exist.

Remarks

This function is used to return an object that represents a Revit shared parameters file Revit can use only one shared parameters file at one time. The filename for the shared parameters file can be set in the Application.SharedParametersFilename property.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


RegisterFailuresProcessor Method

[image]

Revit 2024 API
ControlledApplication..::..RegisterFailuresProcessor Method
ControlledApplication Class See Also Send Feedback
Replaces Revit's default user interface (if present) with alternative handling for all warnings and errors (including those not generated by your application) for the rest of the Revit session; if your application is not prepared to respond to all warnings and errors, consider use of IFailuresPreprocessor (in your opened Transaction) or the FailuresProcessing event instead of this interface.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static void RegisterFailuresProcessor(
    IFailuresProcessor processor
)
Visual Basic
Public Shared Sub RegisterFailuresProcessor ( _
    processor As IFailuresProcessor _
)
Visual C++
public:
static void RegisterFailuresProcessor(
    IFailuresProcessor^ processor
)

Parameters

processor
Type: Autodesk.Revit.DB..::..IFailuresProcessor
Instance of Failures Processor to be used by the Revit Application.

Remarks

If there is previously registered Failures Processor, it gets discarded. If you opt to register a FailuresProcessor for Revit, your processor will become the default error handler for all Revit errors for the session. The standard Revit error dialog will not appear.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


SetLibraryPaths Method

[image]

Revit 2024 API
ControlledApplication..::..SetLibraryPaths Method
ControlledApplication Class See Also Send Feedback
Sets path information identifying where Revit searches for content.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public void SetLibraryPaths(
    IDictionary<string, string> paths
)
Visual Basic
Public Sub SetLibraryPaths ( _
    paths As IDictionary(Of String, String) _
)
Visual C++
public:
void SetLibraryPaths(
    IDictionary<String^, String^>^ paths
)

Parameters

paths
Type: System.Collections.Generic..::..IDictionary<(Of <(<'String, String>)>)>
The map of library paths.

Remarks

The map that is returned should contain a key that is purpose of the path, such as Material Libraries and the value in the map is the fully qualified path to be used for that search path.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


WriteJournalComment Method

[image]

Revit 2024 API
ControlledApplication..::..WriteJournalComment Method
ControlledApplication Class See Also Send Feedback
Writes a comment to the Revit journal file.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public void WriteJournalComment(
    string comment,
    bool timeStamp
)
Visual Basic
Public Sub WriteJournalComment ( _
    comment As String, _
    timeStamp As Boolean _
)
Visual C++
public:
void WriteJournalComment(
    String^ comment,
    bool timeStamp
)

Parameters

comment
Type: System..::..String
Text for journal comment.
timeStamp
Type: System..::..Boolean
If a time stamp should be included in the journal comment.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication Properties

[image] [image]

Revit 2024 API
ControlledApplication Properties
ControlledApplication Class See Also Send Feedback

The ControlledApplication type exposes the following members.

Properties

 | Name | Description
Public property | ActiveAddInId | Retrieves the Id of the currently running external application.
Public property | AllUsersAddinsLocation | The folder location for .addin files for all users.
Public property | Cities | Returns a set of all the known city locations within Revit.
Public property | Create | Provides an object that can be used to create new instances of Autodesk Revit API objects.
Public property | CurrentUserAddinsLocation | The folder location for .addin files for the current user.
Public property | CurrentUsersAddinsDataFolderPath | Path to AddinsData folder for the current user.
Public property | CurrentUsersDataFolderPath | Path to data folder for the current user.
Public property | IsLateAddinLoading | Indicates whether this add-in is loaded on the fly or not. If it is loaded when is Revit starting up, it is false, otherwise it should be true.
Public property | Language | The language used in the current session of Revit.
Public property | Product | The product type for the current session of Revit.
Public property | RecordingJournalFilename | Retrieve the name of the journal file the Revit is currently recording to.
Public property | SharedParametersFilename | Contains the fully qualified path to a shared parameters file.
Public property | SubVersionNumber | The minor version number of Revit
Public property | VersionBuild | Returns the internal build number of the Autodesk Revit application.
Public property | VersionName | Returns the name of the Revit application.
Public property | VersionNumber | Return the primary version of the Revit application.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ActiveAddInId Property

[image]

Revit 2024 API
ControlledApplication..::..ActiveAddInId Property
ControlledApplication Class See Also Send Feedback
Retrieves the Id of the currently running external application.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public AddInId ActiveAddInId { get; }
Visual Basic
Public ReadOnly Property ActiveAddInId As AddInId
    Get
Visual C++
public:
property AddInId^ ActiveAddInId {
    AddInId^ get ();
}

Remarks

The application can be either a UI application, DB application, or an external command. If no addin is active, this property will return nullNothingnullptra null reference (Nothing in Visual Basic). If an event handler is currently being executed, the returned value will be the Id of the application or command in which the event handler was registered.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


AllUsersAddinsLocation Property

[image]

Revit 2024 API
ControlledApplication..::..AllUsersAddinsLocation Property
ControlledApplication Class See Also Send Feedback
The folder location for .addin files for all users.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public string AllUsersAddinsLocation { get; }
Visual Basic
Public ReadOnly Property AllUsersAddinsLocation As String
    Get
Visual C++
public:
property String^ AllUsersAddinsLocation {
    String^ get ();
}

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


Cities Property

[image]

Revit 2024 API
ControlledApplication..::..Cities Property
ControlledApplication Class See Also Send Feedback
Returns a set of all the known city locations within Revit.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CitySet Cities { get; }
Visual Basic
Public ReadOnly Property Cities As CitySet
    Get
Visual C++
public:
property CitySet^ Cities {
    CitySet^ get ();
}

Remarks

Each city has information about longitude, latitude etc.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


Create Property

[image]

Revit 2024 API
ControlledApplication..::..Create Property
ControlledApplication Class See Also Send Feedback
Provides an object that can be used to create new instances of Autodesk Revit API objects.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Application Create { get; }
Visual Basic
Public ReadOnly Property Create As Application
    Get
Visual C++
public:
property Application^ Create {
    Application^ get ();
}

Remarks

The Create property returns an object that is used to create application wide utility and geometric objects within the Autodesk Revit API, such as arrays, sets, lines. This object should be used when you wish to create an object within the Autodesk Revit application memory, rather than your own application's memory. If you are performing your own memory management techniques then it is advisable to create any utility objects via the Create object. For example: Instead of Dim set As New Autodesk_Revit_ElementSet do Set set = application.Create.NewElementSet()

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


CurrentUsersDataFolderPath Property

[image]

Revit 2024 API
ControlledApplication..::..CurrentUsersDataFolderPath Property
ControlledApplication Class See Also Send Feedback
Path to data folder for the current user.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public string CurrentUsersDataFolderPath { get; }
Visual Basic
Public ReadOnly Property CurrentUsersDataFolderPath As String
    Get
Visual C++
public:
property String^ CurrentUsersDataFolderPath {
    String^ get ();
}

Remarks

Similar to C:\Users\[UserName]\AppData\Roaming\Autodesk\[ProductType]\[ReleaseName]

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


Language Property

[image]

Revit 2024 API
ControlledApplication..::..Language Property
ControlledApplication Class See Also Send Feedback
The language used in the current session of Revit.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public LanguageType Language { get; }
Visual Basic
Public ReadOnly Property Language As LanguageType
    Get
Visual C++
public:
property LanguageType Language {
    LanguageType get ();
}

Remarks

Use this property to determine the language used by Revit; this can allow your application to load the appropriate resources.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


Product Property

[image]

Revit 2024 API
ControlledApplication..::..Product Property
ControlledApplication Class See Also Send Feedback
The product type for the current session of Revit.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ProductType Product { get; }
Visual Basic
Public ReadOnly Property Product As ProductType
    Get
Visual C++
public:
property ProductType Product {
    ProductType get ();
}

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


RecordingJournalFilename Property

[image]

Revit 2024 API
ControlledApplication..::..RecordingJournalFilename Property
ControlledApplication Class See Also Send Feedback
Retrieve the name of the journal file the Revit is currently recording to.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string RecordingJournalFilename { get; }
Visual Basic
Public ReadOnly Property RecordingJournalFilename As String
    Get
Visual C++
public:
property String^ RecordingJournalFilename {
    String^ get ();
}

Remarks

As Revit operates it keeps a log of operations that the user performs within a file, known as a journal file. These files provide information about the actions performed in a session and the state of Revit when a problem occurs. These files are included during error reporting to Autodesk.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


SharedParametersFilename Property

[image]

Revit 2024 API
ControlledApplication..::..SharedParametersFilename Property
ControlledApplication Class See Also Send Feedback
Contains the fully qualified path to a shared parameters file.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string SharedParametersFilename { get; set; }
Visual Basic
Public Property SharedParametersFilename As String
    Get
    Set
Visual C++
public:
property String^ SharedParametersFilename {
    String^ get ();
    void set (String^ value);
}

Remarks

This path can be read and set via this property. By default Autodesk Revit does not have a shared parameters file so this property must be set before access is made to the shared parameters file object otherwise an exception will be thrown.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


SubVersionNumber Property

[image]

Revit 2024 API
ControlledApplication..::..SubVersionNumber Property
ControlledApplication Class See Also Send Feedback
The minor version number of Revit

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public string SubVersionNumber { get; }
Visual Basic
Public ReadOnly Property SubVersionNumber As String
    Get
Visual C++
public:
property String^ SubVersionNumber {
    String^ get ();
}

Remarks

SubVersionNumber of Revit may have additional APIs and functionality not available in the standard customer releases. Add-ins written to support standard Revit releases should be compatible with SubVersionNumber releases, but add-ins written specifically targeting new features in SubVersionNumber releases would not be compatible with the standard releases.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


VersionBuild Property

[image]

Revit 2024 API
ControlledApplication..::..VersionBuild Property
ControlledApplication Class See Also Send Feedback
Returns the internal build number of the Autodesk Revit application.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string VersionBuild { get; }
Visual Basic
Public ReadOnly Property VersionBuild As String
    Get
Visual C++
public:
property String^ VersionBuild {
    String^ get ();
}

Remarks

This property can be used by your application to find the version of Autodesk Revit against which your application is running. Based on this information your application can report if it is able to work correctly with that version of Autodesk Revit.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


VersionName Property

[image]

Revit 2024 API
ControlledApplication..::..VersionName Property
ControlledApplication Class See Also Send Feedback
Returns the name of the Revit application.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string VersionName { get; }
Visual Basic
Public ReadOnly Property VersionName As String
    Get
Visual C++
public:
property String^ VersionName {
    String^ get ();
}

Remarks

This property can be used by your application to find the version of Revit against which your application is running. Based on this information your application can report if it is able to work correctly with that version of Revit.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


VersionNumber Property

[image]

Revit 2024 API
ControlledApplication..::..VersionNumber Property
ControlledApplication Class See Also Send Feedback
Return the primary version of the Revit application.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string VersionNumber { get; }
Visual Basic
Public ReadOnly Property VersionNumber As String
    Get
Visual C++
public:
property String^ VersionNumber {
    String^ get ();
}

Remarks

This property can be used by your application to find the version of Revit against which your application is running. Based on this information your application can report if it is able to work correctly with that version of Revit.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ApplicationInitialized Event

[image]

Revit 2024 API
ControlledApplication..::..ApplicationInitialized Event
ControlledApplication Class See Also Send Feedback
Subscribe to this event to get notified after the Revit application has been initialized

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public event EventHandler<ApplicationInitializedEventArgs> ApplicationInitialized
Visual Basic
Public Event ApplicationInitialized As EventHandler(Of ApplicationInitializedEventArgs)
Visual C++
public:
 event EventHandler<ApplicationInitializedEventArgs^>^ ApplicationInitialized {
    void add (EventHandler<ApplicationInitializedEventArgs^>^ value);
    void remove (EventHandler<ApplicationInitializedEventArgs^>^ value);
}

Remarks

The event is raised after Revit was launched as fully initialized, including initialization of external applications.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


DocumentClosed Event

[image]

Revit 2024 API
ControlledApplication..::..DocumentClosed Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2010

Syntax

C#
public event EventHandler<DocumentClosedEventArgs> DocumentClosed
Visual Basic
Public Event DocumentClosed As EventHandler(Of DocumentClosedEventArgs)
Visual C++
public:
 event EventHandler<DocumentClosedEventArgs^>^ DocumentClosed {
    void add (EventHandler<DocumentClosedEventArgs^>^ value);
    void remove (EventHandler<DocumentClosedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished closing a document. It is raised even when document closing failed or was cancelled (during DocumentClosing event).

This event is not cancellable, for the process of closing document has already been finished.

The document cannot be modified because the corresponding object does not exist anymore.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


DocumentClosing Event

[image]

Revit 2024 API
ControlledApplication..::..DocumentClosing Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2010

Syntax

C#
public event EventHandler<DocumentClosingEventArgs> DocumentClosing
Visual Basic
Public Event DocumentClosing As EventHandler(Of DocumentClosingEventArgs)
Visual C++
public:
 event EventHandler<DocumentClosingEventArgs^>^ DocumentClosing {
    void add (EventHandler<DocumentClosingEventArgs^>^ value);
    void remove (EventHandler<DocumentClosingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to close a document.

This event is cancellable, except when it is raised as part of application closing. Check the 'Cancellable' property of event's argument to see whether it is cancellable or not. When it is cancellable, call the 'Cancel()' method of event's argument to True to cancel it. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document may not be modified during this event.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

An DocumentClosed event will be raised immediately after document is closed.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


DocumentCreated Event

[image]

Revit 2024 API
ControlledApplication..::..DocumentCreated Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentCreated event to be notified immediately after Revit has finished creating a new document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2010

Syntax

C#
public event EventHandler<DocumentCreatedEventArgs> DocumentCreated
Visual Basic
Public Event DocumentCreated As EventHandler(Of DocumentCreatedEventArgs)
Visual C++
public:
 event EventHandler<DocumentCreatedEventArgs^>^ DocumentCreated {
    void add (EventHandler<DocumentCreatedEventArgs^>^ value);
    void remove (EventHandler<DocumentCreatedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished creating a new document. It is raised even when document creation failed or was cancelled (during DocumentCreating event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event's argument to see whether the action itself was successful or not. This event is not cancellable, for the process of document creation has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


DocumentCreating Event

[image]

Revit 2024 API
ControlledApplication..::..DocumentCreating Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentCreating event to be notified when Revit is just about to create a new document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2010

Syntax

C#
public event EventHandler<DocumentCreatingEventArgs> DocumentCreating
Visual Basic
Public Event DocumentCreating As EventHandler(Of DocumentCreatingEventArgs)
Visual C++
public:
 event EventHandler<DocumentCreatingEventArgs^>^ DocumentCreating {
    void add (EventHandler<DocumentCreatingEventArgs^>^ value);
    void remove (EventHandler<DocumentCreatingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to create a new document.

Event is cancellable. To cancel it, call the 'Cancel()' method of event's argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document cannot be modified, for it is not created yet at the time of the event.

The following API functions are not available for the current document during this event:

  • [!:Autodesk::Revit::ApplicationServices::Application::NewProjectDocument()]
  • NewFamilyDocument(String)
  • NewProjectTemplateDocument(String)
  • OpenDocumentFile(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another DocumentCreated event will be raised immediately after document creation is finished.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


DocumentOpened Event

[image]

Revit 2024 API
ControlledApplication..::..DocumentOpened Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentOpened event to be notified immediately after Revit has finished opening a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2010

Syntax

C#
public event EventHandler<DocumentOpenedEventArgs> DocumentOpened
Visual Basic
Public Event DocumentOpened As EventHandler(Of DocumentOpenedEventArgs)
Visual C++
public:
 event EventHandler<DocumentOpenedEventArgs^>^ DocumentOpened {
    void add (EventHandler<DocumentOpenedEventArgs^>^ value);
    void remove (EventHandler<DocumentOpenedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished opening a document. It is raised even when document opening failed or was cancelled (during DocumentOpening event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event's argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of opening document has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


DocumentOpening Event

[image]

Revit 2024 API
ControlledApplication..::..DocumentOpening Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentOpening event to be notified when Revit is just about to open a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2010

Syntax

C#
public event EventHandler<DocumentOpeningEventArgs> DocumentOpening
Visual Basic
Public Event DocumentOpening As EventHandler(Of DocumentOpeningEventArgs)
Visual C++
public:
 event EventHandler<DocumentOpeningEventArgs^>^ DocumentOpening {
    void add (EventHandler<DocumentOpeningEventArgs^>^ value);
    void remove (EventHandler<DocumentOpeningEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to open a document.

Event is cancellable. To cancel it, call the 'Cancel()' method in event's argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document cannot be modified, for it is not opened yet at the time of the event.

Another DocumentOpened event will be raised immediately after document is opened.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


DocumentPrinted Event

[image]

Revit 2024 API
ControlledApplication..::..DocumentPrinted Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2010

Syntax

C#
public event EventHandler<DocumentPrintedEventArgs> DocumentPrinted
Visual Basic
Public Event DocumentPrinted As EventHandler(Of DocumentPrintedEventArgs)
Visual C++
public:
 event EventHandler<DocumentPrintedEventArgs^>^ DocumentPrinted {
    void add (EventHandler<DocumentPrintedEventArgs^>^ value);
    void remove (EventHandler<DocumentPrintedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished printing a view or ViewSet of the document. It is raised even when document printing failed or was cancelled (during DocumentPriting event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event's argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of printing has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


DocumentPrinting Event

[image]

Revit 2024 API
ControlledApplication..::..DocumentPrinting Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2010

Syntax

C#
public event EventHandler<DocumentPrintingEventArgs> DocumentPrinting
Visual Basic
Public Event DocumentPrinting As EventHandler(Of DocumentPrintingEventArgs)
Visual C++
public:
 event EventHandler<DocumentPrintingEventArgs^>^ DocumentPrinting {
    void add (EventHandler<DocumentPrintingEventArgs^>^ value);
    void remove (EventHandler<DocumentPrintingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to print a view or ViewSet of the document.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is cancellable. To cancel it, call the 'Cancel()' method of event's argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for current document during this event:

  • All overloads of Autodesk.Revit.DB.Document.Export()
  • Autodesk::Revit::DB::Document::Print
  • Print()()()() and similar overloads.
  • SubmitPrint()()()() and similar overloads.
  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

After this event, for each view being printed, ViewPrinting and ViewPrinted events will be raised. Another event DocumentPrinted will be raised immediately after document printing is finished.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


DocumentReloadedLatest Event

[image]

Revit 2024 API
ControlledApplication..::..DocumentReloadedLatest Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentReloadedLatestEventArgs event to be notified immediately after Revit has finished reloading a document with central model.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public event EventHandler<DocumentReloadedLatestEventArgs> DocumentReloadedLatest
Visual Basic
Public Event DocumentReloadedLatest As EventHandler(Of DocumentReloadedLatestEventArgs)
Visual C++
public:
 event EventHandler<DocumentReloadedLatestEventArgs^>^ DocumentReloadedLatest {
    void add (EventHandler<DocumentReloadedLatestEventArgs^>^ value);
    void remove (EventHandler<DocumentReloadedLatestEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished reloading latest changes from a central model. It is raised even when document reloading latest changes from a central model failed or was cancelled (during DocumentReloadingLatest event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event's argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of reloading latest changes from a central model has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


DocumentReloadingLatest Event

[image]

Revit 2024 API
ControlledApplication..::..DocumentReloadingLatest Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentReloadingLatestEventArgs event to be notified when Revit is just about to reload latest changes from a central model.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public event EventHandler<DocumentReloadingLatestEventArgs> DocumentReloadingLatest
Visual Basic
Public Event DocumentReloadingLatest As EventHandler(Of DocumentReloadingLatestEventArgs)
Visual C++
public:
 event EventHandler<DocumentReloadingLatestEventArgs^>^ DocumentReloadingLatest {
    void add (EventHandler<DocumentReloadingLatestEventArgs^>^ value);
    void remove (EventHandler<DocumentReloadingLatestEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to reload latest changes from a central model.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is cancellable. To cancel it, call the 'Cancel()' method in event's argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another DocumentReloadingLatest event will be raised immediately after latest changes reloading from a central model is finished.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


DocumentSaved Event

[image]

Revit 2024 API
ControlledApplication..::..DocumentSaved Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2010

Syntax

C#
public event EventHandler<DocumentSavedEventArgs> DocumentSaved
Visual Basic
Public Event DocumentSaved As EventHandler(Of DocumentSavedEventArgs)
Visual C++
public:
 event EventHandler<DocumentSavedEventArgs^>^ DocumentSaved {
    void add (EventHandler<DocumentSavedEventArgs^>^ value);
    void remove (EventHandler<DocumentSavedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished saving a document. Note that the first save of a newly created document will raise DocumentSavedAs rather than the DocumentSaved event. It is raised even when document saving failed or was cancelled (during DocumentSaving event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' property in event's argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of saving document has already been finished.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


DocumentSavedAs Event

[image]

Revit 2024 API
ControlledApplication..::..DocumentSavedAs Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2010

Syntax

C#
public event EventHandler<DocumentSavedAsEventArgs> DocumentSavedAs
Visual Basic
Public Event DocumentSavedAs As EventHandler(Of DocumentSavedAsEventArgs)
Visual C++
public:
 event EventHandler<DocumentSavedAsEventArgs^>^ DocumentSavedAs {
    void add (EventHandler<DocumentSavedAsEventArgs^>^ value);
    void remove (EventHandler<DocumentSavedAsEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished saving document with a new file name. Note that the first save of a newly created document will raise DocumentSavedAs rather than DocumentSaved event. It is raised even when document saving failed or was cancelled (during DocumentSavingAs event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' property in event's argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of saving document has already been finished.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


DocumentSaving Event

[image]

Revit 2024 API
ControlledApplication..::..DocumentSaving Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentSaving event to be notified when Revit is just about to save a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2010

Syntax

C#
public event EventHandler<DocumentSavingEventArgs> DocumentSaving
Visual Basic
Public Event DocumentSaving As EventHandler(Of DocumentSavingEventArgs)
Visual C++
public:
 event EventHandler<DocumentSavingEventArgs^>^ DocumentSaving {
    void add (EventHandler<DocumentSavingEventArgs^>^ value);
    void remove (EventHandler<DocumentSavingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to save the document. Note that the first save of a newly created document will raise DocumentSavingAs rather than the DocumentSaving event.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

This event is cancellable, except when it is raised during close of the application. Check the 'Cancellable' property of event's argument to see whether it is cancellable or not. When it is cancellable, call the 'Cancel()' method of event's argument to cancel it. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event DocumentSaved will be raised immediately after the document has been saved.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


DocumentSynchronizedWithCentral Event

[image]

Revit 2024 API
ControlledApplication..::..DocumentSynchronizedWithCentral Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentSynchronizedWithCentral event to be notified immediately after Revit has finished synchronizing a document with central model.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2010

Syntax

C#
public event EventHandler<DocumentSynchronizedWithCentralEventArgs> DocumentSynchronizedWithCentral
Visual Basic
Public Event DocumentSynchronizedWithCentral As EventHandler(Of DocumentSynchronizedWithCentralEventArgs)
Visual C++
public:
 event EventHandler<DocumentSynchronizedWithCentralEventArgs^>^ DocumentSynchronizedWithCentral {
    void add (EventHandler<DocumentSynchronizedWithCentralEventArgs^>^ value);
    void remove (EventHandler<DocumentSynchronizedWithCentralEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished synchronizing a document with central model. It is raised even when document synchronizing with central model failed or was cancelled (during DocumentSynchronizingWithCentral event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event's argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of synchronizing a document with central model has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


DocumentSynchronizingWithCentral Event

[image]

Revit 2024 API
ControlledApplication..::..DocumentSynchronizingWithCentral Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentSynchronizingWithCentral event to be notified when Revit is just about to synchronize a document with central model.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2010

Syntax

C#
public event EventHandler<DocumentSynchronizingWithCentralEventArgs> DocumentSynchronizingWithCentral
Visual Basic
Public Event DocumentSynchronizingWithCentral As EventHandler(Of DocumentSynchronizingWithCentralEventArgs)
Visual C++
public:
 event EventHandler<DocumentSynchronizingWithCentralEventArgs^>^ DocumentSynchronizingWithCentral {
    void add (EventHandler<DocumentSynchronizingWithCentralEventArgs^>^ value);
    void remove (EventHandler<DocumentSynchronizingWithCentralEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to synchronize a document with central model.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is cancellable. To cancel it, call the 'Cancel()' method in event's argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another DocumentSynchronizedWithCentral event will be raised immediately after document synchronizing with central model is finished.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ElementTypeDuplicated Event

[image]

Revit 2024 API
ControlledApplication..::..ElementTypeDuplicated Event
ControlledApplication Class See Also Send Feedback
Subscribe to the ElementTypeDuplicated event to be notified immediately after Revit has finished duplicating an element type.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public event EventHandler<ElementTypeDuplicatedEventArgs> ElementTypeDuplicated
Visual Basic
Public Event ElementTypeDuplicated As EventHandler(Of ElementTypeDuplicatedEventArgs)
Visual C++
public:
 event EventHandler<ElementTypeDuplicatedEventArgs^>^ ElementTypeDuplicated {
    void add (EventHandler<ElementTypeDuplicatedEventArgs^>^ value);
    void remove (EventHandler<ElementTypeDuplicatedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished duplicating an element type. It is raised even when duplicating an element type failed or was cancelled (during ElementTypeDuplicating event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in the event's argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of duplicating an element type has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


FailuresProcessing Event

[image]

Revit 2024 API
ControlledApplication..::..FailuresProcessing Event
ControlledApplication Class See Also Send Feedback
Subscribe to the FailuresProcessing event to be notified when failures are being processed at the end of transaction.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public event EventHandler<FailuresProcessingEventArgs> FailuresProcessing
Visual Basic
Public Event FailuresProcessing As EventHandler(Of FailuresProcessingEventArgs)
Visual C++
public:
 event EventHandler<FailuresProcessingEventArgs^>^ FailuresProcessing {
    void add (EventHandler<FailuresProcessingEventArgs^>^ value);
    void remove (EventHandler<FailuresProcessingEventArgs^>^ value);
}

Remarks

This event is raised when failures are being processed during transaction commit or rollback operations. Handlers of this event have a limited ability to modify the document and/or failures in it, using the provided restricted failures accessor interface.

The event arguments provide access to the FailuresAccessor via [!:Autodesk::Revit::DB::FailuresProcessingEventArgs::GetFailuresAccessor()] which contains the details of the errors and/or warnings that caused the event to trigger.

The arguments also allow you to set a processing result via [!:Autodesk::Revit::DB::FailuresProcessingEventArgs::SetProcessingResult()]. The processing result determines if Revit will attempt to recommit the currently failing transaction, roll it back, or continue. If you are explicitly dismissing warnings from the event callback, a processing result of Continue is sufficient. But if you are explicitly resolving errors from the event callback, you must change the processing result to ProceedWithCommit to ensure that the user is not shown the dismissed errors. If you wish to cancel the transaction silently without showing the errors to the user, set the processing result to ProceedWithRollback, however you must also call SetClearAfterRollback(Boolean) in order to dismiss the errors and silently cancel the transaction.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


FamilyLoadedIntoDocument Event

[image]

Revit 2024 API
ControlledApplication..::..FamilyLoadedIntoDocument Event
ControlledApplication Class See Also Send Feedback
Subscribe to the FamilyLoadedInto event to be notified after Revit loaded a family into a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public event EventHandler<FamilyLoadedIntoDocumentEventArgs> FamilyLoadedIntoDocument
Visual Basic
Public Event FamilyLoadedIntoDocument As EventHandler(Of FamilyLoadedIntoDocumentEventArgs)
Visual C++
public:
 event EventHandler<FamilyLoadedIntoDocumentEventArgs^>^ FamilyLoadedIntoDocument {
    void add (EventHandler<FamilyLoadedIntoDocumentEventArgs^>^ value);
    void remove (EventHandler<FamilyLoadedIntoDocumentEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished loading a family into a document. It is raised even when family loading failed or was cancelled (during FamilyLoadingIntoDocument event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event's argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of importing has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


FileExported Event

[image]

Revit 2024 API
ControlledApplication..::..FileExported Event
ControlledApplication Class See Also Send Feedback
Subscribe to the FileExported event to be notified immediately after Revit has finished exporting files of formats supported by the API.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2010

Syntax

C#
public event EventHandler<FileExportedEventArgs> FileExported
Visual Basic
Public Event FileExported As EventHandler(Of FileExportedEventArgs)
Visual C++
public:
 event EventHandler<FileExportedEventArgs^>^ FileExported {
    void add (EventHandler<FileExportedEventArgs^>^ value);
    void remove (EventHandler<FileExportedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished exporting files of formats supported by the API. It is raised even when file exporting failed or was cancelled (during FileExporting event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event's argument to see whether the action itself was successful or not. If export is a part of 'Publish to Buzzsaw' command which consists of two parts â€“ export of a document followed by publishing it to a BuzzSaw server, the event status only reflects the result of the Export action. The publishing part of the command could still be cancelled or could fail after FileExported event is raised.

This event is not cancellable, for the process of exporting file has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


FileExporting Event

[image]

Revit 2024 API
ControlledApplication..::..FileExporting Event
ControlledApplication Class See Also Send Feedback
Subscribe to the FileExporting event to be notified when Revit is just about to export files of formats supported by the API.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2010

Syntax

C#
public event EventHandler<FileExportingEventArgs> FileExporting
Visual Basic
Public Event FileExporting As EventHandler(Of FileExportingEventArgs)
Visual C++
public:
 event EventHandler<FileExportingEventArgs^>^ FileExporting {
    void add (EventHandler<FileExportingEventArgs^>^ value);
    void remove (EventHandler<FileExportingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to export files of formats supported by the API.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is cancellable. To cancel it, call the 'Cancel()' method in event's argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • All overloads of Autodesk.Revit.DB.Document.Export()
  • Autodesk.Revit.Document.Print()
  • Print()()()() and similar overloads.
  • SubmitPrint()()()() and similar overloads.
  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another FileExported event will be raised immediately after file exporting is finished.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


FileImported Event

[image]

Revit 2024 API
ControlledApplication..::..FileImported Event
ControlledApplication Class See Also Send Feedback
Subscribe to the FileImported event to be notified immediately after Revit has finished importing a file of format supported by the API.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2010

Syntax

C#
public event EventHandler<FileImportedEventArgs> FileImported
Visual Basic
Public Event FileImported As EventHandler(Of FileImportedEventArgs)
Visual C++
public:
 event EventHandler<FileImportedEventArgs^>^ FileImported {
    void add (EventHandler<FileImportedEventArgs^>^ value);
    void remove (EventHandler<FileImportedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished importing a file of format supported by the API. It is raised even when file importing failed or was cancelled (during FileImporting event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event's argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of importing has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


FileImporting Event

[image]

Revit 2024 API
ControlledApplication..::..FileImporting Event
ControlledApplication Class See Also Send Feedback
Subscribe to the FileImporting event to be notified when Revit is just about to import a file of format supported by the API.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2010

Syntax

C#
public event EventHandler<FileImportingEventArgs> FileImporting
Visual Basic
Public Event FileImporting As EventHandler(Of FileImportingEventArgs)
Visual C++
public:
 event EventHandler<FileImportingEventArgs^>^ FileImporting {
    void add (EventHandler<FileImportingEventArgs^>^ value);
    void remove (EventHandler<FileImportingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to import a file of format supported by the API.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is cancellable. To cancel it, call the 'Cancel()' method in event's argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • All overloads of Autodesk.Revit.DB.Document.Import()
  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another FileImported event will be raised immediately after file importing is finished.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


LinkedResourceOpened Event

[image]

Revit 2024 API
ControlledApplication..::..LinkedResourceOpened Event
ControlledApplication Class See Also Send Feedback
Subscribe to the LinkedResourceOpened event to be notified immediately after Revit has finished opening a linked resource.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public event EventHandler<LinkedResourceOpenedEventArgs> LinkedResourceOpened
Visual Basic
Public Event LinkedResourceOpened As EventHandler(Of LinkedResourceOpenedEventArgs)
Visual C++
public:
 event EventHandler<LinkedResourceOpenedEventArgs^>^ LinkedResourceOpened {
    void add (EventHandler<LinkedResourceOpenedEventArgs^>^ value);
    void remove (EventHandler<LinkedResourceOpenedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished opening a linked resource. Only supports linked resources for following types : Revit; IFC; CAD(dwg, dxf, dgn, sat); Topography; It is raised even when a linked resource opening failed. The LinkedResourceOpened events would not raised if there are no update on linked CAD, IFC resources.

Check the 'Status' field in event's argument to see whether the action itself was successful or not.

Another LinkedResourceOpening event will be raised when Revit is just about to open a linked resource.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


LinkedResourceOpening Event

[image]

Revit 2024 API
ControlledApplication..::..LinkedResourceOpening Event
ControlledApplication Class See Also Send Feedback
Subscribe to the LinkedResourceOpening event to be notified when Revit is just about to open a linked resource.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public event EventHandler<LinkedResourceOpeningEventArgs> LinkedResourceOpening
Visual Basic
Public Event LinkedResourceOpening As EventHandler(Of LinkedResourceOpeningEventArgs)
Visual C++
public:
 event EventHandler<LinkedResourceOpeningEventArgs^>^ LinkedResourceOpening {
    void add (EventHandler<LinkedResourceOpeningEventArgs^>^ value);
    void remove (EventHandler<LinkedResourceOpeningEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to open a linked resource. Only supports linked resources for following types : Revit; IFC; CAD(dwg, dxf, dgn, sat); This event would not be raised if there are no update on linked CAD, IFC resources.

Event is not cancellable.

The linked resource cannot be modified, for it is not opened yet at the time of the event.

Another LinkedResourceOpened event will be raised immediately after linked resource is opened.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ViewPrinted Event

[image]

Revit 2024 API
ControlledApplication..::..ViewPrinted Event
ControlledApplication Class See Also Send Feedback
Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2010

Syntax

C#
public event EventHandler<ViewPrintedEventArgs> ViewPrinted
Visual Basic
Public Event ViewPrinted As EventHandler(Of ViewPrintedEventArgs)
Visual C++
public:
 event EventHandler<ViewPrintedEventArgs^>^ ViewPrinted {
    void add (EventHandler<ViewPrintedEventArgs^>^ value);
    void remove (EventHandler<ViewPrintedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished printing a view of the document. If multiple views are combined to a single file, this event will be raised only once. It is raised even when view printing failed.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event's argument to see whether the action was successful or not.

This event is not cancellable, for the process of view printing has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ViewPrinting Event

[image]

Revit 2024 API
ControlledApplication..::..ViewPrinting Event
ControlledApplication Class See Also Send Feedback
Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2010

Syntax

C#
public event EventHandler<ViewPrintingEventArgs> ViewPrinting
Visual Basic
Public Event ViewPrinting As EventHandler(Of ViewPrintingEventArgs)
Visual C++
public:
 event EventHandler<ViewPrintingEventArgs^>^ ViewPrinting {
    void add (EventHandler<ViewPrintingEventArgs^>^ value);
    void remove (EventHandler<ViewPrintingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to print a view of the document. If multiple views are combined to a single file, this event will be raised only once.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is not cancellable. The 'Cancellable' property of event's argument is always False.

The following API functions are not available for the current document during this event:

  • All overloads of Autodesk.Revit.DB.Document.Export()
  • Autodesk.Revit.DB.Document.Print()
  • Print()()()() and similar overloads.
  • SubmitPrint()()()() and similar overloads.
  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event ViewPrinted will be raised immediately after view printing is finished.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


WorksharedOperationProgressChanged Event

[image]

Revit 2024 API
ControlledApplication..::..WorksharedOperationProgressChanged Event
ControlledApplication Class See Also Send Feedback
Subscribe to the WorksharedOperationProgressChanged to be notified when progress has changed during Collaboration for Revit's workshared operations: open model and synchronize with central.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update

Syntax

C#
public event EventHandler<WorksharedOperationProgressChangedEventArgs> WorksharedOperationProgressChanged
Visual Basic
Public Event WorksharedOperationProgressChanged As EventHandler(Of WorksharedOperationProgressChangedEventArgs)
Visual C++
public:
 event EventHandler<WorksharedOperationProgressChangedEventArgs^>^ WorksharedOperationProgressChanged {
    void add (EventHandler<WorksharedOperationProgressChangedEventArgs^>^ value);
    void remove (EventHandler<WorksharedOperationProgressChangedEventArgs^>^ value);
}

Remarks

This event is only supported for Collaboration for Revit and will not be raised for those operations occurring in local-worksharing and Revit Server workflow. Users may not change the document in the handler for this event. It is NOT recommended to do any time-consuming work when handling WorksharedOperationProgressChanged event. This can increase workshared operation time." Exception ModificationForbiddenException will be thrown if any document-modifying method is called during this event's handler.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ProductType Enumeration

[image]

Revit 2024 API
ProductType Enumeration
See Also Send Feedback
An enumerated type containing the possible Revit product types.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum ProductType
Visual Basic
Public Enumeration ProductType
Visual C++
public enum class ProductType

Members

Member name | Description
Architecture | Architecture.
Structure | Structure.
MEP | MEP.
Revit | Revit.
LT | LT.
Unknown | Unknown.

See Also

Autodesk.Revit.ApplicationServices Namespace


Autodesk.Revit.Attributes Namespace

[image]

Revit 2024 API
Autodesk.Revit.Attributes Namespace
Send Feedback

Classes

 | Class | Description
Public class | JournalingAttribute | The custom journaling attribute to control the journaling behavior of the external command.
Public class | RegenerationAttribute | The custom regeneration attribute to control the regeneration behavior of the external command or external application.
Public class | TransactionAttribute | The custom transaction attribute to control the transaction behavior of the external command.

Enumerations

 | Enumeration | Description
Public enumeration | JournalingMode | All journaling modes supported by Revit external commands.
Public enumeration | RegenerationOption | All regeneration options supported by Revit external commands and external applications.
Public enumeration | TransactionMode | All transaction modes supported by Revit external commands.


JournalingAttribute Class

[image]

Revit 2024 API
JournalingAttribute Class
Members See Also Send Feedback
The custom journaling attribute to control the journaling behavior of the external command.

Namespace: Autodesk.Revit.Attributes
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class JournalingAttribute : Attribute
Visual Basic
Public Class JournalingAttribute _
    Inherits Attribute
Visual C++
public ref class JournalingAttribute : public Attribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.Attributes..::..JournalingAttribute

See Also

JournalingAttribute Members
Autodesk.Revit.Attributes Namespace


JournalingAttribute Members

[image] [image]

Revit 2024 API
JournalingAttribute Members
JournalingAttribute Class Constructors Methods Properties See Also Send Feedback

The JournalingAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | JournalingAttribute | Constructs a new JournalingAttribute.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Mode | Journaling mode.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

JournalingAttribute Class
Autodesk.Revit.Attributes Namespace


JournalingAttribute Methods

[image] [image]

Revit 2024 API
JournalingAttribute Methods
JournalingAttribute Class See Also Send Feedback

The JournalingAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

JournalingAttribute Class
Autodesk.Revit.Attributes Namespace


RegenerationAttribute Class

[image]

Revit 2024 API
RegenerationAttribute Class
Members See Also Send Feedback
The custom regeneration attribute to control the regeneration behavior of the external command or external application.

Namespace: Autodesk.Revit.Attributes
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class RegenerationAttribute : Attribute
Visual Basic
Public Class RegenerationAttribute _
    Inherits Attribute
Visual C++
public ref class RegenerationAttribute : public Attribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.Attributes..::..RegenerationAttribute

See Also

RegenerationAttribute Members
Autodesk.Revit.Attributes Namespace


RegenerationAttribute Members

[image] [image]

Revit 2024 API
RegenerationAttribute Members
RegenerationAttribute Class Constructors Methods Properties See Also Send Feedback

The RegenerationAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | RegenerationAttribute | Constructs a new RegenerationAttribute.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Option | Regeneration option.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

RegenerationAttribute Class
Autodesk.Revit.Attributes Namespace


RegenerationAttribute Constructor

[image]

Revit 2024 API
RegenerationAttribute Constructor
RegenerationAttribute Class See Also Send Feedback
Constructs a new RegenerationAttribute.

Namespace: Autodesk.Revit.Attributes
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public RegenerationAttribute(
    RegenerationOption option
)
Visual Basic
Public Sub New ( _
    option As RegenerationOption _
)
Visual C++
public:
RegenerationAttribute(
    RegenerationOption option
)

Parameters

option
Type: Autodesk.Revit.Attributes..::..RegenerationOption

See Also

RegenerationAttribute Class
Autodesk.Revit.Attributes Namespace


RegenerationAttribute Methods

[image] [image]

Revit 2024 API
RegenerationAttribute Methods
RegenerationAttribute Class See Also Send Feedback

The RegenerationAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RegenerationAttribute Class
Autodesk.Revit.Attributes Namespace


RegenerationAttribute Properties

[image] [image]

Revit 2024 API
RegenerationAttribute Properties
RegenerationAttribute Class See Also Send Feedback

The RegenerationAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Option | Regeneration option.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

RegenerationAttribute Class
Autodesk.Revit.Attributes Namespace


Option Property

[image]

Revit 2024 API
RegenerationAttribute..::..Option Property
RegenerationAttribute Class See Also Send Feedback
Regeneration option.

Namespace: Autodesk.Revit.Attributes
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public RegenerationOption Option { get; }
Visual Basic
Public ReadOnly Property Option As RegenerationOption
    Get
Visual C++
public:
property RegenerationOption Option {
    RegenerationOption get ();
}

See Also

RegenerationAttribute Class
Autodesk.Revit.Attributes Namespace


RegenerationOption Enumeration

[image]

Revit 2024 API
RegenerationOption Enumeration
See Also Send Feedback
All regeneration options supported by Revit external commands and external applications.

Namespace: Autodesk.Revit.Attributes
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public enum RegenerationOption
Visual Basic
Public Enumeration RegenerationOption
Visual C++
public enum class RegenerationOption

Members

Member name | Description
Manual | The API framework will not regenerate after every model level change. Instead, you may use the regeneration APIs to force update of the document after a group of changes. SuspendUpdating blocks are unnecessary and should not be used. Performance of multiple modifications of the Revit document should be faster than RegenerationOption.Automatic. Because this mode suspends all updates to the document, your application should not read data from the document after it has been modified until the document has been regenerated, or it runs the risk of accessing stale data. This mode will be only option in a future release.

See Also

Autodesk.Revit.Attributes Namespace


TransactionAttribute Members

[image] [image]

Revit 2024 API
TransactionAttribute Members
TransactionAttribute Class Constructors Methods Properties See Also Send Feedback

The TransactionAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | TransactionAttribute | Constructs a new TransactionAttribute.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Mode | Transaction mode.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

TransactionAttribute Class
Autodesk.Revit.Attributes Namespace


TransactionAttribute Constructor

[image]

Revit 2024 API
TransactionAttribute Constructor
TransactionAttribute Class See Also Send Feedback
Constructs a new TransactionAttribute.

Namespace: Autodesk.Revit.Attributes
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public TransactionAttribute(
    TransactionMode mode
)
Visual Basic
Public Sub New ( _
    mode As TransactionMode _
)
Visual C++
public:
TransactionAttribute(
    TransactionMode mode
)

Parameters

mode
Type: Autodesk.Revit.Attributes..::..TransactionMode

See Also

TransactionAttribute Class
Autodesk.Revit.Attributes Namespace


TransactionAttribute Properties

[image] [image]

Revit 2024 API
TransactionAttribute Properties
TransactionAttribute Class See Also Send Feedback

The TransactionAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Mode | Transaction mode.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

TransactionAttribute Class
Autodesk.Revit.Attributes Namespace


Mode Property

[image]

Revit 2024 API
TransactionAttribute..::..Mode Property
TransactionAttribute Class See Also Send Feedback
Transaction mode.

Namespace: Autodesk.Revit.Attributes
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public TransactionMode Mode { get; }
Visual Basic
Public ReadOnly Property Mode As TransactionMode
    Get
Visual C++
public:
property TransactionMode Mode {
    TransactionMode get ();
}

See Also

TransactionAttribute Class
Autodesk.Revit.Attributes Namespace


TransactionMode Enumeration

[image]

Revit 2024 API
TransactionMode Enumeration
See Also Send Feedback
All transaction modes supported by Revit external commands.

Namespace: Autodesk.Revit.Attributes
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public enum TransactionMode
Visual Basic
Public Enumeration TransactionMode
Visual C++
public enum class TransactionMode

Members

Member name | Description
Manual | The API framework will not create a transaction (but will create an outer group to roll back all changes if the external command returns a failure status). Instead, you may use combinations of transactions, sub-transactions, and groups. You will have to follow all rules regarding use of transactions and related classes. You will have to give your transactions names, which will then appear in the undo menu. Revit will check that all transactions (also groups and sub-transaction) are properly closed upon return from an external command. If not, it will discard all changes to the model.
ReadOnly | No transaction (nor group) will be created, and no transaction may be created for the lifetime of the command. The External command may use methods that only read from the model, but not methods that write anything to it. Exceptions will be thrown if the command either tries to start a transaction (or group) or attempts to write to the model.

See Also

Autodesk.Revit.Attributes Namespace


Application Class

[image]

Revit 2024 API
Application Class
Members See Also Send Feedback
The Application Creation object is used to create new instances of utility objects.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class Application : APIObject
Visual Basic
Public Class Application _
    Inherits APIObject
Visual C++
public ref class Application : public APIObject

Remarks

General purpose objects can be generated by this creation object. Creating objects via this object ensures that they will be correctly constructed and will reside in the Autodesk Revit memory space.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.Creation..::..Application

See Also

Application Members
Autodesk.Revit.Creation Namespace


NewAreaCreationData Method

[image]

Revit 2024 API
Application..::..NewAreaCreationData Method
Application Class See Also Send Feedback
Creates an object which wraps the arguments of Area for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public AreaCreationData NewAreaCreationData(
    ViewPlan areaView,
    UV point
)
Visual Basic
Public Function NewAreaCreationData ( _
    areaView As ViewPlan, _
    point As UV _
) As AreaCreationData
Visual C++
public:
AreaCreationData^ NewAreaCreationData(
    ViewPlan^ areaView,
    UV^ point
)

Parameters

areaView
Type: Autodesk.Revit.DB..::..ViewPlan
The view of area element.
point
Type: Autodesk.Revit.DB..::..UV
A point which lies in an enclosed region of area boundary where the new area will reside.

Return Value

The object containing the data needed for area creation.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewBoundingBoxUV Method

[image]

Revit 2024 API
Application..::..NewBoundingBoxUV Method
Application Class See Also Send Feedback
Creates an empty two-dimensional rectangle.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public BoundingBoxUV NewBoundingBoxUV()
Visual Basic
Public Function NewBoundingBoxUV As BoundingBoxUV
Visual C++
public:
BoundingBoxUV^ NewBoundingBoxUV()

See Also

Application Class
NewBoundingBoxUV Overload
Autodesk.Revit.Creation Namespace


NewBoundingBoxUV Method (Double, Double, Double, Double)

[image]

Revit 2024 API
Application..::..NewBoundingBoxUV Method (Double, Double, Double, Double)
Application Class See Also Send Feedback
Creates a two-dimensional rectangle with supplied values.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public BoundingBoxUV NewBoundingBoxUV(
    double min_u,
    double min_v,
    double max_u,
    double max_v
)
Visual Basic
Public Function NewBoundingBoxUV ( _
    min_u As Double, _
    min_v As Double, _
    max_u As Double, _
    max_v As Double _
) As BoundingBoxUV
Visual C++
public:
BoundingBoxUV^ NewBoundingBoxUV(
    double min_u,
    double min_v,
    double max_u,
    double max_v
)

Parameters

min_u
Type: System..::..Double
The first coordinate of min.
min_v
Type: System..::..Double
The second coordinate of min.
max_u
Type: System..::..Double
The first coordinate of max.
max_v
Type: System..::..Double
The second coordinate of max.

See Also

Application Class
NewBoundingBoxUV Overload
Autodesk.Revit.Creation Namespace


NewCategorySet Method

[image]

Revit 2024 API
Application..::..NewCategorySet Method
Application Class See Also Send Feedback
Creates a new instance of a set specifically for holding category objects.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CategorySet NewCategorySet()
Visual Basic
Public Function NewCategorySet As CategorySet
Visual C++
public:
CategorySet^ NewCategorySet()

Return Value

A new instance of a Category Set.

Remarks

This type of set is used during the creation of instance and type bindings.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewColor Method

[image]

Revit 2024 API
Application..::..NewColor Method
Application Class Example See Also Send Feedback
Returns a new color object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Color NewColor()
Visual Basic
Public Function NewColor As Color
Visual C++
public:
Color^ NewColor()

Return Value

The new color object.

Examples

CopyC#
Color NewColorInfo(Autodesk.Revit.Creation.Application appCreation)
{
    // Create a new color
    Autodesk.Revit.DB.Color color = appCreation.NewColor();

    // Set its RGB values
    color.Red = (byte)127;
    color.Green = (byte)64;
    color.Blue = (byte)32;

    // Display the color info
    StringBuilder info = new StringBuilder();
    info.AppendLine("Red:\t" + color.Red.ToString());
    info.AppendLine("Green:\t" + color.Green.ToString());
    info.AppendLine("Blue:\t" + color.Blue.ToString());

    TaskDialog.Show("Revit",info.ToString());

    return color;
}
CopyVB.NET
Private Function NewColorInfo(appCreation As Autodesk.Revit.Creation.Application) As Color
    ' Create a new color
    Dim color As Autodesk.Revit.DB.Color = appCreation.NewColor()

    ' Set its RGB values
    color.Red = CByte(127)
    color.Green = CByte(64)
    color.Blue = CByte(32)

    ' Display the color info
    Dim info As New StringBuilder()
    info.AppendLine("Red:" & vbTab & color.Red.ToString())
    info.AppendLine("Green:" & vbTab & color.Green.ToString())
    info.AppendLine("Blue:" & vbTab & color.Blue.ToString())

    TaskDialog.Show("Revit", info.ToString())

    Return color
End Function

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewCombinableElementArray Method

[image]

Revit 2024 API
Application..::..NewCombinableElementArray Method
Application Class See Also Send Feedback
Returns an array that can hold combinable element objects.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CombinableElementArray NewCombinableElementArray()
Visual Basic
Public Function NewCombinableElementArray As CombinableElementArray
Visual C++
public:
CombinableElementArray^ NewCombinableElementArray()

Return Value

An empty array that can contain any CombinableElement derived objects.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewCurveLoopsProfile Method

[image]

Revit 2024 API
Application..::..NewCurveLoopsProfile Method
Application Class See Also Send Feedback
Creates a new CurveLoopsProfile object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CurveLoopsProfile NewCurveLoopsProfile(
    CurveArrArray curveLoops
)
Visual Basic
Public Function NewCurveLoopsProfile ( _
    curveLoops As CurveArrArray _
) As CurveLoopsProfile
Visual C++
public:
CurveLoopsProfile^ NewCurveLoopsProfile(
    CurveArrArray^ curveLoops
)

Parameters

curveLoops
Type: Autodesk.Revit.DB..::..CurveArrArray
The curve loops of the Profile.

Return Value

The new CurveLoopsProfile object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the argument is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewDoubleArray Method

[image]

Revit 2024 API
Application..::..NewDoubleArray Method
Application Class See Also Send Feedback
Creates a new instance of a double array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public DoubleArray NewDoubleArray()
Visual Basic
Public Function NewDoubleArray As DoubleArray
Visual C++
public:
DoubleArray^ NewDoubleArray()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewDWFExportOptions Method

[image]

Revit 2024 API
Application..::..NewDWFExportOptions Method
Application Class See Also Send Feedback
Creates DWF Export options.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public DWFExportOptions NewDWFExportOptions()
Visual Basic
Public Function NewDWFExportOptions As DWFExportOptions
Visual C++
public:
DWFExportOptions^ NewDWFExportOptions()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewDWFXExportOptions Method

[image]

Revit 2024 API
Application..::..NewDWFXExportOptions Method
Application Class See Also Send Feedback
Creates DWFX Export options.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public DWFXExportOptions NewDWFXExportOptions()
Visual Basic
Public Function NewDWFXExportOptions As DWFXExportOptions
Visual C++
public:
DWFXExportOptions^ NewDWFXExportOptions()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewElementSet Method

[image]

Revit 2024 API
Application..::..NewElementSet Method
Application Class See Also Send Feedback
Creates a new instance of a set specifically for holding elements.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElementSet NewElementSet()
Visual Basic
Public Function NewElementSet As ElementSet
Visual C++
public:
ElementSet^ NewElementSet()

Return Value

A new Element Set.

Remarks

This is a general purpose set for passing elements to and from methods.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewFaceArray Method

[image]

Revit 2024 API
Application..::..NewFaceArray Method
Application Class See Also Send Feedback
Creates a new instance of a face array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FaceArray NewFaceArray()
Visual Basic
Public Function NewFaceArray As FaceArray
Visual C++
public:
FaceArray^ NewFaceArray()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewFamilyInstanceCreationData Method

[image] [image]

Revit 2024 API
Application..::..NewFamilyInstanceCreationData Method
Application Class See Also Send Feedback
Creates an adaptive component which wraps the arguments of NewFamilyInstance() for batch creation.
Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

Overload List

 | Name | Description
Public method | NewFamilyInstanceCreationData(FamilySymbol, IList<(Of <<'(XYZ>)>>)) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(Face, Line, FamilySymbol) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(XYZ, FamilySymbol, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(Curve, FamilySymbol, Level, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(Face, XYZ, XYZ, FamilySymbol) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(XYZ, FamilySymbol, Element, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(XYZ, FamilySymbol, Level, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(XYZ, FamilySymbol, Element, Level, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

See Also

Application Class
Application Members
Autodesk.Revit.Creation Namespace


NewFamilyInstanceCreationData Method (FamilySymbol, IList(XYZ))

[image]

Revit 2024 API
Application..::..NewFamilyInstanceCreationData Method (FamilySymbol, IList<(Of <(<'XYZ>)>)>)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    FamilySymbol symbol,
    IList<XYZ> adaptivePoints
)
Visual Basic
Public Function NewFamilyInstanceCreationData ( _
    symbol As FamilySymbol, _
    adaptivePoints As IList(Of XYZ) _
) As FamilyInstanceCreationData
Visual C++
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData(
    FamilySymbol^ symbol,
    IList<XYZ^>^ adaptivePoints
)

Parameters

symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
adaptivePoints
Type: System.Collections.Generic..::..IList<(Of <(<' XYZ >)>)>
The adaptive point location where the adaptive instance is to be placed.

See Also

Application Class
NewFamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstanceCreationData Method (Face, Line, FamilySymbol)

[image]

Revit 2024 API
Application..::..NewFamilyInstanceCreationData Method (Face, Line, FamilySymbol)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    Face face,
    Line position,
    FamilySymbol symbol
)
Visual Basic
Public Function NewFamilyInstanceCreationData ( _
    face As Face, _
    position As Line, _
    symbol As FamilySymbol _
) As FamilyInstanceCreationData
Visual C++
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData(
    Face^ face,
    Line^ position,
    FamilySymbol^ symbol
)

Parameters

face
Type: Autodesk.Revit.DB..::..Face
A face of a geometry object.
position
Type: Autodesk.Revit.DB..::..Line
A line on the face defining where the symbol is to be placed.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.

See Also

Application Class
NewFamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstanceCreationData Method (Curve, FamilySymbol, Level, StructuralType)

[image]

Revit 2024 API
Application..::..NewFamilyInstanceCreationData Method (Curve, FamilySymbol, Level, StructuralType)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    Curve curve,
    FamilySymbol symbol,
    Level level,
    StructuralType structuralType
)
Visual Basic
Public Function NewFamilyInstanceCreationData ( _
    curve As Curve, _
    symbol As FamilySymbol, _
    level As Level, _
    structuralType As StructuralType _
) As FamilyInstanceCreationData
Visual C++
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData(
    Curve^ curve,
    FamilySymbol^ symbol,
    Level^ level,
    StructuralType structuralType
)

Parameters

curve
Type: Autodesk.Revit.DB..::..Curve
The curve where the instance is based.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
level
Type: Autodesk.Revit.DB..::..Level
A Level object that is used as the base level for the object.
structuralType
Type: Autodesk.Revit.DB.Structure..::..StructuralType
If structural then specify the type of the component.

See Also

Application Class
NewFamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstanceCreationData Method (XYZ, FamilySymbol, Element, StructuralType)

[image]

Revit 2024 API
Application..::..NewFamilyInstanceCreationData Method (XYZ, FamilySymbol, Element, StructuralType)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    Element host,
    StructuralType structuralType
)
Visual Basic
Public Function NewFamilyInstanceCreationData ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    host As Element, _
    structuralType As StructuralType _
) As FamilyInstanceCreationData
Visual C++
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData(
    XYZ^ location,
    FamilySymbol^ symbol,
    Element^ host,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.DB..::..XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
host
Type: Autodesk.Revit.DB..::..Element
The object into which the family instance is to be inserted, often known as the host.
structuralType
Type: Autodesk.Revit.DB.Structure..::..StructuralType
If structural then specify the type of the component.

See Also

Application Class
NewFamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstanceCreationData Method (XYZ, FamilySymbol, Level, StructuralType)

[image]

Revit 2024 API
Application..::..NewFamilyInstanceCreationData Method (XYZ, FamilySymbol, Level, StructuralType)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    Level level,
    StructuralType structuralType
)
Visual Basic
Public Function NewFamilyInstanceCreationData ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    level As Level, _
    structuralType As StructuralType _
) As FamilyInstanceCreationData
Visual C++
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData(
    XYZ^ location,
    FamilySymbol^ symbol,
    Level^ level,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.DB..::..XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
level
Type: Autodesk.Revit.DB..::..Level
A Level object that is used as the base level for the object.
structuralType
Type: Autodesk.Revit.DB.Structure..::..StructuralType
If structural then specify the type of the component.

See Also

Application Class
NewFamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstanceCreationData Method (XYZ, FamilySymbol, XYZ, Element, StructuralType)

[image]

Revit 2024 API
Application..::..NewFamilyInstanceCreationData Method (XYZ, FamilySymbol, XYZ, Element, StructuralType)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    XYZ referenceDirection,
    Element host,
    StructuralType structuralType
)
Visual Basic
Public Function NewFamilyInstanceCreationData ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    referenceDirection As XYZ, _
    host As Element, _
    structuralType As StructuralType _
) As FamilyInstanceCreationData
Visual C++
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData(
    XYZ^ location,
    FamilySymbol^ symbol,
    XYZ^ referenceDirection,
    Element^ host,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.DB..::..XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
referenceDirection
Type: Autodesk.Revit.DB..::..XYZ
A vector that dictates the direction of certain family instances.
host
Type: Autodesk.Revit.DB..::..Element
The object into which the family instance is to be inserted, often known as the host.
structuralType
Type: Autodesk.Revit.DB.Structure..::..StructuralType
If structural then specify the type of the component.

See Also

Application Class
NewFamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


NewFamilySymbolProfile Method

[image]

Revit 2024 API
Application..::..NewFamilySymbolProfile Method
Application Class See Also Send Feedback
Creates a new FamilySymbolProfile object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilySymbolProfile NewFamilySymbolProfile(
    FamilySymbol familySymbol
)
Visual Basic
Public Function NewFamilySymbolProfile ( _
    familySymbol As FamilySymbol _
) As FamilySymbolProfile
Visual C++
public:
FamilySymbolProfile^ NewFamilySymbolProfile(
    FamilySymbol^ familySymbol
)

Parameters

familySymbol
Type: Autodesk.Revit.DB..::..FamilySymbol
The family symbol of the Profile.

Return Value

The new FamilySymbolProfile object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the argument familySymbol is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewGBXMLImportOptions Method

[image]

Revit 2024 API
Application..::..NewGBXMLImportOptions Method
Application Class See Also Send Feedback
Creates Green-Building XML Import options.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public GBXMLImportOptions NewGBXMLImportOptions()
Visual Basic
Public Function NewGBXMLImportOptions As GBXMLImportOptions
Visual C++
public:
GBXMLImportOptions^ NewGBXMLImportOptions()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewGeometryOptions Method

[image]

Revit 2024 API
Application..::..NewGeometryOptions Method
Application Class Example See Also Send Feedback
Creates an object to specify user preferences in parsing of geometry.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Options NewGeometryOptions()
Visual Basic
Public Function NewGeometryOptions As Options
Visual C++
public:
Options^ NewGeometryOptions()

Return Value

Examples

CopyC#
Autodesk.Revit.DB.Options geomOption = application.Create.NewGeometryOptions();
if (null != geomOption)
{
    geomOption.ComputeReferences = true;
    geomOption.DetailLevel = Autodesk.Revit.DB.ViewDetailLevel.Fine;

    // Either the DetailLevel or the View can be set, but not both
    //geomOption.View = commandData.Application.Application.ActiveDocument.ActiveView;

    TaskDialog.Show("Revit", "Geometry Option created successfully.");
}
CopyVB.NET
Dim geomOption As Autodesk.Revit.DB.Options = application.Create.NewGeometryOptions()
If geomOption IsNot Nothing Then
    geomOption.ComputeReferences = True
    geomOption.DetailLevel = Autodesk.Revit.DB.ViewDetailLevel.Fine

    ' Either the DetailLevel or the View can be set, but not both
    'geomOption.View = commandData.Application.Application.ActiveDocument.ActiveView;

    TaskDialog.Show("Revit", "Geometry Option created successfully.")
End If

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewInstanceBinding Method

[image] [image]

Revit 2024 API
Application..::..NewInstanceBinding Method
Application Class See Also Send Feedback
Creates a new instance binding object.

Overload List

 | Name | Description
Public method | NewInstanceBinding()()()() | Creates a new empty instance binding object.
Public method | NewInstanceBinding(CategorySet) | Creates a new instance binding object containing the categories passed as a parameter.

See Also

Application Class
Application Members
Autodesk.Revit.Creation Namespace


NewInstanceBinding Method

[image]

Revit 2024 API
Application..::..NewInstanceBinding Method
Application Class See Also Send Feedback
Creates a new empty instance binding object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public InstanceBinding NewInstanceBinding()
Visual Basic
Public Function NewInstanceBinding As InstanceBinding
Visual C++
public:
InstanceBinding^ NewInstanceBinding()

Return Value

A new instance binding object.

Remarks

Instance binding objects are used for attaching shared parameter definitions to all instances of an element within a category. Categories can be added to the instance binding via the Categories property of the InstanceBinding object

See Also

Application Class
NewInstanceBinding Overload
Autodesk.Revit.Creation Namespace


NewInstanceBinding Method (CategorySet)

[image]

Revit 2024 API
Application..::..NewInstanceBinding Method (CategorySet)
Application Class See Also Send Feedback
Creates a new instance binding object containing the categories passed as a parameter.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public InstanceBinding NewInstanceBinding(
    CategorySet categorySet
)
Visual Basic
Public Function NewInstanceBinding ( _
    categorySet As CategorySet _
) As InstanceBinding
Visual C++
public:
InstanceBinding^ NewInstanceBinding(
    CategorySet^ categorySet
)

Parameters

categorySet
Type: Autodesk.Revit.DB..::..CategorySet
A set of categories that will be added to the binding.

Return Value

A new instance binding object.

Remarks

Instance binding objects are used for attaching shared parameter definitions to all instances of an element within a category.

See Also

Application Class
NewInstanceBinding Overload
Autodesk.Revit.Creation Namespace


NewIntersectionResultArray Method

[image]

Revit 2024 API
Application..::..NewIntersectionResultArray Method
Application Class See Also Send Feedback
Creates a new instance of an IntersectionResult array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public IntersectionResultArray NewIntersectionResultArray()
Visual Basic
Public Function NewIntersectionResultArray As IntersectionResultArray
Visual C++
public:
IntersectionResultArray^ NewIntersectionResultArray()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewPointOnEdge Method

[image]

Revit 2024 API
Application..::..NewPointOnEdge Method
Application Class See Also Send Feedback
Create a PointOnEdge object which is used to define the placement of a ReferencePoint.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public PointOnEdge NewPointOnEdge(
    Reference edgeReference,
    PointLocationOnCurve locationOnCurve
)
Visual Basic
Public Function NewPointOnEdge ( _
    edgeReference As Reference, _
    locationOnCurve As PointLocationOnCurve _
) As PointOnEdge
Visual C++
public:
PointOnEdge^ NewPointOnEdge(
    Reference^ edgeReference,
    PointLocationOnCurve^ locationOnCurve
)

Parameters

edgeReference
Type: Autodesk.Revit.DB..::..Reference
The reference whose edge the object will be created on.
locationOnCurve
Type: Autodesk.Revit.DB..::..PointLocationOnCurve
The location on the edge.

Return Value

If creation was successful then a new object is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument edgeReference or locationOnCurve is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewPointOnEdgeFaceIntersection Method

[image]

Revit 2024 API
Application..::..NewPointOnEdgeFaceIntersection Method
Application Class See Also Send Feedback
Construct a PointOnEdgeFaceIntersection object which is used to define the placement of a ReferencePoint given a references to edge and a reference to face.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public PointOnEdgeFaceIntersection NewPointOnEdgeFaceIntersection(
    Reference edgeReference,
    Reference faceReference,
    bool orientWithEdge
)
Visual Basic
Public Function NewPointOnEdgeFaceIntersection ( _
    edgeReference As Reference, _
    faceReference As Reference, _
    orientWithEdge As Boolean _
) As PointOnEdgeFaceIntersection
Visual C++
public:
PointOnEdgeFaceIntersection^ NewPointOnEdgeFaceIntersection(
    Reference^ edgeReference,
    Reference^ faceReference,
    bool orientWithEdge
)

Parameters

edgeReference
Type: Autodesk.Revit.DB..::..Reference
The edge reference.
faceReference
Type: Autodesk.Revit.DB..::..Reference
The face reference.
orientWithEdge
Type: System..::..Boolean

Return Value

A new PointOnEdgeFaceIntersection object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument edgeReference or faceReference is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewPointOnFace Method

[image]

Revit 2024 API
Application..::..NewPointOnFace Method
Application Class See Also Send Feedback
Construct a PointOnFace object which is used to define the placement of a ReferencePoint given a reference and a location on the face.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public PointOnFace NewPointOnFace(
    Reference faceReference,
    UV uv
)
Visual Basic
Public Function NewPointOnFace ( _
    faceReference As Reference, _
    uv As UV _
) As PointOnFace
Visual C++
public:
PointOnFace^ NewPointOnFace(
    Reference^ faceReference,
    UV^ uv
)

Parameters

faceReference
Type: Autodesk.Revit.DB..::..Reference
The reference whose face the object will be created on.
uv
Type: Autodesk.Revit.DB..::..UV
A 2-dimensional position.

Return Value

A new PointOnFace object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument faceReference or uv is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewPointRelativeToPoint Method

[image]

Revit 2024 API
Application..::..NewPointRelativeToPoint Method
Application Class See Also Send Feedback
Create a PointRelativeToPoint object, which is used to define the placement of a ReferencePoint relative to a host point.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public PointRelativeToPoint NewPointRelativeToPoint(
    Reference hostPointReference
)
Visual Basic
Public Function NewPointRelativeToPoint ( _
    hostPointReference As Reference _
) As PointRelativeToPoint
Visual C++
public:
PointRelativeToPoint^ NewPointRelativeToPoint(
    Reference^ hostPointReference
)

Parameters

hostPointReference
Type: Autodesk.Revit.DB..::..Reference
The reference of the host point.

Return Value

If creation is successful then a new PointRelativeToPoint object is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument hostPointReference is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewProjectPosition Method

[image]

Revit 2024 API
Application..::..NewProjectPosition Method
Application Class See Also Send Feedback
Creates a new project position object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ProjectPosition NewProjectPosition(
    double ew,
    double ns,
    double elevation,
    double angle
)
Visual Basic
Public Function NewProjectPosition ( _
    ew As Double, _
    ns As Double, _
    elevation As Double, _
    angle As Double _
) As ProjectPosition
Visual C++
public:
ProjectPosition^ NewProjectPosition(
    double ew,
    double ns,
    double elevation,
    double angle
)

Parameters

ew
Type: System..::..Double
East to West offset in feet.
ns
Type: System..::..Double
North to South offset in feet.
elevation
Type: System..::..Double
Elevation above sea level in feet.
angle
Type: System..::..Double
Rotation angle away from true north in the range of -PI to +PI.

Remarks

This object contains offset information and is used by the project location object for setting the project location relative to the site location. Measurements are in feet and radians.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewReferenceArray Method

[image]

Revit 2024 API
Application..::..NewReferenceArray Method
Application Class See Also Send Feedback
Creates a new instance of a reference array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ReferenceArray NewReferenceArray()
Visual Basic
Public Function NewReferenceArray As ReferenceArray
Visual C++
public:
ReferenceArray^ NewReferenceArray()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewReferencePointArray Method

[image]

Revit 2024 API
Application..::..NewReferencePointArray Method
Application Class See Also Send Feedback
Creates an empty array that can store ReferencePoint objects.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ReferencePointArray NewReferencePointArray()
Visual Basic
Public Function NewReferencePointArray As ReferencePointArray
Visual C++
public:
ReferencePointArray^ NewReferencePointArray()

Return Value

An empty array that can hold ReferencePoint objects.

Remarks

This method can be used to create an array that can hold ReferencePoint objects. This array can be then passed to methods, such as NewCurveByPoints, to represent two or more PointElements.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewTypeBinding Method

[image] [image]

Revit 2024 API
Application..::..NewTypeBinding Method
Application Class See Also Send Feedback
Creates a new type binding object.

Overload List

 | Name | Description
Public method | NewTypeBinding()()()() | Creates a new empty type binding object.
Public method | NewTypeBinding(CategorySet) | Creates a new type binding object containing the categories passed as a parameter.

See Also

Application Class
Application Members
Autodesk.Revit.Creation Namespace


NewTypeBinding Method

[image]

Revit 2024 API
Application..::..NewTypeBinding Method
Application Class See Also Send Feedback
Creates a new empty type binding object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public TypeBinding NewTypeBinding()
Visual Basic
Public Function NewTypeBinding As TypeBinding
Visual C++
public:
TypeBinding^ NewTypeBinding()

Return Value

A new type binding object.

Remarks

Type binding objects are used for attaching shared parameter definitions to a type within a category. Categories can be added to the instance binding via the Categories property of the InstanceBinding object

See Also

Application Class
NewTypeBinding Overload
Autodesk.Revit.Creation Namespace


NewTypeBinding Method (CategorySet)

[image]

Revit 2024 API
Application..::..NewTypeBinding Method (CategorySet)
Application Class See Also Send Feedback
Creates a new type binding object containing the categories passed as a parameter.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public TypeBinding NewTypeBinding(
    CategorySet categorySet
)
Visual Basic
Public Function NewTypeBinding ( _
    categorySet As CategorySet _
) As TypeBinding
Visual C++
public:
TypeBinding^ NewTypeBinding(
    CategorySet^ categorySet
)

Parameters

categorySet
Type: Autodesk.Revit.DB..::..CategorySet
A set of categories that will be added to the binding.

Return Value

A new type binding object.

Remarks

Type binding objects are used for attaching shared parameter definitions to a type within a category.

See Also

Application Class
NewTypeBinding Overload
Autodesk.Revit.Creation Namespace


NewUV Method

[image] [image]

Revit 2024 API
Application..::..NewUV Method
Application Class See Also Send Feedback
Creates a UV object representing coordinates in 2-space.

Overload List

 | Name | Description
Public method | NewUV()()()() | Creates a UV object at the origin.
Public method | NewUV(UV) | Creates a UV object by copying the supplied UV object.
Public method | NewUV(Double, Double) | Creates a UV object representing coordinates in 2-space with supplied values.

See Also

Application Class
Application Members
Autodesk.Revit.Creation Namespace


NewUV Method

[image]

Revit 2024 API
Application..::..NewUV Method
Application Class See Also Send Feedback
Creates a UV object at the origin.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public UV NewUV()
Visual Basic
Public Function NewUV As UV
Visual C++
public:
UV^ NewUV()

See Also

Application Class
NewUV Overload
Autodesk.Revit.Creation Namespace


NewUV Method (UV)

[image]

Revit 2024 API
Application..::..NewUV Method (UV)
Application Class See Also Send Feedback
Creates a UV object by copying the supplied UV object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public UV NewUV(
    UV uv
)
Visual Basic
Public Function NewUV ( _
    uv As UV _
) As UV
Visual C++
public:
UV^ NewUV(
    UV^ uv
)

Parameters

uv
Type: Autodesk.Revit.DB..::..UV
The supplied UV object

See Also

Application Class
NewUV Overload
Autodesk.Revit.Creation Namespace


NewUV Method (Double, Double)

[image]

Revit 2024 API
Application..::..NewUV Method (Double, Double)
Application Class See Also Send Feedback
Creates a UV object representing coordinates in 2-space with supplied values.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public UV NewUV(
    double u,
    double v
)
Visual Basic
Public Function NewUV ( _
    u As Double, _
    v As Double _
) As UV
Visual C++
public:
UV^ NewUV(
    double u,
    double v
)

Parameters

u
Type: System..::..Double
The first coordinate.
v
Type: System..::..Double
The second coordinate.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when setting an infinite number to the U or V property.

See Also

Application Class
NewUV Overload
Autodesk.Revit.Creation Namespace


NewVertexIndexPair Method

[image]

Revit 2024 API
Application..::..NewVertexIndexPair Method
Application Class See Also Send Feedback
Creates a new VertexIndexPair object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public VertexIndexPair NewVertexIndexPair(
    int iTop,
    int iBottom
)
Visual Basic
Public Function NewVertexIndexPair ( _
    iTop As Integer, _
    iBottom As Integer _
) As VertexIndexPair
Visual C++
public:
VertexIndexPair^ NewVertexIndexPair(
    int iTop,
    int iBottom
)

Parameters

iTop
Type: System..::..Int32
The index of the vertex pair from the top profile of a blend.
iBottom
Type: System..::..Int32
The index of the vertex pair from the bottom profile of a blend.

Return Value

The new VertexIndexPair object.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewXYZ Method

[image] [image]

Revit 2024 API
Application..::..NewXYZ Method
Application Class See Also Send Feedback
Creates a XYZ object representing coordinates in 3-space.

Overload List

 | Name | Description
Public method | NewXYZ()()()() | Creates a XYZ object at the origin.
Public method | NewXYZ(XYZ) | Creates a XYZ object by copying the supplied XYZ object.
Public method | NewXYZ(Double, Double, Double) | Creates a XYZ object representing coordinates in 3-space with supplied values.

See Also

Application Class
Application Members
Autodesk.Revit.Creation Namespace


NewXYZ Method (XYZ)

[image]

Revit 2024 API
Application..::..NewXYZ Method (XYZ)
Application Class See Also Send Feedback
Creates a XYZ object by copying the supplied XYZ object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ NewXYZ(
    XYZ xyz
)
Visual Basic
Public Function NewXYZ ( _
    xyz As XYZ _
) As XYZ
Visual C++
public:
XYZ^ NewXYZ(
    XYZ^ xyz
)

Parameters

xyz
Type: Autodesk.Revit.DB..::..XYZ
The supplied XYZ object

See Also

Application Class
NewXYZ Overload
Autodesk.Revit.Creation Namespace


NewXYZ Method (Double, Double, Double)

[image]

Revit 2024 API
Application..::..NewXYZ Method (Double, Double, Double)
Application Class See Also Send Feedback
Creates a XYZ object representing coordinates in 3-space with supplied values.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ NewXYZ(
    double x,
    double y,
    double z
)
Visual Basic
Public Function NewXYZ ( _
    x As Double, _
    y As Double, _
    z As Double _
) As XYZ
Visual C++
public:
XYZ^ NewXYZ(
    double x,
    double y,
    double z
)

Parameters

x
Type: System..::..Double
The first coordinate.
y
Type: System..::..Double
The second coordinate.
z
Type: System..::..Double
The third coordinate.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when setting an infinite number to the X, Y or Z property.

See Also

Application Class
NewXYZ Overload
Autodesk.Revit.Creation Namespace


AreaCreationData Class

[image]

Revit 2024 API
AreaCreationData Class
Members See Also Send Feedback
A class which wraps the arguments of Area for batch creation

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class AreaCreationData
Visual Basic
Public Class AreaCreationData
Visual C++
public ref class AreaCreationData

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.Creation..::..AreaCreationData

See Also

AreaCreationData Members
Autodesk.Revit.Creation Namespace


AreaCreationData Members

[image] [image]

Revit 2024 API
AreaCreationData Members
AreaCreationData Class Constructors Methods Properties See Also Send Feedback

The AreaCreationData type exposes the following members.

Constructors

 | Name | Description
Public method | AreaCreationData(Object) | Initializes a new instance of the AreaCreationData class
Public method | AreaCreationData(ViewPlan, UV) | The data needed to create a new area

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | TagPoint | Specify the location of the area tag.

See Also

AreaCreationData Class
Autodesk.Revit.Creation Namespace


AreaCreationData Constructor (Object)

[image]

Revit 2024 API
AreaCreationData Constructor (Object)
AreaCreationData Class See Also Send Feedback
Initializes a new instance of the AreaCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public AreaCreationData(
    Object proxy
)
Visual Basic
Public Sub New ( _
    proxy As Object _
)
Visual C++
public:
AreaCreationData(
    Object^ proxy
)

Parameters

proxy
Type: System..::..Object

See Also

AreaCreationData Class
AreaCreationData Overload
Autodesk.Revit.Creation Namespace


AreaCreationData Constructor (ViewPlan, UV)

[image]

Revit 2024 API
AreaCreationData Constructor (ViewPlan, UV)
AreaCreationData Class See Also Send Feedback
The data needed to create a new area

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public AreaCreationData(
    ViewPlan areaView,
    UV point
)
Visual Basic
Public Sub New ( _
    areaView As ViewPlan, _
    point As UV _
)
Visual C++
public:
AreaCreationData(
    ViewPlan^ areaView,
    UV^ point
)

Parameters

areaView
Type: Autodesk.Revit.DB..::..ViewPlan
The view of area element.
point
Type: Autodesk.Revit.DB..::..UV
The point which lies in the enclosed region of AreaBoundaryLines to put the new created Area

See Also

AreaCreationData Class
AreaCreationData Overload
Autodesk.Revit.Creation Namespace


AreaCreationData Methods

[image] [image]

Revit 2024 API
AreaCreationData Methods
AreaCreationData Class See Also Send Feedback

The AreaCreationData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

AreaCreationData Class
Autodesk.Revit.Creation Namespace


AreaCreationData Properties

[image] [image]

Revit 2024 API
AreaCreationData Properties
AreaCreationData Class See Also Send Feedback

The AreaCreationData type exposes the following members.

Properties

 | Name | Description
Public property | TagPoint | Specify the location of the area tag.

See Also

AreaCreationData Class
Autodesk.Revit.Creation Namespace


TagPoint Property

[image]

Revit 2024 API
AreaCreationData..::..TagPoint Property
AreaCreationData Class See Also Send Feedback
Specify the location of the area tag.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public UV TagPoint { get; set; }
Visual Basic
Public Property TagPoint As UV
    Get
    Set
Visual C++
public:
property UV^ TagPoint {
    UV^ get ();
    void set (UV^ value);
}

See Also

AreaCreationData Class
Autodesk.Revit.Creation Namespace


Document Class

[image]

Revit 2024 API
Document Class
Members See Also Send Feedback
The Document Creation object is used to create new instances of elements within the Autodesk Revit project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class Document : ItemFactoryBase
Visual Basic
Public Class Document _
    Inherits ItemFactoryBase
Visual C++
public ref class Document : public ItemFactoryBase

Remarks

The Document Creation object is a utility object that is used to create new instances of elements within the Autodesk Revit project. This object, available from the Document.Create property should be used to create elements instead of using New. This object ensures that the elements created are added to the document correctly.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.Creation..::..ItemFactoryBase
Autodesk.Revit.Creation..::..Document

See Also

Document Members
Autodesk.Revit.Creation Namespace


Document Members

[image] [image]

Revit 2024 API
Document Members
Document Class Methods Properties See Also Send Feedback

The Document type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NewAlignment | Add a new locked alignment into the Autodesk Revit document. (Inherited from ItemFactoryBase.)
Public method | NewArea | Creates a new area
Public method | NewAreaBoundaryConditions(Element, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) | Creates a new Area BoundaryConditions element on a host element.
Public method | NewAreaBoundaryConditions(Reference, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) | Creates a new Area BoundaryConditions element on a reference.
Public method | NewAreaBoundaryLine | Creates a new boundary line as an Area border.
Public method | NewAreas | Creates new areas
Public method | NewAreaTag | Creates a new area tag.
Public method | NewCrossFitting | Add a new family instance of a cross fitting into the Autodesk Revit document, using four connectors.
Public method | NewCurtainSystem | Creates a new CurtainSystem element from a set of faces.
Public method | NewCurtainSystem2 | Creates a new CurtainSystem element from a set of face references.
Public method | NewDetailCurve | Creates a new detail curve element. (Inherited from ItemFactoryBase.)
Public method | NewDetailCurveArray | Creates an array of new detail curve elements. (Inherited from ItemFactoryBase.)
Public method | NewDimension(View, Line, ReferenceArray) | Creates a new linear dimension object using the default dimension style. (Inherited from ItemFactoryBase.)
Public method | NewDimension(View, Line, ReferenceArray, DimensionType) | Creates a new linear dimension object using the specified dimension style. (Inherited from ItemFactoryBase.)
Public method | NewElbowFitting | Add a new family instance of an elbow fitting into the Autodesk Revit document, using two connectors.
Public method | NewExtrusionRoof | Creates a new Extrusion Roof.
Public method | NewFamilyInstance(Face, Line, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a line on that face for its position, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Line, FamilySymbol, View) | Add a line based detail family instance into the Autodesk Revit document, using an line and a view where the instance should be placed. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Reference, Line, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a line on that face for its position, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, StructuralType) | Inserts a new instance of a family into the document, using a location and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, View) | Add a new family instance into the Autodesk Revit document, using an origin and a view where the instance should be placed. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Curve, FamilySymbol, Level, StructuralType) | Inserts a new instance of a family into the document, using a curve, type/symbol and reference level.
Public method | NewFamilyInstance(Face, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a location, reference direction, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Reference, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a location, reference direction, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the host element. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, Level, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the level. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, Element, Level, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a base level.
Public method | NewFamilyInstance(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a reference direction. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstances2 | Creates Family instances within the document. (Inherited from ItemFactoryBase.)
Public method | NewFascia(FasciaType, Reference) | Creates a fascia along a reference.
Public method | NewFascia(FasciaType, ReferenceArray) | Creates a fascia along a reference array.
Public method | NewFlexDuct(IList<(Of <<'(XYZ>)>>), FlexDuctType) | Adds a new flexible duct into the document, using a point array and duct type.
Public method | NewFlexDuct(Connector, Connector, FlexDuctType) | Adds a new flexible duct into the document, using two connector, and duct type.
Public method | NewFlexDuct(Connector, IList<(Of <<'(XYZ>)>>), FlexDuctType) | Adds a new flexible duct into the document, using a connector, point array and duct type.
Public method | NewFlexPipe(IList<(Of <<'(XYZ>)>>), FlexPipeType) | Adds a new flexible pipe into the document, using a point array and pipe type.
Public method | NewFlexPipe(Connector, Connector, FlexPipeType) | Adds a new flexible pipe into the document, using two connector, and flexible pipe type.
Public method | NewFlexPipe(Connector, IList<(Of <<'(XYZ>)>>), FlexPipeType) | Adds a new flexible pipe into the document, using a connector, point array and pipe type.
Public method | NewFootPrintRoof | Creates a new FootPrintRoof element.
Public method | NewGroup | Creates a new type of group. (Inherited from ItemFactoryBase.)
Public method | NewGutter(GutterType, Reference) | Creates a gutter along a reference.
Public method | NewGutter(GutterType, ReferenceArray) | Creates a gutter along a reference array.
Public method | NewLineBoundaryConditions(Element, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) | Creates a new Line BoundaryConditions element on a host element.
Public method | NewLineBoundaryConditions(Reference, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) | Creates a new Line BoundaryConditions element on a reference.
Public method | NewMechanicalSystem | Creates a new MEP mechanical system element.
Public method | NewModelCurve | Creates a new model line element. (Inherited from ItemFactoryBase.)
Public method | NewModelCurveArray | Creates an array of new model line elements. (Inherited from ItemFactoryBase.)
Public method | NewOpening(Element, CurveArray, eRefFace) | Creates a new opening in a beam, brace and column.
Public method | NewOpening(Element, CurveArray, Boolean) | Creates a new opening in a roof, floor and ceiling.
Public method | NewOpening(Level, Level, CurveArray) | Creates a new shaft opening between a set of levels.
Public method | NewOpening(Wall, XYZ, XYZ) | Creates a rectangular opening on a wall.
Public method | NewPipingSystem | Creates a new MEP piping system element.
Public method | NewPointBoundaryConditions | Creates a new Point BoundaryConditions Element.
Public method | NewReferencePlane | Creates a new instance of ReferencePlane. (Inherited from ItemFactoryBase.)
Public method | NewReferencePlane2 | Creates a new instance of ReferencePlane. (Inherited from ItemFactoryBase.)
Public method | NewRoom(Phase) | Creates a new unplaced room and with an assigned phase.
Public method | NewRoom(Level, UV) | Creates a new room on a level at a specified point.
Public method | NewRoom(Room, PlanCircuit) | Creates a new room within the confines of a plan circuit, or places an unplaced room within the confines of the plan circuit.
Public method | NewRoomBoundaryLines | Creates a new boundary line as an Room border.
Public method | NewRooms2(Level) | Creates new rooms in each plan circuit found in the given level in the last phase.
Public method | NewRooms2(Level, Phase) | Creates new rooms in each plan circuit found in the given level in the given phase.
Public method | NewRooms2(Phase, Int32) | Creates new unplaced rooms in the given phase.
Public method | NewRoomTag | Creates a new RoomTag referencing a room in the host model or in a Revit link.
Public method | NewSlabEdge(SlabEdgeType, Reference) | Creates a slab edge along a reference.
Public method | NewSlabEdge(SlabEdgeType, ReferenceArray) | Creates a slab edge along a reference array.
Public method | NewSpace(Phase) | Creates a new unplaced space on a given phase.
Public method | NewSpace(Level, UV) | Creates a new space element on the given level at the given location.
Public method | NewSpace(Level, Phase, UV) | Creates a new space element on the given level, at the given location, and assigned to the given phase.
Public method | NewSpaceBoundaryLines | Creates a new boundary line as an Space border.
Public method | NewSpaces2(Phase, Int32) | Creates a set of new unplaced spaces on a given phase.
Public method | NewSpaces2(Level, Phase, View) | Creates new spaces on the available plan circuits of a the given level.
Public method | NewSpaceTag | Creates a new SpaceTag.
Public method | NewSpotCoordinate | Generate a new spot coordinate object within the project.
Public method | NewSpotElevation | Generate a new spot elevation object within the project.
Public method | NewTakeoffFitting | Add a new family instance of an takeoff fitting into the Autodesk Revit document, using one connector and one MEP curve.
Public method | NewTeeFitting | Add a new family instance of a tee fitting into the Autodesk Revit document, using three connectors.
Public method | NewTransitionFitting | Add a new family instance of an transition fitting into the Autodesk Revit document, using two connectors.
Public method | NewUnionFitting | Add a new family instance of an union fitting into the Autodesk Revit document, using two connectors.
Public method | NewZone | Creates a new Zone element.
Public method | PlaceGroup | Place an instance of a Model Group into the Autodesk Revit document, using a location and a group type. (Inherited from ItemFactoryBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Document Class
Autodesk.Revit.Creation Namespace


Document Methods

[image] [image]

Revit 2024 API
Document Methods
Document Class See Also Send Feedback

The Document type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NewAlignment | Add a new locked alignment into the Autodesk Revit document. (Inherited from ItemFactoryBase.)
Public method | NewArea | Creates a new area
Public method | NewAreaBoundaryConditions(Element, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) | Creates a new Area BoundaryConditions element on a host element.
Public method | NewAreaBoundaryConditions(Reference, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) | Creates a new Area BoundaryConditions element on a reference.
Public method | NewAreaBoundaryLine | Creates a new boundary line as an Area border.
Public method | NewAreas | Creates new areas
Public method | NewAreaTag | Creates a new area tag.
Public method | NewCrossFitting | Add a new family instance of a cross fitting into the Autodesk Revit document, using four connectors.
Public method | NewCurtainSystem | Creates a new CurtainSystem element from a set of faces.
Public method | NewCurtainSystem2 | Creates a new CurtainSystem element from a set of face references.
Public method | NewDetailCurve | Creates a new detail curve element. (Inherited from ItemFactoryBase.)
Public method | NewDetailCurveArray | Creates an array of new detail curve elements. (Inherited from ItemFactoryBase.)
Public method | NewDimension(View, Line, ReferenceArray) | Creates a new linear dimension object using the default dimension style. (Inherited from ItemFactoryBase.)
Public method | NewDimension(View, Line, ReferenceArray, DimensionType) | Creates a new linear dimension object using the specified dimension style. (Inherited from ItemFactoryBase.)
Public method | NewElbowFitting | Add a new family instance of an elbow fitting into the Autodesk Revit document, using two connectors.
Public method | NewExtrusionRoof | Creates a new Extrusion Roof.
Public method | NewFamilyInstance(Face, Line, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a line on that face for its position, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Line, FamilySymbol, View) | Add a line based detail family instance into the Autodesk Revit document, using an line and a view where the instance should be placed. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Reference, Line, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a line on that face for its position, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, StructuralType) | Inserts a new instance of a family into the document, using a location and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, View) | Add a new family instance into the Autodesk Revit document, using an origin and a view where the instance should be placed. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Curve, FamilySymbol, Level, StructuralType) | Inserts a new instance of a family into the document, using a curve, type/symbol and reference level.
Public method | NewFamilyInstance(Face, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a location, reference direction, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Reference, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a location, reference direction, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the host element. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, Level, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the level. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, Element, Level, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a base level.
Public method | NewFamilyInstance(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a reference direction. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstances2 | Creates Family instances within the document. (Inherited from ItemFactoryBase.)
Public method | NewFascia(FasciaType, Reference) | Creates a fascia along a reference.
Public method | NewFascia(FasciaType, ReferenceArray) | Creates a fascia along a reference array.
Public method | NewFlexDuct(IList<(Of <<'(XYZ>)>>), FlexDuctType) | Adds a new flexible duct into the document, using a point array and duct type.
Public method | NewFlexDuct(Connector, Connector, FlexDuctType) | Adds a new flexible duct into the document, using two connector, and duct type.
Public method | NewFlexDuct(Connector, IList<(Of <<'(XYZ>)>>), FlexDuctType) | Adds a new flexible duct into the document, using a connector, point array and duct type.
Public method | NewFlexPipe(IList<(Of <<'(XYZ>)>>), FlexPipeType) | Adds a new flexible pipe into the document, using a point array and pipe type.
Public method | NewFlexPipe(Connector, Connector, FlexPipeType) | Adds a new flexible pipe into the document, using two connector, and flexible pipe type.
Public method | NewFlexPipe(Connector, IList<(Of <<'(XYZ>)>>), FlexPipeType) | Adds a new flexible pipe into the document, using a connector, point array and pipe type.
Public method | NewFootPrintRoof | Creates a new FootPrintRoof element.
Public method | NewGroup | Creates a new type of group. (Inherited from ItemFactoryBase.)
Public method | NewGutter(GutterType, Reference) | Creates a gutter along a reference.
Public method | NewGutter(GutterType, ReferenceArray) | Creates a gutter along a reference array.
Public method | NewLineBoundaryConditions(Element, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) | Creates a new Line BoundaryConditions element on a host element.
Public method | NewLineBoundaryConditions(Reference, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) | Creates a new Line BoundaryConditions element on a reference.
Public method | NewMechanicalSystem | Creates a new MEP mechanical system element.
Public method | NewModelCurve | Creates a new model line element. (Inherited from ItemFactoryBase.)
Public method | NewModelCurveArray | Creates an array of new model line elements. (Inherited from ItemFactoryBase.)
Public method | NewOpening(Element, CurveArray, eRefFace) | Creates a new opening in a beam, brace and column.
Public method | NewOpening(Element, CurveArray, Boolean) | Creates a new opening in a roof, floor and ceiling.
Public method | NewOpening(Level, Level, CurveArray) | Creates a new shaft opening between a set of levels.
Public method | NewOpening(Wall, XYZ, XYZ) | Creates a rectangular opening on a wall.
Public method | NewPipingSystem | Creates a new MEP piping system element.
Public method | NewPointBoundaryConditions | Creates a new Point BoundaryConditions Element.
Public method | NewReferencePlane | Creates a new instance of ReferencePlane. (Inherited from ItemFactoryBase.)
Public method | NewReferencePlane2 | Creates a new instance of ReferencePlane. (Inherited from ItemFactoryBase.)
Public method | NewRoom(Phase) | Creates a new unplaced room and with an assigned phase.
Public method | NewRoom(Level, UV) | Creates a new room on a level at a specified point.
Public method | NewRoom(Room, PlanCircuit) | Creates a new room within the confines of a plan circuit, or places an unplaced room within the confines of the plan circuit.
Public method | NewRoomBoundaryLines | Creates a new boundary line as an Room border.
Public method | NewRooms2(Level) | Creates new rooms in each plan circuit found in the given level in the last phase.
Public method | NewRooms2(Level, Phase) | Creates new rooms in each plan circuit found in the given level in the given phase.
Public method | NewRooms2(Phase, Int32) | Creates new unplaced rooms in the given phase.
Public method | NewRoomTag | Creates a new RoomTag referencing a room in the host model or in a Revit link.
Public method | NewSlabEdge(SlabEdgeType, Reference) | Creates a slab edge along a reference.
Public method | NewSlabEdge(SlabEdgeType, ReferenceArray) | Creates a slab edge along a reference array.
Public method | NewSpace(Phase) | Creates a new unplaced space on a given phase.
Public method | NewSpace(Level, UV) | Creates a new space element on the given level at the given location.
Public method | NewSpace(Level, Phase, UV) | Creates a new space element on the given level, at the given location, and assigned to the given phase.
Public method | NewSpaceBoundaryLines | Creates a new boundary line as an Space border.
Public method | NewSpaces2(Phase, Int32) | Creates a set of new unplaced spaces on a given phase.
Public method | NewSpaces2(Level, Phase, View) | Creates new spaces on the available plan circuits of a the given level.
Public method | NewSpaceTag | Creates a new SpaceTag.
Public method | NewSpotCoordinate | Generate a new spot coordinate object within the project.
Public method | NewSpotElevation | Generate a new spot elevation object within the project.
Public method | NewTakeoffFitting | Add a new family instance of an takeoff fitting into the Autodesk Revit document, using one connector and one MEP curve.
Public method | NewTeeFitting | Add a new family instance of a tee fitting into the Autodesk Revit document, using three connectors.
Public method | NewTransitionFitting | Add a new family instance of an transition fitting into the Autodesk Revit document, using two connectors.
Public method | NewUnionFitting | Add a new family instance of an union fitting into the Autodesk Revit document, using two connectors.
Public method | NewZone | Creates a new Zone element.
Public method | PlaceGroup | Place an instance of a Model Group into the Autodesk Revit document, using a location and a group type. (Inherited from ItemFactoryBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewAreaBoundaryConditions Method

[image] [image]

Revit 2024 API
Document..::..NewAreaBoundaryConditions Method
Document Class See Also Send Feedback
Creates a new Area BoundaryConditions element.

Overload List

 | Name | Description
Public method | NewAreaBoundaryConditions(Element, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) | Creates a new Area BoundaryConditions element on a host element.
Public method | NewAreaBoundaryConditions(Reference, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) | Creates a new Area BoundaryConditions element on a reference.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewAreaBoundaryConditions Method (Reference, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double)

[image]

Revit 2024 API
Document..::..NewAreaBoundaryConditions Method (Reference, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double)
Document Class Example See Also Send Feedback
Creates a new Area BoundaryConditions element on a reference.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public BoundaryConditions NewAreaBoundaryConditions(
    Reference reference,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus
)
Visual Basic
Public Function NewAreaBoundaryConditions ( _
    reference As Reference, _
    X_Translation As TranslationRotationValue, _
    X_TranslationSpringModulus As Double, _
    Y_Translation As TranslationRotationValue, _
    Y_TranslationSpringModulus As Double, _
    Z_Translation As TranslationRotationValue, _
    Z_TranslationSpringModulus As Double _
) As BoundaryConditions
Visual C++
public:
BoundaryConditions^ NewAreaBoundaryConditions(
    Reference^ reference,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus
)

Parameters

reference
Type: Autodesk.Revit.DB..::..Reference
The Geometry reference obtained from a Wall, Slab or Slab Foundation.
X_Translation
Type: Autodesk.Revit.DB.Structure..::..TranslationRotationValue
A value indicating the X axis translation option.
X_TranslationSpringModulus
Type: System..::..Double
Translation Spring Modulus for X axis. Ignored if X_Translation is not "Spring".
Y_Translation
Type: Autodesk.Revit.DB.Structure..::..TranslationRotationValue
A value indicating the Y axis translation option.
Y_TranslationSpringModulus
Type: System..::..Double
Translation Spring Modulus for Y axis. Ignored if Y_Translation is not "Spring".
Z_Translation
Type: Autodesk.Revit.DB.Structure..::..TranslationRotationValue
A value indicating the Z axis translation option.
Z_TranslationSpringModulus
Type: System..::..Double
Translation Spring Modulus for Z axis. Ignored if Z_Translation is not "Spring".

Return Value

If successful, NewAreaBoundaryConditions returns an object for the newly created BoundaryConditions with the BoundaryType = 2 - "Area". nullNothingnullptra null reference (Nothing in Visual Basic) is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

Examples

CopyC#
bool CreateAreaConditionWithReference(AnalyticalPanel wall, Autodesk.Revit.Creation.Document docCreation)
{
   // Get the Geometry reference to the wall
   Reference profileReference = null;
   if (null == wall)
   {
      return false; // the profile reference can't be retrieved.
   }

   // loop through the curves of the wall and get the first one as a reference
   foreach (Curve curve in wall.GetOuterContour())
   {
      AnalyticalModelSelector selector = new AnalyticalModelSelector(curve);

      profileReference = wall.GetReference(selector);
      if (null != profileReference)
      {
         break;
      }
   }
   BoundaryConditions condition = null;
   // Create the Area Boundary Conditions if we have a profileReference
   if (null != profileReference)
   {
      // Create Area Boundary Conditions with profile reference.
      condition = docCreation.NewAreaBoundaryConditions(profileReference, TranslationRotationValue.Fixed, 0,
                                                                          TranslationRotationValue.Fixed, 0,
                                                                          TranslationRotationValue.Fixed, 0);
   }
   return (null != condition);
}
CopyVB.NET
Private Function CreateAreaConditionWithReference(wall As Wall, docCreation As Autodesk.Revit.Creation.Document) As Boolean
   ' Get the Geometry reference to the wall
   Dim profileReference As Reference = Nothing
   Dim document As Document = wall.Document
   Dim analytical As Autodesk.Revit.DB.Structure.AnalyticalPanel = Nothing
   Dim relManager As Autodesk.Revit.DB.Structure.AnalyticalToPhysicalAssociationManager = Autodesk.Revit.DB.Structure.AnalyticalToPhysicalAssociationManager.GetAnalyticalToPhysicalAssociationManager(document)

   If (relManager Is Nothing) Then
      Return False
   End If

   Dim counterpartId As ElementId = relManager.GetAssociatedElementId(wall.Id)
   If (counterpartId Is Nothing) Then
      Return False
   End If

   analytical = document.GetElement(counterpartId)
   If analytical Is Nothing Then
      ' the profile reference can't be retrieved.
      Return False
   End If

   ' loop through the curves of the wall and get the first one as a reference
   For Each curve As Curve In analytical.GetOuterContour().ToList()
      profileReference = curve.Reference
      If profileReference IsNot Nothing Then
         Exit For
      End If
   Next

   Dim condition As BoundaryConditions = Nothing
   ' Create the Area Boundary Conditions if we have a profileReference
   If profileReference IsNot Nothing Then
      ' Create Area Boundary Conditions with profile reference.
      condition = docCreation.NewAreaBoundaryConditions(profileReference, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed,
              0)
   End If
   Return (condition IsNot Nothing)
End Function

See Also

Document Class
NewAreaBoundaryConditions Overload
Autodesk.Revit.Creation Namespace


NewAreaBoundaryLine Method

[image]

Revit 2024 API
Document..::..NewAreaBoundaryLine Method
Document Class See Also Send Feedback
Creates a new boundary line as an Area border.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ModelCurve NewAreaBoundaryLine(
    SketchPlane sketchPlane,
    Curve geometryCurve,
    ViewPlan areaView
)
Visual Basic
Public Function NewAreaBoundaryLine ( _
    sketchPlane As SketchPlane, _
    geometryCurve As Curve, _
    areaView As ViewPlan _
) As ModelCurve
Visual C++
public:
ModelCurve^ NewAreaBoundaryLine(
    SketchPlane^ sketchPlane,
    Curve^ geometryCurve,
    ViewPlan^ areaView
)

Parameters

sketchPlane
Type: Autodesk.Revit.DB..::..SketchPlane
The sketch plane.
geometryCurve
Type: Autodesk.Revit.DB..::..Curve
The geometry curve on which the boundary line are
areaView
Type: Autodesk.Revit.DB..::..ViewPlan
The View for the new Area

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the sketch plane does not exist in the given document.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the area view does not exist in the given document.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewAreas Method

[image]

Revit 2024 API
Document..::..NewAreas Method
Document Class See Also Send Feedback
Creates new areas

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElementSet NewAreas(
    List<AreaCreationData> dataList
)
Visual Basic
Public Function NewAreas ( _
    dataList As List(Of AreaCreationData) _
) As ElementSet
Visual C++
public:
ElementSet^ NewAreas(
    List<AreaCreationData^>^ dataList
)

Parameters

dataList
Type: System.Collections.Generic..::..List<(Of <(<' AreaCreationData >)>)>
A list of AreaCreationData which wraps the creation arguments of the areas to be created.

Return Value

If successful an Element Set which contains the areas should be returned, otherwise the exception will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | If AreaCreationData's areaPoint is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the area cannot be created successfully or the phase is invalid or regeneration fails at the end of the batch creation.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewAreaTag Method

[image]

Revit 2024 API
Document..::..NewAreaTag Method
Document Class See Also Send Feedback
Creates a new area tag.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public AreaTag NewAreaTag(
    ViewPlan areaView,
    Area room,
    UV point
)
Visual Basic
Public Function NewAreaTag ( _
    areaView As ViewPlan, _
    room As Area, _
    point As UV _
) As AreaTag
Visual C++
public:
AreaTag^ NewAreaTag(
    ViewPlan^ areaView,
    Area^ room,
    UV^ point
)

Parameters

areaView
Type: Autodesk.Revit.DB..::..ViewPlan
The area view
room
Type: Autodesk.Revit.DB..::..Area
The area to tag
point
Type: Autodesk.Revit.DB..::..UV
The position of the area tag

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the area view does not exist in the given document.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the area does not exist in the given document.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewCurtainSystem Method

[image]

Revit 2024 API
Document..::..NewCurtainSystem Method
Document Class See Also Send Feedback
Creates a new CurtainSystem element from a set of faces.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CurtainSystem NewCurtainSystem(
    FaceArray faces,
    CurtainSystemType curtainSystemType
)
Visual Basic
Public Function NewCurtainSystem ( _
    faces As FaceArray, _
    curtainSystemType As CurtainSystemType _
) As CurtainSystem
Visual C++
public:
CurtainSystem^ NewCurtainSystem(
    FaceArray^ faces,
    CurtainSystemType^ curtainSystemType
)

Parameters

faces
Type: Autodesk.Revit.DB..::..FaceArray
The faces new CurtainSystem will be created on.
curtainSystemType
Type: Autodesk.Revit.DB..::..CurtainSystemType
The Type of CurtainSystem to be created.

Return Value

The CurtainSystem created will be returned when the operation succeeds.

Remarks

The input faces will be copied during the operations so that they can be any faces.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown in following cases: The input argument faces or curtainSystemType is nullNothingnullptra null reference (Nothing in Visual Basic). The size of faces is zero.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the CurtainSystem cannot be created or regenerate fails.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the curtain system type does not exist in the given document.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewDimension Method

[image] [image]

Revit 2024 API
Document..::..NewDimension Method
Document Class See Also Send Feedback
Creates a new linear dimension object.

Overload List

 | Name | Description
Public method | NewDimension(View, Line, ReferenceArray) | Creates a new linear dimension object using the default dimension style. (Inherited from ItemFactoryBase.)
Public method | NewDimension(View, Line, ReferenceArray, DimensionType) | Creates a new linear dimension object using the specified dimension style. (Inherited from ItemFactoryBase.)

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewElbowFitting Method

[image]

Revit 2024 API
Document..::..NewElbowFitting Method
Document Class See Also Send Feedback
Add a new family instance of an elbow fitting into the Autodesk Revit document, using two connectors.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyInstance NewElbowFitting(
    Connector connector1,
    Connector connector2
)
Visual Basic
Public Function NewElbowFitting ( _
    connector1 As Connector, _
    connector2 As Connector _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewElbowFitting(
    Connector^ connector1,
    Connector^ connector2
)

Parameters

connector1
Type: Autodesk.Revit.DB..::..Connector
The first connector to be connected to the elbow.
connector2
Type: Autodesk.Revit.DB..::..Connector
The second connector to be connected to the elbow.

Return Value

If creation was successful then an family instance to the new object is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument connector1 or connector2 is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the connectors cannot be used for the elbow creation. For example, they cannot be from the same element, they must be of the same domain, and the angle between them must fall within the valid range (typically 2 to 95 degrees).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when an elbow fitting cannot be created because the angle between the two connectors is too large or too small, the connectors are not close enough together, or the connectors are placed at positions with too high of a tolerance.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method

[image] [image]

Revit 2024 API
Document..::..NewFamilyInstance Method
Document Class See Also Send Feedback
Inserts a new instance of a family into the document.

Overload List

 | Name | Description
Public method | NewFamilyInstance(Face, Line, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a line on that face for its position, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Line, FamilySymbol, View) | Add a line based detail family instance into the Autodesk Revit document, using an line and a view where the instance should be placed. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Reference, Line, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a line on that face for its position, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, StructuralType) | Inserts a new instance of a family into the document, using a location and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, View) | Add a new family instance into the Autodesk Revit document, using an origin and a view where the instance should be placed. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Curve, FamilySymbol, Level, StructuralType) | Inserts a new instance of a family into the document, using a curve, type/symbol and reference level.
Public method | NewFamilyInstance(Face, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a location, reference direction, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Reference, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a location, reference direction, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the host element. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, Level, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the level. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, Element, Level, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a base level.
Public method | NewFamilyInstance(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a reference direction. (Inherited from ItemFactoryBase.)

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method (XYZ, FamilySymbol, Element, Level, StructuralType)

[image]

Revit 2024 API
Document..::..NewFamilyInstance Method (XYZ, FamilySymbol, Element, Level, StructuralType)
Document Class Example See Also Send Feedback
Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a base level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyInstance NewFamilyInstance(
    XYZ location,
    FamilySymbol symbol,
    Element host,
    Level level,
    StructuralType structuralType
)
Visual Basic
Public Function NewFamilyInstance ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    host As Element, _
    level As Level, _
    structuralType As StructuralType _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    XYZ^ location,
    FamilySymbol^ symbol,
    Element^ host,
    Level^ level,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.DB..::..XYZ
The physical location where the instance is to be placed on the specified level.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
host
Type: Autodesk.Revit.DB..::..Element
A host object into which the instance will be embedded
level
Type: Autodesk.Revit.DB..::..Level
A Level object that is used as the base level for the object.
structuralType
Type: Autodesk.Revit.DB.Structure..::..StructuralType
If structural then specify the type of the component.

Return Value

If creation was successful then an instance to the new object is returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

This form of NewFamilyInstance is the most commonly used in Autodesk Revit since there are a large number of elements that use levels, such as Walls, Columns etc. If the instance fails to be created an exception may be thrown.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

All levels within the document can be found by iterating over the entire document and searching for objects of type Autodesk.Revit.Elements.Level.

Some Families, such as Beams, have more than one endpoint and are inserted in the same manner as single point instances. Once inserted these linear family instances can have their endpoints changed by using the instance's Element.Location property.

Note: ForbiddenForDynamicUpdateException might be thrown during a dynamic update if the inserted instance establishes a mutual dependency with another structure.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call.

Examples

CopyC#
void CreateDoorsInWall(Autodesk.Revit.DB.Document document, Wall wall)
{
    // get wall's level for door creation
    Level level = document.GetElement(wall.LevelId) as Level;

    FilteredElementCollector collector = new FilteredElementCollector(document);
    ICollection<Element> collection = collector.OfClass(typeof(FamilySymbol))
                                               .OfCategory(BuiltInCategory.OST_Doors)
                                               .ToElements();
    IEnumerator<Element> symbolItor = collection.GetEnumerator();

    double x = 0, y = 0, z = 0;
    while (symbolItor.MoveNext())
    {
        FamilySymbol symbol = symbolItor.Current as FamilySymbol;
        XYZ location = new XYZ(x, y, z);
        FamilyInstance instance = document.Create.NewFamilyInstance(location, symbol, wall, level, StructuralType.NonStructural);
        x += 10;
        y += 10;
        z += 1.5;
    }
}
CopyVB.NET
Private Sub CreateDoorsInWall(document As Autodesk.Revit.DB.Document, wall As Wall)
    ' get wall's level for door creation
    Dim level As Level = TryCast(document.GetElement(wall.LevelId), Level)

    Dim collector As New FilteredElementCollector(document)
    Dim collection As ICollection(Of Element) = collector.OfClass(GetType(FamilySymbol)).OfCategory(BuiltInCategory.OST_Doors).ToElements()
    Dim symbolItor As IEnumerator(Of Element) = collection.GetEnumerator()

    Dim x As Double = 0, y As Double = 0, z As Double = 0
    While symbolItor.MoveNext()
        Dim symbol As FamilySymbol = TryCast(symbolItor.Current, FamilySymbol)
        Dim location As New XYZ(x, y, z)
        Dim instance As FamilyInstance = document.Create.NewFamilyInstance(location, symbol, wall, level, StructuralType.NonStructural)
        x += 10
        y += 10
        z += 1.5
    End While
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the family symbol does not exist in the given document.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the host does not exist in the given document.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the level does not exist in the given document.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if The symbol is not active.

See Also

Document Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace


NewFascia Method

[image] [image]

Revit 2024 API
Document..::..NewFascia Method
Document Class See Also Send Feedback
Creates a fascia.

Overload List

 | Name | Description
Public method | NewFascia(FasciaType, Reference) | Creates a fascia along a reference.
Public method | NewFascia(FasciaType, ReferenceArray) | Creates a fascia along a reference array.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewFascia Method (FasciaType, Reference)

[image]

Revit 2024 API
Document..::..NewFascia Method (FasciaType, Reference)
Document Class See Also Send Feedback
Creates a fascia along a reference.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Fascia NewFascia(
    FasciaType FasciaType,
    Reference reference
)
Visual Basic
Public Function NewFascia ( _
    FasciaType As FasciaType, _
    reference As Reference _
) As Fascia
Visual C++
public:
Fascia^ NewFascia(
    FasciaType^ FasciaType,
    Reference^ reference
)

Parameters

FasciaType
Type: Autodesk.Revit.DB.Architecture..::..FasciaType
The type of the fascia to create
reference
Type: Autodesk.Revit.DB..::..Reference
A planar line or arc that represents the place where you want to place the fascia.

Return Value

If successful a new fascia object within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the fascia type does not exist in the given document.

See Also

Document Class
NewFascia Overload
Autodesk.Revit.Creation Namespace


NewFascia Method (FasciaType, ReferenceArray)

[image]

Revit 2024 API
Document..::..NewFascia Method (FasciaType, ReferenceArray)
Document Class See Also Send Feedback
Creates a fascia along a reference array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Fascia NewFascia(
    FasciaType FasciaType,
    ReferenceArray references
)
Visual Basic
Public Function NewFascia ( _
    FasciaType As FasciaType, _
    references As ReferenceArray _
) As Fascia
Visual C++
public:
Fascia^ NewFascia(
    FasciaType^ FasciaType,
    ReferenceArray^ references
)

Parameters

FasciaType
Type: Autodesk.Revit.DB.Architecture..::..FasciaType
The type of the fascia to create
references
Type: Autodesk.Revit.DB..::..ReferenceArray
An array of planar lines and arcs that represents the place where you want to place the fascia.

Return Value

If successful a new fascia object within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the fascia type does not exist in the given document.

See Also

Document Class
NewFascia Overload
Autodesk.Revit.Creation Namespace


NewFlexDuct Method (IList(XYZ), FlexDuctType)

[image]

Revit 2024 API
Document..::..NewFlexDuct Method (IList<(Of <(<'XYZ>)>)>, FlexDuctType)
Document Class See Also Send Feedback
Adds a new flexible duct into the document, using a point array and duct type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FlexDuct NewFlexDuct(
    IList<XYZ> points,
    FlexDuctType ductType
)
Visual Basic
Public Function NewFlexDuct ( _
    points As IList(Of XYZ), _
    ductType As FlexDuctType _
) As FlexDuct
Visual C++
public:
FlexDuct^ NewFlexDuct(
    IList<XYZ^>^ points,
    FlexDuctType^ ductType
)

Parameters

points
Type: System.Collections.Generic..::..IList<(Of <(<' XYZ >)>)>
The point array indicating the path of the flexible duct, including the end points.
ductType
Type: Autodesk.Revit.DB.Mechanical..::..FlexDuctType
The type of the flexible duct.

Return Value

If creation was successful then a new flexible duct is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument points is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the flexible duct cannot be created or regenerate fails.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the flexible duct type does not exist in the given document.

See Also

Document Class
NewFlexDuct Overload
Autodesk.Revit.Creation Namespace


NewFlexDuct Method (Connector, Connector, FlexDuctType)

[image]

Revit 2024 API
Document..::..NewFlexDuct Method (Connector, Connector, FlexDuctType)
Document Class See Also Send Feedback
Adds a new flexible duct into the document, using two connector, and duct type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FlexDuct NewFlexDuct(
    Connector connector1,
    Connector connector2,
    FlexDuctType ductType
)
Visual Basic
Public Function NewFlexDuct ( _
    connector1 As Connector, _
    connector2 As Connector, _
    ductType As FlexDuctType _
) As FlexDuct
Visual C++
public:
FlexDuct^ NewFlexDuct(
    Connector^ connector1,
    Connector^ connector2,
    FlexDuctType^ ductType
)

Parameters

connector1
Type: Autodesk.Revit.DB..::..Connector
The first connector to be connected to the duct.
connector2
Type: Autodesk.Revit.DB..::..Connector
The second connector to be connected to the duct.
ductType
Type: Autodesk.Revit.DB.Mechanical..::..FlexDuctType
The type of the flexible duct.

Return Value

If creation was successful then a new flexible duct is returned, otherwise an exception with failure information will be thrown.

Remarks

If the connectors are fitting or equipment connectors of the correct domain, and if the connectors' direction match the direction of the flexible duct to be created, the connectors will be automatically connected. A transition fitting will be added at the connector(s) if necessary. If the connector's type, domain, does not match the one of the input connector, no connection will be established.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument connector1 or connector2 is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the flexible duct cannot be created or regenerate fails.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the flexible duct type does not exist in the given document.

See Also

Document Class
NewFlexDuct Overload
Autodesk.Revit.Creation Namespace


NewFlexDuct Method (Connector, IList(XYZ), FlexDuctType)

[image]

Revit 2024 API
Document..::..NewFlexDuct Method (Connector, IList<(Of <(<'XYZ>)>)>, FlexDuctType)
Document Class See Also Send Feedback
Adds a new flexible duct into the document, using a connector, point array and duct type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FlexDuct NewFlexDuct(
    Connector connector,
    IList<XYZ> points,
    FlexDuctType ductType
)
Visual Basic
Public Function NewFlexDuct ( _
    connector As Connector, _
    points As IList(Of XYZ), _
    ductType As FlexDuctType _
) As FlexDuct
Visual C++
public:
FlexDuct^ NewFlexDuct(
    Connector^ connector,
    IList<XYZ^>^ points,
    FlexDuctType^ ductType
)

Parameters

connector
Type: Autodesk.Revit.DB..::..Connector
The connector to be connected to the duct, including the end points.
points
Type: System.Collections.Generic..::..IList<(Of <(<' XYZ >)>)>
The point array indicating the path of the flexible duct.
ductType
Type: Autodesk.Revit.DB.Mechanical..::..FlexDuctType
The type of the flexible duct.

Return Value

If creation was successful then a new flexible duct is returned, otherwise an exception with failure information will be thrown.

Remarks

If the connector is a fitting or equipment connector of the correct domain, and if the connector's direction matches the direction of the flexible duct to be created, the connectors will be automatically connected. A transition fitting will be added at the connector(s) if necessary. If the connector's type, domain, does not match the one of the input connector, no connection will be established.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument connector or points is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the flexible duct cannot be created or regenerate fails.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the flexible duct type does not exist in the given document.

See Also

Document Class
NewFlexDuct Overload
Autodesk.Revit.Creation Namespace


NewFlexPipe Method (IList(XYZ), FlexPipeType)

[image]

Revit 2024 API
Document..::..NewFlexPipe Method (IList<(Of <(<'XYZ>)>)>, FlexPipeType)
Document Class See Also Send Feedback
Adds a new flexible pipe into the document, using a point array and pipe type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FlexPipe NewFlexPipe(
    IList<XYZ> points,
    FlexPipeType pipeType
)
Visual Basic
Public Function NewFlexPipe ( _
    points As IList(Of XYZ), _
    pipeType As FlexPipeType _
) As FlexPipe
Visual C++
public:
FlexPipe^ NewFlexPipe(
    IList<XYZ^>^ points,
    FlexPipeType^ pipeType
)

Parameters

points
Type: System.Collections.Generic..::..IList<(Of <(<' XYZ >)>)>
The point array indicating the path of the flexible pipe, including the end points.
pipeType
Type: Autodesk.Revit.DB.Plumbing..::..FlexPipeType
The type of the flexible pipe.

Return Value

If creation was successful then a new flexible pipe is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument points is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the flexible pipe cannot be created or regenerate fails.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the flexible pipe type does not exist in the given document.

See Also

Document Class
NewFlexPipe Overload
Autodesk.Revit.Creation Namespace


NewFlexPipe Method (Connector, IList(XYZ), FlexPipeType)

[image]

Revit 2024 API
Document..::..NewFlexPipe Method (Connector, IList<(Of <(<'XYZ>)>)>, FlexPipeType)
Document Class See Also Send Feedback
Adds a new flexible pipe into the document, using a connector, point array and pipe type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FlexPipe NewFlexPipe(
    Connector connector,
    IList<XYZ> points,
    FlexPipeType pipeType
)
Visual Basic
Public Function NewFlexPipe ( _
    connector As Connector, _
    points As IList(Of XYZ), _
    pipeType As FlexPipeType _
) As FlexPipe
Visual C++
public:
FlexPipe^ NewFlexPipe(
    Connector^ connector,
    IList<XYZ^>^ points,
    FlexPipeType^ pipeType
)

Parameters

connector
Type: Autodesk.Revit.DB..::..Connector
The connector to be connected to the flexible pipe, including the end points.
points
Type: System.Collections.Generic..::..IList<(Of <(<' XYZ >)>)>
The point array indicating the path of the flexible pipe.
pipeType
Type: Autodesk.Revit.DB.Plumbing..::..FlexPipeType
The type of the flexible pipe.

Return Value

If creation was successful then a new flexible pipe is returned, otherwise an exception with failure information will be thrown.

Remarks

If the connector is a fitting or equipment connector of the correct domain, and if the connector's direction matches the direction of the flexible pipe to be created, the connectors will be automatically connected. A transition fitting will be added at the connector(s) if necessary. If the connector's type, domain, does not match the one of the input connector, no connection will be established.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument connector or points is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the flexible pipe cannot be created or regenerate fails.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the flexible pipe type does not exist in the given document.

See Also

Document Class
NewFlexPipe Overload
Autodesk.Revit.Creation Namespace


NewFootPrintRoof Method

[image]

Revit 2024 API
Document..::..NewFootPrintRoof Method
Document Class Example See Also Send Feedback
Creates a new FootPrintRoof element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FootPrintRoof NewFootPrintRoof(
    CurveArray footPrint,
    Level level,
    RoofType roofType,
    out ModelCurveArray footPrintToModelCurvesMapping
)
Visual Basic
Public Function NewFootPrintRoof ( _
    footPrint As CurveArray, _
    level As Level, _
    roofType As RoofType, _
    <OutAttribute> ByRef footPrintToModelCurvesMapping As ModelCurveArray _
) As FootPrintRoof
Visual C++
public:
FootPrintRoof^ NewFootPrintRoof(
    CurveArray^ footPrint,
    Level^ level,
    RoofType^ roofType,
    [OutAttribute] ModelCurveArray^% footPrintToModelCurvesMapping
)

Parameters

footPrint
Type: Autodesk.Revit.DB..::..CurveArray
The footprint of the FootPrintRoof.
level
Type: Autodesk.Revit.DB..::..Level
The level of the FootPrintRoof.
roofType
Type: Autodesk.Revit.DB..::..RoofType
Type of the FootPrintRoof.
footPrintToModelCurvesMapping
Type: Autodesk.Revit.DB..::..ModelCurveArray %
An array of Model Curves corresponding to the set of Curves input in the footPrint. By knowing which Model Curve was created by each footPrint curve, you can set properties like SlopeAngle for each curve.

Remarks

This method will regenerate the document even in manual regeneration mode.

Examples

CopyC#
// Before invoking this sample, select some walls to add a roof over.
// Make sure there is a level named "Roof" in the document.

// find the Roof level
FilteredElementCollector collector = new FilteredElementCollector(document);
collector.OfClass(typeof(Level));
var elements = from element in collector where element.Name == "Roof" select element;
Level level = elements.Cast<Level>().ElementAt<Level>(0);

collector = new FilteredElementCollector(document);
collector.OfClass(typeof(RoofType));
RoofType roofType = collector.FirstElement() as RoofType;

// Get the handle of the application
Autodesk.Revit.ApplicationServices.Application application = document.Application;

// Define the footprint for the roof based on user selection
CurveArray footprint = application.Create.NewCurveArray();
UIDocument uidoc = new UIDocument(document);
ICollection<ElementId> selectedIds = uidoc.Selection.GetElementIds();
if (selectedIds.Count != 0)
{
    foreach (ElementId id in selectedIds)
    {
        Element element = document.GetElement(id);
        Wall wall = element as Wall;
        if (wall != null)
        {
            LocationCurve wallCurve = wall.Location as LocationCurve;
            footprint.Append(wallCurve.Curve);
            continue;
        }

        ModelCurve modelCurve = element as ModelCurve;
        if (modelCurve != null)
        {
            footprint.Append(modelCurve.GeometryCurve);
        }
    }

}
else
{
    throw new Exception("You should select a curve loop, or a wall loop, or loops combination \nof walls and curves to create a footprint roof.");
}

ModelCurveArray footPrintToModelCurveMapping = new ModelCurveArray();
FootPrintRoof footprintRoof = document.Create.NewFootPrintRoof(footprint, level, roofType, out footPrintToModelCurveMapping);
ModelCurveArrayIterator iterator = footPrintToModelCurveMapping.ForwardIterator();
iterator.Reset();
while (iterator.MoveNext())
{
    ModelCurve modelCurve = iterator.Current as ModelCurve;
    footprintRoof.set_DefinesSlope(modelCurve, true);
    footprintRoof.set_SlopeAngle(modelCurve, 0.5);
}
CopyVB.NET
' Before invoking this sample, select some walls to add a roof over.
' Make sure there is a level named "Roof" in the document.

' find the Roof level
Dim collector As New FilteredElementCollector(document)
collector.OfClass(GetType(Level))
: Dim elements As System.Collections.Generic.IEnumerable(Of Autodesk.Revit.DB.Element)
elements = From element In collector _
 Where element.Name = "Roof" _
 Select element

Dim level As Level = elements.Cast(Of Level)().ElementAt(0)

collector = New FilteredElementCollector(document)
collector.OfClass(GetType(RoofType))
Dim roofType As RoofType = TryCast(collector.FirstElement(), RoofType)

' Get the handle of the application
Dim application As Autodesk.Revit.ApplicationServices.Application = document.Application

' Define the footprint for the roof based on user selection
Dim footprint As CurveArray = application.Create.NewCurveArray()
Dim uidoc As New UIDocument(document)
Dim selectedIds As ICollection(Of ElementId) = uidoc.Selection.GetElementIds()
If selectedIds.Count <> 0 Then
    For Each id As ElementId In selectedIds
        Dim element As Element = document.GetElement(id)
        Dim wall As Wall = TryCast(element, Wall)
        If wall IsNot Nothing Then
            Dim wallCurve As LocationCurve = TryCast(wall.Location, LocationCurve)
            footprint.Append(wallCurve.Curve)
            Continue For
        End If

        Dim modelCurve As ModelCurve = TryCast(element, ModelCurve)
        If modelCurve IsNot Nothing Then
            footprint.Append(modelCurve.GeometryCurve)
        End If

    Next
Else
    Throw New Exception("You should select a curve loop, or a wall loop, or loops combination " & vbLf & "of walls and curves to create a footprint roof.")
End If

Dim footPrintToModelCurveMapping As New ModelCurveArray()
Dim footprintRoof As FootPrintRoof = document.Create.NewFootPrintRoof(footprint, level, roofType, footPrintToModelCurveMapping)
Dim iterator As ModelCurveArrayIterator = footPrintToModelCurveMapping.ForwardIterator()
iterator.Reset()
While iterator.MoveNext()
    Dim modelCurve As ModelCurve = TryCast(iterator.Current, ModelCurve)
    footprintRoof.DefinesSlope(modelCurve) = True
    footprintRoof.SlopeAngle(modelCurve) = 0.5
End While

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the level does not exist in the given document.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the roof type does not exist in the given document.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewGutter Method

[image] [image]

Revit 2024 API
Document..::..NewGutter Method
Document Class See Also Send Feedback
Creates a gutter.

Overload List

 | Name | Description
Public method | NewGutter(GutterType, Reference) | Creates a gutter along a reference.
Public method | NewGutter(GutterType, ReferenceArray) | Creates a gutter along a reference array.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewGutter Method (GutterType, Reference)

[image]

Revit 2024 API
Document..::..NewGutter Method (GutterType, Reference)
Document Class See Also Send Feedback
Creates a gutter along a reference.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Gutter NewGutter(
    GutterType GutterType,
    Reference reference
)
Visual Basic
Public Function NewGutter ( _
    GutterType As GutterType, _
    reference As Reference _
) As Gutter
Visual C++
public:
Gutter^ NewGutter(
    GutterType^ GutterType,
    Reference^ reference
)

Parameters

GutterType
Type: Autodesk.Revit.DB.Architecture..::..GutterType
The type of the gutter to create
reference
Type: Autodesk.Revit.DB..::..Reference
A planar line or arc that represents the place where you want to place the gutter.

Return Value

If successful a new gutter object within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the gutter type does not exist in the given document.

See Also

Document Class
NewGutter Overload
Autodesk.Revit.Creation Namespace


NewGutter Method (GutterType, ReferenceArray)

[image]

Revit 2024 API
Document..::..NewGutter Method (GutterType, ReferenceArray)
Document Class See Also Send Feedback
Creates a gutter along a reference array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Gutter NewGutter(
    GutterType GutterType,
    ReferenceArray references
)
Visual Basic
Public Function NewGutter ( _
    GutterType As GutterType, _
    references As ReferenceArray _
) As Gutter
Visual C++
public:
Gutter^ NewGutter(
    GutterType^ GutterType,
    ReferenceArray^ references
)

Parameters

GutterType
Type: Autodesk.Revit.DB.Architecture..::..GutterType
The type of the gutter to create
references
Type: Autodesk.Revit.DB..::..ReferenceArray
An array of planar lines and arcs that represents the place where you want to place the gutter.

Return Value

If successful a new gutter object within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the gutter type does not exist in the given document.

See Also

Document Class
NewGutter Overload
Autodesk.Revit.Creation Namespace


NewLineBoundaryConditions Method

[image] [image]

Revit 2024 API
Document..::..NewLineBoundaryConditions Method
Document Class See Also Send Feedback
Creates a new Line BoundaryConditions element.

Overload List

 | Name | Description
Public method | NewLineBoundaryConditions(Element, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) | Creates a new Line BoundaryConditions element on a host element.
Public method | NewLineBoundaryConditions(Reference, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) | Creates a new Line BoundaryConditions element on a reference.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewLineBoundaryConditions Method (Element, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double)

[image]

Revit 2024 API
Document..::..NewLineBoundaryConditions Method (Element, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double)
Document Class Example See Also Send Feedback
Creates a new Line BoundaryConditions element on a host element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public BoundaryConditions NewLineBoundaryConditions(
    Element hostElement,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus,
    TranslationRotationValue X_Rotation,
    double X_RotationSpringModulus
)
Visual Basic
Public Function NewLineBoundaryConditions ( _
    hostElement As Element, _
    X_Translation As TranslationRotationValue, _
    X_TranslationSpringModulus As Double, _
    Y_Translation As TranslationRotationValue, _
    Y_TranslationSpringModulus As Double, _
    Z_Translation As TranslationRotationValue, _
    Z_TranslationSpringModulus As Double, _
    X_Rotation As TranslationRotationValue, _
    X_RotationSpringModulus As Double _
) As BoundaryConditions
Visual C++
public:
BoundaryConditions^ NewLineBoundaryConditions(
    Element^ hostElement,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus,
    TranslationRotationValue X_Rotation,
    double X_RotationSpringModulus
)

Parameters

hostElement
Type: Autodesk.Revit.DB..::..Element
A Beam.
X_Translation
Type: Autodesk.Revit.DB.Structure..::..TranslationRotationValue
A value indicating the X axis translation option.
X_TranslationSpringModulus
Type: System..::..Double
Translation Spring Modulus for X axis. Ignored if X_Translation is not "Spring".
Y_Translation
Type: Autodesk.Revit.DB.Structure..::..TranslationRotationValue
A value indicating the Y axis translation option.
Y_TranslationSpringModulus
Type: System..::..Double
Translation Spring Modulus for Y axis. Ignored if Y_Translation is not "Spring".
Z_Translation
Type: Autodesk.Revit.DB.Structure..::..TranslationRotationValue
A value indicating the Z axis translation option.
Z_TranslationSpringModulus
Type: System..::..Double
Translation Spring Modulus for Z axis. Ignored if Z_Translation is not "Spring".
X_Rotation
Type: Autodesk.Revit.DB.Structure..::..TranslationRotationValue
A value indicating the option for rotation about the X axis.
X_RotationSpringModulus
Type: System..::..Double
Rotation Spring Modulus for X axis. Ignored if X_Rotation is not "Spring"

Return Value

If successful, NewLineBoundaryConditions returns an object for the newly created BoundaryConditions with the BoundaryType = 1 - "Line". nullNothingnullptra null reference (Nothing in Visual Basic) is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

Examples

CopyC#
bool CreateLineConditionsWithElement(AnalyticalMember column, Autodesk.Revit.Creation.Document docCreation)
  {
      if (column.StructuralRole != AnalyticalStructuralRole.StructuralRoleColumn)
      {
          throw new Exception("This sample only works for columns.");
      }

      // Create the new line boundary conditions
      BoundaryConditions condition = docCreation.NewLineBoundaryConditions(column, TranslationRotationValue.Fixed, 0,
                                                                                TranslationRotationValue.Fixed, 0,
                                                                                TranslationRotationValue.Fixed, 0,
                                                                                TranslationRotationValue.Fixed, 0);
      return (null != condition);
  }
CopyVB.NET
Private Function CreateLineConditionsWithElement(column As FamilyInstance, docCreation As Autodesk.Revit.Creation.Document) As Boolean
    If StructuralType.Column <> column.StructuralType Then
        Throw New Exception("This sample only works for columns.")
    End If

    ' Create the new line boundary conditions
    Dim condition As BoundaryConditions = docCreation.NewLineBoundaryConditions(column, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, _
        0, TranslationRotationValue.Fixed, 0)
    Return (condition IsNot Nothing)
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the host element does not exist in the given document.

See Also

Document Class
NewLineBoundaryConditions Overload
Autodesk.Revit.Creation Namespace


NewOpening Method

[image] [image]

Revit 2024 API
Document..::..NewOpening Method
Document Class See Also Send Feedback
Creates a new opening.

Overload List

 | Name | Description
Public method | NewOpening(Element, CurveArray, eRefFace) | Creates a new opening in a beam, brace and column.
Public method | NewOpening(Element, CurveArray, Boolean) | Creates a new opening in a roof, floor and ceiling.
Public method | NewOpening(Level, Level, CurveArray) | Creates a new shaft opening between a set of levels.
Public method | NewOpening(Wall, XYZ, XYZ) | Creates a rectangular opening on a wall.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewOpening Method (Element, CurveArray, eRefFace)

[image]

Revit 2024 API
Document..::..NewOpening Method (Element, CurveArray, eRefFace)
Document Class See Also Send Feedback
Creates a new opening in a beam, brace and column.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Opening NewOpening(
    Element famInstElement,
    CurveArray profile,
    eRefFace iFace
)
Visual Basic
Public Function NewOpening ( _
    famInstElement As Element, _
    profile As CurveArray, _
    iFace As eRefFace _
) As Opening
Visual C++
public:
Opening^ NewOpening(
    Element^ famInstElement,
    CurveArray^ profile,
    eRefFace iFace
)

Parameters

famInstElement
Type: Autodesk.Revit.DB..::..Element
host element of the opening, can be a beam, brace and column.
profile
Type: Autodesk.Revit.DB..::..CurveArray
profile of the opening.
iFace
Type: Autodesk.Revit.Creation..::..eRefFace
face on which opening is based on.

Return Value

If successful, an Opening object is returned.

Remarks

This method forms opening on a beam, brace and column.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the family instance element does not exist in the given document.

See Also

Document Class
NewOpening Overload
Autodesk.Revit.Creation Namespace


NewOpening Method (Element, CurveArray, Boolean)

[image]

Revit 2024 API
Document..::..NewOpening Method (Element, CurveArray, Boolean)
Document Class See Also Send Feedback
Creates a new opening in a roof, floor and ceiling.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Opening NewOpening(
    Element hostElement,
    CurveArray profile,
    bool bPerpendicularFace
)
Visual Basic
Public Function NewOpening ( _
    hostElement As Element, _
    profile As CurveArray, _
    bPerpendicularFace As Boolean _
) As Opening
Visual C++
public:
Opening^ NewOpening(
    Element^ hostElement,
    CurveArray^ profile,
    bool bPerpendicularFace
)

Parameters

hostElement
Type: Autodesk.Revit.DB..::..Element
Host element of the opening. Can be a roof, floor, or ceiling.
profile
Type: Autodesk.Revit.DB..::..CurveArray
Profile of the opening.
bPerpendicularFace
Type: System..::..Boolean
True if the profile is cut perpendicular to the intersecting face of the host. False if the profile is cut vertically.

Return Value

If successful, an Opening object is returned.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the host element does not exist in the given document.

See Also

Document Class
NewOpening Overload
Autodesk.Revit.Creation Namespace


NewOpening Method (Level, Level, CurveArray)

[image]

Revit 2024 API
Document..::..NewOpening Method (Level, Level, CurveArray)
Document Class See Also Send Feedback
Creates a new shaft opening between a set of levels.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Opening NewOpening(
    Level bottomLevel,
    Level topLevel,
    CurveArray profile
)
Visual Basic
Public Function NewOpening ( _
    bottomLevel As Level, _
    topLevel As Level, _
    profile As CurveArray _
) As Opening
Visual C++
public:
Opening^ NewOpening(
    Level^ bottomLevel,
    Level^ topLevel,
    CurveArray^ profile
)

Parameters

bottomLevel
Type: Autodesk.Revit.DB..::..Level
bottom level
topLevel
Type: Autodesk.Revit.DB..::..Level
top level
profile
Type: Autodesk.Revit.DB..::..CurveArray
profile of the opening.

Return Value

If successful, an Opening object is returned.

Remarks

This method forms an opening on floor, ceiling and roof. Make sure topLevel is higher than bottomLevel, otherwise an exception will be returned.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the bottom level does not exist in the given document.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the top level does not exist in the given document.

See Also

Document Class
NewOpening Overload
Autodesk.Revit.Creation Namespace


NewOpening Method (Wall, XYZ, XYZ)

[image]

Revit 2024 API
Document..::..NewOpening Method (Wall, XYZ, XYZ)
Document Class See Also Send Feedback
Creates a rectangular opening on a wall.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Opening NewOpening(
    Wall wall,
    XYZ pntStart,
    XYZ pntEnd
)
Visual Basic
Public Function NewOpening ( _
    wall As Wall, _
    pntStart As XYZ, _
    pntEnd As XYZ _
) As Opening
Visual C++
public:
Opening^ NewOpening(
    Wall^ wall,
    XYZ^ pntStart,
    XYZ^ pntEnd
)

Parameters

wall
Type: Autodesk.Revit.DB..::..Wall
Host element of the opening.
pntStart
Type: Autodesk.Revit.DB..::..XYZ
One corner of the rectangle.
pntEnd
Type: Autodesk.Revit.DB..::..XYZ
The opposite corner of the rectangle.

Return Value

If successful, an Opening object is returned.

Remarks

Slanted stacked walls do not support rectangular openings.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the wall does not exist in the given document, or if the wall doesn't support rectangular openings.

See Also

Document Class
NewOpening Overload
Autodesk.Revit.Creation Namespace


NewRoom Method (Phase)

[image]

Revit 2024 API
Document..::..NewRoom Method (Phase)
Document Class See Also Send Feedback
Creates a new unplaced room and with an assigned phase.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Room NewRoom(
    Phase phase
)
Visual Basic
Public Function NewRoom ( _
    phase As Phase _
) As Room
Visual C++
public:
Room^ NewRoom(
    Phase^ phase
)

Parameters

phase
Type: Autodesk.Revit.DB..::..Phase
The phase in which the room is to exist.

Return Value

If successful the new room , otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the phase does not exist in the given document.

See Also

Document Class
NewRoom Overload
Autodesk.Revit.Creation Namespace


NewRoom Method (Level, UV)

[image]

Revit 2024 API
Document..::..NewRoom Method (Level, UV)
Document Class Example See Also Send Feedback
Creates a new room on a level at a specified point.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Room NewRoom(
    Level level,
    UV point
)
Visual Basic
Public Function NewRoom ( _
    level As Level, _
    point As UV _
) As Room
Visual C++
public:
Room^ NewRoom(
    Level^ level,
    UV^ point
)

Parameters

level
Type: Autodesk.Revit.DB..::..Level
The level on which the room is to exist.
point
Type: Autodesk.Revit.DB..::..UV
A 2D point that dictates the location of the room on that specified level.

Return Value

If successful the new room will be returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

This method will regenerate the document even in manual regeneration mode.

Examples

CopyC#
Room CreateRoom(Autodesk.Revit.DB.Document document, Level level)
{
    // Create a UV structure which determines the room location
   UV roomLocation = new UV(0, 0);

    // Create a new room
    Room room = document.Create.NewRoom(level, roomLocation);
    if (null == room)
    {
        throw new Exception("Create a new room failed.");
    }

    return room;
}
CopyVB.NET
Private Function CreateRoom(document As Autodesk.Revit.DB.Document, level As Level) As Room
    ' Create a UV structure which determines the room location
    Dim roomLocation As New UV(0, 0)

    ' Create a new room
    Dim room As Room = document.Create.NewRoom(level, roomLocation)
    If room Is Nothing Then
        Throw New Exception("Create a new room failed.")
    End If

    Return room
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the level does not exist in the given document.

See Also

Document Class
NewRoom Overload
Autodesk.Revit.Creation Namespace


NewRoom Method (Room, PlanCircuit)

[image]

Revit 2024 API
Document..::..NewRoom Method (Room, PlanCircuit)
Document Class Example See Also Send Feedback
Creates a new room within the confines of a plan circuit, or places an unplaced room within the confines of the plan circuit.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Room NewRoom(
    Room room,
    PlanCircuit circuit
)
Visual Basic
Public Function NewRoom ( _
    room As Room, _
    circuit As PlanCircuit _
) As Room
Visual C++
public:
Room^ NewRoom(
    Room^ room,
    PlanCircuit^ circuit
)

Parameters

room
Type: Autodesk.Revit.DB.Architecture..::..Room
The room which you want to locate in the circuit. Pass nullNothingnullptra null reference (Nothing in Visual Basic) to create a new room.
circuit
Type: Autodesk.Revit.DB..::..PlanCircuit
The circuit in which you want to locate a room.

Return Value

If successful the room is returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

This method will regenerate the document even in manual regeneration mode.

Examples

CopyC#
Room InsertNewRoomInPlanCircuit(Autodesk.Revit.DB.Document document, Level level, Phase newConstructionPhase)
{
    // create room using Phase
    Room newScheduleRoom = document.Create.NewRoom(newConstructionPhase);

    // set the Room Number and Name
    string newRoomNumber = "101";
    string newRoomName = "Class Room 1";
    newScheduleRoom.Name = newRoomName;
    newScheduleRoom.Number = newRoomNumber;

    // Get a PlanCircuit
    PlanCircuit planCircuit = null;
    // first get the plan topology for given level
    PlanTopology planTopology = document.get_PlanTopology(level);

    // Iterate circuits in this plan topology
    foreach (PlanCircuit circuit in planTopology.Circuits)
    {
        // get the first circuit we find
        if (null != circuit)
        {
            planCircuit = circuit;
            break;
        }
    }

    Room newRoom2 = null;
    if (null != planCircuit)
    {
        using (Transaction transaction = new Transaction(document, "Create Room"))
        {
           if (transaction.Start() == TransactionStatus.Started)
           {
               // The input room must exist only in the room schedule,
               // meaning that it does not display in any plan view.
               newRoom2 = document.Create.NewRoom(newScheduleRoom, planCircuit);
               // a model room with the same name and number is created in the
               // view where the PlanCircuit is located
               if (null != newRoom2)
               {
                   // Give the user some information
                   TaskDialog.Show("Revit", "Room placed in Plan Circuit successfully.");
               }
               transaction.Commit();
           }
        }
    }

    return newRoom2;
}
CopyVB.NET
Private Function InsertNewRoomInPlanCircuit(document As Autodesk.Revit.DB.Document, level As Level, newConstructionPhase As Phase) As Room
    ' create room using Phase
    Dim newScheduleRoom As Room = document.Create.NewRoom(newConstructionPhase)

    ' set the Room Number and Name
    Dim newRoomNumber As String = "101"
    Dim newRoomName As String = "Class Room 1"
    newScheduleRoom.Name = newRoomName
    newScheduleRoom.Number = newRoomNumber

    ' Get a PlanCircuit
    Dim planCircuit As PlanCircuit = Nothing
    ' first get the plan topology for given level
    Dim planTopology As PlanTopology = document.PlanTopology(level)

    ' Iterate circuits in this plan topology
    For Each circuit As PlanCircuit In planTopology.Circuits
        ' get the first circuit we find
        If circuit IsNot Nothing Then
            planCircuit = circuit
            Exit For
        End If
    Next

    Dim newRoom2 As Room = Nothing
    If planCircuit IsNot Nothing Then
        Using transaction As New Transaction(document, "Create Room")
            If transaction.Start() = TransactionStatus.Started Then
                ' The input room must exist only in the room schedule,
                ' meaning that it does not display in any plan view.
                newRoom2 = document.Create.NewRoom(newScheduleRoom, planCircuit)
                ' a model room with the same name and number is created in the
                ' view where the PlanCircuit is located
                If newRoom2 IsNot Nothing Then
                    ' Give the user some information
                    TaskDialog.Show("Revit", "Room placed in Plan Circuit successfully.")
                End If
                transaction.Commit()
            End If
        End Using
    End If

    Return newRoom2
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the existing room is already placed.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the room does not exist in the given document.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the circuit does not exist in the given document.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if the level obtained from the circuit has no associated view .

See Also

Document Class
NewRoom Overload
Autodesk.Revit.Creation Namespace


NewRooms2 Method (Level)

[image]

Revit 2024 API
Document..::..NewRooms2 Method (Level)
Document Class See Also Send Feedback
Creates new rooms in each plan circuit found in the given level in the last phase.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ICollection<ElementId> NewRooms2(
    Level level
)
Visual Basic
Public Function NewRooms2 ( _
    level As Level _
) As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ NewRooms2(
    Level^ level
)

Parameters

level
Type: Autodesk.Revit.DB..::..Level
The level from which the circuits are found.

Return Value

If successful, a set of ElementIds which contains the rooms created should be returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | If the view of the relevant level can not be retrieved.
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the phase is invalid, or regeneration fails at the end of the creation.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the level does not exist in the given document.

See Also

Document Class
NewRooms2 Overload
Autodesk.Revit.Creation Namespace


NewRooms2 Method (Level, Phase)

[image]

Revit 2024 API
Document..::..NewRooms2 Method (Level, Phase)
Document Class See Also Send Feedback
Creates new rooms in each plan circuit found in the given level in the given phase.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ICollection<ElementId> NewRooms2(
    Level level,
    Phase phase
)
Visual Basic
Public Function NewRooms2 ( _
    level As Level, _
    phase As Phase _
) As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ NewRooms2(
    Level^ level,
    Phase^ phase
)

Parameters

level
Type: Autodesk.Revit.DB..::..Level
The level from which the circuits are found.
phase
Type: Autodesk.Revit.DB..::..Phase
The phase on which the room is to exist.

Return Value

If successful, a set of ElementIds which contains the rooms should be returned, otherwise the exception will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | If the view of the relevant level can not be retrieved.
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the phase is invalid, or regeneration fails at the end of the creation.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the level does not exist in the given document.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the phase does not exist in the given document.

See Also

Document Class
NewRooms2 Overload
Autodesk.Revit.Creation Namespace


NewRoomTag Method

[image]

Revit 2024 API
Document..::..NewRoomTag Method
Document Class Example See Also Send Feedback
Creates a new RoomTag referencing a room in the host model or in a Revit link.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public RoomTag NewRoomTag(
    LinkElementId roomId,
    UV point,
    ElementId viewId
)
Visual Basic
Public Function NewRoomTag ( _
    roomId As LinkElementId, _
    point As UV, _
    viewId As ElementId _
) As RoomTag
Visual C++
public:
RoomTag^ NewRoomTag(
    LinkElementId^ roomId,
    UV^ point,
    ElementId^ viewId
)

Parameters

roomId
Type: Autodesk.Revit.DB..::..LinkElementId
The HostOrLinkElementId of the Room.
point
Type: Autodesk.Revit.DB..::..UV
A 2D point that defines the tag location on the level of the room.
viewId
Type: Autodesk.Revit.DB..::..ElementId
The id of the view where the tag will be shown. If nullNothingnullptra null reference (Nothing in Visual Basic) and the room in not in a Revit link, the view of the room will be used.

Return Value

If successful a RoomTag object will be returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Examples

CopyC#
RoomTag CreateRoomTag(Autodesk.Revit.DB.Document document, Room room)
{
    // Create a UV structure which determine the room tag location
   UV roomTagLocation = new UV(0, 0);

    // Create a new room tag in the created room
    LinkElementId roomId = new LinkElementId(room.Id);
    RoomTag roomTag = document.Create.NewRoomTag(roomId, roomTagLocation, ElementId.InvalidElementId);
    if (null == roomTag)
    {
        throw new Exception("Create a new room tag failed.");
    }

    // Give the user some information
    TaskDialog.Show("Revit","Room tag created successfully.");

    return roomTag;
}
CopyVB.NET
Private Function CreateRoomTag(document As Autodesk.Revit.DB.Document, room As Room) As RoomTag
    ' Create a UV structure which determine the room tag location
    Dim roomTagLocation As New UV(0, 0)

    ' Create a new room tag in the created room
    Dim roomId As New LinkElementId(room.Id)
    Dim roomTag As RoomTag = document.Create.NewRoomTag(roomId, roomTagLocation, ElementId.InvalidElementId)
    If roomTag Is Nothing Then
        Throw New Exception("Create a new room tag failed.")
    End If

    ' Give the user some information
    TaskDialog.Show("Revit", "Room tag created successfully.")

    Return roomTag
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | viewId is not associated with a plan view or section view.
Autodesk.Revit.Exceptions..::..InvalidOperationException | viewId is null and the room is in a linked file.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewSpace Method (Level, UV)

[image]

Revit 2024 API
Document..::..NewSpace Method (Level, UV)
Document Class See Also Send Feedback
Creates a new space element on the given level at the given location.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Space NewSpace(
    Level level,
    UV point
)
Visual Basic
Public Function NewSpace ( _
    level As Level, _
    point As UV _
) As Space
Visual C++
public:
Space^ NewSpace(
    Level^ level,
    UV^ point
)

Parameters

level
Type: Autodesk.Revit.DB..::..Level
The level on which the space is to exist.
point
Type: Autodesk.Revit.DB..::..UV
A 2D point that dictates the location on that specified level.

Return Value

If successful the new space element is returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when level or point is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the space cannot be created.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the level does not exist in the given document.

See Also

Document Class
NewSpace Overload
Autodesk.Revit.Creation Namespace


NewSpaces2 Method

[image] [image]

Revit 2024 API
Document..::..NewSpaces2 Method
Document Class See Also Send Feedback
Creates one or more spaces.

Overload List

 | Name | Description
Public method | NewSpaces2(Phase, Int32) | Creates a set of new unplaced spaces on a given phase.
Public method | NewSpaces2(Level, Phase, View) | Creates new spaces on the available plan circuits of a the given level.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewSpaces2 Method (Phase, Int32)

[image]

Revit 2024 API
Document..::..NewSpaces2 Method (Phase, Int32)
Document Class See Also Send Feedback
Creates a set of new unplaced spaces on a given phase.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ICollection<ElementId> NewSpaces2(
    Phase phase,
    int count
)
Visual Basic
Public Function NewSpaces2 ( _
    phase As Phase, _
    count As Integer _
) As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ NewSpaces2(
    Phase^ phase,
    int count
)

Parameters

phase
Type: Autodesk.Revit.DB..::..Phase
The phase in which the spaces are to exist.
count
Type: System..::..Int32

Return Value

If successful, a set of ElementIds of new unplaced spaces are be returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the phase does not exist in the given document.

See Also

Document Class
NewSpaces2 Overload
Autodesk.Revit.Creation Namespace


NewSpaces2 Method (Level, Phase, View)

[image]

Revit 2024 API
Document..::..NewSpaces2 Method (Level, Phase, View)
Document Class See Also Send Feedback
Creates new spaces on the available plan circuits of a the given level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ICollection<ElementId> NewSpaces2(
    Level level,
    Phase phase,
    View view
)
Visual Basic
Public Function NewSpaces2 ( _
    level As Level, _
    phase As Phase, _
    view As View _
) As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ NewSpaces2(
    Level^ level,
    Phase^ phase,
    View^ view
)

Parameters

level
Type: Autodesk.Revit.DB..::..Level
The level on which the spaces is to exist.
phase
Type: Autodesk.Revit.DB..::..Phase
The phase in which the spaces is to exist.
view
Type: Autodesk.Revit.DB..::..View
The view on which the space tags for the spaces are to display.

Return Value

If successful, a set of ElementIds which contains the rooms should be returned, otherwise the exception will be thrown.

Remarks

This method will regenerate the document even in manual regeneration mode.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The view of the relevant level can not be retrieved.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The phase is invalid or regeneration fails at the end of the creation.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the level does not exist in the given document.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the phase does not exist in the given document.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the view does not exist in the given document.

See Also

Document Class
NewSpaces2 Overload
Autodesk.Revit.Creation Namespace


NewSpaceTag Method

[image]

Revit 2024 API
Document..::..NewSpaceTag Method
Document Class See Also Send Feedback
Creates a new SpaceTag.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public SpaceTag NewSpaceTag(
    Space space,
    UV point,
    View view
)
Visual Basic
Public Function NewSpaceTag ( _
    space As Space, _
    point As UV, _
    view As View _
) As SpaceTag
Visual C++
public:
SpaceTag^ NewSpaceTag(
    Space^ space,
    UV^ point,
    View^ view
)

Parameters

space
Type: Autodesk.Revit.DB.Mechanical..::..Space
The Space which the tag refers.
point
Type: Autodesk.Revit.DB..::..UV
A 2D point that dictates the location on the level of the space.
view
Type: Autodesk.Revit.DB..::..View
The view where the tag will lie.

Return Value

If successful a SpaceTag object will be returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic). Suitable exceptions will be fired if the parameters are invalid.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the space does not exist in the given document.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the view does not exist in the given document.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewSpotCoordinate Method

[image]

Revit 2024 API
Document..::..NewSpotCoordinate Method
Document Class See Also Send Feedback
Generate a new spot coordinate object within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public SpotDimension NewSpotCoordinate(
    View view,
    Reference reference,
    XYZ origin,
    XYZ bend,
    XYZ end,
    XYZ refPt,
    bool hasLeader
)
Visual Basic
Public Function NewSpotCoordinate ( _
    view As View, _
    reference As Reference, _
    origin As XYZ, _
    bend As XYZ, _
    end As XYZ, _
    refPt As XYZ, _
    hasLeader As Boolean _
) As SpotDimension
Visual C++
public:
SpotDimension^ NewSpotCoordinate(
    View^ view,
    Reference^ reference,
    XYZ^ origin,
    XYZ^ bend,
    XYZ^ end,
    XYZ^ refPt,
    bool hasLeader
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view in which the spot coordinate is to be visible.
reference
Type: Autodesk.Revit.DB..::..Reference
The reference to which the spot coordinate is to be bound.
origin
Type: Autodesk.Revit.DB..::..XYZ
The point which the spot coordinate evaluate.
bend
Type: Autodesk.Revit.DB..::..XYZ
The bend point for the spot coordinate.
end
Type: Autodesk.Revit.DB..::..XYZ
The end point for the spot coordinate.
refPt
Type: Autodesk.Revit.DB..::..XYZ
The actual point on the reference which the spot coordinate evaluate.
hasLeader
Type: System..::..Boolean
Indicate if it has leader or not.

Return Value

If successful a new spot dimension object, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

If the origin point is not on the reference, it'll be projected to the reference automatically. And the refPt is projected point. If the reference is not valid or the point cannot be projected to reference correctly, an exception will be thrown

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the view does not exist in the given document.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewSpotElevation Method

[image]

Revit 2024 API
Document..::..NewSpotElevation Method
Document Class See Also Send Feedback
Generate a new spot elevation object within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public SpotDimension NewSpotElevation(
    View view,
    Reference reference,
    XYZ origin,
    XYZ bend,
    XYZ end,
    XYZ refPt,
    bool hasLeader
)
Visual Basic
Public Function NewSpotElevation ( _
    view As View, _
    reference As Reference, _
    origin As XYZ, _
    bend As XYZ, _
    end As XYZ, _
    refPt As XYZ, _
    hasLeader As Boolean _
) As SpotDimension
Visual C++
public:
SpotDimension^ NewSpotElevation(
    View^ view,
    Reference^ reference,
    XYZ^ origin,
    XYZ^ bend,
    XYZ^ end,
    XYZ^ refPt,
    bool hasLeader
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view in which the spot elevation is to be visible.
reference
Type: Autodesk.Revit.DB..::..Reference
The reference to which the spot elevation is to be bound.
origin
Type: Autodesk.Revit.DB..::..XYZ
The point which the spot elevation evaluate.
bend
Type: Autodesk.Revit.DB..::..XYZ
The bend point for the spot elevation.
end
Type: Autodesk.Revit.DB..::..XYZ
The end point for the spot elevation.
refPt
Type: Autodesk.Revit.DB..::..XYZ
The actual point on the reference which the spot elevation evaluate.
hasLeader
Type: System..::..Boolean
Indicate if it has leader or not.

Return Value

If successful a new spot dimension object, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

If the origin point is not on the reference, it'll be projected to the reference automatically. And the refPt is the projected point. If the reference is not valid or the point cannot be projected to reference correctly, an exception will be thrown

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the view does not exist in the given document.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewTakeoffFitting Method

[image]

Revit 2024 API
Document..::..NewTakeoffFitting Method
Document Class See Also Send Feedback
Add a new family instance of an takeoff fitting into the Autodesk Revit document, using one connector and one MEP curve.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyInstance NewTakeoffFitting(
    Connector connector,
    MEPCurve curve
)
Visual Basic
Public Function NewTakeoffFitting ( _
    connector As Connector, _
    curve As MEPCurve _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewTakeoffFitting(
    Connector^ connector,
    MEPCurve^ curve
)

Parameters

connector
Type: Autodesk.Revit.DB..::..Connector
The connector to be connected to the takeoff.
curve
Type: Autodesk.Revit.DB..::..MEPCurve
The duct or pipe which is the trunk for the takeoff.

Return Value

If creation was successful then an family instance to the new object is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument connector1 or curve is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the connector and the curve cannot be used for takeoff creation. For example, they must be of the same domain, the curve must be a duct or pipe, and the owner of the connector should be (flex) duct or pipe.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when takeoff fitting cannot be created.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the curve does not exist in the given document.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewTeeFitting Method

[image]

Revit 2024 API
Document..::..NewTeeFitting Method
Document Class See Also Send Feedback
Add a new family instance of a tee fitting into the Autodesk Revit document, using three connectors.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyInstance NewTeeFitting(
    Connector connector1,
    Connector connector2,
    Connector connector3
)
Visual Basic
Public Function NewTeeFitting ( _
    connector1 As Connector, _
    connector2 As Connector, _
    connector3 As Connector _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewTeeFitting(
    Connector^ connector1,
    Connector^ connector2,
    Connector^ connector3
)

Parameters

connector1
Type: Autodesk.Revit.DB..::..Connector
The first connector to be connected to the tee.
connector2
Type: Autodesk.Revit.DB..::..Connector
The second connector to be connected to the tee.
connector3
Type: Autodesk.Revit.DB..::..Connector
The third connector to be connected to the tee. This should be connected to the branch of the tee.

Return Value

If creation was successful then an family instance to the new object is returned, and the transition fitting will be added at the connectors' end if necessary, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument connector1, connector2 or connector3 is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the connectors cannot be used for the tee creation. For example, they cannot be from the same element, they must be of the same domain, and the owner of the connectors should be a (flex) duct or pipe.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when tee fitting cannot be created.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewTransitionFitting Method

[image]

Revit 2024 API
Document..::..NewTransitionFitting Method
Document Class See Also Send Feedback
Add a new family instance of an transition fitting into the Autodesk Revit document, using two connectors.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyInstance NewTransitionFitting(
    Connector connector1,
    Connector connector2
)
Visual Basic
Public Function NewTransitionFitting ( _
    connector1 As Connector, _
    connector2 As Connector _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewTransitionFitting(
    Connector^ connector1,
    Connector^ connector2
)

Parameters

connector1
Type: Autodesk.Revit.DB..::..Connector
The first connector to be connected to the transition.
connector2
Type: Autodesk.Revit.DB..::..Connector
The second connector to be connected to the transition.

Return Value

If creation was successful then an family instance to the new object is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument connector1 or connector2 is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the connectors cannot be used for transition creation. For example, they cannot be from the same element, they must be of the same domain, and the owner of connector1 should be a (flex) duct or pipe.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when transition fitting cannot be created.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewUnionFitting Method

[image]

Revit 2024 API
Document..::..NewUnionFitting Method
Document Class See Also Send Feedback
Add a new family instance of an union fitting into the Autodesk Revit document, using two connectors.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyInstance NewUnionFitting(
    Connector connector1,
    Connector connector2
)
Visual Basic
Public Function NewUnionFitting ( _
    connector1 As Connector, _
    connector2 As Connector _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewUnionFitting(
    Connector^ connector1,
    Connector^ connector2
)

Parameters

connector1
Type: Autodesk.Revit.DB..::..Connector
The first connector to be connected to the union.
connector2
Type: Autodesk.Revit.DB..::..Connector
The second connector to be connected to the union.

Return Value

If creation was successful then an family instance to the new object is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument connector1 or connector2 is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the connectors cannot be used for union creation. For example, they cannot be from the same element, they must be of the same domain and shape, and the owner of the connector1 should be a (flex) duct or pipe.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when union fitting cannot be created.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewZone Method

[image]

Revit 2024 API
Document..::..NewZone Method
Document Class See Also Send Feedback
Creates a new Zone element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Zone NewZone(
    Level level,
    Phase phase
)
Visual Basic
Public Function NewZone ( _
    level As Level, _
    phase As Phase _
) As Zone
Visual C++
public:
Zone^ NewZone(
    Level^ level,
    Phase^ phase
)

Parameters

level
Type: Autodesk.Revit.DB..::..Level
The level on which the Zone is to exist.
phase
Type: Autodesk.Revit.DB..::..Phase
The associative phase on which the Zone is to exist.

Return Value

If successful a new Zone element within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the specified parameter Value is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the electrical system cannot be created by these input phase and level.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the level does not exist in the given document.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the phase does not exist in the given document.

See Also

Document Class
Autodesk.Revit.Creation Namespace


Document Properties

[image] [image]

Revit 2024 API
Document Properties
Document Class See Also Send Feedback

The Document type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Document Class
Autodesk.Revit.Creation Namespace


eRefFace Enumeration

[image]

Revit 2024 API
eRefFace Enumeration
See Also Send Feedback
Indicates the reference face. The Opening will be created at the direction perpendicular to the reference face.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum eRefFace
Visual Basic
Public Enumeration eRefFace
Visual C++
public enum class eRefFace

Members

Member name | Description
CenterX | The reference face is at the middle of the element in the direction of x-axis and its normal is parallel to x-axis.
CenterY | The reference face is at the middle of the element in the direction of y-axis and its normal is parallel to y-axis.
CenterZ | The reference face is at the middle of the element in the direction of z-axis and its normal is parallel to z-axis.

Remarks

Direction of the opening.

See Also

Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Class

[image]

Revit 2024 API
FamilyInstanceCreationData Class
Members See Also Send Feedback
A class which wraps the arguments of FamilyInstance for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class FamilyInstanceCreationData
Visual Basic
Public Class FamilyInstanceCreationData
Visual C++
public ref class FamilyInstanceCreationData

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.Creation..::..FamilyInstanceCreationData

See Also

FamilyInstanceCreationData Members
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Members

[image] [image]

Revit 2024 API
FamilyInstanceCreationData Members
FamilyInstanceCreationData Class Constructors Methods Properties See Also Send Feedback

The FamilyInstanceCreationData type exposes the following members.

Constructors

 | Name | Description
Public method | FamilyInstanceCreationData(Object) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(FamilySymbol, IList<(Of <<'(XYZ>)>>)) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(Face, Line, FamilySymbol) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(XYZ, FamilySymbol, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(Curve, FamilySymbol, Level, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(Face, XYZ, XYZ, FamilySymbol) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(XYZ, FamilySymbol, Element, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(XYZ, FamilySymbol, Level, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(XYZ, FamilySymbol, Element, Level, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Axis | Get or set the axis of the FamilyInstance
Public property | RotateAngle | Get or set the rotate angle of the FamilyInstance

See Also

FamilyInstanceCreationData Class
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Constructor

[image] [image]

Revit 2024 API
FamilyInstanceCreationData Constructor
FamilyInstanceCreationData Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FamilyInstanceCreationData(Object) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(FamilySymbol, IList<(Of <<'(XYZ>)>>)) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(Face, Line, FamilySymbol) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(XYZ, FamilySymbol, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(Curve, FamilySymbol, Level, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(Face, XYZ, XYZ, FamilySymbol) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(XYZ, FamilySymbol, Element, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(XYZ, FamilySymbol, Level, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(XYZ, FamilySymbol, Element, Level, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class

See Also

FamilyInstanceCreationData Class
FamilyInstanceCreationData Members
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Constructor (Object)

[image]

Revit 2024 API
FamilyInstanceCreationData Constructor (Object)
FamilyInstanceCreationData Class See Also Send Feedback
Initializes a new instance of the FamilyInstanceCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyInstanceCreationData(
    Object proxy
)
Visual Basic
Public Sub New ( _
    proxy As Object _
)
Visual C++
public:
FamilyInstanceCreationData(
    Object^ proxy
)

Parameters

proxy
Type: System..::..Object

See Also

FamilyInstanceCreationData Class
FamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Constructor (FamilySymbol, IList(XYZ))

[image]

Revit 2024 API
FamilyInstanceCreationData Constructor (FamilySymbol, IList<(Of <(<'XYZ>)>)>)
FamilyInstanceCreationData Class See Also Send Feedback
Initializes a new instance of the FamilyInstanceCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyInstanceCreationData(
    FamilySymbol symbol,
    IList<XYZ> adaptivePoints
)
Visual Basic
Public Sub New ( _
    symbol As FamilySymbol, _
    adaptivePoints As IList(Of XYZ) _
)
Visual C++
public:
FamilyInstanceCreationData(
    FamilySymbol^ symbol,
    IList<XYZ^>^ adaptivePoints
)

Parameters

symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
adaptivePoints
Type: System.Collections.Generic..::..IList<(Of <(<' XYZ >)>)>
The adaptive points where the adaptive instance is to be initialized.

See Also

FamilyInstanceCreationData Class
FamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Constructor (Curve, FamilySymbol, Level, StructuralType)

[image]

Revit 2024 API
FamilyInstanceCreationData Constructor (Curve, FamilySymbol, Level, StructuralType)
FamilyInstanceCreationData Class See Also Send Feedback
Initializes a new instance of the FamilyInstanceCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyInstanceCreationData(
    Curve curve,
    FamilySymbol symbol,
    Level level,
    StructuralType structuralType
)
Visual Basic
Public Sub New ( _
    curve As Curve, _
    symbol As FamilySymbol, _
    level As Level, _
    structuralType As StructuralType _
)
Visual C++
public:
FamilyInstanceCreationData(
    Curve^ curve,
    FamilySymbol^ symbol,
    Level^ level,
    StructuralType structuralType
)

Parameters

curve
Type: Autodesk.Revit.DB..::..Curve
The curve where the instance is based.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
level
Type: Autodesk.Revit.DB..::..Level
A Level object that is used as the base level for the object.
structuralType
Type: Autodesk.Revit.DB.Structure..::..StructuralType
If structural then specify the type of the component.

See Also

FamilyInstanceCreationData Class
FamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Constructor (XYZ, FamilySymbol, Element, StructuralType)

[image]

Revit 2024 API
FamilyInstanceCreationData Constructor (XYZ, FamilySymbol, Element, StructuralType)
FamilyInstanceCreationData Class See Also Send Feedback
Initializes a new instance of the FamilyInstanceCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    Element host,
    StructuralType structuralType
)
Visual Basic
Public Sub New ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    host As Element, _
    structuralType As StructuralType _
)
Visual C++
public:
FamilyInstanceCreationData(
    XYZ^ location,
    FamilySymbol^ symbol,
    Element^ host,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.DB..::..XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
host
Type: Autodesk.Revit.DB..::..Element
The object into which the FamilyInstance is to be inserted, often known as the host.
structuralType
Type: Autodesk.Revit.DB.Structure..::..StructuralType
If structural then specify the type of the component.

See Also

FamilyInstanceCreationData Class
FamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Constructor (XYZ, FamilySymbol, Element, Level, StructuralType)

[image]

Revit 2024 API
FamilyInstanceCreationData Constructor (XYZ, FamilySymbol, Element, Level, StructuralType)
FamilyInstanceCreationData Class See Also Send Feedback
Initializes a new instance of the FamilyInstanceCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    Element host,
    Level level,
    StructuralType structuralType
)
Visual Basic
Public Sub New ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    host As Element, _
    level As Level, _
    structuralType As StructuralType _
)
Visual C++
public:
FamilyInstanceCreationData(
    XYZ^ location,
    FamilySymbol^ symbol,
    Element^ host,
    Level^ level,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.DB..::..XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
host
Type: Autodesk.Revit.DB..::..Element
The object into which the FamilyInstance is to be inserted, often known as the host.
level
Type: Autodesk.Revit.DB..::..Level
A Level object that is used as the base level for the object.
structuralType
Type: Autodesk.Revit.DB.Structure..::..StructuralType
If structural then specify the type of the component.

See Also

FamilyInstanceCreationData Class
FamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Methods

[image] [image]

Revit 2024 API
FamilyInstanceCreationData Methods
FamilyInstanceCreationData Class See Also Send Feedback

The FamilyInstanceCreationData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FamilyInstanceCreationData Class
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Properties

[image] [image]

Revit 2024 API
FamilyInstanceCreationData Properties
FamilyInstanceCreationData Class See Also Send Feedback

The FamilyInstanceCreationData type exposes the following members.

Properties

 | Name | Description
Public property | Axis | Get or set the axis of the FamilyInstance
Public property | RotateAngle | Get or set the rotate angle of the FamilyInstance

See Also

FamilyInstanceCreationData Class
Autodesk.Revit.Creation Namespace


Axis Property

[image]

Revit 2024 API
FamilyInstanceCreationData..::..Axis Property
FamilyInstanceCreationData Class See Also Send Feedback
Get or set the axis of the FamilyInstance

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Line Axis { get; set; }
Visual Basic
Public Property Axis As Line
    Get
    Set
Visual C++
public:
property Line^ Axis {
    Line^ get ();
    void set (Line^ value);
}

Remarks

The element property will be the axis while performing the rotation.

See Also

FamilyInstanceCreationData Class
Autodesk.Revit.Creation Namespace


RotateAngle Property

[image]

Revit 2024 API
FamilyInstanceCreationData..::..RotateAngle Property
FamilyInstanceCreationData Class See Also Send Feedback
Get or set the rotate angle of the FamilyInstance

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double RotateAngle { get; set; }
Visual Basic
Public Property RotateAngle As Double
    Get
    Set
Visual C++
public:
property double RotateAngle {
    double get ();
    void set (double value);
}

Remarks

The FamilyInstance will rotate this angle when the instance is created.

See Also

FamilyInstanceCreationData Class
Autodesk.Revit.Creation Namespace


FamilyItemFactory Class

[image]

Revit 2024 API
FamilyItemFactory Class
Members See Also Send Feedback
The Family Item Factory object is used to create new instances of elements within the Autodesk Revit Family.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class FamilyItemFactory : ItemFactoryBase
Visual Basic
Public Class FamilyItemFactory _
    Inherits ItemFactoryBase
Visual C++
public ref class FamilyItemFactory : public ItemFactoryBase

Remarks

The Family Item Factory object is a utility object that is used to create new instances of elements within the Autodesk Revit Family Document. This object should be used to create elements instead of using New. This object ensures that the elements created are added to the family document correctly.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.Creation..::..ItemFactoryBase
Autodesk.Revit.Creation..::..FamilyItemFactory

See Also

FamilyItemFactory Members
Autodesk.Revit.Creation Namespace


FamilyItemFactory Members

[image] [image]

Revit 2024 API
FamilyItemFactory Members
FamilyItemFactory Class Methods Properties See Also Send Feedback

The FamilyItemFactory type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NewAlignment | Add a new locked alignment into the Autodesk Revit document. (Inherited from ItemFactoryBase.)
Public method | NewAngularDimension(View, Arc, Reference, Reference) | Creates a new angular dimension object using the default dimension type.
Public method | NewAngularDimension(View, Arc, Reference, Reference, DimensionType) | Creates a new angular dimension object using the specified dimension type.
Public method | NewArcLengthDimension(View, Arc, Reference, Reference, Reference) | Creates a new arc length dimension object using the default dimension type.
Public method | NewArcLengthDimension(View, Arc, Reference, Reference, Reference, DimensionType) | Creates a new arc length dimension object using the specified dimension type.
Public method | NewBlend | Add a new Blend instance into the Autodesk Revit family document.
Public method | NewControl | Add a new control into the Autodesk Revit family document.
Public method | NewCurveByPoints | Create a 3d curve through two or more points in an Autodesk Revit family document.
Public method | NewDetailCurve | Creates a new detail curve element. (Inherited from ItemFactoryBase.)
Public method | NewDetailCurveArray | Creates an array of new detail curve elements. (Inherited from ItemFactoryBase.)
Public method | NewDiameterDimension | Creates a new diameter dimension object using the default dimension type.
Public method | NewDimension(View, Line, ReferenceArray) | Creates a new linear dimension object using the default dimension style. (Inherited from ItemFactoryBase.)
Public method | NewDimension(View, Line, ReferenceArray, DimensionType) | Creates a new linear dimension object using the specified dimension style. (Inherited from ItemFactoryBase.)
Public method | NewExtrusion | Add a new Extrusion instance into the Autodesk Revit family document.
Public method | NewExtrusionForm | Create new Form element by Extrude operation, and add it into the Autodesk Revit family document.
Public method | NewFamilyInstance(Face, Line, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a line on that face for its position, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Line, FamilySymbol, View) | Add a line based detail family instance into the Autodesk Revit document, using an line and a view where the instance should be placed. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Reference, Line, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a line on that face for its position, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, StructuralType) | Inserts a new instance of a family into the document, using a location and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, View) | Add a new family instance into the Autodesk Revit document, using an origin and a view where the instance should be placed. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Face, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a location, reference direction, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Reference, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a location, reference direction, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the host element. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, Level, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the level. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a reference direction. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstances2 | Creates Family instances within the document. (Inherited from ItemFactoryBase.)
Public method | NewFormByCap | Create new Form element by cap operation (to create a single-surface form), and add it into the Autodesk Revit family document.
Public method | NewFormByThickenSingleSurface | Create a new Form element by thickening a single-surface form, and add it into the Autodesk Revit family document.
Public method | NewGroup | Creates a new type of group. (Inherited from ItemFactoryBase.)
Public method | NewLinearDimension(View, Line, ReferenceArray) | Generate a new linear dimension object using the default dimension type.
Public method | NewLinearDimension(View, Line, ReferenceArray, DimensionType) | Creates a new linear dimension object using the specified dimension type.
Public method | NewLoftForm | Create new Form element by Loft operation, and add it into the Autodesk Revit family document.
Public method | NewModelCurve | Creates a new model line element. (Inherited from ItemFactoryBase.)
Public method | NewModelCurveArray | Creates an array of new model line elements. (Inherited from ItemFactoryBase.)
Public method | NewModelText | Create a model text in the Autodesk Revit family document.
Public method | NewOpening | Create an opening to cut the wall or ceiling.
Public method | NewRadialDimension(View, Reference, XYZ) | Creates a new radial dimension object using the default dimension type.
Public method | NewRadialDimension(View, Reference, XYZ, DimensionType) | Generate a new radial dimension object using a specified dimension type.
Public method | NewReferencePlane | Creates a new instance of ReferencePlane. (Inherited from ItemFactoryBase.)
Public method | NewReferencePlane2 | Creates a new instance of ReferencePlane. (Inherited from ItemFactoryBase.)
Public method | NewReferencePoint(PointElementReference) | Create a reference point on an existing reference in an Autodesk Revit family document.
Public method | NewReferencePoint(Transform) | Create a reference point at a given location and with a given coordinate system in an Autodesk Revit family document.
Public method | NewReferencePoint(XYZ) | Create a reference point at a given location in an Autodesk Revit family document.
Public method | NewRevolution | Add a new Revolution instance into the Autodesk Revit family document.
Public method | NewRevolveForms | Create new Form elements by revolve operation, and add them into the Autodesk Revit family document.
Public method | NewSweep(Boolean, ReferenceArray, SweepProfile, Int32, ProfilePlaneLocation) | Adds a new sweep form into the family document, using an array of selected references as a 3D path.
Public method | NewSweep(Boolean, CurveArray, SketchPlane, SweepProfile, Int32, ProfilePlaneLocation) | Adds a new sweep form to the family document, using a path of curve elements.
Public method | NewSweptBlend(Boolean, Reference, SweepProfile, SweepProfile) | Adds a new swept blend into the family document, using a selected reference as the path.
Public method | NewSweptBlend(Boolean, Curve, SketchPlane, SweepProfile, SweepProfile) | Add a new swept blend into the family document, using a curve as the path.
Public method | NewSweptBlendForm | Create new Form element by swept blend operation, and add it into the Autodesk Revit family document.
Public method | NewSymbolicCurve | Create a symbolic curve in an Autodesk Revit family document.
Public method | PlaceGroup | Place an instance of a Model Group into the Autodesk Revit document, using a location and a group type. (Inherited from ItemFactoryBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


FamilyItemFactory Methods

[image] [image]

Revit 2024 API
FamilyItemFactory Methods
FamilyItemFactory Class See Also Send Feedback

The FamilyItemFactory type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NewAlignment | Add a new locked alignment into the Autodesk Revit document. (Inherited from ItemFactoryBase.)
Public method | NewAngularDimension(View, Arc, Reference, Reference) | Creates a new angular dimension object using the default dimension type.
Public method | NewAngularDimension(View, Arc, Reference, Reference, DimensionType) | Creates a new angular dimension object using the specified dimension type.
Public method | NewArcLengthDimension(View, Arc, Reference, Reference, Reference) | Creates a new arc length dimension object using the default dimension type.
Public method | NewArcLengthDimension(View, Arc, Reference, Reference, Reference, DimensionType) | Creates a new arc length dimension object using the specified dimension type.
Public method | NewBlend | Add a new Blend instance into the Autodesk Revit family document.
Public method | NewControl | Add a new control into the Autodesk Revit family document.
Public method | NewCurveByPoints | Create a 3d curve through two or more points in an Autodesk Revit family document.
Public method | NewDetailCurve | Creates a new detail curve element. (Inherited from ItemFactoryBase.)
Public method | NewDetailCurveArray | Creates an array of new detail curve elements. (Inherited from ItemFactoryBase.)
Public method | NewDiameterDimension | Creates a new diameter dimension object using the default dimension type.
Public method | NewDimension(View, Line, ReferenceArray) | Creates a new linear dimension object using the default dimension style. (Inherited from ItemFactoryBase.)
Public method | NewDimension(View, Line, ReferenceArray, DimensionType) | Creates a new linear dimension object using the specified dimension style. (Inherited from ItemFactoryBase.)
Public method | NewExtrusion | Add a new Extrusion instance into the Autodesk Revit family document.
Public method | NewExtrusionForm | Create new Form element by Extrude operation, and add it into the Autodesk Revit family document.
Public method | NewFamilyInstance(Face, Line, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a line on that face for its position, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Line, FamilySymbol, View) | Add a line based detail family instance into the Autodesk Revit document, using an line and a view where the instance should be placed. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Reference, Line, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a line on that face for its position, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, StructuralType) | Inserts a new instance of a family into the document, using a location and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, View) | Add a new family instance into the Autodesk Revit document, using an origin and a view where the instance should be placed. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Face, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a location, reference direction, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Reference, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a location, reference direction, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the host element. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, Level, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the level. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a reference direction. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstances2 | Creates Family instances within the document. (Inherited from ItemFactoryBase.)
Public method | NewFormByCap | Create new Form element by cap operation (to create a single-surface form), and add it into the Autodesk Revit family document.
Public method | NewFormByThickenSingleSurface | Create a new Form element by thickening a single-surface form, and add it into the Autodesk Revit family document.
Public method | NewGroup | Creates a new type of group. (Inherited from ItemFactoryBase.)
Public method | NewLinearDimension(View, Line, ReferenceArray) | Generate a new linear dimension object using the default dimension type.
Public method | NewLinearDimension(View, Line, ReferenceArray, DimensionType) | Creates a new linear dimension object using the specified dimension type.
Public method | NewLoftForm | Create new Form element by Loft operation, and add it into the Autodesk Revit family document.
Public method | NewModelCurve | Creates a new model line element. (Inherited from ItemFactoryBase.)
Public method | NewModelCurveArray | Creates an array of new model line elements. (Inherited from ItemFactoryBase.)
Public method | NewModelText | Create a model text in the Autodesk Revit family document.
Public method | NewOpening | Create an opening to cut the wall or ceiling.
Public method | NewRadialDimension(View, Reference, XYZ) | Creates a new radial dimension object using the default dimension type.
Public method | NewRadialDimension(View, Reference, XYZ, DimensionType) | Generate a new radial dimension object using a specified dimension type.
Public method | NewReferencePlane | Creates a new instance of ReferencePlane. (Inherited from ItemFactoryBase.)
Public method | NewReferencePlane2 | Creates a new instance of ReferencePlane. (Inherited from ItemFactoryBase.)
Public method | NewReferencePoint(PointElementReference) | Create a reference point on an existing reference in an Autodesk Revit family document.
Public method | NewReferencePoint(Transform) | Create a reference point at a given location and with a given coordinate system in an Autodesk Revit family document.
Public method | NewReferencePoint(XYZ) | Create a reference point at a given location in an Autodesk Revit family document.
Public method | NewRevolution | Add a new Revolution instance into the Autodesk Revit family document.
Public method | NewRevolveForms | Create new Form elements by revolve operation, and add them into the Autodesk Revit family document.
Public method | NewSweep(Boolean, ReferenceArray, SweepProfile, Int32, ProfilePlaneLocation) | Adds a new sweep form into the family document, using an array of selected references as a 3D path.
Public method | NewSweep(Boolean, CurveArray, SketchPlane, SweepProfile, Int32, ProfilePlaneLocation) | Adds a new sweep form to the family document, using a path of curve elements.
Public method | NewSweptBlend(Boolean, Reference, SweepProfile, SweepProfile) | Adds a new swept blend into the family document, using a selected reference as the path.
Public method | NewSweptBlend(Boolean, Curve, SketchPlane, SweepProfile, SweepProfile) | Add a new swept blend into the family document, using a curve as the path.
Public method | NewSweptBlendForm | Create new Form element by swept blend operation, and add it into the Autodesk Revit family document.
Public method | NewSymbolicCurve | Create a symbolic curve in an Autodesk Revit family document.
Public method | PlaceGroup | Place an instance of a Model Group into the Autodesk Revit document, using a location and a group type. (Inherited from ItemFactoryBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewAngularDimension Method

[image] [image]

Revit 2024 API
FamilyItemFactory..::..NewAngularDimension Method
FamilyItemFactory Class See Also Send Feedback
Creates a new angular dimension object.

Overload List

 | Name | Description
Public method | NewAngularDimension(View, Arc, Reference, Reference) | Creates a new angular dimension object using the default dimension type.
Public method | NewAngularDimension(View, Arc, Reference, Reference, DimensionType) | Creates a new angular dimension object using the specified dimension type.

See Also

FamilyItemFactory Class
FamilyItemFactory Members
Autodesk.Revit.Creation Namespace


NewAngularDimension Method (View, Arc, Reference, Reference)

[image]

Revit 2024 API
FamilyItemFactory..::..NewAngularDimension Method (View, Arc, Reference, Reference)
FamilyItemFactory Class See Also Send Feedback
Creates a new angular dimension object using the default dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Dimension NewAngularDimension(
    View view,
    Arc arc,
    Reference firstRef,
    Reference secondRef
)
Visual Basic
Public Function NewAngularDimension ( _
    view As View, _
    arc As Arc, _
    firstRef As Reference, _
    secondRef As Reference _
) As Dimension
Visual C++
public:
Dimension^ NewAngularDimension(
    View^ view,
    Arc^ arc,
    Reference^ firstRef,
    Reference^ secondRef
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view in which the dimension is to be visible.
arc
Type: Autodesk.Revit.DB..::..Arc
The extension arc of the dimension.
firstRef
Type: Autodesk.Revit.DB..::..Reference
The first geometric reference to which the dimension is to be bound. The reference must be perpendicular to the extension arc.
secondRef
Type: Autodesk.Revit.DB..::..Reference
The second geometric reference to which the dimension is to be bound. The reference must be perpendicular to the extension arc.

Return Value

If creation was successful the new angular dimension is returned, otherwise an exception with failure information will be thrown.

Remarks

The currently user set default style is used for the created dimension.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when any input argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the argument is invalid.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewAngularDimension Overload
Autodesk.Revit.Creation Namespace


NewAngularDimension Method (View, Arc, Reference, Reference, DimensionType)

[image]

Revit 2024 API
FamilyItemFactory..::..NewAngularDimension Method (View, Arc, Reference, Reference, DimensionType)
FamilyItemFactory Class See Also Send Feedback
Creates a new angular dimension object using the specified dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Dimension NewAngularDimension(
    View view,
    Arc arc,
    Reference firstRef,
    Reference secondRef,
    DimensionType dimensionType
)
Visual Basic
Public Function NewAngularDimension ( _
    view As View, _
    arc As Arc, _
    firstRef As Reference, _
    secondRef As Reference, _
    dimensionType As DimensionType _
) As Dimension
Visual C++
public:
Dimension^ NewAngularDimension(
    View^ view,
    Arc^ arc,
    Reference^ firstRef,
    Reference^ secondRef,
    DimensionType^ dimensionType
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view in which the dimension is to be visible.
arc
Type: Autodesk.Revit.DB..::..Arc
The extension arc of the dimension.
firstRef
Type: Autodesk.Revit.DB..::..Reference
The first geometric reference to which the dimension is to be bound. The reference must be perpendicular to the extension arc.
secondRef
Type: Autodesk.Revit.DB..::..Reference
The second geometric reference to which the dimension is to be bound. The reference must be perpendicular to the extension arc.
dimensionType
Type: Autodesk.Revit.DB..::..DimensionType
The dimension style to be used for the dimension.

Return Value

If creation was successful the new angular dimension is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when any input argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the argument firstRef/secondRef/dimensionType is invalid.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewAngularDimension Overload
Autodesk.Revit.Creation Namespace


NewArcLengthDimension Method

[image] [image]

Revit 2024 API
FamilyItemFactory..::..NewArcLengthDimension Method
FamilyItemFactory Class See Also Send Feedback
Creates a new arc length dimension object.

Overload List

 | Name | Description
Public method | NewArcLengthDimension(View, Arc, Reference, Reference, Reference) | Creates a new arc length dimension object using the default dimension type.
Public method | NewArcLengthDimension(View, Arc, Reference, Reference, Reference, DimensionType) | Creates a new arc length dimension object using the specified dimension type.

See Also

FamilyItemFactory Class
FamilyItemFactory Members
Autodesk.Revit.Creation Namespace


NewArcLengthDimension Method (View, Arc, Reference, Reference, Reference)

[image]

Revit 2024 API
FamilyItemFactory..::..NewArcLengthDimension Method (View, Arc, Reference, Reference, Reference)
FamilyItemFactory Class Example See Also Send Feedback
Creates a new arc length dimension object using the default dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Dimension NewArcLengthDimension(
    View view,
    Arc arc,
    Reference arcRef,
    Reference firstRef,
    Reference secondRef
)
Visual Basic
Public Function NewArcLengthDimension ( _
    view As View, _
    arc As Arc, _
    arcRef As Reference, _
    firstRef As Reference, _
    secondRef As Reference _
) As Dimension
Visual C++
public:
Dimension^ NewArcLengthDimension(
    View^ view,
    Arc^ arc,
    Reference^ arcRef,
    Reference^ firstRef,
    Reference^ secondRef
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view in which the dimension is to be visible.
arc
Type: Autodesk.Revit.DB..::..Arc
The extension arc of the dimension.
arcRef
Type: Autodesk.Revit.DB..::..Reference
Geometric reference of the arc to which the dimension is to be bound. This reference must be parallel to the extension arc.
firstRef
Type: Autodesk.Revit.DB..::..Reference
The first geometric reference to which the dimension is to be bound. This reference must intersect the arcRef reference.
secondRef
Type: Autodesk.Revit.DB..::..Reference
The second geometric reference to which the dimension is to be bound. This reference must intersect the arcRef reference.

Return Value

If creation was successful the new arc length dimension is returned, otherwise an exception with failure information will be thrown.

Remarks

The currently user set default style is used for the created dimension.

Examples

CopyC#
public Dimension CreateArcDimension(Document document, SketchPlane sketchPlane)
{
    Autodesk.Revit.Creation.Application appCreate = document.Application.Create;
    Line gLine1 = Line.CreateBound(new XYZ(0, 2, 0), new XYZ(2, 2, 0));
    Line gLine2 = Line.CreateBound(new XYZ(0, 2, 0), new XYZ(2, 4, 0));
    Arc arctoDim = Arc.Create(new XYZ(1, 2, 0), new XYZ(-1, 2, 0), new XYZ(0, 3, 0));
    Arc arcofDim = Arc.Create(new XYZ(0, 3, 0), new XYZ(1, 2, 0), new XYZ(0.8, 2.8, 0));

    Autodesk.Revit.Creation.FamilyItemFactory creationFamily = document.FamilyCreate;
    ModelCurve modelCurve1 = creationFamily.NewModelCurve(gLine1, sketchPlane);
    ModelCurve modelCurve2 = creationFamily.NewModelCurve(gLine2, sketchPlane);
    ModelCurve modelCurve3 = creationFamily.NewModelCurve(arctoDim, sketchPlane);
    //get their reference
    Reference ref1 = modelCurve1.GeometryCurve.Reference;
    Reference ref2 = modelCurve2.GeometryCurve.Reference;
    Reference arcRef = modelCurve3.GeometryCurve.Reference;

    Dimension newArcDim = creationFamily.NewArcLengthDimension(document.ActiveView, arcofDim, arcRef, ref1, ref2);
    if (newArcDim == null)
    {
        throw new Exception("Failed to create new arc length dimension.");
    }

    return newArcDim;
}
CopyVB.NET
Public Function CreateArcDimension(document As Document, sketchPlane As SketchPlane) As Dimension
    Dim appCreate As Autodesk.Revit.Creation.Application = document.Application.Create
    Dim gLine1 As Line = Line.CreateBound(New XYZ(0, 2, 0), New XYZ(2, 2, 0))
    Dim gLine2 As Line = Line.CreateBound(New XYZ(0, 2, 0), New XYZ(2, 4, 0))
    Dim arctoDim As Arc = Arc.Create(New XYZ(1, 2, 0), New XYZ(-1, 2, 0), New XYZ(0, 3, 0))
    Dim arcofDim As Arc = Arc.Create(New XYZ(0, 3, 0), New XYZ(1, 2, 0), New XYZ(0.8, 2.8, 0))

    Dim creationFamily As Autodesk.Revit.Creation.FamilyItemFactory = document.FamilyCreate
    Dim modelCurve1 As ModelCurve = creationFamily.NewModelCurve(gLine1, sketchPlane)
    Dim modelCurve2 As ModelCurve = creationFamily.NewModelCurve(gLine2, sketchPlane)
    Dim modelCurve3 As ModelCurve = creationFamily.NewModelCurve(arctoDim, sketchPlane)
    'get their reference
    Dim ref1 As Reference = modelCurve1.GeometryCurve.Reference
    Dim ref2 As Reference = modelCurve2.GeometryCurve.Reference
    Dim arcRef As Reference = modelCurve3.GeometryCurve.Reference

    Dim newArcDim As Dimension = creationFamily.NewArcLengthDimension(document.ActiveView, arcofDim, arcRef, ref1, ref2)
    If newArcDim Is Nothing Then
        Throw New Exception("Failed to create new arc length dimension.")
    End If

    Return newArcDim
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when any input argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the argument arcRef/ref1/ref2 is invalid.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewArcLengthDimension Overload
Autodesk.Revit.Creation Namespace


NewArcLengthDimension Method (View, Arc, Reference, Reference, Reference, DimensionType)

[image]

Revit 2024 API
FamilyItemFactory..::..NewArcLengthDimension Method (View, Arc, Reference, Reference, Reference, DimensionType)
FamilyItemFactory Class See Also Send Feedback
Creates a new arc length dimension object using the specified dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Dimension NewArcLengthDimension(
    View view,
    Arc arc,
    Reference arcRef,
    Reference firstRef,
    Reference secondRef,
    DimensionType dimensionType
)
Visual Basic
Public Function NewArcLengthDimension ( _
    view As View, _
    arc As Arc, _
    arcRef As Reference, _
    firstRef As Reference, _
    secondRef As Reference, _
    dimensionType As DimensionType _
) As Dimension
Visual C++
public:
Dimension^ NewArcLengthDimension(
    View^ view,
    Arc^ arc,
    Reference^ arcRef,
    Reference^ firstRef,
    Reference^ secondRef,
    DimensionType^ dimensionType
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view in which the dimension is to be visible.
arc
Type: Autodesk.Revit.DB..::..Arc
The extension arc of the dimension.
arcRef
Type: Autodesk.Revit.DB..::..Reference
Geometric reference of the arc to which the dimension is to be bound. This reference must be parallel to the extension arc.
firstRef
Type: Autodesk.Revit.DB..::..Reference
The first geometric reference to which the dimension is to be bound. This reference must intersect the arcRef reference.
secondRef
Type: Autodesk.Revit.DB..::..Reference
The second geometric reference to which the dimension is to be bound. This reference must intersect the arcRef reference.
dimensionType
Type: Autodesk.Revit.DB..::..DimensionType
The dimension style to be used for the dimension.

Return Value

If creation was successful the new arc length dimension is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when any input argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the argument arcRef/ref1/ref2/dimensionType is invalid.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewArcLengthDimension Overload
Autodesk.Revit.Creation Namespace


NewBlend Method

[image]

Revit 2024 API
FamilyItemFactory..::..NewBlend Method
FamilyItemFactory Class Example See Also Send Feedback
Add a new Blend instance into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Blend NewBlend(
    bool isSolid,
    CurveArray profile1,
    CurveArray profile2,
    SketchPlane sketchPlane
)
Visual Basic
Public Function NewBlend ( _
    isSolid As Boolean, _
    profile1 As CurveArray, _
    profile2 As CurveArray, _
    sketchPlane As SketchPlane _
) As Blend
Visual C++
public:
Blend^ NewBlend(
    bool isSolid,
    CurveArray^ profile1,
    CurveArray^ profile2,
    SketchPlane^ sketchPlane
)

Parameters

isSolid
Type: System..::..Boolean
Indicates if the Blend is Solid or Void.
profile1
Type: Autodesk.Revit.DB..::..CurveArray
The first blend section. It should represent a single, planar curve loop.
profile2
Type: Autodesk.Revit.DB..::..CurveArray
The second blend section. It should represent a single, planar curve loop lying in a plane parallel to that of the first blend section.
sketchPlane
Type: Autodesk.Revit.DB..::..SketchPlane
The sketch plane for the first profile. Use this to associate the "base" of the blend to geometry from another element. Optional, it can be nullNothingnullptra null reference (Nothing in Visual Basic) if you want Revit to derive a new sketch plane from the geometry of the base profile.

Return Value

If creation was successful the new blend is returned, otherwise an exception with failure information will be thrown.

Remarks

This method creates a blend in a family document. Revit will determine an appropriate default mapping for the vertices of the two profiles. A profile loop cannot contain just one closed curve - in such a case, the curve must be split into at least two segments, so that Revit can find vertices to use for mapping the blend. Caution: several aspects of the Blend are not (easily) predictable from the input arguments. For example, the Blend's TopOffset may be less than its BottomOffset in some cases, depending on the orientations of the profile loops and the orientation of the sketch plane (if a sketch plane is provided). Also, such orientations can affect whether the first or second profile lies in the sketch plane (if a sketch plane is provided).

Examples

CopyC#
private Blend CreateBlend(UIApplication application, SketchPlane sketchPlane)
{
    Blend blend = null;

    // make sure we have a family document
    Document familyDocument = application.ActiveUIDocument.Document;
    if (true == familyDocument.IsFamilyDocument)
    {
        // Define top and base profiles for the blend
        CurveArray topProfile = new CurveArray();
        CurveArray baseProfile = new CurveArray();

        // create rectangular base profile
        XYZ p00 = XYZ.Zero;
        XYZ p01 = new XYZ(10, 0, 0);
        XYZ p02 = new XYZ(10, 10, 0);
        XYZ p03 = new XYZ(0, 10, 0);
        Line line01 = Line.CreateBound(p00, p01);
        Line line02 = Line.CreateBound(p01, p02);
        Line line03 = Line.CreateBound(p02, p03);
        Line line04 = Line.CreateBound(p03, p00);

        baseProfile.Append(line01);
        baseProfile.Append(line02);
        baseProfile.Append(line03);
        baseProfile.Append(line04);

        // create rectangular top profile
        XYZ p10 = new XYZ(5, 2, 10);
        XYZ p11 = new XYZ(8, 5, 10);
        XYZ p12 = new XYZ(5, 8, 10);
        XYZ p13 = new XYZ(2, 5, 10);
        Line line11 = Line.CreateBound(p10, p11);
        Line line12 = Line.CreateBound(p11, p12);
        Line line13 = Line.CreateBound(p12, p13);
        Line line14 = Line.CreateBound(p13, p10);

        topProfile.Append(line11);
        topProfile.Append(line12);
        topProfile.Append(line13);
        topProfile.Append(line14);

        // now create solid rectangular blend
        blend = familyDocument.FamilyCreate.NewBlend(true, topProfile, baseProfile, sketchPlane);

        if (null != blend)
        {
            // move to proper place
            XYZ transPoint1 = new XYZ(0, 11, 0);
            ElementTransformUtils.MoveElement(familyDocument, blend.Id, transPoint1);
        }
        else
        {
            throw new Exception("Create new Blend failed.");
        }
    }
    else
    {
        throw new Exception("Please open a Family document before invoking this command.");
    }

    return blend;
}
CopyVB.NET
Private Function CreateBlend(application As UIApplication, sketchPlane As SketchPlane) As Blend
    Dim blend As Blend = Nothing

    ' make sure we have a family document
    Dim familyDocument As Document = application.ActiveUIDocument.Document
    If True = familyDocument.IsFamilyDocument Then
        ' Define top and base profiles for the blend
        Dim topProfile As New CurveArray()
        Dim baseProfile As New CurveArray()

        ' create rectangular base profile
        Dim p00 As XYZ = XYZ.Zero
        Dim p01 As New XYZ(10, 0, 0)
        Dim p02 As New XYZ(10, 10, 0)
        Dim p03 As New XYZ(0, 10, 0)
        Dim line01 As Line = Line.CreateBound(p00, p01)
        Dim line02 As Line = Line.CreateBound(p01, p02)
        Dim line03 As Line = Line.CreateBound(p02, p03)
        Dim line04 As Line = Line.CreateBound(p03, p00)

        baseProfile.Append(line01)
        baseProfile.Append(line02)
        baseProfile.Append(line03)
        baseProfile.Append(line04)

        ' create rectangular top profile
        Dim p10 As New XYZ(5, 2, 10)
        Dim p11 As New XYZ(8, 5, 10)
        Dim p12 As New XYZ(5, 8, 10)
        Dim p13 As New XYZ(2, 5, 10)
        Dim line11 As Line = Line.CreateBound(p10, p11)
        Dim line12 As Line = Line.CreateBound(p11, p12)
        Dim line13 As Line = Line.CreateBound(p12, p13)
        Dim line14 As Line = Line.CreateBound(p13, p10)

        topProfile.Append(line11)
        topProfile.Append(line12)
        topProfile.Append(line13)
        topProfile.Append(line14)

        ' now create solid rectangular blend
        blend = familyDocument.FamilyCreate.NewBlend(True, topProfile, baseProfile, sketchPlane)

        If blend IsNot Nothing Then
            ' move to proper place
            Dim transPoint1 As New XYZ(0, 11, 0)
            ElementTransformUtils.MoveElement(familyDocument, blend.Id, transPoint1)
        Else
            Throw New Exception("Create new Blend failed.")
        End If
    Else
        Throw New Exception("Please open a Family document before invoking this command.")
    End If

    Return blend
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the argument is invalid.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when creation is attempted in Conceptual Mass, 2D, or other family where blends cannot be created.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewControl Method

[image]

Revit 2024 API
FamilyItemFactory..::..NewControl Method
FamilyItemFactory Class See Also Send Feedback
Add a new control into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Control NewControl(
    ControlShape controlShape,
    View view,
    XYZ origin
)
Visual Basic
Public Function NewControl ( _
    controlShape As ControlShape, _
    view As View, _
    origin As XYZ _
) As Control
Visual C++
public:
Control^ NewControl(
    ControlShape controlShape,
    View^ view,
    XYZ^ origin
)

Parameters

controlShape
Type: Autodesk.Revit.DB..::..ControlShape
The shape of the control.
view
Type: Autodesk.Revit.DB..::..View
The view in which the control is to be visible. It must be a FloorPlan view or a CeilingPlan view.
origin
Type: Autodesk.Revit.DB..::..XYZ
The origin of the control.

Return Value

If successful, the newly created control is returned, otherwise an exception with error information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"view" or "position"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-"view"-is invalid.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the input argument-"controlType"-is out of range.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when control creation failed.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewCurveByPoints Method

[image]

Revit 2024 API
FamilyItemFactory..::..NewCurveByPoints Method
FamilyItemFactory Class Example See Also Send Feedback
Create a 3d curve through two or more points in an Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CurveByPoints NewCurveByPoints(
    ReferencePointArray points
)
Visual Basic
Public Function NewCurveByPoints ( _
    points As ReferencePointArray _
) As CurveByPoints
Visual C++
public:
CurveByPoints^ NewCurveByPoints(
    ReferencePointArray^ points
)

Parameters

points
Type: Autodesk.Revit.DB..::..ReferencePointArray
Two or more PointElements. The curve will interpolate these points.

Return Value

The newly created curve.

Examples

CopyC#
ReferencePointArray rpa = new ReferencePointArray();

XYZ xyz = document.Application.Create.NewXYZ(0, 0, 0);
ReferencePoint rp = document.FamilyCreate.NewReferencePoint(xyz);
rpa.Append(rp);

xyz = document.Application.Create.NewXYZ(0, 30, 10);
rp = document.FamilyCreate.NewReferencePoint(xyz);
rpa.Append(rp);

xyz = document.Application.Create.NewXYZ(0, 60, 0);
rp = document.FamilyCreate.NewReferencePoint(xyz);
rpa.Append(rp);

xyz = document.Application.Create.NewXYZ(0, 100, 30);
rp = document.FamilyCreate.NewReferencePoint(xyz);
rpa.Append(rp);

xyz = document.Application.Create.NewXYZ(0, 150, 0);
rp = document.FamilyCreate.NewReferencePoint(xyz);
rpa.Append(rp);

curve = document.FamilyCreate.NewCurveByPoints(rpa);
CopyVB.NET
Dim rpa As New ReferencePointArray()

Dim xyz As XYZ = document.Application.Create.NewXYZ(0, 0, 0)
Dim rp As ReferencePoint = document.FamilyCreate.NewReferencePoint(xyz)
rpa.Append(rp)

xyz = document.Application.Create.NewXYZ(0, 30, 10)
rp = document.FamilyCreate.NewReferencePoint(xyz)
rpa.Append(rp)

xyz = document.Application.Create.NewXYZ(0, 60, 0)
rp = document.FamilyCreate.NewReferencePoint(xyz)
rpa.Append(rp)

xyz = document.Application.Create.NewXYZ(0, 100, 30)
rp = document.FamilyCreate.NewReferencePoint(xyz)
rpa.Append(rp)

xyz = document.Application.Create.NewXYZ(0, 150, 0)
rp = document.FamilyCreate.NewReferencePoint(xyz)
rpa.Append(rp)

curve = document.FamilyCreate.NewCurveByPoints(rpa)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when points is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when points does not contain at least two PointElements.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the family is not a Conceptual Mass Family.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewDimension Method

[image] [image]

Revit 2024 API
FamilyItemFactory..::..NewDimension Method
FamilyItemFactory Class See Also Send Feedback
Creates a new linear dimension object.

Overload List

 | Name | Description
Public method | NewDimension(View, Line, ReferenceArray) | Creates a new linear dimension object using the default dimension style. (Inherited from ItemFactoryBase.)
Public method | NewDimension(View, Line, ReferenceArray, DimensionType) | Creates a new linear dimension object using the specified dimension style. (Inherited from ItemFactoryBase.)

See Also

FamilyItemFactory Class
FamilyItemFactory Members
Autodesk.Revit.Creation Namespace


NewExtrusion Method

[image]

Revit 2024 API
FamilyItemFactory..::..NewExtrusion Method
FamilyItemFactory Class Example See Also Send Feedback
Add a new Extrusion instance into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Extrusion NewExtrusion(
    bool isSolid,
    CurveArrArray profile,
    SketchPlane sketchPlane,
    double end
)
Visual Basic
Public Function NewExtrusion ( _
    isSolid As Boolean, _
    profile As CurveArrArray, _
    sketchPlane As SketchPlane, _
    end As Double _
) As Extrusion
Visual C++
public:
Extrusion^ NewExtrusion(
    bool isSolid,
    CurveArrArray^ profile,
    SketchPlane^ sketchPlane,
    double end
)

Parameters

isSolid
Type: System..::..Boolean
Indicates if the Extrusion is Solid or Void.
profile
Type: Autodesk.Revit.DB..::..CurveArrArray
The profile of the newly created Extrusion. This may contain more than one curve loop. Each loop must be a fully closed curve loop and the loops may not intersect. All input curves must lie in the same plane. The loop can be a unbound circle or ellipse, but its geometry will be split in two in order to satisfy requirements for sketches used in extrusions.
sketchPlane
Type: Autodesk.Revit.DB..::..SketchPlane
The sketch plane for the extrusion. The direction of extrusion is determined by the normal for the sketch plane. To extrude in the other direction set the end value to negative.
end
Type: System..::..Double
The length of the extrusion.

Return Value

If creation was successful the new Extrusion is returned, otherwise an exception with failure information will be thrown.

Remarks

This method creates an extrusion in a family document. The extrusion will be extended perpendicular to the sketch plane of the extrusion profile.

Examples

CopyC#
private Extrusion CreateExtrusion(Autodesk.Revit.DB.Document document, SketchPlane sketchPlane)
{
    Extrusion rectExtrusion = null;

    // make sure we have a family document
    if (true == document.IsFamilyDocument)
    {
        // define the profile for the extrusion
        CurveArrArray curveArrArray = new CurveArrArray();
        CurveArray curveArray1 = new CurveArray();
        CurveArray curveArray2 = new CurveArray();
        CurveArray curveArray3 = new CurveArray();

        // create a rectangular profile
        XYZ p0 = XYZ.Zero;
        XYZ p1 = new XYZ(10, 0, 0);
        XYZ p2 = new XYZ(10, 10, 0);
        XYZ p3 = new XYZ(0, 10, 0);
        Line line1 = Line.CreateBound(p0, p1);
        Line line2 = Line.CreateBound(p1, p2);
        Line line3 = Line.CreateBound(p2, p3);
        Line line4 = Line.CreateBound(p3, p0);
        curveArray1.Append(line1);
        curveArray1.Append(line2);
        curveArray1.Append(line3);
        curveArray1.Append(line4);

        curveArrArray.Append(curveArray1);

        // create solid rectangular extrusion
        rectExtrusion = document.FamilyCreate.NewExtrusion(true, curveArrArray, sketchPlane, 10);

        if (null != rectExtrusion)
        {
            // move extrusion to proper place
            XYZ transPoint1 = new XYZ(-16, 0, 0);
            ElementTransformUtils.MoveElement(document, rectExtrusion.Id, transPoint1);
        }
        else
        {
            throw new Exception("Create new Extrusion failed.");
        }
    }
    else
    {
        throw new Exception("Please open a Family document before invoking this command.");
    }

    return rectExtrusion;
}
CopyVB.NET
Private Function CreateExtrusion(document As Autodesk.Revit.DB.Document, sketchPlane As SketchPlane) As Extrusion
    Dim rectExtrusion As Extrusion = Nothing

    ' make sure we have a family document
    If True = document.IsFamilyDocument Then
        ' define the profile for the extrusion
        Dim curveArrArray As New CurveArrArray()
        Dim curveArray1 As New CurveArray()
        Dim curveArray2 As New CurveArray()
        Dim curveArray3 As New CurveArray()

        ' create a rectangular profile
        Dim p0 As XYZ = XYZ.Zero
        Dim p1 As New XYZ(10, 0, 0)
        Dim p2 As New XYZ(10, 10, 0)
        Dim p3 As New XYZ(0, 10, 0)
        Dim line1 As Line = Line.CreateBound(p0, p1)
        Dim line2 As Line = Line.CreateBound(p1, p2)
        Dim line3 As Line = Line.CreateBound(p2, p3)
        Dim line4 As Line = Line.CreateBound(p3, p0)
        curveArray1.Append(line1)
        curveArray1.Append(line2)
        curveArray1.Append(line3)
        curveArray1.Append(line4)

        curveArrArray.Append(curveArray1)

        ' create solid rectangular extrusion
        rectExtrusion = document.FamilyCreate.NewExtrusion(True, curveArrArray, sketchPlane, 10)

        If rectExtrusion IsNot Nothing Then
            ' move extrusion to proper place
            Dim transPoint1 As New XYZ(-16, 0, 0)
            ElementTransformUtils.MoveElement(document, rectExtrusion.Id, transPoint1)
        Else
            Throw New Exception("Create new Extrusion failed.")
        End If
    Else
        Throw New Exception("Please open a Family document before invoking this command.")
    End If

    Return rectExtrusion
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-profile-is nullNothingnullptra null reference (Nothing in Visual Basic) or empty array.
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-sketchPlane-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-sketchPlane-is an invalid sketch plane.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewExtrusionForm Method

[image]

Revit 2024 API
FamilyItemFactory..::..NewExtrusionForm Method
FamilyItemFactory Class Example See Also Send Feedback
Create new Form element by Extrude operation, and add it into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Form NewExtrusionForm(
    bool isSolid,
    ReferenceArray profile,
    XYZ direction
)
Visual Basic
Public Function NewExtrusionForm ( _
    isSolid As Boolean, _
    profile As ReferenceArray, _
    direction As XYZ _
) As Form
Visual C++
public:
Form^ NewExtrusionForm(
    bool isSolid,
    ReferenceArray^ profile,
    XYZ^ direction
)

Parameters

isSolid
Type: System..::..Boolean
Indicates if the Form is Solid or Void.
profile
Type: Autodesk.Revit.DB..::..ReferenceArray
The profile of extrusion. It should consist of only one curve loop.
direction
Type: Autodesk.Revit.DB..::..XYZ
The direction of extrusion, with its length the length of the extrusion. The direction must be perpendicular to the plane determined by profile. The length of vector must be non-zero.

Return Value

If creation was successful new form is returned.

Examples

CopyC#
private Form CreateExtrusionForm(Autodesk.Revit.DB.Document document)
{
    Form extrusionForm = null;

    // Create one profile
    ReferenceArray ref_ar = new ReferenceArray();

    XYZ ptA = new XYZ(10, 10, 0);
    XYZ ptB = new XYZ(90, 10, 0);
    ModelCurve modelcurve = MakeLine(document, ptA, ptB);
    ref_ar.Append(modelcurve.GeometryCurve.Reference);

    ptA = new XYZ(90, 10, 0);
    ptB = new XYZ(10, 90, 0);
    modelcurve = MakeLine(document, ptA, ptB);
    ref_ar.Append(modelcurve.GeometryCurve.Reference);

    ptA = new XYZ(10, 90, 0);
    ptB = new XYZ(10, 10, 0);
    modelcurve = MakeLine(document, ptA, ptB);
    ref_ar.Append(modelcurve.GeometryCurve.Reference);

    // The extrusion form direction
    XYZ direction = new XYZ(0, 0, 50);

    extrusionForm = document.FamilyCreate.NewExtrusionForm(true, ref_ar, direction);

    int profileCount = extrusionForm.ProfileCount;

    return extrusionForm;
}

public ModelCurve MakeLine(Document doc, XYZ ptA, XYZ ptB)
{
    Autodesk.Revit.ApplicationServices.Application app = doc.Application;
    // Create plane by the points
    Line line = Line.CreateBound(ptA, ptB);
    XYZ norm = ptA.CrossProduct(ptB);
    if (norm.IsZeroLength()) norm = XYZ.BasisZ;
    Plane plane = Plane.CreateByNormalAndOrigin(norm, ptB);
    SketchPlane skplane = SketchPlane.Create(doc, plane);
    // Create line here
    ModelCurve modelcurve = doc.FamilyCreate.NewModelCurve(line, skplane);
    return modelcurve;
}
CopyVB.NET
Private Function CreateExtrusionForm(document As Autodesk.Revit.DB.Document) As Form
    Dim extrusionForm As Form = Nothing

    ' Create one profile
    Dim ref_ar As New ReferenceArray()

    Dim ptA As New XYZ(10, 10, 0)
    Dim ptB As New XYZ(90, 10, 0)
    Dim modelcurve As ModelCurve = MakeLine(document, ptA, ptB)
    ref_ar.Append(modelcurve.GeometryCurve.Reference)

    ptA = New XYZ(90, 10, 0)
    ptB = New XYZ(10, 90, 0)
    modelcurve = MakeLine(document, ptA, ptB)
    ref_ar.Append(modelcurve.GeometryCurve.Reference)

    ptA = New XYZ(10, 90, 0)
    ptB = New XYZ(10, 10, 0)
    modelcurve = MakeLine(document, ptA, ptB)
    ref_ar.Append(modelcurve.GeometryCurve.Reference)

    ' The extrusion form direction
    Dim direction As New XYZ(0, 0, 50)

    extrusionForm = document.FamilyCreate.NewExtrusionForm(True, ref_ar, direction)

    Dim profileCount As Integer = extrusionForm.ProfileCount

    Return extrusionForm
End Function

Public Function MakeLine(doc As Document, ptA As XYZ, ptB As XYZ) As ModelCurve
    Dim app As Autodesk.Revit.ApplicationServices.Application = doc.Application
    ' Create plane by the points
    Dim line__1 As Line = Line.CreateBound(ptA, ptB)
    Dim norm As XYZ = ptA.CrossProduct(ptB)
    If norm.IsZeroLength() Then
        norm = XYZ.BasisZ
    End If
 Dim plane As Plane = plane.CreateByNormalAndOrigin(norm, ptB)
    Dim skplane As SketchPlane = SketchPlane.Create(doc, plane)
    ' Create line here
    Dim modelcurve As ModelCurve = doc.FamilyCreate.NewModelCurve(line__1, skplane)
    Return modelcurve
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when creation is attempted in Conceptual Mass, 2D, or other family where extrusions cannot be created.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method

[image] [image]

Revit 2024 API
FamilyItemFactory..::..NewFamilyInstance Method
FamilyItemFactory Class See Also Send Feedback
Inserts a new instance of a family into the document.

Overload List

 | Name | Description
Public method | NewFamilyInstance(Face, Line, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a line on that face for its position, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Line, FamilySymbol, View) | Add a line based detail family instance into the Autodesk Revit document, using an line and a view where the instance should be placed. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Reference, Line, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a line on that face for its position, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, StructuralType) | Inserts a new instance of a family into the document, using a location and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, View) | Add a new family instance into the Autodesk Revit document, using an origin and a view where the instance should be placed. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Face, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a location, reference direction, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Reference, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a location, reference direction, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the host element. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, Level, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the level. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a reference direction. (Inherited from ItemFactoryBase.)

See Also

FamilyItemFactory Class
FamilyItemFactory Members
Autodesk.Revit.Creation Namespace


NewFormByCap Method

[image]

Revit 2024 API
FamilyItemFactory..::..NewFormByCap Method
FamilyItemFactory Class See Also Send Feedback
Create new Form element by cap operation (to create a single-surface form), and add it into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Form NewFormByCap(
    bool isSolid,
    ReferenceArray profile
)
Visual Basic
Public Function NewFormByCap ( _
    isSolid As Boolean, _
    profile As ReferenceArray _
) As Form
Visual C++
public:
Form^ NewFormByCap(
    bool isSolid,
    ReferenceArray^ profile
)

Parameters

isSolid
Type: System..::..Boolean
Indicates if the Form is Solid or Void.
profile
Type: Autodesk.Revit.DB..::..ReferenceArray
The profile of the newly created cap. It should consist of only one curve loop.

Return Value

If creation was successful new form is returned.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewFormByThickenSingleSurface Method

[image]

Revit 2024 API
FamilyItemFactory..::..NewFormByThickenSingleSurface Method
FamilyItemFactory Class See Also Send Feedback
Create a new Form element by thickening a single-surface form, and add it into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Form NewFormByThickenSingleSurface(
    bool isSolid,
    Form singleSurfaceForm,
    XYZ thickenDir
)
Visual Basic
Public Function NewFormByThickenSingleSurface ( _
    isSolid As Boolean, _
    singleSurfaceForm As Form, _
    thickenDir As XYZ _
) As Form
Visual C++
public:
Form^ NewFormByThickenSingleSurface(
    bool isSolid,
    Form^ singleSurfaceForm,
    XYZ^ thickenDir
)

Parameters

isSolid
Type: System..::..Boolean
Indicates if the Form is Solid or Void.
singleSurfaceForm
Type: Autodesk.Revit.DB..::..Form
The single-surface form element. It can have one top/bottom face or one side face.
thickenDir
Type: Autodesk.Revit.DB..::..XYZ
The offset of capped solid.

Return Value

This function will modify the input singleSurfaceForm and return the same element.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewLinearDimension Method

[image] [image]

Revit 2024 API
FamilyItemFactory..::..NewLinearDimension Method
FamilyItemFactory Class See Also Send Feedback
Creates a new linear dimension object.

Overload List

 | Name | Description
Public method | NewLinearDimension(View, Line, ReferenceArray) | Generate a new linear dimension object using the default dimension type.
Public method | NewLinearDimension(View, Line, ReferenceArray, DimensionType) | Creates a new linear dimension object using the specified dimension type.

See Also

FamilyItemFactory Class
FamilyItemFactory Members
Autodesk.Revit.Creation Namespace


NewLinearDimension Method (View, Line, ReferenceArray)

[image]

Revit 2024 API
FamilyItemFactory..::..NewLinearDimension Method (View, Line, ReferenceArray)
FamilyItemFactory Class Example See Also Send Feedback
Generate a new linear dimension object using the default dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Dimension NewLinearDimension(
    View view,
    Line line,
    ReferenceArray references
)
Visual Basic
Public Function NewLinearDimension ( _
    view As View, _
    line As Line, _
    references As ReferenceArray _
) As Dimension
Visual C++
public:
Dimension^ NewLinearDimension(
    View^ view,
    Line^ line,
    ReferenceArray^ references
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view in which the dimension is to be visible.
line
Type: Autodesk.Revit.DB..::..Line
The extension line of the dimension.
references
Type: Autodesk.Revit.DB..::..ReferenceArray
An array of geometric references to which the dimension is to be bound. You must supply at least two references, and all references supplied must be parallel to each other and perpendicular to the extension line.

Return Value

If creation was successful the new linear dimension is returned, otherwise an exception with failure information will be thrown.

Remarks

The currently user set default style is used for the created dimension.

Examples

CopyC#
public Dimension CreateLinearDimension(Document document)
{
    // first create two lines
    XYZ pt1 = new XYZ(5, 5, 0);
    XYZ pt2 = new XYZ(5, 10, 0);
    Line line = Line.CreateBound(pt1, pt2);
    Plane plane = Plane.CreateByNormalAndOrigin(pt1.CrossProduct(pt2), pt2);
    SketchPlane skplane = SketchPlane.Create (document, plane);
    ModelCurve modelcurve1 = document.FamilyCreate.NewModelCurve(line, skplane);

    pt1 = new XYZ(10, 5, 0);
    pt2 = new XYZ(10, 10, 0);
    line = Line.CreateBound(pt1, pt2);
    plane = Plane.CreateByNormalAndOrigin(pt1.CrossProduct(pt2), pt2);
    skplane = SketchPlane.Create (document, plane);
    ModelCurve modelcurve2 = document.FamilyCreate.NewModelCurve(line, skplane);

    // now create a linear dimension between them
    ReferenceArray ra = new ReferenceArray();
    ra.Append(modelcurve1.GeometryCurve.Reference);
    ra.Append(modelcurve2.GeometryCurve.Reference);

    pt1 = new XYZ(5, 10, 0);
    pt2 = new XYZ(10, 10, 0);
    line = Line.CreateBound(pt1, pt2);

    Dimension dim = document.FamilyCreate.NewLinearDimension(document.ActiveView, line, ra);

    // create a label for the dimension called "width"
    FamilyParameter param = document.FamilyManager.AddParameter("width",
        GroupTypeId.Constraints,
        SpecTypeId.Length, false);

    dim.FamilyLabel = param;

    return dim;
}
CopyVB.NET
Public Function CreateLinearDimension(document As Document) As Dimension
    ' first create two lines
    Dim pt1 As New XYZ(5, 5, 0)
    Dim pt2 As New XYZ(5, 10, 0)
    Dim line__1 As Line = Line.CreateBound(pt1, pt2)
 Dim plane As Plane = plane.CreateByNormalAndOrigin(pt1.CrossProduct(pt2), pt2)
    Dim skplane As SketchPlane = SketchPlane.Create(document, plane)
    Dim modelcurve1 As ModelCurve = document.FamilyCreate.NewModelCurve(line__1, skplane)

    pt1 = New XYZ(10, 5, 0)
    pt2 = New XYZ(10, 10, 0)
    line__1 = Line.CreateBound(pt1, pt2)
 plane = plane.CreateByNormalAndOrigin(pt1.CrossProduct(pt2), pt2)
    skplane = SketchPlane.Create(document, plane)
    Dim modelcurve2 As ModelCurve = document.FamilyCreate.NewModelCurve(line__1, skplane)

    ' now create a linear dimension between them
    Dim ra As New ReferenceArray()
    ra.Append(modelcurve1.GeometryCurve.Reference)
    ra.Append(modelcurve2.GeometryCurve.Reference)

    pt1 = New XYZ(5, 10, 0)
    pt2 = New XYZ(10, 10, 0)
    line__1 = Line.CreateBound(pt1, pt2)

    Dim [dim] As Dimension = document.FamilyCreate.NewLinearDimension(document.ActiveView, line__1, ra)

    ' create a label for the dimension called "width"
    Dim param As FamilyParameter = document.FamilyManager.AddParameter("width", GroupTypeId.Constraints, SpecTypeId.Length, False)

    [dim].FamilyLabel = param

    Return [dim]
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when any input argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the argument "references" is invalid.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewLinearDimension Overload
Autodesk.Revit.Creation Namespace


NewLoftForm Method

[image]

Revit 2024 API
FamilyItemFactory..::..NewLoftForm Method
FamilyItemFactory Class Example See Also Send Feedback
Create new Form element by Loft operation, and add it into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Form NewLoftForm(
    bool isSolid,
    ReferenceArrayArray profiles
)
Visual Basic
Public Function NewLoftForm ( _
    isSolid As Boolean, _
    profiles As ReferenceArrayArray _
) As Form
Visual C++
public:
Form^ NewLoftForm(
    bool isSolid,
    ReferenceArrayArray^ profiles
)

Parameters

isSolid
Type: System..::..Boolean
Indicates if the Form is Solid or Void.
profiles
Type: Autodesk.Revit.DB..::..ReferenceArrayArray
The profile set of the newly created loft. Each profile should consist of only one curve loop.

Return Value

If creation was successful form is are returned.

Examples

CopyC#
private Form CreateLoftForm(Autodesk.Revit.DB.Document document)
{
    Form loftForm = null;

    ReferencePointArray rpa = new ReferencePointArray();
    ReferenceArrayArray ref_ar_ar = new ReferenceArrayArray();
    ReferenceArray ref_ar = new ReferenceArray();
    ReferencePoint rp = null;
    XYZ xyz = null;

    // make first profile curve for loft
    xyz = document.Application.Create.NewXYZ(0, 0, 0);
    rp = document.FamilyCreate.NewReferencePoint(xyz);
    rpa.Append(rp);

    xyz = document.Application.Create.NewXYZ(0, 50, 10);
    rp = document.FamilyCreate.NewReferencePoint(xyz);
    rpa.Append(rp);

    xyz = document.Application.Create.NewXYZ(0, 100, 0);
    rp = document.FamilyCreate.NewReferencePoint(xyz);
    rpa.Append(rp);

    CurveByPoints cbp = document.FamilyCreate.NewCurveByPoints(rpa);
    ref_ar.Append(cbp.GeometryCurve.Reference);
    ref_ar_ar.Append(ref_ar);
    rpa.Clear();
    ref_ar = new ReferenceArray();

    // make second profile curve for loft
    xyz = document.Application.Create.NewXYZ(50, 0, 0);
    rp = document.FamilyCreate.NewReferencePoint(xyz);
    rpa.Append(rp);

    xyz = document.Application.Create.NewXYZ(50, 50, 30);
    rp = document.FamilyCreate.NewReferencePoint(xyz);
    rpa.Append(rp);

    xyz = document.Application.Create.NewXYZ(50, 100, 0);
    rp = document.FamilyCreate.NewReferencePoint(xyz);
    rpa.Append(rp);

    cbp = document.FamilyCreate.NewCurveByPoints(rpa);
    ref_ar.Append(cbp.GeometryCurve.Reference);
    ref_ar_ar.Append(ref_ar);
    rpa.Clear();
    ref_ar = new ReferenceArray();

    // make third profile curve for loft
    xyz = document.Application.Create.NewXYZ(75, 0, 0);
    rp = document.FamilyCreate.NewReferencePoint(xyz);
    rpa.Append(rp);

    xyz = document.Application.Create.NewXYZ(75, 50, 5);
    rp = document.FamilyCreate.NewReferencePoint(xyz);
    rpa.Append(rp);

    xyz = document.Application.Create.NewXYZ(75, 100, 0);
    rp = document.FamilyCreate.NewReferencePoint(xyz);
    rpa.Append(rp);

    cbp = document.FamilyCreate.NewCurveByPoints(rpa);
    ref_ar.Append(cbp.GeometryCurve.Reference);
    ref_ar_ar.Append(ref_ar);

    loftForm = document.FamilyCreate.NewLoftForm(true, ref_ar_ar);

    return loftForm;
}
CopyVB.NET
Private Function CreateLoftForm(document As Autodesk.Revit.DB.Document) As Form
    Dim loftForm As Form = Nothing

    Dim rpa As New ReferencePointArray()
    Dim ref_ar_ar As New ReferenceArrayArray()
    Dim ref_ar As New ReferenceArray()
    Dim rp As ReferencePoint = Nothing
    Dim xyz As XYZ = Nothing

    ' make first profile curve for loft
    xyz = document.Application.Create.NewXYZ(0, 0, 0)
    rp = document.FamilyCreate.NewReferencePoint(xyz)
    rpa.Append(rp)

    xyz = document.Application.Create.NewXYZ(0, 50, 10)
    rp = document.FamilyCreate.NewReferencePoint(xyz)
    rpa.Append(rp)

    xyz = document.Application.Create.NewXYZ(0, 100, 0)
    rp = document.FamilyCreate.NewReferencePoint(xyz)
    rpa.Append(rp)

    Dim cbp As CurveByPoints = document.FamilyCreate.NewCurveByPoints(rpa)
    ref_ar.Append(cbp.GeometryCurve.Reference)
    ref_ar_ar.Append(ref_ar)
    rpa.Clear()
    ref_ar = New ReferenceArray()

    ' make second profile curve for loft
    xyz = document.Application.Create.NewXYZ(50, 0, 0)
    rp = document.FamilyCreate.NewReferencePoint(xyz)
    rpa.Append(rp)

    xyz = document.Application.Create.NewXYZ(50, 50, 30)
    rp = document.FamilyCreate.NewReferencePoint(xyz)
    rpa.Append(rp)

    xyz = document.Application.Create.NewXYZ(50, 100, 0)
    rp = document.FamilyCreate.NewReferencePoint(xyz)
    rpa.Append(rp)

    cbp = document.FamilyCreate.NewCurveByPoints(rpa)
    ref_ar.Append(cbp.GeometryCurve.Reference)
    ref_ar_ar.Append(ref_ar)
    rpa.Clear()
    ref_ar = New ReferenceArray()

    ' make third profile curve for loft
    xyz = document.Application.Create.NewXYZ(75, 0, 0)
    rp = document.FamilyCreate.NewReferencePoint(xyz)
    rpa.Append(rp)

    xyz = document.Application.Create.NewXYZ(75, 50, 5)
    rp = document.FamilyCreate.NewReferencePoint(xyz)
    rpa.Append(rp)

    xyz = document.Application.Create.NewXYZ(75, 100, 0)
    rp = document.FamilyCreate.NewReferencePoint(xyz)
    rpa.Append(rp)

    cbp = document.FamilyCreate.NewCurveByPoints(rpa)
    ref_ar.Append(cbp.GeometryCurve.Reference)
    ref_ar_ar.Append(ref_ar)

    loftForm = document.FamilyCreate.NewLoftForm(True, ref_ar_ar)

    Return loftForm
End Function

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewOpening Method

[image]

Revit 2024 API
FamilyItemFactory..::..NewOpening Method
FamilyItemFactory Class See Also Send Feedback
Create an opening to cut the wall or ceiling.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Opening NewOpening(
    Element host,
    CurveArray profile
)
Visual Basic
Public Function NewOpening ( _
    host As Element, _
    profile As CurveArray _
) As Opening
Visual C++
public:
Opening^ NewOpening(
    Element^ host,
    CurveArray^ profile
)

Parameters

host
Type: Autodesk.Revit.DB..::..Element
Host elements that new opening would lie in. The host can only be a wall or a ceiling.
profile
Type: Autodesk.Revit.DB..::..CurveArray
The profile of the newly created opening. This may contain more than one curve loop. Each loop must be a fully closed curve loop and the loops may not intersect. The profiles will be projected into the host plane.

Return Value

If successful, the newly created opening is returned, otherwise an exception with error information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument host or profile is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when host isn't a wall or a ceiling. Thrown when profile doesn't contain any loops.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when opening creation failed.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewRadialDimension Method

[image] [image]

Revit 2024 API
FamilyItemFactory..::..NewRadialDimension Method
FamilyItemFactory Class See Also Send Feedback
Creates a new radial dimension object.

Overload List

 | Name | Description
Public method | NewRadialDimension(View, Reference, XYZ) | Creates a new radial dimension object using the default dimension type.
Public method | NewRadialDimension(View, Reference, XYZ, DimensionType) | Generate a new radial dimension object using a specified dimension type.

See Also

FamilyItemFactory Class
FamilyItemFactory Members
Autodesk.Revit.Creation Namespace


NewRadialDimension Method (View, Reference, XYZ)

[image]

Revit 2024 API
FamilyItemFactory..::..NewRadialDimension Method (View, Reference, XYZ)
FamilyItemFactory Class See Also Send Feedback
Creates a new radial dimension object using the default dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Dimension NewRadialDimension(
    View view,
    Reference arcRef,
    XYZ origin
)
Visual Basic
Public Function NewRadialDimension ( _
    view As View, _
    arcRef As Reference, _
    origin As XYZ _
) As Dimension
Visual C++
public:
Dimension^ NewRadialDimension(
    View^ view,
    Reference^ arcRef,
    XYZ^ origin
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view in which the dimension is to be visible.
arcRef
Type: Autodesk.Revit.DB..::..Reference
Geometric reference of the arc to which the dimension is to be bound.
origin
Type: Autodesk.Revit.DB..::..XYZ
The point where the witness line of the radial dimension will lie.

Return Value

If creation was successful the new arc length dimension is returned, otherwise an exception with failure information will be thrown.

Remarks

The currently user set default style is used for the created dimension.

Remarks

The dimension will be created on default place.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when any input argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the argument arcRef is invalid.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewRadialDimension Overload
Autodesk.Revit.Creation Namespace


NewRadialDimension Method (View, Reference, XYZ, DimensionType)

[image]

Revit 2024 API
FamilyItemFactory..::..NewRadialDimension Method (View, Reference, XYZ, DimensionType)
FamilyItemFactory Class See Also Send Feedback
Generate a new radial dimension object using a specified dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Dimension NewRadialDimension(
    View view,
    Reference arcRef,
    XYZ origin,
    DimensionType dimensionType
)
Visual Basic
Public Function NewRadialDimension ( _
    view As View, _
    arcRef As Reference, _
    origin As XYZ, _
    dimensionType As DimensionType _
) As Dimension
Visual C++
public:
Dimension^ NewRadialDimension(
    View^ view,
    Reference^ arcRef,
    XYZ^ origin,
    DimensionType^ dimensionType
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view in which the dimension is to be visible.
arcRef
Type: Autodesk.Revit.DB..::..Reference
Geometric reference of the arc to which the dimension is to be bound.
origin
Type: Autodesk.Revit.DB..::..XYZ
The point where the witness line of the radial dimension will lie.
dimensionType
Type: Autodesk.Revit.DB..::..DimensionType
The dimension style to be used for the dimension.

Return Value

If creation was successful the new arc length dimension is returned, otherwise an exception with failure information will be thrown.

Remarks

The dimension will be created on default place.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when any input argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the argument arcRef/dimensionType is invalid.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewRadialDimension Overload
Autodesk.Revit.Creation Namespace


NewReferencePoint Method

[image] [image]

Revit 2024 API
FamilyItemFactory..::..NewReferencePoint Method
FamilyItemFactory Class See Also Send Feedback
Creates a reference point.

Overload List

 | Name | Description
Public method | NewReferencePoint(PointElementReference) | Create a reference point on an existing reference in an Autodesk Revit family document.
Public method | NewReferencePoint(Transform) | Create a reference point at a given location and with a given coordinate system in an Autodesk Revit family document.
Public method | NewReferencePoint(XYZ) | Create a reference point at a given location in an Autodesk Revit family document.

See Also

FamilyItemFactory Class
FamilyItemFactory Members
Autodesk.Revit.Creation Namespace


NewReferencePoint Method (Transform)

[image]

Revit 2024 API
FamilyItemFactory..::..NewReferencePoint Method (Transform)
FamilyItemFactory Class See Also Send Feedback
Create a reference point at a given location and with a given coordinate system in an Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ReferencePoint NewReferencePoint(
    Transform A_0
)
Visual Basic
Public Function NewReferencePoint ( _
    A_0 As Transform _
) As ReferencePoint
Visual C++
public:
ReferencePoint^ NewReferencePoint(
    Transform^ A_0
)

Parameters

A_0
Type: Autodesk.Revit.DB..::..Transform

Return Value

The newly created ReferencePoint.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the family is not a Conceptual Mass Family.

See Also

FamilyItemFactory Class
NewReferencePoint Overload
Autodesk.Revit.Creation Namespace


NewRevolveForms Method

[image]

Revit 2024 API
FamilyItemFactory..::..NewRevolveForms Method
FamilyItemFactory Class Example See Also Send Feedback
Create new Form elements by revolve operation, and add them into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FormArray NewRevolveForms(
    bool isSolid,
    ReferenceArray profile,
    Reference axis,
    double startAngle,
    double endAngle
)
Visual Basic
Public Function NewRevolveForms ( _
    isSolid As Boolean, _
    profile As ReferenceArray, _
    axis As Reference, _
    startAngle As Double, _
    endAngle As Double _
) As FormArray
Visual C++
public:
FormArray^ NewRevolveForms(
    bool isSolid,
    ReferenceArray^ profile,
    Reference^ axis,
    double startAngle,
    double endAngle
)

Parameters

isSolid
Type: System..::..Boolean
Indicates if the Form is Solid or Void.
profile
Type: Autodesk.Revit.DB..::..ReferenceArray
The profile of the newly created revolution. It should consist of only one curve loop. The profile must be in the same plane as the axis.
axis
Type: Autodesk.Revit.DB..::..Reference
The axis of revolution. The axis is a line that must lie in the same plane as the curves in the profile.
startAngle
Type: System..::..Double
The start angle of Revolution in radians.
endAngle
Type: System..::..Double
The end angle of Revolution in radians.

Return Value

If creation was successful new forms are returned.

Remarks

Typically this operation produces only a single form, but some combinations of arguments will create multiple forms from a single profile.

Examples

CopyC#
private FormArray CreateRevolveForm(Document document)
{
    FormArray revolveForms = null;

    // Create one profile
    ReferenceArray ref_ar = new ReferenceArray();

    XYZ ptA = new XYZ(0, 0, 10);
    XYZ ptB = new XYZ(100, 0, 10);
    Line line = Line.CreateBound(ptA, ptB);
    ModelCurve modelcurve = MakeLine(document, ptA, ptB);
    ref_ar.Append(modelcurve.GeometryCurve.Reference);

    ptA = new XYZ(100, 0, 10);
    ptB = new XYZ(100, 100, 10);
    modelcurve = MakeLine(document, ptA, ptB);
    ref_ar.Append(modelcurve.GeometryCurve.Reference);

    ptA = new XYZ(100, 100, 10);
    ptB = new XYZ(0, 0, 10);
    modelcurve = MakeLine(document, ptA, ptB);
    ref_ar.Append(modelcurve.GeometryCurve.Reference);

    // Create axis for revolve form
    ptA = new XYZ(-5, 0, 10);
    ptB = new XYZ(-5, 10, 10);
    ModelCurve axis = MakeLine(document, ptA, ptB);

    // make axis a Reference Line
    axis.ChangeToReferenceLine();

    // Typically this operation produces only a single form,
    // but some combinations of arguments will create multiple froms from a single profile.
    revolveForms = document.FamilyCreate.NewRevolveForms(true, ref_ar, axis.GeometryCurve.Reference, 0, Math.PI / 4);

    return revolveForms;
}

public ModelCurve MakeLine(Document doc, XYZ ptA, XYZ ptB)
{
    Autodesk.Revit.ApplicationServices.Application app = doc.Application;
    // Create plane by the points
    Line line = Line.CreateBound(ptA, ptB);
    XYZ norm = ptA.CrossProduct(ptB);
    if (norm.IsZeroLength()) norm = XYZ.BasisZ;
    Plane plane = Plane.CreateByNormalAndOrigin(norm, ptB);
    SketchPlane skplane = SketchPlane.Create(doc, plane);
    // Create line here
    ModelCurve modelcurve = doc.FamilyCreate.NewModelCurve(line, skplane);
    return modelcurve;
}
CopyVB.NET
Private Function CreateRevolveForm(document As Document) As FormArray
    Dim revolveForms As FormArray = Nothing

    ' Create one profile
    Dim ref_ar As New ReferenceArray()

    Dim ptA As New XYZ(0, 0, 10)
    Dim ptB As New XYZ(100, 0, 10)
    Dim line__1 As Line = Line.CreateBound(ptA, ptB)
    Dim modelcurve As ModelCurve = MakeLine(document, ptA, ptB)
    ref_ar.Append(modelcurve.GeometryCurve.Reference)

    ptA = New XYZ(100, 0, 10)
    ptB = New XYZ(100, 100, 10)
    modelcurve = MakeLine(document, ptA, ptB)
    ref_ar.Append(modelcurve.GeometryCurve.Reference)

    ptA = New XYZ(100, 100, 10)
    ptB = New XYZ(0, 0, 10)
    modelcurve = MakeLine(document, ptA, ptB)
    ref_ar.Append(modelcurve.GeometryCurve.Reference)

    ' Create axis for revolve form
    ptA = New XYZ(-5, 0, 10)
    ptB = New XYZ(-5, 10, 10)
    Dim axis As ModelCurve = MakeLine(document, ptA, ptB)

    ' make axis a Reference Line
    axis.ChangeToReferenceLine()

    ' Typically this operation produces only a single form,
    ' but some combinations of arguments will create multiple froms from a single profile.
    revolveForms = document.FamilyCreate.NewRevolveForms(True, ref_ar, axis.GeometryCurve.Reference, 0, Math.PI / 4)

    Return revolveForms
End Function

Public Function MakeLine(doc As Document, ptA As XYZ, ptB As XYZ) As ModelCurve
    Dim app As Autodesk.Revit.ApplicationServices.Application = doc.Application
    ' Create plane by the points
    Dim line__1 As Line = Line.CreateBound(ptA, ptB)
    Dim norm As XYZ = ptA.CrossProduct(ptB)
    If norm.IsZeroLength() Then
        norm = XYZ.BasisZ
    End If
 Dim plane As Plane = plane.CreateByNormalAndOrigin(norm, ptB)
    Dim skplane As SketchPlane = SketchPlane.Create(doc, plane)
    ' Create line here
    Dim modelcurve As ModelCurve = doc.FamilyCreate.NewModelCurve(line__1, skplane)
    Return modelcurve
End Function

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewSweep Method (Boolean, ReferenceArray, SweepProfile, Int32, ProfilePlaneLocation)

[image]

Revit 2024 API
FamilyItemFactory..::..NewSweep Method (Boolean, ReferenceArray, SweepProfile, Int32, ProfilePlaneLocation)
FamilyItemFactory Class See Also Send Feedback
Adds a new sweep form into the family document, using an array of selected references as a 3D path.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Sweep NewSweep(
    bool isSolid,
    ReferenceArray path,
    SweepProfile profile,
    int profileLocationCurveIndex,
    ProfilePlaneLocation profilePlaneLocation
)
Visual Basic
Public Function NewSweep ( _
    isSolid As Boolean, _
    path As ReferenceArray, _
    profile As SweepProfile, _
    profileLocationCurveIndex As Integer, _
    profilePlaneLocation As ProfilePlaneLocation _
) As Sweep
Visual C++
public:
Sweep^ NewSweep(
    bool isSolid,
    ReferenceArray^ path,
    SweepProfile^ profile,
    int profileLocationCurveIndex,
    ProfilePlaneLocation profilePlaneLocation
)

Parameters

isSolid
Type: System..::..Boolean
Indicates if the Sweep is Solid or Void.
path
Type: Autodesk.Revit.DB..::..ReferenceArray
The path of the sweep. The path should be reference of curve or edge obtained from existing geometry.
profile
Type: Autodesk.Revit.DB..::..SweepProfile
The profile to create the new Sweep. The profile must lie in the XY plane, and it will be transformed to the profile plane automatically. This may contain more than one curve loop or a profile family. Each loop must be a fully closed curve loop and the loops must not intersect. The loop can be a unbound circle or ellipse, but its geometry will be split in two in order to satisfy requirements for sketches used in extrusions.
profileLocationCurveIndex
Type: System..::..Int32
The index of the path curves. The curve upon which the profile plane will be determined.
profilePlaneLocation
Type: Autodesk.Revit.DB..::..ProfilePlaneLocation
The location on the profileLocationCurve where the profile plane will be determined.

Return Value

If creation was successful the new Sweep is returned, otherwise an exception with failure information will be thrown.

Remarks

This method creates a sweep in a family document. The sweep will trace the profile along the path.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-path-is nullNothingnullptra null reference (Nothing in Visual Basic) or empty or an unsupported curve type.
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-profile-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the input argument-profileLocationCurveIndex-is out of index bounds.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the input argument-profilePlaneLocation-does not exist in the ProfilePlaneLocation enumeration.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewSweep Overload
Autodesk.Revit.Creation Namespace


NewSweep Method (Boolean, CurveArray, SketchPlane, SweepProfile, Int32, ProfilePlaneLocation)

[image]

Revit 2024 API
FamilyItemFactory..::..NewSweep Method (Boolean, CurveArray, SketchPlane, SweepProfile, Int32, ProfilePlaneLocation)
FamilyItemFactory Class Example See Also Send Feedback
Adds a new sweep form to the family document, using a path of curve elements.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Sweep NewSweep(
    bool isSolid,
    CurveArray path,
    SketchPlane pathPlane,
    SweepProfile profile,
    int profileLocationCurveIndex,
    ProfilePlaneLocation profilePlaneLocation
)
Visual Basic
Public Function NewSweep ( _
    isSolid As Boolean, _
    path As CurveArray, _
    pathPlane As SketchPlane, _
    profile As SweepProfile, _
    profileLocationCurveIndex As Integer, _
    profilePlaneLocation As ProfilePlaneLocation _
) As Sweep
Visual C++
public:
Sweep^ NewSweep(
    bool isSolid,
    CurveArray^ path,
    SketchPlane^ pathPlane,
    SweepProfile^ profile,
    int profileLocationCurveIndex,
    ProfilePlaneLocation profilePlaneLocation
)

Parameters

isSolid
Type: System..::..Boolean
Indicates if the Sweep is Solid or Void.
path
Type: Autodesk.Revit.DB..::..CurveArray
The path of the sweep. The path should be 2D, where all input curves lie in one plane, and the curves are not required to reference existing geometry.
pathPlane
Type: Autodesk.Revit.DB..::..SketchPlane
The sketch plane for the path. Use this when you want to create a 2D path that resides on an existing planar face. Optional, can be nullNothingnullptra null reference (Nothing in Visual Basic) for 3D paths or for 2D paths where the path should not reference an existing face.
profile
Type: Autodesk.Revit.DB..::..SweepProfile
The profile of the newly created Sweep. This may contain more than one curve loop or a profile family. The profile must lie in the XY plane, and it will be transformed to the profile plane automatically. Each loop must be a fully closed curve loop and the loops must not intersect. The loop can be a unbound circle or ellipse, but its geometry will be split in two in order to satisfy requirements for sketches used in extrusions.
profileLocationCurveIndex
Type: System..::..Int32
The index of the path curves. The curve upon which the profile plane will be determined.
profilePlaneLocation
Type: Autodesk.Revit.DB..::..ProfilePlaneLocation
The location on the profileLocationCurve where the profile plane will be determined.

Return Value

If creation was successful the new Sweep is returned, otherwise an exception with failure information will be thrown.

Remarks

This method creates a sweep in a family document. The sweep will trace the profile along the path.

Examples

CopyC#
private Sweep CreateSweep(Autodesk.Revit.DB.Document document, SketchPlane sketchPlane)
{
    Sweep sweep = null;

    // make sure we have a family document
    if (true == document.IsFamilyDocument)
    {
        // Define a profile for the sweep
        CurveArrArray arrarr = new CurveArrArray();
        CurveArray arr = new CurveArray();

        // Create an ovoid profile
        XYZ pnt1 = new XYZ(0, 0, 0);
        XYZ pnt2 = new XYZ(2, 0, 0);
        XYZ pnt3 = new XYZ(1, 1, 0);
        arr.Append(Arc.Create(pnt2, 1.0d, 0.0d, 180.0d, XYZ.BasisX, XYZ.BasisY));
        arr.Append(Arc.Create(pnt1, pnt3, pnt2));
        arrarr.Append(arr);
        SweepProfile profile = document.Application.Create.NewCurveLoopsProfile(arrarr);

        // Create a path for the sweep
        XYZ pnt4 = new XYZ(10, 0, 0);
        XYZ pnt5 = new XYZ(0, 10, 0);
        Curve curve = Line.CreateBound(pnt4, pnt5);

        CurveArray curves = new CurveArray();
        curves.Append(curve);

        // create a solid ovoid sweep
        sweep = document.FamilyCreate.NewSweep(true, curves, sketchPlane, profile, 0, ProfilePlaneLocation.Start);

        if (null != sweep)
        {
            // move to proper place
            XYZ transPoint1 = new XYZ(11, 0, 0);
            ElementTransformUtils.MoveElement(document, sweep.Id, transPoint1);
        }
        else
        {
            throw new Exception("Failed to create a new Sweep.");
        }
    }
    else
    {
        throw new Exception("Please open a Family document before invoking this command.");
    }

    return sweep;
}
CopyVB.NET
Private Function CreateSweep(document As Autodesk.Revit.DB.Document, sketchPlane As SketchPlane) As Sweep
    Dim sweep As Sweep = Nothing

    ' make sure we have a family document
    If True = document.IsFamilyDocument Then
        ' Define a profile for the sweep
        Dim arrarr As New CurveArrArray()
        Dim arr As New CurveArray()

        ' Create an ovoid profile
        Dim pnt1 As New XYZ(0, 0, 0)
        Dim pnt2 As New XYZ(2, 0, 0)
        Dim pnt3 As New XYZ(1, 1, 0)
        arr.Append(Arc.Create(pnt2, 1.0, 0.0, 180.0, XYZ.BasisX, XYZ.BasisY))
        arr.Append(Arc.Create(pnt1, pnt3, pnt2))
        arrarr.Append(arr)
        Dim profile As SweepProfile = document.Application.Create.NewCurveLoopsProfile(arrarr)

        ' Create a path for the sweep
        Dim pnt4 As New XYZ(10, 0, 0)
        Dim pnt5 As New XYZ(0, 10, 0)
        Dim curve As Curve = Line.CreateBound(pnt4, pnt5)

        Dim curves As New CurveArray()
        curves.Append(curve)

        ' create a solid ovoid sweep
        sweep = document.FamilyCreate.NewSweep(True, curves, sketchPlane, profile, 0, ProfilePlaneLocation.Start)

        If sweep IsNot Nothing Then
            ' move to proper place
            Dim transPoint1 As New XYZ(11, 0, 0)
            ElementTransformUtils.MoveElement(document, sweep.Id, transPoint1)
        Else
            Throw New Exception("Failed to create a new Sweep.")
        End If
    Else
        Throw New Exception("Please open a Family document before invoking this command.")
    End If

    Return sweep
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-path-is nullNothingnullptra null reference (Nothing in Visual Basic) or empty.
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-profile-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the input argument-profileLocationCurveIndex-is out of index bounds.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the input argument-profilePlaneLocation-does not exist in the ProfilePlaneLocation enumeration.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when creation is attempted in Conceptual Mass, 2D, or other family where sweeps cannot be created.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewSweep Overload
Autodesk.Revit.Creation Namespace


NewSweptBlend Method

[image] [image]

Revit 2024 API
FamilyItemFactory..::..NewSweptBlend Method
FamilyItemFactory Class See Also Send Feedback
Adds a new swept blend into the family document.

Overload List

 | Name | Description
Public method | NewSweptBlend(Boolean, Reference, SweepProfile, SweepProfile) | Adds a new swept blend into the family document, using a selected reference as the path.
Public method | NewSweptBlend(Boolean, Curve, SketchPlane, SweepProfile, SweepProfile) | Add a new swept blend into the family document, using a curve as the path.

See Also

FamilyItemFactory Class
FamilyItemFactory Members
Autodesk.Revit.Creation Namespace


NewSweptBlend Method (Boolean, Reference, SweepProfile, SweepProfile)

[image]

Revit 2024 API
FamilyItemFactory..::..NewSweptBlend Method (Boolean, Reference, SweepProfile, SweepProfile)
FamilyItemFactory Class See Also Send Feedback
Adds a new swept blend into the family document, using a selected reference as the path.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public SweptBlend NewSweptBlend(
    bool isSolid,
    Reference path,
    SweepProfile bottomProfile,
    SweepProfile topProfile
)
Visual Basic
Public Function NewSweptBlend ( _
    isSolid As Boolean, _
    path As Reference, _
    bottomProfile As SweepProfile, _
    topProfile As SweepProfile _
) As SweptBlend
Visual C++
public:
SweptBlend^ NewSweptBlend(
    bool isSolid,
    Reference^ path,
    SweepProfile^ bottomProfile,
    SweepProfile^ topProfile
)

Parameters

isSolid
Type: System..::..Boolean
Indicates if the swept blend is Solid or Void.
path
Type: Autodesk.Revit.DB..::..Reference
The path of the swept blend. The path might be a reference of single curve or edge obtained from existing geometry. Or the path can be a single sketched curve, and the curve is not required to reference existing geometry.
bottomProfile
Type: Autodesk.Revit.DB..::..SweepProfile
The bottom profile of the newly created Swept blend. It should consist of only one curve loop. the input profile must be in one plane.
topProfile
Type: Autodesk.Revit.DB..::..SweepProfile
The top profile of the newly created Swept blend. It should consist of only one curve loop. The profile must lie in the XY plane, and it will be transformed to the profile plane automatically.

Return Value

If creation was successful the new Swept blend is returned, otherwise an exception with failure information will be thrown.

Remarks

This method creates a swept blend in a family document. The swept blend will trace from bottom profile to the top along the path. Revit will determine an appropriate default mapping for the vertices of the two profiles. If the input profile is to be a cyclic profile (curve or ellipse) it must be split into at least two segments, so that Revit can find vertices to use for mapping the swept blend.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input arguments-path/bottomProfile/topProfile-are nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-bottomProfile/topProfile-is a curve based profile and the profile is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-bottomProfile/topProfile-is a curve based profile and the profile contains nullNothingnullptra null reference (Nothing in Visual Basic) or more than one curve loops.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-bottomProfile/topProfile-is a family symbol based profile and the family symbol profile is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewSweptBlend Overload
Autodesk.Revit.Creation Namespace


NewSweptBlend Method (Boolean, Curve, SketchPlane, SweepProfile, SweepProfile)

[image]

Revit 2024 API
FamilyItemFactory..::..NewSweptBlend Method (Boolean, Curve, SketchPlane, SweepProfile, SweepProfile)
FamilyItemFactory Class Example See Also Send Feedback
Add a new swept blend into the family document, using a curve as the path.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public SweptBlend NewSweptBlend(
    bool isSolid,
    Curve path,
    SketchPlane pathPlane,
    SweepProfile bottomProfile,
    SweepProfile topProfile
)
Visual Basic
Public Function NewSweptBlend ( _
    isSolid As Boolean, _
    path As Curve, _
    pathPlane As SketchPlane, _
    bottomProfile As SweepProfile, _
    topProfile As SweepProfile _
) As SweptBlend
Visual C++
public:
SweptBlend^ NewSweptBlend(
    bool isSolid,
    Curve^ path,
    SketchPlane^ pathPlane,
    SweepProfile^ bottomProfile,
    SweepProfile^ topProfile
)

Parameters

isSolid
Type: System..::..Boolean
Indicates if the swept blend is Solid or Void.
path
Type: Autodesk.Revit.DB..::..Curve
The path of the swept blend. The path should be a single curve. Or the path can be a single sketched curve, and the curve is not required to reference existing geometry.
pathPlane
Type: Autodesk.Revit.DB..::..SketchPlane
The sketch plane for the path. Use this when you want to create a 2D path that resides on an existing planar face. Optional, can be nullNothingnullptra null reference (Nothing in Visual Basic) for a path curve obtained from geometry or for 2D paths where the path should not reference an existing edge.
bottomProfile
Type: Autodesk.Revit.DB..::..SweepProfile
The bottom profile of the newly created Swept blend. It should consist of only one curve loop. The profile must lie in the XY plane, and it will be transformed to the profile plane automatically.
topProfile
Type: Autodesk.Revit.DB..::..SweepProfile
The top profile of the newly created Swept blend. It should consist of only one curve loop. The profile must lie in the XY plane, and it will be transformed to the profile plane automatically.

Return Value

If creation was successful the new Swept blend is returned, otherwise an exception with failure information will be thrown.

Remarks

This method creates a swept blend in a family document. The swept blend will trace from bottom profile to the top along the path. Revit will determine an appropriate default mapping for the vertices of the two profiles. If the input profile is to be a cyclic profile (curve or ellipse) it must be split into at least two segments, so that Revit can find vertices to use for mapping the swept blend.

Examples

CopyC#
private SweptBlend CreateSweptBlend(Autodesk.Revit.DB.Document document, SketchPlane sketchPlane)
{
    SweptBlend newSweptBlend = null;

    // make sure we have a family document
    if (true == document.IsFamilyDocument)
    {
        // Create top and bottom profiles and path curve
        XYZ pnt1 = new XYZ(0, 0, 0);
        XYZ pnt2 = new XYZ(1, 0, 0);
        XYZ pnt3 = new XYZ(1, 1, 0);
        XYZ pnt4 = new XYZ(0, 1, 0);
        XYZ pnt5 = new XYZ(0, 0, 1);

        CurveArrArray arrarr1 = new CurveArrArray();
        CurveArray arr1 = new CurveArray();
        arr1.Append(Line.CreateBound(pnt1, pnt2));
        arr1.Append(Line.CreateBound(pnt2, pnt3));
        arr1.Append(Line.CreateBound(pnt3, pnt4));
        arr1.Append(Line.CreateBound(pnt4, pnt1));
        arrarr1.Append(arr1);

        XYZ pnt6 = new XYZ(0.5, 0, 0);
        XYZ pnt7 = new XYZ(1, 0.5, 0);
        XYZ pnt8 = new XYZ(0.5, 1, 0);
        XYZ pnt9 = new XYZ(0, 0.5, 0);
        CurveArrArray arrarr2 = new CurveArrArray();
        CurveArray arr2 = new CurveArray();
        arr2.Append(Line.CreateBound(pnt6, pnt7));
        arr2.Append(Line.CreateBound(pnt7, pnt8));
        arr2.Append(Line.CreateBound(pnt8, pnt9));
        arr2.Append(Line.CreateBound(pnt9, pnt6));
        arrarr2.Append(arr2);

        SweepProfile bottomProfile = document.Application.Create.NewCurveLoopsProfile(arrarr1);
        SweepProfile topProfile = document.Application.Create.NewCurveLoopsProfile(arrarr2);

        XYZ pnt10 = new XYZ(5, 0, 0);
        XYZ pnt11 = new XYZ(0, 20, 0);
        Curve curve = Line.CreateBound(pnt10, pnt11);

        // here create rectangular swept blend
        newSweptBlend = document.FamilyCreate.NewSweptBlend(true, curve, sketchPlane, bottomProfile, topProfile);
        if (null != newSweptBlend)
        {
            // move to proper place
            XYZ transPoint1 = new XYZ(11, 32, 0);
            ElementTransformUtils.MoveElement(document, newSweptBlend.Id, transPoint1);
        }
        else
        {
            throw new Exception("Failed to create new SweptBlend.");
        }
    }
    else
    {
        throw new Exception("Please open a Family document before invoking this command.");
    }
    return newSweptBlend;
}
CopyVB.NET
Private Function CreateSweptBlend(document As Autodesk.Revit.DB.Document, sketchPlane As SketchPlane) As SweptBlend
    Dim newSweptBlend As SweptBlend = Nothing

    ' make sure we have a family document
    If True = document.IsFamilyDocument Then
        ' Create top and bottom profiles and path curve
        Dim pnt1 As New XYZ(0, 0, 0)
        Dim pnt2 As New XYZ(1, 0, 0)
        Dim pnt3 As New XYZ(1, 1, 0)
        Dim pnt4 As New XYZ(0, 1, 0)
        Dim pnt5 As New XYZ(0, 0, 1)

        Dim arrarr1 As New CurveArrArray()
        Dim arr1 As New CurveArray()
        arr1.Append(Line.CreateBound(pnt1, pnt2))
        arr1.Append(Line.CreateBound(pnt2, pnt3))
        arr1.Append(Line.CreateBound(pnt3, pnt4))
        arr1.Append(Line.CreateBound(pnt4, pnt1))
        arrarr1.Append(arr1)

        Dim pnt6 As New XYZ(0.5, 0, 0)
        Dim pnt7 As New XYZ(1, 0.5, 0)
        Dim pnt8 As New XYZ(0.5, 1, 0)
        Dim pnt9 As New XYZ(0, 0.5, 0)
        Dim arrarr2 As New CurveArrArray()
        Dim arr2 As New CurveArray()
        arr2.Append(Line.CreateBound(pnt6, pnt7))
        arr2.Append(Line.CreateBound(pnt7, pnt8))
        arr2.Append(Line.CreateBound(pnt8, pnt9))
        arr2.Append(Line.CreateBound(pnt9, pnt6))
        arrarr2.Append(arr2)

        Dim bottomProfile As SweepProfile = document.Application.Create.NewCurveLoopsProfile(arrarr1)
        Dim topProfile As SweepProfile = document.Application.Create.NewCurveLoopsProfile(arrarr2)

        Dim pnt10 As New XYZ(5, 0, 0)
        Dim pnt11 As New XYZ(0, 20, 0)
        Dim curve As Curve = Line.CreateBound(pnt10, pnt11)

        ' here create rectangular swept blend
        newSweptBlend = document.FamilyCreate.NewSweptBlend(True, curve, sketchPlane, bottomProfile, topProfile)
        If newSweptBlend IsNot Nothing Then
            ' move to proper place
            Dim transPoint1 As New XYZ(11, 32, 0)
            ElementTransformUtils.MoveElement(document, newSweptBlend.Id, transPoint1)
        Else
            Throw New Exception("Failed to create new SweptBlend.")
        End If
    Else
        Throw New Exception("Please open a Family document before invoking this command.")
    End If
    Return newSweptBlend
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input arguments-path/bottomProfile/topProfile-are nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-bottomProfile/topProfile-is a curve based profile and the profile is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-bottomProfile/topProfile-is a curve based profile and the profile contains nullNothingnullptra null reference (Nothing in Visual Basic) or more than one curve loops.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-bottomProfile/topProfile-is a family symbol based profile and the family symbol profile is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when creation is attempted in Conceptual Mass, 2D, or other family where swept blends cannot be created.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewSweptBlend Overload
Autodesk.Revit.Creation Namespace


NewSweptBlendForm Method

[image]

Revit 2024 API
FamilyItemFactory..::..NewSweptBlendForm Method
FamilyItemFactory Class See Also Send Feedback
Create new Form element by swept blend operation, and add it into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Form NewSweptBlendForm(
    bool isSolid,
    ReferenceArray path,
    ReferenceArrayArray profiles
)
Visual Basic
Public Function NewSweptBlendForm ( _
    isSolid As Boolean, _
    path As ReferenceArray, _
    profiles As ReferenceArrayArray _
) As Form
Visual C++
public:
Form^ NewSweptBlendForm(
    bool isSolid,
    ReferenceArray^ path,
    ReferenceArrayArray^ profiles
)

Parameters

isSolid
Type: System..::..Boolean
Indicates if the Form is Solid or Void.
path
Type: Autodesk.Revit.DB..::..ReferenceArray
The path of the swept blend. The path should be 2D, where all input curves lie in one plane. If there's more than one profile, the path should be a single curve. It's required to reference existing geometry.
profiles
Type: Autodesk.Revit.DB..::..ReferenceArrayArray
The profile set of the newly created swept blend. Each profile should consist of only one curve loop. Each profile must be in a plane that intersects with the path and is perpendicular to the path at the point of intersection.

Return Value

If creation was successful new form is returned.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewSymbolicCurve Method

[image]

Revit 2024 API
FamilyItemFactory..::..NewSymbolicCurve Method
FamilyItemFactory Class See Also Send Feedback
Create a symbolic curve in an Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public SymbolicCurve NewSymbolicCurve(
    Curve curve,
    SketchPlane sketchPlane
)
Visual Basic
Public Function NewSymbolicCurve ( _
    curve As Curve, _
    sketchPlane As SketchPlane _
) As SymbolicCurve
Visual C++
public:
SymbolicCurve^ NewSymbolicCurve(
    Curve^ curve,
    SketchPlane^ sketchPlane
)

Parameters

curve
Type: Autodesk.Revit.DB..::..Curve
The geometry curve of the newly created symbolic curve.
sketchPlane
Type: Autodesk.Revit.DB..::..SketchPlane
The sketch plane for the symbolic curve.

Return Value

The newly created symbolic curve.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when regeneration failed. Thrown when symbolic curve creation failed.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


FamilyItemFactory Properties

[image] [image]

Revit 2024 API
FamilyItemFactory Properties
FamilyItemFactory Class See Also Send Feedback

The FamilyItemFactory type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


ItemFactoryBase Members

[image] [image]

Revit 2024 API
ItemFactoryBase Members
ItemFactoryBase Class Methods Properties See Also Send Feedback

The ItemFactoryBase type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NewAlignment | Add a new locked alignment into the Autodesk Revit document.
Public method | NewDetailCurve | Creates a new detail curve element.
Public method | NewDetailCurveArray | Creates an array of new detail curve elements.
Public method | NewDimension(View, Line, ReferenceArray) | Creates a new linear dimension object using the default dimension style.
Public method | NewDimension(View, Line, ReferenceArray, DimensionType) | Creates a new linear dimension object using the specified dimension style.
Public method | NewFamilyInstance(Face, Line, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a line on that face for its position, and a type/symbol.
Public method | NewFamilyInstance(Line, FamilySymbol, View) | Add a line based detail family instance into the Autodesk Revit document, using an line and a view where the instance should be placed.
Public method | NewFamilyInstance(Reference, Line, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a line on that face for its position, and a type/symbol.
Public method | NewFamilyInstance(XYZ, FamilySymbol, StructuralType) | Inserts a new instance of a family into the document, using a location and a type/symbol.
Public method | NewFamilyInstance(XYZ, FamilySymbol, View) | Add a new family instance into the Autodesk Revit document, using an origin and a view where the instance should be placed.
Public method | NewFamilyInstance(Face, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a location, reference direction, and a type/symbol.
Public method | NewFamilyInstance(Reference, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a location, reference direction, and a type/symbol.
Public method | NewFamilyInstance(XYZ, FamilySymbol, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the host element.
Public method | NewFamilyInstance(XYZ, FamilySymbol, Level, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the level.
Public method | NewFamilyInstance(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a reference direction.
Public method | NewFamilyInstances2 | Creates Family instances within the document.
Public method | NewGroup | Creates a new type of group.
Public method | NewModelCurve | Creates a new model line element.
Public method | NewModelCurveArray | Creates an array of new model line elements.
Public method | NewReferencePlane | Creates a new instance of ReferencePlane.
Public method | NewReferencePlane2 | Creates a new instance of ReferencePlane.
Public method | PlaceGroup | Place an instance of a Model Group into the Autodesk Revit document, using a location and a group type.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


ItemFactoryBase Methods

[image] [image]

Revit 2024 API
ItemFactoryBase Methods
ItemFactoryBase Class See Also Send Feedback

The ItemFactoryBase type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NewAlignment | Add a new locked alignment into the Autodesk Revit document.
Public method | NewDetailCurve | Creates a new detail curve element.
Public method | NewDetailCurveArray | Creates an array of new detail curve elements.
Public method | NewDimension(View, Line, ReferenceArray) | Creates a new linear dimension object using the default dimension style.
Public method | NewDimension(View, Line, ReferenceArray, DimensionType) | Creates a new linear dimension object using the specified dimension style.
Public method | NewFamilyInstance(Face, Line, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a line on that face for its position, and a type/symbol.
Public method | NewFamilyInstance(Line, FamilySymbol, View) | Add a line based detail family instance into the Autodesk Revit document, using an line and a view where the instance should be placed.
Public method | NewFamilyInstance(Reference, Line, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a line on that face for its position, and a type/symbol.
Public method | NewFamilyInstance(XYZ, FamilySymbol, StructuralType) | Inserts a new instance of a family into the document, using a location and a type/symbol.
Public method | NewFamilyInstance(XYZ, FamilySymbol, View) | Add a new family instance into the Autodesk Revit document, using an origin and a view where the instance should be placed.
Public method | NewFamilyInstance(Face, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a location, reference direction, and a type/symbol.
Public method | NewFamilyInstance(Reference, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a location, reference direction, and a type/symbol.
Public method | NewFamilyInstance(XYZ, FamilySymbol, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the host element.
Public method | NewFamilyInstance(XYZ, FamilySymbol, Level, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the level.
Public method | NewFamilyInstance(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a reference direction.
Public method | NewFamilyInstances2 | Creates Family instances within the document.
Public method | NewGroup | Creates a new type of group.
Public method | NewModelCurve | Creates a new model line element.
Public method | NewModelCurveArray | Creates an array of new model line elements.
Public method | NewReferencePlane | Creates a new instance of ReferencePlane.
Public method | NewReferencePlane2 | Creates a new instance of ReferencePlane.
Public method | PlaceGroup | Place an instance of a Model Group into the Autodesk Revit document, using a location and a group type.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewAlignment Method

[image]

Revit 2024 API
ItemFactoryBase..::..NewAlignment Method
ItemFactoryBase Class See Also Send Feedback
Add a new locked alignment into the Autodesk Revit document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Dimension NewAlignment(
    View view,
    Reference reference1,
    Reference reference2
)
Visual Basic
Public Function NewAlignment ( _
    view As View, _
    reference1 As Reference, _
    reference2 As Reference _
) As Dimension
Visual C++
public:
Dimension^ NewAlignment(
    View^ view,
    Reference^ reference1,
    Reference^ reference2
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view that determines the orientation of the alignment.
reference1
Type: Autodesk.Revit.DB..::..Reference
The first reference.
reference2
Type: Autodesk.Revit.DB..::..Reference
The second reference.

Return Value

If creation was successful the new locked alignment dimension is returned, otherwise an exception with failure information will be thrown.

Remarks

These two references must be one of the following combinations:
  • 2 planar faces
  • planar face and reference plane
  • 2 lines
  • line and point
  • line and reference plane
  • 2 arcs
  • 2 cylindrical faces
These references must be already geometrically aligned (this function will not force them to become aligned).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"view" or "headerReference" or "otherReference"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-"headerReference" or "otherReference"-is invalid.

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewDetailCurve Method

[image]

Revit 2024 API
ItemFactoryBase..::..NewDetailCurve Method
ItemFactoryBase Class See Also Send Feedback
Creates a new detail curve element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public DetailCurve NewDetailCurve(
    View view,
    Curve geometryCurve
)
Visual Basic
Public Function NewDetailCurve ( _
    view As View, _
    geometryCurve As Curve _
) As DetailCurve
Visual C++
public:
DetailCurve^ NewDetailCurve(
    View^ view,
    Curve^ geometryCurve
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view in which the detail curve is to be visible.
geometryCurve
Type: Autodesk.Revit.DB..::..Curve
The internal geometry curve for detail curve. It should be a bound curve.

Return Value

If successful a new detail curve element. Otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

Different type of detail curve element will be returned according to the type of geometry curve.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when curve is not in plane of the view

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewDimension Method

[image] [image]

Revit 2024 API
ItemFactoryBase..::..NewDimension Method
ItemFactoryBase Class See Also Send Feedback
Creates a new linear dimension object.

Overload List

 | Name | Description
Public method | NewDimension(View, Line, ReferenceArray) | Creates a new linear dimension object using the default dimension style.
Public method | NewDimension(View, Line, ReferenceArray, DimensionType) | Creates a new linear dimension object using the specified dimension style.

See Also

ItemFactoryBase Class
ItemFactoryBase Members
Autodesk.Revit.Creation Namespace


NewDimension Method (View, Line, ReferenceArray)

[image]

Revit 2024 API
ItemFactoryBase..::..NewDimension Method (View, Line, ReferenceArray)
ItemFactoryBase Class Example See Also Send Feedback
Creates a new linear dimension object using the default dimension style.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Dimension NewDimension(
    View view,
    Line line,
    ReferenceArray references
)
Visual Basic
Public Function NewDimension ( _
    view As View, _
    line As Line, _
    references As ReferenceArray _
) As Dimension
Visual C++
public:
Dimension^ NewDimension(
    View^ view,
    Line^ line,
    ReferenceArray^ references
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view in which the dimension is to be visible. The view must be nullNothingnullptra null reference (Nothing in Visual Basic) if the document is in [!:Autodesk::Revit::DB::SketchEditScope].
line
Type: Autodesk.Revit.DB..::..Line
The line drawn for the dimension.
references
Type: Autodesk.Revit.DB..::..ReferenceArray
An array of geometric references to which the dimension is to be bound.

Return Value

If successful a new dimension object, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

The currently user set default style is used for the created dimension.

Examples

CopyC#
Dimension CreateNewDimensionAlongLine(Autodesk.Revit.DB.Document document, Line line)
{
    // Use the Start and End points of our line as the references
    // Line must come from something in Revit, such as a beam
    ReferenceArray references = new ReferenceArray();
    references.Append(line.GetEndPointReference(0));
    references.Append(line.GetEndPointReference(1));

    // create the new dimension
    Dimension dimension = document.Create.NewDimension(document.ActiveView,
                                                        line, references);
    return dimension;
}
CopyVB.NET
Private Function CreateNewDimensionAlongLine(document As Autodesk.Revit.DB.Document, line As Line) As Dimension
    ' Use the Start and End points of our line as the references
    ' Line must come from something in Revit, such as a beam
    Dim references As New ReferenceArray()
    references.Append(line.GetEndPointReference(0))
    references.Append(line.GetEndPointReference(1))

    ' create the new dimension
    Dim dimension As Dimension = document.Create.NewDimension(document.ActiveView, line, references)
    Return dimension
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when references are not geometric references.

See Also

ItemFactoryBase Class
NewDimension Overload
Autodesk.Revit.Creation Namespace


NewDimension Method (View, Line, ReferenceArray, DimensionType)

[image]

Revit 2024 API
ItemFactoryBase..::..NewDimension Method (View, Line, ReferenceArray, DimensionType)
ItemFactoryBase Class See Also Send Feedback
Creates a new linear dimension object using the specified dimension style.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Dimension NewDimension(
    View view,
    Line line,
    ReferenceArray references,
    DimensionType dimensionType
)
Visual Basic
Public Function NewDimension ( _
    view As View, _
    line As Line, _
    references As ReferenceArray, _
    dimensionType As DimensionType _
) As Dimension
Visual C++
public:
Dimension^ NewDimension(
    View^ view,
    Line^ line,
    ReferenceArray^ references,
    DimensionType^ dimensionType
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view in which the dimension is to be visible. The view must be nullNothingnullptra null reference (Nothing in Visual Basic) if the document is in [!:Autodesk::Revit::DB::SketchEditScope].
line
Type: Autodesk.Revit.DB..::..Line
The line drawn for the dimension.
references
Type: Autodesk.Revit.DB..::..ReferenceArray
An array of geometric references to which the dimension is to be bound.
dimensionType
Type: Autodesk.Revit.DB..::..DimensionType
The dimension style to be used for the dimension.

Return Value

If successful a new dimension object, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when references are not geometric references.

See Also

ItemFactoryBase Class
NewDimension Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method

[image] [image]

Revit 2024 API
ItemFactoryBase..::..NewFamilyInstance Method
ItemFactoryBase Class See Also Send Feedback
Inserts a new instance of a family into the document.

Overload List

 | Name | Description
Public method | NewFamilyInstance(Face, Line, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a line on that face for its position, and a type/symbol.
Public method | NewFamilyInstance(Line, FamilySymbol, View) | Add a line based detail family instance into the Autodesk Revit document, using an line and a view where the instance should be placed.
Public method | NewFamilyInstance(Reference, Line, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a line on that face for its position, and a type/symbol.
Public method | NewFamilyInstance(XYZ, FamilySymbol, StructuralType) | Inserts a new instance of a family into the document, using a location and a type/symbol.
Public method | NewFamilyInstance(XYZ, FamilySymbol, View) | Add a new family instance into the Autodesk Revit document, using an origin and a view where the instance should be placed.
Public method | NewFamilyInstance(Face, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a location, reference direction, and a type/symbol.
Public method | NewFamilyInstance(Reference, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a location, reference direction, and a type/symbol.
Public method | NewFamilyInstance(XYZ, FamilySymbol, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the host element.
Public method | NewFamilyInstance(XYZ, FamilySymbol, Level, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the level.
Public method | NewFamilyInstance(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a reference direction.

See Also

ItemFactoryBase Class
ItemFactoryBase Members
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method (Face, Line, FamilySymbol)

[image]

Revit 2024 API
ItemFactoryBase..::..NewFamilyInstance Method (Face, Line, FamilySymbol)
ItemFactoryBase Class Example See Also Send Feedback
Inserts a new instance of a family onto a face of an existing element, using a line on that face for its position, and a type/symbol.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyInstance NewFamilyInstance(
    Face face,
    Line position,
    FamilySymbol symbol
)
Visual Basic
Public Function NewFamilyInstance ( _
    face As Face, _
    position As Line, _
    symbol As FamilySymbol _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    Face^ face,
    Line^ position,
    FamilySymbol^ symbol
)

Parameters

face
Type: Autodesk.Revit.DB..::..Face
A face of a geometry object.
position
Type: Autodesk.Revit.DB..::..Line
A line on the face defining where the symbol is to be placed.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted. Note that this symbol must represent a family whose FamilyPlacementType is WorkPlaneBased or CurveBased.

Return Value

An instance of the new object if creation was successful, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

Use this method to insert one family instance on a face of another element, using a line on the face to define the position and direction of the new symbol.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

The host object must support insertion of instances, otherwise this method will fail. If the instance fails to be created an exception may be thrown.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call.

Examples

CopyC#
public void PlaceStiffenerOnWallFace(Autodesk.Revit.DB.Document doc, Wall wall)
{
    // The structural stiffeners family type is compatible with line-based face placement
    FilteredElementCollector fsCollector = new FilteredElementCollector(doc);
    fsCollector.OfClass(typeof(FamilySymbol)).OfCategory(BuiltInCategory.OST_StructuralStiffener);
    FamilySymbol stiffenerSymbol = fsCollector.FirstElement() as FamilySymbol;

    // The only way to get a Face to use with this NewFamilyInstance overload
    // is from Element.Geometry with ComputeReferences turned on
    Face face = null;
    Options geomOptions = new Options();
    geomOptions.ComputeReferences = true;
    GeometryElement wallGeom = wall.get_Geometry(geomOptions);
    foreach (GeometryObject geomObj in wallGeom)
    {
        Solid geomSolid = geomObj as Solid;
        if (null != geomSolid)
        {
            foreach (Face geomFace in geomSolid.Faces)
            {
                face = geomFace;
                break;
            }
            break;
        }
    }

    // Generate line for path
    BoundingBoxUV bbox = face.GetBoundingBox();
    UV lowerLeft = bbox.Min;
    UV upperRight = bbox.Max;
    double deltaU = upperRight.U - lowerLeft.U;
    double deltaV = upperRight.V - lowerLeft.V;
    double vOffset = deltaV * 0.80; // 80% up the wall face

    UV firstPoint = lowerLeft + new UV(deltaU * 0.30, vOffset);
    UV lastPoint = lowerLeft + new UV(deltaU * 0.70, vOffset);

    Line line = Line.CreateBound(face.Evaluate(firstPoint), face.Evaluate(lastPoint));

    doc.Create.NewFamilyInstance(face, line, stiffenerSymbol);
}
CopyVB.NET
Public Sub PlaceStiffenerOnWallFace(doc As Autodesk.Revit.DB.Document, wall As Wall)
    ' The structural stiffeners family type is compatible with line-based face placement
    Dim fsCollector As New FilteredElementCollector(doc)
    fsCollector.OfClass(GetType(FamilySymbol)).OfCategory(BuiltInCategory.OST_StructuralStiffener)
    Dim stiffenerSymbol As FamilySymbol = TryCast(fsCollector.FirstElement(), FamilySymbol)

    ' The only way to get a Face to use with this NewFamilyInstance overload
    ' is from Element.Geometry with ComputeReferences turned on
    Dim face As Face = Nothing
    Dim geomOptions As New Options()
    geomOptions.ComputeReferences = True
    Dim wallGeom As GeometryElement = wall.Geometry(geomOptions)
    For Each geomObj As GeometryObject In wallGeom
        Dim geomSolid As Solid = TryCast(geomObj, Solid)
        If geomSolid IsNot Nothing Then
            For Each geomFace As Face In geomSolid.Faces
                face = geomFace
                Exit For
            Next
            Exit For
        End If
    Next

    ' Generate line for path
    Dim bbox As BoundingBoxUV = face.GetBoundingBox()
    Dim lowerLeft As UV = bbox.Min
    Dim upperRight As UV = bbox.Max
    Dim deltaU As Double = upperRight.U - lowerLeft.U
    Dim deltaV As Double = upperRight.V - lowerLeft.V
    Dim vOffset As Double = deltaV * 0.8
    ' 80% up the wall face
    Dim firstPoint As UV = lowerLeft + New UV(deltaU * 0.3, vOffset)
    Dim lastPoint As UV = lowerLeft + New UV(deltaU * 0.7, vOffset)

    Dim line__1 As Line = Line.CreateBound(face.Evaluate(firstPoint), face.Evaluate(lastPoint))

    doc.Create.NewFamilyInstance(face, line__1, stiffenerSymbol)
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when a non-optional argument was null.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the function cannot get the Reference from the face, or, Family cannot be placed as line-based on an input face reference, because its FamilyPlacementType is not WorkPlaneBased or CurveBased
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | Thrown when the family cannot be placed on this line as it does not coincide with the input face.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when Revit is unable to place the family instance.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if The symbol is not active.

See Also

ItemFactoryBase Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method (Line, FamilySymbol, View)

[image]

Revit 2024 API
ItemFactoryBase..::..NewFamilyInstance Method (Line, FamilySymbol, View)
ItemFactoryBase Class Example See Also Send Feedback
Add a line based detail family instance into the Autodesk Revit document, using an line and a view where the instance should be placed.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyInstance NewFamilyInstance(
    Line line,
    FamilySymbol symbol,
    View specView
)
Visual Basic
Public Function NewFamilyInstance ( _
    line As Line, _
    symbol As FamilySymbol, _
    specView As View _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    Line^ line,
    FamilySymbol^ symbol,
    View^ specView
)

Parameters

line
Type: Autodesk.Revit.DB..::..Line
The line location of family instance. The line must in the plane of the view.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A family symbol object that represents the type of the instance that is to be inserted.
specView
Type: Autodesk.Revit.DB..::..View
A 2D view in which to display the family instance.

Remarks

This overload applies only to 2D family line based detail symbols. The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

Examples

CopyC#
void CreateDetailComponent(Autodesk.Revit.DB.Document document, View view)
{
    // Create a detail component in the given view if it is a detail or drafting view
    if (view.ViewType == ViewType.Detail ||
        view.ViewType == ViewType.DraftingView)
    {
        FamilySymbol symbol = null;
        FilteredElementCollector fsCollector = new FilteredElementCollector(document);
        fsCollector.OfClass(typeof(FamilySymbol)).OfCategory(BuiltInCategory.OST_DetailComponents);
        ICollection<Element> collection = fsCollector.ToElements();
        foreach (Element element in collection)
        {
            FamilySymbol current = element as FamilySymbol;
            // This NewFamilyInstance overload requires a curve based family
            if (current.Family.FamilyPlacementType == FamilyPlacementType.CurveBasedDetail)
            {
                symbol = current;
                break;
            }
        }

        if (symbol != null)
        {
            // create a 2' detail component at the view's origin
            XYZ start = view.Origin;
            XYZ end = start + new XYZ(2, 0, 0);

            Line line = Line.CreateBound(start, end);

            FamilyInstance instance = document.Create.NewFamilyInstance(line, symbol, view);
        }
    }
}
CopyVB.NET
Private Sub CreateDetailComponent(document As Autodesk.Revit.DB.Document, view As View)
    ' Create a detail component in the given view if it is a detail or drafting view
    If view.ViewType = ViewType.Detail OrElse view.ViewType = ViewType.DraftingView Then
        Dim symbol As FamilySymbol = Nothing
        Dim fsCollector As New FilteredElementCollector(document)
        fsCollector.OfClass(GetType(FamilySymbol)).OfCategory(BuiltInCategory.OST_DetailComponents)
        Dim collection As ICollection(Of Element) = fsCollector.ToElements()
        For Each element As Element In collection
            Dim current As FamilySymbol = TryCast(element, FamilySymbol)
            ' This NewFamilyInstance overload requires a curve based family
            If current.Family.FamilyPlacementType = FamilyPlacementType.CurveBasedDetail Then
                symbol = current
                Exit For
            End If
        Next

        If symbol IsNot Nothing Then
            ' create a 2' detail component at the view's origin
            Dim start As XYZ = view.Origin
            Dim [end] As XYZ = start + New XYZ(2, 0, 0)

            Dim line__1 As Line = Line.CreateBound(start, [end])

            Dim instance As FamilyInstance = document.Create.NewFamilyInstance(line__1, symbol, view)
        End If
    End If
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when input argument line or symbol or specView is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when input argument line or symbol or specView is invalid, or cannot make such type in the specView, or the line is not in the plane of specView.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when failed to create the instance.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when attempting to place a model-based family. Only 2D detail families can be placed in views.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if The symbol is not active.

See Also

ItemFactoryBase Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method (Reference, Line, FamilySymbol)

[image]

Revit 2024 API
ItemFactoryBase..::..NewFamilyInstance Method (Reference, Line, FamilySymbol)
ItemFactoryBase Class Example See Also Send Feedback
Inserts a new instance of a family onto a face referenced by the input Reference instance, using a line on that face for its position, and a type/symbol.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyInstance NewFamilyInstance(
    Reference reference,
    Line position,
    FamilySymbol symbol
)
Visual Basic
Public Function NewFamilyInstance ( _
    reference As Reference, _
    position As Line, _
    symbol As FamilySymbol _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    Reference^ reference,
    Line^ position,
    FamilySymbol^ symbol
)

Parameters

reference
Type: Autodesk.Revit.DB..::..Reference
A reference to a face.
position
Type: Autodesk.Revit.DB..::..Line
A line on the face defining where the symbol is to be placed.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted. Note that this symbol must represent a family whose FamilyPlacementType is WorkPlaneBased or CurveBased.

Return Value

An instance of the new object if creation was successful, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

Use this method to insert one family instance on a face of another element, using a line on the face to define the position and direction of the new symbol.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

The host object must support insertion of instances, otherwise this method will fail. If the instance fails to be created an exception may be thrown.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call.

Examples

CopyC#
public void PlaceStiffenerOnWallFaceRef(Autodesk.Revit.DB.Document doc)
{
    FilteredElementCollector wallCollector = new FilteredElementCollector(doc);
    wallCollector.OfClass(typeof(Wall));
    Wall wall = wallCollector.FirstElement() as Wall;

    // The structural stiffeners family type is compatible with line-based face placement
    FilteredElementCollector fsCollector = new FilteredElementCollector(doc);
    fsCollector.OfClass(typeof(FamilySymbol)).OfCategory(BuiltInCategory.OST_StructuralStiffener);
    FamilySymbol stiffenerSymbol = fsCollector.FirstElement() as FamilySymbol;

    // Get side face of wall
    IList<Reference> sideFaces = HostObjectUtils.GetSideFaces(wall, ShellLayerType.Exterior);
    Reference sideFaceRef = sideFaces[0];

    // Generate line for path
    Face face = wall.GetGeometryObjectFromReference(sideFaceRef) as Face;
    BoundingBoxUV bbox = face.GetBoundingBox();
    UV lowerLeft = bbox.Min;
    UV upperRight = bbox.Max;
    double deltaU = upperRight.U - lowerLeft.U;
    double deltaV = upperRight.V - lowerLeft.V;
    double vOffset = deltaV * 0.60; // 60% up the wall face

    UV firstPoint = lowerLeft + new UV(deltaU * 0.20, vOffset);
    UV lastPoint = lowerLeft + new UV(deltaU * 0.80, vOffset);

    Line line = Line.CreateBound(face.Evaluate(firstPoint), face.Evaluate(lastPoint));

    doc.Create.NewFamilyInstance(sideFaceRef, line, stiffenerSymbol);
}
CopyVB.NET
Public Sub PlaceStiffenerOnWallFaceRef(doc As Autodesk.Revit.DB.Document)
    Dim wallCollector As New FilteredElementCollector(doc)
    wallCollector.OfClass(GetType(Wall))
    Dim wall As Wall = TryCast(wallCollector.FirstElement(), Wall)

    ' The structural stiffeners family type is compatible with line-based face placement
    Dim fsCollector As New FilteredElementCollector(doc)
    fsCollector.OfClass(GetType(FamilySymbol)).OfCategory(BuiltInCategory.OST_StructuralStiffener)
    Dim stiffenerSymbol As FamilySymbol = TryCast(fsCollector.FirstElement(), FamilySymbol)

    ' Get side face of wall
    Dim sideFaces As IList(Of Reference) = HostObjectUtils.GetSideFaces(wall, ShellLayerType.Exterior)
    Dim sideFaceRef As Reference = sideFaces(0)

    ' Generate line for path
    Dim face As Face = TryCast(wall.GetGeometryObjectFromReference(sideFaceRef), Face)
    Dim bbox As BoundingBoxUV = face.GetBoundingBox()
    Dim lowerLeft As UV = bbox.Min
    Dim upperRight As UV = bbox.Max
    Dim deltaU As Double = upperRight.U - lowerLeft.U
    Dim deltaV As Double = upperRight.V - lowerLeft.V
    Dim vOffset As Double = deltaV * 0.6
    ' 60% up the wall face
    Dim firstPoint As UV = lowerLeft + New UV(deltaU * 0.2, vOffset)
    Dim lastPoint As UV = lowerLeft + New UV(deltaU * 0.8, vOffset)

    Dim line__1 As Line = Line.CreateBound(face.Evaluate(firstPoint), face.Evaluate(lastPoint))

    doc.Create.NewFamilyInstance(sideFaceRef, line__1, stiffenerSymbol)
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when a non-optional argument was null.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the function cannot get a face from the reference, or, when the family cannot be placed as line-based on an input face reference, because its FamilyPlacementType is not WorkPlaneBased or CurveBased
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | Thrown when the family cannot be placed on this line as it does not coincide with the input face.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when Revit is unable to place the family instance.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if The symbol is not active.

See Also

ItemFactoryBase Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method (XYZ, FamilySymbol, StructuralType)

[image]

Revit 2024 API
ItemFactoryBase..::..NewFamilyInstance Method (XYZ, FamilySymbol, StructuralType)
ItemFactoryBase Class See Also Send Feedback
Inserts a new instance of a family into the document, using a location and a type/symbol.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyInstance NewFamilyInstance(
    XYZ location,
    FamilySymbol symbol,
    StructuralType structuralType
)
Visual Basic
Public Function NewFamilyInstance ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    structuralType As StructuralType _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    XYZ^ location,
    FamilySymbol^ symbol,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.DB..::..XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
structuralType
Type: Autodesk.Revit.DB.Structure..::..StructuralType
If structural then specify the type of the component.

Return Value

A valid instance of the given family if the creation is successful. An exception will be thrown otherwise.

Remarks

Use this method to insert a family instance that does not require a host element or level. For creating instances of level-based families use one of the NewFamilyInstance methods of the Revit.Creation.Document class.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

Some Families, such as Beams, have more than one endpoint and are inserted in the same manner as single point instances. Once inserted these linear family instances can have their endpoints changed by using the instance's Element.Location property.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the symbol is not active.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if the family is level-based, for new instances of such families require a valid level to be supplied at the time of creation.

See Also

ItemFactoryBase Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method (XYZ, FamilySymbol, View)

[image]

Revit 2024 API
ItemFactoryBase..::..NewFamilyInstance Method (XYZ, FamilySymbol, View)
ItemFactoryBase Class See Also Send Feedback
Add a new family instance into the Autodesk Revit document, using an origin and a view where the instance should be placed.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyInstance NewFamilyInstance(
    XYZ origin,
    FamilySymbol symbol,
    View specView
)
Visual Basic
Public Function NewFamilyInstance ( _
    origin As XYZ, _
    symbol As FamilySymbol, _
    specView As View _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    XYZ^ origin,
    FamilySymbol^ symbol,
    View^ specView
)

Parameters

origin
Type: Autodesk.Revit.DB..::..XYZ
The origin of family instance. If created on a ViewPlan, the origin will be projected onto the ViewPlan.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A family symbol object that represents the type of the instance that is to be inserted.
specView
Type: Autodesk.Revit.DB..::..View
The 2D view in which to place the family instance.

Return Value

If creation was successful then an instance to the new object is returned.

Remarks

This overload applies only to 2D family symbols (detail components, annotation symbols, titleblocks, etc.). The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | One or more required arguments was nullNothingnullptra null reference (Nothing in Visual Basic)
Autodesk.Revit.Exceptions..::..ArgumentException | The input family PlacementType was not ViewBased, the input view was not 2D, Thrown if The symbol is not active. or instances of the input FamilySymbol are not permitted on a view of this type.

See Also

ItemFactoryBase Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method (Face, XYZ, XYZ, FamilySymbol)

[image]

Revit 2024 API
ItemFactoryBase..::..NewFamilyInstance Method (Face, XYZ, XYZ, FamilySymbol)
ItemFactoryBase Class Example See Also Send Feedback
Inserts a new instance of a family onto a face of an existing element, using a location, reference direction, and a type/symbol.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyInstance NewFamilyInstance(
    Face face,
    XYZ location,
    XYZ referenceDirection,
    FamilySymbol symbol
)
Visual Basic
Public Function NewFamilyInstance ( _
    face As Face, _
    location As XYZ, _
    referenceDirection As XYZ, _
    symbol As FamilySymbol _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    Face^ face,
    XYZ^ location,
    XYZ^ referenceDirection,
    FamilySymbol^ symbol
)

Parameters

face
Type: Autodesk.Revit.DB..::..Face
A face of a geometry object.
location
Type: Autodesk.Revit.DB..::..XYZ
Point on the face where the instance is to be placed.
referenceDirection
Type: Autodesk.Revit.DB..::..XYZ
A vector that defines the direction of the family instance. Note that this direction defines the rotation of the instance on the face, and thus cannot be parallel to the face normal.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted. Note that this symbol must represent a family whose FamilyPlacementType is WorkPlaneBased.

Return Value

An instance of the new object if creation was successful, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

Use this method to insert one family instance on a face of another element, using a point on the face and a vector to define the position and direction of the new symbol.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

The host object must support insertion of instances, otherwise this method will fail. If the instances fails to be created an exception may be thrown.

Some Families, such as Beams, have more than one endpoint and are inserted in the same manner as single point instances. Once inserted, these linear family instances can have their endpoints changed by using the instance's Element.Location property.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call.

Examples

CopyC#
void CreateLightFixtureOnWall(Autodesk.Revit.DB.Document document, Wall wall)
{
    FilteredElementCollector collector = new FilteredElementCollector(document);
    collector.OfClass(typeof(FamilySymbol)).OfCategory(BuiltInCategory.OST_LightingFixtures);
    FamilySymbol symbol = collector.FirstElement() as FamilySymbol;

    // The only way to get a Face to use with this NewFamilyInstance overload
    // is from Element.Geometry with ComputeReferences turned on
    Face face = null;
    Options geomOptions = new Options();
    geomOptions.ComputeReferences = true;
    GeometryElement wallGeom = wall.get_Geometry(geomOptions);
    foreach (GeometryObject geomObj in wallGeom)
    {
        Solid geomSolid = geomObj as Solid;
        if (null != geomSolid)
        {
            foreach (Face geomFace in geomSolid.Faces)
            {
                face = geomFace;
                break;
            }
            break;
        }
    }

    // Get the center of the wall
    BoundingBoxUV bboxUV = face.GetBoundingBox();
    UV center = (bboxUV.Max + bboxUV.Min) / 2.0;
    XYZ location = face.Evaluate(center);
    XYZ normal = face.ComputeNormal(center);
    XYZ refDir = normal.CrossProduct(XYZ.BasisZ);

    FamilyInstance instance = document.Create.NewFamilyInstance(face, location, refDir, symbol);
}
CopyVB.NET
Private Sub CreateLightFixtureOnWall(document As Autodesk.Revit.DB.Document, wall As Wall)
    Dim collector As New FilteredElementCollector(document)
    collector.OfClass(GetType(FamilySymbol)).OfCategory(BuiltInCategory.OST_LightingFixtures)
    Dim symbol As FamilySymbol = TryCast(collector.FirstElement(), FamilySymbol)

    ' The only way to get a Face to use with this NewFamilyInstance overload
    ' is from Element.Geometry with ComputeReferences turned on
    Dim face As Face = Nothing
    Dim geomOptions As New Options()
    geomOptions.ComputeReferences = True
    Dim wallGeom As GeometryElement = wall.Geometry(geomOptions)
    For Each geomObj As GeometryObject In wallGeom
        Dim geomSolid As Solid = TryCast(geomObj, Solid)
        If geomSolid IsNot Nothing Then
            For Each geomFace As Face In geomSolid.Faces
                face = geomFace
                Exit For
            Next
            Exit For
        End If
    Next

    ' Get the center of the wall
    Dim bboxUV As BoundingBoxUV = face.GetBoundingBox()
    Dim center As UV = (bboxUV.Max + bboxUV.Min) / 2.0
    Dim location As XYZ = face.Evaluate(center)
    Dim normal As XYZ = face.ComputeNormal(center)
    Dim refDir As XYZ = normal.CrossProduct(XYZ.BasisZ)

    Dim instance As FamilyInstance = document.Create.NewFamilyInstance(face, location, refDir, symbol)
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when a non-optional argument was null.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the function cannot get the Reference from the face, or, when the Family cannot be placed as line-based on an input face reference, because its FamilyPlacementType is not WorkPlaneBased
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | Thrown when reference direction is parallel to face normal at insertion point.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when Revit is unable to place the family instance.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if The symbol is not active.

See Also

ItemFactoryBase Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method (Reference, XYZ, XYZ, FamilySymbol)

[image]

Revit 2024 API
ItemFactoryBase..::..NewFamilyInstance Method (Reference, XYZ, XYZ, FamilySymbol)
ItemFactoryBase Class Example See Also Send Feedback
Inserts a new instance of a family onto a face referenced by the input Reference instance, using a location, reference direction, and a type/symbol.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyInstance NewFamilyInstance(
    Reference reference,
    XYZ location,
    XYZ referenceDirection,
    FamilySymbol symbol
)
Visual Basic
Public Function NewFamilyInstance ( _
    reference As Reference, _
    location As XYZ, _
    referenceDirection As XYZ, _
    symbol As FamilySymbol _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    Reference^ reference,
    XYZ^ location,
    XYZ^ referenceDirection,
    FamilySymbol^ symbol
)

Parameters

reference
Type: Autodesk.Revit.DB..::..Reference
A reference to a face.
location
Type: Autodesk.Revit.DB..::..XYZ
Point on the face where the instance is to be placed.
referenceDirection
Type: Autodesk.Revit.DB..::..XYZ
A vector that defines the direction of the family instance. Note that this direction defines the rotation of the instance on the face, and thus cannot be parallel to the face normal.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted. Note that this symbol must represent a family whose FamilyPlacementType is WorkPlaneBased.

Return Value

An instance of the new object if creation was successful, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

Use this method to insert one family instance on a face of another element, using a point on the face and a vector to define the position and direction of the new symbol.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

The host object must support insertion of instances, otherwise this method will fail. If the instances fails to be created an exception may be thrown.

Some Families, such as Beams, have more than one endpoint and are inserted in the same manner as single point instances. Once inserted, these linear family instances can have their endpoints changed by using the instance's Element.Location property.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call.

Examples

CopyC#
void CreateNurseCallDomeOnWall(Autodesk.Revit.DB.Document document, Wall wall)
{
    FilteredElementCollector collector = new FilteredElementCollector(document);
    collector.OfClass(typeof(FamilySymbol)).OfCategory(BuiltInCategory.OST_NurseCallDevices);

    FamilySymbol symbol = collector.FirstElement() as FamilySymbol;

    // Get interior face of wall
    IList<Reference> sideFaces = HostObjectUtils.GetSideFaces(wall, ShellLayerType.Interior);
    Reference interiorFaceRef = sideFaces[0];

    XYZ location = new XYZ(4, 2, 8);
    XYZ refDir = new XYZ(0, 0, 1);

    FamilyInstance instance = document.Create.NewFamilyInstance(interiorFaceRef, location, refDir, symbol);
}
CopyVB.NET
Private Sub CreateNurseCallDomeOnWall(document As Autodesk.Revit.DB.Document, wall As Wall)
    Dim collector As New FilteredElementCollector(document)
    collector.OfClass(GetType(FamilySymbol)).OfCategory(BuiltInCategory.OST_NurseCallDevices)

    Dim symbol As FamilySymbol = TryCast(collector.FirstElement(), FamilySymbol)

    ' Get interior face of wall
    Dim sideFaces As IList(Of Reference) = HostObjectUtils.GetSideFaces(wall, ShellLayerType.Interior)
    Dim interiorFaceRef As Reference = sideFaces(0)

    Dim location As New XYZ(4, 2, 8)
    Dim refDir As New XYZ(0, 0, 1)

    Dim instance As FamilyInstance = document.Create.NewFamilyInstance(interiorFaceRef, location, refDir, symbol)
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when a non-optional argument was null.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the function cannot get the face from the reference, or, when the Family cannot be placed as line-based on an input face reference, because its FamilyPlacementType is not WorkPlaneBased
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | Thrown when reference direction is parallel to face normal at insertion point.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when Revit is unable to place the family instance.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if The symbol is not active.

See Also

ItemFactoryBase Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method (XYZ, FamilySymbol, Element, StructuralType)

[image]

Revit 2024 API
ItemFactoryBase..::..NewFamilyInstance Method (XYZ, FamilySymbol, Element, StructuralType)
ItemFactoryBase Class Example See Also Send Feedback
Inserts a new instance of a family into the document, using a location, type/symbol, and the host element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyInstance NewFamilyInstance(
    XYZ location,
    FamilySymbol symbol,
    Element host,
    StructuralType structuralType
)
Visual Basic
Public Function NewFamilyInstance ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    host As Element, _
    structuralType As StructuralType _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    XYZ^ location,
    FamilySymbol^ symbol,
    Element^ host,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.DB..::..XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
host
Type: Autodesk.Revit.DB..::..Element
The object into which the FamilyInstance is to be inserted, often known as the host.
structuralType
Type: Autodesk.Revit.DB.Structure..::..StructuralType
If structural then specify the type of the component.

Return Value

If creation was successful then an instance to the new object is returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

This method is used to insert one family instance into another element, such as inserting a window into a wall. If the instance fails to be created an exception may be thrown.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

The host object must be one that supports insertion of instances otherwise this method will fail.

Some Families, such as Beams, have more than one endpoint and are inserted in the same manner as single point instances. Once inserted these linear family instances can have their endpoints changed by using the instance's Element.Location property.

Note: ForbiddenForDynamicUpdateException might be thrown during a dynamic update if the inserted instance establishes a mutual dependency with another structure.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call.

Examples

CopyC#
Wall CreateWallWithWindows(Autodesk.Revit.DB.Document document, Level level)
{
    // Create a new wall
    // Build a location line for the wall creation
    XYZ start = new XYZ(0, 0, 0);
    XYZ end = new XYZ(10, 10, 0);
    Line wallLine = Line.CreateBound(start, end);

    // Create a wall using the location line
    Wall newWall = Wall.Create(document, wallLine, level.Id, true);

    // Find a Window type for the new windows
    FilteredElementCollector winCollector = new FilteredElementCollector(document);
    IList<Element> windowTypes = winCollector.OfCategory(BuiltInCategory.OST_Windows).WhereElementIsElementType().ToElements();
    FamilySymbol winType = windowTypes.First() as FamilySymbol;
    // put 3 windows in the wall
    double x = 2, y = 2, z = 2;
    for (int i = 0; i < 3; i++)
    {
        XYZ location = new XYZ(x, y, z);
        FamilyInstance instance = document.Create.NewFamilyInstance(location, winType, newWall, StructuralType.NonStructural);
        x += 3;
        y += 3;
    }

    return newWall;
}
CopyVB.NET
Private Function CreateWallWithWindows(document As Autodesk.Revit.DB.Document, level As Level) As Wall
    ' Create a new wall
    ' Build a location line for the wall creation
    Dim start As New XYZ(0, 0, 0)
    Dim [end] As New XYZ(10, 10, 0)
    Dim wallLine As Line = Line.CreateBound(start, [end])

    ' Create a wall using the location line
    Dim newWall As Wall = Wall.Create(document, wallLine, level.Id, True)

    ' Find a Window type for the new windows
    Dim winCollector As New FilteredElementCollector(document)
    Dim windowTypes As IList(Of Element) = winCollector.OfCategory(BuiltInCategory.OST_Windows).WhereElementIsElementType().ToElements()
    Dim winType As FamilySymbol = TryCast(windowTypes.First(), FamilySymbol)
    ' put 3 windows in the wall
    Dim x As Double = 2, y As Double = 2, z As Double = 2
    For i As Integer = 0 To 2
        Dim location As New XYZ(x, y, z)
        Dim instance As FamilyInstance = document.Create.NewFamilyInstance(location, winType, newWall, StructuralType.NonStructural)
        x += 3
        y += 3
    Next

    Return newWall
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if The symbol is not active.

See Also

ItemFactoryBase Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method (XYZ, FamilySymbol, Level, StructuralType)

[image]

Revit 2024 API
ItemFactoryBase..::..NewFamilyInstance Method (XYZ, FamilySymbol, Level, StructuralType)
ItemFactoryBase Class See Also Send Feedback
Inserts a new instance of a family into the document, using a location, type/symbol, and the level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyInstance NewFamilyInstance(
    XYZ location,
    FamilySymbol symbol,
    Level level,
    StructuralType structuralType
)
Visual Basic
Public Function NewFamilyInstance ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    level As Level, _
    structuralType As StructuralType _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    XYZ^ location,
    FamilySymbol^ symbol,
    Level^ level,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.DB..::..XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
level
Type: Autodesk.Revit.DB..::..Level
The level onto which the FamilyInstance is to be placed.
structuralType
Type: Autodesk.Revit.DB.Structure..::..StructuralType
If structural then specify the type of the component.

Return Value

If creation was successful then an instance to the new object is returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

This method is used to place a family instance onto a level. If the instance fails to be created an exception may be thrown.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

Some Families, such as Beams, have more than one endpoint and are inserted in the same manner as single point instances. Once inserted these linear family instances can have their endpoints changed by using the instance's Element.Location property.

Note: ForbiddenForDynamicUpdateException might be thrown during a dynamic update if the inserted instance establishes a mutual dependency with another structure.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the family symbol does not exist in the given document.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the level does not exist in the given document.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if The symbol is not active.

See Also

ItemFactoryBase Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method (XYZ, FamilySymbol, XYZ, Element, StructuralType)

[image]

Revit 2024 API
ItemFactoryBase..::..NewFamilyInstance Method (XYZ, FamilySymbol, XYZ, Element, StructuralType)
ItemFactoryBase Class Example See Also Send Feedback
Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a reference direction.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyInstance NewFamilyInstance(
    XYZ location,
    FamilySymbol symbol,
    XYZ referenceDirection,
    Element host,
    StructuralType structuralType
)
Visual Basic
Public Function NewFamilyInstance ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    referenceDirection As XYZ, _
    host As Element, _
    structuralType As StructuralType _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    XYZ^ location,
    FamilySymbol^ symbol,
    XYZ^ referenceDirection,
    Element^ host,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.DB..::..XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
referenceDirection
Type: Autodesk.Revit.DB..::..XYZ
A vector that dictates the direction of certain family instances.
host
Type: Autodesk.Revit.DB..::..Element
A host object into which the instance will be embedded
structuralType
Type: Autodesk.Revit.DB.Structure..::..StructuralType
If structural then specify the type of the component.

Return Value

If creation was successful then an instance to the new object is returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

This method allows you to create FamilyInstance objects that require both a location and direction. If the instance fails to be created an exception may be thrown.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

Some Families, such as Beams, have more than one endpoint and are inserted in the same manner as single point instances. Once inserted these linear family instances can have their endpoints changed by using the instance's Element.Location property.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call.

Examples

CopyC#
// Get a floor to place the beds
 FilteredElementCollector collector = new FilteredElementCollector(document);
 Floor floor = collector.OfClass(typeof(Floor)).FirstElement() as Floor;
 if (floor != null)
 {
     // Find a Bed-Box family
     Family family = null;
     FilteredElementCollector famCollector = new FilteredElementCollector(document);
     famCollector.OfClass(typeof(Family));
     ICollection<Element> collection = famCollector.ToElements();
     foreach (Element element in collection)
     {

         if (element.Name.CompareTo("Bed-Box") == 0)
         {
             family = element as Family;
             break;
         }
     }

     if (family != null)
     {
         // Enumerate the beds in the Bed-Box family
         FilteredElementCollector fsCollector = new FilteredElementCollector(document);
         ICollection<Element> fsCollection = fsCollector.WherePasses(new FamilySymbolFilter(family.Id)).ToElements();
         IEnumerator<Element> symbolItor = fsCollection.GetEnumerator();

         int x = 0, y = 0;
         int i = 0;
         while (symbolItor.MoveNext())
         {
             FamilySymbol symbol = symbolItor.Current as FamilySymbol;
             XYZ location = new XYZ(x, y, 0);
             XYZ direction = new XYZ();
             switch (i % 3)
             {
                 case 0:
                     direction = new XYZ(1, 1, 0);
                     break;
                 case 1:
                     direction = new XYZ(0, 1, 1);
                     break;
                 case 2:
                     direction = new XYZ(1, 0, 1);
                     break;
             }
             FamilyInstance instance = document.Create.NewFamilyInstance(location, symbol, direction, floor, StructuralType.NonStructural);
             x += 10;
             i++;
         }
     }
 }
CopyVB.NET
' Get a floor to place the beds
Dim collector As New FilteredElementCollector(document)
Dim floor As Floor = TryCast(collector.OfClass(GetType(Floor)).FirstElement(), Floor)
If floor IsNot Nothing Then
    ' Find a Bed-Box family
    Dim family As Family = Nothing
    Dim famCollector As New FilteredElementCollector(document)
    famCollector.OfClass(GetType(Family))
    Dim collection As ICollection(Of Element) = famCollector.ToElements()
    For Each element As Element In collection

        If element.Name.CompareTo("Bed-Box") = 0 Then
            family = TryCast(element, Family)
            Exit For
        End If
    Next

    If family IsNot Nothing Then
        ' Enumerate the beds in the Bed-Box family
        Dim fsCollector As New FilteredElementCollector(document)
        Dim fsCollection As ICollection(Of Element) = fsCollector.WherePasses(New FamilySymbolFilter(family.Id)).ToElements()
        Dim symbolItor As IEnumerator(Of Element) = fsCollection.GetEnumerator()

        Dim x As Integer = 0, y As Integer = 0
        Dim i As Integer = 0
        While symbolItor.MoveNext()
            Dim symbol As FamilySymbol = TryCast(symbolItor.Current, FamilySymbol)
            Dim location As New XYZ(x, y, 0)
            Dim direction As New XYZ()
            Select Case i Mod 3
                Case 0
                    direction = New XYZ(1, 1, 0)
                    Exit Select
                Case 1
                    direction = New XYZ(0, 1, 1)
                    Exit Select
                Case 2
                    direction = New XYZ(1, 0, 1)
                    Exit Select
            End Select
            Dim instance As FamilyInstance = document.Create.NewFamilyInstance(location, symbol, direction, floor, StructuralType.NonStructural)
            x += 10
            i += 1
        End While
    End If
End If

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if The symbol is not active.

See Also

ItemFactoryBase Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstances2 Method

[image]

Revit 2024 API
ItemFactoryBase..::..NewFamilyInstances2 Method
ItemFactoryBase Class Example See Also Send Feedback
Creates Family instances within the document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ICollection<ElementId> NewFamilyInstances2(
    List<FamilyInstanceCreationData> dataList
)
Visual Basic
Public Function NewFamilyInstances2 ( _
    dataList As List(Of FamilyInstanceCreationData) _
) As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ NewFamilyInstances2(
    List<FamilyInstanceCreationData^>^ dataList
)

Parameters

dataList
Type: System.Collections.Generic..::..List<(Of <(<' FamilyInstanceCreationData >)>)>
A list of FamilyInstanceCreationData which wraps the creation arguments of the families to be created.

Return Value

If the creation is successful, a set of ElementIds which contains the Family instances should be returned, otherwise the exception will be thrown.

Remarks

Note: ForbiddenForDynamicUpdateException might be thrown during a dynamic update if the inserted instance establishes a mutual dependency with another structure.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call.

Examples

CopyC#
ICollection<ElementId> BatchCreateColumns(Autodesk.Revit.DB.Document document, Level level)
{
    List<FamilyInstanceCreationData> fiCreationDatas = new List<FamilyInstanceCreationData>();

    //ElementSet elementSet = null;
    ICollection<ElementId> elementSet = null;

    //Try to get a FamilySymbol
    FamilySymbol familySymbol = null;
    FilteredElementCollector collector = new FilteredElementCollector(document);
    ICollection<Element> collection = collector.OfClass(typeof(FamilySymbol)).ToElements();
    foreach (Element e in collection)
    {
        familySymbol = e as FamilySymbol;
        if (null != familySymbol.Category)
        {
            if ("Structural Columns" == familySymbol.Category.Name)
            {
                break;
            }
        }
    }

    if (null != familySymbol)
    {
        //Create 10 FamilyInstanceCreationData items for batch creation
        for (int i = 1; i < 11; i++)
        {
            XYZ location = new XYZ(i * 10, 100, 0);
            FamilyInstanceCreationData fiCreationData =
                new FamilyInstanceCreationData(location, familySymbol, level,  StructuralType.Column);

            if (null != fiCreationData)
            {
                fiCreationDatas.Add(fiCreationData);
            }
        }

        if (fiCreationDatas.Count > 0)
        {
            // Create Columns
            elementSet = document.Create.NewFamilyInstances2(fiCreationDatas);
        }
        else
        {
            throw new Exception("Batch creation failed.");
        }
    }
    else
    {
        throw new Exception("No column types found.");
    }

    return elementSet;
}
CopyVB.NET
Private Function BatchCreateColumns(document As Autodesk.Revit.DB.Document, level As Level) As ICollection(Of ElementId)
    Dim fiCreationDatas As New List(Of FamilyInstanceCreationData)()

    'ElementSet elementSet = null;
    Dim elementSet As ICollection(Of ElementId) = Nothing

    'Try to get a FamilySymbol
    Dim familySymbol As FamilySymbol = Nothing
    Dim collector As New FilteredElementCollector(document)
    Dim collection As ICollection(Of Element) = collector.OfClass(GetType(FamilySymbol)).ToElements()
    For Each e As Element In collection
        familySymbol = TryCast(e, FamilySymbol)
        If familySymbol.Category IsNot Nothing Then
            If "Structural Columns" = familySymbol.Category.Name Then
                Exit For
            End If
        End If
    Next

    If familySymbol IsNot Nothing Then
        'Create 10 FamilyInstanceCreationData items for batch creation
        For i As Integer = 1 To 10
            Dim location As New XYZ(i * 10, 100, 0)
            Dim fiCreationData As New FamilyInstanceCreationData(location, familySymbol, level, StructuralType.Column)

            If fiCreationData IsNot Nothing Then
                fiCreationDatas.Add(fiCreationData)
            End If
        Next

        If fiCreationDatas.Count > 0 Then
            ' Create Columns
            elementSet = document.Create.NewFamilyInstances2(fiCreationDatas)
        Else
            Throw New Exception("Batch creation failed.")
        End If
    Else
        Throw New Exception("No column types found.")
    End If

    Return elementSet
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | If FamilyInstanceCreationData's 'curve' or 'symbol' member is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | If regeneration fails at the end of the batch creation.

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewGroup Method

[image]

Revit 2024 API
ItemFactoryBase..::..NewGroup Method
ItemFactoryBase Class Example See Also Send Feedback
Creates a new type of group.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Group NewGroup(
    ICollection<ElementId> elementIds
)
Visual Basic
Public Function NewGroup ( _
    elementIds As ICollection(Of ElementId) _
) As Group
Visual C++
public:
Group^ NewGroup(
    ICollection<ElementId^>^ elementIds
)

Parameters

elementIds
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
A set of elements which will be made into the new group.

Return Value

A new instance of a group containing the elements specified.

Remarks

  • The new group may contain more members than just the set input to this method. Elements which are closely connected with the inputs (such as sketch and sketch plane) will also be added to the group.
  • Initially the group will have a generic name, such as Group 1. This can be changed by changing the name of the group type as follows: newGroup.GroupType.Name = newName.
  • If a newly-created element is being added to a group, calling document.Regenerate() may be needed to avoid a warning visible in the UI that the group has changed outside group edit mode.

Examples

CopyC#
Group group = null;
UIDocument uidoc = new UIDocument(document);
ICollection<ElementId> selectedIds = uidoc.Selection.GetElementIds();

if (selectedIds.Count > 0)
{
    // Group all selected elements
    group = document.Create.NewGroup(selectedIds);

}
CopyVB.NET
Dim group As Group = Nothing
Dim uidoc As New UIDocument(document)
Dim selectedIds As ICollection(Of ElementId) = uidoc.Selection.GetElementIds()

If selectedIds.Count > 0 Then
    ' Group all selected elements

    group = document.Create.NewGroup(selectedIds)
Else

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewModelCurve Method

[image]

Revit 2024 API
ItemFactoryBase..::..NewModelCurve Method
ItemFactoryBase Class Example See Also Send Feedback
Creates a new model line element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ModelCurve NewModelCurve(
    Curve geometryCurve,
    SketchPlane sketchPlane
)
Visual Basic
Public Function NewModelCurve ( _
    geometryCurve As Curve, _
    sketchPlane As SketchPlane _
) As ModelCurve
Visual C++
public:
ModelCurve^ NewModelCurve(
    Curve^ geometryCurve,
    SketchPlane^ sketchPlane
)

Parameters

geometryCurve
Type: Autodesk.Revit.DB..::..Curve
The internal geometry curve for model line.
sketchPlane
Type: Autodesk.Revit.DB..::..SketchPlane
The sketch plane this new model line resides in.

Return Value

If successful a new model line element. Otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

Different type of model curve element will be returned according to the type of geometry curve.

Examples

CopyC#
// get handle to application from document
Autodesk.Revit.ApplicationServices.Application application = document.Application;

// Create a geometry line in Revit application
XYZ startPoint = new XYZ(0, 0, 0);
XYZ endPoint = new XYZ(10, 10, 0);
Line geomLine = Line.CreateBound(startPoint, endPoint);

// Create a geometry arc in Revit application
XYZ end0 = new XYZ(1, 0, 0);
XYZ end1 = new XYZ(10, 10, 10);
XYZ pointOnCurve = new XYZ(10, 0, 0);
Arc geomArc = Arc.Create(end0, end1, pointOnCurve);

// Create a geometry plane in Revit application
XYZ origin = new XYZ(0, 0, 0);
XYZ normal = new XYZ(1, 1, 0);
Plane geomPlane = Plane.CreateByNormalAndOrigin(normal, origin);

// Create a sketch plane in current document
SketchPlane sketch = SketchPlane.Create(document, geomPlane);

// Create a ModelLine element using the created geometry line and sketch plane
ModelLine line = document.Create.NewModelCurve(geomLine, sketch) as ModelLine;

// Create a ModelArc element using the created geometry arc and sketch plane
ModelArc arc = document.Create.NewModelCurve(geomArc, sketch) as ModelArc;
CopyVB.NET
   ' get handle to application from document
   Dim application As Autodesk.Revit.ApplicationServices.Application = document.Application

   ' Create a geometry line in Revit application
   Dim startPoint As New XYZ(0, 0, 0)
   Dim endPoint As New XYZ(10, 10, 0)
   Dim geomLine As Line = Line.CreateBound(startPoint, endPoint)

   ' Create a geometry arc in Revit application
   Dim end0 As New XYZ(1, 0, 0)
   Dim end1 As New XYZ(10, 10, 10)
   Dim pointOnCurve As New XYZ(10, 0, 0)
   Dim geomArc As Arc = Arc.Create(end0, end1, pointOnCurve)

   ' Create a geometry plane in Revit application
   Dim origin As New XYZ(0, 0, 0)
   Dim normal As New XYZ(1, 1, 0)
Dim geomPlane As Plane = Plane.CreateByNormalAndOrigin(normal, origin)

   ' Create a sketch plane in current document
   Dim sketch As SketchPlane = SketchPlane.Create(document, geomPlane)

   ' Create a ModelLine element using the created geometry line and sketch plane
   Dim line__1 As ModelLine = TryCast(document.Create.NewModelCurve(geomLine, sketch), ModelLine)

   ' Create a ModelArc element using the created geometry arc and sketch plane
   Dim arc__2 As ModelArc = TryCast(document.Create.NewModelCurve(geomArc, sketch), ModelArc)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when curve is not in the plane

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewModelCurveArray Method

[image]

Revit 2024 API
ItemFactoryBase..::..NewModelCurveArray Method
ItemFactoryBase Class See Also Send Feedback
Creates an array of new model line elements.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ModelCurveArray NewModelCurveArray(
    CurveArray geometryCurveArray,
    SketchPlane sketchPlane
)
Visual Basic
Public Function NewModelCurveArray ( _
    geometryCurveArray As CurveArray, _
    sketchPlane As SketchPlane _
) As ModelCurveArray
Visual C++
public:
ModelCurveArray^ NewModelCurveArray(
    CurveArray^ geometryCurveArray,
    SketchPlane^ sketchPlane
)

Parameters

geometryCurveArray
Type: Autodesk.Revit.DB..::..CurveArray
An array containing the internal geometry curves for model lines.
sketchPlane
Type: Autodesk.Revit.DB..::..SketchPlane

Return Value

If successful an array of new model line elements. Otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when curve is not in the plane

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewReferencePlane Method

[image]

Revit 2024 API
ItemFactoryBase..::..NewReferencePlane Method
ItemFactoryBase Class Example See Also Send Feedback
Creates a new instance of ReferencePlane.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ReferencePlane NewReferencePlane(
    XYZ bubbleEnd,
    XYZ freeEnd,
    XYZ cutVec,
    View pView
)
Visual Basic
Public Function NewReferencePlane ( _
    bubbleEnd As XYZ, _
    freeEnd As XYZ, _
    cutVec As XYZ, _
    pView As View _
) As ReferencePlane
Visual C++
public:
ReferencePlane^ NewReferencePlane(
    XYZ^ bubbleEnd,
    XYZ^ freeEnd,
    XYZ^ cutVec,
    View^ pView
)

Parameters

bubbleEnd
Type: Autodesk.Revit.DB..::..XYZ
The bubble end applied to reference plane.
freeEnd
Type: Autodesk.Revit.DB..::..XYZ
The free end applied to reference plane.
cutVec
Type: Autodesk.Revit.DB..::..XYZ
The cut vector apply to reference plane, should perpendicular to the vector (bubbleEnd-freeEnd).
pView
Type: Autodesk.Revit.DB..::..View
The specific view apply to the Reference plane.

Return Value

The newly created reference plane.

Remarks

The specific view is applied to the Reference plane only for certain view types: Legend DraftingView DrawingSheet

Examples

CopyC#
// Define data for reference plane creation
XYZ bubbleEnd = new XYZ(1, 0, 0);   // bubble end applied to reference plane
XYZ freeEnd = new XYZ(-5, 0, 0);    // free end applied to reference plane
// Cut vector should be perpendicular to bubbleEnd-freeEnd vector
XYZ cutVec = new XYZ(0, 0, 1);  // cut vector applied to reference plane

// Create the reference plane, applying the active view
ReferencePlane refPlane = document.Create.NewReferencePlane(bubbleEnd, freeEnd, cutVec, document.ActiveView);
CopyVB.NET
' Define data for reference plane creation
Dim bubbleEnd As New XYZ(1, 0, 0)
' bubble end applied to reference plane
Dim freeEnd As New XYZ(-5, 0, 0)
' free end applied to reference plane
' Cut vector should be perpendicular to bubbleEnd-freeEnd vector
Dim cutVec As New XYZ(0, 0, 1)
' cut vector applied to reference plane
' Create the reference plane, applying the active view
Dim refPlane As ReferencePlane = document.Create.NewReferencePlane(bubbleEnd, freeEnd, cutVec, document.ActiveView)

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewReferencePlane2 Method

[image]

Revit 2024 API
ItemFactoryBase..::..NewReferencePlane2 Method
ItemFactoryBase Class Example See Also Send Feedback
Creates a new instance of ReferencePlane.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ReferencePlane NewReferencePlane2(
    XYZ bubbleEnd,
    XYZ freeEnd,
    XYZ thirdPnt,
    View pView
)
Visual Basic
Public Function NewReferencePlane2 ( _
    bubbleEnd As XYZ, _
    freeEnd As XYZ, _
    thirdPnt As XYZ, _
    pView As View _
) As ReferencePlane
Visual C++
public:
ReferencePlane^ NewReferencePlane2(
    XYZ^ bubbleEnd,
    XYZ^ freeEnd,
    XYZ^ thirdPnt,
    View^ pView
)

Parameters

bubbleEnd
Type: Autodesk.Revit.DB..::..XYZ
The bubble end applied to reference plane.
freeEnd
Type: Autodesk.Revit.DB..::..XYZ
The free end applied to reference plane.
thirdPnt
Type: Autodesk.Revit.DB..::..XYZ
A third point needed to define the reference plane.
pView
Type: Autodesk.Revit.DB..::..View
The specific view apply to the Reference plane.

Return Value

The newly created reference plane.

Remarks

The specific view is applied to the Reference plane only for certain view types: Legend DraftingView DrawingSheet

Examples

CopyC#
// Build now data before creation
XYZ bubbleEnd = new XYZ(1, 0, 0);   // bubble end applied to reference plane
XYZ freeEnd = new XYZ(-5, 0, 0);    // free end applied to reference plane
// Third point should not be on the bubbleEnd-freeEnd line
XYZ thirdPnt = new XYZ(0, 15, 0);   // 3rd point to define reference plane

// Create the reference plane in X-Y, applying the active view
ReferencePlane refPlane = document.Create.NewReferencePlane2(bubbleEnd, freeEnd, thirdPnt, document.ActiveView);
CopyVB.NET
' Build now data before creation
Dim bubbleEnd As New XYZ(1, 0, 0)
' bubble end applied to reference plane
Dim freeEnd As New XYZ(-5, 0, 0)
' free end applied to reference plane
' Third point should not be on the bubbleEnd-freeEnd line
Dim thirdPnt As New XYZ(0, 15, 0)
' 3rd point to define reference plane
' Create the reference plane in X-Y, applying the active view
Dim refPlane As ReferencePlane = document.Create.NewReferencePlane2(bubbleEnd, freeEnd, thirdPnt, document.ActiveView)

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


PlaceGroup Method

[image]

Revit 2024 API
ItemFactoryBase..::..PlaceGroup Method
ItemFactoryBase Class See Also Send Feedback
Place an instance of a Model Group into the Autodesk Revit document, using a location and a group type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Group PlaceGroup(
    XYZ location,
    GroupType groupType
)
Visual Basic
Public Function PlaceGroup ( _
    location As XYZ, _
    groupType As GroupType _
) As Group
Visual C++
public:
Group^ PlaceGroup(
    XYZ^ location,
    GroupType^ groupType
)

Parameters

location
Type: Autodesk.Revit.DB..::..XYZ
The physical location where the group is to be placed.
groupType
Type: Autodesk.Revit.DB..::..GroupType
A GroupType object that represents the type of group that is to be placed.

Return Value

If creation was successful then an instance to the new group is returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

This method is used to place a new instance of an existing group type within the document. The group's origin will placed at the point specified by the location. All group types within the document can be found by iterating over the document and looking for elements of type GroupType.

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


Autodesk.Revit.DB Namespace

[image]

Revit 2024 API
Autodesk.Revit.DB Namespace
Send Feedback

Classes

Class | Description
Public class ACADExportOptions
The base class for options used to export DWG and DXF format files.
Public class AdaptiveComponentFamilyUtils
An interface for Adaptive Component Instances.
Public class AdaptiveComponentInstanceUtils
An interface for Adaptive Component Instances.
Public class AddInId
Identifies an AddIn registered with Revit
Public class AlphanumericRevisionSettings
Contains settings that apply to Revisions with the Alphanumeric RevisionNumberType.
Public class AngularDimension
An object that represents an Angular Dimension within the Revit project.
Public class AnnotationSymbol
This object represents a symbol of the Generic Annotation.
Public class AnnotationSymbolType
An object that represents an annotation style.
Public class APIObject
Supports all objects in the Autodesk Revit API hierarchy.
Public class AppearanceAssetElement
An element that contains a rendering asset used as a portion of a material definition.
Public class Arc
A circular arc.
Public class Area
Provides access to the area topology in Autodesk Revit.
Public class AreaFilter
A filter used to match areas.
Public class AreaScheme
The area scheme associated with a particular area plan.
Public class AreaTag
Provides access to the area topology in Autodesk Revit.
Public class AreaTagFilter
A filter used to match area tags.
Public class AreaTagType
An object that represents an Area Tag style.
Public class AreaVolumeSettings
This class provides access to settings related to volume and area computations.
Public class AssemblyCodeTable
AssemblyCodeTable represents the collection of ClassificationEntries for a document.
Public class AssemblyDifference
Class that describes difference between two assemblies.
Public class AssemblyDifferenceConfiguration
The two assemblies being compared have different spatial configuration
Public class AssemblyDifferenceMemberCount
The two assemblies being compared have different number of members
Public class AssemblyDifferenceMemberDifference
The two assemblies being compared have different members
Public class AssemblyDifferenceNamingCategory
The two assemblies being compared have different naming categories
Public class AssemblyDifferenceNone
The two assemblies being compared are identical
Public class AssemblyInstance
Combines multiple elements for tagging, filtering, scheduling and creating isolated assembly views.
Public class AssemblyMemberDifference
Class that describes difference between two assembly members
Public class AssemblyMemberDifferentCategory
The two assembly members being compared have different category
Public class AssemblyMemberDifferentGeometry
The two assembly members being compared have different geometry
Public class AssemblyMemberDifferentParameters
The two assembly members being compared have different parameters
Public class AssemblyMemberDifferentType
The two assembly members being compared have different type
Public class AssemblyType
Type for construction assembly elements.
Public class AssemblyViewUtils
Utilities that provide capabilities related to assembly view creation and validation.
Public class AXMImportOptions
The import options used to import AXM format files.
Public class BackgroundSettings
Represents the rendering background settings.
Public class BarTypeDiameterOptions
This class stores the diameter information from the RebarBarType.
Public class BaseArray
An abstract base class that represents an array within the Revit project.
Public class BaseExportOptions
The base class for options used to export DWG, DXF and DGN format files.
Public class BaseImportOptions
A base class containing import options used during import of several formats.
Public class BasePoint
A class representing the Project Base Point and Survey Point. Each Revit project contains one project base point and one survey point. The project base point represents the origin of the project coordinate system. The survey point represents the origin of the shared coordinate system.
Public class BasicFileInfo
Encapsulates basic information about a Revit file, including worksharing status, Revit version, username and central path.
Public class BeamSystem
An object that represents a BeamSystem within the Autodesk Revit project.
Public class BeamSystemType
An object that specifies the type of a beam system in Autodesk Revit.
Public class BIMExportOptions
The base class for options used to export using ATF.
Public class Binding
Binding objects are used to take a parameter definition and bind it to one or more categories.
Public class BindingMap
The parameters BindingMap contains all the parameter bindings that exist in the Autodesk Revit project.
Public class Blend
A blend solid or void form.
Public class BooleanOperationsUtils
These utilities are applicable for the geometry created by GeometryCreationUtilities and the geometry of Revit model.
Public class BoundarySegment
An object that represents a segment of an area boundary.
Public class BoundaryValidation
Curve loop validators.
Public class BoundingBoxContainsPointFilter
A filter used to match elements with a bounding box that contains the given point.
Public class BoundingBoxIntersectsFilter
A filter used to match elements with a bounding box that intersects the given Outline.
Public class BoundingBoxIsInsideFilter
A filter used to match elements with a bounding box that is contained by the given Outline.
Public class BoundingBoxUV
A two-dimensional rectangle, parallel to the coordinate axes.
Public class BoundingBoxXYZ
A three-dimensional rectangular box at an arbitrary location and orientation within the Revit model.
Public class BRepBuilder
A class that allows direct construction of geometry objects (solids, open shells, etc.).
Public class BRepBuilderEdgeGeometry
An abstract class used by BRepBuilder to represent the geometry of an edge. Specific edge-geometry representations are represented by subclasses.
Public class BRepBuilderGeometryId
This class is used by the BRepBuilder class to identify objects it creates (faces, edges, etc.).
Public class BRepBuilderPersistentIds
This class stores a map from ExternalGeometryIds to BRepBuilderGeometryIds.
Public class BRepBuilderSurfaceGeometry
An abstract class used by BRepBuilder to represent the geometry of a surface. Specific surface-geometry representations are represented by subclasses.
Public class BrowserOrganization
The organization settings for grouping, sorting, and filtering of items in the project browser.
Public class BuildingPadType
Represents a specific type of Building Pad.
Public class BuiltInFailures
Provides a container of all Revit built-in FailureDefinitionId instances.
Public class BuiltInFailures..::..AlignmentFailures
Failures related to alignment elements and annotations.
Public class BuiltInFailures..::..AnalyticalModelFailures
Failures about AnalyticalModel.
Public class BuiltInFailures..::..ArrayFailures
Failures about Arrays.
Public class BuiltInFailures..::..AssemblyFailures
Failures related to Assemblies.
Public class BuiltInFailures..::..AutoJoinFailures
Failures about AutoJoin.
Public class BuiltInFailures..::..AutoRouteFailures
Failures about AutoRoute.
Public class BuiltInFailures..::..BeamFailures
Failures about Beams.
Public class BuiltInFailures..::..BeamSystemFailures
Failures about BeamSystem.
Public class BuiltInFailures..::..BendFailures
Failures about Bends.
Public class BuiltInFailures..::..BlendFailures
Failures about Blend.
Public class BuiltInFailures..::..ColorFillFailures
Failures about ColorFill.
Public class BuiltInFailures..::..ColumnFailures
Failures about Columns.
Public class BuiltInFailures..::..ColumnInsideWallFailures
Failures description ColumnInsideWall
Public class BuiltInFailures..::..ComponentRepeaterFailures
Failures related to component repeaters.
Public class BuiltInFailures..::..ComponentRepeaterSlotFailures
Failures related to component repeater slots.
Public class BuiltInFailures..::..ConnectorFailures
Failures about Connector.
Public class BuiltInFailures..::..ConstraintFailures
Failures about Constraint.
Public class BuiltInFailures..::..ConversionFailures
Failures about conversion of data to a different format.
Public class BuiltInFailures..::..CopyMonitorFailures
Failures about CopyWatch.
Public class BuiltInFailures..::..CopyPasteFailures
Failures about CopyPasteFailures.
Public class BuiltInFailures..::..CreationFailures
Failures about CreationFailures.
Public class BuiltInFailures..::..CurtainGridFamilyFailures
Failures about CurtainGrid Family.
Public class BuiltInFailures..::..CurtainWallFailures
Failures about CurtainWall.
Public class BuiltInFailures..::..CurveByPointFailures
Failures about Curve By Point Element
Public class BuiltInFailures..::..CurveFailures
Failures about Curves and Curve-Driven Elements.
Public class BuiltInFailures..::..CutFailures
Failures about Cut.
Public class BuiltInFailures..::..CutterFailures
Failures about Cutter.
Public class BuiltInFailures..::..CuttingFailures
Failures about Cutting.
Public class BuiltInFailures..::..DatumPlaneFailures
Failures about DatumPlane.
Public class BuiltInFailures..::..DebugTabBindingFailures
Failures related to binding framework demo panel on Ribbon Debug Tab.
Public class BuiltInFailures..::..DecalFailures
Failures about Decal.
Public class BuiltInFailures..::..DesignOptionFailures
Failures about DesignOptionFailures.
Public class BuiltInFailures..::..DetailFailures
Failures about Detail.
Public class BuiltInFailures..::..DimensionFailures
Failures about DimensionFailures.
Public class | BuiltInFailures..::..DirectContext3DFailures
Public class BuiltInFailures..::..DirectShapeFailures
Failure definitions related to DirectShapes.
Public class BuiltInFailures..::..DisplacementElementFailures
Error messages related to the DisplacementElement.
Public class BuiltInFailures..::..DividedPathFailures
Failures related to divided path operations.
Public class BuiltInFailures..::..DividedSurfaceFailures
Failures about DividedSurface.
Public class BuiltInFailures..::..DocumentFailures
Failures about DocumentFailures.
Public class BuiltInFailures..::..DPartFailures
Failures related to parts.
Public class BuiltInFailures..::..DuctFailures
Failures about Duct.
Public class BuiltInFailures..::..EditingFailures
Failures related to editing operations.
Public class BuiltInFailures..::..ElectricalFailures
Failures about Electricity.
Public class BuiltInFailures..::..ElectricityFailures
Failures related to electrical system and circuits.
Public class BuiltInFailures..::..ElementFailures
Failures about Elements.
Public class BuiltInFailures..::..ElementTypeFailures
Failures about ElementTypeFailures.
Public class BuiltInFailures..::..ElevationFailures
Failures about Elevation.
Public class BuiltInFailures..::..EnergyAnalysisFailures
Failures about EnergyAnalysis.
Public class BuiltInFailures..::..EnergyAnalysisUtilitiesDBFailures
Failures about EnergyAnalysisUtilitiesDBFailures.
Public class BuiltInFailures..::..ExportFailures
Failures about ExportFailures.
Public class | BuiltInFailures..::..ExternalResourceReferenceFailures
Public class BuiltInFailures..::..ExtrusionFailures
Failures about Extrusions.
Public class BuiltInFailures..::..FabricAreaFailures
Failures related to fabric area elements.
Public class BuiltInFailures..::..FabricFailures
Failures about Fabric.
Public class BuiltInFailures..::..FabricSheetFailures
Failures related to fabric sheet elements.
Public class BuiltInFailures..::..FaceSplitterFailures
Failures about FaceSplitter.
Public class BuiltInFailures..::..FamilyFailures
Failures related to families.
Public class BuiltInFailures..::..FilledRegionFailures
Failures about FilledRegion.
Public class BuiltInFailures..::..FloorFailures
Failures related to floors and slabs.
Public class BuiltInFailures..::..FluidFailures
Failures about Fluid.
Public class BuiltInFailures..::..ForeignFileFailures
Failures about files saved by applications that were not developed or licensed by Autodesk.
Public class BuiltInFailures..::..FormFailures
Failures about Form.
Public class BuiltInFailures..::..GeneralFailures
Failures about GeneralFailures.
Public class BuiltInFailures..::..GenericFailures
Generic failures that may apply to any Revit Element
Public class BuiltInFailures..::..GenericMEPFailures
Failures applicable to different mechanical, electrical and piping Elements.
Public class BuiltInFailures..::..GeometryFailures
Failures about GeometryFailures.
Public class | BuiltInFailures..::..GlobalParameterFailures
Public class BuiltInFailures..::..GridChainSketchFailures
Failures related to the GridChain sketch.
Public class BuiltInFailures..::..GridFailures
Failures about Grid.
Public class BuiltInFailures..::..GroupFailures
Failures related to groups and their behavior.
Public class BuiltInFailures..::..HostObjFailures
Failures about HostObj.
Public class BuiltInFailures..::..HvacFailures
Failures related to HVAC in MEP.
Public class BuiltInFailures..::..IlluminationFailures
Failures about Illumination.
Public class BuiltInFailures..::..ImageFailures
Failures about Image.
Public class BuiltInFailures..::..ImportExportFailures
Failures about Import and Export.
Public class BuiltInFailures..::..ImportFailures
Failures about ImportFailures.
Public class BuiltInFailures..::..InaccurateFailures
Failures about Inaccurate.
Public class BuiltInFailures..::..InfillFailures
Failures about Infill.
Public class BuiltInFailures..::..InterferenceFailures
Failures about Interference.
Public class BuiltInFailures..::..JoinElementsFailures
Failures about JoinElements.
Public class BuiltInFailures..::..KeyBasedTreeEntryFailures
Failures about KeyBasedTreeEntry.
Public class BuiltInFailures..::..KeyBasedTreeFileFailures
Failures occurred when reading key based tree text file.
Public class | BuiltInFailures..::..KeynoteFailures
Public class BuiltInFailures..::..KeynoteTagFailures
Failures related to keynote tags.
Public class BuiltInFailures..::..LegendFailures
Failures about Legend.
Public class BuiltInFailures..::..LevelAssociationFailures
Failures about Level association of Analytical Node.
Public class BuiltInFailures..::..LevelFailures
Failures about Level.
Public class BuiltInFailures..::..LinkFailures
Failures about LinkFailures.
Public class BuiltInFailures..::..LoadFailures
Failures about Load.
Public class BuiltInFailures..::..LooseDimensionFailures
Failures about LooseDimension.
Public class BuiltInFailures..::..MacroFailures
Failures about module with duplicate name found during reload latest.
Public class BuiltInFailures..::..MassFailures
Failures about Mass.
Public class BuiltInFailures..::..MatchlineFailures
Failures about Matchline.
Public class BuiltInFailures..::..MechanicalFailures
Failures about HVAC.
Public class BuiltInFailures..::..MEPCalculationFailures
Failures about Fluid.
Public class BuiltInFailures..::..MEPFabricationFailures
Failures about MEP fabrication.
Public class BuiltInFailures..::..MEPSupportFailures
Failures about MEP suppor.
Public class BuiltInFailures..::..MirrorFailures
Failures about Mirror.
Public class BuiltInFailures..::..MultiReferenceAnnotationFailures
Failures about MultiReferenceAnnotations.
Public class BuiltInFailures..::..NumberingFailures
Failures related to object numbering operations.
Public class BuiltInFailures..::..OffsetFacesCellLegacyFailures
Failures related to offset faces operations.
Public class BuiltInFailures..::..OpeningFailures
Failures about Opening.
Public class BuiltInFailures..::..OverlapFailures
Failures detected by overlap check.
Public class BuiltInFailures..::..ParameterFailures
Failures related to parameters and parameter operations.
Public class BuiltInFailures..::..PartMakerMethodForMergePartFailures
Failures related to part merge operations.
Public class BuiltInFailures..::..PartMakerMethodForWallFailures
Failures related to parts related to walls.
Public class BuiltInFailures..::..PathFailures
Failures about Path.
Public class BuiltInFailures..::..PathOfTravelFailures
Failures about PathOfTravel.
Public class BuiltInFailures..::..PerformanceFailures
Failures which give hints pointing to situations where performance could be improved.
Public class BuiltInFailures..::..PipingFailures
Failures about Pipes.
Public class BuiltInFailures..::..PlanRegionFailures
Failures about PlanRegion.
Public class BuiltInFailures..::..PointFailures
Failures about Point Element.
Public class BuiltInFailures..::..ProfileFailures
Failures about Profile.
Public class BuiltInFailures..::..PropertySetElementFailures
Failures related to property set elements.
Public class BuiltInFailures..::..RebarCouplerFailures
Failures concerning couplers
Public class BuiltInFailures..::..RebarFailures
Failures about Rebar.
Public class BuiltInFailures..::..RebarShapeFailures
Failures about RebarShape.
Public class BuiltInFailures..::..RebarSystemFailures
Failures related to rebar systems.
Public class BuiltInFailures..::..RefPlaneFailures
Failures about RefPlane.
Public class BuiltInFailures..::..RegenFailures
Failures about RegenFailures.
Public class BuiltInFailures..::..RenderFailures
Failures related to rendering.
Public class BuiltInFailures..::..RevisionCloudFailures
Failures about RevisionCloud.
Public class BuiltInFailures..::..RevisionFailures
Failures about Revision Settings.
Public class BuiltInFailures..::..RevolutionFailures
Failures about Revolution.
Public class BuiltInFailures..::..RoofFailures
Failures about Roof.
Public class BuiltInFailures..::..RoomFailures
Failures about Room.
Public class BuiltInFailures..::..ScaleFailures
Failures about Scale.
Public class BuiltInFailures..::..ScheduleViewFailures
Failures about Schedule.
Public class BuiltInFailures..::..SculptingFailures
Failures about Sculpting.
Public class BuiltInFailures..::..SectionViewFailures
Failures about Section.
Public class BuiltInFailures..::..SelectionFailures
Failures about Selections.
Public class BuiltInFailures..::..SharedCoordinatesFailures
Failures about shared coordinates.
Public class BuiltInFailures..::..SheetFailures
Failures about Sheet.
Public class BuiltInFailures..::..SiteFailures
Failures about Site.
Public class BuiltInFailures..::..SiteImportFailures
Failures about SiteImport.
Public class BuiltInFailures..::..SketchFailures
Failures about Sketch.
Public class BuiltInFailures..::..SkylightFailures
Failures about Skylight.
Public class BuiltInFailures..::..SlabFailures
Failures about Slab.
Public class BuiltInFailures..::..SlabShapeFailures
Failures about SlabShape.
Public class BuiltInFailures..::..SlantedColumnFailures
Failures about SlantedColumn.
Public class BuiltInFailures..::..SpanDirectionSymbolFailures
Failures about SpanDirectionSymbol.
Public class BuiltInFailures..::..SplineFailures
Failures about Spline.
Public class BuiltInFailures..::..SplitSketchBasedElementFailures
Failures related to the split sketched based element.
Public class | BuiltInFailures..::..SplitToposolidFailures
Public class BuiltInFailures..::..StairRampFailures
Failures about StairRamp.
Public class BuiltInFailures..::..SteelElementFailures
Failures about steel elements
Public class BuiltInFailures..::..SteelElementsFailures
Failures about SteelElement module
Public class BuiltInFailures..::..StructuralAssetFailures
Failures related to structural materials.
Public class BuiltInFailures..::..StructuralConnectionFailures
Failures about StructuralConnectionHandler.
Public class BuiltInFailures..::..StructuralCustomConnectionFailures
Failures about StructuralConnectionHandler.
Public class BuiltInFailures..::..StructuralLoadFailures
Failures about Load.
Public class | BuiltInFailures..::..SubRegionFailures
Public class BuiltInFailures..::..SweepFailures
Failures about Sweep.
Public class BuiltInFailures..::..SweptBlendFailures
Failures about SweptBlend.
Public class BuiltInFailures..::..SystemNavigatorFailures
Failures related with the system browser.
Public class BuiltInFailures..::..SystemsFailures
Failures about System.
Public class BuiltInFailures..::..TagFailures
Failures about Tag.
Public class BuiltInFailures..::..TextFailures
Failures about Text.
Public class BuiltInFailures..::..TilePatternTileFailures
Failures related to tile pattern tile.
Public class BuiltInFailures..::..ToggleViewFailures
Failures about ToggleView.
Public class BuiltInFailures..::..TrussFailures
Failures about Truss.
Public class | BuiltInFailures..::..UniqueElementFailures
Public class BuiltInFailures..::..ViewFailures
Failures about ViewFailures.
Public class BuiltInFailures..::..ViewSheetFailures
Failures about placing viewports on sheets.
Public class BuiltInFailures..::..WallFailures
Failures about Wall.
Public class BuiltInFailures..::..WallJoinFailures
Failures about WallJoin.
Public class BuiltInFailures..::..WallJoinRoofFailures
Failures about WallJoinRoof.
Public class BuiltInFailures..::..WorksharingFailures
Failures about WorksharingFailures.
Public class BuiltInFailures..::..ZoneFailures
Failures about Zone.
Public class CADExportOptions
Generic CAD Export options.
Public class CADLinkOperations
This class is used to extend the IExternalResourceServer interface with methods to support operations specifically related to DWG links.
Public class CADLinkOptions
This class contains the options in use when or reloading a CAD link type (DWG, DXF, etc.)
Public class CADLinkType
CADLinkType represents both CAD links and CAD imports. The function IsLink can be used to distinguish between the two. CAD imports are not ExternalFileReferences; they are brought completely into the document and maintain no connection to their original file.
Public class CameraInfo
An object holding information about the projection mapping of a 3D view.
Public class CancellationListener
Allows clients to poll the cancellation status of a background operation. Revit instantiates CancellationListener objects for internal background operation implementations only. As such, third-party developers are not expected to instantiate or handle CancellationListener objects.
Public class Categories
The Categories object is a map that contains all the top-level Category objects within the Document.
Public class Category
Represents the category or subcategory to which an element belongs.
Public class CategoryNameMap
A map that contains a mapping of category name to its category object.
Public class CategoryNameMapIterator
An iterator to a category name map.
Public class CategorySet
A set that can contains Category objects.
Public class CategorySetIterator
An iterator to a category set.
Public class Ceiling
Represents a ceiling in Autodesk Revit.
Public class CeilingAndFloor
A base class that provides support for all ceiling and floor objects.
Public class CeilingType
Represents a ceiling type in Autodesk Revit.
Public class ChangeType
A class representing a change that can be detected and tracked during Dynamic Update.
Public class City
An object that contains geographical location information for a known city.
Public class CitySet
An set that contains cities.
Public class CitySetIterator
An iterator to a city set.
Public class ClassificationEntries
A collection of ClassificationEntry objects that make up the classification table.
Public class ClassificationEntry
Represents an entry in the classification table.
Public class ClosestPointsPairBetweenTwoCurves
This class captures results of computation of closest points between two generic curves.
Public class Color
Represents a color in Autodesk Revit.
Public class ColorBackgroundSettings
Represents the rendering color background settings.
Public class ColorFillLegend
Represents color fill legend.
Public class ColorFillScheme
Represents a color scheme could be used to colorfy elements in floor plan views and section views.
Public class ColorFillSchemeEntry
Represents an entry of a [!:Autodesk::Revit::DB::ColorFillScheme].
Public class ColorOptions
A class providing access to color settings which affect the colors applied to specific views.
Public class ColorWithTransparency
Color with transparency
Public class ColumnAttachment
An object representing the attachment of the top or bottom of a column to some target: a floor, roof, ceiling, beam, or brace.
Public class CombinableElement
An element that can be added to a geometry combination.
Public class CombinableElementArray
An array that contains CombinableElement objects.
Public class CombinableElementArrayIterator
An iterator to an CombinableElement array.
Public class ComponentRepeater
An element that contains and manages a set of repeated components.
Public class ComponentRepeaterIterator
A slot iterator for ComponentRepeater.
Public class ComponentRepeaterSlot
Represents a slot that holds one repeated component in a component repeater.
Public class CompoundStructure
Describes the internal structure of a wall, floor, roof or ceiling.
Public class CompoundStructureLayer
Describes a single layer in a CompoundStructure.
Public class ConfigurationReloadInfo
This object contains information returned by a reload of the fabrication configuration.
Public class ConicalFace
A conical face of a 3d solid or open shell.
Public class ConicalSurface
A Conical Surface.
Public class ConnectionValidationInfo
This object contains information about fabrication connection validations.
Public class ConnectionValidationWarning
Contains information about a specific connection validation problem.
Public class Connector
A connector in an Autodesk Revit MEP project document.
Public class ConnectorElement
A base class that provides support for all connector elements occurring in families.
Public class ConnectorManager
Provides access to the Connector Manager
Public class ConnectorSet
A set that can contain any type of object.
Public class ConnectorSetIterator
An iterator to a set.
Public class Construction
Construction definition for Project Information.
Public class ContentNode
This class represents a generic content node in a model-exporting process.
Public class ContourSetting
Contour setting object that handles the contour information used to draw contours on elements.
Public class ContourSettingItem
Contour setting item that stores the information of a single contour or a set of contours.
Public class Control
A control in Autodesk Revit family document.
Public class CopyPasteOptions
Settings to control the behavior of a copy-paste operation.
Public class CurtainCell
Represents a CurtainCell within Autodesk Revit.
Public class CurtainGrid
Represents a curtain grid element within Autodesk Revit.
Public class CurtainGridLine
Represents a CurtainGridLine within Autodesk Revit.
Public class CurtainGridSet
A set that can contain any type of object.
Public class CurtainGridSetIterator
An iterator to a set.
Public class CurtainSystem
Provides access to the CurtainSystem object in Autodesk Revit.
Public class CurtainSystemBase
Provides access to the CurtainSystemBase object in Autodesk Revit.
Public class CurtainSystemType
An object that represents CurtainSystem type.
Public class Curve
A parametric curve.
Public class CurveArrArray
An array that can contain any type of object.
Public class CurveArrArrayIterator
An iterator to a array.
Public class CurveArray
An array that can contain curves.
Public class CurveArrayIterator
An iterator to a curve array.
Public class CurveByPoints
A curve interpolating two or more points.
Public class CurveByPointsArray
An array that can contain CurveByPoints elements.
Public class CurveByPointsArrayIterator
An iterator to a CurveByPoints array.
Public class CurveByPointsUtils
A static class that contains methods for processing curves driven by points.
Public class CurveElement
Class representing curve elements.
Public class CurveElementFilter
A filter used to pass curve elements which are of a specific type.
Public class CurveExtents
Represents the start and end parameters for a curve segment.
Public class CurveLoop
A class that represents a chain of curves.
Public class CurveLoopIterator
An iterator to a curve loop.
Public class CurveLoopsProfile
Represents a curve loop based profile for sweep or swept blend elements.
Public class CurveNode
An output node that represents a model curve.
Public class CurveUV
A class that encapsulates the notion of a curve in the 2D parameter space of a surface in 3D space.
Public class CustomExporter
A class that allows exporting 3D or 2D views via an export context.
Public class CustomFieldData
A class that offer access to the information about a custom field.
Public class CylindricalFace
A cylindrical face of a 3d solid or open shell.
Public class CylindricalHelix
A cylindrical helix.
Public class CylindricalSurface
A cylindrical surface.
Public class DataConversionMonitorScope
This class is used to regsiter an application-supplied object that implements IDataConversionMonitor. Creating the object registers an implementation of IDataConversionMonitor supplied as constructor argument. When the scope object is destroyed, that object is unregistered.
Public class DatumPlane
A base class representing a datum surface (level, grid or reference plane) in Autodesk Revit.
Public class DefaultDivideSettings
Provides access to project-wide divide settings.
Public class DefaultOpenFromCloudCallback
A default callback that may be used to control Revit's behavior when opening a model.
Public class Definition
The Definition object is a base object for all type of parameter definitions within the Autodesk Revit API.
Public class DefinitionBindingMap
A map that contains mappings of parameter definitions to parameter bindings.
Public class DefinitionBindingMapIterator
An iterator to a parameter definition to parameter bindings map.
Public class DefinitionFile
The DefinitionFile object represents a shared parameters file on disk.
Public class DefinitionGroup
The DefinitionGroup is a container that is used to hold shared parameter definitions on disk.
Public class DefinitionGroups
A specialized set of definition groups that allows creation of new groups.
Public class Definitions
A base class that supports the addition of new parameter definitions.
Public class DeleteElements
Deletes element(s) related to the failure.
Public class DeleteWorksetSettings
This class represents the settings used to delete a workset.
Public class DesignOption
An element that represents a design alternative.
Public class DetailArc
Represents a DetailArc within Autodesk Revit.
Public class DetailCurve
A curve that is used to create a detail drawing. A detail curve is visible only in the view in which it is drawn.
Public class DetailCurveArray
An array that can contain any type of object.
Public class DetailCurveArrayIterator
An iterator to a array.
Public class DetailElementOrderUtils
A utility class that arranges the draw order of the detail elements.
Public class DetailEllipse
Represents a DetailEllipse within Autodesk Revit.
Public class DetailLine
Represents a DetailLine within Autodesk Revit.
Public class DetailNurbSpline
Represents a DetailNurbSpline within Autodesk Revit.
Public class DGNExportOptions
The export options used by exporting DGN format file.
Public class DGNImportOptions
The import options used to import DGN format files.
Public class Dimension
An object that represents a dimension within the Revit project.
Public class DimensionEqualityLabelFormatting
Instances of this class represent individual parameters used to make up a dimension equality formula for continuous linear or angular dimensions.
Public class DimensionSegment
A segment of a dimension within the Autodesk Revit project.
Public class DimensionSegmentArray
An array that can contain any number of DimensionSegment objects.
Public class DimensionSegmentArrayIterator
An iterator to an array of DimensionSegment objects..
Public class DimensionType
An object that represents a dimension style.
Public class DirectShape
This class is used to store externally created geometric shapes. Primary intended use is for importing shapes from other data formats such as IFC or STEP. A DirectShape object may be assigned a category. That will affect how that object is displayed in Revit.
Public class DirectShapeLibrary
DirectShapeLibrary is used to store pre-created geometry for further referencing via the definition/instance mechanism. It is not persistent: the scope of a library object is usually a single data creation session. DirectShape::createGeometryInstance and DirectShape::CreateElementInstance will use the current DirectShapeLibrary to look up the definitions. store a collection of GNodes as definition end class DirectShapeDefinition
Public class DirectShapeOptions
This class is used to control behavior of a DirectShape object.
Public class DirectShapeReferenceOptions
This class is used to control the behavior of DirectShape and DirectShapeType reference objects.
Public class DirectShapeType
The type element associated with a DirectShape element. This element includes data reused by DirectShape elements of the same type.
Public class DirectShapeTypeOptions
This class is used to control behavior of a DirectShapeType object.
Public class DisableAnalyticalModelCB
Disable the analytical model for a structural wall.
Public class DisciplineTypeId
This class contains constants identifying disciplines.
Public class DisplacementElement
A view-specific element that causes other elements to appear to be displaced from their actual locations.
Public class DisplacementPath
A view-specific annotation related to a DisplacementElement.
Public class DividedPath
An element that consists of a set of points distributed along a path which consists of a connected set of curves and edges.
Public class DividedSurface
An element that represents a mesh on the surface of another element, a family instance, an import instance or a geometry combination, and a tile pattern built on that mesh.
Public class Document
An object that represents an open Autodesk Revit project.
Public class DocumentDifference
DocumentDifference represents the difference (including added elements, modified elements and deleted elements) of a Revit model between different DocumentVersion of the model.
Public class DocumentPreviewSettings
Contains the settings related to the saving of preview images for a given document.
Public class DocumentSet
A set that can contain any documents.
Public class DocumentSetIterator
An iterator to a set of documents.
Public class DocumentValidation
Utility functions with document validation
Public class DocumentVersion
This class uniquely identifies an edition of a given document.
Public class DoubleArray
An array that contains doubles.
Public class DoubleArrayIterator
An iterator to an array of doubles.
Public class DoubleParameterValue
A class that holds a Double value of a parameter element.
Public class DuplicateTypeNamesHandlerArgs
A structure that provides information about an attempt to copy types with names that already exist in the destination document.
Public class DWFExportOptions
DWF Export options.
Public class DWFImportOptions
The import options used by importing DWF or DWFx format file.
Public class DWFXExportOptions
DWFX Export options.
Public class DWGExportOptions
The export options used by exporting DWG format file.
Public class DWGImportOptions
The import options used by importing DWG or DXF format file.
Public class DXFExportOptions
The export options used by exporting DXF format file.
Public class Edge
An edge of a 3d solid.
Public class EdgeArray
An array that contains edges.
Public class EdgeArrayArray
An array of edge arrays.
Public class EdgeArrayArrayIterator
An iterator to an array or edge arrays.
Public class EdgeArrayIterator
An iterator to an edge array.
Public class EdgeEndPoint
Represents the start or the end point of an Edge.
Public class EditScope
The base class for a scope object that provides special access and limitations related to editing certain elements.
Public class Element
Base class for most persistent data within a Revit document.
Public class ElementArray
An array that contains element objects.
Public class ElementArrayIterator
An iterator to an element array.
Public class ElementBinding
A base class for all types of binding that attach to an element.
Public class ElementCategoryFilter
A filter used to match elements by their category.
Public class ElementClassFilter
A filter used to match elements by their class.
Public class ElementDesignOptionFilter
A filter used to find elements contained within a particular design option.
Public class ElementFilter
A base class for a type of filter that accepts or rejects elements based upon criteria.
Public class ElementId
The ElementId object is used as a unique identification for an element within a single project.
Public class ElementIdParameterValue
A class that holds a ElementId value of a parameter element.
Public class ElementIdSetFilter
A filter wrapping a set of elements.
Public class ElementIntersectsElementFilter
A filter to find elements that intersect the solid geometry of a given element.
Public class ElementIntersectsFilter
A base class for filters used to match elements which intersect with geometry.
Public class ElementIntersectsSolidFilter
A filter to find elements that intersect the given solid geometry.
Public class ElementIsCurveDrivenFilter
A filter used to match elements which are curve driven.
Public class ElementIsElementTypeFilter
A filter used to match elements which are ElementTypes.
Public class ElementLevelFilter
A filter used to match elements by their associated level.
Public class ElementLogicalFilter
A filter used to logically combine two or more filters.
Public class ElementMulticategoryFilter
A filter used to find elements whose category matches any of a given set of categories.
Public class ElementMulticlassFilter
A filter used to match elements by their class, where more than one class of element may be passed.
Public class ElementNode
A render node that represents an element, including the host document containing the element.
Public class ElementOwnerViewFilter
A filter used to match elements which are owned by a particular view.
Public class ElementParameterFilter
A filter used to match elements by one or more parameter filter rules.
Public class ElementPhaseStatusFilter
A filter used to match elements that have a given phase status on a given phase.
Public class ElementQuickFilter
A base class for a type of filter that operates on element records.
Public class ElementRecord
A record in the Revit database representing an element.
Public class ElementSet
A set that contains element objects.
Public class ElementSetIterator
An iterator to an element set.
Public class ElementSlowFilter
A base class for a type of filter that operates on expanded elements.
Public class ElementStructuralTypeFilter
A filter used to find elements matching a structural type.
Public class ElementTransformUtils
A collection of utilities allowing transformation of elements (e.g. move, rotate, mirror and copy).
Public class ElementType
Base class for all Types within Autodesk Revit.
Public class ElementWorksetFilter
A filter used to match elements which reside in a given workset.
Public class ElevationMarker
ElevationMarkers either host elevation ViewSection views or view references.
Public class Ellipse
A whole or partial ellipse.
Public class EvaluatedParameter
Hold the evaluated ParameterValue and Definition of a parameter.
Public class ExclusionFilter
A filter used to exclude a set of elements automatically.
Public class ExportDGNSettings
This element contains DGN export settings which are saved in a Revit document.
Public class ExportDWGSettings
This element contains DWG/DXF export settings which are saved in a Revit document.
Public class ExportFontInfo
A value used to represent the info stored in an ExportFontTable.
Public class ExportFontKey
A key used to represent an item stored in an ExportFontTable.
Public class ExportFontTable
A table supporting a mapping of Revit font names to font names that will be set in the target export format.
Public class ExportFontTableIterator
An iterator to a set of font table.
Public class ExportLayerInfo
A value used to represent the info stored in the ExportLayerTable.
Public class ExportLayerKey
A key used to represent an item stored in an ExportLayerTable.
Public class ExportLayerTable
A table supporting a mapping of category and subcategory to layer name and other layer properties that will be set in the target export format.
Public class ExportLayerTableIterator
An iterator to a set of Layer table.
Public class ExportLinetypeInfo
A value used to represent the info stored in the ExportLinetypeTable.
Public class ExportLinetypeKey
A key used to represent an item stored in an ExportLinetypeTable.
Public class ExportLinetypeTable
A table supporting a mapping of linetypes in Revit to linetype names that will be set in the target export format.
Public class ExportLinetypeTableIterator
An iterator to a set of line type table.
Public class ExportLineweightInfo
A value used to represent the info stored in the ExportLineweightTable.
Public class ExportLineweightKey
A key used to represent an item stored in an ExportLineweightTable.
Public class ExportLineweightTable
A table supporting a mapping of line weights in Revit to line weight names that will be set in the target export format.
Public class ExportLineweightTableIterator
An iterator to a set of line weight table.
Public class ExportPatternInfo
A value used to represent the info stored in the ExportPatternTable.
Public class ExportPatternKey
A key used to represent an item stored in an ExportPatternTable.
Public class ExportPatternTable
A table supporting a mapping of FillPatterns in Revit to pattern names that will be set in the target export format.
Public class ExportPatternTableIterator
An iterator to a set of Pattern table.
Public class ExportPDFSettings
Settings for PDF export
Public class ExportUtils
This class provides utilities related to document export.
Public class ExternalDefinition
The ExternalDefinition object adds properties specific to Autodesk Revit shared parameter definitions.
Public class ExternalDefinitionCreationOptions
An option class used for creating a new shared parameter definition, including options such as name, type, visibility, Guid description and modifiable flag.
Public class ExternalDefinitions
Supports the creation of new shared parameters definitions.
Public class ExternalFileReference
A class that contains the details of a reference to a file outside of a given document.
Public class ExternalFileUtils
A utility class containing functions related to external file references.
Public class ExternalGeometryId
This class represents an identifier for geometry from external sources.
Public class ExternallyTaggedBRep
An ExternallyTaggedSolid can hold any shape created by BRepBuilder.
Public class ExternallyTaggedGeometryObject
Base class for ExternallyTaggedGeometryObject and ExternallyTaggedSolid.
Public class ExternallyTaggedGeometryValidation
Provides validation for geometry to be stored in an ExternallyTaggedGeometry.
Public class ExternallyTaggedNonBRep
This class is used to create an externally tagged geometry object.
Public class ExternallyTaggedNonBReps
Holds a collection of ExternallyTaggedNonBRep instances.
Public class ExternalResourceBrowserData
Represents a collection of external resources and external resource folders to be presented as the content of a folder in the file browser in Revit.
Public class ExternalResourceLoadContent
This class contains the actual content data and other results of an external resource load operation that are returned by an IExternalResourceServer to Revit.
Public class ExternalResourceLoadContext
This class contains data describing the context related to an external resource load operation.
Public class ExternalResourceLoadData

This class contains the input and output data resulting from invoking an IExternalResourceServer's LoadResource method.

After the call to LoadResource, the resulting ExternalResourceLoadData will be passed into IExternalResourceServer.HandleLoadResourceResults() so that appropriate UI can be displayed.

Server providers can inspect the ExternalResourceLoadData to get an ExternalResourceLoadContent object of the subclass appropriate to the external resource. The class also contains a copy of the ExternalResourceReference, and information about the context of the load operation.

Public class ExternalResourceMatchOptions
Represents match options used to filter external resources when listing them from external resource server.
Public class ExternalResourceReference
This class identifies an external resource provided by an IExternalResourceServer.
Public class ExternalResourceServerExtensions
An object that contains overrides for external resource-specific methods.
Public class ExternalResourceServerUtils
Contains utilities related to external resource server.
Public class ExternalResourceServiceUtils
Contains utilities related to external resource service.
Public class ExternalResourceSubFolder
Data that describes a remote folder to be shown in the file browser dialog
Public class ExternalResourceType
A type class used to distinguish between different kinds of external resource.
Public class ExternalResourceTypes
Provides a container of all Revit built-in ExternalResourceType instances.
Public class ExternalResourceTypes..::..BuiltInExternalResourceTypes
A collection of ids of the ExternalResourceTypes provided by Revit.
Public class ExternalResourceUtils
A utility class containing functions related to external resource references.
Public class Extrusion
A extrusion solid or void form.
Public class ExtrusionAnalyzer
This geometry utility allows you to attempt to "fit" a given piece of geometry into the shape of an extrusion.
Public class ExtrusionRoof
Represents some kinds of Extrusion Roofs.
Public class FabricationAncillaryUsage
Structure that holds information about the usage of a fabrication ancillary
Public class FabricationConfiguration
This element contains the information about the fabrication configuration settings used by the project.
Public class FabricationConfigurationInfo
Represents an MEP object that holds the properties of an MEP fabrication configuration.
Public class FabricationConnectorInfo
Fabrication connector information.
Public class FabricationDimensionDefinition
Fabricaition dimension definition
Public class FabricationHostedInfo
The fabrication hosted element information.
Public class FabricationItemFile
This class holds information about the item file, including whether it is already loaded from disk into Revit.
Public class FabricationItemFolder
A fabrication item folder that can contain sub folders and access to the FabricationItemFiles contained within.
Public class FabricationPart
Represents a fabrication component in the Autodesk Revit MEP product.
Public class FabricationPartType
Represents a fabrication component type in the Autodesk Revit MEP product.
Public class FabricationRodInfo
The rod information of the fabrication part.
Public class FabricationService
This object contains information about a fabrication service.
Public class FabricationServiceButton
The object contains information about a fabricaton button.
Public class FabricationServiceSettings
Represents the settings related to the fabrication services.
Public class FabricationVersionInfo
The object contains versioning information about fabrication data.
Public class Face
A bounded face of a 3d solid or open shell.
Public class FaceArray
An array that contains faces.
Public class FaceArrayIterator
An iterator to a face array.
Public class FaceDetailNode
A base class of output nodes that represent face edges and face silhouettes.
Public class FaceEdgeNode
An output node that represents a Face edge.
Public class FaceNode
An output node that represents a Face.
Public class FaceSecondDerivatives
Contains second partial derivatives of a face at a specified point.
Public class FaceSilhouetteNode
An output node that represents a Face edge.
Public class FaceSplitter
Represents an element that splits a face.
Public class FacetingUtils
This class is used to convertTrianglesToQuads a triangulated structure into a structure in which some of the triangles have been consolidated into quadrilaterals.
Public class FaceWall
A wall attached to a non-vertical massing face.
Public class FailureDefinition
Defines persistent information about a failure.
Public class FailureDefinitionAccessor
A class that provides access to the details of a FailureDefinition after the definition has been defined.
Public class FailureDefinitionId
The unique identifier of a FailureDefinition.
Public class FailureDefinitionRegistry
The global registry for all FailureDefinitions in the Revit session.
Public class FailureHandlingOptions
Options to control how failures (if any occurred during the transaction) should be handled at the time the transaction is being ended.
Public class FailureMessage
Represents a message describing a failure of an operation in Revit.
Public class FailureMessageAccessor
Restricted accessor for FailureMessage.
Public class FailureMessageKey
A unique key assigned to each posted failure message
Public class FailureResolution
Defines a resolution for a failure.
Public class FailuresAccessor
An interface class that provides access to failure information posted in a document and methods to resolve these failures.
Public class Family
An element that represents a custom family (not a system family) in Autodesk Revit.
Public class FamilyElementVisibility
Provides access to the visibility parameters of family elements in family document.
Public class FamilyInstance
This object represents a single instance of a family type, such as a single I beam.
Public class FamilyInstanceFilter
A filter used to find elements that are family instances of the given family symbol.
Public class FamilyManager
The family manager object to manage the family types and parameters in family document.
Public class FamilyParameter
The family parameter object.
Public class FamilyParameterSet
A set that contains FamilyParameter objects.
Public class FamilyParameterSetIterator
An iterator to a FamilyParameter set.
Public class FamilyPointLocation
Data corresponding to the point locations in certain types of Family Symbols.
Public class FamilyPointPlacementReference
This object represents data corresponding to the placement references in a certain types of Family Instances (see examples listed below).
Public class FamilySizeTable
Contains size information for a family.
Public class FamilySizeTableColumn
Contains column information for a FamilySizeTable.
Public class FamilySizeTableErrorInfo
Error information generated from the CSV file import of a FamilySizeTable.
Public class FamilySizeTableManager
Manages importing, exporting, and querying size data through the FamilySizeTable class.
Public class FamilySymbol
An element that represents a single type with a Family.
Public class FamilySymbolFilter
A filter used to find all family symbols of the given family.
Public class FamilySymbolProfile
Represents a family symbol based profile for sweep or swept blend elements.
Public class FamilyThermalProperties
A class that contains thermal properties for specific types of families (doors, windows, and curtain wall panels).
Public class FamilyType
The family type object provides read access to the values of family parameters for this type.
Public class FamilyTypeSet
A set that contains FamilyType objects.
Public class FamilyTypeSetIterator
An iterator to a FamilyType set.
Public class FamilyUtils
Contains utilities related to family operations.
Public class FBXExportOptions
3D-Studio Max (FBX) Export options.
Public class FilePath
This class represents a path on a disk or network location, but not a path to a Revit server location.
Public class FilledRegion
A filled region element.
Public class FilledRegionType
A filled region attributes element. Note, the forground pattern color is stored in the parent class
Public class FillGrid
Represents a grid line in a fill pattern.
Public class FillPattern
Represents a fill pattern object.
Public class FillPatternElement
An element that represents a fill pattern.
Public class FilterableValueProvider
Defines the interface for classes that extract values from elements in a Revit project for testing against filter rules.
Public class FilterCategoryRule
A filter rule that matches elements of a set of categories.
Public class FilterDoubleRule
A filter rule that operates on double-precision numeric values in a Revit project.
Public class FilteredElementCollector
This class is used to search, filter and iterate through a set of elements.
Public class FilteredElementIdIterator
An iterator to a set of element ids filtered by the settings of a FilteredElementCollector.
Public class FilteredElementIterator
An iterator to a set of elements filtered by the settings of a FilteredElementCollector.
Public class FilteredWorksetCollector
This class is used to search, filter and iterate through a set of worksets.
Public class FilteredWorksetIdIterator
An iterator to a set of workset ids filtered by the settings of a FilteredWorksetCollector.
Public class FilteredWorksetIterator
An iterator to a set of worksets filtered by the settings of a FilteredWorksetCollector.
Public class FilterElement
The base class for filter elements in the document.
Public class FilterElementIdRule
A filter rule that operates on ElementId values in a Revit project.
Public class FilterGlobalParameterAssociationRule
A filter rule that operates on global parameters ElementId values in a Revit project.
Public class FilterIntegerRule
A filter rule that operates on integer values in a Revit project.
Public class FilterInverseRule
A filter rule that inverts the boolean values returned by the rule it contains.
Public class FilterNumericEquals
Tests whether numeric values from the document are equal to a certain value
Public class FilterNumericGreater
Tests whether numeric values from the document are greater than a certain value
Public class FilterNumericGreaterOrEqual
Tests whether numeric values from the document are greater than or equal to a certain value
Public class FilterNumericLess
Tests whether numeric values from the document are less than a certain value
Public class FilterNumericLessOrEqual
Tests whether numeric values from the document are less than or equal to a certain value
Public class FilterNumericRuleEvaluator
Base for all classes that compare numeric values from Revit to a user-supplied filter value.
Public class FilterNumericValueRule
Base for all classes that use a FilterNumericRuleEvaluator to perform their comparisons
Public class FilterOperatorAndTextString
An instance of this class holds a filter operator and a text string that denotes the operator in a particular context. For example, the text string for ScheduleFilterType::LessThan may be "is less than" for a filter rule based on a parameter with numerical values or "is below" for a filter rule based on a parameter representing a Level.
Public class FilterRule
Defines a boolean operation that can be used to cull elements from a document.
Public class FilterStringBeginsWith
Tests whether string values from the document begin with a certain string.
Public class FilterStringContains
Tests whether string values from the document contain a certain string.
Public class FilterStringEndsWith
Tests whether string values from the document end with a certain string.
Public class FilterStringEquals
Tests whether string values from the document match a certain string.
Public class FilterStringGreater
Tests whether string values from the document would sort after a certain string.
Public class FilterStringGreaterOrEqual
Tests whether string values from the document would sort after or match a certain string.
Public class FilterStringLess
Tests whether string values from the document would sort before a certain string.
Public class FilterStringLessOrEqual
Tests whether string values from the document would sort before or match a certain string.
Public class FilterStringRule
A filter rule that operates on string values in a Revit project.
Public class FilterStringRuleEvaluator
Base for all classes that compare string values from Revit to a user-supplied filter value
Public class FilterValueRule
A rule that filters on a particular value of an element.
Public class Floor
An object that represents a Floor within the Autodesk Revit project.
Public class FloorType
An object that specifies the type of a floor in Autodesk Revit.
Public class FolderItemInfo
Contains data for each folder item in the organization settings of the project browser including folder parameter Id and folder name.
Public class FootPrintRoof
Represents kinds of FootPrintRoofs.
Public class ForgeTypeId
This class holds a string that uniquely identifies a Forge schema.
Public class Form
An object that represents a Form within the Autodesk Revit Massing Family.
Public class FormArray
An array that contains form objects.
Public class FormArrayIterator
An iterator to a form array.
Public class FormatOptions
Options for formatting numbers with units.
Public class FormattedText
FormattedText is used to create, edit and format text in a TextNote or to query the text and format properties of a TextNode
Public class FormatValueOptions
Options for formatting numbers with units into strings.
Public class FormulaManager
A class to access and query information about formula engine in Revit models.
Public class FormUtils
Define Form utility functions
Public class Frame
A Frame comprises three vectors at a base point in 3D space.
Public class FreeFormElement
A Free Form Element that contains non-parametric geometry created from an input solid outline.
Public class GBXMLExportOptions
Green-Building XML Export options.
Public class GBXMLImportOptions
Import options for Green-Building XML format.
Public class GenericForm
Provides access to the Generic Form model in Autodesk Revit.
Public class GenericImportOptions
Generic Import options.
Public class GeomCombination
An element created by Join and Cut operations applied to combinable elements in an Autodesk Revit family document.
Public class GeomCombinationSet
A set that contains GeomCombination objects.
Public class GeomCombinationSetIterator
An iterator to a GeomCombination set.
Public class GeometryCreationUtilities
A utility that allows construction of basic solid shapes.
Public class GeometryElement
Geometric representation of an element.
Public class GeometryInstance
An instance of another element (symbol), specially positioned by this element.
Public class GeometryObject
The common base class for all geometric primitives.
Public class GlobalParameter
This class represents a GlobalParameter element in Revit.
Public class GlobalParametersManager
A class to access and query information about global parameters in Revit models.
Public class GradientBackgroundSettings
Represents the view gradient background settings.
Public class GraphicsStyle
The graphics style instance in Autodesk Revit document.
Public class Grid
Represents a single grid line within Autodesk Revit.
Public class GridType
An object that represents a grid type.
Public class Group
An element representing a single instance of a group of elements that may be placed many times in a project or family.
Public class GroupLoadOptions
A class containing options for loading a group from a file.
Public class GroupNode
A node that represents set of individual elements grouped together in some form, such as an instance of a family or linked Revit file, or an instance of a part of symbol's geometry.
Public class GroupSet
An set that contains groups.
Public class GroupSetIterator
An iterator to a group set.
Public class GroupType
An element representing a group of elements that may be placed many times in a project or family.
Public class GroupTypeId
This class contains constants identifying parameter groups.
Public class GuidEnum
Base class of all GUID-based enum classes.
Public class HasNoValueFilterRule
Tests whether an element's parameter doesn't have a value.
Public class HasValueFilterRule
Tests whether an element's parameter has a value.
Public class HermiteFace
A cubic hermite spline face of a 3d solid or open shell.
Public class HermiteSpline
A Hermite spline.
Public class HermiteSplineTangents
This class indicates tangency at the start, the end, or both ends of the curve.
Public class HermiteSurface
A Hermite Surface.
Public class HomeCamera
A structure that contains information about the camera and view for the Home view orientation stored in the model.
Public class HostedSweep
An object that represents an object hosted by an edge of a roof or floor within the Autodesk Revit project.
Public class HostedSweepType
An object that represents the attributes for sweep host objects in Autodesk Revit.
Public class HostObjAttributes
An object that represents characteristics of several kinds of type.
Public class HostObject
A base class that provides support for all objects that can host other objects, such as walls roofs, and floors.
Public class HostObjectUtils
These are generic host object utilities.
Public class IFCExportOptions
IFC Export options.
Public class ImageBackgroundSettings
Represents the rendering image background settings.
Public class ImageExportOptions
This class defines options for exporting views and sheets as an image.
Public class ImageInstance
An element that represents an instance of an image placed in a view
Public class ImagePlacementOptions
ImagePlacementOptions are used to describe where an ImageInstance should be placed in a view
Public class ImageType
Represents a type containing a raster based image. ImageInstances of this type can be placed in 2D views, sheets, and schedules.
Public class ImageTypeOptions
Represents the options used in ImageType::Create(Document, ImageTypeOptions) and ImageType.ReloadFrom(ImageTypeOptions) methods.
Public class ImageView
Class for ImageView views
Public class ImportIFCOptions
Provides access to settings that control linking and opening IFC files.
Public class ImportInstance
An element created during either import or link operation. It is an instance of CADLinkType.
Public class ImportOptions3DM
The import options used to import 3DM format files.
Public class InCanvasControlData
Represents a collection of data which is used by TemporaryGraphicsManager to create and update an in-canvas control.
Public class IndependentTag
Represents tag annotations in Revit.
Public class InsertableObject
A base class you all types that are insertable.
Public class InSessionPrintSetting
Represents the in-session Print Setup (Application Menu->Print->Print Setup) within Autodesk Revit.
Public class InSessionViewSheetSet
Represents the in-session ViewSheetSet.
Public class Instance
The base class for all instance objects.
Public class InstanceBinding
The InstanceBinding object is used to signify a binding between a parameter definition and a parameter on each instance of an element, such as a wall.
Public class InstanceNode
An output node that represents an instance of a geometry. It can be an instance of FamilyInstance, or it can be and instance of a part of symbol's geometry.
Public class InstanceVoidCutUtils
Utilities for cutting elements by unattached voids in family instances.
Public class InsulationLiningBase
Acts as the base class for duct insulation, pipe insulation and duct lining elements.
Public class IntegerParameterValue
A class that holds an Integer value of a parameter element.
Public class IntegerRange
A class to define a range of a sequence of consecutive integer numbers
Public class InternalDefinition
This object represents a parameter definition in an Autodesk Revit model.
Public class InternalDefinitions
This object blocks attempts to create new internal definitions as they are not permitted.
Public class InternalOrigin
A class representing the origin of internal coordinate system. Each Revit project contains one InternalOrigin.
Public class IntersectionResult
This class captures results of intersecting geometric entities. "Intersecting" is meant in generalized sense, so the same class will be used for projection, containment, etc. Refer to the documentation of the method providing the result for the precise meaning of properties.
Public class IntersectionResultArray
An array that can contain any type of object.
Public class IntersectionResultArrayIterator
An iterator to a array.
Public class JoinGeometryUtils
Utilities for joining and unjoining elements, and for managing the order in which elements are joined.
Public class KeyBasedTreeEntries
A collection of KeyBasedTreeEntry objects that make up the key-based tree.
Public class KeyBasedTreeEntriesIterator
An iterator to a set of KeyBasedTreeEntry objects.
Public class KeyBasedTreeEntriesLoadContent
This class is used by IExternalResourceServers to return KeyBasedTreeEntries data to Revit when their LoadResource method is invoked.
Public class KeyBasedTreeEntriesLoadResults
This class contains the results and status information regarding an attempt to load the KeyBasedTreeEntries from an External Resource.
Public class KeyBasedTreeEntry
A key-based tree entry, containing the key, parent key, and children keys (if applicable).
Public class KeyBasedTreeEntryError
This class contains information about a problem encountered while creating a KeyBasedTreeEntries object.
Public class KeyBasedTreeEntryTable
KeyBasedTreeEntryTable represents the collection of key-based tree entries for a document.
Public class KeynoteEntries
A collection of KeynoteEntry objects that make up the keynote table.
Public class KeynoteEntry
Represents an entry in the keynote table, containing the key value, keynote text, and parent key (if applicable).
Public class KeynoteTable
KeynoteTable represents the collection of keynotes (KeynoteEntries) for a document.
Public class LabelUtils
Used to obtain user-visible names for enums.
Public class LayerModifier
A modifier used to designate extra strings to appear in the exported layer name.
Public class LayoutRule
The LayoutRule object is a base object for all type of layout rules for Beam System within the Autodesk Revit API.
Public class LayoutRuleClearSpacing
This class indicate the layout rule of a Beam System is Clear-Spacing.
Public class LayoutRuleFixedDistance
This class indicate the layout rule of a Beam System is Fixed-Distance.
Public class LayoutRuleFixedNumber
This class indicate the layout rule of a Beam System is Fixed-Number.
Public class LayoutRuleMaximumSpacing
This class indicate the layout rule of a Beam System is Max-Spacing.
Public class Leader
A leader object that can be attached to annotation elements such as text notes.
Public class LeaderArray
An array that can contain any number of leaders.
Public class LeaderArrayIterator
An iterator to an array of leaders.
Public class Level
Represents a Level within Autodesk Revit.
Public class LevelAssociationData
This class holds information related to Level.
Public class LevelType
An object that represents a Level type.
Public class LightNode
This class represents a Light element in a model-exporting process.
Public class Line
A line in space.
Public class LineAndTextAttrSymbol
An object that represents a dimension style.
Public class LinearArray
An object that represents an Array created linearly within the Revit project.
Public class LinePattern
Represents a line pattern definition.
Public class LinePatternElement
An element that represents a line pattern.
Public class LinePatternSegment
Represents a segment in a line pattern.
Public class LineProperties
A structure that has access to the pen properties of lines/curves that are currently being drawn/exported via an export context during a custom export process.
Public class LineSegment
An output node that represents a tessellated line segment.
Public class LinkConversionData
This class contains the information necessary to re-create a Revit document from an external source.
Public class LinkElementId
LinkElementId represents an element in a linked document.
Public class LinkLoadContent
This class is used by IExternalResourceServers to return Link data to Revit when their LoadResource method is invoked. It also contains additional information used by IExternalResourceUIServers to display link load status results to the user.
Public class LinkLoadResult
This class stores the results of trying to load a single linked model.
Public class LinkNode
An output node that represents a linked Revit document.
Public class LinkOperations
This class is used to extend the IExternalResourceServer interface with methods to support operations for elements that are LinkTypes.
Public class LoadedFamilyIntegrityCheck
Functions for checking the integrity of loaded families.
Public class Location
Provides location functionality for all elements.
Public class LocationCurve
Provides location functionality for all elements that are based upon a curve.
Public class LocationPoint
Provides location functionality for all elements that have a single insertion point.
Public class LogicalAndFilter
A filter that contains a set of filters. The filter passes when all filters in the set pass.
Public class LogicalOrFilter
A filter that contains a set of filters. The filter passes when any filter in the set passes.
Public class MassInstanceUtils
A static class that contains methods for processing curves driven by points.
Public class Material
Represents a material element within an Autodesk Revit project.
Public class MaterialNode
This class represents a change of material during a model-exporting process.
Public class MathComparisonUtils
This class contains a set of mathematical utilities to compare doubles, using the internal tolerance.
Public class MEPAnalyticalConnection
Represents an analytical element that connects mechanical equipment to piping network.
Public class MEPAnalyticalConnectionType
Represents an analytical connection type between mechanical equipment and piping network.
Public class MEPCalculationServerInfo
a struct to hold the information about a MEP calucation servers
Public class MEPConnectorInfo
MEP connector information.
Public class MEPCurve
A curve object for duct or pipe blend elements.
Public class MEPCurveType
The base type class for MEP curves, such as ducts, pipes, cable trays and conduits.
Public class MEPFamilyConnectorInfo
MEP family connector information.
Public class MEPModel
Supports all MEP models that are persistent within the Autodesk Revit project.
Public class MEPSize
Stores the basic size information for an MEP duct, pipe, cable tray, or conduit.
Public class MEPSupportUtils
General utility methods for the Autodesk Revit MEP Supporting components.
Public class MEPSystem
A system in the Autodesk Revit MEP product.
Public class MEPSystemType
A system type in the Autodesk Revit MEP product.
Public class Mesh
A triangular mesh.
Public class MeshFromGeometryOperationResult
Describes what TessellatedShapeBuilder has built.
Public class MeshTriangle
One triangle of a mesh.
Public class ModelArc
Represents a ModelArc within Autodesk Revit.
Public class ModelCurve
A model element that exists in 3D space and is visible in all views of a Revit project.
Public class ModelCurveArrArray
An array that can contain any type of object.
Public class ModelCurveArrArrayIterator
An iterator to a array.
Public class ModelCurveArray
An array that contains model curves.
Public class ModelCurveArrayIterator
An iterator to a model curve array.
Public class ModelCurveNode
A base class of output nodes that represent various model curves.
Public class ModelEllipse
Represents a ModelEllipse within Autodesk Revit.
Public class ModelHermiteSpline
Represents a ModelHermiteSpline within Autodesk Revit.
Public class ModelLine
Represents a ModelLine within Autodesk Revit.
Public class ModelNurbSpline
Represents a ModelNurbSpline within Autodesk Revit.
Public class ModelPath
A path to a file stored on a disk or on a server.
Public class ModelPathUtils
Utility functions using ModelPaths
Public class ModelText
A model text element in an Autodesk Revit family document.
Public class ModelTextType
A model text type symbol in the Autodesk Revit Family document.
Public class Mullion
Represents a CurtainGrid within Autodesk Revit.
Public class MullionType
An object that represents a mullion type.
Public class MullionTypeSet
A set that contains mullion types.
Public class MullionTypeSetIterator
An iterator to a mullion type set.
Public class MultipleValuesIndicationSettings
MultipleValuesIndicationSettings is an element which contains project-wide settings for multiple values indication in Properties Palette and schedules.
Public class MultiReferenceAnnotation
Multi-reference annotations are annotations pointing to more than one reference, consisting of a dimension and associated tag.
Public class MultiReferenceAnnotationOptions
Options which control the creation of MultiReferenceAnnotations.
Public class MultiReferenceAnnotationType
The type for MultiReferenceAnnotation.
Public class MultiSegmentGrid
This element acts as a multi-segmented Grid. The individual grids associated to the MultiSegmentGrid behave as a single unit and all share the same text. They inherit their type (GridType) from the MultiSegmentGrid.
Public class NamingUtils
A collection of utilities related to element naming.
Public class NavisworksExportOptions
Options which controls the Navisworks export.
Public class NestedFamilyTypeReference
A proxy element representing a nested family type.
Public class NullParameterValue
A class that represent an empty (null) value of a parameter element.
Public class NumberingSchema
A class to support assigning numbers to elements of a particular kind for the purpose of tagging and scheduling them.
Public class NumberingSchemaType
A type for identifying a NumberingSchema of a particular kind.
Public class NumberingSchemaTypes
Provides a container of all Revit built-in NumberingSchemaType instances.
Public class NumberingSchemaTypes..::..StructuralNumberingSchemas
A collection of types of built-in Numbering Schemas that are used for numbering structure elements.
Public class NumberSystem
An annotation that consists of a series of numeric tags attached to and describing a host element.
Public class NumericRevisionSettings
Contains settings that apply to Revisions with the Numeric RevisionNumberType.
Public class NurbSpline
A nurb spline.
Public class NurbsSurfaceData
A class used to represent the definition of a NURBS surface.
Public class OBJExportOptions
The export options used by exporting to OBJ file format.
Public class OBJImportOptions
The import options used to import OBJ format files.
Public class OffsetSurface
A mathematical representation of an offset surface.

Definition of offset surface, quoted from the STEP manual ISO 10303-42:2000(E): This is a procedural definition of a simple offset surface at a normal distance from the originating surface. Distance may be positive, negative, or zero to indicate the preferred side of the surface. The offset surface takes its parametrization directly from that of its basis surface, corresponding points having identical parameter values. The offset surface is parametrized as O(u, v) = S(u, v) + d*N(u, v), where N(u, v) is the oriented unit normal vector of the basis surface S at parameter value (u, v), and d is the signed offset distance.

In Revit, we restrict the types of basis surfaces for which an OffsetSurf can be created for the following reasons:

  • The offsets of Plane, CylindricalSurface, ConicalSurface and RevolvedSurface are of the same type as the original surface and they have closed form solutions. So those surfaces are not taken as basis surfaces of the OffsetSurface class. That leaves HermiteSurface and RuledSurface.
  • As a Revit surface, we require the OffsetSurface to be C2 continuous. That implies that the basis surface should be C3 continuous. That is because the OffsetSurface evaluation involves the normal of the basis surface and the order of continuity of the normal is one less than that of the surface.
  • HermiteSurfaces in general are not C3 continuous, even though some of them can be. A RuledSurface will be C3 continuous if its parametric curves are C3 continuous. So we don't allow a HermiteSurface to be a basis surface and allow only RuledSurfaces whose parametric curves are C3 continuous as basis surfaces of the OffsetSurface class.

The OffsetSurface class will own a copy of the basis surface and use it for many of its methods, which may implicitly assume that the OffsetSurface and the basis surface have the same envelope. So we keep the envelopes of the OffsetSurf and its basis surface in sync.

Public class Opening
An opening in an Autodesk Revit project or family document.
Public class OpenOptions
This class contains options available for opening a document from disk.
Public class OptionalFunctionalityUtils
A collection of utilities that can be used to determine if a particular set of functionality is installed and available.
Public class Options
User preferences for parsing of geometry.
Public class OrdinateDimensionSetting
Represents a collection of Ordinate Dimension settings that can be associated to an ordinate DimensionType.
Public class Outline
Outline is a generic object that provides a bounding box/bounding outline. It supports operations to scale and transform. It also supports intersections and contains operations.
Public class OverrideGraphicSettings
Settings to override display of elements in a view.
Public class Panel
This object represents a curtain panel.
Public class PanelType
An object that represents a curtain panel type.
Public class PanelTypeSet
A set that contains panel types.
Public class PanelTypeSetIterator
An iterator to a panel type set.
Public class PaperSize
An object that represents a Paper Size of Print Setup within the Autodesk Revit project.
Public class PaperSizeSet
A set that can contain any number of paper size objects.
Public class PaperSizeSetIterator
An iterator to a set of paper size objects.
Public class PaperSource
An object that represents a Paper Source of Print Setup within the Autodesk Revit project.
Public class PaperSourceSet
A set that can contain any number of paper source objects.
Public class PaperSourceSetIterator
An iterator to a set of paper source objects.
Public class Parameter
The parameter object contains the value data assigned to that parameter.
Public class ParameterDownloadOptions
An option class used for downloading parameters from the Parameters Service.
Public class ParameterElement
An Element that stores a user-defined parameter.
Public class ParameterFilterElement
Admits elements that satisfy two conditions:
  1. The element's category must be one of a certain set of allowed categories.
  2. The element must pass a series of filter rules.
Public class ParameterFilterRuleFactory
Contains functions that create appropriate FilterRule objects based on the parameters given.
Public class ParameterFilterUtilities
Contains static utility functions for enumerating the categories and parameters that are available for use by ParameterFilterElement objects.
Public class ParameterMap
A map that can contain a mapping of a parameter name (a String) to a parameter.
Public class ParameterMapIterator
An iterator to a map relating a parameter name (the key, a String) to a parameter.
Public class ParameterSet
A set that contains parameters.
Public class ParameterSetIterator
An iterator to a parameter set.
Public class | ParameterTypeId
Public class ParameterUtils
A utility class of functions related to parameters.
Public class ParameterValue
A class that holds a value of a parameter element.
Public class ParameterValuePresenceRule
Tests whether an element's parameter has a value or not.
Public class ParameterValueProvider
Gets the value of a parameter from any element passed to GetStringValue, GetDoubleValue, GetIntegerValue, or GetElementIdValue.
Public class Part
This element represents a part of another element.
Public class PartMaker
PartMaker is an element which takes some source elements (e.g., a wall with all its layers) and creates one or more Parts out of it. The logic according to which these Parts are created is non-trivial and PartMaker uses various PartMakerMethods which represents these logics. This element manages the strategy to make Part elements for one or more original elements.
Public class PartMakerMethodToDivideVolumes
By-References dividing strategy used by PartMaker element. TODO_REFACTOR("LegacyMechanismOfMovingElements") returns true if - the Host Elements are not floors or walls - OR - the Host Elements that are referenced by this PartMaker are floors or walls - transformation has already been applied on those Host Elements
Public class PartUtils
General Part utility methods
Public class Path3d
Provides access to the Generic 3D path object in Autodesk Revit.
Public class PDFExportOptions
Options for PDF export
Public class PerformanceAdviser
The tool to report performance problems in a given document.
Public class PerformanceAdviserRuleId
The unique identifier of a PerformanceAdviserRule
Public class PerformanceAdviserRules
Provides a container of all Revit built-in PerformanceAdviserRuleId instances.
Public class Phase
Represents a phase in the life of a building.
Public class PhaseArray
An array that contains phase objects.
Public class PhaseArrayIterator
An iterator to a phase array.
Public class PhaseFilter
Represents an phase filter within Autodesk Revit.
Public class PlanarFace
A bounded face of a 3d solid or open shell.
Public class PlanCircuit
An object that represents an enclosed area in a plan view within the Autodesk Revit project.
Public class PlanCircuitSet
A set that can contain any number of plan circuit objects.
Public class PlanCircuitSetIterator
An iterator to a set of plan circuit objects.
Public class Plane
A Planar surface.
Public class PlanTopology
An object that represents a Plan Topology within the Autodesk Revit project.
Public class PlanTopologySet
A set that can contain any number of plan topology objects.
Public class PlanTopologySetIterator
An iterator to a set of plan topology objects.
Public class PlanViewRange
This class represents the view range of a plan view or a plan region. It records the element ids of the levels which a plane is relative to and the offset of each plane from that level.
Public class Point
A 3D point.
Public class PointCloudInstance
Represents a single instance of a point cloud in the Revit document.
Public class PointCloudType
Represents a type of point cloud loaded into a Revit document. Each PointCloudType maps to a single file or identifier (depending upon the type of Point Cloud Engine which governs it).
Public class PointElementReference
Base class for objects defining a way to constrain a ReferencePoint to one or more other objects in a document.
Public class PointLocationOnCurve
Defines the measurement parameters necessary to create a point at a specific location on a curve.
Public class PointNode
An output node that represents a 3D point.
Public class PointOnEdge
Define a ReferencePoint relative to a referenceable edge or curve on another element.
Public class PointOnEdgeEdgeIntersection
Define a ReferencePoint at the intersection of two referenceable lines.
Public class PointOnEdgeFaceIntersection
Define a ReferencePoint at the intersection of a referenceable edge or curve and a referenceable face.
Public class PointOnFace
Define a ReferencePoint relative to a Face.
Public class PointOnPlane
Define a ReferencePoint relative to a planar reference.
Public class PointRelativeToPoint
Represents a point placed relative to another point.
Public class PolyLine
A polyline.
Public class PolylineNode
An output node that represents a 3D polyline.
Public class PolylineSegments
An output node that represents a tessellated polyline segments.
Public class PolymeshFacet
A class representing one triangular piece - a facet - in a polymesh topology.
Public class PolymeshTopology
A class representing topology of a polymesh.
Public class PrimaryDesignOptionMemberFilter
A filter used to find elements contained in any primary design option of any design option set.
Public class PrimarySizeCriterion
This class contains a size criterion for a RoutingPreferenceRule.
Public class PrintManager
The PrintManager object is used to configure the global print settings.
Public class PrintParameters
An object that contains settings used for printing the document.
Public class PrintSetting
Represents the Print Setup (Application Menu->Print->Print Setup) within Autodesk Revit.
Public class PrintSetup
Represents the Print Setup (Application Menu->Print->Print Setup) within Autodesk Revit.
Public class Profile
A geometric profile consisting of a loop of curves.
Public class ProjectInfo
An object that represents a Project Information within the Autodesk Revit project.
Public class ProjectLocation
A representation of a specific instance and location of the current project.
Public class ProjectLocationSet
An set that contains project locations.
Public class ProjectLocationSetIterator
An iterator to a project location set.
Public class ProjectPosition
ProjectPosition is a class used to represent a geographical offset and rotation. It can be used to represent the position of a project.
Public class PropertyLine
Represents kinds of PropertyLines.
Public class PropertySetElement
An element that groups together a set of related parameters.
Public class RadialArray
An object that represents an Array created along a circle arc within the Revit project.
Public class Rectangle
Stores a set of four integers that represent the left, top, right and bottom of a rectangle.
Public class Reference
A stable reference to a geometric object in a Revit model.
Public class ReferenceableViewUtils
Utilities related to reference views such as reference sections and reference callouts.
Public class ReferenceArray
An array that contains reference objects.
Public class ReferenceArrayArray
An array that contains ReferenceArray objects.
Public class ReferenceArrayArrayIterator
An iterator to a ReferenceArray array.
Public class ReferenceArrayIterator
An iterator to a reference array.
Public class ReferenceIntersector
A class used to find and return elements that intersect a ray created from an origin point and direction.
Public class ReferencePlane
Represents a reference plane of Autodesk Revit.
Public class ReferencePoint
A reference point in an Autodesk Revit family.
Public class ReferencePointArray
An array that contains reference objects.
Public class ReferencePointArrayIterator
An iterator to a reference array.
Public class ReferenceWithContext
An object including a reference to a geometric object and related context, as instance transform etc.
Public class RelinquishedItems
List of elements and worksets that were relinquished by the current user.
Public class RelinquishOptions
Options to control behavior of relinquishing ownership of elements and worksets.
Public class ReloadLatestOptions
Options to control behavior of pure reload latest (not part of synchronize with central).
Public class ReloadSwapOutInfo
This object contains information about fabrication parts swapped out during reload.
Public class RenderingImageExposureSettings
Represents the exposure settings of rendering.
Public class RenderingQualitySettings
Represents the quality settings of rendering.
Public class RenderingSettings
Represents the rendering settings for a 3d view.
Public class RenderNode
This is the base class of all render nodes in a model-exporting process.
Public class RepeaterBounds
Represents bounds of the array of repeating references in 0, 1, or 2 dimensions. (See RepeatingReferenceSource).
Public class RepeaterCoordinates
Represents coordinates in the array of repeating references in 0, 1, or 2 dimensions.
Public class RepeatingReferenceSource
Represents a collection of repeating references.
Public class Revision
Represents a single revision in the project.
Public class RevisionCloud
A RevisionCloud is a graphical "cloud" that can be displayed on a view or sheet to indicate where revisions in the model have occurred.
Public class RevisionNumberingSequence
Defines the sequences by which numbers are assigned to Revisions.
Public class RevisionSettings
Provides access to project-wide settings related to revisions.
Public class RevitLinkGraphicsSettings
Settings to override display of Revit link in a view.
Public class RevitLinkInstance
Represents an instance of a RevitLinkType.
Public class RevitLinkOperations
This class is used to extend the IExternalResourceServer interface with methods to support operations specifically related to Revit links.
Public class RevitLinkOptions
This class contains the options in use when creating or loading a Revit link.
Public class RevitLinkType
This class represents another Revit Document ("link") brought into the current one ("host").
Public class Revolution
A revolution solid or void form.
Public class RevolvedFace
A revolved face of a 3d solid or open shell.
Public class RevolvedSurface
A surface of revolution defined by a profile curve and a local coordinate system. The surface is obtained by rotating the curve around Z axis of the local coordinate system.
Public class RoofBase
Represents all kinds of Roofs.
Public class RoofType
Represents a specific type of roof.
Public class RoutingCondition
RoutingCondition represents routing information that is used as input when determining if a routing criterion, such as minimum or maximum diameter, is met.
Public class RoutingConditions
RoutingConditions contain routing information that is used as input when determining if a routing criterion, such as minimum or maximum diameter, is met.
Public class RoutingCriterionBase
RoutingCriteriaBase is the base class for all routing criteria.
Public class RoutingPreferenceManager
Manages default pipe segments, fittings, and selection criteria for a given MEPCurveType
Public class RoutingPreferenceRule
A class representing a rule set in MEP routing preferences.
Public class RPCNode
This class represents an RPC content in a model-exporting process.
Public class RuledFace
A ruled face of a 3d solid or open shell.
Public class RuledSurface
A ruled surface is created by sweeping a line between two profile curves or between a curve and a point (a point and a curve). Input curve(s) must be bounded or have natural bounds.
Public class SATExportOptions
The export options used by exporting SAT format file. So far, there is no option in it.
Public class SATImportOptions
The import options used to import SAT format files.
Public class SaveAsOptions
This class contains options available for saving a document to disk with a new filename.
Public class SaveOptions
This class contains options available for saving a document to disk.
Public class SchedulableField
A non-calculated field eligible to be included in a schedule.
Public class ScheduleDefinition
Settings that define the contents of a schedule.
Public class ScheduleField
A field in a schedule.
Public class ScheduleFieldId
The ScheduleFieldId object is used as a unique identification for a field in a schedule.
Public class ScheduleFilter
A filter in a schedule.
Public class ScheduleHeightsOnSheet
Heights information of a schedule on sheet.
Public class ScheduleSheetInstance
An element that represents a particular placement of a schedule on a sheet.
Public class ScheduleSortGroupField
A field that is used for sorting and/or grouping in a schedule.
Public class Segment
This element represents a segment of an MEP curve object.
Public class SelectionFilterElement
A filter element that stores an explicit list of ElementIds. Only elements whose ElementIds are in this list will pass the filter.
Public class ServerPath
This class represents a path to a Revit Server location, rather than a location on disk or a network drive.
Public class Settings
The settings object provides access to general components of the Autodesk Revit application, such as Categories.
Public class ShapeBuilder
The base class for geometry builder classes.
Public class ShapeImporter
A utility class that supports conversion of geometry stored in an external format into a Revit geometry objects.
Public class SharedParameterApplicableRule
Tests whether an element supports a shared parameter.
Public class SharedParameterElement
An element that stores the definition of a shared parameter which is loaded into the document.
Public class SiteLocation
Contains the geographical location information for the project's site.
Public class Sketch
Provides access to the Sketch in Autodesk Revit.
Public class SketchBase
Provides access to the SketchBase in Autodesk Revit.
Public class SketchEditScope
A SketchEditScope allows an application to create and maintain an editing session for a Sketch.
Public class SketchedStairsCurveData
Sketched run/landing curves overrides with height and slope
Public class SketchPlane
Represents a sketch plane or work plane.
Public class SKPImportOptions
The import options used to import SKP format files.
Public class SkyBackgroundSettings
Represents the rendering sky background settings.
Public class SlabEdge
An object that represents a slab edge within the Autodesk Revit project.
Public class SlabEdgeType
An object that represents the slab edge type in Autodesk Revit.
Public class SlabShapeCrease
A crease used in Slab Shape Editing.
Public class SlabShapeCreaseArray
An array that can contain any number of creases used in Slab Shape Editing.
Public class SlabShapeCreaseArrayIterator
An iterator to an array of creases used for Slab Shape Editing.
Public class SlabShapeEditor
An object used for Slab Shape Editing.
Public class SlabShapeVertex
A vertex used in Slab Shape Editing.
Public class SlabShapeVertexArray
An array that can contain any number of vertices used in Slab Shape Editing.
Public class SlabShapeVertexArrayIterator
An iterator to an array of vertices used for Slab Shape Editing.
Public class Solid
A 3d solid.
Public class SolidCurveIntersection
This class represents the results of a calculation of intersection between a solid volume and a curve.
Public class SolidCurveIntersectionOptions
This class contains the options used to calculate the intersection between a solid and a curve.
Public class SolidGeometryOptions
A class containing optional information to control the geometry generation of the Solid by the SolidUtils routines.
Public class SolidOptions
A class containing optional information to control the properties of the Solid generated by the GeometryCreationUtilities routines.
Public class SolidOrShellTessellationControls
Controls various aspects of the triangulation produced by [!:SolidUtils::tessellateSolidOrShell()] method.
Public class SolidSolidCutUtils
Exposes utilities which can cause one solid to cut another.
Public class SolidUtils
Contains utility functions for solid operations.
Public class SpacingRule
A rule for specifying a set of equidistant, parallel gridlines within a region.
Public class SpatialElement
Represents an enclosed area or volume in the Revit model.
Public class SpatialElementBoundaryOptions
Options that can be passed to a SpatialElementBoundaryCalculator to influence the results of the calculation.
Public class SpatialElementBoundarySubface
SpatialElementBoundarySubface represents the geometry boundary information of spatial element.
Public class SpatialElementCalculationLocation
The Spatial Element Calculation Location is used to specify the room/space where an element should be considered as placed.
Public class SpatialElementCalculationPoint
SpatialElementCalculationPoint is used as the search point for family instances placement inside rooms and spaces.
Public class SpatialElementDomainData
A base class for specific domain requirements for a spatial element.
Public class SpatialElementFromToCalculationPoints
SpatialElementFromToCalculationPoints is used to specify the search points for a family instance which connects two rooms or spaces, such as a door or window. The points determine which room or space is considered the "from" and which is considered the "to".
Public class SpatialElementGeometryCalculator
Use this class to calculate the geometry of a spatial element and obtain the relationships between the geometry and the element's boundary elements.
Public class SpatialElementGeometryResults
The results of spatial element geometry calculation.
Public class SpatialElementTag
A tag attached to a SpatialElement (room, space or area) in Autodesk Revit.
Public class SpecTypeId
This class contains constants identifying specs.
Public class SpecTypeId..::..Boolean
This class contains constants identifying Boolean specs.
Public class SpecTypeId..::..Int
This class contains constants identifying integer specs.
Public class SpecTypeId..::..Reference
This class contains constants identifying reference specs.
Public class SpecTypeId..::..String
This class contains constants identifying string specs.
Public class SpecUtils
A utility class of functions related to specs. A spec describes a data type that parameters can hold.
Public class SpotDimension
Object representing various types of SpotDimension
Public class SpotDimensionType
A type element containing the properties of a spot elevation.
Public class SSEPointVisibilitySettings
Represents the settings contained in the document associated to the point display of Floor, Roof and Toposolid. for serialization public api methods
Public class StairsEditScope
StairsEditScope allows user to maintain a stairs-editing session.
Public class StartingViewSettings
The initial view settings for a document dictate which view will initially be open when this model is opened. These settings are available for all Revit project documents.
Public class StdPostedWarning
Support for Reviewable Warnings sent from AddOn.
Public class STLExportOptions
The export options used by exporting STL format file.
Public class STLImportOptions
The import options used to import STL format files.
Public class StringParameterValue
A class that holds a String value of a parameter element.
Public class StructuralAsset
Represents the properties of a material pertinent to structural analysis.
Public class Subelement
An object that represents an element or a subelement within the Autodesk Revit project.
Public class SubTransaction
Sub-transactions are objects that provide control over a subset of changes in a document.
Public class SunAndShadowSettings
The SunAndShadowSettings class represents the sun control.
Public class Surface
A mathematical representation of a surface.
Public class Sweep
A sweep solid or void form.
Public class SweepProfile
Represents a profile for sweep or swept blend elements.
Public class SweptBlend
A swept blend solid or void form.
Public class SweptProfile
Represents an extruded profile swept along a driving curve.
Public class SymbolGeometryId
This class is used to identify a piece of geometry managed by a symbol element.
Public class SymbolicCurve
A curve that provides information but is not intended to represent actual geometry in an element.
Public class SymbolicCurveArray
An array that contains model curves.
Public class SymbolicCurveArrayIterator
An iterator to a model curve array.
Public class SymbolTypeId
This class contains constants identifying symbols.
Public class SynchronizeWithCentralOptions
Options to control behavior of synchronization with central.
Public class TableCellCalculatedValueData
The TableCellCalculatedValueData stores the data for calculated value
Public class TableCellCombinedParameterData
The TableCellCombinedParameterData stores the data for combined parameters
Public class TableCellStyle
The TableCellStyle class contains the appearance settings for a given table cell, column, or table.
Public class TableCellStyleOverrideOptions
This helper class represents the overridden characteristics of the associated cell.
Public class TableData
The TableData class is implemented to hold most of the data that describe the style of the rows, columns, and cells in a table.
Public class TableMergedCell
The TableMergedCell class defines a merged area of the upper-left and lower-right of a table grid.
Public class TableSectionData
The TableSectionData class represents a serialized version of an instance of section table data. The class holds row, column and cell data.
Public class TableView
This represents a view that shows a table. Most of the layout data for the table is contained in the TableData class.
Public class TemporaryGraphicsManager
A class that provides functionality to create temporary graphics in a Revit model.
Public class TemporaryViewModes
A data structure containing data related to temporary view modes.
Public class TessellatedBuildIssue
Types of issues encountered while constructing geometrical objects from the tessellated face sets.
Public class TessellatedFace
Defines a planar face bounded by a polyline in 3d space. A face consists of a single connected component and can have holes.
Public class TessellatedShapeBuilder
A class that permits structured building of geometry or a mesh from a collection of connected faces. Contains all closed face sets and custom precisions.
Public class TessellatedShapeBuilderResult
Describes what TessellatedShapeBuilder has construct.
Public class TextElement
Base class representing text elements in Revit.
Public class TextElementType
An object that represents a text style.
Public class TextNode
This class represents a text annotation object in a model-exporting process.
Public class TextNote
A class representing text note annotations in Revit.
Public class TextNoteOptions
Options to use when creating a new text note element.
Public class TextNoteType
An object that represents a text note style.
Public class TextRange
An object that is used to identify a range of characters in a FormattedText.
Public class ThermalAsset
Represents the properties of a material pertinent to energy analysis.
Public class ThermalProperties
Class specific to thermal properties for assembly types, such as Wall, Floor, Ceiling, Roof and Building Pad.
Public class TilePattern
An object representing a tile pattern that may be applied to a DividedSurface.
Public class TilePatterns
The TilePatterns object is an interface for retrieving the TilePattern objects within the Document.
Public class Toposolid
An object that represents a Toposolid within the Autodesk Revit project.
Public class ToposolidType
An object that specifies the type of a Toposolid in Autodesk Revit.
Public class Transaction
Transactions are context-like objects that guard any changes made to a Revit model
Public class TransactionGroup
Transaction groups aggregate a number of transactions.
Public class TransactWithCentralOptions
Options to customize Revit behavior when accessing the central model.
Public class Transform
A transformation of the affine 3-space.
Public class Transform1D
An affine transform of 1D Euclidean space.
Public class Transform2D
An affine transform of 2D Euclidean space.
Public class TransformWithBoundary
This class contains the transform from model space to projection space for a view and the boundary in model space in which the transform is valid.
Public class TransmissionData
A class representing information on all external file references in a document.
Public class TriangleInShellComponent
This class represents a triangle in a TriangulatedShellComponent object. The triangle is defined by its vertices, which are specified by their indices in the TriangulatedShellComponent's array of vertices.
Public class TriangulatedShellComponent
This class represents a triangulated boundary component of a solid or a triangulated connected component of a shell.
Public class TriangulatedSolidOrShell
This class represents a triangulated solid or shell.
Public class TriangulationInterface
This abstract class provides an interface for querying a triangulation structure (vertices and triangles).
Public class TriangulationInterfaceForTriangulatedShellComponent
This class is used to call FacetingUtils::convertTrianglesToQuads with a triangulation defined by a TriangulatedShellComponent.
Public class TriangulationInterfaceForTriangulatedSolidOrShell
This class is used to call FacetingUtils::convertTrianglesToQuads with a triangulation defined by a TriangulatedSolidOrShell.
Public class TriOrQuadFacet
This class represents a triangle or quadrilateral in a faceted structure.
Public class TypeBinding
TypeBinding objects are used to bind a property to a Revit type, such as a wall type.
Public class UnitFormatUtils
A utility class for formatting and parsing numbers with units.
Public class Units
A document's default settings for formatting numbers with units.
Public class UnitTypeId
This class contains constants identifying units of measurement.
Public class UnitUtils
A utility class of functions related to units.
Public class UpdaterData
Service class that is passed to an Updater to prove access to update execution context
Public class UpdaterId
A unique identifier of an Updater
Public class UpdaterInfo
Information of an updater, such as: Name, AdditionalInformation, name of the application that owns the updater, etc.
Public class UpdaterRegistry
An object that stores and manages all updaters registered in the current session.
Public class UV
Object representing coordinates in 2-dimensional space.
Public class ValidateCurveLoopsOptions
Options for array of curve loops validation.
Public class ValueAtPointBase
A base class representing storage of values at a given point.
Public class ValueParsingOptions
Options for parsing strings into numbers with units.
Public class VertexIndexPair
Represents a connection between vertices in the top and bottom profile of a blend.
Public class VertexIndexPairArray
An array that contains VertexIndex pairs.
Public class VertexIndexPairArrayIterator
An iterator to an array of VertexIndex pairs.
Public class VertexPair
Indices of a pair of vertices in two CurveLoops(one vertex in each loop).
Public class View
Base class for all types of views in Autodesk Revit.
Public class View3D
Class for 3D views
Public class ViewCropRegionShapeManager
A class that provides access to settings related to the crop assigned to a view or a reference callout.
Public class ViewDisplayBackground
Set of values that control how background is drawn in a view. Background can only be set for a 3d view or for a section or elevation view.
Public class ViewDisplayDepthCueing
Represents the settings for depth cueing.
Public class ViewDisplayModel
Represents the settings for displaying model graphics. version 2: m_showHiddenLines type changed bool -> ShowHiddenLinesValues::Enum
Public class ViewDisplaySketchyLines
Represents the settings for sketchy lines.
Public class ViewDrafting
ViewDrafting represents a drafting view within the model.
Public class ViewFamilyType
Represents a type of a Revit view.
Public class ViewNavigationToolSettings
Represents the settings contained in the document associated to the View Navigation tools (such as the View Cube).
Public class ViewNode
A render node that represents a view.
Public class ViewOrientation3D
Container for the point and vectors which define View3D's orientation.
Public class ViewPlan
Represents floor plan, area plan, ceiling plan, and structural plan views in Revit.
Public class Viewport
An element that establishes the placement of a view on a sheet.
Public class ViewSchedule
A schedule view.
Public class ViewScheduleExportOptions
The export options used to export schedule views.
Public class ViewSection
ViewSection covers sections, details, elevations, and callouts, all in their reference and non-reference variations.
Public class ViewSet
A set that contains views.
Public class ViewSetIterator
An iterator to a view set.
Public class ViewShapeBuilder
Builds and verifies a view-specific shape representation that would typically be stored in a DirectShape object. Currently limited to curve-based representations for plan and elevation views.
Public class ViewSheet
Class for ViewSheet
Public class ViewSheetSet
Represents ViewSheetSets stored in a document. ViewSheetSets can be stored so that the same printing task can be executed multiple times.
Public class ViewSheetSetting
Represents the View/Sheet Set (Application Menu->Print) within Autodesk Revit.
Public class VisibleInViewFilter
A quick filter that passes elements that are most likely visible in the given view.
Public class Wall
Represents a wall in Autodesk Revit.
Public class WallFoundation
An object that represents a wall foundation element.
Public class WallFoundationType
An object that represents the type of a wall foundation in Autodesk Revit.
Public class WallSweep
Represents a wall sweep or reveal.
Public class WallSweepInfo
Represents a wall sweep or reveal of a vertically compound structure.
Public class WallType
Represents a specific type of wall, such as 'Generic - 8"'.
Public class WallUtils
General Wall utility methods
Public class WireframeBuilder
Constructs a shape representation consisting of points and curves. That shape would typically be stored in a DirectShape or a DirectShapeType object.
Public class Workset
Represents a workset in the document.
Public class WorksetConfiguration
A configuration class that is passed in to methods that open Revit documents to specify which user-created worksets are opened/closed.
Public class WorksetDefaultVisibilitySettings
An object that manages default visibility of worksets in a document.
Public class WorksetFilter
A base class for a type of filter that accepts or rejects worksets based upon criteria.
Public class WorksetId
WorksetId identifies a workset within a single document.
Public class WorksetKindFilter
A filter used to match worksets of the given WorksetKind.
Public class WorksetPreview
Represents an accessor for workset data which can be obtained from an unopened document.
Public class WorksetTable
A table containing references to all the worksets contained in a document.
Public class WorksharingDisplayGraphicSettings
Represents the graphical settings that can be assigned to elements in the worksharing display modes.
Public class WorksharingDisplaySettings
WorksharingDisplaySettings controls how elements will appear when they are displayed in any of the worksharing display modes.
Public class WorksharingSaveAsOptions
This class contains options specific to worksharing SaveAs.
Public class WorksharingTooltipInfo
Worksharing information about a single element suitable for display in an in-canvas tooltip.
Public class WorksharingUtils
A static class that contains utility functions related to worksharing.
Public class XYZ
Object representing coordinates in 3-dimensional space.

Structures

 | Structure | Description
Public structure | GridNode | A structure that represents a particular location in (U,V) from a grid.

Interfaces

 | Interface | Description
Public interface | IATFTranslationServer | Interface class for external servers implementing ATF translation.
Public interface | ICentralLockedCallback | An interface that may be used to control Revit's behavior when it tries to lock central and is blocked because another user already has locked central.
Public interface | IConnector | An interface which provides access to connector in Autodesk Revit MEP document.
Public interface | ICustomFieldProperties | Represents the base class for the properties of a custom field.
Public interface | IDataConversionMonitor | A base class for an application-specific logger. It should be used to track errors during conversion and/or , track conversion progress, cancel a conversion process if necessary. Implementing a logger class is optional, but highly recommended for all but most basic data converters. The base class is UI- and language-independent. It is up to the using app to implement UI. Language-specifc data may be used to communicate information to application users. English should be used to communicate data of interest to Revit development.
Public interface | IDuplicateTypeNamesHandler | An interface for custom handlers of duplicate type names encountered during a paste operation. When the destination document contains types that have the same names as the types being copied, but different internals, a decision must be made on how to proceed - whether to cancel the operation or continue, but only copy types with unique names.
Public interface | IExportContext | An interface that is used in custom export to process a Revit model.
Public interface | IExportContext2D | An interface that is used in custom export to export 2D views of a Revit model.
Public interface | IExportContextBase | An interface that as common base for IModelExportContext and IExportContext2D.
Public interface | IExtension | An interface that supports the additional operation for Extension Status
Public interface | IExternalDBApplication | An interface that supports addition of DB-level external applications to Revit, to subscribe to DB-level events and updaters.
Public interface | IExternalResourceServer | The interface used to provide custom implementation to provide access to external resources (such as linked files) from arbitrary locations.
Public interface | IFailuresPreprocessor | An interface that may be used to perform a preprocessing step to either filter out anticipated transaction failures or to mark certain failures as non-continuable.
Public interface | IFailuresProcessor | To create your own UI or fully automated tool to process Revit Failures, derive a class from this interface.
Public interface | IFamilyLoadOptions | An interface class which provide the callback for family load options.
Public interface | IGetLocalPathForOpenCallback | The interface used to provide custom support for the "Open (and Unload)" command for Revit Links obtained as external resources.
Public interface | IModelExportContext | An interface that is used in custom export to export 3D views of a Revit model.
Public interface | INavisworksExporter | The interface used to implement a Navisworks exporter.
Public interface | IOnLocalLinkSharedCoordinatesSavedCallback | A callback for notifying an IExternalResourceServer that shared coordinates changes have been saved back to one of the Revit or DWG links provided by that server.
Public interface | IOpenFromCloudCallback | An interface that may be used to control Revit's behavior when opening a cloud model.
Public interface | IPerformanceAdviserRule | Base class to derive specific performance adviser rules from.
Public interface | IPhotoRenderContext | An interface that is used in custom export to render 3D views of a Revit model.
Public interface | IPrintSetting | An interface which represents the Print Setup (Application Menu->Print->Print Setup) within Autodesk Revit.
Public interface | ISaveSharedCoordinatesCallback | An interface that may be used to control Revit when trying to unload or reload a Revit link with changes in shared coordinates.
Public interface | ISaveSharedCoordinatesCallbackForUnloadLocally | An interface that is used to control Revit when trying to unload locally a Revit link with changes in shared coordinates.
Public interface | ITransactionFinalizer | An interface that may be used to perform a custom action at the end of a transaction. A method of the interface will be called when a transaction is either committed or rolled back.
Public interface | ITransientElementMaker | The interface to be implemented by an application that creates transient element(s) in Revit.
Public interface | IUpdater | The interface used to create an updater capable of reacting to changes in the Revit model.
Public interface | IViewSheetSet | This interface represents a selected set of views/sheets which will be used for printing.

Enumerations

 | Enumeration | Description
Public enumeration | ACADVersion | An enumerated type listing available AutoCAD versions, into which a file may be exported.
Public enumeration | ACAObjectPreference | An enumerated type listing possible ways to generate geometry of an ACA object Revit object parameters used to generate geometry of the exported ACA object. Revit object geometry is used to generate geometry of the exported ACA object. That may produce better geometric fidelity in some cases.
Public enumeration | AdaptivePointConstraintType | An enumerated type containing possible constraint types for Adaptive Points.
Public enumeration | AdaptivePointOrientationType | An enumerated type containing possible orientation types for Adaptive Points.
Public enumeration | AdaptivePointType | An enumerated type containing possible types for Adaptive Points.
Public enumeration | AllowedValues | A range of allowed values.
Public enumeration | AlternateUnits | An enumerated type listing the locations where Alternate units may be displayed in dimensions.
Public enumeration | AnalyzesAsType | This enum class is used for the BuiltInParameter STRUCTURAL_ANALYZES_AS.
Public enumeration | AreaElemType | An enumerated type to store type of AreaElement.
Public enumeration | ArrayAnchorMember | Represents the possible choices for how the translation or rotation is used to place each member of the array.
Public enumeration | AssemblyDetailViewOrientation | Orientation of the Assembly Detail View.
Public enumeration | AttachmentType | Enum determining whether a link is an attachment or an overlay
Public enumeration | AutomaticConnectionBehaviorType | Defines behavior of connector with respect to automatic creation of connections
Public enumeration | BackClippingParam | The allowed values for the VIEW_BACK_CLIPPING and VIEWER_BOUND_FAR_CLIPPING parameters.
Public enumeration | BackgroundImageFit | Indicates the background image fit type in rendering settings.
Public enumeration | BackgroundStyle | Indicates the background style in rendering settings.
Public enumeration | BaseLoadOn | An enumerated type listing all the possible power load use types for a space object.
Public enumeration | BeamSystemJustifyType | Describes the justify method of beamsystem.
Public enumeration | BehaviorType | An enumerated type listing all the behavior type for MEP Components.
Public enumeration | BooleanOperationsType | An enumerated type listing boolean types that are supported for boolean operation.
Public enumeration | BorderTile | Options for controlling tiles that overlap the face boundary. See DividedSurface.
Public enumeration | BoxPlacement | An enumerated type containing possible constraint types for Adaptive Points.
Public enumeration | BRepBuilderOutcome | This class defines possible outcomes returned by BRepBuilder functions that need to report outcome via a return value.
Public enumeration | BRepBuilderState | This class defines an enumerative type used to specify the state of a BRepBuilder object.
Public enumeration | BRepType | This class defines an enumerative type used to specify the type of output geometry expected from a BRepBuilder.
Public enumeration | BrowserOrganizationType | Enumerated type representing the type of browser organization.
Public enumeration | BuildingType | This enumeration is used for specifying the most predominant building use type.
Public enumeration | BuiltInCategory | A list of all the built in categories within Revit.
Public enumeration | BuiltInParameter | An enumerated type listing all of the built-in parameter IDs supported by Autodesk Revit.
Public enumeration | BuiltInParameterGroup | Obsolete. An enumerated type listing all of the built-in parameter groups supported by Autodesk Revit.
Public enumeration | CategoryType | The type of category.
Public enumeration | CellType | Declares the cell data type.
Public enumeration | ChangePriority | Enum used to specify the priority of an Updater during execution.
Public enumeration | CheckoutStatus | Indicates the ownership status of an element
Public enumeration | ColorDepthType | An enumerated type listing all Color Depth types of Print Setting.
Public enumeration | ColumnAttachmentCutStyle | Control the handling of columns that intersect their targets.
Public enumeration | ColumnAttachmentJustification | Control the column extent in cases where the target is not a uniform height.
Public enumeration | ComponentRotation | ComponentRotation property of DividedSurface. See DividedSurface.
Public enumeration | CompoundStructureError | When CompoundStructure::isValid() returns false, it uses these values to indicate precise nature of defect.
Public enumeration | ConnectionResolution | An enumerated type listing all the possible resolutions for connectivity validation.
Public enumeration | ConnectionWarning | An enumerated type listing all the reasons for connectivity failure.
Public enumeration | ConnectorDomainType | Type of connector domain.
Public enumeration | ConnectorGenderType | Connector gender type enum
Public enumeration | ConnectorJointType | Connector joint type enum
Public enumeration | ConnectorProfileType | An enumerated type listing all connector profile types
Public enumeration | ConnectorType | An enumerated type listing all connector types for a connection
Public enumeration | ControlShape | An enumerated type listing four shapes of control that Autodesk Revit supports.
Public enumeration | CoordinatePlaneVisibility | Visibility settings for ReferencePoint element's coordinate reference planes.
Public enumeration | CurtainGridAlignType | An enumerated to list CurtainGrid patterns.
Public enumeration | CurvedEdgeConditionParam | The allowed values for the HOST_SSE_CURVED_EDGE_CONDITION_PARAM parameter.
Public enumeration | CurveElementType | An enumerated type listing the curve element types that can be used when filtering elements (via CurveElementFilter).
Public enumeration | CurveProjectionType | This attribute indicates how the curve will be projected to the surface if the curve is sketched on the surface.
Public enumeration | CutFailureReason | The reason why a solid-solid cut cannot be created.
Public enumeration | DataExchangeMessageId | Predefined message ids for DataExchangeLog.
Public enumeration | DataExchangeMessageSeverity | Error levels for DataExchangeLog
Public enumeration | DataExchangeMessageVerbosity | Predefined verbosity levels for DataExchangeLog
Public enumeration | DatumEnds | An enumerated type representing ends of a datum plane.
Public enumeration | DatumExtentType | Represents the type of datum extent that is displayed in a particular view.
Public enumeration | DecimalSymbol | The symbol used to separate the integer and fractional parts of a number.
Public enumeration | DeleteWorksetOption | This class defines an enumerative type used to specify the option to delete a workset.
Public enumeration | DetachFromCentralOption | Options for workset detachment behavior.
Public enumeration | DGNFileFormat | An enumerated type listing available Microstation versions into which a file may be exported.
Public enumeration | DigitGroupingAmount | The number of digits in each group when numbers are formatted with digit grouping.
Public enumeration | DigitGroupingSymbol | The symbol used to separate groups of digits when numbers are formatted with digit grouping.
Public enumeration | DimensionShape | An enumerated type to list dimension type.
Public enumeration | DimensionStyleType | An enumerated type containing possible style types of dimensions.
Public enumeration | DirectShapeReferencingOption | An enumerated type containing possible referencing options for DirectShapes.
Public enumeration | DirectShapeRoomBoundingOption | An enumerated type containing possible room bounding settings for DirectShapes.
Public enumeration | DirectShapeTargetViewType | View types for which DirectShape objects are allowed to have alternative shape representations
Public enumeration | DirectShapeTypeUserAssignability | Options for a DirectShapeType which affect whether or not it can be assigned as the type of a DirectShape.
Public enumeration | DisplacementPathStyle | Used to control the graphical representation of a DisplacementPath element.
Public enumeration | DisplayStyle | Display type of the view.
Public enumeration | DisplayUnit | Describes the type of Revit display unit, metric or imperial.
Public enumeration | DistanceMeasuredFrom | Indicates if the distance is measured from the top or bottom of the wall.
Public enumeration | DistributionOfNormals | An enumeration containing the choices of how normal vectors are assigned and distributed along the surface of a polymesh. Planar faces would typically have only normal vector associated, but curved faces can have a different normal either for each facet (triangle) or each point of the tessellated polymesh.
Public enumeration | DividedPathMeasurementType | DividedPath measurement type.
Public enumeration | DocumentType | Types of Revit documents.
Public enumeration | Domain | Type of connector domain.
Public enumeration | DoorEvacuationExitType | An enumerated type listing the possible door evacuation types
Public enumeration | DrawLayer | An enumerated type containing possible DrawLayer options.
Public enumeration | DuplicateTypeAction | This enumerated type defines the action to be taken when there are types with the same name being pasted.
Public enumeration | DWFImageFormat | An enumerated type listing possible image format for DWF Export.
Public enumeration | DWFImageQuality | An enumerated type listing possible image quality for DWF Export.
Public enumeration | EaveCutterType | An enumerated type to store type of EaveCutter.
Public enumeration | ElementOnPhaseStatus | The statuses that an element can have with respect to a given phase.
Public enumeration | ElementReferenceType | Element reference types.
Public enumeration | ElementTypeGroup | The element type group.
Public enumeration | EndCapCondition | Used by CompoundStructure to describe which shell layers participate in end wrapping.
Public enumeration | EntryAndSchemeConsistency | Enumeration used to specify why an entry is inconsistent with a scheme or another entry.
Public enumeration | ExportColorMode | An enumerated type listing export color mode.
Public enumeration | ExportColumnHeaders | Options for exporting column headers in schedule view export.
Public enumeration | ExportEnergyModelType | This enum is used to define if energy model used for gbXML export should be based on rooms/spaces, building elements or analysis mode in EnergyDataSettings.
Public enumeration | ExportPaperFormat | Paper formats supported by export
Public enumeration | ExportRange | This enum is used to define what view, part of the view, or list of views will be exported.
Public enumeration | ExportResolution | An enumerated type listing possible options to control the tessellation quality.
Public enumeration | ExportSheetType | An enumerated type listing possible Sheet type.
Public enumeration | ExportTextQualifier | Options for the text qualifier character in schedule view export.
Public enumeration | ExportUnit | An enumerated type listing possible target units for CAD Export.
Public enumeration | ExternalDBApplicationResult | Informs Autodesk Revit of the status of your external db application after execution.
Public enumeration | ExternalFileReferenceType | Enum class indicating kinds of external file references
Public enumeration | ExternallyTaggedNonBRepUsage | The ways in which an ExternallyTaggedNonBRep can be used in Revit.
Public enumeration | ExternalResourceLoadStatus | A flag to indicate the status of an ExternalResource load request.
Public enumeration | ExternalResourceUIBrowseResultType | Describes the type of external resource browsing result.
Public enumeration | ExtrusionAnalyzerFaceAlignment | Indicates whether a face of the solid analyzed by ExtrusionAnalyzer is fully aligned, partially aligned, or unaligned with faces of the extrusion.
Public enumeration | FabricationDimensionType | Fabrication dimension type.
Public enumeration | FabricationDimensionUnitType | Fabrication dimension unit type.
Public enumeration | FaceIntersectionFaceResult | An enumerated type listing the possible results of a face-face intersection calculation.
Public enumeration | FailureProcessingResult | An enumerated type representing the result achieved by any of the available types of failure handlers: FailuresPreprocessor, the handler of FailuresProcessing event or a FailuresProcessor.
Public enumeration | FailureResolutionType | Enumeration to classify FailureResolutions by nature of operation they perform on failing Elements.
Public enumeration | FailureSeverity | Enum represents severity of a failure.
Public enumeration | FamilyElementVisibilityType | Indicates the Visibility type of generic forms.
Public enumeration | FamilyHostingBehavior | Types of hosts into/onto which a family can be hosted. For informative purposes only. Does not affect anything in Revit!
Public enumeration | FamilyInstanceReferenceType | Corresponds to the possible values of parameter "Is Reference" of reference planes and parameter "Reference" of reference lines in families. This enum is used to identify references of family instances corresponding to reference planes and reference lines in the family.
Public enumeration | FamilyPlacementType | The type of placement required for a given family.
Public enumeration | FamilySizeTableErrorType | The set of errors that can be returned when importing a FamilySizeTable from a CSV file.
Public enumeration | FamilySource | Describes which version of the family to be loaded.
Public enumeration | FillPatternHostOrientation | The types of orientations for fill patterns.
Public enumeration | FillPatternTarget | The type of the fill pattern.
Public enumeration | FindReferenceTarget | The type of reference to find from a ReferenceIntersector.
Public enumeration | FitDirectionType | This enum is used to define the direction to fit the number of pixels defined by PixelSize.
Public enumeration | FittingAndAccessoryCalculationType | The MEP fitting and accessory pressure drop calculation type.
Public enumeration | FittingAngleUsage | An enumerated type representing the options for how to limit the angle values applicable to fitting content.
Public enumeration | FloorFace | An enumerated type listing floor face types (top or bottom)
Public enumeration | FlowDirectionType | An enumerated type listing direction types for a connector.
Public enumeration | FormatStatus | An enumerated type indicating the formatting status of a range of characters in FormattedText
Public enumeration | FramingShapeClassification | This enumeration is used to classify MEP Ancillary Framing shape.
Public enumeration | GraphicsStyleType | Describes the type of graphics style.
Public enumeration | GridNodeLocation | Location of a grid node relative to the face boundary. See DividedSurface.
Public enumeration | GridSegmentDirection | Specify one of the four adjacent segments to a GridNode. See DividedSurface.
Public enumeration | HiddenLineViewsType | An enumerated type listing all Hidden Line Views types of Print Setting.
Public enumeration | HorizontalAlign | Horizontal alignment of model text.
Public enumeration | HorizontalAlignmentStyle | Declares the horizontal alignment style of font.
Public enumeration | HorizontalTextAlignment | Supported types of horizontal alignment of a text element and text justification within the text containing box.
Public enumeration | IFCExportElement | An enumerated type defining if an element is exported to IFC or not.
Public enumeration | IFCExportElementType | An enumerated type defining if an element type is exported to IFC or not.
Public enumeration | IFCVersion | An enumerated type listing available IFC file versions into which a file may be exported.
Public enumeration | ImageFileType | This enum is used to define exported file type.
Public enumeration | ImageResolution | This enum is used to define image resolution in order to calculate the image size.
Public enumeration | ImageTypeSource | The source of the data used to generate the image.
Public enumeration | ImageTypeStatus | Indicates the current state of the contents of the ImageType.
Public enumeration | ImportColorMode | An enumerated type listing how colors are handled in an import process.
Public enumeration | ImportExportFileFormat | Describes formats supported by import / export.
Public enumeration | ImportPlacement | An enumerated type listing possible placement modes for imported drawings.
Public enumeration | ImportUnit | An enumerated type listing possible target units for CAD Import.
Public enumeration | InsertOrientation | The allowed values for the INSERT_ORIENTATION parameter.
Public enumeration | JoinType | The type of join at the end of an element. The join type affects only the graphic treatment, i.e. cleaning of the end, not the physical join behavior.
Public enumeration | JunctionType | An enumerated type listing all the junction types for MEP curve types.
Public enumeration | KeyBasedTreeEntryErrorType | An Enum indicating the type of error associated with a KeyBasedTreeEntry.
Public enumeration | LabelType | The label type in dimension equality formats.
Public enumeration | LayerCategoryType | An enumerated type listing category types supported in an ExportLayerTable.
Public enumeration | LeaderAtachement | Supported types of vertical attachments of a leader to a text note.
Public enumeration | LeaderEndCondition | An enumerated type listing Leader end conditions that are supported for IndependentTags.
Public enumeration | LeaderShape | Supported geometric shapes of annotation leaders.
Public enumeration | LeadersPresentationMode | Leaders Presentation Mode.
Public enumeration | LightAndMaterialAccuracyMode | An enumerated type containing possible Light and Material Accuracy modes for Raytracer render.
Public enumeration | LightingSource | Indicates the lighting scheme type in rendering settings.
Public enumeration | LinePatternSegmentType | Represents the type of a line pattern segment.
Public enumeration | LineScaling | An enumerated type listing possible LineType scaling modes.
Public enumeration | LinkedFileStatus | Enum displaying the loaded status of a linked file
Public enumeration | LinkLoadResultType | Enum listing the possible results after loading a linked model.
Public enumeration | LinkOriginFileType | Enum determining whether the source type of a temporary rvt link is an ifc.
Public enumeration | LinkVisibility | Link visibility types.
Public enumeration | ListType | An enumerated type indicating the style of list item for paragraphs that are part of ordered or unordered lists in FormattedText.
Public enumeration | LoadOperationType | An enum indicating whether a resource load operation was triggered by a user action or an automatic process.
Public enumeration | MarginType | An enumerated type listing all Margin types of Print Setting.
Public enumeration | MassDisplayTemporaryOverrideType | This enum identifies the mass display overrides.
Public enumeration | MaterialAspect | A list of all material aspects that a material can store PropertySetElements for.
Public enumeration | MaterialFunctionAssignment | Used in class CompoundStructure to specify the function of a layer.
Public enumeration | MaterialPropertyPathType | Enum class indicating kinds of paths which ExternalFileReferenceType.Material references can have.
Public enumeration | MEPSystemClassification | This enumeration is used to classify MEP connectors and systems and drives certain behavior for a particular system type
Public enumeration | MeshFromGeometryOperationIssue | Issues encountered while constructing meshes as fallbacks for geometrical operations.
Public enumeration | ModelUpdatesStatus | Indicates whether an element in the current model has additional user changes in the central model.
Public enumeration | ModifierType | An enumerated type listing options to appear in the exported layer name.
Public enumeration | NavisworksCoordinates | An enumerated type listing possible Coordinates of Navisworks Exporter.
Public enumeration | NavisworksExportScope | An enumerated type listing possible "Element Scopes" of Navisworks Exporter.
Public enumeration | NavisworksParameters | An enumerated type listing possible "Parameter conversions" of Navisworks Exporter.
Public enumeration | NumberSystemDisplayRule | The available options for display of numeric values in the number system.
Public enumeration | NumberSystemJustifyOption | The available options for justification of the numbers in a number system.
Public enumeration | OpenConflictResult | The result of the open conflict.
Public enumeration | OpenConflictScenario | The kinds of conflicts happened during open.
Public enumeration | OpenForeignOption | Options for opening files saved by an application that was not developed or licensed by Autodesk.
Public enumeration | OpeningWrappingCondition | Used by CompoundStructure to describe which shell layers participate in wrapping at openings.
Public enumeration | OrdinateDimensionLineStyle | The ordinate dimension line style.
Public enumeration | OrdinateOriginVisibility | The ordinate origin visibility.
Public enumeration | OrdinateTextOrientation | The ordinate dimension text orientation.
Public enumeration | OrdinateTextPosition | The ordinate dimension text position.
Public enumeration | OverridePermissions | Types of overrides that can be applied to a category.
Public enumeration | PageOrientationType | An enumerated type listing all Page Orientation types of Print Setting
Public enumeration | PaperPlacementType | An enumerated type listing all Paper Placement types of Print Setting.
Public enumeration | ParametersOrder | The order of the parameters.
Public enumeration | PartEdgeConditionOrientation | Relative orientation of the right/lower and left/upper edge condition profiles.
Public enumeration | PartsVisibility | Indicates the visibility of parts for the view.
Public enumeration | PartType | An enumerated type listing all MEP family part types. A part type typically provides one unique set of type parameters that defines this part.
Public enumeration | PathType | Enum determining what kind of path a given external file reference path is. Paths are valid for all types of external file references unless otherwise specified.
Public enumeration | PDFExportQualityType | An enumerated type listing the options for PDF export quality.
Public enumeration | PhaseStatusPresentation | An enumerated type listing the options for element display in a phase filter.
Public enumeration | PlanViewDirection | This enumerated type represents the possible directions for a plan view.
Public enumeration | PlanViewPlane | Locations where view range offsets can be specified.
Public enumeration | PlanViewRangeError | Describes errors in the location of planes in a PlanViewRange object.
Public enumeration | PlanViewRangeLevel | An enumerated type representing the options for setting the range for a plan view.
Public enumeration | PointCloudColorMode | Color mode of a point cloud or part of a point cloud
Public enumeration | PointCloudFoundStatus | Enumerated type representing the possible states related to searching for a point cloud file.
Public enumeration | PointOnCurveMeasureFrom | Point on curve MeasureFrom - It tells from which end of the host curve the point location is measured.
Public enumeration | PointOnCurveMeasurementType | Point on curve measurement type Defines the types of measurements that may be used when placing a point at a designated distance along a curve.
Public enumeration | PreferredJunctionType | Enumerated type representing the possible options for the preferred junction for a routine preference rule.
Public enumeration | PreviewFamilyVisibilityMode | Modes that control visibility of family elements depending on the currently applied Element Visibility Settings of a view.
Public enumeration | PrinterResolution | Controls the resolution level in rendering settings.
Public enumeration | PrintRange | An enumerated type listing all Print Range types of Print.
Public enumeration | ProfileFamilyUsage | An enumerated type listing all types of profile families.
Public enumeration | ProfilePlaneLocation | Indicates the location of Sweep profile plane on the path curve.
Public enumeration | PropOverrideMode | An enumerated type listing ways how overridden object styles get exported.
Public enumeration | RasterQualityType | An enumerated type listing the options for raster quality.
Public enumeration | RectangularGridSegmentOrientation | The orientation type of rectangular grid segment.
Public enumeration | ReferenceBaseOnHostType | This enumeration is used to classify the Reference Base on Host type .
Public enumeration | ReferenceType | Reference types of curve element.
Public enumeration | RenderDuration | An enumerated type containing possible duration types to do Raytracer render.
Public enumeration | RenderingQuality | Indicates the rendering quality in rendering settings.
Public enumeration | RenderNodeAction | Enumerated actions for processing a render node during custom export.
Public enumeration | ResolutionTarget | Indicates the resolution target(Screen or Printer) used for rendering settings.
Public enumeration | ResourceVersionStatus | An enum indicating whether a resource is current or out of date.
Public enumeration | RevisionNumbering | The options for how revision numbers should be displayed on sheets within a project.
Public enumeration | RevisionNumberType | Determines how a particular revision will be numbered.
Public enumeration | RevisionVisibility | Determines whether Revision Clouds and Revision Tags will be visible in the project.
Public enumeration | RoundingMethod | Rounding methods
Public enumeration | RoutingPreferenceErrorLevel | An enumerated type listing the options for posting errors or warnings when routing preferences are not satisfied.
Public enumeration | RoutingPreferenceRuleGroupType | Add more rule group type here.
Public enumeration | RowHeightOverrideOptions | Describes the options for overriding schedule body row heights (applied when viewed as a ScheduleSheetInstance on a ViewSheet).
Public enumeration | SaveModifiedLinksOptions | Class giving options when saving linked files which have been modified in-memory by shared coordinates operations.
Public enumeration | SaveModifiedLinksOptionsForUnloadLocally | Class giving options when saving linked files which are unloaded locally and have been modified in-memory by shared coordinates operations.
Public enumeration | ScheduleFieldDisplayType | Display type of schedule field.
Public enumeration | ScheduleFieldMultipleValuesDisplayType | Define how the schedule field's multiple value is displayed.
Public enumeration | ScheduleFieldType | The type of data displayed in a schedule field.
Public enumeration | ScheduleFilterType | Type of schedule filter.
Public enumeration | ScheduleHeadingOrientation | Orientation of schedule heading.
Public enumeration | ScheduleHorizontalAlignment | Horizontal alignment of data in a schedule.
Public enumeration | ScheduleSortOrder | Options for sort order of rows in a schedule.
Public enumeration | ScheduleVerticalAlignment | Vertical alignment of data in a schedule.
Public enumeration | SectionType | Declares the section data type.
Public enumeration | SelectionFilterAction | An enumerated type containing the type of actions that may be taken with a selection filter applied to a point cloud.
Public enumeration | ServiceType | This enumeration is used for specifying the most predominant service for the building or space.
Public enumeration | SetComparisonResult | An enumerated type listing all the relationship types between two sets of arbitrary nature.
Public enumeration | ShapeImporterSourceFormat | An enumerated type listing the possible formats supported by the Shapeimporter.
Public enumeration | SheetDuplicateOption | Options for duplicating sheets
Public enumeration | ShellLayerType | Used to distinguish exterior and interior shell layers.
Public enumeration | ShowHiddenLinesValues | Provides options for display of hidden lines in a given view.
Public enumeration | SimpleWorksetConfiguration | Indicates the set of user-created worksets to open in memory
Public enumeration | SlabShapeCreaseType | An enumerated type listing all Crease types of Slab Shape Edit.
Public enumeration | SlabShapeVertexType | An enumerated type listing all Vertex types of Slab Shape Edit.
Public enumeration | SlantedOrVerticalColumnType | This enum class is used for the BuiltInParameter SLANTED_COLUMN_TYPE_PARAM.
Public enumeration | SolidCurveIntersectionMode | Represents the types of results available for calculating the intersection between a solid and a curve.
Public enumeration | SolidGeometry | An enumerated type listing possible ways of exporting solids in 3D views.
Public enumeration | SortingOrder | Enumerated type representing the sorting order of a collection of objects.
Public enumeration | SpacingRuleJustification | Justification property of spacing rule
Public enumeration | SpacingRuleLayout | Rules for laying out a series of equidistant points or parallel lines
Public enumeration | SpatialElementBoundaryLocation | An enumerated type listing boundary options of spatial element geometry calculation.
Public enumeration | SpatialElementTagOrientation | An enumerated type listing tag orientation options that are supported by SpatialElementTags.
Public enumeration | SpatialElementType | An enumerated type listing types of spaces.
Public enumeration | SpecialType | An enumerated type listing special types that can appear in an ExportLayerTable. These types do not represent an independent category in Revit, but can be mapped to specific layers on export.
Public enumeration | StickSymbolLocation | Indicates the stick symbol location on the UI, which is used for the BuiltInParameter STRUCTURAL_STICK_SYMBOL_LOCATION.
Public enumeration | StiffenerClassification | This enumeration is used to classify the stiffener.
Public enumeration | StorageType | An enumerated type listing all of the internal parameter data storage types that Autodesk Revit supports.
Public enumeration | StripedRowPattern | An enumerated type representing the possible sets of rows of a striped row schedule.
Public enumeration | StructDeckEmbeddingType | Used in class CompoundStructure to specify the usage of a layer whose function is StructuralDeck.
Public enumeration | StructuralAssetClass | Represents the type of material described by a structural asset. This enum value is returned by Autodesk::Revit::DB::StructuralAsset::StructuralAssetClass.
Public enumeration | StructuralBehavior | Specifies whether structural elements behave orthotropically, isotropically, or transverse-isotropically.
Public enumeration | StructuralReleaseType | Type of structural release, which is used for the BuiltIn parameter STRUCTURAL_END_RELEASE_TYPE.
Public enumeration | SubfaceType | Meaning of a subface's type.
Public enumeration | SunAndShadowType | Sun study type enum of SunAndShadowSettings.
Public enumeration | SunStudyTimeInterval | Time interval enum for a single or multi-day sun study.
Public enumeration | TagMode | The modes of tag creation that are supported for IndependentTags.
Public enumeration | TagOrientation | An enumerated type listing tag orientation options that are supported by IndependentTags.
Public enumeration | TemporaryViewMode | Enumeration to represent the various temporary view modes a view can be in.
Public enumeration | TessellatedBuildIssueType | Types of issues encountered while constructing geometrical objects from the tessellatted face sets.
Public enumeration | TessellatedShapeBuilderFallback | Describes what TessellatedShapeBuilder function should do, if it cannot build a requested TessellatedShapeBuilderTarget.
Public enumeration | TessellatedShapeBuilderOutcome | Describes the outcome of TessellatedShapeBuilder attempt to build geometrical objects.
Public enumeration | TessellatedShapeBuilderTarget | Describes what TessellatedShapeBuilder should generate, if possible.
Public enumeration | TextAlignFlags | An enumerated type listing all the Text align flags.
Public enumeration | TextAlignMask | An enumerated type listing all the Text align mask.
Public enumeration | TextBaselineStyle | Supported styles of text position relative to the normal baseline.
Public enumeration | TextElementBackground | An enumerated type listing all the background mode for the built-in parameter TEXT_BACKGROUND.
Public enumeration | TextListStyle | Supported styles of text list paragraphs.
Public enumeration | TextNoteLeaderStyles | An enumerated type listing all the Leader styles.
Public enumeration | TextNoteLeaderTypes | Types of text-note leaders
Public enumeration | TextTreatment | An enumerated type listing possible text treatment modes.
Public enumeration | ThermalMaterialType | Represents the thermal material type.
Public enumeration | TilePatternsBuiltIn | Revit's built-in tile patterns. See TilePattern.
Public enumeration | TransactionStatus | An enumerated type listing the possible statuses associated with a Transaction, TransactionGroup, or SubTransaction, or the result of a particular method call on one of those objects.
Public enumeration | TransmittedModelOptions | Enum giving desired behavior when opening or saving a transmitted workshared model.
Public enumeration | UnderlayOrientation | Indicates how elements in the underlay are viewed.
Public enumeration | UnitSystem | A system of measurement: Metric or Imperial units.
Public enumeration | UVGridlineType | A choice between U-gridlines or V-gridlines of a divided surface U Gridlines V Gridlines
Public enumeration | ValueAtPointFlags | Enumerated type containing flags related to the display on particular points. Enumerated type that stores bit values of flags that can be set at any domain point.
Public enumeration | VerticalAlignmentStyle | Declares the vertical alignment style of font.
Public enumeration | VerticalTextAlignment | Supported types of vertical alignment of a text element.
Public enumeration | ViewDetailLevel | Detail level of the view
Public enumeration | ViewDiscipline | Discipline of the view
Public enumeration | ViewDisplayBackgroundImageFlags | A collection of bit flags that control how the background image is positioned in relation to the crop region (or the view boundary).
Public enumeration | ViewDisplayBackgroundType | A collection of settings defining the type of the view background
Public enumeration | ViewDisplayEdges | A collection of settings defining how visible edges are displayed
Public enumeration | ViewDuplicateOption | Options for duplicating views
Public enumeration | ViewFamily | An enumerated type that corresponds to the type of a Revit view.
Public enumeration | ViewPlacementOnSheetStatus | Indicates whether the View is placed on a Sheet.
Public enumeration | ViewPlanType | An enumerated type listing plan view types.
Public enumeration | ViewportPositioning | An enumerated type listing of viewport positioning options on the sheet when swapped to another view.
Public enumeration | ViewportRotation | Rotation of the viewport
Public enumeration | ViewTemplateApplicationOption | Options for applying view templates
Public enumeration | ViewType | An enumerated type listing available view types.
Public enumeration | VirtualPrinterType | An enumerated to list Virtual Printer Types in Revit.
Public enumeration | Visibility | Describes the visibility of a particular geometry object.
Public enumeration | WallCrossSection | The allowed values for the WALL_CROSS_SECTION parameter.
Public enumeration | WallFunction | Indicates the function of a specified WallType, as specified in the parameter FUNCTION_PARAM on the WallType.
Public enumeration | WallKind | Describes the fundamental type of wall, such as curtain wall or stacked wall.
Public enumeration | WallLocationLine | This enumerated type represents the options for alignment of a wall's location line.
Public enumeration | WallSide | Represents the possible sides of a wall where a sweep or reveal may be attached.
Public enumeration | WallSweepOrientation | Represents the orientation of horizonally placed sweep's profile relative to the wall side face.
Public enumeration | WallSweepType | Represents the possible types for methods affecting wall sweeps or reveals.
Public enumeration | WidthMeasuredAt | The allowed values for the WALL_TYPE_WIDTH_MEASURED_AT parameter.
Public enumeration | WorksetConfigurationOption | A collection of options used to initialize a WorksetConfiguration.
Public enumeration | WorksetKind | Indicates one of the standard kinds of workset (as available in the UI).
Public enumeration | WorksetVisibility | Indicates the visibility settings of a workset in a particular view.
Public enumeration | WorksharingDisplayMode | Indicates which worksharing display mode a view is in.
Public enumeration | ZoomFitType | This enum is used to define type of zoom.
Public enumeration | ZoomType | An enumerated type listing all Zoom types of Print Setting.


ACADExportOptions Class

[image]

Revit 2024 API
ACADExportOptions Class
Members See Also Send Feedback
The base class for options used to export DWG and DXF format files.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class ACADExportOptions : BaseExportOptions
Visual Basic
Public Class ACADExportOptions _
    Inherits BaseExportOptions
Visual C++
public ref class ACADExportOptions : public BaseExportOptions

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BaseExportOptions
Autodesk.Revit.DB..::..ACADExportOptions
Autodesk.Revit.DB..::..DWGExportOptions
Autodesk.Revit.DB..::..DXFExportOptions

See Also

ACADExportOptions Members
Autodesk.Revit.DB Namespace


ACADExportOptions Methods

[image] [image]

Revit 2024 API
ACADExportOptions Methods
ACADExportOptions Class See Also Send Feedback

The ACADExportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from BaseExportOptions.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetExportFontTable | Gets font table. (Inherited from BaseExportOptions.)
Public method | GetExportLayerTable | Gets the layer table. (Inherited from BaseExportOptions.)
Public method | GetExportLinetypeTable | Gets a copy of the line type table. (Inherited from BaseExportOptions.)
Public method | GetExportPatternTable | Gets a copy of the pattern table. (Inherited from BaseExportOptions.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetExportFontTable | Sets font table to option. (Inherited from BaseExportOptions.)
Public method | SetExportLayerTable | Sets layer table back to option (Inherited from BaseExportOptions.)
Public method | SetExportLinetypeTable | Sets the line type table to use during export. (Inherited from BaseExportOptions.)
Public method | SetExportPatternTable | Sets the pattern table to use during export. (Inherited from BaseExportOptions.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ACADExportOptions Class


ACAPreference Property

[image]

Revit 2024 API
ACADExportOptions..::..ACAPreference Property
ACADExportOptions Class See Also Send Feedback
The preferred way to generate geometry of ACA objects. Default value is ACAObjectPreference.Object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ACAObjectPreference ACAPreference { get; set; }
Visual Basic
Public Property ACAPreference As ACAObjectPreference
    Get
    Set
Visual C++
public:
property ACAObjectPreference ACAPreference {
    ACAObjectPreference get ();
    void set (ACAObjectPreference value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

ACADExportOptions Class


ExportingAreas Property

[image]

Revit 2024 API
ACADExportOptions..::..ExportingAreas Property
ACADExportOptions Class See Also Send Feedback
True to export area and room geometry, false otherwise. Default value is false.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool ExportingAreas { get; set; }
Visual Basic
Public Property ExportingAreas As Boolean
    Get
    Set
Visual C++
public:
property bool ExportingAreas {
    bool get ();
    void set (bool value);
}

See Also

ACADExportOptions Class


ExportOfSolids Property

[image]

Revit 2024 API
ACADExportOptions..::..ExportOfSolids Property
ACADExportOptions Class See Also Send Feedback
The mode used to export solids in 3D views. Default value is SolidGeometry.Polymesh.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public SolidGeometry ExportOfSolids { get; set; }
Visual Basic
Public Property ExportOfSolids As SolidGeometry
    Get
    Set
Visual C++
public:
property SolidGeometry ExportOfSolids {
    SolidGeometry get ();
    void set (SolidGeometry value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

ACADExportOptions Class


FileVersion Property

[image]

Revit 2024 API
ACADExportOptions..::..FileVersion Property
ACADExportOptions Class See Also Send Feedback
ACADVersion::Default Default value is ACADVersion.Default.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ACADVersion FileVersion { get; set; }
Visual Basic
Public Property FileVersion As ACADVersion
    Get
    Set
Visual C++
public:
property ACADVersion FileVersion {
    ACADVersion get ();
    void set (ACADVersion value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

ACADExportOptions Class


HatchBackgroundColor Property

[image]

Revit 2024 API
ACADExportOptions..::..HatchBackgroundColor Property
ACADExportOptions Class See Also Send Feedback
The color that will be set as hatch backgound color on the exported hatch. This color will be used only if useHatchBackgroundColor is true. default value is white

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public Color HatchBackgroundColor { get; set; }
Visual Basic
Public Property HatchBackgroundColor As Color
    Get
    Set
Visual C++
public:
property Color^ HatchBackgroundColor {
    Color^ get ();
    void set (Color^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ACADExportOptions Class


LineScaling Property

[image]

Revit 2024 API
ACADExportOptions..::..LineScaling Property
ACADExportOptions Class See Also Send Feedback
The scaling mode for the line type. Default value is LineScaling.ViewScale.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public LineScaling LineScaling { get; set; }
Visual Basic
Public Property LineScaling As LineScaling
    Get
    Set
Visual C++
public:
property LineScaling LineScaling {
    LineScaling get ();
    void set (LineScaling value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

ACADExportOptions Class


LinetypesFileName Property

[image]

Revit 2024 API
ACADExportOptions..::..LinetypesFileName Property
ACADExportOptions Class See Also Send Feedback
The custom linetype file name (*.lin). Default value is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string LinetypesFileName { get; set; }
Visual Basic
Public Property LinetypesFileName As String
    Get
    Set
Visual C++
public:
property String^ LinetypesFileName {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ACADExportOptions Class


MarkNonplotLayers Property

[image]

Revit 2024 API
ACADExportOptions..::..MarkNonplotLayers Property
ACADExportOptions Class See Also Send Feedback
If true and the nonplot layer suffix is not empty, all layers whose names contain that suffix will be marked as non-plot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool MarkNonplotLayers { get; set; }
Visual Basic
Public Property MarkNonplotLayers As Boolean
    Get
    Set
Visual C++
public:
property bool MarkNonplotLayers {
    bool get ();
    void set (bool value);
}

Remarks

A typical use would be to mark as non-plot all layers containing -NPLT. Default value is false

See Also

ACADExportOptions Class


NonplotSuffix Property

[image]

Revit 2024 API
ACADExportOptions..::..NonplotSuffix Property
ACADExportOptions Class See Also Send Feedback
If the MarkNonplotLayers attribute is set to true, all layers with names containing this suffix will be marked as non-plot. No action will be performed if the suffix is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string NonplotSuffix { get; set; }
Visual Basic
Public Property NonplotSuffix As String
    Get
    Set
Visual C++
public:
property String^ NonplotSuffix {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ACADExportOptions Class


SharedCoords Property

[image]

Revit 2024 API
ACADExportOptions..::..SharedCoords Property
ACADExportOptions Class See Also Send Feedback
True to use the shared coordinate system's origin, false to use the project origin. Default value is false.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool SharedCoords { get; set; }
Visual Basic
Public Property SharedCoords As Boolean
    Get
    Set
Visual C++
public:
property bool SharedCoords {
    bool get ();
    void set (bool value);
}

See Also

ACADExportOptions Class


TargetUnit Property

[image]

Revit 2024 API
ACADExportOptions..::..TargetUnit Property
ACADExportOptions Class See Also Send Feedback
The target unit type. Default value is ExportUnit.Default.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ExportUnit TargetUnit { get; set; }
Visual Basic
Public Property TargetUnit As ExportUnit
    Get
    Set
Visual C++
public:
property ExportUnit TargetUnit {
    ExportUnit get ();
    void set (ExportUnit value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

ACADExportOptions Class


TextTreatment Property

[image]

Revit 2024 API
ACADExportOptions..::..TextTreatment Property
ACADExportOptions Class See Also Send Feedback
The text treatment. Deault value is TextTreatment.Exact.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public TextTreatment TextTreatment { get; set; }
Visual Basic
Public Property TextTreatment As TextTreatment
    Get
    Set
Visual C++
public:
property TextTreatment TextTreatment {
    TextTreatment get ();
    void set (TextTreatment value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

ACADExportOptions Class


UseHatchBackgroundColor Property

[image]

Revit 2024 API
ACADExportOptions..::..UseHatchBackgroundColor Property
ACADExportOptions Class See Also Send Feedback
Indicates if hatch background color will be used or not. default value is false.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public bool UseHatchBackgroundColor { get; set; }
Visual Basic
Public Property UseHatchBackgroundColor As Boolean
    Get
    Set
Visual C++
public:
property bool UseHatchBackgroundColor {
    bool get ();
    void set (bool value);
}

See Also

ACADExportOptions Class


ACADVersion Enumeration

[image]

Revit 2024 API
ACADVersion Enumeration
See Also Send Feedback
An enumerated type listing available AutoCAD versions, into which a file may be exported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum ACADVersion
Visual Basic
Public Enumeration ACADVersion
Visual C++
public enum class ACADVersion

Members

Member name | Description
R2007 | AutoCAD 2007 file format.
R2010 | AutoCAD 2010 file format.
R2013 | AutoCAD 2013 file format.
Default | The Autodesk Revit application's default export format.
R2018 | AutoCAD 2018 file format.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


ACAObjectPreference Enumeration

[image]

Revit 2024 API
ACAObjectPreference Enumeration
See Also Send Feedback
An enumerated type listing possible ways to generate geometry of an ACA object Revit object parameters used to generate geometry of the exported ACA object. Revit object geometry is used to generate geometry of the exported ACA object. That may produce better geometric fidelity in some cases.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum ACAObjectPreference
Visual Basic
Public Enumeration ACAObjectPreference
Visual C++
public enum class ACAObjectPreference

Members

Member name | Description
Object |
Geometry |

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


AdaptiveComponentFamilyUtils Class

[image]

Revit 2024 API
AdaptiveComponentFamilyUtils Class
Members Example See Also Send Feedback
An interface for Adaptive Component Instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static class AdaptiveComponentFamilyUtils
Visual Basic
Public NotInheritable Class AdaptiveComponentFamilyUtils
Visual C++
public ref class AdaptiveComponentFamilyUtils abstract sealed

Examples

CopyC#
private void CreateAdaptiveComponentFamily(Document document)
{
    // check if this family is an Adaptive Component family
    if (!(AdaptiveComponentFamilyUtils.IsAdaptiveComponentFamily(document.OwnerFamily))) return;
    using (Transaction transaction = new Transaction(document))
    {
       int placementCtr = 1;
       ReferencePointArray refPointArray = new ReferencePointArray();
       for (int i = 0; i < 10; i++)
       {
           transaction.SetName("Point" + i);
           transaction.Start();
           ReferencePoint referencePoint = document.FamilyCreate.NewReferencePoint(new XYZ(i, 0, 0));
           if (i % 2 == 0)
           // Even-numbered reference points will be Placement Points
           {
               AdaptiveComponentFamilyUtils.MakeAdaptivePoint(document, referencePoint.Id, AdaptivePointType.PlacementPoint);
               transaction.Commit();
               AdaptiveComponentFamilyUtils.SetPlacementNumber(document, referencePoint.Id, placementCtr);
               placementCtr++;
           }
           else
           // Odd-numbered points will be Shape Handle Points
           {
               AdaptiveComponentFamilyUtils.MakeAdaptivePoint(document, referencePoint.Id, AdaptivePointType.ShapeHandlePoint);
               transaction.Commit();
           }
           refPointArray.Append(referencePoint);
       }
       // Create a curve running through all Reference Points
       if (transaction.GetStatus() == TransactionStatus.Committed)
       {
          transaction.SetName("Curve");
          transaction.Start();
          CurveByPoints curve = document.FamilyCreate.NewCurveByPoints(refPointArray);
          transaction.Commit();
       }
    }
}
CopyVB.NET
Private Sub CreateAdaptiveComponentFamily(document As Document)
    ' check if this family is an Adaptive Component family
    If Not (AdaptiveComponentFamilyUtils.IsAdaptiveComponentFamily(document.OwnerFamily)) Then
        Return
    End If
    Using transaction As New Transaction(document)
        Dim placementCtr As Integer = 1
        Dim refPointArray As New ReferencePointArray()
        For i As Integer = 0 To 9
            transaction.SetName("Point" & i)
            transaction.Start()
            Dim referencePoint As ReferencePoint = document.FamilyCreate.NewReferencePoint(New XYZ(i, 0, 0))
            If i Mod 2 = 0 Then
                ' Even-numbered reference points will be Placement Points
                AdaptiveComponentFamilyUtils.MakeAdaptivePoint(document, referencePoint.Id, AdaptivePointType.PlacementPoint)
                transaction.Commit()
                AdaptiveComponentFamilyUtils.SetPlacementNumber(document, referencePoint.Id, placementCtr)
                placementCtr += 1
            Else
                ' Odd-numbered points will be Shape Handle Points
                AdaptiveComponentFamilyUtils.MakeAdaptivePoint(document, referencePoint.Id, AdaptivePointType.ShapeHandlePoint)
                transaction.Commit()
            End If
            refPointArray.Append(referencePoint)
        Next
        ' Create a curve running through all Reference Points
        If transaction.GetStatus() = TransactionStatus.Committed Then
            transaction.SetName("Curve")
            transaction.Start()
            Dim curve As CurveByPoints = document.FamilyCreate.NewCurveByPoints(refPointArray)
            transaction.Commit()
        End If
    End Using
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..AdaptiveComponentFamilyUtils

See Also

AdaptiveComponentFamilyUtils Members


AdaptiveComponentFamilyUtils Methods

[image] [image]

Revit 2024 API
AdaptiveComponentFamilyUtils Methods
AdaptiveComponentFamilyUtils Class See Also Send Feedback

The AdaptiveComponentFamilyUtils type exposes the following members.

Methods

Name | Description
GetNumberOfAdaptivePoints | Gets number of Adaptive Point Elements in Adaptive Component Family.
GetNumberOfPlacementPoints | Gets number of Placement Point Elements in Adaptive Component Family.
GetNumberOfShapeHandlePoints | Gets number of Shape Handle Point Elements in Adaptive Component Family.
GetPlacementNumber | Gets Placement number of an Adaptive Placement Point.
GetPointConstraintType | Gets constrain type of an Adaptive Shape Handle Point.
GetPointOrientationType | Gets orientation type of an Adaptive Placement Point.
IsAdaptiveComponentFamily | Verifies if the Family is an Adaptive Component Family.
IsAdaptivePlacementPoint | Verifies if the Reference Point is an Adaptive Placement Point.
IsAdaptivePoint | Verifies if the Reference Point is an Adaptive Point.
IsAdaptiveShapeHandlePoint | Verifies if the Reference Point is an Adaptive Shape Handle Point.
MakeAdaptivePoint | Makes Reference Point an Adaptive Point or makes an Adaptive Point a Reference Point.
SetPlacementNumber | Sets Placement Number of an Adaptive Placement Point.
SetPointConstraintType | Sets constrain type of an Adaptive Shape Handle Point.
SetPointOrientationType | Sets orientation type of an Adaptive Placement Point.

See Also

AdaptiveComponentFamilyUtils Class


GetNumberOfAdaptivePoints Method

[image]

Revit 2024 API
AdaptiveComponentFamilyUtils..::..GetNumberOfAdaptivePoints Method
AdaptiveComponentFamilyUtils Class See Also Send Feedback
Gets number of Adaptive Point Elements in Adaptive Component Family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static int GetNumberOfAdaptivePoints(
    Family family
)
Visual Basic
Public Shared Function GetNumberOfAdaptivePoints ( _
    family As Family _
) As Integer
Visual C++
public:
static int GetNumberOfAdaptivePoints(
    Family^ family
)

Parameters

family
Type: Autodesk.Revit.DB..::..Family
The Family

Return Value

Number of Adaptive Point Element References in Adaptive Component Family.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The Family family is not an Adaptive Component Family.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation failed.

See Also

AdaptiveComponentFamilyUtils Class


GetNumberOfShapeHandlePoints Method

[image]

Revit 2024 API
AdaptiveComponentFamilyUtils..::..GetNumberOfShapeHandlePoints Method
AdaptiveComponentFamilyUtils Class See Also Send Feedback
Gets number of Shape Handle Point Elements in Adaptive Component Family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static int GetNumberOfShapeHandlePoints(
    Family family
)
Visual Basic
Public Shared Function GetNumberOfShapeHandlePoints ( _
    family As Family _
) As Integer
Visual C++
public:
static int GetNumberOfShapeHandlePoints(
    Family^ family
)

Parameters

family
Type: Autodesk.Revit.DB..::..Family
The Family

Return Value

Number of Adaptive Shape Handle Point Element References in the Adaptive Component Family.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The Family family is not an Adaptive Component Family.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation failed.

See Also

AdaptiveComponentFamilyUtils Class


GetPlacementNumber Method

[image]

Revit 2024 API
AdaptiveComponentFamilyUtils..::..GetPlacementNumber Method
AdaptiveComponentFamilyUtils Class See Also Send Feedback
Gets Placement number of an Adaptive Placement Point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static int GetPlacementNumber(
    Document doc,
    ElementId refPointId
)
Visual Basic
Public Shared Function GetPlacementNumber ( _
    doc As Document, _
    refPointId As ElementId _
) As Integer
Visual C++
public:
static int GetPlacementNumber(
    Document^ doc,
    ElementId^ refPointId
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The Document
refPointId
Type: Autodesk.Revit.DB..::..ElementId
The ReferencePoint id

Return Value

Placement number of the Adaptive Placement Point.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId refPointId does not correspond to a valid ReferencePoint. -or- The Element corresponding to ElementId refPointId does not belong to an Adaptive Family. -or- The ElementId refPointId does not correspond to an Adaptive Placement Point.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

AdaptiveComponentFamilyUtils Class


GetPointConstraintType Method

[image]

Revit 2024 API
AdaptiveComponentFamilyUtils..::..GetPointConstraintType Method
AdaptiveComponentFamilyUtils Class See Also Send Feedback
Gets constrain type of an Adaptive Shape Handle Point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static AdaptivePointConstraintType GetPointConstraintType(
    Document doc,
    ElementId refPointId
)
Visual Basic
Public Shared Function GetPointConstraintType ( _
    doc As Document, _
    refPointId As ElementId _
) As AdaptivePointConstraintType
Visual C++
public:
static AdaptivePointConstraintType GetPointConstraintType(
    Document^ doc,
    ElementId^ refPointId
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The Document
refPointId
Type: Autodesk.Revit.DB..::..ElementId
The ReferencePoint id

Return Value

Constraint type of the Adaptive Shape Handle Point.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId refPointId does not correspond to a valid ReferencePoint. -or- The Element corresponding to ElementId refPointId does not belong to an Adaptive Family. -or- The ElementId refPointId does not correspond to a Shape Handle Point.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

AdaptiveComponentFamilyUtils Class


GetPointOrientationType Method

[image]

Revit 2024 API
AdaptiveComponentFamilyUtils..::..GetPointOrientationType Method
AdaptiveComponentFamilyUtils Class See Also Send Feedback
Gets orientation type of an Adaptive Placement Point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static AdaptivePointOrientationType GetPointOrientationType(
    Document doc,
    ElementId refPointId
)
Visual Basic
Public Shared Function GetPointOrientationType ( _
    doc As Document, _
    refPointId As ElementId _
) As AdaptivePointOrientationType
Visual C++
public:
static AdaptivePointOrientationType GetPointOrientationType(
    Document^ doc,
    ElementId^ refPointId
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The Document
refPointId
Type: Autodesk.Revit.DB..::..ElementId
The ReferencePoint id

Return Value

Orientation type of Adaptive Placement Point.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId refPointId does not correspond to a valid ReferencePoint. -or- The Element corresponding to ElementId refPointId does not belong to an Adaptive Family. -or- The ElementId refPointId does not correspond to an Adaptive Placement Point.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

AdaptiveComponentFamilyUtils Class


IsAdaptivePlacementPoint Method

[image]

Revit 2024 API
AdaptiveComponentFamilyUtils..::..IsAdaptivePlacementPoint Method
AdaptiveComponentFamilyUtils Class See Also Send Feedback
Verifies if the Reference Point is an Adaptive Placement Point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static bool IsAdaptivePlacementPoint(
    Document doc,
    ElementId refPointId
)
Visual Basic
Public Shared Function IsAdaptivePlacementPoint ( _
    doc As Document, _
    refPointId As ElementId _
) As Boolean
Visual C++
public:
static bool IsAdaptivePlacementPoint(
    Document^ doc,
    ElementId^ refPointId
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The Document
refPointId
Type: Autodesk.Revit.DB..::..ElementId
The ReferencePoint id

Return Value

True if the Point is an Adaptive Placement Point.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

AdaptiveComponentFamilyUtils Class


IsAdaptivePoint Method

[image]

Revit 2024 API
AdaptiveComponentFamilyUtils..::..IsAdaptivePoint Method
AdaptiveComponentFamilyUtils Class See Also Send Feedback
Verifies if the Reference Point is an Adaptive Point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static bool IsAdaptivePoint(
    Document doc,
    ElementId refPointId
)
Visual Basic
Public Shared Function IsAdaptivePoint ( _
    doc As Document, _
    refPointId As ElementId _
) As Boolean
Visual C++
public:
static bool IsAdaptivePoint(
    Document^ doc,
    ElementId^ refPointId
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The Document
refPointId
Type: Autodesk.Revit.DB..::..ElementId
The ReferencePoint id

Return Value

True if the Point is an Adaptive Point (Placement Point or Shape Handle Point).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

AdaptiveComponentFamilyUtils Class


IsAdaptiveShapeHandlePoint Method

[image]

Revit 2024 API
AdaptiveComponentFamilyUtils..::..IsAdaptiveShapeHandlePoint Method
AdaptiveComponentFamilyUtils Class See Also Send Feedback
Verifies if the Reference Point is an Adaptive Shape Handle Point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static bool IsAdaptiveShapeHandlePoint(
    Document doc,
    ElementId refPointId
)
Visual Basic
Public Shared Function IsAdaptiveShapeHandlePoint ( _
    doc As Document, _
    refPointId As ElementId _
) As Boolean
Visual C++
public:
static bool IsAdaptiveShapeHandlePoint(
    Document^ doc,
    ElementId^ refPointId
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The Document
refPointId
Type: Autodesk.Revit.DB..::..ElementId
The ReferencePoint id

Return Value

True if the Point is an Adaptive Shape Handle Point.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

AdaptiveComponentFamilyUtils Class


MakeAdaptivePoint Method

[image]

Revit 2024 API
AdaptiveComponentFamilyUtils..::..MakeAdaptivePoint Method
AdaptiveComponentFamilyUtils Class See Also Send Feedback
Makes Reference Point an Adaptive Point or makes an Adaptive Point a Reference Point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static void MakeAdaptivePoint(
    Document doc,
    ElementId refPointId,
    AdaptivePointType type
)
Visual Basic
Public Shared Sub MakeAdaptivePoint ( _
    doc As Document, _
    refPointId As ElementId, _
    type As AdaptivePointType _
)
Visual C++
public:
static void MakeAdaptivePoint(
    Document^ doc,
    ElementId^ refPointId,
    AdaptivePointType type
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The Document
refPointId
Type: Autodesk.Revit.DB..::..ElementId
The ReferencePoint id
type
Type: Autodesk.Revit.DB..::..AdaptivePointType
The Adaptive Point Type

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId refPointId does not correspond to a valid ReferencePoint. -or- The Element corresponding to ElementId refPointId does not belong to an Adaptive Family.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation failed.

See Also

AdaptiveComponentFamilyUtils Class


SetPlacementNumber Method

[image]

Revit 2024 API
AdaptiveComponentFamilyUtils..::..SetPlacementNumber Method
AdaptiveComponentFamilyUtils Class See Also Send Feedback
Sets Placement Number of an Adaptive Placement Point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static void SetPlacementNumber(
    Document doc,
    ElementId refPointId,
    int placementNumber
)
Visual Basic
Public Shared Sub SetPlacementNumber ( _
    doc As Document, _
    refPointId As ElementId, _
    placementNumber As Integer _
)
Visual C++
public:
static void SetPlacementNumber(
    Document^ doc,
    ElementId^ refPointId,
    int placementNumber
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The Document
refPointId
Type: Autodesk.Revit.DB..::..ElementId
The ReferencePoint id
placementNumber
Type: System..::..Int32
Placement number of the Adaptive Placement Point.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId refPointId does not correspond to a valid ReferencePoint. -or- The Element corresponding to ElementId refPointId does not belong to an Adaptive Family. -or- The ElementId refPointId does not correspond to an Adaptive Placement Point. -or- The number placementNumber is out of range.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation failed.

See Also

AdaptiveComponentFamilyUtils Class


SetPointConstraintType Method

[image]

Revit 2024 API
AdaptiveComponentFamilyUtils..::..SetPointConstraintType Method
AdaptiveComponentFamilyUtils Class See Also Send Feedback
Sets constrain type of an Adaptive Shape Handle Point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static void SetPointConstraintType(
    Document doc,
    ElementId refPointId,
    AdaptivePointConstraintType constraintType
)
Visual Basic
Public Shared Sub SetPointConstraintType ( _
    doc As Document, _
    refPointId As ElementId, _
    constraintType As AdaptivePointConstraintType _
)
Visual C++
public:
static void SetPointConstraintType(
    Document^ doc,
    ElementId^ refPointId,
    AdaptivePointConstraintType constraintType
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The Document
refPointId
Type: Autodesk.Revit.DB..::..ElementId
The ReferencePoint id
constraintType
Type: Autodesk.Revit.DB..::..AdaptivePointConstraintType
Constraint type of the Adaptive Shape Handle Point.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId refPointId does not correspond to a valid ReferencePoint. -or- The Element corresponding to ElementId refPointId does not belong to an Adaptive Family. -or- The ElementId refPointId does not correspond to a Shape Handle Point.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation failed.

See Also

AdaptiveComponentFamilyUtils Class


SetPointOrientationType Method

[image]

Revit 2024 API
AdaptiveComponentFamilyUtils..::..SetPointOrientationType Method
AdaptiveComponentFamilyUtils Class See Also Send Feedback
Sets orientation type of an Adaptive Placement Point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static void SetPointOrientationType(
    Document doc,
    ElementId refPointId,
    AdaptivePointOrientationType orientationType
)
Visual Basic
Public Shared Sub SetPointOrientationType ( _
    doc As Document, _
    refPointId As ElementId, _
    orientationType As AdaptivePointOrientationType _
)
Visual C++
public:
static void SetPointOrientationType(
    Document^ doc,
    ElementId^ refPointId,
    AdaptivePointOrientationType orientationType
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The Document
refPointId
Type: Autodesk.Revit.DB..::..ElementId
The ReferencePoint id
orientationType
Type: Autodesk.Revit.DB..::..AdaptivePointOrientationType
Orientation type of the Adaptive Placement Point.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId refPointId does not correspond to a valid ReferencePoint. -or- The Element corresponding to ElementId refPointId does not belong to an Adaptive Family. -or- The ElementId refPointId does not correspond to an Adaptive Placement Point.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation failed.

See Also

AdaptiveComponentFamilyUtils Class


AdaptiveComponentInstanceUtils Class

[image]

Revit 2024 API
AdaptiveComponentInstanceUtils Class
Members Example See Also Send Feedback
An interface for Adaptive Component Instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static class AdaptiveComponentInstanceUtils
Visual Basic
Public NotInheritable Class AdaptiveComponentInstanceUtils
Visual C++
public ref class AdaptiveComponentInstanceUtils abstract sealed

Examples

CopyC#
private void CreateAdaptiveComponentInstance(Document document, FamilySymbol symbol)
{
    // Create a new instance of an adaptive component family
    FamilyInstance instance = AdaptiveComponentInstanceUtils.CreateAdaptiveComponentInstance(document, symbol);

    // Get the placement points of this instance
    IList<ElementId> placePointIds = new List<ElementId>();
    placePointIds = AdaptiveComponentInstanceUtils.GetInstancePlacementPointElementRefIds(instance);
    double x = 0;

    // Set the position of each placement point
    foreach (ElementId id in placePointIds)
    {
        ReferencePoint point = document.GetElement(id) as ReferencePoint;
        point.Position = new Autodesk.Revit.DB.XYZ(10*x, 10*Math.Cos(x), 0);
        x += Math.PI/6;
    }
}
CopyVB.NET
Private Sub CreateAdaptiveComponentInstance(document As Document, symbol As FamilySymbol)
    ' Create a new instance of an adaptive component family
    Dim instance As FamilyInstance = AdaptiveComponentInstanceUtils.CreateAdaptiveComponentInstance(document, symbol)

    ' Get the placement points of this instance
    Dim placePointIds As IList(Of ElementId) = New List(Of ElementId)()
    placePointIds = AdaptiveComponentInstanceUtils.GetInstancePlacementPointElementRefIds(instance)
    Dim x As Double = 0

    ' Set the position of each placement point
    For Each id As ElementId In placePointIds
        Dim point As ReferencePoint = TryCast(document.GetElement(id), ReferencePoint)
        point.Position = New Autodesk.Revit.DB.XYZ(10 * x, 10 * Math.Cos(x), 0)
        x += Math.PI / 6
    Next
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..AdaptiveComponentInstanceUtils

See Also

AdaptiveComponentInstanceUtils Members


AdaptiveComponentInstanceUtils Methods

[image] [image]

Revit 2024 API
AdaptiveComponentInstanceUtils Methods
AdaptiveComponentInstanceUtils Class See Also Send Feedback

The AdaptiveComponentInstanceUtils type exposes the following members.

Methods

Name | Description
CreateAdaptiveComponentInstance | Creates a FamilyInstance of Adaptive Component Family.
GetInstancePlacementPointElementRefIds | Gets Placement Adaptive Point Element Ref ids to which the instance geometry adapts.
GetInstancePointElementRefIds | Gets Adaptive Point Element Ref ids to which the instance geometry adapts.
GetInstanceShapeHandlePointElementRefIds | Gets Shape Handle Adaptive Point Element Ref ids to which the instance geometry adapts.
HasAdaptiveFamilySymbol | Verifies if a FamilyInstance has an Adaptive Family Symbol.
IsAdaptiveComponentInstance | Verifies if a FamilyInstance is an Adaptive Component Instance.
IsAdaptiveFamilySymbol | Verifies if a FamilySymbol is a valid Adaptive Family Symbol.
IsInstanceFlipped | Gets the value of the flip parameter on the adaptive instance.
MoveAdaptiveComponentInstance | Moves Adaptive Component Instance by the specified transformation.
SetInstanceFlipped | Sets the value of the flip parameter on the adaptive instance.

See Also

AdaptiveComponentInstanceUtils Class


CreateAdaptiveComponentInstance Method

[image]

Revit 2024 API
AdaptiveComponentInstanceUtils..::..CreateAdaptiveComponentInstance Method
AdaptiveComponentInstanceUtils Class See Also Send Feedback
Creates a FamilyInstance of Adaptive Component Family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static FamilyInstance CreateAdaptiveComponentInstance(
    Document doc,
    FamilySymbol famSymb
)
Visual Basic
Public Shared Function CreateAdaptiveComponentInstance ( _
    doc As Document, _
    famSymb As FamilySymbol _
) As FamilyInstance
Visual C++
public:
static FamilyInstance^ CreateAdaptiveComponentInstance(
    Document^ doc,
    FamilySymbol^ famSymb
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The Document
famSymb
Type: Autodesk.Revit.DB..::..FamilySymbol
The FamilySymbol

Return Value

The Family Instance

Remarks

This method creates an Adaptive FamilyInstance and its PointElement references. The references can be accessed by methods like GetInstancePointElementRefIds(). The PointElement references can be moved, rehosted or manipulated just like any other PointElements. The FamilyInstance would then 'adapt' to these references.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element famSymb was not found in the given document. -or- The Symbol famSymb is not an Adaptive Family Symbol.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | Unable to create adaptive component instance.

See Also

AdaptiveComponentInstanceUtils Class


GetInstancePlacementPointElementRefIds Method

[image]

Revit 2024 API
AdaptiveComponentInstanceUtils..::..GetInstancePlacementPointElementRefIds Method
AdaptiveComponentInstanceUtils Class See Also Send Feedback
Gets Placement Adaptive Point Element Ref ids to which the instance geometry adapts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static IList<ElementId> GetInstancePlacementPointElementRefIds(
    FamilyInstance famInst
)
Visual Basic
Public Shared Function GetInstancePlacementPointElementRefIds ( _
    famInst As FamilyInstance _
) As IList(Of ElementId)
Visual C++
public:
static IList<ElementId^>^ GetInstancePlacementPointElementRefIds(
    FamilyInstance^ famInst
)

Parameters

famInst
Type: Autodesk.Revit.DB..::..FamilyInstance
The FamilyInstance.

Return Value

The Placement Adaptive Point Element Ref ids to which the instance geometry adapts.

Remarks

The output contains placement point ref ids. The element ids are sorted in by the placement numbers (increasing order).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The FamilyInstance famInst is not an Adaptive Family Instance. -or- The FamilyInstance famInst does not have an Adaptive Family Symbol.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation failed.

See Also

AdaptiveComponentInstanceUtils Class


GetInstancePointElementRefIds Method

[image]

Revit 2024 API
AdaptiveComponentInstanceUtils..::..GetInstancePointElementRefIds Method
AdaptiveComponentInstanceUtils Class See Also Send Feedback
Gets Adaptive Point Element Ref ids to which the instance geometry adapts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static IList<ElementId> GetInstancePointElementRefIds(
    FamilyInstance famInst
)
Visual Basic
Public Shared Function GetInstancePointElementRefIds ( _
    famInst As FamilyInstance _
) As IList(Of ElementId)
Visual C++
public:
static IList<ElementId^>^ GetInstancePointElementRefIds(
    FamilyInstance^ famInst
)

Parameters

famInst
Type: Autodesk.Revit.DB..::..FamilyInstance
The FamilyInstance.

Return Value

The Adaptive Point Element Ref ids to which the instance geometry adapts.

Remarks

The output contains both placement point ref ids and the shape handles point ref ids. The order corresponds to the same order as that of the Adaptive Points in the Family (which may not be ordered as per their placement number). Will return an empty array if there are no placement points and shape handles. To manipulate such an instance the following methods can be useful: 1) RehostAdaptiveComponentInstanceWithNoPlacementPoints() 2) MoveAdaptiveComponentInstance()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The FamilyInstance famInst is not an Adaptive Family Instance. -or- The FamilyInstance famInst does not have an Adaptive Family Symbol.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation failed.

See Also

AdaptiveComponentInstanceUtils Class


GetInstanceShapeHandlePointElementRefIds Method

[image]

Revit 2024 API
AdaptiveComponentInstanceUtils..::..GetInstanceShapeHandlePointElementRefIds Method
AdaptiveComponentInstanceUtils Class See Also Send Feedback
Gets Shape Handle Adaptive Point Element Ref ids to which the instance geometry adapts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static IList<ElementId> GetInstanceShapeHandlePointElementRefIds(
    FamilyInstance famInst
)
Visual Basic
Public Shared Function GetInstanceShapeHandlePointElementRefIds ( _
    famInst As FamilyInstance _
) As IList(Of ElementId)
Visual C++
public:
static IList<ElementId^>^ GetInstanceShapeHandlePointElementRefIds(
    FamilyInstance^ famInst
)

Parameters

famInst
Type: Autodesk.Revit.DB..::..FamilyInstance
The FamilyInstance

Return Value

The Shape Handle Adaptive Point Element Ref ids to which the instance geometry adapts.

Remarks

The output contains shape handle point ref ids. If there are no shape handle points defined in the Family then the output is empty.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The FamilyInstance famInst is not an Adaptive Family Instance. -or- The FamilyInstance famInst does not have an Adaptive Family Symbol.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation failed.

See Also

AdaptiveComponentInstanceUtils Class


HasAdaptiveFamilySymbol Method

[image]

Revit 2024 API
AdaptiveComponentInstanceUtils..::..HasAdaptiveFamilySymbol Method
AdaptiveComponentInstanceUtils Class See Also Send Feedback
Verifies if a FamilyInstance has an Adaptive Family Symbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static bool HasAdaptiveFamilySymbol(
    FamilyInstance famInst
)
Visual Basic
Public Shared Function HasAdaptiveFamilySymbol ( _
    famInst As FamilyInstance _
) As Boolean
Visual C++
public:
static bool HasAdaptiveFamilySymbol(
    FamilyInstance^ famInst
)

Parameters

famInst
Type: Autodesk.Revit.DB..::..FamilyInstance
The FamilyInstance

Return Value

True if the FamilyInstance has an Adaptive Family Symbol.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

AdaptiveComponentInstanceUtils Class


IsAdaptiveComponentInstance Method

[image]

Revit 2024 API
AdaptiveComponentInstanceUtils..::..IsAdaptiveComponentInstance Method
AdaptiveComponentInstanceUtils Class See Also Send Feedback
Verifies if a FamilyInstance is an Adaptive Component Instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static bool IsAdaptiveComponentInstance(
    FamilyInstance famInst
)
Visual Basic
Public Shared Function IsAdaptiveComponentInstance ( _
    famInst As FamilyInstance _
) As Boolean
Visual C++
public:
static bool IsAdaptiveComponentInstance(
    FamilyInstance^ famInst
)

Parameters

famInst
Type: Autodesk.Revit.DB..::..FamilyInstance
The FamilyInstance

Return Value

True if the FamilyInstance has an Adaptive Component Instances.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

AdaptiveComponentInstanceUtils Class


IsAdaptiveFamilySymbol Method

[image]

Revit 2024 API
AdaptiveComponentInstanceUtils..::..IsAdaptiveFamilySymbol Method
AdaptiveComponentInstanceUtils Class See Also Send Feedback
Verifies if a FamilySymbol is a valid Adaptive Family Symbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static bool IsAdaptiveFamilySymbol(
    FamilySymbol famSymb
)
Visual Basic
Public Shared Function IsAdaptiveFamilySymbol ( _
    famSymb As FamilySymbol _
) As Boolean
Visual C++
public:
static bool IsAdaptiveFamilySymbol(
    FamilySymbol^ famSymb
)

Parameters

famSymb
Type: Autodesk.Revit.DB..::..FamilySymbol
The FamilySymbol

Return Value

True if the FamilySymbol is a valid Adaptive Family Symbol.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

AdaptiveComponentInstanceUtils Class


IsInstanceFlipped Method

[image]

Revit 2024 API
AdaptiveComponentInstanceUtils..::..IsInstanceFlipped Method
AdaptiveComponentInstanceUtils Class See Also Send Feedback
Gets the value of the flip parameter on the adaptive instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static bool IsInstanceFlipped(
    FamilyInstance famInst
)
Visual Basic
Public Shared Function IsInstanceFlipped ( _
    famInst As FamilyInstance _
) As Boolean
Visual C++
public:
static bool IsInstanceFlipped(
    FamilyInstance^ famInst
)

Parameters

famInst
Type: Autodesk.Revit.DB..::..FamilyInstance
The FamilyInstance

Return Value

True if the instance is flipped.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The FamilyInstance famInst is not an Adaptive Family Instance. -or- The FamilyInstance famInst does not have an Adaptive Family Symbol.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

AdaptiveComponentInstanceUtils Class


MoveAdaptiveComponentInstance Method

[image]

Revit 2024 API
AdaptiveComponentInstanceUtils..::..MoveAdaptiveComponentInstance Method
AdaptiveComponentInstanceUtils Class See Also Send Feedback
Moves Adaptive Component Instance by the specified transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static void MoveAdaptiveComponentInstance(
    FamilyInstance famInst,
    Transform trf,
    bool unHost
)
Visual Basic
Public Shared Sub MoveAdaptiveComponentInstance ( _
    famInst As FamilyInstance, _
    trf As Transform, _
    unHost As Boolean _
)
Visual C++
public:
static void MoveAdaptiveComponentInstance(
    FamilyInstance^ famInst,
    Transform^ trf,
    bool unHost
)

Parameters

famInst
Type: Autodesk.Revit.DB..::..FamilyInstance
The FamilyInstance
trf
Type: Autodesk.Revit.DB..::..Transform
The Transformation
unHost
Type: System..::..Boolean
True if the move should disassociate the Point Element Refs from their hosts. False if the Point Element Refs remain hosted.

Remarks

This method will attempt a rigid body motion of all the individual references and hence the instance itself. However if unHost parameter is 'false' and any of the instance's references are hosted to any geometry, then those references will move within the constraints. The instance then adapts to where its references are moved to.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | trf is not a rigid body transformation.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Unable to move the adaptive component instance.

See Also

AdaptiveComponentInstanceUtils Class


AdaptivePointConstraintType Enumeration

[image]

Revit 2024 API
AdaptivePointConstraintType Enumeration
See Also Send Feedback
An enumerated type containing possible constraint types for Adaptive Points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public enum AdaptivePointConstraintType
Visual Basic
Public Enumeration AdaptivePointConstraintType
Visual C++
public enum class AdaptivePointConstraintType

Members

Member name | Description
None | Not constrained.
Plane_YZ | Constrained to the YZ Plane (x=0).
Plane_ZX | Constrained to the ZX Plane (y=0).
Plane_XY | Constrained to the XY Plane (z=0).
Axis_X | Constrained to the X Axis (y=0, z=0).
Axis_Y | Constrained to the Y Axis (x=0, z=0).
Axis_Z | Constrained to the Z Axis (x=0, y=0).

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


AdaptivePointOrientationType Enumeration

[image]

Revit 2024 API
AdaptivePointOrientationType Enumeration
See Also Send Feedback
An enumerated type containing possible orientation types for Adaptive Points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public enum AdaptivePointOrientationType
Visual Basic
Public Enumeration AdaptivePointOrientationType
Visual C++
public enum class AdaptivePointOrientationType

Members

Member name | Description
ToHost | The adaptive point will be oriented to the coordinate system of the geometry the point is hosted on. This option was previously named: HostReferenceStrictly
ToHostAndLoopSystem | The adaptive point will be oriented to the coordinate system of the geometry the point is hosted on. However, the orientation of the Z axis is controlled by the order of placed points. If the placed adaptive points of a component are placed in a different order with respect to the host order, (clockwise instead of counter-clockwise), then the Z axis will invert and the planar projection will flip. This option was previously named: HostReferenceAutoFlip.
ToGlobalZthenHost | The Z axis of the adaptive point will be oriented to the Z axis of the document the instance is placed in. The XY axis are determined by the XY of the geometry the point is hosted on. This option was previously named: PlacementVertical.
ToGlobalXYZ | The adaptive point will be oriented to the coordinate system of the document the instance is placed in. This option was previously named: PlacementOrthogonal
ToInstanceZthenHost | The Z axis of the adaptive point will be oriented to the Z axis of the adaptive family instance the point is part of. The XY axis are determined by the XY of the geometry the point is hosted on. This option was previously named: FamilyVertical
ToInstance | The adaptive point will be oriented to the coordinate system of the adaptive family instance the point is part of. This is the default orientation of adaptive points. This option was previously named: FamilyOrthogonal

Remarks

The default orientation of adaptive points is AdaptivePointOrientationType.ToInstance.

All the items of this enumerated type were renamed for Revit 2016 to better align the names with the corresponding text in the Revit UI. The numeric values of the items weren't modified, allowing existing applications to work. However, to be able to rebuild an application, all point orientations need to be changed to their respective new names.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


AdaptivePointType Enumeration

[image]

Revit 2024 API
AdaptivePointType Enumeration
See Also Send Feedback
An enumerated type containing possible types for Adaptive Points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public enum AdaptivePointType
Visual Basic
Public Enumeration AdaptivePointType
Visual C++
public enum class AdaptivePointType

Members

Member name | Description
ReferencePoint | Reference Point.
PlacementPoint | Placement Point.
ShapeHandlePoint | Shape Handle Point.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


AddInId Class

[image]

Revit 2024 API
AddInId Class
Members See Also Send Feedback
Identifies an AddIn registered with Revit

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class AddInId : IDisposable
Visual Basic
Public Class AddInId _
    Implements IDisposable
Visual C++
public ref class AddInId : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..AddInId

See Also

AddInId Members


Dispose Method

[image]

Revit 2024 API
AddInId..::..Dispose Method
AddInId Class See Also Send Feedback
Releases all resources used by the AddInId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

AddInId Class


GetAddInName Method

[image]

Revit 2024 API
AddInId..::..GetAddInName Method
AddInId Class See Also Send Feedback
name of addin associated with this AddInId Attempts to obtain the name from loaded Third Party AddIns

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public string GetAddInName()
Visual Basic
Public Function GetAddInName As String
Visual C++
public:
String^ GetAddInName()

Return Value

name of addin

See Also

AddInId Class


GetAddInNameFromDocument Method

[image]

Revit 2024 API
AddInId..::..GetAddInNameFromDocument Method
AddInId Class See Also Send Feedback
name of application associated with this ApplicationId First attempts to obtain the name from AddInIds stored in the document. If unsuccessful, attempts to obtain the name from loaded Third Party AddIns.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public string GetAddInNameFromDocument(
    Document aDoc
)
Visual Basic
Public Function GetAddInNameFromDocument ( _
    aDoc As Document _
) As String
Visual C++
public:
String^ GetAddInNameFromDocument(
    Document^ aDoc
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
target document

Return Value

name of application

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AddInId Class


GetGUID Method

[image]

Revit 2024 API
AddInId..::..GetGUID Method
AddInId Class See Also Send Feedback
value of the AddInId as a GUID

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public Guid GetGUID()
Visual Basic
Public Function GetGUID As Guid
Visual C++
public:
Guid GetGUID()

Return Value

GUID value of the AddInId

See Also

AddInId Class


AddInId Properties

[image] [image]

Revit 2024 API
AddInId Properties
AddInId Class See Also Send Feedback

The AddInId type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

AddInId Class


IsValidObject Property

[image]

Revit 2024 API
AddInId..::..IsValidObject Property
AddInId Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

AddInId Class


AllowedValues Enumeration

[image]

Revit 2024 API
AllowedValues Enumeration
See Also Send Feedback
A range of allowed values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014
Since: 2014

Syntax

C#
public enum AllowedValues
Visual Basic
Public Enumeration AllowedValues
Visual C++
public enum class AllowedValues

Members

Member name | Description
NonNegative | Only non-negative values are allowed. A tolerance of 1.0e-9 is used, so very small negative numbers are accepted.
All | All values are allowed.
Positive | Only positive values are allowed. A tolerance of 1.0e-9 is used, so very small positive numbers are rejected.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


AlphanumericRevisionSettings Members

[image] [image]

Revit 2024 API
AlphanumericRevisionSettings Members
AlphanumericRevisionSettings Class Constructors Methods Properties See Also Send Feedback

The AlphanumericRevisionSettings type exposes the following members.

Constructors

 | Name | Description
Public method | AlphanumericRevisionSettings()()()() | Constructs an AlphanumericRevisionSettings with a simple, default sequence.
Public method | AlphanumericRevisionSettings(AlphanumericRevisionSettings) | Constructs a new copy of the input AlphanumericRevisionSettings object.
Public method | AlphanumericRevisionSettings(IList<(Of <<'(String>)>>), String, String) | Constructs an AlphanumericRevisionSettings object.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the AlphanumericRevisionSettings
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSequence | Gets a list containing the strings to be used as the numbering sequence for revisions with the Alphanumeric RevisionNumberType.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Determines whether a specified AlphanumericRevisionSettings is the same as 'this'.
Public method | IsValid | Determines whether the AlphanumericRevisionSettings object is in a valid state.
Public method | SetSequence | Sets the sequence of strings to be used as numbers for revisions with the Alphanumeric RevisionNumberType.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Prefix | The prefix string that will be prepended to the number of each revision with Alphanumeric RevisionNumberingType.
Public property | Suffix | The suffix string that will be appended to the number of each revision with Alphanumeric RevisionNumberingType.

See Also

AlphanumericRevisionSettings Class


AlphanumericRevisionSettings Constructor

[image] [image]

Revit 2024 API
AlphanumericRevisionSettings Constructor
AlphanumericRevisionSettings Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AlphanumericRevisionSettings()()()() | Constructs an AlphanumericRevisionSettings with a simple, default sequence.
Public method | AlphanumericRevisionSettings(AlphanumericRevisionSettings) | Constructs a new copy of the input AlphanumericRevisionSettings object.
Public method | AlphanumericRevisionSettings(IList<(Of <<'(String>)>>), String, String) | Constructs an AlphanumericRevisionSettings object.

See Also

AlphanumericRevisionSettings Class
AlphanumericRevisionSettings Members


AlphanumericRevisionSettings Constructor

[image]

Revit 2024 API
AlphanumericRevisionSettings Constructor
AlphanumericRevisionSettings Class See Also Send Feedback
Constructs an AlphanumericRevisionSettings with a simple, default sequence.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public AlphanumericRevisionSettings()
Visual Basic
Public Sub New
Visual C++
public:
AlphanumericRevisionSettings()

Remarks

The default sequence contains each letter of the alphabet (may differ based on language settings).

See Also

AlphanumericRevisionSettings Class
AlphanumericRevisionSettings Overload


AlphanumericRevisionSettings Constructor (AlphanumericRevisionSettings)

[image]

Revit 2024 API
AlphanumericRevisionSettings Constructor (AlphanumericRevisionSettings)
AlphanumericRevisionSettings Class See Also Send Feedback
Constructs a new copy of the input AlphanumericRevisionSettings object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public AlphanumericRevisionSettings(
    AlphanumericRevisionSettings other
)
Visual Basic
Public Sub New ( _
    other As AlphanumericRevisionSettings _
)
Visual C++
public:
AlphanumericRevisionSettings(
    AlphanumericRevisionSettings^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..AlphanumericRevisionSettings

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | other is not a valid AlphanumericRevisionSettings.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

AlphanumericRevisionSettings Class
AlphanumericRevisionSettings Overload


AlphanumericRevisionSettings Methods

[image] [image]

Revit 2024 API
AlphanumericRevisionSettings Methods
AlphanumericRevisionSettings Class See Also Send Feedback

The AlphanumericRevisionSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSequence | Gets a list containing the strings to be used as the numbering sequence for revisions with the Alphanumeric RevisionNumberType.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Determines whether a specified AlphanumericRevisionSettings is the same as 'this'.
Public method | IsValid | Determines whether the AlphanumericRevisionSettings object is in a valid state.
Public method | SetSequence | Sets the sequence of strings to be used as numbers for revisions with the Alphanumeric RevisionNumberType.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

AlphanumericRevisionSettings Class


Dispose Method

[image]

Revit 2024 API
AlphanumericRevisionSettings..::..Dispose Method
AlphanumericRevisionSettings Class See Also Send Feedback
Releases all resources used by the AlphanumericRevisionSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

AlphanumericRevisionSettings Class


GetSequence Method

[image]

Revit 2024 API
AlphanumericRevisionSettings..::..GetSequence Method
AlphanumericRevisionSettings Class See Also Send Feedback
Gets a list containing the strings to be used as the numbering sequence for revisions with the Alphanumeric RevisionNumberType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public IList<string> GetSequence()
Visual Basic
Public Function GetSequence As IList(Of String)
Visual C++
public:
IList<String^>^ GetSequence()

See Also

AlphanumericRevisionSettings Class


IsEqual Method

[image]

Revit 2024 API
AlphanumericRevisionSettings..::..IsEqual Method
AlphanumericRevisionSettings Class See Also Send Feedback
Determines whether a specified AlphanumericRevisionSettings is the same as 'this'.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool IsEqual(
    AlphanumericRevisionSettings other
)
Visual Basic
Public Function IsEqual ( _
    other As AlphanumericRevisionSettings _
) As Boolean
Visual C++
public:
bool IsEqual(
    AlphanumericRevisionSettings^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..AlphanumericRevisionSettings
The AlphanumericRevisionSettings object to be compared with 'this'.

Return Value

True, if two AlphanumericRevisionSettings are the same.

Remarks

The two AlphanumericRevisionSettings are regarded as the same only if they have the same revision numbering sequence, and the same prefix and suffix strings.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

AlphanumericRevisionSettings Class


IsValid Method

[image]

Revit 2024 API
AlphanumericRevisionSettings..::..IsValid Method
AlphanumericRevisionSettings Class See Also Send Feedback
Determines whether the AlphanumericRevisionSettings object is in a valid state.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool IsValid()
Visual Basic
Public Function IsValid As Boolean
Visual C++
public:
bool IsValid()

Return Value

True if the settings are valid.

Remarks

The AlphanumericRevisionSettings should have at least one string in its revision numbering sequence.

See Also

AlphanumericRevisionSettings Class


SetSequence Method

[image]

Revit 2024 API
AlphanumericRevisionSettings..::..SetSequence Method
AlphanumericRevisionSettings Class See Also Send Feedback
Sets the sequence of strings to be used as numbers for revisions with the Alphanumeric RevisionNumberType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public void SetSequence(
    IList<string> sequence
)
Visual Basic
Public Sub SetSequence ( _
    sequence As IList(Of String) _
)
Visual C++
public:
void SetSequence(
    IList<String^>^ sequence
)

Parameters

sequence
Type: System.Collections.Generic..::..IList<(Of <(<'String>)>)>
The sequence. The sequence strings cannot contain commas.

Remarks

If there are more alphanumeric revisions than there are strings in the sequence, subsequent alphanumeric revisions will be assigned duplicated characters. For example, if the sequence provided were ["X", "Y"], the first alphanumeric revision would be shown as "X", the second as "Y", the third as "XX", then "YY", "XXX", etc.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Input sequence contains invalid entries.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

AlphanumericRevisionSettings Class


IsValidObject Property

[image]

Revit 2024 API
AlphanumericRevisionSettings..::..IsValidObject Property
AlphanumericRevisionSettings Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

AlphanumericRevisionSettings Class


Prefix Property

[image]

Revit 2024 API
AlphanumericRevisionSettings..::..Prefix Property
AlphanumericRevisionSettings Class See Also Send Feedback
The prefix string that will be prepended to the number of each revision with Alphanumeric RevisionNumberingType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public string Prefix { get; set; }
Visual Basic
Public Property Prefix As String
    Get
    Set
Visual C++
public:
property String^ Prefix {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

AlphanumericRevisionSettings Class


Suffix Property

[image]

Revit 2024 API
AlphanumericRevisionSettings..::..Suffix Property
AlphanumericRevisionSettings Class See Also Send Feedback
The suffix string that will be appended to the number of each revision with Alphanumeric RevisionNumberingType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public string Suffix { get; set; }
Visual Basic
Public Property Suffix As String
    Get
    Set
Visual C++
public:
property String^ Suffix {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

AlphanumericRevisionSettings Class


AlternateUnits Enumeration

[image]

Revit 2024 API
AlternateUnits Enumeration
See Also Send Feedback
An enumerated type listing the locations where Alternate units may be displayed in dimensions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum AlternateUnits
Visual Basic
Public Enumeration AlternateUnits
Visual C++
public enum class AlternateUnits

Members

Member name | Description
None | No alternative units.
Right | Alternative units display to the right of the primary units.
Below | Alternative units display below the primary units.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


AnalyzesAsType Enumeration

[image]

Revit 2024 API
AnalyzesAsType Enumeration
See Also Send Feedback
This enum class is used for the BuiltInParameter STRUCTURAL_ANALYZES_AS.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum AnalyzesAsType
Visual Basic
Public Enumeration AnalyzesAsType
Visual C++
public enum class AnalyzesAsType

Members

Member name | Description
AA_Hanger |
AA_Gravity |
AA_Lateral |
AA_SlabOneWay |
AA_Mat |
AA_SlabOnGrade |
AA_Not_For_Analysis |
AA_SlabTwoWay |
AA_GravityLateral |

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


AngularDimension Class

[image]

Revit 2024 API
AngularDimension Class
Members See Also Send Feedback
An object that represents an Angular Dimension within the Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public class AngularDimension : Dimension
Visual Basic
Public Class AngularDimension _
    Inherits Dimension
Visual C++
public ref class AngularDimension : public Dimension

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..Dimension
Autodesk.Revit.DB..::..AngularDimension

See Also

AngularDimension Members


AngularDimension Members

[image] [image]

Revit 2024 API
AngularDimension Members
AngularDimension Class Methods Properties See Also Send Feedback

The AngularDimension type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create | Creates a new instance of an Angular Dimension element within the project.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasOneSegment | Determines whether a dimension has one segment. (Inherited from Dimension.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsTextPositionAdjustable | Indicates if this dimension is supported to set/get TextPosition/LeaderEndPosition. (Inherited from Dimension.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | ResetTextPosition | Resets the text position of the dimension to the initial position determined by its type and parameters. (Inherited from Dimension.)
Public method | SetAngularRadius | Set radius of an Angular Dimension arc. The new radius of the arc.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Above | The text shown above the segment's value. (Inherited from Dimension.)
Public property | AreReferencesAvailable | Indicates if this dimension's references can be resolved. (Inherited from Dimension.)
Public property | AreSegmentsEqual | Indicates if all segments are forced to be equal. (Inherited from Dimension.)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | Below | The text shown below the segment's value. (Inherited from Dimension.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | Curve | A curve that represents the dimension line. (Inherited from Dimension.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DimensionShape | The shape of this dimension. (Inherited from Dimension.)
Public property | DimensionType | The dimension style of this dimension. (Inherited from Dimension.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyLabel | The family parameter label of the dimension. (Inherited from Dimension.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | HasLeader | True if dimension has leader, false otherwise. (Inherited from Dimension.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsLocked | Indicates if this dimension is locked. (Inherited from Dimension.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValid | Indicates if this dimension is valid. (Inherited from Dimension.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LeaderEndPosition | The position of the dimension's leader end point. (Inherited from Dimension.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Retrieves or changes the name associated with the Dimension. (Inherited from Dimension.)
Public property | NumberOfSegments | The number of segments for the dimension. (Inherited from Dimension.)
Public property | Origin | The dimension origin. (Inherited from Dimension.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Prefix | The text shown before the segment's value. (Inherited from Dimension.)
Public property | References | Returns an array of geometric references to which the dimension is attached. (Inherited from Dimension.)
Public property | Segments | The segments in the dimension. (Inherited from Dimension.)
Public property | Suffix | The text shown after the segment's value. (Inherited from Dimension.)
Public property | TextPosition | The position of the dimension text's drag point. (Inherited from Dimension.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | Value | The value of the dimension. (Inherited from Dimension.)
Public property | ValueOverride | The text that replaces the segment's value. (Inherited from Dimension.)
Public property | ValueString | The dimension value as a user visible string. (Inherited from Dimension.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | View | Supplies the view that contains the dimension if the dimension is view specific. (Inherited from Dimension.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

AngularDimension Class


AngularDimension Methods

[image] [image]

Revit 2024 API
AngularDimension Methods
AngularDimension Class See Also Send Feedback

The AngularDimension type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create | Creates a new instance of an Angular Dimension element within the project.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasOneSegment | Determines whether a dimension has one segment. (Inherited from Dimension.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsTextPositionAdjustable | Indicates if this dimension is supported to set/get TextPosition/LeaderEndPosition. (Inherited from Dimension.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | ResetTextPosition | Resets the text position of the dimension to the initial position determined by its type and parameters. (Inherited from Dimension.)
Public method | SetAngularRadius | Set radius of an Angular Dimension arc. The new radius of the arc.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

AngularDimension Class


Create Method

[image]

Revit 2024 API
AngularDimension..::..Create Method
AngularDimension Class See Also Send Feedback
Creates a new instance of an Angular Dimension element within the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public static AngularDimension Create(
    Document document,
    View dbView,
    Arc arc,
    IList<Reference> references,
    DimensionType dimensionStyle
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    dbView As View, _
    arc As Arc, _
    references As IList(Of Reference), _
    dimensionStyle As DimensionType _
) As AngularDimension
Visual C++
public:
static AngularDimension^ Create(
    Document^ document,
    View^ dbView,
    Arc^ arc,
    IList<Reference^>^ references,
    DimensionType^ dimensionStyle
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document where new Angular Dimension is created.
dbView
Type: Autodesk.Revit.DB..::..View
The view in which the Angular Dimension will appear.
arc
Type: Autodesk.Revit.DB..::..Arc
Arc for the Angular Dimension.
references
Type: System.Collections.Generic..::..IList<(Of <(<' Reference >)>)>
The references which the Angular Dimension will witness.
dimensionStyle
Type: Autodesk.Revit.DB..::..DimensionType
Dimension Style.

Return Value

The newly created Angular Dimension instance, or nullNothingnullptra null reference (Nothing in Visual Basic) if the operation fails.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | References should be: at least two, non parallel and rays of the arc passed.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

AngularDimension Class


SetAngularRadius Method

[image]

Revit 2024 API
AngularDimension..::..SetAngularRadius Method
AngularDimension Class See Also Send Feedback
Set radius of an Angular Dimension arc. The new radius of the arc.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public void SetAngularRadius(
    double radius
)
Visual Basic
Public Sub SetAngularRadius ( _
    radius As Double _
)
Visual C++
public:
void SetAngularRadius(
    double radius
)

Parameters

radius
Type: System..::..Double

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given value for radius must be non-negative.

See Also

AngularDimension Class


AnnotationSymbol Class

[image]

Revit 2024 API
AnnotationSymbol Class
Members See Also Send Feedback
This object represents a symbol of the Generic Annotation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class AnnotationSymbol : FamilyInstance
Visual Basic
Public Class AnnotationSymbol _
    Inherits FamilyInstance
Visual C++
public ref class AnnotationSymbol : public FamilyInstance

Remarks

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..Instance
Autodesk.Revit.DB..::..FamilyInstance
Autodesk.Revit.DB..::..AnnotationSymbol

See Also

AnnotationSymbol Members


AnnotationSymbol Methods

[image] [image]

Revit 2024 API
AnnotationSymbol Methods
AnnotationSymbol Class See Also Send Feedback

The AnnotationSymbol type exposes the following members.

Methods

 | Name | Description
Public method | AddCoping | Adds a coping (cut) to a steel beam. (Inherited from FamilyInstance.)
Public method | addLeader | add a leader to this annotation symbol.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | duplicate | Duplicate this annotation symbol.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | flipFacing | The orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true. (Inherited from FamilyInstance.)
Public method | FlipFromToRoom | Flips the settings of "From Room" and "To Room" for the door or window instance. (Inherited from FamilyInstance.)
Public method | flipHand | The orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true. (Inherited from FamilyInstance.)
Public method | GetCopingIds | Lists the elements currently used as coping cutters for this element. (Inherited from FamilyInstance.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetFamilyPointPlacementReferences | Returns the Point Placement References for the Family Instance. (Inherited from FamilyInstance.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLeaders | Returns a collection of leaders currently attached to the annotation.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetOriginalGeometry | Returns the original geometry of the instance, before the instance is modified by joins, cuts, coping, extensions, or other post-processing. (Inherited from FamilyInstance.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetReferenceByName | Gets the family instance reference corresponding to the named reference plane in the instance's family. (Inherited from FamilyInstance.)
Public method | GetReferenceName | Gets the name of the reference plane in the family corresponding to the given family instance reference. (Inherited from FamilyInstance.)
Public method | GetReferences | Gets family instance references corresponding to the reference planes or reference lines of the given reference type in the instance's family. (Inherited from FamilyInstance.)
Public method | GetReferenceType | Gets the type of the reference plane or reference line in the instance's family corresponding to the given family instance reference. (Inherited from FamilyInstance.)
Public method | GetSpatialElementCalculationPoint | Gets the location of the calculation point for this instance. (Inherited from FamilyInstance.)
Public method | GetSpatialElementFromToCalculationPoints | Gets the locations for the calculation points for this instance. (Inherited from FamilyInstance.)
Public method | GetSubComponentIds | Gets the sub component ElementIds of the current family instance. (Inherited from FamilyInstance.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetSweptProfile | Gets the object that describes the profile that is swept along the driving curve for this instance. (Inherited from FamilyInstance.)
Public method | GetTotalTransform | Gets the total transform, which includes the true north transform for instances like import instances. (Inherited from Instance.)
Public method | GetTransform | Gets the transform of the instance. (Inherited from Instance.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasModifiedGeometry | Identifies if the geometry of this FamilyInstance has been modified from the automatically generated default. (Inherited from FamilyInstance.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasSweptProfile | Indicates if this instance can be represented as a swept profile. (Inherited from FamilyInstance.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | RemoveCoping | Removes a coping (cut) from a steel beam. (Inherited from FamilyInstance.)
Public method | removeLeader | remove a leader of this annotation symbol.
Public method | rotate | The family instance will be flipped by 180 degrees. If it can not be rotated, return false, otherwise return true. (Inherited from FamilyInstance.)
Public method | SetCopingIds | Specifies the set of coping cutters on this element. (Inherited from FamilyInstance.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | Split | Splits the family instance element at a point on its defining curve. (Inherited from FamilyInstance.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

AnnotationSymbol Class


addLeader Method

[image]

Revit 2024 API
AnnotationSymbol..::..addLeader Method
AnnotationSymbol Class See Also Send Feedback
add a leader to this annotation symbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void addLeader()
Visual Basic
Public Sub addLeader
Visual C++
public:
void addLeader()

See Also

AnnotationSymbol Class


duplicate Method

[image]

Revit 2024 API
AnnotationSymbol..::..duplicate Method
AnnotationSymbol Class See Also Send Feedback
Duplicate this annotation symbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public AnnotationSymbol duplicate()
Visual Basic
Public Function duplicate As AnnotationSymbol
Visual C++
public:
AnnotationSymbol^ duplicate()

Return Value

Pointer to the new annotation symbol.

See Also

AnnotationSymbol Class


GetLeaders Method

[image]

Revit 2024 API
AnnotationSymbol..::..GetLeaders Method
AnnotationSymbol Class See Also Send Feedback
Returns a collection of leaders currently attached to the annotation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public IList<Leader> GetLeaders()
Visual Basic
Public Function GetLeaders As IList(Of Leader)
Visual C++
public:
IList<Leader^>^ GetLeaders()

Remarks

This method supersedes an older Leaders property which has been deprecated.

See Also

AnnotationSymbol Class


removeLeader Method

[image]

Revit 2024 API
AnnotationSymbol..::..removeLeader Method
AnnotationSymbol Class See Also Send Feedback
remove a leader of this annotation symbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void removeLeader()
Visual Basic
Public Sub removeLeader
Visual C++
public:
void removeLeader()

See Also

AnnotationSymbol Class


AnnotationSymbol Properties

[image] [image]

Revit 2024 API
AnnotationSymbol Properties
AnnotationSymbol Class See Also Send Feedback

The AnnotationSymbol type exposes the following members.

Properties

 | Name | Description
Public property | AnnotationSymbolType | The AnnotationSymbol style of this AnnotationSymbol.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanFlipFacing | Property to test whether the orientation of family instance facing can be flipped. (Inherited from FamilyInstance.)
Public property | CanFlipHand | Property to test whether the orientation of family instance hand can be flipped. (Inherited from FamilyInstance.)
Public property | CanFlipWorkPlane | Identifies if the instance can flip its work plane. (Inherited from FamilyInstance.)
Public property | CanRotate | Property to test whether the family instance can be rotated by 180 degrees. (Inherited from FamilyInstance.)
Public property | CanSplit | Identifies whether a particular family instance can be split at a point on it's defining curve (by Split(Double)). (Inherited from FamilyInstance.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | ExtensionUtility | Property to check whether the instance can be extended and return the interface for extension operation. (Inherited from FamilyInstance.)
Public property | FacingFlipped | Property to test whether the orientation of family instance facing is flipped. (Inherited from FamilyInstance.)
Public property | FacingOrientation | Property to get the orientation of family instance facing. (Inherited from FamilyInstance.)
Public property | FromRoom | The "From Room" set for the door or window in the last phase of the project. (Inherited from FamilyInstance.)
Public property | FromRoom[([( Phase])]) | (Inherited from FamilyInstance.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | HandFlipped | Property to test whether the orientation of family instance hand is flipped. (Inherited from FamilyInstance.)
Public property | HandOrientation | Property to get the orientation of family instance hand. (Inherited from FamilyInstance.)
Public property | HasSpatialElementCalculationPoint | Identifies if this instance has a single SpatialElementCalculationPoint used as the search point for Revit to identify if the instance is inside a room or space. (Inherited from FamilyInstance.)
Public property | HasSpatialElementFromToCalculationPoints | Identifies if this instance has a pair of SpatialElementCalculationPoints used as the search points for Revit to identify if the instance lies between up to two rooms or spaces. (Inherited from FamilyInstance.)
Public property | Host | If the instance is contained within another element, this property returns the containing element. An instance that is face hosted will return the element containing the face. (Inherited from FamilyInstance.)
Public property | HostFace | Property to get the reference to the host face of family instance. (Inherited from FamilyInstance.)
Public property | HostParameter | If the instance is hosted by a wall, this property returns the parameter value of the insertion point of the instance along the wall's location curve, as long as the family of the instance isn't work plane based. (Inherited from FamilyInstance.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | Invisible | Property to test whether the family instance is invisible. (Inherited from FamilyInstance.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsSlantedColumn | Indicates if the family instance is a slanted column. (Inherited from FamilyInstance.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | IsWorkPlaneFlipped | Identifies if the instance's work plane is flipped. (Inherited from FamilyInstance.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an instance within project. (Inherited from FamilyInstance.)
Public property | MEPModel | Retrieves the MEP model for the family instance. (Inherited from FamilyInstance.)
Public property | Mirrored | Property to test whether the family instance is mirrored. (only one axis is flipped) (Inherited from FamilyInstance.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Room | The room in which the instance is located (during the last phase of the project). (Inherited from FamilyInstance.)
Public property | Room[([( Phase])]) | (Inherited from FamilyInstance.)
Public property | Space | The space in which the instance is located (during the last phase of the project). (Inherited from FamilyInstance.)
Public property | Space[([( Phase])]) | (Inherited from FamilyInstance.)
Public property | StructuralMaterialId | Identifies the material that defines the instance's structural analysis properties. (Inherited from FamilyInstance.)
Public property | StructuralMaterialType | This property returns the physical material from which the instance is made. (Inherited from FamilyInstance.)
Public property | StructuralType | Provides the primary structural type of the instance, such as beam or column etc. (Inherited from FamilyInstance.)
Public property | StructuralUsage | Provides the primary structural usage of the instance, such as brace, girder etc. (Inherited from FamilyInstance.)
Public property | SuperComponent | Property to get the super component of current family instance. (Inherited from FamilyInstance.)
Public property | Symbol | Returns or changes the FamilySymbol object that represents the type of the instance. (Inherited from FamilyInstance.)
Public property | ToRoom | The "To Room" set for the door or window in the last phase of the project. (Inherited from FamilyInstance.)
Public property | ToRoom[([( Phase])]) | (Inherited from FamilyInstance.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

AnnotationSymbol Class


AnnotationSymbolType Property

[image]

Revit 2024 API
AnnotationSymbol..::..AnnotationSymbolType Property
AnnotationSymbol Class See Also Send Feedback
The AnnotationSymbol style of this AnnotationSymbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public AnnotationSymbolType AnnotationSymbolType { get; set; }
Visual Basic
Public Property AnnotationSymbolType As AnnotationSymbolType
    Get
    Set
Visual C++
public:
property AnnotationSymbolType^ AnnotationSymbolType {
    AnnotationSymbolType^ get ();
    void set (AnnotationSymbolType^ value);
}

Remarks

The AnnotationSymbolType property can be used to retrieve the kind of the symbol. This property can also be used to change the type of an annotation by setting it to a different type. All the annotation symbol types in the project can be found using the Document.AnnotationSymbolTypes property.

See Also

AnnotationSymbol Class


Room Property

[image] [image]

Revit 2024 API
AnnotationSymbol..::..Room Property
AnnotationSymbol Class See Also Send Feedback
The room in which the instance is located.

Overload List

 | Name | Description
Public property | Room | The room in which the instance is located (during the last phase of the project). (Inherited from FamilyInstance.)
Public property | Room[([( Phase])]) | (Inherited from FamilyInstance.)

See Also

AnnotationSymbol Class
AnnotationSymbol Members


Space Property

[image] [image]

Revit 2024 API
AnnotationSymbol..::..Space Property
AnnotationSymbol Class See Also Send Feedback
The space in which the instance is located.

Overload List

 | Name | Description
Public property | Space | The space in which the instance is located (during the last phase of the project). (Inherited from FamilyInstance.)
Public property | Space[([( Phase])]) | (Inherited from FamilyInstance.)

See Also

AnnotationSymbol Class
AnnotationSymbol Members


ToRoom Property

[image] [image]

Revit 2024 API
AnnotationSymbol..::..ToRoom Property
AnnotationSymbol Class See Also Send Feedback
The "To Room" set for the door or window.

Overload List

 | Name | Description
Public property | ToRoom | The "To Room" set for the door or window in the last phase of the project. (Inherited from FamilyInstance.)
Public property | ToRoom[([( Phase])]) | (Inherited from FamilyInstance.)

See Also

AnnotationSymbol Class
AnnotationSymbol Members


AnnotationSymbolType Class

[image]

Revit 2024 API
AnnotationSymbolType Class
Members See Also Send Feedback
An object that represents an annotation style.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class AnnotationSymbolType : FamilySymbol
Visual Basic
Public Class AnnotationSymbolType _
    Inherits FamilySymbol
Visual C++
public ref class AnnotationSymbolType : public FamilySymbol

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..InsertableObject
Autodesk.Revit.DB..::..FamilySymbol
Autodesk.Revit.DB..::..AnnotationSymbolType

See Also

AnnotationSymbolType Members


AnnotationSymbolType Methods

[image] [image]

Revit 2024 API
AnnotationSymbolType Methods
AnnotationSymbolType Class See Also Send Feedback

The AnnotationSymbolType type exposes the following members.

Methods

 | Name | Description
Public method | Activate | Activates the symbol to ensure that its geometry is accessible. (Inherited from FamilySymbol.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveStructuralSection | Identifies if this FamilySymbol can have a structural section. (Inherited from FamilySymbol.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetFamilyPointLocations | Returns the Point Locations for the Family Symbol. (Inherited from FamilySymbol.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetStructuralSection | Gets the structural section from element. (Inherited from FamilySymbol.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetThermalProperties | Gets the thermal properties for the given FamilySymbol. (Inherited from FamilySymbol.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasThermalProperties | Identifies if this FamilySymbol can include thermal properties. (Inherited from FamilySymbol.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetStructuralSection | Sets the structural section in element. (Inherited from FamilySymbol.)
Public method | SetThermalProperties | Sets the thermal properties for the given FamilySymbol. (Inherited from FamilySymbol.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

AnnotationSymbolType Class


AnnotationSymbolType Properties

[image] [image]

Revit 2024 API
AnnotationSymbolType Properties
AnnotationSymbolType Class See Also Send Feedback

The AnnotationSymbolType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Family | The Family object to which the symbol belongs. (Inherited from FamilySymbol.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsActive | Identifies whether the symbol is active. (Inherited from FamilySymbol.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | StructuralMaterialType | This property returns the physical material from which the type is made. (Inherited from FamilySymbol.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

AnnotationSymbolType Class


Parameter Property

[image] [image]

Revit 2024 API
AnnotationSymbolType..::..Parameter Property
AnnotationSymbolType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

AnnotationSymbolType Class
AnnotationSymbolType Members


APIObject Class

[image]

Revit 2024 API
APIObject Class
Members See Also Send Feedback
Supports all objects in the Autodesk Revit API hierarchy.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class APIObject : IDisposable
Visual Basic
Public Class APIObject _
    Implements IDisposable
Visual C++
public ref class APIObject : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.Creation..::..Application
Autodesk.Revit.Creation..::..ItemFactoryBase
Autodesk.Revit.DB..::..Binding
Autodesk.Revit.DB..::..BoundingBoxXYZ
Autodesk.Revit.DB..::..Category
Autodesk.Revit.DB..::..CategoryNameMap
Autodesk.Revit.DB..::..CategoryNameMapIterator
Autodesk.Revit.DB..::..CategorySet
Autodesk.Revit.DB..::..CategorySetIterator
Autodesk.Revit.DB..::..City
Autodesk.Revit.DB..::..CitySet
Autodesk.Revit.DB..::..CitySetIterator
Autodesk.Revit.DB..::..Color
Autodesk.Revit.DB..::..CombinableElementArray
Autodesk.Revit.DB..::..CombinableElementArrayIterator
Autodesk.Revit.DB..::..ConnectorSet
Autodesk.Revit.DB..::..ConnectorSetIterator
Autodesk.Revit.DB..::..CurtainCell
Autodesk.Revit.DB..::..CurtainGrid
Autodesk.Revit.DB..::..CurtainGridSet
Autodesk.Revit.DB..::..CurtainGridSetIterator
Autodesk.Revit.DB..::..CurveArrArray
Autodesk.Revit.DB..::..CurveArrArrayIterator
Autodesk.Revit.DB..::..CurveArray
Autodesk.Revit.DB..::..CurveArrayIterator
Autodesk.Revit.DB..::..CurveByPointsArray
Autodesk.Revit.DB..::..CurveByPointsArrayIterator
Autodesk.Revit.DB..::..DefinitionBindingMap
Autodesk.Revit.DB..::..DefinitionBindingMapIterator
Autodesk.Revit.DB..::..DefinitionFile
Autodesk.Revit.DB..::..DefinitionGroup
Autodesk.Revit.DB..::..DetailCurveArray
Autodesk.Revit.DB..::..DetailCurveArrayIterator
Autodesk.Revit.DB..::..DimensionSegment
Autodesk.Revit.DB..::..DimensionSegmentArray
Autodesk.Revit.DB..::..DimensionSegmentArrayIterator
Autodesk.Revit.DB..::..DocumentSet
Autodesk.Revit.DB..::..DocumentSetIterator
Autodesk.Revit.DB..::..DoubleArray
Autodesk.Revit.DB..::..DoubleArrayIterator
Autodesk.Revit.DB..::..EdgeArray
Autodesk.Revit.DB..::..EdgeArrayArray
Autodesk.Revit.DB..::..EdgeArrayArrayIterator
Autodesk.Revit.DB..::..EdgeArrayIterator
Autodesk.Revit.DB.Electrical..::..CorrectionFactor
Autodesk.Revit.DB.Electrical..::..CorrectionFactorSet
Autodesk.Revit.DB.Electrical..::..CorrectionFactorSetIterator
Autodesk.Revit.DB.Electrical..::..DistributionSysTypeSet
Autodesk.Revit.DB.Electrical..::..DistributionSysTypeSetIterator
Autodesk.Revit.DB.Electrical..::..GroundConductorSize
Autodesk.Revit.DB.Electrical..::..GroundConductorSizeSet
Autodesk.Revit.DB.Electrical..::..GroundConductorSizeSetIterator
Autodesk.Revit.DB.Electrical..::..InsulationTypeSet
Autodesk.Revit.DB.Electrical..::..InsulationTypeSetIterator
Autodesk.Revit.DB.Electrical..::..TemperatureRatingTypeSet
Autodesk.Revit.DB.Electrical..::..TemperatureRatingTypeSetIterator
Autodesk.Revit.DB.Electrical..::..VoltageTypeSet
Autodesk.Revit.DB.Electrical..::..VoltageTypeSetIterator
Autodesk.Revit.DB.Electrical..::..WireConduitType
Autodesk.Revit.DB.Electrical..::..WireConduitTypeSet
Autodesk.Revit.DB.Electrical..::..WireConduitTypeSetIterator
Autodesk.Revit.DB.Electrical..::..WireMaterialTypeSet
Autodesk.Revit.DB.Electrical..::..WireMaterialTypeSetIterator
Autodesk.Revit.DB.Electrical..::..WireSet
Autodesk.Revit.DB.Electrical..::..WireSetIterator
Autodesk.Revit.DB.Electrical..::..WireSize
Autodesk.Revit.DB.Electrical..::..WireSizeSet
Autodesk.Revit.DB.Electrical..::..WireSizeSetIterator
Autodesk.Revit.DB.Electrical..::..WireTypeSet
Autodesk.Revit.DB.Electrical..::..WireTypeSetIterator
Autodesk.Revit.DB..::..ElementArray
Autodesk.Revit.DB..::..ElementArrayIterator
Autodesk.Revit.DB..::..ElementSet
Autodesk.Revit.DB..::..ElementSetIterator
Autodesk.Revit.DB..::..FaceArray
Autodesk.Revit.DB..::..FaceArrayIterator
Autodesk.Revit.DB..::..FamilyElementVisibility
Autodesk.Revit.DB..::..FamilyManager
Autodesk.Revit.DB..::..FamilyParameter
Autodesk.Revit.DB..::..FamilyParameterSet
Autodesk.Revit.DB..::..FamilyParameterSetIterator
Autodesk.Revit.DB..::..FamilyPointLocation
Autodesk.Revit.DB..::..FamilyPointPlacementReference
Autodesk.Revit.DB..::..FamilyType
Autodesk.Revit.DB..::..FamilyTypeSet
Autodesk.Revit.DB..::..FamilyTypeSetIterator
Autodesk.Revit.DB..::..FormArray
Autodesk.Revit.DB..::..FormArrayIterator
Autodesk.Revit.DB..::..GeomCombinationSet
Autodesk.Revit.DB..::..GeomCombinationSetIterator
Autodesk.Revit.DB..::..GeometryObject
Autodesk.Revit.DB..::..GroupSet
Autodesk.Revit.DB..::..GroupSetIterator
Autodesk.Revit.DB..::..IntersectionResult
Autodesk.Revit.DB..::..IntersectionResultArray
Autodesk.Revit.DB..::..IntersectionResultArrayIterator
Autodesk.Revit.DB..::..LayoutRule
Autodesk.Revit.DB..::..Leader
Autodesk.Revit.DB..::..LeaderArray
Autodesk.Revit.DB..::..LeaderArrayIterator
Autodesk.Revit.DB..::..Location
Autodesk.Revit.DB.Mechanical..::..MEPBuildingConstructionSet
Autodesk.Revit.DB.Mechanical..::..MEPBuildingConstructionSetIterator
Autodesk.Revit.DB.Mechanical..::..SpaceSet
Autodesk.Revit.DB.Mechanical..::..SpaceSetIterator
Autodesk.Revit.DB..::..MEPModel
Autodesk.Revit.DB..::..ModelCurveArrArray
Autodesk.Revit.DB..::..ModelCurveArrArrayIterator
Autodesk.Revit.DB..::..ModelCurveArray
Autodesk.Revit.DB..::..ModelCurveArrayIterator
Autodesk.Revit.DB..::..MullionTypeSet
Autodesk.Revit.DB..::..MullionTypeSetIterator
Autodesk.Revit.DB..::..Options
Autodesk.Revit.DB..::..PanelTypeSet
Autodesk.Revit.DB..::..PanelTypeSetIterator
Autodesk.Revit.DB..::..PaperSize
Autodesk.Revit.DB..::..PaperSizeSet
Autodesk.Revit.DB..::..PaperSizeSetIterator
Autodesk.Revit.DB..::..PaperSource
Autodesk.Revit.DB..::..PaperSourceSet
Autodesk.Revit.DB..::..PaperSourceSetIterator
Autodesk.Revit.DB..::..Parameter
Autodesk.Revit.DB..::..ParameterMap
Autodesk.Revit.DB..::..ParameterMapIterator
Autodesk.Revit.DB..::..ParameterSet
Autodesk.Revit.DB..::..ParameterSetIterator
Autodesk.Revit.DB..::..PhaseArray
Autodesk.Revit.DB..::..PhaseArrayIterator
Autodesk.Revit.DB..::..PlanCircuit
Autodesk.Revit.DB..::..PlanCircuitSet
Autodesk.Revit.DB..::..PlanCircuitSetIterator
Autodesk.Revit.DB..::..PlanTopology
Autodesk.Revit.DB..::..PlanTopologySet
Autodesk.Revit.DB..::..PlanTopologySetIterator
Autodesk.Revit.DB..::..PrintManager
Autodesk.Revit.DB..::..PrintParameters
Autodesk.Revit.DB..::..PrintSetup
Autodesk.Revit.DB..::..ProjectLocationSet
Autodesk.Revit.DB..::..ProjectLocationSetIterator
Autodesk.Revit.DB..::..Reference
Autodesk.Revit.DB..::..ReferenceArray
Autodesk.Revit.DB..::..ReferenceArrayArray
Autodesk.Revit.DB..::..ReferenceArrayArrayIterator
Autodesk.Revit.DB..::..ReferenceArrayIterator
Autodesk.Revit.DB..::..ReferencePointArray
Autodesk.Revit.DB..::..ReferencePointArrayIterator
Autodesk.Revit.DB..::..Settings
Autodesk.Revit.DB..::..SlabShapeCreaseArray
Autodesk.Revit.DB..::..SlabShapeCreaseArrayIterator
Autodesk.Revit.DB..::..SlabShapeVertexArray
Autodesk.Revit.DB..::..SlabShapeVertexArrayIterator
Autodesk.Revit.DB..::..SpacingRule
Autodesk.Revit.DB.Steel..::..SteelElementProperties
Autodesk.Revit.DB..::..SweepProfile
Autodesk.Revit.DB..::..SymbolicCurveArray
Autodesk.Revit.DB..::..SymbolicCurveArrayIterator
Autodesk.Revit.DB..::..TemporaryViewModes
Autodesk.Revit.DB..::..ThermalProperties
Autodesk.Revit.DB..::..TilePatterns
Autodesk.Revit.DB..::..Transform
Autodesk.Revit.DB..::..VertexIndexPairArray
Autodesk.Revit.DB..::..VertexIndexPairArrayIterator
Autodesk.Revit.DB..::..ViewSet
Autodesk.Revit.DB..::..ViewSetIterator
Autodesk.Revit.DB..::..ViewSheetSetting
Autodesk.Revit.DB.Visual..::..AssetSet
Autodesk.Revit.DB.Visual..::..AssetSetIterator
Autodesk.Revit.UI.Events..::..DialogBoxData
Autodesk.Revit.UI..::..ExternalApplicationArray
Autodesk.Revit.UI..::..ExternalApplicationArrayIterator
Autodesk.Revit.UI..::..ExternalCommandData
Autodesk.Revit.UI..::..TaskDialog

See Also

APIObject Members


APIObject Members

[image] [image]

Revit 2024 API
APIObject Members
APIObject Class Methods Properties See Also Send Feedback

The APIObject type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable.

See Also

APIObject Class


APIObject Methods

[image] [image]

Revit 2024 API
APIObject Methods
APIObject Class See Also Send Feedback

The APIObject type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

APIObject Class


Dispose Method

[image]

Revit 2024 API
APIObject..::..Dispose Method
APIObject Class See Also Send Feedback
Causes the object to release immediately any resources it may be utilizing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

Remarks

This method is usually called implicitly by the programming language when the object is destroyed. After calling this method the object will no longer work correctly.

See Also

APIObject Class


APIObject Properties

[image] [image]

Revit 2024 API
APIObject Properties
APIObject Class See Also Send Feedback

The APIObject type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable.

See Also

APIObject Class


AppearanceAssetElement Class

[image]

Revit 2024 API
AppearanceAssetElement Class
Members See Also Send Feedback
An element that contains a rendering asset used as a portion of a material definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class AppearanceAssetElement : Element
Visual Basic
Public Class AppearanceAssetElement _
    Inherits Element
Visual C++
public ref class AppearanceAssetElement : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..AppearanceAssetElement

See Also

AppearanceAssetElement Members


AppearanceAssetElement Methods

[image] [image]

Revit 2024 API
AppearanceAssetElement Methods
AppearanceAssetElement Class See Also Send Feedback

The AppearanceAssetElement type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create | Creates a new AppearanceAssetElement from an existing rendering asset.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates the appearance asset element.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
 | GetAppearanceAssetElementByName | Gets an AppearanceAssetElement by name.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetRenderingAsset | Gets the rendering asset for the appearance asset element.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetRenderingAsset | Sets the rendering asset for the appearance asset element.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

AppearanceAssetElement Class


Duplicate Method

[image]

Revit 2024 API
AppearanceAssetElement..::..Duplicate Method
AppearanceAssetElement Class Example See Also Send Feedback
Duplicates the appearance asset element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018.1

Syntax

C#
public AppearanceAssetElement Duplicate(
    string name
)
Visual Basic
Public Function Duplicate ( _
    name As String _
) As AppearanceAssetElement
Visual C++
public:
AppearanceAssetElement^ Duplicate(
    String^ name
)

Parameters

name
Type: System..::..String
Name of the new appearance asset element - this name must be correctly structured for Revit use and not duplicate the name of another appearance asset in the document.

Return Value

The new AppearanceAssetElement.

Remarks

The asset contained by this element will be duplicated as well. Changes to the duplicated element or its asset do not affect the original element and asset.

Examples

CopyC#
public void DuplicateAndModifyMaterial(Material material)
{
   ElementId appearanceAssetId = material.AppearanceAssetId;

   AppearanceAssetElement assetElem = material.Document.GetElement(appearanceAssetId) as AppearanceAssetElement;

   ElementId duplicateAssetElementId = ElementId.InvalidElementId;

   using (Transaction t = new Transaction(material.Document, "Duplicate Red Carpet Material"))
   {
      t.Start();

      // Duplicate the material
      Material duplicateMaterial = material.Duplicate("Blue Carpet");

      // Duplicate the appearance asset and the asset in it
      AppearanceAssetElement duplicateAssetElement = assetElem.Duplicate("Blue Carpet");

      // Assign the asset element to the material
      duplicateMaterial.AppearanceAssetId = duplicateAssetElement.Id;

      duplicateAssetElementId = duplicateAssetElement.Id;

      t.Commit();
   }

   // Make changes to the duplicate asset
   using (Transaction t2 = new Transaction(material.Document, "Change blue carpet material"))
   {
      t2.Start();

      using (AppearanceAssetEditScope editScope = new AppearanceAssetEditScope(assetElem.Document))
      {
         Asset editableAsset = editScope.Start(duplicateAssetElementId);   // returns an editable copy of the appearance asset

         // Description
         AssetPropertyString descriptionProperty =
            editableAsset.FindByName("description") as AssetPropertyString;
         descriptionProperty.Value = "blue carpet";

         // Diffuse image
         AssetPropertyDoubleArray4d genericDiffuseProperty = editableAsset.FindByName("generic_diffuse") as AssetPropertyDoubleArray4d;

         genericDiffuseProperty.SetValueAsColor(new Color(0x00, 0x00, 0xFF));

         Asset connectedAsset = genericDiffuseProperty.GetSingleConnectedAsset();

         AssetPropertyString bitmapProperty = connectedAsset.FindByName("unifiedbitmap_Bitmap") as AssetPropertyString;

         bitmapProperty.Value = "Finishes.Flooring.Carpet.4.png";

         editScope.Commit(true);
      }

      t2.Commit();
   }
}
CopyVB.NET
Public Sub DuplicateAndModifyMaterial(material As Material)
    Dim appearanceAssetId As ElementId = material.AppearanceAssetId

    Dim assetElem As AppearanceAssetElement = TryCast(material.Document.GetElement(appearanceAssetId), AppearanceAssetElement)

    Dim duplicateAssetElementId As ElementId = ElementId.InvalidElementId

    Using t As New Transaction(material.Document, "Duplicate Red Carpet Material")
        t.Start()

        ' Duplicate the material
        Dim duplicateMaterial As Material = material.Duplicate("Blue Carpet")

        ' Duplicate the appearance asset and the asset in it
        Dim duplicateAssetElement As AppearanceAssetElement = assetElem.Duplicate("Blue Carpet")

        ' Assign the asset element to the material
        duplicateMaterial.AppearanceAssetId = duplicateAssetElement.Id

        duplicateAssetElementId = duplicateAssetElement.Id

        t.Commit()
    End Using

    ' Make changes to the duplicate asset
    Using t2 As New Transaction(material.Document, "Change blue carpet material")
        t2.Start()

        Using editScope As New AppearanceAssetEditScope(assetElem.Document)
            Dim editableAsset As Asset = editScope.Start(duplicateAssetElementId)
       ' returns an editable copy of the appearance asset
       Dim descriptionProperty As AssetPropertyString = TryCast(editableAsset.FindByName("description"), AssetPropertyString)
       descriptionProperty.Value = "blue carpet"

       ' Diffuse image
       Dim genericDiffuseProperty As AssetPropertyDoubleArray4d = TryCast(editableAsset.FindByName("generic_diffuse"), AssetPropertyDoubleArray4d)

       genericDiffuseProperty.SetValueAsColor(New Color(&H0, &H0, &HFF))

            Dim connectedAsset As Asset = genericDiffuseProperty.GetSingleConnectedAsset()

       Dim bitmapProperty As AssetPropertyString = TryCast(connectedAsset.FindByName("unifiedbitmap_Bitmap"), AssetPropertyString)

       bitmapProperty.Value = "Finishes.Flooring.Carpet.4.png"

            editScope.Commit(True)
        End Using

        t2.Commit()
    End Using
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- The given value for name is already in use as an appearance asset name.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

AppearanceAssetElement Class


SetRenderingAsset Method

[image]

Revit 2024 API
AppearanceAssetElement..::..SetRenderingAsset Method
AppearanceAssetElement Class See Also Send Feedback
Sets the rendering asset for the appearance asset element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void SetRenderingAsset(
    Asset asset
)
Visual Basic
Public Sub SetRenderingAsset ( _
    asset As Asset _
)
Visual C++
public:
void SetRenderingAsset(
    Asset^ asset
)

Parameters

asset
Type: Autodesk.Revit.DB.Visual..::..Asset
The new rendering asset. It should be an appearance asset.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The asset is not an appearance asset.

See Also

AppearanceAssetElement Class


AppearanceAssetElement Properties

[image] [image]

Revit 2024 API
AppearanceAssetElement Properties
AppearanceAssetElement Class See Also Send Feedback

The AppearanceAssetElement type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

AppearanceAssetElement Class


Arc Class

[image]

Revit 2024 API
Arc Class
Members See Also Send Feedback
A circular arc.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class Arc : Curve
Visual Basic
Public Class Arc _
    Inherits Curve
Visual C++
public ref class Arc : public Curve

Remarks

The arc lies in the plane defined by center and normal.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeometryObject
Autodesk.Revit.DB..::..Curve
Autodesk.Revit.DB..::..Arc

See Also

Arc Members


Arc Members

[image] [image]

Revit 2024 API
Arc Members
Arc Class Methods Properties See Also Send Feedback

The Arc type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns a copy of this curve. (Inherited from Curve.)
Public method | ComputeClosestPoints | Find the closest points between two curves. Closest points mean closest pairs of points, each pair consisting of a point on this, say P1, and a point on other curve, say P2. P1 and P2 are closest locally. Each pairs of closest points will be represented by the corresponding parameter values with respect to the two curves and the 3d points. A closest pair is also known as a pair of critical points of the distance function between points of the two curves. If the input parameter returnAllCriticalPoints is set to false, then the function will return only pairs with minimum distance. (Inherited from Curve.)
Public method | ComputeDerivatives | Returns the vectors describing the curve at the specified parameter. (Inherited from Curve.)
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve.)
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve.)
 | Create(XYZ, XYZ, XYZ) | Creates a new geometric arc object based on three points.
 | Create(Plane, Double, Double, Double) | Creates a new geometric arc object based on plane, radius, and angles.
 | Create(XYZ, Double, Double, Double, XYZ, XYZ) | Creates a new geometric arc object based on center, radius, unit vectors, and angles.
Public method | CreateOffset | Creates a new curve that is an offset of the existing curve. (Inherited from Curve.)
Public method | CreateReversed | Creates a new curve with the opposite orientation of the existing curve. (Inherited from Curve.)
Public method | CreateTransformed | Crates a new instance of a curve as a transformation of this curve. (Inherited from Curve.)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates and returns the point that matches a parameter along the curve. (Inherited from Curve.)
Public method | GetEndParameter | Returns the raw parameter value at the start or end of this curve. (Inherited from Curve.)
Public method | GetEndPoint | Returns the 3D point at the start or end of this curve. (Inherited from Curve.)
Public method | GetEndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve.)
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve.)
Public method | IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve.)
Public method | MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve.)
Public method | MakeUnbound | Makes this curve unbound. (Inherited from Curve.)
Public method | Project | Projects the specified point on this curve. (Inherited from Curve.)
Public method | SetGraphicsStyleId | Sets the graphics style id for this curve. (Inherited from Curve.)
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
Public property | Center | Returns the center of the arc.
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject.)
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
Public property | IsClosed | Describes whether the curve is closed. (Inherited from Curve.)
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Length | The exact length of the curve. (Inherited from Curve.)
Public property | Normal | Returns the normal to the plane in which the arc is defined.
Public property | Period | The period of this curve. (Inherited from Curve.)
Public property | Radius | Returns the radius of the arc.
Public property | Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Public property | Visibility | The visibility. (Inherited from GeometryObject.)
Public property | XDirection | Returns the X direction.
Public property | YDirection | Returns the Y direction.

See Also

Arc Class


Arc Methods

[image] [image]

Revit 2024 API
Arc Methods
Arc Class See Also Send Feedback

The Arc type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns a copy of this curve. (Inherited from Curve.)
Public method | ComputeClosestPoints | Find the closest points between two curves. Closest points mean closest pairs of points, each pair consisting of a point on this, say P1, and a point on other curve, say P2. P1 and P2 are closest locally. Each pairs of closest points will be represented by the corresponding parameter values with respect to the two curves and the 3d points. A closest pair is also known as a pair of critical points of the distance function between points of the two curves. If the input parameter returnAllCriticalPoints is set to false, then the function will return only pairs with minimum distance. (Inherited from Curve.)
Public method | ComputeDerivatives | Returns the vectors describing the curve at the specified parameter. (Inherited from Curve.)
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve.)
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve.)
 | Create(XYZ, XYZ, XYZ) | Creates a new geometric arc object based on three points.
 | Create(Plane, Double, Double, Double) | Creates a new geometric arc object based on plane, radius, and angles.
 | Create(XYZ, Double, Double, Double, XYZ, XYZ) | Creates a new geometric arc object based on center, radius, unit vectors, and angles.
Public method | CreateOffset | Creates a new curve that is an offset of the existing curve. (Inherited from Curve.)
Public method | CreateReversed | Creates a new curve with the opposite orientation of the existing curve. (Inherited from Curve.)
Public method | CreateTransformed | Crates a new instance of a curve as a transformation of this curve. (Inherited from Curve.)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates and returns the point that matches a parameter along the curve. (Inherited from Curve.)
Public method | GetEndParameter | Returns the raw parameter value at the start or end of this curve. (Inherited from Curve.)
Public method | GetEndPoint | Returns the 3D point at the start or end of this curve. (Inherited from Curve.)
Public method | GetEndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve.)
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve.)
Public method | IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve.)
Public method | MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve.)
Public method | MakeUnbound | Makes this curve unbound. (Inherited from Curve.)
Public method | Project | Projects the specified point on this curve. (Inherited from Curve.)
Public method | SetGraphicsStyleId | Sets the graphics style id for this curve. (Inherited from Curve.)
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Arc Class


Create Method

[image] [image]

Revit 2024 API
Arc..::..Create Method
Arc Class See Also Send Feedback

Overload List

Name | Description
Create(XYZ, XYZ, XYZ) | Creates a new geometric arc object based on three points.
Create(Plane, Double, Double, Double) | Creates a new geometric arc object based on plane, radius, and angles.
Create(XYZ, Double, Double, Double, XYZ, XYZ) | Creates a new geometric arc object based on center, radius, unit vectors, and angles.

See Also

Arc Class
Arc Members


Create Method (XYZ, Double, Double, Double, XYZ, XYZ)

[image]

Revit 2024 API
Arc..::..Create Method (XYZ, Double, Double, Double, XYZ, XYZ)
Arc Class Example See Also Send Feedback
Creates a new geometric arc object based on center, radius, unit vectors, and angles.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static Arc Create(
    XYZ center,
    double radius,
    double startAngle,
    double endAngle,
    XYZ xAxis,
    XYZ yAxis
)
Visual Basic
Public Shared Function Create ( _
    center As XYZ, _
    radius As Double, _
    startAngle As Double, _
    endAngle As Double, _
    xAxis As XYZ, _
    yAxis As XYZ _
) As Arc
Visual C++
public:
static Arc^ Create(
    XYZ^ center,
    double radius,
    double startAngle,
    double endAngle,
    XYZ^ xAxis,
    XYZ^ yAxis
)

Parameters

center
Type: Autodesk.Revit.DB..::..XYZ
The center of the arc.
radius
Type: System..::..Double
The radius of the arc.
startAngle
Type: System..::..Double
The start angle of the arc (in radians).
endAngle
Type: System..::..Double
The end angle of the arc (in radians).
xAxis
Type: Autodesk.Revit.DB..::..XYZ
The x axis to define the arc plane. Must be normalized.
yAxis
Type: Autodesk.Revit.DB..::..XYZ
The y axis to define the arc plane. Must be normalized.

Return Value

The new arc.

Remarks

If the angle range is equal to or greater than 2 * PI, the curve will be automatically converted to an unbounded circle.

Examples

CopyC#
// Create a new arc defined by its center, radios, angles and 2 axes
double radius = 10;
double startAngle = 0;      // In radian
double endAngle = Math.PI;        // In radian
XYZ center = new XYZ(5, 0, 0);
XYZ xAxis = new XYZ(1, 0, 0);   // The x axis to define the arc plane. Must be normalized
XYZ yAxis = new XYZ(0, 1, 0);   // The y axis to define the arc plane. Must be normalized

Arc arc = Arc.Create(center, radius, startAngle, endAngle, xAxis, yAxis);
CopyVB.NET
' Create a new arc defined by its center, radios, angles and 2 axes
Dim radius As Double = 10
Dim startAngle As Double = 0
' In radian
Dim endAngle As Double = Math.PI
' In radian
Dim center As New XYZ(5, 0, 0)
Dim xAxis As New XYZ(1, 0, 0)
' The x axis to define the arc plane. Must be normalized
Dim yAxis As New XYZ(0, 1, 0)
' The y axis to define the arc plane. Must be normalized
Dim arc__1 As Arc = Arc.Create(center, radius, startAngle, endAngle, xAxis, yAxis)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | xAxis is not length 1.0. -or- yAxis is not length 1.0. -or- The given value for radius must be between 0 and 30000 feet.
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | The vectors xAxis and yAxis are not perpendicular. -or- Start angle must be less than end angle. -or- Curve length is too small for Revit's tolerance (as identified by Application.ShortCurveTolerance).

See Also

Arc Class
Create Overload


Intersect Method

[image] [image]

Revit 2024 API
Arc..::..Intersect Method
Arc Class See Also Send Feedback
Calculates the intersection of this curve with the specified curve.

Overload List

 | Name | Description
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve.)

See Also

Arc Class
Arc Members


Arc Properties

[image] [image]

Revit 2024 API
Arc Properties
Arc Class See Also Send Feedback

The Arc type exposes the following members.

Properties

 | Name | Description
Public property | ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
Public property | Center | Returns the center of the arc.
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject.)
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
Public property | IsClosed | Describes whether the curve is closed. (Inherited from Curve.)
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Length | The exact length of the curve. (Inherited from Curve.)
Public property | Normal | Returns the normal to the plane in which the arc is defined.
Public property | Period | The period of this curve. (Inherited from Curve.)
Public property | Radius | Returns the radius of the arc.
Public property | Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Public property | Visibility | The visibility. (Inherited from GeometryObject.)
Public property | XDirection | Returns the X direction.
Public property | YDirection | Returns the Y direction.

See Also

Arc Class


Center Property

[image]

Revit 2024 API
Arc..::..Center Property
Arc Class See Also Send Feedback
Returns the center of the arc.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ Center { get; }
Visual Basic
Public ReadOnly Property Center As XYZ
    Get
Visual C++
public:
property XYZ^ Center {
    XYZ^ get ();
}

See Also

Arc Class


Normal Property

[image]

Revit 2024 API
Arc..::..Normal Property
Arc Class See Also Send Feedback
Returns the normal to the plane in which the arc is defined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ Normal { get; }
Visual Basic
Public ReadOnly Property Normal As XYZ
    Get
Visual C++
public:
property XYZ^ Normal {
    XYZ^ get ();
}

See Also

Arc Class


XDirection Property

[image]

Revit 2024 API
Arc..::..XDirection Property
Arc Class See Also Send Feedback
Returns the X direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ XDirection { get; }
Visual Basic
Public ReadOnly Property XDirection As XYZ
    Get
Visual C++
public:
property XYZ^ XDirection {
    XYZ^ get ();
}

See Also

Arc Class


Area Class

[image]

Revit 2024 API
Area Class
Members See Also Send Feedback
Provides access to the area topology in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class Area : SpatialElement
Visual Basic
Public Class Area _
    Inherits SpatialElement
Visual C++
public ref class Area : public SpatialElement

Remarks

The area object can be queried for its boundary for use in space planning tools.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..SpatialElement
Autodesk.Revit.DB..::..Area

See Also

Area Members


Area Members

[image] [image]

Revit 2024 API
Area Members
Area Class Methods Properties See Also Send Feedback

The Area type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetBoundarySegments | Returns the boundary segments. (Inherited from SpatialElement.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSpatialElementDomainData | Gets the domain data for the spatial element. The domain data contains information of different spatial elements, such as electrical load area. Currently room/space/area don't have domain data. (Inherited from SpatialElement.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Area | The area. (Inherited from SpatialElement.)
Public property | AreaScheme | The area scheme.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsGrossInterior | The boolean value that indicates whether the area is gross interior.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | Level | Gets the level of the room. (Inherited from SpatialElement.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | The location of the element. (Inherited from SpatialElement.)
Public property | Name | A human readable name for the Element. (Inherited from SpatialElement.)
Public property | Number | The number. (Inherited from SpatialElement.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Perimeter | The perimeter. (Inherited from SpatialElement.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SpatialElementType | The spatial element type. (Inherited from SpatialElement.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Area Class


Area Methods

[image] [image]

Revit 2024 API
Area Methods
Area Class See Also Send Feedback

The Area type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetBoundarySegments | Returns the boundary segments. (Inherited from SpatialElement.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSpatialElementDomainData | Gets the domain data for the spatial element. The domain data contains information of different spatial elements, such as electrical load area. Currently room/space/area don't have domain data. (Inherited from SpatialElement.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Area Class


Area Properties

[image] [image]

Revit 2024 API
Area Properties
Area Class See Also Send Feedback

The Area type exposes the following members.

Properties

 | Name | Description
Public property | Area | The area. (Inherited from SpatialElement.)
Public property | AreaScheme | The area scheme.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsGrossInterior | The boolean value that indicates whether the area is gross interior.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | Level | Gets the level of the room. (Inherited from SpatialElement.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | The location of the element. (Inherited from SpatialElement.)
Public property | Name | A human readable name for the Element. (Inherited from SpatialElement.)
Public property | Number | The number. (Inherited from SpatialElement.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Perimeter | The perimeter. (Inherited from SpatialElement.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SpatialElementType | The spatial element type. (Inherited from SpatialElement.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Area Class


AreaScheme Property

[image]

Revit 2024 API
Area..::..AreaScheme Property
Area Class See Also Send Feedback
The area scheme.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public AreaScheme AreaScheme { get; }
Visual Basic
Public ReadOnly Property AreaScheme As AreaScheme
    Get
Visual C++
public:
property AreaScheme^ AreaScheme {
    AreaScheme^ get ();
}

See Also

Area Class


IsGrossInterior Property

[image]

Revit 2024 API
Area..::..IsGrossInterior Property
Area Class See Also Send Feedback
The boolean value that indicates whether the area is gross interior.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsGrossInterior { get; }
Visual Basic
Public ReadOnly Property IsGrossInterior As Boolean
    Get
Visual C++
public:
property bool IsGrossInterior {
    bool get ();
}

See Also

Area Class


Parameter Property

[image] [image]

Revit 2024 API
Area..::..Parameter Property
Area Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Area Class
Area Members


AreaElemType Enumeration

[image]

Revit 2024 API
AreaElemType Enumeration
See Also Send Feedback
An enumerated type to store type of AreaElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum AreaElemType
Visual Basic
Public Enumeration AreaElemType
Visual C++
public enum class AreaElemType

Members

Member name | Description
GrossArea | Gross Area Scheme - only 2 types of spaces (internal and external).
BOMAArea | Office Area Scheme - uses BOMA rules for space classification.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


AreaFilter Class

[image]

Revit 2024 API
AreaFilter Class
Members Example See Also Send Feedback
A filter used to match areas.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class AreaFilter : ElementSlowFilter
Visual Basic
Public Class AreaFilter _
    Inherits ElementSlowFilter
Visual C++
public ref class AreaFilter : public ElementSlowFilter

Remarks

This filter is a slow filter, but it uses a quick filter to eliminate non-candidate elements before the elements are obtained and expanded. Therefore this filter does not have to be paired with another quick filter to minimize the number of Elements that are expanded.

Examples

CopyC#
// Use a AreaFilter to find all area elements in the document. It is necessary to use the AreaFilter,
// and not an ElementClassFilter or the shortcut method OfClass() because the area class is not
// supported by those methods.
AreaFilter filter = new AreaFilter();

// Apply the filter to the elements in the active document
FilteredElementCollector collector = new FilteredElementCollector(document);
IList<Element> areas = collector.WherePasses(filter).ToElements();
CopyVB.NET
' Use a AreaFilter to find all area elements in the document. It is necessary to use the AreaFilter,
' and not an ElementClassFilter or the shortcut method OfClass() because the area class is not
' supported by those methods.
Dim filter As New AreaFilter()

' Apply the filter to the elements in the active document
Dim collector As New FilteredElementCollector(document)
Dim areas As IList(Of Element) = collector.WherePasses(filter).ToElements()

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementSlowFilter
Autodesk.Revit.DB..::..AreaFilter

See Also

AreaFilter Members


AreaFilter Members

[image] [image]

Revit 2024 API
AreaFilter Members
AreaFilter Class Constructors Methods Properties See Also Send Feedback

The AreaFilter type exposes the following members.

Constructors

 | Name | Description
Public method | AreaFilter | Constructs a filter which matches only areas.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)

See Also

AreaFilter Class


AreaFilter Constructor

[image]

Revit 2024 API
AreaFilter Constructor
AreaFilter Class See Also Send Feedback
Constructs a filter which matches only areas.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public AreaFilter()
Visual Basic
Public Sub New
Visual C++
public:
AreaFilter()

See Also

AreaFilter Class


AreaFilter Methods

[image] [image]

Revit 2024 API
AreaFilter Methods
AreaFilter Class See Also Send Feedback

The AreaFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

AreaFilter Class


PassesFilter Method

[image] [image]

Revit 2024 API
AreaFilter..::..PassesFilter Method
AreaFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

AreaFilter Class
AreaFilter Members


AreaFilter Properties

[image] [image]

Revit 2024 API
AreaFilter Properties
AreaFilter Class See Also Send Feedback

The AreaFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)

See Also

AreaFilter Class


AreaScheme Class

[image]

Revit 2024 API
AreaScheme Class
Members See Also Send Feedback
The area scheme associated with a particular area plan.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class AreaScheme : Element
Visual Basic
Public Class AreaScheme _
    Inherits Element
Visual C++
public ref class AreaScheme : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..AreaScheme

See Also

AreaScheme Members


AreaScheme Members

[image] [image]

Revit 2024 API
AreaScheme Members
AreaScheme Class Methods Properties See Also Send Feedback

The AreaScheme type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsGrossBuildingArea | Indicates if the area scheme is a Gross Building Area scheme.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

AreaScheme Class


AreaScheme Methods

[image] [image]

Revit 2024 API
AreaScheme Methods
AreaScheme Class See Also Send Feedback

The AreaScheme type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

AreaScheme Class


IsGrossBuildingArea Property

[image]

Revit 2024 API
AreaScheme..::..IsGrossBuildingArea Property
AreaScheme Class See Also Send Feedback
Indicates if the area scheme is a Gross Building Area scheme.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsGrossBuildingArea { get; }
Visual Basic
Public ReadOnly Property IsGrossBuildingArea As Boolean
    Get
Visual C++
public:
property bool IsGrossBuildingArea {
    bool get ();
}

See Also

AreaScheme Class


AreaTag Class

[image]

Revit 2024 API
AreaTag Class
Members See Also Send Feedback
Provides access to the area topology in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class AreaTag : SpatialElementTag
Visual Basic
Public Class AreaTag _
    Inherits SpatialElementTag
Visual C++
public ref class AreaTag : public SpatialElementTag

Remarks

The areaTag object can be queried for its boundary for use in space planning tools.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..SpatialElementTag
Autodesk.Revit.DB..::..AreaTag

See Also

AreaTag Members


AreaTag Members

[image] [image]

Revit 2024 API
AreaTag Members
AreaTag Class Methods Properties See Also Send Feedback

The AreaTag type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Area | The area that the tag is associated with.
Public property | AreaTagType | The tag type.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | HasElbow | Identifies if the tag's leader has an elbow point or not. (Inherited from SpatialElementTag.)
Public property | HasLeader | Identifies if a leader is displayed for the tag or not. (Inherited from SpatialElementTag.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsOrphaned | Identifies if the tag is orphaned or not. (Inherited from SpatialElementTag.)
Public property | IsTaggingLink | Identifies if the tag has reference to a spatial element in a linked document or not. (Inherited from SpatialElementTag.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LeaderElbow | The position of the leader's elbow (middle point). (Inherited from SpatialElementTag.)
Public property | LeaderEnd | The position of the leader's end. (Inherited from SpatialElementTag.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | The location of the tag. (Inherited from SpatialElementTag.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RotationAngle | The rotation angle of the tag relative to its view (Inherited from SpatialElementTag.)
Public property | TagHeadPosition | The position of the tag's head. (Inherited from SpatialElementTag.)
Public property | TagOrientation | The orientation of the tag. (Inherited from SpatialElementTag.)
Public property | TagText | The text displayed by the tag. (Inherited from SpatialElementTag.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | View | The view in which the tag was placed. (Inherited from SpatialElementTag.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

AreaTag Class


AreaTag Methods

[image] [image]

Revit 2024 API
AreaTag Methods
AreaTag Class See Also Send Feedback

The AreaTag type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

AreaTag Class


AreaTag Properties

[image] [image]

Revit 2024 API
AreaTag Properties
AreaTag Class See Also Send Feedback

The AreaTag type exposes the following members.

Properties

 | Name | Description
Public property | Area | The area that the tag is associated with.
Public property | AreaTagType | The tag type.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | HasElbow | Identifies if the tag's leader has an elbow point or not. (Inherited from SpatialElementTag.)
Public property | HasLeader | Identifies if a leader is displayed for the tag or not. (Inherited from SpatialElementTag.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsOrphaned | Identifies if the tag is orphaned or not. (Inherited from SpatialElementTag.)
Public property | IsTaggingLink | Identifies if the tag has reference to a spatial element in a linked document or not. (Inherited from SpatialElementTag.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LeaderElbow | The position of the leader's elbow (middle point). (Inherited from SpatialElementTag.)
Public property | LeaderEnd | The position of the leader's end. (Inherited from SpatialElementTag.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | The location of the tag. (Inherited from SpatialElementTag.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RotationAngle | The rotation angle of the tag relative to its view (Inherited from SpatialElementTag.)
Public property | TagHeadPosition | The position of the tag's head. (Inherited from SpatialElementTag.)
Public property | TagOrientation | The orientation of the tag. (Inherited from SpatialElementTag.)
Public property | TagText | The text displayed by the tag. (Inherited from SpatialElementTag.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | View | The view in which the tag was placed. (Inherited from SpatialElementTag.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

AreaTag Class


Area Property

[image]

Revit 2024 API
AreaTag..::..Area Property
AreaTag Class See Also Send Feedback
The area that the tag is associated with.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Area Area { get; }
Visual Basic
Public ReadOnly Property Area As Area
    Get
Visual C++
public:
property Area^ Area {
    Area^ get ();
}

Remarks

In rare cases, the tag may not be associated to an area. The property will be nullNothingnullptra null reference (Nothing in Visual Basic) in these situations.

See Also

AreaTag Class


AreaTagType Property

[image]

Revit 2024 API
AreaTag..::..AreaTagType Property
AreaTag Class See Also Send Feedback
The tag type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public AreaTagType AreaTagType { get; set; }
Visual Basic
Public Property AreaTagType As AreaTagType
    Get
    Set
Visual C++
public:
property AreaTagType^ AreaTagType {
    AreaTagType^ get ();
    void set (AreaTagType^ value);
}

See Also

AreaTag Class


Parameter Property

[image] [image]

Revit 2024 API
AreaTag..::..Parameter Property
AreaTag Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

AreaTag Class
AreaTag Members


AreaTagFilter Class

[image]

Revit 2024 API
AreaTagFilter Class
Members See Also Send Feedback
A filter used to match area tags.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class AreaTagFilter : ElementSlowFilter
Visual Basic
Public Class AreaTagFilter _
    Inherits ElementSlowFilter
Visual C++
public ref class AreaTagFilter : public ElementSlowFilter

Remarks

This filter is a slow filter, but it uses a quick filter to eliminate non-candidate elements before the elements are obtained and expanded. Therefore this filter does not have to be paired with another quick filter to minimize the number of Elements that are expanded.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementSlowFilter
Autodesk.Revit.DB..::..AreaTagFilter

See Also

AreaTagFilter Members


AreaTagFilter Members

[image] [image]

Revit 2024 API
AreaTagFilter Members
AreaTagFilter Class Constructors Methods Properties See Also Send Feedback

The AreaTagFilter type exposes the following members.

Constructors

 | Name | Description
Public method | AreaTagFilter | Constructs a filter which matches only areas.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)

See Also

AreaTagFilter Class


AreaTagFilter Constructor

[image]

Revit 2024 API
AreaTagFilter Constructor
AreaTagFilter Class See Also Send Feedback
Constructs a filter which matches only areas.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public AreaTagFilter()
Visual Basic
Public Sub New
Visual C++
public:
AreaTagFilter()

See Also

AreaTagFilter Class


AreaTagFilter Methods

[image] [image]

Revit 2024 API
AreaTagFilter Methods
AreaTagFilter Class See Also Send Feedback

The AreaTagFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

AreaTagFilter Class


PassesFilter Method

[image] [image]

Revit 2024 API
AreaTagFilter..::..PassesFilter Method
AreaTagFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

AreaTagFilter Class
AreaTagFilter Members


AreaTagFilter Properties

[image] [image]

Revit 2024 API
AreaTagFilter Properties
AreaTagFilter Class See Also Send Feedback

The AreaTagFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)

See Also

AreaTagFilter Class


AreaTagType Class

[image]

Revit 2024 API
AreaTagType Class
Members See Also Send Feedback
An object that represents an Area Tag style.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class AreaTagType : FamilySymbol
Visual Basic
Public Class AreaTagType _
    Inherits FamilySymbol
Visual C++
public ref class AreaTagType : public FamilySymbol

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..InsertableObject
Autodesk.Revit.DB..::..FamilySymbol
Autodesk.Revit.DB..::..AreaTagType

See Also

AreaTagType Members


AreaTagType Members

[image] [image]

Revit 2024 API
AreaTagType Members
AreaTagType Class Methods Properties See Also Send Feedback

The AreaTagType type exposes the following members.

Methods

 | Name | Description
Public method | Activate | Activates the symbol to ensure that its geometry is accessible. (Inherited from FamilySymbol.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveStructuralSection | Identifies if this FamilySymbol can have a structural section. (Inherited from FamilySymbol.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetFamilyPointLocations | Returns the Point Locations for the Family Symbol. (Inherited from FamilySymbol.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetStructuralSection | Gets the structural section from element. (Inherited from FamilySymbol.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetThermalProperties | Gets the thermal properties for the given FamilySymbol. (Inherited from FamilySymbol.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasThermalProperties | Identifies if this FamilySymbol can include thermal properties. (Inherited from FamilySymbol.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetStructuralSection | Sets the structural section in element. (Inherited from FamilySymbol.)
Public method | SetThermalProperties | Sets the thermal properties for the given FamilySymbol. (Inherited from FamilySymbol.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Family | The Family object to which the symbol belongs. (Inherited from FamilySymbol.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsActive | Identifies whether the symbol is active. (Inherited from FamilySymbol.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | StructuralMaterialType | This property returns the physical material from which the type is made. (Inherited from FamilySymbol.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

AreaTagType Class


AreaTagType Methods

[image] [image]

Revit 2024 API
AreaTagType Methods
AreaTagType Class See Also Send Feedback

The AreaTagType type exposes the following members.

Methods

 | Name | Description
Public method | Activate | Activates the symbol to ensure that its geometry is accessible. (Inherited from FamilySymbol.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveStructuralSection | Identifies if this FamilySymbol can have a structural section. (Inherited from FamilySymbol.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetFamilyPointLocations | Returns the Point Locations for the Family Symbol. (Inherited from FamilySymbol.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetStructuralSection | Gets the structural section from element. (Inherited from FamilySymbol.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetThermalProperties | Gets the thermal properties for the given FamilySymbol. (Inherited from FamilySymbol.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasThermalProperties | Identifies if this FamilySymbol can include thermal properties. (Inherited from FamilySymbol.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetStructuralSection | Sets the structural section in element. (Inherited from FamilySymbol.)
Public method | SetThermalProperties | Sets the thermal properties for the given FamilySymbol. (Inherited from FamilySymbol.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

AreaTagType Class


AreaTagType Properties

[image] [image]

Revit 2024 API
AreaTagType Properties
AreaTagType Class See Also Send Feedback

The AreaTagType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Family | The Family object to which the symbol belongs. (Inherited from FamilySymbol.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsActive | Identifies whether the symbol is active. (Inherited from FamilySymbol.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | StructuralMaterialType | This property returns the physical material from which the type is made. (Inherited from FamilySymbol.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

AreaTagType Class


Parameter Property

[image] [image]

Revit 2024 API
AreaTagType..::..Parameter Property
AreaTagType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

AreaTagType Class
AreaTagType Members


AreaVolumeSettings Class

[image]

Revit 2024 API
AreaVolumeSettings Class
Members See Also Send Feedback
This class provides access to settings related to volume and area computations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class AreaVolumeSettings : Element
Visual Basic
Public Class AreaVolumeSettings _
    Inherits Element
Visual C++
public ref class AreaVolumeSettings : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..AreaVolumeSettings

See Also

AreaVolumeSettings Members


AreaVolumeSettings Members

[image] [image]

Revit 2024 API
AreaVolumeSettings Members
AreaVolumeSettings Class Methods Properties See Also Send Feedback

The AreaVolumeSettings type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
 | GetAreaVolumeSettings | Get the area and volume settings of the project.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSpatialElementBoundaryLocation | Gets the spatial element boundary location based on spatial element type.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetSpatialElementBoundaryLocation | Sets the spatial element boundary location of a spatial element type.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ComputeVolumes | True to enable volume computation. False to disable it.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

AreaVolumeSettings Class


AreaVolumeSettings Methods

[image] [image]

Revit 2024 API
AreaVolumeSettings Methods
AreaVolumeSettings Class See Also Send Feedback

The AreaVolumeSettings type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
 | GetAreaVolumeSettings | Get the area and volume settings of the project.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSpatialElementBoundaryLocation | Gets the spatial element boundary location based on spatial element type.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetSpatialElementBoundaryLocation | Sets the spatial element boundary location of a spatial element type.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

AreaVolumeSettings Class


GetAreaVolumeSettings Method

[image]

Revit 2024 API
AreaVolumeSettings..::..GetAreaVolumeSettings Method
AreaVolumeSettings Class See Also Send Feedback
Get the area and volume settings of the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static AreaVolumeSettings GetAreaVolumeSettings(
    Document aDoc
)
Visual Basic
Public Shared Function GetAreaVolumeSettings ( _
    aDoc As Document _
) As AreaVolumeSettings
Visual C++
public:
static AreaVolumeSettings^ GetAreaVolumeSettings(
    Document^ aDoc
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
The document.

Return Value

The area and volume settings of the project.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

AreaVolumeSettings Class


GetSpatialElementBoundaryLocation Method

[image]

Revit 2024 API
AreaVolumeSettings..::..GetSpatialElementBoundaryLocation Method
AreaVolumeSettings Class See Also Send Feedback
Gets the spatial element boundary location based on spatial element type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public SpatialElementBoundaryLocation GetSpatialElementBoundaryLocation(
    SpatialElementType spType
)
Visual Basic
Public Function GetSpatialElementBoundaryLocation ( _
    spType As SpatialElementType _
) As SpatialElementBoundaryLocation
Visual C++
public:
SpatialElementBoundaryLocation GetSpatialElementBoundaryLocation(
    SpatialElementType spType
)

Parameters

spType
Type: Autodesk.Revit.DB..::..SpatialElementType
The spatial element type.

Return Value

The boundary location.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

AreaVolumeSettings Class


ComputeVolumes Property

[image]

Revit 2024 API
AreaVolumeSettings..::..ComputeVolumes Property
AreaVolumeSettings Class Example See Also Send Feedback
True to enable volume computation. False to disable it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool ComputeVolumes { get; set; }
Visual Basic
Public Property ComputeVolumes As Boolean
    Get
    Set
Visual C++
public:
property bool ComputeVolumes {
    bool get ();
    void set (bool value);
}

Remarks

When this setting is False, rooms and spaces will be treated as simple extrusions of their 2d boundaries. The volume parameter will report "not computed". When this setting is True, the geometry of rooms and spaces will be trimmed when it intersects elements such as ceilings, roofs, and floors.

Examples

CopyC#
public void GetRoomDimensions(Document doc, Room room)
{
    String roominfo = "Room dimensions:\n";
    // turn on volume calculations:
    using (Transaction t = new Transaction(doc, "Turn on volume calculation"))
    {
        t.Start();
        AreaVolumeSettings settings = AreaVolumeSettings.GetAreaVolumeSettings(doc);
        settings.ComputeVolumes = true;
        t.Commit();
    }

    roominfo += "Vol: " + room.Volume + "\n";
    roominfo += "Area: " + room.Area + "\n";
    roominfo += "Perimeter: " + room.Perimeter + "\n";
    roominfo += "Unbounded height: " + room.UnboundedHeight + "\n";
    TaskDialog.Show("Revit",roominfo);
}
CopyVB.NET
Public Sub GetRoomDimensions(doc As Document, room As Room)
    Dim roominfo As [String] = "Room dimensions:" & vbLf
    ' turn on volume calculations:
    Using t As New Transaction(doc, "Turn on volume calculation")
        t.Start()
        Dim settings As AreaVolumeSettings = AreaVolumeSettings.GetAreaVolumeSettings(doc)
        settings.ComputeVolumes = True
        t.Commit()
    End Using

    roominfo += "Vol: " & Convert.ToString(room.Volume) & vbLf
    roominfo += "Area: " & Convert.ToString(room.Area) & vbLf
    roominfo += "Perimeter: " & Convert.ToString(room.Perimeter) & vbLf
    roominfo += "Unbounded height: " & Convert.ToString(room.UnboundedHeight) & vbLf
    TaskDialog.Show("Revit", roominfo)
End Sub

See Also

AreaVolumeSettings Class


Parameter Property

[image] [image]

Revit 2024 API
AreaVolumeSettings..::..Parameter Property
AreaVolumeSettings Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

AreaVolumeSettings Class
AreaVolumeSettings Members


ArrayAnchorMember Enumeration

[image]

Revit 2024 API
ArrayAnchorMember Enumeration
See Also Send Feedback
Represents the possible choices for how the translation or rotation is used to place each member of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public enum ArrayAnchorMember
Visual Basic
Public Enumeration ArrayAnchorMember
Visual C++
public enum class ArrayAnchorMember

Members

Member name | Description
Second | The translation or rotation value specifies the location of the second member of the array.
Last | The translation or rotation value specifies the location of the last member of the array.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


AssemblyCodeTable Class

[image]

Revit 2024 API
AssemblyCodeTable Class
Members See Also Send Feedback
AssemblyCodeTable represents the collection of ClassificationEntries for a document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public class AssemblyCodeTable : KeyBasedTreeEntryTable
Visual Basic
Public Class AssemblyCodeTable _
    Inherits KeyBasedTreeEntryTable
Visual C++
public ref class AssemblyCodeTable : public KeyBasedTreeEntryTable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..KeyBasedTreeEntryTable
Autodesk.Revit.DB..::..AssemblyCodeTable

See Also

AssemblyCodeTable Members


AssemblyCodeTable Members

[image] [image]

Revit 2024 API
AssemblyCodeTable Members
AssemblyCodeTable Class Methods Properties See Also Send Feedback

The AssemblyCodeTable type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
 | GetAssemblyCodeTable | Returns the AssemblyCodeTable for the specified document.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetKeyBasedTreeEntries | Gets the KeyBasedTreeEntries for this table. (Inherited from KeyBasedTreeEntryTable.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LoadFrom | Loads KeyBasedTreeEntries from the specified external resource into this KeyBasedTreeEntryTable. (Inherited from KeyBasedTreeEntryTable.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | Reload | Reloads KeyBasedTreeEntries from their currently-stored location into this KeyBasedTreeEntryTable. (Inherited from KeyBasedTreeEntryTable.)
Public method | ServerSupports | Checks if the server referenced by the given ExternalResourceReference supports the ExternalResourceReferenceType of this KeyBasedTreeEntryTable. (Inherited from KeyBasedTreeEntryTable.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

AssemblyCodeTable Class


AssemblyCodeTable Methods

[image] [image]

Revit 2024 API
AssemblyCodeTable Methods
AssemblyCodeTable Class See Also Send Feedback

The AssemblyCodeTable type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
 | GetAssemblyCodeTable | Returns the AssemblyCodeTable for the specified document.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetKeyBasedTreeEntries | Gets the KeyBasedTreeEntries for this table. (Inherited from KeyBasedTreeEntryTable.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LoadFrom | Loads KeyBasedTreeEntries from the specified external resource into this KeyBasedTreeEntryTable. (Inherited from KeyBasedTreeEntryTable.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | Reload | Reloads KeyBasedTreeEntries from their currently-stored location into this KeyBasedTreeEntryTable. (Inherited from KeyBasedTreeEntryTable.)
Public method | ServerSupports | Checks if the server referenced by the given ExternalResourceReference supports the ExternalResourceReferenceType of this KeyBasedTreeEntryTable. (Inherited from KeyBasedTreeEntryTable.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

AssemblyCodeTable Class


GetAssemblyCodeTable Method

[image]

Revit 2024 API
AssemblyCodeTable..::..GetAssemblyCodeTable Method
AssemblyCodeTable Class See Also Send Feedback
Returns the AssemblyCodeTable for the specified document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static AssemblyCodeTable GetAssemblyCodeTable(
    Document doc
)
Visual Basic
Public Shared Function GetAssemblyCodeTable ( _
    doc As Document _
) As AssemblyCodeTable
Visual C++
public:
static AssemblyCodeTable^ GetAssemblyCodeTable(
    Document^ doc
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The document owns the AssemblyCodeTable.

Return Value

The AssemblyCodeTable for the document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

AssemblyCodeTable Class


AssemblyCodeTable Properties

[image] [image]

Revit 2024 API
AssemblyCodeTable Properties
AssemblyCodeTable Class See Also Send Feedback

The AssemblyCodeTable type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

AssemblyCodeTable Class


AssemblyDetailViewOrientation Enumeration

[image]

Revit 2024 API
AssemblyDetailViewOrientation Enumeration
See Also Send Feedback
Orientation of the Assembly Detail View.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public enum AssemblyDetailViewOrientation
Visual Basic
Public Enumeration AssemblyDetailViewOrientation
Visual C++
public enum class AssemblyDetailViewOrientation

Members

Member name | Description
HorizontalDetail | The Detail View will be oriented horizontally, looking down.
DetailSectionA | The Detail View will be oriented vertically, looking north.
DetailSectionB | The Detail View will be oriented vertically, looking west.
ElevationTop | The Detail View will be oriented horizontally, with its cut plane along the top face of the assembly's bounding box, looking down into the bounding box.
ElevationBottom | The Detail View will be oriented horizontally, with its cut plane along the bottom face of the assembly's bounding box, looking up into the bounding box.
ElevationLeft | The Detail View will be oriented vertically, with its cut plane along the left face of the assembly's bounding box, looking into the bounding box.
ElevationRight | The Detail View will be oriented vertically, with its cut plane along the right face of the assembly's bounding box, looking into the bounding box.
ElevationFront | The Detail View will be oriented vertically, with its cut plane along the front face of the assembly's bounding box, looking into the bounding box.
ElevationBack | The Detail View will be oriented vertically, with its cut plane along the back face of the assembly's bounding box, looking into the bounding box.

Remarks

The orientation can be specified during creation but not modified for existing views.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


AssemblyDifference Class

[image]

Revit 2024 API
AssemblyDifference Class
Members See Also Send Feedback
Class that describes difference between two assemblies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public class AssemblyDifference : IDisposable
Visual Basic
Public Class AssemblyDifference _
    Implements IDisposable
Visual C++
public ref class AssemblyDifference : IDisposable

Remarks

The assembly comparison function returns a sub-class of this class. Different sub-classes represent different kinds of differences and contain additional data for each particular kind of difference.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..AssemblyDifference
Autodesk.Revit.DB..::..AssemblyDifferenceConfiguration
Autodesk.Revit.DB..::..AssemblyDifferenceMemberCount
Autodesk.Revit.DB..::..AssemblyDifferenceMemberDifference
Autodesk.Revit.DB..::..AssemblyDifferenceNamingCategory
Autodesk.Revit.DB..::..AssemblyDifferenceNone

See Also

AssemblyDifference Members


AssemblyDifference Methods

[image] [image]

Revit 2024 API
AssemblyDifference Methods
AssemblyDifference Class See Also Send Feedback

The AssemblyDifference type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

AssemblyDifference Class


Dispose Method

[image]

Revit 2024 API
AssemblyDifference..::..Dispose Method
AssemblyDifference Class See Also Send Feedback
Releases all resources used by the AssemblyDifference

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

AssemblyDifference Class


AssemblyDifference Properties

[image] [image]

Revit 2024 API
AssemblyDifference Properties
AssemblyDifference Class See Also Send Feedback

The AssemblyDifference type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

AssemblyDifference Class


AssemblyDifferenceConfiguration Class

[image]

Revit 2024 API
AssemblyDifferenceConfiguration Class
Members See Also Send Feedback
The two assemblies being compared have different spatial configuration

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public class AssemblyDifferenceConfiguration : AssemblyDifference
Visual Basic
Public Class AssemblyDifferenceConfiguration _
    Inherits AssemblyDifference
Visual C++
public ref class AssemblyDifferenceConfiguration : public AssemblyDifference

Remarks

Assemblies resulting in this difference might be made up of identical elements, but the elements are not arranged in space relative to each other in the same way.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..AssemblyDifference
Autodesk.Revit.DB..::..AssemblyDifferenceConfiguration

See Also

AssemblyDifferenceConfiguration Members


AssemblyDifferenceConfiguration Members

[image] [image]

Revit 2024 API
AssemblyDifferenceConfiguration Members
AssemblyDifferenceConfiguration Class Methods Properties See Also Send Feedback

The AssemblyDifferenceConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from AssemblyDifference.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from AssemblyDifference.)

See Also

AssemblyDifferenceConfiguration Class


AssemblyDifferenceConfiguration Properties

[image] [image]

Revit 2024 API
AssemblyDifferenceConfiguration Properties
AssemblyDifferenceConfiguration Class See Also Send Feedback

The AssemblyDifferenceConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from AssemblyDifference.)

See Also

AssemblyDifferenceConfiguration Class


AssemblyDifferenceMemberCount Class

[image]

Revit 2024 API
AssemblyDifferenceMemberCount Class
Members See Also Send Feedback
The two assemblies being compared have different number of members

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public class AssemblyDifferenceMemberCount : AssemblyDifference
Visual Basic
Public Class AssemblyDifferenceMemberCount _
    Inherits AssemblyDifference
Visual C++
public ref class AssemblyDifferenceMemberCount : public AssemblyDifference

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..AssemblyDifference
Autodesk.Revit.DB..::..AssemblyDifferenceMemberCount

See Also

AssemblyDifferenceMemberCount Members


AssemblyDifferenceMemberCount Members

[image] [image]

Revit 2024 API
AssemblyDifferenceMemberCount Members
AssemblyDifferenceMemberCount Class Methods Properties See Also Send Feedback

The AssemblyDifferenceMemberCount type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from AssemblyDifference.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count1 | Number of members in the first assembly
Public property | Count2 | Number of members in the second assembly
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from AssemblyDifference.)

See Also

AssemblyDifferenceMemberCount Class


AssemblyDifferenceMemberCount Methods

[image] [image]

Revit 2024 API
AssemblyDifferenceMemberCount Methods
AssemblyDifferenceMemberCount Class See Also Send Feedback

The AssemblyDifferenceMemberCount type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from AssemblyDifference.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

AssemblyDifferenceMemberCount Class


AssemblyDifferenceMemberCount Properties

[image] [image]

Revit 2024 API
AssemblyDifferenceMemberCount Properties
AssemblyDifferenceMemberCount Class See Also Send Feedback

The AssemblyDifferenceMemberCount type exposes the following members.

Properties

 | Name | Description
Public property | Count1 | Number of members in the first assembly
Public property | Count2 | Number of members in the second assembly
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from AssemblyDifference.)

See Also

AssemblyDifferenceMemberCount Class


Count1 Property

[image]

Revit 2024 API
AssemblyDifferenceMemberCount..::..Count1 Property
AssemblyDifferenceMemberCount Class See Also Send Feedback
Number of members in the first assembly

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public int Count1 { get; }
Visual Basic
Public ReadOnly Property Count1 As Integer
    Get
Visual C++
public:
property int Count1 {
    int get ();
}

See Also

AssemblyDifferenceMemberCount Class


Count2 Property

[image]

Revit 2024 API
AssemblyDifferenceMemberCount..::..Count2 Property
AssemblyDifferenceMemberCount Class See Also Send Feedback
Number of members in the second assembly

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public int Count2 { get; }
Visual Basic
Public ReadOnly Property Count2 As Integer
    Get
Visual C++
public:
property int Count2 {
    int get ();
}

See Also

AssemblyDifferenceMemberCount Class


AssemblyDifferenceMemberDifference Class

[image]

Revit 2024 API
AssemblyDifferenceMemberDifference Class
Members See Also Send Feedback
The two assemblies being compared have different members

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public class AssemblyDifferenceMemberDifference : AssemblyDifference
Visual Basic
Public Class AssemblyDifferenceMemberDifference _
    Inherits AssemblyDifference
Visual C++
public ref class AssemblyDifferenceMemberDifference : public AssemblyDifference

Remarks

This difference means that there is a member of the first assembly which is different from the corresponding member of the second assembly. Details about the difference are in memberDifference.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..AssemblyDifference
Autodesk.Revit.DB..::..AssemblyDifferenceMemberDifference

See Also

AssemblyDifferenceMemberDifference Members


AssemblyDifferenceMemberDifference Members

[image] [image]

Revit 2024 API
AssemblyDifferenceMemberDifference Members
AssemblyDifferenceMemberDifference Class Methods Properties See Also Send Feedback

The AssemblyDifferenceMemberDifference type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from AssemblyDifference.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from AssemblyDifference.)
Public property | MemberDifference | Difference between the assembly members
Public property | MemberId1 | Id of the member in the first assembly
Public property | MemberId2 | Id of the member in the second assembly

See Also

AssemblyDifferenceMemberDifference Class


AssemblyDifferenceMemberDifference Methods

[image] [image]

Revit 2024 API
AssemblyDifferenceMemberDifference Methods
AssemblyDifferenceMemberDifference Class See Also Send Feedback

The AssemblyDifferenceMemberDifference type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from AssemblyDifference.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

AssemblyDifferenceMemberDifference Class


AssemblyDifferenceMemberDifference Properties

[image] [image]

Revit 2024 API
AssemblyDifferenceMemberDifference Properties
AssemblyDifferenceMemberDifference Class See Also Send Feedback

The AssemblyDifferenceMemberDifference type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from AssemblyDifference.)
Public property | MemberDifference | Difference between the assembly members
Public property | MemberId1 | Id of the member in the first assembly
Public property | MemberId2 | Id of the member in the second assembly

See Also

AssemblyDifferenceMemberDifference Class


MemberDifference Property

[image]

Revit 2024 API
AssemblyDifferenceMemberDifference..::..MemberDifference Property
AssemblyDifferenceMemberDifference Class See Also Send Feedback
Difference between the assembly members

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public AssemblyMemberDifference MemberDifference { get; }
Visual Basic
Public ReadOnly Property MemberDifference As AssemblyMemberDifference
    Get
Visual C++
public:
property AssemblyMemberDifference^ MemberDifference {
    AssemblyMemberDifference^ get ();
}

See Also

AssemblyDifferenceMemberDifference Class


MemberId1 Property

[image]

Revit 2024 API
AssemblyDifferenceMemberDifference..::..MemberId1 Property
AssemblyDifferenceMemberDifference Class See Also Send Feedback
Id of the member in the first assembly

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public ElementId MemberId1 { get; }
Visual Basic
Public ReadOnly Property MemberId1 As ElementId
    Get
Visual C++
public:
property ElementId^ MemberId1 {
    ElementId^ get ();
}

See Also

AssemblyDifferenceMemberDifference Class


MemberId2 Property

[image]

Revit 2024 API
AssemblyDifferenceMemberDifference..::..MemberId2 Property
AssemblyDifferenceMemberDifference Class See Also Send Feedback
Id of the member in the second assembly

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public ElementId MemberId2 { get; }
Visual Basic
Public ReadOnly Property MemberId2 As ElementId
    Get
Visual C++
public:
property ElementId^ MemberId2 {
    ElementId^ get ();
}

See Also

AssemblyDifferenceMemberDifference Class


AssemblyDifferenceNamingCategory Members

[image] [image]

Revit 2024 API
AssemblyDifferenceNamingCategory Members
AssemblyDifferenceNamingCategory Class Methods Properties See Also Send Feedback

The AssemblyDifferenceNamingCategory type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from AssemblyDifference.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from AssemblyDifference.)
Public property | NamingCategoryId1 | Naming category id of the first assembly
Public property | NamingCategoryId2 | Naming category id of the second assembly

See Also

AssemblyDifferenceNamingCategory Class


AssemblyDifferenceNamingCategory Methods

[image] [image]

Revit 2024 API
AssemblyDifferenceNamingCategory Methods
AssemblyDifferenceNamingCategory Class See Also Send Feedback

The AssemblyDifferenceNamingCategory type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from AssemblyDifference.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

AssemblyDifferenceNamingCategory Class


AssemblyDifferenceNamingCategory Properties

[image] [image]

Revit 2024 API
AssemblyDifferenceNamingCategory Properties
AssemblyDifferenceNamingCategory Class See Also Send Feedback

The AssemblyDifferenceNamingCategory type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from AssemblyDifference.)
Public property | NamingCategoryId1 | Naming category id of the first assembly
Public property | NamingCategoryId2 | Naming category id of the second assembly

See Also

AssemblyDifferenceNamingCategory Class


NamingCategoryId1 Property

[image]

Revit 2024 API
AssemblyDifferenceNamingCategory..::..NamingCategoryId1 Property
AssemblyDifferenceNamingCategory Class See Also Send Feedback
Naming category id of the first assembly

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public ElementId NamingCategoryId1 { get; }
Visual Basic
Public ReadOnly Property NamingCategoryId1 As ElementId
    Get
Visual C++
public:
property ElementId^ NamingCategoryId1 {
    ElementId^ get ();
}

See Also

AssemblyDifferenceNamingCategory Class


NamingCategoryId2 Property

[image]

Revit 2024 API
AssemblyDifferenceNamingCategory..::..NamingCategoryId2 Property
AssemblyDifferenceNamingCategory Class See Also Send Feedback
Naming category id of the second assembly

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public ElementId NamingCategoryId2 { get; }
Visual Basic
Public ReadOnly Property NamingCategoryId2 As ElementId
    Get
Visual C++
public:
property ElementId^ NamingCategoryId2 {
    ElementId^ get ();
}

See Also

AssemblyDifferenceNamingCategory Class


AssemblyDifferenceNone Members

[image] [image]

Revit 2024 API
AssemblyDifferenceNone Members
AssemblyDifferenceNone Class Methods Properties See Also Send Feedback

The AssemblyDifferenceNone type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from AssemblyDifference.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from AssemblyDifference.)

See Also

AssemblyDifferenceNone Class


AssemblyDifferenceNone Properties

[image] [image]

Revit 2024 API
AssemblyDifferenceNone Properties
AssemblyDifferenceNone Class See Also Send Feedback

The AssemblyDifferenceNone type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from AssemblyDifference.)

See Also

AssemblyDifferenceNone Class


AssemblyInstance Class

[image]

Revit 2024 API
AssemblyInstance Class
Members Example See Also Send Feedback
Combines multiple elements for tagging, filtering, scheduling and creating isolated assembly views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public class AssemblyInstance : Element
Visual Basic
Public Class AssemblyInstance _
    Inherits Element
Visual C++
public ref class AssemblyInstance : public Element

Examples

CopyC#
// Identify the difference, if any, between two assembly instances
void FindAssemblyDifferences(AssemblyInstance instance1, AssemblyInstance instance2)
{
    Autodesk.Revit.DB.Document doc = instance1.Document;
    AssemblyDifference difference = AssemblyInstance.CompareAssemblyInstances(instance1, instance2);

    AssemblyDifferenceNone diffNone = difference as AssemblyDifferenceNone;
    if (diffNone != null)
    {
        TaskDialog.Show("Revit", "Assemblies are identical");
        return;
    }

    AssemblyDifferenceConfiguration diffConfig = difference as AssemblyDifferenceConfiguration;
    if (diffConfig != null)
    {
        TaskDialog.Show("Revit", "Elements are not arranged in space relative to each other in the same way");
        return;
    }

    AssemblyDifferenceMemberCount diffMemberCount = difference as AssemblyDifferenceMemberCount;
    if (diffMemberCount != null)
    {
        TaskDialog.Show("Revit", "Elements counts differ: " + diffMemberCount.Count1 + " & " + diffMemberCount.Count2);
        return;
    }

    AssemblyDifferenceNamingCategory diffNameCat = difference as AssemblyDifferenceNamingCategory;
    if (diffNameCat != null)
    {
        TaskDialog.Show("Revit", "Naming categories differ: " +
            Category.GetCategory(doc, diffNameCat.NamingCategoryId1).Name + " & " +
            Category.GetCategory(doc, diffNameCat.NamingCategoryId2).Name);
        return;
    }

    AssemblyDifferenceMemberDifference memberDifference = difference as AssemblyDifferenceMemberDifference;
    if (memberDifference != null)
    {
        AssemblyMemberDifference assemblyMemberDifference = memberDifference.MemberDifference as AssemblyMemberDifference;

        AssemblyMemberDifferentCategory differentCategory = assemblyMemberDifference as AssemblyMemberDifferentCategory;
        if (differentCategory != null)
        {
            TaskDialog.Show("Revit", "Element categories differ: " +
                Category.GetCategory(doc, diffNameCat.NamingCategoryId1).Name + " & " +
                Category.GetCategory(doc, diffNameCat.NamingCategoryId2).Name);
            return;
        }
        AssemblyMemberDifferentGeometry differentGeometry = assemblyMemberDifference as AssemblyMemberDifferentGeometry;
        if (differentGeometry != null)
        {
            TaskDialog.Show("Revit", "Member geometry differs");
            return;
        }
        AssemblyMemberDifferentParameters differentParameters = assemblyMemberDifference as AssemblyMemberDifferentParameters;
        if (differentParameters != null)
        {
            TaskDialog.Show("Revit", "Member parameters differs");
            return;
        }
        AssemblyMemberDifferentType differentType = assemblyMemberDifference as AssemblyMemberDifferentType;
        if (differentType != null)
        {
            TaskDialog.Show("Revit", "Element types differ: " + doc.GetElement(differentType.TypeId1).Name + " & " + doc.GetElement(differentType.TypeId2).Name);
            return;
        }
    }
    return;
}
CopyVB.NET
' Identify the difference, if any, between two assembly instances
Private Sub FindAssemblyDifferences(instance1 As AssemblyInstance, instance2 As AssemblyInstance)
    Dim doc As Autodesk.Revit.DB.Document = instance1.Document
    Dim difference As AssemblyDifference = AssemblyInstance.CompareAssemblyInstances(instance1, instance2)

    Dim diffNone As AssemblyDifferenceNone = TryCast(difference, AssemblyDifferenceNone)
    If diffNone IsNot Nothing Then
        TaskDialog.Show("Revit", "Assemblies are identical")
        Return
    End If

    Dim diffConfig As AssemblyDifferenceConfiguration = TryCast(difference, AssemblyDifferenceConfiguration)
    If diffConfig IsNot Nothing Then
        TaskDialog.Show("Revit", "Elements are not arranged in space relative to each other in the same way")
        Return
    End If

    Dim diffMemberCount As AssemblyDifferenceMemberCount = TryCast(difference, AssemblyDifferenceMemberCount)
    If diffMemberCount IsNot Nothing Then
        TaskDialog.Show("Revit", "Elements counts differ: " + diffMemberCount.Count1 + " & " + diffMemberCount.Count2)
        Return
    End If

    Dim diffNameCat As AssemblyDifferenceNamingCategory = TryCast(difference, AssemblyDifferenceNamingCategory)
    If diffNameCat IsNot Nothing Then
        Dim catInt1 As Long = diffNameCat.NamingCategoryId1.Value
        Dim catInt2 As Long = diffNameCat.NamingCategoryId2.Value
        TaskDialog.Show("Revit", "Naming categories differ: " + doc.Settings.Categories.Item(DirectCast(catInt1, BuiltInCategory)).Name + " & " + doc.Settings.Categories.Item(DirectCast(catInt2, BuiltInCategory)).Name)
        Return
    End If

    Dim memberDifference As AssemblyDifferenceMemberDifference = TryCast(difference, AssemblyDifferenceMemberDifference)
    If memberDifference IsNot Nothing Then
        Dim assemblyMemberDifference As AssemblyMemberDifference = TryCast(memberDifference.MemberDifference, AssemblyMemberDifference)

        Dim differentCategory As AssemblyMemberDifferentCategory = TryCast(assemblyMemberDifference, AssemblyMemberDifferentCategory)
        If differentCategory IsNot Nothing Then
            Dim int1 As Long = differentCategory.CategoryId1.Value
            Dim int2 As Long = differentCategory.CategoryId2.Value
            TaskDialog.Show("Revit", "Element categories differ: " + doc.Settings.Categories.Item(DirectCast(int1, BuiltInCategory)).Name + " & " + doc.Settings.Categories.Item(DirectCast(int2, BuiltInCategory)).Name)
            Return
        End If
        Dim differentGeometry As AssemblyMemberDifferentGeometry = TryCast(assemblyMemberDifference, AssemblyMemberDifferentGeometry)
        If differentGeometry IsNot Nothing Then
            TaskDialog.Show("Revit", "Member geometry differs")
            Return
        End If
        Dim differentParameters As AssemblyMemberDifferentParameters = TryCast(assemblyMemberDifference, AssemblyMemberDifferentParameters)
        If differentParameters IsNot Nothing Then
            TaskDialog.Show("Revit", "Member parameters differs")
            Return
        End If
        Dim differentType As AssemblyMemberDifferentType = TryCast(assemblyMemberDifference, AssemblyMemberDifferentType)
        If differentType IsNot Nothing Then
            TaskDialog.Show("Revit", "Element types differ: " + doc.GetElement(differentType.TypeId1).Name + " & " + doc.GetElement(differentType.TypeId2).Name)
            Return
        End If
    End If
    Return
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..AssemblyInstance

See Also

AssemblyInstance Members


AllowsAssemblyViewCreation Method

[image]

Revit 2024 API
AssemblyInstance..::..AllowsAssemblyViewCreation Method
AssemblyInstance Class See Also Send Feedback
Returns true if assembly views can be created for this Assembly Instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public bool AllowsAssemblyViewCreation()
Visual Basic
Public Function AllowsAssemblyViewCreation As Boolean
Visual C++
public:
bool AllowsAssemblyViewCreation()

Remarks

Assembly views are allowed when there are no assembly views for any instance of this type, or when the only existing assembly views belong to this instance

See Also

AssemblyInstance Class


AreElementsValidForAssembly Method

[image]

Revit 2024 API
AssemblyInstance..::..AreElementsValidForAssembly Method
AssemblyInstance Class See Also Send Feedback
Identifies if provided assembly members are valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static bool AreElementsValidForAssembly(
    Document document,
    ICollection<ElementId> assemblyMemberIds,
    ElementId assemblyId
)
Visual Basic
Public Shared Function AreElementsValidForAssembly ( _
    document As Document, _
    assemblyMemberIds As ICollection(Of ElementId), _
    assemblyId As ElementId _
) As Boolean
Visual C++
public:
static bool AreElementsValidForAssembly(
    Document^ document,
    ICollection<ElementId^>^ assemblyMemberIds,
    ElementId^ assemblyId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
assemblyMemberIds
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
Element ids to be tested for validity for membership of an assembly instance.
assemblyId
Type: Autodesk.Revit.DB..::..ElementId
Id of the existing assembly to add components to. If invalid, the method return whether the components can be added to a new assembly

Return Value

True if all member ids are valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

AssemblyInstance Class


CanRemoveElementsFromAssembly Method

[image]

Revit 2024 API
AssemblyInstance..::..CanRemoveElementsFromAssembly Method
AssemblyInstance Class See Also Send Feedback
Identifies if provided assembly members can be removed from the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static bool CanRemoveElementsFromAssembly(
    AssemblyInstance assemblyInstance,
    ICollection<ElementId> memberIds
)
Visual Basic
Public Shared Function CanRemoveElementsFromAssembly ( _
    assemblyInstance As AssemblyInstance, _
    memberIds As ICollection(Of ElementId) _
) As Boolean
Visual C++
public:
static bool CanRemoveElementsFromAssembly(
    AssemblyInstance^ assemblyInstance,
    ICollection<ElementId^>^ memberIds
)

Parameters

assemblyInstance
Type: Autodesk.Revit.DB..::..AssemblyInstance
The assembly instance to remove elements from.
memberIds
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
Element ids to be tested for validity to remove from the assembly instance.

Return Value

True if all member ids are valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

AssemblyInstance Class


Disassemble Method

[image]

Revit 2024 API
AssemblyInstance..::..Disassemble Method
AssemblyInstance Class See Also Send Feedback
Removes the assembly instance and releases the member elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public ICollection<ElementId> Disassemble()
Visual Basic
Public Function Disassemble As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ Disassemble()

Return Value

ids of elements previously under the assembly instance.

See Also

AssemblyInstance Class


GetMemberIds Method

[image]

Revit 2024 API
AssemblyInstance..::..GetMemberIds Method
AssemblyInstance Class See Also Send Feedback
Gets member element ids for the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public ICollection<ElementId> GetMemberIds()
Visual Basic
Public Function GetMemberIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetMemberIds()

Return Value

Element ids for the members of the assembly instance.

See Also

AssemblyInstance Class


IsValidNamingCategory Method

[image]

Revit 2024 API
AssemblyInstance..::..IsValidNamingCategory Method
AssemblyInstance Class See Also Send Feedback
Identifies if the naming category is valid for an assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static bool IsValidNamingCategory(
    Document document,
    ElementId namingCategoryId,
    ICollection<ElementId> assemblyMemberIds
)
Visual Basic
Public Shared Function IsValidNamingCategory ( _
    document As Document, _
    namingCategoryId As ElementId, _
    assemblyMemberIds As ICollection(Of ElementId) _
) As Boolean
Visual C++
public:
static bool IsValidNamingCategory(
    Document^ document,
    ElementId^ namingCategoryId,
    ICollection<ElementId^>^ assemblyMemberIds
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document for the assembly instance.
namingCategoryId
Type: Autodesk.Revit.DB..::..ElementId
The id of the naming category for the assembly instance.
assemblyMemberIds
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
Member ids to check validity of naming category

Return Value

True if the naming category is valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

AssemblyInstance Class


PlaceInstance Method

[image]

Revit 2024 API
AssemblyInstance..::..PlaceInstance Method
AssemblyInstance Class See Also Send Feedback
Places an assembly instance of a given assembly type at the specified location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static AssemblyInstance PlaceInstance(
    Document document,
    ElementId assemblyTypeId,
    XYZ location
)
Visual Basic
Public Shared Function PlaceInstance ( _
    document As Document, _
    assemblyTypeId As ElementId, _
    location As XYZ _
) As AssemblyInstance
Visual C++
public:
static AssemblyInstance^ PlaceInstance(
    Document^ document,
    ElementId^ assemblyTypeId,
    XYZ^ location
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document for the new assembly instance.
assemblyTypeId
Type: Autodesk.Revit.DB..::..ElementId
The id of the assembly type to be used for the instance.
location
Type: Autodesk.Revit.DB..::..XYZ
The placement location for the instance in project coordinates.

Return Value

The newly created assembly instance.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

AssemblyInstance Class


RemoveMemberIds Method

[image]

Revit 2024 API
AssemblyInstance..::..RemoveMemberIds Method
AssemblyInstance Class See Also Send Feedback
Removes member element ids from the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public void RemoveMemberIds(
    ICollection<ElementId> memberIds
)
Visual Basic
Public Sub RemoveMemberIds ( _
    memberIds As ICollection(Of ElementId) _
)
Visual C++
public:
void RemoveMemberIds(
    ICollection<ElementId^>^ memberIds
)

Parameters

memberIds
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
Element ids to be removed from the assembly instance.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | One or more element ids was not permitted to be removed from the assembly instance. Provided set should not be empty and all elements should be a member of the assembly instance. -or- The provided set includes one or more element ids that cannot be added to or removed from the assembly on their own.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

AssemblyInstance Class


SetMemberIds Method

[image]

Revit 2024 API
AssemblyInstance..::..SetMemberIds Method
AssemblyInstance Class See Also Send Feedback
Sets member element ids for the assembly instance. All existing members are cleared.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public void SetMemberIds(
    ICollection<ElementId> memberIds
)
Visual Basic
Public Sub SetMemberIds ( _
    memberIds As ICollection(Of ElementId) _
)
Visual C++
public:
void SetMemberIds(
    ICollection<ElementId^>^ memberIds
)

Parameters

memberIds
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
Element ids to set for the assembly instance.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | This method may not be called during dynamic update.

See Also

AssemblyInstance Class


SetTransform Method

[image]

Revit 2024 API
AssemblyInstance..::..SetTransform Method
AssemblyInstance Class See Also Send Feedback
Sets the origin of the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void SetTransform(
    Transform trf
)
Visual Basic
Public Sub SetTransform ( _
    trf As Transform _
)
Visual C++
public:
void SetTransform(
    Transform^ trf
)

Parameters

trf
Type: Autodesk.Revit.DB..::..Transform
Transform to be set.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | trf is not a rigid body transformation.

See Also

AssemblyInstance Class


AssemblyInstance Properties

[image] [image]

Revit 2024 API
AssemblyInstance Properties
AssemblyInstance Class See Also Send Feedback

The AssemblyInstance type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | AssemblyTypeName | The name for the assembly type. All matching assembly instances share this name. Unique assembly instances are named automatically based on their naming category.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of the assembly instance within project. (Overrides Element..::..Location.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | NamingCategoryId | Id of the category that drives the default naming scheme for the assembly instance.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

AssemblyInstance Class


AssemblyTypeName Property

[image]

Revit 2024 API
AssemblyInstance..::..AssemblyTypeName Property
AssemblyInstance Class See Also Send Feedback
The name for the assembly type. All matching assembly instances share this name. Unique assembly instances are named automatically based on their naming category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public string AssemblyTypeName { get; set; }
Visual Basic
Public Property AssemblyTypeName As String
    Get
    Set
Visual C++
public:
property String^ AssemblyTypeName {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: This assembly type name is not valid for this assembly instance. An assembly type name should be non-empty, should contain valid characters, and should be unique for its naming category.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

AssemblyInstance Class


NamingCategoryId Property

[image]

Revit 2024 API
AssemblyInstance..::..NamingCategoryId Property
AssemblyInstance Class See Also Send Feedback
Id of the category that drives the default naming scheme for the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public ElementId NamingCategoryId { get; set; }
Visual Basic
Public Property NamingCategoryId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ NamingCategoryId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: This naming category was not valid for an assembly instance containing the proposed members. The naming category should match one of the member element categories.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

AssemblyInstance Class


Parameter Property

[image] [image]

Revit 2024 API
AssemblyInstance..::..Parameter Property
AssemblyInstance Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

AssemblyInstance Class
AssemblyInstance Members


AssemblyMemberDifference Members

[image] [image]

Revit 2024 API
AssemblyMemberDifference Members
AssemblyMemberDifference Class Methods Properties See Also Send Feedback

The AssemblyMemberDifference type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the AssemblyMemberDifference
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

AssemblyMemberDifference Class


AssemblyMemberDifference Methods

[image] [image]

Revit 2024 API
AssemblyMemberDifference Methods
AssemblyMemberDifference Class See Also Send Feedback

The AssemblyMemberDifference type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

AssemblyMemberDifference Class


Dispose Method

[image]

Revit 2024 API
AssemblyMemberDifference..::..Dispose Method
AssemblyMemberDifference Class See Also Send Feedback
Releases all resources used by the AssemblyMemberDifference

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

AssemblyMemberDifference Class


AssemblyMemberDifference Properties

[image] [image]

Revit 2024 API
AssemblyMemberDifference Properties
AssemblyMemberDifference Class See Also Send Feedback

The AssemblyMemberDifference type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

AssemblyMemberDifference Class


IsValidObject Property

[image]

Revit 2024 API
AssemblyMemberDifference..::..IsValidObject Property
AssemblyMemberDifference Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

AssemblyMemberDifference Class


AssemblyMemberDifferentCategory Members

[image] [image]

Revit 2024 API
AssemblyMemberDifferentCategory Members
AssemblyMemberDifferentCategory Class Methods Properties See Also Send Feedback

The AssemblyMemberDifferentCategory type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from AssemblyMemberDifference.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CategoryId1 | Category id of the first assembly member
Public property | CategoryId2 | Category id of the second assembly member
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from AssemblyMemberDifference.)

See Also

AssemblyMemberDifferentCategory Class


AssemblyMemberDifferentCategory Methods

[image] [image]

Revit 2024 API
AssemblyMemberDifferentCategory Methods
AssemblyMemberDifferentCategory Class See Also Send Feedback

The AssemblyMemberDifferentCategory type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from AssemblyMemberDifference.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

AssemblyMemberDifferentCategory Class


AssemblyMemberDifferentCategory Properties

[image] [image]

Revit 2024 API
AssemblyMemberDifferentCategory Properties
AssemblyMemberDifferentCategory Class See Also Send Feedback

The AssemblyMemberDifferentCategory type exposes the following members.

Properties

 | Name | Description
Public property | CategoryId1 | Category id of the first assembly member
Public property | CategoryId2 | Category id of the second assembly member
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from AssemblyMemberDifference.)

See Also

AssemblyMemberDifferentCategory Class


CategoryId1 Property

[image]

Revit 2024 API
AssemblyMemberDifferentCategory..::..CategoryId1 Property
AssemblyMemberDifferentCategory Class See Also Send Feedback
Category id of the first assembly member

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public ElementId CategoryId1 { get; }
Visual Basic
Public ReadOnly Property CategoryId1 As ElementId
    Get
Visual C++
public:
property ElementId^ CategoryId1 {
    ElementId^ get ();
}

See Also

AssemblyMemberDifferentCategory Class


CategoryId2 Property

[image]

Revit 2024 API
AssemblyMemberDifferentCategory..::..CategoryId2 Property
AssemblyMemberDifferentCategory Class See Also Send Feedback
Category id of the second assembly member

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public ElementId CategoryId2 { get; }
Visual Basic
Public ReadOnly Property CategoryId2 As ElementId
    Get
Visual C++
public:
property ElementId^ CategoryId2 {
    ElementId^ get ();
}

See Also

AssemblyMemberDifferentCategory Class


AssemblyMemberDifferentGeometry Class

[image]

Revit 2024 API
AssemblyMemberDifferentGeometry Class
Members See Also Send Feedback
The two assembly members being compared have different geometry

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public class AssemblyMemberDifferentGeometry : AssemblyMemberDifference
Visual Basic
Public Class AssemblyMemberDifferentGeometry _
    Inherits AssemblyMemberDifference
Visual C++
public ref class AssemblyMemberDifferentGeometry : public AssemblyMemberDifference

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..AssemblyMemberDifference
Autodesk.Revit.DB..::..AssemblyMemberDifferentGeometry

See Also

AssemblyMemberDifferentGeometry Members


AssemblyMemberDifferentGeometry Members

[image] [image]

Revit 2024 API
AssemblyMemberDifferentGeometry Members
AssemblyMemberDifferentGeometry Class Methods Properties See Also Send Feedback

The AssemblyMemberDifferentGeometry type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from AssemblyMemberDifference.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from AssemblyMemberDifference.)

See Also

AssemblyMemberDifferentGeometry Class


AssemblyMemberDifferentGeometry Methods

[image] [image]

Revit 2024 API
AssemblyMemberDifferentGeometry Methods
AssemblyMemberDifferentGeometry Class See Also Send Feedback

The AssemblyMemberDifferentGeometry type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from AssemblyMemberDifference.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

AssemblyMemberDifferentGeometry Class


AssemblyMemberDifferentGeometry Properties

[image] [image]

Revit 2024 API
AssemblyMemberDifferentGeometry Properties
AssemblyMemberDifferentGeometry Class See Also Send Feedback

The AssemblyMemberDifferentGeometry type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from AssemblyMemberDifference.)

See Also

AssemblyMemberDifferentGeometry Class


AssemblyMemberDifferentParameters Class

[image]

Revit 2024 API
AssemblyMemberDifferentParameters Class
Members See Also Send Feedback
The two assembly members being compared have different parameters

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public class AssemblyMemberDifferentParameters : AssemblyMemberDifference
Visual Basic
Public Class AssemblyMemberDifferentParameters _
    Inherits AssemblyMemberDifference
Visual C++
public ref class AssemblyMemberDifferentParameters : public AssemblyMemberDifference

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..AssemblyMemberDifference
Autodesk.Revit.DB..::..AssemblyMemberDifferentParameters

See Also

AssemblyMemberDifferentParameters Members


AssemblyMemberDifferentParameters Members

[image] [image]

Revit 2024 API
AssemblyMemberDifferentParameters Members
AssemblyMemberDifferentParameters Class Methods Properties See Also Send Feedback

The AssemblyMemberDifferentParameters type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from AssemblyMemberDifference.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from AssemblyMemberDifference.)

See Also

AssemblyMemberDifferentParameters Class


AssemblyMemberDifferentParameters Methods

[image] [image]

Revit 2024 API
AssemblyMemberDifferentParameters Methods
AssemblyMemberDifferentParameters Class See Also Send Feedback

The AssemblyMemberDifferentParameters type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from AssemblyMemberDifference.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

AssemblyMemberDifferentParameters Class


AssemblyMemberDifferentType Class

[image]

Revit 2024 API
AssemblyMemberDifferentType Class
Members See Also Send Feedback
The two assembly members being compared have different type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public class AssemblyMemberDifferentType : AssemblyMemberDifference
Visual Basic
Public Class AssemblyMemberDifferentType _
    Inherits AssemblyMemberDifference
Visual C++
public ref class AssemblyMemberDifferentType : public AssemblyMemberDifference

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..AssemblyMemberDifference
Autodesk.Revit.DB..::..AssemblyMemberDifferentType

See Also

AssemblyMemberDifferentType Members


AssemblyMemberDifferentType Methods

[image] [image]

Revit 2024 API
AssemblyMemberDifferentType Methods
AssemblyMemberDifferentType Class See Also Send Feedback

The AssemblyMemberDifferentType type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from AssemblyMemberDifference.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

AssemblyMemberDifferentType Class


TypeId2 Property

[image]

Revit 2024 API
AssemblyMemberDifferentType..::..TypeId2 Property
AssemblyMemberDifferentType Class See Also Send Feedback
Type id of the second assembly member

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public ElementId TypeId2 { get; }
Visual Basic
Public ReadOnly Property TypeId2 As ElementId
    Get
Visual C++
public:
property ElementId^ TypeId2 {
    ElementId^ get ();
}

See Also

AssemblyMemberDifferentType Class


AssemblyType Class

[image]

Revit 2024 API
AssemblyType Class
Members See Also Send Feedback
Type for construction assembly elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public class AssemblyType : ElementType
Visual Basic
Public Class AssemblyType _
    Inherits ElementType
Visual C++
public ref class AssemblyType : public ElementType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..AssemblyType

See Also

AssemblyType Members


AssemblyType Members

[image] [image]

Revit 2024 API
AssemblyType Members
AssemblyType Class Methods Properties See Also Send Feedback

The AssemblyType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

AssemblyType Class


AssemblyType Methods

[image] [image]

Revit 2024 API
AssemblyType Methods
AssemblyType Class See Also Send Feedback

The AssemblyType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

AssemblyType Class


Parameter Property

[image] [image]

Revit 2024 API
AssemblyType..::..Parameter Property
AssemblyType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

AssemblyType Class
AssemblyType Members


AssemblyViewUtils Class

[image]

Revit 2024 API
AssemblyViewUtils Class
Members Example See Also Send Feedback
Utilities that provide capabilities related to assembly view creation and validation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static class AssemblyViewUtils
Visual Basic
Public NotInheritable Class AssemblyViewUtils
Visual C++
public ref class AssemblyViewUtils abstract sealed

Examples

CopyC#
private ViewSchedule CreateScheduleForAssembly(Document doc, AssemblyInstance assemblyInstance, ElementId viewTemplateId)
{
    ViewSchedule schedule = null;
    if (assemblyInstance.AllowsAssemblyViewCreation()) // create assembly views for this assembly instance
    {
        using (Transaction transaction = new Transaction(doc))
        {
            transaction.Start("Create Schedule");

            // use naming category for the schedule
            if (ViewSchedule.IsValidCategoryForSchedule(assemblyInstance.NamingCategoryId))
            {
                schedule = AssemblyViewUtils.CreateSingleCategorySchedule(doc, assemblyInstance.Id, assemblyInstance.NamingCategoryId, viewTemplateId, false);
            }
            transaction.Commit();

            if (schedule != null && transaction.GetStatus() == TransactionStatus.Committed)
            {
                transaction.Start("Edit Schedule");
                schedule.Name = "AssemblyViewSchedule";
                transaction.Commit();
            }
        }
    }

    return schedule;
}
CopyVB.NET
Private Function CreateScheduleForAssembly(doc As Document, assemblyInstance As AssemblyInstance, viewTemplateId As ElementId) As ViewSchedule
    Dim schedule As ViewSchedule = Nothing
    If assemblyInstance.AllowsAssemblyViewCreation() Then
        ' create assembly views for this assembly instance
        Using transaction As New Transaction(doc)
            transaction.Start("Create Schedule")

            ' use naming category for the schedule
            If ViewSchedule.IsValidCategoryForSchedule(assemblyInstance.NamingCategoryId) Then
                schedule = AssemblyViewUtils.CreateSingleCategorySchedule(doc, assemblyInstance.Id, assemblyInstance.NamingCategoryId, viewTemplateId, False)
            End If
            transaction.Commit()

            If schedule IsNot Nothing AndAlso transaction.GetStatus() = TransactionStatus.Committed Then
                transaction.Start("Edit Schedule")
                schedule.Name = "AssemblyViewSchedule"
                transaction.Commit()
            End If
        End Using
    End If

    Return schedule
End Function

Private Function IExternalCommand_Execute(commandData As ExternalCommandData, ByRef message As String, elements As ElementSet) As Result Implements IExternalCommand.Execute
    Throw New NotImplementedException()
End Function

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..AssemblyViewUtils

See Also

AssemblyViewUtils Members


AssemblyViewUtils Members

[image] [image]

Revit 2024 API
AssemblyViewUtils Members
AssemblyViewUtils Class Methods See Also Send Feedback

The AssemblyViewUtils type exposes the following members.

Methods

Name | Description
AcquireAssemblyViews | Transfers the assembly views owned by a source assembly instance to a target sibling assembly instance of the same assembly type.
Create3DOrthographic(Document, ElementId) | Creates a new orthographic 3D assembly view for the assembly instance.
Create3DOrthographic(Document, ElementId, ElementId, Boolean) | Creates a new orthographic 3D assembly view for the assembly instance. The view will have the same orientation as the Default 3D view. The document must be regenerated before using the 3D view.
CreateDetailSection(Document, ElementId, AssemblyDetailViewOrientation) | Creates a new detail section assembly view for the assembly instance.
CreateDetailSection(Document, ElementId, AssemblyDetailViewOrientation, ElementId, Boolean) | Creates a new detail section assembly view for the assembly instance.
CreateMaterialTakeoff(Document, ElementId) | Creates a new material takeoff multicategory schedule assembly view for the assembly instance.
CreateMaterialTakeoff(Document, ElementId, ElementId, Boolean) | Creates a new material takeoff multicategory schedule assembly view for the assembly instance.
CreatePartList(Document, ElementId) | Creates a new part list multicategory schedule assembly view for the assembly instance.
CreatePartList(Document, ElementId, ElementId, Boolean) | Creates a new part list multicategory schedule assembly view for the assembly instance.
CreateSheet | Creates a new sheet assembly view for the assembly instance.
CreateSingleCategorySchedule(Document, ElementId, ElementId) | Creates a new single-category schedule assembly view for the assembly instance.
CreateSingleCategorySchedule(Document, ElementId, ElementId, ElementId, Boolean) | Creates a new single-category schedule assembly view for the assembly instance.

See Also

AssemblyViewUtils Class


AssemblyViewUtils Methods

[image] [image]

Revit 2024 API
AssemblyViewUtils Methods
AssemblyViewUtils Class See Also Send Feedback

The AssemblyViewUtils type exposes the following members.

Methods

Name | Description
AcquireAssemblyViews | Transfers the assembly views owned by a source assembly instance to a target sibling assembly instance of the same assembly type.
Create3DOrthographic(Document, ElementId) | Creates a new orthographic 3D assembly view for the assembly instance.
Create3DOrthographic(Document, ElementId, ElementId, Boolean) | Creates a new orthographic 3D assembly view for the assembly instance. The view will have the same orientation as the Default 3D view. The document must be regenerated before using the 3D view.
CreateDetailSection(Document, ElementId, AssemblyDetailViewOrientation) | Creates a new detail section assembly view for the assembly instance.
CreateDetailSection(Document, ElementId, AssemblyDetailViewOrientation, ElementId, Boolean) | Creates a new detail section assembly view for the assembly instance.
CreateMaterialTakeoff(Document, ElementId) | Creates a new material takeoff multicategory schedule assembly view for the assembly instance.
CreateMaterialTakeoff(Document, ElementId, ElementId, Boolean) | Creates a new material takeoff multicategory schedule assembly view for the assembly instance.
CreatePartList(Document, ElementId) | Creates a new part list multicategory schedule assembly view for the assembly instance.
CreatePartList(Document, ElementId, ElementId, Boolean) | Creates a new part list multicategory schedule assembly view for the assembly instance.
CreateSheet | Creates a new sheet assembly view for the assembly instance.
CreateSingleCategorySchedule(Document, ElementId, ElementId) | Creates a new single-category schedule assembly view for the assembly instance.
CreateSingleCategorySchedule(Document, ElementId, ElementId, ElementId, Boolean) | Creates a new single-category schedule assembly view for the assembly instance.

See Also

AssemblyViewUtils Class


AcquireAssemblyViews Method

[image]

Revit 2024 API
AssemblyViewUtils..::..AcquireAssemblyViews Method
AssemblyViewUtils Class See Also Send Feedback
Transfers the assembly views owned by a source assembly instance to a target sibling assembly instance of the same assembly type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static void AcquireAssemblyViews(
    Document document,
    ElementId sourceAssemblyInstanceId,
    ElementId targetAssemblyInstanceId
)
Visual Basic
Public Shared Sub AcquireAssemblyViews ( _
    document As Document, _
    sourceAssemblyInstanceId As ElementId, _
    targetAssemblyInstanceId As ElementId _
)
Visual C++
public:
static void AcquireAssemblyViews(
    Document^ document,
    ElementId^ sourceAssemblyInstanceId,
    ElementId^ targetAssemblyInstanceId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which the assembly instances live.
sourceAssemblyInstanceId
Type: Autodesk.Revit.DB..::..ElementId
Id of the assembly instance that currently owns the assembly views.
targetAssemblyInstanceId
Type: Autodesk.Revit.DB..::..ElementId
Id of the assembly instance which will become the new owner of the assembly views.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | sourceAssemblyInstanceId is not an AssemblyInstance with assembly views. -or- targetAssemblyInstanceId is not an AssemblyInstance. -or- sourceAssemblyInstanceId and targetAssemblyInstanceId are not AssemblyInstances from the same assembly type.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

AssemblyViewUtils Class


CreateDetailSection Method

[image] [image]

Revit 2024 API
AssemblyViewUtils..::..CreateDetailSection Method
AssemblyViewUtils Class See Also Send Feedback

Overload List

Name | Description
CreateDetailSection(Document, ElementId, AssemblyDetailViewOrientation) | Creates a new detail section assembly view for the assembly instance.
CreateDetailSection(Document, ElementId, AssemblyDetailViewOrientation, ElementId, Boolean) | Creates a new detail section assembly view for the assembly instance.

See Also

AssemblyViewUtils Class
AssemblyViewUtils Members


CreateDetailSection Method (Document, ElementId, AssemblyDetailViewOrientation)

[image]

Revit 2024 API
AssemblyViewUtils..::..CreateDetailSection Method (Document, ElementId, AssemblyDetailViewOrientation)
AssemblyViewUtils Class See Also Send Feedback
Creates a new detail section assembly view for the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static ViewSection CreateDetailSection(
    Document document,
    ElementId assemblyInstanceId,
    AssemblyDetailViewOrientation direction
)
Visual Basic
Public Shared Function CreateDetailSection ( _
    document As Document, _
    assemblyInstanceId As ElementId, _
    direction As AssemblyDetailViewOrientation _
) As ViewSection
Visual C++
public:
static ViewSection^ CreateDetailSection(
    Document^ document,
    ElementId^ assemblyInstanceId,
    AssemblyDetailViewOrientation direction
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the view will be added.
assemblyInstanceId
Type: Autodesk.Revit.DB..::..ElementId
Id of the assembly instance that owns the new view.
direction
Type: Autodesk.Revit.DB..::..AssemblyDetailViewOrientation
The direction for the new view.

Return Value

A new detail section assembly view.

Remarks

The detail section will cut through the center of the assembly instance's outline. The document must be regenerated before using the detail section.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | assemblyInstanceId is not an AssemblyInstance.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

AssemblyViewUtils Class
CreateDetailSection Overload


CreateMaterialTakeoff Method

[image] [image]

Revit 2024 API
AssemblyViewUtils..::..CreateMaterialTakeoff Method
AssemblyViewUtils Class See Also Send Feedback

Overload List

Name | Description
CreateMaterialTakeoff(Document, ElementId) | Creates a new material takeoff multicategory schedule assembly view for the assembly instance.
CreateMaterialTakeoff(Document, ElementId, ElementId, Boolean) | Creates a new material takeoff multicategory schedule assembly view for the assembly instance.

See Also

AssemblyViewUtils Class
AssemblyViewUtils Members


CreateMaterialTakeoff Method (Document, ElementId)

[image]

Revit 2024 API
AssemblyViewUtils..::..CreateMaterialTakeoff Method (Document, ElementId)
AssemblyViewUtils Class See Also Send Feedback
Creates a new material takeoff multicategory schedule assembly view for the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static ViewSchedule CreateMaterialTakeoff(
    Document document,
    ElementId assemblyInstanceId
)
Visual Basic
Public Shared Function CreateMaterialTakeoff ( _
    document As Document, _
    assemblyInstanceId As ElementId _
) As ViewSchedule
Visual C++
public:
static ViewSchedule^ CreateMaterialTakeoff(
    Document^ document,
    ElementId^ assemblyInstanceId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the view will be added.
assemblyInstanceId
Type: Autodesk.Revit.DB..::..ElementId
Id of the assembly instance that owns the new view.

Return Value

A new material takeoff multicategory schedule assembly view.

Remarks

The material takeoff schedule will be preloaded with fields "Material: Name" and "Material: Volume". The document must be regenerated before using the schedule.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | assemblyInstanceId is not an AssemblyInstance.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

AssemblyViewUtils Class
CreateMaterialTakeoff Overload


CreateMaterialTakeoff Method (Document, ElementId, ElementId, Boolean)

[image]

Revit 2024 API
AssemblyViewUtils..::..CreateMaterialTakeoff Method (Document, ElementId, ElementId, Boolean)
AssemblyViewUtils Class See Also Send Feedback
Creates a new material takeoff multicategory schedule assembly view for the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public static ViewSchedule CreateMaterialTakeoff(
    Document document,
    ElementId assemblyInstanceId,
    ElementId viewTemplateId,
    bool isAssigned
)
Visual Basic
Public Shared Function CreateMaterialTakeoff ( _
    document As Document, _
    assemblyInstanceId As ElementId, _
    viewTemplateId As ElementId, _
    isAssigned As Boolean _
) As ViewSchedule
Visual C++
public:
static ViewSchedule^ CreateMaterialTakeoff(
    Document^ document,
    ElementId^ assemblyInstanceId,
    ElementId^ viewTemplateId,
    bool isAssigned
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the view will be added.
assemblyInstanceId
Type: Autodesk.Revit.DB..::..ElementId
Id of the assembly instance that owns the new view.
viewTemplateId
Type: Autodesk.Revit.DB..::..ElementId
Id of the view template that is used to create the view; if invalidElementId, the view will be created with the default settings.
isAssigned
Type: System..::..Boolean
If true, the template will be assigned, if false, the template will be applied.

Return Value

A new material takeoff multicategory schedule assembly view.

Remarks

The material takeoff schedule will be preloaded with fields "Material: Name" and "Material: Volume". The document must be regenerated before using the schedule.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | assemblyInstanceId is not an AssemblyInstance. -or- viewTemplateId is not a correct view template for the schedule view.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

AssemblyViewUtils Class
CreateMaterialTakeoff Overload


CreatePartList Method

[image] [image]

Revit 2024 API
AssemblyViewUtils..::..CreatePartList Method
AssemblyViewUtils Class See Also Send Feedback

Overload List

Name | Description
CreatePartList(Document, ElementId) | Creates a new part list multicategory schedule assembly view for the assembly instance.
CreatePartList(Document, ElementId, ElementId, Boolean) | Creates a new part list multicategory schedule assembly view for the assembly instance.

See Also

AssemblyViewUtils Class
AssemblyViewUtils Members


CreatePartList Method (Document, ElementId)

[image]

Revit 2024 API
AssemblyViewUtils..::..CreatePartList Method (Document, ElementId)
AssemblyViewUtils Class See Also Send Feedback
Creates a new part list multicategory schedule assembly view for the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static ViewSchedule CreatePartList(
    Document document,
    ElementId assemblyInstanceId
)
Visual Basic
Public Shared Function CreatePartList ( _
    document As Document, _
    assemblyInstanceId As ElementId _
) As ViewSchedule
Visual C++
public:
static ViewSchedule^ CreatePartList(
    Document^ document,
    ElementId^ assemblyInstanceId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the view will be added.
assemblyInstanceId
Type: Autodesk.Revit.DB..::..ElementId
Id of the assembly instance that owns the new view.

Return Value

A new part list multicategory schedule assembly view.

Remarks

The new part list schedule will be preloaded with fields "Category", "Family and Type" and "Count". The document must be regenerated before using the schedule.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | assemblyInstanceId is not an AssemblyInstance.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

AssemblyViewUtils Class
CreatePartList Overload


CreatePartList Method (Document, ElementId, ElementId, Boolean)

[image]

Revit 2024 API
AssemblyViewUtils..::..CreatePartList Method (Document, ElementId, ElementId, Boolean)
AssemblyViewUtils Class See Also Send Feedback
Creates a new part list multicategory schedule assembly view for the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public static ViewSchedule CreatePartList(
    Document document,
    ElementId assemblyInstanceId,
    ElementId viewTemplateId,
    bool isAssigned
)
Visual Basic
Public Shared Function CreatePartList ( _
    document As Document, _
    assemblyInstanceId As ElementId, _
    viewTemplateId As ElementId, _
    isAssigned As Boolean _
) As ViewSchedule
Visual C++
public:
static ViewSchedule^ CreatePartList(
    Document^ document,
    ElementId^ assemblyInstanceId,
    ElementId^ viewTemplateId,
    bool isAssigned
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the view will be added.
assemblyInstanceId
Type: Autodesk.Revit.DB..::..ElementId
Id of the assembly instance that owns the new view.
viewTemplateId
Type: Autodesk.Revit.DB..::..ElementId
Id of the view template that is used to create the view; if invalidElementId, the view will be created with the default settings.
isAssigned
Type: System..::..Boolean
If true, the template will be assigned, if false, the template will be applied.

Return Value

A new part list multicategory schedule assembly view.

Remarks

The new part list schedule will be preloaded with fields "Category", "Family and Type" and "Count". The document must be regenerated before using the schedule.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | assemblyInstanceId is not an AssemblyInstance. -or- viewTemplateId is not a correct view template for the schedule view.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

AssemblyViewUtils Class
CreatePartList Overload


CreateSheet Method

[image]

Revit 2024 API
AssemblyViewUtils..::..CreateSheet Method
AssemblyViewUtils Class See Also Send Feedback
Creates a new sheet assembly view for the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static ViewSheet CreateSheet(
    Document document,
    ElementId assemblyInstanceId,
    ElementId titleBlockId
)
Visual Basic
Public Shared Function CreateSheet ( _
    document As Document, _
    assemblyInstanceId As ElementId, _
    titleBlockId As ElementId _
) As ViewSheet
Visual C++
public:
static ViewSheet^ CreateSheet(
    Document^ document,
    ElementId^ assemblyInstanceId,
    ElementId^ titleBlockId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the view will be added.
assemblyInstanceId
Type: Autodesk.Revit.DB..::..ElementId
Id of the assembly instance that owns the new view.
titleBlockId
Type: Autodesk.Revit.DB..::..ElementId
Id of the titleblock family to use. For no titleblock, pass invalidElementId.

Return Value

A new sheet assembly view.

Remarks

The document must be regenerated before using the sheet.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | assemblyInstanceId is not an AssemblyInstance. -or- titleBlockId is not a TitleBlock.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

AssemblyViewUtils Class


CreateSingleCategorySchedule Method (Document, ElementId, ElementId)

[image]

Revit 2024 API
AssemblyViewUtils..::..CreateSingleCategorySchedule Method (Document, ElementId, ElementId)
AssemblyViewUtils Class See Also Send Feedback
Creates a new single-category schedule assembly view for the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static ViewSchedule CreateSingleCategorySchedule(
    Document document,
    ElementId assemblyInstanceId,
    ElementId scheduleCategoryId
)
Visual Basic
Public Shared Function CreateSingleCategorySchedule ( _
    document As Document, _
    assemblyInstanceId As ElementId, _
    scheduleCategoryId As ElementId _
) As ViewSchedule
Visual C++
public:
static ViewSchedule^ CreateSingleCategorySchedule(
    Document^ document,
    ElementId^ assemblyInstanceId,
    ElementId^ scheduleCategoryId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the view will be added.
assemblyInstanceId
Type: Autodesk.Revit.DB..::..ElementId
Id of the assembly instance that owns the new view.
scheduleCategoryId
Type: Autodesk.Revit.DB..::..ElementId
Id of the category for which the schedule will be created. Use ViewSchedule.IsValidCategoryForSchedule() to check if a category can be scheduled.

Return Value

A new single-category schedule assembly view.

Remarks

The new single-category schedule will be preloaded with fields "Family and Type" and "Count". The schedule will be empty if there are no elements of the specified category in the assembly instance. The document must be regenerated before using the schedule.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | assemblyInstanceId is not an AssemblyInstance. -or- scheduleCategoryId is not a valid category for a regular schedule.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

AssemblyViewUtils Class
CreateSingleCategorySchedule Overload


CreateSingleCategorySchedule Method (Document, ElementId, ElementId, ElementId, Boolean)

[image]

Revit 2024 API
AssemblyViewUtils..::..CreateSingleCategorySchedule Method (Document, ElementId, ElementId, ElementId, Boolean)
AssemblyViewUtils Class See Also Send Feedback
Creates a new single-category schedule assembly view for the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public static ViewSchedule CreateSingleCategorySchedule(
    Document document,
    ElementId assemblyInstanceId,
    ElementId scheduleCategoryId,
    ElementId viewTemplateId,
    bool isAssigned
)
Visual Basic
Public Shared Function CreateSingleCategorySchedule ( _
    document As Document, _
    assemblyInstanceId As ElementId, _
    scheduleCategoryId As ElementId, _
    viewTemplateId As ElementId, _
    isAssigned As Boolean _
) As ViewSchedule
Visual C++
public:
static ViewSchedule^ CreateSingleCategorySchedule(
    Document^ document,
    ElementId^ assemblyInstanceId,
    ElementId^ scheduleCategoryId,
    ElementId^ viewTemplateId,
    bool isAssigned
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the view will be added.
assemblyInstanceId
Type: Autodesk.Revit.DB..::..ElementId
Id of the assembly instance that owns the new view.
scheduleCategoryId
Type: Autodesk.Revit.DB..::..ElementId
Id of the category for which the schedule will be created. Use ViewSchedule.IsValidCategoryForSchedule() to check if a category can be scheduled.
viewTemplateId
Type: Autodesk.Revit.DB..::..ElementId
Id of the view template that is used to create the view; if invalidElementId, the view will be created with the default settings.
isAssigned
Type: System..::..Boolean
If true, the template will be assigned, if false, the template will be applied.

Return Value

A new single-category schedule assembly view.

Remarks

The new single-category schedule will be preloaded with fields "Family and Type" and "Count". The schedule will be empty if there are no elements of the specified category in the assembly instance. The document must be regenerated before using the schedule.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | assemblyInstanceId is not an AssemblyInstance. -or- scheduleCategoryId is not a valid category for a regular schedule. -or- viewTemplateId is not a correct view template for the schedule view.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

AssemblyViewUtils Class
CreateSingleCategorySchedule Overload


AttachmentType Enumeration

[image]

Revit 2024 API
AttachmentType Enumeration
See Also Send Feedback
Enum determining whether a link is an attachment or an overlay

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Since: 2012

Syntax

C#
public enum AttachmentType
Visual Basic
Public Enumeration AttachmentType
Visual C++
public enum class AttachmentType

Members

Member name | Description
Overlay | The link is an overlay, only meant to be seen in this file. If the host is linked into another file, the link will not be brought along.
Attachment | The link is an attachment. If the host file is linked into another file, the link will also be brought along.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


AutomaticConnectionBehaviorType Enumeration

[image]

Revit 2024 API
AutomaticConnectionBehaviorType Enumeration
See Also Send Feedback
Defines behavior of connector with respect to automatic creation of connections
Enumeration of automatic connection behavior types

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum AutomaticConnectionBehaviorType
Visual Basic
Public Enumeration AutomaticConnectionBehaviorType
Visual C++
public enum class AutomaticConnectionBehaviorType

Members

Member name | Description
Exclude | Connector does not participate in automatic connection
Active | Connector is actively looking to be connected
Forced | Connector must establish a connection
Accepting | Connector accepts more automatic connections if needed, but
Full | Connector may participate in automatic connection, but at the moment it is fully connected

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


AXMImportOptions Members

[image] [image]

Revit 2024 API
AXMImportOptions Members
AXMImportOptions Class Constructors Methods Properties See Also Send Feedback

The AXMImportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | AXMImportOptions()()()() | Constructs a new instance of AXMImportOptions with default values of all properties.
Public method | AXMImportOptions(AXMImportOptions) | Constructs a new instance of AXMImportOptions as a copy of the provided import options.

Methods

 | Name | Description
Public method | Dispose | (Inherited from BaseImportOptions.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDefaultLengthUnit | Get the default length unit used for importing unitless files. (Inherited from BaseImportOptions.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLayerSelection | Get all set layers name which user want to import into Revit. (Inherited from BaseImportOptions.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultLengthUnit | Set the default length unit used for importing unitless files. (Inherited from BaseImportOptions.)
Public method | SetLayerSelection | Set the layers name which user want to import into Revit. (Inherited from BaseImportOptions.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AutoCorrectAlmostVHLines | Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines. (Inherited from BaseImportOptions.)
Public property | ColorMode | Color mode for the import. Three modes are supported. Black and White, Preserve Colors, and Invert Colors. (Inherited from BaseImportOptions.)
Public property | CustomScale | Scaling the import. If this is defined and a valid value (> 0.0), it takes priority over units. (Inherited from BaseImportOptions.)
Public property | ImportLevels | Indicate if levels are to be imported. False by default.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BaseImportOptions.)
Public property | OrientToView | Place the import at the same orientation as the view that was passed into the import method. This option can only be used when not importing into a single view.(i.e. ThisViewOnly is set to false) (Inherited from BaseImportOptions.)
Public property | Placement | Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates. (Inherited from BaseImportOptions.)
Public property | ReferencePoint | The 3D point in the document where the imported instance will be inserted. If not explicitly set, the instance will be inserted at the document origin. (Inherited from BaseImportOptions.)
Public property | ThisViewOnly | Imports drawings into the view that was passed into the import method. This option is not available in 3D views. (Inherited from BaseImportOptions.)
Public property | Unit | The unit of measure for imported geometry. (Inherited from BaseImportOptions.)
Public property | VisibleLayersOnly | Only import the visible layers. (Inherited from BaseImportOptions.)

See Also

AXMImportOptions Class


AXMImportOptions Constructor

[image] [image]

Revit 2024 API
AXMImportOptions Constructor
AXMImportOptions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AXMImportOptions()()()() | Constructs a new instance of AXMImportOptions with default values of all properties.
Public method | AXMImportOptions(AXMImportOptions) | Constructs a new instance of AXMImportOptions as a copy of the provided import options.

See Also

AXMImportOptions Class
AXMImportOptions Members


AXMImportOptions Constructor

[image]

Revit 2024 API
AXMImportOptions Constructor
AXMImportOptions Class See Also Send Feedback
Constructs a new instance of AXMImportOptions with default values of all properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022.1

Syntax

C#
public AXMImportOptions()
Visual Basic
Public Sub New
Visual C++
public:
AXMImportOptions()

See Also

AXMImportOptions Class
AXMImportOptions Overload


AXMImportOptions Constructor (AXMImportOptions)

[image]

Revit 2024 API
AXMImportOptions Constructor (AXMImportOptions)
AXMImportOptions Class See Also Send Feedback
Constructs a new instance of AXMImportOptions as a copy of the provided import options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022.1

Syntax

C#
public AXMImportOptions(
    AXMImportOptions option
)
Visual Basic
Public Sub New ( _
    option As AXMImportOptions _
)
Visual C++
public:
AXMImportOptions(
    AXMImportOptions^ option
)

Parameters

option
Type: Autodesk.Revit.DB..::..AXMImportOptions
The AXM import options to be copied.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

AXMImportOptions Class
AXMImportOptions Overload


AXMImportOptions Methods

[image] [image]

Revit 2024 API
AXMImportOptions Methods
AXMImportOptions Class See Also Send Feedback

The AXMImportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from BaseImportOptions.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDefaultLengthUnit | Get the default length unit used for importing unitless files. (Inherited from BaseImportOptions.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLayerSelection | Get all set layers name which user want to import into Revit. (Inherited from BaseImportOptions.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultLengthUnit | Set the default length unit used for importing unitless files. (Inherited from BaseImportOptions.)
Public method | SetLayerSelection | Set the layers name which user want to import into Revit. (Inherited from BaseImportOptions.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

AXMImportOptions Class


ImportLevels Property

[image]

Revit 2024 API
AXMImportOptions..::..ImportLevels Property
AXMImportOptions Class See Also Send Feedback
Indicate if levels are to be imported. False by default.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022.1

Syntax

C#
public bool ImportLevels { get; set; }
Visual Basic
Public Property ImportLevels As Boolean
    Get
    Set
Visual C++
public:
property bool ImportLevels {
    bool get ();
    void set (bool value);
}

See Also

AXMImportOptions Class


BackClippingParam Enumeration

[image]

Revit 2024 API
BackClippingParam Enumeration
See Also Send Feedback
The allowed values for the VIEW_BACK_CLIPPING and VIEWER_BOUND_FAR_CLIPPING parameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum BackClippingParam
Visual Basic
Public Enumeration BackClippingParam
Visual C++
public enum class BackClippingParam

Members

Member name | Description
NoClip | No clip
ClipWithLine | Clip with line.
ClipNoLine | Clip without line.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


BackgroundImageFit Enumeration

[image]

Revit 2024 API
BackgroundImageFit Enumeration
See Also Send Feedback
Indicates the background image fit type in rendering settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public enum BackgroundImageFit
Visual Basic
Public Enumeration BackgroundImageFit
Visual C++
public enum class BackgroundImageFit

Members

Member name | Description
None | No scale applied to the image; it will keep its original size.
Vertical | The image is proportionally resized so its height matches the view's height.
Horizontal | The image is proportionally resized so its width matches the view's width.
Stretch | The image is stretched in both directions so it matches the view's size.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


BackgroundSettings Methods

[image] [image]

Revit 2024 API
BackgroundSettings Methods
BackgroundSettings Class See Also Send Feedback

The BackgroundSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BackgroundSettings Class


Dispose Method

[image]

Revit 2024 API
BackgroundSettings..::..Dispose Method
BackgroundSettings Class See Also Send Feedback
Releases all resources used by the BackgroundSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

BackgroundSettings Class


BackgroundSettings Properties

[image] [image]

Revit 2024 API
BackgroundSettings Properties
BackgroundSettings Class See Also Send Feedback

The BackgroundSettings type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

BackgroundSettings Class


IsValidObject Property

[image]

Revit 2024 API
BackgroundSettings..::..IsValidObject Property
BackgroundSettings Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

BackgroundSettings Class


BarTypeDiameterOptions Class

[image]

Revit 2024 API
BarTypeDiameterOptions Class
Members See Also Send Feedback
This class stores the diameter information from the RebarBarType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018.1

Syntax

C#
public class BarTypeDiameterOptions : IDisposable
Visual Basic
Public Class BarTypeDiameterOptions _
    Implements IDisposable
Visual C++
public ref class BarTypeDiameterOptions : IDisposable

Remarks

This class can be used to create a whole new set of diameter values for a RebarBarType. It can be used when copying the diameter information as a bulk of data from a RebarBarType to another. The new diameters can be set in the RebarBarType in the following way: 1. Create a BarTypeDiameterOptions object with the new diameters. 2. Set the new diameters in RebarBarType using [!:Autodesk::Revit::DB::Structure::RebarBarType::SetBarTypeDiameters(Autodesk::Revit::DB::BarTypeDiameterOptions ^diametersOpt)]. The method [!:Autodesk::Revit::DB::Structure::RebarBarType::SetBarTypeDiameters(Autodesk::Revit::DB::BarTypeDiameterOptions ^diametersOpt)] is responsible for diameters validation.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BarTypeDiameterOptions

See Also

BarTypeDiameterOptions Members


BarTypeDiameterOptions Constructor

[image]

Revit 2024 API
BarTypeDiameterOptions Constructor
BarTypeDiameterOptions Class See Also Send Feedback
Constructs a new BarTypeDiameterOptions with default settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018.1

Syntax

C#
public BarTypeDiameterOptions()
Visual Basic
Public Sub New
Visual C++
public:
BarTypeDiameterOptions()

See Also

BarTypeDiameterOptions Class
BarTypeDiameterOptions Overload


BarTypeDiameterOptions Constructor (RebarBarType)

[image]

Revit 2024 API
BarTypeDiameterOptions Constructor (RebarBarType)
BarTypeDiameterOptions Class See Also Send Feedback
Constructs a new BarTypeDiameterOptions copying the diameter information from the bar type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018.1

Syntax

C#
public BarTypeDiameterOptions(
    RebarBarType barType
)
Visual Basic
Public Sub New ( _
    barType As RebarBarType _
)
Visual C++
public:
BarTypeDiameterOptions(
    RebarBarType^ barType
)

Parameters

barType
Type: Autodesk.Revit.DB.Structure..::..RebarBarType

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

BarTypeDiameterOptions Class
BarTypeDiameterOptions Overload


Dispose Method

[image]

Revit 2024 API
BarTypeDiameterOptions..::..Dispose Method
BarTypeDiameterOptions Class See Also Send Feedback
Releases all resources used by the BarTypeDiameterOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

BarTypeDiameterOptions Class


BarTypeDiameterOptions Properties

[image] [image]

Revit 2024 API
BarTypeDiameterOptions Properties
BarTypeDiameterOptions Class See Also Send Feedback

The BarTypeDiameterOptions type exposes the following members.

Properties

 | Name | Description
Public property | BarModelDiameter | Represents the bar model diameter of the RebarBarType.
Public property | BarNominalDiameter | Represents the bar nominal diameter of the RebarBarType.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | StandardBendDiameter | Represents the standard bar bend diameter of the RebarBarType.
Public property | StandardHookBendDiameter | Represents the standard hook bend diameter of the RebarBarType.
Public property | StirrupTieBendDiameter | Represents the stirrup/tie bar and hook bend diameter of the RebarBarType.

See Also

BarTypeDiameterOptions Class


BarModelDiameter Property

[image]

Revit 2024 API
BarTypeDiameterOptions..::..BarModelDiameter Property
BarTypeDiameterOptions Class See Also Send Feedback
Represents the bar model diameter of the RebarBarType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018.1

Syntax

C#
public double BarModelDiameter { get; set; }
Visual Basic
Public Property BarModelDiameter As Double
    Get
    Set
Visual C++
public:
property double BarModelDiameter {
    double get ();
    void set (double value);
}

See Also

BarTypeDiameterOptions Class


BarNominalDiameter Property

[image]

Revit 2024 API
BarTypeDiameterOptions..::..BarNominalDiameter Property
BarTypeDiameterOptions Class See Also Send Feedback
Represents the bar nominal diameter of the RebarBarType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018.1

Syntax

C#
public double BarNominalDiameter { get; set; }
Visual Basic
Public Property BarNominalDiameter As Double
    Get
    Set
Visual C++
public:
property double BarNominalDiameter {
    double get ();
    void set (double value);
}

See Also

BarTypeDiameterOptions Class


IsValidObject Property

[image]

Revit 2024 API
BarTypeDiameterOptions..::..IsValidObject Property
BarTypeDiameterOptions Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

BarTypeDiameterOptions Class


StandardBendDiameter Property

[image]

Revit 2024 API
BarTypeDiameterOptions..::..StandardBendDiameter Property
BarTypeDiameterOptions Class See Also Send Feedback
Represents the standard bar bend diameter of the RebarBarType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018.1

Syntax

C#
public double StandardBendDiameter { get; set; }
Visual Basic
Public Property StandardBendDiameter As Double
    Get
    Set
Visual C++
public:
property double StandardBendDiameter {
    double get ();
    void set (double value);
}

See Also

BarTypeDiameterOptions Class


StandardHookBendDiameter Property

[image]

Revit 2024 API
BarTypeDiameterOptions..::..StandardHookBendDiameter Property
BarTypeDiameterOptions Class See Also Send Feedback
Represents the standard hook bend diameter of the RebarBarType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018.1

Syntax

C#
public double StandardHookBendDiameter { get; set; }
Visual Basic
Public Property StandardHookBendDiameter As Double
    Get
    Set
Visual C++
public:
property double StandardHookBendDiameter {
    double get ();
    void set (double value);
}

See Also

BarTypeDiameterOptions Class


StirrupTieBendDiameter Property

[image]

Revit 2024 API
BarTypeDiameterOptions..::..StirrupTieBendDiameter Property
BarTypeDiameterOptions Class See Also Send Feedback
Represents the stirrup/tie bar and hook bend diameter of the RebarBarType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018.1

Syntax

C#
public double StirrupTieBendDiameter { get; set; }
Visual Basic
Public Property StirrupTieBendDiameter As Double
    Get
    Set
Visual C++
public:
property double StirrupTieBendDiameter {
    double get ();
    void set (double value);
}

See Also

BarTypeDiameterOptions Class


BaseArray Members

[image] [image]

Revit 2024 API
BaseArray Members
BaseArray Class Methods Properties See Also Send Feedback

The BaseArray type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetCopiedMemberIds | Retrieves the copied member Ids of the Array.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetOriginalMemberIds | Retrieves the original member Ids of the Array.
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | Label | The family parameter label of the BaseArray.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Get and Set the Name property (Overrides Element..::..Name.)
Public property | NumMembers | Retrieves or changes the number of the arrayed members.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

BaseArray Class


BaseArray Methods

[image] [image]

Revit 2024 API
BaseArray Methods
BaseArray Class See Also Send Feedback

The BaseArray type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetCopiedMemberIds | Retrieves the copied member Ids of the Array.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetOriginalMemberIds | Retrieves the original member Ids of the Array.
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BaseArray Class


GetOriginalMemberIds Method

[image]

Revit 2024 API
BaseArray..::..GetOriginalMemberIds Method
BaseArray Class See Also Send Feedback
Retrieves the original member Ids of the Array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public abstract ICollection<ElementId> GetOriginalMemberIds()
Visual Basic
Public MustOverride Function GetOriginalMemberIds As ICollection(Of ElementId)
Visual C++
public:
virtual ICollection<ElementId^>^ GetOriginalMemberIds() abstract

Return Value

The original member Ids of the Array

See Also

BaseArray Class


BaseArray Properties

[image] [image]

Revit 2024 API
BaseArray Properties
BaseArray Class See Also Send Feedback

The BaseArray type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | Label | The family parameter label of the BaseArray.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Get and Set the Name property (Overrides Element..::..Name.)
Public property | NumMembers | Retrieves or changes the number of the arrayed members.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

BaseArray Class


Label Property

[image]

Revit 2024 API
BaseArray..::..Label Property
BaseArray Class See Also Send Feedback
The family parameter label of the BaseArray.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyParameter Label { get; set; }
Visual Basic
Public Property Label As FamilyParameter
    Get
    Set
Visual C++
public:
property FamilyParameter^ Label {
    FamilyParameter^ get ();
    void set (FamilyParameter^ value);
}

Remarks

The label associates the number of members of the array with a family parameter. A BaseArray only can be labeled in a family document and only can be labeled to a integer FamilyParameter. To unbind the family parameter, set this property to nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the family parameter's ParameterType is not ParameterType.Integer.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when trying to label the BaseArray out of family document.

See Also

BaseArray Class


Name Property

[image]

Revit 2024 API
BaseArray..::..Name Property
BaseArray Class See Also Send Feedback
Get and Set the Name property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public override string Name { set; }
Visual Basic
Public Overrides WriteOnly Property Name As String
    Set
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Remarks

The method set is override to forbid the user to change the Name. When the user tries to call the method set for BaseArray object, an InvalidOperationException will be thrown.

See Also

BaseArray Class


NumMembers Property

[image]

Revit 2024 API
BaseArray..::..NumMembers Property
BaseArray Class See Also Send Feedback
Retrieves or changes the number of the arrayed members.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public abstract int NumMembers { get; set; }
Visual Basic
Public MustOverride Property NumMembers As Integer
    Get
    Set
Visual C++
public:
virtual property int NumMembers {
    int get () abstract;
    void set (int value) abstract;
}

See Also

BaseArray Class


BaseExportOptions Members

[image] [image]

Revit 2024 API
BaseExportOptions Members
BaseExportOptions Class Methods Properties See Also Send Feedback

The BaseExportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the BaseExportOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetExportFontTable | Gets font table.
Public method | GetExportLayerTable | Gets the layer table.
Public method | GetExportLinetypeTable | Gets a copy of the line type table.
Public method | GetExportPatternTable | Gets a copy of the pattern table.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPredefinedSetupNames | Returns a list of names of predefined setups of export options.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetExportFontTable | Sets font table to option.
Public method | SetExportLayerTable | Sets layer table back to option
Public method | SetExportLinetypeTable | Sets the line type table to use during export.
Public method | SetExportPatternTable | Sets the pattern table to use during export.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Colors | Export color mode. Default value is ExportColorMode.IndexColors.
Public property | HatchPatternsFileName | Custom hatch patterns (pat) file name.
Public property | HideReferencePlane | Whether or not to hide reference planes. Default value is false.
Public property | HideScopeBox | Whether or not to hide the scope box. Default value is false.
Public property | HideUnreferenceViewTags | Whether or not to hide unreference view tags. Default value is false.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LayerMapping | Name of a layer settings standard or filename (with custom layer settings). Valid standards are: DGNV7 (only for DGN), AIA, CP83, BS1192, and ISO13567. default value is "" (empty) which means if no value is set, if no value is set, Revit will use a default value according to the localization.
Public property | PreserveCoincidentLines | Whether or not to preserve coincident lines. Default value is false.
Public property | PropOverrides | How to export overridden object styles. Default value is PropOverrideMode.ByEntity.

See Also

BaseExportOptions Class


BaseExportOptions Methods

[image] [image]

Revit 2024 API
BaseExportOptions Methods
BaseExportOptions Class See Also Send Feedback

The BaseExportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetExportFontTable | Gets font table.
Public method | GetExportLayerTable | Gets the layer table.
Public method | GetExportLinetypeTable | Gets a copy of the line type table.
Public method | GetExportPatternTable | Gets a copy of the pattern table.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPredefinedSetupNames | Returns a list of names of predefined setups of export options.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetExportFontTable | Sets font table to option.
Public method | SetExportLayerTable | Sets layer table back to option
Public method | SetExportLinetypeTable | Sets the line type table to use during export.
Public method | SetExportPatternTable | Sets the pattern table to use during export.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BaseExportOptions Class


Dispose Method

[image]

Revit 2024 API
BaseExportOptions..::..Dispose Method
BaseExportOptions Class See Also Send Feedback
Releases all resources used by the BaseExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

BaseExportOptions Class


GetExportFontTable Method

[image]

Revit 2024 API
BaseExportOptions..::..GetExportFontTable Method
BaseExportOptions Class See Also Send Feedback
Gets font table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ExportFontTable GetExportFontTable()
Visual Basic
Public Function GetExportFontTable As ExportFontTable
Visual C++
public:
ExportFontTable^ GetExportFontTable()

See Also

BaseExportOptions Class


GetExportLayerTable Method

[image]

Revit 2024 API
BaseExportOptions..::..GetExportLayerTable Method
BaseExportOptions Class See Also Send Feedback
Gets the layer table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ExportLayerTable GetExportLayerTable()
Visual Basic
Public Function GetExportLayerTable As ExportLayerTable
Visual C++
public:
ExportLayerTable^ GetExportLayerTable()

Return Value

The layer table.

See Also

BaseExportOptions Class


GetExportPatternTable Method

[image]

Revit 2024 API
BaseExportOptions..::..GetExportPatternTable Method
BaseExportOptions Class See Also Send Feedback
Gets a copy of the pattern table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ExportPatternTable GetExportPatternTable()
Visual Basic
Public Function GetExportPatternTable As ExportPatternTable
Visual C++
public:
ExportPatternTable^ GetExportPatternTable()

Return Value

The pattern table.

See Also

BaseExportOptions Class


GetPredefinedSetupNames Method

[image]

Revit 2024 API
BaseExportOptions..::..GetPredefinedSetupNames Method
BaseExportOptions Class See Also Send Feedback
Returns a list of names of predefined setups of export options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static IList<string> GetPredefinedSetupNames(
    Document document
)
Visual Basic
Public Shared Function GetPredefinedSetupNames ( _
    document As Document _
) As IList(Of String)
Visual C++
public:
static IList<String^>^ GetPredefinedSetupNames(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
A Revit document to retrieve names from.

Return Value

An array of strings representing names of predefined setups.

Remarks

The predefined setups may be used for export to both DWG and DXF formats. To get predefined options in the desired format use the static method getPredefinedOptions defined in DWGExportOptions or DXFExportOptions respectively.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

BaseExportOptions Class


SetExportFontTable Method

[image]

Revit 2024 API
BaseExportOptions..::..SetExportFontTable Method
BaseExportOptions Class See Also Send Feedback
Sets font table to option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void SetExportFontTable(
    ExportFontTable fontTable
)
Visual Basic
Public Sub SetExportFontTable ( _
    fontTable As ExportFontTable _
)
Visual C++
public:
void SetExportFontTable(
    ExportFontTable^ fontTable
)

Parameters

fontTable
Type: Autodesk.Revit.DB..::..ExportFontTable
The font table to be set.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

BaseExportOptions Class


SetExportLayerTable Method

[image]

Revit 2024 API
BaseExportOptions..::..SetExportLayerTable Method
BaseExportOptions Class See Also Send Feedback
Sets layer table back to option

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void SetExportLayerTable(
    ExportLayerTable layerTable
)
Visual Basic
Public Sub SetExportLayerTable ( _
    layerTable As ExportLayerTable _
)
Visual C++
public:
void SetExportLayerTable(
    ExportLayerTable^ layerTable
)

Parameters

layerTable
Type: Autodesk.Revit.DB..::..ExportLayerTable
The layer table to be set

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

BaseExportOptions Class


SetExportLinetypeTable Method

[image]

Revit 2024 API
BaseExportOptions..::..SetExportLinetypeTable Method
BaseExportOptions Class See Also Send Feedback
Sets the line type table to use during export.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void SetExportLinetypeTable(
    ExportLinetypeTable linetypeTable
)
Visual Basic
Public Sub SetExportLinetypeTable ( _
    linetypeTable As ExportLinetypeTable _
)
Visual C++
public:
void SetExportLinetypeTable(
    ExportLinetypeTable^ linetypeTable
)

Parameters

linetypeTable
Type: Autodesk.Revit.DB..::..ExportLinetypeTable
The line type table to be set.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

BaseExportOptions Class


SetExportPatternTable Method

[image]

Revit 2024 API
BaseExportOptions..::..SetExportPatternTable Method
BaseExportOptions Class See Also Send Feedback
Sets the pattern table to use during export.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void SetExportPatternTable(
    ExportPatternTable patternTable
)
Visual Basic
Public Sub SetExportPatternTable ( _
    patternTable As ExportPatternTable _
)
Visual C++
public:
void SetExportPatternTable(
    ExportPatternTable^ patternTable
)

Parameters

patternTable
Type: Autodesk.Revit.DB..::..ExportPatternTable
The pattern table to be set.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

BaseExportOptions Class


BaseExportOptions Properties

[image] [image]

Revit 2024 API
BaseExportOptions Properties
BaseExportOptions Class See Also Send Feedback

The BaseExportOptions type exposes the following members.

Properties

 | Name | Description
Public property | Colors | Export color mode. Default value is ExportColorMode.IndexColors.
Public property | HatchPatternsFileName | Custom hatch patterns (pat) file name.
Public property | HideReferencePlane | Whether or not to hide reference planes. Default value is false.
Public property | HideScopeBox | Whether or not to hide the scope box. Default value is false.
Public property | HideUnreferenceViewTags | Whether or not to hide unreference view tags. Default value is false.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LayerMapping | Name of a layer settings standard or filename (with custom layer settings). Valid standards are: DGNV7 (only for DGN), AIA, CP83, BS1192, and ISO13567. default value is "" (empty) which means if no value is set, if no value is set, Revit will use a default value according to the localization.
Public property | PreserveCoincidentLines | Whether or not to preserve coincident lines. Default value is false.
Public property | PropOverrides | How to export overridden object styles. Default value is PropOverrideMode.ByEntity.

See Also

BaseExportOptions Class


Colors Property

[image]

Revit 2024 API
BaseExportOptions..::..Colors Property
BaseExportOptions Class See Also Send Feedback
Export color mode. Default value is ExportColorMode.IndexColors.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ExportColorMode Colors { get; set; }
Visual Basic
Public Property Colors As ExportColorMode
    Get
    Set
Visual C++
public:
property ExportColorMode Colors {
    ExportColorMode get ();
    void set (ExportColorMode value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

BaseExportOptions Class


HatchPatternsFileName Property

[image]

Revit 2024 API
BaseExportOptions..::..HatchPatternsFileName Property
BaseExportOptions Class See Also Send Feedback
Custom hatch patterns (pat) file name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public string HatchPatternsFileName { get; set; }
Visual Basic
Public Property HatchPatternsFileName As String
    Get
    Set
Visual C++
public:
property String^ HatchPatternsFileName {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

BaseExportOptions Class


HideReferencePlane Property

[image]

Revit 2024 API
BaseExportOptions..::..HideReferencePlane Property
BaseExportOptions Class See Also Send Feedback
Whether or not to hide reference planes. Default value is false.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool HideReferencePlane { get; set; }
Visual Basic
Public Property HideReferencePlane As Boolean
    Get
    Set
Visual C++
public:
property bool HideReferencePlane {
    bool get ();
    void set (bool value);
}

See Also

BaseExportOptions Class


HideScopeBox Property

[image]

Revit 2024 API
BaseExportOptions..::..HideScopeBox Property
BaseExportOptions Class See Also Send Feedback
Whether or not to hide the scope box. Default value is false.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool HideScopeBox { get; set; }
Visual Basic
Public Property HideScopeBox As Boolean
    Get
    Set
Visual C++
public:
property bool HideScopeBox {
    bool get ();
    void set (bool value);
}

See Also

BaseExportOptions Class


HideUnreferenceViewTags Property

[image]

Revit 2024 API
BaseExportOptions..::..HideUnreferenceViewTags Property
BaseExportOptions Class See Also Send Feedback
Whether or not to hide unreference view tags. Default value is false.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool HideUnreferenceViewTags { get; set; }
Visual Basic
Public Property HideUnreferenceViewTags As Boolean
    Get
    Set
Visual C++
public:
property bool HideUnreferenceViewTags {
    bool get ();
    void set (bool value);
}

See Also

BaseExportOptions Class


IsValidObject Property

[image]

Revit 2024 API
BaseExportOptions..::..IsValidObject Property
BaseExportOptions Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

BaseExportOptions Class


LayerMapping Property

[image]

Revit 2024 API
BaseExportOptions..::..LayerMapping Property
BaseExportOptions Class See Also Send Feedback
Name of a layer settings standard or filename (with custom layer settings). Valid standards are: DGNV7 (only for DGN), AIA, CP83, BS1192, and ISO13567. default value is "" (empty) which means if no value is set, if no value is set, Revit will use a default value according to the localization.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public string LayerMapping { get; set; }
Visual Basic
Public Property LayerMapping As String
    Get
    Set
Visual C++
public:
property String^ LayerMapping {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

BaseExportOptions Class


PreserveCoincidentLines Property

[image]

Revit 2024 API
BaseExportOptions..::..PreserveCoincidentLines Property
BaseExportOptions Class See Also Send Feedback
Whether or not to preserve coincident lines. Default value is false.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015 Subscription Update

Syntax

C#
public bool PreserveCoincidentLines { get; set; }
Visual Basic
Public Property PreserveCoincidentLines As Boolean
    Get
    Set
Visual C++
public:
property bool PreserveCoincidentLines {
    bool get ();
    void set (bool value);
}

See Also

BaseExportOptions Class


BaseImportOptions Class

[image]

Revit 2024 API
BaseImportOptions Class
Members See Also Send Feedback
A base class containing import options used during import of several formats.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public class BaseImportOptions : IDisposable
Visual Basic
Public Class BaseImportOptions _
    Implements IDisposable
Visual C++
public ref class BaseImportOptions : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BaseImportOptions
Autodesk.Revit.DB..::..AXMImportOptions
Autodesk.Revit.DB..::..DGNImportOptions
Autodesk.Revit.DB..::..DWGImportOptions
Autodesk.Revit.DB..::..ImportOptions3DM
Autodesk.Revit.DB..::..OBJImportOptions
Autodesk.Revit.DB..::..SATImportOptions
Autodesk.Revit.DB..::..SKPImportOptions
Autodesk.Revit.DB..::..STLImportOptions

See Also

BaseImportOptions Members


BaseImportOptions Members

[image] [image]

Revit 2024 API
BaseImportOptions Members
BaseImportOptions Class Methods Properties See Also Send Feedback

The BaseImportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the BaseImportOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDefaultLengthUnit | Get the default length unit used for importing unitless files.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLayerSelection | Get all set layers name which user want to import into Revit.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultLengthUnit | Set the default length unit used for importing unitless files.
Public method | SetLayerSelection | Set the layers name which user want to import into Revit.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AutoCorrectAlmostVHLines | Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines.
Public property | ColorMode | Color mode for the import. Three modes are supported. Black and White, Preserve Colors, and Invert Colors.
Public property | CustomScale | Scaling the import. If this is defined and a valid value (> 0.0), it takes priority over units.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OrientToView | Place the import at the same orientation as the view that was passed into the import method. This option can only be used when not importing into a single view.(i.e. ThisViewOnly is set to false)
Public property | Placement | Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates.
Public property | ReferencePoint | The 3D point in the document where the imported instance will be inserted. If not explicitly set, the instance will be inserted at the document origin.
Public property | ThisViewOnly | Imports drawings into the view that was passed into the import method. This option is not available in 3D views.
Public property | Unit | The unit of measure for imported geometry.
Public property | VisibleLayersOnly | Only import the visible layers.

See Also

BaseImportOptions Class


BaseImportOptions Methods

[image] [image]

Revit 2024 API
BaseImportOptions Methods
BaseImportOptions Class See Also Send Feedback

The BaseImportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDefaultLengthUnit | Get the default length unit used for importing unitless files.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLayerSelection | Get all set layers name which user want to import into Revit.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultLengthUnit | Set the default length unit used for importing unitless files.
Public method | SetLayerSelection | Set the layers name which user want to import into Revit.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BaseImportOptions Class


Dispose Method

[image]

Revit 2024 API
BaseImportOptions..::..Dispose Method
BaseImportOptions Class See Also Send Feedback
Releases all resources used by the BaseImportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

BaseImportOptions Class


GetLayerSelection Method

[image]

Revit 2024 API
BaseImportOptions..::..GetLayerSelection Method
BaseImportOptions Class See Also Send Feedback
Get all set layers name which user want to import into Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ICollection<string> GetLayerSelection()
Visual Basic
Public Function GetLayerSelection As ICollection(Of String)
Visual C++
public:
ICollection<String^>^ GetLayerSelection()

Return Value

The layers' name.

See Also

BaseImportOptions Class


SetDefaultLengthUnit Method

[image]

Revit 2024 API
BaseImportOptions..::..SetDefaultLengthUnit Method
BaseImportOptions Class See Also Send Feedback
Set the default length unit used for importing unitless files.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022.1

Syntax

C#
public void SetDefaultLengthUnit(
    ForgeTypeId specTypeId
)
Visual Basic
Public Sub SetDefaultLengthUnit ( _
    specTypeId As ForgeTypeId _
)
Visual C++
public:
void SetDefaultLengthUnit(
    ForgeTypeId^ specTypeId
)

Parameters

specTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
The default length unit.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given specTypeId is not a supported unit of length.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

BaseImportOptions Class


BaseImportOptions Properties

[image] [image]

Revit 2024 API
BaseImportOptions Properties
BaseImportOptions Class See Also Send Feedback

The BaseImportOptions type exposes the following members.

Properties

 | Name | Description
Public property | AutoCorrectAlmostVHLines | Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines.
Public property | ColorMode | Color mode for the import. Three modes are supported. Black and White, Preserve Colors, and Invert Colors.
Public property | CustomScale | Scaling the import. If this is defined and a valid value (> 0.0), it takes priority over units.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OrientToView | Place the import at the same orientation as the view that was passed into the import method. This option can only be used when not importing into a single view.(i.e. ThisViewOnly is set to false)
Public property | Placement | Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates.
Public property | ReferencePoint | The 3D point in the document where the imported instance will be inserted. If not explicitly set, the instance will be inserted at the document origin.
Public property | ThisViewOnly | Imports drawings into the view that was passed into the import method. This option is not available in 3D views.
Public property | Unit | The unit of measure for imported geometry.
Public property | VisibleLayersOnly | Only import the visible layers.

See Also

BaseImportOptions Class


AutoCorrectAlmostVHLines Property

[image]

Revit 2024 API
BaseImportOptions..::..AutoCorrectAlmostVHLines Property
BaseImportOptions Class See Also Send Feedback
Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool AutoCorrectAlmostVHLines { get; set; }
Visual Basic
Public Property AutoCorrectAlmostVHLines As Boolean
    Get
    Set
Visual C++
public:
property bool AutoCorrectAlmostVHLines {
    bool get ();
    void set (bool value);
}

See Also

BaseImportOptions Class


IsValidObject Property

[image]

Revit 2024 API
BaseImportOptions..::..IsValidObject Property
BaseImportOptions Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

BaseImportOptions Class


Placement Property

[image]

Revit 2024 API
BaseImportOptions..::..Placement Property
BaseImportOptions Class See Also Send Feedback
Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ImportPlacement Placement { get; set; }
Visual Basic
Public Property Placement As ImportPlacement
    Get
    Set
Visual C++
public:
property ImportPlacement Placement {
    ImportPlacement get ();
    void set (ImportPlacement value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

BaseImportOptions Class


ThisViewOnly Property

[image]

Revit 2024 API
BaseImportOptions..::..ThisViewOnly Property
BaseImportOptions Class See Also Send Feedback
Imports drawings into the view that was passed into the import method. This option is not available in 3D views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool ThisViewOnly { get; set; }
Visual Basic
Public Property ThisViewOnly As Boolean
    Get
    Set
Visual C++
public:
property bool ThisViewOnly {
    bool get ();
    void set (bool value);
}

See Also

BaseImportOptions Class


Unit Property

[image]

Revit 2024 API
BaseImportOptions..::..Unit Property
BaseImportOptions Class See Also Send Feedback
The unit of measure for imported geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ImportUnit Unit { get; set; }
Visual Basic
Public Property Unit As ImportUnit
    Get
    Set
Visual C++
public:
property ImportUnit Unit {
    ImportUnit get ();
    void set (ImportUnit value);
}

Remarks

Units are used to calculate the import scale unless scale is defined explicitly using CustomScale, in which case Units will be ignored. Feet, inches, meters, centimeters, decimeters, millimeters are all supported. If Default unit is set, Revit will read and use the units from the file. If units are not available or accessible there, Revit will default to %overrideUnit%.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

BaseImportOptions Class


VisibleLayersOnly Property

[image]

Revit 2024 API
BaseImportOptions..::..VisibleLayersOnly Property
BaseImportOptions Class See Also Send Feedback
Only import the visible layers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool VisibleLayersOnly { get; set; }
Visual Basic
Public Property VisibleLayersOnly As Boolean
    Get
    Set
Visual C++
public:
property bool VisibleLayersOnly {
    bool get ();
    void set (bool value);
}

Remarks

If this option is set to true, only visible layers are imported. For dgn import, this option is unsupported.

See Also

BaseImportOptions Class


BaseLoadOn Enumeration

[image]

Revit 2024 API
BaseLoadOn Enumeration
See Also Send Feedback
An enumerated type listing all the possible power load use types for a space object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum BaseLoadOn
Visual Basic
Public Enumeration BaseLoadOn
Visual C++
public enum class BaseLoadOn

Members

Member name | Description
kUseDefaultLoad | Return BaseLoadOn is UseDefaultLoad. Obsoleted from 2018, use kBySpaceType instead.
kBySpaceType | Return BaseLoadOn is BySpaceType.
kUseEnteredLoad | Return BaseLoadOn is UseEnteredLoad.
kUseCalculatedLoad | Return BaseLoadOn is UseCalculatedLoad.
kUseActualLoad | Return BaseLoadOn is UseActualLoad.
kNoOfBaseLoadOnMethods | Return BaseLoadOn is NoOfBaseLoadOnMethods.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


BasePoint Class

[image]

Revit 2024 API
BasePoint Class
Members See Also Send Feedback
A class representing the Project Base Point and Survey Point. Each Revit project contains one project base point and one survey point. The project base point represents the origin of the project coordinate system. The survey point represents the origin of the shared coordinate system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class BasePoint : Element
Visual Basic
Public Class BasePoint _
    Inherits Element
Visual C++
public ref class BasePoint : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..BasePoint

See Also

BasePoint Members


BasePoint Methods

[image] [image]

Revit 2024 API
BasePoint Methods
BasePoint Class See Also Send Feedback

The BasePoint type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
 | GetProjectBasePoint | Gets the project base point for the document.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
 | GetSurveyPoint | Gets the survey point for the document.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BasePoint Class


GetSurveyPoint Method

[image]

Revit 2024 API
BasePoint..::..GetSurveyPoint Method
BasePoint Class See Also Send Feedback
Gets the survey point for the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020.2

Syntax

C#
public static BasePoint GetSurveyPoint(
    Document cda
)
Visual Basic
Public Shared Function GetSurveyPoint ( _
    cda As Document _
) As BasePoint
Visual C++
public:
static BasePoint^ GetSurveyPoint(
    Document^ cda
)

Parameters

cda
Type: Autodesk.Revit.DB..::..Document
The document from which to get the survey point.

Return Value

The survey point of the document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

BasePoint Class


BasePoint Properties

[image] [image]

Revit 2024 API
BasePoint Properties
BasePoint Class See Also Send Feedback

The BasePoint type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Clipped | Clipped state of the survey point (shared BasePoint). Change its state to clipped or unclipped, depending on how you want to move the survey point. To move the survey coordinate system in relation to the model, move the clipped survey point. To change the survey point to another location in the survey coordinate system, move the unclipped survey point. For project base point (non-shared BasePoint), this property will always return false. Trying to set the property will get an InvalidOperationException.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsShared | Indicates whether the BasePoint is shared. The project's survey point is a BasePoint which is shared.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Position | Position of the BasePoint.
Public property | SharedPosition | Shared position of the BasePoint based on the active ProjectLocation of its belonging Document. To get the shared position under other ProjectLocations, please use ProjectLocation.GetProjectPosition(BasePoint.Position).
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

BasePoint Class


IsShared Property

[image]

Revit 2024 API
BasePoint..::..IsShared Property
BasePoint Class See Also Send Feedback
Indicates whether the BasePoint is shared. The project's survey point is a BasePoint which is shared.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsShared { get; }
Visual Basic
Public ReadOnly Property IsShared As Boolean
    Get
Visual C++
public:
property bool IsShared {
    bool get ();
}

See Also

BasePoint Class


Parameter Property

[image] [image]

Revit 2024 API
BasePoint..::..Parameter Property
BasePoint Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

BasePoint Class
BasePoint Members


Position Property

[image]

Revit 2024 API
BasePoint..::..Position Property
BasePoint Class See Also Send Feedback
Position of the BasePoint.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019.2

Syntax

C#
public XYZ Position { get; }
Visual Basic
Public ReadOnly Property Position As XYZ
    Get
Visual C++
public:
property XYZ^ Position {
    XYZ^ get ();
}

See Also

BasePoint Class


SharedPosition Property

[image]

Revit 2024 API
BasePoint..::..SharedPosition Property
BasePoint Class See Also Send Feedback
Shared position of the BasePoint based on the active ProjectLocation of its belonging Document. To get the shared position under other ProjectLocations, please use ProjectLocation.GetProjectPosition(BasePoint.Position).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019.2

Syntax

C#
public XYZ SharedPosition { get; internal set; }
Visual Basic
Public Property SharedPosition As XYZ
    Get
    Friend Set
Visual C++
public:
property XYZ^ SharedPosition {
    XYZ^ get ();
    internal: void set (XYZ^ value);
}

See Also

BasePoint Class


BasicFileInfo Class

[image]

Revit 2024 API
BasicFileInfo Class
Members See Also Send Feedback
Encapsulates basic information about a Revit file, including worksharing status, Revit version, username and central path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public class BasicFileInfo : IDisposable
Visual Basic
Public Class BasicFileInfo _
    Implements IDisposable
Visual C++
public ref class BasicFileInfo : IDisposable

Remarks

This class provides a fast access to get basic information without fully opening a Revit file. The Extract method can initialize a new instance of this class by providing a full path for Revit file, including project (.rvt) and family (.rfa) files. This class can extract information from files of older formats. If the structure of the BasicFileInfo storage has not changed, it can also extract information from files of newer formats (making the method IsSavedInLaterVersion relevant). However, if the structure of the storage has changed in a newer file format, Extract will not be able to extract the information.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BasicFileInfo

See Also

BasicFileInfo Members


BasicFileInfo Methods

[image] [image]

Revit 2024 API
BasicFileInfo Methods
BasicFileInfo Class See Also Send Feedback

The BasicFileInfo type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Extract | Returns an instance of BasicFileInfo filled with basic information about a Revit file located at the given file-path
Public method | GetDocumentVersion | Gets the DocumentVersion for the file.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BasicFileInfo Class


Extract Method

[image]

Revit 2024 API
BasicFileInfo..::..Extract Method
BasicFileInfo Class See Also Send Feedback
Returns an instance of BasicFileInfo filled with basic information about a Revit file located at the given file-path

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static BasicFileInfo Extract(
    string file
)
Visual Basic
Public Shared Function Extract ( _
    file As String _
) As BasicFileInfo
Visual C++
public:
static BasicFileInfo^ Extract(
    String^ file
)

Parameters

file
Type: System..::..String
The full path to the file to be queried, including project (.rvt) and family (.rfa) files.

Return Value

If successful, basic file data.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | The file doesn't exist.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The file is a newer format file where the structure of the BasicFileInfo storage has changed, or the file is saved in very old version of Revit without basic file data.

See Also

BasicFileInfo Class


GetDocumentVersion Method

[image]

Revit 2024 API
BasicFileInfo..::..GetDocumentVersion Method
BasicFileInfo Class See Also Send Feedback
Gets the DocumentVersion for the file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public DocumentVersion GetDocumentVersion()
Visual Basic
Public Function GetDocumentVersion As DocumentVersion
Visual C++
public:
DocumentVersion^ GetDocumentVersion()

Return Value

The DocumentVersion for the file.

See Also

BasicFileInfo Class


BasicFileInfo Properties

[image] [image]

Revit 2024 API
BasicFileInfo Properties
BasicFileInfo Class See Also Send Feedback

The BasicFileInfo type exposes the following members.

Properties

 | Name | Description
Public property | AllLocalChangesSavedToCentral | Are all local changes saved to the central file?
Public property | CentralPath | Returns the central model path.
Public property | Format | The file format indicator (currently, the major release version such as "2019") used for saving the file.
Public property | IsCentral | Checks if the file is workshared and Central.
Public property | IsCreatedLocal | Checks if the file is local and created by RevitServerTool.exe.
Public property | IsInProgress | Checks if the file is workshared and is in process of becoming Central.
Public property | IsLocal | Checks if the file is workshared and Local.
Public property | IsSavedInCurrentVersion | Checks if the file is saved in the current version.
Public property | IsSavedInLaterVersion | Checks if the file is saved in a later version of Revit than the running Revit.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | IsWorkshared | Checks if the file is workshared.
Public property | LanguageWhenSaved | Return the language active for the last save
Public property | LatestCentralEpisodeGUID | This is the central model's episode GUID corresponding to the last reload latest done for this model.
Public property | LatestCentralVersion | This is the central model's version number corresponding to the last reload latest done for this model.
Public property | Username | Returns the username.

See Also

BasicFileInfo Class


AllLocalChangesSavedToCentral Property

[image]

Revit 2024 API
BasicFileInfo..::..AllLocalChangesSavedToCentral Property
BasicFileInfo Class See Also Send Feedback
Are all local changes saved to the central file?

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool AllLocalChangesSavedToCentral { get; }
Visual Basic
Public ReadOnly Property AllLocalChangesSavedToCentral As Boolean
    Get
Visual C++
public:
property bool AllLocalChangesSavedToCentral {
    bool get ();
}

See Also

BasicFileInfo Class


CentralPath Property

[image]

Revit 2024 API
BasicFileInfo..::..CentralPath Property
BasicFileInfo Class See Also Send Feedback
Returns the central model path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public string CentralPath { get; }
Visual Basic
Public ReadOnly Property CentralPath As String
    Get
Visual C++
public:
property String^ CentralPath {
    String^ get ();
}

See Also

BasicFileInfo Class


Format Property

[image]

Revit 2024 API
BasicFileInfo..::..Format Property
BasicFileInfo Class See Also Send Feedback
The file format indicator (currently, the major release version such as "2019") used for saving the file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public string Format { get; }
Visual Basic
Public ReadOnly Property Format As String
    Get
Visual C++
public:
property String^ Format {
    String^ get ();
}

See Also

BasicFileInfo Class


IsCentral Property

[image]

Revit 2024 API
BasicFileInfo..::..IsCentral Property
BasicFileInfo Class See Also Send Feedback
Checks if the file is workshared and Central.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool IsCentral { get; }
Visual Basic
Public ReadOnly Property IsCentral As Boolean
    Get
Visual C++
public:
property bool IsCentral {
    bool get ();
}

See Also

BasicFileInfo Class


IsLocal Property

[image]

Revit 2024 API
BasicFileInfo..::..IsLocal Property
BasicFileInfo Class See Also Send Feedback
Checks if the file is workshared and Local.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool IsLocal { get; }
Visual Basic
Public ReadOnly Property IsLocal As Boolean
    Get
Visual C++
public:
property bool IsLocal {
    bool get ();
}

See Also

BasicFileInfo Class


IsSavedInLaterVersion Property

[image]

Revit 2024 API
BasicFileInfo..::..IsSavedInLaterVersion Property
BasicFileInfo Class See Also Send Feedback
Checks if the file is saved in a later version of Revit than the running Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public bool IsSavedInLaterVersion { get; }
Visual Basic
Public ReadOnly Property IsSavedInLaterVersion As Boolean
    Get
Visual C++
public:
property bool IsSavedInLaterVersion {
    bool get ();
}

Remarks

If the structure of the BasicFileInfo storage has not changed in a newer format file, this will indicate that the file format is newer. However, if the structure of the storage has changed in a newer format file, extraction would have failed and this method cannot be used to make that determination.

See Also

BasicFileInfo Class


IsValidObject Property

[image]

Revit 2024 API
BasicFileInfo..::..IsValidObject Property
BasicFileInfo Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

BasicFileInfo Class


IsWorkshared Property

[image]

Revit 2024 API
BasicFileInfo..::..IsWorkshared Property
BasicFileInfo Class See Also Send Feedback
Checks if the file is workshared.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool IsWorkshared { get; }
Visual Basic
Public ReadOnly Property IsWorkshared As Boolean
    Get
Visual C++
public:
property bool IsWorkshared {
    bool get ();
}

See Also

BasicFileInfo Class


LanguageWhenSaved Property

[image]

Revit 2024 API
BasicFileInfo..::..LanguageWhenSaved Property
BasicFileInfo Class See Also Send Feedback
Return the language active for the last save

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public LanguageType LanguageWhenSaved { get; }
Visual Basic
Public ReadOnly Property LanguageWhenSaved As LanguageType
    Get
Visual C++
public:
property LanguageType LanguageWhenSaved {
    LanguageType get ();
}

See Also

BasicFileInfo Class


LatestCentralEpisodeGUID Property

[image]

Revit 2024 API
BasicFileInfo..::..LatestCentralEpisodeGUID Property
BasicFileInfo Class See Also Send Feedback
This is the central model's episode GUID corresponding to the last reload latest done for this model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public Guid LatestCentralEpisodeGUID { get; }
Visual Basic
Public ReadOnly Property LatestCentralEpisodeGUID As Guid
    Get
Visual C++
public:
property Guid LatestCentralEpisodeGUID {
    Guid get ();
}

See Also

BasicFileInfo Class


LatestCentralVersion Property

[image]

Revit 2024 API
BasicFileInfo..::..LatestCentralVersion Property
BasicFileInfo Class See Also Send Feedback
This is the central model's version number corresponding to the last reload latest done for this model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public int LatestCentralVersion { get; }
Visual Basic
Public ReadOnly Property LatestCentralVersion As Integer
    Get
Visual C++
public:
property int LatestCentralVersion {
    int get ();
}

See Also

BasicFileInfo Class


Username Property

[image]

Revit 2024 API
BasicFileInfo..::..Username Property
BasicFileInfo Class See Also Send Feedback
Returns the username.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public string Username { get; }
Visual Basic
Public ReadOnly Property Username As String
    Get
Visual C++
public:
property String^ Username {
    String^ get ();
}

See Also

BasicFileInfo Class


BeamSystem Class

[image]

Revit 2024 API
BeamSystem Class
Members Example See Also Send Feedback
An object that represents a BeamSystem within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class BeamSystem : Element
Visual Basic
Public Class BeamSystem _
    Inherits Element
Visual C++
public ref class BeamSystem : public Element

Remarks

This object is derived from the Element base object. It can be used to access properties of a BeamSystem, such as elevation, level, etc. It also provides access to the beams (FamilyInstances) that are created by this BeamSystem.

Examples

CopyC#
public void GetInfo_BeamSystemType(BeamSystem beamSystem)
{
    string message = "BeamSystem : ";
    // Get BeamSystem type name
    message += "\nBeamSystem type name : " + beamSystem.BeamSystemType.Name;

    // Rename the BeamSystem type used by this BeamSystem
    beamSystem.BeamSystemType.Name = "TestBeamSystemTypeName";
    // Get BeamSystem type name
    message += "\nBeamSystem type name after set: " + beamSystem.BeamSystemType.Name;

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetInfo_BeamSystemType(beamSystem As BeamSystem)
    Dim message As String = "BeamSystem : "
    ' Get BeamSystem type name
    message += vbLf & "BeamSystem type name : " & Convert.ToString(beamSystem.BeamSystemType.Name)

    ' Rename the BeamSystem type used by this BeamSystem
    beamSystem.BeamSystemType.Name = "TestBeamSystemTypeName"
    ' Get BeamSystem type name
    message += vbLf & "BeamSystem type name after set: " & Convert.ToString(beamSystem.BeamSystemType.Name)

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..BeamSystem

See Also

BeamSystem Members


BeamSystem Members

[image] [image]

Revit 2024 API
BeamSystem Members
BeamSystem Class Methods Properties See Also Send Feedback

The BeamSystem type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
 | BeamBelongsTo | Find out the BeamSystem to which the beam belongs.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create(Document, IList<(Of <<'(Curve>)>>), SketchPlane, Int32) | Creates a 2D BeamSystem with specified profile curves.
 | Create(Document, IList<(Of <<'(Curve>)>>), Level, XYZ, Boolean) | Creates a new BeamSystem with specified profile curves.
 | Create(Document, IList<(Of <<'(Curve>)>>), Level, Int32, Boolean) | Creates a new BeamSystem with specified profile curves.
 | Create(Document, IList<(Of <<'(Curve>)>>), SketchPlane, XYZ, Boolean) | Creates a new BeamSystem with specified profile curves.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
 | DropBeamSystem | Drop beam system, it will disassociate all members from the beam system and delete the beam system.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetBeamIds | Gets all the beams of the BeamSystem.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BeamSystemType | Retrieves or changes the type of the BeamSystem.
Public property | BeamType | Retrieves or changes the Beam Type of the BeamSystem.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Direction | The Direction of the BeamSystem.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Elevation | Retrieves or changes the Elevation of the BeamSystem.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LayoutRule | Retrieves or changes the LayoutRule of the BeamSystem.
Public property | Level | Get or change the level of the BeamSystem. When the level is changed, the elevation is changed to make the the BeamSystem remain the location.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Profile | Retrieve or set the profile of the BeamSystem.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

BeamSystem Class


BeamBelongsTo Method

[image]

Revit 2024 API
BeamSystem..::..BeamBelongsTo Method
BeamSystem Class See Also Send Feedback
Find out the BeamSystem to which the beam belongs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static BeamSystem BeamBelongsTo(
    FamilyInstance beam
)
Visual Basic
Public Shared Function BeamBelongsTo ( _
    beam As FamilyInstance _
) As BeamSystem
Visual C++
public:
static BeamSystem^ BeamBelongsTo(
    FamilyInstance^ beam
)

Parameters

beam
Type: Autodesk.Revit.DB..::..FamilyInstance
The beam want to ask.

Return Value

The BeamSystem.

See Also

BeamSystem Class


Create Method

[image] [image]

Revit 2024 API
BeamSystem..::..Create Method
BeamSystem Class See Also Send Feedback

Overload List

Name | Description
Create(Document, IList<(Of <<'(Curve>)>>), SketchPlane, Int32) | Creates a 2D BeamSystem with specified profile curves.
Create(Document, IList<(Of <<'(Curve>)>>), Level, XYZ, Boolean) | Creates a new BeamSystem with specified profile curves.
Create(Document, IList<(Of <<'(Curve>)>>), Level, Int32, Boolean) | Creates a new BeamSystem with specified profile curves.
Create(Document, IList<(Of <<'(Curve>)>>), SketchPlane, XYZ, Boolean) | Creates a new BeamSystem with specified profile curves.

See Also

BeamSystem Class
BeamSystem Members


Create Method (Document, IList(Curve), SketchPlane, Int32)

[image]

Revit 2024 API
BeamSystem..::..Create Method (Document, IList<(Of <(<'Curve>)>)>, SketchPlane, Int32)
BeamSystem Class See Also Send Feedback
Creates a 2D BeamSystem with specified profile curves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static BeamSystem Create(
    Document document,
    IList<Curve> profile,
    SketchPlane sketchPlane,
    int curveIndexForDirection
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    profile As IList(Of Curve), _
    sketchPlane As SketchPlane, _
    curveIndexForDirection As Integer _
) As BeamSystem
Visual C++
public:
static BeamSystem^ Create(
    Document^ document,
    IList<Curve^>^ profile,
    SketchPlane^ sketchPlane,
    int curveIndexForDirection
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which the new BeamSystem is created.
profile
Type: System.Collections.Generic..::..IList<(Of <(<' Curve >)>)>
The profile of the BeamSystem.
sketchPlane
Type: Autodesk.Revit.DB..::..SketchPlane
The work-plane for the BeamSystem.
curveIndexForDirection
Type: System..::..Int32
Index of the curve in the profile to be used as direction. '0' means the default direction-to use the first curve in profile. The curve from the profile to be used as direction must be a Line.

Return Value

If successful, a new BeamSystem object will be returned.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | SketchPlane is not valid for BeamSystem creation. -or- The input profile contains at least one helical curve and is not supported for this operation. -or- The profile curves must be in the sketch plane. -or- The curve index must be valid and the curve to be used as direction must be a Line.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

BeamSystem Class
Create Overload


Create Method (Document, IList(Curve), Level, XYZ, Boolean)

[image]

Revit 2024 API
BeamSystem..::..Create Method (Document, IList<(Of <(<'Curve>)>)>, Level, XYZ, Boolean)
BeamSystem Class See Also Send Feedback
Creates a new BeamSystem with specified profile curves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static BeamSystem Create(
    Document document,
    IList<Curve> profile,
    Level level,
    XYZ direction,
    bool is3d
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    profile As IList(Of Curve), _
    level As Level, _
    direction As XYZ, _
    is3d As Boolean _
) As BeamSystem
Visual C++
public:
static BeamSystem^ Create(
    Document^ document,
    IList<Curve^>^ profile,
    Level^ level,
    XYZ^ direction,
    bool is3d
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which the new BeamSystem is created.
profile
Type: System.Collections.Generic..::..IList<(Of <(<' Curve >)>)>
The profile of the BeamSystem.
level
Type: Autodesk.Revit.DB..::..Level
The level on which the BeamSystem is to be created. The work-plane of the BeamSystem will be the sketch plane associated with the Level. If there is no current sketch plane associated with the level yet, we will create a default one.
direction
Type: Autodesk.Revit.DB..::..XYZ
The direction is the direction of the BeamSystem.
is3d
Type: System..::..Boolean
Whether the BeamSystem is 3D. If the BeamSystem is 3D, the sketchPlane must be a level, otherwise an exception will be thrown.

Return Value

If successful, a new BeamSystem object will be returned.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input profile contains at least one helical curve and is not supported for this operation. -or- The input level does not have associated plan view. -or- The plan view associated with the input level is not valid. -or- Can not get valid sketch plane from the input level.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

BeamSystem Class
Create Overload


Create Method (Document, IList(Curve), Level, Int32, Boolean)

[image]

Revit 2024 API
BeamSystem..::..Create Method (Document, IList<(Of <(<'Curve>)>)>, Level, Int32, Boolean)
BeamSystem Class Example See Also Send Feedback
Creates a new BeamSystem with specified profile curves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static BeamSystem Create(
    Document document,
    IList<Curve> profile,
    Level level,
    int curveIndexForDirection,
    bool is3d
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    profile As IList(Of Curve), _
    level As Level, _
    curveIndexForDirection As Integer, _
    is3d As Boolean _
) As BeamSystem
Visual C++
public:
static BeamSystem^ Create(
    Document^ document,
    IList<Curve^>^ profile,
    Level^ level,
    int curveIndexForDirection,
    bool is3d
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which the new BeamSystem is created.
profile
Type: System.Collections.Generic..::..IList<(Of <(<' Curve >)>)>
The profile of the BeamSystem.
level
Type: Autodesk.Revit.DB..::..Level
The level on which the BeamSystem is to be created. The work-plane of the BeamSystem will be the sketch plane associated with the Level. If there is no current sketch plane associated with the level yet, we will create a default one.
curveIndexForDirection
Type: System..::..Int32
Index of the curve in the profile to be used as direction. '0' means the direction to use the first curve in profile. The curve from the profile to be used as direction must be a Line.
is3d
Type: System..::..Boolean
Whether the BeamSystem is 3D. If the BeamSystem is 3D, the sketchPlane must be a level, otherwise an exception will be thrown.

Return Value

If successful, a new BeamSystem object will be returned.

Examples

CopyC#
// Build a profile for the beam system creation
XYZ first = new XYZ(0, 0, 0);
XYZ second = new XYZ(40, 0, 0);
XYZ third = new XYZ(40, 25, 0);
XYZ fourth = new XYZ(0, 25, 0);
List<Curve> profile = new List<Curve>();
profile.Add(Line.CreateBound(first, second));
profile.Add(Line.CreateBound(second, third));
profile.Add(Line.CreateBound(third, fourth));
profile.Add(Line.CreateBound(fourth, first));

// Create a beam system
BeamSystem beamSystem = BeamSystem.Create(document, profile, level, 0, false);
if (null != beamSystem)
{
    // Change some properties, such as elevation
    Parameter elevationPara = beamSystem.get_Parameter(BuiltInParameter.INSTANCE_ELEVATION_PARAM);
    if (null != elevationPara)
    {
        elevationPara.Set(10.0);
    }
}
CopyVB.NET
' Build a profile for the beam system creation
Dim first As New XYZ(0, 0, 0)
Dim second As New XYZ(40, 0, 0)
Dim third As New XYZ(40, 25, 0)
Dim fourth As New XYZ(0, 25, 0)
Dim profile As New List(Of Curve)()
profile.Add(Line.CreateBound(first, second))
profile.Add(Line.CreateBound(second, third))
profile.Add(Line.CreateBound(third, fourth))
profile.Add(Line.CreateBound(fourth, first))

' Create a beam system
Dim beamSystem__1 As BeamSystem = BeamSystem.Create(document, profile, level, 0, False)
If beamSystem__1 IsNot Nothing Then
    ' Change some properties, such as elevation
    Dim elevationPara As Parameter = beamSystem__1.Parameter(BuiltInParameter.INSTANCE_ELEVATION_PARAM)
    If elevationPara IsNot Nothing Then
        elevationPara.[Set](10.0)
    End If
End If

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input profile contains at least one helical curve and is not supported for this operation. -or- The curve index must be valid and the curve to be used as direction must be a Line. -or- The input level does not have associated plan view. -or- The plan view associated with the input level is not valid. -or- Can not get valid sketch plane from the input level.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

BeamSystem Class
Create Overload


DropBeamSystem Method

[image]

Revit 2024 API
BeamSystem..::..DropBeamSystem Method
BeamSystem Class See Also Send Feedback
Drop beam system, it will disassociate all members from the beam system and delete the beam system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static void DropBeamSystem(
    BeamSystem beamSystem
)
Visual Basic
Public Shared Sub DropBeamSystem ( _
    beamSystem As BeamSystem _
)
Visual C++
public:
static void DropBeamSystem(
    BeamSystem^ beamSystem
)

Parameters

beamSystem
Type: Autodesk.Revit.DB..::..BeamSystem
The beam system to be deleted.

See Also

BeamSystem Class


GetBeamIds Method

[image]

Revit 2024 API
BeamSystem..::..GetBeamIds Method
BeamSystem Class See Also Send Feedback
Gets all the beams of the BeamSystem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ICollection<ElementId> GetBeamIds()
Visual Basic
Public Function GetBeamIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetBeamIds()

Return Value

The beam Ids.

See Also

BeamSystem Class


BeamType Property

[image]

Revit 2024 API
BeamSystem..::..BeamType Property
BeamSystem Class Example See Also Send Feedback
Retrieves or changes the Beam Type of the BeamSystem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilySymbol BeamType { get; set; }
Visual Basic
Public Property BeamType As FamilySymbol
    Get
    Set
Visual C++
public:
property FamilySymbol^ BeamType {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}

Examples

CopyC#
public void GetInfo_BeamType(BeamSystem beamSystem)
{
    string message = "BeamSystem : ";
    // Get BeamSystem type name
    message += "\nBeam type name : " + beamSystem.BeamType.Name;
    // Get BeamSystem type material
    foreach (ElementId materialId in beamSystem.BeamType.GetMaterialIds(false))
    {
       Material material = beamSystem.Document.GetElement(materialId) as Material;
       message += "\nBeam type material : " + material.Name;
    }
    // Get BeamSystem family name
    message += "\nBeam family name : " + beamSystem.BeamType.Family.Name;

    // Rename BeamType used by this BeamSystem
    beamSystem.BeamType.Name = "TestBeamTypeName";
    // Rename the Family used by the BeamType that is used by this BeamSystem
    beamSystem.BeamType.Family.Name = "TestBeamTypeFamilyName";

    // Get BeamSystem type name
    message += "\nBeam type name after set : " + beamSystem.BeamType.Name;
    // Get BeamSystem family name
    message += "\nBeam family name after set : " + beamSystem.BeamType.Family.Name;

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetInfo_BeamType(beamSystem As BeamSystem)
    Dim message As String = "BeamSystem : "
    ' Get BeamSystem type name
    message += vbLf & "Beam type name : " & Convert.ToString(beamSystem.BeamType.Name)
    ' Get BeamSystem type material
    For Each materialId As ElementId In beamSystem.BeamType.GetMaterialIds(False)
        Dim material As Material = TryCast(beamSystem.Document.GetElement(materialId), Material)
        message += vbLf & "Beam type material : " + material.Name
    Next
    ' Get BeamSystem family name
    message += vbLf & "Beam family name : " & Convert.ToString(beamSystem.BeamType.Family.Name)

    ' Rename BeamType used by this BeamSystem
    beamSystem.BeamType.Name = "TestBeamTypeName"
    ' Rename the Family used by the BeamType that is used by this BeamSystem
    beamSystem.BeamType.Family.Name = "TestBeamTypeFamilyName"

    ' Get BeamSystem type name
    message += vbLf & "Beam type name after set : " & Convert.ToString(beamSystem.BeamType.Name)
    ' Get BeamSystem family name
    message += vbLf & "Beam family name after set : " & Convert.ToString(beamSystem.BeamType.Family.Name)

    TaskDialog.Show("Revit", message)
End Sub

See Also

BeamSystem Class


Direction Property

[image]

Revit 2024 API
BeamSystem..::..Direction Property
BeamSystem Class See Also Send Feedback
The Direction of the BeamSystem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ Direction { get; }
Visual Basic
Public ReadOnly Property Direction As XYZ
    Get
Visual C++
public:
property XYZ^ Direction {
    XYZ^ get ();
}

See Also

BeamSystem Class


Elevation Property

[image]

Revit 2024 API
BeamSystem..::..Elevation Property
BeamSystem Class See Also Send Feedback
Retrieves or changes the Elevation of the BeamSystem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double Elevation { get; set; }
Visual Basic
Public Property Elevation As Double
    Get
    Set
Visual C++
public:
property double Elevation {
    double get ();
    void set (double value);
}

See Also

BeamSystem Class


LayoutRule Property

[image]

Revit 2024 API
BeamSystem..::..LayoutRule Property
BeamSystem Class See Also Send Feedback
Retrieves or changes the LayoutRule of the BeamSystem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public LayoutRule LayoutRule { get; set; }
Visual Basic
Public Property LayoutRule As LayoutRule
    Get
    Set
Visual C++
public:
property LayoutRule^ LayoutRule {
    LayoutRule^ get ();
    void set (LayoutRule^ value);
}

See Also

BeamSystem Class


BeamSystemJustifyType Enumeration

[image]

Revit 2024 API
BeamSystemJustifyType Enumeration
See Also Send Feedback
Describes the justify method of beamsystem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum BeamSystemJustifyType
Visual Basic
Public Enumeration BeamSystemJustifyType
Visual C++
public enum class BeamSystemJustifyType

Members

Member name | Description
Center | Center.
End | End.
Beginning | Beginning.
DirectionLine | DirectionLine.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


BeamSystemType Class

[image]

Revit 2024 API
BeamSystemType Class
Members See Also Send Feedback
An object that specifies the type of a beam system in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class BeamSystemType : ElementType
Visual Basic
Public Class BeamSystemType _
    Inherits ElementType
Visual C++
public ref class BeamSystemType : public ElementType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..BeamSystemType

See Also

BeamSystemType Members


BeamSystemType Members

[image] [image]

Revit 2024 API
BeamSystemType Members
BeamSystemType Class Methods Properties See Also Send Feedback

The BeamSystemType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

BeamSystemType Class


BeamSystemType Methods

[image] [image]

Revit 2024 API
BeamSystemType Methods
BeamSystemType Class See Also Send Feedback

The BeamSystemType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BeamSystemType Class


BeamSystemType Properties

[image] [image]

Revit 2024 API
BeamSystemType Properties
BeamSystemType Class See Also Send Feedback

The BeamSystemType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

BeamSystemType Class


Parameter Property

[image] [image]

Revit 2024 API
BeamSystemType..::..Parameter Property
BeamSystemType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

BeamSystemType Class
BeamSystemType Members


BehaviorType Enumeration

[image]

Revit 2024 API
BehaviorType Enumeration
See Also Send Feedback
An enumerated type listing all the behavior type for MEP Components.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum BehaviorType
Visual Basic
Public Enumeration BehaviorType
Visual C++
public enum class BehaviorType

Members

Member name | Description
Invalid | BehaviorType is Invalid
Normal | BehaviorType is Normal
Bend | BehaviorType is Bend
Branch | BehaviorType is Branch
Intersection | BehaviorType is Intersection
Inline | BehaviorType is Inline
BreakInto | BehaviorType is Break Into
OrientToObject | BehaviorType is Orient to Object
OrientToCenterLine | BehaviorType is Orient to CenterLine
OrientToFace | BehaviorType is Orient to Face
SystemMember | BehaviorType is System Member
BaseObject | BehaviorType is Base Object
EndCap | BehaviorType is End Cap
Valve | BehaviorType is Valve
Flange | BehaviorType is Flange
MechanicalCoupling | BehaviorType is Mechanical Coupling
VerticalBend | BehaviorType is Vertical Bend
ElectricalBaseObject | BehaviorType is Electrical Base Object
Straight | BehaviorType is Straight
Flex | BehaviorType is Flex
Hanger | BehaviorType is Hanger
Flat_Tap | BehaviorType is a flat tap on flat surface, eg. rectangular straight or flat-side of oval straight
Coupling | BehaviorType is Coupling
Round_CentreLine_Tap | BehaviorType is a round centreline tap on round straight/pipe
Oval_CentreLine_Tap | BehaviorType is a round centreline tap on oval straight
Damper | BehaviorType is a round centreline tap on oval straight

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


BIMExportOptions Class

[image]

Revit 2024 API
BIMExportOptions Class
Members See Also Send Feedback
The base class for options used to export using ATF.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021.1

Syntax

C#
public class BIMExportOptions : IDisposable
Visual Basic
Public Class BIMExportOptions _
    Implements IDisposable
Visual C++
public ref class BIMExportOptions : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BIMExportOptions
Autodesk.Revit.DB..::..OBJExportOptions
Autodesk.Revit.DB..::..STLExportOptions

See Also

BIMExportOptions Members


BIMExportOptions Members

[image] [image]

Revit 2024 API
BIMExportOptions Members
BIMExportOptions Class Methods Properties See Also Send Feedback

The BIMExportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the BIMExportOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ViewId | The element id of the 3D view to export. InvalidElementId by default.

See Also

BIMExportOptions Class


BIMExportOptions Methods

[image] [image]

Revit 2024 API
BIMExportOptions Methods
BIMExportOptions Class See Also Send Feedback

The BIMExportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BIMExportOptions Class


BIMExportOptions Properties

[image] [image]

Revit 2024 API
BIMExportOptions Properties
BIMExportOptions Class See Also Send Feedback

The BIMExportOptions type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ViewId | The element id of the 3D view to export. InvalidElementId by default.

See Also

BIMExportOptions Class


IsValidObject Property

[image]

Revit 2024 API
BIMExportOptions..::..IsValidObject Property
BIMExportOptions Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

BIMExportOptions Class


ViewId Property

[image]

Revit 2024 API
BIMExportOptions..::..ViewId Property
BIMExportOptions Class See Also Send Feedback
The element id of the 3D view to export. InvalidElementId by default.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021.1

Syntax

C#
public ElementId ViewId { get; set; }
Visual Basic
Public Property ViewId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ ViewId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

BIMExportOptions Class


Binding Class

[image]

Revit 2024 API
Binding Class
Members See Also Send Feedback
Binding objects are used to take a parameter definition and bind it to one or more categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public abstract class Binding : APIObject
Visual Basic
Public MustInherit Class Binding _
    Inherits APIObject
Visual C++
public ref class Binding abstract : public APIObject

Remarks

This class is a base class for all types of parameter binding within Autodesk Revit. Once the binding objects are created and added to the document parameters will be added to elements in those categories specified in the binding. There are currently two types of binding available, Instance binding and Type binding. The key difference between the two is that the instance bound parameters appear on all instances of the elements in those categories. Changing the parameter on one does not affect the other instances of the parameter. The Type bound parameters appear only on the type object and is shared by all the instances that use that type. Changing the type bound parameter affects all instances of the elements that use that type. Note, a definition can only be bound to an instance or a type and not both.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..Binding
Autodesk.Revit.DB..::..ElementBinding

See Also

Binding Members


Binding Members

[image] [image]

Revit 2024 API
Binding Members
Binding Class Methods Properties See Also Send Feedback

The Binding type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Binding Class


Binding Methods

[image] [image]

Revit 2024 API
Binding Methods
Binding Class See Also Send Feedback

The Binding type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Binding Class


BindingMap Class

[image]

Revit 2024 API
BindingMap Class
Members See Also Send Feedback
The parameters BindingMap contains all the parameter bindings that exist in the Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class BindingMap : DefinitionBindingMap
Visual Basic
Public Class BindingMap _
    Inherits DefinitionBindingMap
Visual C++
public ref class BindingMap : public DefinitionBindingMap

Remarks

The ParameterBindingsMap is available from the Document.ParameterBindings property. A parameter binding is the way that a parameter definition is bound to elements within one or more categories. This map can be used to interrogate existing bindings, but it can also be used to generate new parameter bindings by using the Insert method.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..DefinitionBindingMap
Autodesk.Revit.DB..::..BindingMap

See Also

BindingMap Members


BindingMap Members

[image] [image]

Revit 2024 API
BindingMap Members
BindingMap Class Methods Properties See Also Send Feedback

The BindingMap type exposes the following members.

Methods

 | Name | Description
Public method | Clear | This method is used to remove all the items in the map. (Overrides DefinitionBindingMap..::..Clear()()()().)
Public method | Contains | The Contains method is used to check if the parameter binding exists for one definition. (Overrides DefinitionBindingMap..::..Contains(Definition).)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | This method is used to erase one item in the map. (Overrides DefinitionBindingMap..::..Erase(Definition).)
Public method | ForwardIterator | Retrieve a forward moving iterator to the map. (Inherited from DefinitionBindingMap.)
Public method | GetEnumerator | Retrieve a forward moving iterator to the map. (Inherited from DefinitionBindingMap.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert(Definition, Binding) | Creates a new parameter binding between a parameter and a set of categories. (Overrides DefinitionBindingMap..::..Insert(Definition, Binding).)
Public method | Insert(Definition, Binding, BuiltInParameterGroup) | Obsolete. Creates a new parameter binding between a parameter and a set of categories in a specified group.
Public method | Insert(Definition, Binding, ForgeTypeId) | Creates a new parameter binding between a parameter and a set of categories in a specified group.
Public method | ReInsert(Definition, Binding) | Removes an existing parameter and creates a new binding for a given parameter.
Public method | ReInsert(Definition, Binding, BuiltInParameterGroup) | Obsolete. Removes an existing parameter and creates a new binding for a given parameter in a specified group.
Public method | ReInsert(Definition, Binding, ForgeTypeId) | Removes an existing parameter and creates a new binding for a given parameter in a specified group.
Public method | Remove | The Remove method is used to remove a parameter binding.
Public method | ReverseIterator | Retrieve a backward moving iterator to the map. (Inherited from DefinitionBindingMap.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the map is empty. (Inherited from DefinitionBindingMap.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | The get_Item method will get the binding item related to the input key. (Overrides DefinitionBindingMap..::..Item[([( Definition])]) .)
Public property | Size | Returns the number of bindings that are in the map. (Inherited from DefinitionBindingMap.)

See Also

BindingMap Class


BindingMap Methods

[image] [image]

Revit 2024 API
BindingMap Methods
BindingMap Class See Also Send Feedback

The BindingMap type exposes the following members.

Methods

 | Name | Description
Public method | Clear | This method is used to remove all the items in the map. (Overrides DefinitionBindingMap..::..Clear()()()().)
Public method | Contains | The Contains method is used to check if the parameter binding exists for one definition. (Overrides DefinitionBindingMap..::..Contains(Definition).)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | This method is used to erase one item in the map. (Overrides DefinitionBindingMap..::..Erase(Definition).)
Public method | ForwardIterator | Retrieve a forward moving iterator to the map. (Inherited from DefinitionBindingMap.)
Public method | GetEnumerator | Retrieve a forward moving iterator to the map. (Inherited from DefinitionBindingMap.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert(Definition, Binding) | Creates a new parameter binding between a parameter and a set of categories. (Overrides DefinitionBindingMap..::..Insert(Definition, Binding).)
Public method | Insert(Definition, Binding, BuiltInParameterGroup) | Obsolete. Creates a new parameter binding between a parameter and a set of categories in a specified group.
Public method | Insert(Definition, Binding, ForgeTypeId) | Creates a new parameter binding between a parameter and a set of categories in a specified group.
Public method | ReInsert(Definition, Binding) | Removes an existing parameter and creates a new binding for a given parameter.
Public method | ReInsert(Definition, Binding, BuiltInParameterGroup) | Obsolete. Removes an existing parameter and creates a new binding for a given parameter in a specified group.
Public method | ReInsert(Definition, Binding, ForgeTypeId) | Removes an existing parameter and creates a new binding for a given parameter in a specified group.
Public method | Remove | The Remove method is used to remove a parameter binding.
Public method | ReverseIterator | Retrieve a backward moving iterator to the map. (Inherited from DefinitionBindingMap.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BindingMap Class


Clear Method

[image]

Revit 2024 API
BindingMap..::..Clear Method
BindingMap Class See Also Send Feedback
This method is used to remove all the items in the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public override void Clear()
Visual Basic
Public Overrides Sub Clear
Visual C++
public:
virtual void Clear() override

Remarks

The method Clear inherited from base class is not permitted for this class. A Autodesk::Revit::Exceptions::InvalidOperationException will be thrown.

See Also

BindingMap Class


Contains Method

[image]

Revit 2024 API
BindingMap..::..Contains Method
BindingMap Class See Also Send Feedback
The Contains method is used to check if the parameter binding exists for one definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public override bool Contains(
    Definition key
)
Visual Basic
Public Overrides Function Contains ( _
    key As Definition _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Definition^ key
) override

Parameters

key
Type: Autodesk.Revit.DB..::..Definition
A parameter definition which can be an existing definition or one from a shared parameters file.

See Also

BindingMap Class


Insert Method

[image] [image]

Revit 2024 API
BindingMap..::..Insert Method
BindingMap Class See Also Send Feedback
Creates a new parameter binding.

Overload List

 | Name | Description
Public method | Insert(Definition, Binding) | Creates a new parameter binding between a parameter and a set of categories. (Overrides DefinitionBindingMap..::..Insert(Definition, Binding).)
Public method | Insert(Definition, Binding, BuiltInParameterGroup) | Obsolete. Creates a new parameter binding between a parameter and a set of categories in a specified group.
Public method | Insert(Definition, Binding, ForgeTypeId) | Creates a new parameter binding between a parameter and a set of categories in a specified group.

See Also

BindingMap Class
BindingMap Members


Insert Method (Definition, Binding, BuiltInParameterGroup)

[image]

Revit 2024 API
BindingMap..::..Insert Method (Definition, Binding, BuiltInParameterGroup)
BindingMap Class See Also Send Feedback
Creates a new parameter binding between a parameter and a set of categories in a specified group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
[ObsoleteAttribute("This method is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use the `Insert(Definition, Binding, ForgeTypeId)` method instead.")]
public virtual bool Insert(
    Definition key,
    Binding item,
    BuiltInParameterGroup parameterGroup
)
Visual Basic
<ObsoleteAttribute("This method is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use the `Insert(Definition, Binding, ForgeTypeId)` method instead.")> _
Public Overridable Function Insert ( _
    key As Definition, _
    item As Binding, _
    parameterGroup As BuiltInParameterGroup _
) As Boolean
Visual C++
[ObsoleteAttribute(L"This method is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use the `Insert(Definition, Binding, ForgeTypeId)` method instead.")]
public:
virtual bool Insert(
    Definition^ key,
    Binding^ item,
    BuiltInParameterGroup parameterGroup
)

Parameters

key
Type: Autodesk.Revit.DB..::..Definition
A parameter definition which can be an existing definition or one from a shared parameters file.
item
Type: Autodesk.Revit.DB..::..Binding
An InstanceBinding or TypeBinding object which contains the set of categories to which the parameter should be bound.
parameterGroup
Type: Autodesk.Revit.DB..::..BuiltInParameterGroup
The GroupID of the parameter definition, or INVALID if the parameter is not to be associated with any predefined group.

Remarks

Note the type of the binding object dictates whether the parameter is bound to all instances or just types. A parameter definition cannot be bound to both instances and types. If the Parameter binding already exists, post an error and return false

See Also

BindingMap Class
Insert Overload


Insert Method (Definition, Binding, ForgeTypeId)

[image]

Revit 2024 API
BindingMap..::..Insert Method (Definition, Binding, ForgeTypeId)
BindingMap Class See Also Send Feedback
Creates a new parameter binding between a parameter and a set of categories in a specified group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool Insert(
    Definition key,
    Binding item,
    ForgeTypeId groupTypeId
)
Visual Basic
Public Overridable Function Insert ( _
    key As Definition, _
    item As Binding, _
    groupTypeId As ForgeTypeId _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Definition^ key,
    Binding^ item,
    ForgeTypeId^ groupTypeId
)

Parameters

key
Type: Autodesk.Revit.DB..::..Definition
A parameter definition which can be an existing definition or one from a shared parameters file.
item
Type: Autodesk.Revit.DB..::..Binding
An InstanceBinding or TypeBinding object which contains the set of categories to which the parameter should be bound.
groupTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
The identifier of the parameter definition's parameter group, or empty if the parameter is not to be associated with any predefined group.

Remarks

Note the type of the binding object dictates whether the parameter is bound to all instances or just types. A parameter definition cannot be bound to both instances and types. If the Parameter binding already exists, post an error and return false

See Also

BindingMap Class
Insert Overload


ReInsert Method

[image] [image]

Revit 2024 API
BindingMap..::..ReInsert Method
BindingMap Class See Also Send Feedback
Removes an existing parameter and creates a new binding for a given parameter.

Overload List

 | Name | Description
Public method | ReInsert(Definition, Binding) | Removes an existing parameter and creates a new binding for a given parameter.
Public method | ReInsert(Definition, Binding, BuiltInParameterGroup) | Obsolete. Removes an existing parameter and creates a new binding for a given parameter in a specified group.
Public method | ReInsert(Definition, Binding, ForgeTypeId) | Removes an existing parameter and creates a new binding for a given parameter in a specified group.

See Also

BindingMap Class
BindingMap Members


ReInsert Method (Definition, Binding)

[image]

Revit 2024 API
BindingMap..::..ReInsert Method (Definition, Binding)
BindingMap Class See Also Send Feedback
Removes an existing parameter and creates a new binding for a given parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool ReInsert(
    Definition key,
    Binding item
)
Visual Basic
Public Overridable Function ReInsert ( _
    key As Definition, _
    item As Binding _
) As Boolean
Visual C++
public:
virtual bool ReInsert(
    Definition^ key,
    Binding^ item
)

Parameters

key
Type: Autodesk.Revit.DB..::..Definition
A parameter definition which can be an existing definition or one from a shared parameters file.
item
Type: Autodesk.Revit.DB..::..Binding
An InstanceBinding or TypeBinding object which contains the set of categories to which the parameter should be bound.

Remarks

Note the type of the binding object dictates whether the parameter is bound to all instances or just types. A parameter definition cannot be bound to both instances and types. If the parameter binding already exists, remove the binding, create a new parameter binding.

See Also

BindingMap Class
ReInsert Overload


ReInsert Method (Definition, Binding, BuiltInParameterGroup)

[image]

Revit 2024 API
BindingMap..::..ReInsert Method (Definition, Binding, BuiltInParameterGroup)
BindingMap Class See Also Send Feedback
Removes an existing parameter and creates a new binding for a given parameter in a specified group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
[ObsoleteAttribute("This method is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use the `ReInsert(Definition, Binding, ForgeTypeId)` method instead.")]
public virtual bool ReInsert(
    Definition key,
    Binding item,
    BuiltInParameterGroup parameterGroup
)
Visual Basic
<ObsoleteAttribute("This method is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use the `ReInsert(Definition, Binding, ForgeTypeId)` method instead.")> _
Public Overridable Function ReInsert ( _
    key As Definition, _
    item As Binding, _
    parameterGroup As BuiltInParameterGroup _
) As Boolean
Visual C++
[ObsoleteAttribute(L"This method is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use the `ReInsert(Definition, Binding, ForgeTypeId)` method instead.")]
public:
virtual bool ReInsert(
    Definition^ key,
    Binding^ item,
    BuiltInParameterGroup parameterGroup
)

Parameters

key
Type: Autodesk.Revit.DB..::..Definition
A parameter definition which can be an existing definition or one from a shared parameters file.
item
Type: Autodesk.Revit.DB..::..Binding
An InstanceBinding or TypeBinding object which contains the set of categories to which the parameter should be bound.
parameterGroup
Type: Autodesk.Revit.DB..::..BuiltInParameterGroup
The GroupID of the parameter definition, or INVALID if the parameter is not to be associated with any predefined group.

Remarks

Note the type of the binding object dictates whether the parameter is bound to all instances or just types. A parameter definition cannot be bound to both instances and types. If the parameter binding already exists, remove the binding, create a new parameter binding. If the parameter binding related to the input key doesn't exist in the database, ReInsert will fail and false will be returned. In this case, Insert should be called.

See Also

BindingMap Class
ReInsert Overload


ReInsert Method (Definition, Binding, ForgeTypeId)

[image]

Revit 2024 API
BindingMap..::..ReInsert Method (Definition, Binding, ForgeTypeId)
BindingMap Class See Also Send Feedback
Removes an existing parameter and creates a new binding for a given parameter in a specified group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool ReInsert(
    Definition key,
    Binding item,
    ForgeTypeId groupTypeId
)
Visual Basic
Public Overridable Function ReInsert ( _
    key As Definition, _
    item As Binding, _
    groupTypeId As ForgeTypeId _
) As Boolean
Visual C++
public:
virtual bool ReInsert(
    Definition^ key,
    Binding^ item,
    ForgeTypeId^ groupTypeId
)

Parameters

key
Type: Autodesk.Revit.DB..::..Definition
A parameter definition which can be an existing definition or one from a shared parameters file.
item
Type: Autodesk.Revit.DB..::..Binding
An InstanceBinding or TypeBinding object which contains the set of categories to which the parameter should be bound.
groupTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
The identifier of the parameter definition's parameter group, or empty if the parameter is not to be associated with any predefined group.

Remarks

Note the type of the binding object dictates whether the parameter is bound to all instances or just types. A parameter definition cannot be bound to both instances and types. If the parameter binding already exists, remove the binding, create a new parameter binding. If the parameter binding related to the input key doesn't exist in the database, ReInsert will fail and false will be returned. In this case, Insert should be called.

See Also

BindingMap Class
ReInsert Overload


Remove Method

[image]

Revit 2024 API
BindingMap..::..Remove Method
BindingMap Class See Also Send Feedback
The Remove method is used to remove a parameter binding.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool Remove(
    Definition key
)
Visual Basic
Public Overridable Function Remove ( _
    key As Definition _
) As Boolean
Visual C++
public:
virtual bool Remove(
    Definition^ key
)

Parameters

key
Type: Autodesk.Revit.DB..::..Definition
A parameter definition which can be an existing definition or one from a shared parameters file.

See Also

BindingMap Class


BindingMap Properties

[image] [image]

Revit 2024 API
BindingMap Properties
BindingMap Class See Also Send Feedback

The BindingMap type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the map is empty. (Inherited from DefinitionBindingMap.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | The get_Item method will get the binding item related to the input key. (Overrides DefinitionBindingMap..::..Item[([( Definition])]) .)
Public property | Size | Returns the number of bindings that are in the map. (Inherited from DefinitionBindingMap.)

See Also

BindingMap Class


Item Property

[image]

Revit 2024 API
BindingMap..::..Item Property
BindingMap Class See Also Send Feedback
The get_Item method will get the binding item related to the input key.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public override Binding this[
    Definition key
] { get; set; }
Visual Basic
Public Overrides Property Item ( _
    key As Definition _
) As Binding
    Get
    Set
Visual C++
public:
virtual property Binding^ Item[Definition^ key] {
    Binding^ get (Definition^ key) override;
    void set (Definition^ key, Binding^ value) override;
}

Parameters

key
Type: Autodesk.Revit.DB..::..Definition
A parameter definition which can be an existing definition or one from a shared parameters file.

Field Value

The returned value of get_Item is an InstanceBinding or TypeBinding object that contains the set of categories to which the parameter is bound. The input item is an InstanceBinding or TypeBinding object which contains the set of categories to which the parameter should be bound.

Remarks

set_Item is not permitted for this class. A Autodesk::Revit::Exceptions::InvalidOperationException will be thrown. Instead use Insert, Remove and ReInsert to modify the bindings in the document.

See Also

BindingMap Class


Blend Class

[image]

Revit 2024 API
Blend Class
Members See Also Send Feedback
A blend solid or void form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class Blend : GenericForm
Visual Basic
Public Class Blend _
    Inherits GenericForm
Visual C++
public ref class Blend : public GenericForm

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..CombinableElement
Autodesk.Revit.DB..::..GenericForm
Autodesk.Revit.DB..::..Blend

See Also

Blend Members


Blend Members

[image] [image]

Revit 2024 API
Blend Members
Blend Class Methods Properties See Also Send Feedback

The Blend type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVertexConnectionMap | Gets the mapping between the vertices in the top and bottom profiles.
Public method | GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetVertexConnectionMap | Sets the mapping between the vertices in the top and bottom profiles.
Public method | SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BottomOffset | The offset of the bottom end of the blend relative to the sketch plane.
Public property | BottomProfile | The curves which make up the bottom profile of the sketch.
Public property | BottomSketch | Returns the Bottom Sketch of the Blend.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Get and Set the Name property (Inherited from GenericForm.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Subcategory | The subcategory. (Inherited from GenericForm.)
Public property | TopOffset | The offset of the top end of the blend relative to the sketch plane.
Public property | TopProfile | The curves which make up the top profile of the sketch.
Public property | TopSketch | Returns the Top Sketch of the Blend.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Visible | The visibility of the GenericForm. (Inherited from GenericForm.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Blend Class


Blend Methods

[image] [image]

Revit 2024 API
Blend Methods
Blend Class See Also Send Feedback

The Blend type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVertexConnectionMap | Gets the mapping between the vertices in the top and bottom profiles.
Public method | GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetVertexConnectionMap | Sets the mapping between the vertices in the top and bottom profiles.
Public method | SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Blend Class


GetVertexConnectionMap Method

[image]

Revit 2024 API
Blend..::..GetVertexConnectionMap Method
Blend Class See Also Send Feedback
Gets the mapping between the vertices in the top and bottom profiles.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public VertexIndexPairArray GetVertexConnectionMap()
Visual Basic
Public Function GetVertexConnectionMap As VertexIndexPairArray
Visual C++
public:
VertexIndexPairArray^ GetVertexConnectionMap()

Remarks

Each vertex refers to the start point of the curve from the top and bottom profiles.

See Also

Blend Class


SetVertexConnectionMap Method

[image]

Revit 2024 API
Blend..::..SetVertexConnectionMap Method
Blend Class See Also Send Feedback
Sets the mapping between the vertices in the top and bottom profiles.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetVertexConnectionMap(
    VertexIndexPairArray vertexMap
)
Visual Basic
Public Sub SetVertexConnectionMap ( _
    vertexMap As VertexIndexPairArray _
)
Visual C++
public:
void SetVertexConnectionMap(
    VertexIndexPairArray^ vertexMap
)

Parameters

vertexMap
Type: Autodesk.Revit.DB..::..VertexIndexPairArray

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"vertexMap"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the input argument-"vertexMap"-is empty.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the document failed to regenerate.

See Also

Blend Class


Blend Properties

[image] [image]

Revit 2024 API
Blend Properties
Blend Class See Also Send Feedback

The Blend type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BottomOffset | The offset of the bottom end of the blend relative to the sketch plane.
Public property | BottomProfile | The curves which make up the bottom profile of the sketch.
Public property | BottomSketch | Returns the Bottom Sketch of the Blend.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Get and Set the Name property (Inherited from GenericForm.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Subcategory | The subcategory. (Inherited from GenericForm.)
Public property | TopOffset | The offset of the top end of the blend relative to the sketch plane.
Public property | TopProfile | The curves which make up the top profile of the sketch.
Public property | TopSketch | Returns the Top Sketch of the Blend.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Visible | The visibility of the GenericForm. (Inherited from GenericForm.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Blend Class


BottomOffset Property

[image]

Revit 2024 API
Blend..::..BottomOffset Property
Blend Class See Also Send Feedback
The offset of the bottom end of the blend relative to the sketch plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double BottomOffset { get; set; }
Visual Basic
Public Property BottomOffset As Double
    Get
    Set
Visual C++
public:
property double BottomOffset {
    double get ();
    void set (double value);
}

See Also

Blend Class


BottomProfile Property

[image]

Revit 2024 API
Blend..::..BottomProfile Property
Blend Class See Also Send Feedback
The curves which make up the bottom profile of the sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CurveArrArray BottomProfile { get; }
Visual Basic
Public ReadOnly Property BottomProfile As CurveArrArray
    Get
Visual C++
public:
property CurveArrArray^ BottomProfile {
    CurveArrArray^ get ();
}

Remarks

The indices of the curves in this array match the indices used in the vertex connection map.

See Also

Blend Class


BottomSketch Property

[image]

Revit 2024 API
Blend..::..BottomSketch Property
Blend Class See Also Send Feedback
Returns the Bottom Sketch of the Blend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Sketch BottomSketch { get; }
Visual Basic
Public ReadOnly Property BottomSketch As Sketch
    Get
Visual C++
public:
property Sketch^ BottomSketch {
    Sketch^ get ();
}

Remarks

This property is used to retrieve the Bottom Sketch of the Blend.

See Also

Blend Class


TopOffset Property

[image]

Revit 2024 API
Blend..::..TopOffset Property
Blend Class See Also Send Feedback
The offset of the top end of the blend relative to the sketch plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double TopOffset { get; set; }
Visual Basic
Public Property TopOffset As Double
    Get
    Set
Visual C++
public:
property double TopOffset {
    double get ();
    void set (double value);
}

See Also

Blend Class


TopProfile Property

[image]

Revit 2024 API
Blend..::..TopProfile Property
Blend Class See Also Send Feedback
The curves which make up the top profile of the sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CurveArrArray TopProfile { get; }
Visual Basic
Public ReadOnly Property TopProfile As CurveArrArray
    Get
Visual C++
public:
property CurveArrArray^ TopProfile {
    CurveArrArray^ get ();
}

Remarks

The indices of the curves in this array match the indices used in the vertex connection map.

See Also

Blend Class


TopSketch Property

[image]

Revit 2024 API
Blend..::..TopSketch Property
Blend Class See Also Send Feedback
Returns the Top Sketch of the Blend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Sketch TopSketch { get; }
Visual Basic
Public ReadOnly Property TopSketch As Sketch
    Get
Visual C++
public:
property Sketch^ TopSketch {
    Sketch^ get ();
}

Remarks

This property is used to retrieve the Top Sketch of the Blend.

See Also

Blend Class


BooleanOperationsType Enumeration

[image]

Revit 2024 API
BooleanOperationsType Enumeration
See Also Send Feedback
An enumerated type listing boolean types that are supported for boolean operation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public enum BooleanOperationsType
Visual Basic
Public Enumeration BooleanOperationsType
Visual C++
public enum class BooleanOperationsType

Members

Member name | Description
Union | Union.
Difference | Difference.
Intersect | Intersect.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


BooleanOperationsUtils Class

[image]

Revit 2024 API
BooleanOperationsUtils Class
Members See Also Send Feedback
These utilities are applicable for the geometry created by GeometryCreationUtilities and the geometry of Revit model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public class BooleanOperationsUtils : IDisposable
Visual Basic
Public Class BooleanOperationsUtils _
    Implements IDisposable
Visual C++
public ref class BooleanOperationsUtils : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BooleanOperationsUtils

See Also

BooleanOperationsUtils Members


BooleanOperationsUtils Members

[image] [image]

Revit 2024 API
BooleanOperationsUtils Members
BooleanOperationsUtils Class Methods Properties See Also Send Feedback

The BooleanOperationsUtils type exposes the following members.

Methods

 | Name | Description
 | CutWithHalfSpace | Creates a new Solid which is the intersection of the input Solid with the half-space on the positive side of the given Plane. The positive side of the plane is the side to which Plane.Normal points.
 | CutWithHalfSpaceModifyingOriginalSolid | Modifies the input Solid preserving only the volume on the positive side of the given Plane. The positive side of the plane is the side to which Plane.Normal points.
Public method | Dispose | Releases all resources used by the BooleanOperationsUtils
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExecuteBooleanOperation | Perform a boolean geometric operation between two solids, and return a new solid to represent the result.
 | ExecuteBooleanOperationModifyingOriginalSolid | Perform a boolean geometric operation between two solids, and modify the original solid to represent the result.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

BooleanOperationsUtils Class


CutWithHalfSpaceModifyingOriginalSolid Method

[image]

Revit 2024 API
BooleanOperationsUtils..::..CutWithHalfSpaceModifyingOriginalSolid Method
BooleanOperationsUtils Class See Also Send Feedback
Modifies the input Solid preserving only the volume on the positive side of the given Plane. The positive side of the plane is the side to which Plane.Normal points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public static void CutWithHalfSpaceModifyingOriginalSolid(
    Solid solid,
    Plane plane
)
Visual Basic
Public Shared Sub CutWithHalfSpaceModifyingOriginalSolid ( _
    solid As Solid, _
    plane As Plane _
)
Visual C++
public:
static void CutWithHalfSpaceModifyingOriginalSolid(
    Solid^ solid,
    Plane^ plane
)

Parameters

solid
Type: Autodesk.Revit.DB..::..Solid
The input Solid to be cut. This object cannot be obtained directly from a Revit element. This means that IsElementGeometry cannot be true.
plane
Type: Autodesk.Revit.DB..::..Plane
The cut plane. The space on the positive side of the normal of the plane will be intersected with the input Solid.

Remarks

This operation modifies the original input Geometry objects.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the original solid object is the geometry of the Revit model.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

BooleanOperationsUtils Class


Dispose Method

[image]

Revit 2024 API
BooleanOperationsUtils..::..Dispose Method
BooleanOperationsUtils Class See Also Send Feedback
Releases all resources used by the BooleanOperationsUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

BooleanOperationsUtils Class


ExecuteBooleanOperation Method

[image]

Revit 2024 API
BooleanOperationsUtils..::..ExecuteBooleanOperation Method
BooleanOperationsUtils Class Example See Also Send Feedback
Perform a boolean geometric operation between two solids, and return a new solid to represent the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static Solid ExecuteBooleanOperation(
    Solid solid0,
    Solid solid1,
    BooleanOperationsType booleanType
)
Visual Basic
Public Shared Function ExecuteBooleanOperation ( _
    solid0 As Solid, _
    solid1 As Solid, _
    booleanType As BooleanOperationsType _
) As Solid
Visual C++
public:
static Solid^ ExecuteBooleanOperation(
    Solid^ solid0,
    Solid^ solid1,
    BooleanOperationsType booleanType
)

Parameters

solid0
Type: Autodesk.Revit.DB..::..Solid
The first solid object. A copy will be taken of the input object, so any solid whether obtained from a Revit element or not would be accepted.
solid1
Type: Autodesk.Revit.DB..::..Solid
The second solid object. A copy will be taken of the input object, so any solid whether obtained from a Revit element or not would be accepted.
booleanType
Type: Autodesk.Revit.DB..::..BooleanOperationsType
boolean operation type.

Return Value

The result geometry.

Examples

CopyC#
private void ComputeIntersectionVolume(Solid solidA, Solid solidB)
{
    Solid intersection = BooleanOperationsUtils.ExecuteBooleanOperation(solidA, solidB, BooleanOperationsType.Intersect);
    double volumeOfIntersection = intersection.Volume;
}
CopyVB.NET
Private Sub ComputeIntersectionVolume(solidA As Solid, solidB As Solid)
    Dim intersection As Solid = BooleanOperationsUtils.ExecuteBooleanOperation(solidA, solidB, BooleanOperationsType.Intersect)
    Dim volumeOfIntersection As Double = intersection.Volume
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | Failed to perform the Boolean operation for the two solids. This may be due to geometric inaccuracies in the solids, such as slightly misaligned faces or edges. If so, eliminating the inaccuracies by making sure the solids are accurately aligned may solve the problem. This also may be due to one or both solids having complexities such as more than two faces geometrically meeting along a single edge, or two coincident edges, etc. Eliminating such conditions, or performing a sequence of Boolean operations in an order that avoids such conditions, may solve the problem.

See Also

BooleanOperationsUtils Class


ExecuteBooleanOperationModifyingOriginalSolid Method

[image]

Revit 2024 API
BooleanOperationsUtils..::..ExecuteBooleanOperationModifyingOriginalSolid Method
BooleanOperationsUtils Class See Also Send Feedback
Perform a boolean geometric operation between two solids, and modify the original solid to represent the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static void ExecuteBooleanOperationModifyingOriginalSolid(
    Solid solid0,
    Solid solid1,
    BooleanOperationsType booleanType
)
Visual Basic
Public Shared Sub ExecuteBooleanOperationModifyingOriginalSolid ( _
    solid0 As Solid, _
    solid1 As Solid, _
    booleanType As BooleanOperationsType _
)
Visual C++
public:
static void ExecuteBooleanOperationModifyingOriginalSolid(
    Solid^ solid0,
    Solid^ solid1,
    BooleanOperationsType booleanType
)

Parameters

solid0
Type: Autodesk.Revit.DB..::..Solid
The original solid object. This object cannot be obtained directly from a Revit element. This means that IsElementGeometry cannot be true.
solid1
Type: Autodesk.Revit.DB..::..Solid
The second solid object. A copy will be taken of the input object, so any solid whether obtained from a Revit element or not would be accepted.
booleanType
Type: Autodesk.Revit.DB..::..BooleanOperationsType
boolean operation type.

Remarks

This operation modifies the original input Geometry objects.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the original solid object is the geometry of the Revit model.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Failed to perform the Boolean operation for the two solids. This may be due to geometric inaccuracies in the solids, such as slightly misaligned faces or edges. If so, eliminating the inaccuracies by making sure the solids are accurately aligned may solve the problem. This also may be due to one or both solids having complexities such as more than two faces geometrically meeting along a single edge, or two coincident edges, etc. Eliminating such conditions, or performing a sequence of Boolean operations in an order that avoids such conditions, may solve the problem."

See Also

BooleanOperationsUtils Class


BooleanOperationsUtils Properties

[image] [image]

Revit 2024 API
BooleanOperationsUtils Properties
BooleanOperationsUtils Class See Also Send Feedback

The BooleanOperationsUtils type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

BooleanOperationsUtils Class


IsValidObject Property

[image]

Revit 2024 API
BooleanOperationsUtils..::..IsValidObject Property
BooleanOperationsUtils Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

BooleanOperationsUtils Class


BorderTile Enumeration

[image]

Revit 2024 API
BorderTile Enumeration
See Also Send Feedback
Options for controlling tiles that overlap the face boundary. See DividedSurface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum BorderTile
Visual Basic
Public Enumeration BorderTile
Visual C++
public enum class BorderTile

Members

Member name | Description
Empty |
Partial |
Overhanging |

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


BoundarySegment Class

[image]

Revit 2024 API
BoundarySegment Class
Members Example See Also Send Feedback
An object that represents a segment of an area boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class BoundarySegment : IDisposable
Visual Basic
Public Class BoundarySegment _
    Implements IDisposable
Visual C++
public ref class BoundarySegment : IDisposable

Remarks

These objects define the exterior boundary of an area. The geometry of the segment can be retrieved along with the id of the element that is responsible for producing that boundary.

Examples

CopyC#
public void GetInfo_BoundarySegment(Room room)
{
   IList<IList<Autodesk.Revit.DB.BoundarySegment>> segments = room.GetBoundarySegments(new SpatialElementBoundaryOptions());

   if (null != segments)  //the room may not be bound
   {
      string message = "BoundarySegment";
      foreach (IList<Autodesk.Revit.DB.BoundarySegment> segmentList in segments)
      {
         foreach (Autodesk.Revit.DB.BoundarySegment boundarySegment in segmentList)
         {

            // Get curve start point
            message += "\nCurve start point: (" + boundarySegment.GetCurve().GetEndPoint(0).X + ","
                           + boundarySegment.GetCurve().GetEndPoint(0).Y + "," +
                          boundarySegment.GetCurve().GetEndPoint(0).Z + ")";
            // Get curve end point
            message += ";\nCurve end point: (" + boundarySegment.GetCurve().GetEndPoint(1).X + ","
                 + boundarySegment.GetCurve().GetEndPoint(1).Y + "," +
                 boundarySegment.GetCurve().GetEndPoint(1).Z + ")";
            // Get document path name
            message += ";\nDocument path name: " + room.Document.PathName;
            // Get boundary segment element name
            if (boundarySegment.ElementId != ElementId.InvalidElementId)
            {
               message += ";\nElement name: " + room.Document.GetElement(boundarySegment.ElementId).Name;
            }
         }
      }
      TaskDialog.Show("Revit",message);
   }
}
CopyVB.NET
Public Sub GetInfo_BoundarySegment(room As Room)
    Dim segments As IList(Of IList(Of Autodesk.Revit.DB.BoundarySegment)) = room.GetBoundarySegments(New SpatialElementBoundaryOptions())

    If segments IsNot Nothing Then
        'the room may not be bound
        Dim message As String = "BoundarySegment"
        For Each segmentList As IList(Of Autodesk.Revit.DB.BoundarySegment) In segments
            For Each boundarySegment As Autodesk.Revit.DB.BoundarySegment In segmentList

          ' Get curve start point
          message += ((vbLf & "Curve start point: (" + boundarySegment.GetCurve().GetEndPoint(0).X & ",") + boundarySegment.GetCurve().GetEndPoint(0).Y & ",") + boundarySegment.GetCurve().GetEndPoint(0).Z & ")"
          ' Get curve end point
          message += ((";" & vbLf & "Curve end point: (" + boundarySegment.GetCurve().GetEndPoint(1).X & ",") + boundarySegment.GetCurve().GetEndPoint(1).Y & ",") + boundarySegment.GetCurve().GetEndPoint(1).Z & ")"
          ' Get document path name
          message += ";" & vbLf & "Document path name: " + room.Document.PathName
          ' Get boundary segment element name
          If boundarySegment.ElementId IsNot ElementId.InvalidElementId Then
             message += ";" & vbLf & "Element name: " + room.Document.GetElement(boundarySegment.ElementId).Name
          End If

            Next
        Next
        TaskDialog.Show("Revit", message)
    End If
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BoundarySegment

See Also

BoundarySegment Members


BoundarySegment Members

[image] [image]

Revit 2024 API
BoundarySegment Members
BoundarySegment Class Methods Properties See Also Send Feedback

The BoundarySegment type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the BoundarySegment
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCurve | Get a copy of the curve that is formed along this boundary.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ElementId | Retrieve the id of the element that produces this boundary segment. If the segment is created from an element in a link, this is the id of the RevitLinkInstance.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LinkElementId | Retrieve the element id of the element in a link instance that forms this boundary.

See Also

BoundarySegment Class


BoundarySegment Methods

[image] [image]

Revit 2024 API
BoundarySegment Methods
BoundarySegment Class See Also Send Feedback

The BoundarySegment type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCurve | Get a copy of the curve that is formed along this boundary.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BoundarySegment Class


Dispose Method

[image]

Revit 2024 API
BoundarySegment..::..Dispose Method
BoundarySegment Class See Also Send Feedback
Releases all resources used by the BoundarySegment

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

BoundarySegment Class


BoundarySegment Properties

[image] [image]

Revit 2024 API
BoundarySegment Properties
BoundarySegment Class See Also Send Feedback

The BoundarySegment type exposes the following members.

Properties

 | Name | Description
Public property | ElementId | Retrieve the id of the element that produces this boundary segment. If the segment is created from an element in a link, this is the id of the RevitLinkInstance.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LinkElementId | Retrieve the element id of the element in a link instance that forms this boundary.

See Also

BoundarySegment Class


IsValidObject Property

[image]

Revit 2024 API
BoundarySegment..::..IsValidObject Property
BoundarySegment Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

BoundarySegment Class


LinkElementId Property

[image]

Revit 2024 API
BoundarySegment..::..LinkElementId Property
BoundarySegment Class See Also Send Feedback
Retrieve the element id of the element in a link instance that forms this boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public ElementId LinkElementId { get; }
Visual Basic
Public ReadOnly Property LinkElementId As ElementId
    Get
Visual C++
public:
property ElementId^ LinkElementId {
    ElementId^ get ();
}

See Also

BoundarySegment Class


BoundaryValidation Class

[image]

Revit 2024 API
BoundaryValidation Class
Members See Also Send Feedback
Curve loop validators.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public class BoundaryValidation : IDisposable
Visual Basic
Public Class BoundaryValidation _
    Implements IDisposable
Visual C++
public ref class BoundaryValidation : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BoundaryValidation

See Also

BoundaryValidation Members


BoundaryValidation Members

[image] [image]

Revit 2024 API
BoundaryValidation Members
BoundaryValidation Class Methods Properties See Also Send Feedback

The BoundaryValidation type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the BoundaryValidation
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValidBoundaryOnSketchPlane | Indicates if the given curve loops compose a valid boundary on the sketch plane.
 | IsValidBoundaryOnView | Indicates if the given curve loops compose a valid boundary on the view's detail sketch plane.
 | IsValidHorizontalBoundary | Identifies whether the given curve loops compose a valid horizontal boundary.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

BoundaryValidation Class


BoundaryValidation Methods

[image] [image]

Revit 2024 API
BoundaryValidation Methods
BoundaryValidation Class See Also Send Feedback

The BoundaryValidation type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValidBoundaryOnSketchPlane | Indicates if the given curve loops compose a valid boundary on the sketch plane.
 | IsValidBoundaryOnView | Indicates if the given curve loops compose a valid boundary on the view's detail sketch plane.
 | IsValidHorizontalBoundary | Identifies whether the given curve loops compose a valid horizontal boundary.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BoundaryValidation Class


Dispose Method

[image]

Revit 2024 API
BoundaryValidation..::..Dispose Method
BoundaryValidation Class See Also Send Feedback
Releases all resources used by the BoundaryValidation

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

BoundaryValidation Class


IsValidBoundaryOnSketchPlane Method

[image]

Revit 2024 API
BoundaryValidation..::..IsValidBoundaryOnSketchPlane Method
BoundaryValidation Class See Also Send Feedback
Indicates if the given curve loops compose a valid boundary on the sketch plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public static bool IsValidBoundaryOnSketchPlane(
    SketchPlane sketchPlane,
    IList<CurveLoop> curveLoops
)
Visual Basic
Public Shared Function IsValidBoundaryOnSketchPlane ( _
    sketchPlane As SketchPlane, _
    curveLoops As IList(Of CurveLoop) _
) As Boolean
Visual C++
public:
static bool IsValidBoundaryOnSketchPlane(
    SketchPlane^ sketchPlane,
    IList<CurveLoop^>^ curveLoops
)

Parameters

sketchPlane
Type: Autodesk.Revit.DB..::..SketchPlane
The sketch plane.
curveLoops
Type: System.Collections.Generic..::..IList<(Of <(<' CurveLoop >)>)>
The curve loops to be checked.

Return Value

True if the given curve loops are valid as described above, false otherwise.

Remarks

The curve loops are valid if projections of the loops onto the sketch plane do not intersect each other; each curve loop is closed; input curves do not contain any helical curve; and each loop is planar and lies on a plane parallel to the sketch plane, but not necessarily the same plane.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

BoundaryValidation Class


IsValidBoundaryOnView Method

[image]

Revit 2024 API
BoundaryValidation..::..IsValidBoundaryOnView Method
BoundaryValidation Class See Also Send Feedback
Indicates if the given curve loops compose a valid boundary on the view's detail sketch plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public static bool IsValidBoundaryOnView(
    Document document,
    ElementId viewId,
    IList<CurveLoop> curveLoops
)
Visual Basic
Public Shared Function IsValidBoundaryOnView ( _
    document As Document, _
    viewId As ElementId, _
    curveLoops As IList(Of CurveLoop) _
) As Boolean
Visual C++
public:
static bool IsValidBoundaryOnView(
    Document^ document,
    ElementId^ viewId,
    IList<CurveLoop^>^ curveLoops
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
viewId
Type: Autodesk.Revit.DB..::..ElementId
The view Id.
curveLoops
Type: System.Collections.Generic..::..IList<(Of <(<' CurveLoop >)>)>
The curve loops to be checked.

Return Value

True if the given curve loops are valid as described above, false otherwise.

Remarks

The curve loops are valid if projections of the loops onto the views's detail sketch plane do not intersect each other; each curve loop is closed; input curves do not contain any helical curve; and each loop is planar and lies on a plane parallel to the views's detail sketch plane, but not necessarily the same plane.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

BoundaryValidation Class


IsValidHorizontalBoundary Method

[image]

Revit 2024 API
BoundaryValidation..::..IsValidHorizontalBoundary Method
BoundaryValidation Class See Also Send Feedback
Identifies whether the given curve loops compose a valid horizontal boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public static bool IsValidHorizontalBoundary(
    IList<CurveLoop> curveLoops
)
Visual Basic
Public Shared Function IsValidHorizontalBoundary ( _
    curveLoops As IList(Of CurveLoop) _
) As Boolean
Visual C++
public:
static bool IsValidHorizontalBoundary(
    IList<CurveLoop^>^ curveLoops
)

Parameters

curveLoops
Type: System.Collections.Generic..::..IList<(Of <(<' CurveLoop >)>)>
The curve loops to be checked.

Return Value

True if the given curve loops are valid as described above, false otherwise.

Remarks

The curve loops are valid if projections of the loops onto a horizontal(XY) plane do not intersect each other; each curve loop is closed; input curves do not contain any helical curve; and each loop is planar and lies on a plane parallel to the horizontal(XY) plane, but not necessarily the same plane.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

BoundaryValidation Class


BoundaryValidation Properties

[image] [image]

Revit 2024 API
BoundaryValidation Properties
BoundaryValidation Class See Also Send Feedback

The BoundaryValidation type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

BoundaryValidation Class


BoundingBoxContainsPointFilter Class

[image]

Revit 2024 API
BoundingBoxContainsPointFilter Class
Members Example See Also Send Feedback
A filter used to match elements with a bounding box that contains the given point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class BoundingBoxContainsPointFilter : ElementQuickFilter
Visual Basic
Public Class BoundingBoxContainsPointFilter _
    Inherits ElementQuickFilter
Visual C++
public ref class BoundingBoxContainsPointFilter : public ElementQuickFilter

Remarks

This filter excludes all objects derived from View and objects derived from ElementType. This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.

Examples

CopyC#
// Use BoundingBoxContainsPoint filter to find elements with a bounding box that contains the
// given point in the document.

// Create a BoundingBoxContainsPoint filter for base point of (0, 0, 0)
XYZ basePnt = new XYZ(0, 0, 0);
BoundingBoxContainsPointFilter filter = new BoundingBoxContainsPointFilter(basePnt);

// Apply the filter to the elements in the active document
// This filter will excludes all objects derived from View and objects derived from ElementType
FilteredElementCollector collector = new FilteredElementCollector(document);
IList<Element> elements = collector.WherePasses(filter).ToElements();

// Find walls that do not contain the given point: use an inverted filter to match elements
// Use shortcut command OfClass() to find walls only
BoundingBoxContainsPointFilter notContainFilter =
    new BoundingBoxContainsPointFilter(basePnt, true); // inverted filter
collector = new FilteredElementCollector(document);
IList<Element> notContainFounds =
    collector.OfClass(typeof(Wall)).WherePasses(notContainFilter).ToElements();
CopyVB.NET
' Use BoundingBoxContainsPoint filter to find elements with a bounding box that contains the
' given point in the document.

' Create a BoundingBoxContainsPoint filter for base point of (0, 0, 0)
Dim basePnt As New XYZ(0, 0, 0)
Dim filter As New BoundingBoxContainsPointFilter(basePnt)

' Apply the filter to the elements in the active document
' This filter will excludes all objects derived from View and objects derived from ElementType
Dim collector As New FilteredElementCollector(document)
Dim elements As IList(Of Element) = collector.WherePasses(filter).ToElements()

' Find walls that do not contain the given point: use an inverted filter to match elements
' Use shortcut command OfClass() to find walls only
Dim notContainFilter As New BoundingBoxContainsPointFilter(basePnt, True)
' inverted filter
collector = New FilteredElementCollector(document)
Dim notContainFounds As IList(Of Element) = collector.OfClass(GetType(Wall)).WherePasses(notContainFilter).ToElements()

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementQuickFilter
Autodesk.Revit.DB..::..BoundingBoxContainsPointFilter

See Also

BoundingBoxContainsPointFilter Members


BoundingBoxContainsPointFilter Members

[image] [image]

Revit 2024 API
BoundingBoxContainsPointFilter Members
BoundingBoxContainsPointFilter Class Constructors Methods Properties See Also Send Feedback

The BoundingBoxContainsPointFilter type exposes the following members.

Constructors

 | Name | Description
Public method | BoundingBoxContainsPointFilter(XYZ) | Constructs a new instance of a filter to match elements with a bounding box that contains the given point.
Public method | BoundingBoxContainsPointFilter(XYZ, Boolean) | Constructs a new instance of a filter to match elements with a bounding box that contains the given point, with the option to invert the filter and match all elements with a bounding box that do not contain the given point.
Public method | BoundingBoxContainsPointFilter(XYZ, Double) | Constructs a new instance of a filter to match elements with a bounding box that contains the given point, while specifying the tolerance to be used in deciding if the point matches the criteria.
Public method | BoundingBoxContainsPointFilter(XYZ, Double, Boolean) | Constructs a new instance of a filter to match elements with a bounding box that contains the given point, while specifying the tolerance to be used in deciding if the point matches the criteria. This constructor includes the option to invert the filter and match all elements with a bounding box that do not contain the given point.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)
Public property | Point | The XYZ point to use when matching element bounding boxes.
Public property | Tolerance | Allows control over the match criteria by using a tolerance in the geometry comparison. It is suggested to use this in cases where trivial differences should be considered when matching elements.

See Also

BoundingBoxContainsPointFilter Class


BoundingBoxContainsPointFilter Constructor

[image] [image]

Revit 2024 API
BoundingBoxContainsPointFilter Constructor
BoundingBoxContainsPointFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BoundingBoxContainsPointFilter(XYZ) | Constructs a new instance of a filter to match elements with a bounding box that contains the given point.
Public method | BoundingBoxContainsPointFilter(XYZ, Boolean) | Constructs a new instance of a filter to match elements with a bounding box that contains the given point, with the option to invert the filter and match all elements with a bounding box that do not contain the given point.
Public method | BoundingBoxContainsPointFilter(XYZ, Double) | Constructs a new instance of a filter to match elements with a bounding box that contains the given point, while specifying the tolerance to be used in deciding if the point matches the criteria.
Public method | BoundingBoxContainsPointFilter(XYZ, Double, Boolean) | Constructs a new instance of a filter to match elements with a bounding box that contains the given point, while specifying the tolerance to be used in deciding if the point matches the criteria. This constructor includes the option to invert the filter and match all elements with a bounding box that do not contain the given point.

See Also

BoundingBoxContainsPointFilter Class
BoundingBoxContainsPointFilter Members


BoundingBoxContainsPointFilter Constructor (XYZ)

[image]

Revit 2024 API
BoundingBoxContainsPointFilter Constructor (XYZ)
BoundingBoxContainsPointFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements with a bounding box that contains the given point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public BoundingBoxContainsPointFilter(
    XYZ point
)
Visual Basic
Public Sub New ( _
    point As XYZ _
)
Visual C++
public:
BoundingBoxContainsPointFilter(
    XYZ^ point
)

Parameters

point
Type: Autodesk.Revit.DB..::..XYZ
The point used to find elements with a bounding box that contains it.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

BoundingBoxContainsPointFilter Class
BoundingBoxContainsPointFilter Overload


BoundingBoxContainsPointFilter Constructor (XYZ, Boolean)

[image]

Revit 2024 API
BoundingBoxContainsPointFilter Constructor (XYZ, Boolean)
BoundingBoxContainsPointFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements with a bounding box that contains the given point, with the option to invert the filter and match all elements with a bounding box that do not contain the given point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public BoundingBoxContainsPointFilter(
    XYZ point,
    bool inverted
)
Visual Basic
Public Sub New ( _
    point As XYZ, _
    inverted As Boolean _
)
Visual C++
public:
BoundingBoxContainsPointFilter(
    XYZ^ point,
    bool inverted
)

Parameters

point
Type: Autodesk.Revit.DB..::..XYZ
The point used to find elements with a bounding box containing it.
inverted
Type: System..::..Boolean
True if the filter should be inverted and match all elements with a bounding box that do not contain the given point.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

BoundingBoxContainsPointFilter Class
BoundingBoxContainsPointFilter Overload


BoundingBoxContainsPointFilter Constructor (XYZ, Double)

[image]

Revit 2024 API
BoundingBoxContainsPointFilter Constructor (XYZ, Double)
BoundingBoxContainsPointFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements with a bounding box that contains the given point, while specifying the tolerance to be used in deciding if the point matches the criteria.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public BoundingBoxContainsPointFilter(
    XYZ point,
    double tolerance
)
Visual Basic
Public Sub New ( _
    point As XYZ, _
    tolerance As Double _
)
Visual C++
public:
BoundingBoxContainsPointFilter(
    XYZ^ point,
    double tolerance
)

Parameters

point
Type: Autodesk.Revit.DB..::..XYZ
The point used to find elements with a bounding box that contains it.
tolerance
Type: System..::..Double
The tolerance value to use instead of zero. See the tolerance property for details.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for tolerance is not finite -or- The given value for tolerance is not a number
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

BoundingBoxContainsPointFilter Class
BoundingBoxContainsPointFilter Overload


BoundingBoxContainsPointFilter Methods

[image] [image]

Revit 2024 API
BoundingBoxContainsPointFilter Methods
BoundingBoxContainsPointFilter Class See Also Send Feedback

The BoundingBoxContainsPointFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BoundingBoxContainsPointFilter Class


PassesFilter Method

[image] [image]

Revit 2024 API
BoundingBoxContainsPointFilter..::..PassesFilter Method
BoundingBoxContainsPointFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

BoundingBoxContainsPointFilter Class
BoundingBoxContainsPointFilter Members


Point Property

[image]

Revit 2024 API
BoundingBoxContainsPointFilter..::..Point Property
BoundingBoxContainsPointFilter Class See Also Send Feedback
The XYZ point to use when matching element bounding boxes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public XYZ Point { get; set; }
Visual Basic
Public Property Point As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ Point {
    XYZ^ get ();
    void set (XYZ^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

BoundingBoxContainsPointFilter Class


Tolerance Property

[image]

Revit 2024 API
BoundingBoxContainsPointFilter..::..Tolerance Property
BoundingBoxContainsPointFilter Class See Also Send Feedback
Allows control over the match criteria by using a tolerance in the geometry comparison. It is suggested to use this in cases where trivial differences should be considered when matching elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public double Tolerance { get; set; }
Visual Basic
Public Property Tolerance As Double
    Get
    Set
Visual C++
public:
property double Tolerance {
    double get ();
    void set (double value);
}

Remarks

By default this is set to zero, but depending on your units of measure and how close objects may be, it is advised to set this to something more realistic. If the tolerance is positive, the point may lie up to the tolerance amount outside the outline to be matched. If the tolerance is negative, the point must lie at least the tolerance amount inside the outline to be matched.

See Also

BoundingBoxContainsPointFilter Class


BoundingBoxIntersectsFilter Class

[image]

Revit 2024 API
BoundingBoxIntersectsFilter Class
Members Example See Also Send Feedback
A filter used to match elements with a bounding box that intersects the given Outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class BoundingBoxIntersectsFilter : ElementQuickFilter
Visual Basic
Public Class BoundingBoxIntersectsFilter _
    Inherits ElementQuickFilter
Visual C++
public ref class BoundingBoxIntersectsFilter : public ElementQuickFilter

Remarks

This filter excludes all objects derived from View and objects derived from ElementType. This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.

Examples

CopyC#
// Use BoundingBoxIntersects filter to find elements with a bounding box that intersects the
// given Outline in the document.

// Create a Outline, uses a minimum and maximum XYZ point to initialize the outline.
Outline myOutLn = new Outline(new XYZ(0, 0, 0), new XYZ(100, 100, 100));

// Create a BoundingBoxIntersects filter with this Outline
BoundingBoxIntersectsFilter filter = new BoundingBoxIntersectsFilter(myOutLn);

// Apply the filter to the elements in the active document
// This filter excludes all objects derived from View and objects derived from ElementType
FilteredElementCollector collector = new FilteredElementCollector(document);
IList<Element> elements = collector.WherePasses(filter).ToElements();

// Find all walls which don't intersect with BoundingBox: use an inverted filter to match elements
// Use shortcut command OfClass() to find walls only
BoundingBoxIntersectsFilter invertFilter = new BoundingBoxIntersectsFilter(myOutLn, true); // inverted filter
collector = new FilteredElementCollector(document);
IList<Element> notIntersectWalls =
    collector.OfClass(typeof(Wall)).WherePasses(invertFilter).ToElements();
CopyVB.NET
' Use BoundingBoxIntersects filter to find elements with a bounding box that intersects the
' given Outline in the document.

' Create a Outline, uses a minimum and maximum XYZ point to initialize the outline.
Dim myOutLn As New Outline(New XYZ(0, 0, 0), New XYZ(100, 100, 100))

' Create a BoundingBoxIntersects filter with this Outline
Dim filter As New BoundingBoxIntersectsFilter(myOutLn)

' Apply the filter to the elements in the active document
' This filter excludes all objects derived from View and objects derived from ElementType
Dim collector As New FilteredElementCollector(document)
Dim elements As IList(Of Element) = collector.WherePasses(filter).ToElements()

' Find all walls which don't intersect with BoundingBox: use an inverted filter to match elements
' Use shortcut command OfClass() to find walls only
Dim invertFilter As New BoundingBoxIntersectsFilter(myOutLn, True)
' inverted filter
collector = New FilteredElementCollector(document)
Dim notIntersectWalls As IList(Of Element) = collector.OfClass(GetType(Wall)).WherePasses(invertFilter).ToElements()

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementQuickFilter
Autodesk.Revit.DB..::..BoundingBoxIntersectsFilter

See Also

BoundingBoxIntersectsFilter Members


BoundingBoxIntersectsFilter Members

[image] [image]

Revit 2024 API
BoundingBoxIntersectsFilter Members
BoundingBoxIntersectsFilter Class Constructors Methods Properties See Also Send Feedback

The BoundingBoxIntersectsFilter type exposes the following members.

Constructors

 | Name | Description
Public method | BoundingBoxIntersectsFilter(Outline) | Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline.
Public method | BoundingBoxIntersectsFilter(Outline, Boolean) | Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline, with the option to invert the filter and match all elements with a bounding box that are not intersecting the given Outline.
Public method | BoundingBoxIntersectsFilter(Outline, Double) | Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline.
Public method | BoundingBoxIntersectsFilter(Outline, Double, Boolean) | Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline, with the option to invert the filter and match all elements with a bounding box that are not intersecting the given Outline.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBoundingBox | Gets the outline being used for this filter.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)
Public property | Tolerance | Allows control over the match criteria by using a tolerance in the geometry comparison. It is suggested to use this in cases where trivial differences should be considered when matching elements.

See Also

BoundingBoxIntersectsFilter Class


BoundingBoxIntersectsFilter Constructor

[image] [image]

Revit 2024 API
BoundingBoxIntersectsFilter Constructor
BoundingBoxIntersectsFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BoundingBoxIntersectsFilter(Outline) | Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline.
Public method | BoundingBoxIntersectsFilter(Outline, Boolean) | Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline, with the option to invert the filter and match all elements with a bounding box that are not intersecting the given Outline.
Public method | BoundingBoxIntersectsFilter(Outline, Double) | Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline.
Public method | BoundingBoxIntersectsFilter(Outline, Double, Boolean) | Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline, with the option to invert the filter and match all elements with a bounding box that are not intersecting the given Outline.

See Also

BoundingBoxIntersectsFilter Class
BoundingBoxIntersectsFilter Members


BoundingBoxIntersectsFilter Constructor (Outline)

[image]

Revit 2024 API
BoundingBoxIntersectsFilter Constructor (Outline)
BoundingBoxIntersectsFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public BoundingBoxIntersectsFilter(
    Outline outline
)
Visual Basic
Public Sub New ( _
    outline As Outline _
)
Visual C++
public:
BoundingBoxIntersectsFilter(
    Outline^ outline
)

Parameters

outline
Type: Autodesk.Revit.DB..::..Outline
The Outline used to find elements with a bounding box that intersect it.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | outline is an empty Outline.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

BoundingBoxIntersectsFilter Class
BoundingBoxIntersectsFilter Overload


BoundingBoxIntersectsFilter Constructor (Outline, Boolean)

[image]

Revit 2024 API
BoundingBoxIntersectsFilter Constructor (Outline, Boolean)
BoundingBoxIntersectsFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline, with the option to invert the filter and match all elements with a bounding box that are not intersecting the given Outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public BoundingBoxIntersectsFilter(
    Outline outline,
    bool inverted
)
Visual Basic
Public Sub New ( _
    outline As Outline, _
    inverted As Boolean _
)
Visual C++
public:
BoundingBoxIntersectsFilter(
    Outline^ outline,
    bool inverted
)

Parameters

outline
Type: Autodesk.Revit.DB..::..Outline
The Outline used to find elements with a bounding box that intersect it.
inverted
Type: System..::..Boolean
True if the filter should be inverted and match all elements with a bounding box that are not intersecting the given Outline.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | outline is an empty Outline.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

BoundingBoxIntersectsFilter Class
BoundingBoxIntersectsFilter Overload


BoundingBoxIntersectsFilter Constructor (Outline, Double)

[image]

Revit 2024 API
BoundingBoxIntersectsFilter Constructor (Outline, Double)
BoundingBoxIntersectsFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public BoundingBoxIntersectsFilter(
    Outline outline,
    double tolerance
)
Visual Basic
Public Sub New ( _
    outline As Outline, _
    tolerance As Double _
)
Visual C++
public:
BoundingBoxIntersectsFilter(
    Outline^ outline,
    double tolerance
)

Parameters

outline
Type: Autodesk.Revit.DB..::..Outline
The Outline used to find elements with a bounding box that intersect it.
tolerance
Type: System..::..Double
The tolerance value to use instead of zero. See the tolerance property for details.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | outline is an empty Outline. -or- The given value for tolerance is not finite -or- The given value for tolerance is not a number
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

BoundingBoxIntersectsFilter Class
BoundingBoxIntersectsFilter Overload


BoundingBoxIntersectsFilter Constructor (Outline, Double, Boolean)

[image]

Revit 2024 API
BoundingBoxIntersectsFilter Constructor (Outline, Double, Boolean)
BoundingBoxIntersectsFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline, with the option to invert the filter and match all elements with a bounding box that are not intersecting the given Outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public BoundingBoxIntersectsFilter(
    Outline outline,
    double tolerance,
    bool inverted
)
Visual Basic
Public Sub New ( _
    outline As Outline, _
    tolerance As Double, _
    inverted As Boolean _
)
Visual C++
public:
BoundingBoxIntersectsFilter(
    Outline^ outline,
    double tolerance,
    bool inverted
)

Parameters

outline
Type: Autodesk.Revit.DB..::..Outline
The Outline used to find elements with a bounding box that intersect it.
tolerance
Type: System..::..Double
The tolerance value to use instead of zero. See the tolerance property for details.
inverted
Type: System..::..Boolean
True if the filter should be inverted and match all elements with a bounding box that are not intersecting the given Outline.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | outline is an empty Outline. -or- The given value for tolerance is not finite -or- The given value for tolerance is not a number
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

BoundingBoxIntersectsFilter Class
BoundingBoxIntersectsFilter Overload


BoundingBoxIntersectsFilter Methods

[image] [image]

Revit 2024 API
BoundingBoxIntersectsFilter Methods
BoundingBoxIntersectsFilter Class See Also Send Feedback

The BoundingBoxIntersectsFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBoundingBox | Gets the outline being used for this filter.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BoundingBoxIntersectsFilter Class


GetBoundingBox Method

[image]

Revit 2024 API
BoundingBoxIntersectsFilter..::..GetBoundingBox Method
BoundingBoxIntersectsFilter Class See Also Send Feedback
Gets the outline being used for this filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public Outline GetBoundingBox()
Visual Basic
Public Function GetBoundingBox As Outline
Visual C++
public:
Outline^ GetBoundingBox()

Return Value

The outline being used for this filter.

See Also

BoundingBoxIntersectsFilter Class


PassesFilter Method

[image] [image]

Revit 2024 API
BoundingBoxIntersectsFilter..::..PassesFilter Method
BoundingBoxIntersectsFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

BoundingBoxIntersectsFilter Class
BoundingBoxIntersectsFilter Members


BoundingBoxIntersectsFilter Properties

[image] [image]

Revit 2024 API
BoundingBoxIntersectsFilter Properties
BoundingBoxIntersectsFilter Class See Also Send Feedback

The BoundingBoxIntersectsFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)
Public property | Tolerance | Allows control over the match criteria by using a tolerance in the geometry comparison. It is suggested to use this in cases where trivial differences should be considered when matching elements.

See Also

BoundingBoxIntersectsFilter Class


Tolerance Property

[image]

Revit 2024 API
BoundingBoxIntersectsFilter..::..Tolerance Property
BoundingBoxIntersectsFilter Class See Also Send Feedback
Allows control over the match criteria by using a tolerance in the geometry comparison. It is suggested to use this in cases where trivial differences should be considered when matching elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public double Tolerance { get; set; }
Visual Basic
Public Property Tolerance As Double
    Get
    Set
Visual C++
public:
property double Tolerance {
    double get ();
    void set (double value);
}

Remarks

By default this is set to zero, but depending on your units of measure and how close objects may be, it is advised to set this to something more realistic. If the tolerance is positive, the outlines may be separated by the tolerance distance in each coordinate. If the tolerance is negative, the outlines must overlap by at least the tolerance distance in each coordinate.

See Also

BoundingBoxIntersectsFilter Class


BoundingBoxIsInsideFilter Constructor (Outline)

[image]

Revit 2024 API
BoundingBoxIsInsideFilter Constructor (Outline)
BoundingBoxIsInsideFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements with a bounding box that is contained by the given Outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public BoundingBoxIsInsideFilter(
    Outline outline
)
Visual Basic
Public Sub New ( _
    outline As Outline _
)
Visual C++
public:
BoundingBoxIsInsideFilter(
    Outline^ outline
)

Parameters

outline
Type: Autodesk.Revit.DB..::..Outline
The Outline used to find elements with a bounding box that are contained by it.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | outline is an empty Outline.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

BoundingBoxIsInsideFilter Class
BoundingBoxIsInsideFilter Overload


BoundingBoxIsInsideFilter Constructor (Outline, Boolean)

[image]

Revit 2024 API
BoundingBoxIsInsideFilter Constructor (Outline, Boolean)
BoundingBoxIsInsideFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements with a bounding box is contained by the given Outline, with the option to invert the filter and match all elements with a bounding box that are not contained by the given Outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public BoundingBoxIsInsideFilter(
    Outline outline,
    bool inverted
)
Visual Basic
Public Sub New ( _
    outline As Outline, _
    inverted As Boolean _
)
Visual C++
public:
BoundingBoxIsInsideFilter(
    Outline^ outline,
    bool inverted
)

Parameters

outline
Type: Autodesk.Revit.DB..::..Outline
The Outline used to find elements with a bounding box that are contained by it.
inverted
Type: System..::..Boolean
True if the filter should be inverted and match all elements with a bounding box that are not contained by the given Outline.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | outline is an empty Outline.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

BoundingBoxIsInsideFilter Class
BoundingBoxIsInsideFilter Overload


BoundingBoxIsInsideFilter Constructor (Outline, Double)

[image]

Revit 2024 API
BoundingBoxIsInsideFilter Constructor (Outline, Double)
BoundingBoxIsInsideFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements with a bounding box that is contained by the given Outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public BoundingBoxIsInsideFilter(
    Outline outline,
    double tolerance
)
Visual Basic
Public Sub New ( _
    outline As Outline, _
    tolerance As Double _
)
Visual C++
public:
BoundingBoxIsInsideFilter(
    Outline^ outline,
    double tolerance
)

Parameters

outline
Type: Autodesk.Revit.DB..::..Outline
The Outline used to find elements with a bounding box that are contained by it.
tolerance
Type: System..::..Double
The tolerance value to use instead of zero. See the tolerance property for details.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | outline is an empty Outline. -or- The given value for tolerance is not finite -or- The given value for tolerance is not a number
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

BoundingBoxIsInsideFilter Class
BoundingBoxIsInsideFilter Overload


BoundingBoxIsInsideFilter Methods

[image] [image]

Revit 2024 API
BoundingBoxIsInsideFilter Methods
BoundingBoxIsInsideFilter Class See Also Send Feedback

The BoundingBoxIsInsideFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBoundingBox | Gets the outline being used for this filter.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BoundingBoxIsInsideFilter Class


GetBoundingBox Method

[image]

Revit 2024 API
BoundingBoxIsInsideFilter..::..GetBoundingBox Method
BoundingBoxIsInsideFilter Class See Also Send Feedback
Gets the outline being used for this filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public Outline GetBoundingBox()
Visual Basic
Public Function GetBoundingBox As Outline
Visual C++
public:
Outline^ GetBoundingBox()

Return Value

The outline being used for this filter.

See Also

BoundingBoxIsInsideFilter Class


PassesFilter Method

[image] [image]

Revit 2024 API
BoundingBoxIsInsideFilter..::..PassesFilter Method
BoundingBoxIsInsideFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

BoundingBoxIsInsideFilter Class
BoundingBoxIsInsideFilter Members


BoundingBoxIsInsideFilter Properties

[image] [image]

Revit 2024 API
BoundingBoxIsInsideFilter Properties
BoundingBoxIsInsideFilter Class See Also Send Feedback

The BoundingBoxIsInsideFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)
Public property | Tolerance | Allows control over the match criteria by using a tolerance in the geometry comparison. It is suggested to use this in cases where trivial differences should be considered when matching elements.

See Also

BoundingBoxIsInsideFilter Class


Tolerance Property

[image]

Revit 2024 API
BoundingBoxIsInsideFilter..::..Tolerance Property
BoundingBoxIsInsideFilter Class See Also Send Feedback
Allows control over the match criteria by using a tolerance in the geometry comparison. It is suggested to use this in cases where trivial differences should be considered when matching elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public double Tolerance { get; set; }
Visual Basic
Public Property Tolerance As Double
    Get
    Set
Visual C++
public:
property double Tolerance {
    double get ();
    void set (double value);
}

Remarks

By default this is set to zero, but depending on your units of measure and how close objects may be, it is advised to set this to something more realistic. If the tolerance is positive, the iterated element's Outline may extend the tolerance distance outside of the given Outline in each coordinate to be a match. If the tolerance is negative, the iterated element's Outline must lie at least the tolerance distance inside the given Outline in each coordinate to be a match.

See Also

BoundingBoxIsInsideFilter Class


BoundingBoxUV Members

[image] [image]

Revit 2024 API
BoundingBoxUV Members
BoundingBoxUV Class Constructors Methods Properties See Also Send Feedback

The BoundingBoxUV type exposes the following members.

Constructors

 | Name | Description
Public method | BoundingBoxUV()()()() | default constructor
Public method | BoundingBoxUV(Double, Double, Double, Double) | Creates object with supplied values.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the BoundingBoxUV
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Bounds | Indexed access for loops. Use 0 for Min and 1 for Max.
Public property | IsSet | Indicates whether the BoundingBoxUV is set or not.
Public property | Max | Maximum coordinates (upper-right corner of the box).
Public property | Min | Minimum coordinates (lower-left corner of the box).

See Also

BoundingBoxUV Class


BoundingBoxUV Constructor

[image] [image]

Revit 2024 API
BoundingBoxUV Constructor
BoundingBoxUV Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BoundingBoxUV()()()() | default constructor
Public method | BoundingBoxUV(Double, Double, Double, Double) | Creates object with supplied values.

See Also

BoundingBoxUV Class
BoundingBoxUV Members


BoundingBoxUV Constructor (Double, Double, Double, Double)

[image]

Revit 2024 API
BoundingBoxUV Constructor (Double, Double, Double, Double)
BoundingBoxUV Class See Also Send Feedback
Creates object with supplied values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public BoundingBoxUV(
    double min_u,
    double min_v,
    double max_u,
    double max_v
)
Visual Basic
Public Sub New ( _
    min_u As Double, _
    min_v As Double, _
    max_u As Double, _
    max_v As Double _
)
Visual C++
public:
BoundingBoxUV(
    double min_u,
    double min_v,
    double max_u,
    double max_v
)

Parameters

min_u
Type: System..::..Double
The first coordinate of min.
min_v
Type: System..::..Double
The second coordinate of min.
max_u
Type: System..::..Double
The first coordinate of max.
max_v
Type: System..::..Double
The second coordinate of max.

See Also

BoundingBoxUV Class
BoundingBoxUV Overload


BoundingBoxUV Methods

[image] [image]

Revit 2024 API
BoundingBoxUV Methods
BoundingBoxUV Class See Also Send Feedback

The BoundingBoxUV type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BoundingBoxUV Class


Dispose Method

[image]

Revit 2024 API
BoundingBoxUV..::..Dispose Method
BoundingBoxUV Class See Also Send Feedback
Releases all resources used by the BoundingBoxUV

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

BoundingBoxUV Class


BoundingBoxUV Properties

[image] [image]

Revit 2024 API
BoundingBoxUV Properties
BoundingBoxUV Class See Also Send Feedback

The BoundingBoxUV type exposes the following members.

Properties

 | Name | Description
Public property | Bounds | Indexed access for loops. Use 0 for Min and 1 for Max.
Public property | IsSet | Indicates whether the BoundingBoxUV is set or not.
Public property | Max | Maximum coordinates (upper-right corner of the box).
Public property | Min | Minimum coordinates (lower-left corner of the box).

See Also

BoundingBoxUV Class


Bounds Property

[image]

Revit 2024 API
BoundingBoxUV..::..Bounds Property
BoundingBoxUV Class See Also Send Feedback
Indexed access for loops. Use 0 for Min and 1 for Max.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public UV this[
    int idx
] { get; }
Visual Basic
Public ReadOnly Property Bounds ( _
    idx As Integer _
) As UV
    Get
Visual C++
public:
property UV^ Bounds[int idx] {
    UV^ get (int idx);
}

Parameters

idx
Type: System..::..Int32

See Also

BoundingBoxUV Class


IsSet Property

[image]

Revit 2024 API
BoundingBoxUV..::..IsSet Property
BoundingBoxUV Class See Also Send Feedback
Indicates whether the BoundingBoxUV is set or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public bool IsSet { get; }
Visual Basic
Public ReadOnly Property IsSet As Boolean
    Get
Visual C++
public:
property bool IsSet {
    bool get ();
}

Remarks

An unset BoundingBoxUV has its lower-left corner to the right of (and above) its upper-right corner (this is an arbitrary internal representation). It means that it is empty and has never been initialized. If someone using the API creates a Plane via one of the Plane.Create() methods, for example, the Plane will not have its envelope set, so Surface.GetBoundingBoxUV() would return an empty BoundingBoxUV.

See Also

BoundingBoxUV Class


Max Property

[image]

Revit 2024 API
BoundingBoxUV..::..Max Property
BoundingBoxUV Class See Also Send Feedback
Maximum coordinates (upper-right corner of the box).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public UV Max { get; set; }
Visual Basic
Public Property Max As UV
    Get
    Set
Visual C++
public:
property UV^ Max {
    UV^ get ();
    void set (UV^ value);
}

See Also

BoundingBoxUV Class


Min Property

[image]

Revit 2024 API
BoundingBoxUV..::..Min Property
BoundingBoxUV Class See Also Send Feedback
Minimum coordinates (lower-left corner of the box).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public UV Min { get; set; }
Visual Basic
Public Property Min As UV
    Get
    Set
Visual C++
public:
property UV^ Min {
    UV^ get ();
    void set (UV^ value);
}

See Also

BoundingBoxUV Class


BoundingBoxXYZ Class

[image]

Revit 2024 API
BoundingBoxXYZ Class
Members Example See Also Send Feedback
A three-dimensional rectangular box at an arbitrary location and orientation within the Revit model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class BoundingBoxXYZ : APIObject
Visual Basic
Public Class BoundingBoxXYZ _
    Inherits APIObject
Visual C++
public ref class BoundingBoxXYZ : public APIObject

Remarks

BoundingBoxXYZ objects are used in Revit in several places related to views (for example, the section box of a 3D view or the definition of a section or detail view). BoundingBoxXYZ objects can also be obtained from elements representing the boundary of the element in a given view.

The extents of the box are determined by three orthogonal planes extended through the minimum (Min) and maximum (Max) points, but the coordinates of these points and the orientation of the planes in relation to the coordinates of the source model is determined by the box Transform (Transform).

This class also has the ability to detect and mark certain extents as disabled. Note that in the current Revit API uses of this class it is not expected that Revit will give objects with disabled extents, and disabled extents in objects sent to Revit will likely be ignored.

Examples

CopyC#
public void GetBoundingBoxXYZInfo(View3D view3D)
{
    string message = "BoundingBoxXYZ : ";
    message += "\nView name : " + view3D.Name;
    BoundingBoxXYZ boundingBox = view3D.GetSectionBox();
    // The section box of the 3D view can cut the model.
    if (view3D.IsSectionBoxActive)
    {
        BoundingBoxXYZ sectionBox = view3D.GetSectionBox();

        // Note that the section box can be rotated and transformed.
        // So the min/max corners coordinates relative to the model must be computed via the transform.
        Transform trf = sectionBox.Transform;

        XYZ max = sectionBox.Max; //Maximum coordinates (upper-right-front corner of the box before transform is applied).
        XYZ min = sectionBox.Min; //Minimum coordinates (lower-left-rear corner of the box before transform is applied).

        // Transform the min and max to model coordinates
        XYZ maxInModelCoords = trf.OfPoint(max);
        XYZ minInModelCoords = trf.OfPoint(min);

        message += "\nView has an active section box: ";
        message += "\n'Maximum' coordinates: " + maxInModelCoords;
        message += "\n'Minimum' coordinates: " + minInModelCoords;
    }
    TaskDialog.Show("Revit", message);
}
CopyVB.NET
Public Sub GetBoundingBoxXYZInfo(view3D As View3D)
    Dim message As String = "BoundingBoxXYZ : "
    message += vbLf & "View name : " + view3D.Name
    Dim boundingBox As BoundingBoxXYZ = view3D.GetSectionBox()
    ' The section box of the 3D view can cut the model.
    If view3D.IsSectionBoxActive Then
        Dim sectionBox As BoundingBoxXYZ = view3D.GetSectionBox()

        ' Note that the section box can be rotated and transformed.
        ' So the min/max corners coordinates relative to the model must be computed via the transform.
        Dim trf As Transform = sectionBox.Transform

        Dim max As XYZ = sectionBox.Max
        'Maximum coordinates (upper-right-front corner of the box before transform is applied).
        Dim min As XYZ = sectionBox.Min
        'Minimum coordinates (lower-left-rear corner of the box before transform is applied).
        ' Transform the min and max to model coordinates
        Dim maxInModelCoords As XYZ = trf.OfPoint(max)
        Dim minInModelCoords As XYZ = trf.OfPoint(min)

        message += vbLf & "View has an active section box: "
        message += vbLf & "Maximum' coordinates: " + maxInModelCoords.ToString()
        message += vbLf & "Minimum' coordinates: " + minInModelCoords.ToString()
    End If
    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..BoundingBoxXYZ

See Also

BoundingBoxXYZ Members


BoundingBoxXYZ Constructor

[image]

Revit 2024 API
BoundingBoxXYZ Constructor
BoundingBoxXYZ Class See Also Send Feedback
Constructs a new BoundingBoxXYZ with a default transform and extents of (-100, -100, -100) to (100, 100, 100).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public BoundingBoxXYZ()
Visual Basic
Public Sub New
Visual C++
public:
BoundingBoxXYZ()

See Also

BoundingBoxXYZ Class


BoundingBoxXYZ Methods

[image] [image]

Revit 2024 API
BoundingBoxXYZ Methods
BoundingBoxXYZ Class See Also Send Feedback

The BoundingBoxXYZ type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BoundingBoxXYZ Class


BoundEnabled Property

[image]

Revit 2024 API
BoundingBoxXYZ..::..BoundEnabled Property
BoundingBoxXYZ Class See Also Send Feedback
Indexed access for loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool this[
    int bound,
    int dim
] { get; set; }
Visual Basic
Public Property BoundEnabled ( _
    bound As Integer, _
    dim As Integer _
) As Boolean
    Get
    Set
Visual C++
public:
property bool BoundEnabled[int bound, int dim] {
    bool get (int bound, int dim);
    void set (int bound, int dim, bool value);
}

Parameters

bound
Type: System..::..Int32
dim
Type: System..::..Int32

Remarks

For bound, use 0 for Min and 1 for Max. For dimension, use 0 for X, 1 for Y and 2 for Z. The entire box must be enabled to have enabled individual bounds.

See Also

BoundingBoxXYZ Class


Bounds Property

[image]

Revit 2024 API
BoundingBoxXYZ..::..Bounds Property
BoundingBoxXYZ Class See Also Send Feedback
Indexed access for loops. Use 0 for Min and 1 for Max.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ this[
    int bound
] { get; set; }
Visual Basic
Public Property Bounds ( _
    bound As Integer _
) As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ Bounds[int bound] {
    XYZ^ get (int bound);
    void set (int bound, XYZ^ value);
}

Parameters

bound
Type: System..::..Int32

Remarks

The bounds are defined in the coordinate space of the box.

See Also

BoundingBoxXYZ Class


Enabled Property

[image]

Revit 2024 API
BoundingBoxXYZ..::..Enabled Property
BoundingBoxXYZ Class See Also Send Feedback
Defines whether the entire bounding box is enabled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool Enabled { get; set; }
Visual Basic
Public Property Enabled As Boolean
    Get
    Set
Visual C++
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

Remarks

A disabled bounding box might be used to signal that the corresponding Revit functionality is deactivated. For example, a disabled 3D view section box represents an inactive section box.

See Also

BoundingBoxXYZ Class


IsSet Property

[image]

Revit 2024 API
BoundingBoxXYZ..::..IsSet Property
BoundingBoxXYZ Class See Also Send Feedback
Indicates whether the bounding box is set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsSet { get; }
Visual Basic
Public ReadOnly Property IsSet As Boolean
    Get
Visual C++
public:
property bool IsSet {
    bool get ();
}

Remarks

Bounding box is considered set when it contains at least one point and "Enabled" is set to "true".

See Also

BoundingBoxXYZ Class


Max Property

[image]

Revit 2024 API
BoundingBoxXYZ..::..Max Property
BoundingBoxXYZ Class See Also Send Feedback
Maximum coordinates (upper-right-front corner of the box).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ Max { get; set; }
Visual Basic
Public Property Max As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ Max {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

The bounds are defined in the coordinate space of the box.

See Also

BoundingBoxXYZ Class


MaxEnabled Property

[image]

Revit 2024 API
BoundingBoxXYZ..::..MaxEnabled Property
BoundingBoxXYZ Class See Also Send Feedback
Defines whether the maximum bound is active for given dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool this[
    int dim
] { get; set; }
Visual Basic
Public Property MaxEnabled ( _
    dim As Integer _
) As Boolean
    Get
    Set
Visual C++
public:
property bool MaxEnabled[int dim] {
    bool get (int dim);
    void set (int dim, bool value);
}

Parameters

dim
Type: System..::..Int32

Remarks

Use 0 for X, 1 for Y and 2 for Z. The entire box must be enabled to have enabled individual bounds.

See Also

BoundingBoxXYZ Class


Min Property

[image]

Revit 2024 API
BoundingBoxXYZ..::..Min Property
BoundingBoxXYZ Class See Also Send Feedback
Minimum coordinates (lower-left-rear corner of the box).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ Min { get; set; }
Visual Basic
Public Property Min As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ Min {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

The bounds are defined in the coordinate space of the box.

See Also

BoundingBoxXYZ Class


MinEnabled Property

[image]

Revit 2024 API
BoundingBoxXYZ..::..MinEnabled Property
BoundingBoxXYZ Class See Also Send Feedback
Defines whether the minimum bound is active for given dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool this[
    int dim
] { get; set; }
Visual Basic
Public Property MinEnabled ( _
    dim As Integer _
) As Boolean
    Get
    Set
Visual C++
public:
property bool MinEnabled[int dim] {
    bool get (int dim);
    void set (int dim, bool value);
}

Parameters

dim
Type: System..::..Int32

Remarks

Use 0 for X, 1 for Y and 2 for Z. The entire box must be enabled to have enabled individual bounds.

See Also

BoundingBoxXYZ Class


Transform Property

[image]

Revit 2024 API
BoundingBoxXYZ..::..Transform Property
BoundingBoxXYZ Class Example See Also Send Feedback
The transform from the coordinate space of the box to the model coordinate space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Transform Transform { get; set; }
Visual Basic
Public Property Transform As Transform
    Get
    Set
Visual C++
public:
property Transform^ Transform {
    Transform^ get ();
    void set (Transform^ value);
}

Remarks

The transform must always be right-handed and orthonormal.

Examples

CopyC#
private void RotateBoundingBox(View3D view3d)
{
    if (!view3d.IsSectionBoxActive)
    {
        TaskDialog.Show("Revit","The section box for View3D isn't active.");
        return;
    }
    BoundingBoxXYZ box = view3d.GetSectionBox();

    // Create a rotation transform to apply to the section box
    XYZ origin = new XYZ(0, 0, 0);
    XYZ axis = new XYZ(0, 0, 1);

    // Rotate 30 degrees
    Transform rotate = Transform.CreateRotationAtPoint(axis, Math.PI/6.0, origin);

    // Transform the View3D's section box with the rotation transform
    box.Transform = box.Transform.Multiply(rotate);

    // Set the section box back to the view (requires an open transaction)
    view3d.SetSectionBox(box);
}
CopyVB.NET
Private Sub RotateBoundingBox(view3d As View3D)
    If Not view3d.IsSectionBoxActive Then
        TaskDialog.Show("Revit", "The section box for View3D isn't active.")
        Return
    End If
    Dim box As BoundingBoxXYZ = view3d.GetSectionBox()

    ' Create a rotation transform to apply to the section box
    Dim origin As New XYZ(0, 0, 0)
    Dim axis As New XYZ(0, 0, 1)

    ' Rotate 30 degrees
    Dim rotate As Transform = Transform.CreateRotationAtPoint(axis, Math.PI / 6.0, origin)

    ' Transform the View3D's section box with the rotation transform
    box.Transform = box.Transform.Multiply(rotate)

    ' Set the section box back to the view (requires an open transaction)
    view3d.SetSectionBox(box)
End Sub

See Also

BoundingBoxXYZ Class


BoxPlacement Enumeration

[image]

Revit 2024 API
BoxPlacement Enumeration
See Also Send Feedback
An enumerated type containing possible constraint types for Adaptive Points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum BoxPlacement
Visual Basic
Public Enumeration BoxPlacement
Visual C++
public enum class BoxPlacement

Members

Member name | Description
Center | Placement of a box by its center point
TopLeft | Placement of a box by its top left corner.
TopRight | Placement of a box by its top right corner.
BottomRight | Placement of a box by its bottom right corner.
BottomLeft | Placement of a box by its bottom left corner.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


BRepBuilder Class

[image]

Revit 2024 API
BRepBuilder Class
Members Example See Also Send Feedback
A class that allows direct construction of geometry objects (solids, open shells, etc.).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public class BRepBuilder : ShapeBuilder
Visual Basic
Public Class BRepBuilder _
    Inherits ShapeBuilder
Visual C++
public ref class BRepBuilder : public ShapeBuilder

Examples

CopyC#
private void CreateDirectShapeFromCylinder(Document doc)
{
    // Naming convention for faces and edges: we assume that x is to the left and pointing down, y is horizontal and pointing to the right, z is up
    BRepBuilder brepBuilder = new BRepBuilder(BRepType.Solid);

    // The surfaces of the four faces.
    Frame basis = new Frame(new XYZ(50, -100, 0), new XYZ(0, 1, 0), new XYZ(-1, 0, 0), new XYZ(0, 0, 1));
    CylindricalSurface cylSurf = CylindricalSurface.Create(basis, 50);
    Plane top = Plane.CreateByNormalAndOrigin(new XYZ(0, 0, 1), new XYZ(0, 0, 100));  // normal points outside the cylinder
    Plane bottom = Plane.CreateByNormalAndOrigin(new XYZ(0, 0, 1), new XYZ(0, 0, 0)); // normal points inside the cylinder

    // Add the four faces
    BRepBuilderGeometryId frontCylFaceId = brepBuilder.AddFace(BRepBuilderSurfaceGeometry.Create(cylSurf, null), false);
    BRepBuilderGeometryId backCylFaceId = brepBuilder.AddFace(BRepBuilderSurfaceGeometry.Create(cylSurf, null), false);
    BRepBuilderGeometryId topFaceId = brepBuilder.AddFace(BRepBuilderSurfaceGeometry.Create(top, null), false);
    BRepBuilderGeometryId bottomFaceId = brepBuilder.AddFace(BRepBuilderSurfaceGeometry.Create(bottom, null), true);

    // Geometry for the four semi-circular edges and two vertical linear edges
    BRepBuilderEdgeGeometry frontEdgeBottom = BRepBuilderEdgeGeometry.Create(Arc.Create(new XYZ(0, -100, 0), new XYZ(100, -100, 0), new XYZ(50, -50, 0)));
    BRepBuilderEdgeGeometry backEdgeBottom = BRepBuilderEdgeGeometry.Create(Arc.Create(new XYZ(100, -100, 0), new XYZ(0, -100, 0), new XYZ(50, -150, 0)));

    BRepBuilderEdgeGeometry frontEdgeTop = BRepBuilderEdgeGeometry.Create(Arc.Create(new XYZ(0, -100, 100), new XYZ(100, -100, 100), new XYZ(50, -50, 100)));
    BRepBuilderEdgeGeometry backEdgeTop = BRepBuilderEdgeGeometry.Create(Arc.Create(new XYZ(0, -100, 100), new XYZ(100, -100, 100), new XYZ(50, -150, 100)));

    BRepBuilderEdgeGeometry linearEdgeFront = BRepBuilderEdgeGeometry.Create(new XYZ(100, -100, 0), new XYZ(100, -100, 100));
    BRepBuilderEdgeGeometry linearEdgeBack = BRepBuilderEdgeGeometry.Create(new XYZ(0, -100, 0), new XYZ(0, -100, 100));

    // Add the six edges
    BRepBuilderGeometryId frontEdgeBottomId = brepBuilder.AddEdge(frontEdgeBottom);
    BRepBuilderGeometryId frontEdgeTopId = brepBuilder.AddEdge(frontEdgeTop);
    BRepBuilderGeometryId linearEdgeFrontId = brepBuilder.AddEdge(linearEdgeFront);
    BRepBuilderGeometryId linearEdgeBackId = brepBuilder.AddEdge(linearEdgeBack);
    BRepBuilderGeometryId backEdgeBottomId = brepBuilder.AddEdge(backEdgeBottom);
    BRepBuilderGeometryId backEdgeTopId = brepBuilder.AddEdge(backEdgeTop);

    // Loops of the four faces
    BRepBuilderGeometryId loopId_Top = brepBuilder.AddLoop(topFaceId);
    BRepBuilderGeometryId loopId_Bottom = brepBuilder.AddLoop(bottomFaceId);
    BRepBuilderGeometryId loopId_Front = brepBuilder.AddLoop(frontCylFaceId);
    BRepBuilderGeometryId loopId_Back = brepBuilder.AddLoop(backCylFaceId);

    // Add coedges for the loop of the front face
    brepBuilder.AddCoEdge(loopId_Front, linearEdgeBackId, false);
    brepBuilder.AddCoEdge(loopId_Front, frontEdgeTopId, false);
    brepBuilder.AddCoEdge(loopId_Front, linearEdgeFrontId, true);
    brepBuilder.AddCoEdge(loopId_Front, frontEdgeBottomId, true);
    brepBuilder.FinishLoop(loopId_Front);
    brepBuilder.FinishFace(frontCylFaceId);

    // Add coedges for the loop of the back face
    brepBuilder.AddCoEdge(loopId_Back, linearEdgeBackId, true);
    brepBuilder.AddCoEdge(loopId_Back, backEdgeBottomId, true);
    brepBuilder.AddCoEdge(loopId_Back, linearEdgeFrontId, false);
    brepBuilder.AddCoEdge(loopId_Back, backEdgeTopId, true);
    brepBuilder.FinishLoop(loopId_Back);
    brepBuilder.FinishFace(backCylFaceId);

    // Add coedges for the loop of the top face
    brepBuilder.AddCoEdge(loopId_Top, backEdgeTopId, false);
    brepBuilder.AddCoEdge(loopId_Top, frontEdgeTopId, true);
    brepBuilder.FinishLoop(loopId_Top);
    brepBuilder.FinishFace(topFaceId);

    // Add coedges for the loop of the bottom face
    brepBuilder.AddCoEdge(loopId_Bottom, frontEdgeBottomId, false);
    brepBuilder.AddCoEdge(loopId_Bottom, backEdgeBottomId, false);
    brepBuilder.FinishLoop(loopId_Bottom);
    brepBuilder.FinishFace(bottomFaceId);

    brepBuilder.Finish();

    using (Transaction tr = new Transaction(doc, "Create a DirectShape"))
    {
        tr.Start();
        DirectShape ds = DirectShape.CreateElement(doc, new ElementId(BuiltInCategory.OST_GenericModel));
        ds.SetShape(brepBuilder);
        tr.Commit();
    }
}
CopyVB.NET
Private Sub CreateDirectShapeFromCylinder(doc As Document)
    ' Naming convention for faces and edges: we assume that x is to the left and pointing down, y is horizontal and pointing to the right, z is up
    Dim brepBuilder As New BRepBuilder(BRepType.Solid)

    ' The surfaces of the four faces.
    Dim basis As New Frame(New XYZ(50, -100, 0), New XYZ(0, 1, 0), New XYZ(-1, 0, 0), New XYZ(0, 0, 1))
    Dim cylSurf As CylindricalSurface = CylindricalSurface.Create(basis, 50)
    Dim top As Plane = Plane.CreateByNormalAndOrigin(New XYZ(0, 0, 1), New XYZ(0, 0, 100))
    ' normal points outside the cylinder
    Dim bottom As Plane = Plane.CreateByNormalAndOrigin(New XYZ(0, 0, 1), New XYZ(0, 0, 0))
    ' normal points inside the cylinder
    ' Add the four faces
    Dim frontCylFaceId As BRepBuilderGeometryId = brepBuilder.AddFace(BRepBuilderSurfaceGeometry.Create(cylSurf, Nothing), False)
    Dim backCylFaceId As BRepBuilderGeometryId = brepBuilder.AddFace(BRepBuilderSurfaceGeometry.Create(cylSurf, Nothing), False)
    Dim topFaceId As BRepBuilderGeometryId = brepBuilder.AddFace(BRepBuilderSurfaceGeometry.Create(top, Nothing), False)
    Dim bottomFaceId As BRepBuilderGeometryId = brepBuilder.AddFace(BRepBuilderSurfaceGeometry.Create(bottom, Nothing), True)

    ' Geometry for the four semi-circular edges and two vertical linear edges
    Dim frontEdgeBottom As BRepBuilderEdgeGeometry = BRepBuilderEdgeGeometry.Create(Arc.Create(New XYZ(0, -100, 0), New XYZ(100, -100, 0), New XYZ(50, -50, 0)))
    Dim backEdgeBottom As BRepBuilderEdgeGeometry = BRepBuilderEdgeGeometry.Create(Arc.Create(New XYZ(100, -100, 0), New XYZ(0, -100, 0), New XYZ(50, -150, 0)))

    Dim frontEdgeTop As BRepBuilderEdgeGeometry = BRepBuilderEdgeGeometry.Create(Arc.Create(New XYZ(0, -100, 100), New XYZ(100, -100, 100), New XYZ(50, -50, 100)))
    Dim backEdgeTop As BRepBuilderEdgeGeometry = BRepBuilderEdgeGeometry.Create(Arc.Create(New XYZ(0, -100, 100), New XYZ(100, -100, 100), New XYZ(50, -150, 100)))

    Dim linearEdgeFront As BRepBuilderEdgeGeometry = BRepBuilderEdgeGeometry.Create(New XYZ(100, -100, 0), New XYZ(100, -100, 100))
    Dim linearEdgeBack As BRepBuilderEdgeGeometry = BRepBuilderEdgeGeometry.Create(New XYZ(0, -100, 0), New XYZ(0, -100, 100))

    ' Add the six edges
    Dim frontEdgeBottomId As BRepBuilderGeometryId = brepBuilder.AddEdge(frontEdgeBottom)
    Dim frontEdgeTopId As BRepBuilderGeometryId = brepBuilder.AddEdge(frontEdgeTop)
    Dim linearEdgeFrontId As BRepBuilderGeometryId = brepBuilder.AddEdge(linearEdgeFront)
    Dim linearEdgeBackId As BRepBuilderGeometryId = brepBuilder.AddEdge(linearEdgeBack)
    Dim backEdgeBottomId As BRepBuilderGeometryId = brepBuilder.AddEdge(backEdgeBottom)
    Dim backEdgeTopId As BRepBuilderGeometryId = brepBuilder.AddEdge(backEdgeTop)

    ' Loops of the four faces
    Dim loopId_Top As BRepBuilderGeometryId = brepBuilder.AddLoop(topFaceId)
    Dim loopId_Bottom As BRepBuilderGeometryId = brepBuilder.AddLoop(bottomFaceId)
    Dim loopId_Front As BRepBuilderGeometryId = brepBuilder.AddLoop(frontCylFaceId)
    Dim loopId_Back As BRepBuilderGeometryId = brepBuilder.AddLoop(backCylFaceId)

    ' Add coedges for the loop of the front face
    brepBuilder.AddCoEdge(loopId_Front, linearEdgeBackId, False)
    brepBuilder.AddCoEdge(loopId_Front, frontEdgeTopId, False)
    brepBuilder.AddCoEdge(loopId_Front, linearEdgeFrontId, True)
    brepBuilder.AddCoEdge(loopId_Front, frontEdgeBottomId, True)
    brepBuilder.FinishLoop(loopId_Front)
    brepBuilder.FinishFace(frontCylFaceId)

    ' Add coedges for the loop of the back face
    brepBuilder.AddCoEdge(loopId_Back, linearEdgeBackId, True)
    brepBuilder.AddCoEdge(loopId_Back, backEdgeBottomId, True)
    brepBuilder.AddCoEdge(loopId_Back, linearEdgeFrontId, False)
    brepBuilder.AddCoEdge(loopId_Back, backEdgeTopId, True)
    brepBuilder.FinishLoop(loopId_Back)
    brepBuilder.FinishFace(backCylFaceId)

    ' Add coedges for the loop of the top face
    brepBuilder.AddCoEdge(loopId_Top, backEdgeTopId, False)
    brepBuilder.AddCoEdge(loopId_Top, frontEdgeTopId, True)
    brepBuilder.FinishLoop(loopId_Top)
    brepBuilder.FinishFace(topFaceId)

    ' Add coedges for the loop of the bottom face
    brepBuilder.AddCoEdge(loopId_Bottom, frontEdgeBottomId, False)
    brepBuilder.AddCoEdge(loopId_Bottom, backEdgeBottomId, False)
    brepBuilder.FinishLoop(loopId_Bottom)
    brepBuilder.FinishFace(bottomFaceId)

    brepBuilder.Finish()

    Using tr As New Transaction(doc, "Create a DirectShape")
        tr.Start()
        Dim ds As DirectShape = DirectShape.CreateElement(doc, New ElementId(BuiltInCategory.OST_GenericModel))
        ds.SetShape(brepBuilder)
        tr.Commit()
    End Using
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ShapeBuilder
Autodesk.Revit.DB..::..BRepBuilder

See Also

BRepBuilder Members


BRepBuilder Constructor

[image]

Revit 2024 API
BRepBuilder Constructor
BRepBuilder Class See Also Send Feedback
Construct a BRepBuilder to use in constructing geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public BRepBuilder(
    BRepType geomType
)
Visual Basic
Public Sub New ( _
    geomType As BRepType _
)
Visual C++
public:
BRepBuilder(
    BRepType geomType
)

Parameters

geomType
Type: Autodesk.Revit.DB..::..BRepType
Specifies the expected type of the output geometry.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

BRepBuilder Class


BRepBuilder Methods

[image] [image]

Revit 2024 API
BRepBuilder Methods
BRepBuilder Class See Also Send Feedback

The BRepBuilder type exposes the following members.

Methods

 | Name | Description
Public method | AddCoEdge | Add a co-edge associated to a previously added edge. A co-edge represents the use of an edge on one of the edge's faces. BrepBuilder allows at most two faces per edge, hence at most two co-edges per edge, and the co-edges must have opposite bCoEdgeIsReversed flags. The co-edges in a loop must be added in the order in which they occur in loop (i.e., in their topological order).
Public method | AddEdge | Add a new edge to the geometry being built. The BRepBuilder uses edges only to store edge geometry and to track pairs of co-edges that share an edge.
Public method | AddFace | Creates an empty face in the geometry being built. Other BRepBuilder methods are used to add loops to the face.
Public method | AddLoop | Creates an empty loop in a given face of the geometry being built. Other BRepBuilder methods are used to add co-edges to the loop.
Public method | AllowRemovalOfProblematicFaces | Allow BRepBuilder to remove problematic faces (e.g., due to inaccurate edge geometry). If this option is enabled and BRepBuilder removes some faces, the output geometry's type will be OpenShell regardless of the expected type specified when the BRepBuilder was created.
Public method | CanAddGeometry | A validator function that checks the state of this BRepBuilder object. Returns true if this BRepBuilder object is accepting b-rep data, false otherwise.
Public method | Dispose | (Inherited from ShapeBuilder.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Finish | Complete construction of the geometry. The geometry will be validated and, if valid, stored in this Builder. Otherwise it will be deleted.
Public method | FinishFace | Indicates that the caller has finished defining the given face.
Public method | FinishLoop | Indicates that the caller has finished defining the given loop.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetResult()()()() | Get the Geometry object built by this BRepBuilder. This will clear the built Geometry stored in the BRepBuilder. This function will throw if this BRepBuilder hasn't completed building the b-rep. Use IsResultAvailable() to verify that this BRepBuilder contains a valid result.
Public method | GetResult(ExternalGeometryId, BRepBuilderPersistentIds) | Get the Geometry object built by this BRepBuilder. This will clear the built Geometry stored in the BRepBuilder. This function will throw if this BRepBuilder hasn't completed building the b-rep. Use IsResultAvailable() to verify that this BRepBuilder contains a valid result.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsPermittedSurfaceType | A validator function that checks whether the surface object is of type supported as face surface by BRepBuilder.
Public method | IsResultAvailable | A validator function that checks the state of this BRepBuilder object. Returns true if this BRepBuilder object has successfully built a b-rep.
Public method | IsValidEdgeId | A validator function that checks whether the edge id corresponds to an edge previously added to this BRepBuilder object.
Public method | IsValidFaceId | A validator function that checks whether the face id corresponds to a face previously added to this BRepBuilder object.
Public method | IsValidLoopId | A validator function that checks whether the loop id corresponds to a loop previously added to this BRepBuilder object.
Public method | IsValidPersistentIdsMap | A validator function that makes sure that all BRepBuilderGeometryIds in the input map can be found in this BRepBuilder object.
Public method | RemovedSomeFaces | Returns 'true' if BRepBuilder removed some problematic faces from the output geometry, 'false' if not. If allowRemovalOfProblematicFaces was not called to enable removal of problematic faces, this function will return 'false'. Note that if some faces were removed, the output geometry's type will be OpenShell regardless of the expected type that was specified when the BRepBuilder was created.
Public method | SetAllowShortEdges | Make BRepBuilder allow edges that it would normally disallow as being too short for Revit geometry.
Public method | SetFaceMaterialId | Sets material id to a face.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BRepBuilder Class


AddCoEdge Method

[image]

Revit 2024 API
BRepBuilder..::..AddCoEdge Method
BRepBuilder Class See Also Send Feedback
Add a co-edge associated to a previously added edge. A co-edge represents the use of an edge on one of the edge's faces. BrepBuilder allows at most two faces per edge, hence at most two co-edges per edge, and the co-edges must have opposite bCoEdgeIsReversed flags. The co-edges in a loop must be added in the order in which they occur in loop (i.e., in their topological order).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public BRepBuilderGeometryId AddCoEdge(
    BRepBuilderGeometryId loopId,
    BRepBuilderGeometryId edgeId,
    bool bCoEdgeIsReversed
)
Visual Basic
Public Function AddCoEdge ( _
    loopId As BRepBuilderGeometryId, _
    edgeId As BRepBuilderGeometryId, _
    bCoEdgeIsReversed As Boolean _
) As BRepBuilderGeometryId
Visual C++
public:
BRepBuilderGeometryId^ AddCoEdge(
    BRepBuilderGeometryId^ loopId,
    BRepBuilderGeometryId^ edgeId,
    bool bCoEdgeIsReversed
)

Parameters

loopId
Type: Autodesk.Revit.DB..::..BRepBuilderGeometryId
Id of the loop containing the new co-edge.
edgeId
Type: Autodesk.Revit.DB..::..BRepBuilderGeometryId
Id of the co-edge's edge, previously created by a call to addEdge().
bCoEdgeIsReversed
Type: System..::..Boolean
True if the co-edge's topological direction in its face is opposite to the edge's parametric direction, false otherwise. The topological directions of the co-edges in a loop must be consistent with the direction in which the loop co-edges appear in the loop, and the loop orientations so defined must follow the convention that outer loops are oriented counter-clockwise and inner loops are oriented clockwise, with respect to the face's orientation.

Return Value

Id of the edge, to be used in calls to other BRepBuilder methods such as AddCoEdge().

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The supplied loop id doesn't correspond to a loop stored in this BRepBuilder object. -or- The supplied edge id doesn't correspond to an edge stored in this BRepBuilder object. -or- FinishLoop() has already been called on loopId. -or- The edge already has two coedges associated to it. -or- Inconsistent use of the edge by co-edges is detected: both co-edges have the same bCoedgeIsReversed parameter. -or- The edge has already been added to this face. -or- There is a gap between this co-edge and the previous co-edge in the loop.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This BRepBuilder object isn't accepting new data, either because it has already been used to build geometry, or because of an error. Consult the State property of the BRepBuilder object for more details.

See Also

BRepBuilder Class


AddEdge Method

[image]

Revit 2024 API
BRepBuilder..::..AddEdge Method
BRepBuilder Class See Also Send Feedback
Add a new edge to the geometry being built. The BRepBuilder uses edges only to store edge geometry and to track pairs of co-edges that share an edge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public BRepBuilderGeometryId AddEdge(
    BRepBuilderEdgeGeometry edgeGeom
)
Visual Basic
Public Function AddEdge ( _
    edgeGeom As BRepBuilderEdgeGeometry _
) As BRepBuilderGeometryId
Visual C++
public:
BRepBuilderGeometryId^ AddEdge(
    BRepBuilderEdgeGeometry^ edgeGeom
)

Parameters

edgeGeom
Type: Autodesk.Revit.DB..::..BRepBuilderEdgeGeometry
Information specifying the edge's geometry.

Return Value

Id of the edge, to be used in calls to other BRepBuilder methods such as AddCoEdge().

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input edge geometry was invalid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This BRepBuilder object isn't accepting new data, either because it has already been used to build geometry, or because of an error. Consult the State property of the BRepBuilder object for more details.

See Also

BRepBuilder Class


AddLoop Method

[image]

Revit 2024 API
BRepBuilder..::..AddLoop Method
BRepBuilder Class See Also Send Feedback
Creates an empty loop in a given face of the geometry being built. Other BRepBuilder methods are used to add co-edges to the loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public BRepBuilderGeometryId AddLoop(
    BRepBuilderGeometryId faceId
)
Visual Basic
Public Function AddLoop ( _
    faceId As BRepBuilderGeometryId _
) As BRepBuilderGeometryId
Visual C++
public:
BRepBuilderGeometryId^ AddLoop(
    BRepBuilderGeometryId^ faceId
)

Parameters

faceId
Type: Autodesk.Revit.DB..::..BRepBuilderGeometryId
Id of the face to which the loop should be added. faceId was returned by a call to AddFace().

Return Value

An id that can be used to identify the loop while the BRepBuilder is actively building geometry (e.g., to add co-edges to the loop).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The supplied face id doesn't correspond to a face stored in this BRepBuilder object. -or- FinishFace() has already been called on faceId. -or- Please finish the previous loop by calling FinishLoop() before adding a new one.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This BRepBuilder object isn't accepting new data, either because it has already been used to build geometry, or because of an error. Consult the State property of the BRepBuilder object for more details.

See Also

BRepBuilder Class


AllowRemovalOfProblematicFaces Method

[image]

Revit 2024 API
BRepBuilder..::..AllowRemovalOfProblematicFaces Method
BRepBuilder Class See Also Send Feedback
Allow BRepBuilder to remove problematic faces (e.g., due to inaccurate edge geometry). If this option is enabled and BRepBuilder removes some faces, the output geometry's type will be OpenShell regardless of the expected type specified when the BRepBuilder was created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017_subscription_update

Syntax

C#
public void AllowRemovalOfProblematicFaces()
Visual Basic
Public Sub AllowRemovalOfProblematicFaces
Visual C++
public:
void AllowRemovalOfProblematicFaces()

See Also

BRepBuilder Class


CanAddGeometry Method

[image]

Revit 2024 API
BRepBuilder..::..CanAddGeometry Method
BRepBuilder Class See Also Send Feedback
A validator function that checks the state of this BRepBuilder object. Returns true if this BRepBuilder object is accepting b-rep data, false otherwise.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool CanAddGeometry()
Visual Basic
Public Function CanAddGeometry As Boolean
Visual C++
public:
bool CanAddGeometry()

Return Value

True if this BRepBuilder object is accepting b-rep data, false otherwise.

Remarks

Use this function before calling AddFace(), AddEdge(), etc. to avoid an exception being thrown.

See Also

BRepBuilder Class


Finish Method

[image]

Revit 2024 API
BRepBuilder..::..Finish Method
BRepBuilder Class See Also Send Feedback
Complete construction of the geometry. The geometry will be validated and, if valid, stored in this Builder. Otherwise it will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public BRepBuilderOutcome Finish()
Visual Basic
Public Function Finish As BRepBuilderOutcome
Visual C++
public:
BRepBuilderOutcome Finish()

Return Value

BRepBuilderOutcome.Success if successful, BRepBuilderOutcome.Failure otherwise.

Remarks

If this function returned anything but BRepBuilderOutcome.Success, this BrepBuilder object should be discarded. An attempt to retrieve the built b-rep via GetBRep() will cause an exception to be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This BRepBuilder object isn't accepting new data, either because it has already been used to build geometry, or because of an error. Consult the State property of the BRepBuilder object for more details. -or- BRep doesn't have enough faces. -or- FinishFace() must be called on all the faces of the BRepBuilder.

See Also

BRepBuilder Class


FinishFace Method

[image]

Revit 2024 API
BRepBuilder..::..FinishFace Method
BRepBuilder Class See Also Send Feedback
Indicates that the caller has finished defining the given face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public void FinishFace(
    BRepBuilderGeometryId faceId
)
Visual Basic
Public Sub FinishFace ( _
    faceId As BRepBuilderGeometryId _
)
Visual C++
public:
void FinishFace(
    BRepBuilderGeometryId^ faceId
)

Parameters

faceId
Type: Autodesk.Revit.DB..::..BRepBuilderGeometryId
Id of the face.

Remarks

No functions that modify the given face's definition should be called after calling this function (e.g., AddLoop(BRepBuilderGeometryId), SetFaceMaterialId(BRepBuilderGeometryId, ElementId)). The BRepBuilder may take the opportunity to validate some of the face's data and report any problems it finds.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The supplied face id doesn't correspond to a face stored in this BRepBuilder object. -or- FinishFace() has already been called on faceId. -or- The face has no edge loops. -or- FinishLoop() must be called on all the edge loops of faceId.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

BRepBuilder Class


GetResult Method

[image]

Revit 2024 API
BRepBuilder..::..GetResult Method
BRepBuilder Class See Also Send Feedback
Get the Geometry object built by this BRepBuilder. This will clear the built Geometry stored in the BRepBuilder. This function will throw if this BRepBuilder hasn't completed building the b-rep. Use IsResultAvailable() to verify that this BRepBuilder contains a valid result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public Solid GetResult()
Visual Basic
Public Function GetResult As Solid
Visual C++
public:
Solid^ GetResult()

Return Value

The Geometry object built by this BRepBuilder.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This BRepBuilder object hasn't completed building data or was unsuccessful building it. Built Geometry is unavailable. In order to access the built Geometry, Finish() must be called first. That will set the state to completed.

See Also

BRepBuilder Class
GetResult Overload


GetResult Method (ExternalGeometryId, BRepBuilderPersistentIds)

[image]

Revit 2024 API
BRepBuilder..::..GetResult Method (ExternalGeometryId, BRepBuilderPersistentIds)
BRepBuilder Class See Also Send Feedback
Get the Geometry object built by this BRepBuilder. This will clear the built Geometry stored in the BRepBuilder. This function will throw if this BRepBuilder hasn't completed building the b-rep. Use IsResultAvailable() to verify that this BRepBuilder contains a valid result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public ExternallyTaggedBRep GetResult(
    ExternalGeometryId externalId,
    BRepBuilderPersistentIds brepPersistentIds
)
Visual Basic
Public Function GetResult ( _
    externalId As ExternalGeometryId, _
    brepPersistentIds As BRepBuilderPersistentIds _
) As ExternallyTaggedBRep
Visual C++
public:
ExternallyTaggedBRep^ GetResult(
    ExternalGeometryId^ externalId,
    BRepBuilderPersistentIds^ brepPersistentIds
)

Parameters

externalId
Type: Autodesk.Revit.DB..::..ExternalGeometryId
The external Id of the Geometry object built by this BRepBuilder.
brepPersistentIds
Type: Autodesk.Revit.DB..::..BRepBuilderPersistentIds
An object storing the relationship between ExternalGeometryIds and BRepBuilderGeometryIds.

Return Value

The Geometry object built by this BRepBuilder.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | At least one BRepBuilderGeometryId in the supplied BRepBuilderPersistentIds map could not be found in this BRepBuilder object.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This BRepBuilder object hasn't completed building data or was unsuccessful building it. Built Geometry is unavailable. In order to access the built Geometry, Finish() must be called first. That will set the state to completed.

See Also

BRepBuilder Class
GetResult Overload


IsPermittedSurfaceType Method

[image]

Revit 2024 API
BRepBuilder..::..IsPermittedSurfaceType Method
BRepBuilder Class See Also Send Feedback
A validator function that checks whether the surface object is of type supported as face surface by BRepBuilder.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public static bool IsPermittedSurfaceType(
    Surface surface
)
Visual Basic
Public Shared Function IsPermittedSurfaceType ( _
    surface As Surface _
) As Boolean
Visual C++
public:
static bool IsPermittedSurfaceType(
    Surface^ surface
)

Parameters

surface
Type: Autodesk.Revit.DB..::..Surface
Surface object intended to be used as a face surface.

Return Value

True if surface of this type may be used as a face surface, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

BRepBuilder Class


IsValidEdgeId Method

[image]

Revit 2024 API
BRepBuilder..::..IsValidEdgeId Method
BRepBuilder Class See Also Send Feedback
A validator function that checks whether the edge id corresponds to an edge previously added to this BRepBuilder object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool IsValidEdgeId(
    BRepBuilderGeometryId edgeId
)
Visual Basic
Public Function IsValidEdgeId ( _
    edgeId As BRepBuilderGeometryId _
) As Boolean
Visual C++
public:
bool IsValidEdgeId(
    BRepBuilderGeometryId^ edgeId
)

Parameters

edgeId
Type: Autodesk.Revit.DB..::..BRepBuilderGeometryId
Edge id to be validated.

Return Value

True if edgeId corresponds to an edge previously added to this BRepBuilder, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

BRepBuilder Class


IsValidFaceId Method

[image]

Revit 2024 API
BRepBuilder..::..IsValidFaceId Method
BRepBuilder Class See Also Send Feedback
A validator function that checks whether the face id corresponds to a face previously added to this BRepBuilder object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool IsValidFaceId(
    BRepBuilderGeometryId faceId
)
Visual Basic
Public Function IsValidFaceId ( _
    faceId As BRepBuilderGeometryId _
) As Boolean
Visual C++
public:
bool IsValidFaceId(
    BRepBuilderGeometryId^ faceId
)

Parameters

faceId
Type: Autodesk.Revit.DB..::..BRepBuilderGeometryId
Face id to be validated.

Return Value

True if faceId corresponds to a face previously added to this BRepBuilder, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

BRepBuilder Class


IsValidLoopId Method

[image]

Revit 2024 API
BRepBuilder..::..IsValidLoopId Method
BRepBuilder Class See Also Send Feedback
A validator function that checks whether the loop id corresponds to a loop previously added to this BRepBuilder object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool IsValidLoopId(
    BRepBuilderGeometryId loopId
)
Visual Basic
Public Function IsValidLoopId ( _
    loopId As BRepBuilderGeometryId _
) As Boolean
Visual C++
public:
bool IsValidLoopId(
    BRepBuilderGeometryId^ loopId
)

Parameters

loopId
Type: Autodesk.Revit.DB..::..BRepBuilderGeometryId
Loop id to be validated.

Return Value

True if loopId corresponds to a loop previously added to this BRepBuilder, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

BRepBuilder Class


IsValidPersistentIdsMap Method

[image]

Revit 2024 API
BRepBuilder..::..IsValidPersistentIdsMap Method
BRepBuilder Class See Also Send Feedback
A validator function that makes sure that all BRepBuilderGeometryIds in the input map can be found in this BRepBuilder object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool IsValidPersistentIdsMap(
    BRepBuilderPersistentIds brepPersistentIds
)
Visual Basic
Public Function IsValidPersistentIdsMap ( _
    brepPersistentIds As BRepBuilderPersistentIds _
) As Boolean
Visual C++
public:
bool IsValidPersistentIdsMap(
    BRepBuilderPersistentIds^ brepPersistentIds
)

Parameters

brepPersistentIds
Type: Autodesk.Revit.DB..::..BRepBuilderPersistentIds
The map that associates ExternalGeometryIds to BRepBuilderGeometryIds.

Return Value

True if all BRepBuilderGeometryIds in the input map can be found in this BRepBuilder object, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

BRepBuilder Class


SetAllowShortEdges Method

[image]

Revit 2024 API
BRepBuilder..::..SetAllowShortEdges Method
BRepBuilder Class See Also Send Feedback
Make BRepBuilder allow edges that it would normally disallow as being too short for Revit geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017_subscription_update

Syntax

C#
public void SetAllowShortEdges()
Visual Basic
Public Sub SetAllowShortEdges
Visual C++
public:
void SetAllowShortEdges()

Remarks

When used, this function must be called before any geometry is defined (e.g., just after constructing a BRepBuilder object). Geometry with short edges may not be as reliable as fully valid geometry. This option is intended to allow the construction of geometry such as mechanical items with small features that is not expected to interact much with other Revit elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This function was called after the geometry had been defined (e.g. by calls to addFace).

See Also

BRepBuilder Class


SetFaceMaterialId Method

[image]

Revit 2024 API
BRepBuilder..::..SetFaceMaterialId Method
BRepBuilder Class See Also Send Feedback
Sets material id to a face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public void SetFaceMaterialId(
    BRepBuilderGeometryId faceId,
    ElementId materialId
)
Visual Basic
Public Sub SetFaceMaterialId ( _
    faceId As BRepBuilderGeometryId, _
    materialId As ElementId _
)
Visual C++
public:
void SetFaceMaterialId(
    BRepBuilderGeometryId^ faceId,
    ElementId^ materialId
)

Parameters

faceId
Type: Autodesk.Revit.DB..::..BRepBuilderGeometryId
Id of the face to which material id will be added. faceId was returned by a call to AddFace().
materialId
Type: Autodesk.Revit.DB..::..ElementId
The material id associated with the face, or invalidElementId if none. It is not verified that materialId corresponds to a valid Material element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The supplied face id doesn't correspond to a face stored in this BRepBuilder object.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This BRepBuilder object isn't accepting new data, either because it has already been used to build geometry, or because of an error. Consult the State property of the BRepBuilder object for more details.

See Also

BRepBuilder Class


BRepBuilder Properties

[image] [image]

Revit 2024 API
BRepBuilder Properties
BRepBuilder Class See Also Send Feedback

The BRepBuilder type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ShapeBuilder.)

See Also

BRepBuilder Class


BRepBuilderEdgeGeometry Class

[image]

Revit 2024 API
BRepBuilderEdgeGeometry Class
Members See Also Send Feedback
An abstract class used by BRepBuilder to represent the geometry of an edge. Specific edge-geometry representations are represented by subclasses.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public class BRepBuilderEdgeGeometry : IDisposable
Visual Basic
Public Class BRepBuilderEdgeGeometry _
    Implements IDisposable
Visual C++
public ref class BRepBuilderEdgeGeometry : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BRepBuilderEdgeGeometry

See Also

BRepBuilderEdgeGeometry Members


BRepBuilderEdgeGeometry Members

[image] [image]

Revit 2024 API
BRepBuilderEdgeGeometry Members
BRepBuilderEdgeGeometry Class Methods Properties See Also Send Feedback

The BRepBuilderEdgeGeometry type exposes the following members.

Methods

 | Name | Description
 | Create(Curve) | Construct BRepBuilderEdgeGeometry based on any GCurve, including GLine and GArc. The curve will be simplified if possible, and the concrete type of the returned value will reflect that simplification: BRepBuilderLinearEdgeGeometry if the curve could be simplified to a line, BRepBuilderArcEdgeGeometry if it could be simplified to an arc, BRepBuilderGenericCurveEdgeGeometry otherwise.
 | Create(XYZ, XYZ) | Constructs a BRepBuilderEdgeGeometry representing a straight line between the two given points.
Public method | Dispose | Releases all resources used by the BRepBuilderEdgeGeometry
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

BRepBuilderEdgeGeometry Class


BRepBuilderEdgeGeometry Methods

[image] [image]

Revit 2024 API
BRepBuilderEdgeGeometry Methods
BRepBuilderEdgeGeometry Class See Also Send Feedback

The BRepBuilderEdgeGeometry type exposes the following members.

Methods

 | Name | Description
 | Create(Curve) | Construct BRepBuilderEdgeGeometry based on any GCurve, including GLine and GArc. The curve will be simplified if possible, and the concrete type of the returned value will reflect that simplification: BRepBuilderLinearEdgeGeometry if the curve could be simplified to a line, BRepBuilderArcEdgeGeometry if it could be simplified to an arc, BRepBuilderGenericCurveEdgeGeometry otherwise.
 | Create(XYZ, XYZ) | Constructs a BRepBuilderEdgeGeometry representing a straight line between the two given points.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BRepBuilderEdgeGeometry Class


Create Method

[image] [image]

Revit 2024 API
BRepBuilderEdgeGeometry..::..Create Method
BRepBuilderEdgeGeometry Class See Also Send Feedback

Overload List

Name | Description
Create(Curve) | Construct BRepBuilderEdgeGeometry based on any GCurve, including GLine and GArc. The curve will be simplified if possible, and the concrete type of the returned value will reflect that simplification: BRepBuilderLinearEdgeGeometry if the curve could be simplified to a line, BRepBuilderArcEdgeGeometry if it could be simplified to an arc, BRepBuilderGenericCurveEdgeGeometry otherwise.
Create(XYZ, XYZ) | Constructs a BRepBuilderEdgeGeometry representing a straight line between the two given points.

See Also

BRepBuilderEdgeGeometry Class
BRepBuilderEdgeGeometry Members


Dispose Method

[image]

Revit 2024 API
BRepBuilderEdgeGeometry..::..Dispose Method
BRepBuilderEdgeGeometry Class See Also Send Feedback
Releases all resources used by the BRepBuilderEdgeGeometry

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

BRepBuilderEdgeGeometry Class


BRepBuilderEdgeGeometry Properties

[image] [image]

Revit 2024 API
BRepBuilderEdgeGeometry Properties
BRepBuilderEdgeGeometry Class See Also Send Feedback

The BRepBuilderEdgeGeometry type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

BRepBuilderEdgeGeometry Class


IsValidObject Property

[image]

Revit 2024 API
BRepBuilderEdgeGeometry..::..IsValidObject Property
BRepBuilderEdgeGeometry Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

BRepBuilderEdgeGeometry Class


BRepBuilderGeometryId Members

[image] [image]

Revit 2024 API
BRepBuilderGeometryId Members
BRepBuilderGeometryId Class Constructors Methods Properties See Also Send Feedback

The BRepBuilderGeometryId type exposes the following members.

Constructors

 | Name | Description
Public method | BRepBuilderGeometryId | Copy constructor

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the BRepBuilderGeometryId
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | InvalidGeometryId | Returns an invalid BRepBuilderGeometryId, used as a return value to indicate an error.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

BRepBuilderGeometryId Class


BRepBuilderGeometryId Constructor

[image]

Revit 2024 API
BRepBuilderGeometryId Constructor
BRepBuilderGeometryId Class See Also Send Feedback
Copy constructor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public BRepBuilderGeometryId(
    BRepBuilderGeometryId other
)
Visual Basic
Public Sub New ( _
    other As BRepBuilderGeometryId _
)
Visual C++
public:
BRepBuilderGeometryId(
    BRepBuilderGeometryId^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..BRepBuilderGeometryId

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

BRepBuilderGeometryId Class


Dispose Method

[image]

Revit 2024 API
BRepBuilderGeometryId..::..Dispose Method
BRepBuilderGeometryId Class See Also Send Feedback
Releases all resources used by the BRepBuilderGeometryId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

BRepBuilderGeometryId Class


InvalidGeometryId Method

[image]

Revit 2024 API
BRepBuilderGeometryId..::..InvalidGeometryId Method
BRepBuilderGeometryId Class See Also Send Feedback
Returns an invalid BRepBuilderGeometryId, used as a return value to indicate an error.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public static BRepBuilderGeometryId InvalidGeometryId()
Visual Basic
Public Shared Function InvalidGeometryId As BRepBuilderGeometryId
Visual C++
public:
static BRepBuilderGeometryId^ InvalidGeometryId()

See Also

BRepBuilderGeometryId Class


BRepBuilderGeometryId Properties

[image] [image]

Revit 2024 API
BRepBuilderGeometryId Properties
BRepBuilderGeometryId Class See Also Send Feedback

The BRepBuilderGeometryId type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

BRepBuilderGeometryId Class


BRepBuilderPersistentIds Class

[image]

Revit 2024 API
BRepBuilderPersistentIds Class
Members See Also Send Feedback
This class stores a map from ExternalGeometryIds to BRepBuilderGeometryIds.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public class BRepBuilderPersistentIds : IDisposable
Visual Basic
Public Class BRepBuilderPersistentIds _
    Implements IDisposable
Visual C++
public ref class BRepBuilderPersistentIds : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BRepBuilderPersistentIds

See Also

BRepBuilderPersistentIds Members


BRepBuilderPersistentIds Members

[image] [image]

Revit 2024 API
BRepBuilderPersistentIds Members
BRepBuilderPersistentIds Class Constructors Methods Properties See Also Send Feedback

The BRepBuilderPersistentIds type exposes the following members.

Constructors

 | Name | Description
Public method | BRepBuilderPersistentIds | Constructs a new BRepBuilderPersistentIds and associates the existing BRepBuilder to it.

Methods

 | Name | Description
Public method | AddSubTag | Adds a correspondence between an ExternalGeometryId and a BRepBuilderGeometryId. Note that an existing correspondence in the map cannot be updated and that a particular BRepBuilderGeometryId may be related to at most one ExternalGeometryId.
Public method | Dispose | Releases all resources used by the BRepBuilderPersistentIds
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAssociatedBRepBuilderValid | Validates the associated (in the constructor) BRepBuilder for this BRepBuilderPersistentIds.
Public method | IsBRepBuilderGeometryIdFaceOrEdge | Validates the input BRepBuilderGeometryId that will be used to create a correspondence. In order to be valid, the input BRepBuilderGeometryId must represent the ID of either a Face or an Edge.
Public method | IsValidBRepBuilderGeometryIdForNewCorrespondence | Validates the input BRepBuilderGeometryId that will be used to create a correspondence. In order to be valid, a correspondence for the input BRepBuilderGeometryId must not already exist.
Public method | IsValidExternalGeometryIdForNewCorrespondence | Validates the input ExternalGeometryId that will be used to create a correspondence. In order to be valid, a correspondence for the input ExternalGeometryId must not already exist.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

BRepBuilderPersistentIds Class


BRepBuilderPersistentIds Constructor

[image]

Revit 2024 API
BRepBuilderPersistentIds Constructor
BRepBuilderPersistentIds Class See Also Send Feedback
Constructs a new BRepBuilderPersistentIds and associates the existing BRepBuilder to it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public BRepBuilderPersistentIds(
    BRepBuilder bRepBuilder
)
Visual Basic
Public Sub New ( _
    bRepBuilder As BRepBuilder _
)
Visual C++
public:
BRepBuilderPersistentIds(
    BRepBuilder^ bRepBuilder
)

Parameters

bRepBuilder
Type: Autodesk.Revit.DB..::..BRepBuilder
The existing BRepBuilder.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

BRepBuilderPersistentIds Class


BRepBuilderPersistentIds Methods

[image] [image]

Revit 2024 API
BRepBuilderPersistentIds Methods
BRepBuilderPersistentIds Class See Also Send Feedback

The BRepBuilderPersistentIds type exposes the following members.

Methods

 | Name | Description
Public method | AddSubTag | Adds a correspondence between an ExternalGeometryId and a BRepBuilderGeometryId. Note that an existing correspondence in the map cannot be updated and that a particular BRepBuilderGeometryId may be related to at most one ExternalGeometryId.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAssociatedBRepBuilderValid | Validates the associated (in the constructor) BRepBuilder for this BRepBuilderPersistentIds.
Public method | IsBRepBuilderGeometryIdFaceOrEdge | Validates the input BRepBuilderGeometryId that will be used to create a correspondence. In order to be valid, the input BRepBuilderGeometryId must represent the ID of either a Face or an Edge.
Public method | IsValidBRepBuilderGeometryIdForNewCorrespondence | Validates the input BRepBuilderGeometryId that will be used to create a correspondence. In order to be valid, a correspondence for the input BRepBuilderGeometryId must not already exist.
Public method | IsValidExternalGeometryIdForNewCorrespondence | Validates the input ExternalGeometryId that will be used to create a correspondence. In order to be valid, a correspondence for the input ExternalGeometryId must not already exist.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BRepBuilderPersistentIds Class


AddSubTag Method

[image]

Revit 2024 API
BRepBuilderPersistentIds..::..AddSubTag Method
BRepBuilderPersistentIds Class See Also Send Feedback
Adds a correspondence between an ExternalGeometryId and a BRepBuilderGeometryId. Note that an existing correspondence in the map cannot be updated and that a particular BRepBuilderGeometryId may be related to at most one ExternalGeometryId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public void AddSubTag(
    ExternalGeometryId externalGeometryId,
    BRepBuilderGeometryId brepBuilderGeometryId
)
Visual Basic
Public Sub AddSubTag ( _
    externalGeometryId As ExternalGeometryId, _
    brepBuilderGeometryId As BRepBuilderGeometryId _
)
Visual C++
public:
void AddSubTag(
    ExternalGeometryId^ externalGeometryId,
    BRepBuilderGeometryId^ brepBuilderGeometryId
)

Parameters

externalGeometryId
Type: Autodesk.Revit.DB..::..ExternalGeometryId
An external geometry object Id.
brepBuilderGeometryId
Type: Autodesk.Revit.DB..::..BRepBuilderGeometryId
A BRepBuilder geometry object Id. It must represent the ID of either a Face or an Edge.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | externalGeometryId cannot be used to create a new correspondence because it is already used. -or- brepBuilderGeometryId cannot be used to create a new correspondence because it is already used. -or- brepBuilderGeometryId cannot be used to create a new correspondence because it doesn't represent the ID of either a Face or an Edge.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The associated BRepBuilder doesn't exist or is not valid (has no Faces and no Edges).

See Also

BRepBuilderPersistentIds Class


Dispose Method

[image]

Revit 2024 API
BRepBuilderPersistentIds..::..Dispose Method
BRepBuilderPersistentIds Class See Also Send Feedback
Releases all resources used by the BRepBuilderPersistentIds

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

BRepBuilderPersistentIds Class


IsAssociatedBRepBuilderValid Method

[image]

Revit 2024 API
BRepBuilderPersistentIds..::..IsAssociatedBRepBuilderValid Method
BRepBuilderPersistentIds Class See Also Send Feedback
Validates the associated (in the constructor) BRepBuilder for this BRepBuilderPersistentIds.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public bool IsAssociatedBRepBuilderValid()
Visual Basic
Public Function IsAssociatedBRepBuilderValid As Boolean
Visual C++
public:
bool IsAssociatedBRepBuilderValid()

Return Value

True if the associated BRepBuilder exists, false otherwise.

See Also

BRepBuilderPersistentIds Class


IsBRepBuilderGeometryIdFaceOrEdge Method

[image]

Revit 2024 API
BRepBuilderPersistentIds..::..IsBRepBuilderGeometryIdFaceOrEdge Method
BRepBuilderPersistentIds Class See Also Send Feedback
Validates the input BRepBuilderGeometryId that will be used to create a correspondence. In order to be valid, the input BRepBuilderGeometryId must represent the ID of either a Face or an Edge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public bool IsBRepBuilderGeometryIdFaceOrEdge(
    BRepBuilderGeometryId brepBuilderGeometryId
)
Visual Basic
Public Function IsBRepBuilderGeometryIdFaceOrEdge ( _
    brepBuilderGeometryId As BRepBuilderGeometryId _
) As Boolean
Visual C++
public:
bool IsBRepBuilderGeometryIdFaceOrEdge(
    BRepBuilderGeometryId^ brepBuilderGeometryId
)

Parameters

brepBuilderGeometryId
Type: Autodesk.Revit.DB..::..BRepBuilderGeometryId
The BRepBuilderGeometryId to be used in a new correspondence.

Return Value

True if the input BRepBuilderGeometryId represents the ID of either a Face or an Edge, false otherwise.

Remarks

This method returns false also in the case when the associated BRepBuilder is not valid. Call IsAssociatedBRepBuilderValid()()()() to check the associated BRepBuilder.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

BRepBuilderPersistentIds Class


IsValidBRepBuilderGeometryIdForNewCorrespondence Method

[image]

Revit 2024 API
BRepBuilderPersistentIds..::..IsValidBRepBuilderGeometryIdForNewCorrespondence Method
BRepBuilderPersistentIds Class See Also Send Feedback
Validates the input BRepBuilderGeometryId that will be used to create a correspondence. In order to be valid, a correspondence for the input BRepBuilderGeometryId must not already exist.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public bool IsValidBRepBuilderGeometryIdForNewCorrespondence(
    BRepBuilderGeometryId brepBuilderGeometryId
)
Visual Basic
Public Function IsValidBRepBuilderGeometryIdForNewCorrespondence ( _
    brepBuilderGeometryId As BRepBuilderGeometryId _
) As Boolean
Visual C++
public:
bool IsValidBRepBuilderGeometryIdForNewCorrespondence(
    BRepBuilderGeometryId^ brepBuilderGeometryId
)

Parameters

brepBuilderGeometryId
Type: Autodesk.Revit.DB..::..BRepBuilderGeometryId
The BRepBuilderGeometryId to be used in a new correspondence.

Return Value

True if the input BRepBuilderGeometryId can be used to create a new correspondence.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

BRepBuilderPersistentIds Class


IsValidExternalGeometryIdForNewCorrespondence Method

[image]

Revit 2024 API
BRepBuilderPersistentIds..::..IsValidExternalGeometryIdForNewCorrespondence Method
BRepBuilderPersistentIds Class See Also Send Feedback
Validates the input ExternalGeometryId that will be used to create a correspondence. In order to be valid, a correspondence for the input ExternalGeometryId must not already exist.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public bool IsValidExternalGeometryIdForNewCorrespondence(
    ExternalGeometryId externalGeometryId
)
Visual Basic
Public Function IsValidExternalGeometryIdForNewCorrespondence ( _
    externalGeometryId As ExternalGeometryId _
) As Boolean
Visual C++
public:
bool IsValidExternalGeometryIdForNewCorrespondence(
    ExternalGeometryId^ externalGeometryId
)

Parameters

externalGeometryId
Type: Autodesk.Revit.DB..::..ExternalGeometryId
The ExternalGeometryId to be used in a new correspondence.

Return Value

True if the input ExternalGeometryId can be used to create a new correspondence.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

BRepBuilderPersistentIds Class


BRepBuilderPersistentIds Properties

[image] [image]

Revit 2024 API
BRepBuilderPersistentIds Properties
BRepBuilderPersistentIds Class See Also Send Feedback

The BRepBuilderPersistentIds type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

BRepBuilderPersistentIds Class


BRepBuilderSurfaceGeometry Class

[image]

Revit 2024 API
BRepBuilderSurfaceGeometry Class
Members See Also Send Feedback
An abstract class used by BRepBuilder to represent the geometry of a surface. Specific surface-geometry representations are represented by subclasses.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public class BRepBuilderSurfaceGeometry : IDisposable
Visual Basic
Public Class BRepBuilderSurfaceGeometry _
    Implements IDisposable
Visual C++
public ref class BRepBuilderSurfaceGeometry : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BRepBuilderSurfaceGeometry

See Also

BRepBuilderSurfaceGeometry Members


BRepBuilderSurfaceGeometry Members

[image] [image]

Revit 2024 API
BRepBuilderSurfaceGeometry Members
BRepBuilderSurfaceGeometry Class Methods Properties See Also Send Feedback

The BRepBuilderSurfaceGeometry type exposes the following members.

Methods

 | Name | Description
 | Create | Construct BRepBuilderSurfaceGeometry based on a permitted Revit Surface, including Plane and CylSurf.
 | CreateNURBSSurface(Int32, Int32, IList<(Of <<'(Double>)>>), IList<(Of <<'(Double>)>>), IList<(Of <<'(XYZ>)>>), Boolean, BoundingBoxUV) | Construct a BRepBuilderSurfaceGeometry based on NURBS surface data, where the weights are not supplied. In this case, the NURBS surface will be a piecewise polynomial surface.
 | CreateNURBSSurface(Int32, Int32, IList<(Of <<'(Double>)>>), IList<(Of <<'(Double>)>>), IList<(Of <<'(XYZ>)>>), IList<(Of <<'(Double>)>>), Boolean, BoundingBoxUV) | Construct BRepBuilderSurfaceGeometry based on NURBS surface data, where the weights are supplied. In this case, the NURBS surface will be a piecewise rational polynomial surface.
Public method | Dispose | Releases all resources used by the BRepBuilderSurfaceGeometry
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

BRepBuilderSurfaceGeometry Class


BRepBuilderSurfaceGeometry Methods

[image] [image]

Revit 2024 API
BRepBuilderSurfaceGeometry Methods
BRepBuilderSurfaceGeometry Class See Also Send Feedback

The BRepBuilderSurfaceGeometry type exposes the following members.

Methods

 | Name | Description
 | Create | Construct BRepBuilderSurfaceGeometry based on a permitted Revit Surface, including Plane and CylSurf.
 | CreateNURBSSurface(Int32, Int32, IList<(Of <<'(Double>)>>), IList<(Of <<'(Double>)>>), IList<(Of <<'(XYZ>)>>), Boolean, BoundingBoxUV) | Construct a BRepBuilderSurfaceGeometry based on NURBS surface data, where the weights are not supplied. In this case, the NURBS surface will be a piecewise polynomial surface.
 | CreateNURBSSurface(Int32, Int32, IList<(Of <<'(Double>)>>), IList<(Of <<'(Double>)>>), IList<(Of <<'(XYZ>)>>), IList<(Of <<'(Double>)>>), Boolean, BoundingBoxUV) | Construct BRepBuilderSurfaceGeometry based on NURBS surface data, where the weights are supplied. In this case, the NURBS surface will be a piecewise rational polynomial surface.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BRepBuilderSurfaceGeometry Class


Create Method

[image]

Revit 2024 API
BRepBuilderSurfaceGeometry..::..Create Method
BRepBuilderSurfaceGeometry Class See Also Send Feedback
Construct BRepBuilderSurfaceGeometry based on a permitted Revit Surface, including Plane and CylSurf.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public static BRepBuilderSurfaceGeometry Create(
    Surface surface,
    BoundingBoxUV surfaceEnvelope
)
Visual Basic
Public Shared Function Create ( _
    surface As Surface, _
    surfaceEnvelope As BoundingBoxUV _
) As BRepBuilderSurfaceGeometry
Visual C++
public:
static BRepBuilderSurfaceGeometry^ Create(
    Surface^ surface,
    BoundingBoxUV^ surfaceEnvelope
)

Parameters

surface
Type: Autodesk.Revit.DB..::..Surface
The Revit surface defining the geometry. This BRepBuilderSurfaceGeometry stores a copy of the input surface.
surfaceEnvelope
Type: Autodesk.Revit.DB..::..BoundingBoxUV
Envelope of the surface in the uv parametric domain. Defines the domain of interest for the created surface. This is typically used to identify the domain of the face that references the surface in question. Expected to either be null or define a valid domain.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | A surface of this type can not be used as a part of the geometry generated by BRepBuilder.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

BRepBuilderSurfaceGeometry Class


CreateNURBSSurface Method

[image] [image]

Revit 2024 API
BRepBuilderSurfaceGeometry..::..CreateNURBSSurface Method
BRepBuilderSurfaceGeometry Class See Also Send Feedback

Overload List

Name | Description
CreateNURBSSurface(Int32, Int32, IList<(Of <<'(Double>)>>), IList<(Of <<'(Double>)>>), IList<(Of <<'(XYZ>)>>), Boolean, BoundingBoxUV) | Construct a BRepBuilderSurfaceGeometry based on NURBS surface data, where the weights are not supplied. In this case, the NURBS surface will be a piecewise polynomial surface.
CreateNURBSSurface(Int32, Int32, IList<(Of <<'(Double>)>>), IList<(Of <<'(Double>)>>), IList<(Of <<'(XYZ>)>>), IList<(Of <<'(Double>)>>), Boolean, BoundingBoxUV) | Construct BRepBuilderSurfaceGeometry based on NURBS surface data, where the weights are supplied. In this case, the NURBS surface will be a piecewise rational polynomial surface.

See Also

BRepBuilderSurfaceGeometry Class
BRepBuilderSurfaceGeometry Members


CreateNURBSSurface Method (Int32, Int32, IList(Double), IList(Double), IList(XYZ), Boolean, BoundingBoxUV)

[image]

Revit 2024 API
BRepBuilderSurfaceGeometry..::..CreateNURBSSurface Method (Int32, Int32, IList<(Of <(<'Double>)>)>, IList<(Of <(<'Double>)>)>, IList<(Of <(<'XYZ>)>)>, Boolean, BoundingBoxUV)
BRepBuilderSurfaceGeometry Class See Also Send Feedback
Construct a BRepBuilderSurfaceGeometry based on NURBS surface data, where the weights are not supplied. In this case, the NURBS surface will be a piecewise polynomial surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017_subscription_update

Syntax

C#
public static BRepBuilderSurfaceGeometry CreateNURBSSurface(
    int degreeU,
    int degreeV,
    IList<double> knotsU,
    IList<double> knotsV,
    IList<XYZ> controlPoints,
    bool bReverseOrientation,
    BoundingBoxUV surfaceEnvelope
)
Visual Basic
Public Shared Function CreateNURBSSurface ( _
    degreeU As Integer, _
    degreeV As Integer, _
    knotsU As IList(Of Double), _
    knotsV As IList(Of Double), _
    controlPoints As IList(Of XYZ), _
    bReverseOrientation As Boolean, _
    surfaceEnvelope As BoundingBoxUV _
) As BRepBuilderSurfaceGeometry
Visual C++
public:
static BRepBuilderSurfaceGeometry^ CreateNURBSSurface(
    int degreeU,
    int degreeV,
    IList<double>^ knotsU,
    IList<double>^ knotsV,
    IList<XYZ^>^ controlPoints,
    bool bReverseOrientation,
    BoundingBoxUV^ surfaceEnvelope
)

Parameters

degreeU
Type: System..::..Int32
The degree of the spline in the u-direction; must be positive.
degreeV
Type: System..::..Int32
The degree of the spline in the v-direction; must be positive.
knotsU
Type: System.Collections.Generic..::..IList<(Of <(<'Double>)>)>
Knot values in the u-direction. The number of knots in the u-direction must be at least 2 * (degreeU + 1).
knotsV
Type: System.Collections.Generic..::..IList<(Of <(<'Double>)>)>
Knot values in the v-direction. The number of knots in the v-direction must be at least 2 * (degreeV + 1).
controlPoints
Type: System.Collections.Generic..::..IList<(Of <(<' XYZ >)>)>
One dimensional array of points representing the two dimensional net of control points of the NURBS surface in u and v directions.

The total number of control points must equal numControlPtsU times numControlPtsV, where numControlPtsU and numControlPtsV are the numbers of control points in u and v directions, and they must satisfy the following conditions:

  • numControlPtsU = number of knots in u - degreeU - 1.
  • numControlPtsV = number of knots in v - degreeV - 1.
The convention for 2d (idxU, idxV) to 1d (idx) conversion of array indexes: idxV first. That is, idxU is outer loop and idxV is inner loop. In other words, idx = idxU * numControlPtsV + idxV.

bReverseOrientation
Type: System..::..Boolean
If true, the surface's orientation is opposite to the canonical parametric orientation, otherwise it is the same. The canonical parametric orientation is a counter-clockwise sense of rotation in the uv-parameter plane. Extrinsically, the oriented normal vector for the canonical parametric orientation points in the direction of the cross product dS/du x dS/dv, which S(u, v) is the parameterized surface.
surfaceEnvelope
Type: Autodesk.Revit.DB..::..BoundingBoxUV
Envelope of the surface in the uv parametric domain. Defines the domain of interest for the created surface. This is typically used to identify the domain of the face that references the surface in question. Expected to either be null or define a valid domain.

Remarks

This function does not handle periodic Nurbs surfaces.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The U-degree value must be at least 1. -or- The V-degree value must be at least 1. -or- The number of knots in the U direction must be at least 2 * (U-degree + 1). -or- The number of knots in the V direction must be at least 2 * (V-degree + 1). -or- The number of control points must equal (number of U-knots - U-degree - 1) * (number of V-knots - V-degree - 1). -or- The input data does not define a valid Nurbs surface.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The Nurbs surface could not be converted for use in Revit. It may have C2-discontinuities or be too large.

See Also

BRepBuilderSurfaceGeometry Class
CreateNURBSSurface Overload


CreateNURBSSurface Method (Int32, Int32, IList(Double), IList(Double), IList(XYZ), IList(Double), Boolean, BoundingBoxUV)

[image]

Revit 2024 API
BRepBuilderSurfaceGeometry..::..CreateNURBSSurface Method (Int32, Int32, IList<(Of <(<'Double>)>)>, IList<(Of <(<'Double>)>)>, IList<(Of <(<'XYZ>)>)>, IList<(Of <(<'Double>)>)>, Boolean, BoundingBoxUV)
BRepBuilderSurfaceGeometry Class See Also Send Feedback
Construct BRepBuilderSurfaceGeometry based on NURBS surface data, where the weights are supplied. In this case, the NURBS surface will be a piecewise rational polynomial surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public static BRepBuilderSurfaceGeometry CreateNURBSSurface(
    int degreeU,
    int degreeV,
    IList<double> knotsU,
    IList<double> knotsV,
    IList<XYZ> controlPoints,
    IList<double> weights,
    bool bReverseOrientation,
    BoundingBoxUV surfaceEnvelope
)
Visual Basic
Public Shared Function CreateNURBSSurface ( _
    degreeU As Integer, _
    degreeV As Integer, _
    knotsU As IList(Of Double), _
    knotsV As IList(Of Double), _
    controlPoints As IList(Of XYZ), _
    weights As IList(Of Double), _
    bReverseOrientation As Boolean, _
    surfaceEnvelope As BoundingBoxUV _
) As BRepBuilderSurfaceGeometry
Visual C++
public:
static BRepBuilderSurfaceGeometry^ CreateNURBSSurface(
    int degreeU,
    int degreeV,
    IList<double>^ knotsU,
    IList<double>^ knotsV,
    IList<XYZ^>^ controlPoints,
    IList<double>^ weights,
    bool bReverseOrientation,
    BoundingBoxUV^ surfaceEnvelope
)

Parameters

degreeU
Type: System..::..Int32
The degree of the spline in the u-direction; must be positive.
degreeV
Type: System..::..Int32
The degree of the spline in the v-direction; must be positive.
knotsU
Type: System.Collections.Generic..::..IList<(Of <(<'Double>)>)>
Knot values in the u-direction. The number of knots in the u-direction must be at least 2 * (degreeU + 1).
knotsV
Type: System.Collections.Generic..::..IList<(Of <(<'Double>)>)>
Knot values in the v-direction. The number of knots in the v-direction must be at least 2 * (degreeV + 1).
controlPoints
Type: System.Collections.Generic..::..IList<(Of <(<' XYZ >)>)>
One dimensional array of points representing the two dimensional net of control points of the NURBS surface in u and v directions.

The total number of control points must equal numControlPtsU times numControlPtsV, where numControlPtsU and numControlPtsV are the numbers of control points in u and v directions, and they must satisfy the following conditions:

  • numControlPtsU = number of knots in u - degreeU - 1.
  • numControlPtsV = number of knots in v - degreeV - 1.
The convention for 2d (idxU, idxV) to 1d (idx) conversion of array indexes: idxV first. That is, idxU is outer loop and idxV is inner loop. In other words, idx = idxU * numControlPtsV + idxV.

weights
Type: System.Collections.Generic..::..IList<(Of <(<'Double>)>)>
Array of weights assigned to the control points. The number of weights must equal the number of control points. All weights should be greater than zero.
bReverseOrientation
Type: System..::..Boolean
If true, the surface's orientation is opposite to the canonical parametric orientation, otherwise it is the same. The canonical parametric orientation is a counter-clockwise sense of rotation in the uv-parameter plane. Extrinsically, the oriented normal vector for the canonical parametric orientation points in the direction of the cross product dS/du x dS/dv, which S(u, v) is the parameterized surface.
surfaceEnvelope
Type: Autodesk.Revit.DB..::..BoundingBoxUV
Envelope of the surface in the uv parametric domain. Defines the domain of interest for the created surface. This is typically used to identify the domain of the face that references the surface in question. Expected to either be null or define a valid domain.

Remarks

A rational polynomial is a quotient of two polynomials; this includes a polynomial, which can be thought of as a quotient with denominator equal to 1. If all the weights are equal, then the NURBS surface will be a piecewise polynomial surface.This class does not handle periodic Nurbs surfaces.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The U-degree value must be at least 1. -or- The V-degree value must be at least 1. -or- The number of knots in the U direction must be at least 2 times the U-degree plus 1. -or- The number of knots in the V direction must be at least 2 times the V-degree plus 1. -or- The number of control points must equal (number of U-knots - U-degree - 1) * (number of V-knots - V-degree - 1). -or- The number of weights must be the same as the number of control points and all weights must be positive or all zero. -or- The input data does not define a valid Nurbs surface.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The Nurbs surface could not be converted for use in Revit. It may have C2-discontinuities or be too large.

See Also

BRepBuilderSurfaceGeometry Class
CreateNURBSSurface Overload


Dispose Method

[image]

Revit 2024 API
BRepBuilderSurfaceGeometry..::..Dispose Method
BRepBuilderSurfaceGeometry Class See Also Send Feedback
Releases all resources used by the BRepBuilderSurfaceGeometry

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

BRepBuilderSurfaceGeometry Class


BRepBuilderSurfaceGeometry Properties

[image] [image]

Revit 2024 API
BRepBuilderSurfaceGeometry Properties
BRepBuilderSurfaceGeometry Class See Also Send Feedback

The BRepBuilderSurfaceGeometry type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

BRepBuilderSurfaceGeometry Class


IsValidObject Property

[image]

Revit 2024 API
BRepBuilderSurfaceGeometry..::..IsValidObject Property
BRepBuilderSurfaceGeometry Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

BRepBuilderSurfaceGeometry Class


BRepType Enumeration

[image]

Revit 2024 API
BRepType Enumeration
See Also Send Feedback
This class defines an enumerative type used to specify the type of output geometry expected from a BRepBuilder.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016
Since: 2016

Syntax

C#
public enum BRepType
Visual Basic
Public Enumeration BRepType
Visual C++
public enum class BRepType

Members

Member name | Description
OpenShell | The output geometry is expected to represent an open shell.
Solid | The output geometry is expected to represent a (possibly disconnected) solid.
Void | The output geometry is expected to represent a (possibly disconnected) void (i.e., an inverted solid).

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


BrowserOrganization Class

[image]

Revit 2024 API
BrowserOrganization Class
Members See Also Send Feedback
The organization settings for grouping, sorting, and filtering of items in the project browser.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public class BrowserOrganization : ElementType
Visual Basic
Public Class BrowserOrganization _
    Inherits ElementType
Visual C++
public ref class BrowserOrganization : public ElementType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..BrowserOrganization

See Also

BrowserOrganization Members


BrowserOrganization Methods

[image] [image]

Revit 2024 API
BrowserOrganization Methods
BrowserOrganization Class See Also Send Feedback

The BrowserOrganization type exposes the following members.

Methods

 | Name | Description
Public method | AreFiltersSatisfied | Determines if the given element satisfies the filters defined by the browser organization.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
 | GetCurrentBrowserOrganizationForSchedules | Gets the BrowserOrganization that applies to the Schedules section of the project browser.
 | GetCurrentBrowserOrganizationForSheets | Gets the BrowserOrganization that applies to the Sheets section of the project browser.
 | GetCurrentBrowserOrganizationForViews | Gets the BrowserOrganization that applies to the Views section of the project browser.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetFolderItems | Returns a collection of leaf FolderItemInfo objects each containing the given element Id.
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BrowserOrganization Class


AreFiltersSatisfied Method

[image]

Revit 2024 API
BrowserOrganization..::..AreFiltersSatisfied Method
BrowserOrganization Class See Also Send Feedback
Determines if the given element satisfies the filters defined by the browser organization.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool AreFiltersSatisfied(
    ElementId elementId
)
Visual Basic
Public Function AreFiltersSatisfied ( _
    elementId As ElementId _
) As Boolean
Visual C++
public:
bool AreFiltersSatisfied(
    ElementId^ elementId
)

Parameters

elementId
Type: Autodesk.Revit.DB..::..ElementId
The element to check.

Return Value

True if the given element satisfies the filter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | elementId is not a valid Element identifier.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

BrowserOrganization Class


GetCurrentBrowserOrganizationForSchedules Method

[image]

Revit 2024 API
BrowserOrganization..::..GetCurrentBrowserOrganizationForSchedules Method
BrowserOrganization Class See Also Send Feedback
Gets the BrowserOrganization that applies to the Schedules section of the project browser.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018.1

Syntax

C#
public static BrowserOrganization GetCurrentBrowserOrganizationForSchedules(
    Document document
)
Visual Basic
Public Shared Function GetCurrentBrowserOrganizationForSchedules ( _
    document As Document _
) As BrowserOrganization
Visual C++
public:
static BrowserOrganization^ GetCurrentBrowserOrganizationForSchedules(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Revit document from which to get the organization data.

Return Value

The BrowserOrganization for schedules, or null if no schedules sections exist

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

BrowserOrganization Class


GetCurrentBrowserOrganizationForSheets Method

[image]

Revit 2024 API
BrowserOrganization..::..GetCurrentBrowserOrganizationForSheets Method
BrowserOrganization Class See Also Send Feedback
Gets the BrowserOrganization that applies to the Sheets section of the project browser.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static BrowserOrganization GetCurrentBrowserOrganizationForSheets(
    Document document
)
Visual Basic
Public Shared Function GetCurrentBrowserOrganizationForSheets ( _
    document As Document _
) As BrowserOrganization
Visual C++
public:
static BrowserOrganization^ GetCurrentBrowserOrganizationForSheets(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Revit document from which to get the organization data.

Return Value

The BrowserOrganization for sheets, or null if no sheets exist.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

BrowserOrganization Class


GetCurrentBrowserOrganizationForViews Method

[image]

Revit 2024 API
BrowserOrganization..::..GetCurrentBrowserOrganizationForViews Method
BrowserOrganization Class See Also Send Feedback
Gets the BrowserOrganization that applies to the Views section of the project browser.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static BrowserOrganization GetCurrentBrowserOrganizationForViews(
    Document document
)
Visual Basic
Public Shared Function GetCurrentBrowserOrganizationForViews ( _
    document As Document _
) As BrowserOrganization
Visual C++
public:
static BrowserOrganization^ GetCurrentBrowserOrganizationForViews(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Revit document from which to get the organization data.

Return Value

The BrowserOrganization for views, or null if no view sections exist

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

BrowserOrganization Class


GetFolderItems Method

[image]

Revit 2024 API
BrowserOrganization..::..GetFolderItems Method
BrowserOrganization Class See Also Send Feedback
Returns a collection of leaf FolderItemInfo objects each containing the given element Id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public IList<FolderItemInfo> GetFolderItems(
    ElementId elementId
)
Visual Basic
Public Function GetFolderItems ( _
    elementId As ElementId _
) As IList(Of FolderItemInfo)
Visual C++
public:
IList<FolderItemInfo^>^ GetFolderItems(
    ElementId^ elementId
)

Parameters

elementId
Type: Autodesk.Revit.DB..::..ElementId
Element id located at a leaf position in the project browser.

Return Value

An array of FolderItemInfo objects.

Remarks

Each returned FolderItemInfo includes the folder name and the corresponding folder parameter Id.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | elementId is not a valid Element identifier.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

BrowserOrganization Class


BrowserOrganization Properties

[image] [image]

Revit 2024 API
BrowserOrganization Properties
BrowserOrganization Class See Also Send Feedback

The BrowserOrganization type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SortingOrder | The sorting order if sorting of items is applicable in the browser.
Public property | SortingParameterId | The Id of the parameter used to determine the sorting order of items in the browser.
Public property | Type | Get BrowserOrganizationType.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

BrowserOrganization Class


Parameter Property

[image] [image]

Revit 2024 API
BrowserOrganization..::..Parameter Property
BrowserOrganization Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

BrowserOrganization Class
BrowserOrganization Members


SortingOrder Property

[image]

Revit 2024 API
BrowserOrganization..::..SortingOrder Property
BrowserOrganization Class See Also Send Feedback
The sorting order if sorting of items is applicable in the browser.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public SortingOrder SortingOrder { get; }
Visual Basic
Public ReadOnly Property SortingOrder As SortingOrder
    Get
Visual C++
public:
property SortingOrder SortingOrder {
    SortingOrder get ();
}

See Also

BrowserOrganization Class


Type Property

[image]

Revit 2024 API
BrowserOrganization..::..Type Property
BrowserOrganization Class See Also Send Feedback
Get BrowserOrganizationType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public BrowserOrganizationType Type { get; }
Visual Basic
Public ReadOnly Property Type As BrowserOrganizationType
    Get
Visual C++
public:
property BrowserOrganizationType Type {
    BrowserOrganizationType get ();
}

See Also

BrowserOrganization Class


BrowserOrganizationType Enumeration

[image]

Revit 2024 API
BrowserOrganizationType Enumeration
See Also Send Feedback
Enumerated type representing the type of browser organization.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015
Since: 2015

Syntax

C#
public enum BrowserOrganizationType
Visual Basic
Public Enumeration BrowserOrganizationType
Visual C++
public enum class BrowserOrganizationType

Members

Member name | Description
Views | The browser organization definition for views.
Sheets | The browser organization definition for sheets.
Schedules | The browser organization definition for schedules.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


BuildingPadType Class

[image]

Revit 2024 API
BuildingPadType Class
Members See Also Send Feedback
Represents a specific type of Building Pad.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class BuildingPadType : HostObjAttributes
Visual Basic
Public Class BuildingPadType _
    Inherits HostObjAttributes
Visual C++
public ref class BuildingPadType : public HostObjAttributes

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..HostObjAttributes
Autodesk.Revit.DB..::..BuildingPadType

See Also

BuildingPadType Members


BuildingPadType Methods

[image] [image]

Revit 2024 API
BuildingPadType Methods
BuildingPadType Class See Also Send Feedback

The BuildingPadType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | CreateDefault | Creates a BuildingPadType element and adds it to the document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BuildingPadType Class


Parameter Property

[image] [image]

Revit 2024 API
BuildingPadType..::..Parameter Property
BuildingPadType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

BuildingPadType Class
BuildingPadType Members


ThermalProperties Property

[image]

Revit 2024 API
BuildingPadType..::..ThermalProperties Property
BuildingPadType Class See Also Send Feedback
The calculated and settable thermal properties of the BuildingPadType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ThermalProperties ThermalProperties { get; }
Visual Basic
Public ReadOnly Property ThermalProperties As ThermalProperties
    Get
Visual C++
public:
property ThermalProperties^ ThermalProperties {
    ThermalProperties^ get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | the building pad does not have thermal properties.

See Also

BuildingPadType Class


BuildingType Enumeration

[image]

Revit 2024 API
BuildingType Enumeration
See Also Send Feedback
This enumeration is used for specifying the most predominant building use type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum BuildingType
Visual Basic
Public Enumeration BuildingType
Visual C++
public enum class BuildingType

Members

Member name | Description
kNoOfBuildingTypes | Building Type is NoOfBuildingTypes.
kAutomotiveFacility | Building Type is AutomotiveFacility.
kConventionCenter | Building Type is ConventionCenter.
kCourthouse | Building Type is Courthouse.
kDiningBarLoungeOrLeisure | Building Type is DiningBarLoungeOrLeisure.
kDiningCafeteriaFastFood | Building Type is DiningCafeteriaFastFood.
kDiningFamily | Building Type is DiningFamily.
kDormitory | Building Type is Dormitory.
kExerciseCenter | Building Type is ExerciseCenter.
kFireStation | Building Type is FireStation.
kGymnasium | Building Type is Gymnasium.
kHospitalOrHealthcare | Building Type is HospitalOrHealthcare.
kHotel | Building Type is Hotel.
kLibrary | Building Type is Library.
kManufacturing | Building Type is Manufacturing.
kMotel | Building Type is Motel.
kMotionPictureTheatre | Building Type is MotionPictureTheatre.
kMultiFamily | Building Type is MultiFamily.
kMuseum | Building Type is Museum.
kOffice | Building Type is Office.
kParkingGarage | Building Type is ParkingGarage.
kPenitentiary | Building Type is Penitentiary.
kPerformingArtsTheater | Building Type is PerformingArtsTheater.
kPoliceStation | Building Type is PoliceStation.
kPostOffice | Building Type is PostOffice.
kReligiousBuilding | Building Type is ReligiousBuilding.
kRetail | Building Type is Retail.
kSchoolOrUniversity | Building Type is SchoolOrUniversity.
kSportsArena | Building Type is SportsArena.
kTownHall | Building Type is TownHall.
kTransportation | Building Type is Transportation.
kWarehouse | Building Type is Warehouse.
kWorkshop | Building Type is Workshop.

Remarks

This enumerated list corresponds to the buildingType attribute in the gbXML (Green Building XML) schema and is primarily used for energy analysis.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


BuiltInCategory Enumeration

[image]

Revit 2024 API
BuiltInCategory Enumeration
See Also Send Feedback
A list of all the built in categories within Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum BuiltInCategory
Visual Basic
Public Enumeration BuiltInCategory
Visual C++
public enum class BuiltInCategory

Members

Member name | Description
OST_StackedWalls_Obsolete_IdInWrongRange |
OST_MassTags_Obsolete_IdInWrongRange |
OST_MassSurface_Obsolete_IdInWrongRange |
OST_MassFloor_Obsolete_IdInWrongRange |
OST_Mass_Obsolete_IdInWrongRange |
OST_WallRefPlanes_Obsolete_IdInWrongRange |
OST_StickSymbols_Obsolete_IdInWrongRange |
OST_RemovedGridSeg_Obsolete_IdInWrongRange |
OST_PointClouds |
OST_AnalyticalPanelLocalCoordSys |
OST_AnalyticalMemberLocalCoordSys |
OST_AnalyticalOpening |
OST_AnalyticalPanel |
OST_AnalyticalMemberTags |
OST_AnalyticalMember |
OST_AssemblyOrigin_Lines |
OST_AssemblyOrigin_Planes |
OST_AssemblyOrigin_Points |
OST_AssemblyOrigin |
OST_LinksAnalytical |
OST_FoundationSlabAnalyticalTags |
OST_WallFoundationAnalyticalTags |
OST_IsolatedFoundationAnalyticalTags |
OST_WallAnalyticalTags |
OST_FloorAnalyticalTags |
OST_ColumnAnalyticalTags |
OST_BraceAnalyticalTags |
OST_BeamAnalyticalTags |
OST_AnalyticalNodes_Lines |
OST_AnalyticalNodes_Planes |
OST_AnalyticalNodes_Points |
OST_AnalyticalNodes |
OST_RigidLinksAnalytical |
OST_FoundationSlabAnalytical |
OST_WallFoundationAnalytical |
OST_IsolatedFoundationAnalytical |
OST_WallAnalytical |
OST_FloorAnalytical |
OST_ColumnEndSegment |
OST_ColumnStartSegment |
OST_ColumnAnalytical |
OST_BraceEndSegment |
OST_BraceStartSegment |
OST_BraceAnalytical |
OST_BeamEndSegment |
OST_BeamStartSegment |
OST_BeamAnalytical |
OST_CompassSecondaryMonth |
OST_CompassPrimaryMonth |
OST_CompassSectionFilled |
OST_LightLine |
OST_MultiSurface |
OST_SunSurface |
OST_Analemma |
OST_SunsetText |
OST_CompassSection |
OST_CompassOuter |
OST_SunriseText |
OST_CompassInner |
OST_SunPath2 |
OST_SunPath1 |
OST_Sun |
OST_SunStudy |
OST_StructuralTrussStickSymbols |
OST_StructuralTrussHiddenLines |
OST_TrussChord |
OST_TrussWeb |
OST_TrussBottomChordCurve |
OST_TrussTopChordCurve |
OST_TrussVertWebCurve |
OST_TrussDiagWebCurve |
OST_Truss |
OST_PlumbingEquipmentHiddenLines |
OST_MechanicalControlDevicesHiddenLines |
OST_RailingSystemTransitionHiddenLines_Deprecated |
OST_RailingSystemTerminationHiddenLines_Deprecated |
OST_RailingSystemRailHiddenLines_Deprecated |
OST_RailingSystemTopRailHiddenLines_Deprecated |
OST_RailingSystemHandRailBracketHiddenLines_Deprecated |
OST_RailingSystemHandRailHiddenLines_Deprecated |
OST_RailingSystemPanelBracketHiddenLines_Deprecated |
OST_RailingSystemPanelHiddenLines_Deprecated |
OST_RailingSystemBalusterHiddenLines_Deprecated |
OST_RailingSystemPostHiddenLines_Deprecated |
OST_RailingSystemSegmentHiddenLines_Deprecated |
OST_RailingSystemHiddenLines_Deprecated |
OST_StairStringer2012HiddenLines_Deprecated |
OST_StairTread2012HiddenLines_Deprecated |
OST_StairLanding2012HiddenLines_Deprecated |
OST_StairRun2012HiddenLines_Deprecated |
OST_Stairs2012HiddenLines_Deprecated |
OST_MassHiddenLines |
OST_CurtaSystemHiddenLines |
OST_OBSOLETE_ElemArrayHiddenLines |
OST_EntourageHiddenLines |
OST_PlantingHiddenLines |
OST_SpecialityEquipmentHiddenLines |
OST_TopographyHiddenLines |
OST_StructuralFramingSystemHiddenLines_Obsolete |
OST_SiteHiddenLines |
OST_RoadsHiddenLines |
OST_ParkingHiddenLines |
OST_PlumbingFixturesHiddenLines |
OST_MechanicalEquipmentHiddenLines |
OST_LightingFixturesHiddenLines |
OST_FurnitureSystemsHiddenLines |
OST_ElectricalFixturesHiddenLines |
OST_ElectricalEquipmentHiddenLines |
OST_CaseworkHiddenLines |
OST_DetailComponentsHiddenLines |
OST_ShaftOpeningHiddenLines |
OST_GenericModelHiddenLines |
OST_CurtainWallMullionsHiddenLines |
OST_CurtainWallPanelsHiddenLines |
OST_RampsHiddenLines |
OST_StairsRailingHiddenLines |
OST_StairsHiddenLines |
OST_ColumnsHiddenLines |
OST_FurnitureHiddenLines |
OST_LinesHiddenLines |
OST_CeilingsHiddenLines |
OST_RoofsHiddenLines |
OST_DoorsHiddenLines |
OST_WindowsHiddenLines |
OST_StructConnectionProfilesTags |
OST_StructConnectionHoleTags |
OST_CouplerHiddenLines |
OST_CouplerTags |
OST_Coupler |
OST_StructConnectionWeldTags |
OST_StructConnectionShearStudTags |
OST_StructConnectionAnchorTags |
OST_StructConnectionBoltTags |
OST_StructConnectionPlateTags |
OST_RebarHiddenLines |
OST_StructSubConnections |
OST_SteelElementStale |
OST_StructConnectionModifiers |
OST_StructConnectionWelds |
OST_StructConnectionHoles |
OST_StructConnectionShearStuds |
OST_StructConnectionNobleWarning |
OST_StructConnectionOthers |
OST_StructConnectionBolts |
OST_StructConnectionTags |
OST_StructConnectionAnchors |
OST_StructConnectionPlates |
OST_StructConnectionProfiles |
OST_StructConnectionReference |
OST_StructConnectionFailed |
OST_StructConnectionStale |
OST_StructConnectionSymbol |
OST_StructConnectionHiddenLines |
OST_StructWeldLines |
OST_StructConnections |
OST_FabricAreaBoundary |
OST_FabricReinSpanSymbol |
OST_FabricReinforcementWire |
OST_FabricReinforcementBoundary |
OST_RebarSetToggle |
OST_FabricAreaTags |
OST_FabricReinforcementTags |
OST_AreaReinTags |
OST_RebarTags |
OST_FabricAreaSketchSheetsLines |
OST_FabricAreaSketchEnvelopeLines |
OST_FabricAreas |
OST_FabricReinforcement |
OST_RebarCover |
OST_CoverType |
OST_RebarShape |
OST_PathReinBoundary |
OST_PathReinTags |
OST_PathReinSpanSymbol |
OST_PathRein |
OST_Cage |
OST_AreaReinXVisibility |
OST_AreaReinBoundary |
OST_AreaReinSpanSymbol |
OST_AreaReinSketchOverride |
OST_AreaRein |
OST_RebarLines |
OST_RebarSketchLines |
OST_Rebar |
OST_MEPAncillaryFramingTags |
OST_PlumbingEquipmentTags |
OST_PlumbingEquipment |
OST_MechanicalControlDeviceTags |
OST_MechanicalControlDevices |
OST_MEPAncillaryFraming |
OST_MEPAncillaries_Obsolete |
OST_FabricationDuctworkStiffenerTags |
OST_FabricationDuctworkStiffeners |
OST_ELECTRICAL_AreaBasedLoads_Reference_Visibility |
OST_ELECTRICAL_AreaBasedLoads_InteriorFill_Visibility |
OST_ELECTRICAL_AreaBasedLoads_ColorFill_Obsolete |
OST_ELECTRICAL_AreaBasedLoads_Reference |
OST_ELECTRICAL_AreaBasedLoads_InteriorFill |
OST_ELECTRICAL_AreaBasedLoads_Boundary |
OST_FabricationPipeworkInsulation |
OST_FabricationDuctworkLining |
OST_FabricationContainmentDrop |
OST_FabricationContainmentRise |
OST_FabricationPipeworkDrop |
OST_FabricationPipeworkRise |
OST_FabricationContainmentSymbology |
OST_FabricationContainmentCenterLine |
OST_FabricationContainmentTags |
OST_FabricationContainment |
OST_FabricationPipeworkSymbology |
OST_FabricationPipeworkCenterLine |
OST_FabricationPipeworkTags |
OST_FabricationPipework |
OST_FabricationDuctworkSymbology |
OST_FabricationDuctworkDrop |
OST_FabricationDuctworkRise |
OST_FabricationHangerTags |
OST_FabricationHangers |
OST_OBSOLETE_FabricationPartsTmpGraphicDropDrag |
OST_FabricationPartsTmpGraphicDrag |
OST_OBSOLETE_FabricationPartsTmpGraphicDrop |
OST_FabricationPartsTmpGraphicEnd |
OST_FabricationDuctworkInsulation |
OST_LayoutNodes |
OST_FabricationDuctworkCenterLine |
OST_FabricationServiceElements |
OST_FabricationDuctworkTags |
OST_FabricationDuctwork |
OST_LayoutPathBase_Pipings |
OST_NumberingSchemas |
OST_DivisionRules |
OST_gbXML_Shade |
OST_AnalyticSurfaces |
OST_AnalyticSpaces |
OST_gbXML_OpeningAir |
OST_gbXML_NonSlidingDoor |
OST_gbXML_SlidingDoor |
OST_gbXML_OperableSkylight |
OST_gbXML_FixedSkylight |
OST_gbXML_OperableWindow |
OST_gbXML_FixedWindow |
OST_gbXML_UndergroundCeiling |
OST_gbXML_UndergroundSlab |
OST_gbXML_UndergroundWall |
OST_gbXML_SurfaceAir |
OST_gbXML_Ceiling |
OST_gbXML_InteriorFloor |
OST_gbXML_InteriorWall |
OST_gbXML_SlabOnGrade |
OST_gbXML_RaisedFloor |
OST_gbXML_Roof |
OST_gbXML_ExteriorWall |
OST_DivisionProfile |
OST_SplitterProfile |
OST_PipeSegments |
OST_GraphicalWarning_OpenConnector |
OST_PlaceHolderPipes |
OST_PlaceHolderDucts |
OST_PipingSystem_Reference_Visibility |
OST_PipingSystem_Reference |
OST_DuctSystem_Reference_Visibility |
OST_DuctSystem_Reference |
OST_PipeInsulationsTags |
OST_DuctLiningsTags |
OST_DuctInsulationsTags |
OST_ElectricalInternalCircuits |
OST_PanelScheduleGraphics |
OST_CableTrayRun |
OST_ConduitRun |
OST_ParamElemElectricalLoadClassification |
OST_DataPanelScheduleTemplates |
OST_SwitchboardScheduleTemplates |
OST_BranchPanelScheduleTemplates |
OST_ConduitStandards |
OST_ElectricalLoadClassifications |
OST_ElectricalDemandFactorDefinitions |
OST_ConduitFittingCenterLine |
OST_CableTrayFittingCenterLine |
OST_ConduitCenterLine |
OST_ConduitDrop |
OST_ConduitRiseDrop |
OST_CableTrayCenterLine |
OST_CableTrayDrop |
OST_CableTrayRiseDrop |
OST_ConduitTags |
OST_Conduit |
OST_CableTrayTags |
OST_CableTray |
OST_ConduitFittingTags |
OST_ConduitFitting |
OST_CableTrayFittingTags |
OST_CableTrayFitting |
OST_RoutingPreferences |
OST_DuctLinings |
OST_DuctInsulations |
OST_PipeInsulations |
OST_HVAC_Load_Schedules |
OST_HVAC_Load_Building_Types |
OST_HVAC_Load_Space_Types |
OST_HVAC_Zones_Reference_Visibility |
OST_HVAC_Zones_InteriorFill_Visibility |
OST_HVAC_Zones_ColorFill |
OST_ZoneTags |
OST_LayoutPath_Bases |
OST_WireTemperatureRatings |
OST_WireInsulations |
OST_WireMaterials |
OST_HVAC_Zones_Reference |
OST_HVAC_Zones_InteriorFill |
OST_HVAC_Zones_Boundary |
OST_HVAC_Zones |
OST_Fluids |
OST_PipeSchedules |
OST_PipeMaterials |
OST_PipeConnections |
OST_EAConstructions |
OST_SwitchSystem |
OST_SprinklerTags |
OST_Sprinklers |
OST_RouteCurveBranch |
OST_RouteCurveMain |
OST_RouteCurve |
OST_GbXML_Opening |
OST_GbXML_SType_Underground |
OST_GbXML_SType_Shade |
OST_GbXML_SType_Exterior |
OST_GbXML_SType_Interior |
OST_GbXMLFaces |
OST_WireHomeRunArrows |
OST_LightingDeviceTags |
OST_LightingDevices |
OST_FireAlarmDeviceTags |
OST_FireAlarmDevices |
OST_DataDeviceTags |
OST_DataDevices |
OST_CommunicationDeviceTags |
OST_CommunicationDevices |
OST_SecurityDeviceTags |
OST_SecurityDevices |
OST_NurseCallDeviceTags |
OST_NurseCallDevices |
OST_TelephoneDeviceTags |
OST_TelephoneDevices |
OST_WireTickMarks |
OST_PipeFittingInsulation |
OST_PipeFittingCenterLine |
OST_FlexPipeCurvesInsulation |
OST_PipeCurvesInsulation |
OST_PipeCurvesDrop |
OST_DuctFittingLining |
OST_DuctFittingInsulation |
OST_DuctFittingCenterLine |
OST_FlexDuctCurvesInsulation |
OST_DuctCurvesLining |
OST_DuctCurvesInsulation |
OST_DuctCurvesDrop |
OST_DuctFittingTags |
OST_PipeFittingTags |
OST_PipeColorFills |
OST_PipeColorFillLegends |
OST_WireTags |
OST_PipeAccessoryTags |
OST_PipeAccessory |
OST_PipeCurvesRiseDrop |
OST_FlexPipeCurvesPattern |
OST_FlexPipeCurvesContour |
OST_FlexPipeCurvesCenterLine |
OST_FlexPipeCurves |
OST_PipeFitting |
OST_FlexPipeTags |
OST_PipeTags |
OST_PipeCurvesContour |
OST_PipeCurvesCenterLine |
OST_PipeCurves |
OST_PipingSystem |
OST_ElectricalDemandFactor |
OST_ElecDistributionSys |
OST_ElectricalVoltage |
OST_Wire |
OST_ElectricalCircuitTags |
OST_ElectricalCircuit |
OST_DuctCurvesRiseDrop |
OST_FlexDuctCurvesPattern |
OST_FlexDuctCurvesContour |
OST_FlexDuctCurvesCenterLine |
OST_FlexDuctCurves |
OST_DuctAccessoryTags |
OST_DuctAccessory |
OST_DuctSystem |
OST_DuctTerminalTags |
OST_DuctTerminal |
OST_DuctFitting |
OST_DuctColorFills |
OST_FlexDuctTags |
OST_DuctTags |
OST_DuctCurvesContour |
OST_DuctCurvesCenterLine |
OST_DuctCurves |
OST_DuctColorFillLegends |
OST_ConnectorElemZAxis |
OST_ConnectorElemYAxis |
OST_ConnectorElemXAxis |
OST_ConnectorElem |
OST_VibrationManagementTags |
OST_BridgeFramingTrussTags |
OST_BridgeFramingDiaphragmTags |
OST_BridgeFramingCrossBracingTags |
OST_StructuralTendonTags |
OST_StructuralTendonHiddenLines |
OST_StructuralTendons |
OST_ExpansionJointTags |
OST_ExpansionJointHiddenLines |
OST_ExpansionJoints |
OST_VibrationIsolatorTags |
OST_VibrationIsolators |
OST_VibrationDamperTags |
OST_VibrationDampers |
OST_VibrationManagementHiddenLines |
OST_VibrationManagement |
OST_BridgeFramingTrusses |
OST_BridgeFramingDiaphragms |
OST_BridgeFramingCrossBracing |
OST_BridgeFramingTags |
OST_BridgeFramingHiddenLines |
OST_BridgeFraming |
OST_PierWallTags |
OST_PierWalls |
OST_PierPileTags |
OST_PierPiles |
OST_PierColumnTags |
OST_PierColumns |
OST_PierCapTags |
OST_PierCaps |
OST_ApproachSlabTags |
OST_AbutmentWallTags |
OST_AbutmentPileTags |
OST_AbutmentFoundationTags |
OST_ApproachSlabs |
OST_AbutmentWalls |
OST_AbutmentPiles |
OST_AbutmentFoundations |
OST_BridgeBearingTags |
OST_BridgeGirderTags |
OST_BridgeFoundationTags |
OST_BridgeDeckTags |
OST_BridgeArchTags |
OST_BridgeCableTags |
OST_BridgeTowerTags |
OST_BridgePierTags |
OST_BridgeAbutmentTags |
OST_BridgeBearingHiddenLines |
OST_BridgeGirderHiddenLines2021_Deprecated |
OST_BridgeFoundationHiddenLines2021_Deprecated |
OST_BridgeDeckHiddenLines |
OST_BridgeArchHiddenLines2021_Deprecated |
OST_BridgeCableHiddenLines2021_Deprecated |
OST_BridgeTowerHiddenLines2021_Deprecated |
OST_BridgePierHiddenLines |
OST_BridgeAbutmentHiddenLines |
OST_BridgeBearings |
OST_BridgeGirders |
OST_BridgeFoundations |
OST_BridgeDecks |
OST_BridgeArches |
OST_BridgeCables |
OST_BridgeTowers |
OST_BridgePiers |
OST_BridgeAbutments |
OST_DesignOptions |
OST_DesignOptionSets |
OST_StructuralBracePlanReps |
OST_StructConnectionSymbols |
OST_StructuralAnnotations |
OST_RevisionCloudTags |
OST_RevisionNumberingSequences |
OST_Revisions |
OST_RevisionClouds |
OST_EditCutProfile |
OST_ElevationMarks |
OST_GridHeads |
OST_LevelHeads |
OST_DecalType |
OST_DecalElement |
OST_VolumeOfInterest |
OST_BoundaryConditions |
OST_InternalAreaLoadTags |
OST_InternalLineLoadTags |
OST_InternalPointLoadTags |
OST_AreaLoadTags |
OST_LineLoadTags |
OST_PointLoadTags |
OST_LoadCasesSeismic |
OST_LoadCasesTemperature |
OST_LoadCasesAccidental |
OST_LoadCasesRoofLive |
OST_LoadCasesSnow |
OST_LoadCasesWind |
OST_LoadCasesLive |
OST_LoadCasesDead |
OST_LoadCases |
OST_InternalAreaLoads |
OST_InternalLineLoads |
OST_InternalPointLoads |
OST_InternalLoads |
OST_AreaLoads |
OST_LineLoads |
OST_PointLoads |
OST_Loads |
OST_BeamSystemTags |
OST_FootingSpanDirectionSymbol |
OST_SpanDirectionSymbol |
OST_SpotSlopesSymbols |
OST_SpotCoordinateSymbols |
OST_SpotElevSymbols |
OST_MultiLeaderTag |
OST_CurtainWallMullionTags |
OST_StructuralConnectionHandlerTags_Deprecated |
OST_TrussTags |
OST_KeynoteTags |
OST_DetailComponentTags |
OST_MaterialTags |
OST_FloorTags |
OST_CurtaSystemTags |
OST_HostFinTags |
OST_StairsTags |
OST_MultiCategoryTags |
OST_PlantingTags |
OST_AreaTags |
OST_StructuralFoundationTags |
OST_StructuralColumnTags |
OST_ParkingTags |
OST_SiteTags |
OST_StructuralFramingTags |
OST_SpecialityEquipmentTags |
OST_GenericModelTags |
OST_CurtainWallPanelTags |
OST_WallTags |
OST_PlumbingFixtureTags |
OST_MechanicalEquipmentTags |
OST_LightingFixtureTags |
OST_FurnitureSystemTags |
OST_FurnitureTags |
OST_ElectricalFixtureTags |
OST_ElectricalEquipmentTags |
OST_CeilingTags |
OST_CaseworkTags |
OST_Tags |
OST_MEPSpaceColorFill |
OST_MEPSpaceReference |
OST_MEPSpaceInteriorFill |
OST_MEPSpaceReferenceVisibility |
OST_MEPSpaceInteriorFillVisibility |
OST_MEPSpaces |
OST_StackedWalls |
OST_MassGlazingAll |
OST_MassFloorsAll |
OST_MassWallsAll |
OST_MassExteriorWallUnderground |
OST_MassSlab |
OST_MassShade |
OST_MassOpening |
OST_MassSkylights |
OST_MassGlazing |
OST_MassRoof |
OST_MassExteriorWall |
OST_MassInteriorWall |
OST_MassZone |
OST_MassAreaFaceTags |
OST_HostTemplate |
OST_MassFaceSplitter |
OST_MassCutter |
OST_ZoningEnvelope |
OST_MassTags |
OST_MassForm |
OST_MassFloor |
OST_Mass |
OST_DividedSurface_DiscardedDivisionLines |
OST_DividedSurfaceBelt |
OST_TilePatterns |
OST_AlwaysExcludedInAllViews |
OST_DividedSurface_TransparentFace |
OST_DividedSurface_PreDividedSurface |
OST_DividedSurface_PatternFill |
OST_DividedSurface_PatternLines |
OST_DividedSurface_Gridlines |
OST_DividedSurface_Nodes |
OST_DividedSurface |
OST_RepeatingDetailLines |
OST_RampsDownArrow |
OST_RampsUpArrow |
OST_RampsDownText |
OST_RampsUpText |
OST_RampsStringerAboveCut |
OST_RampsStringer |
OST_RampsAboveCut |
OST_RampsIncomplete |
OST_TrussDummy |
OST_ZoneSchemes |
OST_AreaSchemes |
OST_Areas |
OST_ProjectInformation |
OST_Sheets |
OST_ProfileFamilies |
OST_DetailComponents |
OST_RoofSoffit |
OST_EdgeSlab |
OST_Gutter |
OST_Fascia |
OST_Entourage |
OST_Planting |
OST_Blocks |
OST_StructuralStiffenerHiddenLines |
OST_StructuralColumnLocationLine |
OST_StructuralFramingLocationLine |
OST_StructuralStiffenerTags |
OST_StructuralStiffener |
OST_FootingAnalyticalGeometry |
OST_RvtLinks |
OST_Automatic |
OST_SpecialityEquipment |
OST_ColumnAnalyticalRigidLinks |
OST_SecondaryTopographyContours |
OST_TopographyContours |
OST_TopographySurface |
OST_Topography |
OST_TopographyLink |
OST_StructuralTruss |
OST_StructuralColumnStickSymbols |
OST_HiddenStructuralColumnLines |
OST_AnalyticalRigidLinks |
OST_ColumnAnalyticalGeometry |
OST_FramingAnalyticalGeometry |
OST_StructuralColumns |
OST_HiddenStructuralFramingLines |
OST_KickerBracing |
OST_StructuralFramingSystem |
OST_VerticalBracing |
OST_HorizontalBracing |
OST_Purlin |
OST_Joist |
OST_Girder |
OST_StructuralFramingOther |
OST_StructuralFraming |
OST_HiddenStructuralFoundationLines |
OST_StructuralFoundation |
OST_LinkBasePoint |
OST_BasePointAxisZ |
OST_BasePointAxisY |
OST_BasePointAxisX |
OST_SharedBasePoint |
OST_ProjectBasePoint |
OST_SiteRegion |
OST_SitePropertyLineSegmentTags |
OST_SitePropertyLineSegment |
OST_SitePropertyTags |
OST_SitePointBoundary |
OST_SiteProperty |
OST_BuildingPad |
OST_SitePoint |
OST_SiteSurface |
OST_Site |
OST_Sewer |
OST_RoadTags |
OST_Roads |
OST_Property |
OST_Parking |
OST_PlumbingFixtures |
OST_MechanicalEquipment |
OST_LightingFixtureSource |
OST_LightingFixtures |
OST_DataExchanges |
OST_FloorLayers |
OST_WallLayers |
OST_RebarBendingDetails |
OST_ToposolidLinkTags |
OST_ElectricalConnectorTags |
OST_ElectricalConnector |
OST_FurnitureSystems |
OST_ElectricalLoadCase |
OST_ElectricalLoadSet |
OST_ToposolidLink |
OST_ElectricalAnalyticalFeeder |
OST_ToposolidOpening |
OST_ToposolidTags |
OST_ToposolidInsulation |
OST_ToposolidSurfacePattern |
OST_ToposolidFinish2 |
OST_ToposolidFinish1 |
OST_ToposolidSubstrate |
OST_ToposolidStructure |
OST_ToposolidMembrane |
OST_ToposolidCutPattern |
OST_ToposolidDefault |
OST_ToposolidSplitLines |
OST_ToposolidFoldingLines |
OST_ToposolidSecondaryContours |
OST_ToposolidContours |
OST_ToposolidHiddenLines |
OST_Toposolid |
OST_ELECTRICAL_AreaBasedLoads_Tags |
OST_ElectricalAnalyticalTransformer |
OST_FloorsSplitLines |
OST_AnalyticalMemberCrossSection |
OST_RvtLinksTags |
OST_ModelGroupTags |
OST_WallSweepTags |
OST_TopRailTags |
OST_SlabEdgeTags |
OST_RoofSoffitTags |
OST_RampTags |
OST_PadTags |
OST_HandrailTags |
OST_GutterTags |
OST_EntourageTags |
OST_ColumnTags |
OST_FasciaTags |
OST_SignageTags |
OST_ElectricalFixtures |
OST_SignageHiddenLines |
OST_Signage |
OST_AudioVisualDeviceTags |
OST_AudioVisualDevicesHiddenLines |
OST_AudioVisualDevices |
OST_VerticalCirculationTags |
OST_VerticalCirculationHiddenLines |
OST_VerticalCirculation |
OST_FireProtectionTags |
OST_FireProtectionHiddenLines |
OST_FireProtection |
OST_MedicalEquipmentTags |
OST_MedicalEquipmentHiddenLines |
OST_MedicalEquipment |
OST_FoodServiceEquipmentTags |
OST_FoodServiceEquipmentHiddenLines |
OST_FoodServiceEquipment |
OST_TemporaryStructureTags |
OST_TemporaryStructureHiddenLines |
OST_ElectricalEquipment |
OST_TemporaryStructure |
OST_HardscapeTags |
OST_HardscapeHiddenLines |
OST_Hardscape |
OST_WallCoreLayer |
OST_WallNonCoreLayer |
OST_MEPLoadAreaSeparationLines |
OST_MEPLoadAreaReferenceVisibility |
OST_MEPLoadAreaInteriorFillVisibility |
OST_MEPLoadAreaReference |
OST_MEPLoadAreaInteriorFill |
OST_MEPLoadAreaColorFill |
OST_ElectricalPowerSource |
OST_MEPLoadAreaTags_OBSOLETE |
OST_MEPLoadAreas |
OST_MEPAnalyticalTransferSwitch |
OST_OBSOLETE_MEPAnalyticalElectricalBranch |
OST_MEPAnalyticalBus |
OST_ElectricalLoadZoneInstance |
OST_ElectricalLoadZoneType |
OST_ElectricalZoneEquipment_Obsolete |
OST_AlignmentStationLabels |
OST_AlignmentStationLabelSets |
OST_AlignmentsTags |
OST_MinorStations_Deprecated |
OST_MajorStations_Deprecated |
OST_Alignments |
OST_ElectricalCircuitNaming |
OST_ZoneEquipment |
OST_MEPAnalyticalWaterLoop |
OST_MEPAnalyticalAirLoop |
OST_MEPSystemZoneTags |
OST_MEPSystemZoneReferenceLinesVisibility |
OST_MEPSystemZoneInteriorFillVisibility |
OST_MEPSystemZoneReferenceLines |
OST_MEPSystemZoneInteriorFill |
OST_MEPSystemZoneBoundary |
OST_MEPSystemZone |
OST_Casework |
OST_ArcWallRectOpening |
OST_DormerOpeningIncomplete |
OST_SWallRectOpening |
OST_ShaftOpening |
OST_StructuralFramingOpening |
OST_ColumnOpening |
OST_RiseDropSymbols |
OST_PipeHydronicSeparationSymbols |
OST_MechanicalEquipmentSetBoundaryLines |
OST_MechanicalEquipmentSetTags |
OST_MechanicalEquipmentSet |
OST_AnalyticalPipeConnectionLineSymbol |
OST_AnalyticalPipeConnections |
OST_Coordination_Model |
OST_MultistoryStairs |
OST_HiddenStructuralConnectionLines_Deprecated |
OST_StructuralConnectionHandler_Deprecated |
OST_CoordinateSystem |
OST_FndSlabLocalCoordSys |
OST_FloorLocalCoordSys |
OST_WallLocalCoordSys |
OST_BraceLocalCoordSys |
OST_ColumnLocalCoordSys |
OST_BeamLocalCoordSys |
OST_MultiReferenceAnnotations |
OST_DSR_LeaderTickMarkStyleId |
OST_DSR_InteriorTickMarkStyleId |
OST_DSR_ArrowHeadStyleId |
OST_DSR_CenterlineTickMarkStyleId |
OST_DSR_CenterlinePatternCatId |
OST_DSR_DimStyleHeavyEndCategoryId |
OST_DSR_DimStyleHeavyEndCatId |
OST_DSR_DimStyleTickCategoryId |
OST_DSR_LineAndTextAttrFontId |
OST_DSR_LineAndTextAttrCategoryId |
OST_AnalyticalOpeningTags |
OST_AnalyticalPanelTags |
OST_NodeAnalyticalTags |
OST_LinkAnalyticalTags |
OST_RailingRailPathExtensionLines |
OST_RailingRailPathLines |
OST_StairsSupports |
OST_RailingHandRailAboveCut |
OST_RailingTopRailAboveCut |
OST_RailingTermination |
OST_RailingSupport |
OST_RailingHandRail |
OST_RailingTopRail |
OST_StairsSketchPathLines |
OST_StairsTriserNumbers |
OST_StairsTriserTags |
OST_StairsSupportTags |
OST_StairsLandingTags |
OST_StairsRunTags |
OST_StairsPathsAboveCut |
OST_StairsPaths |
OST_StairsRiserLinesAboveCut |
OST_StairsRiserLines |
OST_StairsOutlinesAboveCut |
OST_StairsOutlines |
OST_StairsNosingLinesAboveCut |
OST_StairsNosingLines |
OST_StairsCutMarksAboveCut |
OST_StairsCutMarks |
OST_ComponentRepeaterSlot |
OST_ComponentRepeater |
OST_DividedPath |
OST_IOSRoomCalculationPoint |
OST_PropertySet |
OST_AppearanceAsset |
OST_StairStringer2012_Deprecated |
OST_StairsTrisers |
OST_StairsLandings |
OST_StairsRuns |
OST_Stair2012_Deprecated |
OST_RailingSystemTags |
OST_RailingSystemTransition |
OST_RailingSystemTermination |
OST_RailingSystemRail |
OST_RailingSystemTopRail |
OST_RailingSystemHandRailBracket |
OST_RailingSystemHandRail |
OST_RailingSystemHardware |
OST_RailingSystemPanel |
OST_RailingSystemBaluster |
OST_RailingSystemPost |
OST_RailingSystemSegment |
OST_RailingSystem |
OST_AdaptivePoints_HiddenLines |
OST_AdaptivePoints_Lines |
OST_AdaptivePoints_Planes |
OST_AdaptivePoints_Points |
OST_AdaptivePoints |
OST_CeilingOpening |
OST_FloorOpening |
OST_RoofOpening |
OST_WallRefPlanes |
OST_StructLocationLineControl |
OST_PathOfTravelTags |
OST_PathOfTravelLines |
OST_DimLockControlLeader |
OST_MEPSpaceSeparationLines |
OST_AreaPolylines |
OST_RoomPolylines |
OST_InstanceDrivenLineStyle |
OST_RemovedGridSeg |
OST_IOSOpening |
OST_IOSTilePatternGrid |
OST_ControlLocal |
OST_ControlAxisZ |
OST_ControlAxisY |
OST_ControlAxisX |
OST_XRayConstrainedProfileEdge |
OST_XRayImplicitPathCurve |
OST_XRayPathPoint |
OST_XRayPathCurve |
OST_XRaySideEdge |
OST_XRayProfileEdge |
OST_ReferencePoints_HiddenLines |
OST_ReferencePoints_Lines |
OST_ReferencePoints_Planes |
OST_ReferencePoints_Points |
OST_ReferencePoints |
OST_Materials |
OST_CeilingsCutPattern |
OST_CeilingsDefault |
OST_CeilingsFinish2 |
OST_CeilingsFinish1 |
OST_CeilingsSubstrate |
OST_CeilingsInsulation |
OST_CeilingsStructure |
OST_CeilingsMembrane |
OST_FloorsInteriorEdges |
OST_FloorsCutPattern |
OST_HiddenFloorLines |
OST_FloorsDefault |
OST_FloorsFinish2 |
OST_FloorsFinish1 |
OST_FloorsSubstrate |
OST_FloorsInsulation |
OST_FloorsStructure |
OST_FloorsMembrane |
OST_RoofsInteriorEdges |
OST_RoofsCutPattern |
OST_RoofsDefault |
OST_RoofsFinish2 |
OST_RoofsFinish1 |
OST_RoofsSubstrate |
OST_RoofsInsulation |
OST_RoofsStructure |
OST_RoofsMembrane |
OST_WallsCutPattern |
OST_HiddenWallLines |
OST_WallsDefault |
OST_WallsFinish2 |
OST_WallsFinish1 |
OST_WallsSubstrate |
OST_WallsInsulation |
OST_WallsStructure |
OST_WallsMembrane |
OST_PreviewLegendComponents |
OST_LegendComponents |
OST_Schedules |
OST_ScheduleGraphics |
OST_RasterImages |
OST_ColorFillSchema |
OST_RoomColorFill |
OST_ColorFillLegends |
OST_AnnotationCropSpecial |
OST_CropBoundarySpecial |
OST_AnnotationCrop |
OST_FloorsAnalyticalGeometry |
OST_WallsAnalyticalGeometry |
OST_CalloutLeaderLine |
OST_CeilingsSurfacePattern |
OST_RoofsSurfacePattern |
OST_FloorsSurfacePattern |
OST_WallsSurfacePattern |
OST_CalloutBoundary |
OST_CalloutHeads |
OST_Callouts |
OST_CropBoundary |
OST_Elev |
OST_AxisZ |
OST_AxisY |
OST_AxisX |
OST_CLines |
OST_Lights |
OST_ViewportLabel |
OST_Viewports |
OST_Camera_Lines |
OST_Cameras |
OST_MEPSpaceTags |
OST_RoomTags |
OST_DoorTags |
OST_WindowTags |
OST_SectionHeadWideLines |
OST_SectionHeadMediumLines |
OST_SectionHeadThinLines |
OST_SectionHeads |
OST_ContourLabels |
OST_CurtaSystemFaceManager |
OST_CurtaSystem |
OST_AreaReport_Arc_Minus |
OST_AreaReport_Arc_Plus |
OST_AreaReport_Boundary |
OST_AreaReport_Triangle |
OST_CurtainGridsCurtaSystem |
OST_CurtainGridsSystem |
OST_CurtainGridsWall |
OST_CurtainGridsRoof |
OST_HostFinHF |
OST_HostFinWall |
OST_HostFinCeiling |
OST_HostFinRoof |
OST_HostFinFloor |
OST_HostFin |
OST_AnalysisDisplayStyle |
OST_AnalysisResults |
OST_RenderRegions |
OST_SectionBox |
OST_TextNotes |
OST_Divisions |
OST_Catalogs |
OST_DirectionEdgeLines |
OST_CenterLines |
OST_LinesBeyond |
OST_HiddenLines |
OST_DemolishedLines |
OST_OverheadLines |
OST_TitleBlockWideLines |
OST_TitleBlockMediumLines |
OST_TitleBlockThinLines |
OST_TitleBlocks |
OST_Views |
OST_Viewers |
OST_PartHiddenLines |
OST_PartTags |
OST_Parts |
OST_AssemblyTags |
OST_Assemblies |
OST_RoofTags |
OST_SpotSlopes |
OST_SpotCoordinates |
OST_SpotElevations |
OST_Constraints |
OST_WeakDims |
OST_Dimensions |
OST_Levels |
OST_DisplacementPath |
OST_DisplacementElements |
OST_GridChains |
OST_Grids |
OST_BrokenSectionLine |
OST_SectionLine |
OST_Sections |
OST_ReferenceViewer |
OST_ReferenceViewerSymbol |
OST_ImportObjectStyles |
OST_ModelText |
OST_MaskingRegion |
OST_Matchline |
OST_FaceSplitter |
OST_PlanRegion |
OST_FilledRegion |
OST_MassingProjectionOutlines |
OST_MassingCutOutlines |
OST_Massing |
OST_Reveals |
OST_Cornices |
OST_Ramps |
OST_RailingBalusterRailCut |
OST_RailingBalusterRail |
OST_Railings |
OST_CurtainGrids |
OST_CurtainWallMullionsCut |
OST_CurtainWallMullions |
OST_CurtainWallPanels |
OST_AreaReference |
OST_AreaInteriorFill |
OST_RoomReference |
OST_RoomInteriorFill |
OST_AreaColorFill |
OST_AreaReferenceVisibility |
OST_AreaInteriorFillVisibility |
OST_RoomReferenceVisibility |
OST_RoomInteriorFillVisibility |
OST_Rooms |
OST_GenericModel |
OST_GenericAnnotation |
OST_Fixtures |
OST_StairsRailingTags |
OST_StairsRailingAboveCut |
OST_StairsDownArrows |
OST_StairsUpArrows |
OST_StairsDownText |
OST_StairsRailingRail |
OST_StairsRailingBaluster |
OST_StairsRailing |
OST_StairsUpText |
OST_StairsSupportsAboveCut |
OST_StairsStringerCarriage |
OST_StairsAboveCut_ToBeDeprecated |
OST_StairsIncomplete_Deprecated |
OST_Stairs |
OST_IOSNavWheelPivotBall |
OST_IOSRoomComputationHeight |
OST_IOSRoomUpperLowerLines |
OST_IOSDragBoxInverted |
OST_IOSDragBox |
OST_Phases |
OST_IOS_GeoSite |
OST_IOS_GeoLocations |
OST_IOSFabricReinSpanSymbolCtrl |
OST_GuideGrid |
OST_EPS_Future |
OST_EPS_Temporary |
OST_EPS_New |
OST_EPS_Demolished |
OST_EPS_Existing |
OST_IOSMeasureLineScreenSize |
OST_Columns |
OST_IOSRebarSystemSpanSymbolCtrl |
OST_IOSRoomTagToRoomLines |
OST_IOSAttachedDetailGroups |
OST_IOSDetailGroups |
OST_IOSModelGroups |
OST_IOSSuspendedSketch |
OST_IOSWallCoreBoundary |
OST_IOSMeasureLine |
OST_IOSArrays |
OST_Curtain_Systems |
OST_IOSBBoxScreenSize |
OST_IOSSlabShapeEditorPointInterior |
OST_IOSSlabShapeEditorPointBoundary |
OST_IOSSlabShapeEditorBoundary |
OST_IOSSlabShapeEditorAutoCrease |
OST_IOSSlabShapeEditorExplitCrease |
OST_ReferenceLines |
OST_IOSNotSilhouette |
OST_FillPatterns |
OST_Furniture |
OST_AreaSchemeLines |
OST_GenericLines |
OST_InsulationLines |
OST_CloudLines |
OST_IOSRoomPerimeterLines |
OST_IOSCuttingGeometry |
OST_IOSCrashGraphics |
OST_IOSGroups |
OST_IOSGhost |
OST_StairsSketchLandingCenterLines |
OST_StairsSketchRunLines |
OST_StairsSketchRiserLines |
OST_StairsSketchBoundaryLines |
OST_RoomSeparationLines |
OST_AxisOfRotation |
OST_InvisibleLines |
OST_IOSThinPixel_DashDot |
OST_IOSThinPixel_Dash |
OST_IOSThinPixel_Dot |
OST_Extrusions |
OST_IOS |
OST_CutOutlines |
OST_IOSThinPixel |
OST_IOSFlipControl |
OST_IOSSketchGrid |
OST_IOSSuspendedSketch_obsolete |
OST_IOSFreeSnapLine |
OST_IOSDatumPlane |
OST_Lines |
OST_IOSConstructionLine |
OST_IOSAlignmentGraphics |
OST_IOSAligningLine |
OST_IOSBackedUpElements |
OST_IOSRegeneratedElements |
OST_SketchLines |
OST_CurvesWideLines |
OST_CurvesMediumLines |
OST_CurvesThinLines |
OST_Curves |
OST_CeilingsProjection |
OST_CeilingsCut |
OST_Ceilings |
OST_RoofsProjection |
OST_RoofsCut |
OST_Roofs |
OST_FloorsProjection |
OST_FloorsCut |
OST_Floors |
OST_DoorsGlassProjection |
OST_DoorsGlassCut |
OST_DoorsFrameMullionProjection |
OST_DoorsFrameMullionCut |
OST_DoorsOpeningProjection |
OST_DoorsOpeningCut |
OST_DoorsPanelProjection |
OST_DoorsPanelCut |
OST_Doors |
OST_WindowsOpeningProjection |
OST_WindowsOpeningCut |
OST_WindowsSillHeadProjection |
OST_WindowsSillHeadCut |
OST_WindowsFrameMullionProjection |
OST_WindowsFrameMullionCut |
OST_WindowsGlassProjection |
OST_WindowsGlassCut |
OST_Windows |
OST_WallsProjectionOutlines |
OST_WallsCutOutlines |
OST_Walls |
OST_IOSRegenerationFailure |
OST_ScheduleViewParamGroup |
OST_MatchSiteComponent |
OST_MatchProfile |
OST_MatchDetail |
OST_MatchAnnotation |
OST_MatchModel |
OST_MatchAll |
INVALID |

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


BuiltInFailures.AlignmentFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..AlignmentFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures related to alignment elements and annotations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class AlignmentFailures
Visual Basic
Public NotInheritable Class AlignmentFailures
Visual C++
public ref class AlignmentFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..AlignmentFailures

See Also

BuiltInFailures..::..AlignmentFailures Members


BuiltInFailures.AlignmentFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..AlignmentFailures Properties
BuiltInFailures..::..AlignmentFailures Class See Also Send Feedback

The BuiltInFailures..::..AlignmentFailures type exposes the following members.

Properties

Name | Description
AlignmentCheckStationLabels | A change to an Infrastructure Alignment or its Stationing Units may have affected the associated Alignment Station Labels. Please check the labels to ensure proper placement.

See Also

BuiltInFailures..::..AlignmentFailures Class


AlignmentCheckStationLabels Property

[image]

Revit 2024 API
BuiltInFailures..::..AlignmentFailures..::..AlignmentCheckStationLabels Property
BuiltInFailures..::..AlignmentFailures Class See Also Send Feedback
A change to an Infrastructure Alignment or its Stationing Units may have affected the associated Alignment Station Labels. Please check the labels to ensure proper placement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AlignmentCheckStationLabels { get; }
Visual Basic
Public Shared ReadOnly Property AlignmentCheckStationLabels As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AlignmentCheckStationLabels {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AlignmentFailures Class


BuiltInFailures.AnalyticalModelFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..AnalyticalModelFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about AnalyticalModel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class AnalyticalModelFailures
Visual Basic
Public NotInheritable Class AnalyticalModelFailures
Visual C++
public ref class AnalyticalModelFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..AnalyticalModelFailures

See Also

BuiltInFailures..::..AnalyticalModelFailures Members


AdjustCurveTooShort Property

[image]

Revit 2024 API
BuiltInFailures..::..AnalyticalModelFailures..::..AdjustCurveTooShort Property
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback
AdjustCurve is too short.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AdjustCurveTooShort { get; }
Visual Basic
Public Shared ReadOnly Property AdjustCurveTooShort As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AdjustCurveTooShort {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


AdjustEdgeTooShort Property

[image]

Revit 2024 API
BuiltInFailures..::..AnalyticalModelFailures..::..AdjustEdgeTooShort Property
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback
AdjustEdge is too short.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AdjustEdgeTooShort { get; }
Visual Basic
Public Shared ReadOnly Property AdjustEdgeTooShort As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AdjustEdgeTooShort {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


AdjustEdgeTooShortWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..AnalyticalModelFailures..::..AdjustEdgeTooShortWarn Property
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback
AdjustEdge is too short.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AdjustEdgeTooShortWarn { get; }
Visual Basic
Public Shared ReadOnly Property AdjustEdgeTooShortWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AdjustEdgeTooShortWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


AnalyticalBeamSlabWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..AnalyticalModelFailures..::..AnalyticalBeamSlabWarning Property
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback
Beam and Slab Analytical Models do not have the same Analytical Projection Plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AnalyticalBeamSlabWarning { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalBeamSlabWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AnalyticalBeamSlabWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


AnalyticalDiscrepancyWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..AnalyticalModelFailures..::..AnalyticalDiscrepancyWarning Property
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback
Distance between Analytical and Physical Models of Structural Element is beyond tolerance of [Value]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AnalyticalDiscrepancyWarning { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalDiscrepancyWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AnalyticalDiscrepancyWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


AnalyticalElementsInvalidAfterUpgrade Property

[image]

Revit 2024 API
BuiltInFailures..::..AnalyticalModelFailures..::..AnalyticalElementsInvalidAfterUpgrade Property
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback
One or several analytical elements have become invalid during the upgrade process and will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AnalyticalElementsInvalidAfterUpgrade { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalElementsInvalidAfterUpgrade As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AnalyticalElementsInvalidAfterUpgrade {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


AnalyticalLinkJoinedNodes Property

[image]

Revit 2024 API
BuiltInFailures..::..AnalyticalModelFailures..::..AnalyticalLinkJoinedNodes Property
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback
Analitycal Link is invalid. Reference nodes have been joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AnalyticalLinkJoinedNodes { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalLinkJoinedNodes As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AnalyticalLinkJoinedNodes {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


AnalyticalLinkNotConnected Property

[image]

Revit 2024 API
BuiltInFailures..::..AnalyticalModelFailures..::..AnalyticalLinkNotConnected Property
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback
Analytical Link has lost one or more references.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AnalyticalLinkNotConnected { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalLinkNotConnected As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AnalyticalLinkNotConnected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


AnalyticalModelIsIncorrect Property

[image]

Revit 2024 API
BuiltInFailures..::..AnalyticalModelFailures..::..AnalyticalModelIsIncorrect Property
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback
Analytical Model is not created for the structural element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AnalyticalModelIsIncorrect { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalModelIsIncorrect As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AnalyticalModelIsIncorrect {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


AnalyticalPanelNotVisible Property

[image]

Revit 2024 API
BuiltInFailures..::..AnalyticalModelFailures..::..AnalyticalPanelNotVisible Property
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback
Analytical Panel is not visible in the current view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AnalyticalPanelNotVisible { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalPanelNotVisible As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AnalyticalPanelNotVisible {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


AnalyticalPhysicalCheckDone Property

[image]

Revit 2024 API
BuiltInFailures..::..AnalyticalModelFailures..::..AnalyticalPhysicalCheckDone Property
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback
Analytical / Physical Model Consistency check is complete.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AnalyticalPhysicalCheckDone { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalPhysicalCheckDone As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AnalyticalPhysicalCheckDone {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


AnalyticalSupportCycleWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..AnalyticalModelFailures..::..AnalyticalSupportCycleWarning Property
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback
Circular support chain detected

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AnalyticalSupportCycleWarning { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalSupportCycleWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AnalyticalSupportCycleWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


AnalyticalSurfaceCannotMove Property

[image]

Revit 2024 API
BuiltInFailures..::..AnalyticalModelFailures..::..AnalyticalSurfaceCannotMove Property
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback
Cannot move analytical surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AnalyticalSurfaceCannotMove { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalSurfaceCannotMove As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AnalyticalSurfaceCannotMove {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


AnalyticalSurfaceCannotMoveByConnector Property

[image]

Revit 2024 API
BuiltInFailures..::..AnalyticalModelFailures..::..AnalyticalSurfaceCannotMoveByConnector Property
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback
Cannot move analytical surface because it will disconnect the analytical nodes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AnalyticalSurfaceCannotMoveByConnector { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalSurfaceCannotMoveByConnector As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AnalyticalSurfaceCannotMoveByConnector {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


BoundaryLinesIntersect Property

[image]

Revit 2024 API
BuiltInFailures..::..AnalyticalModelFailures..::..BoundaryLinesIntersect Property
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback
Boundary lines intersect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId BoundaryLinesIntersect { get; }
Visual Basic
Public Shared ReadOnly Property BoundaryLinesIntersect As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BoundaryLinesIntersect {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


CannotKeepAnalyticalAdjustment Property

[image]

Revit 2024 API
BuiltInFailures..::..AnalyticalModelFailures..::..CannotKeepAnalyticalAdjustment Property
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback
Analytical model Adjustment distance exceeds current Adjustment Snapping Distance. To adjust snap settings, go to the Structural Settings Dialog.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotKeepAnalyticalAdjustment { get; }
Visual Basic
Public Shared ReadOnly Property CannotKeepAnalyticalAdjustment As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotKeepAnalyticalAdjustment {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


CannotMakeAnalyticalGeometry Property

[image]

Revit 2024 API
BuiltInFailures..::..AnalyticalModelFailures..::..CannotMakeAnalyticalGeometry Property
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback
Cannot construct Analytical Geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotMakeAnalyticalGeometry { get; }
Visual Basic
Public Shared ReadOnly Property CannotMakeAnalyticalGeometry As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMakeAnalyticalGeometry {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


CannotSlantAnalyticalWallError Property

[image]

Revit 2024 API
BuiltInFailures..::..AnalyticalModelFailures..::..CannotSlantAnalyticalWallError Property
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback
Cannot slant a wall with an Analytical Model. Please disable the Analytical Model first.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotSlantAnalyticalWallError { get; }
Visual Basic
Public Shared ReadOnly Property CannotSlantAnalyticalWallError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotSlantAnalyticalWallError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


ContextualAnalyticalModelModeNotEnabled Property

[image]

Revit 2024 API
BuiltInFailures..::..AnalyticalModelFailures..::..ContextualAnalyticalModelModeNotEnabled Property
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback
Contextual Analytical Model not enabled. File open was canceled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ContextualAnalyticalModelModeNotEnabled { get; }
Visual Basic
Public Shared ReadOnly Property ContextualAnalyticalModelModeNotEnabled As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ContextualAnalyticalModelModeNotEnabled {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


LoadsMayBeNotUpToDate Property

[image]

Revit 2024 API
BuiltInFailures..::..AnalyticalModelFailures..::..LoadsMayBeNotUpToDate Property
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback
Reactions defined as Internal Load (Is Reaction) may no longer be valid since the analytical model has changed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId LoadsMayBeNotUpToDate { get; }
Visual Basic
Public Shared ReadOnly Property LoadsMayBeNotUpToDate As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LoadsMayBeNotUpToDate {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


ProjectionPlaneInvalidWall Property

[image]

Revit 2024 API
BuiltInFailures..::..AnalyticalModelFailures..::..ProjectionPlaneInvalidWall Property
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback
Projection plane becomes invalid for this wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ProjectionPlaneInvalidWall { get; }
Visual Basic
Public Shared ReadOnly Property ProjectionPlaneInvalidWall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ProjectionPlaneInvalidWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


ProjectionPlanesParallel Property

[image]

Revit 2024 API
BuiltInFailures..::..AnalyticalModelFailures..::..ProjectionPlanesParallel Property
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback
Can't project Analytical Model. Two or more projection planes are parallel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ProjectionPlanesParallel { get; }
Visual Basic
Public Shared ReadOnly Property ProjectionPlanesParallel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ProjectionPlanesParallel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


StructAnalyticalErrorProjection Property

[image]

Revit 2024 API
BuiltInFailures..::..AnalyticalModelFailures..::..StructAnalyticalErrorProjection Property
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback
Can't project Analytical Model to Analytical Projection Surface

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StructAnalyticalErrorProjection { get; }
Visual Basic
Public Shared ReadOnly Property StructAnalyticalErrorProjection As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StructAnalyticalErrorProjection {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


StructuralElementMayNotBeSupported Property

[image]

Revit 2024 API
BuiltInFailures..::..AnalyticalModelFailures..::..StructuralElementMayNotBeSupported Property
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback
Structural Element may not be supported -- verify support for Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StructuralElementMayNotBeSupported { get; }
Visual Basic
Public Shared ReadOnly Property StructuralElementMayNotBeSupported As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StructuralElementMayNotBeSupported {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


StructWallAnalyticalErrorAlign Property

[image]

Revit 2024 API
BuiltInFailures..::..AnalyticalModelFailures..::..StructWallAnalyticalErrorAlign Property
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback
Can't align Analytical Model with joined Walls.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StructWallAnalyticalErrorAlign { get; }
Visual Basic
Public Shared ReadOnly Property StructWallAnalyticalErrorAlign As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StructWallAnalyticalErrorAlign {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


SupportCheckDone Property

[image]

Revit 2024 API
BuiltInFailures..::..AnalyticalModelFailures..::..SupportCheckDone Property
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback
Member support check is complete. No unsupported elements detected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SupportCheckDone { get; }
Visual Basic
Public Shared ReadOnly Property SupportCheckDone As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SupportCheckDone {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


BuiltInFailures.ArrayFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..ArrayFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Arrays.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class ArrayFailures
Visual Basic
Public NotInheritable Class ArrayFailures
Visual C++
public ref class ArrayFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..ArrayFailures

See Also

BuiltInFailures..::..ArrayFailures Members


BuiltInFailures.ArrayFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..ArrayFailures Members
BuiltInFailures..::..ArrayFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..ArrayFailures type exposes the following members.

Properties

Name | Description
ArrayingNotSupportedForElements | Arraying is not currently supported for the selected elements.
ArrayMixedModAndViewSpecElemsCorruption | Unable to array this mixture of modeling and view specific elements.
ArrayMixedModAndViewSpecElemsWarning | You have selected a mixture of modeling and view specific elements to array in an associative manner. Only the model elements will remain grouped and associative.
CannotCreateArraySelectionIsGrouped | Can't create an array because the selection cannot be grouped.
ConstraintsNotSatisfied | Constraints are not satisfied
CouldntFindNewHostsForElements | Couldn't find new hosts for elements in array.
IdenticalGeometryCopiesInArray | This array contains multiple copies of some identical geometry. Performance might be improved by using a nested family and arraying copies of its instances.
RadiusTooSmall | Radius is too small.

See Also

BuiltInFailures..::..ArrayFailures Class


BuiltInFailures.ArrayFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..ArrayFailures Properties
BuiltInFailures..::..ArrayFailures Class See Also Send Feedback

The BuiltInFailures..::..ArrayFailures type exposes the following members.

Properties

Name | Description
ArrayingNotSupportedForElements | Arraying is not currently supported for the selected elements.
ArrayMixedModAndViewSpecElemsCorruption | Unable to array this mixture of modeling and view specific elements.
ArrayMixedModAndViewSpecElemsWarning | You have selected a mixture of modeling and view specific elements to array in an associative manner. Only the model elements will remain grouped and associative.
CannotCreateArraySelectionIsGrouped | Can't create an array because the selection cannot be grouped.
ConstraintsNotSatisfied | Constraints are not satisfied
CouldntFindNewHostsForElements | Couldn't find new hosts for elements in array.
IdenticalGeometryCopiesInArray | This array contains multiple copies of some identical geometry. Performance might be improved by using a nested family and arraying copies of its instances.
RadiusTooSmall | Radius is too small.

See Also

BuiltInFailures..::..ArrayFailures Class


ArrayingNotSupportedForElements Property

[image]

Revit 2024 API
BuiltInFailures..::..ArrayFailures..::..ArrayingNotSupportedForElements Property
BuiltInFailures..::..ArrayFailures Class See Also Send Feedback
Arraying is not currently supported for the selected elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ArrayingNotSupportedForElements { get; }
Visual Basic
Public Shared ReadOnly Property ArrayingNotSupportedForElements As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ArrayingNotSupportedForElements {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ArrayFailures Class


ArrayMixedModAndViewSpecElemsCorruption Property

[image]

Revit 2024 API
BuiltInFailures..::..ArrayFailures..::..ArrayMixedModAndViewSpecElemsCorruption Property
BuiltInFailures..::..ArrayFailures Class See Also Send Feedback
Unable to array this mixture of modeling and view specific elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ArrayMixedModAndViewSpecElemsCorruption { get; }
Visual Basic
Public Shared ReadOnly Property ArrayMixedModAndViewSpecElemsCorruption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ArrayMixedModAndViewSpecElemsCorruption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ArrayFailures Class


IdenticalGeometryCopiesInArray Property

[image]

Revit 2024 API
BuiltInFailures..::..ArrayFailures..::..IdenticalGeometryCopiesInArray Property
BuiltInFailures..::..ArrayFailures Class See Also Send Feedback
This array contains multiple copies of some identical geometry. Performance might be improved by using a nested family and arraying copies of its instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId IdenticalGeometryCopiesInArray { get; }
Visual Basic
Public Shared ReadOnly Property IdenticalGeometryCopiesInArray As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ IdenticalGeometryCopiesInArray {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ArrayFailures Class


RadiusTooSmall Property

[image]

Revit 2024 API
BuiltInFailures..::..ArrayFailures..::..RadiusTooSmall Property
BuiltInFailures..::..ArrayFailures Class See Also Send Feedback
Radius is too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RadiusTooSmall { get; }
Visual Basic
Public Shared ReadOnly Property RadiusTooSmall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RadiusTooSmall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ArrayFailures Class


BuiltInFailures.AssemblyFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..AssemblyFailures Members
BuiltInFailures..::..AssemblyFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..AssemblyFailures type exposes the following members.

Properties

Name | Description
AddedElementsNotSamePhaseAsAssembly | Selected Element(s) cannot be added to the assembly. Elements must have the same phases as the assembly to be included in the assembly.
AssemblyDeleteTypeWarn | Edits to these assemblies changed the naming category and name of these assemblies.
AssemblyDidNotMatchRequestedTypeWarn | Assembly was changed to a new type, but did not match the type. Geometry could have been changed due to a join condition.
AssemblyDisassembleInstanceWarn | Edits to these assemblies changed the naming category and name of these assemblies.
AssemblyInheritTypeWarn | Edits to these assemblies do not match existing types, new type will be created.
AssemblyInvalidMember | Some elements became ineligible to be included in an assembly and were removed.
AssemblyNewTypeWarn | Edits to these assemblies match existing type and will inherit that name.
AssemblyRenameTypeWarn | Edits to these assemblies changed the naming category and name of these assemblies.
CouldNotAcquireAssemblyViews | The assembly instance could not acquire the assembly views.
CouldNotChangeTypeOfAssembly | Assembly cannot be changed to selected type.
DeleteAssemblyInstWithViewsWarn | Deleting this assembly will remove the assembly from the project and any views associated with that assembly.
DeleteShopDrawingsWarn | The assembly instance has associated views and cannot be merged with assembly type '%1!s!'. Delete the views to continue.\n\nViews:%2!s!
ElementsNotAllowedAreNotAddedToAssembly | Elements not allowed in Assembly were not added to it, but only in the document
IneligibleElementsInAssembly | Ineligible elements in assembly.
MixedPhasesInAssembly | Assembly cannot be created. All elements must have the same phases to be included in an assembly.
NoElementsAddedtoNewAssembly | No elements were added to the assembly. No assembly will be created.
NoElementsLeftInExistingAssembly | There are no elements left in the assembly. It will be disassembled.
NoEligibleElementsInAssembly | No eligible elements in assembly.
SomeElementsPreventAssemblyTypeChange | Assembly cannot be changed to selected type. Some elements in the target assembly prevent the type change from occurring. These tend to be parts and nested elements such as mullion, curtain panels, and members of trusses.

See Also

BuiltInFailures..::..AssemblyFailures Class


BuiltInFailures.AssemblyFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..AssemblyFailures Properties
BuiltInFailures..::..AssemblyFailures Class See Also Send Feedback

The BuiltInFailures..::..AssemblyFailures type exposes the following members.

Properties

Name | Description
AddedElementsNotSamePhaseAsAssembly | Selected Element(s) cannot be added to the assembly. Elements must have the same phases as the assembly to be included in the assembly.
AssemblyDeleteTypeWarn | Edits to these assemblies changed the naming category and name of these assemblies.
AssemblyDidNotMatchRequestedTypeWarn | Assembly was changed to a new type, but did not match the type. Geometry could have been changed due to a join condition.
AssemblyDisassembleInstanceWarn | Edits to these assemblies changed the naming category and name of these assemblies.
AssemblyInheritTypeWarn | Edits to these assemblies do not match existing types, new type will be created.
AssemblyInvalidMember | Some elements became ineligible to be included in an assembly and were removed.
AssemblyNewTypeWarn | Edits to these assemblies match existing type and will inherit that name.
AssemblyRenameTypeWarn | Edits to these assemblies changed the naming category and name of these assemblies.
CouldNotAcquireAssemblyViews | The assembly instance could not acquire the assembly views.
CouldNotChangeTypeOfAssembly | Assembly cannot be changed to selected type.
DeleteAssemblyInstWithViewsWarn | Deleting this assembly will remove the assembly from the project and any views associated with that assembly.
DeleteShopDrawingsWarn | The assembly instance has associated views and cannot be merged with assembly type '%1!s!'. Delete the views to continue.\n\nViews:%2!s!
ElementsNotAllowedAreNotAddedToAssembly | Elements not allowed in Assembly were not added to it, but only in the document
IneligibleElementsInAssembly | Ineligible elements in assembly.
MixedPhasesInAssembly | Assembly cannot be created. All elements must have the same phases to be included in an assembly.
NoElementsAddedtoNewAssembly | No elements were added to the assembly. No assembly will be created.
NoElementsLeftInExistingAssembly | There are no elements left in the assembly. It will be disassembled.
NoEligibleElementsInAssembly | No eligible elements in assembly.
SomeElementsPreventAssemblyTypeChange | Assembly cannot be changed to selected type. Some elements in the target assembly prevent the type change from occurring. These tend to be parts and nested elements such as mullion, curtain panels, and members of trusses.

See Also

BuiltInFailures..::..AssemblyFailures Class


AddedElementsNotSamePhaseAsAssembly Property

[image]

Revit 2024 API
BuiltInFailures..::..AssemblyFailures..::..AddedElementsNotSamePhaseAsAssembly Property
BuiltInFailures..::..AssemblyFailures Class See Also Send Feedback
Selected Element(s) cannot be added to the assembly. Elements must have the same phases as the assembly to be included in the assembly.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AddedElementsNotSamePhaseAsAssembly { get; }
Visual Basic
Public Shared ReadOnly Property AddedElementsNotSamePhaseAsAssembly As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AddedElementsNotSamePhaseAsAssembly {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AssemblyFailures Class


AssemblyDeleteTypeWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..AssemblyFailures..::..AssemblyDeleteTypeWarn Property
BuiltInFailures..::..AssemblyFailures Class See Also Send Feedback
Edits to these assemblies changed the naming category and name of these assemblies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AssemblyDeleteTypeWarn { get; }
Visual Basic
Public Shared ReadOnly Property AssemblyDeleteTypeWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AssemblyDeleteTypeWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AssemblyFailures Class


AssemblyDidNotMatchRequestedTypeWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..AssemblyFailures..::..AssemblyDidNotMatchRequestedTypeWarn Property
BuiltInFailures..::..AssemblyFailures Class See Also Send Feedback
Assembly was changed to a new type, but did not match the type. Geometry could have been changed due to a join condition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AssemblyDidNotMatchRequestedTypeWarn { get; }
Visual Basic
Public Shared ReadOnly Property AssemblyDidNotMatchRequestedTypeWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AssemblyDidNotMatchRequestedTypeWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AssemblyFailures Class


AssemblyDisassembleInstanceWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..AssemblyFailures..::..AssemblyDisassembleInstanceWarn Property
BuiltInFailures..::..AssemblyFailures Class See Also Send Feedback
Edits to these assemblies changed the naming category and name of these assemblies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AssemblyDisassembleInstanceWarn { get; }
Visual Basic
Public Shared ReadOnly Property AssemblyDisassembleInstanceWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AssemblyDisassembleInstanceWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AssemblyFailures Class


AssemblyNewTypeWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..AssemblyFailures..::..AssemblyNewTypeWarn Property
BuiltInFailures..::..AssemblyFailures Class See Also Send Feedback
Edits to these assemblies match existing type and will inherit that name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AssemblyNewTypeWarn { get; }
Visual Basic
Public Shared ReadOnly Property AssemblyNewTypeWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AssemblyNewTypeWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AssemblyFailures Class


AssemblyRenameTypeWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..AssemblyFailures..::..AssemblyRenameTypeWarn Property
BuiltInFailures..::..AssemblyFailures Class See Also Send Feedback
Edits to these assemblies changed the naming category and name of these assemblies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AssemblyRenameTypeWarn { get; }
Visual Basic
Public Shared ReadOnly Property AssemblyRenameTypeWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AssemblyRenameTypeWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AssemblyFailures Class


CouldNotAcquireAssemblyViews Property

[image]

Revit 2024 API
BuiltInFailures..::..AssemblyFailures..::..CouldNotAcquireAssemblyViews Property
BuiltInFailures..::..AssemblyFailures Class See Also Send Feedback
The assembly instance could not acquire the assembly views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CouldNotAcquireAssemblyViews { get; }
Visual Basic
Public Shared ReadOnly Property CouldNotAcquireAssemblyViews As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CouldNotAcquireAssemblyViews {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AssemblyFailures Class


DeleteAssemblyInstWithViewsWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..AssemblyFailures..::..DeleteAssemblyInstWithViewsWarn Property
BuiltInFailures..::..AssemblyFailures Class See Also Send Feedback
Deleting this assembly will remove the assembly from the project and any views associated with that assembly.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DeleteAssemblyInstWithViewsWarn { get; }
Visual Basic
Public Shared ReadOnly Property DeleteAssemblyInstWithViewsWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DeleteAssemblyInstWithViewsWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AssemblyFailures Class


DeleteShopDrawingsWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..AssemblyFailures..::..DeleteShopDrawingsWarn Property
BuiltInFailures..::..AssemblyFailures Class See Also Send Feedback
The assembly instance has associated views and cannot be merged with assembly type '%1!s!'. Delete the views to continue.\n\nViews:%2!s!

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DeleteShopDrawingsWarn { get; }
Visual Basic
Public Shared ReadOnly Property DeleteShopDrawingsWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DeleteShopDrawingsWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AssemblyFailures Class


ElementsNotAllowedAreNotAddedToAssembly Property

[image]

Revit 2024 API
BuiltInFailures..::..AssemblyFailures..::..ElementsNotAllowedAreNotAddedToAssembly Property
BuiltInFailures..::..AssemblyFailures Class See Also Send Feedback
Elements not allowed in Assembly were not added to it, but only in the document

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ElementsNotAllowedAreNotAddedToAssembly { get; }
Visual Basic
Public Shared ReadOnly Property ElementsNotAllowedAreNotAddedToAssembly As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementsNotAllowedAreNotAddedToAssembly {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AssemblyFailures Class


MixedPhasesInAssembly Property

[image]

Revit 2024 API
BuiltInFailures..::..AssemblyFailures..::..MixedPhasesInAssembly Property
BuiltInFailures..::..AssemblyFailures Class See Also Send Feedback
Assembly cannot be created. All elements must have the same phases to be included in an assembly.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MixedPhasesInAssembly { get; }
Visual Basic
Public Shared ReadOnly Property MixedPhasesInAssembly As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MixedPhasesInAssembly {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AssemblyFailures Class


NoElementsLeftInExistingAssembly Property

[image]

Revit 2024 API
BuiltInFailures..::..AssemblyFailures..::..NoElementsLeftInExistingAssembly Property
BuiltInFailures..::..AssemblyFailures Class See Also Send Feedback
There are no elements left in the assembly. It will be disassembled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoElementsLeftInExistingAssembly { get; }
Visual Basic
Public Shared ReadOnly Property NoElementsLeftInExistingAssembly As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoElementsLeftInExistingAssembly {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AssemblyFailures Class


SomeElementsPreventAssemblyTypeChange Property

[image]

Revit 2024 API
BuiltInFailures..::..AssemblyFailures..::..SomeElementsPreventAssemblyTypeChange Property
BuiltInFailures..::..AssemblyFailures Class See Also Send Feedback
Assembly cannot be changed to selected type. Some elements in the target assembly prevent the type change from occurring. These tend to be parts and nested elements such as mullion, curtain panels, and members of trusses.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SomeElementsPreventAssemblyTypeChange { get; }
Visual Basic
Public Shared ReadOnly Property SomeElementsPreventAssemblyTypeChange As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SomeElementsPreventAssemblyTypeChange {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AssemblyFailures Class


BuiltInFailures.AutoJoinFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..AutoJoinFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about AutoJoin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class AutoJoinFailures
Visual Basic
Public NotInheritable Class AutoJoinFailures
Visual C++
public ref class AutoJoinFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..AutoJoinFailures

See Also

BuiltInFailures..::..AutoJoinFailures Members


DesignOptionAndWorksetViolation Property

[image]

Revit 2024 API
BuiltInFailures..::..AutoJoinFailures..::..DesignOptionAndWorksetViolation Property
BuiltInFailures..::..AutoJoinFailures Class See Also Send Feedback
Can't make the expected join because of editability and design option restrictions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DesignOptionAndWorksetViolation { get; }
Visual Basic
Public Shared ReadOnly Property DesignOptionAndWorksetViolation As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DesignOptionAndWorksetViolation {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoJoinFailures Class


DesignOptionCannotReference Property

[image]

Revit 2024 API
BuiltInFailures..::..AutoJoinFailures..::..DesignOptionCannotReference Property
BuiltInFailures..::..AutoJoinFailures Class See Also Send Feedback
Design Option ' [Name] ' cannot reference Design Option ' [Name] '.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DesignOptionCannotReference { get; }
Visual Basic
Public Shared ReadOnly Property DesignOptionCannotReference As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DesignOptionCannotReference {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoJoinFailures Class


OtherNonEditJoinFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..AutoJoinFailures..::..OtherNonEditJoinFailure Property
BuiltInFailures..::..AutoJoinFailures Class See Also Send Feedback
Two elements were not automatically joined because other elements at join are not editable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId OtherNonEditJoinFailure { get; }
Visual Basic
Public Shared ReadOnly Property OtherNonEditJoinFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OtherNonEditJoinFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoJoinFailures Class


UnexpectedJoinFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..AutoJoinFailures..::..UnexpectedJoinFailure Property
BuiltInFailures..::..AutoJoinFailures Class See Also Send Feedback
Join failure caused by editability or design option related problem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UnexpectedJoinFailure { get; }
Visual Basic
Public Shared ReadOnly Property UnexpectedJoinFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnexpectedJoinFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoJoinFailures Class


Unknown Property

[image]

Revit 2024 API
BuiltInFailures..::..AutoJoinFailures..::..Unknown Property
BuiltInFailures..::..AutoJoinFailures Class See Also Send Feedback
Unknown

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId Unknown { get; }
Visual Basic
Public Shared ReadOnly Property Unknown As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ Unknown {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoJoinFailures Class


WorksetJoinWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..AutoJoinFailures..::..WorksetJoinWarn Property
BuiltInFailures..::..AutoJoinFailures Class See Also Send Feedback
Two elements were not automatically joined because one or both is not editable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WorksetJoinWarn { get; }
Visual Basic
Public Shared ReadOnly Property WorksetJoinWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WorksetJoinWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoJoinFailures Class


BuiltInFailures.AutoRouteFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..AutoRouteFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about AutoRoute.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class AutoRouteFailures
Visual Basic
Public NotInheritable Class AutoRouteFailures
Visual C++
public ref class AutoRouteFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..AutoRouteFailures

See Also

BuiltInFailures..::..AutoRouteFailures Members


BuiltInFailures.AutoRouteFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..AutoRouteFailures Properties
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback

The BuiltInFailures..::..AutoRouteFailures type exposes the following members.

Properties

Name | Description
AttemptToConnectNonSlopingElementToSlopedPipeError | You have specified that sloped pipe be drawn, but are trying to connect to an element that doesn't support sloping connections.
AttemptToConnectNonSlopingElementToSlopedPipeWarning | You have specified that sloped pipe be drawn, but are trying to connect to an element that doesn't support sloping connections.
DesignOptionConflictError | The solution is failing to do the elements are not in the same Design Option.
DesignOptionConflictWarning | The solution is failing to do the elements are not in the same Design Option.
DistributionTypeInvalid | Selected distribution system type is invalid!
ElementHasFlowCalculation | This element has an open connection. This may not be an error, but for flow calculations to work correctly all connections should be sealed with an end cap.
ElementHasOpenConnection | This element has an open connection. This may not be an error, but all open connections should be sealed with an end cap.
FailedDowngradeCrossToElbow | Failed to downgrade tee type to elbow type.
FailedDowngradeCrossToTee | Failed to downgrade cross type to tee type.
FailedDowngradeTeeToCross | Failed to upgrade tee type to cross type.
FailToDoCompatiblePhaseError | The solution is failing to do the elements Phases are compatible.
FailToDoCompatiblePhaseWarning | The solution is failing to do the elements Phases are compatible.
FailToIntersectParallelSegmentsError | The solution is failing to do segments which are parallel and should intersect.
FailToIntersectParallelSegmentsWarning | The solution is failing to do segments which are parallel and should intersect.
FittingParamsCauseGeometryToFailError | The one of parameters for the fitting is causing the geometry to fail.
FittingParamsCauseGeometryToFailWarning | The one of parameters for the fitting is causing the geometry to fail.
HighlightedElementDisconnected | The highlighted element has been disconnected.
InappropriateSlopeForPipe | The slope that you specified could not be applied to this pipe. Please check the items that it is connected to and make sure that they aren't constraining the slope of them.
MismatchedSystemClassificationHasSystemWarning | The selected fixture is part of a system with different classification. System calculations (e.g. flow analysis) are not possible between systems with different classifications.
MismatchedSystemClassificationNoSystemWarning | The selected fixture is assigned to a system with different classification.
MismatchedSystemTypeWarning | The selected fixture is part of a different system. You may want to edit the system type and merge two systems.
NoAutoRouteSolutionFoundError | No auto-route solution was found.
NoAutoRouteSolutionFoundWarning | No auto-route solution was found.
NoFittingInProjectError | The routing solution failed because there is no default fitting type specified or the fitting cannot be found in the project. Ensure the fitting is loaded in the project and try again.
NoFittingInProjectWarning | The routing solution failed because there is no default fitting type specified or the fitting cannot be found in the project. Ensure the fitting is loaded in the project and try again.
NoFittingInRoutingError | The fitting that is converted to was not defined. Please assign one in the routing preference.
NoFittingLoadedInProjectError | The fitting that is converted to was not defined. Please load one fitting family and assign it in the routing preference.
NoSolutionInView | There is no solution for this view. All the elements have been filtered for this view, select another view, and select solutions.
NotAllPartsWereConvertedCannotAddPlaceholderWarning | Not all parts were converted. Placeholders could not be added to fill the gap (the gap was too small). Check the fabrication service definition for the system.
NotAllPartsWereConvertedPlaceholdersWereAddedWarning | Not all parts were converted. Placeholders were added to fill the gaps. Check the fabrication service definition for the system.
NotEnoughRoomForFittingsError | There was not enough room to place the required fittings. Consider increasing the length of the segments, or moving them farther apart to generate a solution.
NotEnoughRoomForFittingsWarning | There was not enough room to place the required fittings. Consider increasing the length of the segments, or moving them farther apart to generate a solution.
NoValidSolutionAtSelectedPoint | No valid auto-route solution at selected point.
OverrideFabricationPartFailed | The fabrication part cannot be overridden. The button code you specified does not match the fabrication service. Please specify a different button code or check the fabrication service and try again.
SegmentDrawnFromWrongSideError | The segment is being drawn from the wrong side to connect to the location you indicated.
SegmentDrawnFromWrongSideWarning | The segment is being drawn from the wrong side to connect to the location you indicated.
SegmentsAngleTooGreatError | The resulting angle between the segments is too great.
SegmentsAngleTooGreatWarning | The resulting angle between the segments is too great.
SolutionIsOppositeToConnectionError | The solution is in the opposite direction of the connection direction.
SolutionIsOppositeToConnectionWarning | The solution is in the opposite direction of the connection direction.
SpecifiedAnglesNotCompatibleWithLayoutError | The specified angles are not compatible with current layout.
SpecifiedAnglesNotCompatibleWithLayoutWarning | The specified angles are not compatible with current layout.
UnableToMakeConnectionInDirection | The application is unable to make a connection in that direction. If the connectors are pointing up, make sure that the elevations of the segments (ducts and pipes) are above them. If the connectors are pointing down, make sure that the elevations of the segments (ducts and pipes) are below them.
UtilizationCoefficientOutOfRange | The value for Coefficient of Utilization must be between 0 and 1.
ZeroLengthSegmentError | The solution is failing to do segments which are zero length.
ZeroLengthSegmentWarning | The solution is failing to do segments which are zero length.

See Also

BuiltInFailures..::..AutoRouteFailures Class


AttemptToConnectNonSlopingElementToSlopedPipeWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..AutoRouteFailures..::..AttemptToConnectNonSlopingElementToSlopedPipeWarning Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
You have specified that sloped pipe be drawn, but are trying to connect to an element that doesn't support sloping connections.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AttemptToConnectNonSlopingElementToSlopedPipeWarning { get; }
Visual Basic
Public Shared ReadOnly Property AttemptToConnectNonSlopingElementToSlopedPipeWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AttemptToConnectNonSlopingElementToSlopedPipeWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


DesignOptionConflictError Property

[image]

Revit 2024 API
BuiltInFailures..::..AutoRouteFailures..::..DesignOptionConflictError Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
The solution is failing to do the elements are not in the same Design Option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DesignOptionConflictError { get; }
Visual Basic
Public Shared ReadOnly Property DesignOptionConflictError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DesignOptionConflictError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


DesignOptionConflictWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..AutoRouteFailures..::..DesignOptionConflictWarning Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
The solution is failing to do the elements are not in the same Design Option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DesignOptionConflictWarning { get; }
Visual Basic
Public Shared ReadOnly Property DesignOptionConflictWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DesignOptionConflictWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


DistributionTypeInvalid Property

[image]

Revit 2024 API
BuiltInFailures..::..AutoRouteFailures..::..DistributionTypeInvalid Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
Selected distribution system type is invalid!

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DistributionTypeInvalid { get; }
Visual Basic
Public Shared ReadOnly Property DistributionTypeInvalid As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DistributionTypeInvalid {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


ElementHasFlowCalculation Property

[image]

Revit 2024 API
BuiltInFailures..::..AutoRouteFailures..::..ElementHasFlowCalculation Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
This element has an open connection. This may not be an error, but for flow calculations to work correctly all connections should be sealed with an end cap.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ElementHasFlowCalculation { get; }
Visual Basic
Public Shared ReadOnly Property ElementHasFlowCalculation As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementHasFlowCalculation {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


ElementHasOpenConnection Property

[image]

Revit 2024 API
BuiltInFailures..::..AutoRouteFailures..::..ElementHasOpenConnection Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
This element has an open connection. This may not be an error, but all open connections should be sealed with an end cap.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ElementHasOpenConnection { get; }
Visual Basic
Public Shared ReadOnly Property ElementHasOpenConnection As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementHasOpenConnection {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


FailedDowngradeCrossToTee Property

[image]

Revit 2024 API
BuiltInFailures..::..AutoRouteFailures..::..FailedDowngradeCrossToTee Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
Failed to downgrade cross type to tee type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FailedDowngradeCrossToTee { get; }
Visual Basic
Public Shared ReadOnly Property FailedDowngradeCrossToTee As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FailedDowngradeCrossToTee {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


FailedDowngradeTeeToCross Property

[image]

Revit 2024 API
BuiltInFailures..::..AutoRouteFailures..::..FailedDowngradeTeeToCross Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
Failed to upgrade tee type to cross type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FailedDowngradeTeeToCross { get; }
Visual Basic
Public Shared ReadOnly Property FailedDowngradeTeeToCross As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FailedDowngradeTeeToCross {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


FailToDoCompatiblePhaseError Property

[image]

Revit 2024 API
BuiltInFailures..::..AutoRouteFailures..::..FailToDoCompatiblePhaseError Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
The solution is failing to do the elements Phases are compatible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FailToDoCompatiblePhaseError { get; }
Visual Basic
Public Shared ReadOnly Property FailToDoCompatiblePhaseError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FailToDoCompatiblePhaseError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


FailToDoCompatiblePhaseWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..AutoRouteFailures..::..FailToDoCompatiblePhaseWarning Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
The solution is failing to do the elements Phases are compatible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FailToDoCompatiblePhaseWarning { get; }
Visual Basic
Public Shared ReadOnly Property FailToDoCompatiblePhaseWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FailToDoCompatiblePhaseWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


FailToIntersectParallelSegmentsError Property

[image]

Revit 2024 API
BuiltInFailures..::..AutoRouteFailures..::..FailToIntersectParallelSegmentsError Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
The solution is failing to do segments which are parallel and should intersect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FailToIntersectParallelSegmentsError { get; }
Visual Basic
Public Shared ReadOnly Property FailToIntersectParallelSegmentsError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FailToIntersectParallelSegmentsError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


FailToIntersectParallelSegmentsWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..AutoRouteFailures..::..FailToIntersectParallelSegmentsWarning Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
The solution is failing to do segments which are parallel and should intersect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FailToIntersectParallelSegmentsWarning { get; }
Visual Basic
Public Shared ReadOnly Property FailToIntersectParallelSegmentsWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FailToIntersectParallelSegmentsWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


InappropriateSlopeForPipe Property

[image]

Revit 2024 API
BuiltInFailures..::..AutoRouteFailures..::..InappropriateSlopeForPipe Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
The slope that you specified could not be applied to this pipe. Please check the items that it is connected to and make sure that they aren't constraining the slope of them.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InappropriateSlopeForPipe { get; }
Visual Basic
Public Shared ReadOnly Property InappropriateSlopeForPipe As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InappropriateSlopeForPipe {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


MismatchedSystemClassificationHasSystemWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..AutoRouteFailures..::..MismatchedSystemClassificationHasSystemWarning Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
The selected fixture is part of a system with different classification. System calculations (e.g. flow analysis) are not possible between systems with different classifications.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MismatchedSystemClassificationHasSystemWarning { get; }
Visual Basic
Public Shared ReadOnly Property MismatchedSystemClassificationHasSystemWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MismatchedSystemClassificationHasSystemWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


MismatchedSystemTypeWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..AutoRouteFailures..::..MismatchedSystemTypeWarning Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
The selected fixture is part of a different system. You may want to edit the system type and merge two systems.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MismatchedSystemTypeWarning { get; }
Visual Basic
Public Shared ReadOnly Property MismatchedSystemTypeWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MismatchedSystemTypeWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


NoAutoRouteSolutionFoundError Property

[image]

Revit 2024 API
BuiltInFailures..::..AutoRouteFailures..::..NoAutoRouteSolutionFoundError Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
No auto-route solution was found.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoAutoRouteSolutionFoundError { get; }
Visual Basic
Public Shared ReadOnly Property NoAutoRouteSolutionFoundError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoAutoRouteSolutionFoundError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


NoFittingInProjectError Property

[image]

Revit 2024 API
BuiltInFailures..::..AutoRouteFailures..::..NoFittingInProjectError Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
The routing solution failed because there is no default fitting type specified or the fitting cannot be found in the project. Ensure the fitting is loaded in the project and try again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoFittingInProjectError { get; }
Visual Basic
Public Shared ReadOnly Property NoFittingInProjectError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoFittingInProjectError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


NoFittingInProjectWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..AutoRouteFailures..::..NoFittingInProjectWarning Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
The routing solution failed because there is no default fitting type specified or the fitting cannot be found in the project. Ensure the fitting is loaded in the project and try again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoFittingInProjectWarning { get; }
Visual Basic
Public Shared ReadOnly Property NoFittingInProjectWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoFittingInProjectWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


NoFittingInRoutingError Property

[image]

Revit 2024 API
BuiltInFailures..::..AutoRouteFailures..::..NoFittingInRoutingError Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
The fitting that is converted to was not defined. Please assign one in the routing preference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoFittingInRoutingError { get; }
Visual Basic
Public Shared ReadOnly Property NoFittingInRoutingError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoFittingInRoutingError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


NoFittingLoadedInProjectError Property

[image]

Revit 2024 API
BuiltInFailures..::..AutoRouteFailures..::..NoFittingLoadedInProjectError Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
The fitting that is converted to was not defined. Please load one fitting family and assign it in the routing preference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoFittingLoadedInProjectError { get; }
Visual Basic
Public Shared ReadOnly Property NoFittingLoadedInProjectError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoFittingLoadedInProjectError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


NotAllPartsWereConvertedCannotAddPlaceholderWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..AutoRouteFailures..::..NotAllPartsWereConvertedCannotAddPlaceholderWarning Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
Not all parts were converted. Placeholders could not be added to fill the gap (the gap was too small). Check the fabrication service definition for the system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NotAllPartsWereConvertedCannotAddPlaceholderWarning { get; }
Visual Basic
Public Shared ReadOnly Property NotAllPartsWereConvertedCannotAddPlaceholderWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotAllPartsWereConvertedCannotAddPlaceholderWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


NotEnoughRoomForFittingsError Property

[image]

Revit 2024 API
BuiltInFailures..::..AutoRouteFailures..::..NotEnoughRoomForFittingsError Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
There was not enough room to place the required fittings. Consider increasing the length of the segments, or moving them farther apart to generate a solution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NotEnoughRoomForFittingsError { get; }
Visual Basic
Public Shared ReadOnly Property NotEnoughRoomForFittingsError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotEnoughRoomForFittingsError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


NotEnoughRoomForFittingsWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..AutoRouteFailures..::..NotEnoughRoomForFittingsWarning Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
There was not enough room to place the required fittings. Consider increasing the length of the segments, or moving them farther apart to generate a solution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NotEnoughRoomForFittingsWarning { get; }
Visual Basic
Public Shared ReadOnly Property NotEnoughRoomForFittingsWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotEnoughRoomForFittingsWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


NoValidSolutionAtSelectedPoint Property

[image]

Revit 2024 API
BuiltInFailures..::..AutoRouteFailures..::..NoValidSolutionAtSelectedPoint Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
No valid auto-route solution at selected point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoValidSolutionAtSelectedPoint { get; }
Visual Basic
Public Shared ReadOnly Property NoValidSolutionAtSelectedPoint As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoValidSolutionAtSelectedPoint {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


OverrideFabricationPartFailed Property

[image]

Revit 2024 API
BuiltInFailures..::..AutoRouteFailures..::..OverrideFabricationPartFailed Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
The fabrication part cannot be overridden. The button code you specified does not match the fabrication service. Please specify a different button code or check the fabrication service and try again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId OverrideFabricationPartFailed { get; }
Visual Basic
Public Shared ReadOnly Property OverrideFabricationPartFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OverrideFabricationPartFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


SegmentDrawnFromWrongSideWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..AutoRouteFailures..::..SegmentDrawnFromWrongSideWarning Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
The segment is being drawn from the wrong side to connect to the location you indicated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SegmentDrawnFromWrongSideWarning { get; }
Visual Basic
Public Shared ReadOnly Property SegmentDrawnFromWrongSideWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SegmentDrawnFromWrongSideWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


SegmentsAngleTooGreatError Property

[image]

Revit 2024 API
BuiltInFailures..::..AutoRouteFailures..::..SegmentsAngleTooGreatError Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
The resulting angle between the segments is too great.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SegmentsAngleTooGreatError { get; }
Visual Basic
Public Shared ReadOnly Property SegmentsAngleTooGreatError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SegmentsAngleTooGreatError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


SegmentsAngleTooGreatWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..AutoRouteFailures..::..SegmentsAngleTooGreatWarning Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
The resulting angle between the segments is too great.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SegmentsAngleTooGreatWarning { get; }
Visual Basic
Public Shared ReadOnly Property SegmentsAngleTooGreatWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SegmentsAngleTooGreatWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


SolutionIsOppositeToConnectionError Property

[image]

Revit 2024 API
BuiltInFailures..::..AutoRouteFailures..::..SolutionIsOppositeToConnectionError Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
The solution is in the opposite direction of the connection direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SolutionIsOppositeToConnectionError { get; }
Visual Basic
Public Shared ReadOnly Property SolutionIsOppositeToConnectionError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SolutionIsOppositeToConnectionError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


SolutionIsOppositeToConnectionWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..AutoRouteFailures..::..SolutionIsOppositeToConnectionWarning Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
The solution is in the opposite direction of the connection direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SolutionIsOppositeToConnectionWarning { get; }
Visual Basic
Public Shared ReadOnly Property SolutionIsOppositeToConnectionWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SolutionIsOppositeToConnectionWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


UnableToMakeConnectionInDirection Property

[image]

Revit 2024 API
BuiltInFailures..::..AutoRouteFailures..::..UnableToMakeConnectionInDirection Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
The application is unable to make a connection in that direction. If the connectors are pointing up, make sure that the elevations of the segments (ducts and pipes) are above them. If the connectors are pointing down, make sure that the elevations of the segments (ducts and pipes) are below them.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UnableToMakeConnectionInDirection { get; }
Visual Basic
Public Shared ReadOnly Property UnableToMakeConnectionInDirection As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableToMakeConnectionInDirection {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


UtilizationCoefficientOutOfRange Property

[image]

Revit 2024 API
BuiltInFailures..::..AutoRouteFailures..::..UtilizationCoefficientOutOfRange Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
The value for Coefficient of Utilization must be between 0 and 1.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UtilizationCoefficientOutOfRange { get; }
Visual Basic
Public Shared ReadOnly Property UtilizationCoefficientOutOfRange As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UtilizationCoefficientOutOfRange {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


ZeroLengthSegmentError Property

[image]

Revit 2024 API
BuiltInFailures..::..AutoRouteFailures..::..ZeroLengthSegmentError Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
The solution is failing to do segments which are zero length.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ZeroLengthSegmentError { get; }
Visual Basic
Public Shared ReadOnly Property ZeroLengthSegmentError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ZeroLengthSegmentError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


ZeroLengthSegmentWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..AutoRouteFailures..::..ZeroLengthSegmentWarning Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
The solution is failing to do segments which are zero length.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ZeroLengthSegmentWarning { get; }
Visual Basic
Public Shared ReadOnly Property ZeroLengthSegmentWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ZeroLengthSegmentWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


BuiltInFailures.BeamFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..BeamFailures Members
BuiltInFailures..::..BeamFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..BeamFailures type exposes the following members.

Properties

Name | Description
CannotBendBeamType | Can't bend beam type "[Type Name]" along its location line. The beam is either too large or its curve is too sharp. You may be able to resolve the problem by reducing the beam's width in the bending direction, or by reducing acute angles in the curve.

See Also

BuiltInFailures..::..BeamFailures Class


BuiltInFailures.BeamFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..BeamFailures Properties
BuiltInFailures..::..BeamFailures Class See Also Send Feedback

The BuiltInFailures..::..BeamFailures type exposes the following members.

Properties

Name | Description
CannotBendBeamType | Can't bend beam type "[Type Name]" along its location line. The beam is either too large or its curve is too sharp. You may be able to resolve the problem by reducing the beam's width in the bending direction, or by reducing acute angles in the curve.

See Also

BuiltInFailures..::..BeamFailures Class


CannotBendBeamType Property

[image]

Revit 2024 API
BuiltInFailures..::..BeamFailures..::..CannotBendBeamType Property
BuiltInFailures..::..BeamFailures Class See Also Send Feedback
Can't bend beam type "[Type Name]" along its location line. The beam is either too large or its curve is too sharp. You may be able to resolve the problem by reducing the beam's width in the bending direction, or by reducing acute angles in the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotBendBeamType { get; }
Visual Basic
Public Shared ReadOnly Property CannotBendBeamType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotBendBeamType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..BeamFailures Class


BuiltInFailures.BeamSystemFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..BeamSystemFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about BeamSystem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class BeamSystemFailures
Visual Basic
Public NotInheritable Class BeamSystemFailures
Visual C++
public ref class BeamSystemFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..BeamSystemFailures

See Also

BuiltInFailures..::..BeamSystemFailures Members


BeamSystemEdgeBeamTooWide Property

[image]

Revit 2024 API
BuiltInFailures..::..BeamSystemFailures..::..BeamSystemEdgeBeamTooWide Property
BuiltInFailures..::..BeamSystemFailures Class See Also Send Feedback
Beam of user-defined type does not fit into beam system with clear spacing layout rule. Beam type is reset to default.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId BeamSystemEdgeBeamTooWide { get; }
Visual Basic
Public Shared ReadOnly Property BeamSystemEdgeBeamTooWide As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BeamSystemEdgeBeamTooWide {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..BeamSystemFailures Class


BeamSystemHasTooManyBeams Property

[image]

Revit 2024 API
BuiltInFailures..::..BeamSystemFailures..::..BeamSystemHasTooManyBeams Property
BuiltInFailures..::..BeamSystemFailures Class See Also Send Feedback
A beam system is trying to create more than 500 beams. Please use multiple beam systems if more than 500 beams are desired.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId BeamSystemHasTooManyBeams { get; }
Visual Basic
Public Shared ReadOnly Property BeamSystemHasTooManyBeams As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BeamSystemHasTooManyBeams {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..BeamSystemFailures Class


BeamSystemTagBadView Property

[image]

Revit 2024 API
BuiltInFailures..::..BeamSystemFailures..::..BeamSystemTagBadView Property
BuiltInFailures..::..BeamSystemFailures Class See Also Send Feedback
Beam System Tags can only be placed in plan , elevation and 3D views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId BeamSystemTagBadView { get; }
Visual Basic
Public Shared ReadOnly Property BeamSystemTagBadView As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BeamSystemTagBadView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..BeamSystemFailures Class


BuiltInFailures.BendFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..BendFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Bends.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class BendFailures
Visual Basic
Public NotInheritable Class BendFailures
Visual C++
public ref class BendFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..BendFailures

See Also

BuiltInFailures..::..BendFailures Members


BuiltInFailures.BendFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..BendFailures Properties
BuiltInFailures..::..BendFailures Class See Also Send Feedback

The BuiltInFailures..::..BendFailures type exposes the following members.

Properties

Name | Description
BendAngleIsUnacceptable | The angle of the bend/elbow is unacceptable
DeleteMiddleBendNotAllowed | Delete a middle bend in a bank is not allowed
DeleteSegmentInBankNotAllowed | Delete a segment in a bank is not allowed
NotBentControl | While making curved beam type "[Type Name]" some Control elements were not created
NotBentDetailComponent | While making curved beam type "[Type Name]" 2D Detail Component elements were not created
NotBentFilledRegion | While making curved beam type "[Type Name]" Filled Region elements were not created
NotBentImage | While making curved beam type "[Type Name]" Image elements were not created
NotBentImport | While making curved beam type "[Type Name]" CAD File elements were not created
NotBentMaskingRegion | While making curved beam type "[Type Name]" Masking Region elements were not created
NotBentModelLine | While making curved beam type "[Type Name]" some Model Line elements were not created
NotBentOpening | While making curved beam type "[Type Name]" Opening elements were not created
NotBentRefLine | While making curved beam type "[Type Name]" some Reference Line elements were not created
NotBentRefPlane | While making curved beam type "[Type Name]" some Reference Plane elements were not created
NotBentSharedFamily | While making curved beam type "[Type Name]" Shared Family Instances were not created
NotBentSymbol | While making curved beam type "[Type Name]" Symbol elements were not created
NotBentSymbolicLine | While making curved beam type "[Type Name]" some Symbolic Line elements were not created

See Also

BuiltInFailures..::..BendFailures Class


BendAngleIsUnacceptable Property

[image]

Revit 2024 API
BuiltInFailures..::..BendFailures..::..BendAngleIsUnacceptable Property
BuiltInFailures..::..BendFailures Class See Also Send Feedback
The angle of the bend/elbow is unacceptable

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId BendAngleIsUnacceptable { get; }
Visual Basic
Public Shared ReadOnly Property BendAngleIsUnacceptable As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BendAngleIsUnacceptable {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..BendFailures Class


DeleteMiddleBendNotAllowed Property

[image]

Revit 2024 API
BuiltInFailures..::..BendFailures..::..DeleteMiddleBendNotAllowed Property
BuiltInFailures..::..BendFailures Class See Also Send Feedback
Delete a middle bend in a bank is not allowed

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DeleteMiddleBendNotAllowed { get; }
Visual Basic
Public Shared ReadOnly Property DeleteMiddleBendNotAllowed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DeleteMiddleBendNotAllowed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..BendFailures Class


DeleteSegmentInBankNotAllowed Property

[image]

Revit 2024 API
BuiltInFailures..::..BendFailures..::..DeleteSegmentInBankNotAllowed Property
BuiltInFailures..::..BendFailures Class See Also Send Feedback
Delete a segment in a bank is not allowed

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DeleteSegmentInBankNotAllowed { get; }
Visual Basic
Public Shared ReadOnly Property DeleteSegmentInBankNotAllowed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DeleteSegmentInBankNotAllowed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..BendFailures Class


NotBentControl Property

[image]

Revit 2024 API
BuiltInFailures..::..BendFailures..::..NotBentControl Property
BuiltInFailures..::..BendFailures Class See Also Send Feedback
While making curved beam type "[Type Name]" some Control elements were not created

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NotBentControl { get; }
Visual Basic
Public Shared ReadOnly Property NotBentControl As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotBentControl {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..BendFailures Class


NotBentDetailComponent Property

[image]

Revit 2024 API
BuiltInFailures..::..BendFailures..::..NotBentDetailComponent Property
BuiltInFailures..::..BendFailures Class See Also Send Feedback
While making curved beam type "[Type Name]" 2D Detail Component elements were not created

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NotBentDetailComponent { get; }
Visual Basic
Public Shared ReadOnly Property NotBentDetailComponent As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotBentDetailComponent {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..BendFailures Class


NotBentImage Property

[image]

Revit 2024 API
BuiltInFailures..::..BendFailures..::..NotBentImage Property
BuiltInFailures..::..BendFailures Class See Also Send Feedback
While making curved beam type "[Type Name]" Image elements were not created

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NotBentImage { get; }
Visual Basic
Public Shared ReadOnly Property NotBentImage As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotBentImage {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..BendFailures Class


NotBentImport Property

[image]

Revit 2024 API
BuiltInFailures..::..BendFailures..::..NotBentImport Property
BuiltInFailures..::..BendFailures Class See Also Send Feedback
While making curved beam type "[Type Name]" CAD File elements were not created

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NotBentImport { get; }
Visual Basic
Public Shared ReadOnly Property NotBentImport As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotBentImport {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..BendFailures Class


NotBentMaskingRegion Property

[image]

Revit 2024 API
BuiltInFailures..::..BendFailures..::..NotBentMaskingRegion Property
BuiltInFailures..::..BendFailures Class See Also Send Feedback
While making curved beam type "[Type Name]" Masking Region elements were not created

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NotBentMaskingRegion { get; }
Visual Basic
Public Shared ReadOnly Property NotBentMaskingRegion As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotBentMaskingRegion {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..BendFailures Class


NotBentModelLine Property

[image]

Revit 2024 API
BuiltInFailures..::..BendFailures..::..NotBentModelLine Property
BuiltInFailures..::..BendFailures Class See Also Send Feedback
While making curved beam type "[Type Name]" some Model Line elements were not created

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NotBentModelLine { get; }
Visual Basic
Public Shared ReadOnly Property NotBentModelLine As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotBentModelLine {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..BendFailures Class


NotBentOpening Property

[image]

Revit 2024 API
BuiltInFailures..::..BendFailures..::..NotBentOpening Property
BuiltInFailures..::..BendFailures Class See Also Send Feedback
While making curved beam type "[Type Name]" Opening elements were not created

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NotBentOpening { get; }
Visual Basic
Public Shared ReadOnly Property NotBentOpening As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotBentOpening {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..BendFailures Class


NotBentRefPlane Property

[image]

Revit 2024 API
BuiltInFailures..::..BendFailures..::..NotBentRefPlane Property
BuiltInFailures..::..BendFailures Class See Also Send Feedback
While making curved beam type "[Type Name]" some Reference Plane elements were not created

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NotBentRefPlane { get; }
Visual Basic
Public Shared ReadOnly Property NotBentRefPlane As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotBentRefPlane {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..BendFailures Class


NotBentSharedFamily Property

[image]

Revit 2024 API
BuiltInFailures..::..BendFailures..::..NotBentSharedFamily Property
BuiltInFailures..::..BendFailures Class See Also Send Feedback
While making curved beam type "[Type Name]" Shared Family Instances were not created

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NotBentSharedFamily { get; }
Visual Basic
Public Shared ReadOnly Property NotBentSharedFamily As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotBentSharedFamily {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..BendFailures Class


NotBentSymbol Property

[image]

Revit 2024 API
BuiltInFailures..::..BendFailures..::..NotBentSymbol Property
BuiltInFailures..::..BendFailures Class See Also Send Feedback
While making curved beam type "[Type Name]" Symbol elements were not created

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NotBentSymbol { get; }
Visual Basic
Public Shared ReadOnly Property NotBentSymbol As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotBentSymbol {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..BendFailures Class


NotBentSymbolicLine Property

[image]

Revit 2024 API
BuiltInFailures..::..BendFailures..::..NotBentSymbolicLine Property
BuiltInFailures..::..BendFailures Class See Also Send Feedback
While making curved beam type "[Type Name]" some Symbolic Line elements were not created

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NotBentSymbolicLine { get; }
Visual Basic
Public Shared ReadOnly Property NotBentSymbolicLine As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotBentSymbolicLine {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..BendFailures Class


BuiltInFailures.BlendFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..BlendFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Blend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class BlendFailures
Visual Basic
Public NotInheritable Class BlendFailures
Visual C++
public ref class BlendFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..BlendFailures

See Also

BuiltInFailures..::..BlendFailures Members


BuiltInFailures.BlendFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..BlendFailures Members
BuiltInFailures..::..BlendFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..BlendFailures type exposes the following members.

Properties

Name | Description
CannotDrawBlend | Can't create blend.

See Also

BuiltInFailures..::..BlendFailures Class


BuiltInFailures.ColorFillFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..ColorFillFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about ColorFill.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class ColorFillFailures
Visual Basic
Public NotInheritable Class ColorFillFailures
Visual C++
public ref class ColorFillFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..ColorFillFailures

See Also

BuiltInFailures..::..ColorFillFailures Members


BuiltInFailures.ColorFillFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..ColorFillFailures Members
BuiltInFailures..::..ColorFillFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..ColorFillFailures type exposes the following members.

Properties

Name | Description
OnlyOneColorFillNonPlan | A Color Fill Legend can only be placed in a Floor Plan View or a Section View.
SymtemColorFillLegendNotAllowed | [Category name] Color Fill Legend can only be placed in a Floor Plan View.

See Also

BuiltInFailures..::..ColorFillFailures Class


BuiltInFailures.ColorFillFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..ColorFillFailures Properties
BuiltInFailures..::..ColorFillFailures Class See Also Send Feedback

The BuiltInFailures..::..ColorFillFailures type exposes the following members.

Properties

Name | Description
OnlyOneColorFillNonPlan | A Color Fill Legend can only be placed in a Floor Plan View or a Section View.
SymtemColorFillLegendNotAllowed | [Category name] Color Fill Legend can only be placed in a Floor Plan View.

See Also

BuiltInFailures..::..ColorFillFailures Class


BuiltInFailures.ColumnFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..ColumnFailures Members
BuiltInFailures..::..ColumnFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..ColumnFailures type exposes the following members.

Properties

Name | Description
ColumnAndTargetAreConcrete | Column and target are both concrete. Geometries have been joined.
ColumnBaseAboveTopError | The column base can't be moved above its top.
ColumnBaseAboveTopFailure | The column base can't be moved above its top.
ColumnJoinNonhitFailure | The highlighted column can't maintain attachment to the target. It will be treated as unattached until it can intersect.
ColumnTopBelowBaseError | The column top can't be moved below its base.
ColumnTopBelowBaseFailure | The column top can't be moved below its base.
ColumnZeroHeightError | The column can't have zero height
ColumnZeroHeightFailure | The column can't have zero height

See Also

BuiltInFailures..::..ColumnFailures Class


ColumnAndTargetAreConcrete Property

[image]

Revit 2024 API
BuiltInFailures..::..ColumnFailures..::..ColumnAndTargetAreConcrete Property
BuiltInFailures..::..ColumnFailures Class See Also Send Feedback
Column and target are both concrete. Geometries have been joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ColumnAndTargetAreConcrete { get; }
Visual Basic
Public Shared ReadOnly Property ColumnAndTargetAreConcrete As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ColumnAndTargetAreConcrete {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ColumnFailures Class


ColumnBaseAboveTopError Property

[image]

Revit 2024 API
BuiltInFailures..::..ColumnFailures..::..ColumnBaseAboveTopError Property
BuiltInFailures..::..ColumnFailures Class See Also Send Feedback
The column base can't be moved above its top.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ColumnBaseAboveTopError { get; }
Visual Basic
Public Shared ReadOnly Property ColumnBaseAboveTopError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ColumnBaseAboveTopError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ColumnFailures Class


ColumnBaseAboveTopFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..ColumnFailures..::..ColumnBaseAboveTopFailure Property
BuiltInFailures..::..ColumnFailures Class See Also Send Feedback
The column base can't be moved above its top.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ColumnBaseAboveTopFailure { get; }
Visual Basic
Public Shared ReadOnly Property ColumnBaseAboveTopFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ColumnBaseAboveTopFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ColumnFailures Class


ColumnJoinNonhitFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..ColumnFailures..::..ColumnJoinNonhitFailure Property
BuiltInFailures..::..ColumnFailures Class See Also Send Feedback
The highlighted column can't maintain attachment to the target. It will be treated as unattached until it can intersect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ColumnJoinNonhitFailure { get; }
Visual Basic
Public Shared ReadOnly Property ColumnJoinNonhitFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ColumnJoinNonhitFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ColumnFailures Class


ColumnTopBelowBaseError Property

[image]

Revit 2024 API
BuiltInFailures..::..ColumnFailures..::..ColumnTopBelowBaseError Property
BuiltInFailures..::..ColumnFailures Class See Also Send Feedback
The column top can't be moved below its base.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ColumnTopBelowBaseError { get; }
Visual Basic
Public Shared ReadOnly Property ColumnTopBelowBaseError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ColumnTopBelowBaseError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ColumnFailures Class


ColumnTopBelowBaseFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..ColumnFailures..::..ColumnTopBelowBaseFailure Property
BuiltInFailures..::..ColumnFailures Class See Also Send Feedback
The column top can't be moved below its base.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ColumnTopBelowBaseFailure { get; }
Visual Basic
Public Shared ReadOnly Property ColumnTopBelowBaseFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ColumnTopBelowBaseFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ColumnFailures Class


ColumnZeroHeightError Property

[image]

Revit 2024 API
BuiltInFailures..::..ColumnFailures..::..ColumnZeroHeightError Property
BuiltInFailures..::..ColumnFailures Class See Also Send Feedback
The column can't have zero height

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ColumnZeroHeightError { get; }
Visual Basic
Public Shared ReadOnly Property ColumnZeroHeightError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ColumnZeroHeightError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ColumnFailures Class


ColumnZeroHeightFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..ColumnFailures..::..ColumnZeroHeightFailure Property
BuiltInFailures..::..ColumnFailures Class See Also Send Feedback
The column can't have zero height

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ColumnZeroHeightFailure { get; }
Visual Basic
Public Shared ReadOnly Property ColumnZeroHeightFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ColumnZeroHeightFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ColumnFailures Class


BuiltInFailures.ColumnInsideWallFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..ColumnInsideWallFailures Members
BuiltInFailures..::..ColumnInsideWallFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..ColumnInsideWallFailures type exposes the following members.

Properties

Name | Description
ColumnInsideWall | One element is completely inside another.
CopingWarningExtension | Coping applied, but no cut was made. Adjust Coping Distance or Extension parameters.
CopingWarningIgnored | Cuts on concrete members are ignored.
CopingWarningMedium | Coping applied, but only in Medium Detail Level.
CopingWarningOffset | Coping applied, but no cut was made. Adjust Coping Distance or Offset parameters.
StartCutShadowJoin | Two joined walls are in a position to allow automatic insert copying.
StopCutShadowJoin | Two joined walls are no longer in a position to allow automatic insert copying. They are either non-parallel or non-overlapping.

See Also

BuiltInFailures..::..ColumnInsideWallFailures Class


ColumnInsideWall Property

[image]

Revit 2024 API
BuiltInFailures..::..ColumnInsideWallFailures..::..ColumnInsideWall Property
BuiltInFailures..::..ColumnInsideWallFailures Class See Also Send Feedback
One element is completely inside another.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ColumnInsideWall { get; }
Visual Basic
Public Shared ReadOnly Property ColumnInsideWall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ColumnInsideWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ColumnInsideWallFailures Class


CopingWarningIgnored Property

[image]

Revit 2024 API
BuiltInFailures..::..ColumnInsideWallFailures..::..CopingWarningIgnored Property
BuiltInFailures..::..ColumnInsideWallFailures Class See Also Send Feedback
Cuts on concrete members are ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CopingWarningIgnored { get; }
Visual Basic
Public Shared ReadOnly Property CopingWarningIgnored As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CopingWarningIgnored {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ColumnInsideWallFailures Class


CopingWarningMedium Property

[image]

Revit 2024 API
BuiltInFailures..::..ColumnInsideWallFailures..::..CopingWarningMedium Property
BuiltInFailures..::..ColumnInsideWallFailures Class See Also Send Feedback
Coping applied, but only in Medium Detail Level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CopingWarningMedium { get; }
Visual Basic
Public Shared ReadOnly Property CopingWarningMedium As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CopingWarningMedium {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ColumnInsideWallFailures Class


CopingWarningOffset Property

[image]

Revit 2024 API
BuiltInFailures..::..ColumnInsideWallFailures..::..CopingWarningOffset Property
BuiltInFailures..::..ColumnInsideWallFailures Class See Also Send Feedback
Coping applied, but no cut was made. Adjust Coping Distance or Offset parameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CopingWarningOffset { get; }
Visual Basic
Public Shared ReadOnly Property CopingWarningOffset As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CopingWarningOffset {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ColumnInsideWallFailures Class


StartCutShadowJoin Property

[image]

Revit 2024 API
BuiltInFailures..::..ColumnInsideWallFailures..::..StartCutShadowJoin Property
BuiltInFailures..::..ColumnInsideWallFailures Class See Also Send Feedback
Two joined walls are in a position to allow automatic insert copying.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StartCutShadowJoin { get; }
Visual Basic
Public Shared ReadOnly Property StartCutShadowJoin As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StartCutShadowJoin {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ColumnInsideWallFailures Class


StopCutShadowJoin Property

[image]

Revit 2024 API
BuiltInFailures..::..ColumnInsideWallFailures..::..StopCutShadowJoin Property
BuiltInFailures..::..ColumnInsideWallFailures Class See Also Send Feedback
Two joined walls are no longer in a position to allow automatic insert copying. They are either non-parallel or non-overlapping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StopCutShadowJoin { get; }
Visual Basic
Public Shared ReadOnly Property StopCutShadowJoin As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StopCutShadowJoin {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ColumnInsideWallFailures Class


BuiltInFailures.ComponentRepeaterFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..ComponentRepeaterFailures Properties
BuiltInFailures..::..ComponentRepeaterFailures Class See Also Send Feedback

The BuiltInFailures..::..ComponentRepeaterFailures type exposes the following members.

Properties

Name | Description
ComponentRepeater_InvalidFamilyOnReload | Reloaded family not appropriate for repeater.
ComponentRepeater_ThereIsOnlyOneInstanceInThisRepeater | There is only one component in this repeater.

See Also

BuiltInFailures..::..ComponentRepeaterFailures Class


ComponentRepeater_InvalidFamilyOnReload Property

[image]

Revit 2024 API
BuiltInFailures..::..ComponentRepeaterFailures..::..ComponentRepeater_InvalidFamilyOnReload Property
BuiltInFailures..::..ComponentRepeaterFailures Class See Also Send Feedback
Reloaded family not appropriate for repeater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ComponentRepeater_InvalidFamilyOnReload { get; }
Visual Basic
Public Shared ReadOnly Property ComponentRepeater_InvalidFamilyOnReload As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ComponentRepeater_InvalidFamilyOnReload {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ComponentRepeaterFailures Class


ComponentRepeater_ThereIsOnlyOneInstanceInThisRepeater Property

[image]

Revit 2024 API
BuiltInFailures..::..ComponentRepeaterFailures..::..ComponentRepeater_ThereIsOnlyOneInstanceInThisRepeater Property
BuiltInFailures..::..ComponentRepeaterFailures Class See Also Send Feedback
There is only one component in this repeater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ComponentRepeater_ThereIsOnlyOneInstanceInThisRepeater { get; }
Visual Basic
Public Shared ReadOnly Property ComponentRepeater_ThereIsOnlyOneInstanceInThisRepeater As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ComponentRepeater_ThereIsOnlyOneInstanceInThisRepeater {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ComponentRepeaterFailures Class


BuiltInFailures.ComponentRepeaterSlotFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..ComponentRepeaterSlotFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures related to component repeater slots.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class ComponentRepeaterSlotFailures
Visual Basic
Public NotInheritable Class ComponentRepeaterSlotFailures
Visual C++
public ref class ComponentRepeaterSlotFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..ComponentRepeaterSlotFailures

See Also

BuiltInFailures..::..ComponentRepeaterSlotFailures Members


BuiltInFailures.ComponentRepeaterSlotFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..ComponentRepeaterSlotFailures Properties
BuiltInFailures..::..ComponentRepeaterSlotFailures Class See Also Send Feedback

The BuiltInFailures..::..ComponentRepeaterSlotFailures type exposes the following members.

Properties

Name | Description
ComponentRepeaterSlot_InvalidFamilyOnReload | Reloaded family not appropriate for repeated component.

See Also

BuiltInFailures..::..ComponentRepeaterSlotFailures Class


ComponentRepeaterSlot_InvalidFamilyOnReload Property

[image]

Revit 2024 API
BuiltInFailures..::..ComponentRepeaterSlotFailures..::..ComponentRepeaterSlot_InvalidFamilyOnReload Property
BuiltInFailures..::..ComponentRepeaterSlotFailures Class See Also Send Feedback
Reloaded family not appropriate for repeated component.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ComponentRepeaterSlot_InvalidFamilyOnReload { get; }
Visual Basic
Public Shared ReadOnly Property ComponentRepeaterSlot_InvalidFamilyOnReload As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ComponentRepeaterSlot_InvalidFamilyOnReload {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ComponentRepeaterSlotFailures Class


BuiltInFailures.ConnectorFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..ConnectorFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class ConnectorFailures
Visual Basic
Public NotInheritable Class ConnectorFailures
Visual C++
public ref class ConnectorFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..ConnectorFailures

See Also

BuiltInFailures..::..ConnectorFailures Members


BuiltInFailures.ConnectorFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..ConnectorFailures Members
BuiltInFailures..::..ConnectorFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..ConnectorFailures type exposes the following members.

Properties

Name | Description
AirTerminalCenterNotAligned | The center of the Air Terminal doesn't align at (0,0,0): align the Air Terminal Center to the Origin Defining Reference Planes could help to solve the problem.
AllElementsRemovedFromCircuitGroup | [System] is empty and will be deleted.
DisconnectedElements | Elements are disconnected!
ElementAssignedToDefaultSystem | At least one connector on the highlighted element is currently assigned to the [Element Name]. In general items shouldn't be assigned to the Default Systems, but should be assigned as equipments or elements of a non-default system. Click the More Info button below for additional information on System Creation.
ElementHasMultipleConnectors | Revit found one or more elements with multiple connectors. Select each element and then select the connectors to use for the analytical connection.
ElementsAreDisconnected | Elements need to be disconnected.
ElementsConnectedToParent | You have selected elements that are connected to a parent object in a System. These elements cannot be removed from the System.
ElementsNeedToBeDisconnected | Elements need to be disconnected.
ExistsForSelectedElement | Connections already exists for selected element.
FittingMustBeOnDuct | The [Tap] must be attached to duct.
FittingMustBeOnDuctWarn | The [Tap] must be attached to duct.
FittingMustBeOnPipe | The [Tap] must be attached to pipe.
FittingMustBeOnPipeWarn | The [Tap] must be attached to pipe.
InvalidConnectionRef | The selected fitting has invalid connections and must be deleted to continue.
InvalidConnector | The connector is invalid, the size cannot be determined from the connector.
InvalidLoadClassificationValue | The load classification parameter cannot be empty. Please select a valid load classification element for the connector parameter and the associated family parameter.
InvalidPowerFactorValue | The value for Power Factor must be between 0 and 1.
JointGenderMismatch | The element has a connector with a fitting joint gender mismatch
JointShapeMismatch | The element has a connector with a fitting joint shape mismatch
JointSizeMismatch | The element has a connector with a fitting joint size mismatch
JointTypeMismatch | The element has a connector with a fitting joint type mismatch
LayoutConnector | [Unassigned System Type] on Connector [Index Number].
MismatchNoAvailableConnector | Cannot add [Element] to System. There is no available connector matching the System Type ([Type Name]) for the System.
MultipleNetwork | Elements in [System Name] are not connected in a single physical network due to one or both of the following:\n- There are disconnects in the system's physical network.\n- Elements in the system are connected to more than one physical network.
NetworkValidityError | The family is connected in a network and can no longer keep the connectivity. Disconnect the family from the network?
NetworkValidityErrorWasDisconnected | The family is connected in a network and can no longer keep the connectivity. Disconnect the family from the network?
NoLossDefined | No Loss Defined
NoSupportKCoefficientTable | "K Coefficient from table" is not supported on connector for the element
NotAllowedToModifyGroupElementsError | Connection to a group failed. Modification of elements within a group is not allowed.
NotAllowedToModifyGroupElementsWarning | Connection to a group failed. Modification of elements within a group is not allowed.
OpenConnector | The element has an open connector
RbsNetworkValidityError | The family is connected in a network and can no longer keep the connectivity.
RemoveConnectorLinksWarn | The links between connector [Index] and connector [Index], connector [Index] and connector [Index] are removed.
RemoveConnectorLinkWarn | The link between connector [Index] and connector [Index] is removed.
ShapesNotMatch | Shapes do not match. A connection could not be made.
SizingCalculationFlowOnlyWarn | Some elements are not sized because the system calculation is flow only. You may change the system calculation level to size them again.
SizingCalculationNoneWarn | Some elements are not sized because the system calculation level is none or performance. You may change the system calculation level to size them again.
SizingFailed | Sizing failed.
UnconnectedCircuit | The element has an unconnected circuit on its connector
UnconnectedDevice | Device has an unconnected [Type Name] connector (index = [Index Number]).
UndefinedConnector | Revit does not support Undefined connectors. The following have been replaced by the default connector: [Connector Element]

See Also

BuiltInFailures..::..ConnectorFailures Class


AirTerminalCenterNotAligned Property

[image]

Revit 2024 API
BuiltInFailures..::..ConnectorFailures..::..AirTerminalCenterNotAligned Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
The center of the Air Terminal doesn't align at (0,0,0): align the Air Terminal Center to the Origin Defining Reference Planes could help to solve the problem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AirTerminalCenterNotAligned { get; }
Visual Basic
Public Shared ReadOnly Property AirTerminalCenterNotAligned As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AirTerminalCenterNotAligned {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


DisconnectedElements Property

[image]

Revit 2024 API
BuiltInFailures..::..ConnectorFailures..::..DisconnectedElements Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
Elements are disconnected!

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DisconnectedElements { get; }
Visual Basic
Public Shared ReadOnly Property DisconnectedElements As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DisconnectedElements {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


ElementAssignedToDefaultSystem Property

[image]

Revit 2024 API
BuiltInFailures..::..ConnectorFailures..::..ElementAssignedToDefaultSystem Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
At least one connector on the highlighted element is currently assigned to the [Element Name]. In general items shouldn't be assigned to the Default Systems, but should be assigned as equipments or elements of a non-default system. Click the More Info button below for additional information on System Creation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ElementAssignedToDefaultSystem { get; }
Visual Basic
Public Shared ReadOnly Property ElementAssignedToDefaultSystem As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementAssignedToDefaultSystem {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


ElementsAreDisconnected Property

[image]

Revit 2024 API
BuiltInFailures..::..ConnectorFailures..::..ElementsAreDisconnected Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
Elements need to be disconnected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ElementsAreDisconnected { get; }
Visual Basic
Public Shared ReadOnly Property ElementsAreDisconnected As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementsAreDisconnected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


ElementsConnectedToParent Property

[image]

Revit 2024 API
BuiltInFailures..::..ConnectorFailures..::..ElementsConnectedToParent Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
You have selected elements that are connected to a parent object in a System. These elements cannot be removed from the System.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ElementsConnectedToParent { get; }
Visual Basic
Public Shared ReadOnly Property ElementsConnectedToParent As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementsConnectedToParent {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


ElementsNeedToBeDisconnected Property

[image]

Revit 2024 API
BuiltInFailures..::..ConnectorFailures..::..ElementsNeedToBeDisconnected Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
Elements need to be disconnected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ElementsNeedToBeDisconnected { get; }
Visual Basic
Public Shared ReadOnly Property ElementsNeedToBeDisconnected As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementsNeedToBeDisconnected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


ExistsForSelectedElement Property

[image]

Revit 2024 API
BuiltInFailures..::..ConnectorFailures..::..ExistsForSelectedElement Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
Connections already exists for selected element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ExistsForSelectedElement { get; }
Visual Basic
Public Shared ReadOnly Property ExistsForSelectedElement As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ExistsForSelectedElement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


FittingMustBeOnDuct Property

[image]

Revit 2024 API
BuiltInFailures..::..ConnectorFailures..::..FittingMustBeOnDuct Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
The [Tap] must be attached to duct.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FittingMustBeOnDuct { get; }
Visual Basic
Public Shared ReadOnly Property FittingMustBeOnDuct As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FittingMustBeOnDuct {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


FittingMustBeOnDuctWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..ConnectorFailures..::..FittingMustBeOnDuctWarn Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
The [Tap] must be attached to duct.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FittingMustBeOnDuctWarn { get; }
Visual Basic
Public Shared ReadOnly Property FittingMustBeOnDuctWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FittingMustBeOnDuctWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


FittingMustBeOnPipe Property

[image]

Revit 2024 API
BuiltInFailures..::..ConnectorFailures..::..FittingMustBeOnPipe Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
The [Tap] must be attached to pipe.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FittingMustBeOnPipe { get; }
Visual Basic
Public Shared ReadOnly Property FittingMustBeOnPipe As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FittingMustBeOnPipe {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


FittingMustBeOnPipeWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..ConnectorFailures..::..FittingMustBeOnPipeWarn Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
The [Tap] must be attached to pipe.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FittingMustBeOnPipeWarn { get; }
Visual Basic
Public Shared ReadOnly Property FittingMustBeOnPipeWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FittingMustBeOnPipeWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


InvalidConnectionRef Property

[image]

Revit 2024 API
BuiltInFailures..::..ConnectorFailures..::..InvalidConnectionRef Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
The selected fitting has invalid connections and must be deleted to continue.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidConnectionRef { get; }
Visual Basic
Public Shared ReadOnly Property InvalidConnectionRef As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidConnectionRef {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


JointGenderMismatch Property

[image]

Revit 2024 API
BuiltInFailures..::..ConnectorFailures..::..JointGenderMismatch Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
The element has a connector with a fitting joint gender mismatch

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId JointGenderMismatch { get; }
Visual Basic
Public Shared ReadOnly Property JointGenderMismatch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ JointGenderMismatch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


JointShapeMismatch Property

[image]

Revit 2024 API
BuiltInFailures..::..ConnectorFailures..::..JointShapeMismatch Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
The element has a connector with a fitting joint shape mismatch

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId JointShapeMismatch { get; }
Visual Basic
Public Shared ReadOnly Property JointShapeMismatch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ JointShapeMismatch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


JointSizeMismatch Property

[image]

Revit 2024 API
BuiltInFailures..::..ConnectorFailures..::..JointSizeMismatch Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
The element has a connector with a fitting joint size mismatch

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId JointSizeMismatch { get; }
Visual Basic
Public Shared ReadOnly Property JointSizeMismatch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ JointSizeMismatch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


JointTypeMismatch Property

[image]

Revit 2024 API
BuiltInFailures..::..ConnectorFailures..::..JointTypeMismatch Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
The element has a connector with a fitting joint type mismatch

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId JointTypeMismatch { get; }
Visual Basic
Public Shared ReadOnly Property JointTypeMismatch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ JointTypeMismatch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


LayoutConnector Property

[image]

Revit 2024 API
BuiltInFailures..::..ConnectorFailures..::..LayoutConnector Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
[Unassigned System Type] on Connector [Index Number].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId LayoutConnector { get; }
Visual Basic
Public Shared ReadOnly Property LayoutConnector As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LayoutConnector {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


MultipleNetwork Property

[image]

Revit 2024 API
BuiltInFailures..::..ConnectorFailures..::..MultipleNetwork Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
Elements in [System Name] are not connected in a single physical network due to one or both of the following:\n- There are disconnects in the system's physical network.\n- Elements in the system are connected to more than one physical network.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MultipleNetwork { get; }
Visual Basic
Public Shared ReadOnly Property MultipleNetwork As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MultipleNetwork {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


NetworkValidityError Property

[image]

Revit 2024 API
BuiltInFailures..::..ConnectorFailures..::..NetworkValidityError Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
The family is connected in a network and can no longer keep the connectivity. Disconnect the family from the network?

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NetworkValidityError { get; }
Visual Basic
Public Shared ReadOnly Property NetworkValidityError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NetworkValidityError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


NoLossDefined Property

[image]

Revit 2024 API
BuiltInFailures..::..ConnectorFailures..::..NoLossDefined Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
No Loss Defined

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoLossDefined { get; }
Visual Basic
Public Shared ReadOnly Property NoLossDefined As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoLossDefined {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


NoSupportKCoefficientTable Property

[image]

Revit 2024 API
BuiltInFailures..::..ConnectorFailures..::..NoSupportKCoefficientTable Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
"K Coefficient from table" is not supported on connector for the element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoSupportKCoefficientTable { get; }
Visual Basic
Public Shared ReadOnly Property NoSupportKCoefficientTable As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoSupportKCoefficientTable {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


NotAllowedToModifyGroupElementsWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..ConnectorFailures..::..NotAllowedToModifyGroupElementsWarning Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
Connection to a group failed. Modification of elements within a group is not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NotAllowedToModifyGroupElementsWarning { get; }
Visual Basic
Public Shared ReadOnly Property NotAllowedToModifyGroupElementsWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotAllowedToModifyGroupElementsWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


OpenConnector Property

[image]

Revit 2024 API
BuiltInFailures..::..ConnectorFailures..::..OpenConnector Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
The element has an open connector

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId OpenConnector { get; }
Visual Basic
Public Shared ReadOnly Property OpenConnector As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OpenConnector {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


RbsNetworkValidityError Property

[image]

Revit 2024 API
BuiltInFailures..::..ConnectorFailures..::..RbsNetworkValidityError Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
The family is connected in a network and can no longer keep the connectivity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RbsNetworkValidityError { get; }
Visual Basic
Public Shared ReadOnly Property RbsNetworkValidityError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RbsNetworkValidityError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


RemoveConnectorLinksWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..ConnectorFailures..::..RemoveConnectorLinksWarn Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
The links between connector [Index] and connector [Index], connector [Index] and connector [Index] are removed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RemoveConnectorLinksWarn { get; }
Visual Basic
Public Shared ReadOnly Property RemoveConnectorLinksWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RemoveConnectorLinksWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


RemoveConnectorLinkWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..ConnectorFailures..::..RemoveConnectorLinkWarn Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
The link between connector [Index] and connector [Index] is removed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RemoveConnectorLinkWarn { get; }
Visual Basic
Public Shared ReadOnly Property RemoveConnectorLinkWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RemoveConnectorLinkWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


ShapesNotMatch Property

[image]

Revit 2024 API
BuiltInFailures..::..ConnectorFailures..::..ShapesNotMatch Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
Shapes do not match. A connection could not be made.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ShapesNotMatch { get; }
Visual Basic
Public Shared ReadOnly Property ShapesNotMatch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ShapesNotMatch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


SizingCalculationFlowOnlyWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..ConnectorFailures..::..SizingCalculationFlowOnlyWarn Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
Some elements are not sized because the system calculation is flow only. You may change the system calculation level to size them again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SizingCalculationFlowOnlyWarn { get; }
Visual Basic
Public Shared ReadOnly Property SizingCalculationFlowOnlyWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SizingCalculationFlowOnlyWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


SizingCalculationNoneWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..ConnectorFailures..::..SizingCalculationNoneWarn Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
Some elements are not sized because the system calculation level is none or performance. You may change the system calculation level to size them again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SizingCalculationNoneWarn { get; }
Visual Basic
Public Shared ReadOnly Property SizingCalculationNoneWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SizingCalculationNoneWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


SizingFailed Property

[image]

Revit 2024 API
BuiltInFailures..::..ConnectorFailures..::..SizingFailed Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
Sizing failed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SizingFailed { get; }
Visual Basic
Public Shared ReadOnly Property SizingFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SizingFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


UndefinedConnector Property

[image]

Revit 2024 API
BuiltInFailures..::..ConnectorFailures..::..UndefinedConnector Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
Revit does not support Undefined connectors. The following have been replaced by the default connector: [Connector Element]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UndefinedConnector { get; }
Visual Basic
Public Shared ReadOnly Property UndefinedConnector As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UndefinedConnector {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


BuiltInFailures.ConstraintFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..ConstraintFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Constraint.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class ConstraintFailures
Visual Basic
Public NotInheritable Class ConstraintFailures
Visual C++
public ref class ConstraintFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..ConstraintFailures

See Also

BuiltInFailures..::..ConstraintFailures Members


BuiltInFailures.ConstraintFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..ConstraintFailures Members
BuiltInFailures..::..ConstraintFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..ConstraintFailures type exposes the following members.

Properties

Name | Description
UndeletedConstraints | A dimension that has lock constraints is being deleted, but the elements will still be constrained. Push "Unconstrain" to remove the constraints or "OK" to leave elements constrained..
UndeletedConstraintsEQ | A dimension that has EQ constraints is being deleted, but the elements will still be constrained. Push "Unconstrain" to remove the constraints or "OK" to leave elements constrained..
UndeletedConstraintsInGroup | A labeled dimension is being deleted, but the corresponding constraint belongs to a group and will not be changed. You can change it in group edit mode later.
UndeletedConstraintsLabel | A dimension labeled by a parameter is being deleted, but the elements will still be constrained. Push "Unconstrain" to remove the constraints or "OK" to leave elements constrained..

See Also

BuiltInFailures..::..ConstraintFailures Class


BuiltInFailures.ConstraintFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..ConstraintFailures Properties
BuiltInFailures..::..ConstraintFailures Class See Also Send Feedback

The BuiltInFailures..::..ConstraintFailures type exposes the following members.

Properties

Name | Description
UndeletedConstraints | A dimension that has lock constraints is being deleted, but the elements will still be constrained. Push "Unconstrain" to remove the constraints or "OK" to leave elements constrained..
UndeletedConstraintsEQ | A dimension that has EQ constraints is being deleted, but the elements will still be constrained. Push "Unconstrain" to remove the constraints or "OK" to leave elements constrained..
UndeletedConstraintsInGroup | A labeled dimension is being deleted, but the corresponding constraint belongs to a group and will not be changed. You can change it in group edit mode later.
UndeletedConstraintsLabel | A dimension labeled by a parameter is being deleted, but the elements will still be constrained. Push "Unconstrain" to remove the constraints or "OK" to leave elements constrained..

See Also

BuiltInFailures..::..ConstraintFailures Class


UndeletedConstraints Property

[image]

Revit 2024 API
BuiltInFailures..::..ConstraintFailures..::..UndeletedConstraints Property
BuiltInFailures..::..ConstraintFailures Class See Also Send Feedback
A dimension that has lock constraints is being deleted, but the elements will still be constrained. Push "Unconstrain" to remove the constraints or "OK" to leave elements constrained..

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UndeletedConstraints { get; }
Visual Basic
Public Shared ReadOnly Property UndeletedConstraints As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UndeletedConstraints {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConstraintFailures Class


UndeletedConstraintsInGroup Property

[image]

Revit 2024 API
BuiltInFailures..::..ConstraintFailures..::..UndeletedConstraintsInGroup Property
BuiltInFailures..::..ConstraintFailures Class See Also Send Feedback
A labeled dimension is being deleted, but the corresponding constraint belongs to a group and will not be changed. You can change it in group edit mode later.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UndeletedConstraintsInGroup { get; }
Visual Basic
Public Shared ReadOnly Property UndeletedConstraintsInGroup As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UndeletedConstraintsInGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConstraintFailures Class


UndeletedConstraintsLabel Property

[image]

Revit 2024 API
BuiltInFailures..::..ConstraintFailures..::..UndeletedConstraintsLabel Property
BuiltInFailures..::..ConstraintFailures Class See Also Send Feedback
A dimension labeled by a parameter is being deleted, but the elements will still be constrained. Push "Unconstrain" to remove the constraints or "OK" to leave elements constrained..

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UndeletedConstraintsLabel { get; }
Visual Basic
Public Shared ReadOnly Property UndeletedConstraintsLabel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UndeletedConstraintsLabel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConstraintFailures Class


BuiltInFailures.ConversionFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..ConversionFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about conversion of data to a different format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class ConversionFailures
Visual Basic
Public NotInheritable Class ConversionFailures
Visual C++
public ref class ConversionFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..ConversionFailures

See Also

BuiltInFailures..::..ConversionFailures Members


BuiltInFailures.ConversionFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..ConversionFailures Members
BuiltInFailures..::..ConversionFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..ConversionFailures type exposes the following members.

Properties

Name | Description
CannotConvertPercentToDouble | Cannot convert concentration percent ' [Percentage Value] ' to double value
CannotConvertTempToDouble | Cannot convert temperature '[Temperate Value]' to double value
CannotConvertToDouble | Cannot convert '[Text] ' to double value
UndefinedFluidUnit | Undefined fluid unit: '[Fluid Unit Type Name]'
UndefinedTemperatureUnit | Undefined temperature unit: '[Temperature Unit Type Name]'

See Also

BuiltInFailures..::..ConversionFailures Class


CannotConvertPercentToDouble Property

[image]

Revit 2024 API
BuiltInFailures..::..ConversionFailures..::..CannotConvertPercentToDouble Property
BuiltInFailures..::..ConversionFailures Class See Also Send Feedback
Cannot convert concentration percent ' [Percentage Value] ' to double value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotConvertPercentToDouble { get; }
Visual Basic
Public Shared ReadOnly Property CannotConvertPercentToDouble As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotConvertPercentToDouble {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConversionFailures Class


CannotConvertTempToDouble Property

[image]

Revit 2024 API
BuiltInFailures..::..ConversionFailures..::..CannotConvertTempToDouble Property
BuiltInFailures..::..ConversionFailures Class See Also Send Feedback
Cannot convert temperature '[Temperate Value]' to double value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotConvertTempToDouble { get; }
Visual Basic
Public Shared ReadOnly Property CannotConvertTempToDouble As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotConvertTempToDouble {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConversionFailures Class


CannotConvertToDouble Property

[image]

Revit 2024 API
BuiltInFailures..::..ConversionFailures..::..CannotConvertToDouble Property
BuiltInFailures..::..ConversionFailures Class See Also Send Feedback
Cannot convert '[Text] ' to double value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotConvertToDouble { get; }
Visual Basic
Public Shared ReadOnly Property CannotConvertToDouble As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotConvertToDouble {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConversionFailures Class


UndefinedFluidUnit Property

[image]

Revit 2024 API
BuiltInFailures..::..ConversionFailures..::..UndefinedFluidUnit Property
BuiltInFailures..::..ConversionFailures Class See Also Send Feedback
Undefined fluid unit: '[Fluid Unit Type Name]'

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UndefinedFluidUnit { get; }
Visual Basic
Public Shared ReadOnly Property UndefinedFluidUnit As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UndefinedFluidUnit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConversionFailures Class


UndefinedTemperatureUnit Property

[image]

Revit 2024 API
BuiltInFailures..::..ConversionFailures..::..UndefinedTemperatureUnit Property
BuiltInFailures..::..ConversionFailures Class See Also Send Feedback
Undefined temperature unit: '[Temperature Unit Type Name]'

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UndefinedTemperatureUnit { get; }
Visual Basic
Public Shared ReadOnly Property UndefinedTemperatureUnit As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UndefinedTemperatureUnit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConversionFailures Class


BuiltInFailures.CopyMonitorFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..CopyMonitorFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about CopyWatch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class CopyMonitorFailures
Visual Basic
Public NotInheritable Class CopyMonitorFailures
Visual C++
public ref class CopyMonitorFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..CopyMonitorFailures

See Also

BuiltInFailures..::..CopyMonitorFailures Members


BuiltInFailures.CopyMonitorFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..CopyMonitorFailures Members
BuiltInFailures..::..CopyMonitorFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..CopyMonitorFailures type exposes the following members.

Properties

Name | Description
AlreadyCopiedAndStopWatch | Element has already been copied. Stop existing monitoring to copy again.
AlreadyWatched | Elements already monitored.
CannotCopyCuttingInsert | Copy/Monitor does not support cutting inserts in floors. Some openings were not copied.
CannotMoveHostedFixtureViaCopyMonitor | The fixture is hosted and cannot be moved. Use the Move command to relocate the fixture in the host file as required.
CopyWatchAlert | Coordination Monitor alert : [Description]
GridDeletedSameName | Grid cannot be copied because grid with desired name '[Name]' already exist in a target document.
LevelDeletedSameName | Level cannot be copied because level with desired name '[Name]' already exist in a target document.

See Also

BuiltInFailures..::..CopyMonitorFailures Class


BuiltInFailures.CopyMonitorFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..CopyMonitorFailures Properties
BuiltInFailures..::..CopyMonitorFailures Class See Also Send Feedback

The BuiltInFailures..::..CopyMonitorFailures type exposes the following members.

Properties

Name | Description
AlreadyCopiedAndStopWatch | Element has already been copied. Stop existing monitoring to copy again.
AlreadyWatched | Elements already monitored.
CannotCopyCuttingInsert | Copy/Monitor does not support cutting inserts in floors. Some openings were not copied.
CannotMoveHostedFixtureViaCopyMonitor | The fixture is hosted and cannot be moved. Use the Move command to relocate the fixture in the host file as required.
CopyWatchAlert | Coordination Monitor alert : [Description]
GridDeletedSameName | Grid cannot be copied because grid with desired name '[Name]' already exist in a target document.
LevelDeletedSameName | Level cannot be copied because level with desired name '[Name]' already exist in a target document.

See Also

BuiltInFailures..::..CopyMonitorFailures Class


AlreadyCopiedAndStopWatch Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyMonitorFailures..::..AlreadyCopiedAndStopWatch Property
BuiltInFailures..::..CopyMonitorFailures Class See Also Send Feedback
Element has already been copied. Stop existing monitoring to copy again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AlreadyCopiedAndStopWatch { get; }
Visual Basic
Public Shared ReadOnly Property AlreadyCopiedAndStopWatch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AlreadyCopiedAndStopWatch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyMonitorFailures Class


AlreadyWatched Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyMonitorFailures..::..AlreadyWatched Property
BuiltInFailures..::..CopyMonitorFailures Class See Also Send Feedback
Elements already monitored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AlreadyWatched { get; }
Visual Basic
Public Shared ReadOnly Property AlreadyWatched As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AlreadyWatched {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyMonitorFailures Class


CannotMoveHostedFixtureViaCopyMonitor Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyMonitorFailures..::..CannotMoveHostedFixtureViaCopyMonitor Property
BuiltInFailures..::..CopyMonitorFailures Class See Also Send Feedback
The fixture is hosted and cannot be moved. Use the Move command to relocate the fixture in the host file as required.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotMoveHostedFixtureViaCopyMonitor { get; }
Visual Basic
Public Shared ReadOnly Property CannotMoveHostedFixtureViaCopyMonitor As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMoveHostedFixtureViaCopyMonitor {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyMonitorFailures Class


CopyWatchAlert Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyMonitorFailures..::..CopyWatchAlert Property
BuiltInFailures..::..CopyMonitorFailures Class See Also Send Feedback
Coordination Monitor alert : [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CopyWatchAlert { get; }
Visual Basic
Public Shared ReadOnly Property CopyWatchAlert As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CopyWatchAlert {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyMonitorFailures Class


LevelDeletedSameName Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyMonitorFailures..::..LevelDeletedSameName Property
BuiltInFailures..::..CopyMonitorFailures Class See Also Send Feedback
Level cannot be copied because level with desired name '[Name]' already exist in a target document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId LevelDeletedSameName { get; }
Visual Basic
Public Shared ReadOnly Property LevelDeletedSameName As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LevelDeletedSameName {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyMonitorFailures Class


BuiltInFailures.CopyPasteFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures Members
BuiltInFailures..::..CopyPasteFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..CopyPasteFailures type exposes the following members.

Properties

Name | Description
CannotCopyAttachedType | Cannot copy attached detail group type without copying the model group type it refers to.
CannotCopyAttachedTypeWarn | Cannot copy attached detail group type without copying the model group type it refers to.
CannotCopyBetweenFamilyAndProjectCorruption | Can't copy between Family and Project.
CannotCopyBetweenFamilyAndProjectError | Can't copy between Family and Project.
CannotCopyCurtainWallGridLines | Curtain wall grid lines currently cannot be copied.
CannotCopyDependentView | Dependent views cannot be copied.
CannotCopyDetails | Can't copy some or all of the detailing with the view.
CannotCopyDueToBackgroundCalculation | Cannot copy dragged elements while background calculations are in progress.
CannotCopyDuplicates | Can't paste duplicate types. Only non duplicate types will be pasted.
CannotCopyElevationArrow | To duplicate Elevations, copy the elevation symbol in a plan view.
CannotCopyElevationArrowWarn | To duplicate Elevations, copy the elevation symbol in a plan view.
CannotCopyFamilyName | Can't [Action] because Family '[Family Name]' is different in the two documents. Update the documents to contain the same version of the Family.
CannotCopyFromProjectAndLink | Can't Copy to Clipboard elements from the project and a link instance at the same time. Only elements from the project will be copied.
CannotCopyGridLines | Curtain grid lines cannot be copied. If you are trying to copy the curtain wall, try using tab to select entire wall.
CannotCopyGridLinesWarn | Curtain grid lines cannot be copied. If you are trying to copy the curtain wall, try using tab to select entire wall.
CannotCopyImportInstancesAcrossProjects | Linked Imported Files cannot be copied across projects. All non-RVT linked files will be pasted as imports instead.
CannotCopyIncompleteElement | Can't copy part of element
CannotCopyIncompleteElementWarn | Can't copy part of element
CannotCopyJoinedGeometry | Joined solid geometry cannot be copied as a whole. Instead, select the individual extrusions, etc., using Pick box or Ctrl-select and copy them.
CannotCopyJoinedGeometryWarn | Joined solid geometry cannot be copied as a whole. Instead, select the individual extrusions, etc., using Pick box or Ctrl-select and copy them.
CannotCopyLocked | Can't copy pinned element.
CannotCopyLockedWarn | Can't copy pinned element.
CannotCopyMassing | A massing cannot be copied. Copy the elements within the massing instead.
CannotCopyMassingWarn | A massing cannot be copied. Copy the elements within the massing instead.
CannotCopyMullions | Mullions and panels cannot be copied without copying the entire curtain wall.
CannotCopyMullionsError | Mullions and panels cannot be copied without copying the entire curtain wall.
CannotCopyMullionsWarn | Mullions and panels cannot be copied without copying the entire curtain wall.
CannotCopyMultipleSketchParents | Copying elements from unrelated Workplanes together is not supported in families. Try copying elements separately.
CannotCopyMustBeUnique | Element must be unique.
CannotCopyMustBeUniqueWarn | Element must be unique.
CannotCopyNestedLinks | To copy a nested link, use Copy to Clipboard or Move Copy.
CannotCopyNoAttachedParent | Attached Detail Group can't be copied without its Model Group
CannotCopyNoAttachedParentWarn | Attached Detail Group can't be copied without its Model Group
CannotCopyNoParents | Can't Copy to Clipboard because of relationships between Elements
CannotCopyNoReferences | Elements can't be copied because they will lose their References.
CannotCopyRevolveAxis | The axis cannot be copied.
CannotCopyRevolveAxisWarn | The axis cannot be copied.
CannotCopySelectedPick | The element being dragged can't be copied.
CannotCopySelection | Cannot copy selection.[Description]
CannotCopySketchGrid | Work Planes cannot be copied.
CannotCopySketchGridWarn | Work Planes cannot be copied.
CannotCopySunAndShadowSettings | SunAndShadowSettings cannot be copied.
CannotCopySunAndShadowSettingsWarn | SunAndShadowSettings cannot be copied.
CannotCopyWallPanels | Cannot copy wall panels unless their parent wall is also being copied.
CannotCopyWallPanelsWarn | Cannot copy wall panels unless their parent wall is also being copied.
CannotCopyZone | A Zone cannot be copied.
CannotCopyZoneWarn | A Zone cannot be copied.
CannotDuplicate | Elements can't be duplicated
CannotDuplicateDesignOption | Can't duplicate Design Option.
CannotDuplicateInOption | Elements can't be duplicated in a secondary Option
CannotDuplicateInOptionWarn | Elements can't be duplicated in a secondary Option
CannotDuplicateType | Cannot Duplicate Type.
CannotDuplicateWarn | Elements can't be duplicated
CannotFinalizeClusterInconsistency | Can't finalize because dependent element failed to finalize.
CannotFinalizeOrphanSerf | Can't finalize Group member without finalizing the entire Group.
CannotPasteAlignedAny | Can't Paste Aligned.
CannotPasteAlignedCorruption | Can't Paste Aligned these elements in this view.
CannotPasteAlignedError | Can't Paste Align these elements in this view.
CannotPasteAlignedSomeLevels | Can't Paste Aligned to some views.
CannotPasteAssemblyView | Can't paste assembly view because its associated assembly instance is not available.
CannotPasteCircularLinks | The pasted selection includes a linked instance of this file '[Name]'. A file cannot link itself, so the link was not pasted.
CannotPasteCurtainGridLine | Can't paste Curtain Grid Line.
CannotPasteDifferentViewSpecificElements | Cannot paste view-specific elements from different views.
CannotPasteElemInViewError | Cannot paste the contents into %1!s! view. Attempt to paste into an appropriate view.
CannotPasteInSketch | Can't paste elements into sketch.
CannotPasteInView | Cannot paste the contents into %1!s! view. Attempt to paste into an appropriate view.
CannotPasteInViewError | Cannot paste the contents into %1!s! view. Attempt to paste into an appropriate view.
CannotPasteModelPlusViewSpecificElementsIntoView | Cannot paste view-specific model plus into view.
CannotPasteNoLevelAbove | Can't paste these elements at this height because there is no Level above to Reference.
CannotPasteNoLevelBelow | Can't paste these elements at this height because there is no Level below to reference.
CannotPasteNoWorkplane | Can't paste because there is no corresponding Work Plane. Set workplane or switch to view with appropriate workplane.
CannotPasteRoomsInNonPlanViews | [Rooms] can only be pasted in Plan or Ceiling Plan views.
CannotPasteToSheet | Elements copied to Sheets can only be copied from other Sheets.
CannotPasteViewSpecElemsFromDiffViews | Cannot paste view-specific elements from different views.
CannotPasteViewSpecificElementsIntoPerspectiveView | Can't paste view specific elements into perspective view.
CannotTransferProjectStandards | These Project Standards cannot be transferred.[Description]
CantCopyBetweenModelAndAnnotFam | Can't copy element(s) between Model and Annotation families.
CantCopyElemsToInplaceFam | Can't copy element(s) to In Place family.
CantCopyFrom2dTo3dFam | Can't copy 2D element(s) into a 3D family.
CantCopyFrom3dTo2dFam | Can't copy 3D element(s) into a 2D family.
CantCopyFromDetailToProfileFam | Can't copy Detail element(s) into a Profile family.
CantCopyLevelsOrRefPlanesToNonMassFamily | Can't copy levels or reference planes to families that are not Mass families.
CantCopyStairsLevelHeightNotMatchInMS | Can't copy stairs in Multistory Stairs due to level height doesn't match.
CantCopySymbolicElementToSelfOrientingFamily | Cannot copy symbolic elements sketched in non-horizontal planes.
CopingColumnBeamFailure | The support order for a beam/column connection has been changed. When a beam is supported by a column that same beam cannot be coped by the column. The existing coping has been removed.
CopyImposterContentError | Cannot copy Render Appearance.
CopyImposterContentWarn | Cannot copy Render Appearance.
CopyImposterLightError | Light source cannot be copied!
CopyImposterLightWarn | Light source cannot be copied!
ElementRenamedOnPaste | The loaded type "[Name]" has been renamed to "[New Name]" to avoid conflicts with the existing type.
FinalizedElementsWillBeDeleted | Can't find new hosts for this Element.\nIt will be deleted on Finish Paste unless repositioned or rehosted.
FinalizedElementsWillBeDeletedWarn | Can't find new hosts for this Element.\nIt will be deleted on Finish Paste unless repositioned or rehosted.
FinalizedElementsWillBeModified | Can't find some new hosts for this Element.\nIt will lose references on Finish Paste unless repositioned or rehosted.
FinalizedElementsWillBeModifiedWarn | Can't find some new hosts for this Element.\nIt will lose references on Finish Paste unless repositioned or rehosted.
LostReference | A relationship between Elements in [Option Name] and [Reference Option Name] has been deleted. There is no corresponding relationship in the Primary [New Primary Option Name].
NoSketchPlane | Can't paste because no Work Plane is defined in the View.
PasteInvisibleInView | Selection is invisible in this view.
SomeElementsNotCopiedWarn | Some elements were not copied.[Description]

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyAttachedType Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyAttachedType Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Cannot copy attached detail group type without copying the model group type it refers to.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCopyAttachedType { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyAttachedType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyAttachedType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyAttachedTypeWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyAttachedTypeWarn Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Cannot copy attached detail group type without copying the model group type it refers to.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCopyAttachedTypeWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyAttachedTypeWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyAttachedTypeWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyBetweenFamilyAndProjectCorruption Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyBetweenFamilyAndProjectCorruption Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't copy between Family and Project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCopyBetweenFamilyAndProjectCorruption { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyBetweenFamilyAndProjectCorruption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyBetweenFamilyAndProjectCorruption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyDependentView Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyDependentView Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Dependent views cannot be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCopyDependentView { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyDependentView As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyDependentView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyDueToBackgroundCalculation Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyDueToBackgroundCalculation Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Cannot copy dragged elements while background calculations are in progress.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCopyDueToBackgroundCalculation { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyDueToBackgroundCalculation As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyDueToBackgroundCalculation {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyDuplicates Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyDuplicates Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't paste duplicate types. Only non duplicate types will be pasted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCopyDuplicates { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyDuplicates As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyDuplicates {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyElevationArrow Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyElevationArrow Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
To duplicate Elevations, copy the elevation symbol in a plan view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCopyElevationArrow { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyElevationArrow As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyElevationArrow {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyElevationArrowWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyElevationArrowWarn Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
To duplicate Elevations, copy the elevation symbol in a plan view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCopyElevationArrowWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyElevationArrowWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyElevationArrowWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyFamilyName Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyFamilyName Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't [Action] because Family '[Family Name]' is different in the two documents. Update the documents to contain the same version of the Family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCopyFamilyName { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyFamilyName As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyFamilyName {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyFromProjectAndLink Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyFromProjectAndLink Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't Copy to Clipboard elements from the project and a link instance at the same time. Only elements from the project will be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCopyFromProjectAndLink { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyFromProjectAndLink As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyFromProjectAndLink {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyGridLines Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyGridLines Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Curtain grid lines cannot be copied. If you are trying to copy the curtain wall, try using tab to select entire wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCopyGridLines { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyGridLines As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyGridLines {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyImportInstancesAcrossProjects Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyImportInstancesAcrossProjects Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Linked Imported Files cannot be copied across projects. All non-RVT linked files will be pasted as imports instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCopyImportInstancesAcrossProjects { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyImportInstancesAcrossProjects As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyImportInstancesAcrossProjects {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyIncompleteElement Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyIncompleteElement Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't copy part of element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCopyIncompleteElement { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyIncompleteElement As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyIncompleteElement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyJoinedGeometry Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyJoinedGeometry Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Joined solid geometry cannot be copied as a whole. Instead, select the individual extrusions, etc., using Pick box or Ctrl-select and copy them.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCopyJoinedGeometry { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyJoinedGeometry As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyJoinedGeometry {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyJoinedGeometryWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyJoinedGeometryWarn Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Joined solid geometry cannot be copied as a whole. Instead, select the individual extrusions, etc., using Pick box or Ctrl-select and copy them.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCopyJoinedGeometryWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyJoinedGeometryWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyJoinedGeometryWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyLocked Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyLocked Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't copy pinned element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCopyLocked { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyLocked As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyLocked {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyLockedWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyLockedWarn Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't copy pinned element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCopyLockedWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyLockedWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyLockedWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyMassing Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyMassing Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
A massing cannot be copied. Copy the elements within the massing instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCopyMassing { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyMassing As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyMassing {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyMassingWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyMassingWarn Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
A massing cannot be copied. Copy the elements within the massing instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCopyMassingWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyMassingWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyMassingWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyMullions Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyMullions Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Mullions and panels cannot be copied without copying the entire curtain wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCopyMullions { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyMullions As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyMullions {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyMullionsError Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyMullionsError Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Mullions and panels cannot be copied without copying the entire curtain wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCopyMullionsError { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyMullionsError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyMullionsError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyMullionsWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyMullionsWarn Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Mullions and panels cannot be copied without copying the entire curtain wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCopyMullionsWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyMullionsWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyMullionsWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyMultipleSketchParents Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyMultipleSketchParents Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Copying elements from unrelated Workplanes together is not supported in families. Try copying elements separately.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCopyMultipleSketchParents { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyMultipleSketchParents As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyMultipleSketchParents {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyMustBeUnique Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyMustBeUnique Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Element must be unique.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCopyMustBeUnique { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyMustBeUnique As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyMustBeUnique {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyNoAttachedParent Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyNoAttachedParent Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Attached Detail Group can't be copied without its Model Group

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCopyNoAttachedParent { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyNoAttachedParent As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyNoAttachedParent {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyNoAttachedParentWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyNoAttachedParentWarn Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Attached Detail Group can't be copied without its Model Group

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCopyNoAttachedParentWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyNoAttachedParentWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyNoAttachedParentWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyNoReferences Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyNoReferences Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Elements can't be copied because they will lose their References.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCopyNoReferences { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyNoReferences As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyNoReferences {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyRevolveAxis Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyRevolveAxis Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
The axis cannot be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCopyRevolveAxis { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyRevolveAxis As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyRevolveAxis {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyRevolveAxisWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyRevolveAxisWarn Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
The axis cannot be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCopyRevolveAxisWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyRevolveAxisWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyRevolveAxisWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopySelectedPick Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopySelectedPick Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
The element being dragged can't be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCopySelectedPick { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopySelectedPick As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopySelectedPick {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopySelection Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopySelection Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Cannot copy selection.[Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCopySelection { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopySelection As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopySelection {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopySketchGrid Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopySketchGrid Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Work Planes cannot be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCopySketchGrid { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopySketchGrid As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopySketchGrid {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopySketchGridWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopySketchGridWarn Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Work Planes cannot be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCopySketchGridWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopySketchGridWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopySketchGridWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopySunAndShadowSettings Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopySunAndShadowSettings Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
SunAndShadowSettings cannot be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCopySunAndShadowSettings { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopySunAndShadowSettings As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopySunAndShadowSettings {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyWallPanels Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyWallPanels Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Cannot copy wall panels unless their parent wall is also being copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCopyWallPanels { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyWallPanels As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyWallPanels {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyWallPanelsWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyWallPanelsWarn Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Cannot copy wall panels unless their parent wall is also being copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCopyWallPanelsWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyWallPanelsWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyWallPanelsWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyZone Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyZone Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
A Zone cannot be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCopyZone { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyZone As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyZone {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotDuplicate Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotDuplicate Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Elements can't be duplicated

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotDuplicate { get; }
Visual Basic
Public Shared ReadOnly Property CannotDuplicate As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDuplicate {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotDuplicateDesignOption Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotDuplicateDesignOption Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't duplicate Design Option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotDuplicateDesignOption { get; }
Visual Basic
Public Shared ReadOnly Property CannotDuplicateDesignOption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDuplicateDesignOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotDuplicateInOption Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotDuplicateInOption Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Elements can't be duplicated in a secondary Option

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotDuplicateInOption { get; }
Visual Basic
Public Shared ReadOnly Property CannotDuplicateInOption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDuplicateInOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotDuplicateInOptionWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotDuplicateInOptionWarn Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Elements can't be duplicated in a secondary Option

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotDuplicateInOptionWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotDuplicateInOptionWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDuplicateInOptionWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotDuplicateType Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotDuplicateType Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Cannot Duplicate Type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotDuplicateType { get; }
Visual Basic
Public Shared ReadOnly Property CannotDuplicateType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDuplicateType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotDuplicateWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotDuplicateWarn Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Elements can't be duplicated

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotDuplicateWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotDuplicateWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDuplicateWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotFinalizeClusterInconsistency Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotFinalizeClusterInconsistency Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't finalize because dependent element failed to finalize.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotFinalizeClusterInconsistency { get; }
Visual Basic
Public Shared ReadOnly Property CannotFinalizeClusterInconsistency As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotFinalizeClusterInconsistency {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotFinalizeOrphanSerf Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotFinalizeOrphanSerf Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't finalize Group member without finalizing the entire Group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotFinalizeOrphanSerf { get; }
Visual Basic
Public Shared ReadOnly Property CannotFinalizeOrphanSerf As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotFinalizeOrphanSerf {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotPasteAlignedAny Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotPasteAlignedAny Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't Paste Aligned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotPasteAlignedAny { get; }
Visual Basic
Public Shared ReadOnly Property CannotPasteAlignedAny As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPasteAlignedAny {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotPasteAlignedError Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotPasteAlignedError Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't Paste Align these elements in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotPasteAlignedError { get; }
Visual Basic
Public Shared ReadOnly Property CannotPasteAlignedError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPasteAlignedError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotPasteAlignedSomeLevels Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotPasteAlignedSomeLevels Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't Paste Aligned to some views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotPasteAlignedSomeLevels { get; }
Visual Basic
Public Shared ReadOnly Property CannotPasteAlignedSomeLevels As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPasteAlignedSomeLevels {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotPasteAssemblyView Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotPasteAssemblyView Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't paste assembly view because its associated assembly instance is not available.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotPasteAssemblyView { get; }
Visual Basic
Public Shared ReadOnly Property CannotPasteAssemblyView As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPasteAssemblyView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotPasteCircularLinks Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotPasteCircularLinks Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
The pasted selection includes a linked instance of this file '[Name]'. A file cannot link itself, so the link was not pasted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotPasteCircularLinks { get; }
Visual Basic
Public Shared ReadOnly Property CannotPasteCircularLinks As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPasteCircularLinks {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotPasteCurtainGridLine Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotPasteCurtainGridLine Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't paste Curtain Grid Line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotPasteCurtainGridLine { get; }
Visual Basic
Public Shared ReadOnly Property CannotPasteCurtainGridLine As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPasteCurtainGridLine {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotPasteElemInViewError Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotPasteElemInViewError Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Cannot paste the contents into %1!s! view. Attempt to paste into an appropriate view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotPasteElemInViewError { get; }
Visual Basic
Public Shared ReadOnly Property CannotPasteElemInViewError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPasteElemInViewError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotPasteInView Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotPasteInView Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Cannot paste the contents into %1!s! view. Attempt to paste into an appropriate view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotPasteInView { get; }
Visual Basic
Public Shared ReadOnly Property CannotPasteInView As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPasteInView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotPasteInViewError Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotPasteInViewError Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Cannot paste the contents into %1!s! view. Attempt to paste into an appropriate view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotPasteInViewError { get; }
Visual Basic
Public Shared ReadOnly Property CannotPasteInViewError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPasteInViewError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotPasteModelPlusViewSpecificElementsIntoView Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotPasteModelPlusViewSpecificElementsIntoView Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Cannot paste view-specific model plus into view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotPasteModelPlusViewSpecificElementsIntoView { get; }
Visual Basic
Public Shared ReadOnly Property CannotPasteModelPlusViewSpecificElementsIntoView As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPasteModelPlusViewSpecificElementsIntoView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotPasteNoLevelBelow Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotPasteNoLevelBelow Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't paste these elements at this height because there is no Level below to reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotPasteNoLevelBelow { get; }
Visual Basic
Public Shared ReadOnly Property CannotPasteNoLevelBelow As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPasteNoLevelBelow {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotPasteNoWorkplane Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotPasteNoWorkplane Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't paste because there is no corresponding Work Plane. Set workplane or switch to view with appropriate workplane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotPasteNoWorkplane { get; }
Visual Basic
Public Shared ReadOnly Property CannotPasteNoWorkplane As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPasteNoWorkplane {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotPasteRoomsInNonPlanViews Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotPasteRoomsInNonPlanViews Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
[Rooms] can only be pasted in Plan or Ceiling Plan views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotPasteRoomsInNonPlanViews { get; }
Visual Basic
Public Shared ReadOnly Property CannotPasteRoomsInNonPlanViews As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPasteRoomsInNonPlanViews {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotPasteToSheet Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotPasteToSheet Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Elements copied to Sheets can only be copied from other Sheets.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotPasteToSheet { get; }
Visual Basic
Public Shared ReadOnly Property CannotPasteToSheet As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPasteToSheet {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotTransferProjectStandards Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CannotTransferProjectStandards Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
These Project Standards cannot be transferred.[Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotTransferProjectStandards { get; }
Visual Basic
Public Shared ReadOnly Property CannotTransferProjectStandards As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotTransferProjectStandards {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CantCopyBetweenModelAndAnnotFam Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CantCopyBetweenModelAndAnnotFam Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't copy element(s) between Model and Annotation families.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CantCopyBetweenModelAndAnnotFam { get; }
Visual Basic
Public Shared ReadOnly Property CantCopyBetweenModelAndAnnotFam As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CantCopyBetweenModelAndAnnotFam {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CantCopyFrom2dTo3dFam Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CantCopyFrom2dTo3dFam Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't copy 2D element(s) into a 3D family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CantCopyFrom2dTo3dFam { get; }
Visual Basic
Public Shared ReadOnly Property CantCopyFrom2dTo3dFam As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CantCopyFrom2dTo3dFam {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CantCopyFrom3dTo2dFam Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CantCopyFrom3dTo2dFam Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't copy 3D element(s) into a 2D family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CantCopyFrom3dTo2dFam { get; }
Visual Basic
Public Shared ReadOnly Property CantCopyFrom3dTo2dFam As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CantCopyFrom3dTo2dFam {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CantCopyFromDetailToProfileFam Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CantCopyFromDetailToProfileFam Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't copy Detail element(s) into a Profile family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CantCopyFromDetailToProfileFam { get; }
Visual Basic
Public Shared ReadOnly Property CantCopyFromDetailToProfileFam As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CantCopyFromDetailToProfileFam {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CantCopyLevelsOrRefPlanesToNonMassFamily Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CantCopyLevelsOrRefPlanesToNonMassFamily Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't copy levels or reference planes to families that are not Mass families.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CantCopyLevelsOrRefPlanesToNonMassFamily { get; }
Visual Basic
Public Shared ReadOnly Property CantCopyLevelsOrRefPlanesToNonMassFamily As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CantCopyLevelsOrRefPlanesToNonMassFamily {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CantCopyStairsLevelHeightNotMatchInMS Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CantCopyStairsLevelHeightNotMatchInMS Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't copy stairs in Multistory Stairs due to level height doesn't match.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CantCopyStairsLevelHeightNotMatchInMS { get; }
Visual Basic
Public Shared ReadOnly Property CantCopyStairsLevelHeightNotMatchInMS As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CantCopyStairsLevelHeightNotMatchInMS {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CantCopySymbolicElementToSelfOrientingFamily Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CantCopySymbolicElementToSelfOrientingFamily Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Cannot copy symbolic elements sketched in non-horizontal planes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CantCopySymbolicElementToSelfOrientingFamily { get; }
Visual Basic
Public Shared ReadOnly Property CantCopySymbolicElementToSelfOrientingFamily As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CantCopySymbolicElementToSelfOrientingFamily {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CopingColumnBeamFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CopingColumnBeamFailure Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
The support order for a beam/column connection has been changed. When a beam is supported by a column that same beam cannot be coped by the column. The existing coping has been removed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CopingColumnBeamFailure { get; }
Visual Basic
Public Shared ReadOnly Property CopingColumnBeamFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CopingColumnBeamFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CopyImposterContentError Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CopyImposterContentError Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Cannot copy Render Appearance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CopyImposterContentError { get; }
Visual Basic
Public Shared ReadOnly Property CopyImposterContentError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CopyImposterContentError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CopyImposterContentWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CopyImposterContentWarn Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Cannot copy Render Appearance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CopyImposterContentWarn { get; }
Visual Basic
Public Shared ReadOnly Property CopyImposterContentWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CopyImposterContentWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CopyImposterLightError Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..CopyImposterLightError Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Light source cannot be copied!

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CopyImposterLightError { get; }
Visual Basic
Public Shared ReadOnly Property CopyImposterLightError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CopyImposterLightError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


FinalizedElementsWillBeDeleted Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..FinalizedElementsWillBeDeleted Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't find new hosts for this Element.\nIt will be deleted on Finish Paste unless repositioned or rehosted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FinalizedElementsWillBeDeleted { get; }
Visual Basic
Public Shared ReadOnly Property FinalizedElementsWillBeDeleted As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FinalizedElementsWillBeDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


FinalizedElementsWillBeModified Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..FinalizedElementsWillBeModified Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't find some new hosts for this Element.\nIt will lose references on Finish Paste unless repositioned or rehosted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FinalizedElementsWillBeModified { get; }
Visual Basic
Public Shared ReadOnly Property FinalizedElementsWillBeModified As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FinalizedElementsWillBeModified {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


LostReference Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..LostReference Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
A relationship between Elements in [Option Name] and [Reference Option Name] has been deleted. There is no corresponding relationship in the Primary [New Primary Option Name].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId LostReference { get; }
Visual Basic
Public Shared ReadOnly Property LostReference As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LostReference {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


NoSketchPlane Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..NoSketchPlane Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't paste because no Work Plane is defined in the View.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoSketchPlane { get; }
Visual Basic
Public Shared ReadOnly Property NoSketchPlane As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoSketchPlane {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


PasteInvisibleInView Property

[image]

Revit 2024 API
BuiltInFailures..::..CopyPasteFailures..::..PasteInvisibleInView Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Selection is invisible in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId PasteInvisibleInView { get; }
Visual Basic
Public Shared ReadOnly Property PasteInvisibleInView As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PasteInvisibleInView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


BuiltInFailures.CreationFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..CreationFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about CreationFailures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class CreationFailures
Visual Basic
Public NotInheritable Class CreationFailures
Visual C++
public ref class CreationFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..CreationFailures

See Also

BuiltInFailures..::..CreationFailures Members


CannotCreateCornice Property

[image]

Revit 2024 API
BuiltInFailures..::..CreationFailures..::..CannotCreateCornice Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Could not create Wall Sweep. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateCornice { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateCornice As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateCornice {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateCorniceError Property

[image]

Revit 2024 API
BuiltInFailures..::..CreationFailures..::..CannotCreateCorniceError Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Could not create Wall Sweep. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateCorniceError { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateCorniceError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateCorniceError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateCorniceIntegral Property

[image]

Revit 2024 API
BuiltInFailures..::..CreationFailures..::..CannotCreateCorniceIntegral Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Could not create integral wall sweep for wall instance. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateCorniceIntegral { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateCorniceIntegral As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateCorniceIntegral {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateCorniceIntegralError Property

[image]

Revit 2024 API
BuiltInFailures..::..CreationFailures..::..CannotCreateCorniceIntegralError Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Could not create integral wall sweep for wall instance. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateCorniceIntegralError { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateCorniceIntegralError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateCorniceIntegralError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateCorniceIntegralWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..CreationFailures..::..CannotCreateCorniceIntegralWarn Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Could not create integral wall sweep for wall instance. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateCorniceIntegralWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateCorniceIntegralWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateCorniceIntegralWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateCorniceWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..CreationFailures..::..CannotCreateCorniceWarn Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Could not create Wall Sweep. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateCorniceWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateCorniceWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateCorniceWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateCutout Property

[image]

Revit 2024 API
BuiltInFailures..::..CreationFailures..::..CannotCreateCutout Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Can't make cut-out.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateCutout { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateCutout As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateCutout {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateCutoutWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..CreationFailures..::..CannotCreateCutoutWarn Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Can't make cut-out.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateCutoutWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateCutoutWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateCutoutWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateElementInFamily Property

[image]

Revit 2024 API
BuiltInFailures..::..CreationFailures..::..CannotCreateElementInFamily Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Can't create element in this family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateElementInFamily { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateElementInFamily As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateElementInFamily {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateElementInView Property

[image]

Revit 2024 API
BuiltInFailures..::..CreationFailures..::..CannotCreateElementInView Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Can't create this kind of element in this view in the current mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateElementInView { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateElementInView As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateElementInView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateExplicitCrease Property

[image]

Revit 2024 API
BuiltInFailures..::..CreationFailures..::..CannotCreateExplicitCrease Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Cannot create a new split line based on the picked support.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateExplicitCrease { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateExplicitCrease As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateExplicitCrease {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateFascia Property

[image]

Revit 2024 API
BuiltInFailures..::..CreationFailures..::..CannotCreateFascia Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Could not create Fascia. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateFascia { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateFascia As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateFascia {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateFasciaError Property

[image]

Revit 2024 API
BuiltInFailures..::..CreationFailures..::..CannotCreateFasciaError Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Could not create Fascia. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateFasciaError { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateFasciaError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateFasciaError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateFasciaWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..CreationFailures..::..CannotCreateFasciaWarn Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Could not create Fascia. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateFasciaWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateFasciaWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateFasciaWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateGutter Property

[image]

Revit 2024 API
BuiltInFailures..::..CreationFailures..::..CannotCreateGutter Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Could not create Gutter. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateGutter { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateGutter As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateGutter {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateGutterWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..CreationFailures..::..CannotCreateGutterWarn Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Could not create Gutter. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateGutterWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateGutterWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateGutterWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateMullion Property

[image]

Revit 2024 API
BuiltInFailures..::..CreationFailures..::..CannotCreateMullion Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Can't create Mullion.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateMullion { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateMullion As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateMullion {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateMullionReference Property

[image]

Revit 2024 API
BuiltInFailures..::..CreationFailures..::..CannotCreateMullionReference Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Can't create Curtain Wall Mullion. The grid segment for the Mullion is probably too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateMullionReference { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateMullionReference As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateMullionReference {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateMullionReferenceNoGeometry Property

[image]

Revit 2024 API
BuiltInFailures..::..CreationFailures..::..CannotCreateMullionReferenceNoGeometry Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Can't create Curtain Wall Mullion. The portion of the curtain grid it was placed on no longer exists.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateMullionReferenceNoGeometry { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateMullionReferenceNoGeometry As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateMullionReferenceNoGeometry {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateNewDesignOption Property

[image]

Revit 2024 API
BuiltInFailures..::..CreationFailures..::..CannotCreateNewDesignOption Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Cannot create a new empty design option

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateNewDesignOption { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateNewDesignOption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateNewDesignOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateOldCornerMullion Property

[image]

Revit 2024 API
BuiltInFailures..::..CreationFailures..::..CannotCreateOldCornerMullion Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Cannot change the type of a mullion created prior to release 4.0 to a corner mullion type. Try deleting the existing mullion and placing a new one.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateOldCornerMullion { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateOldCornerMullion As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateOldCornerMullion {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateOpening Property

[image]

Revit 2024 API
BuiltInFailures..::..CreationFailures..::..CannotCreateOpening Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Cannot create opening.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateOpening { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateOpening As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateOpening {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateOpeningRectangularArcWall Property

[image]

Revit 2024 API
BuiltInFailures..::..CreationFailures..::..CannotCreateOpeningRectangularArcWall Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Creation of a Rectangular Arc Wall Opening failed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateOpeningRectangularArcWall { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateOpeningRectangularArcWall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateOpeningRectangularArcWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateReveal Property

[image]

Revit 2024 API
BuiltInFailures..::..CreationFailures..::..CannotCreateReveal Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Could not create Reveal. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateReveal { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateReveal As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateReveal {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateRevealError Property

[image]

Revit 2024 API
BuiltInFailures..::..CreationFailures..::..CannotCreateRevealError Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Could not create Reveal. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateRevealError { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateRevealError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateRevealError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateRevealIntegral Property

[image]

Revit 2024 API
BuiltInFailures..::..CreationFailures..::..CannotCreateRevealIntegral Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Could not create integral reveal for wall instance. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateRevealIntegral { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateRevealIntegral As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateRevealIntegral {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateRevealIntegralError Property

[image]

Revit 2024 API
BuiltInFailures..::..CreationFailures..::..CannotCreateRevealIntegralError Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Could not create integral reveal for wall instance. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateRevealIntegralError { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateRevealIntegralError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateRevealIntegralError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateRevealIntegralWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..CreationFailures..::..CannotCreateRevealIntegralWarn Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Could not create integral reveal for wall instance. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateRevealIntegralWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateRevealIntegralWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateRevealIntegralWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateRevealWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..CreationFailures..::..CannotCreateRevealWarn Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Could not create Reveal. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateRevealWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateRevealWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateRevealWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateSlabEdgeError Property

[image]

Revit 2024 API
BuiltInFailures..::..CreationFailures..::..CannotCreateSlabEdgeError Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Could not create Slab Edge. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateSlabEdgeError { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateSlabEdgeError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateSlabEdgeError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateSlabEdgeWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..CreationFailures..::..CannotCreateSlabEdgeWarn Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Could not create Slab Edge. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateSlabEdgeWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateSlabEdgeWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateSlabEdgeWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateSlantedWallWithSingularLayers Property

[image]

Revit 2024 API
BuiltInFailures..::..CreationFailures..::..CannotCreateSlantedWallWithSingularLayers Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Cannot create wall - its layers would degenerate or intersect. Reduce the wall's height or slant.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateSlantedWallWithSingularLayers { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateSlantedWallWithSingularLayers As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateSlantedWallWithSingularLayers {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateSlantedWallWithSingularLayersError Property

[image]

Revit 2024 API
BuiltInFailures..::..CreationFailures..::..CannotCreateSlantedWallWithSingularLayersError Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Cannot create wall - its layers would degenerate or. Reduce the wall's height or slant.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateSlantedWallWithSingularLayersError { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateSlantedWallWithSingularLayersError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateSlantedWallWithSingularLayersError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateTaperedWallForWallType Property

[image]

Revit 2024 API
BuiltInFailures..::..CreationFailures..::..CannotCreateTaperedWallForWallType Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Cannot create tapered wall - the Wall Type is unacceptable. Be sure to choose a variable-thickness layer in the Wall Type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateTaperedWallForWallType { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateTaperedWallForWallType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateTaperedWallForWallType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateTaperedWallForWallTypeError Property

[image]

Revit 2024 API
BuiltInFailures..::..CreationFailures..::..CannotCreateTaperedWallForWallTypeError Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Cannot create tapered wall - the Wall Type is unacceptable. Be sure to choose a variable-thickness layer in the Wall Type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateTaperedWallForWallTypeError { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateTaperedWallForWallTypeError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateTaperedWallForWallTypeError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateThis Property

[image]

Revit 2024 API
BuiltInFailures..::..CreationFailures..::..CannotCreateThis Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Can't create [Element].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateThis { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateThis As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateThis {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotDrawRoof Property

[image]

Revit 2024 API
BuiltInFailures..::..CreationFailures..::..CannotDrawRoof Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Can't make roof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotDrawRoof { get; }
Visual Basic
Public Shared ReadOnly Property CannotDrawRoof As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDrawRoof {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotDrawRoofError Property

[image]

Revit 2024 API
BuiltInFailures..::..CreationFailures..::..CannotDrawRoofError Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Can't make roof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotDrawRoofError { get; }
Visual Basic
Public Shared ReadOnly Property CannotDrawRoofError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDrawRoofError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotDrawRoofWall Property

[image]

Revit 2024 API
BuiltInFailures..::..CreationFailures..::..CannotDrawRoofWall Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Can't make roof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotDrawRoofWall { get; }
Visual Basic
Public Shared ReadOnly Property CannotDrawRoofWall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDrawRoofWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotDrawSingularSlantedWall Property

[image]

Revit 2024 API
BuiltInFailures..::..CreationFailures..::..CannotDrawSingularSlantedWall Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Cannot create wall - it would intersect itself. Reduce the wall's height or slant.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotDrawSingularSlantedWall { get; }
Visual Basic
Public Shared ReadOnly Property CannotDrawSingularSlantedWall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDrawSingularSlantedWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotDrawSingularSlantedWallError Property

[image]

Revit 2024 API
BuiltInFailures..::..CreationFailures..::..CannotDrawSingularSlantedWallError Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Cannot create wall - it would intersect itself. Reduce the wall's height or slant.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotDrawSingularSlantedWallError { get; }
Visual Basic
Public Shared ReadOnly Property CannotDrawSingularSlantedWallError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDrawSingularSlantedWallError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotDrawWalls Property

[image]

Revit 2024 API
BuiltInFailures..::..CreationFailures..::..CannotDrawWalls Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Can't make Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotDrawWalls { get; }
Visual Basic
Public Shared ReadOnly Property CannotDrawWalls As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDrawWalls {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotDrawWallsError Property

[image]

Revit 2024 API
BuiltInFailures..::..CreationFailures..::..CannotDrawWallsError Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Can't make Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotDrawWallsError { get; }
Visual Basic
Public Shared ReadOnly Property CannotDrawWallsError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDrawWallsError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotMakeRoofFromVerticalFace Property

[image]

Revit 2024 API
BuiltInFailures..::..CreationFailures..::..CannotMakeRoofFromVerticalFace Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Can't make roof from vertical face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotMakeRoofFromVerticalFace { get; }
Visual Basic
Public Shared ReadOnly Property CannotMakeRoofFromVerticalFace As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMakeRoofFromVerticalFace {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotMakeRoofFromVerticalFaceError Property

[image]

Revit 2024 API
BuiltInFailures..::..CreationFailures..::..CannotMakeRoofFromVerticalFaceError Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Can't make roof from vertical face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotMakeRoofFromVerticalFaceError { get; }
Visual Basic
Public Shared ReadOnly Property CannotMakeRoofFromVerticalFaceError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMakeRoofFromVerticalFaceError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotMakeSurface Property

[image]

Revit 2024 API
BuiltInFailures..::..CreationFailures..::..CannotMakeSurface Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Can't construct surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotMakeSurface { get; }
Visual Basic
Public Shared ReadOnly Property CannotMakeSurface As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMakeSurface {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotMakeSurfaceError Property

[image]

Revit 2024 API
BuiltInFailures..::..CreationFailures..::..CannotMakeSurfaceError Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Can't construct surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotMakeSurfaceError { get; }
Visual Basic
Public Shared ReadOnly Property CannotMakeSurfaceError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMakeSurfaceError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotMakeSurfaceWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..CreationFailures..::..CannotMakeSurfaceWarn Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Can't construct surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotMakeSurfaceWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotMakeSurfaceWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMakeSurfaceWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotUpdateWall Property

[image]

Revit 2024 API
BuiltInFailures..::..CreationFailures..::..CannotUpdateWall Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Can't update Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotUpdateWall { get; }
Visual Basic
Public Shared ReadOnly Property CannotUpdateWall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotUpdateWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


SwitchFromLegendBeforeCreateSimilar Property

[image]

Revit 2024 API
BuiltInFailures..::..CreationFailures..::..SwitchFromLegendBeforeCreateSimilar Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
To Create Similar from a Legend View, first select the element, then activate the target view, then invoke Create Similar.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SwitchFromLegendBeforeCreateSimilar { get; }
Visual Basic
Public Shared ReadOnly Property SwitchFromLegendBeforeCreateSimilar As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SwitchFromLegendBeforeCreateSimilar {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


BuiltInFailures.CurtainGridFamilyFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..CurtainGridFamilyFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about CurtainGrid Family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class CurtainGridFamilyFailures
Visual Basic
Public NotInheritable Class CurtainGridFamilyFailures
Visual C++
public ref class CurtainGridFamilyFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..CurtainGridFamilyFailures

See Also

BuiltInFailures..::..CurtainGridFamilyFailures Members


BuiltInFailures.CurtainGridFamilyFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..CurtainGridFamilyFailures Members
BuiltInFailures..::..CurtainGridFamilyFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..CurtainGridFamilyFailures type exposes the following members.

Properties

Name | Description
AllMullionsAreTooShort | The mullion(s) you are trying to place is too short for his type, and was not placed on the grid.
CannotCreateCornerMullionDueAngle | Can't create Corner Mullion due to the angle between the neighboring panels. Try changing the Parameters in the Curtain Wall Mullion Family.
CannotCreateCurtainPanelCorruption | Can't create Curtain Panel. A Panel or a Mullion is probably too small.
CannotCreateCurtainPanelError |
CannotCreateCurtainPanelInOpeningCorruption | Can't create Curtain Panel in opening. The opening is probably too small.
CannotCreateCurtainPanelInOpeningWarning |
CannotGenerateAllNecessaryElements | Unable to regenerate all necessary elements.
CannotPlaceSystemMullionFamilyOnCurtainWall | Can't place System Mullion Family on this Curtain Wall.
CannotPlaceSystemPanelsInOldArcedCurtainWalls | Can't place System Panels in arced Curtain Walls created prior to 3.0, nor in straight Curtain Walls created prior to version 2.0.
CornerMullionOverlapsOtherOnePlacedOnNeighboringRegion | Corner Mullion overlaps Mullion placed on neighboring Curtain region.
CornerMullionsNeighborsMustBeTangent | Corner Mullions must be placed at a location that can have neighboring Panels that are not tangent. With the exception of Wall Join locations, Corner Mullions are not currently supported on the external boundaries of Curtain elements.
CurtainPanelNotBelongsToElement | Curtain element Panel doesn't belong to Curtain element. In merging, you must select the version of a Curtain element that has had Panels added to it.
CurtainPanelsParamDefinedTypeDefinedCirculary | Parameter-defined type of curtain panels defined in a circular way and default panel type will be used instead.
CurtainSystemCouldnotReacquireFaces | Curtain System could not reacquire [Number] faces out of [Number].
InvalidCurtainPanelInModel | There is an invalid Curtain Panel in the model. This is probably caused by two Grid Lines almost meeting at a border of the Curtain Wall or Sloped Glazing, but not exactly at a point. The Curtain Panel can't be displayed.
MullionProfileContainsMoreThanOneOrOpenLoop | The selected mullion profile either contains more than one profile loop or an open profile loop and cannot be used. Valid profiles can only have a single continuous closed profile loop.
NonSystemPanelFamiliesCannotBeUsed | Non-system panel families cannot be used for non-rectangular panels. If your panel is simple, create an appropriate panel type derived from the system panel family. If not, try making the panel in the wall or roof rectangular, and then using a panel family of the desired (non-rectangular) shape. The wall will then conform to the non-rectangular shape of the panel.
PanelsSlightlyMalformedCorruption | Some panels in this curtain system are slightly malformed. The problem is most likely ignorable. This problem usually occurs when a panel or parts of a panel have been divided so that they are very narrow. To better see the malformed panels, temporarily hide the mullion category and set display of lines to ""thin lines"" (using the command on the view menu).
PanelsSlightlyMalformedWarning | Some panels in this curtain system are slightly malformed. The problem is most likely ignorable. This problem usually occurs when a panel or parts of a panel have been divided so that they are very narrow. To better see the malformed panels, temporarily hide the mullion category and set display of lines to ""thin lines"" (using the command on the view menu).
SomeMullionsAreTooShort | Some of the mullions you are trying to place are too short for its types, and were not placed on the grid.

See Also

BuiltInFailures..::..CurtainGridFamilyFailures Class


BuiltInFailures.CurtainGridFamilyFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..CurtainGridFamilyFailures Properties
BuiltInFailures..::..CurtainGridFamilyFailures Class See Also Send Feedback

The BuiltInFailures..::..CurtainGridFamilyFailures type exposes the following members.

Properties

Name | Description
AllMullionsAreTooShort | The mullion(s) you are trying to place is too short for his type, and was not placed on the grid.
CannotCreateCornerMullionDueAngle | Can't create Corner Mullion due to the angle between the neighboring panels. Try changing the Parameters in the Curtain Wall Mullion Family.
CannotCreateCurtainPanelCorruption | Can't create Curtain Panel. A Panel or a Mullion is probably too small.
CannotCreateCurtainPanelError |
CannotCreateCurtainPanelInOpeningCorruption | Can't create Curtain Panel in opening. The opening is probably too small.
CannotCreateCurtainPanelInOpeningWarning |
CannotGenerateAllNecessaryElements | Unable to regenerate all necessary elements.
CannotPlaceSystemMullionFamilyOnCurtainWall | Can't place System Mullion Family on this Curtain Wall.
CannotPlaceSystemPanelsInOldArcedCurtainWalls | Can't place System Panels in arced Curtain Walls created prior to 3.0, nor in straight Curtain Walls created prior to version 2.0.
CornerMullionOverlapsOtherOnePlacedOnNeighboringRegion | Corner Mullion overlaps Mullion placed on neighboring Curtain region.
CornerMullionsNeighborsMustBeTangent | Corner Mullions must be placed at a location that can have neighboring Panels that are not tangent. With the exception of Wall Join locations, Corner Mullions are not currently supported on the external boundaries of Curtain elements.
CurtainPanelNotBelongsToElement | Curtain element Panel doesn't belong to Curtain element. In merging, you must select the version of a Curtain element that has had Panels added to it.
CurtainPanelsParamDefinedTypeDefinedCirculary | Parameter-defined type of curtain panels defined in a circular way and default panel type will be used instead.
CurtainSystemCouldnotReacquireFaces | Curtain System could not reacquire [Number] faces out of [Number].
InvalidCurtainPanelInModel | There is an invalid Curtain Panel in the model. This is probably caused by two Grid Lines almost meeting at a border of the Curtain Wall or Sloped Glazing, but not exactly at a point. The Curtain Panel can't be displayed.
MullionProfileContainsMoreThanOneOrOpenLoop | The selected mullion profile either contains more than one profile loop or an open profile loop and cannot be used. Valid profiles can only have a single continuous closed profile loop.
NonSystemPanelFamiliesCannotBeUsed | Non-system panel families cannot be used for non-rectangular panels. If your panel is simple, create an appropriate panel type derived from the system panel family. If not, try making the panel in the wall or roof rectangular, and then using a panel family of the desired (non-rectangular) shape. The wall will then conform to the non-rectangular shape of the panel.
PanelsSlightlyMalformedCorruption | Some panels in this curtain system are slightly malformed. The problem is most likely ignorable. This problem usually occurs when a panel or parts of a panel have been divided so that they are very narrow. To better see the malformed panels, temporarily hide the mullion category and set display of lines to ""thin lines"" (using the command on the view menu).
PanelsSlightlyMalformedWarning | Some panels in this curtain system are slightly malformed. The problem is most likely ignorable. This problem usually occurs when a panel or parts of a panel have been divided so that they are very narrow. To better see the malformed panels, temporarily hide the mullion category and set display of lines to ""thin lines"" (using the command on the view menu).
SomeMullionsAreTooShort | Some of the mullions you are trying to place are too short for its types, and were not placed on the grid.

See Also

BuiltInFailures..::..CurtainGridFamilyFailures Class


AllMullionsAreTooShort Property

[image]

Revit 2024 API
BuiltInFailures..::..CurtainGridFamilyFailures..::..AllMullionsAreTooShort Property
BuiltInFailures..::..CurtainGridFamilyFailures Class See Also Send Feedback
The mullion(s) you are trying to place is too short for his type, and was not placed on the grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AllMullionsAreTooShort { get; }
Visual Basic
Public Shared ReadOnly Property AllMullionsAreTooShort As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AllMullionsAreTooShort {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainGridFamilyFailures Class


CannotCreateCornerMullionDueAngle Property

[image]

Revit 2024 API
BuiltInFailures..::..CurtainGridFamilyFailures..::..CannotCreateCornerMullionDueAngle Property
BuiltInFailures..::..CurtainGridFamilyFailures Class See Also Send Feedback
Can't create Corner Mullion due to the angle between the neighboring panels. Try changing the Parameters in the Curtain Wall Mullion Family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateCornerMullionDueAngle { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateCornerMullionDueAngle As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateCornerMullionDueAngle {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainGridFamilyFailures Class


CannotCreateCurtainPanelCorruption Property

[image]

Revit 2024 API
BuiltInFailures..::..CurtainGridFamilyFailures..::..CannotCreateCurtainPanelCorruption Property
BuiltInFailures..::..CurtainGridFamilyFailures Class See Also Send Feedback
Can't create Curtain Panel. A Panel or a Mullion is probably too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateCurtainPanelCorruption { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateCurtainPanelCorruption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateCurtainPanelCorruption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainGridFamilyFailures Class


CannotCreateCurtainPanelError Property

[image]

Revit 2024 API
BuiltInFailures..::..CurtainGridFamilyFailures..::..CannotCreateCurtainPanelError Property
BuiltInFailures..::..CurtainGridFamilyFailures Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateCurtainPanelError { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateCurtainPanelError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateCurtainPanelError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainGridFamilyFailures Class


CannotCreateCurtainPanelInOpeningCorruption Property

[image]

Revit 2024 API
BuiltInFailures..::..CurtainGridFamilyFailures..::..CannotCreateCurtainPanelInOpeningCorruption Property
BuiltInFailures..::..CurtainGridFamilyFailures Class See Also Send Feedback
Can't create Curtain Panel in opening. The opening is probably too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateCurtainPanelInOpeningCorruption { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateCurtainPanelInOpeningCorruption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateCurtainPanelInOpeningCorruption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainGridFamilyFailures Class


CannotCreateCurtainPanelInOpeningWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..CurtainGridFamilyFailures..::..CannotCreateCurtainPanelInOpeningWarning Property
BuiltInFailures..::..CurtainGridFamilyFailures Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateCurtainPanelInOpeningWarning { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateCurtainPanelInOpeningWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateCurtainPanelInOpeningWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainGridFamilyFailures Class


CannotGenerateAllNecessaryElements Property

[image]

Revit 2024 API
BuiltInFailures..::..CurtainGridFamilyFailures..::..CannotGenerateAllNecessaryElements Property
BuiltInFailures..::..CurtainGridFamilyFailures Class See Also Send Feedback
Unable to regenerate all necessary elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotGenerateAllNecessaryElements { get; }
Visual Basic
Public Shared ReadOnly Property CannotGenerateAllNecessaryElements As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotGenerateAllNecessaryElements {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainGridFamilyFailures Class


CannotPlaceSystemMullionFamilyOnCurtainWall Property

[image]

Revit 2024 API
BuiltInFailures..::..CurtainGridFamilyFailures..::..CannotPlaceSystemMullionFamilyOnCurtainWall Property
BuiltInFailures..::..CurtainGridFamilyFailures Class See Also Send Feedback
Can't place System Mullion Family on this Curtain Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotPlaceSystemMullionFamilyOnCurtainWall { get; }
Visual Basic
Public Shared ReadOnly Property CannotPlaceSystemMullionFamilyOnCurtainWall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPlaceSystemMullionFamilyOnCurtainWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainGridFamilyFailures Class


CannotPlaceSystemPanelsInOldArcedCurtainWalls Property

[image]

Revit 2024 API
BuiltInFailures..::..CurtainGridFamilyFailures..::..CannotPlaceSystemPanelsInOldArcedCurtainWalls Property
BuiltInFailures..::..CurtainGridFamilyFailures Class See Also Send Feedback
Can't place System Panels in arced Curtain Walls created prior to 3.0, nor in straight Curtain Walls created prior to version 2.0.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotPlaceSystemPanelsInOldArcedCurtainWalls { get; }
Visual Basic
Public Shared ReadOnly Property CannotPlaceSystemPanelsInOldArcedCurtainWalls As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPlaceSystemPanelsInOldArcedCurtainWalls {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainGridFamilyFailures Class


CornerMullionOverlapsOtherOnePlacedOnNeighboringRegion Property

[image]

Revit 2024 API
BuiltInFailures..::..CurtainGridFamilyFailures..::..CornerMullionOverlapsOtherOnePlacedOnNeighboringRegion Property
BuiltInFailures..::..CurtainGridFamilyFailures Class See Also Send Feedback
Corner Mullion overlaps Mullion placed on neighboring Curtain region.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CornerMullionOverlapsOtherOnePlacedOnNeighboringRegion { get; }
Visual Basic
Public Shared ReadOnly Property CornerMullionOverlapsOtherOnePlacedOnNeighboringRegion As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CornerMullionOverlapsOtherOnePlacedOnNeighboringRegion {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainGridFamilyFailures Class


CornerMullionsNeighborsMustBeTangent Property

[image]

Revit 2024 API
BuiltInFailures..::..CurtainGridFamilyFailures..::..CornerMullionsNeighborsMustBeTangent Property
BuiltInFailures..::..CurtainGridFamilyFailures Class See Also Send Feedback
Corner Mullions must be placed at a location that can have neighboring Panels that are not tangent. With the exception of Wall Join locations, Corner Mullions are not currently supported on the external boundaries of Curtain elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CornerMullionsNeighborsMustBeTangent { get; }
Visual Basic
Public Shared ReadOnly Property CornerMullionsNeighborsMustBeTangent As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CornerMullionsNeighborsMustBeTangent {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainGridFamilyFailures Class


CurtainPanelNotBelongsToElement Property

[image]

Revit 2024 API
BuiltInFailures..::..CurtainGridFamilyFailures..::..CurtainPanelNotBelongsToElement Property
BuiltInFailures..::..CurtainGridFamilyFailures Class See Also Send Feedback
Curtain element Panel doesn't belong to Curtain element. In merging, you must select the version of a Curtain element that has had Panels added to it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CurtainPanelNotBelongsToElement { get; }
Visual Basic
Public Shared ReadOnly Property CurtainPanelNotBelongsToElement As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CurtainPanelNotBelongsToElement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainGridFamilyFailures Class


CurtainPanelsParamDefinedTypeDefinedCirculary Property

[image]

Revit 2024 API
BuiltInFailures..::..CurtainGridFamilyFailures..::..CurtainPanelsParamDefinedTypeDefinedCirculary Property
BuiltInFailures..::..CurtainGridFamilyFailures Class See Also Send Feedback
Parameter-defined type of curtain panels defined in a circular way and default panel type will be used instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CurtainPanelsParamDefinedTypeDefinedCirculary { get; }
Visual Basic
Public Shared ReadOnly Property CurtainPanelsParamDefinedTypeDefinedCirculary As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CurtainPanelsParamDefinedTypeDefinedCirculary {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainGridFamilyFailures Class


InvalidCurtainPanelInModel Property

[image]

Revit 2024 API
BuiltInFailures..::..CurtainGridFamilyFailures..::..InvalidCurtainPanelInModel Property
BuiltInFailures..::..CurtainGridFamilyFailures Class See Also Send Feedback
There is an invalid Curtain Panel in the model. This is probably caused by two Grid Lines almost meeting at a border of the Curtain Wall or Sloped Glazing, but not exactly at a point. The Curtain Panel can't be displayed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidCurtainPanelInModel { get; }
Visual Basic
Public Shared ReadOnly Property InvalidCurtainPanelInModel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidCurtainPanelInModel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainGridFamilyFailures Class


NonSystemPanelFamiliesCannotBeUsed Property

[image]

Revit 2024 API
BuiltInFailures..::..CurtainGridFamilyFailures..::..NonSystemPanelFamiliesCannotBeUsed Property
BuiltInFailures..::..CurtainGridFamilyFailures Class See Also Send Feedback
Non-system panel families cannot be used for non-rectangular panels. If your panel is simple, create an appropriate panel type derived from the system panel family. If not, try making the panel in the wall or roof rectangular, and then using a panel family of the desired (non-rectangular) shape. The wall will then conform to the non-rectangular shape of the panel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NonSystemPanelFamiliesCannotBeUsed { get; }
Visual Basic
Public Shared ReadOnly Property NonSystemPanelFamiliesCannotBeUsed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NonSystemPanelFamiliesCannotBeUsed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainGridFamilyFailures Class


PanelsSlightlyMalformedWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..CurtainGridFamilyFailures..::..PanelsSlightlyMalformedWarning Property
BuiltInFailures..::..CurtainGridFamilyFailures Class See Also Send Feedback
Some panels in this curtain system are slightly malformed. The problem is most likely ignorable. This problem usually occurs when a panel or parts of a panel have been divided so that they are very narrow. To better see the malformed panels, temporarily hide the mullion category and set display of lines to ""thin lines"" (using the command on the view menu).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId PanelsSlightlyMalformedWarning { get; }
Visual Basic
Public Shared ReadOnly Property PanelsSlightlyMalformedWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PanelsSlightlyMalformedWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainGridFamilyFailures Class


SomeMullionsAreTooShort Property

[image]

Revit 2024 API
BuiltInFailures..::..CurtainGridFamilyFailures..::..SomeMullionsAreTooShort Property
BuiltInFailures..::..CurtainGridFamilyFailures Class See Also Send Feedback
Some of the mullions you are trying to place are too short for its types, and were not placed on the grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SomeMullionsAreTooShort { get; }
Visual Basic
Public Shared ReadOnly Property SomeMullionsAreTooShort As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SomeMullionsAreTooShort {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainGridFamilyFailures Class


BuiltInFailures.CurtainWallFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..CurtainWallFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about CurtainWall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class CurtainWallFailures
Visual Basic
Public NotInheritable Class CurtainWallFailures
Visual C++
public ref class CurtainWallFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..CurtainWallFailures

See Also

BuiltInFailures..::..CurtainWallFailures Members


BuiltInFailures.CurtainWallFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..CurtainWallFailures Members
BuiltInFailures..::..CurtainWallFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..CurtainWallFailures type exposes the following members.

Properties

Name | Description
AdjustEndCurtainWallParameterNoCorners | Can't put Corner Mullion at end joined to non-Curtain Wall.
AllGridSegmentsRemoved | Curtain grid lines must have at least one segment.
CannotApplyGridSpecification | It is not possible to apply the host family's grid specification to this instance.
CannotDivideCurtainGrid | Can't divide Curtain Grid by Grid Line.
CannotGroupCurtainGridHost | Curtain grid based elements cannot be grouped.
CannotHaveIndependentOverlappingGrids | Overlapping independent type associated gridlines are not allowed.
CannotPlaceSplitMullions | Could not determine how to place the highlighted mullions after the wall was split.
CannotSplitOldMullions | Split does not work on curtain walls containing mullions created in Revit prior to version 4.0. You may delete the mullions, place them again, and then proceed with splitting the wall.
CannotSwitchToCurtainWall | Can't switch type to Curtain Wall after Edit Elevation Profile.
CannotUseCornerMullion | Corner Mullions must be placed at a location that can have neighboring Panels that are not tangent. With the exception of Wall Join locations, Corner Mullions are not currently supported on the external boundaries of Curtain elements.
CurtainGridFaceCannotBeReparamForGridRotation | Curtain grids cannot be rotated exactly as requested. Push "Adjust Grids" to get the nearest valid rotation.
CurtainGridOffHost | Curtain grid has left its host.
CurtainSystemHostInvisible | Element defining the Curtain System is invisible in the current view.
DanglingCurtainWallCorner | A Corner Mullion has been placed at the end of a Curtain Wall that is not joined to another Curtain Wall. The angle of the Corner Mullion will default to 90 degrees.
DeletingCurtainSystemFaceGridLines | Deleting Grid Lines residing on faces that no longer are part of a Curtain System.
DependentGridlineMayBeDeleted | Type generated gridlines will become non-associated due to changes in the type. Press delete if you wish to remove them instead.
ExceedMaxDrivenGridlines | Changes have been made that cause a curtain wall with type driven grid lines to exceed the maximum allowed number of type driven lines (200 in direction (1) and 200 in direction (2)). If you really need this many type driven grid lines, please split the affected wall before proceeding.
ExessiveBeltDistance | The requested Measurement Line Offset would place the put the Measurement Line of the face boundaries.
GridlinesOutOfBounds | Manually placed curtain grid lines are on the wall edges or outside the wall boundaries.
GridlinesOutOfBoundsWarn | Manually placed curtain grid lines are on the wall edges or outside the wall boundaries.
GridlinesOutsideWillBeRedependent | Type associated curtain grid lines outside of the edited wall boundaries will be made dependent again in order that they remain on the wall.
GridlinesOverlap | Overlapping gridlines should be avoided, unless there are only two and one is host type dependent and the other is not.
GridlinesWerePushed | Panels and mullions created by a curtain grid were created with slight inaccuracies.
GridOutOfOrder | Curtain wall grid lines have changed order.
GridOutOfOrderError | Curtain wall grid lines have changed order.
GridOutsideWall | Curtain wall grid lines are outside wall. If you are trying to shorten the wall, please remove grid lines, including mullions on top of them.
InvalidSkipSegments | A curtain grid line had invalid removed segment data. When correcting data, Revit may have split curtain panels that should be combined.
MullionLostRefReorder | Mullions have lost references as a result of gridlines changing order. These mullions must be deleted.
MullionsWillBeDeleted | The Mullions between the Panels being joined will be deleted.
MultipleDominatingMullions | Multiple dominating mullions on a grid face may cause ambiguous automatic adjustment of margins.
MultipleIdsInCurtainSystem | A Curtain System cannot be based on faces from multiple elements.
MustReplacePanels | Missing Curtain Panels will be replaced with System Panels to complete command.
NegativeBeltDistance | Measurement Line Offset cannot be negative.
NonSupportedCurtainWall | Currently, only straight Walls with straight or arc edges are supported for non-rectangular Curtain Walls.
NoPanelsLoaded | No Curtain Panel Families loaded. Can't make arced Curtain Wall.
RequestOrphanMullionDeletion | Due to the changes in parameters of their hosts some mullions became non-type driven.
RuledCurtainElementLostCurves | Ruled Curtain System cannot be built. The Lines or Edges used to create it cannot be found.
TypePanelsFronNonRectCellsUnlocked | Loaded family curtain panels cannot be used in non-rectangular cells of the curtain host. Type-driven panels from non-rectangular cells were unlocked and left unchanged.

See Also

BuiltInFailures..::..CurtainWallFailures Class


BuiltInFailures.CurtainWallFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..CurtainWallFailures Properties
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback

The BuiltInFailures..::..CurtainWallFailures type exposes the following members.

Properties

Name | Description
AdjustEndCurtainWallParameterNoCorners | Can't put Corner Mullion at end joined to non-Curtain Wall.
AllGridSegmentsRemoved | Curtain grid lines must have at least one segment.
CannotApplyGridSpecification | It is not possible to apply the host family's grid specification to this instance.
CannotDivideCurtainGrid | Can't divide Curtain Grid by Grid Line.
CannotGroupCurtainGridHost | Curtain grid based elements cannot be grouped.
CannotHaveIndependentOverlappingGrids | Overlapping independent type associated gridlines are not allowed.
CannotPlaceSplitMullions | Could not determine how to place the highlighted mullions after the wall was split.
CannotSplitOldMullions | Split does not work on curtain walls containing mullions created in Revit prior to version 4.0. You may delete the mullions, place them again, and then proceed with splitting the wall.
CannotSwitchToCurtainWall | Can't switch type to Curtain Wall after Edit Elevation Profile.
CannotUseCornerMullion | Corner Mullions must be placed at a location that can have neighboring Panels that are not tangent. With the exception of Wall Join locations, Corner Mullions are not currently supported on the external boundaries of Curtain elements.
CurtainGridFaceCannotBeReparamForGridRotation | Curtain grids cannot be rotated exactly as requested. Push "Adjust Grids" to get the nearest valid rotation.
CurtainGridOffHost | Curtain grid has left its host.
CurtainSystemHostInvisible | Element defining the Curtain System is invisible in the current view.
DanglingCurtainWallCorner | A Corner Mullion has been placed at the end of a Curtain Wall that is not joined to another Curtain Wall. The angle of the Corner Mullion will default to 90 degrees.
DeletingCurtainSystemFaceGridLines | Deleting Grid Lines residing on faces that no longer are part of a Curtain System.
DependentGridlineMayBeDeleted | Type generated gridlines will become non-associated due to changes in the type. Press delete if you wish to remove them instead.
ExceedMaxDrivenGridlines | Changes have been made that cause a curtain wall with type driven grid lines to exceed the maximum allowed number of type driven lines (200 in direction (1) and 200 in direction (2)). If you really need this many type driven grid lines, please split the affected wall before proceeding.
ExessiveBeltDistance | The requested Measurement Line Offset would place the put the Measurement Line of the face boundaries.
GridlinesOutOfBounds | Manually placed curtain grid lines are on the wall edges or outside the wall boundaries.
GridlinesOutOfBoundsWarn | Manually placed curtain grid lines are on the wall edges or outside the wall boundaries.
GridlinesOutsideWillBeRedependent | Type associated curtain grid lines outside of the edited wall boundaries will be made dependent again in order that they remain on the wall.
GridlinesOverlap | Overlapping gridlines should be avoided, unless there are only two and one is host type dependent and the other is not.
GridlinesWerePushed | Panels and mullions created by a curtain grid were created with slight inaccuracies.
GridOutOfOrder | Curtain wall grid lines have changed order.
GridOutOfOrderError | Curtain wall grid lines have changed order.
GridOutsideWall | Curtain wall grid lines are outside wall. If you are trying to shorten the wall, please remove grid lines, including mullions on top of them.
InvalidSkipSegments | A curtain grid line had invalid removed segment data. When correcting data, Revit may have split curtain panels that should be combined.
MullionLostRefReorder | Mullions have lost references as a result of gridlines changing order. These mullions must be deleted.
MullionsWillBeDeleted | The Mullions between the Panels being joined will be deleted.
MultipleDominatingMullions | Multiple dominating mullions on a grid face may cause ambiguous automatic adjustment of margins.
MultipleIdsInCurtainSystem | A Curtain System cannot be based on faces from multiple elements.
MustReplacePanels | Missing Curtain Panels will be replaced with System Panels to complete command.
NegativeBeltDistance | Measurement Line Offset cannot be negative.
NonSupportedCurtainWall | Currently, only straight Walls with straight or arc edges are supported for non-rectangular Curtain Walls.
NoPanelsLoaded | No Curtain Panel Families loaded. Can't make arced Curtain Wall.
RequestOrphanMullionDeletion | Due to the changes in parameters of their hosts some mullions became non-type driven.
RuledCurtainElementLostCurves | Ruled Curtain System cannot be built. The Lines or Edges used to create it cannot be found.
TypePanelsFronNonRectCellsUnlocked | Loaded family curtain panels cannot be used in non-rectangular cells of the curtain host. Type-driven panels from non-rectangular cells were unlocked and left unchanged.

See Also

BuiltInFailures..::..CurtainWallFailures Class


CannotApplyGridSpecification Property

[image]

Revit 2024 API
BuiltInFailures..::..CurtainWallFailures..::..CannotApplyGridSpecification Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
It is not possible to apply the host family's grid specification to this instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotApplyGridSpecification { get; }
Visual Basic
Public Shared ReadOnly Property CannotApplyGridSpecification As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotApplyGridSpecification {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


CannotDivideCurtainGrid Property

[image]

Revit 2024 API
BuiltInFailures..::..CurtainWallFailures..::..CannotDivideCurtainGrid Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Can't divide Curtain Grid by Grid Line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotDivideCurtainGrid { get; }
Visual Basic
Public Shared ReadOnly Property CannotDivideCurtainGrid As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDivideCurtainGrid {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


CannotGroupCurtainGridHost Property

[image]

Revit 2024 API
BuiltInFailures..::..CurtainWallFailures..::..CannotGroupCurtainGridHost Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Curtain grid based elements cannot be grouped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotGroupCurtainGridHost { get; }
Visual Basic
Public Shared ReadOnly Property CannotGroupCurtainGridHost As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotGroupCurtainGridHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


CannotHaveIndependentOverlappingGrids Property

[image]

Revit 2024 API
BuiltInFailures..::..CurtainWallFailures..::..CannotHaveIndependentOverlappingGrids Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Overlapping independent type associated gridlines are not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotHaveIndependentOverlappingGrids { get; }
Visual Basic
Public Shared ReadOnly Property CannotHaveIndependentOverlappingGrids As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotHaveIndependentOverlappingGrids {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


CannotPlaceSplitMullions Property

[image]

Revit 2024 API
BuiltInFailures..::..CurtainWallFailures..::..CannotPlaceSplitMullions Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Could not determine how to place the highlighted mullions after the wall was split.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotPlaceSplitMullions { get; }
Visual Basic
Public Shared ReadOnly Property CannotPlaceSplitMullions As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPlaceSplitMullions {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


CannotSplitOldMullions Property

[image]

Revit 2024 API
BuiltInFailures..::..CurtainWallFailures..::..CannotSplitOldMullions Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Split does not work on curtain walls containing mullions created in Revit prior to version 4.0. You may delete the mullions, place them again, and then proceed with splitting the wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotSplitOldMullions { get; }
Visual Basic
Public Shared ReadOnly Property CannotSplitOldMullions As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotSplitOldMullions {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


CannotSwitchToCurtainWall Property

[image]

Revit 2024 API
BuiltInFailures..::..CurtainWallFailures..::..CannotSwitchToCurtainWall Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Can't switch type to Curtain Wall after Edit Elevation Profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotSwitchToCurtainWall { get; }
Visual Basic
Public Shared ReadOnly Property CannotSwitchToCurtainWall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotSwitchToCurtainWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


CannotUseCornerMullion Property

[image]

Revit 2024 API
BuiltInFailures..::..CurtainWallFailures..::..CannotUseCornerMullion Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Corner Mullions must be placed at a location that can have neighboring Panels that are not tangent. With the exception of Wall Join locations, Corner Mullions are not currently supported on the external boundaries of Curtain elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotUseCornerMullion { get; }
Visual Basic
Public Shared ReadOnly Property CannotUseCornerMullion As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotUseCornerMullion {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


CurtainGridFaceCannotBeReparamForGridRotation Property

[image]

Revit 2024 API
BuiltInFailures..::..CurtainWallFailures..::..CurtainGridFaceCannotBeReparamForGridRotation Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Curtain grids cannot be rotated exactly as requested. Push "Adjust Grids" to get the nearest valid rotation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CurtainGridFaceCannotBeReparamForGridRotation { get; }
Visual Basic
Public Shared ReadOnly Property CurtainGridFaceCannotBeReparamForGridRotation As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CurtainGridFaceCannotBeReparamForGridRotation {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


CurtainSystemHostInvisible Property

[image]

Revit 2024 API
BuiltInFailures..::..CurtainWallFailures..::..CurtainSystemHostInvisible Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Element defining the Curtain System is invisible in the current view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CurtainSystemHostInvisible { get; }
Visual Basic
Public Shared ReadOnly Property CurtainSystemHostInvisible As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CurtainSystemHostInvisible {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


DeletingCurtainSystemFaceGridLines Property

[image]

Revit 2024 API
BuiltInFailures..::..CurtainWallFailures..::..DeletingCurtainSystemFaceGridLines Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Deleting Grid Lines residing on faces that no longer are part of a Curtain System.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DeletingCurtainSystemFaceGridLines { get; }
Visual Basic
Public Shared ReadOnly Property DeletingCurtainSystemFaceGridLines As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DeletingCurtainSystemFaceGridLines {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


DependentGridlineMayBeDeleted Property

[image]

Revit 2024 API
BuiltInFailures..::..CurtainWallFailures..::..DependentGridlineMayBeDeleted Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Type generated gridlines will become non-associated due to changes in the type. Press delete if you wish to remove them instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DependentGridlineMayBeDeleted { get; }
Visual Basic
Public Shared ReadOnly Property DependentGridlineMayBeDeleted As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DependentGridlineMayBeDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


ExceedMaxDrivenGridlines Property

[image]

Revit 2024 API
BuiltInFailures..::..CurtainWallFailures..::..ExceedMaxDrivenGridlines Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Changes have been made that cause a curtain wall with type driven grid lines to exceed the maximum allowed number of type driven lines (200 in direction (1) and 200 in direction (2)). If you really need this many type driven grid lines, please split the affected wall before proceeding.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ExceedMaxDrivenGridlines { get; }
Visual Basic
Public Shared ReadOnly Property ExceedMaxDrivenGridlines As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ExceedMaxDrivenGridlines {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


ExessiveBeltDistance Property

[image]

Revit 2024 API
BuiltInFailures..::..CurtainWallFailures..::..ExessiveBeltDistance Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
The requested Measurement Line Offset would place the put the Measurement Line of the face boundaries.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ExessiveBeltDistance { get; }
Visual Basic
Public Shared ReadOnly Property ExessiveBeltDistance As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ExessiveBeltDistance {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


GridlinesOutOfBounds Property

[image]

Revit 2024 API
BuiltInFailures..::..CurtainWallFailures..::..GridlinesOutOfBounds Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Manually placed curtain grid lines are on the wall edges or outside the wall boundaries.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId GridlinesOutOfBounds { get; }
Visual Basic
Public Shared ReadOnly Property GridlinesOutOfBounds As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GridlinesOutOfBounds {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


GridlinesOutOfBoundsWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..CurtainWallFailures..::..GridlinesOutOfBoundsWarn Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Manually placed curtain grid lines are on the wall edges or outside the wall boundaries.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId GridlinesOutOfBoundsWarn { get; }
Visual Basic
Public Shared ReadOnly Property GridlinesOutOfBoundsWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GridlinesOutOfBoundsWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


GridlinesWerePushed Property

[image]

Revit 2024 API
BuiltInFailures..::..CurtainWallFailures..::..GridlinesWerePushed Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Panels and mullions created by a curtain grid were created with slight inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId GridlinesWerePushed { get; }
Visual Basic
Public Shared ReadOnly Property GridlinesWerePushed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GridlinesWerePushed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


GridOutOfOrder Property

[image]

Revit 2024 API
BuiltInFailures..::..CurtainWallFailures..::..GridOutOfOrder Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Curtain wall grid lines have changed order.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId GridOutOfOrder { get; }
Visual Basic
Public Shared ReadOnly Property GridOutOfOrder As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GridOutOfOrder {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


GridOutOfOrderError Property

[image]

Revit 2024 API
BuiltInFailures..::..CurtainWallFailures..::..GridOutOfOrderError Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Curtain wall grid lines have changed order.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId GridOutOfOrderError { get; }
Visual Basic
Public Shared ReadOnly Property GridOutOfOrderError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GridOutOfOrderError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


GridOutsideWall Property

[image]

Revit 2024 API
BuiltInFailures..::..CurtainWallFailures..::..GridOutsideWall Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Curtain wall grid lines are outside wall. If you are trying to shorten the wall, please remove grid lines, including mullions on top of them.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId GridOutsideWall { get; }
Visual Basic
Public Shared ReadOnly Property GridOutsideWall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GridOutsideWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


MullionLostRefReorder Property

[image]

Revit 2024 API
BuiltInFailures..::..CurtainWallFailures..::..MullionLostRefReorder Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Mullions have lost references as a result of gridlines changing order. These mullions must be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MullionLostRefReorder { get; }
Visual Basic
Public Shared ReadOnly Property MullionLostRefReorder As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MullionLostRefReorder {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


MultipleDominatingMullions Property

[image]

Revit 2024 API
BuiltInFailures..::..CurtainWallFailures..::..MultipleDominatingMullions Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Multiple dominating mullions on a grid face may cause ambiguous automatic adjustment of margins.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MultipleDominatingMullions { get; }
Visual Basic
Public Shared ReadOnly Property MultipleDominatingMullions As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MultipleDominatingMullions {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


MultipleIdsInCurtainSystem Property

[image]

Revit 2024 API
BuiltInFailures..::..CurtainWallFailures..::..MultipleIdsInCurtainSystem Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
A Curtain System cannot be based on faces from multiple elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MultipleIdsInCurtainSystem { get; }
Visual Basic
Public Shared ReadOnly Property MultipleIdsInCurtainSystem As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MultipleIdsInCurtainSystem {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


MustReplacePanels Property

[image]

Revit 2024 API
BuiltInFailures..::..CurtainWallFailures..::..MustReplacePanels Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Missing Curtain Panels will be replaced with System Panels to complete command.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MustReplacePanels { get; }
Visual Basic
Public Shared ReadOnly Property MustReplacePanels As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MustReplacePanels {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


NoPanelsLoaded Property

[image]

Revit 2024 API
BuiltInFailures..::..CurtainWallFailures..::..NoPanelsLoaded Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
No Curtain Panel Families loaded. Can't make arced Curtain Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoPanelsLoaded { get; }
Visual Basic
Public Shared ReadOnly Property NoPanelsLoaded As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoPanelsLoaded {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


RuledCurtainElementLostCurves Property

[image]

Revit 2024 API
BuiltInFailures..::..CurtainWallFailures..::..RuledCurtainElementLostCurves Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Ruled Curtain System cannot be built. The Lines or Edges used to create it cannot be found.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RuledCurtainElementLostCurves { get; }
Visual Basic
Public Shared ReadOnly Property RuledCurtainElementLostCurves As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RuledCurtainElementLostCurves {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


TypePanelsFronNonRectCellsUnlocked Property

[image]

Revit 2024 API
BuiltInFailures..::..CurtainWallFailures..::..TypePanelsFronNonRectCellsUnlocked Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Loaded family curtain panels cannot be used in non-rectangular cells of the curtain host. Type-driven panels from non-rectangular cells were unlocked and left unchanged.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId TypePanelsFronNonRectCellsUnlocked { get; }
Visual Basic
Public Shared ReadOnly Property TypePanelsFronNonRectCellsUnlocked As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TypePanelsFronNonRectCellsUnlocked {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


BuiltInFailures.CurveByPointFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..CurveByPointFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Curve By Point Element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class CurveByPointFailures
Visual Basic
Public NotInheritable Class CurveByPointFailures
Visual C++
public ref class CurveByPointFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..CurveByPointFailures

See Also

BuiltInFailures..::..CurveByPointFailures Members


UnableToGenerateCurve Property

[image]

Revit 2024 API
BuiltInFailures..::..CurveByPointFailures..::..UnableToGenerateCurve Property
BuiltInFailures..::..CurveByPointFailures Class See Also Send Feedback
Unable to generate valid curve geometry from the driving points. The line by points will be dissolved.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UnableToGenerateCurve { get; }
Visual Basic
Public Shared ReadOnly Property UnableToGenerateCurve As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableToGenerateCurve {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurveByPointFailures Class


BuiltInFailures.CurveFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..CurveFailures Members
BuiltInFailures..::..CurveFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..CurveFailures type exposes the following members.

Properties

Name | Description
CannotFindAreaScheme | Can't find new Area Scheme for Area Boundary.
CantKeepJoinTangent | Can't keep curve join tangent.
CurveNotEditable | Lines created by massing or picking 3d path are not editable.
CurveNotEditableWarn | Lines created by massing or picking 3d path are not editable.
InvalidCurveForElement | End positions are invalid.
LineTooShortError | Line is too short.
LineTooShortWarning | Line is too short.
PeriodicCurveBadParams | End positions are invalid.
SelfIntersectingSpline | Self intersecting splines are not allowed in sketches.
TooShort | Line is too short.
TopLevelBelowBottomLevel | For curveElem support multiple levels, top level belows curve bottom level.

See Also

BuiltInFailures..::..CurveFailures Class


BuiltInFailures.CurveFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..CurveFailures Properties
BuiltInFailures..::..CurveFailures Class See Also Send Feedback

The BuiltInFailures..::..CurveFailures type exposes the following members.

Properties

Name | Description
CannotFindAreaScheme | Can't find new Area Scheme for Area Boundary.
CantKeepJoinTangent | Can't keep curve join tangent.
CurveNotEditable | Lines created by massing or picking 3d path are not editable.
CurveNotEditableWarn | Lines created by massing or picking 3d path are not editable.
InvalidCurveForElement | End positions are invalid.
LineTooShortError | Line is too short.
LineTooShortWarning | Line is too short.
PeriodicCurveBadParams | End positions are invalid.
SelfIntersectingSpline | Self intersecting splines are not allowed in sketches.
TooShort | Line is too short.
TopLevelBelowBottomLevel | For curveElem support multiple levels, top level belows curve bottom level.

See Also

BuiltInFailures..::..CurveFailures Class


CantKeepJoinTangent Property

[image]

Revit 2024 API
BuiltInFailures..::..CurveFailures..::..CantKeepJoinTangent Property
BuiltInFailures..::..CurveFailures Class See Also Send Feedback
Can't keep curve join tangent.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CantKeepJoinTangent { get; }
Visual Basic
Public Shared ReadOnly Property CantKeepJoinTangent As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CantKeepJoinTangent {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurveFailures Class


CurveNotEditable Property

[image]

Revit 2024 API
BuiltInFailures..::..CurveFailures..::..CurveNotEditable Property
BuiltInFailures..::..CurveFailures Class See Also Send Feedback
Lines created by massing or picking 3d path are not editable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CurveNotEditable { get; }
Visual Basic
Public Shared ReadOnly Property CurveNotEditable As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CurveNotEditable {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurveFailures Class


CurveNotEditableWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..CurveFailures..::..CurveNotEditableWarn Property
BuiltInFailures..::..CurveFailures Class See Also Send Feedback
Lines created by massing or picking 3d path are not editable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CurveNotEditableWarn { get; }
Visual Basic
Public Shared ReadOnly Property CurveNotEditableWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CurveNotEditableWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurveFailures Class


InvalidCurveForElement Property

[image]

Revit 2024 API
BuiltInFailures..::..CurveFailures..::..InvalidCurveForElement Property
BuiltInFailures..::..CurveFailures Class See Also Send Feedback
End positions are invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidCurveForElement { get; }
Visual Basic
Public Shared ReadOnly Property InvalidCurveForElement As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidCurveForElement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurveFailures Class


LineTooShortError Property

[image]

Revit 2024 API
BuiltInFailures..::..CurveFailures..::..LineTooShortError Property
BuiltInFailures..::..CurveFailures Class See Also Send Feedback
Line is too short.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId LineTooShortError { get; }
Visual Basic
Public Shared ReadOnly Property LineTooShortError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LineTooShortError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurveFailures Class


LineTooShortWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..CurveFailures..::..LineTooShortWarning Property
BuiltInFailures..::..CurveFailures Class See Also Send Feedback
Line is too short.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId LineTooShortWarning { get; }
Visual Basic
Public Shared ReadOnly Property LineTooShortWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LineTooShortWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurveFailures Class


PeriodicCurveBadParams Property

[image]

Revit 2024 API
BuiltInFailures..::..CurveFailures..::..PeriodicCurveBadParams Property
BuiltInFailures..::..CurveFailures Class See Also Send Feedback
End positions are invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId PeriodicCurveBadParams { get; }
Visual Basic
Public Shared ReadOnly Property PeriodicCurveBadParams As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PeriodicCurveBadParams {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurveFailures Class


SelfIntersectingSpline Property

[image]

Revit 2024 API
BuiltInFailures..::..CurveFailures..::..SelfIntersectingSpline Property
BuiltInFailures..::..CurveFailures Class See Also Send Feedback
Self intersecting splines are not allowed in sketches.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SelfIntersectingSpline { get; }
Visual Basic
Public Shared ReadOnly Property SelfIntersectingSpline As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SelfIntersectingSpline {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurveFailures Class


TooShort Property

[image]

Revit 2024 API
BuiltInFailures..::..CurveFailures..::..TooShort Property
BuiltInFailures..::..CurveFailures Class See Also Send Feedback
Line is too short.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId TooShort { get; }
Visual Basic
Public Shared ReadOnly Property TooShort As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TooShort {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurveFailures Class


TopLevelBelowBottomLevel Property

[image]

Revit 2024 API
BuiltInFailures..::..CurveFailures..::..TopLevelBelowBottomLevel Property
BuiltInFailures..::..CurveFailures Class See Also Send Feedback
For curveElem support multiple levels, top level belows curve bottom level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId TopLevelBelowBottomLevel { get; }
Visual Basic
Public Shared ReadOnly Property TopLevelBelowBottomLevel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TopLevelBelowBottomLevel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurveFailures Class


BuiltInFailures.CutFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..CutFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Cut.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class CutFailures
Visual Basic
Public NotInheritable Class CutFailures
Visual C++
public ref class CutFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..CutFailures

See Also

BuiltInFailures..::..CutFailures Members


BuiltInFailures.CutFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..CutFailures Properties
BuiltInFailures..::..CutFailures Class See Also Send Feedback

The BuiltInFailures..::..CutFailures type exposes the following members.

Properties

Name | Description
CannotCutGeometry | Elements do not intersect.
CannotCutGeometryWarn | Elements do not intersect.
CannotCutInstanceOut | Can't cut instance of [Symbol] out of Wall.
CannotCutInstanceOutError | Can't cut instance of [Symbol] out of Wall.
CannotCutInstanceOutGen | Can't cut instance(s) of [Symbol] out of its host.
CannotCutInstanceOutGenError | Can't cut instance(s) of [Symbol] out of its host.
CannotCutInstanceOutGenWarn | Can't cut instance(s) of [Symbol] out of its host.
CannotCutInstanceOutWarn | Can't cut instance of [Symbol] out of Wall.
CannotCutJoinedElement | Can't cut joined element.
CannotCutRoof | The roof couldn't be cut.
CannotCutRoofError | The roof couldn't be cut.
CantCutHostWithInstance | Can't cut host with instance.
CutExactlyHalf | Can't cut in half. Move plane towards either end.
CutoutNotCuttingAnything | Opening not cutting anything.
CutoutNotCuttingAnythingDeleteOpening | Opening not cutting anything.
DormerCutProblem | Dormer Opening Cut is not fully defined. Cut was not performed.
DormerCutProblemWarn | Dormer Opening Cut is not fully defined. Cut was not performed.
HostCutoutForInsertionFailure | Can't cut host for inserted objects
InstanceNotCuttingAnything | Instance(s) of [Symbol] not cutting anything.

See Also

BuiltInFailures..::..CutFailures Class


CannotCutGeometry Property

[image]

Revit 2024 API
BuiltInFailures..::..CutFailures..::..CannotCutGeometry Property
BuiltInFailures..::..CutFailures Class See Also Send Feedback
Elements do not intersect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCutGeometry { get; }
Visual Basic
Public Shared ReadOnly Property CannotCutGeometry As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCutGeometry {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CutFailures Class


CannotCutGeometryWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..CutFailures..::..CannotCutGeometryWarn Property
BuiltInFailures..::..CutFailures Class See Also Send Feedback
Elements do not intersect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCutGeometryWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCutGeometryWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCutGeometryWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CutFailures Class


CannotCutInstanceOut Property

[image]

Revit 2024 API
BuiltInFailures..::..CutFailures..::..CannotCutInstanceOut Property
BuiltInFailures..::..CutFailures Class See Also Send Feedback
Can't cut instance of [Symbol] out of Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCutInstanceOut { get; }
Visual Basic
Public Shared ReadOnly Property CannotCutInstanceOut As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCutInstanceOut {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CutFailures Class


CannotCutInstanceOutError Property

[image]

Revit 2024 API
BuiltInFailures..::..CutFailures..::..CannotCutInstanceOutError Property
BuiltInFailures..::..CutFailures Class See Also Send Feedback
Can't cut instance of [Symbol] out of Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCutInstanceOutError { get; }
Visual Basic
Public Shared ReadOnly Property CannotCutInstanceOutError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCutInstanceOutError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CutFailures Class


CannotCutInstanceOutGen Property

[image]

Revit 2024 API
BuiltInFailures..::..CutFailures..::..CannotCutInstanceOutGen Property
BuiltInFailures..::..CutFailures Class See Also Send Feedback
Can't cut instance(s) of [Symbol] out of its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCutInstanceOutGen { get; }
Visual Basic
Public Shared ReadOnly Property CannotCutInstanceOutGen As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCutInstanceOutGen {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CutFailures Class


CannotCutInstanceOutGenError Property

[image]

Revit 2024 API
BuiltInFailures..::..CutFailures..::..CannotCutInstanceOutGenError Property
BuiltInFailures..::..CutFailures Class See Also Send Feedback
Can't cut instance(s) of [Symbol] out of its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCutInstanceOutGenError { get; }
Visual Basic
Public Shared ReadOnly Property CannotCutInstanceOutGenError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCutInstanceOutGenError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CutFailures Class


CannotCutInstanceOutGenWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..CutFailures..::..CannotCutInstanceOutGenWarn Property
BuiltInFailures..::..CutFailures Class See Also Send Feedback
Can't cut instance(s) of [Symbol] out of its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCutInstanceOutGenWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCutInstanceOutGenWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCutInstanceOutGenWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CutFailures Class


CannotCutInstanceOutWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..CutFailures..::..CannotCutInstanceOutWarn Property
BuiltInFailures..::..CutFailures Class See Also Send Feedback
Can't cut instance of [Symbol] out of Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCutInstanceOutWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCutInstanceOutWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCutInstanceOutWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CutFailures Class


CannotCutJoinedElement Property

[image]

Revit 2024 API
BuiltInFailures..::..CutFailures..::..CannotCutJoinedElement Property
BuiltInFailures..::..CutFailures Class See Also Send Feedback
Can't cut joined element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCutJoinedElement { get; }
Visual Basic
Public Shared ReadOnly Property CannotCutJoinedElement As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCutJoinedElement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CutFailures Class


CannotCutRoof Property

[image]

Revit 2024 API
BuiltInFailures..::..CutFailures..::..CannotCutRoof Property
BuiltInFailures..::..CutFailures Class See Also Send Feedback
The roof couldn't be cut.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCutRoof { get; }
Visual Basic
Public Shared ReadOnly Property CannotCutRoof As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCutRoof {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CutFailures Class


CannotCutRoofError Property

[image]

Revit 2024 API
BuiltInFailures..::..CutFailures..::..CannotCutRoofError Property
BuiltInFailures..::..CutFailures Class See Also Send Feedback
The roof couldn't be cut.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCutRoofError { get; }
Visual Basic
Public Shared ReadOnly Property CannotCutRoofError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCutRoofError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CutFailures Class


CantCutHostWithInstance Property

[image]

Revit 2024 API
BuiltInFailures..::..CutFailures..::..CantCutHostWithInstance Property
BuiltInFailures..::..CutFailures Class See Also Send Feedback
Can't cut host with instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CantCutHostWithInstance { get; }
Visual Basic
Public Shared ReadOnly Property CantCutHostWithInstance As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CantCutHostWithInstance {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CutFailures Class


CutExactlyHalf Property

[image]

Revit 2024 API
BuiltInFailures..::..CutFailures..::..CutExactlyHalf Property
BuiltInFailures..::..CutFailures Class See Also Send Feedback
Can't cut in half. Move plane towards either end.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CutExactlyHalf { get; }
Visual Basic
Public Shared ReadOnly Property CutExactlyHalf As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CutExactlyHalf {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CutFailures Class


CutoutNotCuttingAnything Property

[image]

Revit 2024 API
BuiltInFailures..::..CutFailures..::..CutoutNotCuttingAnything Property
BuiltInFailures..::..CutFailures Class See Also Send Feedback
Opening not cutting anything.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CutoutNotCuttingAnything { get; }
Visual Basic
Public Shared ReadOnly Property CutoutNotCuttingAnything As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CutoutNotCuttingAnything {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CutFailures Class


CutoutNotCuttingAnythingDeleteOpening Property

[image]

Revit 2024 API
BuiltInFailures..::..CutFailures..::..CutoutNotCuttingAnythingDeleteOpening Property
BuiltInFailures..::..CutFailures Class See Also Send Feedback
Opening not cutting anything.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CutoutNotCuttingAnythingDeleteOpening { get; }
Visual Basic
Public Shared ReadOnly Property CutoutNotCuttingAnythingDeleteOpening As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CutoutNotCuttingAnythingDeleteOpening {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CutFailures Class


DormerCutProblem Property

[image]

Revit 2024 API
BuiltInFailures..::..CutFailures..::..DormerCutProblem Property
BuiltInFailures..::..CutFailures Class See Also Send Feedback
Dormer Opening Cut is not fully defined. Cut was not performed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DormerCutProblem { get; }
Visual Basic
Public Shared ReadOnly Property DormerCutProblem As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DormerCutProblem {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CutFailures Class


DormerCutProblemWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..CutFailures..::..DormerCutProblemWarn Property
BuiltInFailures..::..CutFailures Class See Also Send Feedback
Dormer Opening Cut is not fully defined. Cut was not performed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DormerCutProblemWarn { get; }
Visual Basic
Public Shared ReadOnly Property DormerCutProblemWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DormerCutProblemWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CutFailures Class


HostCutoutForInsertionFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..CutFailures..::..HostCutoutForInsertionFailure Property
BuiltInFailures..::..CutFailures Class See Also Send Feedback
Can't cut host for inserted objects

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId HostCutoutForInsertionFailure { get; }
Visual Basic
Public Shared ReadOnly Property HostCutoutForInsertionFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HostCutoutForInsertionFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CutFailures Class


InstanceNotCuttingAnything Property

[image]

Revit 2024 API
BuiltInFailures..::..CutFailures..::..InstanceNotCuttingAnything Property
BuiltInFailures..::..CutFailures Class See Also Send Feedback
Instance(s) of [Symbol] not cutting anything.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InstanceNotCuttingAnything { get; }
Visual Basic
Public Shared ReadOnly Property InstanceNotCuttingAnything As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InstanceNotCuttingAnything {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CutFailures Class


BuiltInFailures.CutterFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..CutterFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Cutter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class CutterFailures
Visual Basic
Public NotInheritable Class CutterFailures
Visual C++
public ref class CutterFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..CutterFailures

See Also

BuiltInFailures..::..CutterFailures Members


BuiltInFailures.CutterFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..CutterFailures Members
BuiltInFailures..::..CutterFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..CutterFailures type exposes the following members.

Properties

Name | Description
MakeCutterForPlanRegionsGStepFailed | Failed to make cutter for plan view with plan regions. Try deleting one or more plan regions.
MakeCutterForSectionGStepFailed | Attempt to create or manipulate a segmented section has failed.

See Also

BuiltInFailures..::..CutterFailures Class


BuiltInFailures.CutterFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..CutterFailures Properties
BuiltInFailures..::..CutterFailures Class See Also Send Feedback

The BuiltInFailures..::..CutterFailures type exposes the following members.

Properties

Name | Description
MakeCutterForPlanRegionsGStepFailed | Failed to make cutter for plan view with plan regions. Try deleting one or more plan regions.
MakeCutterForSectionGStepFailed | Attempt to create or manipulate a segmented section has failed.

See Also

BuiltInFailures..::..CutterFailures Class


MakeCutterForPlanRegionsGStepFailed Property

[image]

Revit 2024 API
BuiltInFailures..::..CutterFailures..::..MakeCutterForPlanRegionsGStepFailed Property
BuiltInFailures..::..CutterFailures Class See Also Send Feedback
Failed to make cutter for plan view with plan regions. Try deleting one or more plan regions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MakeCutterForPlanRegionsGStepFailed { get; }
Visual Basic
Public Shared ReadOnly Property MakeCutterForPlanRegionsGStepFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MakeCutterForPlanRegionsGStepFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CutterFailures Class


MakeCutterForSectionGStepFailed Property

[image]

Revit 2024 API
BuiltInFailures..::..CutterFailures..::..MakeCutterForSectionGStepFailed Property
BuiltInFailures..::..CutterFailures Class See Also Send Feedback
Attempt to create or manipulate a segmented section has failed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MakeCutterForSectionGStepFailed { get; }
Visual Basic
Public Shared ReadOnly Property MakeCutterForSectionGStepFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MakeCutterForSectionGStepFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CutterFailures Class


BuiltInFailures.CuttingFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..CuttingFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Cutting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class CuttingFailures
Visual Basic
Public NotInheritable Class CuttingFailures
Visual C++
public ref class CuttingFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..CuttingFailures

See Also

BuiltInFailures..::..CuttingFailures Members


BuiltInFailures.CuttingFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..CuttingFailures Members
BuiltInFailures..::..CuttingFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..CuttingFailures type exposes the following members.

Properties

Name | Description
CannotCopyFromMultipleLinks | Elements cannot be copied from multiple links at the same time.
ElementsWithNotCopiedParentsDeleted | Some elements were deleted because elements that they require for references were not copied.
NoFileSaved | No file has been saved.
NoSupported2DElementsToCopyFromView | None of the elements in the view you have selected are supported for the insert 2D operation.
UnableToCopyElementsFromFile | Unable to copy elements from file.
UnableToPasteToFile | Unable to paste current clipboard contents to file.
UnableToReplaceWithLink | Selected elements were copied to new file but Revit was unable to replace them with link to that file.

See Also

BuiltInFailures..::..CuttingFailures Class


BuiltInFailures.CuttingFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..CuttingFailures Properties
BuiltInFailures..::..CuttingFailures Class See Also Send Feedback

The BuiltInFailures..::..CuttingFailures type exposes the following members.

Properties

Name | Description
CannotCopyFromMultipleLinks | Elements cannot be copied from multiple links at the same time.
ElementsWithNotCopiedParentsDeleted | Some elements were deleted because elements that they require for references were not copied.
NoFileSaved | No file has been saved.
NoSupported2DElementsToCopyFromView | None of the elements in the view you have selected are supported for the insert 2D operation.
UnableToCopyElementsFromFile | Unable to copy elements from file.
UnableToPasteToFile | Unable to paste current clipboard contents to file.
UnableToReplaceWithLink | Selected elements were copied to new file but Revit was unable to replace them with link to that file.

See Also

BuiltInFailures..::..CuttingFailures Class


CannotCopyFromMultipleLinks Property

[image]

Revit 2024 API
BuiltInFailures..::..CuttingFailures..::..CannotCopyFromMultipleLinks Property
BuiltInFailures..::..CuttingFailures Class See Also Send Feedback
Elements cannot be copied from multiple links at the same time.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCopyFromMultipleLinks { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyFromMultipleLinks As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyFromMultipleLinks {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CuttingFailures Class


ElementsWithNotCopiedParentsDeleted Property

[image]

Revit 2024 API
BuiltInFailures..::..CuttingFailures..::..ElementsWithNotCopiedParentsDeleted Property
BuiltInFailures..::..CuttingFailures Class See Also Send Feedback
Some elements were deleted because elements that they require for references were not copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ElementsWithNotCopiedParentsDeleted { get; }
Visual Basic
Public Shared ReadOnly Property ElementsWithNotCopiedParentsDeleted As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementsWithNotCopiedParentsDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CuttingFailures Class


NoFileSaved Property

[image]

Revit 2024 API
BuiltInFailures..::..CuttingFailures..::..NoFileSaved Property
BuiltInFailures..::..CuttingFailures Class See Also Send Feedback
No file has been saved.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoFileSaved { get; }
Visual Basic
Public Shared ReadOnly Property NoFileSaved As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoFileSaved {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CuttingFailures Class


UnableToPasteToFile Property

[image]

Revit 2024 API
BuiltInFailures..::..CuttingFailures..::..UnableToPasteToFile Property
BuiltInFailures..::..CuttingFailures Class See Also Send Feedback
Unable to paste current clipboard contents to file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UnableToPasteToFile { get; }
Visual Basic
Public Shared ReadOnly Property UnableToPasteToFile As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableToPasteToFile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CuttingFailures Class


BuiltInFailures.DatumPlaneFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..DatumPlaneFailures Properties
BuiltInFailures..::..DatumPlaneFailures Class See Also Send Feedback

The BuiltInFailures..::..DatumPlaneFailures type exposes the following members.

Properties

Name | Description
ScopeBoxWrongPosition | The Highlighted Datum cannot be associated with the specified Scope Box because the Datum plane does not intersect the Scope Box.

See Also

BuiltInFailures..::..DatumPlaneFailures Class


BuiltInFailures.DebugTabBindingFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..DebugTabBindingFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures related to binding framework demo panel on Ribbon Debug Tab.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class DebugTabBindingFailures
Visual Basic
Public NotInheritable Class DebugTabBindingFailures
Visual C++
public ref class DebugTabBindingFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..DebugTabBindingFailures

See Also

BuiltInFailures..::..DebugTabBindingFailures Members


BuiltInFailures.DebugTabBindingFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..DebugTabBindingFailures Members
BuiltInFailures..::..DebugTabBindingFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..DebugTabBindingFailures type exposes the following members.

Properties

Name | Description
OptionValueOutOfRange | Value out of range for Options enum.

See Also

BuiltInFailures..::..DebugTabBindingFailures Class


OptionValueOutOfRange Property

[image]

Revit 2024 API
BuiltInFailures..::..DebugTabBindingFailures..::..OptionValueOutOfRange Property
BuiltInFailures..::..DebugTabBindingFailures Class See Also Send Feedback
Value out of range for Options enum.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId OptionValueOutOfRange { get; }
Visual Basic
Public Shared ReadOnly Property OptionValueOutOfRange As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OptionValueOutOfRange {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DebugTabBindingFailures Class


BuiltInFailures.DecalFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..DecalFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Decal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class DecalFailures
Visual Basic
Public NotInheritable Class DecalFailures
Visual C++
public ref class DecalFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..DecalFailures

See Also

BuiltInFailures..::..DecalFailures Members


BuiltInFailures.DecalFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..DecalFailures Members
BuiltInFailures..::..DecalFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..DecalFailures type exposes the following members.

Properties

Name | Description
CannotPaste | Can't place Decal at new position.
LongerThanPossible | Decal element is longer than the circumference of the surface.
OutsideHost | Decal does not lie on host.

See Also

BuiltInFailures..::..DecalFailures Class


BuiltInFailures.DecalFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..DecalFailures Properties
BuiltInFailures..::..DecalFailures Class See Also Send Feedback

The BuiltInFailures..::..DecalFailures type exposes the following members.

Properties

Name | Description
CannotPaste | Can't place Decal at new position.
LongerThanPossible | Decal element is longer than the circumference of the surface.
OutsideHost | Decal does not lie on host.

See Also

BuiltInFailures..::..DecalFailures Class


CannotPaste Property

[image]

Revit 2024 API
BuiltInFailures..::..DecalFailures..::..CannotPaste Property
BuiltInFailures..::..DecalFailures Class See Also Send Feedback
Can't place Decal at new position.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotPaste { get; }
Visual Basic
Public Shared ReadOnly Property CannotPaste As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPaste {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DecalFailures Class


LongerThanPossible Property

[image]

Revit 2024 API
BuiltInFailures..::..DecalFailures..::..LongerThanPossible Property
BuiltInFailures..::..DecalFailures Class See Also Send Feedback
Decal element is longer than the circumference of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId LongerThanPossible { get; }
Visual Basic
Public Shared ReadOnly Property LongerThanPossible As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LongerThanPossible {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DecalFailures Class


OutsideHost Property

[image]

Revit 2024 API
BuiltInFailures..::..DecalFailures..::..OutsideHost Property
BuiltInFailures..::..DecalFailures Class See Also Send Feedback
Decal does not lie on host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId OutsideHost { get; }
Visual Basic
Public Shared ReadOnly Property OutsideHost As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OutsideHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DecalFailures Class


BuiltInFailures.DesignOptionFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..DesignOptionFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about DesignOptionFailures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class DesignOptionFailures
Visual Basic
Public NotInheritable Class DesignOptionFailures
Visual C++
public ref class DesignOptionFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..DesignOptionFailures

See Also

BuiltInFailures..::..DesignOptionFailures Members


BuiltInFailures.DesignOptionFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..DesignOptionFailures Members
BuiltInFailures..::..DesignOptionFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..DesignOptionFailures type exposes the following members.

Properties

Name | Description
AreaTagLineCannotBeInDesignOption | Areas and Area Boundaries are not allowed in Design Options. Make an Area Scheme and an Area Plan for this Option then draw all Areas and Area Boundaries in that view.
BadReferenceBetweenOptions | An element may not reference an element in another Option of the same Option Set.
BadReferenceBetweenOptionsWarn | An element may not reference an element in another Option of the same Option Set.
BadReferenceToSecondary | No element in a secondary Option can be referenced by an element outside that Option.
BadReferenceToSecondaryWarn | No element in a secondary Option can be referenced by an element outside that Option.
CannotAddToOptions | Elements can't be added to Option Set
CannotAddToOptionsWarn | Elements can't be added to Option Set
CannotPutELAInOption | Electrical Load Areas must be in the Main Model.
CannotPutELZInOption | Area Based Loads must be in the Main Model.
CannotPutSpaceInOption | MEP space must be in the Main Model
CannotPutZoneInOption | HVAC Zones must be in the Main Model.
ConfusingHostByElementsInAnotherDesignOption | An insert in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].
ConfusingHostByElementsInAnotherDesignOptionWarn | An insert in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].
ConfusingHostByElementsInDesignOption | An insert in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].
ConfusingHostByElementsInDesignOptionWarn | An insert in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].
ConfusingHostByElementsInMainModel | An insert in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].
ConfusingHostByElementsInMainModelWarn | An insert in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInAnotherDesignOption | A pad in a Design Option cannot be hosted by a topography in another Design Option [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInAnotherDesignOptionWarn | A pad in a Design Option cannot be hosted by a topography in another Design Option [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInDesignOption | A pad in the main model cannot be hosted by topography in a Design Option [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInDesignOptionWarn | A pad in the main model cannot be hosted by topography in a Design Option [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInMainModel | A pad in a design option cannot be hosted by topography in the Main Model [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInMainModelWarn | A pad in a design option cannot be hosted by topography in the Main Model [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInAnotherDesignOption | A sweep in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInAnotherDesignOptionWarn | A sweep in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInDesignOption | A sweep in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInDesignOptionWarn | A sweep in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInMainModel | A sweep in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInMainModelWarn | A sweep in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].
DebugLevelsInOptionsError | This is an internal diagnostic message.
DebugLevelsInOptionsWarn | This is an internal diagnostic message.
ElementsWillBeDeletedNoOption | Elements will be deleted
FabricationCannotBeInDesignOption | Structural steel connections or individual structural steel fabrication elements are not allowed in Design Options.
KingNeverInOption | A selected "[Serf]" belongs to a "[King]" which cannot be added to an Option--it was not added to the Option Set.
KingNeverInOptionWarn | A selected "[Serf]" belongs to a "[King]" which cannot be added to an Option--it was not added to the Option Set.
MustAddKing | In order to add this '[Serf]' to the Option Set, you must also add its '[King]'--if you continue it will not be added to the Option Set
MustAddKingWarn | In order to add this '[Serf]' to the Option Set, you must also add its '[King]'--if you continue it will not be added to the Option Set
MustBeInMainModel | Element must be in Main Model
NeverInOption | Some types of elements can't belong to an Option. Elements of these types were not added to this Option Set.
NeverInOptionWarn | Some types of elements can't belong to an Option. Elements of these types were not added to this Option Set.
NoSelectedInOption | None of the selected elements can be added to this Option Set. The following warnings provide additional information.
OptionElementsDeleted | Elements in [option] were deleted
SelectionIncludesOptionItems | Elements that were already in a Design Option were selected. These will not be added to the Option Set.

See Also

BuiltInFailures..::..DesignOptionFailures Class


BuiltInFailures.DesignOptionFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..DesignOptionFailures Properties
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback

The BuiltInFailures..::..DesignOptionFailures type exposes the following members.

Properties

Name | Description
AreaTagLineCannotBeInDesignOption | Areas and Area Boundaries are not allowed in Design Options. Make an Area Scheme and an Area Plan for this Option then draw all Areas and Area Boundaries in that view.
BadReferenceBetweenOptions | An element may not reference an element in another Option of the same Option Set.
BadReferenceBetweenOptionsWarn | An element may not reference an element in another Option of the same Option Set.
BadReferenceToSecondary | No element in a secondary Option can be referenced by an element outside that Option.
BadReferenceToSecondaryWarn | No element in a secondary Option can be referenced by an element outside that Option.
CannotAddToOptions | Elements can't be added to Option Set
CannotAddToOptionsWarn | Elements can't be added to Option Set
CannotPutELAInOption | Electrical Load Areas must be in the Main Model.
CannotPutELZInOption | Area Based Loads must be in the Main Model.
CannotPutSpaceInOption | MEP space must be in the Main Model
CannotPutZoneInOption | HVAC Zones must be in the Main Model.
ConfusingHostByElementsInAnotherDesignOption | An insert in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].
ConfusingHostByElementsInAnotherDesignOptionWarn | An insert in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].
ConfusingHostByElementsInDesignOption | An insert in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].
ConfusingHostByElementsInDesignOptionWarn | An insert in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].
ConfusingHostByElementsInMainModel | An insert in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].
ConfusingHostByElementsInMainModelWarn | An insert in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInAnotherDesignOption | A pad in a Design Option cannot be hosted by a topography in another Design Option [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInAnotherDesignOptionWarn | A pad in a Design Option cannot be hosted by a topography in another Design Option [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInDesignOption | A pad in the main model cannot be hosted by topography in a Design Option [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInDesignOptionWarn | A pad in the main model cannot be hosted by topography in a Design Option [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInMainModel | A pad in a design option cannot be hosted by topography in the Main Model [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInMainModelWarn | A pad in a design option cannot be hosted by topography in the Main Model [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInAnotherDesignOption | A sweep in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInAnotherDesignOptionWarn | A sweep in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInDesignOption | A sweep in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInDesignOptionWarn | A sweep in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInMainModel | A sweep in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInMainModelWarn | A sweep in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].
DebugLevelsInOptionsError | This is an internal diagnostic message.
DebugLevelsInOptionsWarn | This is an internal diagnostic message.
ElementsWillBeDeletedNoOption | Elements will be deleted
FabricationCannotBeInDesignOption | Structural steel connections or individual structural steel fabrication elements are not allowed in Design Options.
KingNeverInOption | A selected "[Serf]" belongs to a "[King]" which cannot be added to an Option--it was not added to the Option Set.
KingNeverInOptionWarn | A selected "[Serf]" belongs to a "[King]" which cannot be added to an Option--it was not added to the Option Set.
MustAddKing | In order to add this '[Serf]' to the Option Set, you must also add its '[King]'--if you continue it will not be added to the Option Set
MustAddKingWarn | In order to add this '[Serf]' to the Option Set, you must also add its '[King]'--if you continue it will not be added to the Option Set
MustBeInMainModel | Element must be in Main Model
NeverInOption | Some types of elements can't belong to an Option. Elements of these types were not added to this Option Set.
NeverInOptionWarn | Some types of elements can't belong to an Option. Elements of these types were not added to this Option Set.
NoSelectedInOption | None of the selected elements can be added to this Option Set. The following warnings provide additional information.
OptionElementsDeleted | Elements in [option] were deleted
SelectionIncludesOptionItems | Elements that were already in a Design Option were selected. These will not be added to the Option Set.

See Also

BuiltInFailures..::..DesignOptionFailures Class


AreaTagLineCannotBeInDesignOption Property

[image]

Revit 2024 API
BuiltInFailures..::..DesignOptionFailures..::..AreaTagLineCannotBeInDesignOption Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
Areas and Area Boundaries are not allowed in Design Options. Make an Area Scheme and an Area Plan for this Option then draw all Areas and Area Boundaries in that view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AreaTagLineCannotBeInDesignOption { get; }
Visual Basic
Public Shared ReadOnly Property AreaTagLineCannotBeInDesignOption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AreaTagLineCannotBeInDesignOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


BadReferenceBetweenOptionsWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..DesignOptionFailures..::..BadReferenceBetweenOptionsWarn Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
An element may not reference an element in another Option of the same Option Set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId BadReferenceBetweenOptionsWarn { get; }
Visual Basic
Public Shared ReadOnly Property BadReferenceBetweenOptionsWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BadReferenceBetweenOptionsWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


BadReferenceToSecondary Property

[image]

Revit 2024 API
BuiltInFailures..::..DesignOptionFailures..::..BadReferenceToSecondary Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
No element in a secondary Option can be referenced by an element outside that Option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId BadReferenceToSecondary { get; }
Visual Basic
Public Shared ReadOnly Property BadReferenceToSecondary As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BadReferenceToSecondary {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


BadReferenceToSecondaryWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..DesignOptionFailures..::..BadReferenceToSecondaryWarn Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
No element in a secondary Option can be referenced by an element outside that Option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId BadReferenceToSecondaryWarn { get; }
Visual Basic
Public Shared ReadOnly Property BadReferenceToSecondaryWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BadReferenceToSecondaryWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


CannotAddToOptions Property

[image]

Revit 2024 API
BuiltInFailures..::..DesignOptionFailures..::..CannotAddToOptions Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
Elements can't be added to Option Set

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotAddToOptions { get; }
Visual Basic
Public Shared ReadOnly Property CannotAddToOptions As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotAddToOptions {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


CannotAddToOptionsWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..DesignOptionFailures..::..CannotAddToOptionsWarn Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
Elements can't be added to Option Set

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotAddToOptionsWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotAddToOptionsWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotAddToOptionsWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


CannotPutELAInOption Property

[image]

Revit 2024 API
BuiltInFailures..::..DesignOptionFailures..::..CannotPutELAInOption Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
Electrical Load Areas must be in the Main Model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotPutELAInOption { get; }
Visual Basic
Public Shared ReadOnly Property CannotPutELAInOption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPutELAInOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


CannotPutELZInOption Property

[image]

Revit 2024 API
BuiltInFailures..::..DesignOptionFailures..::..CannotPutELZInOption Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
Area Based Loads must be in the Main Model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotPutELZInOption { get; }
Visual Basic
Public Shared ReadOnly Property CannotPutELZInOption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPutELZInOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


CannotPutSpaceInOption Property

[image]

Revit 2024 API
BuiltInFailures..::..DesignOptionFailures..::..CannotPutSpaceInOption Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
MEP space must be in the Main Model

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotPutSpaceInOption { get; }
Visual Basic
Public Shared ReadOnly Property CannotPutSpaceInOption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPutSpaceInOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


CannotPutZoneInOption Property

[image]

Revit 2024 API
BuiltInFailures..::..DesignOptionFailures..::..CannotPutZoneInOption Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
HVAC Zones must be in the Main Model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotPutZoneInOption { get; }
Visual Basic
Public Shared ReadOnly Property CannotPutZoneInOption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPutZoneInOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


ConfusingHostByElementsInAnotherDesignOption Property

[image]

Revit 2024 API
BuiltInFailures..::..DesignOptionFailures..::..ConfusingHostByElementsInAnotherDesignOption Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
An insert in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ConfusingHostByElementsInAnotherDesignOption { get; }
Visual Basic
Public Shared ReadOnly Property ConfusingHostByElementsInAnotherDesignOption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ConfusingHostByElementsInAnotherDesignOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


ConfusingHostByElementsInAnotherDesignOptionWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..DesignOptionFailures..::..ConfusingHostByElementsInAnotherDesignOptionWarn Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
An insert in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ConfusingHostByElementsInAnotherDesignOptionWarn { get; }
Visual Basic
Public Shared ReadOnly Property ConfusingHostByElementsInAnotherDesignOptionWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ConfusingHostByElementsInAnotherDesignOptionWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


ConfusingHostByElementsInDesignOption Property

[image]

Revit 2024 API
BuiltInFailures..::..DesignOptionFailures..::..ConfusingHostByElementsInDesignOption Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
An insert in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ConfusingHostByElementsInDesignOption { get; }
Visual Basic
Public Shared ReadOnly Property ConfusingHostByElementsInDesignOption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ConfusingHostByElementsInDesignOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


ConfusingHostByElementsInMainModel Property

[image]

Revit 2024 API
BuiltInFailures..::..DesignOptionFailures..::..ConfusingHostByElementsInMainModel Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
An insert in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ConfusingHostByElementsInMainModel { get; }
Visual Basic
Public Shared ReadOnly Property ConfusingHostByElementsInMainModel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ConfusingHostByElementsInMainModel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


ConfusingHostByElementsInMainModelWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..DesignOptionFailures..::..ConfusingHostByElementsInMainModelWarn Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
An insert in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ConfusingHostByElementsInMainModelWarn { get; }
Visual Basic
Public Shared ReadOnly Property ConfusingHostByElementsInMainModelWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ConfusingHostByElementsInMainModelWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


ConfusingPadByElementsInAnotherDesignOption Property

[image]

Revit 2024 API
BuiltInFailures..::..DesignOptionFailures..::..ConfusingPadByElementsInAnotherDesignOption Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
A pad in a Design Option cannot be hosted by a topography in another Design Option [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ConfusingPadByElementsInAnotherDesignOption { get; }
Visual Basic
Public Shared ReadOnly Property ConfusingPadByElementsInAnotherDesignOption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ConfusingPadByElementsInAnotherDesignOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


ConfusingPadByElementsInAnotherDesignOptionWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..DesignOptionFailures..::..ConfusingPadByElementsInAnotherDesignOptionWarn Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
A pad in a Design Option cannot be hosted by a topography in another Design Option [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ConfusingPadByElementsInAnotherDesignOptionWarn { get; }
Visual Basic
Public Shared ReadOnly Property ConfusingPadByElementsInAnotherDesignOptionWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ConfusingPadByElementsInAnotherDesignOptionWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


ConfusingPadByElementsInDesignOption Property

[image]

Revit 2024 API
BuiltInFailures..::..DesignOptionFailures..::..ConfusingPadByElementsInDesignOption Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
A pad in the main model cannot be hosted by topography in a Design Option [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ConfusingPadByElementsInDesignOption { get; }
Visual Basic
Public Shared ReadOnly Property ConfusingPadByElementsInDesignOption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ConfusingPadByElementsInDesignOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


ConfusingPadByElementsInDesignOptionWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..DesignOptionFailures..::..ConfusingPadByElementsInDesignOptionWarn Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
A pad in the main model cannot be hosted by topography in a Design Option [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ConfusingPadByElementsInDesignOptionWarn { get; }
Visual Basic
Public Shared ReadOnly Property ConfusingPadByElementsInDesignOptionWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ConfusingPadByElementsInDesignOptionWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


ConfusingPadByElementsInMainModel Property

[image]

Revit 2024 API
BuiltInFailures..::..DesignOptionFailures..::..ConfusingPadByElementsInMainModel Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
A pad in a design option cannot be hosted by topography in the Main Model [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ConfusingPadByElementsInMainModel { get; }
Visual Basic
Public Shared ReadOnly Property ConfusingPadByElementsInMainModel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ConfusingPadByElementsInMainModel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


ConfusingPadByElementsInMainModelWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..DesignOptionFailures..::..ConfusingPadByElementsInMainModelWarn Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
A pad in a design option cannot be hosted by topography in the Main Model [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ConfusingPadByElementsInMainModelWarn { get; }
Visual Basic
Public Shared ReadOnly Property ConfusingPadByElementsInMainModelWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ConfusingPadByElementsInMainModelWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


ConfusingSweepByElementsInAnotherDesignOption Property

[image]

Revit 2024 API
BuiltInFailures..::..DesignOptionFailures..::..ConfusingSweepByElementsInAnotherDesignOption Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
A sweep in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ConfusingSweepByElementsInAnotherDesignOption { get; }
Visual Basic
Public Shared ReadOnly Property ConfusingSweepByElementsInAnotherDesignOption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ConfusingSweepByElementsInAnotherDesignOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


ConfusingSweepByElementsInAnotherDesignOptionWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..DesignOptionFailures..::..ConfusingSweepByElementsInAnotherDesignOptionWarn Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
A sweep in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ConfusingSweepByElementsInAnotherDesignOptionWarn { get; }
Visual Basic
Public Shared ReadOnly Property ConfusingSweepByElementsInAnotherDesignOptionWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ConfusingSweepByElementsInAnotherDesignOptionWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


ConfusingSweepByElementsInDesignOption Property

[image]

Revit 2024 API
BuiltInFailures..::..DesignOptionFailures..::..ConfusingSweepByElementsInDesignOption Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
A sweep in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ConfusingSweepByElementsInDesignOption { get; }
Visual Basic
Public Shared ReadOnly Property ConfusingSweepByElementsInDesignOption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ConfusingSweepByElementsInDesignOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


ConfusingSweepByElementsInDesignOptionWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..DesignOptionFailures..::..ConfusingSweepByElementsInDesignOptionWarn Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
A sweep in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ConfusingSweepByElementsInDesignOptionWarn { get; }
Visual Basic
Public Shared ReadOnly Property ConfusingSweepByElementsInDesignOptionWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ConfusingSweepByElementsInDesignOptionWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


ConfusingSweepByElementsInMainModelWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..DesignOptionFailures..::..ConfusingSweepByElementsInMainModelWarn Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
A sweep in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ConfusingSweepByElementsInMainModelWarn { get; }
Visual Basic
Public Shared ReadOnly Property ConfusingSweepByElementsInMainModelWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ConfusingSweepByElementsInMainModelWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


DebugLevelsInOptionsWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..DesignOptionFailures..::..DebugLevelsInOptionsWarn Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
This is an internal diagnostic message.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DebugLevelsInOptionsWarn { get; }
Visual Basic
Public Shared ReadOnly Property DebugLevelsInOptionsWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DebugLevelsInOptionsWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


KingNeverInOption Property

[image]

Revit 2024 API
BuiltInFailures..::..DesignOptionFailures..::..KingNeverInOption Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
A selected "[Serf]" belongs to a "[King]" which cannot be added to an Option--it was not added to the Option Set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId KingNeverInOption { get; }
Visual Basic
Public Shared ReadOnly Property KingNeverInOption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ KingNeverInOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


MustAddKing Property

[image]

Revit 2024 API
BuiltInFailures..::..DesignOptionFailures..::..MustAddKing Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
In order to add this '[Serf]' to the Option Set, you must also add its '[King]'--if you continue it will not be added to the Option Set

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MustAddKing { get; }
Visual Basic
Public Shared ReadOnly Property MustAddKing As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MustAddKing {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


MustAddKingWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..DesignOptionFailures..::..MustAddKingWarn Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
In order to add this '[Serf]' to the Option Set, you must also add its '[King]'--if you continue it will not be added to the Option Set

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MustAddKingWarn { get; }
Visual Basic
Public Shared ReadOnly Property MustAddKingWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MustAddKingWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


MustBeInMainModel Property

[image]

Revit 2024 API
BuiltInFailures..::..DesignOptionFailures..::..MustBeInMainModel Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
Element must be in Main Model

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MustBeInMainModel { get; }
Visual Basic
Public Shared ReadOnly Property MustBeInMainModel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MustBeInMainModel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


NeverInOption Property

[image]

Revit 2024 API
BuiltInFailures..::..DesignOptionFailures..::..NeverInOption Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
Some types of elements can't belong to an Option. Elements of these types were not added to this Option Set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NeverInOption { get; }
Visual Basic
Public Shared ReadOnly Property NeverInOption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NeverInOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


NoSelectedInOption Property

[image]

Revit 2024 API
BuiltInFailures..::..DesignOptionFailures..::..NoSelectedInOption Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
None of the selected elements can be added to this Option Set. The following warnings provide additional information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoSelectedInOption { get; }
Visual Basic
Public Shared ReadOnly Property NoSelectedInOption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoSelectedInOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


OptionElementsDeleted Property

[image]

Revit 2024 API
BuiltInFailures..::..DesignOptionFailures..::..OptionElementsDeleted Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
Elements in [option] were deleted

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId OptionElementsDeleted { get; }
Visual Basic
Public Shared ReadOnly Property OptionElementsDeleted As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OptionElementsDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


BuiltInFailures.DetailFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..DetailFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Detail.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class DetailFailures
Visual Basic
Public NotInheritable Class DetailFailures
Visual C++
public ref class DetailFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..DetailFailures

See Also

BuiltInFailures..::..DetailFailures Members


BuiltInFailures.DetailFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..DetailFailures Members
BuiltInFailures..::..DetailFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..DetailFailures type exposes the following members.

Properties

Name | Description
EavesAreAligned | All eaves are already aligned.
NeedsTwoToAlignEaves | At least two Slope Defining Lines are needed to perform Align Eaves.
RepeatingDetailSpacingZeroError | Spacing must be greater than 0

See Also

BuiltInFailures..::..DetailFailures Class


BuiltInFailures.DetailFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..DetailFailures Properties
BuiltInFailures..::..DetailFailures Class See Also Send Feedback

The BuiltInFailures..::..DetailFailures type exposes the following members.

Properties

Name | Description
EavesAreAligned | All eaves are already aligned.
NeedsTwoToAlignEaves | At least two Slope Defining Lines are needed to perform Align Eaves.
RepeatingDetailSpacingZeroError | Spacing must be greater than 0

See Also

BuiltInFailures..::..DetailFailures Class


EavesAreAligned Property

[image]

Revit 2024 API
BuiltInFailures..::..DetailFailures..::..EavesAreAligned Property
BuiltInFailures..::..DetailFailures Class See Also Send Feedback
All eaves are already aligned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId EavesAreAligned { get; }
Visual Basic
Public Shared ReadOnly Property EavesAreAligned As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ EavesAreAligned {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DetailFailures Class


NeedsTwoToAlignEaves Property

[image]

Revit 2024 API
BuiltInFailures..::..DetailFailures..::..NeedsTwoToAlignEaves Property
BuiltInFailures..::..DetailFailures Class See Also Send Feedback
At least two Slope Defining Lines are needed to perform Align Eaves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NeedsTwoToAlignEaves { get; }
Visual Basic
Public Shared ReadOnly Property NeedsTwoToAlignEaves As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NeedsTwoToAlignEaves {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DetailFailures Class


RepeatingDetailSpacingZeroError Property

[image]

Revit 2024 API
BuiltInFailures..::..DetailFailures..::..RepeatingDetailSpacingZeroError Property
BuiltInFailures..::..DetailFailures Class See Also Send Feedback
Spacing must be greater than 0

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RepeatingDetailSpacingZeroError { get; }
Visual Basic
Public Shared ReadOnly Property RepeatingDetailSpacingZeroError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RepeatingDetailSpacingZeroError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DetailFailures Class


BuiltInFailures.DimensionFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..DimensionFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about DimensionFailures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class DimensionFailures
Visual Basic
Public NotInheritable Class DimensionFailures
Visual C++
public ref class DimensionFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..DimensionFailures

See Also

BuiltInFailures..::..DimensionFailures Members


BuiltInFailures.DimensionFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..DimensionFailures Members
BuiltInFailures..::..DimensionFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..DimensionFailures type exposes the following members.

Properties

Name | Description
AngularDimensionRegenFailed | Can't form Angular Dimension.
ArcAlignmentRegenFailed | Can't form arc alignment.
ArcLengthDimensionNoReferencesOnArc | None of the segment references of this Arc Length Dimension intersects the bounded arc of the arc reference.
ArcLengthDimensionReferencesNotIntersect | One or more dimension references of this Arc Length dimension no longer intersect the circle needed for arc length computation.
AssocpropNeedJog | Need to add jog in order to satisfy constraints
CannotConstrainBasePointAlignments | Alignments to base points cannot be constrained.
CannotConstrainBasePointDimensions | Dimensions to base points cannot be constrained.
CannotCreateDimensionNotParallel | Can't create dimension. Highlighted references are not parallel to first selection.
CannotDragWitnessLine | Moving the Witness Line conflicts with other Constraints in the Sketch.
CannotLockThisDimension | Can't lock this Dimension because it breaks formulas
CannotToggleDimensionEquality | Toggling the dimension's equality constraint would overconstrain the sketch.
ChangeDimensionSegmentFailed | Can't change dimension segment to this value.
ChangeSpotElevationFailed | Can't change Spot Elevation to the desired value.
DifferentLabelsInMultiSegmentDim | All segments of a multi-segment dimension must be labeled the same.
DimensionOverconstrained | The Dimension would overconstrain the Sketch.
DimensionOverconstrainedError | The Dimension would overconstrain the Sketch.
DimensionOverrideNearByIsLost | The dimension segment containing the override(s) shown below has been removed. The override text will no longer appear. [Description]
DimensionPerpendicularToView | The Dimension is perpendicular to the current view, and no longer valid.
DimensionReferencesInvalid | One or more dimension references are or have become invalid.
DimensionUnequaled | Dimension had to be unlocked and un-EQed in order to remove sketch over-constraining.
DimensionUnlocked | Dimension had to be un-EQed in order to remove sketch over-constraining.
DimensionUnlockedAndUnequaled | Dimension had to be unlocked in order to remove sketch over-constraining.
EqualityConstraintsUnsatisfied | Equality constraints are not satisfied. The action either violates a locked constraint or tries to modify a sketch based object outside of the sketch mode.
EqualityConstraintsUnsatisfiedWarn | Equality constraints are not satisfied. The action either violates a locked constraint or tries to modify a sketch based object outside of the sketch mode.
ForbiddenGroupConstraint | You may not create sketch or family constraints between group members and elements which are not members of the same group.
LabelingDimWithGroupReferences | Labeled constraints cannot participate in groups.
LabelingMultiSegmentWithReporting | Cannot label multi-segment dimensions with reporting parameters.
LabelOverconstrained | Labeling this dimension would overconstrain the sketch.
LinearConstraintBadDirection | Bad direction vector in dimension element.
LinearConstraintNotParallel | The References of the highlighted Dimension are no longer parallel.
LinearDimensionReferenceNotOrthogonalToView | The planes of one or more references are not exactly orthogonal to this view. The dimension to these reference cannot be created.
LockOverconstrained | Locking this dimension would overconstrain the sketch.
LockOverconstrainedAlignment | Locking this alignment would overconstrain the sketch.
LooseLabeledDimensionRegenFailure | Failed to Regenerate Family
MoreThanOneDimsLabelToOneReportingParameter | Reporting parameters can only exist on a single dimension/constraint.
NoConstraintsInProperSketch | You are creating a constraint inside the sketch of a property line. Constraints inside a sketch can only drive elements within the sketch. Usually you do not want property lines driven by other elements. If you would like to constrain other elements to the property lines, you should add the constraints outside of sketch mode.
NoConstraintsToLinks | Constraints may not be created to linked instances using Shared Locations.
RadialDimensionCannotProjectToArc | Cannot form radial dimension.
RadialDimensionChangeRadiusFailed | Can't change radius.
RegenConstraintUnsatisfied | Constraints are not satisfied
RegenConstraintUnsatisfiedWarn | Constraints are not satisfied
ReportingParamAlreadyLabelsToAnotherDim | Cannot label multi-dimensions to one reporting parameter.
SomeDimensionsLostOnPaste | Some Dimensions were not copied because some References were lost.
SomeDimensionsLostWitnessLines | Some Dimensions lost some of their References on paste.
SomeSpotDimensionsLostOnPaste | Some Spot Dimensions were not copied because some References were lost.
SpotDimensionFloatingPointError | Some spot dimensions contain invalid floating-point values.
SpotDimensionFormerSetMoribundCall | One or more Spot Dimension references are no longer valid.
SpotDimensionReferencesNoLongerHorizontal | One or more Spot Dimension references are no longer valid. Spot Dimensions can generally reference only those references which have valid coordinates in the view.
SpotElevationLostEdgeReferences | Some Spot Dimensions lost their References. Those Spot Dimensions will be deleted.
SpotElevationMissesReference | Spot Dimension does not lie on its reference.
SpotSlopeReferenceIsVertical | The highlighted Spot Slope references an element that is vertical.
SpotSlopeReferencePointIsSingular | The highlighted Spot Slope references an element point that is singular.
UnavailableDimensionHostReference | A dimension reference could not be resolved on the host element.
UnstableConstraintInFamily | Constraints between geometry in the family can behave unpredictably on parameter modification. To make the family reliable, constrain geometry to levels, reference planes, or reference lines.
WrongConstraintInGridChainSketch | Curve in a GridChain sketch cannot be constrained to a sub-grid
WrongConstraintInJoistSystemSketch | Structural Beam System sketch can't be constrained to its beam.
WrongConstraintInSkeletonSketch | Reference Lines can only be constrained to Reference Planes, Levels, Family Host, and other Reference Lines.
WrongConstraintInTrussSketch | Structural Truss sketch can't be constrained to its members.

See Also

BuiltInFailures..::..DimensionFailures Class


BuiltInFailures.DimensionFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..DimensionFailures Properties
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback

The BuiltInFailures..::..DimensionFailures type exposes the following members.

Properties

Name | Description
AngularDimensionRegenFailed | Can't form Angular Dimension.
ArcAlignmentRegenFailed | Can't form arc alignment.
ArcLengthDimensionNoReferencesOnArc | None of the segment references of this Arc Length Dimension intersects the bounded arc of the arc reference.
ArcLengthDimensionReferencesNotIntersect | One or more dimension references of this Arc Length dimension no longer intersect the circle needed for arc length computation.
AssocpropNeedJog | Need to add jog in order to satisfy constraints
CannotConstrainBasePointAlignments | Alignments to base points cannot be constrained.
CannotConstrainBasePointDimensions | Dimensions to base points cannot be constrained.
CannotCreateDimensionNotParallel | Can't create dimension. Highlighted references are not parallel to first selection.
CannotDragWitnessLine | Moving the Witness Line conflicts with other Constraints in the Sketch.
CannotLockThisDimension | Can't lock this Dimension because it breaks formulas
CannotToggleDimensionEquality | Toggling the dimension's equality constraint would overconstrain the sketch.
ChangeDimensionSegmentFailed | Can't change dimension segment to this value.
ChangeSpotElevationFailed | Can't change Spot Elevation to the desired value.
DifferentLabelsInMultiSegmentDim | All segments of a multi-segment dimension must be labeled the same.
DimensionOverconstrained | The Dimension would overconstrain the Sketch.
DimensionOverconstrainedError | The Dimension would overconstrain the Sketch.
DimensionOverrideNearByIsLost | The dimension segment containing the override(s) shown below has been removed. The override text will no longer appear. [Description]
DimensionPerpendicularToView | The Dimension is perpendicular to the current view, and no longer valid.
DimensionReferencesInvalid | One or more dimension references are or have become invalid.
DimensionUnequaled | Dimension had to be unlocked and un-EQed in order to remove sketch over-constraining.
DimensionUnlocked | Dimension had to be un-EQed in order to remove sketch over-constraining.
DimensionUnlockedAndUnequaled | Dimension had to be unlocked in order to remove sketch over-constraining.
EqualityConstraintsUnsatisfied | Equality constraints are not satisfied. The action either violates a locked constraint or tries to modify a sketch based object outside of the sketch mode.
EqualityConstraintsUnsatisfiedWarn | Equality constraints are not satisfied. The action either violates a locked constraint or tries to modify a sketch based object outside of the sketch mode.
ForbiddenGroupConstraint | You may not create sketch or family constraints between group members and elements which are not members of the same group.
LabelingDimWithGroupReferences | Labeled constraints cannot participate in groups.
LabelingMultiSegmentWithReporting | Cannot label multi-segment dimensions with reporting parameters.
LabelOverconstrained | Labeling this dimension would overconstrain the sketch.
LinearConstraintBadDirection | Bad direction vector in dimension element.
LinearConstraintNotParallel | The References of the highlighted Dimension are no longer parallel.
LinearDimensionReferenceNotOrthogonalToView | The planes of one or more references are not exactly orthogonal to this view. The dimension to these reference cannot be created.
LockOverconstrained | Locking this dimension would overconstrain the sketch.
LockOverconstrainedAlignment | Locking this alignment would overconstrain the sketch.
LooseLabeledDimensionRegenFailure | Failed to Regenerate Family
MoreThanOneDimsLabelToOneReportingParameter | Reporting parameters can only exist on a single dimension/constraint.
NoConstraintsInProperSketch | You are creating a constraint inside the sketch of a property line. Constraints inside a sketch can only drive elements within the sketch. Usually you do not want property lines driven by other elements. If you would like to constrain other elements to the property lines, you should add the constraints outside of sketch mode.
NoConstraintsToLinks | Constraints may not be created to linked instances using Shared Locations.
RadialDimensionCannotProjectToArc | Cannot form radial dimension.
RadialDimensionChangeRadiusFailed | Can't change radius.
RegenConstraintUnsatisfied | Constraints are not satisfied
RegenConstraintUnsatisfiedWarn | Constraints are not satisfied
ReportingParamAlreadyLabelsToAnotherDim | Cannot label multi-dimensions to one reporting parameter.
SomeDimensionsLostOnPaste | Some Dimensions were not copied because some References were lost.
SomeDimensionsLostWitnessLines | Some Dimensions lost some of their References on paste.
SomeSpotDimensionsLostOnPaste | Some Spot Dimensions were not copied because some References were lost.
SpotDimensionFloatingPointError | Some spot dimensions contain invalid floating-point values.
SpotDimensionFormerSetMoribundCall | One or more Spot Dimension references are no longer valid.
SpotDimensionReferencesNoLongerHorizontal | One or more Spot Dimension references are no longer valid. Spot Dimensions can generally reference only those references which have valid coordinates in the view.
SpotElevationLostEdgeReferences | Some Spot Dimensions lost their References. Those Spot Dimensions will be deleted.
SpotElevationMissesReference | Spot Dimension does not lie on its reference.
SpotSlopeReferenceIsVertical | The highlighted Spot Slope references an element that is vertical.
SpotSlopeReferencePointIsSingular | The highlighted Spot Slope references an element point that is singular.
UnavailableDimensionHostReference | A dimension reference could not be resolved on the host element.
UnstableConstraintInFamily | Constraints between geometry in the family can behave unpredictably on parameter modification. To make the family reliable, constrain geometry to levels, reference planes, or reference lines.
WrongConstraintInGridChainSketch | Curve in a GridChain sketch cannot be constrained to a sub-grid
WrongConstraintInJoistSystemSketch | Structural Beam System sketch can't be constrained to its beam.
WrongConstraintInSkeletonSketch | Reference Lines can only be constrained to Reference Planes, Levels, Family Host, and other Reference Lines.
WrongConstraintInTrussSketch | Structural Truss sketch can't be constrained to its members.

See Also

BuiltInFailures..::..DimensionFailures Class


AngularDimensionRegenFailed Property

[image]

Revit 2024 API
BuiltInFailures..::..DimensionFailures..::..AngularDimensionRegenFailed Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Can't form Angular Dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AngularDimensionRegenFailed { get; }
Visual Basic
Public Shared ReadOnly Property AngularDimensionRegenFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AngularDimensionRegenFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


ArcAlignmentRegenFailed Property

[image]

Revit 2024 API
BuiltInFailures..::..DimensionFailures..::..ArcAlignmentRegenFailed Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Can't form arc alignment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ArcAlignmentRegenFailed { get; }
Visual Basic
Public Shared ReadOnly Property ArcAlignmentRegenFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ArcAlignmentRegenFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


ArcLengthDimensionNoReferencesOnArc Property

[image]

Revit 2024 API
BuiltInFailures..::..DimensionFailures..::..ArcLengthDimensionNoReferencesOnArc Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
None of the segment references of this Arc Length Dimension intersects the bounded arc of the arc reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ArcLengthDimensionNoReferencesOnArc { get; }
Visual Basic
Public Shared ReadOnly Property ArcLengthDimensionNoReferencesOnArc As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ArcLengthDimensionNoReferencesOnArc {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


AssocpropNeedJog Property

[image]

Revit 2024 API
BuiltInFailures..::..DimensionFailures..::..AssocpropNeedJog Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Need to add jog in order to satisfy constraints

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AssocpropNeedJog { get; }
Visual Basic
Public Shared ReadOnly Property AssocpropNeedJog As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AssocpropNeedJog {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


CannotConstrainBasePointAlignments Property

[image]

Revit 2024 API
BuiltInFailures..::..DimensionFailures..::..CannotConstrainBasePointAlignments Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Alignments to base points cannot be constrained.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotConstrainBasePointAlignments { get; }
Visual Basic
Public Shared ReadOnly Property CannotConstrainBasePointAlignments As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotConstrainBasePointAlignments {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


CannotConstrainBasePointDimensions Property

[image]

Revit 2024 API
BuiltInFailures..::..DimensionFailures..::..CannotConstrainBasePointDimensions Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Dimensions to base points cannot be constrained.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotConstrainBasePointDimensions { get; }
Visual Basic
Public Shared ReadOnly Property CannotConstrainBasePointDimensions As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotConstrainBasePointDimensions {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


CannotDragWitnessLine Property

[image]

Revit 2024 API
BuiltInFailures..::..DimensionFailures..::..CannotDragWitnessLine Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Moving the Witness Line conflicts with other Constraints in the Sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotDragWitnessLine { get; }
Visual Basic
Public Shared ReadOnly Property CannotDragWitnessLine As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDragWitnessLine {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


CannotToggleDimensionEquality Property

[image]

Revit 2024 API
BuiltInFailures..::..DimensionFailures..::..CannotToggleDimensionEquality Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Toggling the dimension's equality constraint would overconstrain the sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotToggleDimensionEquality { get; }
Visual Basic
Public Shared ReadOnly Property CannotToggleDimensionEquality As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotToggleDimensionEquality {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


ChangeDimensionSegmentFailed Property

[image]

Revit 2024 API
BuiltInFailures..::..DimensionFailures..::..ChangeDimensionSegmentFailed Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Can't change dimension segment to this value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ChangeDimensionSegmentFailed { get; }
Visual Basic
Public Shared ReadOnly Property ChangeDimensionSegmentFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ChangeDimensionSegmentFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


ChangeSpotElevationFailed Property

[image]

Revit 2024 API
BuiltInFailures..::..DimensionFailures..::..ChangeSpotElevationFailed Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Can't change Spot Elevation to the desired value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ChangeSpotElevationFailed { get; }
Visual Basic
Public Shared ReadOnly Property ChangeSpotElevationFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ChangeSpotElevationFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


DifferentLabelsInMultiSegmentDim Property

[image]

Revit 2024 API
BuiltInFailures..::..DimensionFailures..::..DifferentLabelsInMultiSegmentDim Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
All segments of a multi-segment dimension must be labeled the same.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DifferentLabelsInMultiSegmentDim { get; }
Visual Basic
Public Shared ReadOnly Property DifferentLabelsInMultiSegmentDim As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DifferentLabelsInMultiSegmentDim {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


DimensionOverconstrainedError Property

[image]

Revit 2024 API
BuiltInFailures..::..DimensionFailures..::..DimensionOverconstrainedError Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
The Dimension would overconstrain the Sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DimensionOverconstrainedError { get; }
Visual Basic
Public Shared ReadOnly Property DimensionOverconstrainedError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DimensionOverconstrainedError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


DimensionOverrideNearByIsLost Property

[image]

Revit 2024 API
BuiltInFailures..::..DimensionFailures..::..DimensionOverrideNearByIsLost Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
The dimension segment containing the override(s) shown below has been removed. The override text will no longer appear. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DimensionOverrideNearByIsLost { get; }
Visual Basic
Public Shared ReadOnly Property DimensionOverrideNearByIsLost As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DimensionOverrideNearByIsLost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


DimensionPerpendicularToView Property

[image]

Revit 2024 API
BuiltInFailures..::..DimensionFailures..::..DimensionPerpendicularToView Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
The Dimension is perpendicular to the current view, and no longer valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DimensionPerpendicularToView { get; }
Visual Basic
Public Shared ReadOnly Property DimensionPerpendicularToView As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DimensionPerpendicularToView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


DimensionUnequaled Property

[image]

Revit 2024 API
BuiltInFailures..::..DimensionFailures..::..DimensionUnequaled Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Dimension had to be unlocked and un-EQed in order to remove sketch over-constraining.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DimensionUnequaled { get; }
Visual Basic
Public Shared ReadOnly Property DimensionUnequaled As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DimensionUnequaled {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


DimensionUnlocked Property

[image]

Revit 2024 API
BuiltInFailures..::..DimensionFailures..::..DimensionUnlocked Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Dimension had to be un-EQed in order to remove sketch over-constraining.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DimensionUnlocked { get; }
Visual Basic
Public Shared ReadOnly Property DimensionUnlocked As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DimensionUnlocked {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


EqualityConstraintsUnsatisfied Property

[image]

Revit 2024 API
BuiltInFailures..::..DimensionFailures..::..EqualityConstraintsUnsatisfied Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Equality constraints are not satisfied. The action either violates a locked constraint or tries to modify a sketch based object outside of the sketch mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId EqualityConstraintsUnsatisfied { get; }
Visual Basic
Public Shared ReadOnly Property EqualityConstraintsUnsatisfied As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ EqualityConstraintsUnsatisfied {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


EqualityConstraintsUnsatisfiedWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..DimensionFailures..::..EqualityConstraintsUnsatisfiedWarn Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Equality constraints are not satisfied. The action either violates a locked constraint or tries to modify a sketch based object outside of the sketch mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId EqualityConstraintsUnsatisfiedWarn { get; }
Visual Basic
Public Shared ReadOnly Property EqualityConstraintsUnsatisfiedWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ EqualityConstraintsUnsatisfiedWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


ForbiddenGroupConstraint Property

[image]

Revit 2024 API
BuiltInFailures..::..DimensionFailures..::..ForbiddenGroupConstraint Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
You may not create sketch or family constraints between group members and elements which are not members of the same group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ForbiddenGroupConstraint { get; }
Visual Basic
Public Shared ReadOnly Property ForbiddenGroupConstraint As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ForbiddenGroupConstraint {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


LabelingDimWithGroupReferences Property

[image]

Revit 2024 API
BuiltInFailures..::..DimensionFailures..::..LabelingDimWithGroupReferences Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Labeled constraints cannot participate in groups.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId LabelingDimWithGroupReferences { get; }
Visual Basic
Public Shared ReadOnly Property LabelingDimWithGroupReferences As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LabelingDimWithGroupReferences {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


LabelOverconstrained Property

[image]

Revit 2024 API
BuiltInFailures..::..DimensionFailures..::..LabelOverconstrained Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Labeling this dimension would overconstrain the sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId LabelOverconstrained { get; }
Visual Basic
Public Shared ReadOnly Property LabelOverconstrained As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LabelOverconstrained {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


LinearConstraintBadDirection Property

[image]

Revit 2024 API
BuiltInFailures..::..DimensionFailures..::..LinearConstraintBadDirection Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Bad direction vector in dimension element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId LinearConstraintBadDirection { get; }
Visual Basic
Public Shared ReadOnly Property LinearConstraintBadDirection As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LinearConstraintBadDirection {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


LockOverconstrained Property

[image]

Revit 2024 API
BuiltInFailures..::..DimensionFailures..::..LockOverconstrained Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Locking this dimension would overconstrain the sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId LockOverconstrained { get; }
Visual Basic
Public Shared ReadOnly Property LockOverconstrained As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LockOverconstrained {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


LooseLabeledDimensionRegenFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..DimensionFailures..::..LooseLabeledDimensionRegenFailure Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Failed to Regenerate Family

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId LooseLabeledDimensionRegenFailure { get; }
Visual Basic
Public Shared ReadOnly Property LooseLabeledDimensionRegenFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LooseLabeledDimensionRegenFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


MoreThanOneDimsLabelToOneReportingParameter Property

[image]

Revit 2024 API
BuiltInFailures..::..DimensionFailures..::..MoreThanOneDimsLabelToOneReportingParameter Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Reporting parameters can only exist on a single dimension/constraint.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MoreThanOneDimsLabelToOneReportingParameter { get; }
Visual Basic
Public Shared ReadOnly Property MoreThanOneDimsLabelToOneReportingParameter As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MoreThanOneDimsLabelToOneReportingParameter {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


NoConstraintsInProperSketch Property

[image]

Revit 2024 API
BuiltInFailures..::..DimensionFailures..::..NoConstraintsInProperSketch Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
You are creating a constraint inside the sketch of a property line. Constraints inside a sketch can only drive elements within the sketch. Usually you do not want property lines driven by other elements. If you would like to constrain other elements to the property lines, you should add the constraints outside of sketch mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoConstraintsInProperSketch { get; }
Visual Basic
Public Shared ReadOnly Property NoConstraintsInProperSketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoConstraintsInProperSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


RadialDimensionChangeRadiusFailed Property

[image]

Revit 2024 API
BuiltInFailures..::..DimensionFailures..::..RadialDimensionChangeRadiusFailed Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Can't change radius.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RadialDimensionChangeRadiusFailed { get; }
Visual Basic
Public Shared ReadOnly Property RadialDimensionChangeRadiusFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RadialDimensionChangeRadiusFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


RegenConstraintUnsatisfied Property

[image]

Revit 2024 API
BuiltInFailures..::..DimensionFailures..::..RegenConstraintUnsatisfied Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Constraints are not satisfied

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RegenConstraintUnsatisfied { get; }
Visual Basic
Public Shared ReadOnly Property RegenConstraintUnsatisfied As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RegenConstraintUnsatisfied {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


RegenConstraintUnsatisfiedWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..DimensionFailures..::..RegenConstraintUnsatisfiedWarn Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Constraints are not satisfied

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RegenConstraintUnsatisfiedWarn { get; }
Visual Basic
Public Shared ReadOnly Property RegenConstraintUnsatisfiedWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RegenConstraintUnsatisfiedWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


ReportingParamAlreadyLabelsToAnotherDim Property

[image]

Revit 2024 API
BuiltInFailures..::..DimensionFailures..::..ReportingParamAlreadyLabelsToAnotherDim Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Cannot label multi-dimensions to one reporting parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ReportingParamAlreadyLabelsToAnotherDim { get; }
Visual Basic
Public Shared ReadOnly Property ReportingParamAlreadyLabelsToAnotherDim As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ReportingParamAlreadyLabelsToAnotherDim {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


SomeDimensionsLostOnPaste Property

[image]

Revit 2024 API
BuiltInFailures..::..DimensionFailures..::..SomeDimensionsLostOnPaste Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Some Dimensions were not copied because some References were lost.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SomeDimensionsLostOnPaste { get; }
Visual Basic
Public Shared ReadOnly Property SomeDimensionsLostOnPaste As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SomeDimensionsLostOnPaste {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


SomeDimensionsLostWitnessLines Property

[image]

Revit 2024 API
BuiltInFailures..::..DimensionFailures..::..SomeDimensionsLostWitnessLines Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Some Dimensions lost some of their References on paste.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SomeDimensionsLostWitnessLines { get; }
Visual Basic
Public Shared ReadOnly Property SomeDimensionsLostWitnessLines As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SomeDimensionsLostWitnessLines {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


SomeSpotDimensionsLostOnPaste Property

[image]

Revit 2024 API
BuiltInFailures..::..DimensionFailures..::..SomeSpotDimensionsLostOnPaste Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Some Spot Dimensions were not copied because some References were lost.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SomeSpotDimensionsLostOnPaste { get; }
Visual Basic
Public Shared ReadOnly Property SomeSpotDimensionsLostOnPaste As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SomeSpotDimensionsLostOnPaste {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


SpotDimensionFloatingPointError Property

[image]

Revit 2024 API
BuiltInFailures..::..DimensionFailures..::..SpotDimensionFloatingPointError Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Some spot dimensions contain invalid floating-point values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SpotDimensionFloatingPointError { get; }
Visual Basic
Public Shared ReadOnly Property SpotDimensionFloatingPointError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SpotDimensionFloatingPointError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


SpotDimensionFormerSetMoribundCall Property

[image]

Revit 2024 API
BuiltInFailures..::..DimensionFailures..::..SpotDimensionFormerSetMoribundCall Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
One or more Spot Dimension references are no longer valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SpotDimensionFormerSetMoribundCall { get; }
Visual Basic
Public Shared ReadOnly Property SpotDimensionFormerSetMoribundCall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SpotDimensionFormerSetMoribundCall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


SpotDimensionReferencesNoLongerHorizontal Property

[image]

Revit 2024 API
BuiltInFailures..::..DimensionFailures..::..SpotDimensionReferencesNoLongerHorizontal Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
One or more Spot Dimension references are no longer valid. Spot Dimensions can generally reference only those references which have valid coordinates in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SpotDimensionReferencesNoLongerHorizontal { get; }
Visual Basic
Public Shared ReadOnly Property SpotDimensionReferencesNoLongerHorizontal As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SpotDimensionReferencesNoLongerHorizontal {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


SpotElevationLostEdgeReferences Property

[image]

Revit 2024 API
BuiltInFailures..::..DimensionFailures..::..SpotElevationLostEdgeReferences Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Some Spot Dimensions lost their References. Those Spot Dimensions will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SpotElevationLostEdgeReferences { get; }
Visual Basic
Public Shared ReadOnly Property SpotElevationLostEdgeReferences As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SpotElevationLostEdgeReferences {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


SpotSlopeReferenceIsVertical Property

[image]

Revit 2024 API
BuiltInFailures..::..DimensionFailures..::..SpotSlopeReferenceIsVertical Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
The highlighted Spot Slope references an element that is vertical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SpotSlopeReferenceIsVertical { get; }
Visual Basic
Public Shared ReadOnly Property SpotSlopeReferenceIsVertical As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SpotSlopeReferenceIsVertical {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


SpotSlopeReferencePointIsSingular Property

[image]

Revit 2024 API
BuiltInFailures..::..DimensionFailures..::..SpotSlopeReferencePointIsSingular Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
The highlighted Spot Slope references an element point that is singular.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SpotSlopeReferencePointIsSingular { get; }
Visual Basic
Public Shared ReadOnly Property SpotSlopeReferencePointIsSingular As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SpotSlopeReferencePointIsSingular {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


UnavailableDimensionHostReference Property

[image]

Revit 2024 API
BuiltInFailures..::..DimensionFailures..::..UnavailableDimensionHostReference Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
A dimension reference could not be resolved on the host element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UnavailableDimensionHostReference { get; }
Visual Basic
Public Shared ReadOnly Property UnavailableDimensionHostReference As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnavailableDimensionHostReference {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


UnstableConstraintInFamily Property

[image]

Revit 2024 API
BuiltInFailures..::..DimensionFailures..::..UnstableConstraintInFamily Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Constraints between geometry in the family can behave unpredictably on parameter modification. To make the family reliable, constrain geometry to levels, reference planes, or reference lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UnstableConstraintInFamily { get; }
Visual Basic
Public Shared ReadOnly Property UnstableConstraintInFamily As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnstableConstraintInFamily {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


WrongConstraintInGridChainSketch Property

[image]

Revit 2024 API
BuiltInFailures..::..DimensionFailures..::..WrongConstraintInGridChainSketch Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Curve in a GridChain sketch cannot be constrained to a sub-grid

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WrongConstraintInGridChainSketch { get; }
Visual Basic
Public Shared ReadOnly Property WrongConstraintInGridChainSketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WrongConstraintInGridChainSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


WrongConstraintInJoistSystemSketch Property

[image]

Revit 2024 API
BuiltInFailures..::..DimensionFailures..::..WrongConstraintInJoistSystemSketch Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Structural Beam System sketch can't be constrained to its beam.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WrongConstraintInJoistSystemSketch { get; }
Visual Basic
Public Shared ReadOnly Property WrongConstraintInJoistSystemSketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WrongConstraintInJoistSystemSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


WrongConstraintInSkeletonSketch Property

[image]

Revit 2024 API
BuiltInFailures..::..DimensionFailures..::..WrongConstraintInSkeletonSketch Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Reference Lines can only be constrained to Reference Planes, Levels, Family Host, and other Reference Lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WrongConstraintInSkeletonSketch { get; }
Visual Basic
Public Shared ReadOnly Property WrongConstraintInSkeletonSketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WrongConstraintInSkeletonSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


WrongConstraintInTrussSketch Property

[image]

Revit 2024 API
BuiltInFailures..::..DimensionFailures..::..WrongConstraintInTrussSketch Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Structural Truss sketch can't be constrained to its members.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WrongConstraintInTrussSketch { get; }
Visual Basic
Public Shared ReadOnly Property WrongConstraintInTrussSketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WrongConstraintInTrussSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


BuiltInFailures.DirectContext3DFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..DirectContext3DFailures Class
BuiltInFailures Class Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class DirectContext3DFailures
Visual Basic
Public NotInheritable Class DirectContext3DFailures
Visual C++
public ref class DirectContext3DFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..DirectContext3DFailures

See Also

BuiltInFailures..::..DirectContext3DFailures Members


BuiltInFailures.DirectContext3DFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..DirectContext3DFailures Members
BuiltInFailures..::..DirectContext3DFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..DirectContext3DFailures type exposes the following members.

Properties

Name | Description
NoMoreExternalDataTypeInstances | No more instances of the Coordination Model.
UnableToLoadCoordinationModel | Unable to load Coordination Model.

See Also

BuiltInFailures..::..DirectContext3DFailures Class


BuiltInFailures.DirectContext3DFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..DirectContext3DFailures Properties
BuiltInFailures..::..DirectContext3DFailures Class See Also Send Feedback

The BuiltInFailures..::..DirectContext3DFailures type exposes the following members.

Properties

Name | Description
NoMoreExternalDataTypeInstances | No more instances of the Coordination Model.
UnableToLoadCoordinationModel | Unable to load Coordination Model.

See Also

BuiltInFailures..::..DirectContext3DFailures Class


NoMoreExternalDataTypeInstances Property

[image]

Revit 2024 API
BuiltInFailures..::..DirectContext3DFailures..::..NoMoreExternalDataTypeInstances Property
BuiltInFailures..::..DirectContext3DFailures Class See Also Send Feedback
No more instances of the Coordination Model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoMoreExternalDataTypeInstances { get; }
Visual Basic
Public Shared ReadOnly Property NoMoreExternalDataTypeInstances As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoMoreExternalDataTypeInstances {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DirectContext3DFailures Class


UnableToLoadCoordinationModel Property

[image]

Revit 2024 API
BuiltInFailures..::..DirectContext3DFailures..::..UnableToLoadCoordinationModel Property
BuiltInFailures..::..DirectContext3DFailures Class See Also Send Feedback
Unable to load Coordination Model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UnableToLoadCoordinationModel { get; }
Visual Basic
Public Shared ReadOnly Property UnableToLoadCoordinationModel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableToLoadCoordinationModel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DirectContext3DFailures Class


BuiltInFailures.DirectShapeFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..DirectShapeFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failure definitions related to DirectShapes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class DirectShapeFailures
Visual Basic
Public NotInheritable Class DirectShapeFailures
Visual C++
public ref class DirectShapeFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..DirectShapeFailures

See Also

BuiltInFailures..::..DirectShapeFailures Members


BuiltInFailures.DirectShapeFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..DirectShapeFailures Members
BuiltInFailures..::..DirectShapeFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..DirectShapeFailures type exposes the following members.

Properties

Name | Description
CannotCreateDirectShapeOrTypeDocumentCorruption | Cannot create a DirectShape or DirectShapeType.
CannotCreateDirectShapeOrTypeError | Cannot create a DirectShape or DirectShapeType.
CannotCreateDirectShapeOrTypeWarning | Cannot create a DirectShape or DirectShapeType.
CannotCreateDirectShapeRefsWarning | Cannot create reference objects for a DirectShape.
CannotCreateDirectShapeTypeRefsWarning | Cannot create reference objects for a DirectShapeType.

See Also

BuiltInFailures..::..DirectShapeFailures Class


BuiltInFailures.DirectShapeFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..DirectShapeFailures Properties
BuiltInFailures..::..DirectShapeFailures Class See Also Send Feedback

The BuiltInFailures..::..DirectShapeFailures type exposes the following members.

Properties

Name | Description
CannotCreateDirectShapeOrTypeDocumentCorruption | Cannot create a DirectShape or DirectShapeType.
CannotCreateDirectShapeOrTypeError | Cannot create a DirectShape or DirectShapeType.
CannotCreateDirectShapeOrTypeWarning | Cannot create a DirectShape or DirectShapeType.
CannotCreateDirectShapeRefsWarning | Cannot create reference objects for a DirectShape.
CannotCreateDirectShapeTypeRefsWarning | Cannot create reference objects for a DirectShapeType.

See Also

BuiltInFailures..::..DirectShapeFailures Class


CannotCreateDirectShapeOrTypeError Property

[image]

Revit 2024 API
BuiltInFailures..::..DirectShapeFailures..::..CannotCreateDirectShapeOrTypeError Property
BuiltInFailures..::..DirectShapeFailures Class See Also Send Feedback
Cannot create a DirectShape or DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateDirectShapeOrTypeError { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateDirectShapeOrTypeError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateDirectShapeOrTypeError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DirectShapeFailures Class


CannotCreateDirectShapeRefsWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..DirectShapeFailures..::..CannotCreateDirectShapeRefsWarning Property
BuiltInFailures..::..DirectShapeFailures Class See Also Send Feedback
Cannot create reference objects for a DirectShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateDirectShapeRefsWarning { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateDirectShapeRefsWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateDirectShapeRefsWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DirectShapeFailures Class


CannotCreateDirectShapeTypeRefsWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..DirectShapeFailures..::..CannotCreateDirectShapeTypeRefsWarning Property
BuiltInFailures..::..DirectShapeFailures Class See Also Send Feedback
Cannot create reference objects for a DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateDirectShapeTypeRefsWarning { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateDirectShapeTypeRefsWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateDirectShapeTypeRefsWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DirectShapeFailures Class


BuiltInFailures.DisplacementElementFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..DisplacementElementFailures Class
BuiltInFailures Class Members See Also Send Feedback
Error messages related to the DisplacementElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class DisplacementElementFailures
Visual Basic
Public NotInheritable Class DisplacementElementFailures
Visual C++
public ref class DisplacementElementFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..DisplacementElementFailures

See Also

BuiltInFailures..::..DisplacementElementFailures Members


BuiltInFailures.DisplacementElementFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..DisplacementElementFailures Members
BuiltInFailures..::..DisplacementElementFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..DisplacementElementFailures type exposes the following members.

Properties

Name | Description
CannotCopyDisplacementSetIntoOtherDocument | A Displacement Set can only be pasted into a view in the same document in which it was created.
CannotRemoveLastDisplacedElement | A Displacement Set can only be pasted into a view in the same document in which it was created.
DetectedCycleInDisplacedElementParents | Invalid parent relationship for a Displacement element. No cycles are allowed.
ElementsAlreadyDisplacedInView | You cannot copy a displacement set into a view if one or several of its elements already belong to another displacement set.

See Also

BuiltInFailures..::..DisplacementElementFailures Class


BuiltInFailures.DisplacementElementFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..DisplacementElementFailures Properties
BuiltInFailures..::..DisplacementElementFailures Class See Also Send Feedback

The BuiltInFailures..::..DisplacementElementFailures type exposes the following members.

Properties

Name | Description
CannotCopyDisplacementSetIntoOtherDocument | A Displacement Set can only be pasted into a view in the same document in which it was created.
CannotRemoveLastDisplacedElement | A Displacement Set can only be pasted into a view in the same document in which it was created.
DetectedCycleInDisplacedElementParents | Invalid parent relationship for a Displacement element. No cycles are allowed.
ElementsAlreadyDisplacedInView | You cannot copy a displacement set into a view if one or several of its elements already belong to another displacement set.

See Also

BuiltInFailures..::..DisplacementElementFailures Class


CannotCopyDisplacementSetIntoOtherDocument Property

[image]

Revit 2024 API
BuiltInFailures..::..DisplacementElementFailures..::..CannotCopyDisplacementSetIntoOtherDocument Property
BuiltInFailures..::..DisplacementElementFailures Class See Also Send Feedback
A Displacement Set can only be pasted into a view in the same document in which it was created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCopyDisplacementSetIntoOtherDocument { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyDisplacementSetIntoOtherDocument As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyDisplacementSetIntoOtherDocument {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DisplacementElementFailures Class


DetectedCycleInDisplacedElementParents Property

[image]

Revit 2024 API
BuiltInFailures..::..DisplacementElementFailures..::..DetectedCycleInDisplacedElementParents Property
BuiltInFailures..::..DisplacementElementFailures Class See Also Send Feedback
Invalid parent relationship for a Displacement element. No cycles are allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DetectedCycleInDisplacedElementParents { get; }
Visual Basic
Public Shared ReadOnly Property DetectedCycleInDisplacedElementParents As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DetectedCycleInDisplacedElementParents {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DisplacementElementFailures Class


BuiltInFailures.DividedPathFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..DividedPathFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures related to divided path operations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class DividedPathFailures
Visual Basic
Public NotInheritable Class DividedPathFailures
Visual C++
public ref class DividedPathFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..DividedPathFailures

See Also

BuiltInFailures..::..DividedPathFailures Members


BuiltInFailures.DividedPathFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..DividedPathFailures Members
BuiltInFailures..::..DividedPathFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..DividedPathFailures type exposes the following members.

Properties

Name | Description
DividedPathCannotApplyDivideSettings | Default Divide settings cannot be applied to Divided Path.
DividedPathCannotBeMirroredWithoutItsCurves | Divided path cannot be mirrored without its curves.
DividedPathCannotCreateFromGeometry | Highlighted geometry contains a path or edge that could not be divided.
DividedPathDistanceTooSmall | Distance is too small.
DividedPathIndentsOverlap | Beginning indent and end indent overlap.
DividedPathIntersectionPolycurveParamsStepFailed | Intersection failed.
DividedPathInvalidNumberOfPoints | End indent is too large.
DividedPathLayoutStepFailed | Layout algorithm failed.
DividedPathUpdateMergedPointKeysStepFailed | Merging failed.

See Also

BuiltInFailures..::..DividedPathFailures Class


BuiltInFailures.DividedPathFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..DividedPathFailures Properties
BuiltInFailures..::..DividedPathFailures Class See Also Send Feedback

The BuiltInFailures..::..DividedPathFailures type exposes the following members.

Properties

Name | Description
DividedPathCannotApplyDivideSettings | Default Divide settings cannot be applied to Divided Path.
DividedPathCannotBeMirroredWithoutItsCurves | Divided path cannot be mirrored without its curves.
DividedPathCannotCreateFromGeometry | Highlighted geometry contains a path or edge that could not be divided.
DividedPathDistanceTooSmall | Distance is too small.
DividedPathIndentsOverlap | Beginning indent and end indent overlap.
DividedPathIntersectionPolycurveParamsStepFailed | Intersection failed.
DividedPathInvalidNumberOfPoints | End indent is too large.
DividedPathLayoutStepFailed | Layout algorithm failed.
DividedPathUpdateMergedPointKeysStepFailed | Merging failed.

See Also

BuiltInFailures..::..DividedPathFailures Class


DividedPathCannotApplyDivideSettings Property

[image]

Revit 2024 API
BuiltInFailures..::..DividedPathFailures..::..DividedPathCannotApplyDivideSettings Property
BuiltInFailures..::..DividedPathFailures Class See Also Send Feedback
Default Divide settings cannot be applied to Divided Path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DividedPathCannotApplyDivideSettings { get; }
Visual Basic
Public Shared ReadOnly Property DividedPathCannotApplyDivideSettings As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedPathCannotApplyDivideSettings {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedPathFailures Class


DividedPathCannotBeMirroredWithoutItsCurves Property

[image]

Revit 2024 API
BuiltInFailures..::..DividedPathFailures..::..DividedPathCannotBeMirroredWithoutItsCurves Property
BuiltInFailures..::..DividedPathFailures Class See Also Send Feedback
Divided path cannot be mirrored without its curves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DividedPathCannotBeMirroredWithoutItsCurves { get; }
Visual Basic
Public Shared ReadOnly Property DividedPathCannotBeMirroredWithoutItsCurves As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedPathCannotBeMirroredWithoutItsCurves {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedPathFailures Class


DividedPathCannotCreateFromGeometry Property

[image]

Revit 2024 API
BuiltInFailures..::..DividedPathFailures..::..DividedPathCannotCreateFromGeometry Property
BuiltInFailures..::..DividedPathFailures Class See Also Send Feedback
Highlighted geometry contains a path or edge that could not be divided.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DividedPathCannotCreateFromGeometry { get; }
Visual Basic
Public Shared ReadOnly Property DividedPathCannotCreateFromGeometry As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedPathCannotCreateFromGeometry {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedPathFailures Class


DividedPathDistanceTooSmall Property

[image]

Revit 2024 API
BuiltInFailures..::..DividedPathFailures..::..DividedPathDistanceTooSmall Property
BuiltInFailures..::..DividedPathFailures Class See Also Send Feedback
Distance is too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DividedPathDistanceTooSmall { get; }
Visual Basic
Public Shared ReadOnly Property DividedPathDistanceTooSmall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedPathDistanceTooSmall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedPathFailures Class


DividedPathIntersectionPolycurveParamsStepFailed Property

[image]

Revit 2024 API
BuiltInFailures..::..DividedPathFailures..::..DividedPathIntersectionPolycurveParamsStepFailed Property
BuiltInFailures..::..DividedPathFailures Class See Also Send Feedback
Intersection failed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DividedPathIntersectionPolycurveParamsStepFailed { get; }
Visual Basic
Public Shared ReadOnly Property DividedPathIntersectionPolycurveParamsStepFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedPathIntersectionPolycurveParamsStepFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedPathFailures Class


DividedPathLayoutStepFailed Property

[image]

Revit 2024 API
BuiltInFailures..::..DividedPathFailures..::..DividedPathLayoutStepFailed Property
BuiltInFailures..::..DividedPathFailures Class See Also Send Feedback
Layout algorithm failed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DividedPathLayoutStepFailed { get; }
Visual Basic
Public Shared ReadOnly Property DividedPathLayoutStepFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedPathLayoutStepFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedPathFailures Class


DividedPathUpdateMergedPointKeysStepFailed Property

[image]

Revit 2024 API
BuiltInFailures..::..DividedPathFailures..::..DividedPathUpdateMergedPointKeysStepFailed Property
BuiltInFailures..::..DividedPathFailures Class See Also Send Feedback
Merging failed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DividedPathUpdateMergedPointKeysStepFailed { get; }
Visual Basic
Public Shared ReadOnly Property DividedPathUpdateMergedPointKeysStepFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedPathUpdateMergedPointKeysStepFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedPathFailures Class


BuiltInFailures.DividedSurfaceFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..DividedSurfaceFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about DividedSurface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class DividedSurfaceFailures
Visual Basic
Public NotInheritable Class DividedSurfaceFailures
Visual C++
public ref class DividedSurfaceFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..DividedSurfaceFailures

See Also

BuiltInFailures..::..DividedSurfaceFailures Members


BuiltInFailures.DividedSurfaceFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..DividedSurfaceFailures Members
BuiltInFailures..::..DividedSurfaceFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..DividedSurfaceFailures type exposes the following members.

Properties

Name | Description
DividedSurfaceCannotApplyDivideSettings | Default Divide settings were not applied to Divided Surface. Please adjust grid spacing values manually.
DividedSurfaceCoincidingSplittingWorkplanes | Coinciding splitting workplanes are encountered
DividedSurfaceCurveChainBelongsToMultipleBeltIntervals | A chain formed by these curve elements defines a splitter belonging to multiple belt intervals and will be ignored
DividedSurfaceCurveChainBothUandV | A chain formed by these curve elements is trying to be both U- and V- splitter
DividedSurfaceCurveChainDoesNotEngageUorV | A chain formed by these curve elements does engage any gridlines on the face to be divided and will be ignored
DividedSurfaceCurveChainGeneralProblem | The chain formed by these curve elements cannot be processed and will be ignored.
DividedSurfaceCurveChainIntersection | A chain formed by these curve elements intersects other chain with the same grid orientation. Both chains will be ignored
DividedSurfaceCurveChainIsTooClosedToGridlines | A chain formed by these curve elements defines a splitter which lies too close to gridlines and will be ignored
DividedSurfaceCurveChainMultipleSeqIntersWithDivLine | The chain formed by these curve elements has multiple sequential intersections with a gridline and so the chain will be ignored
DividedSurfaceCurveChainNonSeqIntersWithDivLines | The chain formed by these curve elements has multiple non-sequential intersections with the same gridline and will be ignored
DividedSurfaceCurveChainUnsortableBucket | The chains formed by these curve elements cannot be ordered consistently in the their grid interval and will be ignored
DividedSurfaceCurveFromChainMultipleIntersWithDivLine | A curve from the chain formed by these curve elements either intersects a gridline more than once or coincides with it and so the chain will be ignored
DividedSurfaceCurveLoopChainIntersectedByExtensions | Curve elements forming a chain which is intersected by extensions of the chain ends cannot be used as splitters and are ignored.
DividedSurfaceCuttingSurfaceDoesNotCutMeshFace | The surface-based splitter does not intersect a face to be divided and will be ignored
DividedSurfaceCuttingSurfaceGeneralProblem | Cannot process a surface-based splitter
DividedSurfaceCuttingSurfaceMakesMultipleCuts | The surface-based splitter intersects a face to be divided in multiple places and this case is not currently supported
DividedSurfaceDidNotRegenerateProperly | Divided Surface gridlines could not be generated.
DividedSurfaceDiscardedSplittersWarning | Not all intersecting references (levels, reference planes or lines) could be used to intersect the surface
DividedSurfaceIgnoresSplitters | Revit cannot create a rectangular grid by intersecting the current selection of elements (levels, reference planes, or curves drawn on reference planes) with the surface. Make sure that curves do not form closed loops. It is helpful if curves start and end outside the surface, rather than inside it.
DividedSurfaceInvalidSpacing | Constraints not satisfied, cannot generate gridlines.
DividedSurfaceLoopsOfSplittingCurves | Curve elements forming a closed loop currently cannot be used as splitters and are ignored.
DividedSurfaceMultipleIntersBetweenOppositeVirtualGrids | There are multiple intersections between splitting chain of virtual splitters defined by these elements and so one of the virtual splitters will be ignored
DividedSurfaceSelfIntersectingCurveLoopChain | Curve elements forming a self-intersecting chain cannot be used as splitters and are ignored.
DividedSurfaceSingleCurveLoopsAsSplitters | Curve elements forming a single curve loop cannot be used as splitters and are ignored.
DividedSurfaceSingleCurveMultipleIntersBetweenOppositeVirtualGrids | There are curves in splitting chain of virtual splitters defined by these elements which intersect each other multiple times and so one of the virtual splitters will be ignored
DividedSurfaceSplitManagerProblem1dNonWPCurve | Divided Surface cannot be split by a one dimensional curve without workplane
DividedSurfaceSplitManagerProblemClosedArcOrEllipse | Divided Surface cannot be split by a closed arc or ellipse.
DividedSurfaceSplitRefInvisible | Some of the splitting references of this Divided Surface are invisible in the current view.
DividedSurfaceSplittingCurveChainsBetweenMultipleNeighbors | Curve elements which form chains connecting points shared by more than two curve elements are ignored.
DividedSurfaceSplittingCurvesWithMultipleNeighbors | A point cannot coincide with end points of more than two curve elements. All curve elements adjacent to such a point are ignored.
DividedSurfaceZeroLengthSplittingCurve | Curve element with zero length cannot be used as a splitter and ignored.
MeshTopologicalSortFailed | Splitters and grids do not define a consistent rectangular mesh on the face.

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


BuiltInFailures.DividedSurfaceFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..DividedSurfaceFailures Properties
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback

The BuiltInFailures..::..DividedSurfaceFailures type exposes the following members.

Properties

Name | Description
DividedSurfaceCannotApplyDivideSettings | Default Divide settings were not applied to Divided Surface. Please adjust grid spacing values manually.
DividedSurfaceCoincidingSplittingWorkplanes | Coinciding splitting workplanes are encountered
DividedSurfaceCurveChainBelongsToMultipleBeltIntervals | A chain formed by these curve elements defines a splitter belonging to multiple belt intervals and will be ignored
DividedSurfaceCurveChainBothUandV | A chain formed by these curve elements is trying to be both U- and V- splitter
DividedSurfaceCurveChainDoesNotEngageUorV | A chain formed by these curve elements does engage any gridlines on the face to be divided and will be ignored
DividedSurfaceCurveChainGeneralProblem | The chain formed by these curve elements cannot be processed and will be ignored.
DividedSurfaceCurveChainIntersection | A chain formed by these curve elements intersects other chain with the same grid orientation. Both chains will be ignored
DividedSurfaceCurveChainIsTooClosedToGridlines | A chain formed by these curve elements defines a splitter which lies too close to gridlines and will be ignored
DividedSurfaceCurveChainMultipleSeqIntersWithDivLine | The chain formed by these curve elements has multiple sequential intersections with a gridline and so the chain will be ignored
DividedSurfaceCurveChainNonSeqIntersWithDivLines | The chain formed by these curve elements has multiple non-sequential intersections with the same gridline and will be ignored
DividedSurfaceCurveChainUnsortableBucket | The chains formed by these curve elements cannot be ordered consistently in the their grid interval and will be ignored
DividedSurfaceCurveFromChainMultipleIntersWithDivLine | A curve from the chain formed by these curve elements either intersects a gridline more than once or coincides with it and so the chain will be ignored
DividedSurfaceCurveLoopChainIntersectedByExtensions | Curve elements forming a chain which is intersected by extensions of the chain ends cannot be used as splitters and are ignored.
DividedSurfaceCuttingSurfaceDoesNotCutMeshFace | The surface-based splitter does not intersect a face to be divided and will be ignored
DividedSurfaceCuttingSurfaceGeneralProblem | Cannot process a surface-based splitter
DividedSurfaceCuttingSurfaceMakesMultipleCuts | The surface-based splitter intersects a face to be divided in multiple places and this case is not currently supported
DividedSurfaceDidNotRegenerateProperly | Divided Surface gridlines could not be generated.
DividedSurfaceDiscardedSplittersWarning | Not all intersecting references (levels, reference planes or lines) could be used to intersect the surface
DividedSurfaceIgnoresSplitters | Revit cannot create a rectangular grid by intersecting the current selection of elements (levels, reference planes, or curves drawn on reference planes) with the surface. Make sure that curves do not form closed loops. It is helpful if curves start and end outside the surface, rather than inside it.
DividedSurfaceInvalidSpacing | Constraints not satisfied, cannot generate gridlines.
DividedSurfaceLoopsOfSplittingCurves | Curve elements forming a closed loop currently cannot be used as splitters and are ignored.
DividedSurfaceMultipleIntersBetweenOppositeVirtualGrids | There are multiple intersections between splitting chain of virtual splitters defined by these elements and so one of the virtual splitters will be ignored
DividedSurfaceSelfIntersectingCurveLoopChain | Curve elements forming a self-intersecting chain cannot be used as splitters and are ignored.
DividedSurfaceSingleCurveLoopsAsSplitters | Curve elements forming a single curve loop cannot be used as splitters and are ignored.
DividedSurfaceSingleCurveMultipleIntersBetweenOppositeVirtualGrids | There are curves in splitting chain of virtual splitters defined by these elements which intersect each other multiple times and so one of the virtual splitters will be ignored
DividedSurfaceSplitManagerProblem1dNonWPCurve | Divided Surface cannot be split by a one dimensional curve without workplane
DividedSurfaceSplitManagerProblemClosedArcOrEllipse | Divided Surface cannot be split by a closed arc or ellipse.
DividedSurfaceSplitRefInvisible | Some of the splitting references of this Divided Surface are invisible in the current view.
DividedSurfaceSplittingCurveChainsBetweenMultipleNeighbors | Curve elements which form chains connecting points shared by more than two curve elements are ignored.
DividedSurfaceSplittingCurvesWithMultipleNeighbors | A point cannot coincide with end points of more than two curve elements. All curve elements adjacent to such a point are ignored.
DividedSurfaceZeroLengthSplittingCurve | Curve element with zero length cannot be used as a splitter and ignored.
MeshTopologicalSortFailed | Splitters and grids do not define a consistent rectangular mesh on the face.

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceCannotApplyDivideSettings Property

[image]

Revit 2024 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceCannotApplyDivideSettings Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
Default Divide settings were not applied to Divided Surface. Please adjust grid spacing values manually.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DividedSurfaceCannotApplyDivideSettings { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceCannotApplyDivideSettings As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceCannotApplyDivideSettings {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceCurveChainBelongsToMultipleBeltIntervals Property

[image]

Revit 2024 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceCurveChainBelongsToMultipleBeltIntervals Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
A chain formed by these curve elements defines a splitter belonging to multiple belt intervals and will be ignored

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DividedSurfaceCurveChainBelongsToMultipleBeltIntervals { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceCurveChainBelongsToMultipleBeltIntervals As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceCurveChainBelongsToMultipleBeltIntervals {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceCurveChainDoesNotEngageUorV Property

[image]

Revit 2024 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceCurveChainDoesNotEngageUorV Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
A chain formed by these curve elements does engage any gridlines on the face to be divided and will be ignored

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DividedSurfaceCurveChainDoesNotEngageUorV { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceCurveChainDoesNotEngageUorV As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceCurveChainDoesNotEngageUorV {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceCurveChainGeneralProblem Property

[image]

Revit 2024 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceCurveChainGeneralProblem Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
The chain formed by these curve elements cannot be processed and will be ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DividedSurfaceCurveChainGeneralProblem { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceCurveChainGeneralProblem As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceCurveChainGeneralProblem {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceCurveChainIntersection Property

[image]

Revit 2024 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceCurveChainIntersection Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
A chain formed by these curve elements intersects other chain with the same grid orientation. Both chains will be ignored

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DividedSurfaceCurveChainIntersection { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceCurveChainIntersection As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceCurveChainIntersection {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceCurveChainIsTooClosedToGridlines Property

[image]

Revit 2024 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceCurveChainIsTooClosedToGridlines Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
A chain formed by these curve elements defines a splitter which lies too close to gridlines and will be ignored

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DividedSurfaceCurveChainIsTooClosedToGridlines { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceCurveChainIsTooClosedToGridlines As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceCurveChainIsTooClosedToGridlines {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceCurveChainMultipleSeqIntersWithDivLine Property

[image]

Revit 2024 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceCurveChainMultipleSeqIntersWithDivLine Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
The chain formed by these curve elements has multiple sequential intersections with a gridline and so the chain will be ignored

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DividedSurfaceCurveChainMultipleSeqIntersWithDivLine { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceCurveChainMultipleSeqIntersWithDivLine As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceCurveChainMultipleSeqIntersWithDivLine {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceCurveChainNonSeqIntersWithDivLines Property

[image]

Revit 2024 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceCurveChainNonSeqIntersWithDivLines Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
The chain formed by these curve elements has multiple non-sequential intersections with the same gridline and will be ignored

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DividedSurfaceCurveChainNonSeqIntersWithDivLines { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceCurveChainNonSeqIntersWithDivLines As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceCurveChainNonSeqIntersWithDivLines {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceCurveChainUnsortableBucket Property

[image]

Revit 2024 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceCurveChainUnsortableBucket Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
The chains formed by these curve elements cannot be ordered consistently in the their grid interval and will be ignored

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DividedSurfaceCurveChainUnsortableBucket { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceCurveChainUnsortableBucket As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceCurveChainUnsortableBucket {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceCurveLoopChainIntersectedByExtensions Property

[image]

Revit 2024 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceCurveLoopChainIntersectedByExtensions Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
Curve elements forming a chain which is intersected by extensions of the chain ends cannot be used as splitters and are ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DividedSurfaceCurveLoopChainIntersectedByExtensions { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceCurveLoopChainIntersectedByExtensions As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceCurveLoopChainIntersectedByExtensions {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceCuttingSurfaceDoesNotCutMeshFace Property

[image]

Revit 2024 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceCuttingSurfaceDoesNotCutMeshFace Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
The surface-based splitter does not intersect a face to be divided and will be ignored

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DividedSurfaceCuttingSurfaceDoesNotCutMeshFace { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceCuttingSurfaceDoesNotCutMeshFace As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceCuttingSurfaceDoesNotCutMeshFace {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceCuttingSurfaceGeneralProblem Property

[image]

Revit 2024 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceCuttingSurfaceGeneralProblem Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
Cannot process a surface-based splitter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DividedSurfaceCuttingSurfaceGeneralProblem { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceCuttingSurfaceGeneralProblem As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceCuttingSurfaceGeneralProblem {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceDidNotRegenerateProperly Property

[image]

Revit 2024 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceDidNotRegenerateProperly Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
Divided Surface gridlines could not be generated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DividedSurfaceDidNotRegenerateProperly { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceDidNotRegenerateProperly As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceDidNotRegenerateProperly {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceIgnoresSplitters Property

[image]

Revit 2024 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceIgnoresSplitters Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
Revit cannot create a rectangular grid by intersecting the current selection of elements (levels, reference planes, or curves drawn on reference planes) with the surface. Make sure that curves do not form closed loops. It is helpful if curves start and end outside the surface, rather than inside it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DividedSurfaceIgnoresSplitters { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceIgnoresSplitters As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceIgnoresSplitters {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceLoopsOfSplittingCurves Property

[image]

Revit 2024 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceLoopsOfSplittingCurves Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
Curve elements forming a closed loop currently cannot be used as splitters and are ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DividedSurfaceLoopsOfSplittingCurves { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceLoopsOfSplittingCurves As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceLoopsOfSplittingCurves {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceMultipleIntersBetweenOppositeVirtualGrids Property

[image]

Revit 2024 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceMultipleIntersBetweenOppositeVirtualGrids Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
There are multiple intersections between splitting chain of virtual splitters defined by these elements and so one of the virtual splitters will be ignored

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DividedSurfaceMultipleIntersBetweenOppositeVirtualGrids { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceMultipleIntersBetweenOppositeVirtualGrids As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceMultipleIntersBetweenOppositeVirtualGrids {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceSelfIntersectingCurveLoopChain Property

[image]

Revit 2024 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceSelfIntersectingCurveLoopChain Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
Curve elements forming a self-intersecting chain cannot be used as splitters and are ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DividedSurfaceSelfIntersectingCurveLoopChain { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceSelfIntersectingCurveLoopChain As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceSelfIntersectingCurveLoopChain {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceSingleCurveLoopsAsSplitters Property

[image]

Revit 2024 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceSingleCurveLoopsAsSplitters Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
Curve elements forming a single curve loop cannot be used as splitters and are ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DividedSurfaceSingleCurveLoopsAsSplitters { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceSingleCurveLoopsAsSplitters As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceSingleCurveLoopsAsSplitters {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceSingleCurveMultipleIntersBetweenOppositeVirtualGrids Property

[image]

Revit 2024 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceSingleCurveMultipleIntersBetweenOppositeVirtualGrids Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
There are curves in splitting chain of virtual splitters defined by these elements which intersect each other multiple times and so one of the virtual splitters will be ignored

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DividedSurfaceSingleCurveMultipleIntersBetweenOppositeVirtualGrids { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceSingleCurveMultipleIntersBetweenOppositeVirtualGrids As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceSingleCurveMultipleIntersBetweenOppositeVirtualGrids {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceSplitManagerProblemClosedArcOrEllipse Property

[image]

Revit 2024 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceSplitManagerProblemClosedArcOrEllipse Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
Divided Surface cannot be split by a closed arc or ellipse.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DividedSurfaceSplitManagerProblemClosedArcOrEllipse { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceSplitManagerProblemClosedArcOrEllipse As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceSplitManagerProblemClosedArcOrEllipse {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceSplitRefInvisible Property

[image]

Revit 2024 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceSplitRefInvisible Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
Some of the splitting references of this Divided Surface are invisible in the current view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DividedSurfaceSplitRefInvisible { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceSplitRefInvisible As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceSplitRefInvisible {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceSplittingCurveChainsBetweenMultipleNeighbors Property

[image]

Revit 2024 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceSplittingCurveChainsBetweenMultipleNeighbors Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
Curve elements which form chains connecting points shared by more than two curve elements are ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DividedSurfaceSplittingCurveChainsBetweenMultipleNeighbors { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceSplittingCurveChainsBetweenMultipleNeighbors As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceSplittingCurveChainsBetweenMultipleNeighbors {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceSplittingCurvesWithMultipleNeighbors Property

[image]

Revit 2024 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceSplittingCurvesWithMultipleNeighbors Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
A point cannot coincide with end points of more than two curve elements. All curve elements adjacent to such a point are ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DividedSurfaceSplittingCurvesWithMultipleNeighbors { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceSplittingCurvesWithMultipleNeighbors As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceSplittingCurvesWithMultipleNeighbors {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceZeroLengthSplittingCurve Property

[image]

Revit 2024 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceZeroLengthSplittingCurve Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
Curve element with zero length cannot be used as a splitter and ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DividedSurfaceZeroLengthSplittingCurve { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceZeroLengthSplittingCurve As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceZeroLengthSplittingCurve {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


MeshTopologicalSortFailed Property

[image]

Revit 2024 API
BuiltInFailures..::..DividedSurfaceFailures..::..MeshTopologicalSortFailed Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
Splitters and grids do not define a consistent rectangular mesh on the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MeshTopologicalSortFailed { get; }
Visual Basic
Public Shared ReadOnly Property MeshTopologicalSortFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MeshTopologicalSortFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


BuiltInFailures.DocumentFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..DocumentFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about DocumentFailures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class DocumentFailures
Visual Basic
Public NotInheritable Class DocumentFailures
Visual C++
public ref class DocumentFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..DocumentFailures

See Also

BuiltInFailures..::..DocumentFailures Members


ApiDelayedUpdateFailed Property

[image]

Revit 2024 API
BuiltInFailures..::..DocumentFailures..::..ApiDelayedUpdateFailed Property
BuiltInFailures..::..DocumentFailures Class See Also Send Feedback
Delayed Updating Failed. Please contact the 3rd Party Application vendor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ApiDelayedUpdateFailed { get; }
Visual Basic
Public Shared ReadOnly Property ApiDelayedUpdateFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ApiDelayedUpdateFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DocumentFailures Class


CannotAutoUpdate Property

[image]

Revit 2024 API
BuiltInFailures..::..DocumentFailures..::..CannotAutoUpdate Property
BuiltInFailures..::..DocumentFailures Class See Also Send Feedback
Coordination Monitor can't update element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotAutoUpdate { get; }
Visual Basic
Public Shared ReadOnly Property CannotAutoUpdate As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotAutoUpdate {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DocumentFailures Class


CannotLoadLink Property

[image]

Revit 2024 API
BuiltInFailures..::..DocumentFailures..::..CannotLoadLink Property
BuiltInFailures..::..DocumentFailures Class See Also Send Feedback
Can't load Linked File [Name] due to errors. Open it separately to investigate the problem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotLoadLink { get; }
Visual Basic
Public Shared ReadOnly Property CannotLoadLink As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotLoadLink {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DocumentFailures Class


BuiltInFailures.DPartFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..DPartFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures related to parts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class DPartFailures
Visual Basic
Public NotInheritable Class DPartFailures
Visual C++
public ref class DPartFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..DPartFailures

See Also

BuiltInFailures..::..DPartFailures Members


BuiltInFailures.DPartFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..DPartFailures Members
BuiltInFailures..::..DPartFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..DPartFailures type exposes the following members.

Properties

Name | Description
BindLinkWillDeleteAllPartsWarning | Bind Link will delete its associated Parts.
DeletingDPartWillDeleteAllPartsWarning | Deleting a Part will delete all associated Parts and the original Element will be made visible.
DeletingDPartWillDeleteMorePartsError | Deleting a Part will delete all associated Parts and the original Element will be made visible.
DeletingOriginalWillDeleteParts | Deletion of this element will delete its associated Parts.
DivideVolumesProfilesEdgeMatchForWidthAll | Division family cannot be used with the selected edge condition for all widths of hosts
DivideVolumesProfilesEdgeMatchForWidthSome | Division family cannot be used with the selected edge condition for some widths of hosts
DivideVolumesProfilesForWidthAll | Division family cannot be used for all widths of hosts
DivideVolumesProfilesForWidthSome | Division family cannot be used for some widths of hosts
DivideVolumesProfilesGapForWidthAll | Division family cannot be used with the selected division gap for all widths of hosts
DivideVolumesProfilesGapForWidthSome | Division family cannot be used with the selected division gap for some widths of hosts
DivideVolumesProfilesNonSlabSources | Some sources of a volume divider are non-slab like.
DivideVolumesSketchesWithProfileUnfriendlyCurves | Sketch contains curves to which profiles cannot be applied or chains of curves.
DivisionContainsNoParts | The division contains no parts.
DivisionContainsNoReferences | The division contains no dividing references.
ElementsAlreadyHaveParts | Some elements already have parts
IneligibleElementsForParts | Creating parts from ineligible elements
NoPartMakerCreatedInEditMode | Nothing will be divided.
PartPhaseParametersConflictWithOriginal | The creation and demolition phases of a part must lie between the corresponding phases of the original.
PartsCannotBeCreatedFromInvalidGeom | Post failure when attempts to create parts from invalid geometry.
RemovingInvalidDPartParents | Can't make Parts out of these Elements.
RemovingUndividedDPartParents | These parts are not intersected by any dividing references. They will be removed from the division.
SourceInUnloadedLink | Some elements already have parts

See Also

BuiltInFailures..::..DPartFailures Class


DeletingDPartWillDeleteAllPartsWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..DPartFailures..::..DeletingDPartWillDeleteAllPartsWarning Property
BuiltInFailures..::..DPartFailures Class See Also Send Feedback
Deleting a Part will delete all associated Parts and the original Element will be made visible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DeletingDPartWillDeleteAllPartsWarning { get; }
Visual Basic
Public Shared ReadOnly Property DeletingDPartWillDeleteAllPartsWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DeletingDPartWillDeleteAllPartsWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DPartFailures Class


DeletingDPartWillDeleteMorePartsError Property

[image]

Revit 2024 API
BuiltInFailures..::..DPartFailures..::..DeletingDPartWillDeleteMorePartsError Property
BuiltInFailures..::..DPartFailures Class See Also Send Feedback
Deleting a Part will delete all associated Parts and the original Element will be made visible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DeletingDPartWillDeleteMorePartsError { get; }
Visual Basic
Public Shared ReadOnly Property DeletingDPartWillDeleteMorePartsError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DeletingDPartWillDeleteMorePartsError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DPartFailures Class


DivideVolumesProfilesEdgeMatchForWidthAll Property

[image]

Revit 2024 API
BuiltInFailures..::..DPartFailures..::..DivideVolumesProfilesEdgeMatchForWidthAll Property
BuiltInFailures..::..DPartFailures Class See Also Send Feedback
Division family cannot be used with the selected edge condition for all widths of hosts

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DivideVolumesProfilesEdgeMatchForWidthAll { get; }
Visual Basic
Public Shared ReadOnly Property DivideVolumesProfilesEdgeMatchForWidthAll As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DivideVolumesProfilesEdgeMatchForWidthAll {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DPartFailures Class


DivideVolumesProfilesEdgeMatchForWidthSome Property

[image]

Revit 2024 API
BuiltInFailures..::..DPartFailures..::..DivideVolumesProfilesEdgeMatchForWidthSome Property
BuiltInFailures..::..DPartFailures Class See Also Send Feedback
Division family cannot be used with the selected edge condition for some widths of hosts

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DivideVolumesProfilesEdgeMatchForWidthSome { get; }
Visual Basic
Public Shared ReadOnly Property DivideVolumesProfilesEdgeMatchForWidthSome As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DivideVolumesProfilesEdgeMatchForWidthSome {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DPartFailures Class


DivideVolumesProfilesForWidthAll Property

[image]

Revit 2024 API
BuiltInFailures..::..DPartFailures..::..DivideVolumesProfilesForWidthAll Property
BuiltInFailures..::..DPartFailures Class See Also Send Feedback
Division family cannot be used for all widths of hosts

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DivideVolumesProfilesForWidthAll { get; }
Visual Basic
Public Shared ReadOnly Property DivideVolumesProfilesForWidthAll As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DivideVolumesProfilesForWidthAll {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DPartFailures Class


DivideVolumesProfilesGapForWidthSome Property

[image]

Revit 2024 API
BuiltInFailures..::..DPartFailures..::..DivideVolumesProfilesGapForWidthSome Property
BuiltInFailures..::..DPartFailures Class See Also Send Feedback
Division family cannot be used with the selected division gap for some widths of hosts

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DivideVolumesProfilesGapForWidthSome { get; }
Visual Basic
Public Shared ReadOnly Property DivideVolumesProfilesGapForWidthSome As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DivideVolumesProfilesGapForWidthSome {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DPartFailures Class


DivideVolumesProfilesNonSlabSources Property

[image]

Revit 2024 API
BuiltInFailures..::..DPartFailures..::..DivideVolumesProfilesNonSlabSources Property
BuiltInFailures..::..DPartFailures Class See Also Send Feedback
Some sources of a volume divider are non-slab like.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DivideVolumesProfilesNonSlabSources { get; }
Visual Basic
Public Shared ReadOnly Property DivideVolumesProfilesNonSlabSources As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DivideVolumesProfilesNonSlabSources {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DPartFailures Class


DivideVolumesSketchesWithProfileUnfriendlyCurves Property

[image]

Revit 2024 API
BuiltInFailures..::..DPartFailures..::..DivideVolumesSketchesWithProfileUnfriendlyCurves Property
BuiltInFailures..::..DPartFailures Class See Also Send Feedback
Sketch contains curves to which profiles cannot be applied or chains of curves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DivideVolumesSketchesWithProfileUnfriendlyCurves { get; }
Visual Basic
Public Shared ReadOnly Property DivideVolumesSketchesWithProfileUnfriendlyCurves As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DivideVolumesSketchesWithProfileUnfriendlyCurves {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DPartFailures Class


DivisionContainsNoParts Property

[image]

Revit 2024 API
BuiltInFailures..::..DPartFailures..::..DivisionContainsNoParts Property
BuiltInFailures..::..DPartFailures Class See Also Send Feedback
The division contains no parts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DivisionContainsNoParts { get; }
Visual Basic
Public Shared ReadOnly Property DivisionContainsNoParts As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DivisionContainsNoParts {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DPartFailures Class


ElementsAlreadyHaveParts Property

[image]

Revit 2024 API
BuiltInFailures..::..DPartFailures..::..ElementsAlreadyHaveParts Property
BuiltInFailures..::..DPartFailures Class See Also Send Feedback
Some elements already have parts

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ElementsAlreadyHaveParts { get; }
Visual Basic
Public Shared ReadOnly Property ElementsAlreadyHaveParts As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementsAlreadyHaveParts {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DPartFailures Class


IneligibleElementsForParts Property

[image]

Revit 2024 API
BuiltInFailures..::..DPartFailures..::..IneligibleElementsForParts Property
BuiltInFailures..::..DPartFailures Class See Also Send Feedback
Creating parts from ineligible elements

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId IneligibleElementsForParts { get; }
Visual Basic
Public Shared ReadOnly Property IneligibleElementsForParts As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ IneligibleElementsForParts {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DPartFailures Class


PartsCannotBeCreatedFromInvalidGeom Property

[image]

Revit 2024 API
BuiltInFailures..::..DPartFailures..::..PartsCannotBeCreatedFromInvalidGeom Property
BuiltInFailures..::..DPartFailures Class See Also Send Feedback
Post failure when attempts to create parts from invalid geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId PartsCannotBeCreatedFromInvalidGeom { get; }
Visual Basic
Public Shared ReadOnly Property PartsCannotBeCreatedFromInvalidGeom As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PartsCannotBeCreatedFromInvalidGeom {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DPartFailures Class


RemovingUndividedDPartParents Property

[image]

Revit 2024 API
BuiltInFailures..::..DPartFailures..::..RemovingUndividedDPartParents Property
BuiltInFailures..::..DPartFailures Class See Also Send Feedback
These parts are not intersected by any dividing references. They will be removed from the division.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RemovingUndividedDPartParents { get; }
Visual Basic
Public Shared ReadOnly Property RemovingUndividedDPartParents As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RemovingUndividedDPartParents {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DPartFailures Class


BuiltInFailures.DuctFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..DuctFailures Members
BuiltInFailures..::..DuctFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..DuctFailures type exposes the following members.

Properties

Name | Description
CannotCreateGeometryForDuct | Cannot create geometry for flex duct. The flex duct is intersecting itself or the start and end are too close together.
FlexDuctLengthOutOfLimits | The flex duct length of [Length Value] exceeds the maximum specified length of [Maximum Flex Duct Length Value]
NoDuctFittingsInProject | There are no duct fittings defined in project. The default duct type for fittings will be set to none.
PartNotFoundDueToNoDuctConnectedError | "In order to find a matching part, the fitting has to be connected to a duct."
PartNotFoundDueToNoDuctConnectedWarning | "In order to find a matching part, the fitting has to be connected to a duct."

See Also

BuiltInFailures..::..DuctFailures Class


BuiltInFailures.DuctFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..DuctFailures Properties
BuiltInFailures..::..DuctFailures Class See Also Send Feedback

The BuiltInFailures..::..DuctFailures type exposes the following members.

Properties

Name | Description
CannotCreateGeometryForDuct | Cannot create geometry for flex duct. The flex duct is intersecting itself or the start and end are too close together.
FlexDuctLengthOutOfLimits | The flex duct length of [Length Value] exceeds the maximum specified length of [Maximum Flex Duct Length Value]
NoDuctFittingsInProject | There are no duct fittings defined in project. The default duct type for fittings will be set to none.
PartNotFoundDueToNoDuctConnectedError | "In order to find a matching part, the fitting has to be connected to a duct."
PartNotFoundDueToNoDuctConnectedWarning | "In order to find a matching part, the fitting has to be connected to a duct."

See Also

BuiltInFailures..::..DuctFailures Class


CannotCreateGeometryForDuct Property

[image]

Revit 2024 API
BuiltInFailures..::..DuctFailures..::..CannotCreateGeometryForDuct Property
BuiltInFailures..::..DuctFailures Class See Also Send Feedback
Cannot create geometry for flex duct. The flex duct is intersecting itself or the start and end are too close together.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateGeometryForDuct { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateGeometryForDuct As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateGeometryForDuct {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DuctFailures Class


FlexDuctLengthOutOfLimits Property

[image]

Revit 2024 API
BuiltInFailures..::..DuctFailures..::..FlexDuctLengthOutOfLimits Property
BuiltInFailures..::..DuctFailures Class See Also Send Feedback
The flex duct length of [Length Value] exceeds the maximum specified length of [Maximum Flex Duct Length Value]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FlexDuctLengthOutOfLimits { get; }
Visual Basic
Public Shared ReadOnly Property FlexDuctLengthOutOfLimits As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FlexDuctLengthOutOfLimits {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DuctFailures Class


NoDuctFittingsInProject Property

[image]

Revit 2024 API
BuiltInFailures..::..DuctFailures..::..NoDuctFittingsInProject Property
BuiltInFailures..::..DuctFailures Class See Also Send Feedback
There are no duct fittings defined in project. The default duct type for fittings will be set to none.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoDuctFittingsInProject { get; }
Visual Basic
Public Shared ReadOnly Property NoDuctFittingsInProject As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoDuctFittingsInProject {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DuctFailures Class


PartNotFoundDueToNoDuctConnectedError Property

[image]

Revit 2024 API
BuiltInFailures..::..DuctFailures..::..PartNotFoundDueToNoDuctConnectedError Property
BuiltInFailures..::..DuctFailures Class See Also Send Feedback
"In order to find a matching part, the fitting has to be connected to a duct."

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId PartNotFoundDueToNoDuctConnectedError { get; }
Visual Basic
Public Shared ReadOnly Property PartNotFoundDueToNoDuctConnectedError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PartNotFoundDueToNoDuctConnectedError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DuctFailures Class


BuiltInFailures.EditingFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures related to editing operations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class EditingFailures
Visual Basic
Public NotInheritable Class EditingFailures
Visual C++
public ref class EditingFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..EditingFailures

See Also

BuiltInFailures..::..EditingFailures Members


BuiltInFailures.EditingFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..EditingFailures Members
BuiltInFailures..::..EditingFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..EditingFailures type exposes the following members.

Properties

Name | Description
AllInvisibleInPlanViewWarn | None of the created elements are visible in [View Type] View. You may want to check the active view, its Parameters, and Visibility settings, as well as any Plan Regions and their settings.
AllInvisibleInViewWarn | None of the created elements are visible in [View Type] View. You may want to check the active view, its Parameters, and Visibility settings.
BorrowElementsAtRisk | Can't obtain permission to edit the element: The Central Model is inaccessible. You can check out worksets at risk, but consider carefully!
CannotBorrowBusyContention | Can't obtain permission to edit the element. The Central Model is busy.
CannotCheckoutWorksets | Can't make workset editable. User '[Borrowers]' has already checked it out.
CannotDeleteEditedElement | Can't delete element that is being edited.
CannotDeleteEditedElementError | Can't delete element that is being edited.
CannotDeletePredefinedFamilyElement | Element is a built-in part of the family definition and cannot be deleted or added to groups.
CannotDrawInCurrentView | Can't draw because Work Plane is at a very sharp angle in this view. Go to another view or redefine the Work Plane.
CannotDuplicateType | Cannot Duplicate Type
CannotEditDeletedElements | Can't edit the element. It was deleted in the Central Model.
CannotEditDeletedWorkset | This action has caused deletion of non-editable Workset ' [Name] '.
CannotEditEditingElements | Can't obtain permission to edit the element: The Central Model is inaccessible and another user is editing the element.
CannotEditElements | Workset is editable, but you can't edit the element until '[Borrowers]' resaves the element to central and relinquishes it and you Reload Latest.
CannotEditRenamedWorkset | Can't edit workset ' [Name] '.
CannotMirrorInView | Must specify Work Plane to mirror in a 3d View.
CannotMoveElement | Can't move element.
CannotMoveElementWarn | Can't move element.
CannotMoveElementWithoutWorkplane | Element(s) need a workplane to be moved in. There's no workplane defined in this view.
CannotMoveHereInViewError | Can't move here at this view angle. Set another Work Plane or adjust the view.
CannotMoveInView | Can't move element because the move plane is seen at a very sharp angle in this View
CannotMoveInViewError | Can't move element because the move plane is seen at a very sharp angle in this View
CannotMoveLocked | Can't move pinned element.
CannotMoveTogether | Can't move these elements at the same time. One of them is restricted to moving in one direction while the other is restricted to moving in a conflicting direction.
CannotPickHereInCurrentView | Can't pick here at this view angle. Set another Work Plane or adjust the view.
CannotRotateLocked | Can't rotate pinned element.
CannotScaleInView | Can't scale because Move Plane is at a very sharp angle in this view. Change view angle or go to another view.
DeletedRequestedWarn | You have deleted elements that other users requested.
DeleteElementsError | [Description]
DeleteElementsWarn | [Description]
DeletePreventedByGroup | Grouped elements can only be deleted when the group is being edited. To delete a member select the group and then click the Edit Group button on the toolbar, then delete the member.
ElementNotEditable | One or more elements are not editable.
ElementReversed | Element is reversed.
ElementsDeleted | Elements were deleted.
ElementsDeletedPastedToKeep | Elements were deleted. Use Edit Pasted Elements to keep them.
ElementsNotInPlane | Elements don't lie on the same plane.
ElementsWillBeDeleted | Elements in [Design Option] will be deleted
ExtendToOtherCrash | Can't keep [Type Name] extended to [Type Name].
ExtendToOthersWarn | Can't keep [Type Name] extended to [Type Name].
ExtendToOtherWarn | Can't keep [Type Name] extended to [Type Name].
GeneratedByMassing | Selected element(s) produced from Massing shape. Once deleted, the selected element(s) will not be regenerated
HaveNoPermissionToEdit | You do not have permission to edit the element.
HiddenBeamsEditingWarning | The beam join being modified contains beam that are not visible. Geometry of visible beams may be affected by hidden beams.
InvalidArrayObject | Some or all of the selected objects can't be created in an Array (for example, a Camera object for a 3D View).
InvalidElemsInSelection | Can't scale elements together.
LockedDeleted | Pinned objects deleted.
LockedDeletedWarn | Pinned objects deleted.
MirrorProjectSuccess | [Action] command has successfully processed [Number] elements
NElementsDeleted | [Number] elements were deleted
NElementsWrongPosition | Review [Number] elements for correct position and shape
NoRotateMirrorZ | Element cannot be mirrored or rotated in a manner that changes its angle relative to the ground.
NoRotateMirrorZError | Element cannot be mirrored or rotated in a manner that changes its angle relative to the ground.
OutOfDateElements | Workset is editable, but you must Reload Latest before editing the element.
OwnedByOther | Can't edit the element until '[Partition Name]' resaves the element to central and relinquishes it and you Reload Latest.
OwnElementsOutOfDate | You now own the element, but your file is out of date. You must Reload Latest before editing the element.
PinnedObjectHostDeleted | Some pinned objects were deleted because their parent or host object was deleted.
PinnedObjectNotDeleted | Pinned objects were not deleted. To delete them, unpin them before using delete.
PinnedObjectSomeDeleted | Some pinned objects were deleted while others were not.
PlacementFailed | Failed to place component.
PressShowToSee | Press Show to see the element(s); then Ignore or Cancel
ReloadBeforeMakeEditable | You must Reload Latest before editing the element.
ReloadNoGood | You must Reload Latest before editing the element, but the Central Model is inaccessible or being accessed by another user.
RPCTurnOffInRealisticWarn | None of the placed RPC elements are visible when the visual style is set to Realistic. To see the elements, change VisualStyle of the current view, or change RPC visibility in Graphic Display Options.
SourceInEditMode | Can't transfer project standards while source document is in an edit mode. Please exit all edit modes(In-Place Family Edit Mode, Group Edit Mode, Sketch Edit Mode, etc.) and try again.
TargetInEditMode | Can't transfer project standards while target document is in an edit mode. Please exit all edit modes(In-Place Family Edit Mode, Group Edit Mode, Sketch Edit Mode, etc.) and try again.
TemporaryChangesOutOfDate | You must Reload Latest before editing the element. Changes will be temporary, and will not be saved.
TemporaryChangesTransparentPermissions | Permission to edit the element cannot be obtained. Changes will be temporary, and will not be saved.
TooManyElementsToCheckout | Too many elements were attempted to be marked as editable, prompt user to mark workset(s) editable instead
UnableFilletSpecifiedRadius | Unable to create Fillet with the specified radius.
UnableToMakeSourceWorksetEditable | Unable to make the necessary Workset ([Name]) editable in the Linked File in order to change the Shared Coordinates.
UnableToTransformElement | Attempted an invalid element rotate, mirror, or move.
UnableToTransformElementError | Attempted an invalid element rotate, mirror, or move.
WorksetHasChangedInCentralFile | This workset has changed in the Central Model. Please Reload Latest before making this workset editable.

See Also

BuiltInFailures..::..EditingFailures Class


AllInvisibleInPlanViewWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..AllInvisibleInPlanViewWarn Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
None of the created elements are visible in [View Type] View. You may want to check the active view, its Parameters, and Visibility settings, as well as any Plan Regions and their settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AllInvisibleInPlanViewWarn { get; }
Visual Basic
Public Shared ReadOnly Property AllInvisibleInPlanViewWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AllInvisibleInPlanViewWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


AllInvisibleInViewWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..AllInvisibleInViewWarn Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
None of the created elements are visible in [View Type] View. You may want to check the active view, its Parameters, and Visibility settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AllInvisibleInViewWarn { get; }
Visual Basic
Public Shared ReadOnly Property AllInvisibleInViewWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AllInvisibleInViewWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


BorrowElementsAtRisk Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..BorrowElementsAtRisk Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Can't obtain permission to edit the element: The Central Model is inaccessible. You can check out worksets at risk, but consider carefully!

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId BorrowElementsAtRisk { get; }
Visual Basic
Public Shared ReadOnly Property BorrowElementsAtRisk As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BorrowElementsAtRisk {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


CannotBorrowBusyContention Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..CannotBorrowBusyContention Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Can't obtain permission to edit the element. The Central Model is busy.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotBorrowBusyContention { get; }
Visual Basic
Public Shared ReadOnly Property CannotBorrowBusyContention As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotBorrowBusyContention {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


CannotCheckoutWorksets Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..CannotCheckoutWorksets Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Can't make workset editable. User '[Borrowers]' has already checked it out.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCheckoutWorksets { get; }
Visual Basic
Public Shared ReadOnly Property CannotCheckoutWorksets As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCheckoutWorksets {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


CannotDeleteEditedElement Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..CannotDeleteEditedElement Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Can't delete element that is being edited.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotDeleteEditedElement { get; }
Visual Basic
Public Shared ReadOnly Property CannotDeleteEditedElement As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDeleteEditedElement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


CannotDeleteEditedElementError Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..CannotDeleteEditedElementError Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Can't delete element that is being edited.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotDeleteEditedElementError { get; }
Visual Basic
Public Shared ReadOnly Property CannotDeleteEditedElementError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDeleteEditedElementError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


CannotDeletePredefinedFamilyElement Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..CannotDeletePredefinedFamilyElement Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Element is a built-in part of the family definition and cannot be deleted or added to groups.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotDeletePredefinedFamilyElement { get; }
Visual Basic
Public Shared ReadOnly Property CannotDeletePredefinedFamilyElement As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDeletePredefinedFamilyElement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


CannotDrawInCurrentView Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..CannotDrawInCurrentView Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Can't draw because Work Plane is at a very sharp angle in this view. Go to another view or redefine the Work Plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotDrawInCurrentView { get; }
Visual Basic
Public Shared ReadOnly Property CannotDrawInCurrentView As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDrawInCurrentView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


CannotDuplicateType Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..CannotDuplicateType Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Cannot Duplicate Type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotDuplicateType { get; }
Visual Basic
Public Shared ReadOnly Property CannotDuplicateType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDuplicateType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


CannotEditDeletedElements Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..CannotEditDeletedElements Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Can't edit the element. It was deleted in the Central Model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotEditDeletedElements { get; }
Visual Basic
Public Shared ReadOnly Property CannotEditDeletedElements As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotEditDeletedElements {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


CannotEditEditingElements Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..CannotEditEditingElements Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Can't obtain permission to edit the element: The Central Model is inaccessible and another user is editing the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotEditEditingElements { get; }
Visual Basic
Public Shared ReadOnly Property CannotEditEditingElements As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotEditEditingElements {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


CannotEditElements Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..CannotEditElements Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Workset is editable, but you can't edit the element until '[Borrowers]' resaves the element to central and relinquishes it and you Reload Latest.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotEditElements { get; }
Visual Basic
Public Shared ReadOnly Property CannotEditElements As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotEditElements {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


CannotEditRenamedWorkset Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..CannotEditRenamedWorkset Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Can't edit workset ' [Name] '.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotEditRenamedWorkset { get; }
Visual Basic
Public Shared ReadOnly Property CannotEditRenamedWorkset As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotEditRenamedWorkset {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


CannotMirrorInView Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..CannotMirrorInView Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Must specify Work Plane to mirror in a 3d View.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotMirrorInView { get; }
Visual Basic
Public Shared ReadOnly Property CannotMirrorInView As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMirrorInView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


CannotMoveElement Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..CannotMoveElement Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Can't move element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotMoveElement { get; }
Visual Basic
Public Shared ReadOnly Property CannotMoveElement As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMoveElement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


CannotMoveElementWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..CannotMoveElementWarn Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Can't move element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotMoveElementWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotMoveElementWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMoveElementWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


CannotMoveElementWithoutWorkplane Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..CannotMoveElementWithoutWorkplane Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Element(s) need a workplane to be moved in. There's no workplane defined in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotMoveElementWithoutWorkplane { get; }
Visual Basic
Public Shared ReadOnly Property CannotMoveElementWithoutWorkplane As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMoveElementWithoutWorkplane {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


CannotMoveHereInViewError Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..CannotMoveHereInViewError Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Can't move here at this view angle. Set another Work Plane or adjust the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotMoveHereInViewError { get; }
Visual Basic
Public Shared ReadOnly Property CannotMoveHereInViewError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMoveHereInViewError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


CannotMoveInView Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..CannotMoveInView Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Can't move element because the move plane is seen at a very sharp angle in this View

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotMoveInView { get; }
Visual Basic
Public Shared ReadOnly Property CannotMoveInView As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMoveInView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


CannotMoveInViewError Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..CannotMoveInViewError Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Can't move element because the move plane is seen at a very sharp angle in this View

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotMoveInViewError { get; }
Visual Basic
Public Shared ReadOnly Property CannotMoveInViewError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMoveInViewError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


CannotMoveLocked Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..CannotMoveLocked Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Can't move pinned element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotMoveLocked { get; }
Visual Basic
Public Shared ReadOnly Property CannotMoveLocked As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMoveLocked {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


CannotMoveTogether Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..CannotMoveTogether Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Can't move these elements at the same time. One of them is restricted to moving in one direction while the other is restricted to moving in a conflicting direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotMoveTogether { get; }
Visual Basic
Public Shared ReadOnly Property CannotMoveTogether As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMoveTogether {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


CannotPickHereInCurrentView Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..CannotPickHereInCurrentView Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Can't pick here at this view angle. Set another Work Plane or adjust the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotPickHereInCurrentView { get; }
Visual Basic
Public Shared ReadOnly Property CannotPickHereInCurrentView As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPickHereInCurrentView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


CannotRotateLocked Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..CannotRotateLocked Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Can't rotate pinned element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotRotateLocked { get; }
Visual Basic
Public Shared ReadOnly Property CannotRotateLocked As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotRotateLocked {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


DeletedRequestedWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..DeletedRequestedWarn Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
You have deleted elements that other users requested.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DeletedRequestedWarn { get; }
Visual Basic
Public Shared ReadOnly Property DeletedRequestedWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DeletedRequestedWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


DeleteElementsError Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..DeleteElementsError Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
[Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DeleteElementsError { get; }
Visual Basic
Public Shared ReadOnly Property DeleteElementsError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DeleteElementsError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


DeleteElementsWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..DeleteElementsWarn Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
[Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DeleteElementsWarn { get; }
Visual Basic
Public Shared ReadOnly Property DeleteElementsWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DeleteElementsWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


DeletePreventedByGroup Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..DeletePreventedByGroup Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Grouped elements can only be deleted when the group is being edited. To delete a member select the group and then click the Edit Group button on the toolbar, then delete the member.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DeletePreventedByGroup { get; }
Visual Basic
Public Shared ReadOnly Property DeletePreventedByGroup As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DeletePreventedByGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


ElementNotEditable Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..ElementNotEditable Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
One or more elements are not editable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ElementNotEditable { get; }
Visual Basic
Public Shared ReadOnly Property ElementNotEditable As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementNotEditable {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


ElementsDeleted Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..ElementsDeleted Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Elements were deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ElementsDeleted { get; }
Visual Basic
Public Shared ReadOnly Property ElementsDeleted As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementsDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


ElementsDeletedPastedToKeep Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..ElementsDeletedPastedToKeep Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Elements were deleted. Use Edit Pasted Elements to keep them.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ElementsDeletedPastedToKeep { get; }
Visual Basic
Public Shared ReadOnly Property ElementsDeletedPastedToKeep As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementsDeletedPastedToKeep {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


ElementsNotInPlane Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..ElementsNotInPlane Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Elements don't lie on the same plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ElementsNotInPlane { get; }
Visual Basic
Public Shared ReadOnly Property ElementsNotInPlane As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementsNotInPlane {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


ElementsWillBeDeleted Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..ElementsWillBeDeleted Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Elements in [Design Option] will be deleted

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ElementsWillBeDeleted { get; }
Visual Basic
Public Shared ReadOnly Property ElementsWillBeDeleted As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementsWillBeDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


ExtendToOtherCrash Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..ExtendToOtherCrash Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Can't keep [Type Name] extended to [Type Name].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ExtendToOtherCrash { get; }
Visual Basic
Public Shared ReadOnly Property ExtendToOtherCrash As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ExtendToOtherCrash {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


ExtendToOthersWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..ExtendToOthersWarn Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Can't keep [Type Name] extended to [Type Name].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ExtendToOthersWarn { get; }
Visual Basic
Public Shared ReadOnly Property ExtendToOthersWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ExtendToOthersWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


GeneratedByMassing Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..GeneratedByMassing Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Selected element(s) produced from Massing shape. Once deleted, the selected element(s) will not be regenerated

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId GeneratedByMassing { get; }
Visual Basic
Public Shared ReadOnly Property GeneratedByMassing As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GeneratedByMassing {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


HaveNoPermissionToEdit Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..HaveNoPermissionToEdit Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
You do not have permission to edit the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId HaveNoPermissionToEdit { get; }
Visual Basic
Public Shared ReadOnly Property HaveNoPermissionToEdit As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HaveNoPermissionToEdit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


HiddenBeamsEditingWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..HiddenBeamsEditingWarning Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
The beam join being modified contains beam that are not visible. Geometry of visible beams may be affected by hidden beams.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId HiddenBeamsEditingWarning { get; }
Visual Basic
Public Shared ReadOnly Property HiddenBeamsEditingWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HiddenBeamsEditingWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


InvalidArrayObject Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..InvalidArrayObject Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Some or all of the selected objects can't be created in an Array (for example, a Camera object for a 3D View).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidArrayObject { get; }
Visual Basic
Public Shared ReadOnly Property InvalidArrayObject As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidArrayObject {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


LockedDeleted Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..LockedDeleted Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Pinned objects deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId LockedDeleted { get; }
Visual Basic
Public Shared ReadOnly Property LockedDeleted As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LockedDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


LockedDeletedWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..LockedDeletedWarn Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Pinned objects deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId LockedDeletedWarn { get; }
Visual Basic
Public Shared ReadOnly Property LockedDeletedWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LockedDeletedWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


MirrorProjectSuccess Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..MirrorProjectSuccess Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
[Action] command has successfully processed [Number] elements

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MirrorProjectSuccess { get; }
Visual Basic
Public Shared ReadOnly Property MirrorProjectSuccess As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MirrorProjectSuccess {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


NElementsDeleted Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..NElementsDeleted Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
[Number] elements were deleted

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NElementsDeleted { get; }
Visual Basic
Public Shared ReadOnly Property NElementsDeleted As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NElementsDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


NoRotateMirrorZ Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..NoRotateMirrorZ Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Element cannot be mirrored or rotated in a manner that changes its angle relative to the ground.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoRotateMirrorZ { get; }
Visual Basic
Public Shared ReadOnly Property NoRotateMirrorZ As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoRotateMirrorZ {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


NoRotateMirrorZError Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..NoRotateMirrorZError Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Element cannot be mirrored or rotated in a manner that changes its angle relative to the ground.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoRotateMirrorZError { get; }
Visual Basic
Public Shared ReadOnly Property NoRotateMirrorZError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoRotateMirrorZError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


OutOfDateElements Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..OutOfDateElements Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Workset is editable, but you must Reload Latest before editing the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId OutOfDateElements { get; }
Visual Basic
Public Shared ReadOnly Property OutOfDateElements As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OutOfDateElements {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


PinnedObjectHostDeleted Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..PinnedObjectHostDeleted Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Some pinned objects were deleted because their parent or host object was deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId PinnedObjectHostDeleted { get; }
Visual Basic
Public Shared ReadOnly Property PinnedObjectHostDeleted As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PinnedObjectHostDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


PinnedObjectNotDeleted Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..PinnedObjectNotDeleted Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Pinned objects were not deleted. To delete them, unpin them before using delete.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId PinnedObjectNotDeleted { get; }
Visual Basic
Public Shared ReadOnly Property PinnedObjectNotDeleted As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PinnedObjectNotDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


PinnedObjectSomeDeleted Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..PinnedObjectSomeDeleted Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Some pinned objects were deleted while others were not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId PinnedObjectSomeDeleted { get; }
Visual Basic
Public Shared ReadOnly Property PinnedObjectSomeDeleted As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PinnedObjectSomeDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


PressShowToSee Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..PressShowToSee Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Press Show to see the element(s); then Ignore or Cancel

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId PressShowToSee { get; }
Visual Basic
Public Shared ReadOnly Property PressShowToSee As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PressShowToSee {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


ReloadBeforeMakeEditable Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..ReloadBeforeMakeEditable Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
You must Reload Latest before editing the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ReloadBeforeMakeEditable { get; }
Visual Basic
Public Shared ReadOnly Property ReloadBeforeMakeEditable As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ReloadBeforeMakeEditable {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


ReloadNoGood Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..ReloadNoGood Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
You must Reload Latest before editing the element, but the Central Model is inaccessible or being accessed by another user.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ReloadNoGood { get; }
Visual Basic
Public Shared ReadOnly Property ReloadNoGood As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ReloadNoGood {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


RPCTurnOffInRealisticWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..RPCTurnOffInRealisticWarn Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
None of the placed RPC elements are visible when the visual style is set to Realistic. To see the elements, change VisualStyle of the current view, or change RPC visibility in Graphic Display Options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RPCTurnOffInRealisticWarn { get; }
Visual Basic
Public Shared ReadOnly Property RPCTurnOffInRealisticWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RPCTurnOffInRealisticWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


SourceInEditMode Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..SourceInEditMode Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Can't transfer project standards while source document is in an edit mode. Please exit all edit modes(In-Place Family Edit Mode, Group Edit Mode, Sketch Edit Mode, etc.) and try again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SourceInEditMode { get; }
Visual Basic
Public Shared ReadOnly Property SourceInEditMode As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SourceInEditMode {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


TargetInEditMode Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..TargetInEditMode Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Can't transfer project standards while target document is in an edit mode. Please exit all edit modes(In-Place Family Edit Mode, Group Edit Mode, Sketch Edit Mode, etc.) and try again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId TargetInEditMode { get; }
Visual Basic
Public Shared ReadOnly Property TargetInEditMode As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TargetInEditMode {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


TemporaryChangesTransparentPermissions Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..TemporaryChangesTransparentPermissions Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Permission to edit the element cannot be obtained. Changes will be temporary, and will not be saved.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId TemporaryChangesTransparentPermissions { get; }
Visual Basic
Public Shared ReadOnly Property TemporaryChangesTransparentPermissions As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TemporaryChangesTransparentPermissions {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


TooManyElementsToCheckout Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..TooManyElementsToCheckout Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Too many elements were attempted to be marked as editable, prompt user to mark workset(s) editable instead

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId TooManyElementsToCheckout { get; }
Visual Basic
Public Shared ReadOnly Property TooManyElementsToCheckout As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TooManyElementsToCheckout {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


UnableFilletSpecifiedRadius Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..UnableFilletSpecifiedRadius Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Unable to create Fillet with the specified radius.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UnableFilletSpecifiedRadius { get; }
Visual Basic
Public Shared ReadOnly Property UnableFilletSpecifiedRadius As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableFilletSpecifiedRadius {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


UnableToMakeSourceWorksetEditable Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..UnableToMakeSourceWorksetEditable Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Unable to make the necessary Workset ([Name]) editable in the Linked File in order to change the Shared Coordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UnableToMakeSourceWorksetEditable { get; }
Visual Basic
Public Shared ReadOnly Property UnableToMakeSourceWorksetEditable As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableToMakeSourceWorksetEditable {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


UnableToTransformElement Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..UnableToTransformElement Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Attempted an invalid element rotate, mirror, or move.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UnableToTransformElement { get; }
Visual Basic
Public Shared ReadOnly Property UnableToTransformElement As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableToTransformElement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


UnableToTransformElementError Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..UnableToTransformElementError Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Attempted an invalid element rotate, mirror, or move.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UnableToTransformElementError { get; }
Visual Basic
Public Shared ReadOnly Property UnableToTransformElementError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableToTransformElementError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


WorksetHasChangedInCentralFile Property

[image]

Revit 2024 API
BuiltInFailures..::..EditingFailures..::..WorksetHasChangedInCentralFile Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
This workset has changed in the Central Model. Please Reload Latest before making this workset editable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WorksetHasChangedInCentralFile { get; }
Visual Basic
Public Shared ReadOnly Property WorksetHasChangedInCentralFile As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WorksetHasChangedInCentralFile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


BuiltInFailures.ElectricalFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..ElectricalFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Electricity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class ElectricalFailures
Visual Basic
Public NotInheritable Class ElectricalFailures
Visual C++
public ref class ElectricalFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..ElectricalFailures

See Also

BuiltInFailures..::..ElectricalFailures Members


BuiltInFailures.ElectricalFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..ElectricalFailures Properties
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback

The BuiltInFailures..::..ElectricalFailures type exposes the following members.

Properties

Name | Description
AllSlotsOnPanelOccupied | All slots on panel: [Panel Name] are occupied. Some circuits will be disconnected from this panel.
BankDistanceSmallerThanDiameter | The distance value is smaller than the conduit diameter, please enter a larger value
CableTrayModified | The cable tray has been modified to be in the opposite direction or insufficient space to create the required fittings.
CannotAddMorePolesToCircuit | Empty slots are unavailable to hold the number of poles you specified for this spare. \nTo add more poles to this spare, you must free up slots by moving the circuits below the spare.
CannotAssignSecondaryDistSysToCircuit | Cannot assign or add [Element] to Circuit. There is no assigned secondary distribution system for [Element].
CannotConnectDifferentDesignOptsObjects | Cannot add or assign [Element] to circuit. Electrical objects belonging to different design options cannot be connected.
CannotCreatePanelScheduleDuetoNoDefaultTemplate | A panel schedule cannot be created for these panels. A default panel schedule template must be assigned for this template type.
CannotRemoveMembersInCircuitHavingParent | You have selected elements that are connected to a Panel object in a Circuit. These elements cannot be removed from the Circuit.
CircuitOverload | Total connected load for Circuit [Name] is exceeding 80% of the defined rating ([Rating Value]).
CircuitsOverlapAndDeleteSpareSpace | More than one Spare/Space falls onto the same slot. These Spares/Spaces will be deleted.
CircuitsOverlapDisconnectCircuits | More than one circuit falls onto the same slot. These circuits will be disconnected.
ConduitModified | The conduit has been modified to be in the opposite direction or insufficient space to create the required fittings.
ElementsBelongToOtherCircuit | You have selected elements that are already part of other Circuits that have assigned Panels. The elements you selected cannot be added to this Circuit.
FamilyMismatchCircuit | The family no longer matches the properties for the Circuit. Disconnect the family from the Circuit?
FeedThroughLugsIsDisabled | The feed through lugs option is unchecked.
FeedThroughLugsIsNotEnabledAndBindFormulaInFamily | Can't change connection type to Feed Through Lugs because Feed Through Lugs is unchecked. Enable Feed Through Lugs with related formula in family editor the Feed Through Lugs is mapped to. Select the panel -> Edit Family -> Family Types.
FeedThroughLugsIsNotEnabledAndBindGlobalParam | Can't change connection type to Feed Through Lugs because Feed Through Lugs is not enabled. Enable Feed Through Lugs by enabling the global parameter that Feed Through Lugs is mapping. Click Manage tab -> Settings panel -> Global Parameters.
FeedThroughLugsIsOccupied | The feed through lugs is in use by circuit [Element].
FeedThroughLugsIsOccupiedAndDisconnectOtherCircuits | The feed through lugs is occupied, so other circuits connected with feed through lugs will be disconnected from this panel [Panel Name].
InvalidApparentPowerDensity | The Apparent Power Density is invalid. Edit the Power Density and/or Power Factor to recalculate the Apparent Power Density.
InvalidNumberOfCircuitValueForSwitchPanel | The number of circuits on the switchboard currently exceeds the value you entered. Reduce the number of circuits on the equipment before changing this value.
InvalidNumwiresSinglephase | Invalid number of wires for single phase, only 2 and 3 are valid.
InvalidPathOfParallelConduits | Invalid path of parallel conduits
InvalidSpareSpace | The number of poles for a spare/space in a single phase, [wire] wires panel cannot exceed [value].
MaximumNumberOfPolesExceeded | You cannot add more poles to this spare, as doing so would exceed the maximum number of poles set for this equipment.
MismatchConnectorDistSysToCircuit | Cannot add [Element] to Circuit. The Type for the available connector does not match the Type ([Name]) for the Circuit.
MismatchNmbAssignedDistSysToCircuit | Cannot assign or add [Element] to Circuit. There is no assigned distribution system for [Element].
MismatchNmbOfPolesToCircuit | Cannot add [Element] to Circuit. The Number of Poles for [Element] does not match the Number of Poles ([Name]) for the Circuit.
MismatchPoleBrakesSlotsNumbers | The number of pole breakers may not be less than the number of occupied slots.
MismatchVoltageLineToLine | Cannot assign or add [Element] to Circuit. The Voltage ([Voltage Value]) for the Circuit is out of range for the Line to Line Voltage for [Element] (The Line to Line Voltage is specified in the assigned Distribution System).
MismatchVoltageToCircuit | Cannot add [Element] to Circuit. The Voltage for [Element] is out of range for the Voltage ([Voltage Value]) for the Circuit.
MissingOrInvalidWireSizeTable | Wire Size Table "[Fail Name]" is missing or invalid. Use Electrical Settings to select a valid Wire Size Table.
NoAvailableMatchingConnector | Cannot add [Element] to Circuit. There is no available connector matching the Type ([Type Name]) for the Circuit.
NotAllowedCableTrayConduitRotation | Don't allow to rotate a horizontal cable tray/conduit like this
NotEnoughAvailSlotsAndLugsOnPanel | You can't connect to panel [Panel Name] because there aren't enough slots and Feed Through Lugs is occupied. \nYou can increase the [ParameterName] to be greater than [Number] to connect through breaker slots or you can disconnect existing Feed Through Lugs connection.
NotEnoughAvailSlotsAndLugsOnSwitchPanel | You can't connect to switchboard [Panel Name] because there aren't enough space and circuit [Circuit Name] is set to Feed Through Lugs. \nYou can increase the number of circuits to be greater than [Number] to connect through breakers or you can disconnect circuit and select Feed Through Lugs again.
NotEnoughAvailSlotsOnPanel | You can't change the connection type to Breakers connect to panel [Panel Name] because there aren't enough slots. \nYou can increase the [ParameterName] to be greater than [Number] to connect through breaker slots or open the panel schedule and manually reshuffle non - consecutive slots.
NotEnoughRoomForParallelConduits | Due to changes in elevation, there is not enough room to generate all of the parallel conduits. As a result, some conduit segments have not been generated.
NotEnoughRoomForParallelPipes | Due to changes in elevation, there is not enough room to generate all of the parallel pipes. As a result, some pipe segments have not been generated.
NotEnoughSlotsOnlyLugAvailable | There aren't enough slots on panel [Panel Name], so the circuit will connect through Feed Through Lugs.
NotEnoughSlotsOnlyLugAvailableForSwitchPanel | There aren't enough space on switchboard [Panel Name], so the circuit will connect through Feed Through Lugs.
NotPositiveBendRadius | The value you entered for the bend radius is zero or a negative value. Enter a positive value.
NotSupportConcentricBend | Conduit with Fittings do not support Concentric Bend Radius, the bend radius of the conduit fittings will be same.
NumberOfCircuitFullOnSwitchPanel | You can't change the connection type to Breakers and connect to switchboard [Panel Name] because there aren't enough space. \nYou can increase the number of circuits to be greater than [Number] to connect through breakers.
ObjsDemolished | Cannot assign [Element] to circuit. Objects that are demolished cannot be added to a circuit.
PanelMismatchCircuitType | Cannot assign [Element] to Circuit. The Type for the panel does not match the Type ([Name]) for the Circuit.
PanelMismatchDistSysWhenCircuitAssigned | The selected circuit was added to panel [Element], but the distribution system for the panel does not match the power connector definition on the panel.
ReplaceSpareSpaceOnPanelBoard | Need to replace spare or space on panelboard.
ReplaceSpareSpaceOnSwitchBoard | Need to replace spare or space on switchboard.
SelectedElementsArePartOfOtherCircuit | You have selected elements that are already part of other Circuits. They will be removed from the original Circuits and added to this one.
SmallBendRadius | The value you entered for the bend radius for conduit is too small. Enter a larger value.
UnsignedCircuit | Circuit is not assigned to a panel
VoltageIsOutOfRange | Cannot assign or add [Element] to Circuit. The Voltage ([Voltage Value]) for the Circuit is out of range for the Line to Ground Voltage for [Element] (The Line to Ground Voltage is specified in the assigned Distribution System)."
WireMaxSizeNonexistent | Cannot find max size in current wire type's material table.

See Also

BuiltInFailures..::..ElectricalFailures Class


AllSlotsOnPanelOccupied Property

[image]

Revit 2024 API
BuiltInFailures..::..ElectricalFailures..::..AllSlotsOnPanelOccupied Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
All slots on panel: [Panel Name] are occupied. Some circuits will be disconnected from this panel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AllSlotsOnPanelOccupied { get; }
Visual Basic
Public Shared ReadOnly Property AllSlotsOnPanelOccupied As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AllSlotsOnPanelOccupied {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


BankDistanceSmallerThanDiameter Property

[image]

Revit 2024 API
BuiltInFailures..::..ElectricalFailures..::..BankDistanceSmallerThanDiameter Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
The distance value is smaller than the conduit diameter, please enter a larger value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId BankDistanceSmallerThanDiameter { get; }
Visual Basic
Public Shared ReadOnly Property BankDistanceSmallerThanDiameter As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BankDistanceSmallerThanDiameter {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


CannotAddMorePolesToCircuit Property

[image]

Revit 2024 API
BuiltInFailures..::..ElectricalFailures..::..CannotAddMorePolesToCircuit Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
Empty slots are unavailable to hold the number of poles you specified for this spare. \nTo add more poles to this spare, you must free up slots by moving the circuits below the spare.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotAddMorePolesToCircuit { get; }
Visual Basic
Public Shared ReadOnly Property CannotAddMorePolesToCircuit As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotAddMorePolesToCircuit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


CannotAssignSecondaryDistSysToCircuit Property

[image]

Revit 2024 API
BuiltInFailures..::..ElectricalFailures..::..CannotAssignSecondaryDistSysToCircuit Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
Cannot assign or add [Element] to Circuit. There is no assigned secondary distribution system for [Element].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotAssignSecondaryDistSysToCircuit { get; }
Visual Basic
Public Shared ReadOnly Property CannotAssignSecondaryDistSysToCircuit As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotAssignSecondaryDistSysToCircuit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


CannotConnectDifferentDesignOptsObjects Property

[image]

Revit 2024 API
BuiltInFailures..::..ElectricalFailures..::..CannotConnectDifferentDesignOptsObjects Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
Cannot add or assign [Element] to circuit. Electrical objects belonging to different design options cannot be connected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotConnectDifferentDesignOptsObjects { get; }
Visual Basic
Public Shared ReadOnly Property CannotConnectDifferentDesignOptsObjects As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotConnectDifferentDesignOptsObjects {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


CannotCreatePanelScheduleDuetoNoDefaultTemplate Property

[image]

Revit 2024 API
BuiltInFailures..::..ElectricalFailures..::..CannotCreatePanelScheduleDuetoNoDefaultTemplate Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
A panel schedule cannot be created for these panels. A default panel schedule template must be assigned for this template type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreatePanelScheduleDuetoNoDefaultTemplate { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreatePanelScheduleDuetoNoDefaultTemplate As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreatePanelScheduleDuetoNoDefaultTemplate {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


CannotRemoveMembersInCircuitHavingParent Property

[image]

Revit 2024 API
BuiltInFailures..::..ElectricalFailures..::..CannotRemoveMembersInCircuitHavingParent Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
You have selected elements that are connected to a Panel object in a Circuit. These elements cannot be removed from the Circuit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotRemoveMembersInCircuitHavingParent { get; }
Visual Basic
Public Shared ReadOnly Property CannotRemoveMembersInCircuitHavingParent As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotRemoveMembersInCircuitHavingParent {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


CircuitOverload Property

[image]

Revit 2024 API
BuiltInFailures..::..ElectricalFailures..::..CircuitOverload Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
Total connected load for Circuit [Name] is exceeding 80% of the defined rating ([Rating Value]).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CircuitOverload { get; }
Visual Basic
Public Shared ReadOnly Property CircuitOverload As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CircuitOverload {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


CircuitsOverlapAndDeleteSpareSpace Property

[image]

Revit 2024 API
BuiltInFailures..::..ElectricalFailures..::..CircuitsOverlapAndDeleteSpareSpace Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
More than one Spare/Space falls onto the same slot. These Spares/Spaces will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CircuitsOverlapAndDeleteSpareSpace { get; }
Visual Basic
Public Shared ReadOnly Property CircuitsOverlapAndDeleteSpareSpace As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CircuitsOverlapAndDeleteSpareSpace {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


ConduitModified Property

[image]

Revit 2024 API
BuiltInFailures..::..ElectricalFailures..::..ConduitModified Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
The conduit has been modified to be in the opposite direction or insufficient space to create the required fittings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ConduitModified { get; }
Visual Basic
Public Shared ReadOnly Property ConduitModified As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ConduitModified {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


FamilyMismatchCircuit Property

[image]

Revit 2024 API
BuiltInFailures..::..ElectricalFailures..::..FamilyMismatchCircuit Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
The family no longer matches the properties for the Circuit. Disconnect the family from the Circuit?

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FamilyMismatchCircuit { get; }
Visual Basic
Public Shared ReadOnly Property FamilyMismatchCircuit As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FamilyMismatchCircuit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


FeedThroughLugsIsDisabled Property

[image]

Revit 2024 API
BuiltInFailures..::..ElectricalFailures..::..FeedThroughLugsIsDisabled Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
The feed through lugs option is unchecked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FeedThroughLugsIsDisabled { get; }
Visual Basic
Public Shared ReadOnly Property FeedThroughLugsIsDisabled As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FeedThroughLugsIsDisabled {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


FeedThroughLugsIsNotEnabledAndBindFormulaInFamily Property

[image]

Revit 2024 API
BuiltInFailures..::..ElectricalFailures..::..FeedThroughLugsIsNotEnabledAndBindFormulaInFamily Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
Can't change connection type to Feed Through Lugs because Feed Through Lugs is unchecked. Enable Feed Through Lugs with related formula in family editor the Feed Through Lugs is mapped to. Select the panel -> Edit Family -> Family Types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FeedThroughLugsIsNotEnabledAndBindFormulaInFamily { get; }
Visual Basic
Public Shared ReadOnly Property FeedThroughLugsIsNotEnabledAndBindFormulaInFamily As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FeedThroughLugsIsNotEnabledAndBindFormulaInFamily {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


FeedThroughLugsIsNotEnabledAndBindGlobalParam Property

[image]

Revit 2024 API
BuiltInFailures..::..ElectricalFailures..::..FeedThroughLugsIsNotEnabledAndBindGlobalParam Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
Can't change connection type to Feed Through Lugs because Feed Through Lugs is not enabled. Enable Feed Through Lugs by enabling the global parameter that Feed Through Lugs is mapping. Click Manage tab -> Settings panel -> Global Parameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FeedThroughLugsIsNotEnabledAndBindGlobalParam { get; }
Visual Basic
Public Shared ReadOnly Property FeedThroughLugsIsNotEnabledAndBindGlobalParam As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FeedThroughLugsIsNotEnabledAndBindGlobalParam {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


FeedThroughLugsIsOccupied Property

[image]

Revit 2024 API
BuiltInFailures..::..ElectricalFailures..::..FeedThroughLugsIsOccupied Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
The feed through lugs is in use by circuit [Element].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FeedThroughLugsIsOccupied { get; }
Visual Basic
Public Shared ReadOnly Property FeedThroughLugsIsOccupied As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FeedThroughLugsIsOccupied {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


FeedThroughLugsIsOccupiedAndDisconnectOtherCircuits Property

[image]

Revit 2024 API
BuiltInFailures..::..ElectricalFailures..::..FeedThroughLugsIsOccupiedAndDisconnectOtherCircuits Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
The feed through lugs is occupied, so other circuits connected with feed through lugs will be disconnected from this panel [Panel Name].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FeedThroughLugsIsOccupiedAndDisconnectOtherCircuits { get; }
Visual Basic
Public Shared ReadOnly Property FeedThroughLugsIsOccupiedAndDisconnectOtherCircuits As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FeedThroughLugsIsOccupiedAndDisconnectOtherCircuits {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


InvalidApparentPowerDensity Property

[image]

Revit 2024 API
BuiltInFailures..::..ElectricalFailures..::..InvalidApparentPowerDensity Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
The Apparent Power Density is invalid. Edit the Power Density and/or Power Factor to recalculate the Apparent Power Density.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidApparentPowerDensity { get; }
Visual Basic
Public Shared ReadOnly Property InvalidApparentPowerDensity As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidApparentPowerDensity {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


InvalidNumberOfCircuitValueForSwitchPanel Property

[image]

Revit 2024 API
BuiltInFailures..::..ElectricalFailures..::..InvalidNumberOfCircuitValueForSwitchPanel Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
The number of circuits on the switchboard currently exceeds the value you entered. Reduce the number of circuits on the equipment before changing this value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidNumberOfCircuitValueForSwitchPanel { get; }
Visual Basic
Public Shared ReadOnly Property InvalidNumberOfCircuitValueForSwitchPanel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidNumberOfCircuitValueForSwitchPanel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


InvalidPathOfParallelConduits Property

[image]

Revit 2024 API
BuiltInFailures..::..ElectricalFailures..::..InvalidPathOfParallelConduits Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
Invalid path of parallel conduits

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidPathOfParallelConduits { get; }
Visual Basic
Public Shared ReadOnly Property InvalidPathOfParallelConduits As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidPathOfParallelConduits {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


InvalidSpareSpace Property

[image]

Revit 2024 API
BuiltInFailures..::..ElectricalFailures..::..InvalidSpareSpace Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
The number of poles for a spare/space in a single phase, [wire] wires panel cannot exceed [value].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidSpareSpace { get; }
Visual Basic
Public Shared ReadOnly Property InvalidSpareSpace As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidSpareSpace {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


MaximumNumberOfPolesExceeded Property

[image]

Revit 2024 API
BuiltInFailures..::..ElectricalFailures..::..MaximumNumberOfPolesExceeded Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
You cannot add more poles to this spare, as doing so would exceed the maximum number of poles set for this equipment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MaximumNumberOfPolesExceeded { get; }
Visual Basic
Public Shared ReadOnly Property MaximumNumberOfPolesExceeded As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MaximumNumberOfPolesExceeded {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


MismatchConnectorDistSysToCircuit Property

[image]

Revit 2024 API
BuiltInFailures..::..ElectricalFailures..::..MismatchConnectorDistSysToCircuit Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
Cannot add [Element] to Circuit. The Type for the available connector does not match the Type ([Name]) for the Circuit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MismatchConnectorDistSysToCircuit { get; }
Visual Basic
Public Shared ReadOnly Property MismatchConnectorDistSysToCircuit As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MismatchConnectorDistSysToCircuit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


MismatchNmbAssignedDistSysToCircuit Property

[image]

Revit 2024 API
BuiltInFailures..::..ElectricalFailures..::..MismatchNmbAssignedDistSysToCircuit Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
Cannot assign or add [Element] to Circuit. There is no assigned distribution system for [Element].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MismatchNmbAssignedDistSysToCircuit { get; }
Visual Basic
Public Shared ReadOnly Property MismatchNmbAssignedDistSysToCircuit As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MismatchNmbAssignedDistSysToCircuit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


MismatchNmbOfPolesToCircuit Property

[image]

Revit 2024 API
BuiltInFailures..::..ElectricalFailures..::..MismatchNmbOfPolesToCircuit Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
Cannot add [Element] to Circuit. The Number of Poles for [Element] does not match the Number of Poles ([Name]) for the Circuit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MismatchNmbOfPolesToCircuit { get; }
Visual Basic
Public Shared ReadOnly Property MismatchNmbOfPolesToCircuit As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MismatchNmbOfPolesToCircuit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


MismatchPoleBrakesSlotsNumbers Property

[image]

Revit 2024 API
BuiltInFailures..::..ElectricalFailures..::..MismatchPoleBrakesSlotsNumbers Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
The number of pole breakers may not be less than the number of occupied slots.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MismatchPoleBrakesSlotsNumbers { get; }
Visual Basic
Public Shared ReadOnly Property MismatchPoleBrakesSlotsNumbers As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MismatchPoleBrakesSlotsNumbers {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


MismatchVoltageLineToLine Property

[image]

Revit 2024 API
BuiltInFailures..::..ElectricalFailures..::..MismatchVoltageLineToLine Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
Cannot assign or add [Element] to Circuit. The Voltage ([Voltage Value]) for the Circuit is out of range for the Line to Line Voltage for [Element] (The Line to Line Voltage is specified in the assigned Distribution System).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MismatchVoltageLineToLine { get; }
Visual Basic
Public Shared ReadOnly Property MismatchVoltageLineToLine As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MismatchVoltageLineToLine {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


MissingOrInvalidWireSizeTable Property

[image]

Revit 2024 API
BuiltInFailures..::..ElectricalFailures..::..MissingOrInvalidWireSizeTable Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
Wire Size Table "[Fail Name]" is missing or invalid. Use Electrical Settings to select a valid Wire Size Table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MissingOrInvalidWireSizeTable { get; }
Visual Basic
Public Shared ReadOnly Property MissingOrInvalidWireSizeTable As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MissingOrInvalidWireSizeTable {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


NoAvailableMatchingConnector Property

[image]

Revit 2024 API
BuiltInFailures..::..ElectricalFailures..::..NoAvailableMatchingConnector Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
Cannot add [Element] to Circuit. There is no available connector matching the Type ([Type Name]) for the Circuit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoAvailableMatchingConnector { get; }
Visual Basic
Public Shared ReadOnly Property NoAvailableMatchingConnector As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoAvailableMatchingConnector {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


NotAllowedCableTrayConduitRotation Property

[image]

Revit 2024 API
BuiltInFailures..::..ElectricalFailures..::..NotAllowedCableTrayConduitRotation Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
Don't allow to rotate a horizontal cable tray/conduit like this

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NotAllowedCableTrayConduitRotation { get; }
Visual Basic
Public Shared ReadOnly Property NotAllowedCableTrayConduitRotation As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotAllowedCableTrayConduitRotation {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


NotEnoughAvailSlotsAndLugsOnPanel Property

[image]

Revit 2024 API
BuiltInFailures..::..ElectricalFailures..::..NotEnoughAvailSlotsAndLugsOnPanel Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
You can't connect to panel [Panel Name] because there aren't enough slots and Feed Through Lugs is occupied. \nYou can increase the [ParameterName] to be greater than [Number] to connect through breaker slots or you can disconnect existing Feed Through Lugs connection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NotEnoughAvailSlotsAndLugsOnPanel { get; }
Visual Basic
Public Shared ReadOnly Property NotEnoughAvailSlotsAndLugsOnPanel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotEnoughAvailSlotsAndLugsOnPanel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


NotEnoughAvailSlotsAndLugsOnSwitchPanel Property

[image]

Revit 2024 API
BuiltInFailures..::..ElectricalFailures..::..NotEnoughAvailSlotsAndLugsOnSwitchPanel Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
You can't connect to switchboard [Panel Name] because there aren't enough space and circuit [Circuit Name] is set to Feed Through Lugs. \nYou can increase the number of circuits to be greater than [Number] to connect through breakers or you can disconnect circuit and select Feed Through Lugs again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NotEnoughAvailSlotsAndLugsOnSwitchPanel { get; }
Visual Basic
Public Shared ReadOnly Property NotEnoughAvailSlotsAndLugsOnSwitchPanel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotEnoughAvailSlotsAndLugsOnSwitchPanel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


NotEnoughAvailSlotsOnPanel Property

[image]

Revit 2024 API
BuiltInFailures..::..ElectricalFailures..::..NotEnoughAvailSlotsOnPanel Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
You can't change the connection type to Breakers connect to panel [Panel Name] because there aren't enough slots. \nYou can increase the [ParameterName] to be greater than [Number] to connect through breaker slots or open the panel schedule and manually reshuffle non - consecutive slots.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NotEnoughAvailSlotsOnPanel { get; }
Visual Basic
Public Shared ReadOnly Property NotEnoughAvailSlotsOnPanel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotEnoughAvailSlotsOnPanel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


NotEnoughRoomForParallelConduits Property

[image]

Revit 2024 API
BuiltInFailures..::..ElectricalFailures..::..NotEnoughRoomForParallelConduits Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
Due to changes in elevation, there is not enough room to generate all of the parallel conduits. As a result, some conduit segments have not been generated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NotEnoughRoomForParallelConduits { get; }
Visual Basic
Public Shared ReadOnly Property NotEnoughRoomForParallelConduits As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotEnoughRoomForParallelConduits {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


NotEnoughSlotsOnlyLugAvailableForSwitchPanel Property

[image]

Revit 2024 API
BuiltInFailures..::..ElectricalFailures..::..NotEnoughSlotsOnlyLugAvailableForSwitchPanel Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
There aren't enough space on switchboard [Panel Name], so the circuit will connect through Feed Through Lugs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NotEnoughSlotsOnlyLugAvailableForSwitchPanel { get; }
Visual Basic
Public Shared ReadOnly Property NotEnoughSlotsOnlyLugAvailableForSwitchPanel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotEnoughSlotsOnlyLugAvailableForSwitchPanel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


NotPositiveBendRadius Property

[image]

Revit 2024 API
BuiltInFailures..::..ElectricalFailures..::..NotPositiveBendRadius Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
The value you entered for the bend radius is zero or a negative value. Enter a positive value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NotPositiveBendRadius { get; }
Visual Basic
Public Shared ReadOnly Property NotPositiveBendRadius As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotPositiveBendRadius {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


NotSupportConcentricBend Property

[image]

Revit 2024 API
BuiltInFailures..::..ElectricalFailures..::..NotSupportConcentricBend Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
Conduit with Fittings do not support Concentric Bend Radius, the bend radius of the conduit fittings will be same.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NotSupportConcentricBend { get; }
Visual Basic
Public Shared ReadOnly Property NotSupportConcentricBend As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotSupportConcentricBend {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


ObjsDemolished Property

[image]

Revit 2024 API
BuiltInFailures..::..ElectricalFailures..::..ObjsDemolished Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
Cannot assign [Element] to circuit. Objects that are demolished cannot be added to a circuit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ObjsDemolished { get; }
Visual Basic
Public Shared ReadOnly Property ObjsDemolished As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ObjsDemolished {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


PanelMismatchCircuitType Property

[image]

Revit 2024 API
BuiltInFailures..::..ElectricalFailures..::..PanelMismatchCircuitType Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
Cannot assign [Element] to Circuit. The Type for the panel does not match the Type ([Name]) for the Circuit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId PanelMismatchCircuitType { get; }
Visual Basic
Public Shared ReadOnly Property PanelMismatchCircuitType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PanelMismatchCircuitType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


PanelMismatchDistSysWhenCircuitAssigned Property

[image]

Revit 2024 API
BuiltInFailures..::..ElectricalFailures..::..PanelMismatchDistSysWhenCircuitAssigned Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
The selected circuit was added to panel [Element], but the distribution system for the panel does not match the power connector definition on the panel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId PanelMismatchDistSysWhenCircuitAssigned { get; }
Visual Basic
Public Shared ReadOnly Property PanelMismatchDistSysWhenCircuitAssigned As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PanelMismatchDistSysWhenCircuitAssigned {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


ReplaceSpareSpaceOnPanelBoard Property

[image]

Revit 2024 API
BuiltInFailures..::..ElectricalFailures..::..ReplaceSpareSpaceOnPanelBoard Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
Need to replace spare or space on panelboard.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ReplaceSpareSpaceOnPanelBoard { get; }
Visual Basic
Public Shared ReadOnly Property ReplaceSpareSpaceOnPanelBoard As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ReplaceSpareSpaceOnPanelBoard {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


SelectedElementsArePartOfOtherCircuit Property

[image]

Revit 2024 API
BuiltInFailures..::..ElectricalFailures..::..SelectedElementsArePartOfOtherCircuit Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
You have selected elements that are already part of other Circuits. They will be removed from the original Circuits and added to this one.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SelectedElementsArePartOfOtherCircuit { get; }
Visual Basic
Public Shared ReadOnly Property SelectedElementsArePartOfOtherCircuit As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SelectedElementsArePartOfOtherCircuit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


UnsignedCircuit Property

[image]

Revit 2024 API
BuiltInFailures..::..ElectricalFailures..::..UnsignedCircuit Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
Circuit is not assigned to a panel

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UnsignedCircuit { get; }
Visual Basic
Public Shared ReadOnly Property UnsignedCircuit As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnsignedCircuit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


VoltageIsOutOfRange Property

[image]

Revit 2024 API
BuiltInFailures..::..ElectricalFailures..::..VoltageIsOutOfRange Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
Cannot assign or add [Element] to Circuit. The Voltage ([Voltage Value]) for the Circuit is out of range for the Line to Ground Voltage for [Element] (The Line to Ground Voltage is specified in the assigned Distribution System)."

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId VoltageIsOutOfRange { get; }
Visual Basic
Public Shared ReadOnly Property VoltageIsOutOfRange As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ VoltageIsOutOfRange {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


WireMaxSizeNonexistent Property

[image]

Revit 2024 API
BuiltInFailures..::..ElectricalFailures..::..WireMaxSizeNonexistent Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
Cannot find max size in current wire type's material table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WireMaxSizeNonexistent { get; }
Visual Basic
Public Shared ReadOnly Property WireMaxSizeNonexistent As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WireMaxSizeNonexistent {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


BuiltInFailures.ElectricityFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..ElectricityFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures related to electrical system and circuits.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class ElectricityFailures
Visual Basic
Public NotInheritable Class ElectricityFailures
Visual C++
public ref class ElectricityFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..ElectricityFailures

See Also

BuiltInFailures..::..ElectricityFailures Members


BuiltInFailures.ElectricityFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..ElectricityFailures Members
BuiltInFailures..::..ElectricityFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..ElectricityFailures type exposes the following members.

Properties

Name | Description
FamilyMismatchCircuitDisconnected | The family no longer matches the properties for the Circuit. Disconnect the family from the Circuit?
InvalidPoleNumber | The panel is single phase [wire] wires. The number of poles can not be larger than [value].
InvalidSpareLoad | The spare/space assigned to panel '[Panel Name]' has an invalid load property. To correct this issue, remove and add the spare/space to the panel again.

See Also

BuiltInFailures..::..ElectricityFailures Class


FamilyMismatchCircuitDisconnected Property

[image]

Revit 2024 API
BuiltInFailures..::..ElectricityFailures..::..FamilyMismatchCircuitDisconnected Property
BuiltInFailures..::..ElectricityFailures Class See Also Send Feedback
The family no longer matches the properties for the Circuit. Disconnect the family from the Circuit?

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FamilyMismatchCircuitDisconnected { get; }
Visual Basic
Public Shared ReadOnly Property FamilyMismatchCircuitDisconnected As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FamilyMismatchCircuitDisconnected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricityFailures Class


InvalidPoleNumber Property

[image]

Revit 2024 API
BuiltInFailures..::..ElectricityFailures..::..InvalidPoleNumber Property
BuiltInFailures..::..ElectricityFailures Class See Also Send Feedback
The panel is single phase [wire] wires. The number of poles can not be larger than [value].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidPoleNumber { get; }
Visual Basic
Public Shared ReadOnly Property InvalidPoleNumber As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidPoleNumber {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricityFailures Class


InvalidSpareLoad Property

[image]

Revit 2024 API
BuiltInFailures..::..ElectricityFailures..::..InvalidSpareLoad Property
BuiltInFailures..::..ElectricityFailures Class See Also Send Feedback
The spare/space assigned to panel '[Panel Name]' has an invalid load property. To correct this issue, remove and add the spare/space to the panel again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidSpareLoad { get; }
Visual Basic
Public Shared ReadOnly Property InvalidSpareLoad As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidSpareLoad {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricityFailures Class


BuiltInFailures.ElementFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..ElementFailures Properties
BuiltInFailures..::..ElementFailures Class See Also Send Feedback

The BuiltInFailures..::..ElementFailures type exposes the following members.

Properties

Name | Description
FailedToRemoveElement | Element cannot be removed from the solution. The solution is required to have at least two elements to be valid.
NotAllowedToRemoveAllElements | You cannot removed all the elements from current solution. At least there should be two elements in the solution.
SplitElementHasTagsWithoutLeaders | The split element has one or more Tags without Leaders enabled and needs to be checked.

See Also

BuiltInFailures..::..ElementFailures Class


FailedToRemoveElement Property

[image]

Revit 2024 API
BuiltInFailures..::..ElementFailures..::..FailedToRemoveElement Property
BuiltInFailures..::..ElementFailures Class See Also Send Feedback
Element cannot be removed from the solution. The solution is required to have at least two elements to be valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FailedToRemoveElement { get; }
Visual Basic
Public Shared ReadOnly Property FailedToRemoveElement As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FailedToRemoveElement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElementFailures Class


NotAllowedToRemoveAllElements Property

[image]

Revit 2024 API
BuiltInFailures..::..ElementFailures..::..NotAllowedToRemoveAllElements Property
BuiltInFailures..::..ElementFailures Class See Also Send Feedback
You cannot removed all the elements from current solution. At least there should be two elements in the solution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NotAllowedToRemoveAllElements { get; }
Visual Basic
Public Shared ReadOnly Property NotAllowedToRemoveAllElements As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotAllowedToRemoveAllElements {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElementFailures Class


BuiltInFailures.ElementTypeFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..ElementTypeFailures Members
BuiltInFailures..::..ElementTypeFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..ElementTypeFailures type exposes the following members.

Properties

Name | Description
NoDefaultType | As a result of Reloading Latest, there are no types of [User Name] left. Create a new type by duplicating an existing [User Name] type in the Project Browser.
WarnLastType1 | Last type in system family '[Name]' cannot be deleted.

See Also

BuiltInFailures..::..ElementTypeFailures Class


BuiltInFailures.ElementTypeFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..ElementTypeFailures Properties
BuiltInFailures..::..ElementTypeFailures Class See Also Send Feedback

The BuiltInFailures..::..ElementTypeFailures type exposes the following members.

Properties

Name | Description
NoDefaultType | As a result of Reloading Latest, there are no types of [User Name] left. Create a new type by duplicating an existing [User Name] type in the Project Browser.
WarnLastType1 | Last type in system family '[Name]' cannot be deleted.

See Also

BuiltInFailures..::..ElementTypeFailures Class


NoDefaultType Property

[image]

Revit 2024 API
BuiltInFailures..::..ElementTypeFailures..::..NoDefaultType Property
BuiltInFailures..::..ElementTypeFailures Class See Also Send Feedback
As a result of Reloading Latest, there are no types of [User Name] left. Create a new type by duplicating an existing [User Name] type in the Project Browser.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoDefaultType { get; }
Visual Basic
Public Shared ReadOnly Property NoDefaultType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoDefaultType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElementTypeFailures Class


WarnLastType1 Property

[image]

Revit 2024 API
BuiltInFailures..::..ElementTypeFailures..::..WarnLastType1 Property
BuiltInFailures..::..ElementTypeFailures Class See Also Send Feedback
Last type in system family '[Name]' cannot be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WarnLastType1 { get; }
Visual Basic
Public Shared ReadOnly Property WarnLastType1 As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WarnLastType1 {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElementTypeFailures Class


BuiltInFailures.ElevationFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..ElevationFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Elevation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class ElevationFailures
Visual Basic
Public NotInheritable Class ElevationFailures
Visual C++
public ref class ElevationFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..ElevationFailures

See Also

BuiltInFailures..::..ElevationFailures Members


BuiltInFailures.ElevationFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..ElevationFailures Properties
BuiltInFailures..::..ElevationFailures Class See Also Send Feedback

The BuiltInFailures..::..ElevationFailures type exposes the following members.

Properties

Name | Description
ElevationDetach | An Elevation arrow can't keep its Crop Region extents attached.
IncompatibleElevationTagFamily | Attempt to change elevation tag families to one with incompatible view directions.
WarnElevSheet | An elevation symbol references views on more than one sheet. It will show a blank sheet reference. To show the correct references, use a separate elevation symbol for the views on each sheet.

See Also

BuiltInFailures..::..ElevationFailures Class


ElevationDetach Property

[image]

Revit 2024 API
BuiltInFailures..::..ElevationFailures..::..ElevationDetach Property
BuiltInFailures..::..ElevationFailures Class See Also Send Feedback
An Elevation arrow can't keep its Crop Region extents attached.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ElevationDetach { get; }
Visual Basic
Public Shared ReadOnly Property ElevationDetach As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElevationDetach {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElevationFailures Class


IncompatibleElevationTagFamily Property

[image]

Revit 2024 API
BuiltInFailures..::..ElevationFailures..::..IncompatibleElevationTagFamily Property
BuiltInFailures..::..ElevationFailures Class See Also Send Feedback
Attempt to change elevation tag families to one with incompatible view directions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId IncompatibleElevationTagFamily { get; }
Visual Basic
Public Shared ReadOnly Property IncompatibleElevationTagFamily As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ IncompatibleElevationTagFamily {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElevationFailures Class


BuiltInFailures.EnergyAnalysisFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..EnergyAnalysisFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about EnergyAnalysis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class EnergyAnalysisFailures
Visual Basic
Public NotInheritable Class EnergyAnalysisFailures
Visual C++
public ref class EnergyAnalysisFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..EnergyAnalysisFailures

See Also

BuiltInFailures..::..EnergyAnalysisFailures Members


ComputeRoomVolumeNotCheckedWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..EnergyAnalysisFailures..::..ComputeRoomVolumeNotCheckedWarn Property
BuiltInFailures..::..EnergyAnalysisFailures Class See Also Send Feedback
The setting for calculation of Volume Computations is not on. The analysis model produced will be approximate without the computation of Areas and Volumes

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ComputeRoomVolumeNotCheckedWarn { get; }
Visual Basic
Public Shared ReadOnly Property ComputeRoomVolumeNotCheckedWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ComputeRoomVolumeNotCheckedWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EnergyAnalysisFailures Class


NoRoofsRoomBoundingWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..EnergyAnalysisFailures..::..NoRoofsRoomBoundingWarn Property
BuiltInFailures..::..EnergyAnalysisFailures Class See Also Send Feedback
The energy analysis model does not contain any roof surfaces! If there are roofs in your model, please verify that they are room bounding, and make sure that the room offsets are high enough to include the roofs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoRoofsRoomBoundingWarn { get; }
Visual Basic
Public Shared ReadOnly Property NoRoofsRoomBoundingWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoRoofsRoomBoundingWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EnergyAnalysisFailures Class


NoRoomBoundingElementsWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..EnergyAnalysisFailures..::..NoRoomBoundingElementsWarn Property
BuiltInFailures..::..EnergyAnalysisFailures Class See Also Send Feedback
Can't create any energy analysis surfaces. There are no Room bounding elements defined in the current phase. Please check the Project Information settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoRoomBoundingElementsWarn { get; }
Visual Basic
Public Shared ReadOnly Property NoRoomBoundingElementsWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoRoomBoundingElementsWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EnergyAnalysisFailures Class


NoSpaceBoundingElements Property

[image]

Revit 2024 API
BuiltInFailures..::..EnergyAnalysisFailures..::..NoSpaceBoundingElements Property
BuiltInFailures..::..EnergyAnalysisFailures Class See Also Send Feedback
Can't create any energy analysis surfaces. There are no Space bounding elements defined in the current phase. Please check the Project Information settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoSpaceBoundingElements { get; }
Visual Basic
Public Shared ReadOnly Property NoSpaceBoundingElements As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoSpaceBoundingElements {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EnergyAnalysisFailures Class


NoSpaceBoundingElementsWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..EnergyAnalysisFailures..::..NoSpaceBoundingElementsWarn Property
BuiltInFailures..::..EnergyAnalysisFailures Class See Also Send Feedback
Can't create any energy analysis surfaces. There are no Space bounding elements defined in the current phase. Please check the Project Information settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoSpaceBoundingElementsWarn { get; }
Visual Basic
Public Shared ReadOnly Property NoSpaceBoundingElementsWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoSpaceBoundingElementsWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EnergyAnalysisFailures Class


NoSpaces Property

[image]

Revit 2024 API
BuiltInFailures..::..EnergyAnalysisFailures..::..NoSpaces Property
BuiltInFailures..::..EnergyAnalysisFailures Class See Also Send Feedback
Revit was unable to identify any spaces. If you are sure that spaces have been created in the project, please check the Project Phase setting to verify that the Project Phase matches the phase in which spaces have been defined in your project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoSpaces { get; }
Visual Basic
Public Shared ReadOnly Property NoSpaces As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoSpaces {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EnergyAnalysisFailures Class


NoSpacesWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..EnergyAnalysisFailures..::..NoSpacesWarn Property
BuiltInFailures..::..EnergyAnalysisFailures Class See Also Send Feedback
Revit was unable to identify any spaces. If you are sure that spaces have been created in the project, please check the Project Phase setting to verify that the Project Phase matches the phase in which spaces have been defined in your project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoSpacesWarn { get; }
Visual Basic
Public Shared ReadOnly Property NoSpacesWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoSpacesWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EnergyAnalysisFailures Class


PlenumWithNoCeilingWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..EnergyAnalysisFailures..::..PlenumWithNoCeilingWarn Property
BuiltInFailures..::..EnergyAnalysisFailures Class See Also Send Feedback
[Room] has Space Type set to Plenum but has no ceiling surface. A plenum must be separated from the space it serves by a ceiling.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId PlenumWithNoCeilingWarn { get; }
Visual Basic
Public Shared ReadOnly Property PlenumWithNoCeilingWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PlenumWithNoCeilingWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EnergyAnalysisFailures Class


ProblemWithLightingLoadWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..EnergyAnalysisFailures..::..ProblemWithLightingLoadWarn Property
BuiltInFailures..::..EnergyAnalysisFailures Class See Also Send Feedback
[Room]'s lighting load is too high. This may be caused by an incorrect density value and must be corrected before this space can be included in the load calculations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ProblemWithLightingLoadWarn { get; }
Visual Basic
Public Shared ReadOnly Property ProblemWithLightingLoadWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ProblemWithLightingLoadWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EnergyAnalysisFailures Class


ProblemWithPeopleLoadWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..EnergyAnalysisFailures..::..ProblemWithPeopleLoadWarn Property
BuiltInFailures..::..EnergyAnalysisFailures Class See Also Send Feedback
[Room]'s number of people or people load (sensible or latent) is too high. This may be caused by an incorrect density value and must be corrected before this space can be included in the load calculations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ProblemWithPeopleLoadWarn { get; }
Visual Basic
Public Shared ReadOnly Property ProblemWithPeopleLoadWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ProblemWithPeopleLoadWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EnergyAnalysisFailures Class


ProblemWithPowerLoadWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..EnergyAnalysisFailures..::..ProblemWithPowerLoadWarn Property
BuiltInFailures..::..EnergyAnalysisFailures Class See Also Send Feedback
[Room]'s power load is too high. This may be caused by an incorrect density value and must be corrected before this space can be included in the load calculations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ProblemWithPowerLoadWarn { get; }
Visual Basic
Public Shared ReadOnly Property ProblemWithPowerLoadWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ProblemWithPowerLoadWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EnergyAnalysisFailures Class


RoomGeometryCannotFindFreeFacesBoundingElement Property

[image]

Revit 2024 API
BuiltInFailures..::..EnergyAnalysisFailures..::..RoomGeometryCannotFindFreeFacesBoundingElement Property
BuiltInFailures..::..EnergyAnalysisFailures Class See Also Send Feedback
An error occurred while trying to find the free part of a face of the bounding geometry for [Room] when processing the room-bounding element [Name]. The free part of the face is found by subtracting the portions of the face that overlap various room-bounding element faces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RoomGeometryCannotFindFreeFacesBoundingElement { get; }
Visual Basic
Public Shared ReadOnly Property RoomGeometryCannotFindFreeFacesBoundingElement As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomGeometryCannotFindFreeFacesBoundingElement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EnergyAnalysisFailures Class


RoomGeometryCannotTrimBoundingElement Property

[image]

Revit 2024 API
BuiltInFailures..::..EnergyAnalysisFailures..::..RoomGeometryCannotTrimBoundingElement Property
BuiltInFailures..::..EnergyAnalysisFailures Class See Also Send Feedback
An error occurred while trimming the vertical shadow of a room-bounding element [Name] of the bounding geometry for [Room].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RoomGeometryCannotTrimBoundingElement { get; }
Visual Basic
Public Shared ReadOnly Property RoomGeometryCannotTrimBoundingElement As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomGeometryCannotTrimBoundingElement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EnergyAnalysisFailures Class


RoomNotUpperBoundedByElement Property

[image]

Revit 2024 API
BuiltInFailures..::..EnergyAnalysisFailures..::..RoomNotUpperBoundedByElement Property
BuiltInFailures..::..EnergyAnalysisFailures Class See Also Send Feedback
[Family] is not upper bounded by a roof, ceiling or floor element. This can result in incorrect adjacencies and voids in the analytical model. Please ensure that Upper Limit and Limit Offset for [Room] is set correctly.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RoomNotUpperBoundedByElement { get; }
Visual Basic
Public Shared ReadOnly Property RoomNotUpperBoundedByElement As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomNotUpperBoundedByElement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EnergyAnalysisFailures Class


RoomVolumeNegativeWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..EnergyAnalysisFailures..::..RoomVolumeNegativeWarn Property
BuiltInFailures..::..EnergyAnalysisFailures Class See Also Send Feedback
[Room] has a negative volume? [Room] will be ignored in the energy analysis model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RoomVolumeNegativeWarn { get; }
Visual Basic
Public Shared ReadOnly Property RoomVolumeNegativeWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomVolumeNegativeWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EnergyAnalysisFailures Class


RoomVolumeNotComputedWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..EnergyAnalysisFailures..::..RoomVolumeNotComputedWarn Property
BuiltInFailures..::..EnergyAnalysisFailures Class See Also Send Feedback
[Family] volume can't be computed. The bounding geometry (in 3D) can't be found for [Room]. [Room] will be ignored in the energy analysis model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RoomVolumeNotComputedWarn { get; }
Visual Basic
Public Shared ReadOnly Property RoomVolumeNotComputedWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomVolumeNotComputedWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EnergyAnalysisFailures Class


SpaceResolutionOutOfRange Property

[image]

Revit 2024 API
BuiltInFailures..::..EnergyAnalysisFailures..::..SpaceResolutionOutOfRange Property
BuiltInFailures..::..EnergyAnalysisFailures Class See Also Send Feedback
Voxel size is out of range.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SpaceResolutionOutOfRange { get; }
Visual Basic
Public Shared ReadOnly Property SpaceResolutionOutOfRange As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SpaceResolutionOutOfRange {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EnergyAnalysisFailures Class


SurfaceResolutionOutOfRange Property

[image]

Revit 2024 API
BuiltInFailures..::..EnergyAnalysisFailures..::..SurfaceResolutionOutOfRange Property
BuiltInFailures..::..EnergyAnalysisFailures Class See Also Send Feedback
Pixel size is out of range.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SurfaceResolutionOutOfRange { get; }
Visual Basic
Public Shared ReadOnly Property SurfaceResolutionOutOfRange As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SurfaceResolutionOutOfRange {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EnergyAnalysisFailures Class


UndefinedRooms Property

[image]

Revit 2024 API
BuiltInFailures..::..EnergyAnalysisFailures..::..UndefinedRooms Property
BuiltInFailures..::..EnergyAnalysisFailures Class See Also Send Feedback
There are undefined Rooms in the model! Recommend creating a Room schedule and checking the Area parameter of each Room for warnings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UndefinedRooms { get; }
Visual Basic
Public Shared ReadOnly Property UndefinedRooms As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UndefinedRooms {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EnergyAnalysisFailures Class


UndefinedSpaces Property

[image]

Revit 2024 API
BuiltInFailures..::..EnergyAnalysisFailures..::..UndefinedSpaces Property
BuiltInFailures..::..EnergyAnalysisFailures Class See Also Send Feedback
There are undefined Spaces in the model! Recommend creating a Space schedule and checking the Area parameter of each Space for warnings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UndefinedSpaces { get; }
Visual Basic
Public Shared ReadOnly Property UndefinedSpaces As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UndefinedSpaces {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EnergyAnalysisFailures Class


ZoneWithoutSpacesWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..EnergyAnalysisFailures..::..ZoneWithoutSpacesWarn Property
BuiltInFailures..::..EnergyAnalysisFailures Class See Also Send Feedback
This zone has no spaces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ZoneWithoutSpacesWarn { get; }
Visual Basic
Public Shared ReadOnly Property ZoneWithoutSpacesWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ZoneWithoutSpacesWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EnergyAnalysisFailures Class


BuiltInFailures.EnergyAnalysisUtilitiesDBFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..EnergyAnalysisUtilitiesDBFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about EnergyAnalysisUtilitiesDBFailures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class EnergyAnalysisUtilitiesDBFailures
Visual Basic
Public NotInheritable Class EnergyAnalysisUtilitiesDBFailures
Visual C++
public ref class EnergyAnalysisUtilitiesDBFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..EnergyAnalysisUtilitiesDBFailures

See Also

BuiltInFailures..::..EnergyAnalysisUtilitiesDBFailures Members


BuiltInFailures.EnergyAnalysisUtilitiesDBFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..EnergyAnalysisUtilitiesDBFailures Members
BuiltInFailures..::..EnergyAnalysisUtilitiesDBFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..EnergyAnalysisUtilitiesDBFailures type exposes the following members.

Properties

Name | Description
AimErrEmptyName | MassZone '%1' has empty name and id values which cannot be used as gbXML identifiers.

See Also

BuiltInFailures..::..EnergyAnalysisUtilitiesDBFailures Class


BuiltInFailures.ExportFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..ExportFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about ExportFailures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class ExportFailures
Visual Basic
Public NotInheritable Class ExportFailures
Visual C++
public ref class ExportFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..ExportFailures

See Also

BuiltInFailures..::..ExportFailures Members


BuiltInFailures.ExportFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..ExportFailures Properties
BuiltInFailures..::..ExportFailures Class See Also Send Feedback

The BuiltInFailures..::..ExportFailures type exposes the following members.

Properties

Name | Description
IFCFatalExportError | There has been an unrecoverable error during export. Export will now be aborted.
IFCFatalToolkitExportError | There has been an unrecoverable error during export. Export will now be aborted.
IFCGenericExportWarning | Unexpected errors occurred while exporting these elements to the IFC file.
SwitchToRasterProcessingInsteadOfVectorWarning | Some of the views have been switched to raster processing though vector processing is selected.

See Also

BuiltInFailures..::..ExportFailures Class


IFCFatalExportError Property

[image]

Revit 2024 API
BuiltInFailures..::..ExportFailures..::..IFCFatalExportError Property
BuiltInFailures..::..ExportFailures Class See Also Send Feedback
There has been an unrecoverable error during export. Export will now be aborted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId IFCFatalExportError { get; }
Visual Basic
Public Shared ReadOnly Property IFCFatalExportError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ IFCFatalExportError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ExportFailures Class


IFCFatalToolkitExportError Property

[image]

Revit 2024 API
BuiltInFailures..::..ExportFailures..::..IFCFatalToolkitExportError Property
BuiltInFailures..::..ExportFailures Class See Also Send Feedback
There has been an unrecoverable error during export. Export will now be aborted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId IFCFatalToolkitExportError { get; }
Visual Basic
Public Shared ReadOnly Property IFCFatalToolkitExportError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ IFCFatalToolkitExportError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ExportFailures Class


IFCGenericExportWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..ExportFailures..::..IFCGenericExportWarning Property
BuiltInFailures..::..ExportFailures Class See Also Send Feedback
Unexpected errors occurred while exporting these elements to the IFC file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId IFCGenericExportWarning { get; }
Visual Basic
Public Shared ReadOnly Property IFCGenericExportWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ IFCGenericExportWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ExportFailures Class


BuiltInFailures.ExternalResourceReferenceFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..ExternalResourceReferenceFailures Class
BuiltInFailures Class Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class ExternalResourceReferenceFailures
Visual Basic
Public NotInheritable Class ExternalResourceReferenceFailures
Visual C++
public ref class ExternalResourceReferenceFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..ExternalResourceReferenceFailures

See Also

BuiltInFailures..::..ExternalResourceReferenceFailures Members


BuiltInFailures.ExternalResourceReferenceFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..ExternalResourceReferenceFailures Members
BuiltInFailures..::..ExternalResourceReferenceFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..ExternalResourceReferenceFailures type exposes the following members.

Properties

Name | Description
ReferenceToLocalFile | The External Resource refers to a local file that may not be available to workshared users.

See Also

BuiltInFailures..::..ExternalResourceReferenceFailures Class


BuiltInFailures.ExternalResourceReferenceFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..ExternalResourceReferenceFailures Properties
BuiltInFailures..::..ExternalResourceReferenceFailures Class See Also Send Feedback

The BuiltInFailures..::..ExternalResourceReferenceFailures type exposes the following members.

Properties

Name | Description
ReferenceToLocalFile | The External Resource refers to a local file that may not be available to workshared users.

See Also

BuiltInFailures..::..ExternalResourceReferenceFailures Class


BuiltInFailures.ExtrusionFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..ExtrusionFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Extrusions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class ExtrusionFailures
Visual Basic
Public NotInheritable Class ExtrusionFailures
Visual C++
public ref class ExtrusionFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..ExtrusionFailures

See Also

BuiltInFailures..::..ExtrusionFailures Members


BuiltInFailures.ExtrusionFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..ExtrusionFailures Members
BuiltInFailures..::..ExtrusionFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..ExtrusionFailures type exposes the following members.

Properties

Name | Description
CannotDrawExtrusions | Can't make Extrusion.
CannotDrawExtrusionsError | Can't make Extrusion.
ExtrusionTooThin | Extrusion is too thin.
InvalidExtrusionCurveloop | Base sketch for extrusion is invalid.
InvalidExtrusionCurveloopError | Base sketch for extrusion is invalid.

See Also

BuiltInFailures..::..ExtrusionFailures Class


BuiltInFailures.ExtrusionFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..ExtrusionFailures Properties
BuiltInFailures..::..ExtrusionFailures Class See Also Send Feedback

The BuiltInFailures..::..ExtrusionFailures type exposes the following members.

Properties

Name | Description
CannotDrawExtrusions | Can't make Extrusion.
CannotDrawExtrusionsError | Can't make Extrusion.
ExtrusionTooThin | Extrusion is too thin.
InvalidExtrusionCurveloop | Base sketch for extrusion is invalid.
InvalidExtrusionCurveloopError | Base sketch for extrusion is invalid.

See Also

BuiltInFailures..::..ExtrusionFailures Class


InvalidExtrusionCurveloop Property

[image]

Revit 2024 API
BuiltInFailures..::..ExtrusionFailures..::..InvalidExtrusionCurveloop Property
BuiltInFailures..::..ExtrusionFailures Class See Also Send Feedback
Base sketch for extrusion is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidExtrusionCurveloop { get; }
Visual Basic
Public Shared ReadOnly Property InvalidExtrusionCurveloop As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidExtrusionCurveloop {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ExtrusionFailures Class


InvalidExtrusionCurveloopError Property

[image]

Revit 2024 API
BuiltInFailures..::..ExtrusionFailures..::..InvalidExtrusionCurveloopError Property
BuiltInFailures..::..ExtrusionFailures Class See Also Send Feedback
Base sketch for extrusion is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidExtrusionCurveloopError { get; }
Visual Basic
Public Shared ReadOnly Property InvalidExtrusionCurveloopError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidExtrusionCurveloopError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ExtrusionFailures Class


BuiltInFailures.FabricAreaFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..FabricAreaFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures related to fabric area elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class FabricAreaFailures
Visual Basic
Public NotInheritable Class FabricAreaFailures
Visual C++
public ref class FabricAreaFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..FabricAreaFailures

See Also

BuiltInFailures..::..FabricAreaFailures Members


BuiltInFailures.FabricAreaFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..FabricAreaFailures Members
BuiltInFailures..::..FabricAreaFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..FabricAreaFailures type exposes the following members.

Properties

Name | Description
FabricAreaLapSplicesIncorrect | Fabric Area lap splice is incorrect.
FabricAreaOutSideOfHost | Fabric Area is sketched completely outside of its host.

See Also

BuiltInFailures..::..FabricAreaFailures Class


BuiltInFailures.FabricAreaFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..FabricAreaFailures Properties
BuiltInFailures..::..FabricAreaFailures Class See Also Send Feedback

The BuiltInFailures..::..FabricAreaFailures type exposes the following members.

Properties

Name | Description
FabricAreaLapSplicesIncorrect | Fabric Area lap splice is incorrect.
FabricAreaOutSideOfHost | Fabric Area is sketched completely outside of its host.

See Also

BuiltInFailures..::..FabricAreaFailures Class


FabricAreaLapSplicesIncorrect Property

[image]

Revit 2024 API
BuiltInFailures..::..FabricAreaFailures..::..FabricAreaLapSplicesIncorrect Property
BuiltInFailures..::..FabricAreaFailures Class See Also Send Feedback
Fabric Area lap splice is incorrect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FabricAreaLapSplicesIncorrect { get; }
Visual Basic
Public Shared ReadOnly Property FabricAreaLapSplicesIncorrect As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FabricAreaLapSplicesIncorrect {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FabricAreaFailures Class


FabricAreaOutSideOfHost Property

[image]

Revit 2024 API
BuiltInFailures..::..FabricAreaFailures..::..FabricAreaOutSideOfHost Property
BuiltInFailures..::..FabricAreaFailures Class See Also Send Feedback
Fabric Area is sketched completely outside of its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FabricAreaOutSideOfHost { get; }
Visual Basic
Public Shared ReadOnly Property FabricAreaOutSideOfHost As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FabricAreaOutSideOfHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FabricAreaFailures Class


BuiltInFailures.FabricFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..FabricFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Fabric.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class FabricFailures
Visual Basic
Public NotInheritable Class FabricFailures
Visual C++
public ref class FabricFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..FabricFailures

See Also

BuiltInFailures..::..FabricFailures Members


BuiltInFailures.FabricFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..FabricFailures Members
BuiltInFailures..::..FabricFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..FabricFailures type exposes the following members.

Properties

Name | Description
BendDiameterNegative | Fabric Bend Diameter is negative.
BendPolylineInvalid | The bend profile contains too short of a segment to apply the wire bend diameter. Cannot create a bent fabric sheet for this type.
BentHiddenWires | The wires of this custom fabric sheet type are longer than the bending sketch. The linear quantities shown in schedules and tags are not accurate.
CannotPlaceFabricArea | Can't find a host for Fabric Area.
CannotPlaceFabricAreaWarn | Can't find a host for Fabric Area.
CannotPlaceFabricSheet | Can't find a host for Fabric Sheet.
CannotPlaceFabricSheetWarn | Can't find a host for Fabric Sheet.
CoverOffsetTooLong | Cover offset is greater than host thickness.
CoverOffsetTooLongTemp | Cover offset is greater than host thickness - support for transient Single Fabric Sheet in editor.
FabricAreaWrongHost | Fabric Area can be placed only in Structural Floors and straight Structural Walls.
FabricAreaWrongLapSplice | Fabric Area Sheet lap splice is incorrect. Can't create Fabric Area.
FabricAreaWrongSheetAlignment | Fabric Area Sheet Alignment is incorrect. Can't create Fabric Area.
FabricSheetWrongHost | Fabric Sheet can be placed only in Structural Floors and straight Structural Walls.
MajorLapSpliceFailure | The lap splice in the major direction is greater than the half of the overall length.
MajorOverhangFailure | At least one of the overhangs in the major direction is lower than radius of the wire in the minor direction.
MajorSpacingFailure | The spacing in the major direction is lower than diameter of the wire in the minor direction.
MinorLapSpliceFailure | The lap splice in the minor direction is greater than the half of the overall width.
MinorOverhangFailure | At least one of the overhangs in the minor direction is lower than radius of the wire in the major direction.
MinorSpacingFailure | The spacing in the minor direction is lower than diameter of the wire in the major direction.
NoSurfPatternOnWire | Wire elements do not support surface patterns. The surface pattern associated with this material will not be displayed on the indicated Fabric Sheet Type.
NoWireMaterialDensity | Material does not have a density defined. The weight of the Fabric Sheet cannot be computed.
WireDiameterTooLarge | Fabric Wire Diameter is too large.
WrongFabricSheetEndOverhang | Wrong Start Overhang of the Fabric Sheet Type.
WrongFabricSheetLayoutPattern | The Layout Pattern cannot accommodate the current data. Try decreasing the Number of Wires/Spacing.
WrongFabricSheetNumberOfWires | Wrong Number of Wires of the Fabric Sheet Type.
WrongFabricSheetOverallLength | Wrong Overall Length/Width of the Fabric Sheet Type.
WrongFabricSheetSpacing | Wrong Spacing of the Fabric Sheet Type.
WrongFabricSheetStartOverhang | Wrong Start Overhang of the Fabric Sheet Type.

See Also

BuiltInFailures..::..FabricFailures Class


BuiltInFailures.FabricFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..FabricFailures Properties
BuiltInFailures..::..FabricFailures Class See Also Send Feedback

The BuiltInFailures..::..FabricFailures type exposes the following members.

Properties

Name | Description
BendDiameterNegative | Fabric Bend Diameter is negative.
BendPolylineInvalid | The bend profile contains too short of a segment to apply the wire bend diameter. Cannot create a bent fabric sheet for this type.
BentHiddenWires | The wires of this custom fabric sheet type are longer than the bending sketch. The linear quantities shown in schedules and tags are not accurate.
CannotPlaceFabricArea | Can't find a host for Fabric Area.
CannotPlaceFabricAreaWarn | Can't find a host for Fabric Area.
CannotPlaceFabricSheet | Can't find a host for Fabric Sheet.
CannotPlaceFabricSheetWarn | Can't find a host for Fabric Sheet.
CoverOffsetTooLong | Cover offset is greater than host thickness.
CoverOffsetTooLongTemp | Cover offset is greater than host thickness - support for transient Single Fabric Sheet in editor.
FabricAreaWrongHost | Fabric Area can be placed only in Structural Floors and straight Structural Walls.
FabricAreaWrongLapSplice | Fabric Area Sheet lap splice is incorrect. Can't create Fabric Area.
FabricAreaWrongSheetAlignment | Fabric Area Sheet Alignment is incorrect. Can't create Fabric Area.
FabricSheetWrongHost | Fabric Sheet can be placed only in Structural Floors and straight Structural Walls.
MajorLapSpliceFailure | The lap splice in the major direction is greater than the half of the overall length.
MajorOverhangFailure | At least one of the overhangs in the major direction is lower than radius of the wire in the minor direction.
MajorSpacingFailure | The spacing in the major direction is lower than diameter of the wire in the minor direction.
MinorLapSpliceFailure | The lap splice in the minor direction is greater than the half of the overall width.
MinorOverhangFailure | At least one of the overhangs in the minor direction is lower than radius of the wire in the major direction.
MinorSpacingFailure | The spacing in the minor direction is lower than diameter of the wire in the major direction.
NoSurfPatternOnWire | Wire elements do not support surface patterns. The surface pattern associated with this material will not be displayed on the indicated Fabric Sheet Type.
NoWireMaterialDensity | Material does not have a density defined. The weight of the Fabric Sheet cannot be computed.
WireDiameterTooLarge | Fabric Wire Diameter is too large.
WrongFabricSheetEndOverhang | Wrong Start Overhang of the Fabric Sheet Type.
WrongFabricSheetLayoutPattern | The Layout Pattern cannot accommodate the current data. Try decreasing the Number of Wires/Spacing.
WrongFabricSheetNumberOfWires | Wrong Number of Wires of the Fabric Sheet Type.
WrongFabricSheetOverallLength | Wrong Overall Length/Width of the Fabric Sheet Type.
WrongFabricSheetSpacing | Wrong Spacing of the Fabric Sheet Type.
WrongFabricSheetStartOverhang | Wrong Start Overhang of the Fabric Sheet Type.

See Also

BuiltInFailures..::..FabricFailures Class


BendDiameterNegative Property

[image]

Revit 2024 API
BuiltInFailures..::..FabricFailures..::..BendDiameterNegative Property
BuiltInFailures..::..FabricFailures Class See Also Send Feedback
Fabric Bend Diameter is negative.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId BendDiameterNegative { get; }
Visual Basic
Public Shared ReadOnly Property BendDiameterNegative As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BendDiameterNegative {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FabricFailures Class


BendPolylineInvalid Property

[image]

Revit 2024 API
BuiltInFailures..::..FabricFailures..::..BendPolylineInvalid Property
BuiltInFailures..::..FabricFailures Class See Also Send Feedback
The bend profile contains too short of a segment to apply the wire bend diameter. Cannot create a bent fabric sheet for this type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId BendPolylineInvalid { get; }
Visual Basic
Public Shared ReadOnly Property BendPolylineInvalid As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BendPolylineInvalid {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FabricFailures Class


BentHiddenWires Property

[image]

Revit 2024 API
BuiltInFailures..::..FabricFailures..::..BentHiddenWires Property
BuiltInFailures..::..FabricFailures Class See Also Send Feedback
The wires of this custom fabric sheet type are longer than the bending sketch. The linear quantities shown in schedules and tags are not accurate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId BentHiddenWires { get; }
Visual Basic
Public Shared ReadOnly Property BentHiddenWires As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BentHiddenWires {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FabricFailures Class


CannotPlaceFabricArea Property

[image]

Revit 2024 API
BuiltInFailures..::..FabricFailures..::..CannotPlaceFabricArea Property
BuiltInFailures..::..FabricFailures Class See Also Send Feedback
Can't find a host for Fabric Area.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotPlaceFabricArea { get; }
Visual Basic
Public Shared ReadOnly Property CannotPlaceFabricArea As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPlaceFabricArea {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FabricFailures Class


CannotPlaceFabricAreaWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..FabricFailures..::..CannotPlaceFabricAreaWarn Property
BuiltInFailures..::..FabricFailures Class See Also Send Feedback
Can't find a host for Fabric Area.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotPlaceFabricAreaWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotPlaceFabricAreaWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPlaceFabricAreaWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FabricFailures Class


CannotPlaceFabricSheet Property

[image]

Revit 2024 API
BuiltInFailures..::..FabricFailures..::..CannotPlaceFabricSheet Property
BuiltInFailures..::..FabricFailures Class See Also Send Feedback
Can't find a host for Fabric Sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotPlaceFabricSheet { get; }
Visual Basic
Public Shared ReadOnly Property CannotPlaceFabricSheet As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPlaceFabricSheet {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FabricFailures Class


CannotPlaceFabricSheetWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..FabricFailures..::..CannotPlaceFabricSheetWarn Property
BuiltInFailures..::..FabricFailures Class See Also Send Feedback
Can't find a host for Fabric Sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotPlaceFabricSheetWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotPlaceFabricSheetWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPlaceFabricSheetWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FabricFailures Class


CoverOffsetTooLong Property

[image]

Revit 2024 API
BuiltInFailures..::..FabricFailures..::..CoverOffsetTooLong Property
BuiltInFailures..::..FabricFailures Class See Also Send Feedback
Cover offset is greater than host thickness.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CoverOffsetTooLong { get; }
Visual Basic
Public Shared ReadOnly Property CoverOffsetTooLong As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CoverOffsetTooLong {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FabricFailures Class


CoverOffsetTooLongTemp Property

[image]

Revit 2024 API
BuiltInFailures..::..FabricFailures..::..CoverOffsetTooLongTemp Property
BuiltInFailures..::..FabricFailures Class See Also Send Feedback
Cover offset is greater than host thickness - support for transient Single Fabric Sheet in editor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CoverOffsetTooLongTemp { get; }
Visual Basic
Public Shared ReadOnly Property CoverOffsetTooLongTemp As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CoverOffsetTooLongTemp {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FabricFailures Class


FabricAreaWrongHost Property

[image]

Revit 2024 API
BuiltInFailures..::..FabricFailures..::..FabricAreaWrongHost Property
BuiltInFailures..::..FabricFailures Class See Also Send Feedback
Fabric Area can be placed only in Structural Floors and straight Structural Walls.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FabricAreaWrongHost { get; }
Visual Basic
Public Shared ReadOnly Property FabricAreaWrongHost As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FabricAreaWrongHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FabricFailures Class


FabricAreaWrongLapSplice Property

[image]

Revit 2024 API
BuiltInFailures..::..FabricFailures..::..FabricAreaWrongLapSplice Property
BuiltInFailures..::..FabricFailures Class See Also Send Feedback
Fabric Area Sheet lap splice is incorrect. Can't create Fabric Area.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FabricAreaWrongLapSplice { get; }
Visual Basic
Public Shared ReadOnly Property FabricAreaWrongLapSplice As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FabricAreaWrongLapSplice {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FabricFailures Class


FabricSheetWrongHost Property

[image]

Revit 2024 API
BuiltInFailures..::..FabricFailures..::..FabricSheetWrongHost Property
BuiltInFailures..::..FabricFailures Class See Also Send Feedback
Fabric Sheet can be placed only in Structural Floors and straight Structural Walls.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FabricSheetWrongHost { get; }
Visual Basic
Public Shared ReadOnly Property FabricSheetWrongHost As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FabricSheetWrongHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FabricFailures Class


MajorLapSpliceFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..FabricFailures..::..MajorLapSpliceFailure Property
BuiltInFailures..::..FabricFailures Class See Also Send Feedback
The lap splice in the major direction is greater than the half of the overall length.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MajorLapSpliceFailure { get; }
Visual Basic
Public Shared ReadOnly Property MajorLapSpliceFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MajorLapSpliceFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FabricFailures Class


MajorSpacingFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..FabricFailures..::..MajorSpacingFailure Property
BuiltInFailures..::..FabricFailures Class See Also Send Feedback
The spacing in the major direction is lower than diameter of the wire in the minor direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MajorSpacingFailure { get; }
Visual Basic
Public Shared ReadOnly Property MajorSpacingFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MajorSpacingFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FabricFailures Class


MinorLapSpliceFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..FabricFailures..::..MinorLapSpliceFailure Property
BuiltInFailures..::..FabricFailures Class See Also Send Feedback
The lap splice in the minor direction is greater than the half of the overall width.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MinorLapSpliceFailure { get; }
Visual Basic
Public Shared ReadOnly Property MinorLapSpliceFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MinorLapSpliceFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FabricFailures Class


MinorOverhangFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..FabricFailures..::..MinorOverhangFailure Property
BuiltInFailures..::..FabricFailures Class See Also Send Feedback
At least one of the overhangs in the minor direction is lower than radius of the wire in the major direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MinorOverhangFailure { get; }
Visual Basic
Public Shared ReadOnly Property MinorOverhangFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MinorOverhangFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FabricFailures Class


MinorSpacingFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..FabricFailures..::..MinorSpacingFailure Property
BuiltInFailures..::..FabricFailures Class See Also Send Feedback
The spacing in the minor direction is lower than diameter of the wire in the major direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MinorSpacingFailure { get; }
Visual Basic
Public Shared ReadOnly Property MinorSpacingFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MinorSpacingFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FabricFailures Class


NoSurfPatternOnWire Property

[image]

Revit 2024 API
BuiltInFailures..::..FabricFailures..::..NoSurfPatternOnWire Property
BuiltInFailures..::..FabricFailures Class See Also Send Feedback
Wire elements do not support surface patterns. The surface pattern associated with this material will not be displayed on the indicated Fabric Sheet Type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoSurfPatternOnWire { get; }
Visual Basic
Public Shared ReadOnly Property NoSurfPatternOnWire As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoSurfPatternOnWire {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FabricFailures Class


WireDiameterTooLarge Property

[image]

Revit 2024 API
BuiltInFailures..::..FabricFailures..::..WireDiameterTooLarge Property
BuiltInFailures..::..FabricFailures Class See Also Send Feedback
Fabric Wire Diameter is too large.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WireDiameterTooLarge { get; }
Visual Basic
Public Shared ReadOnly Property WireDiameterTooLarge As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WireDiameterTooLarge {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FabricFailures Class


WrongFabricSheetOverallLength Property

[image]

Revit 2024 API
BuiltInFailures..::..FabricFailures..::..WrongFabricSheetOverallLength Property
BuiltInFailures..::..FabricFailures Class See Also Send Feedback
Wrong Overall Length/Width of the Fabric Sheet Type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WrongFabricSheetOverallLength { get; }
Visual Basic
Public Shared ReadOnly Property WrongFabricSheetOverallLength As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WrongFabricSheetOverallLength {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FabricFailures Class


WrongFabricSheetSpacing Property

[image]

Revit 2024 API
BuiltInFailures..::..FabricFailures..::..WrongFabricSheetSpacing Property
BuiltInFailures..::..FabricFailures Class See Also Send Feedback
Wrong Spacing of the Fabric Sheet Type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WrongFabricSheetSpacing { get; }
Visual Basic
Public Shared ReadOnly Property WrongFabricSheetSpacing As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WrongFabricSheetSpacing {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FabricFailures Class


WrongFabricSheetStartOverhang Property

[image]

Revit 2024 API
BuiltInFailures..::..FabricFailures..::..WrongFabricSheetStartOverhang Property
BuiltInFailures..::..FabricFailures Class See Also Send Feedback
Wrong Start Overhang of the Fabric Sheet Type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WrongFabricSheetStartOverhang { get; }
Visual Basic
Public Shared ReadOnly Property WrongFabricSheetStartOverhang As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WrongFabricSheetStartOverhang {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FabricFailures Class


BuiltInFailures.FabricSheetFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..FabricSheetFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures related to fabric sheet elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class FabricSheetFailures
Visual Basic
Public NotInheritable Class FabricSheetFailures
Visual C++
public ref class FabricSheetFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..FabricSheetFailures

See Also

BuiltInFailures..::..FabricSheetFailures Members


BuiltInFailures.FabricSheetFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..FabricSheetFailures Properties
BuiltInFailures..::..FabricSheetFailures Class See Also Send Feedback

The BuiltInFailures..::..FabricSheetFailures type exposes the following members.

Properties

Name | Description
BentFabricSheetTooLongBendingProfile | The bent edge is shorter than the bend profile for this fabric sheet type.
FabricSheetOutSideOfHostError | Fabric Sheet is placed completely outside of its host.
FabricSheetOutSideOfHostWarning | Fabric Sheet is placed completely outside of its host.

See Also

BuiltInFailures..::..FabricSheetFailures Class


BentFabricSheetTooLongBendingProfile Property

[image]

Revit 2024 API
BuiltInFailures..::..FabricSheetFailures..::..BentFabricSheetTooLongBendingProfile Property
BuiltInFailures..::..FabricSheetFailures Class See Also Send Feedback
The bent edge is shorter than the bend profile for this fabric sheet type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId BentFabricSheetTooLongBendingProfile { get; }
Visual Basic
Public Shared ReadOnly Property BentFabricSheetTooLongBendingProfile As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BentFabricSheetTooLongBendingProfile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FabricSheetFailures Class


FabricSheetOutSideOfHostError Property

[image]

Revit 2024 API
BuiltInFailures..::..FabricSheetFailures..::..FabricSheetOutSideOfHostError Property
BuiltInFailures..::..FabricSheetFailures Class See Also Send Feedback
Fabric Sheet is placed completely outside of its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FabricSheetOutSideOfHostError { get; }
Visual Basic
Public Shared ReadOnly Property FabricSheetOutSideOfHostError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FabricSheetOutSideOfHostError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FabricSheetFailures Class


FabricSheetOutSideOfHostWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..FabricSheetFailures..::..FabricSheetOutSideOfHostWarning Property
BuiltInFailures..::..FabricSheetFailures Class See Also Send Feedback
Fabric Sheet is placed completely outside of its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FabricSheetOutSideOfHostWarning { get; }
Visual Basic
Public Shared ReadOnly Property FabricSheetOutSideOfHostWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FabricSheetOutSideOfHostWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FabricSheetFailures Class


BuiltInFailures.FaceSplitterFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..FaceSplitterFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about FaceSplitter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class FaceSplitterFailures
Visual Basic
Public NotInheritable Class FaceSplitterFailures
Visual C++
public ref class FaceSplitterFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..FaceSplitterFailures

See Also

BuiltInFailures..::..FaceSplitterFailures Members


BuiltInFailures.FaceSplitterFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..FaceSplitterFailures Members
BuiltInFailures..::..FaceSplitterFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..FaceSplitterFailures type exposes the following members.

Properties

Name | Description
CannotUseCurvesForFaceSplit | The sketch cannot split the face of the highlighted element.
EndsNotOnEdgeError | Ends of an open loop in sketch splitting face do not lie on an edge of the face to split.
InvalidClosedLoopsForFaceSplit | The closed loop used to split the face must lie completely within the face and cannot intersect or overlap any of the face's edges. To split a face at its border, use an open loop that ends on the boundary of the face.
InvalidOpenLoopsForFaceSplit | The open loops used to split the face must lie completely within the face and cannot intersect or overlap any of the face's edges.
LoopsDoNotSubdivideFace | Sketched loops must sub-divide the face into two or more completely enclosed regions.
LoopsOutsideFaceSplitError | Some of the lines drawn lie outside of the boundary of the face being split. All lines used to split a face must be contained within the face being split and cannot intersect or overlap any of the boundaries of that face.
NoFaceForSplit | The highlighted element no longer contains a face that has been split by highlighted sketch.

See Also

BuiltInFailures..::..FaceSplitterFailures Class


BuiltInFailures.FaceSplitterFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..FaceSplitterFailures Properties
BuiltInFailures..::..FaceSplitterFailures Class See Also Send Feedback

The BuiltInFailures..::..FaceSplitterFailures type exposes the following members.

Properties

Name | Description
CannotUseCurvesForFaceSplit | The sketch cannot split the face of the highlighted element.
EndsNotOnEdgeError | Ends of an open loop in sketch splitting face do not lie on an edge of the face to split.
InvalidClosedLoopsForFaceSplit | The closed loop used to split the face must lie completely within the face and cannot intersect or overlap any of the face's edges. To split a face at its border, use an open loop that ends on the boundary of the face.
InvalidOpenLoopsForFaceSplit | The open loops used to split the face must lie completely within the face and cannot intersect or overlap any of the face's edges.
LoopsDoNotSubdivideFace | Sketched loops must sub-divide the face into two or more completely enclosed regions.
LoopsOutsideFaceSplitError | Some of the lines drawn lie outside of the boundary of the face being split. All lines used to split a face must be contained within the face being split and cannot intersect or overlap any of the boundaries of that face.
NoFaceForSplit | The highlighted element no longer contains a face that has been split by highlighted sketch.

See Also

BuiltInFailures..::..FaceSplitterFailures Class


CannotUseCurvesForFaceSplit Property

[image]

Revit 2024 API
BuiltInFailures..::..FaceSplitterFailures..::..CannotUseCurvesForFaceSplit Property
BuiltInFailures..::..FaceSplitterFailures Class See Also Send Feedback
The sketch cannot split the face of the highlighted element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotUseCurvesForFaceSplit { get; }
Visual Basic
Public Shared ReadOnly Property CannotUseCurvesForFaceSplit As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotUseCurvesForFaceSplit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FaceSplitterFailures Class


EndsNotOnEdgeError Property

[image]

Revit 2024 API
BuiltInFailures..::..FaceSplitterFailures..::..EndsNotOnEdgeError Property
BuiltInFailures..::..FaceSplitterFailures Class See Also Send Feedback
Ends of an open loop in sketch splitting face do not lie on an edge of the face to split.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId EndsNotOnEdgeError { get; }
Visual Basic
Public Shared ReadOnly Property EndsNotOnEdgeError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ EndsNotOnEdgeError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FaceSplitterFailures Class


InvalidOpenLoopsForFaceSplit Property

[image]

Revit 2024 API
BuiltInFailures..::..FaceSplitterFailures..::..InvalidOpenLoopsForFaceSplit Property
BuiltInFailures..::..FaceSplitterFailures Class See Also Send Feedback
The open loops used to split the face must lie completely within the face and cannot intersect or overlap any of the face's edges.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidOpenLoopsForFaceSplit { get; }
Visual Basic
Public Shared ReadOnly Property InvalidOpenLoopsForFaceSplit As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidOpenLoopsForFaceSplit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FaceSplitterFailures Class


LoopsDoNotSubdivideFace Property

[image]

Revit 2024 API
BuiltInFailures..::..FaceSplitterFailures..::..LoopsDoNotSubdivideFace Property
BuiltInFailures..::..FaceSplitterFailures Class See Also Send Feedback
Sketched loops must sub-divide the face into two or more completely enclosed regions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId LoopsDoNotSubdivideFace { get; }
Visual Basic
Public Shared ReadOnly Property LoopsDoNotSubdivideFace As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LoopsDoNotSubdivideFace {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FaceSplitterFailures Class


LoopsOutsideFaceSplitError Property

[image]

Revit 2024 API
BuiltInFailures..::..FaceSplitterFailures..::..LoopsOutsideFaceSplitError Property
BuiltInFailures..::..FaceSplitterFailures Class See Also Send Feedback
Some of the lines drawn lie outside of the boundary of the face being split. All lines used to split a face must be contained within the face being split and cannot intersect or overlap any of the boundaries of that face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId LoopsOutsideFaceSplitError { get; }
Visual Basic
Public Shared ReadOnly Property LoopsOutsideFaceSplitError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LoopsOutsideFaceSplitError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FaceSplitterFailures Class


NoFaceForSplit Property

[image]

Revit 2024 API
BuiltInFailures..::..FaceSplitterFailures..::..NoFaceForSplit Property
BuiltInFailures..::..FaceSplitterFailures Class See Also Send Feedback
The highlighted element no longer contains a face that has been split by highlighted sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoFaceForSplit { get; }
Visual Basic
Public Shared ReadOnly Property NoFaceForSplit As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoFaceForSplit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FaceSplitterFailures Class


BuiltInFailures.FamilyFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures related to families.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class FamilyFailures
Visual Basic
Public NotInheritable Class FamilyFailures
Visual C++
public ref class FamilyFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..FamilyFailures

See Also

BuiltInFailures..::..FamilyFailures Members


BuiltInFailures.FamilyFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures Properties
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback

The BuiltInFailures..::..FamilyFailures type exposes the following members.

Properties

Name | Description
CannotAddParameterToFamily | Parameter '[Parameter]' cannot be added to the family.
CannotChangeCategory | Can't change category of Family Instance
CannotChangeInstFam | Can't change Instance's Family. Try changing Instance's Host to a Level first.
CannotConvertInstHostToWorkPlane | Can't convert Instance's Host to Work Plane. Try resetting Host to a Level.
CannotConvertInstWorkPlaneToHost | Can't convert Instance's Work Plane to Host. Try resetting Work Plane to a Level.
CannotCopyByPatternFamilies | Can't copy between Mass or Curtain Panel by Pattern families, and other families or Revit projects.
CannotCopyInplaceFamily | In-place family groups cannot be copied between in-place families of the same project.
CannotCopyWatchCurveBasedFixture |
CannotCutRefPlane | Can't cut reference plane.
CannotFindHost | Couldn't find an appropriate Host. Try selecting a different Host Face or switch Placement Mode.
CannotLoadImperialFamilyToMetricProject | Can't load an imperial Family into a metric Project.
CannotLoadMetricFamilyToImperialProject | Can't load a metric Family into an imperial Project.
CannotMakeType |
CannotMakeTypeCB | Can't make type "[Family Name]".
CannotMakeTypeFamilySaved | Can't make type "[Family Name]". Failing family has been saved to "[File Name]"
CannotPasteLabelsAcrossFamilies | Can't paste Labels across Families of different Categories.
CannotPasteObject | Can't paste some or all of the selected objects.
CannotRegenerateCorruptFamily | Family [Family Name] is corrupt and its instances cannot be updated. Please reload the family to repair the project..
CannotRotateElement | Can't rotate element into this position.
CannotSetFamilyTypeToNone | Cannot set Family Type to 'None';.
CannotUnlockFamilyTemplate | Can't unlock alignments from Family Template.
CantCopySelectionToNonStory | Can't copy this selection to a non-story Level.
CantEditWhileGrouped | You may not edit this parameter while the element is grouped.
CantMirrorInstWoHost | Can't mirror an instance without its host.
CantMoveFrozenInstance | A family instance placed on a curved surface of a linked file can't be moved while the link is unloaded. To move the instance, reload the link or rehost the instance.
CantPasteSelection | Can't paste selection.
CantPlaceATOnDuctError | The air terminal cannot be placed in an elevation or section view unless it is attached to a duct.
CantPlaceInsertsError | Can't place inserts outside of hosts. These elements won't be copied.
CantPlaceInsertsWarning | Can't place inserts outside of hosts. These elements won't be copied.
CantPlaceInstanceError | Can't place instance of [Symbol]
CantPlaceInstanceWarning | Can't place instance of [Symbol]
CantSetSlantedColumnEndPlane | Unable to determine slanted column end cut plane.
CantSolve | Can't find solution for formulas for Type '[Type Name]'.
CircularRefsForInstParams | "Instance parameter '%1!s!' generates circular references."
ColumnAlreadyAttachedWillBeReattached | The column is already attached. It will be detached and attached to the new target.
ColumnAndTargetAlreadyJoined | The column and target are joined, remove that join before attaching them.
ColumnHeightZeroBecauseOfInvalidOffset | Change Offset Value so that Column height is not 0.0.
ColumnTooLong | This column is too long. Maximum length is 30,000 ft.
ContainsSharedSameNameFamily | Family '[Family Name]' contains a shared family of the same name. Please rename one of the two families before loading!
CouldNotGenerateReferencesForFamilyInstance | Could not generate references for Family Instance.
CouldNotPlaceAdaptiveFamInst | Could not place Adaptive Family Instance.
CustomFittingCreated | Custom fitting was created.
DeletingBadFamElemCorruption | Family contains invalid elements. They will be deleted.
DeletingBadFamElemError | Family contains invalid elements. They will be deleted.
DeletingBadFamType | Can't make type "[Family Name]". It will be deleted.
DeletingBadFamTypeDumped | Can't make type "[Family Name]". It will be deleted. Failing family has been saved to "[File Name]"
DummyHostMustBePerpendicularToXY | Dummy host must be perpendicular to Z or Y axis.
DuplicateFamilyParameterNameWithSharedParameter | Parameter '[Parameter]' has the same name with an existing shared parameter.
DuplicateParamName | Family parameters have duplicate names.
DuplicateTypeName | "Ignoring attempt to add family type '%1!s!' for a second time."
ElementTypeParameterized | The type(s) of the selected element(s) are driven by family parameter(s). Changing the type directly will break the association.
FailedToBecomeNonParametric | Family failed to become non-parametric!
FailedToSetParameters | Failed to apply family parameters.
FailedWhenLoadingFamily | Some unlocked labeled dimensions prevent family from loading. Please try to lock unlocked labeled dimensions and load again.
FamilyBadUnattachedVoids | Family '[Family Name]' contains unattached voids that can't be combined for cutting. Try fixing the voids or unset the Cut with Voids parameter in the family.
FamilyCannotBeUpgraded | "Family '[Name]' cannot be upgraded and must be deleted. To fix the file in the older version of Revit, try loading newer versions of these families: [Names]."
FamilyConnectorDeletedError | The family Connector has been modified so the connection is invalid.
FamilyConnectorDeletedWarning | The family Connector has been modified so the connection is invalid.
FamilyDoesntMatchSystemPropertiesDisconnected | The family no longer matches the properties for the System. Disconnect the family from the System?
FamilyIsCorruptError | Some families have become unusable. Reload the families, or delete them from the model.
FamilyIsCorruptWarning | Some families have become unusable. Reload the families, or delete them from the model.
FamilyMembersReferToOutsideFamily | Memebrs of Family '[Name]' or a nested family thereof illegally refer to Elements outside the family.
FamilyNoExternalParametersError | Family's Category can't be changed because the Family contains Shared Parameters which are not permitted in the new Category.
FamilyNoExternalParametersWarning | Family's Category can't be changed because the Family contains Shared Parameters which are not permitted in the new Category.
FamilyNotFitHostShape | The host shape has changed and the family is no longer appropriate.
FamilyOverconstraint | Dimension overconstrains the Family. Cannot set Family Type to <None>.
FamilyOverconstraintCB | Dimension overconstrains the Family.
FamilyParameterNoExist | The parameter [Name] doesn't exist in the Family. It will be ignored.
FamilyValidationResult | Family Validation Warning(s): [Description]
FormulaBasedParameterCannotBeChanged | Parameter '[Caption]' cannot be changed because it is defined by formula '[Formula]'
FormulasFailedForType | "Can't satisfy formulas for type [Family Symbol].
FrozenBecauseFaceGone | This family instance was hosted by a curved face that is no longer present in the linked file. To move the family instance, rehost it.
FrozenBecauseMonitorRelationshipGone | The position of this element was determined by copy/monitor but the monitor relationship has been removed. To move this instance, use pick new host to select a valid host.
HighlightedElementFamRefsInvalidError | One or more references of the highlighted element have become invalid.
HighlightedElementFamRefsInvalidWarning | One or more references of the highlighted element have become invalid.
InstMayCutMoreOrFewerHosts | Insert may be cutting fewer or more hosts than needed. The problem may be solved by forcing regeneration, e.g. by moving the insert out and back by a tiny distance in any direction.
InstOutsideFaceBoundary | Instance origin does not lie on host face. Instance will lose association to host.
InvalidContextForAdaptivePlacement | The component '%1!s!' cannot be directly placed in the project environment. Place it in either an In-Place Mass, a Conceptual Mass Family, a Curtain Panel by Pattern Family, or an Adaptive Component.
InvalidFamilyType | Invalid family type "[Type Name]".
InvalidFormularFoundInParameter | Invalid formular found in parameter '[Param Name]' in type '[Type Name]'.
InvalidInsertOrientation | The insert orientation is incompatible with the wall's cross-section.
InvalidParameterValue | Parameter [Caption] has an invalid value.
InvalidSlantedColumnOffsets | The column's base (Base Level + Base Offset) must be below its top (Top Level + Top Offset).
InvalidSlantedColumnOffsetsInNestedFamily | Instance of family [Family Name] can't be updated because in nested family the column's base (Base Level + Base Offset) must be below its top (Top Level + Top Offset).
MightntPlaceInsertsWarning | There exist geometry collision. These elements might not be copied.
NoInstparamFormulas | Instance Parameters can't be used in Type Parameter formulas.\n\n[Description]
NonGenericAnnotationsOutsideLegend | Only Generic Annotations may be copied between Legends and other Views
NotFamilyFile | The selected file is not a Family File.
ProfileContainsNoLoops | Profile type '[Family Symbol]' contains no loops.
ReferencePlanesOverconstrained | Reference Planes are overconstrained.
SetbackTooLarge | Setback computations are too large for this element.
SharedParameterReplacedByBuiltInOne | Shared parameter [Name] will be replaced by a built-in parameter with the same name. This may affect scheduling!
SizeLookupTableIsNotAvailableForType | Size Lookup Table is not available for type [Family Symbol].
SketchCannotBeAutomaticallyDimensioned | Sketch can't be Automatically Dimensioned - this is a prerequisite for Labeled Dimensions to work properly.
SlantedColumnEndCutPlaneIsParallelToGeometry | Cut plane of slanted column end is parallel to the location curve.
SlantedColumnEndPlanesHaveFlipped | Position of end cut planes has resulted in a slanted column without any geometry.
StructuralColumnAttachedToNonStructuralTarget | The structural column is attached to a non-structural target.
TitleblockBadViewType | Titleblocks can only be placed on sheets.
TryingToAttachWhenJoined | The column and target are joined. The attachment has been removed.
TypeRecursiveElementIdParameter | Type's parameter cannot recursively point to the type itself.
UnableGenerateTrussByFamilyAndOrientation | Revit is unable to generate a truss using the current Layout Family and Truss orientation.
UnableToUpgradeDueToCorruptFamilies | Some families have become unusable. Reload the families, or delete them from the model.
UnexpectedFamilyChangeResultsError | Changing the family for a MEP fitting might cause unexpected results.
UnexpectedFamilyChangeResultsWarning | Changing the family for a MEP fitting might cause unexpected results.
ValueOutOfRange | The value must be from 0.0 to 1.0
WhileLoadingFamily | While loading family '[Family Name]': [Description]
WhileLoadingFamilyShared | While loading shared family '[Family Name]' from family '[Family Name]': [Description]
WhileScanningParametersForType | While loading Type '[Name]', parameter '[Name]': [Description]

See Also

BuiltInFailures..::..FamilyFailures Class


CannotAddParameterToFamily Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..CannotAddParameterToFamily Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Parameter '[Parameter]' cannot be added to the family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotAddParameterToFamily { get; }
Visual Basic
Public Shared ReadOnly Property CannotAddParameterToFamily As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotAddParameterToFamily {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CannotChangeCategory Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..CannotChangeCategory Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Can't change category of Family Instance

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotChangeCategory { get; }
Visual Basic
Public Shared ReadOnly Property CannotChangeCategory As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotChangeCategory {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CannotChangeInstFam Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..CannotChangeInstFam Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Can't change Instance's Family. Try changing Instance's Host to a Level first.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotChangeInstFam { get; }
Visual Basic
Public Shared ReadOnly Property CannotChangeInstFam As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotChangeInstFam {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CannotConvertInstHostToWorkPlane Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..CannotConvertInstHostToWorkPlane Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Can't convert Instance's Host to Work Plane. Try resetting Host to a Level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotConvertInstHostToWorkPlane { get; }
Visual Basic
Public Shared ReadOnly Property CannotConvertInstHostToWorkPlane As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotConvertInstHostToWorkPlane {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CannotConvertInstWorkPlaneToHost Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..CannotConvertInstWorkPlaneToHost Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Can't convert Instance's Work Plane to Host. Try resetting Work Plane to a Level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotConvertInstWorkPlaneToHost { get; }
Visual Basic
Public Shared ReadOnly Property CannotConvertInstWorkPlaneToHost As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotConvertInstWorkPlaneToHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CannotCopyByPatternFamilies Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..CannotCopyByPatternFamilies Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Can't copy between Mass or Curtain Panel by Pattern families, and other families or Revit projects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCopyByPatternFamilies { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyByPatternFamilies As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyByPatternFamilies {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CannotCopyWatchCurveBasedFixture Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..CannotCopyWatchCurveBasedFixture Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCopyWatchCurveBasedFixture { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyWatchCurveBasedFixture As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyWatchCurveBasedFixture {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CannotCutRefPlane Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..CannotCutRefPlane Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Can't cut reference plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCutRefPlane { get; }
Visual Basic
Public Shared ReadOnly Property CannotCutRefPlane As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCutRefPlane {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CannotFindHost Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..CannotFindHost Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Couldn't find an appropriate Host. Try selecting a different Host Face or switch Placement Mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotFindHost { get; }
Visual Basic
Public Shared ReadOnly Property CannotFindHost As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotFindHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CannotLoadMetricFamilyToImperialProject Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..CannotLoadMetricFamilyToImperialProject Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Can't load a metric Family into an imperial Project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotLoadMetricFamilyToImperialProject { get; }
Visual Basic
Public Shared ReadOnly Property CannotLoadMetricFamilyToImperialProject As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotLoadMetricFamilyToImperialProject {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CannotMakeType Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..CannotMakeType Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotMakeType { get; }
Visual Basic
Public Shared ReadOnly Property CannotMakeType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMakeType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CannotMakeTypeCB Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..CannotMakeTypeCB Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Can't make type "[Family Name]".

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotMakeTypeCB { get; }
Visual Basic
Public Shared ReadOnly Property CannotMakeTypeCB As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMakeTypeCB {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CannotPasteLabelsAcrossFamilies Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..CannotPasteLabelsAcrossFamilies Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Can't paste Labels across Families of different Categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotPasteLabelsAcrossFamilies { get; }
Visual Basic
Public Shared ReadOnly Property CannotPasteLabelsAcrossFamilies As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPasteLabelsAcrossFamilies {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CannotPasteObject Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..CannotPasteObject Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Can't paste some or all of the selected objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotPasteObject { get; }
Visual Basic
Public Shared ReadOnly Property CannotPasteObject As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPasteObject {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CannotRegenerateCorruptFamily Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..CannotRegenerateCorruptFamily Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Family [Family Name] is corrupt and its instances cannot be updated. Please reload the family to repair the project..

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotRegenerateCorruptFamily { get; }
Visual Basic
Public Shared ReadOnly Property CannotRegenerateCorruptFamily As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotRegenerateCorruptFamily {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CannotUnlockFamilyTemplate Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..CannotUnlockFamilyTemplate Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Can't unlock alignments from Family Template.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotUnlockFamilyTemplate { get; }
Visual Basic
Public Shared ReadOnly Property CannotUnlockFamilyTemplate As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotUnlockFamilyTemplate {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CantCopySelectionToNonStory Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..CantCopySelectionToNonStory Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Can't copy this selection to a non-story Level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CantCopySelectionToNonStory { get; }
Visual Basic
Public Shared ReadOnly Property CantCopySelectionToNonStory As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CantCopySelectionToNonStory {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CantEditWhileGrouped Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..CantEditWhileGrouped Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
You may not edit this parameter while the element is grouped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CantEditWhileGrouped { get; }
Visual Basic
Public Shared ReadOnly Property CantEditWhileGrouped As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CantEditWhileGrouped {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CantMirrorInstWoHost Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..CantMirrorInstWoHost Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Can't mirror an instance without its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CantMirrorInstWoHost { get; }
Visual Basic
Public Shared ReadOnly Property CantMirrorInstWoHost As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CantMirrorInstWoHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CantMoveFrozenInstance Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..CantMoveFrozenInstance Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
A family instance placed on a curved surface of a linked file can't be moved while the link is unloaded. To move the instance, reload the link or rehost the instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CantMoveFrozenInstance { get; }
Visual Basic
Public Shared ReadOnly Property CantMoveFrozenInstance As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CantMoveFrozenInstance {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CantPasteSelection Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..CantPasteSelection Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Can't paste selection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CantPasteSelection { get; }
Visual Basic
Public Shared ReadOnly Property CantPasteSelection As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CantPasteSelection {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CantPlaceATOnDuctError Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..CantPlaceATOnDuctError Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
The air terminal cannot be placed in an elevation or section view unless it is attached to a duct.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CantPlaceATOnDuctError { get; }
Visual Basic
Public Shared ReadOnly Property CantPlaceATOnDuctError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CantPlaceATOnDuctError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CantPlaceInsertsWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..CantPlaceInsertsWarning Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Can't place inserts outside of hosts. These elements won't be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CantPlaceInsertsWarning { get; }
Visual Basic
Public Shared ReadOnly Property CantPlaceInsertsWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CantPlaceInsertsWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CantPlaceInstanceError Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..CantPlaceInstanceError Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Can't place instance of [Symbol]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CantPlaceInstanceError { get; }
Visual Basic
Public Shared ReadOnly Property CantPlaceInstanceError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CantPlaceInstanceError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CantSolve Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..CantSolve Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Can't find solution for formulas for Type '[Type Name]'.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CantSolve { get; }
Visual Basic
Public Shared ReadOnly Property CantSolve As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CantSolve {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


ColumnAlreadyAttachedWillBeReattached Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..ColumnAlreadyAttachedWillBeReattached Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
The column is already attached. It will be detached and attached to the new target.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ColumnAlreadyAttachedWillBeReattached { get; }
Visual Basic
Public Shared ReadOnly Property ColumnAlreadyAttachedWillBeReattached As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ColumnAlreadyAttachedWillBeReattached {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


ColumnAndTargetAlreadyJoined Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..ColumnAndTargetAlreadyJoined Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
The column and target are joined, remove that join before attaching them.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ColumnAndTargetAlreadyJoined { get; }
Visual Basic
Public Shared ReadOnly Property ColumnAndTargetAlreadyJoined As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ColumnAndTargetAlreadyJoined {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


ColumnHeightZeroBecauseOfInvalidOffset Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..ColumnHeightZeroBecauseOfInvalidOffset Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Change Offset Value so that Column height is not 0.0.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ColumnHeightZeroBecauseOfInvalidOffset { get; }
Visual Basic
Public Shared ReadOnly Property ColumnHeightZeroBecauseOfInvalidOffset As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ColumnHeightZeroBecauseOfInvalidOffset {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


ColumnTooLong Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..ColumnTooLong Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
This column is too long. Maximum length is 30,000 ft.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ColumnTooLong { get; }
Visual Basic
Public Shared ReadOnly Property ColumnTooLong As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ColumnTooLong {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


ContainsSharedSameNameFamily Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..ContainsSharedSameNameFamily Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Family '[Family Name]' contains a shared family of the same name. Please rename one of the two families before loading!

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ContainsSharedSameNameFamily { get; }
Visual Basic
Public Shared ReadOnly Property ContainsSharedSameNameFamily As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ContainsSharedSameNameFamily {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CouldNotGenerateReferencesForFamilyInstance Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..CouldNotGenerateReferencesForFamilyInstance Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Could not generate references for Family Instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CouldNotGenerateReferencesForFamilyInstance { get; }
Visual Basic
Public Shared ReadOnly Property CouldNotGenerateReferencesForFamilyInstance As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CouldNotGenerateReferencesForFamilyInstance {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CouldNotPlaceAdaptiveFamInst Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..CouldNotPlaceAdaptiveFamInst Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Could not place Adaptive Family Instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CouldNotPlaceAdaptiveFamInst { get; }
Visual Basic
Public Shared ReadOnly Property CouldNotPlaceAdaptiveFamInst As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CouldNotPlaceAdaptiveFamInst {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CustomFittingCreated Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..CustomFittingCreated Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Custom fitting was created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CustomFittingCreated { get; }
Visual Basic
Public Shared ReadOnly Property CustomFittingCreated As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CustomFittingCreated {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


DeletingBadFamElemCorruption Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..DeletingBadFamElemCorruption Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Family contains invalid elements. They will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DeletingBadFamElemCorruption { get; }
Visual Basic
Public Shared ReadOnly Property DeletingBadFamElemCorruption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DeletingBadFamElemCorruption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


DeletingBadFamType Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..DeletingBadFamType Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Can't make type "[Family Name]". It will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DeletingBadFamType { get; }
Visual Basic
Public Shared ReadOnly Property DeletingBadFamType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DeletingBadFamType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


DeletingBadFamTypeDumped Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..DeletingBadFamTypeDumped Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Can't make type "[Family Name]". It will be deleted. Failing family has been saved to "[File Name]"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DeletingBadFamTypeDumped { get; }
Visual Basic
Public Shared ReadOnly Property DeletingBadFamTypeDumped As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DeletingBadFamTypeDumped {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


DuplicateFamilyParameterNameWithSharedParameter Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..DuplicateFamilyParameterNameWithSharedParameter Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Parameter '[Parameter]' has the same name with an existing shared parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DuplicateFamilyParameterNameWithSharedParameter { get; }
Visual Basic
Public Shared ReadOnly Property DuplicateFamilyParameterNameWithSharedParameter As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DuplicateFamilyParameterNameWithSharedParameter {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


DuplicateParamName Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..DuplicateParamName Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Family parameters have duplicate names.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DuplicateParamName { get; }
Visual Basic
Public Shared ReadOnly Property DuplicateParamName As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DuplicateParamName {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


ElementTypeParameterized Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..ElementTypeParameterized Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
The type(s) of the selected element(s) are driven by family parameter(s). Changing the type directly will break the association.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ElementTypeParameterized { get; }
Visual Basic
Public Shared ReadOnly Property ElementTypeParameterized As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementTypeParameterized {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


FailedToBecomeNonParametric Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..FailedToBecomeNonParametric Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Family failed to become non-parametric!

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FailedToBecomeNonParametric { get; }
Visual Basic
Public Shared ReadOnly Property FailedToBecomeNonParametric As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FailedToBecomeNonParametric {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


FamilyBadUnattachedVoids Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..FamilyBadUnattachedVoids Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Family '[Family Name]' contains unattached voids that can't be combined for cutting. Try fixing the voids or unset the Cut with Voids parameter in the family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FamilyBadUnattachedVoids { get; }
Visual Basic
Public Shared ReadOnly Property FamilyBadUnattachedVoids As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FamilyBadUnattachedVoids {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


FamilyCannotBeUpgraded Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..FamilyCannotBeUpgraded Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
"Family '[Name]' cannot be upgraded and must be deleted. To fix the file in the older version of Revit, try loading newer versions of these families: [Names]."

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FamilyCannotBeUpgraded { get; }
Visual Basic
Public Shared ReadOnly Property FamilyCannotBeUpgraded As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FamilyCannotBeUpgraded {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


FamilyConnectorDeletedError Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..FamilyConnectorDeletedError Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
The family Connector has been modified so the connection is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FamilyConnectorDeletedError { get; }
Visual Basic
Public Shared ReadOnly Property FamilyConnectorDeletedError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FamilyConnectorDeletedError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


FamilyConnectorDeletedWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..FamilyConnectorDeletedWarning Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
The family Connector has been modified so the connection is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FamilyConnectorDeletedWarning { get; }
Visual Basic
Public Shared ReadOnly Property FamilyConnectorDeletedWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FamilyConnectorDeletedWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


FamilyMembersReferToOutsideFamily Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..FamilyMembersReferToOutsideFamily Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Memebrs of Family '[Name]' or a nested family thereof illegally refer to Elements outside the family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FamilyMembersReferToOutsideFamily { get; }
Visual Basic
Public Shared ReadOnly Property FamilyMembersReferToOutsideFamily As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FamilyMembersReferToOutsideFamily {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


FamilyNoExternalParametersError Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..FamilyNoExternalParametersError Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Family's Category can't be changed because the Family contains Shared Parameters which are not permitted in the new Category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FamilyNoExternalParametersError { get; }
Visual Basic
Public Shared ReadOnly Property FamilyNoExternalParametersError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FamilyNoExternalParametersError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


FamilyNoExternalParametersWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..FamilyNoExternalParametersWarning Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Family's Category can't be changed because the Family contains Shared Parameters which are not permitted in the new Category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FamilyNoExternalParametersWarning { get; }
Visual Basic
Public Shared ReadOnly Property FamilyNoExternalParametersWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FamilyNoExternalParametersWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


FamilyNotFitHostShape Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..FamilyNotFitHostShape Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
The host shape has changed and the family is no longer appropriate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FamilyNotFitHostShape { get; }
Visual Basic
Public Shared ReadOnly Property FamilyNotFitHostShape As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FamilyNotFitHostShape {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


FamilyOverconstraint Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..FamilyOverconstraint Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Dimension overconstrains the Family. Cannot set Family Type to <None>.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FamilyOverconstraint { get; }
Visual Basic
Public Shared ReadOnly Property FamilyOverconstraint As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FamilyOverconstraint {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


FamilyOverconstraintCB Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..FamilyOverconstraintCB Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Dimension overconstrains the Family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FamilyOverconstraintCB { get; }
Visual Basic
Public Shared ReadOnly Property FamilyOverconstraintCB As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FamilyOverconstraintCB {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


FamilyParameterNoExist Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..FamilyParameterNoExist Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
The parameter [Name] doesn't exist in the Family. It will be ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FamilyParameterNoExist { get; }
Visual Basic
Public Shared ReadOnly Property FamilyParameterNoExist As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FamilyParameterNoExist {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


FamilyValidationResult Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..FamilyValidationResult Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Family Validation Warning(s): [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FamilyValidationResult { get; }
Visual Basic
Public Shared ReadOnly Property FamilyValidationResult As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FamilyValidationResult {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


FormulaBasedParameterCannotBeChanged Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..FormulaBasedParameterCannotBeChanged Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Parameter '[Caption]' cannot be changed because it is defined by formula '[Formula]'

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FormulaBasedParameterCannotBeChanged { get; }
Visual Basic
Public Shared ReadOnly Property FormulaBasedParameterCannotBeChanged As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FormulaBasedParameterCannotBeChanged {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


FrozenBecauseFaceGone Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..FrozenBecauseFaceGone Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
This family instance was hosted by a curved face that is no longer present in the linked file. To move the family instance, rehost it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FrozenBecauseFaceGone { get; }
Visual Basic
Public Shared ReadOnly Property FrozenBecauseFaceGone As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FrozenBecauseFaceGone {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


FrozenBecauseMonitorRelationshipGone Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..FrozenBecauseMonitorRelationshipGone Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
The position of this element was determined by copy/monitor but the monitor relationship has been removed. To move this instance, use pick new host to select a valid host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FrozenBecauseMonitorRelationshipGone { get; }
Visual Basic
Public Shared ReadOnly Property FrozenBecauseMonitorRelationshipGone As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FrozenBecauseMonitorRelationshipGone {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


HighlightedElementFamRefsInvalidError Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..HighlightedElementFamRefsInvalidError Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
One or more references of the highlighted element have become invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId HighlightedElementFamRefsInvalidError { get; }
Visual Basic
Public Shared ReadOnly Property HighlightedElementFamRefsInvalidError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HighlightedElementFamRefsInvalidError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


HighlightedElementFamRefsInvalidWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..HighlightedElementFamRefsInvalidWarning Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
One or more references of the highlighted element have become invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId HighlightedElementFamRefsInvalidWarning { get; }
Visual Basic
Public Shared ReadOnly Property HighlightedElementFamRefsInvalidWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HighlightedElementFamRefsInvalidWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


InstMayCutMoreOrFewerHosts Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..InstMayCutMoreOrFewerHosts Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Insert may be cutting fewer or more hosts than needed. The problem may be solved by forcing regeneration, e.g. by moving the insert out and back by a tiny distance in any direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InstMayCutMoreOrFewerHosts { get; }
Visual Basic
Public Shared ReadOnly Property InstMayCutMoreOrFewerHosts As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InstMayCutMoreOrFewerHosts {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


InstOutsideFaceBoundary Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..InstOutsideFaceBoundary Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Instance origin does not lie on host face. Instance will lose association to host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InstOutsideFaceBoundary { get; }
Visual Basic
Public Shared ReadOnly Property InstOutsideFaceBoundary As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InstOutsideFaceBoundary {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


InvalidContextForAdaptivePlacement Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..InvalidContextForAdaptivePlacement Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
The component '%1!s!' cannot be directly placed in the project environment. Place it in either an In-Place Mass, a Conceptual Mass Family, a Curtain Panel by Pattern Family, or an Adaptive Component.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidContextForAdaptivePlacement { get; }
Visual Basic
Public Shared ReadOnly Property InvalidContextForAdaptivePlacement As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidContextForAdaptivePlacement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


InvalidInsertOrientation Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..InvalidInsertOrientation Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
The insert orientation is incompatible with the wall's cross-section.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidInsertOrientation { get; }
Visual Basic
Public Shared ReadOnly Property InvalidInsertOrientation As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidInsertOrientation {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


InvalidParameterValue Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..InvalidParameterValue Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Parameter [Caption] has an invalid value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidParameterValue { get; }
Visual Basic
Public Shared ReadOnly Property InvalidParameterValue As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidParameterValue {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


InvalidSlantedColumnOffsetsInNestedFamily Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..InvalidSlantedColumnOffsetsInNestedFamily Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Instance of family [Family Name] can't be updated because in nested family the column's base (Base Level + Base Offset) must be below its top (Top Level + Top Offset).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidSlantedColumnOffsetsInNestedFamily { get; }
Visual Basic
Public Shared ReadOnly Property InvalidSlantedColumnOffsetsInNestedFamily As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidSlantedColumnOffsetsInNestedFamily {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


MightntPlaceInsertsWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..MightntPlaceInsertsWarning Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
There exist geometry collision. These elements might not be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MightntPlaceInsertsWarning { get; }
Visual Basic
Public Shared ReadOnly Property MightntPlaceInsertsWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MightntPlaceInsertsWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


NonGenericAnnotationsOutsideLegend Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..NonGenericAnnotationsOutsideLegend Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Only Generic Annotations may be copied between Legends and other Views

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NonGenericAnnotationsOutsideLegend { get; }
Visual Basic
Public Shared ReadOnly Property NonGenericAnnotationsOutsideLegend As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NonGenericAnnotationsOutsideLegend {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


NotFamilyFile Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..NotFamilyFile Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
The selected file is not a Family File.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NotFamilyFile { get; }
Visual Basic
Public Shared ReadOnly Property NotFamilyFile As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotFamilyFile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


ProfileContainsNoLoops Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..ProfileContainsNoLoops Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Profile type '[Family Symbol]' contains no loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ProfileContainsNoLoops { get; }
Visual Basic
Public Shared ReadOnly Property ProfileContainsNoLoops As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ProfileContainsNoLoops {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


ReferencePlanesOverconstrained Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..ReferencePlanesOverconstrained Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Reference Planes are overconstrained.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ReferencePlanesOverconstrained { get; }
Visual Basic
Public Shared ReadOnly Property ReferencePlanesOverconstrained As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ReferencePlanesOverconstrained {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


SetbackTooLarge Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..SetbackTooLarge Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Setback computations are too large for this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SetbackTooLarge { get; }
Visual Basic
Public Shared ReadOnly Property SetbackTooLarge As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SetbackTooLarge {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


SharedParameterReplacedByBuiltInOne Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..SharedParameterReplacedByBuiltInOne Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Shared parameter [Name] will be replaced by a built-in parameter with the same name. This may affect scheduling!

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SharedParameterReplacedByBuiltInOne { get; }
Visual Basic
Public Shared ReadOnly Property SharedParameterReplacedByBuiltInOne As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SharedParameterReplacedByBuiltInOne {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


SizeLookupTableIsNotAvailableForType Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..SizeLookupTableIsNotAvailableForType Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Size Lookup Table is not available for type [Family Symbol].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SizeLookupTableIsNotAvailableForType { get; }
Visual Basic
Public Shared ReadOnly Property SizeLookupTableIsNotAvailableForType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SizeLookupTableIsNotAvailableForType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


SlantedColumnEndCutPlaneIsParallelToGeometry Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..SlantedColumnEndCutPlaneIsParallelToGeometry Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Cut plane of slanted column end is parallel to the location curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SlantedColumnEndCutPlaneIsParallelToGeometry { get; }
Visual Basic
Public Shared ReadOnly Property SlantedColumnEndCutPlaneIsParallelToGeometry As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SlantedColumnEndCutPlaneIsParallelToGeometry {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


SlantedColumnEndPlanesHaveFlipped Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..SlantedColumnEndPlanesHaveFlipped Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Position of end cut planes has resulted in a slanted column without any geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SlantedColumnEndPlanesHaveFlipped { get; }
Visual Basic
Public Shared ReadOnly Property SlantedColumnEndPlanesHaveFlipped As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SlantedColumnEndPlanesHaveFlipped {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


StructuralColumnAttachedToNonStructuralTarget Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..StructuralColumnAttachedToNonStructuralTarget Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
The structural column is attached to a non-structural target.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StructuralColumnAttachedToNonStructuralTarget { get; }
Visual Basic
Public Shared ReadOnly Property StructuralColumnAttachedToNonStructuralTarget As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StructuralColumnAttachedToNonStructuralTarget {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


TryingToAttachWhenJoined Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..TryingToAttachWhenJoined Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
The column and target are joined. The attachment has been removed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId TryingToAttachWhenJoined { get; }
Visual Basic
Public Shared ReadOnly Property TryingToAttachWhenJoined As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TryingToAttachWhenJoined {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


TypeRecursiveElementIdParameter Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..TypeRecursiveElementIdParameter Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Type's parameter cannot recursively point to the type itself.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId TypeRecursiveElementIdParameter { get; }
Visual Basic
Public Shared ReadOnly Property TypeRecursiveElementIdParameter As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TypeRecursiveElementIdParameter {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


UnableGenerateTrussByFamilyAndOrientation Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..UnableGenerateTrussByFamilyAndOrientation Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Revit is unable to generate a truss using the current Layout Family and Truss orientation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UnableGenerateTrussByFamilyAndOrientation { get; }
Visual Basic
Public Shared ReadOnly Property UnableGenerateTrussByFamilyAndOrientation As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableGenerateTrussByFamilyAndOrientation {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


UnexpectedFamilyChangeResultsError Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..UnexpectedFamilyChangeResultsError Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Changing the family for a MEP fitting might cause unexpected results.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UnexpectedFamilyChangeResultsError { get; }
Visual Basic
Public Shared ReadOnly Property UnexpectedFamilyChangeResultsError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnexpectedFamilyChangeResultsError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


UnexpectedFamilyChangeResultsWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..UnexpectedFamilyChangeResultsWarning Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Changing the family for a MEP fitting might cause unexpected results.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UnexpectedFamilyChangeResultsWarning { get; }
Visual Basic
Public Shared ReadOnly Property UnexpectedFamilyChangeResultsWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnexpectedFamilyChangeResultsWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


WhileLoadingFamily Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..WhileLoadingFamily Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
While loading family '[Family Name]': [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WhileLoadingFamily { get; }
Visual Basic
Public Shared ReadOnly Property WhileLoadingFamily As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WhileLoadingFamily {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


WhileLoadingFamilyShared Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..WhileLoadingFamilyShared Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
While loading shared family '[Family Name]' from family '[Family Name]': [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WhileLoadingFamilyShared { get; }
Visual Basic
Public Shared ReadOnly Property WhileLoadingFamilyShared As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WhileLoadingFamilyShared {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


WhileScanningParametersForType Property

[image]

Revit 2024 API
BuiltInFailures..::..FamilyFailures..::..WhileScanningParametersForType Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
While loading Type '[Name]', parameter '[Name]': [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WhileScanningParametersForType { get; }
Visual Basic
Public Shared ReadOnly Property WhileScanningParametersForType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WhileScanningParametersForType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


BuiltInFailures.FilledRegionFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..FilledRegionFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about FilledRegion.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class FilledRegionFailures
Visual Basic
Public NotInheritable Class FilledRegionFailures
Visual C++
public ref class FilledRegionFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..FilledRegionFailures

See Also

BuiltInFailures..::..FilledRegionFailures Members


BuiltInFailures.FilledRegionFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..FilledRegionFailures Members
BuiltInFailures..::..FilledRegionFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..FilledRegionFailures type exposes the following members.

Properties

Name | Description
BadViewType | [Filled Region Name] can't be placed in 3D Views.
CannotDrawFilledRegion | Can't draw [Filled Region Name].
CannotDrawFilledRegionError | Can't draw [Filled Region Name].

See Also

BuiltInFailures..::..FilledRegionFailures Class


BuiltInFailures.FilledRegionFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..FilledRegionFailures Properties
BuiltInFailures..::..FilledRegionFailures Class See Also Send Feedback

The BuiltInFailures..::..FilledRegionFailures type exposes the following members.

Properties

Name | Description
BadViewType | [Filled Region Name] can't be placed in 3D Views.
CannotDrawFilledRegion | Can't draw [Filled Region Name].
CannotDrawFilledRegionError | Can't draw [Filled Region Name].

See Also

BuiltInFailures..::..FilledRegionFailures Class


CannotDrawFilledRegion Property

[image]

Revit 2024 API
BuiltInFailures..::..FilledRegionFailures..::..CannotDrawFilledRegion Property
BuiltInFailures..::..FilledRegionFailures Class See Also Send Feedback
Can't draw [Filled Region Name].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotDrawFilledRegion { get; }
Visual Basic
Public Shared ReadOnly Property CannotDrawFilledRegion As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDrawFilledRegion {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FilledRegionFailures Class


CannotDrawFilledRegionError Property

[image]

Revit 2024 API
BuiltInFailures..::..FilledRegionFailures..::..CannotDrawFilledRegionError Property
BuiltInFailures..::..FilledRegionFailures Class See Also Send Feedback
Can't draw [Filled Region Name].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotDrawFilledRegionError { get; }
Visual Basic
Public Shared ReadOnly Property CannotDrawFilledRegionError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDrawFilledRegionError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FilledRegionFailures Class


BuiltInFailures.FloorFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..FloorFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures related to floors and slabs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class FloorFailures
Visual Basic
Public NotInheritable Class FloorFailures
Visual C++
public ref class FloorFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..FloorFailures

See Also

BuiltInFailures..::..FloorFailures Members


BuiltInFailures.FloorFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..FloorFailures Members
BuiltInFailures..::..FloorFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..FloorFailures type exposes the following members.

Properties

Name | Description
FloorSlopeExceedsThreshold | Thickness of this Floor may be slightly inaccurate due to extreme Shape Editing. Dimensions to this element in sections and details may not accurately indicate the Thickness shown in Type Properties.

See Also

BuiltInFailures..::..FloorFailures Class


BuiltInFailures.FloorFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..FloorFailures Properties
BuiltInFailures..::..FloorFailures Class See Also Send Feedback

The BuiltInFailures..::..FloorFailures type exposes the following members.

Properties

Name | Description
FloorSlopeExceedsThreshold | Thickness of this Floor may be slightly inaccurate due to extreme Shape Editing. Dimensions to this element in sections and details may not accurately indicate the Thickness shown in Type Properties.

See Also

BuiltInFailures..::..FloorFailures Class


FloorSlopeExceedsThreshold Property

[image]

Revit 2024 API
BuiltInFailures..::..FloorFailures..::..FloorSlopeExceedsThreshold Property
BuiltInFailures..::..FloorFailures Class See Also Send Feedback
Thickness of this Floor may be slightly inaccurate due to extreme Shape Editing. Dimensions to this element in sections and details may not accurately indicate the Thickness shown in Type Properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FloorSlopeExceedsThreshold { get; }
Visual Basic
Public Shared ReadOnly Property FloorSlopeExceedsThreshold As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FloorSlopeExceedsThreshold {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FloorFailures Class


BuiltInFailures.FluidFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..FluidFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Fluid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class FluidFailures
Visual Basic
Public NotInheritable Class FluidFailures
Visual C++
public ref class FluidFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..FluidFailures

See Also

BuiltInFailures..::..FluidFailures Members


BuiltInFailures.FluidFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..FluidFailures Properties
BuiltInFailures..::..FluidFailures Class See Also Send Feedback

The BuiltInFailures..::..FluidFailures type exposes the following members.

Properties

Name | Description
UndefinedFluidType | The fluid type '[Type Name]' is not defined

See Also

BuiltInFailures..::..FluidFailures Class


UndefinedFluidType Property

[image]

Revit 2024 API
BuiltInFailures..::..FluidFailures..::..UndefinedFluidType Property
BuiltInFailures..::..FluidFailures Class See Also Send Feedback
The fluid type '[Type Name]' is not defined

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UndefinedFluidType { get; }
Visual Basic
Public Shared ReadOnly Property UndefinedFluidType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UndefinedFluidType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FluidFailures Class


BuiltInFailures.ForeignFileFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..ForeignFileFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about files saved by applications that were not developed or licensed by Autodesk.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class ForeignFileFailures
Visual Basic
Public NotInheritable Class ForeignFileFailures
Visual C++
public ref class ForeignFileFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..ForeignFileFailures

See Also

BuiltInFailures..::..ForeignFileFailures Members


BuiltInFailures.ForeignFileFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..ForeignFileFailures Members
BuiltInFailures..::..ForeignFileFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..ForeignFileFailures type exposes the following members.

Properties

Name | Description
ForeignFile | This file [FamilyName] was saved by an application that was not developed or licensed by Autodesk.
ForeignLink | This file [RvtLinkName] was saved by an application that was not developed or licensed by Autodesk.

See Also

BuiltInFailures..::..ForeignFileFailures Class


BuiltInFailures.ForeignFileFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..ForeignFileFailures Properties
BuiltInFailures..::..ForeignFileFailures Class See Also Send Feedback

The BuiltInFailures..::..ForeignFileFailures type exposes the following members.

Properties

Name | Description
ForeignFile | This file [FamilyName] was saved by an application that was not developed or licensed by Autodesk.
ForeignLink | This file [RvtLinkName] was saved by an application that was not developed or licensed by Autodesk.

See Also

BuiltInFailures..::..ForeignFileFailures Class


ForeignFile Property

[image]

Revit 2024 API
BuiltInFailures..::..ForeignFileFailures..::..ForeignFile Property
BuiltInFailures..::..ForeignFileFailures Class See Also Send Feedback
This file [FamilyName] was saved by an application that was not developed or licensed by Autodesk.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ForeignFile { get; }
Visual Basic
Public Shared ReadOnly Property ForeignFile As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ForeignFile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ForeignFileFailures Class


ForeignLink Property

[image]

Revit 2024 API
BuiltInFailures..::..ForeignFileFailures..::..ForeignLink Property
BuiltInFailures..::..ForeignFileFailures Class See Also Send Feedback
This file [RvtLinkName] was saved by an application that was not developed or licensed by Autodesk.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ForeignLink { get; }
Visual Basic
Public Shared ReadOnly Property ForeignLink As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ForeignLink {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ForeignFileFailures Class


BuiltInFailures.FormFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..FormFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class FormFailures
Visual Basic
Public NotInheritable Class FormFailures
Visual C++
public ref class FormFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..FormFailures

See Also

BuiltInFailures..::..FormFailures Members


BuiltInFailures.FormFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..FormFailures Members
BuiltInFailures..::..FormFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..FormFailures type exposes the following members.

Properties

Name | Description
AddProfileFailure | Failed to Add Profile
DissolveNoValidInputs | No form elements selected to dissolve.
DissolveUnableToDissolveForm | Unable to dissolve form element.
FormCreationInvalidGeomCombination | Cannot remake form that is currently cut or joined to other geometry. Please uncut or unjoin first.
FormElemRegenFailure | Unable to create form element
FormElemRegenFailureError | Unable to create form element
FormElemRegenSelfIntersection | Unable to create form element: self-intersecting or singular geometry would result.
FormElemRegenSelfIntersectionReorderProfiles | This form cannot be created due to self-intersecting geometry. Clicking the Reorder Profiles button will attempt to solve this problem.
FormElemRegenSelfIntersectionResetConnections | This form cannot be created due to self-intersecting geometry. Clicking the Reset Connections button will attempt to solve this problem.
OpenProfileMultiSegmentSweepsNotSupported | An open profile cannot be swept along a multi-segment path.
VoidFormsNotUsed | Some Void Forms of this family do not cut anything and will be deleted. To make a Void Form cut something else use the Cut Geometry tool.

See Also

BuiltInFailures..::..FormFailures Class


AddProfileFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..FormFailures..::..AddProfileFailure Property
BuiltInFailures..::..FormFailures Class See Also Send Feedback
Failed to Add Profile

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AddProfileFailure { get; }
Visual Basic
Public Shared ReadOnly Property AddProfileFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AddProfileFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FormFailures Class


DissolveNoValidInputs Property

[image]

Revit 2024 API
BuiltInFailures..::..FormFailures..::..DissolveNoValidInputs Property
BuiltInFailures..::..FormFailures Class See Also Send Feedback
No form elements selected to dissolve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DissolveNoValidInputs { get; }
Visual Basic
Public Shared ReadOnly Property DissolveNoValidInputs As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DissolveNoValidInputs {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FormFailures Class


DissolveUnableToDissolveForm Property

[image]

Revit 2024 API
BuiltInFailures..::..FormFailures..::..DissolveUnableToDissolveForm Property
BuiltInFailures..::..FormFailures Class See Also Send Feedback
Unable to dissolve form element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DissolveUnableToDissolveForm { get; }
Visual Basic
Public Shared ReadOnly Property DissolveUnableToDissolveForm As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DissolveUnableToDissolveForm {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FormFailures Class


FormCreationInvalidGeomCombination Property

[image]

Revit 2024 API
BuiltInFailures..::..FormFailures..::..FormCreationInvalidGeomCombination Property
BuiltInFailures..::..FormFailures Class See Also Send Feedback
Cannot remake form that is currently cut or joined to other geometry. Please uncut or unjoin first.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FormCreationInvalidGeomCombination { get; }
Visual Basic
Public Shared ReadOnly Property FormCreationInvalidGeomCombination As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FormCreationInvalidGeomCombination {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FormFailures Class


FormElemRegenFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..FormFailures..::..FormElemRegenFailure Property
BuiltInFailures..::..FormFailures Class See Also Send Feedback
Unable to create form element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FormElemRegenFailure { get; }
Visual Basic
Public Shared ReadOnly Property FormElemRegenFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FormElemRegenFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FormFailures Class


FormElemRegenFailureError Property

[image]

Revit 2024 API
BuiltInFailures..::..FormFailures..::..FormElemRegenFailureError Property
BuiltInFailures..::..FormFailures Class See Also Send Feedback
Unable to create form element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FormElemRegenFailureError { get; }
Visual Basic
Public Shared ReadOnly Property FormElemRegenFailureError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FormElemRegenFailureError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FormFailures Class


FormElemRegenSelfIntersection Property

[image]

Revit 2024 API
BuiltInFailures..::..FormFailures..::..FormElemRegenSelfIntersection Property
BuiltInFailures..::..FormFailures Class See Also Send Feedback
Unable to create form element: self-intersecting or singular geometry would result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FormElemRegenSelfIntersection { get; }
Visual Basic
Public Shared ReadOnly Property FormElemRegenSelfIntersection As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FormElemRegenSelfIntersection {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FormFailures Class


FormElemRegenSelfIntersectionResetConnections Property

[image]

Revit 2024 API
BuiltInFailures..::..FormFailures..::..FormElemRegenSelfIntersectionResetConnections Property
BuiltInFailures..::..FormFailures Class See Also Send Feedback
This form cannot be created due to self-intersecting geometry. Clicking the Reset Connections button will attempt to solve this problem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FormElemRegenSelfIntersectionResetConnections { get; }
Visual Basic
Public Shared ReadOnly Property FormElemRegenSelfIntersectionResetConnections As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FormElemRegenSelfIntersectionResetConnections {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FormFailures Class


VoidFormsNotUsed Property

[image]

Revit 2024 API
BuiltInFailures..::..FormFailures..::..VoidFormsNotUsed Property
BuiltInFailures..::..FormFailures Class See Also Send Feedback
Some Void Forms of this family do not cut anything and will be deleted. To make a Void Form cut something else use the Cut Geometry tool.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId VoidFormsNotUsed { get; }
Visual Basic
Public Shared ReadOnly Property VoidFormsNotUsed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ VoidFormsNotUsed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FormFailures Class


BuiltInFailures.GeneralFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..GeneralFailures Members
BuiltInFailures..::..GeneralFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..GeneralFailures type exposes the following members.

Properties

Name | Description
CannotFixProblem | Failed to fix problem. Action has to be cancelled.
CannotSetParameter | Cant set parameter
CharactersNotAllowed | Name cannot contain any of the following characters:\n[{}[]|;<>?`~]\nor any of the non-printable characters.
ContentDocTreeCorruption | Problems with the Content Doc Tree structure - e.g. orphaned Content Docs, Families w/o docs, missing Owner Fam, what-not
ConvertingOldAxisToNormal | This operation will convert the existing axis of revolution to a normal line.
CoreElemTestingError | Core element testing error (internal).
DuplicateValue | Elements have duplicate '[Value]' values.
EnterNonNegativeValue | Enter a non-negative value.
EnterValidRealGreaterThan | Enter a number greater than [Value].
EnterValueBetween | Please enter a value between [Value] and [Value].
ErrorInFamilyResolved | An error occurred in family "[Name]" and was automatically resolved. Please review changes made to the family.\nError Information:\n"[Text]"\nError Resolution: [Resolution]
ErrorInSymbolFamilyResolved | An error occurred in family "[Name]" and was automatically resolved, but may require review by the family creator.\nError Information:\n"[Text]"\nError Resolution: [Resolution]
ErrorResolved | Error "[Text]" was automatically resolved by "[Resolution]"
FailedToOpenFile | Failed to open file.
FailedToReadLine | Failed to read line.
FamilySeparationTestingError | Family separation testing error (internal).
GenericCorruption | A generic error has occurred.
GenericError | Error.
GenericErrorNone | None.
GenericFatalError | A fatal error has occurred. The application will be terminated. You will be given the opportunity to save recovery files for all of your changed projects.\tWould you like to save a recovery file for [Project Name]?
GenericNonFatalError | A serious error has occurred. It is strongly recommended that you use Save As to save your work in a new file before continuing.
GenericWarning | A generic error has occurred.
InaccuracyDetected | A geometric inaccuracy was found in the element.
InternalProblemsParameter | Parameter cannot be changed due to internal problems.
InvalidInput | Invalid Input
InvalidInputWarn | Invalid Input
InvalidOrderOfPhases | Invalid order of phases: [Type Name] cannot be demolished before it was created.
InvalidValue | Invalid value.
NameInUse | The name "[Name]" is already in use.
NameIsEmpty | Name is empty
NameNotUnique | The name entered is already in use. Enter a unique name.
NoRelatedWarnings | Document doesn't contain any warnings related to these elements.
ParameterValueNotInRange | The value for [Parameter Name] must be between [Value] and [Value].
ParameterValuesConflict | The value for [Parameter Name] must be at least [Value] below the value for [Parameter Name].
SeriousElementReferenceCorruption | Element references are seriously corrupt.
TransactionFailed | [Description]
TransactionFailedWarn | [Description]
UnresolvableErrorInFamily | An error occurred in family "[Name]" that cannot be automatically resolved.\nError Information:\n"[Text]"
UnresolvableErrorInFamilyWarn | An error occurred in family "[Name]" that cannot be automatically resolved.\nError Information:\n"[Text]"
UnspecifiedError | Revit has experienced an unexpected error. The operation has been cancelled to protect your project from corruption.
ValueOutOfRange | Value is out of range ! Please enter a number between [Value] and [Value].
WarningInFamilyDismissed | A warning in family "[Name]" was dismissed. Please review warning information to determine if any changes are necessary\nWarning Information:\n"[Text]"

See Also

BuiltInFailures..::..GeneralFailures Class


BuiltInFailures.GeneralFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..GeneralFailures Properties
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback

The BuiltInFailures..::..GeneralFailures type exposes the following members.

Properties

Name | Description
CannotFixProblem | Failed to fix problem. Action has to be cancelled.
CannotSetParameter | Cant set parameter
CharactersNotAllowed | Name cannot contain any of the following characters:\n[{}[]|;<>?`~]\nor any of the non-printable characters.
ContentDocTreeCorruption | Problems with the Content Doc Tree structure - e.g. orphaned Content Docs, Families w/o docs, missing Owner Fam, what-not
ConvertingOldAxisToNormal | This operation will convert the existing axis of revolution to a normal line.
CoreElemTestingError | Core element testing error (internal).
DuplicateValue | Elements have duplicate '[Value]' values.
EnterNonNegativeValue | Enter a non-negative value.
EnterValidRealGreaterThan | Enter a number greater than [Value].
EnterValueBetween | Please enter a value between [Value] and [Value].
ErrorInFamilyResolved | An error occurred in family "[Name]" and was automatically resolved. Please review changes made to the family.\nError Information:\n"[Text]"\nError Resolution: [Resolution]
ErrorInSymbolFamilyResolved | An error occurred in family "[Name]" and was automatically resolved, but may require review by the family creator.\nError Information:\n"[Text]"\nError Resolution: [Resolution]
ErrorResolved | Error "[Text]" was automatically resolved by "[Resolution]"
FailedToOpenFile | Failed to open file.
FailedToReadLine | Failed to read line.
FamilySeparationTestingError | Family separation testing error (internal).
GenericCorruption | A generic error has occurred.
GenericError | Error.
GenericErrorNone | None.
GenericFatalError | A fatal error has occurred. The application will be terminated. You will be given the opportunity to save recovery files for all of your changed projects.\tWould you like to save a recovery file for [Project Name]?
GenericNonFatalError | A serious error has occurred. It is strongly recommended that you use Save As to save your work in a new file before continuing.
GenericWarning | A generic error has occurred.
InaccuracyDetected | A geometric inaccuracy was found in the element.
InternalProblemsParameter | Parameter cannot be changed due to internal problems.
InvalidInput | Invalid Input
InvalidInputWarn | Invalid Input
InvalidOrderOfPhases | Invalid order of phases: [Type Name] cannot be demolished before it was created.
InvalidValue | Invalid value.
NameInUse | The name "[Name]" is already in use.
NameIsEmpty | Name is empty
NameNotUnique | The name entered is already in use. Enter a unique name.
NoRelatedWarnings | Document doesn't contain any warnings related to these elements.
ParameterValueNotInRange | The value for [Parameter Name] must be between [Value] and [Value].
ParameterValuesConflict | The value for [Parameter Name] must be at least [Value] below the value for [Parameter Name].
SeriousElementReferenceCorruption | Element references are seriously corrupt.
TransactionFailed | [Description]
TransactionFailedWarn | [Description]
UnresolvableErrorInFamily | An error occurred in family "[Name]" that cannot be automatically resolved.\nError Information:\n"[Text]"
UnresolvableErrorInFamilyWarn | An error occurred in family "[Name]" that cannot be automatically resolved.\nError Information:\n"[Text]"
UnspecifiedError | Revit has experienced an unexpected error. The operation has been cancelled to protect your project from corruption.
ValueOutOfRange | Value is out of range ! Please enter a number between [Value] and [Value].
WarningInFamilyDismissed | A warning in family "[Name]" was dismissed. Please review warning information to determine if any changes are necessary\nWarning Information:\n"[Text]"

See Also

BuiltInFailures..::..GeneralFailures Class


CannotFixProblem Property

[image]

Revit 2024 API
BuiltInFailures..::..GeneralFailures..::..CannotFixProblem Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
Failed to fix problem. Action has to be cancelled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotFixProblem { get; }
Visual Basic
Public Shared ReadOnly Property CannotFixProblem As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotFixProblem {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


CannotSetParameter Property

[image]

Revit 2024 API
BuiltInFailures..::..GeneralFailures..::..CannotSetParameter Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
Cant set parameter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotSetParameter { get; }
Visual Basic
Public Shared ReadOnly Property CannotSetParameter As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotSetParameter {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


CharactersNotAllowed Property

[image]

Revit 2024 API
BuiltInFailures..::..GeneralFailures..::..CharactersNotAllowed Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
Name cannot contain any of the following characters:\n[{}[]|;<>?`~]\nor any of the non-printable characters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CharactersNotAllowed { get; }
Visual Basic
Public Shared ReadOnly Property CharactersNotAllowed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CharactersNotAllowed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


ContentDocTreeCorruption Property

[image]

Revit 2024 API
BuiltInFailures..::..GeneralFailures..::..ContentDocTreeCorruption Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
Problems with the Content Doc Tree structure - e.g. orphaned Content Docs, Families w/o docs, missing Owner Fam, what-not

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ContentDocTreeCorruption { get; }
Visual Basic
Public Shared ReadOnly Property ContentDocTreeCorruption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ContentDocTreeCorruption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


ConvertingOldAxisToNormal Property

[image]

Revit 2024 API
BuiltInFailures..::..GeneralFailures..::..ConvertingOldAxisToNormal Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
This operation will convert the existing axis of revolution to a normal line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ConvertingOldAxisToNormal { get; }
Visual Basic
Public Shared ReadOnly Property ConvertingOldAxisToNormal As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ConvertingOldAxisToNormal {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


CoreElemTestingError Property

[image]

Revit 2024 API
BuiltInFailures..::..GeneralFailures..::..CoreElemTestingError Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
Core element testing error (internal).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CoreElemTestingError { get; }
Visual Basic
Public Shared ReadOnly Property CoreElemTestingError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CoreElemTestingError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


DuplicateValue Property

[image]

Revit 2024 API
BuiltInFailures..::..GeneralFailures..::..DuplicateValue Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
Elements have duplicate '[Value]' values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DuplicateValue { get; }
Visual Basic
Public Shared ReadOnly Property DuplicateValue As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DuplicateValue {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


EnterValidRealGreaterThan Property

[image]

Revit 2024 API
BuiltInFailures..::..GeneralFailures..::..EnterValidRealGreaterThan Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
Enter a number greater than [Value].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId EnterValidRealGreaterThan { get; }
Visual Basic
Public Shared ReadOnly Property EnterValidRealGreaterThan As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ EnterValidRealGreaterThan {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


EnterValueBetween Property

[image]

Revit 2024 API
BuiltInFailures..::..GeneralFailures..::..EnterValueBetween Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
Please enter a value between [Value] and [Value].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId EnterValueBetween { get; }
Visual Basic
Public Shared ReadOnly Property EnterValueBetween As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ EnterValueBetween {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


ErrorInFamilyResolved Property

[image]

Revit 2024 API
BuiltInFailures..::..GeneralFailures..::..ErrorInFamilyResolved Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
An error occurred in family "[Name]" and was automatically resolved. Please review changes made to the family.\nError Information:\n"[Text]"\nError Resolution: [Resolution]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ErrorInFamilyResolved { get; }
Visual Basic
Public Shared ReadOnly Property ErrorInFamilyResolved As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ErrorInFamilyResolved {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


ErrorInSymbolFamilyResolved Property

[image]

Revit 2024 API
BuiltInFailures..::..GeneralFailures..::..ErrorInSymbolFamilyResolved Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
An error occurred in family "[Name]" and was automatically resolved, but may require review by the family creator.\nError Information:\n"[Text]"\nError Resolution: [Resolution]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ErrorInSymbolFamilyResolved { get; }
Visual Basic
Public Shared ReadOnly Property ErrorInSymbolFamilyResolved As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ErrorInSymbolFamilyResolved {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


ErrorResolved Property

[image]

Revit 2024 API
BuiltInFailures..::..GeneralFailures..::..ErrorResolved Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
Error "[Text]" was automatically resolved by "[Resolution]"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ErrorResolved { get; }
Visual Basic
Public Shared ReadOnly Property ErrorResolved As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ErrorResolved {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


FailedToReadLine Property

[image]

Revit 2024 API
BuiltInFailures..::..GeneralFailures..::..FailedToReadLine Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
Failed to read line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FailedToReadLine { get; }
Visual Basic
Public Shared ReadOnly Property FailedToReadLine As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FailedToReadLine {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


FamilySeparationTestingError Property

[image]

Revit 2024 API
BuiltInFailures..::..GeneralFailures..::..FamilySeparationTestingError Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
Family separation testing error (internal).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FamilySeparationTestingError { get; }
Visual Basic
Public Shared ReadOnly Property FamilySeparationTestingError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FamilySeparationTestingError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


GenericCorruption Property

[image]

Revit 2024 API
BuiltInFailures..::..GeneralFailures..::..GenericCorruption Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
A generic error has occurred.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId GenericCorruption { get; }
Visual Basic
Public Shared ReadOnly Property GenericCorruption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GenericCorruption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


GenericError Property

[image]

Revit 2024 API
BuiltInFailures..::..GeneralFailures..::..GenericError Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
Error.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId GenericError { get; }
Visual Basic
Public Shared ReadOnly Property GenericError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GenericError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


GenericErrorNone Property

[image]

Revit 2024 API
BuiltInFailures..::..GeneralFailures..::..GenericErrorNone Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
None.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId GenericErrorNone { get; }
Visual Basic
Public Shared ReadOnly Property GenericErrorNone As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GenericErrorNone {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


GenericFatalError Property

[image]

Revit 2024 API
BuiltInFailures..::..GeneralFailures..::..GenericFatalError Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
A fatal error has occurred. The application will be terminated. You will be given the opportunity to save recovery files for all of your changed projects.\tWould you like to save a recovery file for [Project Name]?

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId GenericFatalError { get; }
Visual Basic
Public Shared ReadOnly Property GenericFatalError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GenericFatalError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


GenericNonFatalError Property

[image]

Revit 2024 API
BuiltInFailures..::..GeneralFailures..::..GenericNonFatalError Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
A serious error has occurred. It is strongly recommended that you use Save As to save your work in a new file before continuing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId GenericNonFatalError { get; }
Visual Basic
Public Shared ReadOnly Property GenericNonFatalError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GenericNonFatalError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


InternalProblemsParameter Property

[image]

Revit 2024 API
BuiltInFailures..::..GeneralFailures..::..InternalProblemsParameter Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
Parameter cannot be changed due to internal problems.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InternalProblemsParameter { get; }
Visual Basic
Public Shared ReadOnly Property InternalProblemsParameter As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InternalProblemsParameter {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


InvalidInput Property

[image]

Revit 2024 API
BuiltInFailures..::..GeneralFailures..::..InvalidInput Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
Invalid Input

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidInput { get; }
Visual Basic
Public Shared ReadOnly Property InvalidInput As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidInput {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


InvalidInputWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..GeneralFailures..::..InvalidInputWarn Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
Invalid Input

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidInputWarn { get; }
Visual Basic
Public Shared ReadOnly Property InvalidInputWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidInputWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


InvalidOrderOfPhases Property

[image]

Revit 2024 API
BuiltInFailures..::..GeneralFailures..::..InvalidOrderOfPhases Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
Invalid order of phases: [Type Name] cannot be demolished before it was created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidOrderOfPhases { get; }
Visual Basic
Public Shared ReadOnly Property InvalidOrderOfPhases As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidOrderOfPhases {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


InvalidValue Property

[image]

Revit 2024 API
BuiltInFailures..::..GeneralFailures..::..InvalidValue Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
Invalid value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidValue { get; }
Visual Basic
Public Shared ReadOnly Property InvalidValue As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidValue {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


NoRelatedWarnings Property

[image]

Revit 2024 API
BuiltInFailures..::..GeneralFailures..::..NoRelatedWarnings Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
Document doesn't contain any warnings related to these elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoRelatedWarnings { get; }
Visual Basic
Public Shared ReadOnly Property NoRelatedWarnings As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoRelatedWarnings {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


ParameterValueNotInRange Property

[image]

Revit 2024 API
BuiltInFailures..::..GeneralFailures..::..ParameterValueNotInRange Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
The value for [Parameter Name] must be between [Value] and [Value].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ParameterValueNotInRange { get; }
Visual Basic
Public Shared ReadOnly Property ParameterValueNotInRange As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ParameterValueNotInRange {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


ParameterValuesConflict Property

[image]

Revit 2024 API
BuiltInFailures..::..GeneralFailures..::..ParameterValuesConflict Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
The value for [Parameter Name] must be at least [Value] below the value for [Parameter Name].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ParameterValuesConflict { get; }
Visual Basic
Public Shared ReadOnly Property ParameterValuesConflict As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ParameterValuesConflict {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


TransactionFailedWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..GeneralFailures..::..TransactionFailedWarn Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
[Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId TransactionFailedWarn { get; }
Visual Basic
Public Shared ReadOnly Property TransactionFailedWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TransactionFailedWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


UnresolvableErrorInFamily Property

[image]

Revit 2024 API
BuiltInFailures..::..GeneralFailures..::..UnresolvableErrorInFamily Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
An error occurred in family "[Name]" that cannot be automatically resolved.\nError Information:\n"[Text]"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UnresolvableErrorInFamily { get; }
Visual Basic
Public Shared ReadOnly Property UnresolvableErrorInFamily As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnresolvableErrorInFamily {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


UnresolvableErrorInFamilyWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..GeneralFailures..::..UnresolvableErrorInFamilyWarn Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
An error occurred in family "[Name]" that cannot be automatically resolved.\nError Information:\n"[Text]"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UnresolvableErrorInFamilyWarn { get; }
Visual Basic
Public Shared ReadOnly Property UnresolvableErrorInFamilyWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnresolvableErrorInFamilyWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


WarningInFamilyDismissed Property

[image]

Revit 2024 API
BuiltInFailures..::..GeneralFailures..::..WarningInFamilyDismissed Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
A warning in family "[Name]" was dismissed. Please review warning information to determine if any changes are necessary\nWarning Information:\n"[Text]"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WarningInFamilyDismissed { get; }
Visual Basic
Public Shared ReadOnly Property WarningInFamilyDismissed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WarningInFamilyDismissed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


BuiltInFailures.GenericFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..GenericFailures Class
BuiltInFailures Class Members See Also Send Feedback
Generic failures that may apply to any Revit Element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class GenericFailures
Visual Basic
Public NotInheritable Class GenericFailures
Visual C++
public ref class GenericFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..GenericFailures

See Also

BuiltInFailures..::..GenericFailures Members


BuiltInFailures.GenericFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..GenericFailures Members
BuiltInFailures..::..GenericFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..GenericFailures type exposes the following members.

Properties

Name | Description
ElementsInInvalidContext | There are elements in the document that exist in a context they should not. These elements must be deleted to continue using this project or family.

See Also

BuiltInFailures..::..GenericFailures Class


ElementsInInvalidContext Property

[image]

Revit 2024 API
BuiltInFailures..::..GenericFailures..::..ElementsInInvalidContext Property
BuiltInFailures..::..GenericFailures Class See Also Send Feedback
There are elements in the document that exist in a context they should not. These elements must be deleted to continue using this project or family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ElementsInInvalidContext { get; }
Visual Basic
Public Shared ReadOnly Property ElementsInInvalidContext As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementsInInvalidContext {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GenericFailures Class


BuiltInFailures.GenericMEPFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..GenericMEPFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures applicable to different mechanical, electrical and piping Elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class GenericMEPFailures
Visual Basic
Public NotInheritable Class GenericMEPFailures
Visual C++
public ref class GenericMEPFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..GenericMEPFailures

See Also

BuiltInFailures..::..GenericMEPFailures Members


BuiltInFailures.GenericMEPFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..GenericMEPFailures Members
BuiltInFailures..::..GenericMEPFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..GenericMEPFailures type exposes the following members.

Properties

Name | Description
CapsWereAddedWarning | X caps were added.
CapWasAddedWarning | 1 cap was added.
FailedToPlaceCapWarning | Failed to place cap on the open connector.
FlowConfigMismatch | [Element Name]: It is not possible to calculate the flow since all the components in this system have the flow configuration set to Preset or System. At least one component is required to have the flow configuration set to Calculated.
FlowDirectionMismatch | [Element Name]: It is not possible to calculate the flow since the flow direction mismatch. Please check flow direction on all equipment in this system.
InlineEndoflineMismatch | [Element Name]: It is not possible to calculate the flow since there is inline equipment that is configured as end of line. Please check equipment in this system and make sure that the equipment connectors used inline have a global system classification and a calculated flow configuration. Global equipment connectors used inline should always be linked to each other.
MaxWidthAndHeightReached | Maximum width and height reached during sizing
SegmentIsTooShort | The segment is too short.
SizingFailedZeroFlow | Sizing failed. Flow for section is 0.
SplitElementDeletionWarning | The value specified for the Joint Gap exceeds the length of the split segment, so the segment will be deleted.
ValidatePHSegmentConnWarning | The placeholder curve will not be able to connect to the required fittings for placeholder convert
ValidatePHSegmentLengthWarning | The placeholder curve is not long enough to support the required fittings for placeholder convert

See Also

BuiltInFailures..::..GenericMEPFailures Class


BuiltInFailures.GenericMEPFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..GenericMEPFailures Properties
BuiltInFailures..::..GenericMEPFailures Class See Also Send Feedback

The BuiltInFailures..::..GenericMEPFailures type exposes the following members.

Properties

Name | Description
CapsWereAddedWarning | X caps were added.
CapWasAddedWarning | 1 cap was added.
FailedToPlaceCapWarning | Failed to place cap on the open connector.
FlowConfigMismatch | [Element Name]: It is not possible to calculate the flow since all the components in this system have the flow configuration set to Preset or System. At least one component is required to have the flow configuration set to Calculated.
FlowDirectionMismatch | [Element Name]: It is not possible to calculate the flow since the flow direction mismatch. Please check flow direction on all equipment in this system.
InlineEndoflineMismatch | [Element Name]: It is not possible to calculate the flow since there is inline equipment that is configured as end of line. Please check equipment in this system and make sure that the equipment connectors used inline have a global system classification and a calculated flow configuration. Global equipment connectors used inline should always be linked to each other.
MaxWidthAndHeightReached | Maximum width and height reached during sizing
SegmentIsTooShort | The segment is too short.
SizingFailedZeroFlow | Sizing failed. Flow for section is 0.
SplitElementDeletionWarning | The value specified for the Joint Gap exceeds the length of the split segment, so the segment will be deleted.
ValidatePHSegmentConnWarning | The placeholder curve will not be able to connect to the required fittings for placeholder convert
ValidatePHSegmentLengthWarning | The placeholder curve is not long enough to support the required fittings for placeholder convert

See Also

BuiltInFailures..::..GenericMEPFailures Class


CapsWereAddedWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..GenericMEPFailures..::..CapsWereAddedWarning Property
BuiltInFailures..::..GenericMEPFailures Class See Also Send Feedback
X caps were added.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CapsWereAddedWarning { get; }
Visual Basic
Public Shared ReadOnly Property CapsWereAddedWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CapsWereAddedWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GenericMEPFailures Class


CapWasAddedWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..GenericMEPFailures..::..CapWasAddedWarning Property
BuiltInFailures..::..GenericMEPFailures Class See Also Send Feedback
1 cap was added.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CapWasAddedWarning { get; }
Visual Basic
Public Shared ReadOnly Property CapWasAddedWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CapWasAddedWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GenericMEPFailures Class


FailedToPlaceCapWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..GenericMEPFailures..::..FailedToPlaceCapWarning Property
BuiltInFailures..::..GenericMEPFailures Class See Also Send Feedback
Failed to place cap on the open connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FailedToPlaceCapWarning { get; }
Visual Basic
Public Shared ReadOnly Property FailedToPlaceCapWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FailedToPlaceCapWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GenericMEPFailures Class


FlowConfigMismatch Property

[image]

Revit 2024 API
BuiltInFailures..::..GenericMEPFailures..::..FlowConfigMismatch Property
BuiltInFailures..::..GenericMEPFailures Class See Also Send Feedback
[Element Name]: It is not possible to calculate the flow since all the components in this system have the flow configuration set to Preset or System. At least one component is required to have the flow configuration set to Calculated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FlowConfigMismatch { get; }
Visual Basic
Public Shared ReadOnly Property FlowConfigMismatch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FlowConfigMismatch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GenericMEPFailures Class


InlineEndoflineMismatch Property

[image]

Revit 2024 API
BuiltInFailures..::..GenericMEPFailures..::..InlineEndoflineMismatch Property
BuiltInFailures..::..GenericMEPFailures Class See Also Send Feedback
[Element Name]: It is not possible to calculate the flow since there is inline equipment that is configured as end of line. Please check equipment in this system and make sure that the equipment connectors used inline have a global system classification and a calculated flow configuration. Global equipment connectors used inline should always be linked to each other.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InlineEndoflineMismatch { get; }
Visual Basic
Public Shared ReadOnly Property InlineEndoflineMismatch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InlineEndoflineMismatch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GenericMEPFailures Class


MaxWidthAndHeightReached Property

[image]

Revit 2024 API
BuiltInFailures..::..GenericMEPFailures..::..MaxWidthAndHeightReached Property
BuiltInFailures..::..GenericMEPFailures Class See Also Send Feedback
Maximum width and height reached during sizing

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MaxWidthAndHeightReached { get; }
Visual Basic
Public Shared ReadOnly Property MaxWidthAndHeightReached As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MaxWidthAndHeightReached {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GenericMEPFailures Class


SegmentIsTooShort Property

[image]

Revit 2024 API
BuiltInFailures..::..GenericMEPFailures..::..SegmentIsTooShort Property
BuiltInFailures..::..GenericMEPFailures Class See Also Send Feedback
The segment is too short.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SegmentIsTooShort { get; }
Visual Basic
Public Shared ReadOnly Property SegmentIsTooShort As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SegmentIsTooShort {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GenericMEPFailures Class


SizingFailedZeroFlow Property

[image]

Revit 2024 API
BuiltInFailures..::..GenericMEPFailures..::..SizingFailedZeroFlow Property
BuiltInFailures..::..GenericMEPFailures Class See Also Send Feedback
Sizing failed. Flow for section is 0.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SizingFailedZeroFlow { get; }
Visual Basic
Public Shared ReadOnly Property SizingFailedZeroFlow As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SizingFailedZeroFlow {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GenericMEPFailures Class


ValidatePHSegmentLengthWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..GenericMEPFailures..::..ValidatePHSegmentLengthWarning Property
BuiltInFailures..::..GenericMEPFailures Class See Also Send Feedback
The placeholder curve is not long enough to support the required fittings for placeholder convert

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ValidatePHSegmentLengthWarning { get; }
Visual Basic
Public Shared ReadOnly Property ValidatePHSegmentLengthWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ValidatePHSegmentLengthWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GenericMEPFailures Class


BuiltInFailures.GeometryFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..GeometryFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about GeometryFailures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class GeometryFailures
Visual Basic
Public NotInheritable Class GeometryFailures
Visual C++
public ref class GeometryFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..GeometryFailures

See Also

BuiltInFailures..::..GeometryFailures Members


BuiltInFailures.GeometryFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..GeometryFailures Members
BuiltInFailures..::..GeometryFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..GeometryFailures type exposes the following members.

Properties

Name | Description
CannotFindClosest | Cannot find closest points within lines.
ConvertFaceRegionsToFacesCrashed | Failed to replace an instance face with its face regions.
ConvertFaceRegionsToFacesFailed | Failed to replace an instance face with its face regions.
CurveAndSurfaceDoNotIntersect | Curve and Surface do not intersect.
CurveDriverError | Element's internal join data is corrupt.
CurveProjectTooShort | The projection of the line in this view is too short to create a new Line
ElementIsTooThin | [Element] is too thin.
ElementTooSmall | Element is too small on screen
FailedReplaceCurveElemCurveDriver | Failed to replace curve elem curve driver.
FailedUpdateCurveChain | Failed to update curve chain.
FailToConvertLine | Unable to convert lines
LineArcTangentFailure | Can't keep arc element and straight line element tangent.
OffsetFaceFailed | Failed to offset the face.
PolygonSegmentTooShort | Polygon segment too short
SiteInvisible | Topographic elements are not visible in your current view. You can modify View Range settings in the view's Properties or Visibility settings in Visibility/Graphics.
SuccessToConvertLine | Success to convert lines
SymbolicLineInvalidPlane | Symbolic Element refers to a Work Plane with unacceptable normal.
TooManyFacesEdges | This family instance has too many [Edges and Faces]. Remove unnecessary geometry or split the instance into multiple instances.

See Also

BuiltInFailures..::..GeometryFailures Class


BuiltInFailures.GeometryFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..GeometryFailures Properties
BuiltInFailures..::..GeometryFailures Class See Also Send Feedback

The BuiltInFailures..::..GeometryFailures type exposes the following members.

Properties

Name | Description
CannotFindClosest | Cannot find closest points within lines.
ConvertFaceRegionsToFacesCrashed | Failed to replace an instance face with its face regions.
ConvertFaceRegionsToFacesFailed | Failed to replace an instance face with its face regions.
CurveAndSurfaceDoNotIntersect | Curve and Surface do not intersect.
CurveDriverError | Element's internal join data is corrupt.
CurveProjectTooShort | The projection of the line in this view is too short to create a new Line
ElementIsTooThin | [Element] is too thin.
ElementTooSmall | Element is too small on screen
FailedReplaceCurveElemCurveDriver | Failed to replace curve elem curve driver.
FailedUpdateCurveChain | Failed to update curve chain.
FailToConvertLine | Unable to convert lines
LineArcTangentFailure | Can't keep arc element and straight line element tangent.
OffsetFaceFailed | Failed to offset the face.
PolygonSegmentTooShort | Polygon segment too short
SiteInvisible | Topographic elements are not visible in your current view. You can modify View Range settings in the view's Properties or Visibility settings in Visibility/Graphics.
SuccessToConvertLine | Success to convert lines
SymbolicLineInvalidPlane | Symbolic Element refers to a Work Plane with unacceptable normal.
TooManyFacesEdges | This family instance has too many [Edges and Faces]. Remove unnecessary geometry or split the instance into multiple instances.

See Also

BuiltInFailures..::..GeometryFailures Class


ConvertFaceRegionsToFacesCrashed Property

[image]

Revit 2024 API
BuiltInFailures..::..GeometryFailures..::..ConvertFaceRegionsToFacesCrashed Property
BuiltInFailures..::..GeometryFailures Class See Also Send Feedback
Failed to replace an instance face with its face regions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ConvertFaceRegionsToFacesCrashed { get; }
Visual Basic
Public Shared ReadOnly Property ConvertFaceRegionsToFacesCrashed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ConvertFaceRegionsToFacesCrashed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeometryFailures Class


ConvertFaceRegionsToFacesFailed Property

[image]

Revit 2024 API
BuiltInFailures..::..GeometryFailures..::..ConvertFaceRegionsToFacesFailed Property
BuiltInFailures..::..GeometryFailures Class See Also Send Feedback
Failed to replace an instance face with its face regions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ConvertFaceRegionsToFacesFailed { get; }
Visual Basic
Public Shared ReadOnly Property ConvertFaceRegionsToFacesFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ConvertFaceRegionsToFacesFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeometryFailures Class


CurveAndSurfaceDoNotIntersect Property

[image]

Revit 2024 API
BuiltInFailures..::..GeometryFailures..::..CurveAndSurfaceDoNotIntersect Property
BuiltInFailures..::..GeometryFailures Class See Also Send Feedback
Curve and Surface do not intersect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CurveAndSurfaceDoNotIntersect { get; }
Visual Basic
Public Shared ReadOnly Property CurveAndSurfaceDoNotIntersect As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CurveAndSurfaceDoNotIntersect {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeometryFailures Class


CurveDriverError Property

[image]

Revit 2024 API
BuiltInFailures..::..GeometryFailures..::..CurveDriverError Property
BuiltInFailures..::..GeometryFailures Class See Also Send Feedback
Element's internal join data is corrupt.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CurveDriverError { get; }
Visual Basic
Public Shared ReadOnly Property CurveDriverError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CurveDriverError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeometryFailures Class


CurveProjectTooShort Property

[image]

Revit 2024 API
BuiltInFailures..::..GeometryFailures..::..CurveProjectTooShort Property
BuiltInFailures..::..GeometryFailures Class See Also Send Feedback
The projection of the line in this view is too short to create a new Line

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CurveProjectTooShort { get; }
Visual Basic
Public Shared ReadOnly Property CurveProjectTooShort As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CurveProjectTooShort {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeometryFailures Class


ElementTooSmall Property

[image]

Revit 2024 API
BuiltInFailures..::..GeometryFailures..::..ElementTooSmall Property
BuiltInFailures..::..GeometryFailures Class See Also Send Feedback
Element is too small on screen

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ElementTooSmall { get; }
Visual Basic
Public Shared ReadOnly Property ElementTooSmall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementTooSmall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeometryFailures Class


FailedReplaceCurveElemCurveDriver Property

[image]

Revit 2024 API
BuiltInFailures..::..GeometryFailures..::..FailedReplaceCurveElemCurveDriver Property
BuiltInFailures..::..GeometryFailures Class See Also Send Feedback
Failed to replace curve elem curve driver.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FailedReplaceCurveElemCurveDriver { get; }
Visual Basic
Public Shared ReadOnly Property FailedReplaceCurveElemCurveDriver As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FailedReplaceCurveElemCurveDriver {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeometryFailures Class


FailedUpdateCurveChain Property

[image]

Revit 2024 API
BuiltInFailures..::..GeometryFailures..::..FailedUpdateCurveChain Property
BuiltInFailures..::..GeometryFailures Class See Also Send Feedback
Failed to update curve chain.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FailedUpdateCurveChain { get; }
Visual Basic
Public Shared ReadOnly Property FailedUpdateCurveChain As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FailedUpdateCurveChain {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeometryFailures Class


LineArcTangentFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..GeometryFailures..::..LineArcTangentFailure Property
BuiltInFailures..::..GeometryFailures Class See Also Send Feedback
Can't keep arc element and straight line element tangent.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId LineArcTangentFailure { get; }
Visual Basic
Public Shared ReadOnly Property LineArcTangentFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LineArcTangentFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeometryFailures Class


OffsetFaceFailed Property

[image]

Revit 2024 API
BuiltInFailures..::..GeometryFailures..::..OffsetFaceFailed Property
BuiltInFailures..::..GeometryFailures Class See Also Send Feedback
Failed to offset the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId OffsetFaceFailed { get; }
Visual Basic
Public Shared ReadOnly Property OffsetFaceFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OffsetFaceFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeometryFailures Class


PolygonSegmentTooShort Property

[image]

Revit 2024 API
BuiltInFailures..::..GeometryFailures..::..PolygonSegmentTooShort Property
BuiltInFailures..::..GeometryFailures Class See Also Send Feedback
Polygon segment too short

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId PolygonSegmentTooShort { get; }
Visual Basic
Public Shared ReadOnly Property PolygonSegmentTooShort As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PolygonSegmentTooShort {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeometryFailures Class


SiteInvisible Property

[image]

Revit 2024 API
BuiltInFailures..::..GeometryFailures..::..SiteInvisible Property
BuiltInFailures..::..GeometryFailures Class See Also Send Feedback
Topographic elements are not visible in your current view. You can modify View Range settings in the view's Properties or Visibility settings in Visibility/Graphics.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SiteInvisible { get; }
Visual Basic
Public Shared ReadOnly Property SiteInvisible As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SiteInvisible {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeometryFailures Class


SuccessToConvertLine Property

[image]

Revit 2024 API
BuiltInFailures..::..GeometryFailures..::..SuccessToConvertLine Property
BuiltInFailures..::..GeometryFailures Class See Also Send Feedback
Success to convert lines

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SuccessToConvertLine { get; }
Visual Basic
Public Shared ReadOnly Property SuccessToConvertLine As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SuccessToConvertLine {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeometryFailures Class


SymbolicLineInvalidPlane Property

[image]

Revit 2024 API
BuiltInFailures..::..GeometryFailures..::..SymbolicLineInvalidPlane Property
BuiltInFailures..::..GeometryFailures Class See Also Send Feedback
Symbolic Element refers to a Work Plane with unacceptable normal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SymbolicLineInvalidPlane { get; }
Visual Basic
Public Shared ReadOnly Property SymbolicLineInvalidPlane As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SymbolicLineInvalidPlane {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeometryFailures Class


TooManyFacesEdges Property

[image]

Revit 2024 API
BuiltInFailures..::..GeometryFailures..::..TooManyFacesEdges Property
BuiltInFailures..::..GeometryFailures Class See Also Send Feedback
This family instance has too many [Edges and Faces]. Remove unnecessary geometry or split the instance into multiple instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId TooManyFacesEdges { get; }
Visual Basic
Public Shared ReadOnly Property TooManyFacesEdges As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TooManyFacesEdges {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeometryFailures Class


BuiltInFailures.GlobalParameterFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..GlobalParameterFailures Members
BuiltInFailures..::..GlobalParameterFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..GlobalParameterFailures type exposes the following members.

Properties

Name | Description
ElementPropLinkCircularChain | Linked properties in highlighted elements cause a circular chain of references.
ElementPropLinkCircularChainError | Linked properties in highlighted elements cause a circular chain of references.
GlobalParamFormulaCircularChain | A formula in a global parameter causes a circular chain of references between highlighted elements.
GlobalParamFormulaCircularChainError | A formula in a global parameter causes a circular chain of references between highlighted elements.
GlobalParamInvalidElemParamValue | Invalid value of parameter %1!s! in highlighted element.
InvalidElementPropToGlobalParamLink | The following parameters of the highlighted element can no longer be linked to global parameters: %1!s!.

See Also

BuiltInFailures..::..GlobalParameterFailures Class


ElementPropLinkCircularChain Property

[image]

Revit 2024 API
BuiltInFailures..::..GlobalParameterFailures..::..ElementPropLinkCircularChain Property
BuiltInFailures..::..GlobalParameterFailures Class See Also Send Feedback
Linked properties in highlighted elements cause a circular chain of references.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ElementPropLinkCircularChain { get; }
Visual Basic
Public Shared ReadOnly Property ElementPropLinkCircularChain As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementPropLinkCircularChain {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GlobalParameterFailures Class


ElementPropLinkCircularChainError Property

[image]

Revit 2024 API
BuiltInFailures..::..GlobalParameterFailures..::..ElementPropLinkCircularChainError Property
BuiltInFailures..::..GlobalParameterFailures Class See Also Send Feedback
Linked properties in highlighted elements cause a circular chain of references.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ElementPropLinkCircularChainError { get; }
Visual Basic
Public Shared ReadOnly Property ElementPropLinkCircularChainError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementPropLinkCircularChainError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GlobalParameterFailures Class


GlobalParamFormulaCircularChainError Property

[image]

Revit 2024 API
BuiltInFailures..::..GlobalParameterFailures..::..GlobalParamFormulaCircularChainError Property
BuiltInFailures..::..GlobalParameterFailures Class See Also Send Feedback
A formula in a global parameter causes a circular chain of references between highlighted elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId GlobalParamFormulaCircularChainError { get; }
Visual Basic
Public Shared ReadOnly Property GlobalParamFormulaCircularChainError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GlobalParamFormulaCircularChainError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GlobalParameterFailures Class


GlobalParamInvalidElemParamValue Property

[image]

Revit 2024 API
BuiltInFailures..::..GlobalParameterFailures..::..GlobalParamInvalidElemParamValue Property
BuiltInFailures..::..GlobalParameterFailures Class See Also Send Feedback
Invalid value of parameter %1!s! in highlighted element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId GlobalParamInvalidElemParamValue { get; }
Visual Basic
Public Shared ReadOnly Property GlobalParamInvalidElemParamValue As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GlobalParamInvalidElemParamValue {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GlobalParameterFailures Class


BuiltInFailures.GridChainSketchFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..GridChainSketchFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures related to the GridChain sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class GridChainSketchFailures
Visual Basic
Public NotInheritable Class GridChainSketchFailures
Visual C++
public ref class GridChainSketchFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..GridChainSketchFailures

See Also

BuiltInFailures..::..GridChainSketchFailures Members


BuiltInFailures.GridChainSketchFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..GridChainSketchFailures Members
BuiltInFailures..::..GridChainSketchFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..GridChainSketchFailures type exposes the following members.

Properties

Name | Description
ClosedLoop | GridChain sketch contains a closed loop.
InvalidSketch | Sketch is invalid. Grid sketch must consist of a single open loop with no intersecting lines.
MoreThanOneLoop | GridChain sketch contains more than one loop.
OverlappingLines | GridChain sketch contains lines which overlap.

See Also

BuiltInFailures..::..GridChainSketchFailures Class


BuiltInFailures.GridChainSketchFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..GridChainSketchFailures Properties
BuiltInFailures..::..GridChainSketchFailures Class See Also Send Feedback

The BuiltInFailures..::..GridChainSketchFailures type exposes the following members.

Properties

Name | Description
ClosedLoop | GridChain sketch contains a closed loop.
InvalidSketch | Sketch is invalid. Grid sketch must consist of a single open loop with no intersecting lines.
MoreThanOneLoop | GridChain sketch contains more than one loop.
OverlappingLines | GridChain sketch contains lines which overlap.

See Also

BuiltInFailures..::..GridChainSketchFailures Class


InvalidSketch Property

[image]

Revit 2024 API
BuiltInFailures..::..GridChainSketchFailures..::..InvalidSketch Property
BuiltInFailures..::..GridChainSketchFailures Class See Also Send Feedback
Sketch is invalid. Grid sketch must consist of a single open loop with no intersecting lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidSketch { get; }
Visual Basic
Public Shared ReadOnly Property InvalidSketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GridChainSketchFailures Class


MoreThanOneLoop Property

[image]

Revit 2024 API
BuiltInFailures..::..GridChainSketchFailures..::..MoreThanOneLoop Property
BuiltInFailures..::..GridChainSketchFailures Class See Also Send Feedback
GridChain sketch contains more than one loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MoreThanOneLoop { get; }
Visual Basic
Public Shared ReadOnly Property MoreThanOneLoop As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MoreThanOneLoop {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GridChainSketchFailures Class


OverlappingLines Property

[image]

Revit 2024 API
BuiltInFailures..::..GridChainSketchFailures..::..OverlappingLines Property
BuiltInFailures..::..GridChainSketchFailures Class See Also Send Feedback
GridChain sketch contains lines which overlap.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId OverlappingLines { get; }
Visual Basic
Public Shared ReadOnly Property OverlappingLines As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OverlappingLines {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GridChainSketchFailures Class


BuiltInFailures.GridFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..GridFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class GridFailures
Visual Basic
Public NotInheritable Class GridFailures
Visual C++
public ref class GridFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..GridFailures

See Also

BuiltInFailures..::..GridFailures Members


BuiltInFailures.GridFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..GridFailures Members
BuiltInFailures..::..GridFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..GridFailures type exposes the following members.

Properties

Name | Description
GridEndSegmentsLengthTooShort | The end segment length for a grid must be at least [Length Value]
GridInGridChainCannotMirror | A grid that is a sub-grid of a multi-segment grid can only be mirrored if the entire multi-segment grid is being mirrored.
GridlineAxisTooClose | Axis of gridlines should not change order or be closer than [Value] to each other.
GridlineAxisTooFar | Axis of gridlines should not be further than [Value] to each other.

See Also

BuiltInFailures..::..GridFailures Class


BuiltInFailures.GridFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..GridFailures Properties
BuiltInFailures..::..GridFailures Class See Also Send Feedback

The BuiltInFailures..::..GridFailures type exposes the following members.

Properties

Name | Description
GridEndSegmentsLengthTooShort | The end segment length for a grid must be at least [Length Value]
GridInGridChainCannotMirror | A grid that is a sub-grid of a multi-segment grid can only be mirrored if the entire multi-segment grid is being mirrored.
GridlineAxisTooClose | Axis of gridlines should not change order or be closer than [Value] to each other.
GridlineAxisTooFar | Axis of gridlines should not be further than [Value] to each other.

See Also

BuiltInFailures..::..GridFailures Class


GridEndSegmentsLengthTooShort Property

[image]

Revit 2024 API
BuiltInFailures..::..GridFailures..::..GridEndSegmentsLengthTooShort Property
BuiltInFailures..::..GridFailures Class See Also Send Feedback
The end segment length for a grid must be at least [Length Value]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId GridEndSegmentsLengthTooShort { get; }
Visual Basic
Public Shared ReadOnly Property GridEndSegmentsLengthTooShort As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GridEndSegmentsLengthTooShort {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GridFailures Class


GridlineAxisTooClose Property

[image]

Revit 2024 API
BuiltInFailures..::..GridFailures..::..GridlineAxisTooClose Property
BuiltInFailures..::..GridFailures Class See Also Send Feedback
Axis of gridlines should not change order or be closer than [Value] to each other.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId GridlineAxisTooClose { get; }
Visual Basic
Public Shared ReadOnly Property GridlineAxisTooClose As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GridlineAxisTooClose {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GridFailures Class


GridlineAxisTooFar Property

[image]

Revit 2024 API
BuiltInFailures..::..GridFailures..::..GridlineAxisTooFar Property
BuiltInFailures..::..GridFailures Class See Also Send Feedback
Axis of gridlines should not be further than [Value] to each other.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId GridlineAxisTooFar { get; }
Visual Basic
Public Shared ReadOnly Property GridlineAxisTooFar As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GridlineAxisTooFar {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GridFailures Class


BuiltInFailures.GroupFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures related to groups and their behavior.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class GroupFailures
Visual Basic
Public NotInheritable Class GroupFailures
Visual C++
public ref class GroupFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..GroupFailures

See Also

BuiltInFailures..::..GroupFailures Members


BuiltInFailures.GroupFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..GroupFailures Members
BuiltInFailures..::..GroupFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..GroupFailures type exposes the following members.

Properties

Name | Description
AdditionalElementsRequired | Grouping the selected elements requires that additional element(s) also be grouped. [Description] To satisfy the grouping requirement, these additional element(s) will be automatically added to the group as well.
AdditionalElementsRequiredRemove | To be able to remove the selected elements from the group the following additional element(s) will also be removed: [Description]
AllElementsRemovedFromGroup | Group "[Type Name]" is now empty and will be deleted.
AtomTouchedNotAllowed | Changes to groups are only allowed during Edit Group mode. Use Edit Group to make this change.
AtomTouchedNotAllowedDelete | Changes to groups are only allowed during Edit Group mode. Use Edit Group to make this change.
AtomViolationWhenMultiPlacedInstances | Changes to groups are allowed only in group edit mode. Use the Edit Group command to change to all instances of a group type. You may use the "Ungroup" option to proceed with this change by ungrouping the changed group instances.
AtomViolationWhenOnePlaceInstance | A group has been changed outside group edit mode. The change is being allowed because there is only one instance of the type.
AttachedGroupNoMirror | Attached detail groups cannot be mirrored without also mirroring their parent group.
AttachedGroupNoPasteToView | An attached group cannot be pasted into the selected view type and has been omitted from the elements being pasted.
BadProblemWithGroup | The operation performed affects groups in an unacceptable manner.
BadViewForAttachedGroup | Attached groups can only be created for view specific elements belonging to non-3d model views.
BadViewForAttachedGroupWarn | Attached groups can only be created for view specific elements belonging to non-3d model views.
CannotAddAlreadyMemberToDiffGroup | Elements that are already members of one group cannot be added to another group.
CannotAddToGroupFormat | [Element] cannot be added to the instance of [Group]
CannotAddToGroupFormatWarn | [Element] cannot be added to the instance of [Group]
CannotCopyGroup | Unable to copy the selected group.
CannotCreateGroup | Cannot create group of these elements.
CannotCreateGroupWithInvalidReferences | The elements you have selected for grouping contain dimensions or tags which do not reference a common model group. No detail group has been created.
CannotFinishGroupInSketchMode | Can't Finish Group while in Sketch Mode.
CannotLinkAnnotationsForSomeViews | Annotations for some views cannot be displayed from linked file.
CannotPlaceGroup | Can't place Group from browser. Try copy/pasting existing copy of the Group instead.
CannotReloadWithFile | Group [Type Name] cannot be reloaded from file [File Name].
CannotRemoveGroupMemberConstraint | Constraints between group members cannot be removed or excluded from the group.
CannotRemoveGroupMemberConstraintWarn | Constraints between group members cannot be removed or excluded from the group.
CannotRemoveSubordFromGroup | Element can't be removed or excluded from the Group because it is required by another Group element.
CannotRemoveSubordFromGroupWarn | Element can't be removed or excluded from the Group because it is required by another Group element.
CannotSaveGroup | Can't save Group.
CannotSwapNestedGroups | Can't replace because one Group is contained in the other.
ChildrenDeletedOnGroupSwap | Some dependent elements were deleted by changing group type and cannot be retained.
ChildrenLostOnGroupSwap | Some elements could not find new hosts after changing group type and will be deleted.
DetailsOfNestedGroupsLost | Details will be deleted if they reference group members being ungrouped in other instances of this containing group.
DimensionsOrTagsReferecedRemoved | Dimensions or Tags that reference non-group members have been removed from group [Name].
DimRefsGroupMemberSketch | A group member's sketch or family is constrained to an element that is not a member of the group. These constraints have been removed.
DontEditNestedGroup | Cannot edit nested Groups while inside Edit Group mode for its host Group. To edit the nested Group finish editing all Groups. Use the Tab key to select the nested Group and edit it directly.
ElementChangedMoreThanAllowed | The Grouped element has changed length enough to make it substantially different from other Group instances. To make this degree of change Edit Group and make the change again.
ElementsContainsFabricationData | Unable to load models containing elements with fabrication data as group.
ExcludedElementsRestoredInLink | Excluded elements restored in the link.
FailedToChangeGroupLevelRef | Unable to change group level ref.
FailedToSetLeaderGroupId | Unable to set id of group type.
FailedToTransformAttachedGroup | Attached group could not be properly relocated.
GroupAmongstLoadedRenamed | A group or groups that was loaded was renamed because its name was not unique amongst the groups in the file being loaded. Most likely a model subgroup had the same name as the loaded file.
GroupCannotMixBackAndForegroundDetail | This detail group contains some elements which display in the background and some which display in the foreground. Detail groups must be able to be displayed as a unit in either the foreground or background, so this type of mixture is not allowed.
GroupCannotSave | The group cannot be saved at this time because one of its instances is being edited.
GroupCannotSaveWarn | The group cannot be saved at this time because one of its instances is being edited.
GroupChangeNoPlaceElements | Elements cannot be placed as a result of changes to groups.
GroupEditModeNoDuplicates | Can't create duplicates in Edit Group mode.
GroupedModelElemHasViewSpecificSubordinates | Unable to group the selected elements. Model element in group has view specific subordinates or view specific element in group has non-view specific subordinates.
GroupHadFailedElementsWhileUpdating | Group members failed while updating group.
GroupPropagationFailedSketch | Can't change Group"[Name]" with more than one instance because it has a Sketch-based element. Edit the Sketch of the element instead.
GroupPropagationFailedUngroup | Can't make change to Group "[Type Name]" with more than one instance. To resolve: Ungroup and Group again under a new name. Edit and make change, then change all instances of the original Group to the new Group.
GroupPropagationUserCancelled | Changes to Group "[Type Name]" have been cancelled.
GroupsHasCycle | Can't create Group because it contains multiple copies of same Group.
GroupsHaveDifferentMembers | Group instances of the same type do not contain identical members. Press "Fix Groups..." to select from options to make the groups consistent.\nCorresponding group members in different group instances diverge in the following respects:[Description]
GroupsNotCompatibleForTypeChange | Some of the selected groups are not compatible with the new group type that was chosen.
GroupViewSpecificDiffViews | You may not create a detail group with view specific elements from different views.
InvalidGroup | This group is invalid.
LastCopyOfGroupDeleted | Last copy of Group "[Name]" deleted. Group type removed from project.
LastGroupMemberExcluded | Last member of group instance was excluded (deleted), removed, or moved to the project. Group instance has been deleted.
LinkVisibilityLost | Link visibility overrides will be lost.
LoadOfGroupAbortedByUser | You have aborted loading file '[File Name]' as a group.
MembersAlignWarn | User parameter values for group members have been aligned.
MembersExcluded | Group members have been excluded from this group instance.
MembersExcludedWarn | Group members have been excluded from this group instance.
MembersMovedToProjectToMakeConsistent | Group members had to be "moved to the project" (removed from their group instance) because they were not consistent with the group type definition.
ModifyingMultiGroups | Multiple groups of the same type are being edited simultaneously outside group edit mode in an unacceptable manner.
MoveElemFailed | Unable to move element.
NoAppropriateGroup | There is no Group that can be placed in the current view.
NoDetailGroups | There are no Detail Groups in this Project or Family.
NoModelGroups | There are no Model Groups in this Project or Family.
NoneOfSelElemsGroupable | None of the selected elements can be grouped. The elements may already be grouped or may be element types which are not allowed for grouping.
NoSwapGroupBeingEdited | You may not change the type of the group that is currently being edited.
NotAGroupFile | This is not a Group File.
NotAllGroupsFullyRestored | Not all of the excluded members of the select groups were fully restored. You may be able to restore the remaining members individually or by performing "restore all excluded members" on sub-groups of the selected groups.
PlaceGroupFailed | Unable to place group instances.
ProblemRegeneratingInGroupUpdate | Unable to regenerate while updating groups at end of transaction.
ReferencesOutsideGroupAreNotAllowed | The elements you have selected for grouping contain dimensions or tags whose references are not all included in the selection being grouped and are not all included in a common model group. As a result, some of the selected elements have not been included in the new group.
RemoveGroupSketchConstraintParent | You are removing an element from the group which is involved in a sketch or family constraint with another element of the same group. Either remove the constraint or cancel the removal of this element from the group.
RemovingElemCannotBeGrouped | Elements that cannot be grouped were removed from groups of type '[Type Name]'.
RemovingReferencesFromGroupedCurve | References to elements outside the group were removed from a grouped curve element.
RevitUnableToUpadateGroups | Unable to update groups for changes.
SomeGroupInstsBecameEmpty | Group instances have had all their group members deleted and will also be deleted.
SomeMembersNotRestored | Revit was not able to restore all of the requested group members. The members may depend on elements that are still excluded.
UnableToBindLink | Unable to bind the selected links.
UnableToBindLinkInstances | Unable to bind some link instances. Either linked file contains no 3d elements or there was an error loading its elements into the current project.
UnableToConvertGroupsToLinks | Unable to convert the selected groups to links.
UnableToCreateAttachedGroup | Unable to create attached detail group in view '[View Name]' for the selected elements.
UnableToDetachGroup | Unable to detach the selected attached detail group(s).
UnableToExcludeElems | Unable to exclude the selected group members.
UnableToGroupElems | Revit does not allow grouping of some of the selected elements. These elements will not be included in the group.
UnableToLoadAttachedGroup | Unable to load attached detail group '[Type Name]'.
UnableToLoadDetailGroup | Unable to load detail group '[Type Name]'.
UnableToLoadGroup | Unable to load file '[File Name]' as a group.
UnableToMaintainExclusions | Unable to maintain exclusion of some group members. Some excluded members have been restored.
UnableToMaintainExclusionsWarn | Unable to maintain exclusion of some group members. Some excluded members have been restored.
UnableToMoveElemsToProject | Revit is unable to move the selected group members to the project.
UnableToRemapDetails | Unable to create attached detail group in view '[View Name]' for the selected elements.
UnableToReplaceSelectedGroups | Unable to change the types of the groups you have selected and the related groups. You might try deleting the groups you wish to change and placing or copy/pasting new groups of the desired type.
UnableToRestoreAllMembersOfGroups | Revit is unable to restore the members of the selected groups.
UnableToSaveGroupType | Unable to save group type.
UnableToTransferAttachedGroup | Unable to load attached group [Type Name] of model group [Type Name].

See Also

BuiltInFailures..::..GroupFailures Class


BuiltInFailures.GroupFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..GroupFailures Properties
BuiltInFailures..::..GroupFailures Class See Also Send Feedback

The BuiltInFailures..::..GroupFailures type exposes the following members.

Properties

Name | Description
AdditionalElementsRequired | Grouping the selected elements requires that additional element(s) also be grouped. [Description] To satisfy the grouping requirement, these additional element(s) will be automatically added to the group as well.
AdditionalElementsRequiredRemove | To be able to remove the selected elements from the group the following additional element(s) will also be removed: [Description]
AllElementsRemovedFromGroup | Group "[Type Name]" is now empty and will be deleted.
AtomTouchedNotAllowed | Changes to groups are only allowed during Edit Group mode. Use Edit Group to make this change.
AtomTouchedNotAllowedDelete | Changes to groups are only allowed during Edit Group mode. Use Edit Group to make this change.
AtomViolationWhenMultiPlacedInstances | Changes to groups are allowed only in group edit mode. Use the Edit Group command to change to all instances of a group type. You may use the "Ungroup" option to proceed with this change by ungrouping the changed group instances.
AtomViolationWhenOnePlaceInstance | A group has been changed outside group edit mode. The change is being allowed because there is only one instance of the type.
AttachedGroupNoMirror | Attached detail groups cannot be mirrored without also mirroring their parent group.
AttachedGroupNoPasteToView | An attached group cannot be pasted into the selected view type and has been omitted from the elements being pasted.
BadProblemWithGroup | The operation performed affects groups in an unacceptable manner.
BadViewForAttachedGroup | Attached groups can only be created for view specific elements belonging to non-3d model views.
BadViewForAttachedGroupWarn | Attached groups can only be created for view specific elements belonging to non-3d model views.
CannotAddAlreadyMemberToDiffGroup | Elements that are already members of one group cannot be added to another group.
CannotAddToGroupFormat | [Element] cannot be added to the instance of [Group]
CannotAddToGroupFormatWarn | [Element] cannot be added to the instance of [Group]
CannotCopyGroup | Unable to copy the selected group.
CannotCreateGroup | Cannot create group of these elements.
CannotCreateGroupWithInvalidReferences | The elements you have selected for grouping contain dimensions or tags which do not reference a common model group. No detail group has been created.
CannotFinishGroupInSketchMode | Can't Finish Group while in Sketch Mode.
CannotLinkAnnotationsForSomeViews | Annotations for some views cannot be displayed from linked file.
CannotPlaceGroup | Can't place Group from browser. Try copy/pasting existing copy of the Group instead.
CannotReloadWithFile | Group [Type Name] cannot be reloaded from file [File Name].
CannotRemoveGroupMemberConstraint | Constraints between group members cannot be removed or excluded from the group.
CannotRemoveGroupMemberConstraintWarn | Constraints between group members cannot be removed or excluded from the group.
CannotRemoveSubordFromGroup | Element can't be removed or excluded from the Group because it is required by another Group element.
CannotRemoveSubordFromGroupWarn | Element can't be removed or excluded from the Group because it is required by another Group element.
CannotSaveGroup | Can't save Group.
CannotSwapNestedGroups | Can't replace because one Group is contained in the other.
ChildrenDeletedOnGroupSwap | Some dependent elements were deleted by changing group type and cannot be retained.
ChildrenLostOnGroupSwap | Some elements could not find new hosts after changing group type and will be deleted.
DetailsOfNestedGroupsLost | Details will be deleted if they reference group members being ungrouped in other instances of this containing group.
DimensionsOrTagsReferecedRemoved | Dimensions or Tags that reference non-group members have been removed from group [Name].
DimRefsGroupMemberSketch | A group member's sketch or family is constrained to an element that is not a member of the group. These constraints have been removed.
DontEditNestedGroup | Cannot edit nested Groups while inside Edit Group mode for its host Group. To edit the nested Group finish editing all Groups. Use the Tab key to select the nested Group and edit it directly.
ElementChangedMoreThanAllowed | The Grouped element has changed length enough to make it substantially different from other Group instances. To make this degree of change Edit Group and make the change again.
ElementsContainsFabricationData | Unable to load models containing elements with fabrication data as group.
ExcludedElementsRestoredInLink | Excluded elements restored in the link.
FailedToChangeGroupLevelRef | Unable to change group level ref.
FailedToSetLeaderGroupId | Unable to set id of group type.
FailedToTransformAttachedGroup | Attached group could not be properly relocated.
GroupAmongstLoadedRenamed | A group or groups that was loaded was renamed because its name was not unique amongst the groups in the file being loaded. Most likely a model subgroup had the same name as the loaded file.
GroupCannotMixBackAndForegroundDetail | This detail group contains some elements which display in the background and some which display in the foreground. Detail groups must be able to be displayed as a unit in either the foreground or background, so this type of mixture is not allowed.
GroupCannotSave | The group cannot be saved at this time because one of its instances is being edited.
GroupCannotSaveWarn | The group cannot be saved at this time because one of its instances is being edited.
GroupChangeNoPlaceElements | Elements cannot be placed as a result of changes to groups.
GroupEditModeNoDuplicates | Can't create duplicates in Edit Group mode.
GroupedModelElemHasViewSpecificSubordinates | Unable to group the selected elements. Model element in group has view specific subordinates or view specific element in group has non-view specific subordinates.
GroupHadFailedElementsWhileUpdating | Group members failed while updating group.
GroupPropagationFailedSketch | Can't change Group"[Name]" with more than one instance because it has a Sketch-based element. Edit the Sketch of the element instead.
GroupPropagationFailedUngroup | Can't make change to Group "[Type Name]" with more than one instance. To resolve: Ungroup and Group again under a new name. Edit and make change, then change all instances of the original Group to the new Group.
GroupPropagationUserCancelled | Changes to Group "[Type Name]" have been cancelled.
GroupsHasCycle | Can't create Group because it contains multiple copies of same Group.
GroupsHaveDifferentMembers | Group instances of the same type do not contain identical members. Press "Fix Groups..." to select from options to make the groups consistent.\nCorresponding group members in different group instances diverge in the following respects:[Description]
GroupsNotCompatibleForTypeChange | Some of the selected groups are not compatible with the new group type that was chosen.
GroupViewSpecificDiffViews | You may not create a detail group with view specific elements from different views.
InvalidGroup | This group is invalid.
LastCopyOfGroupDeleted | Last copy of Group "[Name]" deleted. Group type removed from project.
LastGroupMemberExcluded | Last member of group instance was excluded (deleted), removed, or moved to the project. Group instance has been deleted.
LinkVisibilityLost | Link visibility overrides will be lost.
LoadOfGroupAbortedByUser | You have aborted loading file '[File Name]' as a group.
MembersAlignWarn | User parameter values for group members have been aligned.
MembersExcluded | Group members have been excluded from this group instance.
MembersExcludedWarn | Group members have been excluded from this group instance.
MembersMovedToProjectToMakeConsistent | Group members had to be "moved to the project" (removed from their group instance) because they were not consistent with the group type definition.
ModifyingMultiGroups | Multiple groups of the same type are being edited simultaneously outside group edit mode in an unacceptable manner.
MoveElemFailed | Unable to move element.
NoAppropriateGroup | There is no Group that can be placed in the current view.
NoDetailGroups | There are no Detail Groups in this Project or Family.
NoModelGroups | There are no Model Groups in this Project or Family.
NoneOfSelElemsGroupable | None of the selected elements can be grouped. The elements may already be grouped or may be element types which are not allowed for grouping.
NoSwapGroupBeingEdited | You may not change the type of the group that is currently being edited.
NotAGroupFile | This is not a Group File.
NotAllGroupsFullyRestored | Not all of the excluded members of the select groups were fully restored. You may be able to restore the remaining members individually or by performing "restore all excluded members" on sub-groups of the selected groups.
PlaceGroupFailed | Unable to place group instances.
ProblemRegeneratingInGroupUpdate | Unable to regenerate while updating groups at end of transaction.
ReferencesOutsideGroupAreNotAllowed | The elements you have selected for grouping contain dimensions or tags whose references are not all included in the selection being grouped and are not all included in a common model group. As a result, some of the selected elements have not been included in the new group.
RemoveGroupSketchConstraintParent | You are removing an element from the group which is involved in a sketch or family constraint with another element of the same group. Either remove the constraint or cancel the removal of this element from the group.
RemovingElemCannotBeGrouped | Elements that cannot be grouped were removed from groups of type '[Type Name]'.
RemovingReferencesFromGroupedCurve | References to elements outside the group were removed from a grouped curve element.
RevitUnableToUpadateGroups | Unable to update groups for changes.
SomeGroupInstsBecameEmpty | Group instances have had all their group members deleted and will also be deleted.
SomeMembersNotRestored | Revit was not able to restore all of the requested group members. The members may depend on elements that are still excluded.
UnableToBindLink | Unable to bind the selected links.
UnableToBindLinkInstances | Unable to bind some link instances. Either linked file contains no 3d elements or there was an error loading its elements into the current project.
UnableToConvertGroupsToLinks | Unable to convert the selected groups to links.
UnableToCreateAttachedGroup | Unable to create attached detail group in view '[View Name]' for the selected elements.
UnableToDetachGroup | Unable to detach the selected attached detail group(s).
UnableToExcludeElems | Unable to exclude the selected group members.
UnableToGroupElems | Revit does not allow grouping of some of the selected elements. These elements will not be included in the group.
UnableToLoadAttachedGroup | Unable to load attached detail group '[Type Name]'.
UnableToLoadDetailGroup | Unable to load detail group '[Type Name]'.
UnableToLoadGroup | Unable to load file '[File Name]' as a group.
UnableToMaintainExclusions | Unable to maintain exclusion of some group members. Some excluded members have been restored.
UnableToMaintainExclusionsWarn | Unable to maintain exclusion of some group members. Some excluded members have been restored.
UnableToMoveElemsToProject | Revit is unable to move the selected group members to the project.
UnableToRemapDetails | Unable to create attached detail group in view '[View Name]' for the selected elements.
UnableToReplaceSelectedGroups | Unable to change the types of the groups you have selected and the related groups. You might try deleting the groups you wish to change and placing or copy/pasting new groups of the desired type.
UnableToRestoreAllMembersOfGroups | Revit is unable to restore the members of the selected groups.
UnableToSaveGroupType | Unable to save group type.
UnableToTransferAttachedGroup | Unable to load attached group [Type Name] of model group [Type Name].

See Also

BuiltInFailures..::..GroupFailures Class


AdditionalElementsRequired Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..AdditionalElementsRequired Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Grouping the selected elements requires that additional element(s) also be grouped. [Description] To satisfy the grouping requirement, these additional element(s) will be automatically added to the group as well.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AdditionalElementsRequired { get; }
Visual Basic
Public Shared ReadOnly Property AdditionalElementsRequired As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AdditionalElementsRequired {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


AdditionalElementsRequiredRemove Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..AdditionalElementsRequiredRemove Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
To be able to remove the selected elements from the group the following additional element(s) will also be removed: [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AdditionalElementsRequiredRemove { get; }
Visual Basic
Public Shared ReadOnly Property AdditionalElementsRequiredRemove As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AdditionalElementsRequiredRemove {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


AtomTouchedNotAllowed Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..AtomTouchedNotAllowed Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Changes to groups are only allowed during Edit Group mode. Use Edit Group to make this change.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AtomTouchedNotAllowed { get; }
Visual Basic
Public Shared ReadOnly Property AtomTouchedNotAllowed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AtomTouchedNotAllowed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


AtomTouchedNotAllowedDelete Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..AtomTouchedNotAllowedDelete Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Changes to groups are only allowed during Edit Group mode. Use Edit Group to make this change.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AtomTouchedNotAllowedDelete { get; }
Visual Basic
Public Shared ReadOnly Property AtomTouchedNotAllowedDelete As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AtomTouchedNotAllowedDelete {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


AtomViolationWhenOnePlaceInstance Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..AtomViolationWhenOnePlaceInstance Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
A group has been changed outside group edit mode. The change is being allowed because there is only one instance of the type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AtomViolationWhenOnePlaceInstance { get; }
Visual Basic
Public Shared ReadOnly Property AtomViolationWhenOnePlaceInstance As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AtomViolationWhenOnePlaceInstance {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


AttachedGroupNoPasteToView Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..AttachedGroupNoPasteToView Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
An attached group cannot be pasted into the selected view type and has been omitted from the elements being pasted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AttachedGroupNoPasteToView { get; }
Visual Basic
Public Shared ReadOnly Property AttachedGroupNoPasteToView As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AttachedGroupNoPasteToView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


BadProblemWithGroup Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..BadProblemWithGroup Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
The operation performed affects groups in an unacceptable manner.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId BadProblemWithGroup { get; }
Visual Basic
Public Shared ReadOnly Property BadProblemWithGroup As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BadProblemWithGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


BadViewForAttachedGroup Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..BadViewForAttachedGroup Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Attached groups can only be created for view specific elements belonging to non-3d model views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId BadViewForAttachedGroup { get; }
Visual Basic
Public Shared ReadOnly Property BadViewForAttachedGroup As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BadViewForAttachedGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


BadViewForAttachedGroupWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..BadViewForAttachedGroupWarn Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Attached groups can only be created for view specific elements belonging to non-3d model views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId BadViewForAttachedGroupWarn { get; }
Visual Basic
Public Shared ReadOnly Property BadViewForAttachedGroupWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BadViewForAttachedGroupWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


CannotAddAlreadyMemberToDiffGroup Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..CannotAddAlreadyMemberToDiffGroup Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Elements that are already members of one group cannot be added to another group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotAddAlreadyMemberToDiffGroup { get; }
Visual Basic
Public Shared ReadOnly Property CannotAddAlreadyMemberToDiffGroup As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotAddAlreadyMemberToDiffGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


CannotAddToGroupFormat Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..CannotAddToGroupFormat Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
[Element] cannot be added to the instance of [Group]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotAddToGroupFormat { get; }
Visual Basic
Public Shared ReadOnly Property CannotAddToGroupFormat As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotAddToGroupFormat {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


CannotAddToGroupFormatWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..CannotAddToGroupFormatWarn Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
[Element] cannot be added to the instance of [Group]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotAddToGroupFormatWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotAddToGroupFormatWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotAddToGroupFormatWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


CannotCopyGroup Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..CannotCopyGroup Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Unable to copy the selected group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCopyGroup { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyGroup As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


CannotCreateGroup Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..CannotCreateGroup Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Cannot create group of these elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateGroup { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateGroup As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


CannotCreateGroupWithInvalidReferences Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..CannotCreateGroupWithInvalidReferences Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
The elements you have selected for grouping contain dimensions or tags which do not reference a common model group. No detail group has been created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateGroupWithInvalidReferences { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateGroupWithInvalidReferences As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateGroupWithInvalidReferences {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


CannotFinishGroupInSketchMode Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..CannotFinishGroupInSketchMode Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Can't Finish Group while in Sketch Mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotFinishGroupInSketchMode { get; }
Visual Basic
Public Shared ReadOnly Property CannotFinishGroupInSketchMode As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotFinishGroupInSketchMode {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


CannotLinkAnnotationsForSomeViews Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..CannotLinkAnnotationsForSomeViews Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Annotations for some views cannot be displayed from linked file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotLinkAnnotationsForSomeViews { get; }
Visual Basic
Public Shared ReadOnly Property CannotLinkAnnotationsForSomeViews As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotLinkAnnotationsForSomeViews {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


CannotPlaceGroup Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..CannotPlaceGroup Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Can't place Group from browser. Try copy/pasting existing copy of the Group instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotPlaceGroup { get; }
Visual Basic
Public Shared ReadOnly Property CannotPlaceGroup As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPlaceGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


CannotReloadWithFile Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..CannotReloadWithFile Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Group [Type Name] cannot be reloaded from file [File Name].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotReloadWithFile { get; }
Visual Basic
Public Shared ReadOnly Property CannotReloadWithFile As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotReloadWithFile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


CannotRemoveSubordFromGroup Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..CannotRemoveSubordFromGroup Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Element can't be removed or excluded from the Group because it is required by another Group element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotRemoveSubordFromGroup { get; }
Visual Basic
Public Shared ReadOnly Property CannotRemoveSubordFromGroup As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotRemoveSubordFromGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


CannotRemoveSubordFromGroupWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..CannotRemoveSubordFromGroupWarn Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Element can't be removed or excluded from the Group because it is required by another Group element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotRemoveSubordFromGroupWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotRemoveSubordFromGroupWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotRemoveSubordFromGroupWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


ChildrenDeletedOnGroupSwap Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..ChildrenDeletedOnGroupSwap Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Some dependent elements were deleted by changing group type and cannot be retained.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ChildrenDeletedOnGroupSwap { get; }
Visual Basic
Public Shared ReadOnly Property ChildrenDeletedOnGroupSwap As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ChildrenDeletedOnGroupSwap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


ChildrenLostOnGroupSwap Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..ChildrenLostOnGroupSwap Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Some elements could not find new hosts after changing group type and will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ChildrenLostOnGroupSwap { get; }
Visual Basic
Public Shared ReadOnly Property ChildrenLostOnGroupSwap As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ChildrenLostOnGroupSwap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


DetailsOfNestedGroupsLost Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..DetailsOfNestedGroupsLost Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Details will be deleted if they reference group members being ungrouped in other instances of this containing group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DetailsOfNestedGroupsLost { get; }
Visual Basic
Public Shared ReadOnly Property DetailsOfNestedGroupsLost As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DetailsOfNestedGroupsLost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


DontEditNestedGroup Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..DontEditNestedGroup Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Cannot edit nested Groups while inside Edit Group mode for its host Group. To edit the nested Group finish editing all Groups. Use the Tab key to select the nested Group and edit it directly.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DontEditNestedGroup { get; }
Visual Basic
Public Shared ReadOnly Property DontEditNestedGroup As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DontEditNestedGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


ElementChangedMoreThanAllowed Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..ElementChangedMoreThanAllowed Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
The Grouped element has changed length enough to make it substantially different from other Group instances. To make this degree of change Edit Group and make the change again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ElementChangedMoreThanAllowed { get; }
Visual Basic
Public Shared ReadOnly Property ElementChangedMoreThanAllowed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementChangedMoreThanAllowed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


ElementsContainsFabricationData Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..ElementsContainsFabricationData Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Unable to load models containing elements with fabrication data as group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ElementsContainsFabricationData { get; }
Visual Basic
Public Shared ReadOnly Property ElementsContainsFabricationData As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementsContainsFabricationData {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


ExcludedElementsRestoredInLink Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..ExcludedElementsRestoredInLink Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Excluded elements restored in the link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ExcludedElementsRestoredInLink { get; }
Visual Basic
Public Shared ReadOnly Property ExcludedElementsRestoredInLink As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ExcludedElementsRestoredInLink {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


FailedToChangeGroupLevelRef Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..FailedToChangeGroupLevelRef Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Unable to change group level ref.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FailedToChangeGroupLevelRef { get; }
Visual Basic
Public Shared ReadOnly Property FailedToChangeGroupLevelRef As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FailedToChangeGroupLevelRef {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


FailedToTransformAttachedGroup Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..FailedToTransformAttachedGroup Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Attached group could not be properly relocated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FailedToTransformAttachedGroup { get; }
Visual Basic
Public Shared ReadOnly Property FailedToTransformAttachedGroup As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FailedToTransformAttachedGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


GroupCannotMixBackAndForegroundDetail Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..GroupCannotMixBackAndForegroundDetail Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
This detail group contains some elements which display in the background and some which display in the foreground. Detail groups must be able to be displayed as a unit in either the foreground or background, so this type of mixture is not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId GroupCannotMixBackAndForegroundDetail { get; }
Visual Basic
Public Shared ReadOnly Property GroupCannotMixBackAndForegroundDetail As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GroupCannotMixBackAndForegroundDetail {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


GroupCannotSave Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..GroupCannotSave Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
The group cannot be saved at this time because one of its instances is being edited.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId GroupCannotSave { get; }
Visual Basic
Public Shared ReadOnly Property GroupCannotSave As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GroupCannotSave {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


GroupCannotSaveWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..GroupCannotSaveWarn Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
The group cannot be saved at this time because one of its instances is being edited.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId GroupCannotSaveWarn { get; }
Visual Basic
Public Shared ReadOnly Property GroupCannotSaveWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GroupCannotSaveWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


GroupChangeNoPlaceElements Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..GroupChangeNoPlaceElements Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Elements cannot be placed as a result of changes to groups.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId GroupChangeNoPlaceElements { get; }
Visual Basic
Public Shared ReadOnly Property GroupChangeNoPlaceElements As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GroupChangeNoPlaceElements {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


GroupEditModeNoDuplicates Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..GroupEditModeNoDuplicates Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Can't create duplicates in Edit Group mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId GroupEditModeNoDuplicates { get; }
Visual Basic
Public Shared ReadOnly Property GroupEditModeNoDuplicates As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GroupEditModeNoDuplicates {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


GroupedModelElemHasViewSpecificSubordinates Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..GroupedModelElemHasViewSpecificSubordinates Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Unable to group the selected elements. Model element in group has view specific subordinates or view specific element in group has non-view specific subordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId GroupedModelElemHasViewSpecificSubordinates { get; }
Visual Basic
Public Shared ReadOnly Property GroupedModelElemHasViewSpecificSubordinates As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GroupedModelElemHasViewSpecificSubordinates {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


GroupHadFailedElementsWhileUpdating Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..GroupHadFailedElementsWhileUpdating Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Group members failed while updating group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId GroupHadFailedElementsWhileUpdating { get; }
Visual Basic
Public Shared ReadOnly Property GroupHadFailedElementsWhileUpdating As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GroupHadFailedElementsWhileUpdating {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


GroupPropagationFailedUngroup Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..GroupPropagationFailedUngroup Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Can't make change to Group "[Type Name]" with more than one instance. To resolve: Ungroup and Group again under a new name. Edit and make change, then change all instances of the original Group to the new Group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId GroupPropagationFailedUngroup { get; }
Visual Basic
Public Shared ReadOnly Property GroupPropagationFailedUngroup As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GroupPropagationFailedUngroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


GroupPropagationUserCancelled Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..GroupPropagationUserCancelled Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Changes to Group "[Type Name]" have been cancelled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId GroupPropagationUserCancelled { get; }
Visual Basic
Public Shared ReadOnly Property GroupPropagationUserCancelled As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GroupPropagationUserCancelled {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


GroupsHasCycle Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..GroupsHasCycle Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Can't create Group because it contains multiple copies of same Group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId GroupsHasCycle { get; }
Visual Basic
Public Shared ReadOnly Property GroupsHasCycle As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GroupsHasCycle {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


GroupsHaveDifferentMembers Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..GroupsHaveDifferentMembers Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Group instances of the same type do not contain identical members. Press "Fix Groups..." to select from options to make the groups consistent.\nCorresponding group members in different group instances diverge in the following respects:[Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId GroupsHaveDifferentMembers { get; }
Visual Basic
Public Shared ReadOnly Property GroupsHaveDifferentMembers As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GroupsHaveDifferentMembers {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


GroupsNotCompatibleForTypeChange Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..GroupsNotCompatibleForTypeChange Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Some of the selected groups are not compatible with the new group type that was chosen.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId GroupsNotCompatibleForTypeChange { get; }
Visual Basic
Public Shared ReadOnly Property GroupsNotCompatibleForTypeChange As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GroupsNotCompatibleForTypeChange {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


GroupViewSpecificDiffViews Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..GroupViewSpecificDiffViews Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
You may not create a detail group with view specific elements from different views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId GroupViewSpecificDiffViews { get; }
Visual Basic
Public Shared ReadOnly Property GroupViewSpecificDiffViews As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GroupViewSpecificDiffViews {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


LastCopyOfGroupDeleted Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..LastCopyOfGroupDeleted Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Last copy of Group "[Name]" deleted. Group type removed from project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId LastCopyOfGroupDeleted { get; }
Visual Basic
Public Shared ReadOnly Property LastCopyOfGroupDeleted As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LastCopyOfGroupDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


LastGroupMemberExcluded Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..LastGroupMemberExcluded Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Last member of group instance was excluded (deleted), removed, or moved to the project. Group instance has been deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId LastGroupMemberExcluded { get; }
Visual Basic
Public Shared ReadOnly Property LastGroupMemberExcluded As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LastGroupMemberExcluded {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


MembersAlignWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..MembersAlignWarn Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
User parameter values for group members have been aligned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MembersAlignWarn { get; }
Visual Basic
Public Shared ReadOnly Property MembersAlignWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MembersAlignWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


MembersExcluded Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..MembersExcluded Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Group members have been excluded from this group instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MembersExcluded { get; }
Visual Basic
Public Shared ReadOnly Property MembersExcluded As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MembersExcluded {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


MembersExcludedWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..MembersExcludedWarn Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Group members have been excluded from this group instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MembersExcludedWarn { get; }
Visual Basic
Public Shared ReadOnly Property MembersExcludedWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MembersExcludedWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


ModifyingMultiGroups Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..ModifyingMultiGroups Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Multiple groups of the same type are being edited simultaneously outside group edit mode in an unacceptable manner.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ModifyingMultiGroups { get; }
Visual Basic
Public Shared ReadOnly Property ModifyingMultiGroups As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ModifyingMultiGroups {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


MoveElemFailed Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..MoveElemFailed Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Unable to move element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MoveElemFailed { get; }
Visual Basic
Public Shared ReadOnly Property MoveElemFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MoveElemFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


NoAppropriateGroup Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..NoAppropriateGroup Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
There is no Group that can be placed in the current view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoAppropriateGroup { get; }
Visual Basic
Public Shared ReadOnly Property NoAppropriateGroup As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoAppropriateGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


NoModelGroups Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..NoModelGroups Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
There are no Model Groups in this Project or Family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoModelGroups { get; }
Visual Basic
Public Shared ReadOnly Property NoModelGroups As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoModelGroups {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


PlaceGroupFailed Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..PlaceGroupFailed Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Unable to place group instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId PlaceGroupFailed { get; }
Visual Basic
Public Shared ReadOnly Property PlaceGroupFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PlaceGroupFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


ProblemRegeneratingInGroupUpdate Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..ProblemRegeneratingInGroupUpdate Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Unable to regenerate while updating groups at end of transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ProblemRegeneratingInGroupUpdate { get; }
Visual Basic
Public Shared ReadOnly Property ProblemRegeneratingInGroupUpdate As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ProblemRegeneratingInGroupUpdate {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


RemoveGroupSketchConstraintParent Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..RemoveGroupSketchConstraintParent Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
You are removing an element from the group which is involved in a sketch or family constraint with another element of the same group. Either remove the constraint or cancel the removal of this element from the group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RemoveGroupSketchConstraintParent { get; }
Visual Basic
Public Shared ReadOnly Property RemoveGroupSketchConstraintParent As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RemoveGroupSketchConstraintParent {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


RemovingElemCannotBeGrouped Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..RemovingElemCannotBeGrouped Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Elements that cannot be grouped were removed from groups of type '[Type Name]'.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RemovingElemCannotBeGrouped { get; }
Visual Basic
Public Shared ReadOnly Property RemovingElemCannotBeGrouped As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RemovingElemCannotBeGrouped {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


RemovingReferencesFromGroupedCurve Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..RemovingReferencesFromGroupedCurve Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
References to elements outside the group were removed from a grouped curve element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RemovingReferencesFromGroupedCurve { get; }
Visual Basic
Public Shared ReadOnly Property RemovingReferencesFromGroupedCurve As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RemovingReferencesFromGroupedCurve {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


RevitUnableToUpadateGroups Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..RevitUnableToUpadateGroups Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Unable to update groups for changes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RevitUnableToUpadateGroups { get; }
Visual Basic
Public Shared ReadOnly Property RevitUnableToUpadateGroups As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RevitUnableToUpadateGroups {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


SomeMembersNotRestored Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..SomeMembersNotRestored Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Revit was not able to restore all of the requested group members. The members may depend on elements that are still excluded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SomeMembersNotRestored { get; }
Visual Basic
Public Shared ReadOnly Property SomeMembersNotRestored As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SomeMembersNotRestored {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


UnableToBindLink Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..UnableToBindLink Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Unable to bind the selected links.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UnableToBindLink { get; }
Visual Basic
Public Shared ReadOnly Property UnableToBindLink As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableToBindLink {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


UnableToConvertGroupsToLinks Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..UnableToConvertGroupsToLinks Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Unable to convert the selected groups to links.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UnableToConvertGroupsToLinks { get; }
Visual Basic
Public Shared ReadOnly Property UnableToConvertGroupsToLinks As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableToConvertGroupsToLinks {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


UnableToCreateAttachedGroup Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..UnableToCreateAttachedGroup Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Unable to create attached detail group in view '[View Name]' for the selected elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UnableToCreateAttachedGroup { get; }
Visual Basic
Public Shared ReadOnly Property UnableToCreateAttachedGroup As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableToCreateAttachedGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


UnableToExcludeElems Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..UnableToExcludeElems Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Unable to exclude the selected group members.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UnableToExcludeElems { get; }
Visual Basic
Public Shared ReadOnly Property UnableToExcludeElems As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableToExcludeElems {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


UnableToLoadAttachedGroup Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..UnableToLoadAttachedGroup Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Unable to load attached detail group '[Type Name]'.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UnableToLoadAttachedGroup { get; }
Visual Basic
Public Shared ReadOnly Property UnableToLoadAttachedGroup As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableToLoadAttachedGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


UnableToLoadDetailGroup Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..UnableToLoadDetailGroup Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Unable to load detail group '[Type Name]'.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UnableToLoadDetailGroup { get; }
Visual Basic
Public Shared ReadOnly Property UnableToLoadDetailGroup As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableToLoadDetailGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


UnableToMaintainExclusions Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..UnableToMaintainExclusions Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Unable to maintain exclusion of some group members. Some excluded members have been restored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UnableToMaintainExclusions { get; }
Visual Basic
Public Shared ReadOnly Property UnableToMaintainExclusions As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableToMaintainExclusions {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


UnableToMaintainExclusionsWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..UnableToMaintainExclusionsWarn Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Unable to maintain exclusion of some group members. Some excluded members have been restored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UnableToMaintainExclusionsWarn { get; }
Visual Basic
Public Shared ReadOnly Property UnableToMaintainExclusionsWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableToMaintainExclusionsWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


UnableToRemapDetails Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..UnableToRemapDetails Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Unable to create attached detail group in view '[View Name]' for the selected elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UnableToRemapDetails { get; }
Visual Basic
Public Shared ReadOnly Property UnableToRemapDetails As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableToRemapDetails {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


UnableToReplaceSelectedGroups Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..UnableToReplaceSelectedGroups Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Unable to change the types of the groups you have selected and the related groups. You might try deleting the groups you wish to change and placing or copy/pasting new groups of the desired type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UnableToReplaceSelectedGroups { get; }
Visual Basic
Public Shared ReadOnly Property UnableToReplaceSelectedGroups As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableToReplaceSelectedGroups {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


UnableToRestoreAllMembersOfGroups Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..UnableToRestoreAllMembersOfGroups Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Revit is unable to restore the members of the selected groups.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UnableToRestoreAllMembersOfGroups { get; }
Visual Basic
Public Shared ReadOnly Property UnableToRestoreAllMembersOfGroups As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableToRestoreAllMembersOfGroups {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


UnableToSaveGroupType Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..UnableToSaveGroupType Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Unable to save group type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UnableToSaveGroupType { get; }
Visual Basic
Public Shared ReadOnly Property UnableToSaveGroupType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableToSaveGroupType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


UnableToTransferAttachedGroup Property

[image]

Revit 2024 API
BuiltInFailures..::..GroupFailures..::..UnableToTransferAttachedGroup Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Unable to load attached group [Type Name] of model group [Type Name].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UnableToTransferAttachedGroup { get; }
Visual Basic
Public Shared ReadOnly Property UnableToTransferAttachedGroup As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableToTransferAttachedGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


BuiltInFailures.HostObjFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..HostObjFailures Members
BuiltInFailures..::..HostObjFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..HostObjFailures type exposes the following members.

Properties

Name | Description
HostMismatch | Can't use this type in this host.
ReferencesNulled | One or more references are or have become invalid.

See Also

BuiltInFailures..::..HostObjFailures Class


BuiltInFailures.HostObjFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..HostObjFailures Properties
BuiltInFailures..::..HostObjFailures Class See Also Send Feedback

The BuiltInFailures..::..HostObjFailures type exposes the following members.

Properties

Name | Description
HostMismatch | Can't use this type in this host.
ReferencesNulled | One or more references are or have become invalid.

See Also

BuiltInFailures..::..HostObjFailures Class


HostMismatch Property

[image]

Revit 2024 API
BuiltInFailures..::..HostObjFailures..::..HostMismatch Property
BuiltInFailures..::..HostObjFailures Class See Also Send Feedback
Can't use this type in this host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId HostMismatch { get; }
Visual Basic
Public Shared ReadOnly Property HostMismatch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HostMismatch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..HostObjFailures Class


ReferencesNulled Property

[image]

Revit 2024 API
BuiltInFailures..::..HostObjFailures..::..ReferencesNulled Property
BuiltInFailures..::..HostObjFailures Class See Also Send Feedback
One or more references are or have become invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ReferencesNulled { get; }
Visual Basic
Public Shared ReadOnly Property ReferencesNulled As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ReferencesNulled {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..HostObjFailures Class


BuiltInFailures.HvacFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..HvacFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures related to HVAC in MEP.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class HvacFailures
Visual Basic
Public NotInheritable Class HvacFailures
Visual C++
public ref class HvacFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..HvacFailures

See Also

BuiltInFailures..::..HvacFailures Members


BuiltInFailures.HvacFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..HvacFailures Members
BuiltInFailures..::..HvacFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..HvacFailures type exposes the following members.

Properties

Name | Description
PanelDoesntMatchCircuitPropertiesDisconnected | The panel no longer matches the properties for the Circuit. Disconnect the panel from the Circuit?

See Also

BuiltInFailures..::..HvacFailures Class


BuiltInFailures.HvacFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..HvacFailures Properties
BuiltInFailures..::..HvacFailures Class See Also Send Feedback

The BuiltInFailures..::..HvacFailures type exposes the following members.

Properties

Name | Description
PanelDoesntMatchCircuitPropertiesDisconnected | The panel no longer matches the properties for the Circuit. Disconnect the panel from the Circuit?

See Also

BuiltInFailures..::..HvacFailures Class


PanelDoesntMatchCircuitPropertiesDisconnected Property

[image]

Revit 2024 API
BuiltInFailures..::..HvacFailures..::..PanelDoesntMatchCircuitPropertiesDisconnected Property
BuiltInFailures..::..HvacFailures Class See Also Send Feedback
The panel no longer matches the properties for the Circuit. Disconnect the panel from the Circuit?

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId PanelDoesntMatchCircuitPropertiesDisconnected { get; }
Visual Basic
Public Shared ReadOnly Property PanelDoesntMatchCircuitPropertiesDisconnected As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PanelDoesntMatchCircuitPropertiesDisconnected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..HvacFailures Class


BuiltInFailures.IlluminationFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..IlluminationFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Illumination.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class IlluminationFailures
Visual Basic
Public NotInheritable Class IlluminationFailures
Visual C++
public ref class IlluminationFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..IlluminationFailures

See Also

BuiltInFailures..::..IlluminationFailures Members


BuiltInFailures.IlluminationFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..IlluminationFailures Members
BuiltInFailures..::..IlluminationFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..IlluminationFailures type exposes the following members.

Properties

Name | Description
IESFileNotFoundWarning | Estimated Illumination failed. IES file not found for lighting fixture.
LightingFixtureLumensWarning | Estimated Illumination failed. Lumens not set for lighting fixture.
RoomCoefficientUtilizationWarning | Estimated Illumination failed. Coefficient of utilization not set for lighting fixture.
RoomLightLossFactorWarning | Estimated Illumination failed. Light Loss factor not set for lighting fixture.

See Also

BuiltInFailures..::..IlluminationFailures Class


BuiltInFailures.IlluminationFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..IlluminationFailures Properties
BuiltInFailures..::..IlluminationFailures Class See Also Send Feedback

The BuiltInFailures..::..IlluminationFailures type exposes the following members.

Properties

Name | Description
IESFileNotFoundWarning | Estimated Illumination failed. IES file not found for lighting fixture.
LightingFixtureLumensWarning | Estimated Illumination failed. Lumens not set for lighting fixture.
RoomCoefficientUtilizationWarning | Estimated Illumination failed. Coefficient of utilization not set for lighting fixture.
RoomLightLossFactorWarning | Estimated Illumination failed. Light Loss factor not set for lighting fixture.

See Also

BuiltInFailures..::..IlluminationFailures Class


IESFileNotFoundWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..IlluminationFailures..::..IESFileNotFoundWarning Property
BuiltInFailures..::..IlluminationFailures Class See Also Send Feedback
Estimated Illumination failed. IES file not found for lighting fixture.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId IESFileNotFoundWarning { get; }
Visual Basic
Public Shared ReadOnly Property IESFileNotFoundWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ IESFileNotFoundWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..IlluminationFailures Class


RoomCoefficientUtilizationWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..IlluminationFailures..::..RoomCoefficientUtilizationWarning Property
BuiltInFailures..::..IlluminationFailures Class See Also Send Feedback
Estimated Illumination failed. Coefficient of utilization not set for lighting fixture.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RoomCoefficientUtilizationWarning { get; }
Visual Basic
Public Shared ReadOnly Property RoomCoefficientUtilizationWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomCoefficientUtilizationWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..IlluminationFailures Class


RoomLightLossFactorWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..IlluminationFailures..::..RoomLightLossFactorWarning Property
BuiltInFailures..::..IlluminationFailures Class See Also Send Feedback
Estimated Illumination failed. Light Loss factor not set for lighting fixture.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RoomLightLossFactorWarning { get; }
Visual Basic
Public Shared ReadOnly Property RoomLightLossFactorWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomLightLossFactorWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..IlluminationFailures Class


BuiltInFailures.ImageFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..ImageFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Image.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class ImageFailures
Visual Basic
Public NotInheritable Class ImageFailures
Visual C++
public ref class ImageFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..ImageFailures

See Also

BuiltInFailures..::..ImageFailures Members


BuiltInFailures.ImageFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..ImageFailures Members
BuiltInFailures..::..ImageFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..ImageFailures type exposes the following members.

Properties

Name | Description
BadViewType | Image Instances can't be placed in 3D Views.
InvalidHeight | The image height must be must be no more than 30000 feet.
InvalidWidth | The image width must be must be no more than 30000 feet.

See Also

BuiltInFailures..::..ImageFailures Class


BuiltInFailures.ImageFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..ImageFailures Properties
BuiltInFailures..::..ImageFailures Class See Also Send Feedback

The BuiltInFailures..::..ImageFailures type exposes the following members.

Properties

Name | Description
BadViewType | Image Instances can't be placed in 3D Views.
InvalidHeight | The image height must be must be no more than 30000 feet.
InvalidWidth | The image width must be must be no more than 30000 feet.

See Also

BuiltInFailures..::..ImageFailures Class


BadViewType Property

[image]

Revit 2024 API
BuiltInFailures..::..ImageFailures..::..BadViewType Property
BuiltInFailures..::..ImageFailures Class See Also Send Feedback
Image Instances can't be placed in 3D Views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId BadViewType { get; }
Visual Basic
Public Shared ReadOnly Property BadViewType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BadViewType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ImageFailures Class


InvalidHeight Property

[image]

Revit 2024 API
BuiltInFailures..::..ImageFailures..::..InvalidHeight Property
BuiltInFailures..::..ImageFailures Class See Also Send Feedback
The image height must be must be no more than 30000 feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidHeight { get; }
Visual Basic
Public Shared ReadOnly Property InvalidHeight As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidHeight {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ImageFailures Class


BuiltInFailures.ImportExportFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..ImportExportFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Import and Export.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class ImportExportFailures
Visual Basic
Public NotInheritable Class ImportExportFailures
Visual C++
public ref class ImportExportFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..ImportExportFailures

See Also

BuiltInFailures..::..ImportExportFailures Members


BuiltInFailures.ImportExportFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..ImportExportFailures Members
BuiltInFailures..::..ImportExportFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..ImportExportFailures type exposes the following members.

Properties

Name | Description
ViewBoundariesTooLarge | The view boundaries are too large to export the view..

See Also

BuiltInFailures..::..ImportExportFailures Class


BuiltInFailures.ImportExportFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..ImportExportFailures Properties
BuiltInFailures..::..ImportExportFailures Class See Also Send Feedback

The BuiltInFailures..::..ImportExportFailures type exposes the following members.

Properties

Name | Description
ViewBoundariesTooLarge | The view boundaries are too large to export the view..

See Also

BuiltInFailures..::..ImportExportFailures Class


ViewBoundariesTooLarge Property

[image]

Revit 2024 API
BuiltInFailures..::..ImportExportFailures..::..ViewBoundariesTooLarge Property
BuiltInFailures..::..ImportExportFailures Class See Also Send Feedback
The view boundaries are too large to export the view..

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ViewBoundariesTooLarge { get; }
Visual Basic
Public Shared ReadOnly Property ViewBoundariesTooLarge As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ViewBoundariesTooLarge {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ImportExportFailures Class


BuiltInFailures.ImportFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..ImportFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about ImportFailures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class ImportFailures
Visual Basic
Public NotInheritable Class ImportFailures
Visual C++
public ref class ImportFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..ImportFailures

See Also

BuiltInFailures..::..ImportFailures Members


BuiltInFailures.ImportFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..ImportFailures Members
BuiltInFailures..::..ImportFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..ImportFailures type exposes the following members.

Properties

Name | Description
ATFContainedUnsupportedGeometricData | The original model contains unsupported geometric data such as curves or points.
ATFNonUniformScalingTransform | The imported geometry contains non-uniform scaling transformations which Revit does not support. Some objects may be displaced or distorted.
BadFaceFoundInDwg | One or more hatch regions were found in the imported file with unconnected boundaries. These hatch regions will be ignored.
CannotChangeImportSymbol | Can't change an imported or linked element's symbol type.
CannotExplodeElement | Can't explode the imported object.
CannotImportFile | Can't import file.
ElementRenamedOnImport | There were duplicate names between the active model and the imported element. To avoid duplicate names, the imported element has been renamed.
FailedToSetWorkplane | Could not set Work Plane of [Import].\n\nPlease use the Work Plane tool to set a Work Plane for this view.
IFCCantUpdateLinkedFile | The cached version of this IFC file is already loaded into another document in this session, and can't be updated. To update the IFC file, please close all other documents containing the link, and then update.
IFCGenericImportWarning | The following problems were encountered in the IFC file: [Description]
IFCGenericRevitImportWarning | Revit had the following problems importing the IFC file: [Description]
IFCPartialSchemaSupport | IFC versions 4 and above are only partially supported by Open IFC. Consider using Link IFC instead.
ImportedModelIsEmpty | Imported model is empty.
ImportModelOutOfRange | The imported model is out of range.
ImportModelTooLarge | The imported model is too large.
ImportScaleTooLarge | This scale factor would make the imported object too large. Reverting to the previous scale factor.
ImportSymbolBaseLevelInvalid |
ImportTooFarAway | Imported objects located a large distance from the model might not display properly. The 'Center-to-Center' option will be used.
ImportTooManyElmentsToExplode | Import Instance has [Number] elements. Imports with more than 10,000 elements cannot be exploded.
LostAcisObjectsOnImport | Some ACIS objects could not be imported. To import them, use AutoCAD to convert them into polymesh objects and reimport.
SomeObjectsNotExploded | Import contained some 3D data or points which can't be exploded.
TextNotImported | Text is only imported if the "Current View Only" option is selected. To see the text in the original file, import again with this check box selected in the Import Dialog.
TooManyPickFaces | Too many faces were created from imported meshes. Host by Face tools may not select the imported meshes correctly. Decrease the complexity of the file or try importing only selected layers to resolve.
WorksetCreatedForLinkWarning | Newly created link types and instances were placed in new workset [workset name]

See Also

BuiltInFailures..::..ImportFailures Class


ATFContainedUnsupportedGeometricData Property

[image]

Revit 2024 API
BuiltInFailures..::..ImportFailures..::..ATFContainedUnsupportedGeometricData Property
BuiltInFailures..::..ImportFailures Class See Also Send Feedback
The original model contains unsupported geometric data such as curves or points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ATFContainedUnsupportedGeometricData { get; }
Visual Basic
Public Shared ReadOnly Property ATFContainedUnsupportedGeometricData As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ATFContainedUnsupportedGeometricData {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ImportFailures Class


ATFNonUniformScalingTransform Property

[image]

Revit 2024 API
BuiltInFailures..::..ImportFailures..::..ATFNonUniformScalingTransform Property
BuiltInFailures..::..ImportFailures Class See Also Send Feedback
The imported geometry contains non-uniform scaling transformations which Revit does not support. Some objects may be displaced or distorted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ATFNonUniformScalingTransform { get; }
Visual Basic
Public Shared ReadOnly Property ATFNonUniformScalingTransform As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ATFNonUniformScalingTransform {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ImportFailures Class


BadFaceFoundInDwg Property

[image]

Revit 2024 API
BuiltInFailures..::..ImportFailures..::..BadFaceFoundInDwg Property
BuiltInFailures..::..ImportFailures Class See Also Send Feedback
One or more hatch regions were found in the imported file with unconnected boundaries. These hatch regions will be ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId BadFaceFoundInDwg { get; }
Visual Basic
Public Shared ReadOnly Property BadFaceFoundInDwg As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BadFaceFoundInDwg {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ImportFailures Class


CannotChangeImportSymbol Property

[image]

Revit 2024 API
BuiltInFailures..::..ImportFailures..::..CannotChangeImportSymbol Property
BuiltInFailures..::..ImportFailures Class See Also Send Feedback
Can't change an imported or linked element's symbol type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotChangeImportSymbol { get; }
Visual Basic
Public Shared ReadOnly Property CannotChangeImportSymbol As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotChangeImportSymbol {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ImportFailures Class


CannotExplodeElement Property

[image]

Revit 2024 API
BuiltInFailures..::..ImportFailures..::..CannotExplodeElement Property
BuiltInFailures..::..ImportFailures Class See Also Send Feedback
Can't explode the imported object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotExplodeElement { get; }
Visual Basic
Public Shared ReadOnly Property CannotExplodeElement As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotExplodeElement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ImportFailures Class


CannotImportFile Property

[image]

Revit 2024 API
BuiltInFailures..::..ImportFailures..::..CannotImportFile Property
BuiltInFailures..::..ImportFailures Class See Also Send Feedback
Can't import file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotImportFile { get; }
Visual Basic
Public Shared ReadOnly Property CannotImportFile As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotImportFile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ImportFailures Class


FailedToSetWorkplane Property

[image]

Revit 2024 API
BuiltInFailures..::..ImportFailures..::..FailedToSetWorkplane Property
BuiltInFailures..::..ImportFailures Class See Also Send Feedback
Could not set Work Plane of [Import].\n\nPlease use the Work Plane tool to set a Work Plane for this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FailedToSetWorkplane { get; }
Visual Basic
Public Shared ReadOnly Property FailedToSetWorkplane As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FailedToSetWorkplane {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ImportFailures Class


IFCCantUpdateLinkedFile Property

[image]

Revit 2024 API
BuiltInFailures..::..ImportFailures..::..IFCCantUpdateLinkedFile Property
BuiltInFailures..::..ImportFailures Class See Also Send Feedback
The cached version of this IFC file is already loaded into another document in this session, and can't be updated. To update the IFC file, please close all other documents containing the link, and then update.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId IFCCantUpdateLinkedFile { get; }
Visual Basic
Public Shared ReadOnly Property IFCCantUpdateLinkedFile As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ IFCCantUpdateLinkedFile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ImportFailures Class


IFCGenericImportWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..ImportFailures..::..IFCGenericImportWarning Property
BuiltInFailures..::..ImportFailures Class See Also Send Feedback
The following problems were encountered in the IFC file: [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId IFCGenericImportWarning { get; }
Visual Basic
Public Shared ReadOnly Property IFCGenericImportWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ IFCGenericImportWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ImportFailures Class


IFCGenericRevitImportWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..ImportFailures..::..IFCGenericRevitImportWarning Property
BuiltInFailures..::..ImportFailures Class See Also Send Feedback
Revit had the following problems importing the IFC file: [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId IFCGenericRevitImportWarning { get; }
Visual Basic
Public Shared ReadOnly Property IFCGenericRevitImportWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ IFCGenericRevitImportWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ImportFailures Class


IFCPartialSchemaSupport Property

[image]

Revit 2024 API
BuiltInFailures..::..ImportFailures..::..IFCPartialSchemaSupport Property
BuiltInFailures..::..ImportFailures Class See Also Send Feedback
IFC versions 4 and above are only partially supported by Open IFC. Consider using Link IFC instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId IFCPartialSchemaSupport { get; }
Visual Basic
Public Shared ReadOnly Property IFCPartialSchemaSupport As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ IFCPartialSchemaSupport {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ImportFailures Class


ImportedModelIsEmpty Property

[image]

Revit 2024 API
BuiltInFailures..::..ImportFailures..::..ImportedModelIsEmpty Property
BuiltInFailures..::..ImportFailures Class See Also Send Feedback
Imported model is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ImportedModelIsEmpty { get; }
Visual Basic
Public Shared ReadOnly Property ImportedModelIsEmpty As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ImportedModelIsEmpty {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ImportFailures Class


ImportModelOutOfRange Property

[image]

Revit 2024 API
BuiltInFailures..::..ImportFailures..::..ImportModelOutOfRange Property
BuiltInFailures..::..ImportFailures Class See Also Send Feedback
The imported model is out of range.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ImportModelOutOfRange { get; }
Visual Basic
Public Shared ReadOnly Property ImportModelOutOfRange As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ImportModelOutOfRange {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ImportFailures Class


ImportModelTooLarge Property

[image]

Revit 2024 API
BuiltInFailures..::..ImportFailures..::..ImportModelTooLarge Property
BuiltInFailures..::..ImportFailures Class See Also Send Feedback
The imported model is too large.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ImportModelTooLarge { get; }
Visual Basic
Public Shared ReadOnly Property ImportModelTooLarge As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ImportModelTooLarge {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ImportFailures Class


ImportScaleTooLarge Property

[image]

Revit 2024 API
BuiltInFailures..::..ImportFailures..::..ImportScaleTooLarge Property
BuiltInFailures..::..ImportFailures Class See Also Send Feedback
This scale factor would make the imported object too large. Reverting to the previous scale factor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ImportScaleTooLarge { get; }
Visual Basic
Public Shared ReadOnly Property ImportScaleTooLarge As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ImportScaleTooLarge {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ImportFailures Class


ImportSymbolBaseLevelInvalid Property

[image]

Revit 2024 API
BuiltInFailures..::..ImportFailures..::..ImportSymbolBaseLevelInvalid Property
BuiltInFailures..::..ImportFailures Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ImportSymbolBaseLevelInvalid { get; }
Visual Basic
Public Shared ReadOnly Property ImportSymbolBaseLevelInvalid As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ImportSymbolBaseLevelInvalid {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ImportFailures Class


ImportTooManyElmentsToExplode Property

[image]

Revit 2024 API
BuiltInFailures..::..ImportFailures..::..ImportTooManyElmentsToExplode Property
BuiltInFailures..::..ImportFailures Class See Also Send Feedback
Import Instance has [Number] elements. Imports with more than 10,000 elements cannot be exploded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ImportTooManyElmentsToExplode { get; }
Visual Basic
Public Shared ReadOnly Property ImportTooManyElmentsToExplode As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ImportTooManyElmentsToExplode {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ImportFailures Class


SomeObjectsNotExploded Property

[image]

Revit 2024 API
BuiltInFailures..::..ImportFailures..::..SomeObjectsNotExploded Property
BuiltInFailures..::..ImportFailures Class See Also Send Feedback
Import contained some 3D data or points which can't be exploded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SomeObjectsNotExploded { get; }
Visual Basic
Public Shared ReadOnly Property SomeObjectsNotExploded As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SomeObjectsNotExploded {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ImportFailures Class


TextNotImported Property

[image]

Revit 2024 API
BuiltInFailures..::..ImportFailures..::..TextNotImported Property
BuiltInFailures..::..ImportFailures Class See Also Send Feedback
Text is only imported if the "Current View Only" option is selected. To see the text in the original file, import again with this check box selected in the Import Dialog.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId TextNotImported { get; }
Visual Basic
Public Shared ReadOnly Property TextNotImported As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TextNotImported {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ImportFailures Class


TooManyPickFaces Property

[image]

Revit 2024 API
BuiltInFailures..::..ImportFailures..::..TooManyPickFaces Property
BuiltInFailures..::..ImportFailures Class See Also Send Feedback
Too many faces were created from imported meshes. Host by Face tools may not select the imported meshes correctly. Decrease the complexity of the file or try importing only selected layers to resolve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId TooManyPickFaces { get; }
Visual Basic
Public Shared ReadOnly Property TooManyPickFaces As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TooManyPickFaces {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ImportFailures Class


WorksetCreatedForLinkWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..ImportFailures..::..WorksetCreatedForLinkWarning Property
BuiltInFailures..::..ImportFailures Class See Also Send Feedback
Newly created link types and instances were placed in new workset [workset name]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WorksetCreatedForLinkWarning { get; }
Visual Basic
Public Shared ReadOnly Property WorksetCreatedForLinkWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WorksetCreatedForLinkWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ImportFailures Class


BuiltInFailures.InaccurateFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..InaccurateFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Inaccurate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class InaccurateFailures
Visual Basic
Public NotInheritable Class InaccurateFailures
Visual C++
public ref class InaccurateFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..InaccurateFailures

See Also

BuiltInFailures..::..InaccurateFailures Members


BuiltInFailures.InaccurateFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..InaccurateFailures Members
BuiltInFailures..::..InaccurateFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..InaccurateFailures type exposes the following members.

Properties

Name | Description
InaccurateAreaLine | Area separation line is slightly off axis and may cause inaccuracies.
InaccurateBeamOrBrace | Beam or Brace is slightly off axis and may cause inaccuracies.
InaccurateCurveBasedFamily | Curve-Based Family is slightly off axis and may cause inaccuracies.
InaccurateDriveCurve | Element is slightly off axis and may cause inaccuracies.
InaccurateGrid | Grid is slightly off axis and may cause inaccuracies.
InaccurateLevel | Level is slightly off axis and may cause inaccuracies.
InaccurateLine | Line is slightly off axis and may cause inaccuracies.
InaccurateMassingSketchLine | Line in Massing Sketch is slightly off axis and may cause inaccuracies.
InaccurateRefPlane | Ref Plane is slightly off axis and may cause inaccuracies.
InaccurateRoomSeparation | Room separation line is slightly off axis and may cause inaccuracies.
InaccurateSketchLine | Line in Sketch is slightly off axis and may cause inaccuracies.
InaccurateSpaceSeparation | Space separation line is slightly off axis and may cause inaccuracies.
InaccurateWall | Wall is slightly off axis and may cause inaccuracies.

See Also

BuiltInFailures..::..InaccurateFailures Class


BuiltInFailures.InaccurateFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..InaccurateFailures Properties
BuiltInFailures..::..InaccurateFailures Class See Also Send Feedback

The BuiltInFailures..::..InaccurateFailures type exposes the following members.

Properties

Name | Description
InaccurateAreaLine | Area separation line is slightly off axis and may cause inaccuracies.
InaccurateBeamOrBrace | Beam or Brace is slightly off axis and may cause inaccuracies.
InaccurateCurveBasedFamily | Curve-Based Family is slightly off axis and may cause inaccuracies.
InaccurateDriveCurve | Element is slightly off axis and may cause inaccuracies.
InaccurateGrid | Grid is slightly off axis and may cause inaccuracies.
InaccurateLevel | Level is slightly off axis and may cause inaccuracies.
InaccurateLine | Line is slightly off axis and may cause inaccuracies.
InaccurateMassingSketchLine | Line in Massing Sketch is slightly off axis and may cause inaccuracies.
InaccurateRefPlane | Ref Plane is slightly off axis and may cause inaccuracies.
InaccurateRoomSeparation | Room separation line is slightly off axis and may cause inaccuracies.
InaccurateSketchLine | Line in Sketch is slightly off axis and may cause inaccuracies.
InaccurateSpaceSeparation | Space separation line is slightly off axis and may cause inaccuracies.
InaccurateWall | Wall is slightly off axis and may cause inaccuracies.

See Also

BuiltInFailures..::..InaccurateFailures Class


InaccurateBeamOrBrace Property

[image]

Revit 2024 API
BuiltInFailures..::..InaccurateFailures..::..InaccurateBeamOrBrace Property
BuiltInFailures..::..InaccurateFailures Class See Also Send Feedback
Beam or Brace is slightly off axis and may cause inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InaccurateBeamOrBrace { get; }
Visual Basic
Public Shared ReadOnly Property InaccurateBeamOrBrace As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InaccurateBeamOrBrace {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..InaccurateFailures Class


InaccurateCurveBasedFamily Property

[image]

Revit 2024 API
BuiltInFailures..::..InaccurateFailures..::..InaccurateCurveBasedFamily Property
BuiltInFailures..::..InaccurateFailures Class See Also Send Feedback
Curve-Based Family is slightly off axis and may cause inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InaccurateCurveBasedFamily { get; }
Visual Basic
Public Shared ReadOnly Property InaccurateCurveBasedFamily As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InaccurateCurveBasedFamily {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..InaccurateFailures Class


InaccurateDriveCurve Property

[image]

Revit 2024 API
BuiltInFailures..::..InaccurateFailures..::..InaccurateDriveCurve Property
BuiltInFailures..::..InaccurateFailures Class See Also Send Feedback
Element is slightly off axis and may cause inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InaccurateDriveCurve { get; }
Visual Basic
Public Shared ReadOnly Property InaccurateDriveCurve As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InaccurateDriveCurve {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..InaccurateFailures Class


InaccurateGrid Property

[image]

Revit 2024 API
BuiltInFailures..::..InaccurateFailures..::..InaccurateGrid Property
BuiltInFailures..::..InaccurateFailures Class See Also Send Feedback
Grid is slightly off axis and may cause inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InaccurateGrid { get; }
Visual Basic
Public Shared ReadOnly Property InaccurateGrid As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InaccurateGrid {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..InaccurateFailures Class


InaccurateLevel Property

[image]

Revit 2024 API
BuiltInFailures..::..InaccurateFailures..::..InaccurateLevel Property
BuiltInFailures..::..InaccurateFailures Class See Also Send Feedback
Level is slightly off axis and may cause inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InaccurateLevel { get; }
Visual Basic
Public Shared ReadOnly Property InaccurateLevel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InaccurateLevel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..InaccurateFailures Class


InaccurateLine Property

[image]

Revit 2024 API
BuiltInFailures..::..InaccurateFailures..::..InaccurateLine Property
BuiltInFailures..::..InaccurateFailures Class See Also Send Feedback
Line is slightly off axis and may cause inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InaccurateLine { get; }
Visual Basic
Public Shared ReadOnly Property InaccurateLine As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InaccurateLine {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..InaccurateFailures Class


InaccurateMassingSketchLine Property

[image]

Revit 2024 API
BuiltInFailures..::..InaccurateFailures..::..InaccurateMassingSketchLine Property
BuiltInFailures..::..InaccurateFailures Class See Also Send Feedback
Line in Massing Sketch is slightly off axis and may cause inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InaccurateMassingSketchLine { get; }
Visual Basic
Public Shared ReadOnly Property InaccurateMassingSketchLine As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InaccurateMassingSketchLine {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..InaccurateFailures Class


InaccurateRoomSeparation Property

[image]

Revit 2024 API
BuiltInFailures..::..InaccurateFailures..::..InaccurateRoomSeparation Property
BuiltInFailures..::..InaccurateFailures Class See Also Send Feedback
Room separation line is slightly off axis and may cause inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InaccurateRoomSeparation { get; }
Visual Basic
Public Shared ReadOnly Property InaccurateRoomSeparation As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InaccurateRoomSeparation {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..InaccurateFailures Class


InaccurateSpaceSeparation Property

[image]

Revit 2024 API
BuiltInFailures..::..InaccurateFailures..::..InaccurateSpaceSeparation Property
BuiltInFailures..::..InaccurateFailures Class See Also Send Feedback
Space separation line is slightly off axis and may cause inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InaccurateSpaceSeparation { get; }
Visual Basic
Public Shared ReadOnly Property InaccurateSpaceSeparation As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InaccurateSpaceSeparation {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..InaccurateFailures Class


InaccurateWall Property

[image]

Revit 2024 API
BuiltInFailures..::..InaccurateFailures..::..InaccurateWall Property
BuiltInFailures..::..InaccurateFailures Class See Also Send Feedback
Wall is slightly off axis and may cause inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InaccurateWall { get; }
Visual Basic
Public Shared ReadOnly Property InaccurateWall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InaccurateWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..InaccurateFailures Class


BuiltInFailures.InfillFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..InfillFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Infill.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class InfillFailures
Visual Basic
Public NotInheritable Class InfillFailures
Visual C++
public ref class InfillFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..InfillFailures

See Also

BuiltInFailures..::..InfillFailures Members


BuiltInFailures.InfillFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..InfillFailures Properties
BuiltInFailures..::..InfillFailures Class See Also Send Feedback

The BuiltInFailures..::..InfillFailures type exposes the following members.

Properties

Name | Description
CannotDeleteInfill | Can't delete infilling element without deleting its insert or host.
FamilyInstanceIsNotCuttingHost | Instance is not cutting host.
InfillCannotChangeType | Infilling element replaced by a later phase insert must be the same type as the insert's host.
InfillCannotHaveDiffThickness | This infilling element must have the same thickness as its host.
InfillDifferentPhase | Wall and instance have different phasing settings. Automatic creation of the infilling wall fails.
InfillLost | Standalone infilling Wall is separated from its insert.
InfillNoSlopeGlazing | Could not change type due to highlighted infilling element. 'Sloped glazing' infills are not allowed.
InfillNoThicknessCeiling | Could not change type due to highlighted infilling element. 'Basic Ceiling' infills are only compatible with 'Basic Ceiling' hosts.
InfillNoThicknessMultiface | Highlighted infilling element could not have thickness different from its host because it spans multiple faces.
InPlaceFamilyNotCuttingHost | Instance of in-place family is not cutting host.
InsertJoinedWall | Insert conflicts with joined Wall.
InsertOverlapsOrOut | Highlighted inserts overlap with other inserts or completely miss their hosts.
MovedInfillToHost | Infilling element was automatically moved to keep it aligned to host.

See Also

BuiltInFailures..::..InfillFailures Class


CannotDeleteInfill Property

[image]

Revit 2024 API
BuiltInFailures..::..InfillFailures..::..CannotDeleteInfill Property
BuiltInFailures..::..InfillFailures Class See Also Send Feedback
Can't delete infilling element without deleting its insert or host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotDeleteInfill { get; }
Visual Basic
Public Shared ReadOnly Property CannotDeleteInfill As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDeleteInfill {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..InfillFailures Class


InfillCannotChangeType Property

[image]

Revit 2024 API
BuiltInFailures..::..InfillFailures..::..InfillCannotChangeType Property
BuiltInFailures..::..InfillFailures Class See Also Send Feedback
Infilling element replaced by a later phase insert must be the same type as the insert's host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InfillCannotChangeType { get; }
Visual Basic
Public Shared ReadOnly Property InfillCannotChangeType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InfillCannotChangeType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..InfillFailures Class


InfillCannotHaveDiffThickness Property

[image]

Revit 2024 API
BuiltInFailures..::..InfillFailures..::..InfillCannotHaveDiffThickness Property
BuiltInFailures..::..InfillFailures Class See Also Send Feedback
This infilling element must have the same thickness as its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InfillCannotHaveDiffThickness { get; }
Visual Basic
Public Shared ReadOnly Property InfillCannotHaveDiffThickness As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InfillCannotHaveDiffThickness {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..InfillFailures Class


InfillDifferentPhase Property

[image]

Revit 2024 API
BuiltInFailures..::..InfillFailures..::..InfillDifferentPhase Property
BuiltInFailures..::..InfillFailures Class See Also Send Feedback
Wall and instance have different phasing settings. Automatic creation of the infilling wall fails.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InfillDifferentPhase { get; }
Visual Basic
Public Shared ReadOnly Property InfillDifferentPhase As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InfillDifferentPhase {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..InfillFailures Class


InfillLost Property

[image]

Revit 2024 API
BuiltInFailures..::..InfillFailures..::..InfillLost Property
BuiltInFailures..::..InfillFailures Class See Also Send Feedback
Standalone infilling Wall is separated from its insert.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InfillLost { get; }
Visual Basic
Public Shared ReadOnly Property InfillLost As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InfillLost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..InfillFailures Class


InfillNoSlopeGlazing Property

[image]

Revit 2024 API
BuiltInFailures..::..InfillFailures..::..InfillNoSlopeGlazing Property
BuiltInFailures..::..InfillFailures Class See Also Send Feedback
Could not change type due to highlighted infilling element. 'Sloped glazing' infills are not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InfillNoSlopeGlazing { get; }
Visual Basic
Public Shared ReadOnly Property InfillNoSlopeGlazing As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InfillNoSlopeGlazing {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..InfillFailures Class


InfillNoThicknessMultiface Property

[image]

Revit 2024 API
BuiltInFailures..::..InfillFailures..::..InfillNoThicknessMultiface Property
BuiltInFailures..::..InfillFailures Class See Also Send Feedback
Highlighted infilling element could not have thickness different from its host because it spans multiple faces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InfillNoThicknessMultiface { get; }
Visual Basic
Public Shared ReadOnly Property InfillNoThicknessMultiface As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InfillNoThicknessMultiface {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..InfillFailures Class


InsertOverlapsOrOut Property

[image]

Revit 2024 API
BuiltInFailures..::..InfillFailures..::..InsertOverlapsOrOut Property
BuiltInFailures..::..InfillFailures Class See Also Send Feedback
Highlighted inserts overlap with other inserts or completely miss their hosts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InsertOverlapsOrOut { get; }
Visual Basic
Public Shared ReadOnly Property InsertOverlapsOrOut As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InsertOverlapsOrOut {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..InfillFailures Class


MovedInfillToHost Property

[image]

Revit 2024 API
BuiltInFailures..::..InfillFailures..::..MovedInfillToHost Property
BuiltInFailures..::..InfillFailures Class See Also Send Feedback
Infilling element was automatically moved to keep it aligned to host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MovedInfillToHost { get; }
Visual Basic
Public Shared ReadOnly Property MovedInfillToHost As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MovedInfillToHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..InfillFailures Class


BuiltInFailures.InterferenceFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..InterferenceFailures Members
BuiltInFailures..::..InterferenceFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..InterferenceFailures type exposes the following members.

Properties

Name | Description
GeometryWarning | A geometrical error has occurred while checking for Interference. Reported interference may not be accurate.

See Also

BuiltInFailures..::..InterferenceFailures Class


BuiltInFailures.InterferenceFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..InterferenceFailures Properties
BuiltInFailures..::..InterferenceFailures Class See Also Send Feedback

The BuiltInFailures..::..InterferenceFailures type exposes the following members.

Properties

Name | Description
GeometryWarning | A geometrical error has occurred while checking for Interference. Reported interference may not be accurate.

See Also

BuiltInFailures..::..InterferenceFailures Class


GeometryWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..InterferenceFailures..::..GeometryWarning Property
BuiltInFailures..::..InterferenceFailures Class See Also Send Feedback
A geometrical error has occurred while checking for Interference. Reported interference may not be accurate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId GeometryWarning { get; }
Visual Basic
Public Shared ReadOnly Property GeometryWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GeometryWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..InterferenceFailures Class


BuiltInFailures.JoinElementsFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..JoinElementsFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about JoinElements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class JoinElementsFailures
Visual Basic
Public NotInheritable Class JoinElementsFailures
Visual C++
public ref class JoinElementsFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..JoinElementsFailures

See Also

BuiltInFailures..::..JoinElementsFailures Members


BuiltInFailures.JoinElementsFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..JoinElementsFailures Members
BuiltInFailures..::..JoinElementsFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..JoinElementsFailures type exposes the following members.

Properties

Name | Description
CannotCope | Can't apply Coping.
CannotCutJoinedGeometry | Element could not be cut by joined element.
CannotJoinDesignOptions | An element cannot join to an element in a secondary Design Option unless it is in the same secondary Design Option.
CannotJoinElements | Can't keep elements joined.
CannotJoinElementsError | Can't keep elements joined.
CannotJoinElementsMultiPlaneError | Can't keep elements joined.
CannotJoinElementsStructural | Can't keep elements joined.
CannotJoinElementsStructuralError | Can't keep elements joined.
CannotJoinElementsWarn | Can't keep elements joined.
CannotJoinRoof | The roof cannot be joined.
CannotJoinRoofError | The roof cannot be joined.
CannotKeepJoined | Can't keep elements joined.
CannotKeepReferenceOfJoinedElement | Can't keep reference of joined element.
CannotKeepReferenceOfJoinedElementWarning | Can't keep reference of joined element.
CannotKeepTrussJoined | Can't keep the highlighted [Element]s joined.
CannotKeepWallJoinToRoof | Can't keep wall and [target] joined
CannotKeepWallJoinToRoofError | Can't keep wall and [target] joined
ElementWillBeDetachedFromPlane | Element will be detached from its associated plane
FootingWillMoveToBottom | An attached Structural Foundation will be moved to the bottom of the Column.
JoiningDisjoint | Highlighted elements are joined but do not intersect.
JoiningDisjointWarn | Highlighted elements are joined but do not intersect.
StairsComponentTypeUnsupportedError | The selected stair type/shape isn't supported for attaching a wall to a stair. To continue, detach the wall from the stairs' components.
StructGroupMemberWillDetachFromGrid | A structural element will be detached from grid(s) due to inconsistent group membership.
WallTypeUnsupportedError | The selected wall type/shape isn't supported for attaching a wall to a stair. To continue, detach the wall from the stairs' components.

See Also

BuiltInFailures..::..JoinElementsFailures Class


BuiltInFailures.JoinElementsFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..JoinElementsFailures Properties
BuiltInFailures..::..JoinElementsFailures Class See Also Send Feedback

The BuiltInFailures..::..JoinElementsFailures type exposes the following members.

Properties

Name | Description
CannotCope | Can't apply Coping.
CannotCutJoinedGeometry | Element could not be cut by joined element.
CannotJoinDesignOptions | An element cannot join to an element in a secondary Design Option unless it is in the same secondary Design Option.
CannotJoinElements | Can't keep elements joined.
CannotJoinElementsError | Can't keep elements joined.
CannotJoinElementsMultiPlaneError | Can't keep elements joined.
CannotJoinElementsStructural | Can't keep elements joined.
CannotJoinElementsStructuralError | Can't keep elements joined.
CannotJoinElementsWarn | Can't keep elements joined.
CannotJoinRoof | The roof cannot be joined.
CannotJoinRoofError | The roof cannot be joined.
CannotKeepJoined | Can't keep elements joined.
CannotKeepReferenceOfJoinedElement | Can't keep reference of joined element.
CannotKeepReferenceOfJoinedElementWarning | Can't keep reference of joined element.
CannotKeepTrussJoined | Can't keep the highlighted [Element]s joined.
CannotKeepWallJoinToRoof | Can't keep wall and [target] joined
CannotKeepWallJoinToRoofError | Can't keep wall and [target] joined
ElementWillBeDetachedFromPlane | Element will be detached from its associated plane
FootingWillMoveToBottom | An attached Structural Foundation will be moved to the bottom of the Column.
JoiningDisjoint | Highlighted elements are joined but do not intersect.
JoiningDisjointWarn | Highlighted elements are joined but do not intersect.
StairsComponentTypeUnsupportedError | The selected stair type/shape isn't supported for attaching a wall to a stair. To continue, detach the wall from the stairs' components.
StructGroupMemberWillDetachFromGrid | A structural element will be detached from grid(s) due to inconsistent group membership.
WallTypeUnsupportedError | The selected wall type/shape isn't supported for attaching a wall to a stair. To continue, detach the wall from the stairs' components.

See Also

BuiltInFailures..::..JoinElementsFailures Class


CannotCutJoinedGeometry Property

[image]

Revit 2024 API
BuiltInFailures..::..JoinElementsFailures..::..CannotCutJoinedGeometry Property
BuiltInFailures..::..JoinElementsFailures Class See Also Send Feedback
Element could not be cut by joined element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCutJoinedGeometry { get; }
Visual Basic
Public Shared ReadOnly Property CannotCutJoinedGeometry As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCutJoinedGeometry {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..JoinElementsFailures Class


CannotJoinDesignOptions Property

[image]

Revit 2024 API
BuiltInFailures..::..JoinElementsFailures..::..CannotJoinDesignOptions Property
BuiltInFailures..::..JoinElementsFailures Class See Also Send Feedback
An element cannot join to an element in a secondary Design Option unless it is in the same secondary Design Option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotJoinDesignOptions { get; }
Visual Basic
Public Shared ReadOnly Property CannotJoinDesignOptions As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotJoinDesignOptions {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..JoinElementsFailures Class


CannotJoinElementsError Property

[image]

Revit 2024 API
BuiltInFailures..::..JoinElementsFailures..::..CannotJoinElementsError Property
BuiltInFailures..::..JoinElementsFailures Class See Also Send Feedback
Can't keep elements joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotJoinElementsError { get; }
Visual Basic
Public Shared ReadOnly Property CannotJoinElementsError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotJoinElementsError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..JoinElementsFailures Class


CannotJoinElementsMultiPlaneError Property

[image]

Revit 2024 API
BuiltInFailures..::..JoinElementsFailures..::..CannotJoinElementsMultiPlaneError Property
BuiltInFailures..::..JoinElementsFailures Class See Also Send Feedback
Can't keep elements joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotJoinElementsMultiPlaneError { get; }
Visual Basic
Public Shared ReadOnly Property CannotJoinElementsMultiPlaneError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotJoinElementsMultiPlaneError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..JoinElementsFailures Class


CannotJoinElementsStructural Property

[image]

Revit 2024 API
BuiltInFailures..::..JoinElementsFailures..::..CannotJoinElementsStructural Property
BuiltInFailures..::..JoinElementsFailures Class See Also Send Feedback
Can't keep elements joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotJoinElementsStructural { get; }
Visual Basic
Public Shared ReadOnly Property CannotJoinElementsStructural As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotJoinElementsStructural {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..JoinElementsFailures Class


CannotJoinElementsStructuralError Property

[image]

Revit 2024 API
BuiltInFailures..::..JoinElementsFailures..::..CannotJoinElementsStructuralError Property
BuiltInFailures..::..JoinElementsFailures Class See Also Send Feedback
Can't keep elements joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotJoinElementsStructuralError { get; }
Visual Basic
Public Shared ReadOnly Property CannotJoinElementsStructuralError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotJoinElementsStructuralError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..JoinElementsFailures Class


CannotJoinElementsWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..JoinElementsFailures..::..CannotJoinElementsWarn Property
BuiltInFailures..::..JoinElementsFailures Class See Also Send Feedback
Can't keep elements joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotJoinElementsWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotJoinElementsWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotJoinElementsWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..JoinElementsFailures Class


CannotJoinRoof Property

[image]

Revit 2024 API
BuiltInFailures..::..JoinElementsFailures..::..CannotJoinRoof Property
BuiltInFailures..::..JoinElementsFailures Class See Also Send Feedback
The roof cannot be joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotJoinRoof { get; }
Visual Basic
Public Shared ReadOnly Property CannotJoinRoof As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotJoinRoof {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..JoinElementsFailures Class


CannotJoinRoofError Property

[image]

Revit 2024 API
BuiltInFailures..::..JoinElementsFailures..::..CannotJoinRoofError Property
BuiltInFailures..::..JoinElementsFailures Class See Also Send Feedback
The roof cannot be joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotJoinRoofError { get; }
Visual Basic
Public Shared ReadOnly Property CannotJoinRoofError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotJoinRoofError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..JoinElementsFailures Class


CannotKeepJoined Property

[image]

Revit 2024 API
BuiltInFailures..::..JoinElementsFailures..::..CannotKeepJoined Property
BuiltInFailures..::..JoinElementsFailures Class See Also Send Feedback
Can't keep elements joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotKeepJoined { get; }
Visual Basic
Public Shared ReadOnly Property CannotKeepJoined As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotKeepJoined {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..JoinElementsFailures Class


CannotKeepWallJoinToRoof Property

[image]

Revit 2024 API
BuiltInFailures..::..JoinElementsFailures..::..CannotKeepWallJoinToRoof Property
BuiltInFailures..::..JoinElementsFailures Class See Also Send Feedback
Can't keep wall and [target] joined

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotKeepWallJoinToRoof { get; }
Visual Basic
Public Shared ReadOnly Property CannotKeepWallJoinToRoof As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotKeepWallJoinToRoof {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..JoinElementsFailures Class


CannotKeepWallJoinToRoofError Property

[image]

Revit 2024 API
BuiltInFailures..::..JoinElementsFailures..::..CannotKeepWallJoinToRoofError Property
BuiltInFailures..::..JoinElementsFailures Class See Also Send Feedback
Can't keep wall and [target] joined

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotKeepWallJoinToRoofError { get; }
Visual Basic
Public Shared ReadOnly Property CannotKeepWallJoinToRoofError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotKeepWallJoinToRoofError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..JoinElementsFailures Class


ElementWillBeDetachedFromPlane Property

[image]

Revit 2024 API
BuiltInFailures..::..JoinElementsFailures..::..ElementWillBeDetachedFromPlane Property
BuiltInFailures..::..JoinElementsFailures Class See Also Send Feedback
Element will be detached from its associated plane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ElementWillBeDetachedFromPlane { get; }
Visual Basic
Public Shared ReadOnly Property ElementWillBeDetachedFromPlane As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementWillBeDetachedFromPlane {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..JoinElementsFailures Class


JoiningDisjoint Property

[image]

Revit 2024 API
BuiltInFailures..::..JoinElementsFailures..::..JoiningDisjoint Property
BuiltInFailures..::..JoinElementsFailures Class See Also Send Feedback
Highlighted elements are joined but do not intersect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId JoiningDisjoint { get; }
Visual Basic
Public Shared ReadOnly Property JoiningDisjoint As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ JoiningDisjoint {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..JoinElementsFailures Class


JoiningDisjointWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..JoinElementsFailures..::..JoiningDisjointWarn Property
BuiltInFailures..::..JoinElementsFailures Class See Also Send Feedback
Highlighted elements are joined but do not intersect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId JoiningDisjointWarn { get; }
Visual Basic
Public Shared ReadOnly Property JoiningDisjointWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ JoiningDisjointWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..JoinElementsFailures Class


StairsComponentTypeUnsupportedError Property

[image]

Revit 2024 API
BuiltInFailures..::..JoinElementsFailures..::..StairsComponentTypeUnsupportedError Property
BuiltInFailures..::..JoinElementsFailures Class See Also Send Feedback
The selected stair type/shape isn't supported for attaching a wall to a stair. To continue, detach the wall from the stairs' components.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StairsComponentTypeUnsupportedError { get; }
Visual Basic
Public Shared ReadOnly Property StairsComponentTypeUnsupportedError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairsComponentTypeUnsupportedError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..JoinElementsFailures Class


StructGroupMemberWillDetachFromGrid Property

[image]

Revit 2024 API
BuiltInFailures..::..JoinElementsFailures..::..StructGroupMemberWillDetachFromGrid Property
BuiltInFailures..::..JoinElementsFailures Class See Also Send Feedback
A structural element will be detached from grid(s) due to inconsistent group membership.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StructGroupMemberWillDetachFromGrid { get; }
Visual Basic
Public Shared ReadOnly Property StructGroupMemberWillDetachFromGrid As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StructGroupMemberWillDetachFromGrid {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..JoinElementsFailures Class


WallTypeUnsupportedError Property

[image]

Revit 2024 API
BuiltInFailures..::..JoinElementsFailures..::..WallTypeUnsupportedError Property
BuiltInFailures..::..JoinElementsFailures Class See Also Send Feedback
The selected wall type/shape isn't supported for attaching a wall to a stair. To continue, detach the wall from the stairs' components.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WallTypeUnsupportedError { get; }
Visual Basic
Public Shared ReadOnly Property WallTypeUnsupportedError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WallTypeUnsupportedError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..JoinElementsFailures Class


BuiltInFailures.KeyBasedTreeEntryFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..KeyBasedTreeEntryFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about KeyBasedTreeEntry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class KeyBasedTreeEntryFailures
Visual Basic
Public NotInheritable Class KeyBasedTreeEntryFailures
Visual C++
public ref class KeyBasedTreeEntryFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..KeyBasedTreeEntryFailures

See Also

BuiltInFailures..::..KeyBasedTreeEntryFailures Members


BuiltInFailures.KeyBasedTreeEntryFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..KeyBasedTreeEntryFailures Properties
BuiltInFailures..::..KeyBasedTreeEntryFailures Class See Also Send Feedback

The BuiltInFailures..::..KeyBasedTreeEntryFailures type exposes the following members.

Properties

Name | Description
BadClassificationLevel | Level [Level] of Classification [Code] is not an integer from 1 to 5.
CircularParentage | A sub-[EntryType] '[Code]' specified as parent for its current ancestor '[Code]'
DuplicateEntry | Duplicate code '[Code]', description: '[Description]'
MissingParent | No parent [EntryType] '[Code]' for '[Code]'

See Also

BuiltInFailures..::..KeyBasedTreeEntryFailures Class


BadClassificationLevel Property

[image]

Revit 2024 API
BuiltInFailures..::..KeyBasedTreeEntryFailures..::..BadClassificationLevel Property
BuiltInFailures..::..KeyBasedTreeEntryFailures Class See Also Send Feedback
Level [Level] of Classification [Code] is not an integer from 1 to 5.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId BadClassificationLevel { get; }
Visual Basic
Public Shared ReadOnly Property BadClassificationLevel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BadClassificationLevel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..KeyBasedTreeEntryFailures Class


CircularParentage Property

[image]

Revit 2024 API
BuiltInFailures..::..KeyBasedTreeEntryFailures..::..CircularParentage Property
BuiltInFailures..::..KeyBasedTreeEntryFailures Class See Also Send Feedback
A sub-[EntryType] '[Code]' specified as parent for its current ancestor '[Code]'

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CircularParentage { get; }
Visual Basic
Public Shared ReadOnly Property CircularParentage As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CircularParentage {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..KeyBasedTreeEntryFailures Class


DuplicateEntry Property

[image]

Revit 2024 API
BuiltInFailures..::..KeyBasedTreeEntryFailures..::..DuplicateEntry Property
BuiltInFailures..::..KeyBasedTreeEntryFailures Class See Also Send Feedback
Duplicate code '[Code]', description: '[Description]'

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DuplicateEntry { get; }
Visual Basic
Public Shared ReadOnly Property DuplicateEntry As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DuplicateEntry {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..KeyBasedTreeEntryFailures Class


MissingParent Property

[image]

Revit 2024 API
BuiltInFailures..::..KeyBasedTreeEntryFailures..::..MissingParent Property
BuiltInFailures..::..KeyBasedTreeEntryFailures Class See Also Send Feedback
No parent [EntryType] '[Code]' for '[Code]'

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MissingParent { get; }
Visual Basic
Public Shared ReadOnly Property MissingParent As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MissingParent {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..KeyBasedTreeEntryFailures Class


BuiltInFailures.KeyBasedTreeFileFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..KeyBasedTreeFileFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures occurred when reading key based tree text file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class KeyBasedTreeFileFailures
Visual Basic
Public NotInheritable Class KeyBasedTreeFileFailures
Visual C++
public ref class KeyBasedTreeFileFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..KeyBasedTreeFileFailures

See Also

BuiltInFailures..::..KeyBasedTreeFileFailures Members


BuiltInFailures.KeyBasedTreeFileFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..KeyBasedTreeFileFailures Members
BuiltInFailures..::..KeyBasedTreeFileFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..KeyBasedTreeFileFailures type exposes the following members.

Properties

Name | Description
CannotOpenFileForRead | Cannot open file [FileName].
CannotUnderstandAtLine | Cannot understand [EntryType] line '[Number]'

See Also

BuiltInFailures..::..KeyBasedTreeFileFailures Class


CannotUnderstandAtLine Property

[image]

Revit 2024 API
BuiltInFailures..::..KeyBasedTreeFileFailures..::..CannotUnderstandAtLine Property
BuiltInFailures..::..KeyBasedTreeFileFailures Class See Also Send Feedback
Cannot understand [EntryType] line '[Number]'

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotUnderstandAtLine { get; }
Visual Basic
Public Shared ReadOnly Property CannotUnderstandAtLine As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotUnderstandAtLine {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..KeyBasedTreeFileFailures Class


BuiltInFailures.KeynoteFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..KeynoteFailures Members
BuiltInFailures..::..KeynoteFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..KeynoteFailures type exposes the following members.

Properties

Name | Description
MissKeynoteParameter | No Keynote Parameter.\nTo resolve, select key value parameter in keynoting system.
MissKeynotingSystem | No Keynoting System associated with Tag Family.\nTo resolve, select keynoting system for the tag family.
NotAssociatedKeynoteParameter | Current tag keynoting system uses key value parameter that is not associated with this element category.\nTo resolve, associate parameter with category or change keynoting system.

See Also

BuiltInFailures..::..KeynoteFailures Class


MissKeynoteParameter Property

[image]

Revit 2024 API
BuiltInFailures..::..KeynoteFailures..::..MissKeynoteParameter Property
BuiltInFailures..::..KeynoteFailures Class See Also Send Feedback
No Keynote Parameter.\nTo resolve, select key value parameter in keynoting system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MissKeynoteParameter { get; }
Visual Basic
Public Shared ReadOnly Property MissKeynoteParameter As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MissKeynoteParameter {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..KeynoteFailures Class


MissKeynotingSystem Property

[image]

Revit 2024 API
BuiltInFailures..::..KeynoteFailures..::..MissKeynotingSystem Property
BuiltInFailures..::..KeynoteFailures Class See Also Send Feedback
No Keynoting System associated with Tag Family.\nTo resolve, select keynoting system for the tag family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MissKeynotingSystem { get; }
Visual Basic
Public Shared ReadOnly Property MissKeynotingSystem As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MissKeynotingSystem {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..KeynoteFailures Class


NotAssociatedKeynoteParameter Property

[image]

Revit 2024 API
BuiltInFailures..::..KeynoteFailures..::..NotAssociatedKeynoteParameter Property
BuiltInFailures..::..KeynoteFailures Class See Also Send Feedback
Current tag keynoting system uses key value parameter that is not associated with this element category.\nTo resolve, associate parameter with category or change keynoting system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NotAssociatedKeynoteParameter { get; }
Visual Basic
Public Shared ReadOnly Property NotAssociatedKeynoteParameter As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotAssociatedKeynoteParameter {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..KeynoteFailures Class


BuiltInFailures.KeynoteTagFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..KeynoteTagFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures related to keynote tags.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class KeynoteTagFailures
Visual Basic
Public NotInheritable Class KeynoteTagFailures
Visual C++
public ref class KeynoteTagFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..KeynoteTagFailures

See Also

BuiltInFailures..::..KeynoteTagFailures Members


BuiltInFailures.KeynoteTagFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..KeynoteTagFailures Properties
BuiltInFailures..::..KeynoteTagFailures Class See Also Send Feedback

The BuiltInFailures..::..KeynoteTagFailures type exposes the following members.

Properties

Name | Description
KeynoteOnLinkWithDifferentKeynoteFile | The parameters of the keynote tag are empty because the keynoted linked element uses a different keynote file.
NoKeynoteAssignedToLinkedElement | The parameters of the keynote tag are empty because the keynoted linked element uses a different keynote file.

See Also

BuiltInFailures..::..KeynoteTagFailures Class


KeynoteOnLinkWithDifferentKeynoteFile Property

[image]

Revit 2024 API
BuiltInFailures..::..KeynoteTagFailures..::..KeynoteOnLinkWithDifferentKeynoteFile Property
BuiltInFailures..::..KeynoteTagFailures Class See Also Send Feedback
The parameters of the keynote tag are empty because the keynoted linked element uses a different keynote file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId KeynoteOnLinkWithDifferentKeynoteFile { get; }
Visual Basic
Public Shared ReadOnly Property KeynoteOnLinkWithDifferentKeynoteFile As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ KeynoteOnLinkWithDifferentKeynoteFile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..KeynoteTagFailures Class


NoKeynoteAssignedToLinkedElement Property

[image]

Revit 2024 API
BuiltInFailures..::..KeynoteTagFailures..::..NoKeynoteAssignedToLinkedElement Property
BuiltInFailures..::..KeynoteTagFailures Class See Also Send Feedback
The parameters of the keynote tag are empty because the keynoted linked element uses a different keynote file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoKeynoteAssignedToLinkedElement { get; }
Visual Basic
Public Shared ReadOnly Property NoKeynoteAssignedToLinkedElement As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoKeynoteAssignedToLinkedElement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..KeynoteTagFailures Class


BuiltInFailures.LegendFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..LegendFailures Members
BuiltInFailures..::..LegendFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..LegendFailures type exposes the following members.

Properties

Name | Description
LegendComponentBadViewType | Legend Components may only be placed in Legends
LegendComponentNotVisible | The component you have selected is not visible in the selected view.

See Also

BuiltInFailures..::..LegendFailures Class


BuiltInFailures.LegendFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..LegendFailures Properties
BuiltInFailures..::..LegendFailures Class See Also Send Feedback

The BuiltInFailures..::..LegendFailures type exposes the following members.

Properties

Name | Description
LegendComponentBadViewType | Legend Components may only be placed in Legends
LegendComponentNotVisible | The component you have selected is not visible in the selected view.

See Also

BuiltInFailures..::..LegendFailures Class


LegendComponentBadViewType Property

[image]

Revit 2024 API
BuiltInFailures..::..LegendFailures..::..LegendComponentBadViewType Property
BuiltInFailures..::..LegendFailures Class See Also Send Feedback
Legend Components may only be placed in Legends

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId LegendComponentBadViewType { get; }
Visual Basic
Public Shared ReadOnly Property LegendComponentBadViewType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LegendComponentBadViewType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LegendFailures Class


LegendComponentNotVisible Property

[image]

Revit 2024 API
BuiltInFailures..::..LegendFailures..::..LegendComponentNotVisible Property
BuiltInFailures..::..LegendFailures Class See Also Send Feedback
The component you have selected is not visible in the selected view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId LegendComponentNotVisible { get; }
Visual Basic
Public Shared ReadOnly Property LegendComponentNotVisible As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LegendComponentNotVisible {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LegendFailures Class


BuiltInFailures.LevelAssociationFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..LevelAssociationFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Level association of Analytical Node.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class LevelAssociationFailures
Visual Basic
Public NotInheritable Class LevelAssociationFailures
Visual C++
public ref class LevelAssociationFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..LevelAssociationFailures

See Also

BuiltInFailures..::..LevelAssociationFailures Members


BuiltInFailures.LevelAssociationFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..LevelAssociationFailures Members
BuiltInFailures..::..LevelAssociationFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..LevelAssociationFailures type exposes the following members.

Properties

Name | Description
AllLevelsDeleted | All Levels from model were deleted

See Also

BuiltInFailures..::..LevelAssociationFailures Class


BuiltInFailures.LevelAssociationFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..LevelAssociationFailures Properties
BuiltInFailures..::..LevelAssociationFailures Class See Also Send Feedback

The BuiltInFailures..::..LevelAssociationFailures type exposes the following members.

Properties

Name | Description
AllLevelsDeleted | All Levels from model were deleted

See Also

BuiltInFailures..::..LevelAssociationFailures Class


AllLevelsDeleted Property

[image]

Revit 2024 API
BuiltInFailures..::..LevelAssociationFailures..::..AllLevelsDeleted Property
BuiltInFailures..::..LevelAssociationFailures Class See Also Send Feedback
All Levels from model were deleted

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AllLevelsDeleted { get; }
Visual Basic
Public Shared ReadOnly Property AllLevelsDeleted As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AllLevelsDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LevelAssociationFailures Class


BuiltInFailures.LevelFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..LevelFailures Members
BuiltInFailures..::..LevelFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..LevelFailures type exposes the following members.

Properties

Name | Description
NoLevelsLeft | There are no levels or plan views remaining in the project.
NoLevelsLeftReloading | As a result of Reloading Latest, there are no Levels left. Create a new Level, and then Reload Latest again.
StoryAboveDeleted | The level set as the Story Above for these levels is being deleted. This change will cause these levels to revert to the default Story Above.
StoryAboveMoved | The level set as the Story Above for these levels has moved below these levels. This change will cause these levels to revert to the default Story Above.
StoryAboveNonStoryLevel | The level set as the Story Above for these levels is no longer a story level. This change will cause these levels to revert to the default Story Above.

See Also

BuiltInFailures..::..LevelFailures Class


BuiltInFailures.LevelFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..LevelFailures Properties
BuiltInFailures..::..LevelFailures Class See Also Send Feedback

The BuiltInFailures..::..LevelFailures type exposes the following members.

Properties

Name | Description
NoLevelsLeft | There are no levels or plan views remaining in the project.
NoLevelsLeftReloading | As a result of Reloading Latest, there are no Levels left. Create a new Level, and then Reload Latest again.
StoryAboveDeleted | The level set as the Story Above for these levels is being deleted. This change will cause these levels to revert to the default Story Above.
StoryAboveMoved | The level set as the Story Above for these levels has moved below these levels. This change will cause these levels to revert to the default Story Above.
StoryAboveNonStoryLevel | The level set as the Story Above for these levels is no longer a story level. This change will cause these levels to revert to the default Story Above.

See Also

BuiltInFailures..::..LevelFailures Class


NoLevelsLeft Property

[image]

Revit 2024 API
BuiltInFailures..::..LevelFailures..::..NoLevelsLeft Property
BuiltInFailures..::..LevelFailures Class See Also Send Feedback
There are no levels or plan views remaining in the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoLevelsLeft { get; }
Visual Basic
Public Shared ReadOnly Property NoLevelsLeft As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoLevelsLeft {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LevelFailures Class


NoLevelsLeftReloading Property

[image]

Revit 2024 API
BuiltInFailures..::..LevelFailures..::..NoLevelsLeftReloading Property
BuiltInFailures..::..LevelFailures Class See Also Send Feedback
As a result of Reloading Latest, there are no Levels left. Create a new Level, and then Reload Latest again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoLevelsLeftReloading { get; }
Visual Basic
Public Shared ReadOnly Property NoLevelsLeftReloading As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoLevelsLeftReloading {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LevelFailures Class


StoryAboveDeleted Property

[image]

Revit 2024 API
BuiltInFailures..::..LevelFailures..::..StoryAboveDeleted Property
BuiltInFailures..::..LevelFailures Class See Also Send Feedback
The level set as the Story Above for these levels is being deleted. This change will cause these levels to revert to the default Story Above.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StoryAboveDeleted { get; }
Visual Basic
Public Shared ReadOnly Property StoryAboveDeleted As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StoryAboveDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LevelFailures Class


StoryAboveMoved Property

[image]

Revit 2024 API
BuiltInFailures..::..LevelFailures..::..StoryAboveMoved Property
BuiltInFailures..::..LevelFailures Class See Also Send Feedback
The level set as the Story Above for these levels has moved below these levels. This change will cause these levels to revert to the default Story Above.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StoryAboveMoved { get; }
Visual Basic
Public Shared ReadOnly Property StoryAboveMoved As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StoryAboveMoved {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LevelFailures Class


StoryAboveNonStoryLevel Property

[image]

Revit 2024 API
BuiltInFailures..::..LevelFailures..::..StoryAboveNonStoryLevel Property
BuiltInFailures..::..LevelFailures Class See Also Send Feedback
The level set as the Story Above for these levels is no longer a story level. This change will cause these levels to revert to the default Story Above.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StoryAboveNonStoryLevel { get; }
Visual Basic
Public Shared ReadOnly Property StoryAboveNonStoryLevel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StoryAboveNonStoryLevel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LevelFailures Class


BuiltInFailures.LinkFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..LinkFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about LinkFailures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class LinkFailures
Visual Basic
Public NotInheritable Class LinkFailures
Visual C++
public ref class LinkFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..LinkFailures

See Also

BuiltInFailures..::..LinkFailures Members


BuiltInFailures.LinkFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..LinkFailures Members
BuiltInFailures..::..LinkFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..LinkFailures type exposes the following members.

Properties

Name | Description
CannotModifyLinkedFile | Shared Sites in the link ""%1!s!"" cannot be modified.
CannotOpenLinkedFileServerFound | Cannot open the linked model using Open and Unload because the plugin [name] provided by [vendor] experienced an error. For more information please contact [vendor].
CannotOpenLinkedFileServerNotFound | Cannot open the linked model using Open and Unload because the plugin [name] cannot be accessed. Please check plugin [name], which has server Id [serverId]
CannotPublishSharedCoordinatesToMirroredNonRevitLinks | Shared coordinates cannot be published to mirrored, non Revit, links.
CannotReloadFile | Can't reload file.
CannotUnlinkFile | Can't unlink file.
DataDictionaryDifferentInLink | Linked file [Name] was last saved in a previous version of Revit. Changes to it cannot be saved until it is upgraded.
DeleteLinkSymbolPrompt | All instances of Linked Model '[Name]' have been deleted, but the file itself is still loaded. Remove the Linked File using Manage Links dialog to save memory unless you are going to reuse it in this project. Removing the Link cannot be undone.
LinkedFileOpenInOtherDoc | Linked file cannot be reloaded because it is loaded into another open document.
LinkInstanceNeedsReconcile | Instance of linked .rvt file needs Coordination Review
ModifiedLinkedFile | Shared Sites in the link have been modified, use move instance to reset the change.
ModifyingLinkedFile | Shared Locations in the Linked Model '[Name]' have been modified, but not saved back to the Linked File. Upon reopening, instances of the Linked Model will return to their last Saved Positions. You can Save the Linked Model later via the Manage Links dialog.
MultipleLinks | Can't complete operation. Linked Files have the same name.
NoConstraintsToLinks1 | Constraints may not be created to linked instances using Shared Locations. Constraints will be removed.
SourceFileDrivenByOtherTarget | Linked Model's Shared Coordinates have been modified via another host model in this session. In order to be able to change the Linked File via the active host model, Save and open it again in a new session.
WatchedLinkMoved | Monitored Link moved.

See Also

BuiltInFailures..::..LinkFailures Class


BuiltInFailures.LinkFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..LinkFailures Properties
BuiltInFailures..::..LinkFailures Class See Also Send Feedback

The BuiltInFailures..::..LinkFailures type exposes the following members.

Properties

Name | Description
CannotModifyLinkedFile | Shared Sites in the link ""%1!s!"" cannot be modified.
CannotOpenLinkedFileServerFound | Cannot open the linked model using Open and Unload because the plugin [name] provided by [vendor] experienced an error. For more information please contact [vendor].
CannotOpenLinkedFileServerNotFound | Cannot open the linked model using Open and Unload because the plugin [name] cannot be accessed. Please check plugin [name], which has server Id [serverId]
CannotPublishSharedCoordinatesToMirroredNonRevitLinks | Shared coordinates cannot be published to mirrored, non Revit, links.
CannotReloadFile | Can't reload file.
CannotUnlinkFile | Can't unlink file.
DataDictionaryDifferentInLink | Linked file [Name] was last saved in a previous version of Revit. Changes to it cannot be saved until it is upgraded.
DeleteLinkSymbolPrompt | All instances of Linked Model '[Name]' have been deleted, but the file itself is still loaded. Remove the Linked File using Manage Links dialog to save memory unless you are going to reuse it in this project. Removing the Link cannot be undone.
LinkedFileOpenInOtherDoc | Linked file cannot be reloaded because it is loaded into another open document.
LinkInstanceNeedsReconcile | Instance of linked .rvt file needs Coordination Review
ModifiedLinkedFile | Shared Sites in the link have been modified, use move instance to reset the change.
ModifyingLinkedFile | Shared Locations in the Linked Model '[Name]' have been modified, but not saved back to the Linked File. Upon reopening, instances of the Linked Model will return to their last Saved Positions. You can Save the Linked Model later via the Manage Links dialog.
MultipleLinks | Can't complete operation. Linked Files have the same name.
NoConstraintsToLinks1 | Constraints may not be created to linked instances using Shared Locations. Constraints will be removed.
SourceFileDrivenByOtherTarget | Linked Model's Shared Coordinates have been modified via another host model in this session. In order to be able to change the Linked File via the active host model, Save and open it again in a new session.
WatchedLinkMoved | Monitored Link moved.

See Also

BuiltInFailures..::..LinkFailures Class


CannotModifyLinkedFile Property

[image]

Revit 2024 API
BuiltInFailures..::..LinkFailures..::..CannotModifyLinkedFile Property
BuiltInFailures..::..LinkFailures Class See Also Send Feedback
Shared Sites in the link ""%1!s!"" cannot be modified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotModifyLinkedFile { get; }
Visual Basic
Public Shared ReadOnly Property CannotModifyLinkedFile As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotModifyLinkedFile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LinkFailures Class


CannotOpenLinkedFileServerFound Property

[image]

Revit 2024 API
BuiltInFailures..::..LinkFailures..::..CannotOpenLinkedFileServerFound Property
BuiltInFailures..::..LinkFailures Class See Also Send Feedback
Cannot open the linked model using Open and Unload because the plugin [name] provided by [vendor] experienced an error. For more information please contact [vendor].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotOpenLinkedFileServerFound { get; }
Visual Basic
Public Shared ReadOnly Property CannotOpenLinkedFileServerFound As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotOpenLinkedFileServerFound {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LinkFailures Class


CannotOpenLinkedFileServerNotFound Property

[image]

Revit 2024 API
BuiltInFailures..::..LinkFailures..::..CannotOpenLinkedFileServerNotFound Property
BuiltInFailures..::..LinkFailures Class See Also Send Feedback
Cannot open the linked model using Open and Unload because the plugin [name] cannot be accessed. Please check plugin [name], which has server Id [serverId]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotOpenLinkedFileServerNotFound { get; }
Visual Basic
Public Shared ReadOnly Property CannotOpenLinkedFileServerNotFound As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotOpenLinkedFileServerNotFound {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LinkFailures Class


CannotPublishSharedCoordinatesToMirroredNonRevitLinks Property

[image]

Revit 2024 API
BuiltInFailures..::..LinkFailures..::..CannotPublishSharedCoordinatesToMirroredNonRevitLinks Property
BuiltInFailures..::..LinkFailures Class See Also Send Feedback
Shared coordinates cannot be published to mirrored, non Revit, links.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotPublishSharedCoordinatesToMirroredNonRevitLinks { get; }
Visual Basic
Public Shared ReadOnly Property CannotPublishSharedCoordinatesToMirroredNonRevitLinks As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPublishSharedCoordinatesToMirroredNonRevitLinks {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LinkFailures Class


CannotReloadFile Property

[image]

Revit 2024 API
BuiltInFailures..::..LinkFailures..::..CannotReloadFile Property
BuiltInFailures..::..LinkFailures Class See Also Send Feedback
Can't reload file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotReloadFile { get; }
Visual Basic
Public Shared ReadOnly Property CannotReloadFile As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotReloadFile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LinkFailures Class


CannotUnlinkFile Property

[image]

Revit 2024 API
BuiltInFailures..::..LinkFailures..::..CannotUnlinkFile Property
BuiltInFailures..::..LinkFailures Class See Also Send Feedback
Can't unlink file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotUnlinkFile { get; }
Visual Basic
Public Shared ReadOnly Property CannotUnlinkFile As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotUnlinkFile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LinkFailures Class


DataDictionaryDifferentInLink Property

[image]

Revit 2024 API
BuiltInFailures..::..LinkFailures..::..DataDictionaryDifferentInLink Property
BuiltInFailures..::..LinkFailures Class See Also Send Feedback
Linked file [Name] was last saved in a previous version of Revit. Changes to it cannot be saved until it is upgraded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DataDictionaryDifferentInLink { get; }
Visual Basic
Public Shared ReadOnly Property DataDictionaryDifferentInLink As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DataDictionaryDifferentInLink {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LinkFailures Class


DeleteLinkSymbolPrompt Property

[image]

Revit 2024 API
BuiltInFailures..::..LinkFailures..::..DeleteLinkSymbolPrompt Property
BuiltInFailures..::..LinkFailures Class See Also Send Feedback
All instances of Linked Model '[Name]' have been deleted, but the file itself is still loaded. Remove the Linked File using Manage Links dialog to save memory unless you are going to reuse it in this project. Removing the Link cannot be undone.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DeleteLinkSymbolPrompt { get; }
Visual Basic
Public Shared ReadOnly Property DeleteLinkSymbolPrompt As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DeleteLinkSymbolPrompt {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LinkFailures Class


LinkInstanceNeedsReconcile Property

[image]

Revit 2024 API
BuiltInFailures..::..LinkFailures..::..LinkInstanceNeedsReconcile Property
BuiltInFailures..::..LinkFailures Class See Also Send Feedback
Instance of linked .rvt file needs Coordination Review

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId LinkInstanceNeedsReconcile { get; }
Visual Basic
Public Shared ReadOnly Property LinkInstanceNeedsReconcile As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LinkInstanceNeedsReconcile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LinkFailures Class


ModifyingLinkedFile Property

[image]

Revit 2024 API
BuiltInFailures..::..LinkFailures..::..ModifyingLinkedFile Property
BuiltInFailures..::..LinkFailures Class See Also Send Feedback
Shared Locations in the Linked Model '[Name]' have been modified, but not saved back to the Linked File. Upon reopening, instances of the Linked Model will return to their last Saved Positions. You can Save the Linked Model later via the Manage Links dialog.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ModifyingLinkedFile { get; }
Visual Basic
Public Shared ReadOnly Property ModifyingLinkedFile As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ModifyingLinkedFile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LinkFailures Class


MultipleLinks Property

[image]

Revit 2024 API
BuiltInFailures..::..LinkFailures..::..MultipleLinks Property
BuiltInFailures..::..LinkFailures Class See Also Send Feedback
Can't complete operation. Linked Files have the same name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MultipleLinks { get; }
Visual Basic
Public Shared ReadOnly Property MultipleLinks As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MultipleLinks {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LinkFailures Class


NoConstraintsToLinks1 Property

[image]

Revit 2024 API
BuiltInFailures..::..LinkFailures..::..NoConstraintsToLinks1 Property
BuiltInFailures..::..LinkFailures Class See Also Send Feedback
Constraints may not be created to linked instances using Shared Locations. Constraints will be removed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoConstraintsToLinks1 { get; }
Visual Basic
Public Shared ReadOnly Property NoConstraintsToLinks1 As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoConstraintsToLinks1 {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LinkFailures Class


WatchedLinkMoved Property

[image]

Revit 2024 API
BuiltInFailures..::..LinkFailures..::..WatchedLinkMoved Property
BuiltInFailures..::..LinkFailures Class See Also Send Feedback
Monitored Link moved.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WatchedLinkMoved { get; }
Visual Basic
Public Shared ReadOnly Property WatchedLinkMoved As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WatchedLinkMoved {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LinkFailures Class


BuiltInFailures.LoadFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..LoadFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Load.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class LoadFailures
Visual Basic
Public NotInheritable Class LoadFailures
Visual C++
public ref class LoadFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..LoadFailures

See Also

BuiltInFailures..::..LoadFailures Members


BuiltInFailures.LoadFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..LoadFailures Members
BuiltInFailures..::..LoadFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..LoadFailures type exposes the following members.

Properties

Name | Description
AreaLoadNotOverlappingHost | Area load is not overlapping with its entire distribution its host.
CannotCopyHostedLoad | Can't copy Load based on the Host Element.
CannotMirrorHostedLoad | Can't mirror Load based on the Host Element.
CannotMirrorLoad | Can't mirror Load because mirror plane is not perpendicular to sketch plane.
CannotMoveHostedLoad | Can't move Load based on the Host Element.
CannotRotateLoad | Can't rotate Load because rotation axis is not perpendicular to sketch plane.
InvalidAreaLoadSketchError | Area Load has invalid Sketch.
LineLoadAllZero | Line Load can't have all force components and moment components to be zero.
LineLoadNotOverlappingHost | Line load is not overlapping with its entire distribution its host.
OpenAreaLoadLoopError | Area Load Sketch can't contain open loops.
PointLoadAllZero | Point Load can't have all force components and moment components to be zero.
PointLoadNotOverlappingHost | Point load is not overlapping with its entire distribution its host.

See Also

BuiltInFailures..::..LoadFailures Class


BuiltInFailures.LoadFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..LoadFailures Properties
BuiltInFailures..::..LoadFailures Class See Also Send Feedback

The BuiltInFailures..::..LoadFailures type exposes the following members.

Properties

Name | Description
AreaLoadNotOverlappingHost | Area load is not overlapping with its entire distribution its host.
CannotCopyHostedLoad | Can't copy Load based on the Host Element.
CannotMirrorHostedLoad | Can't mirror Load based on the Host Element.
CannotMirrorLoad | Can't mirror Load because mirror plane is not perpendicular to sketch plane.
CannotMoveHostedLoad | Can't move Load based on the Host Element.
CannotRotateLoad | Can't rotate Load because rotation axis is not perpendicular to sketch plane.
InvalidAreaLoadSketchError | Area Load has invalid Sketch.
LineLoadAllZero | Line Load can't have all force components and moment components to be zero.
LineLoadNotOverlappingHost | Line load is not overlapping with its entire distribution its host.
OpenAreaLoadLoopError | Area Load Sketch can't contain open loops.
PointLoadAllZero | Point Load can't have all force components and moment components to be zero.
PointLoadNotOverlappingHost | Point load is not overlapping with its entire distribution its host.

See Also

BuiltInFailures..::..LoadFailures Class


AreaLoadNotOverlappingHost Property

[image]

Revit 2024 API
BuiltInFailures..::..LoadFailures..::..AreaLoadNotOverlappingHost Property
BuiltInFailures..::..LoadFailures Class See Also Send Feedback
Area load is not overlapping with its entire distribution its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AreaLoadNotOverlappingHost { get; }
Visual Basic
Public Shared ReadOnly Property AreaLoadNotOverlappingHost As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AreaLoadNotOverlappingHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LoadFailures Class


CannotCopyHostedLoad Property

[image]

Revit 2024 API
BuiltInFailures..::..LoadFailures..::..CannotCopyHostedLoad Property
BuiltInFailures..::..LoadFailures Class See Also Send Feedback
Can't copy Load based on the Host Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCopyHostedLoad { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyHostedLoad As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyHostedLoad {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LoadFailures Class


CannotMirrorHostedLoad Property

[image]

Revit 2024 API
BuiltInFailures..::..LoadFailures..::..CannotMirrorHostedLoad Property
BuiltInFailures..::..LoadFailures Class See Also Send Feedback
Can't mirror Load based on the Host Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotMirrorHostedLoad { get; }
Visual Basic
Public Shared ReadOnly Property CannotMirrorHostedLoad As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMirrorHostedLoad {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LoadFailures Class


CannotMirrorLoad Property

[image]

Revit 2024 API
BuiltInFailures..::..LoadFailures..::..CannotMirrorLoad Property
BuiltInFailures..::..LoadFailures Class See Also Send Feedback
Can't mirror Load because mirror plane is not perpendicular to sketch plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotMirrorLoad { get; }
Visual Basic
Public Shared ReadOnly Property CannotMirrorLoad As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMirrorLoad {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LoadFailures Class


CannotMoveHostedLoad Property

[image]

Revit 2024 API
BuiltInFailures..::..LoadFailures..::..CannotMoveHostedLoad Property
BuiltInFailures..::..LoadFailures Class See Also Send Feedback
Can't move Load based on the Host Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotMoveHostedLoad { get; }
Visual Basic
Public Shared ReadOnly Property CannotMoveHostedLoad As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMoveHostedLoad {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LoadFailures Class


CannotRotateLoad Property

[image]

Revit 2024 API
BuiltInFailures..::..LoadFailures..::..CannotRotateLoad Property
BuiltInFailures..::..LoadFailures Class See Also Send Feedback
Can't rotate Load because rotation axis is not perpendicular to sketch plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotRotateLoad { get; }
Visual Basic
Public Shared ReadOnly Property CannotRotateLoad As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotRotateLoad {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LoadFailures Class


InvalidAreaLoadSketchError Property

[image]

Revit 2024 API
BuiltInFailures..::..LoadFailures..::..InvalidAreaLoadSketchError Property
BuiltInFailures..::..LoadFailures Class See Also Send Feedback
Area Load has invalid Sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidAreaLoadSketchError { get; }
Visual Basic
Public Shared ReadOnly Property InvalidAreaLoadSketchError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidAreaLoadSketchError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LoadFailures Class


LineLoadAllZero Property

[image]

Revit 2024 API
BuiltInFailures..::..LoadFailures..::..LineLoadAllZero Property
BuiltInFailures..::..LoadFailures Class See Also Send Feedback
Line Load can't have all force components and moment components to be zero.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId LineLoadAllZero { get; }
Visual Basic
Public Shared ReadOnly Property LineLoadAllZero As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LineLoadAllZero {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LoadFailures Class


LineLoadNotOverlappingHost Property

[image]

Revit 2024 API
BuiltInFailures..::..LoadFailures..::..LineLoadNotOverlappingHost Property
BuiltInFailures..::..LoadFailures Class See Also Send Feedback
Line load is not overlapping with its entire distribution its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId LineLoadNotOverlappingHost { get; }
Visual Basic
Public Shared ReadOnly Property LineLoadNotOverlappingHost As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LineLoadNotOverlappingHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LoadFailures Class


OpenAreaLoadLoopError Property

[image]

Revit 2024 API
BuiltInFailures..::..LoadFailures..::..OpenAreaLoadLoopError Property
BuiltInFailures..::..LoadFailures Class See Also Send Feedback
Area Load Sketch can't contain open loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId OpenAreaLoadLoopError { get; }
Visual Basic
Public Shared ReadOnly Property OpenAreaLoadLoopError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OpenAreaLoadLoopError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LoadFailures Class


PointLoadAllZero Property

[image]

Revit 2024 API
BuiltInFailures..::..LoadFailures..::..PointLoadAllZero Property
BuiltInFailures..::..LoadFailures Class See Also Send Feedback
Point Load can't have all force components and moment components to be zero.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId PointLoadAllZero { get; }
Visual Basic
Public Shared ReadOnly Property PointLoadAllZero As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PointLoadAllZero {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LoadFailures Class


PointLoadNotOverlappingHost Property

[image]

Revit 2024 API
BuiltInFailures..::..LoadFailures..::..PointLoadNotOverlappingHost Property
BuiltInFailures..::..LoadFailures Class See Also Send Feedback
Point load is not overlapping with its entire distribution its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId PointLoadNotOverlappingHost { get; }
Visual Basic
Public Shared ReadOnly Property PointLoadNotOverlappingHost As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PointLoadNotOverlappingHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LoadFailures Class


BuiltInFailures.LooseDimensionFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..LooseDimensionFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about LooseDimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class LooseDimensionFailures
Visual Basic
Public NotInheritable Class LooseDimensionFailures
Visual C++
public ref class LooseDimensionFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..LooseDimensionFailures

See Also

BuiltInFailures..::..LooseDimensionFailures Members


BuiltInFailures.LooseDimensionFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..LooseDimensionFailures Members
BuiltInFailures..::..LooseDimensionFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..LooseDimensionFailures type exposes the following members.

Properties

Name | Description
LooseCurtainWallData | Switching element type to a non-Curtain element Family type. All data about Mullions, Grid Lines, and design units for the Curtain element will be lost.
LooseDimensionsForCurtainWall | Switching wall type to Family Curtain Wall. All Dimension References to the side faces of the Wall will be deleted.
LooseFaceSplitsForCurtainWall | Switching element type to Curtain Family. All Split Face Regions in the element will be deleted.
LooseInsertsForCurtainWall | Switching element type to Curtain element. All inserts in the element will be deleted.
LooseWallsweepsForCurtainWall | Switching element type to Curtain Family. All Wall Sweeps or Reveals hosted by this instance will be deleted.

See Also

BuiltInFailures..::..LooseDimensionFailures Class


BuiltInFailures.LooseDimensionFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..LooseDimensionFailures Properties
BuiltInFailures..::..LooseDimensionFailures Class See Also Send Feedback

The BuiltInFailures..::..LooseDimensionFailures type exposes the following members.

Properties

Name | Description
LooseCurtainWallData | Switching element type to a non-Curtain element Family type. All data about Mullions, Grid Lines, and design units for the Curtain element will be lost.
LooseDimensionsForCurtainWall | Switching wall type to Family Curtain Wall. All Dimension References to the side faces of the Wall will be deleted.
LooseFaceSplitsForCurtainWall | Switching element type to Curtain Family. All Split Face Regions in the element will be deleted.
LooseInsertsForCurtainWall | Switching element type to Curtain element. All inserts in the element will be deleted.
LooseWallsweepsForCurtainWall | Switching element type to Curtain Family. All Wall Sweeps or Reveals hosted by this instance will be deleted.

See Also

BuiltInFailures..::..LooseDimensionFailures Class


LooseCurtainWallData Property

[image]

Revit 2024 API
BuiltInFailures..::..LooseDimensionFailures..::..LooseCurtainWallData Property
BuiltInFailures..::..LooseDimensionFailures Class See Also Send Feedback
Switching element type to a non-Curtain element Family type. All data about Mullions, Grid Lines, and design units for the Curtain element will be lost.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId LooseCurtainWallData { get; }
Visual Basic
Public Shared ReadOnly Property LooseCurtainWallData As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LooseCurtainWallData {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LooseDimensionFailures Class


LooseDimensionsForCurtainWall Property

[image]

Revit 2024 API
BuiltInFailures..::..LooseDimensionFailures..::..LooseDimensionsForCurtainWall Property
BuiltInFailures..::..LooseDimensionFailures Class See Also Send Feedback
Switching wall type to Family Curtain Wall. All Dimension References to the side faces of the Wall will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId LooseDimensionsForCurtainWall { get; }
Visual Basic
Public Shared ReadOnly Property LooseDimensionsForCurtainWall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LooseDimensionsForCurtainWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LooseDimensionFailures Class


LooseInsertsForCurtainWall Property

[image]

Revit 2024 API
BuiltInFailures..::..LooseDimensionFailures..::..LooseInsertsForCurtainWall Property
BuiltInFailures..::..LooseDimensionFailures Class See Also Send Feedback
Switching element type to Curtain element. All inserts in the element will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId LooseInsertsForCurtainWall { get; }
Visual Basic
Public Shared ReadOnly Property LooseInsertsForCurtainWall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LooseInsertsForCurtainWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LooseDimensionFailures Class


LooseWallsweepsForCurtainWall Property

[image]

Revit 2024 API
BuiltInFailures..::..LooseDimensionFailures..::..LooseWallsweepsForCurtainWall Property
BuiltInFailures..::..LooseDimensionFailures Class See Also Send Feedback
Switching element type to Curtain Family. All Wall Sweeps or Reveals hosted by this instance will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId LooseWallsweepsForCurtainWall { get; }
Visual Basic
Public Shared ReadOnly Property LooseWallsweepsForCurtainWall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LooseWallsweepsForCurtainWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LooseDimensionFailures Class


BuiltInFailures.MacroFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..MacroFailures Members
BuiltInFailures..::..MacroFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..MacroFailures type exposes the following members.

Properties

Name | Description
DuplicateModuleName | Macro project with name [MacroModuleName] duplicates with central file. Delete the macro project or re-create it with another name to proceed.

See Also

BuiltInFailures..::..MacroFailures Class


BuiltInFailures.MacroFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..MacroFailures Properties
BuiltInFailures..::..MacroFailures Class See Also Send Feedback

The BuiltInFailures..::..MacroFailures type exposes the following members.

Properties

Name | Description
DuplicateModuleName | Macro project with name [MacroModuleName] duplicates with central file. Delete the macro project or re-create it with another name to proceed.

See Also

BuiltInFailures..::..MacroFailures Class


DuplicateModuleName Property

[image]

Revit 2024 API
BuiltInFailures..::..MacroFailures..::..DuplicateModuleName Property
BuiltInFailures..::..MacroFailures Class See Also Send Feedback
Macro project with name [MacroModuleName] duplicates with central file. Delete the macro project or re-create it with another name to proceed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DuplicateModuleName { get; }
Visual Basic
Public Shared ReadOnly Property DuplicateModuleName As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DuplicateModuleName {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MacroFailures Class


BuiltInFailures.MassFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..MassFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Mass.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class MassFailures
Visual Basic
Public NotInheritable Class MassFailures
Visual C++
public ref class MassFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..MassFailures

See Also

BuiltInFailures..::..MassFailures Members


BuiltInFailures.MassFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..MassFailures Properties
BuiltInFailures..::..MassFailures Class See Also Send Feedback

The BuiltInFailures..::..MassFailures type exposes the following members.

Properties

Name | Description
AutoGlazingFailed | Failure in Auto-Glazing region computation.
AutoGlazingFailedError | Failure in Auto-Glazing region computation.
BooleanUnionFailed | Failed to merge overlapping solids
CannotIntegrate | In order to restore an element's 'Constrain to Massing' property to 'Dependent', it must be in the main model with the massing.
CannotMergeGeometry | The Mass contains geometry that cannot be combined. Mass Floors, volume, and surface area, won't be computed.
CannotMoveMassing | Can't move whole Massing. Move the elements within the Massing instead.
CreateCoreGeometryFailed | Failed to create core geometries.
DividePerimeterZoneFailed | Failed to divide perimeter zone.
FaceRegionCreationFailed | Failure in face region creation.
FaceSplitFailed | A face of a joined (i.e. one cuts another) mass could not be split into interior and exterior faces. Remove the cut to resolve.
FloorAreaFaceFailed | Failed to create a Mass Floor.
FloorMightLookWrong | Mass Floors may appear incorrect since the Mass contains mesh and solid geometry.
FloorRecreateFailed | The floor cannot be created.
FloorRecreateFailedWarning | The floor cannot be created because no suitable level in the target document can be found.
MinSkylightWidthImperial | The minimum skylight width is 8 inches.
MinSkylightWidthMetric | The minimum skylight width is 203.2 millimeters.
MultipleMassing | Can't complete operation. Massing can only exist in one Workset. Change Workset of Massing to match in Local and Central Models.
NoCurtainRoofsInMassing | Massing cannot be created with a curtain roof. Please change the default roof type and try again.
NonOccupiableMassZone | For mass zone, if the bottom level ref does not intersect, then this zone is going to be "not occupiable" and a warning is posted for it.
NoSolidInMass | Mass contains no solid geometry. Mass Floors, volume, and surface area, won't be computed.
OpenAndSolidGeometry | Mass contains both solid and mesh geometry. Mass Floors, volume, and surface area, may appear incorrect.
OpenGeometryOnly | Mass contains only mesh geometry, which can't be used to compute Mass Floors, volume, or surface area.
OverlappingSolids | Found volumetric overlap between solids. They will be merged into one
SketchCurveNotModelable | This action cannot be completed. An element created by massing has a sketch line that cannot be modeled.
SplitFacesByGroundPlaneCrashed | Failed to split face by ground plane.
SplitFacesByGroundPlaneFailed | Failed to split face by ground plane.
SplitOverlappingFacesFailed | Failed to resolve all overlaps between faces of the same Mass Energy Analytical Model.
TooManyGeometries | The geometry in this Mass instance is too complex to take advantage of the capabilities a Mass provides. Please break it down into multiple Mass and family instances that are less complex.
UpgradedMassingWarning | Your document contained a Massing element which has been upgraded to a Mass instance. Please review the documentation on the new enhanced Mass capabilities to understand the implications of this change.

See Also

BuiltInFailures..::..MassFailures Class


AutoGlazingFailed Property

[image]

Revit 2024 API
BuiltInFailures..::..MassFailures..::..AutoGlazingFailed Property
BuiltInFailures..::..MassFailures Class See Also Send Feedback
Failure in Auto-Glazing region computation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AutoGlazingFailed { get; }
Visual Basic
Public Shared ReadOnly Property AutoGlazingFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AutoGlazingFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MassFailures Class


AutoGlazingFailedError Property

[image]

Revit 2024 API
BuiltInFailures..::..MassFailures..::..AutoGlazingFailedError Property
BuiltInFailures..::..MassFailures Class See Also Send Feedback
Failure in Auto-Glazing region computation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AutoGlazingFailedError { get; }
Visual Basic
Public Shared ReadOnly Property AutoGlazingFailedError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AutoGlazingFailedError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MassFailures Class


BooleanUnionFailed Property

[image]

Revit 2024 API
BuiltInFailures..::..MassFailures..::..BooleanUnionFailed Property
BuiltInFailures..::..MassFailures Class See Also Send Feedback
Failed to merge overlapping solids

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId BooleanUnionFailed { get; }
Visual Basic
Public Shared ReadOnly Property BooleanUnionFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BooleanUnionFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MassFailures Class


CannotIntegrate Property

[image]

Revit 2024 API
BuiltInFailures..::..MassFailures..::..CannotIntegrate Property
BuiltInFailures..::..MassFailures Class See Also Send Feedback
In order to restore an element's 'Constrain to Massing' property to 'Dependent', it must be in the main model with the massing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotIntegrate { get; }
Visual Basic
Public Shared ReadOnly Property CannotIntegrate As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotIntegrate {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MassFailures Class


CannotMergeGeometry Property

[image]

Revit 2024 API
BuiltInFailures..::..MassFailures..::..CannotMergeGeometry Property
BuiltInFailures..::..MassFailures Class See Also Send Feedback
The Mass contains geometry that cannot be combined. Mass Floors, volume, and surface area, won't be computed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotMergeGeometry { get; }
Visual Basic
Public Shared ReadOnly Property CannotMergeGeometry As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMergeGeometry {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MassFailures Class


CannotMoveMassing Property

[image]

Revit 2024 API
BuiltInFailures..::..MassFailures..::..CannotMoveMassing Property
BuiltInFailures..::..MassFailures Class See Also Send Feedback
Can't move whole Massing. Move the elements within the Massing instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotMoveMassing { get; }
Visual Basic
Public Shared ReadOnly Property CannotMoveMassing As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMoveMassing {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MassFailures Class


CreateCoreGeometryFailed Property

[image]

Revit 2024 API
BuiltInFailures..::..MassFailures..::..CreateCoreGeometryFailed Property
BuiltInFailures..::..MassFailures Class See Also Send Feedback
Failed to create core geometries.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CreateCoreGeometryFailed { get; }
Visual Basic
Public Shared ReadOnly Property CreateCoreGeometryFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CreateCoreGeometryFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MassFailures Class


DividePerimeterZoneFailed Property

[image]

Revit 2024 API
BuiltInFailures..::..MassFailures..::..DividePerimeterZoneFailed Property
BuiltInFailures..::..MassFailures Class See Also Send Feedback
Failed to divide perimeter zone.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DividePerimeterZoneFailed { get; }
Visual Basic
Public Shared ReadOnly Property DividePerimeterZoneFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividePerimeterZoneFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MassFailures Class


FaceRegionCreationFailed Property

[image]

Revit 2024 API
BuiltInFailures..::..MassFailures..::..FaceRegionCreationFailed Property
BuiltInFailures..::..MassFailures Class See Also Send Feedback
Failure in face region creation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FaceRegionCreationFailed { get; }
Visual Basic
Public Shared ReadOnly Property FaceRegionCreationFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FaceRegionCreationFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MassFailures Class


FloorAreaFaceFailed Property

[image]

Revit 2024 API
BuiltInFailures..::..MassFailures..::..FloorAreaFaceFailed Property
BuiltInFailures..::..MassFailures Class See Also Send Feedback
Failed to create a Mass Floor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FloorAreaFaceFailed { get; }
Visual Basic
Public Shared ReadOnly Property FloorAreaFaceFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FloorAreaFaceFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MassFailures Class


MinSkylightWidthMetric Property

[image]

Revit 2024 API
BuiltInFailures..::..MassFailures..::..MinSkylightWidthMetric Property
BuiltInFailures..::..MassFailures Class See Also Send Feedback
The minimum skylight width is 203.2 millimeters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MinSkylightWidthMetric { get; }
Visual Basic
Public Shared ReadOnly Property MinSkylightWidthMetric As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MinSkylightWidthMetric {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MassFailures Class


MultipleMassing Property

[image]

Revit 2024 API
BuiltInFailures..::..MassFailures..::..MultipleMassing Property
BuiltInFailures..::..MassFailures Class See Also Send Feedback
Can't complete operation. Massing can only exist in one Workset. Change Workset of Massing to match in Local and Central Models.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MultipleMassing { get; }
Visual Basic
Public Shared ReadOnly Property MultipleMassing As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MultipleMassing {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MassFailures Class


NonOccupiableMassZone Property

[image]

Revit 2024 API
BuiltInFailures..::..MassFailures..::..NonOccupiableMassZone Property
BuiltInFailures..::..MassFailures Class See Also Send Feedback
For mass zone, if the bottom level ref does not intersect, then this zone is going to be "not occupiable" and a warning is posted for it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NonOccupiableMassZone { get; }
Visual Basic
Public Shared ReadOnly Property NonOccupiableMassZone As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NonOccupiableMassZone {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MassFailures Class


OpenAndSolidGeometry Property

[image]

Revit 2024 API
BuiltInFailures..::..MassFailures..::..OpenAndSolidGeometry Property
BuiltInFailures..::..MassFailures Class See Also Send Feedback
Mass contains both solid and mesh geometry. Mass Floors, volume, and surface area, may appear incorrect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId OpenAndSolidGeometry { get; }
Visual Basic
Public Shared ReadOnly Property OpenAndSolidGeometry As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OpenAndSolidGeometry {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MassFailures Class


OpenGeometryOnly Property

[image]

Revit 2024 API
BuiltInFailures..::..MassFailures..::..OpenGeometryOnly Property
BuiltInFailures..::..MassFailures Class See Also Send Feedback
Mass contains only mesh geometry, which can't be used to compute Mass Floors, volume, or surface area.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId OpenGeometryOnly { get; }
Visual Basic
Public Shared ReadOnly Property OpenGeometryOnly As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OpenGeometryOnly {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MassFailures Class


OverlappingSolids Property

[image]

Revit 2024 API
BuiltInFailures..::..MassFailures..::..OverlappingSolids Property
BuiltInFailures..::..MassFailures Class See Also Send Feedback
Found volumetric overlap between solids. They will be merged into one

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId OverlappingSolids { get; }
Visual Basic
Public Shared ReadOnly Property OverlappingSolids As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OverlappingSolids {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MassFailures Class


SketchCurveNotModelable Property

[image]

Revit 2024 API
BuiltInFailures..::..MassFailures..::..SketchCurveNotModelable Property
BuiltInFailures..::..MassFailures Class See Also Send Feedback
This action cannot be completed. An element created by massing has a sketch line that cannot be modeled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SketchCurveNotModelable { get; }
Visual Basic
Public Shared ReadOnly Property SketchCurveNotModelable As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SketchCurveNotModelable {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MassFailures Class


SplitFacesByGroundPlaneCrashed Property

[image]

Revit 2024 API
BuiltInFailures..::..MassFailures..::..SplitFacesByGroundPlaneCrashed Property
BuiltInFailures..::..MassFailures Class See Also Send Feedback
Failed to split face by ground plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SplitFacesByGroundPlaneCrashed { get; }
Visual Basic
Public Shared ReadOnly Property SplitFacesByGroundPlaneCrashed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SplitFacesByGroundPlaneCrashed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MassFailures Class


SplitFacesByGroundPlaneFailed Property

[image]

Revit 2024 API
BuiltInFailures..::..MassFailures..::..SplitFacesByGroundPlaneFailed Property
BuiltInFailures..::..MassFailures Class See Also Send Feedback
Failed to split face by ground plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SplitFacesByGroundPlaneFailed { get; }
Visual Basic
Public Shared ReadOnly Property SplitFacesByGroundPlaneFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SplitFacesByGroundPlaneFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MassFailures Class


UpgradedMassingWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..MassFailures..::..UpgradedMassingWarning Property
BuiltInFailures..::..MassFailures Class See Also Send Feedback
Your document contained a Massing element which has been upgraded to a Mass instance. Please review the documentation on the new enhanced Mass capabilities to understand the implications of this change.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UpgradedMassingWarning { get; }
Visual Basic
Public Shared ReadOnly Property UpgradedMassingWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UpgradedMassingWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MassFailures Class


BuiltInFailures.MatchlineFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..MatchlineFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Matchline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class MatchlineFailures
Visual Basic
Public NotInheritable Class MatchlineFailures
Visual C++
public ref class MatchlineFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..MatchlineFailures

See Also

BuiltInFailures..::..MatchlineFailures Members


BuiltInFailures.MatchlineFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..MatchlineFailures Members
BuiltInFailures..::..MatchlineFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..MatchlineFailures type exposes the following members.

Properties

Name | Description
CreationFailed | Matchline top extent should be higher than its bottom.

See Also

BuiltInFailures..::..MatchlineFailures Class


BuiltInFailures.MatchlineFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..MatchlineFailures Properties
BuiltInFailures..::..MatchlineFailures Class See Also Send Feedback

The BuiltInFailures..::..MatchlineFailures type exposes the following members.

Properties

Name | Description
CreationFailed | Matchline top extent should be higher than its bottom.

See Also

BuiltInFailures..::..MatchlineFailures Class


BuiltInFailures.MechanicalFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..MechanicalFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class MechanicalFailures
Visual Basic
Public NotInheritable Class MechanicalFailures
Visual C++
public ref class MechanicalFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..MechanicalFailures

See Also

BuiltInFailures..::..MechanicalFailures Members


BuiltInFailures.MechanicalFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..MechanicalFailures Members
BuiltInFailures..::..MechanicalFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..MechanicalFailures type exposes the following members.

Properties

Name | Description
InitialEqualFrictionSizingFailed | Initial Equal Friction Sizing failed.
LiningThicknessIsLargeForDiameter | Lining Thickness ([Lining Thickness Value]) is too large for current Diameter ([Diameter Value]).
LiningThicknessIsLargeForHeight | Lining Thickness ([Lining Thickness Value]) is too large for current Height ([Height Value]).
LiningThicknessIsLargeForWidth | Lining Thickness ([Lining Thickness Value]) is too large for current Width ([Width Value]).
PanelDoesntMatchCircuitProperties | The panel no longer matches the properties for the Circuit. Disconnect the panel from the Circuit?
PanelValidateConfigurationError | More than one circuit falls onto the same slot. Disconnect the circuits from the panel?
TwoPointsSelectedBeforeEdit | Two points have to be selected before existing the edit mode.

See Also

BuiltInFailures..::..MechanicalFailures Class


InitialEqualFrictionSizingFailed Property

[image]

Revit 2024 API
BuiltInFailures..::..MechanicalFailures..::..InitialEqualFrictionSizingFailed Property
BuiltInFailures..::..MechanicalFailures Class See Also Send Feedback
Initial Equal Friction Sizing failed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InitialEqualFrictionSizingFailed { get; }
Visual Basic
Public Shared ReadOnly Property InitialEqualFrictionSizingFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InitialEqualFrictionSizingFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MechanicalFailures Class


LiningThicknessIsLargeForDiameter Property

[image]

Revit 2024 API
BuiltInFailures..::..MechanicalFailures..::..LiningThicknessIsLargeForDiameter Property
BuiltInFailures..::..MechanicalFailures Class See Also Send Feedback
Lining Thickness ([Lining Thickness Value]) is too large for current Diameter ([Diameter Value]).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId LiningThicknessIsLargeForDiameter { get; }
Visual Basic
Public Shared ReadOnly Property LiningThicknessIsLargeForDiameter As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LiningThicknessIsLargeForDiameter {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MechanicalFailures Class


LiningThicknessIsLargeForWidth Property

[image]

Revit 2024 API
BuiltInFailures..::..MechanicalFailures..::..LiningThicknessIsLargeForWidth Property
BuiltInFailures..::..MechanicalFailures Class See Also Send Feedback
Lining Thickness ([Lining Thickness Value]) is too large for current Width ([Width Value]).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId LiningThicknessIsLargeForWidth { get; }
Visual Basic
Public Shared ReadOnly Property LiningThicknessIsLargeForWidth As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LiningThicknessIsLargeForWidth {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MechanicalFailures Class


PanelDoesntMatchCircuitProperties Property

[image]

Revit 2024 API
BuiltInFailures..::..MechanicalFailures..::..PanelDoesntMatchCircuitProperties Property
BuiltInFailures..::..MechanicalFailures Class See Also Send Feedback
The panel no longer matches the properties for the Circuit. Disconnect the panel from the Circuit?

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId PanelDoesntMatchCircuitProperties { get; }
Visual Basic
Public Shared ReadOnly Property PanelDoesntMatchCircuitProperties As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PanelDoesntMatchCircuitProperties {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MechanicalFailures Class


TwoPointsSelectedBeforeEdit Property

[image]

Revit 2024 API
BuiltInFailures..::..MechanicalFailures..::..TwoPointsSelectedBeforeEdit Property
BuiltInFailures..::..MechanicalFailures Class See Also Send Feedback
Two points have to be selected before existing the edit mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId TwoPointsSelectedBeforeEdit { get; }
Visual Basic
Public Shared ReadOnly Property TwoPointsSelectedBeforeEdit As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TwoPointsSelectedBeforeEdit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MechanicalFailures Class


BuiltInFailures.MEPCalculationFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..MEPCalculationFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Fluid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class MEPCalculationFailures
Visual Basic
Public NotInheritable Class MEPCalculationFailures
Visual C++
public ref class MEPCalculationFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..MEPCalculationFailures

See Also

BuiltInFailures..::..MEPCalculationFailures Members


BuiltInFailures.MEPCalculationFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..MEPCalculationFailures Members
BuiltInFailures..::..MEPCalculationFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..MEPCalculationFailures type exposes the following members.

Properties

Name | Description
AtLeastOneEquipmentOnDuty | There should be at least one equipment on duty.
ClassificationNotSetInFamily | A calculation did not complete because the Classification parameter in the Mechanical Equipment family is not set.
DemandFlowAndPressureLossNotSetInLossFamily | A calculation did not complete because the pressure loss value for element is not set. Select the element and enter a value for the Pressure Loss.
DemandFlowNotSetInLossFamily | A calculation did not complete because the Demand Flow for the element is not set.
DuctFittingAndAccessoryPressureDropCalculatorNotAvailable | Duct Fitting/Accessory Pressure Drop Calculator Not Available: [Calculator Name]
DuctPressureDropCalculatorNotAvailable | Duct Pressure Drop Calculator Not Available: [Calculator Name]
ExtraPumpSet | More than one parallel pump set defined for the same loop. Verify the flow distribution and delete the extra set, if desired.
FlowAndPressureCalculationMethodHasBeenImproved | During upgrade pressure drop calculations for hydronic piping systems using Simplified Colebrook or Custom Calculation methods have been recalculated using the Colebrook equation.
HydraulicSeparationAmbiguity | Unable to hydraulically separate until the system has flow.
HydraulicSeparationOfOneSystem | Unable to hydraulically separate the loop when both supply and return are assigned to the same system. Try again with both start and end selected.
InvalidFluidProperty | Some network components may have a flow value of 0 (zero), due to invalid value settings for fluid Dynamic Viscosity or Density. \nVerify that you have selected the correct fluid type and that the fluid Dynamic Viscosity and Density values are set correctly in the Mechanical Settings dialog.
InvalidNumberOfMechanicalEquipmentOnDuty | The number of on duty equipment must be less than or equal to the number of available equipments.
LoopSeparationNotCompleted | The loop separation is not completed yet. Only one side of the secondary/tertiary loop is separated. In order to correctly calculate the flow and pressure loss, please check and separate the other end of the loop.
MechanicalEquipmentSetBeingDeleted | The mechanical equipment set was deleted because it no longer contained any members.
Network_ElementNodeIsNotPartOfNetwork | The calculation could not be executed as configured. At least one of the elements in this network uses a node that is not part of the network.
Network_NodePropertyNotSet | The calculation could not be executed as configured. Specify a constraint property set for the following input or output node(s).
Network_NoInputNode | The calculation could not be executed as configured. Select an input node before analyzing this network.
Network_NoOutputNode | The calculation could not be executed as configured. Select an output node before analyzing this network.
Network_NoPressureConstraint | The calculation could not be executed as configured. Each network requires at least 1 pressure constraint. Specify the pressure constraint.
Network_NotEnoughElements | The calculation could not be executed as configured. Specify at least 3 elements before analyzing this network.
Network_NotEnoughNodes | The calculation could not be executed as configured. Specify at least 4 elements before analyzing this network.
Network_NotFullyConnected | The network is not well connected. Some elements may have unexpected flow and pressure loss values.
Network_OverConstrained | The calculation could not be executed as configured. The Pressure and Flow Rate combined constraint requires at least 2 other pressure or flow constraints. Specify additional constraints.
NetworkCanNotDeterminCriticalPath | The calculation has completed, but there may be an error in determining the critical path. Verify that demand flow is specified for all required elements.
NetworkDefaultToPressure | The network uses the default pressure.
NetworkDefaultToReynolds | The network uses the default Reynolds number.
NetworkEnergyEquationNotConverge | The energy calculation could not be performed.
NetworkErrorCalculatingPressure | The pressure calculation could not be performed.
NetworkErrorElementWithDownUpStreamNode | The network needs an input or output element to perform the calculation.
NetworkErrorExtractCurveData | The calculation could not be performed. Verify the pump curve data.
NetworkErrorModelTooBig | The size of the network exceeds the current limit for flow/pressure analysis. In the Mechanical Settings dialog, under Pipe Settings - Calculation, disable the option to Use analysis for closed loop hydronic networks.
NetworkErrorOverConstrained | The calculation could not be performed due to overconstrained flow condition in the network.
NetworkExtraPumpOutsideSet | Flow calculations do not calculate this pump together with the other pumps as one equipment set. Verify the flow distribution and add the pump to the equipment set, if desired.
NetworkInconsistentDemandFlow | The specified flow on this equipment is inconsistent with the other equipment in this branch. The branch flow is calculated based on the maximum specified value.
NetworkMinorLossNotConverge | The minor loss calculation could not be performed.
NetworkPressureNotConverge | The calculation could not be performed. Verify the pressure on the input element.
NetworkUnderConstrained | The network is under constrained. You may specify the design flow value in the missing branches, or cap the open ends.
PipeConnectorsAreNotLined | A calculation did not complete because the connectors used by this family to connect to the network are not linked.
PipeFittingAndAccessoryPressureDropCalculatorNotAvailable | Pipe Fitting/Accessory Pressure Drop Calculator Not Available: [Calculator Name]
PipePressureDropCalculatorNotAvailable | Pipe Pressure Drop Calculator Not Available: [Calculator Name]
PlumbingFlowCalculatorNotAvailable | Plumbing Flow Calculator Not Available: [Calculator Name]
PressureLossNotSetInLossFamily | A calculation did not complete because the pressure loss value for the source equipment is not set for the network.
PumpPressureNotComputed | The calculated pressure drop of this pump is not computed because the critical path is not a closed loop. Check to see if there are other pumps intended for use within a secondary/tertiary loop. Use the Add Separation tool to define the secondary/tertiary loop.
SeparationNotAtJunction | This hydraulic loop is not separated at any junction. Use the Remove Separation tool to clean up undesired hydraulic separations.
SeparationWithOddJunction | Hydraulic separation requires an even number of junctions on the header pipe for accurate calculations. Add or remove junctions to complete the separation.

See Also

BuiltInFailures..::..MEPCalculationFailures Class


BuiltInFailures.MEPCalculationFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..MEPCalculationFailures Properties
BuiltInFailures..::..MEPCalculationFailures Class See Also Send Feedback

The BuiltInFailures..::..MEPCalculationFailures type exposes the following members.

Properties

Name | Description
AtLeastOneEquipmentOnDuty | There should be at least one equipment on duty.
ClassificationNotSetInFamily | A calculation did not complete because the Classification parameter in the Mechanical Equipment family is not set.
DemandFlowAndPressureLossNotSetInLossFamily | A calculation did not complete because the pressure loss value for element is not set. Select the element and enter a value for the Pressure Loss.
DemandFlowNotSetInLossFamily | A calculation did not complete because the Demand Flow for the element is not set.
DuctFittingAndAccessoryPressureDropCalculatorNotAvailable | Duct Fitting/Accessory Pressure Drop Calculator Not Available: [Calculator Name]
DuctPressureDropCalculatorNotAvailable | Duct Pressure Drop Calculator Not Available: [Calculator Name]
ExtraPumpSet | More than one parallel pump set defined for the same loop. Verify the flow distribution and delete the extra set, if desired.
FlowAndPressureCalculationMethodHasBeenImproved | During upgrade pressure drop calculations for hydronic piping systems using Simplified Colebrook or Custom Calculation methods have been recalculated using the Colebrook equation.
HydraulicSeparationAmbiguity | Unable to hydraulically separate until the system has flow.
HydraulicSeparationOfOneSystem | Unable to hydraulically separate the loop when both supply and return are assigned to the same system. Try again with both start and end selected.
InvalidFluidProperty | Some network components may have a flow value of 0 (zero), due to invalid value settings for fluid Dynamic Viscosity or Density. \nVerify that you have selected the correct fluid type and that the fluid Dynamic Viscosity and Density values are set correctly in the Mechanical Settings dialog.
InvalidNumberOfMechanicalEquipmentOnDuty | The number of on duty equipment must be less than or equal to the number of available equipments.
LoopSeparationNotCompleted | The loop separation is not completed yet. Only one side of the secondary/tertiary loop is separated. In order to correctly calculate the flow and pressure loss, please check and separate the other end of the loop.
MechanicalEquipmentSetBeingDeleted | The mechanical equipment set was deleted because it no longer contained any members.
Network_ElementNodeIsNotPartOfNetwork | The calculation could not be executed as configured. At least one of the elements in this network uses a node that is not part of the network.
Network_NodePropertyNotSet | The calculation could not be executed as configured. Specify a constraint property set for the following input or output node(s).
Network_NoInputNode | The calculation could not be executed as configured. Select an input node before analyzing this network.
Network_NoOutputNode | The calculation could not be executed as configured. Select an output node before analyzing this network.
Network_NoPressureConstraint | The calculation could not be executed as configured. Each network requires at least 1 pressure constraint. Specify the pressure constraint.
Network_NotEnoughElements | The calculation could not be executed as configured. Specify at least 3 elements before analyzing this network.
Network_NotEnoughNodes | The calculation could not be executed as configured. Specify at least 4 elements before analyzing this network.
Network_NotFullyConnected | The network is not well connected. Some elements may have unexpected flow and pressure loss values.
Network_OverConstrained | The calculation could not be executed as configured. The Pressure and Flow Rate combined constraint requires at least 2 other pressure or flow constraints. Specify additional constraints.
NetworkCanNotDeterminCriticalPath | The calculation has completed, but there may be an error in determining the critical path. Verify that demand flow is specified for all required elements.
NetworkDefaultToPressure | The network uses the default pressure.
NetworkDefaultToReynolds | The network uses the default Reynolds number.
NetworkEnergyEquationNotConverge | The energy calculation could not be performed.
NetworkErrorCalculatingPressure | The pressure calculation could not be performed.
NetworkErrorElementWithDownUpStreamNode | The network needs an input or output element to perform the calculation.
NetworkErrorExtractCurveData | The calculation could not be performed. Verify the pump curve data.
NetworkErrorModelTooBig | The size of the network exceeds the current limit for flow/pressure analysis. In the Mechanical Settings dialog, under Pipe Settings - Calculation, disable the option to Use analysis for closed loop hydronic networks.
NetworkErrorOverConstrained | The calculation could not be performed due to overconstrained flow condition in the network.
NetworkExtraPumpOutsideSet | Flow calculations do not calculate this pump together with the other pumps as one equipment set. Verify the flow distribution and add the pump to the equipment set, if desired.
NetworkInconsistentDemandFlow | The specified flow on this equipment is inconsistent with the other equipment in this branch. The branch flow is calculated based on the maximum specified value.
NetworkMinorLossNotConverge | The minor loss calculation could not be performed.
NetworkPressureNotConverge | The calculation could not be performed. Verify the pressure on the input element.
NetworkUnderConstrained | The network is under constrained. You may specify the design flow value in the missing branches, or cap the open ends.
PipeConnectorsAreNotLined | A calculation did not complete because the connectors used by this family to connect to the network are not linked.
PipeFittingAndAccessoryPressureDropCalculatorNotAvailable | Pipe Fitting/Accessory Pressure Drop Calculator Not Available: [Calculator Name]
PipePressureDropCalculatorNotAvailable | Pipe Pressure Drop Calculator Not Available: [Calculator Name]
PlumbingFlowCalculatorNotAvailable | Plumbing Flow Calculator Not Available: [Calculator Name]
PressureLossNotSetInLossFamily | A calculation did not complete because the pressure loss value for the source equipment is not set for the network.
PumpPressureNotComputed | The calculated pressure drop of this pump is not computed because the critical path is not a closed loop. Check to see if there are other pumps intended for use within a secondary/tertiary loop. Use the Add Separation tool to define the secondary/tertiary loop.
SeparationNotAtJunction | This hydraulic loop is not separated at any junction. Use the Remove Separation tool to clean up undesired hydraulic separations.
SeparationWithOddJunction | Hydraulic separation requires an even number of junctions on the header pipe for accurate calculations. Add or remove junctions to complete the separation.

See Also

BuiltInFailures..::..MEPCalculationFailures Class


AtLeastOneEquipmentOnDuty Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPCalculationFailures..::..AtLeastOneEquipmentOnDuty Property
BuiltInFailures..::..MEPCalculationFailures Class See Also Send Feedback
There should be at least one equipment on duty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AtLeastOneEquipmentOnDuty { get; }
Visual Basic
Public Shared ReadOnly Property AtLeastOneEquipmentOnDuty As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AtLeastOneEquipmentOnDuty {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPCalculationFailures Class


ClassificationNotSetInFamily Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPCalculationFailures..::..ClassificationNotSetInFamily Property
BuiltInFailures..::..MEPCalculationFailures Class See Also Send Feedback
A calculation did not complete because the Classification parameter in the Mechanical Equipment family is not set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ClassificationNotSetInFamily { get; }
Visual Basic
Public Shared ReadOnly Property ClassificationNotSetInFamily As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ClassificationNotSetInFamily {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPCalculationFailures Class


DemandFlowAndPressureLossNotSetInLossFamily Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPCalculationFailures..::..DemandFlowAndPressureLossNotSetInLossFamily Property
BuiltInFailures..::..MEPCalculationFailures Class See Also Send Feedback
A calculation did not complete because the pressure loss value for element is not set. Select the element and enter a value for the Pressure Loss.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DemandFlowAndPressureLossNotSetInLossFamily { get; }
Visual Basic
Public Shared ReadOnly Property DemandFlowAndPressureLossNotSetInLossFamily As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DemandFlowAndPressureLossNotSetInLossFamily {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPCalculationFailures Class


DemandFlowNotSetInLossFamily Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPCalculationFailures..::..DemandFlowNotSetInLossFamily Property
BuiltInFailures..::..MEPCalculationFailures Class See Also Send Feedback
A calculation did not complete because the Demand Flow for the element is not set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DemandFlowNotSetInLossFamily { get; }
Visual Basic
Public Shared ReadOnly Property DemandFlowNotSetInLossFamily As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DemandFlowNotSetInLossFamily {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPCalculationFailures Class


DuctFittingAndAccessoryPressureDropCalculatorNotAvailable Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPCalculationFailures..::..DuctFittingAndAccessoryPressureDropCalculatorNotAvailable Property
BuiltInFailures..::..MEPCalculationFailures Class See Also Send Feedback
Duct Fitting/Accessory Pressure Drop Calculator Not Available: [Calculator Name]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DuctFittingAndAccessoryPressureDropCalculatorNotAvailable { get; }
Visual Basic
Public Shared ReadOnly Property DuctFittingAndAccessoryPressureDropCalculatorNotAvailable As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DuctFittingAndAccessoryPressureDropCalculatorNotAvailable {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPCalculationFailures Class


DuctPressureDropCalculatorNotAvailable Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPCalculationFailures..::..DuctPressureDropCalculatorNotAvailable Property
BuiltInFailures..::..MEPCalculationFailures Class See Also Send Feedback
Duct Pressure Drop Calculator Not Available: [Calculator Name]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DuctPressureDropCalculatorNotAvailable { get; }
Visual Basic
Public Shared ReadOnly Property DuctPressureDropCalculatorNotAvailable As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DuctPressureDropCalculatorNotAvailable {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPCalculationFailures Class


FlowAndPressureCalculationMethodHasBeenImproved Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPCalculationFailures..::..FlowAndPressureCalculationMethodHasBeenImproved Property
BuiltInFailures..::..MEPCalculationFailures Class See Also Send Feedback
During upgrade pressure drop calculations for hydronic piping systems using Simplified Colebrook or Custom Calculation methods have been recalculated using the Colebrook equation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FlowAndPressureCalculationMethodHasBeenImproved { get; }
Visual Basic
Public Shared ReadOnly Property FlowAndPressureCalculationMethodHasBeenImproved As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FlowAndPressureCalculationMethodHasBeenImproved {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPCalculationFailures Class


HydraulicSeparationAmbiguity Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPCalculationFailures..::..HydraulicSeparationAmbiguity Property
BuiltInFailures..::..MEPCalculationFailures Class See Also Send Feedback
Unable to hydraulically separate until the system has flow.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId HydraulicSeparationAmbiguity { get; }
Visual Basic
Public Shared ReadOnly Property HydraulicSeparationAmbiguity As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HydraulicSeparationAmbiguity {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPCalculationFailures Class


HydraulicSeparationOfOneSystem Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPCalculationFailures..::..HydraulicSeparationOfOneSystem Property
BuiltInFailures..::..MEPCalculationFailures Class See Also Send Feedback
Unable to hydraulically separate the loop when both supply and return are assigned to the same system. Try again with both start and end selected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId HydraulicSeparationOfOneSystem { get; }
Visual Basic
Public Shared ReadOnly Property HydraulicSeparationOfOneSystem As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HydraulicSeparationOfOneSystem {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPCalculationFailures Class


LoopSeparationNotCompleted Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPCalculationFailures..::..LoopSeparationNotCompleted Property
BuiltInFailures..::..MEPCalculationFailures Class See Also Send Feedback
The loop separation is not completed yet. Only one side of the secondary/tertiary loop is separated. In order to correctly calculate the flow and pressure loss, please check and separate the other end of the loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId LoopSeparationNotCompleted { get; }
Visual Basic
Public Shared ReadOnly Property LoopSeparationNotCompleted As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LoopSeparationNotCompleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPCalculationFailures Class


MechanicalEquipmentSetBeingDeleted Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPCalculationFailures..::..MechanicalEquipmentSetBeingDeleted Property
BuiltInFailures..::..MEPCalculationFailures Class See Also Send Feedback
The mechanical equipment set was deleted because it no longer contained any members.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MechanicalEquipmentSetBeingDeleted { get; }
Visual Basic
Public Shared ReadOnly Property MechanicalEquipmentSetBeingDeleted As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MechanicalEquipmentSetBeingDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPCalculationFailures Class


Network_ElementNodeIsNotPartOfNetwork Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPCalculationFailures..::..Network_ElementNodeIsNotPartOfNetwork Property
BuiltInFailures..::..MEPCalculationFailures Class See Also Send Feedback
The calculation could not be executed as configured. At least one of the elements in this network uses a node that is not part of the network.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId Network_ElementNodeIsNotPartOfNetwork { get; }
Visual Basic
Public Shared ReadOnly Property Network_ElementNodeIsNotPartOfNetwork As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ Network_ElementNodeIsNotPartOfNetwork {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPCalculationFailures Class


Network_NoInputNode Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPCalculationFailures..::..Network_NoInputNode Property
BuiltInFailures..::..MEPCalculationFailures Class See Also Send Feedback
The calculation could not be executed as configured. Select an input node before analyzing this network.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId Network_NoInputNode { get; }
Visual Basic
Public Shared ReadOnly Property Network_NoInputNode As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ Network_NoInputNode {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPCalculationFailures Class


Network_NoOutputNode Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPCalculationFailures..::..Network_NoOutputNode Property
BuiltInFailures..::..MEPCalculationFailures Class See Also Send Feedback
The calculation could not be executed as configured. Select an output node before analyzing this network.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId Network_NoOutputNode { get; }
Visual Basic
Public Shared ReadOnly Property Network_NoOutputNode As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ Network_NoOutputNode {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPCalculationFailures Class


Network_NotEnoughNodes Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPCalculationFailures..::..Network_NotEnoughNodes Property
BuiltInFailures..::..MEPCalculationFailures Class See Also Send Feedback
The calculation could not be executed as configured. Specify at least 4 elements before analyzing this network.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId Network_NotEnoughNodes { get; }
Visual Basic
Public Shared ReadOnly Property Network_NotEnoughNodes As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ Network_NotEnoughNodes {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPCalculationFailures Class


Network_NotFullyConnected Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPCalculationFailures..::..Network_NotFullyConnected Property
BuiltInFailures..::..MEPCalculationFailures Class See Also Send Feedback
The network is not well connected. Some elements may have unexpected flow and pressure loss values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId Network_NotFullyConnected { get; }
Visual Basic
Public Shared ReadOnly Property Network_NotFullyConnected As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ Network_NotFullyConnected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPCalculationFailures Class


Network_OverConstrained Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPCalculationFailures..::..Network_OverConstrained Property
BuiltInFailures..::..MEPCalculationFailures Class See Also Send Feedback
The calculation could not be executed as configured. The Pressure and Flow Rate combined constraint requires at least 2 other pressure or flow constraints. Specify additional constraints.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId Network_OverConstrained { get; }
Visual Basic
Public Shared ReadOnly Property Network_OverConstrained As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ Network_OverConstrained {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPCalculationFailures Class


NetworkCanNotDeterminCriticalPath Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPCalculationFailures..::..NetworkCanNotDeterminCriticalPath Property
BuiltInFailures..::..MEPCalculationFailures Class See Also Send Feedback
The calculation has completed, but there may be an error in determining the critical path. Verify that demand flow is specified for all required elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NetworkCanNotDeterminCriticalPath { get; }
Visual Basic
Public Shared ReadOnly Property NetworkCanNotDeterminCriticalPath As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NetworkCanNotDeterminCriticalPath {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPCalculationFailures Class


NetworkDefaultToPressure Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPCalculationFailures..::..NetworkDefaultToPressure Property
BuiltInFailures..::..MEPCalculationFailures Class See Also Send Feedback
The network uses the default pressure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NetworkDefaultToPressure { get; }
Visual Basic
Public Shared ReadOnly Property NetworkDefaultToPressure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NetworkDefaultToPressure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPCalculationFailures Class


NetworkDefaultToReynolds Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPCalculationFailures..::..NetworkDefaultToReynolds Property
BuiltInFailures..::..MEPCalculationFailures Class See Also Send Feedback
The network uses the default Reynolds number.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NetworkDefaultToReynolds { get; }
Visual Basic
Public Shared ReadOnly Property NetworkDefaultToReynolds As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NetworkDefaultToReynolds {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPCalculationFailures Class


NetworkEnergyEquationNotConverge Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPCalculationFailures..::..NetworkEnergyEquationNotConverge Property
BuiltInFailures..::..MEPCalculationFailures Class See Also Send Feedback
The energy calculation could not be performed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NetworkEnergyEquationNotConverge { get; }
Visual Basic
Public Shared ReadOnly Property NetworkEnergyEquationNotConverge As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NetworkEnergyEquationNotConverge {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPCalculationFailures Class


NetworkErrorCalculatingPressure Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPCalculationFailures..::..NetworkErrorCalculatingPressure Property
BuiltInFailures..::..MEPCalculationFailures Class See Also Send Feedback
The pressure calculation could not be performed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NetworkErrorCalculatingPressure { get; }
Visual Basic
Public Shared ReadOnly Property NetworkErrorCalculatingPressure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NetworkErrorCalculatingPressure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPCalculationFailures Class


NetworkErrorElementWithDownUpStreamNode Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPCalculationFailures..::..NetworkErrorElementWithDownUpStreamNode Property
BuiltInFailures..::..MEPCalculationFailures Class See Also Send Feedback
The network needs an input or output element to perform the calculation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NetworkErrorElementWithDownUpStreamNode { get; }
Visual Basic
Public Shared ReadOnly Property NetworkErrorElementWithDownUpStreamNode As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NetworkErrorElementWithDownUpStreamNode {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPCalculationFailures Class


NetworkErrorModelTooBig Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPCalculationFailures..::..NetworkErrorModelTooBig Property
BuiltInFailures..::..MEPCalculationFailures Class See Also Send Feedback
The size of the network exceeds the current limit for flow/pressure analysis. In the Mechanical Settings dialog, under Pipe Settings - Calculation, disable the option to Use analysis for closed loop hydronic networks.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NetworkErrorModelTooBig { get; }
Visual Basic
Public Shared ReadOnly Property NetworkErrorModelTooBig As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NetworkErrorModelTooBig {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPCalculationFailures Class


NetworkErrorOverConstrained Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPCalculationFailures..::..NetworkErrorOverConstrained Property
BuiltInFailures..::..MEPCalculationFailures Class See Also Send Feedback
The calculation could not be performed due to overconstrained flow condition in the network.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NetworkErrorOverConstrained { get; }
Visual Basic
Public Shared ReadOnly Property NetworkErrorOverConstrained As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NetworkErrorOverConstrained {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPCalculationFailures Class


NetworkExtraPumpOutsideSet Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPCalculationFailures..::..NetworkExtraPumpOutsideSet Property
BuiltInFailures..::..MEPCalculationFailures Class See Also Send Feedback
Flow calculations do not calculate this pump together with the other pumps as one equipment set. Verify the flow distribution and add the pump to the equipment set, if desired.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NetworkExtraPumpOutsideSet { get; }
Visual Basic
Public Shared ReadOnly Property NetworkExtraPumpOutsideSet As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NetworkExtraPumpOutsideSet {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPCalculationFailures Class


NetworkInconsistentDemandFlow Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPCalculationFailures..::..NetworkInconsistentDemandFlow Property
BuiltInFailures..::..MEPCalculationFailures Class See Also Send Feedback
The specified flow on this equipment is inconsistent with the other equipment in this branch. The branch flow is calculated based on the maximum specified value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NetworkInconsistentDemandFlow { get; }
Visual Basic
Public Shared ReadOnly Property NetworkInconsistentDemandFlow As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NetworkInconsistentDemandFlow {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPCalculationFailures Class


NetworkUnderConstrained Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPCalculationFailures..::..NetworkUnderConstrained Property
BuiltInFailures..::..MEPCalculationFailures Class See Also Send Feedback
The network is under constrained. You may specify the design flow value in the missing branches, or cap the open ends.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NetworkUnderConstrained { get; }
Visual Basic
Public Shared ReadOnly Property NetworkUnderConstrained As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NetworkUnderConstrained {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPCalculationFailures Class


PipeConnectorsAreNotLined Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPCalculationFailures..::..PipeConnectorsAreNotLined Property
BuiltInFailures..::..MEPCalculationFailures Class See Also Send Feedback
A calculation did not complete because the connectors used by this family to connect to the network are not linked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId PipeConnectorsAreNotLined { get; }
Visual Basic
Public Shared ReadOnly Property PipeConnectorsAreNotLined As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PipeConnectorsAreNotLined {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPCalculationFailures Class


PipeFittingAndAccessoryPressureDropCalculatorNotAvailable Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPCalculationFailures..::..PipeFittingAndAccessoryPressureDropCalculatorNotAvailable Property
BuiltInFailures..::..MEPCalculationFailures Class See Also Send Feedback
Pipe Fitting/Accessory Pressure Drop Calculator Not Available: [Calculator Name]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId PipeFittingAndAccessoryPressureDropCalculatorNotAvailable { get; }
Visual Basic
Public Shared ReadOnly Property PipeFittingAndAccessoryPressureDropCalculatorNotAvailable As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PipeFittingAndAccessoryPressureDropCalculatorNotAvailable {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPCalculationFailures Class


PipePressureDropCalculatorNotAvailable Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPCalculationFailures..::..PipePressureDropCalculatorNotAvailable Property
BuiltInFailures..::..MEPCalculationFailures Class See Also Send Feedback
Pipe Pressure Drop Calculator Not Available: [Calculator Name]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId PipePressureDropCalculatorNotAvailable { get; }
Visual Basic
Public Shared ReadOnly Property PipePressureDropCalculatorNotAvailable As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PipePressureDropCalculatorNotAvailable {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPCalculationFailures Class


PlumbingFlowCalculatorNotAvailable Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPCalculationFailures..::..PlumbingFlowCalculatorNotAvailable Property
BuiltInFailures..::..MEPCalculationFailures Class See Also Send Feedback
Plumbing Flow Calculator Not Available: [Calculator Name]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId PlumbingFlowCalculatorNotAvailable { get; }
Visual Basic
Public Shared ReadOnly Property PlumbingFlowCalculatorNotAvailable As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PlumbingFlowCalculatorNotAvailable {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPCalculationFailures Class


PressureLossNotSetInLossFamily Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPCalculationFailures..::..PressureLossNotSetInLossFamily Property
BuiltInFailures..::..MEPCalculationFailures Class See Also Send Feedback
A calculation did not complete because the pressure loss value for the source equipment is not set for the network.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId PressureLossNotSetInLossFamily { get; }
Visual Basic
Public Shared ReadOnly Property PressureLossNotSetInLossFamily As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PressureLossNotSetInLossFamily {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPCalculationFailures Class


SeparationWithOddJunction Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPCalculationFailures..::..SeparationWithOddJunction Property
BuiltInFailures..::..MEPCalculationFailures Class See Also Send Feedback
Hydraulic separation requires an even number of junctions on the header pipe for accurate calculations. Add or remove junctions to complete the separation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SeparationWithOddJunction { get; }
Visual Basic
Public Shared ReadOnly Property SeparationWithOddJunction As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SeparationWithOddJunction {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPCalculationFailures Class


BuiltInFailures.MEPFabricationFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..MEPFabricationFailures Members
BuiltInFailures..::..MEPFabricationFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..MEPFabricationFailures type exposes the following members.

Properties

Name | Description
AdditionalPartNotLoaded | An additional part was not loaded.
CannotConvertFlexPipeToPart | Cannot convert flex pipe to fabrication part.
CannotMatchFabricationHangerSizeToHost | The hanger cannot be re-sized to match the re-sized host.
FabDbChangeConn | Fabrication Database changes altered connectivity
FabDbOpenJobConn | Fabrication job imported had bad connectivity
FabDbSwapOut | Fabrication Database reload could not swap out for newer parts.
FabricationConfigurationCorrupted | It looks that the Fabrication Configuration %1!s! was corrupted, please check it at %2!s!.
FabricationHangerCannotBeSloped | A hanger cannot be sloped or placed on a sloped element.
FabricationHangerHostNotFound | The hanger will disconnect because we can't find the suitable host.
FabricationHangerNotConnectToHost | Fabrication Hanger didn't connect to the %s host.
FabricationHangerOutOfHost | The hanger is out of its host and will be disconnected.
FabricationHangerSizeNotMatch | The hanger size does not match the size of the host, so it can not be connected.
FabricationOutOfSizeCondition | The fabrication part size is not within the correct size range for the service button condition.
FabricationOverSizedCheck | Fabrication part is too large to fit on the sheet metal. Replace the part with multiple smaller parts, or notify the CAM operator.
FabricationPartCannotBeMirrored |
FabricationPartCannotChangeServiceSizeWarning | The selected fitting(s) cannot successfully change service or change size. You must disconnect the connections on the fitting(s) and try again.
FabricationPartCannotChangeSlopeError | The connected fitting(s) cannot successfully change to the new slope value. You may try to disconnect the connections on the fitting(s) and try again.
FabricationPartCannotChangeTypeBadDimError | The selected fitting(s) cannot successfully change the type. The newly selected fabrication part may have badly configured dimensions or be constrained due to connected fitting(s). You may try to disconnect the connections on the fitting(s) and try again.
FabricationPartCannotChangeTypeBadDimUnConnError | The selected fitting(s) cannot successfully change the type. The newly selected fabrication part may have badly configured dimensions, resulting in bad geometry.
FabricationPartCannotChangeTypeError | The selected fitting(s) cannot successfully change the type. You must disconnect the connections on the fitting(s) and try again.
FabricationPartCannotChangeTypeIncompatError | The selected fitting(s) cannot successfully change the type. The newly selected fabrication part type either has no material or has badly configured dimensions, resulting in bad geometry. You may try to disconnect the connections on the fitting(s) and try again.
FabricationPartCannotChangeTypeIncompatUnConnError | The selected fitting(s) cannot successfully change the type. The newly selected fabrication part type either has no material or has badly configured dimensions, resulting in bad geometry.
FabricationPartCannotChangeTypeMisalignedError | The selected fitting(s) cannot successfully change the type. The newly selected fabrication part type has a problem with the angle dimension of the current fitting(s), resulting in bad geometry. You may try to disconnect the connections on the fitting(s) and try again.
FabricationPartCannotChangeTypeMisalignedUnConnError | The selected fitting(s) cannot successfully change the type. The newly selected fabrication part type has a problem with the angle dimension of the current fitting(s), resulting in bad geometry.
FabricationPartCannotChangeTypeUnConnError | The selected fitting(s) cannot successfully change the type.
FabricationPartCannotChangeTypeWarning | The selected fitting(s) cannot maintain connections to existing fabrication parts due to size, direction or angle differences. You must manually reconnect the open connections.
FabricationPartExceededAngleFlexToleranceWarning | The angle flex is greater than the maximum angle flex tolerance defined by the fabrication part. Connections with this part may not be properly aligned and may appear to be skewed.
FabricationPartExcludedPartWarning | There were fabrication parts needed to the make the connection that were excluded from the fabrication service causing the connection to fail. You may try to inlcude these fitting(s) and try again.
FabricationPartFitFailure | Fabrication Part Fitting Failed to Fit
FabricationPartFitFailWarning | Fabrication Part Fitting Failed to Fit
FabricationPartHasInvalidGeometry | The fabrication part either has no material or has badly configured dimensions, resulting in bad geometry.
FabricationPartInvalidConnection | Fabrication Part connection invalid and could not be automatically coupled.
FabricationPartInvalidSpecification | The part specification is invalid.
FabricationPartNoPartTypeFound | There are no fabrication part types found for the current Configuration and Service. Please select settings and reload the service to create the fabrication part types.
FabricationPartNotAttachedToStraight | The part must be attached to straight.
FabricationPartOptimizeInvalidConnection | No available couplings to connect standard lengths for this instance of straight.
FabricationRodDetachFromHangerError | The rod need to be detached from hanger.
FabricationRodsConnectionChangedWarning | The structural component that the hanger is attached to has changed to a different element.
FabricationRodsDisconnectedError | The hanger rod was disconnected because there is no structural component above.
FabricationRodsDisconnectedWarning | The hanger rod was disconnected because there is no structural component above.
FabricationServiceMismatch | Attempting to connect fabrication parts from different services.
FabricationStraigtLengthOversized | Fabrication straight exceeds the standard length. Use the Optimize Length command to adjust the length.
FixedFabricationPartNotChangeLength | Failed to change length of fixed part.
GroupedFabricationPartNotReposition | Failed to reposition part.
HangerProfileNotMatchWithHost | The defined hanger profile does not match with the host.
HangerWidthOutOfRange | The hanger width is too large to show.
InvalidConnectionsHaveBeenDisconnected | Invalid connections have been disconnected. Please reconnect them manually or use different fittings.
InvalidSelectionThereCannotBeOpenConnectors | Invalid selection there cannot be any open connectors for the design to fabrication part tool.
NoStructuralHostToAttachWarning | There is no structural component to attach the hanger rod to.
NotAllPartsWereConvertedUnsuportedFittingOffsets | Not all parts were converted. Eccentric transitions and taps that have offsets from the center line are unsupported and cannot be converted.
PinnedFabricationPartNotChangeExtension | Failed to change extension of part.
PinnedFabricationPartNotReposition | Failed to reposition part.
PlaceCutinFittingFailed | Failed to insert part.
SizeNotAvailableInFabricationService | Sizes:%1!s! in system %2!s! are not available in fabrication service:%3!s!, All available sizes are:\n%4!s!.
UneditableFabricationPartNotReposition | Failed to reposition part.

See Also

BuiltInFailures..::..MEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..MEPFabricationFailures Properties
BuiltInFailures..::..MEPFabricationFailures Class See Also Send Feedback

The BuiltInFailures..::..MEPFabricationFailures type exposes the following members.

Properties

Name | Description
AdditionalPartNotLoaded | An additional part was not loaded.
CannotConvertFlexPipeToPart | Cannot convert flex pipe to fabrication part.
CannotMatchFabricationHangerSizeToHost | The hanger cannot be re-sized to match the re-sized host.
FabDbChangeConn | Fabrication Database changes altered connectivity
FabDbOpenJobConn | Fabrication job imported had bad connectivity
FabDbSwapOut | Fabrication Database reload could not swap out for newer parts.
FabricationConfigurationCorrupted | It looks that the Fabrication Configuration %1!s! was corrupted, please check it at %2!s!.
FabricationHangerCannotBeSloped | A hanger cannot be sloped or placed on a sloped element.
FabricationHangerHostNotFound | The hanger will disconnect because we can't find the suitable host.
FabricationHangerNotConnectToHost | Fabrication Hanger didn't connect to the %s host.
FabricationHangerOutOfHost | The hanger is out of its host and will be disconnected.
FabricationHangerSizeNotMatch | The hanger size does not match the size of the host, so it can not be connected.
FabricationOutOfSizeCondition | The fabrication part size is not within the correct size range for the service button condition.
FabricationOverSizedCheck | Fabrication part is too large to fit on the sheet metal. Replace the part with multiple smaller parts, or notify the CAM operator.
FabricationPartCannotBeMirrored |
FabricationPartCannotChangeServiceSizeWarning | The selected fitting(s) cannot successfully change service or change size. You must disconnect the connections on the fitting(s) and try again.
FabricationPartCannotChangeSlopeError | The connected fitting(s) cannot successfully change to the new slope value. You may try to disconnect the connections on the fitting(s) and try again.
FabricationPartCannotChangeTypeBadDimError | The selected fitting(s) cannot successfully change the type. The newly selected fabrication part may have badly configured dimensions or be constrained due to connected fitting(s). You may try to disconnect the connections on the fitting(s) and try again.
FabricationPartCannotChangeTypeBadDimUnConnError | The selected fitting(s) cannot successfully change the type. The newly selected fabrication part may have badly configured dimensions, resulting in bad geometry.
FabricationPartCannotChangeTypeError | The selected fitting(s) cannot successfully change the type. You must disconnect the connections on the fitting(s) and try again.
FabricationPartCannotChangeTypeIncompatError | The selected fitting(s) cannot successfully change the type. The newly selected fabrication part type either has no material or has badly configured dimensions, resulting in bad geometry. You may try to disconnect the connections on the fitting(s) and try again.
FabricationPartCannotChangeTypeIncompatUnConnError | The selected fitting(s) cannot successfully change the type. The newly selected fabrication part type either has no material or has badly configured dimensions, resulting in bad geometry.
FabricationPartCannotChangeTypeMisalignedError | The selected fitting(s) cannot successfully change the type. The newly selected fabrication part type has a problem with the angle dimension of the current fitting(s), resulting in bad geometry. You may try to disconnect the connections on the fitting(s) and try again.
FabricationPartCannotChangeTypeMisalignedUnConnError | The selected fitting(s) cannot successfully change the type. The newly selected fabrication part type has a problem with the angle dimension of the current fitting(s), resulting in bad geometry.
FabricationPartCannotChangeTypeUnConnError | The selected fitting(s) cannot successfully change the type.
FabricationPartCannotChangeTypeWarning | The selected fitting(s) cannot maintain connections to existing fabrication parts due to size, direction or angle differences. You must manually reconnect the open connections.
FabricationPartExceededAngleFlexToleranceWarning | The angle flex is greater than the maximum angle flex tolerance defined by the fabrication part. Connections with this part may not be properly aligned and may appear to be skewed.
FabricationPartExcludedPartWarning | There were fabrication parts needed to the make the connection that were excluded from the fabrication service causing the connection to fail. You may try to inlcude these fitting(s) and try again.
FabricationPartFitFailure | Fabrication Part Fitting Failed to Fit
FabricationPartFitFailWarning | Fabrication Part Fitting Failed to Fit
FabricationPartHasInvalidGeometry | The fabrication part either has no material or has badly configured dimensions, resulting in bad geometry.
FabricationPartInvalidConnection | Fabrication Part connection invalid and could not be automatically coupled.
FabricationPartInvalidSpecification | The part specification is invalid.
FabricationPartNoPartTypeFound | There are no fabrication part types found for the current Configuration and Service. Please select settings and reload the service to create the fabrication part types.
FabricationPartNotAttachedToStraight | The part must be attached to straight.
FabricationPartOptimizeInvalidConnection | No available couplings to connect standard lengths for this instance of straight.
FabricationRodDetachFromHangerError | The rod need to be detached from hanger.
FabricationRodsConnectionChangedWarning | The structural component that the hanger is attached to has changed to a different element.
FabricationRodsDisconnectedError | The hanger rod was disconnected because there is no structural component above.
FabricationRodsDisconnectedWarning | The hanger rod was disconnected because there is no structural component above.
FabricationServiceMismatch | Attempting to connect fabrication parts from different services.
FabricationStraigtLengthOversized | Fabrication straight exceeds the standard length. Use the Optimize Length command to adjust the length.
FixedFabricationPartNotChangeLength | Failed to change length of fixed part.
GroupedFabricationPartNotReposition | Failed to reposition part.
HangerProfileNotMatchWithHost | The defined hanger profile does not match with the host.
HangerWidthOutOfRange | The hanger width is too large to show.
InvalidConnectionsHaveBeenDisconnected | Invalid connections have been disconnected. Please reconnect them manually or use different fittings.
InvalidSelectionThereCannotBeOpenConnectors | Invalid selection there cannot be any open connectors for the design to fabrication part tool.
NoStructuralHostToAttachWarning | There is no structural component to attach the hanger rod to.
NotAllPartsWereConvertedUnsuportedFittingOffsets | Not all parts were converted. Eccentric transitions and taps that have offsets from the center line are unsupported and cannot be converted.
PinnedFabricationPartNotChangeExtension | Failed to change extension of part.
PinnedFabricationPartNotReposition | Failed to reposition part.
PlaceCutinFittingFailed | Failed to insert part.
SizeNotAvailableInFabricationService | Sizes:%1!s! in system %2!s! are not available in fabrication service:%3!s!, All available sizes are:\n%4!s!.
UneditableFabricationPartNotReposition | Failed to reposition part.

See Also

BuiltInFailures..::..MEPFabricationFailures Class


AdditionalPartNotLoaded Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPFabricationFailures..::..AdditionalPartNotLoaded Property
BuiltInFailures..::..MEPFabricationFailures Class See Also Send Feedback
An additional part was not loaded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AdditionalPartNotLoaded { get; }
Visual Basic
Public Shared ReadOnly Property AdditionalPartNotLoaded As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AdditionalPartNotLoaded {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPFabricationFailures Class


CannotConvertFlexPipeToPart Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPFabricationFailures..::..CannotConvertFlexPipeToPart Property
BuiltInFailures..::..MEPFabricationFailures Class See Also Send Feedback
Cannot convert flex pipe to fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotConvertFlexPipeToPart { get; }
Visual Basic
Public Shared ReadOnly Property CannotConvertFlexPipeToPart As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotConvertFlexPipeToPart {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPFabricationFailures Class


CannotMatchFabricationHangerSizeToHost Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPFabricationFailures..::..CannotMatchFabricationHangerSizeToHost Property
BuiltInFailures..::..MEPFabricationFailures Class See Also Send Feedback
The hanger cannot be re-sized to match the re-sized host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotMatchFabricationHangerSizeToHost { get; }
Visual Basic
Public Shared ReadOnly Property CannotMatchFabricationHangerSizeToHost As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMatchFabricationHangerSizeToHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPFabricationFailures Class


FabDbChangeConn Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPFabricationFailures..::..FabDbChangeConn Property
BuiltInFailures..::..MEPFabricationFailures Class See Also Send Feedback
Fabrication Database changes altered connectivity

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FabDbChangeConn { get; }
Visual Basic
Public Shared ReadOnly Property FabDbChangeConn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FabDbChangeConn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPFabricationFailures Class


FabDbOpenJobConn Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPFabricationFailures..::..FabDbOpenJobConn Property
BuiltInFailures..::..MEPFabricationFailures Class See Also Send Feedback
Fabrication job imported had bad connectivity

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FabDbOpenJobConn { get; }
Visual Basic
Public Shared ReadOnly Property FabDbOpenJobConn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FabDbOpenJobConn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPFabricationFailures Class


FabDbSwapOut Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPFabricationFailures..::..FabDbSwapOut Property
BuiltInFailures..::..MEPFabricationFailures Class See Also Send Feedback
Fabrication Database reload could not swap out for newer parts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FabDbSwapOut { get; }
Visual Basic
Public Shared ReadOnly Property FabDbSwapOut As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FabDbSwapOut {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPFabricationFailures Class


FabricationConfigurationCorrupted Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPFabricationFailures..::..FabricationConfigurationCorrupted Property
BuiltInFailures..::..MEPFabricationFailures Class See Also Send Feedback
It looks that the Fabrication Configuration %1!s! was corrupted, please check it at %2!s!.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FabricationConfigurationCorrupted { get; }
Visual Basic
Public Shared ReadOnly Property FabricationConfigurationCorrupted As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FabricationConfigurationCorrupted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPFabricationFailures Class


FabricationHangerCannotBeSloped Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPFabricationFailures..::..FabricationHangerCannotBeSloped Property
BuiltInFailures..::..MEPFabricationFailures Class See Also Send Feedback
A hanger cannot be sloped or placed on a sloped element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FabricationHangerCannotBeSloped { get; }
Visual Basic
Public Shared ReadOnly Property FabricationHangerCannotBeSloped As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FabricationHangerCannotBeSloped {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPFabricationFailures Class


FabricationHangerHostNotFound Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPFabricationFailures..::..FabricationHangerHostNotFound Property
BuiltInFailures..::..MEPFabricationFailures Class See Also Send Feedback
The hanger will disconnect because we can't find the suitable host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FabricationHangerHostNotFound { get; }
Visual Basic
Public Shared ReadOnly Property FabricationHangerHostNotFound As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FabricationHangerHostNotFound {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPFabricationFailures Class


FabricationHangerNotConnectToHost Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPFabricationFailures..::..FabricationHangerNotConnectToHost Property
BuiltInFailures..::..MEPFabricationFailures Class See Also Send Feedback
Fabrication Hanger didn't connect to the %s host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FabricationHangerNotConnectToHost { get; }
Visual Basic
Public Shared ReadOnly Property FabricationHangerNotConnectToHost As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FabricationHangerNotConnectToHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPFabricationFailures Class


FabricationHangerOutOfHost Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPFabricationFailures..::..FabricationHangerOutOfHost Property
BuiltInFailures..::..MEPFabricationFailures Class See Also Send Feedback
The hanger is out of its host and will be disconnected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FabricationHangerOutOfHost { get; }
Visual Basic
Public Shared ReadOnly Property FabricationHangerOutOfHost As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FabricationHangerOutOfHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPFabricationFailures Class


FabricationHangerSizeNotMatch Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPFabricationFailures..::..FabricationHangerSizeNotMatch Property
BuiltInFailures..::..MEPFabricationFailures Class See Also Send Feedback
The hanger size does not match the size of the host, so it can not be connected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FabricationHangerSizeNotMatch { get; }
Visual Basic
Public Shared ReadOnly Property FabricationHangerSizeNotMatch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FabricationHangerSizeNotMatch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPFabricationFailures Class


FabricationOutOfSizeCondition Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPFabricationFailures..::..FabricationOutOfSizeCondition Property
BuiltInFailures..::..MEPFabricationFailures Class See Also Send Feedback
The fabrication part size is not within the correct size range for the service button condition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FabricationOutOfSizeCondition { get; }
Visual Basic
Public Shared ReadOnly Property FabricationOutOfSizeCondition As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FabricationOutOfSizeCondition {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPFabricationFailures Class


FabricationOverSizedCheck Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPFabricationFailures..::..FabricationOverSizedCheck Property
BuiltInFailures..::..MEPFabricationFailures Class See Also Send Feedback
Fabrication part is too large to fit on the sheet metal. Replace the part with multiple smaller parts, or notify the CAM operator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FabricationOverSizedCheck { get; }
Visual Basic
Public Shared ReadOnly Property FabricationOverSizedCheck As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FabricationOverSizedCheck {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPFabricationFailures Class


FabricationPartCannotBeMirrored Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPFabricationFailures..::..FabricationPartCannotBeMirrored Property
BuiltInFailures..::..MEPFabricationFailures Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FabricationPartCannotBeMirrored { get; }
Visual Basic
Public Shared ReadOnly Property FabricationPartCannotBeMirrored As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FabricationPartCannotBeMirrored {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPFabricationFailures Class


FabricationPartCannotChangeServiceSizeWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPFabricationFailures..::..FabricationPartCannotChangeServiceSizeWarning Property
BuiltInFailures..::..MEPFabricationFailures Class See Also Send Feedback
The selected fitting(s) cannot successfully change service or change size. You must disconnect the connections on the fitting(s) and try again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FabricationPartCannotChangeServiceSizeWarning { get; }
Visual Basic
Public Shared ReadOnly Property FabricationPartCannotChangeServiceSizeWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FabricationPartCannotChangeServiceSizeWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPFabricationFailures Class


FabricationPartCannotChangeTypeBadDimError Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPFabricationFailures..::..FabricationPartCannotChangeTypeBadDimError Property
BuiltInFailures..::..MEPFabricationFailures Class See Also Send Feedback
The selected fitting(s) cannot successfully change the type. The newly selected fabrication part may have badly configured dimensions or be constrained due to connected fitting(s). You may try to disconnect the connections on the fitting(s) and try again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FabricationPartCannotChangeTypeBadDimError { get; }
Visual Basic
Public Shared ReadOnly Property FabricationPartCannotChangeTypeBadDimError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FabricationPartCannotChangeTypeBadDimError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPFabricationFailures Class


FabricationPartCannotChangeTypeBadDimUnConnError Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPFabricationFailures..::..FabricationPartCannotChangeTypeBadDimUnConnError Property
BuiltInFailures..::..MEPFabricationFailures Class See Also Send Feedback
The selected fitting(s) cannot successfully change the type. The newly selected fabrication part may have badly configured dimensions, resulting in bad geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FabricationPartCannotChangeTypeBadDimUnConnError { get; }
Visual Basic
Public Shared ReadOnly Property FabricationPartCannotChangeTypeBadDimUnConnError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FabricationPartCannotChangeTypeBadDimUnConnError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPFabricationFailures Class


FabricationPartCannotChangeTypeError Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPFabricationFailures..::..FabricationPartCannotChangeTypeError Property
BuiltInFailures..::..MEPFabricationFailures Class See Also Send Feedback
The selected fitting(s) cannot successfully change the type. You must disconnect the connections on the fitting(s) and try again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FabricationPartCannotChangeTypeError { get; }
Visual Basic
Public Shared ReadOnly Property FabricationPartCannotChangeTypeError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FabricationPartCannotChangeTypeError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPFabricationFailures Class


FabricationPartCannotChangeTypeIncompatError Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPFabricationFailures..::..FabricationPartCannotChangeTypeIncompatError Property
BuiltInFailures..::..MEPFabricationFailures Class See Also Send Feedback
The selected fitting(s) cannot successfully change the type. The newly selected fabrication part type either has no material or has badly configured dimensions, resulting in bad geometry. You may try to disconnect the connections on the fitting(s) and try again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FabricationPartCannotChangeTypeIncompatError { get; }
Visual Basic
Public Shared ReadOnly Property FabricationPartCannotChangeTypeIncompatError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FabricationPartCannotChangeTypeIncompatError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPFabricationFailures Class


FabricationPartCannotChangeTypeMisalignedUnConnError Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPFabricationFailures..::..FabricationPartCannotChangeTypeMisalignedUnConnError Property
BuiltInFailures..::..MEPFabricationFailures Class See Also Send Feedback
The selected fitting(s) cannot successfully change the type. The newly selected fabrication part type has a problem with the angle dimension of the current fitting(s), resulting in bad geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FabricationPartCannotChangeTypeMisalignedUnConnError { get; }
Visual Basic
Public Shared ReadOnly Property FabricationPartCannotChangeTypeMisalignedUnConnError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FabricationPartCannotChangeTypeMisalignedUnConnError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPFabricationFailures Class


FabricationPartCannotChangeTypeUnConnError Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPFabricationFailures..::..FabricationPartCannotChangeTypeUnConnError Property
BuiltInFailures..::..MEPFabricationFailures Class See Also Send Feedback
The selected fitting(s) cannot successfully change the type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FabricationPartCannotChangeTypeUnConnError { get; }
Visual Basic
Public Shared ReadOnly Property FabricationPartCannotChangeTypeUnConnError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FabricationPartCannotChangeTypeUnConnError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPFabricationFailures Class


FabricationPartCannotChangeTypeWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPFabricationFailures..::..FabricationPartCannotChangeTypeWarning Property
BuiltInFailures..::..MEPFabricationFailures Class See Also Send Feedback
The selected fitting(s) cannot maintain connections to existing fabrication parts due to size, direction or angle differences. You must manually reconnect the open connections.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FabricationPartCannotChangeTypeWarning { get; }
Visual Basic
Public Shared ReadOnly Property FabricationPartCannotChangeTypeWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FabricationPartCannotChangeTypeWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPFabricationFailures Class


FabricationPartExceededAngleFlexToleranceWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPFabricationFailures..::..FabricationPartExceededAngleFlexToleranceWarning Property
BuiltInFailures..::..MEPFabricationFailures Class See Also Send Feedback
The angle flex is greater than the maximum angle flex tolerance defined by the fabrication part. Connections with this part may not be properly aligned and may appear to be skewed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FabricationPartExceededAngleFlexToleranceWarning { get; }
Visual Basic
Public Shared ReadOnly Property FabricationPartExceededAngleFlexToleranceWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FabricationPartExceededAngleFlexToleranceWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPFabricationFailures Class


FabricationPartExcludedPartWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPFabricationFailures..::..FabricationPartExcludedPartWarning Property
BuiltInFailures..::..MEPFabricationFailures Class See Also Send Feedback
There were fabrication parts needed to the make the connection that were excluded from the fabrication service causing the connection to fail. You may try to inlcude these fitting(s) and try again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FabricationPartExcludedPartWarning { get; }
Visual Basic
Public Shared ReadOnly Property FabricationPartExcludedPartWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FabricationPartExcludedPartWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPFabricationFailures Class


FabricationPartFitFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPFabricationFailures..::..FabricationPartFitFailure Property
BuiltInFailures..::..MEPFabricationFailures Class See Also Send Feedback
Fabrication Part Fitting Failed to Fit

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FabricationPartFitFailure { get; }
Visual Basic
Public Shared ReadOnly Property FabricationPartFitFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FabricationPartFitFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPFabricationFailures Class


FabricationPartFitFailWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPFabricationFailures..::..FabricationPartFitFailWarning Property
BuiltInFailures..::..MEPFabricationFailures Class See Also Send Feedback
Fabrication Part Fitting Failed to Fit

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FabricationPartFitFailWarning { get; }
Visual Basic
Public Shared ReadOnly Property FabricationPartFitFailWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FabricationPartFitFailWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPFabricationFailures Class


FabricationPartInvalidConnection Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPFabricationFailures..::..FabricationPartInvalidConnection Property
BuiltInFailures..::..MEPFabricationFailures Class See Also Send Feedback
Fabrication Part connection invalid and could not be automatically coupled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FabricationPartInvalidConnection { get; }
Visual Basic
Public Shared ReadOnly Property FabricationPartInvalidConnection As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FabricationPartInvalidConnection {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPFabricationFailures Class


FabricationPartInvalidSpecification Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPFabricationFailures..::..FabricationPartInvalidSpecification Property
BuiltInFailures..::..MEPFabricationFailures Class See Also Send Feedback
The part specification is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FabricationPartInvalidSpecification { get; }
Visual Basic
Public Shared ReadOnly Property FabricationPartInvalidSpecification As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FabricationPartInvalidSpecification {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPFabricationFailures Class


FabricationPartNoPartTypeFound Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPFabricationFailures..::..FabricationPartNoPartTypeFound Property
BuiltInFailures..::..MEPFabricationFailures Class See Also Send Feedback
There are no fabrication part types found for the current Configuration and Service. Please select settings and reload the service to create the fabrication part types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FabricationPartNoPartTypeFound { get; }
Visual Basic
Public Shared ReadOnly Property FabricationPartNoPartTypeFound As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FabricationPartNoPartTypeFound {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPFabricationFailures Class


FabricationPartOptimizeInvalidConnection Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPFabricationFailures..::..FabricationPartOptimizeInvalidConnection Property
BuiltInFailures..::..MEPFabricationFailures Class See Also Send Feedback
No available couplings to connect standard lengths for this instance of straight.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FabricationPartOptimizeInvalidConnection { get; }
Visual Basic
Public Shared ReadOnly Property FabricationPartOptimizeInvalidConnection As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FabricationPartOptimizeInvalidConnection {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPFabricationFailures Class


FabricationRodDetachFromHangerError Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPFabricationFailures..::..FabricationRodDetachFromHangerError Property
BuiltInFailures..::..MEPFabricationFailures Class See Also Send Feedback
The rod need to be detached from hanger.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FabricationRodDetachFromHangerError { get; }
Visual Basic
Public Shared ReadOnly Property FabricationRodDetachFromHangerError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FabricationRodDetachFromHangerError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPFabricationFailures Class


FabricationRodsConnectionChangedWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPFabricationFailures..::..FabricationRodsConnectionChangedWarning Property
BuiltInFailures..::..MEPFabricationFailures Class See Also Send Feedback
The structural component that the hanger is attached to has changed to a different element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FabricationRodsConnectionChangedWarning { get; }
Visual Basic
Public Shared ReadOnly Property FabricationRodsConnectionChangedWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FabricationRodsConnectionChangedWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPFabricationFailures Class


FabricationRodsDisconnectedError Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPFabricationFailures..::..FabricationRodsDisconnectedError Property
BuiltInFailures..::..MEPFabricationFailures Class See Also Send Feedback
The hanger rod was disconnected because there is no structural component above.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FabricationRodsDisconnectedError { get; }
Visual Basic
Public Shared ReadOnly Property FabricationRodsDisconnectedError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FabricationRodsDisconnectedError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPFabricationFailures Class


FabricationRodsDisconnectedWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPFabricationFailures..::..FabricationRodsDisconnectedWarning Property
BuiltInFailures..::..MEPFabricationFailures Class See Also Send Feedback
The hanger rod was disconnected because there is no structural component above.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FabricationRodsDisconnectedWarning { get; }
Visual Basic
Public Shared ReadOnly Property FabricationRodsDisconnectedWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FabricationRodsDisconnectedWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPFabricationFailures Class


FabricationServiceMismatch Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPFabricationFailures..::..FabricationServiceMismatch Property
BuiltInFailures..::..MEPFabricationFailures Class See Also Send Feedback
Attempting to connect fabrication parts from different services.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FabricationServiceMismatch { get; }
Visual Basic
Public Shared ReadOnly Property FabricationServiceMismatch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FabricationServiceMismatch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPFabricationFailures Class


FabricationStraigtLengthOversized Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPFabricationFailures..::..FabricationStraigtLengthOversized Property
BuiltInFailures..::..MEPFabricationFailures Class See Also Send Feedback
Fabrication straight exceeds the standard length. Use the Optimize Length command to adjust the length.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FabricationStraigtLengthOversized { get; }
Visual Basic
Public Shared ReadOnly Property FabricationStraigtLengthOversized As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FabricationStraigtLengthOversized {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPFabricationFailures Class


FixedFabricationPartNotChangeLength Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPFabricationFailures..::..FixedFabricationPartNotChangeLength Property
BuiltInFailures..::..MEPFabricationFailures Class See Also Send Feedback
Failed to change length of fixed part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FixedFabricationPartNotChangeLength { get; }
Visual Basic
Public Shared ReadOnly Property FixedFabricationPartNotChangeLength As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FixedFabricationPartNotChangeLength {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPFabricationFailures Class


GroupedFabricationPartNotReposition Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPFabricationFailures..::..GroupedFabricationPartNotReposition Property
BuiltInFailures..::..MEPFabricationFailures Class See Also Send Feedback
Failed to reposition part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId GroupedFabricationPartNotReposition { get; }
Visual Basic
Public Shared ReadOnly Property GroupedFabricationPartNotReposition As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GroupedFabricationPartNotReposition {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPFabricationFailures Class


HangerWidthOutOfRange Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPFabricationFailures..::..HangerWidthOutOfRange Property
BuiltInFailures..::..MEPFabricationFailures Class See Also Send Feedback
The hanger width is too large to show.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId HangerWidthOutOfRange { get; }
Visual Basic
Public Shared ReadOnly Property HangerWidthOutOfRange As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HangerWidthOutOfRange {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPFabricationFailures Class


InvalidConnectionsHaveBeenDisconnected Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPFabricationFailures..::..InvalidConnectionsHaveBeenDisconnected Property
BuiltInFailures..::..MEPFabricationFailures Class See Also Send Feedback
Invalid connections have been disconnected. Please reconnect them manually or use different fittings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidConnectionsHaveBeenDisconnected { get; }
Visual Basic
Public Shared ReadOnly Property InvalidConnectionsHaveBeenDisconnected As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidConnectionsHaveBeenDisconnected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPFabricationFailures Class


InvalidSelectionThereCannotBeOpenConnectors Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPFabricationFailures..::..InvalidSelectionThereCannotBeOpenConnectors Property
BuiltInFailures..::..MEPFabricationFailures Class See Also Send Feedback
Invalid selection there cannot be any open connectors for the design to fabrication part tool.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidSelectionThereCannotBeOpenConnectors { get; }
Visual Basic
Public Shared ReadOnly Property InvalidSelectionThereCannotBeOpenConnectors As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidSelectionThereCannotBeOpenConnectors {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPFabricationFailures Class


PinnedFabricationPartNotChangeExtension Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPFabricationFailures..::..PinnedFabricationPartNotChangeExtension Property
BuiltInFailures..::..MEPFabricationFailures Class See Also Send Feedback
Failed to change extension of part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId PinnedFabricationPartNotChangeExtension { get; }
Visual Basic
Public Shared ReadOnly Property PinnedFabricationPartNotChangeExtension As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PinnedFabricationPartNotChangeExtension {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPFabricationFailures Class


PinnedFabricationPartNotReposition Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPFabricationFailures..::..PinnedFabricationPartNotReposition Property
BuiltInFailures..::..MEPFabricationFailures Class See Also Send Feedback
Failed to reposition part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId PinnedFabricationPartNotReposition { get; }
Visual Basic
Public Shared ReadOnly Property PinnedFabricationPartNotReposition As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PinnedFabricationPartNotReposition {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPFabricationFailures Class


PlaceCutinFittingFailed Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPFabricationFailures..::..PlaceCutinFittingFailed Property
BuiltInFailures..::..MEPFabricationFailures Class See Also Send Feedback
Failed to insert part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId PlaceCutinFittingFailed { get; }
Visual Basic
Public Shared ReadOnly Property PlaceCutinFittingFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PlaceCutinFittingFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPFabricationFailures Class


SizeNotAvailableInFabricationService Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPFabricationFailures..::..SizeNotAvailableInFabricationService Property
BuiltInFailures..::..MEPFabricationFailures Class See Also Send Feedback
Sizes:%1!s! in system %2!s! are not available in fabrication service:%3!s!, All available sizes are:\n%4!s!.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SizeNotAvailableInFabricationService { get; }
Visual Basic
Public Shared ReadOnly Property SizeNotAvailableInFabricationService As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SizeNotAvailableInFabricationService {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPFabricationFailures Class


UneditableFabricationPartNotReposition Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPFabricationFailures..::..UneditableFabricationPartNotReposition Property
BuiltInFailures..::..MEPFabricationFailures Class See Also Send Feedback
Failed to reposition part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UneditableFabricationPartNotReposition { get; }
Visual Basic
Public Shared ReadOnly Property UneditableFabricationPartNotReposition As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UneditableFabricationPartNotReposition {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPFabricationFailures Class


BuiltInFailures.MEPSupportFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..MEPSupportFailures Members
BuiltInFailures..::..MEPSupportFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..MEPSupportFailures type exposes the following members.

Properties

Name | Description
CannotMatchInstanceSizeToHostError | The instance of [Symbol] cannot be re-sized to match the host.
InstanceOutOfHostError | The instance of [Symbol] lost its host and will be deleted.
InstanceProfileNotMatchWithHostError | The [Symbol]'s profile does not match the host. Instances of [Symbol] will be deleted.
TypeSizeNotMatchWithHostError | The [Symbol] does not match the size of the host.

See Also

BuiltInFailures..::..MEPSupportFailures Class


CannotMatchInstanceSizeToHostError Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPSupportFailures..::..CannotMatchInstanceSizeToHostError Property
BuiltInFailures..::..MEPSupportFailures Class See Also Send Feedback
The instance of [Symbol] cannot be re-sized to match the host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotMatchInstanceSizeToHostError { get; }
Visual Basic
Public Shared ReadOnly Property CannotMatchInstanceSizeToHostError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMatchInstanceSizeToHostError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPSupportFailures Class


InstanceProfileNotMatchWithHostError Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPSupportFailures..::..InstanceProfileNotMatchWithHostError Property
BuiltInFailures..::..MEPSupportFailures Class See Also Send Feedback
The [Symbol]'s profile does not match the host. Instances of [Symbol] will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InstanceProfileNotMatchWithHostError { get; }
Visual Basic
Public Shared ReadOnly Property InstanceProfileNotMatchWithHostError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InstanceProfileNotMatchWithHostError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPSupportFailures Class


TypeSizeNotMatchWithHostError Property

[image]

Revit 2024 API
BuiltInFailures..::..MEPSupportFailures..::..TypeSizeNotMatchWithHostError Property
BuiltInFailures..::..MEPSupportFailures Class See Also Send Feedback
The [Symbol] does not match the size of the host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId TypeSizeNotMatchWithHostError { get; }
Visual Basic
Public Shared ReadOnly Property TypeSizeNotMatchWithHostError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TypeSizeNotMatchWithHostError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MEPSupportFailures Class


BuiltInFailures.MirrorFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..MirrorFailures Members
BuiltInFailures..::..MirrorFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..MirrorFailures type exposes the following members.

Properties

Name | Description
BadMirror | Can't mirror element into this position.

See Also

BuiltInFailures..::..MirrorFailures Class


BuiltInFailures.MirrorFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..MirrorFailures Properties
BuiltInFailures..::..MirrorFailures Class See Also Send Feedback

The BuiltInFailures..::..MirrorFailures type exposes the following members.

Properties

Name | Description
BadMirror | Can't mirror element into this position.

See Also

BuiltInFailures..::..MirrorFailures Class


BadMirror Property

[image]

Revit 2024 API
BuiltInFailures..::..MirrorFailures..::..BadMirror Property
BuiltInFailures..::..MirrorFailures Class See Also Send Feedback
Can't mirror element into this position.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId BadMirror { get; }
Visual Basic
Public Shared ReadOnly Property BadMirror As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BadMirror {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MirrorFailures Class


BuiltInFailures.MultiReferenceAnnotationFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..MultiReferenceAnnotationFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about MultiReferenceAnnotations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class MultiReferenceAnnotationFailures
Visual Basic
Public NotInheritable Class MultiReferenceAnnotationFailures
Visual C++
public ref class MultiReferenceAnnotationFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..MultiReferenceAnnotationFailures

See Also

BuiltInFailures..::..MultiReferenceAnnotationFailures Members


BuiltInFailures.MultiReferenceAnnotationFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..MultiReferenceAnnotationFailures Properties
BuiltInFailures..::..MultiReferenceAnnotationFailures Class See Also Send Feedback

The BuiltInFailures..::..MultiReferenceAnnotationFailures type exposes the following members.

Properties

Name | Description
ElementCategoryChangeInvalidatesMultiReferenceAnnotation | Elements have changed category. Multi-rebar annotations for these elements are now of the wrong category and will be deleted.
MultiReferenceAnnotationReferenceCategoryForcesDeletion | Changing the reference category will cause instances of this annotation type to be deleted, because they no longer match their references.

See Also

BuiltInFailures..::..MultiReferenceAnnotationFailures Class


ElementCategoryChangeInvalidatesMultiReferenceAnnotation Property

[image]

Revit 2024 API
BuiltInFailures..::..MultiReferenceAnnotationFailures..::..ElementCategoryChangeInvalidatesMultiReferenceAnnotation Property
BuiltInFailures..::..MultiReferenceAnnotationFailures Class See Also Send Feedback
Elements have changed category. Multi-rebar annotations for these elements are now of the wrong category and will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ElementCategoryChangeInvalidatesMultiReferenceAnnotation { get; }
Visual Basic
Public Shared ReadOnly Property ElementCategoryChangeInvalidatesMultiReferenceAnnotation As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementCategoryChangeInvalidatesMultiReferenceAnnotation {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MultiReferenceAnnotationFailures Class


BuiltInFailures.NumberingFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..NumberingFailures Members
BuiltInFailures..::..NumberingFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..NumberingFailures type exposes the following members.

Properties

Name | Description
SampleNumberingError | Replace this with the first real one

See Also

BuiltInFailures..::..NumberingFailures Class


SampleNumberingError Property

[image]

Revit 2024 API
BuiltInFailures..::..NumberingFailures..::..SampleNumberingError Property
BuiltInFailures..::..NumberingFailures Class See Also Send Feedback
Replace this with the first real one

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SampleNumberingError { get; }
Visual Basic
Public Shared ReadOnly Property SampleNumberingError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SampleNumberingError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..NumberingFailures Class


BuiltInFailures.OffsetFacesCellLegacyFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..OffsetFacesCellLegacyFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures related to offset faces operations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class OffsetFacesCellLegacyFailures
Visual Basic
Public NotInheritable Class OffsetFacesCellLegacyFailures
Visual C++
public ref class OffsetFacesCellLegacyFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..OffsetFacesCellLegacyFailures

See Also

BuiltInFailures..::..OffsetFacesCellLegacyFailures Members


BuiltInFailures.OffsetFacesCellLegacyFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..OffsetFacesCellLegacyFailures Members
BuiltInFailures..::..OffsetFacesCellLegacyFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..OffsetFacesCellLegacyFailures type exposes the following members.

Properties

Name | Description
OffsetFaceFailed |

See Also

BuiltInFailures..::..OffsetFacesCellLegacyFailures Class


BuiltInFailures.OffsetFacesCellLegacyFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..OffsetFacesCellLegacyFailures Properties
BuiltInFailures..::..OffsetFacesCellLegacyFailures Class See Also Send Feedback

The BuiltInFailures..::..OffsetFacesCellLegacyFailures type exposes the following members.

Properties

Name | Description
OffsetFaceFailed |

See Also

BuiltInFailures..::..OffsetFacesCellLegacyFailures Class


OffsetFaceFailed Property

[image]

Revit 2024 API
BuiltInFailures..::..OffsetFacesCellLegacyFailures..::..OffsetFaceFailed Property
BuiltInFailures..::..OffsetFacesCellLegacyFailures Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId OffsetFaceFailed { get; }
Visual Basic
Public Shared ReadOnly Property OffsetFaceFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OffsetFaceFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OffsetFacesCellLegacyFailures Class


BuiltInFailures.OpeningFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..OpeningFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Opening.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class OpeningFailures
Visual Basic
Public NotInheritable Class OpeningFailures
Visual C++
public ref class OpeningFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..OpeningFailures

See Also

BuiltInFailures..::..OpeningFailures Members


BuiltInFailures.OpeningFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..OpeningFailures Members
BuiltInFailures..::..OpeningFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..OpeningFailures type exposes the following members.

Properties

Name | Description
HostForCutHasNoGeometry | Host can't be cut because it has no geometry.
HostForCutHasNoGeometryWarn | Host can't be cut because it has no geometry.
InvalidComplexCut | The family [Family Name] was containing one or more invalid cuts, which have been removed (most likely it was cutting a curtain wall). Please examine the family and make changes as needed.\r\nHint 1: If you are trying to cut a Curtain Wall, you may be able to achieve the desired result by editing the Elevation Profile or the curtain panel.\r\n Hint 2: If you can't see the family, you can still select it from the Project Browser.\r\nHint 3: This warning will disappear after you edit and then finish the family.
ModelAlreadyCheckedOutByUser | The Cloud WorkSharing Model is already checked out by the current user.
OpeningCutAll | Opening completely removes its host
OpeningDoesnotCutHost | Opening does not cut its host.
OpeningDoesnotCutHostDelete | Opening does not cut its host.
OpeningNegativeHeight | The top of the Opening is lower than the bottom of the Opening or coincident with it.
OpeningPartiallyCutsHost | Opening partially cuts its host.
OpeningRectDoesnotCutHost | Rectangular opening doesn't cut its host.
OpeningRemovesHost | Opening completely removes its host.
OpenStringerConflictNosing | Open stringer can't be created for selected nosing profile. Set nosing profile to default to get open stringers created.
PropertyNotClosed | Property lines do not form a closed loop. Area will not be computed.

See Also

BuiltInFailures..::..OpeningFailures Class


BuiltInFailures.OpeningFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..OpeningFailures Properties
BuiltInFailures..::..OpeningFailures Class See Also Send Feedback

The BuiltInFailures..::..OpeningFailures type exposes the following members.

Properties

Name | Description
HostForCutHasNoGeometry | Host can't be cut because it has no geometry.
HostForCutHasNoGeometryWarn | Host can't be cut because it has no geometry.
InvalidComplexCut | The family [Family Name] was containing one or more invalid cuts, which have been removed (most likely it was cutting a curtain wall). Please examine the family and make changes as needed.\r\nHint 1: If you are trying to cut a Curtain Wall, you may be able to achieve the desired result by editing the Elevation Profile or the curtain panel.\r\n Hint 2: If you can't see the family, you can still select it from the Project Browser.\r\nHint 3: This warning will disappear after you edit and then finish the family.
ModelAlreadyCheckedOutByUser | The Cloud WorkSharing Model is already checked out by the current user.
OpeningCutAll | Opening completely removes its host
OpeningDoesnotCutHost | Opening does not cut its host.
OpeningDoesnotCutHostDelete | Opening does not cut its host.
OpeningNegativeHeight | The top of the Opening is lower than the bottom of the Opening or coincident with it.
OpeningPartiallyCutsHost | Opening partially cuts its host.
OpeningRectDoesnotCutHost | Rectangular opening doesn't cut its host.
OpeningRemovesHost | Opening completely removes its host.
OpenStringerConflictNosing | Open stringer can't be created for selected nosing profile. Set nosing profile to default to get open stringers created.
PropertyNotClosed | Property lines do not form a closed loop. Area will not be computed.

See Also

BuiltInFailures..::..OpeningFailures Class


HostForCutHasNoGeometry Property

[image]

Revit 2024 API
BuiltInFailures..::..OpeningFailures..::..HostForCutHasNoGeometry Property
BuiltInFailures..::..OpeningFailures Class See Also Send Feedback
Host can't be cut because it has no geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId HostForCutHasNoGeometry { get; }
Visual Basic
Public Shared ReadOnly Property HostForCutHasNoGeometry As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HostForCutHasNoGeometry {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OpeningFailures Class


HostForCutHasNoGeometryWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..OpeningFailures..::..HostForCutHasNoGeometryWarn Property
BuiltInFailures..::..OpeningFailures Class See Also Send Feedback
Host can't be cut because it has no geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId HostForCutHasNoGeometryWarn { get; }
Visual Basic
Public Shared ReadOnly Property HostForCutHasNoGeometryWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HostForCutHasNoGeometryWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OpeningFailures Class


OpeningDoesnotCutHost Property

[image]

Revit 2024 API
BuiltInFailures..::..OpeningFailures..::..OpeningDoesnotCutHost Property
BuiltInFailures..::..OpeningFailures Class See Also Send Feedback
Opening does not cut its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId OpeningDoesnotCutHost { get; }
Visual Basic
Public Shared ReadOnly Property OpeningDoesnotCutHost As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OpeningDoesnotCutHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OpeningFailures Class


OpeningDoesnotCutHostDelete Property

[image]

Revit 2024 API
BuiltInFailures..::..OpeningFailures..::..OpeningDoesnotCutHostDelete Property
BuiltInFailures..::..OpeningFailures Class See Also Send Feedback
Opening does not cut its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId OpeningDoesnotCutHostDelete { get; }
Visual Basic
Public Shared ReadOnly Property OpeningDoesnotCutHostDelete As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OpeningDoesnotCutHostDelete {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OpeningFailures Class


OpeningNegativeHeight Property

[image]

Revit 2024 API
BuiltInFailures..::..OpeningFailures..::..OpeningNegativeHeight Property
BuiltInFailures..::..OpeningFailures Class See Also Send Feedback
The top of the Opening is lower than the bottom of the Opening or coincident with it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId OpeningNegativeHeight { get; }
Visual Basic
Public Shared ReadOnly Property OpeningNegativeHeight As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OpeningNegativeHeight {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OpeningFailures Class


OpeningPartiallyCutsHost Property

[image]

Revit 2024 API
BuiltInFailures..::..OpeningFailures..::..OpeningPartiallyCutsHost Property
BuiltInFailures..::..OpeningFailures Class See Also Send Feedback
Opening partially cuts its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId OpeningPartiallyCutsHost { get; }
Visual Basic
Public Shared ReadOnly Property OpeningPartiallyCutsHost As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OpeningPartiallyCutsHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OpeningFailures Class


OpeningRectDoesnotCutHost Property

[image]

Revit 2024 API
BuiltInFailures..::..OpeningFailures..::..OpeningRectDoesnotCutHost Property
BuiltInFailures..::..OpeningFailures Class See Also Send Feedback
Rectangular opening doesn't cut its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId OpeningRectDoesnotCutHost { get; }
Visual Basic
Public Shared ReadOnly Property OpeningRectDoesnotCutHost As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OpeningRectDoesnotCutHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OpeningFailures Class


OpeningRemovesHost Property

[image]

Revit 2024 API
BuiltInFailures..::..OpeningFailures..::..OpeningRemovesHost Property
BuiltInFailures..::..OpeningFailures Class See Also Send Feedback
Opening completely removes its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId OpeningRemovesHost { get; }
Visual Basic
Public Shared ReadOnly Property OpeningRemovesHost As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OpeningRemovesHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OpeningFailures Class


OpenStringerConflictNosing Property

[image]

Revit 2024 API
BuiltInFailures..::..OpeningFailures..::..OpenStringerConflictNosing Property
BuiltInFailures..::..OpeningFailures Class See Also Send Feedback
Open stringer can't be created for selected nosing profile. Set nosing profile to default to get open stringers created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId OpenStringerConflictNosing { get; }
Visual Basic
Public Shared ReadOnly Property OpenStringerConflictNosing As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OpenStringerConflictNosing {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OpeningFailures Class


PropertyNotClosed Property

[image]

Revit 2024 API
BuiltInFailures..::..OpeningFailures..::..PropertyNotClosed Property
BuiltInFailures..::..OpeningFailures Class See Also Send Feedback
Property lines do not form a closed loop. Area will not be computed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId PropertyNotClosed { get; }
Visual Basic
Public Shared ReadOnly Property PropertyNotClosed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PropertyNotClosed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OpeningFailures Class


BuiltInFailures.OverlapFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..OverlapFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures detected by overlap check.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class OverlapFailures
Visual Basic
Public NotInheritable Class OverlapFailures
Visual C++
public ref class OverlapFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..OverlapFailures

See Also

BuiltInFailures..::..OverlapFailures Members


BuiltInFailures.OverlapFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..OverlapFailures Members
BuiltInFailures..::..OverlapFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..OverlapFailures type exposes the following members.

Properties

Name | Description
AreaBoundaryLinesOverlap | Highlighted area boundary lines overlap. Color fills, area tags, and areas may not behave correctly.
CurvesOverlap | Highlighted lines overlap. Lines may not form closed loops.
DivisionSketchOverlap | Curves in the sketch of the Division overlap.
DuplicateFabricSheet | There are identical Fabric sheets in the same place. This will result in double counting in schedules.
DuplicateInstances | There are identical instances in the same place. This will result in double counting in schedules.
DuplicatePoints | There are identical points in the same place. Lines created from points may not work as expected.
DuplicateRebar | There are identical rebar in the same place. This will result in double counting in schedules.
ELASeparationLinesOverlap | Highlighted area based load boundary lines overlap. One of them may be ignored when Revit finds load area boundaries. Delete one of the lines.
FloorsOverlap | Highlighted floors overlap.
LevelsOverlap | Highlighted levels overlap.
OverlappingElementsTest | There are overlapping structural framing elements of the same type in the project found by Dynamic Update.
RoomSeparationLinesOverlap | Highlighted room separation lines overlap. One of them may be ignored when Revit finds room boundaries. Delete one of the lines.
SpaceSeparationLinesOverlap | Highlighted space separation lines overlap. One of them may be ignored when Revit finds space boundaries. Delete one of the lines.
SubregionOverlap | Highlighted sub-division overlap.
ToposolidFloorOverlap | Highlighted toposolid and floor overlap.
ToposolidOverlap | Highlighted toposolid overlap.
ToposolidSubregionOverlap | Highlighted toposolid and sub-division overlap.
WallAreaBoundaryOverlap | Wall and area boundary line overlap. Color fills, area tags and areas may not behave correctly.
WallRoomSeparationOverlap | A wall and a room separation line overlap. One of them may be ignored when Revit finds room boundaries. Shorten or delete the room separation line to remove the overlap.
WallsOverlap | Highlighted walls overlap. One of them may be ignored when Revit finds room boundaries. Use Cut Geometry to embed one wall within the other.
WallSpaceSeparationOverlap | A wall and a space separation line overlap. One of them may be ignored when Revit finds space boundaries. Shorten or delete the space separation line to remove the overlap.

See Also

BuiltInFailures..::..OverlapFailures Class


BuiltInFailures.OverlapFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..OverlapFailures Properties
BuiltInFailures..::..OverlapFailures Class See Also Send Feedback

The BuiltInFailures..::..OverlapFailures type exposes the following members.

Properties

Name | Description
AreaBoundaryLinesOverlap | Highlighted area boundary lines overlap. Color fills, area tags, and areas may not behave correctly.
CurvesOverlap | Highlighted lines overlap. Lines may not form closed loops.
DivisionSketchOverlap | Curves in the sketch of the Division overlap.
DuplicateFabricSheet | There are identical Fabric sheets in the same place. This will result in double counting in schedules.
DuplicateInstances | There are identical instances in the same place. This will result in double counting in schedules.
DuplicatePoints | There are identical points in the same place. Lines created from points may not work as expected.
DuplicateRebar | There are identical rebar in the same place. This will result in double counting in schedules.
ELASeparationLinesOverlap | Highlighted area based load boundary lines overlap. One of them may be ignored when Revit finds load area boundaries. Delete one of the lines.
FloorsOverlap | Highlighted floors overlap.
LevelsOverlap | Highlighted levels overlap.
OverlappingElementsTest | There are overlapping structural framing elements of the same type in the project found by Dynamic Update.
RoomSeparationLinesOverlap | Highlighted room separation lines overlap. One of them may be ignored when Revit finds room boundaries. Delete one of the lines.
SpaceSeparationLinesOverlap | Highlighted space separation lines overlap. One of them may be ignored when Revit finds space boundaries. Delete one of the lines.
SubregionOverlap | Highlighted sub-division overlap.
ToposolidFloorOverlap | Highlighted toposolid and floor overlap.
ToposolidOverlap | Highlighted toposolid overlap.
ToposolidSubregionOverlap | Highlighted toposolid and sub-division overlap.
WallAreaBoundaryOverlap | Wall and area boundary line overlap. Color fills, area tags and areas may not behave correctly.
WallRoomSeparationOverlap | A wall and a room separation line overlap. One of them may be ignored when Revit finds room boundaries. Shorten or delete the room separation line to remove the overlap.
WallsOverlap | Highlighted walls overlap. One of them may be ignored when Revit finds room boundaries. Use Cut Geometry to embed one wall within the other.
WallSpaceSeparationOverlap | A wall and a space separation line overlap. One of them may be ignored when Revit finds space boundaries. Shorten or delete the space separation line to remove the overlap.

See Also

BuiltInFailures..::..OverlapFailures Class


AreaBoundaryLinesOverlap Property

[image]

Revit 2024 API
BuiltInFailures..::..OverlapFailures..::..AreaBoundaryLinesOverlap Property
BuiltInFailures..::..OverlapFailures Class See Also Send Feedback
Highlighted area boundary lines overlap. Color fills, area tags, and areas may not behave correctly.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AreaBoundaryLinesOverlap { get; }
Visual Basic
Public Shared ReadOnly Property AreaBoundaryLinesOverlap As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AreaBoundaryLinesOverlap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OverlapFailures Class


CurvesOverlap Property

[image]

Revit 2024 API
BuiltInFailures..::..OverlapFailures..::..CurvesOverlap Property
BuiltInFailures..::..OverlapFailures Class See Also Send Feedback
Highlighted lines overlap. Lines may not form closed loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CurvesOverlap { get; }
Visual Basic
Public Shared ReadOnly Property CurvesOverlap As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CurvesOverlap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OverlapFailures Class


DuplicateFabricSheet Property

[image]

Revit 2024 API
BuiltInFailures..::..OverlapFailures..::..DuplicateFabricSheet Property
BuiltInFailures..::..OverlapFailures Class See Also Send Feedback
There are identical Fabric sheets in the same place. This will result in double counting in schedules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DuplicateFabricSheet { get; }
Visual Basic
Public Shared ReadOnly Property DuplicateFabricSheet As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DuplicateFabricSheet {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OverlapFailures Class


DuplicateInstances Property

[image]

Revit 2024 API
BuiltInFailures..::..OverlapFailures..::..DuplicateInstances Property
BuiltInFailures..::..OverlapFailures Class See Also Send Feedback
There are identical instances in the same place. This will result in double counting in schedules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DuplicateInstances { get; }
Visual Basic
Public Shared ReadOnly Property DuplicateInstances As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DuplicateInstances {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OverlapFailures Class


DuplicateRebar Property

[image]

Revit 2024 API
BuiltInFailures..::..OverlapFailures..::..DuplicateRebar Property
BuiltInFailures..::..OverlapFailures Class See Also Send Feedback
There are identical rebar in the same place. This will result in double counting in schedules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DuplicateRebar { get; }
Visual Basic
Public Shared ReadOnly Property DuplicateRebar As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DuplicateRebar {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OverlapFailures Class


ELASeparationLinesOverlap Property

[image]

Revit 2024 API
BuiltInFailures..::..OverlapFailures..::..ELASeparationLinesOverlap Property
BuiltInFailures..::..OverlapFailures Class See Also Send Feedback
Highlighted area based load boundary lines overlap. One of them may be ignored when Revit finds load area boundaries. Delete one of the lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ELASeparationLinesOverlap { get; }
Visual Basic
Public Shared ReadOnly Property ELASeparationLinesOverlap As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ELASeparationLinesOverlap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OverlapFailures Class


FloorsOverlap Property

[image]

Revit 2024 API
BuiltInFailures..::..OverlapFailures..::..FloorsOverlap Property
BuiltInFailures..::..OverlapFailures Class See Also Send Feedback
Highlighted floors overlap.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FloorsOverlap { get; }
Visual Basic
Public Shared ReadOnly Property FloorsOverlap As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FloorsOverlap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OverlapFailures Class


LevelsOverlap Property

[image]

Revit 2024 API
BuiltInFailures..::..OverlapFailures..::..LevelsOverlap Property
BuiltInFailures..::..OverlapFailures Class See Also Send Feedback
Highlighted levels overlap.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId LevelsOverlap { get; }
Visual Basic
Public Shared ReadOnly Property LevelsOverlap As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LevelsOverlap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OverlapFailures Class


RoomSeparationLinesOverlap Property

[image]

Revit 2024 API
BuiltInFailures..::..OverlapFailures..::..RoomSeparationLinesOverlap Property
BuiltInFailures..::..OverlapFailures Class See Also Send Feedback
Highlighted room separation lines overlap. One of them may be ignored when Revit finds room boundaries. Delete one of the lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RoomSeparationLinesOverlap { get; }
Visual Basic
Public Shared ReadOnly Property RoomSeparationLinesOverlap As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomSeparationLinesOverlap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OverlapFailures Class


SpaceSeparationLinesOverlap Property

[image]

Revit 2024 API
BuiltInFailures..::..OverlapFailures..::..SpaceSeparationLinesOverlap Property
BuiltInFailures..::..OverlapFailures Class See Also Send Feedback
Highlighted space separation lines overlap. One of them may be ignored when Revit finds space boundaries. Delete one of the lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SpaceSeparationLinesOverlap { get; }
Visual Basic
Public Shared ReadOnly Property SpaceSeparationLinesOverlap As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SpaceSeparationLinesOverlap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OverlapFailures Class


SubregionOverlap Property

[image]

Revit 2024 API
BuiltInFailures..::..OverlapFailures..::..SubregionOverlap Property
BuiltInFailures..::..OverlapFailures Class See Also Send Feedback
Highlighted sub-division overlap.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SubregionOverlap { get; }
Visual Basic
Public Shared ReadOnly Property SubregionOverlap As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SubregionOverlap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OverlapFailures Class


ToposolidFloorOverlap Property

[image]

Revit 2024 API
BuiltInFailures..::..OverlapFailures..::..ToposolidFloorOverlap Property
BuiltInFailures..::..OverlapFailures Class See Also Send Feedback
Highlighted toposolid and floor overlap.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ToposolidFloorOverlap { get; }
Visual Basic
Public Shared ReadOnly Property ToposolidFloorOverlap As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ToposolidFloorOverlap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OverlapFailures Class


ToposolidSubregionOverlap Property

[image]

Revit 2024 API
BuiltInFailures..::..OverlapFailures..::..ToposolidSubregionOverlap Property
BuiltInFailures..::..OverlapFailures Class See Also Send Feedback
Highlighted toposolid and sub-division overlap.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ToposolidSubregionOverlap { get; }
Visual Basic
Public Shared ReadOnly Property ToposolidSubregionOverlap As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ToposolidSubregionOverlap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OverlapFailures Class


WallAreaBoundaryOverlap Property

[image]

Revit 2024 API
BuiltInFailures..::..OverlapFailures..::..WallAreaBoundaryOverlap Property
BuiltInFailures..::..OverlapFailures Class See Also Send Feedback
Wall and area boundary line overlap. Color fills, area tags and areas may not behave correctly.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WallAreaBoundaryOverlap { get; }
Visual Basic
Public Shared ReadOnly Property WallAreaBoundaryOverlap As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WallAreaBoundaryOverlap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OverlapFailures Class


WallSpaceSeparationOverlap Property

[image]

Revit 2024 API
BuiltInFailures..::..OverlapFailures..::..WallSpaceSeparationOverlap Property
BuiltInFailures..::..OverlapFailures Class See Also Send Feedback
A wall and a space separation line overlap. One of them may be ignored when Revit finds space boundaries. Shorten or delete the space separation line to remove the overlap.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WallSpaceSeparationOverlap { get; }
Visual Basic
Public Shared ReadOnly Property WallSpaceSeparationOverlap As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WallSpaceSeparationOverlap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OverlapFailures Class


BuiltInFailures.ParameterFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..ParameterFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures related to parameters and parameter operations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class ParameterFailures
Visual Basic
Public NotInheritable Class ParameterFailures
Visual C++
public ref class ParameterFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..ParameterFailures

See Also

BuiltInFailures..::..ParameterFailures Members


BuiltInFailures.ParameterFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..ParameterFailures Members
BuiltInFailures..::..ParameterFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..ParameterFailures type exposes the following members.

Properties

Name | Description
InconsistentSharedParameterDefinitions | The shared parameter '...' cannot be added with name '...' and type '...' because it conflicts with the existing name '...' and type '...'.
UnrecognizedSharedParameterDataType | The shared parameter '...' with name '...' cannot be added because its data type is not recognized.

See Also

BuiltInFailures..::..ParameterFailures Class


BuiltInFailures.ParameterFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..ParameterFailures Properties
BuiltInFailures..::..ParameterFailures Class See Also Send Feedback

The BuiltInFailures..::..ParameterFailures type exposes the following members.

Properties

Name | Description
InconsistentSharedParameterDefinitions | The shared parameter '...' cannot be added with name '...' and type '...' because it conflicts with the existing name '...' and type '...'.
UnrecognizedSharedParameterDataType | The shared parameter '...' with name '...' cannot be added because its data type is not recognized.

See Also

BuiltInFailures..::..ParameterFailures Class


InconsistentSharedParameterDefinitions Property

[image]

Revit 2024 API
BuiltInFailures..::..ParameterFailures..::..InconsistentSharedParameterDefinitions Property
BuiltInFailures..::..ParameterFailures Class See Also Send Feedback
The shared parameter '...' cannot be added with name '...' and type '...' because it conflicts with the existing name '...' and type '...'.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InconsistentSharedParameterDefinitions { get; }
Visual Basic
Public Shared ReadOnly Property InconsistentSharedParameterDefinitions As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InconsistentSharedParameterDefinitions {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ParameterFailures Class


UnrecognizedSharedParameterDataType Property

[image]

Revit 2024 API
BuiltInFailures..::..ParameterFailures..::..UnrecognizedSharedParameterDataType Property
BuiltInFailures..::..ParameterFailures Class See Also Send Feedback
The shared parameter '...' with name '...' cannot be added because its data type is not recognized.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UnrecognizedSharedParameterDataType { get; }
Visual Basic
Public Shared ReadOnly Property UnrecognizedSharedParameterDataType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnrecognizedSharedParameterDataType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ParameterFailures Class


BuiltInFailures.PartMakerMethodForMergePartFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..PartMakerMethodForMergePartFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures related to part merge operations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class PartMakerMethodForMergePartFailures
Visual Basic
Public NotInheritable Class PartMakerMethodForMergePartFailures
Visual C++
public ref class PartMakerMethodForMergePartFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..PartMakerMethodForMergePartFailures

See Also

BuiltInFailures..::..PartMakerMethodForMergePartFailures Members


BuiltInFailures.PartMakerMethodForMergePartFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..PartMakerMethodForMergePartFailures Members
BuiltInFailures..::..PartMakerMethodForMergePartFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..PartMakerMethodForMergePartFailures type exposes the following members.

Properties

Name | Description
MergedPartHasDisConnectedGeometries | A merged part geometry has dis-connected components.
NeedTwoPartsToMerge | Attempt to merge fewer than two parts. There must be at least two. No part will be produced.
PartNotIncludedInMerge | This part is not geometrically coincident with another part of the same material. No merge possible.
PartsCannotBeMerged | This PartMaker refers to parts which cannot be merged.
UnableToIncludePartInMerge | Attempt to merge this Part results in failure of boolean operation. Cannot compute combined geometry.

See Also

BuiltInFailures..::..PartMakerMethodForMergePartFailures Class


BuiltInFailures.PartMakerMethodForMergePartFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..PartMakerMethodForMergePartFailures Properties
BuiltInFailures..::..PartMakerMethodForMergePartFailures Class See Also Send Feedback

The BuiltInFailures..::..PartMakerMethodForMergePartFailures type exposes the following members.

Properties

Name | Description
MergedPartHasDisConnectedGeometries | A merged part geometry has dis-connected components.
NeedTwoPartsToMerge | Attempt to merge fewer than two parts. There must be at least two. No part will be produced.
PartNotIncludedInMerge | This part is not geometrically coincident with another part of the same material. No merge possible.
PartsCannotBeMerged | This PartMaker refers to parts which cannot be merged.
UnableToIncludePartInMerge | Attempt to merge this Part results in failure of boolean operation. Cannot compute combined geometry.

See Also

BuiltInFailures..::..PartMakerMethodForMergePartFailures Class


MergedPartHasDisConnectedGeometries Property

[image]

Revit 2024 API
BuiltInFailures..::..PartMakerMethodForMergePartFailures..::..MergedPartHasDisConnectedGeometries Property
BuiltInFailures..::..PartMakerMethodForMergePartFailures Class See Also Send Feedback
A merged part geometry has dis-connected components.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MergedPartHasDisConnectedGeometries { get; }
Visual Basic
Public Shared ReadOnly Property MergedPartHasDisConnectedGeometries As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MergedPartHasDisConnectedGeometries {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PartMakerMethodForMergePartFailures Class


NeedTwoPartsToMerge Property

[image]

Revit 2024 API
BuiltInFailures..::..PartMakerMethodForMergePartFailures..::..NeedTwoPartsToMerge Property
BuiltInFailures..::..PartMakerMethodForMergePartFailures Class See Also Send Feedback
Attempt to merge fewer than two parts. There must be at least two. No part will be produced.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NeedTwoPartsToMerge { get; }
Visual Basic
Public Shared ReadOnly Property NeedTwoPartsToMerge As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NeedTwoPartsToMerge {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PartMakerMethodForMergePartFailures Class


PartNotIncludedInMerge Property

[image]

Revit 2024 API
BuiltInFailures..::..PartMakerMethodForMergePartFailures..::..PartNotIncludedInMerge Property
BuiltInFailures..::..PartMakerMethodForMergePartFailures Class See Also Send Feedback
This part is not geometrically coincident with another part of the same material. No merge possible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId PartNotIncludedInMerge { get; }
Visual Basic
Public Shared ReadOnly Property PartNotIncludedInMerge As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PartNotIncludedInMerge {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PartMakerMethodForMergePartFailures Class


PartsCannotBeMerged Property

[image]

Revit 2024 API
BuiltInFailures..::..PartMakerMethodForMergePartFailures..::..PartsCannotBeMerged Property
BuiltInFailures..::..PartMakerMethodForMergePartFailures Class See Also Send Feedback
This PartMaker refers to parts which cannot be merged.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId PartsCannotBeMerged { get; }
Visual Basic
Public Shared ReadOnly Property PartsCannotBeMerged As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PartsCannotBeMerged {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PartMakerMethodForMergePartFailures Class


BuiltInFailures.PartMakerMethodForWallFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..PartMakerMethodForWallFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures related to parts related to walls.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class PartMakerMethodForWallFailures
Visual Basic
Public NotInheritable Class PartMakerMethodForWallFailures
Visual C++
public ref class PartMakerMethodForWallFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..PartMakerMethodForWallFailures

See Also

BuiltInFailures..::..PartMakerMethodForWallFailures Members


BuiltInFailures.PartMakerMethodForWallFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..PartMakerMethodForWallFailures Members
BuiltInFailures..::..PartMakerMethodForWallFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..PartMakerMethodForWallFailures type exposes the following members.

Properties

Name | Description
CouldNotAdjustWallPartsAtJoin | Failed to extend or trim some layer at an end join
CouldNotCreateWallPart | Failed to create basic layer geometry. Probably a failure either to create the cutter or to intersect the cutter with the wall geometry.
CouldNotCreateWallPartDueToWallJoin | Failed to create basic layer geometry due to an excessively short edge created by wall join.

See Also

BuiltInFailures..::..PartMakerMethodForWallFailures Class


BuiltInFailures.PartMakerMethodForWallFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..PartMakerMethodForWallFailures Properties
BuiltInFailures..::..PartMakerMethodForWallFailures Class See Also Send Feedback

The BuiltInFailures..::..PartMakerMethodForWallFailures type exposes the following members.

Properties

Name | Description
CouldNotAdjustWallPartsAtJoin | Failed to extend or trim some layer at an end join
CouldNotCreateWallPart | Failed to create basic layer geometry. Probably a failure either to create the cutter or to intersect the cutter with the wall geometry.
CouldNotCreateWallPartDueToWallJoin | Failed to create basic layer geometry due to an excessively short edge created by wall join.

See Also

BuiltInFailures..::..PartMakerMethodForWallFailures Class


CouldNotCreateWallPart Property

[image]

Revit 2024 API
BuiltInFailures..::..PartMakerMethodForWallFailures..::..CouldNotCreateWallPart Property
BuiltInFailures..::..PartMakerMethodForWallFailures Class See Also Send Feedback
Failed to create basic layer geometry. Probably a failure either to create the cutter or to intersect the cutter with the wall geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CouldNotCreateWallPart { get; }
Visual Basic
Public Shared ReadOnly Property CouldNotCreateWallPart As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CouldNotCreateWallPart {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PartMakerMethodForWallFailures Class


CouldNotCreateWallPartDueToWallJoin Property

[image]

Revit 2024 API
BuiltInFailures..::..PartMakerMethodForWallFailures..::..CouldNotCreateWallPartDueToWallJoin Property
BuiltInFailures..::..PartMakerMethodForWallFailures Class See Also Send Feedback
Failed to create basic layer geometry due to an excessively short edge created by wall join.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CouldNotCreateWallPartDueToWallJoin { get; }
Visual Basic
Public Shared ReadOnly Property CouldNotCreateWallPartDueToWallJoin As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CouldNotCreateWallPartDueToWallJoin {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PartMakerMethodForWallFailures Class


BuiltInFailures.PathFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..PathFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class PathFailures
Visual Basic
Public NotInheritable Class PathFailures
Visual C++
public ref class PathFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..PathFailures

See Also

BuiltInFailures..::..PathFailures Members


BuiltInFailures.PathFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..PathFailures Members
BuiltInFailures..::..PathFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..PathFailures type exposes the following members.

Properties

Name | Description
Path3dRegenError | Picked Path could not be regenerated.

See Also

BuiltInFailures..::..PathFailures Class


BuiltInFailures.PathFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..PathFailures Properties
BuiltInFailures..::..PathFailures Class See Also Send Feedback

The BuiltInFailures..::..PathFailures type exposes the following members.

Properties

Name | Description
Path3dRegenError | Picked Path could not be regenerated.

See Also

BuiltInFailures..::..PathFailures Class


Path3dRegenError Property

[image]

Revit 2024 API
BuiltInFailures..::..PathFailures..::..Path3dRegenError Property
BuiltInFailures..::..PathFailures Class See Also Send Feedback
Picked Path could not be regenerated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId Path3dRegenError { get; }
Visual Basic
Public Shared ReadOnly Property Path3dRegenError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ Path3dRegenError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PathFailures Class


BuiltInFailures.PathOfTravelFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..PathOfTravelFailures Members
BuiltInFailures..::..PathOfTravelFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..PathOfTravelFailures type exposes the following members.

Properties

Name | Description
CannotBePasted | Path of Travel cannot be pasted into this view.
ResultAffectedByCrop | A crop region is enabled in the view. The Path of Travel may not be the optimized route because it is calculating only inside the crop region. Consider uncropping the view and placing another Path of Travel to ensure you see the optimized route.
UpdateFailureMultiple | [Number] Path of Travel lines failed to update. [Reason for failure]
UpdateFailureSingle | Path of Travel failed to update.
UpdateSummary | [Number] Path of Travel lines successfully updated. [Number] Path of Travel lines failed to update.

See Also

BuiltInFailures..::..PathOfTravelFailures Class


BuiltInFailures.PathOfTravelFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..PathOfTravelFailures Properties
BuiltInFailures..::..PathOfTravelFailures Class See Also Send Feedback

The BuiltInFailures..::..PathOfTravelFailures type exposes the following members.

Properties

Name | Description
CannotBePasted | Path of Travel cannot be pasted into this view.
ResultAffectedByCrop | A crop region is enabled in the view. The Path of Travel may not be the optimized route because it is calculating only inside the crop region. Consider uncropping the view and placing another Path of Travel to ensure you see the optimized route.
UpdateFailureMultiple | [Number] Path of Travel lines failed to update. [Reason for failure]
UpdateFailureSingle | Path of Travel failed to update.
UpdateSummary | [Number] Path of Travel lines successfully updated. [Number] Path of Travel lines failed to update.

See Also

BuiltInFailures..::..PathOfTravelFailures Class


CannotBePasted Property

[image]

Revit 2024 API
BuiltInFailures..::..PathOfTravelFailures..::..CannotBePasted Property
BuiltInFailures..::..PathOfTravelFailures Class See Also Send Feedback
Path of Travel cannot be pasted into this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotBePasted { get; }
Visual Basic
Public Shared ReadOnly Property CannotBePasted As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotBePasted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PathOfTravelFailures Class


ResultAffectedByCrop Property

[image]

Revit 2024 API
BuiltInFailures..::..PathOfTravelFailures..::..ResultAffectedByCrop Property
BuiltInFailures..::..PathOfTravelFailures Class See Also Send Feedback
A crop region is enabled in the view. The Path of Travel may not be the optimized route because it is calculating only inside the crop region. Consider uncropping the view and placing another Path of Travel to ensure you see the optimized route.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ResultAffectedByCrop { get; }
Visual Basic
Public Shared ReadOnly Property ResultAffectedByCrop As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ResultAffectedByCrop {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PathOfTravelFailures Class


UpdateFailureMultiple Property

[image]

Revit 2024 API
BuiltInFailures..::..PathOfTravelFailures..::..UpdateFailureMultiple Property
BuiltInFailures..::..PathOfTravelFailures Class See Also Send Feedback
[Number] Path of Travel lines failed to update. [Reason for failure]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UpdateFailureMultiple { get; }
Visual Basic
Public Shared ReadOnly Property UpdateFailureMultiple As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UpdateFailureMultiple {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PathOfTravelFailures Class


UpdateFailureSingle Property

[image]

Revit 2024 API
BuiltInFailures..::..PathOfTravelFailures..::..UpdateFailureSingle Property
BuiltInFailures..::..PathOfTravelFailures Class See Also Send Feedback
Path of Travel failed to update.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UpdateFailureSingle { get; }
Visual Basic
Public Shared ReadOnly Property UpdateFailureSingle As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UpdateFailureSingle {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PathOfTravelFailures Class


UpdateSummary Property

[image]

Revit 2024 API
BuiltInFailures..::..PathOfTravelFailures..::..UpdateSummary Property
BuiltInFailures..::..PathOfTravelFailures Class See Also Send Feedback
[Number] Path of Travel lines successfully updated. [Number] Path of Travel lines failed to update.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UpdateSummary { get; }
Visual Basic
Public Shared ReadOnly Property UpdateSummary As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UpdateSummary {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PathOfTravelFailures Class


BuiltInFailures.PerformanceFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..PerformanceFailures Members
BuiltInFailures..::..PerformanceFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..PerformanceFailures type exposes the following members.

Properties

Name | Description
ClippingIsDisabled | View has clipping disabled. It causes view to draw too many elements.
DisjoinedSolidsInInPlaceFamily | In-place family contains multiple disjoined solids. Consider splitting in several in-place families.
DuplicateInstances | There are duplicate instances of the same family in the same place. Delete duplicate instances to improve performance.
FamilyContainsViewSpecificImports | Family definition contains view-specific imports. Such imports are inaccessible in the project - consider removal.
HostHasTooManyInserts | Host object contains too many cutting inserts - it may take long time to update. Consider splitting host object into smaller pieces or using stacked walls.
InteriorCategoriesEnabledInLargeView | Interior categories are enabled in a large view. Even though these objects may be obscured and invisible, they still have negative impact on performance.
LargeFamilyFile | Family occupies XXX kilobytes of memory. Consider simplification of the family.
ManyElementInFamily | Family definition contains too many elements. Consider simplification of the family.
ManyUnusedNestedFamilies | Family contains other families loaded into it but not used. Consider purging family document from unused families and types.
MultipleLoopsInSketch | Sketch of <element> contains multiple independent loops - splitting it in few independent elements might improve performance.
TooLargeSketch | Sketch of <element> has large area - it may slow down selection, drawing and geometric computations.
TooManyAreaBoundaryLinesFound | There are too many area boundary lines in area scheme <element> might result in increased model sizes on disk and in memory. Please investigate if area scheme is used in a proper way.
TooManyElementsInSketch | Sketch of <element> contains too many objects - it may take long time to solve.
UnjoinedRoomSeparationLinesFound | Room Separation of <element> is not joined, might cause performance issue with room boundaries computations.
UnusedTypesInTheProject | Project contains unused families and/or types. Consider purging them out.
ViewDetailLevelIsHighInLargeView | A large view has view detail level set to medium or coarse. Generation of extraneous details harms performance.
WallsOverlap | Walls overlap. Consider embedding walls, editing their extents or profile to avoid overlapping.

See Also

BuiltInFailures..::..PerformanceFailures Class


BuiltInFailures.PerformanceFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..PerformanceFailures Properties
BuiltInFailures..::..PerformanceFailures Class See Also Send Feedback

The BuiltInFailures..::..PerformanceFailures type exposes the following members.

Properties

Name | Description
ClippingIsDisabled | View has clipping disabled. It causes view to draw too many elements.
DisjoinedSolidsInInPlaceFamily | In-place family contains multiple disjoined solids. Consider splitting in several in-place families.
DuplicateInstances | There are duplicate instances of the same family in the same place. Delete duplicate instances to improve performance.
FamilyContainsViewSpecificImports | Family definition contains view-specific imports. Such imports are inaccessible in the project - consider removal.
HostHasTooManyInserts | Host object contains too many cutting inserts - it may take long time to update. Consider splitting host object into smaller pieces or using stacked walls.
InteriorCategoriesEnabledInLargeView | Interior categories are enabled in a large view. Even though these objects may be obscured and invisible, they still have negative impact on performance.
LargeFamilyFile | Family occupies XXX kilobytes of memory. Consider simplification of the family.
ManyElementInFamily | Family definition contains too many elements. Consider simplification of the family.
ManyUnusedNestedFamilies | Family contains other families loaded into it but not used. Consider purging family document from unused families and types.
MultipleLoopsInSketch | Sketch of <element> contains multiple independent loops - splitting it in few independent elements might improve performance.
TooLargeSketch | Sketch of <element> has large area - it may slow down selection, drawing and geometric computations.
TooManyAreaBoundaryLinesFound | There are too many area boundary lines in area scheme <element> might result in increased model sizes on disk and in memory. Please investigate if area scheme is used in a proper way.
TooManyElementsInSketch | Sketch of <element> contains too many objects - it may take long time to solve.
UnjoinedRoomSeparationLinesFound | Room Separation of <element> is not joined, might cause performance issue with room boundaries computations.
UnusedTypesInTheProject | Project contains unused families and/or types. Consider purging them out.
ViewDetailLevelIsHighInLargeView | A large view has view detail level set to medium or coarse. Generation of extraneous details harms performance.
WallsOverlap | Walls overlap. Consider embedding walls, editing their extents or profile to avoid overlapping.

See Also

BuiltInFailures..::..PerformanceFailures Class


ClippingIsDisabled Property

[image]

Revit 2024 API
BuiltInFailures..::..PerformanceFailures..::..ClippingIsDisabled Property
BuiltInFailures..::..PerformanceFailures Class See Also Send Feedback
View has clipping disabled. It causes view to draw too many elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ClippingIsDisabled { get; }
Visual Basic
Public Shared ReadOnly Property ClippingIsDisabled As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ClippingIsDisabled {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PerformanceFailures Class


DisjoinedSolidsInInPlaceFamily Property

[image]

Revit 2024 API
BuiltInFailures..::..PerformanceFailures..::..DisjoinedSolidsInInPlaceFamily Property
BuiltInFailures..::..PerformanceFailures Class See Also Send Feedback
In-place family contains multiple disjoined solids. Consider splitting in several in-place families.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DisjoinedSolidsInInPlaceFamily { get; }
Visual Basic
Public Shared ReadOnly Property DisjoinedSolidsInInPlaceFamily As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DisjoinedSolidsInInPlaceFamily {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PerformanceFailures Class


DuplicateInstances Property

[image]

Revit 2024 API
BuiltInFailures..::..PerformanceFailures..::..DuplicateInstances Property
BuiltInFailures..::..PerformanceFailures Class See Also Send Feedback
There are duplicate instances of the same family in the same place. Delete duplicate instances to improve performance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DuplicateInstances { get; }
Visual Basic
Public Shared ReadOnly Property DuplicateInstances As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DuplicateInstances {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PerformanceFailures Class


InteriorCategoriesEnabledInLargeView Property

[image]

Revit 2024 API
BuiltInFailures..::..PerformanceFailures..::..InteriorCategoriesEnabledInLargeView Property
BuiltInFailures..::..PerformanceFailures Class See Also Send Feedback
Interior categories are enabled in a large view. Even though these objects may be obscured and invisible, they still have negative impact on performance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InteriorCategoriesEnabledInLargeView { get; }
Visual Basic
Public Shared ReadOnly Property InteriorCategoriesEnabledInLargeView As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InteriorCategoriesEnabledInLargeView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PerformanceFailures Class


ManyUnusedNestedFamilies Property

[image]

Revit 2024 API
BuiltInFailures..::..PerformanceFailures..::..ManyUnusedNestedFamilies Property
BuiltInFailures..::..PerformanceFailures Class See Also Send Feedback
Family contains other families loaded into it but not used. Consider purging family document from unused families and types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ManyUnusedNestedFamilies { get; }
Visual Basic
Public Shared ReadOnly Property ManyUnusedNestedFamilies As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ManyUnusedNestedFamilies {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PerformanceFailures Class


TooManyAreaBoundaryLinesFound Property

[image]

Revit 2024 API
BuiltInFailures..::..PerformanceFailures..::..TooManyAreaBoundaryLinesFound Property
BuiltInFailures..::..PerformanceFailures Class See Also Send Feedback
There are too many area boundary lines in area scheme <element> might result in increased model sizes on disk and in memory. Please investigate if area scheme is used in a proper way.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId TooManyAreaBoundaryLinesFound { get; }
Visual Basic
Public Shared ReadOnly Property TooManyAreaBoundaryLinesFound As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TooManyAreaBoundaryLinesFound {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PerformanceFailures Class


TooManyElementsInSketch Property

[image]

Revit 2024 API
BuiltInFailures..::..PerformanceFailures..::..TooManyElementsInSketch Property
BuiltInFailures..::..PerformanceFailures Class See Also Send Feedback
Sketch of <element> contains too many objects - it may take long time to solve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId TooManyElementsInSketch { get; }
Visual Basic
Public Shared ReadOnly Property TooManyElementsInSketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TooManyElementsInSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PerformanceFailures Class


UnusedTypesInTheProject Property

[image]

Revit 2024 API
BuiltInFailures..::..PerformanceFailures..::..UnusedTypesInTheProject Property
BuiltInFailures..::..PerformanceFailures Class See Also Send Feedback
Project contains unused families and/or types. Consider purging them out.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UnusedTypesInTheProject { get; }
Visual Basic
Public Shared ReadOnly Property UnusedTypesInTheProject As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnusedTypesInTheProject {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PerformanceFailures Class


ViewDetailLevelIsHighInLargeView Property

[image]

Revit 2024 API
BuiltInFailures..::..PerformanceFailures..::..ViewDetailLevelIsHighInLargeView Property
BuiltInFailures..::..PerformanceFailures Class See Also Send Feedback
A large view has view detail level set to medium or coarse. Generation of extraneous details harms performance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ViewDetailLevelIsHighInLargeView { get; }
Visual Basic
Public Shared ReadOnly Property ViewDetailLevelIsHighInLargeView As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ViewDetailLevelIsHighInLargeView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PerformanceFailures Class


WallsOverlap Property

[image]

Revit 2024 API
BuiltInFailures..::..PerformanceFailures..::..WallsOverlap Property
BuiltInFailures..::..PerformanceFailures Class See Also Send Feedback
Walls overlap. Consider embedding walls, editing their extents or profile to avoid overlapping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WallsOverlap { get; }
Visual Basic
Public Shared ReadOnly Property WallsOverlap As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WallsOverlap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PerformanceFailures Class


BuiltInFailures.PipingFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..PipingFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Pipes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class PipingFailures
Visual Basic
Public NotInheritable Class PipingFailures
Visual C++
public ref class PipingFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..PipingFailures

See Also

BuiltInFailures..::..PipingFailures Members


BuiltInFailures.PipingFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..PipingFailures Properties
BuiltInFailures..::..PipingFailures Class See Also Send Feedback

The BuiltInFailures..::..PipingFailures type exposes the following members.

Properties

Name | Description
CannotCreateGeometryForPipe | Cannot create geometry for flex pipe. The flex pipe is intersecting itself or the start and end are too close together.
CircularLoopInPipeSizing | Circular loop detected during pipe sizing. The loop may be avoided by modifying segment settings in the pipe routing preference.
DuctPipeModified | The duct/pipe has been modified to be in the opposite direction causing the connections to be invalid.
DuctPipeSizeMismatch | The duct/pipe size is invalid for the service definition
FabFittingFailed | The Fabrication Fitting was invalid
InvalidPipeSize | Pipe Size Table "[File Name]" is missing or invalid.
MaxPipeSizeReached | Maximum pipe size diameter reached during sizing
PartNotFoundDueToNoPipeConnectedError | "In order to find a matching part, the fitting has to be connected to a pipe."
PartNotFoundDueToNoPipeConnectedWarning | "In order to find a matching part, the fitting has to be connected to a pipe."
PartNotFoundInRoutingPreferenceError | "%1s is not found. Please review the routing preference of %2s."
PartNotFoundInRoutingPreferenceWarning | "%1s is not found. Please review the routing preference of %2s."

See Also

BuiltInFailures..::..PipingFailures Class


CannotCreateGeometryForPipe Property

[image]

Revit 2024 API
BuiltInFailures..::..PipingFailures..::..CannotCreateGeometryForPipe Property
BuiltInFailures..::..PipingFailures Class See Also Send Feedback
Cannot create geometry for flex pipe. The flex pipe is intersecting itself or the start and end are too close together.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateGeometryForPipe { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateGeometryForPipe As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateGeometryForPipe {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PipingFailures Class


CircularLoopInPipeSizing Property

[image]

Revit 2024 API
BuiltInFailures..::..PipingFailures..::..CircularLoopInPipeSizing Property
BuiltInFailures..::..PipingFailures Class See Also Send Feedback
Circular loop detected during pipe sizing. The loop may be avoided by modifying segment settings in the pipe routing preference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CircularLoopInPipeSizing { get; }
Visual Basic
Public Shared ReadOnly Property CircularLoopInPipeSizing As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CircularLoopInPipeSizing {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PipingFailures Class


DuctPipeModified Property

[image]

Revit 2024 API
BuiltInFailures..::..PipingFailures..::..DuctPipeModified Property
BuiltInFailures..::..PipingFailures Class See Also Send Feedback
The duct/pipe has been modified to be in the opposite direction causing the connections to be invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DuctPipeModified { get; }
Visual Basic
Public Shared ReadOnly Property DuctPipeModified As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DuctPipeModified {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PipingFailures Class


DuctPipeSizeMismatch Property

[image]

Revit 2024 API
BuiltInFailures..::..PipingFailures..::..DuctPipeSizeMismatch Property
BuiltInFailures..::..PipingFailures Class See Also Send Feedback
The duct/pipe size is invalid for the service definition

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DuctPipeSizeMismatch { get; }
Visual Basic
Public Shared ReadOnly Property DuctPipeSizeMismatch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DuctPipeSizeMismatch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PipingFailures Class


FabFittingFailed Property

[image]

Revit 2024 API
BuiltInFailures..::..PipingFailures..::..FabFittingFailed Property
BuiltInFailures..::..PipingFailures Class See Also Send Feedback
The Fabrication Fitting was invalid

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FabFittingFailed { get; }
Visual Basic
Public Shared ReadOnly Property FabFittingFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FabFittingFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PipingFailures Class


MaxPipeSizeReached Property

[image]

Revit 2024 API
BuiltInFailures..::..PipingFailures..::..MaxPipeSizeReached Property
BuiltInFailures..::..PipingFailures Class See Also Send Feedback
Maximum pipe size diameter reached during sizing

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MaxPipeSizeReached { get; }
Visual Basic
Public Shared ReadOnly Property MaxPipeSizeReached As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MaxPipeSizeReached {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PipingFailures Class


PartNotFoundDueToNoPipeConnectedError Property

[image]

Revit 2024 API
BuiltInFailures..::..PipingFailures..::..PartNotFoundDueToNoPipeConnectedError Property
BuiltInFailures..::..PipingFailures Class See Also Send Feedback
"In order to find a matching part, the fitting has to be connected to a pipe."

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId PartNotFoundDueToNoPipeConnectedError { get; }
Visual Basic
Public Shared ReadOnly Property PartNotFoundDueToNoPipeConnectedError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PartNotFoundDueToNoPipeConnectedError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PipingFailures Class


PartNotFoundInRoutingPreferenceError Property

[image]

Revit 2024 API
BuiltInFailures..::..PipingFailures..::..PartNotFoundInRoutingPreferenceError Property
BuiltInFailures..::..PipingFailures Class See Also Send Feedback
"%1s is not found. Please review the routing preference of %2s."

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId PartNotFoundInRoutingPreferenceError { get; }
Visual Basic
Public Shared ReadOnly Property PartNotFoundInRoutingPreferenceError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PartNotFoundInRoutingPreferenceError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PipingFailures Class


BuiltInFailures.PlanRegionFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..PlanRegionFailures Properties
BuiltInFailures..::..PlanRegionFailures Class See Also Send Feedback

The BuiltInFailures..::..PlanRegionFailures type exposes the following members.

Properties

Name | Description
DeletedViewRangeLevel | Deleted level was used to define plan region's view range.\r\nReplace deleted level by level of parent view and adjust offset?
Intersecting | The boundaries of the highlighted Plan Regions overlap.
InvalidPlanRegion | Plan region is invalid. The sketch of a plan region may not contain intersecting, overlapping or nested loops.
InvalidPlanRegionError | Plan region is invalid. The sketch of a plan region may not contain intersecting, overlapping or nested loops.
Nested | Cannot have nested Plan Regions.

See Also

BuiltInFailures..::..PlanRegionFailures Class


DeletedViewRangeLevel Property

[image]

Revit 2024 API
BuiltInFailures..::..PlanRegionFailures..::..DeletedViewRangeLevel Property
BuiltInFailures..::..PlanRegionFailures Class See Also Send Feedback
Deleted level was used to define plan region's view range.\r\nReplace deleted level by level of parent view and adjust offset?

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DeletedViewRangeLevel { get; }
Visual Basic
Public Shared ReadOnly Property DeletedViewRangeLevel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DeletedViewRangeLevel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PlanRegionFailures Class


Intersecting Property

[image]

Revit 2024 API
BuiltInFailures..::..PlanRegionFailures..::..Intersecting Property
BuiltInFailures..::..PlanRegionFailures Class See Also Send Feedback
The boundaries of the highlighted Plan Regions overlap.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId Intersecting { get; }
Visual Basic
Public Shared ReadOnly Property Intersecting As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ Intersecting {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PlanRegionFailures Class


InvalidPlanRegionError Property

[image]

Revit 2024 API
BuiltInFailures..::..PlanRegionFailures..::..InvalidPlanRegionError Property
BuiltInFailures..::..PlanRegionFailures Class See Also Send Feedback
Plan region is invalid. The sketch of a plan region may not contain intersecting, overlapping or nested loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidPlanRegionError { get; }
Visual Basic
Public Shared ReadOnly Property InvalidPlanRegionError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidPlanRegionError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PlanRegionFailures Class


Nested Property

[image]

Revit 2024 API
BuiltInFailures..::..PlanRegionFailures..::..Nested Property
BuiltInFailures..::..PlanRegionFailures Class See Also Send Feedback
Cannot have nested Plan Regions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId Nested { get; }
Visual Basic
Public Shared ReadOnly Property Nested As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ Nested {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PlanRegionFailures Class


BuiltInFailures.PointFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..PointFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Point Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class PointFailures
Visual Basic
Public NotInheritable Class PointFailures
Visual C++
public ref class PointFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..PointFailures

See Also

BuiltInFailures..::..PointFailures Members


BuiltInFailures.PointFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..PointFailures Members
BuiltInFailures..::..PointFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..PointFailures type exposes the following members.

Properties

Name | Description
CannotMakePointHostedByIntersection | Cannot make point hosted by intersection.
CantChangeParamFlip | Can't flip Element.
CantChangeParamMirror | Can't mirror Element.
CantChangeParamRotate | Can't rotate Element.
EdgeHostedPointToBeUnhosted | A point element in a family was hosted on an edge outside its family and the edge no longer exists. The point will remain placed but with no host.
HostMeasurementError | Invalid host curve measurement type or value or justification
HostParameterRangeError | Hosted Parameter must be between 0 and 1
RegenFailure | Regeneration Failure.

See Also

BuiltInFailures..::..PointFailures Class


BuiltInFailures.PointFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..PointFailures Properties
BuiltInFailures..::..PointFailures Class See Also Send Feedback

The BuiltInFailures..::..PointFailures type exposes the following members.

Properties

Name | Description
CannotMakePointHostedByIntersection | Cannot make point hosted by intersection.
CantChangeParamFlip | Can't flip Element.
CantChangeParamMirror | Can't mirror Element.
CantChangeParamRotate | Can't rotate Element.
EdgeHostedPointToBeUnhosted | A point element in a family was hosted on an edge outside its family and the edge no longer exists. The point will remain placed but with no host.
HostMeasurementError | Invalid host curve measurement type or value or justification
HostParameterRangeError | Hosted Parameter must be between 0 and 1
RegenFailure | Regeneration Failure.

See Also

BuiltInFailures..::..PointFailures Class


CannotMakePointHostedByIntersection Property

[image]

Revit 2024 API
BuiltInFailures..::..PointFailures..::..CannotMakePointHostedByIntersection Property
BuiltInFailures..::..PointFailures Class See Also Send Feedback
Cannot make point hosted by intersection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotMakePointHostedByIntersection { get; }
Visual Basic
Public Shared ReadOnly Property CannotMakePointHostedByIntersection As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMakePointHostedByIntersection {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PointFailures Class


CantChangeParamFlip Property

[image]

Revit 2024 API
BuiltInFailures..::..PointFailures..::..CantChangeParamFlip Property
BuiltInFailures..::..PointFailures Class See Also Send Feedback
Can't flip Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CantChangeParamFlip { get; }
Visual Basic
Public Shared ReadOnly Property CantChangeParamFlip As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CantChangeParamFlip {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PointFailures Class


CantChangeParamRotate Property

[image]

Revit 2024 API
BuiltInFailures..::..PointFailures..::..CantChangeParamRotate Property
BuiltInFailures..::..PointFailures Class See Also Send Feedback
Can't rotate Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CantChangeParamRotate { get; }
Visual Basic
Public Shared ReadOnly Property CantChangeParamRotate As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CantChangeParamRotate {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PointFailures Class


EdgeHostedPointToBeUnhosted Property

[image]

Revit 2024 API
BuiltInFailures..::..PointFailures..::..EdgeHostedPointToBeUnhosted Property
BuiltInFailures..::..PointFailures Class See Also Send Feedback
A point element in a family was hosted on an edge outside its family and the edge no longer exists. The point will remain placed but with no host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId EdgeHostedPointToBeUnhosted { get; }
Visual Basic
Public Shared ReadOnly Property EdgeHostedPointToBeUnhosted As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ EdgeHostedPointToBeUnhosted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PointFailures Class


HostMeasurementError Property

[image]

Revit 2024 API
BuiltInFailures..::..PointFailures..::..HostMeasurementError Property
BuiltInFailures..::..PointFailures Class See Also Send Feedback
Invalid host curve measurement type or value or justification

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId HostMeasurementError { get; }
Visual Basic
Public Shared ReadOnly Property HostMeasurementError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HostMeasurementError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PointFailures Class


HostParameterRangeError Property

[image]

Revit 2024 API
BuiltInFailures..::..PointFailures..::..HostParameterRangeError Property
BuiltInFailures..::..PointFailures Class See Also Send Feedback
Hosted Parameter must be between 0 and 1

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId HostParameterRangeError { get; }
Visual Basic
Public Shared ReadOnly Property HostParameterRangeError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HostParameterRangeError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PointFailures Class


RegenFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..PointFailures..::..RegenFailure Property
BuiltInFailures..::..PointFailures Class See Also Send Feedback
Regeneration Failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RegenFailure { get; }
Visual Basic
Public Shared ReadOnly Property RegenFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RegenFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PointFailures Class


BuiltInFailures.ProfileFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..ProfileFailures Members
BuiltInFailures..::..ProfileFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..ProfileFailures type exposes the following members.

Properties

Name | Description
SketchNotEmpty | Can't move the Profile Plane because the Profile Sketch is not empty. This operation is not supported at this time.

See Also

BuiltInFailures..::..ProfileFailures Class


BuiltInFailures.ProfileFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..ProfileFailures Properties
BuiltInFailures..::..ProfileFailures Class See Also Send Feedback

The BuiltInFailures..::..ProfileFailures type exposes the following members.

Properties

Name | Description
SketchNotEmpty | Can't move the Profile Plane because the Profile Sketch is not empty. This operation is not supported at this time.

See Also

BuiltInFailures..::..ProfileFailures Class


SketchNotEmpty Property

[image]

Revit 2024 API
BuiltInFailures..::..ProfileFailures..::..SketchNotEmpty Property
BuiltInFailures..::..ProfileFailures Class See Also Send Feedback
Can't move the Profile Plane because the Profile Sketch is not empty. This operation is not supported at this time.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SketchNotEmpty { get; }
Visual Basic
Public Shared ReadOnly Property SketchNotEmpty As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SketchNotEmpty {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ProfileFailures Class


BuiltInFailures.PropertySetElementFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..PropertySetElementFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures related to property set elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class PropertySetElementFailures
Visual Basic
Public NotInheritable Class PropertySetElementFailures
Visual C++
public ref class PropertySetElementFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..PropertySetElementFailures

See Also

BuiltInFailures..::..PropertySetElementFailures Members


BuiltInFailures.PropertySetElementFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..PropertySetElementFailures Members
BuiltInFailures..::..PropertySetElementFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..PropertySetElementFailures type exposes the following members.

Properties

Name | Description
EmptyPropertySetName | A property set name cannot be an empty string.
NonStringParameterValue | The given parameter requires a string value.
NonUniquePropertySetName | The value of the given parameter is already in use as a property set name.

See Also

BuiltInFailures..::..PropertySetElementFailures Class


EmptyPropertySetName Property

[image]

Revit 2024 API
BuiltInFailures..::..PropertySetElementFailures..::..EmptyPropertySetName Property
BuiltInFailures..::..PropertySetElementFailures Class See Also Send Feedback
A property set name cannot be an empty string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId EmptyPropertySetName { get; }
Visual Basic
Public Shared ReadOnly Property EmptyPropertySetName As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ EmptyPropertySetName {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PropertySetElementFailures Class


NonStringParameterValue Property

[image]

Revit 2024 API
BuiltInFailures..::..PropertySetElementFailures..::..NonStringParameterValue Property
BuiltInFailures..::..PropertySetElementFailures Class See Also Send Feedback
The given parameter requires a string value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NonStringParameterValue { get; }
Visual Basic
Public Shared ReadOnly Property NonStringParameterValue As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NonStringParameterValue {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PropertySetElementFailures Class


NonUniquePropertySetName Property

[image]

Revit 2024 API
BuiltInFailures..::..PropertySetElementFailures..::..NonUniquePropertySetName Property
BuiltInFailures..::..PropertySetElementFailures Class See Also Send Feedback
The value of the given parameter is already in use as a property set name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NonUniquePropertySetName { get; }
Visual Basic
Public Shared ReadOnly Property NonUniquePropertySetName As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NonUniquePropertySetName {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PropertySetElementFailures Class


BuiltInFailures.RebarCouplerFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..RebarCouplerFailures Members
BuiltInFailures..::..RebarCouplerFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..RebarCouplerFailures type exposes the following members.

Properties

Name | Description
CantKeepConstraintsToBars | The constraints between the coupler and the two connected bars are no longer satisfied. Post error to delete the coupler.
CouplerRequiredRemoveFromGroup | The coupler is invalid in group.
CouplerTypeInvalid | This coupler type does not fit on the selected bar(s). Post error to delete the coupler.
DisconnectElements | Disconnect the coupler from the connected bar.
DistanceBetweenBarsError | This is used to post error. The distance between the connected ends of the bars exceeds 10 bar diameters.
DistanceBetweenBarsWarning | This is used to post warning. The distance between the connected ends of the bars exceeds 10 bar diameters.
EngagementBiggerThanLengthError | This is used to post error. The sum of bar engagements is greater than the total coupler length.
EngagementBiggerThanLengthWarning | This is used to post warning. The sum of bar engagements is greater than the total coupler length.
LengthParameterError | This is used to post error. The "Total Length" parameter must be set to a strictly positive value.
LengthParameterWarning | This is used to post warning. The "Total Length" parameter must be set to a strictly positive value.
MainEngagementParameterError | This is used to post error. "Bar Engagement 1" has an incorrect value.
MainEngagementParameterWarning | This is used to post warning. "Bar Engagement 1" has an incorrect value.
NewCouplerTypeCreated | A new coupler type was automatically created to fit the bar diameters.
NoBarSizeError | This is used to post error. At least Bar Size 1 or Bar Size 2 should have another value than "None".
NoBarSizeWarning | This is used to post warning. At least Bar Size 1 or Bar Size 2 should have a value other than "None".
NoTypeParamsDefinedWarning | The parameters of the default type have no values.
SecondaryEngagementParameterError | This is used to post error. "Bar Engagement 2" has an incorrect value.
SecondaryEngagementParameterWarning | This is used to post warning. "Bar Engagement 2" has an incorrect value.
WidthParameterError | This is used to post error.The "External Diameter" parameter must be set to a strictly positive value.
WidthParameterWarning | This is used to post warning. The "External Diameter" parameter must be set to a strictly positive value.

See Also

BuiltInFailures..::..RebarCouplerFailures Class


BuiltInFailures.RebarCouplerFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..RebarCouplerFailures Properties
BuiltInFailures..::..RebarCouplerFailures Class See Also Send Feedback

The BuiltInFailures..::..RebarCouplerFailures type exposes the following members.

Properties

Name | Description
CantKeepConstraintsToBars | The constraints between the coupler and the two connected bars are no longer satisfied. Post error to delete the coupler.
CouplerRequiredRemoveFromGroup | The coupler is invalid in group.
CouplerTypeInvalid | This coupler type does not fit on the selected bar(s). Post error to delete the coupler.
DisconnectElements | Disconnect the coupler from the connected bar.
DistanceBetweenBarsError | This is used to post error. The distance between the connected ends of the bars exceeds 10 bar diameters.
DistanceBetweenBarsWarning | This is used to post warning. The distance between the connected ends of the bars exceeds 10 bar diameters.
EngagementBiggerThanLengthError | This is used to post error. The sum of bar engagements is greater than the total coupler length.
EngagementBiggerThanLengthWarning | This is used to post warning. The sum of bar engagements is greater than the total coupler length.
LengthParameterError | This is used to post error. The "Total Length" parameter must be set to a strictly positive value.
LengthParameterWarning | This is used to post warning. The "Total Length" parameter must be set to a strictly positive value.
MainEngagementParameterError | This is used to post error. "Bar Engagement 1" has an incorrect value.
MainEngagementParameterWarning | This is used to post warning. "Bar Engagement 1" has an incorrect value.
NewCouplerTypeCreated | A new coupler type was automatically created to fit the bar diameters.
NoBarSizeError | This is used to post error. At least Bar Size 1 or Bar Size 2 should have another value than "None".
NoBarSizeWarning | This is used to post warning. At least Bar Size 1 or Bar Size 2 should have a value other than "None".
NoTypeParamsDefinedWarning | The parameters of the default type have no values.
SecondaryEngagementParameterError | This is used to post error. "Bar Engagement 2" has an incorrect value.
SecondaryEngagementParameterWarning | This is used to post warning. "Bar Engagement 2" has an incorrect value.
WidthParameterError | This is used to post error.The "External Diameter" parameter must be set to a strictly positive value.
WidthParameterWarning | This is used to post warning. The "External Diameter" parameter must be set to a strictly positive value.

See Also

BuiltInFailures..::..RebarCouplerFailures Class


CantKeepConstraintsToBars Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarCouplerFailures..::..CantKeepConstraintsToBars Property
BuiltInFailures..::..RebarCouplerFailures Class See Also Send Feedback
The constraints between the coupler and the two connected bars are no longer satisfied. Post error to delete the coupler.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CantKeepConstraintsToBars { get; }
Visual Basic
Public Shared ReadOnly Property CantKeepConstraintsToBars As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CantKeepConstraintsToBars {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarCouplerFailures Class


CouplerRequiredRemoveFromGroup Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarCouplerFailures..::..CouplerRequiredRemoveFromGroup Property
BuiltInFailures..::..RebarCouplerFailures Class See Also Send Feedback
The coupler is invalid in group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CouplerRequiredRemoveFromGroup { get; }
Visual Basic
Public Shared ReadOnly Property CouplerRequiredRemoveFromGroup As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CouplerRequiredRemoveFromGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarCouplerFailures Class


CouplerTypeInvalid Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarCouplerFailures..::..CouplerTypeInvalid Property
BuiltInFailures..::..RebarCouplerFailures Class See Also Send Feedback
This coupler type does not fit on the selected bar(s). Post error to delete the coupler.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CouplerTypeInvalid { get; }
Visual Basic
Public Shared ReadOnly Property CouplerTypeInvalid As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CouplerTypeInvalid {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarCouplerFailures Class


DisconnectElements Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarCouplerFailures..::..DisconnectElements Property
BuiltInFailures..::..RebarCouplerFailures Class See Also Send Feedback
Disconnect the coupler from the connected bar.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DisconnectElements { get; }
Visual Basic
Public Shared ReadOnly Property DisconnectElements As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DisconnectElements {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarCouplerFailures Class


DistanceBetweenBarsError Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarCouplerFailures..::..DistanceBetweenBarsError Property
BuiltInFailures..::..RebarCouplerFailures Class See Also Send Feedback
This is used to post error. The distance between the connected ends of the bars exceeds 10 bar diameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DistanceBetweenBarsError { get; }
Visual Basic
Public Shared ReadOnly Property DistanceBetweenBarsError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DistanceBetweenBarsError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarCouplerFailures Class


DistanceBetweenBarsWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarCouplerFailures..::..DistanceBetweenBarsWarning Property
BuiltInFailures..::..RebarCouplerFailures Class See Also Send Feedback
This is used to post warning. The distance between the connected ends of the bars exceeds 10 bar diameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DistanceBetweenBarsWarning { get; }
Visual Basic
Public Shared ReadOnly Property DistanceBetweenBarsWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DistanceBetweenBarsWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarCouplerFailures Class


EngagementBiggerThanLengthError Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarCouplerFailures..::..EngagementBiggerThanLengthError Property
BuiltInFailures..::..RebarCouplerFailures Class See Also Send Feedback
This is used to post error. The sum of bar engagements is greater than the total coupler length.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId EngagementBiggerThanLengthError { get; }
Visual Basic
Public Shared ReadOnly Property EngagementBiggerThanLengthError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ EngagementBiggerThanLengthError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarCouplerFailures Class


EngagementBiggerThanLengthWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarCouplerFailures..::..EngagementBiggerThanLengthWarning Property
BuiltInFailures..::..RebarCouplerFailures Class See Also Send Feedback
This is used to post warning. The sum of bar engagements is greater than the total coupler length.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId EngagementBiggerThanLengthWarning { get; }
Visual Basic
Public Shared ReadOnly Property EngagementBiggerThanLengthWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ EngagementBiggerThanLengthWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarCouplerFailures Class


LengthParameterError Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarCouplerFailures..::..LengthParameterError Property
BuiltInFailures..::..RebarCouplerFailures Class See Also Send Feedback
This is used to post error. The "Total Length" parameter must be set to a strictly positive value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId LengthParameterError { get; }
Visual Basic
Public Shared ReadOnly Property LengthParameterError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LengthParameterError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarCouplerFailures Class


LengthParameterWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarCouplerFailures..::..LengthParameterWarning Property
BuiltInFailures..::..RebarCouplerFailures Class See Also Send Feedback
This is used to post warning. The "Total Length" parameter must be set to a strictly positive value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId LengthParameterWarning { get; }
Visual Basic
Public Shared ReadOnly Property LengthParameterWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LengthParameterWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarCouplerFailures Class


MainEngagementParameterWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarCouplerFailures..::..MainEngagementParameterWarning Property
BuiltInFailures..::..RebarCouplerFailures Class See Also Send Feedback
This is used to post warning. "Bar Engagement 1" has an incorrect value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MainEngagementParameterWarning { get; }
Visual Basic
Public Shared ReadOnly Property MainEngagementParameterWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MainEngagementParameterWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarCouplerFailures Class


NewCouplerTypeCreated Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarCouplerFailures..::..NewCouplerTypeCreated Property
BuiltInFailures..::..RebarCouplerFailures Class See Also Send Feedback
A new coupler type was automatically created to fit the bar diameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NewCouplerTypeCreated { get; }
Visual Basic
Public Shared ReadOnly Property NewCouplerTypeCreated As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NewCouplerTypeCreated {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarCouplerFailures Class


NoBarSizeError Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarCouplerFailures..::..NoBarSizeError Property
BuiltInFailures..::..RebarCouplerFailures Class See Also Send Feedback
This is used to post error. At least Bar Size 1 or Bar Size 2 should have another value than "None".

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoBarSizeError { get; }
Visual Basic
Public Shared ReadOnly Property NoBarSizeError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoBarSizeError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarCouplerFailures Class


NoBarSizeWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarCouplerFailures..::..NoBarSizeWarning Property
BuiltInFailures..::..RebarCouplerFailures Class See Also Send Feedback
This is used to post warning. At least Bar Size 1 or Bar Size 2 should have a value other than "None".

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoBarSizeWarning { get; }
Visual Basic
Public Shared ReadOnly Property NoBarSizeWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoBarSizeWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarCouplerFailures Class


NoTypeParamsDefinedWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarCouplerFailures..::..NoTypeParamsDefinedWarning Property
BuiltInFailures..::..RebarCouplerFailures Class See Also Send Feedback
The parameters of the default type have no values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoTypeParamsDefinedWarning { get; }
Visual Basic
Public Shared ReadOnly Property NoTypeParamsDefinedWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoTypeParamsDefinedWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarCouplerFailures Class


SecondaryEngagementParameterError Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarCouplerFailures..::..SecondaryEngagementParameterError Property
BuiltInFailures..::..RebarCouplerFailures Class See Also Send Feedback
This is used to post error. "Bar Engagement 2" has an incorrect value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SecondaryEngagementParameterError { get; }
Visual Basic
Public Shared ReadOnly Property SecondaryEngagementParameterError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SecondaryEngagementParameterError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarCouplerFailures Class


SecondaryEngagementParameterWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarCouplerFailures..::..SecondaryEngagementParameterWarning Property
BuiltInFailures..::..RebarCouplerFailures Class See Also Send Feedback
This is used to post warning. "Bar Engagement 2" has an incorrect value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SecondaryEngagementParameterWarning { get; }
Visual Basic
Public Shared ReadOnly Property SecondaryEngagementParameterWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SecondaryEngagementParameterWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarCouplerFailures Class


WidthParameterError Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarCouplerFailures..::..WidthParameterError Property
BuiltInFailures..::..RebarCouplerFailures Class See Also Send Feedback
This is used to post error.The "External Diameter" parameter must be set to a strictly positive value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WidthParameterError { get; }
Visual Basic
Public Shared ReadOnly Property WidthParameterError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WidthParameterError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarCouplerFailures Class


WidthParameterWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarCouplerFailures..::..WidthParameterWarning Property
BuiltInFailures..::..RebarCouplerFailures Class See Also Send Feedback
This is used to post warning. The "External Diameter" parameter must be set to a strictly positive value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WidthParameterWarning { get; }
Visual Basic
Public Shared ReadOnly Property WidthParameterWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WidthParameterWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarCouplerFailures Class


BuiltInFailures.RebarFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..RebarFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Rebar.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class RebarFailures
Visual Basic
Public NotInheritable Class RebarFailures
Visual C++
public ref class RebarFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..RebarFailures

See Also

BuiltInFailures..::..RebarFailures Members


BuiltInFailures.RebarFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..RebarFailures Members
BuiltInFailures..::..RebarFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..RebarFailures type exposes the following members.

Properties

Name | Description
BarDiameterTooLarge | Rebar Bar Diameter is too large.
BarTypeDoesNotAllowHooksOfCurrentShape | You have selected a Bar Type which does not allow the Hooks used by the current shape. Please select a different Shape / Bar Type combination, or change the Hook permissions for the desired Bar Type (see Hook Lengths under Rebar Bar properties).
BendDiameterTooLarge | Rebar Bend Diameter is too large.
BendDiameterTooSmall | Rebar Bend Diameter is too small.
CannotCreateFreeFormSetDueToShortBar | Cannot create the rebar set using the current references because at least one bar is below the minimum allowed length. Edit the covers and extents of the set and try the desired layout options again.
CannotKeepVariabilityOfRebarInGroup | Modifications to the rebar set might cause it to revert to a uniform distribution. This can occur for layout changes as well as modifications to the geometry.
CannotPlaceRebar | Can't find a host for Rebar.
CannotPlaceRebarWarn | Can't find a host for Rebar.
CannotSolveRebarShapeUsingDataFromDimension | Cannot solve rebar shape using the current constraints.
CannotSolveRebarWithDelayedConstraints | There are rebar handles with invalid selected targets to constrain. The bar preview corresponds to latest valid constraints.
CantMakeFillets | The bar cannot be bent in that shape. Check the bending diameter and the bar type.
ChangeUnitsFormatWarn | The modification of the unit will cause the change of the Reinforcement rounding format. Do you want to continue?
ClearPresentationForAllBarsInRebarSet | All Bars in a Free Form Rebar Set have been hidden.
CoverTooLong | Rebar Cover length is too large for host thickness.
DelayedConstraintForHandle | The selected constraint targets do not satisfy a valid constraint. The rebar preview corresponds to latest valid rebar constraints.
HideAllBarsInRebarSet | All Bars in Rebar Set have been hidden.
HostTopologyChange | A reinforced host has undergone a major change. The reinforcement must be removed.
IncompleteShape | Rebar Shape [Family Name] is not fully defined and cannot be loaded into the project.
InvalidRebarHost | Rebar can be placed only in Concrete Structural elements.
InvalidRebarHostFamilyCanHostRebarParam | Rebar can't be placed in this Generic Model element because rebar hosting is disabled in the family [Name].
InvalidRebarHostNonConcrete | Rebar can't be placed in a structural family unless its [Material Type] is [Concrete].
InvalidRebarHostNonStructural | Rebar can't be placed in a non-structural element.
InvalidRebarHostWrongCategory | Rebar can't be placed in a family of category [Name].
Inverted3dShape | The Rebar Shape XX cannot be inverted.
MaxHookExtensionMultiplierWarn | The allowable range of values for the Rebar Hook Extension Multiplier is from 0.01 to 99.0.
MissingCurrentConstraintForHandle | The current handle has no constraint. Please select a valid target to apply a new constraint.
NoRebarSelected | At least one Rebar should be selected.
NoSurfPatternOnRebar | Rebar elements do not support surface patterns. The surface pattern associated with this material will not be displayed on the indicated Rebar Type.
NoVisibleRebarHandle | Editing of the constraints for the selected rebar with free form geometry is not available. However, the default automatic constraints may still work.
NoVisibleTargetsForCurrentConstraint | There are no visible constraint targets in the current view. Please switch to another view.
OutOfPlaneBendDiameterTooSmall | The Out of Plane Bend Diameter for Rebar Shape XX is too small for Rebar Bar Type YY.
OutSideOfHost | Rebar is placed completely outside of its host.
PathShapeFailure | Can't solve Rebar Shape in Path Reinforcement.
RebarArrayTooShort | Rebar Set can't have coincident Bars.
RebarBendRadiusTooBig | Rebar Bend Radius is too big. Ignoring bend.
RebarBendRadiusTooBigWarn | Rebar Bend Radius is too big. Ignoring bend.
RebarConstraintWarning | Structural rebar have automatic constraints that may conflict with dimensional constraints. Using dimensional constraints with structural rebar is not recommended and should be avoided.\nGrouped structural rebar is the only exception to this recommendation, since the automatic constraints are removed on grouped rebar.
RebarContainerOutSideOfHostWarning | Rebar Container is placed completely outside of its host.
RebarDimensionalConstraintLost | Dimensional constraint on Rebar element was lost on upgrade.
RebarEndTreatmentOverHook | Cannot set end treatment at an end that has hook.
RebarHookOverEndTreatment | Cannot set hook at an end that has end treatment.
RebarHooksDontMatchShape | The Rebar's hooks do not match its Rebar Shape.
RebarIllegalBarType | There is Structural Rebar present in the project that no longer meet the criteria defined in Allowable Rebar Bar types parameter. Please review all existing Structural Rebar created with this Shape.
RebarInvalidDiameterRemoved | Invalid RebarBarType was removed on upgrade.
RebarMovedBarsOverlapped | There are identical overlapping bars in the rebar set. This will result in double counting in schedules.
RebarNoConstraints | The constraints for the rebar with free form geometry are not set or modifications have caused the automatic constraints to be deleted. You can use Edit Constraints to assign new bar constraints.
RebarNoMatchingHooks | The Rebar Shape '[Family Name]' has no matching hooks.
RebarShapeFailure | Can't solve Rebar Shape.
RebarShapeFailureCustomError | '[ErrorMessage]'
RebarShapeFailureCustomWarning | '[ErrorMessage]'
RebarSpacingTooSmall | Bar Spacing is too small.
RebarTooShortImperial | The minimum length of rebar shape is 1 inch.
RebarTooShortMetric | The minimum length of rebar shape is 25 mm.
SketchDimensionsRemoved | The sketch dimensions, that were used to create the sketch, have been removed from the completed rebar shape definition.
SketchDimsBWFRemoved | The sketch dimensions, that were used to create the sketch, have been removed from the completed bend profile definition.
SketchFreeFormSet | Sketching of a free form set produces only a single bar.
SketchNonPlanarFreeForm | The selected free form rebar is not planar. Sketching it will discard the current geometry.
StandardHookBendDiameterTooLarge | Rebar Standard Hook Bend Diameter is too large.
StandardHookBendDiameterTooSmall | Rebar Standard Hook Bend Diameter is too small.
TooLargeNumberOfBars | Rebar Set must contain at most 1002 bar locations.
TooSmallNumberOfBars | Rebar Set must contain at least two bar locations.
TrySmallerBarType | Rebar Bend Diameter is too large. Try a smaller Bar Type.
UnconstrainableRebarHandle | The rebar handle does not have any constraint targets.

See Also

BuiltInFailures..::..RebarFailures Class


BuiltInFailures.RebarFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..RebarFailures Properties
BuiltInFailures..::..RebarFailures Class See Also Send Feedback

The BuiltInFailures..::..RebarFailures type exposes the following members.

Properties

Name | Description
BarDiameterTooLarge | Rebar Bar Diameter is too large.
BarTypeDoesNotAllowHooksOfCurrentShape | You have selected a Bar Type which does not allow the Hooks used by the current shape. Please select a different Shape / Bar Type combination, or change the Hook permissions for the desired Bar Type (see Hook Lengths under Rebar Bar properties).
BendDiameterTooLarge | Rebar Bend Diameter is too large.
BendDiameterTooSmall | Rebar Bend Diameter is too small.
CannotCreateFreeFormSetDueToShortBar | Cannot create the rebar set using the current references because at least one bar is below the minimum allowed length. Edit the covers and extents of the set and try the desired layout options again.
CannotKeepVariabilityOfRebarInGroup | Modifications to the rebar set might cause it to revert to a uniform distribution. This can occur for layout changes as well as modifications to the geometry.
CannotPlaceRebar | Can't find a host for Rebar.
CannotPlaceRebarWarn | Can't find a host for Rebar.
CannotSolveRebarShapeUsingDataFromDimension | Cannot solve rebar shape using the current constraints.
CannotSolveRebarWithDelayedConstraints | There are rebar handles with invalid selected targets to constrain. The bar preview corresponds to latest valid constraints.
CantMakeFillets | The bar cannot be bent in that shape. Check the bending diameter and the bar type.
ChangeUnitsFormatWarn | The modification of the unit will cause the change of the Reinforcement rounding format. Do you want to continue?
ClearPresentationForAllBarsInRebarSet | All Bars in a Free Form Rebar Set have been hidden.
CoverTooLong | Rebar Cover length is too large for host thickness.
DelayedConstraintForHandle | The selected constraint targets do not satisfy a valid constraint. The rebar preview corresponds to latest valid rebar constraints.
HideAllBarsInRebarSet | All Bars in Rebar Set have been hidden.
HostTopologyChange | A reinforced host has undergone a major change. The reinforcement must be removed.
IncompleteShape | Rebar Shape [Family Name] is not fully defined and cannot be loaded into the project.
InvalidRebarHost | Rebar can be placed only in Concrete Structural elements.
InvalidRebarHostFamilyCanHostRebarParam | Rebar can't be placed in this Generic Model element because rebar hosting is disabled in the family [Name].
InvalidRebarHostNonConcrete | Rebar can't be placed in a structural family unless its [Material Type] is [Concrete].
InvalidRebarHostNonStructural | Rebar can't be placed in a non-structural element.
InvalidRebarHostWrongCategory | Rebar can't be placed in a family of category [Name].
Inverted3dShape | The Rebar Shape XX cannot be inverted.
MaxHookExtensionMultiplierWarn | The allowable range of values for the Rebar Hook Extension Multiplier is from 0.01 to 99.0.
MissingCurrentConstraintForHandle | The current handle has no constraint. Please select a valid target to apply a new constraint.
NoRebarSelected | At least one Rebar should be selected.
NoSurfPatternOnRebar | Rebar elements do not support surface patterns. The surface pattern associated with this material will not be displayed on the indicated Rebar Type.
NoVisibleRebarHandle | Editing of the constraints for the selected rebar with free form geometry is not available. However, the default automatic constraints may still work.
NoVisibleTargetsForCurrentConstraint | There are no visible constraint targets in the current view. Please switch to another view.
OutOfPlaneBendDiameterTooSmall | The Out of Plane Bend Diameter for Rebar Shape XX is too small for Rebar Bar Type YY.
OutSideOfHost | Rebar is placed completely outside of its host.
PathShapeFailure | Can't solve Rebar Shape in Path Reinforcement.
RebarArrayTooShort | Rebar Set can't have coincident Bars.
RebarBendRadiusTooBig | Rebar Bend Radius is too big. Ignoring bend.
RebarBendRadiusTooBigWarn | Rebar Bend Radius is too big. Ignoring bend.
RebarConstraintWarning | Structural rebar have automatic constraints that may conflict with dimensional constraints. Using dimensional constraints with structural rebar is not recommended and should be avoided.\nGrouped structural rebar is the only exception to this recommendation, since the automatic constraints are removed on grouped rebar.
RebarContainerOutSideOfHostWarning | Rebar Container is placed completely outside of its host.
RebarDimensionalConstraintLost | Dimensional constraint on Rebar element was lost on upgrade.
RebarEndTreatmentOverHook | Cannot set end treatment at an end that has hook.
RebarHookOverEndTreatment | Cannot set hook at an end that has end treatment.
RebarHooksDontMatchShape | The Rebar's hooks do not match its Rebar Shape.
RebarIllegalBarType | There is Structural Rebar present in the project that no longer meet the criteria defined in Allowable Rebar Bar types parameter. Please review all existing Structural Rebar created with this Shape.
RebarInvalidDiameterRemoved | Invalid RebarBarType was removed on upgrade.
RebarMovedBarsOverlapped | There are identical overlapping bars in the rebar set. This will result in double counting in schedules.
RebarNoConstraints | The constraints for the rebar with free form geometry are not set or modifications have caused the automatic constraints to be deleted. You can use Edit Constraints to assign new bar constraints.
RebarNoMatchingHooks | The Rebar Shape '[Family Name]' has no matching hooks.
RebarShapeFailure | Can't solve Rebar Shape.
RebarShapeFailureCustomError | '[ErrorMessage]'
RebarShapeFailureCustomWarning | '[ErrorMessage]'
RebarSpacingTooSmall | Bar Spacing is too small.
RebarTooShortImperial | The minimum length of rebar shape is 1 inch.
RebarTooShortMetric | The minimum length of rebar shape is 25 mm.
SketchDimensionsRemoved | The sketch dimensions, that were used to create the sketch, have been removed from the completed rebar shape definition.
SketchDimsBWFRemoved | The sketch dimensions, that were used to create the sketch, have been removed from the completed bend profile definition.
SketchFreeFormSet | Sketching of a free form set produces only a single bar.
SketchNonPlanarFreeForm | The selected free form rebar is not planar. Sketching it will discard the current geometry.
StandardHookBendDiameterTooLarge | Rebar Standard Hook Bend Diameter is too large.
StandardHookBendDiameterTooSmall | Rebar Standard Hook Bend Diameter is too small.
TooLargeNumberOfBars | Rebar Set must contain at most 1002 bar locations.
TooSmallNumberOfBars | Rebar Set must contain at least two bar locations.
TrySmallerBarType | Rebar Bend Diameter is too large. Try a smaller Bar Type.
UnconstrainableRebarHandle | The rebar handle does not have any constraint targets.

See Also

BuiltInFailures..::..RebarFailures Class


BendDiameterTooLarge Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarFailures..::..BendDiameterTooLarge Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Rebar Bend Diameter is too large.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId BendDiameterTooLarge { get; }
Visual Basic
Public Shared ReadOnly Property BendDiameterTooLarge As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BendDiameterTooLarge {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


CannotKeepVariabilityOfRebarInGroup Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarFailures..::..CannotKeepVariabilityOfRebarInGroup Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Modifications to the rebar set might cause it to revert to a uniform distribution. This can occur for layout changes as well as modifications to the geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotKeepVariabilityOfRebarInGroup { get; }
Visual Basic
Public Shared ReadOnly Property CannotKeepVariabilityOfRebarInGroup As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotKeepVariabilityOfRebarInGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


CannotPlaceRebar Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarFailures..::..CannotPlaceRebar Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Can't find a host for Rebar.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotPlaceRebar { get; }
Visual Basic
Public Shared ReadOnly Property CannotPlaceRebar As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPlaceRebar {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


CannotPlaceRebarWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarFailures..::..CannotPlaceRebarWarn Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Can't find a host for Rebar.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotPlaceRebarWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotPlaceRebarWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPlaceRebarWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


CannotSolveRebarShapeUsingDataFromDimension Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarFailures..::..CannotSolveRebarShapeUsingDataFromDimension Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Cannot solve rebar shape using the current constraints.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotSolveRebarShapeUsingDataFromDimension { get; }
Visual Basic
Public Shared ReadOnly Property CannotSolveRebarShapeUsingDataFromDimension As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotSolveRebarShapeUsingDataFromDimension {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


CannotSolveRebarWithDelayedConstraints Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarFailures..::..CannotSolveRebarWithDelayedConstraints Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
There are rebar handles with invalid selected targets to constrain. The bar preview corresponds to latest valid constraints.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotSolveRebarWithDelayedConstraints { get; }
Visual Basic
Public Shared ReadOnly Property CannotSolveRebarWithDelayedConstraints As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotSolveRebarWithDelayedConstraints {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


CantMakeFillets Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarFailures..::..CantMakeFillets Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
The bar cannot be bent in that shape. Check the bending diameter and the bar type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CantMakeFillets { get; }
Visual Basic
Public Shared ReadOnly Property CantMakeFillets As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CantMakeFillets {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


ClearPresentationForAllBarsInRebarSet Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarFailures..::..ClearPresentationForAllBarsInRebarSet Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
All Bars in a Free Form Rebar Set have been hidden.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ClearPresentationForAllBarsInRebarSet { get; }
Visual Basic
Public Shared ReadOnly Property ClearPresentationForAllBarsInRebarSet As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ClearPresentationForAllBarsInRebarSet {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


CoverTooLong Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarFailures..::..CoverTooLong Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Rebar Cover length is too large for host thickness.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CoverTooLong { get; }
Visual Basic
Public Shared ReadOnly Property CoverTooLong As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CoverTooLong {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


DelayedConstraintForHandle Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarFailures..::..DelayedConstraintForHandle Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
The selected constraint targets do not satisfy a valid constraint. The rebar preview corresponds to latest valid rebar constraints.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DelayedConstraintForHandle { get; }
Visual Basic
Public Shared ReadOnly Property DelayedConstraintForHandle As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DelayedConstraintForHandle {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


HideAllBarsInRebarSet Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarFailures..::..HideAllBarsInRebarSet Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
All Bars in Rebar Set have been hidden.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId HideAllBarsInRebarSet { get; }
Visual Basic
Public Shared ReadOnly Property HideAllBarsInRebarSet As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HideAllBarsInRebarSet {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


HostTopologyChange Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarFailures..::..HostTopologyChange Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
A reinforced host has undergone a major change. The reinforcement must be removed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId HostTopologyChange { get; }
Visual Basic
Public Shared ReadOnly Property HostTopologyChange As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HostTopologyChange {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


IncompleteShape Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarFailures..::..IncompleteShape Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Rebar Shape [Family Name] is not fully defined and cannot be loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId IncompleteShape { get; }
Visual Basic
Public Shared ReadOnly Property IncompleteShape As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ IncompleteShape {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


InvalidRebarHostNonConcrete Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarFailures..::..InvalidRebarHostNonConcrete Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Rebar can't be placed in a structural family unless its [Material Type] is [Concrete].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidRebarHostNonConcrete { get; }
Visual Basic
Public Shared ReadOnly Property InvalidRebarHostNonConcrete As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidRebarHostNonConcrete {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


InvalidRebarHostNonStructural Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarFailures..::..InvalidRebarHostNonStructural Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Rebar can't be placed in a non-structural element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidRebarHostNonStructural { get; }
Visual Basic
Public Shared ReadOnly Property InvalidRebarHostNonStructural As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidRebarHostNonStructural {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


InvalidRebarHostWrongCategory Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarFailures..::..InvalidRebarHostWrongCategory Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Rebar can't be placed in a family of category [Name].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidRebarHostWrongCategory { get; }
Visual Basic
Public Shared ReadOnly Property InvalidRebarHostWrongCategory As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidRebarHostWrongCategory {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


Inverted3dShape Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarFailures..::..Inverted3dShape Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
The Rebar Shape XX cannot be inverted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId Inverted3dShape { get; }
Visual Basic
Public Shared ReadOnly Property Inverted3dShape As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ Inverted3dShape {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


MaxHookExtensionMultiplierWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarFailures..::..MaxHookExtensionMultiplierWarn Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
The allowable range of values for the Rebar Hook Extension Multiplier is from 0.01 to 99.0.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MaxHookExtensionMultiplierWarn { get; }
Visual Basic
Public Shared ReadOnly Property MaxHookExtensionMultiplierWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MaxHookExtensionMultiplierWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


NoSurfPatternOnRebar Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarFailures..::..NoSurfPatternOnRebar Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Rebar elements do not support surface patterns. The surface pattern associated with this material will not be displayed on the indicated Rebar Type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoSurfPatternOnRebar { get; }
Visual Basic
Public Shared ReadOnly Property NoSurfPatternOnRebar As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoSurfPatternOnRebar {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


NoVisibleRebarHandle Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarFailures..::..NoVisibleRebarHandle Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Editing of the constraints for the selected rebar with free form geometry is not available. However, the default automatic constraints may still work.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoVisibleRebarHandle { get; }
Visual Basic
Public Shared ReadOnly Property NoVisibleRebarHandle As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoVisibleRebarHandle {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


NoVisibleTargetsForCurrentConstraint Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarFailures..::..NoVisibleTargetsForCurrentConstraint Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
There are no visible constraint targets in the current view. Please switch to another view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoVisibleTargetsForCurrentConstraint { get; }
Visual Basic
Public Shared ReadOnly Property NoVisibleTargetsForCurrentConstraint As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoVisibleTargetsForCurrentConstraint {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


OutOfPlaneBendDiameterTooSmall Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarFailures..::..OutOfPlaneBendDiameterTooSmall Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
The Out of Plane Bend Diameter for Rebar Shape XX is too small for Rebar Bar Type YY.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId OutOfPlaneBendDiameterTooSmall { get; }
Visual Basic
Public Shared ReadOnly Property OutOfPlaneBendDiameterTooSmall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OutOfPlaneBendDiameterTooSmall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


OutSideOfHost Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarFailures..::..OutSideOfHost Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Rebar is placed completely outside of its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId OutSideOfHost { get; }
Visual Basic
Public Shared ReadOnly Property OutSideOfHost As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OutSideOfHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


PathShapeFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarFailures..::..PathShapeFailure Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Can't solve Rebar Shape in Path Reinforcement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId PathShapeFailure { get; }
Visual Basic
Public Shared ReadOnly Property PathShapeFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PathShapeFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


RebarArrayTooShort Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarFailures..::..RebarArrayTooShort Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Rebar Set can't have coincident Bars.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RebarArrayTooShort { get; }
Visual Basic
Public Shared ReadOnly Property RebarArrayTooShort As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RebarArrayTooShort {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


RebarBendRadiusTooBigWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarFailures..::..RebarBendRadiusTooBigWarn Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Rebar Bend Radius is too big. Ignoring bend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RebarBendRadiusTooBigWarn { get; }
Visual Basic
Public Shared ReadOnly Property RebarBendRadiusTooBigWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RebarBendRadiusTooBigWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


RebarConstraintWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarFailures..::..RebarConstraintWarning Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Structural rebar have automatic constraints that may conflict with dimensional constraints. Using dimensional constraints with structural rebar is not recommended and should be avoided.\nGrouped structural rebar is the only exception to this recommendation, since the automatic constraints are removed on grouped rebar.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RebarConstraintWarning { get; }
Visual Basic
Public Shared ReadOnly Property RebarConstraintWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RebarConstraintWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


RebarContainerOutSideOfHostWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarFailures..::..RebarContainerOutSideOfHostWarning Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Rebar Container is placed completely outside of its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RebarContainerOutSideOfHostWarning { get; }
Visual Basic
Public Shared ReadOnly Property RebarContainerOutSideOfHostWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RebarContainerOutSideOfHostWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


RebarDimensionalConstraintLost Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarFailures..::..RebarDimensionalConstraintLost Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Dimensional constraint on Rebar element was lost on upgrade.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RebarDimensionalConstraintLost { get; }
Visual Basic
Public Shared ReadOnly Property RebarDimensionalConstraintLost As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RebarDimensionalConstraintLost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


RebarEndTreatmentOverHook Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarFailures..::..RebarEndTreatmentOverHook Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Cannot set end treatment at an end that has hook.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RebarEndTreatmentOverHook { get; }
Visual Basic
Public Shared ReadOnly Property RebarEndTreatmentOverHook As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RebarEndTreatmentOverHook {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


RebarHookOverEndTreatment Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarFailures..::..RebarHookOverEndTreatment Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Cannot set hook at an end that has end treatment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RebarHookOverEndTreatment { get; }
Visual Basic
Public Shared ReadOnly Property RebarHookOverEndTreatment As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RebarHookOverEndTreatment {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


RebarMovedBarsOverlapped Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarFailures..::..RebarMovedBarsOverlapped Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
There are identical overlapping bars in the rebar set. This will result in double counting in schedules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RebarMovedBarsOverlapped { get; }
Visual Basic
Public Shared ReadOnly Property RebarMovedBarsOverlapped As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RebarMovedBarsOverlapped {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


RebarNoConstraints Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarFailures..::..RebarNoConstraints Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
The constraints for the rebar with free form geometry are not set or modifications have caused the automatic constraints to be deleted. You can use Edit Constraints to assign new bar constraints.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RebarNoConstraints { get; }
Visual Basic
Public Shared ReadOnly Property RebarNoConstraints As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RebarNoConstraints {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


RebarNoMatchingHooks Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarFailures..::..RebarNoMatchingHooks Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
The Rebar Shape '[Family Name]' has no matching hooks.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RebarNoMatchingHooks { get; }
Visual Basic
Public Shared ReadOnly Property RebarNoMatchingHooks As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RebarNoMatchingHooks {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


RebarShapeFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarFailures..::..RebarShapeFailure Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Can't solve Rebar Shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RebarShapeFailure { get; }
Visual Basic
Public Shared ReadOnly Property RebarShapeFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RebarShapeFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


RebarShapeFailureCustomError Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarFailures..::..RebarShapeFailureCustomError Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
'[ErrorMessage]'

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RebarShapeFailureCustomError { get; }
Visual Basic
Public Shared ReadOnly Property RebarShapeFailureCustomError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RebarShapeFailureCustomError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


RebarShapeFailureCustomWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarFailures..::..RebarShapeFailureCustomWarning Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
'[ErrorMessage]'

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RebarShapeFailureCustomWarning { get; }
Visual Basic
Public Shared ReadOnly Property RebarShapeFailureCustomWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RebarShapeFailureCustomWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


RebarSpacingTooSmall Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarFailures..::..RebarSpacingTooSmall Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Bar Spacing is too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RebarSpacingTooSmall { get; }
Visual Basic
Public Shared ReadOnly Property RebarSpacingTooSmall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RebarSpacingTooSmall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


RebarTooShortImperial Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarFailures..::..RebarTooShortImperial Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
The minimum length of rebar shape is 1 inch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RebarTooShortImperial { get; }
Visual Basic
Public Shared ReadOnly Property RebarTooShortImperial As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RebarTooShortImperial {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


RebarTooShortMetric Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarFailures..::..RebarTooShortMetric Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
The minimum length of rebar shape is 25 mm.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RebarTooShortMetric { get; }
Visual Basic
Public Shared ReadOnly Property RebarTooShortMetric As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RebarTooShortMetric {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


SketchFreeFormSet Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarFailures..::..SketchFreeFormSet Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Sketching of a free form set produces only a single bar.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SketchFreeFormSet { get; }
Visual Basic
Public Shared ReadOnly Property SketchFreeFormSet As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SketchFreeFormSet {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


SketchNonPlanarFreeForm Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarFailures..::..SketchNonPlanarFreeForm Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
The selected free form rebar is not planar. Sketching it will discard the current geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SketchNonPlanarFreeForm { get; }
Visual Basic
Public Shared ReadOnly Property SketchNonPlanarFreeForm As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SketchNonPlanarFreeForm {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


StandardHookBendDiameterTooLarge Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarFailures..::..StandardHookBendDiameterTooLarge Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Rebar Standard Hook Bend Diameter is too large.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StandardHookBendDiameterTooLarge { get; }
Visual Basic
Public Shared ReadOnly Property StandardHookBendDiameterTooLarge As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StandardHookBendDiameterTooLarge {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


StandardHookBendDiameterTooSmall Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarFailures..::..StandardHookBendDiameterTooSmall Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Rebar Standard Hook Bend Diameter is too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StandardHookBendDiameterTooSmall { get; }
Visual Basic
Public Shared ReadOnly Property StandardHookBendDiameterTooSmall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StandardHookBendDiameterTooSmall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


TooLargeNumberOfBars Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarFailures..::..TooLargeNumberOfBars Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Rebar Set must contain at most 1002 bar locations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId TooLargeNumberOfBars { get; }
Visual Basic
Public Shared ReadOnly Property TooLargeNumberOfBars As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TooLargeNumberOfBars {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


TooSmallNumberOfBars Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarFailures..::..TooSmallNumberOfBars Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Rebar Set must contain at least two bar locations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId TooSmallNumberOfBars { get; }
Visual Basic
Public Shared ReadOnly Property TooSmallNumberOfBars As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TooSmallNumberOfBars {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


TrySmallerBarType Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarFailures..::..TrySmallerBarType Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Rebar Bend Diameter is too large. Try a smaller Bar Type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId TrySmallerBarType { get; }
Visual Basic
Public Shared ReadOnly Property TrySmallerBarType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TrySmallerBarType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


UnconstrainableRebarHandle Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarFailures..::..UnconstrainableRebarHandle Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
The rebar handle does not have any constraint targets.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UnconstrainableRebarHandle { get; }
Visual Basic
Public Shared ReadOnly Property UnconstrainableRebarHandle As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnconstrainableRebarHandle {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


BuiltInFailures.RebarShapeFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..RebarShapeFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about RebarShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class RebarShapeFailures
Visual Basic
Public NotInheritable Class RebarShapeFailures
Visual C++
public ref class RebarShapeFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..RebarShapeFailures

See Also

BuiltInFailures..::..RebarShapeFailures Members


BuiltInFailures.RebarShapeFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..RebarShapeFailures Members
BuiltInFailures..::..RebarShapeFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..RebarShapeFailures type exposes the following members.

Properties

Name | Description
CircleMultiPlanarShape | A circle can't be converted to multiplanar shape.
CircleUnbounded | An unbounded circle can only be used to construct a spiral shape.
CurveOverconstrained | Segment is overconstrained. It has at least one parameterized dimension that conflicts with another dimension.
CurvesCollinear | Collinear segments are not allowed in a Rebar Shape definition.
CurvesUnlooped | Segments defining the Rebar Shape must be in a continuous loop.
CurveUnderconstrained | Segment is underconstrained. It requires additional parameterized dimensions.
DefaultParamaterValuesIncorrect | Default parameters have incorrect values. One reason for failure might be an edge length that is too short (it's smaller than bent radius).
DepthDimensionNotExisted | Multi-planar shape's depth dimension has been deleted. Please assign a new one to multi-planar depth.
DiagonalEdgesAreUnderconstrained | Shape is underconstrained. Please add additional dimension constraints to the shape's diagonal edges. (Diagonal segments with only one dimension constraint are automatically given a second constraint to lie at an angle of exactly 45 degrees, regardless of how they are drawn. The current shape has more than one such segment in sequence, and the resulting constrained edges are co-linear.)
DimensionLoose | This dimension cannot be used to parameterize the Rebar Shape.
DimensionWithCommonLengthUnit | A shape dimension is labelled with a parameter that uses the Common Length unit.
DimensionWithoutParameter | Dimension has no parameter assigned to it.
FormulaDrivenDimension | Dimension can't be driven by a formula parameter.
HooksAndEndTreatmentAtTheSameEnd | Cannot add hooks and end treatments at the same end.
MultiPlanarDepth | Multi-planar depth of Rebar Shape can't be too small.
MultipleArcsMustOverlap | Multiple arcs are supported only if they are concentric and form a circle with an overlap.
ParameterValueNotDefined | Parameter assigned to the dimension has no value defined.
PlanarMultiPlanarShape | The current shape is only bent in a single plane. A multi-planar definition is not required. Please redefine the shape on the top plane only.
ShapeFailure | The displayed Rebar Shape is created using a 'Rebar Bar for Preview'. This bar defines the bend radius displayed in the family. Using this preview bar the drawn shape cannot be completed.
WrongDepthDimensionLabel | Multi-planar depth dimension label is already used for one of the planar shape parameters.

See Also

BuiltInFailures..::..RebarShapeFailures Class


BuiltInFailures.RebarShapeFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..RebarShapeFailures Properties
BuiltInFailures..::..RebarShapeFailures Class See Also Send Feedback

The BuiltInFailures..::..RebarShapeFailures type exposes the following members.

Properties

Name | Description
CircleMultiPlanarShape | A circle can't be converted to multiplanar shape.
CircleUnbounded | An unbounded circle can only be used to construct a spiral shape.
CurveOverconstrained | Segment is overconstrained. It has at least one parameterized dimension that conflicts with another dimension.
CurvesCollinear | Collinear segments are not allowed in a Rebar Shape definition.
CurvesUnlooped | Segments defining the Rebar Shape must be in a continuous loop.
CurveUnderconstrained | Segment is underconstrained. It requires additional parameterized dimensions.
DefaultParamaterValuesIncorrect | Default parameters have incorrect values. One reason for failure might be an edge length that is too short (it's smaller than bent radius).
DepthDimensionNotExisted | Multi-planar shape's depth dimension has been deleted. Please assign a new one to multi-planar depth.
DiagonalEdgesAreUnderconstrained | Shape is underconstrained. Please add additional dimension constraints to the shape's diagonal edges. (Diagonal segments with only one dimension constraint are automatically given a second constraint to lie at an angle of exactly 45 degrees, regardless of how they are drawn. The current shape has more than one such segment in sequence, and the resulting constrained edges are co-linear.)
DimensionLoose | This dimension cannot be used to parameterize the Rebar Shape.
DimensionWithCommonLengthUnit | A shape dimension is labelled with a parameter that uses the Common Length unit.
DimensionWithoutParameter | Dimension has no parameter assigned to it.
FormulaDrivenDimension | Dimension can't be driven by a formula parameter.
HooksAndEndTreatmentAtTheSameEnd | Cannot add hooks and end treatments at the same end.
MultiPlanarDepth | Multi-planar depth of Rebar Shape can't be too small.
MultipleArcsMustOverlap | Multiple arcs are supported only if they are concentric and form a circle with an overlap.
ParameterValueNotDefined | Parameter assigned to the dimension has no value defined.
PlanarMultiPlanarShape | The current shape is only bent in a single plane. A multi-planar definition is not required. Please redefine the shape on the top plane only.
ShapeFailure | The displayed Rebar Shape is created using a 'Rebar Bar for Preview'. This bar defines the bend radius displayed in the family. Using this preview bar the drawn shape cannot be completed.
WrongDepthDimensionLabel | Multi-planar depth dimension label is already used for one of the planar shape parameters.

See Also

BuiltInFailures..::..RebarShapeFailures Class


CircleMultiPlanarShape Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarShapeFailures..::..CircleMultiPlanarShape Property
BuiltInFailures..::..RebarShapeFailures Class See Also Send Feedback
A circle can't be converted to multiplanar shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CircleMultiPlanarShape { get; }
Visual Basic
Public Shared ReadOnly Property CircleMultiPlanarShape As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CircleMultiPlanarShape {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarShapeFailures Class


CurvesCollinear Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarShapeFailures..::..CurvesCollinear Property
BuiltInFailures..::..RebarShapeFailures Class See Also Send Feedback
Collinear segments are not allowed in a Rebar Shape definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CurvesCollinear { get; }
Visual Basic
Public Shared ReadOnly Property CurvesCollinear As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CurvesCollinear {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarShapeFailures Class


DefaultParamaterValuesIncorrect Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarShapeFailures..::..DefaultParamaterValuesIncorrect Property
BuiltInFailures..::..RebarShapeFailures Class See Also Send Feedback
Default parameters have incorrect values. One reason for failure might be an edge length that is too short (it's smaller than bent radius).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DefaultParamaterValuesIncorrect { get; }
Visual Basic
Public Shared ReadOnly Property DefaultParamaterValuesIncorrect As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DefaultParamaterValuesIncorrect {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarShapeFailures Class


DiagonalEdgesAreUnderconstrained Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarShapeFailures..::..DiagonalEdgesAreUnderconstrained Property
BuiltInFailures..::..RebarShapeFailures Class See Also Send Feedback
Shape is underconstrained. Please add additional dimension constraints to the shape's diagonal edges. (Diagonal segments with only one dimension constraint are automatically given a second constraint to lie at an angle of exactly 45 degrees, regardless of how they are drawn. The current shape has more than one such segment in sequence, and the resulting constrained edges are co-linear.)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DiagonalEdgesAreUnderconstrained { get; }
Visual Basic
Public Shared ReadOnly Property DiagonalEdgesAreUnderconstrained As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DiagonalEdgesAreUnderconstrained {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarShapeFailures Class


DimensionLoose Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarShapeFailures..::..DimensionLoose Property
BuiltInFailures..::..RebarShapeFailures Class See Also Send Feedback
This dimension cannot be used to parameterize the Rebar Shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DimensionLoose { get; }
Visual Basic
Public Shared ReadOnly Property DimensionLoose As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DimensionLoose {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarShapeFailures Class


DimensionWithCommonLengthUnit Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarShapeFailures..::..DimensionWithCommonLengthUnit Property
BuiltInFailures..::..RebarShapeFailures Class See Also Send Feedback
A shape dimension is labelled with a parameter that uses the Common Length unit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DimensionWithCommonLengthUnit { get; }
Visual Basic
Public Shared ReadOnly Property DimensionWithCommonLengthUnit As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DimensionWithCommonLengthUnit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarShapeFailures Class


FormulaDrivenDimension Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarShapeFailures..::..FormulaDrivenDimension Property
BuiltInFailures..::..RebarShapeFailures Class See Also Send Feedback
Dimension can't be driven by a formula parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FormulaDrivenDimension { get; }
Visual Basic
Public Shared ReadOnly Property FormulaDrivenDimension As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FormulaDrivenDimension {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarShapeFailures Class


HooksAndEndTreatmentAtTheSameEnd Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarShapeFailures..::..HooksAndEndTreatmentAtTheSameEnd Property
BuiltInFailures..::..RebarShapeFailures Class See Also Send Feedback
Cannot add hooks and end treatments at the same end.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId HooksAndEndTreatmentAtTheSameEnd { get; }
Visual Basic
Public Shared ReadOnly Property HooksAndEndTreatmentAtTheSameEnd As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HooksAndEndTreatmentAtTheSameEnd {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarShapeFailures Class


MultiPlanarDepth Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarShapeFailures..::..MultiPlanarDepth Property
BuiltInFailures..::..RebarShapeFailures Class See Also Send Feedback
Multi-planar depth of Rebar Shape can't be too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MultiPlanarDepth { get; }
Visual Basic
Public Shared ReadOnly Property MultiPlanarDepth As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MultiPlanarDepth {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarShapeFailures Class


MultipleArcsMustOverlap Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarShapeFailures..::..MultipleArcsMustOverlap Property
BuiltInFailures..::..RebarShapeFailures Class See Also Send Feedback
Multiple arcs are supported only if they are concentric and form a circle with an overlap.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MultipleArcsMustOverlap { get; }
Visual Basic
Public Shared ReadOnly Property MultipleArcsMustOverlap As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MultipleArcsMustOverlap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarShapeFailures Class


PlanarMultiPlanarShape Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarShapeFailures..::..PlanarMultiPlanarShape Property
BuiltInFailures..::..RebarShapeFailures Class See Also Send Feedback
The current shape is only bent in a single plane. A multi-planar definition is not required. Please redefine the shape on the top plane only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId PlanarMultiPlanarShape { get; }
Visual Basic
Public Shared ReadOnly Property PlanarMultiPlanarShape As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PlanarMultiPlanarShape {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarShapeFailures Class


ShapeFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarShapeFailures..::..ShapeFailure Property
BuiltInFailures..::..RebarShapeFailures Class See Also Send Feedback
The displayed Rebar Shape is created using a 'Rebar Bar for Preview'. This bar defines the bend radius displayed in the family. Using this preview bar the drawn shape cannot be completed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ShapeFailure { get; }
Visual Basic
Public Shared ReadOnly Property ShapeFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ShapeFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarShapeFailures Class


WrongDepthDimensionLabel Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarShapeFailures..::..WrongDepthDimensionLabel Property
BuiltInFailures..::..RebarShapeFailures Class See Also Send Feedback
Multi-planar depth dimension label is already used for one of the planar shape parameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WrongDepthDimensionLabel { get; }
Visual Basic
Public Shared ReadOnly Property WrongDepthDimensionLabel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WrongDepthDimensionLabel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarShapeFailures Class


BuiltInFailures.RebarSystemFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..RebarSystemFailures Members
BuiltInFailures..::..RebarSystemFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..RebarSystemFailures type exposes the following members.

Properties

Name | Description
AreaReinforcementOutSideOfHost | Area Reinforcement is sketched completely outside of its host.
AreaReinforcementRegenFail | Can't regenerate Area Reinforcement.
AreaReinforcementsCollision | Area Reinforcements are colliding. Aligning the Major Directions, or changing the Additional Offsets, can prevent collision.
AreaReinforcementWrongHost | Area Reinforcement can be placed only in Structural Floors and straight Structural Walls.
BarsTooCloseNumber | Bars are too close together. Decrease the Number Of Lines parameter.
BarsTooCloseSpacing | Bars are too close together. Increase the Maximum Spacing parameter.
BarsTooSparseSpacing | Bar spacing is greater than the size of the reinforced region. Decrease the Maximum Spacing parameter.
CannotPlaceAreaReinforcement | Can't find a host for Area Reinforcement.
CannotPlaceAreaReinforcementWarn | Can't find a host for Area Reinforcement.
CannotPlaceAreaReininforcement | Can't find a host for Area Reinforcement.
CannotPlaceAreaReininforcementWarn | Can't find a host for Area Reinforcement.
CannotPlacePathReinforcement | Can't find a host for Path Reinforcement.
CannotPlacePathReinforcementWarn | Can't find a host for Path Reinforcement.
CannotPlacePathReininforcement | Can't find a host for Path Reinforcement.
CannotPlacePathReininforcementWarn | Can't find a host for Path Reinforcement.
CannotUseAreaReinforcementHookTypeStyle | At least one of the bars in the Area Reinforcement has a Bar Type or Shape that is incompatible with the Hook type. Check the Hook permissions for the Bar Type (see Hook Lengths) and the Hook and Rebar Shape styles.
CannotUsePathReinforcementHookTypeStyle | At least one of the bars in the Path Reinforcement has a Bar Type or Shape that is incompatible with the Hook type. Check the Hook permissions for the Bar Type (see Hook Lengths) and the Hook and Rebar Shape styles.
DPartReinfDeletedEditDivision | Edits to the model will cause some Reinforcement hosted on Parts to be deleted.
DPartReinforcementDeleted | Reinforcement hosted on highlighted Parts will be deleted.
HostFlagAreaOff |
HostFlagAreaOn | The Area Reinforcement element was created in a document with the Host Structural Rebar setting on, and cannot be transferred into this document, which has the setting off.
HostFlagPathOff |
HostFlagPathOn |
LessThanTwoBars | Each reinforcement direction requires at least 2 bars. Please increase the number of bars.
PathReinforcementWrongHost | Path Reinforcement can be placed only in Structural Floors and straight Structural Walls.
RebarSystemOffset | Rebar Cover Side/Edge is too large for sketch. Bar placement may be inaccurate.
ThinHostFloor | Rebar Cover Top and Bottom are too large for host.
ThinHostFloorError | Rebar Cover Top and Bottom are too large for host.
ThinHostWall | Rebar Cover Interior and Exterior are too large for host.
ThinHostWallError | Rebar Cover Interior and Exterior are too large for host.

See Also

BuiltInFailures..::..RebarSystemFailures Class


BuiltInFailures.RebarSystemFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..RebarSystemFailures Properties
BuiltInFailures..::..RebarSystemFailures Class See Also Send Feedback

The BuiltInFailures..::..RebarSystemFailures type exposes the following members.

Properties

Name | Description
AreaReinforcementOutSideOfHost | Area Reinforcement is sketched completely outside of its host.
AreaReinforcementRegenFail | Can't regenerate Area Reinforcement.
AreaReinforcementsCollision | Area Reinforcements are colliding. Aligning the Major Directions, or changing the Additional Offsets, can prevent collision.
AreaReinforcementWrongHost | Area Reinforcement can be placed only in Structural Floors and straight Structural Walls.
BarsTooCloseNumber | Bars are too close together. Decrease the Number Of Lines parameter.
BarsTooCloseSpacing | Bars are too close together. Increase the Maximum Spacing parameter.
BarsTooSparseSpacing | Bar spacing is greater than the size of the reinforced region. Decrease the Maximum Spacing parameter.
CannotPlaceAreaReinforcement | Can't find a host for Area Reinforcement.
CannotPlaceAreaReinforcementWarn | Can't find a host for Area Reinforcement.
CannotPlaceAreaReininforcement | Can't find a host for Area Reinforcement.
CannotPlaceAreaReininforcementWarn | Can't find a host for Area Reinforcement.
CannotPlacePathReinforcement | Can't find a host for Path Reinforcement.
CannotPlacePathReinforcementWarn | Can't find a host for Path Reinforcement.
CannotPlacePathReininforcement | Can't find a host for Path Reinforcement.
CannotPlacePathReininforcementWarn | Can't find a host for Path Reinforcement.
CannotUseAreaReinforcementHookTypeStyle | At least one of the bars in the Area Reinforcement has a Bar Type or Shape that is incompatible with the Hook type. Check the Hook permissions for the Bar Type (see Hook Lengths) and the Hook and Rebar Shape styles.
CannotUsePathReinforcementHookTypeStyle | At least one of the bars in the Path Reinforcement has a Bar Type or Shape that is incompatible with the Hook type. Check the Hook permissions for the Bar Type (see Hook Lengths) and the Hook and Rebar Shape styles.
DPartReinfDeletedEditDivision | Edits to the model will cause some Reinforcement hosted on Parts to be deleted.
DPartReinforcementDeleted | Reinforcement hosted on highlighted Parts will be deleted.
HostFlagAreaOff |
HostFlagAreaOn | The Area Reinforcement element was created in a document with the Host Structural Rebar setting on, and cannot be transferred into this document, which has the setting off.
HostFlagPathOff |
HostFlagPathOn |
LessThanTwoBars | Each reinforcement direction requires at least 2 bars. Please increase the number of bars.
PathReinforcementWrongHost | Path Reinforcement can be placed only in Structural Floors and straight Structural Walls.
RebarSystemOffset | Rebar Cover Side/Edge is too large for sketch. Bar placement may be inaccurate.
ThinHostFloor | Rebar Cover Top and Bottom are too large for host.
ThinHostFloorError | Rebar Cover Top and Bottom are too large for host.
ThinHostWall | Rebar Cover Interior and Exterior are too large for host.
ThinHostWallError | Rebar Cover Interior and Exterior are too large for host.

See Also

BuiltInFailures..::..RebarSystemFailures Class


AreaReinforcementOutSideOfHost Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarSystemFailures..::..AreaReinforcementOutSideOfHost Property
BuiltInFailures..::..RebarSystemFailures Class See Also Send Feedback
Area Reinforcement is sketched completely outside of its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AreaReinforcementOutSideOfHost { get; }
Visual Basic
Public Shared ReadOnly Property AreaReinforcementOutSideOfHost As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AreaReinforcementOutSideOfHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarSystemFailures Class


AreaReinforcementRegenFail Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarSystemFailures..::..AreaReinforcementRegenFail Property
BuiltInFailures..::..RebarSystemFailures Class See Also Send Feedback
Can't regenerate Area Reinforcement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AreaReinforcementRegenFail { get; }
Visual Basic
Public Shared ReadOnly Property AreaReinforcementRegenFail As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AreaReinforcementRegenFail {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarSystemFailures Class


AreaReinforcementWrongHost Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarSystemFailures..::..AreaReinforcementWrongHost Property
BuiltInFailures..::..RebarSystemFailures Class See Also Send Feedback
Area Reinforcement can be placed only in Structural Floors and straight Structural Walls.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AreaReinforcementWrongHost { get; }
Visual Basic
Public Shared ReadOnly Property AreaReinforcementWrongHost As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AreaReinforcementWrongHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarSystemFailures Class


BarsTooCloseNumber Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarSystemFailures..::..BarsTooCloseNumber Property
BuiltInFailures..::..RebarSystemFailures Class See Also Send Feedback
Bars are too close together. Decrease the Number Of Lines parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId BarsTooCloseNumber { get; }
Visual Basic
Public Shared ReadOnly Property BarsTooCloseNumber As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BarsTooCloseNumber {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarSystemFailures Class


BarsTooSparseSpacing Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarSystemFailures..::..BarsTooSparseSpacing Property
BuiltInFailures..::..RebarSystemFailures Class See Also Send Feedback
Bar spacing is greater than the size of the reinforced region. Decrease the Maximum Spacing parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId BarsTooSparseSpacing { get; }
Visual Basic
Public Shared ReadOnly Property BarsTooSparseSpacing As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BarsTooSparseSpacing {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarSystemFailures Class


CannotPlaceAreaReinforcement Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarSystemFailures..::..CannotPlaceAreaReinforcement Property
BuiltInFailures..::..RebarSystemFailures Class See Also Send Feedback
Can't find a host for Area Reinforcement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotPlaceAreaReinforcement { get; }
Visual Basic
Public Shared ReadOnly Property CannotPlaceAreaReinforcement As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPlaceAreaReinforcement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarSystemFailures Class


CannotPlaceAreaReinforcementWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarSystemFailures..::..CannotPlaceAreaReinforcementWarn Property
BuiltInFailures..::..RebarSystemFailures Class See Also Send Feedback
Can't find a host for Area Reinforcement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotPlaceAreaReinforcementWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotPlaceAreaReinforcementWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPlaceAreaReinforcementWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarSystemFailures Class


CannotPlaceAreaReininforcementWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarSystemFailures..::..CannotPlaceAreaReininforcementWarn Property
BuiltInFailures..::..RebarSystemFailures Class See Also Send Feedback
Can't find a host for Area Reinforcement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotPlaceAreaReininforcementWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotPlaceAreaReininforcementWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPlaceAreaReininforcementWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarSystemFailures Class


CannotPlacePathReinforcement Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarSystemFailures..::..CannotPlacePathReinforcement Property
BuiltInFailures..::..RebarSystemFailures Class See Also Send Feedback
Can't find a host for Path Reinforcement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotPlacePathReinforcement { get; }
Visual Basic
Public Shared ReadOnly Property CannotPlacePathReinforcement As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPlacePathReinforcement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarSystemFailures Class


CannotPlacePathReininforcement Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarSystemFailures..::..CannotPlacePathReininforcement Property
BuiltInFailures..::..RebarSystemFailures Class See Also Send Feedback
Can't find a host for Path Reinforcement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotPlacePathReininforcement { get; }
Visual Basic
Public Shared ReadOnly Property CannotPlacePathReininforcement As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPlacePathReininforcement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarSystemFailures Class


CannotPlacePathReininforcementWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarSystemFailures..::..CannotPlacePathReininforcementWarn Property
BuiltInFailures..::..RebarSystemFailures Class See Also Send Feedback
Can't find a host for Path Reinforcement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotPlacePathReininforcementWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotPlacePathReininforcementWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPlacePathReininforcementWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarSystemFailures Class


DPartReinfDeletedEditDivision Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarSystemFailures..::..DPartReinfDeletedEditDivision Property
BuiltInFailures..::..RebarSystemFailures Class See Also Send Feedback
Edits to the model will cause some Reinforcement hosted on Parts to be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DPartReinfDeletedEditDivision { get; }
Visual Basic
Public Shared ReadOnly Property DPartReinfDeletedEditDivision As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DPartReinfDeletedEditDivision {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarSystemFailures Class


DPartReinforcementDeleted Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarSystemFailures..::..DPartReinforcementDeleted Property
BuiltInFailures..::..RebarSystemFailures Class See Also Send Feedback
Reinforcement hosted on highlighted Parts will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DPartReinforcementDeleted { get; }
Visual Basic
Public Shared ReadOnly Property DPartReinforcementDeleted As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DPartReinforcementDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarSystemFailures Class


HostFlagAreaOff Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarSystemFailures..::..HostFlagAreaOff Property
BuiltInFailures..::..RebarSystemFailures Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId HostFlagAreaOff { get; }
Visual Basic
Public Shared ReadOnly Property HostFlagAreaOff As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HostFlagAreaOff {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarSystemFailures Class


HostFlagAreaOn Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarSystemFailures..::..HostFlagAreaOn Property
BuiltInFailures..::..RebarSystemFailures Class See Also Send Feedback
The Area Reinforcement element was created in a document with the Host Structural Rebar setting on, and cannot be transferred into this document, which has the setting off.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId HostFlagAreaOn { get; }
Visual Basic
Public Shared ReadOnly Property HostFlagAreaOn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HostFlagAreaOn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarSystemFailures Class


HostFlagPathOn Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarSystemFailures..::..HostFlagPathOn Property
BuiltInFailures..::..RebarSystemFailures Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId HostFlagPathOn { get; }
Visual Basic
Public Shared ReadOnly Property HostFlagPathOn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HostFlagPathOn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarSystemFailures Class


LessThanTwoBars Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarSystemFailures..::..LessThanTwoBars Property
BuiltInFailures..::..RebarSystemFailures Class See Also Send Feedback
Each reinforcement direction requires at least 2 bars. Please increase the number of bars.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId LessThanTwoBars { get; }
Visual Basic
Public Shared ReadOnly Property LessThanTwoBars As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LessThanTwoBars {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarSystemFailures Class


PathReinforcementWrongHost Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarSystemFailures..::..PathReinforcementWrongHost Property
BuiltInFailures..::..RebarSystemFailures Class See Also Send Feedback
Path Reinforcement can be placed only in Structural Floors and straight Structural Walls.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId PathReinforcementWrongHost { get; }
Visual Basic
Public Shared ReadOnly Property PathReinforcementWrongHost As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PathReinforcementWrongHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarSystemFailures Class


RebarSystemOffset Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarSystemFailures..::..RebarSystemOffset Property
BuiltInFailures..::..RebarSystemFailures Class See Also Send Feedback
Rebar Cover Side/Edge is too large for sketch. Bar placement may be inaccurate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RebarSystemOffset { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemOffset As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RebarSystemOffset {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarSystemFailures Class


ThinHostFloor Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarSystemFailures..::..ThinHostFloor Property
BuiltInFailures..::..RebarSystemFailures Class See Also Send Feedback
Rebar Cover Top and Bottom are too large for host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ThinHostFloor { get; }
Visual Basic
Public Shared ReadOnly Property ThinHostFloor As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ThinHostFloor {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarSystemFailures Class


ThinHostFloorError Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarSystemFailures..::..ThinHostFloorError Property
BuiltInFailures..::..RebarSystemFailures Class See Also Send Feedback
Rebar Cover Top and Bottom are too large for host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ThinHostFloorError { get; }
Visual Basic
Public Shared ReadOnly Property ThinHostFloorError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ThinHostFloorError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarSystemFailures Class


ThinHostWall Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarSystemFailures..::..ThinHostWall Property
BuiltInFailures..::..RebarSystemFailures Class See Also Send Feedback
Rebar Cover Interior and Exterior are too large for host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ThinHostWall { get; }
Visual Basic
Public Shared ReadOnly Property ThinHostWall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ThinHostWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarSystemFailures Class


ThinHostWallError Property

[image]

Revit 2024 API
BuiltInFailures..::..RebarSystemFailures..::..ThinHostWallError Property
BuiltInFailures..::..RebarSystemFailures Class See Also Send Feedback
Rebar Cover Interior and Exterior are too large for host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ThinHostWallError { get; }
Visual Basic
Public Shared ReadOnly Property ThinHostWallError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ThinHostWallError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarSystemFailures Class


BuiltInFailures.RefPlaneFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..RefPlaneFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about RefPlane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class RefPlaneFailures
Visual Basic
Public NotInheritable Class RefPlaneFailures
Visual C++
public ref class RefPlaneFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..RefPlaneFailures

See Also

BuiltInFailures..::..RefPlaneFailures Members


BuiltInFailures.RefPlaneFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..RefPlaneFailures Properties
BuiltInFailures..::..RefPlaneFailures Class See Also Send Feedback

The BuiltInFailures..::..RefPlaneFailures type exposes the following members.

Properties

Name | Description
AlreadyHaveTwoClosurePlanes | No more than two closure planes are allowed.

See Also

BuiltInFailures..::..RefPlaneFailures Class


BuiltInFailures.RegenFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..RegenFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about RegenFailures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class RegenFailures
Visual Basic
Public NotInheritable Class RegenFailures
Visual C++
public ref class RegenFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..RegenFailures

See Also

BuiltInFailures..::..RegenFailures Members


BuiltInFailures.RegenFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..RegenFailures Members
BuiltInFailures..::..RegenFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..RegenFailures type exposes the following members.

Properties

Name | Description
CannotRegenFamily | Can't regenerate Family [Family Name]. Edit Family to modify it.
CircularDependency | There is a circular chain of references among the highlighted elements.
CircularDependencyAssocProp | There is a circular dependency between a Line created with Pick Support and the supporting member.
CircularDependencyAssocPropError | There is a circular dependency between a Line created with Pick Support and the supporting member.
CircularDependencyConstraint | Highlighted constraints cause a circular chain of references.
CircularDependencyConstraintError | Highlighted constraints cause a circular chain of references.
CircularDependencyError | There is a circular chain of references among the highlighted elements.
CircularDependencyResolved | There was a circular chain of references among the highlighted elements that was attempted to resolve. User-visible text will depend on original error returned by offending element.
CircularDependencySketch | Constraints in sketches of highlighted elements cause a circular chain of references.
CircularDependencySketchError | There is a circular chain of references among the highlighted elements.
CircularDependencyUncut | There is a circular chain of references among the highlighted elements.
CircularDependencyUncutError | There is a circular chain of references among the highlighted elements.
CircularDependencyWall | There is a circular chain of references among the highlighted elements.
CircularDependencyWallError | There is a circular chain of references among the highlighted elements.
ForceRegenSketch | Regen Sketch
GeomStepFailed | Can't rebuild geometry.
GeomStepFailedError | Can't rebuild geometry.
RegenElements | Regenerating elements.
RegeneratedElements | Elements regenerated in pass [Regen Index]
RegenFailure | Regeneration Failure.
UserCancelled | Operation is cancelled by the user.
UserCancelledError | Operation is cancelled by the user.

See Also

BuiltInFailures..::..RegenFailures Class


BuiltInFailures.RegenFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..RegenFailures Properties
BuiltInFailures..::..RegenFailures Class See Also Send Feedback

The BuiltInFailures..::..RegenFailures type exposes the following members.

Properties

Name | Description
CannotRegenFamily | Can't regenerate Family [Family Name]. Edit Family to modify it.
CircularDependency | There is a circular chain of references among the highlighted elements.
CircularDependencyAssocProp | There is a circular dependency between a Line created with Pick Support and the supporting member.
CircularDependencyAssocPropError | There is a circular dependency between a Line created with Pick Support and the supporting member.
CircularDependencyConstraint | Highlighted constraints cause a circular chain of references.
CircularDependencyConstraintError | Highlighted constraints cause a circular chain of references.
CircularDependencyError | There is a circular chain of references among the highlighted elements.
CircularDependencyResolved | There was a circular chain of references among the highlighted elements that was attempted to resolve. User-visible text will depend on original error returned by offending element.
CircularDependencySketch | Constraints in sketches of highlighted elements cause a circular chain of references.
CircularDependencySketchError | There is a circular chain of references among the highlighted elements.
CircularDependencyUncut | There is a circular chain of references among the highlighted elements.
CircularDependencyUncutError | There is a circular chain of references among the highlighted elements.
CircularDependencyWall | There is a circular chain of references among the highlighted elements.
CircularDependencyWallError | There is a circular chain of references among the highlighted elements.
ForceRegenSketch | Regen Sketch
GeomStepFailed | Can't rebuild geometry.
GeomStepFailedError | Can't rebuild geometry.
RegenElements | Regenerating elements.
RegeneratedElements | Elements regenerated in pass [Regen Index]
RegenFailure | Regeneration Failure.
UserCancelled | Operation is cancelled by the user.
UserCancelledError | Operation is cancelled by the user.

See Also

BuiltInFailures..::..RegenFailures Class


CircularDependency Property

[image]

Revit 2024 API
BuiltInFailures..::..RegenFailures..::..CircularDependency Property
BuiltInFailures..::..RegenFailures Class See Also Send Feedback
There is a circular chain of references among the highlighted elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CircularDependency { get; }
Visual Basic
Public Shared ReadOnly Property CircularDependency As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CircularDependency {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RegenFailures Class


CircularDependencyAssocProp Property

[image]

Revit 2024 API
BuiltInFailures..::..RegenFailures..::..CircularDependencyAssocProp Property
BuiltInFailures..::..RegenFailures Class See Also Send Feedback
There is a circular dependency between a Line created with Pick Support and the supporting member.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CircularDependencyAssocProp { get; }
Visual Basic
Public Shared ReadOnly Property CircularDependencyAssocProp As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CircularDependencyAssocProp {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RegenFailures Class


CircularDependencyAssocPropError Property

[image]

Revit 2024 API
BuiltInFailures..::..RegenFailures..::..CircularDependencyAssocPropError Property
BuiltInFailures..::..RegenFailures Class See Also Send Feedback
There is a circular dependency between a Line created with Pick Support and the supporting member.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CircularDependencyAssocPropError { get; }
Visual Basic
Public Shared ReadOnly Property CircularDependencyAssocPropError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CircularDependencyAssocPropError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RegenFailures Class


CircularDependencyConstraint Property

[image]

Revit 2024 API
BuiltInFailures..::..RegenFailures..::..CircularDependencyConstraint Property
BuiltInFailures..::..RegenFailures Class See Also Send Feedback
Highlighted constraints cause a circular chain of references.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CircularDependencyConstraint { get; }
Visual Basic
Public Shared ReadOnly Property CircularDependencyConstraint As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CircularDependencyConstraint {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RegenFailures Class


CircularDependencyConstraintError Property

[image]

Revit 2024 API
BuiltInFailures..::..RegenFailures..::..CircularDependencyConstraintError Property
BuiltInFailures..::..RegenFailures Class See Also Send Feedback
Highlighted constraints cause a circular chain of references.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CircularDependencyConstraintError { get; }
Visual Basic
Public Shared ReadOnly Property CircularDependencyConstraintError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CircularDependencyConstraintError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RegenFailures Class


CircularDependencyError Property

[image]

Revit 2024 API
BuiltInFailures..::..RegenFailures..::..CircularDependencyError Property
BuiltInFailures..::..RegenFailures Class See Also Send Feedback
There is a circular chain of references among the highlighted elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CircularDependencyError { get; }
Visual Basic
Public Shared ReadOnly Property CircularDependencyError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CircularDependencyError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RegenFailures Class


CircularDependencyResolved Property

[image]

Revit 2024 API
BuiltInFailures..::..RegenFailures..::..CircularDependencyResolved Property
BuiltInFailures..::..RegenFailures Class See Also Send Feedback
There was a circular chain of references among the highlighted elements that was attempted to resolve. User-visible text will depend on original error returned by offending element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CircularDependencyResolved { get; }
Visual Basic
Public Shared ReadOnly Property CircularDependencyResolved As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CircularDependencyResolved {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RegenFailures Class


CircularDependencySketch Property

[image]

Revit 2024 API
BuiltInFailures..::..RegenFailures..::..CircularDependencySketch Property
BuiltInFailures..::..RegenFailures Class See Also Send Feedback
Constraints in sketches of highlighted elements cause a circular chain of references.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CircularDependencySketch { get; }
Visual Basic
Public Shared ReadOnly Property CircularDependencySketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CircularDependencySketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RegenFailures Class


CircularDependencySketchError Property

[image]

Revit 2024 API
BuiltInFailures..::..RegenFailures..::..CircularDependencySketchError Property
BuiltInFailures..::..RegenFailures Class See Also Send Feedback
There is a circular chain of references among the highlighted elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CircularDependencySketchError { get; }
Visual Basic
Public Shared ReadOnly Property CircularDependencySketchError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CircularDependencySketchError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RegenFailures Class


CircularDependencyUncut Property

[image]

Revit 2024 API
BuiltInFailures..::..RegenFailures..::..CircularDependencyUncut Property
BuiltInFailures..::..RegenFailures Class See Also Send Feedback
There is a circular chain of references among the highlighted elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CircularDependencyUncut { get; }
Visual Basic
Public Shared ReadOnly Property CircularDependencyUncut As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CircularDependencyUncut {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RegenFailures Class


CircularDependencyUncutError Property

[image]

Revit 2024 API
BuiltInFailures..::..RegenFailures..::..CircularDependencyUncutError Property
BuiltInFailures..::..RegenFailures Class See Also Send Feedback
There is a circular chain of references among the highlighted elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CircularDependencyUncutError { get; }
Visual Basic
Public Shared ReadOnly Property CircularDependencyUncutError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CircularDependencyUncutError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RegenFailures Class


CircularDependencyWall Property

[image]

Revit 2024 API
BuiltInFailures..::..RegenFailures..::..CircularDependencyWall Property
BuiltInFailures..::..RegenFailures Class See Also Send Feedback
There is a circular chain of references among the highlighted elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CircularDependencyWall { get; }
Visual Basic
Public Shared ReadOnly Property CircularDependencyWall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CircularDependencyWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RegenFailures Class


ForceRegenSketch Property

[image]

Revit 2024 API
BuiltInFailures..::..RegenFailures..::..ForceRegenSketch Property
BuiltInFailures..::..RegenFailures Class See Also Send Feedback
Regen Sketch

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ForceRegenSketch { get; }
Visual Basic
Public Shared ReadOnly Property ForceRegenSketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ForceRegenSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RegenFailures Class


GeomStepFailed Property

[image]

Revit 2024 API
BuiltInFailures..::..RegenFailures..::..GeomStepFailed Property
BuiltInFailures..::..RegenFailures Class See Also Send Feedback
Can't rebuild geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId GeomStepFailed { get; }
Visual Basic
Public Shared ReadOnly Property GeomStepFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GeomStepFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RegenFailures Class


RegeneratedElements Property

[image]

Revit 2024 API
BuiltInFailures..::..RegenFailures..::..RegeneratedElements Property
BuiltInFailures..::..RegenFailures Class See Also Send Feedback
Elements regenerated in pass [Regen Index]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RegeneratedElements { get; }
Visual Basic
Public Shared ReadOnly Property RegeneratedElements As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RegeneratedElements {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RegenFailures Class


RegenFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..RegenFailures..::..RegenFailure Property
BuiltInFailures..::..RegenFailures Class See Also Send Feedback
Regeneration Failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RegenFailure { get; }
Visual Basic
Public Shared ReadOnly Property RegenFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RegenFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RegenFailures Class


UserCancelled Property

[image]

Revit 2024 API
BuiltInFailures..::..RegenFailures..::..UserCancelled Property
BuiltInFailures..::..RegenFailures Class See Also Send Feedback
Operation is cancelled by the user.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UserCancelled { get; }
Visual Basic
Public Shared ReadOnly Property UserCancelled As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UserCancelled {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RegenFailures Class


BuiltInFailures.RenderFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..RenderFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures related to rendering.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class RenderFailures
Visual Basic
Public NotInheritable Class RenderFailures
Visual C++
public ref class RenderFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..RenderFailures

See Also

BuiltInFailures..::..RenderFailures Members


BuiltInFailures.RenderFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..RenderFailures Properties
BuiltInFailures..::..RenderFailures Class See Also Send Feedback

The BuiltInFailures..::..RenderFailures type exposes the following members.

Properties

Name | Description
LightParametersNotInRange | The value should be in range of [Value] and [Value].
LightSourceInsideGeometry | Light source is inside solid geometry. No light will be emitted during rendering.
ProhibitDeletionLightSource | The light source cannot be deleted with UI.
RenderLibNotInstalledWarn | Rendering library has not been installed, so the third party geometry cannot be created.

See Also

BuiltInFailures..::..RenderFailures Class


LightParametersNotInRange Property

[image]

Revit 2024 API
BuiltInFailures..::..RenderFailures..::..LightParametersNotInRange Property
BuiltInFailures..::..RenderFailures Class See Also Send Feedback
The value should be in range of [Value] and [Value].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId LightParametersNotInRange { get; }
Visual Basic
Public Shared ReadOnly Property LightParametersNotInRange As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LightParametersNotInRange {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RenderFailures Class


LightSourceInsideGeometry Property

[image]

Revit 2024 API
BuiltInFailures..::..RenderFailures..::..LightSourceInsideGeometry Property
BuiltInFailures..::..RenderFailures Class See Also Send Feedback
Light source is inside solid geometry. No light will be emitted during rendering.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId LightSourceInsideGeometry { get; }
Visual Basic
Public Shared ReadOnly Property LightSourceInsideGeometry As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LightSourceInsideGeometry {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RenderFailures Class


RenderLibNotInstalledWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..RenderFailures..::..RenderLibNotInstalledWarn Property
BuiltInFailures..::..RenderFailures Class See Also Send Feedback
Rendering library has not been installed, so the third party geometry cannot be created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RenderLibNotInstalledWarn { get; }
Visual Basic
Public Shared ReadOnly Property RenderLibNotInstalledWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RenderLibNotInstalledWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RenderFailures Class


BuiltInFailures.RevisionCloudFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..RevisionCloudFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about RevisionCloud.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class RevisionCloudFailures
Visual Basic
Public NotInheritable Class RevisionCloudFailures
Visual C++
public ref class RevisionCloudFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..RevisionCloudFailures

See Also

BuiltInFailures..::..RevisionCloudFailures Members


BuiltInFailures.RevisionCloudFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..RevisionCloudFailures Members
BuiltInFailures..::..RevisionCloudFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..RevisionCloudFailures type exposes the following members.

Properties

Name | Description
ModifyingIssuedRevisionCloudOnUpgrade | During upgrade, an issued revision cloud was moved. Please double check the revision cloud to ensure it is located in the correct place.
ProhibitCreationInIssued | The most current project revision has been issued. No new revision clouds can be created in it. Please add a new revision to the global revision table.
ProhibitModificationOfIssuedRevisionCloud | Issued Revision Clouds can't be modified.
ProhibitSwitchFromIssuedRevision | Can't remove cloud from an Issued Revision.
ProhibitSwitchToIssuedRevision | Can't add cloud to an Issued Revision.

See Also

BuiltInFailures..::..RevisionCloudFailures Class


BuiltInFailures.RevisionCloudFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..RevisionCloudFailures Properties
BuiltInFailures..::..RevisionCloudFailures Class See Also Send Feedback

The BuiltInFailures..::..RevisionCloudFailures type exposes the following members.

Properties

Name | Description
ModifyingIssuedRevisionCloudOnUpgrade | During upgrade, an issued revision cloud was moved. Please double check the revision cloud to ensure it is located in the correct place.
ProhibitCreationInIssued | The most current project revision has been issued. No new revision clouds can be created in it. Please add a new revision to the global revision table.
ProhibitModificationOfIssuedRevisionCloud | Issued Revision Clouds can't be modified.
ProhibitSwitchFromIssuedRevision | Can't remove cloud from an Issued Revision.
ProhibitSwitchToIssuedRevision | Can't add cloud to an Issued Revision.

See Also

BuiltInFailures..::..RevisionCloudFailures Class


ModifyingIssuedRevisionCloudOnUpgrade Property

[image]

Revit 2024 API
BuiltInFailures..::..RevisionCloudFailures..::..ModifyingIssuedRevisionCloudOnUpgrade Property
BuiltInFailures..::..RevisionCloudFailures Class See Also Send Feedback
During upgrade, an issued revision cloud was moved. Please double check the revision cloud to ensure it is located in the correct place.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ModifyingIssuedRevisionCloudOnUpgrade { get; }
Visual Basic
Public Shared ReadOnly Property ModifyingIssuedRevisionCloudOnUpgrade As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ModifyingIssuedRevisionCloudOnUpgrade {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RevisionCloudFailures Class


ProhibitCreationInIssued Property

[image]

Revit 2024 API
BuiltInFailures..::..RevisionCloudFailures..::..ProhibitCreationInIssued Property
BuiltInFailures..::..RevisionCloudFailures Class See Also Send Feedback
The most current project revision has been issued. No new revision clouds can be created in it. Please add a new revision to the global revision table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ProhibitCreationInIssued { get; }
Visual Basic
Public Shared ReadOnly Property ProhibitCreationInIssued As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ProhibitCreationInIssued {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RevisionCloudFailures Class


ProhibitModificationOfIssuedRevisionCloud Property

[image]

Revit 2024 API
BuiltInFailures..::..RevisionCloudFailures..::..ProhibitModificationOfIssuedRevisionCloud Property
BuiltInFailures..::..RevisionCloudFailures Class See Also Send Feedback
Issued Revision Clouds can't be modified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ProhibitModificationOfIssuedRevisionCloud { get; }
Visual Basic
Public Shared ReadOnly Property ProhibitModificationOfIssuedRevisionCloud As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ProhibitModificationOfIssuedRevisionCloud {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RevisionCloudFailures Class


ProhibitSwitchToIssuedRevision Property

[image]

Revit 2024 API
BuiltInFailures..::..RevisionCloudFailures..::..ProhibitSwitchToIssuedRevision Property
BuiltInFailures..::..RevisionCloudFailures Class See Also Send Feedback
Can't add cloud to an Issued Revision.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ProhibitSwitchToIssuedRevision { get; }
Visual Basic
Public Shared ReadOnly Property ProhibitSwitchToIssuedRevision As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ProhibitSwitchToIssuedRevision {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RevisionCloudFailures Class


BuiltInFailures.RevisionFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..RevisionFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Revision Settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class RevisionFailures
Visual Basic
Public NotInheritable Class RevisionFailures
Visual C++
public ref class RevisionFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..RevisionFailures

See Also

BuiltInFailures..::..RevisionFailures Members


BuiltInFailures.RevisionFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..RevisionFailures Properties
BuiltInFailures..::..RevisionFailures Class See Also Send Feedback

The BuiltInFailures..::..RevisionFailures type exposes the following members.

Properties

Name | Description
RevisionSettingsDuplicateName | More than one Revisons have the same name %1!s!.

See Also

BuiltInFailures..::..RevisionFailures Class


RevisionSettingsDuplicateName Property

[image]

Revit 2024 API
BuiltInFailures..::..RevisionFailures..::..RevisionSettingsDuplicateName Property
BuiltInFailures..::..RevisionFailures Class See Also Send Feedback
More than one Revisons have the same name %1!s!.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RevisionSettingsDuplicateName { get; }
Visual Basic
Public Shared ReadOnly Property RevisionSettingsDuplicateName As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RevisionSettingsDuplicateName {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RevisionFailures Class


BuiltInFailures.RevolutionFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..RevolutionFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Revolution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class RevolutionFailures
Visual Basic
Public NotInheritable Class RevolutionFailures
Visual C++
public ref class RevolutionFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..RevolutionFailures

See Also

BuiltInFailures..::..RevolutionFailures Members


BuiltInFailures.RevolutionFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..RevolutionFailures Members
BuiltInFailures..::..RevolutionFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..RevolutionFailures type exposes the following members.

Properties

Name | Description
CannotDrawRevolution | Can't create surface of revolution.
ProfileCrossesRevolutionAxis | The profile must not cross the axis of revolution.
ProfileNotPlanar | The Profile must lie in a plane.

See Also

BuiltInFailures..::..RevolutionFailures Class


BuiltInFailures.RevolutionFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..RevolutionFailures Properties
BuiltInFailures..::..RevolutionFailures Class See Also Send Feedback

The BuiltInFailures..::..RevolutionFailures type exposes the following members.

Properties

Name | Description
CannotDrawRevolution | Can't create surface of revolution.
ProfileCrossesRevolutionAxis | The profile must not cross the axis of revolution.
ProfileNotPlanar | The Profile must lie in a plane.

See Also

BuiltInFailures..::..RevolutionFailures Class


CannotDrawRevolution Property

[image]

Revit 2024 API
BuiltInFailures..::..RevolutionFailures..::..CannotDrawRevolution Property
BuiltInFailures..::..RevolutionFailures Class See Also Send Feedback
Can't create surface of revolution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotDrawRevolution { get; }
Visual Basic
Public Shared ReadOnly Property CannotDrawRevolution As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDrawRevolution {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RevolutionFailures Class


ProfileCrossesRevolutionAxis Property

[image]

Revit 2024 API
BuiltInFailures..::..RevolutionFailures..::..ProfileCrossesRevolutionAxis Property
BuiltInFailures..::..RevolutionFailures Class See Also Send Feedback
The profile must not cross the axis of revolution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ProfileCrossesRevolutionAxis { get; }
Visual Basic
Public Shared ReadOnly Property ProfileCrossesRevolutionAxis As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ProfileCrossesRevolutionAxis {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RevolutionFailures Class


ProfileNotPlanar Property

[image]

Revit 2024 API
BuiltInFailures..::..RevolutionFailures..::..ProfileNotPlanar Property
BuiltInFailures..::..RevolutionFailures Class See Also Send Feedback
The Profile must lie in a plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ProfileNotPlanar { get; }
Visual Basic
Public Shared ReadOnly Property ProfileNotPlanar As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ProfileNotPlanar {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RevolutionFailures Class


BuiltInFailures.RoofFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..RoofFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Roof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class RoofFailures
Visual Basic
Public NotInheritable Class RoofFailures
Visual C++
public ref class RoofFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..RoofFailures

See Also

BuiltInFailures..::..RoofFailures Members


BuiltInFailures.RoofFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..RoofFailures Members
BuiltInFailures..::..RoofFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..RoofFailures type exposes the following members.

Properties

Name | Description
CurveRoofSkippedLoops | Some loops were skipped
CurveRoofSkippedLoopsError | Some loops were skipped
CurveRoofSkippedLoopsWarn | Some loops were skipped
ExtrudedRoofCutBySketch | Entire extruded Roof is cut by cut Sketch.
HadToAlignEaves | Adjacent slope-defining lines must have identical eave heights. Eaves were aligned to higher location automatically to avoid failure. Use the Align Eaves tool to specify desired location.
HoleInRoofFailed | Hole(s) could not be cut in roof.
InvalidArcSegmentation | A segmented slope-defining arc has too few segments.
JoinedRoofMissesTarget | Part of the roof to be joined misses the target face.
JoinedRoofMissesTargetError | Part of the roof to be joined misses the target face.
NoFlatCurtainRoofs | A Sloped Glazing with no slope is not allowed.
OnlyOneSlopeCurtainRoof | Only one slope in curtain roof.
OnlyUpwardFacesUsed | The selected faces contain both upward and downward pointing faces. Only the upward pointing faces were used.
RoofCutoffRemoved | The roof's cutoff failed and was removed; make sure the cutoff height is not below the roof.
RoofExceedsMaxHeight | Roof exceeds user-specified maximum height
RoofMeetsRoofTangentially | The roofs cannot be joined because the roof being joined meets the target roof tangentially.
RoofMeetsRoofTangentiallyError | The roofs cannot be joined because the roof being joined meets the target roof tangentially.
RoofSlopeExceedsThreshold | Thickness of this Roof may be slightly inaccurate due to extreme Shape Editing. Dimensions to this element in sections and details may not accurately indicate the Thickness shown in Type Properties.
RoofToRefPlanes | Roof cannot be joined to more than one reference plane.
RoofToRefPlanesError | Roof cannot be joined to more than one reference plane.
UnusedSlopeArrow | The tails of all slope arrows must lie on the roof boundary.
UptoHeightTooLow | Cutoff Level cannot be below bottom of roof.
UserCancelledRoof | Cancelled.
WorkplaneShouldBeLevel | Can't use Workplane that is not a Level. Set the desired Level as current Workplane.

See Also

BuiltInFailures..::..RoofFailures Class


BuiltInFailures.RoofFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..RoofFailures Properties
BuiltInFailures..::..RoofFailures Class See Also Send Feedback

The BuiltInFailures..::..RoofFailures type exposes the following members.

Properties

Name | Description
CurveRoofSkippedLoops | Some loops were skipped
CurveRoofSkippedLoopsError | Some loops were skipped
CurveRoofSkippedLoopsWarn | Some loops were skipped
ExtrudedRoofCutBySketch | Entire extruded Roof is cut by cut Sketch.
HadToAlignEaves | Adjacent slope-defining lines must have identical eave heights. Eaves were aligned to higher location automatically to avoid failure. Use the Align Eaves tool to specify desired location.
HoleInRoofFailed | Hole(s) could not be cut in roof.
InvalidArcSegmentation | A segmented slope-defining arc has too few segments.
JoinedRoofMissesTarget | Part of the roof to be joined misses the target face.
JoinedRoofMissesTargetError | Part of the roof to be joined misses the target face.
NoFlatCurtainRoofs | A Sloped Glazing with no slope is not allowed.
OnlyOneSlopeCurtainRoof | Only one slope in curtain roof.
OnlyUpwardFacesUsed | The selected faces contain both upward and downward pointing faces. Only the upward pointing faces were used.
RoofCutoffRemoved | The roof's cutoff failed and was removed; make sure the cutoff height is not below the roof.
RoofExceedsMaxHeight | Roof exceeds user-specified maximum height
RoofMeetsRoofTangentially | The roofs cannot be joined because the roof being joined meets the target roof tangentially.
RoofMeetsRoofTangentiallyError | The roofs cannot be joined because the roof being joined meets the target roof tangentially.
RoofSlopeExceedsThreshold | Thickness of this Roof may be slightly inaccurate due to extreme Shape Editing. Dimensions to this element in sections and details may not accurately indicate the Thickness shown in Type Properties.
RoofToRefPlanes | Roof cannot be joined to more than one reference plane.
RoofToRefPlanesError | Roof cannot be joined to more than one reference plane.
UnusedSlopeArrow | The tails of all slope arrows must lie on the roof boundary.
UptoHeightTooLow | Cutoff Level cannot be below bottom of roof.
UserCancelledRoof | Cancelled.
WorkplaneShouldBeLevel | Can't use Workplane that is not a Level. Set the desired Level as current Workplane.

See Also

BuiltInFailures..::..RoofFailures Class


CurveRoofSkippedLoops Property

[image]

Revit 2024 API
BuiltInFailures..::..RoofFailures..::..CurveRoofSkippedLoops Property
BuiltInFailures..::..RoofFailures Class See Also Send Feedback
Some loops were skipped

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CurveRoofSkippedLoops { get; }
Visual Basic
Public Shared ReadOnly Property CurveRoofSkippedLoops As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CurveRoofSkippedLoops {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoofFailures Class


CurveRoofSkippedLoopsError Property

[image]

Revit 2024 API
BuiltInFailures..::..RoofFailures..::..CurveRoofSkippedLoopsError Property
BuiltInFailures..::..RoofFailures Class See Also Send Feedback
Some loops were skipped

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CurveRoofSkippedLoopsError { get; }
Visual Basic
Public Shared ReadOnly Property CurveRoofSkippedLoopsError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CurveRoofSkippedLoopsError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoofFailures Class


CurveRoofSkippedLoopsWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..RoofFailures..::..CurveRoofSkippedLoopsWarn Property
BuiltInFailures..::..RoofFailures Class See Also Send Feedback
Some loops were skipped

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CurveRoofSkippedLoopsWarn { get; }
Visual Basic
Public Shared ReadOnly Property CurveRoofSkippedLoopsWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CurveRoofSkippedLoopsWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoofFailures Class


ExtrudedRoofCutBySketch Property

[image]

Revit 2024 API
BuiltInFailures..::..RoofFailures..::..ExtrudedRoofCutBySketch Property
BuiltInFailures..::..RoofFailures Class See Also Send Feedback
Entire extruded Roof is cut by cut Sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ExtrudedRoofCutBySketch { get; }
Visual Basic
Public Shared ReadOnly Property ExtrudedRoofCutBySketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ExtrudedRoofCutBySketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoofFailures Class


HadToAlignEaves Property

[image]

Revit 2024 API
BuiltInFailures..::..RoofFailures..::..HadToAlignEaves Property
BuiltInFailures..::..RoofFailures Class See Also Send Feedback
Adjacent slope-defining lines must have identical eave heights. Eaves were aligned to higher location automatically to avoid failure. Use the Align Eaves tool to specify desired location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId HadToAlignEaves { get; }
Visual Basic
Public Shared ReadOnly Property HadToAlignEaves As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HadToAlignEaves {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoofFailures Class


HoleInRoofFailed Property

[image]

Revit 2024 API
BuiltInFailures..::..RoofFailures..::..HoleInRoofFailed Property
BuiltInFailures..::..RoofFailures Class See Also Send Feedback
Hole(s) could not be cut in roof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId HoleInRoofFailed { get; }
Visual Basic
Public Shared ReadOnly Property HoleInRoofFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HoleInRoofFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoofFailures Class


InvalidArcSegmentation Property

[image]

Revit 2024 API
BuiltInFailures..::..RoofFailures..::..InvalidArcSegmentation Property
BuiltInFailures..::..RoofFailures Class See Also Send Feedback
A segmented slope-defining arc has too few segments.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidArcSegmentation { get; }
Visual Basic
Public Shared ReadOnly Property InvalidArcSegmentation As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidArcSegmentation {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoofFailures Class


JoinedRoofMissesTarget Property

[image]

Revit 2024 API
BuiltInFailures..::..RoofFailures..::..JoinedRoofMissesTarget Property
BuiltInFailures..::..RoofFailures Class See Also Send Feedback
Part of the roof to be joined misses the target face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId JoinedRoofMissesTarget { get; }
Visual Basic
Public Shared ReadOnly Property JoinedRoofMissesTarget As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ JoinedRoofMissesTarget {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoofFailures Class


OnlyOneSlopeCurtainRoof Property

[image]

Revit 2024 API
BuiltInFailures..::..RoofFailures..::..OnlyOneSlopeCurtainRoof Property
BuiltInFailures..::..RoofFailures Class See Also Send Feedback
Only one slope in curtain roof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId OnlyOneSlopeCurtainRoof { get; }
Visual Basic
Public Shared ReadOnly Property OnlyOneSlopeCurtainRoof As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OnlyOneSlopeCurtainRoof {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoofFailures Class


OnlyUpwardFacesUsed Property

[image]

Revit 2024 API
BuiltInFailures..::..RoofFailures..::..OnlyUpwardFacesUsed Property
BuiltInFailures..::..RoofFailures Class See Also Send Feedback
The selected faces contain both upward and downward pointing faces. Only the upward pointing faces were used.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId OnlyUpwardFacesUsed { get; }
Visual Basic
Public Shared ReadOnly Property OnlyUpwardFacesUsed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OnlyUpwardFacesUsed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoofFailures Class


RoofCutoffRemoved Property

[image]

Revit 2024 API
BuiltInFailures..::..RoofFailures..::..RoofCutoffRemoved Property
BuiltInFailures..::..RoofFailures Class See Also Send Feedback
The roof's cutoff failed and was removed; make sure the cutoff height is not below the roof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RoofCutoffRemoved { get; }
Visual Basic
Public Shared ReadOnly Property RoofCutoffRemoved As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoofCutoffRemoved {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoofFailures Class


RoofExceedsMaxHeight Property

[image]

Revit 2024 API
BuiltInFailures..::..RoofFailures..::..RoofExceedsMaxHeight Property
BuiltInFailures..::..RoofFailures Class See Also Send Feedback
Roof exceeds user-specified maximum height

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RoofExceedsMaxHeight { get; }
Visual Basic
Public Shared ReadOnly Property RoofExceedsMaxHeight As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoofExceedsMaxHeight {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoofFailures Class


RoofMeetsRoofTangentially Property

[image]

Revit 2024 API
BuiltInFailures..::..RoofFailures..::..RoofMeetsRoofTangentially Property
BuiltInFailures..::..RoofFailures Class See Also Send Feedback
The roofs cannot be joined because the roof being joined meets the target roof tangentially.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RoofMeetsRoofTangentially { get; }
Visual Basic
Public Shared ReadOnly Property RoofMeetsRoofTangentially As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoofMeetsRoofTangentially {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoofFailures Class


RoofMeetsRoofTangentiallyError Property

[image]

Revit 2024 API
BuiltInFailures..::..RoofFailures..::..RoofMeetsRoofTangentiallyError Property
BuiltInFailures..::..RoofFailures Class See Also Send Feedback
The roofs cannot be joined because the roof being joined meets the target roof tangentially.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RoofMeetsRoofTangentiallyError { get; }
Visual Basic
Public Shared ReadOnly Property RoofMeetsRoofTangentiallyError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoofMeetsRoofTangentiallyError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoofFailures Class


RoofToRefPlanes Property

[image]

Revit 2024 API
BuiltInFailures..::..RoofFailures..::..RoofToRefPlanes Property
BuiltInFailures..::..RoofFailures Class See Also Send Feedback
Roof cannot be joined to more than one reference plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RoofToRefPlanes { get; }
Visual Basic
Public Shared ReadOnly Property RoofToRefPlanes As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoofToRefPlanes {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoofFailures Class


UnusedSlopeArrow Property

[image]

Revit 2024 API
BuiltInFailures..::..RoofFailures..::..UnusedSlopeArrow Property
BuiltInFailures..::..RoofFailures Class See Also Send Feedback
The tails of all slope arrows must lie on the roof boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UnusedSlopeArrow { get; }
Visual Basic
Public Shared ReadOnly Property UnusedSlopeArrow As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnusedSlopeArrow {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoofFailures Class


UptoHeightTooLow Property

[image]

Revit 2024 API
BuiltInFailures..::..RoofFailures..::..UptoHeightTooLow Property
BuiltInFailures..::..RoofFailures Class See Also Send Feedback
Cutoff Level cannot be below bottom of roof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UptoHeightTooLow { get; }
Visual Basic
Public Shared ReadOnly Property UptoHeightTooLow As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UptoHeightTooLow {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoofFailures Class


UserCancelledRoof Property

[image]

Revit 2024 API
BuiltInFailures..::..RoofFailures..::..UserCancelledRoof Property
BuiltInFailures..::..RoofFailures Class See Also Send Feedback
Cancelled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UserCancelledRoof { get; }
Visual Basic
Public Shared ReadOnly Property UserCancelledRoof As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UserCancelledRoof {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoofFailures Class


BuiltInFailures.RoomFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..RoomFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Room.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class RoomFailures
Visual Basic
Public NotInheritable Class RoomFailures
Visual C++
public ref class RoomFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..RoomFailures

See Also

BuiltInFailures..::..RoomFailures Members


BuiltInFailures.RoomFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..RoomFailures Members
BuiltInFailures..::..RoomFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..RoomFailures type exposes the following members.

Properties

Name | Description
AreaTagBadViewType | Can't Copy Area Tags. The target view doesn't have the same Area Scheme as the original view.
AreaUnplaceWarning | An Area was deleted from all model views but still remains in this project. \n The area can be removed from any schedule or placed back in the model using the Area command.
CannotMakeRoomsGeometry | Could not create geometry for [Room].
ExtensionsOverlapWarning | Vertical Extensions on these Walls overlap. This can cause undesirable Joins. Try starting with no overlap and extend the Walls toward one another.
InvalidReflectivityPercentage | The value for Reflectivity must be between 0 and 1.
InvisibleRoomBoundElemement | [Room] Bounding element is invisible in current view.
LoadareaRecovered | The boundary encloses the region for area based load:[Areabasedload].
OptionConflictBoundariesVaryMainAddToOptionSet | Option Conflict between Rooms.\nRoom boundary in the Main Model differs from the apparent boundary in view '[View Name]'.\nTo resolve, select the Main Model Room and use the Add to Design Option Set command.
OptionConflictBoundariesVaryMainSeparate | Option Conflict between Rooms.\nRoom boundary in the Main Model differs from the apparent boundary in view '[View Name]'.\nTo resolve, divide space with Room Separation Lines in the Main Model.
OptionConflictBoundariesVaryOptionSeparate | Option Conflict between Rooms.\nRoom boundary differs from the apparent boundary in view '[View Name]'.\nTo resolve, divide space with Room Separation Lines in the Main Model.
OptionConflictInLinkBoundariesVaryMainAddToOptionSet | Option conflict between rooms in the Revit link '[Link Instance Name]'.\nThe room boundary in the main model of the Revit link differs from the apparent boundary in the linked view '[View Name from Link]'.\nTo resolve the issue, open the Revit link file for editing, select the main model room, and use the Add to Design Option Set tool.
OptionConflictInLinkBoundariesVaryMainSeparate | Option conflict between rooms in the Revit link '[Link Instance Name]'.\nThe room boundary in the main model of the Revit link differs from the apparent boundary in the linked view '[View Name from Link]'.\nTo resolve the issue, open the Revit link file for editing, and use room separation lines to divide the space in the main model.
OptionConflictInLinkBoundariesVaryOptionSeparate | Option conflict between rooms in the Revit link '[Link Instance Name]'.\nThe room boundary differs from the apparent boundary in the linked view '[View Name from Link]'.\nTo resolve the issue, open the Revit link file for editing, and use room separation lines to divide the space in the main model.
OptionConflictInLinkRoomOverlapMain | Option conflict between rooms in the Revit link '[Link Instance Name]'.\nThe room in the Revit link's option '[Option Name in Link]' overlaps a room in the main model.\nTo resolve the issue, open the Revit link file for editing, select the main model room, and use the Add to Design Option Set tool.
OptionConflictInLinkRoomOverlapOption | Option conflict between rooms in the Revit link '[Link Instance Name]'.\nA room in the Revit link's option '[Option #1 Name in Link]' overlaps a room in the Revit link's option '[Option #2 Name in Link]'.\nTo resolve the issue, open the Revit link file for editing, and delete the duplicate room or use room separation lines to divide the space in the main model.
OptionConflictRoomOverlapMain | Option Conflict between Rooms.\nRoom in Option '[Option Name]' overlaps Room in the Main Model.\nTo resolve, select the Main Model Room and use the Add to Design Option Set command.
OptionConflictRoomOverlapOption | Option Conflict between Rooms.\nRoom in Option '[Option Name]' overlaps Room in Option '[Option Name]'.\nTo resolve, delete the duplicate Room or divide space with Room Separation Lines in the Main Model.
RoomBaseAboveComputationHeight | [RoomBase]'s lower offset is above the Computation Height
RoomBelowCompHeight | [Room] Volume is being calculated above the Upper Limit of this [Room]. Change the Upper Limit and Offset or change the height of volume calculations.
RoomBoundaryMisalignment | [Room] bounding element might be misaligned.
RoomHeightNegative | [Room] must have a height greater than 0.
RoomLevelElevs | A [Room]s Upper Limit must be above its Base Level.
RoomNotEnclosed | [Room] is not in a properly enclosed region
RoomNotEnclosedAreas | [Room] is not in a properly enclosed region
RoomNotEnclosedLoadAreas | [Room] is not in a properly enclosed region
RoomNotEnclosedRooms | [Room] is not in a properly enclosed region
RoomNotEnclosedSpaces | [Room] is not in a properly enclosed region
RoomsCreatedAutomatically | [Room] [Room] created automatically.
RoomsFailed | [Room] computations only succeeded without considering the following elements.
RoomsInSameRegion | Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.
RoomsInSameRegionAreas | Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.
RoomsInSameRegionLoadAreas | Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.
RoomsInSameRegionRooms | Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.
RoomsInSameRegionSpaces | Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.
RoomsOverlapInHeight | [Room] volumes overlap. Adjust the Upper Limit and Limit Offset properties of the [rooms].
RoomsReallyFailed | [Room] computations failed. Try to modify the following elements.
RoomTagBadViewType | [Room] Tags can only be placed in Floor Plan, Reflected Ceiling Plan and Section Views.
RoomTagDeleted | A [Room] Tag was deleted, but the corresponding [Room] still exists. You can place another tag for the [Room] using the [Room] Tag tool or select the [Room] and delete it.
RoomTagNotInRoom | [Room] Tag is outside of its [Room]. Enable Leader or move [Room] Tag within its [Room].
RoomTagNotInRoomToArea | [Room] Tag is outside of its [Room]. Enable Leader or move [Room] Tag within its [Room].
RoomTagNotInRoomToRoom | [Room] Tag is outside of its [Room]. Enable Leader or move [Room] Tag within its [Room].
RoomTagNotInRoomToSpace | [Room] Tag is outside of its [Room]. Enable Leader or move [Room] Tag within its [Room].
RoomTagVolumeNotComputed | [Room] Tag is displaying volume that can't be computed.
RoomTooShort | [Room] is very short. If this is not intended, change its Upper Limit and Offset.
RoomUnplaceWarning | A Room was deleted from all model views but still remains in this project. \n The room can be removed from any schedule or placed back in the model using the Room command.
ShowRoomBoundingElements | [Room] Bounding elements are highlighted.
SpaceUnplaceWarning | A Space was deleted from all model views but still remains in this project. \n The Space can be removed from any schedule or placed back in the model using the Space command.

See Also

BuiltInFailures..::..RoomFailures Class


CannotMakeRoomsGeometry Property

[image]

Revit 2024 API
BuiltInFailures..::..RoomFailures..::..CannotMakeRoomsGeometry Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
Could not create geometry for [Room].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotMakeRoomsGeometry { get; }
Visual Basic
Public Shared ReadOnly Property CannotMakeRoomsGeometry As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMakeRoomsGeometry {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


ExtensionsOverlapWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..RoomFailures..::..ExtensionsOverlapWarning Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
Vertical Extensions on these Walls overlap. This can cause undesirable Joins. Try starting with no overlap and extend the Walls toward one another.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ExtensionsOverlapWarning { get; }
Visual Basic
Public Shared ReadOnly Property ExtensionsOverlapWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ExtensionsOverlapWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


InvalidReflectivityPercentage Property

[image]

Revit 2024 API
BuiltInFailures..::..RoomFailures..::..InvalidReflectivityPercentage Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
The value for Reflectivity must be between 0 and 1.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidReflectivityPercentage { get; }
Visual Basic
Public Shared ReadOnly Property InvalidReflectivityPercentage As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidReflectivityPercentage {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


InvisibleRoomBoundElemement Property

[image]

Revit 2024 API
BuiltInFailures..::..RoomFailures..::..InvisibleRoomBoundElemement Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
[Room] Bounding element is invisible in current view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvisibleRoomBoundElemement { get; }
Visual Basic
Public Shared ReadOnly Property InvisibleRoomBoundElemement As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvisibleRoomBoundElemement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


LoadareaRecovered Property

[image]

Revit 2024 API
BuiltInFailures..::..RoomFailures..::..LoadareaRecovered Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
The boundary encloses the region for area based load:[Areabasedload].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId LoadareaRecovered { get; }
Visual Basic
Public Shared ReadOnly Property LoadareaRecovered As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LoadareaRecovered {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


OptionConflictBoundariesVaryOptionSeparate Property

[image]

Revit 2024 API
BuiltInFailures..::..RoomFailures..::..OptionConflictBoundariesVaryOptionSeparate Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
Option Conflict between Rooms.\nRoom boundary differs from the apparent boundary in view '[View Name]'.\nTo resolve, divide space with Room Separation Lines in the Main Model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId OptionConflictBoundariesVaryOptionSeparate { get; }
Visual Basic
Public Shared ReadOnly Property OptionConflictBoundariesVaryOptionSeparate As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OptionConflictBoundariesVaryOptionSeparate {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


OptionConflictInLinkBoundariesVaryMainAddToOptionSet Property

[image]

Revit 2024 API
BuiltInFailures..::..RoomFailures..::..OptionConflictInLinkBoundariesVaryMainAddToOptionSet Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
Option conflict between rooms in the Revit link '[Link Instance Name]'.\nThe room boundary in the main model of the Revit link differs from the apparent boundary in the linked view '[View Name from Link]'.\nTo resolve the issue, open the Revit link file for editing, select the main model room, and use the Add to Design Option Set tool.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId OptionConflictInLinkBoundariesVaryMainAddToOptionSet { get; }
Visual Basic
Public Shared ReadOnly Property OptionConflictInLinkBoundariesVaryMainAddToOptionSet As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OptionConflictInLinkBoundariesVaryMainAddToOptionSet {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


OptionConflictInLinkBoundariesVaryOptionSeparate Property

[image]

Revit 2024 API
BuiltInFailures..::..RoomFailures..::..OptionConflictInLinkBoundariesVaryOptionSeparate Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
Option conflict between rooms in the Revit link '[Link Instance Name]'.\nThe room boundary differs from the apparent boundary in the linked view '[View Name from Link]'.\nTo resolve the issue, open the Revit link file for editing, and use room separation lines to divide the space in the main model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId OptionConflictInLinkBoundariesVaryOptionSeparate { get; }
Visual Basic
Public Shared ReadOnly Property OptionConflictInLinkBoundariesVaryOptionSeparate As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OptionConflictInLinkBoundariesVaryOptionSeparate {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


OptionConflictInLinkRoomOverlapMain Property

[image]

Revit 2024 API
BuiltInFailures..::..RoomFailures..::..OptionConflictInLinkRoomOverlapMain Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
Option conflict between rooms in the Revit link '[Link Instance Name]'.\nThe room in the Revit link's option '[Option Name in Link]' overlaps a room in the main model.\nTo resolve the issue, open the Revit link file for editing, select the main model room, and use the Add to Design Option Set tool.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId OptionConflictInLinkRoomOverlapMain { get; }
Visual Basic
Public Shared ReadOnly Property OptionConflictInLinkRoomOverlapMain As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OptionConflictInLinkRoomOverlapMain {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


OptionConflictInLinkRoomOverlapOption Property

[image]

Revit 2024 API
BuiltInFailures..::..RoomFailures..::..OptionConflictInLinkRoomOverlapOption Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
Option conflict between rooms in the Revit link '[Link Instance Name]'.\nA room in the Revit link's option '[Option #1 Name in Link]' overlaps a room in the Revit link's option '[Option #2 Name in Link]'.\nTo resolve the issue, open the Revit link file for editing, and delete the duplicate room or use room separation lines to divide the space in the main model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId OptionConflictInLinkRoomOverlapOption { get; }
Visual Basic
Public Shared ReadOnly Property OptionConflictInLinkRoomOverlapOption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OptionConflictInLinkRoomOverlapOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


OptionConflictRoomOverlapMain Property

[image]

Revit 2024 API
BuiltInFailures..::..RoomFailures..::..OptionConflictRoomOverlapMain Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
Option Conflict between Rooms.\nRoom in Option '[Option Name]' overlaps Room in the Main Model.\nTo resolve, select the Main Model Room and use the Add to Design Option Set command.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId OptionConflictRoomOverlapMain { get; }
Visual Basic
Public Shared ReadOnly Property OptionConflictRoomOverlapMain As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OptionConflictRoomOverlapMain {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


OptionConflictRoomOverlapOption Property

[image]

Revit 2024 API
BuiltInFailures..::..RoomFailures..::..OptionConflictRoomOverlapOption Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
Option Conflict between Rooms.\nRoom in Option '[Option Name]' overlaps Room in Option '[Option Name]'.\nTo resolve, delete the duplicate Room or divide space with Room Separation Lines in the Main Model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId OptionConflictRoomOverlapOption { get; }
Visual Basic
Public Shared ReadOnly Property OptionConflictRoomOverlapOption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OptionConflictRoomOverlapOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


RoomBelowCompHeight Property

[image]

Revit 2024 API
BuiltInFailures..::..RoomFailures..::..RoomBelowCompHeight Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
[Room] Volume is being calculated above the Upper Limit of this [Room]. Change the Upper Limit and Offset or change the height of volume calculations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RoomBelowCompHeight { get; }
Visual Basic
Public Shared ReadOnly Property RoomBelowCompHeight As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomBelowCompHeight {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


RoomBoundaryMisalignment Property

[image]

Revit 2024 API
BuiltInFailures..::..RoomFailures..::..RoomBoundaryMisalignment Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
[Room] bounding element might be misaligned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RoomBoundaryMisalignment { get; }
Visual Basic
Public Shared ReadOnly Property RoomBoundaryMisalignment As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomBoundaryMisalignment {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


RoomLevelElevs Property

[image]

Revit 2024 API
BuiltInFailures..::..RoomFailures..::..RoomLevelElevs Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
A [Room]s Upper Limit must be above its Base Level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RoomLevelElevs { get; }
Visual Basic
Public Shared ReadOnly Property RoomLevelElevs As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomLevelElevs {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


RoomNotEnclosed Property

[image]

Revit 2024 API
BuiltInFailures..::..RoomFailures..::..RoomNotEnclosed Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
[Room] is not in a properly enclosed region

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RoomNotEnclosed { get; }
Visual Basic
Public Shared ReadOnly Property RoomNotEnclosed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomNotEnclosed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


RoomNotEnclosedAreas Property

[image]

Revit 2024 API
BuiltInFailures..::..RoomFailures..::..RoomNotEnclosedAreas Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
[Room] is not in a properly enclosed region

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RoomNotEnclosedAreas { get; }
Visual Basic
Public Shared ReadOnly Property RoomNotEnclosedAreas As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomNotEnclosedAreas {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


RoomNotEnclosedLoadAreas Property

[image]

Revit 2024 API
BuiltInFailures..::..RoomFailures..::..RoomNotEnclosedLoadAreas Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
[Room] is not in a properly enclosed region

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RoomNotEnclosedLoadAreas { get; }
Visual Basic
Public Shared ReadOnly Property RoomNotEnclosedLoadAreas As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomNotEnclosedLoadAreas {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


RoomNotEnclosedSpaces Property

[image]

Revit 2024 API
BuiltInFailures..::..RoomFailures..::..RoomNotEnclosedSpaces Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
[Room] is not in a properly enclosed region

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RoomNotEnclosedSpaces { get; }
Visual Basic
Public Shared ReadOnly Property RoomNotEnclosedSpaces As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomNotEnclosedSpaces {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


RoomsFailed Property

[image]

Revit 2024 API
BuiltInFailures..::..RoomFailures..::..RoomsFailed Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
[Room] computations only succeeded without considering the following elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RoomsFailed { get; }
Visual Basic
Public Shared ReadOnly Property RoomsFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomsFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


RoomsInSameRegion Property

[image]

Revit 2024 API
BuiltInFailures..::..RoomFailures..::..RoomsInSameRegion Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RoomsInSameRegion { get; }
Visual Basic
Public Shared ReadOnly Property RoomsInSameRegion As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomsInSameRegion {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


RoomsInSameRegionAreas Property

[image]

Revit 2024 API
BuiltInFailures..::..RoomFailures..::..RoomsInSameRegionAreas Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RoomsInSameRegionAreas { get; }
Visual Basic
Public Shared ReadOnly Property RoomsInSameRegionAreas As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomsInSameRegionAreas {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


RoomsInSameRegionRooms Property

[image]

Revit 2024 API
BuiltInFailures..::..RoomFailures..::..RoomsInSameRegionRooms Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RoomsInSameRegionRooms { get; }
Visual Basic
Public Shared ReadOnly Property RoomsInSameRegionRooms As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomsInSameRegionRooms {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


RoomsInSameRegionSpaces Property

[image]

Revit 2024 API
BuiltInFailures..::..RoomFailures..::..RoomsInSameRegionSpaces Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RoomsInSameRegionSpaces { get; }
Visual Basic
Public Shared ReadOnly Property RoomsInSameRegionSpaces As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomsInSameRegionSpaces {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


RoomsOverlapInHeight Property

[image]

Revit 2024 API
BuiltInFailures..::..RoomFailures..::..RoomsOverlapInHeight Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
[Room] volumes overlap. Adjust the Upper Limit and Limit Offset properties of the [rooms].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RoomsOverlapInHeight { get; }
Visual Basic
Public Shared ReadOnly Property RoomsOverlapInHeight As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomsOverlapInHeight {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


RoomsReallyFailed Property

[image]

Revit 2024 API
BuiltInFailures..::..RoomFailures..::..RoomsReallyFailed Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
[Room] computations failed. Try to modify the following elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RoomsReallyFailed { get; }
Visual Basic
Public Shared ReadOnly Property RoomsReallyFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomsReallyFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


RoomTagDeleted Property

[image]

Revit 2024 API
BuiltInFailures..::..RoomFailures..::..RoomTagDeleted Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
A [Room] Tag was deleted, but the corresponding [Room] still exists. You can place another tag for the [Room] using the [Room] Tag tool or select the [Room] and delete it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RoomTagDeleted { get; }
Visual Basic
Public Shared ReadOnly Property RoomTagDeleted As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomTagDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


RoomTagNotInRoom Property

[image]

Revit 2024 API
BuiltInFailures..::..RoomFailures..::..RoomTagNotInRoom Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
[Room] Tag is outside of its [Room]. Enable Leader or move [Room] Tag within its [Room].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RoomTagNotInRoom { get; }
Visual Basic
Public Shared ReadOnly Property RoomTagNotInRoom As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomTagNotInRoom {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


RoomTagNotInRoomToArea Property

[image]

Revit 2024 API
BuiltInFailures..::..RoomFailures..::..RoomTagNotInRoomToArea Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
[Room] Tag is outside of its [Room]. Enable Leader or move [Room] Tag within its [Room].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RoomTagNotInRoomToArea { get; }
Visual Basic
Public Shared ReadOnly Property RoomTagNotInRoomToArea As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomTagNotInRoomToArea {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


RoomTagNotInRoomToRoom Property

[image]

Revit 2024 API
BuiltInFailures..::..RoomFailures..::..RoomTagNotInRoomToRoom Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
[Room] Tag is outside of its [Room]. Enable Leader or move [Room] Tag within its [Room].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RoomTagNotInRoomToRoom { get; }
Visual Basic
Public Shared ReadOnly Property RoomTagNotInRoomToRoom As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomTagNotInRoomToRoom {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


RoomTagNotInRoomToSpace Property

[image]

Revit 2024 API
BuiltInFailures..::..RoomFailures..::..RoomTagNotInRoomToSpace Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
[Room] Tag is outside of its [Room]. Enable Leader or move [Room] Tag within its [Room].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RoomTagNotInRoomToSpace { get; }
Visual Basic
Public Shared ReadOnly Property RoomTagNotInRoomToSpace As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomTagNotInRoomToSpace {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


RoomTagVolumeNotComputed Property

[image]

Revit 2024 API
BuiltInFailures..::..RoomFailures..::..RoomTagVolumeNotComputed Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
[Room] Tag is displaying volume that can't be computed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RoomTagVolumeNotComputed { get; }
Visual Basic
Public Shared ReadOnly Property RoomTagVolumeNotComputed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomTagVolumeNotComputed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


RoomTooShort Property

[image]

Revit 2024 API
BuiltInFailures..::..RoomFailures..::..RoomTooShort Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
[Room] is very short. If this is not intended, change its Upper Limit and Offset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RoomTooShort { get; }
Visual Basic
Public Shared ReadOnly Property RoomTooShort As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomTooShort {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


RoomUnplaceWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..RoomFailures..::..RoomUnplaceWarning Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
A Room was deleted from all model views but still remains in this project. \n The room can be removed from any schedule or placed back in the model using the Room command.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RoomUnplaceWarning { get; }
Visual Basic
Public Shared ReadOnly Property RoomUnplaceWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomUnplaceWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


ShowRoomBoundingElements Property

[image]

Revit 2024 API
BuiltInFailures..::..RoomFailures..::..ShowRoomBoundingElements Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
[Room] Bounding elements are highlighted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ShowRoomBoundingElements { get; }
Visual Basic
Public Shared ReadOnly Property ShowRoomBoundingElements As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ShowRoomBoundingElements {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


BuiltInFailures.ScaleFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..ScaleFailures Members
BuiltInFailures..::..ScaleFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..ScaleFailures type exposes the following members.

Properties

Name | Description
CannotScaleLinkWithSharedCoordinates | Can't scale link that shares coordinates with host model

See Also

BuiltInFailures..::..ScaleFailures Class


BuiltInFailures.ScaleFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..ScaleFailures Properties
BuiltInFailures..::..ScaleFailures Class See Also Send Feedback

The BuiltInFailures..::..ScaleFailures type exposes the following members.

Properties

Name | Description
CannotScaleLinkWithSharedCoordinates | Can't scale link that shares coordinates with host model

See Also

BuiltInFailures..::..ScaleFailures Class


CannotScaleLinkWithSharedCoordinates Property

[image]

Revit 2024 API
BuiltInFailures..::..ScaleFailures..::..CannotScaleLinkWithSharedCoordinates Property
BuiltInFailures..::..ScaleFailures Class See Also Send Feedback
Can't scale link that shares coordinates with host model

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotScaleLinkWithSharedCoordinates { get; }
Visual Basic
Public Shared ReadOnly Property CannotScaleLinkWithSharedCoordinates As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotScaleLinkWithSharedCoordinates {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ScaleFailures Class


BuiltInFailures.ScheduleViewFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..ScheduleViewFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class ScheduleViewFailures
Visual Basic
Public NotInheritable Class ScheduleViewFailures
Visual C++
public ref class ScheduleViewFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..ScheduleViewFailures

See Also

BuiltInFailures..::..ScheduleViewFailures Members


BuiltInFailures.ScheduleViewFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..ScheduleViewFailures Properties
BuiltInFailures..::..ScheduleViewFailures Class See Also Send Feedback

The BuiltInFailures..::..ScheduleViewFailures type exposes the following members.

Properties

Name | Description
BadViewType | Schedules can only be placed on Sheets.
CannotResizeColumn | Can't resize column.
ColumnsExceedSegment | Some columns in Graphical Column Schedule exceed the segment's upper/lower bounds. You can add levels or adjust the view parameters.
ColumnsExcluded | Some columns in the project are excluded from the graphical column schedule view.
CustomFieldNecessaryIdDeleted | An element that is needed to compute the field [field name] from [schedule name] schedule was deleted.
DuplicateFieldRemovedFromKeySchedule | Duplicate fields across key schedules will be removed after paste.
NoColumnsJoinedToGridLines | No columns are joined to grid lines, or view parameters exclude all columns.
NotGridName | '[Text]' is not a Grid line name
PanelScheduleLoadClassInconsistency | You have one or more loads connected to this panel that are not displayed in the panel schedule. Add the load classification(s) to the associated template to report this information in the Loads Summary.
PanelScheduleSlotInconsistency | The template applied to this panel schedule is set to display fewer slots than what is needed to display the maximum number of 1-pole breakers set on the equipment.
PanelScheduleSwitchboardSlotInconsistency | The template applied to this panel schedule is set to display fewer space than what is needed to display the max number of circuits set on the equipment.
SchedulesCanBePlacedOnSheetsOnly | Schedules can only be placed on Sheets.
SegmentsStartIsGreaterThanSegmentsEnd | Change values so Segments End is greater than or equal to Segments Start.

See Also

BuiltInFailures..::..ScheduleViewFailures Class


BadViewType Property

[image]

Revit 2024 API
BuiltInFailures..::..ScheduleViewFailures..::..BadViewType Property
BuiltInFailures..::..ScheduleViewFailures Class See Also Send Feedback
Schedules can only be placed on Sheets.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId BadViewType { get; }
Visual Basic
Public Shared ReadOnly Property BadViewType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BadViewType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ScheduleViewFailures Class


CannotResizeColumn Property

[image]

Revit 2024 API
BuiltInFailures..::..ScheduleViewFailures..::..CannotResizeColumn Property
BuiltInFailures..::..ScheduleViewFailures Class See Also Send Feedback
Can't resize column.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotResizeColumn { get; }
Visual Basic
Public Shared ReadOnly Property CannotResizeColumn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotResizeColumn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ScheduleViewFailures Class


ColumnsExceedSegment Property

[image]

Revit 2024 API
BuiltInFailures..::..ScheduleViewFailures..::..ColumnsExceedSegment Property
BuiltInFailures..::..ScheduleViewFailures Class See Also Send Feedback
Some columns in Graphical Column Schedule exceed the segment's upper/lower bounds. You can add levels or adjust the view parameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ColumnsExceedSegment { get; }
Visual Basic
Public Shared ReadOnly Property ColumnsExceedSegment As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ColumnsExceedSegment {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ScheduleViewFailures Class


CustomFieldNecessaryIdDeleted Property

[image]

Revit 2024 API
BuiltInFailures..::..ScheduleViewFailures..::..CustomFieldNecessaryIdDeleted Property
BuiltInFailures..::..ScheduleViewFailures Class See Also Send Feedback
An element that is needed to compute the field [field name] from [schedule name] schedule was deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CustomFieldNecessaryIdDeleted { get; }
Visual Basic
Public Shared ReadOnly Property CustomFieldNecessaryIdDeleted As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CustomFieldNecessaryIdDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ScheduleViewFailures Class


DuplicateFieldRemovedFromKeySchedule Property

[image]

Revit 2024 API
BuiltInFailures..::..ScheduleViewFailures..::..DuplicateFieldRemovedFromKeySchedule Property
BuiltInFailures..::..ScheduleViewFailures Class See Also Send Feedback
Duplicate fields across key schedules will be removed after paste.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DuplicateFieldRemovedFromKeySchedule { get; }
Visual Basic
Public Shared ReadOnly Property DuplicateFieldRemovedFromKeySchedule As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DuplicateFieldRemovedFromKeySchedule {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ScheduleViewFailures Class


NoColumnsJoinedToGridLines Property

[image]

Revit 2024 API
BuiltInFailures..::..ScheduleViewFailures..::..NoColumnsJoinedToGridLines Property
BuiltInFailures..::..ScheduleViewFailures Class See Also Send Feedback
No columns are joined to grid lines, or view parameters exclude all columns.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoColumnsJoinedToGridLines { get; }
Visual Basic
Public Shared ReadOnly Property NoColumnsJoinedToGridLines As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoColumnsJoinedToGridLines {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ScheduleViewFailures Class


NotGridName Property

[image]

Revit 2024 API
BuiltInFailures..::..ScheduleViewFailures..::..NotGridName Property
BuiltInFailures..::..ScheduleViewFailures Class See Also Send Feedback
'[Text]' is not a Grid line name

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NotGridName { get; }
Visual Basic
Public Shared ReadOnly Property NotGridName As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotGridName {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ScheduleViewFailures Class


PanelScheduleLoadClassInconsistency Property

[image]

Revit 2024 API
BuiltInFailures..::..ScheduleViewFailures..::..PanelScheduleLoadClassInconsistency Property
BuiltInFailures..::..ScheduleViewFailures Class See Also Send Feedback
You have one or more loads connected to this panel that are not displayed in the panel schedule. Add the load classification(s) to the associated template to report this information in the Loads Summary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId PanelScheduleLoadClassInconsistency { get; }
Visual Basic
Public Shared ReadOnly Property PanelScheduleLoadClassInconsistency As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PanelScheduleLoadClassInconsistency {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ScheduleViewFailures Class


PanelScheduleSlotInconsistency Property

[image]

Revit 2024 API
BuiltInFailures..::..ScheduleViewFailures..::..PanelScheduleSlotInconsistency Property
BuiltInFailures..::..ScheduleViewFailures Class See Also Send Feedback
The template applied to this panel schedule is set to display fewer slots than what is needed to display the maximum number of 1-pole breakers set on the equipment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId PanelScheduleSlotInconsistency { get; }
Visual Basic
Public Shared ReadOnly Property PanelScheduleSlotInconsistency As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PanelScheduleSlotInconsistency {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ScheduleViewFailures Class


PanelScheduleSwitchboardSlotInconsistency Property

[image]

Revit 2024 API
BuiltInFailures..::..ScheduleViewFailures..::..PanelScheduleSwitchboardSlotInconsistency Property
BuiltInFailures..::..ScheduleViewFailures Class See Also Send Feedback
The template applied to this panel schedule is set to display fewer space than what is needed to display the max number of circuits set on the equipment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId PanelScheduleSwitchboardSlotInconsistency { get; }
Visual Basic
Public Shared ReadOnly Property PanelScheduleSwitchboardSlotInconsistency As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PanelScheduleSwitchboardSlotInconsistency {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ScheduleViewFailures Class


SchedulesCanBePlacedOnSheetsOnly Property

[image]

Revit 2024 API
BuiltInFailures..::..ScheduleViewFailures..::..SchedulesCanBePlacedOnSheetsOnly Property
BuiltInFailures..::..ScheduleViewFailures Class See Also Send Feedback
Schedules can only be placed on Sheets.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SchedulesCanBePlacedOnSheetsOnly { get; }
Visual Basic
Public Shared ReadOnly Property SchedulesCanBePlacedOnSheetsOnly As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SchedulesCanBePlacedOnSheetsOnly {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ScheduleViewFailures Class


SegmentsStartIsGreaterThanSegmentsEnd Property

[image]

Revit 2024 API
BuiltInFailures..::..ScheduleViewFailures..::..SegmentsStartIsGreaterThanSegmentsEnd Property
BuiltInFailures..::..ScheduleViewFailures Class See Also Send Feedback
Change values so Segments End is greater than or equal to Segments Start.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SegmentsStartIsGreaterThanSegmentsEnd { get; }
Visual Basic
Public Shared ReadOnly Property SegmentsStartIsGreaterThanSegmentsEnd As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SegmentsStartIsGreaterThanSegmentsEnd {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ScheduleViewFailures Class


BuiltInFailures.SculptingFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..SculptingFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Sculpting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class SculptingFailures
Visual Basic
Public NotInheritable Class SculptingFailures
Visual C++
public ref class SculptingFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..SculptingFailures

See Also

BuiltInFailures..::..SculptingFailures Members


BuiltInFailures.SculptingFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..SculptingFailures Members
BuiltInFailures..::..SculptingFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..SculptingFailures type exposes the following members.

Properties

Name | Description
FaceSculptEditFailed | Face Sculpt Edit failed.
FaceSculptingFaceLoss | The original sculpted face is lost.

See Also

BuiltInFailures..::..SculptingFailures Class


BuiltInFailures.SculptingFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..SculptingFailures Properties
BuiltInFailures..::..SculptingFailures Class See Also Send Feedback

The BuiltInFailures..::..SculptingFailures type exposes the following members.

Properties

Name | Description
FaceSculptEditFailed | Face Sculpt Edit failed.
FaceSculptingFaceLoss | The original sculpted face is lost.

See Also

BuiltInFailures..::..SculptingFailures Class


FaceSculptEditFailed Property

[image]

Revit 2024 API
BuiltInFailures..::..SculptingFailures..::..FaceSculptEditFailed Property
BuiltInFailures..::..SculptingFailures Class See Also Send Feedback
Face Sculpt Edit failed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FaceSculptEditFailed { get; }
Visual Basic
Public Shared ReadOnly Property FaceSculptEditFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FaceSculptEditFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SculptingFailures Class


FaceSculptingFaceLoss Property

[image]

Revit 2024 API
BuiltInFailures..::..SculptingFailures..::..FaceSculptingFaceLoss Property
BuiltInFailures..::..SculptingFailures Class See Also Send Feedback
The original sculpted face is lost.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FaceSculptingFaceLoss { get; }
Visual Basic
Public Shared ReadOnly Property FaceSculptingFaceLoss As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FaceSculptingFaceLoss {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SculptingFailures Class


BuiltInFailures.SectionViewFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..SectionViewFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Section.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class SectionViewFailures
Visual Basic
Public NotInheritable Class SectionViewFailures
Visual C++
public ref class SectionViewFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..SectionViewFailures

See Also

BuiltInFailures..::..SectionViewFailures Members


BuiltInFailures.SectionViewFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..SectionViewFailures Members
BuiltInFailures..::..SectionViewFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..SectionViewFailures type exposes the following members.

Properties

Name | Description
ScopeBoxBehindSection | Section may not be associated to a scope box which lies behind it.

See Also

BuiltInFailures..::..SectionViewFailures Class


BuiltInFailures.SectionViewFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..SectionViewFailures Properties
BuiltInFailures..::..SectionViewFailures Class See Also Send Feedback

The BuiltInFailures..::..SectionViewFailures type exposes the following members.

Properties

Name | Description
ScopeBoxBehindSection | Section may not be associated to a scope box which lies behind it.

See Also

BuiltInFailures..::..SectionViewFailures Class


ScopeBoxBehindSection Property

[image]

Revit 2024 API
BuiltInFailures..::..SectionViewFailures..::..ScopeBoxBehindSection Property
BuiltInFailures..::..SectionViewFailures Class See Also Send Feedback
Section may not be associated to a scope box which lies behind it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ScopeBoxBehindSection { get; }
Visual Basic
Public Shared ReadOnly Property ScopeBoxBehindSection As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ScopeBoxBehindSection {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SectionViewFailures Class


BuiltInFailures.SelectionFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..SelectionFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Selections.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class SelectionFailures
Visual Basic
Public NotInheritable Class SelectionFailures
Visual C++
public ref class SelectionFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..SelectionFailures

See Also

BuiltInFailures..::..SelectionFailures Members


BuiltInFailures.SelectionFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..SelectionFailures Members
BuiltInFailures..::..SelectionFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..SelectionFailures type exposes the following members.

Properties

Name | Description
NoElementSelected | No element selected.
NoValidElementSelected | No valid element selected.

See Also

BuiltInFailures..::..SelectionFailures Class


BuiltInFailures.SelectionFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..SelectionFailures Properties
BuiltInFailures..::..SelectionFailures Class See Also Send Feedback

The BuiltInFailures..::..SelectionFailures type exposes the following members.

Properties

Name | Description
NoElementSelected | No element selected.
NoValidElementSelected | No valid element selected.

See Also

BuiltInFailures..::..SelectionFailures Class


NoElementSelected Property

[image]

Revit 2024 API
BuiltInFailures..::..SelectionFailures..::..NoElementSelected Property
BuiltInFailures..::..SelectionFailures Class See Also Send Feedback
No element selected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoElementSelected { get; }
Visual Basic
Public Shared ReadOnly Property NoElementSelected As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoElementSelected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SelectionFailures Class


NoValidElementSelected Property

[image]

Revit 2024 API
BuiltInFailures..::..SelectionFailures..::..NoValidElementSelected Property
BuiltInFailures..::..SelectionFailures Class See Also Send Feedback
No valid element selected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoValidElementSelected { get; }
Visual Basic
Public Shared ReadOnly Property NoValidElementSelected As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoValidElementSelected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SelectionFailures Class


BuiltInFailures.SharedCoordinatesFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..SharedCoordinatesFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about shared coordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class SharedCoordinatesFailures
Visual Basic
Public NotInheritable Class SharedCoordinatesFailures
Visual C++
public ref class SharedCoordinatesFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..SharedCoordinatesFailures

See Also

BuiltInFailures..::..SharedCoordinatesFailures Members


BuiltInFailures.SharedCoordinatesFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..SharedCoordinatesFailures Members
BuiltInFailures..::..SharedCoordinatesFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..SharedCoordinatesFailures type exposes the following members.

Properties

Name | Description
CannotAcquireCoordinatesFromLinkWithScaledLocation | Can't acquire coordiantes from a link that has a scaled location.
CannotAcquireCoordinatesFromScaledLink | Can't acquire coordinates from a link that is scaled.

See Also

BuiltInFailures..::..SharedCoordinatesFailures Class


CannotAcquireCoordinatesFromLinkWithScaledLocation Property

[image]

Revit 2024 API
BuiltInFailures..::..SharedCoordinatesFailures..::..CannotAcquireCoordinatesFromLinkWithScaledLocation Property
BuiltInFailures..::..SharedCoordinatesFailures Class See Also Send Feedback
Can't acquire coordiantes from a link that has a scaled location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotAcquireCoordinatesFromLinkWithScaledLocation { get; }
Visual Basic
Public Shared ReadOnly Property CannotAcquireCoordinatesFromLinkWithScaledLocation As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotAcquireCoordinatesFromLinkWithScaledLocation {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SharedCoordinatesFailures Class


CannotAcquireCoordinatesFromScaledLink Property

[image]

Revit 2024 API
BuiltInFailures..::..SharedCoordinatesFailures..::..CannotAcquireCoordinatesFromScaledLink Property
BuiltInFailures..::..SharedCoordinatesFailures Class See Also Send Feedback
Can't acquire coordinates from a link that is scaled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotAcquireCoordinatesFromScaledLink { get; }
Visual Basic
Public Shared ReadOnly Property CannotAcquireCoordinatesFromScaledLink As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotAcquireCoordinatesFromScaledLink {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SharedCoordinatesFailures Class


BuiltInFailures.SheetFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..SheetFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class SheetFailures
Visual Basic
Public NotInheritable Class SheetFailures
Visual C++
public ref class SheetFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..SheetFailures

See Also

BuiltInFailures..::..SheetFailures Members


BuiltInFailures.SheetFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..SheetFailures Members
BuiltInFailures..::..SheetFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..SheetFailures type exposes the following members.

Properties

Name | Description
SheetNumberDuplicated | Sheet Number is already in use. Enter a unique number.
SheetNumberEmpty | Sheet Number is empty

See Also

BuiltInFailures..::..SheetFailures Class


BuiltInFailures.SheetFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..SheetFailures Properties
BuiltInFailures..::..SheetFailures Class See Also Send Feedback

The BuiltInFailures..::..SheetFailures type exposes the following members.

Properties

Name | Description
SheetNumberDuplicated | Sheet Number is already in use. Enter a unique number.
SheetNumberEmpty | Sheet Number is empty

See Also

BuiltInFailures..::..SheetFailures Class


SheetNumberDuplicated Property

[image]

Revit 2024 API
BuiltInFailures..::..SheetFailures..::..SheetNumberDuplicated Property
BuiltInFailures..::..SheetFailures Class See Also Send Feedback
Sheet Number is already in use. Enter a unique number.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SheetNumberDuplicated { get; }
Visual Basic
Public Shared ReadOnly Property SheetNumberDuplicated As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SheetNumberDuplicated {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SheetFailures Class


SheetNumberEmpty Property

[image]

Revit 2024 API
BuiltInFailures..::..SheetFailures..::..SheetNumberEmpty Property
BuiltInFailures..::..SheetFailures Class See Also Send Feedback
Sheet Number is empty

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SheetNumberEmpty { get; }
Visual Basic
Public Shared ReadOnly Property SheetNumberEmpty As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SheetNumberEmpty {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SheetFailures Class


BuiltInFailures.SiteFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..SiteFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Site.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class SiteFailures
Visual Basic
Public NotInheritable Class SiteFailures
Visual C++
public ref class SiteFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..SiteFailures

See Also

BuiltInFailures..::..SiteFailures Members


BuiltInFailures.SiteFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..SiteFailures Members
BuiltInFailures..::..SiteFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..SiteFailures type exposes the following members.

Properties

Name | Description
BuildingPadNotConnected | Can't create a single Pad with several connected regions.
BuildingPadOverlap | Pads can't overlap (but can share edges).
CannotComputeProperArea | Property Lines must close. Area will not be computed.
CannotIntersectSiteRegions | Subregions cannot intersect.
CannotMakeSurface | Can't construct surface.
ContourLabelEmpty | Contour Label doesn't intersect any contours.
EnterValueOrFormula | Enter a value or a formula starting with '='.
GradingInSamePhase | The Surface being Graded was created in the current Phase. Grading it will result in it being created and destroyed in the same Phase.
NoHostForSubregion | This Subregion now does not appear to overlap any Toposurface with an appropriate Phase and Design Option.
NoHostForSubregionWarn | This Subregion now does not appear to overlap any Toposurface with an appropriate Phase and Design Option.
NotEnoughPointsInSurface | The surface must have at least three distinct Points.
PointNotInSurface | A Point is outside of the Surface boundary. Insert the Point on the boundary instead, and then drag it to the desired location.
PointRelativeOutside | In order to place Points relative to the existing Surface, the Point must be placed within the area of the existing Surface. The height of the new Point will be relative to the current Surface elevation at that Point.
PropertyIntersect | Property lines intersect. Area calculations will not be precise.
RegionPhaseMismatch | Subregions must have the same Phase Created parameter and Phase Demolished parameter as the host Toposurface. Subregion phase will be set to match the Toposurface.
ResetToposurfacePhaseCreated | The parameter Phase Created of the Toposurface is not set to the first Phase. No pre-existing toposurface were detected. The parameter will be reset to the first Phase unless Keep Phase Created option is picked.
SiteEditPointsClipped | Portions of the topographic surface or points on the surface may not be visible in this view due to clipping by the view.
SiteEditPointsInvisible | Topographic elements are not visible in your current view. You can modify View Range settings in the view's Properties or Visibility settings in Visibility/Graphics. It is often easier to edit topography in a Site view or a 3D view.
SiteMergeDisconnected | The two surfaces you are trying to merge are disconnected from one another. They should overlap, or at least share edges.
SitePhasesDontOverlap | The phases of the two surfaces you are merging do not overlap. You can continue the operation, or cancel it and select a different pair of surfaces.
SiteRegionOptionConflict | Subregions must be in the same Design Option as their Toposurface.
SurfaceSelfIntersection | The splitting boundary drawn would result in a self-intersection of the surface boundary. Please edit your splitting lines to correct the problem.
SurfaceSplit | The splitting boundary must split the Surface into exactly two pieces.
SurfaceSplitError | The splitting boundary must split the Surface into exactly two pieces.
SurfaceSplitNoIntersection | The splitting boundary must divide the Surface into separate pieces. There may be a gap in the splitting Lines or the Sketch may be incomplete.
SurfaceTriangulationFailed | The Site Surface failed to triangulate.
ToposolidSlopeExceedsThreshold | Thickness of this Toposolid may be slightly inaccurate due to extreme Shape Editing. Dimensions to this element in sections and details may not accurately indicate the Thickness shown in Type Properties.

See Also

BuiltInFailures..::..SiteFailures Class


BuiltInFailures.SiteFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..SiteFailures Properties
BuiltInFailures..::..SiteFailures Class See Also Send Feedback

The BuiltInFailures..::..SiteFailures type exposes the following members.

Properties

Name | Description
BuildingPadNotConnected | Can't create a single Pad with several connected regions.
BuildingPadOverlap | Pads can't overlap (but can share edges).
CannotComputeProperArea | Property Lines must close. Area will not be computed.
CannotIntersectSiteRegions | Subregions cannot intersect.
CannotMakeSurface | Can't construct surface.
ContourLabelEmpty | Contour Label doesn't intersect any contours.
EnterValueOrFormula | Enter a value or a formula starting with '='.
GradingInSamePhase | The Surface being Graded was created in the current Phase. Grading it will result in it being created and destroyed in the same Phase.
NoHostForSubregion | This Subregion now does not appear to overlap any Toposurface with an appropriate Phase and Design Option.
NoHostForSubregionWarn | This Subregion now does not appear to overlap any Toposurface with an appropriate Phase and Design Option.
NotEnoughPointsInSurface | The surface must have at least three distinct Points.
PointNotInSurface | A Point is outside of the Surface boundary. Insert the Point on the boundary instead, and then drag it to the desired location.
PointRelativeOutside | In order to place Points relative to the existing Surface, the Point must be placed within the area of the existing Surface. The height of the new Point will be relative to the current Surface elevation at that Point.
PropertyIntersect | Property lines intersect. Area calculations will not be precise.
RegionPhaseMismatch | Subregions must have the same Phase Created parameter and Phase Demolished parameter as the host Toposurface. Subregion phase will be set to match the Toposurface.
ResetToposurfacePhaseCreated | The parameter Phase Created of the Toposurface is not set to the first Phase. No pre-existing toposurface were detected. The parameter will be reset to the first Phase unless Keep Phase Created option is picked.
SiteEditPointsClipped | Portions of the topographic surface or points on the surface may not be visible in this view due to clipping by the view.
SiteEditPointsInvisible | Topographic elements are not visible in your current view. You can modify View Range settings in the view's Properties or Visibility settings in Visibility/Graphics. It is often easier to edit topography in a Site view or a 3D view.
SiteMergeDisconnected | The two surfaces you are trying to merge are disconnected from one another. They should overlap, or at least share edges.
SitePhasesDontOverlap | The phases of the two surfaces you are merging do not overlap. You can continue the operation, or cancel it and select a different pair of surfaces.
SiteRegionOptionConflict | Subregions must be in the same Design Option as their Toposurface.
SurfaceSelfIntersection | The splitting boundary drawn would result in a self-intersection of the surface boundary. Please edit your splitting lines to correct the problem.
SurfaceSplit | The splitting boundary must split the Surface into exactly two pieces.
SurfaceSplitError | The splitting boundary must split the Surface into exactly two pieces.
SurfaceSplitNoIntersection | The splitting boundary must divide the Surface into separate pieces. There may be a gap in the splitting Lines or the Sketch may be incomplete.
SurfaceTriangulationFailed | The Site Surface failed to triangulate.
ToposolidSlopeExceedsThreshold | Thickness of this Toposolid may be slightly inaccurate due to extreme Shape Editing. Dimensions to this element in sections and details may not accurately indicate the Thickness shown in Type Properties.

See Also

BuiltInFailures..::..SiteFailures Class


BuildingPadNotConnected Property

[image]

Revit 2024 API
BuiltInFailures..::..SiteFailures..::..BuildingPadNotConnected Property
BuiltInFailures..::..SiteFailures Class See Also Send Feedback
Can't create a single Pad with several connected regions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId BuildingPadNotConnected { get; }
Visual Basic
Public Shared ReadOnly Property BuildingPadNotConnected As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BuildingPadNotConnected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteFailures Class


BuildingPadOverlap Property

[image]

Revit 2024 API
BuiltInFailures..::..SiteFailures..::..BuildingPadOverlap Property
BuiltInFailures..::..SiteFailures Class See Also Send Feedback
Pads can't overlap (but can share edges).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId BuildingPadOverlap { get; }
Visual Basic
Public Shared ReadOnly Property BuildingPadOverlap As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BuildingPadOverlap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteFailures Class


CannotIntersectSiteRegions Property

[image]

Revit 2024 API
BuiltInFailures..::..SiteFailures..::..CannotIntersectSiteRegions Property
BuiltInFailures..::..SiteFailures Class See Also Send Feedback
Subregions cannot intersect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotIntersectSiteRegions { get; }
Visual Basic
Public Shared ReadOnly Property CannotIntersectSiteRegions As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotIntersectSiteRegions {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteFailures Class


CannotMakeSurface Property

[image]

Revit 2024 API
BuiltInFailures..::..SiteFailures..::..CannotMakeSurface Property
BuiltInFailures..::..SiteFailures Class See Also Send Feedback
Can't construct surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotMakeSurface { get; }
Visual Basic
Public Shared ReadOnly Property CannotMakeSurface As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMakeSurface {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteFailures Class


ContourLabelEmpty Property

[image]

Revit 2024 API
BuiltInFailures..::..SiteFailures..::..ContourLabelEmpty Property
BuiltInFailures..::..SiteFailures Class See Also Send Feedback
Contour Label doesn't intersect any contours.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ContourLabelEmpty { get; }
Visual Basic
Public Shared ReadOnly Property ContourLabelEmpty As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ContourLabelEmpty {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteFailures Class


EnterValueOrFormula Property

[image]

Revit 2024 API
BuiltInFailures..::..SiteFailures..::..EnterValueOrFormula Property
BuiltInFailures..::..SiteFailures Class See Also Send Feedback
Enter a value or a formula starting with '='.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId EnterValueOrFormula { get; }
Visual Basic
Public Shared ReadOnly Property EnterValueOrFormula As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ EnterValueOrFormula {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteFailures Class


GradingInSamePhase Property

[image]

Revit 2024 API
BuiltInFailures..::..SiteFailures..::..GradingInSamePhase Property
BuiltInFailures..::..SiteFailures Class See Also Send Feedback
The Surface being Graded was created in the current Phase. Grading it will result in it being created and destroyed in the same Phase.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId GradingInSamePhase { get; }
Visual Basic
Public Shared ReadOnly Property GradingInSamePhase As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GradingInSamePhase {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteFailures Class


NoHostForSubregion Property

[image]

Revit 2024 API
BuiltInFailures..::..SiteFailures..::..NoHostForSubregion Property
BuiltInFailures..::..SiteFailures Class See Also Send Feedback
This Subregion now does not appear to overlap any Toposurface with an appropriate Phase and Design Option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoHostForSubregion { get; }
Visual Basic
Public Shared ReadOnly Property NoHostForSubregion As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoHostForSubregion {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteFailures Class


NoHostForSubregionWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..SiteFailures..::..NoHostForSubregionWarn Property
BuiltInFailures..::..SiteFailures Class See Also Send Feedback
This Subregion now does not appear to overlap any Toposurface with an appropriate Phase and Design Option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoHostForSubregionWarn { get; }
Visual Basic
Public Shared ReadOnly Property NoHostForSubregionWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoHostForSubregionWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteFailures Class


NotEnoughPointsInSurface Property

[image]

Revit 2024 API
BuiltInFailures..::..SiteFailures..::..NotEnoughPointsInSurface Property
BuiltInFailures..::..SiteFailures Class See Also Send Feedback
The surface must have at least three distinct Points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NotEnoughPointsInSurface { get; }
Visual Basic
Public Shared ReadOnly Property NotEnoughPointsInSurface As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotEnoughPointsInSurface {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteFailures Class


PointNotInSurface Property

[image]

Revit 2024 API
BuiltInFailures..::..SiteFailures..::..PointNotInSurface Property
BuiltInFailures..::..SiteFailures Class See Also Send Feedback
A Point is outside of the Surface boundary. Insert the Point on the boundary instead, and then drag it to the desired location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId PointNotInSurface { get; }
Visual Basic
Public Shared ReadOnly Property PointNotInSurface As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PointNotInSurface {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteFailures Class


PointRelativeOutside Property

[image]

Revit 2024 API
BuiltInFailures..::..SiteFailures..::..PointRelativeOutside Property
BuiltInFailures..::..SiteFailures Class See Also Send Feedback
In order to place Points relative to the existing Surface, the Point must be placed within the area of the existing Surface. The height of the new Point will be relative to the current Surface elevation at that Point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId PointRelativeOutside { get; }
Visual Basic
Public Shared ReadOnly Property PointRelativeOutside As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PointRelativeOutside {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteFailures Class


PropertyIntersect Property

[image]

Revit 2024 API
BuiltInFailures..::..SiteFailures..::..PropertyIntersect Property
BuiltInFailures..::..SiteFailures Class See Also Send Feedback
Property lines intersect. Area calculations will not be precise.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId PropertyIntersect { get; }
Visual Basic
Public Shared ReadOnly Property PropertyIntersect As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PropertyIntersect {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteFailures Class


ResetToposurfacePhaseCreated Property

[image]

Revit 2024 API
BuiltInFailures..::..SiteFailures..::..ResetToposurfacePhaseCreated Property
BuiltInFailures..::..SiteFailures Class See Also Send Feedback
The parameter Phase Created of the Toposurface is not set to the first Phase. No pre-existing toposurface were detected. The parameter will be reset to the first Phase unless Keep Phase Created option is picked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ResetToposurfacePhaseCreated { get; }
Visual Basic
Public Shared ReadOnly Property ResetToposurfacePhaseCreated As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ResetToposurfacePhaseCreated {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteFailures Class


SiteEditPointsClipped Property

[image]

Revit 2024 API
BuiltInFailures..::..SiteFailures..::..SiteEditPointsClipped Property
BuiltInFailures..::..SiteFailures Class See Also Send Feedback
Portions of the topographic surface or points on the surface may not be visible in this view due to clipping by the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SiteEditPointsClipped { get; }
Visual Basic
Public Shared ReadOnly Property SiteEditPointsClipped As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SiteEditPointsClipped {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteFailures Class


SiteEditPointsInvisible Property

[image]

Revit 2024 API
BuiltInFailures..::..SiteFailures..::..SiteEditPointsInvisible Property
BuiltInFailures..::..SiteFailures Class See Also Send Feedback
Topographic elements are not visible in your current view. You can modify View Range settings in the view's Properties or Visibility settings in Visibility/Graphics. It is often easier to edit topography in a Site view or a 3D view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SiteEditPointsInvisible { get; }
Visual Basic
Public Shared ReadOnly Property SiteEditPointsInvisible As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SiteEditPointsInvisible {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteFailures Class


SiteRegionOptionConflict Property

[image]

Revit 2024 API
BuiltInFailures..::..SiteFailures..::..SiteRegionOptionConflict Property
BuiltInFailures..::..SiteFailures Class See Also Send Feedback
Subregions must be in the same Design Option as their Toposurface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SiteRegionOptionConflict { get; }
Visual Basic
Public Shared ReadOnly Property SiteRegionOptionConflict As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SiteRegionOptionConflict {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteFailures Class


SurfaceSplit Property

[image]

Revit 2024 API
BuiltInFailures..::..SiteFailures..::..SurfaceSplit Property
BuiltInFailures..::..SiteFailures Class See Also Send Feedback
The splitting boundary must split the Surface into exactly two pieces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SurfaceSplit { get; }
Visual Basic
Public Shared ReadOnly Property SurfaceSplit As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SurfaceSplit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteFailures Class


SurfaceSplitError Property

[image]

Revit 2024 API
BuiltInFailures..::..SiteFailures..::..SurfaceSplitError Property
BuiltInFailures..::..SiteFailures Class See Also Send Feedback
The splitting boundary must split the Surface into exactly two pieces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SurfaceSplitError { get; }
Visual Basic
Public Shared ReadOnly Property SurfaceSplitError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SurfaceSplitError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteFailures Class


SurfaceSplitNoIntersection Property

[image]

Revit 2024 API
BuiltInFailures..::..SiteFailures..::..SurfaceSplitNoIntersection Property
BuiltInFailures..::..SiteFailures Class See Also Send Feedback
The splitting boundary must divide the Surface into separate pieces. There may be a gap in the splitting Lines or the Sketch may be incomplete.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SurfaceSplitNoIntersection { get; }
Visual Basic
Public Shared ReadOnly Property SurfaceSplitNoIntersection As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SurfaceSplitNoIntersection {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteFailures Class


SurfaceTriangulationFailed Property

[image]

Revit 2024 API
BuiltInFailures..::..SiteFailures..::..SurfaceTriangulationFailed Property
BuiltInFailures..::..SiteFailures Class See Also Send Feedback
The Site Surface failed to triangulate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SurfaceTriangulationFailed { get; }
Visual Basic
Public Shared ReadOnly Property SurfaceTriangulationFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SurfaceTriangulationFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteFailures Class


ToposolidSlopeExceedsThreshold Property

[image]

Revit 2024 API
BuiltInFailures..::..SiteFailures..::..ToposolidSlopeExceedsThreshold Property
BuiltInFailures..::..SiteFailures Class See Also Send Feedback
Thickness of this Toposolid may be slightly inaccurate due to extreme Shape Editing. Dimensions to this element in sections and details may not accurately indicate the Thickness shown in Type Properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ToposolidSlopeExceedsThreshold { get; }
Visual Basic
Public Shared ReadOnly Property ToposolidSlopeExceedsThreshold As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ToposolidSlopeExceedsThreshold {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteFailures Class


BuiltInFailures.SiteImportFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..SiteImportFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about SiteImport.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class SiteImportFailures
Visual Basic
Public NotInheritable Class SiteImportFailures
Visual C++
public ref class SiteImportFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..SiteImportFailures

See Also

BuiltInFailures..::..SiteImportFailures Members


BuiltInFailures.SiteImportFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..SiteImportFailures Properties
BuiltInFailures..::..SiteImportFailures Class See Also Send Feedback

The BuiltInFailures..::..SiteImportFailures type exposes the following members.

Properties

Name | Description
BoundaryDetectError | A boundary on this surface could not be autodetected. Revit will impose one, but it may be larger than you want.
ContoursNoncontours | The layers you have selected contain both contour lines and non-contour lines (lines of non-constant elevation). You may want to go back and select fewer layers, or you can continue, but the boundary of the site may be larger than you want.
DifferentEntityTypes | Can't auto-detect boundary. The layers selected contain data that may make the Toposurface look incorrect. For better results, try selecting only those layers that contain relevant 3D info.
InvalidBoundaryError | Failed to get a valid boundary.
NoPoints | No points were found in the file.
NoViewSpecificSiteImports | Can't make Toposurface from View Specific Imports.
SurfaceExists | You are importing data into a surface that already contains points. You may want to go back, create a new surface, and import the data into that instead. You can continue, and Revit will sew the meshes together, but the boundary may be larger than you want.
TooFarAway | Imported Toposolid Points are located a large distance from the model and might not display properly. Points will be centered on the model instead.
TooFewPoints | The toposolid must have at least three distinct points
TooLarge | There are too many points on the selected layers of this dataset to place into the toposolid. Try selecting fewer layers to create the toposolid
TooManyMeshes | The layers you have selected contain more than one mesh. You may want to go back and import the meshes separately. If you continue, the meshes will be combined and a new boundary will be created.
UnusedPoints | Some rows from the file could not be used.

See Also

BuiltInFailures..::..SiteImportFailures Class


BoundaryDetectError Property

[image]

Revit 2024 API
BuiltInFailures..::..SiteImportFailures..::..BoundaryDetectError Property
BuiltInFailures..::..SiteImportFailures Class See Also Send Feedback
A boundary on this surface could not be autodetected. Revit will impose one, but it may be larger than you want.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId BoundaryDetectError { get; }
Visual Basic
Public Shared ReadOnly Property BoundaryDetectError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BoundaryDetectError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteImportFailures Class


DifferentEntityTypes Property

[image]

Revit 2024 API
BuiltInFailures..::..SiteImportFailures..::..DifferentEntityTypes Property
BuiltInFailures..::..SiteImportFailures Class See Also Send Feedback
Can't auto-detect boundary. The layers selected contain data that may make the Toposurface look incorrect. For better results, try selecting only those layers that contain relevant 3D info.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DifferentEntityTypes { get; }
Visual Basic
Public Shared ReadOnly Property DifferentEntityTypes As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DifferentEntityTypes {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteImportFailures Class


InvalidBoundaryError Property

[image]

Revit 2024 API
BuiltInFailures..::..SiteImportFailures..::..InvalidBoundaryError Property
BuiltInFailures..::..SiteImportFailures Class See Also Send Feedback
Failed to get a valid boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidBoundaryError { get; }
Visual Basic
Public Shared ReadOnly Property InvalidBoundaryError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidBoundaryError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteImportFailures Class


NoPoints Property

[image]

Revit 2024 API
BuiltInFailures..::..SiteImportFailures..::..NoPoints Property
BuiltInFailures..::..SiteImportFailures Class See Also Send Feedback
No points were found in the file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoPoints { get; }
Visual Basic
Public Shared ReadOnly Property NoPoints As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoPoints {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteImportFailures Class


NoViewSpecificSiteImports Property

[image]

Revit 2024 API
BuiltInFailures..::..SiteImportFailures..::..NoViewSpecificSiteImports Property
BuiltInFailures..::..SiteImportFailures Class See Also Send Feedback
Can't make Toposurface from View Specific Imports.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoViewSpecificSiteImports { get; }
Visual Basic
Public Shared ReadOnly Property NoViewSpecificSiteImports As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoViewSpecificSiteImports {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteImportFailures Class


SurfaceExists Property

[image]

Revit 2024 API
BuiltInFailures..::..SiteImportFailures..::..SurfaceExists Property
BuiltInFailures..::..SiteImportFailures Class See Also Send Feedback
You are importing data into a surface that already contains points. You may want to go back, create a new surface, and import the data into that instead. You can continue, and Revit will sew the meshes together, but the boundary may be larger than you want.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SurfaceExists { get; }
Visual Basic
Public Shared ReadOnly Property SurfaceExists As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SurfaceExists {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteImportFailures Class


TooFarAway Property

[image]

Revit 2024 API
BuiltInFailures..::..SiteImportFailures..::..TooFarAway Property
BuiltInFailures..::..SiteImportFailures Class See Also Send Feedback
Imported Toposolid Points are located a large distance from the model and might not display properly. Points will be centered on the model instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId TooFarAway { get; }
Visual Basic
Public Shared ReadOnly Property TooFarAway As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TooFarAway {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteImportFailures Class


TooLarge Property

[image]

Revit 2024 API
BuiltInFailures..::..SiteImportFailures..::..TooLarge Property
BuiltInFailures..::..SiteImportFailures Class See Also Send Feedback
There are too many points on the selected layers of this dataset to place into the toposolid. Try selecting fewer layers to create the toposolid

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId TooLarge { get; }
Visual Basic
Public Shared ReadOnly Property TooLarge As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TooLarge {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteImportFailures Class


TooManyMeshes Property

[image]

Revit 2024 API
BuiltInFailures..::..SiteImportFailures..::..TooManyMeshes Property
BuiltInFailures..::..SiteImportFailures Class See Also Send Feedback
The layers you have selected contain more than one mesh. You may want to go back and import the meshes separately. If you continue, the meshes will be combined and a new boundary will be created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId TooManyMeshes { get; }
Visual Basic
Public Shared ReadOnly Property TooManyMeshes As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TooManyMeshes {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteImportFailures Class


UnusedPoints Property

[image]

Revit 2024 API
BuiltInFailures..::..SiteImportFailures..::..UnusedPoints Property
BuiltInFailures..::..SiteImportFailures Class See Also Send Feedback
Some rows from the file could not be used.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UnusedPoints { get; }
Visual Basic
Public Shared ReadOnly Property UnusedPoints As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnusedPoints {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteImportFailures Class


BuiltInFailures.SketchFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class SketchFailures
Visual Basic
Public NotInheritable Class SketchFailures
Visual C++
public ref class SketchFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..SketchFailures

See Also

BuiltInFailures..::..SketchFailures Members


BuiltInFailures.SketchFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..SketchFailures Properties
BuiltInFailures..::..SketchFailures Class See Also Send Feedback

The BuiltInFailures..::..SketchFailures type exposes the following members.

Properties

Name | Description
AreaLoadNoForce | Area Load can't have all force components equal to zero.
AxisNotSpecified | Axis of revolution not specified.
BadNosingProfile | Stairs nosing profile must have one loop. Wrong profile will not be shown in profiles list in Stairs Type properties.
BadRailingsProfile | Rail profile must have one closed loop. Wrong profile will not be shown in profiles list for rail definition.
BeamDirectionNotSpecified | Beam direction not specified.
BeamDirectionNotSpecifiedError | Beam direction not specified.
BentFabricSheetClosedLoopInSketch | The bend profile cannot contain a closed loop. Click Continue to correct the profile or Click Quit sketching to exit the bend profile editor.
BentFabricSheetEmptySketch | The bend profile requires at least one segment to be placed in a host. Click Continue to correct the profile or Click Quit sketching to exit the bend profile editor.
BentFabricSheetInvalidElementInSketch | Arcs in a bend profile must be separated from one another with a connected straight segment. The bend profile cannot start or end with an arc. Click Continue to correct the profile or Click Quit sketching to exit the bend profile editor.
BentFabricSheetLinesOverlapOrIntersect | Segments in a bend profile cannot overlap, intersect, or be collinearly contiguous. Click Continue to correct the profile or Click Quit sketching to exit the bend profile editor.
BentFabricSheetManyLoopsInSketch | The bend profile cannot contain two or more disconnected segments. Click Continue to correct the profile or Click Quit sketching to exit the bend profile editor.
BentFabricSheetTooShortSegments | A segment in the bend profile is too short to apply the wire bend diameter. The bent fabric sheet of the selected type cannot be placed in a host. Click Continue to correct the profile or Click Quit sketching to exit the bend profile editor.
BoundaryNoOverlap | The split sketch is out of the boundary of split element sketch..
BuildingPadNoSurface | A Pad can't extend beyond the edge of a Toposurface.
BuildingPadNoSurfaceError | A Pad can't extend beyond the edge of a Toposurface.
CannotChangeUserSketchPlane | Can't change plane of [Element Name] Sketch.
CannotChangeUserSketchPlaneError | Can't change plane of [Element Name] Sketch.
CannotChangeWorkplaneVisibility | Can't change Work Plane Visibility.
CannotComputeRailingsElevation | Can't compute Railings Elevation Profile.
CannotComputeRailingsElevationError | Can't compute Railings Elevation Profile.
CannotComputeRailingsElevationWarn | Can't compute Railings Elevation Profile
CannotConvertSketch | Can't convert Sketch to Rebar Shape.
CannotDrawExtrusionRoof | Can't make extruded roof.
CannotDrawProfileRoof | Can't make footprint roof.
CannotGetSketchReferences | Cannot find references to dimension sketch.
CannotHaveArcs | Sorry, we can't use arcs here.
CannotHaveArcsPath3d | Sorry, we can't use arcs here.
CircleMultiPlanarShapeInSketch | A circle can't be converted to multiplanar shape.
ClosedProfileRoof | Extrusion roof sketch must be open. The roof's thickness and material composition are defined in its type.
ConstantHeightNotParallel | Constant-height-defining lines must be parallel.
ConstantHeightNotParallelError | Constant-height-defining lines must be parallel.
ContainedInOtherLoops | When creating an opening, you cannot sketch loops within other loops. The highlighted loop(s) are contained within another loop.
ConvertSplineToLineFailed | Failed to convert spline to straight line
CurveFromPickedFailed | Can't create boundary from pick.
CurveIntersectsCutFace | The highlighted line intersects the boundary of the face being modified. To modify a cut face, use open loops that end on the existing boundary without intersecting or overlapping existing edges.
CurveIntersectsSplitFace | The highlighted line intersects the boundary of the face being split. To split a face at its border, use an open loop that ends on the boundary of the face.
CurveTooShort | Line is too short.
DifferentOffsets | Adjacent slope-defining lines must have identical eave heights; the highlighted lines do not. You can use the Align Eaves tool to have the eaves aligned for you.
ElementsSketchTooLarge | The sketch defining the highlighted element is too large.
ElevationSketchNotAllowed | Wall in a family can't have an elevation profile.
EndsNotOnCutFace | Ends of the sketched loop do not lie on the boundary of the face being modified.
EndsNotOnEdge | Ends of an open loop in sketch splitting face do not lie on an edge of the face to split.
FloorCannotAddDirectionCurve | Cannot add the direction curve in the floor sketch.
FloorCannotAddDirectionCurveError | Cannot add the direction curve in the floor sketch.
FloorDirectionNotSpecified | Structural floor span direction not specified.
FloorManyDirectionCurves | More than one span direction curve specified.
InvalidAreaLoadSketch | Area Load has invalid Sketch.
InvalidCropAreaSketch | Crop area sketch can either be empty or include one closed, not self-intersecting loop.
InvalidCropAreaSketchRegen | Crop area sketch can either be empty or include one closed, not self-intersecting loop.
InvalidElevationSketch | Elevation Profile sketch is invalid.
InvalidElevationSketchError | Elevation Profile sketch is invalid.
InvalidProfile | One or more profiles are invalid. Make sure that every used profile is a closed loop of non-intersecting lines.
InvalidProfileError | One or more profiles are invalid. Make sure that every used profile is a closed loop of non-intersecting lines.
InvalidRoofCurveloop | Base sketch for roof is invalid.
InvalidRoofCurveloopError | Base sketch for roof is invalid
InvalidRoofCurveloopFailure | Base sketch for roof is invalid
InvalidSketch | Sketch is invalid.
InvalidSketchError | Sketch is invalid.
InvalidSketchForBuildingpad | Pad sketch is invalid.
InvalidSketchForCeiling | Ceiling sketch is invalid.
InvalidSketchForFloor | Floor sketch is invalid.
InvalidSketchForRoofsoffit | Roof Soffit sketch is invalid.
InvalidSketchForToposolid | Toposolid sketch is invalid.
InvalidSketchPath3d | Sketch is invalid.
LandingNotEnoughBoundaryCurves | Sketch landing require boundaries
LandingTwoManyLoops | Sketch landing can only have one closed loop
LinesOverlap | Cannot have overlapping lines.
LinesOverlapError | Cannot have overlapping lines.
LinesOverlapPath3d | Cannot have overlapping lines.
LoopIntersect | Lines cannot intersect each other. The highlighted lines currently intersect.
LoopIntersectError | Lines cannot intersect each other. The highlighted lines currently intersect.
LoopIntersectPath3d | Lines cannot intersect each other. The highlighted lines currently intersect.
LoopsOutsideFaceSplit | Some of the lines drawn lie outside of the boundary of the face being split. All lines used to split a face must be contained within the face being split and cannot intersect or overlap any of the boundaries of that face.
LoopsOutsideFaceSplitterTooShort | Some of the lines drawn lie outside of the boundary of the face being split. All lines used to split a face must be contained within the face being split and cannot intersect or overlap any of the boundaries of that face.
ManyCCWLoops | Area defined by sketch must be connected.
ManyCCWLoopsError | Area defined by sketch must be connected.
ManyDirectionCurves | More than one direction curve specified.
ManyDirectionCurvesError | More than one direction curve specified.
MissingLapInSketch | Rebar Sketch does not have lapped lengths. A circular shaped Rebar needs overlapping legths. Please overlap one of the ends of the circular Rebar Sketch.
MoreThanOneAxis | More than one axes of revolution.
MutipleStairsPathInOneRunFailure | Each stairs run can only have one stairs path.
NestedLoops | Cannot have nested loops.
NoLoops | Sketch is empty.
NoLoopsError | Sketch is empty.
NoLoopsPath3d | Sketch is empty.
NonMonotoneRoof | All parts of an extruded roof must face upward. Make sure that no part of the sketch lies below any other part of the sketch.
NoPlane | Highlighted geometry no longer determines a plane
NotOneCCWLoop | This sketch defines more than one footprint. Make sure the sketch contains only one outermost loop and that there are no loops inside inner loops.
NotOneCurve | More than one curve not allowed.
NotOneCurveError | More than one curve not allowed.
NotOneCurvePath3d | More than one curve not allowed.
NotOneLoop | More than one loop not allowed.
NotOneLoopPath3d | More than one loop not allowed.
OpenAreaLoadLoop | Area Load Sketch can't contain open loops.
OpenLoop | Lines must be in closed loops. The highlighted lines are open on one end.
OpenLoopError | Lines must be in closed loops. The highlighted lines are open on one end.
OpenLoopPath3d | Lines must be in closed loops. The highlighted lines are open on one end.
PathCannotBeClosedLoop | Path cannot be a closed loop.
PathCannotBeClosedLoopPath3d | Path cannot be a closed loop.
PathReinforcementClosedLoop | Sketch contains a closed loop. Can't create Path Reinforcement.
PathReinforcementEmptySketch | Sketch is empty. Can't create Path Reinforcement.
PathReinforcementManyLoops | Sketch contains more than one chain. Can't create Path Reinforcement.
PlanarMultiPlanarShapeInSketch | The current shape is only bent in a single plane. A multi-planar definition is not required. Please redefine the shape on the top plane only.
RailingDoublyConnected | Railings hosted on Stairs must form a single, open, connected line.
RailingDoublyConnectedError | Railings hosted on Stairs must form a single, open, connected line.
RailingNotConnected | The Railing line must be a single connected Sketch. If you want separate pieces of Railing, create two or more separate Railings.
RailingNotConnectedError | The Railing line must be a single connected Sketch. If you want separate pieces of Railing, create two or more separate Railings.
RebarEmptySketch | Rebar Sketch is empty. Can't create Rebar.
RebarEmptySketchError | Rebar Sketch is empty. Can't create Rebar.
RebarManyLoops | Rebar Sketch contains more than one loop. Can't create Rebar.
RebarManyLoopsError | Rebar Sketch contains more than one loop. Can't create Rebar.
RebarSystemDirectionNotSpecified | Major direction not specified.
RebarSystemDirectionNotSpecifiedError | Major direction not specified.
RunInvalidSketch | Invalid sketch, can't create run by this sketch
RunNotEnoughBoundaryCurves | Sketch run require boundaries (chains of one or more Boundary Lines)
SculptingCurvesCannotFormClosedLoop | Curves cannot form a closed loop.
SculptingCurvesCrossAxis | The highlighted curves cross the axis.
SculptingCurvesTouchAxis | The highlighted curves touch the axis.
SculptingLoopsOnBothSidesOfAxis | All curves must be on the same side of the axis.
SculptingSingleLineLoopLiesOnAxis | The highlighted lines lie on the axis.
ShortCurveInSketch | The sketch contains an extremely short line.
ShortCurveInSketchRoof | The sketch contains an extremely short line.
SiteCannotDrawSurfaceBoundary | Cannot make surface with specified boundary.
SketchedRunInvalidPath | Invalid stair path. Stair path should connect both start and end riser, and cross all other risers.
SketchedShapeNotAvailable | Skeched shape is not available for this type of element.
SketchFailurePlanes | Sketch is no longer parallel to its defining plane
SketchingInTheWrongView | Detail sketch is only editable in [View Type].
SketchingInWrongView | Detail sketch is not editable in this view.
SketchOverconstrained | Sketch is overconstrained.
SketchOverconstrainedError | Sketch is overconstrained.
SketchOverconstrainedWarn | Sketch is overconstrained.
SketchTooLarge | Sketch is too large.
SketchWasDeleted | Sketch was deleted.
StairClosedBoundaries | Stairs Boundaries (chains of one or more Boundary Lines) should not form closed loops.
StairClosedBoundariesError | Stairs Boundaries (chains of one or more Boundary Lines) should not form closed loops.
StairNotEnoughBoundaryCurves | Stairs require boundaries (chains of one or more Boundary Lines) on each side of the Stair.
StairNotEnoughBoundaryCurvesError | Stairs require boundaries (chains of one or more Boundary Lines) on each side of the Stair.
StairNotEnoughRiserCurves | Boundaries (chains of one or more Boundary Lines) must be connected by at least two Riser Lines.
StairNotEnoughRiserCurvesError | Boundaries (chains of one or more Boundary Lines) must be connected by at least two Riser Lines.
StairOnlyOneConnectedBoundary | Stairs require no less than two boundaries (chains of one or more Boundary Lines)."
StairOnlyOneConnectedBoundaryError | Stairs require no less than two boundaries (chains of one or more Boundary Lines).
StairRiserDoesntIntersectBoundary | The line representing the top of a riser does not intersect one or both of the boundary lines.
StairRiserDoesntIntersectBoundaryError | The line representing the top of a riser does not intersect one or both of the boundary lines.
StairTooManyConnectedBoundaries | Stairs require no more than two boundaries (chains of one or more Boundary Lines).
StairTooManyConnectedBoundariesError | Stairs require no more than two boundaries (chains of one or more Boundary Lines).
SubregionNoHostSurf | A Subregion cannot be created outside the boundary of a Toposurface. A Subregion should be completely inside a Toposurface or overlap a Toposurface.
SuggestMakingFamilyNonParametric | Performance Warning: This family now contains both labeled dimensions and sketches with many segments. This may hurt performance. To improve performance, create elements that require complex sketches as nested families.
SuspendedSketchWarn | Highlighted element's sketch could not regenerate and has been suspended. Select the element and edit its sketch to fix the problem. The element will display in magenta until you fix the problem
TooFewParamsForSketch | The sketched Structural Rebar element has too many segments to be properly parameterized. Please reduce the number of segments.
TooManyElementsInSketch | This sketch is large. Performance will improve if constructed as several independent sketches.
TooManySlopes | There is more than one slope defined.
TooManySlopesError | There is more than one slope defined.
TrussClosedReference | Truss references (chains of one or more reference lines) should not form closed loops."
TrussCrossingReferences | Truss top and bottom references cannot cross.
TrussMissingReference | Trusses require both a top and a bottom chord reference (chain of one or more reference lines).
TrussOverlappingReference | Truss references (chains of one or more reference lines) cannot overlap themselves in the vertical direction.
TrussSegmentedReference | Truss reference must form a continuous chain of one or more sketch lines.
TrussShiftedReferences | Truss top and bottom references (chains of one or more reference lines) must overlap at least partially in the vertical direction.
TrussSwappedReferences | Truss top reference must be above the bottom reference.
UnsatisfiedSupportAssocProp | Constraint between a Line created with Pick Support and the Support is not satisfied.
UnsatisfiedWallAssocProp | Constraint between a Line created with Pick Wall and the Wall is not satisfied.
VarSketchFailure | Constraints defined by highlighted Lines and Dimensions can't be satisfied.
VarSketchInElementFailure | The constraints of the sketch defining the highlighted element cannot be satisfied.
WrongCutBoundaryLoops | Only open loops can be used for Edit Cut Profile. All open ends must lie on the boundary of the cut profile, and the loop may not touch the boundary anywhere except at its ends.
WrongFaceSplitterLoopTypesNum | Sketch for splitting the face is invalid. Faces may be split either by a single closed loop that is contained within the face or by one or more open loops whose ends lie on the boundary of the face. None of the lines in the sketch are allowed to overlap or intersect the boundaries of the face.

See Also

BuiltInFailures..::..SketchFailures Class


AreaLoadNoForce Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..AreaLoadNoForce Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Area Load can't have all force components equal to zero.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AreaLoadNoForce { get; }
Visual Basic
Public Shared ReadOnly Property AreaLoadNoForce As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AreaLoadNoForce {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


AxisNotSpecified Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..AxisNotSpecified Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Axis of revolution not specified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AxisNotSpecified { get; }
Visual Basic
Public Shared ReadOnly Property AxisNotSpecified As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AxisNotSpecified {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


BadNosingProfile Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..BadNosingProfile Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Stairs nosing profile must have one loop. Wrong profile will not be shown in profiles list in Stairs Type properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId BadNosingProfile { get; }
Visual Basic
Public Shared ReadOnly Property BadNosingProfile As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BadNosingProfile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


BadRailingsProfile Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..BadRailingsProfile Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Rail profile must have one closed loop. Wrong profile will not be shown in profiles list for rail definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId BadRailingsProfile { get; }
Visual Basic
Public Shared ReadOnly Property BadRailingsProfile As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BadRailingsProfile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


BeamDirectionNotSpecifiedError Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..BeamDirectionNotSpecifiedError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Beam direction not specified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId BeamDirectionNotSpecifiedError { get; }
Visual Basic
Public Shared ReadOnly Property BeamDirectionNotSpecifiedError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BeamDirectionNotSpecifiedError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


BentFabricSheetClosedLoopInSketch Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..BentFabricSheetClosedLoopInSketch Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
The bend profile cannot contain a closed loop. Click Continue to correct the profile or Click Quit sketching to exit the bend profile editor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId BentFabricSheetClosedLoopInSketch { get; }
Visual Basic
Public Shared ReadOnly Property BentFabricSheetClosedLoopInSketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BentFabricSheetClosedLoopInSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


BentFabricSheetEmptySketch Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..BentFabricSheetEmptySketch Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
The bend profile requires at least one segment to be placed in a host. Click Continue to correct the profile or Click Quit sketching to exit the bend profile editor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId BentFabricSheetEmptySketch { get; }
Visual Basic
Public Shared ReadOnly Property BentFabricSheetEmptySketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BentFabricSheetEmptySketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


BentFabricSheetInvalidElementInSketch Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..BentFabricSheetInvalidElementInSketch Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Arcs in a bend profile must be separated from one another with a connected straight segment. The bend profile cannot start or end with an arc. Click Continue to correct the profile or Click Quit sketching to exit the bend profile editor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId BentFabricSheetInvalidElementInSketch { get; }
Visual Basic
Public Shared ReadOnly Property BentFabricSheetInvalidElementInSketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BentFabricSheetInvalidElementInSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


BoundaryNoOverlap Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..BoundaryNoOverlap Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
The split sketch is out of the boundary of split element sketch..

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId BoundaryNoOverlap { get; }
Visual Basic
Public Shared ReadOnly Property BoundaryNoOverlap As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BoundaryNoOverlap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


BuildingPadNoSurface Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..BuildingPadNoSurface Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
A Pad can't extend beyond the edge of a Toposurface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId BuildingPadNoSurface { get; }
Visual Basic
Public Shared ReadOnly Property BuildingPadNoSurface As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BuildingPadNoSurface {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


BuildingPadNoSurfaceError Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..BuildingPadNoSurfaceError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
A Pad can't extend beyond the edge of a Toposurface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId BuildingPadNoSurfaceError { get; }
Visual Basic
Public Shared ReadOnly Property BuildingPadNoSurfaceError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BuildingPadNoSurfaceError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


CannotChangeUserSketchPlane Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..CannotChangeUserSketchPlane Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Can't change plane of [Element Name] Sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotChangeUserSketchPlane { get; }
Visual Basic
Public Shared ReadOnly Property CannotChangeUserSketchPlane As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotChangeUserSketchPlane {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


CannotChangeUserSketchPlaneError Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..CannotChangeUserSketchPlaneError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Can't change plane of [Element Name] Sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotChangeUserSketchPlaneError { get; }
Visual Basic
Public Shared ReadOnly Property CannotChangeUserSketchPlaneError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotChangeUserSketchPlaneError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


CannotChangeWorkplaneVisibility Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..CannotChangeWorkplaneVisibility Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Can't change Work Plane Visibility.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotChangeWorkplaneVisibility { get; }
Visual Basic
Public Shared ReadOnly Property CannotChangeWorkplaneVisibility As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotChangeWorkplaneVisibility {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


CannotComputeRailingsElevationError Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..CannotComputeRailingsElevationError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Can't compute Railings Elevation Profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotComputeRailingsElevationError { get; }
Visual Basic
Public Shared ReadOnly Property CannotComputeRailingsElevationError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotComputeRailingsElevationError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


CannotComputeRailingsElevationWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..CannotComputeRailingsElevationWarn Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Can't compute Railings Elevation Profile

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotComputeRailingsElevationWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotComputeRailingsElevationWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotComputeRailingsElevationWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


CannotConvertSketch Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..CannotConvertSketch Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Can't convert Sketch to Rebar Shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotConvertSketch { get; }
Visual Basic
Public Shared ReadOnly Property CannotConvertSketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotConvertSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


CannotDrawProfileRoof Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..CannotDrawProfileRoof Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Can't make footprint roof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotDrawProfileRoof { get; }
Visual Basic
Public Shared ReadOnly Property CannotDrawProfileRoof As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDrawProfileRoof {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


CannotGetSketchReferences Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..CannotGetSketchReferences Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Cannot find references to dimension sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotGetSketchReferences { get; }
Visual Basic
Public Shared ReadOnly Property CannotGetSketchReferences As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotGetSketchReferences {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


CannotHaveArcs Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..CannotHaveArcs Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Sorry, we can't use arcs here.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotHaveArcs { get; }
Visual Basic
Public Shared ReadOnly Property CannotHaveArcs As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotHaveArcs {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


ClosedProfileRoof Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..ClosedProfileRoof Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Extrusion roof sketch must be open. The roof's thickness and material composition are defined in its type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ClosedProfileRoof { get; }
Visual Basic
Public Shared ReadOnly Property ClosedProfileRoof As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ClosedProfileRoof {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


ConstantHeightNotParallel Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..ConstantHeightNotParallel Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Constant-height-defining lines must be parallel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ConstantHeightNotParallel { get; }
Visual Basic
Public Shared ReadOnly Property ConstantHeightNotParallel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ConstantHeightNotParallel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


ContainedInOtherLoops Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..ContainedInOtherLoops Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
When creating an opening, you cannot sketch loops within other loops. The highlighted loop(s) are contained within another loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ContainedInOtherLoops { get; }
Visual Basic
Public Shared ReadOnly Property ContainedInOtherLoops As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ContainedInOtherLoops {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


ConvertSplineToLineFailed Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..ConvertSplineToLineFailed Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Failed to convert spline to straight line

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ConvertSplineToLineFailed { get; }
Visual Basic
Public Shared ReadOnly Property ConvertSplineToLineFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ConvertSplineToLineFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


CurveFromPickedFailed Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..CurveFromPickedFailed Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Can't create boundary from pick.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CurveFromPickedFailed { get; }
Visual Basic
Public Shared ReadOnly Property CurveFromPickedFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CurveFromPickedFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


CurveIntersectsCutFace Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..CurveIntersectsCutFace Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
The highlighted line intersects the boundary of the face being modified. To modify a cut face, use open loops that end on the existing boundary without intersecting or overlapping existing edges.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CurveIntersectsCutFace { get; }
Visual Basic
Public Shared ReadOnly Property CurveIntersectsCutFace As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CurveIntersectsCutFace {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


CurveIntersectsSplitFace Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..CurveIntersectsSplitFace Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
The highlighted line intersects the boundary of the face being split. To split a face at its border, use an open loop that ends on the boundary of the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CurveIntersectsSplitFace { get; }
Visual Basic
Public Shared ReadOnly Property CurveIntersectsSplitFace As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CurveIntersectsSplitFace {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


CurveTooShort Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..CurveTooShort Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Line is too short.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CurveTooShort { get; }
Visual Basic
Public Shared ReadOnly Property CurveTooShort As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CurveTooShort {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


ElementsSketchTooLarge Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..ElementsSketchTooLarge Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
The sketch defining the highlighted element is too large.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ElementsSketchTooLarge { get; }
Visual Basic
Public Shared ReadOnly Property ElementsSketchTooLarge As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementsSketchTooLarge {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


ElevationSketchNotAllowed Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..ElevationSketchNotAllowed Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Wall in a family can't have an elevation profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ElevationSketchNotAllowed { get; }
Visual Basic
Public Shared ReadOnly Property ElevationSketchNotAllowed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElevationSketchNotAllowed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


EndsNotOnEdge Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..EndsNotOnEdge Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Ends of an open loop in sketch splitting face do not lie on an edge of the face to split.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId EndsNotOnEdge { get; }
Visual Basic
Public Shared ReadOnly Property EndsNotOnEdge As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ EndsNotOnEdge {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


FloorCannotAddDirectionCurve Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..FloorCannotAddDirectionCurve Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Cannot add the direction curve in the floor sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FloorCannotAddDirectionCurve { get; }
Visual Basic
Public Shared ReadOnly Property FloorCannotAddDirectionCurve As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FloorCannotAddDirectionCurve {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


FloorCannotAddDirectionCurveError Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..FloorCannotAddDirectionCurveError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Cannot add the direction curve in the floor sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FloorCannotAddDirectionCurveError { get; }
Visual Basic
Public Shared ReadOnly Property FloorCannotAddDirectionCurveError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FloorCannotAddDirectionCurveError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


FloorDirectionNotSpecified Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..FloorDirectionNotSpecified Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Structural floor span direction not specified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FloorDirectionNotSpecified { get; }
Visual Basic
Public Shared ReadOnly Property FloorDirectionNotSpecified As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FloorDirectionNotSpecified {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


FloorManyDirectionCurves Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..FloorManyDirectionCurves Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
More than one span direction curve specified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FloorManyDirectionCurves { get; }
Visual Basic
Public Shared ReadOnly Property FloorManyDirectionCurves As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FloorManyDirectionCurves {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


InvalidCropAreaSketch Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..InvalidCropAreaSketch Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Crop area sketch can either be empty or include one closed, not self-intersecting loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidCropAreaSketch { get; }
Visual Basic
Public Shared ReadOnly Property InvalidCropAreaSketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidCropAreaSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


InvalidCropAreaSketchRegen Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..InvalidCropAreaSketchRegen Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Crop area sketch can either be empty or include one closed, not self-intersecting loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidCropAreaSketchRegen { get; }
Visual Basic
Public Shared ReadOnly Property InvalidCropAreaSketchRegen As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidCropAreaSketchRegen {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


InvalidElevationSketch Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..InvalidElevationSketch Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Elevation Profile sketch is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidElevationSketch { get; }
Visual Basic
Public Shared ReadOnly Property InvalidElevationSketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidElevationSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


InvalidElevationSketchError Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..InvalidElevationSketchError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Elevation Profile sketch is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidElevationSketchError { get; }
Visual Basic
Public Shared ReadOnly Property InvalidElevationSketchError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidElevationSketchError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


InvalidProfileError Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..InvalidProfileError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
One or more profiles are invalid. Make sure that every used profile is a closed loop of non-intersecting lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidProfileError { get; }
Visual Basic
Public Shared ReadOnly Property InvalidProfileError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidProfileError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


InvalidRoofCurveloopError Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..InvalidRoofCurveloopError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Base sketch for roof is invalid

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidRoofCurveloopError { get; }
Visual Basic
Public Shared ReadOnly Property InvalidRoofCurveloopError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidRoofCurveloopError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


InvalidRoofCurveloopFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..InvalidRoofCurveloopFailure Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Base sketch for roof is invalid

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidRoofCurveloopFailure { get; }
Visual Basic
Public Shared ReadOnly Property InvalidRoofCurveloopFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidRoofCurveloopFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


InvalidSketchForBuildingpad Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..InvalidSketchForBuildingpad Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Pad sketch is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidSketchForBuildingpad { get; }
Visual Basic
Public Shared ReadOnly Property InvalidSketchForBuildingpad As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidSketchForBuildingpad {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


InvalidSketchForCeiling Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..InvalidSketchForCeiling Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Ceiling sketch is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidSketchForCeiling { get; }
Visual Basic
Public Shared ReadOnly Property InvalidSketchForCeiling As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidSketchForCeiling {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


InvalidSketchForRoofsoffit Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..InvalidSketchForRoofsoffit Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Roof Soffit sketch is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidSketchForRoofsoffit { get; }
Visual Basic
Public Shared ReadOnly Property InvalidSketchForRoofsoffit As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidSketchForRoofsoffit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


InvalidSketchForToposolid Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..InvalidSketchForToposolid Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Toposolid sketch is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidSketchForToposolid { get; }
Visual Basic
Public Shared ReadOnly Property InvalidSketchForToposolid As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidSketchForToposolid {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


LandingNotEnoughBoundaryCurves Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..LandingNotEnoughBoundaryCurves Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Sketch landing require boundaries

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId LandingNotEnoughBoundaryCurves { get; }
Visual Basic
Public Shared ReadOnly Property LandingNotEnoughBoundaryCurves As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LandingNotEnoughBoundaryCurves {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


LinesOverlap Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..LinesOverlap Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Cannot have overlapping lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId LinesOverlap { get; }
Visual Basic
Public Shared ReadOnly Property LinesOverlap As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LinesOverlap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


LinesOverlapError Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..LinesOverlapError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Cannot have overlapping lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId LinesOverlapError { get; }
Visual Basic
Public Shared ReadOnly Property LinesOverlapError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LinesOverlapError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


LinesOverlapPath3d Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..LinesOverlapPath3d Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Cannot have overlapping lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId LinesOverlapPath3d { get; }
Visual Basic
Public Shared ReadOnly Property LinesOverlapPath3d As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LinesOverlapPath3d {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


LoopIntersect Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..LoopIntersect Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Lines cannot intersect each other. The highlighted lines currently intersect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId LoopIntersect { get; }
Visual Basic
Public Shared ReadOnly Property LoopIntersect As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LoopIntersect {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


LoopIntersectError Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..LoopIntersectError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Lines cannot intersect each other. The highlighted lines currently intersect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId LoopIntersectError { get; }
Visual Basic
Public Shared ReadOnly Property LoopIntersectError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LoopIntersectError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


LoopIntersectPath3d Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..LoopIntersectPath3d Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Lines cannot intersect each other. The highlighted lines currently intersect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId LoopIntersectPath3d { get; }
Visual Basic
Public Shared ReadOnly Property LoopIntersectPath3d As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LoopIntersectPath3d {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


LoopsOutsideFaceSplit Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..LoopsOutsideFaceSplit Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Some of the lines drawn lie outside of the boundary of the face being split. All lines used to split a face must be contained within the face being split and cannot intersect or overlap any of the boundaries of that face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId LoopsOutsideFaceSplit { get; }
Visual Basic
Public Shared ReadOnly Property LoopsOutsideFaceSplit As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LoopsOutsideFaceSplit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


LoopsOutsideFaceSplitterTooShort Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..LoopsOutsideFaceSplitterTooShort Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Some of the lines drawn lie outside of the boundary of the face being split. All lines used to split a face must be contained within the face being split and cannot intersect or overlap any of the boundaries of that face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId LoopsOutsideFaceSplitterTooShort { get; }
Visual Basic
Public Shared ReadOnly Property LoopsOutsideFaceSplitterTooShort As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LoopsOutsideFaceSplitterTooShort {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


ManyCCWLoopsError Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..ManyCCWLoopsError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Area defined by sketch must be connected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ManyCCWLoopsError { get; }
Visual Basic
Public Shared ReadOnly Property ManyCCWLoopsError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ManyCCWLoopsError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


ManyDirectionCurves Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..ManyDirectionCurves Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
More than one direction curve specified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ManyDirectionCurves { get; }
Visual Basic
Public Shared ReadOnly Property ManyDirectionCurves As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ManyDirectionCurves {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


ManyDirectionCurvesError Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..ManyDirectionCurvesError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
More than one direction curve specified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ManyDirectionCurvesError { get; }
Visual Basic
Public Shared ReadOnly Property ManyDirectionCurvesError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ManyDirectionCurvesError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


MissingLapInSketch Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..MissingLapInSketch Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Rebar Sketch does not have lapped lengths. A circular shaped Rebar needs overlapping legths. Please overlap one of the ends of the circular Rebar Sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MissingLapInSketch { get; }
Visual Basic
Public Shared ReadOnly Property MissingLapInSketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MissingLapInSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


MoreThanOneAxis Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..MoreThanOneAxis Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
More than one axes of revolution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MoreThanOneAxis { get; }
Visual Basic
Public Shared ReadOnly Property MoreThanOneAxis As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MoreThanOneAxis {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


MutipleStairsPathInOneRunFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..MutipleStairsPathInOneRunFailure Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Each stairs run can only have one stairs path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MutipleStairsPathInOneRunFailure { get; }
Visual Basic
Public Shared ReadOnly Property MutipleStairsPathInOneRunFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MutipleStairsPathInOneRunFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


NestedLoops Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..NestedLoops Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Cannot have nested loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NestedLoops { get; }
Visual Basic
Public Shared ReadOnly Property NestedLoops As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NestedLoops {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


NonMonotoneRoof Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..NonMonotoneRoof Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
All parts of an extruded roof must face upward. Make sure that no part of the sketch lies below any other part of the sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NonMonotoneRoof { get; }
Visual Basic
Public Shared ReadOnly Property NonMonotoneRoof As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NonMonotoneRoof {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


NoPlane Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..NoPlane Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Highlighted geometry no longer determines a plane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoPlane { get; }
Visual Basic
Public Shared ReadOnly Property NoPlane As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoPlane {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


NotOneCCWLoop Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..NotOneCCWLoop Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
This sketch defines more than one footprint. Make sure the sketch contains only one outermost loop and that there are no loops inside inner loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NotOneCCWLoop { get; }
Visual Basic
Public Shared ReadOnly Property NotOneCCWLoop As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotOneCCWLoop {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


NotOneCurve Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..NotOneCurve Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
More than one curve not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NotOneCurve { get; }
Visual Basic
Public Shared ReadOnly Property NotOneCurve As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotOneCurve {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


NotOneCurveError Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..NotOneCurveError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
More than one curve not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NotOneCurveError { get; }
Visual Basic
Public Shared ReadOnly Property NotOneCurveError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotOneCurveError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


NotOneLoop Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..NotOneLoop Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
More than one loop not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NotOneLoop { get; }
Visual Basic
Public Shared ReadOnly Property NotOneLoop As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotOneLoop {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


OpenAreaLoadLoop Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..OpenAreaLoadLoop Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Area Load Sketch can't contain open loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId OpenAreaLoadLoop { get; }
Visual Basic
Public Shared ReadOnly Property OpenAreaLoadLoop As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OpenAreaLoadLoop {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


OpenLoopError Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..OpenLoopError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Lines must be in closed loops. The highlighted lines are open on one end.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId OpenLoopError { get; }
Visual Basic
Public Shared ReadOnly Property OpenLoopError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OpenLoopError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


OpenLoopPath3d Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..OpenLoopPath3d Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Lines must be in closed loops. The highlighted lines are open on one end.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId OpenLoopPath3d { get; }
Visual Basic
Public Shared ReadOnly Property OpenLoopPath3d As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OpenLoopPath3d {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


PathCannotBeClosedLoop Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..PathCannotBeClosedLoop Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Path cannot be a closed loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId PathCannotBeClosedLoop { get; }
Visual Basic
Public Shared ReadOnly Property PathCannotBeClosedLoop As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PathCannotBeClosedLoop {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


PathCannotBeClosedLoopPath3d Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..PathCannotBeClosedLoopPath3d Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Path cannot be a closed loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId PathCannotBeClosedLoopPath3d { get; }
Visual Basic
Public Shared ReadOnly Property PathCannotBeClosedLoopPath3d As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PathCannotBeClosedLoopPath3d {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


PathReinforcementEmptySketch Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..PathReinforcementEmptySketch Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Sketch is empty. Can't create Path Reinforcement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId PathReinforcementEmptySketch { get; }
Visual Basic
Public Shared ReadOnly Property PathReinforcementEmptySketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PathReinforcementEmptySketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


PathReinforcementManyLoops Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..PathReinforcementManyLoops Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Sketch contains more than one chain. Can't create Path Reinforcement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId PathReinforcementManyLoops { get; }
Visual Basic
Public Shared ReadOnly Property PathReinforcementManyLoops As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PathReinforcementManyLoops {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


PlanarMultiPlanarShapeInSketch Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..PlanarMultiPlanarShapeInSketch Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
The current shape is only bent in a single plane. A multi-planar definition is not required. Please redefine the shape on the top plane only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId PlanarMultiPlanarShapeInSketch { get; }
Visual Basic
Public Shared ReadOnly Property PlanarMultiPlanarShapeInSketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PlanarMultiPlanarShapeInSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


RailingDoublyConnected Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..RailingDoublyConnected Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Railings hosted on Stairs must form a single, open, connected line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RailingDoublyConnected { get; }
Visual Basic
Public Shared ReadOnly Property RailingDoublyConnected As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RailingDoublyConnected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


RailingDoublyConnectedError Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..RailingDoublyConnectedError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Railings hosted on Stairs must form a single, open, connected line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RailingDoublyConnectedError { get; }
Visual Basic
Public Shared ReadOnly Property RailingDoublyConnectedError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RailingDoublyConnectedError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


RailingNotConnected Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..RailingNotConnected Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
The Railing line must be a single connected Sketch. If you want separate pieces of Railing, create two or more separate Railings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RailingNotConnected { get; }
Visual Basic
Public Shared ReadOnly Property RailingNotConnected As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RailingNotConnected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


RailingNotConnectedError Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..RailingNotConnectedError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
The Railing line must be a single connected Sketch. If you want separate pieces of Railing, create two or more separate Railings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RailingNotConnectedError { get; }
Visual Basic
Public Shared ReadOnly Property RailingNotConnectedError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RailingNotConnectedError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


RebarEmptySketch Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..RebarEmptySketch Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Rebar Sketch is empty. Can't create Rebar.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RebarEmptySketch { get; }
Visual Basic
Public Shared ReadOnly Property RebarEmptySketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RebarEmptySketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


RebarEmptySketchError Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..RebarEmptySketchError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Rebar Sketch is empty. Can't create Rebar.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RebarEmptySketchError { get; }
Visual Basic
Public Shared ReadOnly Property RebarEmptySketchError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RebarEmptySketchError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


RebarManyLoops Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..RebarManyLoops Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Rebar Sketch contains more than one loop. Can't create Rebar.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RebarManyLoops { get; }
Visual Basic
Public Shared ReadOnly Property RebarManyLoops As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RebarManyLoops {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


RebarSystemDirectionNotSpecified Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..RebarSystemDirectionNotSpecified Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Major direction not specified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RebarSystemDirectionNotSpecified { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemDirectionNotSpecified As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RebarSystemDirectionNotSpecified {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


RebarSystemDirectionNotSpecifiedError Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..RebarSystemDirectionNotSpecifiedError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Major direction not specified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RebarSystemDirectionNotSpecifiedError { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemDirectionNotSpecifiedError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RebarSystemDirectionNotSpecifiedError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


RunInvalidSketch Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..RunInvalidSketch Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Invalid sketch, can't create run by this sketch

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RunInvalidSketch { get; }
Visual Basic
Public Shared ReadOnly Property RunInvalidSketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RunInvalidSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


SculptingCurvesCannotFormClosedLoop Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..SculptingCurvesCannotFormClosedLoop Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Curves cannot form a closed loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SculptingCurvesCannotFormClosedLoop { get; }
Visual Basic
Public Shared ReadOnly Property SculptingCurvesCannotFormClosedLoop As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SculptingCurvesCannotFormClosedLoop {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


SculptingCurvesCrossAxis Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..SculptingCurvesCrossAxis Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
The highlighted curves cross the axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SculptingCurvesCrossAxis { get; }
Visual Basic
Public Shared ReadOnly Property SculptingCurvesCrossAxis As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SculptingCurvesCrossAxis {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


SculptingCurvesTouchAxis Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..SculptingCurvesTouchAxis Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
The highlighted curves touch the axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SculptingCurvesTouchAxis { get; }
Visual Basic
Public Shared ReadOnly Property SculptingCurvesTouchAxis As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SculptingCurvesTouchAxis {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


SculptingLoopsOnBothSidesOfAxis Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..SculptingLoopsOnBothSidesOfAxis Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
All curves must be on the same side of the axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SculptingLoopsOnBothSidesOfAxis { get; }
Visual Basic
Public Shared ReadOnly Property SculptingLoopsOnBothSidesOfAxis As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SculptingLoopsOnBothSidesOfAxis {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


ShortCurveInSketch Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..ShortCurveInSketch Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
The sketch contains an extremely short line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ShortCurveInSketch { get; }
Visual Basic
Public Shared ReadOnly Property ShortCurveInSketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ShortCurveInSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


ShortCurveInSketchRoof Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..ShortCurveInSketchRoof Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
The sketch contains an extremely short line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ShortCurveInSketchRoof { get; }
Visual Basic
Public Shared ReadOnly Property ShortCurveInSketchRoof As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ShortCurveInSketchRoof {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


SiteCannotDrawSurfaceBoundary Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..SiteCannotDrawSurfaceBoundary Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Cannot make surface with specified boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SiteCannotDrawSurfaceBoundary { get; }
Visual Basic
Public Shared ReadOnly Property SiteCannotDrawSurfaceBoundary As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SiteCannotDrawSurfaceBoundary {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


SketchedRunInvalidPath Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..SketchedRunInvalidPath Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Invalid stair path. Stair path should connect both start and end riser, and cross all other risers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SketchedRunInvalidPath { get; }
Visual Basic
Public Shared ReadOnly Property SketchedRunInvalidPath As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SketchedRunInvalidPath {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


SketchFailurePlanes Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..SketchFailurePlanes Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Sketch is no longer parallel to its defining plane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SketchFailurePlanes { get; }
Visual Basic
Public Shared ReadOnly Property SketchFailurePlanes As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SketchFailurePlanes {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


SketchingInTheWrongView Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..SketchingInTheWrongView Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Detail sketch is only editable in [View Type].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SketchingInTheWrongView { get; }
Visual Basic
Public Shared ReadOnly Property SketchingInTheWrongView As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SketchingInTheWrongView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


SketchOverconstrained Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..SketchOverconstrained Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Sketch is overconstrained.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SketchOverconstrained { get; }
Visual Basic
Public Shared ReadOnly Property SketchOverconstrained As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SketchOverconstrained {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


SketchOverconstrainedWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..SketchOverconstrainedWarn Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Sketch is overconstrained.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SketchOverconstrainedWarn { get; }
Visual Basic
Public Shared ReadOnly Property SketchOverconstrainedWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SketchOverconstrainedWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


SketchTooLarge Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..SketchTooLarge Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Sketch is too large.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SketchTooLarge { get; }
Visual Basic
Public Shared ReadOnly Property SketchTooLarge As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SketchTooLarge {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


SketchWasDeleted Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..SketchWasDeleted Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Sketch was deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SketchWasDeleted { get; }
Visual Basic
Public Shared ReadOnly Property SketchWasDeleted As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SketchWasDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


StairClosedBoundaries Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..StairClosedBoundaries Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Stairs Boundaries (chains of one or more Boundary Lines) should not form closed loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StairClosedBoundaries { get; }
Visual Basic
Public Shared ReadOnly Property StairClosedBoundaries As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairClosedBoundaries {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


StairClosedBoundariesError Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..StairClosedBoundariesError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Stairs Boundaries (chains of one or more Boundary Lines) should not form closed loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StairClosedBoundariesError { get; }
Visual Basic
Public Shared ReadOnly Property StairClosedBoundariesError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairClosedBoundariesError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


StairNotEnoughBoundaryCurves Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..StairNotEnoughBoundaryCurves Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Stairs require boundaries (chains of one or more Boundary Lines) on each side of the Stair.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StairNotEnoughBoundaryCurves { get; }
Visual Basic
Public Shared ReadOnly Property StairNotEnoughBoundaryCurves As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairNotEnoughBoundaryCurves {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


StairNotEnoughBoundaryCurvesError Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..StairNotEnoughBoundaryCurvesError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Stairs require boundaries (chains of one or more Boundary Lines) on each side of the Stair.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StairNotEnoughBoundaryCurvesError { get; }
Visual Basic
Public Shared ReadOnly Property StairNotEnoughBoundaryCurvesError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairNotEnoughBoundaryCurvesError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


StairNotEnoughRiserCurves Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..StairNotEnoughRiserCurves Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Boundaries (chains of one or more Boundary Lines) must be connected by at least two Riser Lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StairNotEnoughRiserCurves { get; }
Visual Basic
Public Shared ReadOnly Property StairNotEnoughRiserCurves As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairNotEnoughRiserCurves {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


StairNotEnoughRiserCurvesError Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..StairNotEnoughRiserCurvesError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Boundaries (chains of one or more Boundary Lines) must be connected by at least two Riser Lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StairNotEnoughRiserCurvesError { get; }
Visual Basic
Public Shared ReadOnly Property StairNotEnoughRiserCurvesError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairNotEnoughRiserCurvesError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


StairOnlyOneConnectedBoundaryError Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..StairOnlyOneConnectedBoundaryError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Stairs require no less than two boundaries (chains of one or more Boundary Lines).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StairOnlyOneConnectedBoundaryError { get; }
Visual Basic
Public Shared ReadOnly Property StairOnlyOneConnectedBoundaryError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairOnlyOneConnectedBoundaryError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


StairRiserDoesntIntersectBoundary Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..StairRiserDoesntIntersectBoundary Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
The line representing the top of a riser does not intersect one or both of the boundary lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StairRiserDoesntIntersectBoundary { get; }
Visual Basic
Public Shared ReadOnly Property StairRiserDoesntIntersectBoundary As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairRiserDoesntIntersectBoundary {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


StairRiserDoesntIntersectBoundaryError Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..StairRiserDoesntIntersectBoundaryError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
The line representing the top of a riser does not intersect one or both of the boundary lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StairRiserDoesntIntersectBoundaryError { get; }
Visual Basic
Public Shared ReadOnly Property StairRiserDoesntIntersectBoundaryError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairRiserDoesntIntersectBoundaryError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


StairTooManyConnectedBoundaries Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..StairTooManyConnectedBoundaries Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Stairs require no more than two boundaries (chains of one or more Boundary Lines).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StairTooManyConnectedBoundaries { get; }
Visual Basic
Public Shared ReadOnly Property StairTooManyConnectedBoundaries As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairTooManyConnectedBoundaries {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


StairTooManyConnectedBoundariesError Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..StairTooManyConnectedBoundariesError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Stairs require no more than two boundaries (chains of one or more Boundary Lines).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StairTooManyConnectedBoundariesError { get; }
Visual Basic
Public Shared ReadOnly Property StairTooManyConnectedBoundariesError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairTooManyConnectedBoundariesError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


SubregionNoHostSurf Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..SubregionNoHostSurf Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
A Subregion cannot be created outside the boundary of a Toposurface. A Subregion should be completely inside a Toposurface or overlap a Toposurface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SubregionNoHostSurf { get; }
Visual Basic
Public Shared ReadOnly Property SubregionNoHostSurf As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SubregionNoHostSurf {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


SuggestMakingFamilyNonParametric Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..SuggestMakingFamilyNonParametric Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Performance Warning: This family now contains both labeled dimensions and sketches with many segments. This may hurt performance. To improve performance, create elements that require complex sketches as nested families.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SuggestMakingFamilyNonParametric { get; }
Visual Basic
Public Shared ReadOnly Property SuggestMakingFamilyNonParametric As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SuggestMakingFamilyNonParametric {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


SuspendedSketchWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..SuspendedSketchWarn Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Highlighted element's sketch could not regenerate and has been suspended. Select the element and edit its sketch to fix the problem. The element will display in magenta until you fix the problem

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SuspendedSketchWarn { get; }
Visual Basic
Public Shared ReadOnly Property SuspendedSketchWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SuspendedSketchWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


TooFewParamsForSketch Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..TooFewParamsForSketch Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
The sketched Structural Rebar element has too many segments to be properly parameterized. Please reduce the number of segments.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId TooFewParamsForSketch { get; }
Visual Basic
Public Shared ReadOnly Property TooFewParamsForSketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TooFewParamsForSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


TooManyElementsInSketch Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..TooManyElementsInSketch Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
This sketch is large. Performance will improve if constructed as several independent sketches.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId TooManyElementsInSketch { get; }
Visual Basic
Public Shared ReadOnly Property TooManyElementsInSketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TooManyElementsInSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


TooManySlopes Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..TooManySlopes Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
There is more than one slope defined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId TooManySlopes { get; }
Visual Basic
Public Shared ReadOnly Property TooManySlopes As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TooManySlopes {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


TooManySlopesError Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..TooManySlopesError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
There is more than one slope defined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId TooManySlopesError { get; }
Visual Basic
Public Shared ReadOnly Property TooManySlopesError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TooManySlopesError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


TrussClosedReference Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..TrussClosedReference Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Truss references (chains of one or more reference lines) should not form closed loops."

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId TrussClosedReference { get; }
Visual Basic
Public Shared ReadOnly Property TrussClosedReference As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TrussClosedReference {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


TrussCrossingReferences Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..TrussCrossingReferences Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Truss top and bottom references cannot cross.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId TrussCrossingReferences { get; }
Visual Basic
Public Shared ReadOnly Property TrussCrossingReferences As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TrussCrossingReferences {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


TrussMissingReference Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..TrussMissingReference Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Trusses require both a top and a bottom chord reference (chain of one or more reference lines).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId TrussMissingReference { get; }
Visual Basic
Public Shared ReadOnly Property TrussMissingReference As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TrussMissingReference {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


TrussOverlappingReference Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..TrussOverlappingReference Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Truss references (chains of one or more reference lines) cannot overlap themselves in the vertical direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId TrussOverlappingReference { get; }
Visual Basic
Public Shared ReadOnly Property TrussOverlappingReference As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TrussOverlappingReference {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


TrussSegmentedReference Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..TrussSegmentedReference Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Truss reference must form a continuous chain of one or more sketch lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId TrussSegmentedReference { get; }
Visual Basic
Public Shared ReadOnly Property TrussSegmentedReference As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TrussSegmentedReference {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


TrussShiftedReferences Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..TrussShiftedReferences Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Truss top and bottom references (chains of one or more reference lines) must overlap at least partially in the vertical direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId TrussShiftedReferences { get; }
Visual Basic
Public Shared ReadOnly Property TrussShiftedReferences As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TrussShiftedReferences {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


TrussSwappedReferences Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..TrussSwappedReferences Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Truss top reference must be above the bottom reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId TrussSwappedReferences { get; }
Visual Basic
Public Shared ReadOnly Property TrussSwappedReferences As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TrussSwappedReferences {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


UnsatisfiedSupportAssocProp Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..UnsatisfiedSupportAssocProp Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Constraint between a Line created with Pick Support and the Support is not satisfied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UnsatisfiedSupportAssocProp { get; }
Visual Basic
Public Shared ReadOnly Property UnsatisfiedSupportAssocProp As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnsatisfiedSupportAssocProp {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


UnsatisfiedWallAssocProp Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..UnsatisfiedWallAssocProp Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Constraint between a Line created with Pick Wall and the Wall is not satisfied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UnsatisfiedWallAssocProp { get; }
Visual Basic
Public Shared ReadOnly Property UnsatisfiedWallAssocProp As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnsatisfiedWallAssocProp {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


VarSketchFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..VarSketchFailure Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Constraints defined by highlighted Lines and Dimensions can't be satisfied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId VarSketchFailure { get; }
Visual Basic
Public Shared ReadOnly Property VarSketchFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ VarSketchFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


VarSketchInElementFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..VarSketchInElementFailure Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
The constraints of the sketch defining the highlighted element cannot be satisfied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId VarSketchInElementFailure { get; }
Visual Basic
Public Shared ReadOnly Property VarSketchInElementFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ VarSketchInElementFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


WrongFaceSplitterLoopTypesNum Property

[image]

Revit 2024 API
BuiltInFailures..::..SketchFailures..::..WrongFaceSplitterLoopTypesNum Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Sketch for splitting the face is invalid. Faces may be split either by a single closed loop that is contained within the face or by one or more open loops whose ends lie on the boundary of the face. None of the lines in the sketch are allowed to overlap or intersect the boundaries of the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WrongFaceSplitterLoopTypesNum { get; }
Visual Basic
Public Shared ReadOnly Property WrongFaceSplitterLoopTypesNum As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WrongFaceSplitterLoopTypesNum {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


BuiltInFailures.SkylightFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..SkylightFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Skylight.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class SkylightFailures
Visual Basic
Public NotInheritable Class SkylightFailures
Visual C++
public ref class SkylightFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..SkylightFailures

See Also

BuiltInFailures..::..SkylightFailures Members


BuiltInFailures.SkylightFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..SkylightFailures Members
BuiltInFailures..::..SkylightFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..SkylightFailures type exposes the following members.

Properties

Name | Description
MinSkylightWidthImperial | The minimum skylight width is 8 inches.
MinSkylightWidthMetric | The minimum skylight width is 203.2 millimeters.

See Also

BuiltInFailures..::..SkylightFailures Class


BuiltInFailures.SkylightFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..SkylightFailures Properties
BuiltInFailures..::..SkylightFailures Class See Also Send Feedback

The BuiltInFailures..::..SkylightFailures type exposes the following members.

Properties

Name | Description
MinSkylightWidthImperial | The minimum skylight width is 8 inches.
MinSkylightWidthMetric | The minimum skylight width is 203.2 millimeters.

See Also

BuiltInFailures..::..SkylightFailures Class


MinSkylightWidthMetric Property

[image]

Revit 2024 API
BuiltInFailures..::..SkylightFailures..::..MinSkylightWidthMetric Property
BuiltInFailures..::..SkylightFailures Class See Also Send Feedback
The minimum skylight width is 203.2 millimeters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MinSkylightWidthMetric { get; }
Visual Basic
Public Shared ReadOnly Property MinSkylightWidthMetric As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MinSkylightWidthMetric {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SkylightFailures Class


BuiltInFailures.SlabFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..SlabFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Slab.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class SlabFailures
Visual Basic
Public NotInheritable Class SlabFailures
Visual C++
public ref class SlabFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..SlabFailures

See Also

BuiltInFailures..::..SlabFailures Members


BuiltInFailures.SlabFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..SlabFailures Members
BuiltInFailures..::..SlabFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..SlabFailures type exposes the following members.

Properties

Name | Description
CantileverValueTooBig | Cantilever value is too big.

See Also

BuiltInFailures..::..SlabFailures Class


BuiltInFailures.SlabFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..SlabFailures Properties
BuiltInFailures..::..SlabFailures Class See Also Send Feedback

The BuiltInFailures..::..SlabFailures type exposes the following members.

Properties

Name | Description
CantileverValueTooBig | Cantilever value is too big.

See Also

BuiltInFailures..::..SlabFailures Class


BuiltInFailures.SlabShapeFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..SlabShapeFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about SlabShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class SlabShapeFailures
Visual Basic
Public NotInheritable Class SlabShapeFailures
Visual C++
public ref class SlabShapeFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..SlabShapeFailures

See Also

BuiltInFailures..::..SlabShapeFailures Members


BuiltInFailures.SlabShapeFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..SlabShapeFailures Members
BuiltInFailures..::..SlabShapeFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..SlabShapeFailures type exposes the following members.

Properties

Name | Description
SlabShapeEditFailed | Slab Shape Edit failed. [Description]
SlabShapeEditFailedError | Slab Shape Edit failed. [Description]
SlabShapeFailedNotHorz | The Floor or Roof or Toposolid is no longer horizontal.
SlabShapeFailedNotOnlyLines | The Floor or Roof or Toposolid may only contain straight lines.
SlabShapeFailedTooThin | The Floor or Roof or Toposolid is too thin for its given type.
SlabShapeWarnVerticesCoincident | Some slab shape edit vertices were too close to each other or too close to an edge.
SlabShapeWarnVerticesDeleted | Some slab shape edit vertices were deleted because the Floor or Roof or Toposolid has changed its shape.
SlopedInnerEdge | Inner loops of a footprint sketch may not have slope-defining lines.
SlopeTailInsideSlopeLine | The tails of slope arrows must not lie in interior of slope defining lines.
SlopeZero | Adjusting this Line's Overhang will not affect its height because its slope is zero.

See Also

BuiltInFailures..::..SlabShapeFailures Class


BuiltInFailures.SlabShapeFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..SlabShapeFailures Properties
BuiltInFailures..::..SlabShapeFailures Class See Also Send Feedback

The BuiltInFailures..::..SlabShapeFailures type exposes the following members.

Properties

Name | Description
SlabShapeEditFailed | Slab Shape Edit failed. [Description]
SlabShapeEditFailedError | Slab Shape Edit failed. [Description]
SlabShapeFailedNotHorz | The Floor or Roof or Toposolid is no longer horizontal.
SlabShapeFailedNotOnlyLines | The Floor or Roof or Toposolid may only contain straight lines.
SlabShapeFailedTooThin | The Floor or Roof or Toposolid is too thin for its given type.
SlabShapeWarnVerticesCoincident | Some slab shape edit vertices were too close to each other or too close to an edge.
SlabShapeWarnVerticesDeleted | Some slab shape edit vertices were deleted because the Floor or Roof or Toposolid has changed its shape.
SlopedInnerEdge | Inner loops of a footprint sketch may not have slope-defining lines.
SlopeTailInsideSlopeLine | The tails of slope arrows must not lie in interior of slope defining lines.
SlopeZero | Adjusting this Line's Overhang will not affect its height because its slope is zero.

See Also

BuiltInFailures..::..SlabShapeFailures Class


SlabShapeEditFailed Property

[image]

Revit 2024 API
BuiltInFailures..::..SlabShapeFailures..::..SlabShapeEditFailed Property
BuiltInFailures..::..SlabShapeFailures Class See Also Send Feedback
Slab Shape Edit failed. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SlabShapeEditFailed { get; }
Visual Basic
Public Shared ReadOnly Property SlabShapeEditFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SlabShapeEditFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SlabShapeFailures Class


SlabShapeEditFailedError Property

[image]

Revit 2024 API
BuiltInFailures..::..SlabShapeFailures..::..SlabShapeEditFailedError Property
BuiltInFailures..::..SlabShapeFailures Class See Also Send Feedback
Slab Shape Edit failed. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SlabShapeEditFailedError { get; }
Visual Basic
Public Shared ReadOnly Property SlabShapeEditFailedError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SlabShapeEditFailedError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SlabShapeFailures Class


SlabShapeFailedNotHorz Property

[image]

Revit 2024 API
BuiltInFailures..::..SlabShapeFailures..::..SlabShapeFailedNotHorz Property
BuiltInFailures..::..SlabShapeFailures Class See Also Send Feedback
The Floor or Roof or Toposolid is no longer horizontal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SlabShapeFailedNotHorz { get; }
Visual Basic
Public Shared ReadOnly Property SlabShapeFailedNotHorz As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SlabShapeFailedNotHorz {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SlabShapeFailures Class


SlabShapeFailedNotOnlyLines Property

[image]

Revit 2024 API
BuiltInFailures..::..SlabShapeFailures..::..SlabShapeFailedNotOnlyLines Property
BuiltInFailures..::..SlabShapeFailures Class See Also Send Feedback
The Floor or Roof or Toposolid may only contain straight lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SlabShapeFailedNotOnlyLines { get; }
Visual Basic
Public Shared ReadOnly Property SlabShapeFailedNotOnlyLines As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SlabShapeFailedNotOnlyLines {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SlabShapeFailures Class


SlabShapeFailedTooThin Property

[image]

Revit 2024 API
BuiltInFailures..::..SlabShapeFailures..::..SlabShapeFailedTooThin Property
BuiltInFailures..::..SlabShapeFailures Class See Also Send Feedback
The Floor or Roof or Toposolid is too thin for its given type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SlabShapeFailedTooThin { get; }
Visual Basic
Public Shared ReadOnly Property SlabShapeFailedTooThin As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SlabShapeFailedTooThin {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SlabShapeFailures Class


SlabShapeWarnVerticesCoincident Property

[image]

Revit 2024 API
BuiltInFailures..::..SlabShapeFailures..::..SlabShapeWarnVerticesCoincident Property
BuiltInFailures..::..SlabShapeFailures Class See Also Send Feedback
Some slab shape edit vertices were too close to each other or too close to an edge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SlabShapeWarnVerticesCoincident { get; }
Visual Basic
Public Shared ReadOnly Property SlabShapeWarnVerticesCoincident As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SlabShapeWarnVerticesCoincident {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SlabShapeFailures Class


SlopedInnerEdge Property

[image]

Revit 2024 API
BuiltInFailures..::..SlabShapeFailures..::..SlopedInnerEdge Property
BuiltInFailures..::..SlabShapeFailures Class See Also Send Feedback
Inner loops of a footprint sketch may not have slope-defining lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SlopedInnerEdge { get; }
Visual Basic
Public Shared ReadOnly Property SlopedInnerEdge As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SlopedInnerEdge {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SlabShapeFailures Class


SlopeTailInsideSlopeLine Property

[image]

Revit 2024 API
BuiltInFailures..::..SlabShapeFailures..::..SlopeTailInsideSlopeLine Property
BuiltInFailures..::..SlabShapeFailures Class See Also Send Feedback
The tails of slope arrows must not lie in interior of slope defining lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SlopeTailInsideSlopeLine { get; }
Visual Basic
Public Shared ReadOnly Property SlopeTailInsideSlopeLine As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SlopeTailInsideSlopeLine {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SlabShapeFailures Class


SlopeZero Property

[image]

Revit 2024 API
BuiltInFailures..::..SlabShapeFailures..::..SlopeZero Property
BuiltInFailures..::..SlabShapeFailures Class See Also Send Feedback
Adjusting this Line's Overhang will not affect its height because its slope is zero.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SlopeZero { get; }
Visual Basic
Public Shared ReadOnly Property SlopeZero As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SlopeZero {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SlabShapeFailures Class


BuiltInFailures.SlantedColumnFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..SlantedColumnFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about SlantedColumn.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class SlantedColumnFailures
Visual Basic
Public NotInheritable Class SlantedColumnFailures
Visual C++
public ref class SlantedColumnFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..SlantedColumnFailures

See Also

BuiltInFailures..::..SlantedColumnFailures Members


BuiltInFailures.SlantedColumnFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..SlantedColumnFailures Members
BuiltInFailures..::..SlantedColumnFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..SlantedColumnFailures type exposes the following members.

Properties

Name | Description
CannotCutParallelToLocationCurve | Cut plane of slanted column end is parallel to the location curve.
SlantedColumnCannotCutEnd | Unable to trim slanted column end geometry to desired condition.
SlantedColumnCannotCutEndWarn | Unable to trim slanted column end geometry to desired condition.

See Also

BuiltInFailures..::..SlantedColumnFailures Class


BuiltInFailures.SlantedColumnFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..SlantedColumnFailures Properties
BuiltInFailures..::..SlantedColumnFailures Class See Also Send Feedback

The BuiltInFailures..::..SlantedColumnFailures type exposes the following members.

Properties

Name | Description
CannotCutParallelToLocationCurve | Cut plane of slanted column end is parallel to the location curve.
SlantedColumnCannotCutEnd | Unable to trim slanted column end geometry to desired condition.
SlantedColumnCannotCutEndWarn | Unable to trim slanted column end geometry to desired condition.

See Also

BuiltInFailures..::..SlantedColumnFailures Class


CannotCutParallelToLocationCurve Property

[image]

Revit 2024 API
BuiltInFailures..::..SlantedColumnFailures..::..CannotCutParallelToLocationCurve Property
BuiltInFailures..::..SlantedColumnFailures Class See Also Send Feedback
Cut plane of slanted column end is parallel to the location curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCutParallelToLocationCurve { get; }
Visual Basic
Public Shared ReadOnly Property CannotCutParallelToLocationCurve As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCutParallelToLocationCurve {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SlantedColumnFailures Class


SlantedColumnCannotCutEnd Property

[image]

Revit 2024 API
BuiltInFailures..::..SlantedColumnFailures..::..SlantedColumnCannotCutEnd Property
BuiltInFailures..::..SlantedColumnFailures Class See Also Send Feedback
Unable to trim slanted column end geometry to desired condition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SlantedColumnCannotCutEnd { get; }
Visual Basic
Public Shared ReadOnly Property SlantedColumnCannotCutEnd As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SlantedColumnCannotCutEnd {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SlantedColumnFailures Class


SlantedColumnCannotCutEndWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..SlantedColumnFailures..::..SlantedColumnCannotCutEndWarn Property
BuiltInFailures..::..SlantedColumnFailures Class See Also Send Feedback
Unable to trim slanted column end geometry to desired condition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SlantedColumnCannotCutEndWarn { get; }
Visual Basic
Public Shared ReadOnly Property SlantedColumnCannotCutEndWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SlantedColumnCannotCutEndWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SlantedColumnFailures Class


BuiltInFailures.SpanDirectionSymbolFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..SpanDirectionSymbolFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about SpanDirectionSymbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class SpanDirectionSymbolFailures
Visual Basic
Public NotInheritable Class SpanDirectionSymbolFailures
Visual C++
public ref class SpanDirectionSymbolFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..SpanDirectionSymbolFailures

See Also

BuiltInFailures..::..SpanDirectionSymbolFailures Members


BuiltInFailures.SpanDirectionSymbolFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..SpanDirectionSymbolFailures Members
BuiltInFailures..::..SpanDirectionSymbolFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..SpanDirectionSymbolFailures type exposes the following members.

Properties

Name | Description
NonPlanView | Span Direction Symbol can only be placed in a Floor Plan View.

See Also

BuiltInFailures..::..SpanDirectionSymbolFailures Class


BuiltInFailures.SplineFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..SplineFailures Members
BuiltInFailures..::..SplineFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..SplineFailures type exposes the following members.

Properties

Name | Description
CannotCreateSpline | Can't make Spline.
ClosedSpline | Closed or self-intersecting splines are not allowed.

See Also

BuiltInFailures..::..SplineFailures Class


BuiltInFailures.SplineFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..SplineFailures Properties
BuiltInFailures..::..SplineFailures Class See Also Send Feedback

The BuiltInFailures..::..SplineFailures type exposes the following members.

Properties

Name | Description
CannotCreateSpline | Can't make Spline.
ClosedSpline | Closed or self-intersecting splines are not allowed.

See Also

BuiltInFailures..::..SplineFailures Class


ClosedSpline Property

[image]

Revit 2024 API
BuiltInFailures..::..SplineFailures..::..ClosedSpline Property
BuiltInFailures..::..SplineFailures Class See Also Send Feedback
Closed or self-intersecting splines are not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ClosedSpline { get; }
Visual Basic
Public Shared ReadOnly Property ClosedSpline As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ClosedSpline {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SplineFailures Class


BuiltInFailures.SplitSketchBasedElementFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..SplitSketchBasedElementFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures related to the split sketched based element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class SplitSketchBasedElementFailures
Visual Basic
Public NotInheritable Class SplitSketchBasedElementFailures
Visual C++
public ref class SplitSketchBasedElementFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..SplitSketchBasedElementFailures

See Also

BuiltInFailures..::..SplitSketchBasedElementFailures Members


BuiltInFailures.SplitSketchBasedElementFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..SplitSketchBasedElementFailures Members
BuiltInFailures..::..SplitSketchBasedElementFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..SplitSketchBasedElementFailures type exposes the following members.

Properties

Name | Description
NotSplitValidRegions | The split failed. There may be a gap in the boundary loop or the sketch may be incomplete.

See Also

BuiltInFailures..::..SplitSketchBasedElementFailures Class


NotSplitValidRegions Property

[image]

Revit 2024 API
BuiltInFailures..::..SplitSketchBasedElementFailures..::..NotSplitValidRegions Property
BuiltInFailures..::..SplitSketchBasedElementFailures Class See Also Send Feedback
The split failed. There may be a gap in the boundary loop or the sketch may be incomplete.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NotSplitValidRegions { get; }
Visual Basic
Public Shared ReadOnly Property NotSplitValidRegions As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotSplitValidRegions {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SplitSketchBasedElementFailures Class


BuiltInFailures.SplitToposolidFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..SplitToposolidFailures Properties
BuiltInFailures..::..SplitToposolidFailures Class See Also Send Feedback

The BuiltInFailures..::..SplitToposolidFailures type exposes the following members.

Properties

Name | Description
GenerateNewSplitTopoFailed | Failed to generate new toposolid after split.
SplitToposolidFailed | Split toposolid failed.

See Also

BuiltInFailures..::..SplitToposolidFailures Class


GenerateNewSplitTopoFailed Property

[image]

Revit 2024 API
BuiltInFailures..::..SplitToposolidFailures..::..GenerateNewSplitTopoFailed Property
BuiltInFailures..::..SplitToposolidFailures Class See Also Send Feedback
Failed to generate new toposolid after split.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId GenerateNewSplitTopoFailed { get; }
Visual Basic
Public Shared ReadOnly Property GenerateNewSplitTopoFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GenerateNewSplitTopoFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SplitToposolidFailures Class


SplitToposolidFailed Property

[image]

Revit 2024 API
BuiltInFailures..::..SplitToposolidFailures..::..SplitToposolidFailed Property
BuiltInFailures..::..SplitToposolidFailures Class See Also Send Feedback
Split toposolid failed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SplitToposolidFailed { get; }
Visual Basic
Public Shared ReadOnly Property SplitToposolidFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SplitToposolidFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SplitToposolidFailures Class


BuiltInFailures.StairRampFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about StairRamp.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class StairRampFailures
Visual Basic
Public NotInheritable Class StairRampFailures
Visual C++
public ref class StairRampFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..StairRampFailures

See Also

BuiltInFailures..::..StairRampFailures Members


BuiltInFailures.StairRampFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures Members
BuiltInFailures..::..StairRampFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..StairRampFailures type exposes the following members.

Properties

Name | Description
ActualRiserHeightChanged | The actual riser height for one or more stairs violates the maximum set in the type.
AntiparallelRampRisers | Riser lines are parallel but not collinear. Can't build Run between these Risers.
AntiparallelRampRisersError | Riser lines are parallel but not collinear. Can't build Run between these Risers.
ArcRunRadiusTooSmall | Can't create Run. Run radius is too small.
ArcRunWidthTooLongFailure | Arc run width is too long.
AutomaticLandingConvertedToSketchedLandingWarning | Some run(s) are deleted, so automatic landing is converted to sketched landing.
BadBalustersPerTread | Number of Balusters per Tread must be an integer greater than zero.
BadFillingSpacing | Spacing for Excess Length Fill is too small.
BadRailings | Can't create Railings.
BadRailingsError | Can't create Railings.
BadRailProfile | One or more Profile Loops are invalid, probably because of self-intersection.
BadTreadRiserProfile | Tread/Riser profile is invalid.
BalustersTooClose | Baluster Separation must be equal to or greater than the Baluster widths.
BalustersTooCloseAbsolute | Baluster Separation is too small.
BalusterUpsideDown | Top reference is below Bottom reference for one or more Balusters. These Balusters are not created.
CannotAlignSupportOnPosts | Cannot align the support on the posts.
CannotComputeRailElevation | Can't compute elevation profile for one or more Rails
CannotCreateBaluster | Can't create Balusters for given Width and Height.
CannotCreateBalusterPatterns | Can't create Baluster Patterns for Railings
CannotCreateCornerBalusters | Can't create corner Baluster
CannotCreateLandingStringer | Can't create stringer at landing.
CannotCreateMiddleStringer | Can't create one or more Middle Stringers.
CannotCreateMonolithicStairs | Can't make monolithic Stairs.
CannotCreateNosing | Can't create nosing on one or more treads.
CannotCreateOneOrMoreBaluster | Can't create one or more Balusters
CannotCreateOneOrMoreTreads | Can't create geometry for one or more treads.
CannotCreateOpenMiddleStringers | Can't cut open/middle stringers geometry.
CannotCreateRail | Can't create Railing. Thickness of Rail or Balusters might be too small. If you don't want Balusters, specify "None" for Baluster Shape.
CannotCreateRailGeom | Can't create geometry for one or more Rails
CannotCreateRailWarn | Can't create Railing. Thickness of Rail or Balusters might be too small. If you don't want Balusters, specify "None" for Baluster Shape.
CannotCreateRiser | Can't create geometry for one or more risers.
CannotCreateSideStringer | Can't create one or more Side Stringers.
CannotCreateStairForLevelOverlapping | Some of the multistory stairs couldn't be created due to the overlapped levels.
CannotCreateStringers | Can't create stringers geometry.
CannotDrawStairs | Can't make stairs
CannotDrawStairsError | Can't make stairs
CannotEndWithZeroRiser | Can't end Stairs with Riser because Riser Thickness is too small.
CannotGenerateFaces | Couldn't generate surfaces for stairs.
CannotGenerateFacesError | Couldn't generate surfaces for stairs.
CannotGenerateRamp | Couldn't generate surfaces for ramp.
CannotGenerateRampError | Couldn't generate surfaces for ramp.
CannotMakeLanding | Can't make landing.
CannotOffsetBoundary | Can't create Boundary as an offset of Run Curve
CannotOffsetRail | Can't create one or more Rails with desired offset
CannotPlaceBalusterOffset | Can't place Balusters and/or Rails with desired offset
CannotPlaceBalusterPatterns | Can't place Baluster Patterns
CannotPlaceRailingOnStringerWarning | Railing is placed on tread because there is no stringer.
CannotProcessInStairsSketchEditMode | Cannot process when stair(s) in sketch edit mode.
CannotSplitRailingWithExtensions | Railings with extensions cannot be split.
ContinuousRailFilletCreationError | Cannot create specified fillet at rail path corner.
ContinuousRailFilletCreationParallel | Cannot create specified fillet at rail path corner because of the curves are already smoothed.
ContinuousRailFilletCreationWarning | Cannot create specified fillet at rail path corner.
ContinuousRailGometryCreationFailure | Cannot create the continuous rail geometry.
ContinuousRailNotContinuous | The rail is non-continuous.
ContinuousRailSupportPlacementFailure | Cannot place the supports along the rail path.
ContinuousRailTransitionFailure | Cannot create specified transition at rail path turn, hand Rail/Top Rail cannot maintain continuous.
ExtendBelowBaseGreaterThanLandingBaseElevation | Extend Below Base needs to be less than Landing Base Elevation.
ExtendBelowBaseGreaterThanRunTopElevation | Extend Below Base needs to be less than Run Top Elevation.
FailToReOrientSketchCurvesFailure | Failed to orient sketch curves.
HeightOfRunIsTooSmall | Height of run is too small.
IntermediateLandingHigherThanTopRunFailure | Run is reversed.
InvalidBalustersPattern | Invalid Balusters Pattern
InvalidLocationLineJustificationFailure | Modify the location justification to a invalid value.
InvalidParameters | Stairs run or landing has invalid parameter(s).
InvalidRailProfile | Profiles for one or more of the Rails are invalid. Make sure that every used Profile is a closed series of non-intersecting Lines.
InvalidStairsPathFailure | Invalid stairs path provided.
InvalidStartLevel | The start level and end level for this staircase must be at different elevations.
InvalidStartLevelRamp | The start level and end level for this ramp must be at different elevations.
LandingDepthIsLessThanRunWidthWarning | Landing depth is less than run width.
LandingHeightUnderStairsBottom | Cannot make landing because height of landing is equal or less than to bottom height of the stair.
LandingShapeHandleOnPinnedRunFailure | Cannot Drag the automatic landing shape handle control because the connected run is pinned.
MayUnjoinRailAndSupports | Fillet may cause the supports unjoin with the rail.
MultistoryLevelBelowTopbottomLevel | Multistory top level must be above the stair/ramp top and bottom levels.
MultistoryLevelBelowTopbottomLevelError | Multistory top level must be above the stair/ramp top and bottom levels.
MultistoryStairDoesntReach | The multistory stair/ramp could not reach its top level with integral number of flights. Maximum number of flights below the top level is created.
MultistoryStairsAutomaticLevelLandingsDeleted | Level landings are deleted because the connected stairs have been regenerated.
MultistoryStairsComponentJoinFailure | Can't keep elements joined. Avoid converting stairs to skeched-based component in Multistory stairs.
MultistoryStairsHideTopLevelParameter | You have set the stair's multistory top level to None, and Revit will remove this parameter, if you want to create a multistory stair, please use Create Multistory Stair feature.
MultistoryStandardStairBottomEndExceedsOrNotReach | One of the stairs inside multistory stairs bottom ends exceeds or cannot reach the base elevation of the stair.
MultistoryStandardStairTopEndExceedsOrNotReach | One of the stairs inside multistory stairs top ends exceed or cannot reach the top elevation of the stair.
MultusegmentRampRiser | Ramp can't have multisegment Riser.
MultusegmentRampRiserError | Ramp can't have multisegment Riser.
NoCurvesInRailing | Railing Sketch has no Lines.
NoProfileForRail | Must specify Profiles for every Rail.
NoRailingsStringer | Railings and Stringers will not be automatically generated due to bad Runs. This message may be incorrect if you have Edited the Sketch and modified some dimensions.
NoRisersInPureMonolithicStairs | Monolithic Stairs with zero tread thickness can't have risers
NoRunsRamp | Ramp has no Runs. Can't create Ramp.
NoRunsRampError | Ramp has no Runs. Can't create Ramp.
NotALineRiserRamp | Riser line must be a straight line for Ramps.
NotALineRiserRampError | Riser line must be a straight line for Ramps.
NotchThicknessIsLargerThanLandingWarning | The notch thickness is larger than landing.
NotEnoughRisers | Actual Number of Risers is different from Desired Number of Risers. Add/remove Risers or change Desired Number of Risers in Stairs Properties.
OnlyMonolithicStairs | Tread thickness can't be zero for non-monolithic stairs
PartOfRiserLiesOnBoundaryFailure | Part of the riser lies on the boundary is not allowed.
PathDoesntJoinToBorderRisersFailure | Path doesn't join to border risers is not allowed.
RailCurveTooShort | Curve in rail sketch is too short for rail creation and ignored.
RailingBadOffset | An arc in the railing sketch has a radius that conflicts with the current rail widths and offsets. Please either increase the radius or modify rail profiles and offsets.
RailingCurvesNotSplitRamp | The slope of this railing will not parallel the ramp at landings. To get a parallel railing, split the railing sketch at the ends of landings.
RailingCurvesNotSplitStairs | The slope of this railing may not parallel the stairs at runs and landings. To get a parallel railing, split the railing sketch at the ends of landings.
RailingDoublyConnected | Railings hosted on Stairs must form a single, open, connected line.
RailingNotConnected | The Railing line must be a single connected Sketch. If you want separate pieces of Railing, create two or more separate Railings.
RailPathCloseLoopForExtensionWarning | The rail path is closed at the start and end path point for extension creation.
RailPlacedOutsideOfHost | Railings are placed completely outside the host. It may change the adjustment of the railing to the host and its vertical position.
RailProfileLowerThanFilletError | Fillet cannot be created between rail segment since the radius is lower than the profile size.
RailProfileLowerThanFilletFailure | Fillet cannot be created between rail segment since the radius is lower than the profile size.
RailProfileOpen | Open Profile Loop can't be used as a Rail Profile
RailTypeChangeInconsistancyWarningWithResetBtn | Some rail type changes are not consistent with your rail instances customization in this project, you can reset them to make them corresponding with your changes.
RampDoesntReach | The ramp is not long enough to reach the top constraint. Change the slope or increase the length of the ramp.
RampDoesntReachOffset | The ramp is not long enough to reach the top constraint plus top offset. Change the slope or increase the length of the ramp.
RampLandingNotCreated | Beginning of run coincide with the end of previous run. Landing is not created between runs.
RampRunTooComplex | Ramp Run has complex boundary and may produce unreasonable geometry. Split it into few Runs by inserting Riser Lines at the end of each Run and at the beginning of the next one. If you want to create Ramp with arc an straight section you can do it using a Run tool.
RampStartHigherThanEnd | The ramp's base (base level + base offset) must be below its top (top level + top offset).
RiserCurveTooShort | Riser curve is too short to create nosing on it.
RiserHeightIsTooSmall | Riser height is too small.
RiserIntWithBoundaryMoreThanOnceFailure | Riser intersects with boundary more than once.
RisersAtSameLocation | The highlighted risers have the same location along the boundary line. Please move one of the two risers.
RiserThicknesssResetToZero | Monolithic Stairs without Treads can't have Risers. Riser Thickness for Stairs Type was automatically set to zero.
RunBottomHigherThanTopFailure | The base elevation for the run is higher than the top elevation for the run.
RunBottomUnderStairsBottomFailure | Run bottom elevation should not be below the stairs bottom elevation.
RunIsJoiningLandingWithRiserSoNotchDoesNotWorkWarning | Run is joining landing with riser, so notch configuration does not take effect. Try to set run as begin/end with tread to make a notch.
RunTopLowerThanBottomFailure | The top elevation for the run is lower than the base elevation for the run.
SpiralRunRadiusTooSmallFailure | The radius value for the run is too small.
StairIncompleteFailure | Stair element is incomplete, not all components are logic connected.
StairsActualRiserHeightGreaterThanMaximumFailure | Computed actual riser height of stairs is greater than maximum riser height defined in stairs type.
StairsActualRunWidthLessThanMinimumFailure | Actual run width is less than minimum run width defined in stairs type.
StairsActualTreadDepthLessThanMinimumFailure | Computed actual tread depth of stairs is less than minimum tread depth defined in stairs type.
StairsAlreadyAttachedToCurrentLevel | Mutistory Stairs already have a Stair attaching to this level.
StairsAreUpdatedDueToLevelHeightChange | Stair component(s) in the multistory stair are updated due to the level height changes.
StairsAutomaticLandingLayoutFailure | Fail to generate the automatic landing layout
StairsAutomaticLandingLayoutWarn | Fail to generate the automatic landing layout
StairsBottomEndExceedsOrNotReachWarning | Stair bottom end exceeds or cannot reach the base elevation of the stair. Add/remove risers at the bottom end or change base elevation settings in Stair Properties.
StairsCannotExtendToFloorStructureLayerWarning | Stairs cannot extend to floor structure layer.
StairsCommonRunGenerateLayoutFailure | Fail to get base line thus fail to generate run layout
StairsComponentJoinFailure | Can't keep elements joined.
StairsCrossingRisersDisallowedFailure | Crossing risers are not allowed
StairsGenericFailure | Stairs generic failure
StairsGenericTransformFailure | Cannot change base elevation of Stairs
StairsIllegalDesiredNumRisers | Desired Number of Risers is too small. Computed Actual Riser Height is greater than Maximum Riser Height allowed by type.
StairsInMultistoryExceedTopConstraint | Stairs in MultistoryStairs after adjusting still exceed the top constraint.
StairsOnlySingleBoundaryHasRiserWithBothEndsOnBoundaryFailure | Only single boundary case may have riser with its both ends on boundary.
StairsOtherThan2IntsByRiserAndBoundaryFailure | More than 2 intersection points between riser segment and boundary encountered
StairsPathPositionResetWarning | The stairs path doesn't intersect with riser lines.
StairsRunRunJoinNotAllowedFailure | Run-Run join is not allowed of they have same "Start With Riser"/"End With Riser" configuration at the joined end.
StairsStartHigherThanEnd | The stairs' base (Base Level + Base Offset) must be below its top (Top Level + Top Offset).
StairsStringerCannotBeCreated | The stairs stringer cannot be created.
StairsSubElementsNotConnectedWarning | Stair sub-elements are not connected
StairsSupportOverlapFailure | Some supports overlap with others
StairsSupportTooShort | A short support is being created.
StairsTopEndExceedsOrNotReachWarning | Stair top end exceeds or cannot reach the top elevation of the stair. Add/remove risers at the top end or change top elevation settings in Stair Properties.
StairsTopLowerThanBaseFailure | The top of the Stair is lower than the base of the Stair
StairStringerCantOffset | Inside stringer could not be created because of insufficient space. Please disable the inside stringer or decrease its width.
StairsWinderGenLayoutFailure | Fail to generate run layout and then cannot make winder run
StairsWinderInvalidParamsFailure | Cannot create the winder run because some values for the instance properties cannot be satisfied.
StairsZeroDesiredRisers | The number of desired risers for a staircase cannot be 0.
StringerCurvesNotSplitStairs | The slope of stringer may not parallel runs and landings. To get a parallel stringer, split boundary lines at the ends of landings.
StringerCurveTooShort | A piece of boundary is too short to create stringer on it.
TooShortCurveDowngradeGeometry | Curve is too short and may downgrade the geometry.
TreadDepthBelowMin | The Actual Tread Depth for one or more Stairs violates the Minimum Depth set in the type.
TreadDepthFailsEq | The actual tread depth and riser height for one or more stairs of this type violates the stair equation.
TreadDepthTooBigFailure | The tread depth is too large for the spiral run.
TreadFrontProfileInvalid | This profile cannot be used for the front of treads. Please choose a profile composed of a closed loop of lines with exactly one lines coincident with the y-axis. This lines will define the connection of this profile to the tread.
UnableToCreateMultistoryStairs | Unable to create Multistory stairs.
UnexpectedCurveIntersectionFailure | Computing curve intersection and find the invalid result.
WinderFilletRadiusTooLargeFailure | The value for Fillet Radius is too large to satisfy the Minimum Inside Width value.
WinderFirstLegTooShortOrRunWidthTooGreatFailure | The first leg of winder run is too short or the runwidth is too great.
WinderGenericError | Cannot make winder.
WinderLegIsTooShortFailure | A winder leg is too short.
WinderLegsAngleTooGreatOrRunWidthTooSmallFailure | The angle between two consecutive legs are too great or the runwidth is too small.
WinderLegTooShortOrRunWidthTooGreatFailure | One leg of the winder run is too small or the runwidth is too great.
WinderMinWidthTooLargeFailure | The value for Minimum Width on Inside Boundary is too large.
WinderMinWidthTooLargeForParallelTreadsFailure | The value for Minimum Width on Inside Boundary is too large to satisfy the number of Parallel Treads at the Start or End as specified in the Run Instance properties.
WinderParallelLegsFailure | Two consecutive legs are parallel.
WinderParallelTreadsNumberFailure | Cannot satisfy the number of Parallel Treads at the Start or End as specified in the Run Instance properties
WinderRunCreationFailure | The relationship between the current values of Actual Run Width, Minimum Width at Inside Boundary, and Parallel Treads at Start or End does not support the creation of the winder run.
WinderRunInsideMinTreadDepthFailure | Please enter a positive value less than Actual Tread Depth on Stair Path (%Actual Tread Depth%).
WinderRunInsideWalklineOffsetFailure | Please enter a value between 0 and half of Actual Run Width (%1/2 Actual Run Width%).
WinderRunWidthLessThan2TimesMinWidthFailure | The value for Minimum Width on Inside Boundary is too large to satisfy the number of Parallel Treads at the Start or End as specified in the Run Instance properties.
WinderRunWidthLessThanWalkLineOffsetFailure | The value for Run Width is less than two times of value of the inside walkline offset.
WinderRunWidthOrMinWidthOrTooGreatParallelTreadsFailure | The parameter runwidth is great or the parameter min width at inside boundary is too great, or number of parallel treads at both ends is too great.
WinderRunWidthOrMinWidthOrTooShortFailure | The parameter runwidth is too great or the parameter min width at inside boundary is too great, or one leg of winder run is too short.
WinderSecondLegTooShortOrRunwidthTooGreatFailure | The second leg of winder run is too short or the runwidth is too great.
WinderStraightStepsNumberFailure | The current layout cannot allow the specified number of treads. Increase the length of the run leg in the model or reduce the value for Parallel Treads at Start or Parallel Treads at End.
WinderThirdLegTooShortOrRunWidthTooGreatFailure | The third leg of winder run is too short or the runwidth is too great.
WinderTooManyEndParallelTreadsOrRunWidthFailure | The number of parallel treads at end is too great or the run width is too great.
WinderTooManyParallelTreadsAtEndFailure | The number of parallel treads at end is too great.
WinderTooManyParallelTreadsAtHeadFailure | The number of parallel treads at start is too great.
WinderTooManyStartParallelTreadsOrRunWidthFailure | The number of parallel treads at start is too great or the run width is too great.

See Also

BuiltInFailures..::..StairRampFailures Class


ActualRiserHeightChanged Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..ActualRiserHeightChanged Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The actual riser height for one or more stairs violates the maximum set in the type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ActualRiserHeightChanged { get; }
Visual Basic
Public Shared ReadOnly Property ActualRiserHeightChanged As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ActualRiserHeightChanged {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


AntiparallelRampRisers Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..AntiparallelRampRisers Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Riser lines are parallel but not collinear. Can't build Run between these Risers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AntiparallelRampRisers { get; }
Visual Basic
Public Shared ReadOnly Property AntiparallelRampRisers As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AntiparallelRampRisers {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


AntiparallelRampRisersError Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..AntiparallelRampRisersError Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Riser lines are parallel but not collinear. Can't build Run between these Risers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AntiparallelRampRisersError { get; }
Visual Basic
Public Shared ReadOnly Property AntiparallelRampRisersError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AntiparallelRampRisersError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


ArcRunRadiusTooSmall Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..ArcRunRadiusTooSmall Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Can't create Run. Run radius is too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ArcRunRadiusTooSmall { get; }
Visual Basic
Public Shared ReadOnly Property ArcRunRadiusTooSmall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ArcRunRadiusTooSmall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


ArcRunWidthTooLongFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..ArcRunWidthTooLongFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Arc run width is too long.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ArcRunWidthTooLongFailure { get; }
Visual Basic
Public Shared ReadOnly Property ArcRunWidthTooLongFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ArcRunWidthTooLongFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


AutomaticLandingConvertedToSketchedLandingWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..AutomaticLandingConvertedToSketchedLandingWarning Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Some run(s) are deleted, so automatic landing is converted to sketched landing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AutomaticLandingConvertedToSketchedLandingWarning { get; }
Visual Basic
Public Shared ReadOnly Property AutomaticLandingConvertedToSketchedLandingWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AutomaticLandingConvertedToSketchedLandingWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


BadBalustersPerTread Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..BadBalustersPerTread Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Number of Balusters per Tread must be an integer greater than zero.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId BadBalustersPerTread { get; }
Visual Basic
Public Shared ReadOnly Property BadBalustersPerTread As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BadBalustersPerTread {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


BadFillingSpacing Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..BadFillingSpacing Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Spacing for Excess Length Fill is too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId BadFillingSpacing { get; }
Visual Basic
Public Shared ReadOnly Property BadFillingSpacing As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BadFillingSpacing {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


BadRailings Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..BadRailings Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Can't create Railings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId BadRailings { get; }
Visual Basic
Public Shared ReadOnly Property BadRailings As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BadRailings {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


BadRailProfile Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..BadRailProfile Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
One or more Profile Loops are invalid, probably because of self-intersection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId BadRailProfile { get; }
Visual Basic
Public Shared ReadOnly Property BadRailProfile As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BadRailProfile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


BadTreadRiserProfile Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..BadTreadRiserProfile Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Tread/Riser profile is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId BadTreadRiserProfile { get; }
Visual Basic
Public Shared ReadOnly Property BadTreadRiserProfile As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BadTreadRiserProfile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


BalustersTooClose Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..BalustersTooClose Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Baluster Separation must be equal to or greater than the Baluster widths.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId BalustersTooClose { get; }
Visual Basic
Public Shared ReadOnly Property BalustersTooClose As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BalustersTooClose {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


BalustersTooCloseAbsolute Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..BalustersTooCloseAbsolute Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Baluster Separation is too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId BalustersTooCloseAbsolute { get; }
Visual Basic
Public Shared ReadOnly Property BalustersTooCloseAbsolute As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BalustersTooCloseAbsolute {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotAlignSupportOnPosts Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..CannotAlignSupportOnPosts Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Cannot align the support on the posts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotAlignSupportOnPosts { get; }
Visual Basic
Public Shared ReadOnly Property CannotAlignSupportOnPosts As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotAlignSupportOnPosts {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotComputeRailElevation Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..CannotComputeRailElevation Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Can't compute elevation profile for one or more Rails

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotComputeRailElevation { get; }
Visual Basic
Public Shared ReadOnly Property CannotComputeRailElevation As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotComputeRailElevation {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotCreateBaluster Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..CannotCreateBaluster Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Can't create Balusters for given Width and Height.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateBaluster { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateBaluster As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateBaluster {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotCreateBalusterPatterns Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..CannotCreateBalusterPatterns Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Can't create Baluster Patterns for Railings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateBalusterPatterns { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateBalusterPatterns As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateBalusterPatterns {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotCreateCornerBalusters Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..CannotCreateCornerBalusters Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Can't create corner Baluster

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateCornerBalusters { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateCornerBalusters As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateCornerBalusters {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotCreateLandingStringer Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..CannotCreateLandingStringer Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Can't create stringer at landing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateLandingStringer { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateLandingStringer As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateLandingStringer {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotCreateNosing Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..CannotCreateNosing Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Can't create nosing on one or more treads.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateNosing { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateNosing As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateNosing {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotCreateOneOrMoreTreads Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..CannotCreateOneOrMoreTreads Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Can't create geometry for one or more treads.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateOneOrMoreTreads { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateOneOrMoreTreads As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateOneOrMoreTreads {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotCreateOpenMiddleStringers Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..CannotCreateOpenMiddleStringers Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Can't cut open/middle stringers geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateOpenMiddleStringers { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateOpenMiddleStringers As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateOpenMiddleStringers {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotCreateRail Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..CannotCreateRail Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Can't create Railing. Thickness of Rail or Balusters might be too small. If you don't want Balusters, specify "None" for Baluster Shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateRail { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateRail As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateRail {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotCreateRailGeom Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..CannotCreateRailGeom Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Can't create geometry for one or more Rails

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateRailGeom { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateRailGeom As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateRailGeom {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotCreateRailWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..CannotCreateRailWarn Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Can't create Railing. Thickness of Rail or Balusters might be too small. If you don't want Balusters, specify "None" for Baluster Shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateRailWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateRailWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateRailWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotCreateRiser Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..CannotCreateRiser Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Can't create geometry for one or more risers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateRiser { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateRiser As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateRiser {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotCreateSideStringer Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..CannotCreateSideStringer Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Can't create one or more Side Stringers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateSideStringer { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateSideStringer As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateSideStringer {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotCreateStairForLevelOverlapping Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..CannotCreateStairForLevelOverlapping Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Some of the multistory stairs couldn't be created due to the overlapped levels.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateStairForLevelOverlapping { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateStairForLevelOverlapping As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateStairForLevelOverlapping {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotCreateStringers Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..CannotCreateStringers Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Can't create stringers geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateStringers { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateStringers As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateStringers {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotEndWithZeroRiser Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..CannotEndWithZeroRiser Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Can't end Stairs with Riser because Riser Thickness is too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotEndWithZeroRiser { get; }
Visual Basic
Public Shared ReadOnly Property CannotEndWithZeroRiser As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotEndWithZeroRiser {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotGenerateFaces Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..CannotGenerateFaces Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Couldn't generate surfaces for stairs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotGenerateFaces { get; }
Visual Basic
Public Shared ReadOnly Property CannotGenerateFaces As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotGenerateFaces {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotGenerateRamp Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..CannotGenerateRamp Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Couldn't generate surfaces for ramp.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotGenerateRamp { get; }
Visual Basic
Public Shared ReadOnly Property CannotGenerateRamp As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotGenerateRamp {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotOffsetRail Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..CannotOffsetRail Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Can't create one or more Rails with desired offset

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotOffsetRail { get; }
Visual Basic
Public Shared ReadOnly Property CannotOffsetRail As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotOffsetRail {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotPlaceBalusterOffset Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..CannotPlaceBalusterOffset Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Can't place Balusters and/or Rails with desired offset

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotPlaceBalusterOffset { get; }
Visual Basic
Public Shared ReadOnly Property CannotPlaceBalusterOffset As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPlaceBalusterOffset {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotPlaceBalusterPatterns Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..CannotPlaceBalusterPatterns Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Can't place Baluster Patterns

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotPlaceBalusterPatterns { get; }
Visual Basic
Public Shared ReadOnly Property CannotPlaceBalusterPatterns As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPlaceBalusterPatterns {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotPlaceRailingOnStringerWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..CannotPlaceRailingOnStringerWarning Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Railing is placed on tread because there is no stringer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotPlaceRailingOnStringerWarning { get; }
Visual Basic
Public Shared ReadOnly Property CannotPlaceRailingOnStringerWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPlaceRailingOnStringerWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotProcessInStairsSketchEditMode Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..CannotProcessInStairsSketchEditMode Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Cannot process when stair(s) in sketch edit mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotProcessInStairsSketchEditMode { get; }
Visual Basic
Public Shared ReadOnly Property CannotProcessInStairsSketchEditMode As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotProcessInStairsSketchEditMode {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotSplitRailingWithExtensions Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..CannotSplitRailingWithExtensions Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Railings with extensions cannot be split.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotSplitRailingWithExtensions { get; }
Visual Basic
Public Shared ReadOnly Property CannotSplitRailingWithExtensions As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotSplitRailingWithExtensions {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


ContinuousRailFilletCreationWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..ContinuousRailFilletCreationWarning Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Cannot create specified fillet at rail path corner.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ContinuousRailFilletCreationWarning { get; }
Visual Basic
Public Shared ReadOnly Property ContinuousRailFilletCreationWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ContinuousRailFilletCreationWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


ContinuousRailGometryCreationFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..ContinuousRailGometryCreationFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Cannot create the continuous rail geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ContinuousRailGometryCreationFailure { get; }
Visual Basic
Public Shared ReadOnly Property ContinuousRailGometryCreationFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ContinuousRailGometryCreationFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


ContinuousRailNotContinuous Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..ContinuousRailNotContinuous Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The rail is non-continuous.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ContinuousRailNotContinuous { get; }
Visual Basic
Public Shared ReadOnly Property ContinuousRailNotContinuous As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ContinuousRailNotContinuous {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


ContinuousRailSupportPlacementFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..ContinuousRailSupportPlacementFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Cannot place the supports along the rail path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ContinuousRailSupportPlacementFailure { get; }
Visual Basic
Public Shared ReadOnly Property ContinuousRailSupportPlacementFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ContinuousRailSupportPlacementFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


ContinuousRailTransitionFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..ContinuousRailTransitionFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Cannot create specified transition at rail path turn, hand Rail/Top Rail cannot maintain continuous.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ContinuousRailTransitionFailure { get; }
Visual Basic
Public Shared ReadOnly Property ContinuousRailTransitionFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ContinuousRailTransitionFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


ExtendBelowBaseGreaterThanLandingBaseElevation Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..ExtendBelowBaseGreaterThanLandingBaseElevation Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Extend Below Base needs to be less than Landing Base Elevation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ExtendBelowBaseGreaterThanLandingBaseElevation { get; }
Visual Basic
Public Shared ReadOnly Property ExtendBelowBaseGreaterThanLandingBaseElevation As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ExtendBelowBaseGreaterThanLandingBaseElevation {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


ExtendBelowBaseGreaterThanRunTopElevation Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..ExtendBelowBaseGreaterThanRunTopElevation Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Extend Below Base needs to be less than Run Top Elevation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ExtendBelowBaseGreaterThanRunTopElevation { get; }
Visual Basic
Public Shared ReadOnly Property ExtendBelowBaseGreaterThanRunTopElevation As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ExtendBelowBaseGreaterThanRunTopElevation {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


FailToReOrientSketchCurvesFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..FailToReOrientSketchCurvesFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Failed to orient sketch curves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FailToReOrientSketchCurvesFailure { get; }
Visual Basic
Public Shared ReadOnly Property FailToReOrientSketchCurvesFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FailToReOrientSketchCurvesFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


IntermediateLandingHigherThanTopRunFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..IntermediateLandingHigherThanTopRunFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Run is reversed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId IntermediateLandingHigherThanTopRunFailure { get; }
Visual Basic
Public Shared ReadOnly Property IntermediateLandingHigherThanTopRunFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ IntermediateLandingHigherThanTopRunFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


InvalidParameters Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..InvalidParameters Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Stairs run or landing has invalid parameter(s).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidParameters { get; }
Visual Basic
Public Shared ReadOnly Property InvalidParameters As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidParameters {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


InvalidRailProfile Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..InvalidRailProfile Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Profiles for one or more of the Rails are invalid. Make sure that every used Profile is a closed series of non-intersecting Lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidRailProfile { get; }
Visual Basic
Public Shared ReadOnly Property InvalidRailProfile As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidRailProfile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


InvalidStairsPathFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..InvalidStairsPathFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Invalid stairs path provided.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidStairsPathFailure { get; }
Visual Basic
Public Shared ReadOnly Property InvalidStairsPathFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidStairsPathFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


InvalidStartLevel Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..InvalidStartLevel Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The start level and end level for this staircase must be at different elevations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidStartLevel { get; }
Visual Basic
Public Shared ReadOnly Property InvalidStartLevel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidStartLevel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


InvalidStartLevelRamp Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..InvalidStartLevelRamp Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The start level and end level for this ramp must be at different elevations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidStartLevelRamp { get; }
Visual Basic
Public Shared ReadOnly Property InvalidStartLevelRamp As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidStartLevelRamp {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


LandingHeightUnderStairsBottom Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..LandingHeightUnderStairsBottom Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Cannot make landing because height of landing is equal or less than to bottom height of the stair.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId LandingHeightUnderStairsBottom { get; }
Visual Basic
Public Shared ReadOnly Property LandingHeightUnderStairsBottom As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LandingHeightUnderStairsBottom {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


LandingShapeHandleOnPinnedRunFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..LandingShapeHandleOnPinnedRunFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Cannot Drag the automatic landing shape handle control because the connected run is pinned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId LandingShapeHandleOnPinnedRunFailure { get; }
Visual Basic
Public Shared ReadOnly Property LandingShapeHandleOnPinnedRunFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LandingShapeHandleOnPinnedRunFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


MayUnjoinRailAndSupports Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..MayUnjoinRailAndSupports Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Fillet may cause the supports unjoin with the rail.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MayUnjoinRailAndSupports { get; }
Visual Basic
Public Shared ReadOnly Property MayUnjoinRailAndSupports As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MayUnjoinRailAndSupports {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


MultistoryLevelBelowTopbottomLevel Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..MultistoryLevelBelowTopbottomLevel Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Multistory top level must be above the stair/ramp top and bottom levels.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MultistoryLevelBelowTopbottomLevel { get; }
Visual Basic
Public Shared ReadOnly Property MultistoryLevelBelowTopbottomLevel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MultistoryLevelBelowTopbottomLevel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


MultistoryStairDoesntReach Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..MultistoryStairDoesntReach Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The multistory stair/ramp could not reach its top level with integral number of flights. Maximum number of flights below the top level is created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MultistoryStairDoesntReach { get; }
Visual Basic
Public Shared ReadOnly Property MultistoryStairDoesntReach As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MultistoryStairDoesntReach {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


MultistoryStairsAutomaticLevelLandingsDeleted Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..MultistoryStairsAutomaticLevelLandingsDeleted Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Level landings are deleted because the connected stairs have been regenerated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MultistoryStairsAutomaticLevelLandingsDeleted { get; }
Visual Basic
Public Shared ReadOnly Property MultistoryStairsAutomaticLevelLandingsDeleted As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MultistoryStairsAutomaticLevelLandingsDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


MultistoryStairsComponentJoinFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..MultistoryStairsComponentJoinFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Can't keep elements joined. Avoid converting stairs to skeched-based component in Multistory stairs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MultistoryStairsComponentJoinFailure { get; }
Visual Basic
Public Shared ReadOnly Property MultistoryStairsComponentJoinFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MultistoryStairsComponentJoinFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


MultistoryStandardStairBottomEndExceedsOrNotReach Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..MultistoryStandardStairBottomEndExceedsOrNotReach Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
One of the stairs inside multistory stairs bottom ends exceeds or cannot reach the base elevation of the stair.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MultistoryStandardStairBottomEndExceedsOrNotReach { get; }
Visual Basic
Public Shared ReadOnly Property MultistoryStandardStairBottomEndExceedsOrNotReach As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MultistoryStandardStairBottomEndExceedsOrNotReach {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


MultistoryStandardStairTopEndExceedsOrNotReach Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..MultistoryStandardStairTopEndExceedsOrNotReach Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
One of the stairs inside multistory stairs top ends exceed or cannot reach the top elevation of the stair.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MultistoryStandardStairTopEndExceedsOrNotReach { get; }
Visual Basic
Public Shared ReadOnly Property MultistoryStandardStairTopEndExceedsOrNotReach As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MultistoryStandardStairTopEndExceedsOrNotReach {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


MultusegmentRampRiser Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..MultusegmentRampRiser Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Ramp can't have multisegment Riser.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MultusegmentRampRiser { get; }
Visual Basic
Public Shared ReadOnly Property MultusegmentRampRiser As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MultusegmentRampRiser {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


MultusegmentRampRiserError Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..MultusegmentRampRiserError Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Ramp can't have multisegment Riser.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MultusegmentRampRiserError { get; }
Visual Basic
Public Shared ReadOnly Property MultusegmentRampRiserError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MultusegmentRampRiserError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


NoProfileForRail Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..NoProfileForRail Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Must specify Profiles for every Rail.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoProfileForRail { get; }
Visual Basic
Public Shared ReadOnly Property NoProfileForRail As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoProfileForRail {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


NoRisersInPureMonolithicStairs Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..NoRisersInPureMonolithicStairs Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Monolithic Stairs with zero tread thickness can't have risers

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoRisersInPureMonolithicStairs { get; }
Visual Basic
Public Shared ReadOnly Property NoRisersInPureMonolithicStairs As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoRisersInPureMonolithicStairs {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


NoRunsRamp Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..NoRunsRamp Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Ramp has no Runs. Can't create Ramp.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoRunsRamp { get; }
Visual Basic
Public Shared ReadOnly Property NoRunsRamp As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoRunsRamp {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


NoRunsRampError Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..NoRunsRampError Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Ramp has no Runs. Can't create Ramp.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoRunsRampError { get; }
Visual Basic
Public Shared ReadOnly Property NoRunsRampError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoRunsRampError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


NotALineRiserRamp Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..NotALineRiserRamp Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Riser line must be a straight line for Ramps.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NotALineRiserRamp { get; }
Visual Basic
Public Shared ReadOnly Property NotALineRiserRamp As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotALineRiserRamp {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


NotALineRiserRampError Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..NotALineRiserRampError Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Riser line must be a straight line for Ramps.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NotALineRiserRampError { get; }
Visual Basic
Public Shared ReadOnly Property NotALineRiserRampError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotALineRiserRampError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


NotchThicknessIsLargerThanLandingWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..NotchThicknessIsLargerThanLandingWarning Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The notch thickness is larger than landing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NotchThicknessIsLargerThanLandingWarning { get; }
Visual Basic
Public Shared ReadOnly Property NotchThicknessIsLargerThanLandingWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotchThicknessIsLargerThanLandingWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


NotEnoughRisers Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..NotEnoughRisers Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Actual Number of Risers is different from Desired Number of Risers. Add/remove Risers or change Desired Number of Risers in Stairs Properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NotEnoughRisers { get; }
Visual Basic
Public Shared ReadOnly Property NotEnoughRisers As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotEnoughRisers {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


OnlyMonolithicStairs Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..OnlyMonolithicStairs Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Tread thickness can't be zero for non-monolithic stairs

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId OnlyMonolithicStairs { get; }
Visual Basic
Public Shared ReadOnly Property OnlyMonolithicStairs As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OnlyMonolithicStairs {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


PartOfRiserLiesOnBoundaryFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..PartOfRiserLiesOnBoundaryFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Part of the riser lies on the boundary is not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId PartOfRiserLiesOnBoundaryFailure { get; }
Visual Basic
Public Shared ReadOnly Property PartOfRiserLiesOnBoundaryFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PartOfRiserLiesOnBoundaryFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


PathDoesntJoinToBorderRisersFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..PathDoesntJoinToBorderRisersFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Path doesn't join to border risers is not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId PathDoesntJoinToBorderRisersFailure { get; }
Visual Basic
Public Shared ReadOnly Property PathDoesntJoinToBorderRisersFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PathDoesntJoinToBorderRisersFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


RailingBadOffset Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..RailingBadOffset Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
An arc in the railing sketch has a radius that conflicts with the current rail widths and offsets. Please either increase the radius or modify rail profiles and offsets.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RailingBadOffset { get; }
Visual Basic
Public Shared ReadOnly Property RailingBadOffset As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RailingBadOffset {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


RailingCurvesNotSplitRamp Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..RailingCurvesNotSplitRamp Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The slope of this railing will not parallel the ramp at landings. To get a parallel railing, split the railing sketch at the ends of landings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RailingCurvesNotSplitRamp { get; }
Visual Basic
Public Shared ReadOnly Property RailingCurvesNotSplitRamp As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RailingCurvesNotSplitRamp {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


RailingCurvesNotSplitStairs Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..RailingCurvesNotSplitStairs Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The slope of this railing may not parallel the stairs at runs and landings. To get a parallel railing, split the railing sketch at the ends of landings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RailingCurvesNotSplitStairs { get; }
Visual Basic
Public Shared ReadOnly Property RailingCurvesNotSplitStairs As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RailingCurvesNotSplitStairs {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


RailingDoublyConnected Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..RailingDoublyConnected Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Railings hosted on Stairs must form a single, open, connected line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RailingDoublyConnected { get; }
Visual Basic
Public Shared ReadOnly Property RailingDoublyConnected As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RailingDoublyConnected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


RailingNotConnected Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..RailingNotConnected Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The Railing line must be a single connected Sketch. If you want separate pieces of Railing, create two or more separate Railings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RailingNotConnected { get; }
Visual Basic
Public Shared ReadOnly Property RailingNotConnected As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RailingNotConnected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


RailPathCloseLoopForExtensionWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..RailPathCloseLoopForExtensionWarning Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The rail path is closed at the start and end path point for extension creation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RailPathCloseLoopForExtensionWarning { get; }
Visual Basic
Public Shared ReadOnly Property RailPathCloseLoopForExtensionWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RailPathCloseLoopForExtensionWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


RailProfileLowerThanFilletError Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..RailProfileLowerThanFilletError Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Fillet cannot be created between rail segment since the radius is lower than the profile size.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RailProfileLowerThanFilletError { get; }
Visual Basic
Public Shared ReadOnly Property RailProfileLowerThanFilletError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RailProfileLowerThanFilletError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


RailProfileLowerThanFilletFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..RailProfileLowerThanFilletFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Fillet cannot be created between rail segment since the radius is lower than the profile size.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RailProfileLowerThanFilletFailure { get; }
Visual Basic
Public Shared ReadOnly Property RailProfileLowerThanFilletFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RailProfileLowerThanFilletFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


RailProfileOpen Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..RailProfileOpen Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Open Profile Loop can't be used as a Rail Profile

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RailProfileOpen { get; }
Visual Basic
Public Shared ReadOnly Property RailProfileOpen As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RailProfileOpen {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


RailTypeChangeInconsistancyWarningWithResetBtn Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..RailTypeChangeInconsistancyWarningWithResetBtn Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Some rail type changes are not consistent with your rail instances customization in this project, you can reset them to make them corresponding with your changes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RailTypeChangeInconsistancyWarningWithResetBtn { get; }
Visual Basic
Public Shared ReadOnly Property RailTypeChangeInconsistancyWarningWithResetBtn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RailTypeChangeInconsistancyWarningWithResetBtn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


RampDoesntReachOffset Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..RampDoesntReachOffset Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The ramp is not long enough to reach the top constraint plus top offset. Change the slope or increase the length of the ramp.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RampDoesntReachOffset { get; }
Visual Basic
Public Shared ReadOnly Property RampDoesntReachOffset As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RampDoesntReachOffset {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


RampLandingNotCreated Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..RampLandingNotCreated Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Beginning of run coincide with the end of previous run. Landing is not created between runs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RampLandingNotCreated { get; }
Visual Basic
Public Shared ReadOnly Property RampLandingNotCreated As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RampLandingNotCreated {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


RampStartHigherThanEnd Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..RampStartHigherThanEnd Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The ramp's base (base level + base offset) must be below its top (top level + top offset).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RampStartHigherThanEnd { get; }
Visual Basic
Public Shared ReadOnly Property RampStartHigherThanEnd As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RampStartHigherThanEnd {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


RiserCurveTooShort Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..RiserCurveTooShort Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Riser curve is too short to create nosing on it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RiserCurveTooShort { get; }
Visual Basic
Public Shared ReadOnly Property RiserCurveTooShort As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RiserCurveTooShort {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


RiserHeightIsTooSmall Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..RiserHeightIsTooSmall Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Riser height is too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RiserHeightIsTooSmall { get; }
Visual Basic
Public Shared ReadOnly Property RiserHeightIsTooSmall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RiserHeightIsTooSmall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


RiserIntWithBoundaryMoreThanOnceFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..RiserIntWithBoundaryMoreThanOnceFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Riser intersects with boundary more than once.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RiserIntWithBoundaryMoreThanOnceFailure { get; }
Visual Basic
Public Shared ReadOnly Property RiserIntWithBoundaryMoreThanOnceFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RiserIntWithBoundaryMoreThanOnceFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


RiserThicknesssResetToZero Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..RiserThicknesssResetToZero Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Monolithic Stairs without Treads can't have Risers. Riser Thickness for Stairs Type was automatically set to zero.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RiserThicknesssResetToZero { get; }
Visual Basic
Public Shared ReadOnly Property RiserThicknesssResetToZero As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RiserThicknesssResetToZero {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


RunBottomHigherThanTopFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..RunBottomHigherThanTopFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The base elevation for the run is higher than the top elevation for the run.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RunBottomHigherThanTopFailure { get; }
Visual Basic
Public Shared ReadOnly Property RunBottomHigherThanTopFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RunBottomHigherThanTopFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


RunBottomUnderStairsBottomFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..RunBottomUnderStairsBottomFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Run bottom elevation should not be below the stairs bottom elevation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RunBottomUnderStairsBottomFailure { get; }
Visual Basic
Public Shared ReadOnly Property RunBottomUnderStairsBottomFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RunBottomUnderStairsBottomFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


RunIsJoiningLandingWithRiserSoNotchDoesNotWorkWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..RunIsJoiningLandingWithRiserSoNotchDoesNotWorkWarning Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Run is joining landing with riser, so notch configuration does not take effect. Try to set run as begin/end with tread to make a notch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RunIsJoiningLandingWithRiserSoNotchDoesNotWorkWarning { get; }
Visual Basic
Public Shared ReadOnly Property RunIsJoiningLandingWithRiserSoNotchDoesNotWorkWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RunIsJoiningLandingWithRiserSoNotchDoesNotWorkWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


RunTopLowerThanBottomFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..RunTopLowerThanBottomFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The top elevation for the run is lower than the base elevation for the run.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RunTopLowerThanBottomFailure { get; }
Visual Basic
Public Shared ReadOnly Property RunTopLowerThanBottomFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RunTopLowerThanBottomFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StairIncompleteFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..StairIncompleteFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Stair element is incomplete, not all components are logic connected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StairIncompleteFailure { get; }
Visual Basic
Public Shared ReadOnly Property StairIncompleteFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairIncompleteFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StairsAreUpdatedDueToLevelHeightChange Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..StairsAreUpdatedDueToLevelHeightChange Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Stair component(s) in the multistory stair are updated due to the level height changes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StairsAreUpdatedDueToLevelHeightChange { get; }
Visual Basic
Public Shared ReadOnly Property StairsAreUpdatedDueToLevelHeightChange As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairsAreUpdatedDueToLevelHeightChange {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StairsAutomaticLandingLayoutWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..StairsAutomaticLandingLayoutWarn Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Fail to generate the automatic landing layout

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StairsAutomaticLandingLayoutWarn { get; }
Visual Basic
Public Shared ReadOnly Property StairsAutomaticLandingLayoutWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairsAutomaticLandingLayoutWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StairsBottomEndExceedsOrNotReachWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..StairsBottomEndExceedsOrNotReachWarning Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Stair bottom end exceeds or cannot reach the base elevation of the stair. Add/remove risers at the bottom end or change base elevation settings in Stair Properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StairsBottomEndExceedsOrNotReachWarning { get; }
Visual Basic
Public Shared ReadOnly Property StairsBottomEndExceedsOrNotReachWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairsBottomEndExceedsOrNotReachWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StairsCannotExtendToFloorStructureLayerWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..StairsCannotExtendToFloorStructureLayerWarning Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Stairs cannot extend to floor structure layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StairsCannotExtendToFloorStructureLayerWarning { get; }
Visual Basic
Public Shared ReadOnly Property StairsCannotExtendToFloorStructureLayerWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairsCannotExtendToFloorStructureLayerWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StairsCommonRunGenerateLayoutFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..StairsCommonRunGenerateLayoutFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Fail to get base line thus fail to generate run layout

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StairsCommonRunGenerateLayoutFailure { get; }
Visual Basic
Public Shared ReadOnly Property StairsCommonRunGenerateLayoutFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairsCommonRunGenerateLayoutFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StairsCrossingRisersDisallowedFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..StairsCrossingRisersDisallowedFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Crossing risers are not allowed

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StairsCrossingRisersDisallowedFailure { get; }
Visual Basic
Public Shared ReadOnly Property StairsCrossingRisersDisallowedFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairsCrossingRisersDisallowedFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StairsGenericFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..StairsGenericFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Stairs generic failure

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StairsGenericFailure { get; }
Visual Basic
Public Shared ReadOnly Property StairsGenericFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairsGenericFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StairsGenericTransformFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..StairsGenericTransformFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Cannot change base elevation of Stairs

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StairsGenericTransformFailure { get; }
Visual Basic
Public Shared ReadOnly Property StairsGenericTransformFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairsGenericTransformFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StairsIllegalDesiredNumRisers Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..StairsIllegalDesiredNumRisers Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Desired Number of Risers is too small. Computed Actual Riser Height is greater than Maximum Riser Height allowed by type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StairsIllegalDesiredNumRisers { get; }
Visual Basic
Public Shared ReadOnly Property StairsIllegalDesiredNumRisers As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairsIllegalDesiredNumRisers {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StairsInMultistoryExceedTopConstraint Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..StairsInMultistoryExceedTopConstraint Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Stairs in MultistoryStairs after adjusting still exceed the top constraint.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StairsInMultistoryExceedTopConstraint { get; }
Visual Basic
Public Shared ReadOnly Property StairsInMultistoryExceedTopConstraint As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairsInMultistoryExceedTopConstraint {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StairsOnlySingleBoundaryHasRiserWithBothEndsOnBoundaryFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..StairsOnlySingleBoundaryHasRiserWithBothEndsOnBoundaryFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Only single boundary case may have riser with its both ends on boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StairsOnlySingleBoundaryHasRiserWithBothEndsOnBoundaryFailure { get; }
Visual Basic
Public Shared ReadOnly Property StairsOnlySingleBoundaryHasRiserWithBothEndsOnBoundaryFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairsOnlySingleBoundaryHasRiserWithBothEndsOnBoundaryFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StairsOtherThan2IntsByRiserAndBoundaryFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..StairsOtherThan2IntsByRiserAndBoundaryFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
More than 2 intersection points between riser segment and boundary encountered

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StairsOtherThan2IntsByRiserAndBoundaryFailure { get; }
Visual Basic
Public Shared ReadOnly Property StairsOtherThan2IntsByRiserAndBoundaryFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairsOtherThan2IntsByRiserAndBoundaryFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StairsPathPositionResetWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..StairsPathPositionResetWarning Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The stairs path doesn't intersect with riser lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StairsPathPositionResetWarning { get; }
Visual Basic
Public Shared ReadOnly Property StairsPathPositionResetWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairsPathPositionResetWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StairsRunRunJoinNotAllowedFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..StairsRunRunJoinNotAllowedFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Run-Run join is not allowed of they have same "Start With Riser"/"End With Riser" configuration at the joined end.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StairsRunRunJoinNotAllowedFailure { get; }
Visual Basic
Public Shared ReadOnly Property StairsRunRunJoinNotAllowedFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairsRunRunJoinNotAllowedFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StairsStartHigherThanEnd Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..StairsStartHigherThanEnd Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The stairs' base (Base Level + Base Offset) must be below its top (Top Level + Top Offset).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StairsStartHigherThanEnd { get; }
Visual Basic
Public Shared ReadOnly Property StairsStartHigherThanEnd As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairsStartHigherThanEnd {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StairsSubElementsNotConnectedWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..StairsSubElementsNotConnectedWarning Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Stair sub-elements are not connected

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StairsSubElementsNotConnectedWarning { get; }
Visual Basic
Public Shared ReadOnly Property StairsSubElementsNotConnectedWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairsSubElementsNotConnectedWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StairsTopEndExceedsOrNotReachWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..StairsTopEndExceedsOrNotReachWarning Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Stair top end exceeds or cannot reach the top elevation of the stair. Add/remove risers at the top end or change top elevation settings in Stair Properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StairsTopEndExceedsOrNotReachWarning { get; }
Visual Basic
Public Shared ReadOnly Property StairsTopEndExceedsOrNotReachWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairsTopEndExceedsOrNotReachWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StairsTopLowerThanBaseFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..StairsTopLowerThanBaseFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The top of the Stair is lower than the base of the Stair

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StairsTopLowerThanBaseFailure { get; }
Visual Basic
Public Shared ReadOnly Property StairsTopLowerThanBaseFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairsTopLowerThanBaseFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StairStringerCantOffset Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..StairStringerCantOffset Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Inside stringer could not be created because of insufficient space. Please disable the inside stringer or decrease its width.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StairStringerCantOffset { get; }
Visual Basic
Public Shared ReadOnly Property StairStringerCantOffset As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairStringerCantOffset {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StairsWinderGenLayoutFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..StairsWinderGenLayoutFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Fail to generate run layout and then cannot make winder run

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StairsWinderGenLayoutFailure { get; }
Visual Basic
Public Shared ReadOnly Property StairsWinderGenLayoutFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairsWinderGenLayoutFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StairsWinderInvalidParamsFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..StairsWinderInvalidParamsFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Cannot create the winder run because some values for the instance properties cannot be satisfied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StairsWinderInvalidParamsFailure { get; }
Visual Basic
Public Shared ReadOnly Property StairsWinderInvalidParamsFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairsWinderInvalidParamsFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StairsZeroDesiredRisers Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..StairsZeroDesiredRisers Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The number of desired risers for a staircase cannot be 0.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StairsZeroDesiredRisers { get; }
Visual Basic
Public Shared ReadOnly Property StairsZeroDesiredRisers As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairsZeroDesiredRisers {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StringerCurveTooShort Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..StringerCurveTooShort Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
A piece of boundary is too short to create stringer on it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StringerCurveTooShort { get; }
Visual Basic
Public Shared ReadOnly Property StringerCurveTooShort As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StringerCurveTooShort {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


TooShortCurveDowngradeGeometry Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..TooShortCurveDowngradeGeometry Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Curve is too short and may downgrade the geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId TooShortCurveDowngradeGeometry { get; }
Visual Basic
Public Shared ReadOnly Property TooShortCurveDowngradeGeometry As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TooShortCurveDowngradeGeometry {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


TreadDepthBelowMin Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..TreadDepthBelowMin Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The Actual Tread Depth for one or more Stairs violates the Minimum Depth set in the type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId TreadDepthBelowMin { get; }
Visual Basic
Public Shared ReadOnly Property TreadDepthBelowMin As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TreadDepthBelowMin {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


TreadDepthFailsEq Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..TreadDepthFailsEq Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The actual tread depth and riser height for one or more stairs of this type violates the stair equation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId TreadDepthFailsEq { get; }
Visual Basic
Public Shared ReadOnly Property TreadDepthFailsEq As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TreadDepthFailsEq {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


TreadFrontProfileInvalid Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..TreadFrontProfileInvalid Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
This profile cannot be used for the front of treads. Please choose a profile composed of a closed loop of lines with exactly one lines coincident with the y-axis. This lines will define the connection of this profile to the tread.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId TreadFrontProfileInvalid { get; }
Visual Basic
Public Shared ReadOnly Property TreadFrontProfileInvalid As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TreadFrontProfileInvalid {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


UnableToCreateMultistoryStairs Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..UnableToCreateMultistoryStairs Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Unable to create Multistory stairs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UnableToCreateMultistoryStairs { get; }
Visual Basic
Public Shared ReadOnly Property UnableToCreateMultistoryStairs As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableToCreateMultistoryStairs {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


UnexpectedCurveIntersectionFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..UnexpectedCurveIntersectionFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Computing curve intersection and find the invalid result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UnexpectedCurveIntersectionFailure { get; }
Visual Basic
Public Shared ReadOnly Property UnexpectedCurveIntersectionFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnexpectedCurveIntersectionFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


WinderFilletRadiusTooLargeFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..WinderFilletRadiusTooLargeFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The value for Fillet Radius is too large to satisfy the Minimum Inside Width value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WinderFilletRadiusTooLargeFailure { get; }
Visual Basic
Public Shared ReadOnly Property WinderFilletRadiusTooLargeFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WinderFilletRadiusTooLargeFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


WinderFirstLegTooShortOrRunWidthTooGreatFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..WinderFirstLegTooShortOrRunWidthTooGreatFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The first leg of winder run is too short or the runwidth is too great.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WinderFirstLegTooShortOrRunWidthTooGreatFailure { get; }
Visual Basic
Public Shared ReadOnly Property WinderFirstLegTooShortOrRunWidthTooGreatFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WinderFirstLegTooShortOrRunWidthTooGreatFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


WinderGenericError Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..WinderGenericError Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Cannot make winder.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WinderGenericError { get; }
Visual Basic
Public Shared ReadOnly Property WinderGenericError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WinderGenericError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


WinderLegIsTooShortFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..WinderLegIsTooShortFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
A winder leg is too short.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WinderLegIsTooShortFailure { get; }
Visual Basic
Public Shared ReadOnly Property WinderLegIsTooShortFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WinderLegIsTooShortFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


WinderLegsAngleTooGreatOrRunWidthTooSmallFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..WinderLegsAngleTooGreatOrRunWidthTooSmallFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The angle between two consecutive legs are too great or the runwidth is too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WinderLegsAngleTooGreatOrRunWidthTooSmallFailure { get; }
Visual Basic
Public Shared ReadOnly Property WinderLegsAngleTooGreatOrRunWidthTooSmallFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WinderLegsAngleTooGreatOrRunWidthTooSmallFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


WinderLegTooShortOrRunWidthTooGreatFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..WinderLegTooShortOrRunWidthTooGreatFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
One leg of the winder run is too small or the runwidth is too great.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WinderLegTooShortOrRunWidthTooGreatFailure { get; }
Visual Basic
Public Shared ReadOnly Property WinderLegTooShortOrRunWidthTooGreatFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WinderLegTooShortOrRunWidthTooGreatFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


WinderMinWidthTooLargeFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..WinderMinWidthTooLargeFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The value for Minimum Width on Inside Boundary is too large.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WinderMinWidthTooLargeFailure { get; }
Visual Basic
Public Shared ReadOnly Property WinderMinWidthTooLargeFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WinderMinWidthTooLargeFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


WinderMinWidthTooLargeForParallelTreadsFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..WinderMinWidthTooLargeForParallelTreadsFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The value for Minimum Width on Inside Boundary is too large to satisfy the number of Parallel Treads at the Start or End as specified in the Run Instance properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WinderMinWidthTooLargeForParallelTreadsFailure { get; }
Visual Basic
Public Shared ReadOnly Property WinderMinWidthTooLargeForParallelTreadsFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WinderMinWidthTooLargeForParallelTreadsFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


WinderParallelLegsFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..WinderParallelLegsFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Two consecutive legs are parallel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WinderParallelLegsFailure { get; }
Visual Basic
Public Shared ReadOnly Property WinderParallelLegsFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WinderParallelLegsFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


WinderParallelTreadsNumberFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..WinderParallelTreadsNumberFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Cannot satisfy the number of Parallel Treads at the Start or End as specified in the Run Instance properties

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WinderParallelTreadsNumberFailure { get; }
Visual Basic
Public Shared ReadOnly Property WinderParallelTreadsNumberFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WinderParallelTreadsNumberFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


WinderRunInsideMinTreadDepthFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..WinderRunInsideMinTreadDepthFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Please enter a positive value less than Actual Tread Depth on Stair Path (%Actual Tread Depth%).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WinderRunInsideMinTreadDepthFailure { get; }
Visual Basic
Public Shared ReadOnly Property WinderRunInsideMinTreadDepthFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WinderRunInsideMinTreadDepthFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


WinderRunInsideWalklineOffsetFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..WinderRunInsideWalklineOffsetFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Please enter a value between 0 and half of Actual Run Width (%1/2 Actual Run Width%).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WinderRunInsideWalklineOffsetFailure { get; }
Visual Basic
Public Shared ReadOnly Property WinderRunInsideWalklineOffsetFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WinderRunInsideWalklineOffsetFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


WinderRunWidthLessThanWalkLineOffsetFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..WinderRunWidthLessThanWalkLineOffsetFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The value for Run Width is less than two times of value of the inside walkline offset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WinderRunWidthLessThanWalkLineOffsetFailure { get; }
Visual Basic
Public Shared ReadOnly Property WinderRunWidthLessThanWalkLineOffsetFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WinderRunWidthLessThanWalkLineOffsetFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


WinderRunWidthOrMinWidthOrTooGreatParallelTreadsFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..WinderRunWidthOrMinWidthOrTooGreatParallelTreadsFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The parameter runwidth is great or the parameter min width at inside boundary is too great, or number of parallel treads at both ends is too great.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WinderRunWidthOrMinWidthOrTooGreatParallelTreadsFailure { get; }
Visual Basic
Public Shared ReadOnly Property WinderRunWidthOrMinWidthOrTooGreatParallelTreadsFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WinderRunWidthOrMinWidthOrTooGreatParallelTreadsFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


WinderRunWidthOrMinWidthOrTooShortFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..WinderRunWidthOrMinWidthOrTooShortFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The parameter runwidth is too great or the parameter min width at inside boundary is too great, or one leg of winder run is too short.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WinderRunWidthOrMinWidthOrTooShortFailure { get; }
Visual Basic
Public Shared ReadOnly Property WinderRunWidthOrMinWidthOrTooShortFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WinderRunWidthOrMinWidthOrTooShortFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


WinderSecondLegTooShortOrRunwidthTooGreatFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..WinderSecondLegTooShortOrRunwidthTooGreatFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The second leg of winder run is too short or the runwidth is too great.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WinderSecondLegTooShortOrRunwidthTooGreatFailure { get; }
Visual Basic
Public Shared ReadOnly Property WinderSecondLegTooShortOrRunwidthTooGreatFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WinderSecondLegTooShortOrRunwidthTooGreatFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


WinderStraightStepsNumberFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..WinderStraightStepsNumberFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The current layout cannot allow the specified number of treads. Increase the length of the run leg in the model or reduce the value for Parallel Treads at Start or Parallel Treads at End.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WinderStraightStepsNumberFailure { get; }
Visual Basic
Public Shared ReadOnly Property WinderStraightStepsNumberFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WinderStraightStepsNumberFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


WinderTooManyEndParallelTreadsOrRunWidthFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..WinderTooManyEndParallelTreadsOrRunWidthFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The number of parallel treads at end is too great or the run width is too great.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WinderTooManyEndParallelTreadsOrRunWidthFailure { get; }
Visual Basic
Public Shared ReadOnly Property WinderTooManyEndParallelTreadsOrRunWidthFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WinderTooManyEndParallelTreadsOrRunWidthFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


WinderTooManyParallelTreadsAtEndFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..WinderTooManyParallelTreadsAtEndFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The number of parallel treads at end is too great.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WinderTooManyParallelTreadsAtEndFailure { get; }
Visual Basic
Public Shared ReadOnly Property WinderTooManyParallelTreadsAtEndFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WinderTooManyParallelTreadsAtEndFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


WinderTooManyParallelTreadsAtHeadFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..WinderTooManyParallelTreadsAtHeadFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The number of parallel treads at start is too great.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WinderTooManyParallelTreadsAtHeadFailure { get; }
Visual Basic
Public Shared ReadOnly Property WinderTooManyParallelTreadsAtHeadFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WinderTooManyParallelTreadsAtHeadFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


WinderTooManyStartParallelTreadsOrRunWidthFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..StairRampFailures..::..WinderTooManyStartParallelTreadsOrRunWidthFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The number of parallel treads at start is too great or the run width is too great.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WinderTooManyStartParallelTreadsOrRunWidthFailure { get; }
Visual Basic
Public Shared ReadOnly Property WinderTooManyStartParallelTreadsOrRunWidthFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WinderTooManyStartParallelTreadsOrRunWidthFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


BuiltInFailures.SteelElementFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..SteelElementFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about steel elements

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class SteelElementFailures
Visual Basic
Public NotInheritable Class SteelElementFailures
Visual C++
public ref class SteelElementFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..SteelElementFailures

See Also

BuiltInFailures..::..SteelElementFailures Members


BuiltInFailures.SteelElementFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..SteelElementFailures Members
BuiltInFailures..::..SteelElementFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..SteelElementFailures type exposes the following members.

Properties

Name | Description
SteelElementModifyParametersTaskNotFinished | Cannot modify parameters while background calculations are in progress.
SteelElementModifyRangesTaskNotFinished | Cannot modify ranges while background calculations are in progress.
SteelElementPreviewTaskNotFinished | Cannot create preview while background calculations are in progress.
SteelElementPropagationTaskNotFinished | Advance Steel propagation tasks not finished.
SteelElementTaskNotFinished | Advance Steel tasks not finished.

See Also

BuiltInFailures..::..SteelElementFailures Class


BuiltInFailures.SteelElementFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..SteelElementFailures Properties
BuiltInFailures..::..SteelElementFailures Class See Also Send Feedback

The BuiltInFailures..::..SteelElementFailures type exposes the following members.

Properties

Name | Description
SteelElementModifyParametersTaskNotFinished | Cannot modify parameters while background calculations are in progress.
SteelElementModifyRangesTaskNotFinished | Cannot modify ranges while background calculations are in progress.
SteelElementPreviewTaskNotFinished | Cannot create preview while background calculations are in progress.
SteelElementPropagationTaskNotFinished | Advance Steel propagation tasks not finished.
SteelElementTaskNotFinished | Advance Steel tasks not finished.

See Also

BuiltInFailures..::..SteelElementFailures Class


SteelElementModifyParametersTaskNotFinished Property

[image]

Revit 2024 API
BuiltInFailures..::..SteelElementFailures..::..SteelElementModifyParametersTaskNotFinished Property
BuiltInFailures..::..SteelElementFailures Class See Also Send Feedback
Cannot modify parameters while background calculations are in progress.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SteelElementModifyParametersTaskNotFinished { get; }
Visual Basic
Public Shared ReadOnly Property SteelElementModifyParametersTaskNotFinished As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SteelElementModifyParametersTaskNotFinished {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SteelElementFailures Class


SteelElementModifyRangesTaskNotFinished Property

[image]

Revit 2024 API
BuiltInFailures..::..SteelElementFailures..::..SteelElementModifyRangesTaskNotFinished Property
BuiltInFailures..::..SteelElementFailures Class See Also Send Feedback
Cannot modify ranges while background calculations are in progress.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SteelElementModifyRangesTaskNotFinished { get; }
Visual Basic
Public Shared ReadOnly Property SteelElementModifyRangesTaskNotFinished As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SteelElementModifyRangesTaskNotFinished {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SteelElementFailures Class


SteelElementPreviewTaskNotFinished Property

[image]

Revit 2024 API
BuiltInFailures..::..SteelElementFailures..::..SteelElementPreviewTaskNotFinished Property
BuiltInFailures..::..SteelElementFailures Class See Also Send Feedback
Cannot create preview while background calculations are in progress.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SteelElementPreviewTaskNotFinished { get; }
Visual Basic
Public Shared ReadOnly Property SteelElementPreviewTaskNotFinished As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SteelElementPreviewTaskNotFinished {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SteelElementFailures Class


SteelElementPropagationTaskNotFinished Property

[image]

Revit 2024 API
BuiltInFailures..::..SteelElementFailures..::..SteelElementPropagationTaskNotFinished Property
BuiltInFailures..::..SteelElementFailures Class See Also Send Feedback
Advance Steel propagation tasks not finished.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SteelElementPropagationTaskNotFinished { get; }
Visual Basic
Public Shared ReadOnly Property SteelElementPropagationTaskNotFinished As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SteelElementPropagationTaskNotFinished {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SteelElementFailures Class


SteelElementTaskNotFinished Property

[image]

Revit 2024 API
BuiltInFailures..::..SteelElementFailures..::..SteelElementTaskNotFinished Property
BuiltInFailures..::..SteelElementFailures Class See Also Send Feedback
Advance Steel tasks not finished.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SteelElementTaskNotFinished { get; }
Visual Basic
Public Shared ReadOnly Property SteelElementTaskNotFinished As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SteelElementTaskNotFinished {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SteelElementFailures Class


BuiltInFailures.SteelElementsFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..SteelElementsFailures Members
BuiltInFailures..::..SteelElementsFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..SteelElementsFailures type exposes the following members.

Properties

Name | Description
SteelElementInvisibleInCurrentLevelOfDetailWarn | The created elements are only visible in Detail Level: Fine.
SteelElementModifiersWillBeIgnoredWarn | The copes and cuts (by face, with voids, by reference plane) of the element are no longer modifying the geometry.

See Also

BuiltInFailures..::..SteelElementsFailures Class


SteelElementInvisibleInCurrentLevelOfDetailWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..SteelElementsFailures..::..SteelElementInvisibleInCurrentLevelOfDetailWarn Property
BuiltInFailures..::..SteelElementsFailures Class See Also Send Feedback
The created elements are only visible in Detail Level: Fine.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SteelElementInvisibleInCurrentLevelOfDetailWarn { get; }
Visual Basic
Public Shared ReadOnly Property SteelElementInvisibleInCurrentLevelOfDetailWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SteelElementInvisibleInCurrentLevelOfDetailWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SteelElementsFailures Class


SteelElementModifiersWillBeIgnoredWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..SteelElementsFailures..::..SteelElementModifiersWillBeIgnoredWarn Property
BuiltInFailures..::..SteelElementsFailures Class See Also Send Feedback
The copes and cuts (by face, with voids, by reference plane) of the element are no longer modifying the geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SteelElementModifiersWillBeIgnoredWarn { get; }
Visual Basic
Public Shared ReadOnly Property SteelElementModifiersWillBeIgnoredWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SteelElementModifiersWillBeIgnoredWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SteelElementsFailures Class


BuiltInFailures.StructuralAssetFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..StructuralAssetFailures Members
BuiltInFailures..::..StructuralAssetFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..StructuralAssetFailures type exposes the following members.

Properties

Name | Description
StructuralMaterialAssetInvalid | Material assigned to the Analytical Element does not contain Structure parameters - verify material content.

See Also

BuiltInFailures..::..StructuralAssetFailures Class


BuiltInFailures.StructuralAssetFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..StructuralAssetFailures Properties
BuiltInFailures..::..StructuralAssetFailures Class See Also Send Feedback

The BuiltInFailures..::..StructuralAssetFailures type exposes the following members.

Properties

Name | Description
StructuralMaterialAssetInvalid | Material assigned to the Analytical Element does not contain Structure parameters - verify material content.

See Also

BuiltInFailures..::..StructuralAssetFailures Class


StructuralMaterialAssetInvalid Property

[image]

Revit 2024 API
BuiltInFailures..::..StructuralAssetFailures..::..StructuralMaterialAssetInvalid Property
BuiltInFailures..::..StructuralAssetFailures Class See Also Send Feedback
Material assigned to the Analytical Element does not contain Structure parameters - verify material content.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StructuralMaterialAssetInvalid { get; }
Visual Basic
Public Shared ReadOnly Property StructuralMaterialAssetInvalid As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StructuralMaterialAssetInvalid {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StructuralAssetFailures Class


BuiltInFailures.StructuralConnectionFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..StructuralConnectionFailures Members
BuiltInFailures..::..StructuralConnectionFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..StructuralConnectionFailures type exposes the following members.

Properties

Name | Description
StructuralConnectionCannotGenerate | Could not create Structural Connection Handler
StructuralConnectionCannotReplaceRefs | Structural Connection cannot replace elements
StructuralConnectionForbiddenElementInGroup | Fabrication element can not be a group member.
StructuralConnectionNoSingleRef | Summary: Structural Connection Handler lost connected element.
StructuralConnectionNotEnoughRefs | Structural Connection Handler cannot connect fewer than two elements.
StructuralConnectionSetOfRefsChanged | The set of input elements was changed and the connection has been adjusted.
StructuralConnectionTooFarNotEnoughRefs | Structural Connection Handler cannot connect too far elements
StructuralConnectionTooFarRefs | Structural Connection Handler cannot connect too far elements
StructuralConnectionTypeChangedToGeneric | Structural Connection had an inappropriate type, which has been changed to 'Generic Connection'.
StructuralConnectionTypeInfoNotAvailable | There is no add-on installed which supports Structural Connection type.
StructuralConnectionWrongType | Structural Connection has an inappropriate type assigned.
StructuralSectionHasIncompleteDefinition | Structural Section has incomplete definition

See Also

BuiltInFailures..::..StructuralConnectionFailures Class


BuiltInFailures.StructuralConnectionFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..StructuralConnectionFailures Properties
BuiltInFailures..::..StructuralConnectionFailures Class See Also Send Feedback

The BuiltInFailures..::..StructuralConnectionFailures type exposes the following members.

Properties

Name | Description
StructuralConnectionCannotGenerate | Could not create Structural Connection Handler
StructuralConnectionCannotReplaceRefs | Structural Connection cannot replace elements
StructuralConnectionForbiddenElementInGroup | Fabrication element can not be a group member.
StructuralConnectionNoSingleRef | Summary: Structural Connection Handler lost connected element.
StructuralConnectionNotEnoughRefs | Structural Connection Handler cannot connect fewer than two elements.
StructuralConnectionSetOfRefsChanged | The set of input elements was changed and the connection has been adjusted.
StructuralConnectionTooFarNotEnoughRefs | Structural Connection Handler cannot connect too far elements
StructuralConnectionTooFarRefs | Structural Connection Handler cannot connect too far elements
StructuralConnectionTypeChangedToGeneric | Structural Connection had an inappropriate type, which has been changed to 'Generic Connection'.
StructuralConnectionTypeInfoNotAvailable | There is no add-on installed which supports Structural Connection type.
StructuralConnectionWrongType | Structural Connection has an inappropriate type assigned.
StructuralSectionHasIncompleteDefinition | Structural Section has incomplete definition

See Also

BuiltInFailures..::..StructuralConnectionFailures Class


StructuralConnectionCannotGenerate Property

[image]

Revit 2024 API
BuiltInFailures..::..StructuralConnectionFailures..::..StructuralConnectionCannotGenerate Property
BuiltInFailures..::..StructuralConnectionFailures Class See Also Send Feedback
Could not create Structural Connection Handler

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StructuralConnectionCannotGenerate { get; }
Visual Basic
Public Shared ReadOnly Property StructuralConnectionCannotGenerate As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StructuralConnectionCannotGenerate {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StructuralConnectionFailures Class


StructuralConnectionCannotReplaceRefs Property

[image]

Revit 2024 API
BuiltInFailures..::..StructuralConnectionFailures..::..StructuralConnectionCannotReplaceRefs Property
BuiltInFailures..::..StructuralConnectionFailures Class See Also Send Feedback
Structural Connection cannot replace elements

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StructuralConnectionCannotReplaceRefs { get; }
Visual Basic
Public Shared ReadOnly Property StructuralConnectionCannotReplaceRefs As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StructuralConnectionCannotReplaceRefs {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StructuralConnectionFailures Class


StructuralConnectionForbiddenElementInGroup Property

[image]

Revit 2024 API
BuiltInFailures..::..StructuralConnectionFailures..::..StructuralConnectionForbiddenElementInGroup Property
BuiltInFailures..::..StructuralConnectionFailures Class See Also Send Feedback
Fabrication element can not be a group member.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StructuralConnectionForbiddenElementInGroup { get; }
Visual Basic
Public Shared ReadOnly Property StructuralConnectionForbiddenElementInGroup As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StructuralConnectionForbiddenElementInGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StructuralConnectionFailures Class


StructuralConnectionNoSingleRef Property

[image]

Revit 2024 API
BuiltInFailures..::..StructuralConnectionFailures..::..StructuralConnectionNoSingleRef Property
BuiltInFailures..::..StructuralConnectionFailures Class See Also Send Feedback
Summary: Structural Connection Handler lost connected element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StructuralConnectionNoSingleRef { get; }
Visual Basic
Public Shared ReadOnly Property StructuralConnectionNoSingleRef As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StructuralConnectionNoSingleRef {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StructuralConnectionFailures Class


StructuralConnectionNotEnoughRefs Property

[image]

Revit 2024 API
BuiltInFailures..::..StructuralConnectionFailures..::..StructuralConnectionNotEnoughRefs Property
BuiltInFailures..::..StructuralConnectionFailures Class See Also Send Feedback
Structural Connection Handler cannot connect fewer than two elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StructuralConnectionNotEnoughRefs { get; }
Visual Basic
Public Shared ReadOnly Property StructuralConnectionNotEnoughRefs As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StructuralConnectionNotEnoughRefs {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StructuralConnectionFailures Class


StructuralConnectionSetOfRefsChanged Property

[image]

Revit 2024 API
BuiltInFailures..::..StructuralConnectionFailures..::..StructuralConnectionSetOfRefsChanged Property
BuiltInFailures..::..StructuralConnectionFailures Class See Also Send Feedback
The set of input elements was changed and the connection has been adjusted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StructuralConnectionSetOfRefsChanged { get; }
Visual Basic
Public Shared ReadOnly Property StructuralConnectionSetOfRefsChanged As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StructuralConnectionSetOfRefsChanged {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StructuralConnectionFailures Class


StructuralConnectionTooFarNotEnoughRefs Property

[image]

Revit 2024 API
BuiltInFailures..::..StructuralConnectionFailures..::..StructuralConnectionTooFarNotEnoughRefs Property
BuiltInFailures..::..StructuralConnectionFailures Class See Also Send Feedback
Structural Connection Handler cannot connect too far elements

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StructuralConnectionTooFarNotEnoughRefs { get; }
Visual Basic
Public Shared ReadOnly Property StructuralConnectionTooFarNotEnoughRefs As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StructuralConnectionTooFarNotEnoughRefs {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StructuralConnectionFailures Class


StructuralConnectionTooFarRefs Property

[image]

Revit 2024 API
BuiltInFailures..::..StructuralConnectionFailures..::..StructuralConnectionTooFarRefs Property
BuiltInFailures..::..StructuralConnectionFailures Class See Also Send Feedback
Structural Connection Handler cannot connect too far elements

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StructuralConnectionTooFarRefs { get; }
Visual Basic
Public Shared ReadOnly Property StructuralConnectionTooFarRefs As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StructuralConnectionTooFarRefs {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StructuralConnectionFailures Class


StructuralConnectionTypeInfoNotAvailable Property

[image]

Revit 2024 API
BuiltInFailures..::..StructuralConnectionFailures..::..StructuralConnectionTypeInfoNotAvailable Property
BuiltInFailures..::..StructuralConnectionFailures Class See Also Send Feedback
There is no add-on installed which supports Structural Connection type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StructuralConnectionTypeInfoNotAvailable { get; }
Visual Basic
Public Shared ReadOnly Property StructuralConnectionTypeInfoNotAvailable As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StructuralConnectionTypeInfoNotAvailable {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StructuralConnectionFailures Class


StructuralConnectionWrongType Property

[image]

Revit 2024 API
BuiltInFailures..::..StructuralConnectionFailures..::..StructuralConnectionWrongType Property
BuiltInFailures..::..StructuralConnectionFailures Class See Also Send Feedback
Structural Connection has an inappropriate type assigned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StructuralConnectionWrongType { get; }
Visual Basic
Public Shared ReadOnly Property StructuralConnectionWrongType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StructuralConnectionWrongType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StructuralConnectionFailures Class


StructuralSectionHasIncompleteDefinition Property

[image]

Revit 2024 API
BuiltInFailures..::..StructuralConnectionFailures..::..StructuralSectionHasIncompleteDefinition Property
BuiltInFailures..::..StructuralConnectionFailures Class See Also Send Feedback
Structural Section has incomplete definition

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StructuralSectionHasIncompleteDefinition { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionHasIncompleteDefinition As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StructuralSectionHasIncompleteDefinition {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StructuralConnectionFailures Class


BuiltInFailures.StructuralCustomConnectionFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..StructuralCustomConnectionFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about StructuralConnectionHandler.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class StructuralCustomConnectionFailures
Visual Basic
Public NotInheritable Class StructuralCustomConnectionFailures
Visual C++
public ref class StructuralCustomConnectionFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..StructuralCustomConnectionFailures

See Also

BuiltInFailures..::..StructuralCustomConnectionFailures Members


BuiltInFailures.StructuralCustomConnectionFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..StructuralCustomConnectionFailures Members
BuiltInFailures..::..StructuralCustomConnectionFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..StructuralCustomConnectionFailures type exposes the following members.

Properties

Name | Description
SimpleConnectionTooFarRefs | Simple Structural Connection Handler cannot connect too far elements
StructuralCannotCreateCustomConnection | Could not create a custom connection.
StructuralCustomConnectionComponentsRelationship | Cannot create custom connection due to relationships to external elements.
StructuralCustomConnectionEmpty | Structural Custom Connection cannot be empty.
StructuralCustomConnectionWrongType | Structural Custom Connection has an inappropriate type assigned.

See Also

BuiltInFailures..::..StructuralCustomConnectionFailures Class


BuiltInFailures.StructuralCustomConnectionFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..StructuralCustomConnectionFailures Properties
BuiltInFailures..::..StructuralCustomConnectionFailures Class See Also Send Feedback

The BuiltInFailures..::..StructuralCustomConnectionFailures type exposes the following members.

Properties

Name | Description
SimpleConnectionTooFarRefs | Simple Structural Connection Handler cannot connect too far elements
StructuralCannotCreateCustomConnection | Could not create a custom connection.
StructuralCustomConnectionComponentsRelationship | Cannot create custom connection due to relationships to external elements.
StructuralCustomConnectionEmpty | Structural Custom Connection cannot be empty.
StructuralCustomConnectionWrongType | Structural Custom Connection has an inappropriate type assigned.

See Also

BuiltInFailures..::..StructuralCustomConnectionFailures Class


StructuralCannotCreateCustomConnection Property

[image]

Revit 2024 API
BuiltInFailures..::..StructuralCustomConnectionFailures..::..StructuralCannotCreateCustomConnection Property
BuiltInFailures..::..StructuralCustomConnectionFailures Class See Also Send Feedback
Could not create a custom connection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StructuralCannotCreateCustomConnection { get; }
Visual Basic
Public Shared ReadOnly Property StructuralCannotCreateCustomConnection As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StructuralCannotCreateCustomConnection {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StructuralCustomConnectionFailures Class


StructuralCustomConnectionComponentsRelationship Property

[image]

Revit 2024 API
BuiltInFailures..::..StructuralCustomConnectionFailures..::..StructuralCustomConnectionComponentsRelationship Property
BuiltInFailures..::..StructuralCustomConnectionFailures Class See Also Send Feedback
Cannot create custom connection due to relationships to external elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StructuralCustomConnectionComponentsRelationship { get; }
Visual Basic
Public Shared ReadOnly Property StructuralCustomConnectionComponentsRelationship As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StructuralCustomConnectionComponentsRelationship {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StructuralCustomConnectionFailures Class


StructuralCustomConnectionEmpty Property

[image]

Revit 2024 API
BuiltInFailures..::..StructuralCustomConnectionFailures..::..StructuralCustomConnectionEmpty Property
BuiltInFailures..::..StructuralCustomConnectionFailures Class See Also Send Feedback
Structural Custom Connection cannot be empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StructuralCustomConnectionEmpty { get; }
Visual Basic
Public Shared ReadOnly Property StructuralCustomConnectionEmpty As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StructuralCustomConnectionEmpty {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StructuralCustomConnectionFailures Class


StructuralCustomConnectionWrongType Property

[image]

Revit 2024 API
BuiltInFailures..::..StructuralCustomConnectionFailures..::..StructuralCustomConnectionWrongType Property
BuiltInFailures..::..StructuralCustomConnectionFailures Class See Also Send Feedback
Structural Custom Connection has an inappropriate type assigned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StructuralCustomConnectionWrongType { get; }
Visual Basic
Public Shared ReadOnly Property StructuralCustomConnectionWrongType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StructuralCustomConnectionWrongType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StructuralCustomConnectionFailures Class


BuiltInFailures.StructuralLoadFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..StructuralLoadFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Load.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class StructuralLoadFailures
Visual Basic
Public NotInheritable Class StructuralLoadFailures
Visual C++
public ref class StructuralLoadFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..StructuralLoadFailures

See Also

BuiltInFailures..::..StructuralLoadFailures Members


BuiltInFailures.StructuralLoadFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..StructuralLoadFailures Members
BuiltInFailures..::..StructuralLoadFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..StructuralLoadFailures type exposes the following members.

Properties

Name | Description
CannotMirrorBoundaryCondition | Can't mirror Boundary Conditions
CannotMoveBoundaryCondition | Can't move Boundary Conditions
CannotPlaceBoundaryConditions | A boundary condition is already created on the selected element. Duplicate boundary conditions are not allowed. Click the Replace button to delete previous definition of boundary condition or cancel the operation.
HostChangeDisallowsLoadOrBoundaryConditions | Some Hosted Loads or BoundaryConditions lost their References. They will be deleted.

See Also

BuiltInFailures..::..StructuralLoadFailures Class


CannotMirrorBoundaryCondition Property

[image]

Revit 2024 API
BuiltInFailures..::..StructuralLoadFailures..::..CannotMirrorBoundaryCondition Property
BuiltInFailures..::..StructuralLoadFailures Class See Also Send Feedback
Can't mirror Boundary Conditions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotMirrorBoundaryCondition { get; }
Visual Basic
Public Shared ReadOnly Property CannotMirrorBoundaryCondition As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMirrorBoundaryCondition {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StructuralLoadFailures Class


CannotMoveBoundaryCondition Property

[image]

Revit 2024 API
BuiltInFailures..::..StructuralLoadFailures..::..CannotMoveBoundaryCondition Property
BuiltInFailures..::..StructuralLoadFailures Class See Also Send Feedback
Can't move Boundary Conditions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotMoveBoundaryCondition { get; }
Visual Basic
Public Shared ReadOnly Property CannotMoveBoundaryCondition As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMoveBoundaryCondition {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StructuralLoadFailures Class


CannotPlaceBoundaryConditions Property

[image]

Revit 2024 API
BuiltInFailures..::..StructuralLoadFailures..::..CannotPlaceBoundaryConditions Property
BuiltInFailures..::..StructuralLoadFailures Class See Also Send Feedback
A boundary condition is already created on the selected element. Duplicate boundary conditions are not allowed. Click the Replace button to delete previous definition of boundary condition or cancel the operation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotPlaceBoundaryConditions { get; }
Visual Basic
Public Shared ReadOnly Property CannotPlaceBoundaryConditions As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPlaceBoundaryConditions {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StructuralLoadFailures Class


HostChangeDisallowsLoadOrBoundaryConditions Property

[image]

Revit 2024 API
BuiltInFailures..::..StructuralLoadFailures..::..HostChangeDisallowsLoadOrBoundaryConditions Property
BuiltInFailures..::..StructuralLoadFailures Class See Also Send Feedback
Some Hosted Loads or BoundaryConditions lost their References. They will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId HostChangeDisallowsLoadOrBoundaryConditions { get; }
Visual Basic
Public Shared ReadOnly Property HostChangeDisallowsLoadOrBoundaryConditions As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HostChangeDisallowsLoadOrBoundaryConditions {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StructuralLoadFailures Class


BuiltInFailures.SubRegionFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..SubRegionFailures Members
BuiltInFailures..::..SubRegionFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..SubRegionFailures type exposes the following members.

Properties

Name | Description
CreateSubRegionFailed | Create sub-division failed.
NoHostForToposolidSubregion | This sub-division now does not appear to overlap any Toposolid with an appropriate Phase and Design Option.
SubDivisionPhaseMismatch | Sub-division must have the same Phase Created parameter and Phase Demolished parameter as the host Toposolid. Sub-division phase will be set to match the Toposolid.

See Also

BuiltInFailures..::..SubRegionFailures Class


BuiltInFailures.SubRegionFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..SubRegionFailures Properties
BuiltInFailures..::..SubRegionFailures Class See Also Send Feedback

The BuiltInFailures..::..SubRegionFailures type exposes the following members.

Properties

Name | Description
CreateSubRegionFailed | Create sub-division failed.
NoHostForToposolidSubregion | This sub-division now does not appear to overlap any Toposolid with an appropriate Phase and Design Option.
SubDivisionPhaseMismatch | Sub-division must have the same Phase Created parameter and Phase Demolished parameter as the host Toposolid. Sub-division phase will be set to match the Toposolid.

See Also

BuiltInFailures..::..SubRegionFailures Class


CreateSubRegionFailed Property

[image]

Revit 2024 API
BuiltInFailures..::..SubRegionFailures..::..CreateSubRegionFailed Property
BuiltInFailures..::..SubRegionFailures Class See Also Send Feedback
Create sub-division failed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CreateSubRegionFailed { get; }
Visual Basic
Public Shared ReadOnly Property CreateSubRegionFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CreateSubRegionFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SubRegionFailures Class


NoHostForToposolidSubregion Property

[image]

Revit 2024 API
BuiltInFailures..::..SubRegionFailures..::..NoHostForToposolidSubregion Property
BuiltInFailures..::..SubRegionFailures Class See Also Send Feedback
This sub-division now does not appear to overlap any Toposolid with an appropriate Phase and Design Option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoHostForToposolidSubregion { get; }
Visual Basic
Public Shared ReadOnly Property NoHostForToposolidSubregion As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoHostForToposolidSubregion {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SubRegionFailures Class


BuiltInFailures.SweepFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..SweepFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Sweep.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class SweepFailures
Visual Basic
Public NotInheritable Class SweepFailures
Visual C++
public ref class SweepFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..SweepFailures

See Also

BuiltInFailures..::..SweepFailures Members


BuiltInFailures.SweepFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..SweepFailures Members
BuiltInFailures..::..SweepFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..SweepFailures type exposes the following members.

Properties

Name | Description
CannotDrawSweep | Can't create sweep.
ComplexPathWithComplexProfile | Sweep cannot have a path with ellipse or spline segments and a profile with non-straight lines.
ProfileLoopEmpty | Profile sketch is empty!
SweepFailed | Proper sweep geometry creation failed.
SweepFailedError | Proper sweep geometry creation failed.
WallSweepInconsistent | The model contains corrupt elements. Delete the corrupt elements to proceed or cancel the action without deleting the elements.

See Also

BuiltInFailures..::..SweepFailures Class


BuiltInFailures.SweepFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..SweepFailures Properties
BuiltInFailures..::..SweepFailures Class See Also Send Feedback

The BuiltInFailures..::..SweepFailures type exposes the following members.

Properties

Name | Description
CannotDrawSweep | Can't create sweep.
ComplexPathWithComplexProfile | Sweep cannot have a path with ellipse or spline segments and a profile with non-straight lines.
ProfileLoopEmpty | Profile sketch is empty!
SweepFailed | Proper sweep geometry creation failed.
SweepFailedError | Proper sweep geometry creation failed.
WallSweepInconsistent | The model contains corrupt elements. Delete the corrupt elements to proceed or cancel the action without deleting the elements.

See Also

BuiltInFailures..::..SweepFailures Class


CannotDrawSweep Property

[image]

Revit 2024 API
BuiltInFailures..::..SweepFailures..::..CannotDrawSweep Property
BuiltInFailures..::..SweepFailures Class See Also Send Feedback
Can't create sweep.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotDrawSweep { get; }
Visual Basic
Public Shared ReadOnly Property CannotDrawSweep As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDrawSweep {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SweepFailures Class


ComplexPathWithComplexProfile Property

[image]

Revit 2024 API
BuiltInFailures..::..SweepFailures..::..ComplexPathWithComplexProfile Property
BuiltInFailures..::..SweepFailures Class See Also Send Feedback
Sweep cannot have a path with ellipse or spline segments and a profile with non-straight lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ComplexPathWithComplexProfile { get; }
Visual Basic
Public Shared ReadOnly Property ComplexPathWithComplexProfile As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ComplexPathWithComplexProfile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SweepFailures Class


ProfileLoopEmpty Property

[image]

Revit 2024 API
BuiltInFailures..::..SweepFailures..::..ProfileLoopEmpty Property
BuiltInFailures..::..SweepFailures Class See Also Send Feedback
Profile sketch is empty!

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ProfileLoopEmpty { get; }
Visual Basic
Public Shared ReadOnly Property ProfileLoopEmpty As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ProfileLoopEmpty {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SweepFailures Class


SweepFailed Property

[image]

Revit 2024 API
BuiltInFailures..::..SweepFailures..::..SweepFailed Property
BuiltInFailures..::..SweepFailures Class See Also Send Feedback
Proper sweep geometry creation failed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SweepFailed { get; }
Visual Basic
Public Shared ReadOnly Property SweepFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SweepFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SweepFailures Class


SweepFailedError Property

[image]

Revit 2024 API
BuiltInFailures..::..SweepFailures..::..SweepFailedError Property
BuiltInFailures..::..SweepFailures Class See Also Send Feedback
Proper sweep geometry creation failed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SweepFailedError { get; }
Visual Basic
Public Shared ReadOnly Property SweepFailedError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SweepFailedError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SweepFailures Class


WallSweepInconsistent Property

[image]

Revit 2024 API
BuiltInFailures..::..SweepFailures..::..WallSweepInconsistent Property
BuiltInFailures..::..SweepFailures Class See Also Send Feedback
The model contains corrupt elements. Delete the corrupt elements to proceed or cancel the action without deleting the elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WallSweepInconsistent { get; }
Visual Basic
Public Shared ReadOnly Property WallSweepInconsistent As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WallSweepInconsistent {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SweepFailures Class


BuiltInFailures.SweptBlendFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..SweptBlendFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about SweptBlend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class SweptBlendFailures
Visual Basic
Public NotInheritable Class SweptBlendFailures
Visual C++
public ref class SweptBlendFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..SweptBlendFailures

See Also

BuiltInFailures..::..SweptBlendFailures Members


BuiltInFailures.SweptBlendFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..SweptBlendFailures Members
BuiltInFailures..::..SweptBlendFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..SweptBlendFailures type exposes the following members.

Properties

Name | Description
CannotDrawSweptblend | Can't create swept blend.

See Also

BuiltInFailures..::..SweptBlendFailures Class


BuiltInFailures.SweptBlendFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..SweptBlendFailures Properties
BuiltInFailures..::..SweptBlendFailures Class See Also Send Feedback

The BuiltInFailures..::..SweptBlendFailures type exposes the following members.

Properties

Name | Description
CannotDrawSweptblend | Can't create swept blend.

See Also

BuiltInFailures..::..SweptBlendFailures Class


BuiltInFailures.SystemNavigatorFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..SystemNavigatorFailures Members
BuiltInFailures..::..SystemNavigatorFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..SystemNavigatorFailures type exposes the following members.

Properties

Name | Description
CannottFindCorrectTreeNode | Can't find the correct tree node in system browser according to the node index.
MultipleSelectNumberIsWrong | The selected tree nodes number of system browser is wrong.

See Also

BuiltInFailures..::..SystemNavigatorFailures Class


BuiltInFailures.SystemNavigatorFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..SystemNavigatorFailures Properties
BuiltInFailures..::..SystemNavigatorFailures Class See Also Send Feedback

The BuiltInFailures..::..SystemNavigatorFailures type exposes the following members.

Properties

Name | Description
CannottFindCorrectTreeNode | Can't find the correct tree node in system browser according to the node index.
MultipleSelectNumberIsWrong | The selected tree nodes number of system browser is wrong.

See Also

BuiltInFailures..::..SystemNavigatorFailures Class


MultipleSelectNumberIsWrong Property

[image]

Revit 2024 API
BuiltInFailures..::..SystemNavigatorFailures..::..MultipleSelectNumberIsWrong Property
BuiltInFailures..::..SystemNavigatorFailures Class See Also Send Feedback
The selected tree nodes number of system browser is wrong.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MultipleSelectNumberIsWrong { get; }
Visual Basic
Public Shared ReadOnly Property MultipleSelectNumberIsWrong As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MultipleSelectNumberIsWrong {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SystemNavigatorFailures Class


BuiltInFailures.SystemsFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..SystemsFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about System.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class SystemsFailures
Visual Basic
Public NotInheritable Class SystemsFailures
Visual C++
public ref class SystemsFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..SystemsFailures

See Also

BuiltInFailures..::..SystemsFailures Members


BuiltInFailures.SystemsFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..SystemsFailures Members
BuiltInFailures..::..SystemsFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..SystemsFailures type exposes the following members.

Properties

Name | Description
AddingOtherConnectedMembersToSystem | "You have selected elements that are connected to other elements. These elements will also be added to the System."
CircuitWorksetClosedWarning | The workset of the circuit is closed so the circuit path will not be displayed.
CreatePartsWithInvalidService | Parts were not created because a system's service is undefined.
CreatePartsWithInvalidSystem | Parts were not created because the element does not have a valid system.
CreatePartsWithoutDabasebase | Parts were not created because fabrication configuration is not available.
DefaultSystemOver50Elems | The default system "[Element Name]" is now over 50 elements. To improve performance, Revit is no longer calculating the critical path pressure drop and the more complex duct sizing has been disabled. If you want to use these features, you must define logical systems in the model instead of using the default system.
ElementsBelongToOtherSystem | You have selected elements that are already part of other Systems that have assigned Equipment. The elements you selected cannot be added to this System.
FamilyDoesntMatchSystemProperties | The family no longer matches the properties for the System. Disconnect the family from the System?
FamilyDoesntMatchSystemPropertiesWasDisconnected | The family no longer matches the properties for the System. Disconnect the family from the System?
MismatchSystemType | Cannot add [Element] to System. The System Type for the available connector does not match the System Type ([Type Name]) for the System.
PastePartsWithInvalidService | Parts were not pasted because fabrication configuration is not available or service is not valid in the type properties for the system.
SelectedElementsArePartOfOtherSystem | You have selected elements that are already part of other System. They will be removed from the original Systems and added to this one.

See Also

BuiltInFailures..::..SystemsFailures Class


BuiltInFailures.SystemsFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..SystemsFailures Properties
BuiltInFailures..::..SystemsFailures Class See Also Send Feedback

The BuiltInFailures..::..SystemsFailures type exposes the following members.

Properties

Name | Description
AddingOtherConnectedMembersToSystem | "You have selected elements that are connected to other elements. These elements will also be added to the System."
CircuitWorksetClosedWarning | The workset of the circuit is closed so the circuit path will not be displayed.
CreatePartsWithInvalidService | Parts were not created because a system's service is undefined.
CreatePartsWithInvalidSystem | Parts were not created because the element does not have a valid system.
CreatePartsWithoutDabasebase | Parts were not created because fabrication configuration is not available.
DefaultSystemOver50Elems | The default system "[Element Name]" is now over 50 elements. To improve performance, Revit is no longer calculating the critical path pressure drop and the more complex duct sizing has been disabled. If you want to use these features, you must define logical systems in the model instead of using the default system.
ElementsBelongToOtherSystem | You have selected elements that are already part of other Systems that have assigned Equipment. The elements you selected cannot be added to this System.
FamilyDoesntMatchSystemProperties | The family no longer matches the properties for the System. Disconnect the family from the System?
FamilyDoesntMatchSystemPropertiesWasDisconnected | The family no longer matches the properties for the System. Disconnect the family from the System?
MismatchSystemType | Cannot add [Element] to System. The System Type for the available connector does not match the System Type ([Type Name]) for the System.
PastePartsWithInvalidService | Parts were not pasted because fabrication configuration is not available or service is not valid in the type properties for the system.
SelectedElementsArePartOfOtherSystem | You have selected elements that are already part of other System. They will be removed from the original Systems and added to this one.

See Also

BuiltInFailures..::..SystemsFailures Class


AddingOtherConnectedMembersToSystem Property

[image]

Revit 2024 API
BuiltInFailures..::..SystemsFailures..::..AddingOtherConnectedMembersToSystem Property
BuiltInFailures..::..SystemsFailures Class See Also Send Feedback
"You have selected elements that are connected to other elements. These elements will also be added to the System."

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId AddingOtherConnectedMembersToSystem { get; }
Visual Basic
Public Shared ReadOnly Property AddingOtherConnectedMembersToSystem As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AddingOtherConnectedMembersToSystem {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SystemsFailures Class


CircuitWorksetClosedWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..SystemsFailures..::..CircuitWorksetClosedWarning Property
BuiltInFailures..::..SystemsFailures Class See Also Send Feedback
The workset of the circuit is closed so the circuit path will not be displayed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CircuitWorksetClosedWarning { get; }
Visual Basic
Public Shared ReadOnly Property CircuitWorksetClosedWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CircuitWorksetClosedWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SystemsFailures Class


CreatePartsWithInvalidService Property

[image]

Revit 2024 API
BuiltInFailures..::..SystemsFailures..::..CreatePartsWithInvalidService Property
BuiltInFailures..::..SystemsFailures Class See Also Send Feedback
Parts were not created because a system's service is undefined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CreatePartsWithInvalidService { get; }
Visual Basic
Public Shared ReadOnly Property CreatePartsWithInvalidService As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CreatePartsWithInvalidService {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SystemsFailures Class


CreatePartsWithInvalidSystem Property

[image]

Revit 2024 API
BuiltInFailures..::..SystemsFailures..::..CreatePartsWithInvalidSystem Property
BuiltInFailures..::..SystemsFailures Class See Also Send Feedback
Parts were not created because the element does not have a valid system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CreatePartsWithInvalidSystem { get; }
Visual Basic
Public Shared ReadOnly Property CreatePartsWithInvalidSystem As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CreatePartsWithInvalidSystem {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SystemsFailures Class


CreatePartsWithoutDabasebase Property

[image]

Revit 2024 API
BuiltInFailures..::..SystemsFailures..::..CreatePartsWithoutDabasebase Property
BuiltInFailures..::..SystemsFailures Class See Also Send Feedback
Parts were not created because fabrication configuration is not available.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CreatePartsWithoutDabasebase { get; }
Visual Basic
Public Shared ReadOnly Property CreatePartsWithoutDabasebase As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CreatePartsWithoutDabasebase {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SystemsFailures Class


DefaultSystemOver50Elems Property

[image]

Revit 2024 API
BuiltInFailures..::..SystemsFailures..::..DefaultSystemOver50Elems Property
BuiltInFailures..::..SystemsFailures Class See Also Send Feedback
The default system "[Element Name]" is now over 50 elements. To improve performance, Revit is no longer calculating the critical path pressure drop and the more complex duct sizing has been disabled. If you want to use these features, you must define logical systems in the model instead of using the default system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DefaultSystemOver50Elems { get; }
Visual Basic
Public Shared ReadOnly Property DefaultSystemOver50Elems As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DefaultSystemOver50Elems {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SystemsFailures Class


FamilyDoesntMatchSystemProperties Property

[image]

Revit 2024 API
BuiltInFailures..::..SystemsFailures..::..FamilyDoesntMatchSystemProperties Property
BuiltInFailures..::..SystemsFailures Class See Also Send Feedback
The family no longer matches the properties for the System. Disconnect the family from the System?

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FamilyDoesntMatchSystemProperties { get; }
Visual Basic
Public Shared ReadOnly Property FamilyDoesntMatchSystemProperties As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FamilyDoesntMatchSystemProperties {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SystemsFailures Class


FamilyDoesntMatchSystemPropertiesWasDisconnected Property

[image]

Revit 2024 API
BuiltInFailures..::..SystemsFailures..::..FamilyDoesntMatchSystemPropertiesWasDisconnected Property
BuiltInFailures..::..SystemsFailures Class See Also Send Feedback
The family no longer matches the properties for the System. Disconnect the family from the System?

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FamilyDoesntMatchSystemPropertiesWasDisconnected { get; }
Visual Basic
Public Shared ReadOnly Property FamilyDoesntMatchSystemPropertiesWasDisconnected As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FamilyDoesntMatchSystemPropertiesWasDisconnected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SystemsFailures Class


MismatchSystemType Property

[image]

Revit 2024 API
BuiltInFailures..::..SystemsFailures..::..MismatchSystemType Property
BuiltInFailures..::..SystemsFailures Class See Also Send Feedback
Cannot add [Element] to System. The System Type for the available connector does not match the System Type ([Type Name]) for the System.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MismatchSystemType { get; }
Visual Basic
Public Shared ReadOnly Property MismatchSystemType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MismatchSystemType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SystemsFailures Class


PastePartsWithInvalidService Property

[image]

Revit 2024 API
BuiltInFailures..::..SystemsFailures..::..PastePartsWithInvalidService Property
BuiltInFailures..::..SystemsFailures Class See Also Send Feedback
Parts were not pasted because fabrication configuration is not available or service is not valid in the type properties for the system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId PastePartsWithInvalidService { get; }
Visual Basic
Public Shared ReadOnly Property PastePartsWithInvalidService As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PastePartsWithInvalidService {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SystemsFailures Class


SelectedElementsArePartOfOtherSystem Property

[image]

Revit 2024 API
BuiltInFailures..::..SystemsFailures..::..SelectedElementsArePartOfOtherSystem Property
BuiltInFailures..::..SystemsFailures Class See Also Send Feedback
You have selected elements that are already part of other System. They will be removed from the original Systems and added to this one.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SelectedElementsArePartOfOtherSystem { get; }
Visual Basic
Public Shared ReadOnly Property SelectedElementsArePartOfOtherSystem As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SelectedElementsArePartOfOtherSystem {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SystemsFailures Class


BuiltInFailures.TagFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..TagFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Tag.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class TagFailures
Visual Basic
Public NotInheritable Class TagFailures
Visual C++
public ref class TagFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..TagFailures

See Also

BuiltInFailures..::..TagFailures Members


BuiltInFailures.TagFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..TagFailures Members
BuiltInFailures..::..TagFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..TagFailures type exposes the following members.

Properties

Name | Description
CannotCopyTag | A tag cannot be arrayed without copying the associated element.
CannotCopyTagWarn | A tag cannot be arrayed without copying the associated element.
CannotPasteAssociate | Can't find new associated element. Element won't be copied.
CannotPasteOrphanTags | Orphaned tags cannot be pasted.
CannotPasteOrphanTagsWarn | Orphaned tags cannot be pasted.
CannotPasteTag | Can't find new element to tag. Tag won't be copied.
CannotRemapTagReference | The tag reference was not remapped.
ElementCategoryChangeInvalidatesTag | Elements have changed category. Tags for these elements are now of the wrong category and will be deleted.
ElementCategoryChangeInvalidatesTagUpgrade | During upgrade, Revit discovered that the highlighted elements were marked with tags of the wrong category. These tags were deleted.
MultiCategoryTagFilterParamNotFoundInElement | The filter specified by Multi-Category Tag can't be used with the tagged object.
RemoveTagWithNoLeaders | The Tag was deleted because it was no longer pointing to any elements.
TagsCannotBePlacedInUnlocked3dViews | Tags can't be pasted into Unlocked 3D views.

See Also

BuiltInFailures..::..TagFailures Class


BuiltInFailures.TagFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..TagFailures Properties
BuiltInFailures..::..TagFailures Class See Also Send Feedback

The BuiltInFailures..::..TagFailures type exposes the following members.

Properties

Name | Description
CannotCopyTag | A tag cannot be arrayed without copying the associated element.
CannotCopyTagWarn | A tag cannot be arrayed without copying the associated element.
CannotPasteAssociate | Can't find new associated element. Element won't be copied.
CannotPasteOrphanTags | Orphaned tags cannot be pasted.
CannotPasteOrphanTagsWarn | Orphaned tags cannot be pasted.
CannotPasteTag | Can't find new element to tag. Tag won't be copied.
CannotRemapTagReference | The tag reference was not remapped.
ElementCategoryChangeInvalidatesTag | Elements have changed category. Tags for these elements are now of the wrong category and will be deleted.
ElementCategoryChangeInvalidatesTagUpgrade | During upgrade, Revit discovered that the highlighted elements were marked with tags of the wrong category. These tags were deleted.
MultiCategoryTagFilterParamNotFoundInElement | The filter specified by Multi-Category Tag can't be used with the tagged object.
RemoveTagWithNoLeaders | The Tag was deleted because it was no longer pointing to any elements.
TagsCannotBePlacedInUnlocked3dViews | Tags can't be pasted into Unlocked 3D views.

See Also

BuiltInFailures..::..TagFailures Class


CannotCopyTag Property

[image]

Revit 2024 API
BuiltInFailures..::..TagFailures..::..CannotCopyTag Property
BuiltInFailures..::..TagFailures Class See Also Send Feedback
A tag cannot be arrayed without copying the associated element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCopyTag { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyTag As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyTag {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..TagFailures Class


CannotCopyTagWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..TagFailures..::..CannotCopyTagWarn Property
BuiltInFailures..::..TagFailures Class See Also Send Feedback
A tag cannot be arrayed without copying the associated element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCopyTagWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyTagWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyTagWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..TagFailures Class


CannotPasteAssociate Property

[image]

Revit 2024 API
BuiltInFailures..::..TagFailures..::..CannotPasteAssociate Property
BuiltInFailures..::..TagFailures Class See Also Send Feedback
Can't find new associated element. Element won't be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotPasteAssociate { get; }
Visual Basic
Public Shared ReadOnly Property CannotPasteAssociate As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPasteAssociate {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..TagFailures Class


CannotPasteOrphanTags Property

[image]

Revit 2024 API
BuiltInFailures..::..TagFailures..::..CannotPasteOrphanTags Property
BuiltInFailures..::..TagFailures Class See Also Send Feedback
Orphaned tags cannot be pasted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotPasteOrphanTags { get; }
Visual Basic
Public Shared ReadOnly Property CannotPasteOrphanTags As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPasteOrphanTags {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..TagFailures Class


CannotPasteOrphanTagsWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..TagFailures..::..CannotPasteOrphanTagsWarn Property
BuiltInFailures..::..TagFailures Class See Also Send Feedback
Orphaned tags cannot be pasted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotPasteOrphanTagsWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotPasteOrphanTagsWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPasteOrphanTagsWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..TagFailures Class


CannotRemapTagReference Property

[image]

Revit 2024 API
BuiltInFailures..::..TagFailures..::..CannotRemapTagReference Property
BuiltInFailures..::..TagFailures Class See Also Send Feedback
The tag reference was not remapped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotRemapTagReference { get; }
Visual Basic
Public Shared ReadOnly Property CannotRemapTagReference As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotRemapTagReference {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..TagFailures Class


ElementCategoryChangeInvalidatesTag Property

[image]

Revit 2024 API
BuiltInFailures..::..TagFailures..::..ElementCategoryChangeInvalidatesTag Property
BuiltInFailures..::..TagFailures Class See Also Send Feedback
Elements have changed category. Tags for these elements are now of the wrong category and will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ElementCategoryChangeInvalidatesTag { get; }
Visual Basic
Public Shared ReadOnly Property ElementCategoryChangeInvalidatesTag As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementCategoryChangeInvalidatesTag {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..TagFailures Class


MultiCategoryTagFilterParamNotFoundInElement Property

[image]

Revit 2024 API
BuiltInFailures..::..TagFailures..::..MultiCategoryTagFilterParamNotFoundInElement Property
BuiltInFailures..::..TagFailures Class See Also Send Feedback
The filter specified by Multi-Category Tag can't be used with the tagged object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MultiCategoryTagFilterParamNotFoundInElement { get; }
Visual Basic
Public Shared ReadOnly Property MultiCategoryTagFilterParamNotFoundInElement As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MultiCategoryTagFilterParamNotFoundInElement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..TagFailures Class


RemoveTagWithNoLeaders Property

[image]

Revit 2024 API
BuiltInFailures..::..TagFailures..::..RemoveTagWithNoLeaders Property
BuiltInFailures..::..TagFailures Class See Also Send Feedback
The Tag was deleted because it was no longer pointing to any elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RemoveTagWithNoLeaders { get; }
Visual Basic
Public Shared ReadOnly Property RemoveTagWithNoLeaders As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RemoveTagWithNoLeaders {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..TagFailures Class


TagsCannotBePlacedInUnlocked3dViews Property

[image]

Revit 2024 API
BuiltInFailures..::..TagFailures..::..TagsCannotBePlacedInUnlocked3dViews Property
BuiltInFailures..::..TagFailures Class See Also Send Feedback
Tags can't be pasted into Unlocked 3D views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId TagsCannotBePlacedInUnlocked3dViews { get; }
Visual Basic
Public Shared ReadOnly Property TagsCannotBePlacedInUnlocked3dViews As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TagsCannotBePlacedInUnlocked3dViews {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..TagFailures Class


BuiltInFailures.TextFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..TextFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class TextFailures
Visual Basic
Public NotInheritable Class TextFailures
Visual C++
public ref class TextFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..TextFailures

See Also

BuiltInFailures..::..TextFailures Members


BuiltInFailures.TextFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..TextFailures Properties
BuiltInFailures..::..TextFailures Class See Also Send Feedback

The BuiltInFailures..::..TextFailures type exposes the following members.

Properties

Name | Description
CannotCreateModeltext | Can't create Model Text.
ModeltextIsEmpty | Model Text deleted because it consists entirely of spaces and/or carriage returns.

See Also

BuiltInFailures..::..TextFailures Class


CannotCreateModeltext Property

[image]

Revit 2024 API
BuiltInFailures..::..TextFailures..::..CannotCreateModeltext Property
BuiltInFailures..::..TextFailures Class See Also Send Feedback
Can't create Model Text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotCreateModeltext { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateModeltext As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateModeltext {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..TextFailures Class


ModeltextIsEmpty Property

[image]

Revit 2024 API
BuiltInFailures..::..TextFailures..::..ModeltextIsEmpty Property
BuiltInFailures..::..TextFailures Class See Also Send Feedback
Model Text deleted because it consists entirely of spaces and/or carriage returns.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ModeltextIsEmpty { get; }
Visual Basic
Public Shared ReadOnly Property ModeltextIsEmpty As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ModeltextIsEmpty {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..TextFailures Class


BuiltInFailures.TilePatternTileFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..TilePatternTileFailures Properties
BuiltInFailures..::..TilePatternTileFailures Class See Also Send Feedback

The BuiltInFailures..::..TilePatternTileFailures type exposes the following members.

Properties

Name | Description
TilePatternTile_InvalidFamily | Family not appropriate for Divided Surface component.

See Also

BuiltInFailures..::..TilePatternTileFailures Class


TilePatternTile_InvalidFamily Property

[image]

Revit 2024 API
BuiltInFailures..::..TilePatternTileFailures..::..TilePatternTile_InvalidFamily Property
BuiltInFailures..::..TilePatternTileFailures Class See Also Send Feedback
Family not appropriate for Divided Surface component.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId TilePatternTile_InvalidFamily { get; }
Visual Basic
Public Shared ReadOnly Property TilePatternTile_InvalidFamily As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TilePatternTile_InvalidFamily {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..TilePatternTileFailures Class


BuiltInFailures.ToggleViewFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..ToggleViewFailures Members
BuiltInFailures..::..ToggleViewFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..ToggleViewFailures type exposes the following members.

Properties

Name | Description
LoseSavedOrientation | The stored orientation will be lost.

See Also

BuiltInFailures..::..ToggleViewFailures Class


BuiltInFailures.ToggleViewFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..ToggleViewFailures Properties
BuiltInFailures..::..ToggleViewFailures Class See Also Send Feedback

The BuiltInFailures..::..ToggleViewFailures type exposes the following members.

Properties

Name | Description
LoseSavedOrientation | The stored orientation will be lost.

See Also

BuiltInFailures..::..ToggleViewFailures Class


LoseSavedOrientation Property

[image]

Revit 2024 API
BuiltInFailures..::..ToggleViewFailures..::..LoseSavedOrientation Property
BuiltInFailures..::..ToggleViewFailures Class See Also Send Feedback
The stored orientation will be lost.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId LoseSavedOrientation { get; }
Visual Basic
Public Shared ReadOnly Property LoseSavedOrientation As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LoseSavedOrientation {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ToggleViewFailures Class


BuiltInFailures.TrussFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..TrussFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Truss.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class TrussFailures
Visual Basic
Public NotInheritable Class TrussFailures
Visual C++
public ref class TrussFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..TrussFailures

See Also

BuiltInFailures..::..TrussFailures Members


BuiltInFailures.TrussFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..TrussFailures Members
BuiltInFailures..::..TrussFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..TrussFailures type exposes the following members.

Properties

Name | Description
IncorrectWallUsageWithAttachedStruct | A structural framing element is attached to a wall whose Structural Usage is set to [Usage].
InvalidWorkplaneForStructuralFraming | Workplane not valid for Structural Framing component "[Family Name]"
RemoveTrussSketch | Remove Sketch
TrussBadTransformation | Revit cannot transform the truss Layout Family to the Truss as oriented in the project.
TrussChordUntransformable | Unable to maintain user changes to unpinned Chord. Restoring Truss-defined shape.
TrussDuplicateEngineeringType | Elements have duplicate 'Engineering Type' values.
TrussInvalidSymbolGeom | Truss is unable to generate any members due to layout family error.
TrussIsAttachedTo | Revit cannot attach to the chosen Roof/Slab. The truss cannot project to a surface or the attachment creates an invalid profile.
TrussLayoutNonSympleTopChord | This truss layout family defines an offset or non horizontal top chord. This may conflict with attachment or profile editing.
TrussLayoutOverlapedCurves | The current transformation of this specific truss layout will some sub members to overlap.
TrussNotJoinedWebs | The current edits are causing some webs to disjoin. The truss layout family requires additional constraints to maintain these joins.
TrussUserDefinedMemberDeleted | A user-defined structural member was deleted due to missing or deleted references.
TrussUserDefinedMemberNotJoined | Both start and end of web must intersect the truss.

See Also

BuiltInFailures..::..TrussFailures Class


BuiltInFailures.TrussFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..TrussFailures Properties
BuiltInFailures..::..TrussFailures Class See Also Send Feedback

The BuiltInFailures..::..TrussFailures type exposes the following members.

Properties

Name | Description
IncorrectWallUsageWithAttachedStruct | A structural framing element is attached to a wall whose Structural Usage is set to [Usage].
InvalidWorkplaneForStructuralFraming | Workplane not valid for Structural Framing component "[Family Name]"
RemoveTrussSketch | Remove Sketch
TrussBadTransformation | Revit cannot transform the truss Layout Family to the Truss as oriented in the project.
TrussChordUntransformable | Unable to maintain user changes to unpinned Chord. Restoring Truss-defined shape.
TrussDuplicateEngineeringType | Elements have duplicate 'Engineering Type' values.
TrussInvalidSymbolGeom | Truss is unable to generate any members due to layout family error.
TrussIsAttachedTo | Revit cannot attach to the chosen Roof/Slab. The truss cannot project to a surface or the attachment creates an invalid profile.
TrussLayoutNonSympleTopChord | This truss layout family defines an offset or non horizontal top chord. This may conflict with attachment or profile editing.
TrussLayoutOverlapedCurves | The current transformation of this specific truss layout will some sub members to overlap.
TrussNotJoinedWebs | The current edits are causing some webs to disjoin. The truss layout family requires additional constraints to maintain these joins.
TrussUserDefinedMemberDeleted | A user-defined structural member was deleted due to missing or deleted references.
TrussUserDefinedMemberNotJoined | Both start and end of web must intersect the truss.

See Also

BuiltInFailures..::..TrussFailures Class


InvalidWorkplaneForStructuralFraming Property

[image]

Revit 2024 API
BuiltInFailures..::..TrussFailures..::..InvalidWorkplaneForStructuralFraming Property
BuiltInFailures..::..TrussFailures Class See Also Send Feedback
Workplane not valid for Structural Framing component "[Family Name]"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidWorkplaneForStructuralFraming { get; }
Visual Basic
Public Shared ReadOnly Property InvalidWorkplaneForStructuralFraming As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidWorkplaneForStructuralFraming {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..TrussFailures Class


TrussBadTransformation Property

[image]

Revit 2024 API
BuiltInFailures..::..TrussFailures..::..TrussBadTransformation Property
BuiltInFailures..::..TrussFailures Class See Also Send Feedback
Revit cannot transform the truss Layout Family to the Truss as oriented in the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId TrussBadTransformation { get; }
Visual Basic
Public Shared ReadOnly Property TrussBadTransformation As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TrussBadTransformation {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..TrussFailures Class


TrussDuplicateEngineeringType Property

[image]

Revit 2024 API
BuiltInFailures..::..TrussFailures..::..TrussDuplicateEngineeringType Property
BuiltInFailures..::..TrussFailures Class See Also Send Feedback
Elements have duplicate 'Engineering Type' values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId TrussDuplicateEngineeringType { get; }
Visual Basic
Public Shared ReadOnly Property TrussDuplicateEngineeringType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TrussDuplicateEngineeringType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..TrussFailures Class


TrussInvalidSymbolGeom Property

[image]

Revit 2024 API
BuiltInFailures..::..TrussFailures..::..TrussInvalidSymbolGeom Property
BuiltInFailures..::..TrussFailures Class See Also Send Feedback
Truss is unable to generate any members due to layout family error.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId TrussInvalidSymbolGeom { get; }
Visual Basic
Public Shared ReadOnly Property TrussInvalidSymbolGeom As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TrussInvalidSymbolGeom {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..TrussFailures Class


TrussIsAttachedTo Property

[image]

Revit 2024 API
BuiltInFailures..::..TrussFailures..::..TrussIsAttachedTo Property
BuiltInFailures..::..TrussFailures Class See Also Send Feedback
Revit cannot attach to the chosen Roof/Slab. The truss cannot project to a surface or the attachment creates an invalid profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId TrussIsAttachedTo { get; }
Visual Basic
Public Shared ReadOnly Property TrussIsAttachedTo As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TrussIsAttachedTo {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..TrussFailures Class


TrussLayoutNonSympleTopChord Property

[image]

Revit 2024 API
BuiltInFailures..::..TrussFailures..::..TrussLayoutNonSympleTopChord Property
BuiltInFailures..::..TrussFailures Class See Also Send Feedback
This truss layout family defines an offset or non horizontal top chord. This may conflict with attachment or profile editing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId TrussLayoutNonSympleTopChord { get; }
Visual Basic
Public Shared ReadOnly Property TrussLayoutNonSympleTopChord As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TrussLayoutNonSympleTopChord {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..TrussFailures Class


TrussNotJoinedWebs Property

[image]

Revit 2024 API
BuiltInFailures..::..TrussFailures..::..TrussNotJoinedWebs Property
BuiltInFailures..::..TrussFailures Class See Also Send Feedback
The current edits are causing some webs to disjoin. The truss layout family requires additional constraints to maintain these joins.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId TrussNotJoinedWebs { get; }
Visual Basic
Public Shared ReadOnly Property TrussNotJoinedWebs As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TrussNotJoinedWebs {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..TrussFailures Class


TrussUserDefinedMemberDeleted Property

[image]

Revit 2024 API
BuiltInFailures..::..TrussFailures..::..TrussUserDefinedMemberDeleted Property
BuiltInFailures..::..TrussFailures Class See Also Send Feedback
A user-defined structural member was deleted due to missing or deleted references.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId TrussUserDefinedMemberDeleted { get; }
Visual Basic
Public Shared ReadOnly Property TrussUserDefinedMemberDeleted As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TrussUserDefinedMemberDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..TrussFailures Class


TrussUserDefinedMemberNotJoined Property

[image]

Revit 2024 API
BuiltInFailures..::..TrussFailures..::..TrussUserDefinedMemberNotJoined Property
BuiltInFailures..::..TrussFailures Class See Also Send Feedback
Both start and end of web must intersect the truss.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId TrussUserDefinedMemberNotJoined { get; }
Visual Basic
Public Shared ReadOnly Property TrussUserDefinedMemberNotJoined As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TrussUserDefinedMemberNotJoined {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..TrussFailures Class


BuiltInFailures.UniqueElementFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..UniqueElementFailures Class
BuiltInFailures Class Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class UniqueElementFailures
Visual Basic
Public NotInheritable Class UniqueElementFailures
Visual C++
public ref class UniqueElementFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..UniqueElementFailures

See Also

BuiltInFailures..::..UniqueElementFailures Members


BuiltInFailures.UniqueElementFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..UniqueElementFailures Members
BuiltInFailures..::..UniqueElementFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..UniqueElementFailures type exposes the following members.

Properties

Name | Description
ProhibitUniqueElementDeletion | Internal setting '%1!s!' is required by Revit and has been deleted.

See Also

BuiltInFailures..::..UniqueElementFailures Class


BuiltInFailures.UniqueElementFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..UniqueElementFailures Properties
BuiltInFailures..::..UniqueElementFailures Class See Also Send Feedback

The BuiltInFailures..::..UniqueElementFailures type exposes the following members.

Properties

Name | Description
ProhibitUniqueElementDeletion | Internal setting '%1!s!' is required by Revit and has been deleted.

See Also

BuiltInFailures..::..UniqueElementFailures Class


ProhibitUniqueElementDeletion Property

[image]

Revit 2024 API
BuiltInFailures..::..UniqueElementFailures..::..ProhibitUniqueElementDeletion Property
BuiltInFailures..::..UniqueElementFailures Class See Also Send Feedback
Internal setting '%1!s!' is required by Revit and has been deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ProhibitUniqueElementDeletion { get; }
Visual Basic
Public Shared ReadOnly Property ProhibitUniqueElementDeletion As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ProhibitUniqueElementDeletion {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..UniqueElementFailures Class


BuiltInFailures.ViewFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..ViewFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about ViewFailures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class ViewFailures
Visual Basic
Public NotInheritable Class ViewFailures
Visual C++
public ref class ViewFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..ViewFailures

See Also

BuiltInFailures..::..ViewFailures Members


BuiltInFailures.ViewFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..ViewFailures Members
BuiltInFailures..::..ViewFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..ViewFailures type exposes the following members.

Properties

Name | Description
BadViewDirectionSetting | Plan view DBViewType has invalid view direction parameter.
CanNotDeleteLastOpenView | Deleting of all open views in a project is not allowed.
CannotPasteViewReferences | Cannot paste view references into the view they reference or into unrelated views
CannotToggleToPerspective | Cannot toggle to perspective view because the view contains annotations.
DetailNumberDuplicate | Detail Number is already in use. Enter a unique number.
DetailNumberEmpty | Detail Number is empty
InitialViewDeleted | The starting view for the project has been deleted.
InsertColumnViewError | Column cannot be placed in Elevation or Section view
InsertColumnViewFailure | Column cannot be placed in Elevation or Section view
InsertComponentViewError | This type of Component cannot be placed in Elevation or Section view
InsertComponentViewFailure | This type of Component cannot be placed in Elevation or Section view
InvalidDBviewScopeBox | The scope box and view must have parallel vertical axes.
NoTargetsForDependentViewPropagation | There are no valid views. Only views without dependents can be used.
NothingToApplyError | Start and end elevations are the same, nothing to Apply.
NothingToApplyWarning | Start and end elevations are the same, nothing to Apply.
ReloadLatestDeletedLastOpenView | The only open view has been deleted because of changes from the Central Model. Open another view and Reload Latest or Synchronize with Central again.
TurnCropRegionOffRemovesViewBreaks | Turning off the Crop Region of the view will remove all View Breaks. If the Crop Region is turned on at a later time, any desired View Breaks must be created again.
ViewPublishFailed | The following views could not be published.
ZeroLengthViewBreaksRemoved | Some View Regions were consolidated. When the size of a View Break between View Regions becomes zero, the View Break is removed and the adjacent View Regions are joined.
ZeroLengthViewRegionsRemoved | Some View Regions were removed. When the size of a View Region becomes zero, it is removed from the view.

See Also

BuiltInFailures..::..ViewFailures Class


BuiltInFailures.ViewFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..ViewFailures Properties
BuiltInFailures..::..ViewFailures Class See Also Send Feedback

The BuiltInFailures..::..ViewFailures type exposes the following members.

Properties

Name | Description
BadViewDirectionSetting | Plan view DBViewType has invalid view direction parameter.
CanNotDeleteLastOpenView | Deleting of all open views in a project is not allowed.
CannotPasteViewReferences | Cannot paste view references into the view they reference or into unrelated views
CannotToggleToPerspective | Cannot toggle to perspective view because the view contains annotations.
DetailNumberDuplicate | Detail Number is already in use. Enter a unique number.
DetailNumberEmpty | Detail Number is empty
InitialViewDeleted | The starting view for the project has been deleted.
InsertColumnViewError | Column cannot be placed in Elevation or Section view
InsertColumnViewFailure | Column cannot be placed in Elevation or Section view
InsertComponentViewError | This type of Component cannot be placed in Elevation or Section view
InsertComponentViewFailure | This type of Component cannot be placed in Elevation or Section view
InvalidDBviewScopeBox | The scope box and view must have parallel vertical axes.
NoTargetsForDependentViewPropagation | There are no valid views. Only views without dependents can be used.
NothingToApplyError | Start and end elevations are the same, nothing to Apply.
NothingToApplyWarning | Start and end elevations are the same, nothing to Apply.
ReloadLatestDeletedLastOpenView | The only open view has been deleted because of changes from the Central Model. Open another view and Reload Latest or Synchronize with Central again.
TurnCropRegionOffRemovesViewBreaks | Turning off the Crop Region of the view will remove all View Breaks. If the Crop Region is turned on at a later time, any desired View Breaks must be created again.
ViewPublishFailed | The following views could not be published.
ZeroLengthViewBreaksRemoved | Some View Regions were consolidated. When the size of a View Break between View Regions becomes zero, the View Break is removed and the adjacent View Regions are joined.
ZeroLengthViewRegionsRemoved | Some View Regions were removed. When the size of a View Region becomes zero, it is removed from the view.

See Also

BuiltInFailures..::..ViewFailures Class


BadViewDirectionSetting Property

[image]

Revit 2024 API
BuiltInFailures..::..ViewFailures..::..BadViewDirectionSetting Property
BuiltInFailures..::..ViewFailures Class See Also Send Feedback
Plan view DBViewType has invalid view direction parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId BadViewDirectionSetting { get; }
Visual Basic
Public Shared ReadOnly Property BadViewDirectionSetting As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BadViewDirectionSetting {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ViewFailures Class


CanNotDeleteLastOpenView Property

[image]

Revit 2024 API
BuiltInFailures..::..ViewFailures..::..CanNotDeleteLastOpenView Property
BuiltInFailures..::..ViewFailures Class See Also Send Feedback
Deleting of all open views in a project is not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CanNotDeleteLastOpenView { get; }
Visual Basic
Public Shared ReadOnly Property CanNotDeleteLastOpenView As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CanNotDeleteLastOpenView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ViewFailures Class


CannotPasteViewReferences Property

[image]

Revit 2024 API
BuiltInFailures..::..ViewFailures..::..CannotPasteViewReferences Property
BuiltInFailures..::..ViewFailures Class See Also Send Feedback
Cannot paste view references into the view they reference or into unrelated views

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotPasteViewReferences { get; }
Visual Basic
Public Shared ReadOnly Property CannotPasteViewReferences As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPasteViewReferences {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ViewFailures Class


CannotToggleToPerspective Property

[image]

Revit 2024 API
BuiltInFailures..::..ViewFailures..::..CannotToggleToPerspective Property
BuiltInFailures..::..ViewFailures Class See Also Send Feedback
Cannot toggle to perspective view because the view contains annotations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotToggleToPerspective { get; }
Visual Basic
Public Shared ReadOnly Property CannotToggleToPerspective As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotToggleToPerspective {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ViewFailures Class


DetailNumberDuplicate Property

[image]

Revit 2024 API
BuiltInFailures..::..ViewFailures..::..DetailNumberDuplicate Property
BuiltInFailures..::..ViewFailures Class See Also Send Feedback
Detail Number is already in use. Enter a unique number.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DetailNumberDuplicate { get; }
Visual Basic
Public Shared ReadOnly Property DetailNumberDuplicate As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DetailNumberDuplicate {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ViewFailures Class


DetailNumberEmpty Property

[image]

Revit 2024 API
BuiltInFailures..::..ViewFailures..::..DetailNumberEmpty Property
BuiltInFailures..::..ViewFailures Class See Also Send Feedback
Detail Number is empty

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DetailNumberEmpty { get; }
Visual Basic
Public Shared ReadOnly Property DetailNumberEmpty As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DetailNumberEmpty {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ViewFailures Class


InitialViewDeleted Property

[image]

Revit 2024 API
BuiltInFailures..::..ViewFailures..::..InitialViewDeleted Property
BuiltInFailures..::..ViewFailures Class See Also Send Feedback
The starting view for the project has been deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InitialViewDeleted { get; }
Visual Basic
Public Shared ReadOnly Property InitialViewDeleted As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InitialViewDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ViewFailures Class


InsertColumnViewError Property

[image]

Revit 2024 API
BuiltInFailures..::..ViewFailures..::..InsertColumnViewError Property
BuiltInFailures..::..ViewFailures Class See Also Send Feedback
Column cannot be placed in Elevation or Section view

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InsertColumnViewError { get; }
Visual Basic
Public Shared ReadOnly Property InsertColumnViewError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InsertColumnViewError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ViewFailures Class


InsertComponentViewError Property

[image]

Revit 2024 API
BuiltInFailures..::..ViewFailures..::..InsertComponentViewError Property
BuiltInFailures..::..ViewFailures Class See Also Send Feedback
This type of Component cannot be placed in Elevation or Section view

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InsertComponentViewError { get; }
Visual Basic
Public Shared ReadOnly Property InsertComponentViewError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InsertComponentViewError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ViewFailures Class


InvalidDBviewScopeBox Property

[image]

Revit 2024 API
BuiltInFailures..::..ViewFailures..::..InvalidDBviewScopeBox Property
BuiltInFailures..::..ViewFailures Class See Also Send Feedback
The scope box and view must have parallel vertical axes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidDBviewScopeBox { get; }
Visual Basic
Public Shared ReadOnly Property InvalidDBviewScopeBox As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidDBviewScopeBox {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ViewFailures Class


NothingToApplyError Property

[image]

Revit 2024 API
BuiltInFailures..::..ViewFailures..::..NothingToApplyError Property
BuiltInFailures..::..ViewFailures Class See Also Send Feedback
Start and end elevations are the same, nothing to Apply.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NothingToApplyError { get; }
Visual Basic
Public Shared ReadOnly Property NothingToApplyError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NothingToApplyError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ViewFailures Class


NothingToApplyWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..ViewFailures..::..NothingToApplyWarning Property
BuiltInFailures..::..ViewFailures Class See Also Send Feedback
Start and end elevations are the same, nothing to Apply.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NothingToApplyWarning { get; }
Visual Basic
Public Shared ReadOnly Property NothingToApplyWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NothingToApplyWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ViewFailures Class


TurnCropRegionOffRemovesViewBreaks Property

[image]

Revit 2024 API
BuiltInFailures..::..ViewFailures..::..TurnCropRegionOffRemovesViewBreaks Property
BuiltInFailures..::..ViewFailures Class See Also Send Feedback
Turning off the Crop Region of the view will remove all View Breaks. If the Crop Region is turned on at a later time, any desired View Breaks must be created again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId TurnCropRegionOffRemovesViewBreaks { get; }
Visual Basic
Public Shared ReadOnly Property TurnCropRegionOffRemovesViewBreaks As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TurnCropRegionOffRemovesViewBreaks {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ViewFailures Class


ViewPublishFailed Property

[image]

Revit 2024 API
BuiltInFailures..::..ViewFailures..::..ViewPublishFailed Property
BuiltInFailures..::..ViewFailures Class See Also Send Feedback
The following views could not be published.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ViewPublishFailed { get; }
Visual Basic
Public Shared ReadOnly Property ViewPublishFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ViewPublishFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ViewFailures Class


ZeroLengthViewBreaksRemoved Property

[image]

Revit 2024 API
BuiltInFailures..::..ViewFailures..::..ZeroLengthViewBreaksRemoved Property
BuiltInFailures..::..ViewFailures Class See Also Send Feedback
Some View Regions were consolidated. When the size of a View Break between View Regions becomes zero, the View Break is removed and the adjacent View Regions are joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ZeroLengthViewBreaksRemoved { get; }
Visual Basic
Public Shared ReadOnly Property ZeroLengthViewBreaksRemoved As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ZeroLengthViewBreaksRemoved {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ViewFailures Class


BuiltInFailures.ViewSheetFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..ViewSheetFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about placing viewports on sheets.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class ViewSheetFailures
Visual Basic
Public NotInheritable Class ViewSheetFailures
Visual C++
public ref class ViewSheetFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..ViewSheetFailures

See Also

BuiltInFailures..::..ViewSheetFailures Members


BuiltInFailures.ViewSheetFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..ViewSheetFailures Members
BuiltInFailures..::..ViewSheetFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..ViewSheetFailures type exposes the following members.

Properties

Name | Description
ViewInAModelMustBeUnique | Sheet views in this model cannot contain more than one instance of "%1!s!."
ViewInAModelMustBeUniqueWarn | Sheet views in this model cannot contain more than one instance of "%1!s!."
ViewOnASheetCannotBeUncropped3DPerspectiveView | Sheets do not support uncropped perspective views.
ViewOnASheetMustBeUnique | Sheet views cannot contain more than one instance of "%1!s!."
ViewOnASheetMustBeUniqueWarn | Sheet views cannot contain more than one instance of "%1!s!."
ViewportCantContainEmptyView | Sheet views cannot contain empty view "%1!s!".

See Also

BuiltInFailures..::..ViewSheetFailures Class


BuiltInFailures.ViewSheetFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..ViewSheetFailures Properties
BuiltInFailures..::..ViewSheetFailures Class See Also Send Feedback

The BuiltInFailures..::..ViewSheetFailures type exposes the following members.

Properties

Name | Description
ViewInAModelMustBeUnique | Sheet views in this model cannot contain more than one instance of "%1!s!."
ViewInAModelMustBeUniqueWarn | Sheet views in this model cannot contain more than one instance of "%1!s!."
ViewOnASheetCannotBeUncropped3DPerspectiveView | Sheets do not support uncropped perspective views.
ViewOnASheetMustBeUnique | Sheet views cannot contain more than one instance of "%1!s!."
ViewOnASheetMustBeUniqueWarn | Sheet views cannot contain more than one instance of "%1!s!."
ViewportCantContainEmptyView | Sheet views cannot contain empty view "%1!s!".

See Also

BuiltInFailures..::..ViewSheetFailures Class


ViewInAModelMustBeUnique Property

[image]

Revit 2024 API
BuiltInFailures..::..ViewSheetFailures..::..ViewInAModelMustBeUnique Property
BuiltInFailures..::..ViewSheetFailures Class See Also Send Feedback
Sheet views in this model cannot contain more than one instance of "%1!s!."

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ViewInAModelMustBeUnique { get; }
Visual Basic
Public Shared ReadOnly Property ViewInAModelMustBeUnique As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ViewInAModelMustBeUnique {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ViewSheetFailures Class


ViewInAModelMustBeUniqueWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..ViewSheetFailures..::..ViewInAModelMustBeUniqueWarn Property
BuiltInFailures..::..ViewSheetFailures Class See Also Send Feedback
Sheet views in this model cannot contain more than one instance of "%1!s!."

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ViewInAModelMustBeUniqueWarn { get; }
Visual Basic
Public Shared ReadOnly Property ViewInAModelMustBeUniqueWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ViewInAModelMustBeUniqueWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ViewSheetFailures Class


ViewOnASheetCannotBeUncropped3DPerspectiveView Property

[image]

Revit 2024 API
BuiltInFailures..::..ViewSheetFailures..::..ViewOnASheetCannotBeUncropped3DPerspectiveView Property
BuiltInFailures..::..ViewSheetFailures Class See Also Send Feedback
Sheets do not support uncropped perspective views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ViewOnASheetCannotBeUncropped3DPerspectiveView { get; }
Visual Basic
Public Shared ReadOnly Property ViewOnASheetCannotBeUncropped3DPerspectiveView As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ViewOnASheetCannotBeUncropped3DPerspectiveView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ViewSheetFailures Class


ViewOnASheetMustBeUnique Property

[image]

Revit 2024 API
BuiltInFailures..::..ViewSheetFailures..::..ViewOnASheetMustBeUnique Property
BuiltInFailures..::..ViewSheetFailures Class See Also Send Feedback
Sheet views cannot contain more than one instance of "%1!s!."

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ViewOnASheetMustBeUnique { get; }
Visual Basic
Public Shared ReadOnly Property ViewOnASheetMustBeUnique As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ViewOnASheetMustBeUnique {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ViewSheetFailures Class


ViewOnASheetMustBeUniqueWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..ViewSheetFailures..::..ViewOnASheetMustBeUniqueWarn Property
BuiltInFailures..::..ViewSheetFailures Class See Also Send Feedback
Sheet views cannot contain more than one instance of "%1!s!."

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ViewOnASheetMustBeUniqueWarn { get; }
Visual Basic
Public Shared ReadOnly Property ViewOnASheetMustBeUniqueWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ViewOnASheetMustBeUniqueWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ViewSheetFailures Class


ViewportCantContainEmptyView Property

[image]

Revit 2024 API
BuiltInFailures..::..ViewSheetFailures..::..ViewportCantContainEmptyView Property
BuiltInFailures..::..ViewSheetFailures Class See Also Send Feedback
Sheet views cannot contain empty view "%1!s!".

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ViewportCantContainEmptyView { get; }
Visual Basic
Public Shared ReadOnly Property ViewportCantContainEmptyView As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ViewportCantContainEmptyView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ViewSheetFailures Class


BuiltInFailures.WallFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..WallFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class WallFailures
Visual Basic
Public NotInheritable Class WallFailures
Visual C++
public ref class WallFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..WallFailures

See Also

BuiltInFailures..::..WallFailures Members


BuiltInFailures.WallFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..WallFailures Members
BuiltInFailures..::..WallFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..WallFailures type exposes the following members.

Properties

Name | Description
CannotChangeSubwall | Changing the type of a subwall is not allowed. Edit the stacked wall type instead.
CannotChangeTypeOfOldCurtainPanel | Cannot change the type of curtain panels in walls created with early versions of Revit. To change the panels of this curtain wall, wall must be recreated.
CannotMaintainKeyReference | Can't maintain the position of the Location Line in this Wall.
CannotMirrorWallPanel | Cannot mirror wall panels.
CannotRedoFaceBased | Faces defining this Element cannot be reacquired.
CannotRedoFaceBasedWarn | Faces defining this Element cannot be reacquired.
CannotRedoFaceRoof | "Faces defining this Roof cannot be reacquired. Either delete the Roof or leave as it is.
CannotSlantStackedWallError | Cannot slant a stacked wall with rectangular openings. Please delete the openings first.
CannotSplitJoinHostsInplaceFamilies | Can't split/join this host because there are instances of In-place Families that cut openings into it. Edit or delete instances first so they don't cut into the host to be split or joined.
CannotSplitVerticallyCompoundWall | Can't divide Wall's face to assign different materials to a vertically compound Wall.
CannotToSplitWallPanels | Unable to split wall panel(s).
CannotUpdateWallPanel | Unable to update wall panel.
ChangingWallsweepType | This wall sweep instance has different profile or material than its type. You may delete the sweep, or if you ignore this warning, it will be regenerated according to its type.
ConstrainedToWall | Sketch Lines created with Pick Wall must remain parallel to the Wall.
ConstrainedToWallError | Sketch Lines created with Pick Wall must remain parallel to the Wall.
ContFootingCannotJoin | Miter plane for Wall Foundation join is too far away; Bisecting plane will be used instead.
ContFootingRadiusTooSmall | Can't display the Wall Foundation, because the Wall's radius is too small. Please increase the radius to display the Wall Foundation.
CurtainOrStackedWallDisallowedForCrossSectionType | Curtain wall types and Stacked wall types are not allowed for this wall's cross-section type.
DisallowedPathCurve | Cannot create stacked elliptical wall with offsets.
EmbeddedButShouldNotBe | Conditions for wall embedding are no longer satisfied.
ExtrudedWallDisallowedForCrossSectionType | Edited profiles are not allowed for this wall's cross-section type.
FaceBecameVertical | Face defining this non-vertical Wall is vertical.
FaceIsNoGoodForWall | Defining face is not suitable for walls.
FaceIsNoLongerVertical | Face defining this vertical Wall is no longer vertical.
FaceWallBadType | Wall type '[Type Name]' is incompatible with picked face. Only basic wall types are accepted.
FaceWallComplexType | Vertically compound wall type features sweeps, reveals, or split layers are not supported on non-vertical face. Consider using a simplified type.
FaceWallFailedToMake | Can't make Face Wall shape.
FaceWallMissingFace | No picked face found.
FailedConvertWallToPanel | Unable to convert wall to panel.
FailedToChangeInstSymbol | Failed to change symbol of instance.
FailedToStoreSideFace | Failed to store wall side face. Wall sweeps on this wall will fail to regenerate.
InvalidBaseConstraintForLevel | Base Constraint is invalid for the Level.
InvalidCompoundStructure | Invalid compound structure.
InvalidTargetPosition | Joining the highlighted wall to the highlighted element moves the wall's top below its bottom or its bottom above its top, or interferes with wall joins or holes in the wall.
InvalidTargetPositionError | Joining the highlighted wall to the highlighted element moves the wall's top below its bottom or its bottom above its top, or interferes with wall joins or holes in the wall.
InvalidTopConstraintForLevel | Top Constraint is invalid for the Level.
LostEditsJoinsRedoFaceBased | Previous edits and /or wall joins will not be preserved on this operation.
ParameterChangeNotAffectingGeometry | Changing this element's parameter has no effect on its current position or geometry. Check to see if the element is constrained either in the project view or in the element's sketch.
RecursionParameterIgnored | Parameter-defined type of curtain panels defined in a circular way and will be ignored.
RemapConstrainLocationLine | Existing locked constraints to the Location Line will be transferred to the new Location Line position. Press "Unconstrain" to remove the constraint rather than transferring it.
ShorterThanMinWall | Wall is shorter than minimum height allowed by its type.\nIt is [Length] and must be at least [Length].
ShorterThanMinWallError | Wall is shorter than minimum height allowed by its type.\nIt is [Length] and must be at least [Length].
ShorterThanMinWallFailure | Wall is shorter than minimum height allowed by its type.\nIt is [Length] and must be at least [Length].
ShouldAdjustWallParameters | The best way to control top and base of the Wall is to modify the Constraints and Offset Parameters in Properties dialog.
StackedWallNeedsUnjoin | A subwall of this stacked wall is unjoined from its neighbors because it was pulled too far.
SubwallOfStackedWallDeleted | This stacked wall will be deleted because a subwall could not be created.
TaperedWallAnglesControlledByType | Cannot set angles on a tapered wall which has angles controlled by the type.
TooShortStackedWall | Stacked wall instance is too short.
UnableToCreateWallForPanel | Unable to create wall for curtain wall panel.
UnableToDeleteWallForPanel | Unable to delete curtain panel wall.
UnjoinOnEditWallChange | Line associated with a joined face has been moved. This action will cause the other walls to become disjoined from this face. [Description]
VerticalLayerExtensionFailure | Cannot extend layer(s) of the highlighted vertically compound wall.
VerticalLayerExtensionFailureError | Cannot extend layer(s) of the highlighted vertically compound wall.
WallCutoutForInsertionFailure | Can't cut wall for inserted objects
WallLacksCurve | Wall does not have both a curve driver and a curve!!!!
WallNegativeHeight | The top of the Wall is lower than the base of the Wall.
WallSettingsChanged | Default wall settings will be changed (Base Constraint: [Base Level], Base Offset: [Base Offset], Top Constraint: [Top Level], Top Offset: [Top Offset])
WallTypeIncompatibleWithTapered | This wall's type is not compatible with the Tapered cross-section. Tapered walls require a variable thickness layer.

See Also

BuiltInFailures..::..WallFailures Class


BuiltInFailures.WallFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..WallFailures Properties
BuiltInFailures..::..WallFailures Class See Also Send Feedback

The BuiltInFailures..::..WallFailures type exposes the following members.

Properties

Name | Description
CannotChangeSubwall | Changing the type of a subwall is not allowed. Edit the stacked wall type instead.
CannotChangeTypeOfOldCurtainPanel | Cannot change the type of curtain panels in walls created with early versions of Revit. To change the panels of this curtain wall, wall must be recreated.
CannotMaintainKeyReference | Can't maintain the position of the Location Line in this Wall.
CannotMirrorWallPanel | Cannot mirror wall panels.
CannotRedoFaceBased | Faces defining this Element cannot be reacquired.
CannotRedoFaceBasedWarn | Faces defining this Element cannot be reacquired.
CannotRedoFaceRoof | "Faces defining this Roof cannot be reacquired. Either delete the Roof or leave as it is.
CannotSlantStackedWallError | Cannot slant a stacked wall with rectangular openings. Please delete the openings first.
CannotSplitJoinHostsInplaceFamilies | Can't split/join this host because there are instances of In-place Families that cut openings into it. Edit or delete instances first so they don't cut into the host to be split or joined.
CannotSplitVerticallyCompoundWall | Can't divide Wall's face to assign different materials to a vertically compound Wall.
CannotToSplitWallPanels | Unable to split wall panel(s).
CannotUpdateWallPanel | Unable to update wall panel.
ChangingWallsweepType | This wall sweep instance has different profile or material than its type. You may delete the sweep, or if you ignore this warning, it will be regenerated according to its type.
ConstrainedToWall | Sketch Lines created with Pick Wall must remain parallel to the Wall.
ConstrainedToWallError | Sketch Lines created with Pick Wall must remain parallel to the Wall.
ContFootingCannotJoin | Miter plane for Wall Foundation join is too far away; Bisecting plane will be used instead.
ContFootingRadiusTooSmall | Can't display the Wall Foundation, because the Wall's radius is too small. Please increase the radius to display the Wall Foundation.
CurtainOrStackedWallDisallowedForCrossSectionType | Curtain wall types and Stacked wall types are not allowed for this wall's cross-section type.
DisallowedPathCurve | Cannot create stacked elliptical wall with offsets.
EmbeddedButShouldNotBe | Conditions for wall embedding are no longer satisfied.
ExtrudedWallDisallowedForCrossSectionType | Edited profiles are not allowed for this wall's cross-section type.
FaceBecameVertical | Face defining this non-vertical Wall is vertical.
FaceIsNoGoodForWall | Defining face is not suitable for walls.
FaceIsNoLongerVertical | Face defining this vertical Wall is no longer vertical.
FaceWallBadType | Wall type '[Type Name]' is incompatible with picked face. Only basic wall types are accepted.
FaceWallComplexType | Vertically compound wall type features sweeps, reveals, or split layers are not supported on non-vertical face. Consider using a simplified type.
FaceWallFailedToMake | Can't make Face Wall shape.
FaceWallMissingFace | No picked face found.
FailedConvertWallToPanel | Unable to convert wall to panel.
FailedToChangeInstSymbol | Failed to change symbol of instance.
FailedToStoreSideFace | Failed to store wall side face. Wall sweeps on this wall will fail to regenerate.
InvalidBaseConstraintForLevel | Base Constraint is invalid for the Level.
InvalidCompoundStructure | Invalid compound structure.
InvalidTargetPosition | Joining the highlighted wall to the highlighted element moves the wall's top below its bottom or its bottom above its top, or interferes with wall joins or holes in the wall.
InvalidTargetPositionError | Joining the highlighted wall to the highlighted element moves the wall's top below its bottom or its bottom above its top, or interferes with wall joins or holes in the wall.
InvalidTopConstraintForLevel | Top Constraint is invalid for the Level.
LostEditsJoinsRedoFaceBased | Previous edits and /or wall joins will not be preserved on this operation.
ParameterChangeNotAffectingGeometry | Changing this element's parameter has no effect on its current position or geometry. Check to see if the element is constrained either in the project view or in the element's sketch.
RecursionParameterIgnored | Parameter-defined type of curtain panels defined in a circular way and will be ignored.
RemapConstrainLocationLine | Existing locked constraints to the Location Line will be transferred to the new Location Line position. Press "Unconstrain" to remove the constraint rather than transferring it.
ShorterThanMinWall | Wall is shorter than minimum height allowed by its type.\nIt is [Length] and must be at least [Length].
ShorterThanMinWallError | Wall is shorter than minimum height allowed by its type.\nIt is [Length] and must be at least [Length].
ShorterThanMinWallFailure | Wall is shorter than minimum height allowed by its type.\nIt is [Length] and must be at least [Length].
ShouldAdjustWallParameters | The best way to control top and base of the Wall is to modify the Constraints and Offset Parameters in Properties dialog.
StackedWallNeedsUnjoin | A subwall of this stacked wall is unjoined from its neighbors because it was pulled too far.
SubwallOfStackedWallDeleted | This stacked wall will be deleted because a subwall could not be created.
TaperedWallAnglesControlledByType | Cannot set angles on a tapered wall which has angles controlled by the type.
TooShortStackedWall | Stacked wall instance is too short.
UnableToCreateWallForPanel | Unable to create wall for curtain wall panel.
UnableToDeleteWallForPanel | Unable to delete curtain panel wall.
UnjoinOnEditWallChange | Line associated with a joined face has been moved. This action will cause the other walls to become disjoined from this face. [Description]
VerticalLayerExtensionFailure | Cannot extend layer(s) of the highlighted vertically compound wall.
VerticalLayerExtensionFailureError | Cannot extend layer(s) of the highlighted vertically compound wall.
WallCutoutForInsertionFailure | Can't cut wall for inserted objects
WallLacksCurve | Wall does not have both a curve driver and a curve!!!!
WallNegativeHeight | The top of the Wall is lower than the base of the Wall.
WallSettingsChanged | Default wall settings will be changed (Base Constraint: [Base Level], Base Offset: [Base Offset], Top Constraint: [Top Level], Top Offset: [Top Offset])
WallTypeIncompatibleWithTapered | This wall's type is not compatible with the Tapered cross-section. Tapered walls require a variable thickness layer.

See Also

BuiltInFailures..::..WallFailures Class


CannotChangeSubwall Property

[image]

Revit 2024 API
BuiltInFailures..::..WallFailures..::..CannotChangeSubwall Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Changing the type of a subwall is not allowed. Edit the stacked wall type instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotChangeSubwall { get; }
Visual Basic
Public Shared ReadOnly Property CannotChangeSubwall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotChangeSubwall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


CannotChangeTypeOfOldCurtainPanel Property

[image]

Revit 2024 API
BuiltInFailures..::..WallFailures..::..CannotChangeTypeOfOldCurtainPanel Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Cannot change the type of curtain panels in walls created with early versions of Revit. To change the panels of this curtain wall, wall must be recreated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotChangeTypeOfOldCurtainPanel { get; }
Visual Basic
Public Shared ReadOnly Property CannotChangeTypeOfOldCurtainPanel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotChangeTypeOfOldCurtainPanel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


CannotMirrorWallPanel Property

[image]

Revit 2024 API
BuiltInFailures..::..WallFailures..::..CannotMirrorWallPanel Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Cannot mirror wall panels.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotMirrorWallPanel { get; }
Visual Basic
Public Shared ReadOnly Property CannotMirrorWallPanel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMirrorWallPanel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


CannotRedoFaceBasedWarn Property

[image]

Revit 2024 API
BuiltInFailures..::..WallFailures..::..CannotRedoFaceBasedWarn Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Faces defining this Element cannot be reacquired.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotRedoFaceBasedWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotRedoFaceBasedWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotRedoFaceBasedWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


CannotRedoFaceRoof Property

[image]

Revit 2024 API
BuiltInFailures..::..WallFailures..::..CannotRedoFaceRoof Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
"Faces defining this Roof cannot be reacquired. Either delete the Roof or leave as it is.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotRedoFaceRoof { get; }
Visual Basic
Public Shared ReadOnly Property CannotRedoFaceRoof As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotRedoFaceRoof {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


CannotSplitJoinHostsInplaceFamilies Property

[image]

Revit 2024 API
BuiltInFailures..::..WallFailures..::..CannotSplitJoinHostsInplaceFamilies Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Can't split/join this host because there are instances of In-place Families that cut openings into it. Edit or delete instances first so they don't cut into the host to be split or joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotSplitJoinHostsInplaceFamilies { get; }
Visual Basic
Public Shared ReadOnly Property CannotSplitJoinHostsInplaceFamilies As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotSplitJoinHostsInplaceFamilies {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


CannotSplitVerticallyCompoundWall Property

[image]

Revit 2024 API
BuiltInFailures..::..WallFailures..::..CannotSplitVerticallyCompoundWall Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Can't divide Wall's face to assign different materials to a vertically compound Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotSplitVerticallyCompoundWall { get; }
Visual Basic
Public Shared ReadOnly Property CannotSplitVerticallyCompoundWall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotSplitVerticallyCompoundWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


CannotUpdateWallPanel Property

[image]

Revit 2024 API
BuiltInFailures..::..WallFailures..::..CannotUpdateWallPanel Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Unable to update wall panel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CannotUpdateWallPanel { get; }
Visual Basic
Public Shared ReadOnly Property CannotUpdateWallPanel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotUpdateWallPanel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


ChangingWallsweepType Property

[image]

Revit 2024 API
BuiltInFailures..::..WallFailures..::..ChangingWallsweepType Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
This wall sweep instance has different profile or material than its type. You may delete the sweep, or if you ignore this warning, it will be regenerated according to its type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ChangingWallsweepType { get; }
Visual Basic
Public Shared ReadOnly Property ChangingWallsweepType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ChangingWallsweepType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


ConstrainedToWall Property

[image]

Revit 2024 API
BuiltInFailures..::..WallFailures..::..ConstrainedToWall Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Sketch Lines created with Pick Wall must remain parallel to the Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ConstrainedToWall { get; }
Visual Basic
Public Shared ReadOnly Property ConstrainedToWall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ConstrainedToWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


ConstrainedToWallError Property

[image]

Revit 2024 API
BuiltInFailures..::..WallFailures..::..ConstrainedToWallError Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Sketch Lines created with Pick Wall must remain parallel to the Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ConstrainedToWallError { get; }
Visual Basic
Public Shared ReadOnly Property ConstrainedToWallError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ConstrainedToWallError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


ContFootingCannotJoin Property

[image]

Revit 2024 API
BuiltInFailures..::..WallFailures..::..ContFootingCannotJoin Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Miter plane for Wall Foundation join is too far away; Bisecting plane will be used instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ContFootingCannotJoin { get; }
Visual Basic
Public Shared ReadOnly Property ContFootingCannotJoin As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ContFootingCannotJoin {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


CurtainOrStackedWallDisallowedForCrossSectionType Property

[image]

Revit 2024 API
BuiltInFailures..::..WallFailures..::..CurtainOrStackedWallDisallowedForCrossSectionType Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Curtain wall types and Stacked wall types are not allowed for this wall's cross-section type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId CurtainOrStackedWallDisallowedForCrossSectionType { get; }
Visual Basic
Public Shared ReadOnly Property CurtainOrStackedWallDisallowedForCrossSectionType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CurtainOrStackedWallDisallowedForCrossSectionType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


FaceBecameVertical Property

[image]

Revit 2024 API
BuiltInFailures..::..WallFailures..::..FaceBecameVertical Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Face defining this non-vertical Wall is vertical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FaceBecameVertical { get; }
Visual Basic
Public Shared ReadOnly Property FaceBecameVertical As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FaceBecameVertical {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


FaceIsNoGoodForWall Property

[image]

Revit 2024 API
BuiltInFailures..::..WallFailures..::..FaceIsNoGoodForWall Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Defining face is not suitable for walls.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FaceIsNoGoodForWall { get; }
Visual Basic
Public Shared ReadOnly Property FaceIsNoGoodForWall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FaceIsNoGoodForWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


FaceIsNoLongerVertical Property

[image]

Revit 2024 API
BuiltInFailures..::..WallFailures..::..FaceIsNoLongerVertical Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Face defining this vertical Wall is no longer vertical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FaceIsNoLongerVertical { get; }
Visual Basic
Public Shared ReadOnly Property FaceIsNoLongerVertical As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FaceIsNoLongerVertical {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


FaceWallBadType Property

[image]

Revit 2024 API
BuiltInFailures..::..WallFailures..::..FaceWallBadType Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Wall type '[Type Name]' is incompatible with picked face. Only basic wall types are accepted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FaceWallBadType { get; }
Visual Basic
Public Shared ReadOnly Property FaceWallBadType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FaceWallBadType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


FaceWallComplexType Property

[image]

Revit 2024 API
BuiltInFailures..::..WallFailures..::..FaceWallComplexType Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Vertically compound wall type features sweeps, reveals, or split layers are not supported on non-vertical face. Consider using a simplified type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FaceWallComplexType { get; }
Visual Basic
Public Shared ReadOnly Property FaceWallComplexType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FaceWallComplexType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


FaceWallMissingFace Property

[image]

Revit 2024 API
BuiltInFailures..::..WallFailures..::..FaceWallMissingFace Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
No picked face found.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FaceWallMissingFace { get; }
Visual Basic
Public Shared ReadOnly Property FaceWallMissingFace As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FaceWallMissingFace {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


FailedConvertWallToPanel Property

[image]

Revit 2024 API
BuiltInFailures..::..WallFailures..::..FailedConvertWallToPanel Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Unable to convert wall to panel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FailedConvertWallToPanel { get; }
Visual Basic
Public Shared ReadOnly Property FailedConvertWallToPanel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FailedConvertWallToPanel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


FailedToChangeInstSymbol Property

[image]

Revit 2024 API
BuiltInFailures..::..WallFailures..::..FailedToChangeInstSymbol Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Failed to change symbol of instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FailedToChangeInstSymbol { get; }
Visual Basic
Public Shared ReadOnly Property FailedToChangeInstSymbol As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FailedToChangeInstSymbol {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


FailedToStoreSideFace Property

[image]

Revit 2024 API
BuiltInFailures..::..WallFailures..::..FailedToStoreSideFace Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Failed to store wall side face. Wall sweeps on this wall will fail to regenerate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FailedToStoreSideFace { get; }
Visual Basic
Public Shared ReadOnly Property FailedToStoreSideFace As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FailedToStoreSideFace {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


InvalidBaseConstraintForLevel Property

[image]

Revit 2024 API
BuiltInFailures..::..WallFailures..::..InvalidBaseConstraintForLevel Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Base Constraint is invalid for the Level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidBaseConstraintForLevel { get; }
Visual Basic
Public Shared ReadOnly Property InvalidBaseConstraintForLevel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidBaseConstraintForLevel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


InvalidCompoundStructure Property

[image]

Revit 2024 API
BuiltInFailures..::..WallFailures..::..InvalidCompoundStructure Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Invalid compound structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidCompoundStructure { get; }
Visual Basic
Public Shared ReadOnly Property InvalidCompoundStructure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidCompoundStructure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


InvalidTargetPosition Property

[image]

Revit 2024 API
BuiltInFailures..::..WallFailures..::..InvalidTargetPosition Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Joining the highlighted wall to the highlighted element moves the wall's top below its bottom or its bottom above its top, or interferes with wall joins or holes in the wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidTargetPosition { get; }
Visual Basic
Public Shared ReadOnly Property InvalidTargetPosition As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidTargetPosition {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


InvalidTopConstraintForLevel Property

[image]

Revit 2024 API
BuiltInFailures..::..WallFailures..::..InvalidTopConstraintForLevel Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Top Constraint is invalid for the Level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId InvalidTopConstraintForLevel { get; }
Visual Basic
Public Shared ReadOnly Property InvalidTopConstraintForLevel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidTopConstraintForLevel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


ParameterChangeNotAffectingGeometry Property

[image]

Revit 2024 API
BuiltInFailures..::..WallFailures..::..ParameterChangeNotAffectingGeometry Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Changing this element's parameter has no effect on its current position or geometry. Check to see if the element is constrained either in the project view or in the element's sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ParameterChangeNotAffectingGeometry { get; }
Visual Basic
Public Shared ReadOnly Property ParameterChangeNotAffectingGeometry As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ParameterChangeNotAffectingGeometry {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


RecursionParameterIgnored Property

[image]

Revit 2024 API
BuiltInFailures..::..WallFailures..::..RecursionParameterIgnored Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Parameter-defined type of curtain panels defined in a circular way and will be ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId RecursionParameterIgnored { get; }
Visual Basic
Public Shared ReadOnly Property RecursionParameterIgnored As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RecursionParameterIgnored {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


ShorterThanMinWall Property

[image]

Revit 2024 API
BuiltInFailures..::..WallFailures..::..ShorterThanMinWall Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Wall is shorter than minimum height allowed by its type.\nIt is [Length] and must be at least [Length].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ShorterThanMinWall { get; }
Visual Basic
Public Shared ReadOnly Property ShorterThanMinWall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ShorterThanMinWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


ShorterThanMinWallError Property

[image]

Revit 2024 API
BuiltInFailures..::..WallFailures..::..ShorterThanMinWallError Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Wall is shorter than minimum height allowed by its type.\nIt is [Length] and must be at least [Length].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ShorterThanMinWallError { get; }
Visual Basic
Public Shared ReadOnly Property ShorterThanMinWallError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ShorterThanMinWallError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


ShorterThanMinWallFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..WallFailures..::..ShorterThanMinWallFailure Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Wall is shorter than minimum height allowed by its type.\nIt is [Length] and must be at least [Length].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ShorterThanMinWallFailure { get; }
Visual Basic
Public Shared ReadOnly Property ShorterThanMinWallFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ShorterThanMinWallFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


ShouldAdjustWallParameters Property

[image]

Revit 2024 API
BuiltInFailures..::..WallFailures..::..ShouldAdjustWallParameters Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
The best way to control top and base of the Wall is to modify the Constraints and Offset Parameters in Properties dialog.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ShouldAdjustWallParameters { get; }
Visual Basic
Public Shared ReadOnly Property ShouldAdjustWallParameters As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ShouldAdjustWallParameters {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


StackedWallNeedsUnjoin Property

[image]

Revit 2024 API
BuiltInFailures..::..WallFailures..::..StackedWallNeedsUnjoin Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
A subwall of this stacked wall is unjoined from its neighbors because it was pulled too far.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId StackedWallNeedsUnjoin { get; }
Visual Basic
Public Shared ReadOnly Property StackedWallNeedsUnjoin As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StackedWallNeedsUnjoin {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


SubwallOfStackedWallDeleted Property

[image]

Revit 2024 API
BuiltInFailures..::..WallFailures..::..SubwallOfStackedWallDeleted Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
This stacked wall will be deleted because a subwall could not be created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId SubwallOfStackedWallDeleted { get; }
Visual Basic
Public Shared ReadOnly Property SubwallOfStackedWallDeleted As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SubwallOfStackedWallDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


TaperedWallAnglesControlledByType Property

[image]

Revit 2024 API
BuiltInFailures..::..WallFailures..::..TaperedWallAnglesControlledByType Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Cannot set angles on a tapered wall which has angles controlled by the type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId TaperedWallAnglesControlledByType { get; }
Visual Basic
Public Shared ReadOnly Property TaperedWallAnglesControlledByType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TaperedWallAnglesControlledByType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


TooShortStackedWall Property

[image]

Revit 2024 API
BuiltInFailures..::..WallFailures..::..TooShortStackedWall Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Stacked wall instance is too short.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId TooShortStackedWall { get; }
Visual Basic
Public Shared ReadOnly Property TooShortStackedWall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TooShortStackedWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


UnableToCreateWallForPanel Property

[image]

Revit 2024 API
BuiltInFailures..::..WallFailures..::..UnableToCreateWallForPanel Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Unable to create wall for curtain wall panel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UnableToCreateWallForPanel { get; }
Visual Basic
Public Shared ReadOnly Property UnableToCreateWallForPanel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableToCreateWallForPanel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


UnjoinOnEditWallChange Property

[image]

Revit 2024 API
BuiltInFailures..::..WallFailures..::..UnjoinOnEditWallChange Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Line associated with a joined face has been moved. This action will cause the other walls to become disjoined from this face. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId UnjoinOnEditWallChange { get; }
Visual Basic
Public Shared ReadOnly Property UnjoinOnEditWallChange As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnjoinOnEditWallChange {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


VerticalLayerExtensionFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..WallFailures..::..VerticalLayerExtensionFailure Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Cannot extend layer(s) of the highlighted vertically compound wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId VerticalLayerExtensionFailure { get; }
Visual Basic
Public Shared ReadOnly Property VerticalLayerExtensionFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ VerticalLayerExtensionFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


WallCutoutForInsertionFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..WallFailures..::..WallCutoutForInsertionFailure Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Can't cut wall for inserted objects

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WallCutoutForInsertionFailure { get; }
Visual Basic
Public Shared ReadOnly Property WallCutoutForInsertionFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WallCutoutForInsertionFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


WallLacksCurve Property

[image]

Revit 2024 API
BuiltInFailures..::..WallFailures..::..WallLacksCurve Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Wall does not have both a curve driver and a curve!!!!

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WallLacksCurve { get; }
Visual Basic
Public Shared ReadOnly Property WallLacksCurve As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WallLacksCurve {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


WallNegativeHeight Property

[image]

Revit 2024 API
BuiltInFailures..::..WallFailures..::..WallNegativeHeight Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
The top of the Wall is lower than the base of the Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WallNegativeHeight { get; }
Visual Basic
Public Shared ReadOnly Property WallNegativeHeight As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WallNegativeHeight {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


WallSettingsChanged Property

[image]

Revit 2024 API
BuiltInFailures..::..WallFailures..::..WallSettingsChanged Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Default wall settings will be changed (Base Constraint: [Base Level], Base Offset: [Base Offset], Top Constraint: [Top Level], Top Offset: [Top Offset])

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WallSettingsChanged { get; }
Visual Basic
Public Shared ReadOnly Property WallSettingsChanged As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WallSettingsChanged {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


WallTypeIncompatibleWithTapered Property

[image]

Revit 2024 API
BuiltInFailures..::..WallFailures..::..WallTypeIncompatibleWithTapered Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
This wall's type is not compatible with the Tapered cross-section. Tapered walls require a variable thickness layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WallTypeIncompatibleWithTapered { get; }
Visual Basic
Public Shared ReadOnly Property WallTypeIncompatibleWithTapered As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WallTypeIncompatibleWithTapered {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


BuiltInFailures.WallJoinFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..WallJoinFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about WallJoin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class WallJoinFailures
Visual Basic
Public NotInheritable Class WallJoinFailures
Visual C++
public ref class WallJoinFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..WallJoinFailures

See Also

BuiltInFailures..::..WallJoinFailures Members


BuiltInFailures.WallJoinFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..WallJoinFailures Members
BuiltInFailures..::..WallJoinFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..WallJoinFailures type exposes the following members.

Properties

Name | Description
FailedToChangeWallJointsTypeFailure | Some of the joints you have selected can only have one wall joint type, so these joints haven't been changed.

See Also

BuiltInFailures..::..WallJoinFailures Class


BuiltInFailures.WallJoinFailures Properties

[image] [image]

Revit 2024 API
BuiltInFailures..::..WallJoinFailures Properties
BuiltInFailures..::..WallJoinFailures Class See Also Send Feedback

The BuiltInFailures..::..WallJoinFailures type exposes the following members.

Properties

Name | Description
FailedToChangeWallJointsTypeFailure | Some of the joints you have selected can only have one wall joint type, so these joints haven't been changed.

See Also

BuiltInFailures..::..WallJoinFailures Class


FailedToChangeWallJointsTypeFailure Property

[image]

Revit 2024 API
BuiltInFailures..::..WallJoinFailures..::..FailedToChangeWallJointsTypeFailure Property
BuiltInFailures..::..WallJoinFailures Class See Also Send Feedback
Some of the joints you have selected can only have one wall joint type, so these joints haven't been changed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId FailedToChangeWallJointsTypeFailure { get; }
Visual Basic
Public Shared ReadOnly Property FailedToChangeWallJointsTypeFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FailedToChangeWallJointsTypeFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallJoinFailures Class


BuiltInFailures.WallJoinRoofFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..WallJoinRoofFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about WallJoinRoof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class WallJoinRoofFailures
Visual Basic
Public NotInheritable Class WallJoinRoofFailures
Visual C++
public ref class WallJoinRoofFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..WallJoinRoofFailures

See Also

BuiltInFailures..::..WallJoinRoofFailures Members


BuiltInFailures.WallJoinRoofFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..WallJoinRoofFailures Members
BuiltInFailures..::..WallJoinRoofFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..WallJoinRoofFailures type exposes the following members.

Properties

Name | Description
NoFromRoofForWall | Highlighted wall is set to be "From roof", however there is no roof below it that can be used.
NotCoveredAtAllByTarget | Highlighted walls are attached to, but miss, the highlighted targets.
NoUptoRoofForWall | Highlighted wall is set to be "Up to roof", however there is no roof above it that can be used.
WallMeetsRoofTangentially | The highlighted wall cannot be joined to the highlighted roof because the wall meets the roof tangentially.
WallNotCoveredByRoof | The highlighted wall(s) cannot be joined to the highlighted roof because the roof does not entirely cover the wall(s).

See Also

BuiltInFailures..::..WallJoinRoofFailures Class


NotCoveredAtAllByTarget Property

[image]

Revit 2024 API
BuiltInFailures..::..WallJoinRoofFailures..::..NotCoveredAtAllByTarget Property
BuiltInFailures..::..WallJoinRoofFailures Class See Also Send Feedback
Highlighted walls are attached to, but miss, the highlighted targets.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NotCoveredAtAllByTarget { get; }
Visual Basic
Public Shared ReadOnly Property NotCoveredAtAllByTarget As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotCoveredAtAllByTarget {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallJoinRoofFailures Class


NoUptoRoofForWall Property

[image]

Revit 2024 API
BuiltInFailures..::..WallJoinRoofFailures..::..NoUptoRoofForWall Property
BuiltInFailures..::..WallJoinRoofFailures Class See Also Send Feedback
Highlighted wall is set to be "Up to roof", however there is no roof above it that can be used.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId NoUptoRoofForWall { get; }
Visual Basic
Public Shared ReadOnly Property NoUptoRoofForWall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoUptoRoofForWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallJoinRoofFailures Class


WallMeetsRoofTangentially Property

[image]

Revit 2024 API
BuiltInFailures..::..WallJoinRoofFailures..::..WallMeetsRoofTangentially Property
BuiltInFailures..::..WallJoinRoofFailures Class See Also Send Feedback
The highlighted wall cannot be joined to the highlighted roof because the wall meets the roof tangentially.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WallMeetsRoofTangentially { get; }
Visual Basic
Public Shared ReadOnly Property WallMeetsRoofTangentially As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WallMeetsRoofTangentially {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallJoinRoofFailures Class


WallNotCoveredByRoof Property

[image]

Revit 2024 API
BuiltInFailures..::..WallJoinRoofFailures..::..WallNotCoveredByRoof Property
BuiltInFailures..::..WallJoinRoofFailures Class See Also Send Feedback
The highlighted wall(s) cannot be joined to the highlighted roof because the roof does not entirely cover the wall(s).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId WallNotCoveredByRoof { get; }
Visual Basic
Public Shared ReadOnly Property WallNotCoveredByRoof As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WallNotCoveredByRoof {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallJoinRoofFailures Class


BuiltInFailures.WorksharingFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..WorksharingFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about WorksharingFailures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class WorksharingFailures
Visual Basic
Public NotInheritable Class WorksharingFailures
Visual C++
public ref class WorksharingFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..WorksharingFailures

See Also

BuiltInFailures..::..WorksharingFailures Members


BuiltInFailures.WorksharingFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..WorksharingFailures Members
BuiltInFailures..::..WorksharingFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..WorksharingFailures type exposes the following members.

Properties

Name | Description
DuplicateNamesChanged | These elements' names were automatically changed to eliminate duplicates.
MissingUpdaterLatestOrCentralPlural | The file [File Name] you are trying to synchronize was modified by the third-party updaters [Updater Name(s)] which are not currently installed. \n\r \n\r If you continue to Synchronize with Central or Reload Latest, data maintained by these updaters will not be updated properly. This may create problems when [File Name] is later opened when [Updater Name(s)] are present.
MissingUpdaterLatestOrCentralSingular | The file [File Name] you are trying to synchronize was modified by the third-party updater [Updater Name(s)] which is not currently installed. \n\r \n\r If you continue to Synchronize with Central or Reload Latest, data maintained by this updater will not be updated properly. This may create problems when [File Name] is later opened when [Updater Name(s)] is present.
SeriousElementReferenceCorruption | Element references are seriously corrupt.

See Also

BuiltInFailures..::..WorksharingFailures Class


DuplicateNamesChanged Property

[image]

Revit 2024 API
BuiltInFailures..::..WorksharingFailures..::..DuplicateNamesChanged Property
BuiltInFailures..::..WorksharingFailures Class See Also Send Feedback
These elements' names were automatically changed to eliminate duplicates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId DuplicateNamesChanged { get; }
Visual Basic
Public Shared ReadOnly Property DuplicateNamesChanged As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DuplicateNamesChanged {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WorksharingFailures Class


MissingUpdaterLatestOrCentralSingular Property

[image]

Revit 2024 API
BuiltInFailures..::..WorksharingFailures..::..MissingUpdaterLatestOrCentralSingular Property
BuiltInFailures..::..WorksharingFailures Class See Also Send Feedback
The file [File Name] you are trying to synchronize was modified by the third-party updater [Updater Name(s)] which is not currently installed. \n\r \n\r If you continue to Synchronize with Central or Reload Latest, data maintained by this updater will not be updated properly. This may create problems when [File Name] is later opened when [Updater Name(s)] is present.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId MissingUpdaterLatestOrCentralSingular { get; }
Visual Basic
Public Shared ReadOnly Property MissingUpdaterLatestOrCentralSingular As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MissingUpdaterLatestOrCentralSingular {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WorksharingFailures Class


BuiltInFailures.ZoneFailures Class

[image]

Revit 2024 API
BuiltInFailures..::..ZoneFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Zone.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class ZoneFailures
Visual Basic
Public NotInheritable Class ZoneFailures
Visual C++
public ref class ZoneFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..ZoneFailures

See Also

BuiltInFailures..::..ZoneFailures Members


BuiltInFailures.ZoneFailures Members

[image] [image]

Revit 2024 API
BuiltInFailures..::..ZoneFailures Members
BuiltInFailures..::..ZoneFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..ZoneFailures type exposes the following members.

Properties

Name | Description
ZoneExistsNotEnclosedRoom | Zone has a room not enclosed.
ZoneNotEnclosed | Zone not enclosed totally.
ZonesOverlapWarning | Zone overlap to another zone or another room.

See Also

BuiltInFailures..::..ZoneFailures Class


ZoneNotEnclosed Property

[image]

Revit 2024 API
BuiltInFailures..::..ZoneFailures..::..ZoneNotEnclosed Property
BuiltInFailures..::..ZoneFailures Class See Also Send Feedback
Zone not enclosed totally.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ZoneNotEnclosed { get; }
Visual Basic
Public Shared ReadOnly Property ZoneNotEnclosed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ZoneNotEnclosed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ZoneFailures Class


ZonesOverlapWarning Property

[image]

Revit 2024 API
BuiltInFailures..::..ZoneFailures..::..ZonesOverlapWarning Property
BuiltInFailures..::..ZoneFailures Class See Also Send Feedback
Zone overlap to another zone or another room.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static FailureDefinitionId ZonesOverlapWarning { get; }
Visual Basic
Public Shared ReadOnly Property ZonesOverlapWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ZonesOverlapWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ZoneFailures Class


BuiltInParameterGroup Enumeration

[image]

Revit 2024 API
BuiltInParameterGroup Enumeration
See Also Send Feedback
An enumerated type listing all of the built-in parameter groups supported by Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
[ObsoleteAttribute("This enumeration is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use members of the `GroupTypeId` class instead.")]
public enum BuiltInParameterGroup
Visual Basic
<ObsoleteAttribute("This enumeration is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use members of the `GroupTypeId` class instead.")> _
Public Enumeration BuiltInParameterGroup
Visual C++
[ObsoleteAttribute(L"This enumeration is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use members of the `GroupTypeId` class instead.")]
public enum class BuiltInParameterGroup

Members

Member name | Description
PG_TOPOSOLID_SUBDIVISION | "Toposolid Subdivision"
PG_LIFE_SAFETY | "Life Safety"
PG_ELECTRICAL_ANALYSIS | "Electrical Analysis"
PG_ALTERNATE_UNITS | "Alternate Units"
PG_PRIMARY_UNITS | "Primary Units"
PG_WALL_CROSS_SECTION_DEFINITION | "Cross-Section Definition"
PG_ROUTE_ANALYSIS | "Route Analysis"
PG_GEO_LOCATION | "Geolocation"
PG_STRUCTURAL_SECTION_GEOMETRY | "Structural Section Geometry"
PG_ENERGY_ANALYSIS_BLDG_CONS_MTL_THERMAL_PROPS | "Material Thermal Properties"
PG_ENERGY_ANALYSIS_ROOM_SPACE_DATA | "Room/Space Data"
PG_ENERGY_ANALYSIS_BUILDING_DATA | "Building Data"
PG_COUPLER_ARRAY | "Set"
PG_ENERGY_ANALYSIS_ADVANCED | "Advanced"
PG_RELEASES_MEMBER_FORCES | "Releases / Member Forces"
PG_SECONDARY_END | "Secondary End"
PG_PRIMARY_END | "Primary End"
PG_MOMENTS | "Moments"
PG_FORCES | "Forces"
PG_FABRICATION_PRODUCT_DATA | "Fabrication Product Data"
PG_REFERENCE | "Reference"
PG_GEOMETRY_POSITIONING | "Geometric Position"
PG_DIVISION_GEOMETRY | "Division Geometry"
PG_SEGMENTS_FITTINGS | "Segments and Fittings"
PG_CONTINUOUSRAIL_END_TOP_EXTENSION | "Extension (End/Top)"
PG_CONTINUOUSRAIL_BEGIN_BOTTOM_EXTENSION | "Extension (Beginning/Bottom)"
PG_STAIRS_WINDERS | "Winders"
PG_STAIRS_SUPPORTS | "Supports"
PG_STAIRS_OPEN_END_CONNECTION | "End Connection"
PG_RAILING_SYSTEM_SECONDARY_FAMILY_HANDRAILS | "Handrail 2"
PG_TERMINATION | "Terminations"
PG_STAIRS_TREADS_RISERS | "Threads/Risers"
PG_STAIRS_CALCULATOR_RULES | "Calculation Rules"
PG_SPLIT_PROFILE_DIMENSIONS | "Dimensions (linear units or % of thickness)"
PG_LENGTH | "Length"
PG_NODES | "Nodes"
PG_ANALYTICAL_PROPERTIES | "Analytical Properties"
PG_ANALYTICAL_ALIGNMENT | "Analytical Alignment"
PG_SYSTEMTYPE_RISEDROP | "Rise / Drop"
PG_LINING | "Lining"
PG_INSULATION | "Insulation"
PG_OVERALL_LEGEND | "Overall Legend"
PG_VISIBILITY | "Visibility"
PG_SUPPORT | "Supports"
PG_RAILING_SYSTEM_SEGMENT_V_GRID | "V Grid"
PG_RAILING_SYSTEM_SEGMENT_U_GRID | "U Grid"
PG_RAILING_SYSTEM_SEGMENT_POSTS | "Posts"
PG_RAILING_SYSTEM_SEGMENT_PATTERN_REMAINDER | "Pattern Remainder"
PG_RAILING_SYSTEM_SEGMENT_PATTERN_REPEAT | "Pattern Repeat"
PG_RAILING_SYSTEM_FAMILY_SEGMENT_PATTERN | "Segment Pattern (default)"
PG_RAILING_SYSTEM_FAMILY_HANDRAILS | "Handrail 1"
PG_RAILING_SYSTEM_FAMILY_TOP_RAIL | "Top Rail"
PG_CONCEPTUAL_ENERGY_DATA_BUILDING_SERVICES | "Energy Model - Building Services"
PG_DATA | "Data"
PG_ELECTRICAL_CIRCUITING | "Electrical - Circuiting"
PG_GENERAL | "General"
PG_FLEXIBLE | "Adaptive Component"
PG_ENERGY_ANALYSIS_CONCEPTUAL_MODEL | "Energy Analytical Model"
PG_ENERGY_ANALYSIS_DETAILED_MODEL | "Detailed Model"
PG_ENERGY_ANALYSIS_DETAILED_AND_CONCEPTUAL_MODELS | "Essential"
PG_FITTING | "Fittings"
PG_CONCEPTUAL_ENERGY_DATA | "Conceptual Energy Data"
PG_AREA | "Area"
PG_ADSK_MODEL_PROPERTIES | "Model Properties"
PG_CURTAIN_GRID_V | "V Grid"
PG_CURTAIN_GRID_U | "U Grid"
PG_DISPLAY | "Display"
PG_ANALYSIS_RESULTS | "Analysis Results"
PG_SLAB_SHAPE_EDIT | "Slab Shape Edit"
PG_LIGHT_PHOTOMETRICS | "Photometrics"
PG_PATTERN_APPLICATION | "Pattern Application"
PG_GREEN_BUILDING | "Green Building Properties"
PG_PROFILE_2 | "Profile 2"
PG_PROFILE_1 | "Profile 1"
PG_PROFILE | "Profile"
PG_TRUSS_FAMILY_BOTTOM_CHORD | "Bottom Chords"
PG_TRUSS_FAMILY_TOP_CHORD | "Top Chords"
PG_TRUSS_FAMILY_DIAG_WEB | "Diagonal Webs"
PG_TRUSS_FAMILY_VERT_WEB | "Vertical Webs"
PG_TITLE | "Title Text"
PG_FIRE_PROTECTION | "Fire Protection"
PG_ROTATION_ABOUT | "Rotation about"
PG_TRANSLATION_IN | "Translation in"
PG_ANALYTICAL_MODEL | "Analytical Model"
PG_REBAR_ARRAY | "Rebar Set"
PG_REBAR_SYSTEM_LAYERS | "Layers"
PG_CURTAIN_GRID | "Grid"
PG_CURTAIN_MULLION_2 | "Grid 2 Mullions"
PG_CURTAIN_MULLION_HORIZ | "Horizontal Mullions"
PG_CURTAIN_MULLION_1 | "Grid 1 Mullions"
PG_CURTAIN_MULLION_VERT | "Vertical Mullions"
PG_CURTAIN_GRID_2 | "Grid 2"
PG_CURTAIN_GRID_HORIZ | "Horizontal Grid"
PG_CURTAIN_GRID_1 | "Grid 1"
PG_CURTAIN_GRID_VERT | "Vertical Grid"
PG_IFC | "IFC Parameters"
PG_ELECTRICAL | "Electrical"
PG_ENERGY_ANALYSIS | "Energy Analysis"
PG_STRUCTURAL_ANALYSIS | "Structural Analysis"
PG_MECHANICAL_AIRFLOW | "Mechanical - Flow"
PG_MECHANICAL_LOADS | "Mechanical - Loads"
PG_ELECTRICAL_LOADS | "Electrical - Loads"
PG_ELECTRICAL_LIGHTING | "Electrical - Lighting"
PG_TEXT | "Text"
PG_VIEW_CAMERA | "Camera"
PG_VIEW_EXTENTS | "Extents"
PG_PATTERN | "Pattern"
PG_CONSTRAINTS | "Constraints"
PG_PHASING | "Phasing"
PG_MECHANICAL | "Mechanical"
PG_STRUCTURAL | "Structural"
PG_PLUMBING | "Plumbing"
PG_ELECTRICAL_ENGINEERING | "Electrical Engineering"
PG_STAIR_STRINGERS | "Stringers"
PG_STAIR_RISERS | "Risers"
PG_STAIR_TREADS | "Treads"
PG_UNDERLAY | "Underlay"
PG_MATERIALS | "Materials and Finishes"
PG_GRAPHICS | "Graphics"
PG_CONSTRUCTION | "Construction"
PG_GEOMETRY | "Dimensions"
PG_IDENTITY_DATA | "Identity Data"
INVALID |

Remarks

Parameter groups are used to sort parameters within the Element Properties dialog.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


CADExportOptions Class

[image]

Revit 2024 API
CADExportOptions Class
Members See Also Send Feedback
Generic CAD Export options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public abstract class CADExportOptions
Visual Basic
Public MustInherit Class CADExportOptions
Visual C++
public ref class CADExportOptions abstract

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..CADExportOptions
Autodesk.Revit.DB..::..DWFExportOptions

See Also

CADExportOptions Members


CADExportOptions Members

[image] [image]

Revit 2024 API
CADExportOptions Members
CADExportOptions Class Methods See Also Send Feedback

The CADExportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CADExportOptions Class


CADExportOptions Methods

[image] [image]

Revit 2024 API
CADExportOptions Methods
CADExportOptions Class See Also Send Feedback

The CADExportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CADExportOptions Class


CADLinkOperations Methods

[image] [image]

Revit 2024 API
CADLinkOperations Methods
CADLinkOperations Class See Also Send Feedback

The CADLinkOperations type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from LinkOperations.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetOnLocalLinkSharedCoordinatesSavedCallback | Sets the callback that will be called when the Revit user saves new shared coordinate settings to a linked document obtained from an IExternalResourceServer. (Inherited from LinkOperations.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CADLinkOperations Class


CADLinkOperations Properties

[image] [image]

Revit 2024 API
CADLinkOperations Properties
CADLinkOperations Class See Also Send Feedback

The CADLinkOperations type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from LinkOperations.)

See Also

CADLinkOperations Class


CADLinkOptions Class

[image]

Revit 2024 API
CADLinkOptions Class
Members See Also Send Feedback
This class contains the options in use when or reloading a CAD link type (DWG, DXF, etc.)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public class CADLinkOptions : IDisposable
Visual Basic
Public Class CADLinkOptions _
    Implements IDisposable
Visual C++
public ref class CADLinkOptions : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..CADLinkOptions

See Also

CADLinkOptions Members


CADLinkOptions Members

[image] [image]

Revit 2024 API
CADLinkOptions Members
CADLinkOptions Class Constructors Methods Properties See Also Send Feedback

The CADLinkOptions type exposes the following members.

Constructors

 | Name | Description
Public method | CADLinkOptions(CADLinkOptions) | Constructs a new copy of the input CADLinkOptions object.
Public method | CADLinkOptions(Boolean, ElementId) | Creates a CADLinkOptions object, specifying whether to preserve graphic overrides, and what view to use if the link's view has been deleted.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the CADLinkOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | PreserveOverrides | Whether Revit should preserve the link's graphic overrides on reload.
Public property | ViewId | The id of the view to use as the link's reference view, if the reference view has been deleted.

See Also

CADLinkOptions Class


CADLinkOptions Constructor

[image] [image]

Revit 2024 API
CADLinkOptions Constructor
CADLinkOptions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CADLinkOptions(CADLinkOptions) | Constructs a new copy of the input CADLinkOptions object.
Public method | CADLinkOptions(Boolean, ElementId) | Creates a CADLinkOptions object, specifying whether to preserve graphic overrides, and what view to use if the link's view has been deleted.

See Also

CADLinkOptions Class
CADLinkOptions Members


CADLinkOptions Constructor (CADLinkOptions)

[image]

Revit 2024 API
CADLinkOptions Constructor (CADLinkOptions)
CADLinkOptions Class See Also Send Feedback
Constructs a new copy of the input CADLinkOptions object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public CADLinkOptions(
    CADLinkOptions other
)
Visual Basic
Public Sub New ( _
    other As CADLinkOptions _
)
Visual C++
public:
CADLinkOptions(
    CADLinkOptions^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..CADLinkOptions

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

CADLinkOptions Class
CADLinkOptions Overload


CADLinkOptions Constructor (Boolean, ElementId)

[image]

Revit 2024 API
CADLinkOptions Constructor (Boolean, ElementId)
CADLinkOptions Class See Also Send Feedback
Creates a CADLinkOptions object, specifying whether to preserve graphic overrides, and what view to use if the link's view has been deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public CADLinkOptions(
    bool preserveOverrides,
    ElementId viewId
)
Visual Basic
Public Sub New ( _
    preserveOverrides As Boolean, _
    viewId As ElementId _
)
Visual C++
public:
CADLinkOptions(
    bool preserveOverrides,
    ElementId^ viewId
)

Parameters

preserveOverrides
Type: System..::..Boolean
True if Revit should preserve the link's graphic overrides on reload. False otherwise.
viewId
Type: Autodesk.Revit.DB..::..ElementId

The id of the view to use as the link's reference view, if the reference view has been deleted. Revit will ignore this value if the reference view is still in place.

The value may be ElementId.InvalidElementId, although Revit will cancel the load if the reference view is deleted.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

CADLinkOptions Class
CADLinkOptions Overload


CADLinkOptions Methods

[image] [image]

Revit 2024 API
CADLinkOptions Methods
CADLinkOptions Class See Also Send Feedback

The CADLinkOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CADLinkOptions Class


Dispose Method

[image]

Revit 2024 API
CADLinkOptions..::..Dispose Method
CADLinkOptions Class See Also Send Feedback
Releases all resources used by the CADLinkOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

CADLinkOptions Class


CADLinkOptions Properties

[image] [image]

Revit 2024 API
CADLinkOptions Properties
CADLinkOptions Class See Also Send Feedback

The CADLinkOptions type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | PreserveOverrides | Whether Revit should preserve the link's graphic overrides on reload.
Public property | ViewId | The id of the view to use as the link's reference view, if the reference view has been deleted.

See Also

CADLinkOptions Class


IsValidObject Property

[image]

Revit 2024 API
CADLinkOptions..::..IsValidObject Property
CADLinkOptions Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

CADLinkOptions Class


PreserveOverrides Property

[image]

Revit 2024 API
CADLinkOptions..::..PreserveOverrides Property
CADLinkOptions Class See Also Send Feedback
Whether Revit should preserve the link's graphic overrides on reload.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public bool PreserveOverrides { get; set; }
Visual Basic
Public Property PreserveOverrides As Boolean
    Get
    Set
Visual C++
public:
property bool PreserveOverrides {
    bool get ();
    void set (bool value);
}

See Also

CADLinkOptions Class


ViewId Property

[image]

Revit 2024 API
CADLinkOptions..::..ViewId Property
CADLinkOptions Class See Also Send Feedback
The id of the view to use as the link's reference view, if the reference view has been deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public ElementId ViewId { get; set; }
Visual Basic
Public Property ViewId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ ViewId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

CADLinkOptions Class


CADLinkType Class

[image]

Revit 2024 API
CADLinkType Class
Members See Also Send Feedback
CADLinkType represents both CAD links and CAD imports. The function IsLink can be used to distinguish between the two. CAD imports are not ExternalFileReferences; they are brought completely into the document and maintain no connection to their original file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public class CADLinkType : ElementType
Visual Basic
Public Class CADLinkType _
    Inherits ElementType
Visual C++
public ref class CADLinkType : public ElementType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..CADLinkType

See Also

CADLinkType Members


CADLinkType Members

[image] [image]

Revit 2024 API
CADLinkType Members
CADLinkType Class Methods Properties See Also Send Feedback

The CADLinkType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LoadFrom(String) | Loads or reloads the DWG link from the given file path.
Public method | LoadFrom(ExternalResourceReference) | Loads or reloads the DWG link from the given external resource reference.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | Reload()()()() | Loads or reloads the link from its currently-stored location. If the link is an external resource, Revit will contact the IExternalResourceServer to get the latest version of the link.
Public method | Reload(CADLinkOptions) | Loads or reloads the link from its currently-stored location. If the link is an external resource, Revit will contact the IExternalResourceServer to get the latest version of the link.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

CADLinkType Class


CADLinkType Methods

[image] [image]

Revit 2024 API
CADLinkType Methods
CADLinkType Class See Also Send Feedback

The CADLinkType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LoadFrom(String) | Loads or reloads the DWG link from the given file path.
Public method | LoadFrom(ExternalResourceReference) | Loads or reloads the DWG link from the given external resource reference.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | Reload()()()() | Loads or reloads the link from its currently-stored location. If the link is an external resource, Revit will contact the IExternalResourceServer to get the latest version of the link.
Public method | Reload(CADLinkOptions) | Loads or reloads the link from its currently-stored location. If the link is an external resource, Revit will contact the IExternalResourceServer to get the latest version of the link.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CADLinkType Class


LoadFrom Method

[image] [image]

Revit 2024 API
CADLinkType..::..LoadFrom Method
CADLinkType Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LoadFrom(String) | Loads or reloads the DWG link from the given file path.
Public method | LoadFrom(ExternalResourceReference) | Loads or reloads the DWG link from the given external resource reference.

See Also

CADLinkType Class
CADLinkType Members


LoadFrom Method (String)

[image]

Revit 2024 API
CADLinkType..::..LoadFrom Method (String)
CADLinkType Class See Also Send Feedback
Loads or reloads the DWG link from the given file path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public LinkLoadResult LoadFrom(
    string path
)
Visual Basic
Public Function LoadFrom ( _
    path As String _
) As LinkLoadResult
Visual C++
public:
LinkLoadResult^ LoadFrom(
    String^ path
)

Parameters

path
Type: System..::..String
A path on disk giving the location of the linked file. This path must be absolute. The link's path will remain PathType.Absolute or PathType.Relative, whichever it was before. If the link was previously to an external server location, the path type will be relative.

Return Value

An object containing the ElementId of the link and an enum value indicating any errors which occurred while trying to load.

Remarks

If the link is currently loaded, any changes made in-memory to the link's shared coordinates will be discarded.

Graphic overrides will be preserved on reload.

If the original view used to bring in this link has been deleted, Revit will cancel the load.

If there is already another link, not current link itself, using the given file path, the loading will not happen. The element id of the link using the file path will be contained in the LinkLoadResult.

If the link type identified by the given path doesn't match DWG, the load will not proceed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | The given path does not exist.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This CADLinkType represents an import and cannot be used as a link. -or- The element "this CADLinkType" is in a read-only document. -or- The link does not represent a DWG.

See Also

CADLinkType Class
LoadFrom Overload


Reload Method

[image]

Revit 2024 API
CADLinkType..::..Reload Method
CADLinkType Class See Also Send Feedback
Loads or reloads the link from its currently-stored location. If the link is an external resource, Revit will contact the IExternalResourceServer to get the latest version of the link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public LinkLoadResult Reload()
Visual Basic
Public Function Reload As LinkLoadResult
Visual C++
public:
LinkLoadResult^ Reload()

Return Value

An object containing the ElementId of the link and an enum value indicating any errors which occurred while trying to load.

Remarks

If the link is currently loaded, any changes made in-memory to the link's shared coordinates will be discarded.

Graphic overrides will be preserved on reload.

If the original view used to bring in this link has been deleted, Revit will cancel the load.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This CADLinkType represents an import and cannot be used as a link. -or- The element "this CADLinkType" is in a read-only document.

See Also

CADLinkType Class
Reload Overload


Reload Method (CADLinkOptions)

[image]

Revit 2024 API
CADLinkType..::..Reload Method (CADLinkOptions)
CADLinkType Class See Also Send Feedback
Loads or reloads the link from its currently-stored location. If the link is an external resource, Revit will contact the IExternalResourceServer to get the latest version of the link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public LinkLoadResult Reload(
    CADLinkOptions options
)
Visual Basic
Public Function Reload ( _
    options As CADLinkOptions _
) As LinkLoadResult
Visual C++
public:
LinkLoadResult^ Reload(
    CADLinkOptions^ options
)

Parameters

options
Type: Autodesk.Revit.DB..::..CADLinkOptions
Options for reloading the link. Options include the ability to preserve graphic overrides on reload.

Return Value

An object containing the ElementId of the link and an enum value indicating any errors which occurred while trying to load.

Remarks

If the link is currently loaded, any changes made in-memory to the link's shared coordinates will be discarded.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This CADLinkType represents an import and cannot be used as a link. -or- The element "this CADLinkType" is in a read-only document.

See Also

CADLinkType Class
Reload Overload


CADLinkType Properties

[image] [image]

Revit 2024 API
CADLinkType Properties
CADLinkType Class See Also Send Feedback

The CADLinkType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

CADLinkType Class


Parameter Property

[image] [image]

Revit 2024 API
CADLinkType..::..Parameter Property
CADLinkType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

CADLinkType Class
CADLinkType Members


CameraInfo Members

[image] [image]

Revit 2024 API
CameraInfo Members
CameraInfo Class Methods Properties See Also Send Feedback

The CameraInfo type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the CameraInfo
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FarDistance | Distance from eye point to far plane of view frustum along the view direction.
Public property | HorizontalExtent | Distance between left and right planes on the target plane.
Public property | IsPerspective | Identifies whether the projection is orthographic or perspective
Public property | IsPespective | Identifies whether the projection is orthographic or perspective
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | NearDistance | Distance from eye point to near plane of view frustum along the view direction.
Public property | RightOffset | Distance that the target plane is offset towards the right where right is normal to both Up direction and View direction. This offset shifts both left and right planes.
Public property | TargetDistance | Distance from eye point along view direction to target plane.
Public property | UpOffset | Distance that the target plane is offset in the direction of the Up direction. This offset shifts both top and bottom planes.
Public property | VerticalExtent | Distance between top and bottom planes on the target plane.

See Also

CameraInfo Class


CameraInfo Methods

[image] [image]

Revit 2024 API
CameraInfo Methods
CameraInfo Class See Also Send Feedback

The CameraInfo type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CameraInfo Class


Dispose Method

[image]

Revit 2024 API
CameraInfo..::..Dispose Method
CameraInfo Class See Also Send Feedback
Releases all resources used by the CameraInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

CameraInfo Class


FarDistance Property

[image]

Revit 2024 API
CameraInfo..::..FarDistance Property
CameraInfo Class See Also Send Feedback
Distance from eye point to far plane of view frustum along the view direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public double FarDistance { get; }
Visual Basic
Public ReadOnly Property FarDistance As Double
    Get
Visual C++
public:
property double FarDistance {
    double get ();
}

Remarks

This property together with NearDistance determines the depth restrictions of a view frustum.

See Also

CameraInfo Class


HorizontalExtent Property

[image]

Revit 2024 API
CameraInfo..::..HorizontalExtent Property
CameraInfo Class See Also Send Feedback
Distance between left and right planes on the target plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public double HorizontalExtent { get; }
Visual Basic
Public ReadOnly Property HorizontalExtent As Double
    Get
Visual C++
public:
property double HorizontalExtent {
    double get ();
}

See Also

CameraInfo Class


IsPerspective Property

[image]

Revit 2024 API
CameraInfo..::..IsPerspective Property
CameraInfo Class See Also Send Feedback
Identifies whether the projection is orthographic or perspective

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool IsPerspective { get; }
Visual Basic
Public ReadOnly Property IsPerspective As Boolean
    Get
Visual C++
public:
property bool IsPerspective {
    bool get ();
}

See Also

CameraInfo Class


IsValidObject Property

[image]

Revit 2024 API
CameraInfo..::..IsValidObject Property
CameraInfo Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

CameraInfo Class


NearDistance Property

[image]

Revit 2024 API
CameraInfo..::..NearDistance Property
CameraInfo Class See Also Send Feedback
Distance from eye point to near plane of view frustum along the view direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public double NearDistance { get; }
Visual Basic
Public ReadOnly Property NearDistance As Double
    Get
Visual C++
public:
property double NearDistance {
    double get ();
}

Remarks

This property together with FarDistance determines the depth restrictions of a view frustum.

See Also

CameraInfo Class


RightOffset Property

[image]

Revit 2024 API
CameraInfo..::..RightOffset Property
CameraInfo Class See Also Send Feedback
Distance that the target plane is offset towards the right where right is normal to both Up direction and View direction. This offset shifts both left and right planes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public double RightOffset { get; }
Visual Basic
Public ReadOnly Property RightOffset As Double
    Get
Visual C++
public:
property double RightOffset {
    double get ();
}

See Also

CameraInfo Class


TargetDistance Property

[image]

Revit 2024 API
CameraInfo..::..TargetDistance Property
CameraInfo Class See Also Send Feedback
Distance from eye point along view direction to target plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public double TargetDistance { get; }
Visual Basic
Public ReadOnly Property TargetDistance As Double
    Get
Visual C++
public:
property double TargetDistance {
    double get ();
}

Remarks

This value is appropriate for perspective views only. Attempts to get this value for an orthographic view can be made, but the obtained value is to be ignored.

See Also

CameraInfo Class


UpOffset Property

[image]

Revit 2024 API
CameraInfo..::..UpOffset Property
CameraInfo Class See Also Send Feedback
Distance that the target plane is offset in the direction of the Up direction. This offset shifts both top and bottom planes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public double UpOffset { get; }
Visual Basic
Public ReadOnly Property UpOffset As Double
    Get
Visual C++
public:
property double UpOffset {
    double get ();
}

See Also

CameraInfo Class


CancellationListener Members

[image] [image]

Revit 2024 API
CancellationListener Members
CancellationListener Class Methods Properties See Also Send Feedback

The CancellationListener type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the CancellationListener
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Returns true if the operation associated with this instance has been cancelled.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

CancellationListener Class


CancellationListener Methods

[image] [image]

Revit 2024 API
CancellationListener Methods
CancellationListener Class See Also Send Feedback

The CancellationListener type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Returns true if the operation associated with this instance has been cancelled.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CancellationListener Class


Dispose Method

[image]

Revit 2024 API
CancellationListener..::..Dispose Method
CancellationListener Class See Also Send Feedback
Releases all resources used by the CancellationListener

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

CancellationListener Class


IsCancelled Method

[image]

Revit 2024 API
CancellationListener..::..IsCancelled Method
CancellationListener Class See Also Send Feedback
Returns true if the operation associated with this instance has been cancelled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public bool IsCancelled()
Visual Basic
Public Function IsCancelled As Boolean
Visual C++
public:
bool IsCancelled()

See Also

CancellationListener Class


CancellationListener Properties

[image] [image]

Revit 2024 API
CancellationListener Properties
CancellationListener Class See Also Send Feedback

The CancellationListener type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

CancellationListener Class


IsValidObject Property

[image]

Revit 2024 API
CancellationListener..::..IsValidObject Property
CancellationListener Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

CancellationListener Class


Categories Class

[image]

Revit 2024 API
Categories Class
Members Example See Also Send Feedback
The Categories object is a map that contains all the top-level Category objects within the Document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class Categories : CategoryNameMap
Visual Basic
Public Class Categories _
    Inherits CategoryNameMap
Visual C++
public ref class Categories : public CategoryNameMap

Remarks

Use this object to retrieve categories by name or by BuiltInCategory id.

Examples

CopyC#
// Get settings of current document
Settings documentSettings = document.Settings;

// Get all categories of current document
Categories groups = documentSettings.Categories;

// Show the number of all the categories to the user
String prompt = "Number of all categories in current Revit document:" + groups.Size;

// get Floor category according to OST_Floors and show its name
Category floorCategory = groups.get_Item(BuiltInCategory.OST_Floors);
prompt += floorCategory.Name;

// Give the user some information
TaskDialog.Show("Revit",prompt);
CopyVB.NET
' Get settings of current document
Dim documentSettings As Settings = document.Settings

' Get all categories of current document
Dim groups As Categories = documentSettings.Categories

' Show the number of all the categories to the user
Dim prompt As [String] = "Number of all categories in current Revit document:" + groups.Size

' get Floor category according to OST_Floors and show its name
Dim floorCategory As Category = groups.Item(BuiltInCategory.OST_Floors)
prompt += floorCategory.Name

' Give the user some information
TaskDialog.Show("Revit", prompt)

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..CategoryNameMap
Autodesk.Revit.DB..::..Categories

See Also

Categories Members


Categories Members

[image] [image]

Revit 2024 API
Categories Members
Categories Class Methods Properties See Also Send Feedback

The Categories type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every category from the map, rendering it empty. (Inherited from CategoryNameMap.)
Public method | Contains | Identifies if a category which has the specified name is in the list of top-level categories. (Overrides CategoryNameMap..::..Contains(String).)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a category with the specified name from the map. (Inherited from CategoryNameMap.)
Public method | ForwardIterator | Retrieves a forward moving iterator to the map. (Overrides CategoryNameMap..::..ForwardIterator()()()().)
Public method | GetEnumerator | Retrieves a forward moving iterator to the map. (Overrides CategoryNameMap..::..GetEnumerator()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Inserts the specified category with the specified name into the map. (Overrides CategoryNameMap..::..Insert(String, Category).)
Public method | NewSubcategory | Add a new subcategory into the Autodesk Revit document.
Public method | ReverseIterator | Retrieves a backward moving iterator to the map. (Overrides CategoryNameMap..::..ReverseIterator()()()().)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Whether or not the list of top-level categories is empty. (Overrides CategoryNameMap..::..IsEmpty.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item[([( String])]) | Gets a category which has the specified name from this list of top-level categories. (Overrides CategoryNameMap..::..Item[([( String])]) .)
Public property | Item[([( BuiltInCategory])]) | Retrieves a category object corresponding to a BuiltInCategory id.
Public property | Size | The total number of top-level categories in the document. (Overrides CategoryNameMap..::..Size.)

See Also

Categories Class


Contains Method

[image]

Revit 2024 API
Categories..::..Contains Method
Categories Class See Also Send Feedback
Identifies if a category which has the specified name is in the list of top-level categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public override bool Contains(
    string name
)
Visual Basic
Public Overrides Function Contains ( _
    name As String _
) As Boolean
Visual C++
public:
virtual bool Contains(
    String^ name
) override

Parameters

name
Type: System..::..String
The name of the category to be retrieved.

Field Value

Whether the category exists in the list of top-level categories.

See Also

Categories Class


ForwardIterator Method

[image]

Revit 2024 API
Categories..::..ForwardIterator Method
Categories Class See Also Send Feedback
Retrieves a forward moving iterator to the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public override CategoryNameMapIterator ForwardIterator()
Visual Basic
Public Overrides Function ForwardIterator As CategoryNameMapIterator
Visual C++
public:
virtual CategoryNameMapIterator^ ForwardIterator() override

Return Value

A forward moving iterator to the map.

See Also

Categories Class


Insert Method

[image]

Revit 2024 API
Categories..::..Insert Method
Categories Class See Also Send Feedback
Inserts the specified category with the specified name into the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public override bool Insert(
    string key,
    Category item
)
Visual Basic
Public Overrides Function Insert ( _
    key As String, _
    item As Category _
) As Boolean
Visual C++
public:
virtual bool Insert(
    String^ key,
    Category^ item
) override

Parameters

key
Type: System..::..String
The name to be used for inserting the category into the map.
item
Type: Autodesk.Revit.DB..::..Category
The category to be inserted into the map.

Return Value

Whether or not the category was inserted into the map.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Always thrown; this list is read only.

See Also

Categories Class


NewSubcategory Method

[image]

Revit 2024 API
Categories..::..NewSubcategory Method
Categories Class Example See Also Send Feedback
Add a new subcategory into the Autodesk Revit document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Category NewSubcategory(
    Category parentCategory,
    string name
)
Visual Basic
Public Function NewSubcategory ( _
    parentCategory As Category, _
    name As String _
) As Category
Visual C++
public:
Category^ NewSubcategory(
    Category^ parentCategory,
    String^ name
)

Parameters

parentCategory
Type: Autodesk.Revit.DB..::..Category
The parent category.
name
Type: System..::..String
The new category name.

Return Value

If successful, the newly created subcategory.

Examples

CopyC#
public void AssignSubCategory(Document document, GenericForm extrusion)
{
    // create a new subcategory
    Category cat = document.OwnerFamily.FamilyCategory;
    Category subCat = document.Settings.Categories.NewSubcategory(cat, "NewSubCat");

    // create a new material and assign it to the subcategory
    ElementId materialId = Material.Create(document, "Wood Material");
    subCat.Material = document.GetElement(materialId) as Material;

    // assign the subcategory to the element
    extrusion.Subcategory = subCat;
}
CopyVB.NET
Public Sub AssignSubCategory(document As Document, extrusion As GenericForm)
    ' create a new subcategory
    Dim cat As Category = document.OwnerFamily.FamilyCategory
    Dim subCat As Category = document.Settings.Categories.NewSubcategory(cat, "NewSubCat")

    ' create a new material and assign it to the subcategory
    Dim materialId As ElementId = Material.Create(document, "Wood Material")
    subCat.Material = TryCast(document.GetElement(materialId), Material)

    ' assign the subcategory to the element
    extrusion.Subcategory = subCat
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"parentCategory" or "name"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-"parentCategory"-cannot add subcategory. Thrown when the input argument-"name"-is an illegal name.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when subcategory creation failed.

See Also

Categories Class


ReverseIterator Method

[image]

Revit 2024 API
Categories..::..ReverseIterator Method
Categories Class See Also Send Feedback
Retrieves a backward moving iterator to the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public override CategoryNameMapIterator ReverseIterator()
Visual Basic
Public Overrides Function ReverseIterator As CategoryNameMapIterator
Visual C++
public:
virtual CategoryNameMapIterator^ ReverseIterator() override

Return Value

A backward moving iterator to the map.

See Also

Categories Class


IsEmpty Property

[image]

Revit 2024 API
Categories..::..IsEmpty Property
Categories Class See Also Send Feedback
Whether or not the list of top-level categories is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public override bool IsEmpty { get; }
Visual Basic
Public Overrides ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get () override;
}

See Also

Categories Class


Item Property

[image] [image]

Revit 2024 API
Categories..::..Item Property
Categories Class See Also Send Feedback
Retrieves a category object matching an identifier.

Overload List

 | Name | Description
Public property | Item[([( String])]) | Gets a category which has the specified name from this list of top-level categories. (Overrides CategoryNameMap..::..Item[([( String])]) .)
Public property | Item[([( BuiltInCategory])]) | Retrieves a category object corresponding to a BuiltInCategory id.

See Also

Categories Class
Categories Members


Item Property (String)

[image]

Revit 2024 API
Categories..::..Item Property (String)
Categories Class See Also Send Feedback
Gets a category which has the specified name from this list of top-level categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public override Category this[
    string name
] { get; set; }
Visual Basic
Public Overrides Property Item ( _
    name As String _
) As Category
    Get
    Set
Visual C++
public:
virtual property Category^ Item[String^ name] {
    Category^ get (String^ name) override;
    void set (String^ name, Category^ value) override;
}

Parameters

name
Type: System..::..String
The name of the category to be retrieved.

Field Value

The category with the specified name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the category list does not contain the category with this name. Thrown when trying to set an item to this list of categories; this list is read only.

See Also

Categories Class
Item Overload


Item Property (BuiltInCategory)

[image]

Revit 2024 API
Categories..::..Item Property (BuiltInCategory)
Categories Class See Also Send Feedback
Retrieves a category object corresponding to a BuiltInCategory id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Category this[
    BuiltInCategory categoryId
] { get; }
Visual Basic
Public Overridable ReadOnly Property Item ( _
    categoryId As BuiltInCategory _
) As Category
    Get
Visual C++
public:
virtual property Category^ Item[BuiltInCategory categoryId] {
    Category^ get (BuiltInCategory categoryId);
}

Parameters

categoryId
Type: Autodesk.Revit.DB..::..BuiltInCategory

Remarks

Unlike the method that obtains categories by name, this routine will obtain the handle even of built-in subcategories. Since 2016 it is advised to use either [!:​Autodesk::​Revit::DB::​Category::​GetCategory(​Document,​BuiltIn​Category)] or [!:​Autodesk::​Revit::DB::​Category::​GetCategory(​Document,​ElementId)]​ method from Category class.

See Also

Categories Class
Item Overload


Size Property

[image]

Revit 2024 API
Categories..::..Size Property
Categories Class See Also Send Feedback
The total number of top-level categories in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public override int Size { get; }
Visual Basic
Public Overrides ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get () override;
}

See Also

Categories Class


Category Methods

[image] [image]

Revit 2024 API
Category Methods
Category Class See Also Send Feedback

The Category type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetBuiltInCategory | Gets the BuiltInCategory value corresponding to the given built-in category identifier.
 | GetBuiltInCategoryTypeId | Gets the ForgeTypeId identifying the given built-in category.
 | GetCategory(Document, BuiltInCategory) | Retrieves a category object corresponding to a BuiltInCategory id.
 | GetCategory(Document, ElementId) | Retrieves a category object corresponding to the category id.
Public method | GetGraphicsStyle | Gets the graphics style associated with this category for the given graphics style type.
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetLinePatternId | Gets the line pattern id associated with this category for the given graphics style type.
Public method | GetLineWeight | Retrieves the line weight assigned to the category for the given graphics style type.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsBuiltInCategory | Checks whether a ForgeTypeId identifies a built-in category.
 | IsBuiltInCategoryValid | Checks if a Category exists for a given BuiltInCategory.
Public method | SetLinePatternId | Sets the line pattern id associated with this category for the given graphics style type.
Public method | SetLineWeight | Sets the line weight for the given graphics style type.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Category Class


GetBuiltInCategory Method

[image]

Revit 2024 API
Category..::..GetBuiltInCategory Method
Category Class See Also Send Feedback
Gets the BuiltInCategory value corresponding to the given built-in category identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public static BuiltInCategory GetBuiltInCategory(
    ForgeTypeId categoryTypeId
)
Visual Basic
Public Shared Function GetBuiltInCategory ( _
    categoryTypeId As ForgeTypeId _
) As BuiltInCategory
Visual C++
public:
static BuiltInCategory GetBuiltInCategory(
    ForgeTypeId^ categoryTypeId
)

Parameters

categoryTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
The built-in category identifier.

Return Value

The BuiltInCategory value corresponding to the given built-in category identifier.

Remarks

A ForgeTypeId identifies a built-in category if it corresponds to a valid BuiltInCategory value according to Category.IsBuiltInCategory(ForgeTypeId) and Category.GetBuiltInCategoryTypeId(BuiltInCategory).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | categoryTypeId is not a built-in category identifier. See Category.IsBuiltInCategory(ForgeTypeId) and Category.GetBuiltInCategoryTypeId(BuiltInCategory).
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Category Class


GetBuiltInCategoryTypeId Method

[image]

Revit 2024 API
Category..::..GetBuiltInCategoryTypeId Method
Category Class See Also Send Feedback
Gets the ForgeTypeId identifying the given built-in category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public static ForgeTypeId GetBuiltInCategoryTypeId(
    BuiltInCategory categoryId
)
Visual Basic
Public Shared Function GetBuiltInCategoryTypeId ( _
    categoryId As BuiltInCategory _
) As ForgeTypeId
Visual C++
public:
static ForgeTypeId^ GetBuiltInCategoryTypeId(
    BuiltInCategory categoryId
)

Parameters

categoryId
Type: Autodesk.Revit.DB..::..BuiltInCategory
The built-in category.

Return Value

The identifier of the given built-in category.

Remarks

The given BuiltInCategory value must be valid according to Category.IsBuiltInCategoryValid(BuiltInCategory).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | categoryId is not a valid built-in category. See Category.IsBuiltInCategoryValid(BuiltInCategory).

See Also

Category Class


GetCategory Method

[image] [image]

Revit 2024 API
Category..::..GetCategory Method
Category Class See Also Send Feedback

Overload List

Name | Description
GetCategory(Document, BuiltInCategory) | Retrieves a category object corresponding to a BuiltInCategory id.
GetCategory(Document, ElementId) | Retrieves a category object corresponding to the category id.

See Also

Category Class
Category Members


GetCategory Method (Document, BuiltInCategory)

[image]

Revit 2024 API
Category..::..GetCategory Method (Document, BuiltInCategory)
Category Class See Also Send Feedback
Retrieves a category object corresponding to a BuiltInCategory id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public static Category GetCategory(
    Document document,
    BuiltInCategory categoryId
)
Visual Basic
Public Shared Function GetCategory ( _
    document As Document, _
    categoryId As BuiltInCategory _
) As Category
Visual C++
public:
static Category^ GetCategory(
    Document^ document,
    BuiltInCategory categoryId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
categoryId
Type: Autodesk.Revit.DB..::..BuiltInCategory
A built in category id.

Return Value

Returns a category object corresponding to a BuiltInCategory id.

See Also

Category Class
GetCategory Overload


GetGraphicsStyle Method

[image]

Revit 2024 API
Category..::..GetGraphicsStyle Method
Category Class See Also Send Feedback
Gets the graphics style associated with this category for the given graphics style type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public GraphicsStyle GetGraphicsStyle(
    GraphicsStyleType graphicsStyleType
)
Visual Basic
Public Function GetGraphicsStyle ( _
    graphicsStyleType As GraphicsStyleType _
) As GraphicsStyle
Visual C++
public:
GraphicsStyle^ GetGraphicsStyle(
    GraphicsStyleType graphicsStyleType
)

Parameters

graphicsStyleType
Type: Autodesk.Revit.DB..::..GraphicsStyleType
The type of graphics style.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the input argument-"graphicsStyleType"-is out of range.

See Also

Category Class


GetHashCode Method

[image]

Revit 2024 API
Category..::..GetHashCode Method
Category Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

Category Class


GetLineWeight Method

[image]

Revit 2024 API
Category..::..GetLineWeight Method
Category Class See Also Send Feedback
Retrieves the line weight assigned to the category for the given graphics style type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Nullable<int> GetLineWeight(
    GraphicsStyleType graphicsStyleType
)
Visual Basic
Public Function GetLineWeight ( _
    graphicsStyleType As GraphicsStyleType _
) As Nullable(Of Integer)
Visual C++
public:
Nullable<int> GetLineWeight(
    GraphicsStyleType graphicsStyleType
)

Parameters

graphicsStyleType
Type: Autodesk.Revit.DB..::..GraphicsStyleType
The type of graphics style.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the input argument-"graphicsStyleType"-is out of range.

See Also

Category Class


IsBuiltInCategoryValid Method

[image]

Revit 2024 API
Category..::..IsBuiltInCategoryValid Method
Category Class See Also Send Feedback
Checks if a Category exists for a given BuiltInCategory.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public static bool IsBuiltInCategoryValid(
    BuiltInCategory builtInCategory
)
Visual Basic
Public Shared Function IsBuiltInCategoryValid ( _
    builtInCategory As BuiltInCategory _
) As Boolean
Visual C++
public:
static bool IsBuiltInCategoryValid(
    BuiltInCategory builtInCategory
)

Parameters

builtInCategory
Type: Autodesk.Revit.DB..::..BuiltInCategory
The BuiltInCategory to check.

Remarks

Some BuiltInCategory values are obsolete and are kept for upgrade reasons. For those no Category exists.

See Also

Category Class


SetLinePatternId Method

[image]

Revit 2024 API
Category..::..SetLinePatternId Method
Category Class See Also Send Feedback
Sets the line pattern id associated with this category for the given graphics style type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public void SetLinePatternId(
    ElementId linePatternId,
    GraphicsStyleType graphicsStyleType
)
Visual Basic
Public Sub SetLinePatternId ( _
    linePatternId As ElementId, _
    graphicsStyleType As GraphicsStyleType _
)
Visual C++
public:
void SetLinePatternId(
    ElementId^ linePatternId,
    GraphicsStyleType graphicsStyleType
)

Parameters

linePatternId
Type: Autodesk.Revit.DB..::..ElementId
The line pattern id for the graphics style.
graphicsStyleType
Type: Autodesk.Revit.DB..::..GraphicsStyleType
The type of graphics style.

Remarks

  • The line pattern id will be one of the following:
  • A negative value (representing a built-in line pattern); this value can only be obtained via GetLinePatternId
  • The id of a LinePatternElement

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the input argument "linePatternId" is an illegal id.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when this category does not have stored line pattern id for this graphics style type.

See Also

Category Class


SetLineWeight Method

[image]

Revit 2024 API
Category..::..SetLineWeight Method
Category Class See Also Send Feedback
Sets the line weight for the given graphics style type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetLineWeight(
    int lineWeight,
    GraphicsStyleType graphicsStyleType
)
Visual Basic
Public Sub SetLineWeight ( _
    lineWeight As Integer, _
    graphicsStyleType As GraphicsStyleType _
)
Visual C++
public:
void SetLineWeight(
    int lineWeight,
    GraphicsStyleType graphicsStyleType
)

Parameters

lineWeight
Type: System..::..Int32
graphicsStyleType
Type: Autodesk.Revit.DB..::..GraphicsStyleType
The type of graphics style.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the input argument-"lineWeight" or "graphicsStyleType"-is out of range.

See Also

Category Class


Category Properties

[image] [image]

Revit 2024 API
Category Properties
Category Class See Also Send Feedback

The Category type exposes the following members.

Properties

 | Name | Description
Public property | AllowsBoundParameters | To check if the category can have project parameters.
Public property | AllowsVisibilityControl | Whether the visibility can be controlled by the user for this category in this view.
Public property | BuiltInCategory | Gets the BuiltInCategory value for this category.
Public property | CanAddSubcategory | Indicates if subcategories can be assigned to the category.
Public property | CategoryType | Gets the category type of this category.
Public property | HasMaterialQuantities | Identifies if elements of the category are able to report what materials they contain in what quantities.
Public property | Id | Returns the category id associated with the category object.
Public property | IsCuttable | Indicates if the category is cuttable or not.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsTagCategory | Identifies if the category is associated with a type of tag for a different category.
Public property | IsValid | Indicates if the Category is valid or not.
Public property | IsVisibleInUI | Identifies if the category is visible to the user and should be displayed in UI.
Public property | LineColor | The color of lines shown for elements of this category.
Public property | Material | Retrieves or changes the material of the category.
Public property | Name | The category name.
Public property | Parent | Returns the parent category of this category.
Public property | SubCategories | Returns a map containing all of the subcategories of this category.
Public property | Visible | Retrieves or changes the visibility of the category in the active view.

See Also

Category Class


AllowsBoundParameters Property

[image]

Revit 2024 API
Category..::..AllowsBoundParameters Property
Category Class See Also Send Feedback
To check if the category can have project parameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool AllowsBoundParameters { get; }
Visual Basic
Public ReadOnly Property AllowsBoundParameters As Boolean
    Get
Visual C++
public:
property bool AllowsBoundParameters {
    bool get ();
}

See Also

Category Class


AllowsVisibilityControl Property

[image]

Revit 2024 API
Category..::..AllowsVisibilityControl Property
Category Class See Also Send Feedback
Whether the visibility can be controlled by the user for this category in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool this[
    View view
] { get; }
Visual Basic
Public ReadOnly Property AllowsVisibilityControl ( _
    view As View _
) As Boolean
    Get
Visual C++
public:
property bool AllowsVisibilityControl[View^ view] {
    bool get (View^ view);
}

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view where visibility control might be allowed.

Remarks

There are some categories in Revit that are hidden to users in the Object Styles and Visibility dialog. Their visibility cannot be controlled for a particular view. This property identifies if the category allows visibility control (and thus allows the Visible property to be set).

See Also

Category Class


BuiltInCategory Property

[image]

Revit 2024 API
Category..::..BuiltInCategory Property
Category Class See Also Send Feedback
Gets the BuiltInCategory value for this category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public BuiltInCategory BuiltInCategory { get; }
Visual Basic
Public ReadOnly Property BuiltInCategory As BuiltInCategory
    Get
Visual C++
public:
property BuiltInCategory BuiltInCategory {
    BuiltInCategory get ();
}

Field Value

BuiltInCategory value for the category or INVALID if the category is not a built-in category.

See Also

Category Class


CanAddSubcategory Property

[image]

Revit 2024 API
Category..::..CanAddSubcategory Property
Category Class See Also Send Feedback
Indicates if subcategories can be assigned to the category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool CanAddSubcategory { get; }
Visual Basic
Public ReadOnly Property CanAddSubcategory As Boolean
    Get
Visual C++
public:
property bool CanAddSubcategory {
    bool get ();
}

See Also

Category Class


CategoryType Property

[image]

Revit 2024 API
Category..::..CategoryType Property
Category Class See Also Send Feedback
Gets the category type of this category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public CategoryType CategoryType { get; }
Visual Basic
Public ReadOnly Property CategoryType As CategoryType
    Get
Visual C++
public:
property CategoryType CategoryType {
    CategoryType get ();
}

Remarks

The category type determines if the category is shown in the Visibility/Graphics settings grouped with the model,annotation, or analytical model categories. Note that import categories are also "model" but will be shown separately in the dialog. Some categories not shown in the dialog and will return Internal for the category type.

See Also

Category Class


HasMaterialQuantities Property

[image]

Revit 2024 API
Category..::..HasMaterialQuantities Property
Category Class See Also Send Feedback
Identifies if elements of the category are able to report what materials they contain in what quantities.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool HasMaterialQuantities { get; }
Visual Basic
Public ReadOnly Property HasMaterialQuantities As Boolean
    Get
Visual C++
public:
property bool HasMaterialQuantities {
    bool get ();
}

Remarks

Get materials via the Element' property Materials; Get quantities via methods GetMaterialArea and GetMaterialVolume.

See Also

Category Class


Id Property

[image]

Revit 2024 API
Category..::..Id Property
Category Class See Also Send Feedback
Returns the category id associated with the category object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElementId Id { get; }
Visual Basic
Public ReadOnly Property Id As ElementId
    Get
Visual C++
public:
property ElementId^ Id {
    ElementId^ get ();
}

See Also

Category Class


IsTagCategory Property

[image]

Revit 2024 API
Category..::..IsTagCategory Property
Category Class See Also Send Feedback
Identifies if the category is associated with a type of tag for a different category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool IsTagCategory { get; }
Visual Basic
Public ReadOnly Property IsTagCategory As Boolean
    Get
Visual C++
public:
property bool IsTagCategory {
    bool get ();
}

Field Value

True if the category is associated with a type of tag for a different category, false if not.

See Also

Category Class


IsValid Property

[image]

Revit 2024 API
Category..::..IsValid Property
Category Class See Also Send Feedback
Indicates if the Category is valid or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023.1

Syntax

C#
public bool IsValid { get; }
Visual Basic
Public ReadOnly Property IsValid As Boolean
    Get
Visual C++
public:
property bool IsValid {
    bool get ();
}

Remarks

A valid Category is one which is present in the Document's Categories.

See Also

Category Class


IsVisibleInUI Property

[image]

Revit 2024 API
Category..::..IsVisibleInUI Property
Category Class See Also Send Feedback
Identifies if the category is visible to the user and should be displayed in UI.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public bool IsVisibleInUI { get; }
Visual Basic
Public ReadOnly Property IsVisibleInUI As Boolean
    Get
Visual C++
public:
property bool IsVisibleInUI {
    bool get ();
}

Field Value

True if the category should be displayed in UI.

See Also

Category Class


LineColor Property

[image]

Revit 2024 API
Category..::..LineColor Property
Category Class See Also Send Feedback
The color of lines shown for elements of this category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Color LineColor { get; set; }
Visual Basic
Public Property LineColor As Color
    Get
    Set
Visual C++
public:
property Color^ LineColor {
    Color^ get ();
    void set (Color^ value);
}

See Also

Category Class


Material Property

[image]

Revit 2024 API
Category..::..Material Property
Category Class See Also Send Feedback
Retrieves or changes the material of the category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Material Material { get; set; }
Visual Basic
Public Property Material As Material
    Get
    Set
Visual C++
public:
property Material^ Material {
    Material^ get ();
    void set (Material^ value);
}

Field Value

nullNothingnullptra null reference (Nothing in Visual Basic) if this category does not have a material.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: material cannot be set for annotation categories.

See Also

Category Class


Parent Property

[image]

Revit 2024 API
Category..::..Parent Property
Category Class See Also Send Feedback
Returns the parent category of this category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Category Parent { get; }
Visual Basic
Public ReadOnly Property Parent As Category
    Get
Visual C++
public:
property Category^ Parent {
    Category^ get ();
}

Return Value

nullNothingnullptra null reference (Nothing in Visual Basic) if this category a not a subcategory

See Also

Category Class


Visible Property

[image]

Revit 2024 API
Category..::..Visible Property
Category Class See Also Send Feedback
Retrieves or changes the visibility of the category in the active view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool this[
    View view
] { get; set; }
Visual Basic
Public Property Visible ( _
    view As View _
) As Boolean
    Get
    Set
Visual C++
public:
property bool Visible[View^ view] {
    bool get (View^ view);
    void set (View^ view, bool value);
}

Parameters

view
Type: Autodesk.Revit.DB..::..View

Remarks

This affects only if the category is set visible or invisible individually. Other Revit mechanisms may also affect the visibility of elements of this category, including:
  • the category classes settings for model categories, annotation categories, import categories or analytical model categories.
  • view filters
Thus setting this value may not affect the actual visibility of elements of this category in the view.

See Also

Category Class


CategoryNameMap Members

[image] [image]

Revit 2024 API
CategoryNameMap Members
CategoryNameMap Class Constructors Methods Properties See Also Send Feedback

The CategoryNameMap type exposes the following members.

Constructors

 | Name | Description
Public method | CategoryNameMap | Initializes a new instance of the CategoryNameMap class

Methods

 | Name | Description
Public method | Clear | Removes every category from the map, rendering it empty.
Public method | Contains | Tests for the existence of a category with that name within the map.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a category with the specified name from the map.
Public method | ForwardIterator | Retrieve a forward moving iterator to the map.
Public method | GetEnumerator | Retrieve a forward moving iterator to the map.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified category with the specified name into the map.
Public method | ReverseIterator | Retrieve a backward moving iterator to the map.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the map is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a category at a specified name within the map.
Public property | Size | Returns the number of categories that are in the map.

See Also

CategoryNameMap Class


CategoryNameMap Constructor

[image]

Revit 2024 API
CategoryNameMap Constructor
CategoryNameMap Class See Also Send Feedback
Initializes a new instance of the CategoryNameMap class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CategoryNameMap()
Visual Basic
Public Sub New
Visual C++
public:
CategoryNameMap()

See Also

CategoryNameMap Class


CategoryNameMap Methods

[image] [image]

Revit 2024 API
CategoryNameMap Methods
CategoryNameMap Class See Also Send Feedback

The CategoryNameMap type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every category from the map, rendering it empty.
Public method | Contains | Tests for the existence of a category with that name within the map.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a category with the specified name from the map.
Public method | ForwardIterator | Retrieve a forward moving iterator to the map.
Public method | GetEnumerator | Retrieve a forward moving iterator to the map.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified category with the specified name into the map.
Public method | ReverseIterator | Retrieve a backward moving iterator to the map.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CategoryNameMap Class


Clear Method

[image]

Revit 2024 API
CategoryNameMap..::..Clear Method
CategoryNameMap Class See Also Send Feedback
Removes every category from the map, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

CategoryNameMap Class


Contains Method

[image]

Revit 2024 API
CategoryNameMap..::..Contains Method
CategoryNameMap Class See Also Send Feedback
Tests for the existence of a category with that name within the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool Contains(
    string key
)
Visual Basic
Public Overridable Function Contains ( _
    key As String _
) As Boolean
Visual C++
public:
virtual bool Contains(
    String^ key
)

Parameters

key
Type: System..::..String
The category name to be searched for.

Return Value

The Contains method returns True if the name is within the map, otherwise False.

See Also

CategoryNameMap Class


Erase Method

[image]

Revit 2024 API
CategoryNameMap..::..Erase Method
CategoryNameMap Class See Also Send Feedback
Removes a category with the specified name from the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Erase(
    string key
)
Visual Basic
Public Overridable Function Erase ( _
    key As String _
) As Integer
Visual C++
public:
virtual int Erase(
    String^ key
)

Parameters

key
Type: System..::..String
The name of the category to be erased.

Return Value

The number of categories that were erased from the map.

See Also

CategoryNameMap Class


ForwardIterator Method

[image]

Revit 2024 API
CategoryNameMap..::..ForwardIterator Method
CategoryNameMap Class See Also Send Feedback
Retrieve a forward moving iterator to the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual CategoryNameMapIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As CategoryNameMapIterator
Visual C++
public:
virtual CategoryNameMapIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the map.

See Also

CategoryNameMap Class


Insert Method

[image]

Revit 2024 API
CategoryNameMap..::..Insert Method
CategoryNameMap Class See Also Send Feedback
Insert the specified category with the specified name into the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool Insert(
    string key,
    Category item
)
Visual Basic
Public Overridable Function Insert ( _
    key As String, _
    item As Category _
) As Boolean
Visual C++
public:
virtual bool Insert(
    String^ key,
    Category^ item
)

Parameters

key
Type: System..::..String
The name to be used for inserting the category into the map.
item
Type: Autodesk.Revit.DB..::..Category
The category to be inserted into the map.

Return Value

Returns whether the category was inserted into the map.

See Also

CategoryNameMap Class


ReverseIterator Method

[image]

Revit 2024 API
CategoryNameMap..::..ReverseIterator Method
CategoryNameMap Class See Also Send Feedback
Retrieve a backward moving iterator to the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual CategoryNameMapIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As CategoryNameMapIterator
Visual C++
public:
virtual CategoryNameMapIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the map.

See Also

CategoryNameMap Class


CategoryNameMap Properties

[image] [image]

Revit 2024 API
CategoryNameMap Properties
CategoryNameMap Class See Also Send Feedback

The CategoryNameMap type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the map is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a category at a specified name within the map.
Public property | Size | Returns the number of categories that are in the map.

See Also

CategoryNameMap Class


IsEmpty Property

[image]

Revit 2024 API
CategoryNameMap..::..IsEmpty Property
CategoryNameMap Class See Also Send Feedback
Test to see if the map is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the map is empty then True will be returned, otherwise False.

See Also

CategoryNameMap Class


Item Property

[image]

Revit 2024 API
CategoryNameMap..::..Item Property
CategoryNameMap Class See Also Send Feedback
Gets or sets a category at a specified name within the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Category this[
    string key
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    key As String _
) As Category
    Get
    Set
Visual C++
public:
virtual property Category^ Item[String^ key] {
    Category^ get (String^ key);
    void set (String^ key, Category^ value);
}

Parameters

key
Type: System..::..String
The name of the category to be set or retrieved.

Return Value

Returns the category at the specified name.

See Also

CategoryNameMap Class


CategoryNameMapIterator Members

[image] [image]

Revit 2024 API
CategoryNameMapIterator Members
CategoryNameMapIterator Class Constructors Methods Properties See Also Send Feedback

The CategoryNameMapIterator type exposes the following members.

Constructors

 | Name | Description
Public method | CategoryNameMapIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the map.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the category that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Key | Retrieves the category name that is the current focus of the iterator.

See Also

CategoryNameMapIterator Class


CategoryNameMapIterator Constructor

[image]

Revit 2024 API
CategoryNameMapIterator Constructor
CategoryNameMapIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CategoryNameMapIterator()
Visual Basic
Public Sub New
Visual C++
public:
CategoryNameMapIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CategoryNameMapIterator Class


CategoryNameMapIterator Methods

[image] [image]

Revit 2024 API
CategoryNameMapIterator Methods
CategoryNameMapIterator Class See Also Send Feedback

The CategoryNameMapIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the map.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CategoryNameMapIterator Class


MoveNext Method

[image]

Revit 2024 API
CategoryNameMapIterator..::..MoveNext Method
CategoryNameMapIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the map.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

CategoryNameMapIterator Class


CategoryNameMapIterator Properties

[image] [image]

Revit 2024 API
CategoryNameMapIterator Properties
CategoryNameMapIterator Class See Also Send Feedback

The CategoryNameMapIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the category that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Key | Retrieves the category name that is the current focus of the iterator.

See Also

CategoryNameMapIterator Class


Current Property

[image]

Revit 2024 API
CategoryNameMapIterator..::..Current Property
CategoryNameMapIterator Class See Also Send Feedback
Retrieves the category that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

CategoryNameMapIterator Class


Key Property

[image]

Revit 2024 API
CategoryNameMapIterator..::..Key Property
CategoryNameMapIterator Class See Also Send Feedback
Retrieves the category name that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual string Key { get; }
Visual Basic
Public Overridable ReadOnly Property Key As String
    Get
Visual C++
public:
virtual property String^ Key {
    String^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid key as per expected behavior of IEnumerator.

See Also

CategoryNameMapIterator Class


CategorySet Class

[image]

Revit 2024 API
CategorySet Class
Members See Also Send Feedback
A set that can contains Category objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class CategorySet : APIObject,
    IEnumerable
Visual Basic
Public Class CategorySet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class CategorySet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..CategorySet

See Also

CategorySet Members


CategorySet Members

[image] [image]

Revit 2024 API
CategorySet Members
CategorySet Class Constructors Methods Properties See Also Send Feedback

The CategorySet type exposes the following members.

Constructors

 | Name | Description
Public method | CategorySet | Initializes a new instance of the CategorySet class

Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of a category within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified category from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified category into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of categories that are in the set.

See Also

CategorySet Class


CategorySet Constructor

[image]

Revit 2024 API
CategorySet Constructor
CategorySet Class See Also Send Feedback
Initializes a new instance of the CategorySet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CategorySet()
Visual Basic
Public Sub New
Visual C++
public:
CategorySet()

See Also

CategorySet Class


Clear Method

[image]

Revit 2024 API
CategorySet..::..Clear Method
CategorySet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

CategorySet Class


Contains Method

[image]

Revit 2024 API
CategorySet..::..Contains Method
CategorySet Class See Also Send Feedback
Tests for the existence of a category within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool Contains(
    Category item
)
Visual Basic
Public Overridable Function Contains ( _
    item As Category _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Category^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..Category
The category to be searched for.

Return Value

The Contains method returns True if the category is within the set, otherwise False.

See Also

CategorySet Class


Erase Method

[image]

Revit 2024 API
CategorySet..::..Erase Method
CategorySet Class See Also Send Feedback
Removes a specified category from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Erase(
    Category item
)
Visual Basic
Public Overridable Function Erase ( _
    item As Category _
) As Integer
Visual C++
public:
virtual int Erase(
    Category^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..Category
The category to be erased.

Return Value

The number of items that were erased from the set.

See Also

CategorySet Class


ForwardIterator Method

[image]

Revit 2024 API
CategorySet..::..ForwardIterator Method
CategorySet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual CategorySetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As CategorySetIterator
Visual C++
public:
virtual CategorySetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

CategorySet Class


GetEnumerator Method

[image]

Revit 2024 API
CategorySet..::..GetEnumerator Method
CategorySet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

CategorySet Class


Insert Method

[image]

Revit 2024 API
CategorySet..::..Insert Method
CategorySet Class See Also Send Feedback
Insert the specified category into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool Insert(
    Category item
)
Visual Basic
Public Overridable Function Insert ( _
    item As Category _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Category^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..Category
The item to be inserted into the set.

Return Value

Returns whether the item was inserted into the set.

See Also

CategorySet Class


CategorySet Properties

[image] [image]

Revit 2024 API
CategorySet Properties
CategorySet Class See Also Send Feedback

The CategorySet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of categories that are in the set.

See Also

CategorySet Class


IsEmpty Property

[image]

Revit 2024 API
CategorySet..::..IsEmpty Property
CategorySet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

CategorySet Class


CategorySetIterator Class

[image]

Revit 2024 API
CategorySetIterator Class
Members See Also Send Feedback
An iterator to a category set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public abstract class CategorySetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class CategorySetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class CategorySetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..CategorySetIterator

See Also

CategorySetIterator Members


CategorySetIterator Members

[image] [image]

Revit 2024 API
CategorySetIterator Members
CategorySetIterator Class Constructors Methods Properties See Also Send Feedback

The CategorySetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | CategorySetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CategorySetIterator Class


CategorySetIterator Constructor

[image]

Revit 2024 API
CategorySetIterator Constructor
CategorySetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CategorySetIterator()
Visual Basic
Public Sub New
Visual C++
public:
CategorySetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CategorySetIterator Class


CategorySetIterator Properties

[image] [image]

Revit 2024 API
CategorySetIterator Properties
CategorySetIterator Class See Also Send Feedback

The CategorySetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CategorySetIterator Class


Ceiling Class

[image]

Revit 2024 API
Ceiling Class
Members See Also Send Feedback
Represents a ceiling in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public class Ceiling : CeilingAndFloor
Visual Basic
Public Class Ceiling _
    Inherits CeilingAndFloor
Visual C++
public ref class Ceiling : public CeilingAndFloor

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB..::..CeilingAndFloor
Autodesk.Revit.DB..::..Ceiling

See Also

Ceiling Members


Ceiling Members

[image] [image]

Revit 2024 API
Ceiling Members
Ceiling Class Methods Properties See Also Send Feedback

The Ceiling type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create(Document, IList<(Of <<'(CurveLoop>)>>), ElementId, ElementId) | Creates a new instance of ceiling within the project.
 | Create(Document, IList<(Of <<'(CurveLoop>)>>), ElementId, ElementId, Line, Double) | Creates a new instance of ceiling within the project.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchId | Returns id of the sketch.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Ceiling Class


Ceiling Methods

[image] [image]

Revit 2024 API
Ceiling Methods
Ceiling Class See Also Send Feedback

The Ceiling type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create(Document, IList<(Of <<'(CurveLoop>)>>), ElementId, ElementId) | Creates a new instance of ceiling within the project.
 | Create(Document, IList<(Of <<'(CurveLoop>)>>), ElementId, ElementId, Line, Double) | Creates a new instance of ceiling within the project.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Ceiling Class


Create Method (Document, IList(CurveLoop), ElementId, ElementId)

[image]

Revit 2024 API
Ceiling..::..Create Method (Document, IList<(Of <(<'CurveLoop>)>)>, ElementId, ElementId)
Ceiling Class Example See Also Send Feedback
Creates a new instance of ceiling within the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public static Ceiling Create(
    Document document,
    IList<CurveLoop> curveLoops,
    ElementId ceilingTypeId,
    ElementId levelId
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    curveLoops As IList(Of CurveLoop), _
    ceilingTypeId As ElementId, _
    levelId As ElementId _
) As Ceiling
Visual C++
public:
static Ceiling^ Create(
    Document^ document,
    IList<CurveLoop^>^ curveLoops,
    ElementId^ ceilingTypeId,
    ElementId^ levelId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which the new ceiling is created.
curveLoops
Type: System.Collections.Generic..::..IList<(Of <(<' CurveLoop >)>)>
An array of planar curve loops that represent the profile of the ceiling.
ceilingTypeId
Type: Autodesk.Revit.DB..::..ElementId
Id of the ceiling type to be used by the new ceiling. If InvalidElementId is passed, the default type will be used.
levelId
Type: Autodesk.Revit.DB..::..ElementId
Id of the level on which the ceiling is to be placed.

Return Value

If successful a new ceiling object within the project.

Remarks

To validate curve loop profile use BoundaryValidation.

Examples

CopyC#
Ceiling CreateCeilingAtElevation(Document document, Level level, double elevation)
{
   XYZ first = new XYZ(0, 0, 0);
   XYZ second = new XYZ(20, 0, 0);
   XYZ third = new XYZ(20, 15, 0);
   XYZ fourth = new XYZ(0, 15, 0);
   CurveLoop profile = new CurveLoop();
   profile.Append(Line.CreateBound(first, second));
   profile.Append(Line.CreateBound(second, third));
   profile.Append(Line.CreateBound(third, fourth));
   profile.Append(Line.CreateBound(fourth, first));

   var ceiling = Ceiling.Create(document, new List<CurveLoop> { profile }, ElementId.InvalidElementId, level.Id);
   Parameter param = ceiling.get_Parameter(BuiltInParameter.CEILING_HEIGHTABOVELEVEL_PARAM);
   param.Set(elevation);

   return ceiling;
}
CopyVB.NET
Private Function CreateCeilingAtElevation(ByVal document As Document, ByVal level As Level, ByVal elevation As Double) As Ceiling
    Dim first As XYZ = New XYZ(0, 0, 0)
    Dim second As XYZ = New XYZ(20, 0, 0)
    Dim third As XYZ = New XYZ(20, 15, 0)
    Dim fourth As XYZ = New XYZ(0, 15, 0)
    Dim profile As CurveLoop = New CurveLoop()
    profile.Append(Line.CreateBound(first, second))
    profile.Append(Line.CreateBound(second, third))
    profile.Append(Line.CreateBound(third, fourth))
    profile.Append(Line.CreateBound(fourth, first))
    Dim ceiling = Autodesk.Revit.DB.Ceiling.Create(document, New List(Of CurveLoop) From {
        profile
    }, ElementId.InvalidElementId, level.Id)
    Dim param As Parameter = ceiling.Parameter(BuiltInParameter.CEILING_HEIGHTABOVELEVEL_PARAM)
    param.[Set](elevation)
    Return ceiling
End Function

Private Function IExternalCommand_Execute(commandData As ExternalCommandData, ByRef message As String, elements As ElementSet) As Result Implements IExternalCommand.Execute
    Throw New NotImplementedException()
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId levelId is not a Level. -or- The ElementId ceilingTypeId does not correspond to a CeilingType. -or- The input curve loops cannot compose a valid boundary, that means: the "curveLoops" collection is empty; or some curve loops intersect with each other; or each curve loop is not closed individually; or each curve loop is not planar; or each curve loop is not in a plane parallel to the horizontal(XY) plane; or input curves contain at least one helical curve. -or- Input curves build invalid sketch. -or- Failed to create curve elements.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | Cannot generate a sketch. -or- Failed to create new element.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

Ceiling Class
Create Overload


Create Method (Document, IList(CurveLoop), ElementId, ElementId, Line, Double)

[image]

Revit 2024 API
Ceiling..::..Create Method (Document, IList<(Of <(<'CurveLoop>)>)>, ElementId, ElementId, Line, Double)
Ceiling Class Example See Also Send Feedback
Creates a new instance of ceiling within the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public static Ceiling Create(
    Document document,
    IList<CurveLoop> curveLoops,
    ElementId ceilingTypeId,
    ElementId levelId,
    Line slopeArrow,
    double slope
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    curveLoops As IList(Of CurveLoop), _
    ceilingTypeId As ElementId, _
    levelId As ElementId, _
    slopeArrow As Line, _
    slope As Double _
) As Ceiling
Visual C++
public:
static Ceiling^ Create(
    Document^ document,
    IList<CurveLoop^>^ curveLoops,
    ElementId^ ceilingTypeId,
    ElementId^ levelId,
    Line^ slopeArrow,
    double slope
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which the new ceiling is created.
curveLoops
Type: System.Collections.Generic..::..IList<(Of <(<' CurveLoop >)>)>
An array of planar curve loops that represent the profile of the ceiling.
ceilingTypeId
Type: Autodesk.Revit.DB..::..ElementId
Id of the ceiling type to be used by the new ceiling. If InvalidElementId is passed, the default type will be used.
levelId
Type: Autodesk.Revit.DB..::..ElementId
Id of the level on which the ceiling is to be placed.
slopeArrow
Type: Autodesk.Revit.DB..::..Line
A line used to control the slope angle of the Ceiling. It must be horizontal.
slope
Type: System..::..Double
The slope angle.

Return Value

If successful a new ceiling object within the project.

Remarks

To validate curve loop profile use BoundaryValidation.

Examples

CopyC#
Ceiling CreateSlopedCeiling(Document document, Level level)
{
   XYZ first = new XYZ(0, 0, 0);
   XYZ second = new XYZ(20, 0, 0);
   XYZ third = new XYZ(20, 20, 0);
   XYZ fourth = new XYZ(0, 20, 0);
   CurveLoop profile = new CurveLoop();
   profile.Append(Line.CreateBound(first, second));
   profile.Append(Line.CreateBound(second, third));
   profile.Append(Line.CreateBound(third, fourth));
   profile.Append(Line.CreateBound(fourth, first));

   Line slopeArrow = Line.CreateBound(new XYZ(10, 10, 0), new XYZ(11, 10, 0));
   return Ceiling.Create(document, new List<CurveLoop> { profile }, ElementId.InvalidElementId, level.Id, slopeArrow, Math.PI / 2);
}
CopyVB.NET
Private Function CreateSlopedCeiling(ByVal document As Document, ByVal level As Level) As Ceiling
    Dim first As XYZ = New XYZ(0, 0, 0)
    Dim second As XYZ = New XYZ(20, 0, 0)
    Dim third As XYZ = New XYZ(20, 20, 0)
    Dim fourth As XYZ = New XYZ(0, 20, 0)
    Dim profile As CurveLoop = New CurveLoop()
    profile.Append(Line.CreateBound(first, second))
    profile.Append(Line.CreateBound(second, third))
    profile.Append(Line.CreateBound(third, fourth))
    profile.Append(Line.CreateBound(fourth, first))
    Dim slopeArrow As Line = Line.CreateBound(New XYZ(10, 10, 0), New XYZ(11, 10, 0))
    Return Ceiling.Create(document, New List(Of CurveLoop) From {
        profile
    }, ElementId.InvalidElementId, level.Id, slopeArrow, Math.PI / 2)
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId levelId is not a Level. -or- The ElementId ceilingTypeId does not correspond to a CeilingType. -or- The input curve loops cannot compose a valid boundary, that means: the "curveLoops" collection is empty; or some curve loops intersect with each other; or each curve loop is not closed individually; or each curve loop is not planar; or each curve loop is not in a plane parallel to the horizontal(XY) plane; or input curves contain at least one helical curve. -or- The slopeArrow must be a horizontal line. -or- Input curves build invalid sketch. -or- Failed to create curve elements.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | Cannot generate a sketch. -or- Failed to create new element.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

Ceiling Class
Create Overload


Ceiling Properties

[image] [image]

Revit 2024 API
Ceiling Properties
Ceiling Class See Also Send Feedback

The Ceiling type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchId | Returns id of the sketch.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Ceiling Class


Parameter Property

[image] [image]

Revit 2024 API
Ceiling..::..Parameter Property
Ceiling Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Ceiling Class
Ceiling Members


SketchId Property

[image]

Revit 2024 API
Ceiling..::..SketchId Property
Ceiling Class See Also Send Feedback
Returns id of the sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public ElementId SketchId { get; }
Visual Basic
Public ReadOnly Property SketchId As ElementId
    Get
Visual C++
public:
property ElementId^ SketchId {
    ElementId^ get ();
}

See Also

Ceiling Class


CeilingAndFloor Class

[image]

Revit 2024 API
CeilingAndFloor Class
Members See Also Send Feedback
A base class that provides support for all ceiling and floor objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class CeilingAndFloor : HostObject
Visual Basic
Public Class CeilingAndFloor _
    Inherits HostObject
Visual C++
public ref class CeilingAndFloor : public HostObject

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB..::..CeilingAndFloor
Autodesk.Revit.DB.Architecture..::..BuildingPad
Autodesk.Revit.DB..::..Ceiling
Autodesk.Revit.DB..::..Floor
Autodesk.Revit.DB..::..Toposolid

See Also

CeilingAndFloor Members


CeilingAndFloor Members

[image] [image]

Revit 2024 API
CeilingAndFloor Members
CeilingAndFloor Class Methods Properties See Also Send Feedback

The CeilingAndFloor type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

CeilingAndFloor Class


CeilingAndFloor Properties

[image] [image]

Revit 2024 API
CeilingAndFloor Properties
CeilingAndFloor Class See Also Send Feedback

The CeilingAndFloor type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

CeilingAndFloor Class


Parameter Property

[image] [image]

Revit 2024 API
CeilingAndFloor..::..Parameter Property
CeilingAndFloor Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

CeilingAndFloor Class
CeilingAndFloor Members


CeilingType Class

[image]

Revit 2024 API
CeilingType Class
Members See Also Send Feedback
Represents a ceiling type in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class CeilingType : HostObjAttributes
Visual Basic
Public Class CeilingType _
    Inherits HostObjAttributes
Visual C++
public ref class CeilingType : public HostObjAttributes

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..HostObjAttributes
Autodesk.Revit.DB..::..CeilingType

See Also

CeilingType Members


CeilingType Methods

[image] [image]

Revit 2024 API
CeilingType Methods
CeilingType Class See Also Send Feedback

The CeilingType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CeilingType Class


CeilingType Properties

[image] [image]

Revit 2024 API
CeilingType Properties
CeilingType Class See Also Send Feedback

The CeilingType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ThermalProperties | The calculated and settable thermal properties of the CeilingType
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

CeilingType Class


Parameter Property

[image] [image]

Revit 2024 API
CeilingType..::..Parameter Property
CeilingType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

CeilingType Class
CeilingType Members


ThermalProperties Property

[image]

Revit 2024 API
CeilingType..::..ThermalProperties Property
CeilingType Class See Also Send Feedback
The calculated and settable thermal properties of the CeilingType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ThermalProperties ThermalProperties { get; }
Visual Basic
Public ReadOnly Property ThermalProperties As ThermalProperties
    Get
Visual C++
public:
property ThermalProperties^ ThermalProperties {
    ThermalProperties^ get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The ceiling does not have thermal properties.

See Also

CeilingType Class


CellType Enumeration

[image]

Revit 2024 API
CellType Enumeration
See Also Send Feedback
Declares the cell data type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public enum CellType
Visual Basic
Public Enumeration CellType
Visual C++
public enum class CellType

Members

Member name | Description
Text | Simple text
Graphic | Embedded graphic
Parameter | Data bound parameter
Inherited | the type is inherited from the column or section if appropriate
CombinedParameter | The type is combined parameter
CalculatedValue | The type is a calculated value
ParameterText | Read only parameter which only show formatted string
CustomField | Data bounded to a Schedule Custom Field.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


ChangePriority Enumeration

[image]

Revit 2024 API
ChangePriority Enumeration
See Also Send Feedback
Enum used to specify the priority of an Updater during execution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public enum ChangePriority
Visual Basic
Public Enumeration ChangePriority
Visual C++
public enum class ChangePriority

Members

Member name | Description
GridsLevelsReferencePlanes | Updater will modify core datums and major reference planes
Masses | Updater will modify masses
FloorsRoofsStructuralWalls | Updater will modify exterior shell of the building or floor slabs
Structure | Updater will modify structural elements like beams, braces, columns and trusses
InteriorWalls | Updater will modify interior/partition walls
DoorsOpeningsWindows | Updater will modify family instances that cut their hosts like doors and windows
MEPFixtures | Updater will modify MEP fixtures such as lights, sinks, equipment, etc.
RoomsSpacesZones | Updater will modify Rooms, MEP spaces or zones
MEPCalculations | Updater will update MEP calculated values
FreeStandingComponents | Updater will modify standalone components
Connections | Updater will modify connections
Rebar | Updater will modify rebar
MEPAccessoriesFittingsSegmentsWires | Updater will modify MEP elements such as segments, fittings and wires
MEPSystems | Updater will modify MEP systems or circuits
Views | Updater will modify views
DetailComponents | Updater will modify detail components and symbolic lines
Annotations | Updater will modify annotations

Remarks

The enumeration values are ordered in the order in which updaters associated to each priority will be run. For example, updaters associated to priority GridsLevelsReferencePlanes will run first, while updaters associated to priority Annotations will run last.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


ChangeType Class

[image]

Revit 2024 API
ChangeType Class
Members See Also Send Feedback
A class representing a change that can be detected and tracked during Dynamic Update.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class ChangeType : IDisposable
Visual Basic
Public Class ChangeType _
    Implements IDisposable
Visual C++
public ref class ChangeType : IDisposable

Remarks

ChangeTypes for specific changes can be obtained from the static methods available on Element.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ChangeType

See Also

ChangeType Members


ChangeType Members

[image] [image]

Revit 2024 API
ChangeType Members
ChangeType Class Methods Properties See Also Send Feedback

The ChangeType type exposes the following members.

Methods

 | Name | Description
 | ConcatenateChangeTypes | Creates a ChangeType that is a union of the two input ChangeTypes
Public method | Contains | Checks whether this ChangeType contains the input ChangeType
Public method | Dispose | Releases all resources used by the ChangeType
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsIdentical | Compares if two ChangeTypes are identical
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ChangeType Class


ChangeType Methods

[image] [image]

Revit 2024 API
ChangeType Methods
ChangeType Class See Also Send Feedback

The ChangeType type exposes the following members.

Methods

 | Name | Description
 | ConcatenateChangeTypes | Creates a ChangeType that is a union of the two input ChangeTypes
Public method | Contains | Checks whether this ChangeType contains the input ChangeType
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsIdentical | Compares if two ChangeTypes are identical
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ChangeType Class


ConcatenateChangeTypes Method

[image]

Revit 2024 API
ChangeType..::..ConcatenateChangeTypes Method
ChangeType Class See Also Send Feedback
Creates a ChangeType that is a union of the two input ChangeTypes

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static ChangeType ConcatenateChangeTypes(
    ChangeType changeType1,
    ChangeType changeType2
)
Visual Basic
Public Shared Function ConcatenateChangeTypes ( _
    changeType1 As ChangeType, _
    changeType2 As ChangeType _
) As ChangeType
Visual C++
public:
static ChangeType^ ConcatenateChangeTypes(
    ChangeType^ changeType1,
    ChangeType^ changeType2
)

Parameters

changeType1
Type: Autodesk.Revit.DB..::..ChangeType
First input ChangeType to be concatenated
changeType2
Type: Autodesk.Revit.DB..::..ChangeType
Second input ChangeType to be concatenated

Return Value

A new ChangeType that is a concatenation/union of the input change types

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ChangeType Class


Contains Method

[image]

Revit 2024 API
ChangeType..::..Contains Method
ChangeType Class See Also Send Feedback
Checks whether this ChangeType contains the input ChangeType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool Contains(
    ChangeType changeType
)
Visual Basic
Public Function Contains ( _
    changeType As ChangeType _
) As Boolean
Visual C++
public:
bool Contains(
    ChangeType^ changeType
)

Parameters

changeType
Type: Autodesk.Revit.DB..::..ChangeType

Return Value

True if input changeType is contained by this ChangeType

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ChangeType Class


Dispose Method

[image]

Revit 2024 API
ChangeType..::..Dispose Method
ChangeType Class See Also Send Feedback
Releases all resources used by the ChangeType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ChangeType Class


IsIdentical Method

[image]

Revit 2024 API
ChangeType..::..IsIdentical Method
ChangeType Class See Also Send Feedback
Compares if two ChangeTypes are identical

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool IsIdentical(
    ChangeType changeType
)
Visual Basic
Public Function IsIdentical ( _
    changeType As ChangeType _
) As Boolean
Visual C++
public:
bool IsIdentical(
    ChangeType^ changeType
)

Parameters

changeType
Type: Autodesk.Revit.DB..::..ChangeType
Input ChangeType to be compared

Return Value

True if the this ChangeType and input ChangeType are identical

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ChangeType Class


IsValidObject Property

[image]

Revit 2024 API
ChangeType..::..IsValidObject Property
ChangeType Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ChangeType Class


City Class

[image]

Revit 2024 API
City Class
Members Example See Also Send Feedback
An object that contains geographical location information for a known city.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class City : APIObject
Visual Basic
Public Class City _
    Inherits APIObject
Visual C++
public ref class City : public APIObject

Remarks

This object contains longitude, latitude, time zone information for a city already known by Revit. Currently Revit does not the ability to add cities to the existing list. The list of known cities can be retrieved using the Cities property on the application object.

Examples

CopyC#
double angleRatio = Math.PI / 180;   // ratio of Angle

// Get the Latitude information
double latiude = city.Latitude / angleRatio;
String latiudeInfo = "Latitude:      " + latiude.ToString();

// Get the Longitude information
double longitude = city.Longitude / angleRatio;
String longitudeInfo = "Longitude:   " + longitude.ToString();

// Get the TimeZone information
String timeZoneInfo = "TimeZone:   " + city.TimeZone.ToString();

// Set the information text box.
string cityInfo = latiudeInfo + "\n" + longitudeInfo
                            + "\n" + timeZoneInfo;
CopyVB.NET
Dim angleRatio As Double = Math.PI / 180
' ratio of Angle
' Get the Latitude information
Dim latiude As Double = city.Latitude / angleRatio
Dim latiudeInfo As [String] = "Latitude:      " & latiude.ToString()

' Get the Longitude information
Dim longitude As Double = city.Longitude / angleRatio
Dim longitudeInfo As [String] = "Longitude:   " & longitude.ToString()

' Get the TimeZone information
Dim timeZoneInfo As [String] = "TimeZone:   " & city.TimeZone.ToString()

' Set the information text box.
Dim cityInfo As String = latiudeInfo & vbLf & longitudeInfo & vbLf & timeZoneInfo

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..City

See Also

City Members


City Members

[image] [image]

Revit 2024 API
City Members
City Class Methods Properties See Also Send Feedback

The City type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Latitude | Latitude of the city
Public property | Longitude | Longitude of the city
Public property | Name | The name of the city
Public property | TimeZone | Time-zone in which the city resides
Public property | WeatherStation | An identifier for the nearest weather station

See Also

City Class


City Methods

[image] [image]

Revit 2024 API
City Methods
City Class See Also Send Feedback

The City type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

City Class


City Properties

[image] [image]

Revit 2024 API
City Properties
City Class See Also Send Feedback

The City type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Latitude | Latitude of the city
Public property | Longitude | Longitude of the city
Public property | Name | The name of the city
Public property | TimeZone | Time-zone in which the city resides
Public property | WeatherStation | An identifier for the nearest weather station

See Also

City Class


Latitude Property

[image]

Revit 2024 API
City..::..Latitude Property
City Class See Also Send Feedback
Latitude of the city

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double Latitude { get; }
Visual Basic
Public ReadOnly Property Latitude As Double
    Get
Visual C++
public:
property double Latitude {
    double get ();
}

Remarks

A read only property that contains the latitude of the city. The value returned is in radians, ranging from -PI to +PI.

See Also

City Class


Name Property

[image]

Revit 2024 API
City..::..Name Property
City Class See Also Send Feedback
The name of the city

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

Remarks

A read only string property that contains the name of the city, such as Boston.

See Also

City Class


TimeZone Property

[image]

Revit 2024 API
City..::..TimeZone Property
City Class See Also Send Feedback
Time-zone in which the city resides

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double TimeZone { get; }
Visual Basic
Public ReadOnly Property TimeZone As Double
    Get
Visual C++
public:
property double TimeZone {
    double get ();
}

Remarks

A read only property that returns the time zone in which the city resides. The value is in hours, ranging from +12 hours to -12 hours with 0 being GMT.

See Also

City Class


WeatherStation Property

[image]

Revit 2024 API
City..::..WeatherStation Property
City Class See Also Send Feedback
An identifier for the nearest weather station

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public string WeatherStation { get; }
Visual Basic
Public ReadOnly Property WeatherStation As String
    Get
Visual C++
public:
property String^ WeatherStation {
    String^ get ();
}

Remarks

A read only string property that contains an identifier of the nearest weather station.

See Also

City Class


CitySet Class

[image]

Revit 2024 API
CitySet Class
Members See Also Send Feedback
An set that contains cities.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class CitySet : APIObject, IEnumerable
Visual Basic
Public Class CitySet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class CitySet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..CitySet

See Also

CitySet Members


CitySet Members

[image] [image]

Revit 2024 API
CitySet Members
CitySet Class Constructors Methods Properties See Also Send Feedback

The CitySet type exposes the following members.

Constructors

 | Name | Description
Public method | CitySet | Initializes a new instance of the CitySet class

Methods

 | Name | Description
Public method | Clear | Removes every city from the set, rendering it empty.
Public method | Contains | Tests for the existence of a city within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified city from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified city into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of cities that are in the set.

See Also

CitySet Class


CitySet Constructor

[image]

Revit 2024 API
CitySet Constructor
CitySet Class See Also Send Feedback
Initializes a new instance of the CitySet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CitySet()
Visual Basic
Public Sub New
Visual C++
public:
CitySet()

See Also

CitySet Class


CitySet Methods

[image] [image]

Revit 2024 API
CitySet Methods
CitySet Class See Also Send Feedback

The CitySet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every city from the set, rendering it empty.
Public method | Contains | Tests for the existence of a city within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified city from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified city into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CitySet Class


Clear Method

[image]

Revit 2024 API
CitySet..::..Clear Method
CitySet Class See Also Send Feedback
Removes every city from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

CitySet Class


Contains Method

[image]

Revit 2024 API
CitySet..::..Contains Method
CitySet Class See Also Send Feedback
Tests for the existence of a city within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool Contains(
    City item
)
Visual Basic
Public Overridable Function Contains ( _
    item As City _
) As Boolean
Visual C++
public:
virtual bool Contains(
    City^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..City
The city to be searched for.

Return Value

The Contains method returns True if the city is within the set, otherwise False.

See Also

CitySet Class


Erase Method

[image]

Revit 2024 API
CitySet..::..Erase Method
CitySet Class See Also Send Feedback
Removes a specified city from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Erase(
    City item
)
Visual Basic
Public Overridable Function Erase ( _
    item As City _
) As Integer
Visual C++
public:
virtual int Erase(
    City^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..City
The city to be erased.

Return Value

The number of cities that were erased from the set.

See Also

CitySet Class


ForwardIterator Method

[image]

Revit 2024 API
CitySet..::..ForwardIterator Method
CitySet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual CitySetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As CitySetIterator
Visual C++
public:
virtual CitySetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

CitySet Class


GetEnumerator Method

[image]

Revit 2024 API
CitySet..::..GetEnumerator Method
CitySet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

CitySet Class


ReverseIterator Method

[image]

Revit 2024 API
CitySet..::..ReverseIterator Method
CitySet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual CitySetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As CitySetIterator
Visual C++
public:
virtual CitySetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

CitySet Class


IsEmpty Property

[image]

Revit 2024 API
CitySet..::..IsEmpty Property
CitySet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

CitySet Class


Size Property

[image]

Revit 2024 API
CitySet..::..Size Property
CitySet Class See Also Send Feedback
Returns the number of cities that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

CitySet Class


CitySetIterator Members

[image] [image]

Revit 2024 API
CitySetIterator Members
CitySetIterator Class Constructors Methods Properties See Also Send Feedback

The CitySetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | CitySetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CitySetIterator Class


CitySetIterator Constructor

[image]

Revit 2024 API
CitySetIterator Constructor
CitySetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CitySetIterator()
Visual Basic
Public Sub New
Visual C++
public:
CitySetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CitySetIterator Class


MoveNext Method

[image]

Revit 2024 API
CitySetIterator..::..MoveNext Method
CitySetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

CitySetIterator Class


Reset Method

[image]

Revit 2024 API
CitySetIterator..::..Reset Method
CitySetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

CitySetIterator Class


CitySetIterator Properties

[image] [image]

Revit 2024 API
CitySetIterator Properties
CitySetIterator Class See Also Send Feedback

The CitySetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CitySetIterator Class


Current Property

[image]

Revit 2024 API
CitySetIterator..::..Current Property
CitySetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

CitySetIterator Class


ClassificationEntries Class

[image]

Revit 2024 API
ClassificationEntries Class
Members See Also Send Feedback
A collection of ClassificationEntry objects that make up the classification table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public class ClassificationEntries : KeyBasedTreeEntries
Visual Basic
Public Class ClassificationEntries _
    Inherits KeyBasedTreeEntries
Visual C++
public ref class ClassificationEntries : public KeyBasedTreeEntries

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..KeyBasedTreeEntries
Autodesk.Revit.DB..::..ClassificationEntries

See Also

ClassificationEntries Members


ClassificationEntries Members

[image] [image]

Revit 2024 API
ClassificationEntries Members
ClassificationEntries Class Methods Properties See Also Send Feedback

The ClassificationEntries type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from KeyBasedTreeEntries.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindEntry | Finds the KeyBasedTreeEntry associated with the given key value. (Inherited from KeyBasedTreeEntries.)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection. (Inherited from KeyBasedTreeEntries.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from KeyBasedTreeEntries.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetKeyBasedTreeEntriesIterator | Returns a KeyBasedTreeEntriesIterator that iterates through the collection. (Inherited from KeyBasedTreeEntries.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | LoadClassificationEntriesFromFile | Loads the contents of a classification text file into the provided KeyBasedTreeEntriesLoadContent.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from KeyBasedTreeEntries.)

See Also

ClassificationEntries Class


ClassificationEntries Methods

[image] [image]

Revit 2024 API
ClassificationEntries Methods
ClassificationEntries Class See Also Send Feedback

The ClassificationEntries type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from KeyBasedTreeEntries.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindEntry | Finds the KeyBasedTreeEntry associated with the given key value. (Inherited from KeyBasedTreeEntries.)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection. (Inherited from KeyBasedTreeEntries.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from KeyBasedTreeEntries.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetKeyBasedTreeEntriesIterator | Returns a KeyBasedTreeEntriesIterator that iterates through the collection. (Inherited from KeyBasedTreeEntries.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | LoadClassificationEntriesFromFile | Loads the contents of a classification text file into the provided KeyBasedTreeEntriesLoadContent.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ClassificationEntries Class


LoadClassificationEntriesFromFile Method

[image]

Revit 2024 API
ClassificationEntries..::..LoadClassificationEntriesFromFile Method
ClassificationEntries Class See Also Send Feedback
Loads the contents of a classification text file into the provided KeyBasedTreeEntriesLoadContent.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static bool LoadClassificationEntriesFromFile(
    string filePath,
    KeyBasedTreeEntriesLoadContent loadContent
)
Visual Basic
Public Shared Function LoadClassificationEntriesFromFile ( _
    filePath As String, _
    loadContent As KeyBasedTreeEntriesLoadContent _
) As Boolean
Visual C++
public:
static bool LoadClassificationEntriesFromFile(
    String^ filePath,
    KeyBasedTreeEntriesLoadContent^ loadContent
)

Parameters

filePath
Type: System..::..String
The full path of the existing classification file.
loadContent
Type: Autodesk.Revit.DB..::..KeyBasedTreeEntriesLoadContent
The classification entries read from the filePath will be added to this object. A KeyBasedTreeEntriesLoadContent object will also be updated to contain status information, including information about any errors that occurred while reading the keynote entries from the specified file.

Return Value

True if reading the keynote file succeeds; False if the classification file cannot be read.

Remarks

The entries read from the file will be added to any existing entries read from other files before this reading operation in the provided KeyBasedTreeEntriesLoadContent. if file A was read, and then file B was failed to read, all the entries from file A will still be there to build KeynoteEntries object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | filePath is an empty string. -or- The KeyBasedTreeEntries object owned by this KeyBasedTreeEntriesLoadContent object is built already. Adding more KeyBasedTreeEntries as well as repeated building, is not supported.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidPathArgumentException | The destination file name includes one or more invalid characters.

See Also

ClassificationEntries Class


ClassificationEntries Properties

[image] [image]

Revit 2024 API
ClassificationEntries Properties
ClassificationEntries Class See Also Send Feedback

The ClassificationEntries type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from KeyBasedTreeEntries.)

See Also

ClassificationEntries Class


ClassificationEntry Class

[image]

Revit 2024 API
ClassificationEntry Class
Members See Also Send Feedback
Represents an entry in the classification table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public class ClassificationEntry : KeyBasedTreeEntry
Visual Basic
Public Class ClassificationEntry _
    Inherits KeyBasedTreeEntry
Visual C++
public ref class ClassificationEntry : public KeyBasedTreeEntry

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..KeyBasedTreeEntry
Autodesk.Revit.DB..::..ClassificationEntry

See Also

ClassificationEntry Members


ClassificationEntry Members

[image] [image]

Revit 2024 API
ClassificationEntry Members
ClassificationEntry Class Constructors Methods Properties See Also Send Feedback

The ClassificationEntry type exposes the following members.

Constructors

 | Name | Description
Public method | ClassificationEntry | Constructs a ClassificationEntry object

Methods

 | Name | Description
Public method | Dispose | (Inherited from KeyBasedTreeEntry.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetChildrenKeys | Gets a collection containing the keys of all children entry objects from this entry. (Inherited from KeyBasedTreeEntry.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasBadCategoryId | Checks if the category id is Revit BuiltInCategory id.
Public method | HasBadLevel | Checks if the level is an integer in range between 1 and 5 inclusive.
Public method | HasInvalidKey | Checks if the key matches the level and parent key.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CategoryId | The id of the category associated with this entry.
Public property | Description | The description associated with this entry.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from KeyBasedTreeEntry.)
Public property | Key | The key of this entry. (Inherited from KeyBasedTreeEntry.)
Public property | Level | The entry level in the classification table. The expected range is between 1 and 5 inclusive.
Public property | ParentKey | The parent key of this entry. (Inherited from KeyBasedTreeEntry.)

See Also

ClassificationEntry Class


ClassificationEntry Constructor

[image]

Revit 2024 API
ClassificationEntry Constructor
ClassificationEntry Class See Also Send Feedback
Constructs a ClassificationEntry object

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public ClassificationEntry(
    string key,
    string parentKey,
    string description,
    int level,
    ElementId categoryId
)
Visual Basic
Public Sub New ( _
    key As String, _
    parentKey As String, _
    description As String, _
    level As Integer, _
    categoryId As ElementId _
)
Visual C++
public:
ClassificationEntry(
    String^ key,
    String^ parentKey,
    String^ description,
    int level,
    ElementId^ categoryId
)

Parameters

key
Type: System..::..String
The key of this ClassificationEntry.
parentKey
Type: System..::..String
The parent key of this ClassificationEntry.
description
Type: System..::..String
The description associated with this ClassificationEntry.
level
Type: System..::..Int32
The level of this ClassficationEntry.
categoryId
Type: Autodesk.Revit.DB..::..ElementId
The category id of this ClassificationEntry. The category can be invalidElementId, otherwise it must represent Revit existing category.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | key is an empty string. -or- The categoryId is not appropriate category id for classfication entry.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ClassificationEntry Class


ClassificationEntry Methods

[image] [image]

Revit 2024 API
ClassificationEntry Methods
ClassificationEntry Class See Also Send Feedback

The ClassificationEntry type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from KeyBasedTreeEntry.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetChildrenKeys | Gets a collection containing the keys of all children entry objects from this entry. (Inherited from KeyBasedTreeEntry.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasBadCategoryId | Checks if the category id is Revit BuiltInCategory id.
Public method | HasBadLevel | Checks if the level is an integer in range between 1 and 5 inclusive.
Public method | HasInvalidKey | Checks if the key matches the level and parent key.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ClassificationEntry Class


HasBadCategoryId Method

[image]

Revit 2024 API
ClassificationEntry..::..HasBadCategoryId Method
ClassificationEntry Class See Also Send Feedback
Checks if the category id is Revit BuiltInCategory id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool HasBadCategoryId()
Visual Basic
Public Function HasBadCategoryId As Boolean
Visual C++
public:
bool HasBadCategoryId()

Return Value

True if the category id is not Revit BuiltInCategory id. False otherwise.

See Also

ClassificationEntry Class


HasBadLevel Method

[image]

Revit 2024 API
ClassificationEntry..::..HasBadLevel Method
ClassificationEntry Class See Also Send Feedback
Checks if the level is an integer in range between 1 and 5 inclusive.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool HasBadLevel()
Visual Basic
Public Function HasBadLevel As Boolean
Visual C++
public:
bool HasBadLevel()

Return Value

True if the level is not an integer from 1 to 5 inclusive. False otherwise.

See Also

ClassificationEntry Class


HasInvalidKey Method

[image]

Revit 2024 API
ClassificationEntry..::..HasInvalidKey Method
ClassificationEntry Class See Also Send Feedback
Checks if the key matches the level and parent key.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool HasInvalidKey()
Visual Basic
Public Function HasInvalidKey As Boolean
Visual C++
public:
bool HasInvalidKey()

Return Value

True if the key doesn't matach the level and parent key. False otherwise.

See Also

ClassificationEntry Class


ClassificationEntry Properties

[image] [image]

Revit 2024 API
ClassificationEntry Properties
ClassificationEntry Class See Also Send Feedback

The ClassificationEntry type exposes the following members.

Properties

 | Name | Description
Public property | CategoryId | The id of the category associated with this entry.
Public property | Description | The description associated with this entry.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from KeyBasedTreeEntry.)
Public property | Key | The key of this entry. (Inherited from KeyBasedTreeEntry.)
Public property | Level | The entry level in the classification table. The expected range is between 1 and 5 inclusive.
Public property | ParentKey | The parent key of this entry. (Inherited from KeyBasedTreeEntry.)

See Also

ClassificationEntry Class


CategoryId Property

[image]

Revit 2024 API
ClassificationEntry..::..CategoryId Property
ClassificationEntry Class See Also Send Feedback
The id of the category associated with this entry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public ElementId CategoryId { get; }
Visual Basic
Public ReadOnly Property CategoryId As ElementId
    Get
Visual C++
public:
property ElementId^ CategoryId {
    ElementId^ get ();
}

See Also

ClassificationEntry Class


Description Property

[image]

Revit 2024 API
ClassificationEntry..::..Description Property
ClassificationEntry Class See Also Send Feedback
The description associated with this entry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public string Description { get; }
Visual Basic
Public ReadOnly Property Description As String
    Get
Visual C++
public:
property String^ Description {
    String^ get ();
}

See Also

ClassificationEntry Class


Level Property

[image]

Revit 2024 API
ClassificationEntry..::..Level Property
ClassificationEntry Class See Also Send Feedback
The entry level in the classification table. The expected range is between 1 and 5 inclusive.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public int Level { get; }
Visual Basic
Public ReadOnly Property Level As Integer
    Get
Visual C++
public:
property int Level {
    int get ();
}

See Also

ClassificationEntry Class


ClosestPointsPairBetweenTwoCurves Class

[image]

Revit 2024 API
ClosestPointsPairBetweenTwoCurves Class
Members See Also Send Feedback
This class captures results of computation of closest points between two generic curves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018.1

Syntax

C#
public class ClosestPointsPairBetweenTwoCurves : IDisposable
Visual Basic
Public Class ClosestPointsPairBetweenTwoCurves _
    Implements IDisposable
Visual C++
public ref class ClosestPointsPairBetweenTwoCurves : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ClosestPointsPairBetweenTwoCurves

See Also

ClosestPointsPairBetweenTwoCurves Members


ClosestPointsPairBetweenTwoCurves Members

[image] [image]

Revit 2024 API
ClosestPointsPairBetweenTwoCurves Members
ClosestPointsPairBetweenTwoCurves Class Constructors Methods Properties See Also Send Feedback

The ClosestPointsPairBetweenTwoCurves type exposes the following members.

Constructors

 | Name | Description
Public method | ClosestPointsPairBetweenTwoCurves()()()() | Obtain a new instance of ClosestPointsPairBetweenTwoCurves class.
Public method | ClosestPointsPairBetweenTwoCurves(ClosestPointsPairBetweenTwoCurves) | Creates a copy of the ClosestPointsPairBetweenTwoCurves.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ClosestPointsPairBetweenTwoCurves
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Distance | Distance from point on first curve to the point on second curve.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ParameterOnFirstCurve | 1d raw (not normalized) parameter of the point on the first curve.
Public property | ParameterOnSecondCurve | 1d raw (not normalized) parameter of the point on the second curve.
Public property | XYZPointOnFirstCurve | Point on the first curve in 3d coordinates.
Public property | XYZPointOnSecondCurve | Point on the second curve in 3d coordinates.

See Also

ClosestPointsPairBetweenTwoCurves Class


ClosestPointsPairBetweenTwoCurves Constructor

[image] [image]

Revit 2024 API
ClosestPointsPairBetweenTwoCurves Constructor
ClosestPointsPairBetweenTwoCurves Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ClosestPointsPairBetweenTwoCurves()()()() | Obtain a new instance of ClosestPointsPairBetweenTwoCurves class.
Public method | ClosestPointsPairBetweenTwoCurves(ClosestPointsPairBetweenTwoCurves) | Creates a copy of the ClosestPointsPairBetweenTwoCurves.

See Also

ClosestPointsPairBetweenTwoCurves Class
ClosestPointsPairBetweenTwoCurves Members


ClosestPointsPairBetweenTwoCurves Constructor

[image]

Revit 2024 API
ClosestPointsPairBetweenTwoCurves Constructor
ClosestPointsPairBetweenTwoCurves Class See Also Send Feedback
Obtain a new instance of ClosestPointsPairBetweenTwoCurves class.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018.1

Syntax

C#
public ClosestPointsPairBetweenTwoCurves()
Visual Basic
Public Sub New
Visual C++
public:
ClosestPointsPairBetweenTwoCurves()

See Also

ClosestPointsPairBetweenTwoCurves Class
ClosestPointsPairBetweenTwoCurves Overload


ClosestPointsPairBetweenTwoCurves Constructor (ClosestPointsPairBetweenTwoCurves)

[image]

Revit 2024 API
ClosestPointsPairBetweenTwoCurves Constructor (ClosestPointsPairBetweenTwoCurves)
ClosestPointsPairBetweenTwoCurves Class See Also Send Feedback
Creates a copy of the ClosestPointsPairBetweenTwoCurves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018.1

Syntax

C#
public ClosestPointsPairBetweenTwoCurves(
    ClosestPointsPairBetweenTwoCurves other
)
Visual Basic
Public Sub New ( _
    other As ClosestPointsPairBetweenTwoCurves _
)
Visual C++
public:
ClosestPointsPairBetweenTwoCurves(
    ClosestPointsPairBetweenTwoCurves^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..ClosestPointsPairBetweenTwoCurves

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ClosestPointsPairBetweenTwoCurves Class
ClosestPointsPairBetweenTwoCurves Overload


ClosestPointsPairBetweenTwoCurves Methods

[image] [image]

Revit 2024 API
ClosestPointsPairBetweenTwoCurves Methods
ClosestPointsPairBetweenTwoCurves Class See Also Send Feedback

The ClosestPointsPairBetweenTwoCurves type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ClosestPointsPairBetweenTwoCurves Class


ClosestPointsPairBetweenTwoCurves Properties

[image] [image]

Revit 2024 API
ClosestPointsPairBetweenTwoCurves Properties
ClosestPointsPairBetweenTwoCurves Class See Also Send Feedback

The ClosestPointsPairBetweenTwoCurves type exposes the following members.

Properties

 | Name | Description
Public property | Distance | Distance from point on first curve to the point on second curve.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ParameterOnFirstCurve | 1d raw (not normalized) parameter of the point on the first curve.
Public property | ParameterOnSecondCurve | 1d raw (not normalized) parameter of the point on the second curve.
Public property | XYZPointOnFirstCurve | Point on the first curve in 3d coordinates.
Public property | XYZPointOnSecondCurve | Point on the second curve in 3d coordinates.

See Also

ClosestPointsPairBetweenTwoCurves Class


Distance Property

[image]

Revit 2024 API
ClosestPointsPairBetweenTwoCurves..::..Distance Property
ClosestPointsPairBetweenTwoCurves Class See Also Send Feedback
Distance from point on first curve to the point on second curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018.1

Syntax

C#
public double Distance { get; set; }
Visual Basic
Public Property Distance As Double
    Get
    Set
Visual C++
public:
property double Distance {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The property has not been set by the method providing the result.

See Also

ClosestPointsPairBetweenTwoCurves Class


ParameterOnFirstCurve Property

[image]

Revit 2024 API
ClosestPointsPairBetweenTwoCurves..::..ParameterOnFirstCurve Property
ClosestPointsPairBetweenTwoCurves Class See Also Send Feedback
1d raw (not normalized) parameter of the point on the first curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018.1

Syntax

C#
public double ParameterOnFirstCurve { get; set; }
Visual Basic
Public Property ParameterOnFirstCurve As Double
    Get
    Set
Visual C++
public:
property double ParameterOnFirstCurve {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The property has not been set by the method providing the result.

See Also

ClosestPointsPairBetweenTwoCurves Class


XYZPointOnFirstCurve Property

[image]

Revit 2024 API
ClosestPointsPairBetweenTwoCurves..::..XYZPointOnFirstCurve Property
ClosestPointsPairBetweenTwoCurves Class See Also Send Feedback
Point on the first curve in 3d coordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018.1

Syntax

C#
public XYZ XYZPointOnFirstCurve { get; set; }
Visual Basic
Public Property XYZPointOnFirstCurve As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ XYZPointOnFirstCurve {
    XYZ^ get ();
    void set (XYZ^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The property has not been set by the method providing the result.

See Also

ClosestPointsPairBetweenTwoCurves Class


XYZPointOnSecondCurve Property

[image]

Revit 2024 API
ClosestPointsPairBetweenTwoCurves..::..XYZPointOnSecondCurve Property
ClosestPointsPairBetweenTwoCurves Class See Also Send Feedback
Point on the second curve in 3d coordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018.1

Syntax

C#
public XYZ XYZPointOnSecondCurve { get; set; }
Visual Basic
Public Property XYZPointOnSecondCurve As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ XYZPointOnSecondCurve {
    XYZ^ get ();
    void set (XYZ^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The property has not been set by the method providing the result.

See Also

ClosestPointsPairBetweenTwoCurves Class


Color Class

[image]

Revit 2024 API
Color Class
Members See Also Send Feedback
Represents a color in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class Color : APIObject
Visual Basic
Public Class Color _
    Inherits APIObject
Visual C++
public ref class Color : public APIObject

Remarks

Colors obtained from some API methods may represent an uninitialized/invalid color. You can identify these using the IsValid property.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..Color

See Also

Color Members


Color Members

[image] [image]

Revit 2024 API
Color Members
Color Class Constructors Methods Properties See Also Send Feedback

The Color type exposes the following members.

Constructors

 | Name | Description
Public method | Color | Constructor that takes the red, green and blue channels of the color.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Blue | Get the blue channel of the color. Setting a channel is obsolete in Autodesk Revit 2013. Please create a new color instead.
Public property | Green | Get the green channel of the color. Setting a channel is obsolete in Autodesk Revit 2013. Please create a new color instead.
 | InvalidColorValue | Get the invalid Color whose IntegerValue is -1.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsValid | Identifies if the color represents a valid color, or an uninitialized/invalid value.
Public property | Red | Get the red channel of the color. Setting a channel is obsolete in Autodesk Revit 2013. Please create a new color instead.

See Also

Color Class


Color Methods

[image] [image]

Revit 2024 API
Color Methods
Color Class See Also Send Feedback

The Color type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Color Class


Color Properties

[image] [image]

Revit 2024 API
Color Properties
Color Class See Also Send Feedback

The Color type exposes the following members.

Properties

 | Name | Description
Public property | Blue | Get the blue channel of the color. Setting a channel is obsolete in Autodesk Revit 2013. Please create a new color instead.
Public property | Green | Get the green channel of the color. Setting a channel is obsolete in Autodesk Revit 2013. Please create a new color instead.
 | InvalidColorValue | Get the invalid Color whose IntegerValue is -1.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsValid | Identifies if the color represents a valid color, or an uninitialized/invalid value.
Public property | Red | Get the red channel of the color. Setting a channel is obsolete in Autodesk Revit 2013. Please create a new color instead.

See Also

Color Class


InvalidColorValue Property

[image]

Revit 2024 API
Color..::..InvalidColorValue Property
Color Class See Also Send Feedback
Get the invalid Color whose IntegerValue is -1.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static Color InvalidColorValue { get; }
Visual Basic
Public Shared ReadOnly Property InvalidColorValue As Color
    Get
Visual C++
public:
static property Color^ InvalidColorValue {
    Color^ get ();
}

See Also

Color Class


IsValid Property

[image]

Revit 2024 API
Color..::..IsValid Property
Color Class See Also Send Feedback
Identifies if the color represents a valid color, or an uninitialized/invalid value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public bool IsValid { get; }
Visual Basic
Public ReadOnly Property IsValid As Boolean
    Get
Visual C++
public:
property bool IsValid {
    bool get ();
}

See Also

Color Class


Red Property

[image]

Revit 2024 API
Color..::..Red Property
Color Class See Also Send Feedback
Get the red channel of the color. Setting a channel is obsolete in Autodesk Revit 2013. Please create a new color instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public byte Red { get; set; }
Visual Basic
Public Property Red As Byte
    Get
    Set
Visual C++
public:
property unsigned char Red {
    unsigned char get ();
    void set (unsigned char value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When getting the value: the color is invalid or uninitialized.

See Also

Color Class


ColorBackgroundSettings Members

[image] [image]

Revit 2024 API
ColorBackgroundSettings Members
ColorBackgroundSettings Class Methods Properties See Also Send Feedback

The ColorBackgroundSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from BackgroundSettings.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Color | The color of the rendering background.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BackgroundSettings.)

See Also

ColorBackgroundSettings Class


ColorBackgroundSettings Methods

[image] [image]

Revit 2024 API
ColorBackgroundSettings Methods
ColorBackgroundSettings Class See Also Send Feedback

The ColorBackgroundSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from BackgroundSettings.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ColorBackgroundSettings Class


ColorBackgroundSettings Properties

[image] [image]

Revit 2024 API
ColorBackgroundSettings Properties
ColorBackgroundSettings Class See Also Send Feedback

The ColorBackgroundSettings type exposes the following members.

Properties

 | Name | Description
Public property | Color | The color of the rendering background.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BackgroundSettings.)

See Also

ColorBackgroundSettings Class


Color Property

[image]

Revit 2024 API
ColorBackgroundSettings..::..Color Property
ColorBackgroundSettings Class See Also Send Feedback
The color of the rendering background.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public Color Color { get; set; }
Visual Basic
Public Property Color As Color
    Get
    Set
Visual C++
public:
property Color^ Color {
    Color^ get ();
    void set (Color^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ColorBackgroundSettings Class


ColorDepthType Enumeration

[image]

Revit 2024 API
ColorDepthType Enumeration
See Also Send Feedback
An enumerated type listing all Color Depth types of Print Setting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum ColorDepthType
Visual Basic
Public Enumeration ColorDepthType
Visual C++
public enum class ColorDepthType

Members

Member name | Description
BlackLine | The type of Color Depth is Black Line.
GrayScale | The type of Color Depth is Gray Scale.
Color | The type of Color Depth is Color.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


ColorFillLegend Class

[image]

Revit 2024 API
ColorFillLegend Class
Members See Also Send Feedback
Represents color fill legend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public class ColorFillLegend : Element
Visual Basic
Public Class ColorFillLegend _
    Inherits Element
Visual C++
public ref class ColorFillLegend : public Element

Remarks

Color fill legend is a 2D annotation element, it can be created through Create(Document, ElementId, ElementId, XYZ) with specified category of color fill scheme, if there exists a valid color fill scheme activated for the category in the view. After a legend is created, its content and layout will keep consistent with the active color fill scheme of the view. You can adjust its position through Origin property, or manually maintain its layout through Height property andGetColumnWidths()()()()/[M:Autodesk.Revit.DB.ColorFillLegend.SetColumnWidths(System.Collections.Generic.IList`1{System.Double})] methods.

Notes:

  1. GetColorFillSchemeId(ElementId) could be used to retrieve the corresponding color fill scheme of this legend, through the [!:Autodesk::Revit::DB::View::ColorFillCategoryId] and OwnerViewId properties. Note that there could only exist one active scheme for all spatial categories (rooms, areas, and zones) in one view.
  2. Once the height and column widths are explicitly set, they will be fixed even if the contents of the legend change.
  3. To retrieve correct height and column widths, it's better to manually retrieve the geometry of legend for nonvisible views. (Because color fill legend is a view specific element.)
  4. The value of Height property does not contain the line that displays "Calculating...".

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ColorFillLegend

See Also

ColorFillLegend Members


ColorFillLegend Members

[image] [image]

Revit 2024 API
ColorFillLegend Members
ColorFillLegend Class Methods Properties See Also Send Feedback

The ColorFillLegend type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create | Creates new instance of ColorFillLegend.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetColumnWidths | Returns array of column widths in the legend.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetColumnWidths | Sets array of column widths.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ColorFillCategoryId | Returns the id of color fill category that this legend is created for.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Height | The height of the legend.
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Origin | The top left corner of the color fill legend.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ColorFillLegend Class


GetColumnWidths Method

[image]

Revit 2024 API
ColorFillLegend..::..GetColumnWidths Method
ColorFillLegend Class See Also Send Feedback
Returns array of column widths in the legend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public IList<double> GetColumnWidths()
Visual Basic
Public Function GetColumnWidths As IList(Of Double)
Visual C++
public:
IList<double>^ GetColumnWidths()

See Also

ColorFillLegend Class


SetColumnWidths Method

[image]

Revit 2024 API
ColorFillLegend..::..SetColumnWidths Method
ColorFillLegend Class See Also Send Feedback
Sets array of column widths.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public void SetColumnWidths(
    IList<double> widths
)
Visual Basic
Public Sub SetColumnWidths ( _
    widths As IList(Of Double) _
)
Visual C++
public:
void SetColumnWidths(
    IList<double>^ widths
)

Parameters

widths
Type: System.Collections.Generic..::..IList<(Of <(<'Double>)>)>

Remarks

Input array length must be the same as what GetColumnWidths()()()() returns. It can only contain positive values.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Array is not valid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ColorFillLegend Class


ColorFillLegend Properties

[image] [image]

Revit 2024 API
ColorFillLegend Properties
ColorFillLegend Class See Also Send Feedback

The ColorFillLegend type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ColorFillCategoryId | Returns the id of color fill category that this legend is created for.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Height | The height of the legend.
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Origin | The top left corner of the color fill legend.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ColorFillLegend Class


ColorFillCategoryId Property

[image]

Revit 2024 API
ColorFillLegend..::..ColorFillCategoryId Property
ColorFillLegend Class See Also Send Feedback
Returns the id of color fill category that this legend is created for.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public ElementId ColorFillCategoryId { get; }
Visual Basic
Public ReadOnly Property ColorFillCategoryId As ElementId
    Get
Visual C++
public:
property ElementId^ ColorFillCategoryId {
    ElementId^ get ();
}

See Also

ColorFillLegend Class


Height Property

[image]

Revit 2024 API
ColorFillLegend..::..Height Property
ColorFillLegend Class See Also Send Feedback
The height of the legend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public double Height { get; set; }
Visual Basic
Public Property Height As Double
    Get
    Set
Visual C++
public:
property double Height {
    double get ();
    void set (double value);
}

Remarks

Changing the height may result in a change in the count of columns.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for height must be positive.

See Also

ColorFillLegend Class


Origin Property

[image]

Revit 2024 API
ColorFillLegend..::..Origin Property
ColorFillLegend Class See Also Send Feedback
The top left corner of the color fill legend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public XYZ Origin { get; set; }
Visual Basic
Public Property Origin As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

The origin point must be on the view plane this legend is placed on.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The origin is not on the view plane that this legend is placed on.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ColorFillLegend Class


Parameter Property

[image] [image]

Revit 2024 API
ColorFillLegend..::..Parameter Property
ColorFillLegend Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ColorFillLegend Class
ColorFillLegend Members


ColorFillScheme Class

[image]

Revit 2024 API
ColorFillScheme Class
Members See Also Send Feedback
Represents a color scheme could be used to colorfy elements in floor plan views and section views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public class ColorFillScheme : Element
Visual Basic
Public Class ColorFillScheme _
    Inherits Element
Visual C++
public ref class ColorFillScheme : public Element

Remarks

A color scheme is based on element category and one of the category parameter, it contains a set of ColorFillSchemeEntry which stores parameter value, color, fill pattern and other entry data. The entry paramater values may be a range or a single value, based on the IsByRange property. Then elements with the specified category could be colored with the color and fill pattern of matching entry whose parameter value or value range matches the element parameter value.

You can retrieve the entries with GetEntries()()()(), or modify entries with AddEntry(ColorFillSchemeEntry), RemoveEntry(ColorFillSchemeEntry), UpdateEntry(ColorFillSchemeEntry) and [M:Autodesk.Revit.DB.ColorFillScheme.SetEntries(System.Collections.Generic.IList`1{Autodesk.Revit.DB.ColorFillSchemeEntry})].

Unlike most of the other elements, the color scheme works in an "asynchronous" way in UI:

  1. If document elements change, the color scheme will not be updated immediately.
  2. If color schemes changes, the document elements will not be updated immediately too.

API works slightly different with UI:

  1. GetEntries()()()() will return the entries corresponding to the latest document elements status immediately.
  2. The entries modification operation will retrieve the latest entries with GetEntries()()()() at first, and then modify those entries by request, but document elements will still not be updated immediately.
  3. To modify multiple entries, it's better to use [M:Autodesk.Revit.DB.ColorFillScheme.SetEntries(System.Collections.Generic.IList`1{Autodesk.Revit.DB.ColorFillSchemeEntry})] but not modify them one by one with other methods for better performance.

Notes:

  • To apply a color scheme whose CategoryId property is OST_Areas to an area plan view, the AreaSchemeId property must be the same as the view if it is not used as a template.
  • To generate a new color scheme, you have to use Duplicate(String) method to duplicate form an existing one.
  • There should not exist two entries values that are the same in a color scheme. if the StorageType property is Double, then the value accuracy should be based on FormatOptions property.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ColorFillScheme

See Also

ColorFillScheme Members


ColorFillScheme Members

[image] [image]

Revit 2024 API
ColorFillScheme Members
ColorFillScheme Class Methods Properties See Also Send Feedback

The ColorFillScheme type exposes the following members.

Methods

 | Name | Description
Public method | AddEntry | Adds new entry to the scheme.
Public method | AreEntriesConsistentWithScheme | Checks whether the entries can be set to the scheme or not.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDefineByRange | Checks whether the scheme entries can be explained by range.
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanRemoveEntry | Checks whether entry can be removed from the scheme.
Public method | CanUpdateEntry | Checks whether entry exists in the scheme and not the same as input one.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Generates a copy of current scheme.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetEntries | Retrieves copies of all entries.
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetFormatOptions | Returns the FormatOptions of the scheme.
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetSupportedParameterIds | Retrieves collection of all parameters supported by the scheme.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsEntryConsistentWithScheme | Checks whether an entry can be added to the scheme or not.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidParameterDefinitionId | Checks whether the input parameter id can be applied to the scheme.
Public method | IsValidSchemeName | Checks whether the name is valid for new generated scheme.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | RemoveEntry | Removes an entry whose parameter value is the same as the input from the scheme
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetEntries | Update scheme entries in batch mode.
Public method | SetFormatOptions | Sets the FormatOptions of the scheme.
Public method | SortEntries | Sorts the scheme entries ascending.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateEntry | Updates the scheme entry with the same parameter value as the input entry.

Properties

 | Name | Description
Public property | AreaSchemeId | Represents the id of AreaScheme of area plan views that this scheme could be applied to.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CategoryId | Represents the element category that can be colored by this scheme.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsByRange | Represents if the parameter values in entries are treated as value range or not.
Public property | IsLinkedFilesIncluded | Represent if the scheme includes entries whose parameter values are based on elements from linked files.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | ParameterDefinition | Represents the parameter of the elements that this scheme could be used to color.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | StorageType | Represents the type of parameter values stored in entries.
Public property | Title | Represents the title displayed in ColorFillLegend.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ColorFillScheme Class


ColorFillScheme Methods

[image] [image]

Revit 2024 API
ColorFillScheme Methods
ColorFillScheme Class See Also Send Feedback

The ColorFillScheme type exposes the following members.

Methods

 | Name | Description
Public method | AddEntry | Adds new entry to the scheme.
Public method | AreEntriesConsistentWithScheme | Checks whether the entries can be set to the scheme or not.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDefineByRange | Checks whether the scheme entries can be explained by range.
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanRemoveEntry | Checks whether entry can be removed from the scheme.
Public method | CanUpdateEntry | Checks whether entry exists in the scheme and not the same as input one.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Generates a copy of current scheme.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetEntries | Retrieves copies of all entries.
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetFormatOptions | Returns the FormatOptions of the scheme.
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetSupportedParameterIds | Retrieves collection of all parameters supported by the scheme.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsEntryConsistentWithScheme | Checks whether an entry can be added to the scheme or not.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidParameterDefinitionId | Checks whether the input parameter id can be applied to the scheme.
Public method | IsValidSchemeName | Checks whether the name is valid for new generated scheme.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | RemoveEntry | Removes an entry whose parameter value is the same as the input from the scheme
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetEntries | Update scheme entries in batch mode.
Public method | SetFormatOptions | Sets the FormatOptions of the scheme.
Public method | SortEntries | Sorts the scheme entries ascending.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateEntry | Updates the scheme entry with the same parameter value as the input entry.

See Also

ColorFillScheme Class


AddEntry Method

[image]

Revit 2024 API
ColorFillScheme..::..AddEntry Method
ColorFillScheme Class See Also Send Feedback
Adds new entry to the scheme.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public void AddEntry(
    ColorFillSchemeEntry entry
)
Visual Basic
Public Sub AddEntry ( _
    entry As ColorFillSchemeEntry _
)
Visual C++
public:
void AddEntry(
    ColorFillSchemeEntry^ entry
)

Parameters

entry
Type: Autodesk.Revit.DB..::..ColorFillSchemeEntry

Remarks

To make sure that entry can be added to the scheme, call IsEntryConsistentWithScheme(ColorFillSchemeEntry) first.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | There already exists an entry with the same value in the scheme. -or- The entry value is out of range. -or- The scheme and the entry have different parameter storage type. -or- The fill pattern id is not valid for scheme.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ColorFillScheme Class


AreEntriesConsistentWithScheme Method

[image]

Revit 2024 API
ColorFillScheme..::..AreEntriesConsistentWithScheme Method
ColorFillScheme Class See Also Send Feedback
Checks whether the entries can be set to the scheme or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public EntryAndSchemeConsistency AreEntriesConsistentWithScheme(
    IList<ColorFillSchemeEntry> entries
)
Visual Basic
Public Function AreEntriesConsistentWithScheme ( _
    entries As IList(Of ColorFillSchemeEntry) _
) As EntryAndSchemeConsistency
Visual C++
public:
EntryAndSchemeConsistency AreEntriesConsistentWithScheme(
    IList<ColorFillSchemeEntry^>^ entries
)

Parameters

entries
Type: System.Collections.Generic..::..IList<(Of <(<' ColorFillSchemeEntry >)>)>
The entries to check.

Return Value

The state of the entries and scheme consistency.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ColorFillScheme Class


Duplicate Method

[image]

Revit 2024 API
ColorFillScheme..::..Duplicate Method
ColorFillScheme Class See Also Send Feedback
Generates a copy of current scheme.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public ElementId Duplicate(
    string name
)
Visual Basic
Public Function Duplicate ( _
    name As String _
) As ElementId
Visual C++
public:
ElementId^ Duplicate(
    String^ name
)

Parameters

name
Type: System..::..String
The desired name of copied scheme.

Return Value

The id of copied scheme.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The name is not valid for new generated scheme.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ColorFillScheme Class


GetEntries Method

[image]

Revit 2024 API
ColorFillScheme..::..GetEntries Method
ColorFillScheme Class See Also Send Feedback
Retrieves copies of all entries.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public IList<ColorFillSchemeEntry> GetEntries()
Visual Basic
Public Function GetEntries As IList(Of ColorFillSchemeEntry)
Visual C++
public:
IList<ColorFillSchemeEntry^>^ GetEntries()

Remarks

This method recalculates entries based on the current parameter values of the elements colored by the scheme.

See Also

ColorFillScheme Class


GetFormatOptions Method

[image]

Revit 2024 API
ColorFillScheme..::..GetFormatOptions Method
ColorFillScheme Class See Also Send Feedback
Returns the FormatOptions of the scheme.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public FormatOptions GetFormatOptions()
Visual Basic
Public Function GetFormatOptions As FormatOptions
Visual C++
public:
FormatOptions^ GetFormatOptions()

Remarks

This method will return the default FormatOptions if the scheme is by value.

See Also

ColorFillScheme Class


IsEntryConsistentWithScheme Method

[image]

Revit 2024 API
ColorFillScheme..::..IsEntryConsistentWithScheme Method
ColorFillScheme Class See Also Send Feedback
Checks whether an entry can be added to the scheme or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public EntryAndSchemeConsistency IsEntryConsistentWithScheme(
    ColorFillSchemeEntry entry
)
Visual Basic
Public Function IsEntryConsistentWithScheme ( _
    entry As ColorFillSchemeEntry _
) As EntryAndSchemeConsistency
Visual C++
public:
EntryAndSchemeConsistency IsEntryConsistentWithScheme(
    ColorFillSchemeEntry^ entry
)

Parameters

entry
Type: Autodesk.Revit.DB..::..ColorFillSchemeEntry
The entry to check.

Return Value

The state of entry and scheme consistency.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ColorFillScheme Class


SetEntries Method

[image]

Revit 2024 API
ColorFillScheme..::..SetEntries Method
ColorFillScheme Class See Also Send Feedback
Update scheme entries in batch mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public void SetEntries(
    IList<ColorFillSchemeEntry> entries
)
Visual Basic
Public Sub SetEntries ( _
    entries As IList(Of ColorFillSchemeEntry) _
)
Visual C++
public:
void SetEntries(
    IList<ColorFillSchemeEntry^>^ entries
)

Parameters

entries
Type: System.Collections.Generic..::..IList<(Of <(<' ColorFillSchemeEntry >)>)>
Collection of new entries.

Remarks

For by range scheme:

  • If there is only one entry in the input, Revit will generate another one automatically.
  • If the first existing entry is found in the input, it will be updated, otherwise keep not changed.
  • If the other existing entries are found in the input, they will be updated, otherwise removed.

For by value scheme:

  • For an existing entry that is in use, it will be updated if it can be found in the input, otherwise keep not changed.
  • For an existing entry that is no in use, it will be updated if it can be found in the input, otherwise removed.
  • If an entry in the input cannot be found in the existing entries, it will be added to the scheme.

To make sure that entry can be added to the scheme, call [M:Autodesk.Revit.DB.ColorFillScheme.AreEntriesConsistentWithScheme(System.Collections.Generic.IList`1{Autodesk.Revit.DB.ColorFillSchemeEntry})] first.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | There exists entries whose values are duplicated in the input entries. -or- There exists at lease one entry whose value is invalid for the scheme in the input entries. -or- There exists at least one entry in the input entries whose storage type is different with the scheme. -or- There exists at least one entry in the input entries whose fill pattern is invalid for color fill scheme. -or- There exists some inconsistent in the input entries.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ColorFillScheme Class


SetFormatOptions Method

[image]

Revit 2024 API
ColorFillScheme..::..SetFormatOptions Method
ColorFillScheme Class See Also Send Feedback
Sets the FormatOptions of the scheme.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public void SetFormatOptions(
    FormatOptions formatOptions
)
Visual Basic
Public Sub SetFormatOptions ( _
    formatOptions As FormatOptions _
)
Visual C++
public:
void SetFormatOptions(
    FormatOptions^ formatOptions
)

Parameters

formatOptions
Type: Autodesk.Revit.DB..::..FormatOptions

Remarks

This method will set the FormatOptions if the scheme is by range, otherwise do nothing.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ColorFillScheme Class


SortEntries Method

[image]

Revit 2024 API
ColorFillScheme..::..SortEntries Method
ColorFillScheme Class See Also Send Feedback
Sorts the scheme entries ascending.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public void SortEntries()
Visual Basic
Public Sub SortEntries
Visual C++
public:
void SortEntries()

Remarks

If the scheme parameter value storage type is ElementId, then the order of entries would be based on the name of the elements.

See Also

ColorFillScheme Class


UpdateEntry Method

[image]

Revit 2024 API
ColorFillScheme..::..UpdateEntry Method
ColorFillScheme Class See Also Send Feedback
Updates the scheme entry with the same parameter value as the input entry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public void UpdateEntry(
    ColorFillSchemeEntry entry
)
Visual Basic
Public Sub UpdateEntry ( _
    entry As ColorFillSchemeEntry _
)
Visual C++
public:
void UpdateEntry(
    ColorFillSchemeEntry^ entry
)

Parameters

entry
Type: Autodesk.Revit.DB..::..ColorFillSchemeEntry
The entry to be updated.

Remarks

The following entry fields can be updated:

  • Color
  • FillPattenId
  • Caption
  • IsVisible
/

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The entry does not exist or the same as input one. -or- The entry does not exist or all the updating fields are the same as existing one.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ColorFillScheme Class


CategoryId Property

[image]

Revit 2024 API
ColorFillScheme..::..CategoryId Property
ColorFillScheme Class See Also Send Feedback
Represents the element category that can be colored by this scheme.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public ElementId CategoryId { get; }
Visual Basic
Public ReadOnly Property CategoryId As ElementId
    Get
Visual C++
public:
property ElementId^ CategoryId {
    ElementId^ get ();
}

See Also

ColorFillScheme Class


IsByRange Property

[image]

Revit 2024 API
ColorFillScheme..::..IsByRange Property
ColorFillScheme Class See Also Send Feedback
Represents if the parameter values in entries are treated as value range or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public bool IsByRange { get; set; }
Visual Basic
Public Property IsByRange As Boolean
    Get
    Set
Visual C++
public:
property bool IsByRange {
    bool get ();
    void set (bool value);
}

Remarks

Notes:

  • Only numeric parameter values could be treated as by range.
  • There will exist at least two entries if the scheme is by range, and the first entry value should be always Int.MinValue or -Double.MaxValue.
  • The entries will always be sorted by ascending in the scheme if it is by range.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The scheme entries cannot be explained by range.

See Also

ColorFillScheme Class


IsLinkedFilesIncluded Property

[image]

Revit 2024 API
ColorFillScheme..::..IsLinkedFilesIncluded Property
ColorFillScheme Class See Also Send Feedback
Represent if the scheme includes entries whose parameter values are based on elements from linked files.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public bool IsLinkedFilesIncluded { get; set; }
Visual Basic
Public Property IsLinkedFilesIncluded As Boolean
    Get
    Set
Visual C++
public:
property bool IsLinkedFilesIncluded {
    bool get ();
    void set (bool value);
}

See Also

ColorFillScheme Class


Parameter Property

[image] [image]

Revit 2024 API
ColorFillScheme..::..Parameter Property
ColorFillScheme Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ColorFillScheme Class
ColorFillScheme Members


ParameterDefinition Property

[image]

Revit 2024 API
ColorFillScheme..::..ParameterDefinition Property
ColorFillScheme Class See Also Send Feedback
Represents the parameter of the elements that this scheme could be used to color.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public ElementId ParameterDefinition { get; set; }
Visual Basic
Public Property ParameterDefinition As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ ParameterDefinition {
    ElementId^ get ();
    void set (ElementId^ value);
}

Remarks

When this property changed, all existing scheme entries will be removed from the scheme, and the value of IsByRange property will be set to false if the parameter storage type is not numeric.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The paramId cannot be applied to the scheme.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ColorFillScheme Class


StorageType Property

[image]

Revit 2024 API
ColorFillScheme..::..StorageType Property
ColorFillScheme Class See Also Send Feedback
Represents the type of parameter values stored in entries.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public StorageType StorageType { get; }
Visual Basic
Public ReadOnly Property StorageType As StorageType
    Get
Visual C++
public:
property StorageType StorageType {
    StorageType get ();
}

See Also

ColorFillScheme Class


Title Property

[image]

Revit 2024 API
ColorFillScheme..::..Title Property
ColorFillScheme Class See Also Send Feedback
Represents the title displayed in ColorFillLegend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public string Title { get; set; }
Visual Basic
Public Property Title As String
    Get
    Set
Visual C++
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ColorFillScheme Class


ColorFillSchemeEntry Class

[image]

Revit 2024 API
ColorFillSchemeEntry Class
Members See Also Send Feedback
Represents an entry of a [!:Autodesk::Revit::DB::ColorFillScheme].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public class ColorFillSchemeEntry : IDisposable
Visual Basic
Public Class ColorFillSchemeEntry _
    Implements IDisposable
Visual C++
public ref class ColorFillSchemeEntry : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ColorFillSchemeEntry

See Also

ColorFillSchemeEntry Members


ColorFillSchemeEntry Members

[image] [image]

Revit 2024 API
ColorFillSchemeEntry Members
ColorFillSchemeEntry Class Constructors Methods Properties See Also Send Feedback

The ColorFillSchemeEntry type exposes the following members.

Constructors

 | Name | Description
Public method | ColorFillSchemeEntry | Creates new ColorFillSchemeEntry.

Methods

 | Name | Description
Public method | CanSetValue(Double) | Checks whether StorageType of entry is Double and the value is no less than 0.0.
Public method | CanSetValue(Int32) | Checks whether StorageType of entry is Integer.
Public method | CanSetValue(ElementId) | Checks whether StorageType of entry is ElementId.
Public method | Dispose | Releases all resources used by the ColorFillSchemeEntry
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDoubleValue | Gets the Double value stored within the entry.
Public method | GetElementIdValue | Gets the ElementId value stored within the entry.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIntegerValue | Gets the Integer value stored within the entry.
Public method | GetStringValue | Gets the String value stored within the entry.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDoubleValue | Sets new Double value of entry.
Public method | SetElementIdValue | Sets new ElementId value of entry.
Public method | SetIntegerValue | Sets new Integer value of entry.
Public method | SetStringValue | Sets new String value of entry.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Caption | The text displayed in [!:Autodesk::Revit::DB::ColorFillLegend] for this entry.
Public property | Color | The filling color of this entry.
Public property | FillPatternId | The id of fill pattern element of this entry.
Public property | IsInUse | Represents if there exists at least one element colored based on this entry in the document.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | IsVisible | Represents if the element colored based on this entry is visible in views.
Public property | StorageType | The storage type of the value stored in this entry.

See Also

ColorFillSchemeEntry Class


ColorFillSchemeEntry Constructor

[image]

Revit 2024 API
ColorFillSchemeEntry Constructor
ColorFillSchemeEntry Class See Also Send Feedback
Creates new ColorFillSchemeEntry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public ColorFillSchemeEntry(
    StorageType storageType
)
Visual Basic
Public Sub New ( _
    storageType As StorageType _
)
Visual C++
public:
ColorFillSchemeEntry(
    StorageType storageType
)

Parameters

storageType
Type: Autodesk.Revit.DB..::..StorageType
The type of data that could be stored into this entry.

Remarks

A new created ColorFillSchemeEntry should be assigned proper value before it is applied to a [!:Autodesk::Revit::DB::ColorFillScheme]. If the Color and Caption properties are not set, Revit will generate them automatically after the ColorFillSchemeEntry is applied to the ColorFillScheme.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

ColorFillSchemeEntry Class


ColorFillSchemeEntry Methods

[image] [image]

Revit 2024 API
ColorFillSchemeEntry Methods
ColorFillSchemeEntry Class See Also Send Feedback

The ColorFillSchemeEntry type exposes the following members.

Methods

 | Name | Description
Public method | CanSetValue(Double) | Checks whether StorageType of entry is Double and the value is no less than 0.0.
Public method | CanSetValue(Int32) | Checks whether StorageType of entry is Integer.
Public method | CanSetValue(ElementId) | Checks whether StorageType of entry is ElementId.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDoubleValue | Gets the Double value stored within the entry.
Public method | GetElementIdValue | Gets the ElementId value stored within the entry.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIntegerValue | Gets the Integer value stored within the entry.
Public method | GetStringValue | Gets the String value stored within the entry.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDoubleValue | Sets new Double value of entry.
Public method | SetElementIdValue | Sets new ElementId value of entry.
Public method | SetIntegerValue | Sets new Integer value of entry.
Public method | SetStringValue | Sets new String value of entry.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ColorFillSchemeEntry Class


CanSetValue Method

[image] [image]

Revit 2024 API
ColorFillSchemeEntry..::..CanSetValue Method
ColorFillSchemeEntry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CanSetValue(Double) | Checks whether StorageType of entry is Double and the value is no less than 0.0.
Public method | CanSetValue(Int32) | Checks whether StorageType of entry is Integer.
Public method | CanSetValue(ElementId) | Checks whether StorageType of entry is ElementId.

See Also

ColorFillSchemeEntry Class
ColorFillSchemeEntry Members


CanSetValue Method (Double)

[image]

Revit 2024 API
ColorFillSchemeEntry..::..CanSetValue Method (Double)
ColorFillSchemeEntry Class See Also Send Feedback
Checks whether StorageType of entry is Double and the value is no less than 0.0.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public bool CanSetValue(
    double value
)
Visual Basic
Public Function CanSetValue ( _
    value As Double _
) As Boolean
Visual C++
public:
bool CanSetValue(
    double value
)

Parameters

value
Type: System..::..Double
New Double value.

Return Value

True if StorageType of the entry is Double and the value is finite, false otherwise.

See Also

ColorFillSchemeEntry Class
CanSetValue Overload


CanSetValue Method (ElementId)

[image]

Revit 2024 API
ColorFillSchemeEntry..::..CanSetValue Method (ElementId)
ColorFillSchemeEntry Class See Also Send Feedback
Checks whether StorageType of entry is ElementId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public bool CanSetValue(
    ElementId value
)
Visual Basic
Public Function CanSetValue ( _
    value As ElementId _
) As Boolean
Visual C++
public:
bool CanSetValue(
    ElementId^ value
)

Parameters

value
Type: Autodesk.Revit.DB..::..ElementId
New ElementId value.

Return Value

True if StorageType of the entry is ElementId and the entry, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ColorFillSchemeEntry Class
CanSetValue Overload


Dispose Method

[image]

Revit 2024 API
ColorFillSchemeEntry..::..Dispose Method
ColorFillSchemeEntry Class See Also Send Feedback
Releases all resources used by the ColorFillSchemeEntry

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ColorFillSchemeEntry Class


GetElementIdValue Method

[image]

Revit 2024 API
ColorFillSchemeEntry..::..GetElementIdValue Method
ColorFillSchemeEntry Class See Also Send Feedback
Gets the ElementId value stored within the entry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public ElementId GetElementIdValue()
Visual Basic
Public Function GetElementIdValue As ElementId
Visual C++
public:
ElementId^ GetElementIdValue()

Return Value

The ElementId contained in the entry.

Remarks

This method should only be used if the StorageType property reports the type of the entry as a ElementId.

See Also

ColorFillSchemeEntry Class


GetIntegerValue Method

[image]

Revit 2024 API
ColorFillSchemeEntry..::..GetIntegerValue Method
ColorFillSchemeEntry Class See Also Send Feedback
Gets the Integer value stored within the entry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public int GetIntegerValue()
Visual Basic
Public Function GetIntegerValue As Integer
Visual C++
public:
int GetIntegerValue()

Return Value

The Integer value contained in the entry.

Remarks

This method should only be used if the StorageType property reports the type of the entry as a Integer.

See Also

ColorFillSchemeEntry Class


SetDoubleValue Method

[image]

Revit 2024 API
ColorFillSchemeEntry..::..SetDoubleValue Method
ColorFillSchemeEntry Class See Also Send Feedback
Sets new Double value of entry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public void SetDoubleValue(
    double value
)
Visual Basic
Public Sub SetDoubleValue ( _
    value As Double _
)
Visual C++
public:
void SetDoubleValue(
    double value
)

Parameters

value
Type: System..::..Double

Remarks

You should only use this method if the StorageType property reports the type of the entry as a Double.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The entry has different storage type with Double, or value is not finite.

See Also

ColorFillSchemeEntry Class


SetIntegerValue Method

[image]

Revit 2024 API
ColorFillSchemeEntry..::..SetIntegerValue Method
ColorFillSchemeEntry Class See Also Send Feedback
Sets new Integer value of entry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public void SetIntegerValue(
    int value
)
Visual Basic
Public Sub SetIntegerValue ( _
    value As Integer _
)
Visual C++
public:
void SetIntegerValue(
    int value
)

Parameters

value
Type: System..::..Int32

Remarks

You should only use this method if the StorageType property reports the type of the entry as a Integer.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The entry has different storage type with Integer.

See Also

ColorFillSchemeEntry Class


SetStringValue Method

[image]

Revit 2024 API
ColorFillSchemeEntry..::..SetStringValue Method
ColorFillSchemeEntry Class See Also Send Feedback
Sets new String value of entry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public void SetStringValue(
    string value
)
Visual Basic
Public Sub SetStringValue ( _
    value As String _
)
Visual C++
public:
void SetStringValue(
    String^ value
)

Parameters

value
Type: System..::..String

Remarks

This method should only be used if the StorageType property reports the type of the entry as a String. New value should be not empty and valid for Revit name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The entry has different storage type with String, or the value is empty, or contains forbidden characters.

See Also

ColorFillSchemeEntry Class


ColorFillSchemeEntry Properties

[image] [image]

Revit 2024 API
ColorFillSchemeEntry Properties
ColorFillSchemeEntry Class See Also Send Feedback

The ColorFillSchemeEntry type exposes the following members.

Properties

 | Name | Description
Public property | Caption | The text displayed in [!:Autodesk::Revit::DB::ColorFillLegend] for this entry.
Public property | Color | The filling color of this entry.
Public property | FillPatternId | The id of fill pattern element of this entry.
Public property | IsInUse | Represents if there exists at least one element colored based on this entry in the document.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | IsVisible | Represents if the element colored based on this entry is visible in views.
Public property | StorageType | The storage type of the value stored in this entry.

See Also

ColorFillSchemeEntry Class


Caption Property

[image]

Revit 2024 API
ColorFillSchemeEntry..::..Caption Property
ColorFillSchemeEntry Class See Also Send Feedback
The text displayed in [!:Autodesk::Revit::DB::ColorFillLegend] for this entry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public string Caption { get; set; }
Visual Basic
Public Property Caption As String
    Get
    Set
Visual C++
public:
property String^ Caption {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is only meaningful for by range scheme.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: newCaption is an empty string or contains only whitespace.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ColorFillSchemeEntry Class


Color Property

[image]

Revit 2024 API
ColorFillSchemeEntry..::..Color Property
ColorFillSchemeEntry Class See Also Send Feedback
The filling color of this entry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public Color Color { get; set; }
Visual Basic
Public Property Color As Color
    Get
    Set
Visual C++
public:
property Color^ Color {
    Color^ get ();
    void set (Color^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ColorFillSchemeEntry Class


FillPatternId Property

[image]

Revit 2024 API
ColorFillSchemeEntry..::..FillPatternId Property
ColorFillSchemeEntry Class See Also Send Feedback
The id of fill pattern element of this entry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public ElementId FillPatternId { get; set; }
Visual Basic
Public Property FillPatternId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ FillPatternId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Remarks

  • InvalidElementid represents no pattern, that means there would be nothing to be filled for elements colored based on this entry.
  • Only fill pattern elements whose fill pattern target is drafting is valid for color fill scheme.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ColorFillSchemeEntry Class


IsInUse Property

[image]

Revit 2024 API
ColorFillSchemeEntry..::..IsInUse Property
ColorFillSchemeEntry Class See Also Send Feedback
Represents if there exists at least one element colored based on this entry in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public bool IsInUse { get; }
Visual Basic
Public ReadOnly Property IsInUse As Boolean
    Get
Visual C++
public:
property bool IsInUse {
    bool get ();
}

See Also

ColorFillSchemeEntry Class


StorageType Property

[image]

Revit 2024 API
ColorFillSchemeEntry..::..StorageType Property
ColorFillSchemeEntry Class See Also Send Feedback
The storage type of the value stored in this entry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public StorageType StorageType { get; }
Visual Basic
Public ReadOnly Property StorageType As StorageType
    Get
Visual C++
public:
property StorageType StorageType {
    StorageType get ();
}

See Also

ColorFillSchemeEntry Class


ColorOptions Class

[image]

Revit 2024 API
ColorOptions Class
Members See Also Send Feedback
A class providing access to color settings which affect the colors applied to specific views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020.1

Syntax

C#
public class ColorOptions : IDisposable
Visual Basic
Public Class ColorOptions _
    Implements IDisposable
Visual C++
public ref class ColorOptions : IDisposable

Remarks

ColorOptions are managed and stored along with other global application options and thus impact the application as a whole.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ColorOptions

See Also

ColorOptions Members


Dispose Method

[image]

Revit 2024 API
ColorOptions..::..Dispose Method
ColorOptions Class See Also Send Feedback
Releases all resources used by the ColorOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ColorOptions Class


GetColorOptions Method

[image]

Revit 2024 API
ColorOptions..::..GetColorOptions Method
ColorOptions Class See Also Send Feedback
Returns the current Revit instance's ColorOptions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020.1

Syntax

C#
public static ColorOptions GetColorOptions()
Visual Basic
Public Shared Function GetColorOptions As ColorOptions
Visual C++
public:
static ColorOptions^ GetColorOptions()

Return Value

The ColorOptions for the current Revit instance.

See Also

ColorOptions Class


ColorOptions Properties

[image] [image]

Revit 2024 API
ColorOptions Properties
ColorOptions Class See Also Send Feedback

The ColorOptions type exposes the following members.

Properties

 | Name | Description
Public property | AlertColor | The color of the current canvas theme used to highlight elements when a special alert is required.
Public property | BackgroundColor | The background color of the current canvas theme applied to views.
Public property | CalculatingColor | The color of the current canvas theme used to render elements when some aspect of their properties is currently being recalculated.
Public property | EditingColor | The color of the current canvas theme used to render elements when editing.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | PreselectionColor | The color of the current canvas theme used to highlight candidates for selection before they are selected.
Public property | SelectionColor | The color of the current canvas theme used to highlight selected elements.
Public property | SelectionSemitransparent | Indicates whether or not selections will be shown in a semi-transparent manner in current canvas theme.

See Also

ColorOptions Class


AlertColor Property

[image]

Revit 2024 API
ColorOptions..::..AlertColor Property
ColorOptions Class See Also Send Feedback
The color of the current canvas theme used to highlight elements when a special alert is required.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020.1

Syntax

C#
public Color AlertColor { get; set; }
Visual Basic
Public Property AlertColor As Color
    Get
    Set
Visual C++
public:
property Color^ AlertColor {
    Color^ get ();
    void set (Color^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ColorOptions Class


CalculatingColor Property

[image]

Revit 2024 API
ColorOptions..::..CalculatingColor Property
ColorOptions Class See Also Send Feedback
The color of the current canvas theme used to render elements when some aspect of their properties is currently being recalculated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020.1

Syntax

C#
public Color CalculatingColor { get; set; }
Visual Basic
Public Property CalculatingColor As Color
    Get
    Set
Visual C++
public:
property Color^ CalculatingColor {
    Color^ get ();
    void set (Color^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ColorOptions Class


EditingColor Property

[image]

Revit 2024 API
ColorOptions..::..EditingColor Property
ColorOptions Class See Also Send Feedback
The color of the current canvas theme used to render elements when editing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020.1

Syntax

C#
public Color EditingColor { get; set; }
Visual Basic
Public Property EditingColor As Color
    Get
    Set
Visual C++
public:
property Color^ EditingColor {
    Color^ get ();
    void set (Color^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ColorOptions Class


SelectionColor Property

[image]

Revit 2024 API
ColorOptions..::..SelectionColor Property
ColorOptions Class See Also Send Feedback
The color of the current canvas theme used to highlight selected elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020.1

Syntax

C#
public Color SelectionColor { get; set; }
Visual Basic
Public Property SelectionColor As Color
    Get
    Set
Visual C++
public:
property Color^ SelectionColor {
    Color^ get ();
    void set (Color^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ColorOptions Class


SelectionSemitransparent Property

[image]

Revit 2024 API
ColorOptions..::..SelectionSemitransparent Property
ColorOptions Class See Also Send Feedback
Indicates whether or not selections will be shown in a semi-transparent manner in current canvas theme.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020.1

Syntax

C#
public bool SelectionSemitransparent { get; set; }
Visual Basic
Public Property SelectionSemitransparent As Boolean
    Get
    Set
Visual C++
public:
property bool SelectionSemitransparent {
    bool get ();
    void set (bool value);
}

See Also

ColorOptions Class


ColorWithTransparency Class

[image]

Revit 2024 API
ColorWithTransparency Class
Members See Also Send Feedback
Color with transparency

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public class ColorWithTransparency : IDisposable
Visual Basic
Public Class ColorWithTransparency _
    Implements IDisposable
Visual C++
public ref class ColorWithTransparency : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ColorWithTransparency

See Also

ColorWithTransparency Members


ColorWithTransparency Members

[image] [image]

Revit 2024 API
ColorWithTransparency Members
ColorWithTransparency Class Constructors Methods Properties See Also Send Feedback

The ColorWithTransparency type exposes the following members.

Constructors

 | Name | Description
Public method | ColorWithTransparency()()()() | color
Public method | ColorWithTransparency(UInt32, UInt32, UInt32, UInt32) | color

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ColorWithTransparency
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBlue | get blue
Public method | GetColor | get color
Public method | GetGreen | get green
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRed | get red
Public method | GetTransparency | get transparency
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetBlue | set blue
Public method | SetColor | set color
Public method | SetGreen | set green
Public method | SetRed | set red
Public method | SetTransparency | set transparency
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ColorWithTransparency Class


ColorWithTransparency Constructor

[image]

Revit 2024 API
ColorWithTransparency Constructor
ColorWithTransparency Class See Also Send Feedback
color

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public ColorWithTransparency()
Visual Basic
Public Sub New
Visual C++
public:
ColorWithTransparency()

See Also

ColorWithTransparency Class
ColorWithTransparency Overload


ColorWithTransparency Constructor (UInt32, UInt32, UInt32, UInt32)

[image]

Revit 2024 API
ColorWithTransparency Constructor (UInt32, UInt32, UInt32, UInt32)
ColorWithTransparency Class See Also Send Feedback
color

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public ColorWithTransparency(
    uint red,
    uint green,
    uint blue,
    uint transparency
)
Visual Basic
Public Sub New ( _
    red As UInteger, _
    green As UInteger, _
    blue As UInteger, _
    transparency As UInteger _
)
Visual C++
public:
ColorWithTransparency(
    unsigned int red,
    unsigned int green,
    unsigned int blue,
    unsigned int transparency
)

Parameters

red
Type: System..::..UInt32
red
green
Type: System..::..UInt32
green
blue
Type: System..::..UInt32
blue
transparency
Type: System..::..UInt32
transparency

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The value is not valid. The valid range is 0 to 255.

See Also

ColorWithTransparency Class
ColorWithTransparency Overload


ColorWithTransparency Methods

[image] [image]

Revit 2024 API
ColorWithTransparency Methods
ColorWithTransparency Class See Also Send Feedback

The ColorWithTransparency type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBlue | get blue
Public method | GetColor | get color
Public method | GetGreen | get green
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRed | get red
Public method | GetTransparency | get transparency
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetBlue | set blue
Public method | SetColor | set color
Public method | SetGreen | set green
Public method | SetRed | set red
Public method | SetTransparency | set transparency
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ColorWithTransparency Class


Dispose Method

[image]

Revit 2024 API
ColorWithTransparency..::..Dispose Method
ColorWithTransparency Class See Also Send Feedback
Releases all resources used by the ColorWithTransparency

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ColorWithTransparency Class


GetBlue Method

[image]

Revit 2024 API
ColorWithTransparency..::..GetBlue Method
ColorWithTransparency Class See Also Send Feedback
get blue

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public uint GetBlue()
Visual Basic
Public Function GetBlue As UInteger
Visual C++
public:
unsigned int GetBlue()

Return Value

blue

See Also

ColorWithTransparency Class


GetColor Method

[image]

Revit 2024 API
ColorWithTransparency..::..GetColor Method
ColorWithTransparency Class See Also Send Feedback
get color

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public Color GetColor()
Visual Basic
Public Function GetColor As Color
Visual C++
public:
Color^ GetColor()

Return Value

color

See Also

ColorWithTransparency Class


GetGreen Method

[image]

Revit 2024 API
ColorWithTransparency..::..GetGreen Method
ColorWithTransparency Class See Also Send Feedback
get green

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public uint GetGreen()
Visual Basic
Public Function GetGreen As UInteger
Visual C++
public:
unsigned int GetGreen()

Return Value

green

See Also

ColorWithTransparency Class


GetRed Method

[image]

Revit 2024 API
ColorWithTransparency..::..GetRed Method
ColorWithTransparency Class See Also Send Feedback
get red

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public uint GetRed()
Visual Basic
Public Function GetRed As UInteger
Visual C++
public:
unsigned int GetRed()

Return Value

red

See Also

ColorWithTransparency Class


GetTransparency Method

[image]

Revit 2024 API
ColorWithTransparency..::..GetTransparency Method
ColorWithTransparency Class See Also Send Feedback
get transparency

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public uint GetTransparency()
Visual Basic
Public Function GetTransparency As UInteger
Visual C++
public:
unsigned int GetTransparency()

Return Value

transparency

See Also

ColorWithTransparency Class


SetBlue Method

[image]

Revit 2024 API
ColorWithTransparency..::..SetBlue Method
ColorWithTransparency Class See Also Send Feedback
set blue

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public void SetBlue(
    uint blue
)
Visual Basic
Public Sub SetBlue ( _
    blue As UInteger _
)
Visual C++
public:
void SetBlue(
    unsigned int blue
)

Parameters

blue
Type: System..::..UInt32
blue

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The value is not valid. The valid range is 0 to 255.

See Also

ColorWithTransparency Class


SetColor Method

[image]

Revit 2024 API
ColorWithTransparency..::..SetColor Method
ColorWithTransparency Class See Also Send Feedback
set color

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public void SetColor(
    Color color
)
Visual Basic
Public Sub SetColor ( _
    color As Color _
)
Visual C++
public:
void SetColor(
    Color^ color
)

Parameters

color
Type: Autodesk.Revit.DB..::..Color
color

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ColorWithTransparency Class


SetGreen Method

[image]

Revit 2024 API
ColorWithTransparency..::..SetGreen Method
ColorWithTransparency Class See Also Send Feedback
set green

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public void SetGreen(
    uint green
)
Visual Basic
Public Sub SetGreen ( _
    green As UInteger _
)
Visual C++
public:
void SetGreen(
    unsigned int green
)

Parameters

green
Type: System..::..UInt32
green

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The value is not valid. The valid range is 0 to 255.

See Also

ColorWithTransparency Class


SetRed Method

[image]

Revit 2024 API
ColorWithTransparency..::..SetRed Method
ColorWithTransparency Class See Also Send Feedback
set red

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public void SetRed(
    uint red
)
Visual Basic
Public Sub SetRed ( _
    red As UInteger _
)
Visual C++
public:
void SetRed(
    unsigned int red
)

Parameters

red
Type: System..::..UInt32
red

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The value is not valid. The valid range is 0 to 255.

See Also

ColorWithTransparency Class


SetTransparency Method

[image]

Revit 2024 API
ColorWithTransparency..::..SetTransparency Method
ColorWithTransparency Class See Also Send Feedback
set transparency

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public void SetTransparency(
    uint transparency
)
Visual Basic
Public Sub SetTransparency ( _
    transparency As UInteger _
)
Visual C++
public:
void SetTransparency(
    unsigned int transparency
)

Parameters

transparency
Type: System..::..UInt32
transparency

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The value is not valid. The valid range is 0 to 255.

See Also

ColorWithTransparency Class


IsValidObject Property

[image]

Revit 2024 API
ColorWithTransparency..::..IsValidObject Property
ColorWithTransparency Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ColorWithTransparency Class


ColumnAttachment Class

[image]

Revit 2024 API
ColumnAttachment Class
Members See Also Send Feedback
An object representing the attachment of the top or bottom of a column to some target: a floor, roof, ceiling, beam, or brace.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class ColumnAttachment : IDisposable
Visual Basic
Public Class ColumnAttachment _
    Implements IDisposable
Visual C++
public ref class ColumnAttachment : IDisposable

Remarks

Call IsValidColumn() and IsValidTarget() to verify that specific elements support column attachments. A column has at most one top attachment and one bottom attachment.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ColumnAttachment

See Also

ColumnAttachment Members


ColumnAttachment Members

[image] [image]

Revit 2024 API
ColumnAttachment Members
ColumnAttachment Class Methods Properties See Also Send Feedback

The ColumnAttachment type exposes the following members.

Methods

 | Name | Description
 | AddColumnAttachment | Attaches the column to the target. If an attachment already exists with the same "baseOrTop" value, no attachment is made.
Public method | Dispose | Releases all resources used by the ColumnAttachment
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetColumnAttachment(FamilyInstance, ElementId) | Look up a column attachment by specifying the target id.
 | GetColumnAttachment(FamilyInstance, Int32) | Look up a column attachment. There is at most one attachment on the base and one on the top.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValidColumn | Says whether a FamilyInstance supports column attachments.
 | IsValidTarget(Boolean, Element) | Says whether the element can be used as a target for a new attachment.
 | IsValidTarget(FamilyInstance, Element) | Says whether the element can be used as a target for a new attachment.
 | RemoveColumnAttachment(FamilyInstance, ElementId) | Removes any attachment of the column to the specified target.
 | RemoveColumnAttachment(FamilyInstance, Int32) | Removes an attachment at the top or base of a column, if there is one.
Public method | SetJustification | Setter of ColumnAttachmentJustification
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AttachOffset | The offset of the column attachment.
Public property | BaseOrTop | Identifies if this ColumnAttachment is at the base or top of the column.
Public property | CutStyle | Identifies whether the column, or the attached element should be cut (or if neither should be cut).
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Justification | Identifies the type of justification to apply to this ColumnAttachment.
Public property | TargetId | The id of the element that is attached to the column and is described by this ColumnAttachment.

See Also

ColumnAttachment Class


ColumnAttachment Methods

[image] [image]

Revit 2024 API
ColumnAttachment Methods
ColumnAttachment Class See Also Send Feedback

The ColumnAttachment type exposes the following members.

Methods

 | Name | Description
 | AddColumnAttachment | Attaches the column to the target. If an attachment already exists with the same "baseOrTop" value, no attachment is made.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetColumnAttachment(FamilyInstance, ElementId) | Look up a column attachment by specifying the target id.
 | GetColumnAttachment(FamilyInstance, Int32) | Look up a column attachment. There is at most one attachment on the base and one on the top.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValidColumn | Says whether a FamilyInstance supports column attachments.
 | IsValidTarget(Boolean, Element) | Says whether the element can be used as a target for a new attachment.
 | IsValidTarget(FamilyInstance, Element) | Says whether the element can be used as a target for a new attachment.
 | RemoveColumnAttachment(FamilyInstance, ElementId) | Removes any attachment of the column to the specified target.
 | RemoveColumnAttachment(FamilyInstance, Int32) | Removes an attachment at the top or base of a column, if there is one.
Public method | SetJustification | Setter of ColumnAttachmentJustification
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ColumnAttachment Class


AddColumnAttachment Method

[image]

Revit 2024 API
ColumnAttachment..::..AddColumnAttachment Method
ColumnAttachment Class See Also Send Feedback
Attaches the column to the target. If an attachment already exists with the same "baseOrTop" value, no attachment is made.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static void AddColumnAttachment(
    Document doc,
    FamilyInstance column,
    Element target,
    int baseOrTop,
    ColumnAttachmentCutStyle cutColumnStyle,
    ColumnAttachmentJustification justification,
    double attachOffset
)
Visual Basic
Public Shared Sub AddColumnAttachment ( _
    doc As Document, _
    column As FamilyInstance, _
    target As Element, _
    baseOrTop As Integer, _
    cutColumnStyle As ColumnAttachmentCutStyle, _
    justification As ColumnAttachmentJustification, _
    attachOffset As Double _
)
Visual C++
public:
static void AddColumnAttachment(
    Document^ doc,
    FamilyInstance^ column,
    Element^ target,
    int baseOrTop,
    ColumnAttachmentCutStyle cutColumnStyle,
    ColumnAttachmentJustification justification,
    double attachOffset
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The document containing column and target.
column
Type: Autodesk.Revit.DB..::..FamilyInstance
A column.
target
Type: Autodesk.Revit.DB..::..Element
A target element.
baseOrTop
Type: System..::..Int32
0 to attach the column base, 1 to attach the column top.
cutColumnStyle
Type: Autodesk.Revit.DB..::..ColumnAttachmentCutStyle
Control the handling of columns that intersect their targets.
justification
Type: Autodesk.Revit.DB..::..ColumnAttachmentJustification
Control the column extent in cases where the target is not a uniform height.
attachOffset
Type: System..::..Double
An additional offset for the bottom. If positive, the column base or top will be higher than the attachment point; if negative, lower.

Remarks

This method modifies both column and target elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | column is not a column that supports ColumnAttachments. -or- target is not a valid target for ColumnAttachments. -or- column already has an attachment at its base or top as specified by baseOrTop. -or- column already has an attachment to target.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | baseOrTop must be either 0 or 1. -or- The given value for attachOffset must be no more than 30000 feet in absolute value. -or- A value passed for an enumeration argument is not a member of that enumeration

See Also

ColumnAttachment Class


Dispose Method

[image]

Revit 2024 API
ColumnAttachment..::..Dispose Method
ColumnAttachment Class See Also Send Feedback
Releases all resources used by the ColumnAttachment

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ColumnAttachment Class


GetColumnAttachment Method (FamilyInstance, ElementId)

[image]

Revit 2024 API
ColumnAttachment..::..GetColumnAttachment Method (FamilyInstance, ElementId)
ColumnAttachment Class See Also Send Feedback
Look up a column attachment by specifying the target id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ColumnAttachment GetColumnAttachment(
    FamilyInstance column,
    ElementId targetId
)
Visual Basic
Public Shared Function GetColumnAttachment ( _
    column As FamilyInstance, _
    targetId As ElementId _
) As ColumnAttachment
Visual C++
public:
static ColumnAttachment^ GetColumnAttachment(
    FamilyInstance^ column,
    ElementId^ targetId
)

Parameters

column
Type: Autodesk.Revit.DB..::..FamilyInstance
A column.
targetId
Type: Autodesk.Revit.DB..::..ElementId
Id of a target element.

Return Value

The column attachment attaching the column to the target, or nullNothingnullptra null reference (Nothing in Visual Basic) if there is no such attachment.

Remarks

May return either a top or base attachment.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ColumnAttachment Class
GetColumnAttachment Overload


GetColumnAttachment Method (FamilyInstance, Int32)

[image]

Revit 2024 API
ColumnAttachment..::..GetColumnAttachment Method (FamilyInstance, Int32)
ColumnAttachment Class See Also Send Feedback
Look up a column attachment. There is at most one attachment on the base and one on the top.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ColumnAttachment GetColumnAttachment(
    FamilyInstance column,
    int baseOrTop
)
Visual Basic
Public Shared Function GetColumnAttachment ( _
    column As FamilyInstance, _
    baseOrTop As Integer _
) As ColumnAttachment
Visual C++
public:
static ColumnAttachment^ GetColumnAttachment(
    FamilyInstance^ column,
    int baseOrTop
)

Parameters

column
Type: Autodesk.Revit.DB..::..FamilyInstance
A column.
baseOrTop
Type: System..::..Int32
0 for base, 1 for top.

Return Value

The column attachment for the base or top of the column, or nullNothingnullptra null reference (Nothing in Visual Basic) if that end of the column is unattached.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | baseOrTop must be either 0 or 1.

See Also

ColumnAttachment Class
GetColumnAttachment Overload


IsValidColumn Method

[image]

Revit 2024 API
ColumnAttachment..::..IsValidColumn Method
ColumnAttachment Class See Also Send Feedback
Says whether a FamilyInstance supports column attachments.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static bool IsValidColumn(
    FamilyInstance familyInstance
)
Visual Basic
Public Shared Function IsValidColumn ( _
    familyInstance As FamilyInstance _
) As Boolean
Visual C++
public:
static bool IsValidColumn(
    FamilyInstance^ familyInstance
)

Parameters

familyInstance
Type: Autodesk.Revit.DB..::..FamilyInstance
A column.

Remarks

In-place columns do not support attachments.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ColumnAttachment Class


IsValidTarget Method

[image] [image]

Revit 2024 API
ColumnAttachment..::..IsValidTarget Method
ColumnAttachment Class See Also Send Feedback

Overload List

Name | Description
IsValidTarget(Boolean, Element) | Says whether the element can be used as a target for a new attachment.
IsValidTarget(FamilyInstance, Element) | Says whether the element can be used as a target for a new attachment.

See Also

ColumnAttachment Class
ColumnAttachment Members


IsValidTarget Method (Boolean, Element)

[image]

Revit 2024 API
ColumnAttachment..::..IsValidTarget Method (Boolean, Element)
ColumnAttachment Class See Also Send Feedback
Says whether the element can be used as a target for a new attachment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static bool IsValidTarget(
    bool forSlantedColumn,
    Element target
)
Visual Basic
Public Shared Function IsValidTarget ( _
    forSlantedColumn As Boolean, _
    target As Element _
) As Boolean
Visual C++
public:
static bool IsValidTarget(
    bool forSlantedColumn,
    Element^ target
)

Parameters

forSlantedColumn
Type: System..::..Boolean
If true, check whether the target is valid for a slanted column; if false, check whether the target is valid for a vertical column.
target
Type: Autodesk.Revit.DB..::..Element
A proposed target element for a column attachment.

Remarks

Valid targets are roofs, floors, ceilings, levels. Beams and braces are valid targets, except for slanted columns.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ColumnAttachment Class
IsValidTarget Overload


IsValidTarget Method (FamilyInstance, Element)

[image]

Revit 2024 API
ColumnAttachment..::..IsValidTarget Method (FamilyInstance, Element)
ColumnAttachment Class See Also Send Feedback
Says whether the element can be used as a target for a new attachment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static bool IsValidTarget(
    FamilyInstance column,
    Element target
)
Visual Basic
Public Shared Function IsValidTarget ( _
    column As FamilyInstance, _
    target As Element _
) As Boolean
Visual C++
public:
static bool IsValidTarget(
    FamilyInstance^ column,
    Element^ target
)

Parameters

column
Type: Autodesk.Revit.DB..::..FamilyInstance
The column to attach. If the target is a beam or brace, the column will be checked to see if it is slanted. Otherwise, this argument is not used and may be omitted.
target
Type: Autodesk.Revit.DB..::..Element
A proposed target element for a column attachment.

Remarks

Valid targets are roofs, floors, and ceilings. Beams and braces are also valid targets, except for slanted columns.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ColumnAttachment Class
IsValidTarget Overload


RemoveColumnAttachment Method (FamilyInstance, ElementId)

[image]

Revit 2024 API
ColumnAttachment..::..RemoveColumnAttachment Method (FamilyInstance, ElementId)
ColumnAttachment Class See Also Send Feedback
Removes any attachment of the column to the specified target.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static void RemoveColumnAttachment(
    FamilyInstance column,
    ElementId targetId
)
Visual Basic
Public Shared Sub RemoveColumnAttachment ( _
    column As FamilyInstance, _
    targetId As ElementId _
)
Visual C++
public:
static void RemoveColumnAttachment(
    FamilyInstance^ column,
    ElementId^ targetId
)

Parameters

column
Type: Autodesk.Revit.DB..::..FamilyInstance
A column.
targetId
Type: Autodesk.Revit.DB..::..ElementId
Id of a target element.

Remarks

This method modifies both column and target elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ColumnAttachment Class
RemoveColumnAttachment Overload


RemoveColumnAttachment Method (FamilyInstance, Int32)

[image]

Revit 2024 API
ColumnAttachment..::..RemoveColumnAttachment Method (FamilyInstance, Int32)
ColumnAttachment Class See Also Send Feedback
Removes an attachment at the top or base of a column, if there is one.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static void RemoveColumnAttachment(
    FamilyInstance column,
    int baseOrTop
)
Visual Basic
Public Shared Sub RemoveColumnAttachment ( _
    column As FamilyInstance, _
    baseOrTop As Integer _
)
Visual C++
public:
static void RemoveColumnAttachment(
    FamilyInstance^ column,
    int baseOrTop
)

Parameters

column
Type: Autodesk.Revit.DB..::..FamilyInstance
A column.
baseOrTop
Type: System..::..Int32
0 for base, 1 for top.

Remarks

This method modifies both column and target elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | baseOrTop must be either 0 or 1.

See Also

ColumnAttachment Class
RemoveColumnAttachment Overload


AttachOffset Property

[image]

Revit 2024 API
ColumnAttachment..::..AttachOffset Property
ColumnAttachment Class See Also Send Feedback
The offset of the column attachment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double AttachOffset { get; set; }
Visual Basic
Public Property AttachOffset As Double
    Get
    Set
Visual C++
public:
property double AttachOffset {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for attachOffset must be no more than 30000 feet in absolute value.

See Also

ColumnAttachment Class


BaseOrTop Property

[image]

Revit 2024 API
ColumnAttachment..::..BaseOrTop Property
ColumnAttachment Class See Also Send Feedback
Identifies if this ColumnAttachment is at the base or top of the column.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public int BaseOrTop { get; }
Visual Basic
Public ReadOnly Property BaseOrTop As Integer
    Get
Visual C++
public:
property int BaseOrTop {
    int get ();
}

See Also

ColumnAttachment Class


IsValidObject Property

[image]

Revit 2024 API
ColumnAttachment..::..IsValidObject Property
ColumnAttachment Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ColumnAttachment Class


Justification Property

[image]

Revit 2024 API
ColumnAttachment..::..Justification Property
ColumnAttachment Class See Also Send Feedback
Identifies the type of justification to apply to this ColumnAttachment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ColumnAttachmentJustification Justification { get; }
Visual Basic
Public ReadOnly Property Justification As ColumnAttachmentJustification
    Get
Visual C++
public:
property ColumnAttachmentJustification Justification {
    ColumnAttachmentJustification get ();
}

See Also

ColumnAttachment Class


TargetId Property

[image]

Revit 2024 API
ColumnAttachment..::..TargetId Property
ColumnAttachment Class See Also Send Feedback
The id of the element that is attached to the column and is described by this ColumnAttachment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElementId TargetId { get; }
Visual Basic
Public ReadOnly Property TargetId As ElementId
    Get
Visual C++
public:
property ElementId^ TargetId {
    ElementId^ get ();
}

See Also

ColumnAttachment Class


ColumnAttachmentCutStyle Enumeration

[image]

Revit 2024 API
ColumnAttachmentCutStyle Enumeration
See Also Send Feedback
Control the handling of columns that intersect their targets.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum ColumnAttachmentCutStyle
Visual Basic
Public Enumeration ColumnAttachmentCutStyle
Visual C++
public enum class ColumnAttachmentCutStyle

Members

Member name | Description
CutColumn |
CutTarget |
None |

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


ColumnAttachmentJustification Enumeration

[image]

Revit 2024 API
ColumnAttachmentJustification Enumeration
See Also Send Feedback
Control the column extent in cases where the target is not a uniform height.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum ColumnAttachmentJustification
Visual Basic
Public Enumeration ColumnAttachmentJustification
Visual C++
public enum class ColumnAttachmentJustification

Members

Member name | Description
Minimum | Minimize the column extent, so that it comes in contact with the target but does not intersect.
Midpoint | Extend the column until its midpoint contacts the target.
Maximum | Extend the column until it is completely covered by the target, intersecting it if necessary.
Tangent | For slanted columns only. Extend the column until its driving curve contacts the target, then cut the column with a plane tangent to the target at that contact point.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


CombinableElement Class

[image]

Revit 2024 API
CombinableElement Class
Members See Also Send Feedback
An element that can be added to a geometry combination.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class CombinableElement : Element
Visual Basic
Public Class CombinableElement _
    Inherits Element
Visual C++
public ref class CombinableElement : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..CombinableElement
Autodesk.Revit.DB..::..GenericForm
Autodesk.Revit.DB..::..GeomCombination

See Also

CombinableElement Members


CombinableElement Methods

[image] [image]

Revit 2024 API
CombinableElement Methods
CombinableElement Class See Also Send Feedback

The CombinableElement type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CombinableElement Class


CombinableElement Properties

[image] [image]

Revit 2024 API
CombinableElement Properties
CombinableElement Class See Also Send Feedback

The CombinableElement type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Combinations | The geometry combinations that this element belongs to.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

CombinableElement Class


Combinations Property

[image]

Revit 2024 API
CombinableElement..::..Combinations Property
CombinableElement Class See Also Send Feedback
The geometry combinations that this element belongs to.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public GeomCombinationSet Combinations { get; }
Visual Basic
Public ReadOnly Property Combinations As GeomCombinationSet
    Get
Visual C++
public:
property GeomCombinationSet^ Combinations {
    GeomCombinationSet^ get ();
}

Remarks

If this combinable element does not belong to any geometry combination, this value is an empty collection. A solid combinable element may belong to at most one combination, while a void combinable element may belong to multiple combinations.

See Also

CombinableElement Class


Parameter Property

[image] [image]

Revit 2024 API
CombinableElement..::..Parameter Property
CombinableElement Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

CombinableElement Class
CombinableElement Members


CombinableElementArray Members

[image] [image]

Revit 2024 API
CombinableElementArray Members
CombinableElementArray Class Constructors Methods Properties See Also Send Feedback

The CombinableElementArray type exposes the following members.

Constructors

 | Name | Description
Public method | CombinableElementArray | Initializes a new instance of the CombinableElementArray class

Methods

 | Name | Description
Public method | Append | Add the element to the end of the array.
Public method | Clear | Removes every CombinableElement from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified element into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a CombinableElement at a specified index within the array.
Public property | Size | Returns the number of CombinableElements that are in the array.

See Also

CombinableElementArray Class


CombinableElementArray Constructor

[image]

Revit 2024 API
CombinableElementArray Constructor
CombinableElementArray Class See Also Send Feedback
Initializes a new instance of the CombinableElementArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CombinableElementArray()
Visual Basic
Public Sub New
Visual C++
public:
CombinableElementArray()

See Also

CombinableElementArray Class


Append Method

[image]

Revit 2024 API
CombinableElementArray..::..Append Method
CombinableElementArray Class See Also Send Feedback
Add the element to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Append(
    CombinableElement item
)
Visual Basic
Public Overridable Sub Append ( _
    item As CombinableElement _
)
Visual C++
public:
virtual void Append(
    CombinableElement^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..CombinableElement
The CombinableElement to be added.

See Also

CombinableElementArray Class


ForwardIterator Method

[image]

Revit 2024 API
CombinableElementArray..::..ForwardIterator Method
CombinableElementArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual CombinableElementArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As CombinableElementArrayIterator
Visual C++
public:
virtual CombinableElementArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

CombinableElementArray Class


GetEnumerator Method

[image]

Revit 2024 API
CombinableElementArray..::..GetEnumerator Method
CombinableElementArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

CombinableElementArray Class


IsEmpty Property

[image]

Revit 2024 API
CombinableElementArray..::..IsEmpty Property
CombinableElementArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

CombinableElementArray Class


Item Property

[image]

Revit 2024 API
CombinableElementArray..::..Item Property
CombinableElementArray Class See Also Send Feedback
Gets or sets a CombinableElement at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual CombinableElement this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As CombinableElement
    Get
    Set
Visual C++
public:
virtual property CombinableElement^ Item[int index] {
    CombinableElement^ get (int index);
    void set (int index, CombinableElement^ value);
}

Parameters

index
Type: System..::..Int32
The index of the CombinableElement to be set or retrieved.

Return Value

Returns the CombinableElement at the specified index.

See Also

CombinableElementArray Class


Size Property

[image]

Revit 2024 API
CombinableElementArray..::..Size Property
CombinableElementArray Class See Also Send Feedback
Returns the number of CombinableElements that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

CombinableElementArray Class


CombinableElementArrayIterator Class

[image]

Revit 2024 API
CombinableElementArrayIterator Class
Members See Also Send Feedback
An iterator to an CombinableElement array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public abstract class CombinableElementArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class CombinableElementArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class CombinableElementArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..CombinableElementArrayIterator

See Also

CombinableElementArrayIterator Members


CombinableElementArrayIterator Members

[image] [image]

Revit 2024 API
CombinableElementArrayIterator Members
CombinableElementArrayIterator Class Constructors Methods Properties See Also Send Feedback

The CombinableElementArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | CombinableElementArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CombinableElementArrayIterator Class


CombinableElementArrayIterator Constructor

[image]

Revit 2024 API
CombinableElementArrayIterator Constructor
CombinableElementArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CombinableElementArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
CombinableElementArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CombinableElementArrayIterator Class


CombinableElementArrayIterator Methods

[image] [image]

Revit 2024 API
CombinableElementArrayIterator Methods
CombinableElementArrayIterator Class See Also Send Feedback

The CombinableElementArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CombinableElementArrayIterator Class


MoveNext Method

[image]

Revit 2024 API
CombinableElementArrayIterator..::..MoveNext Method
CombinableElementArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

CombinableElementArrayIterator Class


CombinableElementArrayIterator Properties

[image] [image]

Revit 2024 API
CombinableElementArrayIterator Properties
CombinableElementArrayIterator Class See Also Send Feedback

The CombinableElementArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CombinableElementArrayIterator Class


Current Property

[image]

Revit 2024 API
CombinableElementArrayIterator..::..Current Property
CombinableElementArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

CombinableElementArrayIterator Class


ComponentRepeater Class

[image]

Revit 2024 API
ComponentRepeater Class
Members See Also Send Feedback
An element that contains and manages a set of repeated components.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class ComponentRepeater : Element,
    IEnumerable<ComponentRepeaterSlot>
Visual Basic
Public Class ComponentRepeater _
    Inherits Element _
    Implements IEnumerable(Of ComponentRepeaterSlot)
Visual C++
public ref class ComponentRepeater : public Element,
    IEnumerable<ComponentRepeaterSlot^>

Remarks

Component repeaters can be used to replicate (repeat) elements hosted on repeating references. The result of the repeating operation is a collection of slots. Each slot contains one repeated component. The ComponentRepeater class provides the repeating functionality and access to the slots.

Each repeating reference is capable of hosting one point of an adaptive component. An initial pattern can be created by populating one or more repeating references with such points. Component repeaters can then be used to replicate the pattern to fill the rest of the repeating references in the particular repeating reference source.

The repeating references in repeating reference source are arranged in one or two dimensional arrays, allowing for different kinds of repeating:

  • One dimensional source allows for repeating along a path.
  • Two dimensional source allows for repeating across a grid.
  • It is also possible to host a point on a zero dimensional reference (a point). This point will be shared by all slots. A zero dimensional source allows for repeating around a single point. It should not be used alone, but together with at least one other repeating reference source (typically one dimensional.) The point hosted on the zero dimensional source serves as a central point around which other points can be repeated on their respective repeating reference sources.

Multiple adaptive components may be hosted on one repeating reference source, and different points of one adaptive component may be hosted on different repeating reference sources, effectively allowing different points of an adaptive component to be repeated using different patterns.

Following is a typical component repeater creation workflow:

  1. Get the default repeating reference source from a point element, divided path or divided surface. (See HasRepeatingReferenceSource(Document, ElementId) and GetDefaultRepeatingReferenceSource(Document, ElementId).)
  2. Query the bounds of the repeating reference source to find a range of valid coordinates. (See DimensionCount and GetBounds()()()().)
  3. Create one or more instances of adaptive families that will be repeated.
  4. Host the individual points of an adaptive component on one or more repeating references. (See GetReference(RepeaterCoordinates).)
  5. Repeat the set of adaptive components using the RepeatElements() method.

Component repeaters can only be used in Massing families (the conceptual design environment).

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ComponentRepeater

See Also

ComponentRepeater Members


ComponentRepeater Members

[image] [image]

Revit 2024 API
ComponentRepeater Members
ComponentRepeater Class Methods Properties See Also Send Feedback

The ComponentRepeater type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
 | CanElementBeRepeated | Determines whether an element can be repeated using the RepeatElements method.
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsTypeValidForRepeater | Determines whether given family type can be used as the default type for the repeater.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
 | RemoveRepeaters | Removes component repeaters from the document, but leaves the individual repeated components in their respective locations and hosted on their original hosts.
 | RepeatElements | Repeats a set of adaptive component hosted on one or more repeating references.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DefaultFamilyType | The default family type for the component repeater.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DimensionCount | The dimension count of the component repeater.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ComponentRepeater Class


ComponentRepeater Methods

[image] [image]

Revit 2024 API
ComponentRepeater Methods
ComponentRepeater Class See Also Send Feedback

The ComponentRepeater type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
 | CanElementBeRepeated | Determines whether an element can be repeated using the RepeatElements method.
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsTypeValidForRepeater | Determines whether given family type can be used as the default type for the repeater.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
 | RemoveRepeaters | Removes component repeaters from the document, but leaves the individual repeated components in their respective locations and hosted on their original hosts.
 | RepeatElements | Repeats a set of adaptive component hosted on one or more repeating references.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ComponentRepeater Class


CanElementBeRepeated Method

[image]

Revit 2024 API
ComponentRepeater..::..CanElementBeRepeated Method
ComponentRepeater Class See Also Send Feedback
Determines whether an element can be repeated using the RepeatElements method.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015 Subscription Update

Syntax

C#
public static bool CanElementBeRepeated(
    Document ADoc,
    ElementId elementId
)
Visual Basic
Public Shared Function CanElementBeRepeated ( _
    ADoc As Document, _
    elementId As ElementId _
) As Boolean
Visual C++
public:
static bool CanElementBeRepeated(
    Document^ ADoc,
    ElementId^ elementId
)

Parameters

ADoc
Type: Autodesk.Revit.DB..::..Document
The document containing the element.
elementId
Type: Autodesk.Revit.DB..::..ElementId
The element to be tested.

Return Value

True if the element can be repeated.

Remarks

The element must be an adaptive family instance and have no shape handles. At least one placement point must be hosted on a 1D or 2D repeating reference. All other placement points can be hosted on a 0D, 1D or 2D repeating reference, or must be unhosted.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ComponentRepeater Class


GetEnumerator Method

[image]

Revit 2024 API
ComponentRepeater..::..GetEnumerator Method
ComponentRepeater Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IEnumerator<ComponentRepeaterSlot> GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator(Of ComponentRepeaterSlot)
Visual C++
public:
virtual IEnumerator<ComponentRepeaterSlot^>^ GetEnumerator()

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

ComponentRepeater Class


IsTypeValidForRepeater Method

[image]

Revit 2024 API
ComponentRepeater..::..IsTypeValidForRepeater Method
ComponentRepeater Class See Also Send Feedback
Determines whether given family type can be used as the default type for the repeater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsTypeValidForRepeater(
    ElementId typeId
)
Visual Basic
Public Function IsTypeValidForRepeater ( _
    typeId As ElementId _
) As Boolean
Visual C++
public:
bool IsTypeValidForRepeater(
    ElementId^ typeId
)

Parameters

typeId
Type: Autodesk.Revit.DB..::..ElementId
The element id of the type.

Return Value

True if the family type can be used as the default type for the repeater.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ComponentRepeater Class


ComponentRepeater Properties

[image] [image]

Revit 2024 API
ComponentRepeater Properties
ComponentRepeater Class See Also Send Feedback

The ComponentRepeater type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DefaultFamilyType | The default family type for the component repeater.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DimensionCount | The dimension count of the component repeater.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ComponentRepeater Class


DefaultFamilyType Property

[image]

Revit 2024 API
ComponentRepeater..::..DefaultFamilyType Property
ComponentRepeater Class See Also Send Feedback
The default family type for the component repeater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ElementId DefaultFamilyType { get; set; }
Visual Basic
Public Property DefaultFamilyType As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ DefaultFamilyType {
    ElementId^ get ();
    void set (ElementId^ value);
}

Remarks

The default family type is the type of the instances in default slots. This includes slots that are added when the repeater grows. When setting this property, all slots with instances of the default type will change their components to an instance of the new default type. Empty slots will remain unchanged. Slots with non-default family instances will remain unchanged.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: Invalid type for the repeater. The type must be an adaptive family with no shape handles. In addition, it must have same category and same number of placement points as the current type of the repeater.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ComponentRepeater Class


DimensionCount Property

[image]

Revit 2024 API
ComponentRepeater..::..DimensionCount Property
ComponentRepeater Class See Also Send Feedback
The dimension count of the component repeater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public int DimensionCount { get; }
Visual Basic
Public ReadOnly Property DimensionCount As Integer
    Get
Visual C++
public:
property int DimensionCount {
    int get ();
}

See Also

ComponentRepeater Class


Parameter Property

[image] [image]

Revit 2024 API
ComponentRepeater..::..Parameter Property
ComponentRepeater Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ComponentRepeater Class
ComponentRepeater Members


ComponentRepeaterIterator Methods

[image] [image]

Revit 2024 API
ComponentRepeaterIterator Methods
ComponentRepeaterIterator Class See Also Send Feedback

The ComponentRepeaterIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCurrent | Returns the current repeater slot.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next item.
Public method | Reset | Resets the iterator to the initial state.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ComponentRepeaterIterator Class


Dispose Method

[image]

Revit 2024 API
ComponentRepeaterIterator..::..Dispose Method
ComponentRepeaterIterator Class See Also Send Feedback
Releases all resources used by the ComponentRepeaterIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

See Also

ComponentRepeaterIterator Class


IsDone Method

[image]

Revit 2024 API
ComponentRepeaterIterator..::..IsDone Method
ComponentRepeaterIterator Class See Also Send Feedback
Identifies if the iteration has completed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public virtual bool IsDone()
Visual Basic
Public Overridable Function IsDone As Boolean
Visual C++
public:
virtual bool IsDone()

Return Value

True if the iteration has no more items. False if there are more items to be iterated.

See Also

ComponentRepeaterIterator Class


Reset Method

[image]

Revit 2024 API
ComponentRepeaterIterator..::..Reset Method
ComponentRepeaterIterator Class See Also Send Feedback
Resets the iterator to the initial state.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

See Also

ComponentRepeaterIterator Class


ComponentRepeaterIterator Properties

[image] [image]

Revit 2024 API
ComponentRepeaterIterator Properties
ComponentRepeaterIterator Class See Also Send Feedback

The ComponentRepeaterIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ComponentRepeaterIterator Class


Current Property

[image]

Revit 2024 API
ComponentRepeaterIterator..::..Current Property
ComponentRepeaterIterator Class See Also Send Feedback
Gets the item at the current position of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual ComponentRepeaterSlot Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As ComponentRepeaterSlot
    Get
Visual C++
public:
virtual property ComponentRepeaterSlot^ Current {
    ComponentRepeaterSlot^ get ();
}

Implements

IEnumerator<(Of <(<'T>)>)>..::..Current

Remarks

There is no current item if the iterator has not started yet or has been done.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | There is no current item in the iterator.

See Also

ComponentRepeaterIterator Class


CurrentObject Property

[image]

Revit 2024 API
ComponentRepeaterIterator..::..CurrentObject Property
ComponentRepeaterIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
internal Object CurrentObject { get; }
Visual Basic
Friend ReadOnly Property CurrentObject As Object
    Get
Visual C++
internal:
virtual property Object^ CurrentObject {
    Object^ get () sealed;
}

Implements

IEnumerator..::..Current

See Also

ComponentRepeaterIterator Class


IsValidObject Property

[image]

Revit 2024 API
ComponentRepeaterIterator..::..IsValidObject Property
ComponentRepeaterIterator Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ComponentRepeaterIterator Class


ComponentRepeaterSlot Class

[image]

Revit 2024 API
ComponentRepeaterSlot Class
Members See Also Send Feedback
Represents a slot that holds one repeated component in a component repeater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class ComponentRepeaterSlot : Element
Visual Basic
Public Class ComponentRepeaterSlot _
    Inherits Element
Visual C++
public ref class ComponentRepeaterSlot : public Element

Remarks

Each slot can be in one of the following states:

  • Empty.
  • Occupied by an instance of the default family of the repeater that contains the slot.
  • Occupied by an instance of another family.
Initially, every occupied slot holds an instance of the default family of the repeater, based on the original element that was repeated.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ComponentRepeaterSlot

See Also

ComponentRepeaterSlot Members


ComponentRepeaterSlot Members

[image] [image]

Revit 2024 API
ComponentRepeaterSlot Members
ComponentRepeaterSlot Class Methods Properties See Also Send Feedback

The ComponentRepeaterSlot type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsTypeValidForSlot | Determines whether instance of given family type can be used in the component repeater slot.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | MakeDefault | Populates the slot with an instance of the default family type of the component repeater.
Public method | MakeEmpty | Makes the slot empty by removing the instance currently held by the slot.
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyType | The id of the family type of the component in the slot, or invalid id if the slot is empty.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsDefault | A flag indicating whether the slot currently holds an instance of the default family type of the component repeater.
Public property | IsEmpty | A flag indicating whether the slot is currently empty.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ComponentRepeaterSlot Class


ComponentRepeaterSlot Methods

[image] [image]

Revit 2024 API
ComponentRepeaterSlot Methods
ComponentRepeaterSlot Class See Also Send Feedback

The ComponentRepeaterSlot type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsTypeValidForSlot | Determines whether instance of given family type can be used in the component repeater slot.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | MakeDefault | Populates the slot with an instance of the default family type of the component repeater.
Public method | MakeEmpty | Makes the slot empty by removing the instance currently held by the slot.
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ComponentRepeaterSlot Class


IsTypeValidForSlot Method

[image]

Revit 2024 API
ComponentRepeaterSlot..::..IsTypeValidForSlot Method
ComponentRepeaterSlot Class See Also Send Feedback
Determines whether instance of given family type can be used in the component repeater slot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsTypeValidForSlot(
    ElementId typeId
)
Visual Basic
Public Function IsTypeValidForSlot ( _
    typeId As ElementId _
) As Boolean
Visual C++
public:
bool IsTypeValidForSlot(
    ElementId^ typeId
)

Parameters

typeId
Type: Autodesk.Revit.DB..::..ElementId
The element id of the type.

Return Value

True if the family type can be used in the component repeater slot.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ComponentRepeaterSlot Class


MakeDefault Method

[image]

Revit 2024 API
ComponentRepeaterSlot..::..MakeDefault Method
ComponentRepeaterSlot Class See Also Send Feedback
Populates the slot with an instance of the default family type of the component repeater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void MakeDefault()
Visual Basic
Public Sub MakeDefault
Visual C++
public:
void MakeDefault()

See Also

ComponentRepeaterSlot Class


MakeEmpty Method

[image]

Revit 2024 API
ComponentRepeaterSlot..::..MakeEmpty Method
ComponentRepeaterSlot Class See Also Send Feedback
Makes the slot empty by removing the instance currently held by the slot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void MakeEmpty()
Visual Basic
Public Sub MakeEmpty
Visual C++
public:
void MakeEmpty()

See Also

ComponentRepeaterSlot Class


ComponentRepeaterSlot Properties

[image] [image]

Revit 2024 API
ComponentRepeaterSlot Properties
ComponentRepeaterSlot Class See Also Send Feedback

The ComponentRepeaterSlot type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyType | The id of the family type of the component in the slot, or invalid id if the slot is empty.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsDefault | A flag indicating whether the slot currently holds an instance of the default family type of the component repeater.
Public property | IsEmpty | A flag indicating whether the slot is currently empty.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ComponentRepeaterSlot Class


FamilyType Property

[image]

Revit 2024 API
ComponentRepeaterSlot..::..FamilyType Property
ComponentRepeaterSlot Class See Also Send Feedback
The id of the family type of the component in the slot, or invalid id if the slot is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ElementId FamilyType { get; set; }
Visual Basic
Public Property FamilyType As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ FamilyType {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: Invalid type for the slot. The type must be an adaptive family with no shape handles. In addition, it must have same category and same number of placement points as the current type of the repeater.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ComponentRepeaterSlot Class


IsDefault Property

[image]

Revit 2024 API
ComponentRepeaterSlot..::..IsDefault Property
ComponentRepeaterSlot Class See Also Send Feedback
A flag indicating whether the slot currently holds an instance of the default family type of the component repeater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsDefault { get; }
Visual Basic
Public ReadOnly Property IsDefault As Boolean
    Get
Visual C++
public:
property bool IsDefault {
    bool get ();
}

See Also

ComponentRepeaterSlot Class


IsEmpty Property

[image]

Revit 2024 API
ComponentRepeaterSlot..::..IsEmpty Property
ComponentRepeaterSlot Class See Also Send Feedback
A flag indicating whether the slot is currently empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsEmpty { get; }
Visual Basic
Public ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
property bool IsEmpty {
    bool get ();
}

See Also

ComponentRepeaterSlot Class


Parameter Property

[image] [image]

Revit 2024 API
ComponentRepeaterSlot..::..Parameter Property
ComponentRepeaterSlot Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ComponentRepeaterSlot Class
ComponentRepeaterSlot Members


ComponentRotation Enumeration

[image]

Revit 2024 API
ComponentRotation Enumeration
See Also Send Feedback
ComponentRotation property of DividedSurface. See DividedSurface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum ComponentRotation
Visual Basic
Public Enumeration ComponentRotation
Visual C++
public enum class ComponentRotation

Members

Member name | Description
Angle0 |
Angle90 |
Angle180 |
Angle270 |

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


CompoundStructure Members

[image] [image]

Revit 2024 API
CompoundStructure Members
CompoundStructure Class Methods Properties See Also Send Feedback

The CompoundStructure type exposes the following members.

Methods

 | Name | Description
Public method | AddWallSweep | Adds a new wall sweep or reveal to the compound structure.
Public method | AssociateRegionWithLayer | Associates a region with a layer.
Public method | CanLayerBeStructuralMaterial | Identifies if the input layer can be designated as defining the structural material for this structure.
Public method | CanLayerBeVariable | Identifies if the input layer can be designated as a variable thickness layer.
Public method | CanLayerWidthBeNonZero | Identifies if changing the width of an existing layer from zero to a positive value will create a rectangular region.
Public method | CanSplitAndMergeRegionsBeUsed | Checks whether split and merge regions operations can be used for this compound structure.
Public method | ChangeRegionWidth | Adjust the width of an existing simple region.
Public method | ClearWallSweeps | Removes all sweeps or reveals from the compound structure.
 | CreateSimpleCompoundStructure | Creates a non-vertically compound structure comprised of parallel layers.
 | CreateSingleLayerCompoundStructure(MaterialFunctionAssignment, Double, ElementId) | Creates a CompoundStructure containing a single layer.
 | CreateSingleLayerCompoundStructure(Double, MaterialFunctionAssignment, Double, ElementId) | Creates a vertically compound CompoundStructure with one layer.
Public method | DeleteLayer | Deletes the specified layer from this CompoundStructure.
Public method | Dispose | Releases all resources used by the CompoundStructure
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindEnclosingRegionAndSegments | Given a pair of grid coordinates, and a direction for splitting, returns the enclosing region and the two segments intersected by a line through the grid point.
Public method | GetAdjacentRegions | Gets the ids of region bound to a specified segment.
Public method | GetCoreBoundaryLayerIndex | Returns the index of the layer just below the core boundary.
Public method | GetDeckEmbeddingType | Retrieves the deck embedding type used for the specified structural deck.
Public method | GetDeckProfileId | Retrieves the profile loop used for the specified structural deck.
Public method | GetExtendableRegionIds | Gets the extendable region ids for the compound structure.
Public method | GetFirstCoreLayerIndex | Gets the index of the first core layer.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLastCoreLayerIndex | Gets the index of the last core layer.
Public method | GetLayerAssociatedToRegion | Gets the layer associated to a particular region.
Public method | GetLayerFunction | Retrieves the function of the specified layer.
Public method | GetLayers | A copy of the layers which define this compound structure.
Public method | GetLayerWidth | Retrieves the width of a specified layer.
Public method | GetMaterialId | Retrieves the material element id of a specified layer.
 | GetMinimumLayerThickness | Get the minimum allowable layer thickness.
Public method | GetNumberOfShellLayers | Retrieves the number of interior or exterior shell layers.
Public method | GetOffsetForLocationLine | Returns the offset from the center of the compound structure to the given location line value.
Public method | GetPreviousNonZeroLayerIndex | Returns the index of the nearest non-zero width layer before this layer.
Public method | GetRegionEnvelope | Gets the envelope that a specified region spans.
Public method | GetRegionIds | Gets the region ids of this compound structure.
Public method | GetRegionsAlongLevel | Returns the ids of the regions encountered as the vertically compound structure is traversed at a constant height above the bottom a wall to which this structure is applied.
Public method | GetRegionsAssociatedToLayer | Gets the set of region ids associated to a particular layer.
Public method | GetSegmentCoordinate | Gets the coordinate of a segment.
Public method | GetSegmentEndPoints | Gets the end points of a segment.
Public method | GetSegmentIds | Gets the segment ids of this compound structure.
Public method | GetSegmentOrientation | Gets the orientation of a segment.
Public method | GetSimpleCompoundStructure | Takes a horizontal slice through a sample wall to which this CompoundStructure is applied and returns a simple compound structure which describes that slice, i.e. a series of parallel layers.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWallSweepsInfo | Obtains a list of the intrinsic wall sweeps or reveals in this CompoundStructure.
Public method | GetWidth()()()() | The width implied by this compound structure.
Public method | GetWidth(Int32) | Computes the width of the envelope (2d bounding box) of the specified region.
Public method | IsCoreLayer | Checks if the specified layer is a core layer.
Public method | IsEqual | Checks whether this CompoundStructure is the same as another CompoundStructure.
Public method | IsLayerValid | Verifies that the data in this layer is internally consistent.
Public method | IsRectangularRegion | Determines whether the specified region is rectangular.
Public method | IsSimpleRegion | Determines whether the region is a simple region in this CompoundStructure.
Public method | IsStructuralDeck | Determines whether a specified layer is a structural deck.
Public method | IsValid | Checks for errors or inconsistencies in the data in this CompoundStructure.
Public method | IsValidRegionId | Determines whether the specified integer is actually the id of a region in this CompoundStructure.
Public method | IsValidSampleHeight | Is the specified height a valid sample height for this compound structure?
Public method | IsValidSegmentId | Determines whether the specified integer is actually the id of a segment in this CompoundStructure.
Public method | IsVerticallyHomogeneous | Indicates whether this CompoundStructure represents a single set of parallel layers.
Public method | MergeRegionsAdjacentToSegment | Merges the two regions which share the specified segment.
Public method | ParticipatesInWrapping | Identifies if a layer is included in wrapping at inserts and ends.
Public method | RemoveWallSweep | Removes a single sweep or reveal from the compound structure.
Public method | SetDeckEmbeddingType | Sets the deck embedding type to use for the specified structural deck.
Public method | SetDeckProfileId | Sets the profile loop to use for the specified structural deck.
Public method | SetExtendableRegionIds | Sets the extendable region ids for the compound structure.
Public method | SetLayer | Sets a single layer for this CompoundStructure.
Public method | SetLayerFunction | Sets the function of the specified layer.
Public method | SetLayers | Completely resets this CompoundStructure and applies a new set of layers.
Public method | SetLayerWidth | Sets the width of a specified layer.
Public method | SetMaterialId | Sets a material element for a specified layer.
Public method | SetNumberOfShellLayers | Sets the number of interior or exterior shell layers.
Public method | SetParticipatesInWrapping | Assigns if a layer is included in wrapping at inserts and ends.
Public method | SplitRegion(UV, RectangularGridSegmentOrientation) | Splits the region which contains the specified grid point by a line with the specified direction.
Public method | SplitRegion(UV, RectangularGridSegmentOrientation, Int32%) | Splits the region which contains the specified grid point by a line with the specified direction.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CutoffHeight | Horizontal segments below or at the cutoff height have their distance to the wall bottom fixed, those above have their distance to the wall top fixed.
Public property | EndCap | Indicates the end cap condition defining which shell layers will participate in end wrapping.
Public property | HasStructuralDeck | Checks if the compound structure has a structural deck.
Public property | IsEmpty | Checks whether this CompoundStructure is empty.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | IsVerticallyCompound | Identifies if this CompoundStructure represents a layout that is more complicated than a simple set of parallel layers.
Public property | LayerCount | Returns the number of layers contained in this CompoundStructure.
Public property | MinimumSampleHeight | The minimum sample height determined by the current sample height and the horizontal segments.
Public property | OpeningWrapping | Indicates the opening wrapping condition defining which shell layers of a wall, in plan view, wrap at inserts and openings.
Public property | SampleHeight | The sample height is the presumed height of the wall to which the data in this CompoundStructure is applied.
Public property | StructuralMaterialIndex | Indicates the layer whose material defines the structural properties of the type for the purposes of analysis.
Public property | VariableLayerIndex | Indicates the index of the layer which is designated as variable.

See Also

CompoundStructure Class


CompoundStructure Methods

[image] [image]

Revit 2024 API
CompoundStructure Methods
CompoundStructure Class See Also Send Feedback

The CompoundStructure type exposes the following members.

Methods

 | Name | Description
Public method | AddWallSweep | Adds a new wall sweep or reveal to the compound structure.
Public method | AssociateRegionWithLayer | Associates a region with a layer.
Public method | CanLayerBeStructuralMaterial | Identifies if the input layer can be designated as defining the structural material for this structure.
Public method | CanLayerBeVariable | Identifies if the input layer can be designated as a variable thickness layer.
Public method | CanLayerWidthBeNonZero | Identifies if changing the width of an existing layer from zero to a positive value will create a rectangular region.
Public method | CanSplitAndMergeRegionsBeUsed | Checks whether split and merge regions operations can be used for this compound structure.
Public method | ChangeRegionWidth | Adjust the width of an existing simple region.
Public method | ClearWallSweeps | Removes all sweeps or reveals from the compound structure.
 | CreateSimpleCompoundStructure | Creates a non-vertically compound structure comprised of parallel layers.
 | CreateSingleLayerCompoundStructure(MaterialFunctionAssignment, Double, ElementId) | Creates a CompoundStructure containing a single layer.
 | CreateSingleLayerCompoundStructure(Double, MaterialFunctionAssignment, Double, ElementId) | Creates a vertically compound CompoundStructure with one layer.
Public method | DeleteLayer | Deletes the specified layer from this CompoundStructure.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindEnclosingRegionAndSegments | Given a pair of grid coordinates, and a direction for splitting, returns the enclosing region and the two segments intersected by a line through the grid point.
Public method | GetAdjacentRegions | Gets the ids of region bound to a specified segment.
Public method | GetCoreBoundaryLayerIndex | Returns the index of the layer just below the core boundary.
Public method | GetDeckEmbeddingType | Retrieves the deck embedding type used for the specified structural deck.
Public method | GetDeckProfileId | Retrieves the profile loop used for the specified structural deck.
Public method | GetExtendableRegionIds | Gets the extendable region ids for the compound structure.
Public method | GetFirstCoreLayerIndex | Gets the index of the first core layer.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLastCoreLayerIndex | Gets the index of the last core layer.
Public method | GetLayerAssociatedToRegion | Gets the layer associated to a particular region.
Public method | GetLayerFunction | Retrieves the function of the specified layer.
Public method | GetLayers | A copy of the layers which define this compound structure.
Public method | GetLayerWidth | Retrieves the width of a specified layer.
Public method | GetMaterialId | Retrieves the material element id of a specified layer.
 | GetMinimumLayerThickness | Get the minimum allowable layer thickness.
Public method | GetNumberOfShellLayers | Retrieves the number of interior or exterior shell layers.
Public method | GetOffsetForLocationLine | Returns the offset from the center of the compound structure to the given location line value.
Public method | GetPreviousNonZeroLayerIndex | Returns the index of the nearest non-zero width layer before this layer.
Public method | GetRegionEnvelope | Gets the envelope that a specified region spans.
Public method | GetRegionIds | Gets the region ids of this compound structure.
Public method | GetRegionsAlongLevel | Returns the ids of the regions encountered as the vertically compound structure is traversed at a constant height above the bottom a wall to which this structure is applied.
Public method | GetRegionsAssociatedToLayer | Gets the set of region ids associated to a particular layer.
Public method | GetSegmentCoordinate | Gets the coordinate of a segment.
Public method | GetSegmentEndPoints | Gets the end points of a segment.
Public method | GetSegmentIds | Gets the segment ids of this compound structure.
Public method | GetSegmentOrientation | Gets the orientation of a segment.
Public method | GetSimpleCompoundStructure | Takes a horizontal slice through a sample wall to which this CompoundStructure is applied and returns a simple compound structure which describes that slice, i.e. a series of parallel layers.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWallSweepsInfo | Obtains a list of the intrinsic wall sweeps or reveals in this CompoundStructure.
Public method | GetWidth()()()() | The width implied by this compound structure.
Public method | GetWidth(Int32) | Computes the width of the envelope (2d bounding box) of the specified region.
Public method | IsCoreLayer | Checks if the specified layer is a core layer.
Public method | IsEqual | Checks whether this CompoundStructure is the same as another CompoundStructure.
Public method | IsLayerValid | Verifies that the data in this layer is internally consistent.
Public method | IsRectangularRegion | Determines whether the specified region is rectangular.
Public method | IsSimpleRegion | Determines whether the region is a simple region in this CompoundStructure.
Public method | IsStructuralDeck | Determines whether a specified layer is a structural deck.
Public method | IsValid | Checks for errors or inconsistencies in the data in this CompoundStructure.
Public method | IsValidRegionId | Determines whether the specified integer is actually the id of a region in this CompoundStructure.
Public method | IsValidSampleHeight | Is the specified height a valid sample height for this compound structure?
Public method | IsValidSegmentId | Determines whether the specified integer is actually the id of a segment in this CompoundStructure.
Public method | IsVerticallyHomogeneous | Indicates whether this CompoundStructure represents a single set of parallel layers.
Public method | MergeRegionsAdjacentToSegment | Merges the two regions which share the specified segment.
Public method | ParticipatesInWrapping | Identifies if a layer is included in wrapping at inserts and ends.
Public method | RemoveWallSweep | Removes a single sweep or reveal from the compound structure.
Public method | SetDeckEmbeddingType | Sets the deck embedding type to use for the specified structural deck.
Public method | SetDeckProfileId | Sets the profile loop to use for the specified structural deck.
Public method | SetExtendableRegionIds | Sets the extendable region ids for the compound structure.
Public method | SetLayer | Sets a single layer for this CompoundStructure.
Public method | SetLayerFunction | Sets the function of the specified layer.
Public method | SetLayers | Completely resets this CompoundStructure and applies a new set of layers.
Public method | SetLayerWidth | Sets the width of a specified layer.
Public method | SetMaterialId | Sets a material element for a specified layer.
Public method | SetNumberOfShellLayers | Sets the number of interior or exterior shell layers.
Public method | SetParticipatesInWrapping | Assigns if a layer is included in wrapping at inserts and ends.
Public method | SplitRegion(UV, RectangularGridSegmentOrientation) | Splits the region which contains the specified grid point by a line with the specified direction.
Public method | SplitRegion(UV, RectangularGridSegmentOrientation, Int32%) | Splits the region which contains the specified grid point by a line with the specified direction.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CompoundStructure Class


AddWallSweep Method

[image]

Revit 2024 API
CompoundStructure..::..AddWallSweep Method
CompoundStructure Class See Also Send Feedback
Adds a new wall sweep or reveal to the compound structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void AddWallSweep(
    WallSweepInfo wallSweepInfo
)
Visual Basic
Public Sub AddWallSweep ( _
    wallSweepInfo As WallSweepInfo _
)
Visual C++
public:
void AddWallSweep(
    WallSweepInfo^ wallSweepInfo
)

Parameters

wallSweepInfo
Type: Autodesk.Revit.DB..::..WallSweepInfo
The wall sweep info to create a wall sweep.

Remarks

A wall sweep is an object that is created by sweeping a closed 2d profile along a horizontal line that is positioned on one side (exterior or interior) of the hosting wall. A reveal is a special wall sweep with a void shape that is subtracted from the hosting wall.

The id field of the WallSweepInfo must be populated with a non-negative integer value. If there already is a sweep defined for this id, its parameters will be changed. A new sweep will be created if no existing one has matching id.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The wall sweep info does not represent a fixed wall sweep. Only fixed wall sweeps may be assigned to vertical compound structures. -or- The WallSweepInfo has an invalid id for a fixed wall sweep.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only for vertically compound structures.

See Also

CompoundStructure Class


CanLayerBeStructuralMaterial Method

[image]

Revit 2024 API
CompoundStructure..::..CanLayerBeStructuralMaterial Method
CompoundStructure Class See Also Send Feedback
Identifies if the input layer can be designated as defining the structural material for this structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool CanLayerBeStructuralMaterial(
    int layerIndex
)
Visual Basic
Public Function CanLayerBeStructuralMaterial ( _
    layerIndex As Integer _
) As Boolean
Visual C++
public:
bool CanLayerBeStructuralMaterial(
    int layerIndex
)

Parameters

layerIndex
Type: System..::..Int32
Index of a layer in the CompoundStructure.

Return Value

True if the input layer may be used to define the structural material and false otherwise.

Remarks

Only core layers may be designated as defining the structural material.

See Also

CompoundStructure Class


CanLayerBeVariable Method

[image]

Revit 2024 API
CompoundStructure..::..CanLayerBeVariable Method
CompoundStructure Class See Also Send Feedback
Identifies if the input layer can be designated as a variable thickness layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool CanLayerBeVariable(
    int variableLayerIndex
)
Visual Basic
Public Function CanLayerBeVariable ( _
    variableLayerIndex As Integer _
) As Boolean
Visual C++
public:
bool CanLayerBeVariable(
    int variableLayerIndex
)

Parameters

variableLayerIndex
Type: System..::..Int32
Index of a layer in the CompoundStructure.

Return Value

True if the input layer may be a variable thickness layer and false otherwise.

Remarks

A layer whose layer function is StructuralDeck may not be designated as a variable layer.

See Also

CompoundStructure Class


CanSplitAndMergeRegionsBeUsed Method

[image]

Revit 2024 API
CompoundStructure..::..CanSplitAndMergeRegionsBeUsed Method
CompoundStructure Class See Also Send Feedback
Checks whether split and merge regions operations can be used for this compound structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool CanSplitAndMergeRegionsBeUsed()
Visual Basic
Public Function CanSplitAndMergeRegionsBeUsed As Boolean
Visual C++
public:
bool CanSplitAndMergeRegionsBeUsed()

Return Value

True if split and merge regions operation can be used for this compound structure, false otherwise.

See Also

CompoundStructure Class


ChangeRegionWidth Method

[image]

Revit 2024 API
CompoundStructure..::..ChangeRegionWidth Method
CompoundStructure Class See Also Send Feedback
Adjust the width of an existing simple region.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool ChangeRegionWidth(
    int regionId,
    double newWidth
)
Visual Basic
Public Function ChangeRegionWidth ( _
    regionId As Integer, _
    newWidth As Double _
) As Boolean
Visual C++
public:
bool ChangeRegionWidth(
    int regionId,
    double newWidth
)

Parameters

regionId
Type: System..::..Int32
The id of a region.
newWidth
Type: System..::..Double
The desired width of the specified region.

Return Value

True if newWidth is zero and the region was deleted.

Remarks

If width is changed to zero, the effect is to delete the region.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | It is not a valid region id. -or- It is not a simple region.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only for vertically compound structures.

See Also

CompoundStructure Class


ClearWallSweeps Method

[image]

Revit 2024 API
CompoundStructure..::..ClearWallSweeps Method
CompoundStructure Class See Also Send Feedback
Removes all sweeps or reveals from the compound structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void ClearWallSweeps(
    WallSweepType wallSweepType
)
Visual Basic
Public Sub ClearWallSweeps ( _
    wallSweepType As WallSweepType _
)
Visual C++
public:
void ClearWallSweeps(
    WallSweepType wallSweepType
)

Parameters

wallSweepType
Type: Autodesk.Revit.DB..::..WallSweepType
The type of a wall sweep.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only for vertically compound structures.

See Also

CompoundStructure Class


CreateSimpleCompoundStructure Method

[image]

Revit 2024 API
CompoundStructure..::..CreateSimpleCompoundStructure Method
CompoundStructure Class See Also Send Feedback
Creates a non-vertically compound structure comprised of parallel layers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static CompoundStructure CreateSimpleCompoundStructure(
    IList<CompoundStructureLayer> layers
)
Visual Basic
Public Shared Function CreateSimpleCompoundStructure ( _
    layers As IList(Of CompoundStructureLayer) _
) As CompoundStructure
Visual C++
public:
static CompoundStructure^ CreateSimpleCompoundStructure(
    IList<CompoundStructureLayer^>^ layers
)

Parameters

layers
Type: System.Collections.Generic..::..IList<(Of <(<' CompoundStructureLayer >)>)>
An array which describes the parallel layers of this compound structure.

Return Value

A newly created compound structure.

Remarks

All layers are in the core, i.e. there are no shell layers created.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | One or more layers is not valid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

CompoundStructure Class


CreateSingleLayerCompoundStructure Method

[image] [image]

Revit 2024 API
CompoundStructure..::..CreateSingleLayerCompoundStructure Method
CompoundStructure Class See Also Send Feedback

Overload List

Name | Description
CreateSingleLayerCompoundStructure(MaterialFunctionAssignment, Double, ElementId) | Creates a CompoundStructure containing a single layer.
CreateSingleLayerCompoundStructure(Double, MaterialFunctionAssignment, Double, ElementId) | Creates a vertically compound CompoundStructure with one layer.

See Also

CompoundStructure Class
CompoundStructure Members


DeleteLayer Method

[image]

Revit 2024 API
CompoundStructure..::..DeleteLayer Method
CompoundStructure Class See Also Send Feedback
Deletes the specified layer from this CompoundStructure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool DeleteLayer(
    int layerIdx
)
Visual Basic
Public Function DeleteLayer ( _
    layerIdx As Integer _
) As Boolean
Visual C++
public:
bool DeleteLayer(
    int layerIdx
)

Parameters

layerIdx
Type: System..::..Int32
The layer index is zero based. It counts from the exterior of wall and from the top of roofs, floors and ceilings.

Return Value

True if the layer was successfully deleted, and false otherwise.

Remarks

For a vertically compound structure, a layer may only be deleted if it is not associated to a region, or else it is associated to exactly one simple region, which will also be deleted. Regions associated to layers with index greater than layerIdx will have their associated layer indices decremented by one.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The layer cannot be deleted.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The layer index is out of range.

See Also

CompoundStructure Class


Dispose Method

[image]

Revit 2024 API
CompoundStructure..::..Dispose Method
CompoundStructure Class See Also Send Feedback
Releases all resources used by the CompoundStructure

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

CompoundStructure Class


GetAdjacentRegions Method

[image]

Revit 2024 API
CompoundStructure..::..GetAdjacentRegions Method
CompoundStructure Class See Also Send Feedback
Gets the ids of region bound to a specified segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public IList<int> GetAdjacentRegions(
    int segmentId
)
Visual Basic
Public Function GetAdjacentRegions ( _
    segmentId As Integer _
) As IList(Of Integer)
Visual C++
public:
IList<int>^ GetAdjacentRegions(
    int segmentId
)

Parameters

segmentId
Type: System..::..Int32
The id of a segment in this CompoundStructure.

Return Value

The ids of the regions that are bounded by the specified segment.

Remarks

The boundaries of the regions of a vertically compound structure consist of vertical horizontal segments with unique ids. The segments which define the outer boundary of the structure are adjacent to one region, other segments will be adjacent to two regions.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The segment id is invalid.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only for vertically compound structures.

See Also

CompoundStructure Class


GetCoreBoundaryLayerIndex Method

[image]

Revit 2024 API
CompoundStructure..::..GetCoreBoundaryLayerIndex Method
CompoundStructure Class See Also Send Feedback
Returns the index of the layer just below the core boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public int GetCoreBoundaryLayerIndex(
    ShellLayerType shellLayerType
)
Visual Basic
Public Function GetCoreBoundaryLayerIndex ( _
    shellLayerType As ShellLayerType _
) As Integer
Visual C++
public:
int GetCoreBoundaryLayerIndex(
    ShellLayerType shellLayerType
)

Parameters

shellLayerType
Type: Autodesk.Revit.DB..::..ShellLayerType
If ShellLayerType.Exterior return the index on the exterior side (or top side for a roof, floor, or ceiling type). If ShellLayerType.Interior return the index on the interior side (or bottom side for a roof, floor, or ceiling type).

Return Value

The index of the layer.

Remarks

-1 returned if there is no such a layer. You can change the shell/core layer boundary using SetNumberOfShellLayers(ShellLayerType, Int32).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

CompoundStructure Class


GetDeckEmbeddingType Method

[image]

Revit 2024 API
CompoundStructure..::..GetDeckEmbeddingType Method
CompoundStructure Class See Also Send Feedback
Retrieves the deck embedding type used for the specified structural deck.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public StructDeckEmbeddingType GetDeckEmbeddingType(
    int layerIdx
)
Visual Basic
Public Function GetDeckEmbeddingType ( _
    layerIdx As Integer _
) As StructDeckEmbeddingType
Visual C++
public:
StructDeckEmbeddingType GetDeckEmbeddingType(
    int layerIdx
)

Parameters

layerIdx
Type: System..::..Int32
Index of a layer in the CompoundStructure.

Return Value

The embedding type of the structural deck associated to the specified layer. Invalid if it is not a structural deck.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The layer index is out of range.

See Also

CompoundStructure Class


GetDeckProfileId Method

[image]

Revit 2024 API
CompoundStructure..::..GetDeckProfileId Method
CompoundStructure Class See Also Send Feedback
Retrieves the profile loop used for the specified structural deck.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElementId GetDeckProfileId(
    int layerIdx
)
Visual Basic
Public Function GetDeckProfileId ( _
    layerIdx As Integer _
) As ElementId
Visual C++
public:
ElementId^ GetDeckProfileId(
    int layerIdx
)

Parameters

layerIdx
Type: System..::..Int32
Index of a layer in the CompoundStructure.

Return Value

The element id of a FamilySymbol which contains a profile loop used by a structural deck associated to the specified layer, or invalidElementId if isStructuralDeck(layerIdx) is false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The layer index is out of range.

See Also

CompoundStructure Class


GetExtendableRegionIds Method

[image]

Revit 2024 API
CompoundStructure..::..GetExtendableRegionIds Method
CompoundStructure Class See Also Send Feedback
Gets the extendable region ids for the compound structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public IList<int> GetExtendableRegionIds(
    bool top
)
Visual Basic
Public Function GetExtendableRegionIds ( _
    top As Boolean _
) As IList(Of Integer)
Visual C++
public:
IList<int>^ GetExtendableRegionIds(
    bool top
)

Parameters

top
Type: System..::..Boolean
If true, retrieve ids of regions which are extendable at the top, otherwise retrieve the ids of regions which are extendable at the bottom.

Return Value

An array of region ids which are marked extendable.

Remarks

Regions along the top or bottom of the wall may be set to be extendable.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only for vertically compound structures.

See Also

CompoundStructure Class


GetLastCoreLayerIndex Method

[image]

Revit 2024 API
CompoundStructure..::..GetLastCoreLayerIndex Method
CompoundStructure Class See Also Send Feedback
Gets the index of the last core layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public int GetLastCoreLayerIndex()
Visual Basic
Public Function GetLastCoreLayerIndex As Integer
Visual C++
public:
int GetLastCoreLayerIndex()

Return Value

The index of the last core layer.

Remarks

This is the index on the interior side. You can change the shell/core layer boundary using SetNumberOfShellLayers(ShellLayerType, Int32).

See Also

CompoundStructure Class


GetLayerAssociatedToRegion Method

[image]

Revit 2024 API
CompoundStructure..::..GetLayerAssociatedToRegion Method
CompoundStructure Class See Also Send Feedback
Gets the layer associated to a particular region.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public int GetLayerAssociatedToRegion(
    int regionId
)
Visual Basic
Public Function GetLayerAssociatedToRegion ( _
    regionId As Integer _
) As Integer
Visual C++
public:
int GetLayerAssociatedToRegion(
    int regionId
)

Parameters

regionId
Type: System..::..Int32
The id of a region.

Return Value

The index of a layer in this CompoundStructure.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | For a non-vertically compound structure, implicitly each layer is associated to its corresponding simple region.

See Also

CompoundStructure Class


GetLayerFunction Method

[image]

Revit 2024 API
CompoundStructure..::..GetLayerFunction Method
CompoundStructure Class See Also Send Feedback
Retrieves the function of the specified layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public MaterialFunctionAssignment GetLayerFunction(
    int layerIdx
)
Visual Basic
Public Function GetLayerFunction ( _
    layerIdx As Integer _
) As MaterialFunctionAssignment
Visual C++
public:
MaterialFunctionAssignment GetLayerFunction(
    int layerIdx
)

Parameters

layerIdx
Type: System..::..Int32
Index of a layer in the CompoundStructure.

Return Value

The function of the layer.

Remarks

The function determines how this layer interacts with the layers of other elements to which it is joined.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The layer index is out of range.

See Also

CompoundStructure Class


GetLayers Method

[image]

Revit 2024 API
CompoundStructure..::..GetLayers Method
CompoundStructure Class See Also Send Feedback
A copy of the layers which define this compound structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public IList<CompoundStructureLayer> GetLayers()
Visual Basic
Public Function GetLayers As IList(Of CompoundStructureLayer)
Visual C++
public:
IList<CompoundStructureLayer^>^ GetLayers()

Return Value

The layers, returned in order (Exterior to Interior for walls, top to bottom for roofs, floors or ceilings). The index of each layer in this array can be used in other CompoundStructure methods accepting a layer index.

See Also

CompoundStructure Class


GetLayerWidth Method

[image]

Revit 2024 API
CompoundStructure..::..GetLayerWidth Method
CompoundStructure Class See Also Send Feedback
Retrieves the width of a specified layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double GetLayerWidth(
    int layerIdx
)
Visual Basic
Public Function GetLayerWidth ( _
    layerIdx As Integer _
) As Double
Visual C++
public:
double GetLayerWidth(
    int layerIdx
)

Parameters

layerIdx
Type: System..::..Int32
Index of a layer in the CompoundStructure.

Return Value

The width of the specified layer.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The layer index is out of range.

See Also

CompoundStructure Class


GetNumberOfShellLayers Method

[image]

Revit 2024 API
CompoundStructure..::..GetNumberOfShellLayers Method
CompoundStructure Class See Also Send Feedback
Retrieves the number of interior or exterior shell layers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public int GetNumberOfShellLayers(
    ShellLayerType shellLayerType
)
Visual Basic
Public Function GetNumberOfShellLayers ( _
    shellLayerType As ShellLayerType _
) As Integer
Visual C++
public:
int GetNumberOfShellLayers(
    ShellLayerType shellLayerType
)

Parameters

shellLayerType
Type: Autodesk.Revit.DB..::..ShellLayerType
If ShellLayerType.Exterior return the number of exterior shell layers (or top shell layers for a roof, floor, or ceiling type). If ShellLayerType.Interior return the number of interior shell layers (or bottom shell layers for a roof, floor, or ceiling type).

Return Value

The number of shell layers in the interior or exterior shell, as specified by shellLayerType.

Remarks

There will always be at least one core layer, i.e. one layer which is not a shell layer. You can change the shell/core layer boundary using SetNumberOfShellLayers(ShellLayerType, Int32).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

CompoundStructure Class


GetOffsetForLocationLine Method

[image]

Revit 2024 API
CompoundStructure..::..GetOffsetForLocationLine Method
CompoundStructure Class See Also Send Feedback
Returns the offset from the center of the compound structure to the given location line value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double GetOffsetForLocationLine(
    WallLocationLine wallLocationLine
)
Visual Basic
Public Function GetOffsetForLocationLine ( _
    wallLocationLine As WallLocationLine _
) As Double
Visual C++
public:
double GetOffsetForLocationLine(
    WallLocationLine wallLocationLine
)

Parameters

wallLocationLine
Type: Autodesk.Revit.DB..::..WallLocationLine
The alignment type of the wall's location line.

Return Value

The offset.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only vertically homogeneous compound structures.

See Also

CompoundStructure Class


GetPreviousNonZeroLayerIndex Method

[image]

Revit 2024 API
CompoundStructure..::..GetPreviousNonZeroLayerIndex Method
CompoundStructure Class See Also Send Feedback
Returns the index of the nearest non-zero width layer before this layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public int GetPreviousNonZeroLayerIndex(
    int thisIdx
)
Visual Basic
Public Function GetPreviousNonZeroLayerIndex ( _
    thisIdx As Integer _
) As Integer
Visual C++
public:
int GetPreviousNonZeroLayerIndex(
    int thisIdx
)

Parameters

thisIdx
Type: System..::..Int32
The layer from which to look for a non-zero width layer.

Return Value

The index of the layer found.

Remarks

If this layer is non-zero width, it will be returned. If there are non-zero width layers found, returns -1.

See Also

CompoundStructure Class


GetRegionEnvelope Method

[image]

Revit 2024 API
CompoundStructure..::..GetRegionEnvelope Method
CompoundStructure Class See Also Send Feedback
Gets the envelope that a specified region spans.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public BoundingBoxUV GetRegionEnvelope(
    int regionId
)
Visual Basic
Public Function GetRegionEnvelope ( _
    regionId As Integer _
) As BoundingBoxUV
Visual C++
public:
BoundingBoxUV^ GetRegionEnvelope(
    int regionId
)

Parameters

regionId
Type: System..::..Int32
The id of the region.

Return Value

The envelope of the region.

Remarks

This envelope indicates the external boundary of the region. The coordinate system it defines is used in the results of GetSegmentCoordinate().

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | It is not a valid region id.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only for vertically compound structures.

See Also

CompoundStructure Class


GetRegionsAlongLevel Method

[image]

Revit 2024 API
CompoundStructure..::..GetRegionsAlongLevel Method
CompoundStructure Class See Also Send Feedback
Returns the ids of the regions encountered as the vertically compound structure is traversed at a constant height above the bottom a wall to which this structure is applied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public IList<int> GetRegionsAlongLevel(
    double height
)
Visual Basic
Public Function GetRegionsAlongLevel ( _
    height As Double _
) As IList(Of Integer)
Visual C++
public:
IList<int>^ GetRegionsAlongLevel(
    double height
)

Parameters

height
Type: System..::..Double
Distance from the bottom of the wall.

Return Value

The ids of the regions intersected by the specified line.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The height is outside valid range. It should be in the range of [0, SampleHeight].

See Also

CompoundStructure Class


GetRegionsAssociatedToLayer Method

[image]

Revit 2024 API
CompoundStructure..::..GetRegionsAssociatedToLayer Method
CompoundStructure Class See Also Send Feedback
Gets the set of region ids associated to a particular layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public IList<int> GetRegionsAssociatedToLayer(
    int layerIdx
)
Visual Basic
Public Function GetRegionsAssociatedToLayer ( _
    layerIdx As Integer _
) As IList(Of Integer)
Visual C++
public:
IList<int>^ GetRegionsAssociatedToLayer(
    int layerIdx
)

Parameters

layerIdx
Type: System..::..Int32
The index of a layer in this CompoundStructure.

Return Value

An array of region ids which are associated to the specified layer.

Remarks

Regions are associated to layers. In a vertically compound structure, more than one region may be associated to a single layer.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The layer index is out of range.

See Also

CompoundStructure Class


GetSegmentEndPoints Method

[image]

Revit 2024 API
CompoundStructure..::..GetSegmentEndPoints Method
CompoundStructure Class See Also Send Feedback
Gets the end points of a segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void GetSegmentEndPoints(
    int segmentId,
    int regionId,
    out UV end1,
    out UV end2
)
Visual Basic
Public Sub GetSegmentEndPoints ( _
    segmentId As Integer, _
    regionId As Integer, _
    <OutAttribute> ByRef end1 As UV, _
    <OutAttribute> ByRef end2 As UV _
)
Visual C++
public:
void GetSegmentEndPoints(
    int segmentId,
    int regionId,
    [OutAttribute] UV^% end1,
    [OutAttribute] UV^% end2
)

Parameters

segmentId
Type: System..::..Int32
The segment id.
regionId
Type: System..::..Int32
The region id.
end1
Type: Autodesk.Revit.DB..::..UV %
One end point.
end2
Type: Autodesk.Revit.DB..::..UV %
The other end point.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The segment id is invalid.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only for vertically compound structures.

See Also

CompoundStructure Class


GetSegmentIds Method

[image]

Revit 2024 API
CompoundStructure..::..GetSegmentIds Method
CompoundStructure Class See Also Send Feedback
Gets the segment ids of this compound structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public IList<int> GetSegmentIds()
Visual Basic
Public Function GetSegmentIds As IList(Of Integer)
Visual C++
public:
IList<int>^ GetSegmentIds()

Return Value

The ids of the segments which form the boundary of the regions of this CompoundStructure.

Remarks

The boundaries of the regions of a vertically compound structure consist of vertical horizontal segments with unique ids.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only for vertically compound structures.

See Also

CompoundStructure Class


GetSegmentOrientation Method

[image]

Revit 2024 API
CompoundStructure..::..GetSegmentOrientation Method
CompoundStructure Class See Also Send Feedback
Gets the orientation of a segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public RectangularGridSegmentOrientation GetSegmentOrientation(
    int segmentId
)
Visual Basic
Public Function GetSegmentOrientation ( _
    segmentId As Integer _
) As RectangularGridSegmentOrientation
Visual C++
public:
RectangularGridSegmentOrientation GetSegmentOrientation(
    int segmentId
)

Parameters

segmentId
Type: System..::..Int32
The id of a segment in this CompoundStructure.

Return Value

The orientation of the specified segment.

Remarks

The boundaries of the regions of a vertically compound structure consist of vertical horizontal segments.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The segment id is invalid.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only for vertically compound structures.

See Also

CompoundStructure Class


GetSimpleCompoundStructure Method

[image]

Revit 2024 API
CompoundStructure..::..GetSimpleCompoundStructure Method
CompoundStructure Class See Also Send Feedback
Takes a horizontal slice through a sample wall to which this CompoundStructure is applied and returns a simple compound structure which describes that slice, i.e. a series of parallel layers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CompoundStructure GetSimpleCompoundStructure(
    double wallHeight,
    double distAboveBase
)
Visual Basic
Public Function GetSimpleCompoundStructure ( _
    wallHeight As Double, _
    distAboveBase As Double _
) As CompoundStructure
Visual C++
public:
CompoundStructure^ GetSimpleCompoundStructure(
    double wallHeight,
    double distAboveBase
)

Parameters

wallHeight
Type: System..::..Double
The height of the wall.
distAboveBase
Type: System..::..Double
The distance from the base of the wall at which to take the section. If distAboveBase < 0, then internally distAboveBase = 0 is used. If distAboveBase > wallHeight, then internally distAboveBase = wallHeight is used.

Return Value

A simple CompoundStructure representing a series of parallel layers.

Remarks

If IsVerticallyCompound is false, the output is a copy of this CompoundStructure.

See Also

CompoundStructure Class


GetWidth Method

[image] [image]

Revit 2024 API
CompoundStructure..::..GetWidth Method
CompoundStructure Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetWidth()()()() | The width implied by this compound structure.
Public method | GetWidth(Int32) | Computes the width of the envelope (2d bounding box) of the specified region.

See Also

CompoundStructure Class
CompoundStructure Members


GetWidth Method (Int32)

[image]

Revit 2024 API
CompoundStructure..::..GetWidth Method (Int32)
CompoundStructure Class See Also Send Feedback
Computes the width of the envelope (2d bounding box) of the specified region.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double GetWidth(
    int regionId
)
Visual Basic
Public Function GetWidth ( _
    regionId As Integer _
) As Double
Visual C++
public:
double GetWidth(
    int regionId
)

Parameters

regionId
Type: System..::..Int32
The id of a region in this vertically compound structure.

Return Value

The width of the envelope (2d bounding box) of the region.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | It is not a valid region id.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only for vertically compound structures.

See Also

CompoundStructure Class
GetWidth Overload


IsCoreLayer Method

[image]

Revit 2024 API
CompoundStructure..::..IsCoreLayer Method
CompoundStructure Class See Also Send Feedback
Checks if the specified layer is a core layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsCoreLayer(
    int layerIdx
)
Visual Basic
Public Function IsCoreLayer ( _
    layerIdx As Integer _
) As Boolean
Visual C++
public:
bool IsCoreLayer(
    int layerIdx
)

Parameters

layerIdx
Type: System..::..Int32
The index of a layer in this CompoundStructure.

Return Value

Returns true if the layer is within the core layer boundary, false if it is in the interior or exterior shell layers.

Remarks

You can change the shell/core layer boundary using SetNumberOfShellLayers(ShellLayerType, Int32).

See Also

CompoundStructure Class


IsLayerValid Method

[image]

Revit 2024 API
CompoundStructure..::..IsLayerValid Method
CompoundStructure Class See Also Send Feedback
Verifies that the data in this layer is internally consistent.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsLayerValid(
    int layerIdx,
    CompoundStructureLayer layer
)
Visual Basic
Public Function IsLayerValid ( _
    layerIdx As Integer, _
    layer As CompoundStructureLayer _
) As Boolean
Visual C++
public:
bool IsLayerValid(
    int layerIdx,
    CompoundStructureLayer^ layer
)

Parameters

layerIdx
Type: System..::..Int32
The index of the layer in the compound structure to be set.
layer
Type: Autodesk.Revit.DB..::..CompoundStructureLayer
The layer to be set.

Return Value

True if the layer is internally consistent, false if the layer is not internally consistent.

Remarks

If the layer function is not Membrane or StructuralDeck, the width must be greater than zero. If the layer function is not StructuralDeck, then the deck embedding type must be Invalid, and the deck profile id must be InvalidElementId.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

CompoundStructure Class


IsRectangularRegion Method

[image]

Revit 2024 API
CompoundStructure..::..IsRectangularRegion Method
CompoundStructure Class See Also Send Feedback
Determines whether the specified region is rectangular.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsRectangularRegion(
    int regionId
)
Visual Basic
Public Function IsRectangularRegion ( _
    regionId As Integer _
) As Boolean
Visual C++
public:
bool IsRectangularRegion(
    int regionId
)

Parameters

regionId
Type: System..::..Int32
The id of a region.

Return Value

True if the specified region is a rectangle, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | It is not a valid region id.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only for vertically compound structures.

See Also

CompoundStructure Class


IsSimpleRegion Method

[image]

Revit 2024 API
CompoundStructure..::..IsSimpleRegion Method
CompoundStructure Class See Also Send Feedback
Determines whether the region is a simple region in this CompoundStructure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsSimpleRegion(
    int regionId
)
Visual Basic
Public Function IsSimpleRegion ( _
    regionId As Integer _
) As Boolean
Visual C++
public:
bool IsSimpleRegion(
    int regionId
)

Parameters

regionId
Type: System..::..Int32
The id of a region in this vertically compound structure.

Return Value

True if the region is simple, false otherwise.

Remarks

A region is simple if it rectangular and spans the height of the wall.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | It is not a valid region id.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only for vertically compound structures.

See Also

CompoundStructure Class


IsStructuralDeck Method

[image]

Revit 2024 API
CompoundStructure..::..IsStructuralDeck Method
CompoundStructure Class See Also Send Feedback
Determines whether a specified layer is a structural deck.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsStructuralDeck(
    int layerIdx
)
Visual Basic
Public Function IsStructuralDeck ( _
    layerIdx As Integer _
) As Boolean
Visual C++
public:
bool IsStructuralDeck(
    int layerIdx
)

Parameters

layerIdx
Type: System..::..Int32
Index of a layer in the CompoundStructure.

Return Value

True if specified layer is a structural deck, and false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The layer index is out of range.

See Also

CompoundStructure Class


IsValidRegionId Method

[image]

Revit 2024 API
CompoundStructure..::..IsValidRegionId Method
CompoundStructure Class See Also Send Feedback
Determines whether the specified integer is actually the id of a region in this CompoundStructure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsValidRegionId(
    int regionId
)
Visual Basic
Public Function IsValidRegionId ( _
    regionId As Integer _
) As Boolean
Visual C++
public:
bool IsValidRegionId(
    int regionId
)

Parameters

regionId
Type: System..::..Int32
The id of a region in this vertically compound structure.

Return Value

True if the region is valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only for vertically compound structures.

See Also

CompoundStructure Class


IsValidSampleHeight Method

[image]

Revit 2024 API
CompoundStructure..::..IsValidSampleHeight Method
CompoundStructure Class See Also Send Feedback
Is the specified height a valid sample height for this compound structure?

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsValidSampleHeight(
    double height
)
Visual Basic
Public Function IsValidSampleHeight ( _
    height As Double _
) As Boolean
Visual C++
public:
bool IsValidSampleHeight(
    double height
)

Parameters

height
Type: System..::..Double

Remarks

The sample height cannot be less than the value of MinimumSampleHeight.

See Also

CompoundStructure Class


IsValidSegmentId Method

[image]

Revit 2024 API
CompoundStructure..::..IsValidSegmentId Method
CompoundStructure Class See Also Send Feedback
Determines whether the specified integer is actually the id of a segment in this CompoundStructure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsValidSegmentId(
    int segmentId
)
Visual Basic
Public Function IsValidSegmentId ( _
    segmentId As Integer _
) As Boolean
Visual C++
public:
bool IsValidSegmentId(
    int segmentId
)

Parameters

segmentId
Type: System..::..Int32
The id of a segment in this CompoundStructure.

Return Value

True if the specified segment is valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only for vertically compound structures.

See Also

CompoundStructure Class


IsVerticallyHomogeneous Method

[image]

Revit 2024 API
CompoundStructure..::..IsVerticallyHomogeneous Method
CompoundStructure Class See Also Send Feedback
Indicates whether this CompoundStructure represents a single set of parallel layers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsVerticallyHomogeneous()
Visual Basic
Public Function IsVerticallyHomogeneous As Boolean
Visual C++
public:
bool IsVerticallyHomogeneous()

Return Value

True if this CompoundStructure represents a series of parallel layers that stretch from bottom to top, false otherwise.

Remarks

Differs from IsVerticallyCompound as a vertically compound structure might happen not to have any horizontal breaks. For that situation, both IsVerticallyCompound and this method will return true.

See Also

CompoundStructure Class


ParticipatesInWrapping Method

[image]

Revit 2024 API
CompoundStructure..::..ParticipatesInWrapping Method
CompoundStructure Class See Also Send Feedback
Identifies if a layer is included in wrapping at inserts and ends.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool ParticipatesInWrapping(
    int layerIdx
)
Visual Basic
Public Function ParticipatesInWrapping ( _
    layerIdx As Integer _
) As Boolean
Visual C++
public:
bool ParticipatesInWrapping(
    int layerIdx
)

Parameters

layerIdx
Type: System..::..Int32
The index of the layer.

Return Value

If true, then the layer participates in wrapping at inserts and openings. If false, the layer will not participate in wrapping.

Remarks

This method applies only to interior and exterior shell layers.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The layer index is out of range.

See Also

CompoundStructure Class


SetDeckEmbeddingType Method

[image]

Revit 2024 API
CompoundStructure..::..SetDeckEmbeddingType Method
CompoundStructure Class See Also Send Feedback
Sets the deck embedding type to use for the specified structural deck.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetDeckEmbeddingType(
    int layerIdx,
    StructDeckEmbeddingType embedType
)
Visual Basic
Public Sub SetDeckEmbeddingType ( _
    layerIdx As Integer, _
    embedType As StructDeckEmbeddingType _
)
Visual C++
public:
void SetDeckEmbeddingType(
    int layerIdx,
    StructDeckEmbeddingType embedType
)

Parameters

layerIdx
Type: System..::..Int32
Index of a layer in the CompoundStructure.
embedType
Type: Autodesk.Revit.DB..::..StructDeckEmbeddingType
The embedding type to be used by the specified layer if it is a structural deck.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The layer is not a structural deck.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The layer index is out of range. -or- A value passed for an enumeration argument is not a member of that enumeration

See Also

CompoundStructure Class


SetDeckProfileId Method

[image]

Revit 2024 API
CompoundStructure..::..SetDeckProfileId Method
CompoundStructure Class See Also Send Feedback
Sets the profile loop to use for the specified structural deck.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetDeckProfileId(
    int layerIdx,
    ElementId profileId
)
Visual Basic
Public Sub SetDeckProfileId ( _
    layerIdx As Integer, _
    profileId As ElementId _
)
Visual C++
public:
void SetDeckProfileId(
    int layerIdx,
    ElementId^ profileId
)

Parameters

layerIdx
Type: System..::..Int32
Index of a layer in the CompoundStructure.
profileId
Type: Autodesk.Revit.DB..::..ElementId
The element id of a FamilySymbol which contains a profile loop to be used by the specified layer if it is a structural deck.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The layer is not a structural deck.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The layer index is out of range.

See Also

CompoundStructure Class


SetExtendableRegionIds Method

[image]

Revit 2024 API
CompoundStructure..::..SetExtendableRegionIds Method
CompoundStructure Class See Also Send Feedback
Sets the extendable region ids for the compound structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetExtendableRegionIds(
    bool top,
    IList<int> regionIds
)
Visual Basic
Public Sub SetExtendableRegionIds ( _
    top As Boolean, _
    regionIds As IList(Of Integer) _
)
Visual C++
public:
void SetExtendableRegionIds(
    bool top,
    IList<int>^ regionIds
)

Parameters

top
Type: System..::..Boolean
If true, set ids of regions which are extendable at the top, otherwise set the ids of regions which are extendable at the bottom.
regionIds
Type: System.Collections.Generic..::..IList<(Of <(<'Int32>)>)>
The ids of regions which will be extendable.

Remarks

Regions along the top or bottom of the wall may be set to be extendable.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The region ids are not valid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only for vertically compound structures.

See Also

CompoundStructure Class


SetLayer Method

[image]

Revit 2024 API
CompoundStructure..::..SetLayer Method
CompoundStructure Class See Also Send Feedback
Sets a single layer for this CompoundStructure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetLayer(
    int layerIdx,
    CompoundStructureLayer layer
)
Visual Basic
Public Sub SetLayer ( _
    layerIdx As Integer, _
    layer As CompoundStructureLayer _
)
Visual C++
public:
void SetLayer(
    int layerIdx,
    CompoundStructureLayer^ layer
)

Parameters

layerIdx
Type: System..::..Int32
The index of a layer. This should range from 0 to the number of layers - 1.
layer
Type: Autodesk.Revit.DB..::..CompoundStructureLayer
The layer to be set.

Remarks

This function does not support addition of new layers, use SetLayers() to change the number of layers.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The layer is not valid for this operation.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The layer index is out of range.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only for non-vertically compound structures.

See Also

CompoundStructure Class


SetLayerFunction Method

[image]

Revit 2024 API
CompoundStructure..::..SetLayerFunction Method
CompoundStructure Class See Also Send Feedback
Sets the function of the specified layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetLayerFunction(
    int layerIdx,
    MaterialFunctionAssignment function
)
Visual Basic
Public Sub SetLayerFunction ( _
    layerIdx As Integer, _
    function As MaterialFunctionAssignment _
)
Visual C++
public:
void SetLayerFunction(
    int layerIdx,
    MaterialFunctionAssignment function
)

Parameters

layerIdx
Type: System..::..Int32
Index of a layer in the CompoundStructure.
function
Type: Autodesk.Revit.DB..::..MaterialFunctionAssignment
The function of the layer.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The layer index is out of range. -or- A value passed for an enumeration argument is not a member of that enumeration

See Also

CompoundStructure Class


SetLayers Method

[image]

Revit 2024 API
CompoundStructure..::..SetLayers Method
CompoundStructure Class See Also Send Feedback
Completely resets this CompoundStructure and applies a new set of layers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetLayers(
    IList<CompoundStructureLayer> layers
)
Visual Basic
Public Sub SetLayers ( _
    layers As IList(Of CompoundStructureLayer) _
)
Visual C++
public:
void SetLayers(
    IList<CompoundStructureLayer^>^ layers
)

Parameters

layers
Type: System.Collections.Generic..::..IList<(Of <(<' CompoundStructureLayer >)>)>
The layers to be set.

Remarks

This function will replace all existing layers with the contents of the input. This provides a full reset for the CompoundStructure. Therefore:
  • All layers will be marked as Core layers, and any settings related to Shell layers (such as GetFirstCoreLayerIndex()()()(), GetLastCoreLayerIndex()()()() or GetCoreBoundaryLayerIndex(ShellLayerType)) will be modified accordingly.
  • Because all layers will be set as Core layers, the value of LayerCapFlag will be ignored (and set to true) automatically.
  • The VariableLayerIndex will be unset.
  • The StructuralMaterialIndex will be unset.
  • The compound structure will be set to be vertically homogeneous.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

CompoundStructure Class


SetLayerWidth Method

[image]

Revit 2024 API
CompoundStructure..::..SetLayerWidth Method
CompoundStructure Class See Also Send Feedback
Sets the width of a specified layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetLayerWidth(
    int layerIdx,
    double width
)
Visual Basic
Public Sub SetLayerWidth ( _
    layerIdx As Integer, _
    width As Double _
)
Visual C++
public:
void SetLayerWidth(
    int layerIdx,
    double width
)

Parameters

layerIdx
Type: System..::..Int32
Index of a layer in the CompoundStructure.
width
Type: System..::..Double
The new width of the specified layer.

Remarks

If the structure is vertically compound, and the layer is associated to a single simple region, the width of that region is adjusted. If layerIdx is 0 or LayerCount-1, and there is no associated region in the VerticalRegionsStructure, one will be created and associated to the layer. If the specified layer index is associated to a simple region, and the width is set to 0.0, that region will be deleted.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The width of the layer is not valid.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The layer index is out of range.
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the region of the layer is not a simple region.

See Also

CompoundStructure Class


SetMaterialId Method

[image]

Revit 2024 API
CompoundStructure..::..SetMaterialId Method
CompoundStructure Class See Also Send Feedback
Sets a material element for a specified layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetMaterialId(
    int layerIdx,
    ElementId materialId
)
Visual Basic
Public Sub SetMaterialId ( _
    layerIdx As Integer, _
    materialId As ElementId _
)
Visual C++
public:
void SetMaterialId(
    int layerIdx,
    ElementId^ materialId
)

Parameters

layerIdx
Type: System..::..Int32
Index of a layer in the CompoundStructure.
materialId
Type: Autodesk.Revit.DB..::..ElementId
The ElementId of a Material element.

Remarks

It is not verified that materialId corresponds to a valid Material element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The layer index is out of range.

See Also

CompoundStructure Class


SetNumberOfShellLayers Method

[image]

Revit 2024 API
CompoundStructure..::..SetNumberOfShellLayers Method
CompoundStructure Class See Also Send Feedback
Sets the number of interior or exterior shell layers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetNumberOfShellLayers(
    ShellLayerType shellLayerType,
    int numLayers
)
Visual Basic
Public Sub SetNumberOfShellLayers ( _
    shellLayerType As ShellLayerType, _
    numLayers As Integer _
)
Visual C++
public:
void SetNumberOfShellLayers(
    ShellLayerType shellLayerType,
    int numLayers
)

Parameters

shellLayerType
Type: Autodesk.Revit.DB..::..ShellLayerType
If ShellLayerType.Exterior set the number of exterior shell layers (or top shell layers for a roof, floor, or ceiling type). If ShellLayerType.Interior set the number of interior shell layers (or bottom shell layers for a roof, floor, or ceiling type).
numLayers
Type: System..::..Int32
The number of layers to be in the specified shell.

Remarks

There must be at least one core layer, i.e. one layer which is not a shell layer.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Number of shell layers is negative. -or- A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | Too many shell layers: there must be at least one core layer.

See Also

CompoundStructure Class


SetParticipatesInWrapping Method

[image]

Revit 2024 API
CompoundStructure..::..SetParticipatesInWrapping Method
CompoundStructure Class See Also Send Feedback
Assigns if a layer is included in wrapping at inserts and ends.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetParticipatesInWrapping(
    int layerIdx,
    bool participatesInWrapping
)
Visual Basic
Public Sub SetParticipatesInWrapping ( _
    layerIdx As Integer, _
    participatesInWrapping As Boolean _
)
Visual C++
public:
void SetParticipatesInWrapping(
    int layerIdx,
    bool participatesInWrapping
)

Parameters

layerIdx
Type: System..::..Int32
The index of the layer.
participatesInWrapping
Type: System..::..Boolean
True if the specified layer will participate in wrapping at inserts and ends, false otherwise.

Remarks

This method applies only to interior and exterior shell layers.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The wrapping of the layer is not valid.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The layer index is out of range.

See Also

CompoundStructure Class


SplitRegion Method

[image] [image]

Revit 2024 API
CompoundStructure..::..SplitRegion Method
CompoundStructure Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SplitRegion(UV, RectangularGridSegmentOrientation) | Splits the region which contains the specified grid point by a line with the specified direction.
Public method | SplitRegion(UV, RectangularGridSegmentOrientation, Int32%) | Splits the region which contains the specified grid point by a line with the specified direction.

See Also

CompoundStructure Class
CompoundStructure Members


SplitRegion Method (UV, RectangularGridSegmentOrientation)

[image]

Revit 2024 API
CompoundStructure..::..SplitRegion Method (UV, RectangularGridSegmentOrientation)
CompoundStructure Class See Also Send Feedback
Splits the region which contains the specified grid point by a line with the specified direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public int SplitRegion(
    UV gridUV,
    RectangularGridSegmentOrientation splitDirection
)
Visual Basic
Public Function SplitRegion ( _
    gridUV As UV, _
    splitDirection As RectangularGridSegmentOrientation _
) As Integer
Visual C++
public:
int SplitRegion(
    UV^ gridUV,
    RectangularGridSegmentOrientation splitDirection
)

Parameters

gridUV
Type: Autodesk.Revit.DB..::..UV
Coordinates of a point in the rectangular grid of this compound structure.
splitDirection
Type: Autodesk.Revit.DB..::..RectangularGridSegmentOrientation
Specifies the direction of the split.

Return Value

The id of the region created by this operation.

Remarks

This method is meant to be used in conjunction with FindEnclosingRegionAndSegments(UV, RectangularGridSegmentOrientation, Int32%, Int32%). Grid coordinates correspond to uv coordinates of faces.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | Split and merge regions operations can be used only for vertically compound structures without variable thickness layers.

See Also

CompoundStructure Class
SplitRegion Overload


SplitRegion Method (UV, RectangularGridSegmentOrientation, Int32)

[image]

Revit 2024 API
CompoundStructure..::..SplitRegion Method (UV, RectangularGridSegmentOrientation, Int32%)
CompoundStructure Class See Also Send Feedback
Splits the region which contains the specified grid point by a line with the specified direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public int SplitRegion(
    UV gridUV,
    RectangularGridSegmentOrientation splitDirection,
    out int newSegmentId
)
Visual Basic
Public Function SplitRegion ( _
    gridUV As UV, _
    splitDirection As RectangularGridSegmentOrientation, _
    <OutAttribute> ByRef newSegmentId As Integer _
) As Integer
Visual C++
public:
int SplitRegion(
    UV^ gridUV,
    RectangularGridSegmentOrientation splitDirection,
    [OutAttribute] int% newSegmentId
)

Parameters

gridUV
Type: Autodesk.Revit.DB..::..UV
Coordinates of a point in the rectangular grid of this compound structure.
splitDirection
Type: Autodesk.Revit.DB..::..RectangularGridSegmentOrientation
Specifies the direction of the split.
newSegmentId
Type: System..::..Int32%
The id of segment that bounds both the original region and the new region.

Return Value

The id of the region created by this operation.

Remarks

This method is meant to be used in conjunction with FindEnclosingRegionAndSegments(UV, RectangularGridSegmentOrientation, Int32%, Int32%). Grid coordinates correspond to uv coordinates of faces.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | Split and merge regions operations can be used only for vertically compound structures without variable thickness layers.

See Also

CompoundStructure Class
SplitRegion Overload


CompoundStructure Properties

[image] [image]

Revit 2024 API
CompoundStructure Properties
CompoundStructure Class See Also Send Feedback

The CompoundStructure type exposes the following members.

Properties

 | Name | Description
Public property | CutoffHeight | Horizontal segments below or at the cutoff height have their distance to the wall bottom fixed, those above have their distance to the wall top fixed.
Public property | EndCap | Indicates the end cap condition defining which shell layers will participate in end wrapping.
Public property | HasStructuralDeck | Checks if the compound structure has a structural deck.
Public property | IsEmpty | Checks whether this CompoundStructure is empty.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | IsVerticallyCompound | Identifies if this CompoundStructure represents a layout that is more complicated than a simple set of parallel layers.
Public property | LayerCount | Returns the number of layers contained in this CompoundStructure.
Public property | MinimumSampleHeight | The minimum sample height determined by the current sample height and the horizontal segments.
Public property | OpeningWrapping | Indicates the opening wrapping condition defining which shell layers of a wall, in plan view, wrap at inserts and openings.
Public property | SampleHeight | The sample height is the presumed height of the wall to which the data in this CompoundStructure is applied.
Public property | StructuralMaterialIndex | Indicates the layer whose material defines the structural properties of the type for the purposes of analysis.
Public property | VariableLayerIndex | Indicates the index of the layer which is designated as variable.

See Also

CompoundStructure Class


CutoffHeight Property

[image]

Revit 2024 API
CompoundStructure..::..CutoffHeight Property
CompoundStructure Class See Also Send Feedback
Horizontal segments below or at the cutoff height have their distance to the wall bottom fixed, those above have their distance to the wall top fixed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double CutoffHeight { get; set; }
Visual Basic
Public Property CutoffHeight As Double
    Get
    Set
Visual C++
public:
property double CutoffHeight {
    double get ();
    void set (double value);
}

Field Value

The cutoff height of this CompoundStructure.

Remarks

This allows layers with one horizontal segment above and one below this line to be of variable height.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only for vertically compound structures.

See Also

CompoundStructure Class


EndCap Property

[image]

Revit 2024 API
CompoundStructure..::..EndCap Property
CompoundStructure Class See Also Send Feedback
Indicates the end cap condition defining which shell layers will participate in end wrapping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public EndCapCondition EndCap { get; set; }
Visual Basic
Public Property EndCap As EndCapCondition
    Get
    Set
Visual C++
public:
property EndCapCondition EndCap {
    EndCapCondition get ();
    void set (EndCapCondition value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

CompoundStructure Class


HasStructuralDeck Property

[image]

Revit 2024 API
CompoundStructure..::..HasStructuralDeck Property
CompoundStructure Class See Also Send Feedback
Checks if the compound structure has a structural deck.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool HasStructuralDeck { get; }
Visual Basic
Public ReadOnly Property HasStructuralDeck As Boolean
    Get
Visual C++
public:
property bool HasStructuralDeck {
    bool get ();
}

See Also

CompoundStructure Class


IsEmpty Property

[image]

Revit 2024 API
CompoundStructure..::..IsEmpty Property
CompoundStructure Class See Also Send Feedback
Checks whether this CompoundStructure is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsEmpty { get; }
Visual Basic
Public ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
property bool IsEmpty {
    bool get ();
}

See Also

CompoundStructure Class


IsValidObject Property

[image]

Revit 2024 API
CompoundStructure..::..IsValidObject Property
CompoundStructure Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

CompoundStructure Class


LayerCount Property

[image]

Revit 2024 API
CompoundStructure..::..LayerCount Property
CompoundStructure Class See Also Send Feedback
Returns the number of layers contained in this CompoundStructure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public int LayerCount { get; }
Visual Basic
Public ReadOnly Property LayerCount As Integer
    Get
Visual C++
public:
property int LayerCount {
    int get ();
}

Remarks

Establishes the valid range of indices passed to various access functions: [0 ... this value - 1]

See Also

CompoundStructure Class


SampleHeight Property

[image]

Revit 2024 API
CompoundStructure..::..SampleHeight Property
CompoundStructure Class See Also Send Feedback
The sample height is the presumed height of the wall to which the data in this CompoundStructure is applied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double SampleHeight { get; set; }
Visual Basic
Public Property SampleHeight As Double
    Get
    Set
Visual C++
public:
property double SampleHeight {
    double get ();
    void set (double value);
}

Field Value

The height of the wall used to define the vertically compound structure.

Remarks

This value has meaning only for vertically compound structures. In order to apply this CompoundStructure to a wall whose height differs from the sample height, the underlying grid will be rescaled.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The value newSampleHeight is smaller than the value of MinimumSampleHeight.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only for vertically compound structures.

See Also

CompoundStructure Class


CompoundStructureError Enumeration

[image]

Revit 2024 API
CompoundStructureError Enumeration
See Also Send Feedback
When CompoundStructure::isValid() returns false, it uses these values to indicate precise nature of defect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public enum CompoundStructureError
Visual Basic
Public Enumeration CompoundStructureError
Visual C++
public enum class CompoundStructureError

Members

Member name | Description
BadShellOrder | Layer Function Priorities ascend from the Core Boundary to the Finish Face.
CoreTooThin | Core contain a membrane layer or thickness of core is zero.
MembraneTooThick | Thickness of membrane layer is more than zero.
NonmembraneTooThin | Thickness of non-membrane layer is too thin.
BadShellsStructure | The number of shell layers is larger than the total number of layers.
ThinOuterLayer | Thickness of face layer is too thin.
VerticalUnusedLayer | A layer is not membrane layer and the Thickness of layer is zero.
VerticalWrongOrderLayer | Layers assigned to the same Row are not on the same side of the Core Boundary.
VerticalWrongOrderCoreExterior | Exterior core boundary have more than one face at any height.
VerticalWrongOrderCoreInterior | Interior core boundary have more than one face at any height.
VerticalWrongOrderMembrane | Membrane Layer have more than one face at any height.
DeckCantBoundAbove | There is no layer above Structural deck or it is too thin.
DeckCantBoundBelow | There is no layer below Structural deck or it is too thin.
VarThickLayerCantBeZero | Variable thickness layer have zero thickness.
InvalidMaterialId | Element id used as material id does not correspond to an actual MaterialElem.
ExtensibleRegionsNotContiguousAlongTop | Extension Layers at the top of the wall must be adjacent.
ExtensibleRegionsNotContiguousAlongBottom | Extension Layers at the bottom of the wall must be adjacent.
InvalidProfileId | Element id used as profile id does not correspond to a valid deck profile.

Remarks

'LayerTooThin' enum value was removed in 2016

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


CompoundStructureLayer Constructor

[image]

Revit 2024 API
CompoundStructureLayer Constructor
CompoundStructureLayer Class See Also Send Feedback
Creates a compound structure layer using default settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CompoundStructureLayer()
Visual Basic
Public Sub New
Visual C++
public:
CompoundStructureLayer()

Remarks

Note that the combination of the default values does not create a completely valid CompoundStructureLayer. You should change the necessary values before adding to a CompoundStructure.

See Also

CompoundStructureLayer Class
CompoundStructureLayer Overload


CompoundStructureLayer Constructor (CompoundStructureLayer)

[image]

Revit 2024 API
CompoundStructureLayer Constructor (CompoundStructureLayer)
CompoundStructureLayer Class See Also Send Feedback
Creates a copy of a compound structure layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CompoundStructureLayer(
    CompoundStructureLayer cs
)
Visual Basic
Public Sub New ( _
    cs As CompoundStructureLayer _
)
Visual C++
public:
CompoundStructureLayer(
    CompoundStructureLayer^ cs
)

Parameters

cs
Type: Autodesk.Revit.DB..::..CompoundStructureLayer
The compound structure to copy.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

CompoundStructureLayer Class
CompoundStructureLayer Overload


CompoundStructureLayer Constructor (Double, MaterialFunctionAssignment, ElementId)

[image]

Revit 2024 API
CompoundStructureLayer Constructor (Double, MaterialFunctionAssignment, ElementId)
CompoundStructureLayer Class See Also Send Feedback
Creates a default compound structure layer based on the given width, function and material element id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CompoundStructureLayer(
    double width,
    MaterialFunctionAssignment function,
    ElementId materialId
)
Visual Basic
Public Sub New ( _
    width As Double, _
    function As MaterialFunctionAssignment, _
    materialId As ElementId _
)
Visual C++
public:
CompoundStructureLayer(
    double width,
    MaterialFunctionAssignment function,
    ElementId^ materialId
)

Parameters

width
Type: System..::..Double
The width of the layer.
function
Type: Autodesk.Revit.DB..::..MaterialFunctionAssignment
The function of the layer.
materialId
Type: Autodesk.Revit.DB..::..ElementId
The material element id of the layer.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

CompoundStructureLayer Class
CompoundStructureLayer Overload


CompoundStructureLayer Methods

[image] [image]

Revit 2024 API
CompoundStructureLayer Methods
CompoundStructureLayer Class See Also Send Feedback

The CompoundStructureLayer type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CompoundStructureLayer Class


Dispose Method

[image]

Revit 2024 API
CompoundStructureLayer..::..Dispose Method
CompoundStructureLayer Class See Also Send Feedback
Releases all resources used by the CompoundStructureLayer

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

CompoundStructureLayer Class


DeckEmbeddingType Property

[image]

Revit 2024 API
CompoundStructureLayer..::..DeckEmbeddingType Property
CompoundStructureLayer Class See Also Send Feedback
Embedding type for structural deck - only for a layer whose function is StructuralDeck.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public StructDeckEmbeddingType DeckEmbeddingType { get; set; }
Visual Basic
Public Property DeckEmbeddingType As StructDeckEmbeddingType
    Get
    Set
Visual C++
public:
property StructDeckEmbeddingType DeckEmbeddingType {
    StructDeckEmbeddingType get ();
    void set (StructDeckEmbeddingType value);
}

Field Value

The default is StructDeckEmbeddingType.Invalid.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

CompoundStructureLayer Class


DeckProfileId Property

[image]

Revit 2024 API
CompoundStructureLayer..::..DeckProfileId Property
CompoundStructureLayer Class See Also Send Feedback
The ElementId of the structural deck profile - only for a layer whose function is StructuralDeck.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElementId DeckProfileId { get; set; }
Visual Basic
Public Property DeckProfileId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ DeckProfileId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Field Value

The default is InvalidElementId.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

CompoundStructureLayer Class


Function Property

[image]

Revit 2024 API
CompoundStructureLayer..::..Function Property
CompoundStructureLayer Class See Also Send Feedback
The function of the layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public MaterialFunctionAssignment Function { get; set; }
Visual Basic
Public Property Function As MaterialFunctionAssignment
    Get
    Set
Visual C++
public:
property MaterialFunctionAssignment Function {
    MaterialFunctionAssignment get ();
    void set (MaterialFunctionAssignment value);
}

Field Value

The default is MaterialFunctionAssignment.None.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

CompoundStructureLayer Class


IsValidObject Property

[image]

Revit 2024 API
CompoundStructureLayer..::..IsValidObject Property
CompoundStructureLayer Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

CompoundStructureLayer Class


LayerCapFlag Property

[image]

Revit 2024 API
CompoundStructureLayer..::..LayerCapFlag Property
CompoundStructureLayer Class See Also Send Feedback
Identifies if the layer participates in wrapping at end caps and/or inserts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool LayerCapFlag { get; set; }
Visual Basic
Public Property LayerCapFlag As Boolean
    Get
    Set
Visual C++
public:
property bool LayerCapFlag {
    bool get ();
    void set (bool value);
}

Field Value

True if the layer participates in wrapping, false otherwise. It is meaningful only for Shell layers (for Core layers, the value is always true). The default value is true.

See Also

CompoundStructureLayer Class


LayerId Property

[image]

Revit 2024 API
CompoundStructureLayer..::..LayerId Property
CompoundStructureLayer Class See Also Send Feedback
The id of the layer - note that this may be different from the index in the array of layers in a CompoundStructure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public int LayerId { get; }
Visual Basic
Public ReadOnly Property LayerId As Integer
    Get
Visual C++
public:
property int LayerId {
    int get ();
}

See Also

CompoundStructureLayer Class


MaterialId Property

[image]

Revit 2024 API
CompoundStructureLayer..::..MaterialId Property
CompoundStructureLayer Class Example See Also Send Feedback
Id of the material assigned to this layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElementId MaterialId { get; set; }
Visual Basic
Public Property MaterialId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ MaterialId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Field Value

The default is InvalidElementId.

Examples

CopyC#
public void GetWallLayerMaterial(Autodesk.Revit.DB.Document document, Wall wall)
{
    // get WallType of wall
    WallType aWallType = wall.WallType;
    // Only Basic Wall has compoundStructure
    if (WallKind.Basic == aWallType.Kind)
    {
        // Get CompoundStructure
        CompoundStructure comStruct = aWallType.GetCompoundStructure();
        Categories allCategories = document.Settings.Categories;

        // Get the category OST_Walls default Material;
        // use if that layer's default Material is <By Category>
        Category wallCategory = allCategories.get_Item(BuiltInCategory.OST_Walls);
        Autodesk.Revit.DB.Material wallMaterial = wallCategory.Material;

        foreach (CompoundStructureLayer structLayer in comStruct.GetLayers())
        {
            Autodesk.Revit.DB.Material layerMaterial = document.GetElement(structLayer.MaterialId) as Material;

            // If CompoundStructureLayer's Material is specified, use default
            // Material of its Category
            if (null == layerMaterial)
            {
                switch (structLayer.Function)
                {
                    case MaterialFunctionAssignment.Finish1:
                        layerMaterial =
                            allCategories.get_Item(BuiltInCategory.OST_WallsFinish1).Material;
                        break;
                    case MaterialFunctionAssignment.Finish2:
                        layerMaterial =
                            allCategories.get_Item(BuiltInCategory.OST_WallsFinish2).Material;
                        break;
                    case MaterialFunctionAssignment.Membrane:
                        layerMaterial =
                            allCategories.get_Item(BuiltInCategory.OST_WallsMembrane).Material;
                        break;
                    case MaterialFunctionAssignment.Structure:
                        layerMaterial =
                            allCategories.get_Item(BuiltInCategory.OST_WallsStructure).Material;
                        break;
                    case MaterialFunctionAssignment.Substrate:
                        layerMaterial =
                            allCategories.get_Item(BuiltInCategory.OST_WallsSubstrate).Material;
                        break;
                    case MaterialFunctionAssignment.Insulation:
                        layerMaterial =
                            allCategories.get_Item(BuiltInCategory.OST_WallsInsulation).Material;
                        break;
                    default:
                        // It is impossible to reach here
                        break;
                }
                if (null == layerMaterial)
                {
                    // CompoundStructureLayer's default Material is its SubCategory
                    layerMaterial = wallMaterial;
                }
            }
            TaskDialog.Show("Revit","Layer Material: " + layerMaterial);
        }
    }
}
CopyVB.NET
Public Sub GetWallLayerMaterial(document As Autodesk.Revit.DB.Document, wall As Wall)
    ' get WallType of wall
    Dim aWallType As WallType = wall.WallType
    ' Only Basic Wall has compoundStructure
    If WallKind.Basic = aWallType.Kind Then
        ' Get CompoundStructure
        Dim comStruct As CompoundStructure = aWallType.GetCompoundStructure()
        Dim allCategories As Categories = document.Settings.Categories

        ' Get the category OST_Walls default Material;
        ' use if that layer's default Material is <By Category>
        Dim wallCategory As Category = allCategories.Item(BuiltInCategory.OST_Walls)
        Dim wallMaterial As Autodesk.Revit.DB.Material = wallCategory.Material

        For Each structLayer As CompoundStructureLayer In comStruct.GetLayers()
            Dim layerMaterial As Autodesk.Revit.DB.Material = TryCast(document.GetElement(structLayer.MaterialId), Material)

            ' If CompoundStructureLayer's Material is specified, use default
            ' Material of its Category
            If layerMaterial Is Nothing Then
                Select Case structLayer.[Function]
                    Case MaterialFunctionAssignment.Finish1
                        layerMaterial = allCategories.Item(BuiltInCategory.OST_WallsFinish1).Material
                        Exit Select
                    Case MaterialFunctionAssignment.Finish2
                        layerMaterial = allCategories.Item(BuiltInCategory.OST_WallsFinish2).Material
                        Exit Select
                    Case MaterialFunctionAssignment.Membrane
                        layerMaterial = allCategories.Item(BuiltInCategory.OST_WallsMembrane).Material
                        Exit Select
                    Case MaterialFunctionAssignment.[Structure]
                        layerMaterial = allCategories.Item(BuiltInCategory.OST_WallsStructure).Material
                        Exit Select
                    Case MaterialFunctionAssignment.Substrate
                        layerMaterial = allCategories.Item(BuiltInCategory.OST_WallsSubstrate).Material
                        Exit Select
                    Case MaterialFunctionAssignment.Insulation
                        layerMaterial = allCategories.Item(BuiltInCategory.OST_WallsInsulation).Material
                        Exit Select
                    Case Else
                        ' It is impossible to reach here
                        Exit Select
                End Select
                If layerMaterial Is Nothing Then
                    ' CompoundStructureLayer's default Material is its SubCategory
                    layerMaterial = wallMaterial
                End If
            End If
            TaskDialog.Show("Revit", "Layer Material: " & layerMaterial.ToString())
        Next
    End If
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

CompoundStructureLayer Class


Width Property

[image]

Revit 2024 API
CompoundStructureLayer..::..Width Property
CompoundStructureLayer Class See Also Send Feedback
Width of the layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double Width { get; set; }
Visual Basic
Public Property Width As Double
    Get
    Set
Visual C++
public:
property double Width {
    double get ();
    void set (double value);
}

Remarks

Can be 0.0 if this is a membrane layer. 0.0 is the default.

See Also

CompoundStructureLayer Class


ConfigurationReloadInfo Members

[image] [image]

Revit 2024 API
ConfigurationReloadInfo Members
ConfigurationReloadInfo Class Constructors Methods Properties See Also Send Feedback

The ConfigurationReloadInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ConfigurationReloadInfo | Constructor.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ConfigurationReloadInfo
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetConnectivityValidation | Returns information about the post-reload connectivity validation.
Public method | GetCustomDataChangedElements | Gets a list of ElementIds of fabrication parts that had custom data updated during the reload.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOutOfDatePartStatus | Access reload information for out of date part.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Disconnects | The number of disconnections caused by the reload.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OutOfDatePartCount | The number of fabrication part instances that had newer versions and were out of date.
Public property | ProfileNotAvailable | The current profile is not available in the disk configuration.

See Also

ConfigurationReloadInfo Class


Dispose Method

[image]

Revit 2024 API
ConfigurationReloadInfo..::..Dispose Method
ConfigurationReloadInfo Class See Also Send Feedback
Releases all resources used by the ConfigurationReloadInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ConfigurationReloadInfo Class


GetCustomDataChangedElements Method

[image]

Revit 2024 API
ConfigurationReloadInfo..::..GetCustomDataChangedElements Method
ConfigurationReloadInfo Class See Also Send Feedback
Gets a list of ElementIds of fabrication parts that had custom data updated during the reload.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public ISet<ElementId> GetCustomDataChangedElements()
Visual Basic
Public Function GetCustomDataChangedElements As ISet(Of ElementId)
Visual C++
public:
ISet<ElementId^>^ GetCustomDataChangedElements()

Return Value

A list identifying changed elements.

See Also

ConfigurationReloadInfo Class


GetOutOfDatePartStatus Method

[image]

Revit 2024 API
ConfigurationReloadInfo..::..GetOutOfDatePartStatus Method
ConfigurationReloadInfo Class See Also Send Feedback
Access reload information for out of date part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public ReloadSwapOutInfo GetOutOfDatePartStatus(
    int index
)
Visual Basic
Public Function GetOutOfDatePartStatus ( _
    index As Integer _
) As ReloadSwapOutInfo
Visual C++
public:
ReloadSwapOutInfo^ GetOutOfDatePartStatus(
    int index
)

Parameters

index
Type: System..::..Int32
The index of the information about the part being reloaded. Must be between 0 and OutOfDatePartCount.

Return Value

Information about the part being reloaded.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The index is out of range.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

ConfigurationReloadInfo Class


ConfigurationReloadInfo Properties

[image] [image]

Revit 2024 API
ConfigurationReloadInfo Properties
ConfigurationReloadInfo Class See Also Send Feedback

The ConfigurationReloadInfo type exposes the following members.

Properties

 | Name | Description
Public property | Disconnects | The number of disconnections caused by the reload.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OutOfDatePartCount | The number of fabrication part instances that had newer versions and were out of date.
Public property | ProfileNotAvailable | The current profile is not available in the disk configuration.

See Also

ConfigurationReloadInfo Class


Disconnects Property

[image]

Revit 2024 API
ConfigurationReloadInfo..::..Disconnects Property
ConfigurationReloadInfo Class See Also Send Feedback
The number of disconnections caused by the reload.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public int Disconnects { get; }
Visual Basic
Public ReadOnly Property Disconnects As Integer
    Get
Visual C++
public:
property int Disconnects {
    int get ();
}

See Also

ConfigurationReloadInfo Class


IsValidObject Property

[image]

Revit 2024 API
ConfigurationReloadInfo..::..IsValidObject Property
ConfigurationReloadInfo Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ConfigurationReloadInfo Class


OutOfDatePartCount Property

[image]

Revit 2024 API
ConfigurationReloadInfo..::..OutOfDatePartCount Property
ConfigurationReloadInfo Class See Also Send Feedback
The number of fabrication part instances that had newer versions and were out of date.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public int OutOfDatePartCount { get; }
Visual Basic
Public ReadOnly Property OutOfDatePartCount As Integer
    Get
Visual C++
public:
property int OutOfDatePartCount {
    int get ();
}

See Also

ConfigurationReloadInfo Class


ConicalFace Class

[image]

Revit 2024 API
ConicalFace Class
Members Example See Also Send Feedback
A conical face of a 3d solid or open shell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class ConicalFace : Face
Visual Basic
Public Class ConicalFace _
    Inherits Face
Visual C++
public ref class ConicalFace : public Face

Remarks

For details on the parameterization, refer to the documentation for ConicalSurface.

Examples

CopyC#
private void GetConicalFaceInfo(Face face)
{
    ConicalFace conicalFace = face as ConicalFace;
    if (null != conicalFace)
    {
       XYZ axis = conicalFace.Axis;
       XYZ origin = conicalFace.Origin;
        double halfAngle = conicalFace.HalfAngle;
        XYZ radius = conicalFace.get_Radius(0);
    }
}
CopyVB.NET
Private Sub GetConicalFaceInfo(face As Face)
    Dim conicalFace As ConicalFace = TryCast(face, ConicalFace)
    If conicalFace IsNot Nothing Then
        Dim axis As XYZ = conicalFace.Axis
        Dim origin As XYZ = conicalFace.Origin
        Dim halfAngle As Double = conicalFace.HalfAngle
        Dim radius As XYZ = conicalFace.Radius(0)
    End If
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeometryObject
Autodesk.Revit.DB..::..Face
Autodesk.Revit.DB..::..ConicalFace

See Also

ConicalFace Members


ConicalFace Members

[image] [image]

Revit 2024 API
ConicalFace Members
ConicalFace Class Methods Properties See Also Send Feedback

The ConicalFace type exposes the following members.

Methods

 | Name | Description
Public method | ComputeDerivatives | Returns the first partial derivatives of the underlying surface at the specified point. (Inherited from Face.)
Public method | ComputeNormal | Returns the normal vector for the face at the given point. (Inherited from Face.)
Public method | ComputeSecondDerivatives | Returns the second partial derivatives of the face at the specified point. (Inherited from Face.)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates and returns the XYZ coordinates of a point at the indicated UV parameterization of the face. (Inherited from Face.)
Public method | GetBoundingBox | Returns the UV bounding box of the face. (Inherited from Face.)
Public method | GetEdgesAsCurveLoops | Returns a list of closed curve loops that correspond to the edge loops of the face. Curves in each curve loop correspond to individual edges. (Inherited from Face.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject.)
Public method | GetRegions | Gets the face regions (created, for example, by the Split Face command) of the face. (Inherited from Face.)
Public method | GetSurface | Returns a copy of this face's surface. (Inherited from Face.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Public method | Intersect(Face) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)
Public method | Intersect(Face, Curve%) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face.)
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional information about the point location. (Inherited from Face.)
Public method | Project | Projects the specified point on the face. (Inherited from Face.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Triangulate()()()() | Returns a triangular mesh approximation to the face. (Inherited from Face.)
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face. (Inherited from Face.)

Properties

 | Name | Description
Public property | Area | The area of this face. (Inherited from Face.)
Public property | Axis | Axis of the surface.
Public property | EdgeLoops | A collection of edge loops. Each edge loop represents one of the closed boundaries of the face. (Inherited from Face.)
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
Public property | HalfAngle | Half angle of the surface.
Public property | HasRegions | Identifies if the face contains regions (which can be created, for example, by the Split Face command). (Inherited from Face.)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject.)
Public property | IsCyclic | Indicates whether the underlying surface is periodic in the specified parametric direction. (Inherited from Face.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate). (Inherited from Face.)
Public property | MaterialElementId | The element ID of the material from which this face is composed. (Inherited from Face.)
Public property | OrientationMatchesSurfaceOrientation | Returns true if this face's orientation matches the orientation of the face's surface, false if they have opposite orientations. (Inherited from Face.)
Public property | Origin | Origin of the surface.
Public property | Period | The period of the underlying surface in the specified parametric direction. (Inherited from Face.)
Public property | Radius | Radii of the surface.
Public property | Reference | Returns a stable reference to the face. (Inherited from Face.)
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

ConicalFace Class


Intersect Method

[image] [image]

Revit 2024 API
ConicalFace..::..Intersect Method
ConicalFace Class See Also Send Feedback
Calculates the intersection of the specified curve with this face.

Overload List

 | Name | Description
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Public method | Intersect(Face) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)
Public method | Intersect(Face, Curve%) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face.)

See Also

ConicalFace Class
ConicalFace Members


IsInside Method

[image] [image]

Revit 2024 API
ConicalFace..::..IsInside Method
ConicalFace Class See Also Send Feedback
Indicates whether the specified point is within this face.

Overload List

 | Name | Description
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional information about the point location. (Inherited from Face.)

See Also

ConicalFace Class
ConicalFace Members


ConicalFace Properties

[image] [image]

Revit 2024 API
ConicalFace Properties
ConicalFace Class See Also Send Feedback

The ConicalFace type exposes the following members.

Properties

 | Name | Description
Public property | Area | The area of this face. (Inherited from Face.)
Public property | Axis | Axis of the surface.
Public property | EdgeLoops | A collection of edge loops. Each edge loop represents one of the closed boundaries of the face. (Inherited from Face.)
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
Public property | HalfAngle | Half angle of the surface.
Public property | HasRegions | Identifies if the face contains regions (which can be created, for example, by the Split Face command). (Inherited from Face.)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject.)
Public property | IsCyclic | Indicates whether the underlying surface is periodic in the specified parametric direction. (Inherited from Face.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate). (Inherited from Face.)
Public property | MaterialElementId | The element ID of the material from which this face is composed. (Inherited from Face.)
Public property | OrientationMatchesSurfaceOrientation | Returns true if this face's orientation matches the orientation of the face's surface, false if they have opposite orientations. (Inherited from Face.)
Public property | Origin | Origin of the surface.
Public property | Period | The period of the underlying surface in the specified parametric direction. (Inherited from Face.)
Public property | Radius | Radii of the surface.
Public property | Reference | Returns a stable reference to the face. (Inherited from Face.)
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

ConicalFace Class


Axis Property

[image]

Revit 2024 API
ConicalFace..::..Axis Property
ConicalFace Class See Also Send Feedback
Axis of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ Axis { get; }
Visual Basic
Public ReadOnly Property Axis As XYZ
    Get
Visual C++
public:
property XYZ^ Axis {
    XYZ^ get ();
}

See Also

ConicalFace Class


HalfAngle Property

[image]

Revit 2024 API
ConicalFace..::..HalfAngle Property
ConicalFace Class See Also Send Feedback
Half angle of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double HalfAngle { get; }
Visual Basic
Public ReadOnly Property HalfAngle As Double
    Get
Visual C++
public:
property double HalfAngle {
    double get ();
}

See Also

ConicalFace Class


Origin Property

[image]

Revit 2024 API
ConicalFace..::..Origin Property
ConicalFace Class See Also Send Feedback
Origin of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ Origin { get; }
Visual Basic
Public ReadOnly Property Origin As XYZ
    Get
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
}

See Also

ConicalFace Class


ConicalSurface Class

[image]

Revit 2024 API
ConicalSurface Class
Members See Also Send Feedback
A Conical Surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public class ConicalSurface : Surface
Visual Basic
Public Class ConicalSurface _
    Inherits Surface
Visual C++
public ref class ConicalSurface : public Surface

Remarks

The parametric equation of the cone is S(u, v) = center + v*[sin(halfAngle)(cos(u)*xVec + sin(u)*yVec) + cos(halfAngle)*zVec]. Only the branch of the cone with v >= 0 should be used.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Surface
Autodesk.Revit.DB..::..ConicalSurface

See Also

ConicalSurface Members


ConicalSurface Members

[image] [image]

Revit 2024 API
ConicalSurface Members
ConicalSurface Class Methods Properties See Also Send Feedback

The ConicalSurface type exposes the following members.

Methods

 | Name | Description
 | Create | Creates a conical surface defined by a local reference frame and a half angle.
Public method | Dispose | (Inherited from Surface.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBoundingBoxUV | Gets the UV bounding box of the surface. (Inherited from Surface.)
Public method | GetFrameOfReference | Returns frame of reference associated with this ConicalSurface.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValidConeAngle | Checks whether the input value lies is not 0, greater than -PI/2 and lesser than PI/2.
Public method | Project | Project a 3D point orthogonally onto a surface (to find the nearest point). Throws InvalidOperationException if the projection fails. (Inherited from Surface.)
Public method | ProjectWithGuessPoint | Project a 3D point orthogonally onto a surface (to find the nearest point). This method is meant to be used when a good approximate solution for the projection is available. Throws InvalidOperationException if the projection fails. (Inherited from Surface.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Axis | Axis of the cone. This is the Z axis of the local coordinate system associated with this cone.
Public property | HalfAngle | Cone angle.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Surface.)
Public property | OrientationMatchesParametricOrientation | Indicates whether this Surface's orientation is the same as or opposite to its parametric orientation. (Inherited from Surface.)
Public property | Origin | Apex of the cone. This is the origin of the local coordinate system associated with this cone.
Public property | XDir | X axis of the local coordinate system associated with this cone.
Public property | YDir | X axis of the local coordinate system associated with this cone.

See Also

ConicalSurface Class


ConicalSurface Methods

[image] [image]

Revit 2024 API
ConicalSurface Methods
ConicalSurface Class See Also Send Feedback

The ConicalSurface type exposes the following members.

Methods

 | Name | Description
 | Create | Creates a conical surface defined by a local reference frame and a half angle.
Public method | Dispose | (Inherited from Surface.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBoundingBoxUV | Gets the UV bounding box of the surface. (Inherited from Surface.)
Public method | GetFrameOfReference | Returns frame of reference associated with this ConicalSurface.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValidConeAngle | Checks whether the input value lies is not 0, greater than -PI/2 and lesser than PI/2.
Public method | Project | Project a 3D point orthogonally onto a surface (to find the nearest point). Throws InvalidOperationException if the projection fails. (Inherited from Surface.)
Public method | ProjectWithGuessPoint | Project a 3D point orthogonally onto a surface (to find the nearest point). This method is meant to be used when a good approximate solution for the projection is available. Throws InvalidOperationException if the projection fails. (Inherited from Surface.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ConicalSurface Class


GetFrameOfReference Method

[image]

Revit 2024 API
ConicalSurface..::..GetFrameOfReference Method
ConicalSurface Class See Also Send Feedback
Returns frame of reference associated with this ConicalSurface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public Frame GetFrameOfReference()
Visual Basic
Public Function GetFrameOfReference As Frame
Visual C++
public:
Frame^ GetFrameOfReference()

Return Value

Frame of reference associated with this ConicalSurface.

Remarks

This is an equivalent of new Frame(Origin, XDir, YDir, Axis).

See Also

ConicalSurface Class


IsValidConeAngle Method

[image]

Revit 2024 API
ConicalSurface..::..IsValidConeAngle Method
ConicalSurface Class See Also Send Feedback
Checks whether the input value lies is not 0, greater than -PI/2 and lesser than PI/2.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public static bool IsValidConeAngle(
    double halfAngle
)
Visual Basic
Public Shared Function IsValidConeAngle ( _
    halfAngle As Double _
) As Boolean
Visual C++
public:
static bool IsValidConeAngle(
    double halfAngle
)

Parameters

halfAngle
Type: System..::..Double
Cone half-angle parameter.

Return Value

True if input is not 0, lesser than PI/2 and greater than -PI/2, false otherwise.

See Also

ConicalSurface Class


ConicalSurface Properties

[image] [image]

Revit 2024 API
ConicalSurface Properties
ConicalSurface Class See Also Send Feedback

The ConicalSurface type exposes the following members.

Properties

 | Name | Description
Public property | Axis | Axis of the cone. This is the Z axis of the local coordinate system associated with this cone.
Public property | HalfAngle | Cone angle.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Surface.)
Public property | OrientationMatchesParametricOrientation | Indicates whether this Surface's orientation is the same as or opposite to its parametric orientation. (Inherited from Surface.)
Public property | Origin | Apex of the cone. This is the origin of the local coordinate system associated with this cone.
Public property | XDir | X axis of the local coordinate system associated with this cone.
Public property | YDir | X axis of the local coordinate system associated with this cone.

See Also

ConicalSurface Class


Axis Property

[image]

Revit 2024 API
ConicalSurface..::..Axis Property
ConicalSurface Class See Also Send Feedback
Axis of the cone. This is the Z axis of the local coordinate system associated with this cone.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public XYZ Axis { get; }
Visual Basic
Public ReadOnly Property Axis As XYZ
    Get
Visual C++
public:
property XYZ^ Axis {
    XYZ^ get ();
}

See Also

ConicalSurface Class


HalfAngle Property

[image]

Revit 2024 API
ConicalSurface..::..HalfAngle Property
ConicalSurface Class See Also Send Feedback
Cone angle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public double HalfAngle { get; }
Visual Basic
Public ReadOnly Property HalfAngle As Double
    Get
Visual C++
public:
property double HalfAngle {
    double get ();
}

See Also

ConicalSurface Class


Origin Property

[image]

Revit 2024 API
ConicalSurface..::..Origin Property
ConicalSurface Class See Also Send Feedback
Apex of the cone. This is the origin of the local coordinate system associated with this cone.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public XYZ Origin { get; }
Visual Basic
Public ReadOnly Property Origin As XYZ
    Get
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
}

See Also

ConicalSurface Class


XDir Property

[image]

Revit 2024 API
ConicalSurface..::..XDir Property
ConicalSurface Class See Also Send Feedback
X axis of the local coordinate system associated with this cone.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public XYZ XDir { get; }
Visual Basic
Public ReadOnly Property XDir As XYZ
    Get
Visual C++
public:
property XYZ^ XDir {
    XYZ^ get ();
}

See Also

ConicalSurface Class


YDir Property

[image]

Revit 2024 API
ConicalSurface..::..YDir Property
ConicalSurface Class See Also Send Feedback
X axis of the local coordinate system associated with this cone.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public XYZ YDir { get; }
Visual Basic
Public ReadOnly Property YDir As XYZ
    Get
Visual C++
public:
property XYZ^ YDir {
    XYZ^ get ();
}

See Also

ConicalSurface Class


ConnectionResolution Enumeration

[image]

Revit 2024 API
ConnectionResolution Enumeration
See Also Send Feedback
An enumerated type listing all the possible resolutions for connectivity validation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public enum ConnectionResolution
Visual Basic
Public Enumeration ConnectionResolution
Visual C++
public enum class ConnectionResolution

Members

Member name | Description
Disconnected | Value for parts were disconnected.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


ConnectionValidationInfo Members

[image] [image]

Revit 2024 API
ConnectionValidationInfo Members
ConnectionValidationInfo Class Constructors Methods Properties See Also Send Feedback

The ConnectionValidationInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ConnectionValidationInfo | Constructor.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ConnectionValidationInfo
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWarning | Access specific warning number of warnings generated by reload.
Public method | IsValidWarningIndex | Validate warning index.
Public method | ManyWarnings | Returns number of warnings generated by reload.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ConnectionValidationInfo Class


ConnectionValidationInfo Constructor

[image]

Revit 2024 API
ConnectionValidationInfo Constructor
ConnectionValidationInfo Class See Also Send Feedback
Constructor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public ConnectionValidationInfo()
Visual Basic
Public Sub New
Visual C++
public:
ConnectionValidationInfo()

See Also

ConnectionValidationInfo Class


Dispose Method

[image]

Revit 2024 API
ConnectionValidationInfo..::..Dispose Method
ConnectionValidationInfo Class See Also Send Feedback
Releases all resources used by the ConnectionValidationInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ConnectionValidationInfo Class


GetWarning Method

[image]

Revit 2024 API
ConnectionValidationInfo..::..GetWarning Method
ConnectionValidationInfo Class See Also Send Feedback
Access specific warning number of warnings generated by reload.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public ConnectionValidationWarning GetWarning(
    int index
)
Visual Basic
Public Function GetWarning ( _
    index As Integer _
) As ConnectionValidationWarning
Visual C++
public:
ConnectionValidationWarning^ GetWarning(
    int index
)

Parameters

index
Type: System..::..Int32

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Invalid index.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

ConnectionValidationInfo Class


IsValidWarningIndex Method

[image]

Revit 2024 API
ConnectionValidationInfo..::..IsValidWarningIndex Method
ConnectionValidationInfo Class See Also Send Feedback
Validate warning index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool IsValidWarningIndex(
    int index
)
Visual Basic
Public Function IsValidWarningIndex ( _
    index As Integer _
) As Boolean
Visual C++
public:
bool IsValidWarningIndex(
    int index
)

Parameters

index
Type: System..::..Int32

See Also

ConnectionValidationInfo Class


ConnectionValidationInfo Properties

[image] [image]

Revit 2024 API
ConnectionValidationInfo Properties
ConnectionValidationInfo Class See Also Send Feedback

The ConnectionValidationInfo type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ConnectionValidationInfo Class


IsValidObject Property

[image]

Revit 2024 API
ConnectionValidationInfo..::..IsValidObject Property
ConnectionValidationInfo Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ConnectionValidationInfo Class


ConnectionValidationWarning Class

[image]

Revit 2024 API
ConnectionValidationWarning Class
Members See Also Send Feedback
Contains information about a specific connection validation problem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public class ConnectionValidationWarning : IDisposable
Visual Basic
Public Class ConnectionValidationWarning _
    Implements IDisposable
Visual C++
public ref class ConnectionValidationWarning : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ConnectionValidationWarning

See Also

ConnectionValidationWarning Members


ConnectionValidationWarning Members

[image] [image]

Revit 2024 API
ConnectionValidationWarning Members
ConnectionValidationWarning Class Constructors Methods Properties See Also Send Feedback

The ConnectionValidationWarning type exposes the following members.

Constructors

 | Name | Description
Public method | ConnectionValidationWarning | Constructor.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ConnectionValidationWarning
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParts | Get ElementIds of affected parts.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Reason | Enumeration for reason of warning.
Public property | Resolution | Enumeration for resolution that was applied.

See Also

ConnectionValidationWarning Class


ConnectionValidationWarning Constructor

[image]

Revit 2024 API
ConnectionValidationWarning Constructor
ConnectionValidationWarning Class See Also Send Feedback
Constructor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public ConnectionValidationWarning(
    ConnectionResolution resolution,
    ConnectionWarning reason,
    ElementId part1,
    ElementId part2
)
Visual Basic
Public Sub New ( _
    resolution As ConnectionResolution, _
    reason As ConnectionWarning, _
    part1 As ElementId, _
    part2 As ElementId _
)
Visual C++
public:
ConnectionValidationWarning(
    ConnectionResolution resolution,
    ConnectionWarning reason,
    ElementId^ part1,
    ElementId^ part2
)

Parameters

resolution
Type: Autodesk.Revit.DB..::..ConnectionResolution
Resolution type.
reason
Type: Autodesk.Revit.DB..::..ConnectionWarning
Warning reason.
part1
Type: Autodesk.Revit.DB..::..ElementId
First element Id.
part2
Type: Autodesk.Revit.DB..::..ElementId
Second element Id.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

ConnectionValidationWarning Class


GetParts Method

[image]

Revit 2024 API
ConnectionValidationWarning..::..GetParts Method
ConnectionValidationWarning Class See Also Send Feedback
Get ElementIds of affected parts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public ISet<ElementId> GetParts()
Visual Basic
Public Function GetParts As ISet(Of ElementId)
Visual C++
public:
ISet<ElementId^>^ GetParts()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

ConnectionValidationWarning Class


ConnectionValidationWarning Properties

[image] [image]

Revit 2024 API
ConnectionValidationWarning Properties
ConnectionValidationWarning Class See Also Send Feedback

The ConnectionValidationWarning type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Reason | Enumeration for reason of warning.
Public property | Resolution | Enumeration for resolution that was applied.

See Also

ConnectionValidationWarning Class


IsValidObject Property

[image]

Revit 2024 API
ConnectionValidationWarning..::..IsValidObject Property
ConnectionValidationWarning Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ConnectionValidationWarning Class


Reason Property

[image]

Revit 2024 API
ConnectionValidationWarning..::..Reason Property
ConnectionValidationWarning Class See Also Send Feedback
Enumeration for reason of warning.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public ConnectionWarning Reason { get; }
Visual Basic
Public ReadOnly Property Reason As ConnectionWarning
    Get
Visual C++
public:
property ConnectionWarning Reason {
    ConnectionWarning get ();
}

See Also

ConnectionValidationWarning Class


Resolution Property

[image]

Revit 2024 API
ConnectionValidationWarning..::..Resolution Property
ConnectionValidationWarning Class See Also Send Feedback
Enumeration for resolution that was applied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public ConnectionResolution Resolution { get; }
Visual Basic
Public ReadOnly Property Resolution As ConnectionResolution
    Get
Visual C++
public:
property ConnectionResolution Resolution {
    ConnectionResolution get ();
}

See Also

ConnectionValidationWarning Class


ConnectionWarning Enumeration

[image]

Revit 2024 API
ConnectionWarning Enumeration
See Also Send Feedback
An enumerated type listing all the reasons for connectivity failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public enum ConnectionWarning
Visual Basic
Public Enumeration ConnectionWarning
Visual C++
public enum class ConnectionWarning

Members

Member name | Description
Unknown | Value for unknown or unspecified reason.
Alignment | Value for parts were moved when rebuilt so that connectors were no longer aligned.
Size | Value for sizes didn't match.
Shape | Value for shapes didn't match.
Connectivity | Value for fabrication Connectivity Mismatch.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


Connector Class

[image]

Revit 2024 API
Connector Class
Members Example See Also Send Feedback
A connector in an Autodesk Revit MEP project document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class Connector : IConnector, IDisposable
Visual Basic
Public Class Connector _
    Implements IConnector, IDisposable
Visual C++
public ref class Connector : IConnector,
    IDisposable

Remarks

This connector is an item that is a part of another element (duct, pipe, fitting, or equipment etc.). This connector does not represent the connector element that can be created inside a family; for that element, refer to ConnectorElement.

Examples

CopyC#
public void GetElementAtConnector(Autodesk.Revit.DB.Connector connector)
{
    MEPSystem mepSystem = connector.MEPSystem;
    if (null != mepSystem)
    {
        string message = "Connector is owned by: " + connector.Owner.Name;

        if (connector.IsConnected == true)
        {
            ConnectorSet connectorSet = connector.AllRefs;
            ConnectorSetIterator csi = connectorSet.ForwardIterator();
            while (csi.MoveNext())
            {
                Connector connected = csi.Current as Connector;
                if (null != connected)
                {
                    // look for physical connections
                    if (connected.ConnectorType == ConnectorType.End ||
                        connected.ConnectorType == ConnectorType.Curve ||
                        connected.ConnectorType == ConnectorType.Physical)
                    {
                        message += "\nConnector is connected to: " + connected.Owner.Name;
                        message += "\nConnection type is: " + connected.ConnectorType;
                    }
                }
            }
        }
        else
        {
            message += "\nConnector is not connected to anything.";
        }

        TaskDialog.Show("Revit", message);
    }
}
CopyVB.NET
Public Sub GetElementAtConnector(connector As Autodesk.Revit.DB.Connector)
    Dim mepSystem As MEPSystem = connector.MEPSystem
    If mepSystem IsNot Nothing Then
        Dim message As String = "Connector is owned by: " + connector.Owner.Name

        If connector.IsConnected = True Then
            Dim connectorSet As ConnectorSet = connector.AllRefs
            Dim csi As ConnectorSetIterator = connectorSet.ForwardIterator()
            While csi.MoveNext()
                Dim connected As Connector = TryCast(csi.Current, Connector)
                If connected IsNot Nothing Then
                    ' look for physical connections
                    If connected.ConnectorType = ConnectorType.[End] OrElse connected.ConnectorType = ConnectorType.Curve OrElse connected.ConnectorType = ConnectorType.Physical Then
                        message += vbLf & "Connector is connected to: " + connected.Owner.Name
                        message += vbLf & "Connection type is: " + connected.ConnectorType
                    End If
                End If
            End While
        Else
            message += vbLf & "Connector is not connected to anything."
        End If

        TaskDialog.Show("Revit", message)
    End If
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Connector

See Also

Connector Members


Connector Members

[image] [image]

Revit 2024 API
Connector Members
Connector Class Methods Properties See Also Send Feedback

The Connector type exposes the following members.

Methods

 | Name | Description
Public method | ConnectTo | Make connection between two connectors.
Public method | DisconnectFrom | Remove connection between two connectors.
Public method | Dispose | Releases all resources used by the Connector
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetFabricationConnectorInfo | Gets fabrication connectivity information.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMEPConnectorInfo | Gets MEP connector information.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsConnectedTo | Identifies if the connector is connected to the specified connector.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AllowsSlopeAdjustments | Indicates if the connector allows the slope adjustment.
Public property | AllRefs | All references of the connector.
Public property | Angle | The angle of the Connector.
Public property | AssignedDuctFlowConfiguration | The assigned duct flow configuration of the connector.
Public property | AssignedDuctLossMethod | The duct loss method of the connector.
Public property | AssignedFixtureUnits | The assigned fixture units of the connector.
Public property | AssignedFlow | The assigned flow of the connector.
Public property | AssignedFlowDirection | The assigned flow direction of the connector.
Public property | AssignedFlowFactor | The assigned flow factor of this connector.
Public property | AssignedKCoefficient | The assigned kCoefficient of the connector.
Public property | AssignedLossCoefficient | The assigned loss coefficient of the connector.
Public property | AssignedPipeFlowConfiguration | The pipe flow configuration type of the connector.
Public property | AssignedPipeLossMethod | The pipe loss method of the connector.
Public property | AssignedPressureDrop | The assigned pressure drop of the connector.
Public property | Coefficient | The coefficient of the connector.
Public property | ConnectorManager | The connector manager of the connector.
Public property | ConnectorType | The connector type of the connector.
Public property | CoordinateSystem | The coordinate system of the connector.
Public property | Demand | The demand of the connector.
Public property | Description | The description.
Public property | Direction | The direction of the connector.
Public property | Domain | The domain of the connector.
Public property | DuctSystemType | The duct system type of the connector.
Public property | ElectricalSystemType | The electrical system type of the connector.
Public property | EngagementLength | Connector engagement length. When applicable, it represents the inset distance to the end of the fabrication part from the connection point. Otherwise it returns zero.
Public property | Flow | The flow of the connector.
Public property | GasketLength | Connector gasket length. When applicable, it represents the distance from the end of the fabrication part to the center of the gasket. Otherwise it returns zero.
Public property | Height | The height of the connector.
Public property | Id | A unique identifier to identify this connector.
Public property | IsConnected | Identifies if the connector is physically connected to a connector on another element.
Public property | IsMovable | whether the connector can be moved.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MEPSystem | The system of the connector belong to.
Public property | Origin | The location of the connector.
Public property | Owner | The host of the connector.
Public property | PipeSystemType | The pipe system type of the connector.
Public property | PressureDrop | The pressure drop of the connector.
Public property | Radius | The radius of the connector.
Public property | Shape | The shape of the connector.
Public property | Utility | Indicates if the connector is a utility connector.
Public property | VelocityPressure | The velocity pressure of the connector.
Public property | Width | The width of the connector.

See Also

Connector Class


Connector Methods

[image] [image]

Revit 2024 API
Connector Methods
Connector Class See Also Send Feedback

The Connector type exposes the following members.

Methods

 | Name | Description
Public method | ConnectTo | Make connection between two connectors.
Public method | DisconnectFrom | Remove connection between two connectors.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetFabricationConnectorInfo | Gets fabrication connectivity information.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMEPConnectorInfo | Gets MEP connector information.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsConnectedTo | Identifies if the connector is connected to the specified connector.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Connector Class


ConnectTo Method

[image]

Revit 2024 API
Connector..::..ConnectTo Method
Connector Class See Also Send Feedback
Make connection between two connectors.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void ConnectTo(
    Connector connector
)
Visual Basic
Public Sub ConnectTo ( _
    connector As Connector _
)
Visual C++
public:
void ConnectTo(
    Connector^ connector
)

Parameters

connector
Type: Autodesk.Revit.DB..::..Connector
Indicate the connector will be connected to.

Remarks

Connection success may create a new Fitting between two connectors, if necessary.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Argument is invalid.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when two connectors with different domain types. Thrown when these two connectors fail to connect each other. Thrown when connection already exists.

See Also

Connector Class


DisconnectFrom Method

[image]

Revit 2024 API
Connector..::..DisconnectFrom Method
Connector Class See Also Send Feedback
Remove connection between two connectors.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void DisconnectFrom(
    Connector connector
)
Visual Basic
Public Sub DisconnectFrom ( _
    connector As Connector _
)
Visual C++
public:
void DisconnectFrom(
    Connector^ connector
)

Parameters

connector
Type: Autodesk.Revit.DB..::..Connector
Indicate the connector, connection will be removed from.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Argument is invalid.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when no connection between these two connector. Thrown on failure to remove the connection between these two connectors.

See Also

Connector Class


GetFabricationConnectorInfo Method

[image]

Revit 2024 API
Connector..::..GetFabricationConnectorInfo Method
Connector Class See Also Send Feedback
Gets fabrication connectivity information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public FabricationConnectorInfo GetFabricationConnectorInfo()
Visual Basic
Public Function GetFabricationConnectorInfo As FabricationConnectorInfo
Visual C++
public:
FabricationConnectorInfo^ GetFabricationConnectorInfo()

Return Value

Returns nullNothingnullptra null reference (Nothing in Visual Basic) if there is no fabrication connector information associated.

See Also

Connector Class


IsConnectedTo Method

[image]

Revit 2024 API
Connector..::..IsConnectedTo Method
Connector Class See Also Send Feedback
Identifies if the connector is connected to the specified connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsConnectedTo(
    Connector connector
)
Visual Basic
Public Function IsConnectedTo ( _
    connector As Connector _
) As Boolean
Visual C++
public:
bool IsConnectedTo(
    Connector^ connector
)

Parameters

connector
Type: Autodesk.Revit.DB..::..Connector

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the argument is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Connector Class


Connector Properties

[image] [image]

Revit 2024 API
Connector Properties
Connector Class See Also Send Feedback

The Connector type exposes the following members.

Properties

 | Name | Description
Public property | AllowsSlopeAdjustments | Indicates if the connector allows the slope adjustment.
Public property | AllRefs | All references of the connector.
Public property | Angle | The angle of the Connector.
Public property | AssignedDuctFlowConfiguration | The assigned duct flow configuration of the connector.
Public property | AssignedDuctLossMethod | The duct loss method of the connector.
Public property | AssignedFixtureUnits | The assigned fixture units of the connector.
Public property | AssignedFlow | The assigned flow of the connector.
Public property | AssignedFlowDirection | The assigned flow direction of the connector.
Public property | AssignedFlowFactor | The assigned flow factor of this connector.
Public property | AssignedKCoefficient | The assigned kCoefficient of the connector.
Public property | AssignedLossCoefficient | The assigned loss coefficient of the connector.
Public property | AssignedPipeFlowConfiguration | The pipe flow configuration type of the connector.
Public property | AssignedPipeLossMethod | The pipe loss method of the connector.
Public property | AssignedPressureDrop | The assigned pressure drop of the connector.
Public property | Coefficient | The coefficient of the connector.
Public property | ConnectorManager | The connector manager of the connector.
Public property | ConnectorType | The connector type of the connector.
Public property | CoordinateSystem | The coordinate system of the connector.
Public property | Demand | The demand of the connector.
Public property | Description | The description.
Public property | Direction | The direction of the connector.
Public property | Domain | The domain of the connector.
Public property | DuctSystemType | The duct system type of the connector.
Public property | ElectricalSystemType | The electrical system type of the connector.
Public property | EngagementLength | Connector engagement length. When applicable, it represents the inset distance to the end of the fabrication part from the connection point. Otherwise it returns zero.
Public property | Flow | The flow of the connector.
Public property | GasketLength | Connector gasket length. When applicable, it represents the distance from the end of the fabrication part to the center of the gasket. Otherwise it returns zero.
Public property | Height | The height of the connector.
Public property | Id | A unique identifier to identify this connector.
Public property | IsConnected | Identifies if the connector is physically connected to a connector on another element.
Public property | IsMovable | whether the connector can be moved.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MEPSystem | The system of the connector belong to.
Public property | Origin | The location of the connector.
Public property | Owner | The host of the connector.
Public property | PipeSystemType | The pipe system type of the connector.
Public property | PressureDrop | The pressure drop of the connector.
Public property | Radius | The radius of the connector.
Public property | Shape | The shape of the connector.
Public property | Utility | Indicates if the connector is a utility connector.
Public property | VelocityPressure | The velocity pressure of the connector.
Public property | Width | The width of the connector.

See Also

Connector Class


AllowsSlopeAdjustments Property

[image]

Revit 2024 API
Connector..::..AllowsSlopeAdjustments Property
Connector Class See Also Send Feedback
Indicates if the connector allows the slope adjustment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool AllowsSlopeAdjustments { get; }
Visual Basic
Public ReadOnly Property AllowsSlopeAdjustments As Boolean
    Get
Visual C++
public:
property bool AllowsSlopeAdjustments {
    bool get ();
}

See Also

Connector Class


AllRefs Property

[image]

Revit 2024 API
Connector..::..AllRefs Property
Connector Class See Also Send Feedback
All references of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ConnectorSet AllRefs { get; }
Visual Basic
Public ReadOnly Property AllRefs As ConnectorSet
    Get
Visual C++
public:
property ConnectorSet^ AllRefs {
    ConnectorSet^ get ();
}

Remarks

A set of connectors that the connectors is connected to, including both physical connection and logical connection.

See Also

Connector Class


Angle Property

[image]

Revit 2024 API
Connector..::..Angle Property
Connector Class See Also Send Feedback
The angle of the Connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double Angle { get; set; }
Visual Basic
Public Property Angle As Double
    Get
    Set
Visual C++
public:
property double Angle {
    double get ();
    void set (double value);
}

Remarks

Angle may be assigned for connectors of some family instances. In order to set this property, it must be mapped to a writable instance parameter in the family definition. For a connector obtained from a non-family instance (for example not a fitting, but instead a pipe, duct, or cable tray), the value will always be zero. Non-zero angles are only valid for family instance fitting connectors.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the connector's domain is not DomainHvac, DomainPiping, or DomainCableTrayConduit. Thrown when set value for the connector not in family instance.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when setting an invalid value.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown on failure to set angle.

See Also

Connector Class


AssignedDuctFlowConfiguration Property

[image]

Revit 2024 API
Connector..::..AssignedDuctFlowConfiguration Property
Connector Class See Also Send Feedback
The assigned duct flow configuration of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public DuctFlowConfigurationType AssignedDuctFlowConfiguration { get; }
Visual Basic
Public ReadOnly Property AssignedDuctFlowConfiguration As DuctFlowConfigurationType
    Get
Visual C++
public:
property DuctFlowConfigurationType AssignedDuctFlowConfiguration {
    DuctFlowConfigurationType get ();
}

Remarks

Assigned duct flow configuration may be assigned for connectors of some family instances.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the connector's domain is not DomainHvac. Thrown when the connector is not in a family instance.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown on failure to get duct flow configuration.

See Also

Connector Class


AssignedDuctLossMethod Property

[image]

Revit 2024 API
Connector..::..AssignedDuctLossMethod Property
Connector Class See Also Send Feedback
The duct loss method of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public DuctLossMethodType AssignedDuctLossMethod { get; }
Visual Basic
Public ReadOnly Property AssignedDuctLossMethod As DuctLossMethodType
    Get
Visual C++
public:
property DuctLossMethodType AssignedDuctLossMethod {
    DuctLossMethodType get ();
}

Remarks

Assigned duct loss method may be assigned for connectors of some family instances.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the connector's domain is not DomainHvac. Thrown when the connector is not in family instance.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown on failure to get duct loss method.

See Also

Connector Class


AssignedFixtureUnits Property

[image]

Revit 2024 API
Connector..::..AssignedFixtureUnits Property
Connector Class See Also Send Feedback
The assigned fixture units of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double AssignedFixtureUnits { get; set; }
Visual Basic
Public Property AssignedFixtureUnits As Double
    Get
    Set
Visual C++
public:
property double AssignedFixtureUnits {
    double get ();
    void set (double value);
}

Remarks

Assigned fixture units may be assigned for connectors of some family instances.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the connector's domain is not DomainPiping. Thrown when the connector is not in a family instance.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when set an invalid value.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown on failure to get or set assigned fixture units.

See Also

Connector Class


AssignedFlow Property

[image]

Revit 2024 API
Connector..::..AssignedFlow Property
Connector Class See Also Send Feedback
The assigned flow of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double AssignedFlow { get; set; }
Visual Basic
Public Property AssignedFlow As Double
    Get
    Set
Visual C++
public:
property double AssignedFlow {
    double get ();
    void set (double value);
}

Remarks

Assigned flow may be assigned for connectors of some family instances. In order to set this property, it must be mapped to a writable instance parameter in the family definition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the connector's domain is not DomainPiping or DomainHvac. Thrown when the connector is not in a family instance.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when set an invalid value.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown on failure to get or set assigned flow.

See Also

Connector Class


AssignedFlowDirection Property

[image]

Revit 2024 API
Connector..::..AssignedFlowDirection Property
Connector Class See Also Send Feedback
The assigned flow direction of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FlowDirectionType AssignedFlowDirection { get; }
Visual Basic
Public ReadOnly Property AssignedFlowDirection As FlowDirectionType
    Get
Visual C++
public:
property FlowDirectionType AssignedFlowDirection {
    FlowDirectionType get ();
}

Remarks

Flow direction may be assigned for connectors of some family instances.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the connector is not in a family instance. Thrown when the connector's domain is not DomainHvac or DomainPiping.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown on failure to get assigned flow direction.

See Also

Connector Class


AssignedKCoefficient Property

[image]

Revit 2024 API
Connector..::..AssignedKCoefficient Property
Connector Class See Also Send Feedback
The assigned kCoefficient of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double AssignedKCoefficient { get; set; }
Visual Basic
Public Property AssignedKCoefficient As Double
    Get
    Set
Visual C++
public:
property double AssignedKCoefficient {
    double get ();
    void set (double value);
}

Remarks

Assigned kCoefficient may be assigned for connectors of some family instances, for more information. In order to set this property, it must be mapped to a writable instance parameter in the family definition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the connector's domain is not DomainPiping. Thrown when the connector is not in a family instance.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when set an invalid value.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown on failure to get or set kCoefficient.

See Also

Connector Class


AssignedPipeFlowConfiguration Property

[image]

Revit 2024 API
Connector..::..AssignedPipeFlowConfiguration Property
Connector Class See Also Send Feedback
The pipe flow configuration type of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public PipeFlowConfigurationType AssignedPipeFlowConfiguration { get; }
Visual Basic
Public ReadOnly Property AssignedPipeFlowConfiguration As PipeFlowConfigurationType
    Get
Visual C++
public:
property PipeFlowConfigurationType AssignedPipeFlowConfiguration {
    PipeFlowConfigurationType get ();
}

Remarks

Assigned pipe flow configuration may be assigned for connectors of some family instances.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the connector's domain is not DomainPiping. Thrown when the connector is not in a family instance.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown on failure to get pipe flow configuration.

See Also

Connector Class


AssignedPipeLossMethod Property

[image]

Revit 2024 API
Connector..::..AssignedPipeLossMethod Property
Connector Class See Also Send Feedback
The pipe loss method of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public PipeLossMethodType AssignedPipeLossMethod { get; }
Visual Basic
Public ReadOnly Property AssignedPipeLossMethod As PipeLossMethodType
    Get
Visual C++
public:
property PipeLossMethodType AssignedPipeLossMethod {
    PipeLossMethodType get ();
}

Remarks

Assigned duct pipe loss method may be assigned for connectors of some family instances.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the connector's domain is not DomainPiping. Thrown when the connector is not in a family instance.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown on failure to get pipe loss method.

See Also

Connector Class


AssignedPressureDrop Property

[image]

Revit 2024 API
Connector..::..AssignedPressureDrop Property
Connector Class See Also Send Feedback
The assigned pressure drop of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double AssignedPressureDrop { get; set; }
Visual Basic
Public Property AssignedPressureDrop As Double
    Get
    Set
Visual C++
public:
property double AssignedPressureDrop {
    double get ();
    void set (double value);
}

Remarks

Assigned pressure drop may be assigned for connectors of some family instances. In order to set this property, it must be mapped to a writable instance parameter in the family definition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the connector is not in a family instance. Thrown when the connector's domain is not DomainHvac or DomainPiping.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when set an invalid value.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown on failure to get or set assigned pressure drop.

See Also

Connector Class


Coefficient Property

[image]

Revit 2024 API
Connector..::..Coefficient Property
Connector Class See Also Send Feedback
The coefficient of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double Coefficient { get; }
Visual Basic
Public ReadOnly Property Coefficient As Double
    Get
Visual C++
public:
property double Coefficient {
    double get ();
}

Remarks

Instantaneous coefficient of this connector, calculated according to system.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This connector does not support flow calculation and associated properties.

See Also

Connector Class


ConnectorManager Property

[image]

Revit 2024 API
Connector..::..ConnectorManager Property
Connector Class See Also Send Feedback
The connector manager of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ConnectorManager ConnectorManager { get; }
Visual Basic
Public ReadOnly Property ConnectorManager As ConnectorManager
    Get
Visual C++
public:
property ConnectorManager^ ConnectorManager {
    ConnectorManager^ get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown on failure to get connector manager.

See Also

Connector Class


Demand Property

[image]

Revit 2024 API
Connector..::..Demand Property
Connector Class See Also Send Feedback
The demand of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double Demand { get; }
Visual Basic
Public ReadOnly Property Demand As Double
    Get
Visual C++
public:
property double Demand {
    double get ();
}

Remarks

Instantaneous demand at this connector, calculated according to system.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the connector's domain is not DomainPiping.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown on failure to get demand.

See Also

Connector Class


Description Property

[image]

Revit 2024 API
Connector..::..Description Property
Connector Class See Also Send Feedback
The description.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public string Description { get; }
Visual Basic
Public ReadOnly Property Description As String
    Get
Visual C++
public:
property String^ Description {
    String^ get ();
}

See Also

Connector Class


Direction Property

[image]

Revit 2024 API
Connector..::..Direction Property
Connector Class See Also Send Feedback
The direction of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FlowDirectionType Direction { get; }
Visual Basic
Public ReadOnly Property Direction As FlowDirectionType
    Get
Visual C++
public:
property FlowDirectionType Direction {
    FlowDirectionType get ();
}

Remarks

Instantaneous direction of this connector, calculated according to system.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This connector does not support flow calculation and associated properties.

See Also

Connector Class


DuctSystemType Property

[image]

Revit 2024 API
Connector..::..DuctSystemType Property
Connector Class See Also Send Feedback
The duct system type of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public DuctSystemType DuctSystemType { get; }
Visual Basic
Public ReadOnly Property DuctSystemType As DuctSystemType
    Get
Visual C++
public:
property DuctSystemType DuctSystemType {
    DuctSystemType get ();
}

Remarks

This is the instantaneous system type at this connector, calculated according to system. For unconnected connectors, the system type is undefined.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the connector's domain is not DomainHvac.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown on failure to get duct system type.

See Also

Connector Class


EngagementLength Property

[image]

Revit 2024 API
Connector..::..EngagementLength Property
Connector Class See Also Send Feedback
Connector engagement length. When applicable, it represents the inset distance to the end of the fabrication part from the connection point. Otherwise it returns zero.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double EngagementLength { get; }
Visual Basic
Public ReadOnly Property EngagementLength As Double
    Get
Visual C++
public:
property double EngagementLength {
    double get ();
}

See Also

Connector Class


Flow Property

[image]

Revit 2024 API
Connector..::..Flow Property
Connector Class See Also Send Feedback
The flow of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double Flow { get; }
Visual Basic
Public ReadOnly Property Flow As Double
    Get
Visual C++
public:
property double Flow {
    double get ();
}

Remarks

Instantaneous flow at this connector, calculated according to system.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This connector does not support flow calculation and associated properties.

See Also

Connector Class


GasketLength Property

[image]

Revit 2024 API
Connector..::..GasketLength Property
Connector Class See Also Send Feedback
Connector gasket length. When applicable, it represents the distance from the end of the fabrication part to the center of the gasket. Otherwise it returns zero.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public double GasketLength { get; }
Visual Basic
Public ReadOnly Property GasketLength As Double
    Get
Visual C++
public:
property double GasketLength {
    double get ();
}

See Also

Connector Class


Id Property

[image]

Revit 2024 API
Connector..::..Id Property
Connector Class See Also Send Feedback
A unique identifier to identify this connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public int Id { get; }
Visual Basic
Public ReadOnly Property Id As Integer
    Get
Visual C++
public:
property int Id {
    int get ();
}

See Also

Connector Class


IsConnected Property

[image]

Revit 2024 API
Connector..::..IsConnected Property
Connector Class See Also Send Feedback
Identifies if the connector is physically connected to a connector on another element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsConnected { get; }
Visual Basic
Public ReadOnly Property IsConnected As Boolean
    Get
Visual C++
public:
property bool IsConnected {
    bool get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the connector's type is LogicalConn.

See Also

Connector Class


IsMovable Property

[image]

Revit 2024 API
Connector..::..IsMovable Property
Connector Class See Also Send Feedback
whether the connector can be moved.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsMovable { get; }
Visual Basic
Public ReadOnly Property IsMovable As Boolean
    Get
Visual C++
public:
property bool IsMovable {
    bool get ();
}

Remarks

Only connectors of type EndConn can be moved.

See Also

Connector Class


MEPSystem Property

[image]

Revit 2024 API
Connector..::..MEPSystem Property
Connector Class See Also Send Feedback
The system of the connector belong to.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public MEPSystem MEPSystem { get; }
Visual Basic
Public ReadOnly Property MEPSystem As MEPSystem
    Get
Visual C++
public:
property MEPSystem^ MEPSystem {
    MEPSystem^ get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown on failure to get system.

See Also

Connector Class


Origin Property

[image]

Revit 2024 API
Connector..::..Origin Property
Connector Class See Also Send Feedback
The location of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual XYZ Origin { get; set; }
Visual Basic
Public Overridable Property Origin As XYZ
    Get
    Set
Visual C++
public:
virtual property XYZ^ Origin {
    XYZ^ get ();
    void set (XYZ^ value);
}

Implements

IConnector..::..Origin

Remarks

Changing the location of the connector may lead to changes of location and geometry for the connector's host element and the hosts for other elements the element is connected to.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when connector's type is NonEndConn. Thrown when the connector is a part of a family instance.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the assigned origin is invalid.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown on failure to set origin.

See Also

Connector Class


Owner Property

[image]

Revit 2024 API
Connector..::..Owner Property
Connector Class See Also Send Feedback
The host of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Element Owner { get; }
Visual Basic
Public ReadOnly Property Owner As Element
    Get
Visual C++
public:
property Element^ Owner {
    Element^ get ();
}

Remarks

The element that contains this connector. It may also contain other connectors.

See Also

Connector Class


PipeSystemType Property

[image]

Revit 2024 API
Connector..::..PipeSystemType Property
Connector Class See Also Send Feedback
The pipe system type of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public PipeSystemType PipeSystemType { get; }
Visual Basic
Public ReadOnly Property PipeSystemType As PipeSystemType
    Get
Visual C++
public:
property PipeSystemType PipeSystemType {
    PipeSystemType get ();
}

Remarks

Instantaneous system type at this connector, calculated according to system. For unconnected connectors, system type is undefined.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the connector's domain is not DomainPiping.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown on failure to get pipe system type.

See Also

Connector Class


PressureDrop Property

[image]

Revit 2024 API
Connector..::..PressureDrop Property
Connector Class See Also Send Feedback
The pressure drop of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double PressureDrop { get; }
Visual Basic
Public ReadOnly Property PressureDrop As Double
    Get
Visual C++
public:
property double PressureDrop {
    double get ();
}

Remarks

Instantaneous pressure drop of this connector, calculated according to system.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This connector does not support flow calculation and associated properties.

See Also

Connector Class


Radius Property

[image]

Revit 2024 API
Connector..::..Radius Property
Connector Class See Also Send Feedback
The radius of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual double Radius { get; set; }
Visual Basic
Public Overridable Property Radius As Double
    Get
    Set
Visual C++
public:
virtual property double Radius {
    double get ();
    void set (double value);
}

Implements

IConnector..::..Radius

Remarks

In order to set this property, it must be mapped to a writable instance parameter in the family definition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the connector's shape is not round.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the argument is invalid.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown on failure to set radius.

See Also

Connector Class


Shape Property

[image]

Revit 2024 API
Connector..::..Shape Property
Connector Class See Also Send Feedback
The shape of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual ConnectorProfileType Shape { get; }
Visual Basic
Public Overridable ReadOnly Property Shape As ConnectorProfileType
    Get
Visual C++
public:
virtual property ConnectorProfileType Shape {
    ConnectorProfileType get ();
}

Implements

IConnector..::..Shape

See Also

Connector Class


Width Property

[image]

Revit 2024 API
Connector..::..Width Property
Connector Class See Also Send Feedback
The width of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual double Width { get; set; }
Visual Basic
Public Overridable Property Width As Double
    Get
    Set
Visual C++
public:
virtual property double Width {
    double get ();
    void set (double value);
}

Implements

IConnector..::..Width

Remarks

In order to set this property, it must be mapped to a writable instance parameter in the family definition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the connector's shape is not rectangular.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the argument is invalid.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown on failure to set width.

See Also

Connector Class


ConnectorDomainType Enumeration

[image]

Revit 2024 API
ConnectorDomainType Enumeration
See Also Send Feedback
Type of connector domain.
Enumeration of connector domain types

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum ConnectorDomainType
Visual Basic
Public Enumeration ConnectorDomainType
Visual C++
public enum class ConnectorDomainType

Members

Member name | Description
Undefined | Domain is undefined
Hvac | HVAC (duct) connector
Electrical | Electrical connector
Piping | Piping connector
CableTrayConduit | Connector of cable trays or conduits
StructuralAnalytical | Connector of Structural Analytical Model

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


ConnectorElement Members

[image] [image]

Revit 2024 API
ConnectorElement Members
ConnectorElement Class Methods Properties See Also Send Feedback

The ConnectorElement type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | AssignAsPrimary | Assign a connector as a primary connector.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeHostReference(Reference) | Changes the connector host reference to a new planar face.
Public method | ChangeHostReference(Reference, Edge) | Changes the connector host reference to a new planar face and a new edge loop.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | CreateCableTrayConnector(Document, Reference) | Create a new cable tray ConnectorElement.
 | CreateCableTrayConnector(Document, Reference, Edge) | Create a new cable tray ConnectorElement.
 | CreateConduitConnector(Document, Reference) | Create a new conduit ConnectorElement.
 | CreateConduitConnector(Document, Reference, Edge) | Create a new conduit ConnectorElement.
 | CreateDuctConnector(Document, DuctSystemType, ConnectorProfileType, Reference) | Create a new duct ConnectorElement.
 | CreateDuctConnector(Document, DuctSystemType, ConnectorProfileType, Reference, Edge) | Create a new duct ConnectorElement.
 | CreateElectricalConnector(Document, ElectricalSystemType, Reference) | Create a new electrical ConnectorElement.
 | CreateElectricalConnector(Document, ElectricalSystemType, Reference, Edge) | Create a new electrical ConnectorElement.
 | CreatePipeConnector(Document, PipeSystemType, Reference) | Create a new pipe ConnectorElement.
 | CreatePipeConnector(Document, PipeSystemType, Reference, Edge) | Create a new pipe ConnectorElement with a face and an edge.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | FlipDirection | Reverses the direction of the connector element.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLinkedConnectorElement | Get the linked connector element.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSystemClassificationValid | Checks that the MEPSystemType is valid for the domain of connector.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetLinkedConnectorElement | Set the linked connector element.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CoordinateSystem | The coordinate system of the connector.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Direction | Gets the direction of the connector element.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Domain | The domain of the connector.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Height | The height of the connector.
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsPrimary | Identifies if this is the primary connector in the family.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Origin | The location of the connector in family document.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Radius | The radius of the connector.
Public property | Shape | The shape of the connector.
Public property | SystemClassification | The system classification of the connector.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Width | The width of the connector.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ConnectorElement Class


ConnectorElement Methods

[image] [image]

Revit 2024 API
ConnectorElement Methods
ConnectorElement Class See Also Send Feedback

The ConnectorElement type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | AssignAsPrimary | Assign a connector as a primary connector.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeHostReference(Reference) | Changes the connector host reference to a new planar face.
Public method | ChangeHostReference(Reference, Edge) | Changes the connector host reference to a new planar face and a new edge loop.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | CreateCableTrayConnector(Document, Reference) | Create a new cable tray ConnectorElement.
 | CreateCableTrayConnector(Document, Reference, Edge) | Create a new cable tray ConnectorElement.
 | CreateConduitConnector(Document, Reference) | Create a new conduit ConnectorElement.
 | CreateConduitConnector(Document, Reference, Edge) | Create a new conduit ConnectorElement.
 | CreateDuctConnector(Document, DuctSystemType, ConnectorProfileType, Reference) | Create a new duct ConnectorElement.
 | CreateDuctConnector(Document, DuctSystemType, ConnectorProfileType, Reference, Edge) | Create a new duct ConnectorElement.
 | CreateElectricalConnector(Document, ElectricalSystemType, Reference) | Create a new electrical ConnectorElement.
 | CreateElectricalConnector(Document, ElectricalSystemType, Reference, Edge) | Create a new electrical ConnectorElement.
 | CreatePipeConnector(Document, PipeSystemType, Reference) | Create a new pipe ConnectorElement.
 | CreatePipeConnector(Document, PipeSystemType, Reference, Edge) | Create a new pipe ConnectorElement with a face and an edge.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | FlipDirection | Reverses the direction of the connector element.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLinkedConnectorElement | Get the linked connector element.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSystemClassificationValid | Checks that the MEPSystemType is valid for the domain of connector.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetLinkedConnectorElement | Set the linked connector element.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ConnectorElement Class


AssignAsPrimary Method

[image]

Revit 2024 API
ConnectorElement..::..AssignAsPrimary Method
ConnectorElement Class See Also Send Feedback
Assign a connector as a primary connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void AssignAsPrimary()
Visual Basic
Public Sub AssignAsPrimary
Visual C++
public:
void AssignAsPrimary()

Remarks

This method is used to promote this connector as primary, and the rest of connectors in this system will be assigned as secondary.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when fail to assign this connector as primary.

See Also

ConnectorElement Class


ChangeHostReference Method

[image] [image]

Revit 2024 API
ConnectorElement..::..ChangeHostReference Method
ConnectorElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ChangeHostReference(Reference) | Changes the connector host reference to a new planar face.
Public method | ChangeHostReference(Reference, Edge) | Changes the connector host reference to a new planar face and a new edge loop.

See Also

ConnectorElement Class
ConnectorElement Members


ChangeHostReference Method (Reference)

[image]

Revit 2024 API
ConnectorElement..::..ChangeHostReference Method (Reference)
ConnectorElement Class See Also Send Feedback
Changes the connector host reference to a new planar face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public void ChangeHostReference(
    Reference planarFace
)
Visual Basic
Public Sub ChangeHostReference ( _
    planarFace As Reference _
)
Visual C++
public:
void ChangeHostReference(
    Reference^ planarFace
)

Parameters

planarFace
Type: Autodesk.Revit.DB..::..Reference
The planar face to place the connector on.

Remarks

The connector referenced by a planar face alone is placed at the plane origin, and may be moved later along the planar face.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The face is not a planar face.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ConnectorElement Class
ChangeHostReference Overload


ChangeHostReference Method (Reference, Edge)

[image]

Revit 2024 API
ConnectorElement..::..ChangeHostReference Method (Reference, Edge)
ConnectorElement Class See Also Send Feedback
Changes the connector host reference to a new planar face and a new edge loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public void ChangeHostReference(
    Reference planarFace,
    Edge edge
)
Visual Basic
Public Sub ChangeHostReference ( _
    planarFace As Reference, _
    edge As Edge _
)
Visual C++
public:
void ChangeHostReference(
    Reference^ planarFace,
    Edge^ edge
)

Parameters

planarFace
Type: Autodesk.Revit.DB..::..Reference
The planar face to place the connector on.
edge
Type: Autodesk.Revit.DB..::..Edge
One of the edges in the edge loop that defines the new connector location on the planar face.

Remarks

The connector referenced by an edge loop has the fixed origin as defined by the edge loop.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The face is not a planar face. -or- The edge is not on the planar face.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ConnectorElement Class
ChangeHostReference Overload


CreateCableTrayConnector Method

[image] [image]

Revit 2024 API
ConnectorElement..::..CreateCableTrayConnector Method
ConnectorElement Class See Also Send Feedback

Overload List

Name | Description
CreateCableTrayConnector(Document, Reference) | Create a new cable tray ConnectorElement.
CreateCableTrayConnector(Document, Reference, Edge) | Create a new cable tray ConnectorElement.

See Also

ConnectorElement Class
ConnectorElement Members


CreateCableTrayConnector Method (Document, Reference)

[image]

Revit 2024 API
ConnectorElement..::..CreateCableTrayConnector Method (Document, Reference)
ConnectorElement Class See Also Send Feedback
Create a new cable tray ConnectorElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static ConnectorElement CreateCableTrayConnector(
    Document document,
    Reference planarFace
)
Visual Basic
Public Shared Function CreateCableTrayConnector ( _
    document As Document, _
    planarFace As Reference _
) As ConnectorElement
Visual C++
public:
static ConnectorElement^ CreateCableTrayConnector(
    Document^ document,
    Reference^ planarFace
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to add the connector to.
planarFace
Type: Autodesk.Revit.DB..::..Reference
The planar face to place the connector on.

Return Value

The cable tray ConnectorElement.

Remarks

Regenerates the document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The reference is not a planar face. -or- document is not a family document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | Connector creation is not allowed in this family.

See Also

ConnectorElement Class
CreateCableTrayConnector Overload


CreateCableTrayConnector Method (Document, Reference, Edge)

[image]

Revit 2024 API
ConnectorElement..::..CreateCableTrayConnector Method (Document, Reference, Edge)
ConnectorElement Class See Also Send Feedback
Create a new cable tray ConnectorElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static ConnectorElement CreateCableTrayConnector(
    Document document,
    Reference planarFace,
    Edge edge
)
Visual Basic
Public Shared Function CreateCableTrayConnector ( _
    document As Document, _
    planarFace As Reference, _
    edge As Edge _
) As ConnectorElement
Visual C++
public:
static ConnectorElement^ CreateCableTrayConnector(
    Document^ document,
    Reference^ planarFace,
    Edge^ edge
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to add the connector to.
planarFace
Type: Autodesk.Revit.DB..::..Reference
The planar face to place the connector on.
edge
Type: Autodesk.Revit.DB..::..Edge
One of the edges in the edge loop that defines the connector location on the planar face.

Return Value

The cable tray ConnectorElement.

Remarks

Regenerates the document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The reference is not a planar face. -or- document is not a family document. -or- Thrown when the edge does not belong to the face.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | Connector creation is not allowed in this family.

See Also

ConnectorElement Class
CreateCableTrayConnector Overload


CreateConduitConnector Method

[image] [image]

Revit 2024 API
ConnectorElement..::..CreateConduitConnector Method
ConnectorElement Class See Also Send Feedback

Overload List

Name | Description
CreateConduitConnector(Document, Reference) | Create a new conduit ConnectorElement.
CreateConduitConnector(Document, Reference, Edge) | Create a new conduit ConnectorElement.

See Also

ConnectorElement Class
ConnectorElement Members


CreateConduitConnector Method (Document, Reference)

[image]

Revit 2024 API
ConnectorElement..::..CreateConduitConnector Method (Document, Reference)
ConnectorElement Class See Also Send Feedback
Create a new conduit ConnectorElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static ConnectorElement CreateConduitConnector(
    Document document,
    Reference planarFace
)
Visual Basic
Public Shared Function CreateConduitConnector ( _
    document As Document, _
    planarFace As Reference _
) As ConnectorElement
Visual C++
public:
static ConnectorElement^ CreateConduitConnector(
    Document^ document,
    Reference^ planarFace
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to add the connector to.
planarFace
Type: Autodesk.Revit.DB..::..Reference
The planar face to place the connector on.

Return Value

The conduit ConnectorElement.

Remarks

Regenerates the document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The reference is not a planar face. -or- document is not a family document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | Connector creation is not allowed in this family.

See Also

ConnectorElement Class
CreateConduitConnector Overload


CreateDuctConnector Method

[image] [image]

Revit 2024 API
ConnectorElement..::..CreateDuctConnector Method
ConnectorElement Class See Also Send Feedback

Overload List

Name | Description
CreateDuctConnector(Document, DuctSystemType, ConnectorProfileType, Reference) | Create a new duct ConnectorElement.
CreateDuctConnector(Document, DuctSystemType, ConnectorProfileType, Reference, Edge) | Create a new duct ConnectorElement.

See Also

ConnectorElement Class
ConnectorElement Members


CreateDuctConnector Method (Document, DuctSystemType, ConnectorProfileType, Reference)

[image]

Revit 2024 API
ConnectorElement..::..CreateDuctConnector Method (Document, DuctSystemType, ConnectorProfileType, Reference)
ConnectorElement Class See Also Send Feedback
Create a new duct ConnectorElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static ConnectorElement CreateDuctConnector(
    Document document,
    DuctSystemType ductSystemType,
    ConnectorProfileType profileShape,
    Reference planarFace
)
Visual Basic
Public Shared Function CreateDuctConnector ( _
    document As Document, _
    ductSystemType As DuctSystemType, _
    profileShape As ConnectorProfileType, _
    planarFace As Reference _
) As ConnectorElement
Visual C++
public:
static ConnectorElement^ CreateDuctConnector(
    Document^ document,
    DuctSystemType ductSystemType,
    ConnectorProfileType profileShape,
    Reference^ planarFace
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to add the connector to.
ductSystemType
Type: Autodesk.Revit.DB.Mechanical..::..DuctSystemType
The DuctSystemType of the connector.
profileShape
Type: Autodesk.Revit.DB..::..ConnectorProfileType
The profile shape of the duct.
planarFace
Type: Autodesk.Revit.DB..::..Reference
The planar face to place the connector on.

Return Value

The duct ConnectorElement.

Remarks

Regenerates the document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The reference is not a planar face. -or- document is not a family document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | Connector creation is not allowed in this family.

See Also

ConnectorElement Class
CreateDuctConnector Overload


CreateDuctConnector Method (Document, DuctSystemType, ConnectorProfileType, Reference, Edge)

[image]

Revit 2024 API
ConnectorElement..::..CreateDuctConnector Method (Document, DuctSystemType, ConnectorProfileType, Reference, Edge)
ConnectorElement Class See Also Send Feedback
Create a new duct ConnectorElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static ConnectorElement CreateDuctConnector(
    Document document,
    DuctSystemType ductSystemType,
    ConnectorProfileType profileShape,
    Reference planarFace,
    Edge edge
)
Visual Basic
Public Shared Function CreateDuctConnector ( _
    document As Document, _
    ductSystemType As DuctSystemType, _
    profileShape As ConnectorProfileType, _
    planarFace As Reference, _
    edge As Edge _
) As ConnectorElement
Visual C++
public:
static ConnectorElement^ CreateDuctConnector(
    Document^ document,
    DuctSystemType ductSystemType,
    ConnectorProfileType profileShape,
    Reference^ planarFace,
    Edge^ edge
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to add the connector to.
ductSystemType
Type: Autodesk.Revit.DB.Mechanical..::..DuctSystemType
The DuctSystemType of the connector.
profileShape
Type: Autodesk.Revit.DB..::..ConnectorProfileType
The profile shape of the duct.
planarFace
Type: Autodesk.Revit.DB..::..Reference
The planar face to place the connector on.
edge
Type: Autodesk.Revit.DB..::..Edge
One of the edges in the edge loop that defines the connector location on the planar face.

Return Value

The duct ConnectorElement.

Remarks

Regenerates the document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The reference is not a planar face. -or- document is not a family document. -or- Thrown when the edge does not belong to the face.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | Connector creation is not allowed in this family.

See Also

ConnectorElement Class
CreateDuctConnector Overload


CreateElectricalConnector Method

[image] [image]

Revit 2024 API
ConnectorElement..::..CreateElectricalConnector Method
ConnectorElement Class See Also Send Feedback

Overload List

Name | Description
CreateElectricalConnector(Document, ElectricalSystemType, Reference) | Create a new electrical ConnectorElement.
CreateElectricalConnector(Document, ElectricalSystemType, Reference, Edge) | Create a new electrical ConnectorElement.

See Also

ConnectorElement Class
ConnectorElement Members


CreateElectricalConnector Method (Document, ElectricalSystemType, Reference)

[image]

Revit 2024 API
ConnectorElement..::..CreateElectricalConnector Method (Document, ElectricalSystemType, Reference)
ConnectorElement Class See Also Send Feedback
Create a new electrical ConnectorElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static ConnectorElement CreateElectricalConnector(
    Document document,
    ElectricalSystemType electricalSystemType,
    Reference planarFace
)
Visual Basic
Public Shared Function CreateElectricalConnector ( _
    document As Document, _
    electricalSystemType As ElectricalSystemType, _
    planarFace As Reference _
) As ConnectorElement
Visual C++
public:
static ConnectorElement^ CreateElectricalConnector(
    Document^ document,
    ElectricalSystemType electricalSystemType,
    Reference^ planarFace
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to add the connector to.
electricalSystemType
Type: Autodesk.Revit.DB.Electrical..::..ElectricalSystemType
The ElectricalSystemTYpe of the connector.
planarFace
Type: Autodesk.Revit.DB..::..Reference
The planar face to place the connector on.

Return Value

The electrical ConnectorElement.

Remarks

Regenerates the document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The reference is not a planar face. -or- document is not a family document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | Connector creation is not allowed in this family.

See Also

ConnectorElement Class
CreateElectricalConnector Overload


CreateElectricalConnector Method (Document, ElectricalSystemType, Reference, Edge)

[image]

Revit 2024 API
ConnectorElement..::..CreateElectricalConnector Method (Document, ElectricalSystemType, Reference, Edge)
ConnectorElement Class See Also Send Feedback
Create a new electrical ConnectorElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static ConnectorElement CreateElectricalConnector(
    Document document,
    ElectricalSystemType electricalSystemType,
    Reference planarFace,
    Edge edge
)
Visual Basic
Public Shared Function CreateElectricalConnector ( _
    document As Document, _
    electricalSystemType As ElectricalSystemType, _
    planarFace As Reference, _
    edge As Edge _
) As ConnectorElement
Visual C++
public:
static ConnectorElement^ CreateElectricalConnector(
    Document^ document,
    ElectricalSystemType electricalSystemType,
    Reference^ planarFace,
    Edge^ edge
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to add the connector to.
electricalSystemType
Type: Autodesk.Revit.DB.Electrical..::..ElectricalSystemType
The ElectricalSystemTYpe of the connector.
planarFace
Type: Autodesk.Revit.DB..::..Reference
The planar face to place the connector on.
edge
Type: Autodesk.Revit.DB..::..Edge
One of the edges in the edge loop that defines the connector location on the planar face.

Return Value

The electrical ConnectorElement.

Remarks

Regenerates the document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The reference is not a planar face. -or- document is not a family document. -or- Thrown when the edge does not belong to the face.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | Connector creation is not allowed in this family.

See Also

ConnectorElement Class
CreateElectricalConnector Overload


CreatePipeConnector Method

[image] [image]

Revit 2024 API
ConnectorElement..::..CreatePipeConnector Method
ConnectorElement Class See Also Send Feedback

Overload List

Name | Description
CreatePipeConnector(Document, PipeSystemType, Reference) | Create a new pipe ConnectorElement.
CreatePipeConnector(Document, PipeSystemType, Reference, Edge) | Create a new pipe ConnectorElement with a face and an edge.

See Also

ConnectorElement Class
ConnectorElement Members


CreatePipeConnector Method (Document, PipeSystemType, Reference)

[image]

Revit 2024 API
ConnectorElement..::..CreatePipeConnector Method (Document, PipeSystemType, Reference)
ConnectorElement Class Example See Also Send Feedback
Create a new pipe ConnectorElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static ConnectorElement CreatePipeConnector(
    Document document,
    PipeSystemType pipeSystemType,
    Reference planarFace
)
Visual Basic
Public Shared Function CreatePipeConnector ( _
    document As Document, _
    pipeSystemType As PipeSystemType, _
    planarFace As Reference _
) As ConnectorElement
Visual C++
public:
static ConnectorElement^ CreatePipeConnector(
    Document^ document,
    PipeSystemType pipeSystemType,
    Reference^ planarFace
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to add the connector to.
pipeSystemType
Type: Autodesk.Revit.DB.Plumbing..::..PipeSystemType
The PipeSystemType of the connector.
planarFace
Type: Autodesk.Revit.DB..::..Reference
The planar face to place the connector on.

Return Value

The pipe ConnectorElement.

Remarks

Regenerates the document.

Examples

CopyC#
public void CreatePipeConnectors(UIDocument uiDocument, Extrusion extrusion)
{
    // get the faces of the extrusion
    Options geoOptions = uiDocument.Document.Application.Create.NewGeometryOptions();
    geoOptions.View = uiDocument.Document.ActiveView;
    geoOptions.ComputeReferences = true;

    List<PlanarFace> planarFaces = new List<PlanarFace>();
    Autodesk.Revit.DB.GeometryElement geoElement = extrusion.get_Geometry(geoOptions);
    foreach (GeometryObject geoObject in geoElement)
    {
        Solid geoSolid = geoObject as Solid;
        if (null != geoSolid)
        {
            foreach (Face geoFace in geoSolid.Faces)
            {
                if (geoFace is PlanarFace)
                {
                    planarFaces.Add(geoFace as PlanarFace);
                }
            }
        }
    }

    if (planarFaces.Count > 1)
    {
        // Create the Supply Hydronic pipe connector
        //PipeConnector connSupply =
        //    uiDocument.Document.FamilyCreate.NewPipeConnector(planarFaces[0].Reference,
        //                                           PipeSystemType.SupplyHydronic);
        ConnectorElement connSupply =
            ConnectorElement.CreatePipeConnector(uiDocument.Document, PipeSystemType.SupplyHydronic, planarFaces[0].Reference);
        Parameter param = connSupply.get_Parameter(BuiltInParameter.CONNECTOR_RADIUS);
        param.Set(1.0); // 1' radius
        param = connSupply.get_Parameter(BuiltInParameter.RBS_PIPE_FLOW_DIRECTION_PARAM);
        param.Set(2);

        // Create the Return Hydronic pipe connector
        //PipeConnector connReturn =
        //    uiDocument.Document.FamilyCreate.NewPipeConnector(planarFaces[1].Reference,
        //                                           PipeSystemType.ReturnHydronic);
        ConnectorElement connReturn =
            ConnectorElement.CreatePipeConnector(uiDocument.Document, PipeSystemType.ReturnHydronic, planarFaces[1].Reference);
        param = connReturn.get_Parameter(BuiltInParameter.CONNECTOR_RADIUS);
        param.Set(0.5); // 6" radius
        param = connReturn.get_Parameter(BuiltInParameter.RBS_PIPE_FLOW_DIRECTION_PARAM);
        param.Set(1);
    }
}
CopyVB.NET
Public Sub CreatePipeConnectors(uiDocument As UIDocument, extrusion As Extrusion)
    ' get the faces of the extrusion
    Dim geoOptions As Options = uiDocument.Document.Application.Create.NewGeometryOptions()
    geoOptions.View = uiDocument.Document.ActiveView
    geoOptions.ComputeReferences = True

    Dim planarFaces As New List(Of PlanarFace)()
    Dim geoElement As Autodesk.Revit.DB.GeometryElement = extrusion.Geometry(geoOptions)
    For Each geoObject As GeometryObject In geoElement
        Dim geoSolid As Solid = TryCast(geoObject, Solid)
        If geoSolid IsNot Nothing Then
            For Each geoFace As Face In geoSolid.Faces
                If TypeOf geoFace Is PlanarFace Then
                    planarFaces.Add(TryCast(geoFace, PlanarFace))
                End If
            Next
        End If
    Next

    If planarFaces.Count > 1 Then
        ' Create the Supply Hydronic pipe connector
        'PipeConnector connSupply =
        '    uiDocument.Document.FamilyCreate.NewPipeConnector(planarFaces[0].Reference,
        '                                           PipeSystemType.SupplyHydronic);
        Dim connSupply As ConnectorElement = ConnectorElement.CreatePipeConnector(uiDocument.Document, PipeSystemType.SupplyHydronic, planarFaces(0).Reference)
        Dim param As Parameter = connSupply.Parameter(BuiltInParameter.CONNECTOR_RADIUS)
        param.[Set](1.0)
        ' 1' radius
        param = connSupply.Parameter(BuiltInParameter.RBS_PIPE_FLOW_DIRECTION_PARAM)
        param.[Set](2)

        ' Create the Return Hydronic pipe connector
        'PipeConnector connReturn =
        '    uiDocument.Document.FamilyCreate.NewPipeConnector(planarFaces[1].Reference,
        '                                           PipeSystemType.ReturnHydronic);
        Dim connReturn As ConnectorElement = ConnectorElement.CreatePipeConnector(uiDocument.Document, PipeSystemType.ReturnHydronic, planarFaces(1).Reference)
        param = connReturn.Parameter(BuiltInParameter.CONNECTOR_RADIUS)
        param.[Set](0.5)
        ' 6" radius
        param = connReturn.Parameter(BuiltInParameter.RBS_PIPE_FLOW_DIRECTION_PARAM)
        param.[Set](1)
    End If
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The reference is not a planar face. -or- document is not a family document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | Connector creation is not allowed in this family.

See Also

ConnectorElement Class
CreatePipeConnector Overload


CreatePipeConnector Method (Document, PipeSystemType, Reference, Edge)

[image]

Revit 2024 API
ConnectorElement..::..CreatePipeConnector Method (Document, PipeSystemType, Reference, Edge)
ConnectorElement Class See Also Send Feedback
Create a new pipe ConnectorElement with a face and an edge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static ConnectorElement CreatePipeConnector(
    Document document,
    PipeSystemType pipeSystemType,
    Reference planarFace,
    Edge edge
)
Visual Basic
Public Shared Function CreatePipeConnector ( _
    document As Document, _
    pipeSystemType As PipeSystemType, _
    planarFace As Reference, _
    edge As Edge _
) As ConnectorElement
Visual C++
public:
static ConnectorElement^ CreatePipeConnector(
    Document^ document,
    PipeSystemType pipeSystemType,
    Reference^ planarFace,
    Edge^ edge
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to add the connector to.
pipeSystemType
Type: Autodesk.Revit.DB.Plumbing..::..PipeSystemType
The PipeSystemType of the connector.
planarFace
Type: Autodesk.Revit.DB..::..Reference
The planar face to place the connector on.
edge
Type: Autodesk.Revit.DB..::..Edge
One of the edges in the edge loop that defines the connector location on the planar face.

Return Value

The pipe ConnectorElement.

Remarks

Regenerates the document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The reference is not a planar face. -or- document is not a family document. -or- Thrown when the edge does not belong to the face.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | Connector creation is not allowed in this family.

See Also

ConnectorElement Class
CreatePipeConnector Overload


FlipDirection Method

[image]

Revit 2024 API
ConnectorElement..::..FlipDirection Method
ConnectorElement Class See Also Send Feedback
Reverses the direction of the connector element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void FlipDirection()
Visual Basic
Public Sub FlipDirection
Visual C++
public:
void FlipDirection()

See Also

ConnectorElement Class


SetLinkedConnectorElement Method

[image]

Revit 2024 API
ConnectorElement..::..SetLinkedConnectorElement Method
ConnectorElement Class See Also Send Feedback
Set the linked connector element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void SetLinkedConnectorElement(
    ConnectorElement otherConnector
)
Visual Basic
Public Sub SetLinkedConnectorElement ( _
    otherConnector As ConnectorElement _
)
Visual C++
public:
void SetLinkedConnectorElement(
    ConnectorElement^ otherConnector
)

Parameters

otherConnector
Type: Autodesk.Revit.DB..::..ConnectorElement
The connector to link to.

Remarks

Set the linked connector to nullNothingnullptra null reference (Nothing in Visual Basic) to remove the link.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The connector being linked to is a different domain than that of the calling connector. -or- The connector being linked to is the same as the calling connector.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This connector type does not support linked connectors.

See Also

ConnectorElement Class


ConnectorElement Properties

[image] [image]

Revit 2024 API
ConnectorElement Properties
ConnectorElement Class See Also Send Feedback

The ConnectorElement type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CoordinateSystem | The coordinate system of the connector.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Direction | Gets the direction of the connector element.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Domain | The domain of the connector.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Height | The height of the connector.
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsPrimary | Identifies if this is the primary connector in the family.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Origin | The location of the connector in family document.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Radius | The radius of the connector.
Public property | Shape | The shape of the connector.
Public property | SystemClassification | The system classification of the connector.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Width | The width of the connector.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ConnectorElement Class


CoordinateSystem Property

[image]

Revit 2024 API
ConnectorElement..::..CoordinateSystem Property
ConnectorElement Class See Also Send Feedback
The coordinate system of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Transform CoordinateSystem { get; }
Visual Basic
Public Overridable ReadOnly Property CoordinateSystem As Transform
    Get
Visual C++
public:
virtual property Transform^ CoordinateSystem {
    Transform^ get ();
}

Implements

IConnector..::..CoordinateSystem

Remarks

The Z axis of the coordinate system is the normal to the plane of the connector.

See Also

ConnectorElement Class


Direction Property

[image]

Revit 2024 API
ConnectorElement..::..Direction Property
ConnectorElement Class See Also Send Feedback
Gets the direction of the connector element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public XYZ Direction { get; }
Visual Basic
Public ReadOnly Property Direction As XYZ
    Get
Visual C++
public:
property XYZ^ Direction {
    XYZ^ get ();
}

See Also

ConnectorElement Class


Domain Property

[image]

Revit 2024 API
ConnectorElement..::..Domain Property
ConnectorElement Class See Also Send Feedback
The domain of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Domain Domain { get; }
Visual Basic
Public Overridable ReadOnly Property Domain As Domain
    Get
Visual C++
public:
virtual property Domain Domain {
    Domain get ();
}

Implements

IConnector..::..Domain

Remarks

This property is used to retrieve the domain of the connector.

See Also

ConnectorElement Class


Height Property

[image]

Revit 2024 API
ConnectorElement..::..Height Property
ConnectorElement Class See Also Send Feedback
The height of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual double Height { get; }
Visual Basic
Public Overridable ReadOnly Property Height As Double
    Get
Visual C++
public:
virtual property double Height {
    double get ();
}

Implements

IConnector..::..Height

Remarks

-1 if the connector is round.

See Also

ConnectorElement Class


IsPrimary Property

[image]

Revit 2024 API
ConnectorElement..::..IsPrimary Property
ConnectorElement Class See Also Send Feedback
Identifies if this is the primary connector in the family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsPrimary { get; }
Visual Basic
Public ReadOnly Property IsPrimary As Boolean
    Get
Visual C++
public:
property bool IsPrimary {
    bool get ();
}

See Also

ConnectorElement Class


Origin Property

[image]

Revit 2024 API
ConnectorElement..::..Origin Property
ConnectorElement Class See Also Send Feedback
The location of the connector in family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual XYZ Origin { get; }
Visual Basic
Public Overridable ReadOnly Property Origin As XYZ
    Get
Visual C++
public:
virtual property XYZ^ Origin {
    XYZ^ get ();
}

Implements

IConnector..::..Origin

See Also

ConnectorElement Class


Parameter Property

[image] [image]

Revit 2024 API
ConnectorElement..::..Parameter Property
ConnectorElement Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ConnectorElement Class
ConnectorElement Members


Radius Property

[image]

Revit 2024 API
ConnectorElement..::..Radius Property
ConnectorElement Class See Also Send Feedback
The radius of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual double Radius { get; }
Visual Basic
Public Overridable ReadOnly Property Radius As Double
    Get
Visual C++
public:
virtual property double Radius {
    double get ();
}

Implements

IConnector..::..Radius

Remarks

-1 if the connector is not round.

See Also

ConnectorElement Class


SystemClassification Property

[image]

Revit 2024 API
ConnectorElement..::..SystemClassification Property
ConnectorElement Class See Also Send Feedback
The system classification of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public MEPSystemClassification SystemClassification { get; set; }
Visual Basic
Public Property SystemClassification As MEPSystemClassification
    Get
    Set
Visual C++
public:
property MEPSystemClassification SystemClassification {
    MEPSystemClassification get ();
    void set (MEPSystemClassification value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | When setting this property: The MEPSystemType is not valid for the domain of this connector.

See Also

ConnectorElement Class


Width Property

[image]

Revit 2024 API
ConnectorElement..::..Width Property
ConnectorElement Class See Also Send Feedback
The width of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual double Width { get; }
Visual Basic
Public Overridable ReadOnly Property Width As Double
    Get
Visual C++
public:
virtual property double Width {
    double get ();
}

Implements

IConnector..::..Width

Remarks

-1 if the connector is round.

See Also

ConnectorElement Class


ConnectorGenderType Enumeration

[image]

Revit 2024 API
ConnectorGenderType Enumeration
See Also Send Feedback
Connector gender type enum
Enum of connector gender type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum ConnectorGenderType
Visual Basic
Public Enumeration ConnectorGenderType
Visual C++
public enum class ConnectorGenderType

Members

Member name | Description
Undefined | Undefined connector gender type
Male | Male connector gender type
Female | Female connector gender type

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


ConnectorJointType Enumeration

[image]

Revit 2024 API
ConnectorJointType Enumeration
See Also Send Feedback
Connector joint type enum
Enum of connector joint type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum ConnectorJointType
Visual Basic
Public Enumeration ConnectorJointType
Visual C++
public enum class ConnectorJointType

Members

Member name | Description
Undefined | Undefined connector joint type
Flanged | Flanged connector joint type
Welded | Welded connector joint type
Threaded | Threaded connector joint type
Grooved | Grooved connector joint type
Glued | Glued connector joint type
Soldered | Soldered connector joint type

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


ConnectorManager Class

[image]

Revit 2024 API
ConnectorManager Class
Members See Also Send Feedback
Provides access to the Connector Manager

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class ConnectorManager : IDisposable
Visual Basic
Public Class ConnectorManager _
    Implements IDisposable
Visual C++
public ref class ConnectorManager : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ConnectorManager

See Also

ConnectorManager Members


ConnectorManager Members

[image] [image]

Revit 2024 API
ConnectorManager Members
ConnectorManager Class Methods Properties See Also Send Feedback

The ConnectorManager type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ConnectorManager
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Lookup | Lookup the connector using the unique index value that identify this connector.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Connectors | Return all the Connectors of the Connector Manager.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Owner | This property is used to retrieve the owner of the Connector Manager.
Public property | UnusedConnectors | Return all the unused Connectors of the Connector Manager.

See Also

ConnectorManager Class


Dispose Method

[image]

Revit 2024 API
ConnectorManager..::..Dispose Method
ConnectorManager Class See Also Send Feedback
Releases all resources used by the ConnectorManager

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ConnectorManager Class


Lookup Method

[image]

Revit 2024 API
ConnectorManager..::..Lookup Method
ConnectorManager Class See Also Send Feedback
Lookup the connector using the unique index value that identify this connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public Connector Lookup(
    int index
)
Visual Basic
Public Function Lookup ( _
    index As Integer _
) As Connector
Visual C++
public:
Connector^ Lookup(
    int index
)

Parameters

index
Type: System..::..Int32
The unique index value.

Return Value

Returns the connector or null if a connector for the provided unique index value doesn't exist.

See Also

ConnectorManager Class


ConnectorManager Properties

[image] [image]

Revit 2024 API
ConnectorManager Properties
ConnectorManager Class See Also Send Feedback

The ConnectorManager type exposes the following members.

Properties

 | Name | Description
Public property | Connectors | Return all the Connectors of the Connector Manager.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Owner | This property is used to retrieve the owner of the Connector Manager.
Public property | UnusedConnectors | Return all the unused Connectors of the Connector Manager.

See Also

ConnectorManager Class


IsValidObject Property

[image]

Revit 2024 API
ConnectorManager..::..IsValidObject Property
ConnectorManager Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ConnectorManager Class


Owner Property

[image]

Revit 2024 API
ConnectorManager..::..Owner Property
ConnectorManager Class See Also Send Feedback
This property is used to retrieve the owner of the Connector Manager.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Element Owner { get; }
Visual Basic
Public ReadOnly Property Owner As Element
    Get
Visual C++
public:
property Element^ Owner {
    Element^ get ();
}

See Also

ConnectorManager Class


UnusedConnectors Property

[image]

Revit 2024 API
ConnectorManager..::..UnusedConnectors Property
ConnectorManager Class See Also Send Feedback
Return all the unused Connectors of the Connector Manager.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ConnectorSet UnusedConnectors { get; }
Visual Basic
Public ReadOnly Property UnusedConnectors As ConnectorSet
    Get
Visual C++
public:
property ConnectorSet^ UnusedConnectors {
    ConnectorSet^ get ();
}

Remarks

This property is used to retrieve the unused Connectors from the Connector Manager.

See Also

ConnectorManager Class


ConnectorProfileType Enumeration

[image]

Revit 2024 API
ConnectorProfileType Enumeration
See Also Send Feedback
An enumerated type listing all connector profile types

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum ConnectorProfileType
Visual Basic
Public Enumeration ConnectorProfileType
Visual C++
public enum class ConnectorProfileType

Members

Member name | Description
Invalid | Invalid connector profile
Round | Round connector profile
Rectangular | Rectangular connector profile
Oval | Oval connector profile

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


ConnectorSet Class

[image]

Revit 2024 API
ConnectorSet Class
Members See Also Send Feedback
A set that can contain any type of object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class ConnectorSet : APIObject,
    IEnumerable
Visual Basic
Public Class ConnectorSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ConnectorSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..ConnectorSet

See Also

ConnectorSet Members


ConnectorSet Members

[image] [image]

Revit 2024 API
ConnectorSet Members
ConnectorSet Class Constructors Methods Properties See Also Send Feedback

The ConnectorSet type exposes the following members.

Constructors

 | Name | Description
Public method | ConnectorSet | Initializes a new instance of the ConnectorSet class

Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

ConnectorSet Class


ConnectorSet Constructor

[image]

Revit 2024 API
ConnectorSet Constructor
ConnectorSet Class See Also Send Feedback
Initializes a new instance of the ConnectorSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ConnectorSet()
Visual Basic
Public Sub New
Visual C++
public:
ConnectorSet()

See Also

ConnectorSet Class


ConnectorSet Methods

[image] [image]

Revit 2024 API
ConnectorSet Methods
ConnectorSet Class See Also Send Feedback

The ConnectorSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ConnectorSet Class


Clear Method

[image]

Revit 2024 API
ConnectorSet..::..Clear Method
ConnectorSet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ConnectorSet Class


Contains Method

[image]

Revit 2024 API
ConnectorSet..::..Contains Method
ConnectorSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool Contains(
    Connector item
)
Visual Basic
Public Overridable Function Contains ( _
    item As Connector _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Connector^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..Connector

See Also

ConnectorSet Class


Erase Method

[image]

Revit 2024 API
ConnectorSet..::..Erase Method
ConnectorSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Erase(
    Connector item
)
Visual Basic
Public Overridable Function Erase ( _
    item As Connector _
) As Integer
Visual C++
public:
virtual int Erase(
    Connector^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..Connector

See Also

ConnectorSet Class


ForwardIterator Method

[image]

Revit 2024 API
ConnectorSet..::..ForwardIterator Method
ConnectorSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual ConnectorSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As ConnectorSetIterator
Visual C++
public:
virtual ConnectorSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

ConnectorSet Class


GetEnumerator Method

[image]

Revit 2024 API
ConnectorSet..::..GetEnumerator Method
ConnectorSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

ConnectorSet Class


ReverseIterator Method

[image]

Revit 2024 API
ConnectorSet..::..ReverseIterator Method
ConnectorSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual ConnectorSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As ConnectorSetIterator
Visual C++
public:
virtual ConnectorSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

ConnectorSet Class


ConnectorSet Properties

[image] [image]

Revit 2024 API
ConnectorSet Properties
ConnectorSet Class See Also Send Feedback

The ConnectorSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

ConnectorSet Class


IsEmpty Property

[image]

Revit 2024 API
ConnectorSet..::..IsEmpty Property
ConnectorSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

ConnectorSet Class


Size Property

[image]

Revit 2024 API
ConnectorSet..::..Size Property
ConnectorSet Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ConnectorSet Class


ConnectorSetIterator Class

[image]

Revit 2024 API
ConnectorSetIterator Class
Members See Also Send Feedback
An iterator to a set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public abstract class ConnectorSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class ConnectorSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ConnectorSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..ConnectorSetIterator

See Also

ConnectorSetIterator Members


ConnectorSetIterator Members

[image] [image]

Revit 2024 API
ConnectorSetIterator Members
ConnectorSetIterator Class Constructors Methods Properties See Also Send Feedback

The ConnectorSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | ConnectorSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ConnectorSetIterator Class


ConnectorSetIterator Methods

[image] [image]

Revit 2024 API
ConnectorSetIterator Methods
ConnectorSetIterator Class See Also Send Feedback

The ConnectorSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ConnectorSetIterator Class


MoveNext Method

[image]

Revit 2024 API
ConnectorSetIterator..::..MoveNext Method
ConnectorSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ConnectorSetIterator Class


Reset Method

[image]

Revit 2024 API
ConnectorSetIterator..::..Reset Method
ConnectorSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ConnectorSetIterator Class


ConnectorSetIterator Properties

[image] [image]

Revit 2024 API
ConnectorSetIterator Properties
ConnectorSetIterator Class See Also Send Feedback

The ConnectorSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ConnectorSetIterator Class


Current Property

[image]

Revit 2024 API
ConnectorSetIterator..::..Current Property
ConnectorSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ConnectorSetIterator Class


ConnectorType Enumeration

[image]

Revit 2024 API
ConnectorType Enumeration
See Also Send Feedback
An enumerated type listing all connector types for a connection

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum ConnectorType
Visual Basic
Public Enumeration ConnectorType
Visual C++
public enum class ConnectorType

Members

Member name | Description
Invalid | Invalid connection type
End | End connection type
Curve | Curve connection type
Logical | Logical connection type
Reference | Reference connection type
Surface | Surface connection type
EndSurface | End or Surface connection type
Physical | Physical connection type
NonEnd | Not end connection type
MasterSurface | This value is deprecated and will be removed in a future version of Revit. Please use MainSurface instead.
MainSurface | Main surface connection type
Family | Family connection type
NodeReference | Reference to the layout node type
BlankEnd | Blank End type
AnyEnd | Any end connection type
Super | Connection between a sub-system and a super-system, such as a connection between supply and return sub-systems and a main hydronic piping system or an air system.
AllModes | All connection modes

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


Construction Class

[image]

Revit 2024 API
Construction Class
Members See Also Send Feedback
Construction definition for Project Information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class Construction
Visual Basic
Public Class Construction
Visual C++
public ref class Construction

Remarks

This is used to define the information in Constructions.xml.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Construction

See Also

Construction Members


Construction Members

[image] [image]

Revit 2024 API
Construction Members
Construction Class Methods Properties See Also Send Feedback

The Construction type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Id | Get the id of the Construction.
Public property | Name | Get the name of the Construction.

See Also

Construction Class


Construction Methods

[image] [image]

Revit 2024 API
Construction Methods
Construction Class See Also Send Feedback

The Construction type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Construction Class


Construction Properties

[image] [image]

Revit 2024 API
Construction Properties
Construction Class See Also Send Feedback

The Construction type exposes the following members.

Properties

 | Name | Description
Public property | Id | Get the id of the Construction.
Public property | Name | Get the name of the Construction.

See Also

Construction Class


Name Property

[image]

Revit 2024 API
Construction..::..Name Property
Construction Class See Also Send Feedback
Get the name of the Construction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

Remarks

This property is used to get the name of the Construction.

See Also

Construction Class


ContentNode Class

[image]

Revit 2024 API
ContentNode Class
Members See Also Send Feedback
This class represents a generic content node in a model-exporting process.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class ContentNode : RenderNode
Visual Basic
Public Class ContentNode _
    Inherits RenderNode
Visual C++
public ref class ContentNode : public RenderNode

Remarks

Members of this class implement properties and methods common to all content classes, such as RPC and Light nodes. Attributes of a content note can be accessed via an Asset object.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..RenderNode
Autodesk.Revit.DB..::..ContentNode
Autodesk.Revit.DB..::..LightNode
Autodesk.Revit.DB..::..RPCNode

See Also

ContentNode Members


ContentNode Members

[image] [image]

Revit 2024 API
ContentNode Members
ContentNode Class Methods Properties See Also Send Feedback

The ContentNode type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RenderNode.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAsset | Returns an an instance of an Asset object, which contains definitions of the content node.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTransform | A transformation matrix associated with the node.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode.)
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode.)

See Also

ContentNode Class


ContentNode Methods

[image] [image]

Revit 2024 API
ContentNode Methods
ContentNode Class See Also Send Feedback

The ContentNode type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RenderNode.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAsset | Returns an an instance of an Asset object, which contains definitions of the content node.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTransform | A transformation matrix associated with the node.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ContentNode Class


GetAsset Method

[image]

Revit 2024 API
ContentNode..::..GetAsset Method
ContentNode Class See Also Send Feedback
Returns an an instance of an Asset object, which contains definitions of the content node.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public Asset GetAsset()
Visual Basic
Public Function GetAsset As Asset
Visual C++
public:
Asset^ GetAsset()

Remarks

Properties and attributes of the node can be accessed using the standard interface of the Asset class.

See Also

ContentNode Class


GetTransform Method

[image]

Revit 2024 API
ContentNode..::..GetTransform Method
ContentNode Class See Also Send Feedback
A transformation matrix associated with the node.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public Transform GetTransform()
Visual Basic
Public Function GetTransform As Transform
Visual C++
public:
Transform^ GetTransform()

See Also

ContentNode Class


ContourSetting Class

[image]

Revit 2024 API
ContourSetting Class
Members See Also Send Feedback
Contour setting object that handles the contour information used to draw contours on elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public class ContourSetting : IDisposable
Visual Basic
Public Class ContourSetting _
    Implements IDisposable
Visual C++
public ref class ContourSetting : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ContourSetting

See Also

ContourSetting Members


ContourSetting Members

[image] [image]

Revit 2024 API
ContourSetting Members
ContourSetting Class Methods Properties See Also Send Feedback

The ContourSetting type exposes the following members.

Methods

 | Name | Description
Public method | AddContourRange | Add a set of contours as a contour setting item to the current contour setting.
Public method | AddSingleContour | Add a single contour as a contour setting item to the current contour setting.
Public method | DisableItem | Disable a contour setting item of the current contour setting so that the item will not be used to draw contours.
Public method | Dispose | Releases all resources used by the ContourSetting
Public method | EnableItem | Enable a contour setting item of the current contour setting so that the item will be used to draw contours.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetContourSettingItems | Get all contour setting items.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemIndex | Get the index of a contour setting item of the current contour setting
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveItem | Remove a contour setting item from the current contour setting.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ContourSetting Class


AddContourRange Method

[image]

Revit 2024 API
ContourSetting..::..AddContourRange Method
ContourSetting Class See Also Send Feedback
Add a set of contours as a contour setting item to the current contour setting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public ContourSettingItem AddContourRange(
    double start,
    double stop,
    double step,
    ElementId subcategoryId
)
Visual Basic
Public Function AddContourRange ( _
    start As Double, _
    stop As Double, _
    step As Double, _
    subcategoryId As ElementId _
) As ContourSettingItem
Visual C++
public:
ContourSettingItem^ AddContourRange(
    double start,
    double stop,
    double step,
    ElementId^ subcategoryId
)

Parameters

start
Type: System..::..Double
The contour range start elevation.
stop
Type: System..::..Double
The contour range stop elevation. Should be greater than start elevation.
step
Type: System..::..Double
The increment elevation of the contour range. Should be greater than zero.
subcategoryId
Type: Autodesk.Revit.DB..::..ElementId
The contour line style subcategory id.

Return Value

The newly added contour setting item.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for start is not finite -or- The given value for stop is not finite -or- The given value for step is not finite -or- The input subcategory id is not valid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The input contour spacing information is not valid.

See Also

ContourSetting Class


DisableItem Method

[image]

Revit 2024 API
ContourSetting..::..DisableItem Method
ContourSetting Class See Also Send Feedback
Disable a contour setting item of the current contour setting so that the item will not be used to draw contours.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public void DisableItem(
    ContourSettingItem item
)
Visual Basic
Public Sub DisableItem ( _
    item As ContourSettingItem _
)
Visual C++
public:
void DisableItem(
    ContourSettingItem^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..ContourSettingItem
The contour setting item to be disabled.

Remarks

Contour setting will not be changed if the item could not be found.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ContourSetting Class


Dispose Method

[image]

Revit 2024 API
ContourSetting..::..Dispose Method
ContourSetting Class See Also Send Feedback
Releases all resources used by the ContourSetting

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ContourSetting Class


GetContourSettingItems Method

[image]

Revit 2024 API
ContourSetting..::..GetContourSettingItems Method
ContourSetting Class See Also Send Feedback
Get all contour setting items.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public IList<ContourSettingItem> GetContourSettingItems()
Visual Basic
Public Function GetContourSettingItems As IList(Of ContourSettingItem)
Visual C++
public:
IList<ContourSettingItem^>^ GetContourSettingItems()

Return Value

An array of contour setting items.

See Also

ContourSetting Class


GetItemIndex Method

[image]

Revit 2024 API
ContourSetting..::..GetItemIndex Method
ContourSetting Class See Also Send Feedback
Get the index of a contour setting item of the current contour setting

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public int GetItemIndex(
    ContourSettingItem item
)
Visual Basic
Public Function GetItemIndex ( _
    item As ContourSettingItem _
) As Integer
Visual C++
public:
int GetItemIndex(
    ContourSettingItem^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..ContourSettingItem
The contour setting item.

Return Value

The index of the input contour setting item. -1 if the item is not found.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ContourSetting Class


RemoveItem Method

[image]

Revit 2024 API
ContourSetting..::..RemoveItem Method
ContourSetting Class See Also Send Feedback
Remove a contour setting item from the current contour setting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public void RemoveItem(
    ContourSettingItem item
)
Visual Basic
Public Sub RemoveItem ( _
    item As ContourSettingItem _
)
Visual C++
public:
void RemoveItem(
    ContourSettingItem^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..ContourSettingItem
The contour setting item to be removed.

Remarks

Contour setting will not be changed if the item could not be found.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ContourSetting Class


ContourSetting Properties

[image] [image]

Revit 2024 API
ContourSetting Properties
ContourSetting Class See Also Send Feedback

The ContourSetting type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ContourSetting Class


IsValidObject Property

[image]

Revit 2024 API
ContourSetting..::..IsValidObject Property
ContourSetting Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ContourSetting Class


ContourSettingItem Class

[image]

Revit 2024 API
ContourSettingItem Class
Members See Also Send Feedback
Contour setting item that stores the information of a single contour or a set of contours.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public class ContourSettingItem : IDisposable
Visual Basic
Public Class ContourSettingItem _
    Implements IDisposable
Visual C++
public ref class ContourSettingItem : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ContourSettingItem

See Also

ContourSettingItem Members


ContourSettingItem Members

[image] [image]

Revit 2024 API
ContourSettingItem Members
ContourSettingItem Class Methods Properties See Also Send Feedback

The ContourSettingItem type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ContourSettingItem
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Start | The contour range start elevation.
Public property | Step | The increment elevation of the contour range.
Public property | Stop | The contour range stop elevation.
Public property | SubCategoryId | The contour line style subcategory id.

See Also

ContourSettingItem Class


ContourSettingItem Methods

[image] [image]

Revit 2024 API
ContourSettingItem Methods
ContourSettingItem Class See Also Send Feedback

The ContourSettingItem type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ContourSettingItem Class


Dispose Method

[image]

Revit 2024 API
ContourSettingItem..::..Dispose Method
ContourSettingItem Class See Also Send Feedback
Releases all resources used by the ContourSettingItem

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ContourSettingItem Class


ContourSettingItem Properties

[image] [image]

Revit 2024 API
ContourSettingItem Properties
ContourSettingItem Class See Also Send Feedback

The ContourSettingItem type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Start | The contour range start elevation.
Public property | Step | The increment elevation of the contour range.
Public property | Stop | The contour range stop elevation.
Public property | SubCategoryId | The contour line style subcategory id.

See Also

ContourSettingItem Class


IsValidObject Property

[image]

Revit 2024 API
ContourSettingItem..::..IsValidObject Property
ContourSettingItem Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ContourSettingItem Class


Start Property

[image]

Revit 2024 API
ContourSettingItem..::..Start Property
ContourSettingItem Class See Also Send Feedback
The contour range start elevation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public double Start { get; }
Visual Basic
Public ReadOnly Property Start As Double
    Get
Visual C++
public:
property double Start {
    double get ();
}

See Also

ContourSettingItem Class


Step Property

[image]

Revit 2024 API
ContourSettingItem..::..Step Property
ContourSettingItem Class See Also Send Feedback
The increment elevation of the contour range.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public double Step { get; }
Visual Basic
Public ReadOnly Property Step As Double
    Get
Visual C++
public:
property double Step {
    double get ();
}

See Also

ContourSettingItem Class


Stop Property

[image]

Revit 2024 API
ContourSettingItem..::..Stop Property
ContourSettingItem Class See Also Send Feedback
The contour range stop elevation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public double Stop { get; }
Visual Basic
Public ReadOnly Property Stop As Double
    Get
Visual C++
public:
property double Stop {
    double get ();
}

See Also

ContourSettingItem Class


SubCategoryId Property

[image]

Revit 2024 API
ContourSettingItem..::..SubCategoryId Property
ContourSettingItem Class See Also Send Feedback
The contour line style subcategory id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public ElementId SubCategoryId { get; }
Visual Basic
Public ReadOnly Property SubCategoryId As ElementId
    Get
Visual C++
public:
property ElementId^ SubCategoryId {
    ElementId^ get ();
}

See Also

ContourSettingItem Class


Control Members

[image] [image]

Revit 2024 API
Control Members
Control Class Methods Properties See Also Send Feedback

The Control type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Origin | The control origin.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Shape | The control shape.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | View | The view.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Control Class


Parameter Property

[image] [image]

Revit 2024 API
Control..::..Parameter Property
Control Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Control Class
Control Members


Shape Property

[image]

Revit 2024 API
Control..::..Shape Property
Control Class See Also Send Feedback
The control shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ControlShape Shape { get; }
Visual Basic
Public ReadOnly Property Shape As ControlShape
    Get
Visual C++
public:
property ControlShape Shape {
    ControlShape get ();
}

See Also

Control Class


ControlShape Enumeration

[image]

Revit 2024 API
ControlShape Enumeration
See Also Send Feedback
An enumerated type listing four shapes of control that Autodesk Revit supports.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum ControlShape
Visual Basic
Public Enumeration ControlShape
Visual C++
public enum class ControlShape

Members

Member name | Description
VerticalArrow | Vertical arrow.
HorizontalArrow | Horizontal arrow.
DoubleVerticalArrow | Double vertical arrow.
DoubleHorizontalArrow | Double horizontal arrow.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


CoordinatePlaneVisibility Enumeration

[image]

Revit 2024 API
CoordinatePlaneVisibility Enumeration
See Also Send Feedback
Visibility settings for ReferencePoint element's coordinate reference planes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public enum CoordinatePlaneVisibility
Visual Basic
Public Enumeration CoordinatePlaneVisibility
Visual C++
public enum class CoordinatePlaneVisibility

Members

Member name | Description
Never | Never visible.
WhenSelected | Visible when selected.
Always | Always Visible.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


CopyPasteOptions Members

[image] [image]

Revit 2024 API
CopyPasteOptions Members
CopyPasteOptions Class Constructors Methods Properties See Also Send Feedback

The CopyPasteOptions type exposes the following members.

Constructors

 | Name | Description
Public method | CopyPasteOptions | Creates a new instance of a CopyPasteOptions object.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the CopyPasteOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDuplicateTypeNamesHandler | Returns current duplicate type names handler or nullNothingnullptra null reference (Nothing in Visual Basic) if none is set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDuplicateTypeNamesHandler | Sets a custom duplicate type names handler. If this value is not set, the default handler is used. By default, Revit displays a modal dialog with options to either copy new types only, or cancel the operation.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

CopyPasteOptions Class


Dispose Method

[image]

Revit 2024 API
CopyPasteOptions..::..Dispose Method
CopyPasteOptions Class See Also Send Feedback
Releases all resources used by the CopyPasteOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

CopyPasteOptions Class


SetDuplicateTypeNamesHandler Method

[image]

Revit 2024 API
CopyPasteOptions..::..SetDuplicateTypeNamesHandler Method
CopyPasteOptions Class See Also Send Feedback
Sets a custom duplicate type names handler. If this value is not set, the default handler is used. By default, Revit displays a modal dialog with options to either copy new types only, or cancel the operation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void SetDuplicateTypeNamesHandler(
    IDuplicateTypeNamesHandler handler
)
Visual Basic
Public Sub SetDuplicateTypeNamesHandler ( _
    handler As IDuplicateTypeNamesHandler _
)
Visual C++
public:
void SetDuplicateTypeNamesHandler(
    IDuplicateTypeNamesHandler^ handler
)

Parameters

handler
Type: Autodesk.Revit.DB..::..IDuplicateTypeNamesHandler
The duplicate type names handler.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

CopyPasteOptions Class


CopyPasteOptions Properties

[image] [image]

Revit 2024 API
CopyPasteOptions Properties
CopyPasteOptions Class See Also Send Feedback

The CopyPasteOptions type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

CopyPasteOptions Class


IsValidObject Property

[image]

Revit 2024 API
CopyPasteOptions..::..IsValidObject Property
CopyPasteOptions Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

CopyPasteOptions Class


CurtainCell Class

[image]

Revit 2024 API
CurtainCell Class
Members See Also Send Feedback
Represents a CurtainCell within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class CurtainCell : APIObject
Visual Basic
Public Class CurtainCell _
    Inherits APIObject
Visual C++
public ref class CurtainCell : public APIObject

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..CurtainCell

See Also

CurtainCell Members


CurtainCell Members

[image] [image]

Revit 2024 API
CurtainCell Members
CurtainCell Class Methods Properties See Also Send Feedback

The CurtainCell type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CurveLoops | The cell boundaries on the reference face. The boundaries can have more than one CurveLoop. Each item in the returned array represents a CurveLoop containing 3 or more than 3 edges.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | PlanarizedCurveLoops | The planarized curve loops for cell boundaries. The boundaries can have more than one CurveLoop. Each item in the returned array represents a CurveLoop containing 3 or more than 3 edges.

See Also

CurtainCell Class


CurtainCell Methods

[image] [image]

Revit 2024 API
CurtainCell Methods
CurtainCell Class See Also Send Feedback

The CurtainCell type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CurtainCell Class


CurtainCell Properties

[image] [image]

Revit 2024 API
CurtainCell Properties
CurtainCell Class See Also Send Feedback

The CurtainCell type exposes the following members.

Properties

 | Name | Description
Public property | CurveLoops | The cell boundaries on the reference face. The boundaries can have more than one CurveLoop. Each item in the returned array represents a CurveLoop containing 3 or more than 3 edges.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | PlanarizedCurveLoops | The planarized curve loops for cell boundaries. The boundaries can have more than one CurveLoop. Each item in the returned array represents a CurveLoop containing 3 or more than 3 edges.

See Also

CurtainCell Class


PlanarizedCurveLoops Property

[image]

Revit 2024 API
CurtainCell..::..PlanarizedCurveLoops Property
CurtainCell Class See Also Send Feedback
The planarized curve loops for cell boundaries. The boundaries can have more than one CurveLoop. Each item in the returned array represents a CurveLoop containing 3 or more than 3 edges.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CurveArrArray PlanarizedCurveLoops { get; }
Visual Basic
Public ReadOnly Property PlanarizedCurveLoops As CurveArrArray
    Get
Visual C++
public:
property CurveArrArray^ PlanarizedCurveLoops {
    CurveArrArray^ get ();
}

See Also

CurtainCell Class


CurtainGrid Class

[image]

Revit 2024 API
CurtainGrid Class
Members See Also Send Feedback
Represents a curtain grid element within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class CurtainGrid : APIObject
Visual Basic
Public Class CurtainGrid _
    Inherits APIObject
Visual C++
public ref class CurtainGrid : public APIObject

Remarks

This element is obtained from a curtain wall, curtain system, or curtain roof. A curtain wall has only one curtain grid, while a curtain system or curtain roof may have several curtain grids.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..CurtainGrid

See Also

CurtainGrid Members


CurtainGrid Members

[image] [image]

Revit 2024 API
CurtainGrid Members
CurtainGrid Class Methods Properties See Also Send Feedback

The CurtainGrid type exposes the following members.

Methods

 | Name | Description
Public method | AddGridLine | Add a grid line to the curtain grid.
Public method | ChangePanelType | Change the type of a curtain panel.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCell | Get the specified cell located by the intersection of the grid lines.
Public method | GetCurtainCells | Gets the CurtainCells owned by this curtain grid.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMullionIds | Gets all ElementIds of the mullions of the curtain grid.
Public method | GetPanel | Get the specified panel located by the intersection of the grid lines.
Public method | GetPanelIds | Gets all ElementIds of the panels of the curtain grid.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUGridLineIds | Gets all ElementIds of grid lines in the U direction.
Public method | GetUnlockedMullionIds | Gets all ElementIds of the unlocked mullions of the curtain grid.
Public method | GetUnlockedPanelIds | Gets all ElementIds of the unlocked panels of the curtain grid.
Public method | GetVGridLineIds | Gets all ElementIds of grid lines in the V direction.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Grid1Angle | The angle for the U grid line pattern of the curtain grid.
Public property | Grid1Justification | The justification for the U grid line pattern of the curtain grid.
Public property | Grid1Offset | The offset for the U grid line pattern of the curtain grid.
Public property | Grid2Angle | The angle for V grid line pattern of the curtain grid.
Public property | Grid2Justification | The justification for the V grid line pattern of the curtain grid.
Public property | Grid2Offset | The offset for V grid line pattern of the curtain grid.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | NumPanels | The number of panels.
Public property | NumULines | Get the number of grid lines in the U direction.
Public property | NumVLines | Get the number of grid lines in the V direction.

See Also

CurtainGrid Class


AddGridLine Method

[image]

Revit 2024 API
CurtainGrid..::..AddGridLine Method
CurtainGrid Class See Also Send Feedback
Add a grid line to the curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CurtainGridLine AddGridLine(
    bool isUGridLine,
    XYZ position,
    bool oneSegmentOnly
)
Visual Basic
Public Function AddGridLine ( _
    isUGridLine As Boolean, _
    position As XYZ, _
    oneSegmentOnly As Boolean _
) As CurtainGridLine
Visual C++
public:
CurtainGridLine^ AddGridLine(
    bool isUGridLine,
    XYZ^ position,
    bool oneSegmentOnly
)

Parameters

isUGridLine
Type: System..::..Boolean
If true, a U-direction grid line will be added. Otherwise, a V-direction grid line will be added.
position
Type: Autodesk.Revit.DB..::..XYZ
The position of the grid line.
oneSegmentOnly
Type: System..::..Boolean
If it is true, only one segment is added. Otherwise, all segments will be added for the grid line.

Return Value

The created grid line is returned if the operation is successful. Otherwise, nullNothingnullptra null reference (Nothing in Visual Basic) is returned.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if the position for the grid line is out of range.

See Also

CurtainGrid Class


ChangePanelType Method

[image]

Revit 2024 API
CurtainGrid..::..ChangePanelType Method
CurtainGrid Class See Also Send Feedback
Change the type of a curtain panel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Element ChangePanelType(
    Element panel,
    ElementType newSymbol
)
Visual Basic
Public Function ChangePanelType ( _
    panel As Element, _
    newSymbol As ElementType _
) As Element
Visual C++
public:
Element^ ChangePanelType(
    Element^ panel,
    ElementType^ newSymbol
)

Parameters

panel
Type: Autodesk.Revit.DB..::..Element
The panel to be changed, it can be a type of Panel or Wall.
newSymbol
Type: Autodesk.Revit.DB..::..ElementType
The new symbol, it may be of PanelType or WallType when the panel is hosted in a curtain wall. The new symbol can only be of type PanelType if the Panel is hosted in a curtain system.

Return Value

If operation succeeds, the modified panel element is returned.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the input symbol can't be used for the panel.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the type change failed.

See Also

CurtainGrid Class


GetCell Method

[image]

Revit 2024 API
CurtainGrid..::..GetCell Method
CurtainGrid Class See Also Send Feedback
Get the specified cell located by the intersection of the grid lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CurtainCell GetCell(
    ElementId uGridLineId,
    ElementId vGridLineId
)
Visual Basic
Public Function GetCell ( _
    uGridLineId As ElementId, _
    vGridLineId As ElementId _
) As CurtainCell
Visual C++
public:
CurtainCell^ GetCell(
    ElementId^ uGridLineId,
    ElementId^ vGridLineId
)

Parameters

uGridLineId
Type: Autodesk.Revit.DB..::..ElementId
The id of a grid line in the U-direction used to locate the cell.
vGridLineId
Type: Autodesk.Revit.DB..::..ElementId
The id of a grid line in the V-direction used to locate the cell.

Return Value

The cell.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the grid line ids are not part of this curtain grid.

See Also

CurtainGrid Class


GetCurtainCells Method

[image]

Revit 2024 API
CurtainGrid..::..GetCurtainCells Method
CurtainGrid Class See Also Send Feedback
Gets the CurtainCells owned by this curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ICollection<CurtainCell> GetCurtainCells()
Visual Basic
Public Function GetCurtainCells As ICollection(Of CurtainCell)
Visual C++
public:
ICollection<CurtainCell^>^ GetCurtainCells()

Return Value

The CurtainCells owned by this curtain grid.

See Also

CurtainGrid Class


GetMullionIds Method

[image]

Revit 2024 API
CurtainGrid..::..GetMullionIds Method
CurtainGrid Class See Also Send Feedback
Gets all ElementIds of the mullions of the curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ICollection<ElementId> GetMullionIds()
Visual Basic
Public Function GetMullionIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetMullionIds()

Return Value

The mullion ElementIds

Remarks

ElementIds are of Mullion Elements.

See Also

CurtainGrid Class


GetUGridLineIds Method

[image]

Revit 2024 API
CurtainGrid..::..GetUGridLineIds Method
CurtainGrid Class See Also Send Feedback
Gets all ElementIds of grid lines in the U direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ICollection<ElementId> GetUGridLineIds()
Visual Basic
Public Function GetUGridLineIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetUGridLineIds()

Return Value

The U grid line ElementIds

See Also

CurtainGrid Class


GetUnlockedMullionIds Method

[image]

Revit 2024 API
CurtainGrid..::..GetUnlockedMullionIds Method
CurtainGrid Class See Also Send Feedback
Gets all ElementIds of the unlocked mullions of the curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ICollection<ElementId> GetUnlockedMullionIds()
Visual Basic
Public Function GetUnlockedMullionIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetUnlockedMullionIds()

Return Value

The unlocked mullion ElementIds

Remarks

ElementIds are of Mullion Elements.

See Also

CurtainGrid Class


GetUnlockedPanelIds Method

[image]

Revit 2024 API
CurtainGrid..::..GetUnlockedPanelIds Method
CurtainGrid Class See Also Send Feedback
Gets all ElementIds of the unlocked panels of the curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ICollection<ElementId> GetUnlockedPanelIds()
Visual Basic
Public Function GetUnlockedPanelIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetUnlockedPanelIds()

Return Value

The unlocked panel ElementIds

Remarks

For curtain walls, the ElementIds in this set are of either Panel or Wall Elements. For curtain systems, ElementIds are of Panel Elements.

See Also

CurtainGrid Class


GetVGridLineIds Method

[image]

Revit 2024 API
CurtainGrid..::..GetVGridLineIds Method
CurtainGrid Class See Also Send Feedback
Gets all ElementIds of grid lines in the V direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ICollection<ElementId> GetVGridLineIds()
Visual Basic
Public Function GetVGridLineIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetVGridLineIds()

Return Value

The V grid line ElementIds

See Also

CurtainGrid Class


CurtainGrid Properties

[image] [image]

Revit 2024 API
CurtainGrid Properties
CurtainGrid Class See Also Send Feedback

The CurtainGrid type exposes the following members.

Properties

 | Name | Description
Public property | Grid1Angle | The angle for the U grid line pattern of the curtain grid.
Public property | Grid1Justification | The justification for the U grid line pattern of the curtain grid.
Public property | Grid1Offset | The offset for the U grid line pattern of the curtain grid.
Public property | Grid2Angle | The angle for V grid line pattern of the curtain grid.
Public property | Grid2Justification | The justification for the V grid line pattern of the curtain grid.
Public property | Grid2Offset | The offset for V grid line pattern of the curtain grid.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | NumPanels | The number of panels.
Public property | NumULines | Get the number of grid lines in the U direction.
Public property | NumVLines | Get the number of grid lines in the V direction.

See Also

CurtainGrid Class


Grid1Angle Property

[image]

Revit 2024 API
CurtainGrid..::..Grid1Angle Property
CurtainGrid Class See Also Send Feedback
The angle for the U grid line pattern of the curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double Grid1Angle { get; set; }
Visual Basic
Public Property Grid1Angle As Double
    Get
    Set
Visual C++
public:
property double Grid1Angle {
    double get ();
    void set (double value);
}

See Also

CurtainGrid Class


Grid1Justification Property

[image]

Revit 2024 API
CurtainGrid..::..Grid1Justification Property
CurtainGrid Class See Also Send Feedback
The justification for the U grid line pattern of the curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CurtainGridAlignType Grid1Justification { get; set; }
Visual Basic
Public Property Grid1Justification As CurtainGridAlignType
    Get
    Set
Visual C++
public:
property CurtainGridAlignType Grid1Justification {
    CurtainGridAlignType get ();
    void set (CurtainGridAlignType value);
}

See Also

CurtainGrid Class


Grid1Offset Property

[image]

Revit 2024 API
CurtainGrid..::..Grid1Offset Property
CurtainGrid Class See Also Send Feedback
The offset for the U grid line pattern of the curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double Grid1Offset { get; set; }
Visual Basic
Public Property Grid1Offset As Double
    Get
    Set
Visual C++
public:
property double Grid1Offset {
    double get ();
    void set (double value);
}

See Also

CurtainGrid Class


Grid2Angle Property

[image]

Revit 2024 API
CurtainGrid..::..Grid2Angle Property
CurtainGrid Class See Also Send Feedback
The angle for V grid line pattern of the curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double Grid2Angle { get; set; }
Visual Basic
Public Property Grid2Angle As Double
    Get
    Set
Visual C++
public:
property double Grid2Angle {
    double get ();
    void set (double value);
}

See Also

CurtainGrid Class


Grid2Justification Property

[image]

Revit 2024 API
CurtainGrid..::..Grid2Justification Property
CurtainGrid Class See Also Send Feedback
The justification for the V grid line pattern of the curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CurtainGridAlignType Grid2Justification { get; set; }
Visual Basic
Public Property Grid2Justification As CurtainGridAlignType
    Get
    Set
Visual C++
public:
property CurtainGridAlignType Grid2Justification {
    CurtainGridAlignType get ();
    void set (CurtainGridAlignType value);
}

See Also

CurtainGrid Class


Grid2Offset Property

[image]

Revit 2024 API
CurtainGrid..::..Grid2Offset Property
CurtainGrid Class See Also Send Feedback
The offset for V grid line pattern of the curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double Grid2Offset { get; set; }
Visual Basic
Public Property Grid2Offset As Double
    Get
    Set
Visual C++
public:
property double Grid2Offset {
    double get ();
    void set (double value);
}

See Also

CurtainGrid Class


NumPanels Property

[image]

Revit 2024 API
CurtainGrid..::..NumPanels Property
CurtainGrid Class See Also Send Feedback
The number of panels.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public int NumPanels { get; }
Visual Basic
Public ReadOnly Property NumPanels As Integer
    Get
Visual C++
public:
property int NumPanels {
    int get ();
}

See Also

CurtainGrid Class


NumULines Property

[image]

Revit 2024 API
CurtainGrid..::..NumULines Property
CurtainGrid Class See Also Send Feedback
Get the number of grid lines in the U direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public int NumULines { get; }
Visual Basic
Public ReadOnly Property NumULines As Integer
    Get
Visual C++
public:
property int NumULines {
    int get ();
}

See Also

CurtainGrid Class


CurtainGridAlignType Enumeration

[image]

Revit 2024 API
CurtainGridAlignType Enumeration
See Also Send Feedback
An enumerated to list CurtainGrid patterns.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum CurtainGridAlignType
Visual Basic
Public Enumeration CurtainGridAlignType
Visual C++
public enum class CurtainGridAlignType

Members

Member name | Description
NoJustify | NoJustify.
Beginning | Beginning pattern of CurtainGrid.
Center | Center pattern of CurtainGrid.
End | End pattern of CurtainGrid.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


CurtainGridLine Class

[image]

Revit 2024 API
CurtainGridLine Class
Members See Also Send Feedback
Represents a CurtainGridLine within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class CurtainGridLine : HostObject
Visual Basic
Public Class CurtainGridLine _
    Inherits HostObject
Visual C++
public ref class CurtainGridLine : public HostObject

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB..::..CurtainGridLine

See Also

CurtainGridLine Members


CurtainGridLine Members

[image] [image]

Revit 2024 API
CurtainGridLine Members
CurtainGridLine Class Methods Properties See Also Send Feedback

The CurtainGridLine type exposes the following members.

Methods

 | Name | Description
Public method | AddAllSegments | All the segments on this grid line will be added.
Public method | AddMullions | Add mullions on the specified segments of a grid. If any segment already has a mullion, no change is made to that segment.
Public method | AddSegment | Add a segment based on the specified segment curve of the gridline.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | RemoveSegment | Remove the segment specified by the input curve.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AllSegmentCurves | Retrieve the curves of all segments.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | ExistingSegmentCurves | Retrieve all the existing segment curves of the grid line.
Public property | FullCurve | Retrieve the geometry curve of the curtain grid line.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsUGridLine | Retrieve the direction of a grid line.If it is true,we say it is a UGridLine,otherwise it is VGridLine
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Lock | Retrieves or changes the lock state of the curtain grid line.
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SkippedSegmentCurves | Retrieve all the removed segment curves of the grid line.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

CurtainGridLine Class


CurtainGridLine Methods

[image] [image]

Revit 2024 API
CurtainGridLine Methods
CurtainGridLine Class See Also Send Feedback

The CurtainGridLine type exposes the following members.

Methods

 | Name | Description
Public method | AddAllSegments | All the segments on this grid line will be added.
Public method | AddMullions | Add mullions on the specified segments of a grid. If any segment already has a mullion, no change is made to that segment.
Public method | AddSegment | Add a segment based on the specified segment curve of the gridline.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | RemoveSegment | Remove the segment specified by the input curve.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CurtainGridLine Class


AddAllSegments Method

[image]

Revit 2024 API
CurtainGridLine..::..AddAllSegments Method
CurtainGridLine Class See Also Send Feedback
All the segments on this grid line will be added.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void AddAllSegments()
Visual Basic
Public Sub AddAllSegments
Visual C++
public:
void AddAllSegments()

See Also

CurtainGridLine Class


AddMullions Method

[image]

Revit 2024 API
CurtainGridLine..::..AddMullions Method
CurtainGridLine Class See Also Send Feedback
Add mullions on the specified segments of a grid. If any segment already has a mullion, no change is made to that segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElementSet AddMullions(
    Curve segment,
    MullionType mullionType,
    bool oneSegmentOnly
)
Visual Basic
Public Function AddMullions ( _
    segment As Curve, _
    mullionType As MullionType, _
    oneSegmentOnly As Boolean _
) As ElementSet
Visual C++
public:
ElementSet^ AddMullions(
    Curve^ segment,
    MullionType^ mullionType,
    bool oneSegmentOnly
)

Parameters

segment
Type: Autodesk.Revit.DB..::..Curve
Curve of the segment.
mullionType
Type: Autodesk.Revit.DB..::..MullionType
The type of the mullion to add.
oneSegmentOnly
Type: System..::..Boolean
If true, add one mullion to the specified segment, otherwise add mullions to all the segments of the matching grid line.

Return Value

If operation succeeds, the created mullions will be returned.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Invalid curtain grid line or invalid mullion type argument.

See Also

CurtainGridLine Class


AddSegment Method

[image]

Revit 2024 API
CurtainGridLine..::..AddSegment Method
CurtainGridLine Class See Also Send Feedback
Add a segment based on the specified segment curve of the gridline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void AddSegment(
    Curve curve
)
Visual Basic
Public Sub AddSegment ( _
    curve As Curve _
)
Visual C++
public:
void AddSegment(
    Curve^ curve
)

Parameters

curve
Type: Autodesk.Revit.DB..::..Curve
The curve used to locate the segment to be removed. This function will invoke regeneration.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Segment may not have been found in location indicated by curve.

See Also

CurtainGridLine Class


RemoveSegment Method

[image]

Revit 2024 API
CurtainGridLine..::..RemoveSegment Method
CurtainGridLine Class See Also Send Feedback
Remove the segment specified by the input curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void RemoveSegment(
    Curve curve
)
Visual Basic
Public Sub RemoveSegment ( _
    curve As Curve _
)
Visual C++
public:
void RemoveSegment(
    Curve^ curve
)

Parameters

curve
Type: Autodesk.Revit.DB..::..Curve
The curve used to locate the segment to be removed.

Remarks

When a segment is removed, the neighboring two panels will be merged into one panel. This function will invoke regeneration.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Segment may not have been found in location indicated by curve.

See Also

CurtainGridLine Class


CurtainGridLine Properties

[image] [image]

Revit 2024 API
CurtainGridLine Properties
CurtainGridLine Class See Also Send Feedback

The CurtainGridLine type exposes the following members.

Properties

 | Name | Description
Public property | AllSegmentCurves | Retrieve the curves of all segments.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | ExistingSegmentCurves | Retrieve all the existing segment curves of the grid line.
Public property | FullCurve | Retrieve the geometry curve of the curtain grid line.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsUGridLine | Retrieve the direction of a grid line.If it is true,we say it is a UGridLine,otherwise it is VGridLine
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Lock | Retrieves or changes the lock state of the curtain grid line.
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SkippedSegmentCurves | Retrieve all the removed segment curves of the grid line.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

CurtainGridLine Class


AllSegmentCurves Property

[image]

Revit 2024 API
CurtainGridLine..::..AllSegmentCurves Property
CurtainGridLine Class See Also Send Feedback
Retrieve the curves of all segments.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CurveArray AllSegmentCurves { get; }
Visual Basic
Public ReadOnly Property AllSegmentCurves As CurveArray
    Get
Visual C++
public:
property CurveArray^ AllSegmentCurves {
    CurveArray^ get ();
}

Remarks

User can get these curves and then call the method AddSegment() or RemoveSegment() to add/remove specified segments. If the specified segment is already added/removed, nothing will happen.

See Also

CurtainGridLine Class


ExistingSegmentCurves Property

[image]

Revit 2024 API
CurtainGridLine..::..ExistingSegmentCurves Property
CurtainGridLine Class See Also Send Feedback
Retrieve all the existing segment curves of the grid line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CurveArray ExistingSegmentCurves { get; }
Visual Basic
Public ReadOnly Property ExistingSegmentCurves As CurveArray
    Get
Visual C++
public:
property CurveArray^ ExistingSegmentCurves {
    CurveArray^ get ();
}

Remarks

User can get these curves and call RemoveSegment() to remove the segments to the gridline or call AddMullions() to add mullions to these segments.

See Also

CurtainGridLine Class


FullCurve Property

[image]

Revit 2024 API
CurtainGridLine..::..FullCurve Property
CurtainGridLine Class See Also Send Feedback
Retrieve the geometry curve of the curtain grid line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Curve FullCurve { get; }
Visual Basic
Public ReadOnly Property FullCurve As Curve
    Get
Visual C++
public:
property Curve^ FullCurve {
    Curve^ get ();
}

See Also

CurtainGridLine Class


IsUGridLine Property

[image]

Revit 2024 API
CurtainGridLine..::..IsUGridLine Property
CurtainGridLine Class See Also Send Feedback
Retrieve the direction of a grid line.If it is true,we say it is a UGridLine,otherwise it is VGridLine

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsUGridLine { get; }
Visual Basic
Public ReadOnly Property IsUGridLine As Boolean
    Get
Visual C++
public:
property bool IsUGridLine {
    bool get ();
}

See Also

CurtainGridLine Class


Lock Property

[image]

Revit 2024 API
CurtainGridLine..::..Lock Property
CurtainGridLine Class See Also Send Feedback
Retrieves or changes the lock state of the curtain grid line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool Lock { get; set; }
Visual Basic
Public Property Lock As Boolean
    Get
    Set
Visual C++
public:
property bool Lock {
    bool get ();
    void set (bool value);
}

See Also

CurtainGridLine Class


Parameter Property

[image] [image]

Revit 2024 API
CurtainGridLine..::..Parameter Property
CurtainGridLine Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

CurtainGridLine Class
CurtainGridLine Members


SkippedSegmentCurves Property

[image]

Revit 2024 API
CurtainGridLine..::..SkippedSegmentCurves Property
CurtainGridLine Class See Also Send Feedback
Retrieve all the removed segment curves of the grid line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CurveArray SkippedSegmentCurves { get; }
Visual Basic
Public ReadOnly Property SkippedSegmentCurves As CurveArray
    Get
Visual C++
public:
property CurveArray^ SkippedSegmentCurves {
    CurveArray^ get ();
}

Remarks

User can get these curves and then call the method AddSegment() to add the segments to the grid line.

See Also

CurtainGridLine Class


CurtainGridSet Class

[image]

Revit 2024 API
CurtainGridSet Class
Members See Also Send Feedback
A set that can contain any type of object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class CurtainGridSet : APIObject,
    IEnumerable
Visual Basic
Public Class CurtainGridSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class CurtainGridSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..CurtainGridSet

See Also

CurtainGridSet Members


CurtainGridSet Members

[image] [image]

Revit 2024 API
CurtainGridSet Members
CurtainGridSet Class Constructors Methods Properties See Also Send Feedback

The CurtainGridSet type exposes the following members.

Constructors

 | Name | Description
Public method | CurtainGridSet | Initializes a new instance of the CurtainGridSet class

Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

CurtainGridSet Class


CurtainGridSet Constructor

[image]

Revit 2024 API
CurtainGridSet Constructor
CurtainGridSet Class See Also Send Feedback
Initializes a new instance of the CurtainGridSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CurtainGridSet()
Visual Basic
Public Sub New
Visual C++
public:
CurtainGridSet()

See Also

CurtainGridSet Class


CurtainGridSet Methods

[image] [image]

Revit 2024 API
CurtainGridSet Methods
CurtainGridSet Class See Also Send Feedback

The CurtainGridSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CurtainGridSet Class


Clear Method

[image]

Revit 2024 API
CurtainGridSet..::..Clear Method
CurtainGridSet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

CurtainGridSet Class


Contains Method

[image]

Revit 2024 API
CurtainGridSet..::..Contains Method
CurtainGridSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool Contains(
    CurtainGrid item
)
Visual Basic
Public Overridable Function Contains ( _
    item As CurtainGrid _
) As Boolean
Visual C++
public:
virtual bool Contains(
    CurtainGrid^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..CurtainGrid

See Also

CurtainGridSet Class


Erase Method

[image]

Revit 2024 API
CurtainGridSet..::..Erase Method
CurtainGridSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Erase(
    CurtainGrid item
)
Visual Basic
Public Overridable Function Erase ( _
    item As CurtainGrid _
) As Integer
Visual C++
public:
virtual int Erase(
    CurtainGrid^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..CurtainGrid

See Also

CurtainGridSet Class


ReverseIterator Method

[image]

Revit 2024 API
CurtainGridSet..::..ReverseIterator Method
CurtainGridSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual CurtainGridSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As CurtainGridSetIterator
Visual C++
public:
virtual CurtainGridSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

CurtainGridSet Class


CurtainGridSet Properties

[image] [image]

Revit 2024 API
CurtainGridSet Properties
CurtainGridSet Class See Also Send Feedback

The CurtainGridSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

CurtainGridSet Class


IsEmpty Property

[image]

Revit 2024 API
CurtainGridSet..::..IsEmpty Property
CurtainGridSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

CurtainGridSet Class


Size Property

[image]

Revit 2024 API
CurtainGridSet..::..Size Property
CurtainGridSet Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

CurtainGridSet Class


CurtainGridSetIterator Class

[image]

Revit 2024 API
CurtainGridSetIterator Class
Members See Also Send Feedback
An iterator to a set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public abstract class CurtainGridSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class CurtainGridSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class CurtainGridSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..CurtainGridSetIterator

See Also

CurtainGridSetIterator Members


CurtainGridSetIterator Constructor

[image]

Revit 2024 API
CurtainGridSetIterator Constructor
CurtainGridSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CurtainGridSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
CurtainGridSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CurtainGridSetIterator Class


CurtainGridSetIterator Methods

[image] [image]

Revit 2024 API
CurtainGridSetIterator Methods
CurtainGridSetIterator Class See Also Send Feedback

The CurtainGridSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CurtainGridSetIterator Class


MoveNext Method

[image]

Revit 2024 API
CurtainGridSetIterator..::..MoveNext Method
CurtainGridSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

CurtainGridSetIterator Class


CurtainGridSetIterator Properties

[image] [image]

Revit 2024 API
CurtainGridSetIterator Properties
CurtainGridSetIterator Class See Also Send Feedback

The CurtainGridSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CurtainGridSetIterator Class


Current Property

[image]

Revit 2024 API
CurtainGridSetIterator..::..Current Property
CurtainGridSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

CurtainGridSetIterator Class


CurtainSystem Class

[image]

Revit 2024 API
CurtainSystem Class
Members See Also Send Feedback
Provides access to the CurtainSystem object in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class CurtainSystem : CurtainSystemBase
Visual Basic
Public Class CurtainSystem _
    Inherits CurtainSystemBase
Visual C++
public ref class CurtainSystem : public CurtainSystemBase

Remarks

The user can create CurtainSystem object and change the internal properties.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB..::..CurtainSystemBase
Autodesk.Revit.DB..::..CurtainSystem

See Also

CurtainSystem Members


CurtainSystem Members

[image] [image]

Revit 2024 API
CurtainSystem Members
CurtainSystem Class Methods Properties See Also Send Feedback

The CurtainSystem type exposes the following members.

Methods

 | Name | Description
Public method | AddCurtainGrid | Add CurtainGrid on the specified face for the CurtainSystem.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | RemoveCurtainGrid | Remove CurtainGrid from the specified face for the CurtainSystem.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurtainGrids | Get all the CurtainGrid object of this CurtainSystem. Each CurtainGrid corresponds to one face.
Public property | CurtainSystemType | get or set the type of the CurtainSystem.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

CurtainSystem Class


CurtainSystem Methods

[image] [image]

Revit 2024 API
CurtainSystem Methods
CurtainSystem Class See Also Send Feedback

The CurtainSystem type exposes the following members.

Methods

 | Name | Description
Public method | AddCurtainGrid | Add CurtainGrid on the specified face for the CurtainSystem.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | RemoveCurtainGrid | Remove CurtainGrid from the specified face for the CurtainSystem.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CurtainSystem Class


AddCurtainGrid Method

[image]

Revit 2024 API
CurtainSystem..::..AddCurtainGrid Method
CurtainSystem Class See Also Send Feedback
Add CurtainGrid on the specified face for the CurtainSystem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void AddCurtainGrid(
    Reference face
)
Visual Basic
Public Sub AddCurtainGrid ( _
    face As Reference _
)
Visual C++
public:
void AddCurtainGrid(
    Reference^ face
)

Parameters

face
Type: Autodesk.Revit.DB..::..Reference
The face new CurtainGrid will be created on.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument face is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when creating CurtainGrid on the specified face fails or regenerate fails.

See Also

CurtainSystem Class


CurtainSystem Properties

[image] [image]

Revit 2024 API
CurtainSystem Properties
CurtainSystem Class See Also Send Feedback

The CurtainSystem type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurtainGrids | Get all the CurtainGrid object of this CurtainSystem. Each CurtainGrid corresponds to one face.
Public property | CurtainSystemType | get or set the type of the CurtainSystem.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

CurtainSystem Class


CurtainGrids Property

[image]

Revit 2024 API
CurtainSystem..::..CurtainGrids Property
CurtainSystem Class See Also Send Feedback
Get all the CurtainGrid object of this CurtainSystem. Each CurtainGrid corresponds to one face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CurtainGridSet CurtainGrids { get; }
Visual Basic
Public ReadOnly Property CurtainGrids As CurtainGridSet
    Get
Visual C++
public:
property CurtainGridSet^ CurtainGrids {
    CurtainGridSet^ get ();
}

Return Value

A CurtainGrid set will be returned if the operation succeeds. nullNothingnullptra null reference (Nothing in Visual Basic) will be returned if the CurtainSystem doesn't include any CurtainGrid.

See Also

CurtainSystem Class


CurtainSystemType Property

[image]

Revit 2024 API
CurtainSystem..::..CurtainSystemType Property
CurtainSystem Class See Also Send Feedback
get or set the type of the CurtainSystem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CurtainSystemType CurtainSystemType { get; set; }
Visual Basic
Public Property CurtainSystemType As CurtainSystemType
    Get
    Set
Visual C++
public:
property CurtainSystemType^ CurtainSystemType {
    CurtainSystemType^ get ();
    void set (CurtainSystemType^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the specified parameter curtainSystemType is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the type of the CurtainSystem cannot be changed to the specified one.

See Also

CurtainSystem Class


Parameter Property

[image] [image]

Revit 2024 API
CurtainSystem..::..Parameter Property
CurtainSystem Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

CurtainSystem Class
CurtainSystem Members


CurtainSystemBase Methods

[image] [image]

Revit 2024 API
CurtainSystemBase Methods
CurtainSystemBase Class See Also Send Feedback

The CurtainSystemBase type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CurtainSystemBase Class


CurtainSystemBase Properties

[image] [image]

Revit 2024 API
CurtainSystemBase Properties
CurtainSystemBase Class See Also Send Feedback

The CurtainSystemBase type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

CurtainSystemBase Class


CurtainSystemType Class

[image]

Revit 2024 API
CurtainSystemType Class
Members See Also Send Feedback
An object that represents CurtainSystem type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class CurtainSystemType : HostObjAttributes
Visual Basic
Public Class CurtainSystemType _
    Inherits HostObjAttributes
Visual C++
public ref class CurtainSystemType : public HostObjAttributes

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..HostObjAttributes
Autodesk.Revit.DB..::..CurtainSystemType

See Also

CurtainSystemType Members


CurtainSystemType Members

[image] [image]

Revit 2024 API
CurtainSystemType Members
CurtainSystemType Class Methods Properties See Also Send Feedback

The CurtainSystemType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

CurtainSystemType Class


CurtainSystemType Methods

[image] [image]

Revit 2024 API
CurtainSystemType Methods
CurtainSystemType Class See Also Send Feedback

The CurtainSystemType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CurtainSystemType Class


CurtainSystemType Properties

[image] [image]

Revit 2024 API
CurtainSystemType Properties
CurtainSystemType Class See Also Send Feedback

The CurtainSystemType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

CurtainSystemType Class


Parameter Property

[image] [image]

Revit 2024 API
CurtainSystemType..::..Parameter Property
CurtainSystemType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

CurtainSystemType Class
CurtainSystemType Members


Curve Class

[image]

Revit 2024 API
Curve Class
Members See Also Send Feedback
A parametric curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class Curve : GeometryObject
Visual Basic
Public Class Curve _
    Inherits GeometryObject
Visual C++
public ref class Curve : public GeometryObject

Remarks

The concrete curves are defined by parametric equations. If the curve is bound, it is only defined for an interval in parameterization. Otherwise, it is defined for all values of the parameter.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeometryObject
Autodesk.Revit.DB..::..Curve
Autodesk.Revit.DB..::..Arc
Autodesk.Revit.DB..::..CylindricalHelix
Autodesk.Revit.DB..::..Ellipse
Autodesk.Revit.DB..::..HermiteSpline
Autodesk.Revit.DB..::..Line
Autodesk.Revit.DB..::..NurbSpline

See Also

Curve Members


Curve Members

[image] [image]

Revit 2024 API
Curve Members
Curve Class Methods Properties See Also Send Feedback

The Curve type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns a copy of this curve.
Public method | ComputeClosestPoints | Find the closest points between two curves. Closest points mean closest pairs of points, each pair consisting of a point on this, say P1, and a point on other curve, say P2. P1 and P2 are closest locally. Each pairs of closest points will be represented by the corresponding parameter values with respect to the two curves and the 3d points. A closest pair is also known as a pair of critical points of the distance function between points of the two curves. If the input parameter returnAllCriticalPoints is set to false, then the function will return only pairs with minimum distance.
Public method | ComputeDerivatives | Returns the vectors describing the curve at the specified parameter.
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter.
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter.
Public method | CreateOffset | Creates a new curve that is an offset of the existing curve.
Public method | CreateReversed | Creates a new curve with the opposite orientation of the existing curve.
Public method | CreateTransformed | Crates a new instance of a curve as a transformation of this curve.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Distance | Returns the shortest distance from the specified point to this curve.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates and returns the point that matches a parameter along the curve.
Public method | GetEndParameter | Returns the raw parameter value at the start or end of this curve.
Public method | GetEndPoint | Returns the 3D point at the start or end of this curve.
Public method | GetEndPointReference | Returns a stable reference to the start point or the end point of the curve.
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve.
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results.
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds.
Public method | IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index.
Public method | MakeBound | Changes the bounds of this curve to the specified values.
Public method | MakeUnbound | Makes this curve unbound.
Public method | Project | Projects the specified point on this curve.
Public method | SetGraphicsStyleId | Sets the graphics style id for this curve.
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ApproximateLength | The approximate length of the curve.
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject.)
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval.
Public property | IsClosed | Describes whether the curve is closed.
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic.
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Length | The exact length of the curve.
Public property | Period | The period of this curve.
Public property | Reference | Returns a stable reference to the curve.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Curve Class


Curve Methods

[image] [image]

Revit 2024 API
Curve Methods
Curve Class See Also Send Feedback

The Curve type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns a copy of this curve.
Public method | ComputeClosestPoints | Find the closest points between two curves. Closest points mean closest pairs of points, each pair consisting of a point on this, say P1, and a point on other curve, say P2. P1 and P2 are closest locally. Each pairs of closest points will be represented by the corresponding parameter values with respect to the two curves and the 3d points. A closest pair is also known as a pair of critical points of the distance function between points of the two curves. If the input parameter returnAllCriticalPoints is set to false, then the function will return only pairs with minimum distance.
Public method | ComputeDerivatives | Returns the vectors describing the curve at the specified parameter.
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter.
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter.
Public method | CreateOffset | Creates a new curve that is an offset of the existing curve.
Public method | CreateReversed | Creates a new curve with the opposite orientation of the existing curve.
Public method | CreateTransformed | Crates a new instance of a curve as a transformation of this curve.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Distance | Returns the shortest distance from the specified point to this curve.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates and returns the point that matches a parameter along the curve.
Public method | GetEndParameter | Returns the raw parameter value at the start or end of this curve.
Public method | GetEndPoint | Returns the 3D point at the start or end of this curve.
Public method | GetEndPointReference | Returns a stable reference to the start point or the end point of the curve.
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve.
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results.
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds.
Public method | IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index.
Public method | MakeBound | Changes the bounds of this curve to the specified values.
Public method | MakeUnbound | Makes this curve unbound.
Public method | Project | Projects the specified point on this curve.
Public method | SetGraphicsStyleId | Sets the graphics style id for this curve.
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Curve Class


Clone Method

[image]

Revit 2024 API
Curve..::..Clone Method
Curve Class See Also Send Feedback
Returns a copy of this curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Curve Clone()
Visual Basic
Public Function Clone As Curve
Visual C++
public:
Curve^ Clone()

Return Value

A copy of this curve.

See Also

Curve Class


ComputeClosestPoints Method

[image]

Revit 2024 API
Curve..::..ComputeClosestPoints Method
Curve Class See Also Send Feedback
Find the closest points between two curves. Closest points mean closest pairs of points, each pair consisting of a point on this, say P1, and a point on other curve, say P2. P1 and P2 are closest locally. Each pairs of closest points will be represented by the corresponding parameter values with respect to the two curves and the 3d points. A closest pair is also known as a pair of critical points of the distance function between points of the two curves. If the input parameter returnAllCriticalPoints is set to false, then the function will return only pairs with minimum distance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018.1

Syntax

C#
public void ComputeClosestPoints(
    Curve otherCurve,
    bool withinThisCurveBounds,
    bool withinOtherCurveBounds,
    bool returnAllCriticalPnts,
    out IList<ClosestPointsPairBetweenTwoCurves> resultList
)
Visual Basic
Public Sub ComputeClosestPoints ( _
    otherCurve As Curve, _
    withinThisCurveBounds As Boolean, _
    withinOtherCurveBounds As Boolean, _
    returnAllCriticalPnts As Boolean, _
    <OutAttribute> ByRef resultList As IList(Of ClosestPointsPairBetweenTwoCurves) _
)
Visual C++
public:
void ComputeClosestPoints(
    Curve^ otherCurve,
    bool withinThisCurveBounds,
    bool withinOtherCurveBounds,
    bool returnAllCriticalPnts,
    [OutAttribute] IList<ClosestPointsPairBetweenTwoCurves^>^% resultList
)

Parameters

otherCurve
Type: Autodesk.Revit.DB..::..Curve
The specified curve used to compute closest points to this curve.
withinThisCurveBounds
Type: System..::..Boolean
If this parameter is true only the solutions that are between this curve bounds will be returned. This curve must be bound if this parameter is true.
withinOtherCurveBounds
Type: System..::..Boolean
If this parameter is true only the solutions that are between other curve bounds will be returned. The other curve must be bound if this parameter is true.
returnAllCriticalPnts
Type: System..::..Boolean
The input parameter returnAllCriticalPnts is used to tell if all the critical points of the distance function are to be returned.
resultList
Type: System.Collections.Generic..::..IList<(Of <(<' ClosestPointsPairBetweenTwoCurves >)>)>%
Output parameter that will contain the results collection.

Remarks

The output list of closest points contains one entry for each pair of closest points. The following is the meaning of every ClosestPointsPairBetweenTwoCurves's members:
  • XYZPointOnFirstCurve is the closest point on the first curve;
  • XYZPointOnSecondCurve is the closest point on the second curve;
  • ParameterOnFirstCurve is the raw (not normalized) parameter on the first curve
  • ParameterOnSecondCurve is the raw (not normalized) parameter on the second curve
  • Distance is the distance from the closest point on the first curve to the closest point on the second curve.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when otherCurve argument is null. Thrown when resultArray is null.
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | Thrown when withinThisCurveBounds is true and this curve is unbounded. Thrown when withinOtherCurveBounds is true and other curve is unbounded.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the method failed. For example the problem has infinitely many solutions such as two parallel lines or two concentric circles, or in other singular cases that the method currently cannot handle, such as evaluating the closest points between a spline and a line, and the spline contains a flat segment (all points on the segment have zero curvature), and the closest points lie within that flat segment.

See Also

Curve Class


ComputeDerivatives Method

[image]

Revit 2024 API
Curve..::..ComputeDerivatives Method
Curve Class See Also Send Feedback
Returns the vectors describing the curve at the specified parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Transform ComputeDerivatives(
    double parameter,
    bool normalized
)
Visual Basic
Public Function ComputeDerivatives ( _
    parameter As Double, _
    normalized As Boolean _
) As Transform
Visual C++
public:
Transform^ ComputeDerivatives(
    double parameter,
    bool normalized
)

Parameters

parameter
Type: System..::..Double
The parameter to be evaluated.
normalized
Type: System..::..Boolean
If false, param is interpreted as natural parameterization of the curve. If true, param is expected to be in [0,1] interval mapped to the bounds of the curve. Setting to true is valid only if the curve is bound.

Return Value

The transformation containing the point on the curve, the tangent vector, derivative of tangent vector, and bi-normal vector.

Remarks

The following is the meaning of the transformation members: Origin is the point on the curve (equivalent to Evaluate(Double, Boolean)).BasisX is the tangent vector (the first derivative).BasisY is the second derivative. Note that for curves where this cannot be uniquely determined (e.g. lines), this will be a Zero vector.BasisZ is the bi-normal vector (tangent x normal). Note that for curves where normal cannot be uniquely determined (e.g. lines), this will be a Zero vector. None of the vectors are normalized.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for parameter is not finite
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The curve cannot be evaluated as normalized because it is unbound. -or- The parameter is not a valid value for normalized evaluation.

See Also

Curve Class


ComputeRawParameter Method

[image]

Revit 2024 API
Curve..::..ComputeRawParameter Method
Curve Class See Also Send Feedback
Computes the raw parameter from the normalized parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double ComputeRawParameter(
    double normalizedParameter
)
Visual Basic
Public Function ComputeRawParameter ( _
    normalizedParameter As Double _
) As Double
Visual C++
public:
double ComputeRawParameter(
    double normalizedParameter
)

Parameters

normalizedParameter
Type: System..::..Double
The normalized parameter.

Return Value

The real number equal to the raw curve parameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when normalizedParameter is infinite.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the curve is unbound.

See Also

Curve Class


CreateOffset Method

[image]

Revit 2024 API
Curve..::..CreateOffset Method
Curve Class See Also Send Feedback
Creates a new curve that is an offset of the existing curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public Curve CreateOffset(
    double offsetDist,
    XYZ referenceVector
)
Visual Basic
Public Function CreateOffset ( _
    offsetDist As Double, _
    referenceVector As XYZ _
) As Curve
Visual C++
public:
Curve^ CreateOffset(
    double offsetDist,
    XYZ^ referenceVector
)

Parameters

offsetDist
Type: System..::..Double
The signed distance that controls the offset.
referenceVector
Type: Autodesk.Revit.DB..::..XYZ
A reference vector to define the offset direction.

Return Value

The new curve.

Remarks

The offset curve is obtained by moving the points of the given curve by a certain distance (not necessarily the input distance) to the right relative to the reference vector. If the distance is negative, then the offset will be actually on the left side. The precise role played by the reference vector depends on the curve type in an inconsistent way, as specified in detail below. We plan to update this function to have a more consistent and understandable behavior.

For Line, HermiteSpline, NurbSpline and Cylindrical Helix, the right direction is along the cross product of the tangent at that point and the reference vector. In other words, the "right" side of the curve at a given point on the curve is defined with the reference vector being thought of as the upward direction and curve tangent being thought of as the forward direction, as if you are walking along the curve with your body aligned to the reference vector.

For Arc and Ellipse, the right direction is defined relative to the axis of the arc or ellipse in conjunction with the reference vector. If the dot product of the reference vector with the axis is positive, then the right direction is along the cross product of the curve tangent the axis. If the dot product is negetive, then it is in the other way. If the dot product is zero, then it is an input error.

More details of the behavior depending on the type of curve: Line: For a Line, a vecPerp is computed as the cross product of the line direction and the reference vector. The offset is obtained by moving the line by the given distance along the direction of the vecPerp. Note: vecPerp can be zero vector if the reference vector is parallel to the line direction. In that case, the offset is simply a copy of the given line. No error is reported. Arc: For an Arc, the offset is done in the plane of the arc. The resulting offset is another arc in the same plane as the given arc and with the same center. The radius is increased or decreased by the offset distance depending on the offset is to the right or left. The reference vector is used to determine if the offset is to be done to the right or left of the arc, based on the dot product of the reference vector with the axis (normal vector) of the arc. If the dot product is positive then the offset is to the right relative to the axis of the arc; if not, it is to the left. If the dot product is zero, that is, reference vector is perpendicular to the axis, the function will return NULL and report an error. Ellipse: An Ellipse is also a planar curve like the Arc. The offset is done in the plane of the ellipse. Note that the offset of an ellipse is not an ellipse in general. It will be approximated by a Hermite spline curve. The offset curve is obtained by offsetting the points of the ellipse, by the given offset distance, to the right or left relative to the axis (normal vector) of the ellipse. The reference vector is used to determine if the offset is to be done to the right or left of the ellipse, based on the dot product of the reference vector with the axis of the ellipse. If the dot product is positive then the offset is to the right relative to the axis of the ellipse; if not, it is to the left. If the dot product is zero, that is, reference vector is perpendicular to the axis, the function will return NULL and report an error. HermiteSpline, NurbSpline and Cylindrical Helix: A Hermite or Nurbs spline curve can be planar or non-planar; a cylindrical helix is non-planar. For these three types of curves, the offset is computed in a general way as follows: Let P be a point on the given curve and let T be the unit tangent vector at P, assuming that the derivative of the curve at P is not zero. The offset vector at P is the cross product of T and the reference vector. Then the offset point Q corresponding to P is computed as: Q = P + (offset distance) * (offset vector at P). The offset depends on the magnitude as well as the direction of the reference vector. If the magnitude of the reference vector is not one, then the actual distance moved will not be the given offset distance. NOTE: If the curve is a planar Hermite or Nurbs spline curve, the offset curve may not lie on the same plane – unlike the case of arc and ellipse.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Cannot create the offset of the curve.

See Also

Curve Class


CreateReversed Method

[image]

Revit 2024 API
Curve..::..CreateReversed Method
Curve Class See Also Send Feedback
Creates a new curve with the opposite orientation of the existing curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public Curve CreateReversed()
Visual Basic
Public Function CreateReversed As Curve
Visual C++
public:
Curve^ CreateReversed()

Return Value

The new curve.

See Also

Curve Class


CreateTransformed Method

[image]

Revit 2024 API
Curve..::..CreateTransformed Method
Curve Class See Also Send Feedback
Crates a new instance of a curve as a transformation of this curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public Curve CreateTransformed(
    Transform transform
)
Visual Basic
Public Function CreateTransformed ( _
    transform As Transform _
) As Curve
Visual C++
public:
Curve^ CreateTransformed(
    Transform^ transform
)

Parameters

transform
Type: Autodesk.Revit.DB..::..Transform
The transform to apply.

Return Value

The new curve.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | transform is not conformal.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Curve Class


Distance Method

[image]

Revit 2024 API
Curve..::..Distance Method
Curve Class See Also Send Feedback
Returns the shortest distance from the specified point to this curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double Distance(
    XYZ point
)
Visual Basic
Public Function Distance ( _
    point As XYZ _
) As Double
Visual C++
public:
double Distance(
    XYZ^ point
)

Parameters

point
Type: Autodesk.Revit.DB..::..XYZ
The specified point.

Return Value

The real number equal to the shortest distance.

Remarks

Returns the distance from the closest point on the curve to the specified point.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when failed to find the closest point on the curve.

See Also

Curve Class


Evaluate Method

[image]

Revit 2024 API
Curve..::..Evaluate Method
Curve Class See Also Send Feedback
Evaluates and returns the point that matches a parameter along the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ Evaluate(
    double parameter,
    bool normalized
)
Visual Basic
Public Function Evaluate ( _
    parameter As Double, _
    normalized As Boolean _
) As XYZ
Visual C++
public:
XYZ^ Evaluate(
    double parameter,
    bool normalized
)

Parameters

parameter
Type: System..::..Double
The parameter to be evaluated.
normalized
Type: System..::..Boolean
If false, param is interpreted as natural parameterization of the curve. If true, param is expected to be in [0,1] interval mapped to the bounds of the curve. Setting to true is valid only if the curve is bound.

Return Value

The point evaluated along the curve.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for parameter is not finite
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The curve cannot be evaluated as normalized because it is unbound. -or- The parameter is not a valid value for normalized evaluation.

See Also

Curve Class


GetEndParameter Method

[image]

Revit 2024 API
Curve..::..GetEndParameter Method
Curve Class See Also Send Feedback
Returns the raw parameter value at the start or end of this curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public double GetEndParameter(
    int index
)
Visual Basic
Public Function GetEndParameter ( _
    index As Integer _
) As Double
Visual C++
public:
double GetEndParameter(
    int index
)

Parameters

index
Type: System..::..Int32
0 for the start or 1 for end of the curve.

Return Value

The parameter.

Remarks

The start and end value of the parameter can be any value (as it is determined by the system based on the inputs). For curves with regular curvature like lines and arcs, the raw parameter can be used to measure along the curve in Revit's default units (feet). Raw parameters are also the only way to evaluate points along unbound curves.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | curve is unbound and does not have start and end points. -or- index must be 0 for the start of the curve or 1 for the end.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Curve Class


GetEndPoint Method

[image]

Revit 2024 API
Curve..::..GetEndPoint Method
Curve Class See Also Send Feedback
Returns the 3D point at the start or end of this curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public XYZ GetEndPoint(
    int index
)
Visual Basic
Public Function GetEndPoint ( _
    index As Integer _
) As XYZ
Visual C++
public:
XYZ^ GetEndPoint(
    int index
)

Parameters

index
Type: System..::..Int32
0 for the start or 1 for end of the curve.

Return Value

The curve endpoint.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | curve is unbound and does not have start and end points. -or- index must be 0 for the start of the curve or 1 for the end.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Curve Class


GetEndPointReference Method

[image]

Revit 2024 API
Curve..::..GetEndPointReference Method
Curve Class See Also Send Feedback
Returns a stable reference to the start point or the end point of the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public Reference GetEndPointReference(
    int index
)
Visual Basic
Public Function GetEndPointReference ( _
    index As Integer _
) As Reference
Visual C++
public:
Reference^ GetEndPointReference(
    int index
)

Parameters

index
Type: System..::..Int32
Use 0 for the start point; 1 for the end point.

Return Value

Reference to the point or nullNothingnullptra null reference (Nothing in Visual Basic) if reference cannot be obtained.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the specified index is not 0 or 1.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the object is internally marked as read-only or this curve is unbound.

See Also

Curve Class


Intersect Method

[image] [image]

Revit 2024 API
Curve..::..Intersect Method
Curve Class See Also Send Feedback
Calculates the intersection of this curve with the specified curve.

Overload List

 | Name | Description
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve.
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results.

See Also

Curve Class
Curve Members


Intersect Method (Curve)

[image]

Revit 2024 API
Curve..::..Intersect Method (Curve)
Curve Class See Also Send Feedback
Calculates the intersection of this curve with the specified curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public SetComparisonResult Intersect(
    Curve curve
)
Visual Basic
Public Function Intersect ( _
    curve As Curve _
) As SetComparisonResult
Visual C++
public:
SetComparisonResult Intersect(
    Curve^ curve
)

Parameters

curve
Type: Autodesk.Revit.DB..::..Curve
The specified curve to intersect with this curve.

Return Value

  • SetComparisonResult.Overlap - One or more intersections were encountered.
  • SetComparisonResult.Subset - The inputs are parallel lines with only one common intersection point, or the curve used to invoke the intersection check is a line entirely within the unbound line passed as argument curve.
  • SetComparisonResult.Superset - The input curve is entirely within the unbound line used to invoke the intersection check.
  • SetComparisonResult.Disjoint - There is no intersection found between the two curves.
  • SetComparisonResult.Equal - The two curves are identical.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | The specified curve is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Failed to calculate the intersection.

See Also

Curve Class
Intersect Overload


Intersect Method (Curve, IntersectionResultArray)

[image]

Revit 2024 API
Curve..::..Intersect Method (Curve, IntersectionResultArray%)
Curve Class See Also Send Feedback
Calculates the intersection of this curve with the specified curve and returns the intersection results.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public SetComparisonResult Intersect(
    Curve curve,
    out IntersectionResultArray resultArray
)
Visual Basic
Public Function Intersect ( _
    curve As Curve, _
    <OutAttribute> ByRef resultArray As IntersectionResultArray _
) As SetComparisonResult
Visual C++
public:
SetComparisonResult Intersect(
    Curve^ curve,
    [OutAttribute] IntersectionResultArray^% resultArray
)

Parameters

curve
Type: Autodesk.Revit.DB..::..Curve
The specified curve to intersect with this curve.
resultArray
Type: Autodesk.Revit.DB..::..IntersectionResultArray %
Provides more information about the intersection.

Return Value

  • SetComparisonResult.Overlap - One or more intersections were encountered. The output argument has the details.
  • SetComparisonResult.Subset - The inputs are parallel lines with only one common intersection point, or the curve used to invoke the intersection check is a line entirely within the unbound line passed as argument curve. If the former, the output argument has the details of the intersection point.
  • SetComparisonResult.Superset - The input curve is entirely within the unbound line used to invoke the intersection check.
  • SetComparisonResult.Disjoint - There is no intersection found between the two curves.
  • SetComparisonResult.Equal - The two curves are identical.

Remarks

The array of the intersection results contains one entry for each point where curves intersect. The following is the meaning of IntersectionResult members:
  • XYZPoint is the evaluated intersection point
  • UVPoint.U is the unnormalized parameter on this curve (use ComputeNormalizedParameter to compute the normalized value).
  • UVPoint.V is the unnormalized parameter on the specified curve (use ComputeNormalizedParameter to compute the normalized value).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the specified curve is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when failed to calculate the intersection.

See Also

Curve Class
Intersect Overload


IsInside Method

[image] [image]

Revit 2024 API
Curve..::..IsInside Method
Curve Class See Also Send Feedback
Indicates whether the specified parameter value is within this curve's bounds.

Overload List

 | Name | Description
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds.
Public method | IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index.

See Also

Curve Class
Curve Members


IsInside Method (Double)

[image]

Revit 2024 API
Curve..::..IsInside Method (Double)
Curve Class See Also Send Feedback
Indicates whether the specified parameter value is within this curve's bounds.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsInside(
    double parameter
)
Visual Basic
Public Function IsInside ( _
    parameter As Double _
) As Boolean
Visual C++
public:
bool IsInside(
    double parameter
)

Parameters

parameter
Type: System..::..Double
The raw curve parameter to be evaluated.

Return Value

True if the parameter is within the bounds, otherwise false.

Remarks

Always returns true if this curve is unbound.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the specified parameter is infinite.

See Also

Curve Class
IsInside Overload


IsInside Method (Double, Int32)

[image]

Revit 2024 API
Curve..::..IsInside Method (Double, Int32%)
Curve Class See Also Send Feedback
Indicates whether the specified parameter value is within this curve's bounds and outputs the end index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsInside(
    double parameter,
    out int end
)
Visual Basic
Public Function IsInside ( _
    parameter As Double, _
    <OutAttribute> ByRef end As Integer _
) As Boolean
Visual C++
public:
bool IsInside(
    double parameter,
    [OutAttribute] int% end
)

Parameters

parameter
Type: System..::..Double
The raw curve parameter to be evaluated.
end
Type: System..::..Int32%
The end index is equal to 0 for the start point, 1 for the end point, or -1 if the parameter is not at the end.

Return Value

True if the parameter is within the curve's bounds, otherwise false.

Remarks

Always returns true if this curve is unbound.

See Also

Curve Class
IsInside Overload


MakeUnbound Method

[image]

Revit 2024 API
Curve..::..MakeUnbound Method
Curve Class See Also Send Feedback
Makes this curve unbound.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void MakeUnbound()
Visual Basic
Public Sub MakeUnbound
Visual C++
public:
void MakeUnbound()

Remarks

If the curve is marked as read-only (because it was extracted directly from a Revit element or collection/aggregation object), calling this method causes the object to be changed to carry a disconnected copy of the original curve. The modification will not affect the original curve or the object that supplied it.

See Also

Curve Class


Project Method

[image]

Revit 2024 API
Curve..::..Project Method
Curve Class See Also Send Feedback
Projects the specified point on this curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public IntersectionResult Project(
    XYZ point
)
Visual Basic
Public Function Project ( _
    point As XYZ _
) As IntersectionResult
Visual C++
public:
IntersectionResult^ Project(
    XYZ^ point
)

Parameters

point
Type: Autodesk.Revit.DB..::..XYZ
The point to be projected.

Return Value

Geometric information if projection is successful.

Remarks

The following is the meaning of every IntersectionResult's members:
  • XYZPoint is the nearest point on the curve;
  • Parameter is the unnormalized parameter on the curve (use ComputeNormalizedParameter to compute the normalized value)
  • Distance is the distance from the point to the curve (equivalent to Distance).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the curve is an arc and either its radius is zero or the input point is the center of the arc. Thrown when the curve is an elliptical arc and the input point is one of the foci of the elliptical arc.

See Also

Curve Class


SetGraphicsStyleId Method

[image]

Revit 2024 API
Curve..::..SetGraphicsStyleId Method
Curve Class See Also Send Feedback
Sets the graphics style id for this curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetGraphicsStyleId(
    ElementId id
)
Visual Basic
Public Sub SetGraphicsStyleId ( _
    id As ElementId _
)
Visual C++
public:
void SetGraphicsStyleId(
    ElementId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::..ElementId
The id of the GraphicsStyle element from which to apply the curve properties.

Remarks

If the curve is marked as read-only (because it was extracted directly from a Revit element or collection/aggregation object), calling this method causes the object to be changed to carry a disconnected copy of the original curve. The modification will not affect the original curve or the object that supplied it.

Many methods in the Revit API will not use the graphics style associated to this curve. For example, curves used as portions of the sketch of an element will not read this property. Newly created curve elements will not use this value either, as they inherit their graphical properties from their associated category.

See Also

Curve Class


Curve Properties

[image] [image]

Revit 2024 API
Curve Properties
Curve Class See Also Send Feedback

The Curve type exposes the following members.

Properties

 | Name | Description
Public property | ApproximateLength | The approximate length of the curve.
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject.)
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval.
Public property | IsClosed | Describes whether the curve is closed.
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic.
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Length | The exact length of the curve.
Public property | Period | The period of this curve.
Public property | Reference | Returns a stable reference to the curve.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Curve Class


ApproximateLength Property

[image]

Revit 2024 API
Curve..::..ApproximateLength Property
Curve Class See Also Send Feedback
The approximate length of the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double ApproximateLength { get; }
Visual Basic
Public ReadOnly Property ApproximateLength As Double
    Get
Visual C++
public:
property double ApproximateLength {
    double get ();
}

Remarks

Quickly estimates the length of the curve, may deviate by a factor of 2 in some cases. The computation is exact for lines and arcs.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the curve is unbound and not periodic.

See Also

Curve Class


IsClosed Property

[image]

Revit 2024 API
Curve..::..IsClosed Property
Curve Class See Also Send Feedback
Describes whether the curve is closed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public bool IsClosed { get; }
Visual Basic
Public ReadOnly Property IsClosed As Boolean
    Get
Visual C++
public:
property bool IsClosed {
    bool get ();
}

Remarks

A curve is "closed" if it is bounded and its start and end points coincide (to within Revit's 3D tolerance), or if it is unbounded and periodic.

See Also

Curve Class


IsCyclic Property

[image]

Revit 2024 API
Curve..::..IsCyclic Property
Curve Class See Also Send Feedback
The boolean value that indicates whether this curve is cyclic.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsCyclic { get; }
Visual Basic
Public ReadOnly Property IsCyclic As Boolean
    Get
Visual C++
public:
property bool IsCyclic {
    bool get ();
}

Return Value

True if this curve is cyclic; otherwise, false.

See Also

Curve Class


Length Property

[image]

Revit 2024 API
Curve..::..Length Property
Curve Class See Also Send Feedback
The exact length of the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double Length { get; }
Visual Basic
Public ReadOnly Property Length As Double
    Get
Visual C++
public:
property double Length {
    double get ();
}

Remarks

Computes the length of the curve using analytical or numeric integration. There is no performance hit for lines and arcs.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the curve is unbound and not periodic.

See Also

Curve Class


Period Property

[image]

Revit 2024 API
Curve..::..Period Property
Curve Class See Also Send Feedback
The period of this curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double Period { get; }
Visual Basic
Public ReadOnly Property Period As Double
    Get
Visual C++
public:
property double Period {
    double get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the curve is not cyclic.

See Also

Curve Class


CurveArrArray Class

[image]

Revit 2024 API
CurveArrArray Class
Members See Also Send Feedback
An array that can contain any type of object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class CurveArrArray : APIObject,
    IEnumerable
Visual Basic
Public Class CurveArrArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class CurveArrArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..CurveArrArray

See Also

CurveArrArray Members


CurveArrArray Constructor

[image]

Revit 2024 API
CurveArrArray Constructor
CurveArrArray Class See Also Send Feedback
Initializes a new instance of the CurveArrArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CurveArrArray()
Visual Basic
Public Sub New
Visual C++
public:
CurveArrArray()

See Also

CurveArrArray Class


CurveArrArray Methods

[image] [image]

Revit 2024 API
CurveArrArray Methods
CurveArrArray Class See Also Send Feedback

The CurveArrArray type exposes the following members.

Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CurveArrArray Class


GetEnumerator Method

[image]

Revit 2024 API
CurveArrArray..::..GetEnumerator Method
CurveArrArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

CurveArrArray Class


Insert Method

[image]

Revit 2024 API
CurveArrArray..::..Insert Method
CurveArrArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Insert(
    CurveArray item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As CurveArray, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    CurveArray^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::..CurveArray
index
Type: System..::..Int32

See Also

CurveArrArray Class


ReverseIterator Method

[image]

Revit 2024 API
CurveArrArray..::..ReverseIterator Method
CurveArrArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual CurveArrArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As CurveArrArrayIterator
Visual C++
public:
virtual CurveArrArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

CurveArrArray Class


IsEmpty Property

[image]

Revit 2024 API
CurveArrArray..::..IsEmpty Property
CurveArrArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

CurveArrArray Class


Item Property

[image]

Revit 2024 API
CurveArrArray..::..Item Property
CurveArrArray Class See Also Send Feedback
Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual CurveArray this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As CurveArray
    Get
    Set
Visual C++
public:
virtual property CurveArray^ Item[int index] {
    CurveArray^ get (int index);
    void set (int index, CurveArray^ value);
}

Parameters

index
Type: System..::..Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

CurveArrArray Class


Size Property

[image]

Revit 2024 API
CurveArrArray..::..Size Property
CurveArrArray Class See Also Send Feedback
Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

CurveArrArray Class


CurveArrArrayIterator Constructor

[image]

Revit 2024 API
CurveArrArrayIterator Constructor
CurveArrArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CurveArrArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
CurveArrArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CurveArrArrayIterator Class


CurveArrArrayIterator Methods

[image] [image]

Revit 2024 API
CurveArrArrayIterator Methods
CurveArrArrayIterator Class See Also Send Feedback

The CurveArrArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CurveArrArrayIterator Class


MoveNext Method

[image]

Revit 2024 API
CurveArrArrayIterator..::..MoveNext Method
CurveArrArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

CurveArrArrayIterator Class


Reset Method

[image]

Revit 2024 API
CurveArrArrayIterator..::..Reset Method
CurveArrArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

CurveArrArrayIterator Class


CurveArrArrayIterator Properties

[image] [image]

Revit 2024 API
CurveArrArrayIterator Properties
CurveArrArrayIterator Class See Also Send Feedback

The CurveArrArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CurveArrArrayIterator Class


Current Property

[image]

Revit 2024 API
CurveArrArrayIterator..::..Current Property
CurveArrArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

CurveArrArrayIterator Class


CurveArray Class

[image]

Revit 2024 API
CurveArray Class
Members See Also Send Feedback
An array that can contain curves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class CurveArray : APIObject, IEnumerable
Visual Basic
Public Class CurveArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class CurveArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..CurveArray

See Also

CurveArray Members


CurveArray Members

[image] [image]

Revit 2024 API
CurveArray Members
CurveArray Class Constructors Methods Properties See Also Send Feedback

The CurveArray type exposes the following members.

Constructors

 | Name | Description
Public method | CurveArray | Initializes a new instance of the CurveArray class

Methods

 | Name | Description
Public method | Append | Add the curve to the end of the array.
Public method | Clear | Removes every curve from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified curve into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a curve at a specified index within the array.
Public property | Size | Returns the number of curves that are in the array.

See Also

CurveArray Class


CurveArray Constructor

[image]

Revit 2024 API
CurveArray Constructor
CurveArray Class See Also Send Feedback
Initializes a new instance of the CurveArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CurveArray()
Visual Basic
Public Sub New
Visual C++
public:
CurveArray()

See Also

CurveArray Class


Append Method

[image]

Revit 2024 API
CurveArray..::..Append Method
CurveArray Class See Also Send Feedback
Add the curve to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Append(
    Curve item
)
Visual Basic
Public Overridable Sub Append ( _
    item As Curve _
)
Visual C++
public:
virtual void Append(
    Curve^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..Curve
The curve to be added.

See Also

CurveArray Class


ForwardIterator Method

[image]

Revit 2024 API
CurveArray..::..ForwardIterator Method
CurveArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual CurveArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As CurveArrayIterator
Visual C++
public:
virtual CurveArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

CurveArray Class


Insert Method

[image]

Revit 2024 API
CurveArray..::..Insert Method
CurveArray Class See Also Send Feedback
Insert the specified curve into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Insert(
    Curve item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As Curve, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    Curve^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::..Curve
The curve to be inserted into the array.
index
Type: System..::..Int32
The curve will be inserted before this index.

Return Value

Returns whether the curve was inserted into the array.

See Also

CurveArray Class


CurveArray Properties

[image] [image]

Revit 2024 API
CurveArray Properties
CurveArray Class See Also Send Feedback

The CurveArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a curve at a specified index within the array.
Public property | Size | Returns the number of curves that are in the array.

See Also

CurveArray Class


IsEmpty Property

[image]

Revit 2024 API
CurveArray..::..IsEmpty Property
CurveArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

CurveArray Class


Item Property

[image]

Revit 2024 API
CurveArray..::..Item Property
CurveArray Class See Also Send Feedback
Gets or sets a curve at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Curve this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As Curve
    Get
    Set
Visual C++
public:
virtual property Curve^ Item[int index] {
    Curve^ get (int index);
    void set (int index, Curve^ value);
}

Parameters

index
Type: System..::..Int32
The index of the curve to be set or retrieved.

Return Value

Returns the curve at the specified index.

See Also

CurveArray Class


Size Property

[image]

Revit 2024 API
CurveArray..::..Size Property
CurveArray Class See Also Send Feedback
Returns the number of curves that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

CurveArray Class


CurveArrayIterator Constructor

[image]

Revit 2024 API
CurveArrayIterator Constructor
CurveArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CurveArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
CurveArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CurveArrayIterator Class


CurveArrayIterator Methods

[image] [image]

Revit 2024 API
CurveArrayIterator Methods
CurveArrayIterator Class See Also Send Feedback

The CurveArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CurveArrayIterator Class


MoveNext Method

[image]

Revit 2024 API
CurveArrayIterator..::..MoveNext Method
CurveArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

CurveArrayIterator Class


Reset Method

[image]

Revit 2024 API
CurveArrayIterator..::..Reset Method
CurveArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

CurveArrayIterator Class


CurveArrayIterator Properties

[image] [image]

Revit 2024 API
CurveArrayIterator Properties
CurveArrayIterator Class See Also Send Feedback

The CurveArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CurveArrayIterator Class


Current Property

[image]

Revit 2024 API
CurveArrayIterator..::..Current Property
CurveArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

CurveArrayIterator Class


CurveByPoints Class

[image]

Revit 2024 API
CurveByPoints Class
Members See Also Send Feedback
A curve interpolating two or more points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class CurveByPoints : CurveElement
Visual Basic
Public Class CurveByPoints _
    Inherits CurveElement
Visual C++
public ref class CurveByPoints : public CurveElement

Remarks

The points to be interpolated are represented as ReferencePoints, which must already exist in the document. In terms of appearance and graphics control, CurveByPoints behaves similarly to ModelCurve. The main difference being that a ModelCurve refers to a SketchPlane, while a CurveByPoints does not. For more methods capable of accessing data from CurveByPoints elements, see the static class CurveByPointsUtils.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..CurveElement
Autodesk.Revit.DB..::..CurveByPoints

See Also

CurveByPoints Members


CurveByPoints Members

[image] [image]

Revit 2024 API
CurveByPoints Members
CurveByPoints Class Methods Properties See Also Send Feedback

The CurveByPoints type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point. (Inherited from CurveElement.)
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable. (Inherited from CurveElement.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element. (Inherited from CurveElement.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPoints | Get the sequence of points interpolated by this curve.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point. (Inherited from CurveElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point. (Inherited from CurveElement.)
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point. (Inherited from CurveElement.)
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end. (Inherited from CurveElement.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry. (Inherited from CurveElement.)
Public method | SetPoints | Change the sequence of points interpolated by this curve.
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement. (Inherited from CurveElement.)
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point. (Inherited from CurveElement.)
Public method | SetVisibility | Sets the visibility.
 | SortPoints | Order a set of ReferencePoints in the same way Revit does when creating a curve from points.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveElementType | Type of the curve element. (Inherited from CurveElement.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsReferenceLine |
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ReferenceType | Indicates the type of reference.
Public property | SketchPlane | Override the SketchPlane property of CurveElement. (Overrides CurveElement..::..SketchPlane.)
Public property | Subcategory | The subcategory, or graphics style, of the CurveByPoints.
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element. (Inherited from CurveElement.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Visible | Whether the point is visible when the family is loaded into a project.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

CurveByPoints Class


CurveByPoints Methods

[image] [image]

Revit 2024 API
CurveByPoints Methods
CurveByPoints Class See Also Send Feedback

The CurveByPoints type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point. (Inherited from CurveElement.)
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable. (Inherited from CurveElement.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element. (Inherited from CurveElement.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPoints | Get the sequence of points interpolated by this curve.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point. (Inherited from CurveElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point. (Inherited from CurveElement.)
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point. (Inherited from CurveElement.)
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end. (Inherited from CurveElement.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry. (Inherited from CurveElement.)
Public method | SetPoints | Change the sequence of points interpolated by this curve.
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement. (Inherited from CurveElement.)
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point. (Inherited from CurveElement.)
Public method | SetVisibility | Sets the visibility.
 | SortPoints | Order a set of ReferencePoints in the same way Revit does when creating a curve from points.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CurveByPoints Class


GetPoints Method

[image]

Revit 2024 API
CurveByPoints..::..GetPoints Method
CurveByPoints Class See Also Send Feedback
Get the sequence of points interpolated by this curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ReferencePointArray GetPoints()
Visual Basic
Public Function GetPoints As ReferencePointArray
Visual C++
public:
ReferencePointArray^ GetPoints()

See Also

CurveByPoints Class


SetPoints Method

[image]

Revit 2024 API
CurveByPoints..::..SetPoints Method
CurveByPoints Class See Also Send Feedback
Change the sequence of points interpolated by this curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetPoints(
    ReferencePointArray points
)
Visual Basic
Public Sub SetPoints ( _
    points As ReferencePointArray _
)
Visual C++
public:
void SetPoints(
    ReferencePointArray^ points
)

Parameters

points
Type: Autodesk.Revit.DB..::..ReferencePointArray
An array of 2 or more ReferencePoints.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the array contains fewer than 2 points, when the array contains duplicates, or when adjacent points are located too close together.

See Also

CurveByPoints Class


SetVisibility Method

[image]

Revit 2024 API
CurveByPoints..::..SetVisibility Method
CurveByPoints Class See Also Send Feedback
Sets the visibility.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetVisibility(
    FamilyElementVisibility visibility
)
Visual Basic
Public Sub SetVisibility ( _
    visibility As FamilyElementVisibility _
)
Visual C++
public:
void SetVisibility(
    FamilyElementVisibility^ visibility
)

Parameters

visibility
Type: Autodesk.Revit.DB..::..FamilyElementVisibility

Remarks

The visibility of the CurveByPoints can be changed for different types of views and detail levels in the project.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when visibility is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when regeneration failed.

See Also

CurveByPoints Class


SortPoints Method

[image]

Revit 2024 API
CurveByPoints..::..SortPoints Method
CurveByPoints Class See Also Send Feedback
Order a set of ReferencePoints in the same way Revit does when creating a curve from points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static bool SortPoints(
    ReferencePointArray arr
)
Visual Basic
Public Shared Function SortPoints ( _
    arr As ReferencePointArray _
) As Boolean
Visual C++
public:
static bool SortPoints(
    ReferencePointArray^ arr
)

Parameters

arr
Type: Autodesk.Revit.DB..::..ReferencePointArray
An array of ReferencePoints. The array is reordered if sortPoints returns true, and is unchanged if sortPoints returns false.

Return Value

False if the least-squares method is unable to find a solution; true otherwise.

Remarks

Finds a best-fit line to the points by the least squares method, and orders the points by their projection onto the line.

See Also

CurveByPoints Class


IsReferenceLine Property

[image]

Revit 2024 API
CurveByPoints..::..IsReferenceLine Property
CurveByPoints Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsReferenceLine { get; set; }
Visual Basic
Public Property IsReferenceLine As Boolean
    Get
    Set
Visual C++
public:
property bool IsReferenceLine {
    bool get ();
    void set (bool value);
}

See Also

CurveByPoints Class


Parameter Property

[image] [image]

Revit 2024 API
CurveByPoints..::..Parameter Property
CurveByPoints Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

CurveByPoints Class
CurveByPoints Members


ReferenceType Property

[image]

Revit 2024 API
CurveByPoints..::..ReferenceType Property
CurveByPoints Class See Also Send Feedback
Indicates the type of reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ReferenceType ReferenceType { get; set; }
Visual Basic
Public Property ReferenceType As ReferenceType
    Get
    Set
Visual C++
public:
property ReferenceType ReferenceType {
    ReferenceType get ();
    void set (ReferenceType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when argument is out of range.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when regeneration failed.

See Also

CurveByPoints Class


SketchPlane Property

[image]

Revit 2024 API
CurveByPoints..::..SketchPlane Property
CurveByPoints Class See Also Send Feedback
Override the SketchPlane property of CurveElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public override SketchPlane SketchPlane { get; set; }
Visual Basic
Public Overrides Property SketchPlane As SketchPlane
    Get
    Set
Visual C++
public:
virtual property SketchPlane^ SketchPlane {
    SketchPlane^ get () override;
    void set (SketchPlane^ value) override;
}

Remarks

CurveByPoints has no associated SketchPlane. Getting this property returns nullNothingnullptra null reference (Nothing in Visual Basic). Setting it causes an InvalidOperationException.

See Also

CurveByPoints Class


CurveByPointsArray Class

[image]

Revit 2024 API
CurveByPointsArray Class
Members See Also Send Feedback
An array that can contain CurveByPoints elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class CurveByPointsArray : APIObject,
    IEnumerable
Visual Basic
Public Class CurveByPointsArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class CurveByPointsArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..CurveByPointsArray

See Also

CurveByPointsArray Members


CurveByPointsArray Members

[image] [image]

Revit 2024 API
CurveByPointsArray Members
CurveByPointsArray Class Constructors Methods Properties See Also Send Feedback

The CurveByPointsArray type exposes the following members.

Constructors

 | Name | Description
Public method | CurveByPointsArray | Initializes a new instance of the CurveByPointsArray class

Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every curve from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a curve at a specified index within the array.
Public property | Size | Returns the number of curves that are in the array.

See Also

CurveByPointsArray Class


CurveByPointsArray Constructor

[image]

Revit 2024 API
CurveByPointsArray Constructor
CurveByPointsArray Class See Also Send Feedback
Initializes a new instance of the CurveByPointsArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CurveByPointsArray()
Visual Basic
Public Sub New
Visual C++
public:
CurveByPointsArray()

See Also

CurveByPointsArray Class


Append Method

[image]

Revit 2024 API
CurveByPointsArray..::..Append Method
CurveByPointsArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Append(
    CurveByPoints item
)
Visual Basic
Public Overridable Sub Append ( _
    item As CurveByPoints _
)
Visual C++
public:
virtual void Append(
    CurveByPoints^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..CurveByPoints

See Also

CurveByPointsArray Class


Clear Method

[image]

Revit 2024 API
CurveByPointsArray..::..Clear Method
CurveByPointsArray Class See Also Send Feedback
Removes every curve from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

CurveByPointsArray Class


Insert Method

[image]

Revit 2024 API
CurveByPointsArray..::..Insert Method
CurveByPointsArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Insert(
    CurveByPoints item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As CurveByPoints, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    CurveByPoints^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::..CurveByPoints
index
Type: System..::..Int32

See Also

CurveByPointsArray Class


ReverseIterator Method

[image]

Revit 2024 API
CurveByPointsArray..::..ReverseIterator Method
CurveByPointsArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual CurveByPointsArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As CurveByPointsArrayIterator
Visual C++
public:
virtual CurveByPointsArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

CurveByPointsArray Class


CurveByPointsArray Properties

[image] [image]

Revit 2024 API
CurveByPointsArray Properties
CurveByPointsArray Class See Also Send Feedback

The CurveByPointsArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a curve at a specified index within the array.
Public property | Size | Returns the number of curves that are in the array.

See Also

CurveByPointsArray Class


IsEmpty Property

[image]

Revit 2024 API
CurveByPointsArray..::..IsEmpty Property
CurveByPointsArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

CurveByPointsArray Class


Item Property

[image]

Revit 2024 API
CurveByPointsArray..::..Item Property
CurveByPointsArray Class See Also Send Feedback
Gets or sets a curve at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual CurveByPoints this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As CurveByPoints
    Get
    Set
Visual C++
public:
virtual property CurveByPoints^ Item[int index] {
    CurveByPoints^ get (int index);
    void set (int index, CurveByPoints^ value);
}

Parameters

index
Type: System..::..Int32
The index of the curve to be set or retrieved.

Return Value

Returns the curve at the specified index.

See Also

CurveByPointsArray Class


CurveByPointsArrayIterator Class

[image]

Revit 2024 API
CurveByPointsArrayIterator Class
Members See Also Send Feedback
An iterator to a CurveByPoints array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public abstract class CurveByPointsArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class CurveByPointsArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class CurveByPointsArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..CurveByPointsArrayIterator

See Also

CurveByPointsArrayIterator Members


CurveByPointsArrayIterator Members

[image] [image]

Revit 2024 API
CurveByPointsArrayIterator Members
CurveByPointsArrayIterator Class Constructors Methods Properties See Also Send Feedback

The CurveByPointsArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | CurveByPointsArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CurveByPointsArrayIterator Class


CurveByPointsArrayIterator Constructor

[image]

Revit 2024 API
CurveByPointsArrayIterator Constructor
CurveByPointsArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CurveByPointsArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
CurveByPointsArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CurveByPointsArrayIterator Class


CurveByPointsArrayIterator Methods

[image] [image]

Revit 2024 API
CurveByPointsArrayIterator Methods
CurveByPointsArrayIterator Class See Also Send Feedback

The CurveByPointsArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CurveByPointsArrayIterator Class


MoveNext Method

[image]

Revit 2024 API
CurveByPointsArrayIterator..::..MoveNext Method
CurveByPointsArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

CurveByPointsArrayIterator Class


CurveByPointsArrayIterator Properties

[image] [image]

Revit 2024 API
CurveByPointsArrayIterator Properties
CurveByPointsArrayIterator Class See Also Send Feedback

The CurveByPointsArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CurveByPointsArrayIterator Class


Current Property

[image]

Revit 2024 API
CurveByPointsArrayIterator..::..Current Property
CurveByPointsArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

CurveByPointsArrayIterator Class


CurveByPointsUtils Class

[image]

Revit 2024 API
CurveByPointsUtils Class
Members See Also Send Feedback
A static class that contains methods for processing curves driven by points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public class CurveByPointsUtils : IDisposable
Visual Basic
Public Class CurveByPointsUtils _
    Implements IDisposable
Visual C++
public ref class CurveByPointsUtils : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..CurveByPointsUtils

See Also

CurveByPointsUtils Members


CreateArcThroughPoints Method

[image]

Revit 2024 API
CurveByPointsUtils..::..CreateArcThroughPoints Method
CurveByPointsUtils Class See Also Send Feedback
Creates an arc through the given reference points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static CurveElement CreateArcThroughPoints(
    Document document,
    ReferencePoint startPoint,
    ReferencePoint endPoint,
    ReferencePoint interiorPoint
)
Visual Basic
Public Shared Function CreateArcThroughPoints ( _
    document As Document, _
    startPoint As ReferencePoint, _
    endPoint As ReferencePoint, _
    interiorPoint As ReferencePoint _
) As CurveElement
Visual C++
public:
static CurveElement^ CreateArcThroughPoints(
    Document^ document,
    ReferencePoint^ startPoint,
    ReferencePoint^ endPoint,
    ReferencePoint^ interiorPoint
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The Document.
startPoint
Type: Autodesk.Revit.DB..::..ReferencePoint
The start point of the arc.
endPoint
Type: Autodesk.Revit.DB..::..ReferencePoint
The end end of the arc.
interiorPoint
Type: Autodesk.Revit.DB..::..ReferencePoint
The interior point on the arc.

Return Value

The CurveElement to be created.

Remarks

The interiorPoint determines the orientation of the arc while startPoint and endPoint determine the angle parameters at the ends.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | Can't create an arc from the given points

See Also

CurveByPointsUtils Class


CreateRectangle Method

[image]

Revit 2024 API
CurveByPointsUtils..::..CreateRectangle Method
CurveByPointsUtils Class See Also Send Feedback
Creates rectangle on face or sketchplane for two given diagonal points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static void CreateRectangle(
    Document document,
    ReferencePoint startPoint,
    ReferencePoint endPoint,
    CurveProjectionType projectionType,
    bool boundaryReferenceLines,
    bool boundaryCurvesFollowSurface,
    out IList<ElementId> createdCurvesIds,
    out IList<ElementId> createdCornersIds
)
Visual Basic
Public Shared Sub CreateRectangle ( _
    document As Document, _
    startPoint As ReferencePoint, _
    endPoint As ReferencePoint, _
    projectionType As CurveProjectionType, _
    boundaryReferenceLines As Boolean, _
    boundaryCurvesFollowSurface As Boolean, _
    <OutAttribute> ByRef createdCurvesIds As IList(Of ElementId), _
    <OutAttribute> ByRef createdCornersIds As IList(Of ElementId) _
)
Visual C++
public:
static void CreateRectangle(
    Document^ document,
    ReferencePoint^ startPoint,
    ReferencePoint^ endPoint,
    CurveProjectionType projectionType,
    bool boundaryReferenceLines,
    bool boundaryCurvesFollowSurface,
    [OutAttribute] IList<ElementId^>^% createdCurvesIds,
    [OutAttribute] IList<ElementId^>^% createdCornersIds
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The Document.
startPoint
Type: Autodesk.Revit.DB..::..ReferencePoint
First diagonal point of rectangle.
endPoint
Type: Autodesk.Revit.DB..::..ReferencePoint
Second diagonal point of rectangle.
projectionType
Type: Autodesk.Revit.DB..::..CurveProjectionType
Projection type of rectangle's boundary curves. If the rectangle input points are Face hosted, and CurveProjectionType::ParallelToLevel is requested, and the Face normal at the location of the start point is at a less than 45 degree angle with the level planes, then the projectionType will be set to FromTopDown, even if ParallelToLevel was requested.
boundaryReferenceLines
Type: System..::..Boolean
True if rectangle's boundary curves should be reference lines, false otherwise.
boundaryCurvesFollowSurface
Type: System..::..Boolean
True if rectangle's boundary curves should follow surface, false otherwise.
createdCurvesIds
Type: System.Collections.Generic..::..IList<(Of <(<' ElementId >)>)>%
Created rectangle's boundary curves ids.
createdCornersIds
Type: System.Collections.Generic..::..IList<(Of <(<' ElementId >)>)>%
Ids of two newly created corner points.

Remarks

This array contains the ElementIds of the two additional corner points that are created to complete the rectangle.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Unexpected projection type. -or- A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | Unable to create rectangle.

See Also

CurveByPointsUtils Class


Dispose Method

[image]

Revit 2024 API
CurveByPointsUtils..::..Dispose Method
CurveByPointsUtils Class See Also Send Feedback
Releases all resources used by the CurveByPointsUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

CurveByPointsUtils Class


GetFaceRegions Method

[image]

Revit 2024 API
CurveByPointsUtils..::..GetFaceRegions Method
CurveByPointsUtils Class See Also Send Feedback
Gets the FaceRegions in the existing face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static IList<Reference> GetFaceRegions(
    Document cda,
    Reference referenceOfFace
)
Visual Basic
Public Shared Function GetFaceRegions ( _
    cda As Document, _
    referenceOfFace As Reference _
) As IList(Of Reference)
Visual C++
public:
static IList<Reference^>^ GetFaceRegions(
    Document^ cda,
    Reference^ referenceOfFace
)

Parameters

cda
Type: Autodesk.Revit.DB..::..Document
The Document.
referenceOfFace
Type: Autodesk.Revit.DB..::..Reference
The Reference of the existing face.

Return Value

The FaceRegions in the existing face, or an empty collection if no FaceRegions are found.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The Reference is not a Face Reference.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

CurveByPointsUtils Class


GetHostFace Method

[image]

Revit 2024 API
CurveByPointsUtils..::..GetHostFace Method
CurveByPointsUtils Class See Also Send Feedback
Gets the host face to which the CurveElement is added.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static Reference GetHostFace(
    CurveElement curveElem
)
Visual Basic
Public Shared Function GetHostFace ( _
    curveElem As CurveElement _
) As Reference
Visual C++
public:
static Reference^ GetHostFace(
    CurveElement^ curveElem
)

Parameters

curveElem
Type: Autodesk.Revit.DB..::..CurveElement
The CurveElement.

Return Value

The host face to which the CurveElement is added, or an empty Reference if the host is not a face.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input CurveElement is not a CurveByPoints.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

CurveByPointsUtils Class


SetProjectionType Method

[image]

Revit 2024 API
CurveByPointsUtils..::..SetProjectionType Method
CurveByPointsUtils Class See Also Send Feedback
Sets the projection type of the CurveElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static void SetProjectionType(
    CurveElement curveElem,
    CurveProjectionType value
)
Visual Basic
Public Shared Sub SetProjectionType ( _
    curveElem As CurveElement, _
    value As CurveProjectionType _
)
Visual C++
public:
static void SetProjectionType(
    CurveElement^ curveElem,
    CurveProjectionType value
)

Parameters

curveElem
Type: Autodesk.Revit.DB..::..CurveElement
The CurveElement.
value
Type: Autodesk.Revit.DB..::..CurveProjectionType
The input projection type.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input CurveElement is not a CurveByPoints.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

CurveByPointsUtils Class


SetSketchOnSurface Method

[image]

Revit 2024 API
CurveByPointsUtils..::..SetSketchOnSurface Method
CurveByPointsUtils Class See Also Send Feedback
Sets the relationship between the CurveElement and face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static void SetSketchOnSurface(
    CurveElement curveElem,
    bool sketchOnSurface
)
Visual Basic
Public Shared Sub SetSketchOnSurface ( _
    curveElem As CurveElement, _
    sketchOnSurface As Boolean _
)
Visual C++
public:
static void SetSketchOnSurface(
    CurveElement^ curveElem,
    bool sketchOnSurface
)

Parameters

curveElem
Type: Autodesk.Revit.DB..::..CurveElement
The CurveElement.
sketchOnSurface
Type: System..::..Boolean
Whether or not the CurveElement should lie on the face and be able to be added to the face.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input CurveElement is not a CurveByPoints.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

CurveByPointsUtils Class


ValidateCurveElementIdArrayForFaceRegions Method

[image]

Revit 2024 API
CurveByPointsUtils..::..ValidateCurveElementIdArrayForFaceRegions Method
CurveByPointsUtils Class See Also Send Feedback
Validates that the input CurveElements can define FaceRegions. The CurveElements must be CurveByPoints. Each curve must be entirely hosted by a single Face or hosts related to a common Face (for example, Edges of a common Face, other CurveElements hosted by a common Face). To be added to the FaceRegion definition, a CurveElement must have the SketchOnSurface attribute set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static bool ValidateCurveElementIdArrayForFaceRegions(
    Document document,
    IList<ElementId> curveElemIds
)
Visual Basic
Public Shared Function ValidateCurveElementIdArrayForFaceRegions ( _
    document As Document, _
    curveElemIds As IList(Of ElementId) _
) As Boolean
Visual C++
public:
static bool ValidateCurveElementIdArrayForFaceRegions(
    Document^ document,
    IList<ElementId^>^ curveElemIds
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The Document.
curveElemIds
Type: System.Collections.Generic..::..IList<(Of <(<' ElementId >)>)>
The CurveElements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

CurveByPointsUtils Class


CurveByPointsUtils Properties

[image] [image]

Revit 2024 API
CurveByPointsUtils Properties
CurveByPointsUtils Class See Also Send Feedback

The CurveByPointsUtils type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

CurveByPointsUtils Class


IsValidObject Property

[image]

Revit 2024 API
CurveByPointsUtils..::..IsValidObject Property
CurveByPointsUtils Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

CurveByPointsUtils Class


CurveElement Class

[image]

Revit 2024 API
CurveElement Class
Members See Also Send Feedback
Class representing curve elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class CurveElement : Element
Visual Basic
Public Class CurveElement _
    Inherits Element
Visual C++
public ref class CurveElement : public Element

Remarks

As a base class of several specialized curved elements (such as ModelCurve, ModelLine, CurveByPoints, etc.) CurveElement exposes methods and properties of general use applicable to most kinds of curves.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..CurveElement
Autodesk.Revit.DB..::..CurveByPoints
Autodesk.Revit.DB..::..DetailCurve
Autodesk.Revit.DB..::..ModelCurve
Autodesk.Revit.DB.Structure..::..AreaReinforcementCurve
Autodesk.Revit.DB..::..SymbolicCurve

See Also

CurveElement Members


CurveElement Members

[image] [image]

Revit 2024 API
CurveElement Members
CurveElement Class Methods Properties See Also Send Feedback

The CurveElement type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | CreateAreaBasedLoadBoundaryLine | Creates an area based load boundary line.
 | CreateAreaBasedLoadBoundaryLines | Creates area based load boundary lines.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point.
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point.
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point.
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry.
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement.
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveElementType | Type of the curve element.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element.
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element.
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchPlane | The sketch plane the curve element lies in.
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

CurveElement Class


CurveElement Methods

[image] [image]

Revit 2024 API
CurveElement Methods
CurveElement Class See Also Send Feedback

The CurveElement type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | CreateAreaBasedLoadBoundaryLine | Creates an area based load boundary line.
 | CreateAreaBasedLoadBoundaryLines | Creates area based load boundary lines.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point.
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point.
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point.
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry.
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement.
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CurveElement Class


CreateAreaBasedLoadBoundaryLine Method

[image]

Revit 2024 API
CurveElement..::..CreateAreaBasedLoadBoundaryLine Method
CurveElement Class See Also Send Feedback
Creates an area based load boundary line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public static CurveElement CreateAreaBasedLoadBoundaryLine(
    Document document,
    Curve curve,
    ElementId levelId
)
Visual Basic
Public Shared Function CreateAreaBasedLoadBoundaryLine ( _
    document As Document, _
    curve As Curve, _
    levelId As ElementId _
) As CurveElement
Visual C++
public:
static CurveElement^ CreateAreaBasedLoadBoundaryLine(
    Document^ document,
    Curve^ curve,
    ElementId^ levelId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which to create the area based load boundary line.
curve
Type: Autodesk.Revit.DB..::..Curve
The curve.
levelId
Type: Autodesk.Revit.DB..::..ElementId
The id of level.

Return Value

The newly created area based load boundary line.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- The input curve is not bound. -or- The curve is degenerate (its length is too close to zero). -or- The ElementId levelId is not a Level. -or- The curve doesn't lie in the plane of the level.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

CurveElement Class


CreateAreaBasedLoadBoundaryLines Method

[image]

Revit 2024 API
CurveElement..::..CreateAreaBasedLoadBoundaryLines Method
CurveElement Class See Also Send Feedback
Creates area based load boundary lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public static IList<CurveElement> CreateAreaBasedLoadBoundaryLines(
    Document document,
    IList<Curve> curves,
    ElementId levelId
)
Visual Basic
Public Shared Function CreateAreaBasedLoadBoundaryLines ( _
    document As Document, _
    curves As IList(Of Curve), _
    levelId As ElementId _
) As IList(Of CurveElement)
Visual C++
public:
static IList<CurveElement^>^ CreateAreaBasedLoadBoundaryLines(
    Document^ document,
    IList<Curve^>^ curves,
    ElementId^ levelId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which to create the area based load boundary lines.
curves
Type: System.Collections.Generic..::..IList<(Of <(<' Curve >)>)>
The curves.
levelId
Type: Autodesk.Revit.DB..::..ElementId
The id of level.

Return Value

The newly created area based load boundary lines.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- The input curves contains a null pointer or a curve that is not bounded. -or- The input curves contains at least one curve which is degenerate (its length is too close to zero). -or- The ElementId levelId is not a Level. -or- The input curves contains a curve doesn't lie in the plane of the level.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

CurveElement Class


GetAdjoinedCurveElements Method

[image]

Revit 2024 API
CurveElement..::..GetAdjoinedCurveElements Method
CurveElement Class See Also Send Feedback
Returns elements that are joining with this curve element at the given end point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public ISet<ElementId> GetAdjoinedCurveElements(
    int end
)
Visual Basic
Public Function GetAdjoinedCurveElements ( _
    end As Integer _
) As ISet(Of ElementId)
Visual C++
public:
ISet<ElementId^>^ GetAdjoinedCurveElements(
    int end
)

Parameters

end
Type: System..::..Int32
Id of one the curve's end. Value '0' indicates start and '1' indicates the end of the curve, respectively.

Return Value

Collection of Ids of Curve Elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given Id does not represent any of the two end-points of a curve element. A valid value of either '0' or '1' is expected.

See Also

CurveElement Class


GetAreaBasedLoadBoundaryLineData Method

[image]

Revit 2024 API
CurveElement..::..GetAreaBasedLoadBoundaryLineData Method
CurveElement Class See Also Send Feedback
Gets the area based load boundary line data from this curve, if applicable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public AreaBasedLoadBoundaryLineData GetAreaBasedLoadBoundaryLineData()
Visual Basic
Public Function GetAreaBasedLoadBoundaryLineData As AreaBasedLoadBoundaryLineData
Visual C++
public:
AreaBasedLoadBoundaryLineData^ GetAreaBasedLoadBoundaryLineData()

Return Value

The area based load boundary line data, if this is an area based load boundary, or nullNothingnullptra null reference (Nothing in Visual Basic) otherwise.

Remarks

Will return nullNothingnullptra null reference (Nothing in Visual Basic) if curve element isn't an area based load boundary line.

See Also

CurveElement Class


GetLineStyleIds Method

[image]

Revit 2024 API
CurveElement..::..GetLineStyleIds Method
CurveElement Class See Also Send Feedback
Ids of all line style Elements that are applicable to this curve element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ICollection<ElementId> GetLineStyleIds()
Visual Basic
Public Function GetLineStyleIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetLineStyleIds()

Return Value

A collection of Ids of line style elements.

Remarks

The elements are of the [!:Autodesk::Revit::DB::GraphicsStyle] class.

See Also

CurveElement Class


GetTangentLock Method

[image]

Revit 2024 API
CurveElement..::..GetTangentLock Method
CurveElement Class See Also Send Feedback
Returns the state of a tangent join between this and another curve element at the given end-point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public bool GetTangentLock(
    int end,
    ElementId other
)
Visual Basic
Public Function GetTangentLock ( _
    end As Integer, _
    other As ElementId _
) As Boolean
Visual C++
public:
bool GetTangentLock(
    int end,
    ElementId^ other
)

Parameters

end
Type: System..::..Int32
Index of one of the curve's end. Values '0' and '1' indicate the start or end point, respectively.
other
Type: Autodesk.Revit.DB..::..ElementId
ElementId of another Curve Element from the same document.

Return Value

Returns True if this curve element has a tangent joint with the other input element and the join is curently locked; returns False otherwise.

Remarks

The return value indicates whether there is such tangent join and if it is currently locked. A negative value indicates that there either is no tangent join with the other element at the given end-point, or the join between those two curve element is not currently locked.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given Id does not represent any of the two end-points of a curve element. A valid value of either '0' or '1' is expected. -or- The given ElementId (%elementId) is not of a valid Curve Element. A valid Curve Element must be in the same document and must be diferent than this curve elements self. -or- This element has no tangent join with the input element at the given end-point.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

CurveElement Class


HasTangentJoin Method

[image]

Revit 2024 API
CurveElement..::..HasTangentJoin Method
CurveElement Class See Also Send Feedback
Tests whether this curve element and the input curve element have common tangent join at the given end-point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public bool HasTangentJoin(
    int end,
    ElementId other
)
Visual Basic
Public Function HasTangentJoin ( _
    end As Integer, _
    other As ElementId _
) As Boolean
Visual C++
public:
bool HasTangentJoin(
    int end,
    ElementId^ other
)

Parameters

end
Type: System..::..Int32
Index of one of the curve's end. Values '0' and '1' indicate the start or end point, respectively.
other
Type: Autodesk.Revit.DB..::..ElementId
ElementId of another Curve Element from the same document.

Return Value

Returns True if the two curve elements have a tangent join at the given end-point.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

CurveElement Class


HasTangentLocks Method

[image]

Revit 2024 API
CurveElement..::..HasTangentLocks Method
CurveElement Class See Also Send Feedback
Tests whether this curve element has any locked tangent joins at the given end-point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public bool HasTangentLocks(
    int end
)
Visual Basic
Public Function HasTangentLocks ( _
    end As Integer _
) As Boolean
Visual C++
public:
bool HasTangentLocks(
    int end
)

Parameters

end
Type: System..::..Int32
Index of one of the curve's end. Values '0' and '1' indicate the start or end point, respectively.

Return Value

Returns True if the curve element is tangentially locked to at least one other curve element at the given end-point; returns False otherwise.

Remarks

Note that tangent locks between two elements at their joined ends are always kept in sync with each other. It means that if one curve element is locked to another curve, the other curve will be automatically locked to the first curve at the shared join.

See Also

CurveElement Class


IsAdjoinedCurveElement Method

[image]

Revit 2024 API
CurveElement..::..IsAdjoinedCurveElement Method
CurveElement Class See Also Send Feedback
This method tests whether this and the given curve elements are joined at the given end.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public bool IsAdjoinedCurveElement(
    int end,
    ElementId other
)
Visual Basic
Public Function IsAdjoinedCurveElement ( _
    end As Integer, _
    other As ElementId _
) As Boolean
Visual C++
public:
bool IsAdjoinedCurveElement(
    int end,
    ElementId^ other
)

Parameters

end
Type: System..::..Int32
Index of one of the curve's end. Values '0' and '1' indicate the start or end point, respectively.
other
Type: Autodesk.Revit.DB..::..ElementId
ElementId of another Curve Element from the same document.

Return Value

Returns True if the input curve element joins This curve element at the given end-point; returns False otherwise.

Remarks

The input end is relative to this curve element. The other curve element can be joined at any of its end-points.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given Id does not represent any of the two end-points of a curve element. A valid value of either '0' or '1' is expected. -or- The given ElementId (%elementId) is not of a valid Curve Element. A valid Curve Element must be in the same document and must be diferent than this curve elements self.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

CurveElement Class


SetGeometryCurve Method

[image]

Revit 2024 API
CurveElement..::..SetGeometryCurve Method
CurveElement Class See Also Send Feedback
Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public void SetGeometryCurve(
    Curve curve,
    bool overrideJoins
)
Visual Basic
Public Sub SetGeometryCurve ( _
    curve As Curve, _
    overrideJoins As Boolean _
)
Visual C++
public:
void SetGeometryCurve(
    Curve^ curve,
    bool overrideJoins
)

Parameters

curve
Type: Autodesk.Revit.DB..::..Curve
The new curve.
overrideJoins
Type: System..::..Boolean
An option to specify whether or not existing joins will affect setting the geometry of the CurveElement. Setting this parameter to false is essentially the same as directly setting the GeometryCurve property.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown if the argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the input curve is of a type different from the current. -- or -- Thrown if the input curve is bound and the current is not or vice versa. -- or -- Thrown if the input curve is helical. -- or -- Thrown if the input curve lies outside of the SketchPlane of the current curve and the CurveElement is not CurveByPoints.

See Also

CurveElement Class


SetSketchPlaneAndCurve Method

[image]

Revit 2024 API
CurveElement..::..SetSketchPlaneAndCurve Method
CurveElement Class See Also Send Feedback
Sets the sketch plane and the curve for this CurveElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public void SetSketchPlaneAndCurve(
    SketchPlane sketchPlane,
    Curve curve
)
Visual Basic
Public Sub SetSketchPlaneAndCurve ( _
    sketchPlane As SketchPlane, _
    curve As Curve _
)
Visual C++
public:
void SetSketchPlaneAndCurve(
    SketchPlane^ sketchPlane,
    Curve^ curve
)

Parameters

sketchPlane
Type: Autodesk.Revit.DB..::..SketchPlane
The new sketch plane.
curve
Type: Autodesk.Revit.DB..::..Curve
The new curve.

Remarks

Unlike the setters of SketchPlane and GeometryCurve, this method will reset relationships between the two properties and with other elements. To set a geometry curve which belongs to a sketch-based elements, use GeometryCurve

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown if the argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if the CurveElement is CurveByPoints or belongs to a Path3d element. -- or -- Thrown if the sketch plane is set on a DetailCurve. -- or -- Thrown if the sketch plane is not suitable. -- or -- Thrown if the CurveElement belongs to a sketch-based element. -- or -- Thrown if modifying the sketch plane is not allowed. -- or -- Thrown if the CurveElement cannot be moved out of its sketch plane. -- or -- Thrown if the input curve is of a type different from the current. -- or -- Thrown if the input curve is bound and the current is not or vice versa. -- or -- Thrown if the input curve is helical. -- or -- Thrown if the input curve lies outside of the SketchPlane of the current curve.

See Also

CurveElement Class


SetTangentLock Method

[image]

Revit 2024 API
CurveElement..::..SetTangentLock Method
CurveElement Class See Also Send Feedback
Sets a new status for an existing tangent join with another curve element at the given end-point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public void SetTangentLock(
    int end,
    ElementId other,
    bool state
)
Visual Basic
Public Sub SetTangentLock ( _
    end As Integer, _
    other As ElementId, _
    state As Boolean _
)
Visual C++
public:
void SetTangentLock(
    int end,
    ElementId^ other,
    bool state
)

Parameters

end
Type: System..::..Int32
Index of one of the curve's ends. Values '0' and '1' indicate the start or end point, respectively.
other
Type: Autodesk.Revit.DB..::..ElementId
ElementId of another Curve Element from the same document.
state
Type: System..::..Boolean
Requested new state of the lock; True to lock it, False to unlock it.

Remarks

The input status indicates whether the tangent join is to be locked or unlocked. Note that the status can be set only if this and the other curve element are currently joined and tangent at the given point.

Locking a tangent join between elements of a family will make the family parametric. A parametric family needs to utilize a geometry solver in order to determine final shapes of its instances. Using the solver in families which contain large sketches may cause regenerations of such families to become significantly slower. To determine whether a particular family falls into such a category, programmers can query IsParametric property and [!:Autodesk::Revit::DB::Family::DoesContainLargeSketches()] method of the Family class.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given Id does not represent any of the two end-points of a curve element. A valid value of either '0' or '1' is expected. -or- The given ElementId (%elementId) is not of a valid Curve Element. A valid Curve Element must be in the same document and must be diferent than this curve elements self. -or- This element has no tangent join with the input element at the given end-point. -or- The element other does not exist in the document containing this CurveElement
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This curve element does not support tangent joins with other elements.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | This CurveElement is an internal element, such as a component of a loaded family or a group type. -or- The document containing this CurveElement is in Group Edit Mode, Sketch Edit Mode, or Paste Mode, and the element is not a member of the group, sketch, or clipboard. -or- This CurveElement is a member of a group or sketch, and the document is not currently editing the group or sketch. -or- other is an internal element, such as a component of a loaded family or a group type. -or- The document containing other is in Group Edit Mode, Sketch Edit Mode, or Paste Mode, and the element is not a member of the group, sketch, or clipboard. -or- other is a member of a group or sketch, and the document is not currently editing the group or sketch.

See Also

CurveElement Class


CurveElement Properties

[image] [image]

Revit 2024 API
CurveElement Properties
CurveElement Class See Also Send Feedback

The CurveElement type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveElementType | Type of the curve element.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element.
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element.
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchPlane | The sketch plane the curve element lies in.
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

CurveElement Class


CenterPointReference Property

[image]

Revit 2024 API
CurveElement..::..CenterPointReference Property
CurveElement Class See Also Send Feedback
Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Reference CenterPointReference { get; }
Visual Basic
Public ReadOnly Property CenterPointReference As Reference
    Get
Visual C++
public:
property Reference^ CenterPointReference {
    Reference^ get ();
}

Remarks

Use this reference property when using the API to dimension between centerpoints of curves.

See Also

CurveElement Class


CurveElementType Property

[image]

Revit 2024 API
CurveElement..::..CurveElementType Property
CurveElement Class See Also Send Feedback
Type of the curve element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CurveElementType CurveElementType { get; }
Visual Basic
Public ReadOnly Property CurveElementType As CurveElementType
    Get
Visual C++
public:
property CurveElementType CurveElementType {
    CurveElementType get ();
}

See Also

CurveElement Class


GeometryCurve Property

[image]

Revit 2024 API
CurveElement..::..GeometryCurve Property
CurveElement Class See Also Send Feedback
Geometry curve of the curve element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Curve GeometryCurve { get; set; }
Visual Basic
Public Property GeometryCurve As Curve
    Get
    Set
Visual C++
public:
property Curve^ GeometryCurve {
    Curve^ get ();
    void set (Curve^ value);
}

Remarks

When setting this property, any curves that this curve is currently joined to will affect the result - the final geometry of this curve and of the joined curves may change. To avoid the effect of existing joins, use SetGeometryCurve(Curve, Boolean) with true passed ot overrideJoins. After the curve geometry is set, other nearby curves may join to the new curve geometry.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown if the argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown if the argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the input curve is of a type different from the current. -- or -- Thrown if the input curve is bound and the current is not or vice versa. -- or -- Thrown if the input curve is helical. -- or -- Thrown if the input curve lies outside of the SketchPlane of the current curve and the CurveElement is not CurveByPoints.

See Also

CurveElement Class


LineStyle Property

[image]

Revit 2024 API
CurveElement..::..LineStyle Property
CurveElement Class See Also Send Feedback
The line style of this curve element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Element LineStyle { get; set; }
Visual Basic
Public Property LineStyle As Element
    Get
    Set
Visual C++
public:
property Element^ LineStyle {
    Element^ get ();
    void set (Element^ value);
}

Remarks

The return of this property will be a [!:Autodesk::Revit::DB::GraphicsStyle] element. These graphics styles should be associated to subcategories of the BuiltInCategory OST_Lines.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when regeneration failed. -- or -- Thrown when fail to get line style.

See Also

CurveElement Class


SupportsTangentLocks Property

[image]

Revit 2024 API
CurveElement..::..SupportsTangentLocks Property
CurveElement Class See Also Send Feedback
Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool SupportsTangentLocks { get; }
Visual Basic
Public ReadOnly Property SupportsTangentLocks As Boolean
    Get
Visual C++
public:
property bool SupportsTangentLocks {
    bool get ();
}

See Also

CurveElement Class


CurveElementFilter Members

[image] [image]

Revit 2024 API
CurveElementFilter Members
CurveElementFilter Class Constructors Methods Properties See Also Send Feedback

The CurveElementFilter type exposes the following members.

Constructors

 | Name | Description
Public method | CurveElementFilter(CurveElementType) | Constructs a new instance of a filter to match specific types of curve elements.
Public method | CurveElementFilter(CurveElementType, Boolean) | Constructs a new instance of a filter to match specific types of curve elements, with the option to match all curves which are not of the given curve type.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CurveElementType | The curve element type.
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)

See Also

CurveElementFilter Class


CurveElementFilter Constructor

[image] [image]

Revit 2024 API
CurveElementFilter Constructor
CurveElementFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CurveElementFilter(CurveElementType) | Constructs a new instance of a filter to match specific types of curve elements.
Public method | CurveElementFilter(CurveElementType, Boolean) | Constructs a new instance of a filter to match specific types of curve elements, with the option to match all curves which are not of the given curve type.

See Also

CurveElementFilter Class
CurveElementFilter Members


CurveElementFilter Constructor (CurveElementType)

[image]

Revit 2024 API
CurveElementFilter Constructor (CurveElementType)
CurveElementFilter Class See Also Send Feedback
Constructs a new instance of a filter to match specific types of curve elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public CurveElementFilter(
    CurveElementType curveElementType
)
Visual Basic
Public Sub New ( _
    curveElementType As CurveElementType _
)
Visual C++
public:
CurveElementFilter(
    CurveElementType curveElementType
)

Parameters

curveElementType
Type: Autodesk.Revit.DB..::..CurveElementType
The curve element type to match.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

CurveElementFilter Class
CurveElementFilter Overload


CurveElementFilter Constructor (CurveElementType, Boolean)

[image]

Revit 2024 API
CurveElementFilter Constructor (CurveElementType, Boolean)
CurveElementFilter Class See Also Send Feedback
Constructs a new instance of a filter to match specific types of curve elements, with the option to match all curves which are not of the given curve type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public CurveElementFilter(
    CurveElementType curveElementType,
    bool inverted
)
Visual Basic
Public Sub New ( _
    curveElementType As CurveElementType, _
    inverted As Boolean _
)
Visual C++
public:
CurveElementFilter(
    CurveElementType curveElementType,
    bool inverted
)

Parameters

curveElementType
Type: Autodesk.Revit.DB..::..CurveElementType
The curve element type to match.
inverted
Type: System..::..Boolean
True if the filter should match all curves which are not of the given curve type.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

CurveElementFilter Class
CurveElementFilter Overload


CurveElementFilter Methods

[image] [image]

Revit 2024 API
CurveElementFilter Methods
CurveElementFilter Class See Also Send Feedback

The CurveElementFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CurveElementFilter Class


PassesFilter Method

[image] [image]

Revit 2024 API
CurveElementFilter..::..PassesFilter Method
CurveElementFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

CurveElementFilter Class
CurveElementFilter Members


CurveElementType Property

[image]

Revit 2024 API
CurveElementFilter..::..CurveElementType Property
CurveElementFilter Class See Also Send Feedback
The curve element type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public CurveElementType CurveElementType { get; }
Visual Basic
Public ReadOnly Property CurveElementType As CurveElementType
    Get
Visual C++
public:
property CurveElementType CurveElementType {
    CurveElementType get ();
}

See Also

CurveElementFilter Class


CurveElementType Enumeration

[image]

Revit 2024 API
CurveElementType Enumeration
See Also Send Feedback
An enumerated type listing the curve element types that can be used when filtering elements (via CurveElementFilter).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public enum CurveElementType
Visual Basic
Public Enumeration CurveElementType
Visual C++
public enum class CurveElementType

Members

Member name | Description
Invalid | An invalid curve element type.
ModelCurve | A model curve.
DetailCurve | A detail curve.
SymbolicCurve | A symbolic curve.
ReferenceLine | A reference line.
SpaceSeparation | A space separation curve.
RoomSeparation | An room separation curve.
AreaSeparation | An area separation curve.
CurveByPoints | A curve created by connecting a set of points.
RepeatingDetail | The profile of a repeating detail set.
Insulation | A detail curve representing insulation.
Cloud | A portion of a revision cloud.
AreaBasedLoadBoundary | An Area Based Load Boundary curve.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


CurveExtents Members

[image] [image]

Revit 2024 API
CurveExtents Members
CurveExtents Class Methods Properties See Also Send Feedback

The CurveExtents type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the CurveExtents
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | EndParameter | The end parameter of the curve extents.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | StartParameter | The start parameter of the curve extents.

See Also

CurveExtents Class


CurveExtents Methods

[image] [image]

Revit 2024 API
CurveExtents Methods
CurveExtents Class See Also Send Feedback

The CurveExtents type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CurveExtents Class


Dispose Method

[image]

Revit 2024 API
CurveExtents..::..Dispose Method
CurveExtents Class See Also Send Feedback
Releases all resources used by the CurveExtents

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

CurveExtents Class


CurveExtents Properties

[image] [image]

Revit 2024 API
CurveExtents Properties
CurveExtents Class See Also Send Feedback

The CurveExtents type exposes the following members.

Properties

 | Name | Description
Public property | EndParameter | The end parameter of the curve extents.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | StartParameter | The start parameter of the curve extents.

See Also

CurveExtents Class


IsValidObject Property

[image]

Revit 2024 API
CurveExtents..::..IsValidObject Property
CurveExtents Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

CurveExtents Class


StartParameter Property

[image]

Revit 2024 API
CurveExtents..::..StartParameter Property
CurveExtents Class See Also Send Feedback
The start parameter of the curve extents.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double StartParameter { get; }
Visual Basic
Public ReadOnly Property StartParameter As Double
    Get
Visual C++
public:
property double StartParameter {
    double get ();
}

See Also

CurveExtents Class


CurveLoop Class

[image]

Revit 2024 API
CurveLoop Class
Members See Also Send Feedback
A class that represents a chain of curves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public class CurveLoop : IEnumerable<Curve>,
    IDisposable
Visual Basic
Public Class CurveLoop _
    Implements IEnumerable(Of Curve), IDisposable
Visual C++
public ref class CurveLoop : IEnumerable<Curve^>,
    IDisposable

Remarks

There are specific requirements for how valid CurveLoops must be formed:
  • The curves should typically be contiguous.
  • The CurveLoop may be either closed (where the start and end points coincide) or open.
  • There should be no self-intersections.

A CurveLoop is said to be "continuous" if either:

  • the loop contains at most one curve
  • the end of each curve coincides with the start of the next one (if there is a next curve).

Many geometry utilities require CurveLoops to be continuous, but discontinuous CurveLoops are sometimes used. For example, the curves in a continuous CurveLoop may be offset, resulting in a discontinuous loop if the offset curves overlap or do not meet, and the offset curves might then be extended or trimmed to form a continuous CurveLoop.

A CurveLoop is said to be "closed" if it is non-empty, continuous, and if either:

  • the loop contains just one curve, which is unbounded and periodic
  • the loop's end point coincides with its start point
For example, a CurveLoop comprising four lines forming a rectangle, listed in order around the rectangle, with each curve oriented in direction in which the curves are listed is closed. As another example, a CurveLoop consisting of just one unbounded circle is closed.

A CurveLoop is said to be "open" if it is not closed. For example, a CurveLoop consisting of a single line is open, as is the "offset CurveLoop" mentioned above. Note that an open CurveLoop may be continuous or discontinuous, and a continuous CurveLoop may be open or closed. The definitions imply that a discontinuous CurveLoop is necessarily open and an empty CurveLoop is open.

It should also be noted that these definitions take the order of the curves and the curves' directions into account. For example, a CurveLoop comprising the four edges of a rectangle in the order {bottom, top, left, right} is discontinuous. Similarly, a CurveLoop comprising the four edges of a rectangle in the order {bottom, right, top, left}, with three of the lines oriented in the counter-clockwise direction of the rectangle and the fourth oriented in the clockwise direction, is discontinuous.

Finally, note that some routines in Revit may set the CurveLoop to be marked "open" or "closed" in spite of the actual geometry of the curves. In these special cases, the CurveLoop class does not require that the CurveLoop is correctly marked.

In the API, the members of the CurveLoop may be directly iterated, as the class implements IEnumerable<Curve>. The iteration provides copies of the curves directly contained in the loop; modification of the curves will not affect the curves that are contained in the loop.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..CurveLoop

See Also

CurveLoop Members


CurveLoop Members

[image] [image]

Revit 2024 API
CurveLoop Members
CurveLoop Class Constructors Methods Properties See Also Send Feedback

The CurveLoop type exposes the following members.

Constructors

 | Name | Description
Public method | CurveLoop | Constructs a new empty curve loop.

Methods

 | Name | Description
Public method | Append | Append the curve to this loop.
 | Create | Creates a new curve loop.
 | CreateViaCopy | Creates a new curve loop as a copy of the input.
 | CreateViaOffset(CurveLoop, IList<(Of <<'(Double>)>>), XYZ) | Creates a new curve loop that is an offset of the existing curve loop.
 | CreateViaOffset(CurveLoop, Double, XYZ) | Creates a new curve loop that is an offset of the existing curve loop.
 | CreateViaThicken(Curve, Double, XYZ) | Creates a new closed curve loop by thickening the input curve with respect to a given plane.
 | CreateViaThicken(CurveLoop, Double, XYZ) | Creates a new closed curve loop by thickening the input open curve loop with respect to a given plane.
 | CreateViaTransform | Creates a new curve loop as a transformed copy of the input curve loop.
Public method | Dispose | Releases all resources used by the CurveLoop
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Flip | Reverses the orientation of the curve loop.
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetCurveLoopIterator | Returns a curve that iterates through the curve loop.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetExactLength | Returns the sum of exact lengths of all curves in the loop.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPlane | Gets the plane of the curve loop, if it is planar.
Public method | GetRectangularHeight | Returns the width of a curve loop if it is rectangular with respect to the projection plane.
Public method | GetRectangularWidth | Returns the width of a curve loop if it is rectangular with respect to the projection plane.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasPlane | Identifies if the CurveLoop is planar.
Public method | IsCounterclockwise | Determines if this CurveLoop is oriented counter-clockwise (CCW) or clockwise (CW) with respect to the specified 3D direction.
Public method | IsOpen | Returns whether the curve loop is open or closed, as determined by an internal flag.
Public method | IsRectangular | Identifies if the curve loop is rectangular with respect to a given projection plane.
Public method | NumberOfCurves | Returns the number of curves in the curve loop.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Transform | Transforms this curve loop and all of its component curves by the supplied transformation.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

CurveLoop Class


CurveLoop Constructor

[image]

Revit 2024 API
CurveLoop Constructor
CurveLoop Class See Also Send Feedback
Constructs a new empty curve loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public CurveLoop()
Visual Basic
Public Sub New
Visual C++
public:
CurveLoop()

See Also

CurveLoop Class


CurveLoop Methods

[image] [image]

Revit 2024 API
CurveLoop Methods
CurveLoop Class See Also Send Feedback

The CurveLoop type exposes the following members.

Methods

 | Name | Description
Public method | Append | Append the curve to this loop.
 | Create | Creates a new curve loop.
 | CreateViaCopy | Creates a new curve loop as a copy of the input.
 | CreateViaOffset(CurveLoop, IList<(Of <<'(Double>)>>), XYZ) | Creates a new curve loop that is an offset of the existing curve loop.
 | CreateViaOffset(CurveLoop, Double, XYZ) | Creates a new curve loop that is an offset of the existing curve loop.
 | CreateViaThicken(Curve, Double, XYZ) | Creates a new closed curve loop by thickening the input curve with respect to a given plane.
 | CreateViaThicken(CurveLoop, Double, XYZ) | Creates a new closed curve loop by thickening the input open curve loop with respect to a given plane.
 | CreateViaTransform | Creates a new curve loop as a transformed copy of the input curve loop.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Flip | Reverses the orientation of the curve loop.
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetCurveLoopIterator | Returns a curve that iterates through the curve loop.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetExactLength | Returns the sum of exact lengths of all curves in the loop.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPlane | Gets the plane of the curve loop, if it is planar.
Public method | GetRectangularHeight | Returns the width of a curve loop if it is rectangular with respect to the projection plane.
Public method | GetRectangularWidth | Returns the width of a curve loop if it is rectangular with respect to the projection plane.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasPlane | Identifies if the CurveLoop is planar.
Public method | IsCounterclockwise | Determines if this CurveLoop is oriented counter-clockwise (CCW) or clockwise (CW) with respect to the specified 3D direction.
Public method | IsOpen | Returns whether the curve loop is open or closed, as determined by an internal flag.
Public method | IsRectangular | Identifies if the curve loop is rectangular with respect to a given projection plane.
Public method | NumberOfCurves | Returns the number of curves in the curve loop.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Transform | Transforms this curve loop and all of its component curves by the supplied transformation.

See Also

CurveLoop Class


Append Method

[image]

Revit 2024 API
CurveLoop..::..Append Method
CurveLoop Class See Also Send Feedback
Append the curve to this loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public void Append(
    Curve curve
)
Visual Basic
Public Sub Append ( _
    curve As Curve _
)
Visual C++
public:
void Append(
    Curve^ curve
)

Parameters

curve
Type: Autodesk.Revit.DB..::..Curve
The curve.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input curve points to a helical curve and is not supported for this operation. -or- Throws if the input curve makes the loop not contiguous.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

CurveLoop Class


Create Method

[image]

Revit 2024 API
CurveLoop..::..Create Method
CurveLoop Class See Also Send Feedback
Creates a new curve loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static CurveLoop Create(
    IList<Curve> curves
)
Visual Basic
Public Shared Function Create ( _
    curves As IList(Of Curve) _
) As CurveLoop
Visual C++
public:
static CurveLoop^ Create(
    IList<Curve^>^ curves
)

Parameters

curves
Type: System.Collections.Generic..::..IList<(Of <(<' Curve >)>)>
The curves.

Return Value

The curve loop.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input curves contains at least one helical curve and is not supported for this operation. -or- Throws if the input curves are not contiguous.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

CurveLoop Class


CreateViaOffset Method

[image] [image]

Revit 2024 API
CurveLoop..::..CreateViaOffset Method
CurveLoop Class See Also Send Feedback

Overload List

Name | Description
CreateViaOffset(CurveLoop, IList<(Of <<'(Double>)>>), XYZ) | Creates a new curve loop that is an offset of the existing curve loop.
CreateViaOffset(CurveLoop, Double, XYZ) | Creates a new curve loop that is an offset of the existing curve loop.

See Also

CurveLoop Class
CurveLoop Members


CreateViaOffset Method (CurveLoop, IList(Double), XYZ)

[image]

Revit 2024 API
CurveLoop..::..CreateViaOffset Method (CurveLoop, IList<(Of <(<'Double>)>)>, XYZ)
CurveLoop Class See Also Send Feedback
Creates a new curve loop that is an offset of the existing curve loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019.1

Syntax

C#
public static CurveLoop CreateViaOffset(
    CurveLoop original,
    IList<double> offsetDists,
    XYZ normal
)
Visual Basic
Public Shared Function CreateViaOffset ( _
    original As CurveLoop, _
    offsetDists As IList(Of Double), _
    normal As XYZ _
) As CurveLoop
Visual C++
public:
static CurveLoop^ CreateViaOffset(
    CurveLoop^ original,
    IList<double>^ offsetDists,
    XYZ^ normal
)

Parameters

original
Type: Autodesk.Revit.DB..::..CurveLoop
The original curve loop.
offsetDists
Type: System.Collections.Generic..::..IList<(Of <(<'Double>)>)>
The signed offset distances for each curve. The size of this array must match the size of the curve loop. Curve at position i will be offset with offsetDists[i].
normal
Type: Autodesk.Revit.DB..::..XYZ
The normal of the offset plane.

Return Value

The offset curve loop.

Remarks

For each curve i in the curve loop, the offset curve is theoretically defined by translating every point of the original curve by the vector offsetDist[i] * (curveTan x normal) where curveTan is the curve's unit tangent vector at the given point. The curves are then trimmed to create a continuous curve loop. For a planar curve loop, this amounts to pushing each point "to the right" of the curve loop by the signed offset distance offsetDist, within the plane of the curve loop. The "right" side of the curve loop at a given point on the curve loop is defined with reference to normal being thought of as the upward direction and curveTan being thought of as the forward direction, as if you are walking along the curve loop. It follows that if offsetDist[i] is positive, points will be offset to the right of the curve loop, whereas if offsetDist[i] is negative, points will be offset to the left of the curve loop.

If the curve loop contains curves such as elliptical segments or splines, it is possible the offset creation will fail if Revit will not be able to trim contiguous curves to meet one another. If the offset is successful, offsets of those curve types will be created as HermiteSplines.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if the curve loop could not be offset.

See Also

CurveLoop Class
CreateViaOffset Overload


CreateViaOffset Method (CurveLoop, Double, XYZ)

[image]

Revit 2024 API
CurveLoop..::..CreateViaOffset Method (CurveLoop, Double, XYZ)
CurveLoop Class See Also Send Feedback
Creates a new curve loop that is an offset of the existing curve loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static CurveLoop CreateViaOffset(
    CurveLoop original,
    double offsetDist,
    XYZ normal
)
Visual Basic
Public Shared Function CreateViaOffset ( _
    original As CurveLoop, _
    offsetDist As Double, _
    normal As XYZ _
) As CurveLoop
Visual C++
public:
static CurveLoop^ CreateViaOffset(
    CurveLoop^ original,
    double offsetDist,
    XYZ^ normal
)

Parameters

original
Type: Autodesk.Revit.DB..::..CurveLoop
The original curve loop.
offsetDist
Type: System..::..Double
The signed offset distance.
normal
Type: Autodesk.Revit.DB..::..XYZ
The normal of the offset plane.

Return Value

The offset curve loop.

Remarks

For each curve in the curve loop, the offset curve is theoretically defined by translating every point of the original curve by the vector offsetDist * (curveTan x normal) where curveTan is the curve's unit tangent vector at the given point. The curves are then trimmed to create a continuous curve loop. For a planar curve loop, this amounts to pushing each point "to the right" of the curve loop by the signed offset distance offsetDist, within the plane of the curve loop. The "right" side of the curve loop at a given point on the curve loop is defined with reference to normal being thought of as the upward direction and curveTan being thought of as the forward direction, as if you are walking along the curve loop. It follows that if offsetDist is positive, points will be offset to the right of the curve loop, whereas if offsetDist is negative, points will be offset to the left of the curve loop.

If the curve loop contains curves such as elliptical segments or splines, it is possible the offset creation will fail if Revit will not be able to trim contiguous curves to meet one another. If the offset is successful, offsets of those curve types will be created as HermiteSplines.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if the curve loop could not be offset.

See Also

CurveLoop Class
CreateViaOffset Overload


CreateViaThicken Method

[image] [image]

Revit 2024 API
CurveLoop..::..CreateViaThicken Method
CurveLoop Class See Also Send Feedback

Overload List

Name | Description
CreateViaThicken(Curve, Double, XYZ) | Creates a new closed curve loop by thickening the input curve with respect to a given plane.
CreateViaThicken(CurveLoop, Double, XYZ) | Creates a new closed curve loop by thickening the input open curve loop with respect to a given plane.

See Also

CurveLoop Class
CurveLoop Members


CreateViaThicken Method (Curve, Double, XYZ)

[image]

Revit 2024 API
CurveLoop..::..CreateViaThicken Method (Curve, Double, XYZ)
CurveLoop Class See Also Send Feedback
Creates a new closed curve loop by thickening the input curve with respect to a given plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static CurveLoop CreateViaThicken(
    Curve pCurve,
    double thickness,
    XYZ normal
)
Visual Basic
Public Shared Function CreateViaThicken ( _
    pCurve As Curve, _
    thickness As Double, _
    normal As XYZ _
) As CurveLoop
Visual C++
public:
static CurveLoop^ CreateViaThicken(
    Curve^ pCurve,
    double thickness,
    XYZ^ normal
)

Parameters

pCurve
Type: Autodesk.Revit.DB..::..Curve
The input curve.
thickness
Type: System..::..Double
The distance between the offset curves created on either side of the input curve.
normal
Type: Autodesk.Revit.DB..::..XYZ
The normal vector to the plane used for thickening.

Return Value

The new curve loop.

Remarks

The new loop will be created via offsets of the input curve (in the plane of the normal vector) with the endpoints connected with lines.The original curve will be at the center of the new loop.

Note that for input elliptical fragments and NurbSpline curves, any offsets will be created as HermiteSplines.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input thickness is too short for a curve. -or- The input pCurve points to a helical curve and is not supported for this operation.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | Throws if the input curve could not be thickened.

See Also

CurveLoop Class
CreateViaThicken Overload


CreateViaThicken Method (CurveLoop, Double, XYZ)

[image]

Revit 2024 API
CurveLoop..::..CreateViaThicken Method (CurveLoop, Double, XYZ)
CurveLoop Class See Also Send Feedback
Creates a new closed curve loop by thickening the input open curve loop with respect to a given plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static CurveLoop CreateViaThicken(
    CurveLoop curveLoop,
    double thickness,
    XYZ normal
)
Visual Basic
Public Shared Function CreateViaThicken ( _
    curveLoop As CurveLoop, _
    thickness As Double, _
    normal As XYZ _
) As CurveLoop
Visual C++
public:
static CurveLoop^ CreateViaThicken(
    CurveLoop^ curveLoop,
    double thickness,
    XYZ^ normal
)

Parameters

curveLoop
Type: Autodesk.Revit.DB..::..CurveLoop
The input curve loop.
thickness
Type: System..::..Double
The distance between the offset curves created on either side of the input curve.
normal
Type: Autodesk.Revit.DB..::..XYZ
The normal vector to the plane used for thickening.

Return Value

The new curve loop.

Remarks

The new loop will be created via offsets of the input curve loop (in the plane of the normal vector) with the endpoints connected with lines.The original curve loop will be at the center of the new loop.

If the curve loop contains curves such as elliptical segments or splines, it is possible the offset creation will fail if Revit will not be able to trim contiguous curves to meet one another. If the offset is successful, offsets of those curve types will be created as HermiteSplines.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input thickness is too short for a curve. -or- the curve loop is not marked as open.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | Throws if the input curve could not be thickened.

See Also

CurveLoop Class
CreateViaThicken Overload


CreateViaTransform Method

[image]

Revit 2024 API
CurveLoop..::..CreateViaTransform Method
CurveLoop Class See Also Send Feedback
Creates a new curve loop as a transformed copy of the input curve loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public static CurveLoop CreateViaTransform(
    CurveLoop curveLoop,
    Transform transform
)
Visual Basic
Public Shared Function CreateViaTransform ( _
    curveLoop As CurveLoop, _
    transform As Transform _
) As CurveLoop
Visual C++
public:
static CurveLoop^ CreateViaTransform(
    CurveLoop^ curveLoop,
    Transform^ transform
)

Parameters

curveLoop
Type: Autodesk.Revit.DB..::..CurveLoop
The input curve loop.
transform
Type: Autodesk.Revit.DB..::..Transform
The transformation.

Return Value

The new curve loop.

Remarks

The newly created CurveLoop is guaranteed to be valid with all consituent curves contiguous (assuming that the curves were contiguous in the input curve loop).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | transform is not conformal. -or- transform has a scale that is negative or zero.

See Also

CurveLoop Class


Dispose Method

[image]

Revit 2024 API
CurveLoop..::..Dispose Method
CurveLoop Class See Also Send Feedback
Releases all resources used by the CurveLoop

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

CurveLoop Class


Flip Method

[image]

Revit 2024 API
CurveLoop..::..Flip Method
CurveLoop Class See Also Send Feedback
Reverses the orientation of the curve loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public void Flip()
Visual Basic
Public Sub Flip
Visual C++
public:
void Flip()

See Also

CurveLoop Class


GetBasicIEnumerator Method

[image]

Revit 2024 API
CurveLoop..::..GetBasicIEnumerator Method
CurveLoop Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
internal virtual IEnumerator GetBasicIEnumerator()
Visual Basic
Friend Overridable Function GetBasicIEnumerator As IEnumerator
Visual C++
internal:
virtual IEnumerator^ GetBasicIEnumerator()

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

CurveLoop Class


GetCurveLoopIterator Method

[image]

Revit 2024 API
CurveLoop..::..GetCurveLoopIterator Method
CurveLoop Class See Also Send Feedback
Returns a curve that iterates through the curve loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public CurveLoopIterator GetCurveLoopIterator()
Visual Basic
Public Function GetCurveLoopIterator As CurveLoopIterator
Visual C++
public:
CurveLoopIterator^ GetCurveLoopIterator()

Return Value

A curve loop iterator object that can be used to iterate through key-value pairs in the collection.

See Also

CurveLoop Class


GetEnumerator Method

[image]

Revit 2024 API
CurveLoop..::..GetEnumerator Method
CurveLoop Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IEnumerator<Curve> GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator(Of Curve)
Visual C++
public:
virtual IEnumerator<Curve^>^ GetEnumerator()

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

CurveLoop Class


GetExactLength Method

[image]

Revit 2024 API
CurveLoop..::..GetExactLength Method
CurveLoop Class See Also Send Feedback
Returns the sum of exact lengths of all curves in the loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public double GetExactLength()
Visual Basic
Public Function GetExactLength As Double
Visual C++
public:
double GetExactLength()

Return Value

The total length of the curves in the loop.

See Also

CurveLoop Class


GetPlane Method

[image]

Revit 2024 API
CurveLoop..::..GetPlane Method
CurveLoop Class See Also Send Feedback
Gets the plane of the curve loop, if it is planar.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public Plane GetPlane()
Visual Basic
Public Function GetPlane As Plane
Visual C++
public:
Plane^ GetPlane()

Return Value

The plane of the curve loop.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The curve loop does not lie in a single plane.

See Also

CurveLoop Class


HasPlane Method

[image]

Revit 2024 API
CurveLoop..::..HasPlane Method
CurveLoop Class See Also Send Feedback
Identifies if the CurveLoop is planar.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool HasPlane()
Visual Basic
Public Function HasPlane As Boolean
Visual C++
public:
bool HasPlane()

Return Value

True if the curve loop is planar, false otherwise.

See Also

CurveLoop Class


IsOpen Method

[image]

Revit 2024 API
CurveLoop..::..IsOpen Method
CurveLoop Class See Also Send Feedback
Returns whether the curve loop is open or closed, as determined by an internal flag.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public bool IsOpen()
Visual Basic
Public Function IsOpen As Boolean
Visual C++
public:
bool IsOpen()

Return Value

True if the CurveLoop is marked open, false if marked closed.

Remarks

Some routines in Revit may set the CurveLoop to be marked "open" or "closed" in spite of the actual geometry of the curves. In these special cases, the CurveLoop class does not require that the CurveLoop is correctly marked.

See Also

CurveLoop Class


IsRectangular Method

[image]

Revit 2024 API
CurveLoop..::..IsRectangular Method
CurveLoop Class See Also Send Feedback
Identifies if the curve loop is rectangular with respect to a given projection plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public bool IsRectangular(
    Plane plane
)
Visual Basic
Public Function IsRectangular ( _
    plane As Plane _
) As Boolean
Visual C++
public:
bool IsRectangular(
    Plane^ plane
)

Parameters

plane
Type: Autodesk.Revit.DB..::..Plane
The plane to which the curves will be projected to determine if they represent a rectangle.

Return Value

True if the curve loop is rectangular, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

CurveLoop Class


NumberOfCurves Method

[image]

Revit 2024 API
CurveLoop..::..NumberOfCurves Method
CurveLoop Class See Also Send Feedback
Returns the number of curves in the curve loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019.1

Syntax

C#
public int NumberOfCurves()
Visual Basic
Public Function NumberOfCurves As Integer
Visual C++
public:
int NumberOfCurves()

Return Value

The number of curves in the curve loop.

See Also

CurveLoop Class


Transform Method

[image]

Revit 2024 API
CurveLoop..::..Transform Method
CurveLoop Class See Also Send Feedback
Transforms this curve loop and all of its component curves by the supplied transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public void Transform(
    Transform transform
)
Visual Basic
Public Sub Transform ( _
    transform As Transform _
)
Visual C++
public:
void Transform(
    Transform^ transform
)

Parameters

transform
Type: Autodesk.Revit.DB..::..Transform
The transformation.

Remarks

The modified CurveLoop is guaranteed to be valid with all consituent curves contiguous (assuming that the curves were contiguous in the input curve loop).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | transform is not conformal. -or- transform has a scale that is negative or zero.

See Also

CurveLoop Class


CurveLoop Properties

[image] [image]

Revit 2024 API
CurveLoop Properties
CurveLoop Class See Also Send Feedback

The CurveLoop type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

CurveLoop Class


IsValidObject Property

[image]

Revit 2024 API
CurveLoop..::..IsValidObject Property
CurveLoop Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

CurveLoop Class


CurveLoopIterator Class

[image]

Revit 2024 API
CurveLoopIterator Class
Members See Also Send Feedback
An iterator to a curve loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public class CurveLoopIterator : IEnumerator<Curve>
Visual Basic
Public Class CurveLoopIterator _
    Implements IEnumerator(Of Curve)
Visual C++
public ref class CurveLoopIterator : IEnumerator<Curve^>

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..CurveLoopIterator

See Also

CurveLoopIterator Members


CurveLoopIterator Methods

[image] [image]

Revit 2024 API
CurveLoopIterator Methods
CurveLoopIterator Class See Also Send Feedback

The CurveLoopIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Increments the iterator to the next item.
Public method | Reset | Resets the iterator to the initial state.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CurveLoopIterator Class


MoveNext Method

[image]

Revit 2024 API
CurveLoopIterator..::..MoveNext Method
CurveLoopIterator Class See Also Send Feedback
Increments the iterator to the next item.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

True if there is a next available item in this iterator. False if the iterator has completed all available items.

Remarks

After an enumerator is created or after the Reset method is called, an enumerator is positioned before the first element of the collection, and the first call to the MoveNext method moves the enumerator over the first element of the collection.

See Also

CurveLoopIterator Class


CurveLoopIterator Properties

[image] [image]

Revit 2024 API
CurveLoopIterator Properties
CurveLoopIterator Class See Also Send Feedback

The CurveLoopIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

CurveLoopIterator Class


Current Property

[image]

Revit 2024 API
CurveLoopIterator..::..Current Property
CurveLoopIterator Class See Also Send Feedback
Gets the item at the current position of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Curve Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Curve
    Get
Visual C++
public:
virtual property Curve^ Current {
    Curve^ get ();
}

Implements

IEnumerator<(Of <(<'T>)>)>..::..Current

Remarks

There is no current item if the iterator has not started yet or has been done.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | There is no current item in the iterator.

See Also

CurveLoopIterator Class


CurrentObject Property

[image]

Revit 2024 API
CurveLoopIterator..::..CurrentObject Property
CurveLoopIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
internal Object CurrentObject { get; }
Visual Basic
Friend ReadOnly Property CurrentObject As Object
    Get
Visual C++
internal:
virtual property Object^ CurrentObject {
    Object^ get () sealed;
}

Implements

IEnumerator..::..Current

See Also

CurveLoopIterator Class


CurveLoopsProfile Members

[image] [image]

Revit 2024 API
CurveLoopsProfile Members
CurveLoopsProfile Class Methods Properties See Also Send Feedback

The CurveLoopsProfile type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Profile | Returns the curve loops of the profile.

See Also

CurveLoopsProfile Class


CurveLoopsProfile Properties

[image] [image]

Revit 2024 API
CurveLoopsProfile Properties
CurveLoopsProfile Class See Also Send Feedback

The CurveLoopsProfile type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Profile | Returns the curve loops of the profile.

See Also

CurveLoopsProfile Class


Profile Property

[image]

Revit 2024 API
CurveLoopsProfile..::..Profile Property
CurveLoopsProfile Class See Also Send Feedback
Returns the curve loops of the profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CurveArrArray Profile { get; set; }
Visual Basic
Public Property Profile As CurveArrArray
    Get
    Set
Visual C++
public:
property CurveArrArray^ Profile {
    CurveArrArray^ get ();
    void set (CurveArrArray^ value);
}

Remarks

This property is used to retrieve the curve loops of profile.

See Also

CurveLoopsProfile Class


CurveNode Members

[image] [image]

Revit 2024 API
CurveNode Members
CurveNode Class Methods Properties See Also Send Feedback

The CurveNode type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RenderNode.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCurve | Returns the geometric curve object corresponding to the node.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode.)
Public property | LineProperties | Access to the line (pen) properties of the curve being drawn (Inherited from ModelCurveNode.)
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode.)

See Also

CurveNode Class


CurveNode Methods

[image] [image]

Revit 2024 API
CurveNode Methods
CurveNode Class See Also Send Feedback

The CurveNode type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RenderNode.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCurve | Returns the geometric curve object corresponding to the node.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CurveNode Class


GetCurve Method

[image]

Revit 2024 API
CurveNode..::..GetCurve Method
CurveNode Class See Also Send Feedback
Returns the geometric curve object corresponding to the node.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public Curve GetCurve()
Visual Basic
Public Function GetCurve As Curve
Visual C++
public:
Curve^ GetCurve()

Return Value

The curve.

See Also

CurveNode Class


CurveNode Properties

[image] [image]

Revit 2024 API
CurveNode Properties
CurveNode Class See Also Send Feedback

The CurveNode type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode.)
Public property | LineProperties | Access to the line (pen) properties of the curve being drawn (Inherited from ModelCurveNode.)
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode.)

See Also

CurveNode Class


CurveProjectionType Enumeration

[image]

Revit 2024 API
CurveProjectionType Enumeration
See Also Send Feedback
This attribute indicates how the curve will be projected to the surface if the curve is sketched on the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public enum CurveProjectionType
Visual Basic
Public Enumeration CurveProjectionType
Visual C++
public enum class CurveProjectionType

Members

Member name | Description
FromTopDown | Projects curve in a direction parallel to the height of the project or family (projects in an upwardly or downwardly direction). For example, would be used to project curves to a surface that represented a roof or site, where the goal was for the curves to look from above as they were sketched, even though they are being mapped to the surface.
ParallelToLevel | The curves are projected to their target surface in a projection direction that is parallel to level. The exact vector of projection also considers the endpoints of the curve being projected or endpoints in a loop of curves it belongs to (if any). But the vector is always parallel to the level. This is used to create curves on the building that retain a particular sketched shape based on elevation perspective, regardless of target surface contours. Sketching windows is an example where this is useful.
FollowSurfaceUV | The curve is generated on to lie on the surface based on its endpoints/control points on the surface, its curve type, and depending on the surface type, either projecting to the surface based on projecting tessellation points of the curve to the target surface, or by interpreting the equation produced by the curve type and user defined control points in the surface uv. In some ways, this is the most robust way to generate the curve on the surface, but for some surface shapes, it can make it difficult to obtain the desired appearance from a particular perspective in the model.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


CurveUV Class

[image]

Revit 2024 API
CurveUV Class
Members See Also Send Feedback
A class that encapsulates the notion of a curve in the 2D parameter space of a surface in 3D space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public class CurveUV : IDisposable
Visual Basic
Public Class CurveUV _
    Implements IDisposable
Visual C++
public ref class CurveUV : IDisposable

Remarks

Revit does not have a class to represent 2D curves explicitly.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..CurveUV

See Also

CurveUV Members


CurveUV Methods

[image] [image]

Revit 2024 API
CurveUV Methods
CurveUV Class See Also Send Feedback

The CurveUV type exposes the following members.

Methods

 | Name | Description
Public method | As3DCurveInXYPlane | Returns a 3D curve lying in the XY plane in XYZ coordinates, representing the 2D curve with its UV coordinates identified with XY coordinates.
Public method | ComputeDerivatives | Computes the first derivative, the second derivative and the unit tangent vector at the specified parameter along the curve.
 | Create | Create a CurveUV from a bounded 3D Curve lying in the XY plane.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates and returns the point at the specified parameter along the curve.
Public method | GetEndParameter | Gets the raw parameter value at the start or end of this curve.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Transform | Transform this CurveUV by the given 2D affine transform if possible.

See Also

CurveUV Class


Create Method

[image]

Revit 2024 API
CurveUV..::..Create Method
CurveUV Class See Also Send Feedback
Create a CurveUV from a bounded 3D Curve lying in the XY plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static CurveUV Create(
    Curve curve3D
)
Visual Basic
Public Shared Function Create ( _
    curve3D As Curve _
) As CurveUV
Visual C++
public:
static CurveUV^ Create(
    Curve^ curve3D
)

Parameters

curve3D
Type: Autodesk.Revit.DB..::..Curve
The input bounded 3D Curve lying in the XY plane (i.e., z = 0 everywhere along the curve).

Return Value

The newly created CurveUV.

Remarks

The XY plane is identified with the uv parameter space of the surface to which this SurfParamSpaceCurve refers.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input Curve is not a bounded 3D Curve lying in the XY plane (i.e., z = 0 everywhere along the curve).
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

CurveUV Class


Dispose Method

[image]

Revit 2024 API
CurveUV..::..Dispose Method
CurveUV Class See Also Send Feedback
Releases all resources used by the CurveUV

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

CurveUV Class


Transform Method

[image]

Revit 2024 API
CurveUV..::..Transform Method
CurveUV Class See Also Send Feedback
Transform this CurveUV by the given 2D affine transform if possible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public CurveUV Transform(
    Transform2D trfUV
)
Visual Basic
Public Function Transform ( _
    trfUV As Transform2D _
) As CurveUV
Visual C++
public:
CurveUV^ Transform(
    Transform2D^ trfUV
)

Parameters

trfUV
Type: Autodesk.Revit.DB..::..Transform2D
The given 2D affine transform.

Return Value

If successful a transformed CurveUV, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

CurveUV Class


CurveUV Properties

[image] [image]

Revit 2024 API
CurveUV Properties
CurveUV Class See Also Send Feedback

The CurveUV type exposes the following members.

Properties

 | Name | Description
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

CurveUV Class


IsBound Property

[image]

Revit 2024 API
CurveUV..::..IsBound Property
CurveUV Class See Also Send Feedback
Describes whether the parameter of the curve is restricted to a particular interval.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public bool IsBound { get; }
Visual Basic
Public ReadOnly Property IsBound As Boolean
    Get
Visual C++
public:
property bool IsBound {
    bool get ();
}

See Also

CurveUV Class


IsValidObject Property

[image]

Revit 2024 API
CurveUV..::..IsValidObject Property
CurveUV Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

CurveUV Class


CustomExporter Members

[image] [image]

Revit 2024 API
CustomExporter Members
CustomExporter Class Constructors Methods Properties See Also Send Feedback

The CustomExporter type exposes the following members.

Constructors

 | Name | Description
Public method | CustomExporter | Constructs a new instance of a CustomExporter for a given document using the input instance of IExportContext as the output device.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the CustomExporter
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Export(IList<(Of <<'(ElementId>)>>)) | Exports a collection of 3D or 2D views
Public method | Export(View) | Exports one 3D or 2D view
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsRenderingSupported | Checks if view rendering is currently supported in the running instance of Revit.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Export2DForceDisplayStyle | This value tells the exporter of 2D views to force the given display mode for the view.
Public property | Export2DGeometricObjectsIncludingPatternLines | This flag sets the exporter of 2D views to either include or exclude output of face pattern lines as part of geometric objects when the model is being processed by the export context.
Public property | Export2DIncludingAnnotationObjects | This flag sets the exporter of 2D views to either include or exclude output of annotation objects when the model is being processed by the export context.
Public property | IncludeGeometricObjects | This flag sets the exporter to either include or exclude output of geometric objects such as faces and curves when the model is being processed by the export context.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ShouldStopOnError | This flag instructs the exporting process to either stop or continue in case an error occurs during any of the exporting methods.

See Also

CustomExporter Class


CustomExporter Constructor

[image]

Revit 2024 API
CustomExporter Constructor
CustomExporter Class See Also Send Feedback
Constructs a new instance of a CustomExporter for a given document using the input instance of IExportContext as the output device.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public CustomExporter(
    Document document,
    IExportContext context
)
Visual Basic
Public Sub New ( _
    document As Document, _
    context As IExportContext _
)
Visual C++
public:
CustomExporter(
    Document^ document,
    IExportContext^ context
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document containing the model to be exported
context
Type: Autodesk.Revit.DB..::..IExportContext
An instance of a context class that will be consuming the output

Remarks

The input context should be an instance of a class that implements either IModelExportContext or IPhotoRenderContext interfaces.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

CustomExporter Class


CustomExporter Methods

[image] [image]

Revit 2024 API
CustomExporter Methods
CustomExporter Class See Also Send Feedback

The CustomExporter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Export(IList<(Of <<'(ElementId>)>>)) | Exports a collection of 3D or 2D views
Public method | Export(View) | Exports one 3D or 2D view
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsRenderingSupported | Checks if view rendering is currently supported in the running instance of Revit.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CustomExporter Class


Dispose Method

[image]

Revit 2024 API
CustomExporter..::..Dispose Method
CustomExporter Class See Also Send Feedback
Releases all resources used by the CustomExporter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

CustomExporter Class


Export Method (IList(ElementId))

[image]

Revit 2024 API
CustomExporter..::..Export Method (IList<(Of <(<'ElementId>)>)>)
CustomExporter Class See Also Send Feedback
Exports a collection of 3D or 2D views

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void Export(
    IList<ElementId> viewIds
)
Visual Basic
Public Sub Export ( _
    viewIds As IList(Of ElementId) _
)
Visual C++
public:
void Export(
    IList<ElementId^>^ viewIds
)

Parameters

viewIds
Type: System.Collections.Generic..::..IList<(Of <(<' ElementId >)>)>
An array of views to export

Remarks

Note that the actual export process may differ depending on the type of export context used. For example, when the IModelExportContext is used, Revit is likely to perform several rounds of traversing each view, which may result in invoking the OnViewBegin/OnViewEnd method multiple times for every one view. It is because Revit draws objects in several layers (model layer, annotation layer, etc.) and will traverse each layer individually. In the most common scenario the user will receive two invocations of OnViewBegin/OnViewEnd: In the first round, all model entities will be received, while in the second round all text annotation elements will be received, if any present in the given view.

Note that all views in the collection must be either 3D or 2D views and they must match the exporter context.

Note that currently the only 2D view types exported are IncludeGeometricObjects FloorPlan, CeilingPlan,Elevation, Section, Detail, EngineeringPlan, AreaPlan.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | One or more elements in viewIds is not a valid exportable view. For example, templates are not considered valid views to export.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The instance of IExportContext is not valid. -or- Rendering is currently not supported in the running instance of Revit. One reason for that to happen is that rendering and material libraries are not currently available.

See Also

CustomExporter Class
Export Overload


Export Method (View)

[image]

Revit 2024 API
CustomExporter..::..Export Method (View)
CustomExporter Class See Also Send Feedback
Exports one 3D or 2D view

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void Export(
    View view
)
Visual Basic
Public Sub Export ( _
    view As View _
)
Visual C++
public:
void Export(
    View^ view
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
An instance of the view to export

Remarks

Note that the actual export process may differ depending on the type of export context used. For example, when the IModelExportContext is used, Revit is likely to perform several rounds of traversing each view, which may result in invoking the OnViewBegin/OnViewEnd method multiple times for every one view. It is because Revit draws objects in several layers (model layer, annotation layer, etc.) and will traverse each layer individually. In the most common scenario the user will receive two invocations of OnViewBegin/OnViewEnd: In the first round, all model entities will be received, while in the second round all text annotation elements will be received, if any present in the given view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The view is not exportable, such as a template view or wrong type view, for example.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The instance of IExportContext is not valid. -or- Rendering is currently not supported in the running instance of Revit. One reason for that to happen is that rendering and material libraries are not currently available.

See Also

CustomExporter Class
Export Overload


IsRenderingSupported Method

[image]

Revit 2024 API
CustomExporter..::..IsRenderingSupported Method
CustomExporter Class See Also Send Feedback
Checks if view rendering is currently supported in the running instance of Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014 UR1

Syntax

C#
public static bool IsRenderingSupported()
Visual Basic
Public Shared Function IsRenderingSupported As Boolean
Visual C++
public:
static bool IsRenderingSupported()

Return Value

Returns True if rendering is currently supported, False otherwise.

Remarks

A typical reason for rendering not being enabled is when rendering and material libraries are not currently available in the installed copy of Revit.

See Also

CustomExporter Class


Export2DForceDisplayStyle Property

[image]

Revit 2024 API
CustomExporter..::..Export2DForceDisplayStyle Property
CustomExporter Class See Also Send Feedback
This value tells the exporter of 2D views to force the given display mode for the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public DisplayStyle Export2DForceDisplayStyle { get; set; }
Visual Basic
Public Property Export2DForceDisplayStyle As DisplayStyle
    Get
    Set
Visual C++
public:
property DisplayStyle Export2DForceDisplayStyle {
    DisplayStyle get ();
    void set (DisplayStyle value);
}

Remarks

Only DisplayStyle::Wireframe and DisplayStyle::HLR values are supported. Default forced value is DisplayStyle::HLR unless the view has DisplayStyle:Wireframe.

See notes for 2D export for views in non-Wireframe display style in [!:Autodesk::Revit::DB::IExportContextBase] and IExportContext2D.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

CustomExporter Class


Export2DGeometricObjectsIncludingPatternLines Property

[image]

Revit 2024 API
CustomExporter..::..Export2DGeometricObjectsIncludingPatternLines Property
CustomExporter Class See Also Send Feedback
This flag sets the exporter of 2D views to either include or exclude output of face pattern lines as part of geometric objects when the model is being processed by the export context.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public bool Export2DGeometricObjectsIncludingPatternLines { get; set; }
Visual Basic
Public Property Export2DGeometricObjectsIncludingPatternLines As Boolean
    Get
    Set
Visual C++
public:
property bool Export2DGeometricObjectsIncludingPatternLines {
    bool get ();
    void set (bool value);
}

Remarks

This flag is ignored if view has Wireframe display style. This flag is ignored unless property "IncludeGeometricObjects" is set to true.

See Also

CustomExporter Class


Export2DIncludingAnnotationObjects Property

[image]

Revit 2024 API
CustomExporter..::..Export2DIncludingAnnotationObjects Property
CustomExporter Class See Also Send Feedback
This flag sets the exporter of 2D views to either include or exclude output of annotation objects when the model is being processed by the export context.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public bool Export2DIncludingAnnotationObjects { get; set; }
Visual Basic
Public Property Export2DIncludingAnnotationObjects As Boolean
    Get
    Set
Visual C++
public:
property bool Export2DIncludingAnnotationObjects {
    bool get ();
    void set (bool value);
}

Remarks

A convenient way of determining whether an element category is annotation is using [!:Autodesk::Revit::DB::Category::CategoryType].

See Also

CustomExporter Class


IncludeGeometricObjects Property

[image]

Revit 2024 API
CustomExporter..::..IncludeGeometricObjects Property
CustomExporter Class See Also Send Feedback
This flag sets the exporter to either include or exclude output of geometric objects such as faces and curves when the model is being processed by the export context.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IncludeGeometricObjects { get; set; }
Visual Basic
Public Property IncludeGeometricObjects As Boolean
    Get
    Set
Visual C++
public:
property bool IncludeGeometricObjects {
    bool get ();
    void set (bool value);
}

Remarks

If geometric objects are to be excluded, the context will not receive any of the calls to related to Faces or Curves. However, the objects will be still processed by Revit resulting in exporting their tessellated geometry in form of polymeshes or lines, respectivelly.

Regardless of the value of this property, the export context must always implement the methods related to receiving of geometric objects (e.g. OnFaceStart, OnFaceEnd, OnCurve, etc.), even though the methods may never be invoked.

Setting this property to False allows clients to significantly speed up the export process. If the export context does not need to examine geometric objects, it is recommended setting this property to False, which will make the export process faster even when compared with export during which notifications about geometric objects are sent, but ignored by the context.

See Also

CustomExporter Class


IsValidObject Property

[image]

Revit 2024 API
CustomExporter..::..IsValidObject Property
CustomExporter Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

CustomExporter Class


ShouldStopOnError Property

[image]

Revit 2024 API
CustomExporter..::..ShouldStopOnError Property
CustomExporter Class See Also Send Feedback
This flag instructs the exporting process to either stop or continue in case an error occurs during any of the exporting methods.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool ShouldStopOnError { get; set; }
Visual Basic
Public Property ShouldStopOnError As Boolean
    Get
    Set
Visual C++
public:
property bool ShouldStopOnError {
    bool get ();
    void set (bool value);
}

See Also

CustomExporter Class


CustomFieldData Class

[image]

Revit 2024 API
CustomFieldData Class
Members See Also Send Feedback
A class that offer access to the information about a custom field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public class CustomFieldData : IDisposable
Visual Basic
Public Class CustomFieldData _
    Implements IDisposable
Visual C++
public ref class CustomFieldData : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..CustomFieldData

See Also

CustomFieldData Members


CustomFieldData Members

[image] [image]

Revit 2024 API
CustomFieldData Members
CustomFieldData Class Methods Properties See Also Send Feedback

The CustomFieldData type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the CustomFieldData
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCustomFieldId | Gets an unique identifier of the custom field.
Public method | GetCustomFieldProperties | Gets an instance of ICustomFieldProperties which represents the properties of this field.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetCustomFieldProperties | Sets an instance of ICustomFieldProperties which represents the properties of this field.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValidateCustomFieldProperties | Validates the custom field properties.

Properties

 | Name | Description
Public property | DefaultRowHeightOnSheet | Identifies the default row height for this field.
Public property | FieldName | The name of this custom field.
Public property | FieldTooltip | The tooltip that will be shown in the schedule properties dialog for this custom field.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

CustomFieldData Class


Dispose Method

[image]

Revit 2024 API
CustomFieldData..::..Dispose Method
CustomFieldData Class See Also Send Feedback
Releases all resources used by the CustomFieldData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

CustomFieldData Class


GetCustomFieldId Method

[image]

Revit 2024 API
CustomFieldData..::..GetCustomFieldId Method
CustomFieldData Class See Also Send Feedback
Gets an unique identifier of the custom field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public Guid GetCustomFieldId()
Visual Basic
Public Function GetCustomFieldId As Guid
Visual C++
public:
Guid GetCustomFieldId()

Return Value

Returns an unique identifier of type of custom field.

See Also

CustomFieldData Class


GetCustomFieldProperties Method

[image]

Revit 2024 API
CustomFieldData..::..GetCustomFieldProperties Method
CustomFieldData Class See Also Send Feedback
Gets an instance of ICustomFieldProperties which represents the properties of this field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public ICustomFieldProperties GetCustomFieldProperties()
Visual Basic
Public Function GetCustomFieldProperties As ICustomFieldProperties
Visual C++
public:
ICustomFieldProperties^ GetCustomFieldProperties()

Return Value

Returns an instance of ICustomFieldProperties.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Can't obtain the properties from a CustomFieldData of a SchedulableField (which is not added to a schedule).

See Also

CustomFieldData Class


SetCustomFieldProperties Method

[image]

Revit 2024 API
CustomFieldData..::..SetCustomFieldProperties Method
CustomFieldData Class See Also Send Feedback
Sets an instance of ICustomFieldProperties which represents the properties of this field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public void SetCustomFieldProperties(
    ICustomFieldProperties customFieldProperties
)
Visual Basic
Public Sub SetCustomFieldProperties ( _
    customFieldProperties As ICustomFieldProperties _
)
Visual C++
public:
void SetCustomFieldProperties(
    ICustomFieldProperties^ customFieldProperties
)

Parameters

customFieldProperties
Type: Autodesk.Revit.DB..::..ICustomFieldProperties
An instance of ICustomFieldProperties which represents the properties of this field.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input properties are not valid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | Can't set the properties to a CustomFieldData of a SchedulableField (which is not added to a schedule).

See Also

CustomFieldData Class


CustomFieldData Properties

[image] [image]

Revit 2024 API
CustomFieldData Properties
CustomFieldData Class See Also Send Feedback

The CustomFieldData type exposes the following members.

Properties

 | Name | Description
Public property | DefaultRowHeightOnSheet | Identifies the default row height for this field.
Public property | FieldName | The name of this custom field.
Public property | FieldTooltip | The tooltip that will be shown in the schedule properties dialog for this custom field.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

CustomFieldData Class


DefaultRowHeightOnSheet Property

[image]

Revit 2024 API
CustomFieldData..::..DefaultRowHeightOnSheet Property
CustomFieldData Class See Also Send Feedback
Identifies the default row height for this field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public double DefaultRowHeightOnSheet { get; }
Visual Basic
Public ReadOnly Property DefaultRowHeightOnSheet As Double
    Get
Visual C++
public:
property double DefaultRowHeightOnSheet {
    double get ();
}

See Also

CustomFieldData Class


CutFailureReason Enumeration

[image]

Revit 2024 API
CutFailureReason Enumeration
See Also Send Feedback
The reason why a solid-solid cut cannot be created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Since: 2012

Syntax

C#
public enum CutFailureReason
Visual Basic
Public Enumeration CutFailureReason
Visual C++
public enum class CutFailureReason

Members

Member name | Description
CutAllowed | Yes, the cutting element can add a cut to the target element.
CutAlreadyExists | The cutting element has already cut the target element.
OppositeCutExists | The target element has already cut the cutting element.
CutNotAppropriateForElements | The cut is not appropriate for the two elements.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


CylindricalFace Members

[image] [image]

Revit 2024 API
CylindricalFace Members
CylindricalFace Class Methods Properties See Also Send Feedback

The CylindricalFace type exposes the following members.

Methods

 | Name | Description
Public method | ComputeDerivatives | Returns the first partial derivatives of the underlying surface at the specified point. (Inherited from Face.)
Public method | ComputeNormal | Returns the normal vector for the face at the given point. (Inherited from Face.)
Public method | ComputeSecondDerivatives | Returns the second partial derivatives of the face at the specified point. (Inherited from Face.)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates and returns the XYZ coordinates of a point at the indicated UV parameterization of the face. (Inherited from Face.)
Public method | GetBoundingBox | Returns the UV bounding box of the face. (Inherited from Face.)
Public method | GetEdgesAsCurveLoops | Returns a list of closed curve loops that correspond to the edge loops of the face. Curves in each curve loop correspond to individual edges. (Inherited from Face.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject.)
Public method | GetRegions | Gets the face regions (created, for example, by the Split Face command) of the face. (Inherited from Face.)
Public method | GetSurface | Returns a copy of this face's surface. (Inherited from Face.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Public method | Intersect(Face) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)
Public method | Intersect(Face, Curve%) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face.)
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional information about the point location. (Inherited from Face.)
Public method | Project | Projects the specified point on the face. (Inherited from Face.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Triangulate()()()() | Returns a triangular mesh approximation to the face. (Inherited from Face.)
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face. (Inherited from Face.)

Properties

 | Name | Description
Public property | Area | The area of this face. (Inherited from Face.)
Public property | Axis | Axis of the surface.
Public property | EdgeLoops | A collection of edge loops. Each edge loop represents one of the closed boundaries of the face. (Inherited from Face.)
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
Public property | HasRegions | Identifies if the face contains regions (which can be created, for example, by the Split Face command). (Inherited from Face.)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject.)
Public property | IsCyclic | Indicates whether the underlying surface is periodic in the specified parametric direction. (Inherited from Face.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate). (Inherited from Face.)
Public property | MaterialElementId | The element ID of the material from which this face is composed. (Inherited from Face.)
Public property | OrientationMatchesSurfaceOrientation | Returns true if this face's orientation matches the orientation of the face's surface, false if they have opposite orientations. (Inherited from Face.)
Public property | Origin | Origin of the surface.
Public property | Period | The period of the underlying surface in the specified parametric direction. (Inherited from Face.)
Public property | Radius | Radii of the surface.
Public property | Reference | Returns a stable reference to the face. (Inherited from Face.)
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

CylindricalFace Class


CylindricalFace Methods

[image] [image]

Revit 2024 API
CylindricalFace Methods
CylindricalFace Class See Also Send Feedback

The CylindricalFace type exposes the following members.

Methods

 | Name | Description
Public method | ComputeDerivatives | Returns the first partial derivatives of the underlying surface at the specified point. (Inherited from Face.)
Public method | ComputeNormal | Returns the normal vector for the face at the given point. (Inherited from Face.)
Public method | ComputeSecondDerivatives | Returns the second partial derivatives of the face at the specified point. (Inherited from Face.)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates and returns the XYZ coordinates of a point at the indicated UV parameterization of the face. (Inherited from Face.)
Public method | GetBoundingBox | Returns the UV bounding box of the face. (Inherited from Face.)
Public method | GetEdgesAsCurveLoops | Returns a list of closed curve loops that correspond to the edge loops of the face. Curves in each curve loop correspond to individual edges. (Inherited from Face.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject.)
Public method | GetRegions | Gets the face regions (created, for example, by the Split Face command) of the face. (Inherited from Face.)
Public method | GetSurface | Returns a copy of this face's surface. (Inherited from Face.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Public method | Intersect(Face) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)
Public method | Intersect(Face, Curve%) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face.)
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional information about the point location. (Inherited from Face.)
Public method | Project | Projects the specified point on the face. (Inherited from Face.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Triangulate()()()() | Returns a triangular mesh approximation to the face. (Inherited from Face.)
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face. (Inherited from Face.)

See Also

CylindricalFace Class


Intersect Method

[image] [image]

Revit 2024 API
CylindricalFace..::..Intersect Method
CylindricalFace Class See Also Send Feedback
Calculates the intersection of the specified curve with this face.

Overload List

 | Name | Description
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Public method | Intersect(Face) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)
Public method | Intersect(Face, Curve%) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face.)

See Also

CylindricalFace Class
CylindricalFace Members


IsInside Method

[image] [image]

Revit 2024 API
CylindricalFace..::..IsInside Method
CylindricalFace Class See Also Send Feedback
Indicates whether the specified point is within this face.

Overload List

 | Name | Description
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional information about the point location. (Inherited from Face.)

See Also

CylindricalFace Class
CylindricalFace Members


Triangulate Method

[image] [image]

Revit 2024 API
CylindricalFace..::..Triangulate Method
CylindricalFace Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Triangulate()()()() | Returns a triangular mesh approximation to the face. (Inherited from Face.)
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face. (Inherited from Face.)

See Also

CylindricalFace Class
CylindricalFace Members


Axis Property

[image]

Revit 2024 API
CylindricalFace..::..Axis Property
CylindricalFace Class See Also Send Feedback
Axis of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ Axis { get; }
Visual Basic
Public ReadOnly Property Axis As XYZ
    Get
Visual C++
public:
property XYZ^ Axis {
    XYZ^ get ();
}

See Also

CylindricalFace Class


Origin Property

[image]

Revit 2024 API
CylindricalFace..::..Origin Property
CylindricalFace Class See Also Send Feedback
Origin of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ Origin { get; }
Visual Basic
Public ReadOnly Property Origin As XYZ
    Get
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
}

See Also

CylindricalFace Class


Radius Property

[image]

Revit 2024 API
CylindricalFace..::..Radius Property
CylindricalFace Class See Also Send Feedback
Radii of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ this[
    int index
] { get; }
Visual Basic
Public ReadOnly Property Radius ( _
    index As Integer _
) As XYZ
    Get
Visual C++
public:
property XYZ^ Radius[int index] {
    XYZ^ get (int index);
}

Parameters

index
Type: System..::..Int32

See Also

CylindricalFace Class


CylindricalHelix Members

[image] [image]

Revit 2024 API
CylindricalHelix Members
CylindricalHelix Class Methods Properties See Also Send Feedback

The CylindricalHelix type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns a copy of this curve. (Inherited from Curve.)
Public method | ComputeClosestPoints | Find the closest points between two curves. Closest points mean closest pairs of points, each pair consisting of a point on this, say P1, and a point on other curve, say P2. P1 and P2 are closest locally. Each pairs of closest points will be represented by the corresponding parameter values with respect to the two curves and the 3d points. A closest pair is also known as a pair of critical points of the distance function between points of the two curves. If the input parameter returnAllCriticalPoints is set to false, then the function will return only pairs with minimum distance. (Inherited from Curve.)
Public method | ComputeDerivatives | Returns the vectors describing the curve at the specified parameter. (Inherited from Curve.)
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve.)
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve.)
 | Create | Create a cylindrical helix.
Public method | CreateOffset | Creates a new curve that is an offset of the existing curve. (Inherited from Curve.)
Public method | CreateReversed | Creates a new curve with the opposite orientation of the existing curve. (Inherited from Curve.)
Public method | CreateTransformed | Crates a new instance of a curve as a transformation of this curve. (Inherited from Curve.)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates and returns the point that matches a parameter along the curve. (Inherited from Curve.)
Public method | GetEndParameter | Returns the raw parameter value at the start or end of this curve. (Inherited from Curve.)
Public method | GetEndPoint | Returns the 3D point at the start or end of this curve. (Inherited from Curve.)
Public method | GetEndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve.)
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve.)
Public method | IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve.)
Public method | MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve.)
Public method | MakeUnbound | Makes this curve unbound. (Inherited from Curve.)
Public method | Project | Projects the specified point on this curve. (Inherited from Curve.)
Public method | SetGraphicsStyleId | Sets the graphics style id for this curve. (Inherited from Curve.)
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
Public property | BasePoint | The base point of the axis of the cylindrical helix.
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
Public property | Height | Height of the cylindrical helix.
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject.)
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
Public property | IsClosed | Describes whether the curve is closed. (Inherited from Curve.)
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsRightHanded | True if the helix is right handed, false if the helix is left handed.
Public property | Length | The exact length of the curve. (Inherited from Curve.)
Public property | Period | The period of this curve. (Inherited from Curve.)
Public property | Pitch | The pitch of the cylindrical helix.
Public property | Radius | The radius of the cylindrical helix.
Public property | Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Public property | Visibility | The visibility. (Inherited from GeometryObject.)
Public property | XVector | The X direction vector.
Public property | YVector | The Y direction vector.
Public property | ZVector | The Z direction vector, which is same as the axis direction vector.

See Also

CylindricalHelix Class


Create Method

[image]

Revit 2024 API
CylindricalHelix..::..Create Method
CylindricalHelix Class See Also Send Feedback
Create a cylindrical helix.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static CylindricalHelix Create(
    XYZ basePoint,
    double radius,
    XYZ xVector,
    XYZ zVector,
    double pitch,
    double startAngle,
    double endAngle
)
Visual Basic
Public Shared Function Create ( _
    basePoint As XYZ, _
    radius As Double, _
    xVector As XYZ, _
    zVector As XYZ, _
    pitch As Double, _
    startAngle As Double, _
    endAngle As Double _
) As CylindricalHelix
Visual C++
public:
static CylindricalHelix^ Create(
    XYZ^ basePoint,
    double radius,
    XYZ^ xVector,
    XYZ^ zVector,
    double pitch,
    double startAngle,
    double endAngle
)

Parameters

basePoint
Type: Autodesk.Revit.DB..::..XYZ
Base point of the axis. It can be any point in 3d.
radius
Type: System..::..Double
Radius. It should be a positive number.
xVector
Type: Autodesk.Revit.DB..::..XYZ
X vector. Should be Non-zero vector.
zVector
Type: Autodesk.Revit.DB..::..XYZ
Z vector = axis direction. Should be non-zero and orthogonal to X Vector.
pitch
Type: System..::..Double
Pitch. It should be non-zero number, can be positive or negative. Positive means right handed and negative means left handed.
startAngle
Type: System..::..Double
Start angle. It specifies the start point of the Helix.
endAngle
Type: System..::..Double
End angle. It specifies the end point of the Helix. End angle should not be equal to start angle.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The radius is negative -or- the pitch is zero -or- the xVector or zVector is zero length -or- zVector is not orthogonal to xVector -or- endAngle is equal to startAngle.

See Also

CylindricalHelix Class


CylindricalHelix Properties

[image] [image]

Revit 2024 API
CylindricalHelix Properties
CylindricalHelix Class See Also Send Feedback

The CylindricalHelix type exposes the following members.

Properties

 | Name | Description
Public property | ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
Public property | BasePoint | The base point of the axis of the cylindrical helix.
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
Public property | Height | Height of the cylindrical helix.
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject.)
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
Public property | IsClosed | Describes whether the curve is closed. (Inherited from Curve.)
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsRightHanded | True if the helix is right handed, false if the helix is left handed.
Public property | Length | The exact length of the curve. (Inherited from Curve.)
Public property | Period | The period of this curve. (Inherited from Curve.)
Public property | Pitch | The pitch of the cylindrical helix.
Public property | Radius | The radius of the cylindrical helix.
Public property | Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Public property | Visibility | The visibility. (Inherited from GeometryObject.)
Public property | XVector | The X direction vector.
Public property | YVector | The Y direction vector.
Public property | ZVector | The Z direction vector, which is same as the axis direction vector.

See Also

CylindricalHelix Class


BasePoint Property

[image]

Revit 2024 API
CylindricalHelix..::..BasePoint Property
CylindricalHelix Class See Also Send Feedback
The base point of the axis of the cylindrical helix.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ BasePoint { get; }
Visual Basic
Public ReadOnly Property BasePoint As XYZ
    Get
Visual C++
public:
property XYZ^ BasePoint {
    XYZ^ get ();
}

See Also

CylindricalHelix Class


Height Property

[image]

Revit 2024 API
CylindricalHelix..::..Height Property
CylindricalHelix Class See Also Send Feedback
Height of the cylindrical helix.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double Height { get; }
Visual Basic
Public ReadOnly Property Height As Double
    Get
Visual C++
public:
property double Height {
    double get ();
}

Remarks

It is the length of the span of the helix along the axis direction. The height is defined only if the helix is bounded. That is, its start and end angles (parameters) are specified.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | Height is not defined for unbounded helix.

See Also

CylindricalHelix Class


IsRightHanded Property

[image]

Revit 2024 API
CylindricalHelix..::..IsRightHanded Property
CylindricalHelix Class See Also Send Feedback
True if the helix is right handed, false if the helix is left handed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsRightHanded { get; }
Visual Basic
Public ReadOnly Property IsRightHanded As Boolean
    Get
Visual C++
public:
property bool IsRightHanded {
    bool get ();
}

See Also

CylindricalHelix Class


Pitch Property

[image]

Revit 2024 API
CylindricalHelix..::..Pitch Property
CylindricalHelix Class See Also Send Feedback
The pitch of the cylindrical helix.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double Pitch { get; }
Visual Basic
Public ReadOnly Property Pitch As Double
    Get
Visual C++
public:
property double Pitch {
    double get ();
}

Remarks

It is the distance moved along the axis direction when a point makes one rotation about the axis. Pitch can be positive or negative.

See Also

CylindricalHelix Class


Radius Property

[image]

Revit 2024 API
CylindricalHelix..::..Radius Property
CylindricalHelix Class See Also Send Feedback
The radius of the cylindrical helix.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double Radius { get; }
Visual Basic
Public ReadOnly Property Radius As Double
    Get
Visual C++
public:
property double Radius {
    double get ();
}

See Also

CylindricalHelix Class


YVector Property

[image]

Revit 2024 API
CylindricalHelix..::..YVector Property
CylindricalHelix Class See Also Send Feedback
The Y direction vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ YVector { get; }
Visual Basic
Public ReadOnly Property YVector As XYZ
    Get
Visual C++
public:
property XYZ^ YVector {
    XYZ^ get ();
}

See Also

CylindricalHelix Class


ZVector Property

[image]

Revit 2024 API
CylindricalHelix..::..ZVector Property
CylindricalHelix Class See Also Send Feedback
The Z direction vector, which is same as the axis direction vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ ZVector { get; }
Visual Basic
Public ReadOnly Property ZVector As XYZ
    Get
Visual C++
public:
property XYZ^ ZVector {
    XYZ^ get ();
}

See Also

CylindricalHelix Class


CylindricalSurface Class

[image]

Revit 2024 API
CylindricalSurface Class
Members See Also Send Feedback
A cylindrical surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public class CylindricalSurface : Surface
Visual Basic
Public Class CylindricalSurface _
    Inherits Surface
Visual C++
public ref class CylindricalSurface : public Surface

Remarks

The parametric equation of the cylinder is S(u, v) = center + radius*cos(u)*xVec + radius*sin(u)*yVec + v*zVec.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Surface
Autodesk.Revit.DB..::..CylindricalSurface

See Also

CylindricalSurface Members


CylindricalSurface Members

[image] [image]

Revit 2024 API
CylindricalSurface Members
CylindricalSurface Class Methods Properties See Also Send Feedback

The CylindricalSurface type exposes the following members.

Methods

 | Name | Description
 | Create | Construct a cylindrical surface defined by a local coordinate system and a radius.
Public method | Dispose | (Inherited from Surface.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBoundingBoxUV | Gets the UV bounding box of the surface. (Inherited from Surface.)
Public method | GetFrameOfReference | Returns frame of reference associated with this CylindricalSurface.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Project | Project a 3D point orthogonally onto a surface (to find the nearest point). Throws InvalidOperationException if the projection fails. (Inherited from Surface.)
Public method | ProjectWithGuessPoint | Project a 3D point orthogonally onto a surface (to find the nearest point). This method is meant to be used when a good approximate solution for the projection is available. Throws InvalidOperationException if the projection fails. (Inherited from Surface.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Axis | Axis of the cylinder. This is the Z axis of the local coordinate system associated with this cylinder.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Surface.)
Public property | OrientationMatchesParametricOrientation | Indicates whether this Surface's orientation is the same as or opposite to its parametric orientation. (Inherited from Surface.)
Public property | Origin | Center of the circle that defines the base of the cylinder. This is the origin of the local coordinate system associated with this cylinder.
Public property | Radius | Radius of the circle that defines the base of this cylinder.
Public property | XDir | X axis of the local coordinate system associated with this cylinder.
Public property | YDir | Y axis of the local coordinate system associated with this cylinder.

See Also

CylindricalSurface Class


CylindricalSurface Methods

[image] [image]

Revit 2024 API
CylindricalSurface Methods
CylindricalSurface Class See Also Send Feedback

The CylindricalSurface type exposes the following members.

Methods

 | Name | Description
 | Create | Construct a cylindrical surface defined by a local coordinate system and a radius.
Public method | Dispose | (Inherited from Surface.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBoundingBoxUV | Gets the UV bounding box of the surface. (Inherited from Surface.)
Public method | GetFrameOfReference | Returns frame of reference associated with this CylindricalSurface.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Project | Project a 3D point orthogonally onto a surface (to find the nearest point). Throws InvalidOperationException if the projection fails. (Inherited from Surface.)
Public method | ProjectWithGuessPoint | Project a 3D point orthogonally onto a surface (to find the nearest point). This method is meant to be used when a good approximate solution for the projection is available. Throws InvalidOperationException if the projection fails. (Inherited from Surface.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CylindricalSurface Class


Create Method

[image]

Revit 2024 API
CylindricalSurface..::..Create Method
CylindricalSurface Class See Also Send Feedback
Construct a cylindrical surface defined by a local coordinate system and a radius.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public static CylindricalSurface Create(
    Frame frameOfReference,
    double radius
)
Visual Basic
Public Shared Function Create ( _
    frameOfReference As Frame, _
    radius As Double _
) As CylindricalSurface
Visual C++
public:
static CylindricalSurface^ Create(
    Frame^ frameOfReference,
    double radius
)

Parameters

frameOfReference
Type: Autodesk.Revit.DB..::..Frame
frameOfReference is an orthonormal frame that defines a local coordinate system for the cylinder.
  • Frame.Origin is a point on the cylinder's axis.
  • Frame.BasisZ points along the axis, while Frame.BasisX and Frame.BasisY are orthogonal to the axis.
  • The frame may be either left-handed or right-handed (see Frame.IsRightHanded). Note that the "handedness" of the frame does not, by itself, determine the surface's orientation.
radius
Type: System..::..Double
Radius of the circle that defines the base of the cylindrical surface.

Return Value

The created CylindricalSurface.

Remarks

The parametric equation of the cylinder is S(u, v) = Frame.Origin + radius*cos(u)*Frame.BasisX + radius*sin(u)*Frame.BasisY + v*Frame.BasisZ. This implies the following facts:
  • Frame.BasisX points from the axis point to the point on the cylinder with coordinates (0, 0).
  • Frame.BasisY points in the direction of the partial derivative dS/du at (0, 0).
  • Frame.BasisZ points in the direction of the partial derivative dS/dv at (0, 0).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This Frame object may not be used as a local frame of reference.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given value for radius must be greater than 0 and no more than 30000 feet.

See Also

CylindricalSurface Class


GetFrameOfReference Method

[image]

Revit 2024 API
CylindricalSurface..::..GetFrameOfReference Method
CylindricalSurface Class See Also Send Feedback
Returns frame of reference associated with this CylindricalSurface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public Frame GetFrameOfReference()
Visual Basic
Public Function GetFrameOfReference As Frame
Visual C++
public:
Frame^ GetFrameOfReference()

Return Value

Frame of reference associated with this CylindricalSurface.

Remarks

This is an equivalent of new Frame(Origin, XDir, YDir, Axis).

See Also

CylindricalSurface Class


Radius Property

[image]

Revit 2024 API
CylindricalSurface..::..Radius Property
CylindricalSurface Class See Also Send Feedback
Radius of the circle that defines the base of this cylinder.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public double Radius { get; }
Visual Basic
Public ReadOnly Property Radius As Double
    Get
Visual C++
public:
property double Radius {
    double get ();
}

See Also

CylindricalSurface Class


XDir Property

[image]

Revit 2024 API
CylindricalSurface..::..XDir Property
CylindricalSurface Class See Also Send Feedback
X axis of the local coordinate system associated with this cylinder.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public XYZ XDir { get; }
Visual Basic
Public ReadOnly Property XDir As XYZ
    Get
Visual C++
public:
property XYZ^ XDir {
    XYZ^ get ();
}

See Also

CylindricalSurface Class


DataConversionMonitorScope Class

[image]

Revit 2024 API
DataConversionMonitorScope Class
Members See Also Send Feedback
This class is used to regsiter an application-supplied object that implements IDataConversionMonitor. Creating the object registers an implementation of IDataConversionMonitor supplied as constructor argument. When the scope object is destroyed, that object is unregistered.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public class DataConversionMonitorScope : IDisposable
Visual Basic
Public Class DataConversionMonitorScope _
    Implements IDisposable
Visual C++
public ref class DataConversionMonitorScope : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..DataConversionMonitorScope

See Also

DataConversionMonitorScope Members


DataConversionMonitorScope Members

[image] [image]

Revit 2024 API
DataConversionMonitorScope Members
DataConversionMonitorScope Class Constructors Methods Properties See Also Send Feedback

The DataConversionMonitorScope type exposes the following members.

Constructors

 | Name | Description
Public method | DataConversionMonitorScope | The only constructor. Expects a valid pointer to IDataConversionMonitor.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the DataConversionMonitorScope
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

DataConversionMonitorScope Class


DataConversionMonitorScope Constructor

[image]

Revit 2024 API
DataConversionMonitorScope Constructor
DataConversionMonitorScope Class See Also Send Feedback
The only constructor. Expects a valid pointer to IDataConversionMonitor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public DataConversionMonitorScope(
    IDataConversionMonitor IDCM
)
Visual Basic
Public Sub New ( _
    IDCM As IDataConversionMonitor _
)
Visual C++
public:
DataConversionMonitorScope(
    IDataConversionMonitor^ IDCM
)

Parameters

IDCM
Type: Autodesk.Revit.DB..::..IDataConversionMonitor

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DataConversionMonitorScope Class


DataConversionMonitorScope Methods

[image] [image]

Revit 2024 API
DataConversionMonitorScope Methods
DataConversionMonitorScope Class See Also Send Feedback

The DataConversionMonitorScope type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DataConversionMonitorScope Class


Dispose Method

[image]

Revit 2024 API
DataConversionMonitorScope..::..Dispose Method
DataConversionMonitorScope Class See Also Send Feedback
Releases all resources used by the DataConversionMonitorScope

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

DataConversionMonitorScope Class


IsValidObject Property

[image]

Revit 2024 API
DataConversionMonitorScope..::..IsValidObject Property
DataConversionMonitorScope Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

DataConversionMonitorScope Class


DataExchangeMessageSeverity Enumeration

[image]

Revit 2024 API
DataExchangeMessageSeverity Enumeration
See Also Send Feedback
Error levels for DataExchangeLog

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016
Since: 2016

Syntax

C#
public enum DataExchangeMessageSeverity
Visual Basic
Public Enumeration DataExchangeMessageSeverity
Visual C++
public enum class DataExchangeMessageSeverity

Members

Member name | Description
Info | Informational message, such as successful creation fo a face, edge or a solid.
Warning | A potential problem. The converted data should be carefully examined and/or compared to the source data
Error | A problem. The converted data should be carefully examined and/or compared to the source data. The application may want to cancel the conversion process.
FatalError | A serious problem that makes further data conversion pointless. The conversion process will be cancelled.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


DataExchangeMessageVerbosity Enumeration

[image]

Revit 2024 API
DataExchangeMessageVerbosity Enumeration
See Also Send Feedback
Predefined verbosity levels for DataExchangeLog

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016
Since: 2016

Syntax

C#
public enum DataExchangeMessageVerbosity
Visual Basic
Public Enumeration DataExchangeMessageVerbosity
Visual C++
public enum class DataExchangeMessageVerbosity

Members

Member name | Description
Minimal | Minimal verbosity. Only fatal errors are reported.
Default | Default verbosity. Warnings, errors, fatal errors are reported.
Verbose | All events are reported.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


DatumEnds Enumeration

[image]

Revit 2024 API
DatumEnds Enumeration
See Also Send Feedback
An enumerated type representing ends of a datum plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public enum DatumEnds
Visual Basic
Public Enumeration DatumEnds
Visual C++
public enum class DatumEnds

Members

Member name | Description
End0 | The start point of the datum plane in the view.
End1 | The end point of the datum plane in the view.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


DatumExtentType Enumeration

[image]

Revit 2024 API
DatumExtentType Enumeration
See Also Send Feedback
Represents the type of datum extent that is displayed in a particular view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public enum DatumExtentType
Visual Basic
Public Enumeration DatumExtentType
Visual C++
public enum class DatumExtentType

Members

Member name | Description
Model | The extent represents the actual 3D extent of the datum plane.
ViewSpecific | The extent displayed is specific to the view and does not represent the actual 3D extent of the datum plane.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


DatumPlane Class

[image]

Revit 2024 API
DatumPlane Class
Members See Also Send Feedback
A base class representing a datum surface (level, grid or reference plane) in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public class DatumPlane : Element
Visual Basic
Public Class DatumPlane _
    Inherits Element
Visual C++
public ref class DatumPlane : public Element

Remarks

A DatumPlane represents a 3d surface with finite extents. It can be either a rectangle with arbitrary orientation, or a cylinder whose axis is parallel to the project z-axis. If a datum is visible in a plan or section view, it will be displayed as one or more curves. These curves are determined by the intersection of the datum surface with the cut plane of the view. By default, the extents of these curves reflect the 3d extents of the datum surface. If the surface is a plane, then the extents represent the projection of the surface onto the cut plane. This matters, for example, when viewing a datum plane, really a 3d rectangle, along one of its diagonals. The extents of the curve do not vary with the location of the view, because we use the projection of the rectangle and not the actual intersection. If the surface is a cylinder, then the extents reflect the actual intersection of the surface with the cut plane. In addition, the curves that represent a DatumPlane can be modified on a view specific basis. In this case, the ends of the curve no longer reflect the 3d extents of the datum.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..DatumPlane
Autodesk.Revit.DB..::..Grid
Autodesk.Revit.DB..::..Level
Autodesk.Revit.DB..::..ReferencePlane

See Also

DatumPlane Members


DatumPlane Members

[image] [image]

Revit 2024 API
DatumPlane Members
DatumPlane Class Methods Properties See Also Send Feedback

The DatumPlane type exposes the following members.

Methods

 | Name | Description
Public method | AddLeader | Adds a default Leader for the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders).
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanBeVisibleInView | Checks if the datum plane can be visible in the view.
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetCurvesInView | Gets a collection of curves representing the DatumPlane element in the given view.
Public method | GetDatumExtentTypeInView | Identifies whether the curve representing the datum plane is displayed according to its actual 3d extents, or else according to a view specific setting.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLeader | Gets a copy of the leader applied to the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders).
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPropagationViews | Gets a list of candidate views which are parallel to the current view and to which the extents of the datum may be propagated.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasBubbleInView | Identifies if the DatumPlane has bubble or not.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HideBubbleInView | Hides the bubble in a view. This method does not apply to Reference planes.
Public method | IsBubbleVisibleInView | Identifies if the bubble is visible or not in a view.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsCurveValidInView | Checks if the curve is valid to be as the extents for the datum plane in a view. The curve must be bound and coincident with the original one of the datum plane.
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsLeaderValid | Identifies if the leader valid or not for this DatumPlane. This method does not apply to Reference planes (which do not support leaders).
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | Maximize3DExtents | Computes the 3d extents of all model geometry and levels, and extends the 3d extents of this datum surface to include the model extents.
Public method | PropagateToViews | Propagates the extents applied to this datum in the view to the specified parallel views.
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetCurveInView | Sets the extents to match the curve.
Public method | SetDatumExtentType | Sets whether the curve representing the datum plane is displayed according to its 3d extents, or else according to a view specific setting.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetLeader | Sets the leader to the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders).
Public method | ShowBubbleInView | Shows the bubble in a view. This method does not apply to Reference planes.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DatumPlane Class


DatumPlane Methods

[image] [image]

Revit 2024 API
DatumPlane Methods
DatumPlane Class See Also Send Feedback

The DatumPlane type exposes the following members.

Methods

 | Name | Description
Public method | AddLeader | Adds a default Leader for the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders).
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanBeVisibleInView | Checks if the datum plane can be visible in the view.
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetCurvesInView | Gets a collection of curves representing the DatumPlane element in the given view.
Public method | GetDatumExtentTypeInView | Identifies whether the curve representing the datum plane is displayed according to its actual 3d extents, or else according to a view specific setting.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLeader | Gets a copy of the leader applied to the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders).
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPropagationViews | Gets a list of candidate views which are parallel to the current view and to which the extents of the datum may be propagated.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasBubbleInView | Identifies if the DatumPlane has bubble or not.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HideBubbleInView | Hides the bubble in a view. This method does not apply to Reference planes.
Public method | IsBubbleVisibleInView | Identifies if the bubble is visible or not in a view.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsCurveValidInView | Checks if the curve is valid to be as the extents for the datum plane in a view. The curve must be bound and coincident with the original one of the datum plane.
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsLeaderValid | Identifies if the leader valid or not for this DatumPlane. This method does not apply to Reference planes (which do not support leaders).
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | Maximize3DExtents | Computes the 3d extents of all model geometry and levels, and extends the 3d extents of this datum surface to include the model extents.
Public method | PropagateToViews | Propagates the extents applied to this datum in the view to the specified parallel views.
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetCurveInView | Sets the extents to match the curve.
Public method | SetDatumExtentType | Sets whether the curve representing the datum plane is displayed according to its 3d extents, or else according to a view specific setting.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetLeader | Sets the leader to the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders).
Public method | ShowBubbleInView | Shows the bubble in a view. This method does not apply to Reference planes.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DatumPlane Class


AddLeader Method

[image]

Revit 2024 API
DatumPlane..::..AddLeader Method
DatumPlane Class See Also Send Feedback
Adds a default Leader for the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public Leader AddLeader(
    DatumEnds datumEnd,
    View view
)
Visual Basic
Public Function AddLeader ( _
    datumEnd As DatumEnds, _
    view As View _
) As Leader
Visual C++
public:
Leader^ AddLeader(
    DatumEnds datumEnd,
    View^ view
)

Parameters

datumEnd
Type: Autodesk.Revit.DB..::..DatumEnds
The end of the datum plane.
view
Type: Autodesk.Revit.DB..::..View
The view on which the DatumPlane shows.

Return Value

The Leader of the datum plane. Null will return if the view is null.

Remarks

The leader can be added only to ends where the bubble is set to be shown and does not have a leader applied.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The datum plane cannot be visible in the view. -or- The bubble is not visible at the datumEnd of the datum plane.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | This datum plane has no leaders. -or- The DatumPlane already has a leader applied.

See Also

DatumPlane Class


CanBeVisibleInView Method

[image]

Revit 2024 API
DatumPlane..::..CanBeVisibleInView Method
DatumPlane Class See Also Send Feedback
Checks if the datum plane can be visible in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool CanBeVisibleInView(
    View view
)
Visual Basic
Public Function CanBeVisibleInView ( _
    view As View _
) As Boolean
Visual C++
public:
bool CanBeVisibleInView(
    View^ view
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view.

Return Value

True if visible, false otherwise.

Remarks

This method determines if the orientation of the DatumPlane and View allows that the DatumPlane can be seen in the indicated view. It does not actually determine if the DatumPlane is visible, as many factors can affect the visibility of an element in a given view (for example, hiding the element).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DatumPlane Class


GetCurvesInView Method

[image]

Revit 2024 API
DatumPlane..::..GetCurvesInView Method
DatumPlane Class See Also Send Feedback
Gets a collection of curves representing the DatumPlane element in the given view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public IList<Curve> GetCurvesInView(
    DatumExtentType extentMode,
    View view
)
Visual Basic
Public Function GetCurvesInView ( _
    extentMode As DatumExtentType, _
    view As View _
) As IList(Of Curve)
Visual C++
public:
IList<Curve^>^ GetCurvesInView(
    DatumExtentType extentMode,
    View^ view
)

Parameters

extentMode
Type: Autodesk.Revit.DB..::..DatumExtentType
The extent type.
view
Type: Autodesk.Revit.DB..::..View
The view.

Return Value

The curves.

Remarks

Curves returned for Model extents can be different than curves returned for View-specific extents (2d extents) in the given view. In some cases, such as an arc grid in a section view, there will be two identical curves but offset from one another.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The datum plane cannot be visible in the view.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

DatumPlane Class


GetDatumExtentTypeInView Method

[image]

Revit 2024 API
DatumPlane..::..GetDatumExtentTypeInView Method
DatumPlane Class See Also Send Feedback
Identifies whether the curve representing the datum plane is displayed according to its actual 3d extents, or else according to a view specific setting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public DatumExtentType GetDatumExtentTypeInView(
    DatumEnds datumEnd,
    View view
)
Visual Basic
Public Function GetDatumExtentTypeInView ( _
    datumEnd As DatumEnds, _
    view As View _
) As DatumExtentType
Visual C++
public:
DatumExtentType GetDatumExtentTypeInView(
    DatumEnds datumEnd,
    View^ view
)

Parameters

datumEnd
Type: Autodesk.Revit.DB..::..DatumEnds
Specifies one end of the curve representing the datum plane in the view.
view
Type: Autodesk.Revit.DB..::..View
The view in which to evaluate the datum extent settings.

Return Value

The extent type.

Remarks

In a particular view, the datum plane is represented by a curve and the two ends of the curve may have different DatumExtentTypes in that view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The datum plane cannot be visible in the view.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

DatumPlane Class


GetLeader Method

[image]

Revit 2024 API
DatumPlane..::..GetLeader Method
DatumPlane Class See Also Send Feedback
Gets a copy of the leader applied to the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public Leader GetLeader(
    DatumEnds datumEnd,
    View view
)
Visual Basic
Public Function GetLeader ( _
    datumEnd As DatumEnds, _
    view As View _
) As Leader
Visual C++
public:
Leader^ GetLeader(
    DatumEnds datumEnd,
    View^ view
)

Parameters

datumEnd
Type: Autodesk.Revit.DB..::..DatumEnds
The end of the datum plane.
view
Type: Autodesk.Revit.DB..::..View
The view on which the DatumPlane shows.

Return Value

The Leader of the datum plane. Null will return if no leader applied.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The datum plane cannot be visible in the view.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | This datum plane has no leaders.

See Also

DatumPlane Class


HasBubbleInView Method

[image]

Revit 2024 API
DatumPlane..::..HasBubbleInView Method
DatumPlane Class See Also Send Feedback
Identifies if the DatumPlane has bubble or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool HasBubbleInView(
    DatumEnds datumEnd,
    View view
)
Visual Basic
Public Function HasBubbleInView ( _
    datumEnd As DatumEnds, _
    view As View _
) As Boolean
Visual C++
public:
bool HasBubbleInView(
    DatumEnds datumEnd,
    View^ view
)

Parameters

datumEnd
Type: Autodesk.Revit.DB..::..DatumEnds
The end of the datum plane.
view
Type: Autodesk.Revit.DB..::..View
The view on which the DatumPlane shows.

Return Value

True if the DatumPlane has bubble, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | This datum plane doesn't support bubble operations.

See Also

DatumPlane Class


HideBubbleInView Method

[image]

Revit 2024 API
DatumPlane..::..HideBubbleInView Method
DatumPlane Class See Also Send Feedback
Hides the bubble in a view. This method does not apply to Reference planes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public void HideBubbleInView(
    DatumEnds datumEnd,
    View view
)
Visual Basic
Public Sub HideBubbleInView ( _
    datumEnd As DatumEnds, _
    view As View _
)
Visual C++
public:
void HideBubbleInView(
    DatumEnds datumEnd,
    View^ view
)

Parameters

datumEnd
Type: Autodesk.Revit.DB..::..DatumEnds
The end of the datum plane.
view
Type: Autodesk.Revit.DB..::..View
The view on which the DatumPlane shows.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The datum plane cannot be visible in the view.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | This datum plane doesn't support bubble operations.

See Also

DatumPlane Class


IsBubbleVisibleInView Method

[image]

Revit 2024 API
DatumPlane..::..IsBubbleVisibleInView Method
DatumPlane Class See Also Send Feedback
Identifies if the bubble is visible or not in a view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool IsBubbleVisibleInView(
    DatumEnds datumEnd,
    View view
)
Visual Basic
Public Function IsBubbleVisibleInView ( _
    datumEnd As DatumEnds, _
    view As View _
) As Boolean
Visual C++
public:
bool IsBubbleVisibleInView(
    DatumEnds datumEnd,
    View^ view
)

Parameters

datumEnd
Type: Autodesk.Revit.DB..::..DatumEnds
The end of the datum plane.
view
Type: Autodesk.Revit.DB..::..View
The view on which the DatumPlane shows.

Return Value

True if the bubble is visible, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The datum plane cannot be visible in the view.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | This datum plane doesn't support bubble operations.

See Also

DatumPlane Class


IsCurveValidInView Method

[image]

Revit 2024 API
DatumPlane..::..IsCurveValidInView Method
DatumPlane Class See Also Send Feedback
Checks if the curve is valid to be as the extents for the datum plane in a view. The curve must be bound and coincident with the original one of the datum plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool IsCurveValidInView(
    DatumExtentType extentMode,
    View view,
    Curve curve
)
Visual Basic
Public Function IsCurveValidInView ( _
    extentMode As DatumExtentType, _
    view As View, _
    curve As Curve _
) As Boolean
Visual C++
public:
bool IsCurveValidInView(
    DatumExtentType extentMode,
    View^ view,
    Curve^ curve
)

Parameters

extentMode
Type: Autodesk.Revit.DB..::..DatumExtentType
The extent type.
view
Type: Autodesk.Revit.DB..::..View
The view.
curve
Type: Autodesk.Revit.DB..::..Curve
The curve.

Return Value

True if it is valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

DatumPlane Class


IsLeaderValid Method

[image]

Revit 2024 API
DatumPlane..::..IsLeaderValid Method
DatumPlane Class See Also Send Feedback
Identifies if the leader valid or not for this DatumPlane. This method does not apply to Reference planes (which do not support leaders).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool IsLeaderValid(
    DatumEnds datumEnd,
    View view,
    Leader leader
)
Visual Basic
Public Function IsLeaderValid ( _
    datumEnd As DatumEnds, _
    view As View, _
    leader As Leader _
) As Boolean
Visual C++
public:
bool IsLeaderValid(
    DatumEnds datumEnd,
    View^ view,
    Leader^ leader
)

Parameters

datumEnd
Type: Autodesk.Revit.DB..::..DatumEnds
The end of the datum plane.
view
Type: Autodesk.Revit.DB..::..View
The view on which the DatumPlane shows.
leader
Type: Autodesk.Revit.DB..::..Leader
The Leader for setting the datum plane.

Return Value

True if the leader is valid for set leader, false otherwise.

Remarks

If the view or leader is null, it will throw ArgumentNullException; A valid leader meets the following conditions:
  • The leader's End, Elbow and Anchor should lie in the View's plane
  • The End of the leader should be on the datum plane's curve(s)
  • The Elbow of the leader should be between the End and Anchor

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | This datum plane has no leaders. -or- The DatumPlane should not have a leader.

See Also

DatumPlane Class


Maximize3DExtents Method

[image]

Revit 2024 API
DatumPlane..::..Maximize3DExtents Method
DatumPlane Class See Also Send Feedback
Computes the 3d extents of all model geometry and levels, and extends the 3d extents of this datum surface to include the model extents.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public void Maximize3DExtents()
Visual Basic
Public Sub Maximize3DExtents
Visual C++
public:
void Maximize3DExtents()

Remarks

Currently does not apply to curved grids.

See Also

DatumPlane Class


PropagateToViews Method

[image]

Revit 2024 API
DatumPlane..::..PropagateToViews Method
DatumPlane Class See Also Send Feedback
Propagates the extents applied to this datum in the view to the specified parallel views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public void PropagateToViews(
    View view,
    ISet<ElementId> parallelViews
)
Visual Basic
Public Sub PropagateToViews ( _
    view As View, _
    parallelViews As ISet(Of ElementId) _
)
Visual C++
public:
void PropagateToViews(
    View^ view,
    ISet<ElementId^>^ parallelViews
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view on which the DatumPlane shows.
parallelViews
Type: System.Collections.Generic..::..ISet<(Of <(<' ElementId >)>)>
The ids of the specified parallel views.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The datum plane cannot be visible in the view. -or- One ElementId in parallelViews is not valid for extent propagation.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DatumPlane Class


SetDatumExtentType Method

[image]

Revit 2024 API
DatumPlane..::..SetDatumExtentType Method
DatumPlane Class See Also Send Feedback
Sets whether the curve representing the datum plane is displayed according to its 3d extents, or else according to a view specific setting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public void SetDatumExtentType(
    DatumEnds datumEnd,
    View view,
    DatumExtentType extentMode
)
Visual Basic
Public Sub SetDatumExtentType ( _
    datumEnd As DatumEnds, _
    view As View, _
    extentMode As DatumExtentType _
)
Visual C++
public:
void SetDatumExtentType(
    DatumEnds datumEnd,
    View^ view,
    DatumExtentType extentMode
)

Parameters

datumEnd
Type: Autodesk.Revit.DB..::..DatumEnds
Specifies one end of the curve representing the datum plane in the view.
view
Type: Autodesk.Revit.DB..::..View
The view in which to set the datum extent settings.
extentMode
Type: Autodesk.Revit.DB..::..DatumExtentType
The DatumExtentType.

Remarks

In a particular view, the datum plane is represented by a curve and the two ends of the curve may have different DatumExtentTypes in that view. If the value is changed from DatumExtentType::Model to DatumExtentType::ViewSpecific, then the view specific extents will be identical to the model extent until modified.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The datum plane cannot be visible in the view.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

DatumPlane Class


SetLeader Method

[image]

Revit 2024 API
DatumPlane..::..SetLeader Method
DatumPlane Class See Also Send Feedback
Sets the leader to the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public void SetLeader(
    DatumEnds datumEnd,
    View view,
    Leader pLeader
)
Visual Basic
Public Sub SetLeader ( _
    datumEnd As DatumEnds, _
    view As View, _
    pLeader As Leader _
)
Visual C++
public:
void SetLeader(
    DatumEnds datumEnd,
    View^ view,
    Leader^ pLeader
)

Parameters

datumEnd
Type: Autodesk.Revit.DB..::..DatumEnds
The end of the datum plane.
view
Type: Autodesk.Revit.DB..::..View
The view on which the DatumPlane shows.
pLeader
Type: Autodesk.Revit.DB..::..Leader
The Leader for setting the datum plane.

Remarks

The leader can be applied only to ends where the bubble is set to be shown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | One of the conditions is not valid: the input leader and view is not null; The leader End, Elbow, Anchor should be in the view; the End of leader should be in the datum plane curves; Elbow is between End and Anchor. -or- The datum plane cannot be visible in the view. -or- The bubble is not visible at the datumEnd of the datum plane.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

DatumPlane Class


DatumPlane Properties

[image] [image]

Revit 2024 API
DatumPlane Properties
DatumPlane Class See Also Send Feedback

The DatumPlane type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DatumPlane Class


Parameter Property

[image] [image]

Revit 2024 API
DatumPlane..::..Parameter Property
DatumPlane Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

DatumPlane Class
DatumPlane Members


DecimalSymbol Enumeration

[image]

Revit 2024 API
DecimalSymbol Enumeration
See Also Send Feedback
The symbol used to separate the integer and fractional parts of a number.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014
Since: 2014

Syntax

C#
public enum DecimalSymbol
Visual Basic
Public Enumeration DecimalSymbol
Visual C++
public enum class DecimalSymbol

Members

Member name | Description
Dot | A dot (".").
Comma | A comma (",").

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


DefaultDivideSettings Class

[image]

Revit 2024 API
DefaultDivideSettings Class
Members See Also Send Feedback
Provides access to project-wide divide settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class DefaultDivideSettings : Element
Visual Basic
Public Class DefaultDivideSettings _
    Inherits Element
Visual C++
public ref class DefaultDivideSettings : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..DefaultDivideSettings

See Also

DefaultDivideSettings Members


DefaultDivideSettings Methods

[image] [image]

Revit 2024 API
DefaultDivideSettings Methods
DefaultDivideSettings Class See Also Send Feedback

The DefaultDivideSettings type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
 | GetDefaultDivideSettings | Obtains the DefaultDivideSettings object for the specified document.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetSurfaceDistance | Gets the default Divided Surface distance for a fixed, minimum, or maximum distance layout for U or V gridlines.
Public method | GetSurfaceLayout | Gets the default Divided Surface layout for U or V gridlines.
Public method | GetSurfaceNumber | Gets the default Divided Surface number for a fixed number layout for U or V gridlines.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetSurfaceDistance | Sets the default Divided Surface distance for a fixed, minimum, or maximum distance layout for U or V gridlines.
Public method | SetSurfaceLayout | Sets the default Divided Surface layout for U or V gridlines.
Public method | SetSurfaceNumber | Sets the default Divided Surface number for a fixed number layout for U or V gridlines.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DefaultDivideSettings Class


GetDefaultDivideSettings Method

[image]

Revit 2024 API
DefaultDivideSettings..::..GetDefaultDivideSettings Method
DefaultDivideSettings Class See Also Send Feedback
Obtains the DefaultDivideSettings object for the specified document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static DefaultDivideSettings GetDefaultDivideSettings(
    Document cda
)
Visual Basic
Public Shared Function GetDefaultDivideSettings ( _
    cda As Document _
) As DefaultDivideSettings
Visual C++
public:
static DefaultDivideSettings^ GetDefaultDivideSettings(
    Document^ cda
)

Parameters

cda
Type: Autodesk.Revit.DB..::..Document
A document.

Return Value

The DefaultDivideSettings object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DefaultDivideSettings Class


GetSurfaceDistance Method

[image]

Revit 2024 API
DefaultDivideSettings..::..GetSurfaceDistance Method
DefaultDivideSettings Class See Also Send Feedback
Gets the default Divided Surface distance for a fixed, minimum, or maximum distance layout for U or V gridlines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public double GetSurfaceDistance(
    UVGridlineType gridlines
)
Visual Basic
Public Function GetSurfaceDistance ( _
    gridlines As UVGridlineType _
) As Double
Visual C++
public:
double GetSurfaceDistance(
    UVGridlineType gridlines
)

Parameters

gridlines
Type: Autodesk.Revit.DB..::..UVGridlineType
U-gridlines or V-gridlines.

Return Value

The default distance for the layout.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

DefaultDivideSettings Class


GetSurfaceLayout Method

[image]

Revit 2024 API
DefaultDivideSettings..::..GetSurfaceLayout Method
DefaultDivideSettings Class See Also Send Feedback
Gets the default Divided Surface layout for U or V gridlines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public SpacingRuleLayout GetSurfaceLayout(
    UVGridlineType gridlines
)
Visual Basic
Public Function GetSurfaceLayout ( _
    gridlines As UVGridlineType _
) As SpacingRuleLayout
Visual C++
public:
SpacingRuleLayout GetSurfaceLayout(
    UVGridlineType gridlines
)

Parameters

gridlines
Type: Autodesk.Revit.DB..::..UVGridlineType
U-gridlines or V-gridlines.

Return Value

The layout spacing rule.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

DefaultDivideSettings Class


SetSurfaceLayout Method

[image]

Revit 2024 API
DefaultDivideSettings..::..SetSurfaceLayout Method
DefaultDivideSettings Class See Also Send Feedback
Sets the default Divided Surface layout for U or V gridlines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public void SetSurfaceLayout(
    UVGridlineType gridlines,
    SpacingRuleLayout layout
)
Visual Basic
Public Sub SetSurfaceLayout ( _
    gridlines As UVGridlineType, _
    layout As SpacingRuleLayout _
)
Visual C++
public:
void SetSurfaceLayout(
    UVGridlineType gridlines,
    SpacingRuleLayout layout
)

Parameters

gridlines
Type: Autodesk.Revit.DB..::..UVGridlineType
U-gridlines or V-gridlines.
layout
Type: Autodesk.Revit.DB..::..SpacingRuleLayout
A layout spacing rule.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

DefaultDivideSettings Class


SetSurfaceNumber Method

[image]

Revit 2024 API
DefaultDivideSettings..::..SetSurfaceNumber Method
DefaultDivideSettings Class See Also Send Feedback
Sets the default Divided Surface number for a fixed number layout for U or V gridlines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public void SetSurfaceNumber(
    UVGridlineType gridlines,
    int number
)
Visual Basic
Public Sub SetSurfaceNumber ( _
    gridlines As UVGridlineType, _
    number As Integer _
)
Visual C++
public:
void SetSurfaceNumber(
    UVGridlineType gridlines,
    int number
)

Parameters

gridlines
Type: Autodesk.Revit.DB..::..UVGridlineType
U-gridlines or V-gridlines.
number
Type: System..::..Int32
A default number for a fixed number layout.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given value for number is not positive. -or- A value passed for an enumeration argument is not a member of that enumeration

See Also

DefaultDivideSettings Class


DefaultDivideSettings Properties

[image] [image]

Revit 2024 API
DefaultDivideSettings Properties
DefaultDivideSettings Class See Also Send Feedback

The DefaultDivideSettings type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PathDistance | A default Divided Path distance for a fixed, minimum, or maximum distance layout.
Public property | PathLayout | A default Divided Path layout.
Public property | PathMeasurementType | A default Divided Path measurement type for distance layouts.
Public property | PathNumber | A default Divided Path number for a fixed number layout.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DefaultDivideSettings Class


Parameter Property

[image] [image]

Revit 2024 API
DefaultDivideSettings..::..Parameter Property
DefaultDivideSettings Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

DefaultDivideSettings Class
DefaultDivideSettings Members


PathDistance Property

[image]

Revit 2024 API
DefaultDivideSettings..::..PathDistance Property
DefaultDivideSettings Class See Also Send Feedback
A default Divided Path distance for a fixed, minimum, or maximum distance layout.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public double PathDistance { get; set; }
Visual Basic
Public Property PathDistance As Double
    Get
    Set
Visual C++
public:
property double PathDistance {
    double get ();
    void set (double value);
}

See Also

DefaultDivideSettings Class


PathMeasurementType Property

[image]

Revit 2024 API
DefaultDivideSettings..::..PathMeasurementType Property
DefaultDivideSettings Class See Also Send Feedback
A default Divided Path measurement type for distance layouts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public DividedPathMeasurementType PathMeasurementType { get; set; }
Visual Basic
Public Property PathMeasurementType As DividedPathMeasurementType
    Get
    Set
Visual C++
public:
property DividedPathMeasurementType PathMeasurementType {
    DividedPathMeasurementType get ();
    void set (DividedPathMeasurementType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

DefaultDivideSettings Class


PathNumber Property

[image]

Revit 2024 API
DefaultDivideSettings..::..PathNumber Property
DefaultDivideSettings Class See Also Send Feedback
A default Divided Path number for a fixed number layout.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public int PathNumber { get; set; }
Visual Basic
Public Property PathNumber As Integer
    Get
    Set
Visual C++
public:
property int PathNumber {
    int get ();
    void set (int value);
}

See Also

DefaultDivideSettings Class


DefaultOpenFromCloudCallback Class

[image]

Revit 2024 API
DefaultOpenFromCloudCallback Class
Members See Also Send Feedback
A default callback that may be used to control Revit's behavior when opening a model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public class DefaultOpenFromCloudCallback : IOpenFromCloudCallback,
    IDisposable
Visual Basic
Public Class DefaultOpenFromCloudCallback _
    Implements IOpenFromCloudCallback, IDisposable
Visual C++
public ref class DefaultOpenFromCloudCallback : IOpenFromCloudCallback,
    IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..DefaultOpenFromCloudCallback

See Also

DefaultOpenFromCloudCallback Members


DefaultOpenFromCloudCallback Members

[image] [image]

Revit 2024 API
DefaultOpenFromCloudCallback Members
DefaultOpenFromCloudCallback Class Constructors Methods Properties See Also Send Feedback

The DefaultOpenFromCloudCallback type exposes the following members.

Constructors

 | Name | Description
Public method | DefaultOpenFromCloudCallback | Create a default open callback. Open latest by default for all scenarios.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the DefaultOpenFromCloudCallback
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OnOpenConflict | A method called when the conflict is happen during the model opening.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

DefaultOpenFromCloudCallback Class


DefaultOpenFromCloudCallback Methods

[image] [image]

Revit 2024 API
DefaultOpenFromCloudCallback Methods
DefaultOpenFromCloudCallback Class See Also Send Feedback

The DefaultOpenFromCloudCallback type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OnOpenConflict | A method called when the conflict is happen during the model opening.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DefaultOpenFromCloudCallback Class


Dispose Method

[image]

Revit 2024 API
DefaultOpenFromCloudCallback..::..Dispose Method
DefaultOpenFromCloudCallback Class See Also Send Feedback
Releases all resources used by the DefaultOpenFromCloudCallback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

DefaultOpenFromCloudCallback Class


OnOpenConflict Method

[image]

Revit 2024 API
DefaultOpenFromCloudCallback..::..OnOpenConflict Method
DefaultOpenFromCloudCallback Class See Also Send Feedback
A method called when the conflict is happen during the model opening.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public virtual OpenConflictResult OnOpenConflict(
    OpenConflictScenario scenario
)
Visual Basic
Public Overridable Function OnOpenConflict ( _
    scenario As OpenConflictScenario _
) As OpenConflictResult
Visual C++
public:
virtual OpenConflictResult OnOpenConflict(
    OpenConflictScenario scenario
)

Parameters

scenario
Type: Autodesk.Revit.DB..::..OpenConflictScenario
The scenario of the conflict.

Return Value

Returns the result to indicate whether to keep the unsynchronized change, or open the latest version or cancel the open action.

Implements

IOpenFromCloudCallback..::..OnOpenConflict(OpenConflictScenario)

See Also

DefaultOpenFromCloudCallback Class


DefaultOpenFromCloudCallback Properties

[image] [image]

Revit 2024 API
DefaultOpenFromCloudCallback Properties
DefaultOpenFromCloudCallback Class See Also Send Feedback

The DefaultOpenFromCloudCallback type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

DefaultOpenFromCloudCallback Class


IsValidObject Property

[image]

Revit 2024 API
DefaultOpenFromCloudCallback..::..IsValidObject Property
DefaultOpenFromCloudCallback Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

DefaultOpenFromCloudCallback Class


Definition Class

[image]

Revit 2024 API
Definition Class
Members See Also Send Feedback
The Definition object is a base object for all type of parameter definitions within the Autodesk Revit API.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public abstract class Definition
Visual Basic
Public MustInherit Class Definition
Visual C++
public ref class Definition abstract

Remarks

This object supports properties and methods that report the name and type of a particular parameter. There are two kinds of definition object derived from this: InternalDefinition which represents all kinds of definitions existing entirely within the Autodesk Revit database. ExternalDefinitions represent definitions stored on disk in a shared parameters file. Most of the time code should be written to utilize this Definition base class as then the code will be applicable to both internal and external parameter definitions.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Definition
Autodesk.Revit.DB..::..ExternalDefinition
Autodesk.Revit.DB..::..InternalDefinition

See Also

Definition Members


Definition Methods

[image] [image]

Revit 2024 API
Definition Methods
Definition Class See Also Send Feedback

The Definition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDataType | Gets a ForgeTypeId identifying the data type describing values of the parameter.
Public method | GetGroupTypeId | Returns the identifier of the parameter definition's parameter group.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Definition Class


GetDataType Method

[image]

Revit 2024 API
Definition..::..GetDataType Method
Definition Class Example See Also Send Feedback
Gets a ForgeTypeId identifying the data type describing values of the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public ForgeTypeId GetDataType()
Visual Basic
Public Function GetDataType As ForgeTypeId
Visual C++
public:
ForgeTypeId^ GetDataType()

Return Value

A ForgeTypeId identifying the data type of the parameter or an empty ForgeTypeId.

Remarks

The returned ForgeTypeId may be empty or may identify either a spec or a category. When it is a category, it indicates a Family Type parameter of that category. See Parameter.IsSpec(ForgeTypeId), UnitUtils.IsMeasurableSpec(ForgeTypeId), Category.IsBuiltInCategory(ForgeTypeId), and Parameter.IsValidDataType(ForgeTypeId). Some built-in parameters, such as those for color or level, have special data types which are not available for use with user-defined parameters and which have no representation in the Revit user interface or API. For these built-in parameters, this method returns an empty ForgeTypeId instance.

Examples

CopyC#
//Find parameter using the Parameter's definition data type.
public Parameter FindParameter(Element element)
{
    Parameter foundParameter = null;
    // This will find the first parameter that measures length
    foreach (Parameter parameter in element.Parameters)
    {
        if (parameter.Definition.GetDataType() == SpecTypeId.Length)
        {
            foundParameter = parameter;
            break;
        }
    }
    return foundParameter;
}
CopyVB.NET
'Find parameter using the Parameter's definition data type.
Public Function FindParameter(element As Element) As Parameter
    Dim foundParameter As Parameter = Nothing
    ' This will find the first parameter that measures length
    For Each parameter As Parameter In element.Parameters
        If parameter.Definition.GetDataType() = SpecTypeId.Length Then
            foundParameter = parameter
            Exit For
        End If
    Next
    Return foundParameter
End Function

See Also

Definition Class


GetGroupTypeId Method

[image]

Revit 2024 API
Definition..::..GetGroupTypeId Method
Definition Class See Also Send Feedback
Returns the identifier of the parameter definition's parameter group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public abstract ForgeTypeId GetGroupTypeId()
Visual Basic
Public MustOverride Function GetGroupTypeId As ForgeTypeId
Visual C++
public:
virtual ForgeTypeId^ GetGroupTypeId() abstract

See Also

Definition Class


Definition Properties

[image] [image]

Revit 2024 API
Definition Properties
Definition Class See Also Send Feedback

The Definition type exposes the following members.

Properties

 | Name | Description
Public property | Name | The user visible name for the parameter.
Public property | ParameterGroup | Obsolete. Returns the group ID of the parameter definition.

See Also

Definition Class


Name Property

[image]

Revit 2024 API
Definition..::..Name Property
Definition Class See Also Send Feedback
The user visible name for the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public abstract string Name { get; }
Visual Basic
Public MustOverride ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () abstract;
}

See Also

Definition Class


ParameterGroup Property

[image]

Revit 2024 API
Definition..::..ParameterGroup Property
Definition Class See Also Send Feedback
Returns the group ID of the parameter definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
[ObsoleteAttribute("This property is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use the `GetGroupTypeId()` method instead.")]
public abstract BuiltInParameterGroup ParameterGroup { get; }
Visual Basic
<ObsoleteAttribute("This property is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use the `GetGroupTypeId()` method instead.")> _
Public MustOverride ReadOnly Property ParameterGroup As BuiltInParameterGroup
    Get
Visual C++
[ObsoleteAttribute(L"This property is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use the `GetGroupTypeId()` method instead.")]
public:
virtual property BuiltInParameterGroup ParameterGroup {
    BuiltInParameterGroup get () abstract;
}

See Also

Definition Class


DefinitionBindingMap Class

[image]

Revit 2024 API
DefinitionBindingMap Class
Members See Also Send Feedback
A map that contains mappings of parameter definitions to parameter bindings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class DefinitionBindingMap : APIObject,
    IEnumerable
Visual Basic
Public Class DefinitionBindingMap _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class DefinitionBindingMap : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..DefinitionBindingMap
Autodesk.Revit.DB..::..BindingMap

See Also

DefinitionBindingMap Members


DefinitionBindingMap Members

[image] [image]

Revit 2024 API
DefinitionBindingMap Members
DefinitionBindingMap Class Constructors Methods Properties See Also Send Feedback

The DefinitionBindingMap type exposes the following members.

Constructors

 | Name | Description
Public method | DefinitionBindingMap | Initializes a new instance of the DefinitionBindingMap class

Methods

 | Name | Description
Public method | Clear | Removes every binding from the map, rendering it empty.
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the map.
Public method | GetEnumerator | Retrieve a forward moving iterator to the map.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the map.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the map is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item |
Public property | Size | Returns the number of bindings that are in the map.

See Also

DefinitionBindingMap Class


DefinitionBindingMap Constructor

[image]

Revit 2024 API
DefinitionBindingMap Constructor
DefinitionBindingMap Class See Also Send Feedback
Initializes a new instance of the DefinitionBindingMap class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public DefinitionBindingMap()
Visual Basic
Public Sub New
Visual C++
public:
DefinitionBindingMap()

See Also

DefinitionBindingMap Class


DefinitionBindingMap Methods

[image] [image]

Revit 2024 API
DefinitionBindingMap Methods
DefinitionBindingMap Class See Also Send Feedback

The DefinitionBindingMap type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every binding from the map, rendering it empty.
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the map.
Public method | GetEnumerator | Retrieve a forward moving iterator to the map.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the map.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DefinitionBindingMap Class


Contains Method

[image]

Revit 2024 API
DefinitionBindingMap..::..Contains Method
DefinitionBindingMap Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool Contains(
    Definition key
)
Visual Basic
Public Overridable Function Contains ( _
    key As Definition _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Definition^ key
)

Parameters

key
Type: Autodesk.Revit.DB..::..Definition

See Also

DefinitionBindingMap Class


ForwardIterator Method

[image]

Revit 2024 API
DefinitionBindingMap..::..ForwardIterator Method
DefinitionBindingMap Class See Also Send Feedback
Retrieve a forward moving iterator to the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual DefinitionBindingMapIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As DefinitionBindingMapIterator
Visual C++
public:
virtual DefinitionBindingMapIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the map.

See Also

DefinitionBindingMap Class


Insert Method

[image]

Revit 2024 API
DefinitionBindingMap..::..Insert Method
DefinitionBindingMap Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool Insert(
    Definition key,
    Binding item
)
Visual Basic
Public Overridable Function Insert ( _
    key As Definition, _
    item As Binding _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Definition^ key,
    Binding^ item
)

Parameters

key
Type: Autodesk.Revit.DB..::..Definition
item
Type: Autodesk.Revit.DB..::..Binding

See Also

DefinitionBindingMap Class


ReverseIterator Method

[image]

Revit 2024 API
DefinitionBindingMap..::..ReverseIterator Method
DefinitionBindingMap Class See Also Send Feedback
Retrieve a backward moving iterator to the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual DefinitionBindingMapIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As DefinitionBindingMapIterator
Visual C++
public:
virtual DefinitionBindingMapIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the map.

See Also

DefinitionBindingMap Class


DefinitionBindingMap Properties

[image] [image]

Revit 2024 API
DefinitionBindingMap Properties
DefinitionBindingMap Class See Also Send Feedback

The DefinitionBindingMap type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the map is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item |
Public property | Size | Returns the number of bindings that are in the map.

See Also

DefinitionBindingMap Class


IsEmpty Property

[image]

Revit 2024 API
DefinitionBindingMap..::..IsEmpty Property
DefinitionBindingMap Class See Also Send Feedback
Test to see if the map is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the map is empty then True will be returned, otherwise False.

See Also

DefinitionBindingMap Class


Item Property

[image]

Revit 2024 API
DefinitionBindingMap..::..Item Property
DefinitionBindingMap Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Binding this[
    Definition key
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    key As Definition _
) As Binding
    Get
    Set
Visual C++
public:
virtual property Binding^ Item[Definition^ key] {
    Binding^ get (Definition^ key);
    void set (Definition^ key, Binding^ value);
}

Parameters

key
Type: Autodesk.Revit.DB..::..Definition

See Also

DefinitionBindingMap Class


Size Property

[image]

Revit 2024 API
DefinitionBindingMap..::..Size Property
DefinitionBindingMap Class See Also Send Feedback
Returns the number of bindings that are in the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

DefinitionBindingMap Class


DefinitionBindingMapIterator Class

[image]

Revit 2024 API
DefinitionBindingMapIterator Class
Members See Also Send Feedback
An iterator to a parameter definition to parameter bindings map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public abstract class DefinitionBindingMapIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class DefinitionBindingMapIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class DefinitionBindingMapIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..DefinitionBindingMapIterator

See Also

DefinitionBindingMapIterator Members


DefinitionBindingMapIterator Members

[image] [image]

Revit 2024 API
DefinitionBindingMapIterator Members
DefinitionBindingMapIterator Class Constructors Methods Properties See Also Send Feedback

The DefinitionBindingMapIterator type exposes the following members.

Constructors

 | Name | Description
Public method | DefinitionBindingMapIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the map.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the binding that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Key | Retrieves the definition that is the current focus of the iterator.

See Also

DefinitionBindingMapIterator Class


DefinitionBindingMapIterator Constructor

[image]

Revit 2024 API
DefinitionBindingMapIterator Constructor
DefinitionBindingMapIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public DefinitionBindingMapIterator()
Visual Basic
Public Sub New
Visual C++
public:
DefinitionBindingMapIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DefinitionBindingMapIterator Class


DefinitionBindingMapIterator Methods

[image] [image]

Revit 2024 API
DefinitionBindingMapIterator Methods
DefinitionBindingMapIterator Class See Also Send Feedback

The DefinitionBindingMapIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the map.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DefinitionBindingMapIterator Class


MoveNext Method

[image]

Revit 2024 API
DefinitionBindingMapIterator..::..MoveNext Method
DefinitionBindingMapIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the map.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

DefinitionBindingMapIterator Class


Reset Method

[image]

Revit 2024 API
DefinitionBindingMapIterator..::..Reset Method
DefinitionBindingMapIterator Class See Also Send Feedback
Bring the iterator back to the start of the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the map in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

DefinitionBindingMapIterator Class


Current Property

[image]

Revit 2024 API
DefinitionBindingMapIterator..::..Current Property
DefinitionBindingMapIterator Class See Also Send Feedback
Retrieves the binding that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

DefinitionBindingMapIterator Class


DefinitionFile Class

[image]

Revit 2024 API
DefinitionFile Class
Members Example See Also Send Feedback
The DefinitionFile object represents a shared parameters file on disk.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class DefinitionFile : APIObject
Visual Basic
Public Class DefinitionFile _
    Inherits APIObject
Visual C++
public ref class DefinitionFile : public APIObject

Remarks

Shared Parameters are parameter definitions that are stored in a text file external to the Autodesk Revit project. These definitions can be used in multiple projects and are identifiable by a unique identifier generated when they are created. API access to shared parameters consist of a number of objects, the first of which is an object that represents the shared parameters file on disk. That object then contains a number of Group objects. Shared parameters are grouped for easier management. These groups then contain the shared parameter definitions. The groups support the ability to create new shared parameter definitions. The DefinitionFile object can be retrieved by the Application.OpenSharedParameterFile method.

Examples

CopyC#
private void ShowDefinitionFileInfo(DefinitionFile myDefinitionFile)
{
    StringBuilder fileInformation = new StringBuilder(500);

    // get the file name
    fileInformation.AppendLine("File Name: " + myDefinitionFile.Filename);

    // iterate the Definition groups of this file
    foreach (DefinitionGroup myGroup in myDefinitionFile.Groups)
    {
        // get the group name
        fileInformation.AppendLine("Group Name: " + myGroup.Name);

        // iterate the difinitions
        foreach (Definition definition in myGroup.Definitions)
        {
            // get definition name
            fileInformation.AppendLine("Definition Name: " + definition.Name);
        }
    }
    TaskDialog.Show("Revit",fileInformation.ToString());
}
CopyVB.NET
Private Sub ShowDefinitionFileInfo(myDefinitionFile As DefinitionFile)
   Dim fileInformation As New StringBuilder(500)

   ' get the file name
   fileInformation.AppendLine("File Name: " & Convert.ToString(myDefinitionFile.Filename))

   ' iterate the Definition groups of this file
   For Each myGroup As DefinitionGroup In myDefinitionFile.Groups
      ' get the group name
      fileInformation.AppendLine("Group Name: " + myGroup.Name)

      ' iterate the difinitions
      For Each definition As Definition In myGroup.Definitions
         ' get definition name
         fileInformation.AppendLine("Definition Name: " + definition.Name)
      Next
   Next
   TaskDialog.Show("Revit", fileInformation.ToString())
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..DefinitionFile

See Also

DefinitionFile Members


DefinitionFile Members

[image] [image]

Revit 2024 API
DefinitionFile Members
DefinitionFile Class Methods Properties See Also Send Feedback

The DefinitionFile type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Filename | This property returns the physical filename of the shared parameters file on disk.
Public property | Groups | Return a map of shared parameter definition groups contained within the file.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DefinitionFile Class


DefinitionFile Methods

[image] [image]

Revit 2024 API
DefinitionFile Methods
DefinitionFile Class See Also Send Feedback

The DefinitionFile type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DefinitionFile Class


Filename Property

[image]

Revit 2024 API
DefinitionFile..::..Filename Property
DefinitionFile Class See Also Send Feedback
This property returns the physical filename of the shared parameters file on disk.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string Filename { get; }
Visual Basic
Public ReadOnly Property Filename As String
    Get
Visual C++
public:
property String^ Filename {
    String^ get ();
}

See Also

DefinitionFile Class


DefinitionGroup Members

[image] [image]

Revit 2024 API
DefinitionGroup Members
DefinitionGroup Class Methods Properties See Also Send Feedback

The DefinitionGroup type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Definitions | The Definitions property returns an object that contains all the shared parameter definitions within the group.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Returns the name of the parameter group.

See Also

DefinitionGroup Class


DefinitionGroup Methods

[image] [image]

Revit 2024 API
DefinitionGroup Methods
DefinitionGroup Class See Also Send Feedback

The DefinitionGroup type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DefinitionGroup Class


DefinitionGroup Properties

[image] [image]

Revit 2024 API
DefinitionGroup Properties
DefinitionGroup Class See Also Send Feedback

The DefinitionGroup type exposes the following members.

Properties

 | Name | Description
Public property | Definitions | The Definitions property returns an object that contains all the shared parameter definitions within the group.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Returns the name of the parameter group.

See Also

DefinitionGroup Class


DefinitionGroups Members

[image] [image]

Revit 2024 API
DefinitionGroups Members
DefinitionGroups Class Methods Properties See Also Send Feedback

The DefinitionGroups type exposes the following members.

Methods

 | Name | Description
Public method | Contains | Tests for the existence of a definition group within the collection.
Public method | Create | Create a new parameter definition group using the name provided.
Public method | Dispose | Releases all resources used by the DefinitionGroups
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Retrieves an enumerator to the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Identifies if the definition groups collection is empty.
Public property | Item | Retrieve a definition group by name.
Public property | Size | The number of definition groups in the collection.

See Also

DefinitionGroups Class


DefinitionGroups Methods

[image] [image]

Revit 2024 API
DefinitionGroups Methods
DefinitionGroups Class See Also Send Feedback

The DefinitionGroups type exposes the following members.

Methods

 | Name | Description
Public method | Contains | Tests for the existence of a definition group within the collection.
Public method | Create | Create a new parameter definition group using the name provided.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Retrieves an enumerator to the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DefinitionGroups Class


Contains Method

[image]

Revit 2024 API
DefinitionGroups..::..Contains Method
DefinitionGroups Class See Also Send Feedback
Tests for the existence of a definition group within the collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool Contains(
    DefinitionGroup definitionGroup
)
Visual Basic
Public Function Contains ( _
    definitionGroup As DefinitionGroup _
) As Boolean
Visual C++
public:
bool Contains(
    DefinitionGroup^ definitionGroup
)

Parameters

definitionGroup
Type: Autodesk.Revit.DB..::..DefinitionGroup
The definition group to look for.

Return Value

True if the definition group was found, false otherwise.

See Also

DefinitionGroups Class


Create Method

[image]

Revit 2024 API
DefinitionGroups..::..Create Method
DefinitionGroups Class See Also Send Feedback
Create a new parameter definition group using the name provided.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public DefinitionGroup Create(
    string name
)
Visual Basic
Public Function Create ( _
    name As String _
) As DefinitionGroup
Visual C++
public:
DefinitionGroup^ Create(
    String^ name
)

Parameters

name
Type: System..::..String
The name of the group to be created.

Return Value

If successful a reference to the new parameter group is returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

If a group with the same name already exists then an exception will be thrown.

See Also

DefinitionGroups Class


Dispose Method

[image]

Revit 2024 API
DefinitionGroups..::..Dispose Method
DefinitionGroups Class See Also Send Feedback
Releases all resources used by the DefinitionGroups

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

DefinitionGroups Class


GetBasicIEnumerator Method

[image]

Revit 2024 API
DefinitionGroups..::..GetBasicIEnumerator Method
DefinitionGroups Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
internal virtual IEnumerator GetBasicIEnumerator()
Visual Basic
Friend Overridable Function GetBasicIEnumerator As IEnumerator
Visual C++
internal:
virtual IEnumerator^ GetBasicIEnumerator()

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

DefinitionGroups Class


GetEnumerator Method

[image]

Revit 2024 API
DefinitionGroups..::..GetEnumerator Method
DefinitionGroups Class See Also Send Feedback
Retrieves an enumerator to the collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IEnumerator<DefinitionGroup> GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator(Of DefinitionGroup)
Visual C++
public:
virtual IEnumerator<DefinitionGroup^>^ GetEnumerator()

Return Value

The enumerator.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

DefinitionGroups Class


DefinitionGroups Properties

[image] [image]

Revit 2024 API
DefinitionGroups Properties
DefinitionGroups Class See Also Send Feedback

The DefinitionGroups type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Identifies if the definition groups collection is empty.
Public property | Item | Retrieve a definition group by name.
Public property | Size | The number of definition groups in the collection.

See Also

DefinitionGroups Class


IsEmpty Property

[image]

Revit 2024 API
DefinitionGroups..::..IsEmpty Property
DefinitionGroups Class See Also Send Feedback
Identifies if the definition groups collection is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsEmpty { get; }
Visual Basic
Public ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
property bool IsEmpty {
    bool get ();
}

See Also

DefinitionGroups Class


Item Property

[image]

Revit 2024 API
DefinitionGroups..::..Item Property
DefinitionGroups Class See Also Send Feedback
Retrieve a definition group by name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public DefinitionGroup this[
    string groupName
] { get; }
Visual Basic
Public ReadOnly Property Item ( _
    groupName As String _
) As DefinitionGroup
    Get
Visual C++
public:
property DefinitionGroup^ Item[String^ groupName] {
    DefinitionGroup^ get (String^ groupName);
}

Parameters

groupName
Type: System..::..String
The name of the group for which to search.

Remarks

If the group is not found then nullNothingnullptra null reference (Nothing in Visual Basic) will be returned.

See Also

DefinitionGroups Class


Size Property

[image]

Revit 2024 API
DefinitionGroups..::..Size Property
DefinitionGroups Class See Also Send Feedback
The number of definition groups in the collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public int Size { get; }
Visual Basic
Public ReadOnly Property Size As Integer
    Get
Visual C++
public:
property int Size {
    int get ();
}

See Also

DefinitionGroups Class


Definitions Class

[image]

Revit 2024 API
Definitions Class
Members See Also Send Feedback
A base class that supports the addition of new parameter definitions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class Definitions : IEnumerable<Definition>,
    IDisposable
Visual Basic
Public Class Definitions _
    Implements IEnumerable(Of Definition), IDisposable
Visual C++
public ref class Definitions : IEnumerable<Definition^>,
    IDisposable

Remarks

There are two derivations of this class, one of which handles external parameters and another which handles internal parameters.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Definitions
Autodesk.Revit.DB..::..ExternalDefinitions
Autodesk.Revit.DB..::..InternalDefinitions

See Also

Definitions Members


Definitions Constructor

[image]

Revit 2024 API
Definitions Constructor
Definitions Class See Also Send Feedback
Constructs an empty set of parameter definitions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Definitions()
Visual Basic
Public Sub New
Visual C++
public:
Definitions()

See Also

Definitions Class


Definitions Methods

[image] [image]

Revit 2024 API
Definitions Methods
Definitions Class See Also Send Feedback

The Definitions type exposes the following members.

Methods

 | Name | Description
Public method | Contains | Tests for the existence of a definition within the set.
Public method | Create | Creates a new parameter definition using specified options.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Retrieves an enumerator to the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Definitions Class


Contains Method

[image]

Revit 2024 API
Definitions..::..Contains Method
Definitions Class See Also Send Feedback
Tests for the existence of a definition within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool Contains(
    Definition definition
)
Visual Basic
Public Function Contains ( _
    definition As Definition _
) As Boolean
Visual C++
public:
bool Contains(
    Definition^ definition
)

Parameters

definition
Type: Autodesk.Revit.DB..::..Definition
The definition to look for.

Return Value

True if the definition was found, false otherwise.

See Also

Definitions Class


Create Method

[image]

Revit 2024 API
Definitions..::..Create Method
Definitions Class See Also Send Feedback
Creates a new parameter definition using specified options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public Definition Create(
    ExternalDefinitionCreationOptions option
)
Visual Basic
Public Function Create ( _
    option As ExternalDefinitionCreationOptions _
) As Definition
Visual C++
public:
Definition^ Create(
    ExternalDefinitionCreationOptions^ option
)

Parameters

option
Type: Autodesk.Revit.DB..::..ExternalDefinitionCreationOptions
The options used to create the new parameter definition.

Return Value

If successful a reference to the new parameter definition is returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

This method only supports creation of new external definitions (shared parameters).

See Also

Definitions Class


Dispose Method

[image]

Revit 2024 API
Definitions..::..Dispose Method
Definitions Class See Also Send Feedback
Releases all resources used by the Definitions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

Definitions Class


GetBasicIEnumerator Method

[image]

Revit 2024 API
Definitions..::..GetBasicIEnumerator Method
Definitions Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
internal virtual IEnumerator GetBasicIEnumerator()
Visual Basic
Friend Overridable Function GetBasicIEnumerator As IEnumerator
Visual C++
internal:
virtual IEnumerator^ GetBasicIEnumerator()

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

Definitions Class


GetEnumerator Method

[image]

Revit 2024 API
Definitions..::..GetEnumerator Method
Definitions Class See Also Send Feedback
Retrieves an enumerator to the collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IEnumerator<Definition> GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator(Of Definition)
Visual C++
public:
virtual IEnumerator<Definition^>^ GetEnumerator()

Return Value

The enumerator.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

Definitions Class


Definitions Properties

[image] [image]

Revit 2024 API
Definitions Properties
Definitions Class See Also Send Feedback

The Definitions type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Identifies if the definitions collection is empty.
Public property | Item | Retrieves a definition by a given name.
Public property | Size | The number of definitions in the collection.

See Also

Definitions Class


IsEmpty Property

[image]

Revit 2024 API
Definitions..::..IsEmpty Property
Definitions Class See Also Send Feedback
Identifies if the definitions collection is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsEmpty { get; }
Visual Basic
Public ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
property bool IsEmpty {
    bool get ();
}

See Also

Definitions Class


Item Property

[image]

Revit 2024 API
Definitions..::..Item Property
Definitions Class See Also Send Feedback
Retrieves a definition by a given name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Definition this[
    string name
] { get; }
Visual Basic
Public ReadOnly Property Item ( _
    name As String _
) As Definition
    Get
Visual C++
public:
property Definition^ Item[String^ name] {
    Definition^ get (String^ name);
}

Parameters

name
Type: System..::..String
The name of the parameter definition for which to search.

Remarks

If the definition is not found then nullNothingnullptra null reference (Nothing in Visual Basic) will be returned.

See Also

Definitions Class


DeleteElements Members

[image] [image]

Revit 2024 API
DeleteElements Members
DeleteElements Class Methods Properties See Also Send Feedback

The DeleteElements type exposes the following members.

Methods

 | Name | Description
 | Create(Document, ElementId) | Creates an instance of the DeleteElements resolution.
 | Create(Document, IList<(Of <<'(ElementId>)>>)) | Creates an instance of the DeleteElements resolution.
 | Create(Document, ISet<(Of <<'(ElementId>)>>)) | Creates an instance of the DeleteElements resolution.
Public method | Dispose | (Inherited from FailureResolution.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FailureResolution.)

See Also

DeleteElements Class


DeleteElements Methods

[image] [image]

Revit 2024 API
DeleteElements Methods
DeleteElements Class See Also Send Feedback

The DeleteElements type exposes the following members.

Methods

 | Name | Description
 | Create(Document, ElementId) | Creates an instance of the DeleteElements resolution.
 | Create(Document, IList<(Of <<'(ElementId>)>>)) | Creates an instance of the DeleteElements resolution.
 | Create(Document, ISet<(Of <<'(ElementId>)>>)) | Creates an instance of the DeleteElements resolution.
Public method | Dispose | (Inherited from FailureResolution.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DeleteElements Class


Create Method

[image] [image]

Revit 2024 API
DeleteElements..::..Create Method
DeleteElements Class See Also Send Feedback

Overload List

Name | Description
Create(Document, ElementId) | Creates an instance of the DeleteElements resolution.
Create(Document, IList<(Of <<'(ElementId>)>>)) | Creates an instance of the DeleteElements resolution.
Create(Document, ISet<(Of <<'(ElementId>)>>)) | Creates an instance of the DeleteElements resolution.

See Also

DeleteElements Class
DeleteElements Members


Create Method (Document, IList(ElementId))

[image]

Revit 2024 API
DeleteElements..::..Create Method (Document, IList<(Of <(<'ElementId>)>)>)
DeleteElements Class See Also Send Feedback
Creates an instance of the DeleteElements resolution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static FailureResolution Create(
    Document document,
    IList<ElementId> ids
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    ids As IList(Of ElementId) _
) As FailureResolution
Visual C++
public:
static FailureResolution^ Create(
    Document^ document,
    IList<ElementId^>^ ids
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document which owns the elements to delete.
ids
Type: System.Collections.Generic..::..IList<(Of <(<' ElementId >)>)>
The ids of the elements that will be deleted when this resolution is chosen.

Return Value

The instance of the DeleteElements resolution.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input ids is empty or contains an invalid element id.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DeleteElements Class
Create Overload


DeleteElements Properties

[image] [image]

Revit 2024 API
DeleteElements Properties
DeleteElements Class See Also Send Feedback

The DeleteElements type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FailureResolution.)

See Also

DeleteElements Class


DeleteWorksetSettings Class

[image]

Revit 2024 API
DeleteWorksetSettings Class
Members See Also Send Feedback
This class represents the settings used to delete a workset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022.1

Syntax

C#
public class DeleteWorksetSettings : IDisposable
Visual Basic
Public Class DeleteWorksetSettings _
    Implements IDisposable
Visual C++
public ref class DeleteWorksetSettings : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..DeleteWorksetSettings

See Also

DeleteWorksetSettings Members


DeleteWorksetSettings Constructor

[image] [image]

Revit 2024 API
DeleteWorksetSettings Constructor
DeleteWorksetSettings Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DeleteWorksetSettings()()()() | Constructs a DeleteWorksetSettings object with DeleteWorksetOption::DeleteAllElements option.
Public method | DeleteWorksetSettings(DeleteWorksetOption, WorksetId) | Constructs a DeleteWorksetSettings object.

See Also

DeleteWorksetSettings Class
DeleteWorksetSettings Members


DeleteWorksetSettings Constructor

[image]

Revit 2024 API
DeleteWorksetSettings Constructor
DeleteWorksetSettings Class See Also Send Feedback
Constructs a DeleteWorksetSettings object with DeleteWorksetOption::DeleteAllElements option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022.1

Syntax

C#
public DeleteWorksetSettings()
Visual Basic
Public Sub New
Visual C++
public:
DeleteWorksetSettings()

See Also

DeleteWorksetSettings Class
DeleteWorksetSettings Overload


DeleteWorksetSettings Constructor (DeleteWorksetOption, WorksetId)

[image]

Revit 2024 API
DeleteWorksetSettings Constructor (DeleteWorksetOption, WorksetId)
DeleteWorksetSettings Class See Also Send Feedback
Constructs a DeleteWorksetSettings object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022.1

Syntax

C#
public DeleteWorksetSettings(
    DeleteWorksetOption deleteWorksetOption,
    WorksetId elementsMoveInto
)
Visual Basic
Public Sub New ( _
    deleteWorksetOption As DeleteWorksetOption, _
    elementsMoveInto As WorksetId _
)
Visual C++
public:
DeleteWorksetSettings(
    DeleteWorksetOption deleteWorksetOption,
    WorksetId^ elementsMoveInto
)

Parameters

deleteWorksetOption
Type: Autodesk.Revit.DB..::..DeleteWorksetOption
elementsMoveInto
Type: Autodesk.Revit.DB..::..WorksetId

Remarks

elementsMoveInto only takes effect when DeleteWorksetOption::Enum is MoveElementsToWorkset.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

DeleteWorksetSettings Class
DeleteWorksetSettings Overload


DeleteWorksetSettings Methods

[image] [image]

Revit 2024 API
DeleteWorksetSettings Methods
DeleteWorksetSettings Class See Also Send Feedback

The DeleteWorksetSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DeleteWorksetSettings Class


Dispose Method

[image]

Revit 2024 API
DeleteWorksetSettings..::..Dispose Method
DeleteWorksetSettings Class See Also Send Feedback
Releases all resources used by the DeleteWorksetSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

DeleteWorksetSettings Class


DeleteWorksetSettings Properties

[image] [image]

Revit 2024 API
DeleteWorksetSettings Properties
DeleteWorksetSettings Class See Also Send Feedback

The DeleteWorksetSettings type exposes the following members.

Properties

 | Name | Description
Public property | DeleteWorksetOption | The current delete workset option.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | WorksetId | The target worksetId for those elements under the deleted workset, which is used for DeleteWorksetOption::MoveElementsToWorkset.

See Also

DeleteWorksetSettings Class


DeleteWorksetOption Property

[image]

Revit 2024 API
DeleteWorksetSettings..::..DeleteWorksetOption Property
DeleteWorksetSettings Class See Also Send Feedback
The current delete workset option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022.1

Syntax

C#
public DeleteWorksetOption DeleteWorksetOption { get; set; }
Visual Basic
Public Property DeleteWorksetOption As DeleteWorksetOption
    Get
    Set
Visual C++
public:
property DeleteWorksetOption DeleteWorksetOption {
    DeleteWorksetOption get ();
    void set (DeleteWorksetOption value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

DeleteWorksetSettings Class


IsValidObject Property

[image]

Revit 2024 API
DeleteWorksetSettings..::..IsValidObject Property
DeleteWorksetSettings Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

DeleteWorksetSettings Class


WorksetId Property

[image]

Revit 2024 API
DeleteWorksetSettings..::..WorksetId Property
DeleteWorksetSettings Class See Also Send Feedback
The target worksetId for those elements under the deleted workset, which is used for DeleteWorksetOption::MoveElementsToWorkset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022.1

Syntax

C#
public WorksetId WorksetId { get; set; }
Visual Basic
Public Property WorksetId As WorksetId
    Get
    Set
Visual C++
public:
property WorksetId^ WorksetId {
    WorksetId^ get ();
    void set (WorksetId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

DeleteWorksetSettings Class


DesignOption Members

[image] [image]

Revit 2024 API
DesignOption Members
DesignOption Class Methods Properties See Also Send Feedback

The DesignOption type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
 | GetActiveDesignOptionId | Gets the active design option id for the current design option set.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsPrimary | Determines whether this is a primary design option.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DesignOption Class


IsPrimary Property

[image]

Revit 2024 API
DesignOption..::..IsPrimary Property
DesignOption Class See Also Send Feedback
Determines whether this is a primary design option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsPrimary { get; }
Visual Basic
Public ReadOnly Property IsPrimary As Boolean
    Get
Visual C++
public:
property bool IsPrimary {
    bool get ();
}

See Also

DesignOption Class


Parameter Property

[image] [image]

Revit 2024 API
DesignOption..::..Parameter Property
DesignOption Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

DesignOption Class
DesignOption Members


DetachFromCentralOption Enumeration

[image]

Revit 2024 API
DetachFromCentralOption Enumeration
See Also Send Feedback
Options for workset detachment behavior.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public enum DetachFromCentralOption
Visual Basic
Public Enumeration DetachFromCentralOption
Visual C++
public enum class DetachFromCentralOption

Members

Member name | Description
DoNotDetach | Do not detach the file being opened from its central file.
DetachAndPreserveWorksets | Detach the file being opened from its central file.
DetachAndDiscardWorksets | Detach the model being opened from its central model and discard worksets/worksharing.
ClearTransmittedSaveAsNewCentral | After opening the transmitted, workshared model, immediately resave it with its current name and clear the transmitted flag.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


DetailArc Class

[image]

Revit 2024 API
DetailArc Class
Members See Also Send Feedback
Represents a DetailArc within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class DetailArc : DetailCurve
Visual Basic
Public Class DetailArc _
    Inherits DetailCurve
Visual C++
public ref class DetailArc : public DetailCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from DetailCurve::geometryCurve property.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..CurveElement
Autodesk.Revit.DB..::..DetailCurve
Autodesk.Revit.DB..::..DetailArc

See Also

DetailArc Members


DetailArc Members

[image] [image]

Revit 2024 API
DetailArc Members
DetailArc Class Methods Properties See Also Send Feedback

The DetailArc type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point. (Inherited from CurveElement.)
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable. (Inherited from CurveElement.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element. (Inherited from CurveElement.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point. (Inherited from CurveElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point. (Inherited from CurveElement.)
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point. (Inherited from CurveElement.)
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end. (Inherited from CurveElement.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry. (Inherited from CurveElement.)
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement. (Inherited from CurveElement.)
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point. (Inherited from CurveElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveElementType | Type of the curve element. (Inherited from CurveElement.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element. (Inherited from CurveElement.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DetailArc Class


DetailArc Methods

[image] [image]

Revit 2024 API
DetailArc Methods
DetailArc Class See Also Send Feedback

The DetailArc type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point. (Inherited from CurveElement.)
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable. (Inherited from CurveElement.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element. (Inherited from CurveElement.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point. (Inherited from CurveElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point. (Inherited from CurveElement.)
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point. (Inherited from CurveElement.)
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end. (Inherited from CurveElement.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry. (Inherited from CurveElement.)
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement. (Inherited from CurveElement.)
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point. (Inherited from CurveElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DetailArc Class


DetailArc Properties

[image] [image]

Revit 2024 API
DetailArc Properties
DetailArc Class See Also Send Feedback

The DetailArc type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveElementType | Type of the curve element. (Inherited from CurveElement.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element. (Inherited from CurveElement.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DetailArc Class


DetailCurve Class

[image]

Revit 2024 API
DetailCurve Class
Members See Also Send Feedback
A curve that is used to create a detail drawing. A detail curve is visible only in the view in which it is drawn.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class DetailCurve : CurveElement
Visual Basic
Public Class DetailCurve _
    Inherits CurveElement
Visual C++
public ref class DetailCurve : public CurveElement

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..CurveElement
Autodesk.Revit.DB..::..DetailCurve
Autodesk.Revit.DB..::..DetailArc
Autodesk.Revit.DB..::..DetailEllipse
Autodesk.Revit.DB..::..DetailLine
Autodesk.Revit.DB..::..DetailNurbSpline

See Also

DetailCurve Members


DetailCurve Methods

[image] [image]

Revit 2024 API
DetailCurve Methods
DetailCurve Class See Also Send Feedback

The DetailCurve type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point. (Inherited from CurveElement.)
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable. (Inherited from CurveElement.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element. (Inherited from CurveElement.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point. (Inherited from CurveElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point. (Inherited from CurveElement.)
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point. (Inherited from CurveElement.)
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end. (Inherited from CurveElement.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry. (Inherited from CurveElement.)
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement. (Inherited from CurveElement.)
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point. (Inherited from CurveElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DetailCurve Class


Parameter Property

[image] [image]

Revit 2024 API
DetailCurve..::..Parameter Property
DetailCurve Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

DetailCurve Class
DetailCurve Members


DetailCurveArray Members

[image] [image]

Revit 2024 API
DetailCurveArray Members
DetailCurveArray Class Constructors Methods Properties See Also Send Feedback

The DetailCurveArray type exposes the following members.

Constructors

 | Name | Description
Public method | DetailCurveArray | Initializes a new instance of the DetailCurveArray class

Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

DetailCurveArray Class


DetailCurveArray Constructor

[image]

Revit 2024 API
DetailCurveArray Constructor
DetailCurveArray Class See Also Send Feedback
Initializes a new instance of the DetailCurveArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public DetailCurveArray()
Visual Basic
Public Sub New
Visual C++
public:
DetailCurveArray()

See Also

DetailCurveArray Class


DetailCurveArray Methods

[image] [image]

Revit 2024 API
DetailCurveArray Methods
DetailCurveArray Class See Also Send Feedback

The DetailCurveArray type exposes the following members.

Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DetailCurveArray Class


Append Method

[image]

Revit 2024 API
DetailCurveArray..::..Append Method
DetailCurveArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Append(
    DetailCurve item
)
Visual Basic
Public Overridable Sub Append ( _
    item As DetailCurve _
)
Visual C++
public:
virtual void Append(
    DetailCurve^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..DetailCurve

See Also

DetailCurveArray Class


Clear Method

[image]

Revit 2024 API
DetailCurveArray..::..Clear Method
DetailCurveArray Class See Also Send Feedback
Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

DetailCurveArray Class


ForwardIterator Method

[image]

Revit 2024 API
DetailCurveArray..::..ForwardIterator Method
DetailCurveArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual DetailCurveArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As DetailCurveArrayIterator
Visual C++
public:
virtual DetailCurveArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

DetailCurveArray Class


GetEnumerator Method

[image]

Revit 2024 API
DetailCurveArray..::..GetEnumerator Method
DetailCurveArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

DetailCurveArray Class


Insert Method

[image]

Revit 2024 API
DetailCurveArray..::..Insert Method
DetailCurveArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Insert(
    DetailCurve item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As DetailCurve, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    DetailCurve^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::..DetailCurve
index
Type: System..::..Int32

See Also

DetailCurveArray Class


ReverseIterator Method

[image]

Revit 2024 API
DetailCurveArray..::..ReverseIterator Method
DetailCurveArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual DetailCurveArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As DetailCurveArrayIterator
Visual C++
public:
virtual DetailCurveArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

DetailCurveArray Class


DetailCurveArray Properties

[image] [image]

Revit 2024 API
DetailCurveArray Properties
DetailCurveArray Class See Also Send Feedback

The DetailCurveArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

DetailCurveArray Class


IsEmpty Property

[image]

Revit 2024 API
DetailCurveArray..::..IsEmpty Property
DetailCurveArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

DetailCurveArray Class


Item Property

[image]

Revit 2024 API
DetailCurveArray..::..Item Property
DetailCurveArray Class See Also Send Feedback
Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual DetailCurve this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As DetailCurve
    Get
    Set
Visual C++
public:
virtual property DetailCurve^ Item[int index] {
    DetailCurve^ get (int index);
    void set (int index, DetailCurve^ value);
}

Parameters

index
Type: System..::..Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

DetailCurveArray Class


Size Property

[image]

Revit 2024 API
DetailCurveArray..::..Size Property
DetailCurveArray Class See Also Send Feedback
Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

DetailCurveArray Class


DetailCurveArrayIterator Class

[image]

Revit 2024 API
DetailCurveArrayIterator Class
Members See Also Send Feedback
An iterator to a array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public abstract class DetailCurveArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class DetailCurveArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class DetailCurveArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..DetailCurveArrayIterator

See Also

DetailCurveArrayIterator Members


DetailCurveArrayIterator Members

[image] [image]

Revit 2024 API
DetailCurveArrayIterator Members
DetailCurveArrayIterator Class Constructors Methods Properties See Also Send Feedback

The DetailCurveArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | DetailCurveArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DetailCurveArrayIterator Class


DetailCurveArrayIterator Constructor

[image]

Revit 2024 API
DetailCurveArrayIterator Constructor
DetailCurveArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public DetailCurveArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
DetailCurveArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DetailCurveArrayIterator Class


MoveNext Method

[image]

Revit 2024 API
DetailCurveArrayIterator..::..MoveNext Method
DetailCurveArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

DetailCurveArrayIterator Class


Reset Method

[image]

Revit 2024 API
DetailCurveArrayIterator..::..Reset Method
DetailCurveArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

DetailCurveArrayIterator Class


DetailCurveArrayIterator Properties

[image] [image]

Revit 2024 API
DetailCurveArrayIterator Properties
DetailCurveArrayIterator Class See Also Send Feedback

The DetailCurveArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DetailCurveArrayIterator Class


Current Property

[image]

Revit 2024 API
DetailCurveArrayIterator..::..Current Property
DetailCurveArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

DetailCurveArrayIterator Class


DetailElementOrderUtils Class

[image]

Revit 2024 API
DetailElementOrderUtils Class
Members See Also Send Feedback
A utility class that arranges the draw order of the detail elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static class DetailElementOrderUtils
Visual Basic
Public NotInheritable Class DetailElementOrderUtils
Visual C++
public ref class DetailElementOrderUtils abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..DetailElementOrderUtils

See Also

DetailElementOrderUtils Members


DetailElementOrderUtils Members

[image] [image]

Revit 2024 API
DetailElementOrderUtils Members
DetailElementOrderUtils Class Methods See Also Send Feedback

The DetailElementOrderUtils type exposes the following members.

Methods

Name | Description
AreDetailElements | Indicates if the elements are all detail elements that participate in detail draw ordering in the view.
BringForward(Document, View, ElementId) | Moves the given detail instance one step closer to the front of all other detail instances in the view.
BringForward(Document, View, ICollection<(Of <<'(ElementId>)>>)) | Moves the given detail instances one step closer to the front of all other detail instances in the view, while keeping the order of the given ones.
BringToFront(Document, View, ElementId) | Places the given detail instance in the front of all other detail instances in the view.
BringToFront(Document, View, ICollection<(Of <<'(ElementId>)>>)) | Places the given detail instances in the front of all other detail instances in the view, while keeping the order of the given ones.
GetDrawOrderForDetails | Returns the given detail elements according to the currently specified draw order for the detail elements in a given view.
IsDetailElement | Indicates if the element is a detail element that participates in detail draw ordering in the view.
SendBackward(Document, View, ElementId) | Moves the given detail instance one step closer to the back of all other detail instances in the view.
SendBackward(Document, View, ICollection<(Of <<'(ElementId>)>>)) | Moves the given detail instances one step closer to the back with relation to all other detail instances in the view, while keeping the order of the given ones.
SendToBack(Document, View, ElementId) | Places the given detail instance behind all detail instances in the view.
SendToBack(Document, View, ICollection<(Of <<'(ElementId>)>>)) | Places the given detail instances behind all other detail instances in the view, while keeping the order of the given ones.

See Also

DetailElementOrderUtils Class


DetailElementOrderUtils Methods

[image] [image]

Revit 2024 API
DetailElementOrderUtils Methods
DetailElementOrderUtils Class See Also Send Feedback

The DetailElementOrderUtils type exposes the following members.

Methods

Name | Description
AreDetailElements | Indicates if the elements are all detail elements that participate in detail draw ordering in the view.
BringForward(Document, View, ElementId) | Moves the given detail instance one step closer to the front of all other detail instances in the view.
BringForward(Document, View, ICollection<(Of <<'(ElementId>)>>)) | Moves the given detail instances one step closer to the front of all other detail instances in the view, while keeping the order of the given ones.
BringToFront(Document, View, ElementId) | Places the given detail instance in the front of all other detail instances in the view.
BringToFront(Document, View, ICollection<(Of <<'(ElementId>)>>)) | Places the given detail instances in the front of all other detail instances in the view, while keeping the order of the given ones.
GetDrawOrderForDetails | Returns the given detail elements according to the currently specified draw order for the detail elements in a given view.
IsDetailElement | Indicates if the element is a detail element that participates in detail draw ordering in the view.
SendBackward(Document, View, ElementId) | Moves the given detail instance one step closer to the back of all other detail instances in the view.
SendBackward(Document, View, ICollection<(Of <<'(ElementId>)>>)) | Moves the given detail instances one step closer to the back with relation to all other detail instances in the view, while keeping the order of the given ones.
SendToBack(Document, View, ElementId) | Places the given detail instance behind all detail instances in the view.
SendToBack(Document, View, ICollection<(Of <<'(ElementId>)>>)) | Places the given detail instances behind all other detail instances in the view, while keeping the order of the given ones.

See Also

DetailElementOrderUtils Class


AreDetailElements Method

[image]

Revit 2024 API
DetailElementOrderUtils..::..AreDetailElements Method
DetailElementOrderUtils Class See Also Send Feedback
Indicates if the elements are all detail elements that participate in detail draw ordering in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static bool AreDetailElements(
    Document document,
    View view,
    ICollection<ElementId> detailElementIds
)
Visual Basic
Public Shared Function AreDetailElements ( _
    document As Document, _
    view As View, _
    detailElementIds As ICollection(Of ElementId) _
) As Boolean
Visual C++
public:
static bool AreDetailElements(
    Document^ document,
    View^ view,
    ICollection<ElementId^>^ detailElementIds
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
view
Type: Autodesk.Revit.DB..::..View
The view in which the details appear.
detailElementIds
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
The details to check.

Return Value

True if the detail elements are orderable in the view, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DetailElementOrderUtils Class


BringForward Method

[image] [image]

Revit 2024 API
DetailElementOrderUtils..::..BringForward Method
DetailElementOrderUtils Class See Also Send Feedback

Overload List

Name | Description
BringForward(Document, View, ElementId) | Moves the given detail instance one step closer to the front of all other detail instances in the view.
BringForward(Document, View, ICollection<(Of <<'(ElementId>)>>)) | Moves the given detail instances one step closer to the front of all other detail instances in the view, while keeping the order of the given ones.

See Also

DetailElementOrderUtils Class
DetailElementOrderUtils Members


BringForward Method (Document, View, ElementId)

[image]

Revit 2024 API
DetailElementOrderUtils..::..BringForward Method (Document, View, ElementId)
DetailElementOrderUtils Class See Also Send Feedback
Moves the given detail instance one step closer to the front of all other detail instances in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static void BringForward(
    Document document,
    View view,
    ElementId detailElementId
)
Visual Basic
Public Shared Sub BringForward ( _
    document As Document, _
    view As View, _
    detailElementId As ElementId _
)
Visual C++
public:
static void BringForward(
    Document^ document,
    View^ view,
    ElementId^ detailElementId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
view
Type: Autodesk.Revit.DB..::..View
The view in which the detail appears.
detailElementId
Type: Autodesk.Revit.DB..::..ElementId
The detail to bring forward.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The document does not support detail draw order. Only projects and 3d families support draw order. 2d families and in-place families do not support draw order. -or- The element detailElementId is not a detail or it does not participate in detail draw ordering. Details must be visible in the view. -or- In 3d families, detail draw order can only be adjusted in views that are parallel to the document's X, Y or Z axes.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DetailElementOrderUtils Class
BringForward Overload


BringToFront Method

[image] [image]

Revit 2024 API
DetailElementOrderUtils..::..BringToFront Method
DetailElementOrderUtils Class See Also Send Feedback

Overload List

Name | Description
BringToFront(Document, View, ElementId) | Places the given detail instance in the front of all other detail instances in the view.
BringToFront(Document, View, ICollection<(Of <<'(ElementId>)>>)) | Places the given detail instances in the front of all other detail instances in the view, while keeping the order of the given ones.

See Also

DetailElementOrderUtils Class
DetailElementOrderUtils Members


BringToFront Method (Document, View, ElementId)

[image]

Revit 2024 API
DetailElementOrderUtils..::..BringToFront Method (Document, View, ElementId)
DetailElementOrderUtils Class See Also Send Feedback
Places the given detail instance in the front of all other detail instances in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static void BringToFront(
    Document document,
    View view,
    ElementId detailElementId
)
Visual Basic
Public Shared Sub BringToFront ( _
    document As Document, _
    view As View, _
    detailElementId As ElementId _
)
Visual C++
public:
static void BringToFront(
    Document^ document,
    View^ view,
    ElementId^ detailElementId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
view
Type: Autodesk.Revit.DB..::..View
The view in which the detail appears.
detailElementId
Type: Autodesk.Revit.DB..::..ElementId
The detail element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The document does not support detail draw order. Only projects and 3d families support draw order. 2d families and in-place families do not support draw order. -or- The element detailElementId is not a detail or it does not participate in detail draw ordering. Details must be visible in the view. -or- In 3d families, detail draw order can only be adjusted in views that are parallel to the document's X, Y or Z axes.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DetailElementOrderUtils Class
BringToFront Overload


BringToFront Method (Document, View, ICollection(ElementId))

[image]

Revit 2024 API
DetailElementOrderUtils..::..BringToFront Method (Document, View, ICollection<(Of <(<'ElementId>)>)>)
DetailElementOrderUtils Class See Also Send Feedback
Places the given detail instances in the front of all other detail instances in the view, while keeping the order of the given ones.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static void BringToFront(
    Document document,
    View view,
    ICollection<ElementId> detailElementIds
)
Visual Basic
Public Shared Sub BringToFront ( _
    document As Document, _
    view As View, _
    detailElementIds As ICollection(Of ElementId) _
)
Visual C++
public:
static void BringToFront(
    Document^ document,
    View^ view,
    ICollection<ElementId^>^ detailElementIds
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
view
Type: Autodesk.Revit.DB..::..View
The view in which the details appear.
detailElementIds
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
The details to bring to front.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The document does not support detail draw order. Only projects and 3d families support draw order. 2d families and in-place families do not support draw order. -or- detailElementIds is empty or it contains elements that do not participate in detail draw ordering. Details must be visible in the view. -or- In 3d families, detail draw order can only be adjusted in views that are parallel to the document's X, Y or Z axes.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DetailElementOrderUtils Class
BringToFront Overload


GetDrawOrderForDetails Method

[image]

Revit 2024 API
DetailElementOrderUtils..::..GetDrawOrderForDetails Method
DetailElementOrderUtils Class See Also Send Feedback
Returns the given detail elements according to the currently specified draw order for the detail elements in a given view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static IList<ElementId> GetDrawOrderForDetails(
    View view,
    ISet<ElementId> detailIdsToSort
)
Visual Basic
Public Shared Function GetDrawOrderForDetails ( _
    view As View, _
    detailIdsToSort As ISet(Of ElementId) _
) As IList(Of ElementId)
Visual C++
public:
static IList<ElementId^>^ GetDrawOrderForDetails(
    View^ view,
    ISet<ElementId^>^ detailIdsToSort
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view in which the details appear.
detailIdsToSort
Type: System.Collections.Generic..::..ISet<(Of <(<' ElementId >)>)>
The detail to be sorted by draw order.

Return Value

The detail ids sorted from back to front, with earlier elements drawing first and appearing under later elements.

Remarks

The sort order is from back to front, with earlier elements drawing first and appearing under later elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The document does not support detail draw order. Only projects and 3d families support draw order. 2d families and in-place families do not support draw order. -or- detailIdsToSort is empty or it contains elements are not visible in the view. -or- detailIdsToSort is empty or it contains elements that do not participate in detail draw ordering. Details must be visible in the view.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DetailElementOrderUtils Class


IsDetailElement Method

[image]

Revit 2024 API
DetailElementOrderUtils..::..IsDetailElement Method
DetailElementOrderUtils Class See Also Send Feedback
Indicates if the element is a detail element that participates in detail draw ordering in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static bool IsDetailElement(
    Document document,
    View view,
    ElementId detailElementId
)
Visual Basic
Public Shared Function IsDetailElement ( _
    document As Document, _
    view As View, _
    detailElementId As ElementId _
) As Boolean
Visual C++
public:
static bool IsDetailElement(
    Document^ document,
    View^ view,
    ElementId^ detailElementId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
view
Type: Autodesk.Revit.DB..::..View
The view in which the detail appears.
detailElementId
Type: Autodesk.Revit.DB..::..ElementId
The detail element.

Return Value

True if the detail element is orderable in the view, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DetailElementOrderUtils Class


SendBackward Method

[image] [image]

Revit 2024 API
DetailElementOrderUtils..::..SendBackward Method
DetailElementOrderUtils Class See Also Send Feedback

Overload List

Name | Description
SendBackward(Document, View, ElementId) | Moves the given detail instance one step closer to the back of all other detail instances in the view.
SendBackward(Document, View, ICollection<(Of <<'(ElementId>)>>)) | Moves the given detail instances one step closer to the back with relation to all other detail instances in the view, while keeping the order of the given ones.

See Also

DetailElementOrderUtils Class
DetailElementOrderUtils Members


SendBackward Method (Document, View, ElementId)

[image]

Revit 2024 API
DetailElementOrderUtils..::..SendBackward Method (Document, View, ElementId)
DetailElementOrderUtils Class See Also Send Feedback
Moves the given detail instance one step closer to the back of all other detail instances in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static void SendBackward(
    Document document,
    View view,
    ElementId detailElementId
)
Visual Basic
Public Shared Sub SendBackward ( _
    document As Document, _
    view As View, _
    detailElementId As ElementId _
)
Visual C++
public:
static void SendBackward(
    Document^ document,
    View^ view,
    ElementId^ detailElementId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
view
Type: Autodesk.Revit.DB..::..View
The view in which the detail appears.
detailElementId
Type: Autodesk.Revit.DB..::..ElementId
The detail to move backward.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The document does not support detail draw order. Only projects and 3d families support draw order. 2d families and in-place families do not support draw order. -or- The element detailElementId is not a detail or it does not participate in detail draw ordering. Details must be visible in the view. -or- In 3d families, detail draw order can only be adjusted in views that are parallel to the document's X, Y or Z axes.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DetailElementOrderUtils Class
SendBackward Overload


SendBackward Method (Document, View, ICollection(ElementId))

[image]

Revit 2024 API
DetailElementOrderUtils..::..SendBackward Method (Document, View, ICollection<(Of <(<'ElementId>)>)>)
DetailElementOrderUtils Class See Also Send Feedback
Moves the given detail instances one step closer to the back with relation to all other detail instances in the view, while keeping the order of the given ones.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static void SendBackward(
    Document document,
    View view,
    ICollection<ElementId> detailElementIds
)
Visual Basic
Public Shared Sub SendBackward ( _
    document As Document, _
    view As View, _
    detailElementIds As ICollection(Of ElementId) _
)
Visual C++
public:
static void SendBackward(
    Document^ document,
    View^ view,
    ICollection<ElementId^>^ detailElementIds
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
view
Type: Autodesk.Revit.DB..::..View
The view in which the details appear.
detailElementIds
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
The details to move backward.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The document does not support detail draw order. Only projects and 3d families support draw order. 2d families and in-place families do not support draw order. -or- detailElementIds is empty or it contains elements that do not participate in detail draw ordering. Details must be visible in the view. -or- In 3d families, detail draw order can only be adjusted in views that are parallel to the document's X, Y or Z axes.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DetailElementOrderUtils Class
SendBackward Overload


SendToBack Method (Document, View, ElementId)

[image]

Revit 2024 API
DetailElementOrderUtils..::..SendToBack Method (Document, View, ElementId)
DetailElementOrderUtils Class See Also Send Feedback
Places the given detail instance behind all detail instances in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static void SendToBack(
    Document document,
    View view,
    ElementId detailElementId
)
Visual Basic
Public Shared Sub SendToBack ( _
    document As Document, _
    view As View, _
    detailElementId As ElementId _
)
Visual C++
public:
static void SendToBack(
    Document^ document,
    View^ view,
    ElementId^ detailElementId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
view
Type: Autodesk.Revit.DB..::..View
The view in which the detail appears.
detailElementId
Type: Autodesk.Revit.DB..::..ElementId
The detail to send to back.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The document does not support detail draw order. Only projects and 3d families support draw order. 2d families and in-place families do not support draw order. -or- The element detailElementId is not a detail or it does not participate in detail draw ordering. Details must be visible in the view. -or- In 3d families, detail draw order can only be adjusted in views that are parallel to the document's X, Y or Z axes.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DetailElementOrderUtils Class
SendToBack Overload


DetailEllipse Class

[image]

Revit 2024 API
DetailEllipse Class
Members See Also Send Feedback
Represents a DetailEllipse within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class DetailEllipse : DetailCurve
Visual Basic
Public Class DetailEllipse _
    Inherits DetailCurve
Visual C++
public ref class DetailEllipse : public DetailCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from DetailCurve::geometryCurve property.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..CurveElement
Autodesk.Revit.DB..::..DetailCurve
Autodesk.Revit.DB..::..DetailEllipse

See Also

DetailEllipse Members


DetailEllipse Members

[image] [image]

Revit 2024 API
DetailEllipse Members
DetailEllipse Class Methods Properties See Also Send Feedback

The DetailEllipse type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point. (Inherited from CurveElement.)
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable. (Inherited from CurveElement.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element. (Inherited from CurveElement.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point. (Inherited from CurveElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point. (Inherited from CurveElement.)
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point. (Inherited from CurveElement.)
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end. (Inherited from CurveElement.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry. (Inherited from CurveElement.)
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement. (Inherited from CurveElement.)
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point. (Inherited from CurveElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveElementType | Type of the curve element. (Inherited from CurveElement.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element. (Inherited from CurveElement.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DetailEllipse Class


DetailEllipse Methods

[image] [image]

Revit 2024 API
DetailEllipse Methods
DetailEllipse Class See Also Send Feedback

The DetailEllipse type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point. (Inherited from CurveElement.)
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable. (Inherited from CurveElement.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element. (Inherited from CurveElement.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point. (Inherited from CurveElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point. (Inherited from CurveElement.)
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point. (Inherited from CurveElement.)
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end. (Inherited from CurveElement.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry. (Inherited from CurveElement.)
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement. (Inherited from CurveElement.)
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point. (Inherited from CurveElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DetailEllipse Class


DetailEllipse Properties

[image] [image]

Revit 2024 API
DetailEllipse Properties
DetailEllipse Class See Also Send Feedback

The DetailEllipse type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveElementType | Type of the curve element. (Inherited from CurveElement.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element. (Inherited from CurveElement.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DetailEllipse Class


DetailLine Class

[image]

Revit 2024 API
DetailLine Class
Members See Also Send Feedback
Represents a DetailLine within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class DetailLine : DetailCurve
Visual Basic
Public Class DetailLine _
    Inherits DetailCurve
Visual C++
public ref class DetailLine : public DetailCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from DetailCurve::geometryCurve property.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..CurveElement
Autodesk.Revit.DB..::..DetailCurve
Autodesk.Revit.DB..::..DetailLine

See Also

DetailLine Members


DetailLine Methods

[image] [image]

Revit 2024 API
DetailLine Methods
DetailLine Class See Also Send Feedback

The DetailLine type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point. (Inherited from CurveElement.)
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable. (Inherited from CurveElement.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element. (Inherited from CurveElement.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point. (Inherited from CurveElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point. (Inherited from CurveElement.)
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point. (Inherited from CurveElement.)
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end. (Inherited from CurveElement.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry. (Inherited from CurveElement.)
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement. (Inherited from CurveElement.)
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point. (Inherited from CurveElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DetailLine Class


DetailLine Properties

[image] [image]

Revit 2024 API
DetailLine Properties
DetailLine Class See Also Send Feedback

The DetailLine type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveElementType | Type of the curve element. (Inherited from CurveElement.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element. (Inherited from CurveElement.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DetailLine Class


Parameter Property

[image] [image]

Revit 2024 API
DetailLine..::..Parameter Property
DetailLine Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

DetailLine Class
DetailLine Members


DetailNurbSpline Class

[image]

Revit 2024 API
DetailNurbSpline Class
Members See Also Send Feedback
Represents a DetailNurbSpline within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class DetailNurbSpline : DetailCurve
Visual Basic
Public Class DetailNurbSpline _
    Inherits DetailCurve
Visual C++
public ref class DetailNurbSpline : public DetailCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from DetailCurve::geometryCurve property.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..CurveElement
Autodesk.Revit.DB..::..DetailCurve
Autodesk.Revit.DB..::..DetailNurbSpline

See Also

DetailNurbSpline Members


DetailNurbSpline Members

[image] [image]

Revit 2024 API
DetailNurbSpline Members
DetailNurbSpline Class Methods Properties See Also Send Feedback

The DetailNurbSpline type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point. (Inherited from CurveElement.)
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable. (Inherited from CurveElement.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element. (Inherited from CurveElement.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point. (Inherited from CurveElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point. (Inherited from CurveElement.)
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point. (Inherited from CurveElement.)
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end. (Inherited from CurveElement.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry. (Inherited from CurveElement.)
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement. (Inherited from CurveElement.)
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point. (Inherited from CurveElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveElementType | Type of the curve element. (Inherited from CurveElement.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element. (Inherited from CurveElement.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DetailNurbSpline Class


DetailNurbSpline Methods

[image] [image]

Revit 2024 API
DetailNurbSpline Methods
DetailNurbSpline Class See Also Send Feedback

The DetailNurbSpline type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point. (Inherited from CurveElement.)
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable. (Inherited from CurveElement.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element. (Inherited from CurveElement.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point. (Inherited from CurveElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point. (Inherited from CurveElement.)
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point. (Inherited from CurveElement.)
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end. (Inherited from CurveElement.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry. (Inherited from CurveElement.)
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement. (Inherited from CurveElement.)
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point. (Inherited from CurveElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DetailNurbSpline Class


DetailNurbSpline Properties

[image] [image]

Revit 2024 API
DetailNurbSpline Properties
DetailNurbSpline Class See Also Send Feedback

The DetailNurbSpline type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveElementType | Type of the curve element. (Inherited from CurveElement.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element. (Inherited from CurveElement.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DetailNurbSpline Class


DGNExportOptions Members

[image] [image]

Revit 2024 API
DGNExportOptions Members
DGNExportOptions Class Constructors Methods Properties See Also Send Feedback

The DGNExportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | DGNExportOptions()()()() | Constructs a new instance of DGNExportOptions with default values of all properties.
Public method | DGNExportOptions(DGNExportOptions) | Constructs a new instance of DGNExportOptions as a copy of the export options.

Methods

 | Name | Description
Public method | Dispose | (Inherited from BaseExportOptions.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetExportFontTable | Gets font table. (Inherited from BaseExportOptions.)
Public method | GetExportLayerTable | Gets the layer table. (Inherited from BaseExportOptions.)
Public method | GetExportLinetypeTable | Gets a copy of the line type table. (Inherited from BaseExportOptions.)
Public method | GetExportLineweightTable | Gets a copy of the line weight table.
Public method | GetExportPatternTable | Gets a copy of the pattern table. (Inherited from BaseExportOptions.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPredefinedOptions | Returns an instance DGNExportOptions containing settings from a predefined export setup.
 | GetPredefinedSetupNames | Returns a list of names of predefined setups of DGN export options.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetExportFontTable | Sets font table to option. (Inherited from BaseExportOptions.)
Public method | SetExportLayerTable | Sets layer table back to option (Inherited from BaseExportOptions.)
Public method | SetExportLinetypeTable | Sets the line type table to use during export. (Inherited from BaseExportOptions.)
Public method | SetExportLineweightTable | Sets the line weight table to use during export.
Public method | SetExportPatternTable | Sets the pattern table to use during export. (Inherited from BaseExportOptions.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Colors | Export color mode. Default value is ExportColorMode.IndexColors. (Inherited from BaseExportOptions.)
Public property | FileVersion | The DGN file version. Default value of fileVersion is DGNFileFormat.Default.
Public property | HatchPatternsFileName | Custom hatch patterns (pat) file name. (Inherited from BaseExportOptions.)
Public property | HideReferencePlane | Whether or not to hide reference planes. Default value is false. (Inherited from BaseExportOptions.)
Public property | HideScopeBox | Whether or not to hide the scope box. Default value is false. (Inherited from BaseExportOptions.)
Public property | HideUnreferenceViewTags | Whether or not to hide unreference view tags. Default value is false. (Inherited from BaseExportOptions.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BaseExportOptions.)
Public property | LayerMapping | Name of a layer settings standard or filename (with custom layer settings). Valid standards are: DGNV7 (only for DGN), AIA, CP83, BS1192, and ISO13567. default value is "" (empty) which means if no value is set, if no value is set, Revit will use a default value according to the localization. (Inherited from BaseExportOptions.)
Public property | MergedViews | Whether to merge all views in one file (via XRefs). Default value of mergedViews is false.
Public property | PreserveCoincidentLines | Whether or not to preserve coincident lines. Default value is false. (Inherited from BaseExportOptions.)
Public property | PropOverrides | How to export overridden object styles. Default value is PropOverrideMode.ByEntity. (Inherited from BaseExportOptions.)
Public property | SeedName | The name of the DGN seed. Default value of seedName is empty.
Public property | WorkingUnits | If true, Main Units will be used. If false, Sub Units will be used. Default value of WorkingUnits is true.

See Also

DGNExportOptions Class


DGNExportOptions Constructor

[image] [image]

Revit 2024 API
DGNExportOptions Constructor
DGNExportOptions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DGNExportOptions()()()() | Constructs a new instance of DGNExportOptions with default values of all properties.
Public method | DGNExportOptions(DGNExportOptions) | Constructs a new instance of DGNExportOptions as a copy of the export options.

See Also

DGNExportOptions Class
DGNExportOptions Members


DGNExportOptions Constructor

[image]

Revit 2024 API
DGNExportOptions Constructor
DGNExportOptions Class See Also Send Feedback
Constructs a new instance of DGNExportOptions with default values of all properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public DGNExportOptions()
Visual Basic
Public Sub New
Visual C++
public:
DGNExportOptions()

See Also

DGNExportOptions Class
DGNExportOptions Overload


DGNExportOptions Constructor (DGNExportOptions)

[image]

Revit 2024 API
DGNExportOptions Constructor (DGNExportOptions)
DGNExportOptions Class See Also Send Feedback
Constructs a new instance of DGNExportOptions as a copy of the export options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public DGNExportOptions(
    DGNExportOptions option
)
Visual Basic
Public Sub New ( _
    option As DGNExportOptions _
)
Visual C++
public:
DGNExportOptions(
    DGNExportOptions^ option
)

Parameters

option
Type: Autodesk.Revit.DB..::..DGNExportOptions
The options to be copied.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DGNExportOptions Class
DGNExportOptions Overload


DGNExportOptions Methods

[image] [image]

Revit 2024 API
DGNExportOptions Methods
DGNExportOptions Class See Also Send Feedback

The DGNExportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from BaseExportOptions.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetExportFontTable | Gets font table. (Inherited from BaseExportOptions.)
Public method | GetExportLayerTable | Gets the layer table. (Inherited from BaseExportOptions.)
Public method | GetExportLinetypeTable | Gets a copy of the line type table. (Inherited from BaseExportOptions.)
Public method | GetExportLineweightTable | Gets a copy of the line weight table.
Public method | GetExportPatternTable | Gets a copy of the pattern table. (Inherited from BaseExportOptions.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPredefinedOptions | Returns an instance DGNExportOptions containing settings from a predefined export setup.
 | GetPredefinedSetupNames | Returns a list of names of predefined setups of DGN export options.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetExportFontTable | Sets font table to option. (Inherited from BaseExportOptions.)
Public method | SetExportLayerTable | Sets layer table back to option (Inherited from BaseExportOptions.)
Public method | SetExportLinetypeTable | Sets the line type table to use during export. (Inherited from BaseExportOptions.)
Public method | SetExportLineweightTable | Sets the line weight table to use during export.
Public method | SetExportPatternTable | Sets the pattern table to use during export. (Inherited from BaseExportOptions.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DGNExportOptions Class


GetExportLineweightTable Method

[image]

Revit 2024 API
DGNExportOptions..::..GetExportLineweightTable Method
DGNExportOptions Class See Also Send Feedback
Gets a copy of the line weight table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ExportLineweightTable GetExportLineweightTable()
Visual Basic
Public Function GetExportLineweightTable As ExportLineweightTable
Visual C++
public:
ExportLineweightTable^ GetExportLineweightTable()

Return Value

The line weight table.

See Also

DGNExportOptions Class


GetPredefinedOptions Method

[image]

Revit 2024 API
DGNExportOptions..::..GetPredefinedOptions Method
DGNExportOptions Class See Also Send Feedback
Returns an instance DGNExportOptions containing settings from a predefined export setup.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static DGNExportOptions GetPredefinedOptions(
    Document document,
    string setup
)
Visual Basic
Public Shared Function GetPredefinedOptions ( _
    document As Document, _
    setup As String _
) As DGNExportOptions
Visual C++
public:
static DGNExportOptions^ GetPredefinedOptions(
    Document^ document,
    String^ setup
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
A Revit project document to retrieve the setup from.
setup
Type: System..::..String
The name of a predefined export setup from the specified document.

Return Value

An instance of predefined DGNExportOptions, or nullNothingnullptra null reference (Nothing in Visual Basic) if the name was not found.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DGNExportOptions Class


GetPredefinedSetupNames Method

[image]

Revit 2024 API
DGNExportOptions..::..GetPredefinedSetupNames Method
DGNExportOptions Class See Also Send Feedback
Returns a list of names of predefined setups of DGN export options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static IList<string> GetPredefinedSetupNames(
    Document document
)
Visual Basic
Public Shared Function GetPredefinedSetupNames ( _
    document As Document _
) As IList(Of String)
Visual C++
public:
static IList<String^>^ GetPredefinedSetupNames(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
A Revit document to retrieve names from.

Return Value

An array of strings representing names of predefined setups.

Remarks

To get predefined options in the desired format use the static method getPredefinedOptions defined in DGNExportOptions.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DGNExportOptions Class


DGNExportOptions Properties

[image] [image]

Revit 2024 API
DGNExportOptions Properties
DGNExportOptions Class See Also Send Feedback

The DGNExportOptions type exposes the following members.

Properties

 | Name | Description
Public property | Colors | Export color mode. Default value is ExportColorMode.IndexColors. (Inherited from BaseExportOptions.)
Public property | FileVersion | The DGN file version. Default value of fileVersion is DGNFileFormat.Default.
Public property | HatchPatternsFileName | Custom hatch patterns (pat) file name. (Inherited from BaseExportOptions.)
Public property | HideReferencePlane | Whether or not to hide reference planes. Default value is false. (Inherited from BaseExportOptions.)
Public property | HideScopeBox | Whether or not to hide the scope box. Default value is false. (Inherited from BaseExportOptions.)
Public property | HideUnreferenceViewTags | Whether or not to hide unreference view tags. Default value is false. (Inherited from BaseExportOptions.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BaseExportOptions.)
Public property | LayerMapping | Name of a layer settings standard or filename (with custom layer settings). Valid standards are: DGNV7 (only for DGN), AIA, CP83, BS1192, and ISO13567. default value is "" (empty) which means if no value is set, if no value is set, Revit will use a default value according to the localization. (Inherited from BaseExportOptions.)
Public property | MergedViews | Whether to merge all views in one file (via XRefs). Default value of mergedViews is false.
Public property | PreserveCoincidentLines | Whether or not to preserve coincident lines. Default value is false. (Inherited from BaseExportOptions.)
Public property | PropOverrides | How to export overridden object styles. Default value is PropOverrideMode.ByEntity. (Inherited from BaseExportOptions.)
Public property | SeedName | The name of the DGN seed. Default value of seedName is empty.
Public property | WorkingUnits | If true, Main Units will be used. If false, Sub Units will be used. Default value of WorkingUnits is true.

See Also

DGNExportOptions Class


FileVersion Property

[image]

Revit 2024 API
DGNExportOptions..::..FileVersion Property
DGNExportOptions Class See Also Send Feedback
The DGN file version. Default value of fileVersion is DGNFileFormat.Default.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public DGNFileFormat FileVersion { get; set; }
Visual Basic
Public Property FileVersion As DGNFileFormat
    Get
    Set
Visual C++
public:
property DGNFileFormat FileVersion {
    DGNFileFormat get ();
    void set (DGNFileFormat value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

DGNExportOptions Class


MergedViews Property

[image]

Revit 2024 API
DGNExportOptions..::..MergedViews Property
DGNExportOptions Class See Also Send Feedback
Whether to merge all views in one file (via XRefs). Default value of mergedViews is false.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool MergedViews { get; set; }
Visual Basic
Public Property MergedViews As Boolean
    Get
    Set
Visual C++
public:
property bool MergedViews {
    bool get ();
    void set (bool value);
}

See Also

DGNExportOptions Class


SeedName Property

[image]

Revit 2024 API
DGNExportOptions..::..SeedName Property
DGNExportOptions Class See Also Send Feedback
The name of the DGN seed. Default value of seedName is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public string SeedName { get; set; }
Visual Basic
Public Property SeedName As String
    Get
    Set
Visual C++
public:
property String^ SeedName {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

DGNExportOptions Class


WorkingUnits Property

[image]

Revit 2024 API
DGNExportOptions..::..WorkingUnits Property
DGNExportOptions Class See Also Send Feedback
If true, Main Units will be used. If false, Sub Units will be used. Default value of WorkingUnits is true.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021.1

Syntax

C#
public bool WorkingUnits { get; set; }
Visual Basic
Public Property WorkingUnits As Boolean
    Get
    Set
Visual C++
public:
property bool WorkingUnits {
    bool get ();
    void set (bool value);
}

See Also

DGNExportOptions Class


DGNFileFormat Enumeration

[image]

Revit 2024 API
DGNFileFormat Enumeration
See Also Send Feedback
An enumerated type listing available Microstation versions into which a file may be exported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Since: 2013

Syntax

C#
public enum DGNFileFormat
Visual Basic
Public Enumeration DGNFileFormat
Visual C++
public enum class DGNFileFormat

Members

Member name | Description
DGNVersion7 | Micorstation V7 file format.
Default | The Autodesk Revit application's default file format.
DGNVersion8 | Micorstation V8 file format.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


DGNImportOptions Class

[image]

Revit 2024 API
DGNImportOptions Class
Members See Also Send Feedback
The import options used to import DGN format files.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public class DGNImportOptions : BaseImportOptions
Visual Basic
Public Class DGNImportOptions _
    Inherits BaseImportOptions
Visual C++
public ref class DGNImportOptions : public BaseImportOptions

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BaseImportOptions
Autodesk.Revit.DB..::..DGNImportOptions

See Also

DGNImportOptions Members


DGNImportOptions Constructor

[image] [image]

Revit 2024 API
DGNImportOptions Constructor
DGNImportOptions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DGNImportOptions()()()() | Constructs a new instance of DGNImportOptions with default values of all properties.
Public method | DGNImportOptions(DGNImportOptions) | Constructs a new instance of DGNImportOptions as a copy of the import options.

See Also

DGNImportOptions Class
DGNImportOptions Members


DGNImportOptions Constructor

[image]

Revit 2024 API
DGNImportOptions Constructor
DGNImportOptions Class See Also Send Feedback
Constructs a new instance of DGNImportOptions with default values of all properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public DGNImportOptions()
Visual Basic
Public Sub New
Visual C++
public:
DGNImportOptions()

See Also

DGNImportOptions Class
DGNImportOptions Overload


DGNImportOptions Constructor (DGNImportOptions)

[image]

Revit 2024 API
DGNImportOptions Constructor (DGNImportOptions)
DGNImportOptions Class See Also Send Feedback
Constructs a new instance of DGNImportOptions as a copy of the import options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public DGNImportOptions(
    DGNImportOptions option
)
Visual Basic
Public Sub New ( _
    option As DGNImportOptions _
)
Visual C++
public:
DGNImportOptions(
    DGNImportOptions^ option
)

Parameters

option
Type: Autodesk.Revit.DB..::..DGNImportOptions

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DGNImportOptions Class
DGNImportOptions Overload


DGNImportOptions Properties

[image] [image]

Revit 2024 API
DGNImportOptions Properties
DGNImportOptions Class See Also Send Feedback

The DGNImportOptions type exposes the following members.

Properties

 | Name | Description
Public property | AutoCorrectAlmostVHLines | Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines. (Inherited from BaseImportOptions.)
Public property | ColorMode | Color mode for the import. Three modes are supported. Black and White, Preserve Colors, and Invert Colors. (Inherited from BaseImportOptions.)
Public property | CustomScale | Scaling the import. If this is defined and a valid value (> 0.0), it takes priority over units. (Inherited from BaseImportOptions.)
Public property | DGNModelViewName | The model view name to be imported. Need user give a model view name to specify which model view need to be imported into Revit
Public property | IgnoreUnsupportedElementWarning | If true, ignore warning messages about unsupported elements in the DGN file. If false, the import process is aborted if imported dgn files have unsupported elements.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BaseImportOptions.)
Public property | OrientToView | Place the import at the same orientation as the view that was passed into the import method. This option can only be used when not importing into a single view.(i.e. ThisViewOnly is set to false) (Inherited from BaseImportOptions.)
Public property | Placement | Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates. (Inherited from BaseImportOptions.)
Public property | ReferencePoint | The 3D point in the document where the imported instance will be inserted. If not explicitly set, the instance will be inserted at the document origin. (Inherited from BaseImportOptions.)
Public property | ThisViewOnly | Imports drawings into the view that was passed into the import method. This option is not available in 3D views. (Inherited from BaseImportOptions.)
Public property | Unit | The unit of measure for imported geometry. (Inherited from BaseImportOptions.)
Public property | VisibleLayersOnly | Only import the visible layers. (Inherited from BaseImportOptions.)

See Also

DGNImportOptions Class


IgnoreUnsupportedElementWarning Property

[image]

Revit 2024 API
DGNImportOptions..::..IgnoreUnsupportedElementWarning Property
DGNImportOptions Class See Also Send Feedback
If true, ignore warning messages about unsupported elements in the DGN file. If false, the import process is aborted if imported dgn files have unsupported elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool IgnoreUnsupportedElementWarning { get; set; }
Visual Basic
Public Property IgnoreUnsupportedElementWarning As Boolean
    Get
    Set
Visual C++
public:
property bool IgnoreUnsupportedElementWarning {
    bool get ();
    void set (bool value);
}

See Also

DGNImportOptions Class


DigitGroupingAmount Enumeration

[image]

Revit 2024 API
DigitGroupingAmount Enumeration
See Also Send Feedback
The number of digits in each group when numbers are formatted with digit grouping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014
Since: 2014

Syntax

C#
public enum DigitGroupingAmount
Visual Basic
Public Enumeration DigitGroupingAmount
Visual C++
public enum class DigitGroupingAmount

Members

Member name | Description
Two | Digits are in groups of two, with the exception of the first group to the left of the decimal symbol which contains three digits.
Three | Digits are in groups of three.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


Dimension Class

[image]

Revit 2024 API
Dimension Class
Members Example See Also Send Feedback
An object that represents a dimension within the Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class Dimension : Element
Visual Basic
Public Class Dimension _
    Inherits Element
Visual C++
public ref class Dimension : public Element

Examples

CopyC#
public void GetInfo_Dimension(Dimension dimension)
{
    string message = "Dimension : ";
    // Get Dimension name
    message += "\nDimension name is : " + dimension.Name;

    // Get Dimension Curve
    Autodesk.Revit.DB.Curve curve = dimension.Curve;
    if (curve != null && curve.IsBound)
    {
        // Get curve start point
        message += "\nCurve start point:(" + curve.GetEndPoint(0).X + ", "
             + curve.GetEndPoint(0).Y + ", " + curve.GetEndPoint(0).Z + ")";
        // Get curve end point
        message += "; Curve end point:(" + curve.GetEndPoint(1).X + ", "
             + curve.GetEndPoint(1).Y + ", " + curve.GetEndPoint(1).Z + ")";
    }

    // Get Dimension type name
    message += "\nDimension type name is : " + dimension.DimensionType.Name;

    // Get Dimension view name
    message += "\nDimension view name is : " + dimension.View.Name;

    // Get Dimension reference count
    message += "\nDimension references count is " + dimension.References.Size;

    if (BuiltInCategory.OST_Dimensions == dimension.Category.BuiltInCategory)
    {
        message += "\nDimension is a permanent dimension.";
    }
    else if (BuiltInCategory.OST_Constraints == dimension.Category.BuiltInCategory)
    {
        message += "\nDimension is a constraint element.";
    }

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetInfo_Dimension(dimension As Dimension)
   Dim message As String = "Dimension : "
   ' Get Dimension name
   message += vbLf & "Dimension name is : " + dimension.Name

   ' Get Dimension Curve
   Dim curve As Autodesk.Revit.DB.Curve = dimension.Curve
   If curve IsNot Nothing AndAlso curve.IsBound Then
      ' Get curve start point
      message += vbLf & "Curve start point:(" + curve.GetEndPoint(0).X + ", " + curve.GetEndPoint(0).Y + ", " + curve.GetEndPoint(0).Z + ")"
      ' Get curve end point
      message += "; Curve end point:(" + curve.GetEndPoint(1).X + ", " + curve.GetEndPoint(1).Y + ", " + curve.GetEndPoint(1).Z + ")"
   End If

   ' Get Dimension type name
   message += vbLf & "Dimension type name is : " + dimension.DimensionType.Name

   ' Get Dimension view name
   message += vbLf & "Dimension view name is : " + dimension.View.Name

   ' Get Dimension reference count
   message += vbLf & "Dimension references count is " + dimension.References.Size

   If BuiltInCategory.OST_Dimensions = dimension.Category.BuiltInCategory Then
      message += vbLf & "Dimension is a permanent dimension."
   ElseIf BuiltInCategory.OST_Constraints = dimension.Category.BuiltInCategory Then
      message += vbLf & "Dimension is a constraint element."
   End If

   TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..Dimension
Autodesk.Revit.DB..::..AngularDimension
Autodesk.Revit.DB..::..SpotDimension

See Also

Dimension Members


HasOneSegment Method

[image]

Revit 2024 API
Dimension..::..HasOneSegment Method
Dimension Class See Also Send Feedback
Determines whether a dimension has one segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021.1

Syntax

C#
public bool HasOneSegment()
Visual Basic
Public Function HasOneSegment As Boolean
Visual C++
public:
bool HasOneSegment()

See Also

Dimension Class


ResetTextPosition Method

[image]

Revit 2024 API
Dimension..::..ResetTextPosition Method
Dimension Class See Also Send Feedback
Resets the text position of the dimension to the initial position determined by its type and parameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void ResetTextPosition()
Visual Basic
Public Sub ResetTextPosition
Visual C++
public:
void ResetTextPosition()

Remarks

The initial point is the text position determined by the type and parameters of the dimension. This property is for use with single-segment dimensions only. For multi-segment dimensions use the corresponding method of the DimensionSegment class.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException Thrown when:
  • SpotDimension has more than one segments.

See Also

Dimension Class


Above Property

[image]

Revit 2024 API
Dimension..::..Above Property
Dimension Class See Also Send Feedback
The text shown above the segment's value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string Above { get; set; }
Visual Basic
Public Property Above As String
    Get
    Set
Visual C++
public:
property String^ Above {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is for use with single-segmment dimensions only. For multi-segment dimensions use the corresponding properties of the DimensionSegment class.

See Also

Dimension Class


AreSegmentsEqual Property

[image]

Revit 2024 API
Dimension..::..AreSegmentsEqual Property
Dimension Class See Also Send Feedback
Indicates if all segments are forced to be equal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool AreSegmentsEqual { get; set; }
Visual Basic
Public Property AreSegmentsEqual As Boolean
    Get
    Set
Visual C++
public:
property bool AreSegmentsEqual {
    bool get ();
    void set (bool value);
}

Remarks

This property is usable only for linear dimensions with more than one segment.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the dimension is non-linear or has only one segment.

See Also

Dimension Class


Below Property

[image]

Revit 2024 API
Dimension..::..Below Property
Dimension Class See Also Send Feedback
The text shown below the segment's value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string Below { get; set; }
Visual Basic
Public Property Below As String
    Get
    Set
Visual C++
public:
property String^ Below {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is for use with single-segment dimensions only. For multi-segment dimensions use the corresponding properties of the DimensionSegment class.

See Also

Dimension Class


Curve Property

[image]

Revit 2024 API
Dimension..::..Curve Property
Dimension Class See Also Send Feedback
A curve that represents the dimension line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Curve Curve { get; }
Visual Basic
Public ReadOnly Property Curve As Curve
    Get
Visual C++
public:
property Curve^ Curve {
    Curve^ get ();
}

See Also

Dimension Class


DimensionShape Property

[image]

Revit 2024 API
Dimension..::..DimensionShape Property
Dimension Class See Also Send Feedback
The shape of this dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public DimensionShape DimensionShape { get; }
Visual Basic
Public ReadOnly Property DimensionShape As DimensionShape
    Get
Visual C++
public:
property DimensionShape DimensionShape {
    DimensionShape get ();
}

See Also

Dimension Class


DimensionType Property

[image]

Revit 2024 API
Dimension..::..DimensionType Property
Dimension Class See Also Send Feedback
The dimension style of this dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public DimensionType DimensionType { get; set; }
Visual Basic
Public Property DimensionType As DimensionType
    Get
    Set
Visual C++
public:
property DimensionType^ DimensionType {
    DimensionType^ get ();
    void set (DimensionType^ value);
}

See Also

Dimension Class


IsLocked Property

[image]

Revit 2024 API
Dimension..::..IsLocked Property
Dimension Class See Also Send Feedback
Indicates if this dimension is locked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsLocked { get; set; }
Visual Basic
Public Property IsLocked As Boolean
    Get
    Set
Visual C++
public:
property bool IsLocked {
    bool get ();
    void set (bool value);
}

Remarks

This property always returns false if the dimension is a radial or spot dimension. This property cannot be set if the dimension has been labeled, or if the dimension shape is arc-length, radial, diameter or spot, or if the dimension is linear with more than one segment.

See Also

Dimension Class


IsValid Property

[image]

Revit 2024 API
Dimension..::..IsValid Property
Dimension Class See Also Send Feedback
Indicates if this dimension is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public bool IsValid { get; }
Visual Basic
Public ReadOnly Property IsValid As Boolean
    Get
Visual C++
public:
property bool IsValid {
    bool get ();
}

Remarks

This property always returns true for model dimensions. It can return false for view-specific dimensions that are hidden because they are in an invalid state. An example of an invalid state is having misaligned references for an aligned dimension.

See Also

Dimension Class


Name Property

[image]

Revit 2024 API
Dimension..::..Name Property
Dimension Class See Also Send Feedback
Retrieves or changes the name associated with the Dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Remarks

The property inherited from element is hidden, a System.InvalidOperationException is thrown.

See Also

Dimension Class


NumberOfSegments Property

[image]

Revit 2024 API
Dimension..::..NumberOfSegments Property
Dimension Class See Also Send Feedback
The number of segments for the dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public int NumberOfSegments { get; }
Visual Basic
Public ReadOnly Property NumberOfSegments As Integer
    Get
Visual C++
public:
property int NumberOfSegments {
    int get ();
}

See Also

Dimension Class


Parameter Property

[image] [image]

Revit 2024 API
Dimension..::..Parameter Property
Dimension Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Dimension Class
Dimension Members


Prefix Property

[image]

Revit 2024 API
Dimension..::..Prefix Property
Dimension Class See Also Send Feedback
The text shown before the segment's value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string Prefix { get; set; }
Visual Basic
Public Property Prefix As String
    Get
    Set
Visual C++
public:
property String^ Prefix {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is for use with single-segmment dimensions only. For multi-segment dimensions use the corresponding properties of the DimensionSegment class.

See Also

Dimension Class


TextPosition Property

[image]

Revit 2024 API
Dimension..::..TextPosition Property
Dimension Class Example See Also Send Feedback
The position of the dimension text's drag point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015 Subscription Update

Syntax

C#
public XYZ TextPosition { get; set; }
Visual Basic
Public Property TextPosition As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ TextPosition {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

This property is not applicable to all dimensions. For example, it is not available for spot slope dimensions, multi-segments dimensions, dimensions using equality formula, and when dimension style is ordinate.

If the position is not applicable, this property throws InvalidOperationException.

Examples

CopyC#
    // Get the current text XYZ position
XYZ currentTextPosition = dimToModify.TextPosition;
// Calculate a new XYZ position by transforming the current text position
XYZ newTextPosition = Transform.CreateTranslation(new XYZ(0.0, 1.0, 0.0)).OfPoint(currentTextPosition);
// Set the new text position
dimToModify.TextPosition = newTextPosition;

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException Thrown when:
  • SpotDimension style type is SpotSlope.
  • Using equality formula.
  • Dimension style is ordinate.
-or- Thrown when:
  • SpotDimension has more than one segments.
-or-

See Also

Dimension Class


Value Property

[image]

Revit 2024 API
Dimension..::..Value Property
Dimension Class See Also Send Feedback
The value of the dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Nullable<double> Value { get; }
Visual Basic
Public ReadOnly Property Value As Nullable(Of Double)
    Get
Visual C++
public:
property Nullable<double> Value {
    Nullable<double> get ();
}

Remarks

This nullable property will not have a value for spot dimensions or for linear dimensions with more than one segment.

See Also

Dimension Class


ValueOverride Property

[image]

Revit 2024 API
Dimension..::..ValueOverride Property
Dimension Class See Also Send Feedback
The text that replaces the segment's value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string ValueOverride { get; set; }
Visual Basic
Public Property ValueOverride As String
    Get
    Set
Visual C++
public:
property String^ ValueOverride {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is for use with single-segment dimensions only. For multi-segment dimensions use the corresponding properties of the DimensionSegment class.

See Also

Dimension Class


ValueString Property

[image]

Revit 2024 API
Dimension..::..ValueString Property
Dimension Class See Also Send Feedback
The dimension value as a user visible string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string ValueString { get; }
Visual Basic
Public ReadOnly Property ValueString As String
    Get
Visual C++
public:
property String^ ValueString {
    String^ get ();
}

Remarks

This property always return nullNothingnullptra null reference (Nothing in Visual Basic) if this is a spot dimension, or it is a linear dimension with more than one segments.

See Also

Dimension Class


View Property

[image]

Revit 2024 API
Dimension..::..View Property
Dimension Class See Also Send Feedback
Supplies the view that contains the dimension if the dimension is view specific.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public View View { get; }
Visual Basic
Public ReadOnly Property View As View
    Get
Visual C++
public:
property View^ View {
    View^ get ();
}

See Also

Dimension Class


DimensionEqualityLabelFormatting Class

[image]

Revit 2024 API
DimensionEqualityLabelFormatting Class
Members See Also Send Feedback
Instances of this class represent individual parameters used to make up a dimension equality formula for continuous linear or angular dimensions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update

Syntax

C#
public class DimensionEqualityLabelFormatting : IDisposable
Visual Basic
Public Class DimensionEqualityLabelFormatting _
    Implements IDisposable
Visual C++
public ref class DimensionEqualityLabelFormatting : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..DimensionEqualityLabelFormatting

See Also

DimensionEqualityLabelFormatting Members


DimensionEqualityLabelFormatting Members

[image] [image]

Revit 2024 API
DimensionEqualityLabelFormatting Members
DimensionEqualityLabelFormatting Class Constructors Methods Properties See Also Send Feedback

The DimensionEqualityLabelFormatting type exposes the following members.

Constructors

 | Name | Description
Public method | DimensionEqualityLabelFormatting | Constructs a new instance of a DimensionEqualityLabelFormatting object with specified settings.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the DimensionEqualityLabelFormatting
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetFormatOptions | Gets the format options used to show the parameter value.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFormatOptions | Checks whether a FormatOptions object is valid for the LabelType.
Public method | SetFormatOptions | Sets the format options used to show the parameter value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LabelType | The parameter value to be shown.
Public property | LeadingSpaces | The number of spaces to include before the parameter value.
Public property | Prefix | The prefix to include before the parameter value.
Public property | Suffix | The suffix to include after the parameter value.

See Also

DimensionEqualityLabelFormatting Class


DimensionEqualityLabelFormatting Constructor

[image]

Revit 2024 API
DimensionEqualityLabelFormatting Constructor
DimensionEqualityLabelFormatting Class See Also Send Feedback
Constructs a new instance of a DimensionEqualityLabelFormatting object with specified settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update

Syntax

C#
public DimensionEqualityLabelFormatting(
    int leadingSpaces,
    string prefix,
    LabelType labelType,
    string suffix,
    FormatOptions formatOptions
)
Visual Basic
Public Sub New ( _
    leadingSpaces As Integer, _
    prefix As String, _
    labelType As LabelType, _
    suffix As String, _
    formatOptions As FormatOptions _
)
Visual C++
public:
DimensionEqualityLabelFormatting(
    int leadingSpaces,
    String^ prefix,
    LabelType labelType,
    String^ suffix,
    FormatOptions^ formatOptions
)

Parameters

leadingSpaces
Type: System..::..Int32
The number of spaces to include before the parameter value.
prefix
Type: System..::..String
The prefix to include before the parameter value.
labelType
Type: Autodesk.Revit.DB..::..LabelType
The parameter value to be shown.
suffix
Type: System..::..String
The suffix to include after the parameter value.
formatOptions
Type: Autodesk.Revit.DB..::..FormatOptions
The format options to use for the parameter value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

DimensionEqualityLabelFormatting Class


Dispose Method

[image]

Revit 2024 API
DimensionEqualityLabelFormatting..::..Dispose Method
DimensionEqualityLabelFormatting Class See Also Send Feedback
Releases all resources used by the DimensionEqualityLabelFormatting

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

DimensionEqualityLabelFormatting Class


IsValidFormatOptions Method

[image]

Revit 2024 API
DimensionEqualityLabelFormatting..::..IsValidFormatOptions Method
DimensionEqualityLabelFormatting Class See Also Send Feedback
Checks whether a FormatOptions object is valid for the LabelType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update

Syntax

C#
public bool IsValidFormatOptions()
Visual Basic
Public Function IsValidFormatOptions As Boolean
Visual C++
public:
bool IsValidFormatOptions()

Return Value

True if the FormatOptions object is valid, false otherwise.

Remarks

Only objects whose LabelType is LengthOfSegment or TotalLength can have FormatOptions assigned.

See Also

DimensionEqualityLabelFormatting Class


DimensionEqualityLabelFormatting Properties

[image] [image]

Revit 2024 API
DimensionEqualityLabelFormatting Properties
DimensionEqualityLabelFormatting Class See Also Send Feedback

The DimensionEqualityLabelFormatting type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LabelType | The parameter value to be shown.
Public property | LeadingSpaces | The number of spaces to include before the parameter value.
Public property | Prefix | The prefix to include before the parameter value.
Public property | Suffix | The suffix to include after the parameter value.

See Also

DimensionEqualityLabelFormatting Class


IsValidObject Property

[image]

Revit 2024 API
DimensionEqualityLabelFormatting..::..IsValidObject Property
DimensionEqualityLabelFormatting Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

DimensionEqualityLabelFormatting Class


LabelType Property

[image]

Revit 2024 API
DimensionEqualityLabelFormatting..::..LabelType Property
DimensionEqualityLabelFormatting Class See Also Send Feedback
The parameter value to be shown.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update

Syntax

C#
public LabelType LabelType { get; }
Visual Basic
Public ReadOnly Property LabelType As LabelType
    Get
Visual C++
public:
property LabelType LabelType {
    LabelType get ();
}

See Also

DimensionEqualityLabelFormatting Class


LeadingSpaces Property

[image]

Revit 2024 API
DimensionEqualityLabelFormatting..::..LeadingSpaces Property
DimensionEqualityLabelFormatting Class See Also Send Feedback
The number of spaces to include before the parameter value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update

Syntax

C#
public int LeadingSpaces { get; set; }
Visual Basic
Public Property LeadingSpaces As Integer
    Get
    Set
Visual C++
public:
property int LeadingSpaces {
    int get ();
    void set (int value);
}

See Also

DimensionEqualityLabelFormatting Class


Prefix Property

[image]

Revit 2024 API
DimensionEqualityLabelFormatting..::..Prefix Property
DimensionEqualityLabelFormatting Class See Also Send Feedback
The prefix to include before the parameter value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update

Syntax

C#
public string Prefix { get; set; }
Visual Basic
Public Property Prefix As String
    Get
    Set
Visual C++
public:
property String^ Prefix {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

DimensionEqualityLabelFormatting Class


Suffix Property

[image]

Revit 2024 API
DimensionEqualityLabelFormatting..::..Suffix Property
DimensionEqualityLabelFormatting Class See Also Send Feedback
The suffix to include after the parameter value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update

Syntax

C#
public string Suffix { get; set; }
Visual Basic
Public Property Suffix As String
    Get
    Set
Visual C++
public:
property String^ Suffix {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

DimensionEqualityLabelFormatting Class


DimensionSegment Class

[image]

Revit 2024 API
DimensionSegment Class
Members See Also Send Feedback
A segment of a dimension within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class DimensionSegment : APIObject
Visual Basic
Public Class DimensionSegment _
    Inherits APIObject
Visual C++
public ref class DimensionSegment : public APIObject

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..DimensionSegment

See Also

DimensionSegment Members


DimensionSegment Members

[image] [image]

Revit 2024 API
DimensionSegment Members
DimensionSegment Class Methods Properties See Also Send Feedback

The DimensionSegment type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsTextPositionAdjustable | Indicates if this dimension is supported to set/get TextPosition/LeaderPosition.
Public method | ResetTextPosition | Resets the text position of the segment to the initial position determined by its type and parameters.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Above | The text shown above the segment's value.
Public property | Below | The text shown below the segment's value.
Public property | IsLocked | Indicates if this segment is locked.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | LeaderEndPosition | The position of the dimension leader end point.
Public property | Origin | The segment origin.
Public property | Prefix | The text shown before the segment's value.
Public property | Suffix | The text shown after the segment's value.
Public property | TextPosition | The position of the dimension text's drag point.
Public property | Value | The length of the segment.
Public property | ValueOverride | The text that replaces the segment's value.
Public property | ValueString | The displayed value shown for the dimension segment.

See Also

DimensionSegment Class


DimensionSegment Methods

[image] [image]

Revit 2024 API
DimensionSegment Methods
DimensionSegment Class See Also Send Feedback

The DimensionSegment type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsTextPositionAdjustable | Indicates if this dimension is supported to set/get TextPosition/LeaderPosition.
Public method | ResetTextPosition | Resets the text position of the segment to the initial position determined by its type and parameters.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DimensionSegment Class


IsTextPositionAdjustable Method

[image]

Revit 2024 API
DimensionSegment..::..IsTextPositionAdjustable Method
DimensionSegment Class See Also Send Feedback
Indicates if this dimension is supported to set/get TextPosition/LeaderPosition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015 Subscription Update

Syntax

C#
public bool IsTextPositionAdjustable()
Visual Basic
Public Function IsTextPositionAdjustable As Boolean
Visual C++
public:
bool IsTextPositionAdjustable()

Return Value

True if this dimension is supported to set/get TextPosition/LeaderPosition, false otherwise.

See Also

DimensionSegment Class


ResetTextPosition Method

[image]

Revit 2024 API
DimensionSegment..::..ResetTextPosition Method
DimensionSegment Class See Also Send Feedback
Resets the text position of the segment to the initial position determined by its type and parameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015 Subscription Update

Syntax

C#
public void ResetTextPosition()
Visual Basic
Public Sub ResetTextPosition
Visual C++
public:
void ResetTextPosition()

Remarks

The initial point is the text location when dimension is created.

See Also

DimensionSegment Class


DimensionSegment Properties

[image] [image]

Revit 2024 API
DimensionSegment Properties
DimensionSegment Class See Also Send Feedback

The DimensionSegment type exposes the following members.

Properties

 | Name | Description
Public property | Above | The text shown above the segment's value.
Public property | Below | The text shown below the segment's value.
Public property | IsLocked | Indicates if this segment is locked.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | LeaderEndPosition | The position of the dimension leader end point.
Public property | Origin | The segment origin.
Public property | Prefix | The text shown before the segment's value.
Public property | Suffix | The text shown after the segment's value.
Public property | TextPosition | The position of the dimension text's drag point.
Public property | Value | The length of the segment.
Public property | ValueOverride | The text that replaces the segment's value.
Public property | ValueString | The displayed value shown for the dimension segment.

See Also

DimensionSegment Class


Above Property

[image]

Revit 2024 API
DimensionSegment..::..Above Property
DimensionSegment Class See Also Send Feedback
The text shown above the segment's value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string Above { get; set; }
Visual Basic
Public Property Above As String
    Get
    Set
Visual C++
public:
property String^ Above {
    String^ get ();
    void set (String^ value);
}

See Also

DimensionSegment Class


Below Property

[image]

Revit 2024 API
DimensionSegment..::..Below Property
DimensionSegment Class See Also Send Feedback
The text shown below the segment's value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string Below { get; set; }
Visual Basic
Public Property Below As String
    Get
    Set
Visual C++
public:
property String^ Below {
    String^ get ();
    void set (String^ value);
}

See Also

DimensionSegment Class


LeaderEndPosition Property

[image]

Revit 2024 API
DimensionSegment..::..LeaderEndPosition Property
DimensionSegment Class See Also Send Feedback
The position of the dimension leader end point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015 Subscription Update.

Syntax

C#
public XYZ LeaderEndPosition { get; set; }
Visual Basic
Public Property LeaderEndPosition As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ LeaderEndPosition {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

This property is not applicable to all dimensions. For example, it is not available for spot dimensions, dimensions using equality formula, and when dimension style is ordinate.

If the position is not applicable, this property returns NULL and will not allow setting a value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ApplicationException | Thrown when the dimension text is unavailable.
Autodesk.Revit.Exceptions..::..InvalidOperationException Thrown when:
  • The dimension text is a SpotElevation
  • When using equality formula.
  • When dimension style is ordinate.

See Also

DimensionSegment Class


Origin Property

[image]

Revit 2024 API
DimensionSegment..::..Origin Property
DimensionSegment Class See Also Send Feedback
The segment origin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ Origin { get; }
Visual Basic
Public ReadOnly Property Origin As XYZ
    Get
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
}

Remarks

The origin will be the midpoint of the line that makes up the segment.

See Also

DimensionSegment Class


Prefix Property

[image]

Revit 2024 API
DimensionSegment..::..Prefix Property
DimensionSegment Class See Also Send Feedback
The text shown before the segment's value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string Prefix { get; set; }
Visual Basic
Public Property Prefix As String
    Get
    Set
Visual C++
public:
property String^ Prefix {
    String^ get ();
    void set (String^ value);
}

See Also

DimensionSegment Class


Suffix Property

[image]

Revit 2024 API
DimensionSegment..::..Suffix Property
DimensionSegment Class See Also Send Feedback
The text shown after the segment's value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string Suffix { get; set; }
Visual Basic
Public Property Suffix As String
    Get
    Set
Visual C++
public:
property String^ Suffix {
    String^ get ();
    void set (String^ value);
}

See Also

DimensionSegment Class


TextPosition Property

[image]

Revit 2024 API
DimensionSegment..::..TextPosition Property
DimensionSegment Class Example See Also Send Feedback
The position of the dimension text's drag point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015 Subscription Update

Syntax

C#
public XYZ TextPosition { get; set; }
Visual Basic
Public Property TextPosition As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ TextPosition {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

This property is not applicable to all dimensions. For example, it is not available for spot dimensions, dimensions using equality formula, and when dimension style is ordinate.

If the position is not applicable, this property returns NULL and will not allow setting a value.

Examples

CopyC#
      // Get the current text XYZ position
XYZ currentTextPosition = currentSegment.TextPosition;
// Calculate a new XYZ position by transforming the current text position
XYZ newTextPosition = Transform.CreateTranslation(new XYZ(0, 1, 0)).OfPoint(currentTextPosition);
// Set the new text position for the segment's text
currentSegment.TextPosition = newTextPosition;

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ApplicationException | Thrown when the dimension text is unavailable.
Autodesk.Revit.Exceptions..::..InvalidOperationException Thrown when:
  • The dimension text is a SpotElevation
  • When using equality formula.
  • When dimension style is ordinate.
.

See Also

DimensionSegment Class


ValueString Property

[image]

Revit 2024 API
DimensionSegment..::..ValueString Property
DimensionSegment Class See Also Send Feedback
The displayed value shown for the dimension segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string ValueString { get; }
Visual Basic
Public ReadOnly Property ValueString As String
    Get
Visual C++
public:
property String^ ValueString {
    String^ get ();
}

See Also

DimensionSegment Class


DimensionSegmentArray Members

[image] [image]

Revit 2024 API
DimensionSegmentArray Members
DimensionSegmentArray Class Constructors Methods Properties See Also Send Feedback

The DimensionSegmentArray type exposes the following members.

Constructors

 | Name | Description
Public method | DimensionSegmentArray | Initializes a new instance of the DimensionSegmentArray class

Methods

 | Name | Description
Public method | Append | Add the item to the end of the array.
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

DimensionSegmentArray Class


DimensionSegmentArray Constructor

[image]

Revit 2024 API
DimensionSegmentArray Constructor
DimensionSegmentArray Class See Also Send Feedback
Initializes a new instance of the DimensionSegmentArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public DimensionSegmentArray()
Visual Basic
Public Sub New
Visual C++
public:
DimensionSegmentArray()

See Also

DimensionSegmentArray Class


Append Method

[image]

Revit 2024 API
DimensionSegmentArray..::..Append Method
DimensionSegmentArray Class See Also Send Feedback
Add the item to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Append(
    DimensionSegment item
)
Visual Basic
Public Overridable Sub Append ( _
    item As DimensionSegment _
)
Visual C++
public:
virtual void Append(
    DimensionSegment^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..DimensionSegment
The item to be added.

See Also

DimensionSegmentArray Class


Clear Method

[image]

Revit 2024 API
DimensionSegmentArray..::..Clear Method
DimensionSegmentArray Class See Also Send Feedback
Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

DimensionSegmentArray Class


ForwardIterator Method

[image]

Revit 2024 API
DimensionSegmentArray..::..ForwardIterator Method
DimensionSegmentArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual DimensionSegmentArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As DimensionSegmentArrayIterator
Visual C++
public:
virtual DimensionSegmentArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

DimensionSegmentArray Class


GetEnumerator Method

[image]

Revit 2024 API
DimensionSegmentArray..::..GetEnumerator Method
DimensionSegmentArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

DimensionSegmentArray Class


Insert Method

[image]

Revit 2024 API
DimensionSegmentArray..::..Insert Method
DimensionSegmentArray Class See Also Send Feedback
Insert the specified item into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Insert(
    DimensionSegment item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As DimensionSegment, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    DimensionSegment^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::..DimensionSegment
The item to be inserted into the array.
index
Type: System..::..Int32
The item will be inserted before this index.

Return Value

Returns whether the item was inserted into the array.

See Also

DimensionSegmentArray Class


ReverseIterator Method

[image]

Revit 2024 API
DimensionSegmentArray..::..ReverseIterator Method
DimensionSegmentArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual DimensionSegmentArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As DimensionSegmentArrayIterator
Visual C++
public:
virtual DimensionSegmentArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

DimensionSegmentArray Class


IsEmpty Property

[image]

Revit 2024 API
DimensionSegmentArray..::..IsEmpty Property
DimensionSegmentArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

DimensionSegmentArray Class


Size Property

[image]

Revit 2024 API
DimensionSegmentArray..::..Size Property
DimensionSegmentArray Class See Also Send Feedback
Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

DimensionSegmentArray Class


DimensionSegmentArrayIterator Class

[image]

Revit 2024 API
DimensionSegmentArrayIterator Class
Members See Also Send Feedback
An iterator to an array of DimensionSegment objects..

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public abstract class DimensionSegmentArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class DimensionSegmentArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class DimensionSegmentArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..DimensionSegmentArrayIterator

See Also

DimensionSegmentArrayIterator Members


MoveNext Method

[image]

Revit 2024 API
DimensionSegmentArrayIterator..::..MoveNext Method
DimensionSegmentArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

DimensionSegmentArrayIterator Class


Reset Method

[image]

Revit 2024 API
DimensionSegmentArrayIterator..::..Reset Method
DimensionSegmentArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

DimensionSegmentArrayIterator Class


DimensionSegmentArrayIterator Properties

[image] [image]

Revit 2024 API
DimensionSegmentArrayIterator Properties
DimensionSegmentArrayIterator Class See Also Send Feedback

The DimensionSegmentArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DimensionSegmentArrayIterator Class


Current Property

[image]

Revit 2024 API
DimensionSegmentArrayIterator..::..Current Property
DimensionSegmentArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

DimensionSegmentArrayIterator Class


DimensionShape Enumeration

[image]

Revit 2024 API
DimensionShape Enumeration
See Also Send Feedback
An enumerated type to list dimension type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum DimensionShape
Visual Basic
Public Enumeration DimensionShape
Visual C++
public enum class DimensionShape

Members

Member name | Description
Linear | Linear dimension.
Angular | Angular dimension.
Radial | Radial dimension.
ArcLength | ArcLength dimension.
Spot | Spot dimension.
Diameter | Diameter dimension.
Unknown | Unknown type dimension.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


DimensionStyleType Enumeration

[image]

Revit 2024 API
DimensionStyleType Enumeration
See Also Send Feedback
An enumerated type containing possible style types of dimensions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum DimensionStyleType
Visual Basic
Public Enumeration DimensionStyleType
Visual C++
public enum class DimensionStyleType

Members

Member name | Description
Linear | Linear dimension.
Angular | Angular dimension.
Radial | Radial dimension.
ArcLength | ArcLength dimension.
SpotElevation | SpotElevation
SpotCoordinate | SpotCoordinate
LinearFixed | LinearFixed dimension, which is linear dimension whose direction is parallel to X or Y.
SpotSlope | SpotSlope
Diameter | Diameter dimension.
AlignmentStationLabel | Alignment Station Label

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


DimensionType Class

[image]

Revit 2024 API
DimensionType Class
Members See Also Send Feedback
An object that represents a dimension style.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class DimensionType : ElementType
Visual Basic
Public Class DimensionType _
    Inherits ElementType
Visual C++
public ref class DimensionType : public ElementType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..DimensionType
Autodesk.Revit.DB..::..SpotDimensionType

See Also

DimensionType Members


DimensionType Members

[image] [image]

Revit 2024 API
DimensionType Members
DimensionType Class Methods Properties See Also Send Feedback

The DimensionType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveEqualityFormula | Checks whether this DimensionType can have an equality formula.
Public method | CanHaveOrdinateDimensionSetting | Checks whether this DimensionType can have an ordinate dimension settings.
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetAlternateUnitsFormatOptions | Gets the FormatOptions to optionally override the default settings in the Units class for the alternate units value.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetEqualityFormula | Gets an ordered list of the entries in the equality formula definition.
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetOrdinateDimensionSetting | Gets the ordinate dimension settings for this DimensionType.
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSpecTypeId | Gets the spec of this dimension style.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetUnitsFormatOptions | Gets the FormatOptions to optionally override the default settings in the Units class for the units value.
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetAlternateUnitsFormatOptions | Sets the FormatOptions to optionally override the default settings in the Units class for the alternate units value.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetEqualityFormula | Sets an ordered list of the entries to use in the equality formula definition.
Public method | SetOrdinateDimensionSetting | Sets the ordinate dimension settings for this DimensionType.
Public method | SetUnitsFormatOptions | Sets the FormatOptions to optionally override the default settings in the Units class for the units value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AlternateUnits | The alternate units display mode for this DimensionType.
Public property | AlternateUnitsPrefix | The prefix text for the alternate units value.
Public property | AlternateUnitsSuffix | The suffix text for the alternate units value.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Prefix | The prefix text for the dimension value.
Public property | StyleType | The dimension style type of this DimensionType.
Public property | Suffix | The suffix text for the dimension value.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DimensionType Class


DimensionType Methods

[image] [image]

Revit 2024 API
DimensionType Methods
DimensionType Class See Also Send Feedback

The DimensionType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveEqualityFormula | Checks whether this DimensionType can have an equality formula.
Public method | CanHaveOrdinateDimensionSetting | Checks whether this DimensionType can have an ordinate dimension settings.
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetAlternateUnitsFormatOptions | Gets the FormatOptions to optionally override the default settings in the Units class for the alternate units value.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetEqualityFormula | Gets an ordered list of the entries in the equality formula definition.
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetOrdinateDimensionSetting | Gets the ordinate dimension settings for this DimensionType.
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSpecTypeId | Gets the spec of this dimension style.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetUnitsFormatOptions | Gets the FormatOptions to optionally override the default settings in the Units class for the units value.
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetAlternateUnitsFormatOptions | Sets the FormatOptions to optionally override the default settings in the Units class for the alternate units value.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetEqualityFormula | Sets an ordered list of the entries to use in the equality formula definition.
Public method | SetOrdinateDimensionSetting | Sets the ordinate dimension settings for this DimensionType.
Public method | SetUnitsFormatOptions | Sets the FormatOptions to optionally override the default settings in the Units class for the units value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DimensionType Class


CanHaveOrdinateDimensionSetting Method

[image]

Revit 2024 API
DimensionType..::..CanHaveOrdinateDimensionSetting Method
DimensionType Class See Also Send Feedback
Checks whether this DimensionType can have an ordinate dimension settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool CanHaveOrdinateDimensionSetting()
Visual Basic
Public Function CanHaveOrdinateDimensionSetting As Boolean
Visual C++
public:
bool CanHaveOrdinateDimensionSetting()

Return Value

True when the DimensionType is linear and the Dimension String Type parameter is ordinate, false otherwise.

Remarks

It returns true when the DimensionType is linear and when Dimension String Type parameter is set to Ordinate.

See Also

DimensionType Class


GetAlternateUnitsFormatOptions Method

[image]

Revit 2024 API
DimensionType..::..GetAlternateUnitsFormatOptions Method
DimensionType Class See Also Send Feedback
Gets the FormatOptions to optionally override the default settings in the Units class for the alternate units value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FormatOptions GetAlternateUnitsFormatOptions()
Visual Basic
Public Function GetAlternateUnitsFormatOptions As FormatOptions
Visual C++
public:
FormatOptions^ GetAlternateUnitsFormatOptions()

Return Value

A copy of the FormatOptions.

See Also

DimensionType Class


GetEqualityFormula Method

[image]

Revit 2024 API
DimensionType..::..GetEqualityFormula Method
DimensionType Class See Also Send Feedback
Gets an ordered list of the entries in the equality formula definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update

Syntax

C#
public IList<DimensionEqualityLabelFormatting> GetEqualityFormula()
Visual Basic
Public Function GetEqualityFormula As IList(Of DimensionEqualityLabelFormatting)
Visual C++
public:
IList<DimensionEqualityLabelFormatting^>^ GetEqualityFormula()

Return Value

An ordered list of the entries in the equality formula definition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The given DimensionType cannot be assigned an equality formula as it is not continuous linear or angular.

See Also

DimensionType Class


GetOrdinateDimensionSetting Method

[image]

Revit 2024 API
DimensionType..::..GetOrdinateDimensionSetting Method
DimensionType Class See Also Send Feedback
Gets the ordinate dimension settings for this DimensionType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update

Syntax

C#
public OrdinateDimensionSetting GetOrdinateDimensionSetting()
Visual Basic
Public Function GetOrdinateDimensionSetting As OrdinateDimensionSetting
Visual C++
public:
OrdinateDimensionSetting^ GetOrdinateDimensionSetting()

Return Value

The ordinate dimension settings.

See Also

DimensionType Class


GetSpecTypeId Method

[image]

Revit 2024 API
DimensionType..::..GetSpecTypeId Method
DimensionType Class See Also Send Feedback
Gets the spec of this dimension style.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ForgeTypeId GetSpecTypeId()
Visual Basic
Public Function GetSpecTypeId As ForgeTypeId
Visual C++
public:
ForgeTypeId^ GetSpecTypeId()

Return Value

Identifier of the spec.

Remarks

The spec will represent either length, angle or slope.

See Also

DimensionType Class


GetUnitsFormatOptions Method

[image]

Revit 2024 API
DimensionType..::..GetUnitsFormatOptions Method
DimensionType Class See Also Send Feedback
Gets the FormatOptions to optionally override the default settings in the Units class for the units value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update

Syntax

C#
public FormatOptions GetUnitsFormatOptions()
Visual Basic
Public Function GetUnitsFormatOptions As FormatOptions
Visual C++
public:
FormatOptions^ GetUnitsFormatOptions()

Return Value

A copy of the FormatOptions.

See Also

DimensionType Class


SetAlternateUnitsFormatOptions Method

[image]

Revit 2024 API
DimensionType..::..SetAlternateUnitsFormatOptions Method
DimensionType Class See Also Send Feedback
Sets the FormatOptions to optionally override the default settings in the Units class for the alternate units value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetAlternateUnitsFormatOptions(
    FormatOptions formatOptions
)
Visual Basic
Public Sub SetAlternateUnitsFormatOptions ( _
    formatOptions As FormatOptions _
)
Visual C++
public:
void SetAlternateUnitsFormatOptions(
    FormatOptions^ formatOptions
)

Parameters

formatOptions
Type: Autodesk.Revit.DB..::..FormatOptions
The FormatOptions.

Remarks

See the UnitType property to determine the unit type of this dimension style.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The display unit in formatOptions is not a valid display unit for the unit type of this DimensionType, or the rounding method in formatOptions is not set to Nearest. See UnitUtils.IsValidDisplayUnit(UnitType, DisplayUnitType), UnitUtils.GetValidDisplayUnits(UnitType) and FormatOptions.RoundingMethod.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DimensionType Class


SetEqualityFormula Method

[image]

Revit 2024 API
DimensionType..::..SetEqualityFormula Method
DimensionType Class See Also Send Feedback
Sets an ordered list of the entries to use in the equality formula definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update

Syntax

C#
public void SetEqualityFormula(
    IList<DimensionEqualityLabelFormatting> formattingArr
)
Visual Basic
Public Sub SetEqualityFormula ( _
    formattingArr As IList(Of DimensionEqualityLabelFormatting) _
)
Visual C++
public:
void SetEqualityFormula(
    IList<DimensionEqualityLabelFormatting^>^ formattingArr
)

Parameters

formattingArr
Type: System.Collections.Generic..::..IList<(Of <(<' DimensionEqualityLabelFormatting >)>)>
An ordered list of the entries to use in the equality formula definition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input equality formula entries are not valid for use in the given DimensionType.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DimensionType Class


SetOrdinateDimensionSetting Method

[image]

Revit 2024 API
DimensionType..::..SetOrdinateDimensionSetting Method
DimensionType Class See Also Send Feedback
Sets the ordinate dimension settings for this DimensionType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update

Syntax

C#
public void SetOrdinateDimensionSetting(
    OrdinateDimensionSetting ordinateDimSetting
)
Visual Basic
Public Sub SetOrdinateDimensionSetting ( _
    ordinateDimSetting As OrdinateDimensionSetting _
)
Visual C++
public:
void SetOrdinateDimensionSetting(
    OrdinateDimensionSetting^ ordinateDimSetting
)

Parameters

ordinateDimSetting
Type: Autodesk.Revit.DB..::..OrdinateDimensionSetting
The new ordinate dimension settings.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The origin tick mark id in the Ordinate Dimension Setting is invalid for the dimension style.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This DimensionType cannot be assigned ordinate dimension settings, as it is not a linear DimensionType or its Dimension String Type parameter is not set to Ordinate.

See Also

DimensionType Class


SetUnitsFormatOptions Method

[image]

Revit 2024 API
DimensionType..::..SetUnitsFormatOptions Method
DimensionType Class See Also Send Feedback
Sets the FormatOptions to optionally override the default settings in the Units class for the units value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update

Syntax

C#
public void SetUnitsFormatOptions(
    FormatOptions formatOptions
)
Visual Basic
Public Sub SetUnitsFormatOptions ( _
    formatOptions As FormatOptions _
)
Visual C++
public:
void SetUnitsFormatOptions(
    FormatOptions^ formatOptions
)

Parameters

formatOptions
Type: Autodesk.Revit.DB..::..FormatOptions
The FormatOptions.

Remarks

See the UnitType property to determine the unit type of this dimension style.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The display unit in formatOptions is not a valid display unit for the unit type of this DimensionType, or the rounding method in formatOptions is not set to Nearest. See UnitUtils.IsValidDisplayUnit(UnitType, DisplayUnitType), UnitUtils.GetValidDisplayUnits(UnitType) and FormatOptions.RoundingMethod.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DimensionType Class


DimensionType Properties

[image] [image]

Revit 2024 API
DimensionType Properties
DimensionType Class See Also Send Feedback

The DimensionType type exposes the following members.

Properties

 | Name | Description
Public property | AlternateUnits | The alternate units display mode for this DimensionType.
Public property | AlternateUnitsPrefix | The prefix text for the alternate units value.
Public property | AlternateUnitsSuffix | The suffix text for the alternate units value.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Prefix | The prefix text for the dimension value.
Public property | StyleType | The dimension style type of this DimensionType.
Public property | Suffix | The suffix text for the dimension value.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DimensionType Class


AlternateUnits Property

[image]

Revit 2024 API
DimensionType..::..AlternateUnits Property
DimensionType Class See Also Send Feedback
The alternate units display mode for this DimensionType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public AlternateUnits AlternateUnits { get; set; }
Visual Basic
Public Property AlternateUnits As AlternateUnits
    Get
    Set
Visual C++
public:
property AlternateUnits AlternateUnits {
    AlternateUnits get ();
    void set (AlternateUnits value);
}

Field Value

Alternate units let dimensions display values in multiple units. For example, for a dimension which shows its values in imperial units, alternate units can be used to repeat those values in metric units.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

DimensionType Class


AlternateUnitsPrefix Property

[image]

Revit 2024 API
DimensionType..::..AlternateUnitsPrefix Property
DimensionType Class See Also Send Feedback
The prefix text for the alternate units value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string AlternateUnitsPrefix { get; set; }
Visual Basic
Public Property AlternateUnitsPrefix As String
    Get
    Set
Visual C++
public:
property String^ AlternateUnitsPrefix {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

DimensionType Class


Parameter Property

[image] [image]

Revit 2024 API
DimensionType..::..Parameter Property
DimensionType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

DimensionType Class
DimensionType Members


Prefix Property

[image]

Revit 2024 API
DimensionType..::..Prefix Property
DimensionType Class See Also Send Feedback
The prefix text for the dimension value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public string Prefix { get; set; }
Visual Basic
Public Property Prefix As String
    Get
    Set
Visual C++
public:
property String^ Prefix {
    String^ get ();
    void set (String^ value);
}

Remarks

The text goes immediately before the value and is not overridden by the possible instance prefix.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

DimensionType Class


StyleType Property

[image]

Revit 2024 API
DimensionType..::..StyleType Property
DimensionType Class See Also Send Feedback
The dimension style type of this DimensionType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public DimensionStyleType StyleType { get; }
Visual Basic
Public ReadOnly Property StyleType As DimensionStyleType
    Get
Visual C++
public:
property DimensionStyleType StyleType {
    DimensionStyleType get ();
}

See Also

DimensionType Class


Suffix Property

[image]

Revit 2024 API
DimensionType..::..Suffix Property
DimensionType Class See Also Send Feedback
The suffix text for the dimension value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public string Suffix { get; set; }
Visual Basic
Public Property Suffix As String
    Get
    Set
Visual C++
public:
property String^ Suffix {
    String^ get ();
    void set (String^ value);
}

Remarks

The text goes immediately after the value and is not overridden by the possible instance suffix.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

DimensionType Class


DirectShape Class

[image]

Revit 2024 API
DirectShape Class
Members Example See Also Send Feedback
This class is used to store externally created geometric shapes. Primary intended use is for importing shapes from other data formats such as IFC or STEP. A DirectShape object may be assigned a category. That will affect how that object is displayed in Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public class DirectShape : Element
Visual Basic
Public Class DirectShape _
    Inherits Element
Visual C++
public ref class DirectShape : public Element

Remarks

DirectShape is not a replacement for "real" Wall, Roof, Window, etc. It would typically be used where there is not enough information to create, e.g., a Wall, or full functionality of a Wall object is not needed. Some category-specific functionality may be available. If you need to modify a shape held by a DirectShape object, use Revit Geometry API, and then store the modified shape back to the DirectShape object.

Examples

CopyC#
// Create a DirectShape Sphere
public void CreateSphereDirectShape(Document doc)
{
    List<Curve> profile = new List<Curve>();

    // first create sphere with 2' radius
    XYZ center = XYZ.Zero;
    double radius = 2.0;
    XYZ profile00 = center;
    XYZ profilePlus = center + new XYZ(0, radius, 0);
    XYZ profileMinus = center - new XYZ(0, radius, 0);

    profile.Add(Line.CreateBound(profilePlus, profileMinus));
    profile.Add(Arc.Create(profileMinus, profilePlus, center + new XYZ(radius, 0, 0)));

    CurveLoop curveLoop = CurveLoop.Create(profile);
    SolidOptions options = new SolidOptions(ElementId.InvalidElementId, ElementId.InvalidElementId);

    Frame frame = new Frame(center, XYZ.BasisX, -XYZ.BasisZ, XYZ.BasisY);
    if (Frame.CanDefineRevitGeometry(frame) == true)
    {
        Solid sphere = GeometryCreationUtilities.CreateRevolvedGeometry(frame, new CurveLoop[] { curveLoop }, 0, 2 * Math.PI, options);
        using (Transaction t = new Transaction(doc, "Create sphere direct shape"))
        {
            t.Start();
            // create direct shape and assign the sphere shape
            DirectShape ds = DirectShape.CreateElement(doc, new ElementId(BuiltInCategory.OST_GenericModel));

            ds.ApplicationId = "Application id";
            ds.ApplicationDataId = "Geometry object id";
            ds.SetShape(new GeometryObject[] { sphere });
            t.Commit();
        }
    }
}
CopyVB.NET
' Create a DirectShape Sphere
Public Sub CreateSphereDirectShape(doc As Document)
    Dim profile As New List(Of Curve)()

    ' first create sphere with 2' radius
    Dim center As XYZ = XYZ.Zero
    Dim radius As Double = 2.0
    Dim profile00 As XYZ = center
    Dim profilePlus As XYZ = center + New XYZ(0, radius, 0)
    Dim profileMinus As XYZ = center - New XYZ(0, radius, 0)

    profile.Add(Line.CreateBound(profilePlus, profileMinus))
    profile.Add(Arc.Create(profileMinus, profilePlus, center + New XYZ(radius, 0, 0)))

    Dim curveLoop__1 As CurveLoop = CurveLoop.Create(profile)
    Dim options As New SolidOptions(ElementId.InvalidElementId, ElementId.InvalidElementId)

    Dim frame__2 As New Frame(center, XYZ.BasisX, -XYZ.BasisZ, XYZ.BasisY)
    If Frame.CanDefineRevitGeometry(frame__2) = True Then
        Dim sphere As Solid = GeometryCreationUtilities.CreateRevolvedGeometry(frame__2, New CurveLoop() {curveLoop__1}, 0, 2 * Math.PI, options)
        Using t As New Transaction(doc, "Create sphere direct shape")
            t.Start()
            ' create direct shape and assign the sphere shape
            Dim ds As DirectShape = DirectShape.CreateElement(doc, New ElementId(BuiltInCategory.OST_GenericModel))

            ds.ApplicationId = "Application id"
            ds.ApplicationDataId = "Geometry object id"
            ds.SetShape(New GeometryObject() {sphere})
            t.Commit()
        End Using
    End If
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..DirectShape

See Also

DirectShape Members


DirectShape Members

[image] [image]

Revit 2024 API
DirectShape Members
DirectShape Class Methods Properties See Also Send Feedback

The DirectShape type exposes the following members.

Methods

 | Name | Description
Public method | AddExternallyTaggedGeometry | Adds the externally tagged geometry object to the DirectShape.
Public method | AddReferenceCurve(Curve) | Adds a reference curve to the DirectShape.
Public method | AddReferenceCurve(Curve, DirectShapeReferenceOptions) | Adds a reference curve to the DirectShape.
Public method | AddReferencePlane(Plane) | Adds a reference plane to the DirectShape. The reference plane can either be bounded or unbounded.
Public method | AddReferencePlane(Plane, BoundingBoxUV) | Adds a reference plane to the DirectShape. The reference plane can either be bounded or unbounded.
Public method | AddReferencePlane(Plane, DirectShapeReferenceOptions) | Adds a reference plane to the DirectShape. The reference plane can either be bounded or unbounded.
Public method | AddReferencePlane(Plane, BoundingBoxUV, DirectShapeReferenceOptions) | Adds a reference plane to the DirectShape. The reference plane can either be bounded or unbounded.
Public method | AddReferencePoint(XYZ) | Adds a reference point to the DirectShape.
Public method | AddReferencePoint(XYZ, DirectShapeReferenceOptions) | Adds a reference point to the DirectShape.
Public method | AppendShape(IList<(Of <<'(GeometryObject>)>>)) | Appends the collection of GeometryObjects into the model shape representation stored in this DirectShape.
Public method | AppendShape(ShapeBuilder) | Appends shape built by the supplied ShapeBuilderObject to shape representation stored in this DirectShape. The data stored in the supplied ShapeBuilder object will be cleared.
Public method | AppendShape(IList<(Of <<'(GeometryObject>)>>), DirectShapeTargetViewType) | Appends the collection of GeometryObjects into the model or view specific shape representation stored in this DirectShape. Passing DirectShapeTargetViewType.Default as view type will cause the model shape to be updated.
Public method | AreOptionsValid | Validates that the given DirectShapeOptions are allowed for this particular DirectShape.
Public method | AreOptionsValidForTransientDirectShape | Validates that the given DirectShapeOptions are allowed if this DirectShape is transient.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | AreValidDirectShapeReferenceOptions | Validates that the input DirectShapeReferenceOptions are suitable for creating a direct shape reference object. If the options specify an ExternalGeometryId, it must not correspond to any existing reference object belonging to the DirectShape.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanCreateParts | Indicates if it is possible to create parts from this DirectShape element.
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | CreateElement | Creates a DirectShape object and adds it to document.
 | CreateElementInstance | Creates a DirectShape object and adds it to document.
 | CreateGeometryInstance | Creates a copy of a definition shape that was created earlier.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternallyTaggedGeometry | Gets the externally tagged geometry by its external ID that is stored in this DirectShape.
Public method | GetExternallyTaggedReference | Retrieve a Reference to reference geometry of the DirectShape that is associated with a particular ExternalGeometryId.
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOptions | Gets a copy of the current options for this DirectShape.
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasExternalGeometry | Checks whether the externally tagged geometry is already present in this DirectShape.
Public method | HasExternallyTaggedReference | Checks if the externally tagged reference is already present in this DirectShape.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
 | IsSupportedDocument | Tests whether a DirectShape or a DirectShapeType may be created in this document.
 | IsValidCategoryId | Test the category id to make sure the category is allowed for a DirectShape or DirectShapeType.
Public method | IsValidGeometry | Validates geometry to be stored in a DirectShape. Suitable geometry validation is performed. Additionally, the geometry must make sense as a shape representation for the category assigned to this DirectShape object.
 | IsValidReferenceCurve | Validates that the input curve is suitable for creating a direct shape reference curve. Bounded and unbounded lines are accepted. Other bounded and unbounded curve types with natural bounds are accepted if they are not closed. Unbounded periodic curves are not allowed.
 | IsValidReferencePlaneBoundingBoxUV | Validates that the input BoundingBoxUV is suitable for bounding a reference plane surface. The input BoundingBoxUV must be set and not degenerate.
Public method | IsValidShape(ExternallyTaggedGeometryObject) | Validates shape to be stored in a DirectShape.
Public method | IsValidShape(IList<(Of <<'(GeometryObject>)>>)) | Validates shape to be stored in a DirectShape. Supercedes and extends IsValidGeometry().
Public method | IsValidShape(IList<(Of <<'(GeometryObject>)>>), DirectShapeTargetViewType) | Validates view-specific shape to be stored in a DirectShape. Expects a non-default view type.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | IsValidTypeId | Tests the type id to make sure it satisfies the following conditions It is a valid element id.It corresponds to a valid DirectShapeType.The DirectShapeType has the same category assigned. Additionally, this functions tests that the current type id in this DirectShape is invalid. The type id is initialized to invalidElementId by the create functions. Once it is set, it may no longer be changed.
Public method | IsValidUsage | Validates that the ExternallyTaggedGeometryObject's usage is set to an allowed value for a DirectShape.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | RemoveAllReferenceObjects | Removes all reference objects (if any) from the DirectShape.
Public method | RemoveExternallyTaggedGeometry | Removes the externally tagged geometry object by its external ID from this DirectShape.
Public method | RemoveReferenceObject(String) | Removes any reference objects with the given name from the DirectShape. Nothing is done if no reference objects have the given name or if the name is the empty string.
Public method | RemoveReferenceObject(ExternalGeometryId) | Removes any reference object associated with the provided ExternalGeometryId from the DirectShape. Nothing is done if no reference object has the given external ID or if the external ID is an empty string.
Public method | ResetExternallyTaggedGeometry | Removes all of the externally tagged geometry in this DirectShape.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetName | Sets the name for the DirectShape element.
Public method | SetOptions | Sets the options to use for this DirectShape.
Public method | SetShape(IList<(Of <<'(GeometryObject>)>>)) | Builds the shape of this object from the supplied collection of GeometryObjects. The objects are copied. If the new shape is identical to the old one, the old shape will be kept.
Public method | SetShape(ShapeBuilder) | Sets the shape of this object to the one accumulated in the supplied Builder object. If the new shape is identical to the old one, the old shape will be kept.
Public method | SetShape(IList<(Of <<'(GeometryObject>)>>), DirectShapeTargetViewType) | Builds the shape of this object from the supplied collection of GeometryObjects. The objects are copied. If the new shape is identical to the old one, the old shape will be kept.
Public method | SetTypeId | Sets the DirectShapeType for the DirectShape element.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateExternallyTaggedGeometry | Updates the externally tagged geometry object in the DirectShape.

Properties

 | Name | Description
Public property | ApplicationDataId | A text string that identifies the data to the creating application.
Public property | ApplicationId | A text string that identifies the creating application.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | TypeId | Element id of a DirectShapeType object that holds properties to be shared by this element. Optional.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DirectShape Class


AddExternallyTaggedGeometry Method

[image]

Revit 2024 API
DirectShape..::..AddExternallyTaggedGeometry Method
DirectShape Class See Also Send Feedback
Adds the externally tagged geometry object to the DirectShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public void AddExternallyTaggedGeometry(
    ExternallyTaggedGeometryObject externallyTaggedGeometry
)
Visual Basic
Public Sub AddExternallyTaggedGeometry ( _
    externallyTaggedGeometry As ExternallyTaggedGeometryObject _
)
Visual C++
public:
void AddExternallyTaggedGeometry(
    ExternallyTaggedGeometryObject^ externallyTaggedGeometry
)

Parameters

externallyTaggedGeometry
Type: Autodesk.Revit.DB..::..ExternallyTaggedGeometryObject
The externally tagged geometry that should be added to the DirectShape.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input shape does not satisfy DirectShape validation criteria. -or- The input geometry does not have a permitted usage. -or- The externallyTaggedGeometry has already been added to this DirectShape.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShape Class


AddReferenceCurve Method

[image] [image]

Revit 2024 API
DirectShape..::..AddReferenceCurve Method
DirectShape Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddReferenceCurve(Curve) | Adds a reference curve to the DirectShape.
Public method | AddReferenceCurve(Curve, DirectShapeReferenceOptions) | Adds a reference curve to the DirectShape.

See Also

DirectShape Class
DirectShape Members


AddReferenceCurve Method (Curve)

[image]

Revit 2024 API
DirectShape..::..AddReferenceCurve Method (Curve)
DirectShape Class See Also Send Feedback
Adds a reference curve to the DirectShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public void AddReferenceCurve(
    Curve refCurve
)
Visual Basic
Public Sub AddReferenceCurve ( _
    refCurve As Curve _
)
Visual C++
public:
void AddReferenceCurve(
    Curve^ refCurve
)

Parameters

refCurve
Type: Autodesk.Revit.DB..::..Curve
The geometry of the new reference curve. First case: The input curve's bounds are set. The resulting reference curve that is added to the DirectShape will be displayed with those bounds. Note that the specified bounds must not be degenerate. Second case: The input curve is unbounded. Reasonable bounds are therefore automatically calculated and applied to the input curve. The automatic bounds are based on the host direct shape's geometry. Note that only lines and splines may be unbounded. You must specify valid bounds for all other curve types.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | refCurve cannot be used for creating a reference curve.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShape Class
AddReferenceCurve Overload


AddReferenceCurve Method (Curve, DirectShapeReferenceOptions)

[image]

Revit 2024 API
DirectShape..::..AddReferenceCurve Method (Curve, DirectShapeReferenceOptions)
DirectShape Class See Also Send Feedback
Adds a reference curve to the DirectShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public void AddReferenceCurve(
    Curve refCurve,
    DirectShapeReferenceOptions options
)
Visual Basic
Public Sub AddReferenceCurve ( _
    refCurve As Curve, _
    options As DirectShapeReferenceOptions _
)
Visual C++
public:
void AddReferenceCurve(
    Curve^ refCurve,
    DirectShapeReferenceOptions^ options
)

Parameters

refCurve
Type: Autodesk.Revit.DB..::..Curve
The geometry of the new reference curve. First case: The input curve's bounds are set. The resulting reference curve that is added to the DirectShape will be displayed with those bounds. Note that the specified bounds must not be degenerate. Second case: The input curve is unbounded. Reasonable bounds are therefore automatically calculated and applied to the input curve. The automatic bounds are based on the host direct shape's geometry. Note that only lines and splines may be unbounded. You must specify valid bounds for all other curve types.
options
Type: Autodesk.Revit.DB..::..DirectShapeReferenceOptions
The options that are used to configure the new reference curve.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | refCurve cannot be used for creating a reference curve. -or- options cannot be used to add a reference object to this DirectShape.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShape Class
AddReferenceCurve Overload


AddReferencePlane Method (Plane)

[image]

Revit 2024 API
DirectShape..::..AddReferencePlane Method (Plane)
DirectShape Class See Also Send Feedback
Adds a reference plane to the DirectShape. The reference plane can either be bounded or unbounded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public void AddReferencePlane(
    Plane refPlane
)
Visual Basic
Public Sub AddReferencePlane ( _
    refPlane As Plane _
)
Visual C++
public:
void AddReferencePlane(
    Plane^ refPlane
)

Parameters

refPlane
Type: Autodesk.Revit.DB..::..Plane
The geometry of the new reference plane.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShape Class
AddReferencePlane Overload


AddReferencePlane Method (Plane, BoundingBoxUV)

[image]

Revit 2024 API
DirectShape..::..AddReferencePlane Method (Plane, BoundingBoxUV)
DirectShape Class See Also Send Feedback
Adds a reference plane to the DirectShape. The reference plane can either be bounded or unbounded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public void AddReferencePlane(
    Plane refPlane,
    BoundingBoxUV boundingBoxUV
)
Visual Basic
Public Sub AddReferencePlane ( _
    refPlane As Plane, _
    boundingBoxUV As BoundingBoxUV _
)
Visual C++
public:
void AddReferencePlane(
    Plane^ refPlane,
    BoundingBoxUV^ boundingBoxUV
)

Parameters

refPlane
Type: Autodesk.Revit.DB..::..Plane
The geometry of the new reference plane.
boundingBoxUV
Type: Autodesk.Revit.DB..::..BoundingBoxUV
If boundingBoxUV is set, the resulting reference plane that is added to the DirectShape will be displayed with those bounds. Note that the specified bounds must not be degenerate. If boundingBoxUV is not set, reasonable bounds are automatically calculated and applied to the input plane. The automatic bounds are based on the host direct shape's geometry.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | boundingBoxUV cannot be used as a BoundingBoxUV for the reference plane surface.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShape Class
AddReferencePlane Overload


AddReferencePlane Method (Plane, DirectShapeReferenceOptions)

[image]

Revit 2024 API
DirectShape..::..AddReferencePlane Method (Plane, DirectShapeReferenceOptions)
DirectShape Class See Also Send Feedback
Adds a reference plane to the DirectShape. The reference plane can either be bounded or unbounded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public void AddReferencePlane(
    Plane refPlane,
    DirectShapeReferenceOptions options
)
Visual Basic
Public Sub AddReferencePlane ( _
    refPlane As Plane, _
    options As DirectShapeReferenceOptions _
)
Visual C++
public:
void AddReferencePlane(
    Plane^ refPlane,
    DirectShapeReferenceOptions^ options
)

Parameters

refPlane
Type: Autodesk.Revit.DB..::..Plane
The geometry of the new reference plane.
options
Type: Autodesk.Revit.DB..::..DirectShapeReferenceOptions
The options that are used to configure the new reference plane.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | options cannot be used to add a reference object to this DirectShape.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShape Class
AddReferencePlane Overload


AddReferencePlane Method (Plane, BoundingBoxUV, DirectShapeReferenceOptions)

[image]

Revit 2024 API
DirectShape..::..AddReferencePlane Method (Plane, BoundingBoxUV, DirectShapeReferenceOptions)
DirectShape Class See Also Send Feedback
Adds a reference plane to the DirectShape. The reference plane can either be bounded or unbounded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public void AddReferencePlane(
    Plane refPlane,
    BoundingBoxUV boundingBoxUV,
    DirectShapeReferenceOptions options
)
Visual Basic
Public Sub AddReferencePlane ( _
    refPlane As Plane, _
    boundingBoxUV As BoundingBoxUV, _
    options As DirectShapeReferenceOptions _
)
Visual C++
public:
void AddReferencePlane(
    Plane^ refPlane,
    BoundingBoxUV^ boundingBoxUV,
    DirectShapeReferenceOptions^ options
)

Parameters

refPlane
Type: Autodesk.Revit.DB..::..Plane
The geometry of the new reference plane.
boundingBoxUV
Type: Autodesk.Revit.DB..::..BoundingBoxUV
If boundingBoxUV is set, the resulting reference plane that is added to the DirectShape will be displayed with those bounds. Note that the specified bounds must not be degenerate. If boundingBoxUV is not set, reasonable bounds are automatically calculated and applied to the input plane. The automatic bounds are based on the host direct shape's geometry.
options
Type: Autodesk.Revit.DB..::..DirectShapeReferenceOptions
The options that are used to configure the new reference plane.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | boundingBoxUV cannot be used as a BoundingBoxUV for the reference plane surface. -or- options cannot be used to add a reference object to this DirectShape.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShape Class
AddReferencePlane Overload


AddReferencePoint Method

[image] [image]

Revit 2024 API
DirectShape..::..AddReferencePoint Method
DirectShape Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddReferencePoint(XYZ) | Adds a reference point to the DirectShape.
Public method | AddReferencePoint(XYZ, DirectShapeReferenceOptions) | Adds a reference point to the DirectShape.

See Also

DirectShape Class
DirectShape Members


AddReferencePoint Method (XYZ)

[image]

Revit 2024 API
DirectShape..::..AddReferencePoint Method (XYZ)
DirectShape Class See Also Send Feedback
Adds a reference point to the DirectShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public void AddReferencePoint(
    XYZ refPoint
)
Visual Basic
Public Sub AddReferencePoint ( _
    refPoint As XYZ _
)
Visual C++
public:
void AddReferencePoint(
    XYZ^ refPoint
)

Parameters

refPoint
Type: Autodesk.Revit.DB..::..XYZ
The coordinates of the new reference point.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input point lies outside of Revit design limits.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShape Class
AddReferencePoint Overload


AddReferencePoint Method (XYZ, DirectShapeReferenceOptions)

[image]

Revit 2024 API
DirectShape..::..AddReferencePoint Method (XYZ, DirectShapeReferenceOptions)
DirectShape Class See Also Send Feedback
Adds a reference point to the DirectShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public void AddReferencePoint(
    XYZ refPoint,
    DirectShapeReferenceOptions options
)
Visual Basic
Public Sub AddReferencePoint ( _
    refPoint As XYZ, _
    options As DirectShapeReferenceOptions _
)
Visual C++
public:
void AddReferencePoint(
    XYZ^ refPoint,
    DirectShapeReferenceOptions^ options
)

Parameters

refPoint
Type: Autodesk.Revit.DB..::..XYZ
The coordinates of the new reference point.
options
Type: Autodesk.Revit.DB..::..DirectShapeReferenceOptions
The options that are used to configure the new reference point.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input point lies outside of Revit design limits. -or- options cannot be used to add a reference object to this DirectShape.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShape Class
AddReferencePoint Overload


AppendShape Method

[image] [image]

Revit 2024 API
DirectShape..::..AppendShape Method
DirectShape Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AppendShape(IList<(Of <<'(GeometryObject>)>>)) | Appends the collection of GeometryObjects into the model shape representation stored in this DirectShape.
Public method | AppendShape(ShapeBuilder) | Appends shape built by the supplied ShapeBuilderObject to shape representation stored in this DirectShape. The data stored in the supplied ShapeBuilder object will be cleared.
Public method | AppendShape(IList<(Of <<'(GeometryObject>)>>), DirectShapeTargetViewType) | Appends the collection of GeometryObjects into the model or view specific shape representation stored in this DirectShape. Passing DirectShapeTargetViewType.Default as view type will cause the model shape to be updated.

See Also

DirectShape Class
DirectShape Members


AppendShape Method (IList(GeometryObject))

[image]

Revit 2024 API
DirectShape..::..AppendShape Method (IList<(Of <(<'GeometryObject>)>)>)
DirectShape Class See Also Send Feedback
Appends the collection of GeometryObjects into the model shape representation stored in this DirectShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public void AppendShape(
    IList<GeometryObject> pGeomArr
)
Visual Basic
Public Sub AppendShape ( _
    pGeomArr As IList(Of GeometryObject) _
)
Visual C++
public:
void AppendShape(
    IList<GeometryObject^>^ pGeomArr
)

Parameters

pGeomArr
Type: System.Collections.Generic..::..IList<(Of <(<' GeometryObject >)>)>
Shape expressed as a collection of GeometryObjects. The supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point and Curve.

Remarks

The existing shape will not be cleared by this function, and intersecting or overlapped geometry will not be joined with the appended geometry. It is up to the caller to ensure that the combination of geometry will have the correct appearance in Revit.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | At least one member of pGeomArr does not satisfy DirectShape validation criteria.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShape Class
AppendShape Overload


AppendShape Method (ShapeBuilder)

[image]

Revit 2024 API
DirectShape..::..AppendShape Method (ShapeBuilder)
DirectShape Class See Also Send Feedback
Appends shape built by the supplied ShapeBuilderObject to shape representation stored in this DirectShape. The data stored in the supplied ShapeBuilder object will be cleared.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public void AppendShape(
    ShapeBuilder ShapeBuilder
)
Visual Basic
Public Sub AppendShape ( _
    ShapeBuilder As ShapeBuilder _
)
Visual C++
public:
void AppendShape(
    ShapeBuilder^ ShapeBuilder
)

Parameters

ShapeBuilder
Type: Autodesk.Revit.DB..::..ShapeBuilder
The ShapeBuilder object that was used to build the shape to be appended.

Remarks

The existing shape will not be cleared by this function, and intersecting or overlapped geometry will not be joined with the appended geometry. It is up to the caller to ensure that the combination of geometry will have the correct appearance in Revit. This function will bypass extra geometry validation because the built geometry has already been validated by the ShapeBuilder. It is therefore slightly more efficient than the AppendShape() routine that accepts GeometryObjects directly as input.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShape Class
AppendShape Overload


AreOptionsValidForTransientDirectShape Method

[image]

Revit 2024 API
DirectShape..::..AreOptionsValidForTransientDirectShape Method
DirectShape Class See Also Send Feedback
Validates that the given DirectShapeOptions are allowed if this DirectShape is transient.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool AreOptionsValidForTransientDirectShape(
    DirectShapeOptions options
)
Visual Basic
Public Function AreOptionsValidForTransientDirectShape ( _
    options As DirectShapeOptions _
) As Boolean
Visual C++
public:
bool AreOptionsValidForTransientDirectShape(
    DirectShapeOptions^ options
)

Parameters

options
Type: Autodesk.Revit.DB..::..DirectShapeOptions
The options object.

Return Value

True if the DirectShapeOptions are valid; false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShape Class


CanCreateParts Method

[image]

Revit 2024 API
DirectShape..::..CanCreateParts Method
DirectShape Class See Also Send Feedback
Indicates if it is possible to create parts from this DirectShape element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public bool CanCreateParts()
Visual Basic
Public Function CanCreateParts As Boolean
Visual C++
public:
bool CanCreateParts()

Return Value

True if it is possible to create parts from this DirectShape.

Remarks

While it is generally possible to create parts from DirectShape elements, some characteristics make parts creation impossible. This property is re-evaluated every time the element's geometry is modified (via a call to SetShape or AppendShape). Invalid configurations include: DirectShape elements containing a polymesh, or an open geometry, as well as DirectShape elements not containing any solids and DirectShape elements configured as NotReferenceable (via a call to SetOptions). Finally, if a DirectShape element has DirectShapeType instances in its geometry, and one of those DirectShapeTypes has a configuration that is incompatible with parts creation, the DirectShape element will also be incompatible with parts creation.

See Also

DirectShape Class


CreateElement Method

[image]

Revit 2024 API
DirectShape..::..CreateElement Method
DirectShape Class See Also Send Feedback
Creates a DirectShape object and adds it to document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public static DirectShape CreateElement(
    Document document,
    ElementId categoryId
)
Visual Basic
Public Shared Function CreateElement ( _
    document As Document, _
    categoryId As ElementId _
) As DirectShape
Visual C++
public:
static DirectShape^ CreateElement(
    Document^ document,
    ElementId^ categoryId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Document to which the created element will be added.
categoryId
Type: Autodesk.Revit.DB..::..ElementId
Id of the category assigned to this DirectShape. Must be a valid category id.

Return Value

The created DirectShape object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Document document may not contain DirectShape or DirectShapeType objects. -or- Element id categoryId may not be used as a DirectShape category.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShape Class


CreateElementInstance Method

[image]

Revit 2024 API
DirectShape..::..CreateElementInstance Method
DirectShape Class See Also Send Feedback
Creates a DirectShape object and adds it to document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public static DirectShape CreateElementInstance(
    Document document,
    ElementId typeId,
    ElementId categoryId,
    string definitionId,
    Transform trf
)
Visual Basic
Public Shared Function CreateElementInstance ( _
    document As Document, _
    typeId As ElementId, _
    categoryId As ElementId, _
    definitionId As String, _
    trf As Transform _
) As DirectShape
Visual C++
public:
static DirectShape^ CreateElementInstance(
    Document^ document,
    ElementId^ typeId,
    ElementId^ categoryId,
    String^ definitionId,
    Transform^ trf
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Document to which the created element will be added.
typeId
Type: Autodesk.Revit.DB..::..ElementId
Element id of a DirectShapeType element.
categoryId
Type: Autodesk.Revit.DB..::..ElementId
Id of the category assigned to this DirectShape. Must be a valid category id.
definitionId
Type: System..::..String
Id of the shape definition that was created earlier and stored via DirectShapeLibrary.
trf
Type: Autodesk.Revit.DB..::..Transform
Transform to be applied to the definition.

Return Value

The created DirectShape object.

Remarks

This function is included for convenience. It essentially combines CreateGeometryInstance and CreateElement. The shape stored in the element is either a reference or a copy of a definition shape that was created earlier. How the definitions are stored will determine whether an instance or a copy of the shape will be created. The intended use is to support a definition/instance pattern common in CAD formats - DWG blocks, STEP MAPPED_ITEM, IFC IfcMappedItem. Use DirectShapeLibrary class to store definitions prior to using them here.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Document document may not contain DirectShape or DirectShapeType objects. -or- Element id categoryId may not be used as a DirectShape category.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShape Class


CreateGeometryInstance Method

[image]

Revit 2024 API
DirectShape..::..CreateGeometryInstance Method
DirectShape Class See Also Send Feedback
Creates a copy of a definition shape that was created earlier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static IList<GeometryObject> CreateGeometryInstance(
    Document document,
    string definition_id,
    Transform trf
)
Visual Basic
Public Shared Function CreateGeometryInstance ( _
    document As Document, _
    definition_id As String, _
    trf As Transform _
) As IList(Of GeometryObject)
Visual C++
public:
static IList<GeometryObject^>^ CreateGeometryInstance(
    Document^ document,
    String^ definition_id,
    Transform^ trf
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Document to which the created element will be added
definition_id
Type: System..::..String
ID of the shape definition that was created earlier and stored via DirectShapeLibrary
trf
Type: Autodesk.Revit.DB..::..Transform
Transform to be applied to the definition

Return Value

A collection of GeometryObjects representing a placed instance of the pre-defined shape The caller function takes ownership

Remarks

Use DirectShapeLibrary class to store definitions prior to using them here. How the definitions are stored will determine whether an instance or a copy of the shape will be created. Use the output of this function as input to CreateElement to make the created shape persistent. This is intended to support a definition/instance pattern common in CAD formats - DWG blocks, STEP MAPPED_ITEM, IFC IfcMappedItem.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShape Class


GetExternallyTaggedGeometry Method

[image]

Revit 2024 API
DirectShape..::..GetExternallyTaggedGeometry Method
DirectShape Class See Also Send Feedback
Gets the externally tagged geometry by its external ID that is stored in this DirectShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public ExternallyTaggedGeometryObject GetExternallyTaggedGeometry(
    ExternalGeometryId externalId
)
Visual Basic
Public Function GetExternallyTaggedGeometry ( _
    externalId As ExternalGeometryId _
) As ExternallyTaggedGeometryObject
Visual C++
public:
ExternallyTaggedGeometryObject^ GetExternallyTaggedGeometry(
    ExternalGeometryId^ externalId
)

Parameters

externalId
Type: Autodesk.Revit.DB..::..ExternalGeometryId
The external ID of the externally tagged geometry that should be obtained.

Return Value

The externally tagged geometry. Or nullNothingnullptra null reference (Nothing in Visual Basic) if there is no such an externally tagged geometry in the DirectShape.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShape Class


GetExternallyTaggedReference Method

[image]

Revit 2024 API
DirectShape..::..GetExternallyTaggedReference Method
DirectShape Class See Also Send Feedback
Retrieve a Reference to reference geometry of the DirectShape that is associated with a particular ExternalGeometryId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public Reference GetExternallyTaggedReference(
    ExternalGeometryId externalId
)
Visual Basic
Public Function GetExternallyTaggedReference ( _
    externalId As ExternalGeometryId _
) As Reference
Visual C++
public:
Reference^ GetExternallyTaggedReference(
    ExternalGeometryId^ externalId
)

Parameters

externalId
Type: Autodesk.Revit.DB..::..ExternalGeometryId
The ExternalGeometryId of the requested reference object.

Return Value

A Reference to the externally tagged reference GeometryObject having the provided external ID or nullNothingnullptra null reference (Nothing in Visual Basic) if there is no reference geometry having the external ID.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShape Class


GetOptions Method

[image]

Revit 2024 API
DirectShape..::..GetOptions Method
DirectShape Class See Also Send Feedback
Gets a copy of the current options for this DirectShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public DirectShapeOptions GetOptions()
Visual Basic
Public Function GetOptions As DirectShapeOptions
Visual C++
public:
DirectShapeOptions^ GetOptions()

Return Value

Options currently set for this DirectShape.

See Also

DirectShape Class


HasExternallyTaggedReference Method

[image]

Revit 2024 API
DirectShape..::..HasExternallyTaggedReference Method
DirectShape Class See Also Send Feedback
Checks if the externally tagged reference is already present in this DirectShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public bool HasExternallyTaggedReference(
    ExternalGeometryId externalId
)
Visual Basic
Public Function HasExternallyTaggedReference ( _
    externalId As ExternalGeometryId _
) As Boolean
Visual C++
public:
bool HasExternallyTaggedReference(
    ExternalGeometryId^ externalId
)

Parameters

externalId
Type: Autodesk.Revit.DB..::..ExternalGeometryId
The external ID of the tagged reference to check for.

Return Value

True if the DirectShape holds a reference with the specified ExternalGeometryId.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShape Class


IsSupportedDocument Method

[image]

Revit 2024 API
DirectShape..::..IsSupportedDocument Method
DirectShape Class See Also Send Feedback
Tests whether a DirectShape or a DirectShapeType may be created in this document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public static bool IsSupportedDocument(
    Document document
)
Visual Basic
Public Shared Function IsSupportedDocument ( _
    document As Document _
) As Boolean
Visual C++
public:
static bool IsSupportedDocument(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Document to be tested.

Return Value

True if a DirectShape or a DirectShapeType object can be created in this document, false otherwise.

Remarks

Some types of Document, such as 2D families, can't support DirectShape functionality.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShape Class


IsValidCategoryId Method

[image]

Revit 2024 API
DirectShape..::..IsValidCategoryId Method
DirectShape Class See Also Send Feedback
Test the category id to make sure the category is allowed for a DirectShape or DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static bool IsValidCategoryId(
    ElementId categoryId,
    Document doc
)
Visual Basic
Public Shared Function IsValidCategoryId ( _
    categoryId As ElementId, _
    doc As Document _
) As Boolean
Visual C++
public:
static bool IsValidCategoryId(
    ElementId^ categoryId,
    Document^ doc
)

Parameters

categoryId
Type: Autodesk.Revit.DB..::..ElementId
Category id to be tested.
doc
Type: Autodesk.Revit.DB..::..Document
Document to look up the category by id.

Return Value

True if the category is allowed for a DirectShape or DirectShapeType, false if not.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShape Class


IsValidGeometry Method

[image]

Revit 2024 API
DirectShape..::..IsValidGeometry Method
DirectShape Class See Also Send Feedback
Validates geometry to be stored in a DirectShape. Suitable geometry validation is performed. Additionally, the geometry must make sense as a shape representation for the category assigned to this DirectShape object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool IsValidGeometry(
    Solid Geom
)
Visual Basic
Public Function IsValidGeometry ( _
    Geom As Solid _
) As Boolean
Visual C++
public:
bool IsValidGeometry(
    Solid^ Geom
)

Parameters

Geom
Type: Autodesk.Revit.DB..::..Solid
GeometryObject to be validated.

Return Value

True if the supplied GeometryObject passes the validation criteria.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShape Class


IsValidReferenceCurve Method

[image]

Revit 2024 API
DirectShape..::..IsValidReferenceCurve Method
DirectShape Class See Also Send Feedback
Validates that the input curve is suitable for creating a direct shape reference curve. Bounded and unbounded lines are accepted. Other bounded and unbounded curve types with natural bounds are accepted if they are not closed. Unbounded periodic curves are not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public static bool IsValidReferenceCurve(
    Curve curve
)
Visual Basic
Public Shared Function IsValidReferenceCurve ( _
    curve As Curve _
) As Boolean
Visual C++
public:
static bool IsValidReferenceCurve(
    Curve^ curve
)

Parameters

curve
Type: Autodesk.Revit.DB..::..Curve
The curve to test.

Return Value

True if the input curve point can be used to create a direct shape reference curve, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShape Class


IsValidShape Method (ExternallyTaggedGeometryObject)

[image]

Revit 2024 API
DirectShape..::..IsValidShape Method (ExternallyTaggedGeometryObject)
DirectShape Class See Also Send Feedback
Validates shape to be stored in a DirectShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public bool IsValidShape(
    ExternallyTaggedGeometryObject externallyTaggedGeometry
)
Visual Basic
Public Function IsValidShape ( _
    externallyTaggedGeometry As ExternallyTaggedGeometryObject _
) As Boolean
Visual C++
public:
bool IsValidShape(
    ExternallyTaggedGeometryObject^ externallyTaggedGeometry
)

Parameters

externallyTaggedGeometry
Type: Autodesk.Revit.DB..::..ExternallyTaggedGeometryObject
The supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point and Curve.

Return Value

True if the supplied shape passes the validation criteria.

Remarks

This function uses the same criteria as IsValidShape(GeometryObject).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShape Class
IsValidShape Overload


IsValidShape Method (IList(GeometryObject))

[image]

Revit 2024 API
DirectShape..::..IsValidShape Method (IList<(Of <(<'GeometryObject>)>)>)
DirectShape Class See Also Send Feedback
Validates shape to be stored in a DirectShape. Supercedes and extends IsValidGeometry().

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public bool IsValidShape(
    IList<GeometryObject> shape
)
Visual Basic
Public Function IsValidShape ( _
    shape As IList(Of GeometryObject) _
) As Boolean
Visual C++
public:
bool IsValidShape(
    IList<GeometryObject^>^ shape
)

Parameters

shape
Type: System.Collections.Generic..::..IList<(Of <(<' GeometryObject >)>)>
Shape to be validated represented as a collection of GeometryObjects. The supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point and Curve.

Return Value

True if the supplied shape passes the validation criteria.

Remarks

This function calls IsValidShape(GeometryObject) to validate each object in the list.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShape Class
IsValidShape Overload


IsValidTypeId Method

[image]

Revit 2024 API
DirectShape..::..IsValidTypeId Method
DirectShape Class See Also Send Feedback
Tests the type id to make sure it satisfies the following conditions It is a valid element id.It corresponds to a valid DirectShapeType.The DirectShapeType has the same category assigned. Additionally, this functions tests that the current type id in this DirectShape is invalid. The type id is initialized to invalidElementId by the create functions. Once it is set, it may no longer be changed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool IsValidTypeId(
    ElementId typeId
)
Visual Basic
Public Function IsValidTypeId ( _
    typeId As ElementId _
) As Boolean
Visual C++
public:
bool IsValidTypeId(
    ElementId^ typeId
)

Parameters

typeId
Type: Autodesk.Revit.DB..::..ElementId
Type id to be tested.

Return Value

False unless typeId satisfies the conditions listed above and the type id of this object was not set previously.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShape Class


IsValidUsage Method

[image]

Revit 2024 API
DirectShape..::..IsValidUsage Method
DirectShape Class See Also Send Feedback
Validates that the ExternallyTaggedGeometryObject's usage is set to an allowed value for a DirectShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public bool IsValidUsage(
    ExternallyTaggedGeometryObject externallyTaggedGeometry
)
Visual Basic
Public Function IsValidUsage ( _
    externallyTaggedGeometry As ExternallyTaggedGeometryObject _
) As Boolean
Visual C++
public:
bool IsValidUsage(
    ExternallyTaggedGeometryObject^ externallyTaggedGeometry
)

Parameters

externallyTaggedGeometry
Type: Autodesk.Revit.DB..::..ExternallyTaggedGeometryObject
The geometry to check.

Return Value

True if the usage is permitted.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShape Class


RemoveAllReferenceObjects Method

[image]

Revit 2024 API
DirectShape..::..RemoveAllReferenceObjects Method
DirectShape Class See Also Send Feedback
Removes all reference objects (if any) from the DirectShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public void RemoveAllReferenceObjects()
Visual Basic
Public Sub RemoveAllReferenceObjects
Visual C++
public:
void RemoveAllReferenceObjects()

See Also

DirectShape Class


RemoveReferenceObject Method (ExternalGeometryId)

[image]

Revit 2024 API
DirectShape..::..RemoveReferenceObject Method (ExternalGeometryId)
DirectShape Class See Also Send Feedback
Removes any reference object associated with the provided ExternalGeometryId from the DirectShape. Nothing is done if no reference object has the given external ID or if the external ID is an empty string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public void RemoveReferenceObject(
    ExternalGeometryId externalId
)
Visual Basic
Public Sub RemoveReferenceObject ( _
    externalId As ExternalGeometryId _
)
Visual C++
public:
void RemoveReferenceObject(
    ExternalGeometryId^ externalId
)

Parameters

externalId
Type: Autodesk.Revit.DB..::..ExternalGeometryId
The ExternalGeometryId of the reference object to be removed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShape Class
RemoveReferenceObject Overload


ResetExternallyTaggedGeometry Method

[image]

Revit 2024 API
DirectShape..::..ResetExternallyTaggedGeometry Method
DirectShape Class See Also Send Feedback
Removes all of the externally tagged geometry in this DirectShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public void ResetExternallyTaggedGeometry()
Visual Basic
Public Sub ResetExternallyTaggedGeometry
Visual C++
public:
void ResetExternallyTaggedGeometry()

See Also

DirectShape Class


SetName Method

[image]

Revit 2024 API
DirectShape..::..SetName Method
DirectShape Class See Also Send Feedback
Sets the name for the DirectShape element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public void SetName(
    string name
)
Visual Basic
Public Sub SetName ( _
    name As String _
)
Visual C++
public:
void SetName(
    String^ name
)

Parameters

name
Type: System..::..String
The name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShape Class


SetOptions Method

[image]

Revit 2024 API
DirectShape..::..SetOptions Method
DirectShape Class See Also Send Feedback
Sets the options to use for this DirectShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public void SetOptions(
    DirectShapeOptions options
)
Visual Basic
Public Sub SetOptions ( _
    options As DirectShapeOptions _
)
Visual C++
public:
void SetOptions(
    DirectShapeOptions^ options
)

Parameters

options
Type: Autodesk.Revit.DB..::..DirectShapeOptions
Options to use for this DirectShape.

Remarks

The new options take effect immediately. If this DirectShape relies on a DirectShapeType for references, the options stored in DirectShapeType take precedence. Note that changing options affects how the object interacts with Revit. E.g., switching references off will disable existing constraints applied to that object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The DirectShapeOptions provided are not valid for this DirectShape. -or- The DirectShapeOptions provided are not valid for this transient DirectShape.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShape Class


SetShape Method (IList(GeometryObject))

[image]

Revit 2024 API
DirectShape..::..SetShape Method (IList<(Of <(<'GeometryObject>)>)>)
DirectShape Class See Also Send Feedback
Builds the shape of this object from the supplied collection of GeometryObjects. The objects are copied. If the new shape is identical to the old one, the old shape will be kept.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public void SetShape(
    IList<GeometryObject> pGeomArr
)
Visual Basic
Public Sub SetShape ( _
    pGeomArr As IList(Of GeometryObject) _
)
Visual C++
public:
void SetShape(
    IList<GeometryObject^>^ pGeomArr
)

Parameters

pGeomArr
Type: System.Collections.Generic..::..IList<(Of <(<' GeometryObject >)>)>
Shape of this object expressed as a collection of GeometryObjects. The supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point and Curve.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | At least one member of pGeomArr does not satisfy DirectShape validation criteria.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShape Class
SetShape Overload


SetShape Method (ShapeBuilder)

[image]

Revit 2024 API
DirectShape..::..SetShape Method (ShapeBuilder)
DirectShape Class See Also Send Feedback
Sets the shape of this object to the one accumulated in the supplied Builder object. If the new shape is identical to the old one, the old shape will be kept.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public void SetShape(
    ShapeBuilder pBuilder
)
Visual Basic
Public Sub SetShape ( _
    pBuilder As ShapeBuilder _
)
Visual C++
public:
void SetShape(
    ShapeBuilder^ pBuilder
)

Parameters

pBuilder
Type: Autodesk.Revit.DB..::..ShapeBuilder
A ShapeBuilder object that was used to successfully build geometry to store in this DirectShape. The built shape will be transferred to the DirectShape, and the ShapeBuilder object will be reset.

Remarks

This function will bypass extra geometry validation because the built geometry has already been validated by the ShapeBuilder. It is therefore slightly more efficient than the SetShape() routine that accepts GeometryObjects directly as input. Supplying a ViewShapeBuilder object as argument will cause the view-specific shape of this DirectShape to be updated. Supplying other ShapeBuilder types will update the model shape.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShape Class
SetShape Overload


SetTypeId Method

[image]

Revit 2024 API
DirectShape..::..SetTypeId Method
DirectShape Class See Also Send Feedback
Sets the DirectShapeType for the DirectShape element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public void SetTypeId(
    ElementId typeId
)
Visual Basic
Public Sub SetTypeId ( _
    typeId As ElementId _
)
Visual C++
public:
void SetTypeId(
    ElementId^ typeId
)

Parameters

typeId
Type: Autodesk.Revit.DB..::..ElementId
The ID of the type corresponding to this DirectShape element. May only be set once.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | typeId is not a valid Element identifier.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShape Class


UpdateExternallyTaggedGeometry Method

[image]

Revit 2024 API
DirectShape..::..UpdateExternallyTaggedGeometry Method
DirectShape Class See Also Send Feedback
Updates the externally tagged geometry object in the DirectShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public void UpdateExternallyTaggedGeometry(
    ExternallyTaggedGeometryObject externallyTaggedGeometry
)
Visual Basic
Public Sub UpdateExternallyTaggedGeometry ( _
    externallyTaggedGeometry As ExternallyTaggedGeometryObject _
)
Visual C++
public:
void UpdateExternallyTaggedGeometry(
    ExternallyTaggedGeometryObject^ externallyTaggedGeometry
)

Parameters

externallyTaggedGeometry
Type: Autodesk.Revit.DB..::..ExternallyTaggedGeometryObject
The externally tagged geometry that should be updated in the DirectShape.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input shape does not satisfy DirectShape validation criteria. -or- A previous version of the externally tagged geometry is not present in this DirectShape.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShape Class


DirectShape Properties

[image] [image]

Revit 2024 API
DirectShape Properties
DirectShape Class See Also Send Feedback

The DirectShape type exposes the following members.

Properties

 | Name | Description
Public property | ApplicationDataId | A text string that identifies the data to the creating application.
Public property | ApplicationId | A text string that identifies the creating application.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | TypeId | Element id of a DirectShapeType object that holds properties to be shared by this element. Optional.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DirectShape Class


Parameter Property

[image] [image]

Revit 2024 API
DirectShape..::..Parameter Property
DirectShape Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

DirectShape Class
DirectShape Members


TypeId Property

[image]

Revit 2024 API
DirectShape..::..TypeId Property
DirectShape Class See Also Send Feedback
Element id of a DirectShapeType object that holds properties to be shared by this element. Optional.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public ElementId TypeId { get; }
Visual Basic
Public ReadOnly Property TypeId As ElementId
    Get
Visual C++
public:
property ElementId^ TypeId {
    ElementId^ get ();
}

See Also

DirectShape Class


DirectShapeLibrary Class

[image]

Revit 2024 API
DirectShapeLibrary Class
Members See Also Send Feedback
DirectShapeLibrary is used to store pre-created geometry for further referencing via the definition/instance mechanism. It is not persistent: the scope of a library object is usually a single data creation session. DirectShape::createGeometryInstance and DirectShape::CreateElementInstance will use the current DirectShapeLibrary to look up the definitions. store a collection of GNodes as definition end class DirectShapeDefinition

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public class DirectShapeLibrary : IDisposable
Visual Basic
Public Class DirectShapeLibrary _
    Implements IDisposable
Visual C++
public ref class DirectShapeLibrary : IDisposable

Remarks

There are two ways to add a definition to the library. The first is to add the definition as an array of geometry objects. A DirectShape created as an instance of that definition will hold a copy of predefined geometry, transformed as requested. If the definition was added as a DirectShapeType, a DirectShape object created as an instance of that definition will reference the type. Its geometry would be an instance of type geometry.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..DirectShapeLibrary

See Also

DirectShapeLibrary Members


DirectShapeLibrary Members

[image] [image]

Revit 2024 API
DirectShapeLibrary Members
DirectShapeLibrary Class Methods Properties See Also Send Feedback

The DirectShapeLibrary type exposes the following members.

Methods

 | Name | Description
Public method | AddDefinition(String, GeometryObject) | Add a definition to be reused by instances. A definition is a single geometry object.
Public method | AddDefinition(String, IList<(Of <<'(GeometryObject>)>>)) | Add a definition to be reused by instances. A definition is a collection of geometry objects.
Public method | AddDefinitionType | Add a definition to be reused by instances. Adding a definition type will change how the instances are created. When asked to create a definition, the library object will look for a corresponding type object. If one is found, it will create an instance of geometry stored in the type object. If it is not found, the library will look for a list of geometry objects stored as definition, and will copy and transform these to create an instance.
Public method | Contains | A quick check whether a definition already exists in the library. Checks for stored geometry objects only.
Public method | ContainsType | A quick check whether a definition type already exists in the library. Checks for type objects only.
Public method | Dispose | Releases all resources used by the DirectShapeLibrary
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindDefinition | Find a definition by id
Public method | FindDefinitionType | Find a DirectShapeType element by definition id. The element will be used for creating instances of that definition.
 | GetDirectShapeLibrary | Get the currently active Library object
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Reset | Removes all definitions from library. This is useful when importing several self-contained data sets within one session. Once a data set is imported, keeping the definitions specific to that data set will slow down the searches.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

DirectShapeLibrary Class


AddDefinition Method

[image] [image]

Revit 2024 API
DirectShapeLibrary..::..AddDefinition Method
DirectShapeLibrary Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddDefinition(String, GeometryObject) | Add a definition to be reused by instances. A definition is a single geometry object.
Public method | AddDefinition(String, IList<(Of <<'(GeometryObject>)>>)) | Add a definition to be reused by instances. A definition is a collection of geometry objects.

See Also

DirectShapeLibrary Class
DirectShapeLibrary Members


AddDefinition Method (String, GeometryObject)

[image]

Revit 2024 API
DirectShapeLibrary..::..AddDefinition Method (String, GeometryObject)
DirectShapeLibrary Class See Also Send Feedback
Add a definition to be reused by instances. A definition is a single geometry object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public void AddDefinition(
    string id,
    GeometryObject GNode
)
Visual Basic
Public Sub AddDefinition ( _
    id As String, _
    GNode As GeometryObject _
)
Visual C++
public:
void AddDefinition(
    String^ id,
    GeometryObject^ GNode
)

Parameters

id
Type: System..::..String
ID of the definition to be added. Must be unique.
GNode
Type: Autodesk.Revit.DB..::..GeometryObject
Definition as a single Geometry object

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShapeLibrary Class
AddDefinition Overload


AddDefinition Method (String, IList(GeometryObject))

[image]

Revit 2024 API
DirectShapeLibrary..::..AddDefinition Method (String, IList<(Of <(<'GeometryObject>)>)>)
DirectShapeLibrary Class See Also Send Feedback
Add a definition to be reused by instances. A definition is a collection of geometry objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public void AddDefinition(
    string id,
    IList<GeometryObject> GNodes
)
Visual Basic
Public Sub AddDefinition ( _
    id As String, _
    GNodes As IList(Of GeometryObject) _
)
Visual C++
public:
void AddDefinition(
    String^ id,
    IList<GeometryObject^>^ GNodes
)

Parameters

id
Type: System..::..String
ID of the definition to be added. Must be unique.
GNodes
Type: System.Collections.Generic..::..IList<(Of <(<' GeometryObject >)>)>
Definition as a list of Geometry objects

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShapeLibrary Class
AddDefinition Overload


AddDefinitionType Method

[image]

Revit 2024 API
DirectShapeLibrary..::..AddDefinitionType Method
DirectShapeLibrary Class See Also Send Feedback
Add a definition to be reused by instances. Adding a definition type will change how the instances are created. When asked to create a definition, the library object will look for a corresponding type object. If one is found, it will create an instance of geometry stored in the type object. If it is not found, the library will look for a list of geometry objects stored as definition, and will copy and transform these to create an instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public void AddDefinitionType(
    string id,
    ElementId typeId
)
Visual Basic
Public Sub AddDefinitionType ( _
    id As String, _
    typeId As ElementId _
)
Visual C++
public:
void AddDefinitionType(
    String^ id,
    ElementId^ typeId
)

Parameters

id
Type: System..::..String
ID of the definition to be added. Must be unique.
typeId
Type: Autodesk.Revit.DB..::..ElementId
Element id of the DirectShapeType element that will be used as a definition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShapeLibrary Class


FindDefinition Method

[image]

Revit 2024 API
DirectShapeLibrary..::..FindDefinition Method
DirectShapeLibrary Class See Also Send Feedback
Find a definition by id

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public IList<GeometryObject> FindDefinition(
    string id
)
Visual Basic
Public Function FindDefinition ( _
    id As String _
) As IList(Of GeometryObject)
Visual C++
public:
IList<GeometryObject^>^ FindDefinition(
    String^ id
)

Parameters

id
Type: System..::..String
Definition id. Expecected to be unique

Return Value

List of geometry objects that together define a shape

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShapeLibrary Class


FindDefinitionType Method

[image]

Revit 2024 API
DirectShapeLibrary..::..FindDefinitionType Method
DirectShapeLibrary Class See Also Send Feedback
Find a DirectShapeType element by definition id. The element will be used for creating instances of that definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public ElementId FindDefinitionType(
    string id
)
Visual Basic
Public Function FindDefinitionType ( _
    id As String _
) As ElementId
Visual C++
public:
ElementId^ FindDefinitionType(
    String^ id
)

Parameters

id
Type: System..::..String
Definition id. Expected to be unique.

Return Value

Element id of a DirectShapeTypeElement

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShapeLibrary Class


GetDirectShapeLibrary Method

[image]

Revit 2024 API
DirectShapeLibrary..::..GetDirectShapeLibrary Method
DirectShapeLibrary Class See Also Send Feedback
Get the currently active Library object

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static DirectShapeLibrary GetDirectShapeLibrary(
    Document ADoc
)
Visual Basic
Public Shared Function GetDirectShapeLibrary ( _
    ADoc As Document _
) As DirectShapeLibrary
Visual C++
public:
static DirectShapeLibrary^ GetDirectShapeLibrary(
    Document^ ADoc
)

Parameters

ADoc
Type: Autodesk.Revit.DB..::..Document

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShapeLibrary Class


Reset Method

[image]

Revit 2024 API
DirectShapeLibrary..::..Reset Method
DirectShapeLibrary Class See Also Send Feedback
Removes all definitions from library. This is useful when importing several self-contained data sets within one session. Once a data set is imported, keeping the definitions specific to that data set will slow down the searches.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset
Visual C++
public:
void Reset()

See Also

DirectShapeLibrary Class


DirectShapeLibrary Properties

[image] [image]

Revit 2024 API
DirectShapeLibrary Properties
DirectShapeLibrary Class See Also Send Feedback

The DirectShapeLibrary type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

DirectShapeLibrary Class


IsValidObject Property

[image]

Revit 2024 API
DirectShapeLibrary..::..IsValidObject Property
DirectShapeLibrary Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

DirectShapeLibrary Class


DirectShapeOptions Class

[image]

Revit 2024 API
DirectShapeOptions Class
Members See Also Send Feedback
This class is used to control behavior of a DirectShape object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public class DirectShapeOptions : IDisposable
Visual Basic
Public Class DirectShapeOptions _
    Implements IDisposable
Visual C++
public ref class DirectShapeOptions : IDisposable

Remarks

Use Enable/Disable functions to change the default behavior. Use DirectShape.SetOptions to modify that object's behavior.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..DirectShapeOptions

See Also

DirectShapeOptions Members


DirectShapeOptions Methods

[image] [image]

Revit 2024 API
DirectShapeOptions Methods
DirectShapeOptions Class See Also Send Feedback

The DirectShapeOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DirectShapeOptions Class


Dispose Method

[image]

Revit 2024 API
DirectShapeOptions..::..Dispose Method
DirectShapeOptions Class See Also Send Feedback
Releases all resources used by the DirectShapeOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

DirectShapeOptions Class


DirectShapeOptions Properties

[image] [image]

Revit 2024 API
DirectShapeOptions Properties
DirectShapeOptions Class See Also Send Feedback

The DirectShapeOptions type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ReferencingOption | Whether or not the geometry stored in a DirectShape object may be referenced.
Public property | RoomBoundingOption | Identifies whether the DirectShape supports an option for the "Room Bounding" parameter to permit participation in room boundary calculations.

See Also

DirectShapeOptions Class


ReferencingOption Property

[image]

Revit 2024 API
DirectShapeOptions..::..ReferencingOption Property
DirectShapeOptions Class See Also Send Feedback
Whether or not the geometry stored in a DirectShape object may be referenced.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public DirectShapeReferencingOption ReferencingOption { get; set; }
Visual Basic
Public Property ReferencingOption As DirectShapeReferencingOption
    Get
    Set
Visual C++
public:
property DirectShapeReferencingOption ReferencingOption {
    DirectShapeReferencingOption get ();
    void set (DirectShapeReferencingOption value);
}

Field Value

The default value is Referenceable.

Remarks

If the geometry is not referenceable, it may not be used for dimensioning, snapping, alignment, or face-hosting. The element may still be selected by the user for operations which do not reference individual geometry objects.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

DirectShapeOptions Class


RoomBoundingOption Property

[image]

Revit 2024 API
DirectShapeOptions..::..RoomBoundingOption Property
DirectShapeOptions Class See Also Send Feedback
Identifies whether the DirectShape supports an option for the "Room Bounding" parameter to permit participation in room boundary calculations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public DirectShapeRoomBoundingOption RoomBoundingOption { get; }
Visual Basic
Public ReadOnly Property RoomBoundingOption As DirectShapeRoomBoundingOption
    Get
Visual C++
public:
property DirectShapeRoomBoundingOption RoomBoundingOption {
    DirectShapeRoomBoundingOption get ();
}

See Also

DirectShapeOptions Class


DirectShapeReferenceOptions Class

[image]

Revit 2024 API
DirectShapeReferenceOptions Class
Members See Also Send Feedback
This class is used to control the behavior of DirectShape and DirectShapeType reference objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public class DirectShapeReferenceOptions : IDisposable
Visual Basic
Public Class DirectShapeReferenceOptions _
    Implements IDisposable
Visual C++
public ref class DirectShapeReferenceOptions : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..DirectShapeReferenceOptions

See Also

DirectShapeReferenceOptions Members


DirectShapeReferenceOptions Members

[image] [image]

Revit 2024 API
DirectShapeReferenceOptions Members
DirectShapeReferenceOptions Class Constructors Methods Properties See Also Send Feedback

The DirectShapeReferenceOptions type exposes the following members.

Constructors

 | Name | Description
Public method | DirectShapeReferenceOptions()()()() | Constructs a new DirectShapeRefOptions instance with default settings.
Public method | DirectShapeReferenceOptions(DirectShapeReferenceOptions) | Constructs a new copy of the input DirectShapeRefOptions object.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the DirectShapeReferenceOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetExternalGeometryId | Retrieves the ExternalGeometryId associated with the reference object.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValidExternalGeometryId | Validates that the input ExternalGeometryId can be assigned to a direct shape reference.
 | IsValidReferenceName | Validates that the input name can be assigned to a direct shape reference.
Public method | SetExternalGeometryId | Sets the ExternalGeometryId associated with the reference object. The ID must be non-empty.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | The name associated with the reference object. The name does not need to be unique. The name must not be empty and must contain valid characters.

See Also

DirectShapeReferenceOptions Class


DirectShapeReferenceOptions Constructor

[image]

Revit 2024 API
DirectShapeReferenceOptions Constructor
DirectShapeReferenceOptions Class See Also Send Feedback
Constructs a new DirectShapeRefOptions instance with default settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public DirectShapeReferenceOptions()
Visual Basic
Public Sub New
Visual C++
public:
DirectShapeReferenceOptions()

See Also

DirectShapeReferenceOptions Class
DirectShapeReferenceOptions Overload


DirectShapeReferenceOptions Constructor (DirectShapeReferenceOptions)

[image]

Revit 2024 API
DirectShapeReferenceOptions Constructor (DirectShapeReferenceOptions)
DirectShapeReferenceOptions Class See Also Send Feedback
Constructs a new copy of the input DirectShapeRefOptions object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public DirectShapeReferenceOptions(
    DirectShapeReferenceOptions other
)
Visual Basic
Public Sub New ( _
    other As DirectShapeReferenceOptions _
)
Visual C++
public:
DirectShapeReferenceOptions(
    DirectShapeReferenceOptions^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..DirectShapeReferenceOptions

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShapeReferenceOptions Class
DirectShapeReferenceOptions Overload


GetExternalGeometryId Method

[image]

Revit 2024 API
DirectShapeReferenceOptions..::..GetExternalGeometryId Method
DirectShapeReferenceOptions Class See Also Send Feedback
Retrieves the ExternalGeometryId associated with the reference object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public ExternalGeometryId GetExternalGeometryId()
Visual Basic
Public Function GetExternalGeometryId As ExternalGeometryId
Visual C++
public:
ExternalGeometryId^ GetExternalGeometryId()

Remarks

If an ExternalGeometryId has not been set, this method returns nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

DirectShapeReferenceOptions Class


IsValidExternalGeometryId Method

[image]

Revit 2024 API
DirectShapeReferenceOptions..::..IsValidExternalGeometryId Method
DirectShapeReferenceOptions Class See Also Send Feedback
Validates that the input ExternalGeometryId can be assigned to a direct shape reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static bool IsValidExternalGeometryId(
    ExternalGeometryId externalId
)
Visual Basic
Public Shared Function IsValidExternalGeometryId ( _
    externalId As ExternalGeometryId _
) As Boolean
Visual C++
public:
static bool IsValidExternalGeometryId(
    ExternalGeometryId^ externalId
)

Parameters

externalId
Type: Autodesk.Revit.DB..::..ExternalGeometryId
The ExternalGeometryId to assign to the reference.

Return Value

True if the provided ExternalGeometryId is valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShapeReferenceOptions Class


IsValidReferenceName Method

[image]

Revit 2024 API
DirectShapeReferenceOptions..::..IsValidReferenceName Method
DirectShapeReferenceOptions Class See Also Send Feedback
Validates that the input name can be assigned to a direct shape reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public static bool IsValidReferenceName(
    string name
)
Visual Basic
Public Shared Function IsValidReferenceName ( _
    name As String _
) As Boolean
Visual C++
public:
static bool IsValidReferenceName(
    String^ name
)

Parameters

name
Type: System..::..String
The name to assign to the reference.

Return Value

True if the input name is valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShapeReferenceOptions Class


IsValidObject Property

[image]

Revit 2024 API
DirectShapeReferenceOptions..::..IsValidObject Property
DirectShapeReferenceOptions Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

DirectShapeReferenceOptions Class


DirectShapeReferencingOption Enumeration

[image]

Revit 2024 API
DirectShapeReferencingOption Enumeration
See Also Send Feedback
An enumerated type containing possible referencing options for DirectShapes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016
Since: 2016

Syntax

C#
public enum DirectShapeReferencingOption
Visual Basic
Public Enumeration DirectShapeReferencingOption
Visual C++
public enum class DirectShapeReferencingOption

Members

Member name | Description
NotReferenceable | The associated DirectShape shall not be referenceable.
Referenceable | The associated DirectShape may be dimensioned and/or otherwise referenced.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


DirectShapeRoomBoundingOption Enumeration

[image]

Revit 2024 API
DirectShapeRoomBoundingOption Enumeration
See Also Send Feedback
An enumerated type containing possible room bounding settings for DirectShapes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016
Since: 2016

Syntax

C#
public enum DirectShapeRoomBoundingOption
Visual Basic
Public Enumeration DirectShapeRoomBoundingOption
Visual C++
public enum class DirectShapeRoomBoundingOption

Members

Member name | Description
NotApplicable | The associated DirectShape doesn't have a room bounding parameter, and isn't allowed to. Trying to change to this value will result in an exception. Trying to change from this value is restricted to DirectShapes that can be room bounding.
SetByParameter | The associated DirectShape has a room bounding parameter which is which is writeable and defaults to on. If can be toggled by a user or the API (by accessing the parameter WALL_ATTR_ROOM_BOUNDING).

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


DirectShapeTargetViewType Enumeration

[image]

Revit 2024 API
DirectShapeTargetViewType Enumeration
See Also Send Feedback
View types for which DirectShape objects are allowed to have alternative shape representations
View types for which DirectShape objects are allowed to have alternative shape representations. Currently limited to Plan Views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015
Since: 2015

Syntax

C#
public enum DirectShapeTargetViewType
Visual Basic
Public Enumeration DirectShapeTargetViewType
Visual C++
public enum class DirectShapeTargetViewType

Members

Member name | Description
Undefined | Invalid value
Default | Shape to be used in all views for which a view-specific shape was not provided
Plan | The alternate representation will be used only in Revit Plan views

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


DirectShapeType Class

[image]

Revit 2024 API
DirectShapeType Class
Members See Also Send Feedback
The type element associated with a DirectShape element. This element includes data reused by DirectShape elements of the same type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public class DirectShapeType : ElementType
Visual Basic
Public Class DirectShapeType _
    Inherits ElementType
Visual C++
public ref class DirectShapeType : public ElementType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..DirectShapeType

See Also

DirectShapeType Members


DirectShapeType Members

[image] [image]

Revit 2024 API
DirectShapeType Members
DirectShapeType Class Methods Properties See Also Send Feedback

The DirectShapeType type exposes the following members.

Methods

 | Name | Description
Public method | AddExternallyTaggedGeometry | Adds the externally tagged geometry object to the DirectShapeType.
Public method | AddReferenceCurve(Curve) | Adds a reference curve to the DirectShapeType.
Public method | AddReferenceCurve(Curve, DirectShapeReferenceOptions) | Adds a reference curve to the DirectShapeType.
Public method | AddReferencePlane(Plane) | Adds a reference plane to the DirectShapeType. The reference plane can either be bounded or unbounded.
Public method | AddReferencePlane(Plane, BoundingBoxUV) | Adds a reference plane to the DirectShapeType. The reference plane can either be bounded or unbounded.
Public method | AddReferencePlane(Plane, DirectShapeReferenceOptions) | Adds a reference plane to the DirectShapeType. The reference plane can either be bounded or unbounded.
Public method | AddReferencePlane(Plane, BoundingBoxUV, DirectShapeReferenceOptions) | Adds a reference plane to the DirectShapeType. The reference plane can either be bounded or unbounded.
Public method | AddReferencePoint(XYZ) | Adds a reference point to the DirectShapeType.
Public method | AddReferencePoint(XYZ, DirectShapeReferenceOptions) | Adds a reference point to the DirectShapeType.
Public method | AppendShape(IList<(Of <<'(GeometryObject>)>>)) | Appends the collection of GeometryObjects into the model shape representation stored in this DirectShape.
Public method | AppendShape(ShapeBuilder) | Append shape built by the supplied ShapeBuilderObject to shape representation stored in this DirectShapeType. The data stored in the supplied ShapeBuilder object will be cleared.
Public method | AppendShape(IList<(Of <<'(GeometryObject>)>>), DirectShapeTargetViewType) | Appends the collection of GeometryObjects into the model or view specific shape representation stored in this DirectShapeType. Passing DirectShapeTargetViewType.Default as view type will cause the model shape to be updated.
Public method | AreOptionsValid | Validates that the given DirectShapeTypeOptions are allowed for this particular DirectShapeType.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | AreValidDirectShapeReferenceOptions | Validates that the input DirectShapeReferenceOptions are suitable for creating a direct shape reference object. If the options specify an ExternalGeometryId, it must not correspond to any existing reference object belonging to the DirectShapeType.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanChangeFamilyName | Checks whether the DirectShapeType supports a custom family name.
Public method | CanCreateParts | Indicates if it is possible to create parts from this DirectShapeType element.
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create(Document, String, ElementId) | Creates a DirectShapeType element.
 | Create(Document, String, ElementId, DirectShapeTypeOptions) | Creates a DirectShapeType element.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternallyTaggedGeometry | Gets the externally tagged geometry by its external ID that is stored in this DirectShapeType.
Public method | GetExternallyTaggedReference | Retrieve a Reference to reference geometry of the DirectShapeType that is associated with a particular ExternalGeometryId.
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOptions | Gets a copy of the current options for this DirectShapeType.
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasExternalGeometry | Checks whether the externally tagged geometry is already present in this DirectShapeType.
Public method | HasExternallyTaggedReference | Checks if the externally tagged reference is already present in this DirectShapeType.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
 | IsValidReferenceCurve | Validates that the input curve is suitable for creating a direct shape type reference curve. Bounded and unbounded lines are accepted. Other bounded and unbounded curve types with natural bounds are accepted if they are not closed. Unbounded periodic curves are not allowed.
 | IsValidReferencePlaneBoundingBoxUV | Validates that the input BoundingBoxUV is suitable for bounding a reference plane surface. The input BoundingBoxUV must be set and not degenerate.
Public method | IsValidShape(ExternallyTaggedGeometryObject) | Validates shape to be stored in a DirectShapeType.
Public method | IsValidShape(IList<(Of <<'(GeometryObject>)>>)) | Validates shape to be stored in a DirectShapeType.
Public method | IsValidShape(IList<(Of <<'(GeometryObject>)>>), DirectShapeTargetViewType) | Validates view-specific shape to be stored in a DirectShapeType. Expects a non-default view type.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | IsValidUsage | Validates that the ExternallyTaggedGeometryObject's usage is set to an allowed value for a DirectShapeType.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | RemoveAllReferenceObjects | Removes all reference objects (if any) from the DirectShapeType.
Public method | RemoveExternallyTaggedGeometry | Removes the externally tagged geometry object by its external ID from this DirectShapeType.
Public method | RemoveReferenceObject(String) | Removes any reference objects with the given name from the DirectShapeType. Nothing is done if no reference objects have the given name or if the name is the empty string.
Public method | RemoveReferenceObject(ExternalGeometryId) | Removes any reference object associated with the provided ExternalGeometryId from the DirectShapeType. Nothing is done if no reference object has the given external ID or if the external ID is an empty string.
Public method | ResetExternallyTaggedGeometry | Removes all of the externally tagged geometry in this DirectShapeType.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetFamilyName | Sets the family name for the DirectShapeType.
Public method | SetOptions | Sets the options to use for this DirectShapeType.
Public method | SetShape(IList<(Of <<'(GeometryObject>)>>)) | Builds the type shape from the supplied collection of GeometryObjects. The objects are copied. If the new shape is identical to the old one, the old shape will be kept.
Public method | SetShape(ShapeBuilder) | Sets the shape of this object to the one accumulated in the supplied Builder object. If the new shape is identical to the old one, the old shape will be kept.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateExternallyTaggedGeometry | Updates the externally tagged geometry object in the DirectShapeType.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UserAssignability | An option controlling the ability of DirectShapes to assign this DirectShapeType as its type.
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DirectShapeType Class


DirectShapeType Methods

[image] [image]

Revit 2024 API
DirectShapeType Methods
DirectShapeType Class See Also Send Feedback

The DirectShapeType type exposes the following members.

Methods

 | Name | Description
Public method | AddExternallyTaggedGeometry | Adds the externally tagged geometry object to the DirectShapeType.
Public method | AddReferenceCurve(Curve) | Adds a reference curve to the DirectShapeType.
Public method | AddReferenceCurve(Curve, DirectShapeReferenceOptions) | Adds a reference curve to the DirectShapeType.
Public method | AddReferencePlane(Plane) | Adds a reference plane to the DirectShapeType. The reference plane can either be bounded or unbounded.
Public method | AddReferencePlane(Plane, BoundingBoxUV) | Adds a reference plane to the DirectShapeType. The reference plane can either be bounded or unbounded.
Public method | AddReferencePlane(Plane, DirectShapeReferenceOptions) | Adds a reference plane to the DirectShapeType. The reference plane can either be bounded or unbounded.
Public method | AddReferencePlane(Plane, BoundingBoxUV, DirectShapeReferenceOptions) | Adds a reference plane to the DirectShapeType. The reference plane can either be bounded or unbounded.
Public method | AddReferencePoint(XYZ) | Adds a reference point to the DirectShapeType.
Public method | AddReferencePoint(XYZ, DirectShapeReferenceOptions) | Adds a reference point to the DirectShapeType.
Public method | AppendShape(IList<(Of <<'(GeometryObject>)>>)) | Appends the collection of GeometryObjects into the model shape representation stored in this DirectShape.
Public method | AppendShape(ShapeBuilder) | Append shape built by the supplied ShapeBuilderObject to shape representation stored in this DirectShapeType. The data stored in the supplied ShapeBuilder object will be cleared.
Public method | AppendShape(IList<(Of <<'(GeometryObject>)>>), DirectShapeTargetViewType) | Appends the collection of GeometryObjects into the model or view specific shape representation stored in this DirectShapeType. Passing DirectShapeTargetViewType.Default as view type will cause the model shape to be updated.
Public method | AreOptionsValid | Validates that the given DirectShapeTypeOptions are allowed for this particular DirectShapeType.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | AreValidDirectShapeReferenceOptions | Validates that the input DirectShapeReferenceOptions are suitable for creating a direct shape reference object. If the options specify an ExternalGeometryId, it must not correspond to any existing reference object belonging to the DirectShapeType.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanChangeFamilyName | Checks whether the DirectShapeType supports a custom family name.
Public method | CanCreateParts | Indicates if it is possible to create parts from this DirectShapeType element.
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create(Document, String, ElementId) | Creates a DirectShapeType element.
 | Create(Document, String, ElementId, DirectShapeTypeOptions) | Creates a DirectShapeType element.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternallyTaggedGeometry | Gets the externally tagged geometry by its external ID that is stored in this DirectShapeType.
Public method | GetExternallyTaggedReference | Retrieve a Reference to reference geometry of the DirectShapeType that is associated with a particular ExternalGeometryId.
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOptions | Gets a copy of the current options for this DirectShapeType.
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasExternalGeometry | Checks whether the externally tagged geometry is already present in this DirectShapeType.
Public method | HasExternallyTaggedReference | Checks if the externally tagged reference is already present in this DirectShapeType.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
 | IsValidReferenceCurve | Validates that the input curve is suitable for creating a direct shape type reference curve. Bounded and unbounded lines are accepted. Other bounded and unbounded curve types with natural bounds are accepted if they are not closed. Unbounded periodic curves are not allowed.
 | IsValidReferencePlaneBoundingBoxUV | Validates that the input BoundingBoxUV is suitable for bounding a reference plane surface. The input BoundingBoxUV must be set and not degenerate.
Public method | IsValidShape(ExternallyTaggedGeometryObject) | Validates shape to be stored in a DirectShapeType.
Public method | IsValidShape(IList<(Of <<'(GeometryObject>)>>)) | Validates shape to be stored in a DirectShapeType.
Public method | IsValidShape(IList<(Of <<'(GeometryObject>)>>), DirectShapeTargetViewType) | Validates view-specific shape to be stored in a DirectShapeType. Expects a non-default view type.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | IsValidUsage | Validates that the ExternallyTaggedGeometryObject's usage is set to an allowed value for a DirectShapeType.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | RemoveAllReferenceObjects | Removes all reference objects (if any) from the DirectShapeType.
Public method | RemoveExternallyTaggedGeometry | Removes the externally tagged geometry object by its external ID from this DirectShapeType.
Public method | RemoveReferenceObject(String) | Removes any reference objects with the given name from the DirectShapeType. Nothing is done if no reference objects have the given name or if the name is the empty string.
Public method | RemoveReferenceObject(ExternalGeometryId) | Removes any reference object associated with the provided ExternalGeometryId from the DirectShapeType. Nothing is done if no reference object has the given external ID or if the external ID is an empty string.
Public method | ResetExternallyTaggedGeometry | Removes all of the externally tagged geometry in this DirectShapeType.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetFamilyName | Sets the family name for the DirectShapeType.
Public method | SetOptions | Sets the options to use for this DirectShapeType.
Public method | SetShape(IList<(Of <<'(GeometryObject>)>>)) | Builds the type shape from the supplied collection of GeometryObjects. The objects are copied. If the new shape is identical to the old one, the old shape will be kept.
Public method | SetShape(ShapeBuilder) | Sets the shape of this object to the one accumulated in the supplied Builder object. If the new shape is identical to the old one, the old shape will be kept.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateExternallyTaggedGeometry | Updates the externally tagged geometry object in the DirectShapeType.

See Also

DirectShapeType Class


AddExternallyTaggedGeometry Method

[image]

Revit 2024 API
DirectShapeType..::..AddExternallyTaggedGeometry Method
DirectShapeType Class See Also Send Feedback
Adds the externally tagged geometry object to the DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public void AddExternallyTaggedGeometry(
    ExternallyTaggedGeometryObject externallyTaggedGeometry
)
Visual Basic
Public Sub AddExternallyTaggedGeometry ( _
    externallyTaggedGeometry As ExternallyTaggedGeometryObject _
)
Visual C++
public:
void AddExternallyTaggedGeometry(
    ExternallyTaggedGeometryObject^ externallyTaggedGeometry
)

Parameters

externallyTaggedGeometry
Type: Autodesk.Revit.DB..::..ExternallyTaggedGeometryObject
The externally tagged geometry that should be added to the DirectShapeType.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input shape does not satisfy DirectShapeType validation criteria. -or- The input geometry does not have a permitted usage. -or- The externallyTaggedGeometry has already been added to this DirectShapeType.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShapeType Class


AddReferenceCurve Method (Curve)

[image]

Revit 2024 API
DirectShapeType..::..AddReferenceCurve Method (Curve)
DirectShapeType Class See Also Send Feedback
Adds a reference curve to the DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public void AddReferenceCurve(
    Curve refCurve
)
Visual Basic
Public Sub AddReferenceCurve ( _
    refCurve As Curve _
)
Visual C++
public:
void AddReferenceCurve(
    Curve^ refCurve
)

Parameters

refCurve
Type: Autodesk.Revit.DB..::..Curve
The geometry of the new reference curve. First case: The input curve's bounds are set. The resulting reference curve that is added to the DirectShapeType will be displayed with those bounds. Note that the specified bounds must not be degenerate. Second case: The input curve is unbounded. Reasonable bounds are therefore automatically calculated and applied to the input curve. The automatic bounds are based on the host direct shape's geometry. Note that only lines and splines may be unbounded. You must specify valid bounds for all other curve types.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | refCurve cannot be used for creating a reference curve.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShapeType Class
AddReferenceCurve Overload


AddReferenceCurve Method (Curve, DirectShapeReferenceOptions)

[image]

Revit 2024 API
DirectShapeType..::..AddReferenceCurve Method (Curve, DirectShapeReferenceOptions)
DirectShapeType Class See Also Send Feedback
Adds a reference curve to the DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public void AddReferenceCurve(
    Curve refCurve,
    DirectShapeReferenceOptions options
)
Visual Basic
Public Sub AddReferenceCurve ( _
    refCurve As Curve, _
    options As DirectShapeReferenceOptions _
)
Visual C++
public:
void AddReferenceCurve(
    Curve^ refCurve,
    DirectShapeReferenceOptions^ options
)

Parameters

refCurve
Type: Autodesk.Revit.DB..::..Curve
The geometry of the new reference curve. First case: The input curve's bounds are set. The resulting reference curve that is added to the DirectShapeType will be displayed with those bounds. Note that the specified bounds must not be degenerate. Second case: The input curve is unbounded. Reasonable bounds are therefore automatically calculated and applied to the input curve. The automatic bounds are based on the host direct shape's geometry. Note that only lines and splines may be unbounded. You must specify valid bounds for all other curve types.
options
Type: Autodesk.Revit.DB..::..DirectShapeReferenceOptions
The options that are used to configure the new reference curve.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | refCurve cannot be used for creating a reference curve. -or- options cannot be used to add a reference object to this DirectShapeType.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShapeType Class
AddReferenceCurve Overload


AddReferencePlane Method

[image] [image]

Revit 2024 API
DirectShapeType..::..AddReferencePlane Method
DirectShapeType Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddReferencePlane(Plane) | Adds a reference plane to the DirectShapeType. The reference plane can either be bounded or unbounded.
Public method | AddReferencePlane(Plane, BoundingBoxUV) | Adds a reference plane to the DirectShapeType. The reference plane can either be bounded or unbounded.
Public method | AddReferencePlane(Plane, DirectShapeReferenceOptions) | Adds a reference plane to the DirectShapeType. The reference plane can either be bounded or unbounded.
Public method | AddReferencePlane(Plane, BoundingBoxUV, DirectShapeReferenceOptions) | Adds a reference plane to the DirectShapeType. The reference plane can either be bounded or unbounded.

See Also

DirectShapeType Class
DirectShapeType Members


AddReferencePlane Method (Plane)

[image]

Revit 2024 API
DirectShapeType..::..AddReferencePlane Method (Plane)
DirectShapeType Class See Also Send Feedback
Adds a reference plane to the DirectShapeType. The reference plane can either be bounded or unbounded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public void AddReferencePlane(
    Plane refPlane
)
Visual Basic
Public Sub AddReferencePlane ( _
    refPlane As Plane _
)
Visual C++
public:
void AddReferencePlane(
    Plane^ refPlane
)

Parameters

refPlane
Type: Autodesk.Revit.DB..::..Plane
The geometry of the new reference plane.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShapeType Class
AddReferencePlane Overload


AddReferencePlane Method (Plane, BoundingBoxUV)

[image]

Revit 2024 API
DirectShapeType..::..AddReferencePlane Method (Plane, BoundingBoxUV)
DirectShapeType Class See Also Send Feedback
Adds a reference plane to the DirectShapeType. The reference plane can either be bounded or unbounded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public void AddReferencePlane(
    Plane refPlane,
    BoundingBoxUV boundingBoxUV
)
Visual Basic
Public Sub AddReferencePlane ( _
    refPlane As Plane, _
    boundingBoxUV As BoundingBoxUV _
)
Visual C++
public:
void AddReferencePlane(
    Plane^ refPlane,
    BoundingBoxUV^ boundingBoxUV
)

Parameters

refPlane
Type: Autodesk.Revit.DB..::..Plane
The geometry of the new reference plane.
boundingBoxUV
Type: Autodesk.Revit.DB..::..BoundingBoxUV
If boundingBoxUV is set, the resulting reference plane that is added to the DirectShapeType will be displayed with those bounds. Note that the specified bounds must not be degenerate. If boundingBoxUV is not set, reasonable bounds are automatically calculated and applied to the input plane. The automatic bounds are based on the host direct shape's geometry.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | boundingBoxUV cannot be used as a BoundingBoxUV for the reference plane surface.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShapeType Class
AddReferencePlane Overload


AddReferencePlane Method (Plane, DirectShapeReferenceOptions)

[image]

Revit 2024 API
DirectShapeType..::..AddReferencePlane Method (Plane, DirectShapeReferenceOptions)
DirectShapeType Class See Also Send Feedback
Adds a reference plane to the DirectShapeType. The reference plane can either be bounded or unbounded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public void AddReferencePlane(
    Plane refPlane,
    DirectShapeReferenceOptions options
)
Visual Basic
Public Sub AddReferencePlane ( _
    refPlane As Plane, _
    options As DirectShapeReferenceOptions _
)
Visual C++
public:
void AddReferencePlane(
    Plane^ refPlane,
    DirectShapeReferenceOptions^ options
)

Parameters

refPlane
Type: Autodesk.Revit.DB..::..Plane
The geometry of the new reference plane.
options
Type: Autodesk.Revit.DB..::..DirectShapeReferenceOptions
The options that are used to configure the new reference plane.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | options cannot be used to add a reference object to this DirectShapeType.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShapeType Class
AddReferencePlane Overload


AddReferencePlane Method (Plane, BoundingBoxUV, DirectShapeReferenceOptions)

[image]

Revit 2024 API
DirectShapeType..::..AddReferencePlane Method (Plane, BoundingBoxUV, DirectShapeReferenceOptions)
DirectShapeType Class See Also Send Feedback
Adds a reference plane to the DirectShapeType. The reference plane can either be bounded or unbounded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public void AddReferencePlane(
    Plane refPlane,
    BoundingBoxUV boundingBoxUV,
    DirectShapeReferenceOptions options
)
Visual Basic
Public Sub AddReferencePlane ( _
    refPlane As Plane, _
    boundingBoxUV As BoundingBoxUV, _
    options As DirectShapeReferenceOptions _
)
Visual C++
public:
void AddReferencePlane(
    Plane^ refPlane,
    BoundingBoxUV^ boundingBoxUV,
    DirectShapeReferenceOptions^ options
)

Parameters

refPlane
Type: Autodesk.Revit.DB..::..Plane
The geometry of the new reference plane.
boundingBoxUV
Type: Autodesk.Revit.DB..::..BoundingBoxUV
If boundingBoxUV is set, the resulting reference plane that is added to the DirectShapeType will be displayed with those bounds. Note that the specified bounds must not be degenerate. If boundingBoxUV is not set, reasonable bounds are automatically calculated and applied to the input plane. The automatic bounds are based on the host direct shape's geometry.
options
Type: Autodesk.Revit.DB..::..DirectShapeReferenceOptions
The options that are used to configure the new reference plane.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | boundingBoxUV cannot be used as a BoundingBoxUV for the reference plane surface. -or- options cannot be used to add a reference object to this DirectShapeType.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShapeType Class
AddReferencePlane Overload


AddReferencePoint Method

[image] [image]

Revit 2024 API
DirectShapeType..::..AddReferencePoint Method
DirectShapeType Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddReferencePoint(XYZ) | Adds a reference point to the DirectShapeType.
Public method | AddReferencePoint(XYZ, DirectShapeReferenceOptions) | Adds a reference point to the DirectShapeType.

See Also

DirectShapeType Class
DirectShapeType Members


AppendShape Method (IList(GeometryObject))

[image]

Revit 2024 API
DirectShapeType..::..AppendShape Method (IList<(Of <(<'GeometryObject>)>)>)
DirectShapeType Class See Also Send Feedback
Appends the collection of GeometryObjects into the model shape representation stored in this DirectShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public void AppendShape(
    IList<GeometryObject> pGeomArr
)
Visual Basic
Public Sub AppendShape ( _
    pGeomArr As IList(Of GeometryObject) _
)
Visual C++
public:
void AppendShape(
    IList<GeometryObject^>^ pGeomArr
)

Parameters

pGeomArr
Type: System.Collections.Generic..::..IList<(Of <(<' GeometryObject >)>)>
Shape expressed as a collection of GeometryObjects. The supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point, Curve and PolyLine.

Remarks

The existing shape will not be cleared by this function, and intersecting or overlapped geometry will not be joined with the appended geometry. It is up to the caller to ensure that the combination of geometry will have the correct appearance in Revit.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | At least one member of pGeomArr does not satisfy DirectShapeType validation criteria.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShapeType Class
AppendShape Overload


AppendShape Method (ShapeBuilder)

[image]

Revit 2024 API
DirectShapeType..::..AppendShape Method (ShapeBuilder)
DirectShapeType Class See Also Send Feedback
Append shape built by the supplied ShapeBuilderObject to shape representation stored in this DirectShapeType. The data stored in the supplied ShapeBuilder object will be cleared.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public void AppendShape(
    ShapeBuilder ShapeBuilder
)
Visual Basic
Public Sub AppendShape ( _
    ShapeBuilder As ShapeBuilder _
)
Visual C++
public:
void AppendShape(
    ShapeBuilder^ ShapeBuilder
)

Parameters

ShapeBuilder
Type: Autodesk.Revit.DB..::..ShapeBuilder
The ShapeBuilder object that was used to build the shape to be appended.

Remarks

The existing shape will not be cleared by this function, and intersecting or overlapped geometry will not be joined with the appended geometry. It is up to the caller to ensure that the combination of geometry will have teh correct appearance in Revit. This function will bypass extra geometry validation because the built geometry has already been validated by the ShapeBuilder. It is therefore slightly more efficient than the AppendShape() routine that accepts GeometryObjects directly as input.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShapeType Class
AppendShape Overload


AreOptionsValid Method

[image]

Revit 2024 API
DirectShapeType..::..AreOptionsValid Method
DirectShapeType Class See Also Send Feedback
Validates that the given DirectShapeTypeOptions are allowed for this particular DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public bool AreOptionsValid(
    DirectShapeTypeOptions options
)
Visual Basic
Public Function AreOptionsValid ( _
    options As DirectShapeTypeOptions _
) As Boolean
Visual C++
public:
bool AreOptionsValid(
    DirectShapeTypeOptions^ options
)

Parameters

options
Type: Autodesk.Revit.DB..::..DirectShapeTypeOptions
The options object.

Return Value

True if the DirectShapeTypeOptions are valid; false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShapeType Class


AreValidDirectShapeReferenceOptions Method

[image]

Revit 2024 API
DirectShapeType..::..AreValidDirectShapeReferenceOptions Method
DirectShapeType Class See Also Send Feedback
Validates that the input DirectShapeReferenceOptions are suitable for creating a direct shape reference object. If the options specify an ExternalGeometryId, it must not correspond to any existing reference object belonging to the DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public bool AreValidDirectShapeReferenceOptions(
    DirectShapeReferenceOptions options
)
Visual Basic
Public Function AreValidDirectShapeReferenceOptions ( _
    options As DirectShapeReferenceOptions _
) As Boolean
Visual C++
public:
bool AreValidDirectShapeReferenceOptions(
    DirectShapeReferenceOptions^ options
)

Parameters

options
Type: Autodesk.Revit.DB..::..DirectShapeReferenceOptions
The options to test.

Return Value

True if the options can be used to add a reference object to this DirectShapeType.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShapeType Class


CanChangeFamilyName Method

[image]

Revit 2024 API
DirectShapeType..::..CanChangeFamilyName Method
DirectShapeType Class See Also Send Feedback
Checks whether the DirectShapeType supports a custom family name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public bool CanChangeFamilyName()
Visual Basic
Public Function CanChangeFamilyName As Boolean
Visual C++
public:
bool CanChangeFamilyName()

Return Value

True if a custom family name is supported, false otherwise.

See Also

DirectShapeType Class


CanCreateParts Method

[image]

Revit 2024 API
DirectShapeType..::..CanCreateParts Method
DirectShapeType Class See Also Send Feedback
Indicates if it is possible to create parts from this DirectShapeType element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public bool CanCreateParts()
Visual Basic
Public Function CanCreateParts As Boolean
Visual C++
public:
bool CanCreateParts()

Return Value

True if it is possible to create parts from this DirectShapeType.

Remarks

While it is generally possible to create parts from DirectShape elements, some characteristics make parts creation impossible. This property is re-evaluated every time the DirectShapeType's geometry is modified (via a call to SetShape or AppendShape). Invalid configurations include: DirectShapeTypes containing a polymesh, or an open geometry, as well as DirectShapeTypes not containing any solids and DirectShapeTypes configured as NotReferenceable (via a call to SetOptions). Finally, if a DirectShapeType has other DirectShapeType instances in its geometry, and one of those other DirectShapeTypes has a configuration that is incompatible with parts creation, the host DirectShapeType will also be incompatible with parts creation.

See Also

DirectShapeType Class


Create Method

[image] [image]

Revit 2024 API
DirectShapeType..::..Create Method
DirectShapeType Class See Also Send Feedback

Overload List

Name | Description
Create(Document, String, ElementId) | Creates a DirectShapeType element.
Create(Document, String, ElementId, DirectShapeTypeOptions) | Creates a DirectShapeType element.

See Also

DirectShapeType Class
DirectShapeType Members


Create Method (Document, String, ElementId)

[image]

Revit 2024 API
DirectShapeType..::..Create Method (Document, String, ElementId)
DirectShapeType Class See Also Send Feedback
Creates a DirectShapeType element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static DirectShapeType Create(
    Document document,
    string name,
    ElementId categoryId
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    name As String, _
    categoryId As ElementId _
) As DirectShapeType
Visual C++
public:
static DirectShapeType^ Create(
    Document^ document,
    String^ name,
    ElementId^ categoryId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Document to which the created element will be added. Must be a project document.
name
Type: System..::..String
Name of the DirectShapeType.
categoryId
Type: Autodesk.Revit.DB..::..ElementId
Id of the category assigned to this DirectShapeType. Must be a valid category id.

Return Value

The new DirectShapeType.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- Document document may not contain DirectShape or DirectShapeType objects. -or- Element id categoryId may not be used as a DirectShape category.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShapeType Class
Create Overload


Create Method (Document, String, ElementId, DirectShapeTypeOptions)

[image]

Revit 2024 API
DirectShapeType..::..Create Method (Document, String, ElementId, DirectShapeTypeOptions)
DirectShapeType Class See Also Send Feedback
Creates a DirectShapeType element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static DirectShapeType Create(
    Document document,
    string name,
    ElementId categoryId,
    DirectShapeTypeOptions options
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    name As String, _
    categoryId As ElementId, _
    options As DirectShapeTypeOptions _
) As DirectShapeType
Visual C++
public:
static DirectShapeType^ Create(
    Document^ document,
    String^ name,
    ElementId^ categoryId,
    DirectShapeTypeOptions^ options
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Document to which the created element will be added.
name
Type: System..::..String
Name of the DirectShapeType.
categoryId
Type: Autodesk.Revit.DB..::..ElementId
Id of the category assigned to this DirectShapeType. Must be a valid category id.
options
Type: Autodesk.Revit.DB..::..DirectShapeTypeOptions
Options that can be used to control the behavior of DirectShapeType being created.

Return Value

The new DirectShapeType.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Document document may not contain DirectShape or DirectShapeType objects. -or- Element id categoryId may not be used as a DirectShape category.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShapeType Class
Create Overload


GetExternallyTaggedGeometry Method

[image]

Revit 2024 API
DirectShapeType..::..GetExternallyTaggedGeometry Method
DirectShapeType Class See Also Send Feedback
Gets the externally tagged geometry by its external ID that is stored in this DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public ExternallyTaggedGeometryObject GetExternallyTaggedGeometry(
    ExternalGeometryId externalId
)
Visual Basic
Public Function GetExternallyTaggedGeometry ( _
    externalId As ExternalGeometryId _
) As ExternallyTaggedGeometryObject
Visual C++
public:
ExternallyTaggedGeometryObject^ GetExternallyTaggedGeometry(
    ExternalGeometryId^ externalId
)

Parameters

externalId
Type: Autodesk.Revit.DB..::..ExternalGeometryId
The external ID of the externally tagged geometry that should be obtained.

Return Value

The externally tagged geometry. Or nullNothingnullptra null reference (Nothing in Visual Basic) if there is no such externally tagged geometry in the DirectShapeType.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShapeType Class


GetExternallyTaggedReference Method

[image]

Revit 2024 API
DirectShapeType..::..GetExternallyTaggedReference Method
DirectShapeType Class See Also Send Feedback
Retrieve a Reference to reference geometry of the DirectShapeType that is associated with a particular ExternalGeometryId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public Reference GetExternallyTaggedReference(
    ExternalGeometryId externalId
)
Visual Basic
Public Function GetExternallyTaggedReference ( _
    externalId As ExternalGeometryId _
) As Reference
Visual C++
public:
Reference^ GetExternallyTaggedReference(
    ExternalGeometryId^ externalId
)

Parameters

externalId
Type: Autodesk.Revit.DB..::..ExternalGeometryId
The ExternalGeometryId of the requested reference object.

Return Value

A Reference to the externally tagged reference GeometryObject having the provided external ID or nullNothingnullptra null reference (Nothing in Visual Basic) if there is no reference geometry having the external ID.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShapeType Class


GetOptions Method

[image]

Revit 2024 API
DirectShapeType..::..GetOptions Method
DirectShapeType Class See Also Send Feedback
Gets a copy of the current options for this DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public DirectShapeTypeOptions GetOptions()
Visual Basic
Public Function GetOptions As DirectShapeTypeOptions
Visual C++
public:
DirectShapeTypeOptions^ GetOptions()

Return Value

Options currently set for this DirectShapeType.

See Also

DirectShapeType Class


HasExternalGeometry Method

[image]

Revit 2024 API
DirectShapeType..::..HasExternalGeometry Method
DirectShapeType Class See Also Send Feedback
Checks whether the externally tagged geometry is already present in this DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public bool HasExternalGeometry(
    ExternalGeometryId externalId
)
Visual Basic
Public Function HasExternalGeometry ( _
    externalId As ExternalGeometryId _
) As Boolean
Visual C++
public:
bool HasExternalGeometry(
    ExternalGeometryId^ externalId
)

Parameters

externalId
Type: Autodesk.Revit.DB..::..ExternalGeometryId
The external ID of the externally tagged geometry to check.

Return Value

True if such an externally tagged geometry is already present in this DirectShapeType, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShapeType Class


HasExternallyTaggedReference Method

[image]

Revit 2024 API
DirectShapeType..::..HasExternallyTaggedReference Method
DirectShapeType Class See Also Send Feedback
Checks if the externally tagged reference is already present in this DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public bool HasExternallyTaggedReference(
    ExternalGeometryId externalId
)
Visual Basic
Public Function HasExternallyTaggedReference ( _
    externalId As ExternalGeometryId _
) As Boolean
Visual C++
public:
bool HasExternallyTaggedReference(
    ExternalGeometryId^ externalId
)

Parameters

externalId
Type: Autodesk.Revit.DB..::..ExternalGeometryId
The external ID of the tagged reference to check for.

Return Value

True if the DirectShapeType holds a reference with the specified ExternalGeometryId.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShapeType Class


IsValidReferenceCurve Method

[image]

Revit 2024 API
DirectShapeType..::..IsValidReferenceCurve Method
DirectShapeType Class See Also Send Feedback
Validates that the input curve is suitable for creating a direct shape type reference curve. Bounded and unbounded lines are accepted. Other bounded and unbounded curve types with natural bounds are accepted if they are not closed. Unbounded periodic curves are not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public static bool IsValidReferenceCurve(
    Curve curve
)
Visual Basic
Public Shared Function IsValidReferenceCurve ( _
    curve As Curve _
) As Boolean
Visual C++
public:
static bool IsValidReferenceCurve(
    Curve^ curve
)

Parameters

curve
Type: Autodesk.Revit.DB..::..Curve
The curve to test.

Return Value

True if the input curve point can be used to create a direct shape reference curve, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShapeType Class


IsValidReferencePlaneBoundingBoxUV Method

[image]

Revit 2024 API
DirectShapeType..::..IsValidReferencePlaneBoundingBoxUV Method
DirectShapeType Class See Also Send Feedback
Validates that the input BoundingBoxUV is suitable for bounding a reference plane surface. The input BoundingBoxUV must be set and not degenerate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public static bool IsValidReferencePlaneBoundingBoxUV(
    BoundingBoxUV boundingBoxUV
)
Visual Basic
Public Shared Function IsValidReferencePlaneBoundingBoxUV ( _
    boundingBoxUV As BoundingBoxUV _
) As Boolean
Visual C++
public:
static bool IsValidReferencePlaneBoundingBoxUV(
    BoundingBoxUV^ boundingBoxUV
)

Parameters

boundingBoxUV
Type: Autodesk.Revit.DB..::..BoundingBoxUV
The reference plane BoundingBoxUV to test.

Return Value

True if the input BoundingBoxUV is valid for reference plane surfaces, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShapeType Class


IsValidShape Method

[image] [image]

Revit 2024 API
DirectShapeType..::..IsValidShape Method
DirectShapeType Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsValidShape(ExternallyTaggedGeometryObject) | Validates shape to be stored in a DirectShapeType.
Public method | IsValidShape(IList<(Of <<'(GeometryObject>)>>)) | Validates shape to be stored in a DirectShapeType.
Public method | IsValidShape(IList<(Of <<'(GeometryObject>)>>), DirectShapeTargetViewType) | Validates view-specific shape to be stored in a DirectShapeType. Expects a non-default view type.

See Also

DirectShapeType Class
DirectShapeType Members


IsValidShape Method (ExternallyTaggedGeometryObject)

[image]

Revit 2024 API
DirectShapeType..::..IsValidShape Method (ExternallyTaggedGeometryObject)
DirectShapeType Class See Also Send Feedback
Validates shape to be stored in a DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public bool IsValidShape(
    ExternallyTaggedGeometryObject externallyTaggedGeometry
)
Visual Basic
Public Function IsValidShape ( _
    externallyTaggedGeometry As ExternallyTaggedGeometryObject _
) As Boolean
Visual C++
public:
bool IsValidShape(
    ExternallyTaggedGeometryObject^ externallyTaggedGeometry
)

Parameters

externallyTaggedGeometry
Type: Autodesk.Revit.DB..::..ExternallyTaggedGeometryObject
The supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point and Curve.

Return Value

True if the supplied shape passes the validation criteria.

Remarks

This function uses the same criteria as IsValidShape(GeometryObject).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShapeType Class
IsValidShape Overload


IsValidShape Method (IList(GeometryObject))

[image]

Revit 2024 API
DirectShapeType..::..IsValidShape Method (IList<(Of <(<'GeometryObject>)>)>)
DirectShapeType Class See Also Send Feedback
Validates shape to be stored in a DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public bool IsValidShape(
    IList<GeometryObject> shape
)
Visual Basic
Public Function IsValidShape ( _
    shape As IList(Of GeometryObject) _
) As Boolean
Visual C++
public:
bool IsValidShape(
    IList<GeometryObject^>^ shape
)

Parameters

shape
Type: System.Collections.Generic..::..IList<(Of <(<' GeometryObject >)>)>
Shape to be validated represented as a collection of GeometryObjects. The supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point, Curve and PolyLine.

Return Value

True if the supplied shape passes the validation criteria.

Remarks

This function calls IsValidShape(GeometryObject) to validate each object in the list.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShapeType Class
IsValidShape Overload


IsValidUsage Method

[image]

Revit 2024 API
DirectShapeType..::..IsValidUsage Method
DirectShapeType Class See Also Send Feedback
Validates that the ExternallyTaggedGeometryObject's usage is set to an allowed value for a DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public bool IsValidUsage(
    ExternallyTaggedGeometryObject externallyTaggedGeometry
)
Visual Basic
Public Function IsValidUsage ( _
    externallyTaggedGeometry As ExternallyTaggedGeometryObject _
) As Boolean
Visual C++
public:
bool IsValidUsage(
    ExternallyTaggedGeometryObject^ externallyTaggedGeometry
)

Parameters

externallyTaggedGeometry
Type: Autodesk.Revit.DB..::..ExternallyTaggedGeometryObject
The geometry to check.

Return Value

True if the usage is permitted.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShapeType Class


RemoveExternallyTaggedGeometry Method

[image]

Revit 2024 API
DirectShapeType..::..RemoveExternallyTaggedGeometry Method
DirectShapeType Class See Also Send Feedback
Removes the externally tagged geometry object by its external ID from this DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public void RemoveExternallyTaggedGeometry(
    ExternalGeometryId externalId
)
Visual Basic
Public Sub RemoveExternallyTaggedGeometry ( _
    externalId As ExternalGeometryId _
)
Visual C++
public:
void RemoveExternallyTaggedGeometry(
    ExternalGeometryId^ externalId
)

Parameters

externalId
Type: Autodesk.Revit.DB..::..ExternalGeometryId
The external ID of the externally tagged geometry that should be removed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The externally tagged geometry with the input externalId is not present in this DirectShapeType.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShapeType Class


RemoveReferenceObject Method

[image] [image]

Revit 2024 API
DirectShapeType..::..RemoveReferenceObject Method
DirectShapeType Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RemoveReferenceObject(String) | Removes any reference objects with the given name from the DirectShapeType. Nothing is done if no reference objects have the given name or if the name is the empty string.
Public method | RemoveReferenceObject(ExternalGeometryId) | Removes any reference object associated with the provided ExternalGeometryId from the DirectShapeType. Nothing is done if no reference object has the given external ID or if the external ID is an empty string.

See Also

DirectShapeType Class
DirectShapeType Members


RemoveReferenceObject Method (String)

[image]

Revit 2024 API
DirectShapeType..::..RemoveReferenceObject Method (String)
DirectShapeType Class See Also Send Feedback
Removes any reference objects with the given name from the DirectShapeType. Nothing is done if no reference objects have the given name or if the name is the empty string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public void RemoveReferenceObject(
    string refName
)
Visual Basic
Public Sub RemoveReferenceObject ( _
    refName As String _
)
Visual C++
public:
void RemoveReferenceObject(
    String^ refName
)

Parameters

refName
Type: System..::..String
The name of the reference object(s) to be removed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShapeType Class
RemoveReferenceObject Overload


ResetExternallyTaggedGeometry Method

[image]

Revit 2024 API
DirectShapeType..::..ResetExternallyTaggedGeometry Method
DirectShapeType Class See Also Send Feedback
Removes all of the externally tagged geometry in this DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public void ResetExternallyTaggedGeometry()
Visual Basic
Public Sub ResetExternallyTaggedGeometry
Visual C++
public:
void ResetExternallyTaggedGeometry()

See Also

DirectShapeType Class


SetFamilyName Method

[image]

Revit 2024 API
DirectShapeType..::..SetFamilyName Method
DirectShapeType Class See Also Send Feedback
Sets the family name for the DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public void SetFamilyName(
    string name
)
Visual Basic
Public Sub SetFamilyName ( _
    name As String _
)
Visual C++
public:
void SetFamilyName(
    String^ name
)

Parameters

name
Type: System..::..String
Family name for the DirectShapeType.

Remarks

By default the family name is either Direct Shape or a category-specific name. When a category-specific name is used the family name cannot be set.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element type name was empty, contained invalid characters, or was invalid for the specific element type.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The given DirectShapeType has a category which does not support a custom family name.

See Also

DirectShapeType Class


SetOptions Method

[image]

Revit 2024 API
DirectShapeType..::..SetOptions Method
DirectShapeType Class See Also Send Feedback
Sets the options to use for this DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public void SetOptions(
    DirectShapeTypeOptions options
)
Visual Basic
Public Sub SetOptions ( _
    options As DirectShapeTypeOptions _
)
Visual C++
public:
void SetOptions(
    DirectShapeTypeOptions^ options
)

Parameters

options
Type: Autodesk.Revit.DB..::..DirectShapeTypeOptions
Options to use for this DirectShapeType.

Remarks

The new options take effect immediately.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The DirectShapeTypeOptions provided are not valid for this DirectShapeType.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShapeType Class


SetShape Method

[image] [image]

Revit 2024 API
DirectShapeType..::..SetShape Method
DirectShapeType Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetShape(IList<(Of <<'(GeometryObject>)>>)) | Builds the type shape from the supplied collection of GeometryObjects. The objects are copied. If the new shape is identical to the old one, the old shape will be kept.
Public method | SetShape(ShapeBuilder) | Sets the shape of this object to the one accumulated in the supplied Builder object. If the new shape is identical to the old one, the old shape will be kept.

See Also

DirectShapeType Class
DirectShapeType Members


SetShape Method (IList(GeometryObject))

[image]

Revit 2024 API
DirectShapeType..::..SetShape Method (IList<(Of <(<'GeometryObject>)>)>)
DirectShapeType Class See Also Send Feedback
Builds the type shape from the supplied collection of GeometryObjects. The objects are copied. If the new shape is identical to the old one, the old shape will be kept.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public void SetShape(
    IList<GeometryObject> pGeomArr
)
Visual Basic
Public Sub SetShape ( _
    pGeomArr As IList(Of GeometryObject) _
)
Visual C++
public:
void SetShape(
    IList<GeometryObject^>^ pGeomArr
)

Parameters

pGeomArr
Type: System.Collections.Generic..::..IList<(Of <(<' GeometryObject >)>)>
Shape of this object expressed as a collection of GeometryObjects. These will be copied. Shape and Category should be consistent: geometry supplied as shape should be valid for the Category the type object is associated with. The supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point, Curve and PolyLine.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | At least one member of pGeomArr does not satisfy DirectShapeType validation criteria.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShapeType Class
SetShape Overload


SetShape Method (ShapeBuilder)

[image]

Revit 2024 API
DirectShapeType..::..SetShape Method (ShapeBuilder)
DirectShapeType Class See Also Send Feedback
Sets the shape of this object to the one accumulated in the supplied Builder object. If the new shape is identical to the old one, the old shape will be kept.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public void SetShape(
    ShapeBuilder pBuilder
)
Visual Basic
Public Sub SetShape ( _
    pBuilder As ShapeBuilder _
)
Visual C++
public:
void SetShape(
    ShapeBuilder^ pBuilder
)

Parameters

pBuilder
Type: Autodesk.Revit.DB..::..ShapeBuilder
A ShapeBuilder object that was used to successfully build geometry to store in this DirectShapeType. The built shape will be transferred to the DirectShapeType, and the ShapeBuilder object will be reset.

Remarks

This function will bypass extra geometry validation because the built geometry has already been validated by the ShapeBuilder. It is therefore slightly more efficient than the SetShape() routine that accepts GeometryObjects directly as input. Supplying a ViewShapeBuilder object as argument will cause the view-specific shape of this DirectShapeType to be updated. Supplying other ShapeBuilder types will update the model shape.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShapeType Class
SetShape Overload


UpdateExternallyTaggedGeometry Method

[image]

Revit 2024 API
DirectShapeType..::..UpdateExternallyTaggedGeometry Method
DirectShapeType Class See Also Send Feedback
Updates the externally tagged geometry object in the DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public void UpdateExternallyTaggedGeometry(
    ExternallyTaggedGeometryObject externallyTaggedGeometry
)
Visual Basic
Public Sub UpdateExternallyTaggedGeometry ( _
    externallyTaggedGeometry As ExternallyTaggedGeometryObject _
)
Visual C++
public:
void UpdateExternallyTaggedGeometry(
    ExternallyTaggedGeometryObject^ externallyTaggedGeometry
)

Parameters

externallyTaggedGeometry
Type: Autodesk.Revit.DB..::..ExternallyTaggedGeometryObject
The externally tagged geometry that should be updated in the DirectShapeType.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input shape does not satisfy DirectShapeType validation criteria. -or- A previous version of the externally tagged geometry is not present in this DirectShapeType.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DirectShapeType Class


Parameter Property

[image] [image]

Revit 2024 API
DirectShapeType..::..Parameter Property
DirectShapeType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

DirectShapeType Class
DirectShapeType Members


UserAssignability Property

[image]

Revit 2024 API
DirectShapeType..::..UserAssignability Property
DirectShapeType Class See Also Send Feedback
An option controlling the ability of DirectShapes to assign this DirectShapeType as its type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public DirectShapeTypeUserAssignability UserAssignability { get; set; }
Visual Basic
Public Property UserAssignability As DirectShapeTypeUserAssignability
    Get
    Set
Visual C++
public:
property DirectShapeTypeUserAssignability UserAssignability {
    DirectShapeTypeUserAssignability get ();
    void set (DirectShapeTypeUserAssignability value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

DirectShapeType Class


DirectShapeTypeOptions Members

[image] [image]

Revit 2024 API
DirectShapeTypeOptions Members
DirectShapeTypeOptions Class Constructors Methods Properties See Also Send Feedback

The DirectShapeTypeOptions type exposes the following members.

Constructors

 | Name | Description
Public method | DirectShapeTypeOptions | Constructs a new DirectShapeTypeOptions instance with default settings.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the DirectShapeTypeOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqualTo | Compare this object with the one supplied as argument. Return true if the options specified by both objects are the same.
Public method | IsValid | Determines whether a DirectShapeTypeOptions is internally consistent (valid).
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AllowDuplicateNames | Determines whether or not duplicate DirectShapeType names are allowed.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

DirectShapeTypeOptions Class


DirectShapeTypeOptions Methods

[image] [image]

Revit 2024 API
DirectShapeTypeOptions Methods
DirectShapeTypeOptions Class See Also Send Feedback

The DirectShapeTypeOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqualTo | Compare this object with the one supplied as argument. Return true if the options specified by both objects are the same.
Public method | IsValid | Determines whether a DirectShapeTypeOptions is internally consistent (valid).
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DirectShapeTypeOptions Class


Dispose Method

[image]

Revit 2024 API
DirectShapeTypeOptions..::..Dispose Method
DirectShapeTypeOptions Class See Also Send Feedback
Releases all resources used by the DirectShapeTypeOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

DirectShapeTypeOptions Class


DirectShapeTypeOptions Properties

[image] [image]

Revit 2024 API
DirectShapeTypeOptions Properties
DirectShapeTypeOptions Class See Also Send Feedback

The DirectShapeTypeOptions type exposes the following members.

Properties

 | Name | Description
Public property | AllowDuplicateNames | Determines whether or not duplicate DirectShapeType names are allowed.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

DirectShapeTypeOptions Class


IsValidObject Property

[image]

Revit 2024 API
DirectShapeTypeOptions..::..IsValidObject Property
DirectShapeTypeOptions Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

DirectShapeTypeOptions Class


DirectShapeTypeUserAssignability Enumeration

[image]

Revit 2024 API
DirectShapeTypeUserAssignability Enumeration
See Also Send Feedback
Options for a DirectShapeType which affect whether or not it can be assigned as the type of a DirectShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023
Since: 2023

Syntax

C#
public enum DirectShapeTypeUserAssignability
Visual Basic
Public Enumeration DirectShapeTypeUserAssignability
Visual C++
public enum class DirectShapeTypeUserAssignability

Members

Member name | Description
Assignable | The DirectShapeType can be used to replace the type of an existing DirectShape.
Nonassignable | The DirectShapeType cannot be used to replace the type of an existing DirectShape.

Remarks

Only DirectShapeTypes which permit assignability will be shown in the type selector dialog. A DirectShape which uses a DirectShapeType which is not assignable can be copied.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


DisableAnalyticalModelCB Class

[image]

Revit 2024 API
DisableAnalyticalModelCB Class
Members See Also Send Feedback
Disable the analytical model for a structural wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public class DisableAnalyticalModelCB : FailureResolution
Visual Basic
Public Class DisableAnalyticalModelCB _
    Inherits FailureResolution
Visual C++
public ref class DisableAnalyticalModelCB : public FailureResolution

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FailureResolution
Autodesk.Revit.DB..::..DisableAnalyticalModelCB

See Also

DisableAnalyticalModelCB Members


DisableAnalyticalModelCB Members

[image] [image]

Revit 2024 API
DisableAnalyticalModelCB Members
DisableAnalyticalModelCB Class Methods Properties See Also Send Feedback

The DisableAnalyticalModelCB type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FailureResolution.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FailureResolution.)

See Also

DisableAnalyticalModelCB Class


DisableAnalyticalModelCB Methods

[image] [image]

Revit 2024 API
DisableAnalyticalModelCB Methods
DisableAnalyticalModelCB Class See Also Send Feedback

The DisableAnalyticalModelCB type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FailureResolution.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DisableAnalyticalModelCB Class


DisableAnalyticalModelCB Properties

[image] [image]

Revit 2024 API
DisableAnalyticalModelCB Properties
DisableAnalyticalModelCB Class See Also Send Feedback

The DisableAnalyticalModelCB type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FailureResolution.)

See Also

DisableAnalyticalModelCB Class


DisciplineTypeId Class

[image]

Revit 2024 API
DisciplineTypeId Class
Members See Also Send Feedback
This class contains constants identifying disciplines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public static class DisciplineTypeId
Visual Basic
Public NotInheritable Class DisciplineTypeId
Visual C++
public ref class DisciplineTypeId abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..DisciplineTypeId

See Also

DisciplineTypeId Members


DisciplineTypeId Members

[image] [image]

Revit 2024 API
DisciplineTypeId Members
DisciplineTypeId Class Properties See Also Send Feedback

The DisciplineTypeId type exposes the following members.

Properties

Name | Description
Architecture | Architecture.
Common | Common.
Electrical | Electrical.
Energy | Energy.
Hvac | HVAC.
Infrastructure | Infrastructure.
Piping | Piping.
Structural | Structural.

See Also

DisciplineTypeId Class


DisciplineTypeId Properties

[image] [image]

Revit 2024 API
DisciplineTypeId Properties
DisciplineTypeId Class See Also Send Feedback

The DisciplineTypeId type exposes the following members.

Properties

Name | Description
Architecture | Architecture.
Common | Common.
Electrical | Electrical.
Energy | Energy.
Hvac | HVAC.
Infrastructure | Infrastructure.
Piping | Piping.
Structural | Structural.

See Also

DisciplineTypeId Class


Architecture Property

[image]

Revit 2024 API
DisciplineTypeId..::..Architecture Property
DisciplineTypeId Class See Also Send Feedback
Architecture.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public static ForgeTypeId Architecture { get; }
Visual Basic
Public Shared ReadOnly Property Architecture As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Architecture {
    ForgeTypeId^ get ();
}

See Also

DisciplineTypeId Class


Common Property

[image]

Revit 2024 API
DisciplineTypeId..::..Common Property
DisciplineTypeId Class See Also Send Feedback
Common.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public static ForgeTypeId Common { get; }
Visual Basic
Public Shared ReadOnly Property Common As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Common {
    ForgeTypeId^ get ();
}

See Also

DisciplineTypeId Class


Electrical Property

[image]

Revit 2024 API
DisciplineTypeId..::..Electrical Property
DisciplineTypeId Class See Also Send Feedback
Electrical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public static ForgeTypeId Electrical { get; }
Visual Basic
Public Shared ReadOnly Property Electrical As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Electrical {
    ForgeTypeId^ get ();
}

See Also

DisciplineTypeId Class


Energy Property

[image]

Revit 2024 API
DisciplineTypeId..::..Energy Property
DisciplineTypeId Class See Also Send Feedback
Energy.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public static ForgeTypeId Energy { get; }
Visual Basic
Public Shared ReadOnly Property Energy As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Energy {
    ForgeTypeId^ get ();
}

See Also

DisciplineTypeId Class


Hvac Property

[image]

Revit 2024 API
DisciplineTypeId..::..Hvac Property
DisciplineTypeId Class See Also Send Feedback
HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public static ForgeTypeId Hvac { get; }
Visual Basic
Public Shared ReadOnly Property Hvac As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Hvac {
    ForgeTypeId^ get ();
}

See Also

DisciplineTypeId Class


Infrastructure Property

[image]

Revit 2024 API
DisciplineTypeId..::..Infrastructure Property
DisciplineTypeId Class See Also Send Feedback
Infrastructure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public static ForgeTypeId Infrastructure { get; }
Visual Basic
Public Shared ReadOnly Property Infrastructure As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Infrastructure {
    ForgeTypeId^ get ();
}

See Also

DisciplineTypeId Class


Piping Property

[image]

Revit 2024 API
DisciplineTypeId..::..Piping Property
DisciplineTypeId Class See Also Send Feedback
Piping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public static ForgeTypeId Piping { get; }
Visual Basic
Public Shared ReadOnly Property Piping As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Piping {
    ForgeTypeId^ get ();
}

See Also

DisciplineTypeId Class


Structural Property

[image]

Revit 2024 API
DisciplineTypeId..::..Structural Property
DisciplineTypeId Class See Also Send Feedback
Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public static ForgeTypeId Structural { get; }
Visual Basic
Public Shared ReadOnly Property Structural As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Structural {
    ForgeTypeId^ get ();
}

See Also

DisciplineTypeId Class


DisplacementElement Class

[image]

Revit 2024 API
DisplacementElement Class
Members See Also Send Feedback
A view-specific element that causes other elements to appear to be displaced from their actual locations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class DisplacementElement : Element
Visual Basic
Public Class DisplacementElement _
    Inherits Element
Visual C++
public ref class DisplacementElement : public Element

Remarks

The DisplacementElement does not actually change the location of any model elements; it merely causes them to be displayed in a different location.

An element may only be displaced by a single DisplacementElement in any view. Assigning an element to more than one DisplacementElement is an error condition.

A DisplacementElement can declare another DisplacementElement as its parent. In that case, its transform will be concatenated with that of the parent, and the displacement of its associated elements will be relative to the parent DisplacementElement.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..DisplacementElement

See Also

DisplacementElement Members


DisplacementElement Members

[image] [image]

Revit 2024 API
DisplacementElement Members
DisplacementElement Class Methods Properties See Also Send Feedback

The DisplacementElement type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
 | CanCategoryBeDisplaced | Indicates whether elements of the specified category are eligible as displaced elements.
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanElementsBeAddedToDisplacementSet | Indicates if these elements can be displaced by this DisplacementElement.
 | CanElementsBeDisplaced(View, ICollection<(Of <<'(ElementId>)>>)) | Indicates if elements can be assigned to a new DisplacementElement.
 | CanElementsBeDisplaced(View, ICollection<(Of <<'(ElementId>)>>), ElementId%) | Indicates if elements can be assigned to a new DisplacementElement.
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create | Creates a new DisplacementElement as a child of the specified parent DisplacementElement.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetAbsoluteDisplacement | The absolute displacement applied to the displaced elements.
 | GetAdditionalElementsToDisplace | Identify a set of elements that potentially should be displaced along with a given element.
Public method | GetChildren | Returns a set of DisplacementElements which have this DisplacementElement as a parent.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetDisplacedElementIds()()()() | The ids of the elements affected by this DisplacementElement.
 | GetDisplacedElementIds(View) | Returns the element ids of all displaced elements in the specified view.
Public method | GetDisplacedElementIdsFromAllChildren | The element ids of elements displaced by this DisplacementElement and any DisplacementElement which declare this one as parent.
 | GetDisplacementElementId | The element id of the DisplacementElement that includes the specified element.
 | GetDisplacementElementIds | The element ids of all DisplacementElements owned by the specified view.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetRelativeDisplacement | The relative displacement applied to the displaced elements by this DisplacementElement.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
 | IsAllowedAsDisplacedElement | Indicates if the specified element is allowed to be displaced.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
 | IsElementDisplacedInView | Indicates if the specified element displaced in the specified View.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
 | IsNotEmpty | Validates that the input set of element ids is valid for a DisplacementElement.
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
 | IsValidAsParentInView | Indicates whether the specified DisplacementElement can be used as a parent when creating a DisplacementElement in the specified view.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | RemoveDisplacedElement | Remove a displaced element from this DisplacementElement.
Public method | ResetDisplacedElements | Sets the translation of the DisplacementElement to (0, 0, 0). The DisplacementElement continues to exist, but its elements are displayed in their actual location.
Public method | SetDisplacedElementIds | Sets the ids of the elements affected by this DisplacementElement.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetRelativeDisplacement | Sets the relative displacement applied to the displaced elements by this DisplacementElement.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParentId | The element id of the parent DisplacementElement. This DisplacementElement's relative transform will be concatenated with the absolute transform of its parent.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DisplacementElement Class


CanElementsBeAddedToDisplacementSet Method

[image]

Revit 2024 API
DisplacementElement..::..CanElementsBeAddedToDisplacementSet Method
DisplacementElement Class See Also Send Feedback
Indicates if these elements can be displaced by this DisplacementElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool CanElementsBeAddedToDisplacementSet(
    ICollection<ElementId> toDisplace
)
Visual Basic
Public Function CanElementsBeAddedToDisplacementSet ( _
    toDisplace As ICollection(Of ElementId) _
) As Boolean
Visual C++
public:
bool CanElementsBeAddedToDisplacementSet(
    ICollection<ElementId^>^ toDisplace
)

Parameters

toDisplace
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
The elements to displace.

Return Value

True if the elements can be displaced by this DisplacementElement.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DisplacementElement Class


CanElementsBeDisplaced Method

[image] [image]

Revit 2024 API
DisplacementElement..::..CanElementsBeDisplaced Method
DisplacementElement Class See Also Send Feedback

Overload List

Name | Description
CanElementsBeDisplaced(View, ICollection<(Of <<'(ElementId>)>>)) | Indicates if elements can be assigned to a new DisplacementElement.
CanElementsBeDisplaced(View, ICollection<(Of <<'(ElementId>)>>), ElementId%) | Indicates if elements can be assigned to a new DisplacementElement.

See Also

DisplacementElement Class
DisplacementElement Members


CanElementsBeDisplaced Method (View, ICollection(ElementId))

[image]

Revit 2024 API
DisplacementElement..::..CanElementsBeDisplaced Method (View, ICollection<(Of <(<'ElementId>)>)>)
DisplacementElement Class See Also Send Feedback
Indicates if elements can be assigned to a new DisplacementElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static bool CanElementsBeDisplaced(
    View view,
    ICollection<ElementId> elementIds
)
Visual Basic
Public Shared Function CanElementsBeDisplaced ( _
    view As View, _
    elementIds As ICollection(Of ElementId) _
) As Boolean
Visual C++
public:
static bool CanElementsBeDisplaced(
    View^ view,
    ICollection<ElementId^>^ elementIds
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view.
elementIds
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
The element ids.

Remarks

A necessary condition is that isAllowedAsDisplacedElement returns true for each individual element id. In addition, if isElementDisplaced must return the same value for all the specified element ids.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DisplacementElement Class
CanElementsBeDisplaced Overload


CanElementsBeDisplaced Method (View, ICollection(ElementId), ElementId)

[image]

Revit 2024 API
DisplacementElement..::..CanElementsBeDisplaced Method (View, ICollection<(Of <(<'ElementId>)>)>, ElementId%)
DisplacementElement Class See Also Send Feedback
Indicates if elements can be assigned to a new DisplacementElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static bool CanElementsBeDisplaced(
    View view,
    ICollection<ElementId> elementIds,
    out ElementId commonDisplacedElementId
)
Visual Basic
Public Shared Function CanElementsBeDisplaced ( _
    view As View, _
    elementIds As ICollection(Of ElementId), _
    <OutAttribute> ByRef commonDisplacedElementId As ElementId _
) As Boolean
Visual C++
public:
static bool CanElementsBeDisplaced(
    View^ view,
    ICollection<ElementId^>^ elementIds,
    [OutAttribute] ElementId^% commonDisplacedElementId
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view.
elementIds
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
The element ids.
commonDisplacedElementId
Type: Autodesk.Revit.DB..::..ElementId %
If this method returns true, then this is the element id of a DisplacementElement which lists all of elemIds among its displaced elements.

Return Value

Returns true if the specified element ids can be assigned to a new DisplacementElement.

Remarks

A necessary condition is that isAllowedAsDisplacedElement returns true for each individual element id. In addition, if isElementDisplaced must return the same value for all the specified element ids.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DisplacementElement Class
CanElementsBeDisplaced Overload


Create Method

[image]

Revit 2024 API
DisplacementElement..::..Create Method
DisplacementElement Class Example See Also Send Feedback
Creates a new DisplacementElement as a child of the specified parent DisplacementElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static DisplacementElement Create(
    Document document,
    ICollection<ElementId> elementsToDisplace,
    XYZ displacement,
    View ownerDBView,
    DisplacementElement parentDisplacementElement
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    elementsToDisplace As ICollection(Of ElementId), _
    displacement As XYZ, _
    ownerDBView As View, _
    parentDisplacementElement As DisplacementElement _
) As DisplacementElement
Visual C++
public:
static DisplacementElement^ Create(
    Document^ document,
    ICollection<ElementId^>^ elementsToDisplace,
    XYZ^ displacement,
    View^ ownerDBView,
    DisplacementElement^ parentDisplacementElement
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The Document
elementsToDisplace
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
The elements to be displaced.
displacement
Type: Autodesk.Revit.DB..::..XYZ
The translation to be applied to the graphics of the displaced elements.
ownerDBView
Type: Autodesk.Revit.DB..::..View
The 3D view which will own the DisplacementElement.
parentDisplacementElement
Type: Autodesk.Revit.DB..::..DisplacementElement
An existing DisplacementElement that will be the parent of the one being created. It must be owned by ownerDBView. The relative transform of new DisplacementElement will be concatenated with the absolute transform of the parent DisplacementElement. If the elements specified by displacedElemIds are already displaced by another DisplacementElement, then this must be that element.

Return Value

The id of the new DisplacementElement.

Examples

CopyC#
public static void CreateDisplacementAndPath(Document doc, View view)
{
    // Find roof
    FilteredElementCollector fec = new FilteredElementCollector(doc);
    fec.OfClass(typeof(RoofBase));
    RoofBase roof = fec.FirstElement() as RoofBase;

    // Get a geometric reference for the path
    Reference edgeRef = GetHorizontalEdgeReference(roof);

    using (Transaction t = new Transaction(doc, "CreateDisplacementAndPath"))
    {
        t.Start();
        // Create a new top level DisplacementElement
        DisplacementElement dispElem = DisplacementElement.Create(doc, new ElementId[] { roof.Id }, new XYZ(10, 0, 20), view, null);

        // Create the path associated to the element
        DisplacementPath.Create(doc, dispElem, edgeRef, 0.5);
        t.Commit();
    }
}

private static Reference GetHorizontalEdgeReference(Element elem)
{
    //Find target edge from lower face of roof
    Options options = new Options();
    options.ComputeReferences = true;

    GeometryElement geomElem = elem.get_Geometry(options);

    foreach (var geomObj in geomElem)
    {
        if (geomObj is Solid)
        {
            Solid solid = geomObj as Solid;
            var faces = solid.Faces;

            foreach (Face face in faces)
            {
                BoundingBoxUV box = face.GetBoundingBox();
                UV midpoint = (box.Min + box.Max) / 2.0;
                if (face.ComputeNormal(midpoint).Normalize().Z < -0.1) // Downward facing, this is good enough
                {
                    var edgeLoops = face.EdgeLoops;
                    foreach (EdgeArray edgeArray in edgeLoops)
                    {
                        foreach (Edge edge in edgeArray)
                        {
                            // horizontal?
                            if (Math.Abs(edge.AsCurve().ComputeDerivatives(0.0, true).BasisX.DotProduct(XYZ.BasisZ)) - 1 <= 0.00001)
                            {
                                return edge.Reference;
                            }
                        }
                    }
                }
            }
        }
    }

    return null;
}
CopyVB.NET
Public Shared Sub CreateDisplacementAndPath(doc As Document, view As View)
    ' Find roof
    Dim fec As New FilteredElementCollector(doc)
    fec.OfClass(GetType(RoofBase))
    Dim roof As RoofBase = TryCast(fec.FirstElement(), RoofBase)

    ' Get a geometric reference for the path
    Dim edgeRef As Reference = GetHorizontalEdgeReference(roof)

    Using t As New Transaction(doc, "CreateDisplacementAndPath")
        t.Start()
        ' Create a new top level DisplacementElement
        Dim dispElem As DisplacementElement = DisplacementElement.Create(doc, New ElementId() {roof.Id}, New XYZ(10, 0, 20), view, Nothing)

        ' Create the path associated to the element
        DisplacementPath.Create(doc, dispElem, edgeRef, 0.5)
        t.Commit()
    End Using
End Sub

Private Shared Function GetHorizontalEdgeReference(elem As Element) As Reference
    'Find target edge from lower face of roof
    Dim options As New Options()
    options.ComputeReferences = True

    Dim geomElem As GeometryElement = elem.Geometry(options)

    For Each geomObj As GeometryObject In geomElem
        If TypeOf geomObj Is Solid Then
            Dim solid As Solid = TryCast(geomObj, Solid)
            Dim faces = solid.Faces

            For Each face As Face In faces
                Dim box As BoundingBoxUV = face.GetBoundingBox()
                Dim midpoint As UV = (box.Min + box.Max) / 2.0
                If face.ComputeNormal(midpoint).Normalize().Z < -0.1 Then
                    ' Downward facing, this is good enough
                    Dim edgeLoops = face.EdgeLoops
                    For Each edgeArray As EdgeArray In edgeLoops
                        For Each edge As Edge In edgeArray
                            ' horizontal?
                            If Math.Abs(edge.AsCurve().ComputeDerivatives(0.0, True).BasisX.DotProduct(XYZ.BasisZ)) - 1 <= 0.00001 Then
                                Return edge.Reference
                            End If
                        Next
                    Next
                End If
            Next
        End If
    Next

    Return Nothing
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | #elementIds# contains no element ids. -or- ownerDBView is not a 3D view. -or- For each individual element in the set elementsToDisplace, isAllowedAsDisplacedElement must return true, and the elements must either not already be displaced in the specified view, or else they must all be displaced by the same displacement element in the view. -or- The DisplacementElement parentDisplacementElement in not owned by the view ownerDBView.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DisplacementElement Class


GetAbsoluteDisplacement Method

[image]

Revit 2024 API
DisplacementElement..::..GetAbsoluteDisplacement Method
DisplacementElement Class See Also Send Feedback
The absolute displacement applied to the displaced elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public XYZ GetAbsoluteDisplacement()
Visual Basic
Public Function GetAbsoluteDisplacement As XYZ
Visual C++
public:
XYZ^ GetAbsoluteDisplacement()

Return Value

The absolute displacement.

Remarks

The value is the relative translation of this DisplacementElement plus the relative displacements of all of its ancestor DisplacementElements.

See Also

DisplacementElement Class


GetAdditionalElementsToDisplace Method

[image]

Revit 2024 API
DisplacementElement..::..GetAdditionalElementsToDisplace Method
DisplacementElement Class See Also Send Feedback
Identify a set of elements that potentially should be displaced along with a given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static ICollection<ElementId> GetAdditionalElementsToDisplace(
    Document document,
    View view,
    ElementId idToDisplace
)
Visual Basic
Public Shared Function GetAdditionalElementsToDisplace ( _
    document As Document, _
    view As View, _
    idToDisplace As ElementId _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetAdditionalElementsToDisplace(
    Document^ document,
    View^ view,
    ElementId^ idToDisplace
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
the document
view
Type: Autodesk.Revit.DB..::..View
the view
idToDisplace
Type: Autodesk.Revit.DB..::..ElementId
element id of element to displace

Remarks

For example, when a wall is displaced, any inserts or hosted elements should also be displaced.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DisplacementElement Class


GetDisplacedElementIds Method

[image] [image]

Revit 2024 API
DisplacementElement..::..GetDisplacedElementIds Method
DisplacementElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDisplacedElementIds()()()() | The ids of the elements affected by this DisplacementElement.
 | GetDisplacedElementIds(View) | Returns the element ids of all displaced elements in the specified view.

See Also

DisplacementElement Class
DisplacementElement Members


GetDisplacedElementIds Method

[image]

Revit 2024 API
DisplacementElement..::..GetDisplacedElementIds Method
DisplacementElement Class See Also Send Feedback
The ids of the elements affected by this DisplacementElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ICollection<ElementId> GetDisplacedElementIds()
Visual Basic
Public Function GetDisplacedElementIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetDisplacedElementIds()

Return Value

The element ids.

See Also

DisplacementElement Class
GetDisplacedElementIds Overload


GetDisplacedElementIdsFromAllChildren Method

[image]

Revit 2024 API
DisplacementElement..::..GetDisplacedElementIdsFromAllChildren Method
DisplacementElement Class See Also Send Feedback
The element ids of elements displaced by this DisplacementElement and any DisplacementElement which declare this one as parent.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ICollection<ElementId> GetDisplacedElementIdsFromAllChildren()
Visual Basic
Public Function GetDisplacedElementIdsFromAllChildren As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetDisplacedElementIdsFromAllChildren()

Return Value

The element ids.

See Also

DisplacementElement Class


GetDisplacementElementId Method

[image]

Revit 2024 API
DisplacementElement..::..GetDisplacementElementId Method
DisplacementElement Class See Also Send Feedback
The element id of the DisplacementElement that includes the specified element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static ElementId GetDisplacementElementId(
    View view,
    ElementId id
)
Visual Basic
Public Shared Function GetDisplacementElementId ( _
    view As View, _
    id As ElementId _
) As ElementId
Visual C++
public:
static ElementId^ GetDisplacementElementId(
    View^ view,
    ElementId^ id
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view.
id
Type: Autodesk.Revit.DB..::..ElementId
The element id.

Return Value

The element id of DisplacementElement that includes the specified element id.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DisplacementElement Class


GetDisplacementElementIds Method

[image]

Revit 2024 API
DisplacementElement..::..GetDisplacementElementIds Method
DisplacementElement Class See Also Send Feedback
The element ids of all DisplacementElements owned by the specified view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static ICollection<ElementId> GetDisplacementElementIds(
    View view
)
Visual Basic
Public Shared Function GetDisplacementElementIds ( _
    view As View _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetDisplacementElementIds(
    View^ view
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view.

Return Value

The element ids.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DisplacementElement Class


GetRelativeDisplacement Method

[image]

Revit 2024 API
DisplacementElement..::..GetRelativeDisplacement Method
DisplacementElement Class See Also Send Feedback
The relative displacement applied to the displaced elements by this DisplacementElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public XYZ GetRelativeDisplacement()
Visual Basic
Public Function GetRelativeDisplacement As XYZ
Visual C++
public:
XYZ^ GetRelativeDisplacement()

Return Value

The relative displacement.

See Also

DisplacementElement Class


IsAllowedAsDisplacedElement Method

[image]

Revit 2024 API
DisplacementElement..::..IsAllowedAsDisplacedElement Method
DisplacementElement Class See Also Send Feedback
Indicates if the specified element is allowed to be displaced.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static bool IsAllowedAsDisplacedElement(
    Element element
)
Visual Basic
Public Shared Function IsAllowedAsDisplacedElement ( _
    element As Element _
) As Boolean
Visual C++
public:
static bool IsAllowedAsDisplacedElement(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
Any element.

Return Value

Returns true if the element is eligible to be assigned to a DisplacementElement.

Remarks

Exclusions include view specific elements as well as certain categories of elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DisplacementElement Class


IsElementDisplacedInView Method

[image]

Revit 2024 API
DisplacementElement..::..IsElementDisplacedInView Method
DisplacementElement Class See Also Send Feedback
Indicates if the specified element displaced in the specified View.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static bool IsElementDisplacedInView(
    View view,
    ElementId id
)
Visual Basic
Public Shared Function IsElementDisplacedInView ( _
    view As View, _
    id As ElementId _
) As Boolean
Visual C++
public:
static bool IsElementDisplacedInView(
    View^ view,
    ElementId^ id
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view.
id
Type: Autodesk.Revit.DB..::..ElementId
The element id.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DisplacementElement Class


RemoveDisplacedElement Method

[image]

Revit 2024 API
DisplacementElement..::..RemoveDisplacedElement Method
DisplacementElement Class See Also Send Feedback
Remove a displaced element from this DisplacementElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void RemoveDisplacedElement(
    Element ElemToRemove
)
Visual Basic
Public Sub RemoveDisplacedElement ( _
    ElemToRemove As Element _
)
Visual C++
public:
void RemoveDisplacedElement(
    Element^ ElemToRemove
)

Parameters

ElemToRemove
Type: Autodesk.Revit.DB..::..Element
The element to remove.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DisplacementElement Class


ResetDisplacedElements Method

[image]

Revit 2024 API
DisplacementElement..::..ResetDisplacedElements Method
DisplacementElement Class See Also Send Feedback
Sets the translation of the DisplacementElement to (0, 0, 0). The DisplacementElement continues to exist, but its elements are displayed in their actual location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void ResetDisplacedElements()
Visual Basic
Public Sub ResetDisplacedElements
Visual C++
public:
void ResetDisplacedElements()

See Also

DisplacementElement Class


SetRelativeDisplacement Method

[image]

Revit 2024 API
DisplacementElement..::..SetRelativeDisplacement Method
DisplacementElement Class See Also Send Feedback
Sets the relative displacement applied to the displaced elements by this DisplacementElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void SetRelativeDisplacement(
    XYZ displacement
)
Visual Basic
Public Sub SetRelativeDisplacement ( _
    displacement As XYZ _
)
Visual C++
public:
void SetRelativeDisplacement(
    XYZ^ displacement
)

Parameters

displacement
Type: Autodesk.Revit.DB..::..XYZ
The relative displacement.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DisplacementElement Class


DisplacementElement Properties

[image] [image]

Revit 2024 API
DisplacementElement Properties
DisplacementElement Class See Also Send Feedback

The DisplacementElement type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParentId | The element id of the parent DisplacementElement. This DisplacementElement's relative transform will be concatenated with the absolute transform of its parent.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DisplacementElement Class


Parameter Property

[image] [image]

Revit 2024 API
DisplacementElement..::..Parameter Property
DisplacementElement Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

DisplacementElement Class
DisplacementElement Members


ParentId Property

[image]

Revit 2024 API
DisplacementElement..::..ParentId Property
DisplacementElement Class See Also Send Feedback
The element id of the parent DisplacementElement. This DisplacementElement's relative transform will be concatenated with the absolute transform of its parent.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ElementId ParentId { get; }
Visual Basic
Public ReadOnly Property ParentId As ElementId
    Get
Visual C++
public:
property ElementId^ ParentId {
    ElementId^ get ();
}

See Also

DisplacementElement Class


DisplacementPath Class

[image]

Revit 2024 API
DisplacementPath Class
Members See Also Send Feedback
A view-specific annotation related to a DisplacementElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class DisplacementPath : Element
Visual Basic
Public Class DisplacementPath _
    Inherits Element
Visual C++
public ref class DisplacementPath : public Element

Remarks

The DisplacementPath is anchored to the DisplacementElement by a reference to a point on an edge of a source element of the DisplacementElement. It is represented by a single line, or a series of jogged lines, originating at the specified point on the displaced element.

The associated DisplacementElement may have a parent DisplacementElement and this parent may have its own parent DisplacementElement, producing a series of ancestors. The terminal point may be the point's original (un-displaced) location, or the corresponding point on any of the intermediate displaced locations corresponding to these ancestor DisplacementElements.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..DisplacementPath

See Also

DisplacementPath Members


DisplacementPath Members

[image] [image]

Revit 2024 API
DisplacementPath Members
DisplacementPath Class Methods Properties See Also Send Feedback

The DisplacementPath type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create | Creates a new DisplacementPath referencing a DisplacementElement and edge or curve and adds it to the document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
 | IsValidParam | Is the specified value a valid edge or curve parameter.
 | IsValidReference | Does the specified pick represent an edge or a curve belonging to one of the displaced elements.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetAnchorPoint | Sets the reference that determines the origin of this DisplacementPath.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AncestorIdx | Specifies the end point of the path.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PathStyle | Specifies the style of the path.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DisplacementPath Class


DisplacementPath Methods

[image] [image]

Revit 2024 API
DisplacementPath Methods
DisplacementPath Class See Also Send Feedback

The DisplacementPath type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create | Creates a new DisplacementPath referencing a DisplacementElement and edge or curve and adds it to the document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
 | IsValidParam | Is the specified value a valid edge or curve parameter.
 | IsValidReference | Does the specified pick represent an edge or a curve belonging to one of the displaced elements.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetAnchorPoint | Sets the reference that determines the origin of this DisplacementPath.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DisplacementPath Class


Create Method

[image]

Revit 2024 API
DisplacementPath..::..Create Method
DisplacementPath Class See Also Send Feedback
Creates a new DisplacementPath referencing a DisplacementElement and edge or curve and adds it to the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static ElementId Create(
    Document aDoc,
    DisplacementElement displacementElement,
    Reference reference,
    double param
)
Visual Basic
Public Shared Function Create ( _
    aDoc As Document, _
    displacementElement As DisplacementElement, _
    reference As Reference, _
    param As Double _
) As ElementId
Visual C++
public:
static ElementId^ Create(
    Document^ aDoc,
    DisplacementElement^ displacementElement,
    Reference^ reference,
    double param
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
The document.
displacementElement
Type: Autodesk.Revit.DB..::..DisplacementElement
Element id of a DisplacementElement
reference
Type: Autodesk.Revit.DB..::..Reference
A reference that refers to an edge or curve of one of the elements displaced by the displacementElement.
param
Type: System..::..Double
A value in the range [0,1]. It will be interpreted as a parameter for the specified edge.

Return Value

The element id of the newly created DisplacementPath.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The value param should lie in the range [0,1]. -or- reference does not represent an edge or curve belonging to an element displaced by displacementElement.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DisplacementPath Class


IsValidParam Method

[image]

Revit 2024 API
DisplacementPath..::..IsValidParam Method
DisplacementPath Class See Also Send Feedback
Is the specified value a valid edge or curve parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static bool IsValidParam(
    double param
)
Visual Basic
Public Shared Function IsValidParam ( _
    param As Double _
) As Boolean
Visual C++
public:
static bool IsValidParam(
    double param
)

Parameters

param
Type: System..::..Double
proposed edge parameter.

See Also

DisplacementPath Class


SetAnchorPoint Method

[image]

Revit 2024 API
DisplacementPath..::..SetAnchorPoint Method
DisplacementPath Class See Also Send Feedback
Sets the reference that determines the origin of this DisplacementPath.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void SetAnchorPoint(
    DisplacementElement displacementElement,
    Reference reference,
    double param
)
Visual Basic
Public Sub SetAnchorPoint ( _
    displacementElement As DisplacementElement, _
    reference As Reference, _
    param As Double _
)
Visual C++
public:
void SetAnchorPoint(
    DisplacementElement^ displacementElement,
    Reference^ reference,
    double param
)

Parameters

displacementElement
Type: Autodesk.Revit.DB..::..DisplacementElement
The element id of a DisplacementElement.
reference
Type: Autodesk.Revit.DB..::..Reference
A reference of an edge or a curve in the GRep of the element corresponding to elemId.
param
Type: System..::..Double
An parameter used to specify a point on the edge.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The value param should lie in the range [0,1]. -or- reference does not represent an edge or curve belonging to an element displaced by displacementElement.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DisplacementPath Class


DisplacementPath Properties

[image] [image]

Revit 2024 API
DisplacementPath Properties
DisplacementPath Class See Also Send Feedback

The DisplacementPath type exposes the following members.

Properties

 | Name | Description
Public property | AncestorIdx | Specifies the end point of the path.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PathStyle | Specifies the style of the path.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DisplacementPath Class


Parameter Property

[image] [image]

Revit 2024 API
DisplacementPath..::..Parameter Property
DisplacementPath Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

DisplacementPath Class
DisplacementPath Members


PathStyle Property

[image]

Revit 2024 API
DisplacementPath..::..PathStyle Property
DisplacementPath Class See Also Send Feedback
Specifies the style of the path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public DisplacementPathStyle PathStyle { get; set; }
Visual Basic
Public Property PathStyle As DisplacementPathStyle
    Get
    Set
Visual C++
public:
property DisplacementPathStyle PathStyle {
    DisplacementPathStyle get ();
    void set (DisplacementPathStyle value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

DisplacementPath Class


DisplacementPathStyle Enumeration

[image]

Revit 2024 API
DisplacementPathStyle Enumeration
See Also Send Feedback
Used to control the graphical representation of a DisplacementPath element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public enum DisplacementPathStyle
Visual Basic
Public Enumeration DisplacementPathStyle
Visual C++
public enum class DisplacementPathStyle

Members

Member name | Description
Straight | A single straight line is used to represent each stage of the displacement.
Jogged | A jogged path consisting of three straight lines is used to represent each stage of the displacement.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


DisplayStyle Enumeration

[image]

Revit 2024 API
DisplayStyle Enumeration
See Also Send Feedback
Display type of the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public enum DisplayStyle
Visual Basic
Public Enumeration DisplayStyle
Visual C++
public enum class DisplayStyle

Members

Member name | Description
Undefined | View does not use Render Type
Wireframe | Wireframe
HLR | Hidden Line Removal
Shading | Shading
ShadingWithEdges | Shading With Edges
Rendering | Rendering
Realistic | Realistic
FlatColors | Flat Colors
RealisticWithEdges | Realistic With Edges
Textures | Textures

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


DisplayUnit Enumeration

[image]

Revit 2024 API
DisplayUnit Enumeration
See Also Send Feedback
Describes the type of Revit display unit, metric or imperial.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum DisplayUnit
Visual Basic
Public Enumeration DisplayUnit
Visual C++
public enum class DisplayUnit

Members

Member name | Description
METRIC |
IMPERIAL |

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


DistanceMeasuredFrom Enumeration

[image]

Revit 2024 API
DistanceMeasuredFrom Enumeration
See Also Send Feedback
Indicates if the distance is measured from the top or bottom of the wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public enum DistanceMeasuredFrom
Visual Basic
Public Enumeration DistanceMeasuredFrom
Visual C++
public enum class DistanceMeasuredFrom

Members

Member name | Description
Base | From bottom.
Top | From top.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


DistributionOfNormals Enumeration

[image]

Revit 2024 API
DistributionOfNormals Enumeration
See Also Send Feedback
An enumeration containing the choices of how normal vectors are assigned and distributed along the surface of a polymesh. Planar faces would typically have only normal vector associated, but curved faces can have a different normal either for each facet (triangle) or each point of the tessellated polymesh.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014
Since: 2014

Syntax

C#
public enum DistributionOfNormals
Visual Basic
Public Enumeration DistributionOfNormals
Visual C++
public enum class DistributionOfNormals

Members

Member name | Description
AtEachPoint | One normal vector is assigned to each vertex of the polymesh.
OnePerFace | There is only one common normal vector assigned to the face/polymesh.
OnEachFacet | There is one normal vector per each facet of the polymesh.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


DividedPath Class

[image]

Revit 2024 API
DividedPath Class
Members See Also Send Feedback
An element that consists of a set of points distributed along a path which consists of a connected set of curves and edges.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public class DividedPath : Element
Visual Basic
Public Class DividedPath _
    Inherits Element
Visual C++
public ref class DividedPath : public Element

Remarks

The points can be the result of a uniform distribution along the path. The type of the distribution is determined by a selected 'layout'. The distance between the layout points depends on the path, the layout, and layout specific settings. In addition, points can also be the result of intersecting the path with other elements.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..DividedPath

See Also

DividedPath Members


DividedPath Members

[image] [image]

Revit 2024 API
DividedPath Members
DividedPath Class Methods Properties See Also Send Feedback

The DividedPath type exposes the following members.

Methods

 | Name | Description
 | AreCurveReferencesConnected | This checks if the references represent a connected set of curves as required by the divided path.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create(Document, IList<(Of <<'(Reference>)>>)) | Creates a new instance of a divided path with a default layout.
 | Create(Document, IList<(Of <<'(Reference>)>>), ICollection<(Of <<'(ElementId>)>>)) | Creates a new instance of a divided path whose points are determined by the intersecting elements.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | Flip | Toggle the flipped value
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIntersectingElements | Get the elements whose intersection with path produces points.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
 | IsCurveReferenceValid | This returns true if the reference represents a curve or edge that can be used to create a divided path.
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
 | IsIntersectorValidForCreation | This returns true if the intersector is an element that can be used to intersect with a newly created divided path.
Public method | IsIntersectorValidForDividedPath | This returns true if the intersector is an element that can be used to intersect with the divided path.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidBeginningIndent | Checks that the indent value does not cause the beginningIndent and endIndent to overlop
Public method | IsValidEndIndent | Checks that the indent value does not cause the beginningIndent and endIndent to overlop
 | IsValidFixedNumberOfPoints | Identifies if the indicated number of points is valid for assignment to a DividedPath with a layout type 'FixedNumber'.
Public method | IsValidMeasurementType | Checks that the measurement type enumeration value is valid
Public method | IsValidSpacingRuleJustification | Checks that the justification enumeration value is valid
Public method | IsValidSpacingRuleLayout | Checks that the spacing rule layout enumeration value is valid
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
 | SeparateReferencesIntoConnectedReferences | This function separates the input curve references into groups of connected curve references. Each group of connected curve references can be used to create a divided path.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetIntersectingElements | Set the elements whose intersection with path produces points.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BeginningIndent | The beginningIndent is an offset distance from the beginning of the first curve that determines the beginning of the range over which the layout is applied. The measurement type determines how the distance is measured.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DisplayNodeNumbers | Controls whether the node numbers are shown when the divided path is selected
Public property | DisplayNodes | Controls whether the points of the divided path are visible
Public property | DisplayReferenceCurves | Controls whether the curves in the path are visible
Public property | Distance | The distance between points that are distributed along the path according to the selected layout. When the layout is set to 'FixedDistance' this value can be set to desired distance. The measurement type determines how the distance is measured.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EndIndent | The endIndent is an offset distance from the end of the last curve that determines the end of the range over which the layout is applied. The measurement type determines how the distance is measured.
Public property | FixedNumberOfPoints | The number of points used when the layout is set to 'FixedNumber'.
Public property | Flipped | If the divided path is flipped the nodes are numbered in the reverse order. It also switches the ends from which beginningIndent and endIndent are measured from.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsClosedLoop | Whether or not the path forms a closed loop.
Public property | IsCyclical | True if the first and last point coincide False otherwise.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MaximumDistance | The maximum distance is used when the layout is set to 'MaximumSpacing'. When that layout rule is used the distance between points will not exceed this value. The measurement type determines how the distance is measured.
Public property | MeasurementType | The measurement type determines how distances are calculated. Either along a straight line between two points ('ChordLength') or along the segment of the path that connects them. ('SegmentLength').
Public property | MinimumDistance | The minimum distance is used when the layout is set to 'MinimumSpacing'. When that layout rule is used the distance between points will not fall below this value. The measurement type determines how the distance is measured.
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | NumberOfPoints | The total number of points of the divided surface. This combines the layout points and the intersection points.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SpacingRuleJustification | When the layout is set to 'FixedDistance' the points may not cover the entire range of the path. The justification determines whether the points are centered on the range, or shifted towards the start or end of the range.
Public property | SpacingRuleLayout | The layout determines how points are distributed along the path.
Public property | TotalPathLength | The sum of the curve lengths.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DividedPath Class


DividedPath Methods

[image] [image]

Revit 2024 API
DividedPath Methods
DividedPath Class See Also Send Feedback

The DividedPath type exposes the following members.

Methods

 | Name | Description
 | AreCurveReferencesConnected | This checks if the references represent a connected set of curves as required by the divided path.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create(Document, IList<(Of <<'(Reference>)>>)) | Creates a new instance of a divided path with a default layout.
 | Create(Document, IList<(Of <<'(Reference>)>>), ICollection<(Of <<'(ElementId>)>>)) | Creates a new instance of a divided path whose points are determined by the intersecting elements.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | Flip | Toggle the flipped value
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIntersectingElements | Get the elements whose intersection with path produces points.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
 | IsCurveReferenceValid | This returns true if the reference represents a curve or edge that can be used to create a divided path.
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
 | IsIntersectorValidForCreation | This returns true if the intersector is an element that can be used to intersect with a newly created divided path.
Public method | IsIntersectorValidForDividedPath | This returns true if the intersector is an element that can be used to intersect with the divided path.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidBeginningIndent | Checks that the indent value does not cause the beginningIndent and endIndent to overlop
Public method | IsValidEndIndent | Checks that the indent value does not cause the beginningIndent and endIndent to overlop
 | IsValidFixedNumberOfPoints | Identifies if the indicated number of points is valid for assignment to a DividedPath with a layout type 'FixedNumber'.
Public method | IsValidMeasurementType | Checks that the measurement type enumeration value is valid
Public method | IsValidSpacingRuleJustification | Checks that the justification enumeration value is valid
Public method | IsValidSpacingRuleLayout | Checks that the spacing rule layout enumeration value is valid
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
 | SeparateReferencesIntoConnectedReferences | This function separates the input curve references into groups of connected curve references. Each group of connected curve references can be used to create a divided path.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetIntersectingElements | Set the elements whose intersection with path produces points.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DividedPath Class


AreCurveReferencesConnected Method

[image]

Revit 2024 API
DividedPath..::..AreCurveReferencesConnected Method
DividedPath Class See Also Send Feedback
This checks if the references represent a connected set of curves as required by the divided path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static bool AreCurveReferencesConnected(
    Document document,
    IList<Reference> curveReferences
)
Visual Basic
Public Shared Function AreCurveReferencesConnected ( _
    document As Document, _
    curveReferences As IList(Of Reference) _
) As Boolean
Visual C++
public:
static bool AreCurveReferencesConnected(
    Document^ document,
    IList<Reference^>^ curveReferences
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
curveReferences
Type: System.Collections.Generic..::..IList<(Of <(<' Reference >)>)>
The references.

Return Value

True if the arguments passed the checks, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DividedPath Class


Create Method

[image] [image]

Revit 2024 API
DividedPath..::..Create Method
DividedPath Class See Also Send Feedback

Overload List

Name | Description
Create(Document, IList<(Of <<'(Reference>)>>)) | Creates a new instance of a divided path with a default layout.
Create(Document, IList<(Of <<'(Reference>)>>), ICollection<(Of <<'(ElementId>)>>)) | Creates a new instance of a divided path whose points are determined by the intersecting elements.

See Also

DividedPath Class
DividedPath Members


Create Method (Document, IList(Reference))

[image]

Revit 2024 API
DividedPath..::..Create Method (Document, IList<(Of <(<'Reference>)>)>)
DividedPath Class See Also Send Feedback
Creates a new instance of a divided path with a default layout.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static DividedPath Create(
    Document document,
    IList<Reference> curveReferences
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    curveReferences As IList(Of Reference) _
) As DividedPath
Visual C++
public:
static DividedPath^ Create(
    Document^ document,
    IList<Reference^>^ curveReferences
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
curveReferences
Type: System.Collections.Generic..::..IList<(Of <(<' Reference >)>)>
References that represent a connected set of curves or edges.

Return Value

The newly created divided path.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The document does not allow creation of a divided path. -or- Not all curve references in curveReferences represent a curve or an edge -or- The references in curveReferences are not connected.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

DividedPath Class
Create Overload


Create Method (Document, IList(Reference), ICollection(ElementId))

[image]

Revit 2024 API
DividedPath..::..Create Method (Document, IList<(Of <(<'Reference>)>)>, ICollection<(Of <(<'ElementId>)>)>)
DividedPath Class See Also Send Feedback
Creates a new instance of a divided path whose points are determined by the intersecting elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static DividedPath Create(
    Document document,
    IList<Reference> curveReferences,
    ICollection<ElementId> intersectors
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    curveReferences As IList(Of Reference), _
    intersectors As ICollection(Of ElementId) _
) As DividedPath
Visual C++
public:
static DividedPath^ Create(
    Document^ document,
    IList<Reference^>^ curveReferences,
    ICollection<ElementId^>^ intersectors
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
curveReferences
Type: System.Collections.Generic..::..IList<(Of <(<' Reference >)>)>
References that represent a connected set of curves or edges.
intersectors
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
Elements whose intersection with the curve references result in additional divisions.

Return Value

The newly created divided path.

Remarks

Intersectors can be curve elements, datum planes, or other divided paths.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The document does not allow creation of a divided path. -or- Not all curve references in curveReferences represent a curve or an edge -or- The references in curveReferences are not connected. -or- Not all intersecting elements in intersectors are valid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

DividedPath Class
Create Overload


Flip Method

[image]

Revit 2024 API
DividedPath..::..Flip Method
DividedPath Class See Also Send Feedback
Toggle the flipped value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void Flip()
Visual Basic
Public Sub Flip
Visual C++
public:
void Flip()

See Also

DividedPath Class


IsCurveReferenceValid Method

[image]

Revit 2024 API
DividedPath..::..IsCurveReferenceValid Method
DividedPath Class See Also Send Feedback
This returns true if the reference represents a curve or edge that can be used to create a divided path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static bool IsCurveReferenceValid(
    Document document,
    Reference curveReference
)
Visual Basic
Public Shared Function IsCurveReferenceValid ( _
    document As Document, _
    curveReference As Reference _
) As Boolean
Visual C++
public:
static bool IsCurveReferenceValid(
    Document^ document,
    Reference^ curveReference
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
curveReference
Type: Autodesk.Revit.DB..::..Reference
The reference.

Return Value

True if the reference can be used to create a divided path, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DividedPath Class


IsIntersectorValidForDividedPath Method

[image]

Revit 2024 API
DividedPath..::..IsIntersectorValidForDividedPath Method
DividedPath Class See Also Send Feedback
This returns true if the intersector is an element that can be used to intersect with the divided path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool IsIntersectorValidForDividedPath(
    ElementId intersector
)
Visual Basic
Public Function IsIntersectorValidForDividedPath ( _
    intersector As ElementId _
) As Boolean
Visual C++
public:
bool IsIntersectorValidForDividedPath(
    ElementId^ intersector
)

Parameters

intersector
Type: Autodesk.Revit.DB..::..ElementId
The intersector.

Return Value

True if the reference can be used to create a divided path, false otherwise.

Remarks

Intersectors can be curve elements, datum planes, or other divided paths. Note that divided paths that have this divided path as an intersector (either directly, or recursively) are not valid. Also, if the nesting of divided path intersectors that have intersectors is more than 5 levels deep the divided path intersector is considered invalid as well.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DividedPath Class


IsValidBeginningIndent Method

[image]

Revit 2024 API
DividedPath..::..IsValidBeginningIndent Method
DividedPath Class See Also Send Feedback
Checks that the indent value does not cause the beginningIndent and endIndent to overlop

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool IsValidBeginningIndent(
    double beginningIndent
)
Visual Basic
Public Function IsValidBeginningIndent ( _
    beginningIndent As Double _
) As Boolean
Visual C++
public:
bool IsValidBeginningIndent(
    double beginningIndent
)

Parameters

beginningIndent
Type: System..::..Double

See Also

DividedPath Class


IsValidEndIndent Method

[image]

Revit 2024 API
DividedPath..::..IsValidEndIndent Method
DividedPath Class See Also Send Feedback
Checks that the indent value does not cause the beginningIndent and endIndent to overlop

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool IsValidEndIndent(
    double endIndent
)
Visual Basic
Public Function IsValidEndIndent ( _
    endIndent As Double _
) As Boolean
Visual C++
public:
bool IsValidEndIndent(
    double endIndent
)

Parameters

endIndent
Type: System..::..Double

See Also

DividedPath Class


IsValidFixedNumberOfPoints Method

[image]

Revit 2024 API
DividedPath..::..IsValidFixedNumberOfPoints Method
DividedPath Class See Also Send Feedback
Identifies if the indicated number of points is valid for assignment to a DividedPath with a layout type 'FixedNumber'.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static bool IsValidFixedNumberOfPoints(
    int fixedNumberOfPoints
)
Visual Basic
Public Shared Function IsValidFixedNumberOfPoints ( _
    fixedNumberOfPoints As Integer _
) As Boolean
Visual C++
public:
static bool IsValidFixedNumberOfPoints(
    int fixedNumberOfPoints
)

Parameters

fixedNumberOfPoints
Type: System..::..Int32

See Also

DividedPath Class


IsValidMeasurementType Method

[image]

Revit 2024 API
DividedPath..::..IsValidMeasurementType Method
DividedPath Class See Also Send Feedback
Checks that the measurement type enumeration value is valid

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool IsValidMeasurementType(
    DividedPathMeasurementType measurementType
)
Visual Basic
Public Function IsValidMeasurementType ( _
    measurementType As DividedPathMeasurementType _
) As Boolean
Visual C++
public:
bool IsValidMeasurementType(
    DividedPathMeasurementType measurementType
)

Parameters

measurementType
Type: Autodesk.Revit.DB..::..DividedPathMeasurementType

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

DividedPath Class


IsValidSpacingRuleJustification Method

[image]

Revit 2024 API
DividedPath..::..IsValidSpacingRuleJustification Method
DividedPath Class See Also Send Feedback
Checks that the justification enumeration value is valid

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool IsValidSpacingRuleJustification(
    SpacingRuleJustification justification
)
Visual Basic
Public Function IsValidSpacingRuleJustification ( _
    justification As SpacingRuleJustification _
) As Boolean
Visual C++
public:
bool IsValidSpacingRuleJustification(
    SpacingRuleJustification justification
)

Parameters

justification
Type: Autodesk.Revit.DB..::..SpacingRuleJustification

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

DividedPath Class


IsValidSpacingRuleLayout Method

[image]

Revit 2024 API
DividedPath..::..IsValidSpacingRuleLayout Method
DividedPath Class See Also Send Feedback
Checks that the spacing rule layout enumeration value is valid

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool IsValidSpacingRuleLayout(
    SpacingRuleLayout layout
)
Visual Basic
Public Function IsValidSpacingRuleLayout ( _
    layout As SpacingRuleLayout _
) As Boolean
Visual C++
public:
bool IsValidSpacingRuleLayout(
    SpacingRuleLayout layout
)

Parameters

layout
Type: Autodesk.Revit.DB..::..SpacingRuleLayout

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

DividedPath Class


SetIntersectingElements Method

[image]

Revit 2024 API
DividedPath..::..SetIntersectingElements Method
DividedPath Class See Also Send Feedback
Set the elements whose intersection with path produces points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void SetIntersectingElements(
    ICollection<ElementId> intersectors
)
Visual Basic
Public Sub SetIntersectingElements ( _
    intersectors As ICollection(Of ElementId) _
)
Visual C++
public:
void SetIntersectingElements(
    ICollection<ElementId^>^ intersectors
)

Parameters

intersectors
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Not all intersecting elements in intersectors are valid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DividedPath Class


DividedPath Properties

[image] [image]

Revit 2024 API
DividedPath Properties
DividedPath Class See Also Send Feedback

The DividedPath type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BeginningIndent | The beginningIndent is an offset distance from the beginning of the first curve that determines the beginning of the range over which the layout is applied. The measurement type determines how the distance is measured.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DisplayNodeNumbers | Controls whether the node numbers are shown when the divided path is selected
Public property | DisplayNodes | Controls whether the points of the divided path are visible
Public property | DisplayReferenceCurves | Controls whether the curves in the path are visible
Public property | Distance | The distance between points that are distributed along the path according to the selected layout. When the layout is set to 'FixedDistance' this value can be set to desired distance. The measurement type determines how the distance is measured.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EndIndent | The endIndent is an offset distance from the end of the last curve that determines the end of the range over which the layout is applied. The measurement type determines how the distance is measured.
Public property | FixedNumberOfPoints | The number of points used when the layout is set to 'FixedNumber'.
Public property | Flipped | If the divided path is flipped the nodes are numbered in the reverse order. It also switches the ends from which beginningIndent and endIndent are measured from.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsClosedLoop | Whether or not the path forms a closed loop.
Public property | IsCyclical | True if the first and last point coincide False otherwise.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MaximumDistance | The maximum distance is used when the layout is set to 'MaximumSpacing'. When that layout rule is used the distance between points will not exceed this value. The measurement type determines how the distance is measured.
Public property | MeasurementType | The measurement type determines how distances are calculated. Either along a straight line between two points ('ChordLength') or along the segment of the path that connects them. ('SegmentLength').
Public property | MinimumDistance | The minimum distance is used when the layout is set to 'MinimumSpacing'. When that layout rule is used the distance between points will not fall below this value. The measurement type determines how the distance is measured.
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | NumberOfPoints | The total number of points of the divided surface. This combines the layout points and the intersection points.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SpacingRuleJustification | When the layout is set to 'FixedDistance' the points may not cover the entire range of the path. The justification determines whether the points are centered on the range, or shifted towards the start or end of the range.
Public property | SpacingRuleLayout | The layout determines how points are distributed along the path.
Public property | TotalPathLength | The sum of the curve lengths.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DividedPath Class


BeginningIndent Property

[image]

Revit 2024 API
DividedPath..::..BeginningIndent Property
DividedPath Class See Also Send Feedback
The beginningIndent is an offset distance from the beginning of the first curve that determines the beginning of the range over which the layout is applied. The measurement type determines how the distance is measured.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double BeginningIndent { get; set; }
Visual Basic
Public Property BeginningIndent As Double
    Get
    Set
Visual C++
public:
property double BeginningIndent {
    double get ();
    void set (double value);
}

Remarks

BeginningIndent and endIndent are not allowed to overlap

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for beginningIndent must be between 0 and 30000 feet. -or- When setting this property: beginningIndent overlaps with endIndent

See Also

DividedPath Class


DisplayNodes Property

[image]

Revit 2024 API
DividedPath..::..DisplayNodes Property
DividedPath Class See Also Send Feedback
Controls whether the points of the divided path are visible

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool DisplayNodes { get; set; }
Visual Basic
Public Property DisplayNodes As Boolean
    Get
    Set
Visual C++
public:
property bool DisplayNodes {
    bool get ();
    void set (bool value);
}

Remarks

If true the nodes of the divided path are visible. If false the nodes are hidden.

See Also

DividedPath Class


DisplayReferenceCurves Property

[image]

Revit 2024 API
DividedPath..::..DisplayReferenceCurves Property
DividedPath Class See Also Send Feedback
Controls whether the curves in the path are visible

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool DisplayReferenceCurves { get; set; }
Visual Basic
Public Property DisplayReferenceCurves As Boolean
    Get
    Set
Visual C++
public:
property bool DisplayReferenceCurves {
    bool get ();
    void set (bool value);
}

Remarks

If true the references that represent the curves will not be hidden. If false the references that represent the curves may be hidden Only references that are curve elements can be hidden If multiple divided paths reference a curve element then the curve element is not hidden unless all divided paths request that it be hidden.

See Also

DividedPath Class


Distance Property

[image]

Revit 2024 API
DividedPath..::..Distance Property
DividedPath Class See Also Send Feedback
The distance between points that are distributed along the path according to the selected layout. When the layout is set to 'FixedDistance' this value can be set to desired distance. The measurement type determines how the distance is measured.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double Distance { get; set; }
Visual Basic
Public Property Distance As Double
    Get
    Set
Visual C++
public:
property double Distance {
    double get ();
    void set (double value);
}

Remarks

This does not take into account points obtained by intersections with other elements. When the layout is set to 'None' the distance is the value that would be used by the 'FixedDistance' layout.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The distance is too small.
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The distance can only be set when the layout of this DividedPath is set to 'FixedDistance' or 'None'.

See Also

DividedPath Class


EndIndent Property

[image]

Revit 2024 API
DividedPath..::..EndIndent Property
DividedPath Class See Also Send Feedback
The endIndent is an offset distance from the end of the last curve that determines the end of the range over which the layout is applied. The measurement type determines how the distance is measured.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double EndIndent { get; set; }
Visual Basic
Public Property EndIndent As Double
    Get
    Set
Visual C++
public:
property double EndIndent {
    double get ();
    void set (double value);
}

Remarks

BeginningIndent and endIndent are not allowed to overlap

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for endIndent must be between 0 and 30000 feet. -or- When setting this property: endIndent overlaps with beginningIndent

See Also

DividedPath Class


Flipped Property

[image]

Revit 2024 API
DividedPath..::..Flipped Property
DividedPath Class See Also Send Feedback
If the divided path is flipped the nodes are numbered in the reverse order. It also switches the ends from which beginningIndent and endIndent are measured from.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool Flipped { get; }
Visual Basic
Public ReadOnly Property Flipped As Boolean
    Get
Visual C++
public:
property bool Flipped {
    bool get ();
}

See Also

DividedPath Class


IsClosedLoop Property

[image]

Revit 2024 API
DividedPath..::..IsClosedLoop Property
DividedPath Class See Also Send Feedback
Whether or not the path forms a closed loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool IsClosedLoop { get; }
Visual Basic
Public ReadOnly Property IsClosedLoop As Boolean
    Get
Visual C++
public:
property bool IsClosedLoop {
    bool get ();
}

Remarks

True if the path form a closed loop. False otherwise.

See Also

DividedPath Class


IsCyclical Property

[image]

Revit 2024 API
DividedPath..::..IsCyclical Property
DividedPath Class See Also Send Feedback
True if the first and last point coincide False otherwise.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool IsCyclical { get; }
Visual Basic
Public ReadOnly Property IsCyclical As Boolean
    Get
Visual C++
public:
property bool IsCyclical {
    bool get ();
}

See Also

DividedPath Class


MaximumDistance Property

[image]

Revit 2024 API
DividedPath..::..MaximumDistance Property
DividedPath Class See Also Send Feedback
The maximum distance is used when the layout is set to 'MaximumSpacing'. When that layout rule is used the distance between points will not exceed this value. The measurement type determines how the distance is measured.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double MaximumDistance { get; set; }
Visual Basic
Public Property MaximumDistance As Double
    Get
    Set
Visual C++
public:
property double MaximumDistance {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The maximumDistance is too small.

See Also

DividedPath Class


MeasurementType Property

[image]

Revit 2024 API
DividedPath..::..MeasurementType Property
DividedPath Class See Also Send Feedback
The measurement type determines how distances are calculated. Either along a straight line between two points ('ChordLength') or along the segment of the path that connects them. ('SegmentLength').

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public DividedPathMeasurementType MeasurementType { get; set; }
Visual Basic
Public Property MeasurementType As DividedPathMeasurementType
    Get
    Set
Visual C++
public:
property DividedPathMeasurementType MeasurementType {
    DividedPathMeasurementType get ();
    void set (DividedPathMeasurementType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: Invalid measurementType -or- When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

DividedPath Class


MinimumDistance Property

[image]

Revit 2024 API
DividedPath..::..MinimumDistance Property
DividedPath Class See Also Send Feedback
The minimum distance is used when the layout is set to 'MinimumSpacing'. When that layout rule is used the distance between points will not fall below this value. The measurement type determines how the distance is measured.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double MinimumDistance { get; set; }
Visual Basic
Public Property MinimumDistance As Double
    Get
    Set
Visual C++
public:
property double MinimumDistance {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The minimumDistance is too small.

See Also

DividedPath Class


NumberOfPoints Property

[image]

Revit 2024 API
DividedPath..::..NumberOfPoints Property
DividedPath Class See Also Send Feedback
The total number of points of the divided surface. This combines the layout points and the intersection points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public int NumberOfPoints { get; }
Visual Basic
Public ReadOnly Property NumberOfPoints As Integer
    Get
Visual C++
public:
property int NumberOfPoints {
    int get ();
}

See Also

DividedPath Class


Parameter Property

[image] [image]

Revit 2024 API
DividedPath..::..Parameter Property
DividedPath Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

DividedPath Class
DividedPath Members


SpacingRuleJustification Property

[image]

Revit 2024 API
DividedPath..::..SpacingRuleJustification Property
DividedPath Class See Also Send Feedback
When the layout is set to 'FixedDistance' the points may not cover the entire range of the path. The justification determines whether the points are centered on the range, or shifted towards the start or end of the range.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public SpacingRuleJustification SpacingRuleJustification { get; set; }
Visual Basic
Public Property SpacingRuleJustification As SpacingRuleJustification
    Get
    Set
Visual C++
public:
property SpacingRuleJustification SpacingRuleJustification {
    SpacingRuleJustification get ();
    void set (SpacingRuleJustification value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: Invalid justification -or- When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

DividedPath Class


TotalPathLength Property

[image]

Revit 2024 API
DividedPath..::..TotalPathLength Property
DividedPath Class See Also Send Feedback
The sum of the curve lengths.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double TotalPathLength { get; }
Visual Basic
Public ReadOnly Property TotalPathLength As Double
    Get
Visual C++
public:
property double TotalPathLength {
    double get ();
}

See Also

DividedPath Class


DividedPathMeasurementType Enumeration

[image]

Revit 2024 API
DividedPathMeasurementType Enumeration
See Also Send Feedback
DividedPath measurement type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Since: 2013

Syntax

C#
public enum DividedPathMeasurementType
Visual Basic
Public Enumeration DividedPathMeasurementType
Visual C++
public enum class DividedPathMeasurementType

Members

Member name | Description
ChordLength | Distances between two points are measured along a straight line between the points.
SegmentLength | Distances between two points are measured along the path segment between the points.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


DividedSurface Class

[image]

Revit 2024 API
DividedSurface Class
Members Example See Also Send Feedback
An element that represents a mesh on the surface of another element, a family instance, an import instance or a geometry combination, and a tile pattern built on that mesh.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class DividedSurface : Element
Visual Basic
Public Class DividedSurface _
    Inherits Element
Visual C++
public ref class DividedSurface : public Element

Remarks

The type of this element may be set to: a TilePattern element, a FamilySymbol element from a Curtain Panel family.

Examples

CopyC#
public void TileSurface(Document document, Form form)
{
    // cover surface with OctagonRotate tile pattern
    TilePatterns tilePatterns = document.Settings.TilePatterns;
    foreach (Reference r in DividedSurface.GetReferencesWithDividedSurfaces(form))
    {
        DividedSurface ds = DividedSurface.GetDividedSurfaceForReference(document, r);
        ds.ChangeTypeId(tilePatterns.GetTilePattern(TilePatternsBuiltIn.OctagonRotate).Id);
    }
}
CopyVB.NET
Public Sub TileSurface(document As Document, form As Form)
    ' cover surface with OctagonRotate tile pattern
    Dim tilePatterns As TilePatterns = document.Settings.TilePatterns
    For Each r As Reference In DividedSurface.GetReferencesWithDividedSurfaces(form)
        Dim ds As DividedSurface = DividedSurface.GetDividedSurfaceForReference(document, r)
        ds.ChangeTypeId(tilePatterns.GetTilePattern(TilePatternsBuiltIn.OctagonRotate).Id)
    Next
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..DividedSurface

See Also

DividedSurface Members


DividedSurface Members

[image] [image]

Revit 2024 API
DividedSurface Members
DividedSurface Class Methods Properties See Also Send Feedback

The DividedSurface type exposes the following members.

Methods

 | Name | Description
Public method | AddIntersectionElement | Adds an intersection element to the divided surface.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
 | CanBeDivided | This returns true if the reference represents a face that can be used to create a divided surface.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeIntersectionElement | Checks if the element can be an intersection reference.
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create | Creates a new instance of a divided surface with a default layout.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetAllIntersectionElements | Gets all intersection elements which produce division lines.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
 | GetDividedSurfaceForReference | Get a divided surface for a given reference. Returns null if the reference does not host a divided surface.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetGridNodeLocation | Specify whether a particular grid node is interior to the surface, on the boundary, or outside the boundary.
Public method | GetGridNodeReference | Get a reference to the geometric point associated with a grid node.
Public method | GetGridNodeUV | Get the position of a grid node in UV coordinates in the surface.
Public method | GetGridSegmentReference | Get a reference to a line segment connecting two adjacent grid nodes.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
 | GetReferencesWithDividedSurfaces | For a given host element get references to all the faces that host a divided surface
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetTileFamilyInstance | Get a reference to a tile element associated with a given seed node.
Public method | GetTileReference | Get a reference to one of the tile surfaces associated with a given seed node.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSeedNode | Reports whether a grid node is a "seed node," a node that is associated with one or more tiles.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | RemoveAllIntersectionElements | Removes all the intersection elements from a divided surface.
Public method | RemoveIntersectionElement | Removes an intersection element from a divided surface.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AllGridRotation | Angle of rotation applied to the U- and V- directions together.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BorderTile | Determines the handling of tiles that overlap the surface's boundary.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ComponentRotation | The rotation of the pattern by a multiple of 90 degrees.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Host | The element whose surface has been divided.
Public property | HostReference | A reference to the divided face on the host.
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsComponentFlipped | Whether the pattern is flipped.
Public property | IsComponentMirrored | Whether the pattern is mirror-imaged.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | NumberOfUGridlines | Get the number of U-gridlines used on the surface.
Public property | NumberOfVGridlines | Get the number of V-gridlines used on the surface.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UPatternIndent | The offset applied to the pattern by an integral number of grid nodes in the U-direction.
Public property | USpacingRule | Access to the rule for laying out the first series of equidistant parallel lines on the surface.
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | VPatternIndent | The offset applied to the pattern by an integral number of grid nodes in the V-direction.
Public property | VSpacingRule | Access to the rule for laying out the second series of equidistant parallel lines on the surface.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DividedSurface Class


DividedSurface Methods

[image] [image]

Revit 2024 API
DividedSurface Methods
DividedSurface Class See Also Send Feedback

The DividedSurface type exposes the following members.

Methods

 | Name | Description
Public method | AddIntersectionElement | Adds an intersection element to the divided surface.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
 | CanBeDivided | This returns true if the reference represents a face that can be used to create a divided surface.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeIntersectionElement | Checks if the element can be an intersection reference.
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create | Creates a new instance of a divided surface with a default layout.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetAllIntersectionElements | Gets all intersection elements which produce division lines.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
 | GetDividedSurfaceForReference | Get a divided surface for a given reference. Returns null if the reference does not host a divided surface.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetGridNodeLocation | Specify whether a particular grid node is interior to the surface, on the boundary, or outside the boundary.
Public method | GetGridNodeReference | Get a reference to the geometric point associated with a grid node.
Public method | GetGridNodeUV | Get the position of a grid node in UV coordinates in the surface.
Public method | GetGridSegmentReference | Get a reference to a line segment connecting two adjacent grid nodes.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
 | GetReferencesWithDividedSurfaces | For a given host element get references to all the faces that host a divided surface
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetTileFamilyInstance | Get a reference to a tile element associated with a given seed node.
Public method | GetTileReference | Get a reference to one of the tile surfaces associated with a given seed node.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSeedNode | Reports whether a grid node is a "seed node," a node that is associated with one or more tiles.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | RemoveAllIntersectionElements | Removes all the intersection elements from a divided surface.
Public method | RemoveIntersectionElement | Removes an intersection element from a divided surface.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DividedSurface Class


AddIntersectionElement Method

[image]

Revit 2024 API
DividedSurface..::..AddIntersectionElement Method
DividedSurface Class See Also Send Feedback
Adds an intersection element to the divided surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public void AddIntersectionElement(
    ElementId newIntersectionElemId
)
Visual Basic
Public Sub AddIntersectionElement ( _
    newIntersectionElemId As ElementId _
)
Visual C++
public:
void AddIntersectionElement(
    ElementId^ newIntersectionElemId
)

Parameters

newIntersectionElemId
Type: Autodesk.Revit.DB..::..ElementId
The intersection element to be added.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element newIntersectionElemId is not a level, grid, reference plane, or a curve element whose category is lines and reference lines.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DividedSurface Class


CanBeDivided Method

[image]

Revit 2024 API
DividedSurface..::..CanBeDivided Method
DividedSurface Class See Also Send Feedback
This returns true if the reference represents a face that can be used to create a divided surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static bool CanBeDivided(
    Document document,
    Reference reference
)
Visual Basic
Public Shared Function CanBeDivided ( _
    document As Document, _
    reference As Reference _
) As Boolean
Visual C++
public:
static bool CanBeDivided(
    Document^ document,
    Reference^ reference
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
reference
Type: Autodesk.Revit.DB..::..Reference
The reference.

Return Value

True if the reference can be used to create a divided surface, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DividedSurface Class


CanBeIntersectionElement Method

[image]

Revit 2024 API
DividedSurface..::..CanBeIntersectionElement Method
DividedSurface Class See Also Send Feedback
Checks if the element can be an intersection reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool CanBeIntersectionElement(
    ElementId id
)
Visual Basic
Public Function CanBeIntersectionElement ( _
    id As ElementId _
) As Boolean
Visual C++
public:
bool CanBeIntersectionElement(
    ElementId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::..ElementId
The element to be checked.

Return Value

True if the element can be an intersection reference., false otherwise.

Remarks

The element must be a level, grid, reference plane, or a curve element whose category is lines and reference lines.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DividedSurface Class


Create Method

[image]

Revit 2024 API
DividedSurface..::..Create Method
DividedSurface Class Example See Also Send Feedback
Creates a new instance of a divided surface with a default layout.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static DividedSurface Create(
    Document document,
    Reference faceReference
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    faceReference As Reference _
) As DividedSurface
Visual C++
public:
static DividedSurface^ Create(
    Document^ document,
    Reference^ faceReference
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
faceReference
Type: Autodesk.Revit.DB..::..Reference
Reference that represents a face.

Return Value

The newly created divided surface.

Examples

CopyC#
public void DivideSurface(Document document, Form form)
{
    Autodesk.Revit.ApplicationServices.Application application = document.Application;
    Options opt = application.Create.NewGeometryOptions();
    opt.ComputeReferences = true;

    Autodesk.Revit.DB.GeometryElement geomElem = form.get_Geometry(opt);
    foreach (GeometryObject geomObj in geomElem)
    {
        Solid solid = geomObj as Solid;
        foreach (Face face in solid.Faces)
        {
            if (face.Reference != null)
            {
                DividedSurface ds = DividedSurface.Create(document,face.Reference);
                // create a divided surface with fixed number of U and V grid lines
                SpacingRule srU = ds.USpacingRule;
                srU.SetLayoutFixedNumber(16, SpacingRuleJustification.Center, 0, 0);

                SpacingRule srV = ds.VSpacingRule;
                srV.SetLayoutFixedNumber(24, SpacingRuleJustification.Center, 0, 0);

                break;  // just divide one face of form
            }
        }
    }
}
CopyVB.NET
Public Sub DivideSurface(document As Document, form As Form)
    Dim application As Autodesk.Revit.ApplicationServices.Application = document.Application
    Dim opt As Options = application.Create.NewGeometryOptions()
    opt.ComputeReferences = True

    Dim geomElem As Autodesk.Revit.DB.GeometryElement = form.Geometry(opt)
    For Each geomObj As GeometryObject In geomElem
        Dim solid As Solid = TryCast(geomObj, Solid)
        For Each face As Face In solid.Faces
            If face.Reference IsNot Nothing Then
                Dim ds As DividedSurface = DividedSurface.Create(document, face.Reference)
                ' create a divided surface with fixed number of U and V grid lines
                Dim srU As SpacingRule = ds.USpacingRule
                srU.SetLayoutFixedNumber(16, SpacingRuleJustification.Center, 0, 0)

                Dim srV As SpacingRule = ds.VSpacingRule
                srV.SetLayoutFixedNumber(24, SpacingRuleJustification.Center, 0, 0)

                ' just divide one face of form
                Exit For
            End If
        Next
    Next
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The document does not allow creation of a divided surface. -or- Reference is unstable import element -or- Reference does not represent a face -or- Reference already hosts a divided surface
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

DividedSurface Class


GetDividedSurfaceForReference Method

[image]

Revit 2024 API
DividedSurface..::..GetDividedSurfaceForReference Method
DividedSurface Class See Also Send Feedback
Get a divided surface for a given reference. Returns null if the reference does not host a divided surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static DividedSurface GetDividedSurfaceForReference(
    Document document,
    Reference faceReference
)
Visual Basic
Public Shared Function GetDividedSurfaceForReference ( _
    document As Document, _
    faceReference As Reference _
) As DividedSurface
Visual C++
public:
static DividedSurface^ GetDividedSurfaceForReference(
    Document^ document,
    Reference^ faceReference
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
faceReference
Type: Autodesk.Revit.DB..::..Reference
Reference that represents a face.

Return Value

The newly created divided surface.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DividedSurface Class


GetGridNodeLocation Method

[image]

Revit 2024 API
DividedSurface..::..GetGridNodeLocation Method
DividedSurface Class See Also Send Feedback
Specify whether a particular grid node is interior to the surface, on the boundary, or outside the boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public GridNodeLocation GetGridNodeLocation(
    GridNode gridNode
)
Visual Basic
Public Function GetGridNodeLocation ( _
    gridNode As GridNode _
) As GridNodeLocation
Visual C++
public:
GridNodeLocation GetGridNodeLocation(
    GridNode gridNode
)

Parameters

gridNode
Type: Autodesk.Revit.DB..::..GridNode

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the grid node indexes are outside the range [ 0, NumberOfUGridlines - 1 ], [ 0, NumberOfVGridlines - 1 ].

See Also

DividedSurface Class


GetGridNodeReference Method

[image]

Revit 2024 API
DividedSurface..::..GetGridNodeReference Method
DividedSurface Class See Also Send Feedback
Get a reference to the geometric point associated with a grid node.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Reference GetGridNodeReference(
    GridNode gridNode
)
Visual Basic
Public Function GetGridNodeReference ( _
    gridNode As GridNode _
) As Reference
Visual C++
public:
Reference^ GetGridNodeReference(
    GridNode gridNode
)

Parameters

gridNode
Type: Autodesk.Revit.DB..::..GridNode

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the grid node indexes are outside the range [ 0, NumberOfUGridlines - 1 ], [ 0, NumberOfVGridlines - 1 ].

See Also

DividedSurface Class


GetGridNodeUV Method

[image]

Revit 2024 API
DividedSurface..::..GetGridNodeUV Method
DividedSurface Class See Also Send Feedback
Get the position of a grid node in UV coordinates in the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public UV GetGridNodeUV(
    GridNode gridNode
)
Visual Basic
Public Function GetGridNodeUV ( _
    gridNode As GridNode _
) As UV
Visual C++
public:
UV^ GetGridNodeUV(
    GridNode gridNode
)

Parameters

gridNode
Type: Autodesk.Revit.DB..::..GridNode

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the grid node indexes are outside the range [ 0, NumberOfUGridlines - 1 ], [ 0, NumberOfVGridlines - 1 ].

See Also

DividedSurface Class


GetGridSegmentReference Method

[image]

Revit 2024 API
DividedSurface..::..GetGridSegmentReference Method
DividedSurface Class See Also Send Feedback
Get a reference to a line segment connecting two adjacent grid nodes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Reference GetGridSegmentReference(
    GridNode gridNode,
    GridSegmentDirection gridSegmentDirection
)
Visual Basic
Public Function GetGridSegmentReference ( _
    gridNode As GridNode, _
    gridSegmentDirection As GridSegmentDirection _
) As Reference
Visual C++
public:
Reference^ GetGridSegmentReference(
    GridNode gridNode,
    GridSegmentDirection gridSegmentDirection
)

Parameters

gridNode
Type: Autodesk.Revit.DB..::..GridNode
gridSegmentDirection
Type: Autodesk.Revit.DB..::..GridSegmentDirection

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the grid node indexes are outside the range [ 0, NumberOfUGridlines - 1 ], [ 0, NumberOfVGridlines - 1 ], or when the adjacent grid node specified by gridSegmentDirection is out of range.

See Also

DividedSurface Class


GetReferencesWithDividedSurfaces Method

[image]

Revit 2024 API
DividedSurface..::..GetReferencesWithDividedSurfaces Method
DividedSurface Class See Also Send Feedback
For a given host element get references to all the faces that host a divided surface

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static IList<Reference> GetReferencesWithDividedSurfaces(
    Element host
)
Visual Basic
Public Shared Function GetReferencesWithDividedSurfaces ( _
    host As Element _
) As IList(Of Reference)
Visual C++
public:
static IList<Reference^>^ GetReferencesWithDividedSurfaces(
    Element^ host
)

Parameters

host
Type: Autodesk.Revit.DB..::..Element
The element that hosts the divided surfaces

Return Value

References that host a divided surface

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DividedSurface Class


GetTileFamilyInstance Method

[image]

Revit 2024 API
DividedSurface..::..GetTileFamilyInstance Method
DividedSurface Class See Also Send Feedback
Get a reference to a tile element associated with a given seed node.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyInstance GetTileFamilyInstance(
    GridNode gridNode,
    int tileIndex
)
Visual Basic
Public Function GetTileFamilyInstance ( _
    gridNode As GridNode, _
    tileIndex As Integer _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ GetTileFamilyInstance(
    GridNode gridNode,
    int tileIndex
)

Parameters

gridNode
Type: Autodesk.Revit.DB..::..GridNode
tileIndex
Type: System..::..Int32

Return Value

A FamilyInstance object. Returns nullNothingnullptra null reference (Nothing in Visual Basic) if the ObjectType property is not a FamilySymbol. Returns nullNothingnullptra null reference (Nothing in Visual Basic) if the grid node is not a "seed node", or if the tile is omitted due to boundary conditions.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown if the grid node is outside of the range specified by NumberOfUGridlines and NumberOfVGridlines, or if tileIndex is outside the range [0, TilesPerSeedNode-1].

See Also

DividedSurface Class


GetTileReference Method

[image]

Revit 2024 API
DividedSurface..::..GetTileReference Method
DividedSurface Class See Also Send Feedback
Get a reference to one of the tile surfaces associated with a given seed node.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Reference GetTileReference(
    GridNode gridNode,
    int tileIndex
)
Visual Basic
Public Function GetTileReference ( _
    gridNode As GridNode, _
    tileIndex As Integer _
) As Reference
Visual C++
public:
Reference^ GetTileReference(
    GridNode gridNode,
    int tileIndex
)

Parameters

gridNode
Type: Autodesk.Revit.DB..::..GridNode
tileIndex
Type: System..::..Int32
An integer between 0 and T-1, where T is TilesPerSeedNode.

Return Value

A reference to a Face (surface). Returns nullNothingnullptra null reference (Nothing in Visual Basic) if the grid node is not a "seed node", or if the tile is omitted due to boundary conditions.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown if the grid node is outside of the range specified by NumberOfUGridlines and NumberOfVGridlines, or if tileIndex is outside the range [0, TilesPerSeedNode-1].

See Also

DividedSurface Class


IsSeedNode Method

[image]

Revit 2024 API
DividedSurface..::..IsSeedNode Method
DividedSurface Class See Also Send Feedback
Reports whether a grid node is a "seed node," a node that is associated with one or more tiles.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsSeedNode(
    GridNode gridNode
)
Visual Basic
Public Function IsSeedNode ( _
    gridNode As GridNode _
) As Boolean
Visual C++
public:
bool IsSeedNode(
    GridNode gridNode
)

Parameters

gridNode
Type: Autodesk.Revit.DB..::..GridNode

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the grid node indexes are outside the range [ 0, NumberOfUGridlines - 1 ], [ 0, NumberOfVGridlines - 1 ].

See Also

DividedSurface Class


RemoveAllIntersectionElements Method

[image]

Revit 2024 API
DividedSurface..::..RemoveAllIntersectionElements Method
DividedSurface Class See Also Send Feedback
Removes all the intersection elements from a divided surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public void RemoveAllIntersectionElements()
Visual Basic
Public Sub RemoveAllIntersectionElements
Visual C++
public:
void RemoveAllIntersectionElements()

See Also

DividedSurface Class


RemoveIntersectionElement Method

[image]

Revit 2024 API
DividedSurface..::..RemoveIntersectionElement Method
DividedSurface Class See Also Send Feedback
Removes an intersection element from a divided surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public void RemoveIntersectionElement(
    ElementId referenceElemIdToRemove
)
Visual Basic
Public Sub RemoveIntersectionElement ( _
    referenceElemIdToRemove As ElementId _
)
Visual C++
public:
void RemoveIntersectionElement(
    ElementId^ referenceElemIdToRemove
)

Parameters

referenceElemIdToRemove
Type: Autodesk.Revit.DB..::..ElementId
The intersection element to be removed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DividedSurface Class


DividedSurface Properties

[image] [image]

Revit 2024 API
DividedSurface Properties
DividedSurface Class See Also Send Feedback

The DividedSurface type exposes the following members.

Properties

 | Name | Description
Public property | AllGridRotation | Angle of rotation applied to the U- and V- directions together.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BorderTile | Determines the handling of tiles that overlap the surface's boundary.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ComponentRotation | The rotation of the pattern by a multiple of 90 degrees.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Host | The element whose surface has been divided.
Public property | HostReference | A reference to the divided face on the host.
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsComponentFlipped | Whether the pattern is flipped.
Public property | IsComponentMirrored | Whether the pattern is mirror-imaged.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | NumberOfUGridlines | Get the number of U-gridlines used on the surface.
Public property | NumberOfVGridlines | Get the number of V-gridlines used on the surface.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UPatternIndent | The offset applied to the pattern by an integral number of grid nodes in the U-direction.
Public property | USpacingRule | Access to the rule for laying out the first series of equidistant parallel lines on the surface.
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | VPatternIndent | The offset applied to the pattern by an integral number of grid nodes in the V-direction.
Public property | VSpacingRule | Access to the rule for laying out the second series of equidistant parallel lines on the surface.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DividedSurface Class


AllGridRotation Property

[image]

Revit 2024 API
DividedSurface..::..AllGridRotation Property
DividedSurface Class See Also Send Feedback
Angle of rotation applied to the U- and V- directions together.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double AllGridRotation { get; set; }
Visual Basic
Public Property AllGridRotation As Double
    Get
    Set
Visual C++
public:
property double AllGridRotation {
    double get ();
    void set (double value);
}

See Also

DividedSurface Class


BorderTile Property

[image]

Revit 2024 API
DividedSurface..::..BorderTile Property
DividedSurface Class See Also Send Feedback
Determines the handling of tiles that overlap the surface's boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public BorderTile BorderTile { get; set; }
Visual Basic
Public Property BorderTile As BorderTile
    Get
    Set
Visual C++
public:
property BorderTile BorderTile {
    BorderTile get ();
    void set (BorderTile value);
}

See Also

DividedSurface Class


ComponentRotation Property

[image]

Revit 2024 API
DividedSurface..::..ComponentRotation Property
DividedSurface Class See Also Send Feedback
The rotation of the pattern by a multiple of 90 degrees.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ComponentRotation ComponentRotation { get; set; }
Visual Basic
Public Property ComponentRotation As ComponentRotation
    Get
    Set
Visual C++
public:
property ComponentRotation ComponentRotation {
    ComponentRotation get ();
    void set (ComponentRotation value);
}

Remarks

This property has no effect unless a pattern is selected (the ObjectType property is not nullNothingnullptra null reference (Nothing in Visual Basic)).

See Also

DividedSurface Class


HostReference Property

[image]

Revit 2024 API
DividedSurface..::..HostReference Property
DividedSurface Class See Also Send Feedback
A reference to the divided face on the host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Reference HostReference { get; }
Visual Basic
Public ReadOnly Property HostReference As Reference
    Get
Visual C++
public:
property Reference^ HostReference {
    Reference^ get ();
}

Remarks

This is the same as the hostReference argument to the NewDividedSurface method of FamilyItemFactory.

See Also

DividedSurface Class


IsComponentFlipped Property

[image]

Revit 2024 API
DividedSurface..::..IsComponentFlipped Property
DividedSurface Class See Also Send Feedback
Whether the pattern is flipped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsComponentFlipped { get; set; }
Visual Basic
Public Property IsComponentFlipped As Boolean
    Get
    Set
Visual C++
public:
property bool IsComponentFlipped {
    bool get ();
    void set (bool value);
}

Remarks

This property has no effect unless a pattern is selected (the ObjectType property is not nullNothingnullptra null reference (Nothing in Visual Basic)). Changing this flag effectively reflects the component through its XY-plane, which is equivalent to reflecting it through the original surface.

See Also

DividedSurface Class


NumberOfUGridlines Property

[image]

Revit 2024 API
DividedSurface..::..NumberOfUGridlines Property
DividedSurface Class See Also Send Feedback
Get the number of U-gridlines used on the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public int NumberOfUGridlines { get; }
Visual Basic
Public ReadOnly Property NumberOfUGridlines As Integer
    Get
Visual C++
public:
property int NumberOfUGridlines {
    int get ();
}

See Also

DividedSurface Class


NumberOfVGridlines Property

[image]

Revit 2024 API
DividedSurface..::..NumberOfVGridlines Property
DividedSurface Class See Also Send Feedback
Get the number of V-gridlines used on the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public int NumberOfVGridlines { get; }
Visual Basic
Public ReadOnly Property NumberOfVGridlines As Integer
    Get
Visual C++
public:
property int NumberOfVGridlines {
    int get ();
}

See Also

DividedSurface Class


UPatternIndent Property

[image]

Revit 2024 API
DividedSurface..::..UPatternIndent Property
DividedSurface Class See Also Send Feedback
The offset applied to the pattern by an integral number of grid nodes in the U-direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public int UPatternIndent { get; set; }
Visual Basic
Public Property UPatternIndent As Integer
    Get
    Set
Visual C++
public:
property int UPatternIndent {
    int get ();
    void set (int value);
}

See Also

DividedSurface Class


USpacingRule Property

[image]

Revit 2024 API
DividedSurface..::..USpacingRule Property
DividedSurface Class See Also Send Feedback
Access to the rule for laying out the first series of equidistant parallel lines on the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public SpacingRule USpacingRule { get; }
Visual Basic
Public ReadOnly Property USpacingRule As SpacingRule
    Get
Visual C++
public:
property SpacingRule^ USpacingRule {
    SpacingRule^ get ();
}

See Also

DividedSurface Class


VPatternIndent Property

[image]

Revit 2024 API
DividedSurface..::..VPatternIndent Property
DividedSurface Class See Also Send Feedback
The offset applied to the pattern by an integral number of grid nodes in the V-direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public int VPatternIndent { get; set; }
Visual Basic
Public Property VPatternIndent As Integer
    Get
    Set
Visual C++
public:
property int VPatternIndent {
    int get ();
    void set (int value);
}

See Also

DividedSurface Class


VSpacingRule Property

[image]

Revit 2024 API
DividedSurface..::..VSpacingRule Property
DividedSurface Class See Also Send Feedback
Access to the rule for laying out the second series of equidistant parallel lines on the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public SpacingRule VSpacingRule { get; }
Visual Basic
Public ReadOnly Property VSpacingRule As SpacingRule
    Get
Visual C++
public:
property SpacingRule^ VSpacingRule {
    SpacingRule^ get ();
}

See Also

DividedSurface Class


Document Members

[image] [image]

Revit 2024 API
Document Members
Document Class Methods Properties Events See Also Send Feedback

The Document type exposes the following members.

Methods

 | Name | Description
Public method | AcquireCoordinates | Acquires coordinates from the specified link instance.
Public method | AutoJoinElements | Forces the elements in the Revit document to automatically join to their neighbors where appropriate.
Public method | CanEnableCloudWorksharing | Checks if cloud worksharing can be enabled for the cloud model.
Public method | CanEnableWorksharing | Checks if worksharing can be enabled in the document.
Public method | Close()()()() | Closes the document, save the changes if there are.
Public method | Close(Boolean) | Closes the document with the option to save.
Public method | CombineElements | Combine a set of combinable elements into a geometry combination.
Public method | ConvertDetailToModelCurves | Converts a group of DetailCurves to equivalent ModelCurves.
Public method | ConvertModelToDetailCurves | Converts a group of ModelCurves to equivalent DetailCurves.
Public method | ConvertModelToSymbolicCurves | Converts a group of ModelCurves to equivalent SymbolicCurves.
Public method | ConvertSymbolicToModelCurves | Converts a group of SymbolicCurves to equivalent ModelCurves.
Public method | Delete(ElementId) | Deletes an element from the document given the id of that element.
Public method | Delete(ICollection<(Of <<'(ElementId>)>>)) | Deletes a set of elements from the document.
Public method | Dispose | Releases all resources used by the Document
Public method | EditFamily | Gets the document of a loaded family to edit.
Public method | EnableCloudWorksharing | Enables cloud worksharing for a cloud model
Public method | EnableWorksharing | Enables worksharing in the document.
Public method | Equals | Determines whether the specified Object equals to this Object. (Overrides Object..::..Equals(Object).)
Public method | EraseSchemaAndAllEntities | Erases Schema and all its Entities from the document.
Public method | Export(String, IList<(Of <<'(ElementId>)>>), PDFExportOptions) | Exports a selection of views in PDF format.
Public method | Export(String, String, GBXMLExportOptions) | Export the model in gbXML (green-building) format.
Public method | Export(String, String, IFCExportOptions) | Exports the document to the Industry Standard Classes (IFC) format.
Public method | Export(String, String, NavisworksExportOptions) | Exports a Revit project to the Navisworks .nwc format.
Public method | Export(String, String, OBJExportOptions) | Exports a view specified in the export options to the OBJ format.
Public method | Export(String, String, STLExportOptions) | Exports a view specified in the export options to the STL format.
Public method | Export(String, String, ViewSet, DWFExportOptions) | Exports the current view or a selection of views in DWF format.
Public method | Export(String, String, ViewSet, DWFXExportOptions) | Exports the current view or a selection of views in DWFX format.
Public method | Export(String, String, ViewSet, FBXExportOptions) | Exports the document in 3D-Studio Max (FBX) format.
Public method | Export(String, String, ICollection<(Of <<'(ElementId>)>>), DGNExportOptions) | Exports a selection of views in DGN format.
Public method | Export(String, String, ICollection<(Of <<'(ElementId>)>>), DWGExportOptions) | Exports a selection of views in DWG format.
Public method | Export(String, String, ICollection<(Of <<'(ElementId>)>>), DXFExportOptions) | Exports a selection of views in DXF format.
Public method | Export(String, String, ICollection<(Of <<'(ElementId>)>>), SATExportOptions) | Exports the current view or a selection of views in SAT format.
Public method | ExportImage | Exports a view or set of views into an image file.
Public method | GetAllUnusedElements | Returns the list of element ids that are not used. The list of unused element ids may include elements that can't be deleted.
Public method | GetChangedElements | Extracts a collection containing the ids of elements that have been created, modified or deleted between the input baseVersion and the document's current version.
Public method | GetCloudFolderId | Gets ForgeDM folder id where the model locates.
Public method | GetCloudModelPath | Gets the cloud model path of the cloud model.
Public method | GetCloudModelUrn | A ForgeDM Urn identifying the model.
Public method | GetDefaultElementTypeId | Gets the default element type id with the given DefaultElementType id.
Public method | GetDefaultFamilyTypeId | Gets the default family type id with the given family category id.
Public method | GetDocumentPreviewSettings | Returns the preview settings for the given document.
 | GetDocumentVersion | Gets the DocumentVersion that corresponds to a document.
Public method | GetElement(String) | Gets the Element referenced by a unique id string.
Public method | GetElement(ElementId) | Gets the Element referenced by the input ElementId.
Public method | GetElement(Reference) | Gets the Element referenced by the input reference.
Public method | GetHashCode | Gets the hash code of this document instance. (Overrides Object..::..GetHashCode()()()().)
Public method | GetHubId | Gets ForgeDM hub id where the model locates. It is cached in session.
Public method | GetPaintedMaterial | Get the material painted on the element's face. Returns invalidElementId if the face is not painted.
Public method | GetPrintSettingIds | Retrieves all Print Settings of current project.
Public method | GetProjectId | Gets ForgeDM project id where the model locates.
Public method | GetRoomAtPoint(XYZ) | Gets a room containing the point.
Public method | GetRoomAtPoint(XYZ, Phase) | Gets a room containing the point.
Public method | GetSpaceAtPoint(XYZ) | Gets a space containing the point.
Public method | GetSpaceAtPoint(XYZ, Phase) | Gets a space containing the point.
Public method | GetSubelement(String) | Gets the subelement referenced by a unique id string.
Public method | GetSubelement(Reference) | Gets the subelement referenced by the input reference.
Public method | GetSubelement(ElementId, Int32) | Gets the subelement referenced by a parent id and subelement id.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeOfStorage | Get the storage type of the identified built-in parameter.
Public method | GetUnits | Gets the Units object.
Public method | GetUnusedElements | Returns the list of element ids that are not used and can be deleted from the document.
Public method | GetWarnings | Returns list of failure messages generated from persistent (reviewable) warnings accumulated in the document.
Public method | GetWorksetId | Get Id of the Workset which owns the element.
Public method | GetWorksetTable | Get the WorksetTable of this document.
Public method | GetWorksharingCentralModelPath | Gets the central model path of the worksharing model.
Public method | HasAllChangesFromCentral | Returns whether the model in the current session is up to date with central.
Public method | Import(String, GBXMLImportOptions) | Imports a Green-Building XML file into the document.
Public method | Import(String, AXMImportOptions, View) | Imports an AXM file into the document.
Public method | Import(String, ImportOptions3DM, View) | Imports a 3DM file into the document.
Public method | Import(String, OBJImportOptions, View) | Imports an OBJ file into the document.
Public method | Import(String, SATImportOptions, View) | Imports an SAT file into the document.
Public method | Import(String, SKPImportOptions, View) | Imports a SKP file into the document.
Public method | Import(String, STLImportOptions, View) | Imports an STL file into the document.
Public method | Import(String, DGNImportOptions, View, ElementId%) | Imports a DGN file to the document.
Public method | Import(String, DWGImportOptions, View, ElementId%) | Imports a DWG or DXF file to the document.
Public method | IsBackgroundCalculationInProgress | Indicates whether there are any background calculations in progress for this document.
Public method | IsDefaultElementTypeIdValid | Checks whether the element type id is valid for the give DefaultElmentType id.
Public method | IsDefaultFamilyTypeIdValid | Checks whether the family type id is valid for the give family category.
Public method | IsPainted | Checks if the element's face is painted with a material.
 | IsValidVersionGUID | Checks whether the GUID is valid for the given document. Empty GUID is allowed.
Public method | Link(String, DWFImportOptions) | Links Markups in a DWF file into the project document.
Public method | Link(String, ImportOptions3DM, View) | Links a 3DM file into the project document.
Public method | Link(String, OBJImportOptions, View) | Links an OBJ file into the project document.
Public method | Link(String, SATImportOptions, View) | Links an SAT file into the project document.
Public method | Link(String, SKPImportOptions, View) | Links a SKP file into the project document.
Public method | Link(String, STLImportOptions, View) | Links an STL file into the project document.
Public method | Link(String, DGNImportOptions, View, ElementId%) | Links a DGN file into the project document.
Public method | Link(String, DWGImportOptions, View, ElementId%) | Links a DWG or DXF file into the project document.
Public method | LoadFamily(String) | Loads an entire family and all its types/symbols into the document.
Public method | LoadFamily(Document) | Loads the contents of this family document into another document.
Public method | LoadFamily(String, Family%) | Loads an entire family and all its types/symbols into the document and provides a reference to the loaded family.
Public method | LoadFamily(Document, IFamilyLoadOptions) | Loads the contents of this family document into another document.
Public method | LoadFamily(String, IFamilyLoadOptions, Family%) | Loads an entire family and all its types/symbols into the document and provides a reference to the loaded family.
Public method | LoadFamilySymbol(String, String) | Loads only a specified family type/symbol from a family file into the document.
Public method | LoadFamilySymbol(String, String, FamilySymbol%) | Loads only the specified family type/symbol from a family file into the document and provides a reference to the loaded family symbol.
Public method | LoadFamilySymbol(String, String, IFamilyLoadOptions, FamilySymbol%) | Loads only the specified family type/symbol from a family file into the document and provides a reference to the loaded family symbol.
Public method | MakeTransientElements | This method encapsulates the process of creating transient elements in the document.
Public method | Paint(ElementId, Face, ElementId) | Paint the element's face with specified material.
Public method | Paint(ElementId, Face, FamilyParameter) | Paint the element's face with specified material.
Public method | PostFailure | Posts a failure to be displayed to the user at the end of transaction.
Public method | Print(ViewSet) | Prints a set of views with default view template and default print settings.
Public method | Print(ViewSet, View) | Prints a set of views with a specified view template and default print settings.
Public method | Print(ViewSet, Boolean) | Prints a set of views with default view template and default print settings.
Public method | Print(ViewSet, View, Boolean) | Prints a set of views with a specified view template and default print settings.
Public method | PublishCoordinates | Publish coordinates to the specified ProjectLocation of the link instance.
Public method | Regenerate | Updates the elements in the Revit document to reflect all changes.
Public method | ReloadLatest | Fetches changes from central (due to one or more synchronizations with central) and merges them into the current session.
Public method | RemovePaint | Remove the material painted on the element's face. If the face is currently not painted,it will do nothing.
Public method | ResetSharedCoordinates | Reset shared coordinates for the host model/file.
Public method | Save()()()() | Saves the document.
Public method | Save(SaveOptions) | Saves the document.
Public method | SaveAs(String) | Saves the document to a given file path.
Public method | SaveAs(String, SaveAsOptions) | Saves the document to a given file path.
Public method | SaveAs(ModelPath, SaveAsOptions) | Saves the document to a given path.
Public method | SaveAsCloudModel | Saves current non-workshared or workshared model as a cloud model or workshared cloud model in BIM 360 Docs or Autodesk Docs.
Public method | SaveCloudModel | Saves cloud model.
Public method | SaveToProjectAsImage | Creates an image view from the currently active view.
Public method | SeparateElements | Separate a set of combinable elements out of combinations they currently belong to.
Public method | SetDefaultElementTypeId | Sets the default element type id of the given DefaultElementType id.
Public method | SetDefaultFamilyTypeId | Sets the default family type id for the given family category.
Public method | SetUnits | Sets the units.
Public method | SynchronizeWithCentral | Performs reload latest until the model in the current session is up to date and then saves changes back to central. A save to central is performed even if no changes were made.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnpostFailure | Deletes the posted failure message associated with a given FailureMessageKey.

Properties

 | Name | Description
Public property | ActiveProjectLocation | Retrieve the active project location.
Public property | ActiveView | The document's active view.
Public property | Application | Returns the Application in which the Document resides.
Public property | Create | An object that can be used to create new instances of Autodesk Revit API elements within a project.
Public property | CreationGUID | A unique identifier generated when the Document was first created.
Public property | DisplayUnitSystem | Provides access to display unit type with in the document.
Public property | FamilyCreate | An object that can be used to create new instances of Autodesk Revit API elements within a family document.
Public property | FamilyManager | The family manager object provides access to family types and parameters.
Public property | IsDetached | Identifies if a workshared document is detached. Also, see IsWorkshared
Public property | IsFamilyDocument | Identifies if the current document is a family document.
Public property | IsLinked | Identifies if a document is a linked RVT.
Public property | IsModelInCloud | Identifies if document is stored on Autodesk cloud services.
Public property | IsModifiable | Identifies if the document is modifiable.
Public property | IsModified | The state of changes made to the document.
Public property | IsReadOnly | Identifies if the document is read-only or can possibly be modified.
Public property | IsReadOnlyFile | Signals whether the document was opened from a read-only file.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | IsWorkshared | Identifies if worksharing (i.e. editing permissions and multiple worksets) have been enabled in the document. Also, see IsDetached
Public property | MassDisplayTemporaryOverride | This setting controls temporary display in views of objects with mass category or subcategories.
Public property | MullionTypes | This property is used to retrieve all the mullion types in current system.
Public property | OwnerFamily | Get the Family of this Family Document.
Public property | PanelTypes | Retrieves a set of PanelType objects that contains all the panel types that are currently loaded into the project.
Public property | ParameterBindings | Retrieves an object from which mappings between parameter definitions and categories can be found.
Public property | PathName | The fully qualified path of the document's disk file.
Public property | Phases | Retrieves all of the phases in the document.
Public property | PlanTopologies | Get the PlanTopologies of the current project in the last phase.
Public property | PlanTopologies[([( Phase])]) | Gets the PlanTopologies of the current project in a given phase.
Public property | PlanTopology[([( Level])]) | Get the PlanTopology of a given level in the last phase.
Public property | PlanTopology[([( Level, Phase])]) | Get the PlanTopology of a given level in a given phase.
Public property | PrintManager | Retrieve the PrintManager of current project.
Public property | ProjectInformation | Return the Project Information of the current project.
Public property | ProjectLocations | Retrieve all the project locations associated with this project
Public property | ReactionsAreUpToDate | Reports if the analytical model has regenerated in a document with reaction loads.
Public property | Settings | Provides access to general application settings, such as Categories.
Public property | SiteLocation | Returns the site location information.
Public property | Title | The document's title.
Public property | TypeOfStorage | Get the storage type of the specified BuiltInParameter.
Public property | WorksharingCentralGUID | The central GUID of the server-based model.

Events

 | Name | Description
Public event | DocumentClosing | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
Public event | DocumentPrinted | Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.
Public event | DocumentPrinting | Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.
Public event | DocumentSaved | Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving a document.
Public event | DocumentSavedAs | Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.
Public event | DocumentSaving | Subscribe to the DocumentSaving event to be notified when Revit is just about to save a document.
Public event | DocumentSavingAs | Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.
Public event | ViewPrinted | Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.
Public event | ViewPrinting | Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.

See Also

Document Class


AutoJoinElements Method

[image]

Revit 2024 API
Document..::..AutoJoinElements Method
Document Class See Also Send Feedback
Forces the elements in the Revit document to automatically join to their neighbors where appropriate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void AutoJoinElements()
Visual Basic
Public Sub AutoJoinElements
Visual C++
public:
void AutoJoinElements()

Remarks

Use this method to force elements in the document to automatically join to their neighbors. Note that when a transaction is committed there is an automatic call to automatically join elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..AutoJoinFailedException | Thrown when the operation fails.

See Also

Document Class


CanEnableWorksharing Method

[image]

Revit 2024 API
Document..::..CanEnableWorksharing Method
Document Class See Also Send Feedback
Checks if worksharing can be enabled in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool CanEnableWorksharing()
Visual Basic
Public Function CanEnableWorksharing As Boolean
Visual C++
public:
bool CanEnableWorksharing()

Return Value

True if worksharing can be enabled in the document, False otherwise.

See Also

Document Class


Close Method (Boolean)

[image]

Revit 2024 API
Document..::..Close Method (Boolean)
Document Class See Also Send Feedback
Closes the document with the option to save.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool Close(
    bool saveModified
)
Visual Basic
Public Function Close ( _
    saveModified As Boolean _
) As Boolean
Visual C++
public:
bool Close(
    bool saveModified
)

Parameters

saveModified
Type: System..::..Boolean
Indicates if the current document should be saved before close operation.

Return Value

False if closing procedure fails or if saving of a modified document was requested (saveModified = True) but failed. Also returns False if closing is cancelled by an external application during 'DocumentClosing' event. When function succeeds, True is returned.

Remarks

The currently active document may not be closed by this function. It can only be closed via Revit's UI.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when attempting to close the currently active document. Thrown if there are any transactions, sub-transactions or transaction groups which were opened by the API code, and not closed. All of these items must be handled before attempting to close the document. Thrown if saveModified is 'true' and the PathName is not set yet. Thrown if saveModified is 'true' and the saving target file is read only.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if this a linked file.

See Also

Document Class
Close Overload


CombineElements Method

[image]

Revit 2024 API
Document..::..CombineElements Method
Document Class See Also Send Feedback
Combine a set of combinable elements into a geometry combination.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public GeomCombination CombineElements(
    CombinableElementArray members
)
Visual Basic
Public Function CombineElements ( _
    members As CombinableElementArray _
) As GeomCombination
Visual C++
public:
GeomCombination^ CombineElements(
    CombinableElementArray^ members
)

Parameters

members
Type: Autodesk.Revit.DB..::..CombinableElementArray
A list of combinable elements to be combined.

Return Value

If successful, the newly created geometry combination is returned, otherwise an exception with error information will be thrown.

Remarks

If one or more existing geometry combinations are included as input, the return value may be one of those pre-existing combinations. The rest of the pre-existing geometry combinations will be consumed into the new combination; those handles are no longer valid.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when members contains less than two elements. Thrown when members contains nullNothingnullptra null reference (Nothing in Visual Basic) elements.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when creation of the combination failed.

See Also

Document Class


ConvertDetailToModelCurves Method

[image]

Revit 2024 API
Document..::..ConvertDetailToModelCurves Method
Document Class See Also Send Feedback
Converts a group of DetailCurves to equivalent ModelCurves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ModelCurveArray ConvertDetailToModelCurves(
    View view,
    DetailCurveArray detailCurves
)
Visual Basic
Public Function ConvertDetailToModelCurves ( _
    view As View, _
    detailCurves As DetailCurveArray _
) As ModelCurveArray
Visual C++
public:
ModelCurveArray^ ConvertDetailToModelCurves(
    View^ view,
    DetailCurveArray^ detailCurves
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view where the new lines will be created. The lines are projected on the view workplane. The view workplane must be parallel to the view plane.
detailCurves
Type: Autodesk.Revit.DB..::..DetailCurveArray
The detail curve array to be converted.

Remarks

This operation will create new ModelCurves with the same geometry of the original detail curves' geometry. The detail curves will be deleted from the document.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown when the input argument is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | Thrown when the given detail lines are not visible in the given view. Thrown when the detail lines are not in the same view or not parallel to the given view.
System..::..InvalidOperationException | Thrown when one or more curves could not be successfully converted.

See Also

Document Class


ConvertModelToDetailCurves Method

[image]

Revit 2024 API
Document..::..ConvertModelToDetailCurves Method
Document Class See Also Send Feedback
Converts a group of ModelCurves to equivalent DetailCurves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public DetailCurveArray ConvertModelToDetailCurves(
    View view,
    ModelCurveArray modelCurves
)
Visual Basic
Public Function ConvertModelToDetailCurves ( _
    view As View, _
    modelCurves As ModelCurveArray _
) As DetailCurveArray
Visual C++
public:
DetailCurveArray^ ConvertModelToDetailCurves(
    View^ view,
    ModelCurveArray^ modelCurves
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view where the new lines will be created. The lines are projected on the view plane. If the lines are not parallel to the view plane, lines are foreshortened and arcs are converted to ellipses. Splines are modified.
modelCurves
Type: Autodesk.Revit.DB..::..ModelCurveArray
The model curve array to be converted.

Remarks

This operation will create new DetailCurves with the same geometry of the original model curves' geometry. The model curves will be deleted from the document. If the model curves do not lie in a plane parallel to the view, their geometry will be projected to the view.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown when the input argument is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | Thrown when view is invalid to create DetailCurves on it.
System..::..InvalidOperationException | Thrown when current document is a family. Thrown when one or more curves could not be successfully converted, perhaps because some of the input curves could not be projected onto the active workplane of the view.

See Also

Document Class


Delete Method (ElementId)

[image]

Revit 2024 API
Document..::..Delete Method (ElementId)
Document Class Example See Also Send Feedback
Deletes an element from the document given the id of that element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ICollection<ElementId> Delete(
    ElementId elementId
)
Visual Basic
Public Function Delete ( _
    elementId As ElementId _
) As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ Delete(
    ElementId^ elementId
)

Parameters

elementId
Type: Autodesk.Revit.DB..::..ElementId
Id of the element to delete.

Return Value

The deleted element id set.

Remarks

This method will delete the element and any elements that are totally dependent upon that element. Any references to the deleted elements will become invalid and hence cause an exception to be thrown if they are accessed. The elements will be deleted with no prompts for user confirmation. Pinned elements will be deleted with no warnings.

Note: in a family document, the predefined elements (those elements inherited from its family template file) can't be deleted by this method.

Examples

CopyC#
private void DeleteElement(Autodesk.Revit.DB.Document document, Element element)
{
    // Delete a selected element.
   ICollection<Autodesk.Revit.DB.ElementId> deletedIdSet = document.Delete(element.Id);

    if (0 == deletedIdSet.Count)
    {
        throw new Exception("Deleting the selected element in Revit failed.");
    }

    String prompt = "The selected element has been removed and ";
    prompt += deletedIdSet.Count - 1;
    prompt += " more dependent elements have also been removed.";

    // Give the user some information
    TaskDialog.Show("Revit",prompt);

}
CopyC#
private void DeleteElement(Autodesk.Revit.DB.Document document, Element element)
{
    // Delete an element via its id
    Autodesk.Revit.DB.ElementId elementId = element.Id;
    ICollection<Autodesk.Revit.DB.ElementId> deletedIdSet = document.Delete(elementId);

    if (0 == deletedIdSet.Count)
    {
        throw new Exception("Deleting the selected element in Revit failed.");
    }

    String prompt = "The selected element has been removed and ";
    prompt += deletedIdSet.Count - 1;
    prompt += " more dependent elements have also been removed.";

    // Give the user some information
    TaskDialog.Show("Revit", prompt);
}
CopyVB.NET
Private Sub DeleteElement(document As Autodesk.Revit.DB.Document, element As Element)
    ' Delete a selected element.
    Dim deletedIdSet As ICollection(Of Autodesk.Revit.DB.ElementId) = document.Delete(element.Id)

    If 0 = deletedIdSet.Count Then
        Throw New Exception("Deleting the selected element in Revit failed.")
    End If

    Dim prompt As [String] = "The selected element has been removed and "
    prompt += deletedIdSet.Count - 1
    prompt += " more dependent elements have also been removed."

    ' Give the user some information
    TaskDialog.Show("Revit", prompt)

End Sub
CopyVB.NET
Private Sub DeleteElement(document As Autodesk.Revit.DB.Document, element As Element)
    ' Delete an element via its id
    Dim elementId As Autodesk.Revit.DB.ElementId = element.Id
    Dim deletedIdSet As ICollection(Of Autodesk.Revit.DB.ElementId) = document.Delete(elementId)

    If 0 = deletedIdSet.Count Then
        Throw New Exception("Deleting the selected element in Revit failed.")
    End If

    Dim prompt As [String] = "The selected element has been removed and "
    prompt += deletedIdSet.Count - 1
    prompt += " more dependent elements have also been removed."

    ' Give the user some information
    TaskDialog.Show("Revit", prompt)
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element elementId does not exist in the document -or- ElementId cannot be deleted.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

Document Class
Delete Overload


Dispose Method

[image]

Revit 2024 API
Document..::..Dispose Method
Document Class See Also Send Feedback
Releases all resources used by the Document

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

Document Class


EditFamily Method

[image]

Revit 2024 API
Document..::..EditFamily Method
Document Class Example See Also Send Feedback
Gets the document of a loaded family to edit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Document EditFamily(
    Family loadedFamily
)
Visual Basic
Public Function EditFamily ( _
    loadedFamily As Family _
) As Document
Visual C++
public:
Document^ EditFamily(
    Family^ loadedFamily
)

Parameters

loadedFamily
Type: Autodesk.Revit.DB..::..Family
The loaded family in current document.

Return Value

Reference of the document of the family.

Remarks

This creates an independent copy of the family for editing. To apply the changes back to the family stored in the document, use the LoadFamily overload accepting IFamilyLoadOptions.

This method may not be called if the document is currently modifiable (has an open transaction) or is in a read-only state. The method may not be called during dynamic updates. To test the document's current status, check the values of IsModifiable and IsReadOnly properties.

Examples

CopyC#
public void GetLoadedSymbols(Autodesk.Revit.DB.Document document, FamilyInstance familyInstance)
{
    if (null != familyInstance.Symbol)
    {
        // Get family associated with this
        Family family = familyInstance.Symbol.Family;

        // Get Family document for family
        Document familyDoc = document.EditFamily(family);
        if (null != familyDoc && familyDoc.IsFamilyDocument == true)
        {
            String loadedFamilies = "FamilySymbols in " + family.Name + ":\n";
            FilteredElementCollector collector = new FilteredElementCollector(document);
            ICollection<Element> collection =
                collector.OfClass(typeof(FamilySymbol)).ToElements();
            foreach (Element e in collection)
            {
                FamilySymbol fs = e as FamilySymbol;
                loadedFamilies += "\t" + fs.Name + "\n";
            }

            TaskDialog.Show("Revit",loadedFamilies);
        }
    }
}
CopyVB.NET
Public Sub GetLoadedSymbols(document As Autodesk.Revit.DB.Document, familyInstance As FamilyInstance)
    If familyInstance.Symbol IsNot Nothing Then
        ' Get family associated with this
        Dim family As Family = familyInstance.Symbol.Family

        ' Get Family document for family
        Dim familyDoc As Document = document.EditFamily(family)
        If familyDoc IsNot Nothing AndAlso familyDoc.IsFamilyDocument = True Then
            Dim loadedFamilies As [String] = "FamilySymbols in " + family.Name & ":" & vbLf
            Dim collector As New FilteredElementCollector(document)
            Dim collection As ICollection(Of Element) = collector.OfClass(GetType(FamilySymbol)).ToElements()
            For Each e As Element In collection
                Dim fs As FamilySymbol = TryCast(e, FamilySymbol)
                loadedFamilies += vbTab + fs.Name & vbLf
            Next

            TaskDialog.Show("Revit", loadedFamilies)
        End If
    End If
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"loadedFamily"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-"loadedFamily"-is an in-place family or a non-editable family. (This can be checked with the IsInPlace and IsEditable properties of the Family class.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the family is already being edited.
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if this method is called while the document is modifiable (i.e. it has an unfinished transaction.)
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if this method is currently in a read-only state.

See Also

Document Class


EnableCloudWorksharing Method

[image]

Revit 2024 API
Document..::..EnableCloudWorksharing Method
Document Class See Also Send Feedback
Enables cloud worksharing for a cloud model

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019.2

Syntax

C#
public void EnableCloudWorksharing()
Visual Basic
Public Sub EnableCloudWorksharing
Visual C++
public:
void EnableCloudWorksharing()

Remarks

This operation will convert an existing cloud model to a workshared cloud model. This method cannot be used if current model is not a cloud model. This method cannot be used if the current user doesn't have the workshared cloud model entitlement.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..CentralModelAccessDeniedException | Access to the cloud model was denied due to lack of access privileges. -or- Access to the central model was denied. A possible reason is because the model was under maintenance.
Autodesk.Revit.Exceptions..::..CentralModelContentionException | The central model is locked by another client.
Autodesk.Revit.Exceptions..::..CentralModelException | The model in cloud is missing. -or- The model in cloud is incompatible. -or- The model in cloud is corrupt or not an RVT file. -or- The model in cloud was rolled back. -or- An internal error happened on the model in cloud , please contact the administrator.
Autodesk.Revit.Exceptions..::..FileNotFoundException | Cannot access the local cache.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This Document is not a primary document, it is a linked document. -or- This Document is read-only: It cannot be modified. -or- This Document has an open editing transaction and is accepting changes. -or- This Document is not a project document. -or- This Document is in an edit mode. -or- Saving is not allowed in the current application mode. -or- This Document does not have a central location: Worksharing needs to be enabled and central model saved. -or- The file is read-only, can not be saved. -or- The cloud model does not allow cloud worksharing to be enabled. -or- Operation is not permitted when there is any open sub-transaction, transaction, or transaction group.
Autodesk.Revit.Exceptions..::..RevitServerCommunicationException | Could be for any of the reasons related to network.
Autodesk.Revit.Exceptions..::..RevitServerInternalException | Could be for any of the reasons that conversion fails with RevitServerInternalException.
Autodesk.Revit.Exceptions..::..RevitServerUnauthenticatedUserException | User is not signed in with Autodesk id.
Autodesk.Revit.Exceptions..::..RevitServerUnauthorizedException | You do not have workshared cloud model entitlement to access this resource in cloud -or- User is not authorized to access the specified cloud project.

See Also

Document Class


EnableWorksharing Method

[image]

Revit 2024 API
Document..::..EnableWorksharing Method
Document Class See Also Send Feedback
Enables worksharing in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void EnableWorksharing(
    string worksetNameGridLevel,
    string worksetName
)
Visual Basic
Public Sub EnableWorksharing ( _
    worksetNameGridLevel As String, _
    worksetName As String _
)
Visual C++
public:
void EnableWorksharing(
    String^ worksetNameGridLevel,
    String^ worksetName
)

Parameters

worksetNameGridLevel
Type: System..::..String
Name of workset for grids and levels.
worksetName
Type: System..::..String
Name of workset for all other elements.

Remarks

The document's Undo history will be cleared by this command. As a result, this command and others executed before it cannot be undone.

All transaction phases (e.g. transactions transaction groups and sub-transaction) that were explicitly started must be finished prior to calling this method.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | worksetNameGridLevel is an empty string. -or- worksetName is an empty string. -or- worksetNameGridLevel cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- worksetName cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~".
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | This method may not be called during dynamic update.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The document does not allow worksharing to be enabled. -or- This Document is in an edit mode. -or- This Document is a workshared document. -or- There is a transaction phase left open (such as a transaction, sub-transaction of transaction group) at the time of invoking this method.
Autodesk.Revit.Exceptions..::..OperationCanceledException | Enabling worksharing was cancelled.

See Also

Document Class


EraseSchemaAndAllEntities Method

[image]

Revit 2024 API
Document..::..EraseSchemaAndAllEntities Method
Document Class See Also Send Feedback
Erases Schema and all its Entities from the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public void EraseSchemaAndAllEntities(
    Schema schema
)
Visual Basic
Public Sub EraseSchemaAndAllEntities ( _
    schema As Schema _
)
Visual C++
public:
void EraseSchemaAndAllEntities(
    Schema^ schema
)

Parameters

schema
Type: Autodesk.Revit.DB.ExtensibleStorage..::..Schema
The Schema to erase.

Remarks

The Schema remains in memory.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | No write access to this Schema.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

Document Class


Export Method

[image] [image]

Revit 2024 API
Document..::..Export Method
Document Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Export(String, IList<(Of <<'(ElementId>)>>), PDFExportOptions) | Exports a selection of views in PDF format.
Public method | Export(String, String, GBXMLExportOptions) | Export the model in gbXML (green-building) format.
Public method | Export(String, String, IFCExportOptions) | Exports the document to the Industry Standard Classes (IFC) format.
Public method | Export(String, String, NavisworksExportOptions) | Exports a Revit project to the Navisworks .nwc format.
Public method | Export(String, String, OBJExportOptions) | Exports a view specified in the export options to the OBJ format.
Public method | Export(String, String, STLExportOptions) | Exports a view specified in the export options to the STL format.
Public method | Export(String, String, ViewSet, DWFExportOptions) | Exports the current view or a selection of views in DWF format.
Public method | Export(String, String, ViewSet, DWFXExportOptions) | Exports the current view or a selection of views in DWFX format.
Public method | Export(String, String, ViewSet, FBXExportOptions) | Exports the document in 3D-Studio Max (FBX) format.
Public method | Export(String, String, ICollection<(Of <<'(ElementId>)>>), DGNExportOptions) | Exports a selection of views in DGN format.
Public method | Export(String, String, ICollection<(Of <<'(ElementId>)>>), DWGExportOptions) | Exports a selection of views in DWG format.
Public method | Export(String, String, ICollection<(Of <<'(ElementId>)>>), DXFExportOptions) | Exports a selection of views in DXF format.
Public method | Export(String, String, ICollection<(Of <<'(ElementId>)>>), SATExportOptions) | Exports the current view or a selection of views in SAT format.

See Also

Document Class
Document Members


Export Method (String, IList(ElementId), PDFExportOptions)

[image]

Revit 2024 API
Document..::..Export Method (String, IList<(Of <(<'ElementId>)>)>, PDFExportOptions)
Document Class See Also Send Feedback
Exports a selection of views in PDF format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public bool Export(
    string folder,
    IList<ElementId> viewIds,
    PDFExportOptions options
)
Visual Basic
Public Function Export ( _
    folder As String, _
    viewIds As IList(Of ElementId), _
    options As PDFExportOptions _
) As Boolean
Visual C++
public:
bool Export(
    String^ folder,
    IList<ElementId^>^ viewIds,
    PDFExportOptions^ options
)

Parameters

folder
Type: System..::..String
Output folder, into which file(s) will be exported. The folder must exist.
viewIds
Type: System.Collections.Generic..::..IList<(Of <(<' ElementId >)>)>
Selection of ordered views to be exported. The list must contain at least one valid view.
options
Type: Autodesk.Revit.DB..::..PDFExportOptions
Various options applicable to the PDF format.

Return Value

True if all specified views are exported successfully, False if exporting of any view fails, even if some views might have been exported successfully.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | non empty list of views must be provided. -or- NullOrEmpty -or- There are duplicate views in viewIds -or- some of the views are not printable (exportable). -or- Thrown when one or more input arguments are invalid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..FileAccessException | Thrown when the target PDF file is inaccessible, e.g. already opened.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Export is temporarily disabled. -or- Exporting is not allowed in the current application mode.
Autodesk.Revit.Exceptions..::..InvalidPathArgumentException | The folder does not exist.

See Also

Document Class
Export Overload


Export Method (String, String, GBXMLExportOptions)

[image]

Revit 2024 API
Document..::..Export Method (String, String, GBXMLExportOptions)
Document Class See Also Send Feedback
Export the model in gbXML (green-building) format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool Export(
    string folder,
    string name,
    GBXMLExportOptions options
)
Visual Basic
Public Function Export ( _
    folder As String, _
    name As String, _
    options As GBXMLExportOptions _
) As Boolean
Visual C++
public:
bool Export(
    String^ folder,
    String^ name,
    GBXMLExportOptions^ options
)

Parameters

folder
Type: System..::..String
Indicates the path of a folder where to export the gbXML file.
name
Type: System..::..String
Indicates the name of the gbXML file to export. If it doesn't end with ".xml", extension ".xml" will be added automatically. The name cannot contain any of the following characters: \/:*?"<>|. Empty name is not acceptable.
options
Type: Autodesk.Revit.DB..::..GBXMLExportOptions
Options which control the contents of the export.

Return Value

True if successful, otherwise False.

Remarks

This export operation will operate on the main EnergyAnalysisDetailModel in the document, if it exists (see EnergyAnalysisDetailModel.GetMainEnergyAnalysisDetailModel()). If it does not exist, or if the requested ExportEnergyModelType does not match the type of the main EnergyAnalysisDetailModel, this function will fail. If you need to export a model with different settings or type than the current main energy model in the document, you should delete the current main energy model, update the EnergyAnalysisSettings, and regenerate the energy model.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The path is not valid for exporting gbXML files. -or- The name is empty or not valid for exporting gbXML files. -or- Analysis type is invalid. For AnalysisMode.ConceptualMasses, use Document.Export(String, String, MassGBXMLExportOptions). -or- There is no main EnergyAnalysisDetailModel in the document, or the current main EnergyAnalysisDetailModel is not compatible with the option set in the GBXMLExportOptions.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | Exporting is not allowed in the current application mode. -or- Export is temporarily disabled.

See Also

Document Class
Export Overload


Export Method (String, String, IFCExportOptions)

[image]

Revit 2024 API
Document..::..Export Method (String, String, IFCExportOptions)
Document Class See Also Send Feedback
Exports the document to the Industry Standard Classes (IFC) format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool Export(
    string folder,
    string name,
    IFCExportOptions options
)
Visual Basic
Public Function Export ( _
    folder As String, _
    name As String, _
    options As IFCExportOptions _
) As Boolean
Visual C++
public:
bool Export(
    String^ folder,
    String^ name,
    IFCExportOptions^ options
)

Parameters

folder
Type: System..::..String
Output folder into which the file will be exported. The folder must exist.
name
Type: System..::..String
Either the name of a single file or a prefix for a set of files. If empty, automatic naming will be used.
options
Type: Autodesk.Revit.DB..::..IFCExportOptions
Various options applicable to the IFC format. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.

Return Value

True if successful, otherwise False.

Remarks

Exporting to IFC requires that document is modifiable, therefore there must be a transaction already open when this method is called.

This method may not be invoked during dynamic update, for the internal routine might need to modify the existing transaction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | NullOrEmpty -or- Contains invalid characters.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | The IFCExportOptions FamilyMappingFile does not exist.
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | This method may not be called during dynamic update.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Export is temporarily disabled. -or- Exporting is not allowed in the current application mode. -or- This Document is not a project document.
Autodesk.Revit.Exceptions..::..InvalidPathArgumentException | The folder does not exist.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.
Autodesk.Revit.Exceptions..::..OptionalFunctionalityNotAvailableException | The IFC module is not available in the installed Revit.

See Also

Document Class
Export Overload


Export Method (String, String, NavisworksExportOptions)

[image]

Revit 2024 API
Document..::..Export Method (String, String, NavisworksExportOptions)
Document Class See Also Send Feedback
Exports a Revit project to the Navisworks .nwc format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void Export(
    string folder,
    string name,
    NavisworksExportOptions options
)
Visual Basic
Public Sub Export ( _
    folder As String, _
    name As String, _
    options As NavisworksExportOptions _
)
Visual C++
public:
void Export(
    String^ folder,
    String^ name,
    NavisworksExportOptions^ options
)

Parameters

folder
Type: System..::..String
The name of the folder for the exported file.
name
Type: System..::..String
The name of the exported file. If it doesn't end in '.nwc', this extension will be added automatically.
options
Type: Autodesk.Revit.DB..::..NavisworksExportOptions
Options which control the contents of the export.

Remarks

This is an optional functionality that does not have to be installed. The method "OptionalFunctionalityUtils.isNavisworksExporterAvailable()" can be called to check if the exporter is present.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | NullOrEmpty -or- Contains invalid characters. -or- The input options were not valid. Check the exception message for specific details.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | Export is temporarily disabled. -or- Exporting is not allowed in the current application mode.
Autodesk.Revit.Exceptions..::..InvalidPathArgumentException | The folder does not exist.
Autodesk.Revit.Exceptions..::..OperationCanceledException | The export operation is cancelled in event handler.
Autodesk.Revit.Exceptions..::..OptionalFunctionalityNotAvailableException | A Navisworks Exporter is not available in the installed Revit.

See Also

Document Class
Export Overload


Export Method (String, String, OBJExportOptions)

[image]

Revit 2024 API
Document..::..Export Method (String, String, OBJExportOptions)
Document Class See Also Send Feedback
Exports a view specified in the export options to the OBJ format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public bool Export(
    string folder,
    string name,
    OBJExportOptions options
)
Visual Basic
Public Function Export ( _
    folder As String, _
    name As String, _
    options As OBJExportOptions _
) As Boolean
Visual C++
public:
bool Export(
    String^ folder,
    String^ name,
    OBJExportOptions^ options
)

Parameters

folder
Type: System..::..String
Output folder into which the file will be exported. The folder must exist.
name
Type: System..::..String
Indicates the name of the OBJ file to export. If it doesn't end with ".obj", this extension will be added automatically. The name cannot contain any of the following characters: \/:*?"<>|. Empty name is not acceptable.
options
Type: Autodesk.Revit.DB..::..OBJExportOptions
Various options applicable to the OBJ format.

Return Value

True if successful, otherwise False.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | NullOrEmpty -or- Contains invalid characters. -or- The provided options do not specify a printable 3D view.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | This method may not be called during dynamic update.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Export is temporarily disabled. -or- Exporting is not allowed in the current application mode.
Autodesk.Revit.Exceptions..::..InvalidPathArgumentException | The folder does not exist.
Autodesk.Revit.Exceptions..::..OptionalFunctionalityNotAvailableException | The ShapeExporter functionality is not available in the installed Revit, or the Material Library is missing.

See Also

Document Class
Export Overload


Export Method (String, String, ViewSet, DWFExportOptions)

[image]

Revit 2024 API
Document..::..Export Method (String, String, ViewSet, DWFExportOptions)
Document Class Example See Also Send Feedback
Exports the current view or a selection of views in DWF format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool Export(
    string folder,
    string name,
    ViewSet views,
    DWFExportOptions options
)
Visual Basic
Public Function Export ( _
    folder As String, _
    name As String, _
    views As ViewSet, _
    options As DWFExportOptions _
) As Boolean
Visual C++
public:
bool Export(
    String^ folder,
    String^ name,
    ViewSet^ views,
    DWFExportOptions^ options
)

Parameters

folder
Type: System..::..String
Output folder, into which file(s) will be exported. The folder must exist.
name
Type: System..::..String
Either the name of a single file or a prefix for a set of files. If nullNothingnullptra null reference (Nothing in Visual Basic) or empty, automatic naming will be used.
views
Type: Autodesk.Revit.DB..::..ViewSet
Selection of views to be exported.
options
Type: Autodesk.Revit.DB..::..DWFExportOptions
Various options applicable to the DWF format. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.

Return Value

Function returns true only if all specified views are exported successfully. Returns False if exporting of any view fails, even if some views might have been exported successfully.

Remarks

All the views must be printable in order for the Export to succeed. It can be assured by checking the CanBePrinted property of each view.

Examples

CopyC#
public bool ExportViewToDWF(Document document, View view, string pathname)
{
    DWFExportOptions dwfOptions = new DWFExportOptions();
    // export with crop box and area and room geometry
    dwfOptions.CropBoxVisible = true;
    dwfOptions.ExportingAreas = true;
    dwfOptions.ExportTexture = false;

    ViewSet views = new ViewSet();
    views.Insert(view);
    return (document.Export(Path.GetDirectoryName(pathname),
        Path.GetFileNameWithoutExtension(pathname), views, dwfOptions));
}
CopyVB.NET
Public Function ExportViewToDWF(document As Document, view As View, pathname As String) As Boolean
   Dim dwfOptions As New DWFExportOptions()
   ' export with crop box and area and room geometry
   dwfOptions.CropBoxVisible = True
   dwfOptions.ExportingAreas = True
   dwfOptions.ExportTexture = False

   Dim views As New ViewSet()
   views.Insert(view)
   Return (document.Export(Path.GetDirectoryName(pathname), Path.GetFileNameWithoutExtension(pathname), views, dwfOptions))
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input views is nullNothingnullptra null reference (Nothing in Visual Basic)
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input views is an empty ViewSet.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the current document is not modifiable.

See Also

Document Class
Export Overload


Export Method (String, String, ViewSet, FBXExportOptions)

[image]

Revit 2024 API
Document..::..Export Method (String, String, ViewSet, FBXExportOptions)
Document Class See Also Send Feedback
Exports the document in 3D-Studio Max (FBX) format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool Export(
    string folder,
    string name,
    ViewSet views,
    FBXExportOptions options
)
Visual Basic
Public Function Export ( _
    folder As String, _
    name As String, _
    views As ViewSet, _
    options As FBXExportOptions _
) As Boolean
Visual C++
public:
bool Export(
    String^ folder,
    String^ name,
    ViewSet^ views,
    FBXExportOptions^ options
)

Parameters

folder
Type: System..::..String
Output folder, into which file(s) will be exported. The folder must exist.
name
Type: System..::..String
Either the name of a single file or a prefix for a set of files. If nullNothingnullptra null reference (Nothing in Visual Basic) or empty, automatic naming will be used.
views
Type: Autodesk.Revit.DB..::..ViewSet
Selection of views to be exported.Only 3D views are allowed.
options
Type: Autodesk.Revit.DB..::..FBXExportOptions
Options applicable to the FBX format.

Return Value

Function returns true only if all specified views are exported successfully. The function returns False if exporting of any view fails, even if some views might have been exported successfully.

Remarks

Though the 'options' argument is not currently used, an object still must be provided (may be nullNothingnullptra null reference (Nothing in Visual Basic)).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input views is nullNothingnullptra null reference (Nothing in Visual Basic)
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input views is an empty ViewSet. Thrown if any view in the views is not a 3D view.

See Also

Document Class
Export Overload


Export Method (String, String, ICollection(ElementId), DGNExportOptions)

[image]

Revit 2024 API
Document..::..Export Method (String, String, ICollection<(Of <(<'ElementId>)>)>, DGNExportOptions)
Document Class Example See Also Send Feedback
Exports a selection of views in DGN format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool Export(
    string folder,
    string name,
    ICollection<ElementId> views,
    DGNExportOptions options
)
Visual Basic
Public Function Export ( _
    folder As String, _
    name As String, _
    views As ICollection(Of ElementId), _
    options As DGNExportOptions _
) As Boolean
Visual C++
public:
bool Export(
    String^ folder,
    String^ name,
    ICollection<ElementId^>^ views,
    DGNExportOptions^ options
)

Parameters

folder
Type: System..::..String
Output folder, into which file(s) will be exported. The folder must exist.
name
Type: System..::..String
Either the name of a single file or a prefix for a set of files. If empty, automatic naming will be used. If nullNothingnullptra null reference (Nothing in Visual Basic), throw ArgumentException.
views
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
Selection of views to be exported. The set must contain at least one valid view.
options
Type: Autodesk.Revit.DB..::..DGNExportOptions
Various options applicable to the DGN format. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.

Return Value

True if successful, otherwise False.

Remarks

All the views must be printable for the Export to succeed. It can be assured by checking the CanBePrinted property of each view.

Examples

CopyC#
public bool ExportDGN(Document document, View view)
{
    bool exported = false;
    // Get predefined setups and use the first one
    IList<string> setupNames = BaseExportOptions.GetPredefinedSetupNames(document);
    if (setupNames.Count > 0)
    {
        // Get predefined options for first predefined setup
        DGNExportOptions dgnOptions = DGNExportOptions.GetPredefinedOptions(document, setupNames[0]);

        // export the active view if it is printable
        if (view.CanBePrinted == true)
        {
            ICollection<ElementId> views = new List<ElementId>();
            views.Add(view.Id);
            exported = document.Export(Path.GetDirectoryName(document.PathName),
                Path.GetFileNameWithoutExtension(document.PathName), views, dgnOptions);
        }
    }

    return exported;
}
CopyVB.NET
Public Function ExportDGN(document As Document, view As View) As Boolean
   Dim exported As Boolean = False
   ' Get predefined setups and use the first one
   Dim setupNames As IList(Of String) = BaseExportOptions.GetPredefinedSetupNames(document)
   If setupNames.Count > 0 Then
      ' Get predefined options for first predefined setup
      Dim dgnOptions As DGNExportOptions = DGNExportOptions.GetPredefinedOptions(document, setupNames(0))

      ' export the active view if it is printable
      If view.CanBePrinted = True Then
         Dim views As ICollection(Of ElementId) = New List(Of ElementId)()
         views.Add(view.Id)
         exported = document.Export(Path.GetDirectoryName(document.PathName), Path.GetFileNameWithoutExtension(document.PathName), views, dgnOptions)
      End If
   End If

   Return exported
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | NullOrEmpty -or- Contains invalid characters. -or- non empty list of views must be provided. -or- some of the views are not printable (exportable). -or- Thrown when the options in DGNExportOptions is invalid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..DirectoryNotFoundException | Thrown when the directory does not exist.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Export is temporarily disabled. -or- Exporting is not allowed in the current application mode.
Autodesk.Revit.Exceptions..::..InvalidPathArgumentException | The folder does not exist.
Autodesk.Revit.Exceptions..::..OptionalFunctionalityNotAvailableException | The DWG module is not available in the installed Revit. -or- The Graphics module is not available in the installed Revit.

See Also

Document Class
Export Overload


Export Method (String, String, ICollection(ElementId), DWGExportOptions)

[image]

Revit 2024 API
Document..::..Export Method (String, String, ICollection<(Of <(<'ElementId>)>)>, DWGExportOptions)
Document Class Example See Also Send Feedback
Exports a selection of views in DWG format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool Export(
    string folder,
    string name,
    ICollection<ElementId> views,
    DWGExportOptions options
)
Visual Basic
Public Function Export ( _
    folder As String, _
    name As String, _
    views As ICollection(Of ElementId), _
    options As DWGExportOptions _
) As Boolean
Visual C++
public:
bool Export(
    String^ folder,
    String^ name,
    ICollection<ElementId^>^ views,
    DWGExportOptions^ options
)

Parameters

folder
Type: System..::..String
Output folder, into which file(s) will be exported. The folder must exist.
name
Type: System..::..String
Either the name of a single file or a prefix for a set of files. If empty, automatic naming will be used. If nullNothingnullptra null reference (Nothing in Visual Basic), throw ArgumentException.
views
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
Selection of views to be exported. The set must contain at least one valid view.
options
Type: Autodesk.Revit.DB..::..DWGExportOptions
Various options applicable to the DWG format. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.

Return Value

True if successful, otherwise False.

Remarks

All the views must be printable for the Export to succeed. It can be assured by checking the CanBePrinted property of each view.

Examples

CopyC#
public bool ExportDWG(Document document, View view, string setupName)
{
    bool exported = false;
    // Get the predefined setups and use the one with the given name.
    IList<string> setupNames = BaseExportOptions.GetPredefinedSetupNames(document);
    foreach (string name in setupNames)
    {
        if (name.CompareTo(setupName) == 0)
        {
            // Export using the predefined options
            DWGExportOptions dwgOptions = DWGExportOptions.GetPredefinedOptions(document, name);

            // Export the active view
            ICollection<ElementId> views = new List<ElementId>();
            views.Add(view.Id);
            // The document has to be saved already, therefore it has a valid PathName.
            exported = document.Export(Path.GetDirectoryName(document.PathName),
                Path.GetFileNameWithoutExtension(document.PathName), views, dwgOptions);
            break;
        }
    }

    return exported;
}
CopyVB.NET
Public Function ExportDWG(document As Document, view As View, setupName As String) As Boolean
   Dim exported As Boolean = False
   ' Get the predefined setups and use the one with the given name.
   Dim setupNames As IList(Of String) = BaseExportOptions.GetPredefinedSetupNames(document)
   For Each name As String In setupNames
      If name.CompareTo(setupName) = 0 Then
         ' Export using the predefined options
         Dim dwgOptions As DWGExportOptions = DWGExportOptions.GetPredefinedOptions(document, name)

         ' Export the active view
         Dim views As ICollection(Of ElementId) = New List(Of ElementId)()
         views.Add(view.Id)
         ' The document has to be saved already, therefore it has a valid PathName.
         exported = document.Export(Path.GetDirectoryName(document.PathName), Path.GetFileNameWithoutExtension(document.PathName), views, dwgOptions)
         Exit For
      End If
   Next

   Return exported
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | NullOrEmpty -or- Contains invalid characters. -or- non empty list of views must be provided. -or- some of the views are not printable (exportable). -or- The modifiers set in layer info must be valid. -or- Thrown when the options in DWGExportOptions is invalid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..DirectoryNotFoundException | Thrown when the directory does not exist.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Export is temporarily disabled. -or- Exporting is not allowed in the current application mode.
Autodesk.Revit.Exceptions..::..InvalidPathArgumentException | The folder does not exist.
Autodesk.Revit.Exceptions..::..OptionalFunctionalityNotAvailableException | The DWG module is not available in the installed Revit. -or- The Graphics module is not available in the installed Revit.

See Also

Document Class
Export Overload


ExportImage Method

[image]

Revit 2024 API
Document..::..ExportImage Method
Document Class See Also Send Feedback
Exports a view or set of views into an image file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public void ExportImage(
    ImageExportOptions options
)
Visual Basic
Public Sub ExportImage ( _
    options As ImageExportOptions _
)
Visual C++
public:
void ExportImage(
    ImageExportOptions^ options
)

Parameters

options
Type: Autodesk.Revit.DB..::..ImageExportOptions
The options which govern the image export.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The current view cannot be exported as an image
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..FileAccessException | The path indicated could not be accessed.
Autodesk.Revit.Exceptions..::..FileNotFoundException | The path indicated could not be found.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Exporting is not allowed in the current application mode. -or- Failed to export image due to an error with the inputs. -or- Failed to export image due to an issue where the DirectX Device was lost.
Autodesk.Revit.Exceptions..::..OptionalFunctionalityNotAvailableException | The Graphics module is not available in the installed Revit.

See Also

Document Class


GetChangedElements Method

[image]

Revit 2024 API
Document..::..GetChangedElements Method
Document Class Example See Also Send Feedback
Extracts a collection containing the ids of elements that have been created, modified or deleted between the input baseVersion and the document's current version.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public DocumentDifference GetChangedElements(
    Guid baseVersionGUID
)
Visual Basic
Public Function GetChangedElements ( _
    baseVersionGUID As Guid _
) As DocumentDifference
Visual C++
public:
DocumentDifference^ GetChangedElements(
    Guid baseVersionGUID
)

Parameters

baseVersionGUID
Type: System..::..Guid
GUID of base version(excluded) to compare. This GUID should be retrieved from property [!:Autodesk::Revit::DB::DocumentVersion::VersoinGUID]. Empty GUID is allowed to retrieve changes of each version in the document.

Return Value

An object containing collections of the created, modified and deleted ids between the input version and current version.

Examples

CopyC#
private void ShowChangedElements(Autodesk.Revit.DB.Document document, Guid baseVerseionGuid)
{
    //Parameter baseVersionGuid is retrieved from property VersionGUID of Autodesk.Revit.DB.DocumentVersion.
    //System.Guid.Empty is allowed to get all changes in document.
    DocumentDifference docDiff = document.GetChangedElements(baseVerseionGuid);
    if (docDiff.AreDeletedElementIdsAvailable)
    {
        TaskDialog.Show("Revit", "Deleted element history is available in current document.");
    }
    else
    {
        TaskDialog.Show("Revit", "Deleted element history is not available in current document.");
    }

    // New added elements.
    var createdElementIds = docDiff.GetCreatedElementIds();

    // Modified elements.
    var modifiedElementIds = docDiff.GetModifiedElementIds();

    // Deleted elements.
    // For nonworkshared model, always returns an empty collection.
    var deletedElementIds = docDiff.GetDeletedElementIds();

    var changesetMessage = $"Found {createdElementIds.Count} new created elements, {modifiedElementIds.Count} modified elements and {deletedElementIds.Count} deleted elements.";
    TaskDialog.Show("Revit", changesetMessage);
}
CopyVB.NET
Private Sub ShowChangedElements(ByVal document As Document, ByVal baseVerseionGuid As Guid)
    'Parameter baseVersionGuid is retrieved from property VersionGUID of Autodesk.Revit.DB.DocumentVersion.
    'System.Guid.Empty is allowed to get all changes in document.
    Dim docDiff = document.GetChangedElements(baseVerseionGuid)

    If docDiff.AreDeletedElementIdsAvailable Then
        TaskDialog.Show("Revit", "Deleted element history is available in current document.")
    Else
        TaskDialog.Show("Revit", "Deleted element history is not available in current document.")
    End If

    ' New added elements.
    Dim createdElementIds = docDiff.GetCreatedElementIds()

    ' Modified elements.
    Dim modifiedElementIds = docDiff.GetModifiedElementIds()

    ' Deleted elements.
    ' For nonworkshared model, always returns an empty collection.
    Dim deletedElementIds = docDiff.GetDeletedElementIds()
    Dim changesetMessage = $"Found {createdElementIds.Count} new created elements, {modifiedElementIds.Count} modified elements and {deletedElementIds.Count} deleted elements."
    TaskDialog.Show("Revit", changesetMessage)
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This GUID is invalid in the given document.

See Also

Document Class


GetCloudModelPath Method

[image]

Revit 2024 API
Document..::..GetCloudModelPath Method
Document Class See Also Send Feedback
Gets the cloud model path of the cloud model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019.1

Syntax

C#
public ModelPath GetCloudModelPath()
Visual Basic
Public Function GetCloudModelPath As ModelPath
Visual C++
public:
ModelPath^ GetCloudModelPath()

Return Value

The cloud model path

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This Document is a not cloud model, cannot execute this operation.

See Also

Document Class


GetCloudModelUrn Method

[image]

Revit 2024 API
Document..::..GetCloudModelUrn Method
Document Class See Also Send Feedback
A ForgeDM Urn identifying the model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public string GetCloudModelUrn()
Visual Basic
Public Function GetCloudModelUrn As String
Visual C++
public:
String^ GetCloudModelUrn()

Remarks

It is empty for non-cloud model; It is cached in Revit model opened session after getting it;

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..RevitServerUnauthorizedException | Thrown when cannot get data from ForgeDM.

See Also

Document Class


GetDefaultElementTypeId Method

[image]

Revit 2024 API
Document..::..GetDefaultElementTypeId Method
Document Class Example See Also Send Feedback
Gets the default element type id with the given DefaultElementType id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public ElementId GetDefaultElementTypeId(
    ElementTypeGroup defaultTypeId
)
Visual Basic
Public Function GetDefaultElementTypeId ( _
    defaultTypeId As ElementTypeGroup _
) As ElementId
Visual C++
public:
ElementId^ GetDefaultElementTypeId(
    ElementTypeGroup defaultTypeId
)

Parameters

defaultTypeId
Type: Autodesk.Revit.DB..::..ElementTypeGroup
The default element type id.

Return Value

The element type id.

Examples

CopyC#
private bool IsWallUsingDefaultType(Document document, Wall wall)
{
    ElementId defaultElementTypeId = document.GetDefaultElementTypeId(ElementTypeGroup.WallType);
    return (wall.WallType.Id == defaultElementTypeId);
}
CopyVB.NET
Private Function IsWallUsingDefaultType(document As Document, wall As Wall) As Boolean
   Dim defaultElementTypeId As ElementId = document.GetDefaultElementTypeId(ElementTypeGroup.WallType)
   Return (wall.WallType.Id = defaultElementTypeId)
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

Document Class


GetDefaultFamilyTypeId Method

[image]

Revit 2024 API
Document..::..GetDefaultFamilyTypeId Method
Document Class Example See Also Send Feedback
Gets the default family type id with the given family category id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public ElementId GetDefaultFamilyTypeId(
    ElementId familyCategoryId
)
Visual Basic
Public Function GetDefaultFamilyTypeId ( _
    familyCategoryId As ElementId _
) As ElementId
Visual C++
public:
ElementId^ GetDefaultFamilyTypeId(
    ElementId^ familyCategoryId
)

Parameters

familyCategoryId
Type: Autodesk.Revit.DB..::..ElementId
The family category id.

Return Value

The default family type id.

Examples

CopyC#
private void AssignDefaultTypeToColumn(Document document, FamilyInstance column)
{
    ElementId defaultTypeId = document.GetDefaultFamilyTypeId(new ElementId(BuiltInCategory.OST_StructuralColumns));

    if (defaultTypeId != ElementId.InvalidElementId)
    {
        FamilySymbol defaultType = document.GetElement(defaultTypeId) as FamilySymbol;
        if (defaultType != null)
        {
            column.Symbol = defaultType;
        }
    }
}
CopyVB.NET
Private Sub AssignDefaultTypeToColumn(document As Document, column As FamilyInstance)
   Dim defaultTypeId As ElementId = document.GetDefaultFamilyTypeId(New ElementId(BuiltInCategory.OST_StructuralColumns))

   If defaultTypeId <> ElementId.InvalidElementId Then
      Dim defaultType As FamilySymbol = TryCast(document.GetElement(defaultTypeId), FamilySymbol)
      If defaultType IsNot Nothing Then
         column.Symbol = defaultType
      End If
   End If
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Document Class


GetDocumentPreviewSettings Method

[image]

Revit 2024 API
Document..::..GetDocumentPreviewSettings Method
Document Class See Also Send Feedback
Returns the preview settings for the given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public DocumentPreviewSettings GetDocumentPreviewSettings()
Visual Basic
Public Function GetDocumentPreviewSettings As DocumentPreviewSettings
Visual C++
public:
DocumentPreviewSettings^ GetDocumentPreviewSettings()

Return Value

The preview settings.

See Also

Document Class


GetDocumentVersion Method

[image]

Revit 2024 API
Document..::..GetDocumentVersion Method
Document Class See Also Send Feedback
Gets the DocumentVersion that corresponds to a document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static DocumentVersion GetDocumentVersion(
    Document doc
)
Visual Basic
Public Shared Function GetDocumentVersion ( _
    doc As Document _
) As DocumentVersion
Visual C++
public:
static DocumentVersion^ GetDocumentVersion(
    Document^ doc
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The document whose DocumentVersion will be returned.

Return Value

The DocumentVersion corresponding to the given document.

Remarks

This function can be combined with IsModified to see whether a document in memory is different from a version on disk. The documents are different if the document is modified or if the two DocumentVersions differ.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Document Class


GetElement Method

[image] [image]

Revit 2024 API
Document..::..GetElement Method
Document Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetElement(String) | Gets the Element referenced by a unique id string.
Public method | GetElement(ElementId) | Gets the Element referenced by the input ElementId.
Public method | GetElement(Reference) | Gets the Element referenced by the input reference.

See Also

Document Class
Document Members


GetElement Method (String)

[image]

Revit 2024 API
Document..::..GetElement Method (String)
Document Class See Also Send Feedback
Gets the Element referenced by a unique id string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public Element GetElement(
    string uniqueId
)
Visual Basic
Public Function GetElement ( _
    uniqueId As String _
) As Element
Visual C++
public:
Element^ GetElement(
    String^ uniqueId
)

Parameters

uniqueId
Type: System..::..String
The element unique id, whose referenced Element will be retrieved from the model.
  • UniqueId

    • Return Value

    The element referenced by the input argument.

    Remarks

    nullNothingnullptra null reference (Nothing in Visual Basic) will be returned if the input id string doesn't reference to a valid Element.

    Exceptions

    Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

    See Also

    Document Class
    GetElement Overload


GetElement Method (Reference)

[image]

Revit 2024 API
Document..::..GetElement Method (Reference)
Document Class See Also Send Feedback
Gets the Element referenced by the input reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public Element GetElement(
    Reference reference
)
Visual Basic
Public Function GetElement ( _
    reference As Reference _
) As Element
Visual C++
public:
Element^ GetElement(
    Reference^ reference
)

Parameters

reference
Type: Autodesk.Revit.DB..::..Reference
The reference, whose referenced Element will be retrieved from the model.

Return Value

The element referenced by the input argument.

Remarks

nullNothingnullptra null reference (Nothing in Visual Basic) will be returned if the input reference doesn't reference to a valid Element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Document Class
GetElement Overload


GetHashCode Method

[image]

Revit 2024 API
Document..::..GetHashCode Method
Document Class See Also Send Feedback
Gets the hash code of this document instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Remarks

The hash code is the same for document instances that represent the same document currently opened in the Revit session. The hash code is generated when a Revit file is opened or created in session. If the same Revit file is opened later (in the same session or a different session) the hash code will not be the same.

See Also

Document Class


GetPaintedMaterial Method

[image]

Revit 2024 API
Document..::..GetPaintedMaterial Method
Document Class See Also Send Feedback
Get the material painted on the element's face. Returns invalidElementId if the face is not painted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ElementId GetPaintedMaterial(
    ElementId elementId,
    Face face
)
Visual Basic
Public Function GetPaintedMaterial ( _
    elementId As ElementId, _
    face As Face _
) As ElementId
Visual C++
public:
ElementId^ GetPaintedMaterial(
    ElementId^ elementId,
    Face^ face
)

Parameters

elementId
Type: Autodesk.Revit.DB..::..ElementId
The element that the face belongs to.
face
Type: Autodesk.Revit.DB..::..Face
The painted element's face.

Return Value

The material's Id painted on the element's face.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element elementId does not exist in the document -or- The face doesn't belong to the element
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Document Class


GetPrintSettingIds Method

[image]

Revit 2024 API
Document..::..GetPrintSettingIds Method
Document Class See Also Send Feedback
Retrieves all Print Settings of current project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ICollection<ElementId> GetPrintSettingIds()
Visual Basic
Public Function GetPrintSettingIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetPrintSettingIds()

Return Value

The ElementIds of all print setting elements

See Also

Document Class


GetProjectId Method

[image]

Revit 2024 API
Document..::..GetProjectId Method
Document Class See Also Send Feedback
Gets ForgeDM project id where the model locates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public string GetProjectId()
Visual Basic
Public Function GetProjectId As String
Visual C++
public:
String^ GetProjectId()

Remarks

It is empty for non-cloud model; It is cached in Revit model opened session after getting it;

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..RevitServerUnauthorizedException | Thrown when cannot get data from ForgeDM for Revit cloud model.

See Also

Document Class


GetRoomAtPoint Method

[image] [image]

Revit 2024 API
Document..::..GetRoomAtPoint Method
Document Class See Also Send Feedback
Gets a room containing the point.

Overload List

 | Name | Description
Public method | GetRoomAtPoint(XYZ) | Gets a room containing the point.
Public method | GetRoomAtPoint(XYZ, Phase) | Gets a room containing the point.

See Also

Document Class
Document Members


GetRoomAtPoint Method (XYZ)

[image]

Revit 2024 API
Document..::..GetRoomAtPoint Method (XYZ)
Document Class See Also Send Feedback
Gets a room containing the point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Room GetRoomAtPoint(
    XYZ point
)
Visual Basic
Public Function GetRoomAtPoint ( _
    point As XYZ _
) As Room
Visual C++
public:
Room^ GetRoomAtPoint(
    XYZ^ point
)

Parameters

point
Type: Autodesk.Revit.DB..::..XYZ
Point to be checked.

Return Value

The room containing the point.

Remarks

Surveys only the rooms from the final phase of the project. The first one found will be returned. If there is no room containing the point, it returns nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the point is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the coordinates of the point are not number or are Double::MaxValue or Double::MinValue.

See Also

Document Class
GetRoomAtPoint Overload


GetRoomAtPoint Method (XYZ, Phase)

[image]

Revit 2024 API
Document..::..GetRoomAtPoint Method (XYZ, Phase)
Document Class See Also Send Feedback
Gets a room containing the point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Room GetRoomAtPoint(
    XYZ point,
    Phase phase
)
Visual Basic
Public Function GetRoomAtPoint ( _
    point As XYZ, _
    phase As Phase _
) As Room
Visual C++
public:
Room^ GetRoomAtPoint(
    XYZ^ point,
    Phase^ phase
)

Parameters

point
Type: Autodesk.Revit.DB..::..XYZ
Point to be checked.
phase
Type: Autodesk.Revit.DB..::..Phase
Phase in which the room exists.

Return Value

The room containing the point.

Remarks

If phase is nullNothingnullptra null reference (Nothing in Visual Basic), it will get the room of the last phase.The first one found will be returned. If there is no room containing the point, it returns nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the point is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the coordinates of the point are not number or are Double::MaxValue or Double::MinValue.

See Also

Document Class
GetRoomAtPoint Overload


GetSpaceAtPoint Method

[image] [image]

Revit 2024 API
Document..::..GetSpaceAtPoint Method
Document Class See Also Send Feedback
Gets a space containing the point.

Overload List

 | Name | Description
Public method | GetSpaceAtPoint(XYZ) | Gets a space containing the point.
Public method | GetSpaceAtPoint(XYZ, Phase) | Gets a space containing the point.

See Also

Document Class
Document Members


GetSpaceAtPoint Method (XYZ)

[image]

Revit 2024 API
Document..::..GetSpaceAtPoint Method (XYZ)
Document Class See Also Send Feedback
Gets a space containing the point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Space GetSpaceAtPoint(
    XYZ point
)
Visual Basic
Public Function GetSpaceAtPoint ( _
    point As XYZ _
) As Space
Visual C++
public:
Space^ GetSpaceAtPoint(
    XYZ^ point
)

Parameters

point
Type: Autodesk.Revit.DB..::..XYZ
Point to be checked.

Return Value

The space containing the point.

Remarks

Surveys only the spaces from the final phase of the project. The first one found will be returned. If there is no space containing the point, it returns nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the point is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the coordinates of the point are not number or are Double::MaxValue or Double::MinValue.

See Also

Document Class
GetSpaceAtPoint Overload


GetSpaceAtPoint Method (XYZ, Phase)

[image]

Revit 2024 API
Document..::..GetSpaceAtPoint Method (XYZ, Phase)
Document Class See Also Send Feedback
Gets a space containing the point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Space GetSpaceAtPoint(
    XYZ point,
    Phase phase
)
Visual Basic
Public Function GetSpaceAtPoint ( _
    point As XYZ, _
    phase As Phase _
) As Space
Visual C++
public:
Space^ GetSpaceAtPoint(
    XYZ^ point,
    Phase^ phase
)

Parameters

point
Type: Autodesk.Revit.DB..::..XYZ
Point to be checked.
phase
Type: Autodesk.Revit.DB..::..Phase
Phase in which the space exists.

Return Value

The space containing the point.

Remarks

If phase is nullNothingnullptra null reference (Nothing in Visual Basic), it will get the space of the last phase.The first one found will be returned. If there is no space containing the point, it returns nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the point is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the coordinates of the point are not number or are Double::MaxValue or Double::MinValue.

See Also

Document Class
GetSpaceAtPoint Overload


GetSubelement Method (String)

[image]

Revit 2024 API
Document..::..GetSubelement Method (String)
Document Class See Also Send Feedback
Gets the subelement referenced by a unique id string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public Subelement GetSubelement(
    string uniqueId
)
Visual Basic
Public Function GetSubelement ( _
    uniqueId As String _
) As Subelement
Visual C++
public:
Subelement^ GetSubelement(
    String^ uniqueId
)

Parameters

uniqueId
Type: System..::..String
The unique id that identifies element or subelement.
  • UniqueId

    • Return Value

    The subelement referenced by the input argument.

    Remarks

    nullNothingnullptra null reference (Nothing in Visual Basic) will be returned if the input id string doesn't reference to a valid element or subelement.

    Exceptions

    Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

    See Also

    Document Class
    GetSubelement Overload


GetSubelement Method (Reference)

[image]

Revit 2024 API
Document..::..GetSubelement Method (Reference)
Document Class See Also Send Feedback
Gets the subelement referenced by the input reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public Subelement GetSubelement(
    Reference reference
)
Visual Basic
Public Function GetSubelement ( _
    reference As Reference _
) As Subelement
Visual C++
public:
Subelement^ GetSubelement(
    Reference^ reference
)

Parameters

reference
Type: Autodesk.Revit.DB..::..Reference
The reference that identifies element or subelement.

Return Value

The subelement referenced by the input argument.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | reference does not identify a valid element or subelement.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Document Class
GetSubelement Overload


GetSubelement Method (ElementId, Int32)

[image]

Revit 2024 API
Document..::..GetSubelement Method (ElementId, Int32)
Document Class See Also Send Feedback
Gets the subelement referenced by a parent id and subelement id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public Subelement GetSubelement(
    ElementId id,
    int subId
)
Visual Basic
Public Function GetSubelement ( _
    id As ElementId, _
    subId As Integer _
) As Subelement
Visual C++
public:
Subelement^ GetSubelement(
    ElementId^ id,
    int subId
)

Parameters

id
Type: Autodesk.Revit.DB..::..ElementId
Id of the element.
subId
Type: System..::..Int32
Id of the sub element.

Return Value

The subelement referenced by the input argument.

Remarks

nullNothingnullptra null reference (Nothing in Visual Basic) will be returned if the input id string doesn't reference to a valid element or subelement.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Document Class
GetSubelement Overload


GetTypeOfStorage Method

[image]

Revit 2024 API
Document..::..GetTypeOfStorage Method
Document Class See Also Send Feedback
Get the storage type of the identified built-in parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public StorageType GetTypeOfStorage(
    ForgeTypeId parameterTypeId
)
Visual Basic
Public Function GetTypeOfStorage ( _
    parameterTypeId As ForgeTypeId _
) As StorageType
Visual C++
public:
StorageType GetTypeOfStorage(
    ForgeTypeId^ parameterTypeId
)

Parameters

parameterTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
Identifier of the built-in parameter.

Return Value

Storage type of the built-in parameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | parameterTypeId does not identify a built-in parameter. See Parameter.IsBuiltInParameter(ForgeTypeId) and Parameter.GetParameterTypeId(BuiltInParameter).
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Document Class


GetUnits Method

[image]

Revit 2024 API
Document..::..GetUnits Method
Document Class See Also Send Feedback
Gets the Units object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public Units GetUnits()
Visual Basic
Public Function GetUnits As Units
Visual C++
public:
Units^ GetUnits()

Return Value

The Units object.

See Also

Document Class


GetWarnings Method

[image]

Revit 2024 API
Document..::..GetWarnings Method
Document Class See Also Send Feedback
Returns list of failure messages generated from persistent (reviewable) warnings accumulated in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public IList<FailureMessage> GetWarnings()
Visual Basic
Public Function GetWarnings As IList(Of FailureMessage)
Visual C++
public:
IList<FailureMessage^>^ GetWarnings()

Return Value

List of failure messages representing warnings accumulated in the document.

Remarks

Function returns list of failure messages identical to the list displayed in a warning dialog when command Manage tab->Inquiry pane->Review Warnings is issued through the UI. Operations performed on the returned list by the caller do not impact information about warnings stored in the document.

See Also

Document Class


GetWorksetId Method

[image]

Revit 2024 API
Document..::..GetWorksetId Method
Document Class See Also Send Feedback
Get Id of the Workset which owns the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public WorksetId GetWorksetId(
    ElementId id
)
Visual Basic
Public Function GetWorksetId ( _
    id As ElementId _
) As WorksetId
Visual C++
public:
WorksetId^ GetWorksetId(
    ElementId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::..ElementId
Id of the element.

Return Value

Id of the Workset which owns the element.

Remarks

Each element belongs to one and only one workset.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Document Class


GetWorksetTable Method

[image]

Revit 2024 API
Document..::..GetWorksetTable Method
Document Class See Also Send Feedback
Get the WorksetTable of this document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public WorksetTable GetWorksetTable()
Visual Basic
Public Function GetWorksetTable As WorksetTable
Visual C++
public:
WorksetTable^ GetWorksetTable()

Return Value

The WorksetTable of this document.

Remarks

There is one WorksetTable for each document. There will be at least one workset in the table, even if sharing has not yet been enabled for this document.

See Also

Document Class


GetWorksharingCentralModelPath Method

[image]

Revit 2024 API
Document..::..GetWorksharingCentralModelPath Method
Document Class See Also Send Feedback
Gets the central model path of the worksharing model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ModelPath GetWorksharingCentralModelPath()
Visual Basic
Public Function GetWorksharingCentralModelPath As ModelPath
Visual C++
public:
ModelPath^ GetWorksharingCentralModelPath()

Return Value

The central model path, or null if the document is not workshared.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This Document is not a workshared document.

See Also

Document Class


HasAllChangesFromCentral Method

[image]

Revit 2024 API
Document..::..HasAllChangesFromCentral Method
Document Class Example See Also Send Feedback
Returns whether the model in the current session is up to date with central.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool HasAllChangesFromCentral()
Visual Basic
Public Function HasAllChangesFromCentral As Boolean
Visual C++
public:
bool HasAllChangesFromCentral()

Return Value

True means up to date; false means out of date.

If central is locked but Revit can determine that the model in the current session is out of date without opening central, this method will return false instead of throwing CentralModelContentionException.

Examples

CopyC#
void ReloadDocument(Document doc)
{
    ReloadLatestOptions reloadOpts = new ReloadLatestOptions();
    try
    {
        doc.ReloadLatest(reloadOpts);
        // Check to make sure no new changes were synced with Central during reload
        if (doc.HasAllChangesFromCentral() == false)
        {
            // If there are changes from central, reload again
            doc.ReloadLatest(reloadOpts);
        }
    }
    catch (Exception e)
    {
        TaskDialog.Show("Reload Failed", e.Message);
    }
}
CopyVB.NET
Private Sub ReloadDocument(doc As Document)
    Dim reloadOpts As New ReloadLatestOptions()
    Try
        doc.ReloadLatest(reloadOpts)
        ' Check to make sure no new changes were synced with Central during reload
        If doc.HasAllChangesFromCentral() = False Then
            ' If there are changes from central, reload again
            doc.ReloadLatest(reloadOpts)
        End If
    Catch e As Exception
        TaskDialog.Show("Reload Failed", e.Message)
    End Try
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..CentralFileCommunicationException | The file-based central model could not be reached, because e.g. the network is down or the file server is down.
Autodesk.Revit.Exceptions..::..CentralModelAccessDeniedException | Access to the central model was denied due to lack of access privileges. -or- Access to the central model was denied. A possible reason is because the model was under maintenance.
Autodesk.Revit.Exceptions..::..CentralModelContentionException | The central model is locked by another client.
Autodesk.Revit.Exceptions..::..CentralModelException | Username does not match the one used to create the local file. -or- The central model has been replaced by a local model. -or- Local incompatible because it was closed without saving after synchronizing with central. -or- The central model is missing. -or- The central model is incompatible. -or- The central model is corrupt or not an RVT file. -or- The central model was rolled back. -or- The central model's elements have been relinquished -or- The central model is overritten by other user. -or- An internal error happened on the central model, please contact the server administrator.
Autodesk.Revit.Exceptions..::..FileNotFoundException | Cannot access the local file.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This Document is not a workshared document. -or- This Document is a local file that is not owned by the current user, who therefore is not allowed to modify it.
Autodesk.Revit.Exceptions..::..RevitServerCommunicationException | The server-based central model could not be accessed because of a network communication error.
Autodesk.Revit.Exceptions..::..RevitServerInternalException | An internal error happened on the server, please contact the server administrator.
Autodesk.Revit.Exceptions..::..RevitServerUnauthenticatedUserException | User is not signed in with Autodesk id.
Autodesk.Revit.Exceptions..::..RevitServerUnauthorizedException | User is not authorized to access the specified A360 project.

See Also

Document Class


Import Method

[image] [image]

Revit 2024 API
Document..::..Import Method
Document Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Import(String, GBXMLImportOptions) | Imports a Green-Building XML file into the document.
Public method | Import(String, AXMImportOptions, View) | Imports an AXM file into the document.
Public method | Import(String, ImportOptions3DM, View) | Imports a 3DM file into the document.
Public method | Import(String, OBJImportOptions, View) | Imports an OBJ file into the document.
Public method | Import(String, SATImportOptions, View) | Imports an SAT file into the document.
Public method | Import(String, SKPImportOptions, View) | Imports a SKP file into the document.
Public method | Import(String, STLImportOptions, View) | Imports an STL file into the document.
Public method | Import(String, DGNImportOptions, View, ElementId%) | Imports a DGN file to the document.
Public method | Import(String, DWGImportOptions, View, ElementId%) | Imports a DWG or DXF file to the document.

See Also

Document Class
Document Members


Import Method (String, GBXMLImportOptions)

[image]

Revit 2024 API
Document..::..Import Method (String, GBXMLImportOptions)
Document Class See Also Send Feedback
Imports a Green-Building XML file into the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool Import(
    string file,
    GBXMLImportOptions options
)
Visual Basic
Public Function Import ( _
    file As String, _
    options As GBXMLImportOptions _
) As Boolean
Visual C++
public:
bool Import(
    String^ file,
    GBXMLImportOptions^ options
)

Parameters

file
Type: System..::..String
Full path of the file to import. File must exist.
options
Type: Autodesk.Revit.DB..::..GBXMLImportOptions
Various options applicable to GBXml import. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.

Return Value

True if successful, otherwise False.

Remarks

This method is available only in MEP. Though the 'options' argument is not currently used, an object still must be provided (may be nullNothingnullptra null reference (Nothing in Visual Basic)). The method will return False if not succeed. e.g when the input xml file does not contain any result elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when file argument is nullNothingnullptra null reference (Nothing in Visual Basic) or empty.
Autodesk.Revit.Exceptions..::..FileNotFoundException | Thrown when the file specified does not exist.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when no file is specified or if the file is not a valid gbXML file or does not contain any result elements.

See Also

Document Class
Import Overload


Import Method (String, AXMImportOptions, View)

[image]

Revit 2024 API
Document..::..Import Method (String, AXMImportOptions, View)
Document Class See Also Send Feedback
Imports an AXM file into the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022.1

Syntax

C#
public ElementId Import(
    string file,
    AXMImportOptions options,
    View pDBView
)
Visual Basic
Public Function Import ( _
    file As String, _
    options As AXMImportOptions, _
    pDBView As View _
) As ElementId
Visual C++
public:
ElementId^ Import(
    String^ file,
    AXMImportOptions^ options,
    View^ pDBView
)

Parameters

file
Type: System..::..String
Full path of the file to import. File must exist and must be a valid AXM file.
options
Type: Autodesk.Revit.DB..::..AXMImportOptions
Various import options applicable to the AXM format. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values. Import FormIt support Preserve color mode, center-to-center and origin-to-origin placement, other options are not supported. Import FormIt does not support orient to view and this view only option.
pDBView
Type: Autodesk.Revit.DB..::..View
View used to aid placement of the imported file. If the options specify center-to-center placement, this argument is required and the imported file will be placed in the center of the specified view. Otherwise, this view is used to obtain a base level to associate with the imported file. If not specified, an existing view will be chosen instead and may open a view or associate the imported file to an arbitrary level.

Return Value

Returns the element Id of the imported instance.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Not a valid file for AXM import (.axm files are valid). -or- The provided view is not valid for the options provided. -or- Visible layer only option is not false or layers are specified in SetLayerSelection. -or- Import levels is only supported in project document or conceptual mass document for AXM import. -or- Not all AXM import option settings are valid. For more details, please refer to AXMImportOptions. -or- The scale is not valid as a CustomScale for use during import. -or- NullOrEmpty -or- The view is not printable.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | The given file does not exist.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Import is temporarily disabled.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.
Autodesk.Revit.Exceptions..::..OptionalFunctionalityNotAvailableException | The AXM Import/Link module is not available in the installed Revit.

See Also

Document Class
Import Overload


Import Method (String, ImportOptions3DM, View)

[image]

Revit 2024 API
Document..::..Import Method (String, ImportOptions3DM, View)
Document Class See Also Send Feedback
Imports a 3DM file into the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public ElementId Import(
    string file,
    ImportOptions3DM options,
    View pDBView
)
Visual Basic
Public Function Import ( _
    file As String, _
    options As ImportOptions3DM, _
    pDBView As View _
) As ElementId
Visual C++
public:
ElementId^ Import(
    String^ file,
    ImportOptions3DM^ options,
    View^ pDBView
)

Parameters

file
Type: System..::..String
Full path of the file to import. File must exist and must be a valid 3DM file.
options
Type: Autodesk.Revit.DB..::..ImportOptions3DM
Various import options applicable to the 3DM format. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.
pDBView
Type: Autodesk.Revit.DB..::..View
View used to aid placement of the imported file. If the options specify ThisViewOnly, this argument is required and the imported file will only be visible in the specified view. If the options specify center-to-center placement, this argument is required and the imported file will be placed in the center of the specified view. Otherwise, this view is used to obtain a base level to associate with the imported file. If not specified, an existing view will be chosen instead and may open a view or associate the imported file to an arbitrary level.

Return Value

Returns the element Id of the imported instance.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Not a valid file for 3DM import (.3dm files are valid). -or- ThisViewOnly cannot be true when importing a DWG|DGN drawing into a 3D view. -or- The provided view is not valid for the options provided. -or- One or more strings describing layer selection is invalid or empty. -or- The scale is not valid as a CustomScale for use during import. -or- NullOrEmpty -or- The view is not printable.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | The given file does not exist.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Import is temporarily disabled.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.
Autodesk.Revit.Exceptions..::..OptionalFunctionalityNotAvailableException | The 3DM Import/Link module is not available in the installed Revit.

See Also

Document Class
Import Overload


Import Method (String, OBJImportOptions, View)

[image]

Revit 2024 API
Document..::..Import Method (String, OBJImportOptions, View)
Document Class See Also Send Feedback
Imports an OBJ file into the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022.1

Syntax

C#
public ElementId Import(
    string file,
    OBJImportOptions options,
    View pDBView
)
Visual Basic
Public Function Import ( _
    file As String, _
    options As OBJImportOptions, _
    pDBView As View _
) As ElementId
Visual C++
public:
ElementId^ Import(
    String^ file,
    OBJImportOptions^ options,
    View^ pDBView
)

Parameters

file
Type: System..::..String
Full path of the file to import. File must exist and must be a valid OBJ file.
options
Type: Autodesk.Revit.DB..::..OBJImportOptions
Various import options applicable to the OBJ format. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.
pDBView
Type: Autodesk.Revit.DB..::..View
View used to aid placement of the imported file. If the options specify ThisViewOnly, this argument is required and the imported file will only be visible in the specified view. If the options specify center-to-center placement, this argument is required and the imported file will be placed in the center of the specified view. Otherwise, this view is used to obtain a base level to associate with the imported file. If not specified, an existing view will be chosen instead and may open a view or associate the imported file to an arbitrary level.

Return Value

Returns the element Id of the imported instance.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Not a valid file for OBJ import (.obj files are valid). -or- ThisViewOnly cannot be true when importing a DWG|DGN drawing into a 3D view. -or- The provided view is not valid for the options provided. -or- One or more strings describing layer selection is invalid or empty. -or- The scale is not valid as a CustomScale for use during import. -or- NullOrEmpty -or- The view is not printable.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | The given file does not exist.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Import is temporarily disabled.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.
Autodesk.Revit.Exceptions..::..OptionalFunctionalityNotAvailableException | The OBJ Import/Link module is not available in the installed Revit.

See Also

Document Class
Import Overload


Import Method (String, SATImportOptions, View)

[image]

Revit 2024 API
Document..::..Import Method (String, SATImportOptions, View)
Document Class See Also Send Feedback
Imports an SAT file into the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ElementId Import(
    string file,
    SATImportOptions options,
    View pDBView
)
Visual Basic
Public Function Import ( _
    file As String, _
    options As SATImportOptions, _
    pDBView As View _
) As ElementId
Visual C++
public:
ElementId^ Import(
    String^ file,
    SATImportOptions^ options,
    View^ pDBView
)

Parameters

file
Type: System..::..String
Full path of the file to import. File must exist and must be a valid SAT file.
options
Type: Autodesk.Revit.DB..::..SATImportOptions
Various import options applicable to the SAT format. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.
pDBView
Type: Autodesk.Revit.DB..::..View
View used to aid placement of the imported file. If the options specify ThisViewOnly, this argument is required and the imported file will only be visible in the specified view. If the options specify center-to-center placement, this argument is required and the imported file will be placed in the center of the specified view. Otherwise, this view is used to obtain a base level to associate with the imported file. If not specified, an existing view will be chosen instead and may open a view or associate the imported file to an arbitrary level.

Return Value

Returns the element Id of the imported instance.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Not a valid file for SAT import (.sat files are valid). -or- ThisViewOnly cannot be true when importing a DWG|DGN drawing into a 3D view. -or- The provided view is not valid for the options provided. -or- One or more strings describing layer selection is invalid or empty. -or- The scale is not valid as a CustomScale for use during import. -or- NullOrEmpty -or- The view is not printable.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | The given file does not exist.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Import is temporarily disabled.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.
Autodesk.Revit.Exceptions..::..OptionalFunctionalityNotAvailableException | The SAT Import/Link module is not available in the installed Revit.

See Also

Document Class
Import Overload


Import Method (String, SKPImportOptions, View)

[image]

Revit 2024 API
Document..::..Import Method (String, SKPImportOptions, View)
Document Class See Also Send Feedback
Imports a SKP file into the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ElementId Import(
    string file,
    SKPImportOptions options,
    View pDBView
)
Visual Basic
Public Function Import ( _
    file As String, _
    options As SKPImportOptions, _
    pDBView As View _
) As ElementId
Visual C++
public:
ElementId^ Import(
    String^ file,
    SKPImportOptions^ options,
    View^ pDBView
)

Parameters

file
Type: System..::..String
Full path of the file to import. File must exist and must be a valid SKP file.
options
Type: Autodesk.Revit.DB..::..SKPImportOptions
Various import options applicable to the SKP format. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.
pDBView
Type: Autodesk.Revit.DB..::..View
View used to aid placement of the imported file. If the options specify ThisViewOnly, this argument is required and the imported file will only be visible in the specified view. If the options specify center-to-center placement, this argument is required and the imported file will be placed in the center of the specified view. Otherwise, this view is used to obtain a base level to associate with the imported file. If not specified, an existing view will be chosen instead and may open a view or associate the imported file to an arbitrary level.

Return Value

Returns the element Id of the imported instance.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Not a valid file for SKP import (.skp files are valid). -or- ThisViewOnly cannot be true when importing a DWG|DGN drawing into a 3D view. -or- The provided view is not valid for the options provided. -or- One or more strings describing layer selection is invalid or empty. -or- The scale is not valid as a CustomScale for use during import. -or- NullOrEmpty -or- The view is not printable.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | The given file does not exist.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Import is temporarily disabled.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.
Autodesk.Revit.Exceptions..::..OptionalFunctionalityNotAvailableException | The SKP Import/Link module is not available in the installed Revit.

See Also

Document Class
Import Overload


Import Method (String, STLImportOptions, View)

[image]

Revit 2024 API
Document..::..Import Method (String, STLImportOptions, View)
Document Class See Also Send Feedback
Imports an STL file into the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022.1

Syntax

C#
public ElementId Import(
    string file,
    STLImportOptions options,
    View pDBView
)
Visual Basic
Public Function Import ( _
    file As String, _
    options As STLImportOptions, _
    pDBView As View _
) As ElementId
Visual C++
public:
ElementId^ Import(
    String^ file,
    STLImportOptions^ options,
    View^ pDBView
)

Parameters

file
Type: System..::..String
Full path of the file to import. File must exist and must be a valid STL file.
options
Type: Autodesk.Revit.DB..::..STLImportOptions
Various import options applicable to the STL format. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.
pDBView
Type: Autodesk.Revit.DB..::..View
View used to aid placement of the imported file. If the options specify ThisViewOnly, this argument is required and the imported file will only be visible in the specified view. If the options specify center-to-center placement, this argument is required and the imported file will be placed in the center of the specified view. Otherwise, this view is used to obtain a base level to associate with the imported file. If not specified, an existing view will be chosen instead and may open a view or associate the imported file to an arbitrary level.

Return Value

Returns the element Id of the imported instance.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Not a valid file for STL import (.stl files are valid). -or- ThisViewOnly cannot be true when importing a DWG|DGN drawing into a 3D view. -or- The provided view is not valid for the options provided. -or- One or more strings describing layer selection is invalid or empty. -or- The scale is not valid as a CustomScale for use during import. -or- NullOrEmpty -or- The view is not printable.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | The given file does not exist.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Import is temporarily disabled.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.
Autodesk.Revit.Exceptions..::..OptionalFunctionalityNotAvailableException | The STL Import/Link module is not available in the installed Revit.

See Also

Document Class
Import Overload


Import Method (String, DGNImportOptions, View, ElementId)

[image]

Revit 2024 API
Document..::..Import Method (String, DGNImportOptions, View, ElementId%)
Document Class See Also Send Feedback
Imports a DGN file to the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool Import(
    string file,
    DGNImportOptions options,
    View pDBView,
    out ElementId elementId
)
Visual Basic
Public Function Import ( _
    file As String, _
    options As DGNImportOptions, _
    pDBView As View, _
    <OutAttribute> ByRef elementId As ElementId _
) As Boolean
Visual C++
public:
bool Import(
    String^ file,
    DGNImportOptions^ options,
    View^ pDBView,
    [OutAttribute] ElementId^% elementId
)

Parameters

file
Type: System..::..String
Full path of the file to import. File must exist and must be a valid DGN file.
options
Type: Autodesk.Revit.DB..::..DGNImportOptions
Various options applicable to the DGN format. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.
pDBView
Type: Autodesk.Revit.DB..::..View
View used to aid placement of the imported file. If the options specify ThisViewOnly, this argument is required and the imported file will only be visible in the specified view. If the options specify center-to-center placement, this argument is required and the imported file will be placed in the center of the specified view. Otherwise, this view is used to obtain a base level to associate with the imported file. If not specified, an existing view will be chosen instead and may open a view or associate the imported file to an arbitrary level.
elementId
Type: Autodesk.Revit.DB..::..ElementId %
The id of imported instance after a successful import.

Return Value

True if successful, otherwise False.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Not a valid file for DGN import (.dgn files are valid). -or- ThisViewOnly cannot be true when importing a DWG|DGN drawing into a 3D view. -or- The provided view is not valid for the options provided. -or- One or more strings describing layer selection is invalid or empty. -or- The scale is not valid as a CustomScale for use during import. -or- NullOrEmpty -or- The view is not printable. -or- Empty DGN model view name characters. -or- Visible layer only option must be set to false for DGN import.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | The given file does not exist.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Import is temporarily disabled.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.
Autodesk.Revit.Exceptions..::..OptionalFunctionalityNotAvailableException | The DGN Import/Link module is not available in the installed Revit.

See Also

Document Class
Import Overload


Import Method (String, DWGImportOptions, View, ElementId)

[image]

Revit 2024 API
Document..::..Import Method (String, DWGImportOptions, View, ElementId%)
Document Class See Also Send Feedback
Imports a DWG or DXF file to the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool Import(
    string file,
    DWGImportOptions options,
    View pDBView,
    out ElementId elementId
)
Visual Basic
Public Function Import ( _
    file As String, _
    options As DWGImportOptions, _
    pDBView As View, _
    <OutAttribute> ByRef elementId As ElementId _
) As Boolean
Visual C++
public:
bool Import(
    String^ file,
    DWGImportOptions^ options,
    View^ pDBView,
    [OutAttribute] ElementId^% elementId
)

Parameters

file
Type: System..::..String
Full path of the file to import. File must exist and must be a valid DWG or DXF file.
options
Type: Autodesk.Revit.DB..::..DWGImportOptions
Various options applicable to the DWG or DXF format. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.
pDBView
Type: Autodesk.Revit.DB..::..View
View used to aid placement of the imported file. If the options specify ThisViewOnly, this argument is required and the imported file will only be visible in the specified view. If the options specify center-to-center placement, this argument is required and the imported file will be placed in the center of the specified view. Otherwise, this view is used to obtain a base level to associate with the imported file. If not specified, an existing view will be chosen instead and may open a view or associate the imported file to an arbitrary level.
elementId
Type: Autodesk.Revit.DB..::..ElementId %
The id of imported instance after a successful import.

Return Value

True if successful, otherwise False.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Not a valid file for DWG import (.dwg and .dxf files are valid). -or- ThisViewOnly cannot be true when importing a DWG|DGN drawing into a 3D view. -or- The provided view is not valid for the options provided. -or- One or more strings describing layer selection is invalid or empty. -or- The line weights are not valid; either it contains an invalid number of line weights, or a line weight outside the valid range. -or- The scale is not valid as a CustomScale for use during import. -or- NullOrEmpty -or- The view is not printable.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | The given file does not exist.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Import is temporarily disabled.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.
Autodesk.Revit.Exceptions..::..OptionalFunctionalityNotAvailableException | The DWG Import/Link module is not available in the installed Revit.

See Also

Document Class
Import Overload


IsDefaultElementTypeIdValid Method

[image]

Revit 2024 API
Document..::..IsDefaultElementTypeIdValid Method
Document Class See Also Send Feedback
Checks whether the element type id is valid for the give DefaultElmentType id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool IsDefaultElementTypeIdValid(
    ElementTypeGroup defaultTypeId,
    ElementId typeId
)
Visual Basic
Public Function IsDefaultElementTypeIdValid ( _
    defaultTypeId As ElementTypeGroup, _
    typeId As ElementId _
) As Boolean
Visual C++
public:
bool IsDefaultElementTypeIdValid(
    ElementTypeGroup defaultTypeId,
    ElementId^ typeId
)

Parameters

defaultTypeId
Type: Autodesk.Revit.DB..::..ElementTypeGroup
The default element type id.
typeId
Type: Autodesk.Revit.DB..::..ElementId
The element type id.

Return Value

True if the element type id is valid for the give DefaultElmentType id, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

Document Class


IsDefaultFamilyTypeIdValid Method

[image]

Revit 2024 API
Document..::..IsDefaultFamilyTypeIdValid Method
Document Class See Also Send Feedback
Checks whether the family type id is valid for the give family category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool IsDefaultFamilyTypeIdValid(
    ElementId familyCategoryId,
    ElementId familyTypeId
)
Visual Basic
Public Function IsDefaultFamilyTypeIdValid ( _
    familyCategoryId As ElementId, _
    familyTypeId As ElementId _
) As Boolean
Visual C++
public:
bool IsDefaultFamilyTypeIdValid(
    ElementId^ familyCategoryId,
    ElementId^ familyTypeId
)

Parameters

familyCategoryId
Type: Autodesk.Revit.DB..::..ElementId
The family category id.
familyTypeId
Type: Autodesk.Revit.DB..::..ElementId
The default family type id.

Return Value

True if the family type id is valid for the give family category, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Document Class


IsPainted Method

[image]

Revit 2024 API
Document..::..IsPainted Method
Document Class See Also Send Feedback
Checks if the element's face is painted with a material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsPainted(
    ElementId elementId,
    Face face
)
Visual Basic
Public Function IsPainted ( _
    elementId As ElementId, _
    face As Face _
) As Boolean
Visual C++
public:
bool IsPainted(
    ElementId^ elementId,
    Face^ face
)

Parameters

elementId
Type: Autodesk.Revit.DB..::..ElementId
The element that the face belongs to.
face
Type: Autodesk.Revit.DB..::..Face
The painted element's face.

Return Value

True if the element's face is painted.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element elementId does not exist in the document -or- The face doesn't belong to the element
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Document Class


IsValidVersionGUID Method

[image]

Revit 2024 API
Document..::..IsValidVersionGUID Method
Document Class See Also Send Feedback
Checks whether the GUID is valid for the given document. Empty GUID is allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public static bool IsValidVersionGUID(
    Document document,
    Guid versionGUID
)
Visual Basic
Public Shared Function IsValidVersionGUID ( _
    document As Document, _
    versionGUID As Guid _
) As Boolean
Visual C++
public:
static bool IsValidVersionGUID(
    Document^ document,
    Guid versionGUID
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Target document.
versionGUID
Type: System..::..Guid
The GUID to check.

Return Value

True if the GUID is valid.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Document Class


Link Method

[image] [image]

Revit 2024 API
Document..::..Link Method
Document Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Link(String, DWFImportOptions) | Links Markups in a DWF file into the project document.
Public method | Link(String, ImportOptions3DM, View) | Links a 3DM file into the project document.
Public method | Link(String, OBJImportOptions, View) | Links an OBJ file into the project document.
Public method | Link(String, SATImportOptions, View) | Links an SAT file into the project document.
Public method | Link(String, SKPImportOptions, View) | Links a SKP file into the project document.
Public method | Link(String, STLImportOptions, View) | Links an STL file into the project document.
Public method | Link(String, DGNImportOptions, View, ElementId%) | Links a DGN file into the project document.
Public method | Link(String, DWGImportOptions, View, ElementId%) | Links a DWG or DXF file into the project document.

See Also

Document Class
Document Members


Link Method (String, DWFImportOptions)

[image]

Revit 2024 API
Document..::..Link Method (String, DWFImportOptions)
Document Class See Also Send Feedback
Links Markups in a DWF file into the project document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public IList<ElementId> Link(
    string file,
    DWFImportOptions options
)
Visual Basic
Public Function Link ( _
    file As String, _
    options As DWFImportOptions _
) As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ Link(
    String^ file,
    DWFImportOptions^ options
)

Parameters

file
Type: System..::..String
Full path of the file to link. File must exist and must be a valid DWF file.
options
Type: Autodesk.Revit.DB..::..DWFImportOptions
Various link options applicable to the DWF format.

Return Value

A collection of link instance element ids created by the markup link.

Remarks

Link isn't supported for family documents. Please use import instead.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Not a valid file for DWF import (.dwf or.dwfx files are valid). -or- Some of the views are not importable.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | The given file does not exist.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Import is temporarily disabled. -or- This Document is not a project document.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

Document Class
Link Overload


Link Method (String, ImportOptions3DM, View)

[image]

Revit 2024 API
Document..::..Link Method (String, ImportOptions3DM, View)
Document Class See Also Send Feedback
Links a 3DM file into the project document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public ElementId Link(
    string file,
    ImportOptions3DM options,
    View pDBView
)
Visual Basic
Public Function Link ( _
    file As String, _
    options As ImportOptions3DM, _
    pDBView As View _
) As ElementId
Visual C++
public:
ElementId^ Link(
    String^ file,
    ImportOptions3DM^ options,
    View^ pDBView
)

Parameters

file
Type: System..::..String
Full path of the file to link. File must exist and must be a valid 3DM file.
options
Type: Autodesk.Revit.DB..::..ImportOptions3DM
Various import options applicable to the 3DM format. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.
pDBView
Type: Autodesk.Revit.DB..::..View
View used to aid placement of the linked file. If the options specify ThisViewOnly, this argument is required and the linked file will only be visible in the specified view. If the options specify center-to-center placement, this argument is required and the linked file will be placed in the center of the specified view. Otherwise, this view is used to obtain a base level to associate with the linked file. If not specified, an existing view will be chosen instead and may open a view or associate the linked file to an arbitrary level.

Return Value

Returns the element Id of the linked instance.

Remarks

Link isn't supported for family documents. Please use import instead.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Not a valid file for 3DM import (.3dm files are valid). -or- ThisViewOnly cannot be true when importing a DWG|DGN drawing into a 3D view. -or- The provided view is not valid for the options provided. -or- One or more strings describing layer selection is invalid or empty. -or- The scale is not valid as a CustomScale for use during import. -or- NullOrEmpty -or- The view is not printable.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | The given file does not exist.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Import is temporarily disabled. -or- This Document is not a project document.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.
Autodesk.Revit.Exceptions..::..OptionalFunctionalityNotAvailableException | The 3DM Import/Link module is not available in the installed Revit.

See Also

Document Class
Link Overload


Link Method (String, OBJImportOptions, View)

[image]

Revit 2024 API
Document..::..Link Method (String, OBJImportOptions, View)
Document Class See Also Send Feedback
Links an OBJ file into the project document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public ElementId Link(
    string file,
    OBJImportOptions options,
    View pDBView
)
Visual Basic
Public Function Link ( _
    file As String, _
    options As OBJImportOptions, _
    pDBView As View _
) As ElementId
Visual C++
public:
ElementId^ Link(
    String^ file,
    OBJImportOptions^ options,
    View^ pDBView
)

Parameters

file
Type: System..::..String
Full path of the file to link. File must exist and must be a valid OBJ file.
options
Type: Autodesk.Revit.DB..::..OBJImportOptions
Various import options applicable to the OBJ format. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.
pDBView
Type: Autodesk.Revit.DB..::..View
View used to aid placement of the linked file. If the options specify ThisViewOnly, this argument is required and the linked file will only be visible in the specified view. If the options specify center-to-center placement, this argument is required and the linked file will be placed in the center of the specified view. Otherwise, this view is used to obtain a base level to associate with the linked file. If not specified, an existing view will be chosen instead and may open a view or associate the linked file to an arbitrary level.

Return Value

Returns the element Id of the linked instance.

Remarks

Link isn't supported for family documents. Please use import instead.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Not a valid file for OBJ import (.obj files are valid). -or- ThisViewOnly cannot be true when importing a DWG|DGN drawing into a 3D view. -or- The provided view is not valid for the options provided. -or- One or more strings describing layer selection is invalid or empty. -or- The scale is not valid as a CustomScale for use during import. -or- NullOrEmpty -or- The view is not printable.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | The given file does not exist.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Import is temporarily disabled. -or- This Document is not a project document.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.
Autodesk.Revit.Exceptions..::..OptionalFunctionalityNotAvailableException | The OBJ Import/Link module is not available in the installed Revit.

See Also

Document Class
Link Overload


Link Method (String, SATImportOptions, View)

[image]

Revit 2024 API
Document..::..Link Method (String, SATImportOptions, View)
Document Class See Also Send Feedback
Links an SAT file into the project document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ElementId Link(
    string file,
    SATImportOptions options,
    View pDBView
)
Visual Basic
Public Function Link ( _
    file As String, _
    options As SATImportOptions, _
    pDBView As View _
) As ElementId
Visual C++
public:
ElementId^ Link(
    String^ file,
    SATImportOptions^ options,
    View^ pDBView
)

Parameters

file
Type: System..::..String
Full path of the file to link. File must exist and must be a valid SAT file.
options
Type: Autodesk.Revit.DB..::..SATImportOptions
Various import options applicable to the SAT format. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.
pDBView
Type: Autodesk.Revit.DB..::..View
View used to aid placement of the linked file. If the options specify ThisViewOnly, this argument is required and the linked file will only be visible in the specified view. If the options specify center-to-center placement, this argument is required and the linked file will be placed in the center of the specified view. Otherwise, this view is used to obtain a base level to associate with the linked file. If not specified, an existing view will be chosen instead and may open a view or associate the linked file to an arbitrary level.

Return Value

Returns the element Id of the linked instance.

Remarks

Link isn't supported for family documents. Please use import instead.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Not a valid file for SAT import (.sat files are valid). -or- ThisViewOnly cannot be true when importing a DWG|DGN drawing into a 3D view. -or- The provided view is not valid for the options provided. -or- One or more strings describing layer selection is invalid or empty. -or- The scale is not valid as a CustomScale for use during import. -or- NullOrEmpty -or- The view is not printable.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | The given file does not exist.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Import is temporarily disabled. -or- This Document is not a project document.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.
Autodesk.Revit.Exceptions..::..OptionalFunctionalityNotAvailableException | The SAT Import/Link module is not available in the installed Revit.

See Also

Document Class
Link Overload


Link Method (String, DGNImportOptions, View, ElementId)

[image]

Revit 2024 API
Document..::..Link Method (String, DGNImportOptions, View, ElementId%)
Document Class See Also Send Feedback
Links a DGN file into the project document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool Link(
    string file,
    DGNImportOptions options,
    View pDBView,
    out ElementId elementId
)
Visual Basic
Public Function Link ( _
    file As String, _
    options As DGNImportOptions, _
    pDBView As View, _
    <OutAttribute> ByRef elementId As ElementId _
) As Boolean
Visual C++
public:
bool Link(
    String^ file,
    DGNImportOptions^ options,
    View^ pDBView,
    [OutAttribute] ElementId^% elementId
)

Parameters

file
Type: System..::..String
Full path of the file to link. File must exist and must be a valid DGN file.
options
Type: Autodesk.Revit.DB..::..DGNImportOptions
Various import options applicable to the DGN format. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.
pDBView
Type: Autodesk.Revit.DB..::..View
View used to aid placement of the linked file. If the options specify ThisViewOnly, this argument is required and the linked file will only be visible in the specified view. If the options specify center-to-center placement, this argument is required and the linked file will be placed in the center of the specified view. Otherwise, this view is used to obtain a base level to associate with the linked file. If not specified, an existing view will be chosen instead and may open a view or associate the linked file to an arbitrary level.
elementId
Type: Autodesk.Revit.DB..::..ElementId %
The id of linked instance after a successful link.

Return Value

True if successful, otherwise False.

Remarks

Link isn't supported for family documents. Please use import instead.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Not a valid file for DGN import (.dgn files are valid). -or- ThisViewOnly cannot be true when importing a DWG|DGN drawing into a 3D view. -or- The provided view is not valid for the options provided. -or- One or more strings describing layer selection is invalid or empty. -or- The scale is not valid as a CustomScale for use during import. -or- NullOrEmpty -or- The view is not printable. -or- Empty DGN model view name characters. -or- Visible layer only option must be set to false for DGN import.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | The given file does not exist.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Import is temporarily disabled. -or- This Document is not a project document.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.
Autodesk.Revit.Exceptions..::..OptionalFunctionalityNotAvailableException | The DGN Import/Link module is not available in the installed Revit.

See Also

Document Class
Link Overload


LoadFamily Method

[image] [image]

Revit 2024 API
Document..::..LoadFamily Method
Document Class See Also Send Feedback
Loads a family and all its types/symbols into the document.

Overload List

 | Name | Description
Public method | LoadFamily(String) | Loads an entire family and all its types/symbols into the document.
Public method | LoadFamily(Document) | Loads the contents of this family document into another document.
Public method | LoadFamily(String, Family%) | Loads an entire family and all its types/symbols into the document and provides a reference to the loaded family.
Public method | LoadFamily(Document, IFamilyLoadOptions) | Loads the contents of this family document into another document.
Public method | LoadFamily(String, IFamilyLoadOptions, Family%) | Loads an entire family and all its types/symbols into the document and provides a reference to the loaded family.

See Also

Document Class
Document Members


LoadFamily Method (String)

[image]

Revit 2024 API
Document..::..LoadFamily Method (String)
Document Class See Also Send Feedback
Loads an entire family and all its types/symbols into the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool LoadFamily(
    string filename
)
Visual Basic
Public Function LoadFamily ( _
    filename As String _
) As Boolean
Visual C++
public:
bool LoadFamily(
    String^ filename
)

Parameters

filename
Type: System..::..String
The fully qualified filename of the Family file, usually ending in .rfa.

Return Value

True if the entire family was loaded successfully into the project, otherwise False.

Remarks

Loading an entire family may take a considerable amount of time and memory. It is recommended that you use one of the LoadFamilySymbol() methods and only load those symbols that you need.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when filename is nullNothingnullptra null reference (Nothing in Visual Basic) or empty.

See Also

Document Class
LoadFamily Overload


LoadFamily Method (Document)

[image]

Revit 2024 API
Document..::..LoadFamily Method (Document)
Document Class See Also Send Feedback
Loads the contents of this family document into another document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Family LoadFamily(
    Document targetDocument
)
Visual Basic
Public Function LoadFamily ( _
    targetDocument As Document _
) As Family
Visual C++
public:
Family^ LoadFamily(
    Document^ targetDocument
)

Parameters

targetDocument
Type: Autodesk.Revit.DB..::..Document
The target document where the family will be loaded.

Return Value

Reference of the family in the target document.

Remarks

If you are reloading an edited family back into the source document from which it was extracted, this method will always fail. This is because this method automatically suppresses the prompts Revit typically uses to deal with conflicts between families, and assumes that any such conflict should prevent the loading. If you want to be able to reload the same family into the source document, you should use the LoadFamily() overload accepting IFamilyLoadOptions.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"targetDocument"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the current document is not a family document, or when the target document is modifiable (e.g. there is an uncommitted transaction) or doesn't support load of this kind of families (e.g. loading a model family to detail family is disallowed), or when this family was found in the target document already and the conflict caused an automatic abort of the load operation, or when a shared family in this family was found in the target document already and the conflict caused an automatic abort of the load operation, or this document is currently in a read-only state.
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Document Class
LoadFamily Overload


LoadFamily Method (String, Family)

[image]

Revit 2024 API
Document..::..LoadFamily Method (String, Family%)
Document Class Example See Also Send Feedback
Loads an entire family and all its types/symbols into the document and provides a reference to the loaded family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool LoadFamily(
    string filename,
    out Family family
)
Visual Basic
Public Function LoadFamily ( _
    filename As String, _
    <OutAttribute> ByRef family As Family _
) As Boolean
Visual C++
public:
bool LoadFamily(
    String^ filename,
    [OutAttribute] Family^% family
)

Parameters

filename
Type: System..::..String
The fully qualified filename of the Family file, usually ending in .rfa.
family
Type: Autodesk.Revit.DB..::..Family %
A reference to the family that was loaded if successful, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Return Value

True if the entire family was loaded successfully into the project, otherwise False.

Remarks

Loading an entire family may take a considerable amount of time and memory. It is recommended that you use one of the LoadFamilySymbol() methods and only load those symbols that you need.

Examples

CopyC#
// Get the Revit library path as defined via the Options dialog - File Locations tab - Places button
string libraryPath = "";
application.Application.GetLibraryPaths().TryGetValue("Imperial Library", out libraryPath);

if (String.IsNullOrEmpty(libraryPath))
{
    libraryPath = "c:\\";   // If not have, use a default path.
}

// Allow the user to select a family file.
OpenFileDialog openFileDialog1 = new OpenFileDialog();
openFileDialog1.InitialDirectory = libraryPath;
openFileDialog1.Filter = "Family Files (*.rfa)|*.rfa";

// Load the family file using LoadFamily method and then give information.
if (DialogResult.OK == openFileDialog1.ShowDialog())
{
    Autodesk.Revit.DB.Family family = null;
    if (document.LoadFamily(openFileDialog1.FileName, out family))
    {
        String name = family.Name;
        TaskDialog.Show("Revit","Family file has been loaded. Its name is " + name);
    }
    else
    {
        TaskDialog.Show("Revit","Can't load the family file.");
    }
}
CopyVB.NET
' Get the Revit library path as defined via the Options dialog - File Locations tab - Places button
Dim libraryPath As String = ""
application.Application.GetLibraryPaths().TryGetValue("Imperial Library", libraryPath)

If [String].IsNullOrEmpty(libraryPath) Then
    ' If not have, use a default path.
    libraryPath = "c:\"
End If

' Allow the user to select a family file.
Dim openFileDialog1 As New OpenFileDialog()
openFileDialog1.InitialDirectory = libraryPath
openFileDialog1.Filter = "Family Files (*.rfa)|*.rfa"

' Load the family file using LoadFamily method and then give information.
If DialogResult.OK = openFileDialog1.ShowDialog() Then
    Dim family As Autodesk.Revit.DB.Family = Nothing
    If document.LoadFamily(openFileDialog1.FileName, family) Then
        Dim name As [String] = family.Name
        TaskDialog.Show("Revit", "Family file has been loaded. Its name is " & name)
    Else
        TaskDialog.Show("Revit", "Can't load the family file.")
    End If
End If

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when filename is nullNothingnullptra null reference (Nothing in Visual Basic) or empty.

See Also

Document Class
LoadFamily Overload


LoadFamily Method (String, IFamilyLoadOptions, Family)

[image]

Revit 2024 API
Document..::..LoadFamily Method (String, IFamilyLoadOptions, Family%)
Document Class See Also Send Feedback
Loads an entire family and all its types/symbols into the document and provides a reference to the loaded family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool LoadFamily(
    string filename,
    IFamilyLoadOptions familyLoadOptions,
    out Family family
)
Visual Basic
Public Function LoadFamily ( _
    filename As String, _
    familyLoadOptions As IFamilyLoadOptions, _
    <OutAttribute> ByRef family As Family _
) As Boolean
Visual C++
public:
bool LoadFamily(
    String^ filename,
    IFamilyLoadOptions^ familyLoadOptions,
    [OutAttribute] Family^% family
)

Parameters

filename
Type: System..::..String
The fully qualified filename of the Family file, usually ending in .rfa.
familyLoadOptions
Type: Autodesk.Revit.DB..::..IFamilyLoadOptions
The interface implementation to use when loading a family into the document.
family
Type: Autodesk.Revit.DB..::..Family %
A reference to the family that was loaded if successful, otherwise Nothing.

Return Value

True if the entire family was loaded successfully into the project, otherwise False.

Remarks

Loading an entire family may take a considerable amount of time and memory. It is recommended that you use one of the LoadFamilySymbol() methods and only load those symbols that you need.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when filename is nullNothingnullptra null reference (Nothing in Visual Basic) or empty.
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument "familyLoadOptions" is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Document Class
LoadFamily Overload


LoadFamilySymbol Method

[image] [image]

Revit 2024 API
Document..::..LoadFamilySymbol Method
Document Class See Also Send Feedback
Loads only a specified family type/symbol from a family file into the document.

Overload List

 | Name | Description
Public method | LoadFamilySymbol(String, String) | Loads only a specified family type/symbol from a family file into the document.
Public method | LoadFamilySymbol(String, String, FamilySymbol%) | Loads only the specified family type/symbol from a family file into the document and provides a reference to the loaded family symbol.
Public method | LoadFamilySymbol(String, String, IFamilyLoadOptions, FamilySymbol%) | Loads only the specified family type/symbol from a family file into the document and provides a reference to the loaded family symbol.

See Also

Document Class
Document Members


LoadFamilySymbol Method (String, String)

[image]

Revit 2024 API
Document..::..LoadFamilySymbol Method (String, String)
Document Class See Also Send Feedback
Loads only a specified family type/symbol from a family file into the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool LoadFamilySymbol(
    string filename,
    string name
)
Visual Basic
Public Function LoadFamilySymbol ( _
    filename As String, _
    name As String _
) As Boolean
Visual C++
public:
bool LoadFamilySymbol(
    String^ filename,
    String^ name
)

Parameters

filename
Type: System..::..String
The fully qualified filename of the Family file, usually ending in .rfa.
name
Type: System..::..String
The name of the type/symbol to be loaded, such as "W11x14".

Return Value

True if the family type/symbol was loaded successfully into the project, otherwise False.

Remarks

This function supports loading of types/symbols stored in the family, or those available in the family Type Catalog file.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when filename or name is nullNothingnullptra null reference (Nothing in Visual Basic) or empty.

See Also

Document Class
LoadFamilySymbol Overload


LoadFamilySymbol Method (String, String, FamilySymbol)

[image]

Revit 2024 API
Document..::..LoadFamilySymbol Method (String, String, FamilySymbol%)
Document Class See Also Send Feedback
Loads only the specified family type/symbol from a family file into the document and provides a reference to the loaded family symbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool LoadFamilySymbol(
    string filename,
    string name,
    out FamilySymbol symbol
)
Visual Basic
Public Function LoadFamilySymbol ( _
    filename As String, _
    name As String, _
    <OutAttribute> ByRef symbol As FamilySymbol _
) As Boolean
Visual C++
public:
bool LoadFamilySymbol(
    String^ filename,
    String^ name,
    [OutAttribute] FamilySymbol^% symbol
)

Parameters

filename
Type: System..::..String
The fully qualified filename of the Family file, usually ending in .rfa.
name
Type: System..::..String
The name of the type/symbol to be loaded, such as "W11x14".
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol %
A reference to the family symbol that was loaded if successful, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Return Value

True if the family type/symbol was loaded successfully into the project, otherwise False.

Remarks

This function supports loading of types/symbols stored in the family, or those available in the family Type Catalog file.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when filename or name is nullNothingnullptra null reference (Nothing in Visual Basic) or empty.

See Also

Document Class
LoadFamilySymbol Overload


LoadFamilySymbol Method (String, String, IFamilyLoadOptions, FamilySymbol)

[image]

Revit 2024 API
Document..::..LoadFamilySymbol Method (String, String, IFamilyLoadOptions, FamilySymbol%)
Document Class See Also Send Feedback
Loads only the specified family type/symbol from a family file into the document and provides a reference to the loaded family symbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool LoadFamilySymbol(
    string filename,
    string name,
    IFamilyLoadOptions familyLoadOptions,
    out FamilySymbol symbol
)
Visual Basic
Public Function LoadFamilySymbol ( _
    filename As String, _
    name As String, _
    familyLoadOptions As IFamilyLoadOptions, _
    <OutAttribute> ByRef symbol As FamilySymbol _
) As Boolean
Visual C++
public:
bool LoadFamilySymbol(
    String^ filename,
    String^ name,
    IFamilyLoadOptions^ familyLoadOptions,
    [OutAttribute] FamilySymbol^% symbol
)

Parameters

filename
Type: System..::..String
The fully qualified filename of the Family file, usually ending in .rfa.
name
Type: System..::..String
The name of the type/symbol to be loaded, such as "W11x14".
familyLoadOptions
Type: Autodesk.Revit.DB..::..IFamilyLoadOptions
The interface implementation to use when loading a family into the document.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol %
A reference to the family symbol that was loaded if successful, otherwise Nothing.

Return Value

True if the family type/symbol was loaded successfully into the project, otherwise False.

Remarks

This function supports loading of types/symbols stored in the family, or those available in the family Type Catalog file.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when filename or name is nullNothingnullptra null reference (Nothing in Visual Basic) or empty.

See Also

Document Class
LoadFamilySymbol Overload


MakeTransientElements Method

[image]

Revit 2024 API
Document..::..MakeTransientElements Method
Document Class See Also Send Feedback
This method encapsulates the process of creating transient elements in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void MakeTransientElements(
    ITransientElementMaker maker
)
Visual Basic
Public Sub MakeTransientElements ( _
    maker As ITransientElementMaker _
)
Visual C++
public:
void MakeTransientElements(
    ITransientElementMaker^ maker
)

Parameters

maker
Type: Autodesk.Revit.DB..::..ITransientElementMaker
An instance of a class that implements the ITransientElementMaker interface. The maker will be called to create element(s) which would become transient.

Remarks

The method establishes a context within which transient elements will be created and then invokes the given maker object to create the elements. For more information refer to the IsTransient method.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This Document has an open editing transaction and is accepting changes. -or- This Document is read-only: It cannot be modified.

See Also

Document Class


Paint Method (ElementId, Face, ElementId)

[image]

Revit 2024 API
Document..::..Paint Method (ElementId, Face, ElementId)
Document Class Example See Also Send Feedback
Paint the element's face with specified material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void Paint(
    ElementId elementId,
    Face face,
    ElementId materialId
)
Visual Basic
Public Sub Paint ( _
    elementId As ElementId, _
    face As Face, _
    materialId As ElementId _
)
Visual C++
public:
void Paint(
    ElementId^ elementId,
    Face^ face,
    ElementId^ materialId
)

Parameters

elementId
Type: Autodesk.Revit.DB..::..ElementId
The element that the face belongs to.
face
Type: Autodesk.Revit.DB..::..Face
The painted element's face.
materialId
Type: Autodesk.Revit.DB..::..ElementId
The material to be painted on the face

Examples

CopyC#
// Paint any unpainted faces of a given wall
public void PaintWallFaces(Wall wall, ElementId matId)
{
    Document doc = wall.Document;
    GeometryElement geometryElement = wall.get_Geometry(new Options());
    foreach (GeometryObject geometryObject in geometryElement)
    {
        if (geometryObject is Solid)
        {
            Solid solid = geometryObject as Solid;
            foreach (Face face in solid.Faces)
            {
                if (doc.IsPainted(wall.Id, face) == false)
                {
                    doc.Paint(wall.Id, face, matId);
                }
            }
        }
    }
}
CopyC#
public void ApplyPaintByMaterial(Document document, Wall wall, Material material)
{
   // Before acquiring the geometry, make sure the detail level is set to 'Fine'
   Options geoOptions = new Options();
   geoOptions.DetailLevel = ViewDetailLevel.Fine;

   // Obtain geometry for the given Wall element
   GeometryElement geoElem = wall.get_Geometry(geoOptions);

   // Find a face on the wall
   Face wallFace = null;
   IEnumerator<GeometryObject> geoObjectItor = geoElem.GetEnumerator();
   while (geoObjectItor.MoveNext())
   {
      // need to find a solid first
      Solid theSolid = geoObjectItor.Current as Solid;
      if (null != theSolid)
      {
         // Examine faces of the solid to find one with at least
         // one region. Then take the geometric face of that region.
         foreach (Face face in theSolid.Faces)
         {
            if (face.HasRegions)
            {
               wallFace = face.GetRegions()[0];
               break;
            }
         }
      }
   }

   if (null == wallFace)
   {
      TaskDialog.Show("Failure", "Could not find a face to paint on the given wall.");
      return;
   }

   // Paint material to the wall face (modification must be inside a transaction)

   using (Transaction transaction = new Transaction(document, "Painting a wall"))
   {
      transaction.Start();
      document.Paint(wall.Id, wallFace, material.Id);
      transaction.Commit();
   }

   // For illustration purposes only, check if the painted material indeed got applied

   bool isPainted = document.IsPainted(wall.Id, wallFace);
   if (isPainted)
   {
      ElementId paintedMatId = document.GetPaintedMaterial(wall.Id, wallFace);
      if (paintedMatId == material.Id)
      {
         TaskDialog.Show("Painting material", "Wall painted successfully.");
      }
   }
}
CopyVB.NET
' Paint any unpainted faces of a given wall
Public Sub PaintWallFaces(wall As Wall, matId As ElementId)
   Dim doc As Document = wall.Document
   Dim geometryElement As GeometryElement = wall.Geometry(New Options())
   For Each geometryObject As GeometryObject In geometryElement
      If TypeOf geometryObject Is Solid Then
         Dim solid As Solid = TryCast(geometryObject, Solid)
         For Each face As Face In solid.Faces
            If doc.IsPainted(wall.Id, face) = False Then
               doc.Paint(wall.Id, face, matId)
            End If
         Next
      End If
   Next
End Sub
CopyVB.NET
Public Sub ApplyPaintByMaterial(document As Document, wall As Wall, material As Material)
    ' Before acquiring the geometry, make sure the detail level is set to 'Fine'
    Dim geoOptions As New Options()
    geoOptions.DetailLevel = ViewDetailLevel.Fine

    ' Obtain geometry for the given Wall element
    Dim geoElem As GeometryElement = wall.Geometry(geoOptions)

    ' Find a face on the wall
    Dim wallFace As Face = Nothing
    Dim geoObjectItor As IEnumerator(Of GeometryObject) = geoElem.GetEnumerator()
    While geoObjectItor.MoveNext()
        ' need to find a solid first
        Dim theSolid As Solid = TryCast(geoObjectItor.Current, Solid)
        If theSolid IsNot Nothing Then
            ' Examine faces of the solid to find one with at least
            ' one region. Then take the geometric face of that region.
            For Each face As Face In theSolid.Faces
                If face.HasRegions Then
                    wallFace = face.GetRegions()(0)
                    Exit For
                End If
            Next
        End If
    End While

    If wallFace Is Nothing Then
        TaskDialog.Show("Failure", "Could not find a face to paint on the given wall.")
        Return
    End If

    ' Paint material to the wall face (modification must be inside a transaction)

    Using transaction As New Transaction(document, "Painting a wall")
        transaction.Start()
        document.Paint(wall.Id, wallFace, material.Id)
        transaction.Commit()
    End Using

    ' For illustration purposes only, check if the painted material indeed got applied

    Dim isPainted As Boolean = document.IsPainted(wall.Id, wallFace)
    If isPainted Then
        Dim paintedMatId As ElementId = document.GetPaintedMaterial(wall.Id, wallFace)
        If paintedMatId = material.Id Then
            TaskDialog.Show("Painting material", "Wall painted successfully.")
        End If
    End If
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element elementId does not exist in the document -or- The element materialId does not exist in the document -or- The face doesn't belong to the element -or- The materialId doesn't specify a material element. -or- The element's face cannot be painted.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

Document Class
Paint Overload


PostFailure Method

[image]

Revit 2024 API
Document..::..PostFailure Method
Document Class Example See Also Send Feedback
Posts a failure to be displayed to the user at the end of transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FailureMessageKey PostFailure(
    FailureMessage failure
)
Visual Basic
Public Function PostFailure ( _
    failure As FailureMessage _
) As FailureMessageKey
Visual C++
public:
FailureMessageKey^ PostFailure(
    FailureMessage^ failure
)

Parameters

failure
Type: Autodesk.Revit.DB..::..FailureMessage
The failure to be posted.

Return Value

A unique key that identifies posted failure message in a document. If exactly the same error is posted more than once, and not removed between the postings, returned key will be the same every time.

Remarks

If code inside transaction detects a problem that needs to be communicated to the user, it should report these conditions via this method. Failures will be validated and possibly resolved at the end of transaction. Warnings posted via this method will not be stored in the document after they are resolved. A unique key returned by postFailure can be stored for the lifetime of transaction and used to remove failure message if it is no longer relevant.

Examples

CopyC#
// Execute function for an Updater triggered when new FamilyInstances are added
public void Execute(UpdaterData data)
{
   Document doc = data.GetDocument();
   Autodesk.Revit.ApplicationServices.Application app = doc.Application;
   foreach (ElementId id in data.GetModifiedElementIds())
   {
      AnalyticalMember fi = doc.GetElement(id) as AnalyticalMember;
      if (fi.StructuralRole == AnalyticalStructuralRole.StructuralRoleBeam)
      {
         if (fi.IsSingleCurve() == true)
         {
            Curve beamCurve = fi.GetCurve();
            // enforce beam length minimum of 12 inches
            if (beamCurve.Length < 12.0)
            {
               FailureMessage failMessage =
                     new FailureMessage(BuiltInFailures.CurveFailures.TooShort);
               failMessage.SetFailingElement(id);
               doc.PostFailure(failMessage);
            }
         }
      }
   }
}
CopyVB.NET
' Execute function for an Updater triggered when new FamilyInstances are added
Public Sub Execute(data As UpdaterData) Implements IUpdater.Execute
   Dim doc As Document = data.GetDocument()
   Dim app As Autodesk.Revit.ApplicationServices.Application = doc.Application
   For Each id As ElementId In data.GetModifiedElementIds()
      Dim fi As FamilyInstance = TryCast(doc.GetElement(id), FamilyInstance)
      If fi.StructuralType = StructuralType.Beam Then
         Dim analyticalModel As Autodesk.Revit.DB.Structure.AnalyticalElement = Nothing
         Dim relManager As Autodesk.Revit.DB.Structure.AnalyticalToPhysicalAssociationManager = Autodesk.Revit.DB.Structure.AnalyticalToPhysicalAssociationManager.GetAnalyticalToPhysicalAssociationManager(doc)

         If (relManager Is Nothing) Then
            Exit Sub
         End If

         Dim counterpartId As ElementId = relManager.GetAssociatedElementId(fi.Id)
         If (counterpartId Is Nothing) Then
            Exit Sub
         End If

         analyticalModel = doc.GetElement(counterpartId)
         If analyticalModel.IsSingleCurve() = True Then
            Dim beamCurve As Curve = analyticalModel.GetCurve()
            ' enforce beam length minimum of 12 inches
            If beamCurve.Length < 12.0 Then
               Dim failMessage As New FailureMessage(BuiltInFailures.CurveFailures.TooShort)
               failMessage.SetFailingElement(id)
               doc.PostFailure(failMessage)
            End If
         End If
      End If
   Next
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | Document must be in state of accepting posted failures and the failures must be appropriate for that current state.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

Document Class


Print Method (ViewSet)

[image]

Revit 2024 API
Document..::..Print Method (ViewSet)
Document Class See Also Send Feedback
Prints a set of views with default view template and default print settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Print(
    ViewSet views
)
Visual Basic
Public Sub Print ( _
    views As ViewSet _
)
Visual C++
public:
void Print(
    ViewSet^ views
)

Parameters

views
Type: Autodesk.Revit.DB..::..ViewSet
The set of views which need to be printed.

Remarks

If one view in the set can not be printed successfully then an exception will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when printing is not allowed in the current application mode. Or when at least one view from the view set is not a printable view.
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the view set to be printed is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the view set contains a nullNothingnullptra null reference (Nothing in Visual Basic) element.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when at least one view from the view set could not be printed.
Autodesk.Revit.Exceptions..::..OperationCanceledException | Thrown when print is cancelled by event handler.

See Also

Document Class
Print Overload


Print Method (ViewSet, View)

[image]

Revit 2024 API
Document..::..Print Method (ViewSet, View)
Document Class See Also Send Feedback
Prints a set of views with a specified view template and default print settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Print(
    ViewSet views,
    View viewTemplate
)
Visual Basic
Public Sub Print ( _
    views As ViewSet, _
    viewTemplate As View _
)
Visual C++
public:
void Print(
    ViewSet^ views,
    View^ viewTemplate
)

Parameters

views
Type: Autodesk.Revit.DB..::..ViewSet
The set of views which need to be printed.
viewTemplate
Type: Autodesk.Revit.DB..::..View
The view template which apply to the set of views.

Remarks

If one view in the set can not be printed successfully then an exception will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when printing is not allowed in the current application mode. Or when at least one view from the view set is not a printable view.
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the view set to be printed is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the view set contains a nullNothingnullptra null reference (Nothing in Visual Basic) element.
Autodesk.Revit.Exceptions..::..ApplicationException | Thrown when at least one view from the view set could not be printed.
Autodesk.Revit.Exceptions..::..OperationCanceledException | Thrown when print is cancelled by event handler.

See Also

Document Class
Print Overload


Print Method (ViewSet, Boolean)

[image]

Revit 2024 API
Document..::..Print Method (ViewSet, Boolean)
Document Class See Also Send Feedback
Prints a set of views with default view template and default print settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Print(
    ViewSet views,
    bool useCurrentPrintSettings
)
Visual Basic
Public Sub Print ( _
    views As ViewSet, _
    useCurrentPrintSettings As Boolean _
)
Visual C++
public:
void Print(
    ViewSet^ views,
    bool useCurrentPrintSettings
)

Parameters

views
Type: Autodesk.Revit.DB..::..ViewSet
The set of views which need to be printed.
useCurrentPrintSettings
Type: System..::..Boolean
If true, print the view with the current print setting, otherwise with the print setting of the document of the view.

Remarks

If one view in the set can not be printed successfully then an exception will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when printing is not allowed in the current application mode. Or when at least one view from the view set is not a printable view.
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the view set to be printed is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the view set contains a nullNothingnullptra null reference (Nothing in Visual Basic) element.
Autodesk.Revit.Exceptions..::..ApplicationException | Thrown when at least one view from the view set could not be printed.
Autodesk.Revit.Exceptions..::..OperationCanceledException | Thrown when print is cancelled by event handler.

See Also

Document Class
Print Overload


PublishCoordinates Method

[image]

Revit 2024 API
Document..::..PublishCoordinates Method
Document Class See Also Send Feedback
Publish coordinates to the specified ProjectLocation of the link instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public void PublishCoordinates(
    LinkElementId locationId
)
Visual Basic
Public Sub PublishCoordinates ( _
    locationId As LinkElementId _
)
Visual C++
public:
void PublishCoordinates(
    LinkElementId^ locationId
)

Parameters

locationId
Type: Autodesk.Revit.DB..::..LinkElementId
The ElementId of the ProjectLocation in the linked document, to which the transform would be published to.

Remarks

The host project's True North and shared origin are recorded in the linked project, based on the current position of the linked instance. This location is now named in both the host project and the linked project. More than one position of the link can be recorded.

When you publish shared coordinates from a host Revit project to a linked DWG, this changes the linked DWG. The origin of the host Revit project's shared coordinate system becomes the origin of a new User Coordinate System (UCS) in the DWG file. The Y axis of the new UCS corresponds to the host project's True North. You can name the UCS when you publish coordinates. It is not recommended that you change this name after publishing coordinates.

Note: Currently, only RevitLinkInstance is supported. DWG link instance, which is ImportInstance is not supported now. Passing in an locationId that points to an ImportInstance would result an ArgumentException.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | locationId does not contain a valid linkInstanceId. -or- Only RevitLinkInstance is supported through API for publish coordinates.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This Document is not a project document. -or- This Document is in an edit mode. -or- Attempting to publish shared coordinates to a cloud based link which is treated as read-only. -or- Failed to publish coordinates to the specified ProjectLocation of the link instance.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

Document Class


Regenerate Method

[image]

Revit 2024 API
Document..::..Regenerate Method
Document Class Example See Also Send Feedback
Updates the elements in the Revit document to reflect all changes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Regenerate()
Visual Basic
Public Sub Regenerate
Visual C++
public:
void Regenerate()

Remarks

Use this method to force update to the document after a group of changes. Note that when a transaction is committed there is an automatic call to regenerate the document.

Examples

CopyC#
FamilyInstance instance = doc.Create.NewFamilyInstance(new XYZ(15, 20, 0), familySymbol, StructuralType.NonStructural);
FamilyInstance instance2 = doc.Create.NewFamilyInstance(new XYZ(25, 30, 0), familySymbol, StructuralType.NonStructural);
// faster to create multiple instances without calling Regenerate after each one

LocationPoint point = instance.Location as LocationPoint;
// this data is incorrect because the new geometry has not yet been regenerated

doc.Regenerate();
point = instance.Location as LocationPoint;
// now it is correct
CopyVB.NET
Dim instance As FamilyInstance = doc.Create.NewFamilyInstance(New XYZ(15, 20, 0), familySymbol, StructuralType.NonStructural)
Dim instance2 As FamilyInstance = doc.Create.NewFamilyInstance(New XYZ(25, 30, 0), familySymbol, StructuralType.NonStructural)
' faster to create multiple instances without calling Regenerate after each one

Dim point As LocationPoint = TryCast(instance.Location, LocationPoint)
' this data is incorrect because the new geometry has not yet been regenerated

doc.Regenerate()
point = TryCast(instance.Location, LocationPoint)
' now it is correct

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..RegenerationFailedException Thrown when the operation fails.
  • If regeneration fails, there is posted error of severity DocumentCorruption that will be delivered to the end user at the end of transaction explaining what specifically has happened.
  • If regeneration has failed, document is corrupted and even reading from it is illegal.
  • Code that called regeneration and got this exception should not catch and ignore it - instead, it should do nothing but internal cleanup and return control to the owner of currently active transaction/subtransaction, which must be aborted.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Modification of the document is forbidden. Typically, this is because there is no open transaction; consult documentation for Document.IsModified for other possible causes.

See Also

Document Class


RemovePaint Method

[image]

Revit 2024 API
Document..::..RemovePaint Method
Document Class See Also Send Feedback
Remove the material painted on the element's face. If the face is currently not painted,it will do nothing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void RemovePaint(
    ElementId elementId,
    Face face
)
Visual Basic
Public Sub RemovePaint ( _
    elementId As ElementId, _
    face As Face _
)
Visual C++
public:
void RemovePaint(
    ElementId^ elementId,
    Face^ face
)

Parameters

elementId
Type: Autodesk.Revit.DB..::..ElementId
The element that the painted face belongs to.
face
Type: Autodesk.Revit.DB..::..Face
The painted element's face.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element elementId does not exist in the document -or- The face doesn't belong to the element
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Document Class


ResetSharedCoordinates Method

[image]

Revit 2024 API
Document..::..ResetSharedCoordinates Method
Document Class See Also Send Feedback
Reset shared coordinates for the host model/file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021.1

Syntax

C#
public void ResetSharedCoordinates()
Visual Basic
Public Sub ResetSharedCoordinates
Visual C++
public:
void ResetSharedCoordinates()

Remarks

When you reset shared coordinates, the shared coordinates of the host model will be erased. The shared relationship with all the linked models will be eliminated. Survey point will be reset back to startup location, where it coincides with the Internal Origin. The rotation angle between Project North and True North will be reset back to 0.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This Document is not a primary document, it is a linked document. -or- This Document is not a project document. -or- This Document is in an edit mode.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

Document Class


Save Method

[image] [image]

Revit 2024 API
Document..::..Save Method
Document Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Save()()()() | Saves the document.
Public method | Save(SaveOptions) | Saves the document.

See Also

Document Class
Document Members


Save Method

[image]

Revit 2024 API
Document..::..Save Method
Document Class See Also Send Feedback
Saves the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void Save()
Visual Basic
Public Sub Save
Visual C++
public:
void Save()

Remarks

If the document was created in this current session and has not been saved to a file yet, it needs to be first saved using the SaveAs method instead.

This method may not be called unless all transactions, sub-transactions, and transaction groups that were opened by the API code were closed. That also implies that this method cannot be called during dynamic updates. Event handlers are not allowed to save document that are currently in modifiable state.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..CentralModelException | Central model is missing. -or- Central model is incompatible. -or- The central model was saved in a different version of Revit. -or- Revit encountered errors while saving to the new central model. Resave again as a new central model. -or- Incompatible servers for external services. -or- Username does not match the one used to create the local file. -or- Revit could not save all of the worksets that have been changed. Try again.
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | Save may not be called during dynamic update.
Autodesk.Revit.Exceptions..::..InsufficientResourcesException | This computer does not have enough memory, disk space, or other necessary resource to save the model.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This Document is not a primary document, it is a linked document. -or- Save is temporarily disabled. -or- Saving is not allowed in the current application mode. -or- File path must be already set to be able to save the document.It needs to be first saved using the SaveAs method instead. -or- The file is read-only, can not be saved. -or- Operation is not permitted when there is any open sub-transaction, transaction, or transaction group. -or- Saving failed.
Autodesk.Revit.Exceptions..::..OperationCanceledException | Saving was canceled by the user or by an API event callback.
Autodesk.Revit.Exceptions..::..OutdatedDirectlyOpenedCentralException | Other users have modified the central model while you had it opened. Resave your document as a local file and then synchronize with central again.

See Also

Document Class
Save Overload


SaveAs Method

[image] [image]

Revit 2024 API
Document..::..SaveAs Method
Document Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SaveAs(String) | Saves the document to a given file path.
Public method | SaveAs(String, SaveAsOptions) | Saves the document to a given file path.
Public method | SaveAs(ModelPath, SaveAsOptions) | Saves the document to a given path.

See Also

Document Class
Document Members


SaveAs Method (String)

[image]

Revit 2024 API
Document..::..SaveAs Method (String)
Document Class See Also Send Feedback
Saves the document to a given file path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void SaveAs(
    string filepath
)
Visual Basic
Public Sub SaveAs ( _
    filepath As String _
)
Visual C++
public:
void SaveAs(
    String^ filepath
)

Parameters

filepath
Type: System..::..String
File name and path to be saved as. Either a relative or absolute path can be provided.

Remarks

The document's title in Revit's title bar will be updated automatically to reflect the file's new name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | filepath is an empty string. -or- The filepath is not a valid file path.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..CentralModelException | Central model is missing. -or- Central model is incompatible. -or- The central model was saved in a different version of Revit. -or- Revit encountered errors while saving to the new central model. Resave again as a new central model. -or- Incompatible servers for external services. -or- Username does not match the one used to create the local file. -or- Revit could not save all of the worksets that have been changed. Try again.
Autodesk.Revit.Exceptions..::..FileAccessException | The file at the given path location could not be accessed or saved.
Autodesk.Revit.Exceptions..::..FileNotFoundException | The given file, path or network location could not be found during save.
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | SaveAs may not be called during dynamic update.
Autodesk.Revit.Exceptions..::..InsufficientResourcesException | This computer does not have enough memory, disk space, or other necessary resource to save the model.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This Document is not a primary document, it is a linked document. -or- SaveAs is temporarily disabled. -or- There is an existing file at filepath. -or- Saving is not allowed in the current application mode. -or- The document just had worksharing enabled or was opened detached, so SaveAsOptions must be passed in SaveAs with WorksharingSaveAsOptions.SaveAsCentral set to true. -or- Operation is not permitted when there is any open sub-transaction, transaction, or transaction group. -or- Saving failed.
Autodesk.Revit.Exceptions..::..OperationCanceledException | Saving was canceled by the user or by an API event callback.
Autodesk.Revit.Exceptions..::..OutdatedDirectlyOpenedCentralException | Other users have modified the central model while you had it opened. Resave your document as a local file and then synchronize with central again.

See Also

Document Class
SaveAs Overload


SaveAsCloudModel Method

[image]

Revit 2024 API
Document..::..SaveAsCloudModel Method
Document Class See Also Send Feedback
Saves current non-workshared or workshared model as a cloud model or workshared cloud model in BIM 360 Docs or Autodesk Docs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public void SaveAsCloudModel(
    Guid accountId,
    Guid projectId,
    string folderId,
    string modelName
)
Visual Basic
Public Sub SaveAsCloudModel ( _
    accountId As Guid, _
    projectId As Guid, _
    folderId As String, _
    modelName As String _
)
Visual C++
public:
void SaveAsCloudModel(
    Guid accountId,
    Guid projectId,
    String^ folderId,
    String^ modelName
)

Parameters

accountId
Type: System..::..Guid
The BIM 360 Docs or Autodesk Docs account Id. You can use one of the following methods to get this Id:
  • If you get the hub Id with Forge Data Management API, remove the prefix "b." of the Id string and convert the rest to a Guid.
  • If you get the account Id with Forge BIM 360 Docs or Autodesk Docs API, just convert the Id string to a Guid.
projectId
Type: System..::..Guid
The BIM 360 Docs or Autodesk Docs project Id. You can use one of the following methods to get this Id:
  • If you get the project Id with Forge Data Management API, remove the prefix "b." of the Id string and convert the rest to a Guid.
  • If you get the project Id with Forge BIM 360 Docs or Autodesk Docs API, just convert the Id string to a Guid.
folderId
Type: System..::..String
Folder identity in BIM 360 Docs or Autodesk Docs to save the model. You can use one of the following methods to get this Id:
  • The folder Id string from Forge Data Management API.
  • The folder Id string from Forge BIM 360 Docs or Autodesk Docs API.
modelName
Type: System..::..String
Model name in BIM 360 Docs or Autodesk Docs to save the model.

Remarks

Assumes that user is currently signed in BIM 360 Docs or Autodesk Docs and has access to Autodesk cloud services. This operation will create a model on cloud and then create a local cache of the cloud model. This method cannot be used when current document is already in cloud.

You can use one of the following methods to save a local model as a workshared cloud model in BIM 360 Docs or Autodesk Docs.

  • If the local model is a workshared model, then it will be a workshared cloud model after you use this method successfully.
  • If the local model is a non-workshared model, you can enable the workset with EnableWorksharing(String, String) and then save as a workshared cloud model.
  • If the local model is a non-workshared model, and you have already saved it as a non-workshared cloud model in BIM 360 Docs or Autodesk Docs, you can still enable the workset with EnableCloudWorksharing()()()() to convert it to a workshared cloud model.

You cannot save a local workshared model as a non-workshared cloud model in BIM 360 Docs or Autodesk Docs.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | folderId is an empty string. -or- modelName is an empty string. -or- The input file name "modelName" does not represent a valid file name. -or- Thrown when the input BIM 360 Docs or Autodesk Docs account Id or project Id is invalid or unmatched.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | SaveAs may not be called during dynamic update.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Saving is not allowed in the current application mode. -or- This Document is not a project document. -or- This Document is in an edit mode. -or- This Document is not a primary document, it is a linked document. -or- SaveAs is temporarily disabled. -or- This Document is a cloud model, cannot be saved as a cloud model. -or- There is a transaction phase left open (such as a transaction, sub-transaction of transaction group) at the time of invoking this method.
Autodesk.Revit.Exceptions..::..RevitServerCommunicationException | Could be for any of the reasons related to network.
Autodesk.Revit.Exceptions..::..RevitServerInternalException | Could be for any of the reasons that saveAs fails with RevitServerInternalException.
Autodesk.Revit.Exceptions..::..RevitServerModelAlreadyExistsException | Failed due to there is a model with the same name already exists at the specified location.
Autodesk.Revit.Exceptions..::..RevitServerModelNameBreaksConventionException | Failed due to the model name is breaking project naming convention.
Autodesk.Revit.Exceptions..::..RevitServerUnauthenticatedUserException | User is not signed in with Autodesk id.
Autodesk.Revit.Exceptions..::..RevitServerUnauthorizedException | You don't have the entitlement to perform the operation to this this Document. -or- User is not authorized to access the specified cloud project.

See Also

Document Class


SaveCloudModel Method

[image]

Revit 2024 API
Document..::..SaveCloudModel Method
Document Class See Also Send Feedback
Saves cloud model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019.2

Syntax

C#
public void SaveCloudModel()
Visual Basic
Public Sub SaveCloudModel
Visual C++
public:
void SaveCloudModel()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..CentralModelAccessDeniedException | Could be for any of the reasons that related to access to the cloud model.
Autodesk.Revit.Exceptions..::..CentralModelContentionException | The central model is locked by another client.
Autodesk.Revit.Exceptions..::..CentralModelException | Could be for any of the reasons that fails with CentralModelException, for example, a central model with that name is already associated to the specified cloud project.
Autodesk.Revit.Exceptions..::..FileNotFoundException | Cannot access the local file.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This Document is not a primary document, it is a linked document. -or- This Document is read-only: It cannot be modified. -or- This Document has an open editing transaction and is accepting changes. -or- This Document is not a project document. -or- This Document is in an edit mode. -or- Saving is not allowed in the current application mode. -or- This Document does not have a central location: Worksharing needs to be enabled and central model saved. -or- The file is read-only, can not be saved. -or- This Document is a not cloud model, cannot execute this operation. -or- This Document is a workshared document. -or- Operation is not permitted when there is any open sub-transaction, transaction, or transaction group.
Autodesk.Revit.Exceptions..::..OperationCanceledException | Synchronize With Central was canceled by the user or by an API event callback.
Autodesk.Revit.Exceptions..::..RevitServerCommunicationException | Could be for any of the reasons related to network.
Autodesk.Revit.Exceptions..::..RevitServerInternalException | Could be for any of the reasons that save fails with RevitServerInternalException.
Autodesk.Revit.Exceptions..::..RevitServerUnauthenticatedUserException | User is not signed in with Autodesk id.
Autodesk.Revit.Exceptions..::..RevitServerUnauthorizedException | User is not authorized to access the specified cloud project.

See Also

Document Class


SaveToProjectAsImage Method

[image]

Revit 2024 API
Document..::..SaveToProjectAsImage Method
Document Class See Also Send Feedback
Creates an image view from the currently active view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public ElementId SaveToProjectAsImage(
    ImageExportOptions options
)
Visual Basic
Public Function SaveToProjectAsImage ( _
    options As ImageExportOptions _
) As ElementId
Visual C++
public:
ElementId^ SaveToProjectAsImage(
    ImageExportOptions^ options
)

Parameters

options
Type: Autodesk.Revit.DB..::..ImageExportOptions
The options which govern the image creation.

Return Value

Id of the newly created view if the operation succeeded, invalid element id otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | options object is invalid: the ExportRange is invalid, must be CurrentView or VisibleRegionOfCurrentView, or the ViewName is invalid, must be non-empty, unique and should not contain prohibited characters. -or- The current view cannot be exported as an image
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Document Class


SeparateElements Method

[image]

Revit 2024 API
Document..::..SeparateElements Method
Document Class See Also Send Feedback
Separate a set of combinable elements out of combinations they currently belong to.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SeparateElements(
    CombinableElementArray members
)
Visual Basic
Public Sub SeparateElements ( _
    members As CombinableElementArray _
)
Visual C++
public:
void SeparateElements(
    CombinableElementArray^ members
)

Parameters

members
Type: Autodesk.Revit.DB..::..CombinableElementArray
A list of combinable elements to be separated.

Remarks

If geometry combination elements are passed as input, they will be completely separated and deleted. If generic forms that happen to belong to combination elements are passed, these forms will be removed from their geometry combination. The handles of geometry combinations completely removed by this operation are no longer valid.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when members is empty. Thrown when members contains nullNothingnullptra null reference (Nothing in Visual Basic) elements.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when separation failed.

See Also

Document Class


SetDefaultElementTypeId Method

[image]

Revit 2024 API
Document..::..SetDefaultElementTypeId Method
Document Class See Also Send Feedback
Sets the default element type id of the given DefaultElementType id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public void SetDefaultElementTypeId(
    ElementTypeGroup defaultTypeId,
    ElementId typeId
)
Visual Basic
Public Sub SetDefaultElementTypeId ( _
    defaultTypeId As ElementTypeGroup, _
    typeId As ElementId _
)
Visual C++
public:
void SetDefaultElementTypeId(
    ElementTypeGroup defaultTypeId,
    ElementId^ typeId
)

Parameters

defaultTypeId
Type: Autodesk.Revit.DB..::..ElementTypeGroup
The default element type id.
typeId
Type: Autodesk.Revit.DB..::..ElementId
The element type id.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element type id typeId is invalid for the give DefaultElementType id defaultTypeId.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

Document Class


SetDefaultFamilyTypeId Method

[image]

Revit 2024 API
Document..::..SetDefaultFamilyTypeId Method
Document Class Example See Also Send Feedback
Sets the default family type id for the given family category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public void SetDefaultFamilyTypeId(
    ElementId familyCategoryId,
    ElementId familyTypeId
)
Visual Basic
Public Sub SetDefaultFamilyTypeId ( _
    familyCategoryId As ElementId, _
    familyTypeId As ElementId _
)
Visual C++
public:
void SetDefaultFamilyTypeId(
    ElementId^ familyCategoryId,
    ElementId^ familyTypeId
)

Parameters

familyCategoryId
Type: Autodesk.Revit.DB..::..ElementId
The family category id.
familyTypeId
Type: Autodesk.Revit.DB..::..ElementId
The default family type id.

Examples

CopyC#
private void SetDefaultTypeFromDoor(Document document, FamilyInstance door)
{
    ElementId doorCategoryId = new ElementId(BuiltInCategory.OST_Doors);

    // It is necessary to test the type suitability to be a default family type, for not every type can be set as default.
    // Trying to set a non-qualifying default type will cause an exception
    if (door.Symbol.IsValidDefaultFamilyType(doorCategoryId))
    {
        document.SetDefaultFamilyTypeId(doorCategoryId, door.Symbol.Id);
    }
}
CopyVB.NET
Private Sub SetDefaultTypeFromDoor(document As Document, door As FamilyInstance)
   Dim doorCategoryId As New ElementId(BuiltInCategory.OST_Doors)

   ' It is necessary to test the type suitability to be a default family type, for not every type can be set as default.
   ' Trying to set a non-qualifying default type will cause an exception
   If door.Symbol.IsValidDefaultFamilyType(doorCategoryId) Then
      document.SetDefaultFamilyTypeId(doorCategoryId, door.Symbol.Id)
   End If
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The family type id familyTypeId is invalid for the give family category familyCategoryId.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Document Class


SetUnits Method

[image]

Revit 2024 API
Document..::..SetUnits Method
Document Class See Also Send Feedback
Sets the units.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void SetUnits(
    Units units
)
Visual Basic
Public Sub SetUnits ( _
    units As Units _
)
Visual C++
public:
void SetUnits(
    Units^ units
)

Parameters

units
Type: Autodesk.Revit.DB..::..Units
The units.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Document Class


SynchronizeWithCentral Method

[image]

Revit 2024 API
Document..::..SynchronizeWithCentral Method
Document Class Example See Also Send Feedback
Performs reload latest until the model in the current session is up to date and then saves changes back to central. A save to central is performed even if no changes were made.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void SynchronizeWithCentral(
    TransactWithCentralOptions transactOptions,
    SynchronizeWithCentralOptions syncOptions
)
Visual Basic
Public Sub SynchronizeWithCentral ( _
    transactOptions As TransactWithCentralOptions, _
    syncOptions As SynchronizeWithCentralOptions _
)
Visual C++
public:
void SynchronizeWithCentral(
    TransactWithCentralOptions^ transactOptions,
    SynchronizeWithCentralOptions^ syncOptions
)

Parameters

transactOptions
Type: Autodesk.Revit.DB..::..TransactWithCentralOptions
Options to customize behavior accessing the central model.
syncOptions
Type: Autodesk.Revit.DB..::..SynchronizeWithCentralOptions
Options to customize behavior of SynchronizeWithCentral.

Examples

CopyC#
public void SyncWithoutRelinquishing(Document doc)
{
    // Set options for accessing central model
    TransactWithCentralOptions transOpts = new TransactWithCentralOptions();
    SynchLockCallback transCallBack = new SynchLockCallback();
    // Override default behavior of waiting to try again if the central model is locked
    transOpts.SetLockCallback(transCallBack);

    // Set options for synchronizing with central
    SynchronizeWithCentralOptions syncOpts = new SynchronizeWithCentralOptions();
    // Sync without relinquishing any checked out elements or worksets
    RelinquishOptions relinquishOpts = new RelinquishOptions(false);
    syncOpts.SetRelinquishOptions(relinquishOpts);
    // Do not automatically save local model after sync
    syncOpts.SaveLocalAfter = false;
    syncOpts.Comment = "Changes to Workset1";

    try
    {
        doc.SynchronizeWithCentral(transOpts, syncOpts);
    }
    catch (Exception e)
    {
        TaskDialog.Show("Synchronize Failed", e.Message);
    }
}

// This class implements the ICentralLockedCallback to override Revit's default
// behavior for how to handle when the central model is locked by another user
class SynchLockCallback : ICentralLockedCallback
{
    // If unable to lock central, give up rather than waiting
    public bool ShouldWaitForLockAvailability()
    {
        return false;
    }

}
CopyVB.NET
Public Sub SyncWithoutRelinquishing(doc As Document)
    ' Set options for accessing central model
    Dim transOpts As New TransactWithCentralOptions()
    Dim transCallBack As New SynchLockCallback()
    ' Override default behavior of waiting to try again if the central model is locked
    transOpts.SetLockCallback(transCallBack)

    ' Set options for synchronizing with central
    Dim syncOpts As New SynchronizeWithCentralOptions()
    ' Sync without relinquishing any checked out elements or worksets
    Dim relinquishOpts As New RelinquishOptions(False)
    syncOpts.SetRelinquishOptions(relinquishOpts)
    ' Do not automatically save local model after sync
    syncOpts.SaveLocalAfter = False
    syncOpts.Comment = "Changes to Workset1"

    Try
        doc.SynchronizeWithCentral(transOpts, syncOpts)
    Catch e As Exception
        TaskDialog.Show("Synchronize Failed", e.Message)
    End Try
End Sub

' This class implements the ICentralLockedCallback to override Revit's default
' behavior for how to handle when the central model is locked by another user
Private Class SynchLockCallback
    Implements ICentralLockedCallback
    ' If unable to lock central, give up rather than waiting
    Public Function ShouldWaitForLockAvailability() As Boolean Implements ICentralLockedCallback.ShouldWaitForLockAvailability
        Return False
    End Function

End Class

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..CentralFileCommunicationException | The file-based central model could not be reached, because e.g. the network is down or the file server is down.
Autodesk.Revit.Exceptions..::..CentralModelAccessDeniedException | Access to the central model was denied due to lack of access privileges. -or- Access to the central model was denied. A possible reason is because the model was under maintenance.
Autodesk.Revit.Exceptions..::..CentralModelContentionException | The central model is locked by another client.
Autodesk.Revit.Exceptions..::..CentralModelException | Username does not match the one used to create the local file. -or- Revit could not save all of the worksets that have been changed. Try again. -or- Some of the elements you changed in this model are now editable by someone else, or you checked out worksets that were at risk or relinquished in the central model but not this file. You cannot synchronize with the central model until the other user relinquishes these elements without making changes. -or- The central model has been replaced by a local model. -or- Local incompatible because it was closed without saving after synchronizing with central. -or- The central model is missing. -or- The central model is incompatible. -or- The central model is corrupt or not an RVT file. -or- The central model was rolled back. -or- The central model's elements have been relinquished -or- Your data or permissions saving is aborted by another user. -or- The central model is overritten by other user. -or- An internal error happened on the central model, please contact the server administrator.
Autodesk.Revit.Exceptions..::..FileNotFoundException | Cannot access the local file.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This Document is not a primary document, it is a linked document. -or- This Document is read-only: It cannot be modified. -or- This Document has an open editing transaction and is accepting changes. -or- This Document is not a project document. -or- This Document is in an edit mode. -or- Saving is not allowed in the current application mode. -or- This Document does not have a central location: Worksharing needs to be enabled and central model saved. -or- This Document is a local file that is not owned by the current user, who therefore is not allowed to modify it. -or- The local file is read-only. It can not be saved before or after synchronizing with central. -or- This Document is not a workshared document. -or- Saving local before first reload latest and after saving changes to central in Synchronize with Central is mandatory for server-based local models. -or- Operation is not permitted when there is any open sub-transaction, transaction, or transaction group.
Autodesk.Revit.Exceptions..::..OperationCanceledException | Synchronize With Central was canceled by the user or by an API event callback.
Autodesk.Revit.Exceptions..::..RevitServerCommunicationException | The server-based central model could not be reached because of a network communication error.
Autodesk.Revit.Exceptions..::..RevitServerInternalException | The disk space is running low on server, please contact the server administrator. -or- An internal error happened on the server, please contact the server administrator.
Autodesk.Revit.Exceptions..::..RevitServerUnauthenticatedUserException | User is not signed in with Autodesk id.
Autodesk.Revit.Exceptions..::..RevitServerUnauthorizedException | User is not authorized to access the specified A360 project.

See Also

Document Class


UnpostFailure Method

[image]

Revit 2024 API
Document..::..UnpostFailure Method
Document Class See Also Send Feedback
Deletes the posted failure message associated with a given FailureMessageKey.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public void UnpostFailure(
    FailureMessageKey messageKey
)
Visual Basic
Public Sub UnpostFailure ( _
    messageKey As FailureMessageKey _
)
Visual C++
public:
void UnpostFailure(
    FailureMessageKey^ messageKey
)

Parameters

messageKey
Type: Autodesk.Revit.DB..::..FailureMessageKey
The key of the FailureMessage to be deleted.

Remarks

If code that previously has posted a failure is executed again or otherwise detects that failure conditions do not exist anymore and the failure is not longer relevant, it should delete a failure message in order to let transaction to be committed. In order to delete the failure, it should invoke this method with a message key that was returned when the failure was posted.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | messageKey is invalid
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

Document Class


Document Properties

[image] [image]

Revit 2024 API
Document Properties
Document Class See Also Send Feedback

The Document type exposes the following members.

Properties

 | Name | Description
Public property | ActiveProjectLocation | Retrieve the active project location.
Public property | ActiveView | The document's active view.
Public property | Application | Returns the Application in which the Document resides.
Public property | Create | An object that can be used to create new instances of Autodesk Revit API elements within a project.
Public property | CreationGUID | A unique identifier generated when the Document was first created.
Public property | DisplayUnitSystem | Provides access to display unit type with in the document.
Public property | FamilyCreate | An object that can be used to create new instances of Autodesk Revit API elements within a family document.
Public property | FamilyManager | The family manager object provides access to family types and parameters.
Public property | IsDetached | Identifies if a workshared document is detached. Also, see IsWorkshared
Public property | IsFamilyDocument | Identifies if the current document is a family document.
Public property | IsLinked | Identifies if a document is a linked RVT.
Public property | IsModelInCloud | Identifies if document is stored on Autodesk cloud services.
Public property | IsModifiable | Identifies if the document is modifiable.
Public property | IsModified | The state of changes made to the document.
Public property | IsReadOnly | Identifies if the document is read-only or can possibly be modified.
Public property | IsReadOnlyFile | Signals whether the document was opened from a read-only file.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | IsWorkshared | Identifies if worksharing (i.e. editing permissions and multiple worksets) have been enabled in the document. Also, see IsDetached
Public property | MassDisplayTemporaryOverride | This setting controls temporary display in views of objects with mass category or subcategories.
Public property | MullionTypes | This property is used to retrieve all the mullion types in current system.
Public property | OwnerFamily | Get the Family of this Family Document.
Public property | PanelTypes | Retrieves a set of PanelType objects that contains all the panel types that are currently loaded into the project.
Public property | ParameterBindings | Retrieves an object from which mappings between parameter definitions and categories can be found.
Public property | PathName | The fully qualified path of the document's disk file.
Public property | Phases | Retrieves all of the phases in the document.
Public property | PlanTopologies | Get the PlanTopologies of the current project in the last phase.
Public property | PlanTopologies[([( Phase])]) | Gets the PlanTopologies of the current project in a given phase.
Public property | PlanTopology[([( Level])]) | Get the PlanTopology of a given level in the last phase.
Public property | PlanTopology[([( Level, Phase])]) | Get the PlanTopology of a given level in a given phase.
Public property | PrintManager | Retrieve the PrintManager of current project.
Public property | ProjectInformation | Return the Project Information of the current project.
Public property | ProjectLocations | Retrieve all the project locations associated with this project
Public property | ReactionsAreUpToDate | Reports if the analytical model has regenerated in a document with reaction loads.
Public property | Settings | Provides access to general application settings, such as Categories.
Public property | SiteLocation | Returns the site location information.
Public property | Title | The document's title.
Public property | TypeOfStorage | Get the storage type of the specified BuiltInParameter.
Public property | WorksharingCentralGUID | The central GUID of the server-based model.

See Also

Document Class


ActiveView Property

[image]

Revit 2024 API
Document..::..ActiveView Property
Document Class Example See Also Send Feedback
The document's active view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public View ActiveView { get; }
Visual Basic
Public ReadOnly Property ActiveView As View
    Get
Visual C++
public:
property View^ ActiveView {
    View^ get ();
}

Field Value

The active view is the view that last had focus in the UI. nullNothingnullptra null reference (Nothing in Visual Basic) if no view is considered active.

Examples

CopyC#
// Get the active view of the current document.
Autodesk.Revit.DB.View view = document.ActiveView;

// Get the class type of the active view, and format the prompt string
String prompt = "Revit is currently in ";
if (view is Autodesk.Revit.DB.View3D)
{
    prompt += "3D view.";
}
else if (view is Autodesk.Revit.DB.ViewSection)
{
    prompt += "section view.";
}
else if (view is Autodesk.Revit.DB.ViewSheet)
{
    prompt += "sheet view.";
}
else if (view is Autodesk.Revit.DB.ViewDrafting)
{
    prompt += "drafting view.";
}
else
{
    prompt += "normal view, the view name is " + view.Name;
}

// Give the user some information
TaskDialog.Show("Revit",prompt);
CopyVB.NET
' Get the active view of the current document.
Dim view As Autodesk.Revit.DB.View = document.ActiveView

' Get the class type of the active view, and format the prompt string
Dim prompt As [String] = "Revit is currently in "
If TypeOf view Is Autodesk.Revit.DB.View3D Then
   prompt += "3D view."
ElseIf TypeOf view Is Autodesk.Revit.DB.ViewSection Then
   prompt += "section view."
ElseIf TypeOf view Is Autodesk.Revit.DB.ViewSheet Then
   prompt += "sheet view."
ElseIf TypeOf view Is Autodesk.Revit.DB.ViewDrafting Then
   prompt += "drafting view."
Else
   prompt += "normal view, the view name is " + view.Name
End If

' Give the user some information
TaskDialog.Show("Revit", prompt)

See Also

Document Class


Application Property

[image]

Revit 2024 API
Document..::..Application Property
Document Class See Also Send Feedback
Returns the Application in which the Document resides.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Application Application { get; }
Visual Basic
Public ReadOnly Property Application As Application
    Get
Visual C++
public:
property Application^ Application {
    Application^ get ();
}

See Also

Document Class


CreationGUID Property

[image]

Revit 2024 API
Document..::..CreationGUID Property
Document Class See Also Send Feedback
A unique identifier generated when the Document was first created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public Guid CreationGUID { get; }
Visual Basic
Public ReadOnly Property CreationGUID As Guid
    Get
Visual C++
public:
property Guid CreationGUID {
    Guid get ();
}

See Also

Document Class


DisplayUnitSystem Property

[image]

Revit 2024 API
Document..::..DisplayUnitSystem Property
Document Class See Also Send Feedback
Provides access to display unit type with in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public DisplayUnit DisplayUnitSystem { get; }
Visual Basic
Public ReadOnly Property DisplayUnitSystem As DisplayUnit
    Get
Visual C++
public:
property DisplayUnit DisplayUnitSystem {
    DisplayUnit get ();
}

Remarks

Return the display unit type, metric or imperial.

See Also

Document Class


FamilyCreate Property

[image]

Revit 2024 API
Document..::..FamilyCreate Property
Document Class See Also Send Feedback
An object that can be used to create new instances of Autodesk Revit API elements within a family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyItemFactory FamilyCreate { get; }
Visual Basic
Public ReadOnly Property FamilyCreate As FamilyItemFactory
    Get
Visual C++
public:
property FamilyItemFactory^ FamilyCreate {
    FamilyItemFactory^ get ();
}

Field Value

This object is used to create new instances of family elements within the Autodesk Revit API, such as Extrusion or Reference lines.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the current document is project document.

See Also

Document Class


FamilyManager Property

[image]

Revit 2024 API
Document..::..FamilyManager Property
Document Class See Also Send Feedback
The family manager object provides access to family types and parameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyManager FamilyManager { get; }
Visual Basic
Public ReadOnly Property FamilyManager As FamilyManager
    Get
Visual C++
public:
property FamilyManager^ FamilyManager {
    FamilyManager^ get ();
}

Remarks

This property is available when the document is a family document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the current document is project document.

See Also

Document Class


IsDetached Property

[image]

Revit 2024 API
Document..::..IsDetached Property
Document Class See Also Send Feedback
Identifies if a workshared document is detached. Also, see IsWorkshared

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool IsDetached { get; }
Visual Basic
Public ReadOnly Property IsDetached As Boolean
    Get
Visual C++
public:
property bool IsDetached {
    bool get ();
}

Remarks

Note that Title and PathName will be empty strings if a document is detached.

See Also

Document Class


IsFamilyDocument Property

[image]

Revit 2024 API
Document..::..IsFamilyDocument Property
Document Class See Also Send Feedback
Identifies if the current document is a family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsFamilyDocument { get; }
Visual Basic
Public ReadOnly Property IsFamilyDocument As Boolean
    Get
Visual C++
public:
property bool IsFamilyDocument {
    bool get ();
}

See Also

Document Class


IsLinked Property

[image]

Revit 2024 API
Document..::..IsLinked Property
Document Class See Also Send Feedback
Identifies if a document is a linked RVT.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsLinked { get; }
Visual Basic
Public ReadOnly Property IsLinked As Boolean
    Get
Visual C++
public:
property bool IsLinked {
    bool get ();
}

See Also

Document Class


IsModifiable Property

[image]

Revit 2024 API
Document..::..IsModifiable Property
Document Class See Also Send Feedback
Identifies if the document is modifiable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsModifiable { get; }
Visual Basic
Public ReadOnly Property IsModifiable As Boolean
    Get
Visual C++
public:
property bool IsModifiable {
    bool get ();
}

Remarks

This is not a permanent state such as, for example IsReadOnlyFile. Value of this property changes dynamically multiple times within the life-time of an open document. Regardless of the mode a document is opened with, the model can only be modified inside an open transaction. Furthermore, even with a transaction open, the model is not always modifiable. Though this is rather a rare situation, it can happen, most likely during model regeneration, failure processing, or some events. An attempt to modify a non-modifiable document will result in throwing a ModificationOutsideTransactionException. See also IsReadOnly

See Also

Document Class


IsModified Property

[image]

Revit 2024 API
Document..::..IsModified Property
Document Class See Also Send Feedback
The state of changes made to the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsModified { get; }
Visual Basic
Public ReadOnly Property IsModified As Boolean
    Get
Visual C++
public:
property bool IsModified {
    bool get ();
}

See Also

Document Class


IsReadOnly Property

[image]

Revit 2024 API
Document..::..IsReadOnly Property
Document Class See Also Send Feedback
Identifies if the document is read-only or can possibly be modified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsReadOnly { get; }
Visual Basic
Public ReadOnly Property IsReadOnly As Boolean
    Get
Visual C++
public:
property bool IsReadOnly {
    bool get ();
}

Remarks

Like the IsModifiable, IsReadOnly is also a dynamic property. It's value can change depending on the state a document is currently in. There are various factors that may affect this property. The most probable reason for this property to return 'true' is when Revit is currently processing failures (recoverable or not). Another possibility is when an external command is executed in read-only mode. If a document is in a read-only state, then not only the model cannot be modified at the moment, but even a new transaction may not be started. Attempting to do so will raise an InvalidOperationException.

See Also

Document Class


IsReadOnlyFile Property

[image]

Revit 2024 API
Document..::..IsReadOnlyFile Property
Document Class See Also Send Feedback
Signals whether the document was opened from a read-only file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsReadOnlyFile { get; }
Visual Basic
Public ReadOnly Property IsReadOnlyFile As Boolean
    Get
Visual C++
public:
property bool IsReadOnlyFile {
    bool get ();
}

Remarks

A document could be opened this way when, for example, at the time of opening the file was being used by another Revit user, or if the disk file has the read-only attribute set.

Although it will still be possible to modify the opened document, any changes made there will not be possible to save into the original file. If the changes are to be preserved, the document must be saved under a different name using the SaveAs() method.

See Also

Document Class


IsValidObject Property

[image]

Revit 2024 API
Document..::..IsValidObject Property
Document Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

Document Class


IsWorkshared Property

[image]

Revit 2024 API
Document..::..IsWorkshared Property
Document Class See Also Send Feedback
Identifies if worksharing (i.e. editing permissions and multiple worksets) have been enabled in the document. Also, see IsDetached

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsWorkshared { get; }
Visual Basic
Public ReadOnly Property IsWorkshared As Boolean
    Get
Visual C++
public:
property bool IsWorkshared {
    bool get ();
}

See Also

Document Class


MassDisplayTemporaryOverride Property

[image]

Revit 2024 API
Document..::..MassDisplayTemporaryOverride Property
Document Class See Also Send Feedback
This setting controls temporary display in views of objects with mass category or subcategories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public MassDisplayTemporaryOverrideType MassDisplayTemporaryOverride { get; set; }
Visual Basic
Public Property MassDisplayTemporaryOverride As MassDisplayTemporaryOverrideType
    Get
    Set
Visual C++
public:
property MassDisplayTemporaryOverrideType MassDisplayTemporaryOverride {
    MassDisplayTemporaryOverrideType get ();
    void set (MassDisplayTemporaryOverrideType value);
}

Field Value

The MassDisplayTemporaryOverrideType that is active.

Remarks

This setting is temporary and is not stored in the document. The mass display overrides allow mass category and certain mass subcategories to be displayed in all views, regardless of the visibility settings of that view. The settings that show certain mass subcategories will also force the other mass subcategories to be hidden.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The MassDisplayTemporaryOverrideType::Enum value is not in the proper range.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

Document Class


OwnerFamily Property

[image]

Revit 2024 API
Document..::..OwnerFamily Property
Document Class Example See Also Send Feedback
Get the Family of this Family Document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Family OwnerFamily { get; }
Visual Basic
Public ReadOnly Property OwnerFamily As Family
    Get
Visual C++
public:
property Family^ OwnerFamily {
    Family^ get ();
}

Remarks

Only available if the current document is family document.

Examples

CopyC#
string categoryName = familyDoc.OwnerFamily.FamilyCategory.Name;
CopyVB.NET
Dim categoryName As String = familyDoc.OwnerFamily.FamilyCategory.Name

See Also

Document Class


PanelTypes Property

[image]

Revit 2024 API
Document..::..PanelTypes Property
Document Class See Also Send Feedback
Retrieves a set of PanelType objects that contains all the panel types that are currently loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public PanelTypeSet PanelTypes { get; }
Visual Basic
Public ReadOnly Property PanelTypes As PanelTypeSet
    Get
Visual C++
public:
property PanelTypeSet^ PanelTypes {
    PanelTypeSet^ get ();
}

Remarks

This property returns a set of panelType objects. These objects can be used change the type of a panel from one type to another.

See Also

Document Class


PathName Property

[image]

Revit 2024 API
Document..::..PathName Property
Document Class Example See Also Send Feedback
The fully qualified path of the document's disk file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string PathName { get; }
Visual Basic
Public ReadOnly Property PathName As String
    Get
Visual C++
public:
property String^ PathName {
    String^ get ();
}

Remarks

This string is empty if the project has not been saved or does not have a disk file associated with it yet. Note that the pathname will be empty if a document is detached. See IsDetached.

Examples

CopyC#
string docPathName = document.PathName;
CopyVB.NET
Dim docPathName As String = document.PathName

See Also

Document Class


Phases Property

[image]

Revit 2024 API
Document..::..Phases Property
Document Class Example See Also Send Feedback
Retrieves all of the phases in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public PhaseArray Phases { get; }
Visual Basic
Public ReadOnly Property Phases As PhaseArray
    Get
Visual C++
public:
property PhaseArray^ Phases {
    PhaseArray^ get ();
}

Remarks

The phases are returned in order from earliest phase to latest phase.

When Revit is running with UI activated, the default created phase for newly created elements is inherited from the phase of the currently active view.

When Revit is running without its UI, such as when Revit runs on Autodesk Forge Design Automation API for Revit, the default phase for newly created elements is the latest phase in the document.

Examples

CopyC#
void Getinfo_Phase(Document doc)
{
    // Get the phase array which contains all the phases.
    PhaseArray phases = doc.Phases;
    // Format the prompt string which identifies all supported phases in the current document.
    String prompt = null;
    if (0 != phases.Size)
    {
        prompt = "All the phases in current document list as follow:";
        foreach (Phase ii in phases)
        {
            prompt += "\n\t" + ii.Name;
        }
    }
    else
    {
        prompt = "There are no phases in current document.";
    }
    // Give the user the information.
    TaskDialog.Show("Revit",prompt);
}
CopyVB.NET
Private Sub Getinfo_Phase(doc As Document)
    ' Get the phase array which contains all the phases.
    Dim phases As PhaseArray = doc.Phases
    ' Format the prompt string which identifies all supported phases in the current document.
    Dim prompt As [String] = Nothing
    If 0 <> phases.Size Then
        prompt = "All the phases in current document list as follow:"
        For Each ii As Phase In phases
            prompt += vbLf & vbTab + ii.Name
        Next
    Else
        prompt = "There are no phases in current document."
    End If
    ' Give the user the information.
    TaskDialog.Show("Revit", prompt)
End Sub

See Also

Document Class


PlanTopologies Property

[image] [image]

Revit 2024 API
Document..::..PlanTopologies Property
Document Class See Also Send Feedback
Gets the PlanTopologies of the current project.

Overload List

 | Name | Description
Public property | PlanTopologies | Get the PlanTopologies of the current project in the last phase.
Public property | PlanTopologies[([( Phase])]) | Gets the PlanTopologies of the current project in a given phase.

See Also

Document Class
Document Members


PlanTopologies Property

[image]

Revit 2024 API
Document..::..PlanTopologies Property
Document Class See Also Send Feedback
Get the PlanTopologies of the current project in the last phase.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public PlanTopologySet PlanTopologies { get; }
Visual Basic
Public ReadOnly Property PlanTopologies As PlanTopologySet
    Get
Visual C++
public:
property PlanTopologySet^ PlanTopologies {
    PlanTopologySet^ get ();
}

Remarks

Accessing plan topologies requires that document is modifiable as it will actually trigger calculating plan topologies if they have not been calculated yet. The time necessary for the calculations may be significant and should be considered.

See Also

Document Class
PlanTopologies Overload


PlanTopologies Property (Phase)

[image]

Revit 2024 API
Document..::..PlanTopologies Property (Phase)
Document Class See Also Send Feedback
Gets the PlanTopologies of the current project in a given phase.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public PlanTopologySet this[
    Phase phase
] { get; }
Visual Basic
Public ReadOnly Property PlanTopologies ( _
    phase As Phase _
) As PlanTopologySet
    Get
Visual C++
public:
property PlanTopologySet^ PlanTopologies[Phase^ phase] {
    PlanTopologySet^ get (Phase^ phase);
}

Parameters

phase
Type: Autodesk.Revit.DB..::..Phase
The phase of the Plan Topology.

Remarks

Accessing plan topologies requires that document is modifiable as it will actually trigger calculating plan topologies if they have not been calculated yet. The time necessary for the calculations may be significant and should be considered.

See Also

Document Class
PlanTopologies Overload


PlanTopology Property

[image] [image]

Revit 2024 API
Document..::..PlanTopology Property
Document Class See Also Send Feedback
Gets the PlanTopology of a given level.

Overload List

 | Name | Description
Public property | PlanTopology[([( Level])]) | Get the PlanTopology of a given level in the last phase.
Public property | PlanTopology[([( Level, Phase])]) | Get the PlanTopology of a given level in a given phase.

See Also

Document Class
Document Members


PlanTopology Property (Level, Phase)

[image]

Revit 2024 API
Document..::..PlanTopology Property (Level, Phase)
Document Class See Also Send Feedback
Get the PlanTopology of a given level in a given phase.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public PlanTopology this[
    Level level,
    Phase phase
] { get; }
Visual Basic
Public ReadOnly Property PlanTopology ( _
    level As Level, _
    phase As Phase _
) As PlanTopology
    Get
Visual C++
public:
property PlanTopology^ PlanTopology[Level^ level, Phase^ phase] {
    PlanTopology^ get (Level^ level, Phase^ phase);
}

Parameters

level
Type: Autodesk.Revit.DB..::..Level
The level of the Plan Topology.
phase
Type: Autodesk.Revit.DB..::..Phase
The phase of the Plan Topology.

Remarks

Accessing plan topology requires that document is modifiable as it will actually trigger calculating plan topology if they have not been calculated yet. The time necessary for the calculations may be significant and should be considered.

See Also

Document Class
PlanTopology Overload


PrintManager Property

[image]

Revit 2024 API
Document..::..PrintManager Property
Document Class See Also Send Feedback
Retrieve the PrintManager of current project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public PrintManager PrintManager { get; }
Visual Basic
Public ReadOnly Property PrintManager As PrintManager
    Get
Visual C++
public:
property PrintManager^ PrintManager {
    PrintManager^ get ();
}

See Also

Document Class


ProjectInformation Property

[image]

Revit 2024 API
Document..::..ProjectInformation Property
Document Class See Also Send Feedback
Return the Project Information of the current project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ProjectInfo ProjectInformation { get; }
Visual Basic
Public ReadOnly Property ProjectInformation As ProjectInfo
    Get
Visual C++
public:
property ProjectInfo^ ProjectInformation {
    ProjectInfo^ get ();
}

Return Value

Autodesk::Revit::DB::ProjectInfo

See Also

Document Class


ProjectLocations Property

[image]

Revit 2024 API
Document..::..ProjectLocations Property
Document Class See Also Send Feedback
Retrieve all the project locations associated with this project

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ProjectLocationSet ProjectLocations { get; }
Visual Basic
Public ReadOnly Property ProjectLocations As ProjectLocationSet
    Get
Visual C++
public:
property ProjectLocationSet^ ProjectLocations {
    ProjectLocationSet^ get ();
}

Remarks

This property returns all the locations of the project. A project can have one site location but many project locations within that site. Each project location object is an offset and rotation from the site location.

See Also

Document Class


ReactionsAreUpToDate Property

[image]

Revit 2024 API
Document..::..ReactionsAreUpToDate Property
Document Class See Also Send Feedback
Reports if the analytical model has regenerated in a document with reaction loads.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool ReactionsAreUpToDate { get; }
Visual Basic
Public ReadOnly Property ReactionsAreUpToDate As Boolean
    Get
Visual C++
public:
property bool ReactionsAreUpToDate {
    bool get ();
}

Remarks

Revit sets this property to False after regeneration of the analytical model if the document contains loads that have isReaction=True. This results in a user-visible warning that exists until there are no longer loads with isReaction=True.

See Also

Document Class


Settings Property

[image]

Revit 2024 API
Document..::..Settings Property
Document Class See Also Send Feedback
Provides access to general application settings, such as Categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Settings Settings { get; }
Visual Basic
Public ReadOnly Property Settings As Settings
    Get
Visual C++
public:
property Settings^ Settings {
    Settings^ get ();
}

Remarks

Returns an object that provides access to various settings within Autodesk Revit. The Settings property returns an object that provides access to the categories within the Autodesk Revit project.

See Also

Document Class


SiteLocation Property

[image]

Revit 2024 API
Document..::..SiteLocation Property
Document Class See Also Send Feedback
Returns the site location information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public SiteLocation SiteLocation { get; }
Visual Basic
Public ReadOnly Property SiteLocation As SiteLocation
    Get
Visual C++
public:
property SiteLocation^ SiteLocation {
    SiteLocation^ get ();
}

Remarks

The SiteLocation property returns an object that contains the site location for the entire project.

See Also

Document Class


Title Property

[image]

Revit 2024 API
Document..::..Title Property
Document Class See Also Send Feedback
The document's title.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string Title { get; }
Visual Basic
Public ReadOnly Property Title As String
    Get
Visual C++
public:
property String^ Title {
    String^ get ();
}

Remarks

Title is derived from the document's filename, not including the filename extension. Note that returned title will be defaulted if no document saved. Note that returned string may be empty if a document is detached. See IsDetached.

See Also

Document Class


TypeOfStorage Property

[image]

Revit 2024 API
Document..::..TypeOfStorage Property
Document Class See Also Send Feedback
Get the storage type of the specified BuiltInParameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public StorageType this[
    BuiltInParameter A_0
] { get; }
Visual Basic
Public ReadOnly Property TypeOfStorage ( _
    A_0 As BuiltInParameter _
) As StorageType
    Get
Visual C++
public:
property StorageType TypeOfStorage[BuiltInParameter A_0] {
    StorageType get (BuiltInParameter A_0);
}

Parameters

A_0
Type: Autodesk.Revit.DB..::..BuiltInParameter

See Also

Document Class


WorksharingCentralGUID Property

[image]

Revit 2024 API
Document..::..WorksharingCentralGUID Property
Document Class See Also Send Feedback
The central GUID of the server-based model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public Guid WorksharingCentralGUID { get; }
Visual Basic
Public ReadOnly Property WorksharingCentralGUID As Guid
    Get
Visual C++
public:
property Guid WorksharingCentralGUID {
    Guid get ();
}

Remarks

The central model of this document that is file-based model or saved in a release prior to Revit 2013 did not have this GUID. Only the central model saved in Revit 2013 or later and stored on Revit Server will be able to provide this value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | Thrown when the central model of this document is not a server-based model that created in Revit 2013 or later release.

See Also

Document Class


Document Events

[image] [image]

Revit 2024 API
Document Events
Document Class See Also Send Feedback

The Document type exposes the following members.

Events

 | Name | Description
Public event | DocumentClosing | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
Public event | DocumentPrinted | Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.
Public event | DocumentPrinting | Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.
Public event | DocumentSaved | Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving a document.
Public event | DocumentSavedAs | Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.
Public event | DocumentSaving | Subscribe to the DocumentSaving event to be notified when Revit is just about to save a document.
Public event | DocumentSavingAs | Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.
Public event | ViewPrinted | Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.
Public event | ViewPrinting | Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.

See Also

Document Class


DocumentClosing Event

[image]

Revit 2024 API
Document..::..DocumentClosing Event
Document Class See Also Send Feedback
Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2010

Syntax

C#
public event EventHandler<DocumentClosingEventArgs> DocumentClosing
Visual Basic
Public Event DocumentClosing As EventHandler(Of DocumentClosingEventArgs)
Visual C++
public:
 event EventHandler<DocumentClosingEventArgs^>^ DocumentClosing {
    void add (EventHandler<DocumentClosingEventArgs^>^ value);
    void remove (EventHandler<DocumentClosingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to close a document.

This event is cancellable, except when it is raised as part of application closing. Check the 'Cancellable' property of event's argument to see whether it is cancellable or not. When it is cancellable, call the 'Cancel()' method of event's argument to True to cancel it. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document may not be modified during this event.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another Autodesk::Revit::ApplicationServices::Application::DocumentClosed event will be raised immediately after document is closed.

See Also

Document Class


DocumentPrinted Event

[image]

Revit 2024 API
Document..::..DocumentPrinted Event
Document Class See Also Send Feedback
Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2010

Syntax

C#
public event EventHandler<DocumentPrintedEventArgs> DocumentPrinted
Visual Basic
Public Event DocumentPrinted As EventHandler(Of DocumentPrintedEventArgs)
Visual C++
public:
 event EventHandler<DocumentPrintedEventArgs^>^ DocumentPrinted {
    void add (EventHandler<DocumentPrintedEventArgs^>^ value);
    void remove (EventHandler<DocumentPrintedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished printing a view or ViewSet of the document. It is raised even when document printing failed or was cancelled (during DocumentPriting event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event's argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of printing has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Document Class


DocumentPrinting Event

[image]

Revit 2024 API
Document..::..DocumentPrinting Event
Document Class See Also Send Feedback
Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2010

Syntax

C#
public event EventHandler<DocumentPrintingEventArgs> DocumentPrinting
Visual Basic
Public Event DocumentPrinting As EventHandler(Of DocumentPrintingEventArgs)
Visual C++
public:
 event EventHandler<DocumentPrintingEventArgs^>^ DocumentPrinting {
    void add (EventHandler<DocumentPrintingEventArgs^>^ value);
    void remove (EventHandler<DocumentPrintingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to print a view or ViewSet of the document.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is cancellable. To cancel it, call the 'Cancel()' method of event's argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for current document during this event:

  • All overloads of Autodesk.Revit.DB.Document.Export()
  • Autodesk::Revit::DB::Document::Print
  • Print()()()() and similar overloads.
  • SubmitPrint()()()() and similar overloads.
  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

After this event, for each view being printed,ViewPrinting and ViewPrinted events will be raised. Another event DocumentPrinted will be raised immediately after document printing is finished.

See Also

Document Class


DocumentSaved Event

[image]

Revit 2024 API
Document..::..DocumentSaved Event
Document Class See Also Send Feedback
Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving a document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2010

Syntax

C#
public event EventHandler<DocumentSavedEventArgs> DocumentSaved
Visual Basic
Public Event DocumentSaved As EventHandler(Of DocumentSavedEventArgs)
Visual C++
public:
 event EventHandler<DocumentSavedEventArgs^>^ DocumentSaved {
    void add (EventHandler<DocumentSavedEventArgs^>^ value);
    void remove (EventHandler<DocumentSavedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished saving a document. Note that the first save of a newly created document will raise DocumentSavedAs rather than the DocumentSaved event. It is raised even when document saving failed or was cancelled (during DocumentSaving event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' property in event's argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of saving document has already been finished.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Document Class


DocumentSavedAs Event

[image]

Revit 2024 API
Document..::..DocumentSavedAs Event
Document Class See Also Send Feedback
Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2010

Syntax

C#
public event EventHandler<DocumentSavedAsEventArgs> DocumentSavedAs
Visual Basic
Public Event DocumentSavedAs As EventHandler(Of DocumentSavedAsEventArgs)
Visual C++
public:
 event EventHandler<DocumentSavedAsEventArgs^>^ DocumentSavedAs {
    void add (EventHandler<DocumentSavedAsEventArgs^>^ value);
    void remove (EventHandler<DocumentSavedAsEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished saving document with a new file name. Note that the first save of a newly created document will raise DocumentSavedAs rather than DocumentSaved event. It is raised even when document saving failed or was cancelled (during DocumentSavingAs event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' property in event's argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of saving document has already been finished.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Document Class


DocumentSaving Event

[image]

Revit 2024 API
Document..::..DocumentSaving Event
Document Class See Also Send Feedback
Subscribe to the DocumentSaving event to be notified when Revit is just about to save a document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2010

Syntax

C#
public event EventHandler<DocumentSavingEventArgs> DocumentSaving
Visual Basic
Public Event DocumentSaving As EventHandler(Of DocumentSavingEventArgs)
Visual C++
public:
 event EventHandler<DocumentSavingEventArgs^>^ DocumentSaving {
    void add (EventHandler<DocumentSavingEventArgs^>^ value);
    void remove (EventHandler<DocumentSavingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to save the document. Note that the first save of a newly created document will raise DocumentSavingAs rather than the DocumentSaving event.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

This event is cancellable, except when it is raised during close of the application. Check the 'Cancellable' property of event's argument to see whether it is cancellable or not. When it is cancellable, call the 'Cancel()' method of event's argument to cancel it. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event DocumentSaved will be raised immediately after the document has been saved.

See Also

Document Class


ViewPrinted Event

[image]

Revit 2024 API
Document..::..ViewPrinted Event
Document Class See Also Send Feedback
Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2010

Syntax

C#
public event EventHandler<ViewPrintedEventArgs> ViewPrinted
Visual Basic
Public Event ViewPrinted As EventHandler(Of ViewPrintedEventArgs)
Visual C++
public:
 event EventHandler<ViewPrintedEventArgs^>^ ViewPrinted {
    void add (EventHandler<ViewPrintedEventArgs^>^ value);
    void remove (EventHandler<ViewPrintedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished printing a view of the document. If multiple views are combined to a single file, this event will be raised only once. It is raised even when view printing failed.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event's argument to see whether the action was successful or not.

This event is not cancellable, for the process of view printing has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Document Class


ViewPrinting Event

[image]

Revit 2024 API
Document..::..ViewPrinting Event
Document Class See Also Send Feedback
Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2010

Syntax

C#
public event EventHandler<ViewPrintingEventArgs> ViewPrinting
Visual Basic
Public Event ViewPrinting As EventHandler(Of ViewPrintingEventArgs)
Visual C++
public:
 event EventHandler<ViewPrintingEventArgs^>^ ViewPrinting {
    void add (EventHandler<ViewPrintingEventArgs^>^ value);
    void remove (EventHandler<ViewPrintingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to print a view of the document. If multiple views are combined to a single file, this event will be raised only once.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is not cancellable. The 'Cancellable' property of event's argument is always False.

The following API functions are not available for the current document during this event:

  • All overloads of Autodesk.Revit.DB.Document.Export()
  • Autodesk.Revit.DB.Document.Print()
  • Print()()()() and similar overloads.
  • SubmitPrint()()()() and similar overloads.
  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event ViewPrinted will be raised immediately after view printing is finished.

See Also

Document Class


DocumentDifference Class

[image]

Revit 2024 API
DocumentDifference Class
Members See Also Send Feedback
DocumentDifference represents the difference (including added elements, modified elements and deleted elements) of a Revit model between different DocumentVersion of the model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public class DocumentDifference : IDisposable
Visual Basic
Public Class DocumentDifference _
    Implements IDisposable
Visual C++
public ref class DocumentDifference : IDisposable

Remarks

For workshared models, DocumentDifference may contain all the added elements, modified elements and deleted elements. For non-workshared models, deleted elements are not tracked, so this object may only contain added elements and modified elements.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..DocumentDifference

See Also

DocumentDifference Members


DocumentDifference Members

[image] [image]

Revit 2024 API
DocumentDifference Members
DocumentDifference Class Methods Properties See Also Send Feedback

The DocumentDifference type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the DocumentDifference
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCreatedElementIds | Created element id collection.
Public method | GetDeletedElementIds | Deleted element id collection. For non-worksharing models, this will always be an empty collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetModifiedElementIds | Modified element id collection.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AreDeletedElementIdsAvailable | Whether or the deleted elements were retrieved.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

DocumentDifference Class


Dispose Method

[image]

Revit 2024 API
DocumentDifference..::..Dispose Method
DocumentDifference Class See Also Send Feedback
Releases all resources used by the DocumentDifference

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

DocumentDifference Class


GetCreatedElementIds Method

[image]

Revit 2024 API
DocumentDifference..::..GetCreatedElementIds Method
DocumentDifference Class See Also Send Feedback
Created element id collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public ISet<ElementId> GetCreatedElementIds()
Visual Basic
Public Function GetCreatedElementIds As ISet(Of ElementId)
Visual C++
public:
ISet<ElementId^>^ GetCreatedElementIds()

See Also

DocumentDifference Class


GetDeletedElementIds Method

[image]

Revit 2024 API
DocumentDifference..::..GetDeletedElementIds Method
DocumentDifference Class See Also Send Feedback
Deleted element id collection. For non-worksharing models, this will always be an empty collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public ISet<ElementId> GetDeletedElementIds()
Visual Basic
Public Function GetDeletedElementIds As ISet(Of ElementId)
Visual C++
public:
ISet<ElementId^>^ GetDeletedElementIds()

See Also

DocumentDifference Class


DocumentDifference Properties

[image] [image]

Revit 2024 API
DocumentDifference Properties
DocumentDifference Class See Also Send Feedback

The DocumentDifference type exposes the following members.

Properties

 | Name | Description
Public property | AreDeletedElementIdsAvailable | Whether or the deleted elements were retrieved.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

DocumentDifference Class


AreDeletedElementIdsAvailable Property

[image]

Revit 2024 API
DocumentDifference..::..AreDeletedElementIdsAvailable Property
DocumentDifference Class See Also Send Feedback
Whether or the deleted elements were retrieved.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public bool AreDeletedElementIdsAvailable { get; }
Visual Basic
Public ReadOnly Property AreDeletedElementIdsAvailable As Boolean
    Get
Visual C++
public:
property bool AreDeletedElementIdsAvailable {
    bool get ();
}

See Also

DocumentDifference Class


IsValidObject Property

[image]

Revit 2024 API
DocumentDifference..::..IsValidObject Property
DocumentDifference Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

DocumentDifference Class


DocumentPreviewSettings Members

[image] [image]

Revit 2024 API
DocumentPreviewSettings Members
DocumentPreviewSettings Class Methods Properties See Also Send Feedback

The DocumentPreviewSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the DocumentPreviewSettings
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForceViewUpdate | Sets Revit to update the preview view if necessary.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsViewIdValidForPreview | Identifies if the view id is valid as a preview view id.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | IsViewUpdateForced | Identifies if Revit will update the preview view if necessary.
Public property | PreviewViewId | The view id that will be used to generate the preview.

See Also

DocumentPreviewSettings Class


DocumentPreviewSettings Methods

[image] [image]

Revit 2024 API
DocumentPreviewSettings Methods
DocumentPreviewSettings Class See Also Send Feedback

The DocumentPreviewSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForceViewUpdate | Sets Revit to update the preview view if necessary.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsViewIdValidForPreview | Identifies if the view id is valid as a preview view id.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DocumentPreviewSettings Class


Dispose Method

[image]

Revit 2024 API
DocumentPreviewSettings..::..Dispose Method
DocumentPreviewSettings Class See Also Send Feedback
Releases all resources used by the DocumentPreviewSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

DocumentPreviewSettings Class


ForceViewUpdate Method

[image]

Revit 2024 API
DocumentPreviewSettings..::..ForceViewUpdate Method
DocumentPreviewSettings Class See Also Send Feedback
Sets Revit to update the preview view if necessary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public void ForceViewUpdate(
    bool forceViewUpdate
)
Visual Basic
Public Sub ForceViewUpdate ( _
    forceViewUpdate As Boolean _
)
Visual C++
public:
void ForceViewUpdate(
    bool forceViewUpdate
)

Parameters

forceViewUpdate
Type: System..::..Boolean
True to force update of the preview view. False to skip update if necessary (the default).

Remarks

An update is necessary if the view has never been displayed, or if the model has been changed and the view has not been updated or accessed. If the preview view has not been updated, the preview may not be properly saved.

This setting applies only to a single Save operation and is reset to false after it is accessed.

See Also

DocumentPreviewSettings Class


IsViewIdValidForPreview Method

[image]

Revit 2024 API
DocumentPreviewSettings..::..IsViewIdValidForPreview Method
DocumentPreviewSettings Class See Also Send Feedback
Identifies if the view id is valid as a preview view id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public bool IsViewIdValidForPreview(
    ElementId viewId
)
Visual Basic
Public Function IsViewIdValidForPreview ( _
    viewId As ElementId _
) As Boolean
Visual C++
public:
bool IsViewIdValidForPreview(
    ElementId^ viewId
)

Parameters

viewId
Type: Autodesk.Revit.DB..::..ElementId
The view id.

Return Value

True if the view id is valid for preview, false otherwise.

Remarks

Only graphical views (3d or 2d) are valid for use as a preview view. Other views (such as view templates) will not pass this method. InvalidElementId is accepted by this method as this id means that no special view is set for the preview.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DocumentPreviewSettings Class


DocumentPreviewSettings Properties

[image] [image]

Revit 2024 API
DocumentPreviewSettings Properties
DocumentPreviewSettings Class See Also Send Feedback

The DocumentPreviewSettings type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | IsViewUpdateForced | Identifies if Revit will update the preview view if necessary.
Public property | PreviewViewId | The view id that will be used to generate the preview.

See Also

DocumentPreviewSettings Class


IsViewUpdateForced Property

[image]

Revit 2024 API
DocumentPreviewSettings..::..IsViewUpdateForced Property
DocumentPreviewSettings Class See Also Send Feedback
Identifies if Revit will update the preview view if necessary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public bool IsViewUpdateForced { get; }
Visual Basic
Public ReadOnly Property IsViewUpdateForced As Boolean
    Get
Visual C++
public:
property bool IsViewUpdateForced {
    bool get ();
}

Remarks

This setting applies only to a single Save operation and is reset to false after it is accessed.

See Also

DocumentPreviewSettings Class


PreviewViewId Property

[image]

Revit 2024 API
DocumentPreviewSettings..::..PreviewViewId Property
DocumentPreviewSettings Class See Also Send Feedback
The view id that will be used to generate the preview.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public ElementId PreviewViewId { get; set; }
Visual Basic
Public Property PreviewViewId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ PreviewViewId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Field Value

InvalidElementId signals that there is no permanent preview view for the document. Where possible the document's active view will be used to generate the preview upon save; where there is no active view the document will not include a preview.

Remarks

This view will always be saved as the preview view for the document unless it is overridden by the value used in SaveOptions or SaveAsOptions.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The view id is not valid to use as a preview view.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

DocumentPreviewSettings Class


DocumentSet Constructor

[image]

Revit 2024 API
DocumentSet Constructor
DocumentSet Class See Also Send Feedback
Initializes a new instance of the DocumentSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public DocumentSet()
Visual Basic
Public Sub New
Visual C++
public:
DocumentSet()

See Also

DocumentSet Class


DocumentSet Methods

[image] [image]

Revit 2024 API
DocumentSet Methods
DocumentSet Class See Also Send Feedback

The DocumentSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of an item within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified object from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DocumentSet Class


Clear Method

[image]

Revit 2024 API
DocumentSet..::..Clear Method
DocumentSet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

DocumentSet Class


Contains Method

[image]

Revit 2024 API
DocumentSet..::..Contains Method
DocumentSet Class See Also Send Feedback
Tests for the existence of an item within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool Contains(
    Document item
)
Visual Basic
Public Overridable Function Contains ( _
    item As Document _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Document^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..Document
The item to be searched for.

Return Value

The Contains method returns True if the item is within the set, otherwise False.

See Also

DocumentSet Class


Erase Method

[image]

Revit 2024 API
DocumentSet..::..Erase Method
DocumentSet Class See Also Send Feedback
Removes a specified object from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Erase(
    Document item
)
Visual Basic
Public Overridable Function Erase ( _
    item As Document _
) As Integer
Visual C++
public:
virtual int Erase(
    Document^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..Document
The item to be erased.

Return Value

The number of items that were erased from the set.

See Also

DocumentSet Class


ForwardIterator Method

[image]

Revit 2024 API
DocumentSet..::..ForwardIterator Method
DocumentSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual DocumentSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As DocumentSetIterator
Visual C++
public:
virtual DocumentSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

DocumentSet Class


GetEnumerator Method

[image]

Revit 2024 API
DocumentSet..::..GetEnumerator Method
DocumentSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

DocumentSet Class


ReverseIterator Method

[image]

Revit 2024 API
DocumentSet..::..ReverseIterator Method
DocumentSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual DocumentSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As DocumentSetIterator
Visual C++
public:
virtual DocumentSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

DocumentSet Class


DocumentSet Properties

[image] [image]

Revit 2024 API
DocumentSet Properties
DocumentSet Class See Also Send Feedback

The DocumentSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

DocumentSet Class


Size Property

[image]

Revit 2024 API
DocumentSet..::..Size Property
DocumentSet Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

DocumentSet Class


DocumentSetIterator Class

[image]

Revit 2024 API
DocumentSetIterator Class
Members See Also Send Feedback
An iterator to a set of documents.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public abstract class DocumentSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class DocumentSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class DocumentSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..DocumentSetIterator

See Also

DocumentSetIterator Members


DocumentSetIterator Members

[image] [image]

Revit 2024 API
DocumentSetIterator Members
DocumentSetIterator Class Constructors Methods Properties See Also Send Feedback

The DocumentSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DocumentSetIterator Class


MoveNext Method

[image]

Revit 2024 API
DocumentSetIterator..::..MoveNext Method
DocumentSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

DocumentSetIterator Class


Reset Method

[image]

Revit 2024 API
DocumentSetIterator..::..Reset Method
DocumentSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

DocumentSetIterator Class


Current Property

[image]

Revit 2024 API
DocumentSetIterator..::..Current Property
DocumentSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

DocumentSetIterator Class


DocumentValidation Methods

[image] [image]

Revit 2024 API
DocumentValidation Methods
DocumentValidation Class See Also Send Feedback

The DocumentValidation type exposes the following members.

Methods

Name | Description
CanDeleteElement | Indicates if an element can be deleted.

See Also

DocumentValidation Class


DocumentVersion Class

[image]

Revit 2024 API
DocumentVersion Class
Members See Also Send Feedback
This class uniquely identifies an edition of a given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public class DocumentVersion : IDisposable
Visual Basic
Public Class DocumentVersion _
    Implements IDisposable
Visual C++
public ref class DocumentVersion : IDisposable

Remarks

DocumentVersion consists of two parts - a GUID and an integer. The GUID is updated as new elements are created in the document, but it is not necessarily changed whenever any individual change is made to the document. The integer is updated when the document is saved.

The GUID will change as changes are made to a model, so it should not be treated as a static value.

This class does not contain any time information - you cannot compare two DocumentVersions and know which document is newer. It can be used to tell whether a document has changed since it was last inspected. See [!:Autodesk::Revit::DB::BasicFileInfo::GetDocumentVersion()]

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..DocumentVersion

See Also

DocumentVersion Members


DocumentVersion Members

[image] [image]

Revit 2024 API
DocumentVersion Members
DocumentVersion Class Methods Properties See Also Send Feedback

The DocumentVersion type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the DocumentVersion
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Checks whether two DocumentVersions are identical. They are identical if both the GUID and number of saves are equal. If two DocumentVersions are identical, they come from the same document, with the same set of changes.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | NumberOfSaves | The number of times the document has been saved. The save number and GUID are both necessary to uniquely identify a document version.
Public property | VersionGUID | The GUID portion of the DocumentVersion. The GUID is updated when changes are made to the document, but may not update with every change to the document. The GUID and save number are both necessary to uniquely identify a document version.

See Also

DocumentVersion Class


Dispose Method

[image]

Revit 2024 API
DocumentVersion..::..Dispose Method
DocumentVersion Class See Also Send Feedback
Releases all resources used by the DocumentVersion

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

DocumentVersion Class


IsEqual Method

[image]

Revit 2024 API
DocumentVersion..::..IsEqual Method
DocumentVersion Class See Also Send Feedback
Checks whether two DocumentVersions are identical. They are identical if both the GUID and number of saves are equal. If two DocumentVersions are identical, they come from the same document, with the same set of changes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool IsEqual(
    DocumentVersion other
)
Visual Basic
Public Function IsEqual ( _
    other As DocumentVersion _
) As Boolean
Visual C++
public:
bool IsEqual(
    DocumentVersion^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..DocumentVersion
The DocumentVersion to compare to this DocumentVersion.

Return Value

True if the two DocumentVersions are equal. False otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DocumentVersion Class


DocumentVersion Properties

[image] [image]

Revit 2024 API
DocumentVersion Properties
DocumentVersion Class See Also Send Feedback

The DocumentVersion type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | NumberOfSaves | The number of times the document has been saved. The save number and GUID are both necessary to uniquely identify a document version.
Public property | VersionGUID | The GUID portion of the DocumentVersion. The GUID is updated when changes are made to the document, but may not update with every change to the document. The GUID and save number are both necessary to uniquely identify a document version.

See Also

DocumentVersion Class


IsValidObject Property

[image]

Revit 2024 API
DocumentVersion..::..IsValidObject Property
DocumentVersion Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

DocumentVersion Class


NumberOfSaves Property

[image]

Revit 2024 API
DocumentVersion..::..NumberOfSaves Property
DocumentVersion Class See Also Send Feedback
The number of times the document has been saved. The save number and GUID are both necessary to uniquely identify a document version.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public int NumberOfSaves { get; }
Visual Basic
Public ReadOnly Property NumberOfSaves As Integer
    Get
Visual C++
public:
property int NumberOfSaves {
    int get ();
}

See Also

DocumentVersion Class


VersionGUID Property

[image]

Revit 2024 API
DocumentVersion..::..VersionGUID Property
DocumentVersion Class See Also Send Feedback
The GUID portion of the DocumentVersion. The GUID is updated when changes are made to the document, but may not update with every change to the document. The GUID and save number are both necessary to uniquely identify a document version.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public Guid VersionGUID { get; }
Visual Basic
Public ReadOnly Property VersionGUID As Guid
    Get
Visual C++
public:
property Guid VersionGUID {
    Guid get ();
}

See Also

DocumentVersion Class


DoorEvacuationExitType Enumeration

[image]

Revit 2024 API
DoorEvacuationExitType Enumeration
See Also Send Feedback
An enumerated type listing the possible door evacuation types

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum DoorEvacuationExitType
Visual Basic
Public Enumeration DoorEvacuationExitType
Visual C++
public enum class DoorEvacuationExitType

Members

Member name | Description
ExteriorExit | Exterior exit door.
InteriorExit | Interior exit door.
InteriorPassage | Interior passage door.
None | Not used for exit access.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


DoubleArray Class

[image]

Revit 2024 API
DoubleArray Class
Members See Also Send Feedback
An array that contains doubles.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class DoubleArray : APIObject,
    IEnumerable
Visual Basic
Public Class DoubleArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class DoubleArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..DoubleArray

See Also

DoubleArray Members


DoubleArray Members

[image] [image]

Revit 2024 API
DoubleArray Members
DoubleArray Class Constructors Methods Properties See Also Send Feedback

The DoubleArray type exposes the following members.

Constructors

 | Name | Description
Public method | DoubleArray | Initializes a new instance of the DoubleArray class

Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every double from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a double at a specified index within the array.
Public property | Size | Returns the number of doubles that are in the array.

See Also

DoubleArray Class


DoubleArray Constructor

[image]

Revit 2024 API
DoubleArray Constructor
DoubleArray Class See Also Send Feedback
Initializes a new instance of the DoubleArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public DoubleArray()
Visual Basic
Public Sub New
Visual C++
public:
DoubleArray()

See Also

DoubleArray Class


DoubleArray Methods

[image] [image]

Revit 2024 API
DoubleArray Methods
DoubleArray Class See Also Send Feedback

The DoubleArray type exposes the following members.

Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every double from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DoubleArray Class


Clear Method

[image]

Revit 2024 API
DoubleArray..::..Clear Method
DoubleArray Class See Also Send Feedback
Removes every double from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

DoubleArray Class


GetEnumerator Method

[image]

Revit 2024 API
DoubleArray..::..GetEnumerator Method
DoubleArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

DoubleArray Class


Insert Method

[image]

Revit 2024 API
DoubleArray..::..Insert Method
DoubleArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Insert(
    ref double item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    ByRef item As Double, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    double% item,
    int index
)

Parameters

item
Type: System..::..Double%
index
Type: System..::..Int32

See Also

DoubleArray Class


ReverseIterator Method

[image]

Revit 2024 API
DoubleArray..::..ReverseIterator Method
DoubleArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual DoubleArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As DoubleArrayIterator
Visual C++
public:
virtual DoubleArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

DoubleArray Class


DoubleArray Properties

[image] [image]

Revit 2024 API
DoubleArray Properties
DoubleArray Class See Also Send Feedback

The DoubleArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a double at a specified index within the array.
Public property | Size | Returns the number of doubles that are in the array.

See Also

DoubleArray Class


IsEmpty Property

[image]

Revit 2024 API
DoubleArray..::..IsEmpty Property
DoubleArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

DoubleArray Class


Item Property

[image]

Revit 2024 API
DoubleArray..::..Item Property
DoubleArray Class See Also Send Feedback
Gets or sets a double at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual double this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As Double
    Get
    Set
Visual C++
public:
virtual property double Item[int index] {
    double get (int index);
    void set (int index, double value);
}

Parameters

index
Type: System..::..Int32
The index of the double to be set or retrieved.

Return Value

Returns the double at the specified index.

See Also

DoubleArray Class


Size Property

[image]

Revit 2024 API
DoubleArray..::..Size Property
DoubleArray Class See Also Send Feedback
Returns the number of doubles that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

DoubleArray Class


DoubleArrayIterator Class

[image]

Revit 2024 API
DoubleArrayIterator Class
Members See Also Send Feedback
An iterator to an array of doubles.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public abstract class DoubleArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class DoubleArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class DoubleArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..DoubleArrayIterator

See Also

DoubleArrayIterator Members


DoubleArrayIterator Constructor

[image]

Revit 2024 API
DoubleArrayIterator Constructor
DoubleArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public DoubleArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
DoubleArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DoubleArrayIterator Class


DoubleArrayIterator Methods

[image] [image]

Revit 2024 API
DoubleArrayIterator Methods
DoubleArrayIterator Class See Also Send Feedback

The DoubleArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DoubleArrayIterator Class


MoveNext Method

[image]

Revit 2024 API
DoubleArrayIterator..::..MoveNext Method
DoubleArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

DoubleArrayIterator Class


DoubleArrayIterator Properties

[image] [image]

Revit 2024 API
DoubleArrayIterator Properties
DoubleArrayIterator Class See Also Send Feedback

The DoubleArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DoubleArrayIterator Class


Current Property

[image]

Revit 2024 API
DoubleArrayIterator..::..Current Property
DoubleArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

DoubleArrayIterator Class


DoubleParameterValue Class

[image]

Revit 2024 API
DoubleParameterValue Class
Members See Also Send Feedback
A class that holds a Double value of a parameter element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Update

Syntax

C#
public class DoubleParameterValue : ParameterValue
Visual Basic
Public Class DoubleParameterValue _
    Inherits ParameterValue
Visual C++
public ref class DoubleParameterValue : public ParameterValue

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ParameterValue
Autodesk.Revit.DB..::..DoubleParameterValue

See Also

DoubleParameterValue Members


DoubleParameterValue Members

[image] [image]

Revit 2024 API
DoubleParameterValue Members
DoubleParameterValue Class Constructors Methods Properties See Also Send Feedback

The DoubleParameterValue type exposes the following members.

Constructors

 | Name | Description
Public method | DoubleParameterValue()()()() | Default constructor
Public method | DoubleParameterValue(Double) | Value constructor

Methods

 | Name | Description
Public method | Copy | Makes an identical copy of the given parameter value. (Inherited from ParameterValue.)
Public method | Dispose | (Inherited from ParameterValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Tests equality with another instance of the same class. (Inherited from ParameterValue.)
Public method | IsSameType | Tests another instance is of the same value type. (Inherited from ParameterValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ParameterValue.)
Public property | Value | The stored value

See Also

DoubleParameterValue Class


DoubleParameterValue Constructor

[image] [image]

Revit 2024 API
DoubleParameterValue Constructor
DoubleParameterValue Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DoubleParameterValue()()()() | Default constructor
Public method | DoubleParameterValue(Double) | Value constructor

See Also

DoubleParameterValue Class
DoubleParameterValue Members


DoubleParameterValue Constructor

[image]

Revit 2024 API
DoubleParameterValue Constructor
DoubleParameterValue Class See Also Send Feedback
Default constructor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Update

Syntax

C#
public DoubleParameterValue()
Visual Basic
Public Sub New
Visual C++
public:
DoubleParameterValue()

See Also

DoubleParameterValue Class
DoubleParameterValue Overload


DoubleParameterValue Methods

[image] [image]

Revit 2024 API
DoubleParameterValue Methods
DoubleParameterValue Class See Also Send Feedback

The DoubleParameterValue type exposes the following members.

Methods

 | Name | Description
Public method | Copy | Makes an identical copy of the given parameter value. (Inherited from ParameterValue.)
Public method | Dispose | (Inherited from ParameterValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Tests equality with another instance of the same class. (Inherited from ParameterValue.)
Public method | IsSameType | Tests another instance is of the same value type. (Inherited from ParameterValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DoubleParameterValue Class


DoubleParameterValue Properties

[image] [image]

Revit 2024 API
DoubleParameterValue Properties
DoubleParameterValue Class See Also Send Feedback

The DoubleParameterValue type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ParameterValue.)
Public property | Value | The stored value

See Also

DoubleParameterValue Class


Value Property

[image]

Revit 2024 API
DoubleParameterValue..::..Value Property
DoubleParameterValue Class See Also Send Feedback
The stored value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Update

Syntax

C#
public double Value { get; set; }
Visual Basic
Public Property Value As Double
    Get
    Set
Visual C++
public:
property double Value {
    double get ();
    void set (double value);
}

See Also

DoubleParameterValue Class


DuplicateTypeNamesHandlerArgs Class

[image]

Revit 2024 API
DuplicateTypeNamesHandlerArgs Class
Members See Also Send Feedback
A structure that provides information about an attempt to copy types with names that already exist in the destination document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class DuplicateTypeNamesHandlerArgs : IDisposable
Visual Basic
Public Class DuplicateTypeNamesHandlerArgs _
    Implements IDisposable
Visual C++
public ref class DuplicateTypeNamesHandlerArgs : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..DuplicateTypeNamesHandlerArgs

See Also

DuplicateTypeNamesHandlerArgs Members


DuplicateTypeNamesHandlerArgs Methods

[image] [image]

Revit 2024 API
DuplicateTypeNamesHandlerArgs Methods
DuplicateTypeNamesHandlerArgs Class See Also Send Feedback

The DuplicateTypeNamesHandlerArgs type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeIds | Returns ids of the types with duplicate names.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DuplicateTypeNamesHandlerArgs Class


Dispose Method

[image]

Revit 2024 API
DuplicateTypeNamesHandlerArgs..::..Dispose Method
DuplicateTypeNamesHandlerArgs Class See Also Send Feedback
Releases all resources used by the DuplicateTypeNamesHandlerArgs

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

DuplicateTypeNamesHandlerArgs Class


GetTypeIds Method

[image]

Revit 2024 API
DuplicateTypeNamesHandlerArgs..::..GetTypeIds Method
DuplicateTypeNamesHandlerArgs Class See Also Send Feedback
Returns ids of the types with duplicate names.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ICollection<ElementId> GetTypeIds()
Visual Basic
Public Function GetTypeIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetTypeIds()

See Also

DuplicateTypeNamesHandlerArgs Class


Document Property

[image]

Revit 2024 API
DuplicateTypeNamesHandlerArgs..::..Document Property
DuplicateTypeNamesHandlerArgs Class See Also Send Feedback
The document that contains the types with duplicate names.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public Document Document { get; }
Visual Basic
Public ReadOnly Property Document As Document
    Get
Visual C++
public:
property Document^ Document {
    Document^ get ();
}

See Also

DuplicateTypeNamesHandlerArgs Class


IsValidObject Property

[image]

Revit 2024 API
DuplicateTypeNamesHandlerArgs..::..IsValidObject Property
DuplicateTypeNamesHandlerArgs Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

DuplicateTypeNamesHandlerArgs Class


DWFExportOptions Members

[image] [image]

Revit 2024 API
DWFExportOptions Members
DWFExportOptions Class Constructors Methods Properties See Also Send Feedback

The DWFExportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | DWFExportOptions | Default constructor. Sets all options to their default values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CropBoxVisible | Whether to export crop box.
Public property | ExportingAreas | Whether to also export areas and rooms' geometry.
Public property | ExportObjectData | Whether to include properties associated with elements.
Public property | ExportOnlyViewId | Only export the specified view.
Public property | ExportTexture | Whether to export texture.
Public property | ImageFormat | Controls the compression level of images embedded.
Public property | ImageQuality | Image quality level when compressed raster format(JPEG) is used.
Public property | MergedViews | Whether to merge all views in one file.
Public property | PaperFormat | Standard paper format.
Public property | PortraitLayout | Paper orientation - Portrait/Landscape.
Public property | StopOnError | Whether export process should stop when a view fails to export.

See Also

DWFExportOptions Class


DWFExportOptions Constructor

[image]

Revit 2024 API
DWFExportOptions Constructor
DWFExportOptions Class See Also Send Feedback
Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public DWFExportOptions()
Visual Basic
Public Sub New
Visual C++
public:
DWFExportOptions()

See Also

DWFExportOptions Class


DWFExportOptions Methods

[image] [image]

Revit 2024 API
DWFExportOptions Methods
DWFExportOptions Class See Also Send Feedback

The DWFExportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DWFExportOptions Class


DWFExportOptions Properties

[image] [image]

Revit 2024 API
DWFExportOptions Properties
DWFExportOptions Class See Also Send Feedback

The DWFExportOptions type exposes the following members.

Properties

 | Name | Description
Public property | CropBoxVisible | Whether to export crop box.
Public property | ExportingAreas | Whether to also export areas and rooms' geometry.
Public property | ExportObjectData | Whether to include properties associated with elements.
Public property | ExportOnlyViewId | Only export the specified view.
Public property | ExportTexture | Whether to export texture.
Public property | ImageFormat | Controls the compression level of images embedded.
Public property | ImageQuality | Image quality level when compressed raster format(JPEG) is used.
Public property | MergedViews | Whether to merge all views in one file.
Public property | PaperFormat | Standard paper format.
Public property | PortraitLayout | Paper orientation - Portrait/Landscape.
Public property | StopOnError | Whether export process should stop when a view fails to export.

See Also

DWFExportOptions Class


CropBoxVisible Property

[image]

Revit 2024 API
DWFExportOptions..::..CropBoxVisible Property
DWFExportOptions Class See Also Send Feedback
Whether to export crop box.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool CropBoxVisible { get; set; }
Visual Basic
Public Property CropBoxVisible As Boolean
    Get
    Set
Visual C++
public:
property bool CropBoxVisible {
    bool get ();
    void set (bool value);
}

Remarks

The default value is false.

See Also

DWFExportOptions Class


ExportingAreas Property

[image]

Revit 2024 API
DWFExportOptions..::..ExportingAreas Property
DWFExportOptions Class See Also Send Feedback
Whether to also export areas and rooms' geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool ExportingAreas { get; set; }
Visual Basic
Public Property ExportingAreas As Boolean
    Get
    Set
Visual C++
public:
property bool ExportingAreas {
    bool get ();
    void set (bool value);
}

See Also

DWFExportOptions Class


ExportObjectData Property

[image]

Revit 2024 API
DWFExportOptions..::..ExportObjectData Property
DWFExportOptions Class See Also Send Feedback
Whether to include properties associated with elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool ExportObjectData { get; set; }
Visual Basic
Public Property ExportObjectData As Boolean
    Get
    Set
Visual C++
public:
property bool ExportObjectData {
    bool get ();
    void set (bool value);
}

Remarks

ExportObjectData must be enabled (true) in order to also enable exporting rooms and areas (ExportingAreas). If ExportObjectData is disabled, the ExportingAreas property will be ignored.

See Also

DWFExportOptions Class


ExportOnlyViewId Property

[image]

Revit 2024 API
DWFExportOptions..::..ExportOnlyViewId Property
DWFExportOptions Class See Also Send Feedback
Only export the specified view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public ElementId ExportOnlyViewId { get; set; }
Visual Basic
Public Property ExportOnlyViewId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ ExportOnlyViewId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Remarks

Export only the specified view, but the data of the other views is still used, e. g. the hyperlink information.

See Also

DWFExportOptions Class


ImageFormat Property

[image]

Revit 2024 API
DWFExportOptions..::..ImageFormat Property
DWFExportOptions Class See Also Send Feedback
Controls the compression level of images embedded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public DWFImageFormat ImageFormat { get; set; }
Visual Basic
Public Property ImageFormat As DWFImageFormat
    Get
    Set
Visual C++
public:
property DWFImageFormat ImageFormat {
    DWFImageFormat get ();
    void set (DWFImageFormat value);
}

Remarks

ImageQuality is ignored when ImageFormat is set to "PNG"-the standard format.

See Also

DWFExportOptions Class


MergedViews Property

[image]

Revit 2024 API
DWFExportOptions..::..MergedViews Property
DWFExportOptions Class See Also Send Feedback
Whether to merge all views in one file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool MergedViews { get; set; }
Visual Basic
Public Property MergedViews As Boolean
    Get
    Set
Visual C++
public:
property bool MergedViews {
    bool get ();
    void set (bool value);
}

See Also

DWFExportOptions Class


PortraitLayout Property

[image]

Revit 2024 API
DWFExportOptions..::..PortraitLayout Property
DWFExportOptions Class See Also Send Feedback
Paper orientation - Portrait/Landscape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool PortraitLayout { get; set; }
Visual Basic
Public Property PortraitLayout As Boolean
    Get
    Set
Visual C++
public:
property bool PortraitLayout {
    bool get ();
    void set (bool value);
}

See Also

DWFExportOptions Class


StopOnError Property

[image]

Revit 2024 API
DWFExportOptions..::..StopOnError Property
DWFExportOptions Class See Also Send Feedback
Whether export process should stop when a view fails to export.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool StopOnError { get; set; }
Visual Basic
Public Property StopOnError As Boolean
    Get
    Set
Visual C++
public:
property bool StopOnError {
    bool get ();
    void set (bool value);
}

Remarks

If set to false, the export would continue until all views are processed. This option has an effect only when a set of more than one view is specified.

See Also

DWFExportOptions Class


DWFImageFormat Enumeration

[image]

Revit 2024 API
DWFImageFormat Enumeration
See Also Send Feedback
An enumerated type listing possible image format for DWF Export.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum DWFImageFormat
Visual Basic
Public Enumeration DWFImageFormat
Visual C++
public enum class DWFImageFormat

Members

Member name | Description
Lossless |
Lossy |

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


DWFImageQuality Enumeration

[image]

Revit 2024 API
DWFImageQuality Enumeration
See Also Send Feedback
An enumerated type listing possible image quality for DWF Export.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum DWFImageQuality
Visual Basic
Public Enumeration DWFImageQuality
Visual C++
public enum class DWFImageQuality

Members

Member name | Description
Default |
Low |
Medium |
High |

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


DWFImportOptions Class

[image]

Revit 2024 API
DWFImportOptions Class
Members See Also Send Feedback
The import options used by importing DWF or DWFx format file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class DWFImportOptions : IDisposable
Visual Basic
Public Class DWFImportOptions _
    Implements IDisposable
Visual C++
public ref class DWFImportOptions : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..DWFImportOptions

See Also

DWFImportOptions Members


DWFImportOptions Constructor

[image] [image]

Revit 2024 API
DWFImportOptions Constructor
DWFImportOptions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DWFImportOptions(DWFImportOptions) | Constructs a new instance of DWFImportOptions as a copy of the import options.
Public method | DWFImportOptions(IList<(Of <<'(ElementId>)>>)) | Constructs a new instance of DWFImportOptions with an array of imported sheet views.

See Also

DWFImportOptions Class
DWFImportOptions Members


DWFImportOptions Constructor (DWFImportOptions)

[image]

Revit 2024 API
DWFImportOptions Constructor (DWFImportOptions)
DWFImportOptions Class See Also Send Feedback
Constructs a new instance of DWFImportOptions as a copy of the import options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public DWFImportOptions(
    DWFImportOptions option
)
Visual Basic
Public Sub New ( _
    option As DWFImportOptions _
)
Visual C++
public:
DWFImportOptions(
    DWFImportOptions^ option
)

Parameters

option
Type: Autodesk.Revit.DB..::..DWFImportOptions
The options to be copied.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DWFImportOptions Class
DWFImportOptions Overload


Dispose Method

[image]

Revit 2024 API
DWFImportOptions..::..Dispose Method
DWFImportOptions Class See Also Send Feedback
Releases all resources used by the DWFImportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

DWFImportOptions Class


GetSheetViews Method

[image]

Revit 2024 API
DWFImportOptions..::..GetSheetViews Method
DWFImportOptions Class See Also Send Feedback
Get sheet views where DWF markups are imported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public IList<ElementId> GetSheetViews()
Visual Basic
Public Function GetSheetViews As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetSheetViews()

Return Value

An array of sheet views

See Also

DWFImportOptions Class


SetSheetViews Method

[image]

Revit 2024 API
DWFImportOptions..::..SetSheetViews Method
DWFImportOptions Class See Also Send Feedback
Set sheet views where DWF markups are imported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void SetSheetViews(
    IList<ElementId> sheetViews
)
Visual Basic
Public Sub SetSheetViews ( _
    sheetViews As IList(Of ElementId) _
)
Visual C++
public:
void SetSheetViews(
    IList<ElementId^>^ sheetViews
)

Parameters

sheetViews
Type: System.Collections.Generic..::..IList<(Of <(<' ElementId >)>)>
An array of imported sheet views.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DWFImportOptions Class


DWFImportOptions Properties

[image] [image]

Revit 2024 API
DWFImportOptions Properties
DWFImportOptions Class See Also Send Feedback

The DWFImportOptions type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

DWFImportOptions Class


IsValidObject Property

[image]

Revit 2024 API
DWFImportOptions..::..IsValidObject Property
DWFImportOptions Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

DWFImportOptions Class


DWFXExportOptions Class

[image]

Revit 2024 API
DWFXExportOptions Class
Members See Also Send Feedback
DWFX Export options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class DWFXExportOptions : DWFExportOptions
Visual Basic
Public Class DWFXExportOptions _
    Inherits DWFExportOptions
Visual C++
public ref class DWFXExportOptions : public DWFExportOptions

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..CADExportOptions
Autodesk.Revit.DB..::..DWFExportOptions
Autodesk.Revit.DB..::..DWFXExportOptions

See Also

DWFXExportOptions Members


DWFXExportOptions Constructor

[image]

Revit 2024 API
DWFXExportOptions Constructor
DWFXExportOptions Class See Also Send Feedback
Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public DWFXExportOptions()
Visual Basic
Public Sub New
Visual C++
public:
DWFXExportOptions()

See Also

DWFXExportOptions Class


DWGExportOptions Class

[image]

Revit 2024 API
DWGExportOptions Class
Members See Also Send Feedback
The export options used by exporting DWG format file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class DWGExportOptions : ACADExportOptions
Visual Basic
Public Class DWGExportOptions _
    Inherits ACADExportOptions
Visual C++
public ref class DWGExportOptions : public ACADExportOptions

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BaseExportOptions
Autodesk.Revit.DB..::..ACADExportOptions
Autodesk.Revit.DB..::..DWGExportOptions

See Also

DWGExportOptions Members


DWGExportOptions Members

[image] [image]

Revit 2024 API
DWGExportOptions Members
DWGExportOptions Class Constructors Methods Properties See Also Send Feedback

The DWGExportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | DWGExportOptions()()()() | Constructs a new instance of DWGExportOptions with default values of all properties.
Public method | DWGExportOptions(DWGExportOptions) | Constructs a new instance of DWGExportOptions as a copy of the export options.

Methods

 | Name | Description
Public method | Dispose | (Inherited from BaseExportOptions.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetExportFontTable | Gets font table. (Inherited from BaseExportOptions.)
Public method | GetExportLayerTable | Gets the layer table. (Inherited from BaseExportOptions.)
Public method | GetExportLinetypeTable | Gets a copy of the line type table. (Inherited from BaseExportOptions.)
Public method | GetExportPatternTable | Gets a copy of the pattern table. (Inherited from BaseExportOptions.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPredefinedOptions | Returns an instance DWGExportOptions containing settings from a predefined export setup.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetExportFontTable | Sets font table to option. (Inherited from BaseExportOptions.)
Public method | SetExportLayerTable | Sets layer table back to option (Inherited from BaseExportOptions.)
Public method | SetExportLinetypeTable | Sets the line type table to use during export. (Inherited from BaseExportOptions.)
Public method | SetExportPatternTable | Sets the pattern table to use during export. (Inherited from BaseExportOptions.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ACAPreference | The preferred way to generate geometry of ACA objects. Default value is ACAObjectPreference.Object. (Inherited from ACADExportOptions.)
Public property | Colors | Export color mode. Default value is ExportColorMode.IndexColors. (Inherited from BaseExportOptions.)
Public property | ExportingAreas | True to export area and room geometry, false otherwise. Default value is false. (Inherited from ACADExportOptions.)
Public property | ExportOfSolids | The mode used to export solids in 3D views. Default value is SolidGeometry.Polymesh. (Inherited from ACADExportOptions.)
Public property | FileVersion | ACADVersion::Default Default value is ACADVersion.Default. (Inherited from ACADExportOptions.)
Public property | HatchBackgroundColor | The color that will be set as hatch backgound color on the exported hatch. This color will be used only if useHatchBackgroundColor is true. default value is white (Inherited from ACADExportOptions.)
Public property | HatchPatternsFileName | Custom hatch patterns (pat) file name. (Inherited from BaseExportOptions.)
Public property | HideReferencePlane | Whether or not to hide reference planes. Default value is false. (Inherited from BaseExportOptions.)
Public property | HideScopeBox | Whether or not to hide the scope box. Default value is false. (Inherited from BaseExportOptions.)
Public property | HideUnreferenceViewTags | Whether or not to hide unreference view tags. Default value is false. (Inherited from BaseExportOptions.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BaseExportOptions.)
Public property | LayerMapping | Name of a layer settings standard or filename (with custom layer settings). Valid standards are: DGNV7 (only for DGN), AIA, CP83, BS1192, and ISO13567. default value is "" (empty) which means if no value is set, if no value is set, Revit will use a default value according to the localization. (Inherited from BaseExportOptions.)
Public property | LineScaling | The scaling mode for the line type. Default value is LineScaling.ViewScale. (Inherited from ACADExportOptions.)
Public property | LinetypesFileName | The custom linetype file name (*.lin). Default value is empty. (Inherited from ACADExportOptions.)
Public property | MarkNonplotLayers | If true and the nonplot layer suffix is not empty, all layers whose names contain that suffix will be marked as non-plot. (Inherited from ACADExportOptions.)
Public property | MergedViews | Whether to merge all views in one file (via XRefs). Default value is false for mergedViews.
Public property | NonplotSuffix | If the MarkNonplotLayers attribute is set to true, all layers with names containing this suffix will be marked as non-plot. No action will be performed if the suffix is empty. (Inherited from ACADExportOptions.)
Public property | PreserveCoincidentLines | Whether or not to preserve coincident lines. Default value is false. (Inherited from BaseExportOptions.)
Public property | PropOverrides | How to export overridden object styles. Default value is PropOverrideMode.ByEntity. (Inherited from BaseExportOptions.)
Public property | SharedCoords | True to use the shared coordinate system's origin, false to use the project origin. Default value is false. (Inherited from ACADExportOptions.)
Public property | TargetUnit | The target unit type. Default value is ExportUnit.Default. (Inherited from ACADExportOptions.)
Public property | TextTreatment | The text treatment. Deault value is TextTreatment.Exact. (Inherited from ACADExportOptions.)
Public property | UseHatchBackgroundColor | Indicates if hatch background color will be used or not. default value is false. (Inherited from ACADExportOptions.)

See Also

DWGExportOptions Class


DWGExportOptions Constructor

[image]

Revit 2024 API
DWGExportOptions Constructor
DWGExportOptions Class See Also Send Feedback
Constructs a new instance of DWGExportOptions with default values of all properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public DWGExportOptions()
Visual Basic
Public Sub New
Visual C++
public:
DWGExportOptions()

See Also

DWGExportOptions Class
DWGExportOptions Overload


DWGExportOptions Constructor (DWGExportOptions)

[image]

Revit 2024 API
DWGExportOptions Constructor (DWGExportOptions)
DWGExportOptions Class See Also Send Feedback
Constructs a new instance of DWGExportOptions as a copy of the export options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public DWGExportOptions(
    DWGExportOptions option
)
Visual Basic
Public Sub New ( _
    option As DWGExportOptions _
)
Visual C++
public:
DWGExportOptions(
    DWGExportOptions^ option
)

Parameters

option
Type: Autodesk.Revit.DB..::..DWGExportOptions
The options to be copied.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DWGExportOptions Class
DWGExportOptions Overload


DWGExportOptions Methods

[image] [image]

Revit 2024 API
DWGExportOptions Methods
DWGExportOptions Class See Also Send Feedback

The DWGExportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from BaseExportOptions.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetExportFontTable | Gets font table. (Inherited from BaseExportOptions.)
Public method | GetExportLayerTable | Gets the layer table. (Inherited from BaseExportOptions.)
Public method | GetExportLinetypeTable | Gets a copy of the line type table. (Inherited from BaseExportOptions.)
Public method | GetExportPatternTable | Gets a copy of the pattern table. (Inherited from BaseExportOptions.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPredefinedOptions | Returns an instance DWGExportOptions containing settings from a predefined export setup.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetExportFontTable | Sets font table to option. (Inherited from BaseExportOptions.)
Public method | SetExportLayerTable | Sets layer table back to option (Inherited from BaseExportOptions.)
Public method | SetExportLinetypeTable | Sets the line type table to use during export. (Inherited from BaseExportOptions.)
Public method | SetExportPatternTable | Sets the pattern table to use during export. (Inherited from BaseExportOptions.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DWGExportOptions Class


GetPredefinedOptions Method

[image]

Revit 2024 API
DWGExportOptions..::..GetPredefinedOptions Method
DWGExportOptions Class See Also Send Feedback
Returns an instance DWGExportOptions containing settings from a predefined export setup.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static DWGExportOptions GetPredefinedOptions(
    Document document,
    string setup
)
Visual Basic
Public Shared Function GetPredefinedOptions ( _
    document As Document, _
    setup As String _
) As DWGExportOptions
Visual C++
public:
static DWGExportOptions^ GetPredefinedOptions(
    Document^ document,
    String^ setup
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
A Revit project document to retrieve the setup from.
setup
Type: System..::..String
The name of a predefined export setup from the specified document.

Return Value

An instance of predefined DWGExportOptions, or nullNothingnullptra null reference (Nothing in Visual Basic) if the name was not found.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DWGExportOptions Class


DWGExportOptions Properties

[image] [image]

Revit 2024 API
DWGExportOptions Properties
DWGExportOptions Class See Also Send Feedback

The DWGExportOptions type exposes the following members.

Properties

 | Name | Description
Public property | ACAPreference | The preferred way to generate geometry of ACA objects. Default value is ACAObjectPreference.Object. (Inherited from ACADExportOptions.)
Public property | Colors | Export color mode. Default value is ExportColorMode.IndexColors. (Inherited from BaseExportOptions.)
Public property | ExportingAreas | True to export area and room geometry, false otherwise. Default value is false. (Inherited from ACADExportOptions.)
Public property | ExportOfSolids | The mode used to export solids in 3D views. Default value is SolidGeometry.Polymesh. (Inherited from ACADExportOptions.)
Public property | FileVersion | ACADVersion::Default Default value is ACADVersion.Default. (Inherited from ACADExportOptions.)
Public property | HatchBackgroundColor | The color that will be set as hatch backgound color on the exported hatch. This color will be used only if useHatchBackgroundColor is true. default value is white (Inherited from ACADExportOptions.)
Public property | HatchPatternsFileName | Custom hatch patterns (pat) file name. (Inherited from BaseExportOptions.)
Public property | HideReferencePlane | Whether or not to hide reference planes. Default value is false. (Inherited from BaseExportOptions.)
Public property | HideScopeBox | Whether or not to hide the scope box. Default value is false. (Inherited from BaseExportOptions.)
Public property | HideUnreferenceViewTags | Whether or not to hide unreference view tags. Default value is false. (Inherited from BaseExportOptions.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BaseExportOptions.)
Public property | LayerMapping | Name of a layer settings standard or filename (with custom layer settings). Valid standards are: DGNV7 (only for DGN), AIA, CP83, BS1192, and ISO13567. default value is "" (empty) which means if no value is set, if no value is set, Revit will use a default value according to the localization. (Inherited from BaseExportOptions.)
Public property | LineScaling | The scaling mode for the line type. Default value is LineScaling.ViewScale. (Inherited from ACADExportOptions.)
Public property | LinetypesFileName | The custom linetype file name (*.lin). Default value is empty. (Inherited from ACADExportOptions.)
Public property | MarkNonplotLayers | If true and the nonplot layer suffix is not empty, all layers whose names contain that suffix will be marked as non-plot. (Inherited from ACADExportOptions.)
Public property | MergedViews | Whether to merge all views in one file (via XRefs). Default value is false for mergedViews.
Public property | NonplotSuffix | If the MarkNonplotLayers attribute is set to true, all layers with names containing this suffix will be marked as non-plot. No action will be performed if the suffix is empty. (Inherited from ACADExportOptions.)
Public property | PreserveCoincidentLines | Whether or not to preserve coincident lines. Default value is false. (Inherited from BaseExportOptions.)
Public property | PropOverrides | How to export overridden object styles. Default value is PropOverrideMode.ByEntity. (Inherited from BaseExportOptions.)
Public property | SharedCoords | True to use the shared coordinate system's origin, false to use the project origin. Default value is false. (Inherited from ACADExportOptions.)
Public property | TargetUnit | The target unit type. Default value is ExportUnit.Default. (Inherited from ACADExportOptions.)
Public property | TextTreatment | The text treatment. Deault value is TextTreatment.Exact. (Inherited from ACADExportOptions.)
Public property | UseHatchBackgroundColor | Indicates if hatch background color will be used or not. default value is false. (Inherited from ACADExportOptions.)

See Also

DWGExportOptions Class


MergedViews Property

[image]

Revit 2024 API
DWGExportOptions..::..MergedViews Property
DWGExportOptions Class See Also Send Feedback
Whether to merge all views in one file (via XRefs). Default value is false for mergedViews.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool MergedViews { get; set; }
Visual Basic
Public Property MergedViews As Boolean
    Get
    Set
Visual C++
public:
property bool MergedViews {
    bool get ();
    void set (bool value);
}

See Also

DWGExportOptions Class


DWGImportOptions Members

[image] [image]

Revit 2024 API
DWGImportOptions Members
DWGImportOptions Class Constructors Methods Properties See Also Send Feedback

The DWGImportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | DWGImportOptions()()()() | Constructs a new instance of DWGImportOptions with default values of all properties.
Public method | DWGImportOptions(DWGImportOptions) | Constructs a new instance of DWGImportOptions as a copy of the import options.

Methods

 | Name | Description
Public method | Dispose | (Inherited from BaseImportOptions.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDefaultLengthUnit | Get the default length unit used for importing unitless files. (Inherited from BaseImportOptions.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLayerSelection | Get all set layers name which user want to import into Revit. (Inherited from BaseImportOptions.)
Public method | GetLineWeights | Gets array of line weights.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultLengthUnit | Set the default length unit used for importing unitless files. (Inherited from BaseImportOptions.)
Public method | SetLayerSelection | Set the layers name which user want to import into Revit. (Inherited from BaseImportOptions.)
Public method | SetLineWeights | Set array of line weights.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AutoCorrectAlmostVHLines | Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines. (Inherited from BaseImportOptions.)
Public property | ColorMode | Color mode for the import. Three modes are supported. Black and White, Preserve Colors, and Invert Colors. (Inherited from BaseImportOptions.)
Public property | CustomScale | Scaling the import. If this is defined and a valid value (> 0.0), it takes priority over units. (Inherited from BaseImportOptions.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BaseImportOptions.)
Public property | OrientToView | Place the import at the same orientation as the view that was passed into the import method. This option can only be used when not importing into a single view.(i.e. ThisViewOnly is set to false) (Inherited from BaseImportOptions.)
Public property | Placement | Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates. (Inherited from BaseImportOptions.)
Public property | ReferencePoint | The 3D point in the document where the imported instance will be inserted. If not explicitly set, the instance will be inserted at the document origin. (Inherited from BaseImportOptions.)
Public property | ThisViewOnly | Imports drawings into the view that was passed into the import method. This option is not available in 3D views. (Inherited from BaseImportOptions.)
Public property | Unit | The unit of measure for imported geometry. (Inherited from BaseImportOptions.)
Public property | VisibleLayersOnly | Only import the visible layers. (Inherited from BaseImportOptions.)

See Also

DWGImportOptions Class


DWGImportOptions Constructor

[image] [image]

Revit 2024 API
DWGImportOptions Constructor
DWGImportOptions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DWGImportOptions()()()() | Constructs a new instance of DWGImportOptions with default values of all properties.
Public method | DWGImportOptions(DWGImportOptions) | Constructs a new instance of DWGImportOptions as a copy of the import options.

See Also

DWGImportOptions Class
DWGImportOptions Members


DWGImportOptions Constructor

[image]

Revit 2024 API
DWGImportOptions Constructor
DWGImportOptions Class See Also Send Feedback
Constructs a new instance of DWGImportOptions with default values of all properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public DWGImportOptions()
Visual Basic
Public Sub New
Visual C++
public:
DWGImportOptions()

See Also

DWGImportOptions Class
DWGImportOptions Overload


DWGImportOptions Constructor (DWGImportOptions)

[image]

Revit 2024 API
DWGImportOptions Constructor (DWGImportOptions)
DWGImportOptions Class See Also Send Feedback
Constructs a new instance of DWGImportOptions as a copy of the import options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public DWGImportOptions(
    DWGImportOptions option
)
Visual Basic
Public Sub New ( _
    option As DWGImportOptions _
)
Visual C++
public:
DWGImportOptions(
    DWGImportOptions^ option
)

Parameters

option
Type: Autodesk.Revit.DB..::..DWGImportOptions
The options to be copied.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DWGImportOptions Class
DWGImportOptions Overload


DWGImportOptions Methods

[image] [image]

Revit 2024 API
DWGImportOptions Methods
DWGImportOptions Class See Also Send Feedback

The DWGImportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from BaseImportOptions.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDefaultLengthUnit | Get the default length unit used for importing unitless files. (Inherited from BaseImportOptions.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLayerSelection | Get all set layers name which user want to import into Revit. (Inherited from BaseImportOptions.)
Public method | GetLineWeights | Gets array of line weights.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultLengthUnit | Set the default length unit used for importing unitless files. (Inherited from BaseImportOptions.)
Public method | SetLayerSelection | Set the layers name which user want to import into Revit. (Inherited from BaseImportOptions.)
Public method | SetLineWeights | Set array of line weights.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DWGImportOptions Class


GetLineWeights Method

[image]

Revit 2024 API
DWGImportOptions..::..GetLineWeights Method
DWGImportOptions Class See Also Send Feedback
Gets array of line weights.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public IList<int> GetLineWeights()
Visual Basic
Public Function GetLineWeights As IList(Of Integer)
Visual C++
public:
IList<int>^ GetLineWeights()

See Also

DWGImportOptions Class


SetLineWeights Method

[image]

Revit 2024 API
DWGImportOptions..::..SetLineWeights Method
DWGImportOptions Class See Also Send Feedback
Set array of line weights.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void SetLineWeights(
    IList<int> lineWeight
)
Visual Basic
Public Sub SetLineWeights ( _
    lineWeight As IList(Of Integer) _
)
Visual C++
public:
void SetLineWeights(
    IList<int>^ lineWeight
)

Parameters

lineWeight
Type: System.Collections.Generic..::..IList<(Of <(<'Int32>)>)>

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DWGImportOptions Class


DWGImportOptions Properties

[image] [image]

Revit 2024 API
DWGImportOptions Properties
DWGImportOptions Class See Also Send Feedback

The DWGImportOptions type exposes the following members.

Properties

 | Name | Description
Public property | AutoCorrectAlmostVHLines | Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines. (Inherited from BaseImportOptions.)
Public property | ColorMode | Color mode for the import. Three modes are supported. Black and White, Preserve Colors, and Invert Colors. (Inherited from BaseImportOptions.)
Public property | CustomScale | Scaling the import. If this is defined and a valid value (> 0.0), it takes priority over units. (Inherited from BaseImportOptions.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BaseImportOptions.)
Public property | OrientToView | Place the import at the same orientation as the view that was passed into the import method. This option can only be used when not importing into a single view.(i.e. ThisViewOnly is set to false) (Inherited from BaseImportOptions.)
Public property | Placement | Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates. (Inherited from BaseImportOptions.)
Public property | ReferencePoint | The 3D point in the document where the imported instance will be inserted. If not explicitly set, the instance will be inserted at the document origin. (Inherited from BaseImportOptions.)
Public property | ThisViewOnly | Imports drawings into the view that was passed into the import method. This option is not available in 3D views. (Inherited from BaseImportOptions.)
Public property | Unit | The unit of measure for imported geometry. (Inherited from BaseImportOptions.)
Public property | VisibleLayersOnly | Only import the visible layers. (Inherited from BaseImportOptions.)

See Also

DWGImportOptions Class


DXFExportOptions Class

[image]

Revit 2024 API
DXFExportOptions Class
Members See Also Send Feedback
The export options used by exporting DXF format file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public class DXFExportOptions : ACADExportOptions
Visual Basic
Public Class DXFExportOptions _
    Inherits ACADExportOptions
Visual C++
public ref class DXFExportOptions : public ACADExportOptions

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BaseExportOptions
Autodesk.Revit.DB..::..ACADExportOptions
Autodesk.Revit.DB..::..DXFExportOptions

See Also

DXFExportOptions Members


DXFExportOptions Members

[image] [image]

Revit 2024 API
DXFExportOptions Members
DXFExportOptions Class Constructors Methods Properties See Also Send Feedback

The DXFExportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | DXFExportOptions()()()() | Constructs a new instance of DXFImportOptions with default values of all properties.
Public method | DXFExportOptions(DXFExportOptions) | Constructs a new instance of DXFImportOptions as a copy of the export options.

Methods

 | Name | Description
Public method | Dispose | (Inherited from BaseExportOptions.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetExportFontTable | Gets font table. (Inherited from BaseExportOptions.)
Public method | GetExportLayerTable | Gets the layer table. (Inherited from BaseExportOptions.)
Public method | GetExportLinetypeTable | Gets a copy of the line type table. (Inherited from BaseExportOptions.)
Public method | GetExportPatternTable | Gets a copy of the pattern table. (Inherited from BaseExportOptions.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPredefinedOptions | Returns an instance DXFExportOptions containing settings from a predefined export setup.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetExportFontTable | Sets font table to option. (Inherited from BaseExportOptions.)
Public method | SetExportLayerTable | Sets layer table back to option (Inherited from BaseExportOptions.)
Public method | SetExportLinetypeTable | Sets the line type table to use during export. (Inherited from BaseExportOptions.)
Public method | SetExportPatternTable | Sets the pattern table to use during export. (Inherited from BaseExportOptions.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ACAPreference | The preferred way to generate geometry of ACA objects. Default value is ACAObjectPreference.Object. (Inherited from ACADExportOptions.)
Public property | Colors | Export color mode. Default value is ExportColorMode.IndexColors. (Inherited from BaseExportOptions.)
Public property | ExportingAreas | True to export area and room geometry, false otherwise. Default value is false. (Inherited from ACADExportOptions.)
Public property | ExportOfSolids | The mode used to export solids in 3D views. Default value is SolidGeometry.Polymesh. (Inherited from ACADExportOptions.)
Public property | FileVersion | ACADVersion::Default Default value is ACADVersion.Default. (Inherited from ACADExportOptions.)
Public property | HatchBackgroundColor | The color that will be set as hatch backgound color on the exported hatch. This color will be used only if useHatchBackgroundColor is true. default value is white (Inherited from ACADExportOptions.)
Public property | HatchPatternsFileName | Custom hatch patterns (pat) file name. (Inherited from BaseExportOptions.)
Public property | HideReferencePlane | Whether or not to hide reference planes. Default value is false. (Inherited from BaseExportOptions.)
Public property | HideScopeBox | Whether or not to hide the scope box. Default value is false. (Inherited from BaseExportOptions.)
Public property | HideUnreferenceViewTags | Whether or not to hide unreference view tags. Default value is false. (Inherited from BaseExportOptions.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BaseExportOptions.)
Public property | LayerMapping | Name of a layer settings standard or filename (with custom layer settings). Valid standards are: DGNV7 (only for DGN), AIA, CP83, BS1192, and ISO13567. default value is "" (empty) which means if no value is set, if no value is set, Revit will use a default value according to the localization. (Inherited from BaseExportOptions.)
Public property | LineScaling | The scaling mode for the line type. Default value is LineScaling.ViewScale. (Inherited from ACADExportOptions.)
Public property | LinetypesFileName | The custom linetype file name (*.lin). Default value is empty. (Inherited from ACADExportOptions.)
Public property | MarkNonplotLayers | If true and the nonplot layer suffix is not empty, all layers whose names contain that suffix will be marked as non-plot. (Inherited from ACADExportOptions.)
Public property | NonplotSuffix | If the MarkNonplotLayers attribute is set to true, all layers with names containing this suffix will be marked as non-plot. No action will be performed if the suffix is empty. (Inherited from ACADExportOptions.)
Public property | PreserveCoincidentLines | Whether or not to preserve coincident lines. Default value is false. (Inherited from BaseExportOptions.)
Public property | PropOverrides | How to export overridden object styles. Default value is PropOverrideMode.ByEntity. (Inherited from BaseExportOptions.)
Public property | SharedCoords | True to use the shared coordinate system's origin, false to use the project origin. Default value is false. (Inherited from ACADExportOptions.)
Public property | TargetUnit | The target unit type. Default value is ExportUnit.Default. (Inherited from ACADExportOptions.)
Public property | TextTreatment | The text treatment. Deault value is TextTreatment.Exact. (Inherited from ACADExportOptions.)
Public property | UseHatchBackgroundColor | Indicates if hatch background color will be used or not. default value is false. (Inherited from ACADExportOptions.)

See Also

DXFExportOptions Class


DXFExportOptions Constructor

[image] [image]

Revit 2024 API
DXFExportOptions Constructor
DXFExportOptions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DXFExportOptions()()()() | Constructs a new instance of DXFImportOptions with default values of all properties.
Public method | DXFExportOptions(DXFExportOptions) | Constructs a new instance of DXFImportOptions as a copy of the export options.

See Also

DXFExportOptions Class
DXFExportOptions Members


DXFExportOptions Constructor

[image]

Revit 2024 API
DXFExportOptions Constructor
DXFExportOptions Class See Also Send Feedback
Constructs a new instance of DXFImportOptions with default values of all properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public DXFExportOptions()
Visual Basic
Public Sub New
Visual C++
public:
DXFExportOptions()

See Also

DXFExportOptions Class
DXFExportOptions Overload


DXFExportOptions Constructor (DXFExportOptions)

[image]

Revit 2024 API
DXFExportOptions Constructor (DXFExportOptions)
DXFExportOptions Class See Also Send Feedback
Constructs a new instance of DXFImportOptions as a copy of the export options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public DXFExportOptions(
    DXFExportOptions option
)
Visual Basic
Public Sub New ( _
    option As DXFExportOptions _
)
Visual C++
public:
DXFExportOptions(
    DXFExportOptions^ option
)

Parameters

option
Type: Autodesk.Revit.DB..::..DXFExportOptions
The options to be copied.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DXFExportOptions Class
DXFExportOptions Overload


DXFExportOptions Methods

[image] [image]

Revit 2024 API
DXFExportOptions Methods
DXFExportOptions Class See Also Send Feedback

The DXFExportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from BaseExportOptions.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetExportFontTable | Gets font table. (Inherited from BaseExportOptions.)
Public method | GetExportLayerTable | Gets the layer table. (Inherited from BaseExportOptions.)
Public method | GetExportLinetypeTable | Gets a copy of the line type table. (Inherited from BaseExportOptions.)
Public method | GetExportPatternTable | Gets a copy of the pattern table. (Inherited from BaseExportOptions.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPredefinedOptions | Returns an instance DXFExportOptions containing settings from a predefined export setup.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetExportFontTable | Sets font table to option. (Inherited from BaseExportOptions.)
Public method | SetExportLayerTable | Sets layer table back to option (Inherited from BaseExportOptions.)
Public method | SetExportLinetypeTable | Sets the line type table to use during export. (Inherited from BaseExportOptions.)
Public method | SetExportPatternTable | Sets the pattern table to use during export. (Inherited from BaseExportOptions.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DXFExportOptions Class


GetPredefinedOptions Method

[image]

Revit 2024 API
DXFExportOptions..::..GetPredefinedOptions Method
DXFExportOptions Class See Also Send Feedback
Returns an instance DXFExportOptions containing settings from a predefined export setup.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static DXFExportOptions GetPredefinedOptions(
    Document document,
    string setup
)
Visual Basic
Public Shared Function GetPredefinedOptions ( _
    document As Document, _
    setup As String _
) As DXFExportOptions
Visual C++
public:
static DXFExportOptions^ GetPredefinedOptions(
    Document^ document,
    String^ setup
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
A Revit project document to retrieve the setup from.
setup
Type: System..::..String
The name of a predefined export setup from the specified document.

Return Value

An instance of predefined DXFExportOptions, or nullNothingnullptra null reference (Nothing in Visual Basic) if the name was not found.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

DXFExportOptions Class


DXFExportOptions Properties

[image] [image]

Revit 2024 API
DXFExportOptions Properties
DXFExportOptions Class See Also Send Feedback

The DXFExportOptions type exposes the following members.

Properties

 | Name | Description
Public property | ACAPreference | The preferred way to generate geometry of ACA objects. Default value is ACAObjectPreference.Object. (Inherited from ACADExportOptions.)
Public property | Colors | Export color mode. Default value is ExportColorMode.IndexColors. (Inherited from BaseExportOptions.)
Public property | ExportingAreas | True to export area and room geometry, false otherwise. Default value is false. (Inherited from ACADExportOptions.)
Public property | ExportOfSolids | The mode used to export solids in 3D views. Default value is SolidGeometry.Polymesh. (Inherited from ACADExportOptions.)
Public property | FileVersion | ACADVersion::Default Default value is ACADVersion.Default. (Inherited from ACADExportOptions.)
Public property | HatchBackgroundColor | The color that will be set as hatch backgound color on the exported hatch. This color will be used only if useHatchBackgroundColor is true. default value is white (Inherited from ACADExportOptions.)
Public property | HatchPatternsFileName | Custom hatch patterns (pat) file name. (Inherited from BaseExportOptions.)
Public property | HideReferencePlane | Whether or not to hide reference planes. Default value is false. (Inherited from BaseExportOptions.)
Public property | HideScopeBox | Whether or not to hide the scope box. Default value is false. (Inherited from BaseExportOptions.)
Public property | HideUnreferenceViewTags | Whether or not to hide unreference view tags. Default value is false. (Inherited from BaseExportOptions.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BaseExportOptions.)
Public property | LayerMapping | Name of a layer settings standard or filename (with custom layer settings). Valid standards are: DGNV7 (only for DGN), AIA, CP83, BS1192, and ISO13567. default value is "" (empty) which means if no value is set, if no value is set, Revit will use a default value according to the localization. (Inherited from BaseExportOptions.)
Public property | LineScaling | The scaling mode for the line type. Default value is LineScaling.ViewScale. (Inherited from ACADExportOptions.)
Public property | LinetypesFileName | The custom linetype file name (*.lin). Default value is empty. (Inherited from ACADExportOptions.)
Public property | MarkNonplotLayers | If true and the nonplot layer suffix is not empty, all layers whose names contain that suffix will be marked as non-plot. (Inherited from ACADExportOptions.)
Public property | NonplotSuffix | If the MarkNonplotLayers attribute is set to true, all layers with names containing this suffix will be marked as non-plot. No action will be performed if the suffix is empty. (Inherited from ACADExportOptions.)
Public property | PreserveCoincidentLines | Whether or not to preserve coincident lines. Default value is false. (Inherited from BaseExportOptions.)
Public property | PropOverrides | How to export overridden object styles. Default value is PropOverrideMode.ByEntity. (Inherited from BaseExportOptions.)
Public property | SharedCoords | True to use the shared coordinate system's origin, false to use the project origin. Default value is false. (Inherited from ACADExportOptions.)
Public property | TargetUnit | The target unit type. Default value is ExportUnit.Default. (Inherited from ACADExportOptions.)
Public property | TextTreatment | The text treatment. Deault value is TextTreatment.Exact. (Inherited from ACADExportOptions.)
Public property | UseHatchBackgroundColor | Indicates if hatch background color will be used or not. default value is false. (Inherited from ACADExportOptions.)

See Also

DXFExportOptions Class


Edge Class

[image]

Revit 2024 API
Edge Class
Members See Also Send Feedback
An edge of a 3d solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class Edge : GeometryObject
Visual Basic
Public Class Edge _
    Inherits GeometryObject
Visual C++
public ref class Edge : public GeometryObject

Remarks

Edges are defined by intersections of surfaces that form faces of the solid. They have arbitrary parameterization that is normalized to [0,1].

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeometryObject
Autodesk.Revit.DB..::..Edge

See Also

Edge Members


Edge Members

[image] [image]

Revit 2024 API
Edge Members
Edge Class Methods Properties See Also Send Feedback

The Edge type exposes the following members.

Methods

 | Name | Description
Public method | AsCurve | Returns a curve that corresponds to the edge's parametric orientation.
Public method | AsCurveFollowingFace | Returns a curve that corresponds to this edge as oriented in its topological direction on the specified face.
Public method | ComputeDerivatives | Returns the vectors describing the edge at the specified parameter.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates a parameter on the edge.
Public method | EvaluateOnFace | Evaluates a parameter on the edge to produce UV coordinates on the face.
Public method | GetCurveUV(Int32) | Calculate a 2D curve that represents the edge in the uv-parameter plane of one of the edge's faces. The output curve's direction will follow the parametric direction of the edge, not the topological direction of the edge on the given face.
Public method | GetCurveUV(Int32, Transform2D) | Calculate and transform a 2D curve that represents the edge in the uv-parameter plane of one of the edge's faces. The output curve's direction will follow the parametric direction of the edge, not the topological direction of the edge on the given face.
Public method | GetEndPointReference | Returns a stable reference to the start or the end point of the edge.
Public method | GetFace | Returns one of the two faces that meet at the edge.
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsFlippedOnFace(Int32) | Determines if this edge's topological direction on the Face is opposite to its parametric direction.
Public method | IsFlippedOnFace(Face) | Determines if this edge's topological direction on the Face is opposite to its parametric direction.
Public method | Tessellate | Returns a polyline approximation to the edge.
Public method | TessellateOnFace | Returns a polyline approximation to the edge in UV parameters of the face.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ApproximateLength | Returns the approximate length of the edge.
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Reference | Returns a stable reference to the edge.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Edge Class


AsCurve Method

[image]

Revit 2024 API
Edge..::..AsCurve Method
Edge Class See Also Send Feedback
Returns a curve that corresponds to the edge's parametric orientation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Curve AsCurve()
Visual Basic
Public Function AsCurve As Curve
Visual C++
public:
Curve^ AsCurve()

Return Value

It can be an Arc, Line, or HermiteSpline.

See Also

Edge Class


AsCurveFollowingFace Method

[image]

Revit 2024 API
Edge..::..AsCurveFollowingFace Method
Edge Class See Also Send Feedback
Returns a curve that corresponds to this edge as oriented in its topological direction on the specified face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Curve AsCurveFollowingFace(
    Face faceForDir
)
Visual Basic
Public Function AsCurveFollowingFace ( _
    faceForDir As Face _
) As Curve
Visual C++
public:
Curve^ AsCurveFollowingFace(
    Face^ faceForDir
)

Parameters

faceForDir
Type: Autodesk.Revit.DB..::..Face
Specifies the face, on which the curve will follow the topological direction of the edge.

Return Value

It can be an Arc, Line, or HermiteSpline.

Remarks

Evaluating the edge using EvaluateOnFace gives the same result as evaluating the curve returned by AsCurveFollowingFace with a normalized curve parameter. When a Hermite spline is returned, the two evaluated points will be approximately equal.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the specified faceForDir is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the specified faceForDir is not one of the faces for this edge.

See Also

Edge Class


ComputeDerivatives Method

[image]

Revit 2024 API
Edge..::..ComputeDerivatives Method
Edge Class See Also Send Feedback
Returns the vectors describing the edge at the specified parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Transform ComputeDerivatives(
    double parameter
)
Visual Basic
Public Function ComputeDerivatives ( _
    parameter As Double _
) As Transform
Visual C++
public:
Transform^ ComputeDerivatives(
    double parameter
)

Parameters

parameter
Type: System..::..Double
The parameter to be evaluated.

Return Value

The transformation containing a tangent vector, derivative of tangent vector, and bi-normal vector.

Remarks

The following is the meaning of the transformation members:
  • Origin is the point on the edge (equivalent to Evaluate);
  • BasisX is the tangent vector (the first derivative);
  • BasisY is the second derivative;
  • BasisZ is the bi-normal vector (tangent x normal).
Normal and bi-normal are zero if the edge is straight at the point. None of the vectors are normalized.

See Also

Edge Class


Evaluate Method

[image]

Revit 2024 API
Edge..::..Evaluate Method
Edge Class See Also Send Feedback
Evaluates a parameter on the edge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ Evaluate(
    double param
)
Visual Basic
Public Function Evaluate ( _
    param As Double _
) As XYZ
Visual C++
public:
XYZ^ Evaluate(
    double param
)

Parameters

param
Type: System..::..Double
The parameter to be evaluated, in [0,1].

See Also

Edge Class


EvaluateOnFace Method

[image]

Revit 2024 API
Edge..::..EvaluateOnFace Method
Edge Class See Also Send Feedback
Evaluates a parameter on the edge to produce UV coordinates on the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public UV EvaluateOnFace(
    double param,
    Face face
)
Visual Basic
Public Function EvaluateOnFace ( _
    param As Double, _
    face As Face _
) As UV
Visual C++
public:
UV^ EvaluateOnFace(
    double param,
    Face^ face
)

Parameters

param
Type: System..::..Double
The parameter to be evaluated, in [0,1].
face
Type: Autodesk.Revit.DB..::..Face
The face on which to perform the evaluation. Must belong to the edge.

See Also

Edge Class


GetEndPointReference Method

[image]

Revit 2024 API
Edge..::..GetEndPointReference Method
Edge Class See Also Send Feedback
Returns a stable reference to the start or the end point of the edge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Reference GetEndPointReference(
    int index
)
Visual Basic
Public Function GetEndPointReference ( _
    index As Integer _
) As Reference
Visual C++
public:
Reference^ GetEndPointReference(
    int index
)

Parameters

index
Type: System..::..Int32
Use 0 for the start point; 1 for the end point.

Return Value

Reference to the point or nullNothingnullptra null reference (Nothing in Visual Basic) if reference cannot be obtained.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the specified index is not 0 or 1.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the object is internally marked as read-only in the setter.

See Also

Edge Class


GetFace Method

[image]

Revit 2024 API
Edge..::..GetFace Method
Edge Class See Also Send Feedback
Returns one of the two faces that meet at the edge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public Face GetFace(
    int index
)
Visual Basic
Public Function GetFace ( _
    index As Integer _
) As Face
Visual C++
public:
Face^ GetFace(
    int index
)

Parameters

index
Type: System..::..Int32
The index of the face (0 or 1).

See Also

Edge Class


IsFlippedOnFace Method

[image] [image]

Revit 2024 API
Edge..::..IsFlippedOnFace Method
Edge Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsFlippedOnFace(Int32) | Determines if this edge's topological direction on the Face is opposite to its parametric direction.
Public method | IsFlippedOnFace(Face) | Determines if this edge's topological direction on the Face is opposite to its parametric direction.

See Also

Edge Class
Edge Members


IsFlippedOnFace Method (Int32)

[image]

Revit 2024 API
Edge..::..IsFlippedOnFace Method (Int32)
Edge Class See Also Send Feedback
Determines if this edge's topological direction on the Face is opposite to its parametric direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public bool IsFlippedOnFace(
    int index
)
Visual Basic
Public Function IsFlippedOnFace ( _
    index As Integer _
) As Boolean
Visual C++
public:
bool IsFlippedOnFace(
    int index
)

Parameters

index
Type: System..::..Int32
The index of the face (0 or 1).

Return Value

true if this edge's topological direction on the Face is opposite to its parametric direction, false if the topological direction agrees with the parametric direction.

Remarks

Outer edge loops on a Face are oriented counter-clockwise with respect to the Face's orientation, and inner loops are oriented clockwise. The topological direction of an edge on a face means the direction in which the edge's loop is being traversed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the specified index is not 0 or 1.

See Also

Edge Class
IsFlippedOnFace Overload


IsFlippedOnFace Method (Face)

[image]

Revit 2024 API
Edge..::..IsFlippedOnFace Method (Face)
Edge Class See Also Send Feedback
Determines if this edge's topological direction on the Face is opposite to its parametric direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public bool IsFlippedOnFace(
    Face face
)
Visual Basic
Public Function IsFlippedOnFace ( _
    face As Face _
) As Boolean
Visual C++
public:
bool IsFlippedOnFace(
    Face^ face
)

Parameters

face
Type: Autodesk.Revit.DB..::..Face
The face with respect to which the direction is considered. Must belong to the edge.

Return Value

true if this edge's topological direction on the Face is opposite to its parametric direction, false if the topological direction agrees with the parametric direction.

Remarks

Outer edge loops on a Face are oriented counter-clockwise with respect to the Face's orientation, and inner loops are oriented clockwise. The topological direction of an edge on a face means the direction in which the edge's loop is being traversed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the specified face is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the specified face is not one of the faces for this edge.

See Also

Edge Class
IsFlippedOnFace Overload


TessellateOnFace Method

[image]

Revit 2024 API
Edge..::..TessellateOnFace Method
Edge Class See Also Send Feedback
Returns a polyline approximation to the edge in UV parameters of the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public IList<UV> TessellateOnFace(
    Face face
)
Visual Basic
Public Function TessellateOnFace ( _
    face As Face _
) As IList(Of UV)
Visual C++
public:
IList<UV^>^ TessellateOnFace(
    Face^ face
)

Parameters

face
Type: Autodesk.Revit.DB..::..Face
The face on which to perform the tessellation. Must belong to the edge.

Remarks

Tolerance of approximation is defined internally by Revit to be adequate for display purposes.

See Also

Edge Class


Reference Property

[image]

Revit 2024 API
Edge..::..Reference Property
Edge Class See Also Send Feedback
Returns a stable reference to the edge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Reference Reference { get; }
Visual Basic
Public ReadOnly Property Reference As Reference
    Get
Visual C++
public:
property Reference^ Reference {
    Reference^ get ();
}

Remarks

This value is if the corresponding geometry object does not permit referencing.

See Also

Edge Class


EdgeArray Class

[image]

Revit 2024 API
EdgeArray Class
Members See Also Send Feedback
An array that contains edges.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class EdgeArray : APIObject, IEnumerable
Visual Basic
Public Class EdgeArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class EdgeArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..EdgeArray

See Also

EdgeArray Members


EdgeArray Methods

[image] [image]

Revit 2024 API
EdgeArray Methods
EdgeArray Class See Also Send Feedback

The EdgeArray type exposes the following members.

Methods

 | Name | Description
Public method | Append | Add the edge to the end of the array.
Public method | Clear | Removes every edge from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified edge into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

EdgeArray Class


Append Method

[image]

Revit 2024 API
EdgeArray..::..Append Method
EdgeArray Class See Also Send Feedback
Add the edge to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Append(
    Edge item
)
Visual Basic
Public Overridable Sub Append ( _
    item As Edge _
)
Visual C++
public:
virtual void Append(
    Edge^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..Edge
The edge to be added.

See Also

EdgeArray Class


Clear Method

[image]

Revit 2024 API
EdgeArray..::..Clear Method
EdgeArray Class See Also Send Feedback
Removes every edge from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

EdgeArray Class


ForwardIterator Method

[image]

Revit 2024 API
EdgeArray..::..ForwardIterator Method
EdgeArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual EdgeArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As EdgeArrayIterator
Visual C++
public:
virtual EdgeArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

EdgeArray Class


GetEnumerator Method

[image]

Revit 2024 API
EdgeArray..::..GetEnumerator Method
EdgeArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

EdgeArray Class


Insert Method

[image]

Revit 2024 API
EdgeArray..::..Insert Method
EdgeArray Class See Also Send Feedback
Insert the specified edge into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Insert(
    Edge item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As Edge, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    Edge^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::..Edge
The edge to be inserted into the array.
index
Type: System..::..Int32
The edge will be inserted before this index.

Return Value

Returns whether the edge was inserted into the array.

See Also

EdgeArray Class


ReverseIterator Method

[image]

Revit 2024 API
EdgeArray..::..ReverseIterator Method
EdgeArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual EdgeArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As EdgeArrayIterator
Visual C++
public:
virtual EdgeArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

EdgeArray Class


EdgeArray Properties

[image] [image]

Revit 2024 API
EdgeArray Properties
EdgeArray Class See Also Send Feedback

The EdgeArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an edge at a specified index within the array.
Public property | Size | Returns the number of edges that are in the array.

See Also

EdgeArray Class


IsEmpty Property

[image]

Revit 2024 API
EdgeArray..::..IsEmpty Property
EdgeArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

EdgeArray Class


Item Property

[image]

Revit 2024 API
EdgeArray..::..Item Property
EdgeArray Class See Also Send Feedback
Gets or sets an edge at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Edge this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As Edge
    Get
    Set
Visual C++
public:
virtual property Edge^ Item[int index] {
    Edge^ get (int index);
    void set (int index, Edge^ value);
}

Parameters

index
Type: System..::..Int32
The index of the edge to be set or retrieved.

Return Value

Returns the edge at the specified index.

See Also

EdgeArray Class


Size Property

[image]

Revit 2024 API
EdgeArray..::..Size Property
EdgeArray Class See Also Send Feedback
Returns the number of edges that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

EdgeArray Class


EdgeArrayArray Class

[image]

Revit 2024 API
EdgeArrayArray Class
Members Example See Also Send Feedback
An array of edge arrays.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class EdgeArrayArray : APIObject,
    IEnumerable
Visual Basic
Public Class EdgeArrayArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class EdgeArrayArray : public APIObject,
    IEnumerable

Examples

CopyC#
public void GetEdgeArrayArray(Autodesk.Revit.ApplicationServices.Application app, Autodesk.Revit.DB.Element element)
{
    // Get geometry element of the selected element
    Options geoOptions = app.Create.NewGeometryOptions();
    Autodesk.Revit.DB.GeometryElement geoElement = element.get_Geometry(geoOptions);
    // Get geometry object
    foreach (GeometryObject o in geoElement)
    {
        Solid solid = o as Solid;
        if (null != solid)
        {
            foreach (Face face in solid.Faces)
            {
                if (face != null)
                {
                    EdgeArrayArray edgeArrays = face.EdgeLoops;
                    foreach (EdgeArray edges in edgeArrays)
                    {
                        foreach (Edge edge in edges)
                        {
                            // Get one test point
                            XYZ testPoint = edge.Evaluate(0.5);
                            string edgeInfo = string.Format("Point on edge: ({0},{1},{2})", testPoint.X, testPoint.Y, testPoint.Z);
                            TaskDialog.Show("Revit",edgeInfo);
                        }
                    }
                }
            }
        }
    }
}
CopyVB.NET
Public Sub GetEdgeArrayArray(app As Autodesk.Revit.ApplicationServices.Application, element As Autodesk.Revit.DB.Element)
    ' Get geometry element of the selected element
    Dim geoOptions As Options = app.Create.NewGeometryOptions()
    Dim geoElement As Autodesk.Revit.DB.GeometryElement = element.Geometry(geoOptions)
    ' Get geometry object
    For Each o As GeometryObject In geoElement
        Dim solid As Solid = TryCast(o, Solid)
        If solid IsNot Nothing Then
            For Each face As Face In solid.Faces
                If face IsNot Nothing Then
                    Dim edgeArrays As EdgeArrayArray = face.EdgeLoops
                    For Each edges As EdgeArray In edgeArrays
                        For Each edge As Edge In edges
                            ' Get one test point
                            Dim testPoint As XYZ = edge.Evaluate(0.5)
                            Dim edgeInfo As String = String.Format("Point on edge: ({0},{1},{2})", testPoint.X, testPoint.Y, testPoint.Z)
                            TaskDialog.Show("Revit", edgeInfo)
                        Next
                    Next
                End If
            Next
        End If
    Next
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..EdgeArrayArray

See Also

EdgeArrayArray Members


EdgeArrayArray Members

[image] [image]

Revit 2024 API
EdgeArrayArray Members
EdgeArrayArray Class Constructors Methods Properties See Also Send Feedback

The EdgeArrayArray type exposes the following members.

Constructors

 | Name | Description
Public method | EdgeArrayArray | Initializes a new instance of the EdgeArrayArray class

Methods

 | Name | Description
Public method | Append | Add the edge array to the end of the array.
Public method | Clear | Removes every edge array from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified edge array into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an edge array at a specified index within the array.
Public property | Size | Returns the number of edge arrays that are in the array.

See Also

EdgeArrayArray Class


Append Method

[image]

Revit 2024 API
EdgeArrayArray..::..Append Method
EdgeArrayArray Class See Also Send Feedback
Add the edge array to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Append(
    EdgeArray item
)
Visual Basic
Public Overridable Sub Append ( _
    item As EdgeArray _
)
Visual C++
public:
virtual void Append(
    EdgeArray^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..EdgeArray
The edge array to be added.

See Also

EdgeArrayArray Class


Clear Method

[image]

Revit 2024 API
EdgeArrayArray..::..Clear Method
EdgeArrayArray Class See Also Send Feedback
Removes every edge array from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

EdgeArrayArray Class


ForwardIterator Method

[image]

Revit 2024 API
EdgeArrayArray..::..ForwardIterator Method
EdgeArrayArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual EdgeArrayArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As EdgeArrayArrayIterator
Visual C++
public:
virtual EdgeArrayArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

EdgeArrayArray Class


GetEnumerator Method

[image]

Revit 2024 API
EdgeArrayArray..::..GetEnumerator Method
EdgeArrayArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

EdgeArrayArray Class


Insert Method

[image]

Revit 2024 API
EdgeArrayArray..::..Insert Method
EdgeArrayArray Class See Also Send Feedback
Insert the specified edge array into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Insert(
    EdgeArray item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As EdgeArray, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    EdgeArray^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::..EdgeArray
The edge array to be inserted into the array.
index
Type: System..::..Int32
The edge array will be inserted before this index.

Return Value

Returns whether the edge array was inserted into the array.

See Also

EdgeArrayArray Class


ReverseIterator Method

[image]

Revit 2024 API
EdgeArrayArray..::..ReverseIterator Method
EdgeArrayArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual EdgeArrayArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As EdgeArrayArrayIterator
Visual C++
public:
virtual EdgeArrayArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

EdgeArrayArray Class


EdgeArrayArray Properties

[image] [image]

Revit 2024 API
EdgeArrayArray Properties
EdgeArrayArray Class See Also Send Feedback

The EdgeArrayArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an edge array at a specified index within the array.
Public property | Size | Returns the number of edge arrays that are in the array.

See Also

EdgeArrayArray Class


Item Property

[image]

Revit 2024 API
EdgeArrayArray..::..Item Property
EdgeArrayArray Class See Also Send Feedback
Gets or sets an edge array at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual EdgeArray this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As EdgeArray
    Get
    Set
Visual C++
public:
virtual property EdgeArray^ Item[int index] {
    EdgeArray^ get (int index);
    void set (int index, EdgeArray^ value);
}

Parameters

index
Type: System..::..Int32
The index of the edge array to be set or retrieved.

Return Value

Returns the edge array at the specified index.

See Also

EdgeArrayArray Class


EdgeArrayArrayIterator Class

[image]

Revit 2024 API
EdgeArrayArrayIterator Class
Members See Also Send Feedback
An iterator to an array or edge arrays.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public abstract class EdgeArrayArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class EdgeArrayArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class EdgeArrayArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..EdgeArrayArrayIterator

See Also

EdgeArrayArrayIterator Members


EdgeArrayArrayIterator Members

[image] [image]

Revit 2024 API
EdgeArrayArrayIterator Members
EdgeArrayArrayIterator Class Constructors Methods Properties See Also Send Feedback

The EdgeArrayArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | EdgeArrayArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

EdgeArrayArrayIterator Class


EdgeArrayArrayIterator Constructor

[image]

Revit 2024 API
EdgeArrayArrayIterator Constructor
EdgeArrayArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public EdgeArrayArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
EdgeArrayArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

EdgeArrayArrayIterator Class


EdgeArrayArrayIterator Methods

[image] [image]

Revit 2024 API
EdgeArrayArrayIterator Methods
EdgeArrayArrayIterator Class See Also Send Feedback

The EdgeArrayArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

EdgeArrayArrayIterator Class


MoveNext Method

[image]

Revit 2024 API
EdgeArrayArrayIterator..::..MoveNext Method
EdgeArrayArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

EdgeArrayArrayIterator Class


Reset Method

[image]

Revit 2024 API
EdgeArrayArrayIterator..::..Reset Method
EdgeArrayArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

EdgeArrayArrayIterator Class


EdgeArrayArrayIterator Properties

[image] [image]

Revit 2024 API
EdgeArrayArrayIterator Properties
EdgeArrayArrayIterator Class See Also Send Feedback

The EdgeArrayArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

EdgeArrayArrayIterator Class


EdgeArrayIterator Class

[image]

Revit 2024 API
EdgeArrayIterator Class
Members See Also Send Feedback
An iterator to an edge array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public abstract class EdgeArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class EdgeArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class EdgeArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..EdgeArrayIterator

See Also

EdgeArrayIterator Members


EdgeArrayIterator Members

[image] [image]

Revit 2024 API
EdgeArrayIterator Members
EdgeArrayIterator Class Constructors Methods Properties See Also Send Feedback

The EdgeArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | EdgeArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

EdgeArrayIterator Class


Reset Method

[image]

Revit 2024 API
EdgeArrayIterator..::..Reset Method
EdgeArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

EdgeArrayIterator Class


Current Property

[image]

Revit 2024 API
EdgeArrayIterator..::..Current Property
EdgeArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

EdgeArrayIterator Class


EdgeEndPoint Class

[image]

Revit 2024 API
EdgeEndPoint Class
Members See Also Send Feedback
Represents the start or the end point of an Edge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public class EdgeEndPoint : IDisposable
Visual Basic
Public Class EdgeEndPoint _
    Implements IDisposable
Visual C++
public ref class EdgeEndPoint : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..EdgeEndPoint

See Also

EdgeEndPoint Members


EdgeEndPoint Members

[image] [image]

Revit 2024 API
EdgeEndPoint Members
EdgeEndPoint Class Constructors Methods Properties See Also Send Feedback

The EdgeEndPoint type exposes the following members.

Constructors

 | Name | Description
Public method | EdgeEndPoint | Constructs an instance of EdgeEndPoint.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the EdgeEndPoint
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(EdgeEndPoint) | Determines whether this EdgeEndPoint is equal to another.
Public method | Evaluate | Evaluate the end point of the edge in 3d coordinates.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Edge | The Edge.
Public property | Index | The index of the start or the end point of an Edge: 0 is the start point, 1 is the end point.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

EdgeEndPoint Class


EdgeEndPoint Constructor

[image]

Revit 2024 API
EdgeEndPoint Constructor
EdgeEndPoint Class See Also Send Feedback
Constructs an instance of EdgeEndPoint.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public EdgeEndPoint(
    Edge edge,
    int index
)
Visual Basic
Public Sub New ( _
    edge As Edge, _
    index As Integer _
)
Visual C++
public:
EdgeEndPoint(
    Edge^ edge,
    int index
)

Parameters

edge
Type: Autodesk.Revit.DB..::..Edge
The Edge.
index
Type: System..::..Int32
Use 0 for the start point, 1 for the end point of an Edge.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given value for index is not 0 or 1.

See Also

EdgeEndPoint Class


Equals Method

[image] [image]

Revit 2024 API
EdgeEndPoint..::..Equals Method
EdgeEndPoint Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(EdgeEndPoint) | Determines whether this EdgeEndPoint is equal to another.

See Also

EdgeEndPoint Class
EdgeEndPoint Members


Equals Method (EdgeEndPoint)

[image]

Revit 2024 API
EdgeEndPoint..::..Equals Method (EdgeEndPoint)
EdgeEndPoint Class See Also Send Feedback
Determines whether this EdgeEndPoint is equal to another.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public bool Equals(
    EdgeEndPoint other
)
Visual Basic
Public Function Equals ( _
    other As EdgeEndPoint _
) As Boolean
Visual C++
public:
bool Equals(
    EdgeEndPoint^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..EdgeEndPoint
The EdgeEndPoint with which to compare this EdgeEndPoint.

Return Value

True if the given EdgeEndPoint is equal to this one, otherwise false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

EdgeEndPoint Class
Equals Overload


Evaluate Method

[image]

Revit 2024 API
EdgeEndPoint..::..Evaluate Method
EdgeEndPoint Class See Also Send Feedback
Evaluate the end point of the edge in 3d coordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public XYZ Evaluate()
Visual Basic
Public Function Evaluate As XYZ
Visual C++
public:
XYZ^ Evaluate()

Return Value

The end point of the edge in 3d coordinates.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Failed to evaluate the end point of the edge.

See Also

EdgeEndPoint Class


EdgeEndPoint Properties

[image] [image]

Revit 2024 API
EdgeEndPoint Properties
EdgeEndPoint Class See Also Send Feedback

The EdgeEndPoint type exposes the following members.

Properties

 | Name | Description
Public property | Edge | The Edge.
Public property | Index | The index of the start or the end point of an Edge: 0 is the start point, 1 is the end point.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

EdgeEndPoint Class


Edge Property

[image]

Revit 2024 API
EdgeEndPoint..::..Edge Property
EdgeEndPoint Class See Also Send Feedback
The Edge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public Edge Edge { get; }
Visual Basic
Public ReadOnly Property Edge As Edge
    Get
Visual C++
public:
property Edge^ Edge {
    Edge^ get ();
}

See Also

EdgeEndPoint Class


Index Property

[image]

Revit 2024 API
EdgeEndPoint..::..Index Property
EdgeEndPoint Class See Also Send Feedback
The index of the start or the end point of an Edge: 0 is the start point, 1 is the end point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public int Index { get; }
Visual Basic
Public ReadOnly Property Index As Integer
    Get
Visual C++
public:
property int Index {
    int get ();
}

See Also

EdgeEndPoint Class


EditScope Class

[image]

Revit 2024 API
EditScope Class
Members See Also Send Feedback
The base class for a scope object that provides special access and limitations related to editing certain elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class EditScope : IDisposable
Visual Basic
Public Class EditScope _
    Implements IDisposable
Visual C++
public ref class EditScope : IDisposable

Remarks

Derivations of this class provide specific functionality to manage edit modes for specific purposes.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..EditScope
Autodesk.Revit.DB.Architecture..::..TopographyEditScope
Autodesk.Revit.DB..::..SketchEditScope
Autodesk.Revit.DB..::..StairsEditScope

See Also

EditScope Members


EditScope Methods

[image] [image]

Revit 2024 API
EditScope Methods
EditScope Class See Also Send Feedback

The EditScope type exposes the following members.

Methods

 | Name | Description
Public method | Cancel | Cancels the edit scope.
Public method | Commit | Finishes the edit scope.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

EditScope Class


Cancel Method

[image]

Revit 2024 API
EditScope..::..Cancel Method
EditScope Class See Also Send Feedback
Cancels the edit scope.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void Cancel()
Visual Basic
Public Sub Cancel
Visual C++
public:
void Cancel()

Remarks

All the changes made after starting the EditScope will be rolled back.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | EditScope is not active. EditScope can only be committed or cancelled when it is active. -or- EditScope cannot be closed, for there is a transaction or transaction group still open in the document.

See Also

EditScope Class


Commit Method

[image]

Revit 2024 API
EditScope..::..Commit Method
EditScope Class See Also Send Feedback
Finishes the edit scope.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void Commit(
    IFailuresPreprocessor failurePreprocessor
)
Visual Basic
Public Sub Commit ( _
    failurePreprocessor As IFailuresPreprocessor _
)
Visual C++
public:
void Commit(
    IFailuresPreprocessor^ failurePreprocessor
)

Parameters

failurePreprocessor
Type: Autodesk.Revit.DB..::..IFailuresPreprocessor
Callback to be invoked in the beginning of failure processing.

Remarks

All the changes made after starting the EditScope will be committed. Changes will be merged into one transaction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | EditScope is not active. EditScope can only be committed or cancelled when it is active. -or- EditScope cannot be closed, for there is a transaction or transaction group still open in the document.

See Also

EditScope Class


Dispose Method

[image]

Revit 2024 API
EditScope..::..Dispose Method
EditScope Class See Also Send Feedback
Releases all resources used by the EditScope

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

EditScope Class


EditScope Properties

[image] [image]

Revit 2024 API
EditScope Properties
EditScope Class See Also Send Feedback

The EditScope type exposes the following members.

Properties

 | Name | Description
Public property | IsActive | Tells if the EditScope is active. In other words, the EditScope has started but not committed/canceled yet.
Public property | IsPermitted | Tells if the edit scope is permitted to start.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

EditScope Class


IsActive Property

[image]

Revit 2024 API
EditScope..::..IsActive Property
EditScope Class See Also Send Feedback
Tells if the EditScope is active. In other words, the EditScope has started but not committed/canceled yet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsActive { get; }
Visual Basic
Public ReadOnly Property IsActive As Boolean
    Get
Visual C++
public:
property bool IsActive {
    bool get ();
}

Remarks

Starting the edit scope is not permitted when it is active. Canceling/committing is not allowed when the edit scope is not active.

See Also

EditScope Class


IsPermitted Property

[image]

Revit 2024 API
EditScope..::..IsPermitted Property
EditScope Class See Also Send Feedback
Tells if the edit scope is permitted to start.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsPermitted { get; }
Visual Basic
Public ReadOnly Property IsPermitted As Boolean
    Get
Visual C++
public:
property bool IsPermitted {
    bool get ();
}

Remarks

The edit scope is not permitted to start for one of the following possible reasons: The document is in read-only state, or the document is currently modifiable, or there already is another edit mode active in the document.

See Also

EditScope Class


IsValidObject Property

[image]

Revit 2024 API
EditScope..::..IsValidObject Property
EditScope Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

EditScope Class


Element Members

[image] [image]

Revit 2024 API
Element Members
Element Class Methods Properties See Also Send Feedback

The Element type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element.
Public method | CanBeHidden | Indicates if the element can be hidden in the view.
Public method | CanBeLocked | Identifies if the element can be locked.
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element.
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned.
 | CanHaveTypeAssigned(Document, ICollection<(Of <<'(ElementId>)>>)) | Checks if all elements in the set can have a type assigned.
Public method | ChangeTypeId(ElementId) | Changes the type of the element.
 | ChangeTypeId(Document, ICollection<(Of <<'(ElementId>)>>), ElementId) | Changes the type of all elements in the given set.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element
Public method | DeleteSubelement | Removes a subelement from the element.
Public method | DeleteSubelements | Removes the subelements from the element.
Public method | Dispose | Releases all resources used by the Element
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element.
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set.
 | GetChangeTypeAny | Returns ChangeType associated with any change in an element.
 | GetChangeTypeElementAddition | Returns ChangeType associated with element addition
 | GetChangeTypeElementDeletion | Returns ChangeType associated with element deletion.
 | GetChangeTypeGeometry | Returns ChangeType associated with a change in the geometry of an element
 | GetChangeTypeParameter(ElementId) | Returns ChangeType associated with a change in a parameter's value
 | GetChangeTypeParameter(Parameter) | Returns ChangeType associated with a change in a parameter's value
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise.
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element.
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element.
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type.
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type.
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element.
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element.
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object.
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id.
Public method | GetMaterialIds | Gets the element ids of all materials present in the element.
Public method | GetMaterialVolume | Gets the volume of the material with the given id.
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring.
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring.
Public method | GetOrderedParameters | Gets the parameters associated to the element in order.
Public method | GetParameter | Retrieves a parameter from the element given identifier.
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists.
Public method | GetParameters | Retrieves the parameters from the element via the given name.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase
Public method | GetSubelements | Returns the collection of element subelements.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type.
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element.
 | GetValidTypes(Document, ICollection<(Of <<'(ElementId>)>>)) | Obtains a set of types that are valid for all given elements.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order.
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order.
Public method | IsExternalFileReference | Determines whether this Element represents an external file.
Public method | IsHidden | Identifies if the element has been permanently hidden in the view.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models.
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements.
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element.
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element.
 | IsValidType(Document, ICollection<(Of <<'(ElementId>)>>), ElementId) | Checks if given type is valid for the set of elements.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name.
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type.
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished.
Public property | DesignOption | Returns the design option to which the element belongs.
Public property | Document | Returns the Document in which the Element resides.
Public property | Geometry | Retrieves the geometric representation of the element.
Public property | GroupId | The id of the group to which an element belongs.
Public property | Id | A unique identifier for an Element in an Autodesk Revit project.
Public property | IsModifiable | Identifies if the element is modifiable.
Public property | IsTransient | Indicates whether an element is transient or permanent.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LevelId | The id of the level associated with the element.
Public property | Location | This property is used to find the physical location of an element within a project.
Public property | Name | A human readable name for the Element.
Public property | OwnerViewId | The id of the view that owns the element.
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter.
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id.
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element.
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element.
Public property | Pinned | Identifies if the element has been pinned to prevent changes.
Public property | UniqueId | A stable unique identifier for an element within the document.
Public property | VersionGuid | Get the element version Guid.
Public property | ViewSpecific | Identifies if the element is owned by a view.
Public property | WorksetId | Get Id of the Workset which owns the element.

See Also

Element Class


Element Methods

[image] [image]

Revit 2024 API
Element Methods
Element Class See Also Send Feedback

The Element type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element.
Public method | CanBeHidden | Indicates if the element can be hidden in the view.
Public method | CanBeLocked | Identifies if the element can be locked.
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element.
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned.
 | CanHaveTypeAssigned(Document, ICollection<(Of <<'(ElementId>)>>)) | Checks if all elements in the set can have a type assigned.
Public method | ChangeTypeId(ElementId) | Changes the type of the element.
 | ChangeTypeId(Document, ICollection<(Of <<'(ElementId>)>>), ElementId) | Changes the type of all elements in the given set.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element
Public method | DeleteSubelement | Removes a subelement from the element.
Public method | DeleteSubelements | Removes the subelements from the element.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element.
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set.
 | GetChangeTypeAny | Returns ChangeType associated with any change in an element.
 | GetChangeTypeElementAddition | Returns ChangeType associated with element addition
 | GetChangeTypeElementDeletion | Returns ChangeType associated with element deletion.
 | GetChangeTypeGeometry | Returns ChangeType associated with a change in the geometry of an element
 | GetChangeTypeParameter(ElementId) | Returns ChangeType associated with a change in a parameter's value
 | GetChangeTypeParameter(Parameter) | Returns ChangeType associated with a change in a parameter's value
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise.
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element.
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element.
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type.
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type.
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element.
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element.
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object.
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id.
Public method | GetMaterialIds | Gets the element ids of all materials present in the element.
Public method | GetMaterialVolume | Gets the volume of the material with the given id.
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring.
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring.
Public method | GetOrderedParameters | Gets the parameters associated to the element in order.
Public method | GetParameter | Retrieves a parameter from the element given identifier.
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists.
Public method | GetParameters | Retrieves the parameters from the element via the given name.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase
Public method | GetSubelements | Returns the collection of element subelements.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type.
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element.
 | GetValidTypes(Document, ICollection<(Of <<'(ElementId>)>>)) | Obtains a set of types that are valid for all given elements.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order.
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order.
Public method | IsExternalFileReference | Determines whether this Element represents an external file.
Public method | IsHidden | Identifies if the element has been permanently hidden in the view.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models.
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements.
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element.
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element.
 | IsValidType(Document, ICollection<(Of <<'(ElementId>)>>), ElementId) | Checks if given type is valid for the set of elements.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name.
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type.
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Element Class


ArePhasesModifiable Method

[image]

Revit 2024 API
Element..::..ArePhasesModifiable Method
Element Class See Also Send Feedback
Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool ArePhasesModifiable()
Visual Basic
Public Function ArePhasesModifiable As Boolean
Visual C++
public:
bool ArePhasesModifiable()

Return Value

True if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element, false otherwise.

Remarks

Acts as a validator for setting the properties CreatedPhaseId and DemolishedPhaseId.

See Also

Element Class


CanBeHidden Method

[image]

Revit 2024 API
Element..::..CanBeHidden Method
Element Class See Also Send Feedback
Indicates if the element can be hidden in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool CanBeHidden(
    View pView
)
Visual Basic
Public Function CanBeHidden ( _
    pView As View _
) As Boolean
Visual C++
public:
bool CanBeHidden(
    View^ pView
)

Parameters

pView
Type: Autodesk.Revit.DB..::..View

Return Value

If the element is not permitted to be hidden, false is returned.

Remarks

See discussion for some types of elements which may not be hidden. Note: elements in families can only be hidden temporarily.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when argument is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Element Class


CanBeLocked Method

[image]

Revit 2024 API
Element..::..CanBeLocked Method
Element Class See Also Send Feedback
Identifies if the element can be locked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool CanBeLocked()
Visual Basic
Public Function CanBeLocked As Boolean
Visual C++
public:
bool CanBeLocked()

Return Value

True if the element can be locked, false otherwise.

See Also

Element Class


CanDeleteSubelement Method

[image]

Revit 2024 API
Element..::..CanDeleteSubelement Method
Element Class See Also Send Feedback
Checks if given subelement can be removed from the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public bool CanDeleteSubelement(
    Subelement subelem
)
Visual Basic
Public Function CanDeleteSubelement ( _
    subelem As Subelement _
) As Boolean
Visual C++
public:
bool CanDeleteSubelement(
    Subelement^ subelem
)

Parameters

subelem
Type: Autodesk.Revit.DB..::..Subelement
Subelement to check.

Return Value

True if subelement can be removed, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Element Class


CanHaveTypeAssigned Method

[image] [image]

Revit 2024 API
Element..::..CanHaveTypeAssigned Method
Element Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned.
 | CanHaveTypeAssigned(Document, ICollection<(Of <<'(ElementId>)>>)) | Checks if all elements in the set can have a type assigned.

See Also

Element Class
Element Members


CanHaveTypeAssigned Method

[image]

Revit 2024 API
Element..::..CanHaveTypeAssigned Method
Element Class See Also Send Feedback
Identifies if the element can have a type assigned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool CanHaveTypeAssigned()
Visual Basic
Public Function CanHaveTypeAssigned As Boolean
Visual C++
public:
bool CanHaveTypeAssigned()

Return Value

True if element can have a type assigned, false otherwise.

Remarks

Some elements cannot have type assigned, in which case invalid element id is considered to be their type id.

See Also

Element Class
CanHaveTypeAssigned Overload


CanHaveTypeAssigned Method (Document, ICollection(ElementId))

[image]

Revit 2024 API
Element..::..CanHaveTypeAssigned Method (Document, ICollection<(Of <(<'ElementId>)>)>)
Element Class See Also Send Feedback
Checks if all elements in the set can have a type assigned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static bool CanHaveTypeAssigned(
    Document document,
    ICollection<ElementId> elementIds
)
Visual Basic
Public Shared Function CanHaveTypeAssigned ( _
    document As Document, _
    elementIds As ICollection(Of ElementId) _
) As Boolean
Visual C++
public:
static bool CanHaveTypeAssigned(
    Document^ document,
    ICollection<ElementId^>^ elementIds
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
elementIds
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
A collection of element IDs.

Return Value

True if all elements in the set can have a type assigned, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when at least one of the elements does not exist in the document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Element Class
CanHaveTypeAssigned Overload


ChangeTypeId Method

[image] [image]

Revit 2024 API
Element..::..ChangeTypeId Method
Element Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ChangeTypeId(ElementId) | Changes the type of the element.
 | ChangeTypeId(Document, ICollection<(Of <<'(ElementId>)>>), ElementId) | Changes the type of all elements in the given set.

See Also

Element Class
Element Members


ChangeTypeId Method (ElementId)

[image]

Revit 2024 API
Element..::..ChangeTypeId Method (ElementId)
Element Class See Also Send Feedback
Changes the type of the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public ElementId ChangeTypeId(
    ElementId typeId
)
Visual Basic
Public Function ChangeTypeId ( _
    typeId As ElementId _
) As ElementId
Visual C++
public:
ElementId^ ChangeTypeId(
    ElementId^ typeId
)

Parameters

typeId
Type: Autodesk.Revit.DB..::..ElementId
Identifier of the type to assign to this element.

Return Value

The new element id if new element is created, or InvalidElementId if the element's type changed without creating a new element.

Remarks

In rare cases, applying a change in type will result in a new element being created. The only active examples of this are when applying a normal wall type to a curtain panel, or converting such a wall back to a curtain panel. In this situation the new element id is returned. Also, this element becomes invalid. See also: IsModifiable.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The type typeId is not valid for this element.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This Element cannot have type assigned.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | This Element is an internal element, such as a component of a loaded family or a group type. -or- The document containing this Element is in Group Edit Mode, Sketch Edit Mode, or Paste Mode, and the element is not a member of the group, sketch, or clipboard. -or- This Element is a member of a group or sketch, and the document is not currently editing the group or sketch.

See Also

Element Class
ChangeTypeId Overload


ChangeTypeId Method (Document, ICollection(ElementId), ElementId)

[image]

Revit 2024 API
Element..::..ChangeTypeId Method (Document, ICollection<(Of <(<'ElementId>)>)>, ElementId)
Element Class See Also Send Feedback
Changes the type of all elements in the given set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static IDictionary<ElementId, ElementId> ChangeTypeId(
    Document document,
    ICollection<ElementId> elementIds,
    ElementId typeId
)
Visual Basic
Public Shared Function ChangeTypeId ( _
    document As Document, _
    elementIds As ICollection(Of ElementId), _
    typeId As ElementId _
) As IDictionary(Of ElementId, ElementId)
Visual C++
public:
static IDictionary<ElementId^, ElementId^>^ ChangeTypeId(
    Document^ document,
    ICollection<ElementId^>^ elementIds,
    ElementId^ typeId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
elementIds
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
A collection of element IDs.
typeId
Type: Autodesk.Revit.DB..::..ElementId
Identifier of the type to assign to this element.

Return Value

The map of original element IDs to the new element IDs if some elements were replaced by new elements (the map is empty if no elements were replaced)

Remarks

In some cases, applying a change in type will result in a new element being created. The only active examples of this are when applying a normal wall type to a curtain panel, or converting such a wall back to a curtain panel. Then return map would have (original element id, new element id) pair(s). Note: this function needs an open transaction. Note: this function calls regeneration.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | At least one of the elements in elementIds does not exist in the document -or- Not all elements elementIds can have a type assigned. -or- The type typeId is not valid for at least one of the elements in elementIds.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | One or more elements in elementIds is a member of a loaded family. -or- One or more elements in elementIds is a member of a group type that is not being edited.

See Also

Element Class
ChangeTypeId Overload


DeleteSubelements Method

[image]

Revit 2024 API
Element..::..DeleteSubelements Method
Element Class See Also Send Feedback
Removes the subelements from the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public bool DeleteSubelements(
    IList<Subelement> subelems
)
Visual Basic
Public Function DeleteSubelements ( _
    subelems As IList(Of Subelement) _
) As Boolean
Visual C++
public:
bool DeleteSubelements(
    IList<Subelement^>^ subelems
)

Parameters

subelems
Type: System.Collections.Generic..::..IList<(Of <(<' Subelement >)>)>
Subelements to delete.

Return Value

True if entire element was deleted, false otherwise.

Remarks

Depending on implementation for given element as the result, the element can be deleted - especially if after Subelement deletion there are no Subelement left. See also: IsModifiable.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | One or more subelements in subelems do not exist in the element. -or- One or more of the subelements subelems cannot be deleted.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | This Element is an internal element, such as a component of a loaded family or a group type. -or- The document containing this Element is in Group Edit Mode, Sketch Edit Mode, or Paste Mode, and the element is not a member of the group, sketch, or clipboard. -or- This Element is a member of a group or sketch, and the document is not currently editing the group or sketch.

See Also

Element Class


EvaluateAllParameterValues Method

[image]

Revit 2024 API
Element..::..EvaluateAllParameterValues Method
Element Class See Also Send Feedback
Evaluates all the parameters' values of the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public IList<EvaluatedParameter> EvaluateAllParameterValues()
Visual Basic
Public Function EvaluateAllParameterValues As IList(Of EvaluatedParameter)
Visual C++
public:
IList<EvaluatedParameter^>^ EvaluateAllParameterValues()

Return Value

List of EvaluatedParameter of the element.

See Also

Element Class


EvaluateParameterValues Method

[image]

Revit 2024 API
Element..::..EvaluateParameterValues Method
Element Class See Also Send Feedback
Evaluate the parameters' values of the element on the given parameter ID set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public IList<EvaluatedParameter> EvaluateParameterValues(
    ISet<ElementId> parameterIds
)
Visual Basic
Public Function EvaluateParameterValues ( _
    parameterIds As ISet(Of ElementId) _
) As IList(Of EvaluatedParameter)
Visual C++
public:
IList<EvaluatedParameter^>^ EvaluateParameterValues(
    ISet<ElementId^>^ parameterIds
)

Parameters

parameterIds
Type: System.Collections.Generic..::..ISet<(Of <(<' ElementId >)>)>
Parameter IDs with which the ParameterValue to be retrieved.

Return Value

List of EvaluatedParameter of the element, which does not include those that cannot be retrieved but are passed in through parameterIds.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Element Class


GetChangeTypeElementAddition Method

[image]

Revit 2024 API
Element..::..GetChangeTypeElementAddition Method
Element Class See Also Send Feedback
Returns ChangeType associated with element addition

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ChangeType GetChangeTypeElementAddition()
Visual Basic
Public Shared Function GetChangeTypeElementAddition As ChangeType
Visual C++
public:
static ChangeType^ GetChangeTypeElementAddition()

Return Value

ChangeType that can be used to define a trigger for an Updater, triggering on element addition.

Remarks

Use this change type to trigger an Updater on the addition of elements to a document. Note: This change type will not trigger on changes caused by Undo and Redo.

See Also

Element Class


GetChangeTypeGeometry Method

[image]

Revit 2024 API
Element..::..GetChangeTypeGeometry Method
Element Class See Also Send Feedback
Returns ChangeType associated with a change in the geometry of an element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ChangeType GetChangeTypeGeometry()
Visual Basic
Public Shared Function GetChangeTypeGeometry As ChangeType
Visual C++
public:
static ChangeType^ GetChangeTypeGeometry()

Return Value

ChangeType that can be used to define a trigger for an Updater, triggering on a geometry change in an element

Remarks

Use this change type to trigger an Updater when the geometry of an element changes. For example, changes like cutting a hole in a wall or adjusting its height are considered to be geometric changes. Note: This change type will not trigger on newly created or deleted elements or on changes caused by Undo and Redo.

See Also

Element Class


GetChangeTypeParameter Method (ElementId)

[image]

Revit 2024 API
Element..::..GetChangeTypeParameter Method (ElementId)
Element Class See Also Send Feedback
Returns ChangeType associated with a change in a parameter's value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ChangeType GetChangeTypeParameter(
    ElementId parameterId
)
Visual Basic
Public Shared Function GetChangeTypeParameter ( _
    parameterId As ElementId _
) As ChangeType
Visual C++
public:
static ChangeType^ GetChangeTypeParameter(
    ElementId^ parameterId
)

Parameters

parameterId
Type: Autodesk.Revit.DB..::..ElementId
ElementId of parameter for the ChangeType to trigger on.

Return Value

ChangeType that can be used to define a trigger for an Updater, triggering on parameter value change.

Remarks

remarks: Use this change type to trigger an Updater when the value of an element's parameter changes. Note: This change type will not trigger on newly created or deleted elements or on changes caused by Undo and Redo.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Element Class
GetChangeTypeParameter Overload


GetChangeTypeParameter Method (Parameter)

[image]

Revit 2024 API
Element..::..GetChangeTypeParameter Method (Parameter)
Element Class See Also Send Feedback
Returns ChangeType associated with a change in a parameter's value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ChangeType GetChangeTypeParameter(
    Parameter param
)
Visual Basic
Public Shared Function GetChangeTypeParameter ( _
    param As Parameter _
) As ChangeType
Visual C++
public:
static ChangeType^ GetChangeTypeParameter(
    Parameter^ param
)

Parameters

param
Type: Autodesk.Revit.DB..::..Parameter
Parameter for the ChangeType to trigger on

Return Value

ChangeType that can be used to define a trigger for an Updater, triggering on parameter value change

Remarks

Use this change type to trigger an Updater when the value of an element's parameter changes. Note: This change type will not trigger on newly created or deleted elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was nullNothingnullptra null reference (Nothing in Visual Basic)

See Also

Element Class
GetChangeTypeParameter Overload


GetDependentElements Method

[image]

Revit 2024 API
Element..::..GetDependentElements Method
Element Class See Also Send Feedback
Get all elements that, from a logical point of view, are the children of this Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018.1

Syntax

C#
public IList<ElementId> GetDependentElements(
    ElementFilter filter
)
Visual Basic
Public Function GetDependentElements ( _
    filter As ElementFilter _
) As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetDependentElements(
    ElementFilter^ filter
)

Parameters

filter
Type: Autodesk.Revit.DB..::..ElementFilter
What type of elements we are interested of. Can be NULL to return all dependent elements.

Return Value

Logical children of this element

Remarks

The elements that this method will return:

  1. Will be deleted if the input Element is deleted.
  2. Potentially could report the input Element as a host (there could be other type of parent/child relationship here: for example view/view-specific elements, etc.)

See Also

Element Class


GetEntity Method

[image]

Revit 2024 API
Element..::..GetEntity Method
Element Class See Also Send Feedback
Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Entity GetEntity(
    Schema schema
)
Visual Basic
Public Function GetEntity ( _
    schema As Schema _
) As Entity
Visual C++
public:
Entity^ GetEntity(
    Schema^ schema
)

Parameters

schema
Type: Autodesk.Revit.DB.ExtensibleStorage..::..Schema
The Schema describing the Entity.

Return Value

The returned Entity.

Remarks

The Entity that is returned is a copy of the stored data (with copy-on-write optimization). Modifying it is allowed (even with restricted write), but to save your changes you must call SetEntity.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Reading of Entities of this Schema is not allowed to the current add-in.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Element Class


GetEntitySchemaGuids Method

[image]

Revit 2024 API
Element..::..GetEntitySchemaGuids Method
Element Class See Also Send Feedback
Returns the Schema guids of any Entities stored in this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public IList<Guid> GetEntitySchemaGuids()
Visual Basic
Public Function GetEntitySchemaGuids As IList(Of Guid)
Visual C++
public:
IList<Guid>^ GetEntitySchemaGuids()

Return Value

The schema Entity guids.

See Also

Element Class


GetExternalResourceReferenceExpanded Method

[image]

Revit 2024 API
Element..::..GetExternalResourceReferenceExpanded Method
Element Class See Also Send Feedback
Gets the collection of ExternalResourceReference associated with a specified external resource type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public IList<ExternalResourceReference> GetExternalResourceReferenceExpanded(
    ExternalResourceType resourceType
)
Visual Basic
Public Function GetExternalResourceReferenceExpanded ( _
    resourceType As ExternalResourceType _
) As IList(Of ExternalResourceReference)
Visual C++
public:
IList<ExternalResourceReference^>^ GetExternalResourceReferenceExpanded(
    ExternalResourceType^ resourceType
)

Parameters

resourceType
Type: Autodesk.Revit.DB..::..ExternalResourceType
The desired external resource type.

Return Value

The collection of the ExternalResourceReference associated with a specified external resource type.

Remarks

Use this API for an element which has multiple external resource references under a specified type, e.g., AppearanceAssetElement. See also: [!:Autodesk::Revit::DB::Element::getExternalResourceReference].

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This Element does not use a resource reference for the specified resource type.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Element Class


GetExternalResourceReferences Method

[image]

Revit 2024 API
Element..::..GetExternalResourceReferences Method
Element Class See Also Send Feedback
Gets the map of the external resource references referenced by the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public IDictionary<ExternalResourceType, ExternalResourceReference> GetExternalResourceReferences()
Visual Basic
Public Function GetExternalResourceReferences As IDictionary(Of ExternalResourceType, ExternalResourceReference)
Visual C++
public:
IDictionary<ExternalResourceType^, ExternalResourceReference^>^ GetExternalResourceReferences()

Return Value

The map of the external resource references referenced by the element.

Remarks

For an element which has multiple external resource references under a specified type like AppearanceAssetElement, the first one will be the value in the map. See also: [!:Autodesk::Revit::DB::Element::getExternalResourceReferencesExpanded].

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This Element does not use any external resource.

See Also

Element Class


GetExternalResourceReferencesExpanded Method

[image]

Revit 2024 API
Element..::..GetExternalResourceReferencesExpanded Method
Element Class See Also Send Feedback
Gets the expanded map of the external resource references referenced by the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public IDictionary<ExternalResourceType, IList<ExternalResourceReference>> GetExternalResourceReferencesExpanded()
Visual Basic
Public Function GetExternalResourceReferencesExpanded As IDictionary(Of ExternalResourceType, IList(Of ExternalResourceReference))
Visual C++
public:
IDictionary<ExternalResourceType^, IList<ExternalResourceReference^>^>^ GetExternalResourceReferencesExpanded()

Return Value

The expanded map of the external resource references referenced by the element.

Remarks

The value includes all external resource references under the type. Use this API for an element which has multiple external resource references under a specified type, e.g., AppearanceAssetElement. See also: [!:Autodesk::Revit::DB::Element::getExternalResourceReferences].

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This Element does not use any external resource.

See Also

Element Class


GetGeneratingElementIds Method

[image]

Revit 2024 API
Element..::..GetGeneratingElementIds Method
Element Class Example See Also Send Feedback
Returns the ids of the element(s) that generated the input geometry object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public ICollection<ElementId> GetGeneratingElementIds(
    GeometryObject geometryObject
)
Visual Basic
Public Function GetGeneratingElementIds ( _
    geometryObject As GeometryObject _
) As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetGeneratingElementIds(
    GeometryObject^ geometryObject
)

Parameters

geometryObject
Type: Autodesk.Revit.DB..::..GeometryObject
The geometry object whose generating element is requested.

Return Value

The id(s) of the element(s) that generated (or may have generated) the given geometry object. Empty if no generating elements are found. If the set contains just one id, it is the id of the element that generated the geometry object.

Remarks

This function supports many different types of relationships among elements. Most of these relationships will return a single element, for example:
  • Window and door cutting walls
  • Openings cutting hosts
  • Face splitting faces
  • Wall sweep or reveal traversing wall
A few relationships have the potential for returning multiple elements, including:
  • Walls joining to other wall(s)
  • Elements extending to roof(s)
If more than one id is returned, one of them (unspecified) is the id of the element that generated the geometry object and the others are ids of related elements. For example, if a wall A is joined to two walls B and C in a way that creates two end faces, and if this function is called for one of the two end faces, it will return the ids of walls B and C.

Examples

CopyC#
// Find elements joined or attached to the end faces of a given wall (such as walls and roofs).
// Mid-joined walls (such as in a T configuration) are not found because they do not affect end face geometry.

ICollection<ElementId> joinedElements = new Collection<ElementId>(); // collection to store the walls joined to the selected wall

// find all faces of the selected wall
GeometryElement geometryElement = wall.get_Geometry(new Options());
foreach (GeometryObject geometryObject in geometryElement)
{
    if (geometryObject is Solid)
    {
        Solid solid = geometryObject as Solid;
        foreach (Face face in solid.Faces)
        {
            // for each face, find the other elements that generated the geometry of that face
            ICollection<ElementId> generatingElementIds = wall.GetGeneratingElementIds(face);

            generatingElementIds.Remove(wall.Id); // remove the originally selected wall, leaving only other elements joined to it
            foreach (ElementId id in generatingElementIds)
            {
                if (!(joinedElements.Contains(id)))
                    joinedElements.Add(id); // add each wall joined to this face to the overall collection
            }
        }
    }
}

uidocument.Selection.SetElementIds(joinedElements); // select all of the joined elements
CopyVB.NET
' Find elements joined or attached to the end faces of a given wall (such as walls and roofs).
' Mid-joined walls (such as in a T configuration) are not found because they do not affect end face geometry.

Dim joinedElements As ICollection(Of ElementId) = New Collection(Of ElementId)()
' collection to store the walls joined to the selected wall
' find all faces of the selected wall
Dim geometryElement As GeometryElement = wall.Geometry(New Options())
For Each geometryObject As GeometryObject In geometryElement
    If TypeOf geometryObject Is Solid Then
        Dim solid As Solid = TryCast(geometryObject, Solid)
        For Each face As Face In solid.Faces
            ' for each face, find the other elements that generated the geometry of that face
            Dim generatingElementIds As ICollection(Of ElementId) = wall.GetGeneratingElementIds(face)

            generatingElementIds.Remove(wall.Id)
            ' remove the originally selected wall, leaving only other elements joined to it
            For Each id As ElementId In generatingElementIds
                If Not (joinedElements.Contains(id)) Then
                    joinedElements.Add(id)
                    ' add each wall joined to this face to the overall collection
                End If
            Next
        Next
    End If
Next

uidocument.Selection.SetElementIds(joinedElements)
' select all of the joined elements

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input geometryObject is invalid and so cannot be used to obtain the generating element ids.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Element Class


GetGeometryObjectFromReference Method

[image]

Revit 2024 API
Element..::..GetGeometryObjectFromReference Method
Element Class See Also Send Feedback
Retrieve one geometric primitive contained in the element given a reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public GeometryObject GetGeometryObjectFromReference(
    Reference reference
)
Visual Basic
Public Function GetGeometryObjectFromReference ( _
    reference As Reference _
) As GeometryObject
Visual C++
public:
GeometryObject^ GetGeometryObjectFromReference(
    Reference^ reference
)

Parameters

reference
Type: Autodesk.Revit.DB..::..Reference
The geometric object referenced by this instance will be retrieved from the model.

Return Value

The geometric object referenced by the input reference.

Remarks

It will return the last geometric object in the path. nullNothingnullptra null reference (Nothing in Visual Basic) will be returned if related geometric object could not be found in the model.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The id of this element is not same as that referenced by reference
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The element id held by the input reference is not same as the id of this element. The geometric information could not be taken for this element.

See Also

Element Class


GetMaterialArea Method

[image]

Revit 2024 API
Element..::..GetMaterialArea Method
Element Class See Also Send Feedback
Gets the area of the material with the given id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public double GetMaterialArea(
    ElementId materialId,
    bool usePaintMaterial
)
Visual Basic
Public Function GetMaterialArea ( _
    materialId As ElementId, _
    usePaintMaterial As Boolean _
) As Double
Visual C++
public:
double GetMaterialArea(
    ElementId^ materialId,
    bool usePaintMaterial
)

Parameters

materialId
Type: Autodesk.Revit.DB..::..ElementId
The material id returned from GetMaterialIds(Boolean).
usePaintMaterial
Type: System..::..Boolean
If true, this material id was returned as a paint material from GetMaterialIds(Boolean) and the area returned should be calculated from paint applied to the element. If false, this material id was returned as a non-paint element material from GetMaterialIds(Boolean) and the area is calculated from the element geometry and layers.

Return Value

The area of the material for this element. Returns 0.0 if the material id is not a part of this element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | materialId is not a valid Element identifier.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This Element element does not support paint material assignment.

See Also

Element Class


GetMaterialIds Method

[image]

Revit 2024 API
Element..::..GetMaterialIds Method
Element Class See Also Send Feedback
Gets the element ids of all materials present in the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ICollection<ElementId> GetMaterialIds(
    bool returnPaintMaterials
)
Visual Basic
Public Function GetMaterialIds ( _
    returnPaintMaterials As Boolean _
) As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetMaterialIds(
    bool returnPaintMaterials
)

Parameters

returnPaintMaterials
Type: System..::..Boolean
If true, this returns material ids assigned to element faces by the Paint tools. If false, this returns ids associated to the material through its geometry or compound structure layers.

Return Value

The set of material ids.

Remarks

The returned collection of materials will be empty in any of the following situations:
  • The returnPaintMaterials flag is false, and the Category.HasMaterialQuantities property of the element's Category is false.
  • The returnPaintMaterials flag is true, and the the element does not have any painted faces.
Any material ids returned by this method can be used in GetMaterialArea() to get the calculated area associated to the material. Non-paint materials ids returned by this method can be used in GetMaterialVolume() to get the volume associated to the material.

See Also

Element Class


GetMaterialVolume Method

[image]

Revit 2024 API
Element..::..GetMaterialVolume Method
Element Class See Also Send Feedback
Gets the volume of the material with the given id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public double GetMaterialVolume(
    ElementId materialId
)
Visual Basic
Public Function GetMaterialVolume ( _
    materialId As ElementId _
) As Double
Visual C++
public:
double GetMaterialVolume(
    ElementId^ materialId
)

Parameters

materialId
Type: Autodesk.Revit.DB..::..ElementId
The material id returned from GetMaterialIds(Boolean).

Return Value

The volume of the material for this element. Returns 0.0 if the material is not a part of this element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | materialId is not a valid Element identifier.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Element Class


GetMonitoredLinkElementIds Method

[image]

Revit 2024 API
Element..::..GetMonitoredLinkElementIds Method
Element Class See Also Send Feedback
Provides the link instance IDs when the element is monitoring.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public IList<ElementId> GetMonitoredLinkElementIds()
Visual Basic
Public Function GetMonitoredLinkElementIds As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetMonitoredLinkElementIds()

Return Value

The IDs of linked instances.

See Also

Element Class


GetMonitoredLocalElementIds Method

[image]

Revit 2024 API
Element..::..GetMonitoredLocalElementIds Method
Element Class See Also Send Feedback
Provides the local element IDs when the element is monitoring.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public IList<ElementId> GetMonitoredLocalElementIds()
Visual Basic
Public Function GetMonitoredLocalElementIds As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetMonitoredLocalElementIds()

Return Value

The IDs of local element IDs being monitored by this element.

See Also

Element Class


GetOrderedParameters Method

[image]

Revit 2024 API
Element..::..GetOrderedParameters Method
Element Class See Also Send Feedback
Gets the parameters associated to the element in order.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public IList<Parameter> GetOrderedParameters()
Visual Basic
Public Function GetOrderedParameters As IList(Of Parameter)
Visual C++
public:
IList<Parameter^>^ GetOrderedParameters()

Return Value

A collection containing all parameters.

Remarks

The collection consists of only visible parameters associated to the element; it returns a different list than Element.Parameters.

The parameters are returned in the order in which they appear in the Revit UI within a given group; however, parameters of different groups may be mixed within this output.

Currently the Revit UI order is determined first by group and next by the order of the individual parameters.

See Also

Element Class


GetParameterFormatOptions Method

[image]

Revit 2024 API
Element..::..GetParameterFormatOptions Method
Element Class See Also Send Feedback
Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public FormatOptions GetParameterFormatOptions(
    ElementId parameterId
)
Visual Basic
Public Function GetParameterFormatOptions ( _
    parameterId As ElementId _
) As FormatOptions
Visual C++
public:
FormatOptions^ GetParameterFormatOptions(
    ElementId^ parameterId
)

Parameters

parameterId
Type: Autodesk.Revit.DB..::..ElementId
Id of parameter for which FormatOptions will be returned.

Return Value

Format options of element parameter. If the UseDefault property is true, then no formatting overrides have been defined in the element for the specified parameter, and the FormatOptions for the parameter should be obtained from the Unit object, which can be obtained from the Document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Element Class


GetParameters Method

[image]

Revit 2024 API
Element..::..GetParameters Method
Element Class See Also Send Feedback
Retrieves the parameters from the element via the given name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public IList<Parameter> GetParameters(
    string name
)
Visual Basic
Public Function GetParameters ( _
    name As String _
) As IList(Of Parameter)
Visual C++
public:
IList<Parameter^>^ GetParameters(
    String^ name
)

Parameters

name
Type: System..::..String
The name of the parameter to be retrieved.

Return Value

A collection containing the parameters having the same given parameter name.

Remarks

Multiple matches of parameters with the same name can occur because shared parameters or project parameters can be bound to an element category even if there is a built-in parameter with the same name already.

If this method is used to find built-in parameters the code will not be portable to other languages of Revit (because built-in parameter names are translated, and this method matches the translation).

For the reasons above this method should be used sparingly and when portability across multiple languages is not a requirement.

Safer approaches include:

  • get_Parameter(Guid) to get a shared parameter by stored guid.
  • get_Parameter(BuiltInParameter) to find a built-in parameter in a language-independent way.

See Also

Element Class


GetValidTypes Method

[image]

Revit 2024 API
Element..::..GetValidTypes Method
Element Class See Also Send Feedback
Obtains a set of types that are valid for this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public ICollection<ElementId> GetValidTypes()
Visual Basic
Public Function GetValidTypes As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetValidTypes()

Return Value

A set of element IDs of types that are valid for this element or an empty set if element cannot have type assigned.

See Also

Element Class
GetValidTypes Overload


GetValidTypes Method (Document, ICollection(ElementId))

[image]

Revit 2024 API
Element..::..GetValidTypes Method (Document, ICollection<(Of <(<'ElementId>)>)>)
Element Class See Also Send Feedback
Obtains a set of types that are valid for all given elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static ICollection<ElementId> GetValidTypes(
    Document document,
    ICollection<ElementId> elementIds
)
Visual Basic
Public Shared Function GetValidTypes ( _
    document As Document, _
    elementIds As ICollection(Of ElementId) _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetValidTypes(
    Document^ document,
    ICollection<ElementId^>^ elementIds
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
elementIds
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
A collection of element IDs.

Return Value

A set of element IDs of types that are valid for these elements or an empty set if any element cannot have a type assigned.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when at least one of the elements does not exist in the document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Element Class
GetValidTypes Overload


HasPhases Method

[image]

Revit 2024 API
Element..::..HasPhases Method
Element Class See Also Send Feedback
Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool HasPhases()
Visual Basic
Public Function HasPhases As Boolean
Visual C++
public:
bool HasPhases()

Return Value

True if this Element has the properties CreatedPhaseId and DemolishedPhaseId, false otherwise.

Remarks

Acts as a validator for setting the properties CreatedPhaseId and DemolishedPhaseId.

See Also

Element Class


IsCreatedPhaseOrderValid Method

[image]

Revit 2024 API
Element..::..IsCreatedPhaseOrderValid Method
Element Class See Also Send Feedback
Returns true if createdPhaseId and demolishedPhaseId are in order.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public bool IsCreatedPhaseOrderValid(
    ElementId createdPhaseId
)
Visual Basic
Public Function IsCreatedPhaseOrderValid ( _
    createdPhaseId As ElementId _
) As Boolean
Visual C++
public:
bool IsCreatedPhaseOrderValid(
    ElementId^ createdPhaseId
)

Parameters

createdPhaseId
Type: Autodesk.Revit.DB..::..ElementId
The createdPhaseId.

Return Value

True if createdPhaseId index is less than or equal to demolishedPhaseId, otherwise returns false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Element Class


IsDemolishedPhaseOrderValid Method

[image]

Revit 2024 API
Element..::..IsDemolishedPhaseOrderValid Method
Element Class See Also Send Feedback
Returns true if createdPhaseId and demolishedPhaseId are in order.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public bool IsDemolishedPhaseOrderValid(
    ElementId demolishedPhaseId
)
Visual Basic
Public Function IsDemolishedPhaseOrderValid ( _
    demolishedPhaseId As ElementId _
) As Boolean
Visual C++
public:
bool IsDemolishedPhaseOrderValid(
    ElementId^ demolishedPhaseId
)

Parameters

demolishedPhaseId
Type: Autodesk.Revit.DB..::..ElementId
The demolishedPhaseId.

Return Value

True if createdPhaseId index is less than or equal to demolishedPhaseId, otherwise returns false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Element Class


IsExternalFileReference Method

[image]

Revit 2024 API
Element..::..IsExternalFileReference Method
Element Class See Also Send Feedback
Determines whether this Element represents an external file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public bool IsExternalFileReference()
Visual Basic
Public Function IsExternalFileReference As Boolean
Visual C++
public:
bool IsExternalFileReference()

Return Value

True if this element contains information about some external file, false if it does not.

Remarks

Linked files are references to external files, but imported files are not, as their data is brought wholly into Revit.

See Also

Element Class


IsHidden Method

[image]

Revit 2024 API
Element..::..IsHidden Method
Element Class See Also Send Feedback
Identifies if the element has been permanently hidden in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsHidden(
    View pView
)
Visual Basic
Public Function IsHidden ( _
    pView As View _
) As Boolean
Visual C++
public:
bool IsHidden(
    View^ pView
)

Parameters

pView
Type: Autodesk.Revit.DB..::..View

Remarks

This does not determine if the element is hidden as a result of temporary hide/isolate, view sectioning, view crop box, or other operations that can cause elements not to be visible. To hide or unhide an element, use the Hide() and Unhide() method of View.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when argument is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Element Class


IsMonitoringLocalElement Method

[image]

Revit 2024 API
Element..::..IsMonitoringLocalElement Method
Element Class See Also Send Feedback
Indicate whether an element is monitoring other local elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool IsMonitoringLocalElement()
Visual Basic
Public Function IsMonitoringLocalElement As Boolean
Visual C++
public:
bool IsMonitoringLocalElement()

Return Value

True if this element is monitoring other elements in same project. Otherwise, false will be returned.

See Also

Element Class


IsPhaseCreatedValid Method

[image]

Revit 2024 API
Element..::..IsPhaseCreatedValid Method
Element Class See Also Send Feedback
Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool IsPhaseCreatedValid(
    ElementId createdPhaseId
)
Visual Basic
Public Function IsPhaseCreatedValid ( _
    createdPhaseId As ElementId _
) As Boolean
Visual C++
public:
bool IsPhaseCreatedValid(
    ElementId^ createdPhaseId
)

Parameters

createdPhaseId
Type: Autodesk.Revit.DB..::..ElementId
The id of a Phase.

Return Value

True if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element, false otherwise.

Remarks

Acts as a validator for setting the property CreatedPhaseId.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Element Class


IsValidType Method

[image] [image]

Revit 2024 API
Element..::..IsValidType Method
Element Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsValidType(ElementId) | Checks if given type is valid for this element.
 | IsValidType(Document, ICollection<(Of <<'(ElementId>)>>), ElementId) | Checks if given type is valid for the set of elements.

See Also

Element Class
Element Members


IsValidType Method (ElementId)

[image]

Revit 2024 API
Element..::..IsValidType Method (ElementId)
Element Class See Also Send Feedback
Checks if given type is valid for this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool IsValidType(
    ElementId typeId
)
Visual Basic
Public Function IsValidType ( _
    typeId As ElementId _
) As Boolean
Visual C++
public:
bool IsValidType(
    ElementId^ typeId
)

Parameters

typeId
Type: Autodesk.Revit.DB..::..ElementId
ElementId of the type to check.

Return Value

True if element can have a type assigned and this type is valid for this element, false otherwise.

Remarks

A type is valid for an element if it can be assigned to the element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Element Class
IsValidType Overload


LookupParameter Method

[image]

Revit 2024 API
Element..::..LookupParameter Method
Element Class See Also Send Feedback
Attempts to find a parameter on the element which has the given name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public Parameter LookupParameter(
    string name
)
Visual Basic
Public Function LookupParameter ( _
    name As String _
) As Parameter
Visual C++
public:
Parameter^ LookupParameter(
    String^ name
)

Parameters

name
Type: System..::..String
The name of the parameter to be retrieved.

Return Value

The matching parameter. This return may be nullNothingnullptra null reference (Nothing in Visual Basic) if there is no matching parameter. If there are multiple matching parameters the first one found is returned.

Remarks

This method will attempt to find a parameter on this Element whose name matches the input. The possible results include:
  • A single matching parameter is found: it will be returned.
  • No matching parameter is found: nullNothingnullptra null reference (Nothing in Visual Basic) is returned.
  • Multiple matching parameters exist. In this situation the first one encountered will be returned. This match is determined at random and may change in the future.

Multiple matches of parameters with the same name can occur because shared parameters or project parameters can be bound to an element category even if there is a built-in parameter with the same name already.

If this method is used to find built-in parameters the code will not be portable to other languages of Revit (because built-in parameter names are translated, and this method matches the translation).

For the reasons above this method should be used sparingly and only when you have a reasonable expectation that only one parameter exists with the given name, and when portability across multiple languages is not a requirement.

Safer approaches include:

  • GetParameters(String) to get all the matches with the given name.
  • get_Parameter(Guid) to get a shared parameter by stored guid.
  • get_Parameter(BuiltInParameter) to find a built-in parameter in a language-independent way.

See Also

Element Class


RefersToExternalResourceReference Method

[image]

Revit 2024 API
Element..::..RefersToExternalResourceReference Method
Element Class See Also Send Feedback
Determines whether this Element uses external resources associated with a specified external resource type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool RefersToExternalResourceReference(
    ExternalResourceType resourceType
)
Visual Basic
Public Function RefersToExternalResourceReference ( _
    resourceType As ExternalResourceType _
) As Boolean
Visual C++
public:
bool RefersToExternalResourceReference(
    ExternalResourceType^ resourceType
)

Parameters

resourceType
Type: Autodesk.Revit.DB..::..ExternalResourceType
The desired external resource type.

Return Value

Returns true if this Element uses external resources associated with the specified external resource type; otherwise, false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Element Class


RefersToExternalResourceReferences Method

[image]

Revit 2024 API
Element..::..RefersToExternalResourceReferences Method
Element Class See Also Send Feedback
Determines whether this Element uses external resources.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool RefersToExternalResourceReferences()
Visual Basic
Public Function RefersToExternalResourceReferences As Boolean
Visual C++
public:
bool RefersToExternalResourceReferences()

Return Value

True if this element uses external resources, false if it does not.

Remarks

Some elements may contain references to data from external resources. These elements contain one or more ExternalResourceReferences.

See Also

Element Class


Element Properties

[image] [image]

Revit 2024 API
Element Properties
Element Class See Also Send Feedback

The Element type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished.
Public property | DesignOption | Returns the design option to which the element belongs.
Public property | Document | Returns the Document in which the Element resides.
Public property | Geometry | Retrieves the geometric representation of the element.
Public property | GroupId | The id of the group to which an element belongs.
Public property | Id | A unique identifier for an Element in an Autodesk Revit project.
Public property | IsModifiable | Identifies if the element is modifiable.
Public property | IsTransient | Indicates whether an element is transient or permanent.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LevelId | The id of the level associated with the element.
Public property | Location | This property is used to find the physical location of an element within a project.
Public property | Name | A human readable name for the Element.
Public property | OwnerViewId | The id of the view that owns the element.
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter.
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id.
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element.
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element.
Public property | Pinned | Identifies if the element has been pinned to prevent changes.
Public property | UniqueId | A stable unique identifier for an element within the document.
Public property | VersionGuid | Get the element version Guid.
Public property | ViewSpecific | Identifies if the element is owned by a view.
Public property | WorksetId | Get Id of the Workset which owns the element.

See Also

Element Class


AssemblyInstanceId Property

[image]

Revit 2024 API
Element..::..AssemblyInstanceId Property
Element Class See Also Send Feedback
The id of the assembly instance to which the element belongs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElementId AssemblyInstanceId { get; }
Visual Basic
Public ReadOnly Property AssemblyInstanceId As ElementId
    Get
Visual C++
public:
property ElementId^ AssemblyInstanceId {
    ElementId^ get ();
}

See Also

Element Class


Category Property

[image]

Revit 2024 API
Element..::..Category Property
Element Class See Also Send Feedback
Retrieves a Category object that represents the category or sub category in which the element resides.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Category Category { get; }
Visual Basic
Public ReadOnly Property Category As Category
    Get
Visual C++
public:
property Category^ Category {
    Category^ get ();
}

Remarks

All category objects can be retrieved from the application by using the Categories property of the Application.Settings object.

See Also

Element Class


CreatedPhaseId Property

[image]

Revit 2024 API
Element..::..CreatedPhaseId Property
Element Class Example See Also Send Feedback
Id of a Phase at which the Element was created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ElementId CreatedPhaseId { get; set; }
Visual Basic
Public Property CreatedPhaseId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ CreatedPhaseId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Remarks

After setting the property CreatedPhaseId, regeneration can fail if CreatedPhaseId and DemolishedPhaseId are out of order with respect to their index in the property Document.Phases.

When Revit is running with UI activated, the default created phase for newly created elements is inherited from the phase of the currently active view.

When Revit is running without its UI, such as when Revit runs on Autodesk Forge Design Automation API for Revit, the default CreatedPhaseId for newly created elements is the latest phase in Autodesk::Revit::DB::Document::Phases.

Examples

CopyC#
void ShowPhaseCreatedName(Element element)
{
    // Get the Phase Create property, and assert it should not be null
    Autodesk.Revit.DB.Phase phaseCreated = element.Document.GetElement(element.CreatedPhaseId) as Phase;
    if (null == phaseCreated)
    {
        throw new Exception("Elements always have a phase for when they are created.");
    }
    else
    {
        // Show the Phase Create name to the user.
        String prompt = "The phase created is: " + phaseCreated.Name;
        TaskDialog.Show("Revit",prompt);
    }
}
CopyVB.NET
Private Sub ShowPhaseCreatedName(element As Element)
    ' Get the Phase Create property, and assert it should not be null
    Dim phaseCreated As Autodesk.Revit.DB.Phase = TryCast(element.Document.GetElement(element.CreatedPhaseId), Phase)
    If phaseCreated Is Nothing Then
        Throw New Exception("Elements always have a phase for when they are created.")
    Else
        ' Show the Phase Create name to the user.
        Dim prompt As [String] = "The phase created is: " + phaseCreated.Name
        TaskDialog.Show("Revit", prompt)
    End If
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The element does not allow setting the property CreatedPhaseId to the value of createdPhaseId. -or- When setting this property: Invalid order of phases: An object cannot be demolished before it was created.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The element does not have properties CreatedPhaseId and DemolishedPhaseId. -or- When setting this property: The element does not allow setting the properties CreatedPhaseId and DemolishedPhaseId.

See Also

Element Class


DemolishedPhaseId Property

[image]

Revit 2024 API
Element..::..DemolishedPhaseId Property
Element Class Example See Also Send Feedback
Id of a Phase at which the Element was demolished.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ElementId DemolishedPhaseId { get; set; }
Visual Basic
Public Property DemolishedPhaseId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ DemolishedPhaseId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Remarks

After setting the property, DemolishedPhaseId regeneration can fail if CreatedPhaseId and DemolishedPhaseId are out of order with respect to their index in the property Document.Phases. Can be set to invalid element id.

Examples

CopyC#
void ShowPhaseDemolishedName(Element element)
{
    // Get the Phase Demolished property, and check whether it be null
    Autodesk.Revit.DB.Phase phaseDemolished = element.Document.GetElement(element.DemolishedPhaseId) as Phase;
    if (null == phaseDemolished)
    {
        TaskDialog.Show("Revit","This Element doesn't have Phase Demolished parameter.");
    }
    else
    {
        // Show the Phase Demolished name to the user.
        String prompt = "The phase demolished is: " + phaseDemolished.Name;
        TaskDialog.Show("Revit",prompt);
    }
}
CopyVB.NET
Private Sub ShowPhaseDemolishedName(element As Element)
    ' Get the Phase Demolished property, and check whether it be null
    Dim phaseDemolished As Autodesk.Revit.DB.Phase = TryCast(element.Document.GetElement(element.DemolishedPhaseId), Phase)
    If phaseDemolished Is Nothing Then
        TaskDialog.Show("Revit", "This Element doesn't have Phase Demolished parameter.")
    Else
        ' Show the Phase Demolished name to the user.
        Dim prompt As [String] = "The phase demolished is: " + phaseDemolished.Name
        TaskDialog.Show("Revit", prompt)
    End If
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The element does not allow setting the property DemolishedPhaseId to the value of demolishedPhaseId. -or- When setting this property: Invalid order of phases: An object cannot be demolished before it was created.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The element does not have properties CreatedPhaseId and DemolishedPhaseId. -or- When setting this property: The element does not allow setting the properties CreatedPhaseId and DemolishedPhaseId.

See Also

Element Class


DesignOption Property

[image]

Revit 2024 API
Element..::..DesignOption Property
Element Class Example See Also Send Feedback
Returns the design option to which the element belongs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public DesignOption DesignOption { get; }
Visual Basic
Public ReadOnly Property DesignOption As DesignOption
    Get
Visual C++
public:
property DesignOption^ DesignOption {
    DesignOption^ get ();
}

Remarks

If the element is not in a design option, i.e. in the main model, then this property will return nullNothingnullptra null reference (Nothing in Visual Basic).

Examples

CopyC#
void Getinfo_DesignOption(Document document)
{
    // Get the selected Elements in the Active Document
    UIDocument uidoc = new UIDocument(document);
    ICollection<ElementId> selectedIds = uidoc.Selection.GetElementIds();

    foreach (ElementId id in selectedIds)
    {
        Element element = document.GetElement(id);
        //Use the DesignOption property of Element
        if (element.DesignOption != null)
        {
            TaskDialog.Show("Revit",element.DesignOption.Name.ToString());
        }
    }
}
CopyVB.NET
Private Sub Getinfo_DesignOption(document As Document)
    ' Get the selected Elements in the Active Document
    Dim uidoc As New UIDocument(document)
    Dim selectedIds As ICollection(Of ElementId) = uidoc.Selection.GetElementIds()

    For Each id As ElementId In selectedIds
        Dim element As Element = document.GetElement(id)
        'Use the DesignOption property of Element
        If element.DesignOption IsNot Nothing Then
            TaskDialog.Show("Revit", element.DesignOption.Name.ToString())
        End If
    Next
End Sub

See Also

Element Class


Document Property

[image]

Revit 2024 API
Element..::..Document Property
Element Class See Also Send Feedback
Returns the Document in which the Element resides.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Document Document { get; }
Visual Basic
Public ReadOnly Property Document As Document
    Get
Visual C++
public:
property Document^ Document {
    Document^ get ();
}

Remarks

All elements are contained within a document. An element can be retrieved from this document by using the id that is returned by the element's id property.

See Also

Element Class


GroupId Property

[image]

Revit 2024 API
Element..::..GroupId Property
Element Class See Also Send Feedback
The id of the group to which an element belongs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ElementId GroupId { get; }
Visual Basic
Public ReadOnly Property GroupId As ElementId
    Get
Visual C++
public:
property ElementId^ GroupId {
    ElementId^ get ();
}

See Also

Element Class


Id Property

[image]

Revit 2024 API
Element..::..Id Property
Element Class Example See Also Send Feedback
A unique identifier for an Element in an Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElementId Id { get; }
Visual Basic
Public ReadOnly Property Id As ElementId
    Get
Visual C++
public:
property ElementId^ Id {
    ElementId^ get ();
}

Remarks

Returns an object containing the project-wide unique identifier for this Element. The identifier with this id is only unique for the project, it is not unique across separate Autodesk Revit projects.

Examples

CopyC#
private void CheckElementId(Autodesk.Revit.DB.Document document, Autodesk.Revit.DB.Element element)
{
    // Get the id of the element
    Autodesk.Revit.DB.ElementId selectedId = element.Id;
    long idValue = selectedId.Value;

    // create a new id and set the value
    Autodesk.Revit.DB.ElementId id = new Autodesk.Revit.DB.ElementId(idValue);

    // Get the element
    Autodesk.Revit.DB.Element first = document.GetElement(id);

    // And get the element using the original Id (they should be the same)
    Autodesk.Revit.DB.Element second = document.GetElement(selectedId);

    String prompt = "Get an element twice. They should be the same element.";
    // Use the Equal method to check two elements. It is not a good way.
    bool isSame = first.Equals(second);
    prompt += "\nUsing Equal method on elements, the result is: " + isSame;
    isSame = first.Id.Equals(second.Id);
    prompt += "\nUsing Equal method on element's Id properties, the result is: " + isSame;

    TaskDialog.Show("Revit",prompt);
}
CopyVB.NET
Private Sub CheckElementId(document As Autodesk.Revit.DB.Document, element As Autodesk.Revit.DB.Element)
    ' Get the id of the element
    Dim selectedId As Autodesk.Revit.DB.ElementId = element.Id
    Dim idValue As Long = selectedId.Value

    ' create a new id and set the value
    Dim id As New Autodesk.Revit.DB.ElementId(idValue)

    ' Get the element
    Dim first As Autodesk.Revit.DB.Element = document.GetElement(id)

    ' And get the element using the original Id (they should be the same)
    Dim second As Autodesk.Revit.DB.Element = document.GetElement(selectedId)

    Dim prompt As [String] = "Get an element twice. They should be the same element."
    ' Use the Equal method to check two elements. It is not a good way.
    Dim isSame As Boolean = first.Equals(second)
    prompt += vbLf & "Using Equal method on elements, the result is: " & isSame
    isSame = first.Id.Equals(second.Id)
    prompt += vbLf & "Using Equal method on element's Id properties, the result is: " & isSame

    TaskDialog.Show("Revit", prompt)
End Sub

See Also

Element Class


IsModifiable Property

[image]

Revit 2024 API
Element..::..IsModifiable Property
Element Class See Also Send Feedback
Identifies if the element is modifiable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public bool IsModifiable { get; }
Visual Basic
Public ReadOnly Property IsModifiable As Boolean
    Get
Visual C++
public:
property bool IsModifiable {
    bool get ();
}

Remarks

This is not a permanent state. The value depends on the document state. For example, active edit modes can make IsModifiable false for many elements.

See Also

Element Class


IsValidObject Property

[image]

Revit 2024 API
Element..::..IsValidObject Property
Element Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

Element Class


LevelId Property

[image]

Revit 2024 API
Element..::..LevelId Property
Element Class See Also Send Feedback
The id of the level associated with the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ElementId LevelId { get; }
Visual Basic
Public ReadOnly Property LevelId As ElementId
    Get
Visual C++
public:
property ElementId^ LevelId {
    ElementId^ get ();
}

See Also

Element Class


Location Property

[image]

Revit 2024 API
Element..::..Location Property
Element Class Example See Also Send Feedback
This property is used to find the physical location of an element within a project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Location Location { get; }
Visual Basic
Public Overridable ReadOnly Property Location As Location
    Get
Visual C++
public:
virtual property Location^ Location {
    Location^ get ();
}

Remarks

The Location property returns an object that can be used to find the location of an object within the project. An object may have a point location, such as a table or may have a line location. A wall is an example of an element that has a line location.

Examples

CopyC#
void GetLocationInformation(Autodesk.Revit.DB.Element element)
{
    // Get the Location property and judge whether it exists
    Autodesk.Revit.DB.Location position = element.Location;

    String prompt = null;
    if (null == position)
    {
        prompt = "No location can be found in element.";
    }
    else
    {
        // If the location is a point location, give the user information
        Autodesk.Revit.DB.LocationPoint positionPoint = position as Autodesk.Revit.DB.LocationPoint;
        if (null != positionPoint)
        {
            prompt = "Element has a point location.";
        }
        else
        {

            // If the location is a curve location, give the user information
            Autodesk.Revit.DB.LocationCurve positionCurve = position as Autodesk.Revit.DB.LocationCurve;
            if (null != positionCurve)
            {
                prompt = "Element has a curve location.";
            }
        }
    }

    if (null != prompt)
    {
        TaskDialog.Show("Revit",prompt);
    }
}
CopyVB.NET
Private Sub GetLocationInformation(element As Autodesk.Revit.DB.Element)
    ' Get the Location property and judge whether it exists
    Dim position As Autodesk.Revit.DB.Location = element.Location

    Dim prompt As [String] = Nothing
    If position Is Nothing Then
        prompt = "No location can be found in element."
    Else
        ' If the location is a point location, give the user information
        Dim positionPoint As Autodesk.Revit.DB.LocationPoint = TryCast(position, Autodesk.Revit.DB.LocationPoint)
        If positionPoint IsNot Nothing Then
            prompt = "Element has a point location."
        Else

            ' If the location is a curve location, give the user information
            Dim positionCurve As Autodesk.Revit.DB.LocationCurve = TryCast(position, Autodesk.Revit.DB.LocationCurve)
            If positionCurve IsNot Nothing Then
                prompt = "Element has a curve location."
            End If
        End If
    End If

    If prompt IsNot Nothing Then
        TaskDialog.Show("Revit", prompt)
    End If
End Sub

See Also

Element Class


OwnerViewId Property

[image]

Revit 2024 API
Element..::..OwnerViewId Property
Element Class See Also Send Feedback
The id of the view that owns the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElementId OwnerViewId { get; }
Visual Basic
Public ReadOnly Property OwnerViewId As ElementId
    Get
Visual C++
public:
property ElementId^ OwnerViewId {
    ElementId^ get ();
}

See Also

Element Class


Parameter Property

[image] [image]

Revit 2024 API
Element..::..Parameter Property
Element Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter.
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id.
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition.

See Also

Element Class
Element Members


Parameter Property (Guid)

[image]

Revit 2024 API
Element..::..Parameter Property (Guid)
Element Class See Also Send Feedback
Retrieves a parameter from the element given a GUID for a shared parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Parameter this[
    Guid guid
] { get; }
Visual Basic
Public ReadOnly Property Parameter ( _
    guid As Guid _
) As Parameter
    Get
Visual C++
public:
property Parameter^ Parameter[Guid guid] {
    Parameter^ get (Guid guid);
}

Parameters

guid
Type: System..::..Guid
The unique id associated with the shared parameter.

Remarks

Parameters are a generic form of data storage within elements. The parameters are visible through the Autodesk Revit user interface in the Element Properties dialog. This method is used to retrieve a parameter for a known shared parameter. When a shared parameter is created it is assigned a Guid which will not change. This guid can be used to retrieve the piece of data from the element at a later time.

See Also

Element Class
Parameter Overload


Parameter Property (BuiltInParameter)

[image]

Revit 2024 API
Element..::..Parameter Property (BuiltInParameter)
Element Class Example See Also Send Feedback
Retrieves a parameter from the element given a parameter id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Parameter this[
    BuiltInParameter parameterId
] { get; }
Visual Basic
Public ReadOnly Property Parameter ( _
    parameterId As BuiltInParameter _
) As Parameter
    Get
Visual C++
public:
property Parameter^ Parameter[BuiltInParameter parameterId] {
    Parameter^ get (BuiltInParameter parameterId);
}

Parameters

parameterId
Type: Autodesk.Revit.DB..::..BuiltInParameter
The built in parameter id of the parameter to be retrieved.

Remarks

Parameters are a generic form of data storage within elements. The parameters are visible through the Autodesk Revit user interface in the Element Properties dialog. This method uses a built in parameter id to access the parameter. Autodesk Revit has a large number of built in parameters that are available via an enumerated type.

Examples

CopyC#
public Parameter FindWithBuiltinParameterID(Wall wall)
{
    //Use the WALL_BASE_OFFSET paramametId
    // to get the base offset parameter of the wall.
    BuiltInParameter paraIndex = BuiltInParameter.WALL_BASE_OFFSET;
    Parameter parameter = wall.get_Parameter(paraIndex);

    return parameter;
}
CopyVB.NET
Public Function FindWithBuiltinParameterID(wall As Wall) As Parameter
    'Use the WALL_BASE_OFFSET paramametId
    ' to get the base offset parameter of the wall.
    Dim paraIndex As BuiltInParameter = BuiltInParameter.WALL_BASE_OFFSET
    Dim parameter As Parameter = wall.Parameter(paraIndex)

    Return parameter
End Function

See Also

Element Class
Parameter Overload


Parameter Property (Definition)

[image]

Revit 2024 API
Element..::..Parameter Property (Definition)
Element Class See Also Send Feedback
Retrieves a parameter from the element based on its definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Parameter this[
    Definition definition
] { get; }
Visual Basic
Public ReadOnly Property Parameter ( _
    definition As Definition _
) As Parameter
    Get
Visual C++
public:
property Parameter^ Parameter[Definition^ definition] {
    Parameter^ get (Definition^ definition);
}

Parameters

definition
Type: Autodesk.Revit.DB..::..Definition
The internal or external definition of the parameter.

Remarks

Parameters are a generic form of data storage within elements. The parameters are visible through the Autodesk Revit user interface in the Element Properties dialog. An element can only have one instance of a parameter with a specific definition. By using this method you can retrieve that parameter based on definition.

See Also

Element Class
Parameter Overload


Parameters Property

[image]

Revit 2024 API
Element..::..Parameters Property
Element Class Example See Also Send Feedback
Retrieves a set containing all of the parameters that are contained within the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ParameterSet Parameters { get; }
Visual Basic
Public ReadOnly Property Parameters As ParameterSet
    Get
Visual C++
public:
property ParameterSet^ Parameters {
    ParameterSet^ get ();
}

Remarks

The Parameters property contains a set of all the parameters that the element supports. These parameters are displayed in the Element properties dialog in the Autodesk Revit interface. These parameters can be retrieved and set via the parameter objects stored in this set.

Examples

CopyC#
void GetElementParameterInformation(Document document, Element element)
{
    // Format the prompt information string
    String prompt = "Show parameters in selected Element: \n\r";

    StringBuilder st = new StringBuilder();
    // iterate element's parameters
    foreach (Parameter para in element.Parameters)
    {
        st.AppendLine(GetParameterInformation(para, document));
    }

    // Give the user some information
    TaskDialog.Show("Revit", prompt + st.ToString());
}

String GetParameterInformation(Parameter para, Document document)
{
    string defName = para.Definition.Name + "\t : ";
    string defValue = string.Empty;
    // Use different method to get parameter data according to the storage type
    switch (para.StorageType)
    {
        case StorageType.Double:
            //covert the number into Metric
            defValue = para.AsValueString();
            break;
        case StorageType.ElementId:
            //find out the name of the element
            Autodesk.Revit.DB.ElementId id = para.AsElementId();
            if (id != ElementId.InvalidElementId)
            {
                defValue = document.GetElement(id).Name;
            }
            else
            {
                defValue = id.ToString();
            }
            break;
        case StorageType.Integer:
            if (SpecTypeId.Boolean.YesNo == para.Definition.GetDataType())
            {
                if (para.AsInteger() == 0)
                {
                    defValue = "False";
                }
                else
                {
                    defValue = "True";
                }
            }
            else
            {
                defValue = para.AsInteger().ToString();
            }
            break;
        case StorageType.String:
            defValue = para.AsString();
            break;
        default:
            defValue = "Unexposed parameter.";
            break;
    }

    return defName + defValue;
}
CopyVB.NET
Private Sub GetElementParameterInformation(document As Document, element As Element)
    ' Format the prompt information string
    Dim prompt As [String] = "Show parameters in selected Element: " & vbLf & vbCr

    Dim st As New StringBuilder()
    ' iterate element's parameters
    For Each para As Parameter In element.Parameters
        st.AppendLine(GetParameterInformation(para, document))
    Next

    ' Give the user some information
    TaskDialog.Show("Revit", prompt + st.ToString())
End Sub

Private Function GetParameterInformation(para As Parameter, document As Document) As [String]
    Dim defName As String = para.Definition.Name + vbTab & " : "
    Dim defValue As String = String.Empty
    ' Use different method to get parameter data according to the storage type
    Select Case para.StorageType
        Case StorageType.[Double]
            'covert the number into Metric
            defValue = para.AsValueString()
            Exit Select
        Case StorageType.ElementId
            'find out the name of the element
            Dim id As Autodesk.Revit.DB.ElementId = para.AsElementId()
            If id > Autodesk.Revit.DB.ElementId.InvalidElementId Then
                defValue = document.GetElement(id).Name
            Else
                defValue = id.ToString()
            End If
            Exit Select
        Case StorageType.[Integer]
            If SpecTypeId.Boolean.YesNo = para.Definition.GetDataType() Then
                If para.AsInteger() = 0 Then
                    defValue = "False"
                Else
                    defValue = "True"
                End If
            Else
                defValue = para.AsInteger().ToString()
            End If
            Exit Select
        Case StorageType.[String]
            defValue = para.AsString()
            Exit Select
        Case Else
            defValue = "Unexposed parameter."
            Exit Select
    End Select

    Return defName & defValue
End Function

See Also

Element Class


ParametersMap Property

[image]

Revit 2024 API
Element..::..ParametersMap Property
Element Class See Also Send Feedback
Retrieves a map containing all of the parameters that are contained within the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ParameterMap ParametersMap { get; }
Visual Basic
Public ReadOnly Property ParametersMap As ParameterMap
    Get
Visual C++
public:
property ParameterMap^ ParametersMap {
    ParameterMap^ get ();
}

Remarks

The Parameters can be rapidly accessed by parameter name as a key. These parameters are displayed in the Element properties dialog in the Autodesk Revit interface. These parameters can be retrieved and set via the parameter objects stored in this map.

See Also

Element Class


Pinned Property

[image]

Revit 2024 API
Element..::..Pinned Property
Element Class See Also Send Feedback
Identifies if the element has been pinned to prevent changes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool Pinned { get; set; }
Visual Basic
Public Property Pinned As Boolean
    Get
    Set
Visual C++
public:
property bool Pinned {
    bool get ();
    void set (bool value);
}

Remarks

An element which is pinned may not be moved, and warnings will be issued when an attempt is made to delete it.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: Element cannot be pinned or unpinned.

See Also

Element Class


VersionGuid Property

[image]

Revit 2024 API
Element..::..VersionGuid Property
Element Class See Also Send Feedback
Get the element version Guid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public Guid VersionGuid { get; }
Visual Basic
Public ReadOnly Property VersionGuid As Guid
    Get
Visual C++
public:
property Guid VersionGuid {
    Guid get ();
}

Remarks

If element version Guid is the same for a certain element in two instances of the saved file then we guarantee that the two elements are identical. One element version covers a period of time that is larger than a single transaction: it is a period between two saves, synchronize to central and reload latest. Thus, in an opened document in-between saves or synchronize actions, this version cannot be used to determine if any particular element has changed. To watch for element changes happening in-session, use event [!:Autodesk::Revit::ApplicationServices::Application::DocumentChanged].

See Also

Element Class


ViewSpecific Property

[image]

Revit 2024 API
Element..::..ViewSpecific Property
Element Class See Also Send Feedback
Identifies if the element is owned by a view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool ViewSpecific { get; }
Visual Basic
Public ReadOnly Property ViewSpecific As Boolean
    Get
Visual C++
public:
property bool ViewSpecific {
    bool get ();
}

See Also

Element Class


WorksetId Property

[image]

Revit 2024 API
Element..::..WorksetId Property
Element Class See Also Send Feedback
Get Id of the Workset which owns the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public WorksetId WorksetId { get; }
Visual Basic
Public ReadOnly Property WorksetId As WorksetId
    Get
Visual C++
public:
property WorksetId^ WorksetId {
    WorksetId^ get ();
}

Remarks

Each element belongs to one and only one workset.

See Also

Element Class


ElementArray Class

[image]

Revit 2024 API
ElementArray Class
Members See Also Send Feedback
An array that contains element objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class ElementArray : APIObject,
    IEnumerable
Visual Basic
Public Class ElementArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ElementArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..ElementArray

See Also

ElementArray Members


ElementArray Members

[image] [image]

Revit 2024 API
ElementArray Members
ElementArray Class Constructors Methods Properties See Also Send Feedback

The ElementArray type exposes the following members.

Constructors

 | Name | Description
Public method | ElementArray | Initializes a new instance of the ElementArray class

Methods

 | Name | Description
Public method | Append | Add the element to the end of the array.
Public method | Clear | Removes every element from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified element into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an element at a specified index within the array.
Public property | Size | Returns the number of elements that are in the array.

See Also

ElementArray Class


ElementArray Methods

[image] [image]

Revit 2024 API
ElementArray Methods
ElementArray Class See Also Send Feedback

The ElementArray type exposes the following members.

Methods

 | Name | Description
Public method | Append | Add the element to the end of the array.
Public method | Clear | Removes every element from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified element into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ElementArray Class


Append Method

[image]

Revit 2024 API
ElementArray..::..Append Method
ElementArray Class See Also Send Feedback
Add the element to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Append(
    Element item
)
Visual Basic
Public Overridable Sub Append ( _
    item As Element _
)
Visual C++
public:
virtual void Append(
    Element^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..Element
The element to be added.

See Also

ElementArray Class


Clear Method

[image]

Revit 2024 API
ElementArray..::..Clear Method
ElementArray Class See Also Send Feedback
Removes every element from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ElementArray Class


ForwardIterator Method

[image]

Revit 2024 API
ElementArray..::..ForwardIterator Method
ElementArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual ElementArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As ElementArrayIterator
Visual C++
public:
virtual ElementArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

ElementArray Class


GetEnumerator Method

[image]

Revit 2024 API
ElementArray..::..GetEnumerator Method
ElementArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

ElementArray Class


Insert Method

[image]

Revit 2024 API
ElementArray..::..Insert Method
ElementArray Class See Also Send Feedback
Insert the specified element into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Insert(
    Element item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As Element, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    Element^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::..Element
The element to be inserted into the array.
index
Type: System..::..Int32
The element will be inserted before this index.

Return Value

Returns whether the element was inserted into the array.

See Also

ElementArray Class


IsEmpty Property

[image]

Revit 2024 API
ElementArray..::..IsEmpty Property
ElementArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

ElementArray Class


Item Property

[image]

Revit 2024 API
ElementArray..::..Item Property
ElementArray Class See Also Send Feedback
Gets or sets an element at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Element this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As Element
    Get
    Set
Visual C++
public:
virtual property Element^ Item[int index] {
    Element^ get (int index);
    void set (int index, Element^ value);
}

Parameters

index
Type: System..::..Int32
The index of the element to be set or retrieved.

Return Value

Returns the element at the specified index.

See Also

ElementArray Class


Size Property

[image]

Revit 2024 API
ElementArray..::..Size Property
ElementArray Class See Also Send Feedback
Returns the number of elements that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ElementArray Class


ElementArrayIterator Members

[image] [image]

Revit 2024 API
ElementArrayIterator Members
ElementArrayIterator Class Constructors Methods Properties See Also Send Feedback

The ElementArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | ElementArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElementArrayIterator Class


ElementArrayIterator Constructor

[image]

Revit 2024 API
ElementArrayIterator Constructor
ElementArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElementArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
ElementArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ElementArrayIterator Class


ElementArrayIterator Methods

[image] [image]

Revit 2024 API
ElementArrayIterator Methods
ElementArrayIterator Class See Also Send Feedback

The ElementArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ElementArrayIterator Class


MoveNext Method

[image]

Revit 2024 API
ElementArrayIterator..::..MoveNext Method
ElementArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ElementArrayIterator Class


Current Property

[image]

Revit 2024 API
ElementArrayIterator..::..Current Property
ElementArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ElementArrayIterator Class


ElementBinding Class

[image]

Revit 2024 API
ElementBinding Class
Members See Also Send Feedback
A base class for all types of binding that attach to an element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public abstract class ElementBinding : Binding
Visual Basic
Public MustInherit Class ElementBinding _
    Inherits Binding
Visual C++
public ref class ElementBinding abstract : public Binding

Remarks

This base class provides methods that are common to all types of binding that work with elements.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..Binding
Autodesk.Revit.DB..::..ElementBinding
Autodesk.Revit.DB..::..InstanceBinding
Autodesk.Revit.DB..::..TypeBinding

See Also

ElementBinding Members


ElementBinding Members

[image] [image]

Revit 2024 API
ElementBinding Members
ElementBinding Class Methods Properties See Also Send Feedback

The ElementBinding type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Categories | Retrieve or set the categories to which a parameter definition will be bound.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElementBinding Class


ElementBinding Methods

[image] [image]

Revit 2024 API
ElementBinding Methods
ElementBinding Class See Also Send Feedback

The ElementBinding type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ElementBinding Class


ElementBinding Properties

[image] [image]

Revit 2024 API
ElementBinding Properties
ElementBinding Class See Also Send Feedback

The ElementBinding type exposes the following members.

Properties

 | Name | Description
Public property | Categories | Retrieve or set the categories to which a parameter definition will be bound.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElementBinding Class


ElementCategoryFilter Class

[image]

Revit 2024 API
ElementCategoryFilter Class
Members Example See Also Send Feedback
A filter used to match elements by their category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class ElementCategoryFilter : ElementQuickFilter
Visual Basic
Public Class ElementCategoryFilter _
    Inherits ElementQuickFilter
Visual C++
public ref class ElementCategoryFilter : public ElementQuickFilter

Remarks

This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.

Examples

CopyC#
// Find all Wall instances in the document by using category filter
ElementCategoryFilter filter = new ElementCategoryFilter(BuiltInCategory.OST_Walls);

// Apply the filter to the elements in the active document,
// Use shortcut WhereElementIsNotElementType() to find wall instances only
FilteredElementCollector collector = new FilteredElementCollector(document);
IList<Element> walls = collector.WherePasses(filter).WhereElementIsNotElementType().ToElements();
String prompt = "The walls in the current document are:\n";
foreach (Element e in walls)
{
    prompt += e.Name + "\n";
}
TaskDialog.Show("Revit", prompt);
CopyVB.NET
' Find all Wall instances in the document by using category filter
Dim filter As New ElementCategoryFilter(BuiltInCategory.OST_Walls)

' Apply the filter to the elements in the active document,
' Use shortcut WhereElementIsNotElementType() to find wall instances only
Dim collector As New FilteredElementCollector(document)
Dim walls As IList(Of Element) = collector.WherePasses(filter).WhereElementIsNotElementType().ToElements()
Dim prompt As [String] = "The walls in the current document are:" & vbLf
For Each e As Element In walls
   prompt += e.Name + vbLf
Next
TaskDialog.Show("Revit", prompt)

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementQuickFilter
Autodesk.Revit.DB..::..ElementCategoryFilter

See Also

ElementCategoryFilter Members


ElementCategoryFilter Members

[image] [image]

Revit 2024 API
ElementCategoryFilter Members
ElementCategoryFilter Class Constructors Methods Properties See Also Send Feedback

The ElementCategoryFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ElementCategoryFilter(BuiltInCategory) | Constructs a new instance of a filter to match elements by category.
Public method | ElementCategoryFilter(ElementId) | Constructs a new instance of a filter to match elements by category.
Public method | ElementCategoryFilter(BuiltInCategory, Boolean) | Constructs a new instance of a filter to match elements by category, with the option to match all elements which are not of the given category.
Public method | ElementCategoryFilter(ElementId, Boolean) | Constructs a new instance of a filter to match elements by category, with the option to match all elements which are of the given category.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CategoryId | The category id.
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)

See Also

ElementCategoryFilter Class


ElementCategoryFilter Constructor

[image] [image]

Revit 2024 API
ElementCategoryFilter Constructor
ElementCategoryFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ElementCategoryFilter(BuiltInCategory) | Constructs a new instance of a filter to match elements by category.
Public method | ElementCategoryFilter(ElementId) | Constructs a new instance of a filter to match elements by category.
Public method | ElementCategoryFilter(BuiltInCategory, Boolean) | Constructs a new instance of a filter to match elements by category, with the option to match all elements which are not of the given category.
Public method | ElementCategoryFilter(ElementId, Boolean) | Constructs a new instance of a filter to match elements by category, with the option to match all elements which are of the given category.

See Also

ElementCategoryFilter Class
ElementCategoryFilter Members


ElementCategoryFilter Constructor (BuiltInCategory)

[image]

Revit 2024 API
ElementCategoryFilter Constructor (BuiltInCategory)
ElementCategoryFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements by category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElementCategoryFilter(
    BuiltInCategory category
)
Visual Basic
Public Sub New ( _
    category As BuiltInCategory _
)
Visual C++
public:
ElementCategoryFilter(
    BuiltInCategory category
)

Parameters

category
Type: Autodesk.Revit.DB..::..BuiltInCategory
The category to match.

See Also

ElementCategoryFilter Class
ElementCategoryFilter Overload


ElementCategoryFilter Constructor (ElementId)

[image]

Revit 2024 API
ElementCategoryFilter Constructor (ElementId)
ElementCategoryFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements by category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public ElementCategoryFilter(
    ElementId categoryId
)
Visual Basic
Public Sub New ( _
    categoryId As ElementId _
)
Visual C++
public:
ElementCategoryFilter(
    ElementId^ categoryId
)

Parameters

categoryId
Type: Autodesk.Revit.DB..::..ElementId
The category id to match.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The category was not valid for filtering.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ElementCategoryFilter Class
ElementCategoryFilter Overload


ElementCategoryFilter Constructor (BuiltInCategory, Boolean)

[image]

Revit 2024 API
ElementCategoryFilter Constructor (BuiltInCategory, Boolean)
ElementCategoryFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements by category, with the option to match all elements which are not of the given category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElementCategoryFilter(
    BuiltInCategory category,
    bool inverted
)
Visual Basic
Public Sub New ( _
    category As BuiltInCategory, _
    inverted As Boolean _
)
Visual C++
public:
ElementCategoryFilter(
    BuiltInCategory category,
    bool inverted
)

Parameters

category
Type: Autodesk.Revit.DB..::..BuiltInCategory
The category to match.
inverted
Type: System..::..Boolean
True if the filter should match all elements which are not of the given category.

See Also

ElementCategoryFilter Class
ElementCategoryFilter Overload


ElementCategoryFilter Constructor (ElementId, Boolean)

[image]

Revit 2024 API
ElementCategoryFilter Constructor (ElementId, Boolean)
ElementCategoryFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements by category, with the option to match all elements which are of the given category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public ElementCategoryFilter(
    ElementId categoryId,
    bool inverted
)
Visual Basic
Public Sub New ( _
    categoryId As ElementId, _
    inverted As Boolean _
)
Visual C++
public:
ElementCategoryFilter(
    ElementId^ categoryId,
    bool inverted
)

Parameters

categoryId
Type: Autodesk.Revit.DB..::..ElementId
The category id to match.
inverted
Type: System..::..Boolean
True if the filter should match all elements which are not of the given category.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The category was not valid for filtering.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ElementCategoryFilter Class
ElementCategoryFilter Overload


ElementCategoryFilter Methods

[image] [image]

Revit 2024 API
ElementCategoryFilter Methods
ElementCategoryFilter Class See Also Send Feedback

The ElementCategoryFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ElementCategoryFilter Class


PassesFilter Method

[image] [image]

Revit 2024 API
ElementCategoryFilter..::..PassesFilter Method
ElementCategoryFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

ElementCategoryFilter Class
ElementCategoryFilter Members


ElementCategoryFilter Properties

[image] [image]

Revit 2024 API
ElementCategoryFilter Properties
ElementCategoryFilter Class See Also Send Feedback

The ElementCategoryFilter type exposes the following members.

Properties

 | Name | Description
Public property | CategoryId | The category id.
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)

See Also

ElementCategoryFilter Class


ElementClassFilter Class

[image]

Revit 2024 API
ElementClassFilter Class
Members Example See Also Send Feedback
A filter used to match elements by their class.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class ElementClassFilter : ElementQuickFilter
Visual Basic
Public Class ElementClassFilter _
    Inherits ElementQuickFilter
Visual C++
public ref class ElementClassFilter : public ElementQuickFilter

Remarks

This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.

This filter will match elements whose class is an exact match to the input class, or elements whose class is derived from the input class.

There is a small subset of Element subclasses in the API which are not supported by this filter. These types exist in the API, but not in Revit's native object model, which means that this filter doesn't support them. In order to use a class filter to find elements of these types, it is necessary to use a higher level class and then process the results further to find elements matching only the subtype. The following types are affected by this restriction:

  • Subclasses of Autodesk.Revit.DB.Material
  • Subclasses of Autodesk.Revit.DB.CurveElement
  • Subclasses of Autodesk.Revit.DB.ConnectorElement
  • Subclasses of Autodesk.Revit.DB.HostedSweep
  • Autodesk.Revit.DB.Architecture.Room
  • Autodesk.Revit.DB.Mechanical.Space
  • Autodesk.Revit.DB.Area
  • Autodesk.Revit.DB.Architecture.RoomTag
  • Autodesk.Revit.DB.Mechanical.SpaceTag
  • Autodesk.Revit.DB.AreaTag
  • Autodesk.Revit.DB.CombinableElement
  • Autodesk.Revit.DB.Mullion
  • Autodesk.Revit.DB.Panel
  • Autodesk.Revit.DB.AnnotationSymbol
  • Autodesk.Revit.DB.Structure.AreaReinforcementType
  • Autodesk.Revit.DB.Structure.PathReinforcementType
  • Autodesk.Revit.DB.AnnotationSymbolType
  • Autodesk.Revit.DB.Architecture.RoomTagType
  • Autodesk.Revit.DB.Mechanical.SpaceTagType
  • Autodesk.Revit.DB.AreaTagType
  • Autodesk.Revit.DB.Structure.TrussType

Examples

CopyC#
// Use ElementClassFilter to find family instances whose name is 60" x 30" Student
ElementClassFilter filter = new ElementClassFilter(typeof(FamilyInstance));

// Apply the filter to the elements in the active document
FilteredElementCollector collector = new FilteredElementCollector(document);
collector.WherePasses(filter);

// Use Linq query to find family instances whose name is 60" x 30" Student
var query = from element in collector
            where element.Name == "60\" x 30\" Student"
            select element;

// Cast found elements to family instances,
// this cast to FamilyInstance is safe because ElementClassFilter for FamilyInstance was used
List<FamilyInstance> familyInstances = query.Cast<FamilyInstance>().ToList<FamilyInstance>();
CopyVB.NET
' Use ElementClassFilter to find family instances whose name is 60" x 30" Student
Dim filter As New ElementClassFilter(GetType(FamilyInstance))

' Apply the filter to the elements in the active document
Dim collector As New FilteredElementCollector(document)
collector.WherePasses(filter)

' Use Linq query to find family instances whose name is 60" x 30" Student
Dim query As System.Collections.Generic.IEnumerable(Of Autodesk.Revit.DB.Element)
query = From element In collector _
 Where element.Name = "60"" x 30"" Student" _
 Select element

' Cast found elements to family instances,
' this cast to FamilyInstance is safe because ElementClassFilter for FamilyInstance was used
Dim familyInstances As List(Of FamilyInstance) = query.Cast(Of FamilyInstance)().ToList()

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementQuickFilter
Autodesk.Revit.DB..::..ElementClassFilter

See Also

ElementClassFilter Members


ElementClassFilter Constructor (Type)

[image]

Revit 2024 API
ElementClassFilter Constructor (Type)
ElementClassFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements by class.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public ElementClassFilter(
    Type type
)
Visual Basic
Public Sub New ( _
    type As Type _
)
Visual C++
public:
ElementClassFilter(
    Type^ type
)

Parameters

type
Type: System..::..Type
The type to match.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input type is not a subclass of Element. -or- The input type is of an element class that exists in the API, but not in Revit's native object model.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ElementClassFilter Class
ElementClassFilter Overload


ElementClassFilter Constructor (Type, Boolean)

[image]

Revit 2024 API
ElementClassFilter Constructor (Type, Boolean)
ElementClassFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements by class, with the option to match all elements which are not of the given class.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public ElementClassFilter(
    Type type,
    bool inverted
)
Visual Basic
Public Sub New ( _
    type As Type, _
    inverted As Boolean _
)
Visual C++
public:
ElementClassFilter(
    Type^ type,
    bool inverted
)

Parameters

type
Type: System..::..Type
The type to match.
inverted
Type: System..::..Boolean
True if the filter should match all elements which are not of the given class.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input type is not a subclass of Element. -or- The input type is of an element class that exists in the API, but not in Revit's native object model.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ElementClassFilter Class
ElementClassFilter Overload


PassesFilter Method

[image] [image]

Revit 2024 API
ElementClassFilter..::..PassesFilter Method
ElementClassFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

ElementClassFilter Class
ElementClassFilter Members


ElementDesignOptionFilter Class

[image]

Revit 2024 API
ElementDesignOptionFilter Class
Members Example See Also Send Feedback
A filter used to find elements contained within a particular design option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class ElementDesignOptionFilter : ElementQuickFilter
Visual Basic
Public Class ElementDesignOptionFilter _
    Inherits ElementQuickFilter
Visual C++
public ref class ElementDesignOptionFilter : public ElementQuickFilter

Remarks

This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.

Examples

CopyC#
// Create an ElementDesignOption filter to find all walls in the active design option.
// Note that if no design option is being edited, GetActiveDesignOptionId() method will return ElementId.InvalidElementId,
// ElementDesignOptionFilter with invalid id will filter elements not associated to a design option
ElementId activeOptId = Autodesk.Revit.DB.DesignOption.GetActiveDesignOptionId(document);

// Create an ElementDesignOption filter
ElementDesignOptionFilter filter = new ElementDesignOptionFilter(activeOptId);

// Apply the filter to the elements in the active document,
// use shortcut method OfClass() to find Walls only
FilteredElementCollector collector = new FilteredElementCollector(document);
ICollection<Element> wallsOfDesignOpt = collector.WherePasses(filter).OfClass(typeof(Wall)).ToElements();

// Find all walls that are not contained within active design option: use inverted filter to match elements
ElementDesignOptionFilter notActiveOptFilter = new ElementDesignOptionFilter(activeOptId, true); // inverted filter
collector = new FilteredElementCollector(document);
ICollection<Element> notActiveOptWalls =
    collector.WherePasses(notActiveOptFilter).OfClass(typeof(Wall)).ToElements();
CopyVB.NET
' Create an ElementDesignOption filter to find all walls in the active design option.
' Note that if no design option is being edited, GetActiveDesignOptionId() method will return ElementId.InvalidElementId,
' ElementDesignOptionFilter with invalid id will filter elements not associated to a design option
Dim activeOptId As ElementId = Autodesk.Revit.DB.DesignOption.GetActiveDesignOptionId(document)

' Create an ElementDesignOption filter
Dim filter As New ElementDesignOptionFilter(activeOptId)

' Apply the filter to the elements in the active document,
' use shortcut method OfClass() to find Walls only
Dim collector As New FilteredElementCollector(document)
Dim wallsOfDesignOpt As ICollection(Of Element) = collector.WherePasses(filter).OfClass(GetType(Wall)).ToElements()

' Find all walls that are not contained within active design option: use inverted filter to match elements
Dim notActiveOptFilter As New ElementDesignOptionFilter(activeOptId, True)
' inverted filter
collector = New FilteredElementCollector(document)
Dim notActiveOptWalls As ICollection(Of Element) = collector.WherePasses(notActiveOptFilter).OfClass(GetType(Wall)).ToElements()

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementQuickFilter
Autodesk.Revit.DB..::..ElementDesignOptionFilter

See Also

ElementDesignOptionFilter Members


ElementDesignOptionFilter Members

[image] [image]

Revit 2024 API
ElementDesignOptionFilter Members
ElementDesignOptionFilter Class Constructors Methods Properties See Also Send Feedback

The ElementDesignOptionFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ElementDesignOptionFilter(ElementId) | Constructs a new instance of a filter to match elements contained within a particular design option.
Public method | ElementDesignOptionFilter(ElementId, Boolean) | Constructs a new instance of a filter to match elements contained within a particular design option, with the option to invert the filter and find elements not contained within a particular design option.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DesignOptionId | The design option id.
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)

See Also

ElementDesignOptionFilter Class


ElementDesignOptionFilter Constructor

[image] [image]

Revit 2024 API
ElementDesignOptionFilter Constructor
ElementDesignOptionFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ElementDesignOptionFilter(ElementId) | Constructs a new instance of a filter to match elements contained within a particular design option.
Public method | ElementDesignOptionFilter(ElementId, Boolean) | Constructs a new instance of a filter to match elements contained within a particular design option, with the option to invert the filter and find elements not contained within a particular design option.

See Also

ElementDesignOptionFilter Class
ElementDesignOptionFilter Members


ElementDesignOptionFilter Constructor (ElementId)

[image]

Revit 2024 API
ElementDesignOptionFilter Constructor (ElementId)
ElementDesignOptionFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements contained within a particular design option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public ElementDesignOptionFilter(
    ElementId designOptionId
)
Visual Basic
Public Sub New ( _
    designOptionId As ElementId _
)
Visual C++
public:
ElementDesignOptionFilter(
    ElementId^ designOptionId
)

Parameters

designOptionId
Type: Autodesk.Revit.DB..::..ElementId
The design option id to match.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ElementDesignOptionFilter Class
ElementDesignOptionFilter Overload


ElementDesignOptionFilter Constructor (ElementId, Boolean)

[image]

Revit 2024 API
ElementDesignOptionFilter Constructor (ElementId, Boolean)
ElementDesignOptionFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements contained within a particular design option, with the option to invert the filter and find elements not contained within a particular design option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public ElementDesignOptionFilter(
    ElementId designOptionId,
    bool inverted
)
Visual Basic
Public Sub New ( _
    designOptionId As ElementId, _
    inverted As Boolean _
)
Visual C++
public:
ElementDesignOptionFilter(
    ElementId^ designOptionId,
    bool inverted
)

Parameters

designOptionId
Type: Autodesk.Revit.DB..::..ElementId
The design option id to match.
inverted
Type: System..::..Boolean
True if the filter should match all elements which are not contained within a particular design option.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ElementDesignOptionFilter Class
ElementDesignOptionFilter Overload


ElementDesignOptionFilter Methods

[image] [image]

Revit 2024 API
ElementDesignOptionFilter Methods
ElementDesignOptionFilter Class See Also Send Feedback

The ElementDesignOptionFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ElementDesignOptionFilter Class


PassesFilter Method

[image] [image]

Revit 2024 API
ElementDesignOptionFilter..::..PassesFilter Method
ElementDesignOptionFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

ElementDesignOptionFilter Class
ElementDesignOptionFilter Members


ElementDesignOptionFilter Properties

[image] [image]

Revit 2024 API
ElementDesignOptionFilter Properties
ElementDesignOptionFilter Class See Also Send Feedback

The ElementDesignOptionFilter type exposes the following members.

Properties

 | Name | Description
Public property | DesignOptionId | The design option id.
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)

See Also

ElementDesignOptionFilter Class


DesignOptionId Property

[image]

Revit 2024 API
ElementDesignOptionFilter..::..DesignOptionId Property
ElementDesignOptionFilter Class See Also Send Feedback
The design option id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public ElementId DesignOptionId { get; }
Visual Basic
Public ReadOnly Property DesignOptionId As ElementId
    Get
Visual C++
public:
property ElementId^ DesignOptionId {
    ElementId^ get ();
}

See Also

ElementDesignOptionFilter Class


ElementFilter Class

[image]

Revit 2024 API
ElementFilter Class
Members See Also Send Feedback
A base class for a type of filter that accepts or rejects elements based upon criteria.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class ElementFilter : IDisposable
Visual Basic
Public Class ElementFilter _
    Implements IDisposable
Visual C++
public ref class ElementFilter : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementLogicalFilter
Autodesk.Revit.DB..::..ElementQuickFilter
Autodesk.Revit.DB..::..ElementSlowFilter

See Also

ElementFilter Members


ElementFilter Members

[image] [image]

Revit 2024 API
ElementFilter Members
ElementFilter Class Methods Properties See Also Send Feedback

The ElementFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ElementFilter
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element.
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ElementFilter Class


ElementFilter Methods

[image] [image]

Revit 2024 API
ElementFilter Methods
ElementFilter Class See Also Send Feedback

The ElementFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element.
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ElementFilter Class


Dispose Method

[image]

Revit 2024 API
ElementFilter..::..Dispose Method
ElementFilter Class See Also Send Feedback
Releases all resources used by the ElementFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ElementFilter Class


PassesFilter Method

[image] [image]

Revit 2024 API
ElementFilter..::..PassesFilter Method
ElementFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element.
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element.

See Also

ElementFilter Class
ElementFilter Members


PassesFilter Method (Element)

[image]

Revit 2024 API
ElementFilter..::..PassesFilter Method (Element)
ElementFilter Class See Also Send Feedback
Applies the filter to a given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool PassesFilter(
    Element element
)
Visual Basic
Public Function PassesFilter ( _
    element As Element _
) As Boolean
Visual C++
public:
bool PassesFilter(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The element.

Return Value

True if the element is accepted by the filter. False if the element is rejected.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ElementFilter Class
PassesFilter Overload


PassesFilter Method (Document, ElementId)

[image]

Revit 2024 API
ElementFilter..::..PassesFilter Method (Document, ElementId)
ElementFilter Class See Also Send Feedback
Applies the filter to a given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool PassesFilter(
    Document document,
    ElementId id
)
Visual Basic
Public Function PassesFilter ( _
    document As Document, _
    id As ElementId _
) As Boolean
Visual C++
public:
bool PassesFilter(
    Document^ document,
    ElementId^ id
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
id
Type: Autodesk.Revit.DB..::..ElementId
The element id.

Return Value

True if the element is accepted by the filter. False if the element is rejected.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ElementFilter Class
PassesFilter Overload


ElementFilter Properties

[image] [image]

Revit 2024 API
ElementFilter Properties
ElementFilter Class See Also Send Feedback

The ElementFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ElementFilter Class


IsValidObject Property

[image]

Revit 2024 API
ElementFilter..::..IsValidObject Property
ElementFilter Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ElementFilter Class


ElementId Class

[image]

Revit 2024 API
ElementId Class
Members See Also Send Feedback
The ElementId object is used as a unique identification for an element within a single project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class ElementId
Visual Basic
Public Class ElementId
Visual C++
public ref class ElementId

Remarks

The Value within the ElementId is only unique with a single project. It is not unique across several projects. The Id can be used to retrieve a specific element from the database when needed. However ids are subject to change during an Autodesk Revit session and as such should not be retained and used across repeated calls to external commands. If a manner is needed to uniquely identify an element beyond this limitation then a shared parameter should be added to the element containing a unique identifier managed by the external application.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementId

See Also

ElementId Members


ElementId Members

[image] [image]

Revit 2024 API
ElementId Members
ElementId Class Constructors Methods Operators Properties See Also Send Feedback

The ElementId type exposes the following members.

Constructors

 | Name | Description
Public method | ElementId(Int32) | Obsolete. Create an ElementId handle with the given 32-bit integer id.
Public method | ElementId(Int64) | Create an ElementId handle with the given 64-bit integer id.
Public method | ElementId(BuiltInCategory) | Create an ElementId handle with the given BuiltInCategory id.
Public method | ElementId(BuiltInParameter) | Create an ElementId handle with the given BuiltInParameter id.

Methods

 | Name | Description
Public method | Compare | Compares two element ids.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | GetHashCode | Gets the value of the id as hash code (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Parse | Parse the string representation of the id into a corresponding ElementId.
Public method | ToString | Gets a String representation of the value of the id. (Overrides Object..::..ToString()()()().)
 | TryParse | Parse the string representation of the id into a corresponding ElementId.

Operators

Name | Description
Equality | Determines whether these two ElementIds are the same.
GreaterThan | Determines whether one element id is greater than another element id.
GreaterThanOrEqual | Determines whether one element id is not less than another element id.
Inequality | Determines whether these two ElementIds are different.
LessThan | Determines whether this element id is less than another element id.
LessThanOrEqual | Determines whether one element id is not greater than another element id.

Properties

 | Name | Description
Public property | IntegerValue | Obsolete. Provides the value of the element id as a 32-bit integer.
 | InvalidElementId | Get the invalid ElementId whose value is -1.
Public property | Value | Provides the value of the element id as a 64-bit integer.

See Also

ElementId Class


ElementId Constructor (Int32)

[image]

Revit 2024 API
ElementId Constructor (Int32)
ElementId Class See Also Send Feedback
Create an ElementId handle with the given 32-bit integer id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
[ObsoleteAttribute("This constructor is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use the ElementId(Int64 id) constructor instead.")]
public ElementId(
    int id
)
Visual Basic
<ObsoleteAttribute("This constructor is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use the ElementId(Int64 id) constructor instead.")> _
Public Sub New ( _
    id As Integer _
)
Visual C++
[ObsoleteAttribute(L"This constructor is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use the ElementId(Int64 id) constructor instead.")]
public:
ElementId(
    int id
)

Parameters

id
Type: System..::..Int32
The id.

See Also

ElementId Class
ElementId Overload


ElementId Constructor (Int64)

[image]

Revit 2024 API
ElementId Constructor (Int64)
ElementId Class See Also Send Feedback
Create an ElementId handle with the given 64-bit integer id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public ElementId(
    long id
)
Visual Basic
Public Sub New ( _
    id As Long _
)
Visual C++
public:
ElementId(
    long long id
)

Parameters

id
Type: System..::..Int64
The id.

See Also

ElementId Class
ElementId Overload


ElementId Constructor (BuiltInCategory)

[image]

Revit 2024 API
ElementId Constructor (BuiltInCategory)
ElementId Class See Also Send Feedback
Create an ElementId handle with the given BuiltInCategory id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElementId(
    BuiltInCategory categoryId
)
Visual Basic
Public Sub New ( _
    categoryId As BuiltInCategory _
)
Visual C++
public:
ElementId(
    BuiltInCategory categoryId
)

Parameters

categoryId
Type: Autodesk.Revit.DB..::..BuiltInCategory
The id.

See Also

ElementId Class
ElementId Overload


ElementId Methods

[image] [image]

Revit 2024 API
ElementId Methods
ElementId Class See Also Send Feedback

The ElementId type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two element ids.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | GetHashCode | Gets the value of the id as hash code (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Parse | Parse the string representation of the id into a corresponding ElementId.
Public method | ToString | Gets a String representation of the value of the id. (Overrides Object..::..ToString()()()().)
 | TryParse | Parse the string representation of the id into a corresponding ElementId.

See Also

ElementId Class


Compare Method

[image]

Revit 2024 API
ElementId..::..Compare Method
ElementId Class See Also Send Feedback
Compares two element ids.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public int Compare(
    ElementId id
)
Visual Basic
Public Function Compare ( _
    id As ElementId _
) As Integer
Visual C++
public:
int Compare(
    ElementId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::..ElementId
The ElementId to be compared with this ElementId.

Return Value

-1 if this element id is less than id, 0 if equal, 1 if greater.

See Also

ElementId Class


Equals Method

[image]

Revit 2024 API
ElementId..::..Equals Method
ElementId Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
Another object.

See Also

ElementId Class


GetHashCode Method

[image]

Revit 2024 API
ElementId..::..GetHashCode Method
ElementId Class See Also Send Feedback
Gets the value of the id as hash code

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

ElementId Class


Parse Method

[image]

Revit 2024 API
ElementId..::..Parse Method
ElementId Class See Also Send Feedback
Parse the string representation of the id into a corresponding ElementId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public static ElementId Parse(
    string idStr
)
Visual Basic
Public Shared Function Parse ( _
    idStr As String _
) As ElementId
Visual C++
public:
static ElementId^ Parse(
    String^ idStr
)

Parameters

idStr
Type: System..::..String
The string representation of the id to return.

Return Value

ElementId string represented.

Remarks

If the string represents [!:Autodesk::Revit::DB::Element::InvalidElementId] it will be returned.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the string cannot be parsed into an ElementId.

See Also

ElementId Class


TryParse Method

[image]

Revit 2024 API
ElementId..::..TryParse Method
ElementId Class See Also Send Feedback
Parse the string representation of the id into a corresponding ElementId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public static bool TryParse(
    string idStr,
    out ElementId id
)
Visual Basic
Public Shared Function TryParse ( _
    idStr As String, _
    <OutAttribute> ByRef id As ElementId _
) As Boolean
Visual C++
public:
static bool TryParse(
    String^ idStr,
    [OutAttribute] ElementId^% id
)

Parameters

idStr
Type: System..::..String
The string representation of the id to return.
id
Type: Autodesk.Revit.DB..::..ElementId %
Out parameter set to the ElementId represented by the string.

Return Value

true if the string was successfully parsed into an ElementId, false otherwise.

Remarks

If the string represents [!:Autodesk::Revit::DB::Element::InvalidElementId] the id will contain it upon return. If the parse fails, the id will be undefined.

See Also

ElementId Class


ElementId Operators

[image] [image]

Revit 2024 API
ElementId Operators
ElementId Class See Also Send Feedback

The ElementId type exposes the following members.

Operators

Name | Description
Equality | Determines whether these two ElementIds are the same.
GreaterThan | Determines whether one element id is greater than another element id.
GreaterThanOrEqual | Determines whether one element id is not less than another element id.
Inequality | Determines whether these two ElementIds are different.
LessThan | Determines whether this element id is less than another element id.
LessThanOrEqual | Determines whether one element id is not greater than another element id.

See Also

ElementId Class


Equality Operator

[image]

Revit 2024 API
ElementId..::..Equality Operator
ElementId Class See Also Send Feedback
Determines whether these two ElementIds are the same.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static bool operator ==(
    ElementId first,
    ElementId second
)
Visual Basic
Public Shared Operator = ( _
    first As ElementId, _
    second As ElementId _
) As Boolean
Visual C++
public:
static bool operator ==(
    ElementId^ first,
    ElementId^ second
)

Parameters

first
Type: Autodesk.Revit.DB..::..ElementId
The first ElementId.
second
Type: Autodesk.Revit.DB..::..ElementId
The second ElementId.

Return Value

True if the ElementIds are the same; otherwise, false.

See Also

ElementId Class


GreaterThan Operator

[image]

Revit 2024 API
ElementId..::..GreaterThan Operator
ElementId Class See Also Send Feedback
Determines whether one element id is greater than another element id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static bool operator >(
    ElementId elementId1,
    ElementId elementId2
)
Visual Basic
Public Shared Operator > ( _
    elementId1 As ElementId, _
    elementId2 As ElementId _
) As Boolean
Visual C++
public:
static bool operator >(
    ElementId^ elementId1,
    ElementId^ elementId2
)

Parameters

elementId1
Type: Autodesk.Revit.DB..::..ElementId
The first ElementId.
elementId2
Type: Autodesk.Revit.DB..::..ElementId
The second ElementId.

Return Value

True if the first element id is greater than the second element id, otherwise, false.

See Also

ElementId Class


GreaterThanOrEqual Operator

[image]

Revit 2024 API
ElementId..::..GreaterThanOrEqual Operator
ElementId Class See Also Send Feedback
Determines whether one element id is not less than another element id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static bool operator >=(
    ElementId elementId1,
    ElementId elementId2
)
Visual Basic
Public Shared Operator >= ( _
    elementId1 As ElementId, _
    elementId2 As ElementId _
) As Boolean
Visual C++
public:
static bool operator >=(
    ElementId^ elementId1,
    ElementId^ elementId2
)

Parameters

elementId1
Type: Autodesk.Revit.DB..::..ElementId
The first ElementId.
elementId2
Type: Autodesk.Revit.DB..::..ElementId
The second ElementId.

Return Value

True if the first element id is not less than the second element id, otherwise, false.

See Also

ElementId Class


Inequality Operator

[image]

Revit 2024 API
ElementId..::..Inequality Operator
ElementId Class See Also Send Feedback
Determines whether these two ElementIds are different.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static bool operator !=(
    ElementId first,
    ElementId second
)
Visual Basic
Public Shared Operator <> ( _
    first As ElementId, _
    second As ElementId _
) As Boolean
Visual C++
public:
static bool operator !=(
    ElementId^ first,
    ElementId^ second
)

Parameters

first
Type: Autodesk.Revit.DB..::..ElementId
The first ElementId.
second
Type: Autodesk.Revit.DB..::..ElementId
The second ElementId.

Return Value

True if the ElementIds are different; otherwise, false.

See Also

ElementId Class


LessThan Operator

[image]

Revit 2024 API
ElementId..::..LessThan Operator
ElementId Class See Also Send Feedback
Determines whether this element id is less than another element id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static bool operator <(
    ElementId elementId1,
    ElementId elementId2
)
Visual Basic
Public Shared Operator < ( _
    elementId1 As ElementId, _
    elementId2 As ElementId _
) As Boolean
Visual C++
public:
static bool operator <(
    ElementId^ elementId1,
    ElementId^ elementId2
)

Parameters

elementId1
Type: Autodesk.Revit.DB..::..ElementId
The first ElementId.
elementId2
Type: Autodesk.Revit.DB..::..ElementId
The second ElementId.

Return Value

True if the first element id is less than the second element id, otherwise, false.

See Also

ElementId Class


LessThanOrEqual Operator

[image]

Revit 2024 API
ElementId..::..LessThanOrEqual Operator
ElementId Class See Also Send Feedback
Determines whether one element id is not greater than another element id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static bool operator <=(
    ElementId elementId1,
    ElementId elementId2
)
Visual Basic
Public Shared Operator <= ( _
    elementId1 As ElementId, _
    elementId2 As ElementId _
) As Boolean
Visual C++
public:
static bool operator <=(
    ElementId^ elementId1,
    ElementId^ elementId2
)

Parameters

elementId1
Type: Autodesk.Revit.DB..::..ElementId
The first ElementId.
elementId2
Type: Autodesk.Revit.DB..::..ElementId
The second ElementId.

Return Value

True if the first element id is not greater than the second element id, otherwise, false.

See Also

ElementId Class


ElementId Properties

[image] [image]

Revit 2024 API
ElementId Properties
ElementId Class See Also Send Feedback

The ElementId type exposes the following members.

Properties

 | Name | Description
Public property | IntegerValue | Obsolete. Provides the value of the element id as a 32-bit integer.
 | InvalidElementId | Get the invalid ElementId whose value is -1.
Public property | Value | Provides the value of the element id as a 64-bit integer.

See Also

ElementId Class


InvalidElementId Property

[image]

Revit 2024 API
ElementId..::..InvalidElementId Property
ElementId Class See Also Send Feedback
Get the invalid ElementId whose value is -1.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ElementId InvalidElementId { get; }
Visual Basic
Public Shared ReadOnly Property InvalidElementId As ElementId
    Get
Visual C++
public:
static property ElementId^ InvalidElementId {
    ElementId^ get ();
}

See Also

ElementId Class


Value Property

[image]

Revit 2024 API
ElementId..::..Value Property
ElementId Class See Also Send Feedback
Provides the value of the element id as a 64-bit integer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public long Value { get; }
Visual Basic
Public ReadOnly Property Value As Long
    Get
Visual C++
public:
property long long Value {
    long long get ();
}

See Also

ElementId Class


ElementIdParameterValue Class

[image]

Revit 2024 API
ElementIdParameterValue Class
Members See Also Send Feedback
A class that holds a ElementId value of a parameter element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Update

Syntax

C#
public class ElementIdParameterValue : ParameterValue
Visual Basic
Public Class ElementIdParameterValue _
    Inherits ParameterValue
Visual C++
public ref class ElementIdParameterValue : public ParameterValue

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ParameterValue
Autodesk.Revit.DB..::..ElementIdParameterValue

See Also

ElementIdParameterValue Members


ElementIdParameterValue Members

[image] [image]

Revit 2024 API
ElementIdParameterValue Members
ElementIdParameterValue Class Constructors Methods Properties See Also Send Feedback

The ElementIdParameterValue type exposes the following members.

Constructors

 | Name | Description
Public method | ElementIdParameterValue()()()() | Default constructor
Public method | ElementIdParameterValue(ElementId) | Value constructor

Methods

 | Name | Description
Public method | Copy | Makes an identical copy of the given parameter value. (Inherited from ParameterValue.)
Public method | Dispose | (Inherited from ParameterValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Tests equality with another instance of the same class. (Inherited from ParameterValue.)
Public method | IsSameType | Tests another instance is of the same value type. (Inherited from ParameterValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ParameterValue.)
Public property | Value | The stored value

See Also

ElementIdParameterValue Class


ElementIdParameterValue Constructor

[image] [image]

Revit 2024 API
ElementIdParameterValue Constructor
ElementIdParameterValue Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ElementIdParameterValue()()()() | Default constructor
Public method | ElementIdParameterValue(ElementId) | Value constructor

See Also

ElementIdParameterValue Class
ElementIdParameterValue Members


ElementIdParameterValue Constructor

[image]

Revit 2024 API
ElementIdParameterValue Constructor
ElementIdParameterValue Class See Also Send Feedback
Default constructor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Update

Syntax

C#
public ElementIdParameterValue()
Visual Basic
Public Sub New
Visual C++
public:
ElementIdParameterValue()

See Also

ElementIdParameterValue Class
ElementIdParameterValue Overload


ElementIdParameterValue Constructor (ElementId)

[image]

Revit 2024 API
ElementIdParameterValue Constructor (ElementId)
ElementIdParameterValue Class See Also Send Feedback
Value constructor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Update

Syntax

C#
public ElementIdParameterValue(
    ElementId value
)
Visual Basic
Public Sub New ( _
    value As ElementId _
)
Visual C++
public:
ElementIdParameterValue(
    ElementId^ value
)

Parameters

value
Type: Autodesk.Revit.DB..::..ElementId

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ElementIdParameterValue Class
ElementIdParameterValue Overload


ElementIdParameterValue Methods

[image] [image]

Revit 2024 API
ElementIdParameterValue Methods
ElementIdParameterValue Class See Also Send Feedback

The ElementIdParameterValue type exposes the following members.

Methods

 | Name | Description
Public method | Copy | Makes an identical copy of the given parameter value. (Inherited from ParameterValue.)
Public method | Dispose | (Inherited from ParameterValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Tests equality with another instance of the same class. (Inherited from ParameterValue.)
Public method | IsSameType | Tests another instance is of the same value type. (Inherited from ParameterValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ElementIdParameterValue Class


ElementIdParameterValue Properties

[image] [image]

Revit 2024 API
ElementIdParameterValue Properties
ElementIdParameterValue Class See Also Send Feedback

The ElementIdParameterValue type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ParameterValue.)
Public property | Value | The stored value

See Also

ElementIdParameterValue Class


Value Property

[image]

Revit 2024 API
ElementIdParameterValue..::..Value Property
ElementIdParameterValue Class See Also Send Feedback
The stored value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Update

Syntax

C#
public ElementId Value { get; set; }
Visual Basic
Public Property Value As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ Value {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ElementIdParameterValue Class


ElementIdSetFilter Class

[image]

Revit 2024 API
ElementIdSetFilter Class
Members See Also Send Feedback
A filter wrapping a set of elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public class ElementIdSetFilter : ElementQuickFilter
Visual Basic
Public Class ElementIdSetFilter _
    Inherits ElementQuickFilter
Visual C++
public ref class ElementIdSetFilter : public ElementQuickFilter

Remarks

This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementQuickFilter
Autodesk.Revit.DB..::..ElementIdSetFilter

See Also

ElementIdSetFilter Members


ElementIdSetFilter Members

[image] [image]

Revit 2024 API
ElementIdSetFilter Members
ElementIdSetFilter Class Constructors Methods Properties See Also Send Feedback

The ElementIdSetFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ElementIdSetFilter | Constructs a new instance of a filter wrapping a set of elements.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIdsToInclude | Returns the ids of this filter.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)

See Also

ElementIdSetFilter Class


ElementIdSetFilter Constructor

[image]

Revit 2024 API
ElementIdSetFilter Constructor
ElementIdSetFilter Class See Also Send Feedback
Constructs a new instance of a filter wrapping a set of elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public ElementIdSetFilter(
    ICollection<ElementId> idsToInclude
)
Visual Basic
Public Sub New ( _
    idsToInclude As ICollection(Of ElementId) _
)
Visual C++
public:
ElementIdSetFilter(
    ICollection<ElementId^>^ idsToInclude
)

Parameters

idsToInclude
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
The ids.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input collection of ids was empty, or its contents were not valid for iteration.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ElementIdSetFilter Class


ElementIdSetFilter Methods

[image] [image]

Revit 2024 API
ElementIdSetFilter Methods
ElementIdSetFilter Class See Also Send Feedback

The ElementIdSetFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIdsToInclude | Returns the ids of this filter.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ElementIdSetFilter Class


PassesFilter Method

[image] [image]

Revit 2024 API
ElementIdSetFilter..::..PassesFilter Method
ElementIdSetFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

ElementIdSetFilter Class
ElementIdSetFilter Members


ElementIdSetFilter Properties

[image] [image]

Revit 2024 API
ElementIdSetFilter Properties
ElementIdSetFilter Class See Also Send Feedback

The ElementIdSetFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)

See Also

ElementIdSetFilter Class


ElementIntersectsElementFilter Class

[image]

Revit 2024 API
ElementIntersectsElementFilter Class
Members See Also Send Feedback
A filter to find elements that intersect the solid geometry of a given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public class ElementIntersectsElementFilter : ElementIntersectsFilter
Visual Basic
Public Class ElementIntersectsElementFilter _
    Inherits ElementIntersectsFilter
Visual C++
public ref class ElementIntersectsElementFilter : public ElementIntersectsFilter

Remarks

The target object is another element. The intersection is determined with the same logic used by Revit to determine if an interference exists during generation of an Interference Report. (This means that some combinations of elements will never be detected as intersecting by this filter, such as concrete members which are automatically joined at their intersections). Also, elements which have no solid geometry, such as Rebar, will never be detected as intersecting by this filter.

This filter is a slow filter. Slow filters require that the Element be obtained and expanded in memory first. Thus it is preferable to couple this filter with at least one ElementQuickFilter, which should minimize the number of Elements that are expanded.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementSlowFilter
Autodesk.Revit.DB..::..ElementIntersectsFilter
Autodesk.Revit.DB..::..ElementIntersectsElementFilter

See Also

ElementIntersectsElementFilter Members


ElementIntersectsElementFilter Members

[image] [image]

Revit 2024 API
ElementIntersectsElementFilter Members
ElementIntersectsElementFilter Class Constructors Methods Properties See Also Send Feedback

The ElementIntersectsElementFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ElementIntersectsElementFilter(Element) | Constructs a filter to match elements which intersect the given element.
Public method | ElementIntersectsElementFilter(Element, Boolean) | Constructs a filter to match elements which intersect the given element, with the option to match all elements not intersecting the given element.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetElement | Gets the target element.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)

See Also

ElementIntersectsElementFilter Class


ElementIntersectsElementFilter Constructor

[image] [image]

Revit 2024 API
ElementIntersectsElementFilter Constructor
ElementIntersectsElementFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ElementIntersectsElementFilter(Element) | Constructs a filter to match elements which intersect the given element.
Public method | ElementIntersectsElementFilter(Element, Boolean) | Constructs a filter to match elements which intersect the given element, with the option to match all elements not intersecting the given element.

See Also

ElementIntersectsElementFilter Class
ElementIntersectsElementFilter Members


ElementIntersectsElementFilter Constructor (Element)

[image]

Revit 2024 API
ElementIntersectsElementFilter Constructor (Element)
ElementIntersectsElementFilter Class See Also Send Feedback
Constructs a filter to match elements which intersect the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public ElementIntersectsElementFilter(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
ElementIntersectsElementFilter(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The element to check for intersection.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The category of the element is not supported for element intersection filters. -or- The element is not supported for element intersection filters.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ElementIntersectsElementFilter Class
ElementIntersectsElementFilter Overload


ElementIntersectsElementFilter Methods

[image] [image]

Revit 2024 API
ElementIntersectsElementFilter Methods
ElementIntersectsElementFilter Class See Also Send Feedback

The ElementIntersectsElementFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetElement | Gets the target element.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ElementIntersectsElementFilter Class


GetElement Method

[image]

Revit 2024 API
ElementIntersectsElementFilter..::..GetElement Method
ElementIntersectsElementFilter Class See Also Send Feedback
Gets the target element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public Element GetElement()
Visual Basic
Public Function GetElement As Element
Visual C++
public:
Element^ GetElement()

Return Value

The element.

See Also

ElementIntersectsElementFilter Class


PassesFilter Method

[image] [image]

Revit 2024 API
ElementIntersectsElementFilter..::..PassesFilter Method
ElementIntersectsElementFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

ElementIntersectsElementFilter Class
ElementIntersectsElementFilter Members


ElementIntersectsElementFilter Properties

[image] [image]

Revit 2024 API
ElementIntersectsElementFilter Properties
ElementIntersectsElementFilter Class See Also Send Feedback

The ElementIntersectsElementFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)

See Also

ElementIntersectsElementFilter Class


ElementIntersectsFilter Class

[image]

Revit 2024 API
ElementIntersectsFilter Class
Members See Also Send Feedback
A base class for filters used to match elements which intersect with geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public class ElementIntersectsFilter : ElementSlowFilter
Visual Basic
Public Class ElementIntersectsFilter _
    Inherits ElementSlowFilter
Visual C++
public ref class ElementIntersectsFilter : public ElementSlowFilter

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementSlowFilter
Autodesk.Revit.DB..::..ElementIntersectsFilter
Autodesk.Revit.DB..::..ElementIntersectsElementFilter
Autodesk.Revit.DB..::..ElementIntersectsSolidFilter

See Also

ElementIntersectsFilter Members


ElementIntersectsFilter Methods

[image] [image]

Revit 2024 API
ElementIntersectsFilter Methods
ElementIntersectsFilter Class See Also Send Feedback

The ElementIntersectsFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsCategorySupported | Identifies if the input element is of a category supported by element intersection filters.
 | IsElementSupported | Identifies if the input element is supported by element intersection filters.
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ElementIntersectsFilter Class


IsCategorySupported Method

[image]

Revit 2024 API
ElementIntersectsFilter..::..IsCategorySupported Method
ElementIntersectsFilter Class See Also Send Feedback
Identifies if the input element is of a category supported by element intersection filters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static bool IsCategorySupported(
    Element element
)
Visual Basic
Public Shared Function IsCategorySupported ( _
    element As Element _
) As Boolean
Visual C++
public:
static bool IsCategorySupported(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The element.

Return Value

True if the element category is supported, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ElementIntersectsFilter Class


PassesFilter Method

[image] [image]

Revit 2024 API
ElementIntersectsFilter..::..PassesFilter Method
ElementIntersectsFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

ElementIntersectsFilter Class
ElementIntersectsFilter Members


ElementIntersectsFilter Properties

[image] [image]

Revit 2024 API
ElementIntersectsFilter Properties
ElementIntersectsFilter Class See Also Send Feedback

The ElementIntersectsFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)

See Also

ElementIntersectsFilter Class


ElementIntersectsSolidFilter Class

[image]

Revit 2024 API
ElementIntersectsSolidFilter Class
Members Example See Also Send Feedback
A filter to find elements that intersect the given solid geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public class ElementIntersectsSolidFilter : ElementIntersectsFilter
Visual Basic
Public Class ElementIntersectsSolidFilter _
    Inherits ElementIntersectsFilter
Visual C++
public ref class ElementIntersectsSolidFilter : public ElementIntersectsFilter

Remarks

The input solid used for this filter can be obtained from an existing element, created from scratch using the routines in GeometryCreationUtilities or builder classes, or the generated from the result of a secondary operation such as a Boolean operation. Similar to the ElementIntersectsElementFilter, this filter will not detect as intersecting elements which lack solid geometry, such as Rebar.

This filter is a slow filter. Slow filters require that the Element be obtained and expanded in memory first. Thus it is preferable to couple this filter with at least one ElementQuickFilter, which should minimize the number of Elements that are expanded.

Examples

CopyC#
// Find intersections between family instances and a selected element
Reference reference = uidoc.Selection.PickObject(ObjectType.Element, "Select element that will be checked for intersection with all family instances");
Element element = doc.GetElement(reference);
GeometryElement geomElement = element.get_Geometry(new Options());
Solid solid = null;
foreach (GeometryObject geomObj in geomElement)
{
    solid = geomObj as Solid;
    if (solid != null) break;
}

FilteredElementCollector collector = new FilteredElementCollector(doc);
collector.OfClass(typeof(FamilyInstance));
collector.WherePasses(new ElementIntersectsSolidFilter(solid)); // Apply intersection filter to find matches

TaskDialog.Show("Revit", collector.Count() + " family instances intersect with the selected element (" + element.Category.Name + " id:" + element.Id.ToString() + ")");
CopyC#
// Find intersections between family instances and a selected element
Reference reference = uidoc.Selection.PickObject(ObjectType.Element, "Select element that will be checked for intersection with all family instances");
Element element = doc.GetElement(reference);
GeometryElement geomElement = element.get_Geometry(new Options());
Solid solid = null;
foreach (GeometryObject geomObj in geomElement)
{
    solid = geomObj as Solid;
    if (solid != null) break;
}

FilteredElementCollector collector = new FilteredElementCollector(doc);
collector.OfClass(typeof(FamilyInstance));
collector.WherePasses(new ElementIntersectsSolidFilter(solid)); // Apply intersection filter to find matches

TaskDialog.Show("Revit", collector.Count() + " family instances intersect with the selected element (" + element.Category.Name + " id:" + element.Id.ToString() + ")");
CopyVB.NET
' Find intersections between family instances and a selected element
Dim reference As Reference = uidoc.Selection.PickObject(ObjectType.Element, "Select element that will be checked for intersection with all family instances")
Dim element As Element = doc.GetElement(reference)
Dim geomElement As GeometryElement = element.Geometry(New Options())
Dim solid As Solid = Nothing
For Each geomObj As GeometryObject In geomElement
    solid = TryCast(geomObj, Solid)
    If solid IsNot Nothing Then
        Exit For
    End If
Next

Dim collector As New FilteredElementCollector(doc)
collector.OfClass(GetType(FamilyInstance))
collector.WherePasses(New ElementIntersectsSolidFilter(solid))
' Apply intersection filter to find matches
TaskDialog.Show("Revit", collector.Count() + " family instances intersect with the selected element (" + element.Category.Name + " id:" + element.Id.ToString() + ")")
CopyVB.NET
' Find intersections between family instances and a selected element
Dim reference As Reference = uidoc.Selection.PickObject(ObjectType.Element, "Select element that will be checked for intersection with all family instances")
Dim element As Element = doc.GetElement(reference)
Dim geomElement As GeometryElement = element.Geometry(New Options())
Dim solid As Solid = Nothing
For Each geomObj As GeometryObject In geomElement
    solid = TryCast(geomObj, Solid)
    If solid IsNot Nothing Then
        Exit For
    End If
Next

Dim collector As New FilteredElementCollector(doc)
collector.OfClass(GetType(FamilyInstance))
collector.WherePasses(New ElementIntersectsSolidFilter(solid))
' Apply intersection filter to find matches
TaskDialog.Show("Revit", collector.Count() + " family instances intersect with the selected element (" + element.Category.Name + " id:" + element.Id.ToString() + ")")

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementSlowFilter
Autodesk.Revit.DB..::..ElementIntersectsFilter
Autodesk.Revit.DB..::..ElementIntersectsSolidFilter

See Also

ElementIntersectsSolidFilter Members


ElementIntersectsSolidFilter Members

[image] [image]

Revit 2024 API
ElementIntersectsSolidFilter Members
ElementIntersectsSolidFilter Class Constructors Methods Properties See Also Send Feedback

The ElementIntersectsSolidFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ElementIntersectsSolidFilter(Solid) | Constructs a filter to match elements which intersect the given element.
Public method | ElementIntersectsSolidFilter(Solid, Boolean) | Constructs a filter to match elements which intersect the given element, with the option to match all elements not intersecting the given element.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSolid | Gets the target solid geometry.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)

See Also

ElementIntersectsSolidFilter Class


ElementIntersectsSolidFilter Constructor (Solid)

[image]

Revit 2024 API
ElementIntersectsSolidFilter Constructor (Solid)
ElementIntersectsSolidFilter Class See Also Send Feedback
Constructs a filter to match elements which intersect the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public ElementIntersectsSolidFilter(
    Solid solid
)
Visual Basic
Public Sub New ( _
    solid As Solid _
)
Visual C++
public:
ElementIntersectsSolidFilter(
    Solid^ solid
)

Parameters

solid
Type: Autodesk.Revit.DB..::..Solid
The solid geometry to check for intersection.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ElementIntersectsSolidFilter Class
ElementIntersectsSolidFilter Overload


ElementIntersectsSolidFilter Methods

[image] [image]

Revit 2024 API
ElementIntersectsSolidFilter Methods
ElementIntersectsSolidFilter Class See Also Send Feedback

The ElementIntersectsSolidFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSolid | Gets the target solid geometry.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ElementIntersectsSolidFilter Class


GetSolid Method

[image]

Revit 2024 API
ElementIntersectsSolidFilter..::..GetSolid Method
ElementIntersectsSolidFilter Class See Also Send Feedback
Gets the target solid geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public Solid GetSolid()
Visual Basic
Public Function GetSolid As Solid
Visual C++
public:
Solid^ GetSolid()

Return Value

The solid geometry.

See Also

ElementIntersectsSolidFilter Class


ElementIntersectsSolidFilter Properties

[image] [image]

Revit 2024 API
ElementIntersectsSolidFilter Properties
ElementIntersectsSolidFilter Class See Also Send Feedback

The ElementIntersectsSolidFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)

See Also

ElementIntersectsSolidFilter Class


ElementIsCurveDrivenFilter Constructor

[image] [image]

Revit 2024 API
ElementIsCurveDrivenFilter Constructor
ElementIsCurveDrivenFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ElementIsCurveDrivenFilter()()()() | Constructs a new instance of a filter to match only curve driven elements.
Public method | ElementIsCurveDrivenFilter(Boolean) | Constructs a new instance of a filter to match only curve driven elements, with the option to match all elements which are not curve driven elements.

See Also

ElementIsCurveDrivenFilter Class
ElementIsCurveDrivenFilter Members


ElementIsCurveDrivenFilter Methods

[image] [image]

Revit 2024 API
ElementIsCurveDrivenFilter Methods
ElementIsCurveDrivenFilter Class See Also Send Feedback

The ElementIsCurveDrivenFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ElementIsCurveDrivenFilter Class


PassesFilter Method

[image] [image]

Revit 2024 API
ElementIsCurveDrivenFilter..::..PassesFilter Method
ElementIsCurveDrivenFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

ElementIsCurveDrivenFilter Class
ElementIsCurveDrivenFilter Members


ElementIsCurveDrivenFilter Properties

[image] [image]

Revit 2024 API
ElementIsCurveDrivenFilter Properties
ElementIsCurveDrivenFilter Class See Also Send Feedback

The ElementIsCurveDrivenFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)

See Also

ElementIsCurveDrivenFilter Class


ElementIsElementTypeFilter Class

[image]

Revit 2024 API
ElementIsElementTypeFilter Class
Members See Also Send Feedback
A filter used to match elements which are ElementTypes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class ElementIsElementTypeFilter : ElementQuickFilter
Visual Basic
Public Class ElementIsElementTypeFilter _
    Inherits ElementQuickFilter
Visual C++
public ref class ElementIsElementTypeFilter : public ElementQuickFilter

Remarks

This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementQuickFilter
Autodesk.Revit.DB..::..ElementIsElementTypeFilter

See Also

ElementIsElementTypeFilter Members


ElementIsElementTypeFilter Members

[image] [image]

Revit 2024 API
ElementIsElementTypeFilter Members
ElementIsElementTypeFilter Class Constructors Methods Properties See Also Send Feedback

The ElementIsElementTypeFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ElementIsElementTypeFilter()()()() | Constructs a new instance of a filter to match only ElementTypes.
Public method | ElementIsElementTypeFilter(Boolean) | Constructs a new instance of a filter to match only ElementTypes, with the option to match all elements which are not ElementTypes.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)

See Also

ElementIsElementTypeFilter Class


ElementIsElementTypeFilter Constructor

[image] [image]

Revit 2024 API
ElementIsElementTypeFilter Constructor
ElementIsElementTypeFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ElementIsElementTypeFilter()()()() | Constructs a new instance of a filter to match only ElementTypes.
Public method | ElementIsElementTypeFilter(Boolean) | Constructs a new instance of a filter to match only ElementTypes, with the option to match all elements which are not ElementTypes.

See Also

ElementIsElementTypeFilter Class
ElementIsElementTypeFilter Members


ElementIsElementTypeFilter Constructor

[image]

Revit 2024 API
ElementIsElementTypeFilter Constructor
ElementIsElementTypeFilter Class See Also Send Feedback
Constructs a new instance of a filter to match only ElementTypes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public ElementIsElementTypeFilter()
Visual Basic
Public Sub New
Visual C++
public:
ElementIsElementTypeFilter()

See Also

ElementIsElementTypeFilter Class
ElementIsElementTypeFilter Overload


ElementIsElementTypeFilter Methods

[image] [image]

Revit 2024 API
ElementIsElementTypeFilter Methods
ElementIsElementTypeFilter Class See Also Send Feedback

The ElementIsElementTypeFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ElementIsElementTypeFilter Class


PassesFilter Method

[image] [image]

Revit 2024 API
ElementIsElementTypeFilter..::..PassesFilter Method
ElementIsElementTypeFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

ElementIsElementTypeFilter Class
ElementIsElementTypeFilter Members


ElementLevelFilter Class

[image]

Revit 2024 API
ElementLevelFilter Class
Members Example See Also Send Feedback
A filter used to match elements by their associated level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class ElementLevelFilter : ElementSlowFilter
Visual Basic
Public Class ElementLevelFilter _
    Inherits ElementSlowFilter
Visual C++
public ref class ElementLevelFilter : public ElementSlowFilter

Remarks

This filter is a slow filter. Slow filters require that the Element be obtained and expanded in memory first. Thus it is preferable to couple this filter with at least one ElementQuickFilter, which should minimize the number of Elements that are expanded.

Examples

CopyC#
// Use ElementLevel filter to find elements by their associated level in the document

// Find the level whose Name is "Level 1"
FilteredElementCollector collector = new FilteredElementCollector(document);
ICollection<Element> levels = collector.OfClass(typeof(Level)).ToElements();
var query = from element in collector where element.Name == "Level 1" select element;// Linq query

// Get the level id which will be used to match elements
List<Element> level1 = query.ToList<Element>();
ElementId levelId = level1[0].Id;

// Find all walls on level one
ElementLevelFilter level1Filter = new ElementLevelFilter(levelId);
collector = new FilteredElementCollector(document);
ICollection<Element> allWallsOnLevel1 = collector.OfClass(typeof(Wall)).WherePasses(level1Filter).ToElements();

// Find all rooms not on level one: use an inverted ElementLevelFilter to match all elements not on the target level
ElementLevelFilter notOnLevel1Filter = new ElementLevelFilter(levelId, true); // Inverted filter
collector = new FilteredElementCollector(document);
IList<Element> allRoomsNotOnLevel1 = collector.WherePasses(new RoomFilter()).WherePasses(notOnLevel1Filter).ToElements();
CopyVB.NET
' Use ElementLevel filter to find elements by their associated level in the document

' Find the level whose Name is "Level 1"
Dim collector As New FilteredElementCollector(document)
Dim levels As ICollection(Of Element) = collector.OfClass(GetType(Level)).ToElements()
Dim query As System.Collections.Generic.IEnumerable(Of Autodesk.Revit.DB.Element)
query = From element In collector _
 Where element.Name = "Level 1" _
 Select element

' Linq query
' Get the level id which will be used to match elements
Dim level1 As List(Of Element) = query.ToList()
Dim levelId As ElementId = level1(0).Id

' Find all walls on level one
Dim level1Filter As New ElementLevelFilter(levelId)
collector = New FilteredElementCollector(document)
Dim allWallsOnLevel1 As ICollection(Of Element) = collector.OfClass(GetType(Wall)).WherePasses(level1Filter).ToElements()

' Find all rooms not on level one: use an inverted ElementLevelFilter to match all elements not on the target level
Dim notOnLevel1Filter As New ElementLevelFilter(levelId, True)
' Inverted filter
collector = New FilteredElementCollector(document)
Dim allRoomsNotOnLevel1 As IList(Of Element) = collector.WherePasses(New RoomFilter()).WherePasses(notOnLevel1Filter).ToElements()

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementSlowFilter
Autodesk.Revit.DB..::..ElementLevelFilter

See Also

ElementLevelFilter Members


ElementLevelFilter Members

[image] [image]

Revit 2024 API
ElementLevelFilter Members
ElementLevelFilter Class Constructors Methods Properties See Also Send Feedback

The ElementLevelFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ElementLevelFilter(ElementId) | Constructs a new instance of an ElementLevelFilter.
Public method | ElementLevelFilter(ElementId, Boolean) | Constructs a new instance of an ElementLevelFilter, with the option to match all elements not associated to the given level id.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)
Public property | LevelId | The id of the level that will be matched to elements' associated level.

See Also

ElementLevelFilter Class


ElementLevelFilter Constructor (ElementId)

[image]

Revit 2024 API
ElementLevelFilter Constructor (ElementId)
ElementLevelFilter Class See Also Send Feedback
Constructs a new instance of an ElementLevelFilter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public ElementLevelFilter(
    ElementId levelId
)
Visual Basic
Public Sub New ( _
    levelId As ElementId _
)
Visual C++
public:
ElementLevelFilter(
    ElementId^ levelId
)

Parameters

levelId
Type: Autodesk.Revit.DB..::..ElementId
The id of the level that will be matched to elements' associated level.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ElementLevelFilter Class
ElementLevelFilter Overload


ElementLevelFilter Constructor (ElementId, Boolean)

[image]

Revit 2024 API
ElementLevelFilter Constructor (ElementId, Boolean)
ElementLevelFilter Class See Also Send Feedback
Constructs a new instance of an ElementLevelFilter, with the option to match all elements not associated to the given level id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public ElementLevelFilter(
    ElementId levelId,
    bool inverted
)
Visual Basic
Public Sub New ( _
    levelId As ElementId, _
    inverted As Boolean _
)
Visual C++
public:
ElementLevelFilter(
    ElementId^ levelId,
    bool inverted
)

Parameters

levelId
Type: Autodesk.Revit.DB..::..ElementId
The id of the level that will be matched to elements' associated level.
inverted
Type: System..::..Boolean
True if the filter should match all elements not associated to the given level.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ElementLevelFilter Class
ElementLevelFilter Overload


PassesFilter Method

[image] [image]

Revit 2024 API
ElementLevelFilter..::..PassesFilter Method
ElementLevelFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

ElementLevelFilter Class
ElementLevelFilter Members


ElementLevelFilter Properties

[image] [image]

Revit 2024 API
ElementLevelFilter Properties
ElementLevelFilter Class See Also Send Feedback

The ElementLevelFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)
Public property | LevelId | The id of the level that will be matched to elements' associated level.

See Also

ElementLevelFilter Class


ElementLogicalFilter Class

[image]

Revit 2024 API
ElementLogicalFilter Class
Members See Also Send Feedback
A filter used to logically combine two or more filters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class ElementLogicalFilter : ElementFilter
Visual Basic
Public Class ElementLogicalFilter _
    Inherits ElementFilter
Visual C++
public ref class ElementLogicalFilter : public ElementFilter

Remarks

The component filters may be reordered by Revit to cause the quickest acting filters to be evaluated first.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementLogicalFilter
Autodesk.Revit.DB..::..LogicalAndFilter
Autodesk.Revit.DB..::..LogicalOrFilter

See Also

ElementLogicalFilter Members


ElementLogicalFilter Members

[image] [image]

Revit 2024 API
ElementLogicalFilter Members
ElementLogicalFilter Class Methods Properties See Also Send Feedback

The ElementLogicalFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetFilters | Returns an array of copies of the filters that are logically combined by this ElementLogicalFilter.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | SetFilters | Replaces current filters in the logical filter with any number of input filters.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)

See Also

ElementLogicalFilter Class


ElementLogicalFilter Methods

[image] [image]

Revit 2024 API
ElementLogicalFilter Methods
ElementLogicalFilter Class See Also Send Feedback

The ElementLogicalFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetFilters | Returns an array of copies of the filters that are logically combined by this ElementLogicalFilter.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | SetFilters | Replaces current filters in the logical filter with any number of input filters.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ElementLogicalFilter Class


PassesFilter Method

[image] [image]

Revit 2024 API
ElementLogicalFilter..::..PassesFilter Method
ElementLogicalFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

ElementLogicalFilter Class
ElementLogicalFilter Members


SetFilters Method

[image]

Revit 2024 API
ElementLogicalFilter..::..SetFilters Method
ElementLogicalFilter Class See Also Send Feedback
Replaces current filters in the logical filter with any number of input filters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public void SetFilters(
    IList<ElementFilter> filters
)
Visual Basic
Public Sub SetFilters ( _
    filters As IList(Of ElementFilter) _
)
Visual C++
public:
void SetFilters(
    IList<ElementFilter^>^ filters
)

Parameters

filters
Type: System.Collections.Generic..::..IList<(Of <(<' ElementFilter >)>)>
A collection of input filters.

Remarks

The input filters will be copied.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The filter collection is empty, or contains invalid inputs.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ElementLogicalFilter Class


ElementLogicalFilter Properties

[image] [image]

Revit 2024 API
ElementLogicalFilter Properties
ElementLogicalFilter Class See Also Send Feedback

The ElementLogicalFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)

See Also

ElementLogicalFilter Class


ElementMulticategoryFilter Class

[image]

Revit 2024 API
ElementMulticategoryFilter Class
Members See Also Send Feedback
A filter used to find elements whose category matches any of a given set of categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public class ElementMulticategoryFilter : ElementQuickFilter
Visual Basic
Public Class ElementMulticategoryFilter _
    Inherits ElementQuickFilter
Visual C++
public ref class ElementMulticategoryFilter : public ElementQuickFilter

Remarks

This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementQuickFilter
Autodesk.Revit.DB..::..ElementMulticategoryFilter

See Also

ElementMulticategoryFilter Members


ElementMulticategoryFilter Members

[image] [image]

Revit 2024 API
ElementMulticategoryFilter Members
ElementMulticategoryFilter Class Constructors Methods Properties See Also Send Feedback

The ElementMulticategoryFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ElementMulticategoryFilter(ICollection<(Of <<'(BuiltInCategory>)>>)) | Constructs a new instance of a filter to match elements by built-in category.
Public method | ElementMulticategoryFilter(ICollection<(Of <<'(ElementId>)>>)) | Constructs a new instance of a filter to find elements whose category matches any of a given set of categories.
Public method | ElementMulticategoryFilter(ICollection<(Of <<'(BuiltInCategory>)>>), Boolean) | Constructs a new instance of a filter to match elements by built-in category, with the option to match all elements which are not of the given category.
Public method | ElementMulticategoryFilter(ICollection<(Of <<'(ElementId>)>>), Boolean) | Constructs a new instance of a filter to find elements whose category matches any of a given set of categories, with the option to instead match elements which are not of the given categories.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCategoryIds | Gets the category ids assigned to this filter.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)

See Also

ElementMulticategoryFilter Class


ElementMulticategoryFilter Constructor

[image] [image]

Revit 2024 API
ElementMulticategoryFilter Constructor
ElementMulticategoryFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ElementMulticategoryFilter(ICollection<(Of <<'(BuiltInCategory>)>>)) | Constructs a new instance of a filter to match elements by built-in category.
Public method | ElementMulticategoryFilter(ICollection<(Of <<'(ElementId>)>>)) | Constructs a new instance of a filter to find elements whose category matches any of a given set of categories.
Public method | ElementMulticategoryFilter(ICollection<(Of <<'(BuiltInCategory>)>>), Boolean) | Constructs a new instance of a filter to match elements by built-in category, with the option to match all elements which are not of the given category.
Public method | ElementMulticategoryFilter(ICollection<(Of <<'(ElementId>)>>), Boolean) | Constructs a new instance of a filter to find elements whose category matches any of a given set of categories, with the option to instead match elements which are not of the given categories.

See Also

ElementMulticategoryFilter Class
ElementMulticategoryFilter Members


ElementMulticategoryFilter Constructor (ICollection(BuiltInCategory), Boolean)

[image]

Revit 2024 API
ElementMulticategoryFilter Constructor (ICollection<(Of <(<'BuiltInCategory>)>)>, Boolean)
ElementMulticategoryFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements by built-in category, with the option to match all elements which are not of the given category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElementMulticategoryFilter(
    ICollection<BuiltInCategory> categories,
    bool inverted
)
Visual Basic
Public Sub New ( _
    categories As ICollection(Of BuiltInCategory), _
    inverted As Boolean _
)
Visual C++
public:
ElementMulticategoryFilter(
    ICollection<BuiltInCategory>^ categories,
    bool inverted
)

Parameters

categories
Type: System.Collections.Generic..::..ICollection<(Of <(<' BuiltInCategory >)>)>
The built-in categories to match.
inverted
Type: System..::..Boolean
True if the filter should match all elements which are not of the given built-in categories.

See Also

ElementMulticategoryFilter Class
ElementMulticategoryFilter Overload


ElementMulticategoryFilter Constructor (ICollection(ElementId), Boolean)

[image]

Revit 2024 API
ElementMulticategoryFilter Constructor (ICollection<(Of <(<'ElementId>)>)>, Boolean)
ElementMulticategoryFilter Class See Also Send Feedback
Constructs a new instance of a filter to find elements whose category matches any of a given set of categories, with the option to instead match elements which are not of the given categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public ElementMulticategoryFilter(
    ICollection<ElementId> categoryIds,
    bool inverted
)
Visual Basic
Public Sub New ( _
    categoryIds As ICollection(Of ElementId), _
    inverted As Boolean _
)
Visual C++
public:
ElementMulticategoryFilter(
    ICollection<ElementId^>^ categoryIds,
    bool inverted
)

Parameters

categoryIds
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
The category ids to match.
inverted
Type: System..::..Boolean
True if the filter should match all elements which are not of the given categories.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | One or more categories was not valid for filtering.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ElementMulticategoryFilter Class
ElementMulticategoryFilter Overload


ElementMulticategoryFilter Methods

[image] [image]

Revit 2024 API
ElementMulticategoryFilter Methods
ElementMulticategoryFilter Class See Also Send Feedback

The ElementMulticategoryFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCategoryIds | Gets the category ids assigned to this filter.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ElementMulticategoryFilter Class


GetCategoryIds Method

[image]

Revit 2024 API
ElementMulticategoryFilter..::..GetCategoryIds Method
ElementMulticategoryFilter Class See Also Send Feedback
Gets the category ids assigned to this filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public ICollection<ElementId> GetCategoryIds()
Visual Basic
Public Function GetCategoryIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetCategoryIds()

Return Value

The category ids.

See Also

ElementMulticategoryFilter Class


PassesFilter Method

[image] [image]

Revit 2024 API
ElementMulticategoryFilter..::..PassesFilter Method
ElementMulticategoryFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

ElementMulticategoryFilter Class
ElementMulticategoryFilter Members


ElementMulticategoryFilter Properties

[image] [image]

Revit 2024 API
ElementMulticategoryFilter Properties
ElementMulticategoryFilter Class See Also Send Feedback

The ElementMulticategoryFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)

See Also

ElementMulticategoryFilter Class


ElementMulticlassFilter Class

[image]

Revit 2024 API
ElementMulticlassFilter Class
Members See Also Send Feedback
A filter used to match elements by their class, where more than one class of element may be passed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public class ElementMulticlassFilter : ElementQuickFilter
Visual Basic
Public Class ElementMulticlassFilter _
    Inherits ElementQuickFilter
Visual C++
public ref class ElementMulticlassFilter : public ElementQuickFilter

Remarks

This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.

Only elements whose class is an exact match to one of the input classes, or elements whose type is derived from the input class will pass the collector.

There is a small subset of Element subclasses in the API that are not supported by this filter. These classes exist in the API, but not in Revit's native object model, which means that this filter doesn't support them. In order to use a class filter to find elements of these types, it is necessary to use a higher level class and then process the results further to find elements matching only the subclass. For a list of subclasses affected by this restriction, consult the documentation for [!:Autodesk::Revit::DB::ElementClassFilter].

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementQuickFilter
Autodesk.Revit.DB..::..ElementMulticlassFilter

See Also

ElementMulticlassFilter Members


ElementMulticlassFilter Constructor

[image] [image]

Revit 2024 API
ElementMulticlassFilter Constructor
ElementMulticlassFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ElementMulticlassFilter(IList<(Of <<'(Type>)>>)) | Constructs a new instance of a filter to find elements whose Element subclasses matches any of a given set of input classes.
Public method | ElementMulticlassFilter(IList<(Of <<'(Type>)>>), Boolean) | Constructs a new instance of a filter to find elements whose Element subclasses matches any of a given set of input classes, with an option to instead match elements whose Element subclass does not match the list of input classes.

See Also

ElementMulticlassFilter Class
ElementMulticlassFilter Members


ElementMulticlassFilter Constructor (IList(Type))

[image]

Revit 2024 API
ElementMulticlassFilter Constructor (IList<(Of <(<'Type>)>)>)
ElementMulticlassFilter Class See Also Send Feedback
Constructs a new instance of a filter to find elements whose Element subclasses matches any of a given set of input classes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public ElementMulticlassFilter(
    IList<Type> typeList
)
Visual Basic
Public Sub New ( _
    typeList As IList(Of Type) _
)
Visual C++
public:
ElementMulticlassFilter(
    IList<Type^>^ typeList
)

Parameters

typeList
Type: System.Collections.Generic..::..IList<(Of <(<'Type>)>)>
The list of Element subclass types to match.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | One or more input types are not valid subclasses of Element for this filter. -or- One or more of the types do not exist in Revit's native object model.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ElementMulticlassFilter Class
ElementMulticlassFilter Overload


ElementMulticlassFilter Constructor (IList(Type), Boolean)

[image]

Revit 2024 API
ElementMulticlassFilter Constructor (IList<(Of <(<'Type>)>)>, Boolean)
ElementMulticlassFilter Class See Also Send Feedback
Constructs a new instance of a filter to find elements whose Element subclasses matches any of a given set of input classes, with an option to instead match elements whose Element subclass does not match the list of input classes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public ElementMulticlassFilter(
    IList<Type> typeList,
    bool inverted
)
Visual Basic
Public Sub New ( _
    typeList As IList(Of Type), _
    inverted As Boolean _
)
Visual C++
public:
ElementMulticlassFilter(
    IList<Type^>^ typeList,
    bool inverted
)

Parameters

typeList
Type: System.Collections.Generic..::..IList<(Of <(<'Type>)>)>
The list of Element subclass types to match.
inverted
Type: System..::..Boolean
True if the filter should match all elements which are not of the given Element subclass.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | One or more input types are not valid subclasses of Element for this filter. -or- One or more of the types do not exist in Revit's native object model.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ElementMulticlassFilter Class
ElementMulticlassFilter Overload


PassesFilter Method

[image] [image]

Revit 2024 API
ElementMulticlassFilter..::..PassesFilter Method
ElementMulticlassFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

ElementMulticlassFilter Class
ElementMulticlassFilter Members


ElementMulticlassFilter Properties

[image] [image]

Revit 2024 API
ElementMulticlassFilter Properties
ElementMulticlassFilter Class See Also Send Feedback

The ElementMulticlassFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)

See Also

ElementMulticlassFilter Class


ElementNode Class

[image]

Revit 2024 API
ElementNode Class
Members See Also Send Feedback
A render node that represents an element, including the host document containing the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public class ElementNode : RenderNode
Visual Basic
Public Class ElementNode _
    Inherits RenderNode
Visual C++
public ref class ElementNode : public RenderNode

Remarks

See also: [!:Autodesk::Revit::DB::IExportContext2D::OnElementBegin2D]. See also: [!:Autodesk::Revit::DB::IExportContext2D::OnElementEnd2D].

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..RenderNode
Autodesk.Revit.DB..::..ElementNode

See Also

ElementNode Members


ElementNode Properties

[image] [image]

Revit 2024 API
ElementNode Properties
ElementNode Class See Also Send Feedback

The ElementNode type exposes the following members.

Properties

 | Name | Description
Public property | Document | Gets the document associated with the element.
Public property | ElementId | The Id of the element.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode.)
Public property | LinkInstanceId | The Id of the link instance for the element.
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode.)

See Also

ElementNode Class


Document Property

[image]

Revit 2024 API
ElementNode..::..Document Property
ElementNode Class See Also Send Feedback
Gets the document associated with the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public Document Document { get; }
Visual Basic
Public ReadOnly Property Document As Document
    Get
Visual C++
public:
property Document^ Document {
    Document^ get ();
}

Remarks

The document is in read-only state. Transactions are not allowed in it.

See Also

ElementNode Class


LinkInstanceId Property

[image]

Revit 2024 API
ElementNode..::..LinkInstanceId Property
ElementNode Class See Also Send Feedback
The Id of the link instance for the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public ElementId LinkInstanceId { get; }
Visual Basic
Public ReadOnly Property LinkInstanceId As ElementId
    Get
Visual C++
public:
property ElementId^ LinkInstanceId {
    ElementId^ get ();
}

See Also

ElementNode Class


ElementOnPhaseStatus Enumeration

[image]

Revit 2024 API
ElementOnPhaseStatus Enumeration
See Also Send Feedback
The statuses that an element can have with respect to a given phase.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public enum ElementOnPhaseStatus
Visual Basic
Public Enumeration ElementOnPhaseStatus
Visual C++
public enum class ElementOnPhaseStatus

Members

Member name | Description
None | Phase status is undefined (e.g., for annotations)
Past | Created and demolished before the given phase
Existing | Created in a previous phase, existing through the end of the given phase
Demolished | Created before the given phase, to be demolished on the given phase
New | Created on this phase (and not demolished)
Temporary | Created and demolished during this phase
Future | Created after this phase

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


ElementOwnerViewFilter Members

[image] [image]

Revit 2024 API
ElementOwnerViewFilter Members
ElementOwnerViewFilter Class Constructors Methods Properties See Also Send Feedback

The ElementOwnerViewFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ElementOwnerViewFilter(ElementId) | Constructs a new instance of a filter to match elements which are owned by a particular view.
Public method | ElementOwnerViewFilter(ElementId, Boolean) | Constructs a new instance of a filter to match elements which are owned by a particular view, with the option to invert the filter and find elements not owned by the given view.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)
Public property | ViewId | The view id.

See Also

ElementOwnerViewFilter Class


ElementOwnerViewFilter Constructor (ElementId)

[image]

Revit 2024 API
ElementOwnerViewFilter Constructor (ElementId)
ElementOwnerViewFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements which are owned by a particular view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElementOwnerViewFilter(
    ElementId viewId
)
Visual Basic
Public Sub New ( _
    viewId As ElementId _
)
Visual C++
public:
ElementOwnerViewFilter(
    ElementId^ viewId
)

Parameters

viewId
Type: Autodesk.Revit.DB..::..ElementId
The view id to match. Pass invalid element id to create a filter that will pass non-view-specific elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ElementOwnerViewFilter Class
ElementOwnerViewFilter Overload


ElementOwnerViewFilter Constructor (ElementId, Boolean)

[image]

Revit 2024 API
ElementOwnerViewFilter Constructor (ElementId, Boolean)
ElementOwnerViewFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements which are owned by a particular view, with the option to invert the filter and find elements not owned by the given view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElementOwnerViewFilter(
    ElementId viewId,
    bool inverted
)
Visual Basic
Public Sub New ( _
    viewId As ElementId, _
    inverted As Boolean _
)
Visual C++
public:
ElementOwnerViewFilter(
    ElementId^ viewId,
    bool inverted
)

Parameters

viewId
Type: Autodesk.Revit.DB..::..ElementId
The view id to match. Pass invalid element id to create a filter that will pass non-view-specific elements.
inverted
Type: System..::..Boolean
True if the filter should match all elements which are not owned by the given view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ElementOwnerViewFilter Class
ElementOwnerViewFilter Overload


ElementOwnerViewFilter Methods

[image] [image]

Revit 2024 API
ElementOwnerViewFilter Methods
ElementOwnerViewFilter Class See Also Send Feedback

The ElementOwnerViewFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ElementOwnerViewFilter Class


PassesFilter Method

[image] [image]

Revit 2024 API
ElementOwnerViewFilter..::..PassesFilter Method
ElementOwnerViewFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

ElementOwnerViewFilter Class
ElementOwnerViewFilter Members


ElementOwnerViewFilter Properties

[image] [image]

Revit 2024 API
ElementOwnerViewFilter Properties
ElementOwnerViewFilter Class See Also Send Feedback

The ElementOwnerViewFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)
Public property | ViewId | The view id.

See Also

ElementOwnerViewFilter Class


ViewId Property

[image]

Revit 2024 API
ElementOwnerViewFilter..::..ViewId Property
ElementOwnerViewFilter Class See Also Send Feedback
The view id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElementId ViewId { get; }
Visual Basic
Public ReadOnly Property ViewId As ElementId
    Get
Visual C++
public:
property ElementId^ ViewId {
    ElementId^ get ();
}

See Also

ElementOwnerViewFilter Class


ElementParameterFilter Class

[image]

Revit 2024 API
ElementParameterFilter Class
Members Example See Also Send Feedback
A filter used to match elements by one or more parameter filter rules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class ElementParameterFilter : ElementSlowFilter
Visual Basic
Public Class ElementParameterFilter _
    Inherits ElementSlowFilter
Visual C++
public ref class ElementParameterFilter : public ElementSlowFilter

Remarks

This filter is a slow filter. Slow filters require that the Element be obtained and expanded in memory first. Thus it is preferable to couple this filter with at least one ElementQuickFilter, which should minimize the number of Elements that are expanded.

Examples

CopyC#
// Creates an ElementParameter filter to find rooms whose area is
// greater than specified value
// Create filter by provider and evaluator
// provider
ParameterValueProvider pvp = new ParameterValueProvider(new ElementId(BuiltInParameter.ROOM_AREA));
// evaluator
FilterNumericRuleEvaluator fnrv = new FilterNumericGreater();
// rule value
double ruleValue = 100.0f; // filter room whose area is greater than 100 SF
// rule
FilterRule fRule = new FilterDoubleRule(pvp, fnrv, ruleValue, 1E-6);

// Create an ElementParameter filter
ElementParameterFilter filter = new ElementParameterFilter(fRule);

// Apply the filter to the elements in the active document
FilteredElementCollector collector = new FilteredElementCollector(document);
IList<Element> rooms = collector.WherePasses(filter).ToElements();

// Find rooms whose area is less than or equal to 100:
// Use inverted filter to match elements
ElementParameterFilter lessOrEqualFilter = new ElementParameterFilter(fRule, true);
collector = new FilteredElementCollector(document);
IList<Element> lessOrEqualFounds = collector.WherePasses(lessOrEqualFilter).ToElements();
CopyVB.NET
' Creates an ElementParameter filter to find rooms whose area is
' greater than specified value
' Create filter by provider and evaluator
' provider
Dim pvp As New ParameterValueProvider(New ElementId(BuiltInParameter.ROOM_AREA))
' evaluator
Dim fnrv As FilterNumericRuleEvaluator = New FilterNumericGreater()
' rule value
Dim ruleValue As Double = 100.0F
' filter room whose area is greater than 100 SF
' rule
Dim fRule As FilterRule = New FilterDoubleRule(pvp, fnrv, ruleValue, 0.000001)

' Create an ElementParameter filter
Dim filter As New ElementParameterFilter(fRule)

' Apply the filter to the elements in the active document
Dim collector As New FilteredElementCollector(document)
Dim rooms As IList(Of Element) = collector.WherePasses(filter).ToElements()

' Find rooms whose area is less than or equal to 100:
' Use inverted filter to match elements
Dim lessOrEqualFilter As New ElementParameterFilter(fRule, True)
collector = New FilteredElementCollector(document)
Dim lessOrEqualFounds As IList(Of Element) = collector.WherePasses(lessOrEqualFilter).ToElements()

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementSlowFilter
Autodesk.Revit.DB..::..ElementParameterFilter

See Also

ElementParameterFilter Members


ElementParameterFilter Members

[image] [image]

Revit 2024 API
ElementParameterFilter Members
ElementParameterFilter Class Constructors Methods Properties See Also Send Feedback

The ElementParameterFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ElementParameterFilter(FilterRule) | Constructs a new instance of an ElementParameterFilter from a single rule.
Public method | ElementParameterFilter(IList<(Of <<'(FilterRule>)>>)) | Constructs a new instance of an ElementParameterFilter from a set of rules.
Public method | ElementParameterFilter(FilterRule, Boolean) | Constructs a new instance of an ElementParameterFilter, with the option to match all elements not passing a given filter rule.
Public method | ElementParameterFilter(IList<(Of <<'(FilterRule>)>>), Boolean) | Constructs a new instance of an ElementParameterFilter, with the option to match all elements not passing the given filter rules.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRules | Returns the set of rules contained in this filter.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)

See Also

ElementParameterFilter Class


ElementParameterFilter Constructor

[image] [image]

Revit 2024 API
ElementParameterFilter Constructor
ElementParameterFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ElementParameterFilter(FilterRule) | Constructs a new instance of an ElementParameterFilter from a single rule.
Public method | ElementParameterFilter(IList<(Of <<'(FilterRule>)>>)) | Constructs a new instance of an ElementParameterFilter from a set of rules.
Public method | ElementParameterFilter(FilterRule, Boolean) | Constructs a new instance of an ElementParameterFilter, with the option to match all elements not passing a given filter rule.
Public method | ElementParameterFilter(IList<(Of <<'(FilterRule>)>>), Boolean) | Constructs a new instance of an ElementParameterFilter, with the option to match all elements not passing the given filter rules.

See Also

ElementParameterFilter Class
ElementParameterFilter Members


ElementParameterFilter Constructor (FilterRule)

[image]

Revit 2024 API
ElementParameterFilter Constructor (FilterRule)
ElementParameterFilter Class See Also Send Feedback
Constructs a new instance of an ElementParameterFilter from a single rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public ElementParameterFilter(
    FilterRule filterRule
)
Visual Basic
Public Sub New ( _
    filterRule As FilterRule _
)
Visual C++
public:
ElementParameterFilter(
    FilterRule^ filterRule
)

Parameters

filterRule
Type: Autodesk.Revit.DB..::..FilterRule
The rule applied to test if the element passes this filter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ElementParameterFilter Class
ElementParameterFilter Overload


ElementParameterFilter Constructor (IList(FilterRule))

[image]

Revit 2024 API
ElementParameterFilter Constructor (IList<(Of <(<'FilterRule>)>)>)
ElementParameterFilter Class See Also Send Feedback
Constructs a new instance of an ElementParameterFilter from a set of rules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public ElementParameterFilter(
    IList<FilterRule> filterRules
)
Visual Basic
Public Sub New ( _
    filterRules As IList(Of FilterRule) _
)
Visual C++
public:
ElementParameterFilter(
    IList<FilterRule^>^ filterRules
)

Parameters

filterRules
Type: System.Collections.Generic..::..IList<(Of <(<' FilterRule >)>)>
The rules applied to test if the element passes this filter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The filterRules array is empty or invalid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ElementParameterFilter Class
ElementParameterFilter Overload


ElementParameterFilter Constructor (FilterRule, Boolean)

[image]

Revit 2024 API
ElementParameterFilter Constructor (FilterRule, Boolean)
ElementParameterFilter Class See Also Send Feedback
Constructs a new instance of an ElementParameterFilter, with the option to match all elements not passing a given filter rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public ElementParameterFilter(
    FilterRule filterRule,
    bool inverted
)
Visual Basic
Public Sub New ( _
    filterRule As FilterRule, _
    inverted As Boolean _
)
Visual C++
public:
ElementParameterFilter(
    FilterRule^ filterRule,
    bool inverted
)

Parameters

filterRule
Type: Autodesk.Revit.DB..::..FilterRule
The rule applied to test if the element passes this filter.
inverted
Type: System..::..Boolean
True if the filter should match all elements which do not pass the filter rule.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ElementParameterFilter Class
ElementParameterFilter Overload


ElementParameterFilter Constructor (IList(FilterRule), Boolean)

[image]

Revit 2024 API
ElementParameterFilter Constructor (IList<(Of <(<'FilterRule>)>)>, Boolean)
ElementParameterFilter Class See Also Send Feedback
Constructs a new instance of an ElementParameterFilter, with the option to match all elements not passing the given filter rules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public ElementParameterFilter(
    IList<FilterRule> filterRules,
    bool inverted
)
Visual Basic
Public Sub New ( _
    filterRules As IList(Of FilterRule), _
    inverted As Boolean _
)
Visual C++
public:
ElementParameterFilter(
    IList<FilterRule^>^ filterRules,
    bool inverted
)

Parameters

filterRules
Type: System.Collections.Generic..::..IList<(Of <(<' FilterRule >)>)>
The rules applied to test if the element passes this filter.
inverted
Type: System..::..Boolean
True if the filter should match all elements which do not pass the filter rules.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The filterRules array is empty or invalid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ElementParameterFilter Class
ElementParameterFilter Overload


GetRules Method

[image]

Revit 2024 API
ElementParameterFilter..::..GetRules Method
ElementParameterFilter Class See Also Send Feedback
Returns the set of rules contained in this filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public IList<FilterRule> GetRules()
Visual Basic
Public Function GetRules As IList(Of FilterRule)
Visual C++
public:
IList<FilterRule^>^ GetRules()

Return Value

A copy of the set of rules.

See Also

ElementParameterFilter Class


PassesFilter Method

[image] [image]

Revit 2024 API
ElementParameterFilter..::..PassesFilter Method
ElementParameterFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

ElementParameterFilter Class
ElementParameterFilter Members


ElementParameterFilter Properties

[image] [image]

Revit 2024 API
ElementParameterFilter Properties
ElementParameterFilter Class See Also Send Feedback

The ElementParameterFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)

See Also

ElementParameterFilter Class


ElementPhaseStatusFilter Class

[image]

Revit 2024 API
ElementPhaseStatusFilter Class
Members See Also Send Feedback
A filter used to match elements that have a given phase status on a given phase.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public class ElementPhaseStatusFilter : ElementSlowFilter
Visual Basic
Public Class ElementPhaseStatusFilter _
    Inherits ElementSlowFilter
Visual C++
public ref class ElementPhaseStatusFilter : public ElementSlowFilter

Remarks

This filter is a slow filter. Slow filters require that the Element be obtained and expanded in memory first. Thus it is preferable to couple this filter with at least one ElementQuickFilter, which should minimize the number of Elements that are expanded.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementSlowFilter
Autodesk.Revit.DB..::..ElementPhaseStatusFilter

See Also

ElementPhaseStatusFilter Members


ElementPhaseStatusFilter Members

[image] [image]

Revit 2024 API
ElementPhaseStatusFilter Members
ElementPhaseStatusFilter Class Constructors Methods Properties See Also Send Feedback

The ElementPhaseStatusFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ElementPhaseStatusFilter(ElementId, ElementOnPhaseStatus) | Constructs a new instance of a file to match elements that have a given phase status on the input phase.
Public method | ElementPhaseStatusFilter(ElementId, ICollection<(Of <<'(ElementOnPhaseStatus>)>>)) | Constructs a new instance of a file to match elements that have a given phase statuses on the input phase.
Public method | ElementPhaseStatusFilter(ElementId, ElementOnPhaseStatus, Boolean) | Constructs a new instance of a file to match elements that have a given phase status on the input phase, with the option to match all elements that have a phase status other than the input status.
Public method | ElementPhaseStatusFilter(ElementId, ICollection<(Of <<'(ElementOnPhaseStatus>)>>), Boolean) | Constructs a new instance of a file to match elements that have a given phase statuses on the input phase, with the option to match all elements that have a phase status other than the input statuses.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPhaseStatuses | Returns the phase statuses assigned to this filter.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)
Public property | PhaseId | The phase id.

See Also

ElementPhaseStatusFilter Class


ElementPhaseStatusFilter Constructor

[image] [image]

Revit 2024 API
ElementPhaseStatusFilter Constructor
ElementPhaseStatusFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ElementPhaseStatusFilter(ElementId, ElementOnPhaseStatus) | Constructs a new instance of a file to match elements that have a given phase status on the input phase.
Public method | ElementPhaseStatusFilter(ElementId, ICollection<(Of <<'(ElementOnPhaseStatus>)>>)) | Constructs a new instance of a file to match elements that have a given phase statuses on the input phase.
Public method | ElementPhaseStatusFilter(ElementId, ElementOnPhaseStatus, Boolean) | Constructs a new instance of a file to match elements that have a given phase status on the input phase, with the option to match all elements that have a phase status other than the input status.
Public method | ElementPhaseStatusFilter(ElementId, ICollection<(Of <<'(ElementOnPhaseStatus>)>>), Boolean) | Constructs a new instance of a file to match elements that have a given phase statuses on the input phase, with the option to match all elements that have a phase status other than the input statuses.

See Also

ElementPhaseStatusFilter Class
ElementPhaseStatusFilter Members


ElementPhaseStatusFilter Constructor (ElementId, ElementOnPhaseStatus)

[image]

Revit 2024 API
ElementPhaseStatusFilter Constructor (ElementId, ElementOnPhaseStatus)
ElementPhaseStatusFilter Class See Also Send Feedback
Constructs a new instance of a file to match elements that have a given phase status on the input phase.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public ElementPhaseStatusFilter(
    ElementId phaseId,
    ElementOnPhaseStatus phaseStatus
)
Visual Basic
Public Sub New ( _
    phaseId As ElementId, _
    phaseStatus As ElementOnPhaseStatus _
)
Visual C++
public:
ElementPhaseStatusFilter(
    ElementId^ phaseId,
    ElementOnPhaseStatus phaseStatus
)

Parameters

phaseId
Type: Autodesk.Revit.DB..::..ElementId
Id of the phase.
phaseStatus
Type: Autodesk.Revit.DB..::..ElementOnPhaseStatus
Target status.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

ElementPhaseStatusFilter Class
ElementPhaseStatusFilter Overload


ElementPhaseStatusFilter Constructor (ElementId, ICollection(ElementOnPhaseStatus))

[image]

Revit 2024 API
ElementPhaseStatusFilter Constructor (ElementId, ICollection<(Of <(<'ElementOnPhaseStatus>)>)>)
ElementPhaseStatusFilter Class See Also Send Feedback
Constructs a new instance of a file to match elements that have a given phase statuses on the input phase.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public ElementPhaseStatusFilter(
    ElementId phaseId,
    ICollection<ElementOnPhaseStatus> phaseStatuses
)
Visual Basic
Public Sub New ( _
    phaseId As ElementId, _
    phaseStatuses As ICollection(Of ElementOnPhaseStatus) _
)
Visual C++
public:
ElementPhaseStatusFilter(
    ElementId^ phaseId,
    ICollection<ElementOnPhaseStatus>^ phaseStatuses
)

Parameters

phaseId
Type: Autodesk.Revit.DB..::..ElementId
Id of the phase.
phaseStatuses
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementOnPhaseStatus >)>)>
Target statuses.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ElementPhaseStatusFilter Class
ElementPhaseStatusFilter Overload


ElementPhaseStatusFilter Constructor (ElementId, ElementOnPhaseStatus, Boolean)

[image]

Revit 2024 API
ElementPhaseStatusFilter Constructor (ElementId, ElementOnPhaseStatus, Boolean)
ElementPhaseStatusFilter Class See Also Send Feedback
Constructs a new instance of a file to match elements that have a given phase status on the input phase, with the option to match all elements that have a phase status other than the input status.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public ElementPhaseStatusFilter(
    ElementId phaseId,
    ElementOnPhaseStatus phaseStatus,
    bool inverted
)
Visual Basic
Public Sub New ( _
    phaseId As ElementId, _
    phaseStatus As ElementOnPhaseStatus, _
    inverted As Boolean _
)
Visual C++
public:
ElementPhaseStatusFilter(
    ElementId^ phaseId,
    ElementOnPhaseStatus phaseStatus,
    bool inverted
)

Parameters

phaseId
Type: Autodesk.Revit.DB..::..ElementId
Id of the phase.
phaseStatus
Type: Autodesk.Revit.DB..::..ElementOnPhaseStatus
Target status.
inverted
Type: System..::..Boolean
True to match all phase statuses other than the input status.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

ElementPhaseStatusFilter Class
ElementPhaseStatusFilter Overload


ElementPhaseStatusFilter Constructor (ElementId, ICollection(ElementOnPhaseStatus), Boolean)

[image]

Revit 2024 API
ElementPhaseStatusFilter Constructor (ElementId, ICollection<(Of <(<'ElementOnPhaseStatus>)>)>, Boolean)
ElementPhaseStatusFilter Class See Also Send Feedback
Constructs a new instance of a file to match elements that have a given phase statuses on the input phase, with the option to match all elements that have a phase status other than the input statuses.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public ElementPhaseStatusFilter(
    ElementId phaseId,
    ICollection<ElementOnPhaseStatus> phaseStatuses,
    bool inverted
)
Visual Basic
Public Sub New ( _
    phaseId As ElementId, _
    phaseStatuses As ICollection(Of ElementOnPhaseStatus), _
    inverted As Boolean _
)
Visual C++
public:
ElementPhaseStatusFilter(
    ElementId^ phaseId,
    ICollection<ElementOnPhaseStatus>^ phaseStatuses,
    bool inverted
)

Parameters

phaseId
Type: Autodesk.Revit.DB..::..ElementId
Id of the phase.
phaseStatuses
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementOnPhaseStatus >)>)>
Target statuses.
inverted
Type: System..::..Boolean
True to match all phase statuses other than the input statuses.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ElementPhaseStatusFilter Class
ElementPhaseStatusFilter Overload


GetPhaseStatuses Method

[image]

Revit 2024 API
ElementPhaseStatusFilter..::..GetPhaseStatuses Method
ElementPhaseStatusFilter Class See Also Send Feedback
Returns the phase statuses assigned to this filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public ICollection<ElementOnPhaseStatus> GetPhaseStatuses()
Visual Basic
Public Function GetPhaseStatuses As ICollection(Of ElementOnPhaseStatus)
Visual C++
public:
ICollection<ElementOnPhaseStatus>^ GetPhaseStatuses()

Return Value

The phase statuses.

See Also

ElementPhaseStatusFilter Class


ElementPhaseStatusFilter Properties

[image] [image]

Revit 2024 API
ElementPhaseStatusFilter Properties
ElementPhaseStatusFilter Class See Also Send Feedback

The ElementPhaseStatusFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)
Public property | PhaseId | The phase id.

See Also

ElementPhaseStatusFilter Class


ElementQuickFilter Members

[image] [image]

Revit 2024 API
ElementQuickFilter Members
ElementQuickFilter Class Methods Properties See Also Send Feedback

The ElementQuickFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)

See Also

ElementQuickFilter Class


ElementQuickFilter Methods

[image] [image]

Revit 2024 API
ElementQuickFilter Methods
ElementQuickFilter Class See Also Send Feedback

The ElementQuickFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ElementQuickFilter Class


PassesFilter Method

[image] [image]

Revit 2024 API
ElementQuickFilter..::..PassesFilter Method
ElementQuickFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

ElementQuickFilter Class
ElementQuickFilter Members


ElementRecord Members

[image] [image]

Revit 2024 API
ElementRecord Members
ElementRecord Class Methods Properties See Also Send Feedback

The ElementRecord type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ElementRecord
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBoundingBox | Gets the bounding box of the element record.
Public method | GetCategoryId | Gets the category id of the element record.
Public method | GetDesignOptionId | Gets the design option id of the element record.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetId | Gets the id of the element record.
Public method | GetOwnerViewId | Gets the element id of the owner view record.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasBoundingBox | Determines whether this element record has a bounding box.
Public method | IsAnElementType | Identifies if the element record represents an ElementType.
Public method | IsCurveDriven | Identifies if the element is curve driven.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | WorksetId | Get Id of the workset which owns the element.

See Also

ElementRecord Class


ElementRecord Methods

[image] [image]

Revit 2024 API
ElementRecord Methods
ElementRecord Class See Also Send Feedback

The ElementRecord type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBoundingBox | Gets the bounding box of the element record.
Public method | GetCategoryId | Gets the category id of the element record.
Public method | GetDesignOptionId | Gets the design option id of the element record.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetId | Gets the id of the element record.
Public method | GetOwnerViewId | Gets the element id of the owner view record.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasBoundingBox | Determines whether this element record has a bounding box.
Public method | IsAnElementType | Identifies if the element record represents an ElementType.
Public method | IsCurveDriven | Identifies if the element is curve driven.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ElementRecord Class


Dispose Method

[image]

Revit 2024 API
ElementRecord..::..Dispose Method
ElementRecord Class See Also Send Feedback
Releases all resources used by the ElementRecord

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ElementRecord Class


GetCategoryId Method

[image]

Revit 2024 API
ElementRecord..::..GetCategoryId Method
ElementRecord Class See Also Send Feedback
Gets the category id of the element record.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public ElementId GetCategoryId()
Visual Basic
Public Function GetCategoryId As ElementId
Visual C++
public:
ElementId^ GetCategoryId()

Return Value

The category id.

See Also

ElementRecord Class


GetDesignOptionId Method

[image]

Revit 2024 API
ElementRecord..::..GetDesignOptionId Method
ElementRecord Class See Also Send Feedback
Gets the design option id of the element record.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public ElementId GetDesignOptionId()
Visual Basic
Public Function GetDesignOptionId As ElementId
Visual C++
public:
ElementId^ GetDesignOptionId()

Return Value

The design option id.

See Also

ElementRecord Class


GetOwnerViewId Method

[image]

Revit 2024 API
ElementRecord..::..GetOwnerViewId Method
ElementRecord Class See Also Send Feedback
Gets the element id of the owner view record.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public ElementId GetOwnerViewId()
Visual Basic
Public Function GetOwnerViewId As ElementId
Visual C++
public:
ElementId^ GetOwnerViewId()

Return Value

The view record element id.

See Also

ElementRecord Class


HasBoundingBox Method

[image]

Revit 2024 API
ElementRecord..::..HasBoundingBox Method
ElementRecord Class See Also Send Feedback
Determines whether this element record has a bounding box.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool HasBoundingBox()
Visual Basic
Public Function HasBoundingBox As Boolean
Visual C++
public:
bool HasBoundingBox()

Return Value

True if the element record has a bounding box or false otherwise.

See Also

ElementRecord Class


IsCurveDriven Method

[image]

Revit 2024 API
ElementRecord..::..IsCurveDriven Method
ElementRecord Class See Also Send Feedback
Identifies if the element is curve driven.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool IsCurveDriven()
Visual Basic
Public Function IsCurveDriven As Boolean
Visual C++
public:
bool IsCurveDriven()

Return Value

True if the element is curve driven.

See Also

ElementRecord Class


ElementRecord Properties

[image] [image]

Revit 2024 API
ElementRecord Properties
ElementRecord Class See Also Send Feedback

The ElementRecord type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | WorksetId | Get Id of the workset which owns the element.

See Also

ElementRecord Class


IsValidObject Property

[image]

Revit 2024 API
ElementRecord..::..IsValidObject Property
ElementRecord Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ElementRecord Class


WorksetId Property

[image]

Revit 2024 API
ElementRecord..::..WorksetId Property
ElementRecord Class See Also Send Feedback
Get Id of the workset which owns the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public WorksetId WorksetId { get; }
Visual Basic
Public ReadOnly Property WorksetId As WorksetId
    Get
Visual C++
public:
property WorksetId^ WorksetId {
    WorksetId^ get ();
}

Remarks

Each element belongs to one and only one workset.

See Also

ElementRecord Class


ElementSet Class

[image]

Revit 2024 API
ElementSet Class
Members Example See Also Send Feedback
A set that contains element objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class ElementSet : APIObject, IEnumerable
Visual Basic
Public Class ElementSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ElementSet : public APIObject,
    IEnumerable

Examples

CopyC#
ICollection<ElementId> selectedIds = uidoc.Selection.GetElementIds();

string info = "Selected elements:\n";
foreach (ElementId id in selectedIds)
{
    Element elem = document.GetElement(id);
    info += elem.Name + "\n";
}

TaskDialog.Show("Revit",info);
CopyVB.NET
Dim selectedIds As ICollection(Of ElementId) = uidoc.Selection.GetElementIds()

Dim info As String = "Selected elements:" & vbLf
For Each id As ElementId In selectedIds
    Dim elem As Element = document.GetElement(id)
    info += elem.Name + vbLf
Next

TaskDialog.Show("Revit", info)

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..ElementSet

See Also

ElementSet Members


ElementSet Members

[image] [image]

Revit 2024 API
ElementSet Members
ElementSet Class Constructors Methods Properties See Also Send Feedback

The ElementSet type exposes the following members.

Constructors

 | Name | Description
Public method | ElementSet | Initializes a new instance of the ElementSet class

Methods

 | Name | Description
Public method | Clear | Removes every item element the set, rendering it empty.
Public method | Contains | Tests for the existence of an element within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified element from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified element into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of elements that are in the set.

See Also

ElementSet Class


ElementSet Constructor

[image]

Revit 2024 API
ElementSet Constructor
ElementSet Class See Also Send Feedback
Initializes a new instance of the ElementSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElementSet()
Visual Basic
Public Sub New
Visual C++
public:
ElementSet()

See Also

ElementSet Class


Contains Method

[image]

Revit 2024 API
ElementSet..::..Contains Method
ElementSet Class See Also Send Feedback
Tests for the existence of an element within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool Contains(
    Element item
)
Visual Basic
Public Overridable Function Contains ( _
    item As Element _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Element^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..Element
The element to be searched for.

Return Value

The Contains method returns True if the element is within the set, otherwise False.

See Also

ElementSet Class


Erase Method

[image]

Revit 2024 API
ElementSet..::..Erase Method
ElementSet Class See Also Send Feedback
Removes a specified element from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Erase(
    Element item
)
Visual Basic
Public Overridable Function Erase ( _
    item As Element _
) As Integer
Visual C++
public:
virtual int Erase(
    Element^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..Element
The element to be erased.

Return Value

The number of elements that were erased from the set.

See Also

ElementSet Class


ForwardIterator Method

[image]

Revit 2024 API
ElementSet..::..ForwardIterator Method
ElementSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual ElementSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As ElementSetIterator
Visual C++
public:
virtual ElementSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

ElementSet Class


GetEnumerator Method

[image]

Revit 2024 API
ElementSet..::..GetEnumerator Method
ElementSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

ElementSet Class


Insert Method

[image]

Revit 2024 API
ElementSet..::..Insert Method
ElementSet Class See Also Send Feedback
Insert the specified element into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool Insert(
    Element item
)
Visual Basic
Public Overridable Function Insert ( _
    item As Element _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Element^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..Element
The element to be inserted into the set.

Return Value

Returns whether the element was inserted into the set.

See Also

ElementSet Class


IsEmpty Property

[image]

Revit 2024 API
ElementSet..::..IsEmpty Property
ElementSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

ElementSet Class


Size Property

[image]

Revit 2024 API
ElementSet..::..Size Property
ElementSet Class See Also Send Feedback
Returns the number of elements that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ElementSet Class


ElementSetIterator Constructor

[image]

Revit 2024 API
ElementSetIterator Constructor
ElementSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElementSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
ElementSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ElementSetIterator Class


ElementSetIterator Methods

[image] [image]

Revit 2024 API
ElementSetIterator Methods
ElementSetIterator Class See Also Send Feedback

The ElementSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ElementSetIterator Class


MoveNext Method

[image]

Revit 2024 API
ElementSetIterator..::..MoveNext Method
ElementSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ElementSetIterator Class


Reset Method

[image]

Revit 2024 API
ElementSetIterator..::..Reset Method
ElementSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ElementSetIterator Class


ElementSetIterator Properties

[image] [image]

Revit 2024 API
ElementSetIterator Properties
ElementSetIterator Class See Also Send Feedback

The ElementSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElementSetIterator Class


Current Property

[image]

Revit 2024 API
ElementSetIterator..::..Current Property
ElementSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ElementSetIterator Class


PassesFilter Method

[image] [image]

Revit 2024 API
ElementSlowFilter..::..PassesFilter Method
ElementSlowFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

ElementSlowFilter Class
ElementSlowFilter Members


ElementSlowFilter Properties

[image] [image]

Revit 2024 API
ElementSlowFilter Properties
ElementSlowFilter Class See Also Send Feedback

The ElementSlowFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)

See Also

ElementSlowFilter Class


ElementStructuralTypeFilter Members

[image] [image]

Revit 2024 API
ElementStructuralTypeFilter Members
ElementStructuralTypeFilter Class Constructors Methods Properties See Also Send Feedback

The ElementStructuralTypeFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ElementStructuralTypeFilter(StructuralType) | Constructs a new instance of a filter to match elements by structural type.
Public method | ElementStructuralTypeFilter(StructuralType, Boolean) | Constructs a new instance of a filter to match elements by structural type, with the option to match all elements which are of the given structural type.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)
Public property | StructuralType | The structural type.

See Also

ElementStructuralTypeFilter Class


ElementStructuralTypeFilter Constructor

[image] [image]

Revit 2024 API
ElementStructuralTypeFilter Constructor
ElementStructuralTypeFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ElementStructuralTypeFilter(StructuralType) | Constructs a new instance of a filter to match elements by structural type.
Public method | ElementStructuralTypeFilter(StructuralType, Boolean) | Constructs a new instance of a filter to match elements by structural type, with the option to match all elements which are of the given structural type.

See Also

ElementStructuralTypeFilter Class
ElementStructuralTypeFilter Members


ElementStructuralTypeFilter Constructor (StructuralType)

[image]

Revit 2024 API
ElementStructuralTypeFilter Constructor (StructuralType)
ElementStructuralTypeFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements by structural type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public ElementStructuralTypeFilter(
    StructuralType structuralType
)
Visual Basic
Public Sub New ( _
    structuralType As StructuralType _
)
Visual C++
public:
ElementStructuralTypeFilter(
    StructuralType structuralType
)

Parameters

structuralType
Type: Autodesk.Revit.DB.Structure..::..StructuralType
The structural type to match.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

ElementStructuralTypeFilter Class
ElementStructuralTypeFilter Overload


ElementStructuralTypeFilter Constructor (StructuralType, Boolean)

[image]

Revit 2024 API
ElementStructuralTypeFilter Constructor (StructuralType, Boolean)
ElementStructuralTypeFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements by structural type, with the option to match all elements which are of the given structural type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public ElementStructuralTypeFilter(
    StructuralType structuralType,
    bool inverted
)
Visual Basic
Public Sub New ( _
    structuralType As StructuralType, _
    inverted As Boolean _
)
Visual C++
public:
ElementStructuralTypeFilter(
    StructuralType structuralType,
    bool inverted
)

Parameters

structuralType
Type: Autodesk.Revit.DB.Structure..::..StructuralType
The structural type to match.
inverted
Type: System..::..Boolean
True if the filter should match all elements which are not of the given structural type.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

ElementStructuralTypeFilter Class
ElementStructuralTypeFilter Overload


ElementStructuralTypeFilter Methods

[image] [image]

Revit 2024 API
ElementStructuralTypeFilter Methods
ElementStructuralTypeFilter Class See Also Send Feedback

The ElementStructuralTypeFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ElementStructuralTypeFilter Class


PassesFilter Method

[image] [image]

Revit 2024 API
ElementStructuralTypeFilter..::..PassesFilter Method
ElementStructuralTypeFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

ElementStructuralTypeFilter Class
ElementStructuralTypeFilter Members


ElementStructuralTypeFilter Properties

[image] [image]

Revit 2024 API
ElementStructuralTypeFilter Properties
ElementStructuralTypeFilter Class See Also Send Feedback

The ElementStructuralTypeFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)
Public property | StructuralType | The structural type.

See Also

ElementStructuralTypeFilter Class


StructuralType Property

[image]

Revit 2024 API
ElementStructuralTypeFilter..::..StructuralType Property
ElementStructuralTypeFilter Class See Also Send Feedback
The structural type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public StructuralType StructuralType { get; }
Visual Basic
Public ReadOnly Property StructuralType As StructuralType
    Get
Visual C++
public:
property StructuralType StructuralType {
    StructuralType get ();
}

See Also

ElementStructuralTypeFilter Class


ElementTransformUtils Class

[image]

Revit 2024 API
ElementTransformUtils Class
Members See Also Send Feedback
A collection of utilities allowing transformation of elements (e.g. move, rotate, mirror and copy).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static class ElementTransformUtils
Visual Basic
Public NotInheritable Class ElementTransformUtils
Visual C++
public ref class ElementTransformUtils abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementTransformUtils

See Also

ElementTransformUtils Members


ElementTransformUtils Members

[image] [image]

Revit 2024 API
ElementTransformUtils Members
ElementTransformUtils Class Methods See Also Send Feedback

The ElementTransformUtils type exposes the following members.

Methods

Name | Description
CanMirrorElement | Determines whether element can be mirrored.
CanMirrorElements | Determines whether elements can be mirrored.
CopyElement | Copies an element and places the copy at a location indicated by a given transformation.
CopyElements(Document, ICollection<(Of <<'(ElementId>)>>), XYZ) | Copies a set of elements and places the copies at a location indicated by a given translation.
CopyElements(Document, ICollection<(Of <<'(ElementId>)>>), Document, Transform, CopyPasteOptions) | Copies a set of elements from source document to destination document.
CopyElements(View, ICollection<(Of <<'(ElementId>)>>), View, Transform, CopyPasteOptions) | Copies a set of elements from source view to destination view.
GetTransformFromViewToView | Returns a transformation that is applied to elements when copying from one view to another view.
MirrorElement | Creates a mirrored copy of an element about a given plane.
MirrorElements | Mirrors a set of elements about a given plane.
MoveElement | Moves one element by a given transformation.
MoveElements | Moves a set of elements by a given transformation.
RotateElement | Rotates an element about the given axis and angle.
RotateElements | Rotates a set of elements about the given axis and angle.

See Also

ElementTransformUtils Class


ElementTransformUtils Methods

[image] [image]

Revit 2024 API
ElementTransformUtils Methods
ElementTransformUtils Class See Also Send Feedback

The ElementTransformUtils type exposes the following members.

Methods

Name | Description
CanMirrorElement | Determines whether element can be mirrored.
CanMirrorElements | Determines whether elements can be mirrored.
CopyElement | Copies an element and places the copy at a location indicated by a given transformation.
CopyElements(Document, ICollection<(Of <<'(ElementId>)>>), XYZ) | Copies a set of elements and places the copies at a location indicated by a given translation.
CopyElements(Document, ICollection<(Of <<'(ElementId>)>>), Document, Transform, CopyPasteOptions) | Copies a set of elements from source document to destination document.
CopyElements(View, ICollection<(Of <<'(ElementId>)>>), View, Transform, CopyPasteOptions) | Copies a set of elements from source view to destination view.
GetTransformFromViewToView | Returns a transformation that is applied to elements when copying from one view to another view.
MirrorElement | Creates a mirrored copy of an element about a given plane.
MirrorElements | Mirrors a set of elements about a given plane.
MoveElement | Moves one element by a given transformation.
MoveElements | Moves a set of elements by a given transformation.
RotateElement | Rotates an element about the given axis and angle.
RotateElements | Rotates a set of elements about the given axis and angle.

See Also

ElementTransformUtils Class


CanMirrorElement Method

[image]

Revit 2024 API
ElementTransformUtils..::..CanMirrorElement Method
ElementTransformUtils Class See Also Send Feedback
Determines whether element can be mirrored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static bool CanMirrorElement(
    Document ADoc,
    ElementId elemId
)
Visual Basic
Public Shared Function CanMirrorElement ( _
    ADoc As Document, _
    elemId As ElementId _
) As Boolean
Visual C++
public:
static bool CanMirrorElement(
    Document^ ADoc,
    ElementId^ elemId
)

Parameters

ADoc
Type: Autodesk.Revit.DB..::..Document
The document where the element reside.
elemId
Type: Autodesk.Revit.DB..::..ElementId
The element identified by id.

Return Value

True if the element can be mirrored.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ElementTransformUtils Class


CanMirrorElements Method

[image]

Revit 2024 API
ElementTransformUtils..::..CanMirrorElements Method
ElementTransformUtils Class See Also Send Feedback
Determines whether elements can be mirrored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static bool CanMirrorElements(
    Document ADoc,
    ICollection<ElementId> elemIds
)
Visual Basic
Public Shared Function CanMirrorElements ( _
    ADoc As Document, _
    elemIds As ICollection(Of ElementId) _
) As Boolean
Visual C++
public:
static bool CanMirrorElements(
    Document^ ADoc,
    ICollection<ElementId^>^ elemIds
)

Parameters

ADoc
Type: Autodesk.Revit.DB..::..Document
The document where the elements reside.
elemIds
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
The elements identified by id.

Return Value

True if the elements can be mirrored.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ElementTransformUtils Class


CopyElements Method

[image] [image]

Revit 2024 API
ElementTransformUtils..::..CopyElements Method
ElementTransformUtils Class See Also Send Feedback

Overload List

Name | Description
CopyElements(Document, ICollection<(Of <<'(ElementId>)>>), XYZ) | Copies a set of elements and places the copies at a location indicated by a given translation.
CopyElements(Document, ICollection<(Of <<'(ElementId>)>>), Document, Transform, CopyPasteOptions) | Copies a set of elements from source document to destination document.
CopyElements(View, ICollection<(Of <<'(ElementId>)>>), View, Transform, CopyPasteOptions) | Copies a set of elements from source view to destination view.

See Also

ElementTransformUtils Class
ElementTransformUtils Members


CopyElements Method (Document, ICollection(ElementId), XYZ)

[image]

Revit 2024 API
ElementTransformUtils..::..CopyElements Method (Document, ICollection<(Of <(<'ElementId>)>)>, XYZ)
ElementTransformUtils Class See Also Send Feedback
Copies a set of elements and places the copies at a location indicated by a given translation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static ICollection<ElementId> CopyElements(
    Document document,
    ICollection<ElementId> elementsToCopy,
    XYZ translation
)
Visual Basic
Public Shared Function CopyElements ( _
    document As Document, _
    elementsToCopy As ICollection(Of ElementId), _
    translation As XYZ _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ CopyElements(
    Document^ document,
    ICollection<ElementId^>^ elementsToCopy,
    XYZ^ translation
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document that owns the elements.
elementsToCopy
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
The set of elements to copy.
translation
Type: Autodesk.Revit.DB..::..XYZ
The translation vector for the new elements.

Return Value

The ids of the newly created copied elements.

Remarks

This method is not suitable for elements that are hosted in other elements as it does not perform rehosting. If you need to rehost your elements in addition to copying them, use one of the other CopyElements() overloads.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given element id set is empty. -or- One or more elements in elementsToCopy do not exist in the document. -or- Some of the elements cannot be copied, because they belong to different views. -or- The input set of elements contains Sketch members along with other elements or there is no active Sketch edit mode.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | It is not allowed to copy Sketch members between non-parallel sketches. -or- If we are not able to copy all the elements.

See Also

ElementTransformUtils Class
CopyElements Overload


CopyElements Method (Document, ICollection(ElementId), Document, Transform, CopyPasteOptions)

[image]

Revit 2024 API
ElementTransformUtils..::..CopyElements Method (Document, ICollection<(Of <(<'ElementId>)>)>, Document, Transform, CopyPasteOptions)
ElementTransformUtils Class Example See Also Send Feedback
Copies a set of elements from source document to destination document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static ICollection<ElementId> CopyElements(
    Document sourceDocument,
    ICollection<ElementId> elementsToCopy,
    Document destinationDocument,
    Transform transform,
    CopyPasteOptions options
)
Visual Basic
Public Shared Function CopyElements ( _
    sourceDocument As Document, _
    elementsToCopy As ICollection(Of ElementId), _
    destinationDocument As Document, _
    transform As Transform, _
    options As CopyPasteOptions _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ CopyElements(
    Document^ sourceDocument,
    ICollection<ElementId^>^ elementsToCopy,
    Document^ destinationDocument,
    Transform^ transform,
    CopyPasteOptions^ options
)

Parameters

sourceDocument
Type: Autodesk.Revit.DB..::..Document
The document that contains the elements to copy.
elementsToCopy
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
The set of elements to copy.
destinationDocument
Type: Autodesk.Revit.DB..::..Document
The destination document to paste the elements into.
transform
Type: Autodesk.Revit.DB..::..Transform
The transform for the new elements. Can be nullNothingnullptra null reference (Nothing in Visual Basic) if no transform is required.
options
Type: Autodesk.Revit.DB..::..CopyPasteOptions
Optional settings. Can be nullNothingnullptra null reference (Nothing in Visual Basic) if default settings should be used.

Return Value

The ids of the newly created copied elements.

Remarks

Copies are placed at their respective original locations or locations specified by the optional transformation.

This method can be used for copying non-view specific elements only. For copying view-specific elements, use the view-specific form of the CopyElements method.

The destination document can be the same as the source document.

This method performs rehosting of elements where applicable.

Examples

CopyC#
// Copy wall element.
public void CopyWall(Autodesk.Revit.DB.Document sourceDocument, Autodesk.Revit.DB.Document destinationDocument, Autodesk.Revit.DB.Wall wall)
{
   Transform transform = Transform.CreateTranslation(new XYZ(150, 150, 0));
   CopyPasteOptions options = new CopyPasteOptions();

   ElementTransformUtils.CopyElements(sourceDocument, new List<ElementId> { wall.Id }, destinationDocument, transform, options);
}

// The method copies existing Sketch curves inside of the Floor sketch.
public void CopySketchMembersInsideOfSketch(Autodesk.Revit.DB.Document document, Autodesk.Revit.DB.Floor floor)
{
   var floorSketch = document.GetElement(floor.SketchId) as Sketch;

   // Start Sketch edit mode to copy Sketch members inside of the Sketch
   SketchEditScope sketchScope = new SketchEditScope(document, "Edit floor sketch");
   sketchScope.Start(floor.SketchId);

   // Start transaction to be able to modify the document
   using (Transaction tr = new Transaction(document, "Copy sketch members"))
   {
      tr.Start();

      var transform = Transform.CreateTranslation(new XYZ(150, 150, 0));
      var copiedIds = ElementTransformUtils.CopyElements(
         document, floorSketch.GetAllElements(), document, transform, new CopyPasteOptions());

      tr.Commit();
   }

   sketchScope.Commit(new CustomFailuresPreprocessor());
}

// The method copies Sketch members from the Floor to the Ceiling Sketch.
public void CopySketchMembersBetweenSketch(Autodesk.Revit.DB.Floor floor, Autodesk.Revit.DB.Ceiling ceiling)
{
   var ceilingSketch = ceiling.Document.GetElement(ceiling.SketchId) as Sketch;
   var floorSketch = floor.Document.GetElement(floor.SketchId) as Sketch;

   // Sketch members can be copied only between parallel Sketches.
   if (!MathComparisonUtils.IsAlmostEqual(
      Math.Abs(floorSketch.SketchPlane.GetPlane().Normal.DotProduct(ceilingSketch.SketchPlane.GetPlane().Normal)), 1.0))
   {
      return;
   }

   // Start Sketch edit mode, for the ceiling sketch, to copy and paste floor Sketch members to the ceiling
   SketchEditScope sketchScope = new SketchEditScope(ceiling.Document, "Edit ceiling sketch");
   sketchScope.Start(ceiling.SketchId);

   // Start transaction to be able to modify the document
   using (Transaction tr = new Transaction(ceiling.Document, "Copy sketch members"))
   {
      tr.Start();

      var transform = Transform.CreateTranslation(new XYZ(150, 150, 0));
      var copiedIds = ElementTransformUtils.CopyElements(
         floor.Document, floorSketch.GetAllElements(), ceiling.Document, transform, new CopyPasteOptions());

      tr.Commit();
   }

   sketchScope.Commit(new CustomFailuresPreprocessor());
}

// The method copies ModelCurves from the document to the Sketch.
public void CopyModelCurvesFromDocumentToSketch(Autodesk.Revit.DB.Sketch sketch, List<ElementId> modelCurveIds)
{
   // Start Sketch edit mode to insert ModelCurves into the Floor Sketch.
   SketchEditScope sketchScope = new SketchEditScope(sketch.Document, "Edit floor sketch");
   sketchScope.Start(sketch.Id);

   // Start transaction to be able to modify the document
   using (Transaction tr = new Transaction(sketch.Document, "Copy sketch members"))
   {
      tr.Start();

      var transform = Transform.CreateTranslation(new XYZ(150, 150, 0));
      var copiedIds = ElementTransformUtils.CopyElements(
         sketch.Document, modelCurveIds, sketch.Document, transform, new CopyPasteOptions());

      tr.Commit();
   }

   // Sketch curves should not have open loops or intersections to be successfully committed.
   sketchScope.Commit(new CustomFailuresPreprocessor());
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given element id set is empty. -or- One or more elements in elementsToCopy do not exist in the document. -or- Some of the elements cannot be copied, because they are view-specific. -or- The input set of elements contains Sketch members along with other elements or there is no active Sketch edit mode.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | It is not allowed to copy Sketch members between non-parallel sketches. -or- The elements cannot be copied.
Autodesk.Revit.Exceptions..::..OperationCanceledException | User cancelled the operation.

See Also

ElementTransformUtils Class
CopyElements Overload


CopyElements Method (View, ICollection(ElementId), View, Transform, CopyPasteOptions)

[image]

Revit 2024 API
ElementTransformUtils..::..CopyElements Method (View, ICollection<(Of <(<'ElementId>)>)>, View, Transform, CopyPasteOptions)
ElementTransformUtils Class Example See Also Send Feedback
Copies a set of elements from source view to destination view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static ICollection<ElementId> CopyElements(
    View sourceView,
    ICollection<ElementId> elementsToCopy,
    View destinationView,
    Transform additionalTransform,
    CopyPasteOptions options
)
Visual Basic
Public Shared Function CopyElements ( _
    sourceView As View, _
    elementsToCopy As ICollection(Of ElementId), _
    destinationView As View, _
    additionalTransform As Transform, _
    options As CopyPasteOptions _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ CopyElements(
    View^ sourceView,
    ICollection<ElementId^>^ elementsToCopy,
    View^ destinationView,
    Transform^ additionalTransform,
    CopyPasteOptions^ options
)

Parameters

sourceView
Type: Autodesk.Revit.DB..::..View
The view in the source document that contains the elements to copy.
elementsToCopy
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
The set of elements to copy.
destinationView
Type: Autodesk.Revit.DB..::..View
The view in the destination document that the elements will be pasted into.
additionalTransform
Type: Autodesk.Revit.DB..::..Transform
The transform for the new elements, in addition to the transformation between the source and destination views. Can be nullNothingnullptra null reference (Nothing in Visual Basic) if no transform is required. The transformation must be within the plane of the destination view.
options
Type: Autodesk.Revit.DB..::..CopyPasteOptions
Optional settings. Can be nullNothingnullptra null reference (Nothing in Visual Basic) if default settings should be used.

Return Value

The ids of the newly created copied elements.

Remarks

This method can be used for both view-specific and model elements.

Both source and destination views must be 2D graphics views capable of drawing details and view-specific elements (floor and ceiling plans, elevations, sections, drafting views.) Drafting views cannot be used as a destination for model elements.

The pasted elements are repositioned to ensure proper placement in the destination view (e.g. elevation is changed when copying from a level to a different level.) Additional transformation within the destination view can be performed by providing additionalTransform argument. This additional transformation must be within the plane of the destination view.

The destination view can be in the same document as the source view.

The destination view can be the same as the source view.

All view-specific elements in the set must be specific to the source view. Elements specific to views other than the source view or to multiple views cannot be copied.

This method performs rehosting of elements where applicable.

Examples

CopyC#
// The method copies view-specific DetailCurve.
public void CopyDetailCurve(Autodesk.Revit.DB.DetailCurve curve, Autodesk.Revit.DB.View destinationView)
{
   var ownerView = curve.Document.GetElement(curve.OwnerViewId) as Autodesk.Revit.DB.View;
   Transform transform = Transform.CreateTranslation(new XYZ(150, 150, 0));
   CopyPasteOptions options = new CopyPasteOptions();

   ElementTransformUtils.CopyElements(ownerView, new List<ElementId> { curve.Id }, destinationView, transform, options);
}

// The method copies sketch curves from the Floor Sketch to the Document to create independent ModelCurves
// that would replicate curves in the sketch.
public void CopySketchMembersToDocument(Autodesk.Revit.DB.Document document, Autodesk.Revit.DB.Floor floor, Autodesk.Revit.DB.View destinationView)
{
   var floorSketch = document.GetElement(floor.SketchId) as Sketch;
   // Select only curve elements from Sketch.
   var sketchCurves = floorSketch.GetAllElements().Where(id => document.GetElement(id) is ModelCurve).ToList();
   var transform = Transform.CreateTranslation(new XYZ(150, 150, 0));

   var copiedIds = ElementTransformUtils.CopyElements(
      destinationView, sketchCurves, destinationView, transform, new CopyPasteOptions());
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given element id set is empty. -or- The specified view cannot be used as a source or destination for copying elements between two views. -or- Some of the elements cannot be copied, because they belong to a different document. -or- Some of the elements cannot be copied, because they belong to a different view. -or- The elements cannot be copied into the destination view. Drafting views cannot contain model elements. -or- The transformation is not within the plane of the destination view. -or- The input set of elements contains Sketch members along with other elements and the Sketch Id of those members isn't in the set.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | It is not allowed to copy Sketch members between non-parallel sketches. -or- The elements cannot be copied.
Autodesk.Revit.Exceptions..::..OperationCanceledException | User cancelled the operation.

See Also

ElementTransformUtils Class
CopyElements Overload


MirrorElement Method

[image]

Revit 2024 API
ElementTransformUtils..::..MirrorElement Method
ElementTransformUtils Class Example See Also Send Feedback
Creates a mirrored copy of an element about a given plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static void MirrorElement(
    Document document,
    ElementId elementToMirror,
    Plane plane
)
Visual Basic
Public Shared Sub MirrorElement ( _
    document As Document, _
    elementToMirror As ElementId, _
    plane As Plane _
)
Visual C++
public:
static void MirrorElement(
    Document^ document,
    ElementId^ elementToMirror,
    Plane^ plane
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document that owns the element.
elementToMirror
Type: Autodesk.Revit.DB..::..ElementId
The element to mirror.
plane
Type: Autodesk.Revit.DB..::..Plane
The mirror plane.

Examples

CopyC#
public void MirrorWall(Autodesk.Revit.DB.Document document, Wall wall)
{
    Reference reference = HostObjectUtils.GetSideFaces(wall, ShellLayerType.Exterior).First();
    Face face = wall.GetGeometryObjectFromReference(reference) as Face; // get one of the wall's major side faces

    UV bboxMin = face.GetBoundingBox().Min;
    Plane plane = Plane.CreateByNormalAndOrigin(face.ComputeNormal(bboxMin), face.Evaluate(bboxMin).Add(new XYZ(10, 10, 0)));
    // create a plane based on this side face with an offset of 10 in the X & Y directions

    ElementTransformUtils.MirrorElement(document, wall.Id, plane);
}
CopyVB.NET
Public Sub MirrorWall(document As Autodesk.Revit.DB.Document, wall As Wall)
    Dim reference As Reference = HostObjectUtils.GetSideFaces(wall, ShellLayerType.Exterior).First()
    Dim face As Face = TryCast(wall.GetGeometryObjectFromReference(reference), Face)
    ' get one of the wall's major side faces
    Dim bboxMin As UV = face.GetBoundingBox().Min
 Dim plane As Plane = Autodesk.Revit.DB.Plane.CreateByNormalAndOrigin(face.ComputeNormal(bboxMin), face.Evaluate(bboxMin).Add(New XYZ(10, 10, 0)))
    ' create a plane based on this side face with an offset of 10 in the X & Y directions

    ElementTransformUtils.MirrorElement(document, wall.Id, plane)
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | elementToMirror cannot be mirrored. -or- The element elementToMirror does not exist in the document -or- The input element is a Sketch member and there is no Sketch in the edit mode to place this element in.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ElementTransformUtils Class


MirrorElements Method

[image]

Revit 2024 API
ElementTransformUtils..::..MirrorElements Method
ElementTransformUtils Class See Also Send Feedback
Mirrors a set of elements about a given plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public static IList<ElementId> MirrorElements(
    Document document,
    ICollection<ElementId> elementsToMirror,
    Plane plane,
    bool mirrorCopies
)
Visual Basic
Public Shared Function MirrorElements ( _
    document As Document, _
    elementsToMirror As ICollection(Of ElementId), _
    plane As Plane, _
    mirrorCopies As Boolean _
) As IList(Of ElementId)
Visual C++
public:
static IList<ElementId^>^ MirrorElements(
    Document^ document,
    ICollection<ElementId^>^ elementsToMirror,
    Plane^ plane,
    bool mirrorCopies
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document that owns the elements.
elementsToMirror
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
The set of elements to mirror.
plane
Type: Autodesk.Revit.DB..::..Plane
The mirror plane.
mirrorCopies
Type: System..::..Boolean
True if mirroring should be performed on copies of the elements, leaving the original elements intact. False if no copies should be created and the elements should be mirrored directly.

Return Value

A collection of ids of newly created elements - mirrored copies. It is empty if the mirrorCopies arguments is false.

Remarks

Optionally, copies of the elements can be created prior to the operation and mirroring is then performed on the copies instead of the original elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | elementsToMirror cannot be mirrored. -or- The given element id set is empty. -or- One or more elements in elementsToMirror do not exist in the document. -or- Some of the elements cannot be copied, because they belong to different views. -or- The input set of elements contains Sketch members along with other elements or there is no active Sketch edit mode.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the elements cannot be moved (e.g. due to some of the elements being pinned).

See Also

ElementTransformUtils Class


MoveElement Method

[image]

Revit 2024 API
ElementTransformUtils..::..MoveElement Method
ElementTransformUtils Class Example See Also Send Feedback
Moves one element by a given transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static void MoveElement(
    Document document,
    ElementId elementToMove,
    XYZ translation
)
Visual Basic
Public Shared Sub MoveElement ( _
    document As Document, _
    elementToMove As ElementId, _
    translation As XYZ _
)
Visual C++
public:
static void MoveElement(
    Document^ document,
    ElementId^ elementToMove,
    XYZ^ translation
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document that owns the elements.
elementToMove
Type: Autodesk.Revit.DB..::..ElementId
The id of the element to move.
translation
Type: Autodesk.Revit.DB..::..XYZ
The translation vector for the elements.

Examples

CopyC#
public void MoveColumn(Autodesk.Revit.DB.Document document, FamilyInstance column)
{
    // get the column current location
    LocationPoint columnLocation = column.Location as LocationPoint;

    XYZ oldPlace = columnLocation.Point;

    // Move the column to new location.
    XYZ newPlace = new XYZ(10, 20, 30);
    ElementTransformUtils.MoveElement(document, column.Id, newPlace);

    // now get the column's new location
    columnLocation = column.Location as LocationPoint;
    XYZ newActual = columnLocation.Point;

    string info = "Original Z location: " + oldPlace.Z +
                  "\nNew Z location: " + newActual.Z;

    TaskDialog.Show("Revit",info);
}
CopyVB.NET
Public Sub MoveColumn(document As Autodesk.Revit.DB.Document, column As FamilyInstance)
    ' get the column current location
    Dim columnLocation As LocationPoint = TryCast(column.Location, LocationPoint)

    Dim oldPlace As XYZ = columnLocation.Point

    ' Move the column to new location.
    Dim newPlace As New XYZ(10, 20, 30)
    ElementTransformUtils.MoveElement(document, column.Id, newPlace)

    ' now get the column's new location
    columnLocation = TryCast(column.Location, LocationPoint)
    Dim newActual As XYZ = columnLocation.Point

    Dim info As String = ("Original Z location: " + oldPlace.Z & vbLf & "New Z location: ") + newActual.Z

    TaskDialog.Show("Revit", info)
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element elementToMove does not exist in the document
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | If we are not able to move the element (for example, if it is pinned). -or- Move operation failed.

See Also

ElementTransformUtils Class


MoveElements Method

[image]

Revit 2024 API
ElementTransformUtils..::..MoveElements Method
ElementTransformUtils Class See Also Send Feedback
Moves a set of elements by a given transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static void MoveElements(
    Document document,
    ICollection<ElementId> elementsToMove,
    XYZ translation
)
Visual Basic
Public Shared Sub MoveElements ( _
    document As Document, _
    elementsToMove As ICollection(Of ElementId), _
    translation As XYZ _
)
Visual C++
public:
static void MoveElements(
    Document^ document,
    ICollection<ElementId^>^ elementsToMove,
    XYZ^ translation
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document that owns the elements.
elementsToMove
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
The set of elements to move.
translation
Type: Autodesk.Revit.DB..::..XYZ
The translation vector for the elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given element id set is empty. -or- One or more elements in elementsToMove do not exist in the document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | If we are not able to move all the elements (for example, if one or more elements is pinned). -or- Move operation failed.

See Also

ElementTransformUtils Class


RotateElement Method

[image]

Revit 2024 API
ElementTransformUtils..::..RotateElement Method
ElementTransformUtils Class Example See Also Send Feedback
Rotates an element about the given axis and angle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static void RotateElement(
    Document document,
    ElementId elementToRotate,
    Line axis,
    double angle
)
Visual Basic
Public Shared Sub RotateElement ( _
    document As Document, _
    elementToRotate As ElementId, _
    axis As Line, _
    angle As Double _
)
Visual C++
public:
static void RotateElement(
    Document^ document,
    ElementId^ elementToRotate,
    Line^ axis,
    double angle
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document that owns the elements.
elementToRotate
Type: Autodesk.Revit.DB..::..ElementId
The element to rotate.
axis
Type: Autodesk.Revit.DB..::..Line
The axis of rotation.
angle
Type: System..::..Double
The angle of rotation in radians.

Examples

CopyC#
public void RotateColumn(Autodesk.Revit.DB.Document document, Autodesk.Revit.DB.Element element)
{
    XYZ point1 = new XYZ(10, 20, 0);
    XYZ point2 = new XYZ(10, 20, 30);
    Line axis = Line.CreateBound(point1, point2);
    ElementTransformUtils.RotateElement(document, element.Id, axis, Math.PI / 3.0);
}
CopyVB.NET
Public Sub RotateColumn(document As Autodesk.Revit.DB.Document, element As Autodesk.Revit.DB.Element)
    Dim point1 As New XYZ(10, 20, 0)
    Dim point2 As New XYZ(10, 20, 30)
    Dim axis As Line = Line.CreateBound(point1, point2)
    ElementTransformUtils.RotateElement(document, element.Id, axis, Math.PI / 3.0)
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element elementToRotate does not exist in the document
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ElementTransformUtils Class


RotateElements Method

[image]

Revit 2024 API
ElementTransformUtils..::..RotateElements Method
ElementTransformUtils Class See Also Send Feedback
Rotates a set of elements about the given axis and angle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static void RotateElements(
    Document document,
    ICollection<ElementId> elementsToRotate,
    Line axis,
    double angle
)
Visual Basic
Public Shared Sub RotateElements ( _
    document As Document, _
    elementsToRotate As ICollection(Of ElementId), _
    axis As Line, _
    angle As Double _
)
Visual C++
public:
static void RotateElements(
    Document^ document,
    ICollection<ElementId^>^ elementsToRotate,
    Line^ axis,
    double angle
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document that owns the elements.
elementsToRotate
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
The set of elements to rotate.
axis
Type: Autodesk.Revit.DB..::..Line
The axis of rotation.
angle
Type: System..::..Double
The angle of rotation in radians.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given element id set is empty. -or- One or more elements in elementsToRotate do not exist in the document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ElementTransformUtils Class


ElementType Members

[image] [image]

Revit 2024 API
ElementType Members
ElementType Class Methods Properties See Also Send Feedback

The ElementType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element.
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type.
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy
Public property | CanBeDeleted | Determine if this ElementType can be deleted
Public property | CanBeRenamed | Determine if this ElementType can be renamed
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Gets the family name of this element type.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Overrides Element..::..Name.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ElementType Class


ElementType Methods

[image] [image]

Revit 2024 API
ElementType Methods
ElementType Class See Also Send Feedback

The ElementType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element.
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type.
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ElementType Class


Duplicate Method

[image]

Revit 2024 API
ElementType..::..Duplicate Method
ElementType Class See Also Send Feedback
Duplicates an existing element type and assigns it a new name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElementType Duplicate(
    string name
)
Visual Basic
Public Function Duplicate ( _
    name As String _
) As ElementType
Visual C++
public:
ElementType^ Duplicate(
    String^ name
)

Parameters

name
Type: System..::..String
The new name of the element type.

Return Value

The duplicated element type.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | name is an empty string. -or- name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- The element type name was empty, contained invalid characters, or was invalid for the specific element type. -or- The name is already in use for this element type.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InternalException | Duplicate element type could not be obtained.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The ElementType cannot be copied.

See Also

ElementType Class


GetSimilarTypes Method

[image]

Revit 2024 API
ElementType..::..GetSimilarTypes Method
ElementType Class See Also Send Feedback
Obtains a set of types that are similar to this type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public ICollection<ElementId> GetSimilarTypes()
Visual Basic
Public Function GetSimilarTypes As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetSimilarTypes()

Return Value

A set of element IDs of types that are similar to this type.

Remarks

Two types are similar if elements that have one type could be assigned the other type.

See Also

ElementType Class


IsSimilarType Method

[image]

Revit 2024 API
ElementType..::..IsSimilarType Method
ElementType Class See Also Send Feedback
Checks if given type is similar to this type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool IsSimilarType(
    ElementId typeId
)
Visual Basic
Public Function IsSimilarType ( _
    typeId As ElementId _
) As Boolean
Visual C++
public:
bool IsSimilarType(
    ElementId^ typeId
)

Parameters

typeId
Type: Autodesk.Revit.DB..::..ElementId
ElementId of the type to check.

Return Value

True if given type is similar to this type, false otherwise.

Remarks

Two types are similar if elements that have one type could be assigned the other type.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ElementType Class


ElementType Properties

[image] [image]

Revit 2024 API
ElementType Properties
ElementType Class See Also Send Feedback

The ElementType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy
Public property | CanBeDeleted | Determine if this ElementType can be deleted
Public property | CanBeRenamed | Determine if this ElementType can be renamed
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Gets the family name of this element type.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Overrides Element..::..Name.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ElementType Class


CanBeCopied Property

[image]

Revit 2024 API
ElementType..::..CanBeCopied Property
ElementType Class See Also Send Feedback
Determine if this ElementType can create a copy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool CanBeCopied { get; }
Visual Basic
Public ReadOnly Property CanBeCopied As Boolean
    Get
Visual C++
public:
property bool CanBeCopied {
    bool get ();
}

See Also

ElementType Class


CanBeDeleted Property

[image]

Revit 2024 API
ElementType..::..CanBeDeleted Property
ElementType Class See Also Send Feedback
Determine if this ElementType can be deleted

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool CanBeDeleted { get; }
Visual Basic
Public ReadOnly Property CanBeDeleted As Boolean
    Get
Visual C++
public:
property bool CanBeDeleted {
    bool get ();
}

See Also

ElementType Class


FamilyName Property

[image]

Revit 2024 API
ElementType..::..FamilyName Property
ElementType Class See Also Send Feedback
Gets the family name of this element type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public string FamilyName { get; }
Visual Basic
Public ReadOnly Property FamilyName As String
    Get
Visual C++
public:
property String^ FamilyName {
    String^ get ();
}

Remarks

This value is a localized string describing the family in which this ElementType belongs. For family symbols, this will be the name of the associated Family. For system family types, this will be the name used to group related types, such as "Oval Duct" or "Curtain Wall".

See Also

ElementType Class


Name Property

[image]

Revit 2024 API
ElementType..::..Name Property
ElementType Class See Also Send Feedback
Set the name for the ElementType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public override string Name { set; }
Visual Basic
Public Overrides WriteOnly Property Name As String
    Set
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Remarks

This method will assign the element type a new name.

See Also

ElementType Class


Parameter Property

[image] [image]

Revit 2024 API
ElementType..::..Parameter Property
ElementType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ElementType Class
ElementType Members


ElementWorksetFilter Class

[image]

Revit 2024 API
ElementWorksetFilter Class
Members Example See Also Send Feedback
A filter used to match elements which reside in a given workset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public class ElementWorksetFilter : ElementQuickFilter
Visual Basic
Public Class ElementWorksetFilter _
    Inherits ElementQuickFilter
Visual C++
public ref class ElementWorksetFilter : public ElementQuickFilter

Remarks

This filter is a quick filter.

Examples

CopyC#
public void WorksetElements(Document doc, Workset workset)
{
    // filter all elements that belong to the given workset
    FilteredElementCollector elementCollector = new FilteredElementCollector(doc);
    ElementWorksetFilter elementWorksetFilter = new ElementWorksetFilter(workset.Id);
    ICollection<Element> worksetElemsfounds = elementCollector.WherePasses(elementWorksetFilter).ToElements();

    // how many elements were found?
    int elementsCount = worksetElemsfounds.Count;
    String message = "Element count : " + elementsCount;

    // Get name and/or Id of the elements that pass the given filter and show a few of them
    int count = 5;  // show info for 5 elements only
    foreach (Element ele in worksetElemsfounds)
    {
        if (null != ele)
        {
           message += "\nElementId : " + ele.Id;
           message += ", Element Name : " + ele.Name;

          if (0 == --count)
              break;
        }
    }

    Autodesk.Revit.UI.TaskDialog.Show("ElementsOfWorkset", message);
}
CopyVB.NET
Public Sub WorksetElements(doc As Document, workset As Workset)
    ' filter all elements that belong to the given workset
    Dim elementCollector As New FilteredElementCollector(doc)
    Dim elementWorksetFilter As New ElementWorksetFilter(workset.Id)
    Dim worksetElemsfounds As ICollection(Of Element) = elementCollector.WherePasses(elementWorksetFilter).ToElements()

    ' how many elements were found?
    Dim elementsCount As Integer = worksetElemsfounds.Count
    Dim message As [String] = "Element count : " + elementsCount

    ' Get name and/or Id of the elements that pass the given filter and show a few of them
    Dim count As Integer = 5
    ' show info for 5 elements only
    For Each ele As Element In worksetElemsfounds
        If ele IsNot Nothing Then
            message += vbLf & "ElementId : " + ele.Id.ToString
            message += ", Element Name : " + ele.Name

            If 0 = System.Threading.Interlocked.Decrement(count) Then
                Exit For
            End If
        End If
    Next

    Autodesk.Revit.UI.TaskDialog.Show("ElementsOfWorkset", message)
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementQuickFilter
Autodesk.Revit.DB..::..ElementWorksetFilter

See Also

ElementWorksetFilter Members


ElementWorksetFilter Members

[image] [image]

Revit 2024 API
ElementWorksetFilter Members
ElementWorksetFilter Class Constructors Methods Properties See Also Send Feedback

The ElementWorksetFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ElementWorksetFilter(WorksetId) | Constructs a new instance of a filter to match elements in a given workset.
Public method | ElementWorksetFilter(WorksetId, Boolean) | Constructs a new instance of a filter to match elements in a given workset.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)
Public property | WorksetId | The workset id.

See Also

ElementWorksetFilter Class


ElementWorksetFilter Constructor

[image] [image]

Revit 2024 API
ElementWorksetFilter Constructor
ElementWorksetFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ElementWorksetFilter(WorksetId) | Constructs a new instance of a filter to match elements in a given workset.
Public method | ElementWorksetFilter(WorksetId, Boolean) | Constructs a new instance of a filter to match elements in a given workset.

See Also

ElementWorksetFilter Class
ElementWorksetFilter Members


ElementWorksetFilter Constructor (WorksetId)

[image]

Revit 2024 API
ElementWorksetFilter Constructor (WorksetId)
ElementWorksetFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements in a given workset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public ElementWorksetFilter(
    WorksetId worksetId
)
Visual Basic
Public Sub New ( _
    worksetId As WorksetId _
)
Visual C++
public:
ElementWorksetFilter(
    WorksetId^ worksetId
)

Parameters

worksetId
Type: Autodesk.Revit.DB..::..WorksetId
The workset id to match.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ElementWorksetFilter Class
ElementWorksetFilter Overload


ElementWorksetFilter Constructor (WorksetId, Boolean)

[image]

Revit 2024 API
ElementWorksetFilter Constructor (WorksetId, Boolean)
ElementWorksetFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements in a given workset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public ElementWorksetFilter(
    WorksetId worksetId,
    bool inverted
)
Visual Basic
Public Sub New ( _
    worksetId As WorksetId, _
    inverted As Boolean _
)
Visual C++
public:
ElementWorksetFilter(
    WorksetId^ worksetId,
    bool inverted
)

Parameters

worksetId
Type: Autodesk.Revit.DB..::..WorksetId
The workset id to match.
inverted
Type: System..::..Boolean
True if the filter should match all elements which are not in the given workset.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ElementWorksetFilter Class
ElementWorksetFilter Overload


ElementWorksetFilter Methods

[image] [image]

Revit 2024 API
ElementWorksetFilter Methods
ElementWorksetFilter Class See Also Send Feedback

The ElementWorksetFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ElementWorksetFilter Class


PassesFilter Method

[image] [image]

Revit 2024 API
ElementWorksetFilter..::..PassesFilter Method
ElementWorksetFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

ElementWorksetFilter Class
ElementWorksetFilter Members


ElevationMarker Members

[image] [image]

Revit 2024 API
ElevationMarker Members
ElevationMarker Class Methods Properties See Also Send Feedback

The ElevationMarker type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | CreateElevation | Creates a new elevation ViewSection on the ElevationMarker at the desired index.
 | CreateElevationMarker | Creates a new ElevationMarker.
Public method | CreateReferenceElevation | Creates a reference elevation on the ElevationMarker at the desired index.
 | CreateReferenceElevationMarker | Creates a new ElevationMarker.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetViewId | Returns the ViewSection id for the index of the ElevationMarker.
Public method | HasElevations | Returns true if the ElevationMarker has at least one elevation view, false otherwise.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsAvailableIndex | Returns true if a new elevation ViewSection can be placed at %index%, returns false otherwise.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurrentViewCount | The current number of views hosted by this ElevationMarker.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsReference | Indicates if this is a reference ElevationMarker. Only reference elevations can be hosted by reference ElevationMarkers.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MaximumViewCount | The maximum number of views that can be hosted by this ElevationMarker.
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ElevationMarker Class


CreateElevationMarker Method

[image]

Revit 2024 API
ElevationMarker..::..CreateElevationMarker Method
ElevationMarker Class See Also Send Feedback
Creates a new ElevationMarker.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static ElevationMarker CreateElevationMarker(
    Document document,
    ElementId viewFamilyTypeId,
    XYZ origin,
    int initialViewScale
)
Visual Basic
Public Shared Function CreateElevationMarker ( _
    document As Document, _
    viewFamilyTypeId As ElementId, _
    origin As XYZ, _
    initialViewScale As Integer _
) As ElevationMarker
Visual C++
public:
static ElevationMarker^ CreateElevationMarker(
    Document^ document,
    ElementId^ viewFamilyTypeId,
    XYZ^ origin,
    int initialViewScale
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new ElevationMarker will be added.
viewFamilyTypeId
Type: Autodesk.Revit.DB..::..ElementId
This ViewFamilyType will be used by all elevations hosted on the new ElevationMarker.
origin
Type: Autodesk.Revit.DB..::..XYZ
The desired origin for the ElevationMarker.
initialViewScale
Type: System..::..Int32
This view scale will be automatically applied to new elevations created on the ElevationMarker. The scale is the ratio of true model size to paper size.

Return Value

The new ElevationMarker.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This view family type is not appropriate for ElevationMarkers. -or- The denominator X of the view scale 1/X must be in the range 1 to 24,000. -or- Elevation view creation is not allowed in this family.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ElevationMarker Class


CreateReferenceElevation Method

[image]

Revit 2024 API
ElevationMarker..::..CreateReferenceElevation Method
ElevationMarker Class See Also Send Feedback
Creates a reference elevation on the ElevationMarker at the desired index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void CreateReferenceElevation(
    Document document,
    int index,
    ElementId viewIdToReference
)
Visual Basic
Public Sub CreateReferenceElevation ( _
    document As Document, _
    index As Integer, _
    viewIdToReference As ElementId _
)
Visual C++
public:
void CreateReferenceElevation(
    Document^ document,
    int index,
    ElementId^ viewIdToReference
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new reference elevation will be added.
index
Type: System..::..Int32
The index on the ElevationMarker where the reference elevation will be placed.
viewIdToReference
Type: Autodesk.Revit.DB..::..ElementId
The view which will be referenced.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId viewIdToReference does not correspond to a View. -or- This view cannot be referenced by elevations. -or- index is occupied or out of range. -or- Elevation view creation is not allowed in this family.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | Only reference elevations can be hosted on this ElevationMarker.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

ElevationMarker Class


CreateReferenceElevationMarker Method

[image]

Revit 2024 API
ElevationMarker..::..CreateReferenceElevationMarker Method
ElevationMarker Class See Also Send Feedback
Creates a new ElevationMarker.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static ElevationMarker CreateReferenceElevationMarker(
    Document document,
    ElementId viewFamilyTypeId,
    XYZ origin,
    ElementId viewPlanId
)
Visual Basic
Public Shared Function CreateReferenceElevationMarker ( _
    document As Document, _
    viewFamilyTypeId As ElementId, _
    origin As XYZ, _
    viewPlanId As ElementId _
) As ElevationMarker
Visual C++
public:
static ElevationMarker^ CreateReferenceElevationMarker(
    Document^ document,
    ElementId^ viewFamilyTypeId,
    XYZ^ origin,
    ElementId^ viewPlanId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new ElevationMarker will be added.
viewFamilyTypeId
Type: Autodesk.Revit.DB..::..ElementId
This ViewFamilyType will be used by all elevations hosted on the new ElevationMarker.
origin
Type: Autodesk.Revit.DB..::..XYZ
The desired origin for the ElevationMarker.
viewPlanId
Type: Autodesk.Revit.DB..::..ElementId
The ViewPlan in which the reference ElevationMarker will appear. Reference ElevationMarkers only appear in one view.

Return Value

The new ElevationMarker.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId viewPlanId does not correspond to a ViewPlan. -or- This view family type is not appropriate for ElevationMarkers. -or- Elevation view creation is not allowed in this family.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ElevationMarker Class


GetViewId Method

[image]

Revit 2024 API
ElevationMarker..::..GetViewId Method
ElevationMarker Class See Also Send Feedback
Returns the ViewSection id for the index of the ElevationMarker.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ElementId GetViewId(
    int index
)
Visual Basic
Public Function GetViewId ( _
    index As Integer _
) As ElementId
Visual C++
public:
ElementId^ GetViewId(
    int index
)

Parameters

index
Type: System..::..Int32
The index of the ElevationMarker for which a ViewSection id will be returned.

Return Value

ViewSection id of the view at the ElevationMarker index, invalid element id otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The index index is out of range for this ElevationMarker.

See Also

ElevationMarker Class


IsAvailableIndex Method

[image]

Revit 2024 API
ElevationMarker..::..IsAvailableIndex Method
ElevationMarker Class See Also Send Feedback
Returns true if a new elevation ViewSection can be placed at %index%, returns false otherwise.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool IsAvailableIndex(
    int index
)
Visual Basic
Public Function IsAvailableIndex ( _
    index As Integer _
) As Boolean
Visual C++
public:
bool IsAvailableIndex(
    int index
)

Parameters

index
Type: System..::..Int32
The index of the ElevationMarker which will be checked.

Return Value

True if an elevation can be created at %index%, false otherwise.

Remarks

False will be returned if the %index% is already occupied or if %index% is out of range for the ElevationMarker.

See Also

ElevationMarker Class


ElevationMarker Properties

[image] [image]

Revit 2024 API
ElevationMarker Properties
ElevationMarker Class See Also Send Feedback

The ElevationMarker type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurrentViewCount | The current number of views hosted by this ElevationMarker.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsReference | Indicates if this is a reference ElevationMarker. Only reference elevations can be hosted by reference ElevationMarkers.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MaximumViewCount | The maximum number of views that can be hosted by this ElevationMarker.
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ElevationMarker Class


Parameter Property

[image] [image]

Revit 2024 API
ElevationMarker..::..Parameter Property
ElevationMarker Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ElevationMarker Class
ElevationMarker Members


Ellipse Class

[image]

Revit 2024 API
Ellipse Class
Members See Also Send Feedback
A whole or partial ellipse.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class Ellipse : Curve
Visual Basic
Public Class Ellipse _
    Inherits Curve
Visual C++
public ref class Ellipse : public Curve

Remarks

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeometryObject
Autodesk.Revit.DB..::..Curve
Autodesk.Revit.DB..::..Ellipse

See Also

Ellipse Members


Ellipse Members

[image] [image]

Revit 2024 API
Ellipse Members
Ellipse Class Methods Properties See Also Send Feedback

The Ellipse type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns a copy of this curve. (Inherited from Curve.)
Public method | ComputeClosestPoints | Find the closest points between two curves. Closest points mean closest pairs of points, each pair consisting of a point on this, say P1, and a point on other curve, say P2. P1 and P2 are closest locally. Each pairs of closest points will be represented by the corresponding parameter values with respect to the two curves and the 3d points. A closest pair is also known as a pair of critical points of the distance function between points of the two curves. If the input parameter returnAllCriticalPoints is set to false, then the function will return only pairs with minimum distance. (Inherited from Curve.)
Public method | ComputeDerivatives | Returns the vectors describing the curve at the specified parameter. (Inherited from Curve.)
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve.)
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve.)
 | CreateCurve | Creates a new geometric ellipse or elliptical arc object.
Public method | CreateOffset | Creates a new curve that is an offset of the existing curve. (Inherited from Curve.)
Public method | CreateReversed | Creates a new curve with the opposite orientation of the existing curve. (Inherited from Curve.)
Public method | CreateTransformed | Crates a new instance of a curve as a transformation of this curve. (Inherited from Curve.)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates and returns the point that matches a parameter along the curve. (Inherited from Curve.)
Public method | GetEndParameter | Returns the raw parameter value at the start or end of this curve. (Inherited from Curve.)
Public method | GetEndPoint | Returns the 3D point at the start or end of this curve. (Inherited from Curve.)
Public method | GetEndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve.)
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve.)
Public method | IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve.)
Public method | MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve.)
Public method | MakeUnbound | Makes this curve unbound. (Inherited from Curve.)
Public method | Project | Projects the specified point on this curve. (Inherited from Curve.)
Public method | SetGraphicsStyleId | Sets the graphics style id for this curve. (Inherited from Curve.)
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
Public property | Center | Returns the center of the ellipse.
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject.)
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
Public property | IsClosed | Describes whether the curve is closed. (Inherited from Curve.)
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Length | The exact length of the curve. (Inherited from Curve.)
Public property | Normal | Returns the normal to the plane in which the ellipse is defined.
Public property | Period | The period of this curve. (Inherited from Curve.)
Public property | RadiusX | Returns the X vector radius of the ellipse.
Public property | RadiusY | Returns the Y vector radius of the ellipse.
Public property | Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Public property | Visibility | The visibility. (Inherited from GeometryObject.)
Public property | XDirection | The X direction.
Public property | YDirection | The Y direction.

See Also

Ellipse Class


Ellipse Methods

[image] [image]

Revit 2024 API
Ellipse Methods
Ellipse Class See Also Send Feedback

The Ellipse type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns a copy of this curve. (Inherited from Curve.)
Public method | ComputeClosestPoints | Find the closest points between two curves. Closest points mean closest pairs of points, each pair consisting of a point on this, say P1, and a point on other curve, say P2. P1 and P2 are closest locally. Each pairs of closest points will be represented by the corresponding parameter values with respect to the two curves and the 3d points. A closest pair is also known as a pair of critical points of the distance function between points of the two curves. If the input parameter returnAllCriticalPoints is set to false, then the function will return only pairs with minimum distance. (Inherited from Curve.)
Public method | ComputeDerivatives | Returns the vectors describing the curve at the specified parameter. (Inherited from Curve.)
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve.)
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve.)
 | CreateCurve | Creates a new geometric ellipse or elliptical arc object.
Public method | CreateOffset | Creates a new curve that is an offset of the existing curve. (Inherited from Curve.)
Public method | CreateReversed | Creates a new curve with the opposite orientation of the existing curve. (Inherited from Curve.)
Public method | CreateTransformed | Crates a new instance of a curve as a transformation of this curve. (Inherited from Curve.)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates and returns the point that matches a parameter along the curve. (Inherited from Curve.)
Public method | GetEndParameter | Returns the raw parameter value at the start or end of this curve. (Inherited from Curve.)
Public method | GetEndPoint | Returns the 3D point at the start or end of this curve. (Inherited from Curve.)
Public method | GetEndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve.)
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve.)
Public method | IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve.)
Public method | MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve.)
Public method | MakeUnbound | Makes this curve unbound. (Inherited from Curve.)
Public method | Project | Projects the specified point on this curve. (Inherited from Curve.)
Public method | SetGraphicsStyleId | Sets the graphics style id for this curve. (Inherited from Curve.)
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Ellipse Class


CreateCurve Method

[image]

Revit 2024 API
Ellipse..::..CreateCurve Method
Ellipse Class See Also Send Feedback
Creates a new geometric ellipse or elliptical arc object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017_subscription_update

Syntax

C#
public static Curve CreateCurve(
    XYZ center,
    double xRadius,
    double yRadius,
    XYZ xAxis,
    XYZ yAxis,
    double startParameter,
    double endParameter
)
Visual Basic
Public Shared Function CreateCurve ( _
    center As XYZ, _
    xRadius As Double, _
    yRadius As Double, _
    xAxis As XYZ, _
    yAxis As XYZ, _
    startParameter As Double, _
    endParameter As Double _
) As Curve
Visual C++
public:
static Curve^ CreateCurve(
    XYZ^ center,
    double xRadius,
    double yRadius,
    XYZ^ xAxis,
    XYZ^ yAxis,
    double startParameter,
    double endParameter
)

Parameters

center
Type: Autodesk.Revit.DB..::..XYZ
The center.
xRadius
Type: System..::..Double
The x vector radius of the ellipse.
yRadius
Type: System..::..Double
The y vector radius of the ellipse.
xAxis
Type: Autodesk.Revit.DB..::..XYZ
The x axis to define the ellipse plane. Must be normalized.
yAxis
Type: Autodesk.Revit.DB..::..XYZ
The y axis to define the ellipse plane. Must be normalized.
startParameter
Type: System..::..Double
The raw parameter value at the start of the ellipse.
endParameter
Type: System..::..Double
The raw parameter value at the end of the ellipse.

Return Value

The new ellipse or elliptical arc.

Remarks

If the angle range is equal to or greater than 2 * PI, the curve will be automatically converted to an unbounded ellipse. If xRadius and yRadius are almost equal, the curve will be returned as an arc.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given value for xRadius must be greater than 0 and no more than 30000 feet. -or- The given value for yRadius must be greater than 0 and no more than 30000 feet. -or- xAxis is not length 1.0. -or- yAxis is not length 1.0.
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | The vectors xAxis and yAxis are not perpendicular. -or- Start parameter must be less than end parameter. -or- Curve length is too small for Revit's tolerance (as identified by Application.ShortCurveTolerance).

See Also

Ellipse Class


IsInside Method

[image] [image]

Revit 2024 API
Ellipse..::..IsInside Method
Ellipse Class See Also Send Feedback
Indicates whether the specified parameter value is within this curve's bounds.

Overload List

 | Name | Description
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve.)
Public method | IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve.)

See Also

Ellipse Class
Ellipse Members


Ellipse Properties

[image] [image]

Revit 2024 API
Ellipse Properties
Ellipse Class See Also Send Feedback

The Ellipse type exposes the following members.

Properties

 | Name | Description
Public property | ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
Public property | Center | Returns the center of the ellipse.
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject.)
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
Public property | IsClosed | Describes whether the curve is closed. (Inherited from Curve.)
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Length | The exact length of the curve. (Inherited from Curve.)
Public property | Normal | Returns the normal to the plane in which the ellipse is defined.
Public property | Period | The period of this curve. (Inherited from Curve.)
Public property | RadiusX | Returns the X vector radius of the ellipse.
Public property | RadiusY | Returns the Y vector radius of the ellipse.
Public property | Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Public property | Visibility | The visibility. (Inherited from GeometryObject.)
Public property | XDirection | The X direction.
Public property | YDirection | The Y direction.

See Also

Ellipse Class


Center Property

[image]

Revit 2024 API
Ellipse..::..Center Property
Ellipse Class See Also Send Feedback
Returns the center of the ellipse.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ Center { get; }
Visual Basic
Public ReadOnly Property Center As XYZ
    Get
Visual C++
public:
property XYZ^ Center {
    XYZ^ get ();
}

See Also

Ellipse Class


Normal Property

[image]

Revit 2024 API
Ellipse..::..Normal Property
Ellipse Class See Also Send Feedback
Returns the normal to the plane in which the ellipse is defined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ Normal { get; }
Visual Basic
Public ReadOnly Property Normal As XYZ
    Get
Visual C++
public:
property XYZ^ Normal {
    XYZ^ get ();
}

See Also

Ellipse Class


RadiusX Property

[image]

Revit 2024 API
Ellipse..::..RadiusX Property
Ellipse Class See Also Send Feedback
Returns the X vector radius of the ellipse.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double RadiusX { get; }
Visual Basic
Public ReadOnly Property RadiusX As Double
    Get
Visual C++
public:
property double RadiusX {
    double get ();
}

See Also

Ellipse Class


YDirection Property

[image]

Revit 2024 API
Ellipse..::..YDirection Property
Ellipse Class See Also Send Feedback
The Y direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public XYZ YDirection { get; }
Visual Basic
Public ReadOnly Property YDirection As XYZ
    Get
Visual C++
public:
property XYZ^ YDirection {
    XYZ^ get ();
}

See Also

Ellipse Class


EndCapCondition Enumeration

[image]

Revit 2024 API
EndCapCondition Enumeration
See Also Send Feedback
Used by CompoundStructure to describe which shell layers participate in end wrapping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public enum EndCapCondition
Visual Basic
Public Enumeration EndCapCondition
Visual C++
public enum class EndCapCondition

Members

Member name | Description
None | None of the shell layers participate in end wrapping.
Exterior | Only the exterior shell layers participate in end wrapping.
Interior | Only the interior shell layers participate in end wrapping.
NoEndCap | No end wrapping ability. Floors and roofs must use this enum value.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


EntryAndSchemeConsistency Enumeration

[image]

Revit 2024 API
EntryAndSchemeConsistency Enumeration
See Also Send Feedback
Enumeration used to specify why an entry is inconsistent with a scheme or another entry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022
Since: 2022

Syntax

C#
public enum EntryAndSchemeConsistency
Visual Basic
Public Enumeration EntryAndSchemeConsistency
Visual C++
public enum class EntryAndSchemeConsistency

Members

Member name | Description
Consistent | The scheme entry can be applied to the scheme.
InconsistentStorageType | The type of value stored in the entry is different from the type of the scheme parameter.
ValueOutOfRange | The value stored in the entry is out of the scheme parameter range.
ValueDuplicated | There already exists another entry with the same value.
InvalidFillPatternId | The fill pattern id is not valid.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


EvaluatedParameter Class

[image]

Revit 2024 API
EvaluatedParameter Class
Members See Also Send Feedback
Hold the evaluated ParameterValue and Definition of a parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public class EvaluatedParameter : IDisposable
Visual Basic
Public Class EvaluatedParameter _
    Implements IDisposable
Visual C++
public ref class EvaluatedParameter : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..EvaluatedParameter

See Also

EvaluatedParameter Members


EvaluatedParameter Members

[image] [image]

Revit 2024 API
EvaluatedParameter Members
EvaluatedParameter Class Methods Properties See Also Send Feedback

The EvaluatedParameter type exposes the following members.

Methods

 | Name | Description
Public method | AsValueString(Document) | Get the parameter value as a string with units.
Public method | AsValueString(Document, FormatOptions) | Get the parameter value as a string with units.
Public method | Dispose | Releases all resources used by the EvaluatedParameter
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Definition | Definition of the parameter.
Public property | HasValue | This property is true when the parameter value was successfully obtained, false otherwise.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | StorageType | The storage type describes the type that is used internally within the parameter to store its value.
Public property | Value | Evaluated value of the parameter.

See Also

EvaluatedParameter Class


EvaluatedParameter Methods

[image] [image]

Revit 2024 API
EvaluatedParameter Methods
EvaluatedParameter Class See Also Send Feedback

The EvaluatedParameter type exposes the following members.

Methods

 | Name | Description
Public method | AsValueString(Document) | Get the parameter value as a string with units.
Public method | AsValueString(Document, FormatOptions) | Get the parameter value as a string with units.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

EvaluatedParameter Class


AsValueString Method

[image] [image]

Revit 2024 API
EvaluatedParameter..::..AsValueString Method
EvaluatedParameter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AsValueString(Document) | Get the parameter value as a string with units.
Public method | AsValueString(Document, FormatOptions) | Get the parameter value as a string with units.

See Also

EvaluatedParameter Class
EvaluatedParameter Members


AsValueString Method (Document)

[image]

Revit 2024 API
EvaluatedParameter..::..AsValueString Method (Document)
EvaluatedParameter Class See Also Send Feedback
Get the parameter value as a string with units.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public string AsValueString(
    Document doc
)
Visual Basic
Public Function AsValueString ( _
    doc As Document _
) As String
Visual C++
public:
String^ AsValueString(
    Document^ doc
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The document to be used to obtain information about the parameter.

Return Value

The string that represents the parameter value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

EvaluatedParameter Class
AsValueString Overload


AsValueString Method (Document, FormatOptions)

[image]

Revit 2024 API
EvaluatedParameter..::..AsValueString Method (Document, FormatOptions)
EvaluatedParameter Class See Also Send Feedback
Get the parameter value as a string with units.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public string AsValueString(
    Document doc,
    FormatOptions options
)
Visual Basic
Public Function AsValueString ( _
    doc As Document, _
    options As FormatOptions _
) As String
Visual C++
public:
String^ AsValueString(
    Document^ doc,
    FormatOptions^ options
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The document to be used to obtain information about the parameter.
options
Type: Autodesk.Revit.DB..::..FormatOptions
Options for formatting the string.

Return Value

The string that represents the parameter value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

EvaluatedParameter Class
AsValueString Overload


Dispose Method

[image]

Revit 2024 API
EvaluatedParameter..::..Dispose Method
EvaluatedParameter Class See Also Send Feedback
Releases all resources used by the EvaluatedParameter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

EvaluatedParameter Class


EvaluatedParameter Properties

[image] [image]

Revit 2024 API
EvaluatedParameter Properties
EvaluatedParameter Class See Also Send Feedback

The EvaluatedParameter type exposes the following members.

Properties

 | Name | Description
Public property | Definition | Definition of the parameter.
Public property | HasValue | This property is true when the parameter value was successfully obtained, false otherwise.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | StorageType | The storage type describes the type that is used internally within the parameter to store its value.
Public property | Value | Evaluated value of the parameter.

See Also

EvaluatedParameter Class


HasValue Property

[image]

Revit 2024 API
EvaluatedParameter..::..HasValue Property
EvaluatedParameter Class See Also Send Feedback
This property is true when the parameter value was successfully obtained, false otherwise.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public bool HasValue { get; }
Visual Basic
Public ReadOnly Property HasValue As Boolean
    Get
Visual C++
public:
property bool HasValue {
    bool get ();
}

See Also

EvaluatedParameter Class


IsValidObject Property

[image]

Revit 2024 API
EvaluatedParameter..::..IsValidObject Property
EvaluatedParameter Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

EvaluatedParameter Class


StorageType Property

[image]

Revit 2024 API
EvaluatedParameter..::..StorageType Property
EvaluatedParameter Class See Also Send Feedback
The storage type describes the type that is used internally within the parameter to store its value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public StorageType StorageType { get; }
Visual Basic
Public ReadOnly Property StorageType As StorageType
    Get
Visual C++
public:
property StorageType StorageType {
    StorageType get ();
}

Remarks

The property will return one of the following possibilities: String, Integer, Double or ElementId. Based on the value of this property the correct access and set methods should be used to retrieve and set the parameter's data value.

See Also

EvaluatedParameter Class


Value Property

[image]

Revit 2024 API
EvaluatedParameter..::..Value Property
EvaluatedParameter Class See Also Send Feedback
Evaluated value of the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public ParameterValue Value { get; }
Visual Basic
Public ReadOnly Property Value As ParameterValue
    Get
Visual C++
public:
property ParameterValue^ Value {
    ParameterValue^ get ();
}

See Also

EvaluatedParameter Class


ExclusionFilter Class

[image]

Revit 2024 API
ExclusionFilter Class
Members Example See Also Send Feedback
A filter used to exclude a set of elements automatically.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class ExclusionFilter : ElementQuickFilter
Visual Basic
Public Class ExclusionFilter _
    Inherits ElementQuickFilter
Visual C++
public ref class ExclusionFilter : public ElementQuickFilter

Remarks

This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.

Examples

CopyC#
// Use Exclusion filter to find exclude a set of elements in the document automatically

// Find all walls that are not currently selected,
// Get all element ids which are current selected by users, exclude these ids when filtering
ICollection<ElementId> selectedIds = uiDocument.Selection.GetElementIds();

// Use the selection to instantiate an exclusion filter
ExclusionFilter filter = new ExclusionFilter(selectedIds);
// For the sake of simplicity we do not test here whether the selection is empty or not,
// but in production code a proper validation would have to be done to avoid an argument
// exception from the filter's consructor.

// Apply the filter to the elements in the active document,
// Use shortcut method OfClass() to find Walls only
FilteredElementCollector collector = new FilteredElementCollector(uiDocument.Document);
IList<Element> walls = collector.WherePasses(filter).OfClass(typeof(Wall)).ToElements();
CopyVB.NET
' Use Exclusion filter to find exclude a set of elements in the document automatically

' Find all walls that are not currently selected,
' Get all element ids which are current selected by users, exclude these ids when filtering
Dim selectedIds As ICollection(Of ElementId) = uiDocument.Selection.GetElementIds()

' Use the selection to instantiate an exclusion filter
Dim filter As New ExclusionFilter(selectedIds)
' For the sake of simplicity we do not test here whether the selection is empty or not,
' but in production code a proper validation would have to be done to avoid an argument
' exception from the filter's consructor.

' Apply the filter to the elements in the active document,
' Use shortcut method OfClass() to find Walls only
Dim collector As New FilteredElementCollector(uiDocument.Document)
Dim walls As IList(Of Element) = collector.WherePasses(filter).OfClass(GetType(Wall)).ToElements()

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementQuickFilter
Autodesk.Revit.DB..::..ExclusionFilter

See Also

ExclusionFilter Members


ExclusionFilter Members

[image] [image]

Revit 2024 API
ExclusionFilter Members
ExclusionFilter Class Constructors Methods Properties See Also Send Feedback

The ExclusionFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ExclusionFilter | Constructs a new instance of a filter to exclude elements automatically.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIdsToExclude | Returns the ids to be excluded by this filter.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)

See Also

ExclusionFilter Class


ExclusionFilter Constructor

[image]

Revit 2024 API
ExclusionFilter Constructor
ExclusionFilter Class See Also Send Feedback
Constructs a new instance of a filter to exclude elements automatically.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public ExclusionFilter(
    ICollection<ElementId> idsToExclude
)
Visual Basic
Public Sub New ( _
    idsToExclude As ICollection(Of ElementId) _
)
Visual C++
public:
ExclusionFilter(
    ICollection<ElementId^>^ idsToExclude
)

Parameters

idsToExclude
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
The ids to exclude from the results.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input collection of ids was empty, or its contents were not valid for iteration.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExclusionFilter Class


ExclusionFilter Methods

[image] [image]

Revit 2024 API
ExclusionFilter Methods
ExclusionFilter Class See Also Send Feedback

The ExclusionFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIdsToExclude | Returns the ids to be excluded by this filter.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ExclusionFilter Class


PassesFilter Method

[image] [image]

Revit 2024 API
ExclusionFilter..::..PassesFilter Method
ExclusionFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

ExclusionFilter Class
ExclusionFilter Members


ExclusionFilter Properties

[image] [image]

Revit 2024 API
ExclusionFilter Properties
ExclusionFilter Class See Also Send Feedback

The ExclusionFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)

See Also

ExclusionFilter Class


ExportColorMode Enumeration

[image]

Revit 2024 API
ExportColorMode Enumeration
See Also Send Feedback
An enumerated type listing export color mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum ExportColorMode
Visual Basic
Public Enumeration ExportColorMode
Visual C++
public enum class ExportColorMode

Members

Member name | Description
IndexColors | All colors from the Revit project will be set to the closest of the 255 AutoCAD Color Index colors.
TrueColor | All colors from the Revit project will be exported as 24-bit RGB values as specified in object styles.
TrueColorPerView | All colors from the Revit project will be exported as 24-bit RGB values as specified in view.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


ExportColumnHeaders Enumeration

[image]

Revit 2024 API
ExportColumnHeaders Enumeration
See Also Send Feedback
Options for exporting column headers in schedule view export.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public enum ExportColumnHeaders
Visual Basic
Public Enumeration ExportColumnHeaders
Visual C++
public enum class ExportColumnHeaders

Members

Member name | Description
None | Do not export column headers.
OneRow | Export the column headers only.
MultipleRows | Both column headers and grouped header cells are exported.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


ExportDGNSettings Class

[image]

Revit 2024 API
ExportDGNSettings Class
Members See Also Send Feedback
This element contains DGN export settings which are saved in a Revit document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public class ExportDGNSettings : Element
Visual Basic
Public Class ExportDGNSettings _
    Inherits Element
Visual C++
public ref class ExportDGNSettings : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ExportDGNSettings

See Also

ExportDGNSettings Members


ExportDGNSettings Members

[image] [image]

Revit 2024 API
ExportDGNSettings Members
ExportDGNSettings Class Methods Properties See Also Send Feedback

The ExportDGNSettings type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create(Document, String) | Create a DGN export settings with default values.
 | Create(Document, String, DGNExportOptions) | Create DGN export settings with specified values in DGNExportOptions.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
 | FindByName | Returns the pre-defined non-in-session exporting settings for DGN in the given document with the specified name.
 | GetActivePredefinedSettings | Returns the active pre-defined non-in-session exporting settings for DGN in the given document.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetDGNExportOptions | Gets the options stored in the these settings.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
 | ListNames | Returns a list of names of dgn export settings.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetDGNExportOptions | Sets the options stored in these settings.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ExportDGNSettings Class


ExportDGNSettings Methods

[image] [image]

Revit 2024 API
ExportDGNSettings Methods
ExportDGNSettings Class See Also Send Feedback

The ExportDGNSettings type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create(Document, String) | Create a DGN export settings with default values.
 | Create(Document, String, DGNExportOptions) | Create DGN export settings with specified values in DGNExportOptions.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
 | FindByName | Returns the pre-defined non-in-session exporting settings for DGN in the given document with the specified name.
 | GetActivePredefinedSettings | Returns the active pre-defined non-in-session exporting settings for DGN in the given document.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetDGNExportOptions | Gets the options stored in the these settings.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
 | ListNames | Returns a list of names of dgn export settings.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetDGNExportOptions | Sets the options stored in these settings.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ExportDGNSettings Class


Create Method

[image] [image]

Revit 2024 API
ExportDGNSettings..::..Create Method
ExportDGNSettings Class See Also Send Feedback

Overload List

Name | Description
Create(Document, String) | Create a DGN export settings with default values.
Create(Document, String, DGNExportOptions) | Create DGN export settings with specified values in DGNExportOptions.

See Also

ExportDGNSettings Class
ExportDGNSettings Members


Create Method (Document, String)

[image]

Revit 2024 API
ExportDGNSettings..::..Create Method (Document, String)
ExportDGNSettings Class See Also Send Feedback
Create a DGN export settings with default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static ExportDGNSettings Create(
    Document document,
    string name
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    name As String _
) As ExportDGNSettings
Visual C++
public:
static ExportDGNSettings^ Create(
    Document^ document,
    String^ name
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Document where created settings is saved.
name
Type: System..::..String
The name specified to this settings.

Return Value

The new DGN export settings instance.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | ExistOrEmpty
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExportDGNSettings Class
Create Overload


Create Method (Document, String, DGNExportOptions)

[image]

Revit 2024 API
ExportDGNSettings..::..Create Method (Document, String, DGNExportOptions)
ExportDGNSettings Class See Also Send Feedback
Create DGN export settings with specified values in DGNExportOptions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static ExportDGNSettings Create(
    Document document,
    string name,
    DGNExportOptions options
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    name As String, _
    options As DGNExportOptions _
) As ExportDGNSettings
Visual C++
public:
static ExportDGNSettings^ Create(
    Document^ document,
    String^ name,
    DGNExportOptions^ options
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Document where created settings is saved.
name
Type: System..::..String
The name specified to this settings.
options
Type: Autodesk.Revit.DB..::..DGNExportOptions
The options which will be stored in these settings.

Return Value

The new DGN export settings instance.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | ExistOrEmpty
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExportDGNSettings Class
Create Overload


GetActivePredefinedSettings Method

[image]

Revit 2024 API
ExportDGNSettings..::..GetActivePredefinedSettings Method
ExportDGNSettings Class See Also Send Feedback
Returns the active pre-defined non-in-session exporting settings for DGN in the given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public static ExportDGNSettings GetActivePredefinedSettings(
    Document aDoc
)
Visual Basic
Public Shared Function GetActivePredefinedSettings ( _
    aDoc As Document _
) As ExportDGNSettings
Visual C++
public:
static ExportDGNSettings^ GetActivePredefinedSettings(
    Document^ aDoc
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
A Revit document to retrieve the active pre-defined exporting settings for DGN.

Return Value

The active pre-defined exporting settings for DGN, or null if nothing pre-defined exists or the in-session settings is selected.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExportDGNSettings Class


GetDGNExportOptions Method

[image]

Revit 2024 API
ExportDGNSettings..::..GetDGNExportOptions Method
ExportDGNSettings Class See Also Send Feedback
Gets the options stored in the these settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public DGNExportOptions GetDGNExportOptions()
Visual Basic
Public Function GetDGNExportOptions As DGNExportOptions
Visual C++
public:
DGNExportOptions^ GetDGNExportOptions()

Return Value

The options.

See Also

ExportDGNSettings Class


ListNames Method

[image]

Revit 2024 API
ExportDGNSettings..::..ListNames Method
ExportDGNSettings Class See Also Send Feedback
Returns a list of names of dgn export settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static IList<string> ListNames(
    Document aDoc
)
Visual Basic
Public Shared Function ListNames ( _
    aDoc As Document _
) As IList(Of String)
Visual C++
public:
static IList<String^>^ ListNames(
    Document^ aDoc
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
A Revit document to retrieve names from

Return Value

An array of strings representing names of predefined setups.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExportDGNSettings Class


SetDGNExportOptions Method

[image]

Revit 2024 API
ExportDGNSettings..::..SetDGNExportOptions Method
ExportDGNSettings Class See Also Send Feedback
Sets the options stored in these settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void SetDGNExportOptions(
    DGNExportOptions options
)
Visual Basic
Public Sub SetDGNExportOptions ( _
    options As DGNExportOptions _
)
Visual C++
public:
void SetDGNExportOptions(
    DGNExportOptions^ options
)

Parameters

options
Type: Autodesk.Revit.DB..::..DGNExportOptions
The options.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExportDGNSettings Class


Parameter Property

[image] [image]

Revit 2024 API
ExportDGNSettings..::..Parameter Property
ExportDGNSettings Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ExportDGNSettings Class
ExportDGNSettings Members


ExportDWGSettings Class

[image]

Revit 2024 API
ExportDWGSettings Class
Members See Also Send Feedback
This element contains DWG/DXF export settings which are saved in a Revit document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public class ExportDWGSettings : Element
Visual Basic
Public Class ExportDWGSettings _
    Inherits Element
Visual C++
public ref class ExportDWGSettings : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ExportDWGSettings

See Also

ExportDWGSettings Members


ExportDWGSettings Members

[image] [image]

Revit 2024 API
ExportDWGSettings Members
ExportDWGSettings Class Methods Properties See Also Send Feedback

The ExportDWGSettings type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create(Document, String) | Create a DWG export settings with default values.
 | Create(Document, String, DWGExportOptions) | Create a DWG export settings with default values.
 | Create(Document, String, DXFExportOptions) | Create a DWG export settings with default values.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
 | FindByName | Returns the pre-defined non-in-session exporting settings for DWG in the given document with the specified name.
 | GetActivePredefinedSettings | Returns the active pre-defined non-in-session exporting settings for DWG in the given document.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetDWGExportOptions | Gets the options stored in the these settings.
Public method | GetDXFExportOptions | Gets the options stored in the these settings.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
 | ListNames | Returns a list of names of dwg/dxf export settings.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetDWGExportOptions | Sets the options stored in these settings.
Public method | SetDXFExportOptions | Sets the options stored in these settings.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ExportDWGSettings Class


Create Method

[image] [image]

Revit 2024 API
ExportDWGSettings..::..Create Method
ExportDWGSettings Class See Also Send Feedback

Overload List

Name | Description
Create(Document, String) | Create a DWG export settings with default values.
Create(Document, String, DWGExportOptions) | Create a DWG export settings with default values.
Create(Document, String, DXFExportOptions) | Create a DWG export settings with default values.

See Also

ExportDWGSettings Class
ExportDWGSettings Members


Create Method (Document, String, DWGExportOptions)

[image]

Revit 2024 API
ExportDWGSettings..::..Create Method (Document, String, DWGExportOptions)
ExportDWGSettings Class See Also Send Feedback
Create a DWG export settings with default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static ExportDWGSettings Create(
    Document document,
    string name,
    DWGExportOptions options
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    name As String, _
    options As DWGExportOptions _
) As ExportDWGSettings
Visual C++
public:
static ExportDWGSettings^ Create(
    Document^ document,
    String^ name,
    DWGExportOptions^ options
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Document where created settings is saved.
name
Type: System..::..String
The name specified to this settings.
options
Type: Autodesk.Revit.DB..::..DWGExportOptions
Initialize settings by using values in DWGExportOptions.

Return Value

The new DWG export settings instance.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | ExistOrEmpty
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExportDWGSettings Class
Create Overload


Create Method (Document, String, DXFExportOptions)

[image]

Revit 2024 API
ExportDWGSettings..::..Create Method (Document, String, DXFExportOptions)
ExportDWGSettings Class See Also Send Feedback
Create a DWG export settings with default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static ExportDWGSettings Create(
    Document document,
    string name,
    DXFExportOptions options
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    name As String, _
    options As DXFExportOptions _
) As ExportDWGSettings
Visual C++
public:
static ExportDWGSettings^ Create(
    Document^ document,
    String^ name,
    DXFExportOptions^ options
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Document where created settings is saved.
name
Type: System..::..String
The name specified to this settings.
options
Type: Autodesk.Revit.DB..::..DXFExportOptions
Initialize settings by using values in DXFExportOptions.

Return Value

The new DWG export settings instance.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | ExistOrEmpty
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExportDWGSettings Class
Create Overload


FindByName Method

[image]

Revit 2024 API
ExportDWGSettings..::..FindByName Method
ExportDWGSettings Class See Also Send Feedback
Returns the pre-defined non-in-session exporting settings for DWG in the given document with the specified name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public static ExportDWGSettings FindByName(
    Document aDoc,
    string name
)
Visual Basic
Public Shared Function FindByName ( _
    aDoc As Document, _
    name As String _
) As ExportDWGSettings
Visual C++
public:
static ExportDWGSettings^ FindByName(
    Document^ aDoc,
    String^ name
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
A Revit document to retrieve the specified pre-defined exporting settings for DWG.
name
Type: System..::..String
The name of the settings to retrieve.

Return Value

The pre-defined DWG exporting settings, or null if nothing found that has the corresponding name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExportDWGSettings Class


GetActivePredefinedSettings Method

[image]

Revit 2024 API
ExportDWGSettings..::..GetActivePredefinedSettings Method
ExportDWGSettings Class See Also Send Feedback
Returns the active pre-defined non-in-session exporting settings for DWG in the given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public static ExportDWGSettings GetActivePredefinedSettings(
    Document aDoc
)
Visual Basic
Public Shared Function GetActivePredefinedSettings ( _
    aDoc As Document _
) As ExportDWGSettings
Visual C++
public:
static ExportDWGSettings^ GetActivePredefinedSettings(
    Document^ aDoc
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
A Revit document to retrieve the active pre-defined exporting settings for DWG.

Return Value

The active pre-defined exporting settings for DWG, or null if nothing pre-defined exists or the in-session settings is selected.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExportDWGSettings Class


GetDXFExportOptions Method

[image]

Revit 2024 API
ExportDWGSettings..::..GetDXFExportOptions Method
ExportDWGSettings Class See Also Send Feedback
Gets the options stored in the these settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public DXFExportOptions GetDXFExportOptions()
Visual Basic
Public Function GetDXFExportOptions As DXFExportOptions
Visual C++
public:
DXFExportOptions^ GetDXFExportOptions()

Return Value

The options

See Also

ExportDWGSettings Class


ListNames Method

[image]

Revit 2024 API
ExportDWGSettings..::..ListNames Method
ExportDWGSettings Class See Also Send Feedback
Returns a list of names of dwg/dxf export settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static IList<string> ListNames(
    Document aDoc
)
Visual Basic
Public Shared Function ListNames ( _
    aDoc As Document _
) As IList(Of String)
Visual C++
public:
static IList<String^>^ ListNames(
    Document^ aDoc
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
A Revit document to retrieve names from.

Return Value

An array of strings representing names of predefined setups.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExportDWGSettings Class


SetDXFExportOptions Method

[image]

Revit 2024 API
ExportDWGSettings..::..SetDXFExportOptions Method
ExportDWGSettings Class See Also Send Feedback
Sets the options stored in these settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void SetDXFExportOptions(
    DXFExportOptions options
)
Visual Basic
Public Sub SetDXFExportOptions ( _
    options As DXFExportOptions _
)
Visual C++
public:
void SetDXFExportOptions(
    DXFExportOptions^ options
)

Parameters

options
Type: Autodesk.Revit.DB..::..DXFExportOptions
The options.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExportDWGSettings Class


ExportDWGSettings Properties

[image] [image]

Revit 2024 API
ExportDWGSettings Properties
ExportDWGSettings Class See Also Send Feedback

The ExportDWGSettings type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ExportDWGSettings Class


Parameter Property

[image] [image]

Revit 2024 API
ExportDWGSettings..::..Parameter Property
ExportDWGSettings Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ExportDWGSettings Class
ExportDWGSettings Members


ExportEnergyModelType Enumeration

[image]

Revit 2024 API
ExportEnergyModelType Enumeration
See Also Send Feedback
This enum is used to define if energy model used for gbXML export should be based on rooms/spaces, building elements or analysis mode in EnergyDataSettings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public enum ExportEnergyModelType
Visual Basic
Public Enumeration ExportEnergyModelType
Visual C++
public enum class ExportEnergyModelType

Members

Member name | Description
SpatialElement | Energy model based on rooms or spaces.
BuildingElement | The building element based energy analytical model.
AnalysisMode | Energy model based on analysis mode in EnergyDataSettings.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


ExportFontInfo Class

[image]

Revit 2024 API
ExportFontInfo Class
Members See Also Send Feedback
A value used to represent the info stored in an ExportFontTable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class ExportFontInfo : IDisposable
Visual Basic
Public Class ExportFontInfo _
    Implements IDisposable
Visual C++
public ref class ExportFontInfo : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ExportFontInfo

See Also

ExportFontInfo Members


ExportFontInfo Members

[image] [image]

Revit 2024 API
ExportFontInfo Members
ExportFontInfo Class Constructors Methods Properties See Also Send Feedback

The ExportFontInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ExportFontInfo()()()() | Constructs a new default ExportFontInfo.
Public method | ExportFontInfo(String) | Constructs a new ExportFontInfo using the destination font name as input.
Public method | ExportFontInfo(ExportFontInfo) | Constructs a new copy of the input ExportFontInfo object.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ExportFontInfo
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DestinationFontName | The destination font name (the name of the font in the exported format).
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ExportFontInfo Class


ExportFontInfo Constructor

[image] [image]

Revit 2024 API
ExportFontInfo Constructor
ExportFontInfo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ExportFontInfo()()()() | Constructs a new default ExportFontInfo.
Public method | ExportFontInfo(String) | Constructs a new ExportFontInfo using the destination font name as input.
Public method | ExportFontInfo(ExportFontInfo) | Constructs a new copy of the input ExportFontInfo object.

See Also

ExportFontInfo Class
ExportFontInfo Members


ExportFontInfo Constructor

[image]

Revit 2024 API
ExportFontInfo Constructor
ExportFontInfo Class See Also Send Feedback
Constructs a new default ExportFontInfo.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ExportFontInfo()
Visual Basic
Public Sub New
Visual C++
public:
ExportFontInfo()

See Also

ExportFontInfo Class
ExportFontInfo Overload


ExportFontInfo Constructor (String)

[image]

Revit 2024 API
ExportFontInfo Constructor (String)
ExportFontInfo Class See Also Send Feedback
Constructs a new ExportFontInfo using the destination font name as input.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ExportFontInfo(
    string destinationFontName
)
Visual Basic
Public Sub New ( _
    destinationFontName As String _
)
Visual C++
public:
ExportFontInfo(
    String^ destinationFontName
)

Parameters

destinationFontName
Type: System..::..String
The destination font name (the name of the font in the exported format).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExportFontInfo Class
ExportFontInfo Overload


ExportFontInfo Constructor (ExportFontInfo)

[image]

Revit 2024 API
ExportFontInfo Constructor (ExportFontInfo)
ExportFontInfo Class See Also Send Feedback
Constructs a new copy of the input ExportFontInfo object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ExportFontInfo(
    ExportFontInfo other
)
Visual Basic
Public Sub New ( _
    other As ExportFontInfo _
)
Visual C++
public:
ExportFontInfo(
    ExportFontInfo^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..ExportFontInfo

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExportFontInfo Class
ExportFontInfo Overload


Dispose Method

[image]

Revit 2024 API
ExportFontInfo..::..Dispose Method
ExportFontInfo Class See Also Send Feedback
Releases all resources used by the ExportFontInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ExportFontInfo Class


ExportFontInfo Properties

[image] [image]

Revit 2024 API
ExportFontInfo Properties
ExportFontInfo Class See Also Send Feedback

The ExportFontInfo type exposes the following members.

Properties

 | Name | Description
Public property | DestinationFontName | The destination font name (the name of the font in the exported format).
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ExportFontInfo Class


DestinationFontName Property

[image]

Revit 2024 API
ExportFontInfo..::..DestinationFontName Property
ExportFontInfo Class See Also Send Feedback
The destination font name (the name of the font in the exported format).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public string DestinationFontName { get; set; }
Visual Basic
Public Property DestinationFontName As String
    Get
    Set
Visual C++
public:
property String^ DestinationFontName {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ExportFontInfo Class


IsValidObject Property

[image]

Revit 2024 API
ExportFontInfo..::..IsValidObject Property
ExportFontInfo Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ExportFontInfo Class


ExportFontKey Class

[image]

Revit 2024 API
ExportFontKey Class
Members See Also Send Feedback
A key used to represent an item stored in an ExportFontTable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class ExportFontKey : IDisposable
Visual Basic
Public Class ExportFontKey _
    Implements IDisposable
Visual C++
public ref class ExportFontKey : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ExportFontKey

See Also

ExportFontKey Members


ExportFontKey Constructor

[image]

Revit 2024 API
ExportFontKey Constructor
ExportFontKey Class See Also Send Feedback
Constructs a new default ExportFontKey.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ExportFontKey()
Visual Basic
Public Sub New
Visual C++
public:
ExportFontKey()

See Also

ExportFontKey Class
ExportFontKey Overload


ExportFontKey Constructor (String)

[image]

Revit 2024 API
ExportFontKey Constructor (String)
ExportFontKey Class See Also Send Feedback
Constructs a new ExportFontKey using an input font name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ExportFontKey(
    string originalFontName
)
Visual Basic
Public Sub New ( _
    originalFontName As String _
)
Visual C++
public:
ExportFontKey(
    String^ originalFontName
)

Parameters

originalFontName
Type: System..::..String
The original font name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExportFontKey Class
ExportFontKey Overload


ExportFontKey Constructor (ExportFontKey)

[image]

Revit 2024 API
ExportFontKey Constructor (ExportFontKey)
ExportFontKey Class See Also Send Feedback
Constructs a new copy of the input ExportFontKey object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ExportFontKey(
    ExportFontKey other
)
Visual Basic
Public Sub New ( _
    other As ExportFontKey _
)
Visual C++
public:
ExportFontKey(
    ExportFontKey^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..ExportFontKey

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExportFontKey Class
ExportFontKey Overload


ExportFontKey Methods

[image] [image]

Revit 2024 API
ExportFontKey Methods
ExportFontKey Class See Also Send Feedback

The ExportFontKey type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ExportFontKey Class


Dispose Method

[image]

Revit 2024 API
ExportFontKey..::..Dispose Method
ExportFontKey Class See Also Send Feedback
Releases all resources used by the ExportFontKey

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ExportFontKey Class


ExportFontKey Properties

[image] [image]

Revit 2024 API
ExportFontKey Properties
ExportFontKey Class See Also Send Feedback

The ExportFontKey type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OriginalFontName | The original font name.

See Also

ExportFontKey Class


OriginalFontName Property

[image]

Revit 2024 API
ExportFontKey..::..OriginalFontName Property
ExportFontKey Class See Also Send Feedback
The original font name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public string OriginalFontName { get; set; }
Visual Basic
Public Property OriginalFontName As String
    Get
    Set
Visual C++
public:
property String^ OriginalFontName {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ExportFontKey Class


ExportFontTable Class

[image]

Revit 2024 API
ExportFontTable Class
Members See Also Send Feedback
A table supporting a mapping of Revit font names to font names that will be set in the target export format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class ExportFontTable : IEnumerable<KeyValuePair<ExportFontKey, ExportFontInfo>>,
    IDisposable
Visual Basic
Public Class ExportFontTable _
    Implements IEnumerable(Of KeyValuePair(Of ExportFontKey, ExportFontInfo)),  _
    IDisposable
Visual C++
public ref class ExportFontTable : IEnumerable<KeyValuePair<ExportFontKey^, ExportFontInfo^>>,
    IDisposable

Remarks

This table is structured as a mapping from ExportFontKey to ExportFontInfo members. The ExportFontKey contains the identification information for the font table: the Revit font name. The ExportFontInfo contains the font name to use in the export format.

The table can be accessed via direct iteration as a collection of KeyValuePairs, or by traversal of the stored keys obtained from GetKeys(), or via specific lookup of a key constructed externally. In all cases, the ExportFontInfo returned will be a copy of the ExportFontInfo from the table. In order to make changes to the ExportFontInfo and use those settings during export, set the modified ExportFontInfo back into the table using the same key.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ExportFontTable

See Also

ExportFontTable Members


ExportFontTable Members

[image] [image]

Revit 2024 API
ExportFontTable Members
ExportFontTable Class Constructors Methods Properties See Also Send Feedback

The ExportFontTable type exposes the following members.

Constructors

 | Name | Description
Public method | ExportFontTable | Constructs a new ExportFontTable with default values.

Methods

 | Name | Description
Public method | Add | Inserts a (key,info) pair into Export font table.
Public method | Clear | Removes all contents stored in the table.
Public method | ContainsKey | Checks whether a font key exists in the table.
Public method | Dispose | Releases all resources used by the ExportFontTable
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetExportFontInfo | Gets a copy of the font info associated to the input font key.
Public method | GetFontTableIterator | Returns a FontTableIterator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetKeys | Returns a collection of the keys stored in this table.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValues | Returns a collection of the values stored in this table.
Public method | Remove | Removes the pair (key, info) by font key.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Count of the items contained in the collection.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Item | A copy of the ExportFontInfo for the font's ExportFontKey.

See Also

ExportFontTable Class


ExportFontTable Constructor

[image]

Revit 2024 API
ExportFontTable Constructor
ExportFontTable Class See Also Send Feedback
Constructs a new ExportFontTable with default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ExportFontTable()
Visual Basic
Public Sub New
Visual C++
public:
ExportFontTable()

See Also

ExportFontTable Class


Add Method

[image]

Revit 2024 API
ExportFontTable..::..Add Method
ExportFontTable Class See Also Send Feedback
Inserts a (key,info) pair into Export font table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void Add(
    ExportFontKey exportFontKey,
    ExportFontInfo exportFontInfo
)
Visual Basic
Public Sub Add ( _
    exportFontKey As ExportFontKey, _
    exportFontInfo As ExportFontInfo _
)
Visual C++
public:
void Add(
    ExportFontKey^ exportFontKey,
    ExportFontInfo^ exportFontInfo
)

Parameters

exportFontKey
Type: Autodesk.Revit.DB..::..ExportFontKey
The export font key to be added.
exportFontInfo
Type: Autodesk.Revit.DB..::..ExportFontInfo
The export font info to be added.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The key already exists in the table.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExportFontTable Class


Clear Method

[image]

Revit 2024 API
ExportFontTable..::..Clear Method
ExportFontTable Class See Also Send Feedback
Removes all contents stored in the table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

See Also

ExportFontTable Class


ContainsKey Method

[image]

Revit 2024 API
ExportFontTable..::..ContainsKey Method
ExportFontTable Class See Also Send Feedback
Checks whether a font key exists in the table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool ContainsKey(
    ExportFontKey exportfontKey
)
Visual Basic
Public Function ContainsKey ( _
    exportfontKey As ExportFontKey _
) As Boolean
Visual C++
public:
bool ContainsKey(
    ExportFontKey^ exportfontKey
)

Parameters

exportfontKey
Type: Autodesk.Revit.DB..::..ExportFontKey
The export font Key.

Return Value

True if the font key exists in the table.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExportFontTable Class


Dispose Method

[image]

Revit 2024 API
ExportFontTable..::..Dispose Method
ExportFontTable Class See Also Send Feedback
Releases all resources used by the ExportFontTable

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ExportFontTable Class


GetBasicIEnumerator Method

[image]

Revit 2024 API
ExportFontTable..::..GetBasicIEnumerator Method
ExportFontTable Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
internal virtual IEnumerator GetBasicIEnumerator()
Visual Basic
Friend Overridable Function GetBasicIEnumerator As IEnumerator
Visual C++
internal:
virtual IEnumerator^ GetBasicIEnumerator()

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

ExportFontTable Class


GetEnumerator Method

[image]

Revit 2024 API
ExportFontTable..::..GetEnumerator Method
ExportFontTable Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IEnumerator<KeyValuePair<ExportFontKey, ExportFontInfo>> GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator(Of KeyValuePair(Of ExportFontKey, ExportFontInfo))
Visual C++
public:
virtual IEnumerator<KeyValuePair<ExportFontKey^, ExportFontInfo^>>^ GetEnumerator()

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

ExportFontTable Class


GetFontTableIterator Method

[image]

Revit 2024 API
ExportFontTable..::..GetFontTableIterator Method
ExportFontTable Class See Also Send Feedback
Returns a FontTableIterator that iterates through the collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ExportFontTableIterator GetFontTableIterator()
Visual Basic
Public Function GetFontTableIterator As ExportFontTableIterator
Visual C++
public:
ExportFontTableIterator^ GetFontTableIterator()

Return Value

A FontTableIterator object that can be used to iterate through key-value pairs in the collection.

See Also

ExportFontTable Class


GetKeys Method

[image]

Revit 2024 API
ExportFontTable..::..GetKeys Method
ExportFontTable Class See Also Send Feedback
Returns a collection of the keys stored in this table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public IList<ExportFontKey> GetKeys()
Visual Basic
Public Function GetKeys As IList(Of ExportFontKey)
Visual C++
public:
IList<ExportFontKey^>^ GetKeys()

Return Value

The collection of keys.

See Also

ExportFontTable Class


Remove Method

[image]

Revit 2024 API
ExportFontTable..::..Remove Method
ExportFontTable Class See Also Send Feedback
Removes the pair (key, info) by font key.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void Remove(
    ExportFontKey exportFontKey
)
Visual Basic
Public Sub Remove ( _
    exportFontKey As ExportFontKey _
)
Visual C++
public:
void Remove(
    ExportFontKey^ exportFontKey
)

Parameters

exportFontKey
Type: Autodesk.Revit.DB..::..ExportFontKey
The export font key.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExportFontTable Class


ExportFontTable Properties

[image] [image]

Revit 2024 API
ExportFontTable Properties
ExportFontTable Class See Also Send Feedback

The ExportFontTable type exposes the following members.

Properties

 | Name | Description
Public property | Count | Count of the items contained in the collection.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Item | A copy of the ExportFontInfo for the font's ExportFontKey.

See Also

ExportFontTable Class


Count Property

[image]

Revit 2024 API
ExportFontTable..::..Count Property
ExportFontTable Class See Also Send Feedback
Count of the items contained in the collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get
Visual C++
public:
property int Count {
    int get ();
}

See Also

ExportFontTable Class


ExportFontTableIterator Class

[image]

Revit 2024 API
ExportFontTableIterator Class
Members See Also Send Feedback
An iterator to a set of font table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class ExportFontTableIterator : IEnumerator<KeyValuePair<ExportFontKey, ExportFontInfo>>
Visual Basic
Public Class ExportFontTableIterator _
    Implements IEnumerator(Of KeyValuePair(Of ExportFontKey, ExportFontInfo))
Visual C++
public ref class ExportFontTableIterator : IEnumerator<KeyValuePair<ExportFontKey^, ExportFontInfo^>>

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ExportFontTableIterator

See Also

ExportFontTableIterator Members


ExportFontTableIterator Members

[image] [image]

Revit 2024 API
ExportFontTableIterator Members
ExportFontTableIterator Class Methods Properties See Also Send Feedback

The ExportFontTableIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ExportFontTableIterator
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next item.
Public method | Reset | Resets the iterator to the initial state.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ExportFontTableIterator Class


ExportFontTableIterator Methods

[image] [image]

Revit 2024 API
ExportFontTableIterator Methods
ExportFontTableIterator Class See Also Send Feedback

The ExportFontTableIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next item.
Public method | Reset | Resets the iterator to the initial state.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ExportFontTableIterator Class


Dispose Method

[image]

Revit 2024 API
ExportFontTableIterator..::..Dispose Method
ExportFontTableIterator Class See Also Send Feedback
Releases all resources used by the ExportFontTableIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

See Also

ExportFontTableIterator Class


IsDone Method

[image]

Revit 2024 API
ExportFontTableIterator..::..IsDone Method
ExportFontTableIterator Class See Also Send Feedback
Identifies if the iteration has completed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public virtual bool IsDone()
Visual Basic
Public Overridable Function IsDone As Boolean
Visual C++
public:
virtual bool IsDone()

Return Value

True if the iteration has no more items. False if there are more items to be iterated.

See Also

ExportFontTableIterator Class


MoveNext Method

[image]

Revit 2024 API
ExportFontTableIterator..::..MoveNext Method
ExportFontTableIterator Class See Also Send Feedback
Increments the iterator to the next item.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

True if there is a next available item in this iterator. False if the iterator has completed all available items.

See Also

ExportFontTableIterator Class


ExportFontTableIterator Properties

[image] [image]

Revit 2024 API
ExportFontTableIterator Properties
ExportFontTableIterator Class See Also Send Feedback

The ExportFontTableIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ExportFontTableIterator Class


Current Property

[image]

Revit 2024 API
ExportFontTableIterator..::..Current Property
ExportFontTableIterator Class See Also Send Feedback
Gets the item at the current position of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual KeyValuePair<ExportFontKey, ExportFontInfo> Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As KeyValuePair(Of ExportFontKey, ExportFontInfo)
    Get
Visual C++
public:
virtual property KeyValuePair<ExportFontKey^, ExportFontInfo^> Current {
    KeyValuePair<ExportFontKey^, ExportFontInfo^> get ();
}

Implements

IEnumerator<(Of <(<'T>)>)>..::..Current

Remarks

There is no current item if the iterator has not started yet or has been done.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | There is no current item in the iterator.

See Also

ExportFontTableIterator Class


CurrentObject Property

[image]

Revit 2024 API
ExportFontTableIterator..::..CurrentObject Property
ExportFontTableIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
internal Object CurrentObject { get; }
Visual Basic
Friend ReadOnly Property CurrentObject As Object
    Get
Visual C++
internal:
virtual property Object^ CurrentObject {
    Object^ get () sealed;
}

Implements

IEnumerator..::..Current

See Also

ExportFontTableIterator Class


IsValidObject Property

[image]

Revit 2024 API
ExportFontTableIterator..::..IsValidObject Property
ExportFontTableIterator Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ExportFontTableIterator Class


ExportLayerInfo Class

[image]

Revit 2024 API
ExportLayerInfo Class
Members Example See Also Send Feedback
A value used to represent the info stored in the ExportLayerTable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class ExportLayerInfo : IDisposable
Visual Basic
Public Class ExportLayerInfo _
    Implements IDisposable
Visual C++
public ref class ExportLayerInfo : IDisposable

Examples

CopyC#
public bool ExportDWGModifyLayerTable(Document document, View view)
{
    bool exported = false;
    IList<string> setupNames = BaseExportOptions.GetPredefinedSetupNames(document);
    if (setupNames.Count > 0)
    {
        // Get the export options for the first predefined setup
        DWGExportOptions dwgOptions = DWGExportOptions.GetPredefinedOptions(document, setupNames[0]);

        // Get the export layer table
        ExportLayerTable layerTable = dwgOptions.GetExportLayerTable();

        // Find the first mapping for the Ceilings category
        string category = "Ceilings";
        ExportLayerKey targetKey = layerTable.GetKeys().First<ExportLayerKey>(layerKey => layerKey.CategoryName == category);
        ExportLayerInfo targetInfo = layerTable[targetKey];

        // change the color name and cut color number for this mapping
        targetInfo.ColorName = "31";
        targetInfo.CutColorNumber = 31;

        // Set the change back to the map
        layerTable[targetKey] = targetInfo;

        // Set the modified table back to the options
        dwgOptions.SetExportLayerTable(layerTable);

        ICollection<ElementId> views = new List<ElementId>();
        views.Add(view.Id);

        exported = document.Export(Path.GetDirectoryName(document.PathName),
            Path.GetFileNameWithoutExtension(document.PathName), views, dwgOptions);
    }

    return exported;
}
CopyVB.NET
Public Function ExportDWGModifyLayerTable(document As Document, view As View) As Boolean
   Dim exported As Boolean = False
   Dim setupNames As IList(Of String) = BaseExportOptions.GetPredefinedSetupNames(document)
   If setupNames.Count > 0 Then
      ' Get the export options for the first predefined setup
      Dim dwgOptions As DWGExportOptions = DWGExportOptions.GetPredefinedOptions(document, setupNames(0))

      ' Get the export layer table
      Dim layerTable As ExportLayerTable = dwgOptions.GetExportLayerTable()

      ' Find the first mapping for the Ceilings category
      Dim category As String = "Ceilings"
      Dim targetKey As ExportLayerKey = layerTable.GetKeys().First(Function(layerKey) layerKey.CategoryName = category)
      Dim targetInfo As ExportLayerInfo = layerTable(targetKey)

      ' change the color name and cut color number for this mapping
      targetInfo.ColorName = "31"
      targetInfo.CutColorNumber = 31

      ' Set the change back to the map
      layerTable(targetKey) = targetInfo

      ' Set the modified table back to the options
      dwgOptions.SetExportLayerTable(layerTable)

      Dim views As ICollection(Of ElementId) = New List(Of ElementId)()
      views.Add(view.Id)

      exported = document.Export(Path.GetDirectoryName(document.PathName), Path.GetFileNameWithoutExtension(document.PathName), views, dwgOptions)
   End If

   Return exported
End Function

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ExportLayerInfo

See Also

ExportLayerInfo Members


ExportLayerInfo Members

[image] [image]

Revit 2024 API
ExportLayerInfo Members
ExportLayerInfo Class Constructors Methods Properties See Also Send Feedback

The ExportLayerInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ExportLayerInfo | Constructs a new ExportLayerInfo with default values.

Methods

 | Name | Description
Public method | AddCutLayerModifier | Adds a cut layer modifier to the layer info.
Public method | AddLayerModifier | Adds a project layer modifier to the layer info.
Public method | ClearCutLayerModifiers | Clears all the cut layer modifiers stored in the layer info.
Public method | ClearLayerModifiers | Clears all the project layer modifiers stored in the layer info.
Public method | Dispose | Releases all resources used by the ExportLayerInfo
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCutLayerModifiers | Gets all the cut layer modifiers from the layer info.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLayerModifiers | Gets all the project layer modifiers from the layer info.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveCutLayerModifier | Removes a cut layer modifier from the layer info.
Public method | RemoveLayerModifier | Removes a project layer modifier from the layer info.
Public method | SetCutLayerModifiers | Sets a cut layer modifier array to the layer info.
Public method | SetLayerModifiers | Sets a project layer modifier array to the layer info.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CategoryType | The category type which this layer belongs to.
Public property | ColorName | The color name stored in value. For IFC export, the naming is to match the "colornumber" setting -- really, this stores a string that generates the colorNumber (for formats that don't use the color but need a second entry.)
Public property | ColorNumber | The color number stored in value.
Public property | CutColorNumber | The cut color number stored in value.
Public property | CutLayerName | The cut layer name stored in value.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LayerName | The layer name stored in value.

See Also

ExportLayerInfo Class


ExportLayerInfo Constructor

[image]

Revit 2024 API
ExportLayerInfo Constructor
ExportLayerInfo Class See Also Send Feedback
Constructs a new ExportLayerInfo with default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ExportLayerInfo()
Visual Basic
Public Sub New
Visual C++
public:
ExportLayerInfo()

See Also

ExportLayerInfo Class


ExportLayerInfo Methods

[image] [image]

Revit 2024 API
ExportLayerInfo Methods
ExportLayerInfo Class See Also Send Feedback

The ExportLayerInfo type exposes the following members.

Methods

 | Name | Description
Public method | AddCutLayerModifier | Adds a cut layer modifier to the layer info.
Public method | AddLayerModifier | Adds a project layer modifier to the layer info.
Public method | ClearCutLayerModifiers | Clears all the cut layer modifiers stored in the layer info.
Public method | ClearLayerModifiers | Clears all the project layer modifiers stored in the layer info.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCutLayerModifiers | Gets all the cut layer modifiers from the layer info.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLayerModifiers | Gets all the project layer modifiers from the layer info.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveCutLayerModifier | Removes a cut layer modifier from the layer info.
Public method | RemoveLayerModifier | Removes a project layer modifier from the layer info.
Public method | SetCutLayerModifiers | Sets a cut layer modifier array to the layer info.
Public method | SetLayerModifiers | Sets a project layer modifier array to the layer info.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ExportLayerInfo Class


AddCutLayerModifier Method

[image]

Revit 2024 API
ExportLayerInfo..::..AddCutLayerModifier Method
ExportLayerInfo Class See Also Send Feedback
Adds a cut layer modifier to the layer info.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void AddCutLayerModifier(
    LayerModifier layerModifier
)
Visual Basic
Public Sub AddCutLayerModifier ( _
    layerModifier As LayerModifier _
)
Visual C++
public:
void AddCutLayerModifier(
    LayerModifier^ layerModifier
)

Parameters

layerModifier
Type: Autodesk.Revit.DB..::..LayerModifier
The cut layer modifier.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The separator string contains one or more prohibited characters. -or- The modifier type already exists in the cut layer info.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExportLayerInfo Class


AddLayerModifier Method

[image]

Revit 2024 API
ExportLayerInfo..::..AddLayerModifier Method
ExportLayerInfo Class See Also Send Feedback
Adds a project layer modifier to the layer info.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void AddLayerModifier(
    LayerModifier layerModifier
)
Visual Basic
Public Sub AddLayerModifier ( _
    layerModifier As LayerModifier _
)
Visual C++
public:
void AddLayerModifier(
    LayerModifier^ layerModifier
)

Parameters

layerModifier
Type: Autodesk.Revit.DB..::..LayerModifier
The project layer modifier.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The separator string contains one or more prohibited characters. -or- The modifier type already exists in the layer info.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExportLayerInfo Class


ClearCutLayerModifiers Method

[image]

Revit 2024 API
ExportLayerInfo..::..ClearCutLayerModifiers Method
ExportLayerInfo Class See Also Send Feedback
Clears all the cut layer modifiers stored in the layer info.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void ClearCutLayerModifiers()
Visual Basic
Public Sub ClearCutLayerModifiers
Visual C++
public:
void ClearCutLayerModifiers()

See Also

ExportLayerInfo Class


ClearLayerModifiers Method

[image]

Revit 2024 API
ExportLayerInfo..::..ClearLayerModifiers Method
ExportLayerInfo Class See Also Send Feedback
Clears all the project layer modifiers stored in the layer info.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void ClearLayerModifiers()
Visual Basic
Public Sub ClearLayerModifiers
Visual C++
public:
void ClearLayerModifiers()

See Also

ExportLayerInfo Class


Dispose Method

[image]

Revit 2024 API
ExportLayerInfo..::..Dispose Method
ExportLayerInfo Class See Also Send Feedback
Releases all resources used by the ExportLayerInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ExportLayerInfo Class


GetCutLayerModifiers Method

[image]

Revit 2024 API
ExportLayerInfo..::..GetCutLayerModifiers Method
ExportLayerInfo Class See Also Send Feedback
Gets all the cut layer modifiers from the layer info.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public IList<LayerModifier> GetCutLayerModifiers()
Visual Basic
Public Function GetCutLayerModifiers As IList(Of LayerModifier)
Visual C++
public:
IList<LayerModifier^>^ GetCutLayerModifiers()

Return Value

The cut layer modifier array.

See Also

ExportLayerInfo Class


GetLayerModifiers Method

[image]

Revit 2024 API
ExportLayerInfo..::..GetLayerModifiers Method
ExportLayerInfo Class See Also Send Feedback
Gets all the project layer modifiers from the layer info.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public IList<LayerModifier> GetLayerModifiers()
Visual Basic
Public Function GetLayerModifiers As IList(Of LayerModifier)
Visual C++
public:
IList<LayerModifier^>^ GetLayerModifiers()

Return Value

The project layer modifier array.

See Also

ExportLayerInfo Class


RemoveCutLayerModifier Method

[image]

Revit 2024 API
ExportLayerInfo..::..RemoveCutLayerModifier Method
ExportLayerInfo Class See Also Send Feedback
Removes a cut layer modifier from the layer info.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void RemoveCutLayerModifier(
    LayerModifier layerModifier
)
Visual Basic
Public Sub RemoveCutLayerModifier ( _
    layerModifier As LayerModifier _
)
Visual C++
public:
void RemoveCutLayerModifier(
    LayerModifier^ layerModifier
)

Parameters

layerModifier
Type: Autodesk.Revit.DB..::..LayerModifier
The cut layer modifier.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExportLayerInfo Class


SetCutLayerModifiers Method

[image]

Revit 2024 API
ExportLayerInfo..::..SetCutLayerModifiers Method
ExportLayerInfo Class See Also Send Feedback
Sets a cut layer modifier array to the layer info.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void SetCutLayerModifiers(
    IList<LayerModifier> cutLayermodifiers
)
Visual Basic
Public Sub SetCutLayerModifiers ( _
    cutLayermodifiers As IList(Of LayerModifier) _
)
Visual C++
public:
void SetCutLayerModifiers(
    IList<LayerModifier^>^ cutLayermodifiers
)

Parameters

cutLayermodifiers
Type: System.Collections.Generic..::..IList<(Of <(<' LayerModifier >)>)>
The cut layer modifier array.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExportLayerInfo Class


SetLayerModifiers Method

[image]

Revit 2024 API
ExportLayerInfo..::..SetLayerModifiers Method
ExportLayerInfo Class See Also Send Feedback
Sets a project layer modifier array to the layer info.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void SetLayerModifiers(
    IList<LayerModifier> layermodifiers
)
Visual Basic
Public Sub SetLayerModifiers ( _
    layermodifiers As IList(Of LayerModifier) _
)
Visual C++
public:
void SetLayerModifiers(
    IList<LayerModifier^>^ layermodifiers
)

Parameters

layermodifiers
Type: System.Collections.Generic..::..IList<(Of <(<' LayerModifier >)>)>
The project layer modifier array.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExportLayerInfo Class


ExportLayerInfo Properties

[image] [image]

Revit 2024 API
ExportLayerInfo Properties
ExportLayerInfo Class See Also Send Feedback

The ExportLayerInfo type exposes the following members.

Properties

 | Name | Description
Public property | CategoryType | The category type which this layer belongs to.
Public property | ColorName | The color name stored in value. For IFC export, the naming is to match the "colornumber" setting -- really, this stores a string that generates the colorNumber (for formats that don't use the color but need a second entry.)
Public property | ColorNumber | The color number stored in value.
Public property | CutColorNumber | The cut color number stored in value.
Public property | CutLayerName | The cut layer name stored in value.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LayerName | The layer name stored in value.

See Also

ExportLayerInfo Class


ColorName Property

[image]

Revit 2024 API
ExportLayerInfo..::..ColorName Property
ExportLayerInfo Class See Also Send Feedback
The color name stored in value. For IFC export, the naming is to match the "colornumber" setting -- really, this stores a string that generates the colorNumber (for formats that don't use the color but need a second entry.)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public string ColorName { get; set; }
Visual Basic
Public Property ColorName As String
    Get
    Set
Visual C++
public:
property String^ ColorName {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ExportLayerInfo Class


ColorNumber Property

[image]

Revit 2024 API
ExportLayerInfo..::..ColorNumber Property
ExportLayerInfo Class See Also Send Feedback
The color number stored in value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public int ColorNumber { get; set; }
Visual Basic
Public Property ColorNumber As Integer
    Get
    Set
Visual C++
public:
property int ColorNumber {
    int get ();
    void set (int value);
}

See Also

ExportLayerInfo Class


CutColorNumber Property

[image]

Revit 2024 API
ExportLayerInfo..::..CutColorNumber Property
ExportLayerInfo Class See Also Send Feedback
The cut color number stored in value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public int CutColorNumber { get; set; }
Visual Basic
Public Property CutColorNumber As Integer
    Get
    Set
Visual C++
public:
property int CutColorNumber {
    int get ();
    void set (int value);
}

See Also

ExportLayerInfo Class


CutLayerName Property

[image]

Revit 2024 API
ExportLayerInfo..::..CutLayerName Property
ExportLayerInfo Class See Also Send Feedback
The cut layer name stored in value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public string CutLayerName { get; set; }
Visual Basic
Public Property CutLayerName As String
    Get
    Set
Visual C++
public:
property String^ CutLayerName {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ExportLayerInfo Class


LayerName Property

[image]

Revit 2024 API
ExportLayerInfo..::..LayerName Property
ExportLayerInfo Class See Also Send Feedback
The layer name stored in value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public string LayerName { get; set; }
Visual Basic
Public Property LayerName As String
    Get
    Set
Visual C++
public:
property String^ LayerName {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ExportLayerInfo Class


ExportLayerKey Class

[image]

Revit 2024 API
ExportLayerKey Class
Members See Also Send Feedback
A key used to represent an item stored in an ExportLayerTable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class ExportLayerKey : IDisposable
Visual Basic
Public Class ExportLayerKey _
    Implements IDisposable
Visual C++
public ref class ExportLayerKey : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ExportLayerKey

See Also

ExportLayerKey Members


ExportLayerKey Members

[image] [image]

Revit 2024 API
ExportLayerKey Members
ExportLayerKey Class Constructors Methods Properties See Also Send Feedback

The ExportLayerKey type exposes the following members.

Constructors

 | Name | Description
Public method | ExportLayerKey()()()() | Constructs a new ExportLayerKey with default values.
Public method | ExportLayerKey(String, String, SpecialType) | Constructs a new ExportLayerKey with categoryName, subCategoryName and a special type.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ExportLayerKey
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CategoryName | The category name.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SpecialType | The special type for layer key.
Public property | SubCategoryName | The subcategrory Name.

See Also

ExportLayerKey Class


ExportLayerKey Constructor

[image] [image]

Revit 2024 API
ExportLayerKey Constructor
ExportLayerKey Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ExportLayerKey()()()() | Constructs a new ExportLayerKey with default values.
Public method | ExportLayerKey(String, String, SpecialType) | Constructs a new ExportLayerKey with categoryName, subCategoryName and a special type.

See Also

ExportLayerKey Class
ExportLayerKey Members


ExportLayerKey Constructor

[image]

Revit 2024 API
ExportLayerKey Constructor
ExportLayerKey Class See Also Send Feedback
Constructs a new ExportLayerKey with default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ExportLayerKey()
Visual Basic
Public Sub New
Visual C++
public:
ExportLayerKey()

See Also

ExportLayerKey Class
ExportLayerKey Overload


ExportLayerKey Constructor (String, String, SpecialType)

[image]

Revit 2024 API
ExportLayerKey Constructor (String, String, SpecialType)
ExportLayerKey Class See Also Send Feedback
Constructs a new ExportLayerKey with categoryName, subCategoryName and a special type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ExportLayerKey(
    string categoryName,
    string subCategoryName,
    SpecialType num
)
Visual Basic
Public Sub New ( _
    categoryName As String, _
    subCategoryName As String, _
    num As SpecialType _
)
Visual C++
public:
ExportLayerKey(
    String^ categoryName,
    String^ subCategoryName,
    SpecialType num
)

Parameters

categoryName
Type: System..::..String
The category name for the layer key.
subCategoryName
Type: System..::..String
The subCategoryName for the layer key.
num
Type: Autodesk.Revit.DB..::..SpecialType
The special type for layer key.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

ExportLayerKey Class
ExportLayerKey Overload


ExportLayerKey Methods

[image] [image]

Revit 2024 API
ExportLayerKey Methods
ExportLayerKey Class See Also Send Feedback

The ExportLayerKey type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ExportLayerKey Class


Dispose Method

[image]

Revit 2024 API
ExportLayerKey..::..Dispose Method
ExportLayerKey Class See Also Send Feedback
Releases all resources used by the ExportLayerKey

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ExportLayerKey Class


ExportLayerKey Properties

[image] [image]

Revit 2024 API
ExportLayerKey Properties
ExportLayerKey Class See Also Send Feedback

The ExportLayerKey type exposes the following members.

Properties

 | Name | Description
Public property | CategoryName | The category name.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SpecialType | The special type for layer key.
Public property | SubCategoryName | The subcategrory Name.

See Also

ExportLayerKey Class


CategoryName Property

[image]

Revit 2024 API
ExportLayerKey..::..CategoryName Property
ExportLayerKey Class See Also Send Feedback
The category name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public string CategoryName { get; set; }
Visual Basic
Public Property CategoryName As String
    Get
    Set
Visual C++
public:
property String^ CategoryName {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ExportLayerKey Class


IsValidObject Property

[image]

Revit 2024 API
ExportLayerKey..::..IsValidObject Property
ExportLayerKey Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ExportLayerKey Class


SpecialType Property

[image]

Revit 2024 API
ExportLayerKey..::..SpecialType Property
ExportLayerKey Class See Also Send Feedback
The special type for layer key.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public SpecialType SpecialType { get; set; }
Visual Basic
Public Property SpecialType As SpecialType
    Get
    Set
Visual C++
public:
property SpecialType SpecialType {
    SpecialType get ();
    void set (SpecialType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

ExportLayerKey Class


SubCategoryName Property

[image]

Revit 2024 API
ExportLayerKey..::..SubCategoryName Property
ExportLayerKey Class See Also Send Feedback
The subcategrory Name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public string SubCategoryName { get; set; }
Visual Basic
Public Property SubCategoryName As String
    Get
    Set
Visual C++
public:
property String^ SubCategoryName {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ExportLayerKey Class


ExportLayerTable Members

[image] [image]

Revit 2024 API
ExportLayerTable Members
ExportLayerTable Class Constructors Methods Properties See Also Send Feedback

The ExportLayerTable type exposes the following members.

Constructors

 | Name | Description
Public method | ExportLayerTable | Constructs a new ExportLayerTable with default values.

Methods

 | Name | Description
Public method | Add | Inserts a (key,info) pair into Export layer table.
Public method | Clear | Removes all contents stored in the table.
Public method | ContainsKey | Checks whether a layer key exists in the table.
Public method | Dispose | Releases all resources used by the ExportLayerTable
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetAvaliableLayerModifierTypes | Gets all the avaliable layer modifier types for the layer key.
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetExportLayerInfo | Gets a copy of the layer info associated to the input pattern key.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetKeys | Gets all the keys stored in the map.
Public method | GetLayerTableIterator | Returns a LayerTableIterator that iterates through the collection.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValues | Returns all the values stored in the map.
Public method | Remove | Removes the pair (key, info) by pattern key.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Count of the items contained in the collection.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Item | A copy of the ExportLayerInfo item that corresponds to the layer's ExportLayerKey.

See Also

ExportLayerTable Class


ExportLayerTable Constructor

[image]

Revit 2024 API
ExportLayerTable Constructor
ExportLayerTable Class See Also Send Feedback
Constructs a new ExportLayerTable with default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ExportLayerTable()
Visual Basic
Public Sub New
Visual C++
public:
ExportLayerTable()

See Also

ExportLayerTable Class


ExportLayerTable Methods

[image] [image]

Revit 2024 API
ExportLayerTable Methods
ExportLayerTable Class See Also Send Feedback

The ExportLayerTable type exposes the following members.

Methods

 | Name | Description
Public method | Add | Inserts a (key,info) pair into Export layer table.
Public method | Clear | Removes all contents stored in the table.
Public method | ContainsKey | Checks whether a layer key exists in the table.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetAvaliableLayerModifierTypes | Gets all the avaliable layer modifier types for the layer key.
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetExportLayerInfo | Gets a copy of the layer info associated to the input pattern key.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetKeys | Gets all the keys stored in the map.
Public method | GetLayerTableIterator | Returns a LayerTableIterator that iterates through the collection.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValues | Returns all the values stored in the map.
Public method | Remove | Removes the pair (key, info) by pattern key.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ExportLayerTable Class


Clear Method

[image]

Revit 2024 API
ExportLayerTable..::..Clear Method
ExportLayerTable Class See Also Send Feedback
Removes all contents stored in the table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

See Also

ExportLayerTable Class


ContainsKey Method

[image]

Revit 2024 API
ExportLayerTable..::..ContainsKey Method
ExportLayerTable Class See Also Send Feedback
Checks whether a layer key exists in the table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool ContainsKey(
    ExportLayerKey exportlayerKey
)
Visual Basic
Public Function ContainsKey ( _
    exportlayerKey As ExportLayerKey _
) As Boolean
Visual C++
public:
bool ContainsKey(
    ExportLayerKey^ exportlayerKey
)

Parameters

exportlayerKey
Type: Autodesk.Revit.DB..::..ExportLayerKey
The export layer Key.

Return Value

True if the layer key exists in the table.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExportLayerTable Class


Dispose Method

[image]

Revit 2024 API
ExportLayerTable..::..Dispose Method
ExportLayerTable Class See Also Send Feedback
Releases all resources used by the ExportLayerTable

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ExportLayerTable Class


GetAvaliableLayerModifierTypes Method

[image]

Revit 2024 API
ExportLayerTable..::..GetAvaliableLayerModifierTypes Method
ExportLayerTable Class See Also Send Feedback
Gets all the avaliable layer modifier types for the layer key.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static IList<ModifierType> GetAvaliableLayerModifierTypes(
    Document document,
    ExportLayerKey exportLayerKey
)
Visual Basic
Public Shared Function GetAvaliableLayerModifierTypes ( _
    document As Document, _
    exportLayerKey As ExportLayerKey _
) As IList(Of ModifierType)
Visual C++
public:
static IList<ModifierType>^ GetAvaliableLayerModifierTypes(
    Document^ document,
    ExportLayerKey^ exportLayerKey
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
A Revit document to retrieve avaliable layer modifier types from.
exportLayerKey
Type: Autodesk.Revit.DB..::..ExportLayerKey
The export layer key to specify wich category and subCategory will be used to get the layer modifier types.

Return Value

The layer modifier types.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExportLayerTable Class


GetBasicIEnumerator Method

[image]

Revit 2024 API
ExportLayerTable..::..GetBasicIEnumerator Method
ExportLayerTable Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
internal virtual IEnumerator GetBasicIEnumerator()
Visual Basic
Friend Overridable Function GetBasicIEnumerator As IEnumerator
Visual C++
internal:
virtual IEnumerator^ GetBasicIEnumerator()

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

ExportLayerTable Class


GetEnumerator Method

[image]

Revit 2024 API
ExportLayerTable..::..GetEnumerator Method
ExportLayerTable Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IEnumerator<KeyValuePair<ExportLayerKey, ExportLayerInfo>> GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator(Of KeyValuePair(Of ExportLayerKey, ExportLayerInfo))
Visual C++
public:
virtual IEnumerator<KeyValuePair<ExportLayerKey^, ExportLayerInfo^>>^ GetEnumerator()

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

ExportLayerTable Class


GetExportLayerInfo Method

[image]

Revit 2024 API
ExportLayerTable..::..GetExportLayerInfo Method
ExportLayerTable Class See Also Send Feedback
Gets a copy of the layer info associated to the input pattern key.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ExportLayerInfo GetExportLayerInfo(
    ExportLayerKey exportLayerKey
)
Visual Basic
Public Function GetExportLayerInfo ( _
    exportLayerKey As ExportLayerKey _
) As ExportLayerInfo
Visual C++
public:
ExportLayerInfo^ GetExportLayerInfo(
    ExportLayerKey^ exportLayerKey
)

Parameters

exportLayerKey
Type: Autodesk.Revit.DB..::..ExportLayerKey
The export layer Key.

Return Value

Return the layerInfo for this key.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | An entry with the given key is not present in the table.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExportLayerTable Class


GetLayerTableIterator Method

[image]

Revit 2024 API
ExportLayerTable..::..GetLayerTableIterator Method
ExportLayerTable Class See Also Send Feedback
Returns a LayerTableIterator that iterates through the collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ExportLayerTableIterator GetLayerTableIterator()
Visual Basic
Public Function GetLayerTableIterator As ExportLayerTableIterator
Visual C++
public:
ExportLayerTableIterator^ GetLayerTableIterator()

Return Value

A LayerTableIterator object that can be used to iterate through key-value pairs in the collection.

See Also

ExportLayerTable Class


GetValues Method

[image]

Revit 2024 API
ExportLayerTable..::..GetValues Method
ExportLayerTable Class See Also Send Feedback
Returns all the values stored in the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public IList<ExportLayerInfo> GetValues()
Visual Basic
Public Function GetValues As IList(Of ExportLayerInfo)
Visual C++
public:
IList<ExportLayerInfo^>^ GetValues()

Return Value

Return the info array.

See Also

ExportLayerTable Class


Remove Method

[image]

Revit 2024 API
ExportLayerTable..::..Remove Method
ExportLayerTable Class See Also Send Feedback
Removes the pair (key, info) by pattern key.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void Remove(
    ExportLayerKey exportLayerKey
)
Visual Basic
Public Sub Remove ( _
    exportLayerKey As ExportLayerKey _
)
Visual C++
public:
void Remove(
    ExportLayerKey^ exportLayerKey
)

Parameters

exportLayerKey
Type: Autodesk.Revit.DB..::..ExportLayerKey
The export pattern key.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExportLayerTable Class


ExportLayerTable Properties

[image] [image]

Revit 2024 API
ExportLayerTable Properties
ExportLayerTable Class See Also Send Feedback

The ExportLayerTable type exposes the following members.

Properties

 | Name | Description
Public property | Count | Count of the items contained in the collection.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Item | A copy of the ExportLayerInfo item that corresponds to the layer's ExportLayerKey.

See Also

ExportLayerTable Class


Count Property

[image]

Revit 2024 API
ExportLayerTable..::..Count Property
ExportLayerTable Class See Also Send Feedback
Count of the items contained in the collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get
Visual C++
public:
property int Count {
    int get ();
}

See Also

ExportLayerTable Class


IsValidObject Property

[image]

Revit 2024 API
ExportLayerTable..::..IsValidObject Property
ExportLayerTable Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ExportLayerTable Class


Item Property

[image]

Revit 2024 API
ExportLayerTable..::..Item Property
ExportLayerTable Class See Also Send Feedback
A copy of the ExportLayerInfo item that corresponds to the layer's ExportLayerKey.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ExportLayerInfo this[
    ExportLayerKey layerKey
] { get; set; }
Visual Basic
Public Default Property Item ( _
    layerKey As ExportLayerKey _
) As ExportLayerInfo
    Get
    Set
Visual C++
public:
virtual property ExportLayerInfo^ default[ExportLayerKey^ layerKey] {
    ExportLayerInfo^ get (ExportLayerKey^ layerKey) sealed;
    void set (ExportLayerKey^ layerKey, ExportLayerInfo^ value) sealed;
}

Parameters

layerKey
Type: Autodesk.Revit.DB..::..ExportLayerKey

Return Value

A copy of the ExportLayerInfo for the layer Key.

Remarks

When getting this property, it returns a copy of the ExportLayerInfo from the table. In order to make changes to the ExportLayerInfo and use those settings during export, set the modified ExportLayerInfo back into the table using the same key.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When getting this property: An entry with the given key is not present in the table.

See Also

ExportLayerTable Class


ExportLayerTableIterator Class

[image]

Revit 2024 API
ExportLayerTableIterator Class
Members See Also Send Feedback
An iterator to a set of Layer table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class ExportLayerTableIterator : IEnumerator<KeyValuePair<ExportLayerKey, ExportLayerInfo>>
Visual Basic
Public Class ExportLayerTableIterator _
    Implements IEnumerator(Of KeyValuePair(Of ExportLayerKey, ExportLayerInfo))
Visual C++
public ref class ExportLayerTableIterator : IEnumerator<KeyValuePair<ExportLayerKey^, ExportLayerInfo^>>

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ExportLayerTableIterator

See Also

ExportLayerTableIterator Members


ExportLayerTableIterator Members

[image] [image]

Revit 2024 API
ExportLayerTableIterator Members
ExportLayerTableIterator Class Methods Properties See Also Send Feedback

The ExportLayerTableIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ExportLayerTableIterator
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next item.
Public method | Reset | Resets the iterator to the initial state.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ExportLayerTableIterator Class


Dispose Method

[image]

Revit 2024 API
ExportLayerTableIterator..::..Dispose Method
ExportLayerTableIterator Class See Also Send Feedback
Releases all resources used by the ExportLayerTableIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

See Also

ExportLayerTableIterator Class


IsDone Method

[image]

Revit 2024 API
ExportLayerTableIterator..::..IsDone Method
ExportLayerTableIterator Class See Also Send Feedback
Identifies if the iteration has completed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public virtual bool IsDone()
Visual Basic
Public Overridable Function IsDone As Boolean
Visual C++
public:
virtual bool IsDone()

Return Value

True if the iteration has no more items. False if there are more items to be iterated.

See Also

ExportLayerTableIterator Class


MoveNext Method

[image]

Revit 2024 API
ExportLayerTableIterator..::..MoveNext Method
ExportLayerTableIterator Class See Also Send Feedback
Increments the iterator to the next item.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

True if there is a next available item in this iterator. False if the iterator has completed all available items.

See Also

ExportLayerTableIterator Class


Reset Method

[image]

Revit 2024 API
ExportLayerTableIterator..::..Reset Method
ExportLayerTableIterator Class See Also Send Feedback
Resets the iterator to the initial state.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

See Also

ExportLayerTableIterator Class


ExportLayerTableIterator Properties

[image] [image]

Revit 2024 API
ExportLayerTableIterator Properties
ExportLayerTableIterator Class See Also Send Feedback

The ExportLayerTableIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ExportLayerTableIterator Class


Current Property

[image]

Revit 2024 API
ExportLayerTableIterator..::..Current Property
ExportLayerTableIterator Class See Also Send Feedback
Gets the item at the current position of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual KeyValuePair<ExportLayerKey, ExportLayerInfo> Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As KeyValuePair(Of ExportLayerKey, ExportLayerInfo)
    Get
Visual C++
public:
virtual property KeyValuePair<ExportLayerKey^, ExportLayerInfo^> Current {
    KeyValuePair<ExportLayerKey^, ExportLayerInfo^> get ();
}

Implements

IEnumerator<(Of <(<'T>)>)>..::..Current

Remarks

There is no current item if the iterator has not started yet or has been done.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | There is no current item in the iterator.

See Also

ExportLayerTableIterator Class


CurrentObject Property

[image]

Revit 2024 API
ExportLayerTableIterator..::..CurrentObject Property
ExportLayerTableIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
internal Object CurrentObject { get; }
Visual Basic
Friend ReadOnly Property CurrentObject As Object
    Get
Visual C++
internal:
virtual property Object^ CurrentObject {
    Object^ get () sealed;
}

Implements

IEnumerator..::..Current

See Also

ExportLayerTableIterator Class


ExportLinetypeInfo Constructor

[image] [image]

Revit 2024 API
ExportLinetypeInfo Constructor
ExportLinetypeInfo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ExportLinetypeInfo()()()() | Constructs a new default ExportLinetypeInfo.
Public method | ExportLinetypeInfo(String) | Constructs a new ExportLinetypeInfo using the destination linetype name as input.
Public method | ExportLinetypeInfo(ExportLinetypeInfo) | Constructs a new copy of the input ExportLinetypeInfo object.

See Also

ExportLinetypeInfo Class
ExportLinetypeInfo Members


ExportLinetypeInfo Constructor

[image]

Revit 2024 API
ExportLinetypeInfo Constructor
ExportLinetypeInfo Class See Also Send Feedback
Constructs a new default ExportLinetypeInfo.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ExportLinetypeInfo()
Visual Basic
Public Sub New
Visual C++
public:
ExportLinetypeInfo()

See Also

ExportLinetypeInfo Class
ExportLinetypeInfo Overload


ExportLinetypeInfo Constructor (String)

[image]

Revit 2024 API
ExportLinetypeInfo Constructor (String)
ExportLinetypeInfo Class See Also Send Feedback
Constructs a new ExportLinetypeInfo using the destination linetype name as input.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ExportLinetypeInfo(
    string destinationLinetypeName
)
Visual Basic
Public Sub New ( _
    destinationLinetypeName As String _
)
Visual C++
public:
ExportLinetypeInfo(
    String^ destinationLinetypeName
)

Parameters

destinationLinetypeName
Type: System..::..String
The destination line type name (the name of the linetype in the exported format).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExportLinetypeInfo Class
ExportLinetypeInfo Overload


ExportLinetypeInfo Constructor (ExportLinetypeInfo)

[image]

Revit 2024 API
ExportLinetypeInfo Constructor (ExportLinetypeInfo)
ExportLinetypeInfo Class See Also Send Feedback
Constructs a new copy of the input ExportLinetypeInfo object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ExportLinetypeInfo(
    ExportLinetypeInfo other
)
Visual Basic
Public Sub New ( _
    other As ExportLinetypeInfo _
)
Visual C++
public:
ExportLinetypeInfo(
    ExportLinetypeInfo^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..ExportLinetypeInfo

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExportLinetypeInfo Class
ExportLinetypeInfo Overload


ExportLinetypeInfo Methods

[image] [image]

Revit 2024 API
ExportLinetypeInfo Methods
ExportLinetypeInfo Class See Also Send Feedback

The ExportLinetypeInfo type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ExportLinetypeInfo Class


Dispose Method

[image]

Revit 2024 API
ExportLinetypeInfo..::..Dispose Method
ExportLinetypeInfo Class See Also Send Feedback
Releases all resources used by the ExportLinetypeInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ExportLinetypeInfo Class


ExportLinetypeInfo Properties

[image] [image]

Revit 2024 API
ExportLinetypeInfo Properties
ExportLinetypeInfo Class See Also Send Feedback

The ExportLinetypeInfo type exposes the following members.

Properties

 | Name | Description
Public property | DestinationLinetypeName | The destination linetype name (the name of the linetype in the exported format).
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ExportLinetypeInfo Class


DestinationLinetypeName Property

[image]

Revit 2024 API
ExportLinetypeInfo..::..DestinationLinetypeName Property
ExportLinetypeInfo Class See Also Send Feedback
The destination linetype name (the name of the linetype in the exported format).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public string DestinationLinetypeName { get; set; }
Visual Basic
Public Property DestinationLinetypeName As String
    Get
    Set
Visual C++
public:
property String^ DestinationLinetypeName {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ExportLinetypeInfo Class


IsValidObject Property

[image]

Revit 2024 API
ExportLinetypeInfo..::..IsValidObject Property
ExportLinetypeInfo Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ExportLinetypeInfo Class


ExportLinetypeKey Class

[image]

Revit 2024 API
ExportLinetypeKey Class
Members See Also Send Feedback
A key used to represent an item stored in an ExportLinetypeTable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class ExportLinetypeKey : IDisposable
Visual Basic
Public Class ExportLinetypeKey _
    Implements IDisposable
Visual C++
public ref class ExportLinetypeKey : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ExportLinetypeKey

See Also

ExportLinetypeKey Members


ExportLinetypeKey Members

[image] [image]

Revit 2024 API
ExportLinetypeKey Members
ExportLinetypeKey Class Constructors Methods Properties See Also Send Feedback

The ExportLinetypeKey type exposes the following members.

Constructors

 | Name | Description
Public method | ExportLinetypeKey()()()() | Constructs a new default ExportLinetypeKey.
Public method | ExportLinetypeKey(String) | Constructs a new default ExportLinetypeKey using the original line type name as input.
Public method | ExportLinetypeKey(ExportLinetypeKey) | Constructs a new copy of the input ExportLinetypeKey object.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ExportLinetypeKey
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OriginalLinetypeName | The original linetype name.

See Also

ExportLinetypeKey Class


ExportLinetypeKey Constructor

[image] [image]

Revit 2024 API
ExportLinetypeKey Constructor
ExportLinetypeKey Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ExportLinetypeKey()()()() | Constructs a new default ExportLinetypeKey.
Public method | ExportLinetypeKey(String) | Constructs a new default ExportLinetypeKey using the original line type name as input.
Public method | ExportLinetypeKey(ExportLinetypeKey) | Constructs a new copy of the input ExportLinetypeKey object.

See Also

ExportLinetypeKey Class
ExportLinetypeKey Members


ExportLinetypeKey Constructor

[image]

Revit 2024 API
ExportLinetypeKey Constructor
ExportLinetypeKey Class See Also Send Feedback
Constructs a new default ExportLinetypeKey.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ExportLinetypeKey()
Visual Basic
Public Sub New
Visual C++
public:
ExportLinetypeKey()

See Also

ExportLinetypeKey Class
ExportLinetypeKey Overload


ExportLinetypeKey Constructor (ExportLinetypeKey)

[image]

Revit 2024 API
ExportLinetypeKey Constructor (ExportLinetypeKey)
ExportLinetypeKey Class See Also Send Feedback
Constructs a new copy of the input ExportLinetypeKey object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ExportLinetypeKey(
    ExportLinetypeKey other
)
Visual Basic
Public Sub New ( _
    other As ExportLinetypeKey _
)
Visual C++
public:
ExportLinetypeKey(
    ExportLinetypeKey^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..ExportLinetypeKey

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExportLinetypeKey Class
ExportLinetypeKey Overload


ExportLinetypeKey Methods

[image] [image]

Revit 2024 API
ExportLinetypeKey Methods
ExportLinetypeKey Class See Also Send Feedback

The ExportLinetypeKey type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ExportLinetypeKey Class


ExportLinetypeKey Properties

[image] [image]

Revit 2024 API
ExportLinetypeKey Properties
ExportLinetypeKey Class See Also Send Feedback

The ExportLinetypeKey type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OriginalLinetypeName | The original linetype name.

See Also

ExportLinetypeKey Class


IsValidObject Property

[image]

Revit 2024 API
ExportLinetypeKey..::..IsValidObject Property
ExportLinetypeKey Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ExportLinetypeKey Class


OriginalLinetypeName Property

[image]

Revit 2024 API
ExportLinetypeKey..::..OriginalLinetypeName Property
ExportLinetypeKey Class See Also Send Feedback
The original linetype name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public string OriginalLinetypeName { get; set; }
Visual Basic
Public Property OriginalLinetypeName As String
    Get
    Set
Visual C++
public:
property String^ OriginalLinetypeName {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ExportLinetypeKey Class


ExportLinetypeTable Class

[image]

Revit 2024 API
ExportLinetypeTable Class
Members See Also Send Feedback
A table supporting a mapping of linetypes in Revit to linetype names that will be set in the target export format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class ExportLinetypeTable : IEnumerable<KeyValuePair<ExportLinetypeKey, ExportLinetypeInfo>>,
    IDisposable
Visual Basic
Public Class ExportLinetypeTable _
    Implements IEnumerable(Of KeyValuePair(Of ExportLinetypeKey, ExportLinetypeInfo)),  _
    IDisposable
Visual C++
public ref class ExportLinetypeTable : IEnumerable<KeyValuePair<ExportLinetypeKey^, ExportLinetypeInfo^>>,
    IDisposable

Remarks

This table is structured as a mapping from ExportLinetypeKey to ExportLinetypeInfo members. The ExportLinetypeKey contains the identification information for the pattern table: the Revit linetype name. The ExportLinetypeInfo contains the linetype name to use in the export format.

The table can be accessed via direct iteration as a collection of KeyValuePairs, or by traversal of the stored keys obtained from GetKeys(), or via specific lookup of a key constructed externally. In all cases, the ExportLinetypeInfo returned will be a copy of the ExportLinetypeInfo from the table. In order to make changes to the ExportLinetypeInfo and use those settings during export, set the modified ExportLinetypeInfo back into the table using the same key.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ExportLinetypeTable

See Also

ExportLinetypeTable Members


ExportLinetypeTable Methods

[image] [image]

Revit 2024 API
ExportLinetypeTable Methods
ExportLinetypeTable Class See Also Send Feedback

The ExportLinetypeTable type exposes the following members.

Methods

 | Name | Description
Public method | Add | Inserts a (key, info) pair into Export line type table.
Public method | Clear | Removes all contents stored in Export line type table.
Public method | ContainsKey | Checks whether a pattern key exists in the table.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetExportLinetypeInfo | Gets a copy of the ExportLinetypeInfo corresponding to the given ExportLinetypeKey.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetKeys | Gets all the keys stored in the map.
Public method | GetLinetypeTableIterator | Returns a ExportLinetypeTableIterator that iterates through the collection.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValues | Returns all the values stored in the map.
Public method | Remove | Removes the pair (key, info) corresponding to the given ExportLinetypeKey.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ExportLinetypeTable Class


Add Method

[image]

Revit 2024 API
ExportLinetypeTable..::..Add Method
ExportLinetypeTable Class See Also Send Feedback
Inserts a (key, info) pair into Export line type table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Add(
    ExportLinetypeKey exportLinetypeKey,
    ExportLinetypeInfo exportLinetypeInfo
)
Visual Basic
Public Sub Add ( _
    exportLinetypeKey As ExportLinetypeKey, _
    exportLinetypeInfo As ExportLinetypeInfo _
)
Visual C++
public:
void Add(
    ExportLinetypeKey^ exportLinetypeKey,
    ExportLinetypeInfo^ exportLinetypeInfo
)

Parameters

exportLinetypeKey
Type: Autodesk.Revit.DB..::..ExportLinetypeKey
The export line type Key to be added.
exportLinetypeInfo
Type: Autodesk.Revit.DB..::..ExportLinetypeInfo
The export line type info to be added.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The key already exists in the table.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExportLinetypeTable Class


Clear Method

[image]

Revit 2024 API
ExportLinetypeTable..::..Clear Method
ExportLinetypeTable Class See Also Send Feedback
Removes all contents stored in Export line type table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

See Also

ExportLinetypeTable Class


Dispose Method

[image]

Revit 2024 API
ExportLinetypeTable..::..Dispose Method
ExportLinetypeTable Class See Also Send Feedback
Releases all resources used by the ExportLinetypeTable

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ExportLinetypeTable Class


GetBasicIEnumerator Method

[image]

Revit 2024 API
ExportLinetypeTable..::..GetBasicIEnumerator Method
ExportLinetypeTable Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
internal virtual IEnumerator GetBasicIEnumerator()
Visual Basic
Friend Overridable Function GetBasicIEnumerator As IEnumerator
Visual C++
internal:
virtual IEnumerator^ GetBasicIEnumerator()

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

ExportLinetypeTable Class


GetEnumerator Method

[image]

Revit 2024 API
ExportLinetypeTable..::..GetEnumerator Method
ExportLinetypeTable Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IEnumerator<KeyValuePair<ExportLinetypeKey, ExportLinetypeInfo>> GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator(Of KeyValuePair(Of ExportLinetypeKey, ExportLinetypeInfo))
Visual C++
public:
virtual IEnumerator<KeyValuePair<ExportLinetypeKey^, ExportLinetypeInfo^>>^ GetEnumerator()

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

ExportLinetypeTable Class


GetExportLinetypeInfo Method

[image]

Revit 2024 API
ExportLinetypeTable..::..GetExportLinetypeInfo Method
ExportLinetypeTable Class See Also Send Feedback
Gets a copy of the ExportLinetypeInfo corresponding to the given ExportLinetypeKey.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ExportLinetypeInfo GetExportLinetypeInfo(
    ExportLinetypeKey exportLinetypeKey
)
Visual Basic
Public Function GetExportLinetypeInfo ( _
    exportLinetypeKey As ExportLinetypeKey _
) As ExportLinetypeInfo
Visual C++
public:
ExportLinetypeInfo^ GetExportLinetypeInfo(
    ExportLinetypeKey^ exportLinetypeKey
)

Parameters

exportLinetypeKey
Type: Autodesk.Revit.DB..::..ExportLinetypeKey
The export line type Key.

Return Value

Returns the line type info for this key.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | An entry with the given key is not present in the table.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExportLinetypeTable Class


GetKeys Method

[image]

Revit 2024 API
ExportLinetypeTable..::..GetKeys Method
ExportLinetypeTable Class See Also Send Feedback
Gets all the keys stored in the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public IList<ExportLinetypeKey> GetKeys()
Visual Basic
Public Function GetKeys As IList(Of ExportLinetypeKey)
Visual C++
public:
IList<ExportLinetypeKey^>^ GetKeys()

Return Value

The keys.

See Also

ExportLinetypeTable Class


GetLinetypeTableIterator Method

[image]

Revit 2024 API
ExportLinetypeTable..::..GetLinetypeTableIterator Method
ExportLinetypeTable Class See Also Send Feedback
Returns a ExportLinetypeTableIterator that iterates through the collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ExportLinetypeTableIterator GetLinetypeTableIterator()
Visual Basic
Public Function GetLinetypeTableIterator As ExportLinetypeTableIterator
Visual C++
public:
ExportLinetypeTableIterator^ GetLinetypeTableIterator()

Return Value

A ExportLinetypeTableIterator object that can be used to iterate through key-value pairs in the collection.

See Also

ExportLinetypeTable Class


GetValues Method

[image]

Revit 2024 API
ExportLinetypeTable..::..GetValues Method
ExportLinetypeTable Class See Also Send Feedback
Returns all the values stored in the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public IList<ExportLinetypeInfo> GetValues()
Visual Basic
Public Function GetValues As IList(Of ExportLinetypeInfo)
Visual C++
public:
IList<ExportLinetypeInfo^>^ GetValues()

Return Value

The info.

See Also

ExportLinetypeTable Class


Remove Method

[image]

Revit 2024 API
ExportLinetypeTable..::..Remove Method
ExportLinetypeTable Class See Also Send Feedback
Removes the pair (key, info) corresponding to the given ExportLinetypeKey.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Remove(
    ExportLinetypeKey exportLinetypeKey
)
Visual Basic
Public Sub Remove ( _
    exportLinetypeKey As ExportLinetypeKey _
)
Visual C++
public:
void Remove(
    ExportLinetypeKey^ exportLinetypeKey
)

Parameters

exportLinetypeKey
Type: Autodesk.Revit.DB..::..ExportLinetypeKey
The export line type key

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExportLinetypeTable Class


IsValidObject Property

[image]

Revit 2024 API
ExportLinetypeTable..::..IsValidObject Property
ExportLinetypeTable Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ExportLinetypeTable Class


Item Property

[image]

Revit 2024 API
ExportLinetypeTable..::..Item Property
ExportLinetypeTable Class See Also Send Feedback
A copy of the ExportLinetypeInfo for the linetype's ExportLinetypeKey.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ExportLinetypeInfo this[
    ExportLinetypeKey linetypeKey
] { get; set; }
Visual Basic
Public Default Property Item ( _
    linetypeKey As ExportLinetypeKey _
) As ExportLinetypeInfo
    Get
    Set
Visual C++
public:
virtual property ExportLinetypeInfo^ default[ExportLinetypeKey^ linetypeKey] {
    ExportLinetypeInfo^ get (ExportLinetypeKey^ linetypeKey) sealed;
    void set (ExportLinetypeKey^ linetypeKey, ExportLinetypeInfo^ value) sealed;
}

Parameters

linetypeKey
Type: Autodesk.Revit.DB..::..ExportLinetypeKey

Return Value

A copy of the ExportLinetypeInfo.

Remarks

When getting this property, it returns a copy of the ExportLinetypeInfo from the table. In order to make changes to the ExportLinetypeInfo and use those settings during export, set the modified ExportLinetypeInfo back into the table using the same key.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When getting this property: An entry with the given key is not present in the table.

See Also

ExportLinetypeTable Class


ExportLinetypeTableIterator Class

[image]

Revit 2024 API
ExportLinetypeTableIterator Class
Members See Also Send Feedback
An iterator to a set of line type table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class ExportLinetypeTableIterator : IEnumerator<KeyValuePair<ExportLinetypeKey, ExportLinetypeInfo>>
Visual Basic
Public Class ExportLinetypeTableIterator _
    Implements IEnumerator(Of KeyValuePair(Of ExportLinetypeKey, ExportLinetypeInfo))
Visual C++
public ref class ExportLinetypeTableIterator : IEnumerator<KeyValuePair<ExportLinetypeKey^, ExportLinetypeInfo^>>

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ExportLinetypeTableIterator

See Also

ExportLinetypeTableIterator Members


ExportLinetypeTableIterator Methods

[image] [image]

Revit 2024 API
ExportLinetypeTableIterator Methods
ExportLinetypeTableIterator Class See Also Send Feedback

The ExportLinetypeTableIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next item.
Public method | Reset | Resets the iterator to the initial state.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ExportLinetypeTableIterator Class


Dispose Method

[image]

Revit 2024 API
ExportLinetypeTableIterator..::..Dispose Method
ExportLinetypeTableIterator Class See Also Send Feedback
Releases all resources used by the ExportLinetypeTableIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

See Also

ExportLinetypeTableIterator Class


IsDone Method

[image]

Revit 2024 API
ExportLinetypeTableIterator..::..IsDone Method
ExportLinetypeTableIterator Class See Also Send Feedback
Identifies if the iteration has completed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public virtual bool IsDone()
Visual Basic
Public Overridable Function IsDone As Boolean
Visual C++
public:
virtual bool IsDone()

Return Value

True if the iteration has no more items. False if there are more items to be iterated.

See Also

ExportLinetypeTableIterator Class


MoveNext Method

[image]

Revit 2024 API
ExportLinetypeTableIterator..::..MoveNext Method
ExportLinetypeTableIterator Class See Also Send Feedback
Increments the iterator to the next item.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

True if the iteration has no more items. False if there are more items to be iterated.

See Also

ExportLinetypeTableIterator Class


Reset Method

[image]

Revit 2024 API
ExportLinetypeTableIterator..::..Reset Method
ExportLinetypeTableIterator Class See Also Send Feedback
Resets the iterator to the initial state.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

See Also

ExportLinetypeTableIterator Class


ExportLinetypeTableIterator Properties

[image] [image]

Revit 2024 API
ExportLinetypeTableIterator Properties
ExportLinetypeTableIterator Class See Also Send Feedback

The ExportLinetypeTableIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ExportLinetypeTableIterator Class


Current Property

[image]

Revit 2024 API
ExportLinetypeTableIterator..::..Current Property
ExportLinetypeTableIterator Class See Also Send Feedback
Gets the item at the current position of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual KeyValuePair<ExportLinetypeKey, ExportLinetypeInfo> Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As KeyValuePair(Of ExportLinetypeKey, ExportLinetypeInfo)
    Get
Visual C++
public:
virtual property KeyValuePair<ExportLinetypeKey^, ExportLinetypeInfo^> Current {
    KeyValuePair<ExportLinetypeKey^, ExportLinetypeInfo^> get ();
}

Implements

IEnumerator<(Of <(<'T>)>)>..::..Current

Remarks

There is no current item if the iterator has not started yet or has been done.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | There is no current item in the iterator.

See Also

ExportLinetypeTableIterator Class


CurrentObject Property

[image]

Revit 2024 API
ExportLinetypeTableIterator..::..CurrentObject Property
ExportLinetypeTableIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
internal Object CurrentObject { get; }
Visual Basic
Friend ReadOnly Property CurrentObject As Object
    Get
Visual C++
internal:
virtual property Object^ CurrentObject {
    Object^ get () sealed;
}

Implements

IEnumerator..::..Current

See Also

ExportLinetypeTableIterator Class


IsValidObject Property

[image]

Revit 2024 API
ExportLinetypeTableIterator..::..IsValidObject Property
ExportLinetypeTableIterator Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ExportLinetypeTableIterator Class


ExportLineweightInfo Class

[image]

Revit 2024 API
ExportLineweightInfo Class
Members See Also Send Feedback
A value used to represent the info stored in the ExportLineweightTable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class ExportLineweightInfo : IDisposable
Visual Basic
Public Class ExportLineweightInfo _
    Implements IDisposable
Visual C++
public ref class ExportLineweightInfo : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ExportLineweightInfo

See Also

ExportLineweightInfo Members


ExportLineweightInfo Members

[image] [image]

Revit 2024 API
ExportLineweightInfo Members
ExportLineweightInfo Class Constructors Methods Properties See Also Send Feedback

The ExportLineweightInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ExportLineweightInfo()()()() | Constructs a new default ExportLineweightInfo.
Public method | ExportLineweightInfo(String) | Constructs a new ExportLineweightInfo using the destination line weight name as input.
Public method | ExportLineweightInfo(ExportLineweightInfo) | Constructs a new copy of the input ExportLineweightInfo object.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ExportLineweightInfo
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DestinationLineweightName | The destination lineweight name (the name of the line weight in the exported format)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ExportLineweightInfo Class


ExportLineweightInfo Constructor

[image] [image]

Revit 2024 API
ExportLineweightInfo Constructor
ExportLineweightInfo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ExportLineweightInfo()()()() | Constructs a new default ExportLineweightInfo.
Public method | ExportLineweightInfo(String) | Constructs a new ExportLineweightInfo using the destination line weight name as input.
Public method | ExportLineweightInfo(ExportLineweightInfo) | Constructs a new copy of the input ExportLineweightInfo object.

See Also

ExportLineweightInfo Class
ExportLineweightInfo Members


ExportLineweightInfo Constructor

[image]

Revit 2024 API
ExportLineweightInfo Constructor
ExportLineweightInfo Class See Also Send Feedback
Constructs a new default ExportLineweightInfo.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ExportLineweightInfo()
Visual Basic
Public Sub New
Visual C++
public:
ExportLineweightInfo()

See Also

ExportLineweightInfo Class
ExportLineweightInfo Overload


ExportLineweightInfo Constructor (String)

[image]

Revit 2024 API
ExportLineweightInfo Constructor (String)
ExportLineweightInfo Class See Also Send Feedback
Constructs a new ExportLineweightInfo using the destination line weight name as input.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ExportLineweightInfo(
    string destinationLineweightName
)
Visual Basic
Public Sub New ( _
    destinationLineweightName As String _
)
Visual C++
public:
ExportLineweightInfo(
    String^ destinationLineweightName
)

Parameters

destinationLineweightName
Type: System..::..String
The destination line weight name (the name of the line weight in the exported format).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExportLineweightInfo Class
ExportLineweightInfo Overload


ExportLineweightInfo Constructor (ExportLineweightInfo)

[image]

Revit 2024 API
ExportLineweightInfo Constructor (ExportLineweightInfo)
ExportLineweightInfo Class See Also Send Feedback
Constructs a new copy of the input ExportLineweightInfo object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ExportLineweightInfo(
    ExportLineweightInfo other
)
Visual Basic
Public Sub New ( _
    other As ExportLineweightInfo _
)
Visual C++
public:
ExportLineweightInfo(
    ExportLineweightInfo^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..ExportLineweightInfo

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExportLineweightInfo Class
ExportLineweightInfo Overload


ExportLineweightInfo Methods

[image] [image]

Revit 2024 API
ExportLineweightInfo Methods
ExportLineweightInfo Class See Also Send Feedback

The ExportLineweightInfo type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ExportLineweightInfo Class


Dispose Method

[image]

Revit 2024 API
ExportLineweightInfo..::..Dispose Method
ExportLineweightInfo Class See Also Send Feedback
Releases all resources used by the ExportLineweightInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ExportLineweightInfo Class


DestinationLineweightName Property

[image]

Revit 2024 API
ExportLineweightInfo..::..DestinationLineweightName Property
ExportLineweightInfo Class See Also Send Feedback
The destination lineweight name (the name of the line weight in the exported format)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public string DestinationLineweightName { get; set; }
Visual Basic
Public Property DestinationLineweightName As String
    Get
    Set
Visual C++
public:
property String^ DestinationLineweightName {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ExportLineweightInfo Class


IsValidObject Property

[image]

Revit 2024 API
ExportLineweightInfo..::..IsValidObject Property
ExportLineweightInfo Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ExportLineweightInfo Class


ExportLineweightKey Class

[image]

Revit 2024 API
ExportLineweightKey Class
Members See Also Send Feedback
A key used to represent an item stored in an ExportLineweightTable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class ExportLineweightKey : IDisposable
Visual Basic
Public Class ExportLineweightKey _
    Implements IDisposable
Visual C++
public ref class ExportLineweightKey : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ExportLineweightKey

See Also

ExportLineweightKey Members


ExportLineweightKey Members

[image] [image]

Revit 2024 API
ExportLineweightKey Members
ExportLineweightKey Class Constructors Methods Properties See Also Send Feedback

The ExportLineweightKey type exposes the following members.

Constructors

 | Name | Description
Public method | ExportLineweightKey()()()() | Constructs a new default ExportLineweightKey.
Public method | ExportLineweightKey(Int32) | Constructs a new default ExportLineweightKey using the original line weight as input.
Public method | ExportLineweightKey(ExportLineweightKey) | Constructs a new copy of the input ExportLineweightKey object.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ExportLineweightKey
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OriginalLineweight | The original line weight.

See Also

ExportLineweightKey Class


ExportLineweightKey Constructor

[image]

Revit 2024 API
ExportLineweightKey Constructor
ExportLineweightKey Class See Also Send Feedback
Constructs a new default ExportLineweightKey.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ExportLineweightKey()
Visual Basic
Public Sub New
Visual C++
public:
ExportLineweightKey()

See Also

ExportLineweightKey Class
ExportLineweightKey Overload


ExportLineweightKey Constructor (Int32)

[image]

Revit 2024 API
ExportLineweightKey Constructor (Int32)
ExportLineweightKey Class See Also Send Feedback
Constructs a new default ExportLineweightKey using the original line weight as input.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ExportLineweightKey(
    int originalLineweight
)
Visual Basic
Public Sub New ( _
    originalLineweight As Integer _
)
Visual C++
public:
ExportLineweightKey(
    int originalLineweight
)

Parameters

originalLineweight
Type: System..::..Int32
The original line weight.

See Also

ExportLineweightKey Class
ExportLineweightKey Overload


ExportLineweightKey Constructor (ExportLineweightKey)

[image]

Revit 2024 API
ExportLineweightKey Constructor (ExportLineweightKey)
ExportLineweightKey Class See Also Send Feedback
Constructs a new copy of the input ExportLineweightKey object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ExportLineweightKey(
    ExportLineweightKey other
)
Visual Basic
Public Sub New ( _
    other As ExportLineweightKey _
)
Visual C++
public:
ExportLineweightKey(
    ExportLineweightKey^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..ExportLineweightKey

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExportLineweightKey Class
ExportLineweightKey Overload


ExportLineweightKey Methods

[image] [image]

Revit 2024 API
ExportLineweightKey Methods
ExportLineweightKey Class See Also Send Feedback

The ExportLineweightKey type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ExportLineweightKey Class


Dispose Method

[image]

Revit 2024 API
ExportLineweightKey..::..Dispose Method
ExportLineweightKey Class See Also Send Feedback
Releases all resources used by the ExportLineweightKey

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ExportLineweightKey Class


ExportLineweightKey Properties

[image] [image]

Revit 2024 API
ExportLineweightKey Properties
ExportLineweightKey Class See Also Send Feedback

The ExportLineweightKey type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OriginalLineweight | The original line weight.

See Also

ExportLineweightKey Class


IsValidObject Property

[image]

Revit 2024 API
ExportLineweightKey..::..IsValidObject Property
ExportLineweightKey Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ExportLineweightKey Class


ExportLineweightTable Class

[image]

Revit 2024 API
ExportLineweightTable Class
Members See Also Send Feedback
A table supporting a mapping of line weights in Revit to line weight names that will be set in the target export format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class ExportLineweightTable : IEnumerable<KeyValuePair<ExportLineweightKey, ExportLineweightInfo>>,
    IDisposable
Visual Basic
Public Class ExportLineweightTable _
    Implements IEnumerable(Of KeyValuePair(Of ExportLineweightKey, ExportLineweightInfo)),  _
    IDisposable
Visual C++
public ref class ExportLineweightTable : IEnumerable<KeyValuePair<ExportLineweightKey^, ExportLineweightInfo^>>,
    IDisposable

Remarks

This table is structured as a mapping from ExportLineweightKey to ExportLineweightInfo members. The ExportLineweightKey contains the identification information for the pattern table: the Revit line weight. The ExportLineweightInfo contains the line weight to use in the export format.

The table can be accessed via direct iteration as a collection of KeyValuePairs, or by traversal of the stored keys obtained from GetKeys(), or via specific lookup of a key constructed externally. In all cases, the ExportLineweightInfo returned will be a copy of the ExportLineweightInfo from the table. In order to make changes to the ExportLineweightInfo and use those settings during export, set the modified ExportLineweightInfo back into the table using the same key.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ExportLineweightTable

See Also

ExportLineweightTable Members


ExportLineweightTable Members

[image] [image]

Revit 2024 API
ExportLineweightTable Members
ExportLineweightTable Class Constructors Methods Properties See Also Send Feedback

The ExportLineweightTable type exposes the following members.

Constructors

 | Name | Description
Public method | ExportLineweightTable | Constructs a new ExportLineweightTable with default settings.

Methods

 | Name | Description
Public method | Add | Inserts a (key, info) pair into Export line weight table.
Public method | Clear | Removes all contents stored in Export line weight table.
Public method | ContainsKey | Checks whether a line weight key exists in the table.
Public method | Dispose | Releases all resources used by the ExportLineweightTable
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetExportLineweightInfo | Gets a copy of the ExportLineweightInfo corresponding to the given ExportLineweightKey.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetKeys | Gets all the keys stored in the map.
Public method | GetLineweightTableIterator | Returns a ExportLineweightTableIterator that iterates through the collection.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValues | Returns all the values stored in the map.
Public method | Remove | Removes the pair (key, info) corresponding to the given ExportLineweightKey.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Count of the items contained in the collection.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Item | A copy of the ExportLineweightInfo for the line weight's ExportLineweightKey.

See Also

ExportLineweightTable Class


ExportLineweightTable Constructor

[image]

Revit 2024 API
ExportLineweightTable Constructor
ExportLineweightTable Class See Also Send Feedback
Constructs a new ExportLineweightTable with default settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ExportLineweightTable()
Visual Basic
Public Sub New
Visual C++
public:
ExportLineweightTable()

See Also

ExportLineweightTable Class


ExportLineweightTable Methods

[image] [image]

Revit 2024 API
ExportLineweightTable Methods
ExportLineweightTable Class See Also Send Feedback

The ExportLineweightTable type exposes the following members.

Methods

 | Name | Description
Public method | Add | Inserts a (key, info) pair into Export line weight table.
Public method | Clear | Removes all contents stored in Export line weight table.
Public method | ContainsKey | Checks whether a line weight key exists in the table.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetExportLineweightInfo | Gets a copy of the ExportLineweightInfo corresponding to the given ExportLineweightKey.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetKeys | Gets all the keys stored in the map.
Public method | GetLineweightTableIterator | Returns a ExportLineweightTableIterator that iterates through the collection.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValues | Returns all the values stored in the map.
Public method | Remove | Removes the pair (key, info) corresponding to the given ExportLineweightKey.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ExportLineweightTable Class


Add Method

[image]

Revit 2024 API
ExportLineweightTable..::..Add Method
ExportLineweightTable Class See Also Send Feedback
Inserts a (key, info) pair into Export line weight table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Add(
    ExportLineweightKey exportLineweightKey,
    ExportLineweightInfo exportLineweightInfo
)
Visual Basic
Public Sub Add ( _
    exportLineweightKey As ExportLineweightKey, _
    exportLineweightInfo As ExportLineweightInfo _
)
Visual C++
public:
void Add(
    ExportLineweightKey^ exportLineweightKey,
    ExportLineweightInfo^ exportLineweightInfo
)

Parameters

exportLineweightKey
Type: Autodesk.Revit.DB..::..ExportLineweightKey
The export line weight Key to be added.
exportLineweightInfo
Type: Autodesk.Revit.DB..::..ExportLineweightInfo
The export line weight info to be added.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The key already exists in the table.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExportLineweightTable Class


ContainsKey Method

[image]

Revit 2024 API
ExportLineweightTable..::..ContainsKey Method
ExportLineweightTable Class See Also Send Feedback
Checks whether a line weight key exists in the table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool ContainsKey(
    ExportLineweightKey exportLineweightKey
)
Visual Basic
Public Function ContainsKey ( _
    exportLineweightKey As ExportLineweightKey _
) As Boolean
Visual C++
public:
bool ContainsKey(
    ExportLineweightKey^ exportLineweightKey
)

Parameters

exportLineweightKey
Type: Autodesk.Revit.DB..::..ExportLineweightKey
The export line weight key.

Return Value

True if the line weight exists in the table.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExportLineweightTable Class


Dispose Method

[image]

Revit 2024 API
ExportLineweightTable..::..Dispose Method
ExportLineweightTable Class See Also Send Feedback
Releases all resources used by the ExportLineweightTable

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ExportLineweightTable Class


GetBasicIEnumerator Method

[image]

Revit 2024 API
ExportLineweightTable..::..GetBasicIEnumerator Method
ExportLineweightTable Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
internal virtual IEnumerator GetBasicIEnumerator()
Visual Basic
Friend Overridable Function GetBasicIEnumerator As IEnumerator
Visual C++
internal:
virtual IEnumerator^ GetBasicIEnumerator()

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

ExportLineweightTable Class


GetEnumerator Method

[image]

Revit 2024 API
ExportLineweightTable..::..GetEnumerator Method
ExportLineweightTable Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IEnumerator<KeyValuePair<ExportLineweightKey, ExportLineweightInfo>> GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator(Of KeyValuePair(Of ExportLineweightKey, ExportLineweightInfo))
Visual C++
public:
virtual IEnumerator<KeyValuePair<ExportLineweightKey^, ExportLineweightInfo^>>^ GetEnumerator()

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

ExportLineweightTable Class


GetExportLineweightInfo Method

[image]

Revit 2024 API
ExportLineweightTable..::..GetExportLineweightInfo Method
ExportLineweightTable Class See Also Send Feedback
Gets a copy of the ExportLineweightInfo corresponding to the given ExportLineweightKey.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ExportLineweightInfo GetExportLineweightInfo(
    ExportLineweightKey exportLineweightKey
)
Visual Basic
Public Function GetExportLineweightInfo ( _
    exportLineweightKey As ExportLineweightKey _
) As ExportLineweightInfo
Visual C++
public:
ExportLineweightInfo^ GetExportLineweightInfo(
    ExportLineweightKey^ exportLineweightKey
)

Parameters

exportLineweightKey
Type: Autodesk.Revit.DB..::..ExportLineweightKey
The export line weight Key.

Return Value

Returns the line weight info for this key.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | An entry with the given key is not present in the table.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExportLineweightTable Class


GetKeys Method

[image]

Revit 2024 API
ExportLineweightTable..::..GetKeys Method
ExportLineweightTable Class See Also Send Feedback
Gets all the keys stored in the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public IList<ExportLineweightKey> GetKeys()
Visual Basic
Public Function GetKeys As IList(Of ExportLineweightKey)
Visual C++
public:
IList<ExportLineweightKey^>^ GetKeys()

Return Value

The keys.

See Also

ExportLineweightTable Class


GetValues Method

[image]

Revit 2024 API
ExportLineweightTable..::..GetValues Method
ExportLineweightTable Class See Also Send Feedback
Returns all the values stored in the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public IList<ExportLineweightInfo> GetValues()
Visual Basic
Public Function GetValues As IList(Of ExportLineweightInfo)
Visual C++
public:
IList<ExportLineweightInfo^>^ GetValues()

Return Value

The info.

See Also

ExportLineweightTable Class


Remove Method

[image]

Revit 2024 API
ExportLineweightTable..::..Remove Method
ExportLineweightTable Class See Also Send Feedback
Removes the pair (key, info) corresponding to the given ExportLineweightKey.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Remove(
    ExportLineweightKey exportLineweightKey
)
Visual Basic
Public Sub Remove ( _
    exportLineweightKey As ExportLineweightKey _
)
Visual C++
public:
void Remove(
    ExportLineweightKey^ exportLineweightKey
)

Parameters

exportLineweightKey
Type: Autodesk.Revit.DB..::..ExportLineweightKey
The export line weight key

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExportLineweightTable Class


IsValidObject Property

[image]

Revit 2024 API
ExportLineweightTable..::..IsValidObject Property
ExportLineweightTable Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ExportLineweightTable Class


ExportLineweightTableIterator Class

[image]

Revit 2024 API
ExportLineweightTableIterator Class
Members See Also Send Feedback
An iterator to a set of line weight table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class ExportLineweightTableIterator : IEnumerator<KeyValuePair<ExportLineweightKey, ExportLineweightInfo>>
Visual Basic
Public Class ExportLineweightTableIterator _
    Implements IEnumerator(Of KeyValuePair(Of ExportLineweightKey, ExportLineweightInfo))
Visual C++
public ref class ExportLineweightTableIterator : IEnumerator<KeyValuePair<ExportLineweightKey^, ExportLineweightInfo^>>

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ExportLineweightTableIterator

See Also

ExportLineweightTableIterator Members


ExportLineweightTableIterator Methods

[image] [image]

Revit 2024 API
ExportLineweightTableIterator Methods
ExportLineweightTableIterator Class See Also Send Feedback

The ExportLineweightTableIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next item.
Public method | Reset | Resets the iterator to the initial state.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ExportLineweightTableIterator Class


Dispose Method

[image]

Revit 2024 API
ExportLineweightTableIterator..::..Dispose Method
ExportLineweightTableIterator Class See Also Send Feedback
Releases all resources used by the ExportLineweightTableIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

See Also

ExportLineweightTableIterator Class


IsDone Method

[image]

Revit 2024 API
ExportLineweightTableIterator..::..IsDone Method
ExportLineweightTableIterator Class See Also Send Feedback
Identifies if the iteration has completed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public virtual bool IsDone()
Visual Basic
Public Overridable Function IsDone As Boolean
Visual C++
public:
virtual bool IsDone()

Return Value

True if the iteration has no more items. False if there are more items to be iterated.

See Also

ExportLineweightTableIterator Class


MoveNext Method

[image]

Revit 2024 API
ExportLineweightTableIterator..::..MoveNext Method
ExportLineweightTableIterator Class See Also Send Feedback
Increments the iterator to the next item.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

True if the iteration has no more items. False if there are more items to be iterated.

See Also

ExportLineweightTableIterator Class


ExportLineweightTableIterator Properties

[image] [image]

Revit 2024 API
ExportLineweightTableIterator Properties
ExportLineweightTableIterator Class See Also Send Feedback

The ExportLineweightTableIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ExportLineweightTableIterator Class


Current Property

[image]

Revit 2024 API
ExportLineweightTableIterator..::..Current Property
ExportLineweightTableIterator Class See Also Send Feedback
Gets the item at the current position of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual KeyValuePair<ExportLineweightKey, ExportLineweightInfo> Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As KeyValuePair(Of ExportLineweightKey, ExportLineweightInfo)
    Get
Visual C++
public:
virtual property KeyValuePair<ExportLineweightKey^, ExportLineweightInfo^> Current {
    KeyValuePair<ExportLineweightKey^, ExportLineweightInfo^> get ();
}

Implements

IEnumerator<(Of <(<'T>)>)>..::..Current

Remarks

There is no current item if the iterator has not started yet or has been done.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | There is no current item in the iterator.

See Also

ExportLineweightTableIterator Class


CurrentObject Property

[image]

Revit 2024 API
ExportLineweightTableIterator..::..CurrentObject Property
ExportLineweightTableIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
internal Object CurrentObject { get; }
Visual Basic
Friend ReadOnly Property CurrentObject As Object
    Get
Visual C++
internal:
virtual property Object^ CurrentObject {
    Object^ get () sealed;
}

Implements

IEnumerator..::..Current

See Also

ExportLineweightTableIterator Class


IsValidObject Property

[image]

Revit 2024 API
ExportLineweightTableIterator..::..IsValidObject Property
ExportLineweightTableIterator Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ExportLineweightTableIterator Class


ExportPaperFormat Enumeration

[image]

Revit 2024 API
ExportPaperFormat Enumeration
See Also Send Feedback
Paper formats supported by export

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum ExportPaperFormat
Visual Basic
Public Enumeration ExportPaperFormat
Visual C++
public enum class ExportPaperFormat

Members

Member name | Description
Default | Default paper format.
ANSI_A | ANSI A, 8.5 x 11 in
ANSI_B | ANSI B, 11 x 17 in
ANSI_C | ANSI C, 17 x 22 in
ANSI_D | ANSI D, 22 x 34 in
ANSI_E | ANSI E, 34 x 44 in
ISO_A4 | ISO A4, 210 x 297 mm
ISO_A3 | ISO A3, 297 x 420 mm
ISO_A2 | ISO A2, 420 x 594 mm
ISO_A1 | ISO A1, 594 x 841 mm
ISO_A0 | ISO A0, 841 x 1189 mm
ISO_B4 | ISO B4, 250 x 353 mm
ISO_B3 | ISO B3, 353 x 500 mm
ISO_B2 | ISO B2, 500 x 707 mm
ISO_B1 | ISO B1, 707 x 1000 mm
ARCH_A | ARCH A, 9 x 12 in
ARCH_B | ARCH B, 12 x 18 in
ARCH_C | ARCH C, 18 x 24 in
ARCH_D | ARCH D, 24 x 36 in
ARCH_E | ARCH E, 36 x 48 in
ARCH_E1 | ARCH E1, 30 x 42 in
ARCH_E2 | ARCH E2, 26 x 38 in
ARCH_E3 | ARCH E3, 27 x 39 in

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


ExportPatternInfo Class

[image]

Revit 2024 API
ExportPatternInfo Class
Members See Also Send Feedback
A value used to represent the info stored in the ExportPatternTable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class ExportPatternInfo : IDisposable
Visual Basic
Public Class ExportPatternInfo _
    Implements IDisposable
Visual C++
public ref class ExportPatternInfo : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ExportPatternInfo

See Also

ExportPatternInfo Members


ExportPatternInfo Members

[image] [image]

Revit 2024 API
ExportPatternInfo Members
ExportPatternInfo Class Constructors Methods Properties See Also Send Feedback

The ExportPatternInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ExportPatternInfo()()()() | Constructs a new default ExportPatternInfo.
Public method | ExportPatternInfo(String) | Constructs a new ExportPatternInfo using the destination pattern name as input.
Public method | ExportPatternInfo(ExportPatternInfo) | Constructs a new copy of the input ExportPatternInfo object.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ExportPatternInfo
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DestinationPatternName | The destination pattern name (the name of the pattern in the exported format).
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ExportPatternInfo Class


ExportPatternInfo Constructor

[image] [image]

Revit 2024 API
ExportPatternInfo Constructor
ExportPatternInfo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ExportPatternInfo()()()() | Constructs a new default ExportPatternInfo.
Public method | ExportPatternInfo(String) | Constructs a new ExportPatternInfo using the destination pattern name as input.
Public method | ExportPatternInfo(ExportPatternInfo) | Constructs a new copy of the input ExportPatternInfo object.

See Also

ExportPatternInfo Class
ExportPatternInfo Members


ExportPatternInfo Constructor

[image]

Revit 2024 API
ExportPatternInfo Constructor
ExportPatternInfo Class See Also Send Feedback
Constructs a new default ExportPatternInfo.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ExportPatternInfo()
Visual Basic
Public Sub New
Visual C++
public:
ExportPatternInfo()

See Also

ExportPatternInfo Class
ExportPatternInfo Overload


ExportPatternInfo Constructor (String)

[image]

Revit 2024 API
ExportPatternInfo Constructor (String)
ExportPatternInfo Class See Also Send Feedback
Constructs a new ExportPatternInfo using the destination pattern name as input.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ExportPatternInfo(
    string destinationPatternName
)
Visual Basic
Public Sub New ( _
    destinationPatternName As String _
)
Visual C++
public:
ExportPatternInfo(
    String^ destinationPatternName
)

Parameters

destinationPatternName
Type: System..::..String
The destination pattern name (the name of the pattern in the exported format).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExportPatternInfo Class
ExportPatternInfo Overload


ExportPatternInfo Constructor (ExportPatternInfo)

[image]

Revit 2024 API
ExportPatternInfo Constructor (ExportPatternInfo)
ExportPatternInfo Class See Also Send Feedback
Constructs a new copy of the input ExportPatternInfo object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ExportPatternInfo(
    ExportPatternInfo other
)
Visual Basic
Public Sub New ( _
    other As ExportPatternInfo _
)
Visual C++
public:
ExportPatternInfo(
    ExportPatternInfo^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..ExportPatternInfo

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExportPatternInfo Class
ExportPatternInfo Overload


ExportPatternInfo Methods

[image] [image]

Revit 2024 API
ExportPatternInfo Methods
ExportPatternInfo Class See Also Send Feedback

The ExportPatternInfo type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ExportPatternInfo Class


Dispose Method

[image]

Revit 2024 API
ExportPatternInfo..::..Dispose Method
ExportPatternInfo Class See Also Send Feedback
Releases all resources used by the ExportPatternInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ExportPatternInfo Class


ExportPatternInfo Properties

[image] [image]

Revit 2024 API
ExportPatternInfo Properties
ExportPatternInfo Class See Also Send Feedback

The ExportPatternInfo type exposes the following members.

Properties

 | Name | Description
Public property | DestinationPatternName | The destination pattern name (the name of the pattern in the exported format).
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ExportPatternInfo Class


DestinationPatternName Property

[image]

Revit 2024 API
ExportPatternInfo..::..DestinationPatternName Property
ExportPatternInfo Class See Also Send Feedback
The destination pattern name (the name of the pattern in the exported format).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public string DestinationPatternName { get; set; }
Visual Basic
Public Property DestinationPatternName As String
    Get
    Set
Visual C++
public:
property String^ DestinationPatternName {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ExportPatternInfo Class


IsValidObject Property

[image]

Revit 2024 API
ExportPatternInfo..::..IsValidObject Property
ExportPatternInfo Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ExportPatternInfo Class


ExportPatternKey Class

[image]

Revit 2024 API
ExportPatternKey Class
Members See Also Send Feedback
A key used to represent an item stored in an ExportPatternTable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class ExportPatternKey : IDisposable
Visual Basic
Public Class ExportPatternKey _
    Implements IDisposable
Visual C++
public ref class ExportPatternKey : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ExportPatternKey

See Also

ExportPatternKey Members


ExportPatternKey Constructor

[image] [image]

Revit 2024 API
ExportPatternKey Constructor
ExportPatternKey Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ExportPatternKey()()()() | Constructs a new default ExportPatternKey.
Public method | ExportPatternKey(ExportPatternKey) | Constructs a new copy of the input ExportPatternKey object.
Public method | ExportPatternKey(FillPatternTarget, String) | Constructs a new ExportPatternKey using the original fill pattern type and name as input.

See Also

ExportPatternKey Class
ExportPatternKey Members


ExportPatternKey Constructor

[image]

Revit 2024 API
ExportPatternKey Constructor
ExportPatternKey Class See Also Send Feedback
Constructs a new default ExportPatternKey.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ExportPatternKey()
Visual Basic
Public Sub New
Visual C++
public:
ExportPatternKey()

See Also

ExportPatternKey Class
ExportPatternKey Overload


ExportPatternKey Constructor (FillPatternTarget, String)

[image]

Revit 2024 API
ExportPatternKey Constructor (FillPatternTarget, String)
ExportPatternKey Class See Also Send Feedback
Constructs a new ExportPatternKey using the original fill pattern type and name as input.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ExportPatternKey(
    FillPatternTarget originalFillPatternType,
    string originalFillPatternName
)
Visual Basic
Public Sub New ( _
    originalFillPatternType As FillPatternTarget, _
    originalFillPatternName As String _
)
Visual C++
public:
ExportPatternKey(
    FillPatternTarget originalFillPatternType,
    String^ originalFillPatternName
)

Parameters

originalFillPatternType
Type: Autodesk.Revit.DB..::..FillPatternTarget
The original FillPattern type.
originalFillPatternName
Type: System..::..String
The original FillPattern name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

ExportPatternKey Class
ExportPatternKey Overload


ExportPatternKey Methods

[image] [image]

Revit 2024 API
ExportPatternKey Methods
ExportPatternKey Class See Also Send Feedback

The ExportPatternKey type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ExportPatternKey Class


Dispose Method

[image]

Revit 2024 API
ExportPatternKey..::..Dispose Method
ExportPatternKey Class See Also Send Feedback
Releases all resources used by the ExportPatternKey

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ExportPatternKey Class


ExportPatternKey Properties

[image] [image]

Revit 2024 API
ExportPatternKey Properties
ExportPatternKey Class See Also Send Feedback

The ExportPatternKey type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OriginalFillPatternName | The original FillPattern name.
Public property | OriginalFillPatternType | The original FillPattern type.

See Also

ExportPatternKey Class


IsValidObject Property

[image]

Revit 2024 API
ExportPatternKey..::..IsValidObject Property
ExportPatternKey Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ExportPatternKey Class


OriginalFillPatternName Property

[image]

Revit 2024 API
ExportPatternKey..::..OriginalFillPatternName Property
ExportPatternKey Class See Also Send Feedback
The original FillPattern name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public string OriginalFillPatternName { get; set; }
Visual Basic
Public Property OriginalFillPatternName As String
    Get
    Set
Visual C++
public:
property String^ OriginalFillPatternName {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ExportPatternKey Class


OriginalFillPatternType Property

[image]

Revit 2024 API
ExportPatternKey..::..OriginalFillPatternType Property
ExportPatternKey Class See Also Send Feedback
The original FillPattern type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public FillPatternTarget OriginalFillPatternType { get; set; }
Visual Basic
Public Property OriginalFillPatternType As FillPatternTarget
    Get
    Set
Visual C++
public:
property FillPatternTarget OriginalFillPatternType {
    FillPatternTarget get ();
    void set (FillPatternTarget value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

ExportPatternKey Class


ExportPatternTable Class

[image]

Revit 2024 API
ExportPatternTable Class
Members See Also Send Feedback
A table supporting a mapping of FillPatterns in Revit to pattern names that will be set in the target export format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class ExportPatternTable : IEnumerable<KeyValuePair<ExportPatternKey, ExportPatternInfo>>,
    IDisposable
Visual Basic
Public Class ExportPatternTable _
    Implements IEnumerable(Of KeyValuePair(Of ExportPatternKey, ExportPatternInfo)),  _
    IDisposable
Visual C++
public ref class ExportPatternTable : IEnumerable<KeyValuePair<ExportPatternKey^, ExportPatternInfo^>>,
    IDisposable

Remarks

This table is structured as a mapping from ExportPatternKey to ExportPatternInfo members. The ExportPatternKey contains the identification information for the pattern table: the Revit fill pattern type and name. The ExportPatternInfo contains the pattern name to use in the export format.

The table can be accessed via direct iteration as a collection of KeyValuePairs, or by traversal of the stored keys obtained from GetKeys(), or via specific lookup of a key constructed externally. In all cases, the ExportPatternInfo returned will be a copy of the ExportPatternInfo from the table. In order to make changes to the ExportPatternInfo and use those settings during export, set the modified ExportPatternInfo back into the table using the same key.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ExportPatternTable

See Also

ExportPatternTable Members


ExportPatternTable Constructor

[image]

Revit 2024 API
ExportPatternTable Constructor
ExportPatternTable Class See Also Send Feedback
Constructs a new ExportPatternTable with default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ExportPatternTable()
Visual Basic
Public Sub New
Visual C++
public:
ExportPatternTable()

See Also

ExportPatternTable Class


Add Method

[image]

Revit 2024 API
ExportPatternTable..::..Add Method
ExportPatternTable Class See Also Send Feedback
Inserts a (key,info) pair into Export pattern table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void Add(
    ExportPatternKey exportPatternKey,
    ExportPatternInfo exportPatternInfo
)
Visual Basic
Public Sub Add ( _
    exportPatternKey As ExportPatternKey, _
    exportPatternInfo As ExportPatternInfo _
)
Visual C++
public:
void Add(
    ExportPatternKey^ exportPatternKey,
    ExportPatternInfo^ exportPatternInfo
)

Parameters

exportPatternKey
Type: Autodesk.Revit.DB..::..ExportPatternKey
The export pattern key to be added.
exportPatternInfo
Type: Autodesk.Revit.DB..::..ExportPatternInfo
The export pattern info to be added.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The key already exists in the table.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExportPatternTable Class


Clear Method

[image]

Revit 2024 API
ExportPatternTable..::..Clear Method
ExportPatternTable Class See Also Send Feedback
Removes all contents stored in the table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

See Also

ExportPatternTable Class


ContainsKey Method

[image]

Revit 2024 API
ExportPatternTable..::..ContainsKey Method
ExportPatternTable Class See Also Send Feedback
Checks whether a pattern key exists in the table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool ContainsKey(
    ExportPatternKey exportpatternKey
)
Visual Basic
Public Function ContainsKey ( _
    exportpatternKey As ExportPatternKey _
) As Boolean
Visual C++
public:
bool ContainsKey(
    ExportPatternKey^ exportpatternKey
)

Parameters

exportpatternKey
Type: Autodesk.Revit.DB..::..ExportPatternKey
The export pattern Key.

Return Value

True if the pattern key exists in the table.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExportPatternTable Class


GetBasicIEnumerator Method

[image]

Revit 2024 API
ExportPatternTable..::..GetBasicIEnumerator Method
ExportPatternTable Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
internal virtual IEnumerator GetBasicIEnumerator()
Visual Basic
Friend Overridable Function GetBasicIEnumerator As IEnumerator
Visual C++
internal:
virtual IEnumerator^ GetBasicIEnumerator()

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

ExportPatternTable Class


GetEnumerator Method

[image]

Revit 2024 API
ExportPatternTable..::..GetEnumerator Method
ExportPatternTable Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IEnumerator<KeyValuePair<ExportPatternKey, ExportPatternInfo>> GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator(Of KeyValuePair(Of ExportPatternKey, ExportPatternInfo))
Visual C++
public:
virtual IEnumerator<KeyValuePair<ExportPatternKey^, ExportPatternInfo^>>^ GetEnumerator()

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

ExportPatternTable Class


GetExportPatternInfo Method

[image]

Revit 2024 API
ExportPatternTable..::..GetExportPatternInfo Method
ExportPatternTable Class See Also Send Feedback
Gets a copy of the pattern info associated to the input pattern key.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ExportPatternInfo GetExportPatternInfo(
    ExportPatternKey exportPatternKey
)
Visual Basic
Public Function GetExportPatternInfo ( _
    exportPatternKey As ExportPatternKey _
) As ExportPatternInfo
Visual C++
public:
ExportPatternInfo^ GetExportPatternInfo(
    ExportPatternKey^ exportPatternKey
)

Parameters

exportPatternKey
Type: Autodesk.Revit.DB..::..ExportPatternKey
The export pattern Key.

Return Value

Return the patternInfo for this key.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | An entry with the given key is not present in the table.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExportPatternTable Class


GetPatternTableIterator Method

[image]

Revit 2024 API
ExportPatternTable..::..GetPatternTableIterator Method
ExportPatternTable Class See Also Send Feedback
Returns a PatternTableIterator that iterates through the collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ExportPatternTableIterator GetPatternTableIterator()
Visual Basic
Public Function GetPatternTableIterator As ExportPatternTableIterator
Visual C++
public:
ExportPatternTableIterator^ GetPatternTableIterator()

Return Value

A PatternTableIterator object that can be used to iterate through key-value pairs in the collection.

See Also

ExportPatternTable Class


GetValues Method

[image]

Revit 2024 API
ExportPatternTable..::..GetValues Method
ExportPatternTable Class See Also Send Feedback
Returns all the values stored in the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public IList<ExportPatternInfo> GetValues()
Visual Basic
Public Function GetValues As IList(Of ExportPatternInfo)
Visual C++
public:
IList<ExportPatternInfo^>^ GetValues()

Return Value

Return the info array.

See Also

ExportPatternTable Class


Remove Method

[image]

Revit 2024 API
ExportPatternTable..::..Remove Method
ExportPatternTable Class See Also Send Feedback
Removes the pair (key, info) by pattern key.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void Remove(
    ExportPatternKey exportPatternKey
)
Visual Basic
Public Sub Remove ( _
    exportPatternKey As ExportPatternKey _
)
Visual C++
public:
void Remove(
    ExportPatternKey^ exportPatternKey
)

Parameters

exportPatternKey
Type: Autodesk.Revit.DB..::..ExportPatternKey
The export pattern key.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExportPatternTable Class


Count Property

[image]

Revit 2024 API
ExportPatternTable..::..Count Property
ExportPatternTable Class See Also Send Feedback
Count of the items contained in the collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get
Visual C++
public:
property int Count {
    int get ();
}

See Also

ExportPatternTable Class


IsValidObject Property

[image]

Revit 2024 API
ExportPatternTable..::..IsValidObject Property
ExportPatternTable Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ExportPatternTable Class


Item Property

[image]

Revit 2024 API
ExportPatternTable..::..Item Property
ExportPatternTable Class See Also Send Feedback
A copy of the ExportPatternInfo for the pattern's ExportPatternKey.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ExportPatternInfo this[
    ExportPatternKey patternKey
] { get; set; }
Visual Basic
Public Default Property Item ( _
    patternKey As ExportPatternKey _
) As ExportPatternInfo
    Get
    Set
Visual C++
public:
virtual property ExportPatternInfo^ default[ExportPatternKey^ patternKey] {
    ExportPatternInfo^ get (ExportPatternKey^ patternKey) sealed;
    void set (ExportPatternKey^ patternKey, ExportPatternInfo^ value) sealed;
}

Parameters

patternKey
Type: Autodesk.Revit.DB..::..ExportPatternKey

Return Value

A copy of the ExportPatternInfo.

Remarks

When getting this property, it returns a copy of the ExportPatternInfo from the table. In order to make changes to the ExportPatternInfo and use those settings during export, set the modified ExportPatternInfo back into the table using the same key.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When getting this property: An entry with the given key is not present in the table.

See Also

ExportPatternTable Class


ExportPatternTableIterator Class

[image]

Revit 2024 API
ExportPatternTableIterator Class
Members See Also Send Feedback
An iterator to a set of Pattern table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class ExportPatternTableIterator : IEnumerator<KeyValuePair<ExportPatternKey, ExportPatternInfo>>
Visual Basic
Public Class ExportPatternTableIterator _
    Implements IEnumerator(Of KeyValuePair(Of ExportPatternKey, ExportPatternInfo))
Visual C++
public ref class ExportPatternTableIterator : IEnumerator<KeyValuePair<ExportPatternKey^, ExportPatternInfo^>>

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ExportPatternTableIterator

See Also

ExportPatternTableIterator Members


ExportPatternTableIterator Members

[image] [image]

Revit 2024 API
ExportPatternTableIterator Members
ExportPatternTableIterator Class Methods Properties See Also Send Feedback

The ExportPatternTableIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ExportPatternTableIterator
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next item.
Public method | Reset | Resets the iterator to the initial state.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ExportPatternTableIterator Class


ExportPatternTableIterator Methods

[image] [image]

Revit 2024 API
ExportPatternTableIterator Methods
ExportPatternTableIterator Class See Also Send Feedback

The ExportPatternTableIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next item.
Public method | Reset | Resets the iterator to the initial state.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ExportPatternTableIterator Class


IsDone Method

[image]

Revit 2024 API
ExportPatternTableIterator..::..IsDone Method
ExportPatternTableIterator Class See Also Send Feedback
Identifies if the iteration has completed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public virtual bool IsDone()
Visual Basic
Public Overridable Function IsDone As Boolean
Visual C++
public:
virtual bool IsDone()

Return Value

True if the iteration has no more items. False if there are more items to be iterated.

See Also

ExportPatternTableIterator Class


MoveNext Method

[image]

Revit 2024 API
ExportPatternTableIterator..::..MoveNext Method
ExportPatternTableIterator Class See Also Send Feedback
Increments the iterator to the next item.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

True if there is a next available item in this iterator. False if the iterator has completed all available items.

See Also

ExportPatternTableIterator Class


Current Property

[image]

Revit 2024 API
ExportPatternTableIterator..::..Current Property
ExportPatternTableIterator Class See Also Send Feedback
Gets the item at the current position of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual KeyValuePair<ExportPatternKey, ExportPatternInfo> Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As KeyValuePair(Of ExportPatternKey, ExportPatternInfo)
    Get
Visual C++
public:
virtual property KeyValuePair<ExportPatternKey^, ExportPatternInfo^> Current {
    KeyValuePair<ExportPatternKey^, ExportPatternInfo^> get ();
}

Implements

IEnumerator<(Of <(<'T>)>)>..::..Current

Remarks

There is no current item if the iterator has not started yet or has been done.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | There is no current item in the iterator.

See Also

ExportPatternTableIterator Class


CurrentObject Property

[image]

Revit 2024 API
ExportPatternTableIterator..::..CurrentObject Property
ExportPatternTableIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
internal Object CurrentObject { get; }
Visual Basic
Friend ReadOnly Property CurrentObject As Object
    Get
Visual C++
internal:
virtual property Object^ CurrentObject {
    Object^ get () sealed;
}

Implements

IEnumerator..::..Current

See Also

ExportPatternTableIterator Class


IsValidObject Property

[image]

Revit 2024 API
ExportPatternTableIterator..::..IsValidObject Property
ExportPatternTableIterator Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ExportPatternTableIterator Class


ExportPDFSettings Class

[image]

Revit 2024 API
ExportPDFSettings Class
Members See Also Send Feedback
Settings for PDF export

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public class ExportPDFSettings : Element
Visual Basic
Public Class ExportPDFSettings _
    Inherits Element
Visual C++
public ref class ExportPDFSettings : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ExportPDFSettings

See Also

ExportPDFSettings Members


ExportPDFSettings Members

[image] [image]

Revit 2024 API
ExportPDFSettings Members
ExportPDFSettings Class Methods Properties See Also Send Feedback

The ExportPDFSettings type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create | Returns an new created ExportPDFSettings element in the document with specified settings.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
 | FindByName | Returns settings element by name.
 | GetActivePredefinedSettings | Gets the active settings element in the document.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOptions | Gets a copy of options from settings for exporting. Modification on this options would not change the element.
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
 | IsValidName | Returns result that the proposed name is valid and not exist in the specified document.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
 | ListNames | Returns all the names of the settings instances in the document.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetOptions | Sets options for exporting.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ExportPDFSettings Class


Create Method

[image]

Revit 2024 API
ExportPDFSettings..::..Create Method
ExportPDFSettings Class See Also Send Feedback
Returns an new created ExportPDFSettings element in the document with specified settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public static ExportPDFSettings Create(
    Document document,
    string name,
    PDFExportOptions options
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    name As String, _
    options As PDFExportOptions _
) As ExportPDFSettings
Visual C++
public:
static ExportPDFSettings^ Create(
    Document^ document,
    String^ name,
    PDFExportOptions^ options
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Document where the settings will be created.
name
Type: System..::..String
Name to the settings.
options
Type: Autodesk.Revit.DB..::..PDFExportOptions
The options to be set.

Return Value

New instance of ExportPDFSettings just created in the document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | name is an empty string or contains only whitespace. -or- name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- Setting name.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

ExportPDFSettings Class


FindByName Method

[image]

Revit 2024 API
ExportPDFSettings..::..FindByName Method
ExportPDFSettings Class See Also Send Feedback
Returns settings element by name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public static ExportPDFSettings FindByName(
    Document document,
    string name
)
Visual Basic
Public Shared Function FindByName ( _
    document As Document, _
    name As String _
) As ExportPDFSettings
Visual C++
public:
static ExportPDFSettings^ FindByName(
    Document^ document,
    String^ name
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to find the settings with the specified name.
name
Type: System..::..String
Name of the settings to find.

Return Value

The settings element, or nullNothingnullptra null reference (Nothing in Visual Basic) if not found.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~".
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExportPDFSettings Class


GetActivePredefinedSettings Method

[image]

Revit 2024 API
ExportPDFSettings..::..GetActivePredefinedSettings Method
ExportPDFSettings Class See Also Send Feedback
Gets the active settings element in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public static ExportPDFSettings GetActivePredefinedSettings(
    Document document
)
Visual Basic
Public Shared Function GetActivePredefinedSettings ( _
    document As Document _
) As ExportPDFSettings
Visual C++
public:
static ExportPDFSettings^ GetActivePredefinedSettings(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to find the active settings.

Return Value

The active settings, or nullNothingnullptra null reference (Nothing in Visual Basic) if none.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExportPDFSettings Class


IsValidName Method

[image]

Revit 2024 API
ExportPDFSettings..::..IsValidName Method
ExportPDFSettings Class See Also Send Feedback
Returns result that the proposed name is valid and not exist in the specified document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public static bool IsValidName(
    Document document,
    string name
)
Visual Basic
Public Shared Function IsValidName ( _
    document As Document, _
    name As String _
) As Boolean
Visual C++
public:
static bool IsValidName(
    Document^ document,
    String^ name
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Document to check
name
Type: System..::..String
Name to check.

Return Value

Whether or not the name is valid.

Remarks

Name can't contains following characters, such as { } [ ] | ; < > ? ` ~ \ : \r \n \f \t \v. Name can't be blank. If true, the name is valid and not exist in specified document. If false, the name is not a valid name which means it does not exist in specified document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExportPDFSettings Class


ListNames Method

[image]

Revit 2024 API
ExportPDFSettings..::..ListNames Method
ExportPDFSettings Class See Also Send Feedback
Returns all the names of the settings instances in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public static IList<string> ListNames(
    Document document
)
Visual Basic
Public Shared Function ListNames ( _
    document As Document _
) As IList(Of String)
Visual C++
public:
static IList<String^>^ ListNames(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Document where the settings to be found.

Return Value

List of names.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExportPDFSettings Class


SetOptions Method

[image]

Revit 2024 API
ExportPDFSettings..::..SetOptions Method
ExportPDFSettings Class See Also Send Feedback
Sets options for exporting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public void SetOptions(
    PDFExportOptions options
)
Visual Basic
Public Sub SetOptions ( _
    options As PDFExportOptions _
)
Visual C++
public:
void SetOptions(
    PDFExportOptions^ options
)

Parameters

options
Type: Autodesk.Revit.DB..::..PDFExportOptions
Other options.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExportPDFSettings Class


ExportPDFSettings Properties

[image] [image]

Revit 2024 API
ExportPDFSettings Properties
ExportPDFSettings Class See Also Send Feedback

The ExportPDFSettings type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ExportPDFSettings Class


Parameter Property

[image] [image]

Revit 2024 API
ExportPDFSettings..::..Parameter Property
ExportPDFSettings Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ExportPDFSettings Class
ExportPDFSettings Members


ExportRange Enumeration

[image]

Revit 2024 API
ExportRange Enumeration
See Also Send Feedback
This enum is used to define what view, part of the view, or list of views will be exported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public enum ExportRange
Visual Basic
Public Enumeration ExportRange
Visual C++
public enum class ExportRange

Members

Member name | Description
CurrentView | Export the current view only (zoom to fit of the current view).
VisibleRegionOfCurrentView | Export the visible region of the current view.
SetOfViews | Export a set of views (set in ViewsAndSheets).

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


ExportResolution Enumeration

[image]

Revit 2024 API
ExportResolution Enumeration
See Also Send Feedback
An enumerated type listing possible options to control the tessellation quality.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023
Since: 2023

Syntax

C#
public enum ExportResolution
Visual Basic
Public Enumeration ExportResolution
Visual C++
public enum class ExportResolution

Members

Member name | Description
Custom | Tessellated export with custom resolution (all tessellation parameters have default values).
Fine | Tessellated export with fine resolution.
Medium | Tessellated export with medium resolution.
Coarse | Tessellated export with coarse resolution.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


ExportTextQualifier Enumeration

[image]

Revit 2024 API
ExportTextQualifier Enumeration
See Also Send Feedback
Options for the text qualifier character in schedule view export.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public enum ExportTextQualifier
Visual Basic
Public Enumeration ExportTextQualifier
Visual C++
public enum class ExportTextQualifier

Members

Member name | Description
None | No text qualifier.
Quote | The quote character - ' - is used to qualify text.
DoubleQuote | The quote character - " - is used to qualify text.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


ExportUnit Enumeration

[image]

Revit 2024 API
ExportUnit Enumeration
See Also Send Feedback
An enumerated type listing possible target units for CAD Export.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum ExportUnit
Visual Basic
Public Enumeration ExportUnit
Visual C++
public enum class ExportUnit

Members

Member name | Description
Default | Default export unit. Depends on Revit's current units.
Inch | Inches in fractional notation.
Foot | Feet and Inches in fractional notation.
Millimeter | Millimeters as decimal values.
Centimeter | Centimeters as decimal values.
Meter | Meters as decimal values.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


ExportUtils Class

[image]

Revit 2024 API
ExportUtils Class
Members See Also Send Feedback
This class provides utilities related to document export.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static class ExportUtils
Visual Basic
Public NotInheritable Class ExportUtils
Visual C++
public ref class ExportUtils abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ExportUtils

See Also

ExportUtils Members


ExportUtils Members

[image] [image]

Revit 2024 API
ExportUtils Members
ExportUtils Class Methods See Also Send Feedback

The ExportUtils type exposes the following members.

Methods

Name | Description
GetExportId(Subelement) | Retrieves the GUID representing the subelement in DWF and IFC export.
GetExportId(Document, ElementId) | Retrieves the GUID representing this element in DWF and IFC export.
GetGBXMLDocumentId | Retrieves the GUID representing this document in exported gbXML files.
GetNurbsSurfaceDataForSurface | Returns the necessary information to define a NURBS surface for a given [!:Autodesk::Revit::DB::HermiteSuface] or [!:Autodesk::Revit::DB::RuledSuface].

See Also

ExportUtils Class


ExportUtils Methods

[image] [image]

Revit 2024 API
ExportUtils Methods
ExportUtils Class See Also Send Feedback

The ExportUtils type exposes the following members.

Methods

Name | Description
GetExportId(Subelement) | Retrieves the GUID representing the subelement in DWF and IFC export.
GetExportId(Document, ElementId) | Retrieves the GUID representing this element in DWF and IFC export.
GetGBXMLDocumentId | Retrieves the GUID representing this document in exported gbXML files.
GetNurbsSurfaceDataForSurface | Returns the necessary information to define a NURBS surface for a given [!:Autodesk::Revit::DB::HermiteSuface] or [!:Autodesk::Revit::DB::RuledSuface].

See Also

ExportUtils Class


GetExportId Method

[image] [image]

Revit 2024 API
ExportUtils..::..GetExportId Method
ExportUtils Class See Also Send Feedback

Overload List

Name | Description
GetExportId(Subelement) | Retrieves the GUID representing the subelement in DWF and IFC export.
GetExportId(Document, ElementId) | Retrieves the GUID representing this element in DWF and IFC export.

See Also

ExportUtils Class
ExportUtils Members


GetExportId Method (Subelement)

[image]

Revit 2024 API
ExportUtils..::..GetExportId Method (Subelement)
ExportUtils Class See Also Send Feedback
Retrieves the GUID representing the subelement in DWF and IFC export.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public static Guid GetExportId(
    Subelement subelement
)
Visual Basic
Public Shared Function GetExportId ( _
    subelement As Subelement _
) As Guid
Visual C++
public:
static Guid GetExportId(
    Subelement^ subelement
)

Parameters

subelement
Type: Autodesk.Revit.DB..::..Subelement
The subelement.

Return Value

The value of the GUID representing the subelement in the export context.

Remarks

This id is used in the contents of DWF export and IFC export and it should be used only when cross-referencing to the contents of these export formats. When storing Ids that will need to be mapped back to subelements in future sessions, UniqueId must be used.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExportUtils Class
GetExportId Overload


GetGBXMLDocumentId Method

[image]

Revit 2024 API
ExportUtils..::..GetGBXMLDocumentId Method
ExportUtils Class See Also Send Feedback
Retrieves the GUID representing this document in exported gbXML files.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static Guid GetGBXMLDocumentId(
    Document document
)
Visual Basic
Public Shared Function GetGBXMLDocumentId ( _
    document As Document _
) As Guid
Visual C++
public:
static Guid GetGBXMLDocumentId(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.

Return Value

The value of the GUID representing this document in gbXML export.

Remarks

This id can be used to cross-reference different gbXML exports from the same document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExportUtils Class


GetNurbsSurfaceDataForSurface Method

[image]

Revit 2024 API
ExportUtils..::..GetNurbsSurfaceDataForSurface Method
ExportUtils Class See Also Send Feedback
Returns the necessary information to define a NURBS surface for a given [!:Autodesk::Revit::DB::HermiteSuface] or [!:Autodesk::Revit::DB::RuledSuface].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static NurbsSurfaceData GetNurbsSurfaceDataForSurface(
    Surface surface
)
Visual Basic
Public Shared Function GetNurbsSurfaceDataForSurface ( _
    surface As Surface _
) As NurbsSurfaceData
Visual C++
public:
static NurbsSurfaceData^ GetNurbsSurfaceDataForSurface(
    Surface^ surface
)

Parameters

surface
Type: Autodesk.Revit.DB..::..Surface
The HermiteSurface or RuledSurface to be converted.

Return Value

A class containing the necessary data to define a NURBS surface.

Remarks

This function is intended for export purposes.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This surface type is not supported for this function.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | Couldn't get NURBS data from surface.

See Also

ExportUtils Class


ExternalDefinition Class

[image]

Revit 2024 API
ExternalDefinition Class
Members Example See Also Send Feedback
The ExternalDefinition object adds properties specific to Autodesk Revit shared parameter definitions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class ExternalDefinition : Definition,
    IDisposable
Visual Basic
Public Class ExternalDefinition _
    Inherits Definition _
    Implements IDisposable
Visual C++
public ref class ExternalDefinition : public Definition,
    IDisposable

Remarks

The ExternalDefinition object can be created by a definition Group object from a shared parameters file. External parameter definition must belong to a Group which is nothing more than a collection of shared parameter definitions. The following process should be followed to add a parameter to an element: Open the shared parameters file, via the Application.OpenSharedParameterFile() method. Access an existing or create a new group, via the DefinitionFile.Groups property. Access an existing or create a new external parameter definition, via the DefinitionGroup.Definitions property. Create a new Binding object with the categories to which the parameter will be bound using an InstanceBinding or a TypeBinding object. Finally add the binding and definition to the document using the Document.ParameterBindings object.

Shared parameters added to elements are typically visible to interactive users. To add data to elements that is never visible to interactive users, use Extensible Storage to construct and populate the needed structured data.

Examples

CopyC#
private void ReadEditExternalParam(DefinitionFile file)
{
    // get ExternalDefinition from shared parameter file
    DefinitionGroups myGroups = file.Groups;
    DefinitionGroup myGroup = myGroups.get_Item("MyGroup");
    if (myGroup != null)
    {
         ExternalDefinition myExtDef = myGroup.Definitions.get_Item("MyParam") as ExternalDefinition;
         if (myExtDef != null)
         {
             DefinitionGroup newGroup = myGroups.get_Item("AnotherGroup");
             if (newGroup != null)
             {
                 // change the OwnerGroup of the ExternalDefinition
                 myExtDef.OwnerGroup = newGroup;
             }
         }
    }
}
CopyVB.NET
Private Sub ReadEditExternalParam(file As DefinitionFile)
   ' get ExternalDefinition from shared parameter file
   Dim myGroups As DefinitionGroups = file.Groups
   Dim myGroup As DefinitionGroup = myGroups.Item("MyGroup")
   If myGroup IsNot Nothing Then
      Dim myExtDef As ExternalDefinition = TryCast(myGroup.Definitions.Item("MyParam"), ExternalDefinition)
      If myExtDef IsNot Nothing Then
         Dim newGroup As DefinitionGroup = myGroups.Item("AnotherGroup")
         If newGroup IsNot Nothing Then
            ' change the OwnerGroup of the ExternalDefinition
            myExtDef.OwnerGroup = newGroup
         End If
      End If
   End If
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Definition
Autodesk.Revit.DB..::..ExternalDefinition

See Also

ExternalDefinition Members


ExternalDefinition Methods

[image] [image]

Revit 2024 API
ExternalDefinition Methods
ExternalDefinition Class See Also Send Feedback

The ExternalDefinition type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDataType | Gets a ForgeTypeId identifying the data type describing values of the parameter. (Inherited from Definition.)
Public method | GetGroupTypeId | Returns the identifier of the parameter definition's parameter group. (Overrides Definition..::..GetGroupTypeId()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ExternalDefinition Class


Dispose Method

[image]

Revit 2024 API
ExternalDefinition..::..Dispose Method
ExternalDefinition Class See Also Send Feedback
Releases all resources used by the ExternalDefinition

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ExternalDefinition Class


GetGroupTypeId Method

[image]

Revit 2024 API
ExternalDefinition..::..GetGroupTypeId Method
ExternalDefinition Class See Also Send Feedback
Returns the identifier of the parameter definition's parameter group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public override ForgeTypeId GetGroupTypeId()
Visual Basic
Public Overrides Function GetGroupTypeId As ForgeTypeId
Visual C++
public:
virtual ForgeTypeId^ GetGroupTypeId() override

See Also

ExternalDefinition Class


ExternalDefinition Properties

[image] [image]

Revit 2024 API
ExternalDefinition Properties
ExternalDefinition Class See Also Send Feedback

The ExternalDefinition type exposes the following members.

Properties

 | Name | Description
Public property | Description | The description of the parameter. The description will be used as tooltip in the Revit UI including in the properties palette.
Public property | GUID | Returns the GUID associated with the shared parameter definition.
Public property | HideWhenNoValue | Indicates whether this parameter should be hidden from the properties palette when it has no value.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | The user visible name for the parameter. (Overrides Definition..::..Name.)
Public property | OwnerGroup | Returns or change the group ID of the external parameter definition.
Public property | ParameterGroup | Obsolete. Returns the group ID of the parameter definition. (Overrides Definition..::..ParameterGroup.)
Public property | UserModifiable | Indicates whether the parameter can be modified by the user interface.
Public property | Visible | Indicates if the parameter is visible in the Autodesk Revit user interface.

See Also

ExternalDefinition Class


Description Property

[image]

Revit 2024 API
ExternalDefinition..::..Description Property
ExternalDefinition Class See Also Send Feedback
The description of the parameter. The description will be used as tooltip in the Revit UI including in the properties palette.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public virtual string Description { get; }
Visual Basic
Public Overridable ReadOnly Property Description As String
    Get
Visual C++
public:
virtual property String^ Description {
    String^ get ();
}

See Also

ExternalDefinition Class


GUID Property

[image]

Revit 2024 API
ExternalDefinition..::..GUID Property
ExternalDefinition Class See Also Send Feedback
Returns the GUID associated with the shared parameter definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Guid GUID { get; }
Visual Basic
Public Overridable ReadOnly Property GUID As Guid
    Get
Visual C++
public:
virtual property Guid GUID {
    Guid get ();
}

Remarks

Each shared parameter when created is issued a unique identifier. This identifier can then be used at a later time to retrieve the parameter from the Element ensuring that the correct parameter is always retrieved.

See Also

ExternalDefinition Class


HideWhenNoValue Property

[image]

Revit 2024 API
ExternalDefinition..::..HideWhenNoValue Property
ExternalDefinition Class See Also Send Feedback
Indicates whether this parameter should be hidden from the properties palette when it has no value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public bool HideWhenNoValue { get; set; }
Visual Basic
Public Property HideWhenNoValue As Boolean
    Get
    Set
Visual C++
public:
property bool HideWhenNoValue {
    bool get ();
    void set (bool value);
}

Field Value

If true, the parameter will be hidden from the properties palette when it has no value. If false, the parameter will always be shown in the properties palette, no matter if it has a value or not.

Remarks

Even when hidden, the parameter can still be accessed directly via the API.

See Also

ExternalDefinition Class


IsValidObject Property

[image]

Revit 2024 API
ExternalDefinition..::..IsValidObject Property
ExternalDefinition Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ExternalDefinition Class


Name Property

[image]

Revit 2024 API
ExternalDefinition..::..Name Property
ExternalDefinition Class See Also Send Feedback
The user visible name for the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

See Also

ExternalDefinition Class


OwnerGroup Property

[image]

Revit 2024 API
ExternalDefinition..::..OwnerGroup Property
ExternalDefinition Class See Also Send Feedback
Returns or change the group ID of the external parameter definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual DefinitionGroup OwnerGroup { get; set; }
Visual Basic
Public Overridable Property OwnerGroup As DefinitionGroup
    Get
    Set
Visual C++
public:
virtual property DefinitionGroup^ OwnerGroup {
    DefinitionGroup^ get ();
    void set (DefinitionGroup^ value);
}

Remarks

If failed When set the group, an InvalidOperationException will be thrown.

See Also

ExternalDefinition Class


ParameterGroup Property

[image]

Revit 2024 API
ExternalDefinition..::..ParameterGroup Property
ExternalDefinition Class See Also Send Feedback
Returns the group ID of the parameter definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
[ObsoleteAttribute("This property is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use the `GetGroupTypeId()` method instead.")]
public override BuiltInParameterGroup ParameterGroup { get; }
Visual Basic
<ObsoleteAttribute("This property is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use the `GetGroupTypeId()` method instead.")> _
Public Overrides ReadOnly Property ParameterGroup As BuiltInParameterGroup
    Get
Visual C++
[ObsoleteAttribute(L"This property is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use the `GetGroupTypeId()` method instead.")]
public:
virtual property BuiltInParameterGroup ParameterGroup {
    BuiltInParameterGroup get () override;
}

See Also

ExternalDefinition Class


UserModifiable Property

[image]

Revit 2024 API
ExternalDefinition..::..UserModifiable Property
ExternalDefinition Class See Also Send Feedback
Indicates whether the parameter can be modified by the user interface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool UserModifiable { get; }
Visual Basic
Public ReadOnly Property UserModifiable As Boolean
    Get
Visual C++
public:
property bool UserModifiable {
    bool get ();
}

Remarks

If true, the user can edit the value of this parameter. If false, the user cannot edit this value (it will appear grayed out). However, any API application can modify the value of this parameter.

See Also

ExternalDefinition Class


Visible Property

[image]

Revit 2024 API
ExternalDefinition..::..Visible Property
ExternalDefinition Class See Also Send Feedback
Indicates if the parameter is visible in the Autodesk Revit user interface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool Visible { get; }
Visual Basic
Public Overridable ReadOnly Property Visible As Boolean
    Get
Visual C++
public:
virtual property bool Visible {
    bool get ();
}

Remarks

The visible property controls whether a shared parameter is hidden from the user. This is useful if you wish to add data to an element that is only meaningful to your application and not to the user. This value can only be set when the shared parameter definition is created.

See Also

ExternalDefinition Class


ExternalDefinitionCreationOptions Class

[image]

Revit 2024 API
ExternalDefinitionCreationOptions Class
Members See Also Send Feedback
An option class used for creating a new shared parameter definition, including options such as name, type, visibility, Guid description and modifiable flag.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public class ExternalDefinitionCreationOptions : IDisposable
Visual Basic
Public Class ExternalDefinitionCreationOptions _
    Implements IDisposable
Visual C++
public ref class ExternalDefinitionCreationOptions : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ExternalDefinitionCreationOptions

See Also

ExternalDefinitionCreationOptions Members


ExternalDefinitionCreationOptions Members

[image] [image]

Revit 2024 API
ExternalDefinitionCreationOptions Members
ExternalDefinitionCreationOptions Class Constructors Methods Properties See Also Send Feedback

The ExternalDefinitionCreationOptions type exposes the following members.

Constructors

 | Name | Description
Public method | ExternalDefinitionCreationOptions | Constructs the options using a specified name and type.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ExternalDefinitionCreationOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDataType | Gets the identifier describing the parameter's data type. The identifier may belong to either a spec or a category. If it is a category, the parameter is a Family Type parameter of that category.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDataType | Sets the parameter's data type.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Description | The description of the parameter definition to be created. The description will be used as tooltip in the Revit UI including in the properties palette. The default is an empty string.
Public property | GUID | The GUID to use for this parameter definition. If not explicitly set, a random GUID is used.
Public property | HideWhenNoValue | This property indicates whether this parameter should be hidden from the properties palette when it doesn't have a value.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | The name of the parameter definition to be created.
Public property | UserModifiable | This property indicates whether this parameter can be modified by UI user or not.
Public property | Visible | True if the parameter is visible to the user, false if it is hidden and accessible only via the API. The default is true.

See Also

ExternalDefinitionCreationOptions Class


ExternalDefinitionCreationOptions Constructor

[image]

Revit 2024 API
ExternalDefinitionCreationOptions Constructor
ExternalDefinitionCreationOptions Class See Also Send Feedback
Constructs the options using a specified name and type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public ExternalDefinitionCreationOptions(
    string name,
    ForgeTypeId dataType
)
Visual Basic
Public Sub New ( _
    name As String, _
    dataType As ForgeTypeId _
)
Visual C++
public:
ExternalDefinitionCreationOptions(
    String^ name,
    ForgeTypeId^ dataType
)

Parameters

name
Type: System..::..String
The name of the parameter definition to be created.
dataType
Type: Autodesk.Revit.DB..::..ForgeTypeId
The identifier of either a spec or a category. A category identifier indicates a Family Type parameter of that category.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given identifier is neither a spec nor a category.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExternalDefinitionCreationOptions Class


ExternalDefinitionCreationOptions Methods

[image] [image]

Revit 2024 API
ExternalDefinitionCreationOptions Methods
ExternalDefinitionCreationOptions Class See Also Send Feedback

The ExternalDefinitionCreationOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDataType | Gets the identifier describing the parameter's data type. The identifier may belong to either a spec or a category. If it is a category, the parameter is a Family Type parameter of that category.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDataType | Sets the parameter's data type.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ExternalDefinitionCreationOptions Class


Dispose Method

[image]

Revit 2024 API
ExternalDefinitionCreationOptions..::..Dispose Method
ExternalDefinitionCreationOptions Class See Also Send Feedback
Releases all resources used by the ExternalDefinitionCreationOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ExternalDefinitionCreationOptions Class


GetDataType Method

[image]

Revit 2024 API
ExternalDefinitionCreationOptions..::..GetDataType Method
ExternalDefinitionCreationOptions Class See Also Send Feedback
Gets the identifier describing the parameter's data type. The identifier may belong to either a spec or a category. If it is a category, the parameter is a Family Type parameter of that category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public ForgeTypeId GetDataType()
Visual Basic
Public Function GetDataType As ForgeTypeId
Visual C++
public:
ForgeTypeId^ GetDataType()

See Also

ExternalDefinitionCreationOptions Class


SetDataType Method

[image]

Revit 2024 API
ExternalDefinitionCreationOptions..::..SetDataType Method
ExternalDefinitionCreationOptions Class See Also Send Feedback
Sets the parameter's data type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public void SetDataType(
    ForgeTypeId dataType
)
Visual Basic
Public Sub SetDataType ( _
    dataType As ForgeTypeId _
)
Visual C++
public:
void SetDataType(
    ForgeTypeId^ dataType
)

Parameters

dataType
Type: Autodesk.Revit.DB..::..ForgeTypeId
The identifier of either a spec or a category. A category identifier indicates a Family Type parameter of that category.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given identifier is neither a spec nor a category.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExternalDefinitionCreationOptions Class


ExternalDefinitionCreationOptions Properties

[image] [image]

Revit 2024 API
ExternalDefinitionCreationOptions Properties
ExternalDefinitionCreationOptions Class See Also Send Feedback

The ExternalDefinitionCreationOptions type exposes the following members.

Properties

 | Name | Description
Public property | Description | The description of the parameter definition to be created. The description will be used as tooltip in the Revit UI including in the properties palette. The default is an empty string.
Public property | GUID | The GUID to use for this parameter definition. If not explicitly set, a random GUID is used.
Public property | HideWhenNoValue | This property indicates whether this parameter should be hidden from the properties palette when it doesn't have a value.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | The name of the parameter definition to be created.
Public property | UserModifiable | This property indicates whether this parameter can be modified by UI user or not.
Public property | Visible | True if the parameter is visible to the user, false if it is hidden and accessible only via the API. The default is true.

See Also

ExternalDefinitionCreationOptions Class


Description Property

[image]

Revit 2024 API
ExternalDefinitionCreationOptions..::..Description Property
ExternalDefinitionCreationOptions Class See Also Send Feedback
The description of the parameter definition to be created. The description will be used as tooltip in the Revit UI including in the properties palette. The default is an empty string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ExternalDefinitionCreationOptions Class


GUID Property

[image]

Revit 2024 API
ExternalDefinitionCreationOptions..::..GUID Property
ExternalDefinitionCreationOptions Class See Also Send Feedback
The GUID to use for this parameter definition. If not explicitly set, a random GUID is used.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public Guid GUID { get; set; }
Visual Basic
Public Property GUID As Guid
    Get
    Set
Visual C++
public:
property Guid GUID {
    Guid get ();
    void set (Guid value);
}

See Also

ExternalDefinitionCreationOptions Class


HideWhenNoValue Property

[image]

Revit 2024 API
ExternalDefinitionCreationOptions..::..HideWhenNoValue Property
ExternalDefinitionCreationOptions Class See Also Send Feedback
This property indicates whether this parameter should be hidden from the properties palette when it doesn't have a value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public bool HideWhenNoValue { get; set; }
Visual Basic
Public Property HideWhenNoValue As Boolean
    Get
    Set
Visual C++
public:
property bool HideWhenNoValue {
    bool get ();
    void set (bool value);
}

Field Value

True if the parameter should be hidden when it has no value, False if the parameter should remain visible in the properties palette even when it doesn't have a value. The default is false

See Also

ExternalDefinitionCreationOptions Class


IsValidObject Property

[image]

Revit 2024 API
ExternalDefinitionCreationOptions..::..IsValidObject Property
ExternalDefinitionCreationOptions Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ExternalDefinitionCreationOptions Class


UserModifiable Property

[image]

Revit 2024 API
ExternalDefinitionCreationOptions..::..UserModifiable Property
ExternalDefinitionCreationOptions Class See Also Send Feedback
This property indicates whether this parameter can be modified by UI user or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool UserModifiable { get; set; }
Visual Basic
Public Property UserModifiable As Boolean
    Get
    Set
Visual C++
public:
property bool UserModifiable {
    bool get ();
    void set (bool value);
}

Field Value

True if the parameter will be modifiable by the user in the user interface, false if the parameter will display as read-only. The default is true.

See Also

ExternalDefinitionCreationOptions Class


Visible Property

[image]

Revit 2024 API
ExternalDefinitionCreationOptions..::..Visible Property
ExternalDefinitionCreationOptions Class See Also Send Feedback
True if the parameter is visible to the user, false if it is hidden and accessible only via the API. The default is true.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool Visible { get; set; }
Visual Basic
Public Property Visible As Boolean
    Get
    Set
Visual C++
public:
property bool Visible {
    bool get ();
    void set (bool value);
}

See Also

ExternalDefinitionCreationOptions Class


ExternalDefinitions Class

[image]

Revit 2024 API
ExternalDefinitions Class
Members See Also Send Feedback
Supports the creation of new shared parameters definitions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class ExternalDefinitions : Definitions
Visual Basic
Public Class ExternalDefinitions _
    Inherits Definitions
Visual C++
public ref class ExternalDefinitions : public Definitions

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Definitions
Autodesk.Revit.DB..::..ExternalDefinitions

See Also

ExternalDefinitions Members


ExternalDefinitions Members

[image] [image]

Revit 2024 API
ExternalDefinitions Members
ExternalDefinitions Class Methods Properties See Also Send Feedback

The ExternalDefinitions type exposes the following members.

Methods

 | Name | Description
Public method | Contains | Tests for the existence of a definition within the set. (Inherited from Definitions.)
Public method | Create | Creates a new parameter definition using specified options. (Inherited from Definitions.)
Public method | Dispose | (Inherited from Definitions.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Definitions.)
Public method | GetEnumerator | Retrieves an enumerator to the collection. (Inherited from Definitions.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Identifies if the definitions collection is empty. (Inherited from Definitions.)
Public property | Item | Retrieves a definition by a given name. (Inherited from Definitions.)
Public property | Size | The number of definitions in the collection. (Inherited from Definitions.)

See Also

ExternalDefinitions Class


ExternalDefinitions Methods

[image] [image]

Revit 2024 API
ExternalDefinitions Methods
ExternalDefinitions Class See Also Send Feedback

The ExternalDefinitions type exposes the following members.

Methods

 | Name | Description
Public method | Contains | Tests for the existence of a definition within the set. (Inherited from Definitions.)
Public method | Create | Creates a new parameter definition using specified options. (Inherited from Definitions.)
Public method | Dispose | (Inherited from Definitions.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Definitions.)
Public method | GetEnumerator | Retrieves an enumerator to the collection. (Inherited from Definitions.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ExternalDefinitions Class


ExternalDefinitions Properties

[image] [image]

Revit 2024 API
ExternalDefinitions Properties
ExternalDefinitions Class See Also Send Feedback

The ExternalDefinitions type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Identifies if the definitions collection is empty. (Inherited from Definitions.)
Public property | Item | Retrieves a definition by a given name. (Inherited from Definitions.)
Public property | Size | The number of definitions in the collection. (Inherited from Definitions.)

See Also

ExternalDefinitions Class


ExternalFileReference Class

[image]

Revit 2024 API
ExternalFileReference Class
Members See Also Send Feedback
A class that contains the details of a reference to a file outside of a given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public class ExternalFileReference : IDisposable
Visual Basic
Public Class ExternalFileReference _
    Implements IDisposable
Visual C++
public ref class ExternalFileReference : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ExternalFileReference

See Also

ExternalFileReference Members


ExternalFileReference Members

[image] [image]

Revit 2024 API
ExternalFileReference Members
ExternalFileReference Class Methods Properties See Also Send Feedback

The ExternalFileReference type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ExternalFileReference
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAbsolutePath | Returns an absolute path to the referenced file, regardless of whether the PathType.Enum is relative or absolute.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLinkedFileStatus | Returns a LinkedFileStatus.Enum corresponding to the load status of the referenced file.
Public method | GetPath | Gets the path of the link, relative or absolute according to the link's settings
Public method | GetReferencingId | Gets the ElementId corresponding to the element which this ExternalFileReference is associated with.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValidExternalFileReference | Checks an ExternalFileReference to see if it is properly created.
Public method | IsValidPathTypeForExternalFileReference | Checks whether a PathType enum value will be valid to use with this ExternalFileReference.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ExternalFileReferenceType | The type of external file which this object references.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | PathType | The path type of the link (relative, absolute, or server).

See Also

ExternalFileReference Class


ExternalFileReference Methods

[image] [image]

Revit 2024 API
ExternalFileReference Methods
ExternalFileReference Class See Also Send Feedback

The ExternalFileReference type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAbsolutePath | Returns an absolute path to the referenced file, regardless of whether the PathType.Enum is relative or absolute.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLinkedFileStatus | Returns a LinkedFileStatus.Enum corresponding to the load status of the referenced file.
Public method | GetPath | Gets the path of the link, relative or absolute according to the link's settings
Public method | GetReferencingId | Gets the ElementId corresponding to the element which this ExternalFileReference is associated with.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValidExternalFileReference | Checks an ExternalFileReference to see if it is properly created.
Public method | IsValidPathTypeForExternalFileReference | Checks whether a PathType enum value will be valid to use with this ExternalFileReference.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ExternalFileReference Class


Dispose Method

[image]

Revit 2024 API
ExternalFileReference..::..Dispose Method
ExternalFileReference Class See Also Send Feedback
Releases all resources used by the ExternalFileReference

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ExternalFileReference Class


GetAbsolutePath Method

[image]

Revit 2024 API
ExternalFileReference..::..GetAbsolutePath Method
ExternalFileReference Class See Also Send Feedback
Returns an absolute path to the referenced file, regardless of whether the PathType.Enum is relative or absolute.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public ModelPath GetAbsolutePath()
Visual Basic
Public Function GetAbsolutePath As ModelPath
Visual C++
public:
ModelPath^ GetAbsolutePath()

Return Value

A full path to the linked model.

Remarks

ExternalFileReferences which are taken from a closed document will report their absolute path as of the last time the document was saved.

See Also

ExternalFileReference Class


GetPath Method

[image]

Revit 2024 API
ExternalFileReference..::..GetPath Method
ExternalFileReference Class See Also Send Feedback
Gets the path of the link, relative or absolute according to the link's settings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public ModelPath GetPath()
Visual Basic
Public Function GetPath As ModelPath
Visual C++
public:
ModelPath^ GetPath()

Return Value

The path of the link. This path will be relative for relatively-pathed links.

See Also

ExternalFileReference Class


GetReferencingId Method

[image]

Revit 2024 API
ExternalFileReference..::..GetReferencingId Method
ExternalFileReference Class See Also Send Feedback
Gets the ElementId corresponding to the element which this ExternalFileReference is associated with.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public ElementId GetReferencingId()
Visual Basic
Public Function GetReferencingId As ElementId
Visual C++
public:
ElementId^ GetReferencingId()

See Also

ExternalFileReference Class


IsValidExternalFileReference Method

[image]

Revit 2024 API
ExternalFileReference..::..IsValidExternalFileReference Method
ExternalFileReference Class See Also Send Feedback
Checks an ExternalFileReference to see if it is properly created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static bool IsValidExternalFileReference(
    ExternalFileReference data
)
Visual Basic
Public Shared Function IsValidExternalFileReference ( _
    data As ExternalFileReference _
) As Boolean
Visual C++
public:
static bool IsValidExternalFileReference(
    ExternalFileReference^ data
)

Parameters

data
Type: Autodesk.Revit.DB..::..ExternalFileReference
The ExternalFileReference to be checked

Remarks

The following restrictions exist:
  • PathType.Server is only valid for ExternalFileReferences of type ExternalFileReferenceType.RevitLink
  • PathType.Content is only valid for ExternalFileReferences of type ExternalFileReferenceType.KeynoteTable, ExternalFileReferenceType.AssemblyCodeTable or ExternalFileReferenceType.Decal
  • Keynote tables, assembly code tables and Decals (ExternalFileReferenceType.KeynoteTable, ExternalFileReferenceType.AssemblyCodeTable and ExternalFileReferenceType.Decal) may only be LinkedFileStatus.Loaded or LinkedFileStatus.NotFound.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExternalFileReference Class


IsValidPathTypeForExternalFileReference Method

[image]

Revit 2024 API
ExternalFileReference..::..IsValidPathTypeForExternalFileReference Method
ExternalFileReference Class See Also Send Feedback
Checks whether a PathType enum value will be valid to use with this ExternalFileReference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public bool IsValidPathTypeForExternalFileReference(
    PathType pathType
)
Visual Basic
Public Function IsValidPathTypeForExternalFileReference ( _
    pathType As PathType _
) As Boolean
Visual C++
public:
bool IsValidPathTypeForExternalFileReference(
    PathType pathType
)

Parameters

pathType
Type: Autodesk.Revit.DB..::..PathType

Remarks

  • PathType.Server is only valid for ExternalFileReferences of type ExternalFileReferenceType.RevitLink
  • PathType.Content is only valid for ExternalFileReferences of type ExternalFileReferenceType.KeynoteTable, ExternalFileReferenceType.AssemblyCodeTable and ExternalFileReferenceType.Decal

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

ExternalFileReference Class


ExternalFileReference Properties

[image] [image]

Revit 2024 API
ExternalFileReference Properties
ExternalFileReference Class See Also Send Feedback

The ExternalFileReference type exposes the following members.

Properties

 | Name | Description
Public property | ExternalFileReferenceType | The type of external file which this object references.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | PathType | The path type of the link (relative, absolute, or server).

See Also

ExternalFileReference Class


IsValidObject Property

[image]

Revit 2024 API
ExternalFileReference..::..IsValidObject Property
ExternalFileReference Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ExternalFileReference Class


ExternalFileReferenceType Enumeration

[image]

Revit 2024 API
ExternalFileReferenceType Enumeration
See Also Send Feedback
Enum class indicating kinds of external file references

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Since: 2012

Syntax

C#
public enum ExternalFileReferenceType
Visual Basic
Public Enumeration ExternalFileReferenceType
Visual C++
public enum class ExternalFileReferenceType

Members

Member name | Description
None | Uninitialized value
RevitLink | Revit linked files
CADLink | Linked CAD files
DWFMarkup | DWF markup files
KeynoteTable | The keynote table (The file which contains keynote information.)
Decal | Decals (images which appear only during rendering)
Material | Materials are not included as ExternalFileReferences in the 2012 release
AssemblyCodeTable | The assembly code table (The file which contains assembly code information.)
SystemsAnalysisReport | Systems analysis report file path

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


GetAllExternalFileReferences Method

[image]

Revit 2024 API
ExternalFileUtils..::..GetAllExternalFileReferences Method
ExternalFileUtils Class See Also Send Feedback
Gets the ids of all elements which are external file references.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static ICollection<ElementId> GetAllExternalFileReferences(
    Document aDoc
)
Visual Basic
Public Shared Function GetAllExternalFileReferences ( _
    aDoc As Document _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetAllExternalFileReferences(
    Document^ aDoc
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
A Revit Document.

Return Value

The ids of all elements which are external file references.

Remarks

This function will not return the ids of nested Revit links; it only returns top-level references.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExternalFileUtils Class


GetFileBasedTempFolder Method

[image]

Revit 2024 API
ExternalFileUtils..::..GetFileBasedTempFolder Method
ExternalFileUtils Class See Also Send Feedback
Gets a temp folder based on the given file name

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static string GetFileBasedTempFolder(
    string filename
)
Visual Basic
Public Shared Function GetFileBasedTempFolder ( _
    filename As String _
) As String
Visual C++
public:
static String^ GetFileBasedTempFolder(
    String^ filename
)

Parameters

filename
Type: System..::..String

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExternalFileUtils Class


ExternalGeometryId Class

[image]

Revit 2024 API
ExternalGeometryId Class
Members See Also Send Feedback
This class represents an identifier for geometry from external sources.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public class ExternalGeometryId : IDisposable
Visual Basic
Public Class ExternalGeometryId _
    Implements IDisposable
Visual C++
public ref class ExternalGeometryId : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ExternalGeometryId

See Also

ExternalGeometryId Members


ExternalGeometryId Constructor

[image]

Revit 2024 API
ExternalGeometryId Constructor
ExternalGeometryId Class See Also Send Feedback
Constructs an ExternalGeometryId object holding the given external geometry identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public ExternalGeometryId(
    string externalGeometryId
)
Visual Basic
Public Sub New ( _
    externalGeometryId As String _
)
Visual C++
public:
ExternalGeometryId(
    String^ externalGeometryId
)

Parameters

externalGeometryId
Type: System..::..String
A string that represents an identifier for an external geometry.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | externalGeometryId is not a valid ExternalGeometryId.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExternalGeometryId Class


ExternalGeometryId Methods

[image] [image]

Revit 2024 API
ExternalGeometryId Methods
ExternalGeometryId Class See Also Send Feedback

The ExternalGeometryId type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | GetHashCode | Gets the hash code. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValidExternalGeometryId | Checks whether a given string represents a valid ExternalGeometryId or not.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ExternalGeometryId Class


Dispose Method

[image]

Revit 2024 API
ExternalGeometryId..::..Dispose Method
ExternalGeometryId Class See Also Send Feedback
Releases all resources used by the ExternalGeometryId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ExternalGeometryId Class


Equals Method

[image]

Revit 2024 API
ExternalGeometryId..::..Equals Method
ExternalGeometryId Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
Another object.

See Also

ExternalGeometryId Class


GetHashCode Method

[image]

Revit 2024 API
ExternalGeometryId..::..GetHashCode Method
ExternalGeometryId Class See Also Send Feedback
Gets the hash code.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

ExternalGeometryId Class


IsValidExternalGeometryId Method

[image]

Revit 2024 API
ExternalGeometryId..::..IsValidExternalGeometryId Method
ExternalGeometryId Class See Also Send Feedback
Checks whether a given string represents a valid ExternalGeometryId or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public static bool IsValidExternalGeometryId(
    string externalGeometryId
)
Visual Basic
Public Shared Function IsValidExternalGeometryId ( _
    externalGeometryId As String _
) As Boolean
Visual C++
public:
static bool IsValidExternalGeometryId(
    String^ externalGeometryId
)

Parameters

externalGeometryId
Type: System..::..String
A string that represents an identifier for an external geometry.

Return Value

True if the string represents a valid ExternalGeometryId, false otherwise.

Remarks

Any non-empty string is a valid ExternalGeometryId.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExternalGeometryId Class


Equality Operator

[image]

Revit 2024 API
ExternalGeometryId..::..Equality Operator
ExternalGeometryId Class See Also Send Feedback
Determines whether two ExternalGeometryIds are the same.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static bool operator ==(
    ExternalGeometryId first,
    ExternalGeometryId second
)
Visual Basic
Public Shared Operator = ( _
    first As ExternalGeometryId, _
    second As ExternalGeometryId _
) As Boolean
Visual C++
public:
static bool operator ==(
    ExternalGeometryId^ first,
    ExternalGeometryId^ second
)

Parameters

first
Type: Autodesk.Revit.DB..::..ExternalGeometryId
The first ExternalGeometryId.
second
Type: Autodesk.Revit.DB..::..ExternalGeometryId
The second ExternalGeometryId.

Return Value

True if the ExternalGeometryIds are the same; otherwise, false.

See Also

ExternalGeometryId Class


Inequality Operator

[image]

Revit 2024 API
ExternalGeometryId..::..Inequality Operator
ExternalGeometryId Class See Also Send Feedback
Determines whether two ExternalGeometryIds are different.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static bool operator !=(
    ExternalGeometryId first,
    ExternalGeometryId second
)
Visual Basic
Public Shared Operator <> ( _
    first As ExternalGeometryId, _
    second As ExternalGeometryId _
) As Boolean
Visual C++
public:
static bool operator !=(
    ExternalGeometryId^ first,
    ExternalGeometryId^ second
)

Parameters

first
Type: Autodesk.Revit.DB..::..ExternalGeometryId
The first ExternalGeometryId.
second
Type: Autodesk.Revit.DB..::..ExternalGeometryId
The second ExternalGeometryId.

Return Value

True if the ExternalGeometryIds are different; otherwise, false.

See Also

ExternalGeometryId Class


ExternallyTaggedBRep Class

[image]

Revit 2024 API
ExternallyTaggedBRep Class
Members See Also Send Feedback
An ExternallyTaggedSolid can hold any shape created by BRepBuilder.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public class ExternallyTaggedBRep : ExternallyTaggedGeometryObject
Visual Basic
Public Class ExternallyTaggedBRep _
    Inherits ExternallyTaggedGeometryObject
Visual C++
public ref class ExternallyTaggedBRep : public ExternallyTaggedGeometryObject

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ExternallyTaggedGeometryObject
Autodesk.Revit.DB..::..ExternallyTaggedBRep

See Also

ExternallyTaggedBRep Members


ExternallyTaggedBRep Members

[image] [image]

Revit 2024 API
ExternallyTaggedBRep Members
ExternallyTaggedBRep Class Methods Properties See Also Send Feedback

The ExternallyTaggedBRep type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ExternallyTaggedGeometryObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTaggedGeometry | Returns the externally tagged geometry object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ExternalId | The external Id of the geometry object. (Inherited from ExternallyTaggedGeometryObject.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ExternallyTaggedGeometryObject.)

See Also

ExternallyTaggedBRep Class


ExternallyTaggedBRep Methods

[image] [image]

Revit 2024 API
ExternallyTaggedBRep Methods
ExternallyTaggedBRep Class See Also Send Feedback

The ExternallyTaggedBRep type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ExternallyTaggedGeometryObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTaggedGeometry | Returns the externally tagged geometry object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ExternallyTaggedBRep Class


GetTaggedGeometry Method

[image]

Revit 2024 API
ExternallyTaggedBRep..::..GetTaggedGeometry Method
ExternallyTaggedBRep Class See Also Send Feedback
Returns the externally tagged geometry object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public GeometryObject GetTaggedGeometry(
    ExternalGeometryId externalId
)
Visual Basic
Public Function GetTaggedGeometry ( _
    externalId As ExternalGeometryId _
) As GeometryObject
Visual C++
public:
GeometryObject^ GetTaggedGeometry(
    ExternalGeometryId^ externalId
)

Parameters

externalId
Type: Autodesk.Revit.DB..::..ExternalGeometryId
An external tag that may match a geometry object (i.e face/edge) in this Solid.

Return Value

Returns the geometry object that matches the external tag. If no such object is found, this method will return null.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExternallyTaggedBRep Class


Dispose Method

[image]

Revit 2024 API
ExternallyTaggedGeometryObject..::..Dispose Method
ExternallyTaggedGeometryObject Class See Also Send Feedback
Releases all resources used by the ExternallyTaggedGeometryObject

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ExternallyTaggedGeometryObject Class


ExternallyTaggedGeometryObject Properties

[image] [image]

Revit 2024 API
ExternallyTaggedGeometryObject Properties
ExternallyTaggedGeometryObject Class See Also Send Feedback

The ExternallyTaggedGeometryObject type exposes the following members.

Properties

 | Name | Description
Public property | ExternalId | The external Id of the geometry object.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ExternallyTaggedGeometryObject Class


ExternalId Property

[image]

Revit 2024 API
ExternallyTaggedGeometryObject..::..ExternalId Property
ExternallyTaggedGeometryObject Class See Also Send Feedback
The external Id of the geometry object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public ExternalGeometryId ExternalId { get; }
Visual Basic
Public ReadOnly Property ExternalId As ExternalGeometryId
    Get
Visual C++
public:
property ExternalGeometryId^ ExternalId {
    ExternalGeometryId^ get ();
}

See Also

ExternallyTaggedGeometryObject Class


ExternallyTaggedGeometryValidation Class

[image]

Revit 2024 API
ExternallyTaggedGeometryValidation Class
Members See Also Send Feedback
Provides validation for geometry to be stored in an ExternallyTaggedGeometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public static class ExternallyTaggedGeometryValidation
Visual Basic
Public NotInheritable Class ExternallyTaggedGeometryValidation
Visual C++
public ref class ExternallyTaggedGeometryValidation abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ExternallyTaggedGeometryValidation

See Also

ExternallyTaggedGeometryValidation Members


ExternallyTaggedGeometryValidation Members

[image] [image]

Revit 2024 API
ExternallyTaggedGeometryValidation Members
ExternallyTaggedGeometryValidation Class Methods See Also Send Feedback

The ExternallyTaggedGeometryValidation type exposes the following members.

Methods

Name | Description
IsNonSolid | Makes sure that the input geometry object is not a Solid.
IsSolid | Makes sure that the input geometry object is a Solid.
IsValidGeometry | Obsolete. Validates the input geometry to be stored in an externally tagged geometry object. Valid types of geometry are: Solid, Mesh, GeometryInstance, Point and Curve.
LacksSubnodes | Makes sure that the input geometry object does not have sub-nodes.

See Also

ExternallyTaggedGeometryValidation Class


ExternallyTaggedGeometryValidation Methods

[image] [image]

Revit 2024 API
ExternallyTaggedGeometryValidation Methods
ExternallyTaggedGeometryValidation Class See Also Send Feedback

The ExternallyTaggedGeometryValidation type exposes the following members.

Methods

Name | Description
IsNonSolid | Makes sure that the input geometry object is not a Solid.
IsSolid | Makes sure that the input geometry object is a Solid.
IsValidGeometry | Obsolete. Validates the input geometry to be stored in an externally tagged geometry object. Valid types of geometry are: Solid, Mesh, GeometryInstance, Point and Curve.
LacksSubnodes | Makes sure that the input geometry object does not have sub-nodes.

See Also

ExternallyTaggedGeometryValidation Class


IsNonSolid Method

[image]

Revit 2024 API
ExternallyTaggedGeometryValidation..::..IsNonSolid Method
ExternallyTaggedGeometryValidation Class See Also Send Feedback
Makes sure that the input geometry object is not a Solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public static bool IsNonSolid(
    GeometryObject geometry
)
Visual Basic
Public Shared Function IsNonSolid ( _
    geometry As GeometryObject _
) As Boolean
Visual C++
public:
static bool IsNonSolid(
    GeometryObject^ geometry
)

Parameters

geometry
Type: Autodesk.Revit.DB..::..GeometryObject
Geometry object to be validated.

Return Value

True if the supplied geometry object is not a Solid.

Remarks

This validation is different than negating IsSolid().

See Also

ExternallyTaggedGeometryValidation Class


IsSolid Method

[image]

Revit 2024 API
ExternallyTaggedGeometryValidation..::..IsSolid Method
ExternallyTaggedGeometryValidation Class See Also Send Feedback
Makes sure that the input geometry object is a Solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public static bool IsSolid(
    GeometryObject geometry
)
Visual Basic
Public Shared Function IsSolid ( _
    geometry As GeometryObject _
) As Boolean
Visual C++
public:
static bool IsSolid(
    GeometryObject^ geometry
)

Parameters

geometry
Type: Autodesk.Revit.DB..::..GeometryObject
Geometry object to be validated.

Return Value

True if the supplied geometry object is a Solid.

Remarks

This validation is different than negating IsNonSolid().

See Also

ExternallyTaggedGeometryValidation Class


IsValidGeometry Method

[image]

Revit 2024 API
ExternallyTaggedGeometryValidation..::..IsValidGeometry Method
ExternallyTaggedGeometryValidation Class See Also Send Feedback
Validates the input geometry to be stored in an externally tagged geometry object. Valid types of geometry are: Solid, Mesh, GeometryInstance, Point and Curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
[ObsoleteAttribute("This method is deprecated in Revit 2024 and may be removed in a later version of Revit. We suggest using validation methods provided by the Element which uses this geometry where available. For example, DirectShape.IsValidShape for a DirectShape should be used for DirectShapes.")]
public static bool IsValidGeometry(
    GeometryObject geometry
)
Visual Basic
<ObsoleteAttribute("This method is deprecated in Revit 2024 and may be removed in a later version of Revit. We suggest using validation methods provided by the Element which uses this geometry where available. For example, DirectShape.IsValidShape for a DirectShape should be used for DirectShapes.")> _
Public Shared Function IsValidGeometry ( _
    geometry As GeometryObject _
) As Boolean
Visual C++
[ObsoleteAttribute(L"This method is deprecated in Revit 2024 and may be removed in a later version of Revit. We suggest using validation methods provided by the Element which uses this geometry where available. For example, DirectShape.IsValidShape for a DirectShape should be used for DirectShapes.")]
public:
static bool IsValidGeometry(
    GeometryObject^ geometry
)

Parameters

geometry
Type: Autodesk.Revit.DB..::..GeometryObject
Geometry object to be validated.

Return Value

True if the supplied geometry object passes the validation criteria.

See Also

ExternallyTaggedGeometryValidation Class


LacksSubnodes Method

[image]

Revit 2024 API
ExternallyTaggedGeometryValidation..::..LacksSubnodes Method
ExternallyTaggedGeometryValidation Class See Also Send Feedback
Makes sure that the input geometry object does not have sub-nodes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public static bool LacksSubnodes(
    GeometryObject geometry
)
Visual Basic
Public Shared Function LacksSubnodes ( _
    geometry As GeometryObject _
) As Boolean
Visual C++
public:
static bool LacksSubnodes(
    GeometryObject^ geometry
)

Parameters

geometry
Type: Autodesk.Revit.DB..::..GeometryObject
Geometry object to be validated.

Return Value

True if the supplied geometry object does not have sub-nodes.

See Also

ExternallyTaggedGeometryValidation Class


ExternallyTaggedNonBRep Class

[image]

Revit 2024 API
ExternallyTaggedNonBRep Class
Members See Also Send Feedback
This class is used to create an externally tagged geometry object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public class ExternallyTaggedNonBRep : ExternallyTaggedGeometryObject
Visual Basic
Public Class ExternallyTaggedNonBRep _
    Inherits ExternallyTaggedGeometryObject
Visual C++
public ref class ExternallyTaggedNonBRep : public ExternallyTaggedGeometryObject

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ExternallyTaggedGeometryObject
Autodesk.Revit.DB..::..ExternallyTaggedNonBRep

See Also

ExternallyTaggedNonBRep Members


ExternallyTaggedNonBRep Members

[image] [image]

Revit 2024 API
ExternallyTaggedNonBRep Members
ExternallyTaggedNonBRep Class Constructors Methods Properties See Also Send Feedback

The ExternallyTaggedNonBRep type exposes the following members.

Constructors

 | Name | Description
Public method | ExternallyTaggedNonBRep | Constructs an ExternallyTaggedGeometryObject associating a given ExternalGeometryId with a particular GeometryObject.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ExternallyTaggedGeometryObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetUsage | Controls the usage of this ExternallyTaggedNonBRep.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ExternalId | The external Id of the geometry object. (Inherited from ExternallyTaggedGeometryObject.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ExternallyTaggedGeometryObject.)

See Also

ExternallyTaggedNonBRep Class


ExternallyTaggedNonBRep Constructor

[image]

Revit 2024 API
ExternallyTaggedNonBRep Constructor
ExternallyTaggedNonBRep Class See Also Send Feedback
Constructs an ExternallyTaggedGeometryObject associating a given ExternalGeometryId with a particular GeometryObject.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public ExternallyTaggedNonBRep(
    ExternalGeometryId externalId,
    GeometryObject geometry
)
Visual Basic
Public Sub New ( _
    externalId As ExternalGeometryId, _
    geometry As GeometryObject _
)
Visual C++
public:
ExternallyTaggedNonBRep(
    ExternalGeometryId^ externalId,
    GeometryObject^ geometry
)

Parameters

externalId
Type: Autodesk.Revit.DB..::..ExternalGeometryId
The Id of the input geometry object.
geometry
Type: Autodesk.Revit.DB..::..GeometryObject
The externally tagged geometry object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | geometry must not be a Solid. -or- geometry must not have sub-nodes.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExternallyTaggedNonBRep Class


ExternallyTaggedNonBRep Methods

[image] [image]

Revit 2024 API
ExternallyTaggedNonBRep Methods
ExternallyTaggedNonBRep Class See Also Send Feedback

The ExternallyTaggedNonBRep type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ExternallyTaggedGeometryObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetUsage | Controls the usage of this ExternallyTaggedNonBRep.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ExternallyTaggedNonBRep Class


SetUsage Method

[image]

Revit 2024 API
ExternallyTaggedNonBRep..::..SetUsage Method
ExternallyTaggedNonBRep Class See Also Send Feedback
Controls the usage of this ExternallyTaggedNonBRep.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public void SetUsage(
    ExternallyTaggedNonBRepUsage usage
)
Visual Basic
Public Sub SetUsage ( _
    usage As ExternallyTaggedNonBRepUsage _
)
Visual C++
public:
void SetUsage(
    ExternallyTaggedNonBRepUsage usage
)

Parameters

usage
Type: Autodesk.Revit.DB..::..ExternallyTaggedNonBRepUsage

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

ExternallyTaggedNonBRep Class


ExternallyTaggedNonBRep Properties

[image] [image]

Revit 2024 API
ExternallyTaggedNonBRep Properties
ExternallyTaggedNonBRep Class See Also Send Feedback

The ExternallyTaggedNonBRep type exposes the following members.

Properties

 | Name | Description
Public property | ExternalId | The external Id of the geometry object. (Inherited from ExternallyTaggedGeometryObject.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ExternallyTaggedGeometryObject.)

See Also

ExternallyTaggedNonBRep Class


ExternallyTaggedNonBReps Class

[image]

Revit 2024 API
ExternallyTaggedNonBReps Class
Members See Also Send Feedback
Holds a collection of ExternallyTaggedNonBRep instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public class ExternallyTaggedNonBReps : IDisposable
Visual Basic
Public Class ExternallyTaggedNonBReps _
    Implements IDisposable
Visual C++
public ref class ExternallyTaggedNonBReps : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ExternallyTaggedNonBReps

See Also

ExternallyTaggedNonBReps Members


ExternallyTaggedNonBReps Members

[image] [image]

Revit 2024 API
ExternallyTaggedNonBReps Members
ExternallyTaggedNonBReps Class Constructors Methods Properties See Also Send Feedback

The ExternallyTaggedNonBReps type exposes the following members.

Constructors

 | Name | Description
Public method | ExternallyTaggedNonBReps | Make a new empty collection of ExternallyTaggedNonBRep instances.

Methods

 | Name | Description
Public method | Add | Adds a copy of the input ExternallyTaggedNonBRep to this collection.
Public method | CanAddExternallyTaggedNonBRep | Checks if the input geometry could be added to this collection or not.
Public method | Dispose | Releases all resources used by the ExternallyTaggedNonBReps
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ExternallyTaggedNonBReps Class


ExternallyTaggedNonBReps Constructor

[image]

Revit 2024 API
ExternallyTaggedNonBReps Constructor
ExternallyTaggedNonBReps Class See Also Send Feedback
Make a new empty collection of ExternallyTaggedNonBRep instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public ExternallyTaggedNonBReps()
Visual Basic
Public Sub New
Visual C++
public:
ExternallyTaggedNonBReps()

See Also

ExternallyTaggedNonBReps Class


ExternallyTaggedNonBReps Methods

[image] [image]

Revit 2024 API
ExternallyTaggedNonBReps Methods
ExternallyTaggedNonBReps Class See Also Send Feedback

The ExternallyTaggedNonBReps type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds a copy of the input ExternallyTaggedNonBRep to this collection.
Public method | CanAddExternallyTaggedNonBRep | Checks if the input geometry could be added to this collection or not.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ExternallyTaggedNonBReps Class


Add Method

[image]

Revit 2024 API
ExternallyTaggedNonBReps..::..Add Method
ExternallyTaggedNonBReps Class See Also Send Feedback
Adds a copy of the input ExternallyTaggedNonBRep to this collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public void Add(
    ExternallyTaggedNonBRep geometry
)
Visual Basic
Public Sub Add ( _
    geometry As ExternallyTaggedNonBRep _
)
Visual C++
public:
void Add(
    ExternallyTaggedNonBRep^ geometry
)

Parameters

geometry
Type: Autodesk.Revit.DB..::..ExternallyTaggedNonBRep
The ExternallyTaggedNonBRep to be added.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ExternalGeometryId of geometry already exists in this collection.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExternallyTaggedNonBReps Class


CanAddExternallyTaggedNonBRep Method

[image]

Revit 2024 API
ExternallyTaggedNonBReps..::..CanAddExternallyTaggedNonBRep Method
ExternallyTaggedNonBReps Class See Also Send Feedback
Checks if the input geometry could be added to this collection or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public bool CanAddExternallyTaggedNonBRep(
    ExternallyTaggedNonBRep geometry
)
Visual Basic
Public Function CanAddExternallyTaggedNonBRep ( _
    geometry As ExternallyTaggedNonBRep _
) As Boolean
Visual C++
public:
bool CanAddExternallyTaggedNonBRep(
    ExternallyTaggedNonBRep^ geometry
)

Parameters

geometry
Type: Autodesk.Revit.DB..::..ExternallyTaggedNonBRep

Return Value

True if we can add the input geometry to this collection, false otherwise.

Remarks

Duplicate ExternalGeometryIds are prohibited.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExternallyTaggedNonBReps Class


Dispose Method

[image]

Revit 2024 API
ExternallyTaggedNonBReps..::..Dispose Method
ExternallyTaggedNonBReps Class See Also Send Feedback
Releases all resources used by the ExternallyTaggedNonBReps

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ExternallyTaggedNonBReps Class


ExternallyTaggedNonBReps Properties

[image] [image]

Revit 2024 API
ExternallyTaggedNonBReps Properties
ExternallyTaggedNonBReps Class See Also Send Feedback

The ExternallyTaggedNonBReps type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ExternallyTaggedNonBReps Class


ExternalResourceBrowserData Class

[image]

Revit 2024 API
ExternalResourceBrowserData Class
Members See Also Send Feedback
Represents a collection of external resources and external resource folders to be presented as the content of a folder in the file browser in Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public class ExternalResourceBrowserData : IDisposable
Visual Basic
Public Class ExternalResourceBrowserData _
    Implements IDisposable
Visual C++
public ref class ExternalResourceBrowserData : IDisposable

Remarks

This data represents the contents to be shown to the user while they are browsing a specific folder in Revit.

The folder path can be obtained from the FolderPath property.

The external resource server is expected to populate all of the available resources and subfolders that should appear in the Revit file browser while the browser is open to this particular folder.

If the user navigates to another folder, a different ExternalResourceBrowserData object will be provided to allow the server to populate resources at that location.

When adding resource and subfolder, the resource and subfolder should not be added recursively.

When adding resource and subfolder, the name should be unique short name(without folder).

The name of resource and subfolder should not contain any invalid character of \/:*?"<>|.

The length of resource combined path(server name + folder path + resource name) should not exceed 259; The length of subfolder also has same restriction.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ExternalResourceBrowserData

See Also

ExternalResourceBrowserData Members


ExternalResourceBrowserData Members

[image] [image]

Revit 2024 API
ExternalResourceBrowserData Members
ExternalResourceBrowserData Class Constructors Methods Properties See Also Send Feedback

The ExternalResourceBrowserData type exposes the following members.

Constructors

 | Name | Description
Public method | ExternalResourceBrowserData | Constructs a new ExternalResourceBrowserData using the given document(optional), server id, folder path and match options.

Methods

 | Name | Description
Public method | AddResource(String) | Adds an external resource to the folder path by supplying the resource name.
Public method | AddResource(String, IDictionary<(Of <<'(String, String>)>>)) | Adds an external resource to the folder path by supplying the resource name and reference information.
Public method | AddResource(String, String) | Adds an external resource to the folder path by supplying the resource name and version.
Public method | AddResource(String, String, IDictionary<(Of <<'(String, String>)>>)) | Adds an external resource to the folder path by supplying the resource name, version and reference information.
Public method | AddSubFolder(String) | Adds a subfolder to the folder path with the given name.
Public method | AddSubFolder(String, String) | Adds a subfolder to the folder path with the given name and icon type.
Public method | CallingDocumentHasModelPath | Indicates whether the document requesting the external resource browser data has a defined ModelPath.
Public method | Dispose | Releases all resources used by the ExternalResourceBrowserData
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCallingDocumentModelPath | Returns a copy of the ModelPath of the document that is requesting the external resource browser data.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMatchOptions | Gets the match options used to filter external resources.
Public method | GetResources | Gets the external resources under the folder path of the browser data.
Public method | GetSubFoldersData | Gets the subfolders data under the folder path of the browser data.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFolderName | Checks whether the folder name is valid.
Public method | IsValidResourceName | Checks whether the resource name is valid.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FolderPath | The current folder path to which the new resources and subfolder belong.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ServerId | The Id of IExternalResourceServer which handles the external resource load.

See Also

ExternalResourceBrowserData Class


ExternalResourceBrowserData Methods

[image] [image]

Revit 2024 API
ExternalResourceBrowserData Methods
ExternalResourceBrowserData Class See Also Send Feedback

The ExternalResourceBrowserData type exposes the following members.

Methods

 | Name | Description
Public method | AddResource(String) | Adds an external resource to the folder path by supplying the resource name.
Public method | AddResource(String, IDictionary<(Of <<'(String, String>)>>)) | Adds an external resource to the folder path by supplying the resource name and reference information.
Public method | AddResource(String, String) | Adds an external resource to the folder path by supplying the resource name and version.
Public method | AddResource(String, String, IDictionary<(Of <<'(String, String>)>>)) | Adds an external resource to the folder path by supplying the resource name, version and reference information.
Public method | AddSubFolder(String) | Adds a subfolder to the folder path with the given name.
Public method | AddSubFolder(String, String) | Adds a subfolder to the folder path with the given name and icon type.
Public method | CallingDocumentHasModelPath | Indicates whether the document requesting the external resource browser data has a defined ModelPath.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCallingDocumentModelPath | Returns a copy of the ModelPath of the document that is requesting the external resource browser data.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMatchOptions | Gets the match options used to filter external resources.
Public method | GetResources | Gets the external resources under the folder path of the browser data.
Public method | GetSubFoldersData | Gets the subfolders data under the folder path of the browser data.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidFolderName | Checks whether the folder name is valid.
Public method | IsValidResourceName | Checks whether the resource name is valid.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ExternalResourceBrowserData Class


AddResource Method

[image] [image]

Revit 2024 API
ExternalResourceBrowserData..::..AddResource Method
ExternalResourceBrowserData Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddResource(String) | Adds an external resource to the folder path by supplying the resource name.
Public method | AddResource(String, IDictionary<(Of <<'(String, String>)>>)) | Adds an external resource to the folder path by supplying the resource name and reference information.
Public method | AddResource(String, String) | Adds an external resource to the folder path by supplying the resource name and version.
Public method | AddResource(String, String, IDictionary<(Of <<'(String, String>)>>)) | Adds an external resource to the folder path by supplying the resource name, version and reference information.

See Also

ExternalResourceBrowserData Class
ExternalResourceBrowserData Members


AddResource Method (String)

[image]

Revit 2024 API
ExternalResourceBrowserData..::..AddResource Method (String)
ExternalResourceBrowserData Class See Also Send Feedback
Adds an external resource to the folder path by supplying the resource name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public void AddResource(
    string resourceName
)
Visual Basic
Public Sub AddResource ( _
    resourceName As String _
)
Visual C++
public:
void AddResource(
    String^ resourceName
)

Parameters

resourceName
Type: System..::..String
The unique short name of external resource.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The resourceName is not a valid resource name used to display in Revit external resource browse UI. The name should be a unique non-empty short name and it should not contain any invalid character of \\/:*?"<>|. The length of combined path(server name + folder path + resourceName) should not exceeds 259.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExternalResourceBrowserData Class
AddResource Overload


AddResource Method (String, IDictionary(String, String))

[image]

Revit 2024 API
ExternalResourceBrowserData..::..AddResource Method (String, IDictionary<(Of <(<'String, String>)>)>)
ExternalResourceBrowserData Class See Also Send Feedback
Adds an external resource to the folder path by supplying the resource name and reference information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public void AddResource(
    string resourceName,
    IDictionary<string, string> referenceInformation
)
Visual Basic
Public Sub AddResource ( _
    resourceName As String, _
    referenceInformation As IDictionary(Of String, String) _
)
Visual C++
public:
void AddResource(
    String^ resourceName,
    IDictionary<String^, String^>^ referenceInformation
)

Parameters

resourceName
Type: System..::..String
The unique short name of external resource.
referenceInformation
Type: System.Collections.Generic..::..IDictionary<(Of <(<'String, String>)>)>
The (String, String) map containing reference or lookup information that will be stored in Revit.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The resourceName is not a valid resource name used to display in Revit external resource browse UI. The name should be a unique non-empty short name and it should not contain any invalid character of \\/:*?"<>|. The length of combined path(server name + folder path + resourceName) should not exceeds 259.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExternalResourceBrowserData Class
AddResource Overload


AddResource Method (String, String)

[image]

Revit 2024 API
ExternalResourceBrowserData..::..AddResource Method (String, String)
ExternalResourceBrowserData Class See Also Send Feedback
Adds an external resource to the folder path by supplying the resource name and version.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public void AddResource(
    string resourceName,
    string version
)
Visual Basic
Public Sub AddResource ( _
    resourceName As String, _
    version As String _
)
Visual C++
public:
void AddResource(
    String^ resourceName,
    String^ version
)

Parameters

resourceName
Type: System..::..String
The unique short name of external resource.
version
Type: System..::..String
The version of external resource.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The resourceName is not a valid resource name used to display in Revit external resource browse UI. The name should be a unique non-empty short name and it should not contain any invalid character of \\/:*?"<>|. The length of combined path(server name + folder path + resourceName) should not exceeds 259.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExternalResourceBrowserData Class
AddResource Overload


AddResource Method (String, String, IDictionary(String, String))

[image]

Revit 2024 API
ExternalResourceBrowserData..::..AddResource Method (String, String, IDictionary<(Of <(<'String, String>)>)>)
ExternalResourceBrowserData Class See Also Send Feedback
Adds an external resource to the folder path by supplying the resource name, version and reference information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public void AddResource(
    string resourceName,
    string version,
    IDictionary<string, string> referenceInformation
)
Visual Basic
Public Sub AddResource ( _
    resourceName As String, _
    version As String, _
    referenceInformation As IDictionary(Of String, String) _
)
Visual C++
public:
void AddResource(
    String^ resourceName,
    String^ version,
    IDictionary<String^, String^>^ referenceInformation
)

Parameters

resourceName
Type: System..::..String
The unique short name of external resource.
version
Type: System..::..String
The version of external resource.
referenceInformation
Type: System.Collections.Generic..::..IDictionary<(Of <(<'String, String>)>)>
The (String, String) map containing reference or lookup information that will be stored in Revit.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The resourceName is not a valid resource name used to display in Revit external resource browse UI. The name should be a unique non-empty short name and it should not contain any invalid character of \\/:*?"<>|. The length of combined path(server name + folder path + resourceName) should not exceeds 259.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExternalResourceBrowserData Class
AddResource Overload


AddSubFolder Method (String)

[image]

Revit 2024 API
ExternalResourceBrowserData..::..AddSubFolder Method (String)
ExternalResourceBrowserData Class See Also Send Feedback
Adds a subfolder to the folder path with the given name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public void AddSubFolder(
    string folderName
)
Visual Basic
Public Sub AddSubFolder ( _
    folderName As String _
)
Visual C++
public:
void AddSubFolder(
    String^ folderName
)

Parameters

folderName
Type: System..::..String
The name of the folder.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The folderName is not a valid folder name used to display in Revit external resource browse UI. The name should be a unique non-empty short name and it should not contain any invalid character of \\/:*?"<>|. The length of combined path(server name + folder path) should not exceeds 259.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExternalResourceBrowserData Class
AddSubFolder Overload


AddSubFolder Method (String, String)

[image]

Revit 2024 API
ExternalResourceBrowserData..::..AddSubFolder Method (String, String)
ExternalResourceBrowserData Class See Also Send Feedback
Adds a subfolder to the folder path with the given name and icon type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019.1

Syntax

C#
public void AddSubFolder(
    string folderName,
    string iconPath
)
Visual Basic
Public Sub AddSubFolder ( _
    folderName As String, _
    iconPath As String _
)
Visual C++
public:
void AddSubFolder(
    String^ folderName,
    String^ iconPath
)

Parameters

folderName
Type: System..::..String
The name of the folder.
iconPath
Type: System..::..String
Icon path.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The folderName is not a valid folder name used to display in Revit external resource browse UI. The name should be a unique non-empty short name and it should not contain any invalid character of \\/:*?"<>|. The length of combined path(server name + folder path) should not exceeds 259.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExternalResourceBrowserData Class
AddSubFolder Overload


CallingDocumentHasModelPath Method

[image]

Revit 2024 API
ExternalResourceBrowserData..::..CallingDocumentHasModelPath Method
ExternalResourceBrowserData Class See Also Send Feedback
Indicates whether the document requesting the external resource browser data has a defined ModelPath.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool CallingDocumentHasModelPath()
Visual Basic
Public Function CallingDocumentHasModelPath As Boolean
Visual C++
public:
bool CallingDocumentHasModelPath()

Return Value

True if the document has a defined ModelPath.

Remarks

A project that is detached, or has not been saved to disk yet, will not have a ModelPath.

See Also

ExternalResourceBrowserData Class


Dispose Method

[image]

Revit 2024 API
ExternalResourceBrowserData..::..Dispose Method
ExternalResourceBrowserData Class See Also Send Feedback
Releases all resources used by the ExternalResourceBrowserData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ExternalResourceBrowserData Class


GetCallingDocumentModelPath Method

[image]

Revit 2024 API
ExternalResourceBrowserData..::..GetCallingDocumentModelPath Method
ExternalResourceBrowserData Class See Also Send Feedback
Returns a copy of the ModelPath of the document that is requesting the external resource browser data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public ModelPath GetCallingDocumentModelPath()
Visual Basic
Public Function GetCallingDocumentModelPath As ModelPath
Visual C++
public:
ModelPath^ GetCallingDocumentModelPath()

Return Value

A copy of the ModelPath of the document that is requesting the external resource browser data.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The document requesting the external resource browser data does not have a ModelPath, either because it is detached, or because it has not been saved to disk yet, or no document specified.

See Also

ExternalResourceBrowserData Class


GetMatchOptions Method

[image]

Revit 2024 API
ExternalResourceBrowserData..::..GetMatchOptions Method
ExternalResourceBrowserData Class See Also Send Feedback
Gets the match options used to filter external resources.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public ExternalResourceMatchOptions GetMatchOptions()
Visual Basic
Public Function GetMatchOptions As ExternalResourceMatchOptions
Visual C++
public:
ExternalResourceMatchOptions^ GetMatchOptions()

Return Value

The external resource match options.

See Also

ExternalResourceBrowserData Class


GetResources Method

[image]

Revit 2024 API
ExternalResourceBrowserData..::..GetResources Method
ExternalResourceBrowserData Class See Also Send Feedback
Gets the external resources under the folder path of the browser data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public IList<ExternalResourceReference> GetResources()
Visual Basic
Public Function GetResources As IList(Of ExternalResourceReference)
Visual C++
public:
IList<ExternalResourceReference^>^ GetResources()

Return Value

The external resources under current folder of the browser data.

See Also

ExternalResourceBrowserData Class


GetSubFoldersData Method

[image]

Revit 2024 API
ExternalResourceBrowserData..::..GetSubFoldersData Method
ExternalResourceBrowserData Class See Also Send Feedback
Gets the subfolders data under the folder path of the browser data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019.1

Syntax

C#
public IList<ExternalResourceSubFolder> GetSubFoldersData()
Visual Basic
Public Function GetSubFoldersData As IList(Of ExternalResourceSubFolder)
Visual C++
public:
IList<ExternalResourceSubFolder^>^ GetSubFoldersData()

Return Value

The subfolders data under folder path of the browser data.

See Also

ExternalResourceBrowserData Class


IsValidFolderName Method

[image]

Revit 2024 API
ExternalResourceBrowserData..::..IsValidFolderName Method
ExternalResourceBrowserData Class See Also Send Feedback
Checks whether the folder name is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool IsValidFolderName(
    string folderName
)
Visual Basic
Public Function IsValidFolderName ( _
    folderName As String _
) As Boolean
Visual C++
public:
bool IsValidFolderName(
    String^ folderName
)

Parameters

folderName
Type: System..::..String
The folder name to check.

Return Value

True if the name is a valid folder name, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExternalResourceBrowserData Class


FolderPath Property

[image]

Revit 2024 API
ExternalResourceBrowserData..::..FolderPath Property
ExternalResourceBrowserData Class See Also Send Feedback
The current folder path to which the new resources and subfolder belong.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public string FolderPath { get; }
Visual Basic
Public ReadOnly Property FolderPath As String
    Get
Visual C++
public:
property String^ FolderPath {
    String^ get ();
}

See Also

ExternalResourceBrowserData Class


IsValidObject Property

[image]

Revit 2024 API
ExternalResourceBrowserData..::..IsValidObject Property
ExternalResourceBrowserData Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ExternalResourceBrowserData Class


ExternalResourceLoadContent Class

[image]

Revit 2024 API
ExternalResourceLoadContent Class
Members See Also Send Feedback
This class contains the actual content data and other results of an external resource load operation that are returned by an IExternalResourceServer to Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public class ExternalResourceLoadContent : IDisposable
Visual Basic
Public Class ExternalResourceLoadContent _
    Implements IDisposable
Visual C++
public ref class ExternalResourceLoadContent : IDisposable

Remarks

When Revit calls the LoadResource method for an IExternalResourceServer, Revit will provide an object that is a sub-class of ExternalResourceLoadContent. The IExternalResourceServer will use this object to return the content Revit should use for the external resource. The server can also add information about any errors that occurred during the load operation. This error information will be stored by Revit and later passed to the associated IExternalResourceUIServer (if any) that designates the IExternalResourceServer as its "DBServer" (see the IExternalResourceUIServer.GetDBServerId() method). The IExternalResourceUIServer can then generate any UI that is required for handling the errors that occurred.

Note that since different kinds of external resources are expected to return different kinds of data to Revit, a number of ExternalResourceLoadContent sub-classes have been created to handle the data for specific ExternalResourceTypes. This base class contains only a string to indicate the version of the resource data that is being supplied by the server and a status variable to indicate the outcome of a load operation. Revit will always provide the server with an instance of the appropriate sub-class of ExternalResourceLoadContent, with internal data that are relevant to the particular ExternalResourceType that is being loaded.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ExternalResourceLoadContent
Autodesk.Revit.DB..::..KeyBasedTreeEntriesLoadContent
Autodesk.Revit.DB..::..LinkLoadContent

See Also

ExternalResourceLoadContent Members


ExternalResourceLoadContent Members

[image] [image]

Revit 2024 API
ExternalResourceLoadContent Members
ExternalResourceLoadContent Class Methods Properties See Also Send Feedback

The ExternalResourceLoadContent type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ExternalResourceLoadContent
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LoadStatus | A value to indicate the status of an external resource load operation. IExternalResourceServers should set this in the LoadResource() method.
Public property | Version | The version of the external data that the server is providing in this object.

See Also

ExternalResourceLoadContent Class


ExternalResourceLoadContent Methods

[image] [image]

Revit 2024 API
ExternalResourceLoadContent Methods
ExternalResourceLoadContent Class See Also Send Feedback

The ExternalResourceLoadContent type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ExternalResourceLoadContent Class


Dispose Method

[image]

Revit 2024 API
ExternalResourceLoadContent..::..Dispose Method
ExternalResourceLoadContent Class See Also Send Feedback
Releases all resources used by the ExternalResourceLoadContent

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ExternalResourceLoadContent Class


ExternalResourceLoadContent Properties

[image] [image]

Revit 2024 API
ExternalResourceLoadContent Properties
ExternalResourceLoadContent Class See Also Send Feedback

The ExternalResourceLoadContent type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LoadStatus | A value to indicate the status of an external resource load operation. IExternalResourceServers should set this in the LoadResource() method.
Public property | Version | The version of the external data that the server is providing in this object.

See Also

ExternalResourceLoadContent Class


IsValidObject Property

[image]

Revit 2024 API
ExternalResourceLoadContent..::..IsValidObject Property
ExternalResourceLoadContent Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ExternalResourceLoadContent Class


LoadStatus Property

[image]

Revit 2024 API
ExternalResourceLoadContent..::..LoadStatus Property
ExternalResourceLoadContent Class See Also Send Feedback
A value to indicate the status of an external resource load operation. IExternalResourceServers should set this in the LoadResource() method.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public ExternalResourceLoadStatus LoadStatus { get; set; }
Visual Basic
Public Property LoadStatus As ExternalResourceLoadStatus
    Get
    Set
Visual C++
public:
property ExternalResourceLoadStatus LoadStatus {
    ExternalResourceLoadStatus get ();
    void set (ExternalResourceLoadStatus value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The ExternalResourceLoadContent does not contain all the necessary data. To see the requirements for this particular resource type, please see the documentation for the specific subclass of ExternalResourceLoadContent.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

ExternalResourceLoadContent Class


Version Property

[image]

Revit 2024 API
ExternalResourceLoadContent..::..Version Property
ExternalResourceLoadContent Class See Also Send Feedback
The version of the external data that the server is providing in this object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public string Version { get; set; }
Visual Basic
Public Property Version As String
    Get
    Set
Visual C++
public:
property String^ Version {
    String^ get ();
    void set (String^ value);
}

Remarks

When its LoadResource() method is invoked, an IExternalResourceServer can indicate the version of the data that it is providing to Revit by setting this property. Doing so will improve performance, because Revit will use the version information to avoid unnecessary reloads.

See GetResourceVersionStatus(ExternalResourceReference).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ExternalResourceLoadContent Class


ExternalResourceLoadContext Class

[image]

Revit 2024 API
ExternalResourceLoadContext Class
Members See Also Send Feedback
This class contains data describing the context related to an external resource load operation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public class ExternalResourceLoadContext : IDisposable
Visual Basic
Public Class ExternalResourceLoadContext _
    Implements IDisposable
Visual C++
public ref class ExternalResourceLoadContext : IDisposable

Remarks

Note that automatic loads can occur in the context of other operations such as opening a file. During automatic loads, it is therefore recommended that the server only display UI that is critical for the user to see (such as error message).

The loading operation type is Explicit when the user is specifically trying to reload the resource. During explicit loads, it may be desirable to provide more feedback to the user, such as specific feedback that the load operation succeeded.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ExternalResourceLoadContext

See Also

ExternalResourceLoadContext Members


ExternalResourceLoadContext Members

[image] [image]

Revit 2024 API
ExternalResourceLoadContext Members
ExternalResourceLoadContext Class Methods Properties See Also Send Feedback

The ExternalResourceLoadContext type exposes the following members.

Methods

 | Name | Description
Public method | CallingDocumentHasModelPath | Indicates whether the document requesting the external resource has a defined ModelPath.
Public method | Dispose | Releases all resources used by the ExternalResourceLoadContext
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCallingDocumentModelPath | Returns a copy of the ModelPath of the document that is requesting the external resource.
Public method | GetCurrentlyLoadedReference | Returns a copy of the ExternalResourceReference currently in use by the containing element.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LoadOperationType | An enum value indicating whether the resource load was triggered by an automatic event (such as file open) or an explicit user action.

See Also

ExternalResourceLoadContext Class


CallingDocumentHasModelPath Method

[image]

Revit 2024 API
ExternalResourceLoadContext..::..CallingDocumentHasModelPath Method
ExternalResourceLoadContext Class See Also Send Feedback
Indicates whether the document requesting the external resource has a defined ModelPath.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool CallingDocumentHasModelPath()
Visual Basic
Public Function CallingDocumentHasModelPath As Boolean
Visual C++
public:
bool CallingDocumentHasModelPath()

Return Value

True if the document has a defined ModelPath.

Remarks

A project that is detached, or has not been saved to disk yet, will not have a ModelPath.

See Also

ExternalResourceLoadContext Class


GetCallingDocumentModelPath Method

[image]

Revit 2024 API
ExternalResourceLoadContext..::..GetCallingDocumentModelPath Method
ExternalResourceLoadContext Class See Also Send Feedback
Returns a copy of the ModelPath of the document that is requesting the external resource.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public ModelPath GetCallingDocumentModelPath()
Visual Basic
Public Function GetCallingDocumentModelPath As ModelPath
Visual C++
public:
ModelPath^ GetCallingDocumentModelPath()

Return Value

A copy of the ModelPath of the document that is requesting the external resource.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The document requesting the external resource does not have a ModelPath, either because it is detached, or because it has not been saved to disk yet.

See Also

ExternalResourceLoadContext Class


GetCurrentlyLoadedReference Method

[image]

Revit 2024 API
ExternalResourceLoadContext..::..GetCurrentlyLoadedReference Method
ExternalResourceLoadContext Class See Also Send Feedback
Returns a copy of the ExternalResourceReference currently in use by the containing element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public ExternalResourceReference GetCurrentlyLoadedReference()
Visual Basic
Public Function GetCurrentlyLoadedReference As ExternalResourceReference
Visual C++
public:
ExternalResourceReference^ GetCurrentlyLoadedReference()

Return Value

A copy of the ExternalResourceReference currently in use by the containing element.

Remarks

A server may use to wish this information to, for example, tell whether the Revit user was previously using their server or not.

This reference may be nullNothingnullptra null reference (Nothing in Visual Basic) if there is no current value. For example, a newly-created link being loaded for the first time would have no currently-loaded reference.

See Also

ExternalResourceLoadContext Class


ExternalResourceLoadContext Properties

[image] [image]

Revit 2024 API
ExternalResourceLoadContext Properties
ExternalResourceLoadContext Class See Also Send Feedback

The ExternalResourceLoadContext type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LoadOperationType | An enum value indicating whether the resource load was triggered by an automatic event (such as file open) or an explicit user action.

See Also

ExternalResourceLoadContext Class


LoadOperationType Property

[image]

Revit 2024 API
ExternalResourceLoadContext..::..LoadOperationType Property
ExternalResourceLoadContext Class See Also Send Feedback
An enum value indicating whether the resource load was triggered by an automatic event (such as file open) or an explicit user action.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public LoadOperationType LoadOperationType { get; }
Visual Basic
Public ReadOnly Property LoadOperationType As LoadOperationType
    Get
Visual C++
public:
property LoadOperationType LoadOperationType {
    LoadOperationType get ();
}

See Also

ExternalResourceLoadContext Class


ExternalResourceLoadData Members

[image] [image]

Revit 2024 API
ExternalResourceLoadData Members
ExternalResourceLoadData Class Methods Properties See Also Send Feedback

The ExternalResourceLoadData type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ExternalResourceLoadData
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetExternalResourceReference | Returns the ExternalResourceReference that identifies which resource should be loaded.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLoadContent | Returns the ExternalResourceLoadContent resulting from this load operation.
Public method | GetLoadContext | Returns an object containing information about the context of the load operation.
Public method | GetLoadRequestId | Returns the load operation GUID.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ErrorsReported | Indicates whether the IExternalResourceUIServer has reported errors for this ExternalResourceLoadData. This value can be set by the IExternalResourceUIServer in HandleLoadResourceResults().
Public property | ExternalResourceType | The ExternalResourceType for which Revit is requesting data from the server.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LoadStatus | The success or failure status of the load attempt.

See Also

ExternalResourceLoadData Class


ExternalResourceLoadData Methods

[image] [image]

Revit 2024 API
ExternalResourceLoadData Methods
ExternalResourceLoadData Class See Also Send Feedback

The ExternalResourceLoadData type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetExternalResourceReference | Returns the ExternalResourceReference that identifies which resource should be loaded.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLoadContent | Returns the ExternalResourceLoadContent resulting from this load operation.
Public method | GetLoadContext | Returns an object containing information about the context of the load operation.
Public method | GetLoadRequestId | Returns the load operation GUID.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ExternalResourceLoadData Class


Dispose Method

[image]

Revit 2024 API
ExternalResourceLoadData..::..Dispose Method
ExternalResourceLoadData Class See Also Send Feedback
Releases all resources used by the ExternalResourceLoadData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ExternalResourceLoadData Class


GetExternalResourceReference Method

[image]

Revit 2024 API
ExternalResourceLoadData..::..GetExternalResourceReference Method
ExternalResourceLoadData Class See Also Send Feedback
Returns the ExternalResourceReference that identifies which resource should be loaded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public ExternalResourceReference GetExternalResourceReference()
Visual Basic
Public Function GetExternalResourceReference As ExternalResourceReference
Visual C++
public:
ExternalResourceReference^ GetExternalResourceReference()

Remarks

Information in this object tells the server from which specific resource Revit expects to receive the external data.

See Also

ExternalResourceLoadData Class


GetLoadContent Method

[image]

Revit 2024 API
ExternalResourceLoadData..::..GetLoadContent Method
ExternalResourceLoadData Class See Also Send Feedback
Returns the ExternalResourceLoadContent resulting from this load operation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public ExternalResourceLoadContent GetLoadContent()
Visual Basic
Public Function GetLoadContent As ExternalResourceLoadContent
Visual C++
public:
ExternalResourceLoadContent^ GetLoadContent()

Return Value

A reference to an ExternalResourceLoadContent object.

Remarks

This object contains the content produced by the call to the IExternalResourceServer's LoadResource method.

See Also

ExternalResourceLoadData Class


GetLoadContext Method

[image]

Revit 2024 API
ExternalResourceLoadData..::..GetLoadContext Method
ExternalResourceLoadData Class See Also Send Feedback
Returns an object containing information about the context of the load operation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public ExternalResourceLoadContext GetLoadContext()
Visual Basic
Public Function GetLoadContext As ExternalResourceLoadContext
Visual C++
public:
ExternalResourceLoadContext^ GetLoadContext()

Return Value

An object containing information about the context of the load operation.

See Also

ExternalResourceLoadData Class


GetLoadRequestId Method

[image]

Revit 2024 API
ExternalResourceLoadData..::..GetLoadRequestId Method
ExternalResourceLoadData Class See Also Send Feedback
Returns the load operation GUID.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public Guid GetLoadRequestId()
Visual Basic
Public Function GetLoadRequestId As Guid
Visual C++
public:
Guid GetLoadRequestId()

Return Value

The load operation GUID.

Remarks

This Id uniquely identifies the load request. IExternalResourceServers can use it as a key to store and retrieve information (such as errors) that is relevant to a specific load operation.

See Also

ExternalResourceLoadData Class


ExternalResourceLoadData Properties

[image] [image]

Revit 2024 API
ExternalResourceLoadData Properties
ExternalResourceLoadData Class See Also Send Feedback

The ExternalResourceLoadData type exposes the following members.

Properties

 | Name | Description
Public property | ErrorsReported | Indicates whether the IExternalResourceUIServer has reported errors for this ExternalResourceLoadData. This value can be set by the IExternalResourceUIServer in HandleLoadResourceResults().
Public property | ExternalResourceType | The ExternalResourceType for which Revit is requesting data from the server.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LoadStatus | The success or failure status of the load attempt.

See Also

ExternalResourceLoadData Class


ErrorsReported Property

[image]

Revit 2024 API
ExternalResourceLoadData..::..ErrorsReported Property
ExternalResourceLoadData Class See Also Send Feedback
Indicates whether the IExternalResourceUIServer has reported errors for this ExternalResourceLoadData. This value can be set by the IExternalResourceUIServer in HandleLoadResourceResults().

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool ErrorsReported { get; set; }
Visual Basic
Public Property ErrorsReported As Boolean
    Get
    Set
Visual C++
public:
property bool ErrorsReported {
    bool get ();
    void set (bool value);
}

Remarks

For Revit links specifically, Revit will check this value to see if it should report errors about a given link in the Unresolved References dialog. An IExternalResourceUIServer can set this value to true to avoid redundant messages.

Note that it is possible for Revit to encounter errors internally even if the server successfully provides a reference. In general, this value should only be set to true if the server has reported an error condition.

See Also

ExternalResourceLoadData Class


ExternalResourceType Property

[image]

Revit 2024 API
ExternalResourceLoadData..::..ExternalResourceType Property
ExternalResourceLoadData Class See Also Send Feedback
The ExternalResourceType for which Revit is requesting data from the server.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public ExternalResourceType ExternalResourceType { get; }
Visual Basic
Public ReadOnly Property ExternalResourceType As ExternalResourceType
    Get
Visual C++
public:
property ExternalResourceType^ ExternalResourceType {
    ExternalResourceType^ get ();
}

See Also

ExternalResourceLoadData Class


ExternalResourceLoadStatus Enumeration

[image]

Revit 2024 API
ExternalResourceLoadStatus Enumeration
See Also Send Feedback
A flag to indicate the status of an ExternalResource load request.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum ExternalResourceLoadStatus
Visual Basic
Public Enumeration ExternalResourceLoadStatus
Visual C++
public enum class ExternalResourceLoadStatus

Members

Member name | Description
Success | The load operation was successful.
Failure | The load operation failed.
Uninitialized | The load operation is in an incomplete state. Revit will treat this result as a failure.
ResourceAlreadyCurrent | The current version of the resource is already loaded into Revit so no changes were made to the model.
CannotFindServer | The server identified by the ExternalResourceReference could not be found, and may not be registered.
ServerThrewException | The server identified by the ExternalResourceReference threw an exception while attempting to load a resource.

Remarks

This flag is returned by the LoadResource method of the IExternalResourceServer class to inform callers whether the load operation succeeded, or encountered an error.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


ExternalResourceMatchOptions Members

[image] [image]

Revit 2024 API
ExternalResourceMatchOptions Members
ExternalResourceMatchOptions Class Constructors Methods Properties See Also Send Feedback

The ExternalResourceMatchOptions type exposes the following members.

Constructors

 | Name | Description
Public method | ExternalResourceMatchOptions | Constructs new instance with specified resource type.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ExternalResourceMatchOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ResourceType | The desired resource type which external resources should match.

See Also

ExternalResourceMatchOptions Class


ExternalResourceMatchOptions Constructor

[image]

Revit 2024 API
ExternalResourceMatchOptions Constructor
ExternalResourceMatchOptions Class See Also Send Feedback
Constructs new instance with specified resource type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public ExternalResourceMatchOptions(
    ExternalResourceType resourceType
)
Visual Basic
Public Sub New ( _
    resourceType As ExternalResourceType _
)
Visual C++
public:
ExternalResourceMatchOptions(
    ExternalResourceType^ resourceType
)

Parameters

resourceType
Type: Autodesk.Revit.DB..::..ExternalResourceType
The desired resource type.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExternalResourceMatchOptions Class


Dispose Method

[image]

Revit 2024 API
ExternalResourceMatchOptions..::..Dispose Method
ExternalResourceMatchOptions Class See Also Send Feedback
Releases all resources used by the ExternalResourceMatchOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ExternalResourceMatchOptions Class


ExternalResourceMatchOptions Properties

[image] [image]

Revit 2024 API
ExternalResourceMatchOptions Properties
ExternalResourceMatchOptions Class See Also Send Feedback

The ExternalResourceMatchOptions type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ResourceType | The desired resource type which external resources should match.

See Also

ExternalResourceMatchOptions Class


IsValidObject Property

[image]

Revit 2024 API
ExternalResourceMatchOptions..::..IsValidObject Property
ExternalResourceMatchOptions Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ExternalResourceMatchOptions Class


ExternalResourceReference Constructor (ExternalResourceReference)

[image]

Revit 2024 API
ExternalResourceReference Constructor (ExternalResourceReference)
ExternalResourceReference Class See Also Send Feedback
Creates a new ExternalResourceReference from the given ExternalResourceReference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public ExternalResourceReference(
    ExternalResourceReference other
)
Visual Basic
Public Sub New ( _
    other As ExternalResourceReference _
)
Visual C++
public:
ExternalResourceReference(
    ExternalResourceReference^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..ExternalResourceReference
The ExternalResourceReference to copy.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExternalResourceReference Class
ExternalResourceReference Overload


ExternalResourceReference Constructor (Guid, IDictionary(String, String), String, String)

[image]

Revit 2024 API
ExternalResourceReference Constructor (Guid, IDictionary<(Of <(<'String, String>)>)>, String, String)
ExternalResourceReference Class See Also Send Feedback
Creates a new ExternalResourceReference from the given data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public ExternalResourceReference(
    Guid serverId,
    IDictionary<string, string> referenceInformation,
    string version,
    string inSessionPath
)
Visual Basic
Public Sub New ( _
    serverId As Guid, _
    referenceInformation As IDictionary(Of String, String), _
    version As String, _
    inSessionPath As String _
)
Visual C++
public:
ExternalResourceReference(
    Guid serverId,
    IDictionary<String^, String^>^ referenceInformation,
    String^ version,
    String^ inSessionPath
)

Parameters

serverId
Type: System..::..Guid
The id of the server associated with this ExternalResourceReference. The server must implement IExternalResourceServer.
referenceInformation
Type: System.Collections.Generic..::..IDictionary<(Of <(<'String, String>)>)>
The (String, String) map containing reference or lookup information that will be stored in Revit.
version
Type: System..::..String
The version of the external data.
inSessionPath
Type: System..::..String
The path that identifies a resource in server. ExternalResourceServer must provide this path which should not contain the server name. Revit internally will construct and store the full display path which includes the server name plus this path at the time a resource is loaded into the model for use if the server is missing.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The file is not allowed to access.

See Also

ExternalResourceReference Class
ExternalResourceReference Overload


ExternalResourceReference Methods

[image] [image]

Revit 2024 API
ExternalResourceReference Methods
ExternalResourceReference Class See Also Send Feedback

The ExternalResourceReference type exposes the following members.

Methods

 | Name | Description
 | CreateLocalResource | Creates an ExternalResourceReference representing a local file managed by Revit's built-in server.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetReferenceInformation | Returns a copy of an object containing previously-stored reference or lookup information about the specific resource provided by the server.
Public method | GetResourceShortDisplayName | Gets the short display name of the external resource.
Public method | GetResourceVersionStatus | Checks whether this ExternalResourceReference corresponds to the current version of the resource.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasValidDisplayPath | Checks whether this external Resource has a valid display path.
Public method | IsValidReference | Checks whether the reference is in a valid format.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ExternalResourceReference Class


CreateLocalResource Method

[image]

Revit 2024 API
ExternalResourceReference..::..CreateLocalResource Method
ExternalResourceReference Class See Also Send Feedback
Creates an ExternalResourceReference representing a local file managed by Revit's built-in server.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static ExternalResourceReference CreateLocalResource(
    Document doc,
    ExternalResourceType resourceType,
    ModelPath path,
    PathType pathType
)
Visual Basic
Public Shared Function CreateLocalResource ( _
    doc As Document, _
    resourceType As ExternalResourceType, _
    path As ModelPath, _
    pathType As PathType _
) As ExternalResourceReference
Visual C++
public:
static ExternalResourceReference^ CreateLocalResource(
    Document^ doc,
    ExternalResourceType^ resourceType,
    ModelPath^ path,
    PathType pathType
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The document containing the reference. If the PathType is relative, the path will be made relative to the location of this Document. (If this Document belongs to a workshared model, the reference will be relative to the central model.)
resourceType
Type: Autodesk.Revit.DB..::..ExternalResourceType
The type of the external resource.
path
Type: Autodesk.Revit.DB..::..ModelPath
A path to the external file. This path must be absolute. If the PathType is relative, then Revit will relativize the path according to the location of the given Document.
pathType
Type: Autodesk.Revit.DB..::..PathType
An enum indicating the type of path which the ExternalResourceReference should use. The PathType must be PathType.Server if the reference is to a Revit model on Revit Server. The PathType must be PathType.Absolute if the reference is local but the host model or host's central model are on Revit Server.

Return Value

The newly-created ExternalResourceReference.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The PathType.Enum value is not valid for this resource type or Document location. PathType.Content is not valid for Revit links. The PathType must be PathType.Server if the resource is on Revit Server and is only valid for Revit links. The PathType must be PathType.Absolute if the host document or the host document's central model are on Revit Server. -or- The given path path is a cloud path which is not supported in this method.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | The model is not allowed to access.

See Also

ExternalResourceReference Class


HasValidDisplayPath Method

[image]

Revit 2024 API
ExternalResourceReference..::..HasValidDisplayPath Method
ExternalResourceReference Class See Also Send Feedback
Checks whether this external Resource has a valid display path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool HasValidDisplayPath()
Visual Basic
Public Function HasValidDisplayPath As Boolean
Visual C++
public:
bool HasValidDisplayPath()

Return Value

True if the this external Resource has a valid display path. False otherwise.

Remarks

For an external resource, such as a Revit link loaded from an external server, the valid display path should be like "My Server://Nested/Nested_1.rvt". For an external resource, such as a Revit link loaded from the "built-in" server, the valid display path should be like "c:\LocalLinks\Link_1.rvt".

See Also

ExternalResourceReference Class


IsValidReference Method

[image]

Revit 2024 API
ExternalResourceReference..::..IsValidReference Method
ExternalResourceReference Class See Also Send Feedback
Checks whether the reference is in a valid format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool IsValidReference(
    ExternalResourceType resourceType
)
Visual Basic
Public Function IsValidReference ( _
    resourceType As ExternalResourceType _
) As Boolean
Visual C++
public:
bool IsValidReference(
    ExternalResourceType^ resourceType
)

Parameters

resourceType
Type: Autodesk.Revit.DB..::..ExternalResourceType
The type of resource which the ExternalResourceReference should correspond to.

Return Value

True if this is a valid ExternalResourceReference. False otherwise.

Remarks

This function checks:
  • The server id corresponds to a valid server which implements IExternalResourceServer.
  • The server supports the given ExternalResourceType.
  • The reference information is well-formed.
This function does not check whether the resource exists on the server.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExternalResourceReference Class


ExternalResourceReference Properties

[image] [image]

Revit 2024 API
ExternalResourceReference Properties
ExternalResourceReference Class See Also Send Feedback

The ExternalResourceReference type exposes the following members.

Properties

Name Description
Public property InSessionPath

The path stores the full display path which includes the server name plus the path provided by ExternalResourceServer.

The path that Revit will present for user recognizing and browsing to this resource during one session of Revit.

This property allows ExternalResourceServers to handle cases where the path to a resource may vary between Revit sessions. For example, if this ExternalResourceReference refers to a resource in a folder, this property can be used to store the current path of the resource. If the resource is moved to another folder later, the ExternalResourceServer could calculate the correct path for the resource from resource identification information when it is loaded and store it in this property, so that it will work correctly even if the rvt file is opened in a different location.

Do not rely on this path to look up an ExternalResourceReference, as the path is neither unique nor stable. It isn't unique because multiple servers might use the same server name and display name format. It isn't stable because some servers allow renaming, and because a server might change its name at some point.

Public property IsValidObject
Specifies whether the .NET object represents a valid Revit entity.
Public property ServerId
The id of the server that Revit is expecting to provide the external resource.
Public property Version
The version of the external data that was most recently loaded in Revit.

See Also

ExternalResourceReference Class


InSessionPath Property

[image]

Revit 2024 API
ExternalResourceReference..::..InSessionPath Property
ExternalResourceReference Class See Also Send Feedback

The path stores the full display path which includes the server name plus the path provided by ExternalResourceServer.

The path that Revit will present for user recognizing and browsing to this resource during one session of Revit.

This property allows ExternalResourceServers to handle cases where the path to a resource may vary between Revit sessions. For example, if this ExternalResourceReference refers to a resource in a folder, this property can be used to store the current path of the resource. If the resource is moved to another folder later, the ExternalResourceServer could calculate the correct path for the resource from resource identification information when it is loaded and store it in this property, so that it will work correctly even if the rvt file is opened in a different location.

Do not rely on this path to look up an ExternalResourceReference, as the path is neither unique nor stable. It isn't unique because multiple servers might use the same server name and display name format. It isn't stable because some servers allow renaming, and because a server might change its name at some point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public string InSessionPath { get; internal set; }
Visual Basic
Public Property InSessionPath As String
    Get
    Friend Set
Visual C++
public:
property String^ InSessionPath {
    String^ get ();
    internal: void set (String^ value);
}

See Also

ExternalResourceReference Class


IsValidObject Property

[image]

Revit 2024 API
ExternalResourceReference..::..IsValidObject Property
ExternalResourceReference Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ExternalResourceReference Class


ServerId Property

[image]

Revit 2024 API
ExternalResourceReference..::..ServerId Property
ExternalResourceReference Class See Also Send Feedback
The id of the server that Revit is expecting to provide the external resource.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public Guid ServerId { get; }
Visual Basic
Public ReadOnly Property ServerId As Guid
    Get
Visual C++
public:
property Guid ServerId {
    Guid get ();
}

See Also

ExternalResourceReference Class


Version Property

[image]

Revit 2024 API
ExternalResourceReference..::..Version Property
ExternalResourceReference Class See Also Send Feedback
The version of the external data that was most recently loaded in Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public string Version { get; internal set; }
Visual Basic
Public Property Version As String
    Get
    Friend Set
Visual C++
public:
property String^ Version {
    String^ get ();
    internal: void set (String^ value);
}

See Also

ExternalResourceReference Class


ExternalResourceServerExtensions Class

[image]

Revit 2024 API
ExternalResourceServerExtensions Class
Members See Also Send Feedback
An object that contains overrides for external resource-specific methods.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public class ExternalResourceServerExtensions : IDisposable
Visual Basic
Public Class ExternalResourceServerExtensions _
    Implements IDisposable
Visual C++
public ref class ExternalResourceServerExtensions : IDisposable

Remarks

This class permits assignment of some specific operations related to a type of external resource, such as what to do when "Open (and Unload)" happens, or when "Shared Coordinates update" happens for Revit or CAD links.

There is no feedback to the UI server for ExternalResourceServerExtensions. Revit will use standard, common message dialogs to handle any error conditions.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ExternalResourceServerExtensions

See Also

ExternalResourceServerExtensions Members


ExternalResourceServerExtensions Members

[image] [image]

Revit 2024 API
ExternalResourceServerExtensions Members
ExternalResourceServerExtensions Class Methods Properties See Also Send Feedback

The ExternalResourceServerExtensions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ExternalResourceServerExtensions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCADLinkOperations | Gets the specific methods supported by external resource CAD Links.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRevitLinkOperations | Gets the specific methods supported by the external resource of Revit Links.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ExternalResourceServerExtensions Class


Dispose Method

[image]

Revit 2024 API
ExternalResourceServerExtensions..::..Dispose Method
ExternalResourceServerExtensions Class See Also Send Feedback
Releases all resources used by the ExternalResourceServerExtensions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ExternalResourceServerExtensions Class


GetCADLinkOperations Method

[image]

Revit 2024 API
ExternalResourceServerExtensions..::..GetCADLinkOperations Method
ExternalResourceServerExtensions Class See Also Send Feedback
Gets the specific methods supported by external resource CAD Links.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public CADLinkOperations GetCADLinkOperations()
Visual Basic
Public Function GetCADLinkOperations As CADLinkOperations
Visual C++
public:
CADLinkOperations^ GetCADLinkOperations()

Return Value

The specific methods supported by external resource CAD Links.

See Also

ExternalResourceServerExtensions Class


GetRevitLinkOperations Method

[image]

Revit 2024 API
ExternalResourceServerExtensions..::..GetRevitLinkOperations Method
ExternalResourceServerExtensions Class See Also Send Feedback
Gets the specific methods supported by the external resource of Revit Links.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public RevitLinkOperations GetRevitLinkOperations()
Visual Basic
Public Function GetRevitLinkOperations As RevitLinkOperations
Visual C++
public:
RevitLinkOperations^ GetRevitLinkOperations()

Return Value

The specific methods supported by the external resource of Revit Links.

See Also

ExternalResourceServerExtensions Class


ExternalResourceServerExtensions Properties

[image] [image]

Revit 2024 API
ExternalResourceServerExtensions Properties
ExternalResourceServerExtensions Class See Also Send Feedback

The ExternalResourceServerExtensions type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ExternalResourceServerExtensions Class


IsValidObject Property

[image]

Revit 2024 API
ExternalResourceServerExtensions..::..IsValidObject Property
ExternalResourceServerExtensions Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ExternalResourceServerExtensions Class


ExternalResourceServerUtils Class

[image]

Revit 2024 API
ExternalResourceServerUtils Class
Members See Also Send Feedback
Contains utilities related to external resource server.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static class ExternalResourceServerUtils
Visual Basic
Public NotInheritable Class ExternalResourceServerUtils
Visual C++
public ref class ExternalResourceServerUtils abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ExternalResourceServerUtils

See Also

ExternalResourceServerUtils Members


ExternalResourceServerUtils Methods

[image] [image]

Revit 2024 API
ExternalResourceServerUtils Methods
ExternalResourceServerUtils Class See Also Send Feedback

The ExternalResourceServerUtils type exposes the following members.

Methods

Name | Description
IsValidShortName | Checks whether the name is a valid short name for the external resource server.
ServerSupportsAssemblyCodeData | Checks that the server referenced by the given ExternalResourceReference supports AssemblyCodeData.
ServerSupportsCADLinks | Checks that the server referenced by the given ExternalResourceReference supports CAD links.
ServerSupportsIFCLinks | Checks that the server referenced by the given ExternalResourceReference supports IFC links.
ServerSupportsKeynotes | Checks that the server referenced by the given ExternalResourceReference supports KeynoteTable data.
ServerSupportsRevitLinks | Checks that the server referenced by the given ExternalResourceReference supports Revit links.

See Also

ExternalResourceServerUtils Class


IsValidShortName Method

[image]

Revit 2024 API
ExternalResourceServerUtils..::..IsValidShortName Method
ExternalResourceServerUtils Class See Also Send Feedback
Checks whether the name is a valid short name for the external resource server.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static bool IsValidShortName(
    Guid serverId,
    string serverName
)
Visual Basic
Public Shared Function IsValidShortName ( _
    serverId As Guid, _
    serverName As String _
) As Boolean
Visual C++
public:
static bool IsValidShortName(
    Guid serverId,
    String^ serverName
)

Parameters

serverId
Type: System..::..Guid
The id of the external resource server.
serverName
Type: System..::..String
The short name of the external resource server.

Return Value

True if the name is a valid short name, false otherwise.

Remarks

A valid short name should match the restrictions documented in GetShortName()()()().

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExternalResourceServerUtils Class


ServerSupportsAssemblyCodeData Method

[image]

Revit 2024 API
ExternalResourceServerUtils..::..ServerSupportsAssemblyCodeData Method
ExternalResourceServerUtils Class See Also Send Feedback
Checks that the server referenced by the given ExternalResourceReference supports AssemblyCodeData.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static bool ServerSupportsAssemblyCodeData(
    ExternalResourceReference extRef
)
Visual Basic
Public Shared Function ServerSupportsAssemblyCodeData ( _
    extRef As ExternalResourceReference _
) As Boolean
Visual C++
public:
static bool ServerSupportsAssemblyCodeData(
    ExternalResourceReference^ extRef
)

Parameters

extRef
Type: Autodesk.Revit.DB..::..ExternalResourceReference
The ExternalResourceReference to check.

Return Value

True if the ExternalResourceReference refers to a server that supports AssemblyCodeData. False otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExternalResourceServerUtils Class


ServerSupportsCADLinks Method

[image]

Revit 2024 API
ExternalResourceServerUtils..::..ServerSupportsCADLinks Method
ExternalResourceServerUtils Class See Also Send Feedback
Checks that the server referenced by the given ExternalResourceReference supports CAD links.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public static bool ServerSupportsCADLinks(
    ExternalResourceReference extRef
)
Visual Basic
Public Shared Function ServerSupportsCADLinks ( _
    extRef As ExternalResourceReference _
) As Boolean
Visual C++
public:
static bool ServerSupportsCADLinks(
    ExternalResourceReference^ extRef
)

Parameters

extRef
Type: Autodesk.Revit.DB..::..ExternalResourceReference
The ExternalResourceReference to check.

Return Value

True if the ExternalResourceReference refers to a server that supports CAD links. False otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExternalResourceServerUtils Class


ServerSupportsIFCLinks Method

[image]

Revit 2024 API
ExternalResourceServerUtils..::..ServerSupportsIFCLinks Method
ExternalResourceServerUtils Class See Also Send Feedback
Checks that the server referenced by the given ExternalResourceReference supports IFC links.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public static bool ServerSupportsIFCLinks(
    ExternalResourceReference extRef
)
Visual Basic
Public Shared Function ServerSupportsIFCLinks ( _
    extRef As ExternalResourceReference _
) As Boolean
Visual C++
public:
static bool ServerSupportsIFCLinks(
    ExternalResourceReference^ extRef
)

Parameters

extRef
Type: Autodesk.Revit.DB..::..ExternalResourceReference
The ExternalResourceReference to check.

Return Value

True if the ExternalResourceReference refers to a server that supports IFC links. False otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExternalResourceServerUtils Class


ServerSupportsRevitLinks Method

[image]

Revit 2024 API
ExternalResourceServerUtils..::..ServerSupportsRevitLinks Method
ExternalResourceServerUtils Class See Also Send Feedback
Checks that the server referenced by the given ExternalResourceReference supports Revit links.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static bool ServerSupportsRevitLinks(
    ExternalResourceReference extRef
)
Visual Basic
Public Shared Function ServerSupportsRevitLinks ( _
    extRef As ExternalResourceReference _
) As Boolean
Visual C++
public:
static bool ServerSupportsRevitLinks(
    ExternalResourceReference^ extRef
)

Parameters

extRef
Type: Autodesk.Revit.DB..::..ExternalResourceReference
The ExternalResourceReference to check.

Return Value

True if the ExternalResourceReference refers to a server that supports Revit links. False otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExternalResourceServerUtils Class


ExternalResourceServiceUtils Class

[image]

Revit 2024 API
ExternalResourceServiceUtils Class
Members See Also Send Feedback
Contains utilities related to external resource service.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static class ExternalResourceServiceUtils
Visual Basic
Public NotInheritable Class ExternalResourceServiceUtils
Visual C++
public ref class ExternalResourceServiceUtils abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ExternalResourceServiceUtils

See Also

ExternalResourceServiceUtils Members


ExternalResourceServiceUtils Members

[image] [image]

Revit 2024 API
ExternalResourceServiceUtils Members
ExternalResourceServiceUtils Class Methods See Also Send Feedback

The ExternalResourceServiceUtils type exposes the following members.

Methods

Name | Description
GetServersByType | Gets registered external resource servers which support the external resource type.

See Also

ExternalResourceServiceUtils Class


ExternalResourceServiceUtils Methods

[image] [image]

Revit 2024 API
ExternalResourceServiceUtils Methods
ExternalResourceServiceUtils Class See Also Send Feedback

The ExternalResourceServiceUtils type exposes the following members.

Methods

Name | Description
GetServersByType | Gets registered external resource servers which support the external resource type.

See Also

ExternalResourceServiceUtils Class


GetServersByType Method

[image]

Revit 2024 API
ExternalResourceServiceUtils..::..GetServersByType Method
ExternalResourceServiceUtils Class See Also Send Feedback
Gets registered external resource servers which support the external resource type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static IList<IExternalResourceServer> GetServersByType(
    ExternalResourceType type
)
Visual Basic
Public Shared Function GetServersByType ( _
    type As ExternalResourceType _
) As IList(Of IExternalResourceServer)
Visual C++
public:
static IList<IExternalResourceServer^>^ GetServersByType(
    ExternalResourceType^ type
)

Parameters

type
Type: Autodesk.Revit.DB..::..ExternalResourceType
The external resource type for the servers to match

Return Value

A list of matched external resource servers

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExternalResourceServiceUtils Class


ExternalResourceSubFolder Class

[image]

Revit 2024 API
ExternalResourceSubFolder Class
Members See Also Send Feedback
Data that describes a remote folder to be shown in the file browser dialog

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019.1

Syntax

C#
public class ExternalResourceSubFolder : IDisposable
Visual Basic
Public Class ExternalResourceSubFolder _
    Implements IDisposable
Visual C++
public ref class ExternalResourceSubFolder : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ExternalResourceSubFolder

See Also

ExternalResourceSubFolder Members


ExternalResourceSubFolder Members

[image] [image]

Revit 2024 API
ExternalResourceSubFolder Members
ExternalResourceSubFolder Class Constructors Methods Properties See Also Send Feedback

The ExternalResourceSubFolder type exposes the following members.

Constructors

 | Name | Description
Public method | ExternalResourceSubFolder()()()() | Constructs a new ExternalResourceSubFolder with default values for folder name and icon path.
Public method | ExternalResourceSubFolder(String, String) | Constructs a new ExternalResourceSubFolder with custom values for folder name and icon path.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ExternalResourceSubFolder
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FolderName | Folder displayed name.
Public property | IconPath | The path of the resource icon.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ExternalResourceSubFolder Class


ExternalResourceSubFolder Constructor

[image]

Revit 2024 API
ExternalResourceSubFolder Constructor
ExternalResourceSubFolder Class See Also Send Feedback
Constructs a new ExternalResourceSubFolder with default values for folder name and icon path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019.1

Syntax

C#
public ExternalResourceSubFolder()
Visual Basic
Public Sub New
Visual C++
public:
ExternalResourceSubFolder()

See Also

ExternalResourceSubFolder Class
ExternalResourceSubFolder Overload


ExternalResourceSubFolder Methods

[image] [image]

Revit 2024 API
ExternalResourceSubFolder Methods
ExternalResourceSubFolder Class See Also Send Feedback

The ExternalResourceSubFolder type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ExternalResourceSubFolder Class


Dispose Method

[image]

Revit 2024 API
ExternalResourceSubFolder..::..Dispose Method
ExternalResourceSubFolder Class See Also Send Feedback
Releases all resources used by the ExternalResourceSubFolder

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ExternalResourceSubFolder Class


ExternalResourceSubFolder Properties

[image] [image]

Revit 2024 API
ExternalResourceSubFolder Properties
ExternalResourceSubFolder Class See Also Send Feedback

The ExternalResourceSubFolder type exposes the following members.

Properties

 | Name | Description
Public property | FolderName | Folder displayed name.
Public property | IconPath | The path of the resource icon.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ExternalResourceSubFolder Class


FolderName Property

[image]

Revit 2024 API
ExternalResourceSubFolder..::..FolderName Property
ExternalResourceSubFolder Class See Also Send Feedback
Folder displayed name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019.1

Syntax

C#
public string FolderName { get; set; }
Visual Basic
Public Property FolderName As String
    Get
    Set
Visual C++
public:
property String^ FolderName {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ExternalResourceSubFolder Class


IconPath Property

[image]

Revit 2024 API
ExternalResourceSubFolder..::..IconPath Property
ExternalResourceSubFolder Class See Also Send Feedback
The path of the resource icon.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019.1

Syntax

C#
public string IconPath { get; set; }
Visual Basic
Public Property IconPath As String
    Get
    Set
Visual C++
public:
property String^ IconPath {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ExternalResourceSubFolder Class


ExternalResourceType Class

[image]

Revit 2024 API
ExternalResourceType Class
Members See Also Send Feedback
A type class used to distinguish between different kinds of external resource.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public class ExternalResourceType : GuidEnum
Visual Basic
Public Class ExternalResourceType _
    Inherits GuidEnum
Visual C++
public ref class ExternalResourceType : public GuidEnum

Remarks

Revit elements can consume multiple types of external resource data, provided by one or more external servers. Conversely, external servers can support one, or more than one, type of external resource.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..GuidEnum
Autodesk.Revit.DB..::..ExternalResourceType

See Also

ExternalResourceType Members


ExternalResourceType Members

[image] [image]

Revit 2024 API
ExternalResourceType Members
ExternalResourceType Class Constructors Methods Operators Properties See Also Send Feedback

The ExternalResourceType type exposes the following members.

Constructors

 | Name | Description
Public method | ExternalResourceType | Creates a new ExternalResourceType instance.

Methods

 | Name | Description
Public method | Equals | Compares two Guid-based enum object based on their concrete class and GUID value. (Inherited from GuidEnum.)
Public method | GetHashCode | Generates a hash code for this Guid-based enum object. (Inherited from GuidEnum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Operators

Name | Description
Equality | Compares two ExternalResourceType instances.
Inequality | Compares two ExternalResourceType instances.

Properties

 | Name | Description
Public property | Guid | The Guid of GUID-based enum object. (Inherited from GuidEnum.)

See Also

ExternalResourceType Class


ExternalResourceType Constructor

[image]

Revit 2024 API
ExternalResourceType Constructor
ExternalResourceType Class See Also Send Feedback
Creates a new ExternalResourceType instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ExternalResourceType(
    Guid guid
)
Visual Basic
Public Sub New ( _
    guid As Guid _
)
Visual C++
public:
ExternalResourceType(
    Guid guid
)

Parameters

guid
Type: System..::..Guid
The identifier for the ExternalResourceType.

See Also

ExternalResourceType Class


ExternalResourceType Methods

[image] [image]

Revit 2024 API
ExternalResourceType Methods
ExternalResourceType Class See Also Send Feedback

The ExternalResourceType type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Compares two Guid-based enum object based on their concrete class and GUID value. (Inherited from GuidEnum.)
Public method | GetHashCode | Generates a hash code for this Guid-based enum object. (Inherited from GuidEnum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ExternalResourceType Class


Inequality Operator

[image]

Revit 2024 API
ExternalResourceType..::..Inequality Operator
ExternalResourceType Class See Also Send Feedback
Compares two ExternalResourceType instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static bool operator !=(
    ExternalResourceType first,
    ExternalResourceType second
)
Visual Basic
Public Shared Operator <> ( _
    first As ExternalResourceType, _
    second As ExternalResourceType _
) As Boolean
Visual C++
public:
static bool operator !=(
    ExternalResourceType^ first,
    ExternalResourceType^ second
)

Parameters

first
Type: Autodesk.Revit.DB..::..ExternalResourceType
The first ExternalResourceType.
second
Type: Autodesk.Revit.DB..::..ExternalResourceType
The second ExternalResourceType.

Return Value

True if the inputs are different, false if they are identical.

See Also

ExternalResourceType Class


ExternalResourceTypes Class

[image]

Revit 2024 API
ExternalResourceTypes Class
See Also Send Feedback
Provides a container of all Revit built-in ExternalResourceType instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class ExternalResourceTypes
Visual Basic
Public NotInheritable Class ExternalResourceTypes
Visual C++
public ref class ExternalResourceTypes abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ExternalResourceTypes

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


ExternalResourceTypes.BuiltInExternalResourceTypes Class

[image]

Revit 2024 API
ExternalResourceTypes..::..BuiltInExternalResourceTypes Class
ExternalResourceTypes Class Members See Also Send Feedback
A collection of ids of the ExternalResourceTypes provided by Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class BuiltInExternalResourceTypes
Visual Basic
Public NotInheritable Class BuiltInExternalResourceTypes
Visual C++
public ref class BuiltInExternalResourceTypes abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ExternalResourceTypes..::..BuiltInExternalResourceTypes

See Also

ExternalResourceTypes..::..BuiltInExternalResourceTypes Members


ExternalResourceTypes.BuiltInExternalResourceTypes Members

[image] [image]

Revit 2024 API
ExternalResourceTypes..::..BuiltInExternalResourceTypes Members
ExternalResourceTypes..::..BuiltInExternalResourceTypes Class Properties See Also Send Feedback

Provides a container of all Revit built-in ExternalResourceType instances.

The ExternalResourceTypes..::..BuiltInExternalResourceTypes type exposes the following members.

Properties

Name | Description
AssemblyCodeTable | An external resource type representing assembly code data.
CADLink | An external resource type representing CAD Links data.
DecalBumpMap | An external resource type representing Decal linked data for bump map. This type is reserved for future expansion but not yet implemented.
DecalCutOut | An external resource type representing Decal linked data for cut out opacity. This type is reserved for future expansion but not yet implemented.
DecalImage | An external resource type representing decal images.
DecalMap | An external resource type representing Decal linked data for diffuse. This type is reserved for future expansion but not yet implemented.
DWFMarkup | An external resource type representing DWF markups data. This type is reserved for future expansion but not yet implemented.
FabricationConfiguration | An external resource type representing an MEP fabrication configuration.
IFCLink | An external resource type representing IFC links.
Image | An external resource type representing images.
KeynoteTable | An external resource type representing keynote data.
MaterialTexture | An external resource type representing material texture images.
PointCloud | An external resource type representing Point Clouds. This type is reserved for future expansion but not yet implemented.
RevitLink | An external resource type representing Revit Links data.
SystemsAnalysisReport | An external resource type representing systems analysis report path.
TopographyLink | An external resource type representing Topography Links.

See Also

ExternalResourceTypes..::..BuiltInExternalResourceTypes Class


ExternalResourceTypes.BuiltInExternalResourceTypes Properties

[image] [image]

Revit 2024 API
ExternalResourceTypes..::..BuiltInExternalResourceTypes Properties
ExternalResourceTypes..::..BuiltInExternalResourceTypes Class See Also Send Feedback

The ExternalResourceTypes..::..BuiltInExternalResourceTypes type exposes the following members.

Properties

Name | Description
AssemblyCodeTable | An external resource type representing assembly code data.
CADLink | An external resource type representing CAD Links data.
DecalBumpMap | An external resource type representing Decal linked data for bump map. This type is reserved for future expansion but not yet implemented.
DecalCutOut | An external resource type representing Decal linked data for cut out opacity. This type is reserved for future expansion but not yet implemented.
DecalImage | An external resource type representing decal images.
DecalMap | An external resource type representing Decal linked data for diffuse. This type is reserved for future expansion but not yet implemented.
DWFMarkup | An external resource type representing DWF markups data. This type is reserved for future expansion but not yet implemented.
FabricationConfiguration | An external resource type representing an MEP fabrication configuration.
IFCLink | An external resource type representing IFC links.
Image | An external resource type representing images.
KeynoteTable | An external resource type representing keynote data.
MaterialTexture | An external resource type representing material texture images.
PointCloud | An external resource type representing Point Clouds. This type is reserved for future expansion but not yet implemented.
RevitLink | An external resource type representing Revit Links data.
SystemsAnalysisReport | An external resource type representing systems analysis report path.
TopographyLink | An external resource type representing Topography Links.

See Also

ExternalResourceTypes..::..BuiltInExternalResourceTypes Class


AssemblyCodeTable Property

[image]

Revit 2024 API
ExternalResourceTypes..::..BuiltInExternalResourceTypes..::..AssemblyCodeTable Property
ExternalResourceTypes..::..BuiltInExternalResourceTypes Class See Also Send Feedback
An external resource type representing assembly code data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ExternalResourceType AssemblyCodeTable { get; }
Visual Basic
Public Shared ReadOnly Property AssemblyCodeTable As ExternalResourceType
    Get
Visual C++
public:
static property ExternalResourceType^ AssemblyCodeTable {
    ExternalResourceType^ get ();
}

See Also

ExternalResourceTypes..::..BuiltInExternalResourceTypes Class


CADLink Property

[image]

Revit 2024 API
ExternalResourceTypes..::..BuiltInExternalResourceTypes..::..CADLink Property
ExternalResourceTypes..::..BuiltInExternalResourceTypes Class See Also Send Feedback
An external resource type representing CAD Links data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ExternalResourceType CADLink { get; }
Visual Basic
Public Shared ReadOnly Property CADLink As ExternalResourceType
    Get
Visual C++
public:
static property ExternalResourceType^ CADLink {
    ExternalResourceType^ get ();
}

See Also

ExternalResourceTypes..::..BuiltInExternalResourceTypes Class


DecalBumpMap Property

[image]

Revit 2024 API
ExternalResourceTypes..::..BuiltInExternalResourceTypes..::..DecalBumpMap Property
ExternalResourceTypes..::..BuiltInExternalResourceTypes Class See Also Send Feedback
An external resource type representing Decal linked data for bump map. This type is reserved for future expansion but not yet implemented.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ExternalResourceType DecalBumpMap { get; }
Visual Basic
Public Shared ReadOnly Property DecalBumpMap As ExternalResourceType
    Get
Visual C++
public:
static property ExternalResourceType^ DecalBumpMap {
    ExternalResourceType^ get ();
}

See Also

ExternalResourceTypes..::..BuiltInExternalResourceTypes Class


DecalCutOut Property

[image]

Revit 2024 API
ExternalResourceTypes..::..BuiltInExternalResourceTypes..::..DecalCutOut Property
ExternalResourceTypes..::..BuiltInExternalResourceTypes Class See Also Send Feedback
An external resource type representing Decal linked data for cut out opacity. This type is reserved for future expansion but not yet implemented.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ExternalResourceType DecalCutOut { get; }
Visual Basic
Public Shared ReadOnly Property DecalCutOut As ExternalResourceType
    Get
Visual C++
public:
static property ExternalResourceType^ DecalCutOut {
    ExternalResourceType^ get ();
}

See Also

ExternalResourceTypes..::..BuiltInExternalResourceTypes Class


DecalMap Property

[image]

Revit 2024 API
ExternalResourceTypes..::..BuiltInExternalResourceTypes..::..DecalMap Property
ExternalResourceTypes..::..BuiltInExternalResourceTypes Class See Also Send Feedback
An external resource type representing Decal linked data for diffuse. This type is reserved for future expansion but not yet implemented.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ExternalResourceType DecalMap { get; }
Visual Basic
Public Shared ReadOnly Property DecalMap As ExternalResourceType
    Get
Visual C++
public:
static property ExternalResourceType^ DecalMap {
    ExternalResourceType^ get ();
}

See Also

ExternalResourceTypes..::..BuiltInExternalResourceTypes Class


DWFMarkup Property

[image]

Revit 2024 API
ExternalResourceTypes..::..BuiltInExternalResourceTypes..::..DWFMarkup Property
ExternalResourceTypes..::..BuiltInExternalResourceTypes Class See Also Send Feedback
An external resource type representing DWF markups data. This type is reserved for future expansion but not yet implemented.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ExternalResourceType DWFMarkup { get; }
Visual Basic
Public Shared ReadOnly Property DWFMarkup As ExternalResourceType
    Get
Visual C++
public:
static property ExternalResourceType^ DWFMarkup {
    ExternalResourceType^ get ();
}

See Also

ExternalResourceTypes..::..BuiltInExternalResourceTypes Class


FabricationConfiguration Property

[image]

Revit 2024 API
ExternalResourceTypes..::..BuiltInExternalResourceTypes..::..FabricationConfiguration Property
ExternalResourceTypes..::..BuiltInExternalResourceTypes Class See Also Send Feedback
An external resource type representing an MEP fabrication configuration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ExternalResourceType FabricationConfiguration { get; }
Visual Basic
Public Shared ReadOnly Property FabricationConfiguration As ExternalResourceType
    Get
Visual C++
public:
static property ExternalResourceType^ FabricationConfiguration {
    ExternalResourceType^ get ();
}

See Also

ExternalResourceTypes..::..BuiltInExternalResourceTypes Class


IFCLink Property

[image]

Revit 2024 API
ExternalResourceTypes..::..BuiltInExternalResourceTypes..::..IFCLink Property
ExternalResourceTypes..::..BuiltInExternalResourceTypes Class See Also Send Feedback
An external resource type representing IFC links.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ExternalResourceType IFCLink { get; }
Visual Basic
Public Shared ReadOnly Property IFCLink As ExternalResourceType
    Get
Visual C++
public:
static property ExternalResourceType^ IFCLink {
    ExternalResourceType^ get ();
}

See Also

ExternalResourceTypes..::..BuiltInExternalResourceTypes Class


MaterialTexture Property

[image]

Revit 2024 API
ExternalResourceTypes..::..BuiltInExternalResourceTypes..::..MaterialTexture Property
ExternalResourceTypes..::..BuiltInExternalResourceTypes Class See Also Send Feedback
An external resource type representing material texture images.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ExternalResourceType MaterialTexture { get; }
Visual Basic
Public Shared ReadOnly Property MaterialTexture As ExternalResourceType
    Get
Visual C++
public:
static property ExternalResourceType^ MaterialTexture {
    ExternalResourceType^ get ();
}

See Also

ExternalResourceTypes..::..BuiltInExternalResourceTypes Class


RevitLink Property

[image]

Revit 2024 API
ExternalResourceTypes..::..BuiltInExternalResourceTypes..::..RevitLink Property
ExternalResourceTypes..::..BuiltInExternalResourceTypes Class See Also Send Feedback
An external resource type representing Revit Links data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ExternalResourceType RevitLink { get; }
Visual Basic
Public Shared ReadOnly Property RevitLink As ExternalResourceType
    Get
Visual C++
public:
static property ExternalResourceType^ RevitLink {
    ExternalResourceType^ get ();
}

See Also

ExternalResourceTypes..::..BuiltInExternalResourceTypes Class


SystemsAnalysisReport Property

[image]

Revit 2024 API
ExternalResourceTypes..::..BuiltInExternalResourceTypes..::..SystemsAnalysisReport Property
ExternalResourceTypes..::..BuiltInExternalResourceTypes Class See Also Send Feedback
An external resource type representing systems analysis report path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ExternalResourceType SystemsAnalysisReport { get; }
Visual Basic
Public Shared ReadOnly Property SystemsAnalysisReport As ExternalResourceType
    Get
Visual C++
public:
static property ExternalResourceType^ SystemsAnalysisReport {
    ExternalResourceType^ get ();
}

See Also

ExternalResourceTypes..::..BuiltInExternalResourceTypes Class


ExternalResourceUIBrowseResultType Enumeration

[image]

Revit 2024 API
ExternalResourceUIBrowseResultType Enumeration
See Also Send Feedback
Describes the type of external resource browsing result.
Describes the type of external resource browsing result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015
Since: 2015

Syntax

C#
public enum ExternalResourceUIBrowseResultType
Visual Basic
Public Enumeration ExternalResourceUIBrowseResultType
Visual C++
public enum class ExternalResourceUIBrowseResultType

Members

Member name | Description
Success | There is no predefined error happened during this browse operation. The DB server can store any errors itself in this case.
FolderNotFound | The specified external resource folder cannot be found by external resource server.
ResourceNotFound | The specified external resource cannot be found by external resource server.

Remarks

This enum is used to describe the type of external resources browsing operation result ( the browsing operation include list folders and resources of an external server or a folder, or open an external resource in browsing dialog.) The meaning of each enum value:
  • There is no predefined error happened during this browse operation. The DB server can store any errors itself in this case.
  • FolderNotFound means the external resource folder want to browse could not be founded in external server.
  • ResourceNotFound means the external resource want to open could not be founded in external server.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


ExternalResourceUtils Class

[image]

Revit 2024 API
ExternalResourceUtils Class
Members See Also Send Feedback
A utility class containing functions related to external resource references.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static class ExternalResourceUtils
Visual Basic
Public NotInheritable Class ExternalResourceUtils
Visual C++
public ref class ExternalResourceUtils abstract sealed

Remarks

Elements which are external resource references refer to data outside of the base .rvt file. Examples include Revit links and the keynote table data.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ExternalResourceUtils

See Also

ExternalResourceUtils Members


ExternalResourceUtils Members

[image] [image]

Revit 2024 API
ExternalResourceUtils Members
ExternalResourceUtils Class Methods See Also Send Feedback

Methods

Name | Description
GetAllExternalResourceReferences(Document) | Gets the ids of all elements which refer to external resources.
GetAllExternalResourceReferences(Document, ExternalResourceType) | Gets the ids of all elements which refer to a specific type of external resource.

See Also

ExternalResourceUtils Class


GetAllExternalResourceReferences Method

[image] [image]

Revit 2024 API
ExternalResourceUtils..::..GetAllExternalResourceReferences Method
ExternalResourceUtils Class See Also Send Feedback

Overload List

Name | Description
GetAllExternalResourceReferences(Document) | Gets the ids of all elements which refer to external resources.
GetAllExternalResourceReferences(Document, ExternalResourceType) | Gets the ids of all elements which refer to a specific type of external resource.

See Also

ExternalResourceUtils Class
ExternalResourceUtils Members


GetAllExternalResourceReferences Method (Document)

[image]

Revit 2024 API
ExternalResourceUtils..::..GetAllExternalResourceReferences Method (Document)
ExternalResourceUtils Class See Also Send Feedback
Gets the ids of all elements which refer to external resources.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static ISet<ElementId> GetAllExternalResourceReferences(
    Document document
)
Visual Basic
Public Shared Function GetAllExternalResourceReferences ( _
    document As Document _
) As ISet(Of ElementId)
Visual C++
public:
static ISet<ElementId^>^ GetAllExternalResourceReferences(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The Revit Document containing the external resource references.

Return Value

The ids of all elements which refer to external resources.

Remarks

This function will not return the ids of nested Revit links; it only returns top-level references.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ExternalResourceUtils Class
GetAllExternalResourceReferences Overload


Extrusion Class

[image]

Revit 2024 API
Extrusion Class
Members See Also Send Feedback
A extrusion solid or void form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class Extrusion : GenericForm
Visual Basic
Public Class Extrusion _
    Inherits GenericForm
Visual C++
public ref class Extrusion : public GenericForm

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..CombinableElement
Autodesk.Revit.DB..::..GenericForm
Autodesk.Revit.DB..::..Extrusion

See Also

Extrusion Members


Extrusion Members

[image] [image]

Revit 2024 API
Extrusion Members
Extrusion Class Methods Properties See Also Send Feedback

The Extrusion type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EndOffset | The offset of the end of the extrusion relative to the sketch plane.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Get and Set the Name property (Inherited from GenericForm.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Sketch | Returns the Sketch of the Extrusion.
Public property | StartOffset | The offset of the start of the extrusion relative to the sketch plane.
Public property | Subcategory | The subcategory. (Inherited from GenericForm.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Visible | The visibility of the GenericForm. (Inherited from GenericForm.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Extrusion Class


Extrusion Methods

[image] [image]

Revit 2024 API
Extrusion Methods
Extrusion Class See Also Send Feedback

The Extrusion type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Extrusion Class


EndOffset Property

[image]

Revit 2024 API
Extrusion..::..EndOffset Property
Extrusion Class See Also Send Feedback
The offset of the end of the extrusion relative to the sketch plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double EndOffset { get; set; }
Visual Basic
Public Property EndOffset As Double
    Get
    Set
Visual C++
public:
property double EndOffset {
    double get ();
    void set (double value);
}

Remarks

The direction of the offset is based on the normal of the extrusion's sketch plane: a positive value is in the direction of the normal, a negative value is in the other direction.

See Also

Extrusion Class


Parameter Property

[image] [image]

Revit 2024 API
Extrusion..::..Parameter Property
Extrusion Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Extrusion Class
Extrusion Members


Sketch Property

[image]

Revit 2024 API
Extrusion..::..Sketch Property
Extrusion Class See Also Send Feedback
Returns the Sketch of the Extrusion.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Sketch Sketch { get; }
Visual Basic
Public ReadOnly Property Sketch As Sketch
    Get
Visual C++
public:
property Sketch^ Sketch {
    Sketch^ get ();
}

Remarks

This property is used to retrieve the Sketches of the Extrusion.

See Also

Extrusion Class


ExtrusionAnalyzer Class

[image]

Revit 2024 API
ExtrusionAnalyzer Class
Members See Also Send Feedback
This geometry utility allows you to attempt to "fit" a given piece of geometry into the shape of an extrusion.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public class ExtrusionAnalyzer : IDisposable
Visual Basic
Public Class ExtrusionAnalyzer _
    Implements IDisposable
Visual C++
public ref class ExtrusionAnalyzer : IDisposable

Remarks

An instance of this class is a single-time use class which should be supplied a solid geometry, a plane, and a direction. The utility will calculate a base boundary parallel to the input plane which is the outer boundary of the shadow cast by the solid onto the input plane and along the extrusion direction.

After the extrusion has been calculated, the class permits a second step analysis to identify all faces from the original geometry which do not align with the faces of the calculated extrusion.

This utility works best for geometry which are at least somewhat "extrusion-like", for example, the geometry of a wall which may or may not be affected by end joins, floor joins, roof joins, openings cut by windows and doors, or other modifications.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ExtrusionAnalyzer

See Also

ExtrusionAnalyzer Members


ExtrusionAnalyzer Members

[image] [image]

Revit 2024 API
ExtrusionAnalyzer Members
ExtrusionAnalyzer Class Methods Properties See Also Send Feedback

The ExtrusionAnalyzer type exposes the following members.

Methods

 | Name | Description
Public method | CalculateFaceAlignment | Calculates the alignment status of each face of the solid.
 | Create | Creates an ExtrusionAnalyzer and computes and stores the solid's shadow.
Public method | Dispose | Releases all resources used by the ExtrusionAnalyzer
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetExtrusionBase | Obtains the face that represents the base contour of the extrusion analysis.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | EndParameter | The end parameter (distance along the extrusion direction from the input plane) calculated by the extrusion analysis.
Public property | ExtrusionDirection | The direction of extrusion specified for the extrusion analysis.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | StartParameter | The start parameter (distance along the extrusion direction from the input plane) calculated by the extrusion analysis.

See Also

ExtrusionAnalyzer Class


ExtrusionAnalyzer Methods

[image] [image]

Revit 2024 API
ExtrusionAnalyzer Methods
ExtrusionAnalyzer Class See Also Send Feedback

The ExtrusionAnalyzer type exposes the following members.

Methods

 | Name | Description
Public method | CalculateFaceAlignment | Calculates the alignment status of each face of the solid.
 | Create | Creates an ExtrusionAnalyzer and computes and stores the solid's shadow.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetExtrusionBase | Obtains the face that represents the base contour of the extrusion analysis.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ExtrusionAnalyzer Class


CalculateFaceAlignment Method

[image]

Revit 2024 API
ExtrusionAnalyzer..::..CalculateFaceAlignment Method
ExtrusionAnalyzer Class See Also Send Feedback
Calculates the alignment status of each face of the solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public IDictionary<Face, ExtrusionAnalyzerFaceAlignment> CalculateFaceAlignment()
Visual Basic
Public Function CalculateFaceAlignment As IDictionary(Of Face, ExtrusionAnalyzerFaceAlignment)
Visual C++
public:
IDictionary<Face^, ExtrusionAnalyzerFaceAlignment>^ CalculateFaceAlignment()

Return Value

Maps each face of the solid to its alignment status.

Remarks

You can obtain the element which produced the non-aligned face by passing the face to Element.GetGeneratingElementIds().

See Also

ExtrusionAnalyzer Class


Create Method

[image]

Revit 2024 API
ExtrusionAnalyzer..::..Create Method
ExtrusionAnalyzer Class See Also Send Feedback
Creates an ExtrusionAnalyzer and computes and stores the solid's shadow.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static ExtrusionAnalyzer Create(
    Solid solidGeometry,
    Plane plane,
    XYZ direction
)
Visual Basic
Public Shared Function Create ( _
    solidGeometry As Solid, _
    plane As Plane, _
    direction As XYZ _
) As ExtrusionAnalyzer
Visual C++
public:
static ExtrusionAnalyzer^ Create(
    Solid^ solidGeometry,
    Plane^ plane,
    XYZ^ direction
)

Parameters

solidGeometry
Type: Autodesk.Revit.DB..::..Solid
The geometry to analyze.
plane
Type: Autodesk.Revit.DB..::..Plane
The plane to use for the base plane for the extrusion.
direction
Type: Autodesk.Revit.DB..::..XYZ
The direction to use for the calculation for the extrusion. The direction must be transverse to the base plane.

Return Value

The newly created ExtrusionAnalyzer object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input direction must be transverse to the input plane.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | A failure occurred in creating the ExtrusionAnalyzer or computing the solid's shadow.

See Also

ExtrusionAnalyzer Class


Dispose Method

[image]

Revit 2024 API
ExtrusionAnalyzer..::..Dispose Method
ExtrusionAnalyzer Class See Also Send Feedback
Releases all resources used by the ExtrusionAnalyzer

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ExtrusionAnalyzer Class


GetExtrusionBase Method

[image]

Revit 2024 API
ExtrusionAnalyzer..::..GetExtrusionBase Method
ExtrusionAnalyzer Class See Also Send Feedback
Obtains the face that represents the base contour of the extrusion analysis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public Face GetExtrusionBase()
Visual Basic
Public Function GetExtrusionBase As Face
Visual C++
public:
Face^ GetExtrusionBase()

Return Value

The face that represents the base contour.

See Also

ExtrusionAnalyzer Class


ExtrusionAnalyzer Properties

[image] [image]

Revit 2024 API
ExtrusionAnalyzer Properties
ExtrusionAnalyzer Class See Also Send Feedback

The ExtrusionAnalyzer type exposes the following members.

Properties

 | Name | Description
Public property | EndParameter | The end parameter (distance along the extrusion direction from the input plane) calculated by the extrusion analysis.
Public property | ExtrusionDirection | The direction of extrusion specified for the extrusion analysis.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | StartParameter | The start parameter (distance along the extrusion direction from the input plane) calculated by the extrusion analysis.

See Also

ExtrusionAnalyzer Class


EndParameter Property

[image]

Revit 2024 API
ExtrusionAnalyzer..::..EndParameter Property
ExtrusionAnalyzer Class See Also Send Feedback
The end parameter (distance along the extrusion direction from the input plane) calculated by the extrusion analysis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public double EndParameter { get; }
Visual Basic
Public ReadOnly Property EndParameter As Double
    Get
Visual C++
public:
property double EndParameter {
    double get ();
}

See Also

ExtrusionAnalyzer Class


ExtrusionDirection Property

[image]

Revit 2024 API
ExtrusionAnalyzer..::..ExtrusionDirection Property
ExtrusionAnalyzer Class See Also Send Feedback
The direction of extrusion specified for the extrusion analysis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public XYZ ExtrusionDirection { get; }
Visual Basic
Public ReadOnly Property ExtrusionDirection As XYZ
    Get
Visual C++
public:
property XYZ^ ExtrusionDirection {
    XYZ^ get ();
}

See Also

ExtrusionAnalyzer Class


StartParameter Property

[image]

Revit 2024 API
ExtrusionAnalyzer..::..StartParameter Property
ExtrusionAnalyzer Class See Also Send Feedback
The start parameter (distance along the extrusion direction from the input plane) calculated by the extrusion analysis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public double StartParameter { get; }
Visual Basic
Public ReadOnly Property StartParameter As Double
    Get
Visual C++
public:
property double StartParameter {
    double get ();
}

See Also

ExtrusionAnalyzer Class


ExtrusionAnalyzerFaceAlignment Enumeration

[image]

Revit 2024 API
ExtrusionAnalyzerFaceAlignment Enumeration
See Also Send Feedback
Indicates whether a face of the solid analyzed by ExtrusionAnalyzer is fully aligned, partially aligned, or unaligned with faces of the extrusion.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public enum ExtrusionAnalyzerFaceAlignment
Visual Basic
Public Enumeration ExtrusionAnalyzerFaceAlignment
Visual C++
public enum class ExtrusionAnalyzerFaceAlignment

Members

Member name | Description
FullyAligned | The face is fully aligned with faces of the extrusion.
PartiallyAligned | The face is only partially aligned with faces of the extrusion.
Unaligned | The face is not aligned with any faces of the extrusion.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


ExtrusionRoof Class

[image]

Revit 2024 API
ExtrusionRoof Class
Members See Also Send Feedback
Represents some kinds of Extrusion Roofs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class ExtrusionRoof : RoofBase
Visual Basic
Public Class ExtrusionRoof _
    Inherits RoofBase
Visual C++
public ref class ExtrusionRoof : public RoofBase

Remarks

The ExtrusionRoof object represents some kinds of extruded roofs in Revit.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB..::..RoofBase
Autodesk.Revit.DB..::..ExtrusionRoof

See Also

ExtrusionRoof Members


ExtrusionRoof Members

[image] [image]

Revit 2024 API
ExtrusionRoof Members
ExtrusionRoof Class Methods Properties See Also Send Feedback

The ExtrusionRoof type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetProfile | Retrieve the Profile of ExtrusionRoof.
Public method | GetSlabShapeEditor | Gets a SlabShapeEditor that can used to add or modify points of this RoofBase. (Inherited from RoofBase.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurtainGrids | Retrieve all the CurtainGrid objects of a curtain Roof.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EaveCuts | Retrieve or set the EaveCutterType. (Inherited from RoofBase.)
Public property | FasciaDepth | Retrieve or set the FasciaDepth. (Inherited from RoofBase.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RoofType | Retrieve or set the Type. (Inherited from RoofBase.)
Public property | SlabShapeEditor | Obsolete. Get the SlabShapeEditor used for slab shape editing. (Inherited from RoofBase.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ExtrusionRoof Class


ExtrusionRoof Methods

[image] [image]

Revit 2024 API
ExtrusionRoof Methods
ExtrusionRoof Class See Also Send Feedback

The ExtrusionRoof type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetProfile | Retrieve the Profile of ExtrusionRoof.
Public method | GetSlabShapeEditor | Gets a SlabShapeEditor that can used to add or modify points of this RoofBase. (Inherited from RoofBase.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ExtrusionRoof Class


GetProfile Method

[image]

Revit 2024 API
ExtrusionRoof..::..GetProfile Method
ExtrusionRoof Class See Also Send Feedback
Retrieve the Profile of ExtrusionRoof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ModelCurveArray GetProfile()
Visual Basic
Public Function GetProfile As ModelCurveArray
Visual C++
public:
ModelCurveArray^ GetProfile()

See Also

ExtrusionRoof Class


ExtrusionRoof Properties

[image] [image]

Revit 2024 API
ExtrusionRoof Properties
ExtrusionRoof Class See Also Send Feedback

The ExtrusionRoof type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurtainGrids | Retrieve all the CurtainGrid objects of a curtain Roof.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EaveCuts | Retrieve or set the EaveCutterType. (Inherited from RoofBase.)
Public property | FasciaDepth | Retrieve or set the FasciaDepth. (Inherited from RoofBase.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RoofType | Retrieve or set the Type. (Inherited from RoofBase.)
Public property | SlabShapeEditor | Obsolete. Get the SlabShapeEditor used for slab shape editing. (Inherited from RoofBase.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ExtrusionRoof Class


CurtainGrids Property

[image]

Revit 2024 API
ExtrusionRoof..::..CurtainGrids Property
ExtrusionRoof Class See Also Send Feedback
Retrieve all the CurtainGrid objects of a curtain Roof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CurtainGridSet CurtainGrids { get; }
Visual Basic
Public ReadOnly Property CurtainGrids As CurtainGridSet
    Get
Visual C++
public:
property CurtainGridSet^ CurtainGrids {
    CurtainGridSet^ get ();
}

Remarks

Only when the object is a CurtainRoof, this property makes sense.

See Also

ExtrusionRoof Class


FabricationAncillaryUsage Class

[image]

Revit 2024 API
FabricationAncillaryUsage Class
Members See Also Send Feedback
Structure that holds information about the usage of a fabrication ancillary

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update

Syntax

C#
public class FabricationAncillaryUsage : IDisposable
Visual Basic
Public Class FabricationAncillaryUsage _
    Implements IDisposable
Visual C++
public ref class FabricationAncillaryUsage : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FabricationAncillaryUsage

See Also

FabricationAncillaryUsage Members


FabricationAncillaryUsage Members

[image] [image]

Revit 2024 API
FabricationAncillaryUsage Members
FabricationAncillaryUsage Class Methods Properties See Also Send Feedback

The FabricationAncillaryUsage type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FabricationAncillaryUsage
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AncillaryDepth | Depth of required ancillary if it isn't round.
Public property | AncillaryId | Fabrication ancillary database identifier.
Public property | AncillaryWidthOrDiameter | Width or diameter of required ancillary.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Length | Length of required ancillaries.
Public property | ProductCode | A unique string code that idnenifies the ancillary in the fabriction database in order to purchase it.
Public property | Quantity | Quantity of required ancillaries.
Public property | Type | Fabrication ancillary type.
Public property | UsageType | Fabrication ancillary usage type.

See Also

FabricationAncillaryUsage Class


FabricationAncillaryUsage Methods

[image] [image]

Revit 2024 API
FabricationAncillaryUsage Methods
FabricationAncillaryUsage Class See Also Send Feedback

The FabricationAncillaryUsage type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FabricationAncillaryUsage Class


Dispose Method

[image]

Revit 2024 API
FabricationAncillaryUsage..::..Dispose Method
FabricationAncillaryUsage Class See Also Send Feedback
Releases all resources used by the FabricationAncillaryUsage

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FabricationAncillaryUsage Class


FabricationAncillaryUsage Properties

[image] [image]

Revit 2024 API
FabricationAncillaryUsage Properties
FabricationAncillaryUsage Class See Also Send Feedback

The FabricationAncillaryUsage type exposes the following members.

Properties

 | Name | Description
Public property | AncillaryDepth | Depth of required ancillary if it isn't round.
Public property | AncillaryId | Fabrication ancillary database identifier.
Public property | AncillaryWidthOrDiameter | Width or diameter of required ancillary.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Length | Length of required ancillaries.
Public property | ProductCode | A unique string code that idnenifies the ancillary in the fabriction database in order to purchase it.
Public property | Quantity | Quantity of required ancillaries.
Public property | Type | Fabrication ancillary type.
Public property | UsageType | Fabrication ancillary usage type.

See Also

FabricationAncillaryUsage Class


AncillaryDepth Property

[image]

Revit 2024 API
FabricationAncillaryUsage..::..AncillaryDepth Property
FabricationAncillaryUsage Class See Also Send Feedback
Depth of required ancillary if it isn't round.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update

Syntax

C#
public double AncillaryDepth { get; }
Visual Basic
Public ReadOnly Property AncillaryDepth As Double
    Get
Visual C++
public:
property double AncillaryDepth {
    double get ();
}

See Also

FabricationAncillaryUsage Class


AncillaryId Property

[image]

Revit 2024 API
FabricationAncillaryUsage..::..AncillaryId Property
FabricationAncillaryUsage Class See Also Send Feedback
Fabrication ancillary database identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update

Syntax

C#
public int AncillaryId { get; }
Visual Basic
Public ReadOnly Property AncillaryId As Integer
    Get
Visual C++
public:
property int AncillaryId {
    int get ();
}

See Also

FabricationAncillaryUsage Class


IsValidObject Property

[image]

Revit 2024 API
FabricationAncillaryUsage..::..IsValidObject Property
FabricationAncillaryUsage Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

FabricationAncillaryUsage Class


Length Property

[image]

Revit 2024 API
FabricationAncillaryUsage..::..Length Property
FabricationAncillaryUsage Class See Also Send Feedback
Length of required ancillaries.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update

Syntax

C#
public double Length { get; }
Visual Basic
Public ReadOnly Property Length As Double
    Get
Visual C++
public:
property double Length {
    double get ();
}

See Also

FabricationAncillaryUsage Class


ProductCode Property

[image]

Revit 2024 API
FabricationAncillaryUsage..::..ProductCode Property
FabricationAncillaryUsage Class See Also Send Feedback
A unique string code that idnenifies the ancillary in the fabriction database in order to purchase it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update

Syntax

C#
public string ProductCode { get; }
Visual Basic
Public ReadOnly Property ProductCode As String
    Get
Visual C++
public:
property String^ ProductCode {
    String^ get ();
}

See Also

FabricationAncillaryUsage Class


Quantity Property

[image]

Revit 2024 API
FabricationAncillaryUsage..::..Quantity Property
FabricationAncillaryUsage Class See Also Send Feedback
Quantity of required ancillaries.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update

Syntax

C#
public double Quantity { get; }
Visual Basic
Public ReadOnly Property Quantity As Double
    Get
Visual C++
public:
property double Quantity {
    double get ();
}

See Also

FabricationAncillaryUsage Class


Type Property

[image]

Revit 2024 API
FabricationAncillaryUsage..::..Type Property
FabricationAncillaryUsage Class See Also Send Feedback
Fabrication ancillary type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update

Syntax

C#
public FabricationAncillaryType Type { get; }
Visual Basic
Public ReadOnly Property Type As FabricationAncillaryType
    Get
Visual C++
public:
property FabricationAncillaryType Type {
    FabricationAncillaryType get ();
}

See Also

FabricationAncillaryUsage Class


UsageType Property

[image]

Revit 2024 API
FabricationAncillaryUsage..::..UsageType Property
FabricationAncillaryUsage Class See Also Send Feedback
Fabrication ancillary usage type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update

Syntax

C#
public FabricationAncillaryUsageType UsageType { get; }
Visual Basic
Public ReadOnly Property UsageType As FabricationAncillaryUsageType
    Get
Visual C++
public:
property FabricationAncillaryUsageType UsageType {
    FabricationAncillaryUsageType get ();
}

See Also

FabricationAncillaryUsage Class


FabricationConfiguration Members

[image] [image]

Revit 2024 API
FabricationConfiguration Members
FabricationConfiguration Class Methods Properties See Also Send Feedback

The FabricationConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | AncillaryExists | Checks to see if the specified ancillary exists.
Public method | AreItemFilesLoaded | Checks if the fabrication item files have been loaded.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanBeSwapped | Checks if the fabrication configuration can be swapped.
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanUnloadItemFiles | Checks if the fabrication item files are already in use and should not be unloaded.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | CustomDataExists | Checks to see if the specified custom data exists.
Public method | DamperExists | Checks to see if the specified damper exists.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetAllDampers | Gets all damper identifiers in the fabrication configuration.
Public method | GetAllFabricationConnectorDefinitions | Gets fabrication connector identifiers from the fabrication configuration, filtered by shape and domain.
Public method | GetAllInsulationSpecifications | Gets all insulation specification identifiers in the fabrication configuration.
Public method | GetAllLoadedItemFiles | Get list of all loaded fabrication item files.
Public method | GetAllLoadedServices | Returns all the loaded fabrication services.
Public method | GetAllMaterials | Gets all material identifiers in the fabrication configuration.
Public method | GetAllPartCustomData | Gets all possible fabrication part custom data identifiers.
Public method | GetAllPartStatuses | Gets all possible fabrication part status identifiers.
Public method | GetAllServices | Returns all fabrication services in the fabrication configuration.
Public method | GetAllSpecifications | Gets all specification identifiers in the fabrication configuration.
Public method | GetAllUsedItemFiles | Returns all the used fabrication item files. A fabrication item file is used if any fabrication parts in the model were created from it.
Public method | GetAllUsedServices | Returns all the used fabrication services. A service is used if any fabrication part in the service is created by user.
Public method | GetAncillaries | Gets fabrication ancillaries of the specified type.
Public method | GetAncillaryGroup | Gets the fabrication ancillary group of the specified fabrication ancillary identifier.
Public method | GetAncillaryGroupName | Gets the fabrication ancillary group and name for the specified fabrication ancillary identifier.
Public method | GetAncillaryName | Gets the fabrication ancillary name for the specified fabrication ancillary identifier.
Public method | GetDamperName | Gets the damper name from its identifier.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
 | GetFabricationConfiguration | Gets the fabrication configuration element in the document.
Public method | GetFabricationConfigurationInfo | Gets the information about the fabrication configuration of the project.
Public method | GetFabricationConnectorDomain | Gets the fabrication connector domain from its identifier.
Public method | GetFabricationConnectorGroup | Gets the fabrication connector group from its identifier.
Public method | GetFabricationConnectorName | Gets the fabrication connector name from its identifier.
Public method | GetFabricationConnectorShape | Gets the fabrication connector shape from its identifier.
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInsulationSpecificationAbbreviation | Gets insulation specification abbreviation.
Public method | GetInsulationSpecificationGroup | Gets the insulation specification group from its identifier.
Public method | GetInsulationSpecificationName | Gets the insulation specification name from its identifier.
Public method | GetItemFolders | Gets a list of every fabrication item folder in the fabrication item folder structure.
Public method | GetMaterialAbbreviation | Gets the abreviation of the material or the insulation or the double wall material.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialByGUID | Gets the material identifier by its GUID.
Public method | GetMaterialGaugeByGUID | Gets the material gauge identifier by its GUID and material identifier.
Public method | GetMaterialGaugeGUID | Gets the material gauge GUID by its material/gauge identifiers.
Public method | GetMaterialGroup | Gets material group from its identifier.
Public method | GetMaterialGUID | Gets the material GUID by its identifier.
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialName | Gets material name from its identifier.
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPartCustomDataName | Gets the custom data name from its identifier.
Public method | GetPartCustomDataType | Gets the custom data type from its identifier. See FabricationCustomDataType enumerator.
Public method | GetPartStatusDescription | Gets the status description from its identifier.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetProfile | Return the profile of the loaded fabrication configuration. Return empty string for global profile.
Public method | GetService | Get the service based on the service identifier from the fabrication configuration in the current document.
Public method | GetServiceByGUID | Gets the service identifier by its GUID.
Public method | GetServiceGUID | Gets the service GUID by its identifier.
Public method | GetServiceTypeName | Gets the service type name.
Public method | GetSpecificationAbbreviation | Gets specification abbreviation.
Public method | GetSpecificationByGUID | Gets the specification identifier by its GUID.
Public method | GetSpecificationGroup | Gets the specification group from its identifier.
Public method | GetSpecificationGUID | Gets the specification GUID by its identifier.
Public method | GetSpecificationName | Gets the specification name from its identifier.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasValidConfiguration | Checks whether a valid fabrication configuration has been set for the project.
Public method | IsAncillaryKit | Gets whether the specified fabrication ancillary identifier is an ancillary kit or not.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LoadItemFiles | Loads the specified fabrication item files into the project.
Public method | LoadServices | Loads the specified fabrication services into the project.
Public method | LocateFabricationConnector | Gets the fabrication connector identifiers by group and name, filtered by shape and domain.
Public method | LocateInsulationSpecification | Gets the insulation specification by group and name.
Public method | LocateMaterial | Gets material by group and name.
Public method | LocateSpecification | Gets the specification identifier by group and name.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | ReloadConfiguration | Reloads the fabrication configuration from its source fabrication configuration.
Public method | SetConfiguration(FabricationConfigurationInfo) | Set the fabrication configuration with global profile.
Public method | SetConfiguration(FabricationConfigurationInfo, String) | Set the fabrication configuration with specific profile.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetServicesToLoad | Sets the services which are to be loaded or not next time reloadConfiguration is called. If a service is not included but is currently loaded then it will be unloaded then.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnloadItemFiles | Unload the specified fabrication item files from the project.
Public method | UnloadServices | Unload the specified fabrication services from the project.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FabricationConfiguration Class


FabricationConfiguration Methods

[image] [image]

Revit 2024 API
FabricationConfiguration Methods
FabricationConfiguration Class See Also Send Feedback

The FabricationConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | AncillaryExists | Checks to see if the specified ancillary exists.
Public method | AreItemFilesLoaded | Checks if the fabrication item files have been loaded.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanBeSwapped | Checks if the fabrication configuration can be swapped.
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanUnloadItemFiles | Checks if the fabrication item files are already in use and should not be unloaded.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | CustomDataExists | Checks to see if the specified custom data exists.
Public method | DamperExists | Checks to see if the specified damper exists.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetAllDampers | Gets all damper identifiers in the fabrication configuration.
Public method | GetAllFabricationConnectorDefinitions | Gets fabrication connector identifiers from the fabrication configuration, filtered by shape and domain.
Public method | GetAllInsulationSpecifications | Gets all insulation specification identifiers in the fabrication configuration.
Public method | GetAllLoadedItemFiles | Get list of all loaded fabrication item files.
Public method | GetAllLoadedServices | Returns all the loaded fabrication services.
Public method | GetAllMaterials | Gets all material identifiers in the fabrication configuration.
Public method | GetAllPartCustomData | Gets all possible fabrication part custom data identifiers.
Public method | GetAllPartStatuses | Gets all possible fabrication part status identifiers.
Public method | GetAllServices | Returns all fabrication services in the fabrication configuration.
Public method | GetAllSpecifications | Gets all specification identifiers in the fabrication configuration.
Public method | GetAllUsedItemFiles | Returns all the used fabrication item files. A fabrication item file is used if any fabrication parts in the model were created from it.
Public method | GetAllUsedServices | Returns all the used fabrication services. A service is used if any fabrication part in the service is created by user.
Public method | GetAncillaries | Gets fabrication ancillaries of the specified type.
Public method | GetAncillaryGroup | Gets the fabrication ancillary group of the specified fabrication ancillary identifier.
Public method | GetAncillaryGroupName | Gets the fabrication ancillary group and name for the specified fabrication ancillary identifier.
Public method | GetAncillaryName | Gets the fabrication ancillary name for the specified fabrication ancillary identifier.
Public method | GetDamperName | Gets the damper name from its identifier.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
 | GetFabricationConfiguration | Gets the fabrication configuration element in the document.
Public method | GetFabricationConfigurationInfo | Gets the information about the fabrication configuration of the project.
Public method | GetFabricationConnectorDomain | Gets the fabrication connector domain from its identifier.
Public method | GetFabricationConnectorGroup | Gets the fabrication connector group from its identifier.
Public method | GetFabricationConnectorName | Gets the fabrication connector name from its identifier.
Public method | GetFabricationConnectorShape | Gets the fabrication connector shape from its identifier.
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInsulationSpecificationAbbreviation | Gets insulation specification abbreviation.
Public method | GetInsulationSpecificationGroup | Gets the insulation specification group from its identifier.
Public method | GetInsulationSpecificationName | Gets the insulation specification name from its identifier.
Public method | GetItemFolders | Gets a list of every fabrication item folder in the fabrication item folder structure.
Public method | GetMaterialAbbreviation | Gets the abreviation of the material or the insulation or the double wall material.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialByGUID | Gets the material identifier by its GUID.
Public method | GetMaterialGaugeByGUID | Gets the material gauge identifier by its GUID and material identifier.
Public method | GetMaterialGaugeGUID | Gets the material gauge GUID by its material/gauge identifiers.
Public method | GetMaterialGroup | Gets material group from its identifier.
Public method | GetMaterialGUID | Gets the material GUID by its identifier.
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialName | Gets material name from its identifier.
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPartCustomDataName | Gets the custom data name from its identifier.
Public method | GetPartCustomDataType | Gets the custom data type from its identifier. See FabricationCustomDataType enumerator.
Public method | GetPartStatusDescription | Gets the status description from its identifier.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetProfile | Return the profile of the loaded fabrication configuration. Return empty string for global profile.
Public method | GetService | Get the service based on the service identifier from the fabrication configuration in the current document.
Public method | GetServiceByGUID | Gets the service identifier by its GUID.
Public method | GetServiceGUID | Gets the service GUID by its identifier.
Public method | GetServiceTypeName | Gets the service type name.
Public method | GetSpecificationAbbreviation | Gets specification abbreviation.
Public method | GetSpecificationByGUID | Gets the specification identifier by its GUID.
Public method | GetSpecificationGroup | Gets the specification group from its identifier.
Public method | GetSpecificationGUID | Gets the specification GUID by its identifier.
Public method | GetSpecificationName | Gets the specification name from its identifier.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasValidConfiguration | Checks whether a valid fabrication configuration has been set for the project.
Public method | IsAncillaryKit | Gets whether the specified fabrication ancillary identifier is an ancillary kit or not.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LoadItemFiles | Loads the specified fabrication item files into the project.
Public method | LoadServices | Loads the specified fabrication services into the project.
Public method | LocateFabricationConnector | Gets the fabrication connector identifiers by group and name, filtered by shape and domain.
Public method | LocateInsulationSpecification | Gets the insulation specification by group and name.
Public method | LocateMaterial | Gets material by group and name.
Public method | LocateSpecification | Gets the specification identifier by group and name.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | ReloadConfiguration | Reloads the fabrication configuration from its source fabrication configuration.
Public method | SetConfiguration(FabricationConfigurationInfo) | Set the fabrication configuration with global profile.
Public method | SetConfiguration(FabricationConfigurationInfo, String) | Set the fabrication configuration with specific profile.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetServicesToLoad | Sets the services which are to be loaded or not next time reloadConfiguration is called. If a service is not included but is currently loaded then it will be unloaded then.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnloadItemFiles | Unload the specified fabrication item files from the project.
Public method | UnloadServices | Unload the specified fabrication services from the project.

See Also

FabricationConfiguration Class


AncillaryExists Method

[image]

Revit 2024 API
FabricationConfiguration..::..AncillaryExists Method
FabricationConfiguration Class See Also Send Feedback
Checks to see if the specified ancillary exists.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public bool AncillaryExists(
    int ancillaryId
)
Visual Basic
Public Function AncillaryExists ( _
    ancillaryId As Integer _
) As Boolean
Visual C++
public:
bool AncillaryExists(
    int ancillaryId
)

Parameters

ancillaryId
Type: System..::..Int32
The ancillary identifier.

Return Value

Returns true if the ancillary exists.

See Also

FabricationConfiguration Class


AreItemFilesLoaded Method

[image]

Revit 2024 API
FabricationConfiguration..::..AreItemFilesLoaded Method
FabricationConfiguration Class See Also Send Feedback
Checks if the fabrication item files have been loaded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public bool AreItemFilesLoaded(
    IList<FabricationItemFile> itemFiles
)
Visual Basic
Public Function AreItemFilesLoaded ( _
    itemFiles As IList(Of FabricationItemFile) _
) As Boolean
Visual C++
public:
bool AreItemFilesLoaded(
    IList<FabricationItemFile^>^ itemFiles
)

Parameters

itemFiles
Type: System.Collections.Generic..::..IList<(Of <(<' FabricationItemFile >)>)>
The fabrication item files.

Return Value

Returns true if the fabrication item files have been loaded, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FabricationConfiguration Class


CanBeSwapped Method

[image]

Revit 2024 API
FabricationConfiguration..::..CanBeSwapped Method
FabricationConfiguration Class See Also Send Feedback
Checks if the fabrication configuration can be swapped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool CanBeSwapped()
Visual Basic
Public Function CanBeSwapped As Boolean
Visual C++
public:
bool CanBeSwapped()

Return Value

True if the fabrication configuration can be swapped, false otherwise.

Remarks

Swapping configuration is not permitted if the existing configuration has already been used to create fabrication part elements in the document.

See Also

FabricationConfiguration Class


CustomDataExists Method

[image]

Revit 2024 API
FabricationConfiguration..::..CustomDataExists Method
FabricationConfiguration Class See Also Send Feedback
Checks to see if the specified custom data exists.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public bool CustomDataExists(
    int customDataId
)
Visual Basic
Public Function CustomDataExists ( _
    customDataId As Integer _
) As Boolean
Visual C++
public:
bool CustomDataExists(
    int customDataId
)

Parameters

customDataId
Type: System..::..Int32
The custom data identifier.

Return Value

Returns true if the custom data exists.

See Also

FabricationConfiguration Class


DamperExists Method

[image]

Revit 2024 API
FabricationConfiguration..::..DamperExists Method
FabricationConfiguration Class See Also Send Feedback
Checks to see if the specified damper exists.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public bool DamperExists(
    int damperId
)
Visual Basic
Public Function DamperExists ( _
    damperId As Integer _
) As Boolean
Visual C++
public:
bool DamperExists(
    int damperId
)

Parameters

damperId
Type: System..::..Int32
The damper identifier to check.

Return Value

Returns true if the damper exists.

See Also

FabricationConfiguration Class


GetAllDampers Method

[image]

Revit 2024 API
FabricationConfiguration..::..GetAllDampers Method
FabricationConfiguration Class See Also Send Feedback
Gets all damper identifiers in the fabrication configuration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update

Syntax

C#
public IList<int> GetAllDampers()
Visual Basic
Public Function GetAllDampers As IList(Of Integer)
Visual C++
public:
IList<int>^ GetAllDampers()

Return Value

An array of specification identifiers.

See Also

FabricationConfiguration Class


GetAllLoadedItemFiles Method

[image]

Revit 2024 API
FabricationConfiguration..::..GetAllLoadedItemFiles Method
FabricationConfiguration Class See Also Send Feedback
Get list of all loaded fabrication item files.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public IList<FabricationItemFile> GetAllLoadedItemFiles()
Visual Basic
Public Function GetAllLoadedItemFiles As IList(Of FabricationItemFile)
Visual C++
public:
IList<FabricationItemFile^>^ GetAllLoadedItemFiles()

Return Value

Returns an array of the loaded fabrication item files.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The fabrication configuration is not set yet.

See Also

FabricationConfiguration Class


GetAllLoadedServices Method

[image]

Revit 2024 API
FabricationConfiguration..::..GetAllLoadedServices Method
FabricationConfiguration Class See Also Send Feedback
Returns all the loaded fabrication services.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public IList<FabricationService> GetAllLoadedServices()
Visual Basic
Public Function GetAllLoadedServices As IList(Of FabricationService)
Visual C++
public:
IList<FabricationService^>^ GetAllLoadedServices()

Return Value

All the loaded fabrication services.

See Also

FabricationConfiguration Class


GetAllPartCustomData Method

[image]

Revit 2024 API
FabricationConfiguration..::..GetAllPartCustomData Method
FabricationConfiguration Class See Also Send Feedback
Gets all possible fabrication part custom data identifiers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update

Syntax

C#
public IList<int> GetAllPartCustomData()
Visual Basic
Public Function GetAllPartCustomData As IList(Of Integer)
Visual C++
public:
IList<int>^ GetAllPartCustomData()

Return Value

An array of custom data identifiers.

See Also

FabricationConfiguration Class


GetAllPartStatuses Method

[image]

Revit 2024 API
FabricationConfiguration..::..GetAllPartStatuses Method
FabricationConfiguration Class See Also Send Feedback
Gets all possible fabrication part status identifiers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update

Syntax

C#
public IList<int> GetAllPartStatuses()
Visual Basic
Public Function GetAllPartStatuses As IList(Of Integer)
Visual C++
public:
IList<int>^ GetAllPartStatuses()

Return Value

An array of status identifiers.

See Also

FabricationConfiguration Class


GetAllSpecifications Method

[image]

Revit 2024 API
FabricationConfiguration..::..GetAllSpecifications Method
FabricationConfiguration Class See Also Send Feedback
Gets all specification identifiers in the fabrication configuration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public IList<int> GetAllSpecifications(
    FabricationPart part
)
Visual Basic
Public Function GetAllSpecifications ( _
    part As FabricationPart _
) As IList(Of Integer)
Visual C++
public:
IList<int>^ GetAllSpecifications(
    FabricationPart^ part
)

Parameters

part
Type: Autodesk.Revit.DB..::..FabricationPart
The fabrication part.

Return Value

An array of specification identifiers.

Remarks

If a part is passed, only returns specifications which are valid for the part, otherwise returns all specifications.

See Also

FabricationConfiguration Class


GetAllUsedItemFiles Method

[image]

Revit 2024 API
FabricationConfiguration..::..GetAllUsedItemFiles Method
FabricationConfiguration Class See Also Send Feedback
Returns all the used fabrication item files. A fabrication item file is used if any fabrication parts in the model were created from it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public IList<FabricationItemFile> GetAllUsedItemFiles()
Visual Basic
Public Function GetAllUsedItemFiles As IList(Of FabricationItemFile)
Visual C++
public:
IList<FabricationItemFile^>^ GetAllUsedItemFiles()

Return Value

All the used fabrication item files.

See Also

FabricationConfiguration Class


GetAllUsedServices Method

[image]

Revit 2024 API
FabricationConfiguration..::..GetAllUsedServices Method
FabricationConfiguration Class See Also Send Feedback
Returns all the used fabrication services. A service is used if any fabrication part in the service is created by user.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public IList<FabricationService> GetAllUsedServices()
Visual Basic
Public Function GetAllUsedServices As IList(Of FabricationService)
Visual C++
public:
IList<FabricationService^>^ GetAllUsedServices()

Return Value

All the used fabrication services.

See Also

FabricationConfiguration Class


GetAncillaries Method

[image]

Revit 2024 API
FabricationConfiguration..::..GetAncillaries Method
FabricationConfiguration Class See Also Send Feedback
Gets fabrication ancillaries of the specified type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update

Syntax

C#
public IList<int> GetAncillaries(
    FabricationAncillaryType type,
    bool includeKits,
    bool filterKits
)
Visual Basic
Public Function GetAncillaries ( _
    type As FabricationAncillaryType, _
    includeKits As Boolean, _
    filterKits As Boolean _
) As IList(Of Integer)
Visual C++
public:
IList<int>^ GetAncillaries(
    FabricationAncillaryType type,
    bool includeKits,
    bool filterKits
)

Parameters

type
Type: Autodesk.Revit.DB.Fabrication..::..FabricationAncillaryType
The type of ancillaries to get.
includeKits
Type: System..::..Boolean
Whether or not to include ancillary kits as well.
filterKits
Type: System..::..Boolean
Whether kits should be filtered to only those that contain the specified ancillary type.

Return Value

An array of ancillary identifiers.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

FabricationConfiguration Class


GetAncillaryGroup Method

[image]

Revit 2024 API
FabricationConfiguration..::..GetAncillaryGroup Method
FabricationConfiguration Class See Also Send Feedback
Gets the fabrication ancillary group of the specified fabrication ancillary identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update

Syntax

C#
public string GetAncillaryGroup(
    int ancillaryId
)
Visual Basic
Public Function GetAncillaryGroup ( _
    ancillaryId As Integer _
) As String
Visual C++
public:
String^ GetAncillaryGroup(
    int ancillaryId
)

Parameters

ancillaryId
Type: System..::..Int32
The fabrication ancillary database identifier of the ancillary.

Return Value

The group name of the ancillary.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ancillary does not exist.

See Also

FabricationConfiguration Class


GetAncillaryGroupName Method

[image]

Revit 2024 API
FabricationConfiguration..::..GetAncillaryGroupName Method
FabricationConfiguration Class See Also Send Feedback
Gets the fabrication ancillary group and name for the specified fabrication ancillary identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update

Syntax

C#
public string GetAncillaryGroupName(
    int ancillaryId
)
Visual Basic
Public Function GetAncillaryGroupName ( _
    ancillaryId As Integer _
) As String
Visual C++
public:
String^ GetAncillaryGroupName(
    int ancillaryId
)

Parameters

ancillaryId
Type: System..::..Int32
The fabrication ancillary database identifier of the ancillary.

Return Value

The group and name of the ancillary.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ancillary does not exist.

See Also

FabricationConfiguration Class


GetFabricationConfiguration Method

[image]

Revit 2024 API
FabricationConfiguration..::..GetFabricationConfiguration Method
FabricationConfiguration Class See Also Send Feedback
Gets the fabrication configuration element in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public static FabricationConfiguration GetFabricationConfiguration(
    Document document
)
Visual Basic
Public Shared Function GetFabricationConfiguration ( _
    document As Document _
) As FabricationConfiguration
Visual C++
public:
static FabricationConfiguration^ GetFabricationConfiguration(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.

Return Value

The fabrication configuration element in the document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FabricationConfiguration Class


GetFabricationConfigurationInfo Method

[image]

Revit 2024 API
FabricationConfiguration..::..GetFabricationConfigurationInfo Method
FabricationConfiguration Class See Also Send Feedback
Gets the information about the fabrication configuration of the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public FabricationConfigurationInfo GetFabricationConfigurationInfo()
Visual Basic
Public Function GetFabricationConfigurationInfo As FabricationConfigurationInfo
Visual C++
public:
FabricationConfigurationInfo^ GetFabricationConfigurationInfo()

Return Value

The information about the fabrication configuration of the project.

See Also

FabricationConfiguration Class


GetFabricationConnectorGroup Method

[image]

Revit 2024 API
FabricationConfiguration..::..GetFabricationConnectorGroup Method
FabricationConfiguration Class See Also Send Feedback
Gets the fabrication connector group from its identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public string GetFabricationConnectorGroup(
    int fabricationConnectorId
)
Visual Basic
Public Function GetFabricationConnectorGroup ( _
    fabricationConnectorId As Integer _
) As String
Visual C++
public:
String^ GetFabricationConnectorGroup(
    int fabricationConnectorId
)

Parameters

fabricationConnectorId
Type: System..::..Int32
The fabrication connector identifier.

Return Value

The fabrication connector's group.

See Also

FabricationConfiguration Class


GetFabricationConnectorShape Method

[image]

Revit 2024 API
FabricationConfiguration..::..GetFabricationConnectorShape Method
FabricationConfiguration Class See Also Send Feedback
Gets the fabrication connector shape from its identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public ConnectorProfileType GetFabricationConnectorShape(
    int fabricationConnectorId
)
Visual Basic
Public Function GetFabricationConnectorShape ( _
    fabricationConnectorId As Integer _
) As ConnectorProfileType
Visual C++
public:
ConnectorProfileType GetFabricationConnectorShape(
    int fabricationConnectorId
)

Parameters

fabricationConnectorId
Type: System..::..Int32
The fabrication connector identifier.

Return Value

The fabrication connector's shape.

See Also

FabricationConfiguration Class


GetInsulationSpecificationAbbreviation Method

[image]

Revit 2024 API
FabricationConfiguration..::..GetInsulationSpecificationAbbreviation Method
FabricationConfiguration Class See Also Send Feedback
Gets insulation specification abbreviation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public string GetInsulationSpecificationAbbreviation(
    int insulationSpecificationId
)
Visual Basic
Public Function GetInsulationSpecificationAbbreviation ( _
    insulationSpecificationId As Integer _
) As String
Visual C++
public:
String^ GetInsulationSpecificationAbbreviation(
    int insulationSpecificationId
)

Parameters

insulationSpecificationId
Type: System..::..Int32
The insulation specification identifier.

See Also

FabricationConfiguration Class


GetInsulationSpecificationName Method

[image]

Revit 2024 API
FabricationConfiguration..::..GetInsulationSpecificationName Method
FabricationConfiguration Class See Also Send Feedback
Gets the insulation specification name from its identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public string GetInsulationSpecificationName(
    int specId
)
Visual Basic
Public Function GetInsulationSpecificationName ( _
    specId As Integer _
) As String
Visual C++
public:
String^ GetInsulationSpecificationName(
    int specId
)

Parameters

specId
Type: System..::..Int32
The insulation specification identifier.

Return Value

The insulation specification name.

See Also

FabricationConfiguration Class


GetMaterialByGUID Method

[image]

Revit 2024 API
FabricationConfiguration..::..GetMaterialByGUID Method
FabricationConfiguration Class See Also Send Feedback
Gets the material identifier by its GUID.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public int GetMaterialByGUID(
    Guid materialGUID
)
Visual Basic
Public Function GetMaterialByGUID ( _
    materialGUID As Guid _
) As Integer
Visual C++
public:
int GetMaterialByGUID(
    Guid materialGUID
)

Parameters

materialGUID
Type: System..::..Guid
The material GUID.

Return Value

The material identifier. Returns 0 if not found.

See Also

FabricationConfiguration Class


GetMaterialGaugeByGUID Method

[image]

Revit 2024 API
FabricationConfiguration..::..GetMaterialGaugeByGUID Method
FabricationConfiguration Class See Also Send Feedback
Gets the material gauge identifier by its GUID and material identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public int GetMaterialGaugeByGUID(
    Guid gaugeGUID,
    int materialId
)
Visual Basic
Public Function GetMaterialGaugeByGUID ( _
    gaugeGUID As Guid, _
    materialId As Integer _
) As Integer
Visual C++
public:
int GetMaterialGaugeByGUID(
    Guid gaugeGUID,
    int materialId
)

Parameters

gaugeGUID
Type: System..::..Guid
The material gauge GUID.
materialId
Type: System..::..Int32
The material identifier. The same material gauge GUID could have different material gauge identifiers for different materials.

Return Value

The gauge identifier. Returns 0 if not found.

See Also

FabricationConfiguration Class


GetMaterialGaugeGUID Method

[image]

Revit 2024 API
FabricationConfiguration..::..GetMaterialGaugeGUID Method
FabricationConfiguration Class See Also Send Feedback
Gets the material gauge GUID by its material/gauge identifiers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public Guid GetMaterialGaugeGUID(
    int materialId,
    int gaugeId
)
Visual Basic
Public Function GetMaterialGaugeGUID ( _
    materialId As Integer, _
    gaugeId As Integer _
) As Guid
Visual C++
public:
Guid GetMaterialGaugeGUID(
    int materialId,
    int gaugeId
)

Parameters

materialId
Type: System..::..Int32
The material identifier. The same material gauge GUID could have different material gauge identifiers for different materials.
gaugeId
Type: System..::..Int32
The material gauge identifier.

Return Value

The material gauge GUID. Returns empty GUID if not found.

See Also

FabricationConfiguration Class


GetMaterialGroup Method

[image]

Revit 2024 API
FabricationConfiguration..::..GetMaterialGroup Method
FabricationConfiguration Class See Also Send Feedback
Gets material group from its identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public string GetMaterialGroup(
    int materialId
)
Visual Basic
Public Function GetMaterialGroup ( _
    materialId As Integer _
) As String
Visual C++
public:
String^ GetMaterialGroup(
    int materialId
)

Parameters

materialId
Type: System..::..Int32
The material identifier.

Return Value

The material group.

See Also

FabricationConfiguration Class


GetMaterialGUID Method

[image]

Revit 2024 API
FabricationConfiguration..::..GetMaterialGUID Method
FabricationConfiguration Class See Also Send Feedback
Gets the material GUID by its identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public Guid GetMaterialGUID(
    int materialId
)
Visual Basic
Public Function GetMaterialGUID ( _
    materialId As Integer _
) As Guid
Visual C++
public:
Guid GetMaterialGUID(
    int materialId
)

Parameters

materialId
Type: System..::..Int32
The material identifier.

Return Value

The material GUID. Returns empty GUID if not found.

See Also

FabricationConfiguration Class


GetMaterialName Method

[image]

Revit 2024 API
FabricationConfiguration..::..GetMaterialName Method
FabricationConfiguration Class See Also Send Feedback
Gets material name from its identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public string GetMaterialName(
    int materialId
)
Visual Basic
Public Function GetMaterialName ( _
    materialId As Integer _
) As String
Visual C++
public:
String^ GetMaterialName(
    int materialId
)

Parameters

materialId
Type: System..::..Int32
The material identifier.

Return Value

The material name without the group.

See Also

FabricationConfiguration Class


GetPartCustomDataName Method

[image]

Revit 2024 API
FabricationConfiguration..::..GetPartCustomDataName Method
FabricationConfiguration Class See Also Send Feedback
Gets the custom data name from its identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update

Syntax

C#
public string GetPartCustomDataName(
    int customDataId
)
Visual Basic
Public Function GetPartCustomDataName ( _
    customDataId As Integer _
) As String
Visual C++
public:
String^ GetPartCustomDataName(
    int customDataId
)

Parameters

customDataId
Type: System..::..Int32
The custom data identifier.

Return Value

The custom data name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The custom data does not exist.

See Also

FabricationConfiguration Class


GetPartCustomDataType Method

[image]

Revit 2024 API
FabricationConfiguration..::..GetPartCustomDataType Method
FabricationConfiguration Class See Also Send Feedback
Gets the custom data type from its identifier. See FabricationCustomDataType enumerator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update

Syntax

C#
public FabricationCustomDataType GetPartCustomDataType(
    int customDataId
)
Visual Basic
Public Function GetPartCustomDataType ( _
    customDataId As Integer _
) As FabricationCustomDataType
Visual C++
public:
FabricationCustomDataType GetPartCustomDataType(
    int customDataId
)

Parameters

customDataId
Type: System..::..Int32
The custom data identifier.

Return Value

The custom data type.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The custom data does not exist.

See Also

FabricationConfiguration Class


GetPartStatusDescription Method

[image]

Revit 2024 API
FabricationConfiguration..::..GetPartStatusDescription Method
FabricationConfiguration Class See Also Send Feedback
Gets the status description from its identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update

Syntax

C#
public string GetPartStatusDescription(
    int statusId
)
Visual Basic
Public Function GetPartStatusDescription ( _
    statusId As Integer _
) As String
Visual C++
public:
String^ GetPartStatusDescription(
    int statusId
)

Parameters

statusId
Type: System..::..Int32
The status identifier.

Return Value

The status description.

See Also

FabricationConfiguration Class


GetProfile Method

[image]

Revit 2024 API
FabricationConfiguration..::..GetProfile Method
FabricationConfiguration Class See Also Send Feedback
Return the profile of the loaded fabrication configuration. Return empty string for global profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public string GetProfile()
Visual Basic
Public Function GetProfile As String
Visual C++
public:
String^ GetProfile()

See Also

FabricationConfiguration Class


GetService Method

[image]

Revit 2024 API
FabricationConfiguration..::..GetService Method
FabricationConfiguration Class See Also Send Feedback
Get the service based on the service identifier from the fabrication configuration in the current document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public FabricationService GetService(
    int serviceId
)
Visual Basic
Public Function GetService ( _
    serviceId As Integer _
) As FabricationService
Visual C++
public:
FabricationService^ GetService(
    int serviceId
)

Parameters

serviceId
Type: System..::..Int32
The service identifier.

Return Value

The service based on the service identifier.

See Also

FabricationConfiguration Class


GetServiceByGUID Method

[image]

Revit 2024 API
FabricationConfiguration..::..GetServiceByGUID Method
FabricationConfiguration Class See Also Send Feedback
Gets the service identifier by its GUID.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public int GetServiceByGUID(
    Guid serviceGUID
)
Visual Basic
Public Function GetServiceByGUID ( _
    serviceGUID As Guid _
) As Integer
Visual C++
public:
int GetServiceByGUID(
    Guid serviceGUID
)

Parameters

serviceGUID
Type: System..::..Guid
The service GUID.

Return Value

The service identifier. Returns 0 if not found.

See Also

FabricationConfiguration Class


GetServiceGUID Method

[image]

Revit 2024 API
FabricationConfiguration..::..GetServiceGUID Method
FabricationConfiguration Class See Also Send Feedback
Gets the service GUID by its identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public Guid GetServiceGUID(
    int serviceId
)
Visual Basic
Public Function GetServiceGUID ( _
    serviceId As Integer _
) As Guid
Visual C++
public:
Guid GetServiceGUID(
    int serviceId
)

Parameters

serviceId
Type: System..::..Int32
The service identifier.

Return Value

The service GUID. Returns empty GUID if not found.

See Also

FabricationConfiguration Class


GetServiceTypeName Method

[image]

Revit 2024 API
FabricationConfiguration..::..GetServiceTypeName Method
FabricationConfiguration Class See Also Send Feedback
Gets the service type name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public string GetServiceTypeName(
    int serviceTypeId
)
Visual Basic
Public Function GetServiceTypeName ( _
    serviceTypeId As Integer _
) As String
Visual C++
public:
String^ GetServiceTypeName(
    int serviceTypeId
)

Parameters

serviceTypeId
Type: System..::..Int32
The service type identifier.

See Also

FabricationConfiguration Class


GetSpecificationAbbreviation Method

[image]

Revit 2024 API
FabricationConfiguration..::..GetSpecificationAbbreviation Method
FabricationConfiguration Class See Also Send Feedback
Gets specification abbreviation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public string GetSpecificationAbbreviation(
    int specificationId
)
Visual Basic
Public Function GetSpecificationAbbreviation ( _
    specificationId As Integer _
) As String
Visual C++
public:
String^ GetSpecificationAbbreviation(
    int specificationId
)

Parameters

specificationId
Type: System..::..Int32
The specification identifier.

See Also

FabricationConfiguration Class


GetSpecificationByGUID Method

[image]

Revit 2024 API
FabricationConfiguration..::..GetSpecificationByGUID Method
FabricationConfiguration Class See Also Send Feedback
Gets the specification identifier by its GUID.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public int GetSpecificationByGUID(
    Guid specificationGUID
)
Visual Basic
Public Function GetSpecificationByGUID ( _
    specificationGUID As Guid _
) As Integer
Visual C++
public:
int GetSpecificationByGUID(
    Guid specificationGUID
)

Parameters

specificationGUID
Type: System..::..Guid
The specification GUID.

Return Value

The specification identifier. Returns 0 if not found.

See Also

FabricationConfiguration Class


GetSpecificationGroup Method

[image]

Revit 2024 API
FabricationConfiguration..::..GetSpecificationGroup Method
FabricationConfiguration Class See Also Send Feedback
Gets the specification group from its identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public string GetSpecificationGroup(
    int specId
)
Visual Basic
Public Function GetSpecificationGroup ( _
    specId As Integer _
) As String
Visual C++
public:
String^ GetSpecificationGroup(
    int specId
)

Parameters

specId
Type: System..::..Int32
The specification identifier.

Return Value

The specification group.

See Also

FabricationConfiguration Class


GetSpecificationGUID Method

[image]

Revit 2024 API
FabricationConfiguration..::..GetSpecificationGUID Method
FabricationConfiguration Class See Also Send Feedback
Gets the specification GUID by its identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public Guid GetSpecificationGUID(
    int specificationId
)
Visual Basic
Public Function GetSpecificationGUID ( _
    specificationId As Integer _
) As Guid
Visual C++
public:
Guid GetSpecificationGUID(
    int specificationId
)

Parameters

specificationId
Type: System..::..Int32
The specification identifier.

Return Value

The specification GUID. Returns empty GUID if not found.

See Also

FabricationConfiguration Class


GetSpecificationName Method

[image]

Revit 2024 API
FabricationConfiguration..::..GetSpecificationName Method
FabricationConfiguration Class See Also Send Feedback
Gets the specification name from its identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public string GetSpecificationName(
    int specId
)
Visual Basic
Public Function GetSpecificationName ( _
    specId As Integer _
) As String
Visual C++
public:
String^ GetSpecificationName(
    int specId
)

Parameters

specId
Type: System..::..Int32
The specification identifier.

Return Value

The specification name;

See Also

FabricationConfiguration Class


IsAncillaryKit Method

[image]

Revit 2024 API
FabricationConfiguration..::..IsAncillaryKit Method
FabricationConfiguration Class See Also Send Feedback
Gets whether the specified fabrication ancillary identifier is an ancillary kit or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update

Syntax

C#
public bool IsAncillaryKit(
    int ancillaryId
)
Visual Basic
Public Function IsAncillaryKit ( _
    ancillaryId As Integer _
) As Boolean
Visual C++
public:
bool IsAncillaryKit(
    int ancillaryId
)

Parameters

ancillaryId
Type: System..::..Int32
The fabrication ancillary database identifier of the ancillary.

Return Value

Returns true if the ancillary is a kit.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ancillary does not exist.

See Also

FabricationConfiguration Class


LoadServices Method

[image]

Revit 2024 API
FabricationConfiguration..::..LoadServices Method
FabricationConfiguration Class See Also Send Feedback
Loads the specified fabrication services into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public IList<int> LoadServices(
    IList<int> serviceIds
)
Visual Basic
Public Function LoadServices ( _
    serviceIds As IList(Of Integer) _
) As IList(Of Integer)
Visual C++
public:
IList<int>^ LoadServices(
    IList<int>^ serviceIds
)

Parameters

serviceIds
Type: System.Collections.Generic..::..IList<(Of <(<'Int32>)>)>
The identifiers of the fabrication services to load.

Return Value

The identifiers of the fabrication services which failed to load.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The current fabrication configuration is not connected and updated to source configuration. Reload and try again. -or- this operation failed.

See Also

FabricationConfiguration Class


LocateFabricationConnector Method

[image]

Revit 2024 API
FabricationConfiguration..::..LocateFabricationConnector Method
FabricationConfiguration Class See Also Send Feedback
Gets the fabrication connector identifiers by group and name, filtered by shape and domain.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public int LocateFabricationConnector(
    string group,
    string name,
    ConnectorDomainType domain,
    ConnectorProfileType shape
)
Visual Basic
Public Function LocateFabricationConnector ( _
    group As String, _
    name As String, _
    domain As ConnectorDomainType, _
    shape As ConnectorProfileType _
) As Integer
Visual C++
public:
int LocateFabricationConnector(
    String^ group,
    String^ name,
    ConnectorDomainType domain,
    ConnectorProfileType shape
)

Parameters

group
Type: System..::..String
The fabrication connector group.
name
Type: System..::..String
The fabrication connector name.
domain
Type: Autodesk.Revit.DB..::..ConnectorDomainType
ConnectorDomainType to filter by. Pass ConnectorDomainType::Undefined to get all connector domains.
shape
Type: Autodesk.Revit.DB..::..ConnectorProfileType
ConnectorProfileType to filter by. Pass ConnectorProfileType::Invalid to get all shapes.

Return Value

Return the fabrication connector identifier. Returns -1 if not found.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

FabricationConfiguration Class


LocateInsulationSpecification Method

[image]

Revit 2024 API
FabricationConfiguration..::..LocateInsulationSpecification Method
FabricationConfiguration Class See Also Send Feedback
Gets the insulation specification by group and name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public int LocateInsulationSpecification(
    string group,
    string name
)
Visual Basic
Public Function LocateInsulationSpecification ( _
    group As String, _
    name As String _
) As Integer
Visual C++
public:
int LocateInsulationSpecification(
    String^ group,
    String^ name
)

Parameters

group
Type: System..::..String
The insulation specification group.
name
Type: System..::..String
The insulation specification name.

Return Value

The insulation specification identifier. Returns -1 if not found.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FabricationConfiguration Class


LocateSpecification Method

[image]

Revit 2024 API
FabricationConfiguration..::..LocateSpecification Method
FabricationConfiguration Class See Also Send Feedback
Gets the specification identifier by group and name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public int LocateSpecification(
    string group,
    string name
)
Visual Basic
Public Function LocateSpecification ( _
    group As String, _
    name As String _
) As Integer
Visual C++
public:
int LocateSpecification(
    String^ group,
    String^ name
)

Parameters

group
Type: System..::..String
The specification group.
name
Type: System..::..String
The specification name.

Return Value

The specification identifier. Returns -1 if not found.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FabricationConfiguration Class


ReloadConfiguration Method

[image]

Revit 2024 API
FabricationConfiguration..::..ReloadConfiguration Method
FabricationConfiguration Class See Also Send Feedback
Reloads the fabrication configuration from its source fabrication configuration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public ConfigurationReloadInfo ReloadConfiguration()
Visual Basic
Public Function ReloadConfiguration As ConfigurationReloadInfo
Visual C++
public:
ConfigurationReloadInfo^ ReloadConfiguration()

Return Value

The information about the reload of the fabrication configuration.

Remarks

The configuration must be reloaded from its source fabrication configuration before loading new fabrication services or additional parts.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The fabrication configuration is not set yet. -or- The source fabrication configuration could not be found. -or- this operation failed.

See Also

FabricationConfiguration Class


SetConfiguration Method

[image] [image]

Revit 2024 API
FabricationConfiguration..::..SetConfiguration Method
FabricationConfiguration Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetConfiguration(FabricationConfigurationInfo) | Set the fabrication configuration with global profile.
Public method | SetConfiguration(FabricationConfigurationInfo, String) | Set the fabrication configuration with specific profile.

See Also

FabricationConfiguration Class
FabricationConfiguration Members


SetConfiguration Method (FabricationConfigurationInfo)

[image]

Revit 2024 API
FabricationConfiguration..::..SetConfiguration Method (FabricationConfigurationInfo)
FabricationConfiguration Class See Also Send Feedback
Set the fabrication configuration with global profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public void SetConfiguration(
    FabricationConfigurationInfo fabricationConfigurationInfo
)
Visual Basic
Public Sub SetConfiguration ( _
    fabricationConfigurationInfo As FabricationConfigurationInfo _
)
Visual C++
public:
void SetConfiguration(
    FabricationConfigurationInfo^ fabricationConfigurationInfo
)

Parameters

fabricationConfigurationInfo
Type: Autodesk.Revit.DB..::..FabricationConfigurationInfo
The desired fabrication configuration.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The fabrication configuration cannot be swapped because the exiting fabrication configuration has already been used in the document. -or- Cannot set the configuration.

See Also

FabricationConfiguration Class
SetConfiguration Overload


SetConfiguration Method (FabricationConfigurationInfo, String)

[image]

Revit 2024 API
FabricationConfiguration..::..SetConfiguration Method (FabricationConfigurationInfo, String)
FabricationConfiguration Class See Also Send Feedback
Set the fabrication configuration with specific profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public void SetConfiguration(
    FabricationConfigurationInfo fabricationConfigurationInfo,
    string profile
)
Visual Basic
Public Sub SetConfiguration ( _
    fabricationConfigurationInfo As FabricationConfigurationInfo, _
    profile As String _
)
Visual C++
public:
void SetConfiguration(
    FabricationConfigurationInfo^ fabricationConfigurationInfo,
    String^ profile
)

Parameters

fabricationConfigurationInfo
Type: Autodesk.Revit.DB..::..FabricationConfigurationInfo
The desired fabrication configuration.
profile
Type: System..::..String
The desired profile of the fabrication configuration. Use empty string for the global profile.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The profile "profile" is invalid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The fabrication configuration cannot be swapped because the exiting fabrication configuration has already been used in the document. -or- Cannot set the configuration.

See Also

FabricationConfiguration Class
SetConfiguration Overload


SetServicesToLoad Method

[image]

Revit 2024 API
FabricationConfiguration..::..SetServicesToLoad Method
FabricationConfiguration Class See Also Send Feedback
Sets the services which are to be loaded or not next time reloadConfiguration is called. If a service is not included but is currently loaded then it will be unloaded then.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public bool SetServicesToLoad(
    IList<int> serviceIds
)
Visual Basic
Public Function SetServicesToLoad ( _
    serviceIds As IList(Of Integer) _
) As Boolean
Visual C++
public:
bool SetServicesToLoad(
    IList<int>^ serviceIds
)

Parameters

serviceIds
Type: System.Collections.Generic..::..IList<(Of <(<'Int32>)>)>

Return Value

Returns true if successful. May fail if any service currently loaded is not included and is in use so cannot be unloaded.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FabricationConfiguration Class


UnloadItemFiles Method

[image]

Revit 2024 API
FabricationConfiguration..::..UnloadItemFiles Method
FabricationConfiguration Class See Also Send Feedback
Unload the specified fabrication item files from the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public void UnloadItemFiles(
    IList<FabricationItemFile> itemFiles
)
Visual Basic
Public Sub UnloadItemFiles ( _
    itemFiles As IList(Of FabricationItemFile) _
)
Visual C++
public:
void UnloadItemFiles(
    IList<FabricationItemFile^>^ itemFiles
)

Parameters

itemFiles
Type: System.Collections.Generic..::..IList<(Of <(<' FabricationItemFile >)>)>
The fabrication item files to unload.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Fabrication item files can not be unloaded if they are currently in use. -or- Some fabrication item files have not been loaded.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The current fabrication configuration is not connected and updated to source configuration. Reload and try again.

See Also

FabricationConfiguration Class


UnloadServices Method

[image]

Revit 2024 API
FabricationConfiguration..::..UnloadServices Method
FabricationConfiguration Class See Also Send Feedback
Unload the specified fabrication services from the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public void UnloadServices(
    IList<int> serviceIds
)
Visual Basic
Public Sub UnloadServices ( _
    serviceIds As IList(Of Integer) _
)
Visual C++
public:
void UnloadServices(
    IList<int>^ serviceIds
)

Parameters

serviceIds
Type: System.Collections.Generic..::..IList<(Of <(<'Int32>)>)>
The identifiers of the fabrication services to unload.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Fabrication services can not be unloaded if they are in use currently. -or- Some services are not loaded yet.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The current fabrication configuration is not connected and updated to source configuration. Reload and try again.

See Also

FabricationConfiguration Class


FabricationConfiguration Properties

[image] [image]

Revit 2024 API
FabricationConfiguration Properties
FabricationConfiguration Class See Also Send Feedback

The FabricationConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FabricationConfiguration Class


Parameter Property

[image] [image]

Revit 2024 API
FabricationConfiguration..::..Parameter Property
FabricationConfiguration Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

FabricationConfiguration Class
FabricationConfiguration Members


FabricationConfigurationInfo Class

[image]

Revit 2024 API
FabricationConfigurationInfo Class
Members See Also Send Feedback
Represents an MEP object that holds the properties of an MEP fabrication configuration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public class FabricationConfigurationInfo : IDisposable
Visual Basic
Public Class FabricationConfigurationInfo _
    Implements IDisposable
Visual C++
public ref class FabricationConfigurationInfo : IDisposable

Remarks

To populate the Path property, you may need to call FindSourceFabricationConfiguration first.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FabricationConfigurationInfo

See Also

FabricationConfigurationInfo Members


FabricationConfigurationInfo Members

[image] [image]

Revit 2024 API
FabricationConfigurationInfo Members
FabricationConfigurationInfo Class Methods Properties See Also Send Feedback

The FabricationConfigurationInfo type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FabricationConfigurationInfo
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FindSourceFabricationConfiguration | Finds the source fabrication configuration on disk which matches the input fabrication configuration.
 | GetAllFabricationConfigurations | Gets all added fabrication configurations.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProfiles | Return the profiles in the fabrication configuration.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid | Checks if the fabrication configuration is valid.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CloudId | The identifier of the cloud configuration.
Public property | Description | The description of the fabrication configuration.
Public property | GUID | The unique identification of the fabrication configuration.
Public property | IsCloudConfiguration | Whether the cloud configuration is a remote cloud one.
Public property | IsLocked | Checks whether the fabrication configuration is locked. If true, the configuration is locked and cannot be removed.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | The name of the fabrication configuration.
Public property | Path | The path where the fabrication configuration is located. To populate this property, you may need to call FindSourceFabricationConfiguration first.
Public property | UnitSystem | The unit system of the fabrication configuration. Units can be UnitSystem.Metric or UnitSystem.Imperial.
Public property | Version | The version of the fabrication configuration.

See Also

FabricationConfigurationInfo Class


Dispose Method

[image]

Revit 2024 API
FabricationConfigurationInfo..::..Dispose Method
FabricationConfigurationInfo Class See Also Send Feedback
Releases all resources used by the FabricationConfigurationInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FabricationConfigurationInfo Class


FindSourceFabricationConfiguration Method

[image]

Revit 2024 API
FabricationConfigurationInfo..::..FindSourceFabricationConfiguration Method
FabricationConfigurationInfo Class See Also Send Feedback
Finds the source fabrication configuration on disk which matches the input fabrication configuration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public static FabricationConfigurationInfo FindSourceFabricationConfiguration(
    FabricationConfigurationInfo fabricationConfiguration
)
Visual Basic
Public Shared Function FindSourceFabricationConfiguration ( _
    fabricationConfiguration As FabricationConfigurationInfo _
) As FabricationConfigurationInfo
Visual C++
public:
static FabricationConfigurationInfo^ FindSourceFabricationConfiguration(
    FabricationConfigurationInfo^ fabricationConfiguration
)

Parameters

fabricationConfiguration
Type: Autodesk.Revit.DB..::..FabricationConfigurationInfo
The fabrication configuration to match.

Return Value

The matching source fabrication configuration.

Remarks

Fabrication configuration is matched by configuration GUID and version. The GUIDs are required to be the same. For version, we first try to match the version exactly. If Revit cannot find an exact match, then it looks for the closest version later than the input configuration, then the closest earlier version.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FabricationConfigurationInfo Class


GetAllFabricationConfigurations Method

[image]

Revit 2024 API
FabricationConfigurationInfo..::..GetAllFabricationConfigurations Method
FabricationConfigurationInfo Class See Also Send Feedback
Gets all added fabrication configurations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public static IList<FabricationConfigurationInfo> GetAllFabricationConfigurations()
Visual Basic
Public Shared Function GetAllFabricationConfigurations As IList(Of FabricationConfigurationInfo)
Visual C++
public:
static IList<FabricationConfigurationInfo^>^ GetAllFabricationConfigurations()

Return Value

All added fabrication configurations.

See Also

FabricationConfigurationInfo Class


GetProfiles Method

[image]

Revit 2024 API
FabricationConfigurationInfo..::..GetProfiles Method
FabricationConfigurationInfo Class See Also Send Feedback
Return the profiles in the fabrication configuration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public IList<string> GetProfiles()
Visual Basic
Public Function GetProfiles As IList(Of String)
Visual C++
public:
IList<String^>^ GetProfiles()

Remarks

The global profile name is empty, and is not returned here.

See Also

FabricationConfigurationInfo Class


IsValid Method

[image]

Revit 2024 API
FabricationConfigurationInfo..::..IsValid Method
FabricationConfigurationInfo Class See Also Send Feedback
Checks if the fabrication configuration is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool IsValid()
Visual Basic
Public Function IsValid As Boolean
Visual C++
public:
bool IsValid()

Return Value

True if the fabrication configuration is valid.

See Also

FabricationConfigurationInfo Class


FabricationConfigurationInfo Properties

[image] [image]

Revit 2024 API
FabricationConfigurationInfo Properties
FabricationConfigurationInfo Class See Also Send Feedback

The FabricationConfigurationInfo type exposes the following members.

Properties

 | Name | Description
Public property | CloudId | The identifier of the cloud configuration.
Public property | Description | The description of the fabrication configuration.
Public property | GUID | The unique identification of the fabrication configuration.
Public property | IsCloudConfiguration | Whether the cloud configuration is a remote cloud one.
Public property | IsLocked | Checks whether the fabrication configuration is locked. If true, the configuration is locked and cannot be removed.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | The name of the fabrication configuration.
Public property | Path | The path where the fabrication configuration is located. To populate this property, you may need to call FindSourceFabricationConfiguration first.
Public property | UnitSystem | The unit system of the fabrication configuration. Units can be UnitSystem.Metric or UnitSystem.Imperial.
Public property | Version | The version of the fabrication configuration.

See Also

FabricationConfigurationInfo Class


CloudId Property

[image]

Revit 2024 API
FabricationConfigurationInfo..::..CloudId Property
FabricationConfigurationInfo Class See Also Send Feedback
The identifier of the cloud configuration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public string CloudId { get; }
Visual Basic
Public ReadOnly Property CloudId As String
    Get
Visual C++
public:
property String^ CloudId {
    String^ get ();
}

See Also

FabricationConfigurationInfo Class


Description Property

[image]

Revit 2024 API
FabricationConfigurationInfo..::..Description Property
FabricationConfigurationInfo Class See Also Send Feedback
The description of the fabrication configuration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public string Description { get; }
Visual Basic
Public ReadOnly Property Description As String
    Get
Visual C++
public:
property String^ Description {
    String^ get ();
}

See Also

FabricationConfigurationInfo Class


GUID Property

[image]

Revit 2024 API
FabricationConfigurationInfo..::..GUID Property
FabricationConfigurationInfo Class See Also Send Feedback
The unique identification of the fabrication configuration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public Guid GUID { get; }
Visual Basic
Public ReadOnly Property GUID As Guid
    Get
Visual C++
public:
property Guid GUID {
    Guid get ();
}

See Also

FabricationConfigurationInfo Class


IsCloudConfiguration Property

[image]

Revit 2024 API
FabricationConfigurationInfo..::..IsCloudConfiguration Property
FabricationConfigurationInfo Class See Also Send Feedback
Whether the cloud configuration is a remote cloud one.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public bool IsCloudConfiguration { get; }
Visual Basic
Public ReadOnly Property IsCloudConfiguration As Boolean
    Get
Visual C++
public:
property bool IsCloudConfiguration {
    bool get ();
}

See Also

FabricationConfigurationInfo Class


IsLocked Property

[image]

Revit 2024 API
FabricationConfigurationInfo..::..IsLocked Property
FabricationConfigurationInfo Class See Also Send Feedback
Checks whether the fabrication configuration is locked. If true, the configuration is locked and cannot be removed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool IsLocked { get; }
Visual Basic
Public ReadOnly Property IsLocked As Boolean
    Get
Visual C++
public:
property bool IsLocked {
    bool get ();
}

See Also

FabricationConfigurationInfo Class


IsValidObject Property

[image]

Revit 2024 API
FabricationConfigurationInfo..::..IsValidObject Property
FabricationConfigurationInfo Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

FabricationConfigurationInfo Class


Name Property

[image]

Revit 2024 API
FabricationConfigurationInfo..::..Name Property
FabricationConfigurationInfo Class See Also Send Feedback
The name of the fabrication configuration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

FabricationConfigurationInfo Class


Path Property

[image]

Revit 2024 API
FabricationConfigurationInfo..::..Path Property
FabricationConfigurationInfo Class See Also Send Feedback
The path where the fabrication configuration is located. To populate this property, you may need to call FindSourceFabricationConfiguration first.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public string Path { get; }
Visual Basic
Public ReadOnly Property Path As String
    Get
Visual C++
public:
property String^ Path {
    String^ get ();
}

See Also

FabricationConfigurationInfo Class


Version Property

[image]

Revit 2024 API
FabricationConfigurationInfo..::..Version Property
FabricationConfigurationInfo Class See Also Send Feedback
The version of the fabrication configuration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public double Version { get; }
Visual Basic
Public ReadOnly Property Version As Double
    Get
Visual C++
public:
property double Version {
    double get ();
}

See Also

FabricationConfigurationInfo Class


FabricationConnectorInfo Class

[image]

Revit 2024 API
FabricationConnectorInfo Class
Members See Also Send Feedback
Fabrication connector information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public class FabricationConnectorInfo : IDisposable
Visual Basic
Public Class FabricationConnectorInfo _
    Implements IDisposable
Visual C++
public ref class FabricationConnectorInfo : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FabricationConnectorInfo

See Also

FabricationConnectorInfo Members


FabricationConnectorInfo Members

[image] [image]

Revit 2024 API
FabricationConnectorInfo Members
FabricationConnectorInfo Class Methods Properties See Also Send Feedback

The FabricationConnectorInfo type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FabricationConnectorInfo
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasDoubleWallConnector | Checks if there are any double wall connectors fabricated.
Public method | IsValid | Checks if the connector has fabrication parameters associated with it that can be set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BodyConnectorId | Fabrication body connector Id.
Public property | DoubleWallConnectorId | Fabrication double wall connector Id.
Public property | FabricationIndex | The index of the connector shown within the fabrication software.
Public property | IsBodyConnectorLocked | Fabrication body connector lock.
Public property | IsDoubleWallConnectorLocked | Fabrication double wall connector lock.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

FabricationConnectorInfo Class


FabricationConnectorInfo Methods

[image] [image]

Revit 2024 API
FabricationConnectorInfo Methods
FabricationConnectorInfo Class See Also Send Feedback

The FabricationConnectorInfo type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasDoubleWallConnector | Checks if there are any double wall connectors fabricated.
Public method | IsValid | Checks if the connector has fabrication parameters associated with it that can be set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FabricationConnectorInfo Class


Dispose Method

[image]

Revit 2024 API
FabricationConnectorInfo..::..Dispose Method
FabricationConnectorInfo Class See Also Send Feedback
Releases all resources used by the FabricationConnectorInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FabricationConnectorInfo Class


HasDoubleWallConnector Method

[image]

Revit 2024 API
FabricationConnectorInfo..::..HasDoubleWallConnector Method
FabricationConnectorInfo Class See Also Send Feedback
Checks if there are any double wall connectors fabricated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool HasDoubleWallConnector()
Visual Basic
Public Function HasDoubleWallConnector As Boolean
Visual C++
public:
bool HasDoubleWallConnector()

Return Value

True if there are any double wall connectors fabricated.

See Also

FabricationConnectorInfo Class


FabricationConnectorInfo Properties

[image] [image]

Revit 2024 API
FabricationConnectorInfo Properties
FabricationConnectorInfo Class See Also Send Feedback

The FabricationConnectorInfo type exposes the following members.

Properties

 | Name | Description
Public property | BodyConnectorId | Fabrication body connector Id.
Public property | DoubleWallConnectorId | Fabrication double wall connector Id.
Public property | FabricationIndex | The index of the connector shown within the fabrication software.
Public property | IsBodyConnectorLocked | Fabrication body connector lock.
Public property | IsDoubleWallConnectorLocked | Fabrication double wall connector lock.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

FabricationConnectorInfo Class


BodyConnectorId Property

[image]

Revit 2024 API
FabricationConnectorInfo..::..BodyConnectorId Property
FabricationConnectorInfo Class See Also Send Feedback
Fabrication body connector Id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public int BodyConnectorId { get; set; }
Visual Basic
Public Property BodyConnectorId As Integer
    Get
    Set
Visual C++
public:
property int BodyConnectorId {
    int get ();
    void set (int value);
}

Remarks

A reference to the fabrication configuration connectors. Setting the connector value will also set the connector lock. A value of 0 indicates the connector is set to none.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: bodyConnectorId is invalid based on the shape and domain.
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: the connector cannot be modified on an owned fabrication part. -or- When setting this property: the connector is already connected. -or- When setting this property: the fabrication part is connected to more than one item.

See Also

FabricationConnectorInfo Class


DoubleWallConnectorId Property

[image]

Revit 2024 API
FabricationConnectorInfo..::..DoubleWallConnectorId Property
FabricationConnectorInfo Class See Also Send Feedback
Fabrication double wall connector Id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public int DoubleWallConnectorId { get; set; }
Visual Basic
Public Property DoubleWallConnectorId As Integer
    Get
    Set
Visual C++
public:
property int DoubleWallConnectorId {
    int get ();
    void set (int value);
}

Remarks

A reference to the fabrication configuration connectors. Setting the connector value will also set the connector lock. A value of 0 indicates no connector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: doubleWallConnectorId is invalid based on the shape and domain.
Autodesk.Revit.Exceptions..::..InvalidOperationException | No double wall connector available. -or- When setting this property: the connector cannot be modified on an owned fabrication part. -or- When setting this property: the connector is already connected. -or- When setting this property: the fabrication part is connected to more than one item.

See Also

FabricationConnectorInfo Class


FabricationIndex Property

[image]

Revit 2024 API
FabricationConnectorInfo..::..FabricationIndex Property
FabricationConnectorInfo Class See Also Send Feedback
The index of the connector shown within the fabrication software.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public int FabricationIndex { get; }
Visual Basic
Public ReadOnly Property FabricationIndex As Integer
    Get
Visual C++
public:
property int FabricationIndex {
    int get ();
}

See Also

FabricationConnectorInfo Class


IsBodyConnectorLocked Property

[image]

Revit 2024 API
FabricationConnectorInfo..::..IsBodyConnectorLocked Property
FabricationConnectorInfo Class See Also Send Feedback
Fabrication body connector lock.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool IsBodyConnectorLocked { get; set; }
Visual Basic
Public Property IsBodyConnectorLocked As Boolean
    Get
    Set
Visual C++
public:
property bool IsBodyConnectorLocked {
    bool get ();
    void set (bool value);
}

Remarks

If set this prevents the connector value being overridden by the fabrication specification.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: the connector cannot be modified on an owned fabrication part. -or- When setting this property: the connector is already connected. -or- When setting this property: the fabrication part is connected to more than one item.

See Also

FabricationConnectorInfo Class


IsValidObject Property

[image]

Revit 2024 API
FabricationConnectorInfo..::..IsValidObject Property
FabricationConnectorInfo Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

FabricationConnectorInfo Class


FabricationDimensionDefinition Methods

[image] [image]

Revit 2024 API
FabricationDimensionDefinition Methods
FabricationDimensionDefinition Class See Also Send Feedback

The FabricationDimensionDefinition type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FabricationDimensionDefinition Class


Dispose Method

[image]

Revit 2024 API
FabricationDimensionDefinition..::..Dispose Method
FabricationDimensionDefinition Class See Also Send Feedback
Releases all resources used by the FabricationDimensionDefinition

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FabricationDimensionDefinition Class


FabricationDimensionDefinition Properties

[image] [image]

Revit 2024 API
FabricationDimensionDefinition Properties
FabricationDimensionDefinition Class See Also Send Feedback

The FabricationDimensionDefinition type exposes the following members.

Properties

 | Name | Description
Public property | IsModifiable | If the fabrication dimension is modifiable by user.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | Fabrication dimension name.
Public property | Type | Fabrication dimension type.
Public property | UnitType | Fabrication dimension unit type.

See Also

FabricationDimensionDefinition Class


IsModifiable Property

[image]

Revit 2024 API
FabricationDimensionDefinition..::..IsModifiable Property
FabricationDimensionDefinition Class See Also Send Feedback
If the fabrication dimension is modifiable by user.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool IsModifiable { get; }
Visual Basic
Public ReadOnly Property IsModifiable As Boolean
    Get
Visual C++
public:
property bool IsModifiable {
    bool get ();
}

See Also

FabricationDimensionDefinition Class


Name Property

[image]

Revit 2024 API
FabricationDimensionDefinition..::..Name Property
FabricationDimensionDefinition Class See Also Send Feedback
Fabrication dimension name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

FabricationDimensionDefinition Class


FabricationDimensionUnitType Enumeration

[image]

Revit 2024 API
FabricationDimensionUnitType Enumeration
See Also Send Feedback
Fabrication dimension unit type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public enum FabricationDimensionUnitType
Visual Basic
Public Enumeration FabricationDimensionUnitType
Visual C++
public enum class FabricationDimensionUnitType

Members

Member name | Description
NoUnits | NoUnits.
Linear | Linear.
Angular | Angular.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


FabricationHostedInfo Class

[image]

Revit 2024 API
FabricationHostedInfo Class
Members See Also Send Feedback
The fabrication hosted element information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public class FabricationHostedInfo : IDisposable
Visual Basic
Public Class FabricationHostedInfo _
    Implements IDisposable
Visual C++
public ref class FabricationHostedInfo : IDisposable

Remarks

A fabrication part may have a host, the FabricationHostedInfo stores the host information for the fabrication part.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FabricationHostedInfo

See Also

FabricationHostedInfo Members


DisconnectFromHost Method

[image]

Revit 2024 API
FabricationHostedInfo..::..DisconnectFromHost Method
FabricationHostedInfo Class See Also Send Feedback
Disconnects the part from the host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public void DisconnectFromHost()
Visual Basic
Public Sub DisconnectFromHost
Visual C++
public:
void DisconnectFromHost()

See Also

FabricationHostedInfo Class


Dispose Method

[image]

Revit 2024 API
FabricationHostedInfo..::..Dispose Method
FabricationHostedInfo Class See Also Send Feedback
Releases all resources used by the FabricationHostedInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FabricationHostedInfo Class


GetBearerCenterline Method

[image]

Revit 2024 API
FabricationHostedInfo..::..GetBearerCenterline Method
FabricationHostedInfo Class See Also Send Feedback
Gets the centerline of the bearer. The method is applicable only for bearer hanger.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public Line GetBearerCenterline()
Visual Basic
Public Function GetBearerCenterline As Line
Visual C++
public:
Line^ GetBearerCenterline()

Return Value

The centerline of the bearer.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The hanger is not a bearer hanger.

See Also

FabricationHostedInfo Class


PlaceOnHost Method

[image] [image]

Revit 2024 API
FabricationHostedInfo..::..PlaceOnHost Method
FabricationHostedInfo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PlaceOnHost(ElementId, Connector, Double) | Places the part on the specified host.
Public method | PlaceOnHost(ElementId, Connector, Double, Double) | Places the part on the specified host.

See Also

FabricationHostedInfo Class
FabricationHostedInfo Members


PlaceOnHost Method (ElementId, Connector, Double)

[image]

Revit 2024 API
FabricationHostedInfo..::..PlaceOnHost Method (ElementId, Connector, Double)
FabricationHostedInfo Class See Also Send Feedback
Places the part on the specified host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public void PlaceOnHost(
    ElementId hostId,
    Connector hostConnector,
    double distance
)
Visual Basic
Public Sub PlaceOnHost ( _
    hostId As ElementId, _
    hostConnector As Connector, _
    distance As Double _
)
Visual C++
public:
void PlaceOnHost(
    ElementId^ hostId,
    Connector^ hostConnector,
    double distance
)

Parameters

hostId
Type: Autodesk.Revit.DB..::..ElementId
Identifier of the host fabrication part.
hostConnector
Type: Autodesk.Revit.DB..::..Connector
The connector of the host.
distance
Type: System..::..Double
The distance from the connector to place the hosted part. Units are in feet (ft).

Remarks

The document must be regenerated before the fabrication part can be used. Check ValidationStatus after regeneration to see if the part is valid for fabrication.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Invalid fabrication part host. The host should be a straight fabrication part. -or- Invalid connector of fabrication part host. -or- The distance is out of range.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FabricationHostedInfo Class
PlaceOnHost Overload


PlaceOnHost Method (ElementId, Connector, Double, Double)

[image]

Revit 2024 API
FabricationHostedInfo..::..PlaceOnHost Method (ElementId, Connector, Double, Double)
FabricationHostedInfo Class See Also Send Feedback
Places the part on the specified host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public void PlaceOnHost(
    ElementId hostId,
    Connector hostConnector,
    double distance,
    double axisRotation
)
Visual Basic
Public Sub PlaceOnHost ( _
    hostId As ElementId, _
    hostConnector As Connector, _
    distance As Double, _
    axisRotation As Double _
)
Visual C++
public:
void PlaceOnHost(
    ElementId^ hostId,
    Connector^ hostConnector,
    double distance,
    double axisRotation
)

Parameters

hostId
Type: Autodesk.Revit.DB..::..ElementId
Identifier of the host fabrication part.
hostConnector
Type: Autodesk.Revit.DB..::..Connector
The connector of the host.
distance
Type: System..::..Double
The distance from the connector to place the hosted part. Units are in feet (ft).
axisRotation
Type: System..::..Double
The axis rotation in radians.

Remarks

The document must be regenerated before the fabrication part can be used. Check ValidationStatus after regeneration to see if the part is valid for fabrication.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Invalid fabrication part host. The host should be a straight fabrication part. -or- Invalid connector of fabrication part host. -or- The distance is out of range. -or- For rectangular and oval parts the axis rotation must be a multiple of PI/2.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FabricationHostedInfo Class
PlaceOnHost Overload


IsValidObject Property

[image]

Revit 2024 API
FabricationHostedInfo..::..IsValidObject Property
FabricationHostedInfo Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

FabricationHostedInfo Class


FabricationItemFile Members

[image] [image]

Revit 2024 API
FabricationItemFile Members
FabricationItemFile Class Methods Properties See Also Send Feedback

The FabricationItemFile type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FabricationItemFile
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetImage | Gets the image for the fabrication item file.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsLoaded | Checks to see if the item file has been loaded into the configuration.
Public method | IsValid | Checks to see if the item file is valid.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Identifier | The string identifier for the item file. This string is unique and can be used to compare whether fabrication item files are the same file.
Public property | IsUsed | Checks to see if the item file is already in use in the project.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

FabricationItemFile Class


FabricationItemFile Methods

[image] [image]

Revit 2024 API
FabricationItemFile Methods
FabricationItemFile Class See Also Send Feedback

The FabricationItemFile type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetImage | Gets the image for the fabrication item file.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsLoaded | Checks to see if the item file has been loaded into the configuration.
Public method | IsValid | Checks to see if the item file is valid.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FabricationItemFile Class


Dispose Method

[image]

Revit 2024 API
FabricationItemFile..::..Dispose Method
FabricationItemFile Class See Also Send Feedback
Releases all resources used by the FabricationItemFile

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FabricationItemFile Class


GetImage Method

[image]

Revit 2024 API
FabricationItemFile..::..GetImage Method
FabricationItemFile Class See Also Send Feedback
Gets the image for the fabrication item file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public virtual Bitmap GetImage()
Visual Basic
Public Overridable Function GetImage As Bitmap
Visual C++
public:
virtual Bitmap^ GetImage()

Return Value

System.Drawing.Bitmap represents the fabrication item file image. nullNothingnullptra null reference (Nothing in Visual Basic) if there is no preview image.

See Also

FabricationItemFile Class


IsLoaded Method

[image]

Revit 2024 API
FabricationItemFile..::..IsLoaded Method
FabricationItemFile Class See Also Send Feedback
Checks to see if the item file has been loaded into the configuration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public bool IsLoaded()
Visual Basic
Public Function IsLoaded As Boolean
Visual C++
public:
bool IsLoaded()

Return Value

Returns true if the item file has been loaded into the configuration, false otherwise.

See Also

FabricationItemFile Class


IsValid Method

[image]

Revit 2024 API
FabricationItemFile..::..IsValid Method
FabricationItemFile Class See Also Send Feedback
Checks to see if the item file is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public bool IsValid()
Visual Basic
Public Function IsValid As Boolean
Visual C++
public:
bool IsValid()

Return Value

Returns true if the item file is valid, false otherwise.

See Also

FabricationItemFile Class


FabricationItemFile Properties

[image] [image]

Revit 2024 API
FabricationItemFile Properties
FabricationItemFile Class See Also Send Feedback

The FabricationItemFile type exposes the following members.

Properties

 | Name | Description
Public property | Identifier | The string identifier for the item file. This string is unique and can be used to compare whether fabrication item files are the same file.
Public property | IsUsed | Checks to see if the item file is already in use in the project.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

FabricationItemFile Class


Identifier Property

[image]

Revit 2024 API
FabricationItemFile..::..Identifier Property
FabricationItemFile Class See Also Send Feedback
The string identifier for the item file. This string is unique and can be used to compare whether fabrication item files are the same file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public string Identifier { get; }
Visual Basic
Public ReadOnly Property Identifier As String
    Get
Visual C++
public:
property String^ Identifier {
    String^ get ();
}

See Also

FabricationItemFile Class


IsUsed Property

[image]

Revit 2024 API
FabricationItemFile..::..IsUsed Property
FabricationItemFile Class See Also Send Feedback
Checks to see if the item file is already in use in the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public bool IsUsed { get; }
Visual Basic
Public ReadOnly Property IsUsed As Boolean
    Get
Visual C++
public:
property bool IsUsed {
    bool get ();
}

See Also

FabricationItemFile Class


FabricationItemFolder Class

[image]

Revit 2024 API
FabricationItemFolder Class
Members See Also Send Feedback
A fabrication item folder that can contain sub folders and access to the FabricationItemFiles contained within.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public class FabricationItemFolder : IDisposable
Visual Basic
Public Class FabricationItemFolder _
    Implements IDisposable
Visual C++
public ref class FabricationItemFolder : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FabricationItemFolder

See Also

FabricationItemFolder Members


FabricationItemFolder Members

[image] [image]

Revit 2024 API
FabricationItemFolder Members
FabricationItemFolder Class Methods Properties See Also Send Feedback

The FabricationItemFolder type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FabricationItemFolder
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemFiles | Gets the item files in this item folder.
Public method | GetSubFolders | Gets the item folder's sub folders.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | The item folder's name.

See Also

FabricationItemFolder Class


FabricationItemFolder Methods

[image] [image]

Revit 2024 API
FabricationItemFolder Methods
FabricationItemFolder Class See Also Send Feedback

The FabricationItemFolder type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemFiles | Gets the item files in this item folder.
Public method | GetSubFolders | Gets the item folder's sub folders.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FabricationItemFolder Class


GetItemFiles Method

[image]

Revit 2024 API
FabricationItemFolder..::..GetItemFiles Method
FabricationItemFolder Class See Also Send Feedback
Gets the item files in this item folder.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public IList<FabricationItemFile> GetItemFiles()
Visual Basic
Public Function GetItemFiles As IList(Of FabricationItemFile)
Visual C++
public:
IList<FabricationItemFile^>^ GetItemFiles()

See Also

FabricationItemFolder Class


GetSubFolders Method

[image]

Revit 2024 API
FabricationItemFolder..::..GetSubFolders Method
FabricationItemFolder Class See Also Send Feedback
Gets the item folder's sub folders.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public IList<FabricationItemFolder> GetSubFolders()
Visual Basic
Public Function GetSubFolders As IList(Of FabricationItemFolder)
Visual C++
public:
IList<FabricationItemFolder^>^ GetSubFolders()

See Also

FabricationItemFolder Class


IsValidObject Property

[image]

Revit 2024 API
FabricationItemFolder..::..IsValidObject Property
FabricationItemFolder Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

FabricationItemFolder Class


Name Property

[image]

Revit 2024 API
FabricationItemFolder..::..Name Property
FabricationItemFolder Class See Also Send Feedback
The item folder's name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

FabricationItemFolder Class


FabricationPart Class

[image]

Revit 2024 API
FabricationPart Class
Members See Also Send Feedback
Represents a fabrication component in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public class FabricationPart : Element
Visual Basic
Public Class FabricationPart _
    Inherits Element
Visual C++
public ref class FabricationPart : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..FabricationPart

See Also

FabricationPart Members


FabricationPart Members

[image] [image]

Revit 2024 API
FabricationPart Members
FabricationPart Class Methods Properties See Also Send Feedback

The FabricationPart type exposes the following members.

Methods

 | Name | Description
Public method | AddPartCustomData | Add custom data type to the fabrication part. The new data gets the default value defined by the fabrication configuration.
Public method | AdjustEndLength | Adjusts the length for the specified connector.
 | AlignPartByConnector | Align the part by its connector to a point and rotation in free space.
 | AlignPartByConnectors | Moves fabrication part by one of its connectors and aligns it to another connector.
 | AlignPartByConnectorToConnector | Align a part by its connector to another connector. This will replace the FabricationPart::AlignPartByConnectors method.
 | AlignPartByInsertionPoint | Align the part by its insertion point to a point and rotation in free space.
 | AlignPartByInsertionPointAndCutInToStraight | Align the part by its insertion point to a point and rotation on a straight. This will automatically size and connect the part being cut into, if possible.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanAdjustEndLength | Checks if the end of fabrication part can be adjusted.
Public method | CanASlopeBeApplied | This will test if a slope can be applied to the part and maintain connections with any connected parts.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanFlipPart | Validates if the fabrication part is one of the supported fabrication part types that can be flipped.
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanSplitStraight | Validates if the straight can be split into two at the passed in point.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | ConnectAndCouple | Makes a connection between the specified connectors and adds coupling if necessary.
 | Create(Document, FabricationItemFile, ElementId) | Creates a fabrication part element from a fabrication item file.
 | Create(Document, FabricationServiceButton, Int32, ElementId) | Creates a fabrication part element based on button.
 | Create(Document, FabricationServiceButton, Double, Double, ElementId) | Creates a fabrication part element based on button and size.
 | CreateHanger(Document, FabricationServiceButton, Int32, ElementId) | Creates a free placed hanger.
 | CreateHanger(Document, FabricationServiceButton, ElementId, Connector, Double, Boolean) | Creates a hanger on the fabrication part.
 | CreateHanger(Document, FabricationServiceButton, Int32, ElementId, Connector, Double, Boolean) | Creates a hanger on the fabrication part.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | Flip | Flips the fabrication part that is directionally oriented (tees, crosses, valves, dampers, etc.) to the opposite direction.
Public method | GetCalculatedDimensionValue | Gets the calculated dimension value.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetDimensionCalculatedOptions | Gets the calculated options of the fabrication dimension.
Public method | GetDimensions | Gets all fabrication dimensions.
Public method | GetDimensionValue | Gets the value of the fabrication dimension, returns value in Revit internal units.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHostedInfo | Gets the fabrication hosted element information.
Public method | GetInsulationLiningGeometry | Gets insulation and lining geometry for this fabrication part.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPartAncillaryUsage | Gets a list of all ancillary usage information for the part.
Public method | GetPartCustomDataInteger | Get custom data integer value for the specified custom data.
Public method | GetPartCustomDataReal | Get custom data real value for the specified custom data.
Public method | GetPartCustomDataText | Get custom data text for the specified custom data.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetProductListEntryCount | Gets the number of product entries for this part.
Public method | GetProductListEntryName | Gets the specified product list entry name.
Public method | GetRodInfo | Gets the fabrication rod information.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetTransform | Gets the transformation matrix of the fabrication part element.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVersionHistory | Gets a history of version change information about the current part.
Public method | HasCustomData | Check if fabrication part contains custom data already.
Public method | HasNoConnections | Checks to see if all the fabrication part's connectors are open.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsAHanger | Checks whether it is a hanger.
Public method | IsAStraight | Checks whether it is a straight part.
Public method | IsATap | Checks if it is any sort of tap.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDimensionCalculated | Checks if the fabrication dimension is calculated.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsProductList | Gets whether or not the fabrication part is a product list.
Public method | IsProductListEntryCompatibleSize | Checks to see if this part can be changed to the specified product entry without altering any connected dimensions.
Public method | IsSameAs | Compare this fabrication part with the part passed and checks the pattern dimensions and options. A list of fields that can be ignored in the comparison check can be specified.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
 | OptimizeLengths | Optimizes the length fabrication straight parts.
 | PlaceAsTap | Places the part by its connector to a specific position on the straight part at the specified distance from the host part connector.
 | PlaceFittingAsCutIn | Places the fitting on the straight part by cut in, use the fitting's focal point as the insertion position.
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | RemovePartCustomData | Remove custom data from the fabrication part.
 | Reposition | Repositions the fabrication straight part to another end of the run.
 | RotateConnectedPartByConnector | Rotates a connected fabrication part around the axis of the specified connector.
 | RotateConnectedTap | Rotates a connected fabrication tap by the specified angles about the primary and secondary axis.
 | SaveAsFabricationJob | Save fabrication parts to an MEP job that can be opened in the fabrication software.
Public method | SetCalculatedDimensionValue | Sets the calculated dimension value.
Public method | SetDimensionValue | Sets the fabrication dimension value. The value is in Revit internal units.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetPartCustomDataInteger | Set the custom data integer value for the specified custom data.
Public method | SetPartCustomDataReal | Set the custom data real value for the specified custom data.
Public method | SetPartCustomDataText | Set the custom data real value for the specified custom data.
Public method | SetPositionByEnd | Positions the connector of the fabrication part element by the passed point.
Public method | SplitStraight(XYZ) | Splits the straight into two at the passed in point.
Public method | SplitStraight(Document, ElementId, XYZ) | Splits the straight into two at the passed in point.
 | StretchAndFit | Stretch the fabrication part from the specified connector and fit to the target routing end.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Alias | The alias of the fabrication part.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BottomOfPartElevation | The associated elevation to the bottom of fabrication part off of the current level.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterlineLength | The centerline length of the fabrication part.
Public property | ConnectorManager | The connector manager of the fabrication part.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CutType | The cut type of the fabrication part.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | DomainType | The domain type for the fabrication part.
Public property | DoubleWallMaterial | The double wall material identifier of the fabrication part.
Public property | DoubleWallMaterialArea | The double wall material area of the fabrication part. If the fabrication part is not double walled, returns zero.
Public property | DoubleWallMaterialThickness | The double wall material thickness of the fabrication part. If the fabrication part is not double walled, returns zero.
Public property | FreeSize | The inner size of the fabrication part.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryChecksum | Gets the geometry checksum of the fabrication part symbol, and it does nothing with the fabrication part instance position.
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | HangerRodKit | Specifies whether an ancillary kit is being used to override support rods, bolts and clips, if any. A value of 0 indicates no override is being used.
Public property | HasDoubleWall | True if the fabrication part is double walled.
Public property | HasInsulation | True if the fabrication part is insulated.
Public property | HasLining | True if the fabrication part is lined.
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | InsulationArea | The insulation area of the fabrication part. If the fabrication part is not insulated, returns zero.
Public property | InsulationSpecification | The fabrication part insulation specification identifier.
Public property | InsulationThickness | The insulation thickness of the fabrication part. If the fabrication part is not insulated, returns zero.
Public property | InsulationType | The insulation type of the fabrication part.
Public property | IsBoughtOut | True if the fabrication part is bought out.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | ItemCustomId | The item custom identifier for the fabrication part.
Public property | ItemNumber | The item number that is used for identification, re-ordering from shop.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | LevelOffset | The associated level offset that indicates the distance from the center of the fabrication part to the current level.
Public property | LiningArea | The lining area of the fabrication part. If the fabrication part is not lined, returns zero.
Public property | LiningThickness | The lining thickness of the fabrication part. If the fabrication part is not lined, returns zero.
Public property | LiningType | The lining type of the fabrication part.
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Material | The fabrication material identifier.
Public property | MaterialGauge | The fabrication material gauge identifier.
Public property | MaterialThickness | The material thickness of the fabrication part.
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Notes | The notes of the fabrication part.
Public property | Origin | The origin of the fabrication part element.
Public property | OverallSize | The overall size of the fabrication part.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PartGuid | The fabrication part's globally unique identifier.
Public property | PartStatus | The status identifier for the fabrication part.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ProductCode | The current database id of the part within the fabrication database.
Public property | ProductDataRange | The product data range of the fabrication part.
Public property | ProductFinishDescription | The product finish description of the fabrication part.
Public property | ProductInstallType | The product install type of the fabrication part.
Public property | ProductListEntry | The product entry index of the fabrication part. A value of -1 indicates the fabrication part is not a product list.
Public property | ProductLongDescription | The product long description of the fabrication part.
Public property | ProductMaterialDescription | The product material description of the fabrication part.
Public property | ProductName | The product name of the fabrication part.
Public property | ProductOriginalEquipmentManufacture | The product original equipment manufacture (OEM) of the fabrication part.
Public property | ProductShortDescription | The product short description of the fabrication part.
Public property | ProductSizeDescription | The product size description of the fabrication part.
Public property | ProductSpecificationDescription | The product specification description of the fabrication part.
Public property | ServiceAbbreviation | The associated service abbreviation for the fabrication service.
Public property | ServiceId | The fabrication part service identifier. The service can only be changed to compatible services.
Public property | ServiceName | The name of the service associated with the fabrication part.
Public property | ServiceType | The service type identifier of the fabrication part.
Public property | SheetMetalArea | The sheet metal area of the fabrication part.
Public property | Size | The size of the fabrication part.
Public property | Slope | The slope for the straight fabrication part.
Public property | Specification | The fabrication part specification identifier.
Public property | SpoolName | The spool name of the fabrication part.
Public property | TopOfPartElevation | The associated elevation to the top of fabrication part off of the current level.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ValidationStatus | The validation status of the fabrication part.
Public property | Vendor | The vendor of the fabrication part.
Public property | VendorCode | The vendor code of the fabrication part.
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Weight | The weight of the fabrication part.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FabricationPart Class


FabricationPart Methods

[image] [image]

Revit 2024 API
FabricationPart Methods
FabricationPart Class See Also Send Feedback

The FabricationPart type exposes the following members.

Methods

 | Name | Description
Public method | AddPartCustomData | Add custom data type to the fabrication part. The new data gets the default value defined by the fabrication configuration.
Public method | AdjustEndLength | Adjusts the length for the specified connector.
 | AlignPartByConnector | Align the part by its connector to a point and rotation in free space.
 | AlignPartByConnectors | Moves fabrication part by one of its connectors and aligns it to another connector.
 | AlignPartByConnectorToConnector | Align a part by its connector to another connector. This will replace the FabricationPart::AlignPartByConnectors method.
 | AlignPartByInsertionPoint | Align the part by its insertion point to a point and rotation in free space.
 | AlignPartByInsertionPointAndCutInToStraight | Align the part by its insertion point to a point and rotation on a straight. This will automatically size and connect the part being cut into, if possible.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanAdjustEndLength | Checks if the end of fabrication part can be adjusted.
Public method | CanASlopeBeApplied | This will test if a slope can be applied to the part and maintain connections with any connected parts.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanFlipPart | Validates if the fabrication part is one of the supported fabrication part types that can be flipped.
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanSplitStraight | Validates if the straight can be split into two at the passed in point.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | ConnectAndCouple | Makes a connection between the specified connectors and adds coupling if necessary.
 | Create(Document, FabricationItemFile, ElementId) | Creates a fabrication part element from a fabrication item file.
 | Create(Document, FabricationServiceButton, Int32, ElementId) | Creates a fabrication part element based on button.
 | Create(Document, FabricationServiceButton, Double, Double, ElementId) | Creates a fabrication part element based on button and size.
 | CreateHanger(Document, FabricationServiceButton, Int32, ElementId) | Creates a free placed hanger.
 | CreateHanger(Document, FabricationServiceButton, ElementId, Connector, Double, Boolean) | Creates a hanger on the fabrication part.
 | CreateHanger(Document, FabricationServiceButton, Int32, ElementId, Connector, Double, Boolean) | Creates a hanger on the fabrication part.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | Flip | Flips the fabrication part that is directionally oriented (tees, crosses, valves, dampers, etc.) to the opposite direction.
Public method | GetCalculatedDimensionValue | Gets the calculated dimension value.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetDimensionCalculatedOptions | Gets the calculated options of the fabrication dimension.
Public method | GetDimensions | Gets all fabrication dimensions.
Public method | GetDimensionValue | Gets the value of the fabrication dimension, returns value in Revit internal units.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHostedInfo | Gets the fabrication hosted element information.
Public method | GetInsulationLiningGeometry | Gets insulation and lining geometry for this fabrication part.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPartAncillaryUsage | Gets a list of all ancillary usage information for the part.
Public method | GetPartCustomDataInteger | Get custom data integer value for the specified custom data.
Public method | GetPartCustomDataReal | Get custom data real value for the specified custom data.
Public method | GetPartCustomDataText | Get custom data text for the specified custom data.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetProductListEntryCount | Gets the number of product entries for this part.
Public method | GetProductListEntryName | Gets the specified product list entry name.
Public method | GetRodInfo | Gets the fabrication rod information.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetTransform | Gets the transformation matrix of the fabrication part element.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVersionHistory | Gets a history of version change information about the current part.
Public method | HasCustomData | Check if fabrication part contains custom data already.
Public method | HasNoConnections | Checks to see if all the fabrication part's connectors are open.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsAHanger | Checks whether it is a hanger.
Public method | IsAStraight | Checks whether it is a straight part.
Public method | IsATap | Checks if it is any sort of tap.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDimensionCalculated | Checks if the fabrication dimension is calculated.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsProductList | Gets whether or not the fabrication part is a product list.
Public method | IsProductListEntryCompatibleSize | Checks to see if this part can be changed to the specified product entry without altering any connected dimensions.
Public method | IsSameAs | Compare this fabrication part with the part passed and checks the pattern dimensions and options. A list of fields that can be ignored in the comparison check can be specified.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
 | OptimizeLengths | Optimizes the length fabrication straight parts.
 | PlaceAsTap | Places the part by its connector to a specific position on the straight part at the specified distance from the host part connector.
 | PlaceFittingAsCutIn | Places the fitting on the straight part by cut in, use the fitting's focal point as the insertion position.
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | RemovePartCustomData | Remove custom data from the fabrication part.
 | Reposition | Repositions the fabrication straight part to another end of the run.
 | RotateConnectedPartByConnector | Rotates a connected fabrication part around the axis of the specified connector.
 | RotateConnectedTap | Rotates a connected fabrication tap by the specified angles about the primary and secondary axis.
 | SaveAsFabricationJob | Save fabrication parts to an MEP job that can be opened in the fabrication software.
Public method | SetCalculatedDimensionValue | Sets the calculated dimension value.
Public method | SetDimensionValue | Sets the fabrication dimension value. The value is in Revit internal units.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetPartCustomDataInteger | Set the custom data integer value for the specified custom data.
Public method | SetPartCustomDataReal | Set the custom data real value for the specified custom data.
Public method | SetPartCustomDataText | Set the custom data real value for the specified custom data.
Public method | SetPositionByEnd | Positions the connector of the fabrication part element by the passed point.
Public method | SplitStraight(XYZ) | Splits the straight into two at the passed in point.
Public method | SplitStraight(Document, ElementId, XYZ) | Splits the straight into two at the passed in point.
 | StretchAndFit | Stretch the fabrication part from the specified connector and fit to the target routing end.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FabricationPart Class


AddPartCustomData Method

[image]

Revit 2024 API
FabricationPart..::..AddPartCustomData Method
FabricationPart Class See Also Send Feedback
Add custom data type to the fabrication part. The new data gets the default value defined by the fabrication configuration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public bool AddPartCustomData(
    int customId
)
Visual Basic
Public Function AddPartCustomData ( _
    customId As Integer _
) As Boolean
Visual C++
public:
bool AddPartCustomData(
    int customId
)

Parameters

customId
Type: System..::..Int32
The identifier of the custom data field to add.

Return Value

Returns true if the type was not already present.

Remarks

The custom id must be positive.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The custom data identifier does not exist.

See Also

FabricationPart Class


AdjustEndLength Method

[image]

Revit 2024 API
FabricationPart..::..AdjustEndLength Method
FabricationPart Class See Also Send Feedback
Adjusts the length for the specified connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public double AdjustEndLength(
    Connector connector,
    double lengthToAdjust,
    bool totalLengthOnly
)
Visual Basic
Public Function AdjustEndLength ( _
    connector As Connector, _
    lengthToAdjust As Double, _
    totalLengthOnly As Boolean _
) As Double
Visual C++
public:
double AdjustEndLength(
    Connector^ connector,
    double lengthToAdjust,
    bool totalLengthOnly
)

Parameters

connector
Type: Autodesk.Revit.DB..::..Connector
# The connector of the fabrication part to adjust length.
lengthToAdjust
Type: System..::..Double
The length to adjust.
totalLengthOnly
Type: System..::..Boolean
True if adjust the total length only when adjust length.

Return Value

The adjusted length.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The end of the fabrication part of the connector can not be adjusted. -or- Connector is connected.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FabricationPart Class


AlignPartByConnector Method

[image]

Revit 2024 API
FabricationPart..::..AlignPartByConnector Method
FabricationPart Class See Also Send Feedback
Align the part by its connector to a point and rotation in free space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public static bool AlignPartByConnector(
    Document document,
    Connector connector,
    XYZ position,
    double rotation,
    double rotationPerpendicular,
    double slope,
    FabricationPartJustification justification,
    Transform trf
)
Visual Basic
Public Shared Function AlignPartByConnector ( _
    document As Document, _
    connector As Connector, _
    position As XYZ, _
    rotation As Double, _
    rotationPerpendicular As Double, _
    slope As Double, _
    justification As FabricationPartJustification, _
    trf As Transform _
) As Boolean
Visual C++
public:
static bool AlignPartByConnector(
    Document^ document,
    Connector^ connector,
    XYZ^ position,
    double rotation,
    double rotationPerpendicular,
    double slope,
    FabricationPartJustification justification,
    Transform^ trf
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
connector
Type: Autodesk.Revit.DB..::..Connector
The connector to align in free space.
position
Type: Autodesk.Revit.DB..::..XYZ
The position to move the connector to.
rotation
Type: System..::..Double
The rotation in radians.
rotationPerpendicular
Type: System..::..Double
The perpendicular rotation for free placement around the Y axis direction of connection - angle in radians.
slope
Type: System..::..Double
The slope value to flex to match if possible in fractional units (eg.1/50). Positive values are up, negative are down. Slopes can only be applied to fittings, whilst straights will inherit the slope from the piece it is connecting to.
justification
Type: Autodesk.Revit.DB.Fabrication..::..FabricationPartJustification
The justification to align eccentric parts.
trf
Type: Autodesk.Revit.DB..::..Transform
Optional alignment transformation matrix, eg. a Trf that describes plan or side elevation.

Return Value

True if the alignment succeeds, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The connector does not belong to a fabrication part. -or- The fabrication part is connected.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

FabricationPart Class


AlignPartByConnectors Method

[image]

Revit 2024 API
FabricationPart..::..AlignPartByConnectors Method
FabricationPart Class See Also Send Feedback
Moves fabrication part by one of its connectors and aligns it to another connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public static bool AlignPartByConnectors(
    Document document,
    Connector connector,
    Connector toConnector,
    double axisRotation
)
Visual Basic
Public Shared Function AlignPartByConnectors ( _
    document As Document, _
    connector As Connector, _
    toConnector As Connector, _
    axisRotation As Double _
) As Boolean
Visual C++
public:
static bool AlignPartByConnectors(
    Document^ document,
    Connector^ connector,
    Connector^ toConnector,
    double axisRotation
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
connector
Type: Autodesk.Revit.DB..::..Connector
The connector of the fabrication part to move and align by.
toConnector
Type: Autodesk.Revit.DB..::..Connector
The connector of the fabrication part or family to align to.
axisRotation
Type: System..::..Double
Rotation around the direction of connection - angle between width vectors in radians.

Return Value

True if alignment succeeds, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | For rectangular and oval parts the axis rotation must be a multiple of PI/2. -or- The connector does not belong to a fabrication part. -or- The fabrication part is connected.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FabricationPart Class


AlignPartByConnectorToConnector Method

[image]

Revit 2024 API
FabricationPart..::..AlignPartByConnectorToConnector Method
FabricationPart Class See Also Send Feedback
Align a part by its connector to another connector. This will replace the FabricationPart::AlignPartByConnectors method.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public static bool AlignPartByConnectorToConnector(
    Document document,
    Connector connector,
    Connector fixedConnector,
    double rotation,
    double slope,
    FabricationPartJustification justification
)
Visual Basic
Public Shared Function AlignPartByConnectorToConnector ( _
    document As Document, _
    connector As Connector, _
    fixedConnector As Connector, _
    rotation As Double, _
    slope As Double, _
    justification As FabricationPartJustification _
) As Boolean
Visual C++
public:
static bool AlignPartByConnectorToConnector(
    Document^ document,
    Connector^ connector,
    Connector^ fixedConnector,
    double rotation,
    double slope,
    FabricationPartJustification justification
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
connector
Type: Autodesk.Revit.DB..::..Connector
The connector of the fabrication part to move by in free space.
fixedConnector
Type: Autodesk.Revit.DB..::..Connector
The connector for the fabrication part or family connector to align to.
rotation
Type: System..::..Double
The rotation in radians.
slope
Type: System..::..Double
The slope value to flex to match if possible in fractional units (eg.1/50). Positive values are up, negative are down. Slopes can only be applied to fittings, whilst straights will inherit the slope from the piece it is connecting to.
justification
Type: Autodesk.Revit.DB.Fabrication..::..FabricationPartJustification
The justification to align eccentric parts.

Return Value

True if the alignment succeeds, false otherwise and the part will not move from the original position.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | For rectangular and oval parts the axis rotation must be a multiple of PI/2. -or- The connector does not belong to a fabrication part. -or- The fabrication part is connected.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

FabricationPart Class


AlignPartByInsertionPoint Method

[image]

Revit 2024 API
FabricationPart..::..AlignPartByInsertionPoint Method
FabricationPart Class See Also Send Feedback
Align the part by its insertion point to a point and rotation in free space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public static bool AlignPartByInsertionPoint(
    Document document,
    ElementId partId,
    XYZ position,
    double rotation,
    double rotationPerpendicular,
    double slope,
    FabricationPartJustification justification,
    Transform trf
)
Visual Basic
Public Shared Function AlignPartByInsertionPoint ( _
    document As Document, _
    partId As ElementId, _
    position As XYZ, _
    rotation As Double, _
    rotationPerpendicular As Double, _
    slope As Double, _
    justification As FabricationPartJustification, _
    trf As Transform _
) As Boolean
Visual C++
public:
static bool AlignPartByInsertionPoint(
    Document^ document,
    ElementId^ partId,
    XYZ^ position,
    double rotation,
    double rotationPerpendicular,
    double slope,
    FabricationPartJustification justification,
    Transform^ trf
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
partId
Type: Autodesk.Revit.DB..::..ElementId
The element identifier of the part to align.
position
Type: Autodesk.Revit.DB..::..XYZ
The position to move the part's insertion point to.
rotation
Type: System..::..Double
The rotation in radians.
rotationPerpendicular
Type: System..::..Double
The perpendicular rotation for free placement around the Y axis direction of connection - angle in radians.
slope
Type: System..::..Double
The slope value to flex to match if possible in fractional units (eg.1/50). Positive values are up, negative are down. Slopes can only be applied to fittings, whilst straights will inherit the slope from the piece it is connecting to.
justification
Type: Autodesk.Revit.DB.Fabrication..::..FabricationPartJustification
The justification to align eccentric parts.
trf
Type: Autodesk.Revit.DB..::..Transform
Optional alignment transformation matrix, eg. a Trf that describes plan or side elevation.

Return Value

True if the alignment succeeds, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element is not a fabrication part. -or- Not all of the fabrication part's connectors are open.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

FabricationPart Class


AlignPartByInsertionPointAndCutInToStraight Method

[image]

Revit 2024 API
FabricationPart..::..AlignPartByInsertionPointAndCutInToStraight Method
FabricationPart Class See Also Send Feedback
Align the part by its insertion point to a point and rotation on a straight. This will automatically size and connect the part being cut into, if possible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public static bool AlignPartByInsertionPointAndCutInToStraight(
    Document document,
    ElementId straightId,
    ElementId partId,
    XYZ position,
    double rotation,
    double slope,
    bool flip
)
Visual Basic
Public Shared Function AlignPartByInsertionPointAndCutInToStraight ( _
    document As Document, _
    straightId As ElementId, _
    partId As ElementId, _
    position As XYZ, _
    rotation As Double, _
    slope As Double, _
    flip As Boolean _
) As Boolean
Visual C++
public:
static bool AlignPartByInsertionPointAndCutInToStraight(
    Document^ document,
    ElementId^ straightId,
    ElementId^ partId,
    XYZ^ position,
    double rotation,
    double slope,
    bool flip
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
straightId
Type: Autodesk.Revit.DB..::..ElementId
The element identifier of the straight to be cut in to.
partId
Type: Autodesk.Revit.DB..::..ElementId
The element identifier of the part to align and cut in with.
position
Type: Autodesk.Revit.DB..::..XYZ
The position to move the parts insertion point to.
rotation
Type: System..::..Double
The rotation in radians.
slope
Type: System..::..Double
The slope value to flex to match if possible in fractional units (eg.1/50). Positive values are up, negative are down. Slopes can only be applied to fittings, whilst straights will inherit the slope from the piece it is connecting to.
flip
Type: System..::..Boolean
Flip the part to allow for flow direction.

Return Value

True if the alignment succeeds, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element is not a fabrication part. -or- Not all of the fabrication part's connectors are open. -or- The part is not a straight. -or- The fabrication parts do not have matching domain types. -or- The position is not on the straight.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | Failed to align the part to the straight to cut in to.

See Also

FabricationPart Class


CanAdjustEndLength Method

[image]

Revit 2024 API
FabricationPart..::..CanAdjustEndLength Method
FabricationPart Class See Also Send Feedback
Checks if the end of fabrication part can be adjusted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public bool CanAdjustEndLength(
    Connector connector
)
Visual Basic
Public Function CanAdjustEndLength ( _
    connector As Connector _
) As Boolean
Visual C++
public:
bool CanAdjustEndLength(
    Connector^ connector
)

Parameters

connector
Type: Autodesk.Revit.DB..::..Connector
The connector of the fabrication part to adjust length.

Return Value

True if the end of fabrication part can be adjusted.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FabricationPart Class


CanASlopeBeApplied Method

[image]

Revit 2024 API
FabricationPart..::..CanASlopeBeApplied Method
FabricationPart Class See Also Send Feedback
This will test if a slope can be applied to the part and maintain connections with any connected parts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public bool CanASlopeBeApplied()
Visual Basic
Public Function CanASlopeBeApplied As Boolean
Visual C++
public:
bool CanASlopeBeApplied()

Return Value

Returns true if the part can be successfully sloped otherwise false.

See Also

FabricationPart Class


CanFlipPart Method

[image]

Revit 2024 API
FabricationPart..::..CanFlipPart Method
FabricationPart Class See Also Send Feedback
Validates if the fabrication part is one of the supported fabrication part types that can be flipped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public bool CanFlipPart()
Visual Basic
Public Function CanFlipPart As Boolean
Visual C++
public:
bool CanFlipPart()

Return Value

Returns true if valid otherwise false if the fabrication part cannot be flipped.

See Also

FabricationPart Class


CanSplitStraight Method

[image]

Revit 2024 API
FabricationPart..::..CanSplitStraight Method
FabricationPart Class See Also Send Feedback
Validates if the straight can be split into two at the passed in point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public bool CanSplitStraight(
    XYZ position
)
Visual Basic
Public Function CanSplitStraight ( _
    position As XYZ _
) As Boolean
Visual C++
public:
bool CanSplitStraight(
    XYZ^ position
)

Parameters

position
Type: Autodesk.Revit.DB..::..XYZ
The position to split in the straight.

Return Value

Returns true if valid otherwise false if the straight cannot be split.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FabricationPart Class


ConnectAndCouple Method

[image]

Revit 2024 API
FabricationPart..::..ConnectAndCouple Method
FabricationPart Class See Also Send Feedback
Makes a connection between the specified connectors and adds coupling if necessary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public static bool ConnectAndCouple(
    Document document,
    Connector connector,
    Connector toConnector
)
Visual Basic
Public Shared Function ConnectAndCouple ( _
    document As Document, _
    connector As Connector, _
    toConnector As Connector _
) As Boolean
Visual C++
public:
static bool ConnectAndCouple(
    Document^ document,
    Connector^ connector,
    Connector^ toConnector
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
connector
Type: Autodesk.Revit.DB..::..Connector
The connector of the fabrication part.
toConnector
Type: Autodesk.Revit.DB..::..Connector
The connector of the fabrication part or family to connect to.

Return Value

True if connection succeeded, false otherwise.

Remarks

This function does not place and align the fabrication part. Call AlignPartByConnectors before connecting.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The connector does not belong to a fabrication part. -or- The fabrication part connectors are not aligned, call AlignPartByConnectors to align them.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FabricationPart Class


Create Method

[image] [image]

Revit 2024 API
FabricationPart..::..Create Method
FabricationPart Class See Also Send Feedback

Overload List

Name | Description
Create(Document, FabricationItemFile, ElementId) | Creates a fabrication part element from a fabrication item file.
Create(Document, FabricationServiceButton, Int32, ElementId) | Creates a fabrication part element based on button.
Create(Document, FabricationServiceButton, Double, Double, ElementId) | Creates a fabrication part element based on button and size.

See Also

FabricationPart Class
FabricationPart Members


Create Method (Document, FabricationItemFile, ElementId)

[image]

Revit 2024 API
FabricationPart..::..Create Method (Document, FabricationItemFile, ElementId)
FabricationPart Class See Also Send Feedback
Creates a fabrication part element from a fabrication item file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public static FabricationPart Create(
    Document document,
    FabricationItemFile itemFile,
    ElementId levelId
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    itemFile As FabricationItemFile, _
    levelId As ElementId _
) As FabricationPart
Visual C++
public:
static FabricationPart^ Create(
    Document^ document,
    FabricationItemFile^ itemFile,
    ElementId^ levelId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
itemFile
Type: Autodesk.Revit.DB..::..FabricationItemFile
The fabrication item file.
levelId
Type: Autodesk.Revit.DB..::..ElementId
The element identifier associated with the Level the FabricationPart will be created on.

Return Value

The new fabrication part.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The item file is not valid for use in Revit. -or- The item file has not been loaded into the configuration. -or- The ElementId levelId is not a Level.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FabricationPart Class
Create Overload


Create Method (Document, FabricationServiceButton, Double, Double, ElementId)

[image]

Revit 2024 API
FabricationPart..::..Create Method (Document, FabricationServiceButton, Double, Double, ElementId)
FabricationPart Class See Also Send Feedback
Creates a fabrication part element based on button and size.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public static FabricationPart Create(
    Document document,
    FabricationServiceButton button,
    double width,
    double depth,
    ElementId levelId
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    button As FabricationServiceButton, _
    width As Double, _
    depth As Double, _
    levelId As ElementId _
) As FabricationPart
Visual C++
public:
static FabricationPart^ Create(
    Document^ document,
    FabricationServiceButton^ button,
    double width,
    double depth,
    ElementId^ levelId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
button
Type: Autodesk.Revit.DB..::..FabricationServiceButton
The fabrication service button to use. Matches button condition based on the specified size.
width
Type: System..::..Double
The width of the part. Units are in feet (ft).
depth
Type: System..::..Double
The depth of the part. Units are in feet (ft). It should be equal to width for round part.
levelId
Type: Autodesk.Revit.DB..::..ElementId
The element identifier associated with the Level the FabricationPart will be created on.

Return Value

The new fabrication part.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Fabrication service button contains invalid fittings. -or- Please use FabricationPart.CreateHanger to create fabrication hanger. -or- The ElementId levelId is not a Level.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The fabrication part type does not exist. Reload the service using FabricationConfiguration.LoadServices. -or- failing to match a button condition based on specific size.

See Also

FabricationPart Class
Create Overload


CreateHanger Method

[image] [image]

Revit 2024 API
FabricationPart..::..CreateHanger Method
FabricationPart Class See Also Send Feedback

Overload List

Name | Description
CreateHanger(Document, FabricationServiceButton, Int32, ElementId) | Creates a free placed hanger.
CreateHanger(Document, FabricationServiceButton, ElementId, Connector, Double, Boolean) | Creates a hanger on the fabrication part.
CreateHanger(Document, FabricationServiceButton, Int32, ElementId, Connector, Double, Boolean) | Creates a hanger on the fabrication part.

See Also

FabricationPart Class
FabricationPart Members


CreateHanger Method (Document, FabricationServiceButton, Int32, ElementId)

[image]

Revit 2024 API
FabricationPart..::..CreateHanger Method (Document, FabricationServiceButton, Int32, ElementId)
FabricationPart Class See Also Send Feedback
Creates a free placed hanger.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public static FabricationPart CreateHanger(
    Document document,
    FabricationServiceButton button,
    int condition,
    ElementId levelId
)
Visual Basic
Public Shared Function CreateHanger ( _
    document As Document, _
    button As FabricationServiceButton, _
    condition As Integer, _
    levelId As ElementId _
) As FabricationPart
Visual C++
public:
static FabricationPart^ CreateHanger(
    Document^ document,
    FabricationServiceButton^ button,
    int condition,
    ElementId^ levelId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
button
Type: Autodesk.Revit.DB..::..FabricationServiceButton
The fabrication service button to use.
condition
Type: System..::..Int32
The condition index. If the button has multiple conditions.
levelId
Type: Autodesk.Revit.DB..::..ElementId
The level identifier associated with the level.

Return Value

The newly-created fabrication hanger.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Invalid fabrication service button.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The index condition is not larger or equal to 0 and less than ConditionCount.

See Also

FabricationPart Class
CreateHanger Overload


CreateHanger Method (Document, FabricationServiceButton, ElementId, Connector, Double, Boolean)

[image]

Revit 2024 API
FabricationPart..::..CreateHanger Method (Document, FabricationServiceButton, ElementId, Connector, Double, Boolean)
FabricationPart Class See Also Send Feedback
Creates a hanger on the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public static FabricationPart CreateHanger(
    Document document,
    FabricationServiceButton button,
    ElementId hostId,
    Connector hostConnector,
    double distance,
    bool attachToStructure
)
Visual Basic
Public Shared Function CreateHanger ( _
    document As Document, _
    button As FabricationServiceButton, _
    hostId As ElementId, _
    hostConnector As Connector, _
    distance As Double, _
    attachToStructure As Boolean _
) As FabricationPart
Visual C++
public:
static FabricationPart^ CreateHanger(
    Document^ document,
    FabricationServiceButton^ button,
    ElementId^ hostId,
    Connector^ hostConnector,
    double distance,
    bool attachToStructure
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
button
Type: Autodesk.Revit.DB..::..FabricationServiceButton
The fabrication service button to use. It finds the matching condition automatically if the button has multiple condition.
hostId
Type: Autodesk.Revit.DB..::..ElementId
The host part id. The host should be one horizontal straight part.
hostConnector
Type: Autodesk.Revit.DB..::..Connector
The connector of the host.
distance
Type: System..::..Double
The distance from the input connector of the host part. Units are in feet (ft).
attachToStructure
Type: System..::..Boolean
Attach to the nearest structural element. The structural element might be one of Floor/Roof/Stair/Structure Framing.

Return Value

The newly-created fabrication hanger.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Hangers may only be placed on straight horizontal fabrication segments and some kind of fittings. -or- Invalid fabrication service button. -or- The distance is out of range.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | cannot place hanger on the host.

See Also

FabricationPart Class
CreateHanger Overload


CreateHanger Method (Document, FabricationServiceButton, Int32, ElementId, Connector, Double, Boolean)

[image]

Revit 2024 API
FabricationPart..::..CreateHanger Method (Document, FabricationServiceButton, Int32, ElementId, Connector, Double, Boolean)
FabricationPart Class See Also Send Feedback
Creates a hanger on the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public static FabricationPart CreateHanger(
    Document document,
    FabricationServiceButton button,
    int condition,
    ElementId hostId,
    Connector hostConnector,
    double distance,
    bool attachToStructure
)
Visual Basic
Public Shared Function CreateHanger ( _
    document As Document, _
    button As FabricationServiceButton, _
    condition As Integer, _
    hostId As ElementId, _
    hostConnector As Connector, _
    distance As Double, _
    attachToStructure As Boolean _
) As FabricationPart
Visual C++
public:
static FabricationPart^ CreateHanger(
    Document^ document,
    FabricationServiceButton^ button,
    int condition,
    ElementId^ hostId,
    Connector^ hostConnector,
    double distance,
    bool attachToStructure
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
button
Type: Autodesk.Revit.DB..::..FabricationServiceButton
The fabrication service button to use.
condition
Type: System..::..Int32
The condition index. If the button has multiple conditions.
hostId
Type: Autodesk.Revit.DB..::..ElementId
The host part id. The host should be one horizontal straight part.
hostConnector
Type: Autodesk.Revit.DB..::..Connector
The connector of the host.
distance
Type: System..::..Double
The distance from the input connector of the host part. Units are in feet (ft).
attachToStructure
Type: System..::..Boolean
Attach to the nearest structural element. The structural element might be one of Floor/Roof/Stair/Structural Framing.

Return Value

The newly-created fabrication hanger.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Hangers may only be placed on straight horizontal fabrication segments and some kind of fittings. -or- Invalid fabrication service button.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The index condition is not larger or equal to 0 and less than ConditionCount.
Autodesk.Revit.Exceptions..::..InvalidOperationException | the distance is out of range. -or- cannot find suitable fabrication part for the host. -or- cannot place hanger on the host.

See Also

FabricationPart Class
CreateHanger Overload


Flip Method

[image]

Revit 2024 API
FabricationPart..::..Flip Method
FabricationPart Class See Also Send Feedback
Flips the fabrication part that is directionally oriented (tees, crosses, valves, dampers, etc.) to the opposite direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public bool Flip()
Visual Basic
Public Function Flip As Boolean
Visual C++
public:
bool Flip()

Return Value

Returns true if successful otherwise false if the fabrication part cannot be flipped.

Remarks

Existing connections will be maintained, disconnect warnings will be posted if the connection cannot be maintained.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | It is not a valid part that can be flipped.

See Also

FabricationPart Class


GetCalculatedDimensionValue Method

[image]

Revit 2024 API
FabricationPart..::..GetCalculatedDimensionValue Method
FabricationPart Class See Also Send Feedback
Gets the calculated dimension value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public string GetCalculatedDimensionValue(
    FabricationDimensionDefinition dim
)
Visual Basic
Public Function GetCalculatedDimensionValue ( _
    dim As FabricationDimensionDefinition _
) As String
Visual C++
public:
String^ GetCalculatedDimensionValue(
    FabricationDimensionDefinition^ dim
)

Parameters

dim
Type: Autodesk.Revit.DB..::..FabricationDimensionDefinition
The fabrication dimension.

Return Value

The calculated dimension value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FabricationPart Class


GetDimensionCalculatedOptions Method

[image]

Revit 2024 API
FabricationPart..::..GetDimensionCalculatedOptions Method
FabricationPart Class See Also Send Feedback
Gets the calculated options of the fabrication dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public IList<string> GetDimensionCalculatedOptions(
    FabricationDimensionDefinition dim
)
Visual Basic
Public Function GetDimensionCalculatedOptions ( _
    dim As FabricationDimensionDefinition _
) As IList(Of String)
Visual C++
public:
IList<String^>^ GetDimensionCalculatedOptions(
    FabricationDimensionDefinition^ dim
)

Parameters

dim
Type: Autodesk.Revit.DB..::..FabricationDimensionDefinition
The fabrication dimension.

Return Value

The calculated options of the fabrication dimension.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FabricationPart Class


GetPartCustomDataInteger Method

[image]

Revit 2024 API
FabricationPart..::..GetPartCustomDataInteger Method
FabricationPart Class See Also Send Feedback
Get custom data integer value for the specified custom data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update

Syntax

C#
public int GetPartCustomDataInteger(
    int customId
)
Visual Basic
Public Function GetPartCustomDataInteger ( _
    customId As Integer _
) As Integer
Visual C++
public:
int GetPartCustomDataInteger(
    int customId
)

Parameters

customId
Type: System..::..Int32
The identifier of the custom data field to get.

Return Value

Returns the integer of the custom data. If the data is not a number it will return 0.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The custom data does not exist on the part.

See Also

FabricationPart Class


GetPartCustomDataReal Method

[image]

Revit 2024 API
FabricationPart..::..GetPartCustomDataReal Method
FabricationPart Class See Also Send Feedback
Get custom data real value for the specified custom data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update

Syntax

C#
public double GetPartCustomDataReal(
    int customId
)
Visual Basic
Public Function GetPartCustomDataReal ( _
    customId As Integer _
) As Double
Visual C++
public:
double GetPartCustomDataReal(
    int customId
)

Parameters

customId
Type: System..::..Int32
The identifier of the custom data field to get.

Return Value

Returns the real number of the custom data. If the data is not a number it will return 0.0.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The custom data does not exist on the part.

See Also

FabricationPart Class


GetPartCustomDataText Method

[image]

Revit 2024 API
FabricationPart..::..GetPartCustomDataText Method
FabricationPart Class See Also Send Feedback
Get custom data text for the specified custom data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update

Syntax

C#
public string GetPartCustomDataText(
    int customId
)
Visual Basic
Public Function GetPartCustomDataText ( _
    customId As Integer _
) As String
Visual C++
public:
String^ GetPartCustomDataText(
    int customId
)

Parameters

customId
Type: System..::..Int32
The identifier of the custom data field to get.

Return Value

Returns the text of the custom data. If the data is a number it will be formatted according to the fabrication configuration's rules.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The custom data does not exist on the part.

See Also

FabricationPart Class


GetProductListEntryCount Method

[image]

Revit 2024 API
FabricationPart..::..GetProductListEntryCount Method
FabricationPart Class See Also Send Feedback
Gets the number of product entries for this part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Release

Syntax

C#
public int GetProductListEntryCount()
Visual Basic
Public Function GetProductListEntryCount As Integer
Visual C++
public:
int GetProductListEntryCount()

Return Value

Returns the number of product entries.

See Also

FabricationPart Class


GetProductListEntryName Method

[image]

Revit 2024 API
FabricationPart..::..GetProductListEntryName Method
FabricationPart Class See Also Send Feedback
Gets the specified product list entry name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Release

Syntax

C#
public string GetProductListEntryName(
    int index
)
Visual Basic
Public Function GetProductListEntryName ( _
    index As Integer _
) As String
Visual C++
public:
String^ GetProductListEntryName(
    int index
)

Parameters

index
Type: System..::..Int32
The product entry index.

Return Value

Returns the specified product entry name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The product entry index is not larger than 0 and less than GetProductCount.

See Also

FabricationPart Class


GetTransform Method

[image]

Revit 2024 API
FabricationPart..::..GetTransform Method
FabricationPart Class See Also Send Feedback
Gets the transformation matrix of the fabrication part element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public Transform GetTransform()
Visual Basic
Public Function GetTransform As Transform
Visual C++
public:
Transform^ GetTransform()

Return Value

The transformation matrix of the fabrication part element.

See Also

FabricationPart Class


GetVersionHistory Method

[image]

Revit 2024 API
FabricationPart..::..GetVersionHistory Method
FabricationPart Class See Also Send Feedback
Gets a history of version change information about the current part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public IList<FabricationVersionInfo> GetVersionHistory()
Visual Basic
Public Function GetVersionHistory As IList(Of FabricationVersionInfo)
Visual C++
public:
IList<FabricationVersionInfo^>^ GetVersionHistory()

Return Value

A list of version information about the current part. The list starts with the most recent changes.

See Also

FabricationPart Class


HasCustomData Method

[image]

Revit 2024 API
FabricationPart..::..HasCustomData Method
FabricationPart Class See Also Send Feedback
Check if fabrication part contains custom data already.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update

Syntax

C#
public bool HasCustomData(
    int customId
)
Visual Basic
Public Function HasCustomData ( _
    customId As Integer _
) As Boolean
Visual C++
public:
bool HasCustomData(
    int customId
)

Parameters

customId
Type: System..::..Int32
The identifier of the custom data field to look for.

Return Value

Returns true if the fabrication part contains the custom data.

See Also

FabricationPart Class


HasNoConnections Method

[image]

Revit 2024 API
FabricationPart..::..HasNoConnections Method
FabricationPart Class See Also Send Feedback
Checks to see if all the fabrication part's connectors are open.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public bool HasNoConnections()
Visual Basic
Public Function HasNoConnections As Boolean
Visual C++
public:
bool HasNoConnections()

Return Value

Returns true if the part has zero connections.

See Also

FabricationPart Class


IsAHanger Method

[image]

Revit 2024 API
FabricationPart..::..IsAHanger Method
FabricationPart Class See Also Send Feedback
Checks whether it is a hanger.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool IsAHanger()
Visual Basic
Public Function IsAHanger As Boolean
Visual C++
public:
bool IsAHanger()

Return Value

True if the part is a hanger. False otherwise.

See Also

FabricationPart Class


IsAStraight Method

[image]

Revit 2024 API
FabricationPart..::..IsAStraight Method
FabricationPart Class See Also Send Feedback
Checks whether it is a straight part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool IsAStraight()
Visual Basic
Public Function IsAStraight As Boolean
Visual C++
public:
bool IsAStraight()

Return Value

True if the part is a straight part. False otherwise.

See Also

FabricationPart Class


IsDimensionCalculated Method

[image]

Revit 2024 API
FabricationPart..::..IsDimensionCalculated Method
FabricationPart Class See Also Send Feedback
Checks if the fabrication dimension is calculated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool IsDimensionCalculated(
    FabricationDimensionDefinition dim
)
Visual Basic
Public Function IsDimensionCalculated ( _
    dim As FabricationDimensionDefinition _
) As Boolean
Visual C++
public:
bool IsDimensionCalculated(
    FabricationDimensionDefinition^ dim
)

Parameters

dim
Type: Autodesk.Revit.DB..::..FabricationDimensionDefinition
The fabrication dimension.

Return Value

True if the fabrication dimension is calculated.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FabricationPart Class


IsProductList Method

[image]

Revit 2024 API
FabricationPart..::..IsProductList Method
FabricationPart Class See Also Send Feedback
Gets whether or not the fabrication part is a product list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Release

Syntax

C#
public bool IsProductList()
Visual Basic
Public Function IsProductList As Boolean
Visual C++
public:
bool IsProductList()

Return Value

Returns true if the fabrication part is a product list.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | the fabrication part is not a product list.

See Also

FabricationPart Class


IsSameAs Method

[image]

Revit 2024 API
FabricationPart..::..IsSameAs Method
FabricationPart Class See Also Send Feedback
Compare this fabrication part with the part passed and checks the pattern dimensions and options. A list of fields that can be ignored in the comparison check can be specified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public bool IsSameAs(
    FabricationPart part,
    IList<FabricationPartCompareType> ignoreFields
)
Visual Basic
Public Function IsSameAs ( _
    part As FabricationPart, _
    ignoreFields As IList(Of FabricationPartCompareType) _
) As Boolean
Visual C++
public:
bool IsSameAs(
    FabricationPart^ part,
    IList<FabricationPartCompareType>^ ignoreFields
)

Parameters

part
Type: Autodesk.Revit.DB..::..FabricationPart
The part to compare this part with.
ignoreFields
Type: System.Collections.Generic..::..IList<(Of <(<' FabricationPartCompareType >)>)>
Array of types of data to ignore from the comparison check.

Return Value

Returns true if the fabrication parts are the same.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FabricationPart Class


OptimizeLengths Method

[image]

Revit 2024 API
FabricationPart..::..OptimizeLengths Method
FabricationPart Class See Also Send Feedback
Optimizes the length fabrication straight parts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public static ISet<ElementId> OptimizeLengths(
    Document document,
    ISet<ElementId> partIds
)
Visual Basic
Public Shared Function OptimizeLengths ( _
    document As Document, _
    partIds As ISet(Of ElementId) _
) As ISet(Of ElementId)
Visual C++
public:
static ISet<ElementId^>^ OptimizeLengths(
    Document^ document,
    ISet<ElementId^>^ partIds
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
partIds
Type: System.Collections.Generic..::..ISet<(Of <(<' ElementId >)>)>
The identifiers of the fabrication parts in a selected fabrication part run.

Return Value

New and modified fabrication part ids in the optimize

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | There are no straight parts to optimize, or all parts are locked or locked by group membership.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | this operation failed.

See Also

FabricationPart Class


PlaceFittingAsCutIn Method

[image]

Revit 2024 API
FabricationPart..::..PlaceFittingAsCutIn Method
FabricationPart Class See Also Send Feedback
Places the fitting on the straight part by cut in, use the fitting's focal point as the insertion position.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public static bool PlaceFittingAsCutIn(
    Document document,
    ElementId straightId,
    ElementId fittingId,
    XYZ position,
    Connector fittingConnector,
    double axisRotation
)
Visual Basic
Public Shared Function PlaceFittingAsCutIn ( _
    document As Document, _
    straightId As ElementId, _
    fittingId As ElementId, _
    position As XYZ, _
    fittingConnector As Connector, _
    axisRotation As Double _
) As Boolean
Visual C++
public:
static bool PlaceFittingAsCutIn(
    Document^ document,
    ElementId^ straightId,
    ElementId^ fittingId,
    XYZ^ position,
    Connector^ fittingConnector,
    double axisRotation
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
straightId
Type: Autodesk.Revit.DB..::..ElementId
Identifier of the straight to be cut in.
fittingId
Type: Autodesk.Revit.DB..::..ElementId
Identifier of the fitting to cut in.
position
Type: Autodesk.Revit.DB..::..XYZ
The position to cut in the straight.
fittingConnector
Type: Autodesk.Revit.DB..::..Connector
The connector of the fitting to align with the primary connector of the straight part.
axisRotation
Type: System..::..Double
Rotation around the direction of connection - angle between width vectors in radians.

Return Value

True if cuts in successful.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | For rectangular and oval parts the axis rotation must be a multiple of PI/2. -or- The fitting connector is not a connector of the fitting. -or- The fitting connector is not valid, it is not within a pair connector for cutting in.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | Failed to align fitting to the straight to cut in. -or- There is no enough room in the run for cut in.

See Also

FabricationPart Class


Reposition Method

[image]

Revit 2024 API
FabricationPart..::..Reposition Method
FabricationPart Class See Also Send Feedback
Repositions the fabrication straight part to another end of the run.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public static void Reposition(
    Document document,
    ElementId partId
)
Visual Basic
Public Shared Sub Reposition ( _
    document As Document, _
    partId As ElementId _
)
Visual C++
public:
static void Reposition(
    Document^ document,
    ElementId^ partId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
partId
Type: Autodesk.Revit.DB..::..ElementId
Identifier of the fabrication part to reposition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | It is not a straight segment on the end in the run. -or- There are locked parts in the run.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | this operation failed.

See Also

FabricationPart Class


RotateConnectedPartByConnector Method

[image]

Revit 2024 API
FabricationPart..::..RotateConnectedPartByConnector Method
FabricationPart Class See Also Send Feedback
Rotates a connected fabrication part around the axis of the specified connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Release

Syntax

C#
public static void RotateConnectedPartByConnector(
    Document document,
    Connector connector,
    double axisRotationBy
)
Visual Basic
Public Shared Sub RotateConnectedPartByConnector ( _
    document As Document, _
    connector As Connector, _
    axisRotationBy As Double _
)
Visual C++
public:
static void RotateConnectedPartByConnector(
    Document^ document,
    Connector^ connector,
    double axisRotationBy
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
connector
Type: Autodesk.Revit.DB..::..Connector
The connected connector of the fabrication part to be rotated.
axisRotationBy
Type: System..::..Double
The angle in radians to rotate by.

Remarks

Attempts to resize rectangular and oval ends if the angle is a multiple of PI/2. Taps cannot be rotated. For rectangular and oval profiles only 90, 180 and 270 degree rotations are valid.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | For rectangular and oval parts the axis rotation must be a multiple of PI/2. -or- The connector does not belong to a fabrication part. -or- Connector is not connected. -or- Connector belongs to a fabrication part tap. -or- Fabrication part cannot be rotated because it is either unable to be re-sized or it is too constrained.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | rotate failed because the fabrication part geometry could not be modified accordingly.

See Also

FabricationPart Class


RotateConnectedTap Method

[image]

Revit 2024 API
FabricationPart..::..RotateConnectedTap Method
FabricationPart Class See Also Send Feedback
Rotates a connected fabrication tap by the specified angles about the primary and secondary axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Release

Syntax

C#
public static void RotateConnectedTap(
    Document document,
    FabricationPart tap,
    double primaryAxisRotateBy,
    double secondaryAxisRotateBy
)
Visual Basic
Public Shared Sub RotateConnectedTap ( _
    document As Document, _
    tap As FabricationPart, _
    primaryAxisRotateBy As Double, _
    secondaryAxisRotateBy As Double _
)
Visual C++
public:
static void RotateConnectedTap(
    Document^ document,
    FabricationPart^ tap,
    double primaryAxisRotateBy,
    double secondaryAxisRotateBy
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
tap
Type: Autodesk.Revit.DB..::..FabricationPart
The connected fabrication part tap to rotate.
primaryAxisRotateBy
Type: System..::..Double
The primary axis rotation angle in radians to rotate by.
secondaryAxisRotateBy
Type: System..::..Double
The secondary axis rotation angle in radians to rotate by.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Is not connected as a fabrication part tap. -or- tap cannot be rotated about the primary axis by the specified angle: primaryAxisRotateBy -or- tap cannot be rotated about the secondary axis by the specified angle: secondaryAxisRotateBy
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FabricationPart Class


SaveAsFabricationJob Method

[image]

Revit 2024 API
FabricationPart..::..SaveAsFabricationJob Method
FabricationPart Class See Also Send Feedback
Save fabrication parts to an MEP job that can be opened in the fabrication software.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public static ISet<ElementId> SaveAsFabricationJob(
    Document document,
    ISet<ElementId> ids,
    string filename,
    FabricationSaveJobOptions saveOptions
)
Visual Basic
Public Shared Function SaveAsFabricationJob ( _
    document As Document, _
    ids As ISet(Of ElementId), _
    filename As String, _
    saveOptions As FabricationSaveJobOptions _
) As ISet(Of ElementId)
Visual C++
public:
static ISet<ElementId^>^ SaveAsFabricationJob(
    Document^ document,
    ISet<ElementId^>^ ids,
    String^ filename,
    FabricationSaveJobOptions^ saveOptions
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
ids
Type: System.Collections.Generic..::..ISet<(Of <(<' ElementId >)>)>
List of element Ids of fabrication parts or assemblies and group elements that contain fabrication parts to save. Non-fabrication part elements will be ignored.
filename
Type: System..::..String
The full path and filename of the fabrication job to save.
saveOptions
Type: Autodesk.Revit.DB.Fabrication..::..FabricationSaveJobOptions
Options for the save operation.

Return Value

Returns a list of fabrication part element Ids that were saved to the fabrication job.

Remarks

Only fabrication MAJ files are supported.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Fabrication configuration is missing.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | the path to the filename must already exist and be writeable
Autodesk.Revit.Exceptions..::..InvalidPathArgumentException | The destination file name includes one or more invalid characters.

See Also

FabricationPart Class


SetCalculatedDimensionValue Method

[image]

Revit 2024 API
FabricationPart..::..SetCalculatedDimensionValue Method
FabricationPart Class See Also Send Feedback
Sets the calculated dimension value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public void SetCalculatedDimensionValue(
    FabricationDimensionDefinition dim,
    string value
)
Visual Basic
Public Sub SetCalculatedDimensionValue ( _
    dim As FabricationDimensionDefinition, _
    value As String _
)
Visual C++
public:
void SetCalculatedDimensionValue(
    FabricationDimensionDefinition^ dim,
    String^ value
)

Parameters

dim
Type: Autodesk.Revit.DB..::..FabricationDimensionDefinition
The fabrication dimension.
value
Type: System..::..String
The calculated dimension value.

Remarks

Multiple dimensions may need to be set in order to reach the desired outcome. The document must be regenerated before the fabrication part can be used. Check ValidationStatus after regeneration to see if the part is valid for fabrication.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | value is not a valid calculated fabrication dimension value. -or- fabrication dimension is unable to be modified because it is locked or from a product list. -or- the fabrication dimension is unable to be modified because it will affect the geometry of a connected end.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | the fabrication dimension is unable to be modified because the fabrication part is connected to more than one object. -or- the fabrication dimension cannot be set to the option: value.

See Also

FabricationPart Class


SetDimensionValue Method

[image]

Revit 2024 API
FabricationPart..::..SetDimensionValue Method
FabricationPart Class See Also Send Feedback
Sets the fabrication dimension value. The value is in Revit internal units.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public void SetDimensionValue(
    FabricationDimensionDefinition dim,
    double newValue
)
Visual Basic
Public Sub SetDimensionValue ( _
    dim As FabricationDimensionDefinition, _
    newValue As Double _
)
Visual C++
public:
void SetDimensionValue(
    FabricationDimensionDefinition^ dim,
    double newValue
)

Parameters

dim
Type: Autodesk.Revit.DB..::..FabricationDimensionDefinition
The fabrication dimension.
newValue
Type: System..::..Double
The dimension value.

Remarks

Multiple dimensions may need to be set in order to reach the desired outcome. The document must be regenerated before the fabrication part can be used. Check ValidationStatus after regeneration to see if the part is valid for fabrication.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | fabrication dimension is unable to be modified because it is locked or from a product list. -or- the fabrication dimension is unable to be modified because it will affect the geometry of a connected end.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | the fabrication dimension is unable to be modified because the fabrication part is connected to more than one object. -or- the fabrication dimension cannot be set to the value: newValue.

See Also

FabricationPart Class


SetPartCustomDataInteger Method

[image]

Revit 2024 API
FabricationPart..::..SetPartCustomDataInteger Method
FabricationPart Class See Also Send Feedback
Set the custom data integer value for the specified custom data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public void SetPartCustomDataInteger(
    int customId,
    int value
)
Visual Basic
Public Sub SetPartCustomDataInteger ( _
    customId As Integer, _
    value As Integer _
)
Visual C++
public:
void SetPartCustomDataInteger(
    int customId,
    int value
)

Parameters

customId
Type: System..::..Int32
The identifier of the custom data field to set.
value
Type: System..::..Int32
The integer value of the custom data. If the data is not an integer type the value will be parsed according to the fabrication confifuration rules.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The custom data does not exist on the part.

See Also

FabricationPart Class


SetPartCustomDataReal Method

[image]

Revit 2024 API
FabricationPart..::..SetPartCustomDataReal Method
FabricationPart Class See Also Send Feedback
Set the custom data real value for the specified custom data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public void SetPartCustomDataReal(
    int customId,
    double value
)
Visual Basic
Public Sub SetPartCustomDataReal ( _
    customId As Integer, _
    value As Double _
)
Visual C++
public:
void SetPartCustomDataReal(
    int customId,
    double value
)

Parameters

customId
Type: System..::..Int32
The identifier of the custom data field to set.
value
Type: System..::..Double
The real value of the custom data. If the data is not a real type the value will be parsed according to the fabrication confifuration rules.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The custom data does not exist on the part.

See Also

FabricationPart Class


SetPartCustomDataText Method

[image]

Revit 2024 API
FabricationPart..::..SetPartCustomDataText Method
FabricationPart Class See Also Send Feedback
Set the custom data real value for the specified custom data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update

Syntax

C#
public void SetPartCustomDataText(
    int customId,
    string value
)
Visual Basic
Public Sub SetPartCustomDataText ( _
    customId As Integer, _
    value As String _
)
Visual C++
public:
void SetPartCustomDataText(
    int customId,
    String^ value
)

Parameters

customId
Type: System..::..Int32
The identifier of the custom data field to set.
value
Type: System..::..String
The text value of the custom data. If the data is not a text type the value will be parsed according to the fabrication confifuration rules.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The custom data does not exist on the part.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FabricationPart Class


SetPositionByEnd Method

[image]

Revit 2024 API
FabricationPart..::..SetPositionByEnd Method
FabricationPart Class See Also Send Feedback
Positions the connector of the fabrication part element by the passed point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public void SetPositionByEnd(
    Connector connector,
    XYZ position
)
Visual Basic
Public Sub SetPositionByEnd ( _
    connector As Connector, _
    position As XYZ _
)
Visual C++
public:
void SetPositionByEnd(
    Connector^ connector,
    XYZ^ position
)

Parameters

connector
Type: Autodesk.Revit.DB..::..Connector
The connector of the fabrication part element.
position
Type: Autodesk.Revit.DB..::..XYZ
The position to move to.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | this operation failed.

See Also

FabricationPart Class


SplitStraight Method

[image] [image]

Revit 2024 API
FabricationPart..::..SplitStraight Method
FabricationPart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SplitStraight(XYZ) | Splits the straight into two at the passed in point.
Public method | SplitStraight(Document, ElementId, XYZ) | Splits the straight into two at the passed in point.

See Also

FabricationPart Class
FabricationPart Members


SplitStraight Method (XYZ)

[image]

Revit 2024 API
FabricationPart..::..SplitStraight Method (XYZ)
FabricationPart Class See Also Send Feedback
Splits the straight into two at the passed in point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public ElementId SplitStraight(
    XYZ position
)
Visual Basic
Public Function SplitStraight ( _
    position As XYZ _
) As ElementId
Visual C++
public:
ElementId^ SplitStraight(
    XYZ^ position
)

Parameters

position
Type: Autodesk.Revit.DB..::..XYZ
The position to split in the straight.

Return Value

Returns the element identifier of the new straight.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The position is not on the straight.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The part is not a straight.

See Also

FabricationPart Class
SplitStraight Overload


SplitStraight Method (Document, ElementId, XYZ)

[image]

Revit 2024 API
FabricationPart..::..SplitStraight Method (Document, ElementId, XYZ)
FabricationPart Class See Also Send Feedback
Splits the straight into two at the passed in point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update

Syntax

C#
public ElementId SplitStraight(
    Document document,
    ElementId partId,
    XYZ position
)
Visual Basic
Public Function SplitStraight ( _
    document As Document, _
    partId As ElementId, _
    position As XYZ _
) As ElementId
Visual C++
public:
ElementId^ SplitStraight(
    Document^ document,
    ElementId^ partId,
    XYZ^ position
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
partId
Type: Autodesk.Revit.DB..::..ElementId
Identifier of the straight to split.
position
Type: Autodesk.Revit.DB..::..XYZ
The position to split in the straight.

Return Value

Returns the element identifier of the new straight.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The part is not a straight. -or- The position is not on the straight.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FabricationPart Class
SplitStraight Overload


StretchAndFit Method

[image]

Revit 2024 API
FabricationPart..::..StretchAndFit Method
FabricationPart Class See Also Send Feedback
Stretch the fabrication part from the specified connector and fit to the target routing end.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public static FabricationPartFitResult StretchAndFit(
    Document document,
    Connector stretchConnector,
    FabricationPartRouteEnd target,
    out ISet<ElementId> newPartIds
)
Visual Basic
Public Shared Function StretchAndFit ( _
    document As Document, _
    stretchConnector As Connector, _
    target As FabricationPartRouteEnd, _
    <OutAttribute> ByRef newPartIds As ISet(Of ElementId) _
) As FabricationPartFitResult
Visual C++
public:
static FabricationPartFitResult StretchAndFit(
    Document^ document,
    Connector^ stretchConnector,
    FabricationPartRouteEnd^ target,
    [OutAttribute] ISet<ElementId^>^% newPartIds
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which to perform the stretch and fit.
stretchConnector
Type: Autodesk.Revit.DB..::..Connector
The connector of the fabrication part to be stretched.
target
Type: Autodesk.Revit.DB.Fabrication..::..FabricationPartRouteEnd
The target routing end to align and fit to.
newPartIds
Type: System.Collections.Generic..::..ISet<(Of <(<' ElementId >)>)>%
New fabrication part element identifiers.

Return Value

Returns FabricationPartFitResult::Success if successful.

Remarks

Cannot stretch and fit fabrication part straight, tap or hanger.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Connector does not belong to a fabrication part with a valid fabrication service. -or- Connector is connected. -or- Connector belongs to a fabrication part straight, tap, or hanger. -or- Routing end is valid to route to. -or- stretch target end type must be a supported type.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | fabrication part is not connected at one end only. -or- cannot stretch fabrication part to a different service.

See Also

FabricationPart Class


FabricationPart Properties

[image] [image]

Revit 2024 API
FabricationPart Properties
FabricationPart Class See Also Send Feedback

The FabricationPart type exposes the following members.

Properties

 | Name | Description
Public property | Alias | The alias of the fabrication part.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BottomOfPartElevation | The associated elevation to the bottom of fabrication part off of the current level.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterlineLength | The centerline length of the fabrication part.
Public property | ConnectorManager | The connector manager of the fabrication part.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CutType | The cut type of the fabrication part.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | DomainType | The domain type for the fabrication part.
Public property | DoubleWallMaterial | The double wall material identifier of the fabrication part.
Public property | DoubleWallMaterialArea | The double wall material area of the fabrication part. If the fabrication part is not double walled, returns zero.
Public property | DoubleWallMaterialThickness | The double wall material thickness of the fabrication part. If the fabrication part is not double walled, returns zero.
Public property | FreeSize | The inner size of the fabrication part.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryChecksum | Gets the geometry checksum of the fabrication part symbol, and it does nothing with the fabrication part instance position.
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | HangerRodKit | Specifies whether an ancillary kit is being used to override support rods, bolts and clips, if any. A value of 0 indicates no override is being used.
Public property | HasDoubleWall | True if the fabrication part is double walled.
Public property | HasInsulation | True if the fabrication part is insulated.
Public property | HasLining | True if the fabrication part is lined.
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | InsulationArea | The insulation area of the fabrication part. If the fabrication part is not insulated, returns zero.
Public property | InsulationSpecification | The fabrication part insulation specification identifier.
Public property | InsulationThickness | The insulation thickness of the fabrication part. If the fabrication part is not insulated, returns zero.
Public property | InsulationType | The insulation type of the fabrication part.
Public property | IsBoughtOut | True if the fabrication part is bought out.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | ItemCustomId | The item custom identifier for the fabrication part.
Public property | ItemNumber | The item number that is used for identification, re-ordering from shop.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | LevelOffset | The associated level offset that indicates the distance from the center of the fabrication part to the current level.
Public property | LiningArea | The lining area of the fabrication part. If the fabrication part is not lined, returns zero.
Public property | LiningThickness | The lining thickness of the fabrication part. If the fabrication part is not lined, returns zero.
Public property | LiningType | The lining type of the fabrication part.
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Material | The fabrication material identifier.
Public property | MaterialGauge | The fabrication material gauge identifier.
Public property | MaterialThickness | The material thickness of the fabrication part.
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Notes | The notes of the fabrication part.
Public property | Origin | The origin of the fabrication part element.
Public property | OverallSize | The overall size of the fabrication part.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PartGuid | The fabrication part's globally unique identifier.
Public property | PartStatus | The status identifier for the fabrication part.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ProductCode | The current database id of the part within the fabrication database.
Public property | ProductDataRange | The product data range of the fabrication part.
Public property | ProductFinishDescription | The product finish description of the fabrication part.
Public property | ProductInstallType | The product install type of the fabrication part.
Public property | ProductListEntry | The product entry index of the fabrication part. A value of -1 indicates the fabrication part is not a product list.
Public property | ProductLongDescription | The product long description of the fabrication part.
Public property | ProductMaterialDescription | The product material description of the fabrication part.
Public property | ProductName | The product name of the fabrication part.
Public property | ProductOriginalEquipmentManufacture | The product original equipment manufacture (OEM) of the fabrication part.
Public property | ProductShortDescription | The product short description of the fabrication part.
Public property | ProductSizeDescription | The product size description of the fabrication part.
Public property | ProductSpecificationDescription | The product specification description of the fabrication part.
Public property | ServiceAbbreviation | The associated service abbreviation for the fabrication service.
Public property | ServiceId | The fabrication part service identifier. The service can only be changed to compatible services.
Public property | ServiceName | The name of the service associated with the fabrication part.
Public property | ServiceType | The service type identifier of the fabrication part.
Public property | SheetMetalArea | The sheet metal area of the fabrication part.
Public property | Size | The size of the fabrication part.
Public property | Slope | The slope for the straight fabrication part.
Public property | Specification | The fabrication part specification identifier.
Public property | SpoolName | The spool name of the fabrication part.
Public property | TopOfPartElevation | The associated elevation to the top of fabrication part off of the current level.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ValidationStatus | The validation status of the fabrication part.
Public property | Vendor | The vendor of the fabrication part.
Public property | VendorCode | The vendor code of the fabrication part.
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Weight | The weight of the fabrication part.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FabricationPart Class


Alias Property

[image]

Revit 2024 API
FabricationPart..::..Alias Property
FabricationPart Class See Also Send Feedback
The alias of the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public string Alias { get; }
Visual Basic
Public ReadOnly Property Alias As String
    Get
Visual C++
public:
property String^ Alias {
    String^ get ();
}

See Also

FabricationPart Class


BottomOfPartElevation Property

[image]

Revit 2024 API
FabricationPart..::..BottomOfPartElevation Property
FabricationPart Class See Also Send Feedback
The associated elevation to the bottom of fabrication part off of the current level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public double BottomOfPartElevation { get; }
Visual Basic
Public ReadOnly Property BottomOfPartElevation As Double
    Get
Visual C++
public:
property double BottomOfPartElevation {
    double get ();
}

See Also

FabricationPart Class


ConnectorManager Property

[image]

Revit 2024 API
FabricationPart..::..ConnectorManager Property
FabricationPart Class See Also Send Feedback
The connector manager of the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public ConnectorManager ConnectorManager { get; }
Visual Basic
Public ReadOnly Property ConnectorManager As ConnectorManager
    Get
Visual C++
public:
property ConnectorManager^ ConnectorManager {
    ConnectorManager^ get ();
}

See Also

FabricationPart Class


DomainType Property

[image]

Revit 2024 API
FabricationPart..::..DomainType Property
FabricationPart Class See Also Send Feedback
The domain type for the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public ConnectorDomainType DomainType { get; }
Visual Basic
Public ReadOnly Property DomainType As ConnectorDomainType
    Get
Visual C++
public:
property ConnectorDomainType DomainType {
    ConnectorDomainType get ();
}

See Also

FabricationPart Class


DoubleWallMaterial Property

[image]

Revit 2024 API
FabricationPart..::..DoubleWallMaterial Property
FabricationPart Class See Also Send Feedback
The double wall material identifier of the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public int DoubleWallMaterial { get; }
Visual Basic
Public ReadOnly Property DoubleWallMaterial As Integer
    Get
Visual C++
public:
property int DoubleWallMaterial {
    int get ();
}

See Also

FabricationPart Class


DoubleWallMaterialThickness Property

[image]

Revit 2024 API
FabricationPart..::..DoubleWallMaterialThickness Property
FabricationPart Class See Also Send Feedback
The double wall material thickness of the fabrication part. If the fabrication part is not double walled, returns zero.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public double DoubleWallMaterialThickness { get; }
Visual Basic
Public ReadOnly Property DoubleWallMaterialThickness As Double
    Get
Visual C++
public:
property double DoubleWallMaterialThickness {
    double get ();
}

See Also

FabricationPart Class


GeometryChecksum Property

[image]

Revit 2024 API
FabricationPart..::..GeometryChecksum Property
FabricationPart Class See Also Send Feedback
Gets the geometry checksum of the fabrication part symbol, and it does nothing with the fabrication part instance position.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018.2

Syntax

C#
public AssetPropertyUInt64 GeometryChecksum { get; }
Visual Basic
Public ReadOnly Property GeometryChecksum As AssetPropertyUInt64
    Get
Visual C++
public:
property AssetPropertyUInt64^ GeometryChecksum {
    AssetPropertyUInt64^ get ();
}

See Also

FabricationPart Class


HangerRodKit Property

[image]

Revit 2024 API
FabricationPart..::..HangerRodKit Property
FabricationPart Class See Also Send Feedback
Specifies whether an ancillary kit is being used to override support rods, bolts and clips, if any. A value of 0 indicates no override is being used.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update

Syntax

C#
public int HangerRodKit { get; set; }
Visual Basic
Public Property HangerRodKit As Integer
    Get
    Set
Visual C++
public:
property int HangerRodKit {
    int get ();
    void set (int value);
}

Remarks

For hangers only. Setting an invalid hanger rod kit will result in the property being unchanged.

See Also

FabricationPart Class


HasDoubleWall Property

[image]

Revit 2024 API
FabricationPart..::..HasDoubleWall Property
FabricationPart Class See Also Send Feedback
True if the fabrication part is double walled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public bool HasDoubleWall { get; }
Visual Basic
Public ReadOnly Property HasDoubleWall As Boolean
    Get
Visual C++
public:
property bool HasDoubleWall {
    bool get ();
}

See Also

FabricationPart Class


HasInsulation Property

[image]

Revit 2024 API
FabricationPart..::..HasInsulation Property
FabricationPart Class See Also Send Feedback
True if the fabrication part is insulated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public bool HasInsulation { get; }
Visual Basic
Public ReadOnly Property HasInsulation As Boolean
    Get
Visual C++
public:
property bool HasInsulation {
    bool get ();
}

See Also

FabricationPart Class


HasLining Property

[image]

Revit 2024 API
FabricationPart..::..HasLining Property
FabricationPart Class See Also Send Feedback
True if the fabrication part is lined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public bool HasLining { get; }
Visual Basic
Public ReadOnly Property HasLining As Boolean
    Get
Visual C++
public:
property bool HasLining {
    bool get ();
}

See Also

FabricationPart Class


InsulationSpecification Property

[image]

Revit 2024 API
FabricationPart..::..InsulationSpecification Property
FabricationPart Class See Also Send Feedback
The fabrication part insulation specification identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public int InsulationSpecification { get; set; }
Visual Basic
Public Property InsulationSpecification As Integer
    Get
    Set
Visual C++
public:
property int InsulationSpecification {
    int get ();
    void set (int value);
}

Remarks

A value of 0 indicates the insulation specification is set to off.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: the insulation specification is invalid for the fabrication part.
Autodesk.Revit.Exceptions..::..InvalidOperationException | -or- When setting this property: the fabrication part has taps connected. -or- When setting this property: the specification fails to be set by identifier: specId.

See Also

FabricationPart Class


InsulationThickness Property

[image]

Revit 2024 API
FabricationPart..::..InsulationThickness Property
FabricationPart Class See Also Send Feedback
The insulation thickness of the fabrication part. If the fabrication part is not insulated, returns zero.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public double InsulationThickness { get; }
Visual Basic
Public ReadOnly Property InsulationThickness As Double
    Get
Visual C++
public:
property double InsulationThickness {
    double get ();
}

See Also

FabricationPart Class


InsulationType Property

[image]

Revit 2024 API
FabricationPart..::..InsulationType Property
FabricationPart Class See Also Send Feedback
The insulation type of the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public string InsulationType { get; }
Visual Basic
Public ReadOnly Property InsulationType As String
    Get
Visual C++
public:
property String^ InsulationType {
    String^ get ();
}

See Also

FabricationPart Class


IsBoughtOut Property

[image]

Revit 2024 API
FabricationPart..::..IsBoughtOut Property
FabricationPart Class See Also Send Feedback
True if the fabrication part is bought out.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public bool IsBoughtOut { get; }
Visual Basic
Public ReadOnly Property IsBoughtOut As Boolean
    Get
Visual C++
public:
property bool IsBoughtOut {
    bool get ();
}

See Also

FabricationPart Class


ItemCustomId Property

[image]

Revit 2024 API
FabricationPart..::..ItemCustomId Property
FabricationPart Class See Also Send Feedback
The item custom identifier for the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public int ItemCustomId { get; }
Visual Basic
Public ReadOnly Property ItemCustomId As Integer
    Get
Visual C++
public:
property int ItemCustomId {
    int get ();
}

See Also

FabricationPart Class


ItemNumber Property

[image]

Revit 2024 API
FabricationPart..::..ItemNumber Property
FabricationPart Class See Also Send Feedback
The item number that is used for identification, re-ordering from shop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public string ItemNumber { get; set; }
Visual Basic
Public Property ItemNumber As String
    Get
    Set
Visual C++
public:
property String^ ItemNumber {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property:

See Also

FabricationPart Class


LevelOffset Property

[image]

Revit 2024 API
FabricationPart..::..LevelOffset Property
FabricationPart Class See Also Send Feedback
The associated level offset that indicates the distance from the center of the fabrication part to the current level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public double LevelOffset { get; }
Visual Basic
Public ReadOnly Property LevelOffset As Double
    Get
Visual C++
public:
property double LevelOffset {
    double get ();
}

See Also

FabricationPart Class


LiningThickness Property

[image]

Revit 2024 API
FabricationPart..::..LiningThickness Property
FabricationPart Class See Also Send Feedback
The lining thickness of the fabrication part. If the fabrication part is not lined, returns zero.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public double LiningThickness { get; }
Visual Basic
Public ReadOnly Property LiningThickness As Double
    Get
Visual C++
public:
property double LiningThickness {
    double get ();
}

See Also

FabricationPart Class


LiningType Property

[image]

Revit 2024 API
FabricationPart..::..LiningType Property
FabricationPart Class See Also Send Feedback
The lining type of the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public string LiningType { get; }
Visual Basic
Public ReadOnly Property LiningType As String
    Get
Visual C++
public:
property String^ LiningType {
    String^ get ();
}

See Also

FabricationPart Class


MaterialGauge Property

[image]

Revit 2024 API
FabricationPart..::..MaterialGauge Property
FabricationPart Class See Also Send Feedback
The fabrication material gauge identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public int MaterialGauge { get; }
Visual Basic
Public ReadOnly Property MaterialGauge As Integer
    Get
Visual C++
public:
property int MaterialGauge {
    int get ();
}

See Also

FabricationPart Class


MaterialThickness Property

[image]

Revit 2024 API
FabricationPart..::..MaterialThickness Property
FabricationPart Class See Also Send Feedback
The material thickness of the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public double MaterialThickness { get; }
Visual Basic
Public ReadOnly Property MaterialThickness As Double
    Get
Visual C++
public:
property double MaterialThickness {
    double get ();
}

See Also

FabricationPart Class


Origin Property

[image]

Revit 2024 API
FabricationPart..::..Origin Property
FabricationPart Class See Also Send Feedback
The origin of the fabrication part element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public XYZ Origin { get; }
Visual Basic
Public ReadOnly Property Origin As XYZ
    Get
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
}

See Also

FabricationPart Class


OverallSize Property

[image]

Revit 2024 API
FabricationPart..::..OverallSize Property
FabricationPart Class See Also Send Feedback
The overall size of the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public string OverallSize { get; }
Visual Basic
Public ReadOnly Property OverallSize As String
    Get
Visual C++
public:
property String^ OverallSize {
    String^ get ();
}

See Also

FabricationPart Class


Parameter Property

[image] [image]

Revit 2024 API
FabricationPart..::..Parameter Property
FabricationPart Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

FabricationPart Class
FabricationPart Members


PartGuid Property

[image]

Revit 2024 API
FabricationPart..::..PartGuid Property
FabricationPart Class See Also Send Feedback
The fabrication part's globally unique identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update

Syntax

C#
public Guid PartGuid { get; }
Visual Basic
Public ReadOnly Property PartGuid As Guid
    Get
Visual C++
public:
property Guid PartGuid {
    Guid get ();
}

See Also

FabricationPart Class


ProductCode Property

[image]

Revit 2024 API
FabricationPart..::..ProductCode Property
FabricationPart Class See Also Send Feedback
The current database id of the part within the fabrication database.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public string ProductCode { get; }
Visual Basic
Public ReadOnly Property ProductCode As String
    Get
Visual C++
public:
property String^ ProductCode {
    String^ get ();
}

See Also

FabricationPart Class


ProductDataRange Property

[image]

Revit 2024 API
FabricationPart..::..ProductDataRange Property
FabricationPart Class See Also Send Feedback
The product data range of the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public string ProductDataRange { get; }
Visual Basic
Public ReadOnly Property ProductDataRange As String
    Get
Visual C++
public:
property String^ ProductDataRange {
    String^ get ();
}

See Also

FabricationPart Class


ProductFinishDescription Property

[image]

Revit 2024 API
FabricationPart..::..ProductFinishDescription Property
FabricationPart Class See Also Send Feedback
The product finish description of the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public string ProductFinishDescription { get; }
Visual Basic
Public ReadOnly Property ProductFinishDescription As String
    Get
Visual C++
public:
property String^ ProductFinishDescription {
    String^ get ();
}

See Also

FabricationPart Class


ProductInstallType Property

[image]

Revit 2024 API
FabricationPart..::..ProductInstallType Property
FabricationPart Class See Also Send Feedback
The product install type of the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public string ProductInstallType { get; }
Visual Basic
Public ReadOnly Property ProductInstallType As String
    Get
Visual C++
public:
property String^ ProductInstallType {
    String^ get ();
}

See Also

FabricationPart Class


ProductListEntry Property

[image]

Revit 2024 API
FabricationPart..::..ProductListEntry Property
FabricationPart Class See Also Send Feedback
The product entry index of the fabrication part. A value of -1 indicates the fabrication part is not a product list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Release

Syntax

C#
public int ProductListEntry { get; set; }
Visual Basic
Public Property ProductListEntry As Integer
    Get
    Set
Visual C++
public:
property int ProductListEntry {
    int get ();
    void set (int value);
}

Remarks

The product list is a catalog of available sizes for the part and the index refers to the entry on this list.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: modifying the product entry will cause the dimensions of connected ends to change.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The product entry index is not larger than 0 and less than GetProductCount.
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: -or- When setting this property: the product entry fails to be set by index: productEntryIndex.

See Also

FabricationPart Class


ProductLongDescription Property

[image]

Revit 2024 API
FabricationPart..::..ProductLongDescription Property
FabricationPart Class See Also Send Feedback
The product long description of the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public string ProductLongDescription { get; }
Visual Basic
Public ReadOnly Property ProductLongDescription As String
    Get
Visual C++
public:
property String^ ProductLongDescription {
    String^ get ();
}

See Also

FabricationPart Class


ProductMaterialDescription Property

[image]

Revit 2024 API
FabricationPart..::..ProductMaterialDescription Property
FabricationPart Class See Also Send Feedback
The product material description of the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public string ProductMaterialDescription { get; }
Visual Basic
Public ReadOnly Property ProductMaterialDescription As String
    Get
Visual C++
public:
property String^ ProductMaterialDescription {
    String^ get ();
}

See Also

FabricationPart Class


ProductName Property

[image]

Revit 2024 API
FabricationPart..::..ProductName Property
FabricationPart Class See Also Send Feedback
The product name of the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public string ProductName { get; }
Visual Basic
Public ReadOnly Property ProductName As String
    Get
Visual C++
public:
property String^ ProductName {
    String^ get ();
}

See Also

FabricationPart Class


ProductShortDescription Property

[image]

Revit 2024 API
FabricationPart..::..ProductShortDescription Property
FabricationPart Class See Also Send Feedback
The product short description of the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public string ProductShortDescription { get; }
Visual Basic
Public ReadOnly Property ProductShortDescription As String
    Get
Visual C++
public:
property String^ ProductShortDescription {
    String^ get ();
}

See Also

FabricationPart Class


ProductSpecificationDescription Property

[image]

Revit 2024 API
FabricationPart..::..ProductSpecificationDescription Property
FabricationPart Class See Also Send Feedback
The product specification description of the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public string ProductSpecificationDescription { get; }
Visual Basic
Public ReadOnly Property ProductSpecificationDescription As String
    Get
Visual C++
public:
property String^ ProductSpecificationDescription {
    String^ get ();
}

See Also

FabricationPart Class


ServiceAbbreviation Property

[image]

Revit 2024 API
FabricationPart..::..ServiceAbbreviation Property
FabricationPart Class See Also Send Feedback
The associated service abbreviation for the fabrication service.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public string ServiceAbbreviation { get; }
Visual Basic
Public ReadOnly Property ServiceAbbreviation As String
    Get
Visual C++
public:
property String^ ServiceAbbreviation {
    String^ get ();
}

See Also

FabricationPart Class


ServiceId Property

[image]

Revit 2024 API
FabricationPart..::..ServiceId Property
FabricationPart Class See Also Send Feedback
The fabrication part service identifier. The service can only be changed to compatible services.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Release

Syntax

C#
public int ServiceId { get; set; }
Visual Basic
Public Property ServiceId As Integer
    Get
    Set
Visual C++
public:
property int ServiceId {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property:

See Also

FabricationPart Class


ServiceName Property

[image]

Revit 2024 API
FabricationPart..::..ServiceName Property
FabricationPart Class See Also Send Feedback
The name of the service associated with the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public string ServiceName { get; }
Visual Basic
Public ReadOnly Property ServiceName As String
    Get
Visual C++
public:
property String^ ServiceName {
    String^ get ();
}

See Also

FabricationPart Class


Slope Property

[image]

Revit 2024 API
FabricationPart..::..Slope Property
FabricationPart Class See Also Send Feedback
The slope for the straight fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public double Slope { get; }
Visual Basic
Public ReadOnly Property Slope As Double
    Get
Visual C++
public:
property double Slope {
    double get ();
}

See Also

FabricationPart Class


SpoolName Property

[image]

Revit 2024 API
FabricationPart..::..SpoolName Property
FabricationPart Class See Also Send Feedback
The spool name of the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public string SpoolName { get; set; }
Visual Basic
Public Property SpoolName As String
    Get
    Set
Visual C++
public:
property String^ SpoolName {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property:

See Also

FabricationPart Class


TopOfPartElevation Property

[image]

Revit 2024 API
FabricationPart..::..TopOfPartElevation Property
FabricationPart Class See Also Send Feedback
The associated elevation to the top of fabrication part off of the current level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public double TopOfPartElevation { get; }
Visual Basic
Public ReadOnly Property TopOfPartElevation As Double
    Get
Visual C++
public:
property double TopOfPartElevation {
    double get ();
}

See Also

FabricationPart Class


ValidationStatus Property

[image]

Revit 2024 API
FabricationPart..::..ValidationStatus Property
FabricationPart Class See Also Send Feedback
The validation status of the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public ValidationStatus ValidationStatus { get; }
Visual Basic
Public ReadOnly Property ValidationStatus As ValidationStatus
    Get
Visual C++
public:
property ValidationStatus ValidationStatus {
    ValidationStatus get ();
}

See Also

FabricationPart Class


Vendor Property

[image]

Revit 2024 API
FabricationPart..::..Vendor Property
FabricationPart Class See Also Send Feedback
The vendor of the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public string Vendor { get; }
Visual Basic
Public ReadOnly Property Vendor As String
    Get
Visual C++
public:
property String^ Vendor {
    String^ get ();
}

See Also

FabricationPart Class


VendorCode Property

[image]

Revit 2024 API
FabricationPart..::..VendorCode Property
FabricationPart Class See Also Send Feedback
The vendor code of the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public string VendorCode { get; }
Visual Basic
Public ReadOnly Property VendorCode As String
    Get
Visual C++
public:
property String^ VendorCode {
    String^ get ();
}

See Also

FabricationPart Class


FabricationPartType Class

[image]

Revit 2024 API
FabricationPartType Class
Members See Also Send Feedback
Represents a fabrication component type in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public class FabricationPartType : ElementType
Visual Basic
Public Class FabricationPartType _
    Inherits ElementType
Visual C++
public ref class FabricationPartType : public ElementType

Remarks

For the product-based MAP parts, every size is a new part type in Revit. For others, one part type can have many sizes.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..FabricationPartType

See Also

FabricationPartType Members


FabricationPartType Members

[image] [image]

Revit 2024 API
FabricationPartType Members
FabricationPartType Class Methods Properties See Also Send Feedback

The FabricationPartType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create | Creates a fabrication part type element based on a specific fabrication servic button and condition.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
 | Lookup | Looks up an existing fabrication part type based on a specfic fabrication service button and condition.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FabricationPartType Class


Create Method

[image]

Revit 2024 API
FabricationPartType..::..Create Method
FabricationPartType Class See Also Send Feedback
Creates a fabrication part type element based on a specific fabrication servic button and condition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public static FabricationPartType Create(
    Document document,
    FabricationServiceButton button,
    int condition
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    button As FabricationServiceButton, _
    condition As Integer _
) As FabricationPartType
Visual C++
public:
static FabricationPartType^ Create(
    Document^ document,
    FabricationServiceButton^ button,
    int condition
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
button
Type: Autodesk.Revit.DB..::..FabricationServiceButton
The fabrication service button.
condition
Type: System..::..Int32
The condition index.

Return Value

The created fabrication part type element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Fabrication service button contains invalid fittings.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The index condition is not larger or equal to 0 and less than ConditionCount.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The fabrication part type already exists.

See Also

FabricationPartType Class


Lookup Method

[image]

Revit 2024 API
FabricationPartType..::..Lookup Method
FabricationPartType Class See Also Send Feedback
Looks up an existing fabrication part type based on a specfic fabrication service button and condition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public static ElementId Lookup(
    Document document,
    FabricationServiceButton button,
    int condition
)
Visual Basic
Public Shared Function Lookup ( _
    document As Document, _
    button As FabricationServiceButton, _
    condition As Integer _
) As ElementId
Visual C++
public:
static ElementId^ Lookup(
    Document^ document,
    FabricationServiceButton^ button,
    int condition
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
button
Type: Autodesk.Revit.DB..::..FabricationServiceButton
The fabrication service button.
condition
Type: System..::..Int32
The condition index.

Return Value

Identifier of the fabrication part type element or invalidElementId if no fabrication part type exist for the specific fabrication service button and condition

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The index condition is not larger or equal to 0 and less than ConditionCount.

See Also

FabricationPartType Class


FabricationPartType Properties

[image] [image]

Revit 2024 API
FabricationPartType Properties
FabricationPartType Class See Also Send Feedback

The FabricationPartType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FabricationPartType Class


Parameter Property

[image] [image]

Revit 2024 API
FabricationPartType..::..Parameter Property
FabricationPartType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

FabricationPartType Class
FabricationPartType Members


FabricationRodInfo Class

[image]

Revit 2024 API
FabricationRodInfo Class
Members See Also Send Feedback
The rod information of the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public class FabricationRodInfo : IDisposable
Visual Basic
Public Class FabricationRodInfo _
    Implements IDisposable
Visual C++
public ref class FabricationRodInfo : IDisposable

Remarks

A fabrication part may have one or more rods. The FabricationRodInfo stores the rod information of the fabrication part.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FabricationRodInfo

See Also

FabricationRodInfo Members


FabricationRodInfo Members

[image] [image]

Revit 2024 API
FabricationRodInfo Members
FabricationRodInfo Class Methods Properties See Also Send Feedback

The FabricationRodInfo type exposes the following members.

Methods

 | Name | Description
Public method | AttachToHanger | Attaches the hanger rod to another bearer hanger.
Public method | AttachToStructure | Attaches to the nearest structural element.
Public method | Dispose | Releases all resources used by the FabricationRodInfo
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBearerExtension | Gets the bearer extension. The method is applicable only for bearer hanger.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRodAttachedElementId | Gets the identifier of the attached component for the specified rod.
Public method | GetRodEndPosition | Gets the position of the rod end.
Public method | GetRodLength | Get the current rod length. If the rod is the length will include structural extension.
Public method | GetRodStructureExtension | Gets the length of the rod's top extension into structure.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsRodLockedWithHost | Checks if the rod is locked with the host. The method is applicable only for bearer hanger.
Public method | SetBearerExtension | Sets the bearer extension. The method is applicable only for bearer hanger.
Public method | SetRodEndPosition | Sets the position of the rod end. The method is applicable only for bearer hanger.
Public method | SetRodLength | Set the rod length of the hanger for the specified rod index, excluding top extension. The hanger must not be set to be auto-hosted.
Public method | SetRodLockedWithHost | Locks the rod with the host. The method is applicable only for bearer hanger.
Public method | SetRodStructureExtension | Set the length of the rod's top extension into structure. The rod must be attached to structure.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CanRodsBeHosted | Controls whether the hanger's rod's will be automatically hosted by other elements.
Public property | IsAttachedToStructure | Checks if the hanger is attached to structure.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | RodCount | Gets the number of rods.

See Also

FabricationRodInfo Class


FabricationRodInfo Methods

[image] [image]

Revit 2024 API
FabricationRodInfo Methods
FabricationRodInfo Class See Also Send Feedback

The FabricationRodInfo type exposes the following members.

Methods

 | Name | Description
Public method | AttachToHanger | Attaches the hanger rod to another bearer hanger.
Public method | AttachToStructure | Attaches to the nearest structural element.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBearerExtension | Gets the bearer extension. The method is applicable only for bearer hanger.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRodAttachedElementId | Gets the identifier of the attached component for the specified rod.
Public method | GetRodEndPosition | Gets the position of the rod end.
Public method | GetRodLength | Get the current rod length. If the rod is the length will include structural extension.
Public method | GetRodStructureExtension | Gets the length of the rod's top extension into structure.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsRodLockedWithHost | Checks if the rod is locked with the host. The method is applicable only for bearer hanger.
Public method | SetBearerExtension | Sets the bearer extension. The method is applicable only for bearer hanger.
Public method | SetRodEndPosition | Sets the position of the rod end. The method is applicable only for bearer hanger.
Public method | SetRodLength | Set the rod length of the hanger for the specified rod index, excluding top extension. The hanger must not be set to be auto-hosted.
Public method | SetRodLockedWithHost | Locks the rod with the host. The method is applicable only for bearer hanger.
Public method | SetRodStructureExtension | Set the length of the rod's top extension into structure. The rod must be attached to structure.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FabricationRodInfo Class


AttachToHanger Method

[image]

Revit 2024 API
FabricationRodInfo..::..AttachToHanger Method
FabricationRodInfo Class See Also Send Feedback
Attaches the hanger rod to another bearer hanger.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public void AttachToHanger(
    ElementId hangerId,
    int rodIndex,
    XYZ position
)
Visual Basic
Public Sub AttachToHanger ( _
    hangerId As ElementId, _
    rodIndex As Integer, _
    position As XYZ _
)
Visual C++
public:
void AttachToHanger(
    ElementId^ hangerId,
    int rodIndex,
    XYZ^ position
)

Parameters

hangerId
Type: Autodesk.Revit.DB..::..ElementId
Identifier of the bearer hanger to which the rod attaches.
rodIndex
Type: System..::..Int32
The index of the rod.
position
Type: Autodesk.Revit.DB..::..XYZ
The position of the rod end. It should be on bearer centerline.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The hanger is not a bearer hanger. -or- The point is not on hanger bearer centerline.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | the index rodIndex is should be in range of rod count.

See Also

FabricationRodInfo Class


AttachToStructure Method

[image]

Revit 2024 API
FabricationRodInfo..::..AttachToStructure Method
FabricationRodInfo Class See Also Send Feedback
Attaches to the nearest structural element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public void AttachToStructure()
Visual Basic
Public Sub AttachToStructure
Visual C++
public:
void AttachToStructure()

See Also

FabricationRodInfo Class


Dispose Method

[image]

Revit 2024 API
FabricationRodInfo..::..Dispose Method
FabricationRodInfo Class See Also Send Feedback
Releases all resources used by the FabricationRodInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FabricationRodInfo Class


GetBearerExtension Method

[image]

Revit 2024 API
FabricationRodInfo..::..GetBearerExtension Method
FabricationRodInfo Class See Also Send Feedback
Gets the bearer extension. The method is applicable only for bearer hanger.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public double GetBearerExtension(
    int rodIndex
)
Visual Basic
Public Function GetBearerExtension ( _
    rodIndex As Integer _
) As Double
Visual C++
public:
double GetBearerExtension(
    int rodIndex
)

Parameters

rodIndex
Type: System..::..Int32
The index of the rod.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | the index rodIndex is should be in range of rod count.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The hanger is not a bearer hanger.

See Also

FabricationRodInfo Class


GetRodAttachedElementId Method

[image]

Revit 2024 API
FabricationRodInfo..::..GetRodAttachedElementId Method
FabricationRodInfo Class See Also Send Feedback
Gets the identifier of the attached component for the specified rod.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public LinkElementId GetRodAttachedElementId(
    int rodIndex
)
Visual Basic
Public Function GetRodAttachedElementId ( _
    rodIndex As Integer _
) As LinkElementId
Visual C++
public:
LinkElementId^ GetRodAttachedElementId(
    int rodIndex
)

Parameters

rodIndex
Type: System..::..Int32
The index of the specified rod.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | the index rodIndex is should be in range of rod count.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The rods do not attached to any structue.

See Also

FabricationRodInfo Class


GetRodStructureExtension Method

[image]

Revit 2024 API
FabricationRodInfo..::..GetRodStructureExtension Method
FabricationRodInfo Class See Also Send Feedback
Gets the length of the rod's top extension into structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public double GetRodStructureExtension(
    int rodIndex
)
Visual Basic
Public Function GetRodStructureExtension ( _
    rodIndex As Integer _
) As Double
Visual C++
public:
double GetRodStructureExtension(
    int rodIndex
)

Parameters

rodIndex
Type: System..::..Int32
The rod index.

Return Value

Returns the extension length that will be applied if the rod is attached to structure.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | the index rodIndex is should be in range of rod count.

See Also

FabricationRodInfo Class


IsRodLockedWithHost Method

[image]

Revit 2024 API
FabricationRodInfo..::..IsRodLockedWithHost Method
FabricationRodInfo Class See Also Send Feedback
Checks if the rod is locked with the host. The method is applicable only for bearer hanger.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public bool IsRodLockedWithHost(
    int rodIndex
)
Visual Basic
Public Function IsRodLockedWithHost ( _
    rodIndex As Integer _
) As Boolean
Visual C++
public:
bool IsRodLockedWithHost(
    int rodIndex
)

Parameters

rodIndex
Type: System..::..Int32
The index of the rod.

Return Value

True if the rod is locked with its host.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | the index rodIndex is should be in range of rod count.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The hanger is not a bearer hanger.

See Also

FabricationRodInfo Class


SetRodEndPosition Method

[image]

Revit 2024 API
FabricationRodInfo..::..SetRodEndPosition Method
FabricationRodInfo Class See Also Send Feedback
Sets the position of the rod end. The method is applicable only for bearer hanger.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public void SetRodEndPosition(
    int rodIndex,
    XYZ position
)
Visual Basic
Public Sub SetRodEndPosition ( _
    rodIndex As Integer, _
    position As XYZ _
)
Visual C++
public:
void SetRodEndPosition(
    int rodIndex,
    XYZ^ position
)

Parameters

rodIndex
Type: System..::..Int32
The index of the rod.
position
Type: Autodesk.Revit.DB..::..XYZ
The position of the rod end.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Invalid rod position.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | the index rodIndex is should be in range of rod count.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The hanger is not a bearer hanger.

See Also

FabricationRodInfo Class


SetRodLength Method

[image]

Revit 2024 API
FabricationRodInfo..::..SetRodLength Method
FabricationRodInfo Class See Also Send Feedback
Set the rod length of the hanger for the specified rod index, excluding top extension. The hanger must not be set to be auto-hosted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public bool SetRodLength(
    int rodIndex,
    double newLength
)
Visual Basic
Public Function SetRodLength ( _
    rodIndex As Integer, _
    newLength As Double _
) As Boolean
Visual C++
public:
bool SetRodLength(
    int rodIndex,
    double newLength
)

Parameters

rodIndex
Type: System..::..Int32
The rod index.
newLength
Type: System..::..Double

Return Value

Returns true if it was successful otherwise false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | the index rodIndex is should be in range of rod count.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The rod length cannot be set because the hanger is set to automatically host to other elements.

See Also

FabricationRodInfo Class


SetRodLockedWithHost Method

[image]

Revit 2024 API
FabricationRodInfo..::..SetRodLockedWithHost Method
FabricationRodInfo Class See Also Send Feedback
Locks the rod with the host. The method is applicable only for bearer hanger.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public void SetRodLockedWithHost(
    int rodIndex,
    bool locked
)
Visual Basic
Public Sub SetRodLockedWithHost ( _
    rodIndex As Integer, _
    locked As Boolean _
)
Visual C++
public:
void SetRodLockedWithHost(
    int rodIndex,
    bool locked
)

Parameters

rodIndex
Type: System..::..Int32
The index of the rod.
locked
Type: System..::..Boolean
Locks the rod with the host.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | the index rodIndex is should be in range of rod count.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The hanger is not a bearer hanger.

See Also

FabricationRodInfo Class


FabricationRodInfo Properties

[image] [image]

Revit 2024 API
FabricationRodInfo Properties
FabricationRodInfo Class See Also Send Feedback

The FabricationRodInfo type exposes the following members.

Properties

 | Name | Description
Public property | CanRodsBeHosted | Controls whether the hanger's rod's will be automatically hosted by other elements.
Public property | IsAttachedToStructure | Checks if the hanger is attached to structure.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | RodCount | Gets the number of rods.

See Also

FabricationRodInfo Class


CanRodsBeHosted Property

[image]

Revit 2024 API
FabricationRodInfo..::..CanRodsBeHosted Property
FabricationRodInfo Class See Also Send Feedback
Controls whether the hanger's rod's will be automatically hosted by other elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public bool CanRodsBeHosted { get; set; }
Visual Basic
Public Property CanRodsBeHosted As Boolean
    Get
    Set
Visual C++
public:
property bool CanRodsBeHosted {
    bool get ();
    void set (bool value);
}

See Also

FabricationRodInfo Class


IsAttachedToStructure Property

[image]

Revit 2024 API
FabricationRodInfo..::..IsAttachedToStructure Property
FabricationRodInfo Class See Also Send Feedback
Checks if the hanger is attached to structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool IsAttachedToStructure { get; }
Visual Basic
Public ReadOnly Property IsAttachedToStructure As Boolean
    Get
Visual C++
public:
property bool IsAttachedToStructure {
    bool get ();
}

See Also

FabricationRodInfo Class


IsValidObject Property

[image]

Revit 2024 API
FabricationRodInfo..::..IsValidObject Property
FabricationRodInfo Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

FabricationRodInfo Class


RodCount Property

[image]

Revit 2024 API
FabricationRodInfo..::..RodCount Property
FabricationRodInfo Class See Also Send Feedback
Gets the number of rods.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public int RodCount { get; }
Visual Basic
Public ReadOnly Property RodCount As Integer
    Get
Visual C++
public:
property int RodCount {
    int get ();
}

See Also

FabricationRodInfo Class


FabricationService Members

[image] [image]

Revit 2024 API
FabricationService Members
FabricationService Class Methods Properties See Also Send Feedback

The FabricationService type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FabricationService
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetButton | Gets the service button for a given palette index and button index from the service.
Public method | GetButtonCount | Gets the number of buttons for a given palette in the service.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPaletteName | Gets the name of a palette based on palette index.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCompatibleWith | Check whether the service is broadly interchangable with another one without affecting part geometry. The services must have the same fabrication system template and specification.
Public method | IsPaletteExcluded | Get whether a service palette is excluded from being used by the Route and Fill, Design to Fabrication, or Multi Point Routing commands. The default configuration values may be overridden by SetServicePaletteExclusions.
Public method | IsValidButtonIndex | Validates the button index.
Public method | IsValidPaletteIndex | Validates the palette index.
Public method | OverrideServiceButtonExclusion | Overrides the default service button exclusions, used by Route and Fill, Design to Fabrication, or Multi Point Routing for the current user and session only.
Public method | ResetServiceExclusionOverrides | Resets the overridden service palette and button exclusions back to default, as defined by the configuration.
Public method | SetServicePaletteExclusions | Sets the service palette exclusions, used by Route and Fill or Design to Fabrication commands, for the current user and session only. This will alter them from the default configuration exclusions to only exclude those palettes passed.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Abbreviation | The short name of service.
Public property | FabricationSystemName | The fabrication system name of the service.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | The name of the service.
Public property | PaletteCount | The number of palettes in the service.
Public property | ServiceId | The service identifier of the service.

See Also

FabricationService Class


FabricationService Methods

[image] [image]

Revit 2024 API
FabricationService Methods
FabricationService Class See Also Send Feedback

The FabricationService type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetButton | Gets the service button for a given palette index and button index from the service.
Public method | GetButtonCount | Gets the number of buttons for a given palette in the service.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPaletteName | Gets the name of a palette based on palette index.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCompatibleWith | Check whether the service is broadly interchangable with another one without affecting part geometry. The services must have the same fabrication system template and specification.
Public method | IsPaletteExcluded | Get whether a service palette is excluded from being used by the Route and Fill, Design to Fabrication, or Multi Point Routing commands. The default configuration values may be overridden by SetServicePaletteExclusions.
Public method | IsValidButtonIndex | Validates the button index.
Public method | IsValidPaletteIndex | Validates the palette index.
Public method | OverrideServiceButtonExclusion | Overrides the default service button exclusions, used by Route and Fill, Design to Fabrication, or Multi Point Routing for the current user and session only.
Public method | ResetServiceExclusionOverrides | Resets the overridden service palette and button exclusions back to default, as defined by the configuration.
Public method | SetServicePaletteExclusions | Sets the service palette exclusions, used by Route and Fill or Design to Fabrication commands, for the current user and session only. This will alter them from the default configuration exclusions to only exclude those palettes passed.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FabricationService Class


Dispose Method

[image]

Revit 2024 API
FabricationService..::..Dispose Method
FabricationService Class See Also Send Feedback
Releases all resources used by the FabricationService

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FabricationService Class


GetButton Method

[image]

Revit 2024 API
FabricationService..::..GetButton Method
FabricationService Class See Also Send Feedback
Gets the service button for a given palette index and button index from the service.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public FabricationServiceButton GetButton(
    int paletteIndex,
    int buttonIndex
)
Visual Basic
Public Function GetButton ( _
    paletteIndex As Integer, _
    buttonIndex As Integer _
) As FabricationServiceButton
Visual C++
public:
FabricationServiceButton^ GetButton(
    int paletteIndex,
    int buttonIndex
)

Parameters

paletteIndex
Type: System..::..Int32
The palette index.
buttonIndex
Type: System..::..Int32
The button index.

Return Value

The service button.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The index paletteIndex is not larger or equal to 0 and less than PaletteCount.

See Also

FabricationService Class


GetButtonCount Method

[image]

Revit 2024 API
FabricationService..::..GetButtonCount Method
FabricationService Class See Also Send Feedback
Gets the number of buttons for a given palette in the service.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public int GetButtonCount(
    int palette
)
Visual Basic
Public Function GetButtonCount ( _
    palette As Integer _
) As Integer
Visual C++
public:
int GetButtonCount(
    int palette
)

Parameters

palette
Type: System..::..Int32
The index of the palette

Return Value

The number of buttons.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The index palette is not larger or equal to 0 and less than PaletteCount.

See Also

FabricationService Class


GetPaletteName Method

[image]

Revit 2024 API
FabricationService..::..GetPaletteName Method
FabricationService Class See Also Send Feedback
Gets the name of a palette based on palette index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public string GetPaletteName(
    int palette
)
Visual Basic
Public Function GetPaletteName ( _
    palette As Integer _
) As String
Visual C++
public:
String^ GetPaletteName(
    int palette
)

Parameters

palette
Type: System..::..Int32
The index of the palette.

Return Value

The name of the palette.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The index palette is not larger or equal to 0 and less than PaletteCount.

See Also

FabricationService Class


IsPaletteExcluded Method

[image]

Revit 2024 API
FabricationService..::..IsPaletteExcluded Method
FabricationService Class See Also Send Feedback
Get whether a service palette is excluded from being used by the Route and Fill, Design to Fabrication, or Multi Point Routing commands. The default configuration values may be overridden by SetServicePaletteExclusions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public bool IsPaletteExcluded(
    int paletteIndex
)
Visual Basic
Public Function IsPaletteExcluded ( _
    paletteIndex As Integer _
) As Boolean
Visual C++
public:
bool IsPaletteExcluded(
    int paletteIndex
)

Parameters

paletteIndex
Type: System..::..Int32
The index of the palete.

Return Value

Returns true if the palette indexed by paletteIndex is currently to be excluded.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The index paletteIndex is not larger or equal to 0 and less than PaletteCount.

See Also

FabricationService Class


IsValidButtonIndex Method

[image]

Revit 2024 API
FabricationService..::..IsValidButtonIndex Method
FabricationService Class See Also Send Feedback
Validates the button index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool IsValidButtonIndex(
    int paletteIndex,
    int buttonIndex
)
Visual Basic
Public Function IsValidButtonIndex ( _
    paletteIndex As Integer, _
    buttonIndex As Integer _
) As Boolean
Visual C++
public:
bool IsValidButtonIndex(
    int paletteIndex,
    int buttonIndex
)

Parameters

paletteIndex
Type: System..::..Int32
The palette index.
buttonIndex
Type: System..::..Int32
The button index to check.

Return Value

True if larger or equal to 0 and less than PaletteCount.

See Also

FabricationService Class


IsValidPaletteIndex Method

[image]

Revit 2024 API
FabricationService..::..IsValidPaletteIndex Method
FabricationService Class See Also Send Feedback
Validates the palette index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public bool IsValidPaletteIndex(
    int paletteIndex
)
Visual Basic
Public Function IsValidPaletteIndex ( _
    paletteIndex As Integer _
) As Boolean
Visual C++
public:
bool IsValidPaletteIndex(
    int paletteIndex
)

Parameters

paletteIndex
Type: System..::..Int32
The palette index to check.

Return Value

True if larger or equal to 0 and less than PaletteCount.

See Also

FabricationService Class


OverrideServiceButtonExclusion Method

[image]

Revit 2024 API
FabricationService..::..OverrideServiceButtonExclusion Method
FabricationService Class See Also Send Feedback
Overrides the default service button exclusions, used by Route and Fill, Design to Fabrication, or Multi Point Routing for the current user and session only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update

Syntax

C#
public void OverrideServiceButtonExclusion(
    int paletteIndex,
    int buttonIndex,
    bool exclude
)
Visual Basic
Public Sub OverrideServiceButtonExclusion ( _
    paletteIndex As Integer, _
    buttonIndex As Integer, _
    exclude As Boolean _
)
Visual C++
public:
void OverrideServiceButtonExclusion(
    int paletteIndex,
    int buttonIndex,
    bool exclude
)

Parameters

paletteIndex
Type: System..::..Int32
The index of the service palette to exclude the service button from.
buttonIndex
Type: System..::..Int32
The index of the service button to exclude.
exclude
Type: System..::..Boolean
Pass true to exclude from being used by Route and Fill or Design to Fabrication.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The index paletteIndex is not larger or equal to 0 and less than PaletteCount.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

FabricationService Class


ResetServiceExclusionOverrides Method

[image]

Revit 2024 API
FabricationService..::..ResetServiceExclusionOverrides Method
FabricationService Class See Also Send Feedback
Resets the overridden service palette and button exclusions back to default, as defined by the configuration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update

Syntax

C#
public void ResetServiceExclusionOverrides()
Visual Basic
Public Sub ResetServiceExclusionOverrides
Visual C++
public:
void ResetServiceExclusionOverrides()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

FabricationService Class


SetServicePaletteExclusions Method

[image]

Revit 2024 API
FabricationService..::..SetServicePaletteExclusions Method
FabricationService Class See Also Send Feedback
Sets the service palette exclusions, used by Route and Fill or Design to Fabrication commands, for the current user and session only. This will alter them from the default configuration exclusions to only exclude those palettes passed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public bool SetServicePaletteExclusions(
    IList<int> excludedPalettes
)
Visual Basic
Public Function SetServicePaletteExclusions ( _
    excludedPalettes As IList(Of Integer) _
) As Boolean
Visual C++
public:
bool SetServicePaletteExclusions(
    IList<int>^ excludedPalettes
)

Parameters

excludedPalettes
Type: System.Collections.Generic..::..IList<(Of <(<'Int32>)>)>
A list of service palette indexes to be excluded.

Return Value

Returns true if succeeded to set the exclusions to the specified palette(s).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Palette indices contains an index that is not larger or equal to 0 and less than PaletteCount.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

FabricationService Class


Name Property

[image]

Revit 2024 API
FabricationService..::..Name Property
FabricationService Class See Also Send Feedback
The name of the service.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

FabricationService Class


PaletteCount Property

[image]

Revit 2024 API
FabricationService..::..PaletteCount Property
FabricationService Class See Also Send Feedback
The number of palettes in the service.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public int PaletteCount { get; }
Visual Basic
Public ReadOnly Property PaletteCount As Integer
    Get
Visual C++
public:
property int PaletteCount {
    int get ();
}

See Also

FabricationService Class


FabricationServiceButton Class

[image]

Revit 2024 API
FabricationServiceButton Class
Members See Also Send Feedback
The object contains information about a fabricaton button.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public class FabricationServiceButton : IDisposable
Visual Basic
Public Class FabricationServiceButton _
    Implements IDisposable
Visual C++
public ref class FabricationServiceButton : IDisposable

Remarks

A fabrication service button defines what items to use for different conditions. Fabrication service buttons are part of a fabrication service.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FabricationServiceButton

See Also

FabricationServiceButton Members


FabricationServiceButton Members

[image] [image]

Revit 2024 API
FabricationServiceButton Members
FabricationServiceButton Class Methods Properties See Also Send Feedback

The FabricationServiceButton type exposes the following members.

Methods

 | Name | Description
Public method | ContainsFabricationPartType | Checks to see if the fabrication part type exists on one of the button conditions.
Public method | Dispose | Releases all resources used by the FabricationServiceButton
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetConditionDescription | Gets the description for the condition size range.
Public method | GetConditionImage | Gets the image for the specified fabrication service button condition.
Public method | GetConditionLowerValue | Gets the condition lower value (valid if greater or equal) for a given condition index.
Public method | GetConditionName | Gets the name of the specified condition on the fabrication service button.
Public method | GetConditionUpperValue | Gets the condition upper value (valid if less) for a given condition index.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetImage | Gets the image for fabrication service button.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsExcluded | Gets if the button's fabrication part content associated with the button is to be excluded from Route and Fill, Design to Fabrication, or Multi-Point Routing commands.
Public method | IsUnrestrictedCondition | Checks if the condition is unrestricted.
Public method | IsValid | Checks if the button contains only valid fittings.
 | IsValidConditionIndex | Validates if the given condition index is valid or not.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ButtonIndex | The button index for this button.
Public property | Code | The code of the button.
Public property | ConditionCount | The number of conditions.
Public property | IsAHanger | Checks if the fabrication service button is hanger.
Public property | IsStraight | Checks if all of the fabrication service button conditions are straights.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | The name of the button.
Public property | PaletteIndex | The palette index for this button.
Public property | ServiceId | The fabrication service identifier for the fabrication service this button belongs to.

See Also

FabricationServiceButton Class


FabricationServiceButton Methods

[image] [image]

Revit 2024 API
FabricationServiceButton Methods
FabricationServiceButton Class See Also Send Feedback

The FabricationServiceButton type exposes the following members.

Methods

 | Name | Description
Public method | ContainsFabricationPartType | Checks to see if the fabrication part type exists on one of the button conditions.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetConditionDescription | Gets the description for the condition size range.
Public method | GetConditionImage | Gets the image for the specified fabrication service button condition.
Public method | GetConditionLowerValue | Gets the condition lower value (valid if greater or equal) for a given condition index.
Public method | GetConditionName | Gets the name of the specified condition on the fabrication service button.
Public method | GetConditionUpperValue | Gets the condition upper value (valid if less) for a given condition index.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetImage | Gets the image for fabrication service button.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsExcluded | Gets if the button's fabrication part content associated with the button is to be excluded from Route and Fill, Design to Fabrication, or Multi-Point Routing commands.
Public method | IsUnrestrictedCondition | Checks if the condition is unrestricted.
Public method | IsValid | Checks if the button contains only valid fittings.
 | IsValidConditionIndex | Validates if the given condition index is valid or not.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FabricationServiceButton Class


ContainsFabricationPartType Method

[image]

Revit 2024 API
FabricationServiceButton..::..ContainsFabricationPartType Method
FabricationServiceButton Class See Also Send Feedback
Checks to see if the fabrication part type exists on one of the button conditions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Release

Syntax

C#
public bool ContainsFabricationPartType(
    FabricationPartType partType
)
Visual Basic
Public Function ContainsFabricationPartType ( _
    partType As FabricationPartType _
) As Boolean
Visual C++
public:
bool ContainsFabricationPartType(
    FabricationPartType^ partType
)

Parameters

partType
Type: Autodesk.Revit.DB..::..FabricationPartType
The fabrication part type to check.

Return Value

Returns true if the fabrication part type exists on the fabrication service button.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FabricationServiceButton Class


Dispose Method

[image]

Revit 2024 API
FabricationServiceButton..::..Dispose Method
FabricationServiceButton Class See Also Send Feedback
Releases all resources used by the FabricationServiceButton

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FabricationServiceButton Class


GetConditionDescription Method

[image]

Revit 2024 API
FabricationServiceButton..::..GetConditionDescription Method
FabricationServiceButton Class See Also Send Feedback
Gets the description for the condition size range.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public string GetConditionDescription(
    int condition
)
Visual Basic
Public Function GetConditionDescription ( _
    condition As Integer _
) As String
Visual C++
public:
String^ GetConditionDescription(
    int condition
)

Parameters

condition
Type: System..::..Int32
The index of the condition in the service button.

Return Value

A user-defined string that describes the condition range, as defined in the fabrication configuration. For example, this may describe the size of the range or describe the type of fitting.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The index condition is not larger or equal to 0 and less than ConditionCount.

See Also

FabricationServiceButton Class


GetConditionImage Method

[image]

Revit 2024 API
FabricationServiceButton..::..GetConditionImage Method
FabricationServiceButton Class See Also Send Feedback
Gets the image for the specified fabrication service button condition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public virtual Bitmap GetConditionImage(
    int condition
)
Visual Basic
Public Overridable Function GetConditionImage ( _
    condition As Integer _
) As Bitmap
Visual C++
public:
virtual Bitmap^ GetConditionImage(
    int condition
)

Parameters

condition
Type: System..::..Int32
The condition index.

Return Value

System.Drawing.Bitmap represents the fabrication service button image. nullNothingnullptra null reference (Nothing in Visual Basic) if there is no preview image.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | the index condition is not larger or equal to 0 and less than ConditionCount

See Also

FabricationServiceButton Class


GetConditionLowerValue Method

[image]

Revit 2024 API
FabricationServiceButton..::..GetConditionLowerValue Method
FabricationServiceButton Class See Also Send Feedback
Gets the condition lower value (valid if greater or equal) for a given condition index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public double GetConditionLowerValue(
    int condition
)
Visual Basic
Public Function GetConditionLowerValue ( _
    condition As Integer _
) As Double
Visual C++
public:
double GetConditionLowerValue(
    int condition
)

Parameters

condition
Type: System..::..Int32
The condition index.

Return Value

The condition lower value.

Remarks

A value of -1 indicates an unrestricted value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The index condition is not larger or equal to 0 and less than ConditionCount.

See Also

FabricationServiceButton Class


GetConditionUpperValue Method

[image]

Revit 2024 API
FabricationServiceButton..::..GetConditionUpperValue Method
FabricationServiceButton Class See Also Send Feedback
Gets the condition upper value (valid if less) for a given condition index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public double GetConditionUpperValue(
    int condition
)
Visual Basic
Public Function GetConditionUpperValue ( _
    condition As Integer _
) As Double
Visual C++
public:
double GetConditionUpperValue(
    int condition
)

Parameters

condition
Type: System..::..Int32
The condition index.

Return Value

The condition upper value.

Remarks

A value of -1 indicates an unrestricted value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The index condition is not larger or equal to 0 and less than ConditionCount.

See Also

FabricationServiceButton Class


IsExcluded Method

[image]

Revit 2024 API
FabricationServiceButton..::..IsExcluded Method
FabricationServiceButton Class See Also Send Feedback
Gets if the button's fabrication part content associated with the button is to be excluded from Route and Fill, Design to Fabrication, or Multi-Point Routing commands.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update

Syntax

C#
public bool IsExcluded()
Visual Basic
Public Function IsExcluded As Boolean
Visual C++
public:
bool IsExcluded()

Return Value

Returns true if the button's parts are excluded.

See Also

FabricationServiceButton Class


IsValid Method

[image]

Revit 2024 API
FabricationServiceButton..::..IsValid Method
FabricationServiceButton Class See Also Send Feedback
Checks if the button contains only valid fittings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool IsValid()
Visual Basic
Public Function IsValid As Boolean
Visual C++
public:
bool IsValid()

Return Value

True if the button contains only valid fittings.

See Also

FabricationServiceButton Class


IsValidConditionIndex Method

[image]

Revit 2024 API
FabricationServiceButton..::..IsValidConditionIndex Method
FabricationServiceButton Class See Also Send Feedback
Validates if the given condition index is valid or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public static bool IsValidConditionIndex(
    FabricationServiceButton button,
    int condition
)
Visual Basic
Public Shared Function IsValidConditionIndex ( _
    button As FabricationServiceButton, _
    condition As Integer _
) As Boolean
Visual C++
public:
static bool IsValidConditionIndex(
    FabricationServiceButton^ button,
    int condition
)

Parameters

button
Type: Autodesk.Revit.DB..::..FabricationServiceButton
The button to check.
condition
Type: System..::..Int32
The condition index.

Return Value

True if larger or equal to 0 and less than ConditionCount.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FabricationServiceButton Class


FabricationServiceButton Properties

[image] [image]

Revit 2024 API
FabricationServiceButton Properties
FabricationServiceButton Class See Also Send Feedback

The FabricationServiceButton type exposes the following members.

Properties

 | Name | Description
Public property | ButtonIndex | The button index for this button.
Public property | Code | The code of the button.
Public property | ConditionCount | The number of conditions.
Public property | IsAHanger | Checks if the fabrication service button is hanger.
Public property | IsStraight | Checks if all of the fabrication service button conditions are straights.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | The name of the button.
Public property | PaletteIndex | The palette index for this button.
Public property | ServiceId | The fabrication service identifier for the fabrication service this button belongs to.

See Also

FabricationServiceButton Class


ButtonIndex Property

[image]

Revit 2024 API
FabricationServiceButton..::..ButtonIndex Property
FabricationServiceButton Class See Also Send Feedback
The button index for this button.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public int ButtonIndex { get; }
Visual Basic
Public ReadOnly Property ButtonIndex As Integer
    Get
Visual C++
public:
property int ButtonIndex {
    int get ();
}

See Also

FabricationServiceButton Class


Code Property

[image]

Revit 2024 API
FabricationServiceButton..::..Code Property
FabricationServiceButton Class See Also Send Feedback
The code of the button.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public string Code { get; }
Visual Basic
Public ReadOnly Property Code As String
    Get
Visual C++
public:
property String^ Code {
    String^ get ();
}

See Also

FabricationServiceButton Class


ConditionCount Property

[image]

Revit 2024 API
FabricationServiceButton..::..ConditionCount Property
FabricationServiceButton Class See Also Send Feedback
The number of conditions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public int ConditionCount { get; }
Visual Basic
Public ReadOnly Property ConditionCount As Integer
    Get
Visual C++
public:
property int ConditionCount {
    int get ();
}

See Also

FabricationServiceButton Class


IsAHanger Property

[image]

Revit 2024 API
FabricationServiceButton..::..IsAHanger Property
FabricationServiceButton Class See Also Send Feedback
Checks if the fabrication service button is hanger.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool IsAHanger { get; }
Visual Basic
Public ReadOnly Property IsAHanger As Boolean
    Get
Visual C++
public:
property bool IsAHanger {
    bool get ();
}

See Also

FabricationServiceButton Class


IsStraight Property

[image]

Revit 2024 API
FabricationServiceButton..::..IsStraight Property
FabricationServiceButton Class See Also Send Feedback
Checks if all of the fabrication service button conditions are straights.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool IsStraight { get; }
Visual Basic
Public ReadOnly Property IsStraight As Boolean
    Get
Visual C++
public:
property bool IsStraight {
    bool get ();
}

See Also

FabricationServiceButton Class


ServiceId Property

[image]

Revit 2024 API
FabricationServiceButton..::..ServiceId Property
FabricationServiceButton Class See Also Send Feedback
The fabrication service identifier for the fabrication service this button belongs to.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public int ServiceId { get; }
Visual Basic
Public ReadOnly Property ServiceId As Integer
    Get
Visual C++
public:
property int ServiceId {
    int get ();
}

See Also

FabricationServiceButton Class


FabricationServiceSettings Class

[image]

Revit 2024 API
FabricationServiceSettings Class
Members See Also Send Feedback
Represents the settings related to the fabrication services.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public class FabricationServiceSettings : Element
Visual Basic
Public Class FabricationServiceSettings _
    Inherits Element
Visual C++
public ref class FabricationServiceSettings : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..FabricationServiceSettings

See Also

FabricationServiceSettings Members


FabricationServiceSettings Methods

[image] [image]

Revit 2024 API
FabricationServiceSettings Methods
FabricationServiceSettings Class See Also Send Feedback

The FabricationServiceSettings type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
 | GetFabricationServiceSettings | Gets the settings element in the document.
Public method | GetFluidTemperature | Gets the fluid temperature of the specified service.
Public method | GetFluidType | Gets the fluid type of the specified service.
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasValidFluidSetting | Is the service associated with a fluid type and temperature?
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | RemoveFluidSetting | Clears the fluid setting of the specified service if found.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetFluidTypeAndTemperature | Sets the fluid type and temperature of the specified service.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FabricationServiceSettings Class


GetFluidTemperature Method

[image]

Revit 2024 API
FabricationServiceSettings..::..GetFluidTemperature Method
FabricationServiceSettings Class See Also Send Feedback
Gets the fluid temperature of the specified service.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public double GetFluidTemperature(
    FabricationService service
)
Visual Basic
Public Function GetFluidTemperature ( _
    service As FabricationService _
) As Double
Visual C++
public:
double GetFluidTemperature(
    FabricationService^ service
)

Parameters

service
Type: Autodesk.Revit.DB..::..FabricationService
The service to lookup.

Return Value

The temperature in Kelvin.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | service is not mapped to a fluid type and temperature.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FabricationServiceSettings Class


GetFluidType Method

[image]

Revit 2024 API
FabricationServiceSettings..::..GetFluidType Method
FabricationServiceSettings Class See Also Send Feedback
Gets the fluid type of the specified service.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public ElementId GetFluidType(
    FabricationService service
)
Visual Basic
Public Function GetFluidType ( _
    service As FabricationService _
) As ElementId
Visual C++
public:
ElementId^ GetFluidType(
    FabricationService^ service
)

Parameters

service
Type: Autodesk.Revit.DB..::..FabricationService
The service to lookup.

Return Value

The fluid type id.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | service is not mapped to a fluid type and temperature.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FabricationServiceSettings Class


RemoveFluidSetting Method

[image]

Revit 2024 API
FabricationServiceSettings..::..RemoveFluidSetting Method
FabricationServiceSettings Class See Also Send Feedback
Clears the fluid setting of the specified service if found.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public void RemoveFluidSetting(
    FabricationService service
)
Visual Basic
Public Sub RemoveFluidSetting ( _
    service As FabricationService _
)
Visual C++
public:
void RemoveFluidSetting(
    FabricationService^ service
)

Parameters

service
Type: Autodesk.Revit.DB..::..FabricationService
The service to clear.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FabricationServiceSettings Class


SetFluidTypeAndTemperature Method

[image]

Revit 2024 API
FabricationServiceSettings..::..SetFluidTypeAndTemperature Method
FabricationServiceSettings Class See Also Send Feedback
Sets the fluid type and temperature of the specified service.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public void SetFluidTypeAndTemperature(
    FabricationService service,
    ElementId fluidId,
    double temperature
)
Visual Basic
Public Sub SetFluidTypeAndTemperature ( _
    service As FabricationService, _
    fluidId As ElementId, _
    temperature As Double _
)
Visual C++
public:
void SetFluidTypeAndTemperature(
    FabricationService^ service,
    ElementId^ fluidId,
    double temperature
)

Parameters

service
Type: Autodesk.Revit.DB..::..FabricationService
The fabrication service to be set.
fluidId
Type: Autodesk.Revit.DB..::..ElementId
The fluid type id.
temperature
Type: System..::..Double
The temperature in Kelvin.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | fluidId is not a fluid type. -or- The temperature is not defined for the fluidId fluid type.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FabricationServiceSettings Class


FabricationServiceSettings Properties

[image] [image]

Revit 2024 API
FabricationServiceSettings Properties
FabricationServiceSettings Class See Also Send Feedback

The FabricationServiceSettings type exposes the following members.

Properties

 | Name | Description
 | AirFluidType | A special fluid type for fabrication HVAC services.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FabricationServiceSettings Class


AirFluidType Property

[image]

Revit 2024 API
FabricationServiceSettings..::..AirFluidType Property
FabricationServiceSettings Class See Also Send Feedback
A special fluid type for fabrication HVAC services.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ElementId AirFluidType { get; }
Visual Basic
Public Shared ReadOnly Property AirFluidType As ElementId
    Get
Visual C++
public:
static property ElementId^ AirFluidType {
    ElementId^ get ();
}

See Also

FabricationServiceSettings Class


Parameter Property

[image] [image]

Revit 2024 API
FabricationServiceSettings..::..Parameter Property
FabricationServiceSettings Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

FabricationServiceSettings Class
FabricationServiceSettings Members


FabricationVersionInfo Class

[image]

Revit 2024 API
FabricationVersionInfo Class
Members See Also Send Feedback
The object contains versioning information about fabrication data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public class FabricationVersionInfo : IDisposable
Visual Basic
Public Class FabricationVersionInfo _
    Implements IDisposable
Visual C++
public ref class FabricationVersionInfo : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FabricationVersionInfo

See Also

FabricationVersionInfo Members


Dispose Method

[image]

Revit 2024 API
FabricationVersionInfo..::..Dispose Method
FabricationVersionInfo Class See Also Send Feedback
Releases all resources used by the FabricationVersionInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FabricationVersionInfo Class


IsValidObject Property

[image]

Revit 2024 API
FabricationVersionInfo..::..IsValidObject Property
FabricationVersionInfo Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

FabricationVersionInfo Class


Version Property

[image]

Revit 2024 API
FabricationVersionInfo..::..Version Property
FabricationVersionInfo Class See Also Send Feedback
The version number of the change.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public int Version { get; }
Visual Basic
Public ReadOnly Property Version As Integer
    Get
Visual C++
public:
property int Version {
    int get ();
}

See Also

FabricationVersionInfo Class


Face Members

[image] [image]

Revit 2024 API
Face Members
Face Class Methods Properties See Also Send Feedback

The Face type exposes the following members.

Methods

 | Name | Description
Public method | ComputeDerivatives | Returns the first partial derivatives of the underlying surface at the specified point.
Public method | ComputeNormal | Returns the normal vector for the face at the given point.
Public method | ComputeSecondDerivatives | Returns the second partial derivatives of the face at the specified point.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates and returns the XYZ coordinates of a point at the indicated UV parameterization of the face.
Public method | GetBoundingBox | Returns the UV bounding box of the face.
Public method | GetEdgesAsCurveLoops | Returns a list of closed curve loops that correspond to the edge loops of the face. Curves in each curve loop correspond to individual edges.
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject.)
Public method | GetRegions | Gets the face regions (created, for example, by the Split Face command) of the face.
Public method | GetSurface | Returns a copy of this face's surface.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face.
Public method | Intersect(Face) | Calculates the intersection of the specified face with this face and returns the intersection results.
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results.
Public method | Intersect(Face, Curve%) | Calculates the intersection of the specified face with this face and returns the intersection results.
Public method | IsInside(UV) | Indicates whether the specified point is within this face.
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional information about the point location.
Public method | Project | Projects the specified point on the face.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Triangulate()()()() | Returns a triangular mesh approximation to the face.
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face.

Properties

 | Name | Description
Public property | Area | The area of this face.
Public property | EdgeLoops | A collection of edge loops. Each edge loop represents one of the closed boundaries of the face.
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
Public property | HasRegions | Identifies if the face contains regions (which can be created, for example, by the Split Face command).
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject.)
Public property | IsCyclic | Indicates whether the underlying surface is periodic in the specified parametric direction.
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate).
Public property | MaterialElementId | The element ID of the material from which this face is composed.
Public property | OrientationMatchesSurfaceOrientation | Returns true if this face's orientation matches the orientation of the face's surface, false if they have opposite orientations.
Public property | Period | The period of the underlying surface in the specified parametric direction.
Public property | Reference | Returns a stable reference to the face.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Face Class


Face Methods

[image] [image]

Revit 2024 API
Face Methods
Face Class See Also Send Feedback

The Face type exposes the following members.

Methods

 | Name | Description
Public method | ComputeDerivatives | Returns the first partial derivatives of the underlying surface at the specified point.
Public method | ComputeNormal | Returns the normal vector for the face at the given point.
Public method | ComputeSecondDerivatives | Returns the second partial derivatives of the face at the specified point.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates and returns the XYZ coordinates of a point at the indicated UV parameterization of the face.
Public method | GetBoundingBox | Returns the UV bounding box of the face.
Public method | GetEdgesAsCurveLoops | Returns a list of closed curve loops that correspond to the edge loops of the face. Curves in each curve loop correspond to individual edges.
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject.)
Public method | GetRegions | Gets the face regions (created, for example, by the Split Face command) of the face.
Public method | GetSurface | Returns a copy of this face's surface.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face.
Public method | Intersect(Face) | Calculates the intersection of the specified face with this face and returns the intersection results.
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results.
Public method | Intersect(Face, Curve%) | Calculates the intersection of the specified face with this face and returns the intersection results.
Public method | IsInside(UV) | Indicates whether the specified point is within this face.
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional information about the point location.
Public method | Project | Projects the specified point on the face.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Triangulate()()()() | Returns a triangular mesh approximation to the face.
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face.

See Also

Face Class


ComputeDerivatives Method

[image]

Revit 2024 API
Face..::..ComputeDerivatives Method
Face Class See Also Send Feedback
Returns the first partial derivatives of the underlying surface at the specified point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Transform ComputeDerivatives(
    UV point
)
Visual Basic
Public Function ComputeDerivatives ( _
    point As UV _
) As Transform
Visual C++
public:
Transform^ ComputeDerivatives(
    UV^ point
)

Parameters

point
Type: Autodesk.Revit.DB..::..UV
The parameters to be evaluated, in natural parameterization of the face.

Return Value

A transformation containing tangent vectors and a normal vector.

Remarks

The following is the meaning of the transformation members:
  • Origin is the point on the face (equivalent to Evaluate(UV));
  • BasisX is the tangent vector along the U coordinate (partial derivative with respect to U).
  • BasisY is the tangent vector along the V coordinate (partial derivative with respect to V).
  • BasisZ is the underlying surface's normal vector. This is not necessarily aligned with the normal vector pointing out of a solid that contains the face, to get that value use ComputeNormal(UV).
None of the vectors are normalized.

See Also

Face Class


ComputeNormal Method

[image]

Revit 2024 API
Face..::..ComputeNormal Method
Face Class See Also Send Feedback
Returns the normal vector for the face at the given point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ ComputeNormal(
    UV point
)
Visual Basic
Public Function ComputeNormal ( _
    point As UV _
) As XYZ
Visual C++
public:
XYZ^ ComputeNormal(
    UV^ point
)

Parameters

point
Type: Autodesk.Revit.DB..::..UV
The parameters to be evaluated, in natural parameterization of the face.

Return Value

The normal vector. This vector will be normalized.

Remarks

Differs from the normal returned from ComputeDerivatives(UV) in that this vector is the "face normal" vector. It will always be oriented to point out of a solid that contains the face.

See Also

Face Class


GetBoundingBox Method

[image]

Revit 2024 API
Face..::..GetBoundingBox Method
Face Class See Also Send Feedback
Returns the UV bounding box of the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public BoundingBoxUV GetBoundingBox()
Visual Basic
Public Function GetBoundingBox As BoundingBoxUV
Visual C++
public:
BoundingBoxUV^ GetBoundingBox()

Return Value

A BoundingBoxUV with the extents of the parameterization of the face.

See Also

Face Class


GetEdgesAsCurveLoops Method

[image]

Revit 2024 API
Face..::..GetEdgesAsCurveLoops Method
Face Class See Also Send Feedback
Returns a list of closed curve loops that correspond to the edge loops of the face. Curves in each curve loop correspond to individual edges.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public IList<CurveLoop> GetEdgesAsCurveLoops()
Visual Basic
Public Function GetEdgesAsCurveLoops As IList(Of CurveLoop)
Visual C++
public:
IList<CurveLoop^>^ GetEdgesAsCurveLoops()

Return Value

A list of closed curve loops, that correspond edges of face.

Remarks

Orientations of the curves and curve loops match the orientations of the face's edges and edge loops. The order of the CurveLoops should be considered as arbitrary.

See Also

Face Class


GetRegions Method

[image]

Revit 2024 API
Face..::..GetRegions Method
Face Class See Also Send Feedback
Gets the face regions (created, for example, by the Split Face command) of the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public IList<Face> GetRegions()
Visual Basic
Public Function GetRegions As IList(Of Face)
Visual C++
public:
IList<Face^>^ GetRegions()

Return Value

A list of faces, one for the main face of the object hosting the Split Face (such as wall or floor) and one face for each Split Face regions.

Remarks

Use the FaceSplitter class to filter and find elements which may generate face regions.

See Also

Face Class


GetSurface Method

[image]

Revit 2024 API
Face..::..GetSurface Method
Face Class See Also Send Feedback
Returns a copy of this face's surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public Surface GetSurface()
Visual Basic
Public Function GetSurface As Surface
Visual C++
public:
Surface^ GetSurface()

Return Value

A copy of this face's surface.

See Also

Face Class


Intersect Method

[image] [image]

Revit 2024 API
Face..::..Intersect Method
Face Class See Also Send Feedback
Calculates the intersection of the specified curve with this face.

Overload List

 | Name | Description
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face.
Public method | Intersect(Face) | Calculates the intersection of the specified face with this face and returns the intersection results.
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results.
Public method | Intersect(Face, Curve%) | Calculates the intersection of the specified face with this face and returns the intersection results.

See Also

Face Class
Face Members


Intersect Method (Curve)

[image]

Revit 2024 API
Face..::..Intersect Method (Curve)
Face Class See Also Send Feedback
Calculates the intersection of the specified curve with this face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public SetComparisonResult Intersect(
    Curve curve
)
Visual Basic
Public Function Intersect ( _
    curve As Curve _
) As SetComparisonResult
Visual C++
public:
SetComparisonResult Intersect(
    Curve^ curve
)

Parameters

curve
Type: Autodesk.Revit.DB..::..Curve
The specified curve to intersect with this face.

Return Value

  • SetComparisonResult.Overlap - One or more intersections were encountered.
  • SetComparisonResult.Subset - The curve is coincident with the surface.
  • SetComparisonResult.Disjoint - There is no intersection found.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | The curve is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | The intersection calculation fails.

See Also

Face Class
Intersect Overload


Intersect Method (Face)

[image]

Revit 2024 API
Face..::..Intersect Method (Face)
Face Class See Also Send Feedback
Calculates the intersection of the specified face with this face and returns the intersection results.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FaceIntersectionFaceResult Intersect(
    Face face
)
Visual Basic
Public Function Intersect ( _
    face As Face _
) As FaceIntersectionFaceResult
Visual C++
public:
FaceIntersectionFaceResult Intersect(
    Face^ face
)

Parameters

face
Type: Autodesk.Revit.DB..::..Face
The specified face to intersect with this face.

Return Value

  • FaceIntersectionFaceResult.Intersecting - One or more intersections were encountered.
  • SetComparisonResult.NonIntersecting - There is no intersection found.

Remarks

This is not a general-purpose function: it only works properly for simple configurations. For other configurations, it may return an incorrect result. Some configurations for which the function might return a correct result are:
  • A planar face that fully intersects another face in a single curve, when the other face is planar or cylindrical.
  • A cylindrical face that fully intersects another face in a single curve, when the other face is planar.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | The face is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | The intersection calculation fails.

See Also

Face Class
Intersect Overload


Intersect Method (Curve, IntersectionResultArray)

[image]

Revit 2024 API
Face..::..Intersect Method (Curve, IntersectionResultArray%)
Face Class See Also Send Feedback
Calculates the intersection of the specified curve with this face and returns the intersection results.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public SetComparisonResult Intersect(
    Curve curve,
    out IntersectionResultArray results
)
Visual Basic
Public Function Intersect ( _
    curve As Curve, _
    <OutAttribute> ByRef results As IntersectionResultArray _
) As SetComparisonResult
Visual C++
public:
SetComparisonResult Intersect(
    Curve^ curve,
    [OutAttribute] IntersectionResultArray^% results
)

Parameters

curve
Type: Autodesk.Revit.DB..::..Curve
The specified curve to intersect with this face.
results
Type: Autodesk.Revit.DB..::..IntersectionResultArray %
Provides more information about the intersection.

Return Value

  • SetComparisonResult.Overlap - One or more intersections were encountered. The output argument has the results.
  • SetComparisonResult.Subset - The curve is coincident with the surface.
  • SetComparisonResult.Disjoint - There is no intersection found.

Remarks

The array of the intersection results contains one entry for each point where this face and the curve intersect. The following is the meaning of IntersectionResult's members:
  • XYZPoint is the evaluated intersection point.
  • UVPoint is the intersection parameters on the face.
  • Parameter is the raw intersection parameter on the curve.
  • EdgeObject is the edge if the intersection happens to be near an edge of the face.
  • EdgeParameter is the parameter of the nearest point on the edge.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | The curve is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | The intersection calculation fails.

See Also

Face Class
Intersect Overload


Intersect Method (Face, Curve)

[image]

Revit 2024 API
Face..::..Intersect Method (Face, Curve%)
Face Class See Also Send Feedback
Calculates the intersection of the specified face with this face and returns the intersection results.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FaceIntersectionFaceResult Intersect(
    Face face,
    out Curve result
)
Visual Basic
Public Function Intersect ( _
    face As Face, _
    <OutAttribute> ByRef result As Curve _
) As FaceIntersectionFaceResult
Visual C++
public:
FaceIntersectionFaceResult Intersect(
    Face^ face,
    [OutAttribute] Curve^% result
)

Parameters

face
Type: Autodesk.Revit.DB..::..Face
The specified face to intersect with this face.
result
Type: Autodesk.Revit.DB..::..Curve %
A single Curve representing the intersection.

Return Value

  • FaceIntersectionFaceResult.Intersecting - One or more intersections were encountered.
  • SetComparisonResult.NonIntersecting - There is no intersection found.

Remarks

This is not a general-purpose function: it only works properly for simple configurations. For other configurations, it may return an incorrect result. Some configurations for which the function might return a correct result are:
  • A planar face that fully intersects another face in a single curve, when the other face is planar or cylindrical.
  • A cylindrical face that fully intersects another face in a single curve, when the other face is planar.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | The face is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | The intersection calculation fails.

See Also

Face Class
Intersect Overload


IsInside Method

[image] [image]

Revit 2024 API
Face..::..IsInside Method
Face Class See Also Send Feedback
Indicates whether the specified point is within this face.

Overload List

 | Name | Description
Public method | IsInside(UV) | Indicates whether the specified point is within this face.
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional information about the point location.

See Also

Face Class
Face Members


IsInside Method (UV)

[image]

Revit 2024 API
Face..::..IsInside Method (UV)
Face Class See Also Send Feedback
Indicates whether the specified point is within this face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsInside(
    UV point
)
Visual Basic
Public Function IsInside ( _
    point As UV _
) As Boolean
Visual C++
public:
bool IsInside(
    UV^ point
)

Parameters

point
Type: Autodesk.Revit.DB..::..UV
The parameters to be evaluated, in natural parameterization of the face.

Return Value

True if point is within this face or on its boundary, otherwise false.

See Also

Face Class
IsInside Overload


IsInside Method (UV, IntersectionResult)

[image]

Revit 2024 API
Face..::..IsInside Method (UV, IntersectionResult%)
Face Class See Also Send Feedback
Indicates whether the specified point is within this face and outputs additional information about the point location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsInside(
    UV point,
    out IntersectionResult result
)
Visual Basic
Public Function IsInside ( _
    point As UV, _
    <OutAttribute> ByRef result As IntersectionResult _
) As Boolean
Visual C++
public:
bool IsInside(
    UV^ point,
    [OutAttribute] IntersectionResult^% result
)

Parameters

point
Type: Autodesk.Revit.DB..::..UV
The parameters to be evaluated, in natural parameterization of the face.
result
Type: Autodesk.Revit.DB..::..IntersectionResult %
Provides more information only when the point is on the edge; otherwise, nullNothingnullptra null reference (Nothing in Visual Basic).

Return Value

True if within this face or on its boundary, otherwise False.

Remarks

The following is the meaning of the IntersectionResult members when the point is on the edge:
  • EdgeObject is the edge that the point lies on
  • EdgeParameter is the parameter of the point on the edge nearest to the UV point
  • UV is the specified point

See Also

Face Class
IsInside Overload


Project Method

[image]

Revit 2024 API
Face..::..Project Method
Face Class See Also Send Feedback
Projects the specified point on the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public IntersectionResult Project(
    XYZ point
)
Visual Basic
Public Function Project ( _
    point As XYZ _
) As IntersectionResult
Visual C++
public:
IntersectionResult^ Project(
    XYZ^ point
)

Parameters

point
Type: Autodesk.Revit.DB..::..XYZ
The point to be projected.

Return Value

Geometric information if projection is successful; if projection fails or the nearest point is outside of this face, returns nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

The following is the meaning of IntersectionResult's members:
  • XYZPoint is the nearest point to the projected point on the face.
  • UVPoint is the UV coordinates of the nearest point on the face.
  • Distance is the distance from the point to the face.
  • EdgeObject is the edge if projected point is near an edge.
  • EdgeParameter is the parameter of the nearest point on the edge.

See Also

Face Class


Triangulate Method

[image] [image]

Revit 2024 API
Face..::..Triangulate Method
Face Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Triangulate()()()() | Returns a triangular mesh approximation to the face.
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face.

See Also

Face Class
Face Members


Triangulate Method

[image]

Revit 2024 API
Face..::..Triangulate Method
Face Class Example See Also Send Feedback
Returns a triangular mesh approximation to the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Mesh Triangulate()
Visual Basic
Public Function Triangulate As Mesh
Visual C++
public:
Mesh^ Triangulate()

Remarks

Tolerance of approximation is defined internally by Revit to be adequate for display purposes.

Examples

CopyC#
private void TriangulateFace(Face face)
{
    // Get mesh
    Mesh mesh = face.Triangulate();
    for (int i = 0; i < mesh.NumTriangles; i++)
    {
        MeshTriangle triangle = mesh.get_Triangle(i);
        XYZ vertex1 = triangle.get_Vertex(0);
        XYZ vertex2 = triangle.get_Vertex(1);
        XYZ vertex3 = triangle.get_Vertex(2);
    }
}
CopyVB.NET
Private Sub TriangulateFace(face As Face)
    ' Get mesh
    Dim mesh As Mesh = face.Triangulate()
    For i As Integer = 0 To mesh.NumTriangles - 1
        Dim triangle As MeshTriangle = mesh.Triangle(i)
        Dim vertex1 As XYZ = triangle.Vertex(0)
        Dim vertex2 As XYZ = triangle.Vertex(1)
        Dim vertex3 As XYZ = triangle.Vertex(2)
    Next
End Sub

See Also

Face Class
Triangulate Overload


Triangulate Method (Double)

[image]

Revit 2024 API
Face..::..Triangulate Method (Double)
Face Class See Also Send Feedback
Returns a triangular mesh approximation to the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public Mesh Triangulate(
    double levelOfDetail
)
Visual Basic
Public Function Triangulate ( _
    levelOfDetail As Double _
) As Mesh
Visual C++
public:
Mesh^ Triangulate(
    double levelOfDetail
)

Parameters

levelOfDetail
Type: System..::..Double
The level of detail. Its range is from 0 to 1. 0 is the lowest level of detail and 1 is the highest.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when level of detail is less than 0 or greater than 1.

See Also

Face Class
Triangulate Overload


EdgeLoops Property

[image]

Revit 2024 API
Face..::..EdgeLoops Property
Face Class See Also Send Feedback
A collection of edge loops. Each edge loop represents one of the closed boundaries of the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public EdgeArrayArray EdgeLoops { get; }
Visual Basic
Public ReadOnly Property EdgeLoops As EdgeArrayArray
    Get
Visual C++
public:
property EdgeArrayArray^ EdgeLoops {
    EdgeArrayArray^ get ();
}

See Also

Face Class


HasRegions Property

[image]

Revit 2024 API
Face..::..HasRegions Property
Face Class See Also Send Feedback
Identifies if the face contains regions (which can be created, for example, by the Split Face command).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool HasRegions { get; }
Visual Basic
Public ReadOnly Property HasRegions As Boolean
    Get
Visual C++
public:
property bool HasRegions {
    bool get ();
}

Remarks

If this is true, use GetRegions()()()() to get access to the specific Faces which make up the regions.

See Also

Face Class


IsTwoSided Property

[image]

Revit 2024 API
Face..::..IsTwoSided Property
Face Class See Also Send Feedback
Determines if a face is two-sided (degenerate).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool IsTwoSided { get; }
Visual Basic
Public Overridable ReadOnly Property IsTwoSided As Boolean
    Get
Visual C++
public:
virtual property bool IsTwoSided {
    bool get ();
}

See Also

Face Class


MaterialElementId Property

[image]

Revit 2024 API
Face..::..MaterialElementId Property
Face Class See Also Send Feedback
The element ID of the material from which this face is composed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElementId MaterialElementId { get; }
Visual Basic
Public ReadOnly Property MaterialElementId As ElementId
    Get
Visual C++
public:
property ElementId^ MaterialElementId {
    ElementId^ get ();
}

See Also

Face Class


OrientationMatchesSurfaceOrientation Property

[image]

Revit 2024 API
Face..::..OrientationMatchesSurfaceOrientation Property
Face Class See Also Send Feedback
Returns true if this face's orientation matches the orientation of the face's surface, false if they have opposite orientations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool OrientationMatchesSurfaceOrientation { get; }
Visual Basic
Public ReadOnly Property OrientationMatchesSurfaceOrientation As Boolean
    Get
Visual C++
public:
property bool OrientationMatchesSurfaceOrientation {
    bool get ();
}

Remarks

(Revit uses only orientable faces and surfaces). At any point on a face or surface, the face's or surface's orientation is specified by the normal vector at that point. The face's normal vector can be the same or opposite to that of its surface. If OrientationMatchesSurfaceOrientation() is true, then the face’s normal vector is the same as that of its surface at each point on the face, otherwise the normal vectors are opposite. See also Surface::OrientationMatchesParametricOrientation.

See Also

Face Class


Period Property

[image]

Revit 2024 API
Face..::..Period Property
Face Class See Also Send Feedback
The period of the underlying surface in the specified parametric direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double this[
    int paramIdx
] { get; }
Visual Basic
Public ReadOnly Property Period ( _
    paramIdx As Integer _
) As Double
    Get
Visual C++
public:
property double Period[int paramIdx] {
    double get (int paramIdx);
}

Parameters

paramIdx
Type: System..::..Int32
Use 0 for U coordinates and 1 for V coordinates.

Return Value

The real number equal to the period of the underlying surface.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when an incorrect coordinate dimension is supplied.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when this face is not cyclic in the specified direction.

See Also

Face Class


FaceArray Class

[image]

Revit 2024 API
FaceArray Class
Members See Also Send Feedback
An array that contains faces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class FaceArray : APIObject, IEnumerable
Visual Basic
Public Class FaceArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class FaceArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..FaceArray

See Also

FaceArray Members


FaceArray Members

[image] [image]

Revit 2024 API
FaceArray Members
FaceArray Class Constructors Methods Properties See Also Send Feedback

The FaceArray type exposes the following members.

Constructors

 | Name | Description
Public method | FaceArray | Initializes a new instance of the FaceArray class

Methods

 | Name | Description
Public method | Append | Add the face to the end of the array.
Public method | Clear | Removes every face from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified face into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a face at a specified index within the array.
Public property | Size | Returns the number of faces that are in the array.

See Also

FaceArray Class


FaceArray Methods

[image] [image]

Revit 2024 API
FaceArray Methods
FaceArray Class See Also Send Feedback

The FaceArray type exposes the following members.

Methods

 | Name | Description
Public method | Append | Add the face to the end of the array.
Public method | Clear | Removes every face from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified face into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FaceArray Class


Append Method

[image]

Revit 2024 API
FaceArray..::..Append Method
FaceArray Class See Also Send Feedback
Add the face to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Append(
    Face item
)
Visual Basic
Public Overridable Sub Append ( _
    item As Face _
)
Visual C++
public:
virtual void Append(
    Face^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..Face
The face to be added.

See Also

FaceArray Class


Clear Method

[image]

Revit 2024 API
FaceArray..::..Clear Method
FaceArray Class See Also Send Feedback
Removes every face from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

FaceArray Class


ForwardIterator Method

[image]

Revit 2024 API
FaceArray..::..ForwardIterator Method
FaceArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual FaceArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As FaceArrayIterator
Visual C++
public:
virtual FaceArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

FaceArray Class


Insert Method

[image]

Revit 2024 API
FaceArray..::..Insert Method
FaceArray Class See Also Send Feedback
Insert the specified face into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Insert(
    Face item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As Face, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    Face^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::..Face
The face to be inserted into the array.
index
Type: System..::..Int32
The face will be inserted before this index.

Return Value

Returns whether the face was inserted into the array.

See Also

FaceArray Class


ReverseIterator Method

[image]

Revit 2024 API
FaceArray..::..ReverseIterator Method
FaceArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual FaceArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As FaceArrayIterator
Visual C++
public:
virtual FaceArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

FaceArray Class


FaceArray Properties

[image] [image]

Revit 2024 API
FaceArray Properties
FaceArray Class See Also Send Feedback

The FaceArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a face at a specified index within the array.
Public property | Size | Returns the number of faces that are in the array.

See Also

FaceArray Class


IsEmpty Property

[image]

Revit 2024 API
FaceArray..::..IsEmpty Property
FaceArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

FaceArray Class


Item Property

[image]

Revit 2024 API
FaceArray..::..Item Property
FaceArray Class See Also Send Feedback
Gets or sets a face at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Face this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As Face
    Get
    Set
Visual C++
public:
virtual property Face^ Item[int index] {
    Face^ get (int index);
    void set (int index, Face^ value);
}

Parameters

index
Type: System..::..Int32
The index of the face to be set or retrieved.

Return Value

Returns the face at the specified index.

See Also

FaceArray Class


FaceArrayIterator Class

[image]

Revit 2024 API
FaceArrayIterator Class
Members See Also Send Feedback
An iterator to a face array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public abstract class FaceArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class FaceArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class FaceArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..FaceArrayIterator

See Also

FaceArrayIterator Members


FaceArrayIterator Members

[image] [image]

Revit 2024 API
FaceArrayIterator Members
FaceArrayIterator Class Constructors Methods Properties See Also Send Feedback

The FaceArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | FaceArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FaceArrayIterator Class


FaceArrayIterator Constructor

[image]

Revit 2024 API
FaceArrayIterator Constructor
FaceArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FaceArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
FaceArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FaceArrayIterator Class


FaceArrayIterator Methods

[image] [image]

Revit 2024 API
FaceArrayIterator Methods
FaceArrayIterator Class See Also Send Feedback

The FaceArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FaceArrayIterator Class


MoveNext Method

[image]

Revit 2024 API
FaceArrayIterator..::..MoveNext Method
FaceArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

FaceArrayIterator Class


Reset Method

[image]

Revit 2024 API
FaceArrayIterator..::..Reset Method
FaceArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

FaceArrayIterator Class


FaceArrayIterator Properties

[image] [image]

Revit 2024 API
FaceArrayIterator Properties
FaceArrayIterator Class See Also Send Feedback

The FaceArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FaceArrayIterator Class


Current Property

[image]

Revit 2024 API
FaceArrayIterator..::..Current Property
FaceArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

FaceArrayIterator Class


FaceDetailNode Class

[image]

Revit 2024 API
FaceDetailNode Class
Members See Also Send Feedback
A base class of output nodes that represent face edges and face silhouettes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public class FaceDetailNode : RenderNode
Visual Basic
Public Class FaceDetailNode _
    Inherits RenderNode
Visual C++
public ref class FaceDetailNode : public RenderNode

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..RenderNode
Autodesk.Revit.DB..::..FaceDetailNode
Autodesk.Revit.DB..::..FaceEdgeNode
Autodesk.Revit.DB..::..FaceSilhouetteNode

See Also

FaceDetailNode Members


FaceDetailNode Members

[image] [image]

Revit 2024 API
FaceDetailNode Members
FaceDetailNode Class Methods Properties See Also Send Feedback

The FaceDetailNode type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RenderNode.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInstanceTransform | Returns instance transform of the object being drawn.
Public method | GetLinkTransform | Returns link transform of the object being drawn.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode.)
Public property | LineProperties | Access to the line (pen) properties of the curve being drawn.
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode.)

See Also

FaceDetailNode Class


FaceDetailNode Methods

[image] [image]

Revit 2024 API
FaceDetailNode Methods
FaceDetailNode Class See Also Send Feedback

The FaceDetailNode type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RenderNode.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInstanceTransform | Returns instance transform of the object being drawn.
Public method | GetLinkTransform | Returns link transform of the object being drawn.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FaceDetailNode Class


GetInstanceTransform Method

[image]

Revit 2024 API
FaceDetailNode..::..GetInstanceTransform Method
FaceDetailNode Class See Also Send Feedback
Returns instance transform of the object being drawn.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public Transform GetInstanceTransform()
Visual Basic
Public Function GetInstanceTransform As Transform
Visual C++
public:
Transform^ GetInstanceTransform()

See Also

FaceDetailNode Class


FaceDetailNode Properties

[image] [image]

Revit 2024 API
FaceDetailNode Properties
FaceDetailNode Class See Also Send Feedback

The FaceDetailNode type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode.)
Public property | LineProperties | Access to the line (pen) properties of the curve being drawn.
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode.)

See Also

FaceDetailNode Class


LineProperties Property

[image]

Revit 2024 API
FaceDetailNode..::..LineProperties Property
FaceDetailNode Class See Also Send Feedback
Access to the line (pen) properties of the curve being drawn.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public LineProperties LineProperties { get; }
Visual Basic
Public ReadOnly Property LineProperties As LineProperties
    Get
Visual C++
public:
property LineProperties^ LineProperties {
    LineProperties^ get ();
}

See Also

FaceDetailNode Class


FaceEdgeNode Class

[image]

Revit 2024 API
FaceEdgeNode Class
Members See Also Send Feedback
An output node that represents a Face edge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public class FaceEdgeNode : FaceDetailNode
Visual Basic
Public Class FaceEdgeNode _
    Inherits FaceDetailNode
Visual C++
public ref class FaceEdgeNode : public FaceDetailNode

Remarks

See also: [!:Autodesk::Revit::DB::IExportContext2D::OnFaceEdge2D].

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..RenderNode
Autodesk.Revit.DB..::..FaceDetailNode
Autodesk.Revit.DB..::..FaceEdgeNode

See Also

FaceEdgeNode Members


FaceEdgeNode Members

[image] [image]

Revit 2024 API
FaceEdgeNode Members
FaceEdgeNode Class Methods Properties See Also Send Feedback

The FaceEdgeNode type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RenderNode.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetFaceEdge | Returns the Face edge object corresponding to the node.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInstanceTransform | Returns instance transform of the object being drawn. (Inherited from FaceDetailNode.)
Public method | GetLinkTransform | Returns link transform of the object being drawn. (Inherited from FaceDetailNode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode.)
Public property | LineProperties | Access to the line (pen) properties of the curve being drawn. (Inherited from FaceDetailNode.)
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode.)

See Also

FaceEdgeNode Class


FaceEdgeNode Methods

[image] [image]

Revit 2024 API
FaceEdgeNode Methods
FaceEdgeNode Class See Also Send Feedback

The FaceEdgeNode type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RenderNode.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetFaceEdge | Returns the Face edge object corresponding to the node.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInstanceTransform | Returns instance transform of the object being drawn. (Inherited from FaceDetailNode.)
Public method | GetLinkTransform | Returns link transform of the object being drawn. (Inherited from FaceDetailNode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FaceEdgeNode Class


FaceEdgeNode Properties

[image] [image]

Revit 2024 API
FaceEdgeNode Properties
FaceEdgeNode Class See Also Send Feedback

The FaceEdgeNode type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode.)
Public property | LineProperties | Access to the line (pen) properties of the curve being drawn. (Inherited from FaceDetailNode.)
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode.)

See Also

FaceEdgeNode Class


FaceNode Members

[image] [image]

Revit 2024 API
FaceNode Members
FaceNode Class Methods Properties See Also Send Feedback

The FaceNode type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RenderNode.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetFace | Returns the Face object corresponding to the node.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode.)
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode.)

See Also

FaceNode Class


FaceNode Methods

[image] [image]

Revit 2024 API
FaceNode Methods
FaceNode Class See Also Send Feedback

The FaceNode type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RenderNode.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetFace | Returns the Face object corresponding to the node.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FaceNode Class


GetFace Method

[image]

Revit 2024 API
FaceNode..::..GetFace Method
FaceNode Class See Also Send Feedback
Returns the Face object corresponding to the node.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public Face GetFace()
Visual Basic
Public Function GetFace As Face
Visual C++
public:
Face^ GetFace()

Return Value

The face.

See Also

FaceNode Class


FaceNode Properties

[image] [image]

Revit 2024 API
FaceNode Properties
FaceNode Class See Also Send Feedback

The FaceNode type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode.)
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode.)

See Also

FaceNode Class


FaceSecondDerivatives Class

[image]

Revit 2024 API
FaceSecondDerivatives Class
Members See Also Send Feedback
Contains second partial derivatives of a face at a specified point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public class FaceSecondDerivatives : IDisposable
Visual Basic
Public Class FaceSecondDerivatives _
    Implements IDisposable
Visual C++
public ref class FaceSecondDerivatives : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FaceSecondDerivatives

See Also

FaceSecondDerivatives Members


FaceSecondDerivatives Methods

[image] [image]

Revit 2024 API
FaceSecondDerivatives Methods
FaceSecondDerivatives Class See Also Send Feedback

The FaceSecondDerivatives type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FaceSecondDerivatives Class


Dispose Method

[image]

Revit 2024 API
FaceSecondDerivatives..::..Dispose Method
FaceSecondDerivatives Class See Also Send Feedback
Releases all resources used by the FaceSecondDerivatives

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FaceSecondDerivatives Class


IsValidObject Property

[image]

Revit 2024 API
FaceSecondDerivatives..::..IsValidObject Property
FaceSecondDerivatives Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

FaceSecondDerivatives Class


MixedDerivative Property

[image]

Revit 2024 API
FaceSecondDerivatives..::..MixedDerivative Property
FaceSecondDerivatives Class See Also Send Feedback
The mixed derivative.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public XYZ MixedDerivative { get; }
Visual Basic
Public ReadOnly Property MixedDerivative As XYZ
    Get
Visual C++
public:
property XYZ^ MixedDerivative {
    XYZ^ get ();
}

See Also

FaceSecondDerivatives Class


UUDerivative Property

[image]

Revit 2024 API
FaceSecondDerivatives..::..UUDerivative Property
FaceSecondDerivatives Class See Also Send Feedback
The second derivative with respect to U.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public XYZ UUDerivative { get; }
Visual Basic
Public ReadOnly Property UUDerivative As XYZ
    Get
Visual C++
public:
property XYZ^ UUDerivative {
    XYZ^ get ();
}

See Also

FaceSecondDerivatives Class


VVDerivative Property

[image]

Revit 2024 API
FaceSecondDerivatives..::..VVDerivative Property
FaceSecondDerivatives Class See Also Send Feedback
The second derivative with respect to V.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public XYZ VVDerivative { get; }
Visual Basic
Public ReadOnly Property VVDerivative As XYZ
    Get
Visual C++
public:
property XYZ^ VVDerivative {
    XYZ^ get ();
}

See Also

FaceSecondDerivatives Class


FaceSilhouetteNode Class

[image]

Revit 2024 API
FaceSilhouetteNode Class
Members See Also Send Feedback
An output node that represents a Face edge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public class FaceSilhouetteNode : FaceDetailNode
Visual Basic
Public Class FaceSilhouetteNode _
    Inherits FaceDetailNode
Visual C++
public ref class FaceSilhouetteNode : public FaceDetailNode

Remarks

See also: [!:Autodesk::Revit::DB::IExportContext2D::OnFaceSilhouette2D].

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..RenderNode
Autodesk.Revit.DB..::..FaceDetailNode
Autodesk.Revit.DB..::..FaceSilhouetteNode

See Also

FaceSilhouetteNode Members


FaceSilhouetteNode Members

[image] [image]

Revit 2024 API
FaceSilhouetteNode Members
FaceSilhouetteNode Class Methods Properties See Also Send Feedback

The FaceSilhouetteNode type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RenderNode.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetFace | Returns the Face object corresponding to the node.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInstanceTransform | Returns instance transform of the object being drawn. (Inherited from FaceDetailNode.)
Public method | GetLinkTransform | Returns link transform of the object being drawn. (Inherited from FaceDetailNode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode.)
Public property | LineProperties | Access to the line (pen) properties of the curve being drawn. (Inherited from FaceDetailNode.)
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode.)

See Also

FaceSilhouetteNode Class


FaceSilhouetteNode Methods

[image] [image]

Revit 2024 API
FaceSilhouetteNode Methods
FaceSilhouetteNode Class See Also Send Feedback

The FaceSilhouetteNode type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RenderNode.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetFace | Returns the Face object corresponding to the node.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInstanceTransform | Returns instance transform of the object being drawn. (Inherited from FaceDetailNode.)
Public method | GetLinkTransform | Returns link transform of the object being drawn. (Inherited from FaceDetailNode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FaceSilhouetteNode Class


GetFace Method

[image]

Revit 2024 API
FaceSilhouetteNode..::..GetFace Method
FaceSilhouetteNode Class See Also Send Feedback
Returns the Face object corresponding to the node.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public Face GetFace()
Visual Basic
Public Function GetFace As Face
Visual C++
public:
Face^ GetFace()

Return Value

The face.

See Also

FaceSilhouetteNode Class


FaceSplitter Class

[image]

Revit 2024 API
FaceSplitter Class
Members See Also Send Feedback
Represents an element that splits a face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public class FaceSplitter : Element
Visual Basic
Public Class FaceSplitter _
    Inherits Element
Visual C++
public ref class FaceSplitter : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..FaceSplitter

See Also

FaceSplitter Members


FaceSplitter Members

[image] [image]

Revit 2024 API
FaceSplitter Members
FaceSplitter Class Methods Properties See Also Send Feedback

The FaceSplitter type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetBoundaries | Gets the boundaries.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SplitElementId | The id of the element whose face is split by this element.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FaceSplitter Class


FaceSplitter Methods

[image] [image]

Revit 2024 API
FaceSplitter Methods
FaceSplitter Class See Also Send Feedback

The FaceSplitter type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetBoundaries | Gets the boundaries.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FaceSplitter Class


GetBoundaries Method

[image]

Revit 2024 API
FaceSplitter..::..GetBoundaries Method
FaceSplitter Class See Also Send Feedback
Gets the boundaries.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public IList<CurveLoop> GetBoundaries()
Visual Basic
Public Function GetBoundaries As IList(Of CurveLoop)
Visual C++
public:
IList<CurveLoop^>^ GetBoundaries()

Return Value

The face splitter boundaries.

See Also

FaceSplitter Class


FaceSplitter Properties

[image] [image]

Revit 2024 API
FaceSplitter Properties
FaceSplitter Class See Also Send Feedback

The FaceSplitter type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SplitElementId | The id of the element whose face is split by this element.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FaceSplitter Class


SplitElementId Property

[image]

Revit 2024 API
FaceSplitter..::..SplitElementId Property
FaceSplitter Class See Also Send Feedback
The id of the element whose face is split by this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public ElementId SplitElementId { get; }
Visual Basic
Public ReadOnly Property SplitElementId As ElementId
    Get
Visual C++
public:
property ElementId^ SplitElementId {
    ElementId^ get ();
}

See Also

FaceSplitter Class


FacetingUtils Members

[image] [image]

Revit 2024 API
FacetingUtils Members
FacetingUtils Class Methods See Also Send Feedback

The FacetingUtils type exposes the following members.

Methods

Name | Description
ConvertTrianglesToQuads | Replaces pairs of adjacent, coplanar triangles by quadrilaterals.

See Also

FacetingUtils Class


ConvertTrianglesToQuads Method

[image]

Revit 2024 API
FacetingUtils..::..ConvertTrianglesToQuads Method
FacetingUtils Class See Also Send Feedback
Replaces pairs of adjacent, coplanar triangles by quadrilaterals.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static IList<TriOrQuadFacet> ConvertTrianglesToQuads(
    TriangulationInterface triangulation
)
Visual Basic
Public Shared Function ConvertTrianglesToQuads ( _
    triangulation As TriangulationInterface _
) As IList(Of TriOrQuadFacet)
Visual C++
public:
static IList<TriOrQuadFacet^>^ ConvertTrianglesToQuads(
    TriangulationInterface^ triangulation
)

Parameters

triangulation
Type: Autodesk.Revit.DB..::..TriangulationInterface
A triangulated face, shell, or solid.

Return Value

A collection of triangles and quadrilaterals representing the original triangulated object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation failed.

See Also

FacetingUtils Class


FaceWall Members

[image] [image]

Revit 2024 API
FaceWall Members
FaceWall Class Methods Properties See Also Send Feedback

The FaceWall type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create | Creates a new instance of a wall attached to a non-vertical massing face.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
 | IsValidFaceReferenceForFaceWall | Identifies if a reference may be used as the parent of a face wall.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
 | IsWallTypeValidForFaceWall | Identifies if a wall type may be applied to a face wall.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FaceWall Class


FaceWall Methods

[image] [image]

Revit 2024 API
FaceWall Methods
FaceWall Class See Also Send Feedback

The FaceWall type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create | Creates a new instance of a wall attached to a non-vertical massing face.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
 | IsValidFaceReferenceForFaceWall | Identifies if a reference may be used as the parent of a face wall.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
 | IsWallTypeValidForFaceWall | Identifies if a wall type may be applied to a face wall.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FaceWall Class


Create Method

[image]

Revit 2024 API
FaceWall..::..Create Method
FaceWall Class See Also Send Feedback
Creates a new instance of a wall attached to a non-vertical massing face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static FaceWall Create(
    Document document,
    ElementId wallType,
    WallLocationLine locationLine,
    Reference faceReference
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    wallType As ElementId, _
    locationLine As WallLocationLine, _
    faceReference As Reference _
) As FaceWall
Visual C++
public:
static FaceWall^ Create(
    Document^ document,
    ElementId^ wallType,
    WallLocationLine locationLine,
    Reference^ faceReference
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
wallType
Type: Autodesk.Revit.DB..::..ElementId
The wall type. This must be a wall type accepted by IsWallTypeValidForFaceWall()
locationLine
Type: Autodesk.Revit.DB..::..WallLocationLine
The alignment of the wall location line.
faceReference
Type: Autodesk.Revit.DB..::..Reference
The reference from the massing face. This must pass IsValidFaceReferenceForFaceWall()

Return Value

The newly created face wall.

Remarks

This method will regenerate the document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element wallType does not exist in the document -or- document is not a project document. -or- This wall type cannot be applied to a face wall. -or- This reference cannot be applied to a face wall.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | During a dynamic update, the newly created face wall is going to be joined to surrounding structures.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The element is a member of a loaded family. -or- The element is a member of a group type that is not being edited.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

FaceWall Class


IsValidFaceReferenceForFaceWall Method

[image]

Revit 2024 API
FaceWall..::..IsValidFaceReferenceForFaceWall Method
FaceWall Class See Also Send Feedback
Identifies if a reference may be used as the parent of a face wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static bool IsValidFaceReferenceForFaceWall(
    Document document,
    Reference faceReference
)
Visual Basic
Public Shared Function IsValidFaceReferenceForFaceWall ( _
    document As Document, _
    faceReference As Reference _
) As Boolean
Visual C++
public:
static bool IsValidFaceReferenceForFaceWall(
    Document^ document,
    Reference^ faceReference
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
faceReference
Type: Autodesk.Revit.DB..::..Reference
The reference.

Return Value

True if the reference is valid as a parent to a face wall, false otherwise.

Remarks

The reference must represent a face of a massing instance, and must be planar, and its normal must not be vertical or horizontal.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FaceWall Class


IsWallTypeValidForFaceWall Method

[image]

Revit 2024 API
FaceWall..::..IsWallTypeValidForFaceWall Method
FaceWall Class See Also Send Feedback
Identifies if a wall type may be applied to a face wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static bool IsWallTypeValidForFaceWall(
    Document document,
    ElementId wallType
)
Visual Basic
Public Shared Function IsWallTypeValidForFaceWall ( _
    document As Document, _
    wallType As ElementId _
) As Boolean
Visual C++
public:
static bool IsWallTypeValidForFaceWall(
    Document^ document,
    ElementId^ wallType
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
wallType
Type: Autodesk.Revit.DB..::..ElementId
The wall type.

Return Value

True if the wall type is valid for face wall, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FaceWall Class


FaceWall Properties

[image] [image]

Revit 2024 API
FaceWall Properties
FaceWall Class See Also Send Feedback

The FaceWall type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FaceWall Class


Parameter Property

[image] [image]

Revit 2024 API
FaceWall..::..Parameter Property
FaceWall Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

FaceWall Class
FaceWall Members


FailureDefinition Class

[image]

Revit 2024 API
FailureDefinition Class
Members See Also Send Feedback
Defines persistent information about a failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class FailureDefinition : IDisposable
Visual Basic
Public Class FailureDefinition _
    Implements IDisposable
Visual C++
public ref class FailureDefinition : IDisposable

Remarks

Each failure that can be potentially posted in Revit must be based on a FailureDefinition object that contains some persistent information about failure such as identity, severity, basic description text, types of resolution and default resolution. Each FailureMessage, which contains variable part of the information for a specific failure when it occurs, is created with a reference to a registered FailureDefinition. In order to be able to post a failure, one must define and register it via FailureDefinition object during Revit Application startup.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FailureDefinition

See Also

FailureDefinition Members


FailureDefinition Members

[image] [image]

Revit 2024 API
FailureDefinition Members
FailureDefinition Class Methods Properties See Also Send Feedback

The FailureDefinition type exposes the following members.

Methods

 | Name | Description
Public method | AddResolutionType | Adds a type of possible resolution for the failure.
 | CreateFailureDefinition | Creates an instance of a FailureDefinition.
Public method | Dispose | Releases all resources used by the FailureDefinition
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetApplicableResolutionTypes | Retrieves a list of resolution types applicable to the failure.
Public method | GetDefaultResolutionType | Retrieves the default resolution type for the failure.
Public method | GetDescriptionText | Retrieves the description text of the failure.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetResolutionCaption | Retrieves the caption for a specific resolution type.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasResolutions | Checks if the FailureDefinition has at least one resolution.
Public method | IsResolutionApplicable | Checks if the given resolution type is applicable to the failure.
Public method | SetDefaultResolutionType | Sets the default resolution type for the failure.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Severity | The severity of the failure.

See Also

FailureDefinition Class


FailureDefinition Methods

[image] [image]

Revit 2024 API
FailureDefinition Methods
FailureDefinition Class See Also Send Feedback

The FailureDefinition type exposes the following members.

Methods

 | Name | Description
Public method | AddResolutionType | Adds a type of possible resolution for the failure.
 | CreateFailureDefinition | Creates an instance of a FailureDefinition.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetApplicableResolutionTypes | Retrieves a list of resolution types applicable to the failure.
Public method | GetDefaultResolutionType | Retrieves the default resolution type for the failure.
Public method | GetDescriptionText | Retrieves the description text of the failure.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetResolutionCaption | Retrieves the caption for a specific resolution type.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasResolutions | Checks if the FailureDefinition has at least one resolution.
Public method | IsResolutionApplicable | Checks if the given resolution type is applicable to the failure.
Public method | SetDefaultResolutionType | Sets the default resolution type for the failure.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FailureDefinition Class


AddResolutionType Method

[image]

Revit 2024 API
FailureDefinition..::..AddResolutionType Method
FailureDefinition Class See Also Send Feedback
Adds a type of possible resolution for the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FailureDefinition AddResolutionType(
    FailureResolutionType type,
    string caption,
    Type classOfResolution
)
Visual Basic
Public Function AddResolutionType ( _
    type As FailureResolutionType, _
    caption As String, _
    classOfResolution As Type _
) As FailureDefinition
Visual C++
public:
FailureDefinition^ AddResolutionType(
    FailureResolutionType type,
    String^ caption,
    Type^ classOfResolution
)

Parameters

type
Type: Autodesk.Revit.DB..::..FailureResolutionType
Type of the resolution to add. The type of resolution can be used only once for the FailureDefinition.
caption
Type: System..::..String
A simple description of the resolution.
classOfResolution
Type: System..::..Type
The runtime class of the resolution. Used to ensure that the actual FailureResoution object added to the instance of FailureMessage belongs to an applicable class.

Return Value

The FailureDefinition.

Remarks

In order to inform Revit what failure resolutions can be possibly used with a given failure, a FailureDefinition must contain a full list of resolution types applicable to the failure, including user-visible caption and runtime class of the resolution. The number of resolutions is not limited. The first added resolution becomes the default resolution.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The type has already been added as a resolution to the FailureDefinition. -or- The input classOfResolution is not a subclass of FailureResolution.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

FailureDefinition Class


CreateFailureDefinition Method

[image]

Revit 2024 API
FailureDefinition..::..CreateFailureDefinition Method
FailureDefinition Class Example See Also Send Feedback
Creates an instance of a FailureDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static FailureDefinition CreateFailureDefinition(
    FailureDefinitionId id,
    FailureSeverity severity,
    string messageString
)
Visual Basic
Public Shared Function CreateFailureDefinition ( _
    id As FailureDefinitionId, _
    severity As FailureSeverity, _
    messageString As String _
) As FailureDefinition
Visual C++
public:
static FailureDefinition^ CreateFailureDefinition(
    FailureDefinitionId^ id,
    FailureSeverity severity,
    String^ messageString
)

Parameters

id
Type: Autodesk.Revit.DB..::..FailureDefinitionId
Unique identifier of the failure.
severity
Type: Autodesk.Revit.DB..::..FailureSeverity
The severity of the failure. Cannot be FailureSeverity::None.
messageString
Type: System..::..String
A user-visible string describing the failure.

Return Value

The created FailureDefinition instance.

Remarks

The newly created FailureDefinition will be added to the FailureDefinitionRegistry. Because FailureDefinition could only be registered when Revit starting up, this function cannot be used after Revit has already started. Throws InvalidOperationException if invoked after Revit start-up is completed.

Examples

CopyC#
// define a new failure id for a warning about walls
FailureDefinitionId warnId =
    new FailureDefinitionId(new Guid("FB4F5AF3-42BB-4371-B559-FB1648D5B4D1"));

// register the new warning using FailureDefinition
FailureDefinition failDef = FailureDefinition.CreateFailureDefinition(warnId,
    FailureSeverity.Warning,
    "Wall is too big (>100'). Performance problems may result.");
CopyVB.NET
' define a new failure id for a warning about walls
Dim warnId As New FailureDefinitionId(New Guid("FB4F5AF3-42BB-4371-B559-FB1648D5B4D1"))

' register the new warning using FailureDefinition
Dim failDef As FailureDefinition = FailureDefinition.CreateFailureDefinition(warnId, FailureSeverity.Warning, "Wall is too big (>100'). Performance problems may result.")

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The id of failure definition is not valid. -or- The id of failure definition is already used to register another FailureDefinition. -or- The severity of failures cannot be FailureSeverity::None. -or- Message string is empty or contains invalid characters.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

FailureDefinition Class


Dispose Method

[image]

Revit 2024 API
FailureDefinition..::..Dispose Method
FailureDefinition Class See Also Send Feedback
Releases all resources used by the FailureDefinition

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FailureDefinition Class


GetApplicableResolutionTypes Method

[image]

Revit 2024 API
FailureDefinition..::..GetApplicableResolutionTypes Method
FailureDefinition Class See Also Send Feedback
Retrieves a list of resolution types applicable to the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public IList<FailureResolutionType> GetApplicableResolutionTypes()
Visual Basic
Public Function GetApplicableResolutionTypes As IList(Of FailureResolutionType)
Visual C++
public:
IList<FailureResolutionType>^ GetApplicableResolutionTypes()

Return Value

The list of resolution types applicable to the failure.

See Also

FailureDefinition Class


GetDefaultResolutionType Method

[image]

Revit 2024 API
FailureDefinition..::..GetDefaultResolutionType Method
FailureDefinition Class See Also Send Feedback
Retrieves the default resolution type for the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FailureResolutionType GetDefaultResolutionType()
Visual Basic
Public Function GetDefaultResolutionType As FailureResolutionType
Visual C++
public:
FailureResolutionType GetDefaultResolutionType()

Return Value

The Default resolution type for the failure.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | FailureDefinition does not have any resolutions.

See Also

FailureDefinition Class


HasResolutions Method

[image]

Revit 2024 API
FailureDefinition..::..HasResolutions Method
FailureDefinition Class See Also Send Feedback
Checks if the FailureDefinition has at least one resolution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool HasResolutions()
Visual Basic
Public Function HasResolutions As Boolean
Visual C++
public:
bool HasResolutions()

Return Value

True if at least one resolution is defined in the FailureDefinition.

See Also

FailureDefinition Class


SetDefaultResolutionType Method

[image]

Revit 2024 API
FailureDefinition..::..SetDefaultResolutionType Method
FailureDefinition Class See Also Send Feedback
Sets the default resolution type for the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FailureDefinition SetDefaultResolutionType(
    FailureResolutionType type
)
Visual Basic
Public Function SetDefaultResolutionType ( _
    type As FailureResolutionType _
) As FailureDefinition
Visual C++
public:
FailureDefinition^ SetDefaultResolutionType(
    FailureResolutionType type
)

Parameters

type
Type: Autodesk.Revit.DB..::..FailureResolutionType
The type of resolution to be used as default.

Return Value

The FailureDefinition.

Remarks

If failure has multiple resolutions, one of them is designated as designated as the default resolution. The default resolution is used by Revit failure processing mechanism to resolve failures automatically when applicable.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Resolution of the type is not applicable to the failure.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | FailureDefinition does not have any resolutions.

See Also

FailureDefinition Class


IsValidObject Property

[image]

Revit 2024 API
FailureDefinition..::..IsValidObject Property
FailureDefinition Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

FailureDefinition Class


Severity Property

[image]

Revit 2024 API
FailureDefinition..::..Severity Property
FailureDefinition Class See Also Send Feedback
The severity of the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FailureSeverity Severity { get; }
Visual Basic
Public ReadOnly Property Severity As FailureSeverity
    Get
Visual C++
public:
property FailureSeverity Severity {
    FailureSeverity get ();
}

See Also

FailureDefinition Class


FailureDefinitionAccessor Class

[image]

Revit 2024 API
FailureDefinitionAccessor Class
Members See Also Send Feedback
A class that provides access to the details of a FailureDefinition after the definition has been defined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class FailureDefinitionAccessor : IDisposable
Visual Basic
Public Class FailureDefinitionAccessor _
    Implements IDisposable
Visual C++
public ref class FailureDefinitionAccessor : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FailureDefinitionAccessor

See Also

FailureDefinitionAccessor Members


Dispose Method

[image]

Revit 2024 API
FailureDefinitionAccessor..::..Dispose Method
FailureDefinitionAccessor Class See Also Send Feedback
Releases all resources used by the FailureDefinitionAccessor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FailureDefinitionAccessor Class


GetApplicableResolutionTypes Method

[image]

Revit 2024 API
FailureDefinitionAccessor..::..GetApplicableResolutionTypes Method
FailureDefinitionAccessor Class See Also Send Feedback
Retrieves a list of resolution types applicable to the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public IList<FailureResolutionType> GetApplicableResolutionTypes()
Visual Basic
Public Function GetApplicableResolutionTypes As IList(Of FailureResolutionType)
Visual C++
public:
IList<FailureResolutionType>^ GetApplicableResolutionTypes()

Return Value

The list of resolution types applicable to the failure.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The FailureDefinitionAccessor has not been properly initialized.

See Also

FailureDefinitionAccessor Class


GetDefaultResolutionType Method

[image]

Revit 2024 API
FailureDefinitionAccessor..::..GetDefaultResolutionType Method
FailureDefinitionAccessor Class See Also Send Feedback
Retrieves the default resolution type for the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FailureResolutionType GetDefaultResolutionType()
Visual Basic
Public Function GetDefaultResolutionType As FailureResolutionType
Visual C++
public:
FailureResolutionType GetDefaultResolutionType()

Return Value

The default resolution type for the failure.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The FailureDefinitionAccessor has not been properly initialized. -or- FailureDefinition does not have any resolutions.

See Also

FailureDefinitionAccessor Class


GetDescriptionText Method

[image]

Revit 2024 API
FailureDefinitionAccessor..::..GetDescriptionText Method
FailureDefinitionAccessor Class See Also Send Feedback
Retrieves the description text of the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public string GetDescriptionText()
Visual Basic
Public Function GetDescriptionText As String
Visual C++
public:
String^ GetDescriptionText()

Return Value

The description text.

Remarks

Retrieved description text for built-in Revit failures is localized. The result may vary from the description text retrieved from the corresponding FailureMessage. A failure definition contains a description string, that may have format specifiers like %s, and "sample" strings, that will be used to resolve them. A FailureMessage will contain "specific" strings. So, in the failure definition description "Cannot keep %s joined" will be converted into "Cannot keep Element joined" while the description in actual FailureMessage will read "Cannot keep Walls joined" or "Cannot keep Beams joined"

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The FailureDefinitionAccessor has not been properly initialized.

See Also

FailureDefinitionAccessor Class


GetId Method

[image]

Revit 2024 API
FailureDefinitionAccessor..::..GetId Method
FailureDefinitionAccessor Class See Also Send Feedback
Retrieves the unique identifier of the FailureDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FailureDefinitionId GetId()
Visual Basic
Public Function GetId As FailureDefinitionId
Visual C++
public:
FailureDefinitionId^ GetId()

Return Value

The unique identifier of the FailureDefinition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The FailureDefinitionAccessor has not been properly initialized.

See Also

FailureDefinitionAccessor Class


GetResolutionCaption Method

[image]

Revit 2024 API
FailureDefinitionAccessor..::..GetResolutionCaption Method
FailureDefinitionAccessor Class See Also Send Feedback
Retrieves the caption for a specific resolution type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public string GetResolutionCaption(
    FailureResolutionType type
)
Visual Basic
Public Function GetResolutionCaption ( _
    type As FailureResolutionType _
) As String
Visual C++
public:
String^ GetResolutionCaption(
    FailureResolutionType type
)

Parameters

type
Type: Autodesk.Revit.DB..::..FailureResolutionType
The resolution type.

Return Value

The caption of the resolution.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Resolution of the type is not applicable to the failure.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | The FailureDefinitionAccessor has not been properly initialized. -or- FailureDefinition does not have any resolutions.

See Also

FailureDefinitionAccessor Class


HasResolutions Method

[image]

Revit 2024 API
FailureDefinitionAccessor..::..HasResolutions Method
FailureDefinitionAccessor Class See Also Send Feedback
Checks if the FailureDefinition has at least one resolution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool HasResolutions()
Visual Basic
Public Function HasResolutions As Boolean
Visual C++
public:
bool HasResolutions()

Return Value

True if at least one resolution is defined in the FailureDefinition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The FailureDefinitionAccessor has not been properly initialized.

See Also

FailureDefinitionAccessor Class


IsResolutionApplicable Method

[image]

Revit 2024 API
FailureDefinitionAccessor..::..IsResolutionApplicable Method
FailureDefinitionAccessor Class See Also Send Feedback
Checks if the given resolution type is applicable to the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool IsResolutionApplicable(
    FailureResolutionType type
)
Visual Basic
Public Function IsResolutionApplicable ( _
    type As FailureResolutionType _
) As Boolean
Visual C++
public:
bool IsResolutionApplicable(
    FailureResolutionType type
)

Parameters

type
Type: Autodesk.Revit.DB..::..FailureResolutionType
The resolution type to check.

Return Value

True if the given resolution type is applicable to the failure, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | The FailureDefinitionAccessor has not been properly initialized.

See Also

FailureDefinitionAccessor Class


SetDefaultResolutionType Method

[image]

Revit 2024 API
FailureDefinitionAccessor..::..SetDefaultResolutionType Method
FailureDefinitionAccessor Class See Also Send Feedback
Sets the default resolution type for the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public void SetDefaultResolutionType(
    FailureResolutionType type
)
Visual Basic
Public Sub SetDefaultResolutionType ( _
    type As FailureResolutionType _
)
Visual C++
public:
void SetDefaultResolutionType(
    FailureResolutionType type
)

Parameters

type
Type: Autodesk.Revit.DB..::..FailureResolutionType
The type of resolution to be used as default.

Remarks

If failure has multiple resolutions, one of them is designated as designated as the default resolution. The default resolution is used by Revit failure processing mechanism to resolve failures automatically when applicable.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Resolution of the type is not applicable to the failure.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | The FailureDefinitionAccessor has not been properly initialized. -or- FailureDefinition does not have any resolutions.

See Also

FailureDefinitionAccessor Class


IsValidObject Property

[image]

Revit 2024 API
FailureDefinitionAccessor..::..IsValidObject Property
FailureDefinitionAccessor Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

FailureDefinitionAccessor Class


FailureDefinitionId Class

[image]

Revit 2024 API
FailureDefinitionId Class
Members See Also Send Feedback
The unique identifier of a FailureDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class FailureDefinitionId : GuidEnum
Visual Basic
Public Class FailureDefinitionId _
    Inherits GuidEnum
Visual C++
public ref class FailureDefinitionId : public GuidEnum

Remarks

Each possible failure in Revit must be defined and registered during Revit application startup by creating a FailureDefinition object. Unique FailureDefinitionId must be used as a key to register FailureDefinition. Those unique FailureDefinitionId should be created using GUID generation tool. Later FailureDefinitionId can be used to lookup FailureDefinition in FailureDefinitionRegistry, and create and post FailureMessages.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..GuidEnum
Autodesk.Revit.DB..::..FailureDefinitionId

See Also

FailureDefinitionId Members


FailureDefinitionId Members

[image] [image]

Revit 2024 API
FailureDefinitionId Members
FailureDefinitionId Class Constructors Methods Operators Properties See Also Send Feedback

The FailureDefinitionId type exposes the following members.

Constructors

 | Name | Description
Public method | FailureDefinitionId | Creates a new FailureDefinitionId instance.

Methods

 | Name | Description
Public method | Equals | Compares two Guid-based enum object based on their concrete class and GUID value. (Inherited from GuidEnum.)
Public method | GetHashCode | Generates a hash code for this Guid-based enum object. (Inherited from GuidEnum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Operators

Name | Description
Equality | Compares two FailureDefinitionId instances.
Inequality | Compares two FailureDefinitionId instances.

Properties

 | Name | Description
Public property | Guid | The Guid of GUID-based enum object. (Inherited from GuidEnum.)

See Also

FailureDefinitionId Class


FailureDefinitionId Methods

[image] [image]

Revit 2024 API
FailureDefinitionId Methods
FailureDefinitionId Class See Also Send Feedback

The FailureDefinitionId type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Compares two Guid-based enum object based on their concrete class and GUID value. (Inherited from GuidEnum.)
Public method | GetHashCode | Generates a hash code for this Guid-based enum object. (Inherited from GuidEnum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FailureDefinitionId Class


FailureDefinitionId Operators

[image] [image]

Revit 2024 API
FailureDefinitionId Operators
FailureDefinitionId Class See Also Send Feedback

The FailureDefinitionId type exposes the following members.

Operators

Name | Description
Equality | Compares two FailureDefinitionId instances.
Inequality | Compares two FailureDefinitionId instances.

See Also

FailureDefinitionId Class


Equality Operator

[image]

Revit 2024 API
FailureDefinitionId..::..Equality Operator
FailureDefinitionId Class See Also Send Feedback
Compares two FailureDefinitionId instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static bool operator ==(
    FailureDefinitionId first,
    FailureDefinitionId second
)
Visual Basic
Public Shared Operator = ( _
    first As FailureDefinitionId, _
    second As FailureDefinitionId _
) As Boolean
Visual C++
public:
static bool operator ==(
    FailureDefinitionId^ first,
    FailureDefinitionId^ second
)

Parameters

first
Type: Autodesk.Revit.DB..::..FailureDefinitionId
The first FailureDefinitionId.
second
Type: Autodesk.Revit.DB..::..FailureDefinitionId
The second FailureDefinitionId.

Return Value

True if the inputs are identical, false if they are different.

See Also

FailureDefinitionId Class


Inequality Operator

[image]

Revit 2024 API
FailureDefinitionId..::..Inequality Operator
FailureDefinitionId Class See Also Send Feedback
Compares two FailureDefinitionId instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static bool operator !=(
    FailureDefinitionId first,
    FailureDefinitionId second
)
Visual Basic
Public Shared Operator <> ( _
    first As FailureDefinitionId, _
    second As FailureDefinitionId _
) As Boolean
Visual C++
public:
static bool operator !=(
    FailureDefinitionId^ first,
    FailureDefinitionId^ second
)

Parameters

first
Type: Autodesk.Revit.DB..::..FailureDefinitionId
The first FailureDefinitionId.
second
Type: Autodesk.Revit.DB..::..FailureDefinitionId
The second FailureDefinitionId.

Return Value

True if the inputs are different, false if they are identical.

See Also

FailureDefinitionId Class


FailureDefinitionId Properties

[image] [image]

Revit 2024 API
FailureDefinitionId Properties
FailureDefinitionId Class See Also Send Feedback

The FailureDefinitionId type exposes the following members.

Properties

 | Name | Description
Public property | Guid | The Guid of GUID-based enum object. (Inherited from GuidEnum.)

See Also

FailureDefinitionId Class


FailureDefinitionRegistry Class

[image]

Revit 2024 API
FailureDefinitionRegistry Class
Members See Also Send Feedback
The global registry for all FailureDefinitions in the Revit session.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class FailureDefinitionRegistry : IDisposable
Visual Basic
Public Class FailureDefinitionRegistry _
    Implements IDisposable
Visual C++
public ref class FailureDefinitionRegistry : IDisposable

Remarks

When a FailureDefinition is created, it will be registered in this registry automatically. Registration is allowed only during Revit Application startup - after that FailureDefinitionRegistry is locked and creation of new FailureDefinitions is not allowed. There is only one instance of FailureDefinitionRegistry in session. GetFailureDefinitionRegistry()()()()

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FailureDefinitionRegistry

See Also

FailureDefinitionRegistry Members


FailureDefinitionRegistry Members

[image] [image]

Revit 2024 API
FailureDefinitionRegistry Members
FailureDefinitionRegistry Class Methods Properties See Also Send Feedback

The FailureDefinitionRegistry type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FailureDefinitionRegistry
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindFailureDefinition | Finds a specific FailureDefinition by a given FailureDefinitionId.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ListAllFailureDefinitions | Retrieves all the registered FailureDefinitions.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

FailureDefinitionRegistry Class


FailureDefinitionRegistry Methods

[image] [image]

Revit 2024 API
FailureDefinitionRegistry Methods
FailureDefinitionRegistry Class See Also Send Feedback

The FailureDefinitionRegistry type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindFailureDefinition | Finds a specific FailureDefinition by a given FailureDefinitionId.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ListAllFailureDefinitions | Retrieves all the registered FailureDefinitions.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FailureDefinitionRegistry Class


Dispose Method

[image]

Revit 2024 API
FailureDefinitionRegistry..::..Dispose Method
FailureDefinitionRegistry Class See Also Send Feedback
Releases all resources used by the FailureDefinitionRegistry

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FailureDefinitionRegistry Class


FindFailureDefinition Method

[image]

Revit 2024 API
FailureDefinitionRegistry..::..FindFailureDefinition Method
FailureDefinitionRegistry Class See Also Send Feedback
Finds a specific FailureDefinition by a given FailureDefinitionId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FailureDefinitionAccessor FindFailureDefinition(
    FailureDefinitionId id
)
Visual Basic
Public Function FindFailureDefinition ( _
    id As FailureDefinitionId _
) As FailureDefinitionAccessor
Visual C++
public:
FailureDefinitionAccessor^ FindFailureDefinition(
    FailureDefinitionId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::..FailureDefinitionId
The id of the FailureDefinition.

Return Value

The accessor of the found FailureDefinition, or null, if the FailureDefinition was not found.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FailureDefinitionRegistry Class


ListAllFailureDefinitions Method

[image]

Revit 2024 API
FailureDefinitionRegistry..::..ListAllFailureDefinitions Method
FailureDefinitionRegistry Class See Also Send Feedback
Retrieves all the registered FailureDefinitions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public IList<FailureDefinitionAccessor> ListAllFailureDefinitions()
Visual Basic
Public Function ListAllFailureDefinitions As IList(Of FailureDefinitionAccessor)
Visual C++
public:
IList<FailureDefinitionAccessor^>^ ListAllFailureDefinitions()

Return Value

All the registered FailureDefinitions.

See Also

FailureDefinitionRegistry Class


IsValidObject Property

[image]

Revit 2024 API
FailureDefinitionRegistry..::..IsValidObject Property
FailureDefinitionRegistry Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

FailureDefinitionRegistry Class


FailureHandlingOptions Class

[image]

Revit 2024 API
FailureHandlingOptions Class
Members See Also Send Feedback
Options to control how failures (if any occurred during the transaction) should be handled at the time the transaction is being ended.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class FailureHandlingOptions : IDisposable
Visual Basic
Public Class FailureHandlingOptions _
    Implements IDisposable
Visual C++
public ref class FailureHandlingOptions : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FailureHandlingOptions

See Also

FailureHandlingOptions Members


FailureHandlingOptions Members

[image] [image]

Revit 2024 API
FailureHandlingOptions Members
FailureHandlingOptions Class Methods Properties See Also Send Feedback

The FailureHandlingOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FailureHandlingOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetClearAfterRollback | Obtains the flag indicating if all posted failures should be removed silently when transaction is being rolled back.
Public method | GetDelayedMiniWarnings | Obtains the flag indicating if showing of mini-warning dialog should be delayed until the end of next transaction.
Public method | GetFailuresPreprocessor | Gets the callback to be invoked in the beginning of failure processing.
Public method | GetForcedModalHandling | Obtains the flag indicating if the error handling dialog shown at the end of the failing transaction should be modal.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTransactionFinalizer | Gets the callback to be executed after transaction is completed.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetClearAfterRollback | Sets a flag indicating that Revit should clear all posted failures silently when the failing transaction is being rolled back intentionally. If not set, the failures may still be displayed to the user during rollback.
Public method | SetDelayedMiniWarnings | Sets a flag indicating if Revit should delay the display of the mini-warning dialog (if one is to be shown as a result of warnings in the current transaction) until the end of the next transaction.
Public method | SetFailuresPreprocessor | Sets the callback to be invoked in the beginning of failure processing.
Public method | SetForcedModalHandling | Sets a flag indicating whether Revit will show a modal (blocking) error dialog if the transaction failed to finish.
Public method | SetTransactionFinalizer | Sets the callback to be executed after the transaction is completed.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

FailureHandlingOptions Class


FailureHandlingOptions Methods

[image] [image]

Revit 2024 API
FailureHandlingOptions Methods
FailureHandlingOptions Class See Also Send Feedback

The FailureHandlingOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetClearAfterRollback | Obtains the flag indicating if all posted failures should be removed silently when transaction is being rolled back.
Public method | GetDelayedMiniWarnings | Obtains the flag indicating if showing of mini-warning dialog should be delayed until the end of next transaction.
Public method | GetFailuresPreprocessor | Gets the callback to be invoked in the beginning of failure processing.
Public method | GetForcedModalHandling | Obtains the flag indicating if the error handling dialog shown at the end of the failing transaction should be modal.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTransactionFinalizer | Gets the callback to be executed after transaction is completed.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetClearAfterRollback | Sets a flag indicating that Revit should clear all posted failures silently when the failing transaction is being rolled back intentionally. If not set, the failures may still be displayed to the user during rollback.
Public method | SetDelayedMiniWarnings | Sets a flag indicating if Revit should delay the display of the mini-warning dialog (if one is to be shown as a result of warnings in the current transaction) until the end of the next transaction.
Public method | SetFailuresPreprocessor | Sets the callback to be invoked in the beginning of failure processing.
Public method | SetForcedModalHandling | Sets a flag indicating whether Revit will show a modal (blocking) error dialog if the transaction failed to finish.
Public method | SetTransactionFinalizer | Sets the callback to be executed after the transaction is completed.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FailureHandlingOptions Class


Dispose Method

[image]

Revit 2024 API
FailureHandlingOptions..::..Dispose Method
FailureHandlingOptions Class See Also Send Feedback
Releases all resources used by the FailureHandlingOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FailureHandlingOptions Class


GetTransactionFinalizer Method

[image]

Revit 2024 API
FailureHandlingOptions..::..GetTransactionFinalizer Method
FailureHandlingOptions Class See Also Send Feedback
Gets the callback to be executed after transaction is completed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public ITransactionFinalizer GetTransactionFinalizer()
Visual Basic
Public Function GetTransactionFinalizer As ITransactionFinalizer
Visual C++
public:
ITransactionFinalizer^ GetTransactionFinalizer()

Return Value

The callback to be executed after transaction is completed.

See Also

FailureHandlingOptions Class


SetClearAfterRollback Method

[image]

Revit 2024 API
FailureHandlingOptions..::..SetClearAfterRollback Method
FailureHandlingOptions Class See Also Send Feedback
Sets a flag indicating that Revit should clear all posted failures silently when the failing transaction is being rolled back intentionally. If not set, the failures may still be displayed to the user during rollback.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FailureHandlingOptions SetClearAfterRollback(
    bool bFlag
)
Visual Basic
Public Function SetClearAfterRollback ( _
    bFlag As Boolean _
) As FailureHandlingOptions
Visual C++
public:
FailureHandlingOptions^ SetClearAfterRollback(
    bool bFlag
)

Parameters

bFlag
Type: System..::..Boolean
True to clear posted failures silently if the transaction is being rolled back, false to keep these failures in place (they may be displayed to the user).

Return Value

This FailureHandlingOptions object.

See Also

FailureHandlingOptions Class


SetDelayedMiniWarnings Method

[image]

Revit 2024 API
FailureHandlingOptions..::..SetDelayedMiniWarnings Method
FailureHandlingOptions Class See Also Send Feedback
Sets a flag indicating if Revit should delay the display of the mini-warning dialog (if one is to be shown as a result of warnings in the current transaction) until the end of the next transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FailureHandlingOptions SetDelayedMiniWarnings(
    bool bFlag
)
Visual Basic
Public Function SetDelayedMiniWarnings ( _
    bFlag As Boolean _
) As FailureHandlingOptions
Visual C++
public:
FailureHandlingOptions^ SetDelayedMiniWarnings(
    bool bFlag
)

Parameters

bFlag
Type: System..::..Boolean
True to delay the display of the mini-warning dialog until the end of the next transation, false to display them as this transaction is completed.

Return Value

This FailureHandlingOptions object.

Remarks

This controls warnings suitable for the mini-warnings dialog only. If the modal flag is set to true with SetForcedModalHandling(Boolean) then this flag will be ignored.

See Also

FailureHandlingOptions Class


SetFailuresPreprocessor Method

[image]

Revit 2024 API
FailureHandlingOptions..::..SetFailuresPreprocessor Method
FailureHandlingOptions Class See Also Send Feedback
Sets the callback to be invoked in the beginning of failure processing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FailureHandlingOptions SetFailuresPreprocessor(
    IFailuresPreprocessor preprocessor
)
Visual Basic
Public Function SetFailuresPreprocessor ( _
    preprocessor As IFailuresPreprocessor _
) As FailureHandlingOptions
Visual C++
public:
FailureHandlingOptions^ SetFailuresPreprocessor(
    IFailuresPreprocessor^ preprocessor
)

Parameters

preprocessor
Type: Autodesk.Revit.DB..::..IFailuresPreprocessor
The callback to be invoked in the beginning of failure processing.

Return Value

This FailureHandlingOptions object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FailureHandlingOptions Class


SetTransactionFinalizer Method

[image]

Revit 2024 API
FailureHandlingOptions..::..SetTransactionFinalizer Method
FailureHandlingOptions Class See Also Send Feedback
Sets the callback to be executed after the transaction is completed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FailureHandlingOptions SetTransactionFinalizer(
    ITransactionFinalizer finalizer
)
Visual Basic
Public Function SetTransactionFinalizer ( _
    finalizer As ITransactionFinalizer _
) As FailureHandlingOptions
Visual C++
public:
FailureHandlingOptions^ SetTransactionFinalizer(
    ITransactionFinalizer^ finalizer
)

Parameters

finalizer
Type: Autodesk.Revit.DB..::..ITransactionFinalizer
The callback to be executed after the transaction is completed.

Return Value

This FailureHandlingOptions object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FailureHandlingOptions Class


FailureHandlingOptions Properties

[image] [image]

Revit 2024 API
FailureHandlingOptions Properties
FailureHandlingOptions Class See Also Send Feedback

The FailureHandlingOptions type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

FailureHandlingOptions Class


IsValidObject Property

[image]

Revit 2024 API
FailureHandlingOptions..::..IsValidObject Property
FailureHandlingOptions Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

FailureHandlingOptions Class


FailureMessage Members

[image] [image]

Revit 2024 API
FailureMessage Members
FailureMessage Class Constructors Methods Properties See Also Send Feedback

The FailureMessage type exposes the following members.

Constructors

 | Name | Description
Public method | FailureMessage | Creates a new FailureMessage related to a given FailureDefinition.

Methods

 | Name | Description
Public method | AddResolution | Adds a resolution for the failure.
Public method | Dispose | Releases all resources used by the FailureMessage
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAdditionalElements | Retrieves list of the additional reference elements for the failure.
Public method | GetDefaultResolutionCaption | Retrieves the caption of the default resolution of the failure.
Public method | GetDescriptionText | Retrieves the description text of the failure.
Public method | GetFailingElements | Retrieves list of the elements that have caused the failure.
Public method | GetFailureDefinitionId | Retrieves the id of the failure definition for the failure.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSeverity | Retrieves the severity of the failure.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasResolutionOfType | Checks if failure has a resolution of a given type.
Public method | HasResolutions | Checks if the failure has any resolutions.
Public method | SetAdditionalElement | Sets the additional reference element for the failure.
Public method | SetAdditionalElements | Sets the additional reference elements for the failure.
Public method | SetFailingElement | Sets the element that has caused the failure.
Public method | SetFailingElements | Sets elements that have caused the failure.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

FailureMessage Class


FailureMessage Constructor

[image]

Revit 2024 API
FailureMessage Constructor
FailureMessage Class See Also Send Feedback
Creates a new FailureMessage related to a given FailureDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FailureMessage(
    FailureDefinitionId id
)
Visual Basic
Public Sub New ( _
    id As FailureDefinitionId _
)
Visual C++
public:
FailureMessage(
    FailureDefinitionId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::..FailureDefinitionId
Id of FailureDefinition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | id is valid or does not have corresponding failure definition.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FailureMessage Class


FailureMessage Methods

[image] [image]

Revit 2024 API
FailureMessage Methods
FailureMessage Class See Also Send Feedback

The FailureMessage type exposes the following members.

Methods

 | Name | Description
Public method | AddResolution | Adds a resolution for the failure.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAdditionalElements | Retrieves list of the additional reference elements for the failure.
Public method | GetDefaultResolutionCaption | Retrieves the caption of the default resolution of the failure.
Public method | GetDescriptionText | Retrieves the description text of the failure.
Public method | GetFailingElements | Retrieves list of the elements that have caused the failure.
Public method | GetFailureDefinitionId | Retrieves the id of the failure definition for the failure.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSeverity | Retrieves the severity of the failure.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasResolutionOfType | Checks if failure has a resolution of a given type.
Public method | HasResolutions | Checks if the failure has any resolutions.
Public method | SetAdditionalElement | Sets the additional reference element for the failure.
Public method | SetAdditionalElements | Sets the additional reference elements for the failure.
Public method | SetFailingElement | Sets the element that has caused the failure.
Public method | SetFailingElements | Sets elements that have caused the failure.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FailureMessage Class


AddResolution Method

[image]

Revit 2024 API
FailureMessage..::..AddResolution Method
FailureMessage Class See Also Send Feedback
Adds a resolution for the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FailureMessage AddResolution(
    FailureResolutionType type,
    FailureResolution resolution
)
Visual Basic
Public Function AddResolution ( _
    type As FailureResolutionType, _
    resolution As FailureResolution _
) As FailureMessage
Visual C++
public:
FailureMessage^ AddResolution(
    FailureResolutionType type,
    FailureResolution^ resolution
)

Parameters

type
Type: Autodesk.Revit.DB..::..FailureResolutionType
The type of the resolution.
resolution
Type: Autodesk.Revit.DB..::..FailureResolution
The resolution.

Return Value

The FailureMessage.

Remarks

Each pair of FailureResolutionType and FailureResolution must have been defined in FailureDefinition, and could only be added once.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | type is not a valid resolution type for this FailureMessage. -or- resolution of type is not valid for this FailureMessage. -or- This FailureMessage already contains a resolution of type type.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailureMessage is already posted to a document

See Also

FailureMessage Class


Dispose Method

[image]

Revit 2024 API
FailureMessage..::..Dispose Method
FailureMessage Class See Also Send Feedback
Releases all resources used by the FailureMessage

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FailureMessage Class


GetAdditionalElements Method

[image]

Revit 2024 API
FailureMessage..::..GetAdditionalElements Method
FailureMessage Class See Also Send Feedback
Retrieves list of the additional reference elements for the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public ICollection<ElementId> GetAdditionalElements()
Visual Basic
Public Function GetAdditionalElements As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetAdditionalElements()

Return Value

The additional elements.

See Also

FailureMessage Class


GetDefaultResolutionCaption Method

[image]

Revit 2024 API
FailureMessage..::..GetDefaultResolutionCaption Method
FailureMessage Class See Also Send Feedback
Retrieves the caption of the default resolution of the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public string GetDefaultResolutionCaption()
Visual Basic
Public Function GetDefaultResolutionCaption As String
Visual C++
public:
String^ GetDefaultResolutionCaption()

Return Value

The caption of the default resolution of the failure.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailureMessage does not have any resolutions.

See Also

FailureMessage Class


GetDescriptionText Method

[image]

Revit 2024 API
FailureMessage..::..GetDescriptionText Method
FailureMessage Class See Also Send Feedback
Retrieves the description text of the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public string GetDescriptionText()
Visual Basic
Public Function GetDescriptionText As String
Visual C++
public:
String^ GetDescriptionText()

Return Value

The description text.

See Also

FailureMessage Class


GetFailureDefinitionId Method

[image]

Revit 2024 API
FailureMessage..::..GetFailureDefinitionId Method
FailureMessage Class See Also Send Feedback
Retrieves the id of the failure definition for the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FailureDefinitionId GetFailureDefinitionId()
Visual Basic
Public Function GetFailureDefinitionId As FailureDefinitionId
Visual C++
public:
FailureDefinitionId^ GetFailureDefinitionId()

Return Value

The id of the FailureDefinition for the failure.

See Also

FailureMessage Class


HasResolutionOfType Method

[image]

Revit 2024 API
FailureMessage..::..HasResolutionOfType Method
FailureMessage Class See Also Send Feedback
Checks if failure has a resolution of a given type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool HasResolutionOfType(
    FailureResolutionType type
)
Visual Basic
Public Function HasResolutionOfType ( _
    type As FailureResolutionType _
) As Boolean
Visual C++
public:
bool HasResolutionOfType(
    FailureResolutionType type
)

Parameters

type
Type: Autodesk.Revit.DB..::..FailureResolutionType
The type of resolution.

Return Value

True if the failure has a type of resolutions, else false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

FailureMessage Class


HasResolutions Method

[image]

Revit 2024 API
FailureMessage..::..HasResolutions Method
FailureMessage Class See Also Send Feedback
Checks if the failure has any resolutions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool HasResolutions()
Visual Basic
Public Function HasResolutions As Boolean
Visual C++
public:
bool HasResolutions()

Return Value

True if the failure has any resolutions, false otherwise.

See Also

FailureMessage Class


SetAdditionalElement Method

[image]

Revit 2024 API
FailureMessage..::..SetAdditionalElement Method
FailureMessage Class See Also Send Feedback
Sets the additional reference element for the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FailureMessage SetAdditionalElement(
    ElementId additionalElement
)
Visual Basic
Public Function SetAdditionalElement ( _
    additionalElement As ElementId _
) As FailureMessage
Visual C++
public:
FailureMessage^ SetAdditionalElement(
    ElementId^ additionalElement
)

Parameters

additionalElement
Type: Autodesk.Revit.DB..::..ElementId
The additional element.

Return Value

The FailureMessage.

Remarks

Additional elements are used to highlight additional information to the user. They are not considered as causing the failure, but are related to it. User cannot delete them in extended error dialog.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailureMessage is already posted to a document

See Also

FailureMessage Class


SetFailingElement Method

[image]

Revit 2024 API
FailureMessage..::..SetFailingElement Method
FailureMessage Class See Also Send Feedback
Sets the element that has caused the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FailureMessage SetFailingElement(
    ElementId id
)
Visual Basic
Public Function SetFailingElement ( _
    id As ElementId _
) As FailureMessage
Visual C++
public:
FailureMessage^ SetFailingElement(
    ElementId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::..ElementId
The element that has caused the failure.

Return Value

The FailureMessage.

Remarks

In Revit error dialog this element will be highlighted to the user and can be deleted by user via extended error dialog.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailureMessage is already posted to a document

See Also

FailureMessage Class


FailureMessage Properties

[image] [image]

Revit 2024 API
FailureMessage Properties
FailureMessage Class See Also Send Feedback

The FailureMessage type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

FailureMessage Class


IsValidObject Property

[image]

Revit 2024 API
FailureMessage..::..IsValidObject Property
FailureMessage Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

FailureMessage Class


FailureMessageAccessor Class

[image]

Revit 2024 API
FailureMessageAccessor Class
Members See Also Send Feedback
Restricted accessor for FailureMessage.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class FailureMessageAccessor : IDisposable
Visual Basic
Public Class FailureMessageAccessor _
    Implements IDisposable
Visual C++
public ref class FailureMessageAccessor : IDisposable

Remarks

Provides access to a FailureMessage stored in a Document. Reading of the information from the FailureMessage is allowed, changing of information is generally not allowed, except setting of the current resolution type.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FailureMessageAccessor

See Also

FailureMessageAccessor Members


FailureMessageAccessor Members

[image] [image]

Revit 2024 API
FailureMessageAccessor Members
FailureMessageAccessor Class Methods Properties See Also Send Feedback

The FailureMessageAccessor type exposes the following members.

Methods

 | Name | Description
Public method | CloneFailureMessage | Creates a copy of the FailureMessage.
Public method | Dispose | Releases all resources used by the FailureMessageAccessor
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAdditionalElementIds | Retrieves Ids of Elements that have not caused the failure but are related to it Checks if the failure has resolution of a given resolution type.
Public method | GetCurrentResolutionType | Retrieves the type of resolution to be used to resolve the failure.
Public method | GetDefaultResolutionCaption | Retrieves the caption of default resolution of the failure.
Public method | GetDescriptionText | Retrieves the description of the failure.
Public method | GetFailingElementIds | Retrieves Ids of Elements that have caused the failure.
Public method | GetFailureDefinitionId | Retrieves the Id of the FailureDefinition of the failure.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNumberOfResolutions | Retrieves number of resolutions that can be used to resolve failure.
Public method | GetSeverity | Retrieves the severity of the failure.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasResolutionOfType | Checks if failure has a resolution of a given type.
Public method | HasResolutions | Checks if the failure has any resolutions.
Public method | SetCurrentResolutionType | Sets the type of a resolution to be used to resolve the failure.
Public method | ShouldMergeWithMessage | Checks if the FailureMessage should be merged with the other FailureMessage for better user experience.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

FailureMessageAccessor Class


CloneFailureMessage Method

[image]

Revit 2024 API
FailureMessageAccessor..::..CloneFailureMessage Method
FailureMessageAccessor Class See Also Send Feedback
Creates a copy of the FailureMessage.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FailureMessage CloneFailureMessage()
Visual Basic
Public Function CloneFailureMessage As FailureMessage
Visual C++
public:
FailureMessage^ CloneFailureMessage()

Return Value

Copy of the FailureMesassge.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailureMessageAccessor has not been properly initialized.

See Also

FailureMessageAccessor Class


Dispose Method

[image]

Revit 2024 API
FailureMessageAccessor..::..Dispose Method
FailureMessageAccessor Class See Also Send Feedback
Releases all resources used by the FailureMessageAccessor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FailureMessageAccessor Class


GetAdditionalElementIds Method

[image]

Revit 2024 API
FailureMessageAccessor..::..GetAdditionalElementIds Method
FailureMessageAccessor Class See Also Send Feedback
Retrieves Ids of Elements that have not caused the failure but are related to it Checks if the failure has resolution of a given resolution type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public ICollection<ElementId> GetAdditionalElementIds()
Visual Basic
Public Function GetAdditionalElementIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetAdditionalElementIds()

Return Value

Ids of Elements related to the failure

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailureMessageAccessor has not been properly initialized.

See Also

FailureMessageAccessor Class


GetCurrentResolutionType Method

[image]

Revit 2024 API
FailureMessageAccessor..::..GetCurrentResolutionType Method
FailureMessageAccessor Class See Also Send Feedback
Retrieves the type of resolution to be used to resolve the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FailureResolutionType GetCurrentResolutionType()
Visual Basic
Public Function GetCurrentResolutionType As FailureResolutionType
Visual C++
public:
FailureResolutionType GetCurrentResolutionType()

Return Value

The type of failure resolution to be used to resolve the failure.

Remarks

If the current resolution type was never set for the failure, FailureResolutionType::Default is returned.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailureMessageAccessor has not been properly initialized. -or- This FailureMessageAccessor does not have any resolutions.

See Also

FailureMessageAccessor Class


GetDefaultResolutionCaption Method

[image]

Revit 2024 API
FailureMessageAccessor..::..GetDefaultResolutionCaption Method
FailureMessageAccessor Class See Also Send Feedback
Retrieves the caption of default resolution of the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public string GetDefaultResolutionCaption()
Visual Basic
Public Function GetDefaultResolutionCaption As String
Visual C++
public:
String^ GetDefaultResolutionCaption()

Return Value

The caption of default resolution of the failure.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailureMessageAccessor has not been properly initialized.

See Also

FailureMessageAccessor Class


GetDescriptionText Method

[image]

Revit 2024 API
FailureMessageAccessor..::..GetDescriptionText Method
FailureMessageAccessor Class See Also Send Feedback
Retrieves the description of the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public string GetDescriptionText()
Visual Basic
Public Function GetDescriptionText As String
Visual C++
public:
String^ GetDescriptionText()

Return Value

The description text.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailureMessageAccessor has not been properly initialized.

See Also

FailureMessageAccessor Class


GetFailingElementIds Method

[image]

Revit 2024 API
FailureMessageAccessor..::..GetFailingElementIds Method
FailureMessageAccessor Class See Also Send Feedback
Retrieves Ids of Elements that have caused the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public ICollection<ElementId> GetFailingElementIds()
Visual Basic
Public Function GetFailingElementIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetFailingElementIds()

Return Value

Ids of Elements that have caused the failure.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailureMessageAccessor has not been properly initialized.

See Also

FailureMessageAccessor Class


GetNumberOfResolutions Method

[image]

Revit 2024 API
FailureMessageAccessor..::..GetNumberOfResolutions Method
FailureMessageAccessor Class See Also Send Feedback
Retrieves number of resolutions that can be used to resolve failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public int GetNumberOfResolutions()
Visual Basic
Public Function GetNumberOfResolutions As Integer
Visual C++
public:
int GetNumberOfResolutions()

Return Value

Number of resolutions that can be used to resolve failure

Remarks

If number of resolutions is zero, the failure cannot be resolved. If severity of the failure is Warning, it can be deleted. Otherwise, the only option is to cancel current operation and roll back the transaction

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailureMessageAccessor has not been properly initialized.

See Also

FailureMessageAccessor Class


GetSeverity Method

[image]

Revit 2024 API
FailureMessageAccessor..::..GetSeverity Method
FailureMessageAccessor Class See Also Send Feedback
Retrieves the severity of the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FailureSeverity GetSeverity()
Visual Basic
Public Function GetSeverity As FailureSeverity
Visual C++
public:
FailureSeverity GetSeverity()

Return Value

The severity of the failure.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailureMessageAccessor has not been properly initialized.

See Also

FailureMessageAccessor Class


HasResolutionOfType Method

[image]

Revit 2024 API
FailureMessageAccessor..::..HasResolutionOfType Method
FailureMessageAccessor Class See Also Send Feedback
Checks if failure has a resolution of a given type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool HasResolutionOfType(
    FailureResolutionType type
)
Visual Basic
Public Function HasResolutionOfType ( _
    type As FailureResolutionType _
) As Boolean
Visual C++
public:
bool HasResolutionOfType(
    FailureResolutionType type
)

Parameters

type
Type: Autodesk.Revit.DB..::..FailureResolutionType
The type of resolution.

Return Value

True if failure has a resolution of a given type, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailureMessageAccessor has not been properly initialized.

See Also

FailureMessageAccessor Class


SetCurrentResolutionType Method

[image]

Revit 2024 API
FailureMessageAccessor..::..SetCurrentResolutionType Method
FailureMessageAccessor Class See Also Send Feedback
Sets the type of a resolution to be used to resolve the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public void SetCurrentResolutionType(
    FailureResolutionType resolutionType
)
Visual Basic
Public Sub SetCurrentResolutionType ( _
    resolutionType As FailureResolutionType _
)
Visual C++
public:
void SetCurrentResolutionType(
    FailureResolutionType resolutionType
)

Parameters

resolutionType
Type: Autodesk.Revit.DB..::..FailureResolutionType
The type of failure resolution to be used to resolve the failure.

Remarks

When FailuresAccessor is used to resolve failures, it will execute resolutions based on current resolution type. If no current resolution type is set, the default resolution type will be used. Setting is performed on the FailureMessageAccessor object itself, so if there are several accessors issued for the same FailureMessage, setting of the resolution type performed on one of them does not impact the others.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This FailureMessageAccessor has no resolution of resolutionType.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailureMessageAccessor has not been properly initialized. -or- This FailureMessageAccessor does not have any resolutions.

See Also

FailureMessageAccessor Class


ShouldMergeWithMessage Method

[image]

Revit 2024 API
FailureMessageAccessor..::..ShouldMergeWithMessage Method
FailureMessageAccessor Class See Also Send Feedback
Checks if the FailureMessage should be merged with the other FailureMessage for better user experience.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool ShouldMergeWithMessage(
    FailureMessageAccessor messageToMergeWith
)
Visual Basic
Public Function ShouldMergeWithMessage ( _
    messageToMergeWith As FailureMessageAccessor _
) As Boolean
Visual C++
public:
bool ShouldMergeWithMessage(
    FailureMessageAccessor^ messageToMergeWith
)

Parameters

messageToMergeWith
Type: Autodesk.Revit.DB..::..FailureMessageAccessor

Return Value

True if messages should be merged

Remarks

Messages should be merged if all user-visible information except failing elements is the same, failure resolution types are the same and merging lists of failing elements keeps message text applicable to all of them equally. Method is used by the Revit UI to display multiple messages as one.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | messageToMergeWith has not been properly initialized.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailureMessageAccessor has not been properly initialized.

See Also

FailureMessageAccessor Class


FailureMessageAccessor Properties

[image] [image]

Revit 2024 API
FailureMessageAccessor Properties
FailureMessageAccessor Class See Also Send Feedback

The FailureMessageAccessor type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

FailureMessageAccessor Class


IsValidObject Property

[image]

Revit 2024 API
FailureMessageAccessor..::..IsValidObject Property
FailureMessageAccessor Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

FailureMessageAccessor Class


FailureMessageKey Members

[image] [image]

Revit 2024 API
FailureMessageKey Members
FailureMessageKey Class Constructors Methods Operators Properties See Also Send Feedback

The FailureMessageKey type exposes the following members.

Constructors

 | Name | Description
Public method | FailureMessageKey | Constructs a new FailureMessageKey with default settings.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FailureMessageKey
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | GetHashCode | Gets the integer value of the id as hash code (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Checks it this key is equal to the other.
Public method | IsValid | Checks if the failure message key is valid
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Operators

Name | Description
Equality | Determines whether two FailureMessageKeys are the same.
Inequality | Determines whether two FailureMessageKeys are different.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

FailureMessageKey Class


FailureMessageKey Constructor

[image]

Revit 2024 API
FailureMessageKey Constructor
FailureMessageKey Class See Also Send Feedback
Constructs a new FailureMessageKey with default settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FailureMessageKey()
Visual Basic
Public Sub New
Visual C++
public:
FailureMessageKey()

See Also

FailureMessageKey Class


FailureMessageKey Methods

[image] [image]

Revit 2024 API
FailureMessageKey Methods
FailureMessageKey Class See Also Send Feedback

The FailureMessageKey type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | GetHashCode | Gets the integer value of the id as hash code (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Checks it this key is equal to the other.
Public method | IsValid | Checks if the failure message key is valid
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FailureMessageKey Class


Dispose Method

[image]

Revit 2024 API
FailureMessageKey..::..Dispose Method
FailureMessageKey Class See Also Send Feedback
Releases all resources used by the FailureMessageKey

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FailureMessageKey Class


IsEqual Method

[image]

Revit 2024 API
FailureMessageKey..::..IsEqual Method
FailureMessageKey Class See Also Send Feedback
Checks it this key is equal to the other.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool IsEqual(
    FailureMessageKey other
)
Visual Basic
Public Function IsEqual ( _
    other As FailureMessageKey _
) As Boolean
Visual C++
public:
bool IsEqual(
    FailureMessageKey^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..FailureMessageKey
The key to compare with.

Return Value

True if keys are equal, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FailureMessageKey Class


FailureMessageKey Operators

[image] [image]

Revit 2024 API
FailureMessageKey Operators
FailureMessageKey Class See Also Send Feedback

The FailureMessageKey type exposes the following members.

Operators

Name | Description
Equality | Determines whether two FailureMessageKeys are the same.
Inequality | Determines whether two FailureMessageKeys are different.

See Also

FailureMessageKey Class


Inequality Operator

[image]

Revit 2024 API
FailureMessageKey..::..Inequality Operator
FailureMessageKey Class See Also Send Feedback
Determines whether two FailureMessageKeys are different.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static bool operator !=(
    FailureMessageKey first,
    FailureMessageKey second
)
Visual Basic
Public Shared Operator <> ( _
    first As FailureMessageKey, _
    second As FailureMessageKey _
) As Boolean
Visual C++
public:
static bool operator !=(
    FailureMessageKey^ first,
    FailureMessageKey^ second
)

Parameters

first
Type: Autodesk.Revit.DB..::..FailureMessageKey
The first FailureMessageKey.
second
Type: Autodesk.Revit.DB..::..FailureMessageKey
The second FailureMessageKey.

Return Value

True if the FailureMessageKeys are different; otherwise, false.

See Also

FailureMessageKey Class


FailureMessageKey Properties

[image] [image]

Revit 2024 API
FailureMessageKey Properties
FailureMessageKey Class See Also Send Feedback

The FailureMessageKey type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

FailureMessageKey Class


IsValidObject Property

[image]

Revit 2024 API
FailureMessageKey..::..IsValidObject Property
FailureMessageKey Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

FailureMessageKey Class


FailureResolution Class

[image]

Revit 2024 API
FailureResolution Class
Members See Also Send Feedback
Defines a resolution for a failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class FailureResolution : IDisposable
Visual Basic
Public Class FailureResolution _
    Implements IDisposable
Visual C++
public ref class FailureResolution : IDisposable

Remarks

A failure could have several permitted resolutions. List of applicable resolution types for the specific failure is defined by the FailureDefinition, actual FailureResolutions are instantiated with the FailureMessage before it is posted. Multiple resolutions per failure are allowed, although Revit UI only uses default resolution.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FailureResolution
Autodesk.Revit.DB..::..DeleteElements
Autodesk.Revit.DB..::..DisableAnalyticalModelCB

See Also

FailureResolution Members


FailureResolution Members

[image] [image]

Revit 2024 API
FailureResolution Members
FailureResolution Class Methods Properties See Also Send Feedback

The FailureResolution type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FailureResolution
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

FailureResolution Class


Dispose Method

[image]

Revit 2024 API
FailureResolution..::..Dispose Method
FailureResolution Class See Also Send Feedback
Releases all resources used by the FailureResolution

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FailureResolution Class


FailureResolution Properties

[image] [image]

Revit 2024 API
FailureResolution Properties
FailureResolution Class See Also Send Feedback

The FailureResolution type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

FailureResolution Class


IsValidObject Property

[image]

Revit 2024 API
FailureResolution..::..IsValidObject Property
FailureResolution Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

FailureResolution Class


FailureResolutionType Enumeration

[image]

Revit 2024 API
FailureResolutionType Enumeration
See Also Send Feedback
Enumeration to classify FailureResolutions by nature of operation they perform on failing Elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public enum FailureResolutionType
Visual Basic
Public Enumeration FailureResolutionType
Visual C++
public enum class FailureResolutionType

Members

Member name | Description
Invalid | Special (reserved) type. This should be non-initialized value of any variable of FailureResolutionType, end user should not see this value, API programmer could use this in initialization and comparison.
Default | Special (reserved) type. It cannot be used as a type when defining a resolution, but can be used as a key to query default resolution from FailureMessage or FailureDefinition.
CreateElements | Defines a resolution of a failure where Revit will add new Element(s) in place of missing one(s).
DeleteElements | Defines a resolution of a failure by deleting Element(s) that caused the failure.
SkipElements | Defines a resolution of a failure by skipping Element(s) for which operation has failed and proceeding with the rest of Elements.
MoveElements | Defines a resolution of a failure by moving Element(s) to an appropriate location.
FixElements | Defines a resolution of a failure by changing failing Element(s) - specific change may vary depending in type of failure and type of Element(s).
DetachElements | Defines a resolution of a failure by removing invalid relationships between elements such as joined walls and roofs, grouped elements, and associated curves.
QuitEditMode | Defines a resolution of a failure by quitting an Edit Mode instead of committing changes. Changes made in edit mode will be rolled back.
UnlockConstraints | Defines a resolution of a failure by unconstraining Element(s).
SetValue | Defines a resolution of a failure by setting an appropriate value in place of invalid value.
SaveDocument | Save the current document to avoid losing more if something serious occurs.
ShowElements | The standard "Show" may fail in some context, special resolution could be added in this condition to show failing element(s).
Others | Resolution type does not match any of the above.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


FailuresAccessor Members

[image] [image]

Revit 2024 API
FailuresAccessor Members
FailuresAccessor Class Methods Properties See Also Send Feedback

The FailuresAccessor type exposes the following members.

Methods

 | Name | Description
Public method | CanCommitPendingTransaction | Checks if pending failure processing can be finished by committing a pending transaction.
Public method | CanRollBackPendingTransaction | Checks if pending failure processing can be finished by rolling back a pending transaction.
Public method | CommitPendingTransaction | Finishes pending failures processing by committing the pending transaction.
Public method | DeleteAllWarnings | Deletes all FailureMessages of severity "Warning" currently posted in a document.
Public method | DeleteElements | Resolves failures by deletion of elements related to the failures.
Public method | DeleteWarning | Deletes one specific failure message of severity "Warning".
Public method | Dispose | Releases all resources used by the FailuresAccessor
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAttemptedResolutionTypes | Returns list of the failure resolution types attempted for the failure in the current transaction.
Public method | GetDocument | Provides access to a document for which failures are being processed or preprocessed.
Public method | GetFailureHandlingOptions | Provides access to the failure handling options for the transaction currently being finished.
Public method | GetFailureMessages()()()() | Provides access to the individual failure messages currently posted in the document.
Public method | GetFailureMessages(FailureSeverity) | Provides access to the individual failure messages if a given severity currently posted in the document.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSeverity | Provides access to the current failure severity.
Public method | GetTransactionName | Retrieves the name of the transaction for which failures are being processed.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsActive | Method allows to check if this instance of the accessor is currently active.
Public method | IsElementsDeletionPermitted()()()() | Checks if resolution of the failures by deleting failure elements is permitted.
Public method | IsElementsDeletionPermitted(IList<(Of <<'(ElementId>)>>)) | Checks if resolution of the failures by deleting given collection of elements is permitted.
Public method | IsElementsDeletionPermitted(IList<(Of <<'(ElementId>)>>), String%) | Checks if resolution of the failures by deleting given collection of elements is permitted.
Public method | IsFailureResolutionPermitted()()()() | Checks if resolution of failures is permitted.
Public method | IsFailureResolutionPermitted(FailureMessageAccessor) | Checks if default resolution of the failure is permitted.
Public method | IsFailureResolutionPermitted(FailureMessageAccessor, FailureResolutionType) | Checks if resolution of the failure using given resolution type is permitted.
Public method | IsPending | Checks if the failure processing is pending.
Public method | IsTransactionBeingCommitted | Checks if the transaction for which failures are processed is being committed or rolled back.
Public method | JournalFailures | Allows to record information about failures in the journal.
Public method | PostFailure | Posts an additional failure message to be processed for the current transaction.
Public method | ReplaceFailures | Deletes all failure messages currently posted in a document and replaces them with one "generic" failure.
Public method | ResolveFailure | Resolves one failure using the failure resolution type last set for it.
Public method | ResolveFailures | Resolves one or more failures using last set failure resolution type for each of the failures. If failure resolution type was not set for some of failures, default failure resolution type will be used.
Public method | RollBackPendingTransaction | Finishes pending failures processing by rolling back the pending transaction.
Public method | SetFailureHandlingOptions | Sets failure handling options for the transaction currently being finished.
Public method | SetTransactionName | Changes the name of the transaction for which failures are being processed.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

FailuresAccessor Class


FailuresAccessor Methods

[image] [image]

Revit 2024 API
FailuresAccessor Methods
FailuresAccessor Class See Also Send Feedback

The FailuresAccessor type exposes the following members.

Methods

 | Name | Description
Public method | CanCommitPendingTransaction | Checks if pending failure processing can be finished by committing a pending transaction.
Public method | CanRollBackPendingTransaction | Checks if pending failure processing can be finished by rolling back a pending transaction.
Public method | CommitPendingTransaction | Finishes pending failures processing by committing the pending transaction.
Public method | DeleteAllWarnings | Deletes all FailureMessages of severity "Warning" currently posted in a document.
Public method | DeleteElements | Resolves failures by deletion of elements related to the failures.
Public method | DeleteWarning | Deletes one specific failure message of severity "Warning".
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAttemptedResolutionTypes | Returns list of the failure resolution types attempted for the failure in the current transaction.
Public method | GetDocument | Provides access to a document for which failures are being processed or preprocessed.
Public method | GetFailureHandlingOptions | Provides access to the failure handling options for the transaction currently being finished.
Public method | GetFailureMessages()()()() | Provides access to the individual failure messages currently posted in the document.
Public method | GetFailureMessages(FailureSeverity) | Provides access to the individual failure messages if a given severity currently posted in the document.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSeverity | Provides access to the current failure severity.
Public method | GetTransactionName | Retrieves the name of the transaction for which failures are being processed.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsActive | Method allows to check if this instance of the accessor is currently active.
Public method | IsElementsDeletionPermitted()()()() | Checks if resolution of the failures by deleting failure elements is permitted.
Public method | IsElementsDeletionPermitted(IList<(Of <<'(ElementId>)>>)) | Checks if resolution of the failures by deleting given collection of elements is permitted.
Public method | IsElementsDeletionPermitted(IList<(Of <<'(ElementId>)>>), String%) | Checks if resolution of the failures by deleting given collection of elements is permitted.
Public method | IsFailureResolutionPermitted()()()() | Checks if resolution of failures is permitted.
Public method | IsFailureResolutionPermitted(FailureMessageAccessor) | Checks if default resolution of the failure is permitted.
Public method | IsFailureResolutionPermitted(FailureMessageAccessor, FailureResolutionType) | Checks if resolution of the failure using given resolution type is permitted.
Public method | IsPending | Checks if the failure processing is pending.
Public method | IsTransactionBeingCommitted | Checks if the transaction for which failures are processed is being committed or rolled back.
Public method | JournalFailures | Allows to record information about failures in the journal.
Public method | PostFailure | Posts an additional failure message to be processed for the current transaction.
Public method | ReplaceFailures | Deletes all failure messages currently posted in a document and replaces them with one "generic" failure.
Public method | ResolveFailure | Resolves one failure using the failure resolution type last set for it.
Public method | ResolveFailures | Resolves one or more failures using last set failure resolution type for each of the failures. If failure resolution type was not set for some of failures, default failure resolution type will be used.
Public method | RollBackPendingTransaction | Finishes pending failures processing by rolling back the pending transaction.
Public method | SetFailureHandlingOptions | Sets failure handling options for the transaction currently being finished.
Public method | SetTransactionName | Changes the name of the transaction for which failures are being processed.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FailuresAccessor Class


CanCommitPendingTransaction Method

[image]

Revit 2024 API
FailuresAccessor..::..CanCommitPendingTransaction Method
FailuresAccessor Class See Also Send Feedback
Checks if pending failure processing can be finished by committing a pending transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool CanCommitPendingTransaction()
Visual Basic
Public Function CanCommitPendingTransaction As Boolean
Visual C++
public:
bool CanCommitPendingTransaction()

Return Value

True if there is a pending transaction and this transaction is allowed to be committed.

Remarks

Check makes sense only if the failure processing is pending.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class


DeleteAllWarnings Method

[image]

Revit 2024 API
FailuresAccessor..::..DeleteAllWarnings Method
FailuresAccessor Class See Also Send Feedback
Deletes all FailureMessages of severity "Warning" currently posted in a document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public void DeleteAllWarnings()
Visual Basic
Public Sub DeleteAllWarnings
Visual C++
public:
void DeleteAllWarnings()

Remarks

Warnings are deleted immediately and will not be accessible by any further failures processing. Any accessors for these failure messages become invalid.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class


DeleteElements Method

[image]

Revit 2024 API
FailuresAccessor..::..DeleteElements Method
FailuresAccessor Class See Also Send Feedback
Resolves failures by deletion of elements related to the failures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public void DeleteElements(
    IList<ElementId> idsToDelete
)
Visual Basic
Public Sub DeleteElements ( _
    idsToDelete As IList(Of ElementId) _
)
Visual C++
public:
void DeleteElements(
    IList<ElementId^>^ idsToDelete
)

Parameters

idsToDelete
Type: System.Collections.Generic..::..IList<(Of <(<' ElementId >)>)>
Ids of elements to be deleted.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Resolution of the failures by deleting idsToDelete is not permitted
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class


DeleteWarning Method

[image]

Revit 2024 API
FailuresAccessor..::..DeleteWarning Method
FailuresAccessor Class See Also Send Feedback
Deletes one specific failure message of severity "Warning".

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public void DeleteWarning(
    FailureMessageAccessor failure
)
Visual Basic
Public Sub DeleteWarning ( _
    failure As FailureMessageAccessor _
)
Visual C++
public:
void DeleteWarning(
    FailureMessageAccessor^ failure
)

Parameters

failure
Type: Autodesk.Revit.DB..::..FailureMessageAccessor
The accessor to the warning to be deleted.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | failure has not been properly initialized. -or- Severity of failure is not FailureSeverity::Warning.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class


Dispose Method

[image]

Revit 2024 API
FailuresAccessor..::..Dispose Method
FailuresAccessor Class See Also Send Feedback
Releases all resources used by the FailuresAccessor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FailuresAccessor Class


GetAttemptedResolutionTypes Method

[image]

Revit 2024 API
FailuresAccessor..::..GetAttemptedResolutionTypes Method
FailuresAccessor Class See Also Send Feedback
Returns list of the failure resolution types attempted for the failure in the current transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public IList<FailureResolutionType> GetAttemptedResolutionTypes(
    FailureMessageAccessor failure
)
Visual Basic
Public Function GetAttemptedResolutionTypes ( _
    failure As FailureMessageAccessor _
) As IList(Of FailureResolutionType)
Visual C++
public:
IList<FailureResolutionType>^ GetAttemptedResolutionTypes(
    FailureMessageAccessor^ failure
)

Parameters

failure
Type: Autodesk.Revit.DB..::..FailureMessageAccessor
The failure.

Return Value

The list of the types of failure resolutions attempted for the failure.

Remarks

In some cases attempt to resolve a failure has no impact or failure gets reposted during next round of the end of transaction checks after being resolved. Knowing if any failure resolutions were attempted for the failure allows failures processor to prevent infinite loop.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | failure has not been properly initialized.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class


GetFailureMessages Method

[image] [image]

Revit 2024 API
FailuresAccessor..::..GetFailureMessages Method
FailuresAccessor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetFailureMessages()()()() | Provides access to the individual failure messages currently posted in the document.
Public method | GetFailureMessages(FailureSeverity) | Provides access to the individual failure messages if a given severity currently posted in the document.

See Also

FailuresAccessor Class
FailuresAccessor Members


GetFailureMessages Method (FailureSeverity)

[image]

Revit 2024 API
FailuresAccessor..::..GetFailureMessages Method (FailureSeverity)
FailuresAccessor Class See Also Send Feedback
Provides access to the individual failure messages if a given severity currently posted in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public IList<FailureMessageAccessor> GetFailureMessages(
    FailureSeverity severity
)
Visual Basic
Public Function GetFailureMessages ( _
    severity As FailureSeverity _
) As IList(Of FailureMessageAccessor)
Visual C++
public:
IList<FailureMessageAccessor^>^ GetFailureMessages(
    FailureSeverity severity
)

Parameters

severity
Type: Autodesk.Revit.DB..::..FailureSeverity
The failure severity for which failure messages are requested. If the requested severity is None, an empty collection is returned.

Return Value

Accessors to the individual failure messages of a given severity posted in the document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class
GetFailureMessages Overload


GetSeverity Method

[image]

Revit 2024 API
FailuresAccessor..::..GetSeverity Method
FailuresAccessor Class See Also Send Feedback
Provides access to the current failure severity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FailureSeverity GetSeverity()
Visual Basic
Public Function GetSeverity As FailureSeverity
Visual C++
public:
FailureSeverity GetSeverity()

Return Value

The highest severity of a failure message currently posted in the document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class


GetTransactionName Method

[image]

Revit 2024 API
FailuresAccessor..::..GetTransactionName Method
FailuresAccessor Class See Also Send Feedback
Retrieves the name of the transaction for which failures are being processed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public string GetTransactionName()
Visual Basic
Public Function GetTransactionName As String
Visual C++
public:
String^ GetTransactionName()

Return Value

The name of the transaction for which failures are being processed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class


IsElementsDeletionPermitted Method

[image] [image]

Revit 2024 API
FailuresAccessor..::..IsElementsDeletionPermitted Method
FailuresAccessor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsElementsDeletionPermitted()()()() | Checks if resolution of the failures by deleting failure elements is permitted.
Public method | IsElementsDeletionPermitted(IList<(Of <<'(ElementId>)>>)) | Checks if resolution of the failures by deleting given collection of elements is permitted.
Public method | IsElementsDeletionPermitted(IList<(Of <<'(ElementId>)>>), String%) | Checks if resolution of the failures by deleting given collection of elements is permitted.

See Also

FailuresAccessor Class
FailuresAccessor Members


IsElementsDeletionPermitted Method

[image]

Revit 2024 API
FailuresAccessor..::..IsElementsDeletionPermitted Method
FailuresAccessor Class See Also Send Feedback
Checks if resolution of the failures by deleting failure elements is permitted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool IsElementsDeletionPermitted()
Visual Basic
Public Function IsElementsDeletionPermitted As Boolean
Visual C++
public:
bool IsElementsDeletionPermitted()

Return Value

True if resolution of the failures by deleting failure elements is permitted.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class
IsElementsDeletionPermitted Overload


IsFailureResolutionPermitted Method

[image] [image]

Revit 2024 API
FailuresAccessor..::..IsFailureResolutionPermitted Method
FailuresAccessor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsFailureResolutionPermitted()()()() | Checks if resolution of failures is permitted.
Public method | IsFailureResolutionPermitted(FailureMessageAccessor) | Checks if default resolution of the failure is permitted.
Public method | IsFailureResolutionPermitted(FailureMessageAccessor, FailureResolutionType) | Checks if resolution of the failure using given resolution type is permitted.

See Also

FailuresAccessor Class
FailuresAccessor Members


IsFailureResolutionPermitted Method

[image]

Revit 2024 API
FailuresAccessor..::..IsFailureResolutionPermitted Method
FailuresAccessor Class See Also Send Feedback
Checks if resolution of failures is permitted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool IsFailureResolutionPermitted()
Visual Basic
Public Function IsFailureResolutionPermitted As Boolean
Visual C++
public:
bool IsFailureResolutionPermitted()

Return Value

True if resolutions of failures is permitted.

See Also

FailuresAccessor Class
IsFailureResolutionPermitted Overload


IsFailureResolutionPermitted Method (FailureMessageAccessor)

[image]

Revit 2024 API
FailuresAccessor..::..IsFailureResolutionPermitted Method (FailureMessageAccessor)
FailuresAccessor Class See Also Send Feedback
Checks if default resolution of the failure is permitted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool IsFailureResolutionPermitted(
    FailureMessageAccessor failure
)
Visual Basic
Public Function IsFailureResolutionPermitted ( _
    failure As FailureMessageAccessor _
) As Boolean
Visual C++
public:
bool IsFailureResolutionPermitted(
    FailureMessageAccessor^ failure
)

Parameters

failure
Type: Autodesk.Revit.DB..::..FailureMessageAccessor
The accessor to the failure to be resolved.

Return Value

True if default resolution of the failure is permitted

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | failure has not been properly initialized.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class
IsFailureResolutionPermitted Overload


IsFailureResolutionPermitted Method (FailureMessageAccessor, FailureResolutionType)

[image]

Revit 2024 API
FailuresAccessor..::..IsFailureResolutionPermitted Method (FailureMessageAccessor, FailureResolutionType)
FailuresAccessor Class See Also Send Feedback
Checks if resolution of the failure using given resolution type is permitted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool IsFailureResolutionPermitted(
    FailureMessageAccessor failure,
    FailureResolutionType resolutionType
)
Visual Basic
Public Function IsFailureResolutionPermitted ( _
    failure As FailureMessageAccessor, _
    resolutionType As FailureResolutionType _
) As Boolean
Visual C++
public:
bool IsFailureResolutionPermitted(
    FailureMessageAccessor^ failure,
    FailureResolutionType resolutionType
)

Parameters

failure
Type: Autodesk.Revit.DB..::..FailureMessageAccessor
Accessor to the failure to be resolved.
resolutionType
Type: Autodesk.Revit.DB..::..FailureResolutionType
Type of the failure resolution to be used.

Return Value

True if resolution of the failure using given resolution type is permitted.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | failure has not been properly initialized.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class
IsFailureResolutionPermitted Overload


IsPending Method

[image]

Revit 2024 API
FailuresAccessor..::..IsPending Method
FailuresAccessor Class See Also Send Feedback
Checks if the failure processing is pending.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool IsPending()
Visual Basic
Public Function IsPending As Boolean
Visual C++
public:
bool IsPending()

Return Value

True if the failures processing is in the pending state.

Remarks

The failure processing is pending after failures processor has returned WaitForUserInput and until pending state is finished by either committing or rolling back of the pending transaction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class


IsTransactionBeingCommitted Method

[image]

Revit 2024 API
FailuresAccessor..::..IsTransactionBeingCommitted Method
FailuresAccessor Class See Also Send Feedback
Checks if the transaction for which failures are processed is being committed or rolled back.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool IsTransactionBeingCommitted()
Visual Basic
Public Function IsTransactionBeingCommitted As Boolean
Visual C++
public:
bool IsTransactionBeingCommitted()

Return Value

True if current transaction is being committed, false if the transaction is being rolled back.

Remarks

A transaction is considered as "being committed" if a caller has requested the transaction to be committed and no previous failure processing operation requested the transaction to be rolled back.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class


JournalFailures Method

[image]

Revit 2024 API
FailuresAccessor..::..JournalFailures Method
FailuresAccessor Class See Also Send Feedback
Allows to record information about failures in the journal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public void JournalFailures(
    IList<FailureMessageAccessor> failures
)
Visual Basic
Public Sub JournalFailures ( _
    failures As IList(Of FailureMessageAccessor) _
)
Visual C++
public:
void JournalFailures(
    IList<FailureMessageAccessor^>^ failures
)

Parameters

failures
Type: System.Collections.Generic..::..IList<(Of <(<' FailureMessageAccessor >)>)>
Accessors to the failures to journal.

Remarks

Records information about failure messages and elements involved in the failures. If this method not invoked, journal does not contain any information about failures resolved by (pre)processing.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class


PostFailure Method

[image]

Revit 2024 API
FailuresAccessor..::..PostFailure Method
FailuresAccessor Class See Also Send Feedback
Posts an additional failure message to be processed for the current transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public void PostFailure(
    FailureMessage failure
)
Visual Basic
Public Sub PostFailure ( _
    failure As FailureMessage _
)
Visual C++
public:
void PostFailure(
    FailureMessage^ failure
)

Parameters

failure
Type: Autodesk.Revit.DB..::..FailureMessage
Failure message to post.

Remarks

Should be used during failures processing instead of a similar method in a document class. Using method of the document class with the same name during failures processing is prohibited.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class


ReplaceFailures Method

[image]

Revit 2024 API
FailuresAccessor..::..ReplaceFailures Method
FailuresAccessor Class See Also Send Feedback
Deletes all failure messages currently posted in a document and replaces them with one "generic" failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public void ReplaceFailures(
    FailureMessage failure
)
Visual Basic
Public Sub ReplaceFailures ( _
    failure As FailureMessage _
)
Visual C++
public:
void ReplaceFailures(
    FailureMessage^ failure
)

Parameters

failure
Type: Autodesk.Revit.DB..::..FailureMessage
FailureMessage that should replace all currently posted messages. It must have severity DocumentCorruption.

Remarks

If analysis done by Failures Processing code concludes that in a given context delivering of the posted failures to the user makes no sense, this method can be used to discard all posted failures and substitute one "generic" one, that will be delivered to the user and then transaction forced to be aborted. After the call, (pre)processing of failures should return ProceedWithRollback.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Severity of failure must be FailureSeverity::DocumentCorruption.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class


ResolveFailures Method

[image]

Revit 2024 API
FailuresAccessor..::..ResolveFailures Method
FailuresAccessor Class See Also Send Feedback
Resolves one or more failures using last set failure resolution type for each of the failures. If failure resolution type was not set for some of failures, default failure resolution type will be used.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public void ResolveFailures(
    IList<FailureMessageAccessor> failures
)
Visual Basic
Public Sub ResolveFailures ( _
    failures As IList(Of FailureMessageAccessor) _
)
Visual C++
public:
void ResolveFailures(
    IList<FailureMessageAccessor^>^ failures
)

Parameters

failures
Type: System.Collections.Generic..::..IList<(Of <(<' FailureMessageAccessor >)>)>
The accessors to the failures to be resolved.

Remarks

After execution of the failure resolutions the failures will not be removed from the document automatically. To prevent failure from being delivered to the user, failures (pre)processor should return ProceedWithCommit. It will cause failures to be regenerated and failure resolution process to be restarted. If attempt to resolve failure was not successful, and the same failure is present on repetitive calls of the failures (pre)processor, the preprocessor code should take care to attempt a different resolution the next time the failure appears, to avoid an infinite loop.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Default resolution of one of the failures is not permitted or not applicable. -or- One of the failures was already attempted to resolve twice with that resolution type.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing). -or- Resolution of failures is not permitted in the current state of the document.

See Also

FailuresAccessor Class


RollBackPendingTransaction Method

[image]

Revit 2024 API
FailuresAccessor..::..RollBackPendingTransaction Method
FailuresAccessor Class See Also Send Feedback
Finishes pending failures processing by rolling back the pending transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public TransactionStatus RollBackPendingTransaction()
Visual Basic
Public Function RollBackPendingTransaction As TransactionStatus
Visual C++
public:
TransactionStatus RollBackPendingTransaction()

Return Value

Result of attempt to roll back the pending transaction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing). -or- The processing of the failures is not in the pending state.

See Also

FailuresAccessor Class


SetFailureHandlingOptions Method

[image]

Revit 2024 API
FailuresAccessor..::..SetFailureHandlingOptions Method
FailuresAccessor Class See Also Send Feedback
Sets failure handling options for the transaction currently being finished.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public void SetFailureHandlingOptions(
    FailureHandlingOptions options
)
Visual Basic
Public Sub SetFailureHandlingOptions ( _
    options As FailureHandlingOptions _
)
Visual C++
public:
void SetFailureHandlingOptions(
    FailureHandlingOptions^ options
)

Parameters

options
Type: Autodesk.Revit.DB..::..FailureHandlingOptions
The failure handling options to be set for the transaction currently being finished.

Remarks

If used with returning ProceedWithRollback from (pre)processing, allows to dismiss errors and roll back transaction without any further failures processing and silently for the user.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class


SetTransactionName Method

[image]

Revit 2024 API
FailuresAccessor..::..SetTransactionName Method
FailuresAccessor Class See Also Send Feedback
Changes the name of the transaction for which failures are being processed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public void SetTransactionName(
    string transactionName
)
Visual Basic
Public Sub SetTransactionName ( _
    transactionName As String _
)
Visual C++
public:
void SetTransactionName(
    String^ transactionName
)

Parameters

transactionName
Type: System..::..String
The name of the transaction to set.

Remarks

If the transaction will be committed by or after failures processing it can change its name to reflect results of processing of the failures. For example, if the original transaction name was "review warnings" and some of the warnings were resolved by deleting of the relevant elements, failures processor may change the name of the transaction to "delete elements".

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | transactionName is an empty string.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class


FailuresAccessor Properties

[image] [image]

Revit 2024 API
FailuresAccessor Properties
FailuresAccessor Class See Also Send Feedback

The FailuresAccessor type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

FailuresAccessor Class


Family Methods

[image] [image]

Revit 2024 API
Family Methods
Family Class See Also Send Feedback

The Family type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveStructuralSection | Identifies if this Family can have a structural section.
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
 | CanLoadFamilies | Checks whether the document is in a state that allows the loading of families.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | ExtractPartAtom | Writes a PartAtom XML from the contents of a family object.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetFamilySymbolIds | Gets the ids of the FamilySymbols owned by this Family.
Public method | GetFamilyTypeParameterValues | Returns all applicable values for a FamilyType parameter of this family.
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasLargeSketches | Checks whether the family contains sketches with a large number of elements.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsAppropriateCategoryId | Identifies if the input category id can be assigned as the new category for this family.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Family Class


CanHaveStructuralSection Method

[image]

Revit 2024 API
Family..::..CanHaveStructuralSection Method
Family Class See Also Send Feedback
Identifies if this Family can have a structural section.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool CanHaveStructuralSection()
Visual Basic
Public Function CanHaveStructuralSection As Boolean
Visual C++
public:
bool CanHaveStructuralSection()

Return Value

True if the Family can have structural section, false otherwise.

See Also

Family Class


GetFamilySymbolIds Method

[image]

Revit 2024 API
Family..::..GetFamilySymbolIds Method
Family Class See Also Send Feedback
Gets the ids of the FamilySymbols owned by this Family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public ISet<ElementId> GetFamilySymbolIds()
Visual Basic
Public Function GetFamilySymbolIds As ISet(Of ElementId)
Visual C++
public:
ISet<ElementId^>^ GetFamilySymbolIds()

Return Value

The ids of the FamilySymbols.

See Also

Family Class


GetFamilyTypeParameterValues Method

[image]

Revit 2024 API
Family..::..GetFamilyTypeParameterValues Method
Family Class Example See Also Send Feedback
Returns all applicable values for a FamilyType parameter of this family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public ISet<ElementId> GetFamilyTypeParameterValues(
    ElementId parameterId
)
Visual Basic
Public Function GetFamilyTypeParameterValues ( _
    parameterId As ElementId _
) As ISet(Of ElementId)
Visual C++
public:
ISet<ElementId^>^ GetFamilyTypeParameterValues(
    ElementId^ parameterId
)

Parameters

parameterId
Type: Autodesk.Revit.DB..::..ElementId
A valid Id of a FamilyType parameter defined for this family.

Return Value

Ids of all applicable ElementType and NestedFamilyTypeReference elements.

Remarks

The values are Element Ids of all family types that match the category specified by the definition of the given parameter. The elements are either of class ElementType or NestedFamilyTypeReference. The second variant is for the types that are nested in families and thus are not accessible otherwise.

If there are no applicable types of such category the returned collection will be empty.

Examples

CopyC#
public void GetNestedFamilyTypes(FamilyInstance instance)
{
    // find one FamilyType parameter and all values applicable to it

    Parameter aTypeParam = null;
    ISet<ElementId> values = null;

    Family family = instance.Symbol.Family;

    foreach (Parameter param in instance.Symbol.Parameters)
    {

        if (Category.IsBuiltInCategory(param.Definition.GetDataType()))
        {

            aTypeParam = param;

            values = family.GetFamilyTypeParameterValues(param.Id);

            break;
        }
    }

    if (aTypeParam == null)
    {
        TaskDialog.Show("Warning", "The selected family has no FamilyType parameter defined.");
    }
    else if (values == null)
    {
        TaskDialog.Show("Error", "A FamilyType parameter does not have any applicable values!?");
    }
    else
    {
        ElementId newValue = values.Last<ElementId>();

        if (newValue != aTypeParam.AsElementId())
        {

            using (Transaction trans = new Transaction(instance.Document, "Setting parameter value"))
            {

                trans.Start();
                aTypeParam.Set(newValue);
                trans.Commit();
            }
        }
    }
}
CopyVB.NET
Public Sub GetNestedFamilyTypes(instance As FamilyInstance)
    ' find one FamilyType parameter and all values applicable to it

    Dim aTypeParam As Parameter = Nothing
    Dim values As ISet(Of ElementId) = Nothing

    Dim family As Family = instance.Symbol.Family

    For Each param As Parameter In instance.Symbol.Parameters

        If Category.IsBuiltInCategory(param.Definition.GetDataType()) Then

            aTypeParam = param

            values = family.GetFamilyTypeParameterValues(param.Id)

            Exit For
        End If
    Next

    If aTypeParam Is Nothing Then
        TaskDialog.Show("Warning", "The selected family has no FamilyType parameter defined.")
    ElseIf values Is Nothing Then
        TaskDialog.Show("Error", "A FamilyType parameter does not have any applicable values!?")
    Else
        Dim newValue As ElementId = values.Last()

        If newValue <> aTypeParam.AsElementId() Then

            Using trans As New Transaction(instance.Document, "Setting parameter value")

                trans.Start()
                aTypeParam.[Set](newValue)
                trans.Commit()
            End Using
        End If
    End If
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given parameterId does not represent a valid FamilyType parameter of this family.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Family Class


HasLargeSketches Method

[image]

Revit 2024 API
Family..::..HasLargeSketches Method
Family Class See Also Send Feedback
Checks whether the family contains sketches with a large number of elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public bool HasLargeSketches()
Visual Basic
Public Function HasLargeSketches As Boolean
Visual C++
public:
bool HasLargeSketches()

Remarks

Families containing large sketches (typically with 300+ elements) may cause performance problems in parametric families (see IsParametric). Thus, before adding any constraints to a family (which will make the family parametric,) this method can be queried and the decision about whether the family should indeed be turned parametric may be deferred to the end-user.

See Also

Family Class


IsAppropriateCategoryId Method

[image]

Revit 2024 API
Family..::..IsAppropriateCategoryId Method
Family Class See Also Send Feedback
Identifies if the input category id can be assigned as the new category for this family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool IsAppropriateCategoryId(
    ElementId categoryId
)
Visual Basic
Public Function IsAppropriateCategoryId ( _
    categoryId As ElementId _
) As Boolean
Visual C++
public:
bool IsAppropriateCategoryId(
    ElementId^ categoryId
)

Parameters

categoryId
Type: Autodesk.Revit.DB..::..ElementId
The category id.

Return Value

True if the input category id can be assigned as the new category for this family, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Family Class


Family Properties

[image] [image]

Revit 2024 API
Family Properties
Family Class See Also Send Feedback

The Family type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurtainPanelHorizontalSpacing | For Curtain Panel families, the horizontal spacing of the driving mesh.
Public property | CurtainPanelTilePattern | For Curtain Panel families, the choice of tile pattern.
Public property | CurtainPanelVerticalSpacing | For Curtain Panel families, the vertical spacing of the driving mesh.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyCategory | Retrieves or sets a Category object that represents the category or sub category in which the elements ( this family could generate ) reside.
Public property | FamilyCategoryId | The id of the category or sub category in which the elements that this family could generate reside.
Public property | FamilyPlacementType | Identifies the type of placement required by a given family.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsConceptualMassFamily | Whether the Family is a Conceptual Mass family.
Public property | IsCurtainPanelFamily | Whether the Family is a Curtain Panel family. Curtain Panel family symbols are used as the ObjectTypes of DividedSurface elements.
Public property | IsEditable | True if the family supports editing, false otherwise.
Public property | IsInPlace | True if the family is an in-place family, false if the family is a loadable family.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsOwnerFamily | True if the family is the owner family for its own editable document, false otherwise.
Public property | IsParametric | Identifies whether the family contains parametric relations between some of its elements.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsUserCreated | Determine whether the family has been defined by the user.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ShowSpatialElementCalculationPoint | For families that can have a calculation point for spatial elements, hide or show the calculation point. SpatialElementCalculationPoint elements.
Public property | StructuralCodeName | The family's structural code name.
Public property | StructuralFamilyNameKey | The family's structural section shape name key.
Public property | StructuralMaterialType | The family's structural material type.
Public property | StructuralSectionShape | The family's structural section shape.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Family Class


CurtainPanelHorizontalSpacing Property

[image]

Revit 2024 API
Family..::..CurtainPanelHorizontalSpacing Property
Family Class See Also Send Feedback
For Curtain Panel families, the horizontal spacing of the driving mesh.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double CurtainPanelHorizontalSpacing { get; set; }
Visual Basic
Public Property CurtainPanelHorizontalSpacing As Double
    Get
    Set
Visual C++
public:
property double CurtainPanelHorizontalSpacing {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if this family is not the owner family of a curtain panel family document.

See Also

Family Class


CurtainPanelTilePattern Property

[image]

Revit 2024 API
Family..::..CurtainPanelTilePattern Property
Family Class See Also Send Feedback
For Curtain Panel families, the choice of tile pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public TilePatternsBuiltIn CurtainPanelTilePattern { get; }
Visual Basic
Public ReadOnly Property CurtainPanelTilePattern As TilePatternsBuiltIn
    Get
Visual C++
public:
property TilePatternsBuiltIn CurtainPanelTilePattern {
    TilePatternsBuiltIn get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if this family is not a Curtain Panel family.

See Also

Family Class


CurtainPanelVerticalSpacing Property

[image]

Revit 2024 API
Family..::..CurtainPanelVerticalSpacing Property
Family Class See Also Send Feedback
For Curtain Panel families, the vertical spacing of the driving mesh.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double CurtainPanelVerticalSpacing { get; set; }
Visual Basic
Public Property CurtainPanelVerticalSpacing As Double
    Get
    Set
Visual C++
public:
property double CurtainPanelVerticalSpacing {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if this family is not the owner family of a curtain panel family document.

See Also

Family Class


FamilyCategoryId Property

[image]

Revit 2024 API
Family..::..FamilyCategoryId Property
Family Class See Also Send Feedback
The id of the category or sub category in which the elements that this family could generate reside.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public ElementId FamilyCategoryId { get; set; }
Visual Basic
Public Property FamilyCategoryId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ FamilyCategoryId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The input category id cannot be assigned as the new category for this family.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The family is not an owner family for its own editable document.

See Also

Family Class


FamilyPlacementType Property

[image]

Revit 2024 API
Family..::..FamilyPlacementType Property
Family Class See Also Send Feedback
Identifies the type of placement required by a given family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public FamilyPlacementType FamilyPlacementType { get; }
Visual Basic
Public ReadOnly Property FamilyPlacementType As FamilyPlacementType
    Get
Visual C++
public:
property FamilyPlacementType FamilyPlacementType {
    FamilyPlacementType get ();
}

See Also

Family Class


IsConceptualMassFamily Property

[image]

Revit 2024 API
Family..::..IsConceptualMassFamily Property
Family Class See Also Send Feedback
Whether the Family is a Conceptual Mass family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsConceptualMassFamily { get; }
Visual Basic
Public ReadOnly Property IsConceptualMassFamily As Boolean
    Get
Visual C++
public:
property bool IsConceptualMassFamily {
    bool get ();
}

See Also

Family Class


IsParametric Property

[image]

Revit 2024 API
Family..::..IsParametric Property
Family Class See Also Send Feedback
Identifies whether the family contains parametric relations between some of its elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public bool IsParametric { get; }
Visual Basic
Public ReadOnly Property IsParametric As Boolean
    Get
Visual C++
public:
property bool IsParametric {
    bool get ();
}

Remarks

A family is parametric if it contains parameter-driven relations between its elements, such as labeled dimensions or locked tangential joins.

Parametric families containing large sketches may cause performance problems. Caution is therefore advised before adding any constraints to a yet non-parametric family that already contains large sketches. See [!:DoesContainLargeSketches()].

See Also

Family Class


IsUserCreated Property

[image]

Revit 2024 API
Family..::..IsUserCreated Property
Family Class See Also Send Feedback
Determine whether the family has been defined by the user.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool IsUserCreated { get; }
Visual Basic
Public ReadOnly Property IsUserCreated As Boolean
    Get
Visual C++
public:
property bool IsUserCreated {
    bool get ();
}

Remarks

Some families are created internally and cannot be saved or reloaded. This function will return False for such internal families.

See Also

Family Class


Parameter Property

[image] [image]

Revit 2024 API
Family..::..Parameter Property
Family Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Family Class
Family Members


ShowSpatialElementCalculationPoint Property

[image]

Revit 2024 API
Family..::..ShowSpatialElementCalculationPoint Property
Family Class See Also Send Feedback
For families that can have a calculation point for spatial elements, hide or show the calculation point. SpatialElementCalculationPoint elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool ShowSpatialElementCalculationPoint { get; set; }
Visual Basic
Public Property ShowSpatialElementCalculationPoint As Boolean
    Get
    Set
Visual C++
public:
property bool ShowSpatialElementCalculationPoint {
    bool get ();
    void set (bool value);
}

See Also

Family Class


StructuralFamilyNameKey Property

[image]

Revit 2024 API
Family..::..StructuralFamilyNameKey Property
Family Class See Also Send Feedback
The family's structural section shape name key.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public string StructuralFamilyNameKey { get; set; }
Visual Basic
Public Property StructuralFamilyNameKey As String
    Get
    Set
Visual C++
public:
property String^ StructuralFamilyNameKey {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

Family Class


StructuralMaterialType Property

[image]

Revit 2024 API
Family..::..StructuralMaterialType Property
Family Class See Also Send Feedback
The family's structural material type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public StructuralMaterialType StructuralMaterialType { get; }
Visual Basic
Public ReadOnly Property StructuralMaterialType As StructuralMaterialType
    Get
Visual C++
public:
property StructuralMaterialType StructuralMaterialType {
    StructuralMaterialType get ();
}

See Also

Family Class


FamilyElementVisibility Members

[image] [image]

Revit 2024 API
FamilyElementVisibility Members
FamilyElementVisibility Class Constructors Methods Properties See Also Send Feedback

The FamilyElementVisibility type exposes the following members.

Constructors

 | Name | Description
Public method | FamilyElementVisibility | Initializes a new instance of the FamilyElementVisibility class

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsShownInCoarse | Indicates if the instance is display with Coarse detail level in the view of project document.
Public property | IsShownInFine | Indicates if the instance is display with Fine detail level in the view of project document.
Public property | IsShownInFrontBack | Indicates if the instance is display in Front/Back view of project document.
Public property | IsShownInLeftRight | Indicates if the instance is display in Left/Right view of project document.
Public property | IsShownInMedium | Indicates if the instance is display with Medium detail level in the view of project document.
Public property | IsShownInPlanRCPCut | Indicates if the instance is displayed when cut in Plan/RCP (if the category permits).
Public property | IsShownInTopBottom | Indicates if the instance is display in Plan/RCP view of project document.
Public property | IsShownOnlyWhenCut | Indicates if the instance is displayed only if it has been cut.
Public property | VisibilityType | Indicates if the instance is Model or View specific.

See Also

FamilyElementVisibility Class


FamilyElementVisibility Constructor

[image]

Revit 2024 API
FamilyElementVisibility Constructor
FamilyElementVisibility Class See Also Send Feedback
Initializes a new instance of the FamilyElementVisibility class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyElementVisibility(
    FamilyElementVisibilityType visibilityType
)
Visual Basic
Public Sub New ( _
    visibilityType As FamilyElementVisibilityType _
)
Visual C++
public:
FamilyElementVisibility(
    FamilyElementVisibilityType visibilityType
)

Parameters

visibilityType
Type: Autodesk.Revit.DB..::..FamilyElementVisibilityType

See Also

FamilyElementVisibility Class


FamilyElementVisibility Methods

[image] [image]

Revit 2024 API
FamilyElementVisibility Methods
FamilyElementVisibility Class See Also Send Feedback

The FamilyElementVisibility type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FamilyElementVisibility Class


FamilyElementVisibility Properties

[image] [image]

Revit 2024 API
FamilyElementVisibility Properties
FamilyElementVisibility Class See Also Send Feedback

The FamilyElementVisibility type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsShownInCoarse | Indicates if the instance is display with Coarse detail level in the view of project document.
Public property | IsShownInFine | Indicates if the instance is display with Fine detail level in the view of project document.
Public property | IsShownInFrontBack | Indicates if the instance is display in Front/Back view of project document.
Public property | IsShownInLeftRight | Indicates if the instance is display in Left/Right view of project document.
Public property | IsShownInMedium | Indicates if the instance is display with Medium detail level in the view of project document.
Public property | IsShownInPlanRCPCut | Indicates if the instance is displayed when cut in Plan/RCP (if the category permits).
Public property | IsShownInTopBottom | Indicates if the instance is display in Plan/RCP view of project document.
Public property | IsShownOnlyWhenCut | Indicates if the instance is displayed only if it has been cut.
Public property | VisibilityType | Indicates if the instance is Model or View specific.

See Also

FamilyElementVisibility Class


IsShownInCoarse Property

[image]

Revit 2024 API
FamilyElementVisibility..::..IsShownInCoarse Property
FamilyElementVisibility Class See Also Send Feedback
Indicates if the instance is display with Coarse detail level in the view of project document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsShownInCoarse { get; set; }
Visual Basic
Public Property IsShownInCoarse As Boolean
    Get
    Set
Visual C++
public:
property bool IsShownInCoarse {
    bool get ();
    void set (bool value);
}

Remarks

This property cannot be set to false if the other two detail levels are also false.

See Also

FamilyElementVisibility Class


IsShownInMedium Property

[image]

Revit 2024 API
FamilyElementVisibility..::..IsShownInMedium Property
FamilyElementVisibility Class See Also Send Feedback
Indicates if the instance is display with Medium detail level in the view of project document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsShownInMedium { get; set; }
Visual Basic
Public Property IsShownInMedium As Boolean
    Get
    Set
Visual C++
public:
property bool IsShownInMedium {
    bool get ();
    void set (bool value);
}

Remarks

This property cannot be set to false if the other two detail levels are also false.

See Also

FamilyElementVisibility Class


IsShownInPlanRCPCut Property

[image]

Revit 2024 API
FamilyElementVisibility..::..IsShownInPlanRCPCut Property
FamilyElementVisibility Class See Also Send Feedback
Indicates if the instance is displayed when cut in Plan/RCP (if the category permits).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsShownInPlanRCPCut { get; set; }
Visual Basic
Public Property IsShownInPlanRCPCut As Boolean
    Get
    Set
Visual C++
public:
property bool IsShownInPlanRCPCut {
    bool get ();
    void set (bool value);
}

Remarks

controls whether the Model Family Element is shown when a FamilyInstance of that Family is cut in a Plan/RCP view, i.e. the cut plane passes through the bounding box of the instance. It only has a meaning for categories that are "cut in the symbol". For non-cuttable categories it is always false and for ones that are "cuttable in the instance" it is the same as the IsShownInTopBottom.

See Also

FamilyElementVisibility Class


IsShownInTopBottom Property

[image]

Revit 2024 API
FamilyElementVisibility..::..IsShownInTopBottom Property
FamilyElementVisibility Class See Also Send Feedback
Indicates if the instance is display in Plan/RCP view of project document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsShownInTopBottom { get; set; }
Visual Basic
Public Property IsShownInTopBottom As Boolean
    Get
    Set
Visual C++
public:
property bool IsShownInTopBottom {
    bool get ();
    void set (bool value);
}

Remarks

This property matters for objects whose visibility type is Model.

See Also

FamilyElementVisibility Class


IsShownOnlyWhenCut Property

[image]

Revit 2024 API
FamilyElementVisibility..::..IsShownOnlyWhenCut Property
FamilyElementVisibility Class See Also Send Feedback
Indicates if the instance is displayed only if it has been cut.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsShownOnlyWhenCut { get; set; }
Visual Basic
Public Property IsShownOnlyWhenCut As Boolean
    Get
    Set
Visual C++
public:
property bool IsShownOnlyWhenCut {
    bool get ();
    void set (bool value);
}

Remarks

This property matters for objects which visibility type is ViewSpecific.

See Also

FamilyElementVisibility Class


FamilyElementVisibilityType Enumeration

[image]

Revit 2024 API
FamilyElementVisibilityType Enumeration
See Also Send Feedback
Indicates the Visibility type of generic forms.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum FamilyElementVisibilityType
Visual Basic
Public Enumeration FamilyElementVisibilityType
Visual C++
public enum class FamilyElementVisibilityType

Members

Member name | Description
Model | The element will be displayed in 3D views and model other model views.
ViewSpecific | The element will be displayed only in the view where it is created. This applies to items like detail components, annotations, and view-specific imports.

Remarks

Use this enum to indicate the visibility type of new forms.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


FamilyHostingBehavior Enumeration

[image]

Revit 2024 API
FamilyHostingBehavior Enumeration
See Also Send Feedback
Types of hosts into/onto which a family can be hosted. For informative purposes only. Does not affect anything in Revit!

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public enum FamilyHostingBehavior
Visual Basic
Public Enumeration FamilyHostingBehavior
Visual C++
public enum class FamilyHostingBehavior

Members

Member name | Description
None |
Wall |
Floor |
Ceiling |
Roof |
Face |

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


FamilyInstance Class

[image]

Revit 2024 API
FamilyInstance Class
Members Example See Also Send Feedback
This object represents a single instance of a family type, such as a single I beam.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class FamilyInstance : Instance
Visual Basic
Public Class FamilyInstance _
    Inherits Instance
Visual C++
public ref class FamilyInstance : public Instance

Remarks

Examples of FamilyInstance objects within Autodesk Revit are Beams, Columns, Braces and Desks. The FamilyInstance object provides more detailed properties that enable the type of the family instance to be changed, thus changing their appearance within the project.

Examples

CopyC#
public void GetInfo_FamilyInstance(FamilyInstance familyInstance)
{
    string message = "FamilyInstance : ";
    // Get FamilyInstance host name
    if (familyInstance.Host != null)
    {
        message += "\nFamilyInstance host name is : " + familyInstance.Host.Name;
    }

    foreach (ElementId materialId in familyInstance.GetMaterialIds(false))
    {
        Material material = familyInstance.Document.GetElement(materialId) as Material;
        message += "\nFamilyInstance e material : " + material.Name;
    }
    // Get FamilyInstance room name
    if (familyInstance.Room != null)
    {
        message += "\nFamilyInstance room name is : " + familyInstance.Room.Name;
    }

    // Get FamilyInstance structural type
    message += "\nFamilyInstance structural type is : " + familyInstance.StructuralType;

    // Get FamilyInstance structural usage
    message += "\nFamilyInstance structural usage is : " + familyInstance.StructuralUsage;

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetInfo_FamilyInstance(familyInstance As FamilyInstance)
 Dim message As String = "FamilyInstance : "

 ' Get FamilyInstance host name
 If familyInstance.Host IsNot Nothing Then
        message += vbLf & "FamilyInstance host name is : " & Convert.ToString(familyInstance.Host.Name)
    End If

    For Each materialId As ElementId In familyInstance.GetMaterialIds(False)
        Dim material As Material = TryCast(familyInstance.Document.GetElement(materialId), Material)
        message += vbLf & "FamilyInstance e material : " + material.Name
    Next
    ' Get FamilyInstance room name
    If familyInstance.Room IsNot Nothing Then
        message += vbLf & "FamilyInstance room name is : " & Convert.ToString(familyInstance.Room.Name)
    End If

    ' Get FamilyInstance structural type
    message += vbLf & "FamilyInstance structural type is : " & Convert.ToString(familyInstance.StructuralType)

    ' Get FamilyInstance structural usage
    message += vbLf & "FamilyInstance structural usage is : " & Convert.ToString(familyInstance.StructuralUsage)

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..Instance
Autodesk.Revit.DB..::..FamilyInstance
Autodesk.Revit.DB..::..AnnotationSymbol
Autodesk.Revit.DB..::..Mullion
Autodesk.Revit.DB..::..Panel

See Also

FamilyInstance Members


FamilyInstance Methods

[image] [image]

Revit 2024 API
FamilyInstance Methods
FamilyInstance Class See Also Send Feedback

The FamilyInstance type exposes the following members.

Methods

 | Name | Description
Public method | AddCoping | Adds a coping (cut) to a steel beam.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | flipFacing | The orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true.
Public method | FlipFromToRoom | Flips the settings of "From Room" and "To Room" for the door or window instance.
Public method | flipHand | The orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true.
Public method | GetCopingIds | Lists the elements currently used as coping cutters for this element.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetFamilyPointPlacementReferences | Returns the Point Placement References for the Family Instance.
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetOriginalGeometry | Returns the original geometry of the instance, before the instance is modified by joins, cuts, coping, extensions, or other post-processing.
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetReferenceByName | Gets the family instance reference corresponding to the named reference plane in the instance's family.
Public method | GetReferenceName | Gets the name of the reference plane in the family corresponding to the given family instance reference.
Public method | GetReferences | Gets family instance references corresponding to the reference planes or reference lines of the given reference type in the instance's family.
Public method | GetReferenceType | Gets the type of the reference plane or reference line in the instance's family corresponding to the given family instance reference.
Public method | GetSpatialElementCalculationPoint | Gets the location of the calculation point for this instance.
Public method | GetSpatialElementFromToCalculationPoints | Gets the locations for the calculation points for this instance.
Public method | GetSubComponentIds | Gets the sub component ElementIds of the current family instance.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetSweptProfile | Gets the object that describes the profile that is swept along the driving curve for this instance.
Public method | GetTotalTransform | Gets the total transform, which includes the true north transform for instances like import instances. (Inherited from Instance.)
Public method | GetTransform | Gets the transform of the instance. (Inherited from Instance.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasModifiedGeometry | Identifies if the geometry of this FamilyInstance has been modified from the automatically generated default.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasSweptProfile | Indicates if this instance can be represented as a swept profile.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | RemoveCoping | Removes a coping (cut) from a steel beam.
Public method | rotate | The family instance will be flipped by 180 degrees. If it can not be rotated, return false, otherwise return true.
Public method | SetCopingIds | Specifies the set of coping cutters on this element.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | Split | Splits the family instance element at a point on its defining curve.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FamilyInstance Class


AddCoping Method

[image]

Revit 2024 API
FamilyInstance..::..AddCoping Method
FamilyInstance Class See Also Send Feedback
Adds a coping (cut) to a steel beam.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool AddCoping(
    FamilyInstance cutter
)
Visual Basic
Public Function AddCoping ( _
    cutter As FamilyInstance _
) As Boolean
Visual C++
public:
bool AddCoping(
    FamilyInstance^ cutter
)

Parameters

cutter
Type: Autodesk.Revit.DB..::..FamilyInstance
A steel beam or column. May not be nullNothingnullptra null reference (Nothing in Visual Basic) or itself.

Remarks

This beam will be cut to fit another element, the cutter. The cut will include an offset determined by the parameter STRUCTURAL_COPING_DISTANCE. The parameter affects all copings on this element. This function corresponds to Tools -> Coping in Revit Structure.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when 'cutter' is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when 'cutter' refers to this instance.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when regeneration fails.

See Also

FamilyInstance Class


flipFacing Method

[image]

Revit 2024 API
FamilyInstance..::..flipFacing Method
FamilyInstance Class See Also Send Feedback
The orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool flipFacing()
Visual Basic
Public Function flipFacing As Boolean
Visual C++
public:
bool flipFacing()

See Also

FamilyInstance Class


FlipFromToRoom Method

[image]

Revit 2024 API
FamilyInstance..::..FlipFromToRoom Method
FamilyInstance Class See Also Send Feedback
Flips the settings of "From Room" and "To Room" for the door or window instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void FlipFromToRoom()
Visual Basic
Public Sub FlipFromToRoom
Visual C++
public:
void FlipFromToRoom()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the FamilyInstance is neither a door nor a window.

See Also

FamilyInstance Class


flipHand Method

[image]

Revit 2024 API
FamilyInstance..::..flipHand Method
FamilyInstance Class See Also Send Feedback
The orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool flipHand()
Visual Basic
Public Function flipHand As Boolean
Visual C++
public:
bool flipHand()

See Also

FamilyInstance Class


GetCopingIds Method

[image]

Revit 2024 API
FamilyInstance..::..GetCopingIds Method
FamilyInstance Class See Also Send Feedback
Lists the elements currently used as coping cutters for this element.
Lists the elements currently used as coping cutters for this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ICollection<ElementId> GetCopingIds()
Visual Basic
Public Function GetCopingIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetCopingIds()

Return Value

The coping ElementIds

See Also

FamilyInstance Class


GetFamilyPointPlacementReferences Method

[image]

Revit 2024 API
FamilyInstance..::..GetFamilyPointPlacementReferences Method
FamilyInstance Class See Also Send Feedback
Returns the Point Placement References for the Family Instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public IList<FamilyPointPlacementReference> GetFamilyPointPlacementReferences()
Visual Basic
Public Function GetFamilyPointPlacementReferences As IList(Of FamilyPointPlacementReference)
Visual C++
public:
IList<FamilyPointPlacementReference^>^ GetFamilyPointPlacementReferences()

Remarks

If a family instance has point placement references then they are returned by this method, otherwise an empty collection is returned. Examples of FamilyInstance objects that contain placement references are Panels and Flexible Components.

See Also

FamilyInstance Class


GetReferenceName Method

[image]

Revit 2024 API
FamilyInstance..::..GetReferenceName Method
FamilyInstance Class See Also Send Feedback
Gets the name of the reference plane in the family corresponding to the given family instance reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public string GetReferenceName(
    Reference reference
)
Visual Basic
Public Function GetReferenceName ( _
    reference As Reference _
) As String
Visual C++
public:
String^ GetReferenceName(
    Reference^ reference
)

Parameters

reference
Type: Autodesk.Revit.DB..::..Reference
The family instance reference.

Return Value

Returns the name of the reference plane in the family corresponding to the given family instance reference. If the reference doesn't correspond to a named reference plane, returns an empty string.

Remarks

If the given family reference corresponds to a named reference plane in the instance's family, the name of that reference plane will be returned. Otherwise, an empty string will be returned.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FamilyInstance Class


GetReferences Method

[image]

Revit 2024 API
FamilyInstance..::..GetReferences Method
FamilyInstance Class See Also Send Feedback
Gets family instance references corresponding to the reference planes or reference lines of the given reference type in the instance's family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public IList<Reference> GetReferences(
    FamilyInstanceReferenceType referenceType
)
Visual Basic
Public Function GetReferences ( _
    referenceType As FamilyInstanceReferenceType _
) As IList(Of Reference)
Visual C++
public:
IList<Reference^>^ GetReferences(
    FamilyInstanceReferenceType referenceType
)

Parameters

referenceType
Type: Autodesk.Revit.DB..::..FamilyInstanceReferenceType
The family reference type.

Return Value

Returns all the family instance references corresponding to reference planes and reference lines of the given reference type. Returns null if there are no family instance references of the given reference type, or if the input reference type is FamilyInstanceReferenceType.NotAReference.

Remarks

Reference planes from the instance's family that have their "Is Reference" property set to "Not a Reference" do not create references in the family instance.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

FamilyInstance Class


GetReferenceType Method

[image]

Revit 2024 API
FamilyInstance..::..GetReferenceType Method
FamilyInstance Class See Also Send Feedback
Gets the type of the reference plane or reference line in the instance's family corresponding to the given family instance reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public FamilyInstanceReferenceType GetReferenceType(
    Reference reference
)
Visual Basic
Public Function GetReferenceType ( _
    reference As Reference _
) As FamilyInstanceReferenceType
Visual C++
public:
FamilyInstanceReferenceType GetReferenceType(
    Reference^ reference
)

Parameters

reference
Type: Autodesk.Revit.DB..::..Reference
The family instance reference.

Return Value

Returns the type of the reference plane or reference line in the instance's family corresponding to the given family instance reference. Returns FamilyInstanceReferenceType.NotAReference if the instance reference doesn't correspond to a reference plane or line in the family.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FamilyInstance Class


GetSpatialElementCalculationPoint Method

[image]

Revit 2024 API
FamilyInstance..::..GetSpatialElementCalculationPoint Method
FamilyInstance Class See Also Send Feedback
Gets the location of the calculation point for this instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public XYZ GetSpatialElementCalculationPoint()
Visual Basic
Public Function GetSpatialElementCalculationPoint As XYZ
Visual C++
public:
XYZ^ GetSpatialElementCalculationPoint()

Return Value

A 3d point.

Remarks

See HasSpatialElementCalculationPoint for reference.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if this instance does not have a single calculation point.

See Also

FamilyInstance Class


GetSpatialElementFromToCalculationPoints Method

[image]

Revit 2024 API
FamilyInstance..::..GetSpatialElementFromToCalculationPoints Method
FamilyInstance Class See Also Send Feedback
Gets the locations for the calculation points for this instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public IList<XYZ> GetSpatialElementFromToCalculationPoints()
Visual Basic
Public Function GetSpatialElementFromToCalculationPoints As IList(Of XYZ)
Visual C++
public:
IList<XYZ^>^ GetSpatialElementFromToCalculationPoints()

Return Value

A list of 3d points.

Remarks

For a family instance which connects two rooms or spaces, such as a door or window, the points determine which room or space is considered the "from" and which is considered the "to".

Remarks

See HasSpatialElementFromToCalculationPoints for reference.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if this instance does not have from/to calculation points..

See Also

FamilyInstance Class


GetSubComponentIds Method

[image]

Revit 2024 API
FamilyInstance..::..GetSubComponentIds Method
FamilyInstance Class Example See Also Send Feedback
Gets the sub component ElementIds of the current family instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ICollection<ElementId> GetSubComponentIds()
Visual Basic
Public Function GetSubComponentIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetSubComponentIds()

Return Value

The subcomponent ElementIDs

Examples

CopyC#
public void GetSubAndSuperComponents(FamilyInstance familyInstance)
{
    ICollection<ElementId> subElemSet = familyInstance.GetSubComponentIds();
    if (subElemSet != null)
    {
        string subElems = "";
        foreach (Autodesk.Revit.DB.ElementId ee in subElemSet)
        {
            FamilyInstance f = familyInstance.Document.GetElement(ee) as FamilyInstance;
            subElems = subElems + f.Name + "\n";
        }
        TaskDialog.Show("Revit","Subcomponent count = " + subElemSet.Count + "\n" + subElems);
    }
    FamilyInstance super = familyInstance.SuperComponent as FamilyInstance;
    if (super != null)
    {
        TaskDialog.Show("Revit","SUPER component: " + super.Name);
    }
}
CopyVB.NET
Public Sub GetSubAndSuperComponents(familyInstance As FamilyInstance)
    Dim subElemSet As ICollection(Of ElementId) = familyInstance.GetSubComponentIds()
    If subElemSet IsNot Nothing Then
        Dim subElems As String = ""
        For Each ee As Autodesk.Revit.DB.ElementId In subElemSet
            Dim f As FamilyInstance = TryCast(familyInstance.Document.GetElement(ee), FamilyInstance)
            subElems = subElems + f.Name & vbLf
        Next
        TaskDialog.Show("Revit", "Subcomponent count = " & subElemSet.Count & vbLf & subElems)
    End If
    Dim super As FamilyInstance = TryCast(familyInstance.SuperComponent, FamilyInstance)
    If super IsNot Nothing Then
        TaskDialog.Show("Revit", "SUPER component: " + super.Name)
    End If
End Sub

See Also

FamilyInstance Class


GetSweptProfile Method

[image]

Revit 2024 API
FamilyInstance..::..GetSweptProfile Method
FamilyInstance Class See Also Send Feedback
Gets the object that describes the profile that is swept along the driving curve for this instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public SweptProfile GetSweptProfile()
Visual Basic
Public Function GetSweptProfile As SweptProfile
Visual C++
public:
SweptProfile^ GetSweptProfile()

Return Value

A swept profile.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | Thrown if this instance does not have a swept profile.

See Also

FamilyInstance Class


HasModifiedGeometry Method

[image]

Revit 2024 API
FamilyInstance..::..HasModifiedGeometry Method
FamilyInstance Class See Also Send Feedback
Identifies if the geometry of this FamilyInstance has been modified from the automatically generated default.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool HasModifiedGeometry()
Visual Basic
Public Function HasModifiedGeometry As Boolean
Visual C++
public:
bool HasModifiedGeometry()

Remarks

This method returns true if the geometry has been modified from post-processing activity in Revit such as joining, cutting, coping, extension, adaptive component modification, or other similar activity.

See Also

FamilyInstance Class


RemoveCoping Method

[image]

Revit 2024 API
FamilyInstance..::..RemoveCoping Method
FamilyInstance Class See Also Send Feedback
Removes a coping (cut) from a steel beam.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool RemoveCoping(
    FamilyInstance cutter
)
Visual Basic
Public Function RemoveCoping ( _
    cutter As FamilyInstance _
) As Boolean
Visual C++
public:
bool RemoveCoping(
    FamilyInstance^ cutter
)

Parameters

cutter
Type: Autodesk.Revit.DB..::..FamilyInstance
A steel beam or column for which this beam currently has a coping cut. May not be nullNothingnullptra null reference (Nothing in Visual Basic) or itself.

Remarks

This function corresponds to Tools -> Remove coping in Revit Structure.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when 'cutter' is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when 'cutter' refers to this instance.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when regeneration fails.

See Also

FamilyInstance Class


rotate Method

[image]

Revit 2024 API
FamilyInstance..::..rotate Method
FamilyInstance Class See Also Send Feedback
The family instance will be flipped by 180 degrees. If it can not be rotated, return false, otherwise return true.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool rotate()
Visual Basic
Public Function rotate As Boolean
Visual C++
public:
bool rotate()

See Also

FamilyInstance Class


SetCopingIds Method

[image]

Revit 2024 API
FamilyInstance..::..SetCopingIds Method
FamilyInstance Class See Also Send Feedback
Specifies the set of coping cutters on this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool SetCopingIds(
    ICollection<ElementId> cutters
)
Visual Basic
Public Function SetCopingIds ( _
    cutters As ICollection(Of ElementId) _
) As Boolean
Visual C++
public:
bool SetCopingIds(
    ICollection<ElementId^>^ cutters
)

Parameters

cutters
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
A set of coping cutters (steel beams and steel columns).

Remarks

The set may be nullNothingnullptra null reference (Nothing in Visual Basic) or empty, but may not contain the element being coped.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when 'cutters' contains this instance.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when regeneration fails or if a cutter element is not a FamilyInstance.

See Also

FamilyInstance Class


Split Method

[image]

Revit 2024 API
FamilyInstance..::..Split Method
FamilyInstance Class See Also Send Feedback
Splits the family instance element at a point on its defining curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElementId Split(
    double param
)
Visual Basic
Public Function Split ( _
    param As Double _
) As ElementId
Visual C++
public:
ElementId^ Split(
    double param
)

Parameters

param
Type: System..::..Double
The normalized parameter value along the element (should be greater than 0 and less than 1).

Return Value

The newly created family instance id.

Remarks

Splitting is permitted for architectural and structural columns, beams and braces. Beams and braces that are not a line or an arc is not permitted. See CanSplit to determine if the family instance is allowed to be split by this method.

Splitting modifies this family instance and adds a second family instance to the model.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when parameter is out of range.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the family instance element cannot be split.

See Also

FamilyInstance Class


FamilyInstance Properties

[image] [image]

Revit 2024 API
FamilyInstance Properties
FamilyInstance Class See Also Send Feedback

The FamilyInstance type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanFlipFacing | Property to test whether the orientation of family instance facing can be flipped.
Public property | CanFlipHand | Property to test whether the orientation of family instance hand can be flipped.
Public property | CanFlipWorkPlane | Identifies if the instance can flip its work plane.
Public property | CanRotate | Property to test whether the family instance can be rotated by 180 degrees.
Public property | CanSplit | Identifies whether a particular family instance can be split at a point on it's defining curve (by Split(Double)).
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | ExtensionUtility | Property to check whether the instance can be extended and return the interface for extension operation.
Public property | FacingFlipped | Property to test whether the orientation of family instance facing is flipped.
Public property | FacingOrientation | Property to get the orientation of family instance facing.
Public property | FromRoom | The "From Room" set for the door or window in the last phase of the project.
Public property | FromRoom[([( Phase])]) |
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | HandFlipped | Property to test whether the orientation of family instance hand is flipped.
Public property | HandOrientation | Property to get the orientation of family instance hand.
Public property | HasSpatialElementCalculationPoint | Identifies if this instance has a single SpatialElementCalculationPoint used as the search point for Revit to identify if the instance is inside a room or space.
Public property | HasSpatialElementFromToCalculationPoints | Identifies if this instance has a pair of SpatialElementCalculationPoints used as the search points for Revit to identify if the instance lies between up to two rooms or spaces.
Public property | Host | If the instance is contained within another element, this property returns the containing element. An instance that is face hosted will return the element containing the face.
Public property | HostFace | Property to get the reference to the host face of family instance.
Public property | HostParameter | If the instance is hosted by a wall, this property returns the parameter value of the insertion point of the instance along the wall's location curve, as long as the family of the instance isn't work plane based.
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | Invisible | Property to test whether the family instance is invisible.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsSlantedColumn | Indicates if the family instance is a slanted column.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | IsWorkPlaneFlipped | Identifies if the instance's work plane is flipped.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an instance within project. (Overrides Element..::..Location.)
Public property | MEPModel | Retrieves the MEP model for the family instance.
Public property | Mirrored | Property to test whether the family instance is mirrored. (only one axis is flipped)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Room | The room in which the instance is located (during the last phase of the project).
Public property | Room[([( Phase])]) |
Public property | Space | The space in which the instance is located (during the last phase of the project).
Public property | Space[([( Phase])]) |
Public property | StructuralMaterialId | Identifies the material that defines the instance's structural analysis properties.
Public property | StructuralMaterialType | This property returns the physical material from which the instance is made.
Public property | StructuralType | Provides the primary structural type of the instance, such as beam or column etc.
Public property | StructuralUsage | Provides the primary structural usage of the instance, such as brace, girder etc.
Public property | SuperComponent | Property to get the super component of current family instance.
Public property | Symbol | Returns or changes the FamilySymbol object that represents the type of the instance.
Public property | ToRoom | The "To Room" set for the door or window in the last phase of the project.
Public property | ToRoom[([( Phase])]) |
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FamilyInstance Class


CanFlipFacing Property

[image]

Revit 2024 API
FamilyInstance..::..CanFlipFacing Property
FamilyInstance Class See Also Send Feedback
Property to test whether the orientation of family instance facing can be flipped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool CanFlipFacing { get; }
Visual Basic
Public ReadOnly Property CanFlipFacing As Boolean
    Get
Visual C++
public:
property bool CanFlipFacing {
    bool get ();
}

See Also

FamilyInstance Class


CanFlipWorkPlane Property

[image]

Revit 2024 API
FamilyInstance..::..CanFlipWorkPlane Property
FamilyInstance Class See Also Send Feedback
Identifies if the instance can flip its work plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool CanFlipWorkPlane { get; }
Visual Basic
Public ReadOnly Property CanFlipWorkPlane As Boolean
    Get
Visual C++
public:
property bool CanFlipWorkPlane {
    bool get ();
}

See Also

FamilyInstance Class


CanRotate Property

[image]

Revit 2024 API
FamilyInstance..::..CanRotate Property
FamilyInstance Class See Also Send Feedback
Property to test whether the family instance can be rotated by 180 degrees.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool CanRotate { get; }
Visual Basic
Public ReadOnly Property CanRotate As Boolean
    Get
Visual C++
public:
property bool CanRotate {
    bool get ();
}

See Also

FamilyInstance Class


CanSplit Property

[image]

Revit 2024 API
FamilyInstance..::..CanSplit Property
FamilyInstance Class See Also Send Feedback
Identifies whether a particular family instance can be split at a point on it's defining curve (by Split(Double)).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool CanSplit { get; }
Visual Basic
Public ReadOnly Property CanSplit As Boolean
    Get
Visual C++
public:
property bool CanSplit {
    bool get ();
}

Field Value

True if the family instance can be split, otherwise false.

See Also

FamilyInstance Class


ExtensionUtility Property

[image]

Revit 2024 API
FamilyInstance..::..ExtensionUtility Property
FamilyInstance Class See Also Send Feedback
Property to check whether the instance can be extended and return the interface for extension operation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public IExtension ExtensionUtility { get; }
Visual Basic
Public ReadOnly Property ExtensionUtility As IExtension
    Get
Visual C++
public:
property IExtension^ ExtensionUtility {
    IExtension^ get ();
}

Remarks

If the family instance can not support extension operation, it returns nullNothingnullptra null reference (Nothing in Visual Basic)

See Also

FamilyInstance Class


FacingFlipped Property

[image]

Revit 2024 API
FamilyInstance..::..FacingFlipped Property
FamilyInstance Class See Also Send Feedback
Property to test whether the orientation of family instance facing is flipped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool FacingFlipped { get; }
Visual Basic
Public ReadOnly Property FacingFlipped As Boolean
    Get
Visual C++
public:
property bool FacingFlipped {
    bool get ();
}

See Also

FamilyInstance Class


FacingOrientation Property

[image]

Revit 2024 API
FamilyInstance..::..FacingOrientation Property
FamilyInstance Class See Also Send Feedback
Property to get the orientation of family instance facing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ FacingOrientation { get; }
Visual Basic
Public ReadOnly Property FacingOrientation As XYZ
    Get
Visual C++
public:
property XYZ^ FacingOrientation {
    XYZ^ get ();
}

See Also

FamilyInstance Class


FromRoom Property

[image] [image]

Revit 2024 API
FamilyInstance..::..FromRoom Property
FamilyInstance Class See Also Send Feedback
The "From Room" set for the door or window.

Overload List

 | Name | Description
Public property | FromRoom | The "From Room" set for the door or window in the last phase of the project.
Public property | FromRoom[([( Phase])]) |

See Also

FamilyInstance Class
FamilyInstance Members


FromRoom Property (Phase)

[image]

Revit 2024 API
FamilyInstance..::..FromRoom Property (Phase)
FamilyInstance Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Room this[
    Phase phase
] { get; }
Visual Basic
Public ReadOnly Property FromRoom ( _
    phase As Phase _
) As Room
    Get
Visual C++
public:
property Room^ FromRoom[Phase^ phase] {
    Room^ get (Phase^ phase);
}

Parameters

phase
Type: Autodesk.Revit.DB..::..Phase

See Also

FamilyInstance Class
FromRoom Overload


HandFlipped Property

[image]

Revit 2024 API
FamilyInstance..::..HandFlipped Property
FamilyInstance Class See Also Send Feedback
Property to test whether the orientation of family instance hand is flipped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool HandFlipped { get; }
Visual Basic
Public ReadOnly Property HandFlipped As Boolean
    Get
Visual C++
public:
property bool HandFlipped {
    bool get ();
}

See Also

FamilyInstance Class


HandOrientation Property

[image]

Revit 2024 API
FamilyInstance..::..HandOrientation Property
FamilyInstance Class See Also Send Feedback
Property to get the orientation of family instance hand.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ HandOrientation { get; }
Visual Basic
Public ReadOnly Property HandOrientation As XYZ
    Get
Visual C++
public:
property XYZ^ HandOrientation {
    XYZ^ get ();
}

See Also

FamilyInstance Class


Host Property

[image]

Revit 2024 API
FamilyInstance..::..Host Property
FamilyInstance Class See Also Send Feedback
If the instance is contained within another element, this property returns the containing element. An instance that is face hosted will return the element containing the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Element Host { get; }
Visual Basic
Public ReadOnly Property Host As Element
    Get
Visual C++
public:
property Element^ Host {
    Element^ get ();
}

Remarks

An example of an instance that is contained is a window. In this case the host property would return the wall in which the window is contained. Another example is an instance that is hosted to a planar or curved face in a Mass element will return the Mass element.

See Also

FamilyInstance Class


HostParameter Property

[image]

Revit 2024 API
FamilyInstance..::..HostParameter Property
FamilyInstance Class See Also Send Feedback
If the instance is hosted by a wall, this property returns the parameter value of the insertion point of the instance along the wall's location curve, as long as the family of the instance isn't work plane based.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double HostParameter { get; }
Visual Basic
Public ReadOnly Property HostParameter As Double
    Get
Visual C++
public:
property double HostParameter {
    double get ();
}

Remarks

This works for instances with a host element that is of type Wall or is in the OST_Walls category only, including in-place ones.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Only hosted instances whose family is not work plane based can support this functionality.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Only hosted instances of type Wall or in-place elements of category OST_Walls can support this functionality.

See Also

FamilyInstance Class


Invisible Property

[image]

Revit 2024 API
FamilyInstance..::..Invisible Property
FamilyInstance Class See Also Send Feedback
Property to test whether the family instance is invisible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool Invisible { get; }
Visual Basic
Public ReadOnly Property Invisible As Boolean
    Get
Visual C++
public:
property bool Invisible {
    bool get ();
}

See Also

FamilyInstance Class


IsSlantedColumn Property

[image]

Revit 2024 API
FamilyInstance..::..IsSlantedColumn Property
FamilyInstance Class See Also Send Feedback
Indicates if the family instance is a slanted column.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsSlantedColumn { get; }
Visual Basic
Public ReadOnly Property IsSlantedColumn As Boolean
    Get
Visual C++
public:
property bool IsSlantedColumn {
    bool get ();
}

Remarks

If the family instance is a slanted column, it returns true, otherwise returns false.

See Also

FamilyInstance Class


IsWorkPlaneFlipped Property

[image]

Revit 2024 API
FamilyInstance..::..IsWorkPlaneFlipped Property
FamilyInstance Class See Also Send Feedback
Identifies if the instance's work plane is flipped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsWorkPlaneFlipped { get; set; }
Visual Basic
Public Property IsWorkPlaneFlipped As Boolean
    Get
    Set
Visual C++
public:
property bool IsWorkPlaneFlipped {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | Work plane cannot be flipped for this instance.

See Also

FamilyInstance Class


Location Property

[image]

Revit 2024 API
FamilyInstance..::..Location Property
FamilyInstance Class See Also Send Feedback
This property is used to find the physical location of an instance within project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public override Location Location { get; }
Visual Basic
Public Overrides ReadOnly Property Location As Location
    Get
Visual C++
public:
virtual property Location^ Location {
    Location^ get () override;
}

Remarks

The Location property returns an object that can be used to find the location of an instance within the project. An instance may have a point location, such as a footing or may have a line location. A beam is an example of an instance that has a line location.

See Also

FamilyInstance Class


MEPModel Property

[image]

Revit 2024 API
FamilyInstance..::..MEPModel Property
FamilyInstance Class See Also Send Feedback
Retrieves the MEP model for the family instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public MEPModel MEPModel { get; }
Visual Basic
Public ReadOnly Property MEPModel As MEPModel
    Get
Visual C++
public:
property MEPModel^ MEPModel {
    MEPModel^ get ();
}

Remarks

If the family instance has a MEP model it is returned by this method, otherwise nullNothingnullptra null reference (Nothing in Visual Basic) is returned. Different types of MEP model will be returned based on the type of the instance, for example - if the instance is a lighting device then a lighting device model will be returned. This property will only function with the Autodesk Revit MEP product.

See Also

FamilyInstance Class


Mirrored Property

[image]

Revit 2024 API
FamilyInstance..::..Mirrored Property
FamilyInstance Class See Also Send Feedback
Property to test whether the family instance is mirrored. (only one axis is flipped)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool Mirrored { get; }
Visual Basic
Public ReadOnly Property Mirrored As Boolean
    Get
Visual C++
public:
property bool Mirrored {
    bool get ();
}

See Also

FamilyInstance Class


Parameter Property

[image] [image]

Revit 2024 API
FamilyInstance..::..Parameter Property
FamilyInstance Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

FamilyInstance Class
FamilyInstance Members


Room Property

[image] [image]

Revit 2024 API
FamilyInstance..::..Room Property
FamilyInstance Class See Also Send Feedback
The room in which the instance is located.

Overload List

 | Name | Description
Public property | Room | The room in which the instance is located (during the last phase of the project).
Public property | Room[([( Phase])]) |

See Also

FamilyInstance Class
FamilyInstance Members


Room Property

[image]

Revit 2024 API
FamilyInstance..::..Room Property
FamilyInstance Class See Also Send Feedback
The room in which the instance is located (during the last phase of the project).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Room Room { get; }
Visual Basic
Public ReadOnly Property Room As Room
    Get
Visual C++
public:
property Room^ Room {
    Room^ get ();
}

Remarks

This property will be the first room encountered that contains the instance. If more than one room includes this point in its volume only the first one is returned. If no room is found that contains the instance, or if phase does not apply to this FaimlyInstance, this property is nullNothingnullptra null reference (Nothing in Visual Basic). This property should not be used for door or window instances, which are placed on the boundary or between rooms. Use the FromRoom and ToRoom properties instead.

See Also

FamilyInstance Class
Room Overload


Room Property (Phase)

[image]

Revit 2024 API
FamilyInstance..::..Room Property (Phase)
FamilyInstance Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Room this[
    Phase phase
] { get; }
Visual Basic
Public ReadOnly Property Room ( _
    phase As Phase _
) As Room
    Get
Visual C++
public:
property Room^ Room[Phase^ phase] {
    Room^ get (Phase^ phase);
}

Parameters

phase
Type: Autodesk.Revit.DB..::..Phase

See Also

FamilyInstance Class
Room Overload


Space Property

[image] [image]

Revit 2024 API
FamilyInstance..::..Space Property
FamilyInstance Class See Also Send Feedback
The space in which the instance is located.

Overload List

 | Name | Description
Public property | Space | The space in which the instance is located (during the last phase of the project).
Public property | Space[([( Phase])]) |

See Also

FamilyInstance Class
FamilyInstance Members


Space Property

[image]

Revit 2024 API
FamilyInstance..::..Space Property
FamilyInstance Class See Also Send Feedback
The space in which the instance is located (during the last phase of the project).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Space Space { get; }
Visual Basic
Public ReadOnly Property Space As Space
    Get
Visual C++
public:
property Space^ Space {
    Space^ get ();
}

Remarks

This property will be the first space encountered that contains the instance. If more than one space includes this point in its volume only the first one is returned. If no space is found that contains the instance, or if phase does not apply to this FaimlyInstance, this property is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

FamilyInstance Class
Space Overload


Space Property (Phase)

[image]

Revit 2024 API
FamilyInstance..::..Space Property (Phase)
FamilyInstance Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Space this[
    Phase phase
] { get; }
Visual Basic
Public ReadOnly Property Space ( _
    phase As Phase _
) As Space
    Get
Visual C++
public:
property Space^ Space[Phase^ phase] {
    Space^ get (Phase^ phase);
}

Parameters

phase
Type: Autodesk.Revit.DB..::..Phase

See Also

FamilyInstance Class
Space Overload


StructuralMaterialId Property

[image]

Revit 2024 API
FamilyInstance..::..StructuralMaterialId Property
FamilyInstance Class See Also Send Feedback
Identifies the material that defines the instance's structural analysis properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElementId StructuralMaterialId { get; set; }
Visual Basic
Public Property StructuralMaterialId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ StructuralMaterialId {
    ElementId^ get ();
    void set (ElementId^ value);
}

See Also

FamilyInstance Class


StructuralMaterialType Property

[image]

Revit 2024 API
FamilyInstance..::..StructuralMaterialType Property
FamilyInstance Class See Also Send Feedback
This property returns the physical material from which the instance is made.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public StructuralMaterialType StructuralMaterialType { get; }
Visual Basic
Public ReadOnly Property StructuralMaterialType As StructuralMaterialType
    Get
Visual C++
public:
property StructuralMaterialType StructuralMaterialType {
    StructuralMaterialType get ();
}

Remarks

Values of this property can be Steel, Concrete, Wood or some other material. Different from Revit materials that geometry really consists of, this property is a family parameter defining family behavior and can not be set per instance. Its value is the same with the type of the instance's family. For example, the instances of different kind of column families(Steel, Concrete or Wood) have different material values and can't be changed int the UI or RevitAPI.

See Also

FamilyInstance Class


StructuralType Property

[image]

Revit 2024 API
FamilyInstance..::..StructuralType Property
FamilyInstance Class Example See Also Send Feedback
Provides the primary structural type of the instance, such as beam or column etc.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public StructuralType StructuralType { get; }
Visual Basic
Public ReadOnly Property StructuralType As StructuralType
    Get
Visual C++
public:
property StructuralType StructuralType {
    StructuralType get ();
}

Examples

CopyC#
public void GetStructuralType(FamilyInstance familyInstance)
{
    string message = "";
    switch (familyInstance.StructuralType)
    {
        case StructuralType.Beam:
            message = "FamilyInstance is a beam.";
            break;
        case StructuralType.Brace:
            message = "FamilyInstance is a brace.";
            break;
        case StructuralType.Column:
            message = "FamilyInstance is a column.";
            break;
        case StructuralType.Footing:
            message = "FamilyInstance is a footing.";
            break;
        default:
            message = "FamilyInstance is non-structural or unknown framing.";
            break;
    }

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetStructuralType(familyInstance As FamilyInstance)
    Dim message As String = ""
    Select Case familyInstance.StructuralType
        Case StructuralType.Beam
            message = "FamilyInstance is a beam."
            Exit Select
        Case StructuralType.Brace
            message = "FamilyInstance is a brace."
            Exit Select
        Case StructuralType.Column
            message = "FamilyInstance is a column."
            Exit Select
        Case StructuralType.Footing
            message = "FamilyInstance is a footing."
            Exit Select
        Case Else
            message = "FamilyInstance is non-structural or unknown framing."
            Exit Select
    End Select

    TaskDialog.Show("Revit", message)
End Sub

See Also

FamilyInstance Class


StructuralUsage Property

[image]

Revit 2024 API
FamilyInstance..::..StructuralUsage Property
FamilyInstance Class See Also Send Feedback
Provides the primary structural usage of the instance, such as brace, girder etc.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public StructuralInstanceUsage StructuralUsage { get; set; }
Visual Basic
Public Property StructuralUsage As StructuralInstanceUsage
    Get
    Set
Visual C++
public:
property StructuralInstanceUsage StructuralUsage {
    StructuralInstanceUsage get ();
    void set (StructuralInstanceUsage value);
}

See Also

FamilyInstance Class


SuperComponent Property

[image]

Revit 2024 API
FamilyInstance..::..SuperComponent Property
FamilyInstance Class See Also Send Feedback
Property to get the super component of current family instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Element SuperComponent { get; }
Visual Basic
Public ReadOnly Property SuperComponent As Element
    Get
Visual C++
public:
property Element^ SuperComponent {
    Element^ get ();
}

Remarks

When the FamilyInstance has no super component, it returns nullNothingnullptra null reference (Nothing in Visual Basic)

See Also

FamilyInstance Class


Symbol Property

[image]

Revit 2024 API
FamilyInstance..::..Symbol Property
FamilyInstance Class Example See Also Send Feedback
Returns or changes the FamilySymbol object that represents the type of the instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilySymbol Symbol { get; set; }
Visual Basic
Public Property Symbol As FamilySymbol
    Get
    Set
Visual C++
public:
property FamilySymbol^ Symbol {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}

Remarks

Setting this property will result in the type of the instance being changed. Related types can be found by examining the Family to which the symbol belongs.

Examples

CopyC#
public void GetInfo_FamilyInstance_Symbol(FamilyInstance familyInstance)
{
    string message = "FamilyInstance symbol: ";
    if (familyInstance.Symbol != null)
    {
        // Get FamilyInstance structural symbol
        message += "\nFamilyInstance structural symbol name is : " + familyInstance.Symbol.Name;

        // Rename the Symbol used by this FamilyInstance
        familyInstance.Symbol.Name = "TestFamilyInstanceSymbolName";

        // Get FamilyInstance structural symbol
        message += "\nFamilyInstance structural symbol name after set is : " + familyInstance.Symbol.Name;
    }
    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetInfo_FamilyInstance_Symbol(familyInstance As FamilyInstance)
    Dim message As String = "FamilyInstance symbol: "
    If familyInstance.Symbol IsNot Nothing Then
        ' Get FamilyInstance structural symbol
        message += vbLf & "FamilyInstance structural symbol name is : " & Convert.ToString(familyInstance.Symbol.Name)

        ' Rename the Symbol used by this FamilyInstance
        familyInstance.Symbol.Name = "TestFamilyInstanceSymbolName"

        ' Get FamilyInstance structural symbol
        message += vbLf & "FamilyInstance structural symbol name after set is : " & Convert.ToString(familyInstance.Symbol.Name)
    End If
    TaskDialog.Show("Revit", message)
End Sub

See Also

FamilyInstance Class


ToRoom Property

[image] [image]

Revit 2024 API
FamilyInstance..::..ToRoom Property
FamilyInstance Class See Also Send Feedback
The "To Room" set for the door or window.

Overload List

 | Name | Description
Public property | ToRoom | The "To Room" set for the door or window in the last phase of the project.
Public property | ToRoom[([( Phase])]) |

See Also

FamilyInstance Class
FamilyInstance Members


ToRoom Property

[image]

Revit 2024 API
FamilyInstance..::..ToRoom Property
FamilyInstance Class See Also Send Feedback
The "To Room" set for the door or window in the last phase of the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Room ToRoom { get; }
Visual Basic
Public ReadOnly Property ToRoom As Room
    Get
Visual C++
public:
property Room^ ToRoom {
    Room^ get ();
}

Field Value

The "To Room" set for the door or window in the last phase of the project. nullNothingnullptra null reference (Nothing in Visual Basic) if the FamilyInstance is neither a door nor a window, or if the door or window leads to a space where there is no room (an exterior space or interior space with no room defined). Also nullNothingnullptra null reference (Nothing in Visual Basic) if there is no target room assigned to the last phase, or phase does not apply to this FamilyInstance.

Remarks

Revit automatically calculates the "To Room" for a given door or window. This is the default shown when creating a door or window schedule and adding the "To Room" properties. The user can opt to swap the "From Room" and "To Room" values via the schedule if they choose. The method FlipFromToRoom()()()() also can be used to swap the values.

See Also

FamilyInstance Class
ToRoom Overload


ToRoom Property (Phase)

[image]

Revit 2024 API
FamilyInstance..::..ToRoom Property (Phase)
FamilyInstance Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Room this[
    Phase phase
] { get; }
Visual Basic
Public ReadOnly Property ToRoom ( _
    phase As Phase _
) As Room
    Get
Visual C++
public:
property Room^ ToRoom[Phase^ phase] {
    Room^ get (Phase^ phase);
}

Parameters

phase
Type: Autodesk.Revit.DB..::..Phase

See Also

FamilyInstance Class
ToRoom Overload


FamilyInstanceFilter Members

[image] [image]

Revit 2024 API
FamilyInstanceFilter Members
FamilyInstanceFilter Class Constructors Methods Properties See Also Send Feedback

The FamilyInstanceFilter type exposes the following members.

Constructors

 | Name | Description
Public method | FamilyInstanceFilter | Constructs a new instance of a filter to match family instances of the given family symbol.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FamilySymbolId | The family symbol id.
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)

See Also

FamilyInstanceFilter Class


FamilyInstanceFilter Constructor

[image]

Revit 2024 API
FamilyInstanceFilter Constructor
FamilyInstanceFilter Class See Also Send Feedback
Constructs a new instance of a filter to match family instances of the given family symbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FamilyInstanceFilter(
    Document document,
    ElementId familySymbolId
)
Visual Basic
Public Sub New ( _
    document As Document, _
    familySymbolId As ElementId _
)
Visual C++
public:
FamilyInstanceFilter(
    Document^ document,
    ElementId^ familySymbolId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document. This requirement is unique to this filter and is needed to ensure the input family symbol id is valid for the provided document. This ensures the most stability and greatest performance for this filter.
familySymbolId
Type: Autodesk.Revit.DB..::..ElementId
The family symbol id.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The familySymbolId does not represent a valid FamilySymbol record in the document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FamilyInstanceFilter Class


FamilyInstanceFilter Methods

[image] [image]

Revit 2024 API
FamilyInstanceFilter Methods
FamilyInstanceFilter Class See Also Send Feedback

The FamilyInstanceFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FamilyInstanceFilter Class


PassesFilter Method

[image] [image]

Revit 2024 API
FamilyInstanceFilter..::..PassesFilter Method
FamilyInstanceFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

FamilyInstanceFilter Class
FamilyInstanceFilter Members


FamilyInstanceFilter Properties

[image] [image]

Revit 2024 API
FamilyInstanceFilter Properties
FamilyInstanceFilter Class See Also Send Feedback

The FamilyInstanceFilter type exposes the following members.

Properties

 | Name | Description
Public property | FamilySymbolId | The family symbol id.
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)

See Also

FamilyInstanceFilter Class


FamilyInstanceReferenceType Enumeration

[image]

Revit 2024 API
FamilyInstanceReferenceType Enumeration
See Also Send Feedback
Corresponds to the possible values of parameter "Is Reference" of reference planes and parameter "Reference" of reference lines in families. This enum is used to identify references of family instances corresponding to reference planes and reference lines in the family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018
Since: 2018

Syntax

C#
public enum FamilyInstanceReferenceType
Visual Basic
Public Enumeration FamilyInstanceReferenceType
Visual C++
public enum class FamilyInstanceReferenceType

Members

Member name | Description
Left | Reference plane whose "Is Reference" parameter is set to "Left". There may be no more than one such reference plane in the family. This reference is stable: if there is a dimension to this reference of an instance, and the instance's type or family is replaced, the dimension will survive.
CenterLeftRight | Reference plane whose "Is Reference" parameter is set to "Center (Left/Right)". There may be no more than one such reference plane in the family. This reference is stable: if there is a dimension to this reference of an instance, and the instance's type or family is replaced, the dimension will survive.
Right | Reference plane whose "Is Reference" parameter is set to "Right". There may be no more than one such reference plane in the family. This reference is stable: if there is a dimension to this reference of an instance, and the instance's type or family is replaced, the dimension will survive.
Front | Reference plane whose "Is Reference" parameter is set to "Front". There may be no more than one such reference plane in the family. This reference is stable: if there is a dimension to this reference of an instance, and the instance's type or family is replaced, the dimension will survive.
CenterFrontBack | Reference plane whose "Is Reference" parameter is set to "Center (Front/Back)". There may be no more than one such reference plane in the family. This reference is stable: if there is a dimension to this reference of an instance, and the instance's type or family is replaced, the dimension will survive.
Back | Reference plane whose "Is Reference" parameter is set to "Back". There may be no more than one such reference plane in the family. This reference is stable: if there is a dimension to this reference of an instance, and the instance's type or family is replaced, the dimension will survive.
Bottom | Reference plane whose "Is Reference" parameter is set to "Bottom". There may be no more than one such reference plane in the family. This reference is stable: if there is a dimension to this reference of an instance, and the instance's type or family is replaced, the dimension will survive.
CenterElevation | Reference plane whose "Is Reference" parameter is set to "Center (Elevation)". There may be no more than one such reference plane in the family. This reference is stable: if there is a dimension to this reference of an instance, and the instance's type or family is replaced, the dimension will survive.
Top | Reference plane whose "Is Reference" parameter is set to "Top". There may be no more than one such reference plane in the family. This reference is stable: if there is a dimension to this reference of an instance, and the instance's type or family is replaced, the dimension will survive.
StrongReference | Reference plane whose "Is Reference" parameter is set to "Strong Reference", or reference line whose "Reference" parameter is set to "Strong Reference". There may be multiple such reference planes and lines in the family. These references are not stable: if there is a dimension to such reference, and the instance's family is replaced, the dimension is not guaranteed to survive.
WeakReference | Reference plane whose "Is Reference" parameter is set to "Weak Reference", or reference line whose "Reference" parameter is set to "Weak Reference". There may be multiple such reference planes and lines in the family. These references are not stable: if there is a dimension to such reference, and the instance's family is replaced, the dimension is not guaranteed to survive.
NotAReference | This value is returned from FamilyInstance::getReferenceType if the reference does not correspond to any reference plane or reference line in the family.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


FamilyManager Class

[image]

Revit 2024 API
FamilyManager Class
Members See Also Send Feedback
The family manager object to manage the family types and parameters in family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class FamilyManager : APIObject
Visual Basic
Public Class FamilyManager _
    Inherits APIObject
Visual C++
public ref class FamilyManager : public APIObject

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..FamilyManager

See Also

FamilyManager Members


FamilyManager Members

[image] [image]

Revit 2024 API
FamilyManager Members
FamilyManager Class Methods Properties See Also Send Feedback

The FamilyManager type exposes the following members.

Methods

 | Name | Description
Public method | AddParameter(ExternalDefinition, BuiltInParameterGroup, Boolean) | Obsolete. Add a new shared parameter to the family.
Public method | AddParameter(ExternalDefinition, ForgeTypeId, Boolean) | Add a new shared parameter to the family.
Public method | AddParameter(String, BuiltInParameterGroup, Category, Boolean) | Obsolete. Add a new family type parameter to control the type of a nested family within another family.
Public method | AddParameter(String, ForgeTypeId, Category, Boolean) | Add a new family type parameter to control the type of a nested family within another family.
Public method | AddParameter(String, ForgeTypeId, ForgeTypeId, Boolean) | Add a new family parameter with a given name.
Public method | AssociateElementParameterToFamilyParameter | Associates or disassociates the element parameter to an existing family parameter.
Public method | CanElementParameterBeAssociated | Indicates if this element parameter can be associated with a family parameter.
Public method | DeleteCurrentType | Remove the current family type.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAssociatedFamilyParameter | Gets the associated family parameter of an element parameter.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParameter | Obtains the family parameter with the given built-in parameter identifier.
Public method | GetParameters | Gets the parameters associated to family types in order.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsParameterLockable | For Conceptual Mass and Curtain Panel families, indicate whether the specified parameter can be locked.
Public method | IsParameterLocked | For Conceptual Mass and Curtain Panel families, indicate whether the specified dimension-driving parameter is locked.
Public method | IsUserAssignableParameterGroup(BuiltInParameterGroup) | Obsolete. Checks if the given parameter group can be assigned to new parameters.
Public method | IsUserAssignableParameterGroup(ForgeTypeId) | Checks if the given parameter group can be assigned to new parameters.
Public method | MakeInstance | Set the family parameter as an instance parameter.
Public method | MakeNonReporting | Set the reporting family parameter as a regular/driving parameter.
Public method | MakeReporting | Set the family parameter as a reporting parameter.
Public method | MakeType | Set the family parameter as a type parameter.
Public method | NewType | Add a new family type with a given name and makes it be the current type.
Public method | RemoveParameter | Remove an existing family parameter from the family.
Public method | RenameCurrentType | Rename the current family type.
Public method | RenameParameter | Rename a family parameter.
Public method | ReorderParameters | Reorders the family parameters by the specified parameters order.
Public method | ReplaceParameter(FamilyParameter, ExternalDefinition, BuiltInParameterGroup, Boolean) | Obsolete. Replace a family parameter with a shared parameter.
Public method | ReplaceParameter(FamilyParameter, ExternalDefinition, ForgeTypeId, Boolean) | Replace a family parameter with a shared parameter.
Public method | ReplaceParameter(FamilyParameter, String, BuiltInParameterGroup, Boolean) | Obsolete. Replace a shared family parameter with a new non-shared family parameter.
Public method | ReplaceParameter(FamilyParameter, String, ForgeTypeId, Boolean) | Replace a shared family parameter with a new non-shared family parameter.
Public method | Set(FamilyParameter, ElementId) | Set the ElementId value of a family parameter of the current family type.
Public method | Set(FamilyParameter, Double) | Set the double value of a family parameter of the current family type.
Public method | Set(FamilyParameter, Int32) | Set the integer value of a family parameter of the current family type.
Public method | Set(FamilyParameter, String) | Set the string value of a family parameter of the current family type.
Public method | SetDescription | Set the description for an existing family parameter. The description will be used as tooltip in the Revit UI including in the properties palette.
Public method | SetFormula | Set the formula of a family parameter.
Public method | SetParameterLocked | For Conceptual Mass and Curtain Panel families, lock or unlock a dimension-driving parameter.
Public method | SetValueString | Set the string value of a family parameter of the current family type.
Public method | SortParameters | Sorts the family parameters according to the desired sort order.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CurrentType | The current family type.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Parameter[([( Guid])]) | Obtains the parameter of this type with a given GUID for a shared parameter.
Public property | Parameter[([( String])]) | Obtains the parameter of this type with a given name.
Public property | Parameter[([( BuiltInParameter])]) | Obtains the parameter of this type with a given parameter id.
Public property | Parameter[([( Definition])]) | Obtains the parameter of this type with a given definition.
Public property | Parameters | All family parameters in this family.
Public property | Types | All family types in the family.

See Also

FamilyManager Class


FamilyManager Methods

[image] [image]

Revit 2024 API
FamilyManager Methods
FamilyManager Class See Also Send Feedback

The FamilyManager type exposes the following members.

Methods

 | Name | Description
Public method | AddParameter(ExternalDefinition, BuiltInParameterGroup, Boolean) | Obsolete. Add a new shared parameter to the family.
Public method | AddParameter(ExternalDefinition, ForgeTypeId, Boolean) | Add a new shared parameter to the family.
Public method | AddParameter(String, BuiltInParameterGroup, Category, Boolean) | Obsolete. Add a new family type parameter to control the type of a nested family within another family.
Public method | AddParameter(String, ForgeTypeId, Category, Boolean) | Add a new family type parameter to control the type of a nested family within another family.
Public method | AddParameter(String, ForgeTypeId, ForgeTypeId, Boolean) | Add a new family parameter with a given name.
Public method | AssociateElementParameterToFamilyParameter | Associates or disassociates the element parameter to an existing family parameter.
Public method | CanElementParameterBeAssociated | Indicates if this element parameter can be associated with a family parameter.
Public method | DeleteCurrentType | Remove the current family type.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAssociatedFamilyParameter | Gets the associated family parameter of an element parameter.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParameter | Obtains the family parameter with the given built-in parameter identifier.
Public method | GetParameters | Gets the parameters associated to family types in order.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsParameterLockable | For Conceptual Mass and Curtain Panel families, indicate whether the specified parameter can be locked.
Public method | IsParameterLocked | For Conceptual Mass and Curtain Panel families, indicate whether the specified dimension-driving parameter is locked.
Public method | IsUserAssignableParameterGroup(BuiltInParameterGroup) | Obsolete. Checks if the given parameter group can be assigned to new parameters.
Public method | IsUserAssignableParameterGroup(ForgeTypeId) | Checks if the given parameter group can be assigned to new parameters.
Public method | MakeInstance | Set the family parameter as an instance parameter.
Public method | MakeNonReporting | Set the reporting family parameter as a regular/driving parameter.
Public method | MakeReporting | Set the family parameter as a reporting parameter.
Public method | MakeType | Set the family parameter as a type parameter.
Public method | NewType | Add a new family type with a given name and makes it be the current type.
Public method | RemoveParameter | Remove an existing family parameter from the family.
Public method | RenameCurrentType | Rename the current family type.
Public method | RenameParameter | Rename a family parameter.
Public method | ReorderParameters | Reorders the family parameters by the specified parameters order.
Public method | ReplaceParameter(FamilyParameter, ExternalDefinition, BuiltInParameterGroup, Boolean) | Obsolete. Replace a family parameter with a shared parameter.
Public method | ReplaceParameter(FamilyParameter, ExternalDefinition, ForgeTypeId, Boolean) | Replace a family parameter with a shared parameter.
Public method | ReplaceParameter(FamilyParameter, String, BuiltInParameterGroup, Boolean) | Obsolete. Replace a shared family parameter with a new non-shared family parameter.
Public method | ReplaceParameter(FamilyParameter, String, ForgeTypeId, Boolean) | Replace a shared family parameter with a new non-shared family parameter.
Public method | Set(FamilyParameter, ElementId) | Set the ElementId value of a family parameter of the current family type.
Public method | Set(FamilyParameter, Double) | Set the double value of a family parameter of the current family type.
Public method | Set(FamilyParameter, Int32) | Set the integer value of a family parameter of the current family type.
Public method | Set(FamilyParameter, String) | Set the string value of a family parameter of the current family type.
Public method | SetDescription | Set the description for an existing family parameter. The description will be used as tooltip in the Revit UI including in the properties palette.
Public method | SetFormula | Set the formula of a family parameter.
Public method | SetParameterLocked | For Conceptual Mass and Curtain Panel families, lock or unlock a dimension-driving parameter.
Public method | SetValueString | Set the string value of a family parameter of the current family type.
Public method | SortParameters | Sorts the family parameters according to the desired sort order.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FamilyManager Class


AddParameter Method (ExternalDefinition, BuiltInParameterGroup, Boolean)

[image]

Revit 2024 API
FamilyManager..::..AddParameter Method (ExternalDefinition, BuiltInParameterGroup, Boolean)
FamilyManager Class See Also Send Feedback
Add a new shared parameter to the family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
[ObsoleteAttribute("This method is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use the `AddParameter(ExternalDefinition, ForgeTypeId, bool)` method instead.")]
public FamilyParameter AddParameter(
    ExternalDefinition familyDefinition,
    BuiltInParameterGroup parameterGroup,
    bool isInstance
)
Visual Basic
<ObsoleteAttribute("This method is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use the `AddParameter(ExternalDefinition, ForgeTypeId, bool)` method instead.")> _
Public Function AddParameter ( _
    familyDefinition As ExternalDefinition, _
    parameterGroup As BuiltInParameterGroup, _
    isInstance As Boolean _
) As FamilyParameter
Visual C++
[ObsoleteAttribute(L"This method is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use the `AddParameter(ExternalDefinition, ForgeTypeId, bool)` method instead.")]
public:
FamilyParameter^ AddParameter(
    ExternalDefinition^ familyDefinition,
    BuiltInParameterGroup parameterGroup,
    bool isInstance
)

Parameters

familyDefinition
Type: Autodesk.Revit.DB..::..ExternalDefinition
The definition of the loaded shared parameter.
parameterGroup
Type: Autodesk.Revit.DB..::..BuiltInParameterGroup
The group to which the family parameter belongs.
isInstance
Type: System..::..Boolean
Indicates if the new parameter is instance or type.

Return Value

If creation was successful the new shared parameter is returned, otherwise an exception with failure information will be thrown.

Remarks

This method can work even without any family type, but it cannot be assigned the value via FamilyManager.Set methods when there is no current type.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input parameter group cannot be assigned to the new parameter.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the shared family parameter creation is not supported. Or trying to add an instance parameter of image type.

See Also

FamilyManager Class
AddParameter Overload


AddParameter Method (ExternalDefinition, ForgeTypeId, Boolean)

[image]

Revit 2024 API
FamilyManager..::..AddParameter Method (ExternalDefinition, ForgeTypeId, Boolean)
FamilyManager Class See Also Send Feedback
Add a new shared parameter to the family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyParameter AddParameter(
    ExternalDefinition familyDefinition,
    ForgeTypeId groupTypeId,
    bool isInstance
)
Visual Basic
Public Function AddParameter ( _
    familyDefinition As ExternalDefinition, _
    groupTypeId As ForgeTypeId, _
    isInstance As Boolean _
) As FamilyParameter
Visual C++
public:
FamilyParameter^ AddParameter(
    ExternalDefinition^ familyDefinition,
    ForgeTypeId^ groupTypeId,
    bool isInstance
)

Parameters

familyDefinition
Type: Autodesk.Revit.DB..::..ExternalDefinition
The definition of the loaded shared parameter.
groupTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
The identifier of the parameter group to which the family parameter belongs.
isInstance
Type: System..::..Boolean
Indicates if the new parameter is instance or type.

Return Value

If creation was successful the new shared parameter is returned, otherwise an exception with failure information will be thrown.

Remarks

This method can work even without any family type, but it cannot be assigned the value via FamilyManager.Set methods when there is no current type.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input parameter group cannot be assigned to the new parameter.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the shared family parameter creation is not supported. Or trying to add an instance parameter of image type.

See Also

FamilyManager Class
AddParameter Overload


AddParameter Method (String, ForgeTypeId, Category, Boolean)

[image]

Revit 2024 API
FamilyManager..::..AddParameter Method (String, ForgeTypeId, Category, Boolean)
FamilyManager Class See Also Send Feedback
Add a new family type parameter to control the type of a nested family within another family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyParameter AddParameter(
    string parameterName,
    ForgeTypeId groupTypeId,
    Category familyCategory,
    bool isInstance
)
Visual Basic
Public Function AddParameter ( _
    parameterName As String, _
    groupTypeId As ForgeTypeId, _
    familyCategory As Category, _
    isInstance As Boolean _
) As FamilyParameter
Visual C++
public:
FamilyParameter^ AddParameter(
    String^ parameterName,
    ForgeTypeId^ groupTypeId,
    Category^ familyCategory,
    bool isInstance
)

Parameters

parameterName
Type: System..::..String
The name of the new family parameter.
groupTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
The identifier of the group to which the family parameter belongs.
familyCategory
Type: Autodesk.Revit.DB..::..Category
The category to which the new family parameter binds.
isInstance
Type: System..::..Boolean
Indicates if the new family parameter is instance or type.

Return Value

If creation was successful the new parameter is returned, otherwise an exception with failure information will be thrown.

Remarks

This method can work even without any family type, but it cannot be assigned the value via FamilyManager.Set methods when there is no current type.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"parameterName"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-"parameterName"-is already in use, or the input parameter group cannot be assigned to the new parameter, or the input argument-"familyCategory"-is illegal to bind with parameter.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the required family of familyCategory is not existing in current document, , or when the creation failed. Or trying to add an instance parameter of image type.

See Also

FamilyManager Class
AddParameter Overload


AddParameter Method (String, ForgeTypeId, ForgeTypeId, Boolean)

[image]

Revit 2024 API
FamilyManager..::..AddParameter Method (String, ForgeTypeId, ForgeTypeId, Boolean)
FamilyManager Class See Also Send Feedback
Add a new family parameter with a given name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyParameter AddParameter(
    string parameterName,
    ForgeTypeId groupTypeId,
    ForgeTypeId specTypeId,
    bool isInstance
)
Visual Basic
Public Function AddParameter ( _
    parameterName As String, _
    groupTypeId As ForgeTypeId, _
    specTypeId As ForgeTypeId, _
    isInstance As Boolean _
) As FamilyParameter
Visual C++
public:
FamilyParameter^ AddParameter(
    String^ parameterName,
    ForgeTypeId^ groupTypeId,
    ForgeTypeId^ specTypeId,
    bool isInstance
)

Parameters

parameterName
Type: System..::..String
The name of the new family parameter.
groupTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
The identifier of the new family parameter's parameter group.
specTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
The type of new family parameter.
isInstance
Type: System..::..Boolean
Indicates if the new family parameter is instance or type.

Return Value

If creation was successful the new parameter is returned, otherwise an exception with failure information will be thrown.

Remarks

This method can work even without any family type, but it cannot be assigned the value via FamilyManager.Set methods when there is no current type. To add a parameter of family type use the AddParameter overload that accepts a category instead.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"parameterName"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-"parameterName"-is already in use, or when the input argument -"specTypeId" is an invalid type, or the input parameter group cannot be assigned to the new parameter.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the family parameter creation failed. Or trying to add an instance parameter of image type.

See Also

FamilyManager Class
AddParameter Overload


AssociateElementParameterToFamilyParameter Method

[image]

Revit 2024 API
FamilyManager..::..AssociateElementParameterToFamilyParameter Method
FamilyManager Class See Also Send Feedback
Associates or disassociates the element parameter to an existing family parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void AssociateElementParameterToFamilyParameter(
    Parameter elementParameter,
    FamilyParameter familyParameter
)
Visual Basic
Public Sub AssociateElementParameterToFamilyParameter ( _
    elementParameter As Parameter, _
    familyParameter As FamilyParameter _
)
Visual C++
public:
void AssociateElementParameterToFamilyParameter(
    Parameter^ elementParameter,
    FamilyParameter^ familyParameter
)

Parameters

elementParameter
Type: Autodesk.Revit.DB..::..Parameter
The parameter of an element in family.
familyParameter
Type: Autodesk.Revit.DB..::..FamilyParameter
The existing family parameter. If the input to this argument is nullNothingnullptra null reference (Nothing in Visual Basic), it will disassociate the element parameter from any family parameters.

Remarks

The parameter types of these two input parameter should be same, if not an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"elementParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-"elementParameter" or "familyParameter"-is an invalid parameter, or the input argument-"elementParameter"-cannot be associated.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the family parameter binding failed.

See Also

FamilyManager Class


DeleteCurrentType Method

[image]

Revit 2024 API
FamilyManager..::..DeleteCurrentType Method
FamilyManager Class See Also Send Feedback
Remove the current family type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void DeleteCurrentType()
Visual Basic
Public Sub DeleteCurrentType
Visual C++
public:
void DeleteCurrentType()

Remarks

If successfully removed, the first available type will become the current type, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when there is only one family type in current document.

See Also

FamilyManager Class


GetAssociatedFamilyParameter Method

[image]

Revit 2024 API
FamilyManager..::..GetAssociatedFamilyParameter Method
FamilyManager Class See Also Send Feedback
Gets the associated family parameter of an element parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyParameter GetAssociatedFamilyParameter(
    Parameter elementParameter
)
Visual Basic
Public Function GetAssociatedFamilyParameter ( _
    elementParameter As Parameter _
) As FamilyParameter
Visual C++
public:
FamilyParameter^ GetAssociatedFamilyParameter(
    Parameter^ elementParameter
)

Parameters

elementParameter
Type: Autodesk.Revit.DB..::..Parameter
The parameter of an element in family.

Return Value

The associated family parameter if there is an association between them, returns nullNothingnullptra null reference (Nothing in Visual Basic) if not.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"elementParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

FamilyManager Class


GetParameter Method

[image]

Revit 2024 API
FamilyManager..::..GetParameter Method
FamilyManager Class See Also Send Feedback
Obtains the family parameter with the given built-in parameter identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public FamilyParameter GetParameter(
    ForgeTypeId parameterTypeId
)
Visual Basic
Public Function GetParameter ( _
    parameterTypeId As ForgeTypeId _
) As FamilyParameter
Visual C++
public:
FamilyParameter^ GetParameter(
    ForgeTypeId^ parameterTypeId
)

Parameters

parameterTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
Identifier of the built-in parameter.

Remarks

Returns nullNothingnullptra null reference (Nothing in Visual Basic) if the parameter is not found.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | parameterTypeId does not identify a built-in parameter. See Parameter.IsBuiltInParameter(ForgeTypeId) and Parameter.GetParameterTypeId(BuiltInParameter).
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FamilyManager Class


GetParameters Method

[image]

Revit 2024 API
FamilyManager..::..GetParameters Method
FamilyManager Class See Also Send Feedback
Gets the parameters associated to family types in order.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public IList<FamilyParameter> GetParameters()
Visual Basic
Public Function GetParameters As IList(Of FamilyParameter)
Visual C++
public:
IList<FamilyParameter^>^ GetParameters()

Return Value

A collection containing all family parameters.

Remarks

The parameters are family built-in parameters, category built-in parameters and shared parameters associated to the family types.

The collection consists of both visible and invisible parameters associated to the family types.

The parameters are returned in the order in which they appear in the Revit UI within a given group; however, parameters of different groups may be mixed within this output.

Currently the Revit UI order is determined first by group and next by the order of the individual parameters.

See Also

FamilyManager Class


IsParameterLockable Method

[image]

Revit 2024 API
FamilyManager..::..IsParameterLockable Method
FamilyManager Class See Also Send Feedback
For Conceptual Mass and Curtain Panel families, indicate whether the specified parameter can be locked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsParameterLockable(
    FamilyParameter familyParameter
)
Visual Basic
Public Function IsParameterLockable ( _
    familyParameter As FamilyParameter _
) As Boolean
Visual C++
public:
bool IsParameterLockable(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::..FamilyParameter

Return Value

True if the family is a Conceptual Mass or Curtain Panel Family and the parameter drives one or more dimensions; false otherwise.

See Also

FamilyManager Class


IsParameterLocked Method

[image]

Revit 2024 API
FamilyManager..::..IsParameterLocked Method
FamilyManager Class See Also Send Feedback
For Conceptual Mass and Curtain Panel families, indicate whether the specified dimension-driving parameter is locked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsParameterLocked(
    FamilyParameter familyParameter
)
Visual Basic
Public Function IsParameterLocked ( _
    familyParameter As FamilyParameter _
) As Boolean
Visual C++
public:
bool IsParameterLocked(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::..FamilyParameter

Return Value

True if the parameter is lockable and is locked; false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if this family is not a Conceptual Mass or Curtain Panel family.

See Also

FamilyManager Class


IsUserAssignableParameterGroup Method

[image] [image]

Revit 2024 API
FamilyManager..::..IsUserAssignableParameterGroup Method
FamilyManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsUserAssignableParameterGroup(BuiltInParameterGroup) | Obsolete. Checks if the given parameter group can be assigned to new parameters.
Public method | IsUserAssignableParameterGroup(ForgeTypeId) | Checks if the given parameter group can be assigned to new parameters.

See Also

FamilyManager Class
FamilyManager Members


IsUserAssignableParameterGroup Method (BuiltInParameterGroup)

[image]

Revit 2024 API
FamilyManager..::..IsUserAssignableParameterGroup Method (BuiltInParameterGroup)
FamilyManager Class See Also Send Feedback
Checks if the given parameter group can be assigned to new parameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
[ObsoleteAttribute("This method is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use the `IsUserAssignableParameterGroup(ForgeTypeId)` method instead.")]
public bool IsUserAssignableParameterGroup(
    BuiltInParameterGroup parameterGroup
)
Visual Basic
<ObsoleteAttribute("This method is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use the `IsUserAssignableParameterGroup(ForgeTypeId)` method instead.")> _
Public Function IsUserAssignableParameterGroup ( _
    parameterGroup As BuiltInParameterGroup _
) As Boolean
Visual C++
[ObsoleteAttribute(L"This method is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use the `IsUserAssignableParameterGroup(ForgeTypeId)` method instead.")]
public:
bool IsUserAssignableParameterGroup(
    BuiltInParameterGroup parameterGroup
)

Parameters

parameterGroup
Type: Autodesk.Revit.DB..::..BuiltInParameterGroup

Return Value

True if the parameter group can be assigned to new parameters, false otherwise.

See Also

FamilyManager Class
IsUserAssignableParameterGroup Overload


IsUserAssignableParameterGroup Method (ForgeTypeId)

[image]

Revit 2024 API
FamilyManager..::..IsUserAssignableParameterGroup Method (ForgeTypeId)
FamilyManager Class See Also Send Feedback
Checks if the given parameter group can be assigned to new parameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool IsUserAssignableParameterGroup(
    ForgeTypeId groupTypeId
)
Visual Basic
Public Function IsUserAssignableParameterGroup ( _
    groupTypeId As ForgeTypeId _
) As Boolean
Visual C++
public:
bool IsUserAssignableParameterGroup(
    ForgeTypeId^ groupTypeId
)

Parameters

groupTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId

Return Value

True if the parameter group can be assigned to new parameters, false otherwise.

See Also

FamilyManager Class
IsUserAssignableParameterGroup Overload


MakeInstance Method

[image]

Revit 2024 API
FamilyManager..::..MakeInstance Method
FamilyManager Class See Also Send Feedback
Set the family parameter as an instance parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void MakeInstance(
    FamilyParameter familyParameter
)
Visual Basic
Public Sub MakeInstance ( _
    familyParameter As FamilyParameter _
)
Visual C++
public:
void MakeInstance(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::..FamilyParameter

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"familyParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-"familyParameter"-is an invalid parameter or a builtIn parameter.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when there is Type family parameter driven by this parameter. Or trying to make a parameter of image type to instance.

See Also

FamilyManager Class


MakeNonReporting Method

[image]

Revit 2024 API
FamilyManager..::..MakeNonReporting Method
FamilyManager Class See Also Send Feedback
Set the reporting family parameter as a regular/driving parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public void MakeNonReporting(
    FamilyParameter familyParameter
)
Visual Basic
Public Sub MakeNonReporting ( _
    familyParameter As FamilyParameter _
)
Visual C++
public:
void MakeNonReporting(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::..FamilyParameter

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"familyParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when attempting to make a parameter which is labeled to an arc length dimension non-reporting.

See Also

FamilyManager Class


MakeReporting Method

[image]

Revit 2024 API
FamilyManager..::..MakeReporting Method
FamilyManager Class See Also Send Feedback
Set the family parameter as a reporting parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public void MakeReporting(
    FamilyParameter familyParameter
)
Visual Basic
Public Sub MakeReporting ( _
    familyParameter As FamilyParameter _
)
Visual C++
public:
void MakeReporting(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::..FamilyParameter

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"familyParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the parameter can not be changed to a reporting parameter.

See Also

FamilyManager Class


MakeType Method

[image]

Revit 2024 API
FamilyManager..::..MakeType Method
FamilyManager Class See Also Send Feedback
Set the family parameter as a type parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void MakeType(
    FamilyParameter familyParameter
)
Visual Basic
Public Sub MakeType ( _
    familyParameter As FamilyParameter _
)
Visual C++
public:
void MakeType(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::..FamilyParameter

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"familyParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-"familyParameter"-is an invalid parameter or a builtIn parameter.

See Also

FamilyManager Class


NewType Method

[image]

Revit 2024 API
FamilyManager..::..NewType Method
FamilyManager Class Example See Also Send Feedback
Add a new family type with a given name and makes it be the current type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyType NewType(
    string typeName
)
Visual Basic
Public Function NewType ( _
    typeName As String _
) As FamilyType
Visual C++
public:
FamilyType^ NewType(
    String^ typeName
)

Parameters

typeName
Type: System..::..String
The name of new family type.

Examples

CopyC#
public void EditFamilyTypes(Document document, FamilyInstance familyInstance)
{
    // example works best when familyInstance is a rectangular concrete element

    if ((null == document) || (null == familyInstance.Symbol))
    {
        return;   // invalid arguments
    }

    // Get family associated with this
    Family family = familyInstance.Symbol.Family;
    if (null == family)
    {
        return;    // could not get the family
    }

    // Get Family document for family
    Document familyDoc = document.EditFamily(family);
    if (null == familyDoc)
    {
        return;    // could not open a family for edit
    }

    FamilyManager familyManager = familyDoc.FamilyManager;
    if (null == familyManager)
    {
        return;  // cuould not get a family manager
    }

    // Start transaction for the family document
    using (Transaction newFamilyTypeTransaction = new Transaction(familyDoc, "Add Type to Family"))
    {
        int changesMade = 0;
        newFamilyTypeTransaction.Start();

        // add a new type and edit its parameters
        FamilyType newFamilyType = familyManager.NewType("2X2");

        if (newFamilyType != null)
        {
            // look for 'b' and 'h' parameters and set them to 2 feet
            FamilyParameter familyParam = familyManager.get_Parameter("b");
            if (null != familyParam)
            {
                familyManager.Set(familyParam, 2.0);
                changesMade += 1;
            }

            familyParam = familyManager.get_Parameter("h");
            if (null != familyParam)
            {
                familyManager.Set(familyParam, 2.0);
                changesMade += 1;
            }
        }

        if (2 == changesMade)   // set both paramaters?
        {
            newFamilyTypeTransaction.Commit();
        }
        else   // could not make the change -> should roll back
        {
            newFamilyTypeTransaction.RollBack();
        }

        // if could not make the change or could not commit it, we return
        if (newFamilyTypeTransaction.GetStatus() != TransactionStatus.Committed)
        {
            return;
        }
    }

    // now update the Revit project with Family which has a new type
    LoadOpts loadOptions = new LoadOpts();

    // This overload is necessary for reloading an edited family
    // back into the source document from which it was extracted
    family = familyDoc.LoadFamily(document, loadOptions);
    if (null != family)
    {
        // find the new type and assign it to FamilyInstance
        ISet<ElementId> familySymbolIds = family.GetFamilySymbolIds();
        foreach (ElementId id in familySymbolIds)
        {
            FamilySymbol familySymbol = family.Document.GetElement(id) as FamilySymbol;
            if ((null != familySymbol) && familySymbol.Name == "2X2")
            {
                using (Transaction changeSymbol = new Transaction(document, "Change Symbol Assignment"))
                {
                    changeSymbol.Start();
                    familyInstance.Symbol = familySymbol;
                    changeSymbol.Commit();
                }
                break;
            }
        }
    }
}

class LoadOpts : IFamilyLoadOptions
{
    public bool OnFamilyFound(bool familyInUse, out bool overwriteParameterValues)
    {
        overwriteParameterValues = true;
        return true;
    }

    public bool OnSharedFamilyFound(Family sharedFamily, bool familyInUse, out FamilySource source, out bool overwriteParameterValues)
    {
        source = FamilySource.Family;
        overwriteParameterValues = true;
        return true;
    }
}
CopyVB.NET
Public Sub EditFamilyTypes(document As Document, familyInstance As FamilyInstance)
    ' example works best when familyInstance is a rectangular concrete element

    If (document Is Nothing) OrElse (familyInstance.Symbol Is Nothing) Then
        ' invalid arguments
        Return
    End If

    ' Get family associated with this
    Dim family As Family = familyInstance.Symbol.Family
    If family Is Nothing Then
        ' could not get the family
        Return
    End If

    ' Get Family document for family
    Dim familyDoc As Document = document.EditFamily(family)
    If familyDoc Is Nothing Then
        ' could not open a family for edit
        Return
    End If

    Dim familyManager As FamilyManager = familyDoc.FamilyManager
    If familyManager Is Nothing Then
        ' cuould not get a family manager
        Return
    End If

    ' Start transaction for the family document
    Using newFamilyTypeTransaction As New Transaction(familyDoc, "Add Type to Family")
        Dim changesMade As Integer = 0
        newFamilyTypeTransaction.Start()

        ' add a new type and edit its parameters
        Dim newFamilyType As FamilyType = familyManager.NewType("2X2")

        If newFamilyType IsNot Nothing Then
            ' look for 'b' and 'h' parameters and set them to 2 feet
            Dim familyParam As FamilyParameter = familyManager.Parameter("b")
            If familyParam IsNot Nothing Then
                familyManager.[Set](familyParam, 2.0)
                changesMade += 1
            End If

            familyParam = familyManager.Parameter("h")
            If familyParam IsNot Nothing Then
                familyManager.[Set](familyParam, 2.0)
                changesMade += 1
            End If
        End If

        If 2 = changesMade Then
            ' set both paramaters?
            newFamilyTypeTransaction.Commit()
        Else
            ' could not make the change -> should roll back
            newFamilyTypeTransaction.RollBack()
        End If

        ' if could not make the change or could not commit it, we return
        If newFamilyTypeTransaction.GetStatus() <> TransactionStatus.Committed Then
            Return
        End If
    End Using

    ' now update the Revit project with Family which has a new type
    Dim loadOptions As New LoadOpts()

    ' This overload is necessary for reloading an edited family
    ' back into the source document from which it was extracted
    family = familyDoc.LoadFamily(document, loadOptions)
    If family IsNot Nothing Then
        ' find the new type and assign it to FamilyInstance
        Dim familySymbolIds As ISet(Of ElementId) = family.GetFamilySymbolIds()
        For Each id As ElementId In familySymbolIds
            Dim familySymbol As FamilySymbol = TryCast(family.Document.GetElement(id), FamilySymbol)
            If (familySymbol IsNot Nothing) AndAlso familySymbol.Name = "2X2" Then
                Using changeSymbol As New Transaction(document, "Change Symbol Assignment")
                    changeSymbol.Start()
                    familyInstance.Symbol = familySymbol
                    changeSymbol.Commit()
                End Using
                Exit For
            End If
        Next
    End If
End Sub

Private Class LoadOpts
    Implements IFamilyLoadOptions
    Public Function OnFamilyFound(familyInUse As Boolean, ByRef overwriteParameterValues As Boolean) As Boolean Implements IFamilyLoadOptions.OnFamilyFound
        overwriteParameterValues = True
        Return True
    End Function

    Public Function OnSharedFamilyFound(sharedFamily As Family, familyInUse As Boolean, ByRef source As FamilySource, ByRef overwriteParameterValues As Boolean) As Boolean Implements IFamilyLoadOptions.OnSharedFamilyFound
        source = FamilySource.Family
        overwriteParameterValues = True
        Return True
    End Function
End Class

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"typeName"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-"typeName"-is already in use.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the family type creation failed.

See Also

FamilyManager Class


RenameParameter Method

[image]

Revit 2024 API
FamilyManager..::..RenameParameter Method
FamilyManager Class See Also Send Feedback
Rename a family parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void RenameParameter(
    FamilyParameter familyParameter,
    string name
)
Visual Basic
Public Sub RenameParameter ( _
    familyParameter As FamilyParameter, _
    name As String _
)
Visual C++
public:
void RenameParameter(
    FamilyParameter^ familyParameter,
    String^ name
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::..FamilyParameter
The family parameter.
name
Type: System..::..String
The new name.

Remarks

This operation is valid only for Family Parameters, and is invalid for Shared Parameters and Built-in Parameters.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"familyParameter" or "name"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-"familyParameter"-is invalid, or the input name string contains illegal characters, or duplicated with existing parameter name.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when trying to rename a built-in parameter or shared parameter.

See Also

FamilyManager Class


ReplaceParameter Method (FamilyParameter, ExternalDefinition, BuiltInParameterGroup, Boolean)

[image]

Revit 2024 API
FamilyManager..::..ReplaceParameter Method (FamilyParameter, ExternalDefinition, BuiltInParameterGroup, Boolean)
FamilyManager Class See Also Send Feedback
Replace a family parameter with a shared parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
[ObsoleteAttribute("This method is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use the `ReplaceParameter(FamilyParameter, ExternalDefinition, ForgeTypeId, bool)` method instead.")]
public FamilyParameter ReplaceParameter(
    FamilyParameter currentParameter,
    ExternalDefinition familyDefinition,
    BuiltInParameterGroup parameterGroup,
    bool isInstance
)
Visual Basic
<ObsoleteAttribute("This method is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use the `ReplaceParameter(FamilyParameter, ExternalDefinition, ForgeTypeId, bool)` method instead.")> _
Public Function ReplaceParameter ( _
    currentParameter As FamilyParameter, _
    familyDefinition As ExternalDefinition, _
    parameterGroup As BuiltInParameterGroup, _
    isInstance As Boolean _
) As FamilyParameter
Visual C++
[ObsoleteAttribute(L"This method is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use the `ReplaceParameter(FamilyParameter, ExternalDefinition, ForgeTypeId, bool)` method instead.")]
public:
FamilyParameter^ ReplaceParameter(
    FamilyParameter^ currentParameter,
    ExternalDefinition^ familyDefinition,
    BuiltInParameterGroup parameterGroup,
    bool isInstance
)

Parameters

currentParameter
Type: Autodesk.Revit.DB..::..FamilyParameter
The current family parameter.
familyDefinition
Type: Autodesk.Revit.DB..::..ExternalDefinition
The definition of the loaded shared parameter.
parameterGroup
Type: Autodesk.Revit.DB..::..BuiltInParameterGroup
The group to which the new shared parameter belongs.
isInstance
Type: System..::..Boolean
Indicates if the new parameter is instance or type.

Return Value

If replacement was successful the new shared parameter is returned, otherwise an exception with failure information will be thrown.

Remarks

This operation is invalid for Built-in Parameters. The formulas and labels which in reference to this parameter will be updated to the new parameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"familyParameter" or "name"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-"familyParameter"-is invalid, or the input parameter group cannot be assigned to the new parameter, or the input name string contains illegal characters, or duplicated with existing parameter name.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when trying to replace a built-in parameter.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when replacement failed, because the replacement would cause a formula error. Or trying to replace with an instance parameter of image type.

See Also

FamilyManager Class
ReplaceParameter Overload


ReplaceParameter Method (FamilyParameter, ExternalDefinition, ForgeTypeId, Boolean)

[image]

Revit 2024 API
FamilyManager..::..ReplaceParameter Method (FamilyParameter, ExternalDefinition, ForgeTypeId, Boolean)
FamilyManager Class See Also Send Feedback
Replace a family parameter with a shared parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyParameter ReplaceParameter(
    FamilyParameter currentParameter,
    ExternalDefinition familyDefinition,
    ForgeTypeId groupTypeId,
    bool isInstance
)
Visual Basic
Public Function ReplaceParameter ( _
    currentParameter As FamilyParameter, _
    familyDefinition As ExternalDefinition, _
    groupTypeId As ForgeTypeId, _
    isInstance As Boolean _
) As FamilyParameter
Visual C++
public:
FamilyParameter^ ReplaceParameter(
    FamilyParameter^ currentParameter,
    ExternalDefinition^ familyDefinition,
    ForgeTypeId^ groupTypeId,
    bool isInstance
)

Parameters

currentParameter
Type: Autodesk.Revit.DB..::..FamilyParameter
The current family parameter.
familyDefinition
Type: Autodesk.Revit.DB..::..ExternalDefinition
The definition of the loaded shared parameter.
groupTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
The identifier of the group to which the new shared parameter belongs.
isInstance
Type: System..::..Boolean
Indicates if the new parameter is instance or type.

Return Value

If replacement was successful the new shared parameter is returned, otherwise an exception with failure information will be thrown.

Remarks

This operation is invalid for Built-in Parameters. The formulas and labels which in reference to this parameter will be updated to the new parameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"familyParameter" or "name"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-"familyParameter"-is invalid, or the input parameter group cannot be assigned to the new parameter, or the input name string contains illegal characters, or duplicated with existing parameter name.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when trying to replace a built-in parameter.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when replacement failed, because the replacement would cause a formula error. Or trying to replace with an instance parameter of image type.

See Also

FamilyManager Class
ReplaceParameter Overload


ReplaceParameter Method (FamilyParameter, String, BuiltInParameterGroup, Boolean)

[image]

Revit 2024 API
FamilyManager..::..ReplaceParameter Method (FamilyParameter, String, BuiltInParameterGroup, Boolean)
FamilyManager Class See Also Send Feedback
Replace a shared family parameter with a new non-shared family parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
[ObsoleteAttribute("This method is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use the `ReplaceParameter(FamilyParameter, ExternalDefinition, ForgeTypeId, bool)` method instead.")]
public FamilyParameter ReplaceParameter(
    FamilyParameter currentParameter,
    string parameterName,
    BuiltInParameterGroup parameterGroup,
    bool isInstance
)
Visual Basic
<ObsoleteAttribute("This method is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use the `ReplaceParameter(FamilyParameter, ExternalDefinition, ForgeTypeId, bool)` method instead.")> _
Public Function ReplaceParameter ( _
    currentParameter As FamilyParameter, _
    parameterName As String, _
    parameterGroup As BuiltInParameterGroup, _
    isInstance As Boolean _
) As FamilyParameter
Visual C++
[ObsoleteAttribute(L"This method is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use the `ReplaceParameter(FamilyParameter, ExternalDefinition, ForgeTypeId, bool)` method instead.")]
public:
FamilyParameter^ ReplaceParameter(
    FamilyParameter^ currentParameter,
    String^ parameterName,
    BuiltInParameterGroup parameterGroup,
    bool isInstance
)

Parameters

currentParameter
Type: Autodesk.Revit.DB..::..FamilyParameter
The current family parameter.
parameterName
Type: System..::..String
The name of the new family parameter.
parameterGroup
Type: Autodesk.Revit.DB..::..BuiltInParameterGroup
The group to which the new family parameter belongs.
isInstance
Type: System..::..Boolean
Indicates if the new parameter is instance or type.

Return Value

If replacement was successful the new family parameter is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"currentParameter" or "parameterName"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-"currentParameter"-is invalid, or the input parameter group cannot be assigned to the new parameter, or the input name string contains illegal characters, or duplicated with existing parameter name.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when trying to replace a built-in parameter or family parameter.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when replacement failed, because the replacement would cause a formula error. Or trying to replace with an instance parameter of image type.

See Also

FamilyManager Class
ReplaceParameter Overload


ReplaceParameter Method (FamilyParameter, String, ForgeTypeId, Boolean)

[image]

Revit 2024 API
FamilyManager..::..ReplaceParameter Method (FamilyParameter, String, ForgeTypeId, Boolean)
FamilyManager Class See Also Send Feedback
Replace a shared family parameter with a new non-shared family parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyParameter ReplaceParameter(
    FamilyParameter currentParameter,
    string parameterName,
    ForgeTypeId groupTypeId,
    bool isInstance
)
Visual Basic
Public Function ReplaceParameter ( _
    currentParameter As FamilyParameter, _
    parameterName As String, _
    groupTypeId As ForgeTypeId, _
    isInstance As Boolean _
) As FamilyParameter
Visual C++
public:
FamilyParameter^ ReplaceParameter(
    FamilyParameter^ currentParameter,
    String^ parameterName,
    ForgeTypeId^ groupTypeId,
    bool isInstance
)

Parameters

currentParameter
Type: Autodesk.Revit.DB..::..FamilyParameter
The current family parameter.
parameterName
Type: System..::..String
The name of the new family parameter.
groupTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
The identifier of the group to which the new family parameter belongs.
isInstance
Type: System..::..Boolean
Indicates if the new parameter is instance or type.

Return Value

If replacement was successful the new family parameter is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"currentParameter" or "parameterName"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-"currentParameter"-is invalid, or the input parameter group cannot be assigned to the new parameter, or the input name string contains illegal characters, or duplicated with existing parameter name.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when trying to replace a built-in parameter or family parameter.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when replacement failed, because the replacement would cause a formula error. Or trying to replace with an instance parameter of image type.

See Also

FamilyManager Class
ReplaceParameter Overload


Set Method

[image] [image]

Revit 2024 API
FamilyManager..::..Set Method
FamilyManager Class See Also Send Feedback
Set the value of a family parameter of the current family type.

Overload List

 | Name | Description
Public method | Set(FamilyParameter, ElementId) | Set the ElementId value of a family parameter of the current family type.
Public method | Set(FamilyParameter, Double) | Set the double value of a family parameter of the current family type.
Public method | Set(FamilyParameter, Int32) | Set the integer value of a family parameter of the current family type.
Public method | Set(FamilyParameter, String) | Set the string value of a family parameter of the current family type.

See Also

FamilyManager Class
FamilyManager Members


Set Method (FamilyParameter, ElementId)

[image]

Revit 2024 API
FamilyManager..::..Set Method (FamilyParameter, ElementId)
FamilyManager Class See Also Send Feedback
Set the ElementId value of a family parameter of the current family type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Set(
    FamilyParameter familyParameter,
    ElementId value
)
Visual Basic
Public Sub Set ( _
    familyParameter As FamilyParameter, _
    value As ElementId _
)
Visual C++
public:
void Set(
    FamilyParameter^ familyParameter,
    ElementId^ value
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::..FamilyParameter
A family parameter of the current type.
value
Type: Autodesk.Revit.DB..::..ElementId
The new value for family parameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the storage type of family parameter is not ElementId --or-- The input ElementId does not represent either a valid element in the document or InvalidElementId.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the input ElementId is not valid as a value for this FamilyParameter.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the family parameter is determined by formula, or the current family type is invalid.

See Also

FamilyManager Class
Set Overload


Set Method (FamilyParameter, Double)

[image]

Revit 2024 API
FamilyManager..::..Set Method (FamilyParameter, Double)
FamilyManager Class See Also Send Feedback
Set the double value of a family parameter of the current family type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Set(
    FamilyParameter familyParameter,
    double value
)
Visual Basic
Public Sub Set ( _
    familyParameter As FamilyParameter, _
    value As Double _
)
Visual C++
public:
void Set(
    FamilyParameter^ familyParameter,
    double value
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::..FamilyParameter
A family parameter of the current type.
value
Type: System..::..Double
The new value for family parameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-"familyParameter"-is an invalid family parameter.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the input argument-"familyParameter"-is out of range.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the family parameter is determined by formula, or the current family type is invalid.

See Also

FamilyManager Class
Set Overload


Set Method (FamilyParameter, String)

[image]

Revit 2024 API
FamilyManager..::..Set Method (FamilyParameter, String)
FamilyManager Class See Also Send Feedback
Set the string value of a family parameter of the current family type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Set(
    FamilyParameter familyParameter,
    string value
)
Visual Basic
Public Sub Set ( _
    familyParameter As FamilyParameter, _
    value As String _
)
Visual C++
public:
void Set(
    FamilyParameter^ familyParameter,
    String^ value
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::..FamilyParameter
A family parameter of the current type.
value
Type: System..::..String
The new value for family parameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"familyParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-"familyParameter"-is an invalid family parameter.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the input argument-"familyParameter"-is out of range.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the family parameter is determined by formula, or the current family type is invalid.

See Also

FamilyManager Class
Set Overload


SetParameterLocked Method

[image]

Revit 2024 API
FamilyManager..::..SetParameterLocked Method
FamilyManager Class See Also Send Feedback
For Conceptual Mass and Curtain Panel families, lock or unlock a dimension-driving parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetParameterLocked(
    FamilyParameter familyParameter,
    bool locked
)
Visual Basic
Public Sub SetParameterLocked ( _
    familyParameter As FamilyParameter, _
    locked As Boolean _
)
Visual C++
public:
void SetParameterLocked(
    FamilyParameter^ familyParameter,
    bool locked
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::..FamilyParameter
locked
Type: System..::..Boolean

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if this family is not a Conceptual Mass or Curtain Panel family.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the parameter is not lockable.

See Also

FamilyManager Class


SetValueString Method

[image]

Revit 2024 API
FamilyManager..::..SetValueString Method
FamilyManager Class See Also Send Feedback
Set the string value of a family parameter of the current family type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetValueString(
    FamilyParameter familyParameter,
    string value
)
Visual Basic
Public Sub SetValueString ( _
    familyParameter As FamilyParameter, _
    value As String _
)
Visual C++
public:
void SetValueString(
    FamilyParameter^ familyParameter,
    String^ value
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::..FamilyParameter
The family parameter of current type.
value
Type: System..::..String
The new value string for family parameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-"familyParameter" or "value"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-"familyParameter"-is an invalid family parameter. or the input argument-"value"-is an illegal string.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the input argument-"familyParameter"-is out of range.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the family parameter is determined by formula, or it is not a value type, or the current family type is invalid.

See Also

FamilyManager Class


SortParameters Method

[image]

Revit 2024 API
FamilyManager..::..SortParameters Method
FamilyManager Class Example See Also Send Feedback
Sorts the family parameters according to the desired sort order.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public void SortParameters(
    ParametersOrder order
)
Visual Basic
Public Sub SortParameters ( _
    order As ParametersOrder _
)
Visual C++
public:
void SortParameters(
    ParametersOrder order
)

Parameters

order
Type: Autodesk.Revit.DB..::..ParametersOrder
The desired sort order.

Remarks

The sort only affects visible parameters within the same parameter group.

Parameters that belong to different groups will remain separated, and the groups' order will not be affected.

The sort is a one-time operation and when new parameters are added they will not be automatically sorted.

Examples

CopyC#
private void DisplayParametersInAscendingOrder(Document familyDoc)
{
    FamilyManager familyManager = familyDoc.FamilyManager;
    familyManager.SortParameters(ParametersOrder.Ascending);
}
CopyVB.NET
Private Sub DisplayParametersInAscendingOrder(familyDoc As Document)
    Dim familyManager As FamilyManager = familyDoc.FamilyManager
    familyManager.SortParameters(ParametersOrder.Ascending)
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when this family is a Rebar Shape family which doesn't support parameters reorder.

See Also

FamilyManager Class


FamilyManager Properties

[image] [image]

Revit 2024 API
FamilyManager Properties
FamilyManager Class See Also Send Feedback

The FamilyManager type exposes the following members.

Properties

 | Name | Description
Public property | CurrentType | The current family type.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Parameter[([( Guid])]) | Obtains the parameter of this type with a given GUID for a shared parameter.
Public property | Parameter[([( String])]) | Obtains the parameter of this type with a given name.
Public property | Parameter[([( BuiltInParameter])]) | Obtains the parameter of this type with a given parameter id.
Public property | Parameter[([( Definition])]) | Obtains the parameter of this type with a given definition.
Public property | Parameters | All family parameters in this family.
Public property | Types | All family types in the family.

See Also

FamilyManager Class


CurrentType Property

[image]

Revit 2024 API
FamilyManager..::..CurrentType Property
FamilyManager Class See Also Send Feedback
The current family type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyType CurrentType { get; set; }
Visual Basic
Public Property CurrentType As FamilyType
    Get
    Set
Visual C++
public:
property FamilyType^ CurrentType {
    FamilyType^ get ();
    void set (FamilyType^ value);
}

Remarks

Only the current family type is editable using the methods in FamilyManager. If you want to modify the properties of any family type, it must be set to be the current type first. This value will be nullNothingnullptra null reference (Nothing in Visual Basic) if there is no type in the family. In order to modify parameter values, you will need to create one using NewType(String).

See Also

FamilyManager Class


Parameter Property

[image] [image]

Revit 2024 API
FamilyManager..::..Parameter Property
FamilyManager Class See Also Send Feedback
Obtains a parameter based on an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Obtains the parameter of this type with a given GUID for a shared parameter.
Public property | Parameter[([( String])]) | Obtains the parameter of this type with a given name.
Public property | Parameter[([( BuiltInParameter])]) | Obtains the parameter of this type with a given parameter id.
Public property | Parameter[([( Definition])]) | Obtains the parameter of this type with a given definition.

See Also

FamilyManager Class
FamilyManager Members


Parameter Property (Guid)

[image]

Revit 2024 API
FamilyManager..::..Parameter Property (Guid)
FamilyManager Class See Also Send Feedback
Obtains the parameter of this type with a given GUID for a shared parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyParameter this[
    Guid guid
] { get; }
Visual Basic
Public ReadOnly Property Parameter ( _
    guid As Guid _
) As FamilyParameter
    Get
Visual C++
public:
property FamilyParameter^ Parameter[Guid guid] {
    FamilyParameter^ get (Guid guid);
}

Parameters

guid
Type: System..::..Guid

Remarks

Returns nullNothingnullptra null reference (Nothing in Visual Basic) if the parameter is not found. This method is used to retrieve a family parameter for a known shared parameter. When a shared parameter is created it is assigned a Guid which will not change. This guid can be used to retrieve the piece of data from the element at a later time.

See Also

FamilyManager Class
Parameter Overload


Parameter Property (String)

[image]

Revit 2024 API
FamilyManager..::..Parameter Property (String)
FamilyManager Class See Also Send Feedback
Obtains the parameter of this type with a given name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyParameter this[
    string parameterName
] { get; }
Visual Basic
Public ReadOnly Property Parameter ( _
    parameterName As String _
) As FamilyParameter
    Get
Visual C++
public:
property FamilyParameter^ Parameter[String^ parameterName] {
    FamilyParameter^ get (String^ parameterName);
}

Parameters

parameterName
Type: System..::..String

Remarks

Returns nullNothingnullptra null reference (Nothing in Visual Basic) if the parameter is not found.

See Also

FamilyManager Class
Parameter Overload


Parameter Property (BuiltInParameter)

[image]

Revit 2024 API
FamilyManager..::..Parameter Property (BuiltInParameter)
FamilyManager Class See Also Send Feedback
Obtains the parameter of this type with a given parameter id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyParameter this[
    BuiltInParameter parameterId
] { get; }
Visual Basic
Public ReadOnly Property Parameter ( _
    parameterId As BuiltInParameter _
) As FamilyParameter
    Get
Visual C++
public:
property FamilyParameter^ Parameter[BuiltInParameter parameterId] {
    FamilyParameter^ get (BuiltInParameter parameterId);
}

Parameters

parameterId
Type: Autodesk.Revit.DB..::..BuiltInParameter

Remarks

Returns nullNothingnullptra null reference (Nothing in Visual Basic) if the parameter is not found.

See Also

FamilyManager Class
Parameter Overload


Parameter Property (Definition)

[image]

Revit 2024 API
FamilyManager..::..Parameter Property (Definition)
FamilyManager Class See Also Send Feedback
Obtains the parameter of this type with a given definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyParameter this[
    Definition definition
] { get; }
Visual Basic
Public ReadOnly Property Parameter ( _
    definition As Definition _
) As FamilyParameter
    Get
Visual C++
public:
property FamilyParameter^ Parameter[Definition^ definition] {
    FamilyParameter^ get (Definition^ definition);
}

Parameters

definition
Type: Autodesk.Revit.DB..::..Definition

Remarks

Returns nullNothingnullptra null reference (Nothing in Visual Basic) if the parameter is not found.

See Also

FamilyManager Class
Parameter Overload


Parameters Property

[image]

Revit 2024 API
FamilyManager..::..Parameters Property
FamilyManager Class See Also Send Feedback
All family parameters in this family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyParameterSet Parameters { get; }
Visual Basic
Public ReadOnly Property Parameters As FamilyParameterSet
    Get
Visual C++
public:
property FamilyParameterSet^ Parameters {
    FamilyParameterSet^ get ();
}

Remarks

These parameters will include the 'family parameter', 'shared parameter' and 'builtIn parameter' binding to the family types. Some parameters might be created as placeholders without a currently assigned value.

See Also

FamilyManager Class


Types Property

[image]

Revit 2024 API
FamilyManager..::..Types Property
FamilyManager Class Example See Also Send Feedback
All family types in the family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyTypeSet Types { get; }
Visual Basic
Public ReadOnly Property Types As FamilyTypeSet
    Get
Visual C++
public:
property FamilyTypeSet^ Types {
    FamilyTypeSet^ get ();
}

Examples

CopyC#
public void GetFamilyTypesInFamily(Document familyDoc)
{
    if (familyDoc.IsFamilyDocument)
    {
        FamilyManager familyManager = familyDoc.FamilyManager;

        // get types in family
        string types = "Family Types: ";
        FamilyTypeSet familyTypes = familyManager.Types;
        FamilyTypeSetIterator familyTypesItor = familyTypes.ForwardIterator();
        familyTypesItor.Reset();
        while (familyTypesItor.MoveNext())
        {
            FamilyType familyType = familyTypesItor.Current as FamilyType;
            types += "\n" + familyType.Name;
        }
        TaskDialog.Show("Revit",types);
    }
}
CopyVB.NET
Public Sub GetFamilyTypesInFamily(familyDoc As Document)
    If familyDoc.IsFamilyDocument Then
        Dim familyManager As FamilyManager = familyDoc.FamilyManager

        ' get types in family
        Dim types As String = "Family Types: "
        Dim familyTypes As FamilyTypeSet = familyManager.Types
        Dim familyTypesItor As FamilyTypeSetIterator = familyTypes.ForwardIterator()
        familyTypesItor.Reset()
        While familyTypesItor.MoveNext()
            Dim familyType As FamilyType = TryCast(familyTypesItor.Current, FamilyType)
            types += vbLf + familyType.Name
        End While
        TaskDialog.Show("Revit", types)
    End If
End Sub

See Also

FamilyManager Class


FamilyParameter Class

[image]

Revit 2024 API
FamilyParameter Class
Members See Also Send Feedback
The family parameter object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class FamilyParameter : APIObject
Visual Basic
Public Class FamilyParameter _
    Inherits APIObject
Visual C++
public ref class FamilyParameter : public APIObject

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..FamilyParameter

See Also

FamilyParameter Members


FamilyParameter Members

[image] [image]

Revit 2024 API
FamilyParameter Members
FamilyParameter Class Methods Properties See Also Send Feedback

The FamilyParameter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUnitTypeId | Gets the identifier of the unit quantifying the parameter value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssociatedParameters | The parameters from elements in the family which are associated to this parameter.
Public property | CanAssignFormula | Indicates if this parameter can be assigned a formula.
Public property | Definition | The definition.
Public property | Formula | The formula.
Public property | GUID | The globally unique identifier
Public property | Id | The id of the family parameter.
Public property | IsDeterminedByFormula | Indicates if the parameter is determined by formula.
Public property | IsInstance | Indicates if the parameter is instance or type.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Overrides APIObject..::..IsReadOnly.)
Public property | IsReporting | Indicates if the parameter is a reporting parameter.
Public property | IsShared | Identifies if the parameter is a shared parameter.
Public property | StorageType | The storage type describes the type that is used internally within the parameter to store its value.
Public property | UserModifiable | Indicates whether the interactive user can modify the value of this parameter.

See Also

FamilyParameter Class


GetUnitTypeId Method

[image]

Revit 2024 API
FamilyParameter..::..GetUnitTypeId Method
FamilyParameter Class See Also Send Feedback
Gets the identifier of the unit quantifying the parameter value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ForgeTypeId GetUnitTypeId()
Visual Basic
Public Function GetUnitTypeId As ForgeTypeId
Visual C++
public:
ForgeTypeId^ GetUnitTypeId()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if this parameter is not of value type.

See Also

FamilyParameter Class


FamilyParameter Properties

[image] [image]

Revit 2024 API
FamilyParameter Properties
FamilyParameter Class See Also Send Feedback

The FamilyParameter type exposes the following members.

Properties

 | Name | Description
Public property | AssociatedParameters | The parameters from elements in the family which are associated to this parameter.
Public property | CanAssignFormula | Indicates if this parameter can be assigned a formula.
Public property | Definition | The definition.
Public property | Formula | The formula.
Public property | GUID | The globally unique identifier
Public property | Id | The id of the family parameter.
Public property | IsDeterminedByFormula | Indicates if the parameter is determined by formula.
Public property | IsInstance | Indicates if the parameter is instance or type.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Overrides APIObject..::..IsReadOnly.)
Public property | IsReporting | Indicates if the parameter is a reporting parameter.
Public property | IsShared | Identifies if the parameter is a shared parameter.
Public property | StorageType | The storage type describes the type that is used internally within the parameter to store its value.
Public property | UserModifiable | Indicates whether the interactive user can modify the value of this parameter.

See Also

FamilyParameter Class


AssociatedParameters Property

[image]

Revit 2024 API
FamilyParameter..::..AssociatedParameters Property
FamilyParameter Class See Also Send Feedback
The parameters from elements in the family which are associated to this parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ParameterSet AssociatedParameters { get; }
Visual Basic
Public ReadOnly Property AssociatedParameters As ParameterSet
    Get
Visual C++
public:
property ParameterSet^ AssociatedParameters {
    ParameterSet^ get ();
}

See Also

FamilyParameter Class


CanAssignFormula Property

[image]

Revit 2024 API
FamilyParameter..::..CanAssignFormula Property
FamilyParameter Class See Also Send Feedback
Indicates if this parameter can be assigned a formula.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool CanAssignFormula { get; }
Visual Basic
Public ReadOnly Property CanAssignFormula As Boolean
    Get
Visual C++
public:
property bool CanAssignFormula {
    bool get ();
}

See Also

FamilyParameter Class


Definition Property

[image]

Revit 2024 API
FamilyParameter..::..Definition Property
FamilyParameter Class See Also Send Feedback
The definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Definition Definition { get; }
Visual Basic
Public ReadOnly Property Definition As Definition
    Get
Visual C++
public:
property Definition^ Definition {
    Definition^ get ();
}

See Also

FamilyParameter Class


Formula Property

[image]

Revit 2024 API
FamilyParameter..::..Formula Property
FamilyParameter Class See Also Send Feedback
The formula.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string Formula { get; }
Visual Basic
Public ReadOnly Property Formula As String
    Get
Visual C++
public:
property String^ Formula {
    String^ get ();
}

Remarks

Returns nullNothingnullptra null reference (Nothing in Visual Basic) if there is no formula governing this parameter.

See Also

FamilyParameter Class


GUID Property

[image]

Revit 2024 API
FamilyParameter..::..GUID Property
FamilyParameter Class Example See Also Send Feedback
The globally unique identifier

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public Guid GUID { get; }
Visual Basic
Public ReadOnly Property GUID As Guid
    Get
Visual C++
public:
property Guid GUID {
    Guid get ();
}

Examples

CopyC#
foreach (FamilyParameter familyParam in familyDoc.FamilyManager.Parameters)
{
    string familyParamName = familyParam.Definition.Name;
    try
    {
        Guid guid = familyParam.GUID;
        TaskDialog.Show("Revit",familyParamName + " is shared. Guid is " + guid);
    }
    catch (System.Exception)
    {
        TaskDialog.Show("Revit",familyParamName + " is NOT shared");
    }
}
CopyVB.NET
For Each familyParam As FamilyParameter In familyDoc.FamilyManager.Parameters
    Dim familyParamName As String = familyParam.Definition.Name
    Try
        Dim guid As Guid = familyParam.GUID
        TaskDialog.Show("Revit", familyParamName & " is shared. Guid is " & Convert.ToString(guid))
    Catch generatedExceptionName As System.Exception
        TaskDialog.Show("Revit", familyParamName & " is NOT shared")
    End Try

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the parameter is not a shared parameter.

See Also

FamilyParameter Class


Id Property

[image]

Revit 2024 API
FamilyParameter..::..Id Property
FamilyParameter Class See Also Send Feedback
The id of the family parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public ElementId Id { get; }
Visual Basic
Public ReadOnly Property Id As ElementId
    Get
Visual C++
public:
property ElementId^ Id {
    ElementId^ get ();
}

See Also

FamilyParameter Class


IsDeterminedByFormula Property

[image]

Revit 2024 API
FamilyParameter..::..IsDeterminedByFormula Property
FamilyParameter Class See Also Send Feedback
Indicates if the parameter is determined by formula.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsDeterminedByFormula { get; }
Visual Basic
Public ReadOnly Property IsDeterminedByFormula As Boolean
    Get
Visual C++
public:
property bool IsDeterminedByFormula {
    bool get ();
}

Remarks

The parameter is read only if it is determined by formula.

See Also

FamilyParameter Class


IsInstance Property

[image]

Revit 2024 API
FamilyParameter..::..IsInstance Property
FamilyParameter Class See Also Send Feedback
Indicates if the parameter is instance or type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsInstance { get; }
Visual Basic
Public ReadOnly Property IsInstance As Boolean
    Get
Visual C++
public:
property bool IsInstance {
    bool get ();
}

See Also

FamilyParameter Class


IsReadOnly Property

[image]

Revit 2024 API
FamilyParameter..::..IsReadOnly Property
FamilyParameter Class See Also Send Feedback
Identifies if the object is read-only or modifiable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public override bool IsReadOnly { get; }
Visual Basic
Public Overrides ReadOnly Property IsReadOnly As Boolean
    Get
Visual C++
public:
virtual property bool IsReadOnly {
    bool get () override;
}

Field Value

If true, the object may not be modified. If false, the object's contents may be modified.

See Also

FamilyParameter Class


IsReporting Property

[image]

Revit 2024 API
FamilyParameter..::..IsReporting Property
FamilyParameter Class See Also Send Feedback
Indicates if the parameter is a reporting parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool IsReporting { get; }
Visual Basic
Public ReadOnly Property IsReporting As Boolean
    Get
Visual C++
public:
property bool IsReporting {
    bool get ();
}

Remarks

If true, the parameter is a reporting parameter associated to a dimension value, and cannot be modified. If false, the parameter is a driving parameter and if associated to a dimension, can modify the dimension it labels.

See Also

FamilyParameter Class


IsShared Property

[image]

Revit 2024 API
FamilyParameter..::..IsShared Property
FamilyParameter Class See Also Send Feedback
Identifies if the parameter is a shared parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsShared { get; }
Visual Basic
Public ReadOnly Property IsShared As Boolean
    Get
Visual C++
public:
property bool IsShared {
    bool get ();
}

See Also

FamilyParameter Class


StorageType Property

[image]

Revit 2024 API
FamilyParameter..::..StorageType Property
FamilyParameter Class See Also Send Feedback
The storage type describes the type that is used internally within the parameter to store its value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public StorageType StorageType { get; }
Visual Basic
Public ReadOnly Property StorageType As StorageType
    Get
Visual C++
public:
property StorageType StorageType {
    StorageType get ();
}

Remarks

The property will return one of the following possibilities: String, Integer, Double or ElementId. Based on the value of this property the correct access and set methods should be used to retrieve and set the parameter's data value.

See Also

FamilyParameter Class


FamilyParameterSet Members

[image] [image]

Revit 2024 API
FamilyParameterSet Members
FamilyParameterSet Class Constructors Methods Properties See Also Send Feedback

The FamilyParameterSet type exposes the following members.

Constructors

 | Name | Description
Public method | FamilyParameterSet | Initializes a new instance of the FamilyParameterSet class

Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

FamilyParameterSet Class


FamilyParameterSet Constructor

[image]

Revit 2024 API
FamilyParameterSet Constructor
FamilyParameterSet Class See Also Send Feedback
Initializes a new instance of the FamilyParameterSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyParameterSet()
Visual Basic
Public Sub New
Visual C++
public:
FamilyParameterSet()

See Also

FamilyParameterSet Class


FamilyParameterSet Methods

[image] [image]

Revit 2024 API
FamilyParameterSet Methods
FamilyParameterSet Class See Also Send Feedback

The FamilyParameterSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FamilyParameterSet Class


Clear Method

[image]

Revit 2024 API
FamilyParameterSet..::..Clear Method
FamilyParameterSet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

FamilyParameterSet Class


Contains Method

[image]

Revit 2024 API
FamilyParameterSet..::..Contains Method
FamilyParameterSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool Contains(
    FamilyParameter item
)
Visual Basic
Public Overridable Function Contains ( _
    item As FamilyParameter _
) As Boolean
Visual C++
public:
virtual bool Contains(
    FamilyParameter^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..FamilyParameter

See Also

FamilyParameterSet Class


Erase Method

[image]

Revit 2024 API
FamilyParameterSet..::..Erase Method
FamilyParameterSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Erase(
    FamilyParameter item
)
Visual Basic
Public Overridable Function Erase ( _
    item As FamilyParameter _
) As Integer
Visual C++
public:
virtual int Erase(
    FamilyParameter^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..FamilyParameter

See Also

FamilyParameterSet Class


ForwardIterator Method

[image]

Revit 2024 API
FamilyParameterSet..::..ForwardIterator Method
FamilyParameterSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual FamilyParameterSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As FamilyParameterSetIterator
Visual C++
public:
virtual FamilyParameterSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

FamilyParameterSet Class


ReverseIterator Method

[image]

Revit 2024 API
FamilyParameterSet..::..ReverseIterator Method
FamilyParameterSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual FamilyParameterSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As FamilyParameterSetIterator
Visual C++
public:
virtual FamilyParameterSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

FamilyParameterSet Class


FamilyParameterSet Properties

[image] [image]

Revit 2024 API
FamilyParameterSet Properties
FamilyParameterSet Class See Also Send Feedback

The FamilyParameterSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

FamilyParameterSet Class


Size Property

[image]

Revit 2024 API
FamilyParameterSet..::..Size Property
FamilyParameterSet Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

FamilyParameterSet Class


FamilyParameterSetIterator Class

[image]

Revit 2024 API
FamilyParameterSetIterator Class
Members See Also Send Feedback
An iterator to a FamilyParameter set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public abstract class FamilyParameterSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class FamilyParameterSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class FamilyParameterSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..FamilyParameterSetIterator

See Also

FamilyParameterSetIterator Members


FamilyParameterSetIterator Members

[image] [image]

Revit 2024 API
FamilyParameterSetIterator Members
FamilyParameterSetIterator Class Constructors Methods Properties See Also Send Feedback

The FamilyParameterSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | FamilyParameterSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FamilyParameterSetIterator Class


FamilyParameterSetIterator Methods

[image] [image]

Revit 2024 API
FamilyParameterSetIterator Methods
FamilyParameterSetIterator Class See Also Send Feedback

The FamilyParameterSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FamilyParameterSetIterator Class


MoveNext Method

[image]

Revit 2024 API
FamilyParameterSetIterator..::..MoveNext Method
FamilyParameterSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

FamilyParameterSetIterator Class


Reset Method

[image]

Revit 2024 API
FamilyParameterSetIterator..::..Reset Method
FamilyParameterSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

FamilyParameterSetIterator Class


FamilyParameterSetIterator Properties

[image] [image]

Revit 2024 API
FamilyParameterSetIterator Properties
FamilyParameterSetIterator Class See Also Send Feedback

The FamilyParameterSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FamilyParameterSetIterator Class


FamilyPlacementType Enumeration

[image]

Revit 2024 API
FamilyPlacementType Enumeration
See Also Send Feedback
The type of placement required for a given family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public enum FamilyPlacementType
Visual Basic
Public Enumeration FamilyPlacementType
Visual C++
public enum class FamilyPlacementType

Members

Member name | Description
OneLevelBased | The family is placed referencing a single level.
OneLevelBasedHosted | The family is placed referencing a single level and host.
TwoLevelsBased | The family is placed referencing two levels (e.g. a column).
ViewBased | The family is view-specific (e.g. a detail annotation)
WorkPlaneBased | The family is placed on a work plane or face.
CurveBased | The family is based on a line and placed on a work plane.
CurveBasedDetail | The family is based on a line and place on a specific view (e.g. a detail component).
CurveDrivenStructural | The family is a structural curve driven member (beam, brace, or slanted column)
Adaptive | The family is an adaptive family.
Invalid | This signals an invalid value for the enum.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


FamilyPointLocation Class

[image]

Revit 2024 API
FamilyPointLocation Class
Members See Also Send Feedback
Data corresponding to the point locations in certain types of Family Symbols.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class FamilyPointLocation : APIObject
Visual Basic
Public Class FamilyPointLocation _
    Inherits APIObject
Visual C++
public ref class FamilyPointLocation : public APIObject

Remarks

Examples of FamilySymbol objects that contain placement references are Panels and Flexible Components.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..FamilyPointLocation

See Also

FamilyPointLocation Members


FamilyPointLocation Methods

[image] [image]

Revit 2024 API
FamilyPointLocation Methods
FamilyPointLocation Class See Also Send Feedback

The FamilyPointLocation type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLocation | Gets the location of the point.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FamilyPointLocation Class


GetLocation Method

[image]

Revit 2024 API
FamilyPointLocation..::..GetLocation Method
FamilyPointLocation Class See Also Send Feedback
Gets the location of the point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public Transform GetLocation()
Visual Basic
Public Function GetLocation As Transform
Visual C++
public:
Transform^ GetLocation()

Return Value

The location of the point.

See Also

FamilyPointLocation Class


FamilyPointLocation Properties

[image] [image]

Revit 2024 API
FamilyPointLocation Properties
FamilyPointLocation Class See Also Send Feedback

The FamilyPointLocation type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | The name of the corresponding reference point in the Family document.

See Also

FamilyPointLocation Class


IsValidObject Property

[image]

Revit 2024 API
FamilyPointLocation..::..IsValidObject Property
FamilyPointLocation Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

FamilyPointLocation Class


Name Property

[image]

Revit 2024 API
FamilyPointLocation..::..Name Property
FamilyPointLocation Class See Also Send Feedback
The name of the corresponding reference point in the Family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

FamilyPointLocation Class


FamilyPointPlacementReference Methods

[image] [image]

Revit 2024 API
FamilyPointPlacementReference Methods
FamilyPointPlacementReference Class See Also Send Feedback

The FamilyPointPlacementReference type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FamilyPointPlacementReference Class


FamilyPointPlacementReference Properties

[image] [image]

Revit 2024 API
FamilyPointPlacementReference Properties
FamilyPointPlacementReference Class See Also Send Feedback

The FamilyPointPlacementReference type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Location | The location of the point.
Public property | Name | The name of the corresponding reference point in the Family document.
Public property | PointReference | The reference on which the point depends on.

See Also

FamilyPointPlacementReference Class


Location Property

[image]

Revit 2024 API
FamilyPointPlacementReference..::..Location Property
FamilyPointPlacementReference Class See Also Send Feedback
The location of the point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Transform Location { get; }
Visual Basic
Public ReadOnly Property Location As Transform
    Get
Visual C++
public:
property Transform^ Location {
    Transform^ get ();
}

See Also

FamilyPointPlacementReference Class


Name Property

[image]

Revit 2024 API
FamilyPointPlacementReference..::..Name Property
FamilyPointPlacementReference Class See Also Send Feedback
The name of the corresponding reference point in the Family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

FamilyPointPlacementReference Class


PointReference Property

[image]

Revit 2024 API
FamilyPointPlacementReference..::..PointReference Property
FamilyPointPlacementReference Class See Also Send Feedback
The reference on which the point depends on.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Reference PointReference { get; }
Visual Basic
Public ReadOnly Property PointReference As Reference
    Get
Visual C++
public:
property Reference^ PointReference {
    Reference^ get ();
}

See Also

FamilyPointPlacementReference Class


FamilySizeTable Class

[image]

Revit 2024 API
FamilySizeTable Class
Members See Also Send Feedback
Contains size information for a family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class FamilySizeTable : IDisposable
Visual Basic
Public Class FamilySizeTable _
    Implements IDisposable
Visual C++
public ref class FamilySizeTable : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FamilySizeTable

See Also

FamilySizeTable Members


FamilySizeTable Methods

[image] [image]

Revit 2024 API
FamilySizeTable Methods
FamilySizeTable Class See Also Send Feedback

The FamilySizeTable type exposes the following members.

Methods

 | Name | Description
Public method | AsValueString | Gets the table cell value as a string.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetColumnHeader | Gets a column of the table at at given index.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidColumnIndex | Checks if the column index is valid.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FamilySizeTable Class


GetColumnHeader Method

[image]

Revit 2024 API
FamilySizeTable..::..GetColumnHeader Method
FamilySizeTable Class See Also Send Feedback
Gets a column of the table at at given index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public FamilySizeTableColumn GetColumnHeader(
    int index
)
Visual Basic
Public Function GetColumnHeader ( _
    index As Integer _
) As FamilySizeTableColumn
Visual C++
public:
FamilySizeTableColumn^ GetColumnHeader(
    int index
)

Parameters

index
Type: System..::..Int32
Index of the column.

Return Value

The column at the given index.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The column index is out of range.

See Also

FamilySizeTable Class


IsValidObject Property

[image]

Revit 2024 API
FamilySizeTable..::..IsValidObject Property
FamilySizeTable Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

FamilySizeTable Class


NumberOfColumns Property

[image]

Revit 2024 API
FamilySizeTable..::..NumberOfColumns Property
FamilySizeTable Class See Also Send Feedback
Number of columns in the table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public int NumberOfColumns { get; }
Visual Basic
Public ReadOnly Property NumberOfColumns As Integer
    Get
Visual C++
public:
property int NumberOfColumns {
    int get ();
}

See Also

FamilySizeTable Class


NumberOfRows Property

[image]

Revit 2024 API
FamilySizeTable..::..NumberOfRows Property
FamilySizeTable Class See Also Send Feedback
Number of rows in the table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public int NumberOfRows { get; }
Visual Basic
Public ReadOnly Property NumberOfRows As Integer
    Get
Visual C++
public:
property int NumberOfRows {
    int get ();
}

See Also

FamilySizeTable Class


FamilySizeTableColumn Class

[image]

Revit 2024 API
FamilySizeTableColumn Class
Members See Also Send Feedback
Contains column information for a FamilySizeTable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class FamilySizeTableColumn : IDisposable
Visual Basic
Public Class FamilySizeTableColumn _
    Implements IDisposable
Visual C++
public ref class FamilySizeTableColumn : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FamilySizeTableColumn

See Also

FamilySizeTableColumn Members


FamilySizeTableColumn Members

[image] [image]

Revit 2024 API
FamilySizeTableColumn Members
FamilySizeTableColumn Class Methods Properties See Also Send Feedback

The FamilySizeTableColumn type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FamilySizeTableColumn
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSpecTypeId | Gets the identifier of the spec describing values in the column.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUnitTypeId | Gets the identifier of the unit quantifying values in the column.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | The column name.

See Also

FamilySizeTableColumn Class


FamilySizeTableColumn Methods

[image] [image]

Revit 2024 API
FamilySizeTableColumn Methods
FamilySizeTableColumn Class See Also Send Feedback

The FamilySizeTableColumn type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSpecTypeId | Gets the identifier of the spec describing values in the column.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUnitTypeId | Gets the identifier of the unit quantifying values in the column.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FamilySizeTableColumn Class


Dispose Method

[image]

Revit 2024 API
FamilySizeTableColumn..::..Dispose Method
FamilySizeTableColumn Class See Also Send Feedback
Releases all resources used by the FamilySizeTableColumn

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FamilySizeTableColumn Class


GetUnitTypeId Method

[image]

Revit 2024 API
FamilySizeTableColumn..::..GetUnitTypeId Method
FamilySizeTableColumn Class See Also Send Feedback
Gets the identifier of the unit quantifying values in the column.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ForgeTypeId GetUnitTypeId()
Visual Basic
Public Function GetUnitTypeId As ForgeTypeId
Visual C++
public:
ForgeTypeId^ GetUnitTypeId()

Return Value

Identifier of the unit.

See Also

FamilySizeTableColumn Class


FamilySizeTableColumn Properties

[image] [image]

Revit 2024 API
FamilySizeTableColumn Properties
FamilySizeTableColumn Class See Also Send Feedback

The FamilySizeTableColumn type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | The column name.

See Also

FamilySizeTableColumn Class


IsValidObject Property

[image]

Revit 2024 API
FamilySizeTableColumn..::..IsValidObject Property
FamilySizeTableColumn Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

FamilySizeTableColumn Class


Name Property

[image]

Revit 2024 API
FamilySizeTableColumn..::..Name Property
FamilySizeTableColumn Class See Also Send Feedback
The column name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

FamilySizeTableColumn Class


FamilySizeTableErrorInfo Class

[image]

Revit 2024 API
FamilySizeTableErrorInfo Class
Members See Also Send Feedback
Error information generated from the CSV file import of a FamilySizeTable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class FamilySizeTableErrorInfo : IDisposable
Visual Basic
Public Class FamilySizeTableErrorInfo _
    Implements IDisposable
Visual C++
public ref class FamilySizeTableErrorInfo : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FamilySizeTableErrorInfo

See Also

FamilySizeTableErrorInfo Members


FamilySizeTableErrorInfo Members

[image] [image]

Revit 2024 API
FamilySizeTableErrorInfo Members
FamilySizeTableErrorInfo Class Constructors Methods Properties See Also Send Feedback

The FamilySizeTableErrorInfo type exposes the following members.

Constructors

 | Name | Description
Public method | FamilySizeTableErrorInfo | Constructs a new FamilySizeTableErrorInfo with default settings.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FamilySizeTableErrorInfo
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FamilySizeTableErrorType | The error type.
Public property | FilePath | The path of the imported CSV file.
Public property | InvalidColumnIndex | The index of the invalid column.
Public property | InvalidHeaderText | The invalid header text.
Public property | InvalidRowIndex | The index of the invalid row.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

FamilySizeTableErrorInfo Class


Dispose Method

[image]

Revit 2024 API
FamilySizeTableErrorInfo..::..Dispose Method
FamilySizeTableErrorInfo Class See Also Send Feedback
Releases all resources used by the FamilySizeTableErrorInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FamilySizeTableErrorInfo Class


FamilySizeTableErrorInfo Properties

[image] [image]

Revit 2024 API
FamilySizeTableErrorInfo Properties
FamilySizeTableErrorInfo Class See Also Send Feedback

The FamilySizeTableErrorInfo type exposes the following members.

Properties

 | Name | Description
Public property | FamilySizeTableErrorType | The error type.
Public property | FilePath | The path of the imported CSV file.
Public property | InvalidColumnIndex | The index of the invalid column.
Public property | InvalidHeaderText | The invalid header text.
Public property | InvalidRowIndex | The index of the invalid row.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

FamilySizeTableErrorInfo Class


FilePath Property

[image]

Revit 2024 API
FamilySizeTableErrorInfo..::..FilePath Property
FamilySizeTableErrorInfo Class See Also Send Feedback
The path of the imported CSV file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public string FilePath { get; }
Visual Basic
Public ReadOnly Property FilePath As String
    Get
Visual C++
public:
property String^ FilePath {
    String^ get ();
}

See Also

FamilySizeTableErrorInfo Class


InvalidColumnIndex Property

[image]

Revit 2024 API
FamilySizeTableErrorInfo..::..InvalidColumnIndex Property
FamilySizeTableErrorInfo Class See Also Send Feedback
The index of the invalid column.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public int InvalidColumnIndex { get; }
Visual Basic
Public ReadOnly Property InvalidColumnIndex As Integer
    Get
Visual C++
public:
property int InvalidColumnIndex {
    int get ();
}

See Also

FamilySizeTableErrorInfo Class


InvalidHeaderText Property

[image]

Revit 2024 API
FamilySizeTableErrorInfo..::..InvalidHeaderText Property
FamilySizeTableErrorInfo Class See Also Send Feedback
The invalid header text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public string InvalidHeaderText { get; }
Visual Basic
Public ReadOnly Property InvalidHeaderText As String
    Get
Visual C++
public:
property String^ InvalidHeaderText {
    String^ get ();
}

See Also

FamilySizeTableErrorInfo Class


IsValidObject Property

[image]

Revit 2024 API
FamilySizeTableErrorInfo..::..IsValidObject Property
FamilySizeTableErrorInfo Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

FamilySizeTableErrorInfo Class


FamilySizeTableManager Members

[image] [image]

Revit 2024 API
FamilySizeTableManager Members
FamilySizeTableManager Class Methods Properties See Also Send Feedback

The FamilySizeTableManager type exposes the following members.

Methods

 | Name | Description
 | CreateFamilySizeTableManager | Adds FamilySizeTableManager to a Family. A FamilySizeTableManager and FamilySizeTables are only needed when importing, exporting, or removing size data previously stored in CSV files.
Public method | Dispose | Releases all resources used by the FamilySizeTableManager
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExportSizeTable | Exports the size table to aCSV file.
Public method | GetAllSizeTableNames | Get the FamilySizeTable names in a family.
 | GetFamilySizeTableManager | Gets a FamilySizeTableManager from a Family
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSizeTable | Get a FamilySizeTable by name.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasSizeTable | Checks if a FamilySizeTable of a given name exists.
Public method | ImportSizeTable | Imports a FamilySizeTable from a CSV file.
Public method | RemoveSizeTable | Removes the FamilySizeTable of a given name.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | NumberOfSizeTables | The number of FamilySizeTables in a family.

See Also

FamilySizeTableManager Class


FamilySizeTableManager Methods

[image] [image]

Revit 2024 API
FamilySizeTableManager Methods
FamilySizeTableManager Class See Also Send Feedback

The FamilySizeTableManager type exposes the following members.

Methods

 | Name | Description
 | CreateFamilySizeTableManager | Adds FamilySizeTableManager to a Family. A FamilySizeTableManager and FamilySizeTables are only needed when importing, exporting, or removing size data previously stored in CSV files.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExportSizeTable | Exports the size table to aCSV file.
Public method | GetAllSizeTableNames | Get the FamilySizeTable names in a family.
 | GetFamilySizeTableManager | Gets a FamilySizeTableManager from a Family
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSizeTable | Get a FamilySizeTable by name.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasSizeTable | Checks if a FamilySizeTable of a given name exists.
Public method | ImportSizeTable | Imports a FamilySizeTable from a CSV file.
Public method | RemoveSizeTable | Removes the FamilySizeTable of a given name.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FamilySizeTableManager Class


CreateFamilySizeTableManager Method

[image]

Revit 2024 API
FamilySizeTableManager..::..CreateFamilySizeTableManager Method
FamilySizeTableManager Class See Also Send Feedback
Adds FamilySizeTableManager to a Family. A FamilySizeTableManager and FamilySizeTables are only needed when importing, exporting, or removing size data previously stored in CSV files.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static bool CreateFamilySizeTableManager(
    Document document,
    ElementId familyId
)
Visual Basic
Public Shared Function CreateFamilySizeTableManager ( _
    document As Document, _
    familyId As ElementId _
) As Boolean
Visual C++
public:
static bool CreateFamilySizeTableManager(
    Document^ document,
    ElementId^ familyId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Family owned document or project document.
familyId
Type: Autodesk.Revit.DB..::..ElementId
ElementId of the Family.

Return Value

True if successful, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FamilySizeTableManager Class


Dispose Method

[image]

Revit 2024 API
FamilySizeTableManager..::..Dispose Method
FamilySizeTableManager Class See Also Send Feedback
Releases all resources used by the FamilySizeTableManager

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FamilySizeTableManager Class


ExportSizeTable Method

[image]

Revit 2024 API
FamilySizeTableManager..::..ExportSizeTable Method
FamilySizeTableManager Class See Also Send Feedback
Exports the size table to aCSV file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool ExportSizeTable(
    string tableName,
    string filePath
)
Visual Basic
Public Function ExportSizeTable ( _
    tableName As String, _
    filePath As String _
) As Boolean
Visual C++
public:
bool ExportSizeTable(
    String^ tableName,
    String^ filePath
)

Parameters

tableName
Type: System..::..String
The bool name to export.
filePath
Type: System..::..String
The CSV file to export to.

Return Value

True if successful, false otherwise..

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FamilySizeTableManager Class


GetFamilySizeTableManager Method

[image]

Revit 2024 API
FamilySizeTableManager..::..GetFamilySizeTableManager Method
FamilySizeTableManager Class See Also Send Feedback
Gets a FamilySizeTableManager from a Family

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static FamilySizeTableManager GetFamilySizeTableManager(
    Document document,
    ElementId familyId
)
Visual Basic
Public Shared Function GetFamilySizeTableManager ( _
    document As Document, _
    familyId As ElementId _
) As FamilySizeTableManager
Visual C++
public:
static FamilySizeTableManager^ GetFamilySizeTableManager(
    Document^ document,
    ElementId^ familyId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Family owned document or a project document
familyId
Type: Autodesk.Revit.DB..::..ElementId
ElementId of the Family.

Return Value

The FamilySizeTableManager of the Family.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FamilySizeTableManager Class


HasSizeTable Method

[image]

Revit 2024 API
FamilySizeTableManager..::..HasSizeTable Method
FamilySizeTableManager Class See Also Send Feedback
Checks if a FamilySizeTable of a given name exists.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool HasSizeTable(
    string tableName
)
Visual Basic
Public Function HasSizeTable ( _
    tableName As String _
) As Boolean
Visual C++
public:
bool HasSizeTable(
    String^ tableName
)

Parameters

tableName
Type: System..::..String
The name of the FamilySizeTable.

Return Value

True if the FamilySizeTable exists, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FamilySizeTableManager Class


ImportSizeTable Method

[image]

Revit 2024 API
FamilySizeTableManager..::..ImportSizeTable Method
FamilySizeTableManager Class See Also Send Feedback
Imports a FamilySizeTable from a CSV file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool ImportSizeTable(
    Document document,
    string filePath,
    FamilySizeTableErrorInfo errorInfo
)
Visual Basic
Public Function ImportSizeTable ( _
    document As Document, _
    filePath As String, _
    errorInfo As FamilySizeTableErrorInfo _
) As Boolean
Visual C++
public:
bool ImportSizeTable(
    Document^ document,
    String^ filePath,
    FamilySizeTableErrorInfo^ errorInfo
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Family owned document or project document.
filePath
Type: System..::..String
The CSV file path.
errorInfo
Type: Autodesk.Revit.DB..::..FamilySizeTableErrorInfo
An error object to be written to if errors occur.

Return Value

True if successful, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FamilySizeTableManager Class


RemoveSizeTable Method

[image]

Revit 2024 API
FamilySizeTableManager..::..RemoveSizeTable Method
FamilySizeTableManager Class See Also Send Feedback
Removes the FamilySizeTable of a given name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool RemoveSizeTable(
    string tableName
)
Visual Basic
Public Function RemoveSizeTable ( _
    tableName As String _
) As Boolean
Visual C++
public:
bool RemoveSizeTable(
    String^ tableName
)

Parameters

tableName
Type: System..::..String
The FamilySizeTable name.

Return Value

True if successful, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FamilySizeTableManager Class


FamilySizeTableManager Properties

[image] [image]

Revit 2024 API
FamilySizeTableManager Properties
FamilySizeTableManager Class See Also Send Feedback

The FamilySizeTableManager type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | NumberOfSizeTables | The number of FamilySizeTables in a family.

See Also

FamilySizeTableManager Class


IsValidObject Property

[image]

Revit 2024 API
FamilySizeTableManager..::..IsValidObject Property
FamilySizeTableManager Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

FamilySizeTableManager Class


FamilySymbol Class

[image]

Revit 2024 API
FamilySymbol Class
Members Example See Also Send Feedback
An element that represents a single type with a Family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class FamilySymbol : InsertableObject
Visual Basic
Public Class FamilySymbol _
    Inherits InsertableObject
Visual C++
public ref class FamilySymbol : public InsertableObject

Remarks

Custom families within the Revit API represented by three objects - Family, FamilySymbol and FamilyInstance. Each object plays a significant part in the structure of families. The Family element represents the entire family that consists of a collection of types, such as an 'I Beam'. You can think of that object as representing the entire family file. The Family object contains a number of FamilySymbol elements. The FamilySymbol object represents a specific set of family settings within that Family and represents what is known in the Revit user interface as a Type, such as 'W14x32'. The FamilyInstance object represents an actual instance of that type placed the Autodesk Revit project. For example the FamilyInstance would be a single instance of a W14x32 column within the project.

Examples

CopyC#
public void GetInfo_FamilySymbol(FamilySymbol familySymbol)
{
    string message;
    // Get FamilySymbol family name
    message = "Family name is : " + familySymbol.Family.Name;

    // Get FamilySymbol material
    message += "\nFamilySymbol materials are :";
    foreach (ElementId matid in familySymbol.GetMaterialIds(true))
    {
       Material material = familySymbol.Document.GetElement(matid) as Material;
       if (null != material)
       {
          message += "\n" + material.Name;
       }
    }

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetInfo_FamilySymbol(familySymbol As FamilySymbol)
   Dim message As String
   ' Get FamilySymbol family name
   message = "Family name is : " & Convert.ToString(familySymbol.Family.Name)

   ' Get FamilySymbol material
   message += vbLf & "FamilySymbol materials are :"
   For Each matid As ElementId In familySymbol.GetMaterialIds(True)
      Dim material As Material = TryCast(familySymbol.Document.GetElement(matid), Material)
      If material IsNot Nothing Then
         message += vbLf + material.Name
      End If
   Next

   TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..InsertableObject
Autodesk.Revit.DB..::..FamilySymbol
Autodesk.Revit.DB..::..AnnotationSymbolType
Autodesk.Revit.DB.Architecture..::..RoomTagType
Autodesk.Revit.DB..::..AreaTagType
Autodesk.Revit.DB.Mechanical..::..SpaceTagType
Autodesk.Revit.DB..::..MullionType
Autodesk.Revit.DB..::..PanelType
Autodesk.Revit.DB.Structure..::..TrussType

See Also

FamilySymbol Members


FamilySymbol Members

[image] [image]

Revit 2024 API
FamilySymbol Members
FamilySymbol Class Methods Properties See Also Send Feedback

The FamilySymbol type exposes the following members.

Methods

 | Name | Description
Public method | Activate | Activates the symbol to ensure that its geometry is accessible.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveStructuralSection | Identifies if this FamilySymbol can have a structural section.
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetFamilyPointLocations | Returns the Point Locations for the Family Symbol.
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetStructuralSection | Gets the structural section from element.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetThermalProperties | Gets the thermal properties for the given FamilySymbol.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasThermalProperties | Identifies if this FamilySymbol can include thermal properties.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetStructuralSection | Sets the structural section in element.
Public method | SetThermalProperties | Sets the thermal properties for the given FamilySymbol.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Family | The Family object to which the symbol belongs.
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsActive | Identifies whether the symbol is active.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | StructuralMaterialType | This property returns the physical material from which the type is made.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FamilySymbol Class


Activate Method

[image]

Revit 2024 API
FamilySymbol..::..Activate Method
FamilySymbol Class See Also Send Feedback
Activates the symbol to ensure that its geometry is accessible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void Activate()
Visual Basic
Public Sub Activate
Visual C++
public:
void Activate()

Remarks

Symbols that are not used in the document may be deactivated to conserve memory and regeneration time. When the symbol is inactive, its geometry is empty and should not be accessed. In order to access geometry of a symbol that is not active in the document, first check its IsActive property. Note that until the document is regenerated, the newly activated symbol's geometry will still be empty.

See Also

FamilySymbol Class


GetFamilyPointLocations Method

[image]

Revit 2024 API
FamilySymbol..::..GetFamilyPointLocations Method
FamilySymbol Class See Also Send Feedback
Returns the Point Locations for the Family Symbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public IList<FamilyPointLocation> GetFamilyPointLocations()
Visual Basic
Public Function GetFamilyPointLocations As IList(Of FamilyPointLocation)
Visual C++
public:
IList<FamilyPointLocation^>^ GetFamilyPointLocations()

Remarks

If a family symbol has point references then their locations are returned by this method, otherwise an empty collection is returned. Examples of FamilySymbol objects that contain point location are Panels and Flexible Components.

See Also

FamilySymbol Class


GetStructuralSection Method

[image]

Revit 2024 API
FamilySymbol..::..GetStructuralSection Method
FamilySymbol Class See Also Send Feedback
Gets the structural section from element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public StructuralSection GetStructuralSection()
Visual Basic
Public Function GetStructuralSection As StructuralSection
Visual C++
public:
StructuralSection^ GetStructuralSection()

Return Value

The structural section. nullNothingnullptra null reference (Nothing in Visual Basic) if the family symbol does not contain a structural section.

Remarks

Only beams, braces and structural columns can have a structural section. To check if the element can have structural section use the [!:Family.HasStructuralSection()] method.

See Also

FamilySymbol Class


SetStructuralSection Method

[image]

Revit 2024 API
FamilySymbol..::..SetStructuralSection Method
FamilySymbol Class See Also Send Feedback
Sets the structural section in element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public void SetStructuralSection(
    StructuralSection structuralSection
)
Visual Basic
Public Sub SetStructuralSection ( _
    structuralSection As StructuralSection _
)
Visual C++
public:
void SetStructuralSection(
    StructuralSection^ structuralSection
)

Parameters

structuralSection
Type: Autodesk.Revit.DB.Structure.StructuralSections..::..StructuralSection
Structural section with values that will be set.

Remarks

Only beams, braces and structural columns can have a structural section. To check if the element can have structural section use the [!:Family.HasStructuralSection()] method.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FamilySymbol cannot have a structural section.

See Also

FamilySymbol Class


SetThermalProperties Method

[image]

Revit 2024 API
FamilySymbol..::..SetThermalProperties Method
FamilySymbol Class See Also Send Feedback
Sets the thermal properties for the given FamilySymbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void SetThermalProperties(
    FamilyThermalProperties thermalProperties
)
Visual Basic
Public Sub SetThermalProperties ( _
    thermalProperties As FamilyThermalProperties _
)
Visual C++
public:
void SetThermalProperties(
    FamilyThermalProperties^ thermalProperties
)

Parameters

thermalProperties
Type: Autodesk.Revit.DB..::..FamilyThermalProperties
The new thermal properties. If nullNothingnullptra null reference (Nothing in Visual Basic), this unsets custom thermal properties for this FamilySymbol.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The thermal properties are not valid for assignment.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FamilySymbol does not contain thermal properties.

See Also

FamilySymbol Class


FamilySymbol Properties

[image] [image]

Revit 2024 API
FamilySymbol Properties
FamilySymbol Class See Also Send Feedback

The FamilySymbol type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Family | The Family object to which the symbol belongs.
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsActive | Identifies whether the symbol is active.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | StructuralMaterialType | This property returns the physical material from which the type is made.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FamilySymbol Class


Family Property

[image]

Revit 2024 API
FamilySymbol..::..Family Property
FamilySymbol Class See Also Send Feedback
The Family object to which the symbol belongs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Family Family { get; }
Visual Basic
Public ReadOnly Property Family As Family
    Get
Visual C++
public:
property Family^ Family {
    Family^ get ();
}

See Also

FamilySymbol Class


IsActive Property

[image]

Revit 2024 API
FamilySymbol..::..IsActive Property
FamilySymbol Class See Also Send Feedback
Identifies whether the symbol is active.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsActive { get; }
Visual Basic
Public ReadOnly Property IsActive As Boolean
    Get
Visual C++
public:
property bool IsActive {
    bool get ();
}

Remarks

Symbols that are not used in the document may be deactivated to conserve memory and regeneration time. When the symbol is inactive, its geometry is empty and cannot be accessed. In order to access the geometry of a symbol that is not active in the document, the symbol should first be activated by calling Activate()()()().

See Also

FamilySymbol Class


FamilySymbolFilter Class

[image]

Revit 2024 API
FamilySymbolFilter Class
Members See Also Send Feedback
A filter used to find all family symbols of the given family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class FamilySymbolFilter : ElementQuickFilter
Visual Basic
Public Class FamilySymbolFilter _
    Inherits ElementQuickFilter
Visual C++
public ref class FamilySymbolFilter : public ElementQuickFilter

Remarks

This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.

Note that it may be faster to get a list of symbol ids from GetFamilySymbolIds()()()() rather than to iterate all of the contents of a document with this filter applied.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementQuickFilter
Autodesk.Revit.DB..::..FamilySymbolFilter

See Also

FamilySymbolFilter Members


FamilySymbolFilter Members

[image] [image]

Revit 2024 API
FamilySymbolFilter Members
FamilySymbolFilter Class Constructors Methods Properties See Also Send Feedback

The FamilySymbolFilter type exposes the following members.

Constructors

 | Name | Description
Public method | FamilySymbolFilter | Constructs a new instance of a filter to find all family symbols of the given family.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FamilyId | The family id.
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)

See Also

FamilySymbolFilter Class


FamilySymbolFilter Constructor

[image]

Revit 2024 API
FamilySymbolFilter Constructor
FamilySymbolFilter Class See Also Send Feedback
Constructs a new instance of a filter to find all family symbols of the given family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FamilySymbolFilter(
    ElementId familyId
)
Visual Basic
Public Sub New ( _
    familyId As ElementId _
)
Visual C++
public:
FamilySymbolFilter(
    ElementId^ familyId
)

Parameters

familyId
Type: Autodesk.Revit.DB..::..ElementId
The family id.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The familyId is invalid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FamilySymbolFilter Class


FamilySymbolFilter Methods

[image] [image]

Revit 2024 API
FamilySymbolFilter Methods
FamilySymbolFilter Class See Also Send Feedback

The FamilySymbolFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FamilySymbolFilter Class


FamilySymbolFilter Properties

[image] [image]

Revit 2024 API
FamilySymbolFilter Properties
FamilySymbolFilter Class See Also Send Feedback

The FamilySymbolFilter type exposes the following members.

Properties

 | Name | Description
Public property | FamilyId | The family id.
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)

See Also

FamilySymbolFilter Class


FamilyId Property

[image]

Revit 2024 API
FamilySymbolFilter..::..FamilyId Property
FamilySymbolFilter Class See Also Send Feedback
The family id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public ElementId FamilyId { get; }
Visual Basic
Public ReadOnly Property FamilyId As ElementId
    Get
Visual C++
public:
property ElementId^ FamilyId {
    ElementId^ get ();
}

See Also

FamilySymbolFilter Class


FamilySymbolProfile Class

[image]

Revit 2024 API
FamilySymbolProfile Class
Members See Also Send Feedback
Represents a family symbol based profile for sweep or swept blend elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class FamilySymbolProfile : SweepProfile
Visual Basic
Public Class FamilySymbolProfile _
    Inherits SweepProfile
Visual C++
public ref class FamilySymbolProfile : public SweepProfile

Remarks

Use objects of this type in methods as NewSweep() and NewSweptBlend() in FamilyItemFactory to create the profile.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..SweepProfile
Autodesk.Revit.DB..::..FamilySymbolProfile

See Also

FamilySymbolProfile Members


FamilySymbolProfile Members

[image] [image]

Revit 2024 API
FamilySymbolProfile Members
FamilySymbolProfile Class Methods Properties See Also Send Feedback

The FamilySymbolProfile type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Angle | The angle of the rotation of the profile in radians.
Public property | IsFlipped | Indicates if the symbol profile is flipped or not.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Profile | Returns the family symbol of the profile.
Public property | XOffset | The offset of the profile to the origin of the sketch plane in the X direction.
Public property | YOffset | The offset of the profile to the origin of the sketch plane in the Y direction.

See Also

FamilySymbolProfile Class


FamilySymbolProfile Methods

[image] [image]

Revit 2024 API
FamilySymbolProfile Methods
FamilySymbolProfile Class See Also Send Feedback

The FamilySymbolProfile type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FamilySymbolProfile Class


Angle Property

[image]

Revit 2024 API
FamilySymbolProfile..::..Angle Property
FamilySymbolProfile Class See Also Send Feedback
The angle of the rotation of the profile in radians.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double Angle { get; set; }
Visual Basic
Public Property Angle As Double
    Get
    Set
Visual C++
public:
property double Angle {
    double get ();
    void set (double value);
}

See Also

FamilySymbolProfile Class


IsFlipped Property

[image]

Revit 2024 API
FamilySymbolProfile..::..IsFlipped Property
FamilySymbolProfile Class See Also Send Feedback
Indicates if the symbol profile is flipped or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsFlipped { get; set; }
Visual Basic
Public Property IsFlipped As Boolean
    Get
    Set
Visual C++
public:
property bool IsFlipped {
    bool get ();
    void set (bool value);
}

See Also

FamilySymbolProfile Class


Profile Property

[image]

Revit 2024 API
FamilySymbolProfile..::..Profile Property
FamilySymbolProfile Class See Also Send Feedback
Returns the family symbol of the profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilySymbol Profile { get; set; }
Visual Basic
Public Property Profile As FamilySymbol
    Get
    Set
Visual C++
public:
property FamilySymbol^ Profile {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}

Remarks

The symbol must of the category BuiltInCategory.OST_ProfileFamilies.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the category of argument is not BuiltInCategory.OST_ProfileFamilies.

See Also

FamilySymbolProfile Class


XOffset Property

[image]

Revit 2024 API
FamilySymbolProfile..::..XOffset Property
FamilySymbolProfile Class See Also Send Feedback
The offset of the profile to the origin of the sketch plane in the X direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double XOffset { get; set; }
Visual Basic
Public Property XOffset As Double
    Get
    Set
Visual C++
public:
property double XOffset {
    double get ();
    void set (double value);
}

See Also

FamilySymbolProfile Class


YOffset Property

[image]

Revit 2024 API
FamilySymbolProfile..::..YOffset Property
FamilySymbolProfile Class See Also Send Feedback
The offset of the profile to the origin of the sketch plane in the Y direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double YOffset { get; set; }
Visual Basic
Public Property YOffset As Double
    Get
    Set
Visual C++
public:
property double YOffset {
    double get ();
    void set (double value);
}

See Also

FamilySymbolProfile Class


FamilyThermalProperties Class

[image]

Revit 2024 API
FamilyThermalProperties Class
Members See Also Send Feedback
A class that contains thermal properties for specific types of families (doors, windows, and curtain wall panels).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public class FamilyThermalProperties : IDisposable
Visual Basic
Public Class FamilyThermalProperties _
    Implements IDisposable
Visual C++
public ref class FamilyThermalProperties : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FamilyThermalProperties

See Also

FamilyThermalProperties Members


FamilyThermalProperties Members

[image] [image]

Revit 2024 API
FamilyThermalProperties Members
FamilyThermalProperties Class Constructors Methods Properties See Also Send Feedback

The FamilyThermalProperties type exposes the following members.

Constructors

 | Name | Description
Public method | FamilyThermalProperties | Constructs a new FamilyThermalProperties with default settings.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FamilyThermalProperties
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Find | Finds the thermal properties by the 'id' property of a constructionType node in Constructions.xml.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid | Confirms that the thermal properties are correctly set for assignment to a FamilySymbol.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AnalyticConstructionName | The construction gbXML name. This value corresponds to the 'Name' property of a constructionType node in Constructions.xml.
Public property | AnalyticConstructionTypeId | The construction gbXML type. This value corresponds to the 'id' property of a constructionType node in Constructions.xml.
Public property | HeatTransferCoefficient | The heat transfer coefficient value (U-Value). The units are watts per meter-squared kelvin (W/(m^2*K)).
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SolarHeatGainCoefficient | The solar heat gain coefficient.
Public property | ThermalResistance | The calculated thermal resistance value (R-Value). The units are meter-squared kelvin per watt ((m^2*K)/Watt).
Public property | VisualLightTransmittance | The visual light transmittance.

See Also

FamilyThermalProperties Class


FamilyThermalProperties Methods

[image] [image]

Revit 2024 API
FamilyThermalProperties Methods
FamilyThermalProperties Class See Also Send Feedback

The FamilyThermalProperties type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Find | Finds the thermal properties by the 'id' property of a constructionType node in Constructions.xml.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid | Confirms that the thermal properties are correctly set for assignment to a FamilySymbol.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FamilyThermalProperties Class


Dispose Method

[image]

Revit 2024 API
FamilyThermalProperties..::..Dispose Method
FamilyThermalProperties Class See Also Send Feedback
Releases all resources used by the FamilyThermalProperties

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FamilyThermalProperties Class


Find Method

[image]

Revit 2024 API
FamilyThermalProperties..::..Find Method
FamilyThermalProperties Class See Also Send Feedback
Finds the thermal properties by the 'id' property of a constructionType node in Constructions.xml.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static FamilyThermalProperties Find(
    Document pADoc,
    string constructionId
)
Visual Basic
Public Shared Function Find ( _
    pADoc As Document, _
    constructionId As String _
) As FamilyThermalProperties
Visual C++
public:
static FamilyThermalProperties^ Find(
    Document^ pADoc,
    String^ constructionId
)

Parameters

pADoc
Type: Autodesk.Revit.DB..::..Document
The document.
constructionId
Type: System..::..String
The 'id' property of a constructionType node in Constructions.xml

Return Value

The thermal properties found, or nullNothingnullptra null reference (Nothing in Visual Basic) if no match was found.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FamilyThermalProperties Class


IsValid Method

[image]

Revit 2024 API
FamilyThermalProperties..::..IsValid Method
FamilyThermalProperties Class See Also Send Feedback
Confirms that the thermal properties are correctly set for assignment to a FamilySymbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool IsValid()
Visual Basic
Public Function IsValid As Boolean
Visual C++
public:
bool IsValid()

Return Value

True if the thermal properties are valid, false otherwise.

See Also

FamilyThermalProperties Class


FamilyThermalProperties Properties

[image] [image]

Revit 2024 API
FamilyThermalProperties Properties
FamilyThermalProperties Class See Also Send Feedback

The FamilyThermalProperties type exposes the following members.

Properties

 | Name | Description
Public property | AnalyticConstructionName | The construction gbXML name. This value corresponds to the 'Name' property of a constructionType node in Constructions.xml.
Public property | AnalyticConstructionTypeId | The construction gbXML type. This value corresponds to the 'id' property of a constructionType node in Constructions.xml.
Public property | HeatTransferCoefficient | The heat transfer coefficient value (U-Value). The units are watts per meter-squared kelvin (W/(m^2*K)).
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SolarHeatGainCoefficient | The solar heat gain coefficient.
Public property | ThermalResistance | The calculated thermal resistance value (R-Value). The units are meter-squared kelvin per watt ((m^2*K)/Watt).
Public property | VisualLightTransmittance | The visual light transmittance.

See Also

FamilyThermalProperties Class


AnalyticConstructionName Property

[image]

Revit 2024 API
FamilyThermalProperties..::..AnalyticConstructionName Property
FamilyThermalProperties Class See Also Send Feedback
The construction gbXML name. This value corresponds to the 'Name' property of a constructionType node in Constructions.xml.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public string AnalyticConstructionName { get; }
Visual Basic
Public ReadOnly Property AnalyticConstructionName As String
    Get
Visual C++
public:
property String^ AnalyticConstructionName {
    String^ get ();
}

See Also

FamilyThermalProperties Class


HeatTransferCoefficient Property

[image]

Revit 2024 API
FamilyThermalProperties..::..HeatTransferCoefficient Property
FamilyThermalProperties Class See Also Send Feedback
The heat transfer coefficient value (U-Value). The units are watts per meter-squared kelvin (W/(m^2*K)).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double HeatTransferCoefficient { get; }
Visual Basic
Public ReadOnly Property HeatTransferCoefficient As Double
    Get
Visual C++
public:
property double HeatTransferCoefficient {
    double get ();
}

See Also

FamilyThermalProperties Class


IsValidObject Property

[image]

Revit 2024 API
FamilyThermalProperties..::..IsValidObject Property
FamilyThermalProperties Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

FamilyThermalProperties Class


SolarHeatGainCoefficient Property

[image]

Revit 2024 API
FamilyThermalProperties..::..SolarHeatGainCoefficient Property
FamilyThermalProperties Class See Also Send Feedback
The solar heat gain coefficient.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double SolarHeatGainCoefficient { get; }
Visual Basic
Public ReadOnly Property SolarHeatGainCoefficient As Double
    Get
Visual C++
public:
property double SolarHeatGainCoefficient {
    double get ();
}

See Also

FamilyThermalProperties Class


VisualLightTransmittance Property

[image]

Revit 2024 API
FamilyThermalProperties..::..VisualLightTransmittance Property
FamilyThermalProperties Class See Also Send Feedback
The visual light transmittance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double VisualLightTransmittance { get; }
Visual Basic
Public ReadOnly Property VisualLightTransmittance As Double
    Get
Visual C++
public:
property double VisualLightTransmittance {
    double get ();
}

See Also

FamilyThermalProperties Class


FamilyType Class

[image]

Revit 2024 API
FamilyType Class
Members See Also Send Feedback
The family type object provides read access to the values of family parameters for this type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class FamilyType : APIObject
Visual Basic
Public Class FamilyType _
    Inherits APIObject
Visual C++
public ref class FamilyType : public APIObject

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..FamilyType

See Also

FamilyType Members


FamilyType Methods

[image] [image]

Revit 2024 API
FamilyType Methods
FamilyType Class See Also Send Feedback

The FamilyType type exposes the following members.

Methods

 | Name | Description
Public method | AsDouble | Provides access to the double precision number of the given family parameter.
Public method | AsElementId | Provides access to the Autodesk::Revit::DB::ElementId^ stored in the given family parameter.
Public method | AsInteger | Provides access to the integer number of the given family parameter.
Public method | AsString | Provides access to the string contents of the given family parameter.
Public method | AsValueString | Provides access to value as a string with unit in the given family parameter.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasValue | Indicates if this family parameter has an assigned value or not.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FamilyType Class


AsDouble Method

[image]

Revit 2024 API
FamilyType..::..AsDouble Method
FamilyType Class See Also Send Feedback
Provides access to the double precision number of the given family parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Nullable<double> AsDouble(
    FamilyParameter familyParameter
)
Visual Basic
Public Function AsDouble ( _
    familyParameter As FamilyParameter _
) As Nullable(Of Double)
Visual C++
public:
Nullable<double> AsDouble(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::..FamilyParameter

Return Value

The double value contained in the parameter. Returns nullNothingnullptra null reference (Nothing in Visual Basic) if the storage type of the input argument is not double type or this parameter has no value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"familyParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the input argument-"familyParameter"-is invalid,

See Also

FamilyType Class


AsElementId Method

[image]

Revit 2024 API
FamilyType..::..AsElementId Method
FamilyType Class See Also Send Feedback
Provides access to the Autodesk::Revit::DB::ElementId^ stored in the given family parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElementId AsElementId(
    FamilyParameter familyParameter
)
Visual Basic
Public Function AsElementId ( _
    familyParameter As FamilyParameter _
) As ElementId
Visual C++
public:
ElementId^ AsElementId(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::..FamilyParameter

Return Value

The Autodesk::Revit::DB::ElementId^ contained in the parameter.Returns an invalid element id if the storage type of the input argument is Autodesk::Revit::DB::ElementId^ type or this parameter has no value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"familyParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the input argument-"familyParameter"-is invalid,

See Also

FamilyType Class


AsString Method

[image]

Revit 2024 API
FamilyType..::..AsString Method
FamilyType Class See Also Send Feedback
Provides access to the string contents of the given family parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string AsString(
    FamilyParameter familyParameter
)
Visual Basic
Public Function AsString ( _
    familyParameter As FamilyParameter _
) As String
Visual C++
public:
String^ AsString(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::..FamilyParameter

Return Value

The string contained in the parameter. Returns nullNothingnullptra null reference (Nothing in Visual Basic) if the storage type of the input argument is not string type or this parameter has no value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"familyParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the input argument-"familyParameter"-is invalid,

See Also

FamilyType Class


AsValueString Method

[image]

Revit 2024 API
FamilyType..::..AsValueString Method
FamilyType Class See Also Send Feedback
Provides access to value as a string with unit in the given family parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string AsValueString(
    FamilyParameter familyParameter
)
Visual Basic
Public Function AsValueString ( _
    familyParameter As FamilyParameter _
) As String
Visual C++
public:
String^ AsValueString(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::..FamilyParameter

Return Value

The string that represents the parameter value with unit.

Remarks

The method only applies to parameters of value types. If the parameter has no value or does not contain a numeric value, the method returns nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"familyParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the input argument-"familyParameter"-is invalid.

See Also

FamilyType Class


HasValue Method

[image]

Revit 2024 API
FamilyType..::..HasValue Method
FamilyType Class See Also Send Feedback
Indicates if this family parameter has an assigned value or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool HasValue(
    FamilyParameter familyParameter
)
Visual Basic
Public Function HasValue ( _
    familyParameter As FamilyParameter _
) As Boolean
Visual C++
public:
bool HasValue(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::..FamilyParameter

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"familyParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the input argument-"familyParameter"-is invalid.

See Also

FamilyType Class


FamilyType Properties

[image] [image]

Revit 2024 API
FamilyType Properties
FamilyType Class See Also Send Feedback

The FamilyType type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | The name of the family type.

See Also

FamilyType Class


Name Property

[image]

Revit 2024 API
FamilyType..::..Name Property
FamilyType Class See Also Send Feedback
The name of the family type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

FamilyType Class


FamilyTypeSet Class

[image]

Revit 2024 API
FamilyTypeSet Class
Members See Also Send Feedback
A set that contains FamilyType objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class FamilyTypeSet : APIObject,
    IEnumerable
Visual Basic
Public Class FamilyTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class FamilyTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..FamilyTypeSet

See Also

FamilyTypeSet Members


FamilyTypeSet Methods

[image] [image]

Revit 2024 API
FamilyTypeSet Methods
FamilyTypeSet Class See Also Send Feedback

The FamilyTypeSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FamilyTypeSet Class


Clear Method

[image]

Revit 2024 API
FamilyTypeSet..::..Clear Method
FamilyTypeSet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

FamilyTypeSet Class


Contains Method

[image]

Revit 2024 API
FamilyTypeSet..::..Contains Method
FamilyTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool Contains(
    FamilyType item
)
Visual Basic
Public Overridable Function Contains ( _
    item As FamilyType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    FamilyType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..FamilyType

See Also

FamilyTypeSet Class


Erase Method

[image]

Revit 2024 API
FamilyTypeSet..::..Erase Method
FamilyTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Erase(
    FamilyType item
)
Visual Basic
Public Overridable Function Erase ( _
    item As FamilyType _
) As Integer
Visual C++
public:
virtual int Erase(
    FamilyType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..FamilyType

See Also

FamilyTypeSet Class


GetEnumerator Method

[image]

Revit 2024 API
FamilyTypeSet..::..GetEnumerator Method
FamilyTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

FamilyTypeSet Class


Insert Method

[image]

Revit 2024 API
FamilyTypeSet..::..Insert Method
FamilyTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool Insert(
    FamilyType item
)
Visual Basic
Public Overridable Function Insert ( _
    item As FamilyType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    FamilyType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..FamilyType

See Also

FamilyTypeSet Class


ReverseIterator Method

[image]

Revit 2024 API
FamilyTypeSet..::..ReverseIterator Method
FamilyTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual FamilyTypeSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As FamilyTypeSetIterator
Visual C++
public:
virtual FamilyTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

FamilyTypeSet Class


IsEmpty Property

[image]

Revit 2024 API
FamilyTypeSet..::..IsEmpty Property
FamilyTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

FamilyTypeSet Class


FamilyTypeSetIterator Class

[image]

Revit 2024 API
FamilyTypeSetIterator Class
Members See Also Send Feedback
An iterator to a FamilyType set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public abstract class FamilyTypeSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class FamilyTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class FamilyTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..FamilyTypeSetIterator

See Also

FamilyTypeSetIterator Members


FamilyTypeSetIterator Members

[image] [image]

Revit 2024 API
FamilyTypeSetIterator Members
FamilyTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The FamilyTypeSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | FamilyTypeSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FamilyTypeSetIterator Class


FamilyTypeSetIterator Constructor

[image]

Revit 2024 API
FamilyTypeSetIterator Constructor
FamilyTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyTypeSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
FamilyTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FamilyTypeSetIterator Class


FamilyTypeSetIterator Methods

[image] [image]

Revit 2024 API
FamilyTypeSetIterator Methods
FamilyTypeSetIterator Class See Also Send Feedback

The FamilyTypeSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FamilyTypeSetIterator Class


Reset Method

[image]

Revit 2024 API
FamilyTypeSetIterator..::..Reset Method
FamilyTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

FamilyTypeSetIterator Class


FamilyTypeSetIterator Properties

[image] [image]

Revit 2024 API
FamilyTypeSetIterator Properties
FamilyTypeSetIterator Class See Also Send Feedback

The FamilyTypeSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FamilyTypeSetIterator Class


Current Property

[image]

Revit 2024 API
FamilyTypeSetIterator..::..Current Property
FamilyTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

FamilyTypeSetIterator Class


FamilyUtils Class

[image]

Revit 2024 API
FamilyUtils Class
Members See Also Send Feedback
Contains utilities related to family operations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class FamilyUtils
Visual Basic
Public NotInheritable Class FamilyUtils
Visual C++
public ref class FamilyUtils abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FamilyUtils

See Also

FamilyUtils Members


FamilyUtils Methods

[image] [image]

Revit 2024 API
FamilyUtils Methods
FamilyUtils Class See Also Send Feedback

The FamilyUtils type exposes the following members.

Methods

Name | Description
ConvertFamilyToFaceHostBased | Converts a family to be face host based.
FamilyCanConvertToFaceHostBased | Indicates whether the family can be converted to face host based.
GetProfileSymbols | Gets the profile Family Symbols of the document.

See Also

FamilyUtils Class


ConvertFamilyToFaceHostBased Method

[image]

Revit 2024 API
FamilyUtils..::..ConvertFamilyToFaceHostBased Method
FamilyUtils Class See Also Send Feedback
Converts a family to be face host based.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static void ConvertFamilyToFaceHostBased(
    Document document,
    ElementId familyId
)
Visual Basic
Public Shared Sub ConvertFamilyToFaceHostBased ( _
    document As Document, _
    familyId As ElementId _
)
Visual C++
public:
static void ConvertFamilyToFaceHostBased(
    Document^ document,
    ElementId^ familyId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document containing the family to be converted.
familyId
Type: Autodesk.Revit.DB..::..ElementId
The family id.

Remarks

Converts a family hosted by some element other than a face to be hosted by a face. This is done by replacing the existing host (wall, roof, ceiling, floor) with a face. Conversion can succeed only if FamilyUtils.FamilyCanConvertToFaceHostBased() returns true.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input familyId cannot be converted to face host based.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | Failed to convert the family to face host based. -or- The family is already unhosted.

See Also

FamilyUtils Class


FamilyCanConvertToFaceHostBased Method

[image]

Revit 2024 API
FamilyUtils..::..FamilyCanConvertToFaceHostBased Method
FamilyUtils Class See Also Send Feedback
Indicates whether the family can be converted to face host based.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static bool FamilyCanConvertToFaceHostBased(
    Document document,
    ElementId familyId
)
Visual Basic
Public Shared Function FamilyCanConvertToFaceHostBased ( _
    document As Document, _
    familyId As ElementId _
) As Boolean
Visual C++
public:
static bool FamilyCanConvertToFaceHostBased(
    Document^ document,
    ElementId^ familyId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
familyId
Type: Autodesk.Revit.DB..::..ElementId
The element id of the family.

Return Value

True if the family can be converted to face-based. Otherwise false, which will be returned if there any family instances exist in the project, the family is already face-based, or the family does not have a host. Also, false is returned if the family does not belong to one of the following categories:
  • OST_CommunicationDevices
  • OST_DataDevices
  • OST_DuctTerminal
  • OST_ElectricalEquipment
  • OST_ElectricalFixtures
  • OST_FireAlarmDevices
  • OST_LightingDevices
  • OST_LightingFixtures
  • OST_MechanicalControlDevices
  • OST_MechanicalEquipment
  • OST_NurseCallDevices
  • OST_PlumbingEquipment
  • OST_PlumbingFixtures
  • OST_SecurityDevices
  • OST_Sprinklers
  • OST_TelephoneDevices

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FamilyUtils Class


GetProfileSymbols Method

[image]

Revit 2024 API
FamilyUtils..::..GetProfileSymbols Method
FamilyUtils Class See Also Send Feedback
Gets the profile Family Symbols of the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static ICollection<ElementId> GetProfileSymbols(
    Document document,
    ProfileFamilyUsage profileFamilyUsage,
    bool oneCurveLoopOnly
)
Visual Basic
Public Shared Function GetProfileSymbols ( _
    document As Document, _
    profileFamilyUsage As ProfileFamilyUsage, _
    oneCurveLoopOnly As Boolean _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetProfileSymbols(
    Document^ document,
    ProfileFamilyUsage profileFamilyUsage,
    bool oneCurveLoopOnly
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
profileFamilyUsage
Type: Autodesk.Revit.DB..::..ProfileFamilyUsage
The profile family usage.
oneCurveLoopOnly
Type: System..::..Boolean
Whether or not to return only profiles with one curve loop.

Return Value

The set of profile Family Symbol element ids.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

FamilyUtils Class


FBXExportOptions Members

[image] [image]

Revit 2024 API
FBXExportOptions Members
FBXExportOptions Class Constructors Methods Properties See Also Send Feedback

The FBXExportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | FBXExportOptions | Default constructor. Sets all options to their default values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | LevelsOfDetailValue | The value of the levels of detail.
Public property | StopOnError | Whether export process should stop when a view fails to export.
Public property | UseLevelsOfDetail | True to use levels of detail, false otherwise.
Public property | WithoutBoundaryEdges | True to export without boundary edges, false otherwise.

See Also

FBXExportOptions Class


FBXExportOptions Constructor

[image]

Revit 2024 API
FBXExportOptions Constructor
FBXExportOptions Class See Also Send Feedback
Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FBXExportOptions()
Visual Basic
Public Sub New
Visual C++
public:
FBXExportOptions()

See Also

FBXExportOptions Class


FBXExportOptions Methods

[image] [image]

Revit 2024 API
FBXExportOptions Methods
FBXExportOptions Class See Also Send Feedback

The FBXExportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FBXExportOptions Class


FBXExportOptions Properties

[image] [image]

Revit 2024 API
FBXExportOptions Properties
FBXExportOptions Class See Also Send Feedback

The FBXExportOptions type exposes the following members.

Properties

 | Name | Description
Public property | LevelsOfDetailValue | The value of the levels of detail.
Public property | StopOnError | Whether export process should stop when a view fails to export.
Public property | UseLevelsOfDetail | True to use levels of detail, false otherwise.
Public property | WithoutBoundaryEdges | True to export without boundary edges, false otherwise.

See Also

FBXExportOptions Class


LevelsOfDetailValue Property

[image]

Revit 2024 API
FBXExportOptions..::..LevelsOfDetailValue Property
FBXExportOptions Class See Also Send Feedback
The value of the levels of detail.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public int LevelsOfDetailValue { get; set; }
Visual Basic
Public Property LevelsOfDetailValue As Integer
    Get
    Set
Visual C++
public:
property int LevelsOfDetailValue {
    int get ();
    void set (int value);
}

Field Value

To use this option, UseLevelsOfDetail should be set to true. And the value should be in the range [0, 15]. It will be calculated based on the settings of current view if it's not assigned a valid value.

See Also

FBXExportOptions Class


StopOnError Property

[image]

Revit 2024 API
FBXExportOptions..::..StopOnError Property
FBXExportOptions Class See Also Send Feedback
Whether export process should stop when a view fails to export.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool StopOnError { get; set; }
Visual Basic
Public Property StopOnError As Boolean
    Get
    Set
Visual C++
public:
property bool StopOnError {
    bool get ();
    void set (bool value);
}

Remarks

If set to false, the export would continue until all views are processed. This option has an effect only when a set of more than one view is specified.

See Also

FBXExportOptions Class


UseLevelsOfDetail Property

[image]

Revit 2024 API
FBXExportOptions..::..UseLevelsOfDetail Property
FBXExportOptions Class See Also Send Feedback
True to use levels of detail, false otherwise.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool UseLevelsOfDetail { get; set; }
Visual Basic
Public Property UseLevelsOfDetail As Boolean
    Get
    Set
Visual C++
public:
property bool UseLevelsOfDetail {
    bool get ();
    void set (bool value);
}

Field Value

The default value is false.

See Also

FBXExportOptions Class


WithoutBoundaryEdges Property

[image]

Revit 2024 API
FBXExportOptions..::..WithoutBoundaryEdges Property
FBXExportOptions Class See Also Send Feedback
True to export without boundary edges, false otherwise.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool WithoutBoundaryEdges { get; set; }
Visual Basic
Public Property WithoutBoundaryEdges As Boolean
    Get
    Set
Visual C++
public:
property bool WithoutBoundaryEdges {
    bool get ();
    void set (bool value);
}

Field Value

The default value is false.

See Also

FBXExportOptions Class


FilePath Class

[image]

Revit 2024 API
FilePath Class
Members See Also Send Feedback
This class represents a path on a disk or network location, but not a path to a Revit server location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public class FilePath : ModelPath
Visual Basic
Public Class FilePath _
    Inherits ModelPath
Visual C++
public ref class FilePath : public ModelPath

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ModelPath
Autodesk.Revit.DB..::..FilePath

See Also

FilePath Members


FilePath Members

[image] [image]

Revit 2024 API
FilePath Members
FilePath Class Constructors Methods Properties See Also Send Feedback

The FilePath type exposes the following members.

Constructors

 | Name | Description
Public method | FilePath | Constructs a FilePath

Methods

 | Name | Description
Public method | Compare | Compares this ModelPath with another (Inherited from ModelPath.)
Public method | Dispose | (Inherited from ModelPath.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetModelGUID | A GUID identifying the Revit cloud model. (Inherited from ModelPath.)
Public method | GetProjectGUID | A GUID identifying the BIM 360 Docs or Autodesk Docs project to which the model is associated. (Inherited from ModelPath.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CentralServerPath | The path to the location of the central Revit server or cloud. (Inherited from ModelPath.)
Public property | CloudPath | Whether this path represents a path on an Autodesk server such as BIM360. (Inherited from ModelPath.)
Public property | Empty | Whether this path is empty (Inherited from ModelPath.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ModelPath.)
Public property | Region | The region of the BIM 360 Docs or Autodesk Docs account and project which contains this model. (Inherited from ModelPath.)
Public property | ServerPath | Whether this path is a server path (as opposed to a file path or cloud path) (Inherited from ModelPath.)

See Also

FilePath Class


FilePath Constructor

[image]

Revit 2024 API
FilePath Constructor
FilePath Class See Also Send Feedback
Constructs a FilePath

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public FilePath(
    string path
)
Visual Basic
Public Sub New ( _
    path As String _
)
Visual C++
public:
FilePath(
    String^ path
)

Parameters

path
Type: System..::..String
The path to the file. This path does not have to be a full path; it can be relative.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FilePath Class


FilePath Methods

[image] [image]

Revit 2024 API
FilePath Methods
FilePath Class See Also Send Feedback

The FilePath type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares this ModelPath with another (Inherited from ModelPath.)
Public method | Dispose | (Inherited from ModelPath.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetModelGUID | A GUID identifying the Revit cloud model. (Inherited from ModelPath.)
Public method | GetProjectGUID | A GUID identifying the BIM 360 Docs or Autodesk Docs project to which the model is associated. (Inherited from ModelPath.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FilePath Class


FilePath Properties

[image] [image]

Revit 2024 API
FilePath Properties
FilePath Class See Also Send Feedback

The FilePath type exposes the following members.

Properties

 | Name | Description
Public property | CentralServerPath | The path to the location of the central Revit server or cloud. (Inherited from ModelPath.)
Public property | CloudPath | Whether this path represents a path on an Autodesk server such as BIM360. (Inherited from ModelPath.)
Public property | Empty | Whether this path is empty (Inherited from ModelPath.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ModelPath.)
Public property | Region | The region of the BIM 360 Docs or Autodesk Docs account and project which contains this model. (Inherited from ModelPath.)
Public property | ServerPath | Whether this path is a server path (as opposed to a file path or cloud path) (Inherited from ModelPath.)

See Also

FilePath Class


FilledRegion Class

[image]

Revit 2024 API
FilledRegion Class
Members See Also Send Feedback
A filled region element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public class FilledRegion : Element
Visual Basic
Public Class FilledRegion _
    Inherits Element
Visual C++
public ref class FilledRegion : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..FilledRegion

See Also

FilledRegion Members


FilledRegion Members

[image] [image]

Revit 2024 API
FilledRegion Members
FilledRegion Class Methods Properties See Also Send Feedback

The FilledRegion type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create(Document, ElementId, ElementId, IList<(Of <<'(CurveLoop>)>>)) | Creates a view-specific filled region from the given boundaries.
 | Create(Document, ElementId, SketchPlane, IList<(Of <<'(CurveLoop>)>>)) | Creates a filled region on a sketch plane in a 3d model family.
 | CreateMaskingRegion(Document, ElementId, IList<(Of <<'(CurveLoop>)>>)) | Creates a view-specific masking region from the given boundaries.
 | CreateMaskingRegion(Document, SketchPlane, IList<(Of <<'(CurveLoop>)>>)) | Creates a masking region on a sketch plane in a 3d model family.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetBoundaries | Gets the boundaries.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
 | GetValidLineStyleIdsForFilledRegion | Gets the line style Ids which are permitted to be assigned to a filled region.
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
 | IsValidFilledRegionTypeId | Indicates whether the given Id is a valid filled region type Id.
 | IsValidLineStyleIdForFilledRegion | Indicates whether the given Id is a valid line style Id.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetLineStyleId | Sets the line style Id for all boundaries.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsMasking | Indicates whether this element is a 'Filled Region or a 'Masking Region'.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FilledRegion Class


Create Method

[image] [image]

Revit 2024 API
FilledRegion..::..Create Method
FilledRegion Class See Also Send Feedback

Overload List

Name | Description
Create(Document, ElementId, ElementId, IList<(Of <<'(CurveLoop>)>>)) | Creates a view-specific filled region from the given boundaries.
Create(Document, ElementId, SketchPlane, IList<(Of <<'(CurveLoop>)>>)) | Creates a filled region on a sketch plane in a 3d model family.

See Also

FilledRegion Class
FilledRegion Members


Create Method (Document, ElementId, SketchPlane, IList(CurveLoop))

[image]

Revit 2024 API
FilledRegion..::..Create Method (Document, ElementId, SketchPlane, IList<(Of <(<'CurveLoop>)>)>)
FilledRegion Class See Also Send Feedback
Creates a filled region on a sketch plane in a 3d model family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public static FilledRegion Create(
    Document document,
    ElementId typeId,
    SketchPlane sketchPlane,
    IList<CurveLoop> boundaries
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    typeId As ElementId, _
    sketchPlane As SketchPlane, _
    boundaries As IList(Of CurveLoop) _
) As FilledRegion
Visual C++
public:
static FilledRegion^ Create(
    Document^ document,
    ElementId^ typeId,
    SketchPlane^ sketchPlane,
    IList<CurveLoop^>^ boundaries
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The family document in which to create the filled region.
typeId
Type: Autodesk.Revit.DB..::..ElementId
The filled region type Id.
sketchPlane
Type: Autodesk.Revit.DB..::..SketchPlane
The sketch plane for use with the filled region.
boundaries
Type: System.Collections.Generic..::..IList<(Of <(<' CurveLoop >)>)>
The filled region boundaries, which will be projected onto the sketch plane.

Return Value

The new filled region.

Remarks

If the sketch plane is currently in use, then a copy of the sketch plane will be created and used. The sketch plane normal must be parallel to the model's X, Y or Z axis. The sketch plane can be a planar face reference to model geometry. The line style of the boundaries will be set to thin lines by default.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The document is not a 3d model family. -or- The Id typeId is invalid. -or- Filled regions can't be created in this document or view. -or- The sketch plane is not suitable for model elements. -or- The sketch plane normal is not parallel to the model's X, Y or Z axis. -or- The input curve loops cannot compose a valid boundary, that means: the "curveLoops" collection is empty; or some curve loops intersect with each other; or each curve loop is not closed individually; or each curve loop is not planar; or each curve loop is not in a plane parallel to the sketch plane; or input curves contain at least one helical curve.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FilledRegion Class
Create Overload


CreateMaskingRegion Method

[image] [image]

Revit 2024 API
FilledRegion..::..CreateMaskingRegion Method
FilledRegion Class See Also Send Feedback

Overload List

Name | Description
CreateMaskingRegion(Document, ElementId, IList<(Of <<'(CurveLoop>)>>)) | Creates a view-specific masking region from the given boundaries.
CreateMaskingRegion(Document, SketchPlane, IList<(Of <<'(CurveLoop>)>>)) | Creates a masking region on a sketch plane in a 3d model family.

See Also

FilledRegion Class
FilledRegion Members


CreateMaskingRegion Method (Document, ElementId, IList(CurveLoop))

[image]

Revit 2024 API
FilledRegion..::..CreateMaskingRegion Method (Document, ElementId, IList<(Of <(<'CurveLoop>)>)>)
FilledRegion Class See Also Send Feedback
Creates a view-specific masking region from the given boundaries.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static FilledRegion CreateMaskingRegion(
    Document document,
    ElementId viewId,
    IList<CurveLoop> boundaries
)
Visual Basic
Public Shared Function CreateMaskingRegion ( _
    document As Document, _
    viewId As ElementId, _
    boundaries As IList(Of CurveLoop) _
) As FilledRegion
Visual C++
public:
static FilledRegion^ CreateMaskingRegion(
    Document^ document,
    ElementId^ viewId,
    IList<CurveLoop^>^ boundaries
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which to create the masking region.
viewId
Type: Autodesk.Revit.DB..::..ElementId
The view Id.
boundaries
Type: System.Collections.Generic..::..IList<(Of <(<' CurveLoop >)>)>
The boundaries.

Return Value

The newly created masking region.

Remarks

View-specific masking regions can be created in models and 2d families. The line style of the boundaries will be set to thin lines by default.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The document is a 3d model family. -or- Details can't be drawn in the view. -or- Masking regions and Filled regions can't be created in this document or view. -or- The input curve loops cannot compose a valid boundary, that means: the "curveLoops" collection is empty; or some curve loops intersect with each other; or each curve loop is not closed individually; or each curve loop is not planar; or each curve loop is not in a plane parallel to the view's detail sketch plane; or input curves contain at least one helical curve. -or- Thrown if the viewId is invalid, or the view does not support the detail items creation, or if the boundaries are empty, open, or self-intersecting.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FilledRegion Class
CreateMaskingRegion Overload


CreateMaskingRegion Method (Document, SketchPlane, IList(CurveLoop))

[image]

Revit 2024 API
FilledRegion..::..CreateMaskingRegion Method (Document, SketchPlane, IList<(Of <(<'CurveLoop>)>)>)
FilledRegion Class See Also Send Feedback
Creates a masking region on a sketch plane in a 3d model family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static FilledRegion CreateMaskingRegion(
    Document document,
    SketchPlane sketchPlane,
    IList<CurveLoop> boundaries
)
Visual Basic
Public Shared Function CreateMaskingRegion ( _
    document As Document, _
    sketchPlane As SketchPlane, _
    boundaries As IList(Of CurveLoop) _
) As FilledRegion
Visual C++
public:
static FilledRegion^ CreateMaskingRegion(
    Document^ document,
    SketchPlane^ sketchPlane,
    IList<CurveLoop^>^ boundaries
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The family document in which to create the masking region.
sketchPlane
Type: Autodesk.Revit.DB..::..SketchPlane
The sketch plane for use with the masking region.
boundaries
Type: System.Collections.Generic..::..IList<(Of <(<' CurveLoop >)>)>
The masking region boundaries, which will be projected onto the sketch plane.

Return Value

The new masking region.

Remarks

If the sketch plane is currently in use, then a copy of the sketch plane will be created and used. The sketch plane normal must be parallel to the model's X, Y or Z axis. The sketch plane can be a planar face reference to model geometry. The line style of the boundaries will be set to thin lines by default.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The document is not a 3d model family. -or- Filled regions can't be created in this document or view. -or- The sketch plane is not suitable for model elements. -or- The sketch plane normal is not parallel to the model's X, Y or Z axis. -or- The input curve loops cannot compose a valid boundary, that means: the "curveLoops" collection is empty; or some curve loops intersect with each other; or each curve loop is not closed individually; or each curve loop is not planar; or each curve loop is not in a plane parallel to the sketch plane; or input curves contain at least one helical curve.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FilledRegion Class
CreateMaskingRegion Overload


GetBoundaries Method

[image]

Revit 2024 API
FilledRegion..::..GetBoundaries Method
FilledRegion Class See Also Send Feedback
Gets the boundaries.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public IList<CurveLoop> GetBoundaries()
Visual Basic
Public Function GetBoundaries As IList(Of CurveLoop)
Visual C++
public:
IList<CurveLoop^>^ GetBoundaries()

Return Value

The filled region boundaries.

See Also

FilledRegion Class


IsValidFilledRegionTypeId Method

[image]

Revit 2024 API
FilledRegion..::..IsValidFilledRegionTypeId Method
FilledRegion Class See Also Send Feedback
Indicates whether the given Id is a valid filled region type Id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static bool IsValidFilledRegionTypeId(
    Document document,
    ElementId typeId
)
Visual Basic
Public Shared Function IsValidFilledRegionTypeId ( _
    document As Document, _
    typeId As ElementId _
) As Boolean
Visual C++
public:
static bool IsValidFilledRegionTypeId(
    Document^ document,
    ElementId^ typeId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
typeId
Type: Autodesk.Revit.DB..::..ElementId
The filled region type Id.

Return Value

True if it is a valid filled region type Id, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FilledRegion Class


IsValidLineStyleIdForFilledRegion Method

[image]

Revit 2024 API
FilledRegion..::..IsValidLineStyleIdForFilledRegion Method
FilledRegion Class See Also Send Feedback
Indicates whether the given Id is a valid line style Id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static bool IsValidLineStyleIdForFilledRegion(
    Document document,
    ElementId lineStyleId
)
Visual Basic
Public Shared Function IsValidLineStyleIdForFilledRegion ( _
    document As Document, _
    lineStyleId As ElementId _
) As Boolean
Visual C++
public:
static bool IsValidLineStyleIdForFilledRegion(
    Document^ document,
    ElementId^ lineStyleId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
lineStyleId
Type: Autodesk.Revit.DB..::..ElementId
The line style Id.

Return Value

True if it is a valid line style Id, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FilledRegion Class


SetLineStyleId Method

[image]

Revit 2024 API
FilledRegion..::..SetLineStyleId Method
FilledRegion Class See Also Send Feedback
Sets the line style Id for all boundaries.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void SetLineStyleId(
    ElementId lineStyleId
)
Visual Basic
Public Sub SetLineStyleId ( _
    lineStyleId As ElementId _
)
Visual C++
public:
void SetLineStyleId(
    ElementId^ lineStyleId
)

Parameters

lineStyleId
Type: Autodesk.Revit.DB..::..ElementId
The line style Id.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | lineStyleId is not a valid line style Id for a filled region.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FilledRegion Class


FilledRegion Properties

[image] [image]

Revit 2024 API
FilledRegion Properties
FilledRegion Class See Also Send Feedback

The FilledRegion type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsMasking | Indicates whether this element is a 'Filled Region or a 'Masking Region'.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FilledRegion Class


IsMasking Property

[image]

Revit 2024 API
FilledRegion..::..IsMasking Property
FilledRegion Class See Also Send Feedback
Indicates whether this element is a 'Filled Region or a 'Masking Region'.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public bool IsMasking { get; }
Visual Basic
Public ReadOnly Property IsMasking As Boolean
    Get
Visual C++
public:
property bool IsMasking {
    bool get ();
}

See Also

FilledRegion Class


Parameter Property

[image] [image]

Revit 2024 API
FilledRegion..::..Parameter Property
FilledRegion Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

FilledRegion Class
FilledRegion Members


FilledRegionType Class

[image]

Revit 2024 API
FilledRegionType Class
Members See Also Send Feedback
A filled region attributes element. Note, the forground pattern color is stored in the parent class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public class FilledRegionType : LineAndTextAttrSymbol
Visual Basic
Public Class FilledRegionType _
    Inherits LineAndTextAttrSymbol
Visual C++
public ref class FilledRegionType : public LineAndTextAttrSymbol

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..LineAndTextAttrSymbol
Autodesk.Revit.DB..::..FilledRegionType

See Also

FilledRegionType Members


IsValidBackgroundPatternId Method

[image]

Revit 2024 API
FilledRegionType..::..IsValidBackgroundPatternId Method
FilledRegionType Class See Also Send Feedback
Check if the id is valid for a background pattern

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public bool IsValidBackgroundPatternId(
    ElementId patternId
)
Visual Basic
Public Function IsValidBackgroundPatternId ( _
    patternId As ElementId _
) As Boolean
Visual C++
public:
bool IsValidBackgroundPatternId(
    ElementId^ patternId
)

Parameters

patternId
Type: Autodesk.Revit.DB..::..ElementId
Element id of the FillPatternElement

Return Value

False if the FillPatternElement is a model pattern. True otherwise.

Remarks

The FillPatternElement must be a 'Drafting' pattern.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FilledRegionType Class


IsValidFillPatternId Method

[image]

Revit 2024 API
FilledRegionType..::..IsValidFillPatternId Method
FilledRegionType Class See Also Send Feedback
Check if the id is a FillPatternElement or an invalidElementId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public bool IsValidFillPatternId(
    ElementId patternId
)
Visual Basic
Public Function IsValidFillPatternId ( _
    patternId As ElementId _
) As Boolean
Visual C++
public:
bool IsValidFillPatternId(
    ElementId^ patternId
)

Parameters

patternId
Type: Autodesk.Revit.DB..::..ElementId
Element id of the FillPatternElement

Return Value

True if the id is InvalidElementId, or if the element is a FillPatternElement. False otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FilledRegionType Class


IsValidForegroundPatternId Method

[image]

Revit 2024 API
FilledRegionType..::..IsValidForegroundPatternId Method
FilledRegionType Class See Also Send Feedback
Check if the id is valid for a foreground pattern

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public bool IsValidForegroundPatternId(
    ElementId patternId
)
Visual Basic
Public Function IsValidForegroundPatternId ( _
    patternId As ElementId _
) As Boolean
Visual C++
public:
bool IsValidForegroundPatternId(
    ElementId^ patternId
)

Parameters

patternId
Type: Autodesk.Revit.DB..::..ElementId
Element id of the FillPatternElement

Return Value

False if in a family, and the id is a FillPatternElement that targets 'Drafting'. True otherwise.

Remarks

In a family the FillPatternElement must be a 'Drafting' pattern.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FilledRegionType Class


IsValidLineWeight Method

[image]

Revit 2024 API
FilledRegionType..::..IsValidLineWeight Method
FilledRegionType Class See Also Send Feedback
Indicates whether the given line weight value is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static bool IsValidLineWeight(
    int lineWeight
)
Visual Basic
Public Shared Function IsValidLineWeight ( _
    lineWeight As Integer _
) As Boolean
Visual C++
public:
static bool IsValidLineWeight(
    int lineWeight
)

Parameters

lineWeight
Type: System..::..Int32
The line weight.

Return Value

True if it is a valid line weight value, false otherwise.

See Also

FilledRegionType Class


IsValidMasking Method

[image]

Revit 2024 API
FilledRegionType..::..IsValidMasking Method
FilledRegionType Class See Also Send Feedback
Check that in a family the FillRegionType is always masking.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public bool IsValidMasking(
    bool isMasking
)
Visual Basic
Public Function IsValidMasking ( _
    isMasking As Boolean _
) As Boolean
Visual C++
public:
bool IsValidMasking(
    bool isMasking
)

Parameters

isMasking
Type: System..::..Boolean
The isMasking value to check.

Return Value

True if the IsMasking property can be set to the new value.

See Also

FilledRegionType Class


IsValidSolidFillPatternId Method

[image]

Revit 2024 API
FilledRegionType..::..IsValidSolidFillPatternId Method
FilledRegionType Class See Also Send Feedback
Checks if the id is valid for a background pattern

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public bool IsValidSolidFillPatternId(
    ElementId patternId
)
Visual Basic
Public Function IsValidSolidFillPatternId ( _
    patternId As ElementId _
) As Boolean
Visual C++
public:
bool IsValidSolidFillPatternId(
    ElementId^ patternId
)

Parameters

patternId
Type: Autodesk.Revit.DB..::..ElementId
Element id of the FillPatternElement

Return Value

False if in a family and the id is a solid fill pattern and 'isMasking' is masking is false. True otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FilledRegionType Class


FilledRegionType Properties

[image] [image]

Revit 2024 API
FilledRegionType Properties
FilledRegionType Class See Also Send Feedback

The FilledRegionType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BackgroundPatternColor | The background fill pattern color.
Public property | BackgroundPatternId | The background fill pattern Id.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | ForegroundPatternColor | The foreground fill pattern color.
Public property | ForegroundPatternId | The foreground fill pattern Id.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsMasking | If true then the FilledRegion will cover the lines and edges of objects behind it. If false then lines and edges will remain visible.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | LineWeight | The line weight of the fill pattern.
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FilledRegionType Class


BackgroundPatternColor Property

[image]

Revit 2024 API
FilledRegionType..::..BackgroundPatternColor Property
FilledRegionType Class See Also Send Feedback
The background fill pattern color.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public Color BackgroundPatternColor { get; set; }
Visual Basic
Public Property BackgroundPatternColor As Color
    Get
    Set
Visual C++
public:
property Color^ BackgroundPatternColor {
    Color^ get ();
    void set (Color^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

FilledRegionType Class


ForegroundPatternColor Property

[image]

Revit 2024 API
FilledRegionType..::..ForegroundPatternColor Property
FilledRegionType Class See Also Send Feedback
The foreground fill pattern color.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public Color ForegroundPatternColor { get; set; }
Visual Basic
Public Property ForegroundPatternColor As Color
    Get
    Set
Visual C++
public:
property Color^ ForegroundPatternColor {
    Color^ get ();
    void set (Color^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

FilledRegionType Class


ForegroundPatternId Property

[image]

Revit 2024 API
FilledRegionType..::..ForegroundPatternId Property
FilledRegionType Class See Also Send Feedback
The foreground fill pattern Id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public ElementId ForegroundPatternId { get; set; }
Visual Basic
Public Property ForegroundPatternId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ ForegroundPatternId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Remarks

When the FilledRegionAttributes element is in a family then the FillPattern used for a foreground pattern must have a 'Drafting' target. In addition, when the FilledRegionAttributes element is in a family, the pattern cannot be the solid fill pattern unless the 'IsMasking' property is set to true. InvalidElementId is used when there is no foreground pattern

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The patternId must either be InvalidElementId or represent a valid FillPatternElement. -or- When setting this property: In a family the patternId must be a 'Drafting' pattern. -or- When setting this property: In a family the patternId can not be a solid fill pattern if the 'IsMasking' property is false.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

FilledRegionType Class


LineWeight Property

[image]

Revit 2024 API
FilledRegionType..::..LineWeight Property
FilledRegionType Class See Also Send Feedback
The line weight of the fill pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public int LineWeight { get; set; }
Visual Basic
Public Property LineWeight As Integer
    Get
    Set
Visual C++
public:
property int LineWeight {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: lineWeight is not a valid line weight value (it must be within the range of 1-16).

See Also

FilledRegionType Class


Parameter Property

[image] [image]

Revit 2024 API
FilledRegionType..::..Parameter Property
FilledRegionType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

FilledRegionType Class
FilledRegionType Members


FillGrid Class

[image]

Revit 2024 API
FillGrid Class
Members See Also Send Feedback
Represents a grid line in a fill pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public class FillGrid : IDisposable
Visual Basic
Public Class FillGrid _
    Implements IDisposable
Visual C++
public ref class FillGrid : IDisposable

Remarks

A grid line is described in the two dimensions of a face as follows: angle, origin, shift, offset, segments
  • Angle specifies the direction, in degrees, of the grid line relative to the x-axis.
  • Parallel lines are drawn as specified by Offset and Shift to fill the entire face. Offset defines the distance between parallel lines. Zero Offset is not allowed. Shift moves the pattern of dashes and spaces along the length of each new parallel line. Shift is ignored if the line is solid.
  • The segments defines a repeating pattern of dashes and spaces for the grid line. If it is omitted, the line is solid. Positive numbers define dashes, negative numbers define spaces, and zero specifies a dot. If you begin a pattern with a space, do not alternate dashes and spaces, or do not end with a space, Revit will introduce tiny dashes or spaces to compensate. Revit expands dots and very short dashes into dashes of a minimum size.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FillGrid

See Also

FillGrid Members


FillGrid Members

[image] [image]

Revit 2024 API
FillGrid Members
FillGrid Class Constructors Methods Properties See Also Send Feedback

The FillGrid type exposes the following members.

Constructors

 | Name | Description
Public method | FillGrid()()()() | Creates a simple fill grid.
Public method | FillGrid(FillGrid) | Constructs a new FillGrid with default settings.
Public method | FillGrid(Double, Double) | Creates a simple fill grid with given angle and offset.

Methods

 | Name | Description
Public method | CalculateLengthPerArea | Calculates length of the pattern per unit area.
Public method | CalculateLinesPerLength | Calculates the number of solid lines of the pattern per unit length.
Public method | CalculateStrokesPerArea | Calculates the number of the segments of the pattern per unit area.
Public method | Dispose | Releases all resources used by the FillGrid
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHatchingDirection | Provides the hatching propagation. Hatching is inverted.
Public method | GetPointLineZone(UV) | Gets the index of fill grid line closest to the input 2d point.
Public method | GetPointLineZone(UV, UV%) | Gets the index of fill grid line and the point on the grid line nearest to the input point.
Public method | GetSegmentDirection | Provides the segment direction.
Public method | GetSegments | Gets the segments of the fill grid.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Check if two fill grids are equal.
Public method | SetSegments | Sets the segments to the fill grid.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Angle | Gets and sets the angle of the fill grid.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Offset | Gets and sets the offset of the fill grid.
Public property | Origin | Gets and sets the origin of the fill grid.
Public property | Shift | Gets and sets the shift of the fill grid.

See Also

FillGrid Class


FillGrid Constructor

[image] [image]

Revit 2024 API
FillGrid Constructor
FillGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FillGrid()()()() | Creates a simple fill grid.
Public method | FillGrid(FillGrid) | Constructs a new FillGrid with default settings.
Public method | FillGrid(Double, Double) | Creates a simple fill grid with given angle and offset.

See Also

FillGrid Class
FillGrid Members


FillGrid Constructor

[image]

Revit 2024 API
FillGrid Constructor
FillGrid Class See Also Send Feedback
Creates a simple fill grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public FillGrid()
Visual Basic
Public Sub New
Visual C++
public:
FillGrid()

See Also

FillGrid Class
FillGrid Overload


FillGrid Constructor (FillGrid)

[image]

Revit 2024 API
FillGrid Constructor (FillGrid)
FillGrid Class See Also Send Feedback
Constructs a new FillGrid with default settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public FillGrid(
    FillGrid other
)
Visual Basic
Public Sub New ( _
    other As FillGrid _
)
Visual C++
public:
FillGrid(
    FillGrid^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..FillGrid

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FillGrid Class
FillGrid Overload


FillGrid Constructor (Double, Double)

[image]

Revit 2024 API
FillGrid Constructor (Double, Double)
FillGrid Class See Also Send Feedback
Creates a simple fill grid with given angle and offset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public FillGrid(
    double angle,
    double offset
)
Visual Basic
Public Sub New ( _
    angle As Double, _
    offset As Double _
)
Visual C++
public:
FillGrid(
    double angle,
    double offset
)

Parameters

angle
Type: System..::..Double
The angle.
offset
Type: System..::..Double
The offset represents the spacing between the lines.

See Also

FillGrid Class
FillGrid Overload


CalculateLengthPerArea Method

[image]

Revit 2024 API
FillGrid..::..CalculateLengthPerArea Method
FillGrid Class See Also Send Feedback
Calculates length of the pattern per unit area.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public double CalculateLengthPerArea()
Visual Basic
Public Function CalculateLengthPerArea As Double
Visual C++
public:
double CalculateLengthPerArea()

Return Value

The length per area.

See Also

FillGrid Class


CalculateLinesPerLength Method

[image]

Revit 2024 API
FillGrid..::..CalculateLinesPerLength Method
FillGrid Class See Also Send Feedback
Calculates the number of solid lines of the pattern per unit length.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public double CalculateLinesPerLength()
Visual Basic
Public Function CalculateLinesPerLength As Double
Visual C++
public:
double CalculateLinesPerLength()

Return Value

The solid lines per length.

See Also

FillGrid Class


CalculateStrokesPerArea Method

[image]

Revit 2024 API
FillGrid..::..CalculateStrokesPerArea Method
FillGrid Class See Also Send Feedback
Calculates the number of the segments of the pattern per unit area.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public double CalculateStrokesPerArea()
Visual Basic
Public Function CalculateStrokesPerArea As Double
Visual C++
public:
double CalculateStrokesPerArea()

Return Value

The strokes per area.

See Also

FillGrid Class


Dispose Method

[image]

Revit 2024 API
FillGrid..::..Dispose Method
FillGrid Class See Also Send Feedback
Releases all resources used by the FillGrid

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FillGrid Class


GetHatchingDirection Method

[image]

Revit 2024 API
FillGrid..::..GetHatchingDirection Method
FillGrid Class See Also Send Feedback
Provides the hatching propagation. Hatching is inverted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public UV GetHatchingDirection()
Visual Basic
Public Function GetHatchingDirection As UV
Visual C++
public:
UV^ GetHatchingDirection()

Return Value

The direction of hatching.

See Also

FillGrid Class


GetPointLineZone Method

[image] [image]

Revit 2024 API
FillGrid..::..GetPointLineZone Method
FillGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetPointLineZone(UV) | Gets the index of fill grid line closest to the input 2d point.
Public method | GetPointLineZone(UV, UV%) | Gets the index of fill grid line and the point on the grid line nearest to the input point.

See Also

FillGrid Class
FillGrid Members


GetPointLineZone Method (UV)

[image]

Revit 2024 API
FillGrid..::..GetPointLineZone Method (UV)
FillGrid Class See Also Send Feedback
Gets the index of fill grid line closest to the input 2d point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public int GetPointLineZone(
    UV point
)
Visual Basic
Public Function GetPointLineZone ( _
    point As UV _
) As Integer
Visual C++
public:
int GetPointLineZone(
    UV^ point
)

Parameters

point
Type: Autodesk.Revit.DB..::..UV
Input point.

Return Value

The index of fill grid line.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FillGrid Class
GetPointLineZone Overload


GetSegmentDirection Method

[image]

Revit 2024 API
FillGrid..::..GetSegmentDirection Method
FillGrid Class See Also Send Feedback
Provides the segment direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public UV GetSegmentDirection()
Visual Basic
Public Function GetSegmentDirection As UV
Visual C++
public:
UV^ GetSegmentDirection()

Return Value

The direction of segment.

See Also

FillGrid Class


IsEqual Method

[image]

Revit 2024 API
FillGrid..::..IsEqual Method
FillGrid Class See Also Send Feedback
Check if two fill grids are equal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public bool IsEqual(
    FillGrid other
)
Visual Basic
Public Function IsEqual ( _
    other As FillGrid _
) As Boolean
Visual C++
public:
bool IsEqual(
    FillGrid^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..FillGrid
The fill grid to be compared.

Return Value

True if the two fill grids are equal, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FillGrid Class


SetSegments Method

[image]

Revit 2024 API
FillGrid..::..SetSegments Method
FillGrid Class See Also Send Feedback
Sets the segments to the fill grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public void SetSegments(
    IList<double> segArr
)
Visual Basic
Public Sub SetSegments ( _
    segArr As IList(Of Double) _
)
Visual C++
public:
void SetSegments(
    IList<double>^ segArr
)

Parameters

segArr
Type: System.Collections.Generic..::..IList<(Of <(<'Double>)>)>
The segments to be used.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FillGrid Class


FillGrid Properties

[image] [image]

Revit 2024 API
FillGrid Properties
FillGrid Class See Also Send Feedback

The FillGrid type exposes the following members.

Properties

 | Name | Description
Public property | Angle | Gets and sets the angle of the fill grid.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Offset | Gets and sets the offset of the fill grid.
Public property | Origin | Gets and sets the origin of the fill grid.
Public property | Shift | Gets and sets the shift of the fill grid.

See Also

FillGrid Class


Angle Property

[image]

Revit 2024 API
FillGrid..::..Angle Property
FillGrid Class See Also Send Feedback
Gets and sets the angle of the fill grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public double Angle { get; set; }
Visual Basic
Public Property Angle As Double
    Get
    Set
Visual C++
public:
property double Angle {
    double get ();
    void set (double value);
}

See Also

FillGrid Class


IsValidObject Property

[image]

Revit 2024 API
FillGrid..::..IsValidObject Property
FillGrid Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

FillGrid Class


Offset Property

[image]

Revit 2024 API
FillGrid..::..Offset Property
FillGrid Class See Also Send Feedback
Gets and sets the offset of the fill grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public double Offset { get; set; }
Visual Basic
Public Property Offset As Double
    Get
    Set
Visual C++
public:
property double Offset {
    double get ();
    void set (double value);
}

Field Value

The offset of the fill grid.

Remarks

Offset defines the distance between parallel lines. A zero offset is not allowed.

See Also

FillGrid Class


Shift Property

[image]

Revit 2024 API
FillGrid..::..Shift Property
FillGrid Class See Also Send Feedback
Gets and sets the shift of the fill grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public double Shift { get; set; }
Visual Basic
Public Property Shift As Double
    Get
    Set
Visual C++
public:
property double Shift {
    double get ();
    void set (double value);
}

Field Value

The shift of the fill grid.

Remarks

Shift moves the pattern of dashes and spaces along the length of each new parallel line. Shift is ignored if the line is solid.

See Also

FillGrid Class


FillPattern Members

[image] [image]

Revit 2024 API
FillPattern Members
FillPattern Class Constructors Methods Properties See Also Send Feedback

The FillPattern type exposes the following members.

Constructors

 | Name | Description
Public method | FillPattern()()()() | Creates a fill pattern with FillPatternHostOrientation::FPORIENTATION_TO_VIEW and FillPatternTarget::FPTARGET_NONE.
Public method | FillPattern(FillPattern) | Constructs a new copy of the input FillPattern object.
Public method | FillPattern(String, FillPatternTarget, FillPatternHostOrientation) | Creates a fill pattern based on the given name, FillPatternTarget and FillPatternHostOrientation.
Public method | FillPattern(String, FillPatternTarget, FillPatternHostOrientation, Double, Double) | Creates a simple hatch fill pattern based on the given name, angle, spacing, FillPatternTarget and FillPatternHostOrientation.
Public method | FillPattern(String, FillPatternTarget, FillPatternHostOrientation, Double, Double, Double) | Creates a simple crosshatch fill pattern based on the given name, angle, spacing, FillPatternTarget and FillPatternHostOrientation.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FillPattern
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExpandDots | Corrects pattern dots to make them be drawn properly for Revit.
Public method | GetFillGrid | Gets the specified fill grid.
Public method | GetFillGrids | Gets all fill grids in this fill pattern
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Check if the contents and the name of the fill pattern is the same as the name and contents of this fill pattern.
Public method | SetFillGrid | Sets the fill grid.
Public method | SetFillGrids | Set the fill grids in this fill pattern.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | GridCount | Gets the count of the fill grids in this fill pattern.
Public property | HostOrientation | Orientation to host layer.
Public property | IsSolidFill | Check if the fill pattern is a solid fill pattern.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LengthPerArea | Gets length of all lines that placed on unit area.
Public property | LinesPerLength | Gets the number of solid lines that placed in unit length.
Public property | Name | The name of the fill pattern.
Public property | StrokesPerArea | Gets the number of strokes that placed on unit area.
Public property | Target | Target of this fill pattern applied to.

See Also

FillPattern Class


FillPattern Constructor

[image] [image]

Revit 2024 API
FillPattern Constructor
FillPattern Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FillPattern()()()() | Creates a fill pattern with FillPatternHostOrientation::FPORIENTATION_TO_VIEW and FillPatternTarget::FPTARGET_NONE.
Public method | FillPattern(FillPattern) | Constructs a new copy of the input FillPattern object.
Public method | FillPattern(String, FillPatternTarget, FillPatternHostOrientation) | Creates a fill pattern based on the given name, FillPatternTarget and FillPatternHostOrientation.
Public method | FillPattern(String, FillPatternTarget, FillPatternHostOrientation, Double, Double) | Creates a simple hatch fill pattern based on the given name, angle, spacing, FillPatternTarget and FillPatternHostOrientation.
Public method | FillPattern(String, FillPatternTarget, FillPatternHostOrientation, Double, Double, Double) | Creates a simple crosshatch fill pattern based on the given name, angle, spacing, FillPatternTarget and FillPatternHostOrientation.

See Also

FillPattern Class
FillPattern Members


FillPattern Constructor (String, FillPatternTarget, FillPatternHostOrientation)

[image]

Revit 2024 API
FillPattern Constructor (String, FillPatternTarget, FillPatternHostOrientation)
FillPattern Class See Also Send Feedback
Creates a fill pattern based on the given name, FillPatternTarget and FillPatternHostOrientation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FillPattern(
    string name,
    FillPatternTarget target,
    FillPatternHostOrientation orientation
)
Visual Basic
Public Sub New ( _
    name As String, _
    target As FillPatternTarget, _
    orientation As FillPatternHostOrientation _
)
Visual C++
public:
FillPattern(
    String^ name,
    FillPatternTarget target,
    FillPatternHostOrientation orientation
)

Parameters

name
Type: System..::..String
The name.
target
Type: Autodesk.Revit.DB..::..FillPatternTarget
The fill pattern target.
orientation
Type: Autodesk.Revit.DB..::..FillPatternHostOrientation
The fill pattern orientation.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

FillPattern Class
FillPattern Overload


FillPattern Constructor (String, FillPatternTarget, FillPatternHostOrientation, Double, Double, Double)

[image]

Revit 2024 API
FillPattern Constructor (String, FillPatternTarget, FillPatternHostOrientation, Double, Double, Double)
FillPattern Class See Also Send Feedback
Creates a simple crosshatch fill pattern based on the given name, angle, spacing, FillPatternTarget and FillPatternHostOrientation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FillPattern(
    string name,
    FillPatternTarget target,
    FillPatternHostOrientation orientation,
    double angle,
    double spacing1,
    double spacing2
)
Visual Basic
Public Sub New ( _
    name As String, _
    target As FillPatternTarget, _
    orientation As FillPatternHostOrientation, _
    angle As Double, _
    spacing1 As Double, _
    spacing2 As Double _
)
Visual C++
public:
FillPattern(
    String^ name,
    FillPatternTarget target,
    FillPatternHostOrientation orientation,
    double angle,
    double spacing1,
    double spacing2
)

Parameters

name
Type: System..::..String
The name.
target
Type: Autodesk.Revit.DB..::..FillPatternTarget
The fill pattern target.
orientation
Type: Autodesk.Revit.DB..::..FillPatternHostOrientation
The fill pattern orientation.
angle
Type: System..::..Double
The angle.
spacing1
Type: System..::..Double
The spacing.
spacing2
Type: System..::..Double
The spacing.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

FillPattern Class
FillPattern Overload


FillPattern Methods

[image] [image]

Revit 2024 API
FillPattern Methods
FillPattern Class See Also Send Feedback

The FillPattern type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExpandDots | Corrects pattern dots to make them be drawn properly for Revit.
Public method | GetFillGrid | Gets the specified fill grid.
Public method | GetFillGrids | Gets all fill grids in this fill pattern
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Check if the contents and the name of the fill pattern is the same as the name and contents of this fill pattern.
Public method | SetFillGrid | Sets the fill grid.
Public method | SetFillGrids | Set the fill grids in this fill pattern.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FillPattern Class


GetFillGrid Method

[image]

Revit 2024 API
FillPattern..::..GetFillGrid Method
FillPattern Class See Also Send Feedback
Gets the specified fill grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FillGrid GetFillGrid(
    int gridIdx
)
Visual Basic
Public Function GetFillGrid ( _
    gridIdx As Integer _
) As FillGrid
Visual C++
public:
FillGrid^ GetFillGrid(
    int gridIdx
)

Parameters

gridIdx
Type: System..::..Int32
The index of the fill grid.

Return Value

The fill grid.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The index of the FillGrid is not valid.

See Also

FillPattern Class


IsEqual Method

[image]

Revit 2024 API
FillPattern..::..IsEqual Method
FillPattern Class See Also Send Feedback
Check if the contents and the name of the fill pattern is the same as the name and contents of this fill pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsEqual(
    FillPattern other
)
Visual Basic
Public Function IsEqual ( _
    other As FillPattern _
) As Boolean
Visual C++
public:
bool IsEqual(
    FillPattern^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..FillPattern
The fill pattern to be compared.

Return Value

True for equal, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FillPattern Class


SetFillGrid Method

[image]

Revit 2024 API
FillPattern..::..SetFillGrid Method
FillPattern Class See Also Send Feedback
Sets the fill grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetFillGrid(
    int gridIdx,
    FillGrid fillGrid
)
Visual Basic
Public Sub SetFillGrid ( _
    gridIdx As Integer, _
    fillGrid As FillGrid _
)
Visual C++
public:
void SetFillGrid(
    int gridIdx,
    FillGrid^ fillGrid
)

Parameters

gridIdx
Type: System..::..Int32
The index of the fill grid.
fillGrid
Type: Autodesk.Revit.DB..::..FillGrid
The fill grid to be used.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FillPattern Class


SetFillGrids Method

[image]

Revit 2024 API
FillPattern..::..SetFillGrids Method
FillPattern Class See Also Send Feedback
Set the fill grids in this fill pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetFillGrids(
    IList<FillGrid> fillGrids
)
Visual Basic
Public Sub SetFillGrids ( _
    fillGrids As IList(Of FillGrid) _
)
Visual C++
public:
void SetFillGrids(
    IList<FillGrid^>^ fillGrids
)

Parameters

fillGrids
Type: System.Collections.Generic..::..IList<(Of <(<' FillGrid >)>)>
The fill grids to be used.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FillPattern Class


GridCount Property

[image]

Revit 2024 API
FillPattern..::..GridCount Property
FillPattern Class See Also Send Feedback
Gets the count of the fill grids in this fill pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public int GridCount { get; }
Visual Basic
Public ReadOnly Property GridCount As Integer
    Get
Visual C++
public:
property int GridCount {
    int get ();
}

See Also

FillPattern Class


IsSolidFill Property

[image]

Revit 2024 API
FillPattern..::..IsSolidFill Property
FillPattern Class See Also Send Feedback
Check if the fill pattern is a solid fill pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsSolidFill { get; }
Visual Basic
Public ReadOnly Property IsSolidFill As Boolean
    Get
Visual C++
public:
property bool IsSolidFill {
    bool get ();
}

See Also

FillPattern Class


IsValidObject Property

[image]

Revit 2024 API
FillPattern..::..IsValidObject Property
FillPattern Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

FillPattern Class


LengthPerArea Property

[image]

Revit 2024 API
FillPattern..::..LengthPerArea Property
FillPattern Class See Also Send Feedback
Gets length of all lines that placed on unit area.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double LengthPerArea { get; }
Visual Basic
Public ReadOnly Property LengthPerArea As Double
    Get
Visual C++
public:
property double LengthPerArea {
    double get ();
}

See Also

FillPattern Class


LinesPerLength Property

[image]

Revit 2024 API
FillPattern..::..LinesPerLength Property
FillPattern Class See Also Send Feedback
Gets the number of solid lines that placed in unit length.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double LinesPerLength { get; }
Visual Basic
Public ReadOnly Property LinesPerLength As Double
    Get
Visual C++
public:
property double LinesPerLength {
    double get ();
}

See Also

FillPattern Class


Name Property

[image]

Revit 2024 API
FillPattern..::..Name Property
FillPattern Class See Also Send Feedback
The name of the fill pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Remarks

The name of solid fill patterns cannot be changed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

FillPattern Class


StrokesPerArea Property

[image]

Revit 2024 API
FillPattern..::..StrokesPerArea Property
FillPattern Class See Also Send Feedback
Gets the number of strokes that placed on unit area.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double StrokesPerArea { get; }
Visual Basic
Public ReadOnly Property StrokesPerArea As Double
    Get
Visual C++
public:
property double StrokesPerArea {
    double get ();
}

See Also

FillPattern Class


Target Property

[image]

Revit 2024 API
FillPattern..::..Target Property
FillPattern Class See Also Send Feedback
Target of this fill pattern applied to.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FillPatternTarget Target { get; set; }
Visual Basic
Public Property Target As FillPatternTarget
    Get
    Set
Visual C++
public:
property FillPatternTarget Target {
    FillPatternTarget get ();
    void set (FillPatternTarget value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

FillPattern Class


FillPatternElement Class

[image]

Revit 2024 API
FillPatternElement Class
Members See Also Send Feedback
An element that represents a fill pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public class FillPatternElement : Element
Visual Basic
Public Class FillPatternElement _
    Inherits Element
Visual C++
public ref class FillPatternElement : public Element

Remarks

The FillPatternElement represents a fill pattern in a project. It enables the user to retrieve, modify or create a fill pattern in a project.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..FillPatternElement

See Also

FillPatternElement Members


FillPatternElement Members

[image] [image]

Revit 2024 API
FillPatternElement Members
FillPatternElement Class Methods Properties See Also Send Feedback

The FillPatternElement type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create | Creates a new FillPatternElement.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetFillPattern | Gets the FillPattern associated to this element.
 | GetFillPatternElementByName | Retrieves the FillPatternElement by its name.
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetFillPattern | Sets the FillPattern associated to this element.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FillPatternElement Class


Create Method

[image]

Revit 2024 API
FillPatternElement..::..Create Method
FillPatternElement Class Example See Also Send Feedback
Creates a new FillPatternElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static FillPatternElement Create(
    Document document,
    FillPattern fillPattern
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    fillPattern As FillPattern _
) As FillPatternElement
Visual C++
public:
static FillPatternElement^ Create(
    Document^ document,
    FillPattern^ fillPattern
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which to create the FillPatternElement.
fillPattern
Type: Autodesk.Revit.DB..::..FillPattern
The FillPattern associated to the newly created FillPatternElement.

Return Value

The newly created FillPatternElement.

Examples

CopyC#
// Create a complex fill pattern
public void CreateComplexFillPattern(Document doc)
{
    // Create the fill pattern
    FillPattern fillPattern = new FillPattern("API-created", FillPatternTarget.Model,
                                              FillPatternHostOrientation.ToHost);

    // Add grids
    List<FillGrid> grids = new List<FillGrid>();

    //Horizontal lines.
    // The arguments: origin, offset (vertical distance between lines),
    // angle, shift (delta between location of start point per line)
    // The last two arguments are the segments: e.g. 1.0 units on,
    // 0.1 units off (units are Revit units (ft))
    grids.Add(CreateGrid(new UV(0, 0.1), 0.5, 0, 0.55, 1.0, 0.1));
    grids.Add(CreateGrid(new UV(0, 0.5), 0.5, 0, 0.55, 1.0, 0.1));

    // Vertical lines.
    grids.Add(CreateGrid(new UV(0, 0.1), 0.55, Math.PI / 2, 0.5, 0.4, 0.6));
    grids.Add(CreateGrid(new UV(1.0, 0.1), 0.55, Math.PI / 2, 0.5, 0.4, 0.6));

    fillPattern.SetFillGrids(grids);

    // Create the fill pattern element. Now document is modified; transaction is needed
    using (Transaction t = new Transaction(doc, "Create fill pattern"))
    {
       t.Start();
       FillPatternElement patternElement = FillPatternElement.Create(doc, fillPattern);
       t.Commit();
    }
}

// Creates and returns a new fill grid
private FillGrid CreateGrid(UV origin, double offset, double angle,
                            double shift, params double[] segments)
{
    FillGrid fillGrid = new FillGrid();
    fillGrid.Origin = origin;
    fillGrid.Offset = offset;
    fillGrid.Angle = angle;
    fillGrid.Shift = shift;
    List<double> segmentsList = new List<double>();
    foreach (double d in segments)
    {
        segmentsList.Add(d);
    }
    fillGrid.SetSegments(segmentsList);

    return fillGrid;
}
CopyVB.NET
' Create a complex fill pattern
Public Sub CreateComplexFillPattern(doc As Document)
    ' Create the fill pattern
    Dim fillPattern As New FillPattern("API-created", FillPatternTarget.Model, FillPatternHostOrientation.ToHost)

    ' Add grids
    Dim grids As New List(Of FillGrid)()

    'Horizontal lines.
    ' The arguments: origin, offset (vertical distance between lines),
    ' angle, shift (delta between location of start point per line)
    ' The last two arguments are the segments: e.g. 1.0 units on,
    ' 0.1 units off (units are Revit units (ft))
    grids.Add(CreateGrid(New UV(0, 0.1), 0.5, 0, 0.55, 1.0, 0.1))
    grids.Add(CreateGrid(New UV(0, 0.5), 0.5, 0, 0.55, 1.0, 0.1))

    ' Vertical lines.
    grids.Add(CreateGrid(New UV(0, 0.1), 0.55, Math.PI / 2, 0.5, 0.4, 0.6))
    grids.Add(CreateGrid(New UV(1.0, 0.1), 0.55, Math.PI / 2, 0.5, 0.4, 0.6))

    fillPattern.SetFillGrids(grids)

    ' Create the fill pattern element. Now document is modified; transaction is needed
    Using t As New Transaction(doc, "Create fill pattern")
        t.Start()
        Dim patternElement As FillPatternElement = FillPatternElement.Create(doc, fillPattern)
        t.Commit()
    End Using
End Sub

' Creates and returns a new fill grid
Private Function CreateGrid(origin As UV, offset As Double, angle As Double, shift As Double, ParamArray segments As Double()) As FillGrid
    Dim fillGrid As New FillGrid()
    fillGrid.Origin = origin
    fillGrid.Offset = offset
    fillGrid.Angle = angle
    fillGrid.Shift = shift
    Dim segmentsList As New List(Of Double)()
    For Each d As Double In segments
        segmentsList.Add(d)
    Next
    fillGrid.SetSegments(segmentsList)

    Return fillGrid
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | fillPattern does not have a valid Target. -or- fillPattern does not have a valid Name. -or- fillPattern is a solid fill pattern. -or- fillPattern contains FillGrids with a zero Offset. -or- The name of the fillPattern already exists.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FillPatternElement Class


GetFillPattern Method

[image]

Revit 2024 API
FillPatternElement..::..GetFillPattern Method
FillPatternElement Class See Also Send Feedback
Gets the FillPattern associated to this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public FillPattern GetFillPattern()
Visual Basic
Public Function GetFillPattern As FillPattern
Visual C++
public:
FillPattern^ GetFillPattern()

Return Value

A copy of FillPattern object.

See Also

FillPatternElement Class


GetFillPatternElementByName Method

[image]

Revit 2024 API
FillPatternElement..::..GetFillPatternElementByName Method
FillPatternElement Class See Also Send Feedback
Retrieves the FillPatternElement by its name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static FillPatternElement GetFillPatternElementByName(
    Document document,
    FillPatternTarget target,
    string name
)
Visual Basic
Public Shared Function GetFillPatternElementByName ( _
    document As Document, _
    target As FillPatternTarget, _
    name As String _
) As FillPatternElement
Visual C++
public:
static FillPatternElement^ GetFillPatternElementByName(
    Document^ document,
    FillPatternTarget target,
    String^ name
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which to retrieve the FillPatternElement.
target
Type: Autodesk.Revit.DB..::..FillPatternTarget
The FillPatternTarget of the FillPatternElement.
name
Type: System..::..String
The name of the FillPatternElement.

Return Value

The FillPatternElement.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | target must be Model or Drafting.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

FillPatternElement Class


SetFillPattern Method

[image]

Revit 2024 API
FillPatternElement..::..SetFillPattern Method
FillPatternElement Class See Also Send Feedback
Sets the FillPattern associated to this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public void SetFillPattern(
    FillPattern newFillPattern
)
Visual Basic
Public Sub SetFillPattern ( _
    newFillPattern As FillPattern _
)
Visual C++
public:
void SetFillPattern(
    FillPattern^ newFillPattern
)

Parameters

newFillPattern
Type: Autodesk.Revit.DB..::..FillPattern
The new FillPattern object.

Remarks

The data stored inside the input FillPattern will be copied into this element. The input FillPattern itself will not be associated with the element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | newFillPattern does not have a valid Target. -or- newFillPattern does not have a valid Name. -or- newFillPattern is a solid fill pattern. -or- newFillPattern contains FillGrids with a zero Offset. -or- The name of the newFillPattern already exists.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The element is the build-in solid fill pattern element and can not be modified.

See Also

FillPatternElement Class


Parameter Property

[image] [image]

Revit 2024 API
FillPatternElement..::..Parameter Property
FillPatternElement Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

FillPatternElement Class
FillPatternElement Members


FillPatternHostOrientation Enumeration

[image]

Revit 2024 API
FillPatternHostOrientation Enumeration
See Also Send Feedback
The types of orientations for fill patterns.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public enum FillPatternHostOrientation
Visual Basic
Public Enumeration FillPatternHostOrientation
Visual C++
public enum class FillPatternHostOrientation

Members

Member name | Description
ToView | All patterns share the same orientation and origin with respect to view, so they perfectly align at element transitions.
AsText | Mimics the behavior of text. Patterns align with the host and share the same origin with respect to view.
ToHost | Patterns align with the host and compute a origin to fit the host.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


FillPatternTarget Enumeration

[image]

Revit 2024 API
FillPatternTarget Enumeration
See Also Send Feedback
The type of the fill pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public enum FillPatternTarget
Visual Basic
Public Enumeration FillPatternTarget
Visual C++
public enum class FillPatternTarget

Members

Member name | Description
Drafting | Represents a material in symbolic form.
Model | Represents an actual element appearance on a building.
None |

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


FilterableValueProvider Class

[image]

Revit 2024 API
FilterableValueProvider Class
Members See Also Send Feedback
Defines the interface for classes that extract values from elements in a Revit project for testing against filter rules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class FilterableValueProvider : IDisposable
Visual Basic
Public Class FilterableValueProvider _
    Implements IDisposable
Visual C++
public ref class FilterableValueProvider : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterableValueProvider
Autodesk.Revit.DB..::..ParameterValueProvider

See Also

FilterableValueProvider Members


FilterableValueProvider Members

[image] [image]

Revit 2024 API
FilterableValueProvider Members
FilterableValueProvider Class Methods Properties See Also Send Feedback

The FilterableValueProvider type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FilterableValueProvider
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAssociatedGlobalParameterValue | Gets a global parameter value associated with a parameter from the given element.
Public method | GetDoubleValue | Gets a double-precision numeric value from the given element.
Public method | GetElementIdValue | Gets an ElementId value from the given element.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIntegerValue | Gets an integer value from the given element.
Public method | GetStringValue | Gets a string value from the given element.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDoubleValueSupported | Determines whether the provide can provide a double-precision numeric value for the given element.
Public method | IsElementIdValueSupported | Determines whether the provide can provide an ElementId value for the given element.
Public method | IsIntegerValueSupported | Determines whether the provide can provide an integer value for the given element.
Public method | IsStringValueSupported | Determines whether the provide can provide a string value for the given element.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

FilterableValueProvider Class


FilterableValueProvider Methods

[image] [image]

Revit 2024 API
FilterableValueProvider Methods
FilterableValueProvider Class See Also Send Feedback

The FilterableValueProvider type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAssociatedGlobalParameterValue | Gets a global parameter value associated with a parameter from the given element.
Public method | GetDoubleValue | Gets a double-precision numeric value from the given element.
Public method | GetElementIdValue | Gets an ElementId value from the given element.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIntegerValue | Gets an integer value from the given element.
Public method | GetStringValue | Gets a string value from the given element.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDoubleValueSupported | Determines whether the provide can provide a double-precision numeric value for the given element.
Public method | IsElementIdValueSupported | Determines whether the provide can provide an ElementId value for the given element.
Public method | IsIntegerValueSupported | Determines whether the provide can provide an integer value for the given element.
Public method | IsStringValueSupported | Determines whether the provide can provide a string value for the given element.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FilterableValueProvider Class


Dispose Method

[image]

Revit 2024 API
FilterableValueProvider..::..Dispose Method
FilterableValueProvider Class See Also Send Feedback
Releases all resources used by the FilterableValueProvider

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FilterableValueProvider Class


GetDoubleValue Method

[image]

Revit 2024 API
FilterableValueProvider..::..GetDoubleValue Method
FilterableValueProvider Class See Also Send Feedback
Gets a double-precision numeric value from the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public double GetDoubleValue(
    Element element
)
Visual Basic
Public Function GetDoubleValue ( _
    element As Element _
) As Double
Visual C++
public:
double GetDoubleValue(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The element to query.

Return Value

The double-precision numeric value from the element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FilterableValueProvider Class


GetElementIdValue Method

[image]

Revit 2024 API
FilterableValueProvider..::..GetElementIdValue Method
FilterableValueProvider Class See Also Send Feedback
Gets an ElementId value from the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public ElementId GetElementIdValue(
    Element element
)
Visual Basic
Public Function GetElementIdValue ( _
    element As Element _
) As ElementId
Visual C++
public:
ElementId^ GetElementIdValue(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The element to query.

Return Value

The ElementId value from the element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FilterableValueProvider Class


GetIntegerValue Method

[image]

Revit 2024 API
FilterableValueProvider..::..GetIntegerValue Method
FilterableValueProvider Class See Also Send Feedback
Gets an integer value from the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public int GetIntegerValue(
    Element element
)
Visual Basic
Public Function GetIntegerValue ( _
    element As Element _
) As Integer
Visual C++
public:
int GetIntegerValue(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The element to query.

Return Value

The integer value from the element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FilterableValueProvider Class


GetStringValue Method

[image]

Revit 2024 API
FilterableValueProvider..::..GetStringValue Method
FilterableValueProvider Class See Also Send Feedback
Gets a string value from the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public string GetStringValue(
    Element element
)
Visual Basic
Public Function GetStringValue ( _
    element As Element _
) As String
Visual C++
public:
String^ GetStringValue(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The element to query.

Return Value

The string value from the element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FilterableValueProvider Class


IsDoubleValueSupported Method

[image]

Revit 2024 API
FilterableValueProvider..::..IsDoubleValueSupported Method
FilterableValueProvider Class See Also Send Feedback
Determines whether the provide can provide a double-precision numeric value for the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool IsDoubleValueSupported(
    Element element
)
Visual Basic
Public Function IsDoubleValueSupported ( _
    element As Element _
) As Boolean
Visual C++
public:
bool IsDoubleValueSupported(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The element to query.

Return Value

True if the provider can return a double-precision numeric value for the given element, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FilterableValueProvider Class


IsElementIdValueSupported Method

[image]

Revit 2024 API
FilterableValueProvider..::..IsElementIdValueSupported Method
FilterableValueProvider Class See Also Send Feedback
Determines whether the provide can provide an ElementId value for the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool IsElementIdValueSupported(
    Element element
)
Visual Basic
Public Function IsElementIdValueSupported ( _
    element As Element _
) As Boolean
Visual C++
public:
bool IsElementIdValueSupported(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The element to query.

Return Value

True if the provider can return an ElementId value for the given element, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FilterableValueProvider Class


IsIntegerValueSupported Method

[image]

Revit 2024 API
FilterableValueProvider..::..IsIntegerValueSupported Method
FilterableValueProvider Class See Also Send Feedback
Determines whether the provide can provide an integer value for the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool IsIntegerValueSupported(
    Element element
)
Visual Basic
Public Function IsIntegerValueSupported ( _
    element As Element _
) As Boolean
Visual C++
public:
bool IsIntegerValueSupported(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The element to query.

Return Value

True if the provider can return an integer value for the given element, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FilterableValueProvider Class


IsStringValueSupported Method

[image]

Revit 2024 API
FilterableValueProvider..::..IsStringValueSupported Method
FilterableValueProvider Class See Also Send Feedback
Determines whether the provide can provide a string value for the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool IsStringValueSupported(
    Element element
)
Visual Basic
Public Function IsStringValueSupported ( _
    element As Element _
) As Boolean
Visual C++
public:
bool IsStringValueSupported(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The element to query.

Return Value

True if the provider can return a string value for the given element, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FilterableValueProvider Class


FilterableValueProvider Properties

[image] [image]

Revit 2024 API
FilterableValueProvider Properties
FilterableValueProvider Class See Also Send Feedback

The FilterableValueProvider type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

FilterableValueProvider Class


IsValidObject Property

[image]

Revit 2024 API
FilterableValueProvider..::..IsValidObject Property
FilterableValueProvider Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

FilterableValueProvider Class


FilterCategoryRule Class

[image]

Revit 2024 API
FilterCategoryRule Class
Members See Also Send Feedback
A filter rule that matches elements of a set of categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class FilterCategoryRule : FilterRule
Visual Basic
Public Class FilterCategoryRule _
    Inherits FilterRule
Visual C++
public ref class FilterCategoryRule : public FilterRule

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterRule
Autodesk.Revit.DB..::..FilterCategoryRule

See Also

FilterCategoryRule Members


FilterCategoryRule Members

[image] [image]

Revit 2024 API
FilterCategoryRule Members
FilterCategoryRule Class Constructors Methods Properties See Also Send Feedback

The FilterCategoryRule type exposes the following members.

Constructors

 | Name | Description
Public method | FilterCategoryRule | Constructs a new instance of FilterCategoryRule.

Methods

 | Name | Description
 | AllCategoriesFilterable | Checks that all of the given categories are filterable.
Public method | Dispose | (Inherited from FilterRule.)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCategories | Gets the rule's categories.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter. (Inherited from FilterRule.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetCategories | Sets the rule's categories.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterRule.)

See Also

FilterCategoryRule Class


FilterCategoryRule Constructor

[image]

Revit 2024 API
FilterCategoryRule Constructor
FilterCategoryRule Class See Also Send Feedback
Constructs a new instance of FilterCategoryRule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public FilterCategoryRule(
    ICollection<ElementId> categories
)
Visual Basic
Public Sub New ( _
    categories As ICollection(Of ElementId) _
)
Visual C++
public:
FilterCategoryRule(
    ICollection<ElementId^>^ categories
)

Parameters

categories
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
The set of categories.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FilterCategoryRule Class


FilterCategoryRule Methods

[image] [image]

Revit 2024 API
FilterCategoryRule Methods
FilterCategoryRule Class See Also Send Feedback

The FilterCategoryRule type exposes the following members.

Methods

 | Name | Description
 | AllCategoriesFilterable | Checks that all of the given categories are filterable.
Public method | Dispose | (Inherited from FilterRule.)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCategories | Gets the rule's categories.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter. (Inherited from FilterRule.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetCategories | Sets the rule's categories.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FilterCategoryRule Class


GetCategories Method

[image]

Revit 2024 API
FilterCategoryRule..::..GetCategories Method
FilterCategoryRule Class See Also Send Feedback
Gets the rule's categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ICollection<ElementId> GetCategories()
Visual Basic
Public Function GetCategories As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetCategories()

See Also

FilterCategoryRule Class


SetCategories Method

[image]

Revit 2024 API
FilterCategoryRule..::..SetCategories Method
FilterCategoryRule Class See Also Send Feedback
Sets the rule's categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool SetCategories(
    ICollection<ElementId> categories
)
Visual Basic
Public Function SetCategories ( _
    categories As ICollection(Of ElementId) _
) As Boolean
Visual C++
public:
bool SetCategories(
    ICollection<ElementId^>^ categories
)

Parameters

categories
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
The categories.

Return Value

True if the set of categories was changed, false if no change was necessary.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | One of the given categories is not filterable
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FilterCategoryRule Class


FilterCategoryRule Properties

[image] [image]

Revit 2024 API
FilterCategoryRule Properties
FilterCategoryRule Class See Also Send Feedback

The FilterCategoryRule type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterRule.)

See Also

FilterCategoryRule Class


FilterDoubleRule Class

[image]

Revit 2024 API
FilterDoubleRule Class
Members See Also Send Feedback
A filter rule that operates on double-precision numeric values in a Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class FilterDoubleRule : FilterNumericValueRule
Visual Basic
Public Class FilterDoubleRule _
    Inherits FilterNumericValueRule
Visual C++
public ref class FilterDoubleRule : public FilterNumericValueRule

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterRule
Autodesk.Revit.DB..::..FilterValueRule
Autodesk.Revit.DB..::..FilterNumericValueRule
Autodesk.Revit.DB..::..FilterDoubleRule

See Also

FilterDoubleRule Members


FilterDoubleRule Constructor

[image]

Revit 2024 API
FilterDoubleRule Constructor
FilterDoubleRule Class See Also Send Feedback
Constructs an instance of FilterDoubleRule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FilterDoubleRule(
    FilterableValueProvider valueProvider,
    FilterNumericRuleEvaluator evaluator,
    double ruleValue,
    double epsilon
)
Visual Basic
Public Sub New ( _
    valueProvider As FilterableValueProvider, _
    evaluator As FilterNumericRuleEvaluator, _
    ruleValue As Double, _
    epsilon As Double _
)
Visual C++
public:
FilterDoubleRule(
    FilterableValueProvider^ valueProvider,
    FilterNumericRuleEvaluator^ evaluator,
    double ruleValue,
    double epsilon
)

Parameters

valueProvider
Type: Autodesk.Revit.DB..::..FilterableValueProvider
A pointer to a "value provider" object that will extract values from a Revit document.
evaluator
Type: Autodesk.Revit.DB..::..FilterNumericRuleEvaluator
A pointer to the filter rule evaluator object that implements the desired test. The built-in evaluators implement commonly used tests such as less-than, greater-than less-than-or-equal-to, equal, etc.
ruleValue
Type: System..::..Double
The user-supplied value against which values from a Revit document will be tested.
epsilon
Type: System..::..Double
The tolerance within which two floating-point values may be considered equal.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for ruleValue is not finite -or- The given value for ruleValue is not a number -or- The given value for epsilon is not finite -or- The given value for epsilon is not a number
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FilterDoubleRule Class


FilterDoubleRule Properties

[image] [image]

Revit 2024 API
FilterDoubleRule Properties
FilterDoubleRule Class See Also Send Feedback

The FilterDoubleRule type exposes the following members.

Properties

 | Name | Description
Public property | Epsilon | The tolerance within which two floating-point values may be considered equal.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterRule.)
Public property | RuleValue | The user-supplied value against which values from a Revit document will be tested.

See Also

FilterDoubleRule Class


Epsilon Property

[image]

Revit 2024 API
FilterDoubleRule..::..Epsilon Property
FilterDoubleRule Class See Also Send Feedback
The tolerance within which two floating-point values may be considered equal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public double Epsilon { get; set; }
Visual Basic
Public Property Epsilon As Double
    Get
    Set
Visual C++
public:
property double Epsilon {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The given value for epsilon is not finite -or- When setting this property: The given value for epsilon is not a number

See Also

FilterDoubleRule Class


RuleValue Property

[image]

Revit 2024 API
FilterDoubleRule..::..RuleValue Property
FilterDoubleRule Class See Also Send Feedback
The user-supplied value against which values from a Revit document will be tested.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public double RuleValue { get; set; }
Visual Basic
Public Property RuleValue As Double
    Get
    Set
Visual C++
public:
property double RuleValue {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The given value for ruleValue is not finite -or- When setting this property: The given value for ruleValue is not a number

See Also

FilterDoubleRule Class


FilteredElementCollector Class

[image]

Revit 2024 API
FilteredElementCollector Class
Members See Also Send Feedback
This class is used to search, filter and iterate through a set of elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class FilteredElementCollector : IEnumerable<Element>,
    IDisposable
Visual Basic
Public Class FilteredElementCollector _
    Implements IEnumerable(Of Element), IDisposable
Visual C++
public ref class FilteredElementCollector : IEnumerable<Element^>,
    IDisposable

Remarks

Developers can assign a variety of conditions to filter the elements that are returned. This class requires that at least one condition be set before making the attempt to access the elements.

Revit will attempt to organize the filters in order to minimize expansion of elements regardless of the order in which conditions and filters are applied.

There are three groups of methods that you can use on a given collector once you have applied filter(s) to it. One group provides collections of all passing elements, a second finds the first match of the given filter(s), and a third provides an iterator that is evaluated lazily (each element is tested by the filter only when the iterator reaches it). You should only use one of the methods from these group at a time; the collector will reset if you call another method to extract elements. Thus, if you have previously obtained an iterator, it will be stopped and traverse no more elements if you call another method to extract elements.

In .NET, this class supports the IEnumerable interface for Elements. You can use this class with LINQ queries and operations to process lists of elements. Note that because the ElementFilters and the shortcut methods offered by this class process elements in native code before their managed wrappers are generated, better performance will be obtained by using as many native filters as possible on the collector before attempting to process the results using LINQ queries.

One special consideration when using this class in .NET: the debugger will attempt to traverse the members of the collector because of its implementation of IEnumerable. You may see strange results if you also attempt to extract the first element or all elements from the collector while the debugger is also looking at the contents of the collector.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilteredElementCollector

See Also

FilteredElementCollector Members


FilteredElementCollector Members

[image] [image]

Revit 2024 API
FilteredElementCollector Members
FilteredElementCollector Class Constructors Methods Properties See Also Send Feedback

The FilteredElementCollector type exposes the following members.

Constructors

 | Name | Description
Public method | FilteredElementCollector(Document) | Constructs a new FilteredElementCollector that will search and filter the set of elements in a document.
Public method | FilteredElementCollector(Document, ElementId) | Constructs a new FilteredElementCollector that will search and filter the visible elements in a view.
Public method | FilteredElementCollector(Document, ICollection<(Of <<'(ElementId>)>>)) | Constructs a new FilteredElementCollector that will search and filter a specified set of elements.
Public method | FilteredElementCollector(Document, ElementId, ElementId) | Constructs a new FilteredElementCollector that will search and filter the visible elements from a Revit link in a host document view.

Methods

 | Name | Description
Public method | ContainedInDesignOption | Applies an ElementDesignOptionFilter to the collector.
Public method | Dispose | Releases all resources used by the FilteredElementCollector
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Excluding | Applies an ExclusionFilter to the collector.
Public method | FirstElement | Returns the first element to pass the filter(s).
Public method | FirstElementId | Returns the id of the first element to pass the filter(s).
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetElementCount | Gets the number of elements in your current filter.
Public method | GetElementIdIterator | Returns an element id iterator to the elements passing the filters.
Public method | GetElementIterator | Returns an element iterator to the elements passing the filters.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectWith | Intersects the set of elements passing the filter in this collector with the set of elements passing the filter in another collector.
 | IsViewValidForElementIteration | Identifies if the particular element is valid for iteration of drawn elements.
Public method | OfCategory | Applies an ElementCategoryFilter to the collector.
Public method | OfCategoryId | Applies an ElementCategoryFilter to the collector.
Public method | OfClass | Applies an ElementClassFilter to the collector.
Public method | OwnedByView | Applies an ElementOwnerViewFilter to the collector.
Public method | ToElementIds | Returns the complete set of element ids that pass the filter(s).
Public method | ToElements | Returns the complete set of elements that pass the filter(s).
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnionWith | Unites the set of elements passing the filter in this collector with the set of elements passing the filter in another collector.
Public method | WhereElementIsCurveDriven | Applies an ElementIsCurveDrivenFilter to the collector.
Public method | WhereElementIsElementType | Applies an ElementIsElementTypeFilter to the collector.
Public method | WhereElementIsNotElementType | Applies an inverted ElementIsElementTypeFilter to the collector.
Public method | WhereElementIsViewIndependent | Applies an ElementOwnerViewFilter to the collector.
Public method | WherePasses | Applies an element filter to the collector.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

FilteredElementCollector Class


FilteredElementCollector Constructor

[image] [image]

Revit 2024 API
FilteredElementCollector Constructor
FilteredElementCollector Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FilteredElementCollector(Document) | Constructs a new FilteredElementCollector that will search and filter the set of elements in a document.
Public method | FilteredElementCollector(Document, ElementId) | Constructs a new FilteredElementCollector that will search and filter the visible elements in a view.
Public method | FilteredElementCollector(Document, ICollection<(Of <<'(ElementId>)>>)) | Constructs a new FilteredElementCollector that will search and filter a specified set of elements.
Public method | FilteredElementCollector(Document, ElementId, ElementId) | Constructs a new FilteredElementCollector that will search and filter the visible elements from a Revit link in a host document view.

See Also

FilteredElementCollector Class
FilteredElementCollector Members


FilteredElementCollector Constructor (Document)

[image]

Revit 2024 API
FilteredElementCollector Constructor (Document)
FilteredElementCollector Class See Also Send Feedback
Constructs a new FilteredElementCollector that will search and filter the set of elements in a document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FilteredElementCollector(
    Document document
)
Visual Basic
Public Sub New ( _
    document As Document _
)
Visual C++
public:
FilteredElementCollector(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FilteredElementCollector Class
FilteredElementCollector Overload


FilteredElementCollector Constructor (Document, ElementId)

[image]

Revit 2024 API
FilteredElementCollector Constructor (Document, ElementId)
FilteredElementCollector Class Example See Also Send Feedback
Constructs a new FilteredElementCollector that will search and filter the visible elements in a view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FilteredElementCollector(
    Document document,
    ElementId viewId
)
Visual Basic
Public Sub New ( _
    document As Document, _
    viewId As ElementId _
)
Visual C++
public:
FilteredElementCollector(
    Document^ document,
    ElementId^ viewId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document that owns the view.
viewId
Type: Autodesk.Revit.DB..::..ElementId
The view id.

Remarks

Elements that will be passed by the collector have graphics that may be visible in the input view. Some elements may still be hidden because they are obscured by other elements.

For elements which are outside of a crop region, they may still be passed by the collector because Revit relies on later processing to eliminate the elements hidden by the crop. This effect may more easily occur for non-rectangular crop regions, but may also happen even for rectangular crops. You can compare the boundary of the region with the element's boundary if more precise results are required.

Accessing these visible elements may require Revit to rebuild the geometry of the view. The first time your code constructs a collector for a given view, or the first time your code constructs a collector for a view whose display settings have just been changed, you may experience a significant performance degradation.

Examples

CopyC#
private void CountElements(UIDocument uiDoc)
{
    StringBuilder message = new StringBuilder();
    FilteredElementCollector viewCollector =
        new FilteredElementCollector(uiDoc.Document, uiDoc.ActiveView.Id);
    viewCollector.OfCategory(BuiltInCategory.OST_Walls);
    message.AppendLine("Wall category elements within active View: "
       + viewCollector.ToElementIds().Count);

    FilteredElementCollector docCollector = new FilteredElementCollector(uiDoc.Document);
    docCollector.OfCategory(BuiltInCategory.OST_Walls);
    message.AppendLine("Wall category elements within document: "
       + docCollector.ToElementIds().Count);

    TaskDialog.Show("Revit", message.ToString());
}
CopyC#
public static void GetScheduleContents(ViewSchedule viewSchedule)
{
    // Collect types displayed in the schedule
    FilteredElementCollector typeCollector = new FilteredElementCollector(viewSchedule.Document, viewSchedule.Id);
    typeCollector.WhereElementIsElementType();

    int numberOfTypes = typeCollector.Count();

    // Collect instances displayed in the schedule
    FilteredElementCollector instCollector = new FilteredElementCollector(viewSchedule.Document, viewSchedule.Id);
    instCollector.WhereElementIsNotElementType();

    int numberOfInstances = instCollector.Count();

    TaskDialog.Show("Elements in schedule", String.Format("Types {0} instances {1}", numberOfTypes, numberOfInstances));
}
CopyVB.NET
Private Sub CountElements(uiDoc As UIDocument)
   Dim message As New StringBuilder()
   Dim viewCollector As New FilteredElementCollector(uiDoc.Document, uiDoc.ActiveView.Id)
   viewCollector.OfCategory(BuiltInCategory.OST_Walls)
   message.AppendLine("Wall category elements within active View: " + viewCollector.ToElementIds().Count)

   Dim docCollector As New FilteredElementCollector(uiDoc.Document)
   docCollector.OfCategory(BuiltInCategory.OST_Walls)
   message.AppendLine("Wall category elements within document: " + docCollector.ToElementIds().Count)

   TaskDialog.Show("Revit", message.ToString())
End Sub
CopyVB.NET
Public Shared Sub GetScheduleContents(viewSchedule As ViewSchedule)
    ' Collect types displayed in the schedule
    Dim typeCollector As New FilteredElementCollector(viewSchedule.Document, viewSchedule.Id)
    typeCollector.WhereElementIsElementType()

    Dim numberOfTypes As Integer = typeCollector.Count()

    ' Collect instances displayed in the schedule
    Dim instCollector As New FilteredElementCollector(viewSchedule.Document, viewSchedule.Id)
    instCollector.WhereElementIsNotElementType()

    Dim numberOfInstances As Integer = instCollector.Count()

    TaskDialog.Show("Elements in schedule", [String].Format("Types {0} instances {1}", numberOfTypes, numberOfInstances))
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | viewId is not a view. -or- viewId is not valid for element iteration, because it has no way of representing drawn elements. Many view templates will fail this check.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FilteredElementCollector Class
FilteredElementCollector Overload


FilteredElementCollector Constructor (Document, ICollection(ElementId))

[image]

Revit 2024 API
FilteredElementCollector Constructor (Document, ICollection<(Of <(<'ElementId>)>)>)
FilteredElementCollector Class See Also Send Feedback
Constructs a new FilteredElementCollector that will search and filter a specified set of elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FilteredElementCollector(
    Document document,
    ICollection<ElementId> elementIds
)
Visual Basic
Public Sub New ( _
    document As Document, _
    elementIds As ICollection(Of ElementId) _
)
Visual C++
public:
FilteredElementCollector(
    Document^ document,
    ICollection<ElementId^>^ elementIds
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document that owns the elements matching the element ids.
elementIds
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
The input set of element ids.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input collection of ids was empty, or its contents were not valid for iteration.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FilteredElementCollector Class
FilteredElementCollector Overload


FilteredElementCollector Constructor (Document, ElementId, ElementId)

[image]

Revit 2024 API
FilteredElementCollector Constructor (Document, ElementId, ElementId)
FilteredElementCollector Class See Also Send Feedback
Constructs a new FilteredElementCollector that will search and filter the visible elements from a Revit link in a host document view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public FilteredElementCollector(
    Document hostDocument,
    ElementId viewId,
    ElementId linkId
)
Visual Basic
Public Sub New ( _
    hostDocument As Document, _
    viewId As ElementId, _
    linkId As ElementId _
)
Visual C++
public:
FilteredElementCollector(
    Document^ hostDocument,
    ElementId^ viewId,
    ElementId^ linkId
)

Parameters

hostDocument
Type: Autodesk.Revit.DB..::..Document
The document that owns the view.
viewId
Type: Autodesk.Revit.DB..::..ElementId
The view id in the host document.
linkId
Type: Autodesk.Revit.DB..::..ElementId
The Revit link instance id in the host document.

Remarks

Only visible elements belonging to the link instance will be returned. Other instances of that link may have different element visibility in a given view.

Elements that will be passed by the collector have graphics that may be visible in the input view. Some elements may still be hidden because they are obscured by other elements.

For elements which are outside of a crop region, they may still be passed by the collector because Revit relies on later processing to eliminate the elements hidden by the crop. This effect may more easily occur for non-rectangular crop regions, but may also happen even for rectangular crops. You can compare the boundary of the region with the element's boundary if more precise results are required.

Accessing these visible elements may require Revit to rebuild the geometry of the view. The first time your code constructs a collector for a given view, or the first time your code constructs a collector for a view whose display settings have just been changed, you may experience a significant performance degradation.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | viewId is not a view. -or- linkId does not refer to a valid link document. -or- viewId is not valid for element iteration, because it has no way of representing drawn elements. Many view templates will fail this check.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FilteredElementCollector Class
FilteredElementCollector Overload


FilteredElementCollector Methods

[image] [image]

Revit 2024 API
FilteredElementCollector Methods
FilteredElementCollector Class See Also Send Feedback

The FilteredElementCollector type exposes the following members.

Methods

 | Name | Description
Public method | ContainedInDesignOption | Applies an ElementDesignOptionFilter to the collector.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Excluding | Applies an ExclusionFilter to the collector.
Public method | FirstElement | Returns the first element to pass the filter(s).
Public method | FirstElementId | Returns the id of the first element to pass the filter(s).
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetElementCount | Gets the number of elements in your current filter.
Public method | GetElementIdIterator | Returns an element id iterator to the elements passing the filters.
Public method | GetElementIterator | Returns an element iterator to the elements passing the filters.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectWith | Intersects the set of elements passing the filter in this collector with the set of elements passing the filter in another collector.
 | IsViewValidForElementIteration | Identifies if the particular element is valid for iteration of drawn elements.
Public method | OfCategory | Applies an ElementCategoryFilter to the collector.
Public method | OfCategoryId | Applies an ElementCategoryFilter to the collector.
Public method | OfClass | Applies an ElementClassFilter to the collector.
Public method | OwnedByView | Applies an ElementOwnerViewFilter to the collector.
Public method | ToElementIds | Returns the complete set of element ids that pass the filter(s).
Public method | ToElements | Returns the complete set of elements that pass the filter(s).
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnionWith | Unites the set of elements passing the filter in this collector with the set of elements passing the filter in another collector.
Public method | WhereElementIsCurveDriven | Applies an ElementIsCurveDrivenFilter to the collector.
Public method | WhereElementIsElementType | Applies an ElementIsElementTypeFilter to the collector.
Public method | WhereElementIsNotElementType | Applies an inverted ElementIsElementTypeFilter to the collector.
Public method | WhereElementIsViewIndependent | Applies an ElementOwnerViewFilter to the collector.
Public method | WherePasses | Applies an element filter to the collector.

See Also

FilteredElementCollector Class


ContainedInDesignOption Method

[image]

Revit 2024 API
FilteredElementCollector..::..ContainedInDesignOption Method
FilteredElementCollector Class See Also Send Feedback
Applies an ElementDesignOptionFilter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FilteredElementCollector ContainedInDesignOption(
    ElementId designOptionId
)
Visual Basic
Public Function ContainedInDesignOption ( _
    designOptionId As ElementId _
) As FilteredElementCollector
Visual C++
public:
FilteredElementCollector^ ContainedInDesignOption(
    ElementId^ designOptionId
)

Parameters

designOptionId
Type: Autodesk.Revit.DB..::..ElementId
The design option id.

Return Value

A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Remarks

Only elements that are contained by this particular design option will pass the collector. If you have an active iterator to this collector it will be stopped by this call.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FilteredElementCollector Class


Dispose Method

[image]

Revit 2024 API
FilteredElementCollector..::..Dispose Method
FilteredElementCollector Class See Also Send Feedback
Releases all resources used by the FilteredElementCollector

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FilteredElementCollector Class


Excluding Method

[image]

Revit 2024 API
FilteredElementCollector..::..Excluding Method
FilteredElementCollector Class See Also Send Feedback
Applies an ExclusionFilter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FilteredElementCollector Excluding(
    ICollection<ElementId> idsToExclude
)
Visual Basic
Public Function Excluding ( _
    idsToExclude As ICollection(Of ElementId) _
) As FilteredElementCollector
Visual C++
public:
FilteredElementCollector^ Excluding(
    ICollection<ElementId^>^ idsToExclude
)

Parameters

idsToExclude
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
The ids to exclude from the results.

Return Value

A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Remarks

Elements passed to this filter will be automatically excluded from the results. If you have an active iterator to this collector it will be stopped by this call.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input collection of ids was empty, or its contents were not valid for iteration.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FilteredElementCollector Class


FirstElement Method

[image]

Revit 2024 API
FilteredElementCollector..::..FirstElement Method
FilteredElementCollector Class Example See Also Send Feedback
Returns the first element to pass the filter(s).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public Element FirstElement()
Visual Basic
Public Function FirstElement As Element
Visual C++
public:
Element^ FirstElement()

Return Value

The first element.

Remarks

This will reset the collector to the beginning and find the first element that passes the applied filter(s). If you have an active iterator to this same collector it will be stopped by this call.

Examples

CopyC#
public FamilyInstance GetAColumn(Autodesk.Revit.DB.Document document)
{
    // Create a filter to find all columns
    StructuralInstanceUsageFilter columnFilter =
        new StructuralInstanceUsageFilter(StructuralInstanceUsage.Column);

    // Apply the filter to the elements in the active document
    FilteredElementCollector collector = new FilteredElementCollector(document);
    collector.WherePasses(columnFilter);

    // Get the first column from the filtered results
    // Element will be a FamilyInstance
    FamilyInstance column = collector.FirstElement() as FamilyInstance;

    return column;
}
CopyVB.NET
Public Function GetAColumn(document As Autodesk.Revit.DB.Document) As FamilyInstance
   ' Create a filter to find all columns
   Dim columnFilter As New StructuralInstanceUsageFilter(StructuralInstanceUsage.Column)

   ' Apply the filter to the elements in the active document
   Dim collector As New FilteredElementCollector(document)
   collector.WherePasses(columnFilter)

   ' Get the first column from the filtered results
   ' Element will be a FamilyInstance
   Dim column As FamilyInstance = TryCast(collector.FirstElement(), FamilyInstance)

   Return column
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter.

See Also

FilteredElementCollector Class


FirstElementId Method

[image]

Revit 2024 API
FilteredElementCollector..::..FirstElementId Method
FilteredElementCollector Class Example See Also Send Feedback
Returns the id of the first element to pass the filter(s).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public ElementId FirstElementId()
Visual Basic
Public Function FirstElementId As ElementId
Visual C++
public:
ElementId^ FirstElementId()

Return Value

The first element id.

Remarks

This will reset the collector to the beginning and find the first element that passes the applied filter(s). If you have an active iterator to this same collector it will be stopped by this call.

Examples

CopyC#
FilteredElementCollector collector = new FilteredElementCollector(document);

// Use shortcut OfClass to get View elements
collector.OfClass(typeof(View3D));

// Get the Id of the first view
ElementId viewId = collector.FirstElementId();

// Test if the view is valid for element filtering
if (FilteredElementCollector.IsViewValidForElementIteration(document, viewId))
{
    FilteredElementCollector viewCollector = new FilteredElementCollector(document, viewId);

    // Get all FamilyInstance items in the view and delete them
    viewCollector.OfClass(typeof(FamilyInstance));
    ICollection<ElementId> familyInstanceIds = viewCollector.ToElementIds();

    document.Delete(familyInstanceIds);
}
CopyVB.NET
Dim collector As New FilteredElementCollector(document)

' Use shortcut OfClass to get View elements
collector.OfClass(GetType(View3D))

' Get the Id of the first view
Dim viewId As ElementId = collector.FirstElementId()

' Test if the view is valid for element filtering
If FilteredElementCollector.IsViewValidForElementIteration(document, viewId) Then
   Dim viewCollector As New FilteredElementCollector(document, viewId)

   ' Get all FamilyInstance items in the view and delete them
   viewCollector.OfClass(GetType(FamilyInstance))
   Dim familyInstanceIds As ICollection(Of ElementId) = viewCollector.ToElementIds()

   document.Delete(familyInstanceIds)
End If

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter.

See Also

FilteredElementCollector Class


GetBasicIEnumerator Method

[image]

Revit 2024 API
FilteredElementCollector..::..GetBasicIEnumerator Method
FilteredElementCollector Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
internal virtual IEnumerator GetBasicIEnumerator()
Visual Basic
Friend Overridable Function GetBasicIEnumerator As IEnumerator
Visual C++
internal:
virtual IEnumerator^ GetBasicIEnumerator()

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

FilteredElementCollector Class


GetElementCount Method

[image]

Revit 2024 API
FilteredElementCollector..::..GetElementCount Method
FilteredElementCollector Class See Also Send Feedback
Gets the number of elements in your current filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public int GetElementCount()
Visual Basic
Public Function GetElementCount As Integer
Visual C++
public:
int GetElementCount()

Return Value

The number of elements

Remarks

Does not require a filter, if called on a new FilteredElementCollector it will return a count of all the elements.

See Also

FilteredElementCollector Class


GetElementIdIterator Method

[image]

Revit 2024 API
FilteredElementCollector..::..GetElementIdIterator Method
FilteredElementCollector Class Example See Also Send Feedback
Returns an element id iterator to the elements passing the filters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FilteredElementIdIterator GetElementIdIterator()
Visual Basic
Public Function GetElementIdIterator As FilteredElementIdIterator
Visual C++
public:
FilteredElementIdIterator^ GetElementIdIterator()

Remarks

Calling this when you have an active iterator to this same collector will result in the first iterator being stopped by this call.

Examples

CopyC#
// Use a RoomFilter to find all room elements in the document.
RoomFilter filter = new RoomFilter();

// Apply the filter to the elements in the active document
FilteredElementCollector collector = new FilteredElementCollector(document);
collector.WherePasses(filter);

// Get results as ElementId iterator
FilteredElementIdIterator roomIdItr = collector.GetElementIdIterator();
roomIdItr.Reset();
while (roomIdItr.MoveNext())
{
    ElementId roomId = roomIdItr.Current;
    // Warn rooms smaller than 50 SF
    Room room = document.GetElement(roomId) as Room;
    if (room.Area < 50.0)
    {
        String prompt = "Room is too small: id = " + roomId.ToString();
        TaskDialog.Show("Revit", prompt);
        break;
    }
}
CopyVB.NET
' Use a RoomFilter to find all room elements in the document.
Dim filter As New RoomFilter()

' Apply the filter to the elements in the active document
Dim collector As New FilteredElementCollector(document)
collector.WherePasses(filter)

' Get results as ElementId iterator
Dim roomIdItr As FilteredElementIdIterator = collector.GetElementIdIterator()
roomIdItr.Reset()
While roomIdItr.MoveNext()
   Dim roomId As ElementId = roomIdItr.Current
   ' Warn rooms smaller than 50 SF
   Dim room As Room = TryCast(document.GetElement(roomId), Room)
   If room.Area < 50.0 Then
      Dim prompt As [String] = "Room is too small: id = " & roomId.ToString()
      TaskDialog.Show("Revit", prompt)
      Exit While
   End If
End While

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter.

See Also

FilteredElementCollector Class


GetElementIterator Method

[image]

Revit 2024 API
FilteredElementCollector..::..GetElementIterator Method
FilteredElementCollector Class Example See Also Send Feedback
Returns an element iterator to the elements passing the filters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FilteredElementIterator GetElementIterator()
Visual Basic
Public Function GetElementIterator As FilteredElementIterator
Visual C++
public:
FilteredElementIterator^ GetElementIterator()

Remarks

Calling this when you have an active iterator to this same collector will result in the first iterator being stopped by this call.

Examples

CopyC#
FilteredElementCollector collector = new FilteredElementCollector(document);

// Apply a filter to get all pipes in the document
collector.OfClass(typeof(Autodesk.Revit.DB.Plumbing.Pipe));

// Get results as an element iterator and look for a pipe with
// a specific flow state
FilteredElementIterator elemItr = collector.GetElementIterator();
elemItr.Reset();
while (elemItr.MoveNext())
{
    Pipe pipe = elemItr.Current as Pipe;
    if (pipe.FlowState == PipeFlowState.LaminarState)
    {
        TaskDialog.Show("Revit", "Model has at least one pipe with Laminar flow state.");
        break;
    }
}
CopyVB.NET
Dim collector As New FilteredElementCollector(document)

' Apply a filter to get all pipes in the document
collector.OfClass(GetType(Autodesk.Revit.DB.Plumbing.Pipe))

' Get results as an element iterator and look for a pipe with
' a specific flow state
Dim elemItr As FilteredElementIterator = collector.GetElementIterator()
elemItr.Reset()
While elemItr.MoveNext()
   Dim pipe As Pipe = TryCast(elemItr.Current, Pipe)
   If pipe.FlowState = PipeFlowState.LaminarState Then
      TaskDialog.Show("Revit", "Model has at least one pipe with Laminar flow state.")
      Exit While
   End If
End While

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter.

See Also

FilteredElementCollector Class


GetEnumerator Method

[image]

Revit 2024 API
FilteredElementCollector..::..GetEnumerator Method
FilteredElementCollector Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IEnumerator<Element> GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator(Of Element)
Visual C++
public:
virtual IEnumerator<Element^>^ GetEnumerator()

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

FilteredElementCollector Class


IntersectWith Method

[image]

Revit 2024 API
FilteredElementCollector..::..IntersectWith Method
FilteredElementCollector Class See Also Send Feedback
Intersects the set of elements passing the filter in this collector with the set of elements passing the filter in another collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FilteredElementCollector IntersectWith(
    FilteredElementCollector other
)
Visual Basic
Public Function IntersectWith ( _
    other As FilteredElementCollector _
) As FilteredElementCollector
Visual C++
public:
FilteredElementCollector^ IntersectWith(
    FilteredElementCollector^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..FilteredElementCollector
The other collector

Return Value

A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Remarks

The result will be the same as using a LogicalAndFilter to connect this filter with another. If you have an active iterator to this collector it will be stopped by this call.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter.

See Also

FilteredElementCollector Class


IsViewValidForElementIteration Method

[image]

Revit 2024 API
FilteredElementCollector..::..IsViewValidForElementIteration Method
FilteredElementCollector Class See Also Send Feedback
Identifies if the particular element is valid for iteration of drawn elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static bool IsViewValidForElementIteration(
    Document document,
    ElementId viewId
)
Visual Basic
Public Shared Function IsViewValidForElementIteration ( _
    document As Document, _
    viewId As ElementId _
) As Boolean
Visual C++
public:
static bool IsViewValidForElementIteration(
    Document^ document,
    ElementId^ viewId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
viewId
Type: Autodesk.Revit.DB..::..ElementId
The view id.

Return Value

True if the element is valid for iteration.

Remarks

Views that have no way of representing drawn elements, such as many view templates, fail this check.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FilteredElementCollector Class


OfCategory Method

[image]

Revit 2024 API
FilteredElementCollector..::..OfCategory Method
FilteredElementCollector Class Example See Also Send Feedback
Applies an ElementCategoryFilter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FilteredElementCollector OfCategory(
    BuiltInCategory category
)
Visual Basic
Public Function OfCategory ( _
    category As BuiltInCategory _
) As FilteredElementCollector
Visual C++
public:
FilteredElementCollector^ OfCategory(
    BuiltInCategory category
)

Parameters

category
Type: Autodesk.Revit.DB..::..BuiltInCategory
The category.

Return Value

This collector.

Remarks

Only elements of this category id will pass the collector.

Examples

CopyC#
// Use OfCategory method to apply an ElementCategoryFilter and fine elements in the Doors category
FilteredElementCollector collector = new FilteredElementCollector(document);
ICollection<Element> doors = collector.OfCategory(BuiltInCategory.OST_Doors).ToElements();
CopyVB.NET
' Use OfCategory method to apply an ElementCategoryFilter and fine elements in the Doors category
Dim collector As New FilteredElementCollector(document)
Dim doors As ICollection(Of Element) = collector.OfCategory(BuiltInCategory.OST_Doors).ToElements()

See Also

FilteredElementCollector Class


OfCategoryId Method

[image]

Revit 2024 API
FilteredElementCollector..::..OfCategoryId Method
FilteredElementCollector Class See Also Send Feedback
Applies an ElementCategoryFilter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FilteredElementCollector OfCategoryId(
    ElementId categoryId
)
Visual Basic
Public Function OfCategoryId ( _
    categoryId As ElementId _
) As FilteredElementCollector
Visual C++
public:
FilteredElementCollector^ OfCategoryId(
    ElementId^ categoryId
)

Parameters

categoryId
Type: Autodesk.Revit.DB..::..ElementId
The category id.

Return Value

A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Remarks

Only elements of this category id will pass the collector. If you have an active iterator to this collector it will be stopped by this call.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FilteredElementCollector Class


OfClass Method

[image]

Revit 2024 API
FilteredElementCollector..::..OfClass Method
FilteredElementCollector Class Example See Also Send Feedback
Applies an ElementClassFilter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FilteredElementCollector OfClass(
    Type type
)
Visual Basic
Public Function OfClass ( _
    type As Type _
) As FilteredElementCollector
Visual C++
public:
FilteredElementCollector^ OfClass(
    Type^ type
)

Parameters

type
Type: System..::..Type
The element type.

Return Value

A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Remarks

Only elements whose class is an exact match to the input class, or elements whose type is derived from the input class will pass the collector.

There is a small subset of Element subclasses in the API that are not supported by this filter. These classes exist in the API, but not in Revit's native object model, which means that this filter doesn't support them. In order to use a class filter to find elements of these types, it is necessary to use a higher level class and then process the results further to find elements matching only the subclass. For a list of subclasses affected by this restriction, consult the documentation for ElementClassFilter.

If you have an active iterator to this collector it will be stopped by this call.

Examples

CopyC#
// Use OfClass method to apply an ElementClassFilter and find Levels in the document
FilteredElementCollector collector = new FilteredElementCollector(document);
ICollection<Element> levels = collector.OfClass(typeof(Level)).ToElements();
CopyVB.NET
' Use OfClass method to apply an ElementClassFilter and find Levels in the document
Dim collector As New FilteredElementCollector(document)
Dim levels As ICollection(Of Element) = collector.OfClass(GetType(Level)).ToElements()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input type is not a subclass of Element. -or- The input type is of an element type that exists in the API, but not in Revit's native object model.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FilteredElementCollector Class


OwnedByView Method

[image]

Revit 2024 API
FilteredElementCollector..::..OwnedByView Method
FilteredElementCollector Class See Also Send Feedback
Applies an ElementOwnerViewFilter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FilteredElementCollector OwnedByView(
    ElementId viewId
)
Visual Basic
Public Function OwnedByView ( _
    viewId As ElementId _
) As FilteredElementCollector
Visual C++
public:
FilteredElementCollector^ OwnedByView(
    ElementId^ viewId
)

Parameters

viewId
Type: Autodesk.Revit.DB..::..ElementId
The view id of the owner view.

Return Value

A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Remarks

Only elements that are owned by this particular view will pass the collector. If you have an active iterator to this collector it will be stopped by this call.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FilteredElementCollector Class


ToElementIds Method

[image]

Revit 2024 API
FilteredElementCollector..::..ToElementIds Method
FilteredElementCollector Class See Also Send Feedback
Returns the complete set of element ids that pass the filter(s).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public ICollection<ElementId> ToElementIds()
Visual Basic
Public Function ToElementIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ ToElementIds()

Return Value

The complete set of element ids.

Remarks

This will reset the collector to the beginning and extract all elements that pass the applied filter(s). If you have an active iterator to this same collector it will be stopped by this call.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter.

See Also

FilteredElementCollector Class


ToElements Method

[image]

Revit 2024 API
FilteredElementCollector..::..ToElements Method
FilteredElementCollector Class See Also Send Feedback
Returns the complete set of elements that pass the filter(s).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public IList<Element> ToElements()
Visual Basic
Public Function ToElements As IList(Of Element)
Visual C++
public:
IList<Element^>^ ToElements()

Return Value

The complete set of element ids.

Remarks

This will reset the collector to the beginning and extract all elements that pass the applied filter(s). If you have an active iterator to this same collector it will be stopped by this call.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter.

See Also

FilteredElementCollector Class


UnionWith Method

[image]

Revit 2024 API
FilteredElementCollector..::..UnionWith Method
FilteredElementCollector Class See Also Send Feedback
Unites the set of elements passing the filter in this collector with the set of elements passing the filter in another collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FilteredElementCollector UnionWith(
    FilteredElementCollector other
)
Visual Basic
Public Function UnionWith ( _
    other As FilteredElementCollector _
) As FilteredElementCollector
Visual C++
public:
FilteredElementCollector^ UnionWith(
    FilteredElementCollector^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..FilteredElementCollector
The other collector

Return Value

A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Remarks

The result will be the same as using a LogicalOrFilter to connect this filter with another. If you have an active iterator to this collector it will be stopped by this call.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter.

See Also

FilteredElementCollector Class


WhereElementIsCurveDriven Method

[image]

Revit 2024 API
FilteredElementCollector..::..WhereElementIsCurveDriven Method
FilteredElementCollector Class See Also Send Feedback
Applies an ElementIsCurveDrivenFilter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FilteredElementCollector WhereElementIsCurveDriven()
Visual Basic
Public Function WhereElementIsCurveDriven As FilteredElementCollector
Visual C++
public:
FilteredElementCollector^ WhereElementIsCurveDriven()

Return Value

A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Remarks

Only elements that are curve driven will pass the collector. If you have an active iterator to this collector it will be stopped by this call.

See Also

FilteredElementCollector Class


WhereElementIsElementType Method

[image]

Revit 2024 API
FilteredElementCollector..::..WhereElementIsElementType Method
FilteredElementCollector Class See Also Send Feedback
Applies an ElementIsElementTypeFilter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FilteredElementCollector WhereElementIsElementType()
Visual Basic
Public Function WhereElementIsElementType As FilteredElementCollector
Visual C++
public:
FilteredElementCollector^ WhereElementIsElementType()

Return Value

A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Remarks

Only elements that are ElementTypes will pass the collector. If you have an active iterator to this collector it will be stopped by this call.

See Also

FilteredElementCollector Class


WhereElementIsNotElementType Method

[image]

Revit 2024 API
FilteredElementCollector..::..WhereElementIsNotElementType Method
FilteredElementCollector Class See Also Send Feedback
Applies an inverted ElementIsElementTypeFilter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FilteredElementCollector WhereElementIsNotElementType()
Visual Basic
Public Function WhereElementIsNotElementType As FilteredElementCollector
Visual C++
public:
FilteredElementCollector^ WhereElementIsNotElementType()

Return Value

A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Remarks

Only elements that are not element types will pass the collector. If you have an active iterator to this collector it will be stopped by this call.

See Also

FilteredElementCollector Class


WhereElementIsViewIndependent Method

[image]

Revit 2024 API
FilteredElementCollector..::..WhereElementIsViewIndependent Method
FilteredElementCollector Class See Also Send Feedback
Applies an ElementOwnerViewFilter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FilteredElementCollector WhereElementIsViewIndependent()
Visual Basic
Public Function WhereElementIsViewIndependent As FilteredElementCollector
Visual C++
public:
FilteredElementCollector^ WhereElementIsViewIndependent()

Return Value

A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Remarks

Only elements that are view independent will pass the collector. If you have an active iterator to this collector it will be stopped by this call.

See Also

FilteredElementCollector Class


WherePasses Method

[image]

Revit 2024 API
FilteredElementCollector..::..WherePasses Method
FilteredElementCollector Class See Also Send Feedback
Applies an element filter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FilteredElementCollector WherePasses(
    ElementFilter filter
)
Visual Basic
Public Function WherePasses ( _
    filter As ElementFilter _
) As FilteredElementCollector
Visual C++
public:
FilteredElementCollector^ WherePasses(
    ElementFilter^ filter
)

Parameters

filter
Type: Autodesk.Revit.DB..::..ElementFilter
The element filter.

Return Value

A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Remarks

The filter will be added as an additional condition that all filtered elements must pass. If you have an active iterator to this collector it will be stopped by this call.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FilteredElementCollector Class


IsValidObject Property

[image]

Revit 2024 API
FilteredElementCollector..::..IsValidObject Property
FilteredElementCollector Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

FilteredElementCollector Class


FilteredElementIdIterator Members

[image] [image]

Revit 2024 API
FilteredElementIdIterator Members
FilteredElementIdIterator Class Methods Properties See Also Send Feedback

The FilteredElementIdIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FilteredElementIdIterator
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCurrent | The current element id found by the iterator.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next element id passing the filter.
Public method | Reset | Resets the iterator to the beginning.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

FilteredElementIdIterator Class


FilteredElementIdIterator Methods

[image] [image]

Revit 2024 API
FilteredElementIdIterator Methods
FilteredElementIdIterator Class See Also Send Feedback

The FilteredElementIdIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCurrent | The current element id found by the iterator.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next element id passing the filter.
Public method | Reset | Resets the iterator to the beginning.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FilteredElementIdIterator Class


Dispose Method

[image]

Revit 2024 API
FilteredElementIdIterator..::..Dispose Method
FilteredElementIdIterator Class See Also Send Feedback
Releases all resources used by the FilteredElementIdIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

See Also

FilteredElementIdIterator Class


GetCurrent Method

[image]

Revit 2024 API
FilteredElementIdIterator..::..GetCurrent Method
FilteredElementIdIterator Class See Also Send Feedback
The current element id found by the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public ElementId GetCurrent()
Visual Basic
Public Function GetCurrent As ElementId
Visual C++
public:
ElementId^ GetCurrent()

Return Value

The element id.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | There are no more element ids in the iterator. -or- The FilteredElementCollector that yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator. -or- The iterator cannot proceed due to changes made to the Element table in Revit's database (typically, this can be the result of an Element deletion).

See Also

FilteredElementIdIterator Class


IsValidObject Property

[image]

Revit 2024 API
FilteredElementIdIterator..::..IsValidObject Property
FilteredElementIdIterator Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

FilteredElementIdIterator Class


FilteredElementIterator Class

[image]

Revit 2024 API
FilteredElementIterator Class
Members See Also Send Feedback
An iterator to a set of elements filtered by the settings of a FilteredElementCollector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class FilteredElementIterator : IEnumerator<Element>
Visual Basic
Public Class FilteredElementIterator _
    Implements IEnumerator(Of Element)
Visual C++
public ref class FilteredElementIterator : IEnumerator<Element^>

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilteredElementIterator

See Also

FilteredElementIterator Members


FilteredElementIterator Members

[image] [image]

Revit 2024 API
FilteredElementIterator Members
FilteredElementIterator Class Methods Properties See Also Send Feedback

The FilteredElementIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FilteredElementIterator
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCurrent | The current element found by the iterator.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next element passing the filter.
Public method | Reset | Resets the iterator to the beginning.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

FilteredElementIterator Class


Dispose Method

[image]

Revit 2024 API
FilteredElementIterator..::..Dispose Method
FilteredElementIterator Class See Also Send Feedback
Releases all resources used by the FilteredElementIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

See Also

FilteredElementIterator Class


GetCurrent Method

[image]

Revit 2024 API
FilteredElementIterator..::..GetCurrent Method
FilteredElementIterator Class See Also Send Feedback
The current element found by the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public Element GetCurrent()
Visual Basic
Public Function GetCurrent As Element
Visual C++
public:
Element^ GetCurrent()

Return Value

The element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | There are no more element ids in the iterator. -or- The FilteredElementCollector that yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator. -or- The iterator cannot proceed due to changes made to the Element table in Revit's database (typically, This can be the result of an Element deletion).

See Also

FilteredElementIterator Class


IsDone Method

[image]

Revit 2024 API
FilteredElementIterator..::..IsDone Method
FilteredElementIterator Class See Also Send Feedback
Identifies if the iteration has completed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public virtual bool IsDone()
Visual Basic
Public Overridable Function IsDone As Boolean
Visual C++
public:
virtual bool IsDone()

Return Value

True if the iteration has no more matching elements. False if there are more element ids to be iterated.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The FilteredElementCollector that yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator.

See Also

FilteredElementIterator Class


MoveNext Method

[image]

Revit 2024 API
FilteredElementIterator..::..MoveNext Method
FilteredElementIterator Class See Also Send Feedback
Increments the iterator to the next element passing the filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

True if there is another available element passing the filter in this iterator. False if the iterator has completed all available elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The FilteredElementCollector that yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator. -or- The iterator cannot proceed due to changes made to the Element table in Revit's database (typically, This can be the result of an Element deletion).

See Also

FilteredElementIterator Class


Reset Method

[image]

Revit 2024 API
FilteredElementIterator..::..Reset Method
FilteredElementIterator Class See Also Send Feedback
Resets the iterator to the beginning.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The FilteredElementCollector that yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator.

See Also

FilteredElementIterator Class


FilteredElementIterator Properties

[image] [image]

Revit 2024 API
FilteredElementIterator Properties
FilteredElementIterator Class See Also Send Feedback

The FilteredElementIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

FilteredElementIterator Class


Current Property

[image]

Revit 2024 API
FilteredElementIterator..::..Current Property
FilteredElementIterator Class See Also Send Feedback
Gets the item at the current position of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Element Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Element
    Get
Visual C++
public:
virtual property Element^ Current {
    Element^ get ();
}

Implements

IEnumerator<(Of <(<'T>)>)>..::..Current

Remarks

There is no current item if the iterator has not started yet or has been done.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | There is no current item in the iterator.

See Also

FilteredElementIterator Class


IsValidObject Property

[image]

Revit 2024 API
FilteredElementIterator..::..IsValidObject Property
FilteredElementIterator Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

FilteredElementIterator Class


FilteredWorksetCollector Class

[image]

Revit 2024 API
FilteredWorksetCollector Class
Members See Also Send Feedback
This class is used to search, filter and iterate through a set of worksets.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public class FilteredWorksetCollector : IEnumerable<Workset>,
    IDisposable
Visual Basic
Public Class FilteredWorksetCollector _
    Implements IEnumerable(Of Workset), IDisposable
Visual C++
public ref class FilteredWorksetCollector : IEnumerable<Workset^>,
    IDisposable

Remarks

Developers can assign a condition to filter the worksets that are returned. If no condition is applied, it attempts to access all the worksets in the document.

The collector will reset if you call another method to extract worksets. Thus, if you have previously obtained an iterator, it will be stopped and traverse no more worksets if you call another method to extract worksets.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilteredWorksetCollector

See Also

FilteredWorksetCollector Members


FilteredWorksetCollector Members

[image] [image]

Revit 2024 API
FilteredWorksetCollector Members
FilteredWorksetCollector Class Constructors Methods Properties See Also Send Feedback

The FilteredWorksetCollector type exposes the following members.

Constructors

 | Name | Description
Public method | FilteredWorksetCollector | Constructs a new FilteredWorksetCollector that will search and filter the set of worksets in a document.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FilteredWorksetCollector
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FirstWorkset | Returns the first workset to pass the filter(s).
Public method | FirstWorksetId | Returns the id of the first workset to pass the filter(s).
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWorksetIdIterator | Returns a FilteredWorksetIdIterator to the worksets passing the current filter.
Public method | GetWorksetIterator | Returns a FilteredWorksetIterator to the worksets passing the current filter.
Public method | OfKind | Applies a WorksetKindFilter to the collector.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToWorksetIds | Returns the complete set of workset ids that pass the filter(s).
Public method | ToWorksets | Returns the complete set of worksets that pass the filter(s).
Public method | WherePasses | Applies a workset filter to the collector.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

FilteredWorksetCollector Class


FilteredWorksetCollector Constructor

[image]

Revit 2024 API
FilteredWorksetCollector Constructor
FilteredWorksetCollector Class See Also Send Feedback
Constructs a new FilteredWorksetCollector that will search and filter the set of worksets in a document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public FilteredWorksetCollector(
    Document document
)
Visual Basic
Public Sub New ( _
    document As Document _
)
Visual C++
public:
FilteredWorksetCollector(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FilteredWorksetCollector Class


FilteredWorksetCollector Methods

[image] [image]

Revit 2024 API
FilteredWorksetCollector Methods
FilteredWorksetCollector Class See Also Send Feedback

The FilteredWorksetCollector type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FirstWorkset | Returns the first workset to pass the filter(s).
Public method | FirstWorksetId | Returns the id of the first workset to pass the filter(s).
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWorksetIdIterator | Returns a FilteredWorksetIdIterator to the worksets passing the current filter.
Public method | GetWorksetIterator | Returns a FilteredWorksetIterator to the worksets passing the current filter.
Public method | OfKind | Applies a WorksetKindFilter to the collector.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToWorksetIds | Returns the complete set of workset ids that pass the filter(s).
Public method | ToWorksets | Returns the complete set of worksets that pass the filter(s).
Public method | WherePasses | Applies a workset filter to the collector.

See Also

FilteredWorksetCollector Class


Dispose Method

[image]

Revit 2024 API
FilteredWorksetCollector..::..Dispose Method
FilteredWorksetCollector Class See Also Send Feedback
Releases all resources used by the FilteredWorksetCollector

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FilteredWorksetCollector Class


FirstWorkset Method

[image]

Revit 2024 API
FilteredWorksetCollector..::..FirstWorkset Method
FilteredWorksetCollector Class See Also Send Feedback
Returns the first workset to pass the filter(s).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public Workset FirstWorkset()
Visual Basic
Public Function FirstWorkset As Workset
Visual C++
public:
Workset^ FirstWorkset()

Return Value

The first workset.

Remarks

This will reset the collector to the beginning and find the first workset that passes the applied filter(s). If you have an active iterator to this same collector it will be stopped by this call.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of worksets is not permitted without a filter.

See Also

FilteredWorksetCollector Class


GetBasicIEnumerator Method

[image]

Revit 2024 API
FilteredWorksetCollector..::..GetBasicIEnumerator Method
FilteredWorksetCollector Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
internal virtual IEnumerator GetBasicIEnumerator()
Visual Basic
Friend Overridable Function GetBasicIEnumerator As IEnumerator
Visual C++
internal:
virtual IEnumerator^ GetBasicIEnumerator()

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

FilteredWorksetCollector Class


GetEnumerator Method

[image]

Revit 2024 API
FilteredWorksetCollector..::..GetEnumerator Method
FilteredWorksetCollector Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IEnumerator<Workset> GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator(Of Workset)
Visual C++
public:
virtual IEnumerator<Workset^>^ GetEnumerator()

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

FilteredWorksetCollector Class


GetWorksetIdIterator Method

[image]

Revit 2024 API
FilteredWorksetCollector..::..GetWorksetIdIterator Method
FilteredWorksetCollector Class See Also Send Feedback
Returns a FilteredWorksetIdIterator to the worksets passing the current filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public FilteredWorksetIdIterator GetWorksetIdIterator()
Visual Basic
Public Function GetWorksetIdIterator As FilteredWorksetIdIterator
Visual C++
public:
FilteredWorksetIdIterator^ GetWorksetIdIterator()

Remarks

Calling this when you have an active iterator to this same collector will result in the first iterator being stopped by this call.

See Also

FilteredWorksetCollector Class


GetWorksetIterator Method

[image]

Revit 2024 API
FilteredWorksetCollector..::..GetWorksetIterator Method
FilteredWorksetCollector Class See Also Send Feedback
Returns a FilteredWorksetIterator to the worksets passing the current filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public FilteredWorksetIterator GetWorksetIterator()
Visual Basic
Public Function GetWorksetIterator As FilteredWorksetIterator
Visual C++
public:
FilteredWorksetIterator^ GetWorksetIterator()

Remarks

Calling this when you have an active iterator to this same collector will result in the first iterator being stopped by this call.

See Also

FilteredWorksetCollector Class


OfKind Method

[image]

Revit 2024 API
FilteredWorksetCollector..::..OfKind Method
FilteredWorksetCollector Class See Also Send Feedback
Applies a WorksetKindFilter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public FilteredWorksetCollector OfKind(
    WorksetKind worksetKind
)
Visual Basic
Public Function OfKind ( _
    worksetKind As WorksetKind _
) As FilteredWorksetCollector
Visual C++
public:
FilteredWorksetCollector^ OfKind(
    WorksetKind worksetKind
)

Parameters

worksetKind
Type: Autodesk.Revit.DB..::..WorksetKind
The WorksetKind of the workset.

Return Value

A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Remarks

Only worksets whose WorksetKind is an exact match to the input WorksetKind will pass the collector.

If you have an active iterator to this collector it will be stopped by this call.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

FilteredWorksetCollector Class


ToWorksetIds Method

[image]

Revit 2024 API
FilteredWorksetCollector..::..ToWorksetIds Method
FilteredWorksetCollector Class See Also Send Feedback
Returns the complete set of workset ids that pass the filter(s).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public ICollection<WorksetId> ToWorksetIds()
Visual Basic
Public Function ToWorksetIds As ICollection(Of WorksetId)
Visual C++
public:
ICollection<WorksetId^>^ ToWorksetIds()

Return Value

The complete set of workset ids.

Remarks

This will reset the collector to the beginning and extract all worksets that pass the applied filter(s). If you have an active iterator to this same collector it will be stopped by this call.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of worksets is not permitted without a filter.

See Also

FilteredWorksetCollector Class


ToWorksets Method

[image]

Revit 2024 API
FilteredWorksetCollector..::..ToWorksets Method
FilteredWorksetCollector Class See Also Send Feedback
Returns the complete set of worksets that pass the filter(s).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public IList<Workset> ToWorksets()
Visual Basic
Public Function ToWorksets As IList(Of Workset)
Visual C++
public:
IList<Workset^>^ ToWorksets()

Return Value

The complete array of worksets.

Remarks

This will reset the collector to the beginning and extract all worksets that pass the applied filter(s). If you have an active iterator to this same collector it will be stopped by this call.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of worksets is not permitted without a filter.

See Also

FilteredWorksetCollector Class


WherePasses Method

[image]

Revit 2024 API
FilteredWorksetCollector..::..WherePasses Method
FilteredWorksetCollector Class See Also Send Feedback
Applies a workset filter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public FilteredWorksetCollector WherePasses(
    WorksetFilter filter
)
Visual Basic
Public Function WherePasses ( _
    filter As WorksetFilter _
) As FilteredWorksetCollector
Visual C++
public:
FilteredWorksetCollector^ WherePasses(
    WorksetFilter^ filter
)

Parameters

filter
Type: Autodesk.Revit.DB..::..WorksetFilter
The workset filter.

Return Value

A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Remarks

The filter will be added as an additional condition that all filtered worksets must pass. If you have an active iterator to this collector it will be stopped by this call.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FilteredWorksetCollector Class


FilteredWorksetCollector Properties

[image] [image]

Revit 2024 API
FilteredWorksetCollector Properties
FilteredWorksetCollector Class See Also Send Feedback

The FilteredWorksetCollector type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

FilteredWorksetCollector Class


IsValidObject Property

[image]

Revit 2024 API
FilteredWorksetCollector..::..IsValidObject Property
FilteredWorksetCollector Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

FilteredWorksetCollector Class


FilteredWorksetIdIterator Class

[image]

Revit 2024 API
FilteredWorksetIdIterator Class
Members See Also Send Feedback
An iterator to a set of workset ids filtered by the settings of a FilteredWorksetCollector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public class FilteredWorksetIdIterator : IEnumerator<WorksetId>
Visual Basic
Public Class FilteredWorksetIdIterator _
    Implements IEnumerator(Of WorksetId)
Visual C++
public ref class FilteredWorksetIdIterator : IEnumerator<WorksetId^>

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilteredWorksetIdIterator

See Also

FilteredWorksetIdIterator Members


FilteredWorksetIdIterator Members

[image] [image]

Revit 2024 API
FilteredWorksetIdIterator Members
FilteredWorksetIdIterator Class Methods Properties See Also Send Feedback

The FilteredWorksetIdIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FilteredWorksetIdIterator
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCurrent | The current workset id found by the iterator.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next workset id passing the filter.
Public method | Reset | Resets the iterator to the beginning.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

FilteredWorksetIdIterator Class


FilteredWorksetIdIterator Methods

[image] [image]

Revit 2024 API
FilteredWorksetIdIterator Methods
FilteredWorksetIdIterator Class See Also Send Feedback

The FilteredWorksetIdIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCurrent | The current workset id found by the iterator.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next workset id passing the filter.
Public method | Reset | Resets the iterator to the beginning.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FilteredWorksetIdIterator Class


Dispose Method

[image]

Revit 2024 API
FilteredWorksetIdIterator..::..Dispose Method
FilteredWorksetIdIterator Class See Also Send Feedback
Releases all resources used by the FilteredWorksetIdIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

See Also

FilteredWorksetIdIterator Class


IsDone Method

[image]

Revit 2024 API
FilteredWorksetIdIterator..::..IsDone Method
FilteredWorksetIdIterator Class See Also Send Feedback
Identifies if the iteration has completed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public virtual bool IsDone()
Visual Basic
Public Overridable Function IsDone As Boolean
Visual C++
public:
virtual bool IsDone()

Return Value

True if the iteration has no more matching worksets. False if there are more workset ids to be iterated.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The FilteredWorksetCollector that yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator.

See Also

FilteredWorksetIdIterator Class


Reset Method

[image]

Revit 2024 API
FilteredWorksetIdIterator..::..Reset Method
FilteredWorksetIdIterator Class See Also Send Feedback
Resets the iterator to the beginning.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The FilteredWorksetCollector that yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator.

See Also

FilteredWorksetIdIterator Class


Current Property

[image]

Revit 2024 API
FilteredWorksetIdIterator..::..Current Property
FilteredWorksetIdIterator Class See Also Send Feedback
Gets the item at the current position of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual WorksetId Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As WorksetId
    Get
Visual C++
public:
virtual property WorksetId^ Current {
    WorksetId^ get ();
}

Implements

IEnumerator<(Of <(<'T>)>)>..::..Current

Remarks

There is no current item if the iterator has not started yet or has been done.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | There is no current item in the iterator.

See Also

FilteredWorksetIdIterator Class


CurrentObject Property

[image]

Revit 2024 API
FilteredWorksetIdIterator..::..CurrentObject Property
FilteredWorksetIdIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
internal Object CurrentObject { get; }
Visual Basic
Friend ReadOnly Property CurrentObject As Object
    Get
Visual C++
internal:
virtual property Object^ CurrentObject {
    Object^ get () sealed;
}

Implements

IEnumerator..::..Current

See Also

FilteredWorksetIdIterator Class


IsValidObject Property

[image]

Revit 2024 API
FilteredWorksetIdIterator..::..IsValidObject Property
FilteredWorksetIdIterator Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

FilteredWorksetIdIterator Class


FilteredWorksetIterator Class

[image]

Revit 2024 API
FilteredWorksetIterator Class
Members See Also Send Feedback
An iterator to a set of worksets filtered by the settings of a FilteredWorksetCollector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public class FilteredWorksetIterator : IEnumerator<Workset>
Visual Basic
Public Class FilteredWorksetIterator _
    Implements IEnumerator(Of Workset)
Visual C++
public ref class FilteredWorksetIterator : IEnumerator<Workset^>

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilteredWorksetIterator

See Also

FilteredWorksetIterator Members


FilteredWorksetIterator Members

[image] [image]

Revit 2024 API
FilteredWorksetIterator Members
FilteredWorksetIterator Class Methods Properties See Also Send Feedback

The FilteredWorksetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FilteredWorksetIterator
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCurrent | The current workset found by the iterator.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next workset passing the filter.
Public method | Reset | Resets the iterator to the beginning.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

FilteredWorksetIterator Class


FilteredWorksetIterator Methods

[image] [image]

Revit 2024 API
FilteredWorksetIterator Methods
FilteredWorksetIterator Class See Also Send Feedback

The FilteredWorksetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCurrent | The current workset found by the iterator.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next workset passing the filter.
Public method | Reset | Resets the iterator to the beginning.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FilteredWorksetIterator Class


IsDone Method

[image]

Revit 2024 API
FilteredWorksetIterator..::..IsDone Method
FilteredWorksetIterator Class See Also Send Feedback
Identifies if the iteration has completed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public virtual bool IsDone()
Visual Basic
Public Overridable Function IsDone As Boolean
Visual C++
public:
virtual bool IsDone()

Return Value

True if the iteration has no more matching worksets. False if there are more worksets to be iterated.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The FilteredWorksetCollector that yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator.

See Also

FilteredWorksetIterator Class


MoveNext Method

[image]

Revit 2024 API
FilteredWorksetIterator..::..MoveNext Method
FilteredWorksetIterator Class See Also Send Feedback
Increments the iterator to the next workset passing the filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

True if there is another available workset passing the filter in this iterator. False if the iterator has completed all available worksets.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The FilteredWorksetCollector that yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator.

See Also

FilteredWorksetIterator Class


Reset Method

[image]

Revit 2024 API
FilteredWorksetIterator..::..Reset Method
FilteredWorksetIterator Class See Also Send Feedback
Resets the iterator to the beginning.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The FilteredWorksetCollector that yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator.

See Also

FilteredWorksetIterator Class


FilteredWorksetIterator Properties

[image] [image]

Revit 2024 API
FilteredWorksetIterator Properties
FilteredWorksetIterator Class See Also Send Feedback

The FilteredWorksetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

FilteredWorksetIterator Class


Current Property

[image]

Revit 2024 API
FilteredWorksetIterator..::..Current Property
FilteredWorksetIterator Class See Also Send Feedback
Gets the item at the current position of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Workset Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Workset
    Get
Visual C++
public:
virtual property Workset^ Current {
    Workset^ get ();
}

Implements

IEnumerator<(Of <(<'T>)>)>..::..Current

Remarks

There is no current item if the iterator has not started yet or has been done.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | There is no current item in the iterator.

See Also

FilteredWorksetIterator Class


CurrentObject Property

[image]

Revit 2024 API
FilteredWorksetIterator..::..CurrentObject Property
FilteredWorksetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
internal Object CurrentObject { get; }
Visual Basic
Friend ReadOnly Property CurrentObject As Object
    Get
Visual C++
internal:
virtual property Object^ CurrentObject {
    Object^ get () sealed;
}

Implements

IEnumerator..::..Current

See Also

FilteredWorksetIterator Class


IsValidObject Property

[image]

Revit 2024 API
FilteredWorksetIterator..::..IsValidObject Property
FilteredWorksetIterator Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

FilteredWorksetIterator Class


FilterElement Class

[image]

Revit 2024 API
FilterElement Class
Members See Also Send Feedback
The base class for filter elements in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class FilterElement : Element
Visual Basic
Public Class FilterElement _
    Inherits Element
Visual C++
public ref class FilterElement : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..FilterElement
Autodesk.Revit.DB..::..ParameterFilterElement
Autodesk.Revit.DB..::..SelectionFilterElement

See Also

FilterElement Members


FilterElement Members

[image] [image]

Revit 2024 API
FilterElement Members
FilterElement Class Methods Properties See Also Send Feedback

The FilterElement type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsNameUnique(String) | Determines whether a potential filter element name is unique.
 | IsNameUnique(Document, String) | Determines whether the given name could be applied to a new FilterElement, or if it could not be applied because the name is already in use.
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FilterElement Class


FilterElement Methods

[image] [image]

Revit 2024 API
FilterElement Methods
FilterElement Class See Also Send Feedback

The FilterElement type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsNameUnique(String) | Determines whether a potential filter element name is unique.
 | IsNameUnique(Document, String) | Determines whether the given name could be applied to a new FilterElement, or if it could not be applied because the name is already in use.
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FilterElement Class


IsNameUnique Method

[image] [image]

Revit 2024 API
FilterElement..::..IsNameUnique Method
FilterElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsNameUnique(String) | Determines whether a potential filter element name is unique.
 | IsNameUnique(Document, String) | Determines whether the given name could be applied to a new FilterElement, or if it could not be applied because the name is already in use.

See Also

FilterElement Class
FilterElement Members


IsNameUnique Method (String)

[image]

Revit 2024 API
FilterElement..::..IsNameUnique Method (String)
FilterElement Class See Also Send Feedback
Determines whether a potential filter element name is unique.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool IsNameUnique(
    string name
)
Visual Basic
Public Function IsNameUnique ( _
    name As String _
) As Boolean
Visual C++
public:
bool IsNameUnique(
    String^ name
)

Parameters

name
Type: System..::..String
The candidate name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FilterElement Class
IsNameUnique Overload


IsNameUnique Method (Document, String)

[image]

Revit 2024 API
FilterElement..::..IsNameUnique Method (Document, String)
FilterElement Class See Also Send Feedback
Determines whether the given name could be applied to a new FilterElement, or if it could not be applied because the name is already in use.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static bool IsNameUnique(
    Document aDocument,
    string name
)
Visual Basic
Public Shared Function IsNameUnique ( _
    aDocument As Document, _
    name As String _
) As Boolean
Visual C++
public:
static bool IsNameUnique(
    Document^ aDocument,
    String^ name
)

Parameters

aDocument
Type: Autodesk.Revit.DB..::..Document
The document in which the name is being tested for uniqueness.
name
Type: System..::..String
The name tested for uniqueness.

Return Value

Returns true if the name is unique, and false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FilterElement Class
IsNameUnique Overload


FilterElementIdRule Class

[image]

Revit 2024 API
FilterElementIdRule Class
Members See Also Send Feedback
A filter rule that operates on ElementId values in a Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class FilterElementIdRule : FilterNumericValueRule
Visual Basic
Public Class FilterElementIdRule _
    Inherits FilterNumericValueRule
Visual C++
public ref class FilterElementIdRule : public FilterNumericValueRule

Remarks

When GetRuleParameter()()()() returns a parameter that UsesLevelFiltering(Document, ElementId), then the comparisons will first compare the values of the levels' elevations, then compare the levels' names, and finally the levels' element ids to rank and sort the levels.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterRule
Autodesk.Revit.DB..::..FilterValueRule
Autodesk.Revit.DB..::..FilterNumericValueRule
Autodesk.Revit.DB..::..FilterElementIdRule

See Also

FilterElementIdRule Members


FilterElementIdRule Members

[image] [image]

Revit 2024 API
FilterElementIdRule Members
FilterElementIdRule Class Constructors Methods Properties See Also Send Feedback

The FilterElementIdRule type exposes the following members.

Constructors

 | Name | Description
Public method | FilterElementIdRule | Constructs an instance of FilterElementIdRule.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterRule.)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEvaluator | Gets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter. (Inherited from FilterRule.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetEvaluator | Sets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | UsesLevelFiltering | This function checks if a parameter uses level filtering.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterRule.)
Public property | RuleValue | The user-supplied value against which values from a Revit document will be tested.

See Also

FilterElementIdRule Class


FilterElementIdRule Constructor

[image]

Revit 2024 API
FilterElementIdRule Constructor
FilterElementIdRule Class See Also Send Feedback
Constructs an instance of FilterElementIdRule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FilterElementIdRule(
    FilterableValueProvider valueProvider,
    FilterNumericRuleEvaluator evaluator,
    ElementId ruleValue
)
Visual Basic
Public Sub New ( _
    valueProvider As FilterableValueProvider, _
    evaluator As FilterNumericRuleEvaluator, _
    ruleValue As ElementId _
)
Visual C++
public:
FilterElementIdRule(
    FilterableValueProvider^ valueProvider,
    FilterNumericRuleEvaluator^ evaluator,
    ElementId^ ruleValue
)

Parameters

valueProvider
Type: Autodesk.Revit.DB..::..FilterableValueProvider
A pointer to a "value provider" object that will extract values from a Revit document.
evaluator
Type: Autodesk.Revit.DB..::..FilterNumericRuleEvaluator
A pointer to the filter rule evaluator object that implements the desired test. The built-in evaluators implement commonly used tests such as less-than, greater-than less-than-or-equal-to, equal, etc.
ruleValue
Type: Autodesk.Revit.DB..::..ElementId
The user-supplied value against which values from a Revit document will be tested.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FilterElementIdRule Class


FilterElementIdRule Methods

[image] [image]

Revit 2024 API
FilterElementIdRule Methods
FilterElementIdRule Class See Also Send Feedback

The FilterElementIdRule type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterRule.)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEvaluator | Gets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter. (Inherited from FilterRule.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetEvaluator | Sets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | UsesLevelFiltering | This function checks if a parameter uses level filtering.

See Also

FilterElementIdRule Class


UsesLevelFiltering Method

[image]

Revit 2024 API
FilterElementIdRule..::..UsesLevelFiltering Method
FilterElementIdRule Class See Also Send Feedback
This function checks if a parameter uses level filtering.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public static bool UsesLevelFiltering(
    Document doc,
    ElementId parameterId
)
Visual Basic
Public Shared Function UsesLevelFiltering ( _
    doc As Document, _
    parameterId As ElementId _
) As Boolean
Visual C++
public:
static bool UsesLevelFiltering(
    Document^ doc,
    ElementId^ parameterId
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The document which owns the parameter.
parameterId
Type: Autodesk.Revit.DB..::..ElementId
The id of the parameter that will be tested to see if it uses level filtering.

Return Value

True if the parameter uses level filtering, false otherwise.

Remarks

When level-filtering parameters are compared, the comparisons will first compare the values of the levels' elevations, then compare the levels' names, and finally the levels' element ids to rank and sort the levels.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FilterElementIdRule Class


FilterElementIdRule Properties

[image] [image]

Revit 2024 API
FilterElementIdRule Properties
FilterElementIdRule Class See Also Send Feedback

The FilterElementIdRule type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterRule.)
Public property | RuleValue | The user-supplied value against which values from a Revit document will be tested.

See Also

FilterElementIdRule Class


RuleValue Property

[image]

Revit 2024 API
FilterElementIdRule..::..RuleValue Property
FilterElementIdRule Class See Also Send Feedback
The user-supplied value against which values from a Revit document will be tested.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public ElementId RuleValue { get; set; }
Visual Basic
Public Property RuleValue As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ RuleValue {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

FilterElementIdRule Class


FilterGlobalParameterAssociationRule Class

[image]

Revit 2024 API
FilterGlobalParameterAssociationRule Class
Members See Also Send Feedback
A filter rule that operates on global parameters ElementId values in a Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public class FilterGlobalParameterAssociationRule : FilterNumericValueRule
Visual Basic
Public Class FilterGlobalParameterAssociationRule _
    Inherits FilterNumericValueRule
Visual C++
public ref class FilterGlobalParameterAssociationRule : public FilterNumericValueRule

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterRule
Autodesk.Revit.DB..::..FilterValueRule
Autodesk.Revit.DB..::..FilterNumericValueRule
Autodesk.Revit.DB..::..FilterGlobalParameterAssociationRule

See Also

FilterGlobalParameterAssociationRule Members


FilterGlobalParameterAssociationRule Members

[image] [image]

Revit 2024 API
FilterGlobalParameterAssociationRule Members
FilterGlobalParameterAssociationRule Class Constructors Methods Properties See Also Send Feedback

The FilterGlobalParameterAssociationRule type exposes the following members.

Constructors

 | Name | Description
Public method | FilterGlobalParameterAssociationRule | Constructs an instance of FilterGlobalParameterAssociationRule.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterRule.)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEvaluator | Gets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter. (Inherited from FilterRule.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetEvaluator | Sets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterRule.)
Public property | RuleValue | The user-supplied global parameter value against which values from a Revit document will be tested.

See Also

FilterGlobalParameterAssociationRule Class


FilterGlobalParameterAssociationRule Methods

[image] [image]

Revit 2024 API
FilterGlobalParameterAssociationRule Methods
FilterGlobalParameterAssociationRule Class See Also Send Feedback

The FilterGlobalParameterAssociationRule type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterRule.)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEvaluator | Gets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter. (Inherited from FilterRule.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetEvaluator | Sets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FilterGlobalParameterAssociationRule Class


FilterGlobalParameterAssociationRule Properties

[image] [image]

Revit 2024 API
FilterGlobalParameterAssociationRule Properties
FilterGlobalParameterAssociationRule Class See Also Send Feedback

The FilterGlobalParameterAssociationRule type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterRule.)
Public property | RuleValue | The user-supplied global parameter value against which values from a Revit document will be tested.

See Also

FilterGlobalParameterAssociationRule Class


FilterIntegerRule Class

[image]

Revit 2024 API
FilterIntegerRule Class
Members See Also Send Feedback
A filter rule that operates on integer values in a Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class FilterIntegerRule : FilterNumericValueRule
Visual Basic
Public Class FilterIntegerRule _
    Inherits FilterNumericValueRule
Visual C++
public ref class FilterIntegerRule : public FilterNumericValueRule

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterRule
Autodesk.Revit.DB..::..FilterValueRule
Autodesk.Revit.DB..::..FilterNumericValueRule
Autodesk.Revit.DB..::..FilterIntegerRule

See Also

FilterIntegerRule Members


FilterIntegerRule Members

[image] [image]

Revit 2024 API
FilterIntegerRule Members
FilterIntegerRule Class Constructors Methods Properties See Also Send Feedback

The FilterIntegerRule type exposes the following members.

Constructors

 | Name | Description
Public method | FilterIntegerRule | Constructs an instance of FilterIntegerRule.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterRule.)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEvaluator | Gets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter. (Inherited from FilterRule.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetEvaluator | Sets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterRule.)
Public property | RuleValue | The user-supplied value against which values from a Revit document will be tested.

See Also

FilterIntegerRule Class


FilterIntegerRule Constructor

[image]

Revit 2024 API
FilterIntegerRule Constructor
FilterIntegerRule Class See Also Send Feedback
Constructs an instance of FilterIntegerRule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FilterIntegerRule(
    FilterableValueProvider valueProvider,
    FilterNumericRuleEvaluator evaluator,
    int ruleValue
)
Visual Basic
Public Sub New ( _
    valueProvider As FilterableValueProvider, _
    evaluator As FilterNumericRuleEvaluator, _
    ruleValue As Integer _
)
Visual C++
public:
FilterIntegerRule(
    FilterableValueProvider^ valueProvider,
    FilterNumericRuleEvaluator^ evaluator,
    int ruleValue
)

Parameters

valueProvider
Type: Autodesk.Revit.DB..::..FilterableValueProvider
A pointer to a "value provider" object that will extract values from a Revit document.
evaluator
Type: Autodesk.Revit.DB..::..FilterNumericRuleEvaluator
A pointer to the filter rule evaluator object that implements the desired test. The built-in evaluators implement commonly used tests such as less-than, greater-than less-than-or-equal-to, equal, etc.
ruleValue
Type: System..::..Int32
The user-supplied value against which values from a Revit document will be tested.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FilterIntegerRule Class


FilterIntegerRule Methods

[image] [image]

Revit 2024 API
FilterIntegerRule Methods
FilterIntegerRule Class See Also Send Feedback

The FilterIntegerRule type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterRule.)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEvaluator | Gets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter. (Inherited from FilterRule.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetEvaluator | Sets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FilterIntegerRule Class


FilterIntegerRule Properties

[image] [image]

Revit 2024 API
FilterIntegerRule Properties
FilterIntegerRule Class See Also Send Feedback

The FilterIntegerRule type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterRule.)
Public property | RuleValue | The user-supplied value against which values from a Revit document will be tested.

See Also

FilterIntegerRule Class


RuleValue Property

[image]

Revit 2024 API
FilterIntegerRule..::..RuleValue Property
FilterIntegerRule Class See Also Send Feedback
The user-supplied value against which values from a Revit document will be tested.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public int RuleValue { get; set; }
Visual Basic
Public Property RuleValue As Integer
    Get
    Set
Visual C++
public:
property int RuleValue {
    int get ();
    void set (int value);
}

See Also

FilterIntegerRule Class


FilterInverseRule Class

[image]

Revit 2024 API
FilterInverseRule Class
Members See Also Send Feedback
A filter rule that inverts the boolean values returned by the rule it contains.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class FilterInverseRule : FilterRule
Visual Basic
Public Class FilterInverseRule _
    Inherits FilterRule
Visual C++
public ref class FilterInverseRule : public FilterRule

Remarks

FilterInverse rule performs a logical "not" operation on its inner rule's "elementPasses()" method.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterRule
Autodesk.Revit.DB..::..FilterInverseRule

See Also

FilterInverseRule Members


FilterInverseRule Constructor

[image]

Revit 2024 API
FilterInverseRule Constructor
FilterInverseRule Class See Also Send Feedback
Constructs a new instance of FilterInverseRule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FilterInverseRule(
    FilterRule innerRule
)
Visual Basic
Public Sub New ( _
    innerRule As FilterRule _
)
Visual C++
public:
FilterInverseRule(
    FilterRule^ innerRule
)

Parameters

innerRule
Type: Autodesk.Revit.DB..::..FilterRule
The rule to invert.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FilterInverseRule Class


FilterInverseRule Methods

[image] [image]

Revit 2024 API
FilterInverseRule Methods
FilterInverseRule Class See Also Send Feedback

The FilterInverseRule type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterRule.)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInnerRule | Gets the rule being inverted.
Public method | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter. (Inherited from FilterRule.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetInnerRule | Gets the rule being inverted.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FilterInverseRule Class


GetInnerRule Method

[image]

Revit 2024 API
FilterInverseRule..::..GetInnerRule Method
FilterInverseRule Class See Also Send Feedback
Gets the rule being inverted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FilterRule GetInnerRule()
Visual Basic
Public Function GetInnerRule As FilterRule
Visual C++
public:
FilterRule^ GetInnerRule()

See Also

FilterInverseRule Class


SetInnerRule Method

[image]

Revit 2024 API
FilterInverseRule..::..SetInnerRule Method
FilterInverseRule Class See Also Send Feedback
Gets the rule being inverted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public void SetInnerRule(
    FilterRule innerRule
)
Visual Basic
Public Sub SetInnerRule ( _
    innerRule As FilterRule _
)
Visual C++
public:
void SetInnerRule(
    FilterRule^ innerRule
)

Parameters

innerRule
Type: Autodesk.Revit.DB..::..FilterRule
The rule to invert.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FilterInverseRule Class


FilterInverseRule Properties

[image] [image]

Revit 2024 API
FilterInverseRule Properties
FilterInverseRule Class See Also Send Feedback

The FilterInverseRule type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterRule.)

See Also

FilterInverseRule Class


FilterNumericEquals Class

[image]

Revit 2024 API
FilterNumericEquals Class
Members See Also Send Feedback
Tests whether numeric values from the document are equal to a certain value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class FilterNumericEquals : FilterNumericRuleEvaluator
Visual Basic
Public Class FilterNumericEquals _
    Inherits FilterNumericRuleEvaluator
Visual C++
public ref class FilterNumericEquals : public FilterNumericRuleEvaluator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterNumericRuleEvaluator
Autodesk.Revit.DB..::..FilterNumericEquals

See Also

FilterNumericEquals Members


FilterNumericEquals Members

[image] [image]

Revit 2024 API
FilterNumericEquals Members
FilterNumericEquals Class Constructors Methods Properties See Also Send Feedback

The FilterNumericEquals type exposes the following members.

Constructors

 | Name | Description
Public method | FilterNumericEquals | Constructs an instance of FilterNumericEquals.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterNumericRuleEvaluator.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate(Int32, Int32) | Obsolete. Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator.)
Public method | Evaluate(Int64, Int64) | Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator.)
Public method | Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not. (Inherited from FilterNumericRuleEvaluator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterNumericRuleEvaluator.)

See Also

FilterNumericEquals Class


FilterNumericEquals Constructor

[image]

Revit 2024 API
FilterNumericEquals Constructor
FilterNumericEquals Class See Also Send Feedback
Constructs an instance of FilterNumericEquals.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FilterNumericEquals()
Visual Basic
Public Sub New
Visual C++
public:
FilterNumericEquals()

See Also

FilterNumericEquals Class


FilterNumericEquals Methods

[image] [image]

Revit 2024 API
FilterNumericEquals Methods
FilterNumericEquals Class See Also Send Feedback

The FilterNumericEquals type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterNumericRuleEvaluator.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate(Int32, Int32) | Obsolete. Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator.)
Public method | Evaluate(Int64, Int64) | Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator.)
Public method | Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not. (Inherited from FilterNumericRuleEvaluator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FilterNumericEquals Class


Evaluate Method

[image] [image]

Revit 2024 API
FilterNumericEquals..::..Evaluate Method
FilterNumericEquals Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Evaluate(Int32, Int32) | Obsolete. Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator.)
Public method | Evaluate(Int64, Int64) | Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator.)
Public method | Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not. (Inherited from FilterNumericRuleEvaluator.)

See Also

FilterNumericEquals Class
FilterNumericEquals Members


FilterNumericEquals Properties

[image] [image]

Revit 2024 API
FilterNumericEquals Properties
FilterNumericEquals Class See Also Send Feedback

The FilterNumericEquals type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterNumericRuleEvaluator.)

See Also

FilterNumericEquals Class


FilterNumericGreater Class

[image]

Revit 2024 API
FilterNumericGreater Class
Members See Also Send Feedback
Tests whether numeric values from the document are greater than a certain value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class FilterNumericGreater : FilterNumericRuleEvaluator
Visual Basic
Public Class FilterNumericGreater _
    Inherits FilterNumericRuleEvaluator
Visual C++
public ref class FilterNumericGreater : public FilterNumericRuleEvaluator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterNumericRuleEvaluator
Autodesk.Revit.DB..::..FilterNumericGreater

See Also

FilterNumericGreater Members


FilterNumericGreater Constructor

[image]

Revit 2024 API
FilterNumericGreater Constructor
FilterNumericGreater Class See Also Send Feedback
Constructs an instance of FilterNumericGreater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FilterNumericGreater()
Visual Basic
Public Sub New
Visual C++
public:
FilterNumericGreater()

See Also

FilterNumericGreater Class


FilterNumericGreater Methods

[image] [image]

Revit 2024 API
FilterNumericGreater Methods
FilterNumericGreater Class See Also Send Feedback

The FilterNumericGreater type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterNumericRuleEvaluator.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate(Int32, Int32) | Obsolete. Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator.)
Public method | Evaluate(Int64, Int64) | Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator.)
Public method | Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not. (Inherited from FilterNumericRuleEvaluator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FilterNumericGreater Class


Evaluate Method

[image] [image]

Revit 2024 API
FilterNumericGreater..::..Evaluate Method
FilterNumericGreater Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Evaluate(Int32, Int32) | Obsolete. Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator.)
Public method | Evaluate(Int64, Int64) | Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator.)
Public method | Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not. (Inherited from FilterNumericRuleEvaluator.)

See Also

FilterNumericGreater Class
FilterNumericGreater Members


FilterNumericGreaterOrEqual Class

[image]

Revit 2024 API
FilterNumericGreaterOrEqual Class
Members See Also Send Feedback
Tests whether numeric values from the document are greater than or equal to a certain value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class FilterNumericGreaterOrEqual : FilterNumericRuleEvaluator
Visual Basic
Public Class FilterNumericGreaterOrEqual _
    Inherits FilterNumericRuleEvaluator
Visual C++
public ref class FilterNumericGreaterOrEqual : public FilterNumericRuleEvaluator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterNumericRuleEvaluator
Autodesk.Revit.DB..::..FilterNumericGreaterOrEqual

See Also

FilterNumericGreaterOrEqual Members


FilterNumericGreaterOrEqual Members

[image] [image]

Revit 2024 API
FilterNumericGreaterOrEqual Members
FilterNumericGreaterOrEqual Class Constructors Methods Properties See Also Send Feedback

The FilterNumericGreaterOrEqual type exposes the following members.

Constructors

 | Name | Description
Public method | FilterNumericGreaterOrEqual | Constructs an instance of FilterNumericGreaterOrEqual.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterNumericRuleEvaluator.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate(Int32, Int32) | Obsolete. Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator.)
Public method | Evaluate(Int64, Int64) | Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator.)
Public method | Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not. (Inherited from FilterNumericRuleEvaluator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterNumericRuleEvaluator.)

See Also

FilterNumericGreaterOrEqual Class


FilterNumericGreaterOrEqual Methods

[image] [image]

Revit 2024 API
FilterNumericGreaterOrEqual Methods
FilterNumericGreaterOrEqual Class See Also Send Feedback

The FilterNumericGreaterOrEqual type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterNumericRuleEvaluator.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate(Int32, Int32) | Obsolete. Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator.)
Public method | Evaluate(Int64, Int64) | Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator.)
Public method | Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not. (Inherited from FilterNumericRuleEvaluator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FilterNumericGreaterOrEqual Class


Evaluate Method

[image] [image]

Revit 2024 API
FilterNumericGreaterOrEqual..::..Evaluate Method
FilterNumericGreaterOrEqual Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Evaluate(Int32, Int32) | Obsolete. Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator.)
Public method | Evaluate(Int64, Int64) | Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator.)
Public method | Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not. (Inherited from FilterNumericRuleEvaluator.)

See Also

FilterNumericGreaterOrEqual Class
FilterNumericGreaterOrEqual Members


FilterNumericGreaterOrEqual Properties

[image] [image]

Revit 2024 API
FilterNumericGreaterOrEqual Properties
FilterNumericGreaterOrEqual Class See Also Send Feedback

The FilterNumericGreaterOrEqual type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterNumericRuleEvaluator.)

See Also

FilterNumericGreaterOrEqual Class


FilterNumericLess Members

[image] [image]

Revit 2024 API
FilterNumericLess Members
FilterNumericLess Class Constructors Methods Properties See Also Send Feedback

The FilterNumericLess type exposes the following members.

Constructors

 | Name | Description
Public method | FilterNumericLess | Constructs an instance of FilterNumericLess.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterNumericRuleEvaluator.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate(Int32, Int32) | Obsolete. Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator.)
Public method | Evaluate(Int64, Int64) | Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator.)
Public method | Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not. (Inherited from FilterNumericRuleEvaluator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterNumericRuleEvaluator.)

See Also

FilterNumericLess Class


FilterNumericLess Constructor

[image]

Revit 2024 API
FilterNumericLess Constructor
FilterNumericLess Class See Also Send Feedback
Constructs an instance of FilterNumericLess.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FilterNumericLess()
Visual Basic
Public Sub New
Visual C++
public:
FilterNumericLess()

See Also

FilterNumericLess Class


FilterNumericLess Methods

[image] [image]

Revit 2024 API
FilterNumericLess Methods
FilterNumericLess Class See Also Send Feedback

The FilterNumericLess type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterNumericRuleEvaluator.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate(Int32, Int32) | Obsolete. Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator.)
Public method | Evaluate(Int64, Int64) | Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator.)
Public method | Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not. (Inherited from FilterNumericRuleEvaluator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FilterNumericLess Class


Evaluate Method

[image] [image]

Revit 2024 API
FilterNumericLess..::..Evaluate Method
FilterNumericLess Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Evaluate(Int32, Int32) | Obsolete. Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator.)
Public method | Evaluate(Int64, Int64) | Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator.)
Public method | Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not. (Inherited from FilterNumericRuleEvaluator.)

See Also

FilterNumericLess Class
FilterNumericLess Members


FilterNumericLessOrEqual Class

[image]

Revit 2024 API
FilterNumericLessOrEqual Class
Members See Also Send Feedback
Tests whether numeric values from the document are less than or equal to a certain value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class FilterNumericLessOrEqual : FilterNumericRuleEvaluator
Visual Basic
Public Class FilterNumericLessOrEqual _
    Inherits FilterNumericRuleEvaluator
Visual C++
public ref class FilterNumericLessOrEqual : public FilterNumericRuleEvaluator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterNumericRuleEvaluator
Autodesk.Revit.DB..::..FilterNumericLessOrEqual

See Also

FilterNumericLessOrEqual Members


FilterNumericLessOrEqual Members

[image] [image]

Revit 2024 API
FilterNumericLessOrEqual Members
FilterNumericLessOrEqual Class Constructors Methods Properties See Also Send Feedback

The FilterNumericLessOrEqual type exposes the following members.

Constructors

 | Name | Description
Public method | FilterNumericLessOrEqual | Constructs an instance of FilterNumericLessOrEqual.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterNumericRuleEvaluator.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate(Int32, Int32) | Obsolete. Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator.)
Public method | Evaluate(Int64, Int64) | Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator.)
Public method | Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not. (Inherited from FilterNumericRuleEvaluator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterNumericRuleEvaluator.)

See Also

FilterNumericLessOrEqual Class


FilterNumericLessOrEqual Constructor

[image]

Revit 2024 API
FilterNumericLessOrEqual Constructor
FilterNumericLessOrEqual Class See Also Send Feedback
Constructs an instance of FilterNumericLessOrEqual.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FilterNumericLessOrEqual()
Visual Basic
Public Sub New
Visual C++
public:
FilterNumericLessOrEqual()

See Also

FilterNumericLessOrEqual Class


FilterNumericLessOrEqual Methods

[image] [image]

Revit 2024 API
FilterNumericLessOrEqual Methods
FilterNumericLessOrEqual Class See Also Send Feedback

The FilterNumericLessOrEqual type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterNumericRuleEvaluator.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate(Int32, Int32) | Obsolete. Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator.)
Public method | Evaluate(Int64, Int64) | Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator.)
Public method | Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not. (Inherited from FilterNumericRuleEvaluator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FilterNumericLessOrEqual Class


Evaluate Method

[image] [image]

Revit 2024 API
FilterNumericLessOrEqual..::..Evaluate Method
FilterNumericLessOrEqual Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Evaluate(Int32, Int32) | Obsolete. Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator.)
Public method | Evaluate(Int64, Int64) | Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator.)
Public method | Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not. (Inherited from FilterNumericRuleEvaluator.)

See Also

FilterNumericLessOrEqual Class
FilterNumericLessOrEqual Members


FilterNumericLessOrEqual Properties

[image] [image]

Revit 2024 API
FilterNumericLessOrEqual Properties
FilterNumericLessOrEqual Class See Also Send Feedback

The FilterNumericLessOrEqual type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterNumericRuleEvaluator.)

See Also

FilterNumericLessOrEqual Class


FilterNumericRuleEvaluator Class

[image]

Revit 2024 API
FilterNumericRuleEvaluator Class
Members See Also Send Feedback
Base for all classes that compare numeric values from Revit to a user-supplied filter value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class FilterNumericRuleEvaluator : IDisposable
Visual Basic
Public Class FilterNumericRuleEvaluator _
    Implements IDisposable
Visual C++
public ref class FilterNumericRuleEvaluator : IDisposable

Remarks

A class derived from FilterNumericRuleEvaluator must handle both integer and double-precision types. For double-precision comparisons, an epsilon value is given. The evaluator class should use this value in a manner appropriate to the comparison being implemented.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterNumericRuleEvaluator
Autodesk.Revit.DB..::..FilterNumericEquals
Autodesk.Revit.DB..::..FilterNumericGreater
Autodesk.Revit.DB..::..FilterNumericGreaterOrEqual
Autodesk.Revit.DB..::..FilterNumericLess
Autodesk.Revit.DB..::..FilterNumericLessOrEqual

See Also

FilterNumericRuleEvaluator Members


FilterNumericRuleEvaluator Methods

[image] [image]

Revit 2024 API
FilterNumericRuleEvaluator Methods
FilterNumericRuleEvaluator Class See Also Send Feedback

The FilterNumericRuleEvaluator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate(Int32, Int32) | Obsolete. Derived classes should override this method to implement the desired test.
Public method | Evaluate(Int64, Int64) | Derived classes should override this method to implement the desired test.
Public method | Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FilterNumericRuleEvaluator Class


Dispose Method

[image]

Revit 2024 API
FilterNumericRuleEvaluator..::..Dispose Method
FilterNumericRuleEvaluator Class See Also Send Feedback
Releases all resources used by the FilterNumericRuleEvaluator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FilterNumericRuleEvaluator Class


Evaluate Method

[image] [image]

Revit 2024 API
FilterNumericRuleEvaluator..::..Evaluate Method
FilterNumericRuleEvaluator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Evaluate(Int32, Int32) | Obsolete. Derived classes should override this method to implement the desired test.
Public method | Evaluate(Int64, Int64) | Derived classes should override this method to implement the desired test.
Public method | Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not.

See Also

FilterNumericRuleEvaluator Class
FilterNumericRuleEvaluator Members


Evaluate Method (Int32, Int32)

[image]

Revit 2024 API
FilterNumericRuleEvaluator..::..Evaluate Method (Int32, Int32)
FilterNumericRuleEvaluator Class See Also Send Feedback
Derived classes should override this method to implement the desired test.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
[ObsoleteAttribute("This method is deprecated in Revit 2024. Override the evalute method taking Int64 instead. It may be removed in a future version.")]
public bool Evaluate(
    int lhs,
    int rhs
)
Visual Basic
<ObsoleteAttribute("This method is deprecated in Revit 2024. Override the evalute method taking Int64 instead. It may be removed in a future version.")> _
Public Function Evaluate ( _
    lhs As Integer, _
    rhs As Integer _
) As Boolean
Visual C++
[ObsoleteAttribute(L"This method is deprecated in Revit 2024. Override the evalute method taking Int64 instead. It may be removed in a future version.")]
public:
bool Evaluate(
    int lhs,
    int rhs
)

Parameters

lhs
Type: System..::..Int32
A value from an element in the document.
rhs
Type: System..::..Int32
The user-supplied value against which values from the document are tested.

Return Value

True if lhs, rhs satisfy the condition implemented by this evaluator.

See Also

FilterNumericRuleEvaluator Class
Evaluate Overload


Evaluate Method (Int64, Int64)

[image]

Revit 2024 API
FilterNumericRuleEvaluator..::..Evaluate Method (Int64, Int64)
FilterNumericRuleEvaluator Class See Also Send Feedback
Derived classes should override this method to implement the desired test.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public bool Evaluate(
    long lhs,
    long rhs
)
Visual Basic
Public Function Evaluate ( _
    lhs As Long, _
    rhs As Long _
) As Boolean
Visual C++
public:
bool Evaluate(
    long long lhs,
    long long rhs
)

Parameters

lhs
Type: System..::..Int64
A value from an element in the document.
rhs
Type: System..::..Int64
The user-supplied value against which values from the document are tested.

Return Value

True if lhs, rhs satisfy the condition implemented by this evaluator.

See Also

FilterNumericRuleEvaluator Class
Evaluate Overload


Evaluate Method (Double, Double, Double)

[image]

Revit 2024 API
FilterNumericRuleEvaluator..::..Evaluate Method (Double, Double, Double)
FilterNumericRuleEvaluator Class See Also Send Feedback
Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool Evaluate(
    double lhs,
    double rhs,
    double epsilon
)
Visual Basic
Public Function Evaluate ( _
    lhs As Double, _
    rhs As Double, _
    epsilon As Double _
) As Boolean
Visual C++
public:
bool Evaluate(
    double lhs,
    double rhs,
    double epsilon
)

Parameters

lhs
Type: System..::..Double
A value from an element in the document.
rhs
Type: System..::..Double
The user-supplied value against which values from the document are tested.
epsilon
Type: System..::..Double
Defines the tolerance within which two values may be considered equal.

Return Value

True if the given arguments satisfy the condition, otherwise false.

Remarks

The arguments may be thought of as the left and right operands of a binary expression; for example, "a < b", "x >= 100", etc. The left operand comes from an element in the Revit document (e.g., the value of a parameter.) The right operand is supplied by the user when creating the filter that contains the rule that uses this evaluator.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for lhs is not finite -or- The given value for lhs is not a number -or- The given value for rhs is not finite -or- The given value for rhs is not a number -or- The given value for epsilon is not finite -or- The given value for epsilon is not a number

See Also

FilterNumericRuleEvaluator Class
Evaluate Overload


FilterNumericRuleEvaluator Properties

[image] [image]

Revit 2024 API
FilterNumericRuleEvaluator Properties
FilterNumericRuleEvaluator Class See Also Send Feedback

The FilterNumericRuleEvaluator type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

FilterNumericRuleEvaluator Class


IsValidObject Property

[image]

Revit 2024 API
FilterNumericRuleEvaluator..::..IsValidObject Property
FilterNumericRuleEvaluator Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

FilterNumericRuleEvaluator Class


FilterNumericValueRule Class

[image]

Revit 2024 API
FilterNumericValueRule Class
Members See Also Send Feedback
Base for all classes that use a FilterNumericRuleEvaluator to perform their comparisons

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class FilterNumericValueRule : FilterValueRule
Visual Basic
Public Class FilterNumericValueRule _
    Inherits FilterValueRule
Visual C++
public ref class FilterNumericValueRule : public FilterValueRule

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterRule
Autodesk.Revit.DB..::..FilterValueRule
Autodesk.Revit.DB..::..FilterNumericValueRule
Autodesk.Revit.DB..::..FilterDoubleRule
Autodesk.Revit.DB..::..FilterElementIdRule
Autodesk.Revit.DB..::..FilterGlobalParameterAssociationRule
Autodesk.Revit.DB..::..FilterIntegerRule

See Also

FilterNumericValueRule Members


FilterNumericValueRule Methods

[image] [image]

Revit 2024 API
FilterNumericValueRule Methods
FilterNumericValueRule Class See Also Send Feedback

The FilterNumericValueRule type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterRule.)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEvaluator | Gets the evaluator that implements the test for this rule.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter. (Inherited from FilterRule.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetEvaluator | Sets the evaluator that implements the test for this rule.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FilterNumericValueRule Class


GetEvaluator Method

[image]

Revit 2024 API
FilterNumericValueRule..::..GetEvaluator Method
FilterNumericValueRule Class See Also Send Feedback
Gets the evaluator that implements the test for this rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FilterNumericRuleEvaluator GetEvaluator()
Visual Basic
Public Function GetEvaluator As FilterNumericRuleEvaluator
Visual C++
public:
FilterNumericRuleEvaluator^ GetEvaluator()

See Also

FilterNumericValueRule Class


SetEvaluator Method

[image]

Revit 2024 API
FilterNumericValueRule..::..SetEvaluator Method
FilterNumericValueRule Class See Also Send Feedback
Sets the evaluator that implements the test for this rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public void SetEvaluator(
    FilterNumericRuleEvaluator evaluator
)
Visual Basic
Public Sub SetEvaluator ( _
    evaluator As FilterNumericRuleEvaluator _
)
Visual C++
public:
void SetEvaluator(
    FilterNumericRuleEvaluator^ evaluator
)

Parameters

evaluator
Type: Autodesk.Revit.DB..::..FilterNumericRuleEvaluator

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FilterNumericValueRule Class


FilterOperatorAndTextString Class

[image]

Revit 2024 API
FilterOperatorAndTextString Class
Members See Also Send Feedback
An instance of this class holds a filter operator and a text string that denotes the operator in a particular context. For example, the text string for ScheduleFilterType::LessThan may be "is less than" for a filter rule based on a parameter with numerical values or "is below" for a filter rule based on a parameter representing a Level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public class FilterOperatorAndTextString : IDisposable
Visual Basic
Public Class FilterOperatorAndTextString _
    Implements IDisposable
Visual C++
public ref class FilterOperatorAndTextString : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterOperatorAndTextString

See Also

FilterOperatorAndTextString Members


FilterOperatorAndTextString Members

[image] [image]

Revit 2024 API
FilterOperatorAndTextString Members
FilterOperatorAndTextString Class Methods Properties See Also Send Feedback

The FilterOperatorAndTextString type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FilterOperatorAndTextString
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FilterOperatorStr | A text string denoting the filter operator.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OperatorType | The filter operator.

See Also

FilterOperatorAndTextString Class


FilterOperatorAndTextString Methods

[image] [image]

Revit 2024 API
FilterOperatorAndTextString Methods
FilterOperatorAndTextString Class See Also Send Feedback

The FilterOperatorAndTextString type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FilterOperatorAndTextString Class


FilterOperatorAndTextString Properties

[image] [image]

Revit 2024 API
FilterOperatorAndTextString Properties
FilterOperatorAndTextString Class See Also Send Feedback

The FilterOperatorAndTextString type exposes the following members.

Properties

 | Name | Description
Public property | FilterOperatorStr | A text string denoting the filter operator.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OperatorType | The filter operator.

See Also

FilterOperatorAndTextString Class


FilterOperatorStr Property

[image]

Revit 2024 API
FilterOperatorAndTextString..::..FilterOperatorStr Property
FilterOperatorAndTextString Class See Also Send Feedback
A text string denoting the filter operator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public string FilterOperatorStr { get; }
Visual Basic
Public ReadOnly Property FilterOperatorStr As String
    Get
Visual C++
public:
property String^ FilterOperatorStr {
    String^ get ();
}

See Also

FilterOperatorAndTextString Class


OperatorType Property

[image]

Revit 2024 API
FilterOperatorAndTextString..::..OperatorType Property
FilterOperatorAndTextString Class See Also Send Feedback
The filter operator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public ScheduleFilterType OperatorType { get; }
Visual Basic
Public ReadOnly Property OperatorType As ScheduleFilterType
    Get
Visual C++
public:
property ScheduleFilterType OperatorType {
    ScheduleFilterType get ();
}

See Also

FilterOperatorAndTextString Class


FilterRule Class

[image]

Revit 2024 API
FilterRule Class
Members See Also Send Feedback
Defines a boolean operation that can be used to cull elements from a document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class FilterRule : IDisposable
Visual Basic
Public Class FilterRule _
    Implements IDisposable
Visual C++
public ref class FilterRule : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterRule
Autodesk.Revit.DB..::..FilterCategoryRule
Autodesk.Revit.DB..::..FilterInverseRule
Autodesk.Revit.DB..::..FilterValueRule
Autodesk.Revit.DB..::..ParameterValuePresenceRule
Autodesk.Revit.DB..::..SharedParameterApplicableRule

See Also

FilterRule Members


FilterRule Members

[image] [image]

Revit 2024 API
FilterRule Members
FilterRule Class Methods Properties See Also Send Feedback

The FilterRule type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FilterRule
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

FilterRule Class


Dispose Method

[image]

Revit 2024 API
FilterRule..::..Dispose Method
FilterRule Class See Also Send Feedback
Releases all resources used by the FilterRule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FilterRule Class


IsValidObject Property

[image]

Revit 2024 API
FilterRule..::..IsValidObject Property
FilterRule Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

FilterRule Class


FilterStringBeginsWith Class

[image]

Revit 2024 API
FilterStringBeginsWith Class
Members See Also Send Feedback
Tests whether string values from the document begin with a certain string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class FilterStringBeginsWith : FilterStringRuleEvaluator
Visual Basic
Public Class FilterStringBeginsWith _
    Inherits FilterStringRuleEvaluator
Visual C++
public ref class FilterStringBeginsWith : public FilterStringRuleEvaluator

Remarks

All string comparisons in this class are performed in the case-insensitive manner.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterStringRuleEvaluator
Autodesk.Revit.DB..::..FilterStringBeginsWith

See Also

FilterStringBeginsWith Members


FilterStringBeginsWith Members

[image] [image]

Revit 2024 API
FilterStringBeginsWith Members
FilterStringBeginsWith Class Constructors Methods Properties See Also Send Feedback

The FilterStringBeginsWith type exposes the following members.

Constructors

 | Name | Description
Public method | FilterStringBeginsWith | Constructs an instance of FilterStringBeginsWith.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterStringRuleEvaluator.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterStringRuleEvaluator.)

See Also

FilterStringBeginsWith Class


FilterStringBeginsWith Constructor

[image]

Revit 2024 API
FilterStringBeginsWith Constructor
FilterStringBeginsWith Class See Also Send Feedback
Constructs an instance of FilterStringBeginsWith.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FilterStringBeginsWith()
Visual Basic
Public Sub New
Visual C++
public:
FilterStringBeginsWith()

See Also

FilterStringBeginsWith Class


FilterStringBeginsWith Methods

[image] [image]

Revit 2024 API
FilterStringBeginsWith Methods
FilterStringBeginsWith Class See Also Send Feedback

The FilterStringBeginsWith type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterStringRuleEvaluator.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FilterStringBeginsWith Class


FilterStringBeginsWith Properties

[image] [image]

Revit 2024 API
FilterStringBeginsWith Properties
FilterStringBeginsWith Class See Also Send Feedback

The FilterStringBeginsWith type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterStringRuleEvaluator.)

See Also

FilterStringBeginsWith Class


FilterStringContains Class

[image]

Revit 2024 API
FilterStringContains Class
Members See Also Send Feedback
Tests whether string values from the document contain a certain string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class FilterStringContains : FilterStringRuleEvaluator
Visual Basic
Public Class FilterStringContains _
    Inherits FilterStringRuleEvaluator
Visual C++
public ref class FilterStringContains : public FilterStringRuleEvaluator

Remarks

All string comparisons in this class are performed in the case-insensitive manner.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterStringRuleEvaluator
Autodesk.Revit.DB..::..FilterStringContains

See Also

FilterStringContains Members


FilterStringContains Members

[image] [image]

Revit 2024 API
FilterStringContains Members
FilterStringContains Class Constructors Methods Properties See Also Send Feedback

The FilterStringContains type exposes the following members.

Constructors

 | Name | Description
Public method | FilterStringContains | Constructs an instance of FilterStringContains.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterStringRuleEvaluator.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterStringRuleEvaluator.)

See Also

FilterStringContains Class


FilterStringContains Methods

[image] [image]

Revit 2024 API
FilterStringContains Methods
FilterStringContains Class See Also Send Feedback

The FilterStringContains type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterStringRuleEvaluator.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FilterStringContains Class


FilterStringContains Properties

[image] [image]

Revit 2024 API
FilterStringContains Properties
FilterStringContains Class See Also Send Feedback

The FilterStringContains type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterStringRuleEvaluator.)

See Also

FilterStringContains Class


FilterStringEndsWith Members

[image] [image]

Revit 2024 API
FilterStringEndsWith Members
FilterStringEndsWith Class Constructors Methods Properties See Also Send Feedback

The FilterStringEndsWith type exposes the following members.

Constructors

 | Name | Description
Public method | FilterStringEndsWith | Constructs an instance of FilterStringEndsWith.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterStringRuleEvaluator.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterStringRuleEvaluator.)

See Also

FilterStringEndsWith Class


FilterStringEndsWith Constructor

[image]

Revit 2024 API
FilterStringEndsWith Constructor
FilterStringEndsWith Class See Also Send Feedback
Constructs an instance of FilterStringEndsWith.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FilterStringEndsWith()
Visual Basic
Public Sub New
Visual C++
public:
FilterStringEndsWith()

See Also

FilterStringEndsWith Class


FilterStringEndsWith Methods

[image] [image]

Revit 2024 API
FilterStringEndsWith Methods
FilterStringEndsWith Class See Also Send Feedback

The FilterStringEndsWith type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterStringRuleEvaluator.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FilterStringEndsWith Class


FilterStringEndsWith Properties

[image] [image]

Revit 2024 API
FilterStringEndsWith Properties
FilterStringEndsWith Class See Also Send Feedback

The FilterStringEndsWith type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterStringRuleEvaluator.)

See Also

FilterStringEndsWith Class


FilterStringEquals Class

[image]

Revit 2024 API
FilterStringEquals Class
Members See Also Send Feedback
Tests whether string values from the document match a certain string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class FilterStringEquals : FilterStringRuleEvaluator
Visual Basic
Public Class FilterStringEquals _
    Inherits FilterStringRuleEvaluator
Visual C++
public ref class FilterStringEquals : public FilterStringRuleEvaluator

Remarks

All string comparisons in this class are performed in the case-insensitive manner.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterStringRuleEvaluator
Autodesk.Revit.DB..::..FilterStringEquals

See Also

FilterStringEquals Members


FilterStringEquals Members

[image] [image]

Revit 2024 API
FilterStringEquals Members
FilterStringEquals Class Constructors Methods Properties See Also Send Feedback

The FilterStringEquals type exposes the following members.

Constructors

 | Name | Description
Public method | FilterStringEquals | Constructs an instance of FilterStringEquals.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterStringRuleEvaluator.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterStringRuleEvaluator.)

See Also

FilterStringEquals Class


FilterStringEquals Constructor

[image]

Revit 2024 API
FilterStringEquals Constructor
FilterStringEquals Class See Also Send Feedback
Constructs an instance of FilterStringEquals.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FilterStringEquals()
Visual Basic
Public Sub New
Visual C++
public:
FilterStringEquals()

See Also

FilterStringEquals Class


FilterStringEquals Methods

[image] [image]

Revit 2024 API
FilterStringEquals Methods
FilterStringEquals Class See Also Send Feedback

The FilterStringEquals type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterStringRuleEvaluator.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FilterStringEquals Class


FilterStringGreater Class

[image]

Revit 2024 API
FilterStringGreater Class
Members See Also Send Feedback
Tests whether string values from the document would sort after a certain string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class FilterStringGreater : FilterStringRuleEvaluator
Visual Basic
Public Class FilterStringGreater _
    Inherits FilterStringRuleEvaluator
Visual C++
public ref class FilterStringGreater : public FilterStringRuleEvaluator

Remarks

All string comparisons in this class are performed in the case-insensitive manner.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterStringRuleEvaluator
Autodesk.Revit.DB..::..FilterStringGreater

See Also

FilterStringGreater Members


FilterStringGreater Members

[image] [image]

Revit 2024 API
FilterStringGreater Members
FilterStringGreater Class Constructors Methods Properties See Also Send Feedback

The FilterStringGreater type exposes the following members.

Constructors

 | Name | Description
Public method | FilterStringGreater | Constructs an instance of FilterStringGreater.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterStringRuleEvaluator.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterStringRuleEvaluator.)

See Also

FilterStringGreater Class


FilterStringGreater Methods

[image] [image]

Revit 2024 API
FilterStringGreater Methods
FilterStringGreater Class See Also Send Feedback

The FilterStringGreater type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterStringRuleEvaluator.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FilterStringGreater Class


FilterStringGreater Properties

[image] [image]

Revit 2024 API
FilterStringGreater Properties
FilterStringGreater Class See Also Send Feedback

The FilterStringGreater type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterStringRuleEvaluator.)

See Also

FilterStringGreater Class


FilterStringGreaterOrEqual Class

[image]

Revit 2024 API
FilterStringGreaterOrEqual Class
Members See Also Send Feedback
Tests whether string values from the document would sort after or match a certain string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class FilterStringGreaterOrEqual : FilterStringRuleEvaluator
Visual Basic
Public Class FilterStringGreaterOrEqual _
    Inherits FilterStringRuleEvaluator
Visual C++
public ref class FilterStringGreaterOrEqual : public FilterStringRuleEvaluator

Remarks

All string comparisons in this class are performed in the case-insensitive manner.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterStringRuleEvaluator
Autodesk.Revit.DB..::..FilterStringGreaterOrEqual

See Also

FilterStringGreaterOrEqual Members


FilterStringGreaterOrEqual Members

[image] [image]

Revit 2024 API
FilterStringGreaterOrEqual Members
FilterStringGreaterOrEqual Class Constructors Methods Properties See Also Send Feedback

The FilterStringGreaterOrEqual type exposes the following members.

Constructors

 | Name | Description
Public method | FilterStringGreaterOrEqual | Constructs an instance of FilterStringGreaterOrEqual.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterStringRuleEvaluator.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterStringRuleEvaluator.)

See Also

FilterStringGreaterOrEqual Class


FilterStringGreaterOrEqual Constructor

[image]

Revit 2024 API
FilterStringGreaterOrEqual Constructor
FilterStringGreaterOrEqual Class See Also Send Feedback
Constructs an instance of FilterStringGreaterOrEqual.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FilterStringGreaterOrEqual()
Visual Basic
Public Sub New
Visual C++
public:
FilterStringGreaterOrEqual()

See Also

FilterStringGreaterOrEqual Class


FilterStringGreaterOrEqual Methods

[image] [image]

Revit 2024 API
FilterStringGreaterOrEqual Methods
FilterStringGreaterOrEqual Class See Also Send Feedback

The FilterStringGreaterOrEqual type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterStringRuleEvaluator.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FilterStringGreaterOrEqual Class


FilterStringLess Class

[image]

Revit 2024 API
FilterStringLess Class
Members See Also Send Feedback
Tests whether string values from the document would sort before a certain string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class FilterStringLess : FilterStringRuleEvaluator
Visual Basic
Public Class FilterStringLess _
    Inherits FilterStringRuleEvaluator
Visual C++
public ref class FilterStringLess : public FilterStringRuleEvaluator

Remarks

All string comparisons in this class are performed in the case-insensitive manner.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterStringRuleEvaluator
Autodesk.Revit.DB..::..FilterStringLess

See Also

FilterStringLess Members


FilterStringLess Members

[image] [image]

Revit 2024 API
FilterStringLess Members
FilterStringLess Class Constructors Methods Properties See Also Send Feedback

The FilterStringLess type exposes the following members.

Constructors

 | Name | Description
Public method | FilterStringLess | Constructs an instance of FilterStringLess.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterStringRuleEvaluator.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterStringRuleEvaluator.)

See Also

FilterStringLess Class


FilterStringLess Constructor

[image]

Revit 2024 API
FilterStringLess Constructor
FilterStringLess Class See Also Send Feedback
Constructs an instance of FilterStringLess.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FilterStringLess()
Visual Basic
Public Sub New
Visual C++
public:
FilterStringLess()

See Also

FilterStringLess Class


FilterStringLess Methods

[image] [image]

Revit 2024 API
FilterStringLess Methods
FilterStringLess Class See Also Send Feedback

The FilterStringLess type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterStringRuleEvaluator.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FilterStringLess Class


FilterStringLess Properties

[image] [image]

Revit 2024 API
FilterStringLess Properties
FilterStringLess Class See Also Send Feedback

The FilterStringLess type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterStringRuleEvaluator.)

See Also

FilterStringLess Class


FilterStringLessOrEqual Members

[image] [image]

Revit 2024 API
FilterStringLessOrEqual Members
FilterStringLessOrEqual Class Constructors Methods Properties See Also Send Feedback

The FilterStringLessOrEqual type exposes the following members.

Constructors

 | Name | Description
Public method | FilterStringLessOrEqual | Constructs an instance of FilterStringLessOrEqual.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterStringRuleEvaluator.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterStringRuleEvaluator.)

See Also

FilterStringLessOrEqual Class


FilterStringLessOrEqual Constructor

[image]

Revit 2024 API
FilterStringLessOrEqual Constructor
FilterStringLessOrEqual Class See Also Send Feedback
Constructs an instance of FilterStringLessOrEqual.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FilterStringLessOrEqual()
Visual Basic
Public Sub New
Visual C++
public:
FilterStringLessOrEqual()

See Also

FilterStringLessOrEqual Class


FilterStringLessOrEqual Properties

[image] [image]

Revit 2024 API
FilterStringLessOrEqual Properties
FilterStringLessOrEqual Class See Also Send Feedback

The FilterStringLessOrEqual type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterStringRuleEvaluator.)

See Also

FilterStringLessOrEqual Class


FilterStringRule Class

[image]

Revit 2024 API
FilterStringRule Class
Members See Also Send Feedback
A filter rule that operates on string values in a Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class FilterStringRule : FilterValueRule
Visual Basic
Public Class FilterStringRule _
    Inherits FilterValueRule
Visual C++
public ref class FilterStringRule : public FilterValueRule

Remarks

All string comparisons in this class are performed in the case-insensitive manner.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterRule
Autodesk.Revit.DB..::..FilterValueRule
Autodesk.Revit.DB..::..FilterStringRule

See Also

FilterStringRule Members


FilterStringRule Members

[image] [image]

Revit 2024 API
FilterStringRule Members
FilterStringRule Class Constructors Methods Properties See Also Send Feedback

The FilterStringRule type exposes the following members.

Constructors

 | Name | Description
Public method | FilterStringRule | Constructs an instance of FilterStringRule.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterRule.)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEvaluator | Gets the evaluator that implements the test for this rule.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter. (Inherited from FilterRule.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetEvaluator | Sets the evaluator that implements the test for this rule.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterRule.)
Public property | RuleString | The user-supplied string against which strings from a Revit document will be tested.

See Also

FilterStringRule Class


FilterStringRule Constructor

[image]

Revit 2024 API
FilterStringRule Constructor
FilterStringRule Class See Also Send Feedback
Constructs an instance of FilterStringRule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public FilterStringRule(
    FilterableValueProvider valueProvider,
    FilterStringRuleEvaluator evaluator,
    string ruleString
)
Visual Basic
Public Sub New ( _
    valueProvider As FilterableValueProvider, _
    evaluator As FilterStringRuleEvaluator, _
    ruleString As String _
)
Visual C++
public:
FilterStringRule(
    FilterableValueProvider^ valueProvider,
    FilterStringRuleEvaluator^ evaluator,
    String^ ruleString
)

Parameters

valueProvider
Type: Autodesk.Revit.DB..::..FilterableValueProvider
A pointer to a "value provider" object that will extract values from a Revit document.
evaluator
Type: Autodesk.Revit.DB..::..FilterStringRuleEvaluator
A pointer to the filter rule evaluator object that implements the desired test. The built-in evaluators implement commonly used tests for strings such as begins-with, ends-with, contains, equal, etc.
ruleString
Type: System..::..String
The user-supplied string against which strings from a Revit document will be tested.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FilterStringRule Class


FilterStringRule Methods

[image] [image]

Revit 2024 API
FilterStringRule Methods
FilterStringRule Class See Also Send Feedback

The FilterStringRule type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterRule.)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEvaluator | Gets the evaluator that implements the test for this rule.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter. (Inherited from FilterRule.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetEvaluator | Sets the evaluator that implements the test for this rule.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FilterStringRule Class


GetEvaluator Method

[image]

Revit 2024 API
FilterStringRule..::..GetEvaluator Method
FilterStringRule Class See Also Send Feedback
Gets the evaluator that implements the test for this rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FilterStringRuleEvaluator GetEvaluator()
Visual Basic
Public Function GetEvaluator As FilterStringRuleEvaluator
Visual C++
public:
FilterStringRuleEvaluator^ GetEvaluator()

See Also

FilterStringRule Class


SetEvaluator Method

[image]

Revit 2024 API
FilterStringRule..::..SetEvaluator Method
FilterStringRule Class See Also Send Feedback
Sets the evaluator that implements the test for this rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public void SetEvaluator(
    FilterStringRuleEvaluator evaluator
)
Visual Basic
Public Sub SetEvaluator ( _
    evaluator As FilterStringRuleEvaluator _
)
Visual C++
public:
void SetEvaluator(
    FilterStringRuleEvaluator^ evaluator
)

Parameters

evaluator
Type: Autodesk.Revit.DB..::..FilterStringRuleEvaluator

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FilterStringRule Class


RuleString Property

[image]

Revit 2024 API
FilterStringRule..::..RuleString Property
FilterStringRule Class See Also Send Feedback
The user-supplied string against which strings from a Revit document will be tested.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public string RuleString { get; set; }
Visual Basic
Public Property RuleString As String
    Get
    Set
Visual C++
public:
property String^ RuleString {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

FilterStringRule Class


FilterStringRuleEvaluator Class

[image]

Revit 2024 API
FilterStringRuleEvaluator Class
Members See Also Send Feedback
Base for all classes that compare string values from Revit to a user-supplied filter value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class FilterStringRuleEvaluator : IDisposable
Visual Basic
Public Class FilterStringRuleEvaluator _
    Implements IDisposable
Visual C++
public ref class FilterStringRuleEvaluator : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterStringRuleEvaluator
Autodesk.Revit.DB..::..FilterStringBeginsWith
Autodesk.Revit.DB..::..FilterStringContains
Autodesk.Revit.DB..::..FilterStringEndsWith
Autodesk.Revit.DB..::..FilterStringEquals
Autodesk.Revit.DB..::..FilterStringGreater
Autodesk.Revit.DB..::..FilterStringGreaterOrEqual
Autodesk.Revit.DB..::..FilterStringLess
Autodesk.Revit.DB..::..FilterStringLessOrEqual

See Also

FilterStringRuleEvaluator Members


FilterStringRuleEvaluator Members

[image] [image]

Revit 2024 API
FilterStringRuleEvaluator Members
FilterStringRuleEvaluator Class Methods Properties See Also Send Feedback

The FilterStringRuleEvaluator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FilterStringRuleEvaluator
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

FilterStringRuleEvaluator Class


Dispose Method

[image]

Revit 2024 API
FilterStringRuleEvaluator..::..Dispose Method
FilterStringRuleEvaluator Class See Also Send Feedback
Releases all resources used by the FilterStringRuleEvaluator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FilterStringRuleEvaluator Class


FilterStringRuleEvaluator Properties

[image] [image]

Revit 2024 API
FilterStringRuleEvaluator Properties
FilterStringRuleEvaluator Class See Also Send Feedback

The FilterStringRuleEvaluator type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

FilterStringRuleEvaluator Class


IsValidObject Property

[image]

Revit 2024 API
FilterStringRuleEvaluator..::..IsValidObject Property
FilterStringRuleEvaluator Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

FilterStringRuleEvaluator Class


FilterValueRule Class

[image]

Revit 2024 API
FilterValueRule Class
Members See Also Send Feedback
A rule that filters on a particular value of an element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class FilterValueRule : FilterRule
Visual Basic
Public Class FilterValueRule _
    Inherits FilterRule
Visual C++
public ref class FilterValueRule : public FilterRule

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterRule
Autodesk.Revit.DB..::..FilterValueRule
Autodesk.Revit.DB..::..FilterNumericValueRule
Autodesk.Revit.DB..::..FilterStringRule

See Also

FilterValueRule Members


FilterValueRule Members

[image] [image]

Revit 2024 API
FilterValueRule Members
FilterValueRule Class Methods Properties See Also Send Feedback

The FilterValueRule type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterRule.)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter. (Inherited from FilterRule.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterRule.)

See Also

FilterValueRule Class


FilterValueRule Properties

[image] [image]

Revit 2024 API
FilterValueRule Properties
FilterValueRule Class See Also Send Feedback

The FilterValueRule type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterRule.)

See Also

FilterValueRule Class


FittingAndAccessoryCalculationType Enumeration

[image]

Revit 2024 API
FittingAndAccessoryCalculationType Enumeration
See Also Send Feedback
The MEP fitting and accessory pressure drop calculation type.
Enum of fitting and accessory pressure drop calculation type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum FittingAndAccessoryCalculationType
Visual Basic
Public Enumeration FittingAndAccessoryCalculationType
Visual C++
public enum class FittingAndAccessoryCalculationType

Members

Member name | Description
Undefined | Undefined fitting and accessory pressure drop calculation type.
CalculatePressureDrop | To calculate the pressure drop of the fitting and accessory.
CalculateDefaultSettings | To calculate the default settings of the fitting and accessory.
ValidateCurrentSettings | To validate the current settings of the fitting and accessory.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


FittingAngleUsage Enumeration

[image]

Revit 2024 API
FittingAngleUsage Enumeration
See Also Send Feedback
An enumerated type representing the options for how to limit the angle values applicable to fitting content.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public enum FittingAngleUsage
Visual Basic
Public Enumeration FittingAngleUsage
Visual C++
public enum class FittingAngleUsage

Members

Member name | Description
UseAnyAngle | Uses any angle supported by fitting content.
UseAnAngleIncrement | Uses the increment to determine the angle value.
UseSpecificAngles | Uses only the angles specified.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


Floor Class

[image]

Revit 2024 API
Floor Class
Members Example See Also Send Feedback
An object that represents a Floor within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class Floor : CeilingAndFloor
Visual Basic
Public Class Floor _
    Inherits CeilingAndFloor
Visual C++
public ref class Floor : public CeilingAndFloor

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object.

Examples

CopyC#
public void ShowFloorInfo(Floor floor)
{
    string message = "Floor : ";
    // Get Floor type name
    message += "\nFloor type name is : " + floor.FloorType.Name;
    try
    {
        // Get Floor span direction angle
        message += "\nFloor span direction angle is : " + floor.SpanDirectionAngle;
    }
    catch (Exception)
    {
        // an exception is thrown if floor is non-structural
        message += "\nFloor is non-structural.";
    }

    TaskDialog.Show("Revit",message);

}
CopyVB.NET
Public Sub ShowFloorInfo(floor As Floor)
 Dim message As String = "Floor : "
 ' Get Floor type name
 message += vbLf & "Floor type name is : " & Convert.ToString(floor.FloorType.Name)
    Try
        ' Get Floor span direction angle
        message += vbLf & "Floor span direction angle is : " & Convert.ToString(floor.SpanDirectionAngle)
    Catch generatedExceptionName As Exception
        ' an exception is thrown if floor is non-structural
        message += vbLf & "Floor is non-structural."
    End Try

    TaskDialog.Show("Revit", message)

End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB..::..CeilingAndFloor
Autodesk.Revit.DB..::..Floor

See Also

Floor Members


Floor Methods

[image] [image]

Revit 2024 API
Floor Methods
Floor Class See Also Send Feedback

The Floor type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create(Document, IList<(Of <<'(CurveLoop>)>>), ElementId, ElementId) | Creates a new instance of architectural floor within the project.
 | Create(Document, IList<(Of <<'(CurveLoop>)>>), ElementId, ElementId, Boolean, Line, Double) | Creates a new instance of floor within the project.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
 | GetDefaultFloorType | Returns id of default floor type.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetNormalAtVerticalProjectionPoint | Return a surface normal on either the top or bottom face of a floor slab at a point corresponding to the vertical projection of an arbitrary point in project space.
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSlabShapeEditor | Gets a SlabShapeEditor that can be used to add or modify points of this Floor.
Public method | GetSpanDirectionSymbolIds | Retrieves span direction symbol ElementIds.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVerticalProjectionPoint | Return a surface point on either the top or bottom face of a floor slab corresponding to the vertical projection of an arbitrary point in project space.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Floor Class


Create Method (Document, IList(CurveLoop), ElementId, ElementId)

[image]

Revit 2024 API
Floor..::..Create Method (Document, IList<(Of <(<'CurveLoop>)>)>, ElementId, ElementId)
Floor Class Example See Also Send Feedback
Creates a new instance of architectural floor within the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public static Floor Create(
    Document document,
    IList<CurveLoop> profile,
    ElementId floorTypeId,
    ElementId levelId
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    profile As IList(Of CurveLoop), _
    floorTypeId As ElementId, _
    levelId As ElementId _
) As Floor
Visual C++
public:
static Floor^ Create(
    Document^ document,
    IList<CurveLoop^>^ profile,
    ElementId^ floorTypeId,
    ElementId^ levelId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which the new floor is created.
profile
Type: System.Collections.Generic..::..IList<(Of <(<' CurveLoop >)>)>
An array of planar curve loops that represent the profile of the floor.
floorTypeId
Type: Autodesk.Revit.DB..::..ElementId
Id of the floor type to be used by the new Floor.
levelId
Type: Autodesk.Revit.DB..::..ElementId
Id of the level on which the floor is to be placed.

Return Value

If successful a new floor object within the project.

Remarks

To validate curve loop profile use BoundaryValidation. To get default floor type use GetDefaultFloorType(Document, Boolean).

Examples

CopyC#
/// The example below shows how to use Floor.Create method to create a new structural floor (slab) on one level
/// using a geometry profile and a floor type.
/// In this sample, the geometry profile is a CurveLoop of lines, you can also use arcs, ellipses and splines.
Floor CreateFloor(Document document, Level level)
{
   // Get a floor type for floor creation
   ElementId floorTypeId = Floor.GetDefaultFloorType(document, false);

   // Build a floor profile for the floor creation
   XYZ first = new XYZ(0, 0, 0);
   XYZ second = new XYZ(20, 0, 0);
   XYZ third = new XYZ(20, 15, 0);
   XYZ fourth = new XYZ(0, 15, 0);
   CurveLoop profile = new CurveLoop();
   profile.Append(Line.CreateBound(first, second));
   profile.Append(Line.CreateBound(second, third));
   profile.Append(Line.CreateBound(third, fourth));
   profile.Append(Line.CreateBound(fourth, first));

   return Floor.Create(document, new List<CurveLoop> { profile }, floorTypeId, level.Id);
}
CopyC#
/// The example below shows how to use Floor.Create method to create a new Floor with specified elevation, on one level
/// using a geometry profile and a floor type.
/// It shows how to adapt your code that used NewFloor and NewSlab methods, which are obsolete since 2022.
/// In this sample, the geometry profile is a CurveLoop of lines, you can also use arcs, ellipses and splines.
Floor CreateFloorAtElevation(Document document, double elevation)
{
   // Get a floor type for floor creation
   // You must provide a valid floor type (unlike in now obsolete NewFloor and NewSlab methods).
   ElementId floorTypeId = Floor.GetDefaultFloorType(document, false);

   // Get a level
   // You must provide a valid level (unlike in now obsolete NewFloor and NewSlab methods).
   double offset;
   ElementId levelId = Level.GetNearestLevelId(document, elevation, out offset);

   // Build a floor profile for the floor creation
   XYZ first = new XYZ(0, 0, 0);
   XYZ second = new XYZ(20, 0, 0);
   XYZ third = new XYZ(20, 15, 0);
   XYZ fourth = new XYZ(0, 15, 0);
   CurveLoop profile = new CurveLoop();
   profile.Append(Line.CreateBound(first, second));
   profile.Append(Line.CreateBound(second, third));
   profile.Append(Line.CreateBound(third, fourth));
   profile.Append(Line.CreateBound(fourth, first));

   // The elevation of the curve loops is not taken into account (unlike in now obsolete NewFloor and NewSlab methods).
   // If the default elevation is not what you want, you need to set it explicitly.
   var floor = Floor.Create(document, new List<CurveLoop> { profile }, floorTypeId, levelId);
   Parameter param = floor.get_Parameter(BuiltInParameter.FLOOR_HEIGHTABOVELEVEL_PARAM);
   param.Set(offset);

   return floor;
}
CopyVB.NET
Private Function CreateFloor(application As UIApplication, level As Level) As Floor
   ' Get the Revit document
   Dim document As Autodesk.Revit.DB.Document = application.ActiveUIDocument.Document

   ' Get the application creation object
   Dim appCreation As Autodesk.Revit.Creation.Application = application.Application.Create

   ' Get a floor type for floor creation
   Dim collector As New FilteredElementCollector(document)
   collector.OfClass(GetType(FloorType))
   Dim floorType As FloorType = TryCast(collector.FirstElement(), FloorType)

   ' Build a floor profile for the floor creation
   Dim first As New XYZ(0, 0, 0)
   Dim second As New XYZ(20, 0, 0)
   Dim third As New XYZ(20, 15, 0)
   Dim fourth As New XYZ(0, 15, 0)
   Dim profile As New CurveLoop()
   profile.Append(Line.CreateBound(first, second))
   profile.Append(Line.CreateBound(second, third))
   profile.Append(Line.CreateBound(third, fourth))
   profile.Append(Line.CreateBound(fourth, first))

   Return Floor.Create(document, New List(Of CurveLoop)({profile}), floorType.Id, level.Id)
End Function
CopyVB.NET
Private Function CreateFloorAtElevation(ByVal document As Document, ByVal elevation As Double) As Floor
   ' Get a floor type for floor creation
   ' You must provide a valid floor type (unlike in now obsolete NewFloor and NewSlab methods).
   Dim floorTypeId As ElementId = Autodesk.Revit.DB.Floor.GetDefaultFloorType(document, False)

   ' Get a level
   ' You must provide a valid level (unlike in now obsolete NewFloor and NewSlab methods).
   Dim offset As Double
   Dim levelId = Level.GetNearestLevelId(document, elevation, offset)

   ' Build a floor profile for the floor creation
   Dim first As XYZ = New XYZ(0, 0, 0)
   Dim second As XYZ = New XYZ(20, 0, 0)
   Dim third As XYZ = New XYZ(20, 15, 0)
   Dim fourth As XYZ = New XYZ(0, 15, 0)
   Dim profile As CurveLoop = New CurveLoop()
   profile.Append(Line.CreateBound(first, second))
   profile.Append(Line.CreateBound(second, third))
   profile.Append(Line.CreateBound(third, fourth))
   profile.Append(Line.CreateBound(fourth, first))

   ' The elevation of the curve loops is not taken into account (unlike in now obsolete NewFloor and NewSlab methods).
   ' If the default elevation is not what you want, you need to set it explicitly.
   Dim floor = Autodesk.Revit.DB.Floor.Create(document, New List(Of CurveLoop) From {
             profile
         }, floorTypeId, levelId)
   Dim param As Parameter = floor.Parameter(BuiltInParameter.FLOOR_HEIGHTABOVELEVEL_PARAM)
   param.Set(offset)
   Return floor
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId levelId is not a Level. -or- The floorTypeId does not correspond to a FloorType. -or- The input curve loops cannot compose a valid boundary, that means: the "curveLoops" collection is empty; or some curve loops intersect with each other; or each curve loop is not closed individually; or each curve loop is not planar; or each curve loop is not in a plane parallel to the horizontal(XY) plane; or input curves contain at least one helical curve. -or- Input curves build invalid sketch. -or- Failed to create curve elements.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | Cannot generate a sketch. -or- Failed to create new element.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

Floor Class
Create Overload


Create Method (Document, IList(CurveLoop), ElementId, ElementId, Boolean, Line, Double)

[image]

Revit 2024 API
Floor..::..Create Method (Document, IList<(Of <(<'CurveLoop>)>)>, ElementId, ElementId, Boolean, Line, Double)
Floor Class Example See Also Send Feedback
Creates a new instance of floor within the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public static Floor Create(
    Document document,
    IList<CurveLoop> profile,
    ElementId floorTypeId,
    ElementId levelId,
    bool isStructural,
    Line slopeArrow,
    double slope
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    profile As IList(Of CurveLoop), _
    floorTypeId As ElementId, _
    levelId As ElementId, _
    isStructural As Boolean, _
    slopeArrow As Line, _
    slope As Double _
) As Floor
Visual C++
public:
static Floor^ Create(
    Document^ document,
    IList<CurveLoop^>^ profile,
    ElementId^ floorTypeId,
    ElementId^ levelId,
    bool isStructural,
    Line^ slopeArrow,
    double slope
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which the new floor is created.
profile
Type: System.Collections.Generic..::..IList<(Of <(<' CurveLoop >)>)>
An array of planar curve loops that represent the profile of the floor.
floorTypeId
Type: Autodesk.Revit.DB..::..ElementId
Id of the floor type to be used by the new Floor.
levelId
Type: Autodesk.Revit.DB..::..ElementId
Id of the level on which the floor is to be placed.
isStructural
Type: System..::..Boolean
True if new floor should be structural, false if architectural.
slopeArrow
Type: Autodesk.Revit.DB..::..Line
A line used to control the slope angle of the Floor. It must be horizontal. If slopeArrow is nullNothingnullptra null reference (Nothing in Visual Basic), the horizontal floor will be created.
slope
Type: System..::..Double
The slope angle. If slopeArrow is nullNothingnullptra null reference (Nothing in Visual Basic), this parameter will be ignored.

Return Value

If successful a new floor object within the project.

Remarks

To validate curve loop profile use BoundaryValidation. To get default floor type use GetDefaultFloorType(Document, Boolean).

Examples

CopyC#
/// The example below shows how to use Floor.Create method to create a new slopped floor on one level
/// using a geometry profile and a floor type.
/// In this sample, the geometry profile is a CurveLoop of lines, you can also use arcs, ellipses and splines.
Floor CreateSlopedFloor(Document document, Level level)
{
   // Get a floor type for floor creation
   ElementId floorTypeId = Floor.GetDefaultFloorType(document, false);

   // Build a floor profile for the floor creation
   XYZ first = new XYZ(0, 0, 0);
   XYZ second = new XYZ(20, 0, 0);
   XYZ third = new XYZ(20, 20, 0);
   XYZ fourth = new XYZ(0, 20, 0);
   CurveLoop profile = new CurveLoop();
   profile.Append(Line.CreateBound(first, second));
   profile.Append(Line.CreateBound(second, third));
   profile.Append(Line.CreateBound(third, fourth));
   profile.Append(Line.CreateBound(fourth, first));

   Line slopeArrow = Line.CreateBound(new XYZ(10, 10, 0), new XYZ(11, 10, 0));
   return Floor.Create(document, new List<CurveLoop> { profile }, floorTypeId, level.Id, true, slopeArrow, Math.PI / 2);
}
CopyVB.NET
Private Function CreateSlopedFloor(ByVal document As Document, ByVal level As Level) As Floor
   Dim floorTypeId As ElementId = Floor.GetDefaultFloorType(document, False)
   Dim first As XYZ = New XYZ(0, 0, 0)
   Dim second As XYZ = New XYZ(20, 0, 0)
   Dim third As XYZ = New XYZ(20, 20, 0)
   Dim fourth As XYZ = New XYZ(0, 20, 0)
   Dim profile As CurveLoop = New CurveLoop()
   profile.Append(Line.CreateBound(first, second))
   profile.Append(Line.CreateBound(second, third))
   profile.Append(Line.CreateBound(third, fourth))
   profile.Append(Line.CreateBound(fourth, first))
   Dim slopeArrow As Line = Line.CreateBound(New XYZ(10, 10, 0), New XYZ(11, 10, 0))
   Return Floor.Create(document, New List(Of CurveLoop) From {
          profile
      }, floorTypeId, level.Id, True, slopeArrow, Math.PI / 2)
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId levelId is not a Level. -or- The floorTypeId does not correspond to a FloorType. -or- The input curve loops cannot compose a valid boundary, that means: the "curveLoops" collection is empty; or some curve loops intersect with each other; or each curve loop is not closed individually; or each curve loop is not planar; or each curve loop is not in a plane parallel to the horizontal(XY) plane; or input curves contain at least one helical curve. -or- The slopeArrow must be a horizontal line. -or- Input curves build invalid sketch. -or- Failed to create curve elements.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | Cannot generate a sketch. -or- Failed to create new element.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

Floor Class
Create Overload


GetDefaultFloorType Method

[image]

Revit 2024 API
Floor..::..GetDefaultFloorType Method
Floor Class See Also Send Feedback
Returns id of default floor type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public static ElementId GetDefaultFloorType(
    Document document,
    bool isFoundation
)
Visual Basic
Public Shared Function GetDefaultFloorType ( _
    document As Document, _
    isFoundation As Boolean _
) As ElementId
Visual C++
public:
static ElementId^ GetDefaultFloorType(
    Document^ document,
    bool isFoundation
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
isFoundation
Type: System..::..Boolean
True to return id of foundation floor type.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Floor Class


GetSlabShapeEditor Method

[image]

Revit 2024 API
Floor..::..GetSlabShapeEditor Method
Floor Class See Also Send Feedback
Gets a SlabShapeEditor that can be used to add or modify points of this Floor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public SlabShapeEditor GetSlabShapeEditor()
Visual Basic
Public Function GetSlabShapeEditor As SlabShapeEditor
Visual C++
public:
SlabShapeEditor^ GetSlabShapeEditor()

Return Value

The SlabShapeEditor object

See Also

Floor Class


GetSpanDirectionSymbolIds Method

[image]

Revit 2024 API
Floor..::..GetSpanDirectionSymbolIds Method
Floor Class See Also Send Feedback
Retrieves span direction symbol ElementIds.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ICollection<ElementId> GetSpanDirectionSymbolIds()
Visual Basic
Public Function GetSpanDirectionSymbolIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetSpanDirectionSymbolIds()

Return Value

A collection of Element Ids of span direction symbol elements

Remarks

The element types of the Ids of these symbols determine if the floor has one way or two way span direction graphics.

See Also

Floor Class


GetVerticalProjectionPoint Method

[image]

Revit 2024 API
Floor..::..GetVerticalProjectionPoint Method
Floor Class See Also Send Feedback
Return a surface point on either the top or bottom face of a floor slab corresponding to the vertical projection of an arbitrary point in project space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ GetVerticalProjectionPoint(
    XYZ modelLocation,
    FloorFace floorFace
)
Visual Basic
Public Function GetVerticalProjectionPoint ( _
    modelLocation As XYZ, _
    floorFace As FloorFace _
) As XYZ
Visual C++
public:
XYZ^ GetVerticalProjectionPoint(
    XYZ^ modelLocation,
    FloorFace floorFace
)

Parameters

modelLocation
Type: Autodesk.Revit.DB..::..XYZ
A point in project coordinates that will be projected to the slab top or bottom face.
floorFace
Type: Autodesk.Revit.DB..::..FloorFace
A flag determining whether the top or bottom face of the floor should be used.

Return Value

Slab surface point for the vertically projected model point.

Remarks

If the floor is shape edited, the surface location must be within the boundaries of a face on the slab. Otherwise the method will return nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Floor Class


Floor Properties

[image] [image]

Revit 2024 API
Floor Properties
Floor Class See Also Send Feedback

The Floor type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FloorType | Retrieves/sets an object that represents the type of the floor.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchId | Returns id of the sketch.
Public property | SlabShapeEditor | Obsolete. Get the SlabShapeEditor used for slab shape editing.
Public property | SpanDirectionAngle | Retrieve the span direction angle of the floor.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Floor Class


FloorType Property

[image]

Revit 2024 API
Floor..::..FloorType Property
Floor Class See Also Send Feedback
Retrieves/sets an object that represents the type of the floor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FloorType FloorType { get; set; }
Visual Basic
Public Property FloorType As FloorType
    Get
    Set
Visual C++
public:
property FloorType^ FloorType {
    FloorType^ get ();
    void set (FloorType^ value);
}

Remarks

The floor type can be used to access the multi layered structure of a floor.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: Floor type is not valid for this floor.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

Floor Class


Parameter Property

[image] [image]

Revit 2024 API
Floor..::..Parameter Property
Floor Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Floor Class
Floor Members


SketchId Property

[image]

Revit 2024 API
Floor..::..SketchId Property
Floor Class See Also Send Feedback
Returns id of the sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public ElementId SketchId { get; }
Visual Basic
Public ReadOnly Property SketchId As ElementId
    Get
Visual C++
public:
property ElementId^ SketchId {
    ElementId^ get ();
}

See Also

Floor Class


FloorFace Enumeration

[image]

Revit 2024 API
FloorFace Enumeration
See Also Send Feedback
An enumerated type listing floor face types (top or bottom)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum FloorFace
Visual Basic
Public Enumeration FloorFace
Visual C++
public enum class FloorFace

Members

Member name | Description
Top |
Bottom |

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


FloorType Class

[image]

Revit 2024 API
FloorType Class
Members Example See Also Send Feedback
An object that specifies the type of a floor in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class FloorType : HostObjAttributes
Visual Basic
Public Class FloorType _
    Inherits HostObjAttributes
Visual C++
public ref class FloorType : public HostObjAttributes

Remarks

The structural layers of the floor can be accessed via this object.

Examples

CopyC#
public void GetInfo_FloorType(FloorType floorType)
{
    string message;
    // Get whether FloorType is a foundation slab
    message = "If is foundation slab : " + floorType.IsFoundationSlab;
    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetInfo_FloorType(floorType As FloorType)
    Dim message As String
    ' Get whether FloorType is a foundation slab
    message = "If is foundation slab : " & Convert.ToString(floorType.IsFoundationSlab)
    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..HostObjAttributes
Autodesk.Revit.DB..::..FloorType

See Also

FloorType Members


FloorType Members

[image] [image]

Revit 2024 API
FloorType Members
FloorType Class Methods Properties See Also Send Feedback

The FloorType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsFoundationSlab | Returns whether the element FloorAttributes type is FoundationSlab.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | StructuralMaterialId | Returns the identifier of the material that defines the element's structural analysis properties.
Public property | ThermalProperties | The calculated and settable thermal properties of the FloorType
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FloorType Class


FloorType Properties

[image] [image]

Revit 2024 API
FloorType Properties
FloorType Class See Also Send Feedback

The FloorType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsFoundationSlab | Returns whether the element FloorAttributes type is FoundationSlab.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | StructuralMaterialId | Returns the identifier of the material that defines the element's structural analysis properties.
Public property | ThermalProperties | The calculated and settable thermal properties of the FloorType
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FloorType Class


IsFoundationSlab Property

[image]

Revit 2024 API
FloorType..::..IsFoundationSlab Property
FloorType Class See Also Send Feedback
Returns whether the element FloorAttributes type is FoundationSlab.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsFoundationSlab { get; }
Visual Basic
Public ReadOnly Property IsFoundationSlab As Boolean
    Get
Visual C++
public:
property bool IsFoundationSlab {
    bool get ();
}

See Also

FloorType Class


StructuralMaterialId Property

[image]

Revit 2024 API
FloorType..::..StructuralMaterialId Property
FloorType Class See Also Send Feedback
Returns the identifier of the material that defines the element's structural analysis properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ElementId StructuralMaterialId { get; set; }
Visual Basic
Public Property StructuralMaterialId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ StructuralMaterialId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: the floor does not have a structural material

See Also

FloorType Class


ThermalProperties Property

[image]

Revit 2024 API
FloorType..::..ThermalProperties Property
FloorType Class See Also Send Feedback
The calculated and settable thermal properties of the FloorType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ThermalProperties ThermalProperties { get; }
Visual Basic
Public ReadOnly Property ThermalProperties As ThermalProperties
    Get
Visual C++
public:
property ThermalProperties^ ThermalProperties {
    ThermalProperties^ get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | the floor does not have thermal properties.

See Also

FloorType Class


Dispose Method

[image]

Revit 2024 API
FolderItemInfo..::..Dispose Method
FolderItemInfo Class See Also Send Feedback
Releases all resources used by the FolderItemInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FolderItemInfo Class


FolderItemInfo Properties

[image] [image]

Revit 2024 API
FolderItemInfo Properties
FolderItemInfo Class See Also Send Feedback

The FolderItemInfo type exposes the following members.

Properties

 | Name | Description
Public property | ElementId | The folder parameter Id
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | The folder name

See Also

FolderItemInfo Class


ElementId Property

[image]

Revit 2024 API
FolderItemInfo..::..ElementId Property
FolderItemInfo Class See Also Send Feedback
The folder parameter Id

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public ElementId ElementId { get; }
Visual Basic
Public ReadOnly Property ElementId As ElementId
    Get
Visual C++
public:
property ElementId^ ElementId {
    ElementId^ get ();
}

See Also

FolderItemInfo Class


IsValidObject Property

[image]

Revit 2024 API
FolderItemInfo..::..IsValidObject Property
FolderItemInfo Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

FolderItemInfo Class


Name Property

[image]

Revit 2024 API
FolderItemInfo..::..Name Property
FolderItemInfo Class See Also Send Feedback
The folder name

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

FolderItemInfo Class


FootPrintRoof Class

[image]

Revit 2024 API
FootPrintRoof Class
Members See Also Send Feedback
Represents kinds of FootPrintRoofs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class FootPrintRoof : RoofBase
Visual Basic
Public Class FootPrintRoof _
    Inherits RoofBase
Visual C++
public ref class FootPrintRoof : public RoofBase

Remarks

The FootPrintRoof object represents some kinds of FootPrintRoof in Revit. The RoofType property is used to distinguish the type of the roof.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB..::..RoofBase
Autodesk.Revit.DB..::..FootPrintRoof

See Also

FootPrintRoof Members


FootPrintRoof Methods

[image] [image]

Revit 2024 API
FootPrintRoof Methods
FootPrintRoof Class See Also Send Feedback

The FootPrintRoof type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetProfiles | Retrieve all the curveLoops of FootPrintRoof.
Public method | GetSlabShapeEditor | Gets a SlabShapeEditor that can used to add or modify points of this RoofBase. (Inherited from RoofBase.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FootPrintRoof Class


GetProfiles Method

[image]

Revit 2024 API
FootPrintRoof..::..GetProfiles Method
FootPrintRoof Class See Also Send Feedback
Retrieve all the curveLoops of FootPrintRoof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ModelCurveArrArray GetProfiles()
Visual Basic
Public Function GetProfiles As ModelCurveArrArray
Visual C++
public:
ModelCurveArrArray^ GetProfiles()

See Also

FootPrintRoof Class


FootPrintRoof Properties

[image] [image]

Revit 2024 API
FootPrintRoof Properties
FootPrintRoof Class See Also Send Feedback

The FootPrintRoof type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurtainGrids | Retrieve all the CurtainGrid objects of a FootPrintRoof.
Public property | DefinesSlope | Retrieve or set the DefinesSlope of the curve.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EaveCuts | Retrieve or set the EaveCutterType. (Inherited from RoofBase.)
Public property | ExtendIntoWall | Retrieve or set whether extend into wall the curve.
Public property | FasciaDepth | Retrieve or set the FasciaDepth. (Inherited from RoofBase.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Offset | Retrieve or set the Offset of the curve.
Public property | Overhang | Retrieve or set the Overhang of the curve.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RoofType | Retrieve or set the Type. (Inherited from RoofBase.)
Public property | SlabShapeEditor | Obsolete. Get the SlabShapeEditor used for slab shape editing. (Inherited from RoofBase.)
Public property | SlopeAngle | Retrieve or set the SlopeAngle of the curve.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FootPrintRoof Class


CurtainGrids Property

[image]

Revit 2024 API
FootPrintRoof..::..CurtainGrids Property
FootPrintRoof Class See Also Send Feedback
Retrieve all the CurtainGrid objects of a FootPrintRoof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CurtainGridSet CurtainGrids { get; }
Visual Basic
Public ReadOnly Property CurtainGrids As CurtainGridSet
    Get
Visual C++
public:
property CurtainGridSet^ CurtainGrids {
    CurtainGridSet^ get ();
}

Remarks

Only applicable when the object is a Curtain FootPrintRoof.

See Also

FootPrintRoof Class


DefinesSlope Property

[image]

Revit 2024 API
FootPrintRoof..::..DefinesSlope Property
FootPrintRoof Class See Also Send Feedback
Retrieve or set the DefinesSlope of the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool this[
    ModelCurve pCurve
] { get; set; }
Visual Basic
Public Property DefinesSlope ( _
    pCurve As ModelCurve _
) As Boolean
    Get
    Set
Visual C++
public:
property bool DefinesSlope[ModelCurve^ pCurve] {
    bool get (ModelCurve^ pCurve);
    void set (ModelCurve^ pCurve, bool value);
}

Parameters

pCurve
Type: Autodesk.Revit.DB..::..ModelCurve

See Also

FootPrintRoof Class


ExtendIntoWall Property

[image]

Revit 2024 API
FootPrintRoof..::..ExtendIntoWall Property
FootPrintRoof Class See Also Send Feedback
Retrieve or set whether extend into wall the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool this[
    ModelCurve pCurve
] { get; set; }
Visual Basic
Public Property ExtendIntoWall ( _
    pCurve As ModelCurve _
) As Boolean
    Get
    Set
Visual C++
public:
property bool ExtendIntoWall[ModelCurve^ pCurve] {
    bool get (ModelCurve^ pCurve);
    void set (ModelCurve^ pCurve, bool value);
}

Parameters

pCurve
Type: Autodesk.Revit.DB..::..ModelCurve

Remarks

Only applicable when the FootPrintRoof is created with Pick Walls.

See Also

FootPrintRoof Class


Offset Property

[image]

Revit 2024 API
FootPrintRoof..::..Offset Property
FootPrintRoof Class See Also Send Feedback
Retrieve or set the Offset of the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double this[
    ModelCurve pCurve
] { get; set; }
Visual Basic
Public Property Offset ( _
    pCurve As ModelCurve _
) As Double
    Get
    Set
Visual C++
public:
property double Offset[ModelCurve^ pCurve] {
    double get (ModelCurve^ pCurve);
    void set (ModelCurve^ pCurve, double value);
}

Parameters

pCurve
Type: Autodesk.Revit.DB..::..ModelCurve

See Also

FootPrintRoof Class


Overhang Property

[image]

Revit 2024 API
FootPrintRoof..::..Overhang Property
FootPrintRoof Class See Also Send Feedback
Retrieve or set the Overhang of the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double this[
    ModelCurve pCurve
] { get; set; }
Visual Basic
Public Property Overhang ( _
    pCurve As ModelCurve _
) As Double
    Get
    Set
Visual C++
public:
property double Overhang[ModelCurve^ pCurve] {
    double get (ModelCurve^ pCurve);
    void set (ModelCurve^ pCurve, double value);
}

Parameters

pCurve
Type: Autodesk.Revit.DB..::..ModelCurve

Remarks

Only applicable when the FootPrintRoof is created with Pick Walls.

See Also

FootPrintRoof Class


SlopeAngle Property

[image]

Revit 2024 API
FootPrintRoof..::..SlopeAngle Property
FootPrintRoof Class See Also Send Feedback
Retrieve or set the SlopeAngle of the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double this[
    ModelCurve pCurve
] { get; set; }
Visual Basic
Public Property SlopeAngle ( _
    pCurve As ModelCurve _
) As Double
    Get
    Set
Visual C++
public:
property double SlopeAngle[ModelCurve^ pCurve] {
    double get (ModelCurve^ pCurve);
    void set (ModelCurve^ pCurve, double value);
}

Parameters

pCurve
Type: Autodesk.Revit.DB..::..ModelCurve

Remarks

The value is a "slope" measurement. For example, 0.5 is one unit of rise for each 2 units of run. This creates a slope of 26.57 degrees (the arctangent of 0.5).

See Also

FootPrintRoof Class


ForgeTypeId Members

[image] [image]

Revit 2024 API
ForgeTypeId Members
ForgeTypeId Class Constructors Methods Operators Properties See Also Send Feedback

The ForgeTypeId type exposes the following members.

Constructors

 | Name | Description
Public method | ForgeTypeId()()()() | Constructs a ForgeTypeId holding an empty schema identifier.
Public method | ForgeTypeId(String) | Constructs a ForgeTypeId holding the given schema identifier.

Methods

 | Name | Description
Public method | Clear | Sets the typeId to an empty string
Public method | Dispose | Releases all resources used by the ForgeTypeId
Public method | Empty | Checks if the typeId is an empty string
Public method | Equals | Determines whether this ForgeTypeId is equal to another. (Overrides Object..::..Equals(Object).)
Public method | GetHashCode | Returns the hash code for this ForgeTypeId (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NameEquals | Returns true if the typeid string held by this ForgeTypeId is equal to that held by the given ForgeTypeId, excluding the version number. The version number of a typeid string follows a hyphen character. This function compares the typeid strings up to the first hyphen. This is the default equality comparison method for the ForgeTypeId class, used by the equality operator (==).
Public method | StrictlyEquals | Returns true if the entire typeid string held by this ForgeTypeId is exactly equal to that held by the given ForgeTypeId. For the default equality comparison used by the equality operator (==), see NameEquals(ForgeTypeId).
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Operators

Name | Description
Equality |
Inequality |
LessThan |

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | TypeId | The schema identifier.

See Also

ForgeTypeId Class


ForgeTypeId Constructor

[image] [image]

Revit 2024 API
ForgeTypeId Constructor
ForgeTypeId Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ForgeTypeId()()()() | Constructs a ForgeTypeId holding an empty schema identifier.
Public method | ForgeTypeId(String) | Constructs a ForgeTypeId holding the given schema identifier.

See Also

ForgeTypeId Class
ForgeTypeId Members


ForgeTypeId Constructor

[image]

Revit 2024 API
ForgeTypeId Constructor
ForgeTypeId Class See Also Send Feedback
Constructs a ForgeTypeId holding an empty schema identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public ForgeTypeId()
Visual Basic
Public Sub New
Visual C++
public:
ForgeTypeId()

See Also

ForgeTypeId Class
ForgeTypeId Overload


ForgeTypeId Constructor (String)

[image]

Revit 2024 API
ForgeTypeId Constructor (String)
ForgeTypeId Class See Also Send Feedback
Constructs a ForgeTypeId holding the given schema identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public ForgeTypeId(
    string typeId
)
Visual Basic
Public Sub New ( _
    typeId As String _
)
Visual C++
public:
ForgeTypeId(
    String^ typeId
)

Parameters

typeId
Type: System..::..String

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ForgeTypeId Class
ForgeTypeId Overload


Clear Method

[image]

Revit 2024 API
ForgeTypeId..::..Clear Method
ForgeTypeId Class See Also Send Feedback
Sets the typeId to an empty string

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public ForgeTypeId Clear()
Visual Basic
Public Function Clear As ForgeTypeId
Visual C++
public:
ForgeTypeId^ Clear()

See Also

ForgeTypeId Class


Empty Method

[image]

Revit 2024 API
ForgeTypeId..::..Empty Method
ForgeTypeId Class See Also Send Feedback
Checks if the typeId is an empty string

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public bool Empty()
Visual Basic
Public Function Empty As Boolean
Visual C++
public:
bool Empty()

See Also

ForgeTypeId Class


Equals Method

[image]

Revit 2024 API
ForgeTypeId..::..Equals Method
ForgeTypeId Class See Also Send Feedback
Determines whether this ForgeTypeId is equal to another.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public override bool Equals(
    Object other
)
Visual Basic
Public Overrides Function Equals ( _
    other As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ other
) override

Parameters

other
Type: System..::..Object
The ForgeTypeId with which to compare this ForgeTypeId.

Return Value

True if the given ForgeTypeId is equal to this one, or false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ForgeTypeId Class


GetHashCode Method

[image]

Revit 2024 API
ForgeTypeId..::..GetHashCode Method
ForgeTypeId Class See Also Send Feedback
Returns the hash code for this ForgeTypeId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

A 32-bit signed integer hash code.

See Also

ForgeTypeId Class


NameEquals Method

[image]

Revit 2024 API
ForgeTypeId..::..NameEquals Method
ForgeTypeId Class See Also Send Feedback
Returns true if the typeid string held by this ForgeTypeId is equal to that held by the given ForgeTypeId, excluding the version number. The version number of a typeid string follows a hyphen character. This function compares the typeid strings up to the first hyphen. This is the default equality comparison method for the ForgeTypeId class, used by the equality operator (==).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public bool NameEquals(
    ForgeTypeId other
)
Visual Basic
Public Function NameEquals ( _
    other As ForgeTypeId _
) As Boolean
Visual C++
public:
bool NameEquals(
    ForgeTypeId^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..ForgeTypeId

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ForgeTypeId Class


StrictlyEquals Method

[image]

Revit 2024 API
ForgeTypeId..::..StrictlyEquals Method
ForgeTypeId Class See Also Send Feedback
Returns true if the entire typeid string held by this ForgeTypeId is exactly equal to that held by the given ForgeTypeId. For the default equality comparison used by the equality operator (==), see NameEquals(ForgeTypeId).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public bool StrictlyEquals(
    ForgeTypeId other
)
Visual Basic
Public Function StrictlyEquals ( _
    other As ForgeTypeId _
) As Boolean
Visual C++
public:
bool StrictlyEquals(
    ForgeTypeId^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..ForgeTypeId

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ForgeTypeId Class


ForgeTypeId Operators

[image] [image]

Revit 2024 API
ForgeTypeId Operators
ForgeTypeId Class See Also Send Feedback

The ForgeTypeId type exposes the following members.

Operators

Name | Description
Equality |
Inequality |
LessThan |

See Also

ForgeTypeId Class


LessThan Operator

[image]

Revit 2024 API
ForgeTypeId..::..LessThan Operator
ForgeTypeId Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static bool operator <(
    ForgeTypeId lhs,
    ForgeTypeId rhs
)
Visual Basic
Public Shared Operator < ( _
    lhs As ForgeTypeId, _
    rhs As ForgeTypeId _
) As Boolean
Visual C++
public:
static bool operator <(
    ForgeTypeId^ lhs,
    ForgeTypeId^ rhs
)

Parameters

lhs
Type: Autodesk.Revit.DB..::..ForgeTypeId
rhs
Type: Autodesk.Revit.DB..::..ForgeTypeId

See Also

ForgeTypeId Class


ForgeTypeId Properties

[image] [image]

Revit 2024 API
ForgeTypeId Properties
ForgeTypeId Class See Also Send Feedback

The ForgeTypeId type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | TypeId | The schema identifier.

See Also

ForgeTypeId Class


TypeId Property

[image]

Revit 2024 API
ForgeTypeId..::..TypeId Property
ForgeTypeId Class See Also Send Feedback
The schema identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public string TypeId { get; set; }
Visual Basic
Public Property TypeId As String
    Get
    Set
Visual C++
public:
property String^ TypeId {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ForgeTypeId Class


Form Class

[image]

Revit 2024 API
Form Class
Members See Also Send Feedback
An object that represents a Form within the Autodesk Revit Massing Family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class Form : GenericForm
Visual Basic
Public Class Form _
    Inherits GenericForm
Visual C++
public ref class Form : public GenericForm

Remarks

For any reference returned from a Form method, its GeometryObject will become invalid after a form modification method, e.g. MoveSubElement. Call the method on the Form object to retrieve the new reference if it is needed after the modification.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..CombinableElement
Autodesk.Revit.DB..::..GenericForm
Autodesk.Revit.DB..::..Form

See Also

Form Members


Form Members

[image] [image]

Revit 2024 API
Form Members
Form Class Methods Properties See Also Send Feedback

The Form type exposes the following members.

Methods

 | Name | Description
Public method | AddEdge(Reference, Reference) | Add an edge to the form, connecting two edges on same/different profile, by a pair of specified points.
Public method | AddEdge(Reference, XYZ) | Add an edge to the form, connecting two edges on different profiles, by a specified face of the form and a point on face.
Public method | AddEdge(Reference, Double, Reference, Double) | Add an edge to the form, connecting two edges on same/different profile, by a pair of specified edge/param.
Public method | AddProfile | Add a profile into the form, by a specified edge/param.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanManipulateProfile | Tell if a profile can be deleted/moved/rotated.
Public method | CanManipulateSubElement | Tell if a sub element can be deleted/moved/rotated/scaled.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | ConstrainProfiles | Constrain form profiles using the specified profile as primary. This is an advanced version of property "AreProfilesConstrained", allowing specify the primary profile.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteProfile | Delete a profile of the form.
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubElement | Delete a face/edge/curve/vertex of the form, specified by a reference.
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetControlPoints | Given an edge or a curve or a face, return all control points lying on it (in form of geometry references).
Public method | GetCurvesAndEdgesReference | Given a point, return all edges and curves that it is lying on.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPathCurveIndexByCurveReference | Given a reference to certain curve in the path, return its index.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetProfileAndCurveLoopIndexFromReference | Given a reference to certain curve or edge, get the index of its profile and curve loop respectively.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsAutoCreaseEdge | Tell if an edge is an auto-crease on a top/bottom cap face.
Public method | IsBeginningFace | Given a face, tell if it is a beginning cap face.
Public method | IsConnectingEdge | Tell if an edge is a connecting edge on a side face. Connecting edges connect vertices on different profiles.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsCurveReference | Tell if the pick is the reference to a curve of the form.
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsEdgeReference | Tell if the pick is the reference to an edge of the form.
Public method | IsEndFace | Given a face, tell if it is an end cap face.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsFaceReference | Tell if the pick is the reference to a face of the form.
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsProfileEdge | Tell if an edge or curve is generated from a profile.
Public method | IsReferenceOnlyProfile | Tell if the profile is made by referencing existing geometry in the Revit model.
Public method | IsSideFace | Given a face, tell if it is a side face.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | IsVertexReference | Tell if the pick is the reference to a vertex of the form.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | MoveProfile | Move a profile of the form, specified by a reference, and an offset vector.
Public method | MoveSubElement | Move a face/edge/curve/vertex of the form, specified by a reference, and an offset vector.
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | Rehost(Reference, XYZ) | Rehost Form to edge, face or curve.
Public method | Rehost(SketchPlane, XYZ) | Rehost Form to sketch plane
Public method | RotateProfile | Rotate a profile of the form, by a specified angle around a given axis.
Public method | RotateSubElement | Rotate a face/edge/curve/vertex of the form, by a specified angle around a given axis.
Public method | ScaleProfile | Scale a profile of the form, by a specified origin and scale factor.
Public method | ScaleSubElement | Scale a face/edge/curve/vertex of the form, by a specified origin and scale factor.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AreProfilesConstrained | Get/set if the form's profiles are constrained.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BaseOffset | Retrieve/set the base offset of the form object. It is only valid for locked form.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveLoopReferencesOnProfile | The curve references in certain curve loop, specified by profile index and curve loop index.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | HasOneOrMoreReferenceProfiles | Tell if the form has any reference profile.
Public property | HasOpenGeometry | Tell if the form has an open geometry.
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsInXRayMode | Get/set if the form is in X-Ray mode.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Get and Set the Name property (Inherited from GenericForm.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PathCurveCount | The number of curves in the form path.
Public property | PathCurveReference | The curve reference in the path, specified by curve index.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ProfileCount | The number of profiles in the form.
Public property | ProfileCurveLoopCount | The number of curve loops in certain profile, specified by profile index.
Public property | Subcategory | The subcategory. (Inherited from GenericForm.)
Public property | TopOffset | Retrieve/set the top offset of the form object. It is only valid for locked form.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Visible | The visibility of the GenericForm. (Inherited from GenericForm.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Form Class


Form Methods

[image] [image]

Revit 2024 API
Form Methods
Form Class See Also Send Feedback

The Form type exposes the following members.

Methods

 | Name | Description
Public method | AddEdge(Reference, Reference) | Add an edge to the form, connecting two edges on same/different profile, by a pair of specified points.
Public method | AddEdge(Reference, XYZ) | Add an edge to the form, connecting two edges on different profiles, by a specified face of the form and a point on face.
Public method | AddEdge(Reference, Double, Reference, Double) | Add an edge to the form, connecting two edges on same/different profile, by a pair of specified edge/param.
Public method | AddProfile | Add a profile into the form, by a specified edge/param.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanManipulateProfile | Tell if a profile can be deleted/moved/rotated.
Public method | CanManipulateSubElement | Tell if a sub element can be deleted/moved/rotated/scaled.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | ConstrainProfiles | Constrain form profiles using the specified profile as primary. This is an advanced version of property "AreProfilesConstrained", allowing specify the primary profile.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteProfile | Delete a profile of the form.
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubElement | Delete a face/edge/curve/vertex of the form, specified by a reference.
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetControlPoints | Given an edge or a curve or a face, return all control points lying on it (in form of geometry references).
Public method | GetCurvesAndEdgesReference | Given a point, return all edges and curves that it is lying on.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPathCurveIndexByCurveReference | Given a reference to certain curve in the path, return its index.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetProfileAndCurveLoopIndexFromReference | Given a reference to certain curve or edge, get the index of its profile and curve loop respectively.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsAutoCreaseEdge | Tell if an edge is an auto-crease on a top/bottom cap face.
Public method | IsBeginningFace | Given a face, tell if it is a beginning cap face.
Public method | IsConnectingEdge | Tell if an edge is a connecting edge on a side face. Connecting edges connect vertices on different profiles.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsCurveReference | Tell if the pick is the reference to a curve of the form.
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsEdgeReference | Tell if the pick is the reference to an edge of the form.
Public method | IsEndFace | Given a face, tell if it is an end cap face.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsFaceReference | Tell if the pick is the reference to a face of the form.
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsProfileEdge | Tell if an edge or curve is generated from a profile.
Public method | IsReferenceOnlyProfile | Tell if the profile is made by referencing existing geometry in the Revit model.
Public method | IsSideFace | Given a face, tell if it is a side face.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | IsVertexReference | Tell if the pick is the reference to a vertex of the form.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | MoveProfile | Move a profile of the form, specified by a reference, and an offset vector.
Public method | MoveSubElement | Move a face/edge/curve/vertex of the form, specified by a reference, and an offset vector.
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | Rehost(Reference, XYZ) | Rehost Form to edge, face or curve.
Public method | Rehost(SketchPlane, XYZ) | Rehost Form to sketch plane
Public method | RotateProfile | Rotate a profile of the form, by a specified angle around a given axis.
Public method | RotateSubElement | Rotate a face/edge/curve/vertex of the form, by a specified angle around a given axis.
Public method | ScaleProfile | Scale a profile of the form, by a specified origin and scale factor.
Public method | ScaleSubElement | Scale a face/edge/curve/vertex of the form, by a specified origin and scale factor.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Form Class


AddEdge Method

[image] [image]

Revit 2024 API
Form..::..AddEdge Method
Form Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddEdge(Reference, Reference) | Add an edge to the form, connecting two edges on same/different profile, by a pair of specified points.
Public method | AddEdge(Reference, XYZ) | Add an edge to the form, connecting two edges on different profiles, by a specified face of the form and a point on face.
Public method | AddEdge(Reference, Double, Reference, Double) | Add an edge to the form, connecting two edges on same/different profile, by a pair of specified edge/param.

See Also

Form Class
Form Members


AddEdge Method (Reference, XYZ)

[image]

Revit 2024 API
Form..::..AddEdge Method (Reference, XYZ)
Form Class See Also Send Feedback
Add an edge to the form, connecting two edges on different profiles, by a specified face of the form and a point on face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void AddEdge(
    Reference faceReference,
    XYZ point
)
Visual Basic
Public Sub AddEdge ( _
    faceReference As Reference, _
    point As XYZ _
)
Visual C++
public:
void AddEdge(
    Reference^ faceReference,
    XYZ^ point
)

Parameters

faceReference
Type: Autodesk.Revit.DB..::..Reference
The geometry reference of face
point
Type: Autodesk.Revit.DB..::..XYZ
A point on the face, defining the position of edge to be created.

See Also

Form Class
AddEdge Overload


AddEdge Method (Reference, Double, Reference, Double)

[image]

Revit 2024 API
Form..::..AddEdge Method (Reference, Double, Reference, Double)
Form Class See Also Send Feedback
Add an edge to the form, connecting two edges on same/different profile, by a pair of specified edge/param.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void AddEdge(
    Reference startEdgeReference,
    double startParam,
    Reference endEdgeReference,
    double endParam
)
Visual Basic
Public Sub AddEdge ( _
    startEdgeReference As Reference, _
    startParam As Double, _
    endEdgeReference As Reference, _
    endParam As Double _
)
Visual C++
public:
void AddEdge(
    Reference^ startEdgeReference,
    double startParam,
    Reference^ endEdgeReference,
    double endParam
)

Parameters

startEdgeReference
Type: Autodesk.Revit.DB..::..Reference
The geometry reference of start edge
startParam
Type: System..::..Double
The param on start edge to specify the location.
endEdgeReference
Type: Autodesk.Revit.DB..::..Reference
The geometry reference of end edge
endParam
Type: System..::..Double
The param on end edge to specify the location.

See Also

Form Class
AddEdge Overload


AddProfile Method

[image]

Revit 2024 API
Form..::..AddProfile Method
Form Class See Also Send Feedback
Add a profile into the form, by a specified edge/param.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public int AddProfile(
    Reference edgeReference,
    double param
)
Visual Basic
Public Function AddProfile ( _
    edgeReference As Reference, _
    param As Double _
) As Integer
Visual C++
public:
int AddProfile(
    Reference^ edgeReference,
    double param
)

Parameters

edgeReference
Type: Autodesk.Revit.DB..::..Reference
The geometry reference of edge.
param
Type: System..::..Double
The param on edge to specify the location.

Return Value

Index of newly created profile.

See Also

Form Class


CanManipulateSubElement Method

[image]

Revit 2024 API
Form..::..CanManipulateSubElement Method
Form Class See Also Send Feedback
Tell if a sub element can be deleted/moved/rotated/scaled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool CanManipulateSubElement(
    Reference subElementReference
)
Visual Basic
Public Function CanManipulateSubElement ( _
    subElementReference As Reference _
) As Boolean
Visual C++
public:
bool CanManipulateSubElement(
    Reference^ subElementReference
)

Parameters

subElementReference
Type: Autodesk.Revit.DB..::..Reference
The geometry reference of face/edge/curve/vertex

See Also

Form Class


ConstrainProfiles Method

[image]

Revit 2024 API
Form..::..ConstrainProfiles Method
Form Class See Also Send Feedback
Constrain form profiles using the specified profile as primary. This is an advanced version of property "AreProfilesConstrained", allowing specify the primary profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void ConstrainProfiles(
    int primaryProfileIndex
)
Visual Basic
Public Sub ConstrainProfiles ( _
    primaryProfileIndex As Integer _
)
Visual C++
public:
void ConstrainProfiles(
    int primaryProfileIndex
)

Parameters

primaryProfileIndex
Type: System..::..Int32
Index to specify the profile used as primary profile.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation can only be performed on a swept blend form.

See Also

Form Class


DeleteProfile Method

[image]

Revit 2024 API
Form..::..DeleteProfile Method
Form Class See Also Send Feedback
Delete a profile of the form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void DeleteProfile(
    int profileIndex
)
Visual Basic
Public Sub DeleteProfile ( _
    profileIndex As Integer _
)
Visual C++
public:
void DeleteProfile(
    int profileIndex
)

Parameters

profileIndex
Type: System..::..Int32
Index to specify the profile.

See Also

Form Class


DeleteSubElement Method

[image]

Revit 2024 API
Form..::..DeleteSubElement Method
Form Class See Also Send Feedback
Delete a face/edge/curve/vertex of the form, specified by a reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void DeleteSubElement(
    Reference subElementReference
)
Visual Basic
Public Sub DeleteSubElement ( _
    subElementReference As Reference _
)
Visual C++
public:
void DeleteSubElement(
    Reference^ subElementReference
)

Parameters

subElementReference
Type: Autodesk.Revit.DB..::..Reference
The geometry reference of face/edge/curve/vertex

See Also

Form Class


GetControlPoints Method

[image]

Revit 2024 API
Form..::..GetControlPoints Method
Form Class See Also Send Feedback
Given an edge or a curve or a face, return all control points lying on it (in form of geometry references).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ReferenceArray GetControlPoints(
    Reference curveOrEdgeOrFaceReference
)
Visual Basic
Public Function GetControlPoints ( _
    curveOrEdgeOrFaceReference As Reference _
) As ReferenceArray
Visual C++
public:
ReferenceArray^ GetControlPoints(
    Reference^ curveOrEdgeOrFaceReference
)

Parameters

curveOrEdgeOrFaceReference
Type: Autodesk.Revit.DB..::..Reference
The reference of an edge or curve or face.

Return Value

Reference array containing all control points lying on it.

See Also

Form Class


GetCurvesAndEdgesReference Method

[image]

Revit 2024 API
Form..::..GetCurvesAndEdgesReference Method
Form Class See Also Send Feedback
Given a point, return all edges and curves that it is lying on.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ReferenceArray GetCurvesAndEdgesReference(
    Reference pointReference
)
Visual Basic
Public Function GetCurvesAndEdgesReference ( _
    pointReference As Reference _
) As ReferenceArray
Visual C++
public:
ReferenceArray^ GetCurvesAndEdgesReference(
    Reference^ pointReference
)

Parameters

pointReference
Type: Autodesk.Revit.DB..::..Reference
The reference of a point.

Return Value

Reference array containing all edges and curves that the point is lying on.

See Also

Form Class


GetPathCurveIndexByCurveReference Method

[image]

Revit 2024 API
Form..::..GetPathCurveIndexByCurveReference Method
Form Class See Also Send Feedback
Given a reference to certain curve in the path, return its index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public int GetPathCurveIndexByCurveReference(
    Reference curveReference
)
Visual Basic
Public Function GetPathCurveIndexByCurveReference ( _
    curveReference As Reference _
) As Integer
Visual C++
public:
int GetPathCurveIndexByCurveReference(
    Reference^ curveReference
)

Parameters

curveReference
Type: Autodesk.Revit.DB..::..Reference
Reference to the curve in path

See Also

Form Class


GetProfileAndCurveLoopIndexFromReference Method

[image]

Revit 2024 API
Form..::..GetProfileAndCurveLoopIndexFromReference Method
Form Class See Also Send Feedback
Given a reference to certain curve or edge, get the index of its profile and curve loop respectively.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void GetProfileAndCurveLoopIndexFromReference(
    Reference curveOrEdgeReference,
    ref int profileIndex,
    ref int curveLoopIndex
)
Visual Basic
Public Sub GetProfileAndCurveLoopIndexFromReference ( _
    curveOrEdgeReference As Reference, _
    ByRef profileIndex As Integer, _
    ByRef curveLoopIndex As Integer _
)
Visual C++
public:
void GetProfileAndCurveLoopIndexFromReference(
    Reference^ curveOrEdgeReference,
    int% profileIndex,
    int% curveLoopIndex
)

Parameters

curveOrEdgeReference
Type: Autodesk.Revit.DB..::..Reference
Reference to a curve/edge that is part of one profile
profileIndex
Type: System..::..Int32%
Profile index for output
curveLoopIndex
Type: System..::..Int32%
Curve loop index for output

See Also

Form Class


IsAutoCreaseEdge Method

[image]

Revit 2024 API
Form..::..IsAutoCreaseEdge Method
Form Class See Also Send Feedback
Tell if an edge is an auto-crease on a top/bottom cap face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsAutoCreaseEdge(
    Reference edgeReference
)
Visual Basic
Public Function IsAutoCreaseEdge ( _
    edgeReference As Reference _
) As Boolean
Visual C++
public:
bool IsAutoCreaseEdge(
    Reference^ edgeReference
)

Parameters

edgeReference
Type: Autodesk.Revit.DB..::..Reference
The reference of the edge to be checked.

See Also

Form Class


IsConnectingEdge Method

[image]

Revit 2024 API
Form..::..IsConnectingEdge Method
Form Class See Also Send Feedback
Tell if an edge is a connecting edge on a side face. Connecting edges connect vertices on different profiles.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsConnectingEdge(
    Reference edgeReference
)
Visual Basic
Public Function IsConnectingEdge ( _
    edgeReference As Reference _
) As Boolean
Visual C++
public:
bool IsConnectingEdge(
    Reference^ edgeReference
)

Parameters

edgeReference
Type: Autodesk.Revit.DB..::..Reference
The reference of the edge to be checked.

See Also

Form Class


IsEdgeReference Method

[image]

Revit 2024 API
Form..::..IsEdgeReference Method
Form Class See Also Send Feedback
Tell if the pick is the reference to an edge of the form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsEdgeReference(
    Reference edgeReference
)
Visual Basic
Public Function IsEdgeReference ( _
    edgeReference As Reference _
) As Boolean
Visual C++
public:
bool IsEdgeReference(
    Reference^ edgeReference
)

Parameters

edgeReference
Type: Autodesk.Revit.DB..::..Reference
Reference to be checked.

See Also

Form Class


IsEndFace Method

[image]

Revit 2024 API
Form..::..IsEndFace Method
Form Class See Also Send Feedback
Given a face, tell if it is an end cap face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsEndFace(
    Reference faceReference
)
Visual Basic
Public Function IsEndFace ( _
    faceReference As Reference _
) As Boolean
Visual C++
public:
bool IsEndFace(
    Reference^ faceReference
)

Parameters

faceReference
Type: Autodesk.Revit.DB..::..Reference
The reference of the face to be checked.

See Also

Form Class


IsFaceReference Method

[image]

Revit 2024 API
Form..::..IsFaceReference Method
Form Class See Also Send Feedback
Tell if the pick is the reference to a face of the form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsFaceReference(
    Reference faceReference
)
Visual Basic
Public Function IsFaceReference ( _
    faceReference As Reference _
) As Boolean
Visual C++
public:
bool IsFaceReference(
    Reference^ faceReference
)

Parameters

faceReference
Type: Autodesk.Revit.DB..::..Reference
Reference to be checked.

See Also

Form Class


IsProfileEdge Method

[image]

Revit 2024 API
Form..::..IsProfileEdge Method
Form Class See Also Send Feedback
Tell if an edge or curve is generated from a profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsProfileEdge(
    Reference curveOrEdgeReference
)
Visual Basic
Public Function IsProfileEdge ( _
    curveOrEdgeReference As Reference _
) As Boolean
Visual C++
public:
bool IsProfileEdge(
    Reference^ curveOrEdgeReference
)

Parameters

curveOrEdgeReference
Type: Autodesk.Revit.DB..::..Reference
The reference of the edge or curve to be checked.

See Also

Form Class


IsReferenceOnlyProfile Method

[image]

Revit 2024 API
Form..::..IsReferenceOnlyProfile Method
Form Class See Also Send Feedback
Tell if the profile is made by referencing existing geometry in the Revit model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsReferenceOnlyProfile(
    int profileIndex
)
Visual Basic
Public Function IsReferenceOnlyProfile ( _
    profileIndex As Integer _
) As Boolean
Visual C++
public:
bool IsReferenceOnlyProfile(
    int profileIndex
)

Parameters

profileIndex
Type: System..::..Int32
Index to specify the profile to be checked.

See Also

Form Class


IsSideFace Method

[image]

Revit 2024 API
Form..::..IsSideFace Method
Form Class See Also Send Feedback
Given a face, tell if it is a side face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsSideFace(
    Reference faceReference
)
Visual Basic
Public Function IsSideFace ( _
    faceReference As Reference _
) As Boolean
Visual C++
public:
bool IsSideFace(
    Reference^ faceReference
)

Parameters

faceReference
Type: Autodesk.Revit.DB..::..Reference
The reference of the face to be checked.

See Also

Form Class


IsVertexReference Method

[image]

Revit 2024 API
Form..::..IsVertexReference Method
Form Class See Also Send Feedback
Tell if the pick is the reference to a vertex of the form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsVertexReference(
    Reference vertexReference
)
Visual Basic
Public Function IsVertexReference ( _
    vertexReference As Reference _
) As Boolean
Visual C++
public:
bool IsVertexReference(
    Reference^ vertexReference
)

Parameters

vertexReference
Type: Autodesk.Revit.DB..::..Reference
Reference to be checked.

See Also

Form Class


MoveProfile Method

[image]

Revit 2024 API
Form..::..MoveProfile Method
Form Class Example See Also Send Feedback
Move a profile of the form, specified by a reference, and an offset vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void MoveProfile(
    int profileIndex,
    XYZ offset
)
Visual Basic
Public Sub MoveProfile ( _
    profileIndex As Integer, _
    offset As XYZ _
)
Visual C++
public:
void MoveProfile(
    int profileIndex,
    XYZ^ offset
)

Parameters

profileIndex
Type: System..::..Int32
Index to specify the profile.
offset
Type: Autodesk.Revit.DB..::..XYZ
The vector by which the element is to be moved.

Examples

CopyC#
public void MoveForm(Form form)
{
    int profileCount = form.ProfileCount;
    if (form.ProfileCount > 0)
    {
        int profileIndex = 0;   // modify the first form only
        if (form.CanManipulateProfile(profileIndex))
        {
            XYZ offset = new XYZ(-25, 0, 0);
            form.MoveProfile(profileIndex, offset);
        }
    }
}
CopyVB.NET
Public Sub MoveForm(form As Form)
    Dim profileCount As Integer = form.ProfileCount
    If form.ProfileCount > 0 Then
        Dim profileIndex As Integer = 0
        ' modify the first form only
        If form.CanManipulateProfile(profileIndex) Then
            Dim offset As New XYZ(-25, 0, 0)
            form.MoveProfile(profileIndex, offset)
        End If
    End If
End Sub

See Also

Form Class


Rehost Method

[image] [image]

Revit 2024 API
Form..::..Rehost Method
Form Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Rehost(Reference, XYZ) | Rehost Form to edge, face or curve.
Public method | Rehost(SketchPlane, XYZ) | Rehost Form to sketch plane

See Also

Form Class
Form Members


Rehost Method (Reference, XYZ)

[image]

Revit 2024 API
Form..::..Rehost Method (Reference, XYZ)
Form Class See Also Send Feedback
Rehost Form to edge, face or curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public void Rehost(
    Reference hostRef,
    XYZ location
)
Visual Basic
Public Sub Rehost ( _
    hostRef As Reference, _
    location As XYZ _
)
Visual C++
public:
void Rehost(
    Reference^ hostRef,
    XYZ^ location
)

Parameters

hostRef
Type: Autodesk.Revit.DB..::..Reference
The geometry reference on which to rehost the form.
location
Type: Autodesk.Revit.DB..::..XYZ
The location to which to Rehost the form.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the hostRef or location is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when rehosting Form failed.

See Also

Form Class
Rehost Overload


Rehost Method (SketchPlane, XYZ)

[image]

Revit 2024 API
Form..::..Rehost Method (SketchPlane, XYZ)
Form Class See Also Send Feedback
Rehost Form to sketch plane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public void Rehost(
    SketchPlane sketchPlane,
    XYZ location
)
Visual Basic
Public Sub Rehost ( _
    sketchPlane As SketchPlane, _
    location As XYZ _
)
Visual C++
public:
void Rehost(
    SketchPlane^ sketchPlane,
    XYZ^ location
)

Parameters

sketchPlane
Type: Autodesk.Revit.DB..::..SketchPlane
The sketch plane on which to rehost the form.
location
Type: Autodesk.Revit.DB..::..XYZ
The location to which to Rehost the form.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the sketchPlane or location is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when rehosting Form failed.

See Also

Form Class
Rehost Overload


RotateProfile Method

[image]

Revit 2024 API
Form..::..RotateProfile Method
Form Class See Also Send Feedback
Rotate a profile of the form, by a specified angle around a given axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void RotateProfile(
    int profileIndex,
    Line axis,
    double angle
)
Visual Basic
Public Sub RotateProfile ( _
    profileIndex As Integer, _
    axis As Line, _
    angle As Double _
)
Visual C++
public:
void RotateProfile(
    int profileIndex,
    Line^ axis,
    double angle
)

Parameters

profileIndex
Type: System..::..Int32
Index to specify the profile.
axis
Type: Autodesk.Revit.DB..::..Line
An unbounded line that represents the axis of rotation.
angle
Type: System..::..Double
The angle, in radians, by which the element is to be rotated around the specified axis.

See Also

Form Class


ScaleProfile Method

[image]

Revit 2024 API
Form..::..ScaleProfile Method
Form Class See Also Send Feedback
Scale a profile of the form, by a specified origin and scale factor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void ScaleProfile(
    int profileIndex,
    double factor,
    XYZ origin
)
Visual Basic
Public Sub ScaleProfile ( _
    profileIndex As Integer, _
    factor As Double, _
    origin As XYZ _
)
Visual C++
public:
void ScaleProfile(
    int profileIndex,
    double factor,
    XYZ^ origin
)

Parameters

profileIndex
Type: System..::..Int32
Index to specify the profile.
factor
Type: System..::..Double
The scale factor, it should be large than zero.
origin
Type: Autodesk.Revit.DB..::..XYZ
The origin where scale happens.

See Also

Form Class


ScaleSubElement Method

[image]

Revit 2024 API
Form..::..ScaleSubElement Method
Form Class See Also Send Feedback
Scale a face/edge/curve/vertex of the form, by a specified origin and scale factor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void ScaleSubElement(
    Reference subElementReference,
    double factor,
    XYZ origin
)
Visual Basic
Public Sub ScaleSubElement ( _
    subElementReference As Reference, _
    factor As Double, _
    origin As XYZ _
)
Visual C++
public:
void ScaleSubElement(
    Reference^ subElementReference,
    double factor,
    XYZ^ origin
)

Parameters

subElementReference
Type: Autodesk.Revit.DB..::..Reference
The geometry reference of face/edge/curve/vertex
factor
Type: System..::..Double
The scale factor, it should be large than zero.
origin
Type: Autodesk.Revit.DB..::..XYZ
The origin where scale happens.

See Also

Form Class


Form Properties

[image] [image]

Revit 2024 API
Form Properties
Form Class See Also Send Feedback

The Form type exposes the following members.

Properties

 | Name | Description
Public property | AreProfilesConstrained | Get/set if the form's profiles are constrained.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BaseOffset | Retrieve/set the base offset of the form object. It is only valid for locked form.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveLoopReferencesOnProfile | The curve references in certain curve loop, specified by profile index and curve loop index.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | HasOneOrMoreReferenceProfiles | Tell if the form has any reference profile.
Public property | HasOpenGeometry | Tell if the form has an open geometry.
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsInXRayMode | Get/set if the form is in X-Ray mode.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Get and Set the Name property (Inherited from GenericForm.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PathCurveCount | The number of curves in the form path.
Public property | PathCurveReference | The curve reference in the path, specified by curve index.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ProfileCount | The number of profiles in the form.
Public property | ProfileCurveLoopCount | The number of curve loops in certain profile, specified by profile index.
Public property | Subcategory | The subcategory. (Inherited from GenericForm.)
Public property | TopOffset | Retrieve/set the top offset of the form object. It is only valid for locked form.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Visible | The visibility of the GenericForm. (Inherited from GenericForm.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Form Class


AreProfilesConstrained Property

[image]

Revit 2024 API
Form..::..AreProfilesConstrained Property
Form Class See Also Send Feedback
Get/set if the form's profiles are constrained.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool AreProfilesConstrained { get; set; }
Visual Basic
Public Property AreProfilesConstrained As Boolean
    Get
    Set
Visual C++
public:
property bool AreProfilesConstrained {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property to 'true' This operation can only be performed on a swept blend form.

See Also

Form Class


CurveLoopReferencesOnProfile Property

[image]

Revit 2024 API
Form..::..CurveLoopReferencesOnProfile Property
Form Class See Also Send Feedback
The curve references in certain curve loop, specified by profile index and curve loop index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ReferenceArray this[
    int profileIndex,
    int curveLoopIndex
] { get; }
Visual Basic
Public ReadOnly Property CurveLoopReferencesOnProfile ( _
    profileIndex As Integer, _
    curveLoopIndex As Integer _
) As ReferenceArray
    Get
Visual C++
public:
property ReferenceArray^ CurveLoopReferencesOnProfile[int profileIndex, int curveLoopIndex] {
    ReferenceArray^ get (int profileIndex, int curveLoopIndex);
}

Parameters

profileIndex
Type: System..::..Int32
Index to specify the profile, should be within 0 and (ProfileCount - 1).
curveLoopIndex
Type: System..::..Int32
Index to specify the curve loop, should be within 0 and (CurveLoopCount - 1).

See Also

Form Class


HasOneOrMoreReferenceProfiles Property

[image]

Revit 2024 API
Form..::..HasOneOrMoreReferenceProfiles Property
Form Class See Also Send Feedback
Tell if the form has any reference profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool HasOneOrMoreReferenceProfiles { get; }
Visual Basic
Public ReadOnly Property HasOneOrMoreReferenceProfiles As Boolean
    Get
Visual C++
public:
property bool HasOneOrMoreReferenceProfiles {
    bool get ();
}

See Also

Form Class


HasOpenGeometry Property

[image]

Revit 2024 API
Form..::..HasOpenGeometry Property
Form Class See Also Send Feedback
Tell if the form has an open geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool HasOpenGeometry { get; }
Visual Basic
Public ReadOnly Property HasOpenGeometry As Boolean
    Get
Visual C++
public:
property bool HasOpenGeometry {
    bool get ();
}

See Also

Form Class


IsInXRayMode Property

[image]

Revit 2024 API
Form..::..IsInXRayMode Property
Form Class See Also Send Feedback
Get/set if the form is in X-Ray mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsInXRayMode { get; set; }
Visual Basic
Public Property IsInXRayMode As Boolean
    Get
    Set
Visual C++
public:
property bool IsInXRayMode {
    bool get ();
    void set (bool value);
}

See Also

Form Class


Parameter Property

[image] [image]

Revit 2024 API
Form..::..Parameter Property
Form Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Form Class
Form Members


PathCurveCount Property

[image]

Revit 2024 API
Form..::..PathCurveCount Property
Form Class See Also Send Feedback
The number of curves in the form path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public int PathCurveCount { get; }
Visual Basic
Public ReadOnly Property PathCurveCount As Integer
    Get
Visual C++
public:
property int PathCurveCount {
    int get ();
}

See Also

Form Class


PathCurveReference Property

[image]

Revit 2024 API
Form..::..PathCurveReference Property
Form Class See Also Send Feedback
The curve reference in the path, specified by curve index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Reference this[
    int curveIndex
] { get; }
Visual Basic
Public ReadOnly Property PathCurveReference ( _
    curveIndex As Integer _
) As Reference
    Get
Visual C++
public:
property Reference^ PathCurveReference[int curveIndex] {
    Reference^ get (int curveIndex);
}

Parameters

curveIndex
Type: System..::..Int32
Index to specify the curve in path

See Also

Form Class


ProfileCount Property

[image]

Revit 2024 API
Form..::..ProfileCount Property
Form Class See Also Send Feedback
The number of profiles in the form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public int ProfileCount { get; }
Visual Basic
Public ReadOnly Property ProfileCount As Integer
    Get
Visual C++
public:
property int ProfileCount {
    int get ();
}

See Also

Form Class


ProfileCurveLoopCount Property

[image]

Revit 2024 API
Form..::..ProfileCurveLoopCount Property
Form Class See Also Send Feedback
The number of curve loops in certain profile, specified by profile index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public int this[
    int index
] { get; }
Visual Basic
Public ReadOnly Property ProfileCurveLoopCount ( _
    index As Integer _
) As Integer
    Get
Visual C++
public:
property int ProfileCurveLoopCount[int index] {
    int get (int index);
}

Parameters

index
Type: System..::..Int32
Index to specify the profile, should be within 0 and (ProfileCount - 1).

See Also

Form Class


TopOffset Property

[image]

Revit 2024 API
Form..::..TopOffset Property
Form Class See Also Send Feedback
Retrieve/set the top offset of the form object. It is only valid for locked form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double TopOffset { get; set; }
Visual Basic
Public Property TopOffset As Double
    Get
    Set
Visual C++
public:
property double TopOffset {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when this is not a locked form.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the value is invalid.
Autodesk.Revit.Exceptions..::..ApplicationException | Thrown when it fail to get/set TopOffset.

See Also

Form Class


FormArray Class

[image]

Revit 2024 API
FormArray Class
Members See Also Send Feedback
An array that contains form objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class FormArray : APIObject, IEnumerable
Visual Basic
Public Class FormArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class FormArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..FormArray

See Also

FormArray Members


FormArray Members

[image] [image]

Revit 2024 API
FormArray Members
FormArray Class Constructors Methods Properties See Also Send Feedback

The FormArray type exposes the following members.

Constructors

 | Name | Description
Public method | FormArray | Initializes a new instance of the FormArray class

Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every form from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a form at a specified index within the array.
Public property | Size | Returns the number of forms that are in the array.

See Also

FormArray Class


FormArray Constructor

[image]

Revit 2024 API
FormArray Constructor
FormArray Class See Also Send Feedback
Initializes a new instance of the FormArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FormArray()
Visual Basic
Public Sub New
Visual C++
public:
FormArray()

See Also

FormArray Class


FormArray Methods

[image] [image]

Revit 2024 API
FormArray Methods
FormArray Class See Also Send Feedback

The FormArray type exposes the following members.

Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every form from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FormArray Class


Clear Method

[image]

Revit 2024 API
FormArray..::..Clear Method
FormArray Class See Also Send Feedback
Removes every form from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

FormArray Class


ForwardIterator Method

[image]

Revit 2024 API
FormArray..::..ForwardIterator Method
FormArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual FormArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As FormArrayIterator
Visual C++
public:
virtual FormArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

FormArray Class


GetEnumerator Method

[image]

Revit 2024 API
FormArray..::..GetEnumerator Method
FormArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

FormArray Class


ReverseIterator Method

[image]

Revit 2024 API
FormArray..::..ReverseIterator Method
FormArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual FormArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As FormArrayIterator
Visual C++
public:
virtual FormArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

FormArray Class


FormArray Properties

[image] [image]

Revit 2024 API
FormArray Properties
FormArray Class See Also Send Feedback

The FormArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a form at a specified index within the array.
Public property | Size | Returns the number of forms that are in the array.

See Also

FormArray Class


IsEmpty Property

[image]

Revit 2024 API
FormArray..::..IsEmpty Property
FormArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

FormArray Class


Size Property

[image]

Revit 2024 API
FormArray..::..Size Property
FormArray Class See Also Send Feedback
Returns the number of forms that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

FormArray Class


FormArrayIterator Class

[image]

Revit 2024 API
FormArrayIterator Class
Members See Also Send Feedback
An iterator to a form array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public abstract class FormArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class FormArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class FormArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..FormArrayIterator

See Also

FormArrayIterator Members


FormArrayIterator Members

[image] [image]

Revit 2024 API
FormArrayIterator Members
FormArrayIterator Class Constructors Methods Properties See Also Send Feedback

The FormArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | FormArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FormArrayIterator Class


FormArrayIterator Constructor

[image]

Revit 2024 API
FormArrayIterator Constructor
FormArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FormArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
FormArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FormArrayIterator Class


FormArrayIterator Methods

[image] [image]

Revit 2024 API
FormArrayIterator Methods
FormArrayIterator Class See Also Send Feedback

The FormArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FormArrayIterator Class


MoveNext Method

[image]

Revit 2024 API
FormArrayIterator..::..MoveNext Method
FormArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

FormArrayIterator Class


Current Property

[image]

Revit 2024 API
FormArrayIterator..::..Current Property
FormArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

FormArrayIterator Class


FormatOptions Class

[image]

Revit 2024 API
FormatOptions Class
Members See Also Send Feedback
Options for formatting numbers with units.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class FormatOptions : IDisposable
Visual Basic
Public Class FormatOptions _
    Implements IDisposable
Visual C++
public ref class FormatOptions : IDisposable

Remarks

The FormatOptions class contains settings that control how to format numbers with units as strings. It contains those settings that are typically chosen by an end user in the Format dialog and stored in the document.

The FormatOptions class is used in two different ways. A FormatOptions object in the Units class represents the default settings for the document. A FormatOptions object used elsewhere represents settings that may optionally override the default settings.

The UseDefault property controls whether a FormatOptions object represents default or custom formatting. If UseDefault is true, formatting will be according to the default settings in the Units class, and none of the other settings in the object are meaningful. If UseDefault is false, the object contains custom settings that override the default settings in the Units class. UseDefault is always false for FormatOptions objects in the Units class.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FormatOptions

See Also

FormatOptions Members


FormatOptions Members

[image] [image]

Revit 2024 API
FormatOptions Members
FormatOptions Class Constructors Methods Properties See Also Send Feedback

The FormatOptions type exposes the following members.

Constructors

 | Name | Description
Public method | FormatOptions()()()() | Creates a new FormatOptions object that represents default formatting.
Public method | FormatOptions(ForgeTypeId) | Creates a new FormatOptions object that represents custom formatting.
Public method | FormatOptions(FormatOptions) | Creates a copy of a FormatOptions object.
Public method | FormatOptions(ForgeTypeId, ForgeTypeId) | Creates a new FormatOptions object that represents custom formatting.

Methods

 | Name | Description
Public method | CanHaveSymbol()()()() | Checks whether a symbol can be specified to display the unit in this FormatOptions.
 | CanHaveSymbol(ForgeTypeId) | Checks whether a symbol can be specified to display a given unit.
Public method | CanSuppressLeadingZeros()()()() | Checks whether leading zeros can be suppressed for the display unit in this FormatOptions.
 | CanSuppressLeadingZeros(ForgeTypeId) | Checks whether leading zeros can be suppressed for a given unit.
Public method | CanSuppressSpaces()()()() | Checks whether spaces can be suppressed for the display unit in this FormatOptions.
 | CanSuppressSpaces(ForgeTypeId) | Checks whether spaces can be suppressed for a given unit.
Public method | CanSuppressTrailingZeros()()()() | Checks whether trailing zeros can be suppressed for the display unit in this FormatOptions.
 | CanSuppressTrailingZeros(ForgeTypeId) | Checks whether trailing zeros can be suppressed for a given unit.
Public method | CanUsePlusPrefix()()()() | Checks whether a plus prefix can be displayed for the display unit in this FormatOptions.
 | CanUsePlusPrefix(ForgeTypeId) | Checks whether a plus prefix can be displayed for a given unit.
Public method | Dispose | Releases all resources used by the FormatOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSymbolTypeId | Gets the identifier of the symbol indicating the unit quantifying the value.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUnitTypeId | Gets the identifier of the unit used to quantify values.
Public method | GetValidSymbols()()()() | Gets the identifiers of all valid symbols for the unit in this FormatOptions.
 | GetValidSymbols(ForgeTypeId) | Gets the identifiers of all valid symbols for a given unit.
Public method | IsValidAccuracy(Double) | Checks whether an accuracy is valid for the display unit in this FormatOptions.
 | IsValidAccuracy(ForgeTypeId, Double) | Checks whether an accuracy is valid for a given unit.
Public method | IsValidForSpec | Checks whether this FormatOptions is valid for a given spec.
Public method | IsValidSymbol(ForgeTypeId) | Checks whether a symbol is valid for the unit in this FormatOptions.
 | IsValidSymbol(ForgeTypeId, ForgeTypeId) | Checks whether a symbol is valid for a given unit.
Public method | SetSymbolTypeId | Sets the symbol that should be displayed to indicate the unit quantifying the value.
Public method | SetUnitTypeId | Sets the unit used to quantify values.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Accuracy | The accuracy to which values will be rounded.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | RoundingMethod | The method used to round values: round to nearest, round up, or round down.
Public property | SuppressLeadingZeros | Indicates if leading zeros should be suppressed in feet and fractional inches.
Public property | SuppressSpaces | Indicates if spaces around the dash should be suppressed in feet and fractional inches.
Public property | SuppressTrailingZeros | Indicates if trailing zeros after the decimal point should be suppressed.
Public property | UseDefault | Indicates whether default or custom formatting should be used.
Public property | UseDigitGrouping | Indicates if digit grouping symbols should be displayed.
Public property | UsePlusPrefix | Indicates if a plus sign prefix should be displayed for positive and zero values.

See Also

FormatOptions Class


FormatOptions Constructor

[image] [image]

Revit 2024 API
FormatOptions Constructor
FormatOptions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FormatOptions()()()() | Creates a new FormatOptions object that represents default formatting.
Public method | FormatOptions(ForgeTypeId) | Creates a new FormatOptions object that represents custom formatting.
Public method | FormatOptions(FormatOptions) | Creates a copy of a FormatOptions object.
Public method | FormatOptions(ForgeTypeId, ForgeTypeId) | Creates a new FormatOptions object that represents custom formatting.

See Also

FormatOptions Class
FormatOptions Members


FormatOptions Constructor

[image]

Revit 2024 API
FormatOptions Constructor
FormatOptions Class See Also Send Feedback
Creates a new FormatOptions object that represents default formatting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public FormatOptions()
Visual Basic
Public Sub New
Visual C++
public:
FormatOptions()

See Also

FormatOptions Class
FormatOptions Overload


FormatOptions Constructor (ForgeTypeId)

[image]

Revit 2024 API
FormatOptions Constructor (ForgeTypeId)
FormatOptions Class See Also Send Feedback
Creates a new FormatOptions object that represents custom formatting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public FormatOptions(
    ForgeTypeId unitTypeId
)
Visual Basic
Public Sub New ( _
    unitTypeId As ForgeTypeId _
)
Visual C++
public:
FormatOptions(
    ForgeTypeId^ unitTypeId
)

Parameters

unitTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
Identifier of the unit to display.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | unitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType).
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FormatOptions Class
FormatOptions Overload


FormatOptions Constructor (FormatOptions)

[image]

Revit 2024 API
FormatOptions Constructor (FormatOptions)
FormatOptions Class See Also Send Feedback
Creates a copy of a FormatOptions object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public FormatOptions(
    FormatOptions other
)
Visual Basic
Public Sub New ( _
    other As FormatOptions _
)
Visual C++
public:
FormatOptions(
    FormatOptions^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..FormatOptions

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FormatOptions Class
FormatOptions Overload


FormatOptions Constructor (ForgeTypeId, ForgeTypeId)

[image]

Revit 2024 API
FormatOptions Constructor (ForgeTypeId, ForgeTypeId)
FormatOptions Class See Also Send Feedback
Creates a new FormatOptions object that represents custom formatting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public FormatOptions(
    ForgeTypeId unitTypeId,
    ForgeTypeId symbolTypeId
)
Visual Basic
Public Sub New ( _
    unitTypeId As ForgeTypeId, _
    symbolTypeId As ForgeTypeId _
)
Visual C++
public:
FormatOptions(
    ForgeTypeId^ unitTypeId,
    ForgeTypeId^ symbolTypeId
)

Parameters

unitTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
Identifier of the unit to display.
symbolTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
Identifier of the symbol with which to render the unit.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | unitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType). -or- symbolTypeId is not a valid symbol for unitTypeId.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FormatOptions Class
FormatOptions Overload


FormatOptions Methods

[image] [image]

Revit 2024 API
FormatOptions Methods
FormatOptions Class See Also Send Feedback

The FormatOptions type exposes the following members.

Methods

 | Name | Description
Public method | CanHaveSymbol()()()() | Checks whether a symbol can be specified to display the unit in this FormatOptions.
 | CanHaveSymbol(ForgeTypeId) | Checks whether a symbol can be specified to display a given unit.
Public method | CanSuppressLeadingZeros()()()() | Checks whether leading zeros can be suppressed for the display unit in this FormatOptions.
 | CanSuppressLeadingZeros(ForgeTypeId) | Checks whether leading zeros can be suppressed for a given unit.
Public method | CanSuppressSpaces()()()() | Checks whether spaces can be suppressed for the display unit in this FormatOptions.
 | CanSuppressSpaces(ForgeTypeId) | Checks whether spaces can be suppressed for a given unit.
Public method | CanSuppressTrailingZeros()()()() | Checks whether trailing zeros can be suppressed for the display unit in this FormatOptions.
 | CanSuppressTrailingZeros(ForgeTypeId) | Checks whether trailing zeros can be suppressed for a given unit.
Public method | CanUsePlusPrefix()()()() | Checks whether a plus prefix can be displayed for the display unit in this FormatOptions.
 | CanUsePlusPrefix(ForgeTypeId) | Checks whether a plus prefix can be displayed for a given unit.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSymbolTypeId | Gets the identifier of the symbol indicating the unit quantifying the value.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUnitTypeId | Gets the identifier of the unit used to quantify values.
Public method | GetValidSymbols()()()() | Gets the identifiers of all valid symbols for the unit in this FormatOptions.
 | GetValidSymbols(ForgeTypeId) | Gets the identifiers of all valid symbols for a given unit.
Public method | IsValidAccuracy(Double) | Checks whether an accuracy is valid for the display unit in this FormatOptions.
 | IsValidAccuracy(ForgeTypeId, Double) | Checks whether an accuracy is valid for a given unit.
Public method | IsValidForSpec | Checks whether this FormatOptions is valid for a given spec.
Public method | IsValidSymbol(ForgeTypeId) | Checks whether a symbol is valid for the unit in this FormatOptions.
 | IsValidSymbol(ForgeTypeId, ForgeTypeId) | Checks whether a symbol is valid for a given unit.
Public method | SetSymbolTypeId | Sets the symbol that should be displayed to indicate the unit quantifying the value.
Public method | SetUnitTypeId | Sets the unit used to quantify values.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FormatOptions Class


CanHaveSymbol Method

[image] [image]

Revit 2024 API
FormatOptions..::..CanHaveSymbol Method
FormatOptions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CanHaveSymbol()()()() | Checks whether a symbol can be specified to display the unit in this FormatOptions.
 | CanHaveSymbol(ForgeTypeId) | Checks whether a symbol can be specified to display a given unit.

See Also

FormatOptions Class
FormatOptions Members


CanHaveSymbol Method

[image]

Revit 2024 API
FormatOptions..::..CanHaveSymbol Method
FormatOptions Class See Also Send Feedback
Checks whether a symbol can be specified to display the unit in this FormatOptions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool CanHaveSymbol()
Visual Basic
Public Function CanHaveSymbol As Boolean
Visual C++
public:
bool CanHaveSymbol()

Return Value

True if a symbol can be specified, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | UseDefault is true in this FormatOptions.

See Also

FormatOptions Class
CanHaveSymbol Overload


CanHaveSymbol Method (ForgeTypeId)

[image]

Revit 2024 API
FormatOptions..::..CanHaveSymbol Method (ForgeTypeId)
FormatOptions Class See Also Send Feedback
Checks whether a symbol can be specified to display a given unit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static bool CanHaveSymbol(
    ForgeTypeId unitTypeId
)
Visual Basic
Public Shared Function CanHaveSymbol ( _
    unitTypeId As ForgeTypeId _
) As Boolean
Visual C++
public:
static bool CanHaveSymbol(
    ForgeTypeId^ unitTypeId
)

Parameters

unitTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
Identifier of the unit.

Return Value

True if a symbol can be specified, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | unitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType).
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FormatOptions Class
CanHaveSymbol Overload


CanSuppressLeadingZeros Method

[image] [image]

Revit 2024 API
FormatOptions..::..CanSuppressLeadingZeros Method
FormatOptions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CanSuppressLeadingZeros()()()() | Checks whether leading zeros can be suppressed for the display unit in this FormatOptions.
 | CanSuppressLeadingZeros(ForgeTypeId) | Checks whether leading zeros can be suppressed for a given unit.

See Also

FormatOptions Class
FormatOptions Members


CanSuppressLeadingZeros Method

[image]

Revit 2024 API
FormatOptions..::..CanSuppressLeadingZeros Method
FormatOptions Class See Also Send Feedback
Checks whether leading zeros can be suppressed for the display unit in this FormatOptions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool CanSuppressLeadingZeros()
Visual Basic
Public Function CanSuppressLeadingZeros As Boolean
Visual C++
public:
bool CanSuppressLeadingZeros()

Return Value

True if leading zeros can be suppressed, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | UseDefault is true in this FormatOptions.

See Also

FormatOptions Class
CanSuppressLeadingZeros Overload


CanSuppressSpaces Method

[image] [image]

Revit 2024 API
FormatOptions..::..CanSuppressSpaces Method
FormatOptions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CanSuppressSpaces()()()() | Checks whether spaces can be suppressed for the display unit in this FormatOptions.
 | CanSuppressSpaces(ForgeTypeId) | Checks whether spaces can be suppressed for a given unit.

See Also

FormatOptions Class
FormatOptions Members


CanSuppressSpaces Method

[image]

Revit 2024 API
FormatOptions..::..CanSuppressSpaces Method
FormatOptions Class See Also Send Feedback
Checks whether spaces can be suppressed for the display unit in this FormatOptions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool CanSuppressSpaces()
Visual Basic
Public Function CanSuppressSpaces As Boolean
Visual C++
public:
bool CanSuppressSpaces()

Return Value

True if spaces can be suppressed, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | UseDefault is true in this FormatOptions.

See Also

FormatOptions Class
CanSuppressSpaces Overload


CanSuppressSpaces Method (ForgeTypeId)

[image]

Revit 2024 API
FormatOptions..::..CanSuppressSpaces Method (ForgeTypeId)
FormatOptions Class See Also Send Feedback
Checks whether spaces can be suppressed for a given unit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static bool CanSuppressSpaces(
    ForgeTypeId unitTypeId
)
Visual Basic
Public Shared Function CanSuppressSpaces ( _
    unitTypeId As ForgeTypeId _
) As Boolean
Visual C++
public:
static bool CanSuppressSpaces(
    ForgeTypeId^ unitTypeId
)

Parameters

unitTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
Identifier of the unit.

Return Value

True if spaces can be suppressed, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | unitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType).
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FormatOptions Class
CanSuppressSpaces Overload


CanSuppressTrailingZeros Method

[image] [image]

Revit 2024 API
FormatOptions..::..CanSuppressTrailingZeros Method
FormatOptions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CanSuppressTrailingZeros()()()() | Checks whether trailing zeros can be suppressed for the display unit in this FormatOptions.
 | CanSuppressTrailingZeros(ForgeTypeId) | Checks whether trailing zeros can be suppressed for a given unit.

See Also

FormatOptions Class
FormatOptions Members


CanSuppressTrailingZeros Method (ForgeTypeId)

[image]

Revit 2024 API
FormatOptions..::..CanSuppressTrailingZeros Method (ForgeTypeId)
FormatOptions Class See Also Send Feedback
Checks whether trailing zeros can be suppressed for a given unit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static bool CanSuppressTrailingZeros(
    ForgeTypeId unitTypeId
)
Visual Basic
Public Shared Function CanSuppressTrailingZeros ( _
    unitTypeId As ForgeTypeId _
) As Boolean
Visual C++
public:
static bool CanSuppressTrailingZeros(
    ForgeTypeId^ unitTypeId
)

Parameters

unitTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
Identifier of the unit.

Return Value

True if trailing zeros can be suppressed, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | unitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType).
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FormatOptions Class
CanSuppressTrailingZeros Overload


CanUsePlusPrefix Method

[image] [image]

Revit 2024 API
FormatOptions..::..CanUsePlusPrefix Method
FormatOptions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CanUsePlusPrefix()()()() | Checks whether a plus prefix can be displayed for the display unit in this FormatOptions.
 | CanUsePlusPrefix(ForgeTypeId) | Checks whether a plus prefix can be displayed for a given unit.

See Also

FormatOptions Class
FormatOptions Members


CanUsePlusPrefix Method

[image]

Revit 2024 API
FormatOptions..::..CanUsePlusPrefix Method
FormatOptions Class See Also Send Feedback
Checks whether a plus prefix can be displayed for the display unit in this FormatOptions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool CanUsePlusPrefix()
Visual Basic
Public Function CanUsePlusPrefix As Boolean
Visual C++
public:
bool CanUsePlusPrefix()

Return Value

True if a plus prefix can be displayed, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | UseDefault is true in this FormatOptions.

See Also

FormatOptions Class
CanUsePlusPrefix Overload


CanUsePlusPrefix Method (ForgeTypeId)

[image]

Revit 2024 API
FormatOptions..::..CanUsePlusPrefix Method (ForgeTypeId)
FormatOptions Class See Also Send Feedback
Checks whether a plus prefix can be displayed for a given unit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static bool CanUsePlusPrefix(
    ForgeTypeId unitTypeId
)
Visual Basic
Public Shared Function CanUsePlusPrefix ( _
    unitTypeId As ForgeTypeId _
) As Boolean
Visual C++
public:
static bool CanUsePlusPrefix(
    ForgeTypeId^ unitTypeId
)

Parameters

unitTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
Identifier of the unit.

Return Value

True if a plus prefix can be displayed, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | unitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType).
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FormatOptions Class
CanUsePlusPrefix Overload


Dispose Method

[image]

Revit 2024 API
FormatOptions..::..Dispose Method
FormatOptions Class See Also Send Feedback
Releases all resources used by the FormatOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FormatOptions Class


GetUnitTypeId Method

[image]

Revit 2024 API
FormatOptions..::..GetUnitTypeId Method
FormatOptions Class See Also Send Feedback
Gets the identifier of the unit used to quantify values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ForgeTypeId GetUnitTypeId()
Visual Basic
Public Function GetUnitTypeId As ForgeTypeId
Visual C++
public:
ForgeTypeId^ GetUnitTypeId()

Remarks

Most units, such as square feet or degrees, are formatted as decimal decimal numbers. Other units may be displayed with specialized formatting methods like "feet and fractional inches" or "degrees, minutes and seconds".

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | UseDefault is true in this FormatOptions.

See Also

FormatOptions Class


GetValidSymbols Method

[image] [image]

Revit 2024 API
FormatOptions..::..GetValidSymbols Method
FormatOptions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValidSymbols()()()() | Gets the identifiers of all valid symbols for the unit in this FormatOptions.
 | GetValidSymbols(ForgeTypeId) | Gets the identifiers of all valid symbols for a given unit.

See Also

FormatOptions Class
FormatOptions Members


GetValidSymbols Method

[image]

Revit 2024 API
FormatOptions..::..GetValidSymbols Method
FormatOptions Class See Also Send Feedback
Gets the identifiers of all valid symbols for the unit in this FormatOptions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public IList<ForgeTypeId> GetValidSymbols()
Visual Basic
Public Function GetValidSymbols As IList(Of ForgeTypeId)
Visual C++
public:
IList<ForgeTypeId^>^ GetValidSymbols()

Return Value

Identifiers of the valid symbols.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | UseDefault is true in this FormatOptions.

See Also

FormatOptions Class
GetValidSymbols Overload


IsValidAccuracy Method

[image] [image]

Revit 2024 API
FormatOptions..::..IsValidAccuracy Method
FormatOptions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsValidAccuracy(Double) | Checks whether an accuracy is valid for the display unit in this FormatOptions.
 | IsValidAccuracy(ForgeTypeId, Double) | Checks whether an accuracy is valid for a given unit.

See Also

FormatOptions Class
FormatOptions Members


IsValidAccuracy Method (Double)

[image]

Revit 2024 API
FormatOptions..::..IsValidAccuracy Method (Double)
FormatOptions Class See Also Send Feedback
Checks whether an accuracy is valid for the display unit in this FormatOptions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidAccuracy(
    double accuracy
)
Visual Basic
Public Function IsValidAccuracy ( _
    accuracy As Double _
) As Boolean
Visual C++
public:
bool IsValidAccuracy(
    double accuracy
)

Parameters

accuracy
Type: System..::..Double
The accuracy to check.

Return Value

True if the accuracy is valid, false otherwise.

Remarks

See the Accuracy property for details on valid accuracy values.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | UseDefault is true in this FormatOptions.

See Also

FormatOptions Class
IsValidAccuracy Overload


IsValidAccuracy Method (ForgeTypeId, Double)

[image]

Revit 2024 API
FormatOptions..::..IsValidAccuracy Method (ForgeTypeId, Double)
FormatOptions Class See Also Send Feedback
Checks whether an accuracy is valid for a given unit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static bool IsValidAccuracy(
    ForgeTypeId unitTypeId,
    double accuracy
)
Visual Basic
Public Shared Function IsValidAccuracy ( _
    unitTypeId As ForgeTypeId, _
    accuracy As Double _
) As Boolean
Visual C++
public:
static bool IsValidAccuracy(
    ForgeTypeId^ unitTypeId,
    double accuracy
)

Parameters

unitTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
Identifier of the unit.
accuracy
Type: System..::..Double
The accuracy to check.

Return Value

True if the accuracy is valid, false otherwise.

Remarks

See the Accuracy property for details on valid accuracy values.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | unitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType).
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FormatOptions Class
IsValidAccuracy Overload


IsValidForSpec Method

[image]

Revit 2024 API
FormatOptions..::..IsValidForSpec Method
FormatOptions Class See Also Send Feedback
Checks whether this FormatOptions is valid for a given spec.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidForSpec(
    ForgeTypeId specTypeId
)
Visual Basic
Public Function IsValidForSpec ( _
    specTypeId As ForgeTypeId _
) As Boolean
Visual C++
public:
bool IsValidForSpec(
    ForgeTypeId^ specTypeId
)

Parameters

specTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
Identifier of the spec.

Return Value

True if the FormatOptions is valid, false otherwise.

Remarks

The FormatOptions is valid if UseDefault is true or if the unit in the FormatOptions is valid for the spec. See UnitUtils.IsValidUnit(ForgeTypeId, ForgeTypeId) and UnitUtils.GetValidUnits(ForgeTypeId).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | specTypeId is not a measurable spec identifier. See UnitUtils.IsMeasurableSpec(ForgeTypeId).
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FormatOptions Class


IsValidSymbol Method

[image] [image]

Revit 2024 API
FormatOptions..::..IsValidSymbol Method
FormatOptions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsValidSymbol(ForgeTypeId) | Checks whether a symbol is valid for the unit in this FormatOptions.
 | IsValidSymbol(ForgeTypeId, ForgeTypeId) | Checks whether a symbol is valid for a given unit.

See Also

FormatOptions Class
FormatOptions Members


IsValidSymbol Method (ForgeTypeId)

[image]

Revit 2024 API
FormatOptions..::..IsValidSymbol Method (ForgeTypeId)
FormatOptions Class See Also Send Feedback
Checks whether a symbol is valid for the unit in this FormatOptions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidSymbol(
    ForgeTypeId symbolTypeId
)
Visual Basic
Public Function IsValidSymbol ( _
    symbolTypeId As ForgeTypeId _
) As Boolean
Visual C++
public:
bool IsValidSymbol(
    ForgeTypeId^ symbolTypeId
)

Parameters

symbolTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
Identifier of the symbol to check.

Return Value

True if the symbol is valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | UseDefault is true in this FormatOptions.

See Also

FormatOptions Class
IsValidSymbol Overload


IsValidSymbol Method (ForgeTypeId, ForgeTypeId)

[image]

Revit 2024 API
FormatOptions..::..IsValidSymbol Method (ForgeTypeId, ForgeTypeId)
FormatOptions Class See Also Send Feedback
Checks whether a symbol is valid for a given unit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static bool IsValidSymbol(
    ForgeTypeId unitTypeId,
    ForgeTypeId symbolTypeId
)
Visual Basic
Public Shared Function IsValidSymbol ( _
    unitTypeId As ForgeTypeId, _
    symbolTypeId As ForgeTypeId _
) As Boolean
Visual C++
public:
static bool IsValidSymbol(
    ForgeTypeId^ unitTypeId,
    ForgeTypeId^ symbolTypeId
)

Parameters

unitTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
Identifier of the unit.
symbolTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
Identifier of the symbol to check.

Return Value

True if the symbol is valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | unitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType).
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FormatOptions Class
IsValidSymbol Overload


SetUnitTypeId Method

[image]

Revit 2024 API
FormatOptions..::..SetUnitTypeId Method
FormatOptions Class See Also Send Feedback
Sets the unit used to quantify values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public FormatOptions SetUnitTypeId(
    ForgeTypeId unitTypeId
)
Visual Basic
Public Function SetUnitTypeId ( _
    unitTypeId As ForgeTypeId _
) As FormatOptions
Visual C++
public:
FormatOptions^ SetUnitTypeId(
    ForgeTypeId^ unitTypeId
)

Parameters

unitTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
The unit identifier.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | unitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType).
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | UseDefault is true in this FormatOptions.

See Also

FormatOptions Class


FormatOptions Properties

[image] [image]

Revit 2024 API
FormatOptions Properties
FormatOptions Class See Also Send Feedback

The FormatOptions type exposes the following members.

Properties

 | Name | Description
Public property | Accuracy | The accuracy to which values will be rounded.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | RoundingMethod | The method used to round values: round to nearest, round up, or round down.
Public property | SuppressLeadingZeros | Indicates if leading zeros should be suppressed in feet and fractional inches.
Public property | SuppressSpaces | Indicates if spaces around the dash should be suppressed in feet and fractional inches.
Public property | SuppressTrailingZeros | Indicates if trailing zeros after the decimal point should be suppressed.
Public property | UseDefault | Indicates whether default or custom formatting should be used.
Public property | UseDigitGrouping | Indicates if digit grouping symbols should be displayed.
Public property | UsePlusPrefix | Indicates if a plus sign prefix should be displayed for positive and zero values.

See Also

FormatOptions Class


Accuracy Property

[image]

Revit 2024 API
FormatOptions..::..Accuracy Property
FormatOptions Class See Also Send Feedback
The accuracy to which values will be rounded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public double Accuracy { get; set; }
Visual Basic
Public Property Accuracy As Double
    Get
    Set
Visual C++
public:
property double Accuracy {
    double get ();
    void set (double value);
}

Field Value

The accuracy. The default depends on the display unit.

Remarks

Formatted values will be rounded to the nearest multiple of the accuracy value.

Accuracy is specified in display units, not in Revit's internal units.

For DUT_GENERAL, the accuracy value is always 0.000001 and cannot be set to another value. DUT_GENERAL is a special display unit that always rounds to six decimal places and suppresses trailing zeros, roughly equivalent to DUT_FIXED with the accuracy set to 0.000001 and SuppressTrailingZeros set to true.

For other display units, a wide range of accuracy values may be specified. All values from 1.0e-12 to 1.0e12 will be accepted, but the specified value will be automatically adjusted to the nearest supported value if necessary. For best results, the accuracy value should be chosen to be compatible with the display unit:

  • For most display units, the value is displayed as a decimal number, and the accuracy should typically be a power of 10, for example 1.0 to round to 0 decimal places or 0.001 to round to 3 decimal places. Other values can be used, for example 0.25 to round to the nearest 0.25 (displayed with 2 decimal places) or 2.0 to round to the nearest even integer (displayed with 0 decimal places). The specified accuracy will automatically be rounded to the nearest positive multiple of 1.0e-12.
  • For DUT_FRACTIONAL_INCHES, DUT_RISE_OVER_INCHES, and DUT_RISE_OVER_120_INCHES, the accuracy should typically be a power of 2, for example 0.25 to round to the nearest 1/4". Other values can be used, for example 6.0 to round to the nearest 6" or 1.5 to round to the nearest 1 1/2". For DUT_FEET_FRACTIONAL_INCHES, DUT_RISE_OVER_FOOT, and DUT_RISE_OVER_10_FEET, similar accuracy values can be used but they must be divided by 12 because the accuracy is specified in feet. The specified accuracy will automatically be rounded to the nearest positive multiple of 1/2^20 inches.
  • For DUT_DEGREES_AND_MINUTES, the accuracy should typically be a power of 10 divided by 3600 to round seconds to a specific number of decimal places, for example 1.0 / 3600.0 to round seconds to 0 decimal places or 0.01 / 3600.0 to round seconds to 2 decimal places. The specified accuracy will automatically be rounded to the nearest positive multiple of 1.0e-8 seconds.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: accuracy is not a valid accuracy for the display unit in this FormatOptions.
Autodesk.Revit.Exceptions..::..InvalidOperationException | UseDefault is true in this FormatOptions.

See Also

FormatOptions Class


IsValidObject Property

[image]

Revit 2024 API
FormatOptions..::..IsValidObject Property
FormatOptions Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

FormatOptions Class


RoundingMethod Property

[image]

Revit 2024 API
FormatOptions..::..RoundingMethod Property
FormatOptions Class See Also Send Feedback
The method used to round values: round to nearest, round up, or round down.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public RoundingMethod RoundingMethod { get; set; }
Visual Basic
Public Property RoundingMethod As RoundingMethod
    Get
    Set
Visual C++
public:
property RoundingMethod RoundingMethod {
    RoundingMethod get ();
    void set (RoundingMethod value);
}

Field Value

The rounding method. The default is Nearest.

Remarks

The RoundingMethod property is currently only supported for rebar parameters. A FormatOptions object containing any rounding method may be returned by Element.GetParameterFormatOptions() and may be passed to the formatting and parsing utilities in the UnitFormatUtils class. FormatOptions objects used in other contexts must contain the default rounding method (Nearest).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | UseDefault is true in this FormatOptions.

See Also

FormatOptions Class


SuppressLeadingZeros Property

[image]

Revit 2024 API
FormatOptions..::..SuppressLeadingZeros Property
FormatOptions Class See Also Send Feedback
Indicates if leading zeros should be suppressed in feet and fractional inches.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool SuppressLeadingZeros { get; set; }
Visual Basic
Public Property SuppressLeadingZeros As Boolean
    Get
    Set
Visual C++
public:
property bool SuppressLeadingZeros {
    bool get ();
    void set (bool value);
}

Field Value

True if leading zeros should be suppressed, false otherwise. The default is false.

Remarks

This property is applicable to display units related to feet and fractional inches:

  • DUT_FEET_FRACTIONAL_INCHES
  • DUT_RISE_OVER_FOOT
  • DUT_RISE_OVER_10_FEET

When SuppressLeadingZeros is true:

  • If the foot component of the value is zero (the value is less than one foot), it will not be displayed. For example, 0' - 2 3/4" will be displayed as 2 3/4".
  • If both the foot and integer inch components of the value are zero (the value is less than one inch), neither will be displayed. For example, 0' - 0 3/4" will be displayed as 3/4".
  • However, an integer inch component of zero will be displayed if the foot component is non-zero. For example 1' - 0 3/4" will be displayed as 1' - 0 3/4".

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | UseDefault is true in this FormatOptions. -or- When setting this property: SuppressLeadingZeros was set to true but leading zeros cannot be suppressed for the display unit in this FormatOptions.

See Also

FormatOptions Class


SuppressSpaces Property

[image]

Revit 2024 API
FormatOptions..::..SuppressSpaces Property
FormatOptions Class See Also Send Feedback
Indicates if spaces around the dash should be suppressed in feet and fractional inches.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool SuppressSpaces { get; set; }
Visual Basic
Public Property SuppressSpaces As Boolean
    Get
    Set
Visual C++
public:
property bool SuppressSpaces {
    bool get ();
    void set (bool value);
}

Field Value

True if spaces should be suppressed, false otherwise. The default is false.

Remarks

This property is applicable to display units related to feet and fractional inches:

  • DUT_FEET_FRACTIONAL_INCHES
  • DUT_RISE_OVER_FOOT
  • DUT_RISE_OVER_10_FEET

When SuppressLeadingZeros is true, spaces will not be inserted before and after the dash separating feet from inches. For example, 1' - 2 3/4" will be displayed as 1'-2 3/4".

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | UseDefault is true in this FormatOptions. -or- When setting this property: SuppressSpaces was set to true but spaces cannot be suppressed for the display unit in this FormatOptions.

See Also

FormatOptions Class


UseDigitGrouping Property

[image]

Revit 2024 API
FormatOptions..::..UseDigitGrouping Property
FormatOptions Class See Also Send Feedback
Indicates if digit grouping symbols should be displayed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool UseDigitGrouping { get; set; }
Visual Basic
Public Property UseDigitGrouping As Boolean
    Get
    Set
Visual C++
public:
property bool UseDigitGrouping {
    bool get ();
    void set (bool value);
}

Field Value

True if digit grouping symbols should be displayed, false otherwise. The default is false.

Remarks

When UseDigitGrouping is true, digit grouping symbols (i.e. thousands separators) will be displayed when needed. For example, 123456789.00 may be displayed as 123,456,789.00. The precise display is determined by the DigitGroupingSymbol and DigitGroupingAmount properties of the Units class.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | UseDefault is true in this FormatOptions.

See Also

FormatOptions Class


FormatStatus Enumeration

[image]

Revit 2024 API
FormatStatus Enumeration
See Also Send Feedback
An enumerated type indicating the formatting status of a range of characters in FormattedText

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017
Since: 2017

Syntax

C#
public enum FormatStatus
Visual Basic
Public Enumeration FormatStatus
Visual C++
public enum class FormatStatus

Members

Member name | Description
None | None of the characters in the range has the specified format.
All | All of the characters in the range have the specified format.
Mixed | The characters in the format have mixed formatting.

Remarks

The character formatting includes
  • Bold
  • Italic
  • Underline
  • SuperScript
  • Subscript
  • All Caps

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


FormattedText Class

[image]

Revit 2024 API
FormattedText Class
Members Example See Also Send Feedback
FormattedText is used to create, edit and format text in a TextNote or to query the text and format properties of a TextNode

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public class FormattedText : IDisposable
Visual Basic
Public Class FormattedText _
    Implements IDisposable
Visual C++
public ref class FormattedText : IDisposable

Remarks

An instance of FormattedText can be obtained from a TextNote (See TextNote.GetFormattedText()) or from a TextNode (See TextNode.GetFormattedText())

It is also possible to create a new instance of FormattedText and assign it to a TextNote (See TextNote.SetFormattedText()) This will result in a TextNote with text with the specified formatting applied

Formatted text can be used to:

  • Create formatted text for a new TextNote
  • Edit, Find and Replace text in an existing TextNote
  • Modify formatting of text in an existing TextNote
  • Or query the text and formatting a TextNote or a TextNode

Formatted text can be populated with plain text by using its constructor FormattedText(String) that takes a string, or by using the SetPlainText(String) method.

In addition, selected ranges of text can be added, removed, or replaced with the SetPlainText(TextRange, String) method by specifying a TextRange.

Use the Find(String, Int32, Boolean, Boolean) method to find the location of existing text.

Formatted text can have up to 30,000 characters. All characters, except the linefeed character ('\n'), are allowed. This means that you should not use the 'Environment.NewLine' property, since that includes a linefeed character. Use the carriage return character ('\r') to terminate a paragraph. And use a vertical tab character ('\v') to create a new line without terminating the paragraph.

Formatted text allows for individual characters to be formatted. The following formatting can be applied.

  • Bold
  • Italic
  • Underline
  • Superscript/Subscript
  • All Caps
Use SetBoldStatus(TextRange, Boolean)) , SetItalicStatus(TextRange, Boolean)) , SetUnderlineStatus(TextRange, Boolean)) , SetSuperscriptStatus(TextRange, Boolean)) , SetSubscriptStatus(TextRange, Boolean)) , or SetAllCapsStatus(TextRange, Boolean)) to set the character formatting on a range of text.

Use GetBoldStatus(TextRange)) , GetItalicStatus(TextRange)) , GetUnderlineStatus(TextRange)) , GetSuperscriptStatus(TextRange)) , GetSubscriptStatus(TextRange)) , or GetAllCapsStatus(TextRange)) to get the character formatting of a range of text.

Text can be broken up in paragraphs. Paragraphs are terminated by a carriage return character ('\r').

Each paragraph can be indented several levels deep. For each additional level the indentation increments by one tab size. The total indentation is the product of a tab size and the indent level. Use SetIndentLevel(TextRange, Int32) to set the level of indenting up to a maximum indent level that can be obtained from GetMaximumIndentLevel()()()() Use GetIndentLevel(TextRange) to find the indent level of a given range of text.

Note that the tab size is determined by the object that will contain the FormattedText.

In the case of a TextNote the tab size is a property of the TextNoteType returned from TextNote.TextNoteType. The tab size can be found by calling the Parameter[([( Guid])]) with TEXT_TAB_SIZE on the TextNoteType obtained from the TextNote

In the case of a TextNode the tab size can be obtained from its TabSize property

Formatted text can also be used to create numbered or bulleted paragraphs with the SetListType(TextRange, ListType) method.

The following ListType options are available:

  • Bullet
  • ArabicNumbers
  • LowerCaseLetters
  • UpperCaseLetters
Paragraphs with a ListType other than None are considered to be 'list' paragraphs. Consecutive list paragraphs with the same indentation level are treated as part of the same list. A list ends when a list paragraph is followed by
  • a paragraph that has None
  • or a list paragraph that has a lower indentation level, i.e. is indented less. (See GetIndentLevel(TextRange))
Note that a list will continue uninterrupted after list paragraphs that have higher indentation level. These paragraphs form a 'sub-list' of the list they interrupt. Sub-lists can have their own sub-sub-lists. The nesting level is only limited by the maximum indent level. Using SetIndentLevel(TextRange, Int32) it is therefore possible to create multi-level lists.

FormattedText will keep lists consistent. That means that list paragraphs will automatically get sequential numbers or letters. It also means that if the list type of one of the paragraphs in a list is changed then that change is propagated to all the paragraphs in that list. Note that this will not affect the list type of any nested sub-lists.

Use a vertical tab character ('\v') to insert a line without a bullet or number. Since this does not end the paragraph this will allow the list to continue to the next paragraph.

Examples

CopyC#
public void FormatText(TextNote textNote)
{
    // TextNote created with "New sample text"
    FormattedText formatText = textNote.GetFormattedText();

    // italicize "New"
    TextRange range = new TextRange(0, 3);
    formatText.SetItalicStatus(range, true);

    // make "sample" bold
    range = formatText.Find("sample", 0, false, true);
    if (range.Length > 0)
        formatText.SetBoldStatus(range, true);

    // make "text" underlined
    range = formatText.Find("text", 0, false, true);
    if (range.Length > 0)
        formatText.SetUnderlineStatus(range, true);

    // make all text uppercase
    formatText.SetAllCapsStatus(true);

    textNote.SetFormattedText(formatText);
}
CopyVB.NET
Public Sub FormatText(textNote As TextNote)
    ' TextNote created with "New sample text"
    Dim formatText__1 As FormattedText = textNote.GetFormattedText()

    ' italicize "New"
    Dim range As New TextRange(0, 3)
    formatText__1.SetItalicStatus(range, True)

    ' make "sample" bold
    range = formatText__1.Find("sample", 0, False, True)
    If range.Length > 0 Then
        formatText__1.SetBoldStatus(range, True)
    End If

    ' make "text" underlined
    range = formatText__1.Find("text", 0, False, True)
    If range.Length > 0 Then
        formatText__1.SetUnderlineStatus(range, True)
    End If

    ' make all text uppercase
    formatText__1.SetAllCapsStatus(True)

    textNote.SetFormattedText(formatText__1)
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FormattedText

See Also

FormattedText Members


FormattedText Constructor

[image] [image]

Revit 2024 API
FormattedText Constructor
FormattedText Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FormattedText()()()() | Creates a new default FormattedText object, which contains only a carriage return character and has no formatting.
Public method | FormattedText(String) | Creates a new FormattedText object with unformatted text.

See Also

FormattedText Class
FormattedText Members


FormattedText Constructor

[image]

Revit 2024 API
FormattedText Constructor
FormattedText Class See Also Send Feedback
Creates a new default FormattedText object, which contains only a carriage return character and has no formatting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public FormattedText()
Visual Basic
Public Sub New
Visual C++
public:
FormattedText()

See Also

FormattedText Class
FormattedText Overload


FormattedText Constructor (String)

[image]

Revit 2024 API
FormattedText Constructor (String)
FormattedText Class Example See Also Send Feedback
Creates a new FormattedText object with unformatted text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public FormattedText(
    string plainText
)
Visual Basic
Public Sub New ( _
    plainText As String _
)
Visual C++
public:
FormattedText(
    String^ plainText
)

Parameters

plainText
Type: System..::..String
The text in a plain text form.

Remarks

The given text should have no more than 30,000 characters. Line feed characters ('/n') are not allowed. An empty string is allowed.

Examples

CopyC#
public void ReformatText(TextNote textNote, string textToChange)
{
    String plainText = textNote.Text;
    FormattedText formattedText = new FormattedText(plainText);

    TextRange foundRange = formattedText.Find(textToChange, 0, false, true);
    while (foundRange.Length > 0)
    {
        formattedText.SetBoldStatus(foundRange, true);
        foundRange = formattedText.Find(textToChange, foundRange.End, false, true);
    }

    textNote.SetFormattedText(formattedText);
}
CopyVB.NET
Public Sub ReformatText(textNote As TextNote, textToChange As String)
    Dim plainText As [String] = textNote.Text
    Dim formattedText As New FormattedText(plainText)

    Dim foundRange As TextRange = formattedText.Find(textToChange, 0, False, True)
    While foundRange.Length > 0
        formattedText.SetBoldStatus(foundRange, True)
        foundRange = formattedText.Find(textToChange, foundRange.[End], False, True)
    End While

    textNote.SetFormattedText(formattedText)
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | plainText (excluding a carriage return character ('\r') at the end) has more than 30,000 characters. -or- plainText contains invalid characters such as a newline character.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FormattedText Class
FormattedText Overload


FormattedText Methods

[image] [image]

Revit 2024 API
FormattedText Methods
FormattedText Class See Also Send Feedback

The FormattedText type exposes the following members.

Methods

 | Name | Description
Public method | AsTextRange | Returns a TextRange object that represents the entire text.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Find | Returns a text range identifying the first occurrence of the given string within the text, starting from a given index.
Public method | GetAllCapsStatus()()()() | Returns whether All, None or a Mixed of characters in the entire text are in all caps.
Public method | GetAllCapsStatus(TextRange) | Returns whether All, None or a Mixed set of characters in a given text range are in all caps.
Public method | GetBoldStatus()()()() | Returns whether All, None or a Mixed of characters in the entire text are bold.
Public method | GetBoldStatus(TextRange) | Returns whether All, None or a Mixed set of characters in a given text range are bold.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIndentLevel | Returns the indent level of the paragraphs in the text range.
Public method | GetItalicStatus()()()() | Returns whether All, None or a Mixed of characters in the entire text are italic.
Public method | GetItalicStatus(TextRange) | Returns whether All, None or a Mixed set of characters in a given text range are italic.
Public method | GetListStartNumber | Returns the list start number of the paragraphs in a given text range.
Public method | GetListType | Returns the ListType of a paragraph.
Public method | GetMaximumIndentLevel | Returns the maximum allowed indent level
Public method | GetMaximumListStartNumber | Returns the maximum allowed list start number.
Public method | GetMinimumListStartNumber | Returns the minumum allowed list start number.
Public method | GetPlainText()()()() | Returns the entire text in a plain text form.
Public method | GetPlainText(TextRange) | Returns a substring of the text in a plain text form. The start and end of the substring is identified by a given TextRange.
Public method | GetSubscriptStatus()()()() | Returns whether All, None or a Mixed of characters in the entire text are subscripted.
Public method | GetSubscriptStatus(TextRange) | Returns whether All, None or a Mixed set of characters in a given text range are subscripted.
Public method | GetSuperscriptStatus()()()() | Returns whether All, None or a Mixed of characters in the entire text are superscripted.
Public method | GetSuperscriptStatus(TextRange) | Returns whether All, None or a Mixed set of characters in a given text range are superscripted.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUnderlineStatus()()()() | Returns whether All, None or a Mixed of characters in the entire text are underlined.
Public method | GetUnderlineStatus(TextRange) | Returns whether All, None or a Mixed set of characters in a given text range are underlined.
Public method | SetAllCapsStatus(Boolean) | Sets the characters in the entire text to be in all caps or not.
Public method | SetAllCapsStatus(TextRange, Boolean) | Sets the characters in a given text range to be in all caps or not.
Public method | SetBoldStatus(Boolean) | Sets the characters in the entire text to be bold or not bold.
Public method | SetBoldStatus(TextRange, Boolean) | Sets the characters in a given text range to be bold or not bold.
Public method | SetIndentLevel | Sets the number of tab stops that the paragraph should be indented.
Public method | SetItalicStatus(Boolean) | Sets the characters in the entire text to be italic or not italic.
Public method | SetItalicStatus(TextRange, Boolean) | Sets the characters in a given text range to be italic or not italic.
Public method | SetListStartNumber | Sets the list start number on the paragraphs in a given text range.
Public method | SetListType | Sets the ListType of a paragraph.
Public method | SetPlainText(String) | Sets the entire text with the given text in a plain text form.
Public method | SetPlainText(TextRange, String) | Sets the text with the given text in a plain text form in a range.
Public method | SetSubscriptStatus(Boolean) | Sets the characters in the entire text to be subscript or not subscript.
Public method | SetSubscriptStatus(TextRange, Boolean) | Sets the characters in a given text range to be subscript or not subscript.
Public method | SetSuperscriptStatus(Boolean) | Sets the characters in the entire text to be superscript or not superscript.
Public method | SetSuperscriptStatus(TextRange, Boolean) | Sets the characters in a given text range to be superscript or not superscript.
Public method | SetUnderlineStatus(Boolean) | Sets the characters in the entire text to be underlined or not underlined.
Public method | SetUnderlineStatus(TextRange, Boolean) | Sets the characters in a given text range to be underlined or not underlined.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FormattedText Class


AsTextRange Method

[image]

Revit 2024 API
FormattedText..::..AsTextRange Method
FormattedText Class Example See Also Send Feedback
Returns a TextRange object that represents the entire text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public TextRange AsTextRange()
Visual Basic
Public Function AsTextRange As TextRange
Visual C++
public:
TextRange^ AsTextRange()

Return Value

The TextRange object that represents the entire text.

Remarks

This range includes a carriage return character ('\r') that is always present. As a result the range can never be an empty range.

Examples

CopyC#
public void AppendText(TextNote textNote)
{
    FormattedText formatText = textNote.GetFormattedText();

    TextRange range = formatText.AsTextRange();

    range.Start = range.End - 1;
    // set Length to 0 to insert
    range.Length = 0;
    string someNewText = "\rThis is a new paragraph\vThis is a new line without a paragraph break\r";
    formatText.SetPlainText(range, someNewText);

    // get range for entire text
    range = formatText.AsTextRange();
    range.Start = range.End - 1;
    range.Length = 0;
    string someListText = "\rBulleted List item 1\rItem 2\vSecond line for Item 2\rThird bullet point";
    formatText.SetPlainText(range, someListText);
    range.Start++;
    range.Length = someListText.Length;
    formatText.SetListType(range, ListType.Bullet);

    if (formatText.GetAllCapsStatus(range) != FormatStatus.None)
    {
        formatText.SetAllCapsStatus(range, false);
    }

    textNote.SetFormattedText(formatText);
}
CopyVB.NET
Public Sub AppendText(textNote As TextNote)
    Dim formatText As FormattedText = textNote.GetFormattedText()

    Dim range As TextRange = formatText.AsTextRange()

    range.Start = range.[End] - 1
    ' set Length to 0 to insert
    range.Length = 0
    Dim someNewText As String = vbCr & "This is a new paragraph" & vbVerticalTab & "This is a new line without a paragraph break" & vbCr
    formatText.SetPlainText(range, someNewText)

    ' get range for entire text
    range = formatText.AsTextRange()
    range.Start = range.[End] - 1
    range.Length = 0
    Dim someListText As String = vbCr & "Bulleted List item 1" & vbCr & "Item 2" & vbVerticalTab & "Second line for Item 2" & vbCr & "Third bullet point"
    formatText.SetPlainText(range, someListText)
    range.Start += 1
    range.Length = someListText.Length
    formatText.SetListType(range, ListType.Bullet)

    If formatText.GetAllCapsStatus(range) <> FormatStatus.None Then
        formatText.SetAllCapsStatus(range, False)
    End If

    textNote.SetFormattedText(formatText)
End Sub

See Also

FormattedText Class


Dispose Method

[image]

Revit 2024 API
FormattedText..::..Dispose Method
FormattedText Class See Also Send Feedback
Releases all resources used by the FormattedText

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FormattedText Class


Find Method

[image]

Revit 2024 API
FormattedText..::..Find Method
FormattedText Class Example See Also Send Feedback
Returns a text range identifying the first occurrence of the given string within the text, starting from a given index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public TextRange Find(
    string searchString,
    int startIndex,
    bool matchCase,
    bool matchWholeWord
)
Visual Basic
Public Function Find ( _
    searchString As String, _
    startIndex As Integer, _
    matchCase As Boolean, _
    matchWholeWord As Boolean _
) As TextRange
Visual C++
public:
TextRange^ Find(
    String^ searchString,
    int startIndex,
    bool matchCase,
    bool matchWholeWord
)

Parameters

searchString
Type: System..::..String
The text to search for.
startIndex
Type: System..::..Int32
The start index to search within the text.
matchCase
Type: System..::..Boolean
True if the case must match when searching the formatted text, false to search in a case-insensitive manner.
matchWholeWord
Type: System..::..Boolean
True if the match must be a whole word when searching the formatted text, false otherwise.

Return Value

The text range identified.

Remarks

Returns an empty text range:
  • if the given string cannot be found in the text.
  • if the given start index is beyond the length of the entire text.
The search can be case-sensitive or case-insensitive. The search can be set to match whole words or part of words.

Examples

CopyC#
#region Autodesk.Revit.DB.FormattedText.#ctor(System.String)
public void ReformatText(TextNote textNote, string textToChange)
{
    String plainText = textNote.Text;
    FormattedText formattedText = new FormattedText(plainText);

    TextRange foundRange = formattedText.Find(textToChange, 0, false, true);
    while (foundRange.Length > 0)
    {
        formattedText.SetBoldStatus(foundRange, true);
        foundRange = formattedText.Find(textToChange, foundRange.End, false, true);
    }

    textNote.SetFormattedText(formattedText);
}
#endregion
CopyVB.NET
#Region "Autodesk.Revit.DB.FormattedText.#ctor(System.String)"
        Public Sub ReformatText(textNote As TextNote, textToChange As String)
            Dim plainText As [String] = textNote.Text
            Dim formattedText As New FormattedText(plainText)

            Dim foundRange As TextRange = formattedText.Find(textToChange, 0, False, True)
            While foundRange.Length > 0
                formattedText.SetBoldStatus(foundRange, True)
                foundRange = formattedText.Find(textToChange, foundRange.[End], False, True)
            End While

            textNote.SetFormattedText(formattedText)
        End Sub
#End Region

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | searchString is an empty string. -or- searchString contains invalid characters such as a newline character.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given value for startIndex is negative.

See Also

FormattedText Class


GetAllCapsStatus Method

[image]

Revit 2024 API
FormattedText..::..GetAllCapsStatus Method
FormattedText Class See Also Send Feedback
Returns whether All, None or a Mixed of characters in the entire text are in all caps.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public FormatStatus GetAllCapsStatus()
Visual Basic
Public Function GetAllCapsStatus As FormatStatus
Visual C++
public:
FormatStatus GetAllCapsStatus()

Return Value

The format status of all caps on characters FormatStatus.

Remarks

This function only returns All or None if the entire text contains one character.

See Also

FormattedText Class
GetAllCapsStatus Overload


GetAllCapsStatus Method (TextRange)

[image]

Revit 2024 API
FormattedText..::..GetAllCapsStatus Method (TextRange)
FormattedText Class See Also Send Feedback
Returns whether All, None or a Mixed set of characters in a given text range are in all caps.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public FormatStatus GetAllCapsStatus(
    TextRange textRange
)
Visual Basic
Public Function GetAllCapsStatus ( _
    textRange As TextRange _
) As FormatStatus
Visual C++
public:
FormatStatus GetAllCapsStatus(
    TextRange^ textRange
)

Parameters

textRange
Type: Autodesk.Revit.DB..::..TextRange
The given text range.

Return Value

The format status of all caps on characters FormatStatus.

Remarks

This function only returns All or None if the text contains one character. The given text range should not be empty.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This text range is empty. -or- This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FormattedText Class
GetAllCapsStatus Overload


GetBoldStatus Method

[image] [image]

Revit 2024 API
FormattedText..::..GetBoldStatus Method
FormattedText Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetBoldStatus()()()() | Returns whether All, None or a Mixed of characters in the entire text are bold.
Public method | GetBoldStatus(TextRange) | Returns whether All, None or a Mixed set of characters in a given text range are bold.

See Also

FormattedText Class
FormattedText Members


GetBoldStatus Method

[image]

Revit 2024 API
FormattedText..::..GetBoldStatus Method
FormattedText Class See Also Send Feedback
Returns whether All, None or a Mixed of characters in the entire text are bold.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public FormatStatus GetBoldStatus()
Visual Basic
Public Function GetBoldStatus As FormatStatus
Visual C++
public:
FormatStatus GetBoldStatus()

Return Value

The format status of bold on characters FormatStatus.

Remarks

This function only returns All or None if the entire text contains one character.

See Also

FormattedText Class
GetBoldStatus Overload


GetBoldStatus Method (TextRange)

[image]

Revit 2024 API
FormattedText..::..GetBoldStatus Method (TextRange)
FormattedText Class See Also Send Feedback
Returns whether All, None or a Mixed set of characters in a given text range are bold.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public FormatStatus GetBoldStatus(
    TextRange textRange
)
Visual Basic
Public Function GetBoldStatus ( _
    textRange As TextRange _
) As FormatStatus
Visual C++
public:
FormatStatus GetBoldStatus(
    TextRange^ textRange
)

Parameters

textRange
Type: Autodesk.Revit.DB..::..TextRange
The given text range.

Return Value

The format status of bold on characters FormatStatus.

Remarks

This function only returns All or None if the text contains one character. The given text range should not be empty.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This text range is empty. -or- This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FormattedText Class
GetBoldStatus Overload


GetIndentLevel Method

[image]

Revit 2024 API
FormattedText..::..GetIndentLevel Method
FormattedText Class See Also Send Feedback
Returns the indent level of the paragraphs in the text range.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public int GetIndentLevel(
    TextRange textRange
)
Visual Basic
Public Function GetIndentLevel ( _
    textRange As TextRange _
) As Integer
Visual C++
public:
int GetIndentLevel(
    TextRange^ textRange
)

Parameters

textRange
Type: Autodesk.Revit.DB..::..TextRange
The given text range.

Return Value

The indentation level of the paragraphs in the range.

Remarks

Returns -1 if the range contains multiple paragraphs with different indent levels.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FormattedText Class


GetItalicStatus Method

[image] [image]

Revit 2024 API
FormattedText..::..GetItalicStatus Method
FormattedText Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetItalicStatus()()()() | Returns whether All, None or a Mixed of characters in the entire text are italic.
Public method | GetItalicStatus(TextRange) | Returns whether All, None or a Mixed set of characters in a given text range are italic.

See Also

FormattedText Class
FormattedText Members


GetItalicStatus Method

[image]

Revit 2024 API
FormattedText..::..GetItalicStatus Method
FormattedText Class See Also Send Feedback
Returns whether All, None or a Mixed of characters in the entire text are italic.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public FormatStatus GetItalicStatus()
Visual Basic
Public Function GetItalicStatus As FormatStatus
Visual C++
public:
FormatStatus GetItalicStatus()

Return Value

The format status of italic on characters FormatStatus.

Remarks

This function only returns All or None if the entire text contains one character.

See Also

FormattedText Class
GetItalicStatus Overload


GetItalicStatus Method (TextRange)

[image]

Revit 2024 API
FormattedText..::..GetItalicStatus Method (TextRange)
FormattedText Class See Also Send Feedback
Returns whether All, None or a Mixed set of characters in a given text range are italic.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public FormatStatus GetItalicStatus(
    TextRange textRange
)
Visual Basic
Public Function GetItalicStatus ( _
    textRange As TextRange _
) As FormatStatus
Visual C++
public:
FormatStatus GetItalicStatus(
    TextRange^ textRange
)

Parameters

textRange
Type: Autodesk.Revit.DB..::..TextRange
The given text range.

Return Value

The format status of italic on characters FormatStatus.

Remarks

This function only returns All or None if the text contains one character. The given text range should not be empty.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This text range is empty. -or- This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FormattedText Class
GetItalicStatus Overload


GetListStartNumber Method

[image]

Revit 2024 API
FormattedText..::..GetListStartNumber Method
FormattedText Class See Also Send Feedback
Returns the list start number of the paragraphs in a given text range.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public int GetListStartNumber(
    TextRange textRange
)
Visual Basic
Public Function GetListStartNumber ( _
    textRange As TextRange _
) As Integer
Visual C++
public:
int GetListStartNumber(
    TextRange^ textRange
)

Parameters

textRange
Type: Autodesk.Revit.DB..::..TextRange
The given text range.

Return Value

The list start number of the text range.

Remarks

Returns -1 if there is a mix of list start values in the range or if there are paragraphs in different lists or sub-lists in the range or if there are paragraphs of type None or Bullet in the range.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FormattedText Class


GetListType Method

[image]

Revit 2024 API
FormattedText..::..GetListType Method
FormattedText Class See Also Send Feedback
Returns the ListType of a paragraph.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public ListType GetListType(
    TextRange textRange
)
Visual Basic
Public Function GetListType ( _
    textRange As TextRange _
) As ListType
Visual C++
public:
ListType GetListType(
    TextRange^ textRange
)

Parameters

textRange
Type: Autodesk.Revit.DB..::..TextRange
The given text range.

Return Value

The ListType of the paragraph.

Remarks

This function returns the list type of all paragraphs contained in the given range. Returns None if the paragraph is not in a list. Returns Mixed if the list types don't match between the paragraphs.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This text range is empty. -or- This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FormattedText Class


GetMaximumIndentLevel Method

[image]

Revit 2024 API
FormattedText..::..GetMaximumIndentLevel Method
FormattedText Class See Also Send Feedback
Returns the maximum allowed indent level

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public int GetMaximumIndentLevel()
Visual Basic
Public Function GetMaximumIndentLevel As Integer
Visual C++
public:
int GetMaximumIndentLevel()

See Also

FormattedText Class


GetMaximumListStartNumber Method

[image]

Revit 2024 API
FormattedText..::..GetMaximumListStartNumber Method
FormattedText Class See Also Send Feedback
Returns the maximum allowed list start number.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public int GetMaximumListStartNumber()
Visual Basic
Public Function GetMaximumListStartNumber As Integer
Visual C++
public:
int GetMaximumListStartNumber()

See Also

FormattedText Class


GetMinimumListStartNumber Method

[image]

Revit 2024 API
FormattedText..::..GetMinimumListStartNumber Method
FormattedText Class See Also Send Feedback
Returns the minumum allowed list start number.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public int GetMinimumListStartNumber()
Visual Basic
Public Function GetMinimumListStartNumber As Integer
Visual C++
public:
int GetMinimumListStartNumber()

See Also

FormattedText Class


GetPlainText Method

[image]

Revit 2024 API
FormattedText..::..GetPlainText Method
FormattedText Class See Also Send Feedback
Returns the entire text in a plain text form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public string GetPlainText()
Visual Basic
Public Function GetPlainText As String
Visual C++
public:
String^ GetPlainText()

Return Value

The entire text in a plain text form.

Remarks

The text includes a carriage return character ('\r') that is always present. As a result this method will never return an empty string.

See Also

FormattedText Class
GetPlainText Overload


GetPlainText Method (TextRange)

[image]

Revit 2024 API
FormattedText..::..GetPlainText Method (TextRange)
FormattedText Class See Also Send Feedback
Returns a substring of the text in a plain text form. The start and end of the substring is identified by a given TextRange.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public string GetPlainText(
    TextRange textRange
)
Visual Basic
Public Function GetPlainText ( _
    textRange As TextRange _
) As String
Visual C++
public:
String^ GetPlainText(
    TextRange^ textRange
)

Parameters

textRange
Type: Autodesk.Revit.DB..::..TextRange
The given TextRange.

Return Value

The substring of the text in a plain text form.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FormattedText Class
GetPlainText Overload


GetSubscriptStatus Method

[image] [image]

Revit 2024 API
FormattedText..::..GetSubscriptStatus Method
FormattedText Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetSubscriptStatus()()()() | Returns whether All, None or a Mixed of characters in the entire text are subscripted.
Public method | GetSubscriptStatus(TextRange) | Returns whether All, None or a Mixed set of characters in a given text range are subscripted.

See Also

FormattedText Class
FormattedText Members


GetSubscriptStatus Method

[image]

Revit 2024 API
FormattedText..::..GetSubscriptStatus Method
FormattedText Class See Also Send Feedback
Returns whether All, None or a Mixed of characters in the entire text are subscripted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public FormatStatus GetSubscriptStatus()
Visual Basic
Public Function GetSubscriptStatus As FormatStatus
Visual C++
public:
FormatStatus GetSubscriptStatus()

Return Value

The format status of subscript on characters FormatStatus.

Remarks

This function only returns All or None if the entire text contains one character.

See Also

FormattedText Class
GetSubscriptStatus Overload


GetSubscriptStatus Method (TextRange)

[image]

Revit 2024 API
FormattedText..::..GetSubscriptStatus Method (TextRange)
FormattedText Class See Also Send Feedback
Returns whether All, None or a Mixed set of characters in a given text range are subscripted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public FormatStatus GetSubscriptStatus(
    TextRange textRange
)
Visual Basic
Public Function GetSubscriptStatus ( _
    textRange As TextRange _
) As FormatStatus
Visual C++
public:
FormatStatus GetSubscriptStatus(
    TextRange^ textRange
)

Parameters

textRange
Type: Autodesk.Revit.DB..::..TextRange
The given text range.

Return Value

The format status of subscript on characters FormatStatus.

Remarks

This function only returns All or None if the text contains one character. The given text range should not be empty.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This text range is empty. -or- This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FormattedText Class
GetSubscriptStatus Overload


GetSuperscriptStatus Method

[image] [image]

Revit 2024 API
FormattedText..::..GetSuperscriptStatus Method
FormattedText Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetSuperscriptStatus()()()() | Returns whether All, None or a Mixed of characters in the entire text are superscripted.
Public method | GetSuperscriptStatus(TextRange) | Returns whether All, None or a Mixed set of characters in a given text range are superscripted.

See Also

FormattedText Class
FormattedText Members


GetSuperscriptStatus Method

[image]

Revit 2024 API
FormattedText..::..GetSuperscriptStatus Method
FormattedText Class See Also Send Feedback
Returns whether All, None or a Mixed of characters in the entire text are superscripted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public FormatStatus GetSuperscriptStatus()
Visual Basic
Public Function GetSuperscriptStatus As FormatStatus
Visual C++
public:
FormatStatus GetSuperscriptStatus()

Return Value

The format status of superscript on characters FormatStatus.

Remarks

This function only returns All or None if the entire text contains one character.

See Also

FormattedText Class
GetSuperscriptStatus Overload


GetSuperscriptStatus Method (TextRange)

[image]

Revit 2024 API
FormattedText..::..GetSuperscriptStatus Method (TextRange)
FormattedText Class See Also Send Feedback
Returns whether All, None or a Mixed set of characters in a given text range are superscripted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public FormatStatus GetSuperscriptStatus(
    TextRange textRange
)
Visual Basic
Public Function GetSuperscriptStatus ( _
    textRange As TextRange _
) As FormatStatus
Visual C++
public:
FormatStatus GetSuperscriptStatus(
    TextRange^ textRange
)

Parameters

textRange
Type: Autodesk.Revit.DB..::..TextRange
The given text range.

Return Value

The format status of superscript on characters FormatStatus.

Remarks

This function only returns All or None if the text contains one character. The given text range should not be empty.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This text range is empty. -or- This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FormattedText Class
GetSuperscriptStatus Overload


GetUnderlineStatus Method

[image] [image]

Revit 2024 API
FormattedText..::..GetUnderlineStatus Method
FormattedText Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetUnderlineStatus()()()() | Returns whether All, None or a Mixed of characters in the entire text are underlined.
Public method | GetUnderlineStatus(TextRange) | Returns whether All, None or a Mixed set of characters in a given text range are underlined.

See Also

FormattedText Class
FormattedText Members


GetUnderlineStatus Method

[image]

Revit 2024 API
FormattedText..::..GetUnderlineStatus Method
FormattedText Class See Also Send Feedback
Returns whether All, None or a Mixed of characters in the entire text are underlined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public FormatStatus GetUnderlineStatus()
Visual Basic
Public Function GetUnderlineStatus As FormatStatus
Visual C++
public:
FormatStatus GetUnderlineStatus()

Return Value

The format status of underline on characters FormatStatus.

Remarks

This function only returns All or None if the entire text contains one character.

See Also

FormattedText Class
GetUnderlineStatus Overload


GetUnderlineStatus Method (TextRange)

[image]

Revit 2024 API
FormattedText..::..GetUnderlineStatus Method (TextRange)
FormattedText Class See Also Send Feedback
Returns whether All, None or a Mixed set of characters in a given text range are underlined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public FormatStatus GetUnderlineStatus(
    TextRange textRange
)
Visual Basic
Public Function GetUnderlineStatus ( _
    textRange As TextRange _
) As FormatStatus
Visual C++
public:
FormatStatus GetUnderlineStatus(
    TextRange^ textRange
)

Parameters

textRange
Type: Autodesk.Revit.DB..::..TextRange
The given text range.

Return Value

The format status of underline on characters FormatStatus.

Remarks

This function only returns All or None if the text contains one character. The given text range should not be empty.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This text range is empty. -or- This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FormattedText Class
GetUnderlineStatus Overload


SetAllCapsStatus Method

[image] [image]

Revit 2024 API
FormattedText..::..SetAllCapsStatus Method
FormattedText Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetAllCapsStatus(Boolean) | Sets the characters in the entire text to be in all caps or not.
Public method | SetAllCapsStatus(TextRange, Boolean) | Sets the characters in a given text range to be in all caps or not.

See Also

FormattedText Class
FormattedText Members


SetAllCapsStatus Method (Boolean)

[image]

Revit 2024 API
FormattedText..::..SetAllCapsStatus Method (Boolean)
FormattedText Class See Also Send Feedback
Sets the characters in the entire text to be in all caps or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public void SetAllCapsStatus(
    bool isAllCaps
)
Visual Basic
Public Sub SetAllCapsStatus ( _
    isAllCaps As Boolean _
)
Visual C++
public:
void SetAllCapsStatus(
    bool isAllCaps
)

Parameters

isAllCaps
Type: System..::..Boolean
The desired all caps status of characters in the entire text. True to set all capped, false to set not all capped.

See Also

FormattedText Class
SetAllCapsStatus Overload


SetAllCapsStatus Method (TextRange, Boolean)

[image]

Revit 2024 API
FormattedText..::..SetAllCapsStatus Method (TextRange, Boolean)
FormattedText Class See Also Send Feedback
Sets the characters in a given text range to be in all caps or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public void SetAllCapsStatus(
    TextRange textRange,
    bool isAllCaps
)
Visual Basic
Public Sub SetAllCapsStatus ( _
    textRange As TextRange, _
    isAllCaps As Boolean _
)
Visual C++
public:
void SetAllCapsStatus(
    TextRange^ textRange,
    bool isAllCaps
)

Parameters

textRange
Type: Autodesk.Revit.DB..::..TextRange
The given text range.
isAllCaps
Type: System..::..Boolean
The desired all caps status of characters in the given text range. True will render all characters in all caps. False will revert the characters back to their original mixed case.

Remarks

Removing the all caps status will revert the characters back to their original case. It will not make them lower case.

The given text range should not be empty.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This text range is empty. -or- This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FormattedText Class
SetAllCapsStatus Overload


SetBoldStatus Method

[image] [image]

Revit 2024 API
FormattedText..::..SetBoldStatus Method
FormattedText Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBoldStatus(Boolean) | Sets the characters in the entire text to be bold or not bold.
Public method | SetBoldStatus(TextRange, Boolean) | Sets the characters in a given text range to be bold or not bold.

See Also

FormattedText Class
FormattedText Members


SetBoldStatus Method (Boolean)

[image]

Revit 2024 API
FormattedText..::..SetBoldStatus Method (Boolean)
FormattedText Class See Also Send Feedback
Sets the characters in the entire text to be bold or not bold.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public void SetBoldStatus(
    bool isBold
)
Visual Basic
Public Sub SetBoldStatus ( _
    isBold As Boolean _
)
Visual C++
public:
void SetBoldStatus(
    bool isBold
)

Parameters

isBold
Type: System..::..Boolean
The desired bold status of characters in the entire text. True to set bold, false to set not bold.

See Also

FormattedText Class
SetBoldStatus Overload


SetIndentLevel Method

[image]

Revit 2024 API
FormattedText..::..SetIndentLevel Method
FormattedText Class See Also Send Feedback
Sets the number of tab stops that the paragraph should be indented.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public void SetIndentLevel(
    TextRange textRange,
    int level
)
Visual Basic
Public Sub SetIndentLevel ( _
    textRange As TextRange, _
    level As Integer _
)
Visual C++
public:
void SetIndentLevel(
    TextRange^ textRange,
    int level
)

Parameters

textRange
Type: Autodesk.Revit.DB..::..TextRange
The given text range.
level
Type: System..::..Int32
The level set on the paragraph.

Remarks

The indent level is the number of tab stops by which each paragraph will be indented.

Note that adjoining paragraphs that have the same indent level and have a list type other than None are considered part of a numbered list. Changing the indent level of paragraphs that are bulleted or numbered (i.e. paragraphs that have a list type other than None) may cause other changes to the document as the changed paragraphs may join or leave a list. Which will cause the other paragraphs in those lists to be renumbered.

This function applies the nesting level to all paragraphs contained in the given range. The level set on the paragraph cannot be negative and cannot be larger than the value returned by GetMaximumIndentLevel()()()() .

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text. -or- This level is too large to set on a paragraph.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given value for level is negative.

See Also

FormattedText Class


SetItalicStatus Method

[image] [image]

Revit 2024 API
FormattedText..::..SetItalicStatus Method
FormattedText Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetItalicStatus(Boolean) | Sets the characters in the entire text to be italic or not italic.
Public method | SetItalicStatus(TextRange, Boolean) | Sets the characters in a given text range to be italic or not italic.

See Also

FormattedText Class
FormattedText Members


SetItalicStatus Method (TextRange, Boolean)

[image]

Revit 2024 API
FormattedText..::..SetItalicStatus Method (TextRange, Boolean)
FormattedText Class See Also Send Feedback
Sets the characters in a given text range to be italic or not italic.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public void SetItalicStatus(
    TextRange textRange,
    bool isItalic
)
Visual Basic
Public Sub SetItalicStatus ( _
    textRange As TextRange, _
    isItalic As Boolean _
)
Visual C++
public:
void SetItalicStatus(
    TextRange^ textRange,
    bool isItalic
)

Parameters

textRange
Type: Autodesk.Revit.DB..::..TextRange
The given text range.
isItalic
Type: System..::..Boolean
The desired italic status of characters in the given text range. True to set italic, false to set not italic.

Remarks

To make the numbers or letters in a list italic, apply the italic status to the carriage return character that ends the list paragraph.

The given text range should not be empty.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This text range is empty. -or- This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FormattedText Class
SetItalicStatus Overload


SetListType Method

[image]

Revit 2024 API
FormattedText..::..SetListType Method
FormattedText Class Example See Also Send Feedback
Sets the ListType of a paragraph.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public void SetListType(
    TextRange textRange,
    ListType listType
)
Visual Basic
Public Sub SetListType ( _
    textRange As TextRange, _
    listType As ListType _
)
Visual C++
public:
void SetListType(
    TextRange^ textRange,
    ListType listType
)

Parameters

textRange
Type: Autodesk.Revit.DB..::..TextRange
The given text range.
listType
Type: Autodesk.Revit.DB..::..ListType
The ListType to set on the paragraph.

Remarks

This function applies the ListType to all paragraphs contained in the given range.

The following ListType options are available:

  • Bullet
  • ArabicNumbers
  • LowerCaseLetters
  • UpperCaseLetters

Set the list type to None if the paragraph should not be in a list.

The list type cannot be set to Mixed.

Paragraphs with a ListType other than None are considered to be 'list' paragraphs.

Consecutive list paragraphs with the same indentation level are treated as part of the same list. A list ends when a list paragraph is followed by

  • a paragraph that has None
  • or a list paragraph that has a lower indentation level, (i.e. is indented less)
Note that a list will continue uninterrupted after list paragraphs that have higher indentation level. These paragraphs are considered a 'sub-list'. Using SetIndentLevel(TextRange, Int32) it is therefore possible to create multi-level lists. Note that sub-lists can have their own sub-sub-lists. The nesting level is only limited by the maximum indent level.

FormattedText will keep lists consistent. That means that numbered paragraphs will automatically get sequential numbers or letters. It also means that if the list type of one paragraphs in the list is changed then that change is propagated to all the paragraphs in that list. Even if those paragraphs were not in the input text range. Note that this will not affect the list type of any nested sub-lists.

Use a vertical tab character ('\v') to insert a line without a bullet or number. Since this does not end the paragraph this will allow the list to continue to the next paragraph.

Examples

CopyC#
#region Autodesk.Revit.DB.FormattedText.AsTextRange()
public void AppendText(TextNote textNote)
{
    FormattedText formatText = textNote.GetFormattedText();

    TextRange range = formatText.AsTextRange();

    range.Start = range.End - 1;
    // set Length to 0 to insert
    range.Length = 0;
    string someNewText = "\rThis is a new paragraph\vThis is a new line without a paragraph break\r";
    formatText.SetPlainText(range, someNewText);

    // get range for entire text
    range = formatText.AsTextRange();
    range.Start = range.End - 1;
    range.Length = 0;
    string someListText = "\rBulleted List item 1\rItem 2\vSecond line for Item 2\rThird bullet point";
    formatText.SetPlainText(range, someListText);
    range.Start++;
    range.Length = someListText.Length;
    formatText.SetListType(range, ListType.Bullet);

    if (formatText.GetAllCapsStatus(range) != FormatStatus.None)
    {
        formatText.SetAllCapsStatus(range, false);
    }

    textNote.SetFormattedText(formatText);
}
#endregion
CopyVB.NET
#Region "Autodesk.Revit.DB.FormattedText.AsTextRange()"
        Public Sub AppendText(textNote As TextNote)
            Dim formatText As FormattedText = textNote.GetFormattedText()

            Dim range As TextRange = formatText.AsTextRange()

            range.Start = range.[End] - 1
            ' set Length to 0 to insert
            range.Length = 0
            Dim someNewText As String = vbCr & "This is a new paragraph" & vbVerticalTab & "This is a new line without a paragraph break" & vbCr
            formatText.SetPlainText(range, someNewText)

            ' get range for entire text
            range = formatText.AsTextRange()
            range.Start = range.[End] - 1
            range.Length = 0
            Dim someListText As String = vbCr & "Bulleted List item 1" & vbCr & "Item 2" & vbVerticalTab & "Second line for Item 2" & vbCr & "Third bullet point"
            formatText.SetPlainText(range, someListText)
            range.Start += 1
            range.Length = someListText.Length
            formatText.SetListType(range, ListType.Bullet)

            If formatText.GetAllCapsStatus(range) <> FormatStatus.None Then
                formatText.SetAllCapsStatus(range, False)
            End If

            textNote.SetFormattedText(formatText)
        End Sub
#End Region

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This text range is empty. -or- This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text. -or- This list type is not valid to set on a paragraph.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

FormattedText Class


SetPlainText Method (String)

[image]

Revit 2024 API
FormattedText..::..SetPlainText Method (String)
FormattedText Class See Also Send Feedback
Sets the entire text with the given text in a plain text form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public void SetPlainText(
    string plainText
)
Visual Basic
Public Sub SetPlainText ( _
    plainText As String _
)
Visual C++
public:
void SetPlainText(
    String^ plainText
)

Parameters

plainText
Type: System..::..String
The given text in a plain text form.

Remarks

Any individual formatting present before will be lost after applying this function and the text will have uniform formatting. If the text does not end with a carriage return character ('\r') one will be added. An empty string is allowed. The given text should have no more than 30,000 characters, not counting a terminating carriage return character ('\r'). Newline characters ('\n') are not allowed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | plainText (excluding a carriage return character ('\r') at the end) has more than 30,000 characters. -or- plainText contains invalid characters such as a newline character.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FormattedText Class
SetPlainText Overload


SetSubscriptStatus Method (Boolean)

[image]

Revit 2024 API
FormattedText..::..SetSubscriptStatus Method (Boolean)
FormattedText Class See Also Send Feedback
Sets the characters in the entire text to be subscript or not subscript.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public void SetSubscriptStatus(
    bool isSubscript
)
Visual Basic
Public Sub SetSubscriptStatus ( _
    isSubscript As Boolean _
)
Visual C++
public:
void SetSubscriptStatus(
    bool isSubscript
)

Parameters

isSubscript
Type: System..::..Boolean
The desired subscript status of characters in the entire text. True to set subscript, false to set not subscript.

Remarks

If the characters are set to be subscript, they cannot be superscript. This sets the superscript status to false.

See Also

FormattedText Class
SetSubscriptStatus Overload


SetSubscriptStatus Method (TextRange, Boolean)

[image]

Revit 2024 API
FormattedText..::..SetSubscriptStatus Method (TextRange, Boolean)
FormattedText Class See Also Send Feedback
Sets the characters in a given text range to be subscript or not subscript.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public void SetSubscriptStatus(
    TextRange textRange,
    bool isSubscript
)
Visual Basic
Public Sub SetSubscriptStatus ( _
    textRange As TextRange, _
    isSubscript As Boolean _
)
Visual C++
public:
void SetSubscriptStatus(
    TextRange^ textRange,
    bool isSubscript
)

Parameters

textRange
Type: Autodesk.Revit.DB..::..TextRange
The given text range.
isSubscript
Type: System..::..Boolean
The desired subscript status of characters in the given text range. True to set subscript, false to set not subscript.

Remarks

Superscript and subscript are mutually exclusive. Applying the subscript status will automatically remove the superscript status.

The given text range should not be empty.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This text range is empty. -or- This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FormattedText Class
SetSubscriptStatus Overload


SetSuperscriptStatus Method

[image] [image]

Revit 2024 API
FormattedText..::..SetSuperscriptStatus Method
FormattedText Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetSuperscriptStatus(Boolean) | Sets the characters in the entire text to be superscript or not superscript.
Public method | SetSuperscriptStatus(TextRange, Boolean) | Sets the characters in a given text range to be superscript or not superscript.

See Also

FormattedText Class
FormattedText Members


SetSuperscriptStatus Method (Boolean)

[image]

Revit 2024 API
FormattedText..::..SetSuperscriptStatus Method (Boolean)
FormattedText Class See Also Send Feedback
Sets the characters in the entire text to be superscript or not superscript.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public void SetSuperscriptStatus(
    bool isSuperscript
)
Visual Basic
Public Sub SetSuperscriptStatus ( _
    isSuperscript As Boolean _
)
Visual C++
public:
void SetSuperscriptStatus(
    bool isSuperscript
)

Parameters

isSuperscript
Type: System..::..Boolean
The desired superscript status of characters in the entire text. True to set superscript, false to set not superscript.

Remarks

If the characters are set to be superscript, they cannot be subscript. This sets the subscript status to false.

See Also

FormattedText Class
SetSuperscriptStatus Overload


SetSuperscriptStatus Method (TextRange, Boolean)

[image]

Revit 2024 API
FormattedText..::..SetSuperscriptStatus Method (TextRange, Boolean)
FormattedText Class See Also Send Feedback
Sets the characters in a given text range to be superscript or not superscript.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public void SetSuperscriptStatus(
    TextRange textRange,
    bool isSuperscript
)
Visual Basic
Public Sub SetSuperscriptStatus ( _
    textRange As TextRange, _
    isSuperscript As Boolean _
)
Visual C++
public:
void SetSuperscriptStatus(
    TextRange^ textRange,
    bool isSuperscript
)

Parameters

textRange
Type: Autodesk.Revit.DB..::..TextRange
The given text range.
isSuperscript
Type: System..::..Boolean
The desired superscript status of characters in the given text range. True to set superscript, false to set not superscript.

Remarks

Superscript and subscript are mutually exclusive. Applying the superscript status will automatically remove the subscript status.

The given text range should not be empty.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This text range is empty. -or- This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FormattedText Class
SetSuperscriptStatus Overload


SetUnderlineStatus Method (Boolean)

[image]

Revit 2024 API
FormattedText..::..SetUnderlineStatus Method (Boolean)
FormattedText Class See Also Send Feedback
Sets the characters in the entire text to be underlined or not underlined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public void SetUnderlineStatus(
    bool isUnderlined
)
Visual Basic
Public Sub SetUnderlineStatus ( _
    isUnderlined As Boolean _
)
Visual C++
public:
void SetUnderlineStatus(
    bool isUnderlined
)

Parameters

isUnderlined
Type: System..::..Boolean
The desired underline status of characters in the entire text. True to set underlined, false to set not underlined.

See Also

FormattedText Class
SetUnderlineStatus Overload


FormattedText Properties

[image] [image]

Revit 2024 API
FormattedText Properties
FormattedText Class See Also Send Feedback

The FormattedText type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

FormattedText Class


IsValidObject Property

[image]

Revit 2024 API
FormattedText..::..IsValidObject Property
FormattedText Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

FormattedText Class


FormatValueOptions Class

[image]

Revit 2024 API
FormatValueOptions Class
Members See Also Send Feedback
Options for formatting numbers with units into strings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class FormatValueOptions : IDisposable
Visual Basic
Public Class FormatValueOptions _
    Implements IDisposable
Visual C++
public ref class FormatValueOptions : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FormatValueOptions

See Also

FormatValueOptions Members


FormatValueOptions Members

[image] [image]

Revit 2024 API
FormatValueOptions Members
FormatValueOptions Class Constructors Methods Properties See Also Send Feedback

The FormatValueOptions type exposes the following members.

Constructors

 | Name | Description
Public method | FormatValueOptions | Creates a new FormatValueOptions object with default settings.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FormatValueOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetFormatOptions | Gets the FormatOptions to optionally override the default settings in the Units class.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetFormatOptions | Sets the FormatOptions to optionally override the default settings in the Units class.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AppendUnitSymbol | Indicates if a unit symbol should be appended regardless of the settings in the FormatOptions.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

FormatValueOptions Class


FormatValueOptions Constructor

[image]

Revit 2024 API
FormatValueOptions Constructor
FormatValueOptions Class See Also Send Feedback
Creates a new FormatValueOptions object with default settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public FormatValueOptions()
Visual Basic
Public Sub New
Visual C++
public:
FormatValueOptions()

See Also

FormatValueOptions Class


FormatValueOptions Methods

[image] [image]

Revit 2024 API
FormatValueOptions Methods
FormatValueOptions Class See Also Send Feedback

The FormatValueOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetFormatOptions | Gets the FormatOptions to optionally override the default settings in the Units class.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetFormatOptions | Sets the FormatOptions to optionally override the default settings in the Units class.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

FormatValueOptions Class


Dispose Method

[image]

Revit 2024 API
FormatValueOptions..::..Dispose Method
FormatValueOptions Class See Also Send Feedback
Releases all resources used by the FormatValueOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FormatValueOptions Class


GetFormatOptions Method

[image]

Revit 2024 API
FormatValueOptions..::..GetFormatOptions Method
FormatValueOptions Class See Also Send Feedback
Gets the FormatOptions to optionally override the default settings in the Units class.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public FormatOptions GetFormatOptions()
Visual Basic
Public Function GetFormatOptions As FormatOptions
Visual C++
public:
FormatOptions^ GetFormatOptions()

Return Value

A copy of the FormatOptions.

Remarks

By default, the FormatOptions represents default formatting (UseDefault is true) and the FormatOptions in the Units class will be used.

See Also

FormatValueOptions Class


SetFormatOptions Method

[image]

Revit 2024 API
FormatValueOptions..::..SetFormatOptions Method
FormatValueOptions Class See Also Send Feedback
Sets the FormatOptions to optionally override the default settings in the Units class.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void SetFormatOptions(
    FormatOptions formatOptions
)
Visual Basic
Public Sub SetFormatOptions ( _
    formatOptions As FormatOptions _
)
Visual C++
public:
void SetFormatOptions(
    FormatOptions^ formatOptions
)

Parameters

formatOptions
Type: Autodesk.Revit.DB..::..FormatOptions
The FormatOptions.

Remarks

By default, the FormatOptions represents default formatting (UseDefault is true) and the FormatOptions in the Units class will be used.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FormatValueOptions Class


FormatValueOptions Properties

[image] [image]

Revit 2024 API
FormatValueOptions Properties
FormatValueOptions Class See Also Send Feedback

The FormatValueOptions type exposes the following members.

Properties

 | Name | Description
Public property | AppendUnitSymbol | Indicates if a unit symbol should be appended regardless of the settings in the FormatOptions.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

FormatValueOptions Class


AppendUnitSymbol Property

[image]

Revit 2024 API
FormatValueOptions..::..AppendUnitSymbol Property
FormatValueOptions Class See Also Send Feedback
Indicates if a unit symbol should be appended regardless of the settings in the FormatOptions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool AppendUnitSymbol { get; set; }
Visual Basic
Public Property AppendUnitSymbol As Boolean
    Get
    Set
Visual C++
public:
property bool AppendUnitSymbol {
    bool get ();
    void set (bool value);
}

Field Value

True to force a unit symbol to be appended; false to use the settings specified by the FormatOptions. The default is false.

See Also

FormatValueOptions Class


IsValidObject Property

[image]

Revit 2024 API
FormatValueOptions..::..IsValidObject Property
FormatValueOptions Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

FormatValueOptions Class


FormulaManager Members

[image] [image]

Revit 2024 API
FormulaManager Members
FormulaManager Class Methods Properties See Also Send Feedback

The FormulaManager type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FormulaManager
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate | Evaluates value of the formula
 | GetFunctions | Gets list of function names supported by formula engine
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOperators | Gets list of operator names supported by formula engine
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | Validate | Validates the formuls

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

FormulaManager Class


FormulaManager Methods

[image] [image]

Revit 2024 API
FormulaManager Methods
FormulaManager Class See Also Send Feedback

The FormulaManager type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate | Evaluates value of the formula
 | GetFunctions | Gets list of function names supported by formula engine
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOperators | Gets list of operator names supported by formula engine
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | Validate | Validates the formuls

See Also

FormulaManager Class


Evaluate Method

[image]

Revit 2024 API
FormulaManager..::..Evaluate Method
FormulaManager Class See Also Send Feedback
Evaluates value of the formula

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static string Evaluate(
    ElementId parameterId,
    Document document,
    string formula
)
Visual Basic
Public Shared Function Evaluate ( _
    parameterId As ElementId, _
    document As Document, _
    formula As String _
) As String
Visual C++
public:
static String^ Evaluate(
    ElementId^ parameterId,
    Document^ document,
    String^ formula
)

Parameters

parameterId
Type: Autodesk.Revit.DB..::..ElementId
document
Type: Autodesk.Revit.DB..::..Document
formula
Type: System..::..String

Remarks

It evaluates formula using list of global or family parameters depends on document type.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FormulaManager Class


GetFunctions Method

[image]

Revit 2024 API
FormulaManager..::..GetFunctions Method
FormulaManager Class See Also Send Feedback
Gets list of function names supported by formula engine

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static IList<string> GetFunctions()
Visual Basic
Public Shared Function GetFunctions As IList(Of String)
Visual C++
public:
static IList<String^>^ GetFunctions()

See Also

FormulaManager Class


GetOperators Method

[image]

Revit 2024 API
FormulaManager..::..GetOperators Method
FormulaManager Class See Also Send Feedback
Gets list of operator names supported by formula engine

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static IList<string> GetOperators()
Visual Basic
Public Shared Function GetOperators As IList(Of String)
Visual C++
public:
static IList<String^>^ GetOperators()

See Also

FormulaManager Class


Validate Method

[image]

Revit 2024 API
FormulaManager..::..Validate Method
FormulaManager Class See Also Send Feedback
Validates the formuls

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static string Validate(
    ElementId parameterId,
    Document document,
    string formula
)
Visual Basic
Public Shared Function Validate ( _
    parameterId As ElementId, _
    document As Document, _
    formula As String _
) As String
Visual C++
public:
static String^ Validate(
    ElementId^ parameterId,
    Document^ document,
    String^ formula
)

Parameters

parameterId
Type: Autodesk.Revit.DB..::..ElementId
document
Type: Autodesk.Revit.DB..::..Document
formula
Type: System..::..String

Remarks

It validates formula using list of global or family parameters depends on document type.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FormulaManager Class


FormulaManager Properties

[image] [image]

Revit 2024 API
FormulaManager Properties
FormulaManager Class See Also Send Feedback

The FormulaManager type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

FormulaManager Class


IsValidObject Property

[image]

Revit 2024 API
FormulaManager..::..IsValidObject Property
FormulaManager Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

FormulaManager Class


FormUtils Members

[image] [image]

Revit 2024 API
FormUtils Members
FormUtils Class Methods See Also Send Feedback

The FormUtils type exposes the following members.

Methods

Name | Description
CanBeDissolved | Validates that input contains one or more form elements or geom combinations containing form elements.
DissolveForms(Document, ICollection<(Of <<'(ElementId>)>>)) | Dissolves a collection of form elements into their defining elements.
DissolveForms(Document, ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>)%) | Dissolves a collection of form elements into their defining elements.

See Also

FormUtils Class


FormUtils Methods

[image] [image]

Revit 2024 API
FormUtils Methods
FormUtils Class See Also Send Feedback

The FormUtils type exposes the following members.

Methods

Name | Description
CanBeDissolved | Validates that input contains one or more form elements or geom combinations containing form elements.
DissolveForms(Document, ICollection<(Of <<'(ElementId>)>>)) | Dissolves a collection of form elements into their defining elements.
DissolveForms(Document, ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>)%) | Dissolves a collection of form elements into their defining elements.

See Also

FormUtils Class


CanBeDissolved Method

[image]

Revit 2024 API
FormUtils..::..CanBeDissolved Method
FormUtils Class See Also Send Feedback
Validates that input contains one or more form elements or geom combinations containing form elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static bool CanBeDissolved(
    Document ADoc,
    ICollection<ElementId> elements
)
Visual Basic
Public Shared Function CanBeDissolved ( _
    ADoc As Document, _
    elements As ICollection(Of ElementId) _
) As Boolean
Visual C++
public:
static bool CanBeDissolved(
    Document^ ADoc,
    ICollection<ElementId^>^ elements
)

Parameters

ADoc
Type: Autodesk.Revit.DB..::..Document
The document.
elements
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
A collection of elements.

Return Value

True if inputs contain one or more form elements. Non-form element inputs are ignored. False if none of the inputs are form elements or do not contain form elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FormUtils Class


DissolveForms Method

[image] [image]

Revit 2024 API
FormUtils..::..DissolveForms Method
FormUtils Class See Also Send Feedback

Overload List

Name | Description
DissolveForms(Document, ICollection<(Of <<'(ElementId>)>>)) | Dissolves a collection of form elements into their defining elements.
DissolveForms(Document, ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>)%) | Dissolves a collection of form elements into their defining elements.

See Also

FormUtils Class
FormUtils Members


DissolveForms Method (Document, ICollection(ElementId))

[image]

Revit 2024 API
FormUtils..::..DissolveForms Method (Document, ICollection<(Of <(<'ElementId>)>)>)
FormUtils Class See Also Send Feedback
Dissolves a collection of form elements into their defining elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ICollection<ElementId> DissolveForms(
    Document ADoc,
    ICollection<ElementId> elements
)
Visual Basic
Public Shared Function DissolveForms ( _
    ADoc As Document, _
    elements As ICollection(Of ElementId) _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ DissolveForms(
    Document^ ADoc,
    ICollection<ElementId^>^ elements
)

Parameters

ADoc
Type: Autodesk.Revit.DB..::..Document
The document
elements
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
A collection of element IDs of Forms and GeomCombinations that contain Forms that will be dissolved.

Return Value

A collection of curve element ids from the profiles and paths of the dissolved forms.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The elements do not include Forms that can be dissolved.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FormUtils Class
DissolveForms Overload


DissolveForms Method (Document, ICollection(ElementId), ICollection(ElementId))

[image]

Revit 2024 API
FormUtils..::..DissolveForms Method (Document, ICollection<(Of <(<'ElementId>)>)>, ICollection<(Of <(<'ElementId>)>)>%)
FormUtils Class See Also Send Feedback
Dissolves a collection of form elements into their defining elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ICollection<ElementId> DissolveForms(
    Document ADoc,
    ICollection<ElementId> elements,
    out ICollection<ElementId> ProfileOriginPointSet
)
Visual Basic
Public Shared Function DissolveForms ( _
    ADoc As Document, _
    elements As ICollection(Of ElementId), _
    <OutAttribute> ByRef ProfileOriginPointSet As ICollection(Of ElementId) _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ DissolveForms(
    Document^ ADoc,
    ICollection<ElementId^>^ elements,
    [OutAttribute] ICollection<ElementId^>^% ProfileOriginPointSet
)

Parameters

ADoc
Type: Autodesk.Revit.DB..::..Document
The document
elements
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
A collection of element IDs of Forms and GeomCombinations that contain Forms that will be dissolved.
ProfileOriginPointSet
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>%
A collection of the point element ids that represent the 'origin' of the profiles

Return Value

A collection of curve element ids from the profiles and paths of the dissolved forms.

Remarks

Profile origin points define the workplane of form profiles and paths and their curves. The profile origin point represents a coordinate system with an origin (reference point) which can be manipulated to move the curves of a profile together as a unit after dissolve. Profile origin points may themselves be constrained to other parts of the model or parts of the form, based on how the form was created/constructed. This is done through the reference point hosting mechanism.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The elements do not include Forms that can be dissolved.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FormUtils Class
DissolveForms Overload


Frame Members

[image] [image]

Revit 2024 API
Frame Members
Frame Class Constructors Methods Properties See Also Send Feedback

The Frame type exposes the following members.

Constructors

 | Name | Description
Public method | Frame()()()() | Default constructor. Uses global origin and standard basis vectors.
Public method | Frame(XYZ, XYZ, XYZ, XYZ) | Constructor that takes the frame's base point and three basis vectors.

Methods

 | Name | Description
 | CanDefineRevitGeometry | Tests whether the supplied Frame object may be used to define a Revit curve or surface. In order to satisfy the requirements the Frame must be orthonormal and its origin is expected to lie within the Revit design limits IsWithinLengthLimits(XYZ).
Public method | Dispose | Releases all resources used by the Frame
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsOrthogonal | Determines if this frame's basis vectors are orthogonal.
Public method | IsOrthonormal | Determines if this frame's basis vectors are orthonormal.
Public method | IsRightHanded | Determine if this frame's basis is right-handed.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Transform | Applies the input transform to this frame.

Properties

 | Name | Description
Public property | BasisX | The first basis vector of the frame.
Public property | BasisY | The second basis vector of the frame.
Public property | BasisZ | The third basis vector of the frame.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Origin | The frame's base point.

See Also

Frame Class


Frame Constructor

[image] [image]

Revit 2024 API
Frame Constructor
Frame Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Frame()()()() | Default constructor. Uses global origin and standard basis vectors.
Public method | Frame(XYZ, XYZ, XYZ, XYZ) | Constructor that takes the frame's base point and three basis vectors.

See Also

Frame Class
Frame Members


Frame Constructor

[image]

Revit 2024 API
Frame Constructor
Frame Class See Also Send Feedback
Default constructor. Uses global origin and standard basis vectors.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public Frame()
Visual Basic
Public Sub New
Visual C++
public:
Frame()

See Also

Frame Class
Frame Overload


Frame Constructor (XYZ, XYZ, XYZ, XYZ)

[image]

Revit 2024 API
Frame Constructor (XYZ, XYZ, XYZ, XYZ)
Frame Class See Also Send Feedback
Constructor that takes the frame's base point and three basis vectors.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public Frame(
    XYZ origin,
    XYZ vec1,
    XYZ vec2,
    XYZ vec3
)
Visual Basic
Public Sub New ( _
    origin As XYZ, _
    vec1 As XYZ, _
    vec2 As XYZ, _
    vec3 As XYZ _
)
Visual C++
public:
Frame(
    XYZ^ origin,
    XYZ^ vec1,
    XYZ^ vec2,
    XYZ^ vec3
)

Parameters

origin
Type: Autodesk.Revit.DB..::..XYZ
The frame's base point.
vec1
Type: Autodesk.Revit.DB..::..XYZ
The frame's first basis vector.
vec2
Type: Autodesk.Revit.DB..::..XYZ
The frame's second basis vector.
vec3
Type: Autodesk.Revit.DB..::..XYZ
The frame's third basis vector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Frame Class
Frame Overload


Frame Methods

[image] [image]

Revit 2024 API
Frame Methods
Frame Class See Also Send Feedback

The Frame type exposes the following members.

Methods

 | Name | Description
 | CanDefineRevitGeometry | Tests whether the supplied Frame object may be used to define a Revit curve or surface. In order to satisfy the requirements the Frame must be orthonormal and its origin is expected to lie within the Revit design limits IsWithinLengthLimits(XYZ).
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsOrthogonal | Determines if this frame's basis vectors are orthogonal.
Public method | IsOrthonormal | Determines if this frame's basis vectors are orthonormal.
Public method | IsRightHanded | Determine if this frame's basis is right-handed.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Transform | Applies the input transform to this frame.

See Also

Frame Class


CanDefineRevitGeometry Method

[image]

Revit 2024 API
Frame..::..CanDefineRevitGeometry Method
Frame Class See Also Send Feedback
Tests whether the supplied Frame object may be used to define a Revit curve or surface. In order to satisfy the requirements the Frame must be orthonormal and its origin is expected to lie within the Revit design limits IsWithinLengthLimits(XYZ).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public static bool CanDefineRevitGeometry(
    Frame frameOfReference
)
Visual Basic
Public Shared Function CanDefineRevitGeometry ( _
    frameOfReference As Frame _
) As Boolean
Visual C++
public:
static bool CanDefineRevitGeometry(
    Frame^ frameOfReference
)

Parameters

frameOfReference
Type: Autodesk.Revit.DB..::..Frame
Frame to be validated.

Return Value

True if this Frame may be used as a local frame of reference, false otherwise.

Remarks

Certain Revit curve and surface types are defined using a local frame of reference.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Frame Class


Dispose Method

[image]

Revit 2024 API
Frame..::..Dispose Method
Frame Class See Also Send Feedback
Releases all resources used by the Frame

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

Frame Class


IsOrthogonal Method

[image]

Revit 2024 API
Frame..::..IsOrthogonal Method
Frame Class See Also Send Feedback
Determines if this frame's basis vectors are orthogonal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public bool IsOrthogonal()
Visual Basic
Public Function IsOrthogonal As Boolean
Visual C++
public:
bool IsOrthogonal()

Return Value

True if this frame's basis vectors are orthogonal, false if not.

See Also

Frame Class


IsOrthonormal Method

[image]

Revit 2024 API
Frame..::..IsOrthonormal Method
Frame Class See Also Send Feedback
Determines if this frame's basis vectors are orthonormal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public bool IsOrthonormal()
Visual Basic
Public Function IsOrthonormal As Boolean
Visual C++
public:
bool IsOrthonormal()

Return Value

True if this frame's basis vectors are orthonormal, false if not.

Remarks

"Orthonormal" means that the three vectors are orthogonal and each of them has unit length.

See Also

Frame Class


IsRightHanded Method

[image]

Revit 2024 API
Frame..::..IsRightHanded Method
Frame Class See Also Send Feedback
Determine if this frame's basis is right-handed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public bool IsRightHanded()
Visual Basic
Public Function IsRightHanded As Boolean
Visual C++
public:
bool IsRightHanded()

Return Value

True if this frame's basis is right-handed, false if not.

Remarks

The three basis vectors are "right-handed" if the triple vector product [vecX, vecY, vecZ] is positive, or equivalently if dot(vecX x vecY, vecZ) is positive, where "dot" represents the dot product.

See Also

Frame Class


Transform Method

[image]

Revit 2024 API
Frame..::..Transform Method
Frame Class See Also Send Feedback
Applies the input transform to this frame.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public void Transform(
    Transform trf
)
Visual Basic
Public Sub Transform ( _
    trf As Transform _
)
Visual C++
public:
void Transform(
    Transform^ trf
)

Parameters

trf
Type: Autodesk.Revit.DB..::..Transform
The transform to apply to the frame.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | this operation failed.

See Also

Frame Class


Frame Properties

[image] [image]

Revit 2024 API
Frame Properties
Frame Class See Also Send Feedback

The Frame type exposes the following members.

Properties

 | Name | Description
Public property | BasisX | The first basis vector of the frame.
Public property | BasisY | The second basis vector of the frame.
Public property | BasisZ | The third basis vector of the frame.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Origin | The frame's base point.

See Also

Frame Class


BasisX Property

[image]

Revit 2024 API
Frame..::..BasisX Property
Frame Class See Also Send Feedback
The first basis vector of the frame.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public XYZ BasisX { get; set; }
Visual Basic
Public Property BasisX As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ BasisX {
    XYZ^ get ();
    void set (XYZ^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

Frame Class


BasisY Property

[image]

Revit 2024 API
Frame..::..BasisY Property
Frame Class See Also Send Feedback
The second basis vector of the frame.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public XYZ BasisY { get; set; }
Visual Basic
Public Property BasisY As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ BasisY {
    XYZ^ get ();
    void set (XYZ^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

Frame Class


BasisZ Property

[image]

Revit 2024 API
Frame..::..BasisZ Property
Frame Class See Also Send Feedback
The third basis vector of the frame.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public XYZ BasisZ { get; set; }
Visual Basic
Public Property BasisZ As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ BasisZ {
    XYZ^ get ();
    void set (XYZ^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

Frame Class


IsValidObject Property

[image]

Revit 2024 API
Frame..::..IsValidObject Property
Frame Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

Frame Class


Origin Property

[image]

Revit 2024 API
Frame..::..Origin Property
Frame Class See Also Send Feedback
The frame's base point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public XYZ Origin { get; set; }
Visual Basic
Public Property Origin As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
    void set (XYZ^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

Frame Class


FramingShapeClassification Enumeration

[image]

Revit 2024 API
FramingShapeClassification Enumeration
See Also Send Feedback
This enumeration is used to classify MEP Ancillary Framing shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public enum FramingShapeClassification
Visual Basic
Public Enumeration FramingShapeClassification
Visual C++
public enum class FramingShapeClassification

Members

Member name | Description
Linear |
Circular |
Oval |
Other |

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


FreeFormElement Class

[image]

Revit 2024 API
FreeFormElement Class
Members See Also Send Feedback
A Free Form Element that contains non-parametric geometry created from an input solid outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class FreeFormElement : GenericForm
Visual Basic
Public Class FreeFormElement _
    Inherits GenericForm
Visual C++
public ref class FreeFormElement : public GenericForm

Remarks

The element can participate in joins and void cuts with other combinable elements.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..CombinableElement
Autodesk.Revit.DB..::..GenericForm
Autodesk.Revit.DB..::..FreeFormElement

See Also

FreeFormElement Members


FreeFormElement Members

[image] [image]

Revit 2024 API
FreeFormElement Members
FreeFormElement Class Methods Properties See Also Send Feedback

The FreeFormElement type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanOffsetFace | Determines if the input face of the FreeFormElement can be offset.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create | Creates a new FreeFormElement from a copy of the input geometry.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetFaceOffset | Offsets a planar face of the free form element a certain distance in the normal direction.
Public method | SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateSolidGeometry | Updates the geometry of the FreeForm element to the given shape preserving References to the existing geometry where possible (see remarks for rules).

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Get and Set the Name property (Inherited from GenericForm.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Subcategory | The subcategory. (Inherited from GenericForm.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Visible | The visibility of the GenericForm. (Inherited from GenericForm.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FreeFormElement Class


CanOffsetFace Method

[image]

Revit 2024 API
FreeFormElement..::..CanOffsetFace Method
FreeFormElement Class See Also Send Feedback
Determines if the input face of the FreeFormElement can be offset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool CanOffsetFace(
    Face face
)
Visual Basic
Public Function CanOffsetFace ( _
    face As Face _
) As Boolean
Visual C++
public:
bool CanOffsetFace(
    Face^ face
)

Parameters

face
Type: Autodesk.Revit.DB..::..Face
The face to be checked.

Return Value

True if the face can be offset, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FreeFormElement Class


Create Method

[image]

Revit 2024 API
FreeFormElement..::..Create Method
FreeFormElement Class See Also Send Feedback
Creates a new FreeFormElement from a copy of the input geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static FreeFormElement Create(
    Document document,
    Solid geometry
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    geometry As Solid _
) As FreeFormElement
Visual C++
public:
static FreeFormElement^ Create(
    Document^ document,
    Solid^ geometry
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which the element is to be created.
geometry
Type: Autodesk.Revit.DB..::..Solid
The input geometry.

Return Value

returns a new FreeFormElement

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a family document, nor a document editing an in-place family.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

FreeFormElement Class


SetFaceOffset Method

[image]

Revit 2024 API
FreeFormElement..::..SetFaceOffset Method
FreeFormElement Class See Also Send Feedback
Offsets a planar face of the free form element a certain distance in the normal direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void SetFaceOffset(
    Face face,
    double offset
)
Visual Basic
Public Sub SetFaceOffset ( _
    face As Face, _
    offset As Double _
)
Visual C++
public:
void SetFaceOffset(
    Face^ face,
    double offset
)

Parameters

face
Type: Autodesk.Revit.DB..::..Face
The face to offset.
offset
Type: System..::..Double
The magnitude of the offset. A positive value offsets out of the input solid. A negative value offsets into the solid shape.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | face does not belong to the solid. -or- The face to be offset should be planar and satisfy constraints of its parent element.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FreeFormElement Class


UpdateSolidGeometry Method

[image]

Revit 2024 API
FreeFormElement..::..UpdateSolidGeometry Method
FreeFormElement Class See Also Send Feedback
Updates the geometry of the FreeForm element to the given shape preserving References to the existing geometry where possible (see remarks for rules).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public void UpdateSolidGeometry(
    Solid newGeometry
)
Visual Basic
Public Sub UpdateSolidGeometry ( _
    newGeometry As Solid _
)
Visual C++
public:
void UpdateSolidGeometry(
    Solid^ newGeometry
)

Parameters

newGeometry
Type: Autodesk.Revit.DB..::..Solid
The new geometry to set in the FreeForm element.

Remarks

Rules for preserving References:
  • First preserve faces as Reference when exclusively coincident with existing faces.
  • Then preserve faces as Reference if exclusively parallel to existing faces.
  • Then preserve faces as Reference if exclusive at small angle to the existing faces.
  • Any other faces are will not be preserved as a Reference.
Edges are preserved as References if and only if exclusively bound to faces that are also preserved as References.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

FreeFormElement Class


FreeFormElement Properties

[image] [image]

Revit 2024 API
FreeFormElement Properties
FreeFormElement Class See Also Send Feedback

The FreeFormElement type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Get and Set the Name property (Inherited from GenericForm.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Subcategory | The subcategory. (Inherited from GenericForm.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Visible | The visibility of the GenericForm. (Inherited from GenericForm.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FreeFormElement Class


Parameter Property

[image] [image]

Revit 2024 API
FreeFormElement..::..Parameter Property
FreeFormElement Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

FreeFormElement Class
FreeFormElement Members


GBXMLExportOptions Class

[image]

Revit 2024 API
GBXMLExportOptions Class
Members See Also Send Feedback
Green-Building XML Export options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public class GBXMLExportOptions : IDisposable
Visual Basic
Public Class GBXMLExportOptions _
    Implements IDisposable
Visual C++
public ref class GBXMLExportOptions : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..GBXMLExportOptions

See Also

GBXMLExportOptions Members


GBXMLExportOptions Members

[image] [image]

Revit 2024 API
GBXMLExportOptions Members
GBXMLExportOptions Class Constructors Methods Properties See Also Send Feedback

The GBXMLExportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | GBXMLExportOptions | Constructs a new instance of the options used to export a model in gbXML (green-building) format.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the GBXMLExportOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Encoding | The encoding options to go into the processing instruction for the exported gbXML file.
Public property | ExportAnalyticalSystems | Indicates if the gbXML should contain analytical system elements (e.g., Water Loop, Air System, and Zone Equipment).
Public property | ExportEnergyModelType | The energy model type from which gbXML will be exported.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

GBXMLExportOptions Class


GBXMLExportOptions Constructor

[image]

Revit 2024 API
GBXMLExportOptions Constructor
GBXMLExportOptions Class See Also Send Feedback
Constructs a new instance of the options used to export a model in gbXML (green-building) format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public GBXMLExportOptions()
Visual Basic
Public Sub New
Visual C++
public:
GBXMLExportOptions()

See Also

GBXMLExportOptions Class


GBXMLExportOptions Methods

[image] [image]

Revit 2024 API
GBXMLExportOptions Methods
GBXMLExportOptions Class See Also Send Feedback

The GBXMLExportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

GBXMLExportOptions Class


Dispose Method

[image]

Revit 2024 API
GBXMLExportOptions..::..Dispose Method
GBXMLExportOptions Class See Also Send Feedback
Releases all resources used by the GBXMLExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

GBXMLExportOptions Class


GBXMLExportOptions Properties

[image] [image]

Revit 2024 API
GBXMLExportOptions Properties
GBXMLExportOptions Class See Also Send Feedback

The GBXMLExportOptions type exposes the following members.

Properties

 | Name | Description
Public property | Encoding | The encoding options to go into the processing instruction for the exported gbXML file.
Public property | ExportAnalyticalSystems | Indicates if the gbXML should contain analytical system elements (e.g., Water Loop, Air System, and Zone Equipment).
Public property | ExportEnergyModelType | The energy model type from which gbXML will be exported.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

GBXMLExportOptions Class


Encoding Property

[image]

Revit 2024 API
GBXMLExportOptions..::..Encoding Property
GBXMLExportOptions Class See Also Send Feedback
The encoding options to go into the processing instruction for the exported gbXML file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public string Encoding { get; }
Visual Basic
Public ReadOnly Property Encoding As String
    Get
Visual C++
public:
property String^ Encoding {
    String^ get ();
}

See Also

GBXMLExportOptions Class


IsValidObject Property

[image]

Revit 2024 API
GBXMLExportOptions..::..IsValidObject Property
GBXMLExportOptions Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

GBXMLExportOptions Class


GBXMLImportOptions Class

[image]

Revit 2024 API
GBXMLImportOptions Class
Members See Also Send Feedback
Import options for Green-Building XML format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class GBXMLImportOptions
Visual Basic
Public Class GBXMLImportOptions
Visual C++
public ref class GBXMLImportOptions

Remarks

Not used currently. Reserved for future use.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..GBXMLImportOptions

See Also

GBXMLImportOptions Members


GBXMLImportOptions Members

[image] [image]

Revit 2024 API
GBXMLImportOptions Members
GBXMLImportOptions Class Constructors Methods See Also Send Feedback

The GBXMLImportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | GBXMLImportOptions | Default constructor. Sets all options to their default values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

GBXMLImportOptions Class


GBXMLImportOptions Constructor

[image]

Revit 2024 API
GBXMLImportOptions Constructor
GBXMLImportOptions Class See Also Send Feedback
Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public GBXMLImportOptions()
Visual Basic
Public Sub New
Visual C++
public:
GBXMLImportOptions()

See Also

GBXMLImportOptions Class


GBXMLImportOptions Methods

[image] [image]

Revit 2024 API
GBXMLImportOptions Methods
GBXMLImportOptions Class See Also Send Feedback

The GBXMLImportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

GBXMLImportOptions Class


GenericForm Members

[image] [image]

Revit 2024 API
GenericForm Members
GenericForm Class Methods Properties See Also Send Feedback

The GenericForm type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the generic form.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetVisibility | Sets the visibility for the generic form.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Get and Set the Name property (Overrides Element..::..Name.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Subcategory | The subcategory.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Visible | The visibility of the GenericForm.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

GenericForm Class


GenericForm Methods

[image] [image]

Revit 2024 API
GenericForm Methods
GenericForm Class See Also Send Feedback

The GenericForm type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the generic form.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetVisibility | Sets the visibility for the generic form.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

GenericForm Class


SetVisibility Method

[image]

Revit 2024 API
GenericForm..::..SetVisibility Method
GenericForm Class See Also Send Feedback
Sets the visibility for the generic form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetVisibility(
    FamilyElementVisibility visibility
)
Visual Basic
Public Sub SetVisibility ( _
    visibility As FamilyElementVisibility _
)
Visual C++
public:
void SetVisibility(
    FamilyElementVisibility^ visibility
)

Parameters

visibility
Type: Autodesk.Revit.DB..::..FamilyElementVisibility

Remarks

The visibility of the generic form geometry can be changed for different types of views and detail levels in the project.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when visibility is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when regeneration failed.

See Also

GenericForm Class


GenericForm Properties

[image] [image]

Revit 2024 API
GenericForm Properties
GenericForm Class See Also Send Feedback

The GenericForm type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Get and Set the Name property (Overrides Element..::..Name.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Subcategory | The subcategory.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Visible | The visibility of the GenericForm.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

GenericForm Class


IsSolid Property

[image]

Revit 2024 API
GenericForm..::..IsSolid Property
GenericForm Class See Also Send Feedback
Identifies if the GenericForm is a solid or a void element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsSolid { get; }
Visual Basic
Public ReadOnly Property IsSolid As Boolean
    Get
Visual C++
public:
property bool IsSolid {
    bool get ();
}

Field Value

True if the form is a solid, false if the solid is a void element.

See Also

GenericForm Class


Name Property

[image]

Revit 2024 API
GenericForm..::..Name Property
GenericForm Class See Also Send Feedback
Get and Set the Name property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public override string Name { set; }
Visual Basic
Public Overrides WriteOnly Property Name As String
    Set
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Remarks

The method set is override to forbid the user to change the Name. When the user tries to call the method set for GenericForm object, an InvalidOperationException will be thrown.

See Also

GenericForm Class


Parameter Property

[image] [image]

Revit 2024 API
GenericForm..::..Parameter Property
GenericForm Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

GenericForm Class
GenericForm Members


Subcategory Property

[image]

Revit 2024 API
GenericForm..::..Subcategory Property
GenericForm Class See Also Send Feedback
The subcategory.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Category Subcategory { get; set; }
Visual Basic
Public Property Subcategory As Category
    Get
    Set
Visual C++
public:
property Category^ Subcategory {
    Category^ get ();
    void set (Category^ value);
}

Remarks

The subcategory can be set to either the family category or one of its subcategories.

See Also

GenericForm Class


Visible Property

[image]

Revit 2024 API
GenericForm..::..Visible Property
GenericForm Class See Also Send Feedback
The visibility of the GenericForm.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool Visible { get; }
Visual Basic
Public ReadOnly Property Visible As Boolean
    Get
Visual C++
public:
property bool Visible {
    bool get ();
}

Field Value

True if the form is visible, false if it is hidden.

See Also

GenericForm Class


GenericImportOptions Members

[image] [image]

Revit 2024 API
GenericImportOptions Members
GenericImportOptions Class Methods Properties See Also Send Feedback

The GenericImportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | RefPoint | Reference point (in Revit) to which the image is going to be inserted.

See Also

GenericImportOptions Class


GenericImportOptions Methods

[image] [image]

Revit 2024 API
GenericImportOptions Methods
GenericImportOptions Class See Also Send Feedback

The GenericImportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

GenericImportOptions Class


GenericImportOptions Properties

[image] [image]

Revit 2024 API
GenericImportOptions Properties
GenericImportOptions Class See Also Send Feedback

The GenericImportOptions type exposes the following members.

Properties

 | Name | Description
Public property | RefPoint | Reference point (in Revit) to which the image is going to be inserted.

See Also

GenericImportOptions Class


RefPoint Property

[image]

Revit 2024 API
GenericImportOptions..::..RefPoint Property
GenericImportOptions Class See Also Send Feedback
Reference point (in Revit) to which the image is going to be inserted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ RefPoint { get; set; }
Visual Basic
Public Property RefPoint As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ RefPoint {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

If nullNothingnullptra null reference (Nothing in Visual Basic), the image will be inserted to the Revit's origin.

See Also

GenericImportOptions Class


GeomCombination Class

[image]

Revit 2024 API
GeomCombination Class
Members See Also Send Feedback
An element created by Join and Cut operations applied to combinable elements in an Autodesk Revit family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class GeomCombination : CombinableElement
Visual Basic
Public Class GeomCombination _
    Inherits CombinableElement
Visual C++
public ref class GeomCombination : public CombinableElement

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..CombinableElement
Autodesk.Revit.DB..::..GeomCombination

See Also

GeomCombination Members


GeomCombination Members

[image] [image]

Revit 2024 API
GeomCombination Members
GeomCombination Class Methods Properties See Also Send Feedback

The GeomCombination type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AllMembers | All elements that are joined in this geometry combination.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

GeomCombination Class


GeomCombination Properties

[image] [image]

Revit 2024 API
GeomCombination Properties
GeomCombination Class See Also Send Feedback

The GeomCombination type exposes the following members.

Properties

 | Name | Description
Public property | AllMembers | All elements that are joined in this geometry combination.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

GeomCombination Class


Parameter Property

[image] [image]

Revit 2024 API
GeomCombination..::..Parameter Property
GeomCombination Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

GeomCombination Class
GeomCombination Members


GeomCombinationSet Class

[image]

Revit 2024 API
GeomCombinationSet Class
Members See Also Send Feedback
A set that contains GeomCombination objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class GeomCombinationSet : APIObject,
    IEnumerable
Visual Basic
Public Class GeomCombinationSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class GeomCombinationSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeomCombinationSet

See Also

GeomCombinationSet Members


GeomCombinationSet Members

[image] [image]

Revit 2024 API
GeomCombinationSet Members
GeomCombinationSet Class Constructors Methods Properties See Also Send Feedback

The GeomCombinationSet type exposes the following members.

Constructors

 | Name | Description
Public method | GeomCombinationSet | Initializes a new instance of the GeomCombinationSet class

Methods

 | Name | Description
Public method | Clear | Removes every item GeomCombination the set, rendering it empty.
Public method | Contains | Tests for the existence of an GeomCombination within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified GeomCombination from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified element into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of GeomCombinations that are in the set.

See Also

GeomCombinationSet Class


GeomCombinationSet Constructor

[image]

Revit 2024 API
GeomCombinationSet Constructor
GeomCombinationSet Class See Also Send Feedback
Initializes a new instance of the GeomCombinationSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public GeomCombinationSet()
Visual Basic
Public Sub New
Visual C++
public:
GeomCombinationSet()

See Also

GeomCombinationSet Class


GeomCombinationSet Methods

[image] [image]

Revit 2024 API
GeomCombinationSet Methods
GeomCombinationSet Class See Also Send Feedback

The GeomCombinationSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every item GeomCombination the set, rendering it empty.
Public method | Contains | Tests for the existence of an GeomCombination within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified GeomCombination from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified element into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

GeomCombinationSet Class


Clear Method

[image]

Revit 2024 API
GeomCombinationSet..::..Clear Method
GeomCombinationSet Class See Also Send Feedback
Removes every item GeomCombination the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

GeomCombinationSet Class


Contains Method

[image]

Revit 2024 API
GeomCombinationSet..::..Contains Method
GeomCombinationSet Class See Also Send Feedback
Tests for the existence of an GeomCombination within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool Contains(
    GeomCombination item
)
Visual Basic
Public Overridable Function Contains ( _
    item As GeomCombination _
) As Boolean
Visual C++
public:
virtual bool Contains(
    GeomCombination^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..GeomCombination
The element to be searched for.

Return Value

The Contains method returns True if the GeomCombination is within the set, otherwise False.

See Also

GeomCombinationSet Class


GetEnumerator Method

[image]

Revit 2024 API
GeomCombinationSet..::..GetEnumerator Method
GeomCombinationSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

GeomCombinationSet Class


Insert Method

[image]

Revit 2024 API
GeomCombinationSet..::..Insert Method
GeomCombinationSet Class See Also Send Feedback
Insert the specified element into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool Insert(
    GeomCombination item
)
Visual Basic
Public Overridable Function Insert ( _
    item As GeomCombination _
) As Boolean
Visual C++
public:
virtual bool Insert(
    GeomCombination^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..GeomCombination
The GeomCombination to be inserted into the set.

Return Value

Returns whether the GeomCombination was inserted into the set.

See Also

GeomCombinationSet Class


GeomCombinationSet Properties

[image] [image]

Revit 2024 API
GeomCombinationSet Properties
GeomCombinationSet Class See Also Send Feedback

The GeomCombinationSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of GeomCombinations that are in the set.

See Also

GeomCombinationSet Class


IsEmpty Property

[image]

Revit 2024 API
GeomCombinationSet..::..IsEmpty Property
GeomCombinationSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

GeomCombinationSet Class


Size Property

[image]

Revit 2024 API
GeomCombinationSet..::..Size Property
GeomCombinationSet Class See Also Send Feedback
Returns the number of GeomCombinations that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

GeomCombinationSet Class


GeomCombinationSetIterator Class

[image]

Revit 2024 API
GeomCombinationSetIterator Class
Members See Also Send Feedback
An iterator to a GeomCombination set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public abstract class GeomCombinationSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class GeomCombinationSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class GeomCombinationSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeomCombinationSetIterator

See Also

GeomCombinationSetIterator Members


GeomCombinationSetIterator Members

[image] [image]

Revit 2024 API
GeomCombinationSetIterator Members
GeomCombinationSetIterator Class Constructors Methods Properties See Also Send Feedback

The GeomCombinationSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | GeomCombinationSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GeomCombinationSetIterator Class


GeomCombinationSetIterator Constructor

[image]

Revit 2024 API
GeomCombinationSetIterator Constructor
GeomCombinationSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public GeomCombinationSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
GeomCombinationSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

GeomCombinationSetIterator Class


MoveNext Method

[image]

Revit 2024 API
GeomCombinationSetIterator..::..MoveNext Method
GeomCombinationSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

GeomCombinationSetIterator Class


Reset Method

[image]

Revit 2024 API
GeomCombinationSetIterator..::..Reset Method
GeomCombinationSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

GeomCombinationSetIterator Class


GeomCombinationSetIterator Properties

[image] [image]

Revit 2024 API
GeomCombinationSetIterator Properties
GeomCombinationSetIterator Class See Also Send Feedback

The GeomCombinationSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GeomCombinationSetIterator Class


Current Property

[image]

Revit 2024 API
GeomCombinationSetIterator..::..Current Property
GeomCombinationSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

GeomCombinationSetIterator Class


GeometryCreationUtilities Members

[image] [image]

Revit 2024 API
GeometryCreationUtilities Members
GeometryCreationUtilities Class Methods See Also Send Feedback

The GeometryCreationUtilities type exposes the following members.

Methods

Name | Description
CreateBlendGeometry(CurveLoop, CurveLoop, ICollection<(Of <<'(VertexPair>)>>)) | Creates a solid by blending two closed curve loops lying in non-coincident planes.
CreateBlendGeometry(CurveLoop, CurveLoop, ICollection<(Of <<'(VertexPair>)>>), SolidOptions) | Creates a solid by blending two closed curve loops lying in non-coincident planes.
CreateExtrusionGeometry(IList<(Of <<'(CurveLoop>)>>), XYZ, Double) | Creates a solid by linearly extruding one or more closed coplanar curve loops.
CreateExtrusionGeometry(IList<(Of <<'(CurveLoop>)>>), XYZ, Double, SolidOptions) | Creates a solid by linearly extruding one or more closed coplanar curve loops.
CreateFixedReferenceSweptGeometry(CurveLoop, Int32, Double, IList<(Of <<'(CurveLoop>)>>), XYZ) | Creates a solid by sweeping one or more closed coplanar curve loops along a path while keeping the profile plane oriented so that a line in the plane that is initially perpendicular to a given fixed direction remains perpendicular as the profile is swept along the path.
CreateFixedReferenceSweptGeometry(CurveLoop, Int32, Double, IList<(Of <<'(CurveLoop>)>>), XYZ, SolidOptions) | Creates a solid by sweeping one or more closed coplanar curve loops along a path while keeping the profile plane oriented so that a line in the plane that is initially perpendicular to a given fixed direction remains perpendicular as the profile is swept along the path.
CreateLoftGeometry | Creates a solid or open shell geometry by lofting between a sequence of curve loops.
CreateRevolvedGeometry(Frame, IList<(Of <<'(CurveLoop>)>>), Double, Double) | Creates a solid of revolution by revolving a set of closed curve loops around an axis by a specified angle.
CreateRevolvedGeometry(Frame, IList<(Of <<'(CurveLoop>)>>), Double, Double, SolidOptions) | Creates a solid of revolution by revolving a set of closed curve loops around an axis by a specified angle.
CreateSweptBlendGeometry(Curve, IList<(Of <<'(Double>)>>), IList<(Of <<'(CurveLoop>)>>), IList<(Of <<'(ICollection<(Of <<'(VertexPair>)>>)>)>>)) | Creates a solid by simultaneously sweeping and blending two or more closed planar curve loops along a single curve.
CreateSweptBlendGeometry(Curve, IList<(Of <<'(Double>)>>), IList<(Of <<'(CurveLoop>)>>), IList<(Of <<'(ICollection<(Of <<'(VertexPair>)>>)>)>>), SolidOptions) | Creates a solid by simultaneously sweeping and blending two or more closed planar curve loops along a single curve.
CreateSweptGeometry(CurveLoop, Int32, Double, IList<(Of <<'(CurveLoop>)>>)) | Creates a solid by sweeping one or more closed coplanar curve loops along a path.
CreateSweptGeometry(CurveLoop, Int32, Double, IList<(Of <<'(CurveLoop>)>>), SolidOptions) | Creates a solid by sweeping one or more closed coplanar curve loops along a path.

See Also

GeometryCreationUtilities Class


GeometryCreationUtilities Methods

[image] [image]

Revit 2024 API
GeometryCreationUtilities Methods
GeometryCreationUtilities Class See Also Send Feedback

The GeometryCreationUtilities type exposes the following members.

Methods

Name | Description
CreateBlendGeometry(CurveLoop, CurveLoop, ICollection<(Of <<'(VertexPair>)>>)) | Creates a solid by blending two closed curve loops lying in non-coincident planes.
CreateBlendGeometry(CurveLoop, CurveLoop, ICollection<(Of <<'(VertexPair>)>>), SolidOptions) | Creates a solid by blending two closed curve loops lying in non-coincident planes.
CreateExtrusionGeometry(IList<(Of <<'(CurveLoop>)>>), XYZ, Double) | Creates a solid by linearly extruding one or more closed coplanar curve loops.
CreateExtrusionGeometry(IList<(Of <<'(CurveLoop>)>>), XYZ, Double, SolidOptions) | Creates a solid by linearly extruding one or more closed coplanar curve loops.
CreateFixedReferenceSweptGeometry(CurveLoop, Int32, Double, IList<(Of <<'(CurveLoop>)>>), XYZ) | Creates a solid by sweeping one or more closed coplanar curve loops along a path while keeping the profile plane oriented so that a line in the plane that is initially perpendicular to a given fixed direction remains perpendicular as the profile is swept along the path.
CreateFixedReferenceSweptGeometry(CurveLoop, Int32, Double, IList<(Of <<'(CurveLoop>)>>), XYZ, SolidOptions) | Creates a solid by sweeping one or more closed coplanar curve loops along a path while keeping the profile plane oriented so that a line in the plane that is initially perpendicular to a given fixed direction remains perpendicular as the profile is swept along the path.
CreateLoftGeometry | Creates a solid or open shell geometry by lofting between a sequence of curve loops.
CreateRevolvedGeometry(Frame, IList<(Of <<'(CurveLoop>)>>), Double, Double) | Creates a solid of revolution by revolving a set of closed curve loops around an axis by a specified angle.
CreateRevolvedGeometry(Frame, IList<(Of <<'(CurveLoop>)>>), Double, Double, SolidOptions) | Creates a solid of revolution by revolving a set of closed curve loops around an axis by a specified angle.
CreateSweptBlendGeometry(Curve, IList<(Of <<'(Double>)>>), IList<(Of <<'(CurveLoop>)>>), IList<(Of <<'(ICollection<(Of <<'(VertexPair>)>>)>)>>)) | Creates a solid by simultaneously sweeping and blending two or more closed planar curve loops along a single curve.
CreateSweptBlendGeometry(Curve, IList<(Of <<'(Double>)>>), IList<(Of <<'(CurveLoop>)>>), IList<(Of <<'(ICollection<(Of <<'(VertexPair>)>>)>)>>), SolidOptions) | Creates a solid by simultaneously sweeping and blending two or more closed planar curve loops along a single curve.
CreateSweptGeometry(CurveLoop, Int32, Double, IList<(Of <<'(CurveLoop>)>>)) | Creates a solid by sweeping one or more closed coplanar curve loops along a path.
CreateSweptGeometry(CurveLoop, Int32, Double, IList<(Of <<'(CurveLoop>)>>), SolidOptions) | Creates a solid by sweeping one or more closed coplanar curve loops along a path.

See Also

GeometryCreationUtilities Class


CreateBlendGeometry Method (CurveLoop, CurveLoop, ICollection(VertexPair))

[image]

Revit 2024 API
GeometryCreationUtilities..::..CreateBlendGeometry Method (CurveLoop, CurveLoop, ICollection<(Of <(<'VertexPair>)>)>)
GeometryCreationUtilities Class See Also Send Feedback
Creates a solid by blending two closed curve loops lying in non-coincident planes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static Solid CreateBlendGeometry(
    CurveLoop firstLoop,
    CurveLoop secondLoop,
    ICollection<VertexPair> vertexPairs
)
Visual Basic
Public Shared Function CreateBlendGeometry ( _
    firstLoop As CurveLoop, _
    secondLoop As CurveLoop, _
    vertexPairs As ICollection(Of VertexPair) _
) As Solid
Visual C++
public:
static Solid^ CreateBlendGeometry(
    CurveLoop^ firstLoop,
    CurveLoop^ secondLoop,
    ICollection<VertexPair^>^ vertexPairs
)

Parameters

firstLoop
Type: Autodesk.Revit.DB..::..CurveLoop
The first curve loop. The loop must be a closed planar loop without intersections or degeneracies. No orientation conditions are imposed. The loop may not contain just one closed curve - split such a loop into two or more curves beforehand.
secondLoop
Type: Autodesk.Revit.DB..::..CurveLoop
The second curve loop, satisfying the same conditions as the first loop. The planes of the first and second loops must not be coincident, but they need not be parallel.
vertexPairs
Type: System.Collections.Generic..::..ICollection<(Of <(<' VertexPair >)>)>
This input specifies how the two profile loops should be connected. If null, the function chooses vertex connections that will result in a geometrically reasonable blend.

Return Value

The requested solid.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The first profile CurveLoop do not satisfy the input requirements. -or- The second profile CurveLoop do not satisfy the input requirements.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

GeometryCreationUtilities Class
CreateBlendGeometry Overload


CreateBlendGeometry Method (CurveLoop, CurveLoop, ICollection(VertexPair), SolidOptions)

[image]

Revit 2024 API
GeometryCreationUtilities..::..CreateBlendGeometry Method (CurveLoop, CurveLoop, ICollection<(Of <(<'VertexPair>)>)>, SolidOptions)
GeometryCreationUtilities Class See Also Send Feedback
Creates a solid by blending two closed curve loops lying in non-coincident planes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static Solid CreateBlendGeometry(
    CurveLoop firstLoop,
    CurveLoop secondLoop,
    ICollection<VertexPair> vertexPairs,
    SolidOptions solidOptions
)
Visual Basic
Public Shared Function CreateBlendGeometry ( _
    firstLoop As CurveLoop, _
    secondLoop As CurveLoop, _
    vertexPairs As ICollection(Of VertexPair), _
    solidOptions As SolidOptions _
) As Solid
Visual C++
public:
static Solid^ CreateBlendGeometry(
    CurveLoop^ firstLoop,
    CurveLoop^ secondLoop,
    ICollection<VertexPair^>^ vertexPairs,
    SolidOptions^ solidOptions
)

Parameters

firstLoop
Type: Autodesk.Revit.DB..::..CurveLoop
The first curve loop. The loop must be a closed planar loop without intersections or degeneracies. No orientation conditions are imposed. The loop must be a closed planar loop without intersections or degeneracies. No orientation conditions are imposed. The loop may not contain just one closed curve - split such a loop into two or more curves beforehand.
secondLoop
Type: Autodesk.Revit.DB..::..CurveLoop
The second curve loop, satisfying the same conditions as the first loop. The planes of the first and second loops must not be coincident, but they need not be parallel.
vertexPairs
Type: System.Collections.Generic..::..ICollection<(Of <(<' VertexPair >)>)>
This input specifies how the two profile loops should be connected. If null, the function chooses vertex connections that will result in a geometrically reasonable blend.
solidOptions
Type: Autodesk.Revit.DB..::..SolidOptions
The optional information to control the properties of the Solid.

Return Value

The requested solid.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The first profile CurveLoop do not satisfy the input requirements. -or- The second profile CurveLoop do not satisfy the input requirements.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

GeometryCreationUtilities Class
CreateBlendGeometry Overload


CreateExtrusionGeometry Method

[image] [image]

Revit 2024 API
GeometryCreationUtilities..::..CreateExtrusionGeometry Method
GeometryCreationUtilities Class See Also Send Feedback

Overload List

Name | Description
CreateExtrusionGeometry(IList<(Of <<'(CurveLoop>)>>), XYZ, Double) | Creates a solid by linearly extruding one or more closed coplanar curve loops.
CreateExtrusionGeometry(IList<(Of <<'(CurveLoop>)>>), XYZ, Double, SolidOptions) | Creates a solid by linearly extruding one or more closed coplanar curve loops.

See Also

GeometryCreationUtilities Class
GeometryCreationUtilities Members


CreateExtrusionGeometry Method (IList(CurveLoop), XYZ, Double)

[image]

Revit 2024 API
GeometryCreationUtilities..::..CreateExtrusionGeometry Method (IList<(Of <(<'CurveLoop>)>)>, XYZ, Double)
GeometryCreationUtilities Class See Also Send Feedback
Creates a solid by linearly extruding one or more closed coplanar curve loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static Solid CreateExtrusionGeometry(
    IList<CurveLoop> profileLoops,
    XYZ extrusionDir,
    double extrusionDist
)
Visual Basic
Public Shared Function CreateExtrusionGeometry ( _
    profileLoops As IList(Of CurveLoop), _
    extrusionDir As XYZ, _
    extrusionDist As Double _
) As Solid
Visual C++
public:
static Solid^ CreateExtrusionGeometry(
    IList<CurveLoop^>^ profileLoops,
    XYZ^ extrusionDir,
    double extrusionDist
)

Parameters

profileLoops
Type: System.Collections.Generic..::..IList<(Of <(<' CurveLoop >)>)>
The profile loops to be extruded. The loops must be closed, coplanar, and without intersections, self-intersections, or degeneracies. No loop may contain just one closed curve - split such loops into two or more curves beforehand. No conditions are imposed on the orientations of the loops: this function will use copies of the input loops that have been oriented as necessary to conform to Revit's orientation conventions.
extrusionDir
Type: Autodesk.Revit.DB..::..XYZ
The direction in which to extrude the profile loops. This vector must be non-zero and transverse (i.e., not parallel) to the plane of the profile loops. Its length is irrelevant; only its direction is used.
extrusionDist
Type: System..::..Double
The positive distance by which the loops are to be extruded in the direction of the input extrusionDir.

Return Value

The requested solid.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The profile CurveLoops do not satisfy the input requirements. -or- The Input extrusionDir must be a non-zero vector. The normal of the loop plane should not be perpendicular to the given extrusionDir. -or- The input argument extrusionDist must be positive.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

GeometryCreationUtilities Class
CreateExtrusionGeometry Overload


CreateFixedReferenceSweptGeometry Method (CurveLoop, Int32, Double, IList(CurveLoop), XYZ)

[image]

Revit 2024 API
GeometryCreationUtilities..::..CreateFixedReferenceSweptGeometry Method (CurveLoop, Int32, Double, IList<(Of <(<'CurveLoop>)>)>, XYZ)
GeometryCreationUtilities Class See Also Send Feedback
Creates a solid by sweeping one or more closed coplanar curve loops along a path while keeping the profile plane oriented so that a line in the plane that is initially perpendicular to a given fixed direction remains perpendicular as the profile is swept along the path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public static Solid CreateFixedReferenceSweptGeometry(
    CurveLoop sweepPath,
    int pathAttachmentCrvIdx,
    double pathAttachmentParam,
    IList<CurveLoop> profileLoops,
    XYZ fixedReferenceDirection
)
Visual Basic
Public Shared Function CreateFixedReferenceSweptGeometry ( _
    sweepPath As CurveLoop, _
    pathAttachmentCrvIdx As Integer, _
    pathAttachmentParam As Double, _
    profileLoops As IList(Of CurveLoop), _
    fixedReferenceDirection As XYZ _
) As Solid
Visual C++
public:
static Solid^ CreateFixedReferenceSweptGeometry(
    CurveLoop^ sweepPath,
    int pathAttachmentCrvIdx,
    double pathAttachmentParam,
    IList<CurveLoop^>^ profileLoops,
    XYZ^ fixedReferenceDirection
)

Parameters

sweepPath
Type: Autodesk.Revit.DB..::..CurveLoop
The sweep path, consisting of a set of contiguous curves. The path may be open or closed, but should not otherwise have any self-intersections. The path may be planar or non-planar. With the exception of path curves that lie in a plane parallel to %fixedReferenceDirection%, the curve's tangent should be nowhere parallel to %fixedReferenceDirection%. If the sweep path has corners, the solid segments that meet at a corner may not meet smoothly.
pathAttachmentCrvIdx
Type: System..::..Int32
The index of the curve in the sweep path where the profile loops are situated. Indexing starts at 0. Together with pathAttachmentParam, this specifies the profile's attachment point.
pathAttachmentParam
Type: System..::..Double
Parameter of the path curve specified by pathAttachmentCrvIdx. The profile curves must lie in the plane orthogonal to the path at this attachment point.
profileLoops
Type: System.Collections.Generic..::..IList<(Of <(<' CurveLoop >)>)>
The curve loops defining the planar domain to be swept along the path. No conditions are imposed on the orientations of the loops; this function will use copies of the input loops that have been oriented as necessary to conform to Revit's orientation conventions. Restrictions:
  • The loops must lie in the plane orthogonal to the path at the attachment point as defined above.
  • The curve loop(s) must be closed and should define a single planar domain (one outer loop and, optionally, one or more inner loops).
  • The curve loops must be without intersections, self-intersections, or degeneracies.
  • No loop may contain just one closed curve - split such loops into two or more curves beforehand.
fixedReferenceDirection
Type: Autodesk.Revit.DB..::..XYZ
A unit vector specifying the fixed direction used to control how the profile plane is swept along the path; see the description and remarks above.

Return Value

The requested solid.

Remarks

The profile loops must lie in a plane orthogonal to the sweep path at some attachment point along the path. An example where this method is useful is in constructing railings. If the fixed direction is the upward vertical, a line in the profile plane that is initially horizontal will remain horizontal as the profile is swept along the path. This property can be used to ensure that the top of the railing remains horizontal all along the railing. The STEP ISO 10303-42 and IFC standards define a "Fixed Reference Sweep" similar to this sweep method, though there are some minor technical differences:
  • The STEP ISO reference describes a specific parameterization of the swept surface, whereas we do not guarantee any particular parameterization (partly because we simplify the surface when possible).
  • Neither reference mentions what should be done if the sweep pathâ€™s tangent is tangent to the reference direction at some point(s) or along the entire directrix.
  • Both references impose unnecessary conditions, and they're inconsistent: STEP says "the swept_curve is required to be a curve lying in the plane z = 0" while IFC says "The SweptArea shall lie in the plane z = 0" (SweptArea is the profile being swept).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input argument sweepPath should at least contain one curve. -or- The input argument pathAttachmentCrvIdx is not valid. -or- The profile CurveLoops do not satisfy the input requirements.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | fixedReferenceDirection is not length 1.0.

See Also

GeometryCreationUtilities Class
CreateFixedReferenceSweptGeometry Overload


CreateFixedReferenceSweptGeometry Method (CurveLoop, Int32, Double, IList(CurveLoop), XYZ, SolidOptions)

[image]

Revit 2024 API
GeometryCreationUtilities..::..CreateFixedReferenceSweptGeometry Method (CurveLoop, Int32, Double, IList<(Of <(<'CurveLoop>)>)>, XYZ, SolidOptions)
GeometryCreationUtilities Class See Also Send Feedback
Creates a solid by sweeping one or more closed coplanar curve loops along a path while keeping the profile plane oriented so that a line in the plane that is initially perpendicular to a given fixed direction remains perpendicular as the profile is swept along the path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public static Solid CreateFixedReferenceSweptGeometry(
    CurveLoop sweepPath,
    int pathAttachmentCrvIdx,
    double pathAttachmentParam,
    IList<CurveLoop> profileLoops,
    XYZ fixedReferenceDirection,
    SolidOptions solidOptions
)
Visual Basic
Public Shared Function CreateFixedReferenceSweptGeometry ( _
    sweepPath As CurveLoop, _
    pathAttachmentCrvIdx As Integer, _
    pathAttachmentParam As Double, _
    profileLoops As IList(Of CurveLoop), _
    fixedReferenceDirection As XYZ, _
    solidOptions As SolidOptions _
) As Solid
Visual C++
public:
static Solid^ CreateFixedReferenceSweptGeometry(
    CurveLoop^ sweepPath,
    int pathAttachmentCrvIdx,
    double pathAttachmentParam,
    IList<CurveLoop^>^ profileLoops,
    XYZ^ fixedReferenceDirection,
    SolidOptions^ solidOptions
)

Parameters

sweepPath
Type: Autodesk.Revit.DB..::..CurveLoop
The sweep path, consisting of a set of contiguous curves. The path may be open or closed, but should not otherwise have any self-intersections. The path may be planar or non-planar. With the exception of path curves that lie in a plane parallel to %fixedReferenceDirection%, the curve's tangent should be nowhere parallel to %fixedReferenceDirection%. If the sweep path has corners, the solid segments that meet at a corner may not meet smoothly.
pathAttachmentCrvIdx
Type: System..::..Int32
The index of the curve in the sweep path where the profile loops are situated. Indexing starts at 0. Together with pathAttachmentParam, this specifies the profile's attachment point.
pathAttachmentParam
Type: System..::..Double
Parameter of the path curve specified by pathAttachmentCrvIdx. The profile curves must lie in the plane orthogonal to the path at this attachment point.
profileLoops
Type: System.Collections.Generic..::..IList<(Of <(<' CurveLoop >)>)>
The curve loops defining the planar domain to be swept along the path. No conditions are imposed on the orientations of the loops; this function will use copies of the input loops that have been oriented as necessary to conform to Revit's orientation conventions. Restrictions:
  • The loops must lie in the plane orthogonal to the path at the attachment point as defined above.
  • The curve loop(s) must be closed and should define a single planar domain (one outer loop and, optionally, one or more inner loops).
  • The curve loops must be without intersections, self-intersections, or degeneracies.
  • No loop may contain just one closed curve - split such loops into two or more curves beforehand.
fixedReferenceDirection
Type: Autodesk.Revit.DB..::..XYZ
A unit vector specifying the fixed direction used to control how the profile plane is swept along the path; see the description and remarks above. The profile CurveLoops do not satisfy the input requirements.
solidOptions
Type: Autodesk.Revit.DB..::..SolidOptions
The optional information to control the properties of the Solid.

Return Value

The requested solid.

Remarks

The profile loops must lie in a plane orthogonal to the sweep path at some attachment point along the path. An example where this method is useful is in constructing railings. If the fixed direction is the upward vertical, a line in the profile plane that is initially horizontal will remain horizontal as the profile is swept along the path. This property can be used to ensure that the top of the railing remains horizontal all along the railing. The STEP ISO 10303-42 and IFC standards define a "Fixed Reference Sweep" similar to this sweep method, though there are some minor technical differences:
  • The STEP ISO reference describes a specific parameterization of the swept surface, whereas we do not guarantee any particular parameterization (partly because we simplify the surface when possible).
  • Neither reference mentions what should be done if the sweep pathâ€™s tangent is tangent to the reference direction at some point(s) or along the entire directrix.
  • Both references impose unnecessary conditions, and they're inconsistent: STEP says "the swept_curve is required to be a curve lying in the plane z = 0" while IFC says "The SweptArea shall lie in the plane z = 0" (SweptArea is the profile being swept).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input argument sweepPath should at least contain one curve. -or- The input argument pathAttachmentCrvIdx is not valid. -or-
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | fixedReferenceDirection is not length 1.0.

See Also

GeometryCreationUtilities Class
CreateFixedReferenceSweptGeometry Overload


CreateLoftGeometry Method

[image]

Revit 2024 API
GeometryCreationUtilities..::..CreateLoftGeometry Method
GeometryCreationUtilities Class See Also Send Feedback
Creates a solid or open shell geometry by lofting between a sequence of curve loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public static Solid CreateLoftGeometry(
    IList<CurveLoop> profileLoops,
    SolidOptions solidOptions
)
Visual Basic
Public Shared Function CreateLoftGeometry ( _
    profileLoops As IList(Of CurveLoop), _
    solidOptions As SolidOptions _
) As Solid
Visual C++
public:
static Solid^ CreateLoftGeometry(
    IList<CurveLoop^>^ profileLoops,
    SolidOptions^ solidOptions
)

Parameters

profileLoops
Type: System.Collections.Generic..::..IList<(Of <(<' CurveLoop >)>)>
The array of curve loops, where the order of the array determines the lofting sequence used.
solidOptions
Type: Autodesk.Revit.DB..::..SolidOptions
The optional information to control the properties of the solid or open shell.

Return Value

The requested solid or open shell.

Remarks

If all the curve loops are closed it will create a solid. No loop may contain just one closed curve - split such loops into two or more curves beforehand. If all the curve loops are open, then create an open shell. If there are both open and closed loops, only the first and/or last loop are allowed to be open, others (if they exist) must be closed. A solid will be created in this case. The surface of the solid or open shell will pass through these profiles blending smoothly between the profiles. Each profile loop must be free of intersections and degeneracies. No orientation conditions on the loops are imposed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The number of profile CurveLoops is less than 2.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

GeometryCreationUtilities Class


CreateRevolvedGeometry Method (Frame, IList(CurveLoop), Double, Double)

[image]

Revit 2024 API
GeometryCreationUtilities..::..CreateRevolvedGeometry Method (Frame, IList<(Of <(<'CurveLoop>)>)>, Double, Double)
GeometryCreationUtilities Class See Also Send Feedback
Creates a solid of revolution by revolving a set of closed curve loops around an axis by a specified angle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static Solid CreateRevolvedGeometry(
    Frame coordinateFrame,
    IList<CurveLoop> profileLoops,
    double startAngle,
    double endAngle
)
Visual Basic
Public Shared Function CreateRevolvedGeometry ( _
    coordinateFrame As Frame, _
    profileLoops As IList(Of CurveLoop), _
    startAngle As Double, _
    endAngle As Double _
) As Solid
Visual C++
public:
static Solid^ CreateRevolvedGeometry(
    Frame^ coordinateFrame,
    IList<CurveLoop^>^ profileLoops,
    double startAngle,
    double endAngle
)

Parameters

coordinateFrame
Type: Autodesk.Revit.DB..::..Frame
A right-handed orthonormal frame of vectors. The frame's z-vector is the axis of revolution. The start and end angle inputs refer to this frame.
profileLoops
Type: System.Collections.Generic..::..IList<(Of <(<' CurveLoop >)>)>
The profile loops to be revolved. No conditions are imposed on the orientations of the loops. This function will use copies of the input loops that have been oriented as necessary to conform to Revit's orientation conventions. Restrictions:
  • The loops must lie in the xz coordinate plane of the input coordinate frame.
  • The curve loop(s) must be closed and must define a single planar domain (one outer loop and, optionally, one or more inner loops).
  • The curve loops must be without intersections, self-intersections, or degeneracies.
  • The loops must lie on the "right" side of the z axis (where x >= 0).
  • No loop may contain just one closed curve - split such loops into two or more curves beforehand.
startAngle
Type: System..::..Double
The start angle for the revolution, in radians, measured counter-clockwise from the coordinate frame's x-axis as viewed looking down the frame's z-axis.
endAngle
Type: System..::..Double
The end angle for the revolution, using the same conventions as the start angle. The end angle may be less than (but not equal to) the start angle. The total angle of revolution, equal to the absolute value of (endAngle â€“ startAngle), must be at most 2*PI.

Return Value

The requested solid. Note that if less than a full revolution is used, planar end faces will be added as part of the solid.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input argument coordinateFrame should be a right-handed orthonormal frame of vectors. -or- The profile CurveLoops do not satisfy the input requirements. -or- The absolute value of %(endAngle â€“ startAngle)%, must be at most 2*PI.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

GeometryCreationUtilities Class
CreateRevolvedGeometry Overload


CreateRevolvedGeometry Method (Frame, IList(CurveLoop), Double, Double, SolidOptions)

[image]

Revit 2024 API
GeometryCreationUtilities..::..CreateRevolvedGeometry Method (Frame, IList<(Of <(<'CurveLoop>)>)>, Double, Double, SolidOptions)
GeometryCreationUtilities Class See Also Send Feedback
Creates a solid of revolution by revolving a set of closed curve loops around an axis by a specified angle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static Solid CreateRevolvedGeometry(
    Frame coordinateFrame,
    IList<CurveLoop> profileLoops,
    double startAngle,
    double endAngle,
    SolidOptions solidOptions
)
Visual Basic
Public Shared Function CreateRevolvedGeometry ( _
    coordinateFrame As Frame, _
    profileLoops As IList(Of CurveLoop), _
    startAngle As Double, _
    endAngle As Double, _
    solidOptions As SolidOptions _
) As Solid
Visual C++
public:
static Solid^ CreateRevolvedGeometry(
    Frame^ coordinateFrame,
    IList<CurveLoop^>^ profileLoops,
    double startAngle,
    double endAngle,
    SolidOptions^ solidOptions
)

Parameters

coordinateFrame
Type: Autodesk.Revit.DB..::..Frame
A right-handed orthonormal frame of vectors. The frame's z-vector is the axis of revolution. The start and end angle inputs refer to this frame.
profileLoops
Type: System.Collections.Generic..::..IList<(Of <(<' CurveLoop >)>)>
The profile loops to be revolved. No conditions are imposed on the orientations of the loops. This function will use copies of the input loops that have been oriented as necessary to conform to Revit's orientation conventions. Restrictions:
  • The loops must lie in the xz coordinate plane of the input coordinate frame.
  • The curve loop(s) must be closed and must define a single planar domain (one outer loop and, optionally, one or more inner loops).
  • The curve loops must be without intersections, self-intersections, or degeneracies.
  • The loops must lie on the "right" side of the z axis (where x >= 0).
  • No loop may contain just one closed curve - split such loops into two or more curves beforehand.
startAngle
Type: System..::..Double
The start angle for the revolution, in radians, measured counter-clockwise from the coordinate frame's x-axis as viewed looking down the frame's z-axis.
endAngle
Type: System..::..Double
The end angle for the revolution, using the same conventions as the start angle. The end angle may be less than (but not equal to) the start angle. The total angle of revolution, equal to the absolute value of (endAngle â€“ startAngle), must be at most 2*PI.
solidOptions
Type: Autodesk.Revit.DB..::..SolidOptions
The optional information to control the properties of the Solid.

Return Value

The requested solid. Note that if less than a full revolution is used, planar end faces will be added as part of the solid.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input argument coordinateFrame should be a right-handed orthonormal frame of vectors. -or- The profile CurveLoops do not satisfy the input requirements. -or- The absolute value of %(endAngle â€“ startAngle)%, must be at most 2*PI.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

GeometryCreationUtilities Class
CreateRevolvedGeometry Overload


CreateSweptBlendGeometry Method

[image] [image]

Revit 2024 API
GeometryCreationUtilities..::..CreateSweptBlendGeometry Method
GeometryCreationUtilities Class See Also Send Feedback

Overload List

Name | Description
CreateSweptBlendGeometry(Curve, IList<(Of <<'(Double>)>>), IList<(Of <<'(CurveLoop>)>>), IList<(Of <<'(ICollection<(Of <<'(VertexPair>)>>)>)>>)) | Creates a solid by simultaneously sweeping and blending two or more closed planar curve loops along a single curve.
CreateSweptBlendGeometry(Curve, IList<(Of <<'(Double>)>>), IList<(Of <<'(CurveLoop>)>>), IList<(Of <<'(ICollection<(Of <<'(VertexPair>)>>)>)>>), SolidOptions) | Creates a solid by simultaneously sweeping and blending two or more closed planar curve loops along a single curve.

See Also

GeometryCreationUtilities Class
GeometryCreationUtilities Members


CreateSweptBlendGeometry Method (Curve, IList(Double), IList(CurveLoop), IList(ICollection(VertexPair)))

[image]

Revit 2024 API
GeometryCreationUtilities..::..CreateSweptBlendGeometry Method (Curve, IList<(Of <(<'Double>)>)>, IList<(Of <(<'CurveLoop>)>)>, IList<(Of <(<'ICollection<(Of <(<'VertexPair>)>)>>)>)>)
GeometryCreationUtilities Class See Also Send Feedback
Creates a solid by simultaneously sweeping and blending two or more closed planar curve loops along a single curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static Solid CreateSweptBlendGeometry(
    Curve pathCurve,
    IList<double> pathParams,
    IList<CurveLoop> profileLoops,
    IList<ICollection<VertexPair>> vertexPairs
)
Visual Basic
Public Shared Function CreateSweptBlendGeometry ( _
    pathCurve As Curve, _
    pathParams As IList(Of Double), _
    profileLoops As IList(Of CurveLoop), _
    vertexPairs As IList(Of ICollection(Of VertexPair)) _
) As Solid
Visual C++
public:
static Solid^ CreateSweptBlendGeometry(
    Curve^ pathCurve,
    IList<double>^ pathParams,
    IList<CurveLoop^>^ profileLoops,
    IList<ICollection<VertexPair^>^>^ vertexPairs
)

Parameters

pathCurve
Type: Autodesk.Revit.DB..::..Curve
The sweep path, consisting of a single bounded, open curve.
pathParams
Type: System.Collections.Generic..::..IList<(Of <(<'Double>)>)>
An increasing sequence of parameters along the path curve (lying within the curve's bounds). These parameters specify the locations of the planes orthogonal to the path that contain the profile loops. This array must have the same size as the input array "profileLoops".
profileLoops
Type: System.Collections.Generic..::..IList<(Of <(<' CurveLoop >)>)>
Closed, planar curve loops arrayed along the path. No loop may contain just one closed curve - split such loops into two or more curves beforehand. The solid will have these profiles as cross-sections at the points specified by the input pathParams. The solid will blend smoothly between the profiles. This array must have the same size as the input array "pathParams", and each profile loop must lie in the plane orthogonal to the path at the point specified by the corresponding entry in the input array "pathParams". Each profile loop must define a single planar domain and must be free of intersections and degeneracies. No orientation conditions on the loops are imposed.
vertexPairs
Type: System.Collections.Generic..::..IList<(Of <(<'ICollection<(Of <(<' VertexPair >)>)>>)>)>
This input specifies how adjacent profile loops should be connected. It must contain one less element than the "profileLoops" input, and entry vertexPairs[idx] specifies how profileLoops[idx] and profileLoops[idx+1] should be connected (indexing starts at 0).

Return Value

The requested solid.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input pathCurve is a helical curve and is not supported for this operation. -or- The input argument pathCurve should be bounded. The input argument pathCurve should be non-degenerate. -or- The input argument pathParams should be an increasing array. -or- The profile CurveLoops do not satisfy the input requirements.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

GeometryCreationUtilities Class
CreateSweptBlendGeometry Overload


CreateSweptBlendGeometry Method (Curve, IList(Double), IList(CurveLoop), IList(ICollection(VertexPair)), SolidOptions)

[image]

Revit 2024 API
GeometryCreationUtilities..::..CreateSweptBlendGeometry Method (Curve, IList<(Of <(<'Double>)>)>, IList<(Of <(<'CurveLoop>)>)>, IList<(Of <(<'ICollection<(Of <(<'VertexPair>)>)>>)>)>, SolidOptions)
GeometryCreationUtilities Class See Also Send Feedback
Creates a solid by simultaneously sweeping and blending two or more closed planar curve loops along a single curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static Solid CreateSweptBlendGeometry(
    Curve pathCurve,
    IList<double> pathParams,
    IList<CurveLoop> profileLoops,
    IList<ICollection<VertexPair>> vertexPairs,
    SolidOptions solidOptions
)
Visual Basic
Public Shared Function CreateSweptBlendGeometry ( _
    pathCurve As Curve, _
    pathParams As IList(Of Double), _
    profileLoops As IList(Of CurveLoop), _
    vertexPairs As IList(Of ICollection(Of VertexPair)), _
    solidOptions As SolidOptions _
) As Solid
Visual C++
public:
static Solid^ CreateSweptBlendGeometry(
    Curve^ pathCurve,
    IList<double>^ pathParams,
    IList<CurveLoop^>^ profileLoops,
    IList<ICollection<VertexPair^>^>^ vertexPairs,
    SolidOptions^ solidOptions
)

Parameters

pathCurve
Type: Autodesk.Revit.DB..::..Curve
The sweep path, consisting of a single bounded, open curve.
pathParams
Type: System.Collections.Generic..::..IList<(Of <(<'Double>)>)>
An increasing sequence of parameters along the path curve (lying within the curve's bounds). These parameters specify the locations of the planes orthogonal to the path that contain the profile loops. This array must have the same size as the input array "profileLoops".
profileLoops
Type: System.Collections.Generic..::..IList<(Of <(<' CurveLoop >)>)>
Closed, planar curve loops arrayed along the path. No loop may contain just one closed curve - split such loops into two or more curves beforehand. The solid will have these profiles as cross-sections at the points specified by the input pathParams. The solid will blend smoothly between the profiles. This array must have the same size as the input array "pathParams", and each profile loop must lie in the plane orthogonal to the path at the point specified by the corresponding entry in the input array "pathParams". Each profile loop must define a single planar domain and must be free of intersections and degeneracies. No orientation conditions on the loops are imposed.
vertexPairs
Type: System.Collections.Generic..::..IList<(Of <(<'ICollection<(Of <(<' VertexPair >)>)>>)>)>
This input specifies how adjacent profile loops should be connected. It must contain one less element than the "profileLoops" input, and entry vertexPairs[idx] specifies how profileLoops[idx] and profileLoops[idx+1] should be connected (indexing starts at 0).
solidOptions
Type: Autodesk.Revit.DB..::..SolidOptions
The optional information to control the properties of the Solid.

Return Value

The requested solid.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input pathCurve is a helical curve and is not supported for this operation. -or- The input argument pathCurve should be bounded. The input argument pathCurve should be non-degenerate. -or- The input argument pathParams should be an increasing array. -or- The profile CurveLoops do not satisfy the input requirements.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

GeometryCreationUtilities Class
CreateSweptBlendGeometry Overload


CreateSweptGeometry Method

[image] [image]

Revit 2024 API
GeometryCreationUtilities..::..CreateSweptGeometry Method
GeometryCreationUtilities Class See Also Send Feedback

Overload List

Name | Description
CreateSweptGeometry(CurveLoop, Int32, Double, IList<(Of <<'(CurveLoop>)>>)) | Creates a solid by sweeping one or more closed coplanar curve loops along a path.
CreateSweptGeometry(CurveLoop, Int32, Double, IList<(Of <<'(CurveLoop>)>>), SolidOptions) | Creates a solid by sweeping one or more closed coplanar curve loops along a path.

See Also

GeometryCreationUtilities Class
GeometryCreationUtilities Members


CreateSweptGeometry Method (CurveLoop, Int32, Double, IList(CurveLoop))

[image]

Revit 2024 API
GeometryCreationUtilities..::..CreateSweptGeometry Method (CurveLoop, Int32, Double, IList<(Of <(<'CurveLoop>)>)>)
GeometryCreationUtilities Class See Also Send Feedback
Creates a solid by sweeping one or more closed coplanar curve loops along a path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static Solid CreateSweptGeometry(
    CurveLoop sweepPath,
    int pathAttachmentCrvIdx,
    double pathAttachmentParam,
    IList<CurveLoop> profileLoops
)
Visual Basic
Public Shared Function CreateSweptGeometry ( _
    sweepPath As CurveLoop, _
    pathAttachmentCrvIdx As Integer, _
    pathAttachmentParam As Double, _
    profileLoops As IList(Of CurveLoop) _
) As Solid
Visual C++
public:
static Solid^ CreateSweptGeometry(
    CurveLoop^ sweepPath,
    int pathAttachmentCrvIdx,
    double pathAttachmentParam,
    IList<CurveLoop^>^ profileLoops
)

Parameters

sweepPath
Type: Autodesk.Revit.DB..::..CurveLoop
The sweep path, consisting of a set of contiguous curves. The path may be open or closed, but should not otherwise have any self-intersections. The path may be planar or non-planar.
pathAttachmentCrvIdx
Type: System..::..Int32
The index of the curve in the sweep path where the profile loops are situated. Indexing starts at 0. Together with pathAttachmentParam, this specifies the profile's attachment point.
pathAttachmentParam
Type: System..::..Double
Parameter of the path curve specified by pathAttachmentCrvIdx. The profile curves must lie in the plane orthogonal to the path at this attachment point.
profileLoops
Type: System.Collections.Generic..::..IList<(Of <(<' CurveLoop >)>)>
The curve loops defining the planar domain to be swept along the path. No conditions are imposed on the orientations of the loops: this function will use copies of the input loops that have been oriented as necessary to conform to Revit's orientation conventions. Restrictions:
  • The loops must lie in the plane orthogonal to the path at the attachment point as defined above.
  • The curve loop(s) must be closed and should define a single planar domain (one outer loop and, optionally, one or more inner loops)
  • The curve loops must be without intersections, self-intersections, or degeneracies.
  • No loop may contain just one closed curve - split such loops into two or more curves beforehand.

Return Value

The requested solid.

Remarks

The profile loops must lie in a plane orthogonal to the sweep path at some attachment point along the path.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input argument sweepPath should at least contain one curve. -or- The input argument pathAttachmentCrvIdx is not valid. The given attachment point doesn't lie in the plane of the Curve Loop. -or- The profile CurveLoops do not satisfy the input requirements.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | Failed to create the swept solid.

See Also

GeometryCreationUtilities Class
CreateSweptGeometry Overload


CreateSweptGeometry Method (CurveLoop, Int32, Double, IList(CurveLoop), SolidOptions)

[image]

Revit 2024 API
GeometryCreationUtilities..::..CreateSweptGeometry Method (CurveLoop, Int32, Double, IList<(Of <(<'CurveLoop>)>)>, SolidOptions)
GeometryCreationUtilities Class See Also Send Feedback
Creates a solid by sweeping one or more closed coplanar curve loops along a path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static Solid CreateSweptGeometry(
    CurveLoop sweepPath,
    int pathAttachmentCrvIdx,
    double pathAttachmentParam,
    IList<CurveLoop> profileLoops,
    SolidOptions solidOptions
)
Visual Basic
Public Shared Function CreateSweptGeometry ( _
    sweepPath As CurveLoop, _
    pathAttachmentCrvIdx As Integer, _
    pathAttachmentParam As Double, _
    profileLoops As IList(Of CurveLoop), _
    solidOptions As SolidOptions _
) As Solid
Visual C++
public:
static Solid^ CreateSweptGeometry(
    CurveLoop^ sweepPath,
    int pathAttachmentCrvIdx,
    double pathAttachmentParam,
    IList<CurveLoop^>^ profileLoops,
    SolidOptions^ solidOptions
)

Parameters

sweepPath
Type: Autodesk.Revit.DB..::..CurveLoop
The sweep path, consisting of a set of contiguous curves. The path may be open or closed, but should not otherwise have any self-intersections. The path may be planar or non-planar.
pathAttachmentCrvIdx
Type: System..::..Int32
The index of the curve in the sweep path where the profile loops are situated. Indexing starts at 0. Together with pathAttachmentParam, this specifies the profile's attachment point.
pathAttachmentParam
Type: System..::..Double
Parameter of the path curve specified by pathAttachmentCrvIdx. The profile curves must lie in the plane orthogonal to the path at this attachment point.
profileLoops
Type: System.Collections.Generic..::..IList<(Of <(<' CurveLoop >)>)>
The curve loops defining the planar domain to be swept along the path. No conditions are imposed on the orientations of the loops: this function will use copies of the input loops that have been oriented as necessary to conform to Revit's orientation conventions. Restrictions:
  • The loops must lie in the plane orthogonal to the path at the attachment point as defined above.
  • The curve loop(s) must be closed and should define a single planar domain (one outer loop and, optionally, one or more inner loops)
  • The curve loops must be without intersections, self-intersections, or degeneracies.
  • No loop may contain just one closed curve - split such loops into two or more curves beforehand.
solidOptions
Type: Autodesk.Revit.DB..::..SolidOptions
The optional information to control the properties of the Solid.

Return Value

The requested solid.

Remarks

The profile loops must lie in a plane orthogonal to the sweep path at some attachment point along the path.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input argument sweepPath should at least contain one curve. -or- The input argument pathAttachmentCrvIdx is not valid. The given attachment point doesn't lie in the plane of the Curve Loop. -or- The profile CurveLoops do not satisfy the input requirements.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

GeometryCreationUtilities Class
CreateSweptGeometry Overload


GeometryElement Class

[image]

Revit 2024 API
GeometryElement Class
Members See Also Send Feedback
Geometric representation of an element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class GeometryElement : GeometryObject,
    IEnumerable<GeometryObject>
Visual Basic
Public Class GeometryElement _
    Inherits GeometryObject _
    Implements IEnumerable(Of GeometryObject)
Visual C++
public ref class GeometryElement : public GeometryObject,
    IEnumerable<GeometryObject^>

Remarks

This class contains geometric primitives that are generated from the parametric description of the element. The member geometric primitives can be obtained directly from this object using the capabilities of IEnumerable.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeometryObject
Autodesk.Revit.DB..::..GeometryElement

See Also

GeometryElement Members


GeometryElement Members

[image] [image]

Revit 2024 API
GeometryElement Members
GeometryElement Class Methods Properties See Also Send Feedback

The GeometryElement type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | GetBoundingBox | Retrieves a box that encloses the geometry element.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Protected method | GetEnumeratorNG | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject.)
Public method | GetTransformed | Returns a transformed copy of the geometry in this element.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | MaterialElement | Element describing the material from which this element is composed.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

GeometryElement Class


GetBoundingBox Method

[image]

Revit 2024 API
GeometryElement..::..GetBoundingBox Method
GeometryElement Class See Also Send Feedback
Retrieves a box that encloses the geometry element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public BoundingBoxXYZ GetBoundingBox()
Visual Basic
Public Function GetBoundingBox As BoundingBoxXYZ
Visual C++
public:
BoundingBoxXYZ^ GetBoundingBox()

Return Value

The bounding box.

Remarks

Note: If the GeometryElement was obtained via Element.get_Geometry from an Element containing 2D geometry but no 3D geometry, the bounding box returned by this function may not be empty because it takes the 2D geometry into account.

See Also

GeometryElement Class


GetEnumerator Method

[image]

Revit 2024 API
GeometryElement..::..GetEnumerator Method
GeometryElement Class See Also Send Feedback
Returns an enumerator that iterates through the collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IEnumerator<GeometryObject> GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator(Of GeometryObject)
Visual C++
public:
virtual IEnumerator<GeometryObject^>^ GetEnumerator()

Return Value

An IEnumerator(GeometryObject) object that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

GeometryElement Class


GetTransformed Method

[image]

Revit 2024 API
GeometryElement..::..GetTransformed Method
GeometryElement Class See Also Send Feedback
Returns a transformed copy of the geometry in this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public GeometryElement GetTransformed(
    Transform transform
)
Visual Basic
Public Function GetTransformed ( _
    transform As Transform _
) As GeometryElement
Visual C++
public:
GeometryElement^ GetTransformed(
    Transform^ transform
)

Parameters

transform
Type: Autodesk.Revit.DB..::..Transform
The transformation to apply to the geometry.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Transform is not conformal

See Also

GeometryElement Class


GeometryElement Properties

[image] [image]

Revit 2024 API
GeometryElement Properties
GeometryElement Class See Also Send Feedback

The GeometryElement type exposes the following members.

Properties

 | Name | Description
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | MaterialElement | Element describing the material from which this element is composed.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

GeometryElement Class


MaterialElement Property

[image]

Revit 2024 API
GeometryElement..::..MaterialElement Property
GeometryElement Class See Also Send Feedback
Element describing the material from which this element is composed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Material MaterialElement { get; }
Visual Basic
Public ReadOnly Property MaterialElement As Material
    Get
Visual C++
public:
property Material^ MaterialElement {
    Material^ get ();
}

See Also

GeometryElement Class


GeometryInstance Members

[image] [image]

Revit 2024 API
GeometryInstance Members
GeometryInstance Class Methods Properties See Also Send Feedback

The GeometryInstance type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | GetDocument | Gets the document that contains the symbol of this instance.
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject.)
Public method | GetInstanceGeometry()()()() | Computes the geometric representation of the instance.
Public method | GetInstanceGeometry(Transform) | Computes a transformation of the geometric representation of the instance.
Public method | GetSymbolGeometry()()()() | Computes the geometric representation of the symbol which generates this instance.
Public method | GetSymbolGeometry(Transform) | Computes a transformation of the geometric representation of the symbol which generates this instance.
Public method | GetSymbolGeometryId | Gets the SymbolGeometryId that contains data about the symbol of this instance.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | SymbolGeometry | The geometric representation of the symbol which generates this instance.
Public property | Transform | The affine transformation from the local coordinate space of the symbol into the coordinate space of the instance.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

GeometryInstance Class


GetDocument Method

[image]

Revit 2024 API
GeometryInstance..::..GetDocument Method
GeometryInstance Class See Also Send Feedback
Gets the document that contains the symbol of this instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public Document GetDocument()
Visual Basic
Public Function GetDocument As Document
Visual C++
public:
Document^ GetDocument()

Return Value

Returns the document that contains the symbol of this instance.

See Also

GeometryInstance Class


GetInstanceGeometry Method

[image] [image]

Revit 2024 API
GeometryInstance..::..GetInstanceGeometry Method
GeometryInstance Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetInstanceGeometry()()()() | Computes the geometric representation of the instance.
Public method | GetInstanceGeometry(Transform) | Computes a transformation of the geometric representation of the instance.

See Also

GeometryInstance Class
GeometryInstance Members


GetInstanceGeometry Method

[image]

Revit 2024 API
GeometryInstance..::..GetInstanceGeometry Method
GeometryInstance Class See Also Send Feedback
Computes the geometric representation of the instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public GeometryElement GetInstanceGeometry()
Visual Basic
Public Function GetInstanceGeometry As GeometryElement
Visual C++
public:
GeometryElement^ GetInstanceGeometry()

Return Value

An element which contains the computed geometry for the instance.

Remarks

The geometry will be in the coordinate system of the model that owns this instance. The context of the instance object (such as effective material) will be applied to the symbol. Note that this method involves extensive parsing or Revit's data structures, so try to minimize calls if performance is critical. Geometry will be parsed with the same options as those used when this object was retrieved. This method returns a copy of the Revit geometry. It is suitable for use in a tool which extracts geometry to another format or carries out a geometric analysis; however, because it returns a copy the references found in the geometry objects contained in this element are not suitable for creating new Revit elements referencing the original element (for example, dimensioning). Only the geometry returned by GetSymbolGeometry() with no transform can be used for that purpose.

See Also

GeometryInstance Class
GetInstanceGeometry Overload


GetSymbolGeometry Method

[image] [image]

Revit 2024 API
GeometryInstance..::..GetSymbolGeometry Method
GeometryInstance Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetSymbolGeometry()()()() | Computes the geometric representation of the symbol which generates this instance.
Public method | GetSymbolGeometry(Transform) | Computes a transformation of the geometric representation of the symbol which generates this instance.

See Also

GeometryInstance Class
GeometryInstance Members


GetSymbolGeometry Method

[image]

Revit 2024 API
GeometryInstance..::..GetSymbolGeometry Method
GeometryInstance Class See Also Send Feedback
Computes the geometric representation of the symbol which generates this instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public GeometryElement GetSymbolGeometry()
Visual Basic
Public Function GetSymbolGeometry As GeometryElement
Visual C++
public:
GeometryElement^ GetSymbolGeometry()

Return Value

An element which contains the computed geometry for the symbol.

Remarks

The geometry will be in the local coordinate space of the symbol. The context of this instance object (such as effective material) will be applied to the symbol. Note that this method involves extensive parsing or Revit's data structures, so try to minimize calls if performance is critical. Geometry will be parsed with the same options as those used when this object was retrieved. The results of the method and the value of the SymbolGeometry property are identical. This method returns the actual Revit geometry. Unlike other methods which extract transformed copies of the geometry, the return value of this method is suitable for creating new Revit elements referencing the original element (for example, dimensioning).

See Also

GeometryInstance Class
GetSymbolGeometry Overload


GetSymbolGeometry Method (Transform)

[image]

Revit 2024 API
GeometryInstance..::..GetSymbolGeometry Method (Transform)
GeometryInstance Class See Also Send Feedback
Computes a transformation of the geometric representation of the symbol which generates this instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public GeometryElement GetSymbolGeometry(
    Transform transform
)
Visual Basic
Public Function GetSymbolGeometry ( _
    transform As Transform _
) As GeometryElement
Visual C++
public:
GeometryElement^ GetSymbolGeometry(
    Transform^ transform
)

Parameters

transform
Type: Autodesk.Revit.DB..::..Transform
The transformation to apply to the geometry.

Return Value

An element which contains the computed geometry for the transformed symbol.

Remarks

The context of this instance object (such as effective material) will be applied to the symbol. Note that this method involves extensive parsing or Revit's data structures, so try to minimize calls if performance is critical. Geometry will be parsed with the same options as those used when this object was retrieved. This method returns a copy of the Revit geometry. It is suitable for use in a tool which extracts geometry to another format or carries out a geometric analysis; however, because it returns a copy the references found in the geometry objects contained in this element are not suitable for creating new Revit elements referencing the original element (for example, dimensioning). Only the geometry returned by GetSymbolGeometry() with no transform can be used for that purpose.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Transform is not conformal

See Also

GeometryInstance Class
GetSymbolGeometry Overload


GetSymbolGeometryId Method

[image]

Revit 2024 API
GeometryInstance..::..GetSymbolGeometryId Method
GeometryInstance Class See Also Send Feedback
Gets the SymbolGeometryId that contains data about the symbol of this instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public SymbolGeometryId GetSymbolGeometryId()
Visual Basic
Public Function GetSymbolGeometryId As SymbolGeometryId
Visual C++
public:
SymbolGeometryId^ GetSymbolGeometryId()

Return Value

Returns the SymbolGeometryId that contains data about the symbol of this instance.

Remarks

Use the strings returned by SymbolGeometryId.AsIdentifier(bool) to check if two GeometryInstance point to the same geometry of the symbol.

See Also

GeometryInstance Class


GeometryInstance Properties

[image] [image]

Revit 2024 API
GeometryInstance Properties
GeometryInstance Class See Also Send Feedback

The GeometryInstance type exposes the following members.

Properties

 | Name | Description
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | SymbolGeometry | The geometric representation of the symbol which generates this instance.
Public property | Transform | The affine transformation from the local coordinate space of the symbol into the coordinate space of the instance.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

GeometryInstance Class


SymbolGeometry Property

[image]

Revit 2024 API
GeometryInstance..::..SymbolGeometry Property
GeometryInstance Class See Also Send Feedback
The geometric representation of the symbol which generates this instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public GeometryElement SymbolGeometry { get; }
Visual Basic
Public ReadOnly Property SymbolGeometry As GeometryElement
    Get
Visual C++
public:
property GeometryElement^ SymbolGeometry {
    GeometryElement^ get ();
}

Remarks

The geometry will be in the local coordinate space of the symbol. The context of this instance object (such as effective material) will be applied to the symbol. Note that retrieving the value of this property involves extensive parsing or Revit's data structures, so try to minimize calls if performance is critical. Geometry will be parsed with the same options as those used when this object was retrieved. The value of this property and the results of the method GetSymbolGeometry(void) are identical.

See Also

GeometryInstance Class


Transform Property

[image]

Revit 2024 API
GeometryInstance..::..Transform Property
GeometryInstance Class Example See Also Send Feedback
The affine transformation from the local coordinate space of the symbol into the coordinate space of the instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Transform Transform { get; }
Visual Basic
Public ReadOnly Property Transform As Transform
    Get
Visual C++
public:
property Transform^ Transform {
    Transform^ get ();
}

Examples

CopyC#
public void GetAndTransformCurve(Autodesk.Revit.ApplicationServices.Application app,
    Autodesk.Revit.DB.Element element, Options geoOptions)
{
    // Get geometry element of the selected element
    Autodesk.Revit.DB.GeometryElement geoElement = element.get_Geometry(geoOptions);

    // Get geometry object
    foreach (GeometryObject geoObject in geoElement)
    {
        // Get the geometry instance which contains the geometry information
       Autodesk.Revit.DB.GeometryInstance instance =
           geoObject as Autodesk.Revit.DB.GeometryInstance;
        if (null != instance)
        {
            foreach (GeometryObject o in instance.SymbolGeometry)
            {
                // Get curve
                Curve curve = o as Curve;
                if (curve != null)
                {
                    // transfrom the curve to make it in the instance's coordinate space
                    curve = curve.CreateTransformed(instance.Transform);
                }
            }
        }
    }
}
CopyVB.NET
Public Sub GetAndTransformCurve(app As Autodesk.Revit.ApplicationServices.Application, element As Autodesk.Revit.DB.Element, geoOptions As Options)
    ' Get geometry element of the selected element
    Dim geoElement As Autodesk.Revit.DB.GeometryElement = element.Geometry(geoOptions)

    ' Get geometry object
    For Each geoObject As GeometryObject In geoElement
        ' Get the geometry instance which contains the geometry information
        Dim instance As Autodesk.Revit.DB.GeometryInstance = TryCast(geoObject, Autodesk.Revit.DB.GeometryInstance)
        If instance IsNot Nothing Then
            For Each o As GeometryObject In instance.SymbolGeometry
                ' Get curve
                Dim curve As Curve = TryCast(o, Curve)
                If curve IsNot Nothing Then
                    ' transfrom the curve to make it in the instance's coordinate space
                    curve = curve.CreateTransformed(instance.Transform)
                End If
            Next
        End If
    Next
End Sub

See Also

GeometryInstance Class


GeometryObject Members

[image] [image]

Revit 2024 API
GeometryObject Members
GeometryObject Class Methods Operators Properties See Also Send Feedback

The GeometryObject type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Operators

Name | Description
Equality | Determines whether two GeometryObjects are the same.
Inequality | Determines whether two GeometryObjects are different.

Properties

 | Name | Description
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement.
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Visibility | The visibility.

See Also

GeometryObject Class


GeometryObject Methods

[image] [image]

Revit 2024 API
GeometryObject Methods
GeometryObject Class See Also Send Feedback

The GeometryObject type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

GeometryObject Class


Equals Method

[image]

Revit 2024 API
GeometryObject..::..Equals Method
GeometryObject Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
Another object.

Remarks

This compares the internal identifiers of the geometry, and doesn't compare them geometrically.

See Also

GeometryObject Class


GetHashCode Method

[image]

Revit 2024 API
GeometryObject..::..GetHashCode Method
GeometryObject Class See Also Send Feedback
Gets the integer value of the geometry object as hash code

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

GeometryObject Class


GeometryObject Operators

[image] [image]

Revit 2024 API
GeometryObject Operators
GeometryObject Class See Also Send Feedback

The GeometryObject type exposes the following members.

Operators

Name | Description
Equality | Determines whether two GeometryObjects are the same.
Inequality | Determines whether two GeometryObjects are different.

See Also

GeometryObject Class


Equality Operator

[image]

Revit 2024 API
GeometryObject..::..Equality Operator
GeometryObject Class See Also Send Feedback
Determines whether two GeometryObjects are the same.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static bool operator ==(
    GeometryObject first,
    GeometryObject second
)
Visual Basic
Public Shared Operator = ( _
    first As GeometryObject, _
    second As GeometryObject _
) As Boolean
Visual C++
public:
static bool operator ==(
    GeometryObject^ first,
    GeometryObject^ second
)

Parameters

first
Type: Autodesk.Revit.DB..::..GeometryObject
The first GeometryObject.
second
Type: Autodesk.Revit.DB..::..GeometryObject
The second GeometryObject.

Return Value

True if the GeometryObjects are the same; otherwise, false.

Remarks

This compares the internal identifiers of the geometry, and doesn't compare them geometrically.

See Also

GeometryObject Class


Inequality Operator

[image]

Revit 2024 API
GeometryObject..::..Inequality Operator
GeometryObject Class See Also Send Feedback
Determines whether two GeometryObjects are different.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static bool operator !=(
    GeometryObject first,
    GeometryObject second
)
Visual Basic
Public Shared Operator <> ( _
    first As GeometryObject, _
    second As GeometryObject _
) As Boolean
Visual C++
public:
static bool operator !=(
    GeometryObject^ first,
    GeometryObject^ second
)

Parameters

first
Type: Autodesk.Revit.DB..::..GeometryObject
The first GeometryObject.
second
Type: Autodesk.Revit.DB..::..GeometryObject
The second GeometryObject.

Return Value

True if the GeometryObjects are different; otherwise, false.

Remarks

This compares the internal identifiers of the geometry, and doesn't compare them geometrically.

See Also

GeometryObject Class


GeometryObject Properties

[image] [image]

Revit 2024 API
GeometryObject Properties
GeometryObject Class See Also Send Feedback

The GeometryObject type exposes the following members.

Properties

 | Name | Description
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement.
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Visibility | The visibility.

See Also

GeometryObject Class


GraphicsStyleId Property

[image]

Revit 2024 API
GeometryObject..::..GraphicsStyleId Property
GeometryObject Class Example See Also Send Feedback
The ElementId of the GeometryObject's GraphicsStyle

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public ElementId GraphicsStyleId { get; }
Visual Basic
Public ReadOnly Property GraphicsStyleId As ElementId
    Get
Visual C++
public:
property ElementId^ GraphicsStyleId {
    ElementId^ get ();
}

Remarks

This property provides the id of the GraphicsStyle assigned to the GeometryObject. This can be used to find the category of the object.

Examples

CopyC#
// find the name of the GraphicsSytleCategory for every geometric primitive in a family instance
        Options options = app.Create.NewGeometryOptions();
        GeometryElement geomElem = element.get_Geometry(options);
        foreach (GeometryObject geomObj in geomElem)
        {
            GeometryInstance geomInst = geomObj as GeometryInstance;
            if (geomInst != null)
            {
                foreach (Object obj in geomInst.SymbolGeometry)
                {
                    GeometryObject geomObject = obj as GeometryObject;
                    GraphicsStyle gStyle = doc.GetElement(geomObject.GraphicsStyleId) as GraphicsStyle;
                    if (gStyle != null)
                    {
                        string gstyleName = gStyle.GraphicsStyleCategory.Name;
                    }
                }
            }
        }
CopyVB.NET
' find the name of the GraphicsSytleCategory for every geometric primitive in a family instance
Dim options As Options = app.Create.NewGeometryOptions()
Dim geomElem As GeometryElement = element.Geometry(options)
For Each geomObj As GeometryObject In geomElem
    Dim geomInst As GeometryInstance = TryCast(geomObj, GeometryInstance)
    If geomInst IsNot Nothing Then
        For Each obj As [Object] In geomInst.SymbolGeometry
            Dim geomObject As GeometryObject = TryCast(obj, GeometryObject)
            Dim gStyle As GraphicsStyle = TryCast(doc.GetElement(geomObject.GraphicsStyleId), GraphicsStyle)
            If gStyle IsNot Nothing Then
                Dim gstyleName As String = gStyle.GraphicsStyleCategory.Name
            End If
        Next
    End If

See Also

GeometryObject Class


Id Property

[image]

Revit 2024 API
GeometryObject..::..Id Property
GeometryObject Class See Also Send Feedback
A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public int Id { get; }
Visual Basic
Public ReadOnly Property Id As Integer
    Get
Visual C++
public:
property int Id {
    int get ();
}

Remarks

This id can be stored and used for future referencing. The reference should be stable between minor geometric changes and modifications, but may not remain valid if there are major changes to the element or its surroundings. Note that the id may be negative(and thus invalid for referencing) if obtained from view - specific geometry, or if obtained from most GeometryObjects created in memory by the API. Negative ids cannot be used for referencing. These integer ids should not be used for comparison purposes(other than to check if they are equivalent or not). Nothing should be assumed about rules about how an element populates the sequence of different numeric values as this may change based on the element's definition.

See Also

GeometryObject Class


IsElementGeometry Property

[image]

Revit 2024 API
GeometryObject..::..IsElementGeometry Property
GeometryObject Class See Also Send Feedback
Indicates whether this geometry is obtained directly from an Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public bool IsElementGeometry { get; }
Visual Basic
Public ReadOnly Property IsElementGeometry As Boolean
    Get
Visual C++
public:
property bool IsElementGeometry {
    bool get ();
}

See Also

GeometryObject Class


Visibility Property

[image]

Revit 2024 API
GeometryObject..::..Visibility Property
GeometryObject Class See Also Send Feedback
The visibility.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Visibility Visibility { get; set; }
Visual Basic
Public Property Visibility As Visibility
    Get
    Set
Visual C++
public:
property Visibility Visibility {
    Visibility get ();
    void set (Visibility value);
}

Remarks

The visibility of this object has no effect on the visibility of objects contained within this object. For example, the visibility of a Solid may be Contextual but the faces within that solid may still be Visible.

See Also

GeometryObject Class


GlobalParameter Class

[image]

Revit 2024 API
GlobalParameter Class
Members See Also Send Feedback
This class represents a GlobalParameter element in Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Update

Syntax

C#
public class GlobalParameter : ParameterElement
Visual Basic
Public Class GlobalParameter _
    Inherits ParameterElement
Visual C++
public ref class GlobalParameter : public ParameterElement

Remarks

Global parameters can be used to drive values of dimensions or other elements' parameters. Also, a global parameter can be driven by a selected dimension, the value of which then determines the value of the global parameter. Such parameters can further be used to drive values of other elements' parameters.

See also the GlobalParametersManager class for methods that operate upon global parameters of a document, such as getting all defined global parameters and testing whether a global parameter of certain name already exists or not.

Reporting vs. Non-Reporting parameters

There are several ways global parameters can be categorized, but probably the most significant categorization stems from the IsReporting property which divides global parameters into two groups - Reporting and Non-Reporting. The significance of reporting parameters lays in the fact that their values are driven by the dimension that has been labeled by a reporting parameter. It means that the value of a reporting parameter reflects the value of a dimension (length or angle) and gets updated anytime the dimension changes. Non-Reporting parameters behave in the opposite manner - they drive value of dimensions that have been labeled by them, which results in controlling the model's geometry through global parameters' values.

Reporting parameters are limited in several ways. They can be only of Length or Angle type, a requirement due to the fact that a dimension must be able to drive the value. For the same reason reporting parameters may not have formulas.

Non-Reporting parameters, on the other way, can be of almost any type (Length, Integer, Area, etc.) with the exception of ElementId type. Also, Non-Reporting parameters may have assigned formulas in which other global parameters may be used as arguments. This way one global parameter's value can be derived from other parameter (or parameters), and the other parameter can be either reporting or non-reporting.

Creating Global Parameters

Global parameters get created via the static method Create(Document, String, ForgeTypeId). It is important to note that each new parameter must have a name that is unique within the document. Parameters are created as non-reporting initially, but programmers are free to modify the IsReporting property once a global parameter is created and is of an eligible type. The programmer can call the HasValidTypeForReporting()()()() when in doubt whether parameters of a certain data type can be made reporting. Note, that a parameter may not be made reporting after more than one dimension has been labeled by it. It is because reporting parameter can label (and be driven) by one dimension only.

An alternative way of making a parameter reporting is via the SetDrivingDimension(ElementId) method which labels one dimension by a global parameter and also makes the parameter reporting if it is not reporting yet.

Other important properties of global parameters are IsDrivenByDimension and IsDrivenByFormula, which are mutually exclusive - a parameter that has a formula assigned cannot be driven by a dimension (nor can be reporting) and vice versa.

Global Parameters with formulas

Like with family parameters, formulas may be assigned to non-reporting global parameters using the SetFormula(String) method (paired with GetFormula()()()() to query the current formula.) Formulas may include all standard arithmetic operations and logical operations (as functions and, or, not.) Input to logical operations must be Boolean values (parameters of YesNo type). Consequently, arithmetic operations can be applied to numeric values only. While there are no operations supported for string (text) arguments, strings can be used as results of a logical If operation. Depending on their type (and units), parameters of different value types can be combined. However, unit-less values such as Integer and Number (double) may only be combined with each other. Since formulas can get quite complicated, the method IsValidFormula(String) is available for the programmer to ensure a formula is valid in order to avoid potential exception due to applying an invalid formula.

Labeling dimensions

Probably the most notable feature of global parameters is their ability to "Label" dimensions, a process that establishes dependency of a dimension on a global parameter (or vice versa, depending on the reporting status.) One parameter can label any number of dimensions as long as the parameter is non-reporting. If the parameter labels a multi-segment dimension, values of all segments of this dimension will be equal to the parameter's value. As mentioned above, reporting parameter can label one dimension only, and this dimension can have only one segment. Methods and properties related to labeling include: LabelDimension(ElementId), UnlabelDimension(ElementId), and GetLabeledDimensions()()()(). Also in this set is the CanLabelDimension(ElementId) method which indicates whether or not a particular dimension can be labeled. Presently, only single linear dimensions and angles are permitted.

Elements affected by a Global Parameter

Global parameters can be associated with other global parameters as well as regular family instance parameters (which may report global parameters as their values via the assignment formula.) There are two methods available to find relations among parameters: GetAffectedGlobalParameters()()()() and GetAffectedElements()()()(). The former returns all other global parameters that refer to a particular global parameter in their respective formulas. The other method returns a set of all elements of which some parameters are controlled by the global parameter. These two methods together with the GetLabeledDimensions()()()() can help the programmer in figuring out how model elements relate to each other via global parameters.

Methods for maintaining associations between element properties and global parameters can be found in the Parameter class.

Getting and setting the value of a Global Parameter

All global parameters, formula-driven, dimension-driven, or independent, have values. A value can be obtained by calling the GetValue()()()() method. The object returned by that method is an instance of one of the classes derived from ParameterValue class. The concrete instance is determined by the type of the global parameter (specified upon creation.) Parameters that are neither formula-driven nor dimension-driven (reporting) can have a value assigned. The method to use is SetValue(ParameterValue) and it accepts the same type of ParameterValue that is returned by SetValue. However, the type can also be deduced easily: Text parameters accept only StringParameterValue. Integer and YesNo parameters accept only IntegerParameterValue. All other parameters accept only DoubleParameterValue.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ParameterElement
Autodesk.Revit.DB..::..GlobalParameter

See Also

GlobalParameter Members


GlobalParameter Methods

[image] [image]

Revit 2024 API
GlobalParameter Methods
GlobalParameter Class See Also Send Feedback

The GlobalParameter type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanChangeReporting | Tests whether the global parameter permits a change of its current value of the IsReporting attribute.
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanLabelDimension | Tests whether a dimension can be labeled by the global parameter.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create | Creates a new Global Parameter in the given document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetAffectedElements | Returns all elements of which properties are driven by this global parameter.
Public method | GetAffectedGlobalParameters | Returns all other global parameters which refer to this global parameter in their formulas.
Public method | GetDefinition | Get the definition representing this parameter element. (Inherited from ParameterElement.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetFormula | Returns the parameter's expression in form of a string.
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLabeledDimensions | Returns all dimension elements that are currently labeled by this global parameter.
Public method | GetLabelName | Returns the name of this parameter's label, which is used to label dimension elements.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetValue | Obtains the curent value of the global parameter.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasValidTypeForReporting | Tests that the global parameter has data of a type that supports reporting.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidFormula | Tests that the given expression is a valid as formula for this parameter.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LabelDimension | Labels a dimension with this global parameter.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetDrivingDimension | Set a dimension to drive the value of this parameter.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetFormula | Sets a formula expression for this parameter.
Public method | SetValue | Sets a new value of the global parameter.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnlabelDimension | Unlabels a dimension that is currently labeled by this global parameter.

See Also

GlobalParameter Class


CanChangeReporting Method

[image]

Revit 2024 API
GlobalParameter..::..CanChangeReporting Method
GlobalParameter Class See Also Send Feedback
Tests whether the global parameter permits a change of its current value of the IsReporting attribute.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public bool CanChangeReporting()
Visual Basic
Public Function CanChangeReporting As Boolean
Visual C++
public:
bool CanChangeReporting()

Return Value

Returns True if the change is allowed; False otherwise.

See Also

GlobalParameter Class


CanLabelDimension Method

[image]

Revit 2024 API
GlobalParameter..::..CanLabelDimension Method
GlobalParameter Class See Also Send Feedback
Tests whether a dimension can be labeled by the global parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Update

Syntax

C#
public bool CanLabelDimension(
    ElementId dimensionId
)
Visual Basic
Public Function CanLabelDimension ( _
    dimensionId As ElementId _
) As Boolean
Visual C++
public:
bool CanLabelDimension(
    ElementId^ dimensionId
)

Parameters

dimensionId
Type: Autodesk.Revit.DB..::..ElementId
Id of a dimension element.

Return Value

True of the input dimension can be labeled by this global parameter; False oterwise.

Remarks

Possible causes include a dimension that cannot be labeled at all, or it is of other than Linear or Angular type, or does not have the appropriate labeling parameter. Another reason for this method returning False is that the data type of this global parameter is not suitable for labeling (i.e. it contains neither Length nor Angle value), or the parameter is reporting and the dimension has more than one segment.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

GlobalParameter Class


GetAffectedElements Method

[image]

Revit 2024 API
GlobalParameter..::..GetAffectedElements Method
GlobalParameter Class See Also Send Feedback
Returns all elements of which properties are driven by this global parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Update

Syntax

C#
public ISet<ElementId> GetAffectedElements()
Visual Basic
Public Function GetAffectedElements As ISet(Of ElementId)
Visual C++
public:
ISet<ElementId^>^ GetAffectedElements()

Return Value

Collection of Element Ids.

Remarks

The returned collection does not include dimensions labeled by this global parameter. To get the labeled dimensions use the GetLabeledDimensions()()()() method. Other global parameters that may be affected by this one (in their formulas) are also excluded from the returned collection. To get the set of affected global parameters use the GetAffectedGlobalParameters()()()() method.

See Also

GlobalParameter Class


GetAffectedGlobalParameters Method

[image]

Revit 2024 API
GlobalParameter..::..GetAffectedGlobalParameters Method
GlobalParameter Class See Also Send Feedback
Returns all other global parameters which refer to this global parameter in their formulas.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Update

Syntax

C#
public ISet<ElementId> GetAffectedGlobalParameters()
Visual Basic
Public Function GetAffectedGlobalParameters As ISet(Of ElementId)
Visual C++
public:
ISet<ElementId^>^ GetAffectedGlobalParameters()

Return Value

Collection of Element Ids.

Remarks

The method returns other global parameters that directly (in their formulas) refer to this parameter. For example, if P1 refers to P0 (e.g. [= 2.5 * P0]), and P2 refers to P1 (e.g. [= P1 + 3.14]), then the set of parameters affected directly by P0 would only contain one parameter - P1. Naturally, be using this method repeatedly, firts on P0 and then P1 (assuming the above example), the programmer can eventually collect all depending global parameters, whether they refer to P0 directly or indirectly.

See Also

GlobalParameter Class


GetFormula Method

[image]

Revit 2024 API
GlobalParameter..::..GetFormula Method
GlobalParameter Class See Also Send Feedback
Returns the parameter's expression in form of a string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Update

Syntax

C#
public string GetFormula()
Visual Basic
Public Function GetFormula As String
Visual C++
public:
String^ GetFormula()

Return Value

The string representing the expression assigned to the parameter.

Remarks

Returns an empty string a case the parameter is not determined by a formula, or if the the expression cannot be converted to a string.

See Also

GlobalParameter Class


GetLabeledDimensions Method

[image]

Revit 2024 API
GlobalParameter..::..GetLabeledDimensions Method
GlobalParameter Class See Also Send Feedback
Returns all dimension elements that are currently labeled by this global parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Update

Syntax

C#
public ISet<ElementId> GetLabeledDimensions()
Visual Basic
Public Function GetLabeledDimensions As ISet(Of ElementId)
Visual C++
public:
ISet<ElementId^>^ GetLabeledDimensions()

Return Value

Collection of Element Ids.

Remarks

In case of a reporting parameter the returned collection will contain at most one element - the driving dimension, if it has been set already. It is because reporting parameters may have only one dimension labeled. For non-reporting parameters the set would contain all dimensions that have been labeled by this global parameter.

See Also

GlobalParameter Class


GetLabelName Method

[image]

Revit 2024 API
GlobalParameter..::..GetLabelName Method
GlobalParameter Class See Also Send Feedback
Returns the name of this parameter's label, which is used to label dimension elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Update

Syntax

C#
public string GetLabelName()
Visual Basic
Public Function GetLabelName As String
Visual C++
public:
String^ GetLabelName()

Return Value

The name of the parameter's label.

Remarks

Note that a Label equals a parameter's name if the parameters is non-reporting. Reporting parameters, however, have their labels suffixed by a special string to make it obvious the parameters is reporting (thus suitable to be driven by a dimension.)

See Also

GlobalParameter Class


GetValue Method

[image]

Revit 2024 API
GlobalParameter..::..GetValue Method
GlobalParameter Class See Also Send Feedback
Obtains the curent value of the global parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Update

Syntax

C#
public ParameterValue GetValue()
Visual Basic
Public Function GetValue As ParameterValue
Visual C++
public:
ParameterValue^ GetValue()

Return Value

An instance of one of the classes derived from the ParameterValue base class.

Remarks

Note that a value is always returned regardless of whether the parameter is formula-driven, or dimension-driven, or independent.

The returned ParameterValue is casted-up an instance of one of the derived classes, such as DoubleParameterValue or IntegerParameterValue.

See Also

GlobalParameter Class


HasValidTypeForReporting Method

[image]

Revit 2024 API
GlobalParameter..::..HasValidTypeForReporting Method
GlobalParameter Class See Also Send Feedback
Tests that the global parameter has data of a type that supports reporting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Update

Syntax

C#
public bool HasValidTypeForReporting()
Visual Basic
Public Function HasValidTypeForReporting As Boolean
Visual C++
public:
bool HasValidTypeForReporting()

Return Value

True if the parameter has data of a type that supports reporting; False otherwise.

Remarks

Only few data types can be used for reporting parmeters. Currently, reporting global parameters must be either of type Lenght or Angle - basically, they need to be value-driven by standard dimensions.

See Also

GlobalParameter Class


IsValidFormula Method

[image]

Revit 2024 API
GlobalParameter..::..IsValidFormula Method
GlobalParameter Class See Also Send Feedback
Tests that the given expression is a valid as formula for this parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Update

Syntax

C#
public bool IsValidFormula(
    string expression
)
Visual Basic
Public Function IsValidFormula ( _
    expression As String _
) As Boolean
Visual C++
public:
bool IsValidFormula(
    String^ expression
)

Parameters

expression
Type: System..::..String

Remarks

Use this method to test validity of a formula before assigning it to a global parameter when in doubt whether it is an acceptable expression or not.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

GlobalParameter Class


LabelDimension Method

[image]

Revit 2024 API
GlobalParameter..::..LabelDimension Method
GlobalParameter Class Example See Also Send Feedback
Labels a dimension with this global parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Update

Syntax

C#
public void LabelDimension(
    ElementId dimensionId
)
Visual Basic
Public Sub LabelDimension ( _
    dimensionId As ElementId _
)
Visual C++
public:
void LabelDimension(
    ElementId^ dimensionId
)

Parameters

dimensionId
Type: Autodesk.Revit.DB..::..ElementId
Id of a dimension element.

Remarks

When a dimension is labeled by a global parameters, then its value is either controlled by the parameter (non-reporting), or drives the value of the parameter (reporting). It is important to note that a reporting parameter can label at most one dimension object - meaning, a parameter can be driven by one dimension only. If the dimension has several segments and is labeled by a non-reprting parameter, the value of each segment will be driven by this parameter. Multi-segmented dimensions cannot be labeled by reporting parameters.

If the dimension is already labeled by another global parameter, labeling it again will automatically detach it from that parameter.

Presently, not just any kind of dimensions may be labeled by a global parameter. Typically only single Linear and Angular dimensions can be labeled, but there are other restrictions in effect too. Also, for the value of the parameter and dimension labeled by it depend on each other, the data type of the global parameters must be either Length or Angle, since those are the only units a dimension can represent. Refer to the [!:CanLabelDimension(Autodesk::Revit::DB::ElementId)] method to find out whether a particular dimension element may be labeled or not.

Examples

CopyC#
/// <summary>
/// Creates a global parameter and uses it to label the set of given dimension elements
/// </summary>
/// <param name="document">Revit project document that contains the dimension.</param>
/// <param name="gpname">A name of the global parameter to create.</param>
/// <param name="value">Initial value of the global parameter</param>
/// <param name="dimset">A collection of dimension elements to drive by a global parameter</param>
/// <returns>Number of actually labeled dimension</returns>
public int DriveSelectedDimensions(Document document, string name, double value, ISet<ElementId> dimset)
{
    if (!GlobalParametersManager.AreGlobalParametersAllowed(document))
        throw new System.InvalidOperationException("Global parameters are not permitted in the given document");

    if (!GlobalParametersManager.IsUniqueName(document, name))
        throw new System.ArgumentException("Global parameter with such name already exists in the document", "name");

    if (value <= 0.0)
        throw new System.ArgumentException("Value of a global parameter that drives dimension must be a positive number", "value");

    int nLabeledDims = 0;   // number of labeled dimensions (for testing)

    // creation of any element must be in a transaction
    using (Transaction trans = new Transaction(document, "Create Global Parameter"))
    {
        trans.Start();

        // create a GP with the given name and type Length
        // Note: Length (or Angle) is required type of global parameters that are to label a dimension
        GlobalParameter newgp = GlobalParameter.Create(document, name, SpecTypeId.Length);
        if (newgp != null)
        {
            newgp.SetValue(new DoubleParameterValue(value));

            // use the parameter to label the given dimensions
            foreach (ElementId elemid in dimset)
            {
                // not just any dimension is allowed to be labeled
                // check first to avoid exceptions
                if (newgp.CanLabelDimension(elemid))
                {
                    newgp.LabelDimension(elemid);
                    nLabeledDims += 1;
                }
            }

            trans.Commit();
        }
    }

    // for illustration purposes only, we'll test the results of our modifications

    // 1.) Check the new parameter can be found

    ElementId gpid = GlobalParametersManager.FindByName(document,name);
    if (gpid == ElementId.InvalidElementId)
    {
        TaskDialog.Show("Error", "Failed to find a newly created global parameter");
    }

    GlobalParameter gp = document.GetElement(gpid) as GlobalParameter;

    // 2. Check the number of labeled dimension is as expected

    ISet<ElementId> labeledSet = gp.GetLabeledDimensions();
    if (labeledSet.Count != nLabeledDims)
    {
        TaskDialog.Show("Error", "Have not found all the dimension that were labeled.");
    }

    return labeledSet.Count;
}
CopyVB.NET
' <summary>
' Creates a global parameter and uses it to label the set of given dimension elements
' </summary>
' <param name="document">Revit project document that contains the dimension.</param>
' <param name="gpname">A name of the global parameter to create.</param>
' <param name="value">Initial value of the global parameter</param>
' <param name="dimset">A collection of dimension elements to drive by a global parameter</param>
' <returns>Number of actually labeled dimension</returns>
Public Function DriveSelectedDimensions(document As Document, name As String, value As Double, dimset As ISet(Of ElementId)) As Integer
    If Not GlobalParametersManager.AreGlobalParametersAllowed(document) Then
        Throw New System.InvalidOperationException("Global parameters are not permitted in the given document")
    End If

    If Not GlobalParametersManager.IsUniqueName(document, name) Then
        Throw New System.ArgumentException("Global parameter with such name already exists in the document", "name")
    End If

    If value <= 0.0 Then
        Throw New System.ArgumentException("Value of a global parameter that drives dimension must be a positive number", "value")
    End If

    Dim nLabeledDims As Integer = 0
    ' number of labeled dimensions (for testing)
    ' creation of any element must be in a transaction
    Using trans As New Transaction(document, "Create Global Parameter")
        trans.Start()

    ' create a GP with the given name and type Length
    ' Note: Length (or Angle) is required type of global parameters that are to label a dimension
    Dim newgp As GlobalParameter = GlobalParameter.Create(document, name, SpecTypeId.Length)
    If newgp IsNot Nothing Then
            newgp.SetValue(New DoubleParameterValue(value))

            ' use the parameter to label the given dimensions
            For Each elemid As ElementId In dimset
                ' not just any dimension is allowed to be labeled
                ' check first to avoid exceptions
                If newgp.CanLabelDimension(elemid) Then
                    newgp.LabelDimension(elemid)
                    nLabeledDims += 1
                End If
            Next

            trans.Commit()
        End If
    End Using

    ' for illustration purposes only, we'll test the results of our modifications

    ' 1.) Check the new parameter can be found

    Dim gpid As ElementId = GlobalParametersManager.FindByName(document, name)
    If gpid = ElementId.InvalidElementId Then
        TaskDialog.Show("Error", "Failed to find a newly created global parameter")
    End If

    Dim gp As GlobalParameter = TryCast(document.GetElement(gpid), GlobalParameter)

    ' 2. Check the number of labeled dimension is as expected

    Dim labeledSet As ISet(Of ElementId) = gp.GetLabeledDimensions()
    If labeledSet.Count <> nLabeledDims Then
        TaskDialog.Show("Error", "Have not found all the dimension that were labeled.")
    End If

    Return labeledSet.Count
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Given element Id is not of a valid dimension element. -or- Dimension with the Id of dimensionId cannot be labeled by this global parameter. Possible causes include the dimension cannot be labeled at all, or it is a dimension of other than Linear or Angular type, or the Dimension object does not have the appropriate labeling parameter, or the dimension has more than one segment and the parameter is reporting.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

GlobalParameter Class


SetDrivingDimension Method

[image]

Revit 2024 API
GlobalParameter..::..SetDrivingDimension Method
GlobalParameter Class Example See Also Send Feedback
Set a dimension to drive the value of this parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Update

Syntax

C#
public void SetDrivingDimension(
    ElementId dimensionId
)
Visual Basic
Public Sub SetDrivingDimension ( _
    dimensionId As ElementId _
)
Visual C++
public:
void SetDrivingDimension(
    ElementId^ dimensionId
)

Parameters

dimensionId
Type: Autodesk.Revit.DB..::..ElementId
Id of a dimension element.

Remarks

This method is a combined action of two steps: a) Making the parameter reporting if it is not yet, and b) Labeling the given dimension with it. Because of that, the parameter must be eligible for reporting - i.e must be of certain types, and must not be used to label more than one dimensions yet.

In case this parameter is already driven by another dimension, the other dimension will be unlabeled first before the given one is labeled. It is because a reporting parameter can only label one dimension at a time (i.e. it can be driven by one dimension only.)

Examples

CopyC#
/// <summary>
/// Make a global parameter to be driven by the value of a dimension.
/// </summary>
/// <param name="document">Revit project document containing the global parameter and dimension elements.</param>
/// <param name="gpid">ElementId of a global parameter.</param>
/// <param name="dimid">ElementId of a dimension element.</param>
public bool AssignDrivingDimension(Document document, ElementId gpid, ElementId dimid)
{
    // we expect to find the global parameter in the document
    GlobalParameter gp = document.GetElement(gpid) as GlobalParameter;
    if (gp == null)
        return false;

    // we expect to find the given dimension in the document
    Dimension dim = document.GetElement(dimid) as Dimension;
    if (dim == null)
        return false;

    // not every global parameter can label
    // and not every dimension can be labeled
    if (!gp.CanLabelDimension(dimid))
        return false;

    // we need a transaction to modify the model
    using (Transaction trans = new Transaction(document,"Assign a driving dimension"))
    {
        trans.Start();

        // we cannot assign a driving dimension to a global
        // parameter that is already used to label other dimensions
        ISet<ElementId> dimset = gp.GetLabeledDimensions();
        foreach (ElementId elemid in dimset)
        {
            gp.UnlabelDimension(elemid);
        }

        // with the GP free of all previously labels (if there were any)
        gp.SetDrivingDimension(dimid);

        // we should be able to commit, but we test the result anyway
        if (trans.Commit() != TransactionStatus.Committed)
            return false;
    }

    return true;
}
CopyVB.NET
' <summary>
' Make a global parameter to be driven by the value of a dimension.
' </summary>
' <param name="document">Revit project document containing the global parameter and dimension elements.</param>
' <param name="gpid">ElementId of a global parameter.</param>
' <param name="dimid">ElementId of a dimension element.</param>
Public Function AssignDrivingDimension(document As Document, gpid As ElementId, dimid As ElementId) As Boolean
    ' we expect to find the global parameter in the document
    Dim gp As GlobalParameter = TryCast(document.GetElement(gpid), GlobalParameter)
    If gp Is Nothing Then
        Return False
    End If

    ' we expect to find the given dimension in the document
    Dim [dim] As Dimension = TryCast(document.GetElement(dimid), Dimension)
    If [dim] Is Nothing Then
        Return False
    End If

    ' not every global parameter can label
    ' and not every dimension can be labeled
    If Not gp.CanLabelDimension(dimid) Then
        Return False
    End If

    ' we need a transaction to modify the model
    Using trans As New Transaction(document, "Assign a driving dimension")
        trans.Start()

        ' we cannot assign a driving dimension to a global
        ' parameter that is already used to label other dimensions
        Dim dimset As ISet(Of ElementId) = gp.GetLabeledDimensions()
        For Each elemid As ElementId In dimset
            gp.UnlabelDimension(elemid)
        Next

        ' with the GP free of all previously labels (if there were any)
        gp.SetDrivingDimension(dimid)

        ' we should be able to commit, but we test the result anyway
        If trans.Commit() <> TransactionStatus.Committed Then
            Return False
        End If
    End Using

    Return True
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Given element Id is not of a valid dimension element. -or- Dimension with the Id of dimensionId cannot be labeled by this global parameter. Possible causes include the dimension cannot be labeled at all, or it is a dimension of other than Linear or Angular type, or the Dimension object does not have the appropriate labeling parameter, or the dimension has more than one segment and the parameter is reporting.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This is a formula-driven parameter. As such it does not allow the current operation. -or- This non-reporting global parameter has already labeled other dimension segments (more then 1). It cannot, therefore, be made reporting and dimension-driven before un-labeling all the dependent dimensions first.

See Also

GlobalParameter Class


SetFormula Method

[image]

Revit 2024 API
GlobalParameter..::..SetFormula Method
GlobalParameter Class Example See Also Send Feedback
Sets a formula expression for this parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Update

Syntax

C#
public void SetFormula(
    string expression
)
Visual Basic
Public Sub SetFormula ( _
    expression As String _
)
Visual C++
public:
void SetFormula(
    String^ expression
)

Parameters

expression
Type: System..::..String
Valid formula string.

Remarks

An assigned expression will compute the parameter's actual value.

In order to set a formula, the global parameter must be non-reporting. Therefore a reporting parameter must be changed to non-reporting first before assigning a formula.

Value of the evaluated formula must be compatible with the value-type of the parameter. For example, it is permitted to use Integer parameters in a formula assigned to a Double (Number) parameter, or vice versa. It is not allowed, however, to use Length or Angle arguments in a formula in a parameter of which type is ether Integer or Number. To test whether a formula is valid for a global parameter, the method IsValidFormula(String) can be used.

An empty string can be used to remove an existing formula. When a formula is removed, the parameter retains its value as it was previously computed using the formula.

Formulas may include all standard arithmetic operations and logical operations (as functions and, or, not.) Input to logical operations must be Boolean values (parameters of YesNo type). Consequently, arithmetic operations can be applied to numeric values only. While there are no operations supported for string (text) arguments, strings can be used as results of a logical If operation.

Examples

CopyC#
/// <summary>
/// Create global parameters and then set a formula to one so it has a value of
/// either of two other parameters depending on the boolean value of the forth one.
/// </summary>
/// <param name="document">Revit project document in which we create global parameters.</param>
public void SetCombinationParameters(Document document)
{
    GlobalParameter gpB = null;
    GlobalParameter gpT = null;
    GlobalParameter gpF = null;
    GlobalParameter gpX = null;

    int TRUE = 1;
    int FALSE = 0;

    // transaction to create global parameters and set their values
    using (Transaction trans = new Transaction(document, "Creating global parameters"))
    {
        // create 4 new global parameters

        trans.Start();

        gpB = GlobalParameter.Create(document, "GPB", SpecTypeId.Boolean.YesNo);
        gpT = GlobalParameter.Create(document, "GPT", SpecTypeId.String.Text);
        gpF = GlobalParameter.Create(document, "GPF", SpecTypeId.String.Text);
        gpX = GlobalParameter.Create(document, "GPX", SpecTypeId.String.Text);

        // assign initial values and a formula to the global parameters

        gpB.SetValue(new IntegerParameterValue(TRUE));
        gpT.SetValue(new StringParameterValue("TypeA"));
        gpF.SetValue(new StringParameterValue("TypeB"));

        // Set the formula to GPX so that its final value is either the value of GPT (TypeA)
        // or GPF (TypeB) depending on whether the value of GPB is True or False.
        // Note: in this particular case we are certain the formula is valid, but if weren't
        // certain, we could use a validation method as we are now going to illustrate here:
        string expression = "if(GPB,GPT,GPF)"; // XPX <== if (GPB == TRUE) then GPT else GPF
        if (gpX.IsValidFormula(expression))
        {
            gpX.SetFormula(expression);
        }

        trans.Commit();
    }

    // we can test that the formula works
    // since the boolean value is TRUE, the value of the GPX parameter
    // should be the same as the value of the GPT parameters

    StringParameterValue sTrue = gpT.GetValue() as StringParameterValue;
    StringParameterValue sFalse = gpF.GetValue() as StringParameterValue;
    StringParameterValue sValue = gpX.GetValue() as StringParameterValue;

    if (sValue.Value != sTrue.Value)
    {
        TaskDialog.Show("Error", "Unexpected value of a global parameter");
    }

    // we can also test that evaluation of the formula is affected by changes

    using (Transaction trans = new Transaction(document, "Change value of a YesNo parameter"))
    {
        trans.Start();
        gpB.SetValue(new IntegerParameterValue(FALSE));
        trans.Commit();
    }

    sValue = gpX.GetValue() as StringParameterValue;

    if (sValue.Value != sFalse.Value)
    {
        TaskDialog.Show("Error", "Unexpected value of a global parameter");
    }

}
CopyVB.NET
' <summary>
' Create global parameters and then set a formula to one so it has a value of
' either of two other parameters depending on the boolean value of the forth one.
' </summary>
' <param name="document">Revit project document in which we create global parameters.</param>
Public Sub SetCombinationParameters(document As Document)
    Dim gpB As GlobalParameter = Nothing
    Dim gpT As GlobalParameter = Nothing
    Dim gpF As GlobalParameter = Nothing
    Dim gpX As GlobalParameter = Nothing

    Dim [TRUE] As Integer = 1
    Dim [FALSE] As Integer = 0

    ' transaction to create global parameters and set their values
    Using trans As New Transaction(document, "Creating global parameters")
        ' create 4 new global parameters

        trans.Start()

    gpB = GlobalParameter.Create(document, "GPB", SpecTypeId.Boolean.YesNo)
    gpT = GlobalParameter.Create(document, "GPT", SpecTypeId.String.Text)
    gpF = GlobalParameter.Create(document, "GPF", SpecTypeId.String.Text)
    gpX = GlobalParameter.Create(document, "GPX", SpecTypeId.String.Text)

    ' assign initial values and a formula to the global parameters

    gpB.SetValue(New IntegerParameterValue([TRUE]))
        gpT.SetValue(New StringParameterValue("TypeA"))
        gpF.SetValue(New StringParameterValue("TypeB"))

        ' Set the formula to GPX so that its final value is either the value of GPT (TypeA)
        ' or GPF (TypeB) depending on whether the value of GPB is True or False.
        ' Note: in this particular case we are certain the formula is valid, but if weren't
        ' certain, we could use a validation method as we are now going to illustrate here:
        Dim expression As String = "if(GPB,GPT,GPF)"
        ' XPX <== if (GPB == TRUE) then GPT else GPF
        If gpX.IsValidFormula(expression) Then
            gpX.SetFormula(expression)
        End If

        trans.Commit()
    End Using

    ' we can test that the formula works
    ' since the boolean value is TRUE, the value of the GPX parameter
    ' should be the same as the value of the GPT parameters

    Dim sTrue As StringParameterValue = TryCast(gpT.GetValue(), StringParameterValue)
    Dim sFalse As StringParameterValue = TryCast(gpF.GetValue(), StringParameterValue)
    Dim sValue As StringParameterValue = TryCast(gpX.GetValue(), StringParameterValue)

    If sValue.Value <> sTrue.Value Then
        TaskDialog.Show("Error", "Unexpected value of a global parameter")
    End If

    ' we can also test that evaluation of the formula is affected by changes

    Using trans As New Transaction(document, "Change value of a YesNo parameter")
        trans.Start()
        gpB.SetValue(New IntegerParameterValue([FALSE]))
        trans.Commit()
    End Using

    sValue = TryCast(gpX.GetValue(), StringParameterValue)

    If sValue.Value <> sFalse.Value Then
        TaskDialog.Show("Error", "Unexpected value of a global parameter")
    End If

End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given expression argument is not valid as a formula for this parameter.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This is a non-reporting global parameter. As such it does not allow the current operation.

See Also

GlobalParameter Class


UnlabelDimension Method

[image]

Revit 2024 API
GlobalParameter..::..UnlabelDimension Method
GlobalParameter Class See Also Send Feedback
Unlabels a dimension that is currently labeled by this global parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Update

Syntax

C#
public void UnlabelDimension(
    ElementId dimensionId
)
Visual Basic
Public Sub UnlabelDimension ( _
    dimensionId As ElementId _
)
Visual C++
public:
void UnlabelDimension(
    ElementId^ dimensionId
)

Parameters

dimensionId
Type: Autodesk.Revit.DB..::..ElementId
Id of a dimension element.

Remarks

It is assumed that the given dimension element is presently labeled by this parameter. If it is not, this method throws an exception.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Given element Id is not of a valid dimension element. -or- The given dimension (dimensionId) is not labeled by this global parameter.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

GlobalParameter Class


IsDrivenByDimension Property

[image]

Revit 2024 API
GlobalParameter..::..IsDrivenByDimension Property
GlobalParameter Class See Also Send Feedback
Indicates whether this parameter is driven by a dimension or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Update

Syntax

C#
public bool IsDrivenByDimension { get; }
Visual Basic
Public ReadOnly Property IsDrivenByDimension As Boolean
    Get
Visual C++
public:
property bool IsDrivenByDimension {
    bool get ();
}

Remarks

Only reporting parameters can be driven by dimensions. Thus, to drive a parameter by a dimension, the parameter must first be set as reporting before it is used to label the driving dimension.

Note that the value of this property is always the opposite of the IsDrivenByFormula property. It is so because a parameter of which value is evaluated by a formula cannot be driven by a dimension, and vice versa.

See Also

GlobalParameter Class


IsReporting Property

[image]

Revit 2024 API
GlobalParameter..::..IsReporting Property
GlobalParameter Class See Also Send Feedback
Indicates whether this is a reporting global parameter or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Update

Syntax

C#
public bool IsReporting { get; set; }
Visual Basic
Public Property IsReporting As Boolean
    Get
    Set
Visual C++
public:
property bool IsReporting {
    bool get ();
    void set (bool value);
}

Field Value

True if the parameter is reporting, False otherwise.

Remarks

When a global parameter is declared as reporting, it takes its value from the one driving dimension it is set to label. To be declared as reporting, a parameter must be labeling no more than one single-segment dimension. If a global parameter is not labeling any dimensions at the time it is declared as reporting, its value stays unchanged until a driving dimension is labeled with it.

Reporting parameters can be (currently) only of type Length or Angle, but programmers can always call the HasValidTypeForReporting()()()() first when in doubt about whether a global parameter has a data type eligible for reporting.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: This is a formula-driven parameter. As such it does not allow the current operation. -or- When setting this property: This non-reporting global parameter has already labeled other dimensions (more then 1). It cannot, therefore, be made reporting and dimension-driven before un-labeling all the dependent dimensions first. -or- When setting this property: The global parameter is not of a type that may be used with reporting. Generally, a reporting parameter must be either of type Length or Angle. -or- When setting this property: Currently reporting parameters may not be changed if they are driven by a dimension that cannot have its value set by a global parameter, such as an arc-length, locked, or multi-segment dimension.

See Also

GlobalParameter Class


Parameter Property

[image] [image]

Revit 2024 API
GlobalParameter..::..Parameter Property
GlobalParameter Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

GlobalParameter Class
GlobalParameter Members


GlobalParametersManager Members

[image] [image]

Revit 2024 API
GlobalParametersManager Members
GlobalParametersManager Class Methods Properties See Also Send Feedback

The GlobalParametersManager type exposes the following members.

Methods

 | Name | Description
 | AreGlobalParametersAllowed | Tests whether global parameters are allowed in the given document.
Public method | Dispose | Releases all resources used by the GlobalParametersManager
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FindByName | Finds whether a global parameter with the given name exists in the input document.
 | GetAllGlobalParameters | Returns all global parameters available in the given document.
 | GetGlobalParametersOrdered | Returns all global paramters in an ordered array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsUniqueName | Tests whether a name is unique among existing global parameters of a given document.
 | IsValidGlobalParameter | Tests whether an ElementId is of a global parameter in the given document.
 | MoveParameterDownOrder | Moves given paramerer Down in the current order.
 | MoveParameterUpOrder | Moves given paramerer Up in the current order.
 | SortParameters | Sorts global parameters in the desired order.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

GlobalParametersManager Class


AreGlobalParametersAllowed Method

[image]

Revit 2024 API
GlobalParametersManager..::..AreGlobalParametersAllowed Method
GlobalParametersManager Class Example See Also Send Feedback
Tests whether global parameters are allowed in the given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Update

Syntax

C#
public static bool AreGlobalParametersAllowed(
    Document document
)
Visual Basic
Public Shared Function AreGlobalParametersAllowed ( _
    document As Document _
) As Boolean
Visual C++
public:
static bool AreGlobalParametersAllowed(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
A revit document of interest.

Remarks

First of all, global parameters can be had in main project documents only; they are not supported in family documents. However, there may also be other circumstances due to which global parameters may be disallowed in a particular project, either temporarily or permanently.

Examples

CopyC#
/// <summary>
/// Tests whether there are any global parameters present in the given document
/// </summary>
/// <param name="document">Revit project document.</param>
/// <returns>A set of ElementIds of global parameter elements</returns>
public bool ContainsGlobalParameters(Document document)
{
    // Global parameters are not available in all documents.
    // They are available in projects, but not in families.
    if (GlobalParametersManager.AreGlobalParametersAllowed(document))
    {
        return (GlobalParametersManager.GetAllGlobalParameters(document).Count > 0);
    }

    return false;
}
CopyVB.NET
' <summary>
' Tests whether there are any global parameters present in the given document
' </summary>
' <param name="document">Revit project document.</param>
' <returns>A set of ElementIds of global parameter elements</returns>
Public Function ContainsGlobalParameters(document As Document) As Boolean
    ' Global parameters are not available in all documents.
    ' They are available in projects, but not in families.
    If GlobalParametersManager.AreGlobalParametersAllowed(document) Then
        Return (GlobalParametersManager.GetAllGlobalParameters(document).Count > 0)
    End If

    Return False
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

GlobalParametersManager Class


Dispose Method

[image]

Revit 2024 API
GlobalParametersManager..::..Dispose Method
GlobalParametersManager Class See Also Send Feedback
Releases all resources used by the GlobalParametersManager

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

GlobalParametersManager Class


FindByName Method

[image]

Revit 2024 API
GlobalParametersManager..::..FindByName Method
GlobalParametersManager Class Example See Also Send Feedback
Finds whether a global parameter with the given name exists in the input document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Update

Syntax

C#
public static ElementId FindByName(
    Document document,
    string name
)
Visual Basic
Public Shared Function FindByName ( _
    document As Document, _
    name As String _
) As ElementId
Visual C++
public:
static ElementId^ FindByName(
    Document^ document,
    String^ name
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document expected to contain the global parameter.
name
Type: System..::..String
Name of the global parameter

Return Value

ElementId of the parameter element, or InvalidElementId if it was not found.

Remarks

No exception is thrown when no parameter with such a name exists in the document; instead, the method returns an ElementId.InvalidElementId.

Examples

CopyC#
/// <summary>
/// Tries to find a global parameter by its name.
/// </summary>
/// <param name="document">Revit project document.</param>
/// <param name="name">Name of a global parameter.</param>
/// <returns>An Element Id of the global parameter, or InvalidElementId if none found</returns>
public ElementId GetGlobalParameterByName(Document document, String name)
{
    // Global parameters are not available in all documents.
    // They are available in projects, but not in families.
    if (GlobalParametersManager.AreGlobalParametersAllowed(document))
    {
        return GlobalParametersManager.FindByName(document, name);
    }

    // return an empty set if global parameters are not available in the document
    return ElementId.InvalidElementId;
}
CopyVB.NET
' <summary>
' Tries to find a global parameter by its name.
' </summary>
' <param name="document">Revit project document.</param>
' <param name="name">Name of a global parameter.</param>
' <returns>An Element Id of the global parameter, or InvalidElementId if none found</returns>
Public Function GetGlobalParameterByName(document As Document, name As [String]) As ElementId
    ' Global parameters are not available in all documents.
    ' They are available in projects, but not in families.
    If GlobalParametersManager.AreGlobalParametersAllowed(document) Then
        Return GlobalParametersManager.FindByName(document, name)
    End If

    ' return an empty set if global parameters are not available in the document
    Return ElementId.InvalidElementId
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

GlobalParametersManager Class


GetAllGlobalParameters Method

[image]

Revit 2024 API
GlobalParametersManager..::..GetAllGlobalParameters Method
GlobalParametersManager Class Example See Also Send Feedback
Returns all global parameters available in the given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Update

Syntax

C#
public static ISet<ElementId> GetAllGlobalParameters(
    Document document
)
Visual Basic
Public Shared Function GetAllGlobalParameters ( _
    document As Document _
) As ISet(Of ElementId)
Visual C++
public:
static ISet<ElementId^>^ GetAllGlobalParameters(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document containing the global parameters

Return Value

A collection of Element Ids of global parameter elements.

Examples

CopyC#
/// <summary>
/// Returns all global parameter elements defined in the given document.
/// </summary>
/// <param name="document">Revit project document.</param>
/// <returns>A set of ElementIds of global parameter elements</returns>
public ISet<ElementId> GetAllGlobalParameters(Document document)
{
    // Global parameters are not available in all documents.
    // They are available in projects, but not in families.
    if (GlobalParametersManager.AreGlobalParametersAllowed(document))
    {
        return GlobalParametersManager.GetAllGlobalParameters(document);
    }

    // return an empty set if global parameters are not available in the document
    return new HashSet<ElementId>();
}
CopyVB.NET
' <summary>
' Returns all global parameter elements defined in the given document.
' </summary>
' <param name="document">Revit project document.</param>
' <returns>A set of ElementIds of global parameter elements</returns>
Public Function GetAllGlobalParameters(document As Document) As ISet(Of ElementId)
    ' Global parameters are not available in all documents.
    ' They are available in projects, but not in families.
    If GlobalParametersManager.AreGlobalParametersAllowed(document) Then
        Return GlobalParametersManager.GetAllGlobalParameters(document)
    End If

    ' return an empty set if global parameters are not available in the document
    Return New HashSet(Of ElementId)()
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Global parameters are not supported in the given document. A possible cause is that it is not a project document, for global parameters are not supported in Revit families.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

GlobalParametersManager Class


IsUniqueName Method

[image]

Revit 2024 API
GlobalParametersManager..::..IsUniqueName Method
GlobalParametersManager Class Example See Also Send Feedback
Tests whether a name is unique among existing global parameters of a given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Update

Syntax

C#
public static bool IsUniqueName(
    Document document,
    string name
)
Visual Basic
Public Shared Function IsUniqueName ( _
    document As Document, _
    name As String _
) As Boolean
Visual C++
public:
static bool IsUniqueName(
    Document^ document,
    String^ name
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Document in which a new parameter is to be added.
name
Type: System..::..String
A name of a parameter being added.

Return Value

True if the given %name% does not exist yet among existing global parameters nof the document; False otherwise.

Remarks

Typically, this method is used before a new global parameters is created, for all global parameters must have their names unique in the scope of a document.

Examples

CopyC#
/// <summary>
/// Creates or finds a global parameter of a given name.
/// </summary>
/// <param name="document">Revit project document.</param>
/// <param name="name">Name of a global parameter.</param>
/// <returns>An Element Id of the global parameter</returns>
public GlobalParameter GetOrCreateAGlobalParameter(Document document, String name)
{
    GlobalParameter gp = null;

    // Global parameters are not available in all documents.
    // They are available in projects, but not in families.
    if (GlobalParametersManager.AreGlobalParametersAllowed(document))
    {
        if (GlobalParametersManager.IsUniqueName(document,name))
        {
            // if the name is not unique, the global parameter must exist already
            gp = document.GetElement(GlobalParametersManager.FindByName(document, name)) as GlobalParameter;
        }
        else
        {
            // A global parameter with such a name does not exist yet;
            // Let's create a new one (assume the type is Number)
            using (Transaction trans = new Transaction(document, "Create Global Parameter"))
            {
                trans.Start();
                gp = GlobalParameter.Create(document,name, SpecTypeId.Number);
                trans.Commit();
            }
        }
    }

    return gp;
}
CopyVB.NET
' <summary>
' Creates or finds a global parameter of a given name.
' </summary>
' <param name="document">Revit project document.</param>
' <param name="name">Name of a global parameter.</param>
' <returns>An Element Id of the global parameter</returns>
Public Function GetOrCreateAGlobalParameter(document As Document, name As [String]) As GlobalParameter
    Dim gp As GlobalParameter = Nothing

    ' Global parameters are not available in all documents.
    ' They are available in projects, but not in families.
    If GlobalParametersManager.AreGlobalParametersAllowed(document) Then
        If GlobalParametersManager.IsUniqueName(document, name) Then
            ' if the name is not unique, the global parameter must exist already
            gp = TryCast(document.GetElement(GlobalParametersManager.FindByName(document, name)), GlobalParameter)
        Else
            ' A global parameter with such a name does not exist yet;
            ' Let's create a new one (assume the type is Number)
            Using trans As New Transaction(document, "Create Global Parameter")
                trans.Start()
          gp = GlobalParameter.Create(document, name, SpecTypeId.Number)
          trans.Commit()
            End Using
        End If
    End If

    Return gp
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

GlobalParametersManager Class


MoveParameterUpOrder Method

[image]

Revit 2024 API
GlobalParametersManager..::..MoveParameterUpOrder Method
GlobalParametersManager Class See Also Send Feedback
Moves given paramerer Up in the current order.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public static bool MoveParameterUpOrder(
    Document document,
    ElementId parameterId
)
Visual Basic
Public Shared Function MoveParameterUpOrder ( _
    document As Document, _
    parameterId As ElementId _
) As Boolean
Visual C++
public:
static bool MoveParameterUpOrder(
    Document^ document,
    ElementId^ parameterId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Document containing the give global parameter
parameterId
Type: Autodesk.Revit.DB..::..ElementId
The parameter to move up

Return Value

Indicates whether the parameter could be moved Up in order or not.

Remarks

A parameter can only be moved within its parameter group, meaning that repeated moving a parameter will not push the parameter out of and into the next (in order) parameter group. When a parameter can no longer move because it is at the boundary of its group, this method returns False.

This operation has no effect on the global parameters themselves. The rearranged order is only visible in the standard Global Parameters dialog. However, the order of parameters is serialized in the document, thus available on the DB level as well.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Global parameters are not supported in the given document. A possible cause is that it is not a project document, for global parameters are not supported in Revit families. -or- The input parameterId is not of a valid global parameter of the given document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

GlobalParametersManager Class


IsValidObject Property

[image]

Revit 2024 API
GlobalParametersManager..::..IsValidObject Property
GlobalParametersManager Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

GlobalParametersManager Class


GradientBackgroundSettings Members

[image] [image]

Revit 2024 API
GradientBackgroundSettings Members
GradientBackgroundSettings Class Methods Properties See Also Send Feedback

The GradientBackgroundSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from BackgroundSettings.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | GroundColor | The color of the ground.
Public property | HorizonColor | The color of the horizon.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BackgroundSettings.)
Public property | SkyColor | The color of the top of the sky.

See Also

GradientBackgroundSettings Class


GradientBackgroundSettings Methods

[image] [image]

Revit 2024 API
GradientBackgroundSettings Methods
GradientBackgroundSettings Class See Also Send Feedback

The GradientBackgroundSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from BackgroundSettings.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

GradientBackgroundSettings Class


GradientBackgroundSettings Properties

[image] [image]

Revit 2024 API
GradientBackgroundSettings Properties
GradientBackgroundSettings Class See Also Send Feedback

The GradientBackgroundSettings type exposes the following members.

Properties

 | Name | Description
Public property | GroundColor | The color of the ground.
Public property | HorizonColor | The color of the horizon.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BackgroundSettings.)
Public property | SkyColor | The color of the top of the sky.

See Also

GradientBackgroundSettings Class


GroundColor Property

[image]

Revit 2024 API
GradientBackgroundSettings..::..GroundColor Property
GradientBackgroundSettings Class See Also Send Feedback
The color of the ground.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public Color GroundColor { get; set; }
Visual Basic
Public Property GroundColor As Color
    Get
    Set
Visual C++
public:
property Color^ GroundColor {
    Color^ get ();
    void set (Color^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

GradientBackgroundSettings Class


HorizonColor Property

[image]

Revit 2024 API
GradientBackgroundSettings..::..HorizonColor Property
GradientBackgroundSettings Class See Also Send Feedback
The color of the horizon.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public Color HorizonColor { get; set; }
Visual Basic
Public Property HorizonColor As Color
    Get
    Set
Visual C++
public:
property Color^ HorizonColor {
    Color^ get ();
    void set (Color^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

GradientBackgroundSettings Class


SkyColor Property

[image]

Revit 2024 API
GradientBackgroundSettings..::..SkyColor Property
GradientBackgroundSettings Class See Also Send Feedback
The color of the top of the sky.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public Color SkyColor { get; set; }
Visual Basic
Public Property SkyColor As Color
    Get
    Set
Visual C++
public:
property Color^ SkyColor {
    Color^ get ();
    void set (Color^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

GradientBackgroundSettings Class


GraphicsStyle Members

[image] [image]

Revit 2024 API
GraphicsStyle Members
GraphicsStyle Class Methods Properties See Also Send Feedback

The GraphicsStyle type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GraphicsStyleCategory | The graphics style category.
Public property | GraphicsStyleType | The graphics style type.
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

GraphicsStyle Class


GraphicsStyle Methods

[image] [image]

Revit 2024 API
GraphicsStyle Methods
GraphicsStyle Class See Also Send Feedback

The GraphicsStyle type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

GraphicsStyle Class


GraphicsStyle Properties

[image] [image]

Revit 2024 API
GraphicsStyle Properties
GraphicsStyle Class See Also Send Feedback

The GraphicsStyle type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GraphicsStyleCategory | The graphics style category.
Public property | GraphicsStyleType | The graphics style type.
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

GraphicsStyle Class


GraphicsStyleCategory Property

[image]

Revit 2024 API
GraphicsStyle..::..GraphicsStyleCategory Property
GraphicsStyle Class See Also Send Feedback
The graphics style category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Category GraphicsStyleCategory { get; }
Visual Basic
Public ReadOnly Property GraphicsStyleCategory As Category
    Get
Visual C++
public:
property Category^ GraphicsStyleCategory {
    Category^ get ();
}

See Also

GraphicsStyle Class


GraphicsStyleType Property

[image]

Revit 2024 API
GraphicsStyle..::..GraphicsStyleType Property
GraphicsStyle Class See Also Send Feedback
The graphics style type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public GraphicsStyleType GraphicsStyleType { get; }
Visual Basic
Public ReadOnly Property GraphicsStyleType As GraphicsStyleType
    Get
Visual C++
public:
property GraphicsStyleType GraphicsStyleType {
    GraphicsStyleType get ();
}

See Also

GraphicsStyle Class


Parameter Property

[image] [image]

Revit 2024 API
GraphicsStyle..::..Parameter Property
GraphicsStyle Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

GraphicsStyle Class
GraphicsStyle Members


GraphicsStyleType Enumeration

[image]

Revit 2024 API
GraphicsStyleType Enumeration
See Also Send Feedback
Describes the type of graphics style.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum GraphicsStyleType
Visual Basic
Public Enumeration GraphicsStyleType
Visual C++
public enum class GraphicsStyleType

Members

Member name | Description
Projection | Projection.
Cut | Cut.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


Grid Class

[image]

Revit 2024 API
Grid Class
Members Example See Also Send Feedback
Represents a single grid line within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class Grid : DatumPlane
Visual Basic
Public Class Grid _
    Inherits DatumPlane
Visual C++
public ref class Grid : public DatumPlane

Remarks

A Grid is a DatumPlane, so it is actually a three dimensional surface. It can be either a plane parallel to the project z-axis, or else a cylinder whose axis is parallel to the project z-xis. [!:Autodesk::Revit::DatumPlane]

Examples

CopyC#
public void GetInfo_Grid(Grid grid)
{
    string message = "Grid : ";

    // Show IsCurved property
    message += "\nIf grid is Arc : " + grid.IsCurved;

    // Show Curve information
    Autodesk.Revit.DB.Curve curve = grid.Curve;
    if (grid.IsCurved)
    {
        // if the curve is an arc, give center and radius information
        Autodesk.Revit.DB.Arc arc = curve as Autodesk.Revit.DB.Arc;
        message += "\nArc's radius: " + arc.Radius;
        message += "\nArc's center:  (" + XYZToString(arc.Center);
    }
    else
    {
        // if the curve is a line, give length information
        Autodesk.Revit.DB.Line line = curve as Autodesk.Revit.DB.Line;
        message += "\nLine's Length: " + line.Length;
    }
    // Get curve start point
    message += "\nStart point: " + XYZToString(curve.GetEndPoint(0));
    // Get curve end point
    message += "; End point: " + XYZToString(curve.GetEndPoint(0));

    TaskDialog.Show("Revit",message);
}

// output the point's three coordinates
string XYZToString(XYZ point)
{
    return "(" + point.X + ", " + point.Y + ", " + point.Z + ")";
}
CopyVB.NET
Public Sub GetInfo_Grid(grid As Grid)
    Dim message As String = "Grid : "

    ' Show IsCurved property
    message += vbLf & "If grid is Arc : " & Convert.ToString(grid.IsCurved)

    ' Show Curve information
    Dim curve As Autodesk.Revit.DB.Curve = grid.Curve
    If grid.IsCurved Then
        ' if the curve is an arc, give center and radius information
        Dim arc As Autodesk.Revit.DB.Arc = TryCast(curve, Autodesk.Revit.DB.Arc)
        message += vbLf & "Arc's radius: " + arc.Radius
        message += vbLf & "Arc's center:  (" & XYZToString(arc.Center)
    Else
        ' if the curve is a line, give length information
        Dim line As Autodesk.Revit.DB.Line = TryCast(curve, Autodesk.Revit.DB.Line)
        message += vbLf & "Line's Length: " + line.Length
    End If
    ' Get curve start point
    message += vbLf & "Start point: " & XYZToString(curve.GetEndPoint(0))
    ' Get curve end point
    message += "; End point: " & XYZToString(curve.GetEndPoint(0))

    TaskDialog.Show("Revit", message)
End Sub

' output the point's three coordinates
Private Function XYZToString(point As XYZ) As String
    Return "(" & Convert.ToString(point.X) & ", " & Convert.ToString(point.Y) & ", " & Convert.ToString(point.Z) & ")"
End Function

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..DatumPlane
Autodesk.Revit.DB..::..Grid

See Also

Grid Members


Grid Members

[image] [image]

Revit 2024 API
Grid Members
Grid Class Methods Properties See Also Send Feedback

The Grid type exposes the following members.

Methods

 | Name | Description
Public method | AddLeader | Adds a default Leader for the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders). (Inherited from DatumPlane.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanBeVisibleInView | Checks if the datum plane can be visible in the view. (Inherited from DatumPlane.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create(Document, Arc) | Creates a new radial grid line.
 | Create(Document, Line) | Creates a new grid line.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetCurvesInView | Gets a collection of curves representing the DatumPlane element in the given view. (Inherited from DatumPlane.)
Public method | GetDatumExtentTypeInView | Identifies whether the curve representing the datum plane is displayed according to its actual 3d extents, or else according to a view specific setting. (Inherited from DatumPlane.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExtents | Gets the extents of the grid in the model.
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLeader | Gets a copy of the leader applied to the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders). (Inherited from DatumPlane.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPropagationViews | Gets a list of candidate views which are parallel to the current view and to which the extents of the datum may be propagated. (Inherited from DatumPlane.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasBubbleInView | Identifies if the DatumPlane has bubble or not. (Inherited from DatumPlane.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HideBubbleInView | Hides the bubble in a view. This method does not apply to Reference planes. (Inherited from DatumPlane.)
Public method | IsBubbleVisibleInView | Identifies if the bubble is visible or not in a view. (Inherited from DatumPlane.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsCurveValidInView | Checks if the curve is valid to be as the extents for the datum plane in a view. The curve must be bound and coincident with the original one of the datum plane. (Inherited from DatumPlane.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsLeaderValid | Identifies if the leader valid or not for this DatumPlane. This method does not apply to Reference planes (which do not support leaders). (Inherited from DatumPlane.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | Maximize3DExtents | Computes the 3d extents of all model geometry and levels, and extends the 3d extents of this datum surface to include the model extents. (Inherited from DatumPlane.)
Public method | PropagateToViews | Propagates the extents applied to this datum in the view to the specified parallel views. (Inherited from DatumPlane.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetCurveInView | Sets the extents to match the curve. (Inherited from DatumPlane.)
Public method | SetDatumExtentType | Sets whether the curve representing the datum plane is displayed according to its 3d extents, or else according to a view specific setting. (Inherited from DatumPlane.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetLeader | Sets the leader to the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders). (Inherited from DatumPlane.)
Public method | SetVerticalExtents | Adjusts the grid to extend through only the vertical range between bottom and top.
Public method | ShowBubbleInView | Shows the bubble in a view. This method does not apply to Reference planes. (Inherited from DatumPlane.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | Curve | Retrieves an object that represents the geometry of the grid line.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsCurved | Identifies if the grid line is curved or straight.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Grid Class


Create Method

[image] [image]

Revit 2024 API
Grid..::..Create Method
Grid Class See Also Send Feedback

Overload List

Name | Description
Create(Document, Arc) | Creates a new radial grid line.
Create(Document, Line) | Creates a new grid line.

See Also

Grid Class
Grid Members


Create Method (Document, Arc)

[image]

Revit 2024 API
Grid..::..Create Method (Document, Arc)
Grid Class Example See Also Send Feedback
Creates a new radial grid line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static Grid Create(
    Document document,
    Arc arc
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    arc As Arc _
) As Grid
Visual C++
public:
static Grid^ Create(
    Document^ document,
    Arc^ arc
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which the new instance is created.
arc
Type: Autodesk.Revit.DB..::..Arc
An arc object that represents the location of the new grid line.

Return Value

The newly created grid line.

Remarks

The arc should be on a horizontal plane.

Examples

CopyC#
// Create the geometry arc which the grid locates
XYZ end0 = new XYZ(0, 0, 0);
XYZ end1 = new XYZ(10, 40, 0);
XYZ pointOnCurve = new XYZ(5, 7, 0);
Arc geomArc = Arc.Create(end0, end1, pointOnCurve);

// Create a grid using the geometry arc
Grid arcGrid = Grid.Create(document, geomArc);

if (null == arcGrid)
{
    throw new Exception("Create a new curved grid failed.");
}

// Modify the name of the created grid
arcGrid.Name = "New Name2";
CopyVB.NET
   ' Create the geometry arc which the grid locates
   Dim end0 As New XYZ(0, 0, 0)
   Dim end1 As New XYZ(10, 40, 0)
   Dim pointOnCurve As New XYZ(5, 7, 0)
   Dim geomArc As Arc = Arc.Create(end0, end1, pointOnCurve)

   ' Create a grid using the geometry arc
Dim arcGrid As Grid = Grid.Create(document, geomArc)

   If arcGrid Is Nothing Then
       Throw New Exception("Create a new curved grid failed.")
   End If

   ' Modify the name of the created grid
   arcGrid.Name = "New Name2"

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- The input arc is not on horizontal plane.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Grid Class
Create Overload


Create Method (Document, Line)

[image]

Revit 2024 API
Grid..::..Create Method (Document, Line)
Grid Class Example See Also Send Feedback
Creates a new grid line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static Grid Create(
    Document document,
    Line line
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    line As Line _
) As Grid
Visual C++
public:
static Grid^ Create(
    Document^ document,
    Line^ line
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which the new instance is created.
line
Type: Autodesk.Revit.DB..::..Line
A line which represents the location of the grid line.

Return Value

The newly created grid line.

Remarks

The line should be on a horizontal plane.

Examples

CopyC#
// Create the geometry line which the grid locates
 XYZ start = new XYZ(0, 0, 0);
 XYZ end = new XYZ(30, 30, 0);
 Line geomLine = Line.CreateBound(start, end);

 // Create a grid using the geometry line
 Grid lineGrid = Grid.Create(document, geomLine);

 if (null == lineGrid)
 {
     throw new Exception("Create a new straight grid failed.");
 }

 // Modify the name of the created grid
 lineGrid.Name = "New Name1";
CopyVB.NET
   ' Create the geometry line which the grid locates
   Dim start As New XYZ(0, 0, 0)
   Dim [end] As New XYZ(30, 30, 0)
   Dim geomLine As Line = Line.CreateBound(start, [end])

   ' Create a grid using the geometry line
Dim lineGrid As Grid = Grid.Create(document, geomLine)

   If lineGrid Is Nothing Then
       Throw New Exception("Create a new straight grid failed.")
   End If

   ' Modify the name of the created grid
   lineGrid.Name = "New Name1"

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- The input line is not on horizontal plane.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Grid Class
Create Overload


GetExtents Method

[image]

Revit 2024 API
Grid..::..GetExtents Method
Grid Class See Also Send Feedback
Gets the extents of the grid in the model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public Outline GetExtents()
Visual Basic
Public Function GetExtents As Outline
Visual C++
public:
Outline^ GetExtents()

Return Value

The extents are the 3D bounding box surrounding the grid. The Z coordinates of the box are used by Revit to determine if the grid should be displayed in a corresponding view plan (if the grid is linear). The extents are not used for arc grids.

See Also

Grid Class


SetVerticalExtents Method

[image]

Revit 2024 API
Grid..::..SetVerticalExtents Method
Grid Class See Also Send Feedback
Adjusts the grid to extend through only the vertical range between bottom and top.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public void SetVerticalExtents(
    double bottom,
    double top
)
Visual Basic
Public Sub SetVerticalExtents ( _
    bottom As Double, _
    top As Double _
)
Visual C++
public:
void SetVerticalExtents(
    double bottom,
    double top
)

Parameters

bottom
Type: System..::..Double
The bottom range of the grid extents. It must be a valid number and below the top range.
top
Type: System..::..Double
The top range of the grid extents. It must be a valid number and above the bottom range.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The bottom and top ranges are reversed for the extents.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given value for bottom must be no more than 30000 feet in absolute value. -or- The given value for top must be no more than 30000 feet in absolute value.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Couldn't change the extents of the grid.

See Also

Grid Class


Grid Properties

[image] [image]

Revit 2024 API
Grid Properties
Grid Class See Also Send Feedback

The Grid type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | Curve | Retrieves an object that represents the geometry of the grid line.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsCurved | Identifies if the grid line is curved or straight.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Grid Class


Curve Property

[image]

Revit 2024 API
Grid..::..Curve Property
Grid Class See Also Send Feedback
Retrieves an object that represents the geometry of the grid line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Curve Curve { get; }
Visual Basic
Public ReadOnly Property Curve As Curve
    Get
Visual C++
public:
property Curve^ Curve {
    Curve^ get ();
}

Remarks

The geometry can either be an arc or a curve. The IsCurved property can be used to determine this.

See Also

Grid Class


IsCurved Property

[image]

Revit 2024 API
Grid..::..IsCurved Property
Grid Class See Also Send Feedback
Identifies if the grid line is curved or straight.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsCurved { get; }
Visual Basic
Public ReadOnly Property IsCurved As Boolean
    Get
Visual C++
public:
property bool IsCurved {
    bool get ();
}

Remarks

A value of True is returned if the grid line is an arc or False if the grid line is straight. Use the Curve property to retrieve an object that represents the geometry of the grid line.

See Also

Grid Class


Parameter Property

[image] [image]

Revit 2024 API
Grid..::..Parameter Property
Grid Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Grid Class
Grid Members


GridNode Structure

[image]

Revit 2024 API
GridNode Structure
Members See Also Send Feedback
A structure that represents a particular location in (U,V) from a grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public struct GridNode
Visual Basic
Public Structure GridNode
Visual C++
public value class GridNode

See Also

GridNode Members


GridNode Members

[image] [image]

Revit 2024 API
GridNode Members
GridNode Structure Constructors Methods Properties See Also Send Feedback

The GridNode type exposes the following members.

Constructors

 | Name | Description
Public method | GridNode | Initializes a new instance of the GridNode class

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Properties

 | Name | Description
Public property | UIndex | The node's index along the U axis.
Public property | VIndex | The node's index along the V axis.

See Also

GridNode Structure


GridNode Methods

[image] [image]

Revit 2024 API
GridNode Methods
GridNode Structure See Also Send Feedback

The GridNode type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

GridNode Structure


GridNode Properties

[image] [image]

Revit 2024 API
GridNode Properties
GridNode Structure See Also Send Feedback

The GridNode type exposes the following members.

Properties

 | Name | Description
Public property | UIndex | The node's index along the U axis.
Public property | VIndex | The node's index along the V axis.

See Also

GridNode Structure


UIndex Property

[image]

Revit 2024 API
GridNode..::..UIndex Property
GridNode Structure See Also Send Feedback
The node's index along the U axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public int UIndex { get; set; }
Visual Basic
Public Property UIndex As Integer
    Get
    Set
Visual C++
public:
property int UIndex {
    int get ();
    void set (int value);
}

See Also

GridNode Structure


GridNodeLocation Enumeration

[image]

Revit 2024 API
GridNodeLocation Enumeration
See Also Send Feedback
Location of a grid node relative to the face boundary. See DividedSurface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum GridNodeLocation
Visual Basic
Public Enumeration GridNodeLocation
Visual C++
public enum class GridNodeLocation

Members

Member name | Description
Interior |
Boundary |
Exterior |

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


GridType Members

[image] [image]

Revit 2024 API
GridType Members
GridType Class Methods Properties See Also Send Feedback

The GridType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

GridType Class


GridType Methods

[image] [image]

Revit 2024 API
GridType Methods
GridType Class See Also Send Feedback

The GridType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

GridType Class


Group Members

[image] [image]

Revit 2024 API
Group Members
Group Class Methods Properties See Also Send Feedback

The Group type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetAvailableAttachedDetailGroupTypeIds | Returns the attached detail groups available for this group type.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMemberIds | Retrieves all the member ElementIds of the group.
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetShownAttachedDetailGroupTypeIds | Returns the attached detail groups which have displayed instances for this group type in the input view.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HideAllAttachedDetailGroups | Hides all the available attached detail groups for this element group type that are compatible with the input view type.
Public method | HideAttachedDetailGroups | Hides the element group's attached detail groups of the input group type that are compatible with the input view.
Public method | IsCompatibleAttachedDetailGroupType | Checks if the orientation of the input attached detail group matches the input view's orientation.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ShowAllAttachedDetailGroups | Shows all the available attached detail groups for this element group type that are compatible with the input view type.
Public method | ShowAttachedDetailGroups | Shows the element group's attached detail groups of the input group type that are compatible with the input view.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UngroupMembers | Ungroups the group.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | AttachedParentId | Indicates the Id of the parent group this group is attached to.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | GroupType | Get or set the type of the group.
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsAttached | Indicates wether or not this group is attached to a parent group.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of a group within project. (Overrides Element..::..Location.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Group Class


Group Methods

[image] [image]

Revit 2024 API
Group Methods
Group Class See Also Send Feedback

The Group type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetAvailableAttachedDetailGroupTypeIds | Returns the attached detail groups available for this group type.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMemberIds | Retrieves all the member ElementIds of the group.
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetShownAttachedDetailGroupTypeIds | Returns the attached detail groups which have displayed instances for this group type in the input view.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HideAllAttachedDetailGroups | Hides all the available attached detail groups for this element group type that are compatible with the input view type.
Public method | HideAttachedDetailGroups | Hides the element group's attached detail groups of the input group type that are compatible with the input view.
Public method | IsCompatibleAttachedDetailGroupType | Checks if the orientation of the input attached detail group matches the input view's orientation.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ShowAllAttachedDetailGroups | Shows all the available attached detail groups for this element group type that are compatible with the input view type.
Public method | ShowAttachedDetailGroups | Shows the element group's attached detail groups of the input group type that are compatible with the input view.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UngroupMembers | Ungroups the group.

See Also

Group Class


GetMemberIds Method

[image]

Revit 2024 API
Group..::..GetMemberIds Method
Group Class See Also Send Feedback
Retrieves all the member ElementIds of the group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public IList<ElementId> GetMemberIds()
Visual Basic
Public Function GetMemberIds As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetMemberIds()

Return Value

An ordered list of the members within the group. The order of this list can be used to match members between other instances of the group.

See Also

Group Class


GetShownAttachedDetailGroupTypeIds Method

[image]

Revit 2024 API
Group..::..GetShownAttachedDetailGroupTypeIds Method
Group Class See Also Send Feedback
Returns the attached detail groups which have displayed instances for this group type in the input view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019.1

Syntax

C#
public ISet<ElementId> GetShownAttachedDetailGroupTypeIds(
    View view
)
Visual Basic
Public Function GetShownAttachedDetailGroupTypeIds ( _
    view As View _
) As ISet(Of ElementId)
Visual C++
public:
ISet<ElementId^>^ GetShownAttachedDetailGroupTypeIds(
    View^ view
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view in which the attached detail groups are displayed.

Return Value

The collection of attached detail group Ids that match this group's type.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The input group is not a model group and can therefore not have attached detail groups.

See Also

Group Class


HideAttachedDetailGroups Method

[image]

Revit 2024 API
Group..::..HideAttachedDetailGroups Method
Group Class See Also Send Feedback
Hides the element group's attached detail groups of the input group type that are compatible with the input view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019.1

Syntax

C#
public void HideAttachedDetailGroups(
    View view,
    ElementId detailGroupTypeId
)
Visual Basic
Public Sub HideAttachedDetailGroups ( _
    view As View, _
    detailGroupTypeId As ElementId _
)
Visual C++
public:
void HideAttachedDetailGroups(
    View^ view,
    ElementId^ detailGroupTypeId
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view that the attached detail groups must be compatible with.
detailGroupTypeId
Type: Autodesk.Revit.DB..::..ElementId
Only attached detail groups of this type will be hidden.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The attached detail group detailGroupTypeId does not match the input view's orientation.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The input group is not a model group and can therefore not have attached detail groups.

See Also

Group Class


IsCompatibleAttachedDetailGroupType Method

[image]

Revit 2024 API
Group..::..IsCompatibleAttachedDetailGroupType Method
Group Class See Also Send Feedback
Checks if the orientation of the input attached detail group matches the input view's orientation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019.1

Syntax

C#
public bool IsCompatibleAttachedDetailGroupType(
    View view,
    ElementId detailGroupTypeId
)
Visual Basic
Public Function IsCompatibleAttachedDetailGroupType ( _
    view As View, _
    detailGroupTypeId As ElementId _
) As Boolean
Visual C++
public:
bool IsCompatibleAttachedDetailGroupType(
    View^ view,
    ElementId^ detailGroupTypeId
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view that the input attached detail group must be compatible with.
detailGroupTypeId
Type: Autodesk.Revit.DB..::..ElementId
The attached detail group that will be checked for compatibility with the input view.

Return Value

Returns true if the input attached detail group is compatible with the input view and false otherwise.

Remarks

Currently, detail groups in perpendicular elevation views (for example, North and East views) are considered compatible. When showing these detail groups, an error (FailureMessage) based on id can be generated if the orientation of the annotations do not match the orientation of the target view (for example, the failure definition DimensionPerpendicularToView). To prevent displaying detail groups in the wrong view, you can check the OwnerViewId of a detail group to make sure it matches the view in which you are trying to display it.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The input group is not a model group and can therefore not have attached detail groups.

See Also

Group Class


ShowAttachedDetailGroups Method

[image]

Revit 2024 API
Group..::..ShowAttachedDetailGroups Method
Group Class See Also Send Feedback
Shows the element group's attached detail groups of the input group type that are compatible with the input view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019.1

Syntax

C#
public void ShowAttachedDetailGroups(
    View view,
    ElementId detailGroupTypeId
)
Visual Basic
Public Sub ShowAttachedDetailGroups ( _
    view As View, _
    detailGroupTypeId As ElementId _
)
Visual C++
public:
void ShowAttachedDetailGroups(
    View^ view,
    ElementId^ detailGroupTypeId
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view that the attached detail groups must be compatible with.
detailGroupTypeId
Type: Autodesk.Revit.DB..::..ElementId
Only attached detail groups of this type will be shown.

Remarks

Currently, perpendicular elevation views (for example, North and East views) are considered compatible when deciding whether or not to allow a detail group to be displayed in a view. The show operation may generate an error (FailureMessage) based on id if the orientation of the annotations do not match the orientation of the target view (for example, the failure definition DimensionPerpendicularToView). To prevent displaying detail groups in the wrong view, you can check the OwnerViewId of a detail group to make sure it matches the view in which you are trying to display it.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The attached detail group detailGroupTypeId does not match the input view's orientation.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The input group is not a model group and can therefore not have attached detail groups. -or- This exception is thrown if the input attached detail group cannot be found in the current document.

See Also

Group Class


UngroupMembers Method

[image]

Revit 2024 API
Group..::..UngroupMembers Method
Group Class See Also Send Feedback
Ungroups the group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ICollection<ElementId> UngroupMembers()
Visual Basic
Public Function UngroupMembers As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ UngroupMembers()

Return Value

If successful, the ids of the members of group are returned.

Remarks

Removes all the members from the group and deletes the group. Note that the reference to this group object will become invalid once this method is called.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if the group cannot be ungrouped.

See Also

Group Class


Group Properties

[image] [image]

Revit 2024 API
Group Properties
Group Class See Also Send Feedback

The Group type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | AttachedParentId | Indicates the Id of the parent group this group is attached to.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | GroupType | Get or set the type of the group.
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsAttached | Indicates wether or not this group is attached to a parent group.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of a group within project. (Overrides Element..::..Location.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Group Class


AttachedParentId Property

[image]

Revit 2024 API
Group..::..AttachedParentId Property
Group Class See Also Send Feedback
Indicates the Id of the parent group this group is attached to.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019.1

Syntax

C#
public ElementId AttachedParentId { get; }
Visual Basic
Public ReadOnly Property AttachedParentId As ElementId
    Get
Visual C++
public:
property ElementId^ AttachedParentId {
    ElementId^ get ();
}

See Also

Group Class


Location Property

[image]

Revit 2024 API
Group..::..Location Property
Group Class See Also Send Feedback
This property is used to find the physical location of a group within project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public override Location Location { get; }
Visual Basic
Public Overrides ReadOnly Property Location As Location
    Get
Visual C++
public:
virtual property Location^ Location {
    Location^ get () override;
}

Remarks

The Location property returns an object that can be used to find the location of an object within the project. Groups return a point location object.

See Also

Group Class


Parameter Property

[image] [image]

Revit 2024 API
Group..::..Parameter Property
Group Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Group Class
Group Members


GroupLoadOptions Constructor

[image]

Revit 2024 API
GroupLoadOptions Constructor
GroupLoadOptions Class See Also Send Feedback
Creates a new instance of a GroupLoadOptions object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public GroupLoadOptions()
Visual Basic
Public Sub New
Visual C++
public:
GroupLoadOptions()

See Also

GroupLoadOptions Class


Dispose Method

[image]

Revit 2024 API
GroupLoadOptions..::..Dispose Method
GroupLoadOptions Class See Also Send Feedback
Releases all resources used by the GroupLoadOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

GroupLoadOptions Class


GetDuplicateTypeNamesHandler Method

[image]

Revit 2024 API
GroupLoadOptions..::..GetDuplicateTypeNamesHandler Method
GroupLoadOptions Class See Also Send Feedback
Returns current duplicate type names handler or nullNothingnullptra null reference (Nothing in Visual Basic) if none is set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public IDuplicateTypeNamesHandler GetDuplicateTypeNamesHandler()
Visual Basic
Public Function GetDuplicateTypeNamesHandler As IDuplicateTypeNamesHandler
Visual C++
public:
IDuplicateTypeNamesHandler^ GetDuplicateTypeNamesHandler()

See Also

GroupLoadOptions Class


SetDuplicateTypeNamesHandler Method

[image]

Revit 2024 API
GroupLoadOptions..::..SetDuplicateTypeNamesHandler Method
GroupLoadOptions Class See Also Send Feedback
Sets a custom duplicate type names handler. If this value is not set, the default handler is used. By default, Revit displays a modal dialog with options to either copy new types only, or cancel the operation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public void SetDuplicateTypeNamesHandler(
    IDuplicateTypeNamesHandler handler
)
Visual Basic
Public Sub SetDuplicateTypeNamesHandler ( _
    handler As IDuplicateTypeNamesHandler _
)
Visual C++
public:
void SetDuplicateTypeNamesHandler(
    IDuplicateTypeNamesHandler^ handler
)

Parameters

handler
Type: Autodesk.Revit.DB..::..IDuplicateTypeNamesHandler
The duplicate type names handler.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

GroupLoadOptions Class


GroupLoadOptions Properties

[image] [image]

Revit 2024 API
GroupLoadOptions Properties
GroupLoadOptions Class See Also Send Feedback

The GroupLoadOptions type exposes the following members.

Properties

 | Name | Description
Public property | IncludeAttachedDetails | True if attached detail groups should be included, false otherwise. The default value is trueTruetruetrue (True in Visual Basic).
Public property | IncludeGrids | True if grids should be brought in from the input file, false otherwise. The default value is falseFalsefalsefalse (False in Visual Basic).
Public property | IncludeLevels | True if levels should be brought in from the input file, false otherwise. The default value is falseFalsefalsefalse (False in Visual Basic).
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ReplaceDuplicatedGroups | If there are groups with the same names in source and destination documents set this property to trueTruetruetrue (True in Visual Basic) to replace existing groups, otherwise the operation will be canceled. The default value is falseFalsefalsefalse (False in Visual Basic).

See Also

GroupLoadOptions Class


IncludeAttachedDetails Property

[image]

Revit 2024 API
GroupLoadOptions..::..IncludeAttachedDetails Property
GroupLoadOptions Class See Also Send Feedback
True if attached detail groups should be included, false otherwise. The default value is trueTruetruetrue (True in Visual Basic).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public bool IncludeAttachedDetails { get; set; }
Visual Basic
Public Property IncludeAttachedDetails As Boolean
    Get
    Set
Visual C++
public:
property bool IncludeAttachedDetails {
    bool get ();
    void set (bool value);
}

See Also

GroupLoadOptions Class


IncludeGrids Property

[image]

Revit 2024 API
GroupLoadOptions..::..IncludeGrids Property
GroupLoadOptions Class See Also Send Feedback
True if grids should be brought in from the input file, false otherwise. The default value is falseFalsefalsefalse (False in Visual Basic).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public bool IncludeGrids { get; set; }
Visual Basic
Public Property IncludeGrids As Boolean
    Get
    Set
Visual C++
public:
property bool IncludeGrids {
    bool get ();
    void set (bool value);
}

See Also

GroupLoadOptions Class


IsValidObject Property

[image]

Revit 2024 API
GroupLoadOptions..::..IsValidObject Property
GroupLoadOptions Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

GroupLoadOptions Class


ReplaceDuplicatedGroups Property

[image]

Revit 2024 API
GroupLoadOptions..::..ReplaceDuplicatedGroups Property
GroupLoadOptions Class See Also Send Feedback
If there are groups with the same names in source and destination documents set this property to trueTruetruetrue (True in Visual Basic) to replace existing groups, otherwise the operation will be canceled. The default value is falseFalsefalsefalse (False in Visual Basic).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public bool ReplaceDuplicatedGroups { get; set; }
Visual Basic
Public Property ReplaceDuplicatedGroups As Boolean
    Get
    Set
Visual C++
public:
property bool ReplaceDuplicatedGroups {
    bool get ();
    void set (bool value);
}

See Also

GroupLoadOptions Class


GroupNode Class

[image]

Revit 2024 API
GroupNode Class
Members See Also Send Feedback
A node that represents set of individual elements grouped together in some form, such as an instance of a family or linked Revit file, or an instance of a part of symbol's geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class GroupNode : RenderNode
Visual Basic
Public Class GroupNode _
    Inherits RenderNode
Visual C++
public ref class GroupNode : public RenderNode

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..RenderNode
Autodesk.Revit.DB..::..GroupNode
Autodesk.Revit.DB..::..InstanceNode
Autodesk.Revit.DB..::..LinkNode

See Also

GroupNode Members


GroupNode Members

[image] [image]

Revit 2024 API
GroupNode Members
GroupNode Class Methods Properties See Also Send Feedback

The GroupNode type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RenderNode.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTransform | A transformation matrix associated with the node.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode.)
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode.)

See Also

GroupNode Class


GroupNode Methods

[image] [image]

Revit 2024 API
GroupNode Methods
GroupNode Class See Also Send Feedback

The GroupNode type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RenderNode.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTransform | A transformation matrix associated with the node.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

GroupNode Class


GetTransform Method

[image]

Revit 2024 API
GroupNode..::..GetTransform Method
GroupNode Class See Also Send Feedback
A transformation matrix associated with the node.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public Transform GetTransform()
Visual Basic
Public Function GetTransform As Transform
Visual C++
public:
Transform^ GetTransform()

See Also

GroupNode Class


GroupNode Properties

[image] [image]

Revit 2024 API
GroupNode Properties
GroupNode Class See Also Send Feedback

The GroupNode type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode.)
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode.)

See Also

GroupNode Class


GroupSet Members

[image] [image]

Revit 2024 API
GroupSet Members
GroupSet Class Constructors Methods Properties See Also Send Feedback

The GroupSet type exposes the following members.

Constructors

 | Name | Description
Public method | GroupSet | Initializes a new instance of the GroupSet class

Methods

 | Name | Description
Public method | Clear | Removes every group from the set, rendering it empty.
Public method | Contains | Tests for the existence of a group within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified group from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified group into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of groups that are in the set.

See Also

GroupSet Class


GroupSet Constructor

[image]

Revit 2024 API
GroupSet Constructor
GroupSet Class See Also Send Feedback
Initializes a new instance of the GroupSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public GroupSet()
Visual Basic
Public Sub New
Visual C++
public:
GroupSet()

See Also

GroupSet Class


Clear Method

[image]

Revit 2024 API
GroupSet..::..Clear Method
GroupSet Class See Also Send Feedback
Removes every group from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

GroupSet Class


Contains Method

[image]

Revit 2024 API
GroupSet..::..Contains Method
GroupSet Class See Also Send Feedback
Tests for the existence of a group within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool Contains(
    Group item
)
Visual Basic
Public Overridable Function Contains ( _
    item As Group _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Group^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..Group
The group to be searched for.

Return Value

The Contains method returns True if the group is within the set, otherwise False.

See Also

GroupSet Class


ForwardIterator Method

[image]

Revit 2024 API
GroupSet..::..ForwardIterator Method
GroupSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual GroupSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As GroupSetIterator
Visual C++
public:
virtual GroupSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

GroupSet Class


Insert Method

[image]

Revit 2024 API
GroupSet..::..Insert Method
GroupSet Class See Also Send Feedback
Insert the specified group into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool Insert(
    Group item
)
Visual Basic
Public Overridable Function Insert ( _
    item As Group _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Group^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..Group
The group to be inserted into the set.

Return Value

Returns whether the group was inserted into the set.

See Also

GroupSet Class


ReverseIterator Method

[image]

Revit 2024 API
GroupSet..::..ReverseIterator Method
GroupSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual GroupSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As GroupSetIterator
Visual C++
public:
virtual GroupSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

GroupSet Class


GroupSet Properties

[image] [image]

Revit 2024 API
GroupSet Properties
GroupSet Class See Also Send Feedback

The GroupSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of groups that are in the set.

See Also

GroupSet Class


IsEmpty Property

[image]

Revit 2024 API
GroupSet..::..IsEmpty Property
GroupSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

GroupSet Class


Size Property

[image]

Revit 2024 API
GroupSet..::..Size Property
GroupSet Class See Also Send Feedback
Returns the number of groups that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

GroupSet Class


GroupSetIterator Constructor

[image]

Revit 2024 API
GroupSetIterator Constructor
GroupSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public GroupSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
GroupSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

GroupSetIterator Class


GroupSetIterator Methods

[image] [image]

Revit 2024 API
GroupSetIterator Methods
GroupSetIterator Class See Also Send Feedback

The GroupSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

GroupSetIterator Class


MoveNext Method

[image]

Revit 2024 API
GroupSetIterator..::..MoveNext Method
GroupSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

GroupSetIterator Class


Reset Method

[image]

Revit 2024 API
GroupSetIterator..::..Reset Method
GroupSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

GroupSetIterator Class


GroupSetIterator Properties

[image] [image]

Revit 2024 API
GroupSetIterator Properties
GroupSetIterator Class See Also Send Feedback

The GroupSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GroupSetIterator Class


Current Property

[image]

Revit 2024 API
GroupSetIterator..::..Current Property
GroupSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

GroupSetIterator Class


GroupType Class

[image]

Revit 2024 API
GroupType Class
Members Example See Also Send Feedback
An element representing a group of elements that may be placed many times in a project or family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class GroupType : ElementType
Visual Basic
Public Class GroupType _
    Inherits ElementType
Visual C++
public ref class GroupType : public ElementType

Remarks

Grouping elements is useful when you need to create entities that represent repeating layouts or are common to many building projects, such as hotel rooms, apartments, or repeating floors.

Examples

CopyC#
public void GetInfo_GroupType(GroupType groupType)
{
    string message = "GroupType";
    //Retrieve a set of all the groups that have this type.
    foreach (Group group in groupType.Groups)
    {
        // Get GroupType group name
        message = "\nThe group type name is : " + groupType.Name;
        //Returns all the members of the group.
        message += "\nThe types and ids of the group members are : ";
        IList<ElementId> groupMembers = group.GetMemberIds();
        foreach (ElementId memberId in groupMembers)
        {
            Element element = group.Document.GetElement(memberId);
            // Get GroupType group element id
            message += "\n\t" + element.GetType().Name + " : " + memberId.ToString();
        }
    }
    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetInfo_GroupType(groupType As GroupType)
    Dim message As String = "GroupType"
    'Retrieve a set of all the groups that have this type.
    For Each group As Group In groupType.Groups
        ' Get GroupType group name
        message = vbLf & "The group type name is : " & Convert.ToString(groupType.Name)
        'Returns all the members of the group.
        message += vbLf & "The types and ids of the group members are : "
        Dim groupMembers As IList(Of ElementId) = group.GetMemberIds()
        For Each memberId As ElementId In groupMembers
            Dim element As Element = group.Document.GetElement(memberId)
            ' Get GroupType group element id
            message += (vbLf & vbTab + element.[GetType]().Name & " : ") + memberId.Value
        Next
    Next
    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..GroupType

See Also

GroupType Members


GroupType Members

[image] [image]

Revit 2024 API
GroupType Members
GroupType Class Methods Properties See Also Send Feedback

The GroupType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetAvailableAttachedDetailGroupTypeIds | Returns the attached detail groups available for this element group type.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LoadFrom | Replaces the group with the contents of the input file.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Groups | Retrieve a set of all the groups that have this type.
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

GroupType Class


GroupType Methods

[image] [image]

Revit 2024 API
GroupType Methods
GroupType Class See Also Send Feedback

The GroupType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetAvailableAttachedDetailGroupTypeIds | Returns the attached detail groups available for this element group type.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LoadFrom | Replaces the group with the contents of the input file.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

GroupType Class


LoadFrom Method

[image]

Revit 2024 API
GroupType..::..LoadFrom Method
GroupType Class Example See Also Send Feedback
Replaces the group with the contents of the input file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public void LoadFrom(
    string fileName,
    GroupLoadOptions options
)
Visual Basic
Public Sub LoadFrom ( _
    fileName As String, _
    options As GroupLoadOptions _
)
Visual C++
public:
void LoadFrom(
    String^ fileName,
    GroupLoadOptions^ options
)

Parameters

fileName
Type: System..::..String
The file to be used for the replacment.
options
Type: Autodesk.Revit.DB..::..GroupLoadOptions
Group load options.

Examples

CopyC#
public void LoadGroup(Group group, string filePath)
{
   GroupLoadOptions options = new GroupLoadOptions();
   options.ReplaceDuplicatedGroups = true;
   options.SetDuplicateTypeNamesHandler(new CustomDuplicateTypeNamesHandler());

   group.GroupType.LoadFrom(filePath, options);
}

class CustomDuplicateTypeNamesHandler : IDuplicateTypeNamesHandler
{
   public DuplicateTypeAction OnDuplicateTypeNamesFound(DuplicateTypeNamesHandlerArgs args)
   {
      return DuplicateTypeAction.UseDestinationTypes;
   }
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Not a valid RVT file.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | The given fileName does not exist.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The element "this GroupType" is in a document which is in an edit mode or is in family mode. -or- The element "this GroupType" does not belong to a project document. -or- The GroupType is not a Model group type and can't be reloaded.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document containing this GroupType is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document containing this GroupType is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document containing this GroupType has no open transaction.

See Also

GroupType Class


Parameter Property

[image] [image]

Revit 2024 API
GroupType..::..Parameter Property
GroupType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

GroupType Class
GroupType Members


GroupTypeId Class

[image]

Revit 2024 API
GroupTypeId Class
Members See Also Send Feedback
This class contains constants identifying parameter groups.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static class GroupTypeId
Visual Basic
Public NotInheritable Class GroupTypeId
Visual C++
public ref class GroupTypeId abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..GroupTypeId

See Also

GroupTypeId Members


GroupTypeId Properties

[image] [image]

Revit 2024 API
GroupTypeId Properties
GroupTypeId Class See Also Send Feedback

The GroupTypeId type exposes the following members.

Properties

Name | Description
AdskModelProperties | Model Properties.
AlternateUnits | Alternate Units.
AnalysisResults | Analysis Results.
AnalyticalAlignment | Analytical Alignment.
AnalyticalModel | Analytical Model.
AnalyticalProperties | Analytical Properties.
Area | Area.
ConceptualEnergyData | Conceptual Energy Data.
ConceptualEnergyDataBuildingServices | Energy Model - Building Services.
Constraints | Constraints.
Construction | Construction.
ContinuousrailBeginBottomExtension | Extension (Beginning/Bottom).
ContinuousrailEndTopExtension | Extension (End/Top).
CouplerArray | Set.
CurtainGrid | Grid.
CurtainGridHoriz | Horizontal Grid.
CurtainGridn1 | Grid 1.
CurtainGridn2 | Grid 2.
CurtainGridU | U Grid.
CurtainGridV | V Grid.
CurtainGridVert | Vertical Grid.
CurtainMullionHoriz | Horizontal Mullions.
CurtainMullionn1 | Grid 1 Mullions.
CurtainMullionn2 | Grid 2 Mullions.
CurtainMullionVert | Vertical Mullions.
Data | Data.
Display | Display.
DivisionGeometry | Division Geometry.
Electrical | Electrical.
ElectricalAnalysis | Electrical Analysis.
ElectricalCircuiting | Electrical - Circuiting.
ElectricalEngineering | Electrical Engineering.
ElectricalLighting | Electrical - Lighting.
ElectricalLoads | Electrical - Loads.
EnergyAnalysis | Energy Analysis.
EnergyAnalysisAdvanced | Advanced.
EnergyAnalysisBldgConsMtlThermalProps | Material Thermal Properties.
EnergyAnalysisBuildingData | Building Data.
EnergyAnalysisConceptualModel | Energy Analytical Model.
EnergyAnalysisDetailedAndConceptualModels | Essential.
EnergyAnalysisDetailedModel | Detailed Model.
EnergyAnalysisRoomSpaceData | Room/Space Data.
FabricationProductData | Fabrication Product Data.
FireProtection | Fire Protection.
Fitting | Fittings.
Flexible | Adaptive Component.
Forces | Forces.
General | General.
GeoLocation | Geolocation.
Geometry | Geometry.
GeometryPositioning | Geometric Position.
Graphics | Graphics.
GreenBuilding | Green Building Properties.
IdentityData | Identity Data.
Ifc | IFC Parameters.
Insulation | Insulation.
Length | Length.
LifeSafety | Life Safety.
LightPhotometrics | Photometrics.
Lining | Lining.
Materials | Materials and Finishes.
Mechanical | Mechanical.
MechanicalAirflow | Mechanical - Flow.
MechanicalLoads | Mechanical - Loads.
Moments | Moments.
Nodes | Nodes.
OverallLegend | Overall Legend.
Pattern | Pattern.
PatternApplication | Pattern Application.
Phasing | Phasing.
Plumbing | Plumbing.
PrimaryEnd | Primary End.
PrimaryUnits | Primary Units.
Profile | Profile.
Profilen1 | Profile 1.
Profilen2 | Profile 2.
RailingSystemFamilyHandrails | Handrail 1.
RailingSystemFamilySegmentPattern | Segment Pattern (default).
RailingSystemFamilyTopRail | Top Rail.
RailingSystemSecondaryFamilyHandrails | Handrail 2.
RailingSystemSegmentPatternRemainder | Pattern Remainder.
RailingSystemSegmentPatternRepeat | Pattern Repeat.
RailingSystemSegmentPosts | Posts.
RailingSystemSegmentUGrid | U Grid.
RailingSystemSegmentVGrid | V Grid.
RebarArray | Rebar Set.
RebarSystemLayers | Layers.
Reference | Reference.
ReleasesMemberForces | Releases / Member Forces.
RotationAbout | Rotation about.
RouteAnalysis | Route Analysis.
SecondaryEnd | Secondary End.
SegmentsFittings | Segments and Fittings.
SlabShapeEdit | Slab Shape Edit.
SplitProfileDimensions | Dimensions (linear units or % of thickness).
StairRisers | Risers.
StairsCalculatorRules | Calculation Rules.
StairsOpenEndConnection | End Connection.
StairsSupports | Supports.
StairsTreadsRisers | Threads/Risers.
StairStringers | Stringers.
StairsWinders | Winders.
StairTreads | Treads.
Structural | Structural.
StructuralAnalysis | Structural Analysis.
StructuralSectionDimensions | Structural Section Dimensions.
StructuralSectionGeometry | Structural Section Geometry.
Support | Supports.
SystemtypeRisedrop | Rise / Drop.
Termination | Terminations.
Text | Text.
Title | Title Text.
ToposolidSubdivision | Sub-Division.
TranslationIn | Translation in.
TrussFamilyBottomChord | Bottom Chords.
TrussFamilyDiagWeb | Diagonal Webs.
TrussFamilyTopChord | Top Chords.
TrussFamilyVertWeb | Vertical Webs.
Underlay | Underlay.
ViewCamera | Camera.
ViewExtents | Extents.
Visibility | Visibility.
WallCrossSectionDefinition | Cross-Section Definition.

See Also

GroupTypeId Class


AdskModelProperties Property

[image]

Revit 2024 API
GroupTypeId..::..AdskModelProperties Property
GroupTypeId Class See Also Send Feedback
Model Properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId AdskModelProperties { get; }
Visual Basic
Public Shared ReadOnly Property AdskModelProperties As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AdskModelProperties {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


AlternateUnits Property

[image]

Revit 2024 API
GroupTypeId..::..AlternateUnits Property
GroupTypeId Class See Also Send Feedback
Alternate Units.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId AlternateUnits { get; }
Visual Basic
Public Shared ReadOnly Property AlternateUnits As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AlternateUnits {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


AnalysisResults Property

[image]

Revit 2024 API
GroupTypeId..::..AnalysisResults Property
GroupTypeId Class See Also Send Feedback
Analysis Results.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId AnalysisResults { get; }
Visual Basic
Public Shared ReadOnly Property AnalysisResults As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalysisResults {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


AnalyticalModel Property

[image]

Revit 2024 API
GroupTypeId..::..AnalyticalModel Property
GroupTypeId Class See Also Send Feedback
Analytical Model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId AnalyticalModel { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalModel As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalModel {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


AnalyticalProperties Property

[image]

Revit 2024 API
GroupTypeId..::..AnalyticalProperties Property
GroupTypeId Class See Also Send Feedback
Analytical Properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId AnalyticalProperties { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalProperties As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalProperties {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


Area Property

[image]

Revit 2024 API
GroupTypeId..::..Area Property
GroupTypeId Class See Also Send Feedback
Area.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId Area { get; }
Visual Basic
Public Shared ReadOnly Property Area As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Area {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


ConceptualEnergyData Property

[image]

Revit 2024 API
GroupTypeId..::..ConceptualEnergyData Property
GroupTypeId Class See Also Send Feedback
Conceptual Energy Data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId ConceptualEnergyData { get; }
Visual Basic
Public Shared ReadOnly Property ConceptualEnergyData As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ConceptualEnergyData {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


ConceptualEnergyDataBuildingServices Property

[image]

Revit 2024 API
GroupTypeId..::..ConceptualEnergyDataBuildingServices Property
GroupTypeId Class See Also Send Feedback
Energy Model - Building Services.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId ConceptualEnergyDataBuildingServices { get; }
Visual Basic
Public Shared ReadOnly Property ConceptualEnergyDataBuildingServices As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ConceptualEnergyDataBuildingServices {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


Constraints Property

[image]

Revit 2024 API
GroupTypeId..::..Constraints Property
GroupTypeId Class See Also Send Feedback
Constraints.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId Constraints { get; }
Visual Basic
Public Shared ReadOnly Property Constraints As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Constraints {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


ContinuousrailBeginBottomExtension Property

[image]

Revit 2024 API
GroupTypeId..::..ContinuousrailBeginBottomExtension Property
GroupTypeId Class See Also Send Feedback
Extension (Beginning/Bottom).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId ContinuousrailBeginBottomExtension { get; }
Visual Basic
Public Shared ReadOnly Property ContinuousrailBeginBottomExtension As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ContinuousrailBeginBottomExtension {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


ContinuousrailEndTopExtension Property

[image]

Revit 2024 API
GroupTypeId..::..ContinuousrailEndTopExtension Property
GroupTypeId Class See Also Send Feedback
Extension (End/Top).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId ContinuousrailEndTopExtension { get; }
Visual Basic
Public Shared ReadOnly Property ContinuousrailEndTopExtension As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ContinuousrailEndTopExtension {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


CouplerArray Property

[image]

Revit 2024 API
GroupTypeId..::..CouplerArray Property
GroupTypeId Class See Also Send Feedback
Set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId CouplerArray { get; }
Visual Basic
Public Shared ReadOnly Property CouplerArray As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CouplerArray {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


CurtainGrid Property

[image]

Revit 2024 API
GroupTypeId..::..CurtainGrid Property
GroupTypeId Class See Also Send Feedback
Grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId CurtainGrid { get; }
Visual Basic
Public Shared ReadOnly Property CurtainGrid As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurtainGrid {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


CurtainGridHoriz Property

[image]

Revit 2024 API
GroupTypeId..::..CurtainGridHoriz Property
GroupTypeId Class See Also Send Feedback
Horizontal Grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId CurtainGridHoriz { get; }
Visual Basic
Public Shared ReadOnly Property CurtainGridHoriz As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurtainGridHoriz {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


CurtainGridn1 Property

[image]

Revit 2024 API
GroupTypeId..::..CurtainGridn1 Property
GroupTypeId Class See Also Send Feedback
Grid 1.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId CurtainGridn1 { get; }
Visual Basic
Public Shared ReadOnly Property CurtainGridn1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurtainGridn1 {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


CurtainGridn2 Property

[image]

Revit 2024 API
GroupTypeId..::..CurtainGridn2 Property
GroupTypeId Class See Also Send Feedback
Grid 2.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId CurtainGridn2 { get; }
Visual Basic
Public Shared ReadOnly Property CurtainGridn2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurtainGridn2 {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


CurtainGridU Property

[image]

Revit 2024 API
GroupTypeId..::..CurtainGridU Property
GroupTypeId Class See Also Send Feedback
U Grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId CurtainGridU { get; }
Visual Basic
Public Shared ReadOnly Property CurtainGridU As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurtainGridU {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


CurtainGridV Property

[image]

Revit 2024 API
GroupTypeId..::..CurtainGridV Property
GroupTypeId Class See Also Send Feedback
V Grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId CurtainGridV { get; }
Visual Basic
Public Shared ReadOnly Property CurtainGridV As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurtainGridV {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


CurtainGridVert Property

[image]

Revit 2024 API
GroupTypeId..::..CurtainGridVert Property
GroupTypeId Class See Also Send Feedback
Vertical Grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId CurtainGridVert { get; }
Visual Basic
Public Shared ReadOnly Property CurtainGridVert As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurtainGridVert {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


CurtainMullionHoriz Property

[image]

Revit 2024 API
GroupTypeId..::..CurtainMullionHoriz Property
GroupTypeId Class See Also Send Feedback
Horizontal Mullions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId CurtainMullionHoriz { get; }
Visual Basic
Public Shared ReadOnly Property CurtainMullionHoriz As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurtainMullionHoriz {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


CurtainMullionn1 Property

[image]

Revit 2024 API
GroupTypeId..::..CurtainMullionn1 Property
GroupTypeId Class See Also Send Feedback
Grid 1 Mullions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId CurtainMullionn1 { get; }
Visual Basic
Public Shared ReadOnly Property CurtainMullionn1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurtainMullionn1 {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


CurtainMullionn2 Property

[image]

Revit 2024 API
GroupTypeId..::..CurtainMullionn2 Property
GroupTypeId Class See Also Send Feedback
Grid 2 Mullions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId CurtainMullionn2 { get; }
Visual Basic
Public Shared ReadOnly Property CurtainMullionn2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurtainMullionn2 {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


Data Property

[image]

Revit 2024 API
GroupTypeId..::..Data Property
GroupTypeId Class See Also Send Feedback
Data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId Data { get; }
Visual Basic
Public Shared ReadOnly Property Data As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Data {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


Display Property

[image]

Revit 2024 API
GroupTypeId..::..Display Property
GroupTypeId Class See Also Send Feedback
Display.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId Display { get; }
Visual Basic
Public Shared ReadOnly Property Display As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Display {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


Electrical Property

[image]

Revit 2024 API
GroupTypeId..::..Electrical Property
GroupTypeId Class See Also Send Feedback
Electrical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId Electrical { get; }
Visual Basic
Public Shared ReadOnly Property Electrical As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Electrical {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


ElectricalEngineering Property

[image]

Revit 2024 API
GroupTypeId..::..ElectricalEngineering Property
GroupTypeId Class See Also Send Feedback
Electrical Engineering.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId ElectricalEngineering { get; }
Visual Basic
Public Shared ReadOnly Property ElectricalEngineering As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ElectricalEngineering {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


ElectricalLighting Property

[image]

Revit 2024 API
GroupTypeId..::..ElectricalLighting Property
GroupTypeId Class See Also Send Feedback
Electrical - Lighting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId ElectricalLighting { get; }
Visual Basic
Public Shared ReadOnly Property ElectricalLighting As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ElectricalLighting {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


ElectricalLoads Property

[image]

Revit 2024 API
GroupTypeId..::..ElectricalLoads Property
GroupTypeId Class See Also Send Feedback
Electrical - Loads.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId ElectricalLoads { get; }
Visual Basic
Public Shared ReadOnly Property ElectricalLoads As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ElectricalLoads {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


EnergyAnalysis Property

[image]

Revit 2024 API
GroupTypeId..::..EnergyAnalysis Property
GroupTypeId Class See Also Send Feedback
Energy Analysis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId EnergyAnalysis { get; }
Visual Basic
Public Shared ReadOnly Property EnergyAnalysis As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ EnergyAnalysis {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


EnergyAnalysisAdvanced Property

[image]

Revit 2024 API
GroupTypeId..::..EnergyAnalysisAdvanced Property
GroupTypeId Class See Also Send Feedback
Advanced.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId EnergyAnalysisAdvanced { get; }
Visual Basic
Public Shared ReadOnly Property EnergyAnalysisAdvanced As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ EnergyAnalysisAdvanced {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


EnergyAnalysisBldgConsMtlThermalProps Property

[image]

Revit 2024 API
GroupTypeId..::..EnergyAnalysisBldgConsMtlThermalProps Property
GroupTypeId Class See Also Send Feedback
Material Thermal Properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId EnergyAnalysisBldgConsMtlThermalProps { get; }
Visual Basic
Public Shared ReadOnly Property EnergyAnalysisBldgConsMtlThermalProps As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ EnergyAnalysisBldgConsMtlThermalProps {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


EnergyAnalysisDetailedAndConceptualModels Property

[image]

Revit 2024 API
GroupTypeId..::..EnergyAnalysisDetailedAndConceptualModels Property
GroupTypeId Class See Also Send Feedback
Essential.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId EnergyAnalysisDetailedAndConceptualModels { get; }
Visual Basic
Public Shared ReadOnly Property EnergyAnalysisDetailedAndConceptualModels As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ EnergyAnalysisDetailedAndConceptualModels {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


EnergyAnalysisDetailedModel Property

[image]

Revit 2024 API
GroupTypeId..::..EnergyAnalysisDetailedModel Property
GroupTypeId Class See Also Send Feedback
Detailed Model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId EnergyAnalysisDetailedModel { get; }
Visual Basic
Public Shared ReadOnly Property EnergyAnalysisDetailedModel As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ EnergyAnalysisDetailedModel {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


EnergyAnalysisRoomSpaceData Property

[image]

Revit 2024 API
GroupTypeId..::..EnergyAnalysisRoomSpaceData Property
GroupTypeId Class See Also Send Feedback
Room/Space Data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId EnergyAnalysisRoomSpaceData { get; }
Visual Basic
Public Shared ReadOnly Property EnergyAnalysisRoomSpaceData As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ EnergyAnalysisRoomSpaceData {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


FireProtection Property

[image]

Revit 2024 API
GroupTypeId..::..FireProtection Property
GroupTypeId Class See Also Send Feedback
Fire Protection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId FireProtection { get; }
Visual Basic
Public Shared ReadOnly Property FireProtection As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FireProtection {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


Fitting Property

[image]

Revit 2024 API
GroupTypeId..::..Fitting Property
GroupTypeId Class See Also Send Feedback
Fittings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId Fitting { get; }
Visual Basic
Public Shared ReadOnly Property Fitting As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Fitting {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


Forces Property

[image]

Revit 2024 API
GroupTypeId..::..Forces Property
GroupTypeId Class See Also Send Feedback
Forces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId Forces { get; }
Visual Basic
Public Shared ReadOnly Property Forces As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Forces {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


General Property

[image]

Revit 2024 API
GroupTypeId..::..General Property
GroupTypeId Class See Also Send Feedback
General.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId General { get; }
Visual Basic
Public Shared ReadOnly Property General As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ General {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


GeoLocation Property

[image]

Revit 2024 API
GroupTypeId..::..GeoLocation Property
GroupTypeId Class See Also Send Feedback
Geolocation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId GeoLocation { get; }
Visual Basic
Public Shared ReadOnly Property GeoLocation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ GeoLocation {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


Geometry Property

[image]

Revit 2024 API
GroupTypeId..::..Geometry Property
GroupTypeId Class See Also Send Feedback
Geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId Geometry { get; }
Visual Basic
Public Shared ReadOnly Property Geometry As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Geometry {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


GeometryPositioning Property

[image]

Revit 2024 API
GroupTypeId..::..GeometryPositioning Property
GroupTypeId Class See Also Send Feedback
Geometric Position.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId GeometryPositioning { get; }
Visual Basic
Public Shared ReadOnly Property GeometryPositioning As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ GeometryPositioning {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


Graphics Property

[image]

Revit 2024 API
GroupTypeId..::..Graphics Property
GroupTypeId Class See Also Send Feedback
Graphics.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId Graphics { get; }
Visual Basic
Public Shared ReadOnly Property Graphics As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Graphics {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


GreenBuilding Property

[image]

Revit 2024 API
GroupTypeId..::..GreenBuilding Property
GroupTypeId Class See Also Send Feedback
Green Building Properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId GreenBuilding { get; }
Visual Basic
Public Shared ReadOnly Property GreenBuilding As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ GreenBuilding {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


IdentityData Property

[image]

Revit 2024 API
GroupTypeId..::..IdentityData Property
GroupTypeId Class See Also Send Feedback
Identity Data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId IdentityData { get; }
Visual Basic
Public Shared ReadOnly Property IdentityData As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ IdentityData {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


Ifc Property

[image]

Revit 2024 API
GroupTypeId..::..Ifc Property
GroupTypeId Class See Also Send Feedback
IFC Parameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId Ifc { get; }
Visual Basic
Public Shared ReadOnly Property Ifc As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Ifc {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


Insulation Property

[image]

Revit 2024 API
GroupTypeId..::..Insulation Property
GroupTypeId Class See Also Send Feedback
Insulation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId Insulation { get; }
Visual Basic
Public Shared ReadOnly Property Insulation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Insulation {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


Length Property

[image]

Revit 2024 API
GroupTypeId..::..Length Property
GroupTypeId Class See Also Send Feedback
Length.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId Length { get; }
Visual Basic
Public Shared ReadOnly Property Length As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Length {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


Lining Property

[image]

Revit 2024 API
GroupTypeId..::..Lining Property
GroupTypeId Class See Also Send Feedback
Lining.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId Lining { get; }
Visual Basic
Public Shared ReadOnly Property Lining As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Lining {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


Materials Property

[image]

Revit 2024 API
GroupTypeId..::..Materials Property
GroupTypeId Class See Also Send Feedback
Materials and Finishes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId Materials { get; }
Visual Basic
Public Shared ReadOnly Property Materials As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Materials {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


Mechanical Property

[image]

Revit 2024 API
GroupTypeId..::..Mechanical Property
GroupTypeId Class See Also Send Feedback
Mechanical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId Mechanical { get; }
Visual Basic
Public Shared ReadOnly Property Mechanical As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Mechanical {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


MechanicalAirflow Property

[image]

Revit 2024 API
GroupTypeId..::..MechanicalAirflow Property
GroupTypeId Class See Also Send Feedback
Mechanical - Flow.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId MechanicalAirflow { get; }
Visual Basic
Public Shared ReadOnly Property MechanicalAirflow As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MechanicalAirflow {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


MechanicalLoads Property

[image]

Revit 2024 API
GroupTypeId..::..MechanicalLoads Property
GroupTypeId Class See Also Send Feedback
Mechanical - Loads.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId MechanicalLoads { get; }
Visual Basic
Public Shared ReadOnly Property MechanicalLoads As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MechanicalLoads {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


OverallLegend Property

[image]

Revit 2024 API
GroupTypeId..::..OverallLegend Property
GroupTypeId Class See Also Send Feedback
Overall Legend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId OverallLegend { get; }
Visual Basic
Public Shared ReadOnly Property OverallLegend As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ OverallLegend {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


Pattern Property

[image]

Revit 2024 API
GroupTypeId..::..Pattern Property
GroupTypeId Class See Also Send Feedback
Pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId Pattern { get; }
Visual Basic
Public Shared ReadOnly Property Pattern As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Pattern {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


PatternApplication Property

[image]

Revit 2024 API
GroupTypeId..::..PatternApplication Property
GroupTypeId Class See Also Send Feedback
Pattern Application.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId PatternApplication { get; }
Visual Basic
Public Shared ReadOnly Property PatternApplication As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PatternApplication {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


Plumbing Property

[image]

Revit 2024 API
GroupTypeId..::..Plumbing Property
GroupTypeId Class See Also Send Feedback
Plumbing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId Plumbing { get; }
Visual Basic
Public Shared ReadOnly Property Plumbing As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Plumbing {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


PrimaryUnits Property

[image]

Revit 2024 API
GroupTypeId..::..PrimaryUnits Property
GroupTypeId Class See Also Send Feedback
Primary Units.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId PrimaryUnits { get; }
Visual Basic
Public Shared ReadOnly Property PrimaryUnits As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PrimaryUnits {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


Profile Property

[image]

Revit 2024 API
GroupTypeId..::..Profile Property
GroupTypeId Class See Also Send Feedback
Profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId Profile { get; }
Visual Basic
Public Shared ReadOnly Property Profile As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Profile {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


Profilen1 Property

[image]

Revit 2024 API
GroupTypeId..::..Profilen1 Property
GroupTypeId Class See Also Send Feedback
Profile 1.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId Profilen1 { get; }
Visual Basic
Public Shared ReadOnly Property Profilen1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Profilen1 {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


Profilen2 Property

[image]

Revit 2024 API
GroupTypeId..::..Profilen2 Property
GroupTypeId Class See Also Send Feedback
Profile 2.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId Profilen2 { get; }
Visual Basic
Public Shared ReadOnly Property Profilen2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Profilen2 {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


RailingSystemFamilyHandrails Property

[image]

Revit 2024 API
GroupTypeId..::..RailingSystemFamilyHandrails Property
GroupTypeId Class See Also Send Feedback
Handrail 1.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId RailingSystemFamilyHandrails { get; }
Visual Basic
Public Shared ReadOnly Property RailingSystemFamilyHandrails As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RailingSystemFamilyHandrails {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


RailingSystemFamilySegmentPattern Property

[image]

Revit 2024 API
GroupTypeId..::..RailingSystemFamilySegmentPattern Property
GroupTypeId Class See Also Send Feedback
Segment Pattern (default).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId RailingSystemFamilySegmentPattern { get; }
Visual Basic
Public Shared ReadOnly Property RailingSystemFamilySegmentPattern As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RailingSystemFamilySegmentPattern {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


RailingSystemSegmentPatternRemainder Property

[image]

Revit 2024 API
GroupTypeId..::..RailingSystemSegmentPatternRemainder Property
GroupTypeId Class See Also Send Feedback
Pattern Remainder.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId RailingSystemSegmentPatternRemainder { get; }
Visual Basic
Public Shared ReadOnly Property RailingSystemSegmentPatternRemainder As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RailingSystemSegmentPatternRemainder {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


RailingSystemSegmentPatternRepeat Property

[image]

Revit 2024 API
GroupTypeId..::..RailingSystemSegmentPatternRepeat Property
GroupTypeId Class See Also Send Feedback
Pattern Repeat.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId RailingSystemSegmentPatternRepeat { get; }
Visual Basic
Public Shared ReadOnly Property RailingSystemSegmentPatternRepeat As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RailingSystemSegmentPatternRepeat {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


RailingSystemSegmentPosts Property

[image]

Revit 2024 API
GroupTypeId..::..RailingSystemSegmentPosts Property
GroupTypeId Class See Also Send Feedback
Posts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId RailingSystemSegmentPosts { get; }
Visual Basic
Public Shared ReadOnly Property RailingSystemSegmentPosts As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RailingSystemSegmentPosts {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


RailingSystemSegmentVGrid Property

[image]

Revit 2024 API
GroupTypeId..::..RailingSystemSegmentVGrid Property
GroupTypeId Class See Also Send Feedback
V Grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId RailingSystemSegmentVGrid { get; }
Visual Basic
Public Shared ReadOnly Property RailingSystemSegmentVGrid As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RailingSystemSegmentVGrid {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


RebarArray Property

[image]

Revit 2024 API
GroupTypeId..::..RebarArray Property
GroupTypeId Class See Also Send Feedback
Rebar Set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId RebarArray { get; }
Visual Basic
Public Shared ReadOnly Property RebarArray As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarArray {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


RebarSystemLayers Property

[image]

Revit 2024 API
GroupTypeId..::..RebarSystemLayers Property
GroupTypeId Class See Also Send Feedback
Layers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId RebarSystemLayers { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemLayers As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemLayers {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


Reference Property

[image]

Revit 2024 API
GroupTypeId..::..Reference Property
GroupTypeId Class See Also Send Feedback
Reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId Reference { get; }
Visual Basic
Public Shared ReadOnly Property Reference As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Reference {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


RouteAnalysis Property

[image]

Revit 2024 API
GroupTypeId..::..RouteAnalysis Property
GroupTypeId Class See Also Send Feedback
Route Analysis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId RouteAnalysis { get; }
Visual Basic
Public Shared ReadOnly Property RouteAnalysis As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RouteAnalysis {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


SecondaryEnd Property

[image]

Revit 2024 API
GroupTypeId..::..SecondaryEnd Property
GroupTypeId Class See Also Send Feedback
Secondary End.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId SecondaryEnd { get; }
Visual Basic
Public Shared ReadOnly Property SecondaryEnd As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SecondaryEnd {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


SegmentsFittings Property

[image]

Revit 2024 API
GroupTypeId..::..SegmentsFittings Property
GroupTypeId Class See Also Send Feedback
Segments and Fittings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId SegmentsFittings { get; }
Visual Basic
Public Shared ReadOnly Property SegmentsFittings As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SegmentsFittings {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


SlabShapeEdit Property

[image]

Revit 2024 API
GroupTypeId..::..SlabShapeEdit Property
GroupTypeId Class See Also Send Feedback
Slab Shape Edit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId SlabShapeEdit { get; }
Visual Basic
Public Shared ReadOnly Property SlabShapeEdit As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SlabShapeEdit {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


StairRisers Property

[image]

Revit 2024 API
GroupTypeId..::..StairRisers Property
GroupTypeId Class See Also Send Feedback
Risers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId StairRisers { get; }
Visual Basic
Public Shared ReadOnly Property StairRisers As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairRisers {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


StairsCalculatorRules Property

[image]

Revit 2024 API
GroupTypeId..::..StairsCalculatorRules Property
GroupTypeId Class See Also Send Feedback
Calculation Rules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId StairsCalculatorRules { get; }
Visual Basic
Public Shared ReadOnly Property StairsCalculatorRules As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsCalculatorRules {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


StairsOpenEndConnection Property

[image]

Revit 2024 API
GroupTypeId..::..StairsOpenEndConnection Property
GroupTypeId Class See Also Send Feedback
End Connection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId StairsOpenEndConnection { get; }
Visual Basic
Public Shared ReadOnly Property StairsOpenEndConnection As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsOpenEndConnection {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


StairsSupports Property

[image]

Revit 2024 API
GroupTypeId..::..StairsSupports Property
GroupTypeId Class See Also Send Feedback
Supports.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId StairsSupports { get; }
Visual Basic
Public Shared ReadOnly Property StairsSupports As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsSupports {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


StairsTreadsRisers Property

[image]

Revit 2024 API
GroupTypeId..::..StairsTreadsRisers Property
GroupTypeId Class See Also Send Feedback
Threads/Risers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId StairsTreadsRisers { get; }
Visual Basic
Public Shared ReadOnly Property StairsTreadsRisers As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsTreadsRisers {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


StairsWinders Property

[image]

Revit 2024 API
GroupTypeId..::..StairsWinders Property
GroupTypeId Class See Also Send Feedback
Winders.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId StairsWinders { get; }
Visual Basic
Public Shared ReadOnly Property StairsWinders As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsWinders {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


StairTreads Property

[image]

Revit 2024 API
GroupTypeId..::..StairTreads Property
GroupTypeId Class See Also Send Feedback
Treads.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId StairTreads { get; }
Visual Basic
Public Shared ReadOnly Property StairTreads As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairTreads {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


Structural Property

[image]

Revit 2024 API
GroupTypeId..::..Structural Property
GroupTypeId Class See Also Send Feedback
Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId Structural { get; }
Visual Basic
Public Shared ReadOnly Property Structural As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Structural {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


StructuralAnalysis Property

[image]

Revit 2024 API
GroupTypeId..::..StructuralAnalysis Property
GroupTypeId Class See Also Send Feedback
Structural Analysis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId StructuralAnalysis { get; }
Visual Basic
Public Shared ReadOnly Property StructuralAnalysis As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralAnalysis {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


StructuralSectionDimensions Property

[image]

Revit 2024 API
GroupTypeId..::..StructuralSectionDimensions Property
GroupTypeId Class See Also Send Feedback
Structural Section Dimensions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId StructuralSectionDimensions { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionDimensions As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionDimensions {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


StructuralSectionGeometry Property

[image]

Revit 2024 API
GroupTypeId..::..StructuralSectionGeometry Property
GroupTypeId Class See Also Send Feedback
Structural Section Geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId StructuralSectionGeometry { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionGeometry As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionGeometry {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


Support Property

[image]

Revit 2024 API
GroupTypeId..::..Support Property
GroupTypeId Class See Also Send Feedback
Supports.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId Support { get; }
Visual Basic
Public Shared ReadOnly Property Support As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Support {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


SystemtypeRisedrop Property

[image]

Revit 2024 API
GroupTypeId..::..SystemtypeRisedrop Property
GroupTypeId Class See Also Send Feedback
Rise / Drop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId SystemtypeRisedrop { get; }
Visual Basic
Public Shared ReadOnly Property SystemtypeRisedrop As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SystemtypeRisedrop {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


Termination Property

[image]

Revit 2024 API
GroupTypeId..::..Termination Property
GroupTypeId Class See Also Send Feedback
Terminations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId Termination { get; }
Visual Basic
Public Shared ReadOnly Property Termination As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Termination {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


Title Property

[image]

Revit 2024 API
GroupTypeId..::..Title Property
GroupTypeId Class See Also Send Feedback
Title Text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId Title { get; }
Visual Basic
Public Shared ReadOnly Property Title As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Title {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


ToposolidSubdivision Property

[image]

Revit 2024 API
GroupTypeId..::..ToposolidSubdivision Property
GroupTypeId Class See Also Send Feedback
Sub-Division.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId ToposolidSubdivision { get; }
Visual Basic
Public Shared ReadOnly Property ToposolidSubdivision As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ToposolidSubdivision {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


TrussFamilyBottomChord Property

[image]

Revit 2024 API
GroupTypeId..::..TrussFamilyBottomChord Property
GroupTypeId Class See Also Send Feedback
Bottom Chords.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId TrussFamilyBottomChord { get; }
Visual Basic
Public Shared ReadOnly Property TrussFamilyBottomChord As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TrussFamilyBottomChord {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


TrussFamilyDiagWeb Property

[image]

Revit 2024 API
GroupTypeId..::..TrussFamilyDiagWeb Property
GroupTypeId Class See Also Send Feedback
Diagonal Webs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId TrussFamilyDiagWeb { get; }
Visual Basic
Public Shared ReadOnly Property TrussFamilyDiagWeb As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TrussFamilyDiagWeb {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


TrussFamilyTopChord Property

[image]

Revit 2024 API
GroupTypeId..::..TrussFamilyTopChord Property
GroupTypeId Class See Also Send Feedback
Top Chords.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId TrussFamilyTopChord { get; }
Visual Basic
Public Shared ReadOnly Property TrussFamilyTopChord As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TrussFamilyTopChord {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


Underlay Property

[image]

Revit 2024 API
GroupTypeId..::..Underlay Property
GroupTypeId Class See Also Send Feedback
Underlay.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId Underlay { get; }
Visual Basic
Public Shared ReadOnly Property Underlay As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Underlay {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


ViewCamera Property

[image]

Revit 2024 API
GroupTypeId..::..ViewCamera Property
GroupTypeId Class See Also Send Feedback
Camera.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId ViewCamera { get; }
Visual Basic
Public Shared ReadOnly Property ViewCamera As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewCamera {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


ViewExtents Property

[image]

Revit 2024 API
GroupTypeId..::..ViewExtents Property
GroupTypeId Class See Also Send Feedback
Extents.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId ViewExtents { get; }
Visual Basic
Public Shared ReadOnly Property ViewExtents As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewExtents {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


Visibility Property

[image]

Revit 2024 API
GroupTypeId..::..Visibility Property
GroupTypeId Class See Also Send Feedback
Visibility.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId Visibility { get; }
Visual Basic
Public Shared ReadOnly Property Visibility As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Visibility {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


WallCrossSectionDefinition Property

[image]

Revit 2024 API
GroupTypeId..::..WallCrossSectionDefinition Property
GroupTypeId Class See Also Send Feedback
Cross-Section Definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ForgeTypeId WallCrossSectionDefinition { get; }
Visual Basic
Public Shared ReadOnly Property WallCrossSectionDefinition As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WallCrossSectionDefinition {
    ForgeTypeId^ get ();
}

See Also

GroupTypeId Class


GuidEnum Class

[image]

Revit 2024 API
GuidEnum Class
Members See Also Send Feedback
Base class of all GUID-based enum classes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class GuidEnum
Visual Basic
Public Class GuidEnum
Visual C++
public ref class GuidEnum

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..GuidEnum
Autodesk.Revit.DB..::..ExternalResourceType
Autodesk.Revit.DB.ExternalService..::..ExternalServiceId
Autodesk.Revit.DB..::..FailureDefinitionId
Autodesk.Revit.DB..::..NumberingSchemaType
Autodesk.Revit.DB..::..PerformanceAdviserRuleId
Autodesk.Revit.UI..::..DockablePaneId

See Also

GuidEnum Members


GuidEnum Constructor

[image]

Revit 2024 API
GuidEnum Constructor
GuidEnum Class See Also Send Feedback
Creates an Guid-based enum instance with the supplied name and GUID. GUID-based enum instance can be compared by this guid value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public GuidEnum(
    Guid guid
)
Visual Basic
Public Sub New ( _
    guid As Guid _
)
Visual C++
public:
GuidEnum(
    Guid guid
)

Parameters

guid
Type: System..::..Guid
The GUID of this GUID-based enum.

See Also

GuidEnum Class


GuidEnum Methods

[image] [image]

Revit 2024 API
GuidEnum Methods
GuidEnum Class See Also Send Feedback

The GuidEnum type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Compares two Guid-based enum object based on their concrete class and GUID value. (Overrides Object..::..Equals(Object).)
Public method | GetHashCode | Generates a hash code for this Guid-based enum object. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

GuidEnum Class


Equals Method

[image]

Revit 2024 API
GuidEnum..::..Equals Method
GuidEnum Class See Also Send Feedback
Compares two Guid-based enum object based on their concrete class and GUID value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object

See Also

GuidEnum Class


GetHashCode Method

[image]

Revit 2024 API
GuidEnum..::..GetHashCode Method
GuidEnum Class See Also Send Feedback
Generates a hash code for this Guid-based enum object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

GuidEnum Class


GuidEnum Properties

[image] [image]

Revit 2024 API
GuidEnum Properties
GuidEnum Class See Also Send Feedback

The GuidEnum type exposes the following members.

Properties

 | Name | Description
Public property | Guid | The Guid of GUID-based enum object.

See Also

GuidEnum Class


Guid Property

[image]

Revit 2024 API
GuidEnum..::..Guid Property
GuidEnum Class See Also Send Feedback
The Guid of GUID-based enum object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Guid Guid { get; }
Visual Basic
Public ReadOnly Property Guid As Guid
    Get
Visual C++
public:
property Guid Guid {
    Guid get ();
}

See Also

GuidEnum Class


HasNoValueFilterRule Class

[image]

Revit 2024 API
HasNoValueFilterRule Class
Members See Also Send Feedback
Tests whether an element's parameter doesn't have a value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public class HasNoValueFilterRule : ParameterValuePresenceRule
Visual Basic
Public Class HasNoValueFilterRule _
    Inherits ParameterValuePresenceRule
Visual C++
public ref class HasNoValueFilterRule : public ParameterValuePresenceRule

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterRule
Autodesk.Revit.DB..::..ParameterValuePresenceRule
Autodesk.Revit.DB..::..HasNoValueFilterRule

See Also

HasNoValueFilterRule Members


HasNoValueFilterRule Members

[image] [image]

Revit 2024 API
HasNoValueFilterRule Members
HasNoValueFilterRule Class Constructors Methods Properties See Also Send Feedback

The HasNoValueFilterRule type exposes the following members.

Constructors

 | Name | Description
Public method | HasNoValueFilterRule | constructs an instance of HasNoValueFilterRule.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterRule.)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter. (Inherited from FilterRule.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterRule.)
Public property | Parameter | The parameter which will be evaluated to pass this rule. (Inherited from ParameterValuePresenceRule.)

See Also

HasNoValueFilterRule Class


HasNoValueFilterRule Constructor

[image]

Revit 2024 API
HasNoValueFilterRule Constructor
HasNoValueFilterRule Class See Also Send Feedback
constructs an instance of HasNoValueFilterRule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public HasNoValueFilterRule(
    ElementId parameter
)
Visual Basic
Public Sub New ( _
    parameter As ElementId _
)
Visual C++
public:
HasNoValueFilterRule(
    ElementId^ parameter
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
The parameter that an element must not have a value for to pass this rule.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

HasNoValueFilterRule Class


HasNoValueFilterRule Methods

[image] [image]

Revit 2024 API
HasNoValueFilterRule Methods
HasNoValueFilterRule Class See Also Send Feedback

The HasNoValueFilterRule type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterRule.)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter. (Inherited from FilterRule.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

HasNoValueFilterRule Class


HasValueFilterRule Class

[image]

Revit 2024 API
HasValueFilterRule Class
Members See Also Send Feedback
Tests whether an element's parameter has a value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public class HasValueFilterRule : ParameterValuePresenceRule
Visual Basic
Public Class HasValueFilterRule _
    Inherits ParameterValuePresenceRule
Visual C++
public ref class HasValueFilterRule : public ParameterValuePresenceRule

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterRule
Autodesk.Revit.DB..::..ParameterValuePresenceRule
Autodesk.Revit.DB..::..HasValueFilterRule

See Also

HasValueFilterRule Members


HasValueFilterRule Constructor

[image]

Revit 2024 API
HasValueFilterRule Constructor
HasValueFilterRule Class See Also Send Feedback
constructs an instance of HasValueFilterRule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public HasValueFilterRule(
    ElementId parameter
)
Visual Basic
Public Sub New ( _
    parameter As ElementId _
)
Visual C++
public:
HasValueFilterRule(
    ElementId^ parameter
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
The parameter that an element must have a value for to pass this rule.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

HasValueFilterRule Class


HasValueFilterRule Methods

[image] [image]

Revit 2024 API
HasValueFilterRule Methods
HasValueFilterRule Class See Also Send Feedback

The HasValueFilterRule type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterRule.)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter. (Inherited from FilterRule.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

HasValueFilterRule Class


HasValueFilterRule Properties

[image] [image]

Revit 2024 API
HasValueFilterRule Properties
HasValueFilterRule Class See Also Send Feedback

The HasValueFilterRule type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterRule.)
Public property | Parameter | The parameter which will be evaluated to pass this rule. (Inherited from ParameterValuePresenceRule.)

See Also

HasValueFilterRule Class


HermiteFace Members

[image] [image]

Revit 2024 API
HermiteFace Members
HermiteFace Class Methods Properties See Also Send Feedback

The HermiteFace type exposes the following members.

Methods

 | Name | Description
Public method | ComputeDerivatives | Returns the first partial derivatives of the underlying surface at the specified point. (Inherited from Face.)
Public method | ComputeNormal | Returns the normal vector for the face at the given point. (Inherited from Face.)
Public method | ComputeSecondDerivatives | Returns the second partial derivatives of the face at the specified point. (Inherited from Face.)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates and returns the XYZ coordinates of a point at the indicated UV parameterization of the face. (Inherited from Face.)
Public method | GetBoundingBox | Returns the UV bounding box of the face. (Inherited from Face.)
Public method | GetEdgesAsCurveLoops | Returns a list of closed curve loops that correspond to the edge loops of the face. Curves in each curve loop correspond to individual edges. (Inherited from Face.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject.)
Public method | GetRegions | Gets the face regions (created, for example, by the Split Face command) of the face. (Inherited from Face.)
Public method | GetSurface | Returns a copy of this face's surface. (Inherited from Face.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Public method | Intersect(Face) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)
Public method | Intersect(Face, Curve%) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face.)
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional information about the point location. (Inherited from Face.)
Public method | Project | Projects the specified point on the face. (Inherited from Face.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Triangulate()()()() | Returns a triangular mesh approximation to the face. (Inherited from Face.)
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face. (Inherited from Face.)

Properties

 | Name | Description
Public property | Area | The area of this face. (Inherited from Face.)
Public property | EdgeLoops | A collection of edge loops. Each edge loop represents one of the closed boundaries of the face. (Inherited from Face.)
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
Public property | HasRegions | Identifies if the face contains regions (which can be created, for example, by the Split Face command). (Inherited from Face.)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject.)
Public property | IsCyclic | Indicates whether the underlying surface is periodic in the specified parametric direction. (Inherited from Face.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate). (Inherited from Face.)
Public property | MaterialElementId | The element ID of the material from which this face is composed. (Inherited from Face.)
Public property | MixedDerivs | Mixed derivatives of the surface.
Public property | OrientationMatchesSurfaceOrientation | Returns true if this face's orientation matches the orientation of the face's surface, false if they have opposite orientations. (Inherited from Face.)
Public property | Params | Parameters of the surface.
Public property | Period | The period of the underlying surface in the specified parametric direction. (Inherited from Face.)
Public property | Points | Interpolation points of the surface.
Public property | Reference | Returns a stable reference to the face. (Inherited from Face.)
Public property | Tangents | Tangents of the surface.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

HermiteFace Class


HermiteFace Methods

[image] [image]

Revit 2024 API
HermiteFace Methods
HermiteFace Class See Also Send Feedback

The HermiteFace type exposes the following members.

Methods

 | Name | Description
Public method | ComputeDerivatives | Returns the first partial derivatives of the underlying surface at the specified point. (Inherited from Face.)
Public method | ComputeNormal | Returns the normal vector for the face at the given point. (Inherited from Face.)
Public method | ComputeSecondDerivatives | Returns the second partial derivatives of the face at the specified point. (Inherited from Face.)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates and returns the XYZ coordinates of a point at the indicated UV parameterization of the face. (Inherited from Face.)
Public method | GetBoundingBox | Returns the UV bounding box of the face. (Inherited from Face.)
Public method | GetEdgesAsCurveLoops | Returns a list of closed curve loops that correspond to the edge loops of the face. Curves in each curve loop correspond to individual edges. (Inherited from Face.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject.)
Public method | GetRegions | Gets the face regions (created, for example, by the Split Face command) of the face. (Inherited from Face.)
Public method | GetSurface | Returns a copy of this face's surface. (Inherited from Face.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Public method | Intersect(Face) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)
Public method | Intersect(Face, Curve%) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face.)
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional information about the point location. (Inherited from Face.)
Public method | Project | Projects the specified point on the face. (Inherited from Face.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Triangulate()()()() | Returns a triangular mesh approximation to the face. (Inherited from Face.)
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face. (Inherited from Face.)

See Also

HermiteFace Class


Intersect Method

[image] [image]

Revit 2024 API
HermiteFace..::..Intersect Method
HermiteFace Class See Also Send Feedback
Calculates the intersection of the specified curve with this face.

Overload List

 | Name | Description
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Public method | Intersect(Face) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)
Public method | Intersect(Face, Curve%) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face.)

See Also

HermiteFace Class
HermiteFace Members


IsInside Method

[image] [image]

Revit 2024 API
HermiteFace..::..IsInside Method
HermiteFace Class See Also Send Feedback
Indicates whether the specified point is within this face.

Overload List

 | Name | Description
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional information about the point location. (Inherited from Face.)

See Also

HermiteFace Class
HermiteFace Members


Triangulate Method

[image] [image]

Revit 2024 API
HermiteFace..::..Triangulate Method
HermiteFace Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Triangulate()()()() | Returns a triangular mesh approximation to the face. (Inherited from Face.)
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face. (Inherited from Face.)

See Also

HermiteFace Class
HermiteFace Members


HermiteFace Properties

[image] [image]

Revit 2024 API
HermiteFace Properties
HermiteFace Class See Also Send Feedback

The HermiteFace type exposes the following members.

Properties

 | Name | Description
Public property | Area | The area of this face. (Inherited from Face.)
Public property | EdgeLoops | A collection of edge loops. Each edge loop represents one of the closed boundaries of the face. (Inherited from Face.)
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
Public property | HasRegions | Identifies if the face contains regions (which can be created, for example, by the Split Face command). (Inherited from Face.)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject.)
Public property | IsCyclic | Indicates whether the underlying surface is periodic in the specified parametric direction. (Inherited from Face.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate). (Inherited from Face.)
Public property | MaterialElementId | The element ID of the material from which this face is composed. (Inherited from Face.)
Public property | MixedDerivs | Mixed derivatives of the surface.
Public property | OrientationMatchesSurfaceOrientation | Returns true if this face's orientation matches the orientation of the face's surface, false if they have opposite orientations. (Inherited from Face.)
Public property | Params | Parameters of the surface.
Public property | Period | The period of the underlying surface in the specified parametric direction. (Inherited from Face.)
Public property | Points | Interpolation points of the surface.
Public property | Reference | Returns a stable reference to the face. (Inherited from Face.)
Public property | Tangents | Tangents of the surface.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

HermiteFace Class


Params Property

[image]

Revit 2024 API
HermiteFace..::..Params Property
HermiteFace Class See Also Send Feedback
Parameters of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public DoubleArray this[
    int index
] { get; }
Visual Basic
Public ReadOnly Property Params ( _
    index As Integer _
) As DoubleArray
    Get
Visual C++
public:
property DoubleArray^ Params[int index] {
    DoubleArray^ get (int index);
}

Parameters

index
Type: System..::..Int32

See Also

HermiteFace Class


Points Property

[image]

Revit 2024 API
HermiteFace..::..Points Property
HermiteFace Class See Also Send Feedback
Interpolation points of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public IList<XYZ> Points { get; }
Visual Basic
Public ReadOnly Property Points As IList(Of XYZ)
    Get
Visual C++
public:
property IList<XYZ^>^ Points {
    IList<XYZ^>^ get ();
}

See Also

HermiteFace Class


HermiteSpline Class

[image]

Revit 2024 API
HermiteSpline Class
Members See Also Send Feedback
A Hermite spline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class HermiteSpline : Curve
Visual Basic
Public Class HermiteSpline _
    Inherits Curve
Visual C++
public ref class HermiteSpline : public Curve

Remarks

The Hermite spline lies in the plane defined by control points.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeometryObject
Autodesk.Revit.DB..::..Curve
Autodesk.Revit.DB..::..HermiteSpline

See Also

HermiteSpline Members


HermiteSpline Members

[image] [image]

Revit 2024 API
HermiteSpline Members
HermiteSpline Class Methods Properties See Also Send Feedback

The HermiteSpline type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns a copy of this curve. (Inherited from Curve.)
Public method | ComputeClosestPoints | Find the closest points between two curves. Closest points mean closest pairs of points, each pair consisting of a point on this, say P1, and a point on other curve, say P2. P1 and P2 are closest locally. Each pairs of closest points will be represented by the corresponding parameter values with respect to the two curves and the 3d points. A closest pair is also known as a pair of critical points of the distance function between points of the two curves. If the input parameter returnAllCriticalPoints is set to false, then the function will return only pairs with minimum distance. (Inherited from Curve.)
Public method | ComputeDerivatives | Returns the vectors describing the curve at the specified parameter. (Inherited from Curve.)
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve.)
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve.)
 | Create(IList<(Of <<'(XYZ>)>>), Boolean) | Creates a Hermite spline with default tangency at its endpoints.
 | Create(IList<(Of <<'(XYZ>)>>), Boolean, HermiteSplineTangents) | Creates a Hermite spline with specified tangency at its endpoints.
Public method | CreateOffset | Creates a new curve that is an offset of the existing curve. (Inherited from Curve.)
Public method | CreateReversed | Creates a new curve with the opposite orientation of the existing curve. (Inherited from Curve.)
Public method | CreateTransformed | Crates a new instance of a curve as a transformation of this curve. (Inherited from Curve.)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates and returns the point that matches a parameter along the curve. (Inherited from Curve.)
Public method | GetEndParameter | Returns the raw parameter value at the start or end of this curve. (Inherited from Curve.)
Public method | GetEndPoint | Returns the 3D point at the start or end of this curve. (Inherited from Curve.)
Public method | GetEndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve.)
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve.)
Public method | IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve.)
Public method | MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve.)
Public method | MakeUnbound | Makes this curve unbound. (Inherited from Curve.)
Public method | Project | Projects the specified point on this curve. (Inherited from Curve.)
Public method | SetGraphicsStyleId | Sets the graphics style id for this curve. (Inherited from Curve.)
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
Public property | ControlPoints | The control points of the Hermite spline.
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject.)
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
Public property | IsClosed | Describes whether the curve is closed. (Inherited from Curve.)
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsPeriodic | Returns whether the Hermite spline is periodic or not.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Length | The exact length of the curve. (Inherited from Curve.)
Public property | Parameters | Returns the params of the Hermite spline.
Public property | Period | The period of this curve. (Inherited from Curve.)
Public property | Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Public property | Tangents | Returns the tangents of the Hermite spline.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

HermiteSpline Class


HermiteSpline Methods

[image] [image]

Revit 2024 API
HermiteSpline Methods
HermiteSpline Class See Also Send Feedback

The HermiteSpline type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns a copy of this curve. (Inherited from Curve.)
Public method | ComputeClosestPoints | Find the closest points between two curves. Closest points mean closest pairs of points, each pair consisting of a point on this, say P1, and a point on other curve, say P2. P1 and P2 are closest locally. Each pairs of closest points will be represented by the corresponding parameter values with respect to the two curves and the 3d points. A closest pair is also known as a pair of critical points of the distance function between points of the two curves. If the input parameter returnAllCriticalPoints is set to false, then the function will return only pairs with minimum distance. (Inherited from Curve.)
Public method | ComputeDerivatives | Returns the vectors describing the curve at the specified parameter. (Inherited from Curve.)
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve.)
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve.)
 | Create(IList<(Of <<'(XYZ>)>>), Boolean) | Creates a Hermite spline with default tangency at its endpoints.
 | Create(IList<(Of <<'(XYZ>)>>), Boolean, HermiteSplineTangents) | Creates a Hermite spline with specified tangency at its endpoints.
Public method | CreateOffset | Creates a new curve that is an offset of the existing curve. (Inherited from Curve.)
Public method | CreateReversed | Creates a new curve with the opposite orientation of the existing curve. (Inherited from Curve.)
Public method | CreateTransformed | Crates a new instance of a curve as a transformation of this curve. (Inherited from Curve.)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates and returns the point that matches a parameter along the curve. (Inherited from Curve.)
Public method | GetEndParameter | Returns the raw parameter value at the start or end of this curve. (Inherited from Curve.)
Public method | GetEndPoint | Returns the 3D point at the start or end of this curve. (Inherited from Curve.)
Public method | GetEndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve.)
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve.)
Public method | IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve.)
Public method | MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve.)
Public method | MakeUnbound | Makes this curve unbound. (Inherited from Curve.)
Public method | Project | Projects the specified point on this curve. (Inherited from Curve.)
Public method | SetGraphicsStyleId | Sets the graphics style id for this curve. (Inherited from Curve.)
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

HermiteSpline Class


Create Method

[image] [image]

Revit 2024 API
HermiteSpline..::..Create Method
HermiteSpline Class See Also Send Feedback

Overload List

Name | Description
Create(IList<(Of <<'(XYZ>)>>), Boolean) | Creates a Hermite spline with default tangency at its endpoints.
Create(IList<(Of <<'(XYZ>)>>), Boolean, HermiteSplineTangents) | Creates a Hermite spline with specified tangency at its endpoints.

See Also

HermiteSpline Class
HermiteSpline Members


Create Method (IList(XYZ), Boolean)

[image]

Revit 2024 API
HermiteSpline..::..Create Method (IList<(Of <(<'XYZ>)>)>, Boolean)
HermiteSpline Class See Also Send Feedback
Creates a Hermite spline with default tangency at its endpoints.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static HermiteSpline Create(
    IList<XYZ> controlPoints,
    bool periodic
)
Visual Basic
Public Shared Function Create ( _
    controlPoints As IList(Of XYZ), _
    periodic As Boolean _
) As HermiteSpline
Visual C++
public:
static HermiteSpline^ Create(
    IList<XYZ^>^ controlPoints,
    bool periodic
)

Parameters

controlPoints
Type: System.Collections.Generic..::..IList<(Of <(<' XYZ >)>)>
The control points of the Hermite spline.
periodic
Type: System..::..Boolean
True if the Hermite spline is to be periodic, false otherwise.

Return Value

The new HermiteSpline object.

Remarks

The tangents at the ends of the spline are computed from the control points.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The control points array is invalid, because it doesn't contain the minimum number of points (2).
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | Curve length is too small for Revit's tolerance (as identified by Application.ShortCurveTolerance).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Unable to construct valid HermiteSpline from given inputs.

See Also

HermiteSpline Class
Create Overload


Create Method (IList(XYZ), Boolean, HermiteSplineTangents)

[image]

Revit 2024 API
HermiteSpline..::..Create Method (IList<(Of <(<'XYZ>)>)>, Boolean, HermiteSplineTangents)
HermiteSpline Class See Also Send Feedback
Creates a Hermite spline with specified tangency at its endpoints.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static HermiteSpline Create(
    IList<XYZ> controlPoints,
    bool periodic,
    HermiteSplineTangents tangents
)
Visual Basic
Public Shared Function Create ( _
    controlPoints As IList(Of XYZ), _
    periodic As Boolean, _
    tangents As HermiteSplineTangents _
) As HermiteSpline
Visual C++
public:
static HermiteSpline^ Create(
    IList<XYZ^>^ controlPoints,
    bool periodic,
    HermiteSplineTangents^ tangents
)

Parameters

controlPoints
Type: System.Collections.Generic..::..IList<(Of <(<' XYZ >)>)>
The control points of the Hermite spline.
periodic
Type: System..::..Boolean
True if the Hermite spline is to be periodic, false otherwise.
tangents
Type: Autodesk.Revit.DB..::..HermiteSplineTangents
The object which indicates tangency at the start, the end, or both ends of the curve.

Return Value

The new HermiteSpline object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The control points array is invalid, because it doesn't contain the minimum number of points (2).
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | Curve length is too small for Revit's tolerance (as identified by Application.ShortCurveTolerance).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Unable to construct valid HermiteSpline from given inputs.

See Also

HermiteSpline Class
Create Overload


Intersect Method

[image] [image]

Revit 2024 API
HermiteSpline..::..Intersect Method
HermiteSpline Class See Also Send Feedback
Calculates the intersection of this curve with the specified curve.

Overload List

 | Name | Description
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve.)

See Also

HermiteSpline Class
HermiteSpline Members


IsInside Method

[image] [image]

Revit 2024 API
HermiteSpline..::..IsInside Method
HermiteSpline Class See Also Send Feedback
Indicates whether the specified parameter value is within this curve's bounds.

Overload List

 | Name | Description
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve.)
Public method | IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve.)

See Also

HermiteSpline Class
HermiteSpline Members


HermiteSpline Properties

[image] [image]

Revit 2024 API
HermiteSpline Properties
HermiteSpline Class See Also Send Feedback

The HermiteSpline type exposes the following members.

Properties

 | Name | Description
Public property | ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
Public property | ControlPoints | The control points of the Hermite spline.
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject.)
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
Public property | IsClosed | Describes whether the curve is closed. (Inherited from Curve.)
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsPeriodic | Returns whether the Hermite spline is periodic or not.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Length | The exact length of the curve. (Inherited from Curve.)
Public property | Parameters | Returns the params of the Hermite spline.
Public property | Period | The period of this curve. (Inherited from Curve.)
Public property | Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Public property | Tangents | Returns the tangents of the Hermite spline.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

HermiteSpline Class


ControlPoints Property

[image]

Revit 2024 API
HermiteSpline..::..ControlPoints Property
HermiteSpline Class See Also Send Feedback
The control points of the Hermite spline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public IList<XYZ> ControlPoints { get; set; }
Visual Basic
Public Property ControlPoints As IList(Of XYZ)
    Get
    Set
Visual C++
public:
property IList<XYZ^>^ ControlPoints {
    IList<XYZ^>^ get ();
    void set (IList<XYZ^>^ value);
}

See Also

HermiteSpline Class


IsPeriodic Property

[image]

Revit 2024 API
HermiteSpline..::..IsPeriodic Property
HermiteSpline Class See Also Send Feedback
Returns whether the Hermite spline is periodic or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsPeriodic { get; }
Visual Basic
Public ReadOnly Property IsPeriodic As Boolean
    Get
Visual C++
public:
property bool IsPeriodic {
    bool get ();
}

See Also

HermiteSpline Class


Parameters Property

[image]

Revit 2024 API
HermiteSpline..::..Parameters Property
HermiteSpline Class See Also Send Feedback
Returns the params of the Hermite spline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public DoubleArray Parameters { get; }
Visual Basic
Public ReadOnly Property Parameters As DoubleArray
    Get
Visual C++
public:
property DoubleArray^ Parameters {
    DoubleArray^ get ();
}

See Also

HermiteSpline Class


Tangents Property

[image]

Revit 2024 API
HermiteSpline..::..Tangents Property
HermiteSpline Class See Also Send Feedback
Returns the tangents of the Hermite spline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public IList<XYZ> Tangents { get; }
Visual Basic
Public ReadOnly Property Tangents As IList(Of XYZ)
    Get
Visual C++
public:
property IList<XYZ^>^ Tangents {
    IList<XYZ^>^ get ();
}

See Also

HermiteSpline Class


HermiteSplineTangents Class

[image]

Revit 2024 API
HermiteSplineTangents Class
Members See Also Send Feedback
This class indicates tangency at the start, the end, or both ends of the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class HermiteSplineTangents : IDisposable
Visual Basic
Public Class HermiteSplineTangents _
    Implements IDisposable
Visual C++
public ref class HermiteSplineTangents : IDisposable

Remarks

Initially, the tangent vectors will not be set, and no tangency condition will be imposed when the curve is created.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..HermiteSplineTangents

See Also

HermiteSplineTangents Members


HermiteSplineTangents Members

[image] [image]

Revit 2024 API
HermiteSplineTangents Members
HermiteSplineTangents Class Constructors Methods Properties See Also Send Feedback

The HermiteSplineTangents type exposes the following members.

Constructors

 | Name | Description
Public method | HermiteSplineTangents | Constructs a new default instance of the class, with tangent vectors uninitialized.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the HermiteSplineTangents
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | EndTangent | The tangent vector at the end of the curve.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | StartTangent | The tangent vector at the start of the curve.

See Also

HermiteSplineTangents Class


HermiteSplineTangents Constructor

[image]

Revit 2024 API
HermiteSplineTangents Constructor
HermiteSplineTangents Class See Also Send Feedback
Constructs a new default instance of the class, with tangent vectors uninitialized.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public HermiteSplineTangents()
Visual Basic
Public Sub New
Visual C++
public:
HermiteSplineTangents()

See Also

HermiteSplineTangents Class


HermiteSplineTangents Methods

[image] [image]

Revit 2024 API
HermiteSplineTangents Methods
HermiteSplineTangents Class See Also Send Feedback

The HermiteSplineTangents type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

HermiteSplineTangents Class


Dispose Method

[image]

Revit 2024 API
HermiteSplineTangents..::..Dispose Method
HermiteSplineTangents Class See Also Send Feedback
Releases all resources used by the HermiteSplineTangents

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

HermiteSplineTangents Class


HermiteSplineTangents Properties

[image] [image]

Revit 2024 API
HermiteSplineTangents Properties
HermiteSplineTangents Class See Also Send Feedback

The HermiteSplineTangents type exposes the following members.

Properties

 | Name | Description
Public property | EndTangent | The tangent vector at the end of the curve.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | StartTangent | The tangent vector at the start of the curve.

See Also

HermiteSplineTangents Class


EndTangent Property

[image]

Revit 2024 API
HermiteSplineTangents..::..EndTangent Property
HermiteSplineTangents Class See Also Send Feedback
The tangent vector at the end of the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public XYZ EndTangent { get; set; }
Visual Basic
Public Property EndTangent As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ EndTangent {
    XYZ^ get ();
    void set (XYZ^ value);
}

Field Value

This must be a nomalized unit vector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: endTangent has zero length.
Autodesk.Revit.Exceptions..::..InapplicableDataException | The end tangent value is not set.

See Also

HermiteSplineTangents Class


IsValidObject Property

[image]

Revit 2024 API
HermiteSplineTangents..::..IsValidObject Property
HermiteSplineTangents Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

HermiteSplineTangents Class


HermiteSurface Class

[image]

Revit 2024 API
HermiteSurface Class
Members See Also Send Feedback
A Hermite Surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public class HermiteSurface : Surface
Visual Basic
Public Class HermiteSurface _
    Inherits Surface
Visual C++
public ref class HermiteSurface : public Surface

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Surface
Autodesk.Revit.DB..::..HermiteSurface

See Also

HermiteSurface Members


HermiteSurface Members

[image] [image]

Revit 2024 API
HermiteSurface Members
HermiteSurface Class Methods Properties See Also Send Feedback

The HermiteSurface type exposes the following members.

Methods

 | Name | Description
 | Create(Int32, Int32, IList<(Of <<'(XYZ>)>>)) | Create a non-periodic Hermite surface using a net of 3D points as input.
 | Create(Int32, Int32, IList<(Of <<'(XYZ>)>>), Boolean, Boolean) | Create a Hermite surface using a net of 3D points as input. Specify periodicity in U and V direction.
Public method | Dispose | (Inherited from Surface.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBoundingBoxUV | Gets the UV bounding box of the surface. (Inherited from Surface.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid | Checks whether this HermiteSurface object is valid.
Public method | Project | Project a 3D point orthogonally onto a surface (to find the nearest point). Throws InvalidOperationException if the projection fails. (Inherited from Surface.)
Public method | ProjectWithGuessPoint | Project a 3D point orthogonally onto a surface (to find the nearest point). This method is meant to be used when a good approximate solution for the projection is available. Throws InvalidOperationException if the projection fails. (Inherited from Surface.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Surface.)
Public property | OrientationMatchesParametricOrientation | Indicates whether this Surface's orientation is the same as or opposite to its parametric orientation. (Inherited from Surface.)

See Also

HermiteSurface Class


HermiteSurface Methods

[image] [image]

Revit 2024 API
HermiteSurface Methods
HermiteSurface Class See Also Send Feedback

The HermiteSurface type exposes the following members.

Methods

 | Name | Description
 | Create(Int32, Int32, IList<(Of <<'(XYZ>)>>)) | Create a non-periodic Hermite surface using a net of 3D points as input.
 | Create(Int32, Int32, IList<(Of <<'(XYZ>)>>), Boolean, Boolean) | Create a Hermite surface using a net of 3D points as input. Specify periodicity in U and V direction.
Public method | Dispose | (Inherited from Surface.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBoundingBoxUV | Gets the UV bounding box of the surface. (Inherited from Surface.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid | Checks whether this HermiteSurface object is valid.
Public method | Project | Project a 3D point orthogonally onto a surface (to find the nearest point). Throws InvalidOperationException if the projection fails. (Inherited from Surface.)
Public method | ProjectWithGuessPoint | Project a 3D point orthogonally onto a surface (to find the nearest point). This method is meant to be used when a good approximate solution for the projection is available. Throws InvalidOperationException if the projection fails. (Inherited from Surface.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

HermiteSurface Class


Create Method

[image] [image]

Revit 2024 API
HermiteSurface..::..Create Method
HermiteSurface Class See Also Send Feedback

Overload List

Name | Description
Create(Int32, Int32, IList<(Of <<'(XYZ>)>>)) | Create a non-periodic Hermite surface using a net of 3D points as input.
Create(Int32, Int32, IList<(Of <<'(XYZ>)>>), Boolean, Boolean) | Create a Hermite surface using a net of 3D points as input. Specify periodicity in U and V direction.

See Also

HermiteSurface Class
HermiteSurface Members


IsValid Method

[image]

Revit 2024 API
HermiteSurface..::..IsValid Method
HermiteSurface Class See Also Send Feedback
Checks whether this HermiteSurface object is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public bool IsValid()
Visual Basic
Public Function IsValid As Boolean
Visual C++
public:
bool IsValid()

Return Value

True if this is a valid Hermite Surface, false otherwise.

Remarks

An attempt to access or compute data in an invalid Hermite Surface will cause an exception.

See Also

HermiteSurface Class


HomeCamera Class

[image]

Revit 2024 API
HomeCamera Class
Members See Also Send Feedback
A structure that contains information about the camera and view for the Home view orientation stored in the model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public class HomeCamera : IDisposable
Visual Basic
Public Class HomeCamera _
    Implements IDisposable
Visual C++
public ref class HomeCamera : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..HomeCamera

See Also

HomeCamera Members


HomeCamera Members

[image] [image]

Revit 2024 API
HomeCamera Members
HomeCamera Class Constructors Methods Properties See Also Send Feedback

The HomeCamera type exposes the following members.

Constructors

 | Name | Description
Public method | HomeCamera | Constructs a new copy of the input HomeCamera object.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the HomeCamera
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BottomAngleOfFieldOfView | The bottom angle of the field of view.
Public property | Center | The zoom or orbit center.
Public property | EyePosition | The eye position point.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LeftAngleOfFieldOfView | The left angle of the field of view.
Public property | OrthogonalProjectionHeight | The height of orthogonal projection view volume.
Public property | OrthogonalProjectionWidth | The width of orthogonal projection view volume.
Public property | Pivot | The pivot point.
Public property | RightAngleOfFieldOfView | The right angle of the field of view.
Public property | TopAngleOfFieldOfView | The top angle of the field of view.
Public property | UpDirection | The up direction vector.
Public property | ViewId | The id of the view which is associated to this document's Home view orientation.

See Also

HomeCamera Class


HomeCamera Constructor

[image]

Revit 2024 API
HomeCamera Constructor
HomeCamera Class See Also Send Feedback
Constructs a new copy of the input HomeCamera object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public HomeCamera(
    HomeCamera other
)
Visual Basic
Public Sub New ( _
    other As HomeCamera _
)
Visual C++
public:
HomeCamera(
    HomeCamera^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..HomeCamera

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

HomeCamera Class


HomeCamera Methods

[image] [image]

Revit 2024 API
HomeCamera Methods
HomeCamera Class See Also Send Feedback

The HomeCamera type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

HomeCamera Class


Dispose Method

[image]

Revit 2024 API
HomeCamera..::..Dispose Method
HomeCamera Class See Also Send Feedback
Releases all resources used by the HomeCamera

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

HomeCamera Class


HomeCamera Properties

[image] [image]

Revit 2024 API
HomeCamera Properties
HomeCamera Class See Also Send Feedback

The HomeCamera type exposes the following members.

Properties

 | Name | Description
Public property | BottomAngleOfFieldOfView | The bottom angle of the field of view.
Public property | Center | The zoom or orbit center.
Public property | EyePosition | The eye position point.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LeftAngleOfFieldOfView | The left angle of the field of view.
Public property | OrthogonalProjectionHeight | The height of orthogonal projection view volume.
Public property | OrthogonalProjectionWidth | The width of orthogonal projection view volume.
Public property | Pivot | The pivot point.
Public property | RightAngleOfFieldOfView | The right angle of the field of view.
Public property | TopAngleOfFieldOfView | The top angle of the field of view.
Public property | UpDirection | The up direction vector.
Public property | ViewId | The id of the view which is associated to this document's Home view orientation.

See Also

HomeCamera Class


Center Property

[image]

Revit 2024 API
HomeCamera..::..Center Property
HomeCamera Class See Also Send Feedback
The zoom or orbit center.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public XYZ Center { get; }
Visual Basic
Public ReadOnly Property Center As XYZ
    Get
Visual C++
public:
property XYZ^ Center {
    XYZ^ get ();
}

See Also

HomeCamera Class


EyePosition Property

[image]

Revit 2024 API
HomeCamera..::..EyePosition Property
HomeCamera Class See Also Send Feedback
The eye position point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public XYZ EyePosition { get; }
Visual Basic
Public ReadOnly Property EyePosition As XYZ
    Get
Visual C++
public:
property XYZ^ EyePosition {
    XYZ^ get ();
}

See Also

HomeCamera Class


IsValidObject Property

[image]

Revit 2024 API
HomeCamera..::..IsValidObject Property
HomeCamera Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

HomeCamera Class


OrthogonalProjectionHeight Property

[image]

Revit 2024 API
HomeCamera..::..OrthogonalProjectionHeight Property
HomeCamera Class See Also Send Feedback
The height of orthogonal projection view volume.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public double OrthogonalProjectionHeight { get; }
Visual Basic
Public ReadOnly Property OrthogonalProjectionHeight As Double
    Get
Visual C++
public:
property double OrthogonalProjectionHeight {
    double get ();
}

See Also

HomeCamera Class


OrthogonalProjectionWidth Property

[image]

Revit 2024 API
HomeCamera..::..OrthogonalProjectionWidth Property
HomeCamera Class See Also Send Feedback
The width of orthogonal projection view volume.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public double OrthogonalProjectionWidth { get; }
Visual Basic
Public ReadOnly Property OrthogonalProjectionWidth As Double
    Get
Visual C++
public:
property double OrthogonalProjectionWidth {
    double get ();
}

See Also

HomeCamera Class


Pivot Property

[image]

Revit 2024 API
HomeCamera..::..Pivot Property
HomeCamera Class See Also Send Feedback
The pivot point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public XYZ Pivot { get; }
Visual Basic
Public ReadOnly Property Pivot As XYZ
    Get
Visual C++
public:
property XYZ^ Pivot {
    XYZ^ get ();
}

See Also

HomeCamera Class


RightAngleOfFieldOfView Property

[image]

Revit 2024 API
HomeCamera..::..RightAngleOfFieldOfView Property
HomeCamera Class See Also Send Feedback
The right angle of the field of view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public double RightAngleOfFieldOfView { get; }
Visual Basic
Public ReadOnly Property RightAngleOfFieldOfView As Double
    Get
Visual C++
public:
property double RightAngleOfFieldOfView {
    double get ();
}

See Also

HomeCamera Class


TopAngleOfFieldOfView Property

[image]

Revit 2024 API
HomeCamera..::..TopAngleOfFieldOfView Property
HomeCamera Class See Also Send Feedback
The top angle of the field of view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public double TopAngleOfFieldOfView { get; }
Visual Basic
Public ReadOnly Property TopAngleOfFieldOfView As Double
    Get
Visual C++
public:
property double TopAngleOfFieldOfView {
    double get ();
}

See Also

HomeCamera Class


UpDirection Property

[image]

Revit 2024 API
HomeCamera..::..UpDirection Property
HomeCamera Class See Also Send Feedback
The up direction vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public XYZ UpDirection { get; }
Visual Basic
Public ReadOnly Property UpDirection As XYZ
    Get
Visual C++
public:
property XYZ^ UpDirection {
    XYZ^ get ();
}

See Also

HomeCamera Class


ViewId Property

[image]

Revit 2024 API
HomeCamera..::..ViewId Property
HomeCamera Class See Also Send Feedback
The id of the view which is associated to this document's Home view orientation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public ElementId ViewId { get; }
Visual Basic
Public ReadOnly Property ViewId As ElementId
    Get
Visual C++
public:
property ElementId^ ViewId {
    ElementId^ get ();
}

Remarks

A view can be associated to the document's Home view orientation by the View Cube menu option "Set Current View as Home". Only one view is associated to the Home view orientation at any given time in the document.

See Also

HomeCamera Class


HorizontalAlign Enumeration

[image]

Revit 2024 API
HorizontalAlign Enumeration
See Also Send Feedback
Horizontal alignment of model text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum HorizontalAlign
Visual Basic
Public Enumeration HorizontalAlign
Visual C++
public enum class HorizontalAlign

Members

Member name | Description
Left |
Center |
Right |

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


HorizontalAlignmentStyle Enumeration

[image]

Revit 2024 API
HorizontalAlignmentStyle Enumeration
See Also Send Feedback
Declares the horizontal alignment style of font.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public enum HorizontalAlignmentStyle
Visual Basic
Public Enumeration HorizontalAlignmentStyle
Visual C++
public enum class HorizontalAlignmentStyle

Members

Member name | Description
Left | Alignment to left
Center | Alignment to center
Right | Alignment to right

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


HostedSweep Members

[image] [image]

Revit 2024 API
HostedSweep Members
HostedSweep Class Methods Properties See Also Send Feedback

The HostedSweep type exposes the following members.

Methods

 | Name | Description
Public method | AddSegment | Add segments to the hosted sweep object.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEndPointParameter | Retrieve segment's start point or end point parameter.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HorizontalFlip | Flip the hosted sweep object along horizontal line.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | RemoveSegment | Remove segments from the hosted sweep object.
Public method | SetEndPointParameter | Set segment's start point or end point parameter.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | VerticalFlip | Flip the hosted sweep object along vertical line.

Properties

 | Name | Description
Public property | Angle | Retrieve/set the angle of the hosted sweep object relative its references (Unit : Radian).
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | HorizontalFlipped | Retrieve the horizontal flip status of the hosted sweep object.
Public property | HorizontalOffset | Retrieve/set the horizontal offset of the hosted sweep object.
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | Length | Retrieve the length of the hosted sweep object.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ReferenceCurve | The curve on which the hosted sweep segment is created.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | VerticalFlipped | Retrieve the vertical flip status of the hosted sweep object.
Public property | VerticalOffset | Retrieve/set the vertical offset of the hosted sweep object.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

HostedSweep Class


HostedSweep Methods

[image] [image]

Revit 2024 API
HostedSweep Methods
HostedSweep Class See Also Send Feedback

The HostedSweep type exposes the following members.

Methods

 | Name | Description
Public method | AddSegment | Add segments to the hosted sweep object.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEndPointParameter | Retrieve segment's start point or end point parameter.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HorizontalFlip | Flip the hosted sweep object along horizontal line.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | RemoveSegment | Remove segments from the hosted sweep object.
Public method | SetEndPointParameter | Set segment's start point or end point parameter.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | VerticalFlip | Flip the hosted sweep object along vertical line.

See Also

HostedSweep Class


AddSegment Method

[image]

Revit 2024 API
HostedSweep..::..AddSegment Method
HostedSweep Class See Also Send Feedback
Add segments to the hosted sweep object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public abstract void AddSegment(
    Reference targetRef
)
Visual Basic
Public MustOverride Sub AddSegment ( _
    targetRef As Reference _
)
Visual C++
public:
virtual void AddSegment(
    Reference^ targetRef
) abstract

Parameters

targetRef
Type: Autodesk.Revit.DB..::..Reference

See Also

HostedSweep Class


GetEndPointParameter Method

[image]

Revit 2024 API
HostedSweep..::..GetEndPointParameter Method
HostedSweep Class See Also Send Feedback
Retrieve segment's start point or end point parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double GetEndPointParameter(
    Reference targetRef,
    int endIdx
)
Visual Basic
Public Function GetEndPointParameter ( _
    targetRef As Reference, _
    endIdx As Integer _
) As Double
Visual C++
public:
double GetEndPointParameter(
    Reference^ targetRef,
    int endIdx
)

Parameters

targetRef
Type: Autodesk.Revit.DB..::..Reference
Segment's reference whose parameter want to be get.
endIdx
Type: System..::..Int32
Start point (=0) or end point (=1).

Return Value

Start point or end point parameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when regeneration fails.

See Also

HostedSweep Class


HorizontalFlip Method

[image]

Revit 2024 API
HostedSweep..::..HorizontalFlip Method
HostedSweep Class See Also Send Feedback
Flip the hosted sweep object along horizontal line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void HorizontalFlip()
Visual Basic
Public Sub HorizontalFlip
Visual C++
public:
void HorizontalFlip()

See Also

HostedSweep Class


RemoveSegment Method

[image]

Revit 2024 API
HostedSweep..::..RemoveSegment Method
HostedSweep Class See Also Send Feedback
Remove segments from the hosted sweep object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void RemoveSegment(
    Reference targetRef
)
Visual Basic
Public Sub RemoveSegment ( _
    targetRef As Reference _
)
Visual C++
public:
void RemoveSegment(
    Reference^ targetRef
)

Parameters

targetRef
Type: Autodesk.Revit.DB..::..Reference
Segment's reference which want to be removed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when regeneration fails.

See Also

HostedSweep Class


VerticalFlip Method

[image]

Revit 2024 API
HostedSweep..::..VerticalFlip Method
HostedSweep Class See Also Send Feedback
Flip the hosted sweep object along vertical line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void VerticalFlip()
Visual Basic
Public Sub VerticalFlip
Visual C++
public:
void VerticalFlip()

See Also

HostedSweep Class


HostedSweep Properties

[image] [image]

Revit 2024 API
HostedSweep Properties
HostedSweep Class See Also Send Feedback

The HostedSweep type exposes the following members.

Properties

 | Name | Description
Public property | Angle | Retrieve/set the angle of the hosted sweep object relative its references (Unit : Radian).
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | HorizontalFlipped | Retrieve the horizontal flip status of the hosted sweep object.
Public property | HorizontalOffset | Retrieve/set the horizontal offset of the hosted sweep object.
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | Length | Retrieve the length of the hosted sweep object.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ReferenceCurve | The curve on which the hosted sweep segment is created.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | VerticalFlipped | Retrieve the vertical flip status of the hosted sweep object.
Public property | VerticalOffset | Retrieve/set the vertical offset of the hosted sweep object.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

HostedSweep Class


Angle Property

[image]

Revit 2024 API
HostedSweep..::..Angle Property
HostedSweep Class See Also Send Feedback
Retrieve/set the angle of the hosted sweep object relative its references (Unit : Radian).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double Angle { get; set; }
Visual Basic
Public Property Angle As Double
    Get
    Set
Visual C++
public:
property double Angle {
    double get ();
    void set (double value);
}

See Also

HostedSweep Class


HorizontalFlipped Property

[image]

Revit 2024 API
HostedSweep..::..HorizontalFlipped Property
HostedSweep Class See Also Send Feedback
Retrieve the horizontal flip status of the hosted sweep object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool HorizontalFlipped { get; }
Visual Basic
Public ReadOnly Property HorizontalFlipped As Boolean
    Get
Visual C++
public:
property bool HorizontalFlipped {
    bool get ();
}

See Also

HostedSweep Class


HorizontalOffset Property

[image]

Revit 2024 API
HostedSweep..::..HorizontalOffset Property
HostedSweep Class See Also Send Feedback
Retrieve/set the horizontal offset of the hosted sweep object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double HorizontalOffset { get; set; }
Visual Basic
Public Property HorizontalOffset As Double
    Get
    Set
Visual C++
public:
property double HorizontalOffset {
    double get ();
    void set (double value);
}

See Also

HostedSweep Class


Length Property

[image]

Revit 2024 API
HostedSweep..::..Length Property
HostedSweep Class See Also Send Feedback
Retrieve the length of the hosted sweep object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double Length { get; }
Visual Basic
Public ReadOnly Property Length As Double
    Get
Visual C++
public:
property double Length {
    double get ();
}

See Also

HostedSweep Class


ReferenceCurve Property

[image]

Revit 2024 API
HostedSweep..::..ReferenceCurve Property
HostedSweep Class See Also Send Feedback
The curve on which the hosted sweep segment is created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Curve this[
    Reference targetRef
] { get; }
Visual Basic
Public ReadOnly Property ReferenceCurve ( _
    targetRef As Reference _
) As Curve
    Get
Visual C++
public:
property Curve^ ReferenceCurve[Reference^ targetRef] {
    Curve^ get (Reference^ targetRef);
}

Parameters

targetRef
Type: Autodesk.Revit.DB..::..Reference
Reference of the curve that hosts the object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when regeneration fails.

See Also

HostedSweep Class


VerticalFlipped Property

[image]

Revit 2024 API
HostedSweep..::..VerticalFlipped Property
HostedSweep Class See Also Send Feedback
Retrieve the vertical flip status of the hosted sweep object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool VerticalFlipped { get; }
Visual Basic
Public ReadOnly Property VerticalFlipped As Boolean
    Get
Visual C++
public:
property bool VerticalFlipped {
    bool get ();
}

See Also

HostedSweep Class


VerticalOffset Property

[image]

Revit 2024 API
HostedSweep..::..VerticalOffset Property
HostedSweep Class See Also Send Feedback
Retrieve/set the vertical offset of the hosted sweep object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double VerticalOffset { get; set; }
Visual Basic
Public Property VerticalOffset As Double
    Get
    Set
Visual C++
public:
property double VerticalOffset {
    double get ();
    void set (double value);
}

See Also

HostedSweep Class


HostedSweepType Class

[image]

Revit 2024 API
HostedSweepType Class
Members See Also Send Feedback
An object that represents the attributes for sweep host objects in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class HostedSweepType : HostObjAttributes
Visual Basic
Public Class HostedSweepType _
    Inherits HostObjAttributes
Visual C++
public ref class HostedSweepType : public HostObjAttributes

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..HostObjAttributes
Autodesk.Revit.DB..::..HostedSweepType
Autodesk.Revit.DB.Architecture..::..FasciaType
Autodesk.Revit.DB.Architecture..::..GutterType
Autodesk.Revit.DB..::..SlabEdgeType

See Also

HostedSweepType Members


HostedSweepType Members

[image] [image]

Revit 2024 API
HostedSweepType Members
HostedSweepType Class Methods Properties See Also Send Feedback

The HostedSweepType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

HostedSweepType Class


HostedSweepType Methods

[image] [image]

Revit 2024 API
HostedSweepType Methods
HostedSweepType Class See Also Send Feedback

The HostedSweepType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

HostedSweepType Class


HostedSweepType Properties

[image] [image]

Revit 2024 API
HostedSweepType Properties
HostedSweepType Class See Also Send Feedback

The HostedSweepType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

HostedSweepType Class


Parameter Property

[image] [image]

Revit 2024 API
HostedSweepType..::..Parameter Property
HostedSweepType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

HostedSweepType Class
HostedSweepType Members


HostObjAttributes Class

[image]

Revit 2024 API
HostObjAttributes Class
Members See Also Send Feedback
An object that represents characteristics of several kinds of type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class HostObjAttributes : ElementType
Visual Basic
Public Class HostObjAttributes _
    Inherits ElementType
Visual C++
public ref class HostObjAttributes : public ElementType

Remarks

This object provides access to structural layering components for any object derived from it, such as wall types and floor types.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..HostObjAttributes
Autodesk.Revit.DB..::..BuildingPadType
Autodesk.Revit.DB..::..CeilingType
Autodesk.Revit.DB..::..CurtainSystemType
Autodesk.Revit.DB..::..FloorType
Autodesk.Revit.DB..::..HostedSweepType
Autodesk.Revit.DB..::..MEPCurveType
Autodesk.Revit.DB..::..RoofType
Autodesk.Revit.DB..::..ToposolidType
Autodesk.Revit.DB..::..WallFoundationType
Autodesk.Revit.DB..::..WallType

See Also

HostObjAttributes Members


HostObjAttributes Members

[image] [image]

Revit 2024 API
HostObjAttributes Members
HostObjAttributes Class Methods Properties See Also Send Feedback

The HostObjAttributes type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

HostObjAttributes Class


GetCompoundStructure Method

[image]

Revit 2024 API
HostObjAttributes..::..GetCompoundStructure Method
HostObjAttributes Class See Also Send Feedback
Returns an object that represents the compound structure of the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CompoundStructure GetCompoundStructure()
Visual Basic
Public Function GetCompoundStructure As CompoundStructure
Visual C++
public:
CompoundStructure^ GetCompoundStructure()

Remarks

A copy of the compound structure is returned and changes made to it will not apply to the type until SetCompoundStructure is called. From this object the layers of a compound structure can be accessed. If the element does not have a compound structure then this method will return nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

HostObjAttributes Class


SetCompoundStructure Method

[image]

Revit 2024 API
HostObjAttributes..::..SetCompoundStructure Method
HostObjAttributes Class See Also Send Feedback
Sets the compound structure of the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetCompoundStructure(
    CompoundStructure compoundStructure
)
Visual Basic
Public Sub SetCompoundStructure ( _
    compoundStructure As CompoundStructure _
)
Visual C++
public:
void SetCompoundStructure(
    CompoundStructure^ compoundStructure
)

Parameters

compoundStructure
Type: Autodesk.Revit.DB..::..CompoundStructure

See Also

HostObjAttributes Class


HostObjAttributes Properties

[image] [image]

Revit 2024 API
HostObjAttributes Properties
HostObjAttributes Class See Also Send Feedback

The HostObjAttributes type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

HostObjAttributes Class


Parameter Property

[image] [image]

Revit 2024 API
HostObjAttributes..::..Parameter Property
HostObjAttributes Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

HostObjAttributes Class
HostObjAttributes Members


HostObject Class

[image]

Revit 2024 API
HostObject Class
Members See Also Send Feedback
A base class that provides support for all objects that can host other objects, such as walls roofs, and floors.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class HostObject : Element
Visual Basic
Public Class HostObject _
    Inherits Element
Visual C++
public ref class HostObject : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB..::..CeilingAndFloor
Autodesk.Revit.DB..::..CurtainGridLine
Autodesk.Revit.DB..::..CurtainSystemBase
Autodesk.Revit.DB..::..FaceWall
Autodesk.Revit.DB..::..HostedSweep
Autodesk.Revit.DB..::..MEPCurve
Autodesk.Revit.DB..::..RoofBase
Autodesk.Revit.DB..::..Wall
Autodesk.Revit.DB..::..WallFoundation
Autodesk.Revit.DB..::..WallSweep

See Also

HostObject Members


HostObject Methods

[image] [image]

Revit 2024 API
HostObject Methods
HostObject Class See Also Send Feedback

The HostObject type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

HostObject Class


FindInserts Method

[image]

Revit 2024 API
HostObject..::..FindInserts Method
HostObject Class See Also Send Feedback
Gets the ids of the instances inserted into this host object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public IList<ElementId> FindInserts(
    bool addRectOpenings,
    bool includeShadows,
    bool includeEmbeddedWalls,
    bool includeSharedEmbeddedInserts
)
Visual Basic
Public Function FindInserts ( _
    addRectOpenings As Boolean, _
    includeShadows As Boolean, _
    includeEmbeddedWalls As Boolean, _
    includeSharedEmbeddedInserts As Boolean _
) As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ FindInserts(
    bool addRectOpenings,
    bool includeShadows,
    bool includeEmbeddedWalls,
    bool includeSharedEmbeddedInserts
)

Parameters

addRectOpenings
Type: System..::..Boolean
True if rectangular openings should be included in the return.
includeShadows
Type: System..::..Boolean
True if shadows should be included in the return.
includeEmbeddedWalls
Type: System..::..Boolean
True if embedded walls should be included in the return.
includeSharedEmbeddedInserts
Type: System..::..Boolean
True if shared embedded inserts should be included in the return.

Return Value

All the insertable instances' ids.

See Also

HostObject Class


HostObject Properties

[image] [image]

Revit 2024 API
HostObject Properties
HostObject Class See Also Send Feedback

The HostObject type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

HostObject Class


Parameter Property

[image] [image]

Revit 2024 API
HostObject..::..Parameter Property
HostObject Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

HostObject Class
HostObject Members


HostObjectUtils Class

[image]

Revit 2024 API
HostObjectUtils Class
Members See Also Send Feedback
These are generic host object utilities.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static class HostObjectUtils
Visual Basic
Public NotInheritable Class HostObjectUtils
Visual C++
public ref class HostObjectUtils abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..HostObjectUtils

See Also

HostObjectUtils Members


HostObjectUtils Members

[image] [image]

Revit 2024 API
HostObjectUtils Members
HostObjectUtils Class Methods See Also Send Feedback

The HostObjectUtils type exposes the following members.

Methods

Name | Description
GetBottomFaces | Returns the bottom faces for this host object.
GetSideFaces | Returns the major side faces for this host object.
GetTopFaces | Returns the top faces for this host object.

See Also

HostObjectUtils Class


HostObjectUtils Methods

[image] [image]

Revit 2024 API
HostObjectUtils Methods
HostObjectUtils Class See Also Send Feedback

The HostObjectUtils type exposes the following members.

Methods

Name | Description
GetBottomFaces | Returns the bottom faces for this host object.
GetSideFaces | Returns the major side faces for this host object.
GetTopFaces | Returns the top faces for this host object.

See Also

HostObjectUtils Class


GetBottomFaces Method

[image]

Revit 2024 API
HostObjectUtils..::..GetBottomFaces Method
HostObjectUtils Class See Also Send Feedback
Returns the bottom faces for this host object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static IList<Reference> GetBottomFaces(
    HostObject hostObject
)
Visual Basic
Public Shared Function GetBottomFaces ( _
    hostObject As HostObject _
) As IList(Of Reference)
Visual C++
public:
static IList<Reference^>^ GetBottomFaces(
    HostObject^ hostObject
)

Parameters

hostObject
Type: Autodesk.Revit.DB..::..HostObject
The host object.

Return Value

An array of references to the faces which are at the bottom of this element.

Remarks

This utility supports host objects whose bottom faces represent one of the boundaries of CompoundStructure (such as roofs, floors or ceilings).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This host object does not support access to top or bottom faces.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

HostObjectUtils Class


GetSideFaces Method

[image]

Revit 2024 API
HostObjectUtils..::..GetSideFaces Method
HostObjectUtils Class See Also Send Feedback
Returns the major side faces for this host object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static IList<Reference> GetSideFaces(
    HostObject hostObject,
    ShellLayerType side
)
Visual Basic
Public Shared Function GetSideFaces ( _
    hostObject As HostObject, _
    side As ShellLayerType _
) As IList(Of Reference)
Visual C++
public:
static IList<Reference^>^ GetSideFaces(
    HostObject^ hostObject,
    ShellLayerType side
)

Parameters

hostObject
Type: Autodesk.Revit.DB..::..HostObject
The host object.
side
Type: Autodesk.Revit.DB..::..ShellLayerType
The side of the host object.

Return Value

An array of references to the faces which are on the given side of this element.

Remarks

This utility supports host objects whose CompoundStructure is nominally oriented vertically. It outputs faces which are at the boundary of the CompoundStructure (such as Walls and FaceWalls).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This host object does not support access to side faces.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

HostObjectUtils Class


IATFTranslationServer Members

[image] [image]

Revit 2024 API
IATFTranslationServer Members
IATFTranslationServer Interface Methods See Also Send Feedback

The IATFTranslationServer type exposes the following members.

Methods

 | Name | Description
Public method | GetDescription | Implement this method to return a description of the server. (Inherited from IExternalServer.)
Public method | GetName | Implement this method to return the name of the server. (Inherited from IExternalServer.)
Public method | GetServerId | Implement this method to return the id of the server. (Inherited from IExternalServer.)
Public method | GetServiceId | Implement this method to return the id of the service. (Inherited from IExternalServer.)
Public method | GetVendorId | Implement this method to return the id of the vendor of the server. (Inherited from IExternalServer.)
Public method | Translate | Translate a model according to translationData settings

See Also

IATFTranslationServer Interface


IATFTranslationServer Methods

[image] [image]

Revit 2024 API
IATFTranslationServer Methods
IATFTranslationServer Interface See Also Send Feedback

The IATFTranslationServer type exposes the following members.

Methods

 | Name | Description
Public method | GetDescription | Implement this method to return a description of the server. (Inherited from IExternalServer.)
Public method | GetName | Implement this method to return the name of the server. (Inherited from IExternalServer.)
Public method | GetServerId | Implement this method to return the id of the server. (Inherited from IExternalServer.)
Public method | GetServiceId | Implement this method to return the id of the service. (Inherited from IExternalServer.)
Public method | GetVendorId | Implement this method to return the id of the vendor of the server. (Inherited from IExternalServer.)
Public method | Translate | Translate a model according to translationData settings

See Also

IATFTranslationServer Interface


Translate Method

[image]

Revit 2024 API
IATFTranslationServer..::..Translate Method
IATFTranslationServer Interface See Also Send Feedback
Translate a model according to translationData settings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
bool Translate(
    ATFTranslationServiceData serviceData
)
Visual Basic
Function Translate ( _
    serviceData As ATFTranslationServiceData _
) As Boolean
Visual C++
bool Translate(
    ATFTranslationServiceData^ serviceData
)

Parameters

serviceData
Type: ATFTranslationServiceData

Return Value

Returns true if the translation finished successfully, false otherwise.

See Also

IATFTranslationServer Interface


ICentralLockedCallback Members

[image] [image]

Revit 2024 API
ICentralLockedCallback Members
ICentralLockedCallback Interface Methods See Also Send Feedback

The ICentralLockedCallback type exposes the following members.

Methods

 | Name | Description
Public method | ShouldWaitForLockAvailability | Returns whether Revit should wait and try again to acquire the lock on central.

See Also

ICentralLockedCallback Interface


ICentralLockedCallback Methods

[image] [image]

Revit 2024 API
ICentralLockedCallback Methods
ICentralLockedCallback Interface See Also Send Feedback

The ICentralLockedCallback type exposes the following members.

Methods

 | Name | Description
Public method | ShouldWaitForLockAvailability | Returns whether Revit should wait and try again to acquire the lock on central.

See Also

ICentralLockedCallback Interface


ShouldWaitForLockAvailability Method

[image]

Revit 2024 API
ICentralLockedCallback..::..ShouldWaitForLockAvailability Method
ICentralLockedCallback Interface See Also Send Feedback
Returns whether Revit should wait and try again to acquire the lock on central.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
bool ShouldWaitForLockAvailability()
Visual Basic
Function ShouldWaitForLockAvailability As Boolean
Visual C++
bool ShouldWaitForLockAvailability()

Return Value

True means wait and try again later. False means immediately give up.

See Also

ICentralLockedCallback Interface


IConnector Members

[image] [image]

Revit 2024 API
IConnector Members
IConnector Interface Properties See Also Send Feedback

The IConnector type exposes the following members.

Properties

 | Name | Description
Public property | CoordinateSystem | The coordinate system of the connector.
Public property | Domain | The domain of the connector.
Public property | Height | The height of the connector.
Public property | Origin | The location of the connector in family document.
Public property | Radius | The radius of the connector.
Public property | Shape | The shape of the connector.
Public property | Width | The width of the connector.

See Also

IConnector Interface


CoordinateSystem Property

[image]

Revit 2024 API
IConnector..::..CoordinateSystem Property
IConnector Interface See Also Send Feedback
The coordinate system of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
Transform CoordinateSystem { get; }
Visual Basic
ReadOnly Property CoordinateSystem As Transform
    Get
Visual C++
property Transform^ CoordinateSystem {
    Transform^ get ();
}

Remarks

The Z axis of the coordinate system is the normal to the plane of the connector.

See Also

IConnector Interface


Domain Property

[image]

Revit 2024 API
IConnector..::..Domain Property
IConnector Interface See Also Send Feedback
The domain of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
Domain Domain { get; }
Visual Basic
ReadOnly Property Domain As Domain
    Get
Visual C++
property Domain Domain {
    Domain get ();
}

Remarks

This property is used to retrieve the domain of the connector.

See Also

IConnector Interface


Height Property

[image]

Revit 2024 API
IConnector..::..Height Property
IConnector Interface See Also Send Feedback
The height of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
double Height { get; }
Visual Basic
ReadOnly Property Height As Double
    Get
Visual C++
property double Height {
    double get ();
}

Remarks

This property is used to retrieve the height of the connector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the connector's shape is not rectangular.

See Also

IConnector Interface


Origin Property

[image]

Revit 2024 API
IConnector..::..Origin Property
IConnector Interface See Also Send Feedback
The location of the connector in family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
XYZ Origin { get; }
Visual Basic
ReadOnly Property Origin As XYZ
    Get
Visual C++
property XYZ^ Origin {
    XYZ^ get ();
}

Remarks

This property is used to retrieve the origin of the connector.

See Also

IConnector Interface


Radius Property

[image]

Revit 2024 API
IConnector..::..Radius Property
IConnector Interface See Also Send Feedback
The radius of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
double Radius { get; }
Visual Basic
ReadOnly Property Radius As Double
    Get
Visual C++
property double Radius {
    double get ();
}

Remarks

This property is used to retrieve the radius of the connector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the connector's shape is not round.

See Also

IConnector Interface


Shape Property

[image]

Revit 2024 API
IConnector..::..Shape Property
IConnector Interface See Also Send Feedback
The shape of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
ConnectorProfileType Shape { get; }
Visual Basic
ReadOnly Property Shape As ConnectorProfileType
    Get
Visual C++
property ConnectorProfileType Shape {
    ConnectorProfileType get ();
}

Remarks

This property is used to retrieve the shape of the connector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Throw when this connector has no shape.

See Also

IConnector Interface


Width Property

[image]

Revit 2024 API
IConnector..::..Width Property
IConnector Interface See Also Send Feedback
The width of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
double Width { get; }
Visual Basic
ReadOnly Property Width As Double
    Get
Visual C++
property double Width {
    double get ();
}

Remarks

This property is used to retrieve the width of the connector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the connector's shape is not rectangular.

See Also

IConnector Interface


ICustomFieldProperties Interface

[image]

Revit 2024 API
ICustomFieldProperties Interface
Members See Also Send Feedback
Represents the base class for the properties of a custom field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public interface ICustomFieldProperties
Visual Basic
Public Interface ICustomFieldProperties
Visual C++
public interface class ICustomFieldProperties

See Also

ICustomFieldProperties Members


ICustomFieldProperties Methods

[image] [image]

Revit 2024 API
ICustomFieldProperties Methods
ICustomFieldProperties Interface See Also Send Feedback

The ICustomFieldProperties type exposes the following members.

Methods

 | Name | Description
Public method | AreEqualTo | Identifies if the custom field properties are equal or not.

See Also

ICustomFieldProperties Interface


AreEqualTo Method

[image]

Revit 2024 API
ICustomFieldProperties..::..AreEqualTo Method
ICustomFieldProperties Interface See Also Send Feedback
Identifies if the custom field properties are equal or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
bool AreEqualTo(
    ICustomFieldProperties otherProperties
)
Visual Basic
Function AreEqualTo ( _
    otherProperties As ICustomFieldProperties _
) As Boolean
Visual C++
bool AreEqualTo(
    ICustomFieldProperties^ otherProperties
)

Parameters

otherProperties
Type: Autodesk.Revit.DB..::..ICustomFieldProperties
The other properties.

Return Value

Returns true if the custom field properties are equal, false otherwise.

See Also

ICustomFieldProperties Interface


IDataConversionMonitor Interface

[image]

Revit 2024 API
IDataConversionMonitor Interface
Members See Also Send Feedback
A base class for an application-specific logger. It should be used to track errors during conversion and/or , track conversion progress, cancel a conversion process if necessary. Implementing a logger class is optional, but highly recommended for all but most basic data converters. The base class is UI- and language-independent. It is up to the using app to implement UI. Language-specifc data may be used to communicate information to application users. English should be used to communicate data of interest to Revit development.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public interface IDataConversionMonitor
Visual Basic
Public Interface IDataConversionMonitor
Visual C++
public interface class IDataConversionMonitor

See Also

IDataConversionMonitor Members


IDataConversionMonitor Members

[image] [image]

Revit 2024 API
IDataConversionMonitor Members
IDataConversionMonitor Interface Methods See Also Send Feedback

The IDataConversionMonitor type exposes the following members.

Methods

Name Description
Public method GetVerbosity
Reports requested verbosity level
Public method ProcessMessage
The default implementation ignores input and always returns true. The using app should override the behavior as necessary. Some examples of overridden behavior are 1. Someone is developing a classic Revit add-on that imports STEP AP 203 solids. She will implement a log object such that a) At each imported face (logMessage() called with LogMessage::FaceCreated as first argument) the log object will update count of imported faces and call an application-specific progress indicator where appropriate b) If the app gets a cancel request between the calls to logMessage(), the next call will return false. The Import API will then cancel the conversion and clean up the intermediate data. 2. Someone is implementing a web service to convert IFC files to RVT. As a part of that service UI, the user would like to cancel the conversion on the first error in order to avoid being charged for storage/processor time. The implementation of logMessage() in that case would be different: the cancellation request would be based on severity of the error. The app would probably want to keep a detailed count of entities converted. 3. Someone is implementing an IFC importer. Each API call is fast enough that cancelation/progress requests are handled by the application. Problems with data should be reported to the user, but the conversion should go on regardless. The app collects its own conversion statistics. The app developer implements logMessage() to accumulate reported errors and appends the formatted results to her conversion report. The overloaded logMessage() always returns true, since all cancellations are handled by the app.

See Also

IDataConversionMonitor Interface


IDataConversionMonitor Methods

[image] [image]

Revit 2024 API
IDataConversionMonitor Methods
IDataConversionMonitor Interface See Also Send Feedback

The IDataConversionMonitor type exposes the following members.

Methods

Name Description
Public method GetVerbosity
Reports requested verbosity level
Public method ProcessMessage
The default implementation ignores input and always returns true. The using app should override the behavior as necessary. Some examples of overridden behavior are 1. Someone is developing a classic Revit add-on that imports STEP AP 203 solids. She will implement a log object such that a) At each imported face (logMessage() called with LogMessage::FaceCreated as first argument) the log object will update count of imported faces and call an application-specific progress indicator where appropriate b) If the app gets a cancel request between the calls to logMessage(), the next call will return false. The Import API will then cancel the conversion and clean up the intermediate data. 2. Someone is implementing a web service to convert IFC files to RVT. As a part of that service UI, the user would like to cancel the conversion on the first error in order to avoid being charged for storage/processor time. The implementation of logMessage() in that case would be different: the cancellation request would be based on severity of the error. The app would probably want to keep a detailed count of entities converted. 3. Someone is implementing an IFC importer. Each API call is fast enough that cancelation/progress requests are handled by the application. Problems with data should be reported to the user, but the conversion should go on regardless. The app collects its own conversion statistics. The app developer implements logMessage() to accumulate reported errors and appends the formatted results to her conversion report. The overloaded logMessage() always returns true, since all cancellations are handled by the app.

See Also

IDataConversionMonitor Interface


GetVerbosity Method

[image]

Revit 2024 API
IDataConversionMonitor..::..GetVerbosity Method
IDataConversionMonitor Interface See Also Send Feedback
Reports requested verbosity level

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
DataExchangeMessageVerbosity GetVerbosity()
Visual Basic
Function GetVerbosity As DataExchangeMessageVerbosity
Visual C++
DataExchangeMessageVerbosity GetVerbosity()

See Also

IDataConversionMonitor Interface


ProcessMessage Method

[image]

Revit 2024 API
IDataConversionMonitor..::..ProcessMessage Method
IDataConversionMonitor Interface See Also Send Feedback
The default implementation ignores input and always returns true. The using app should override the behavior as necessary. Some examples of overridden behavior are 1. Someone is developing a classic Revit add-on that imports STEP AP 203 solids. She will implement a log object such that a) At each imported face (logMessage() called with LogMessage::FaceCreated as first argument) the log object will update count of imported faces and call an application-specific progress indicator where appropriate b) If the app gets a cancel request between the calls to logMessage(), the next call will return false. The Import API will then cancel the conversion and clean up the intermediate data. 2. Someone is implementing a web service to convert IFC files to RVT. As a part of that service UI, the user would like to cancel the conversion on the first error in order to avoid being charged for storage/processor time. The implementation of logMessage() in that case would be different: the cancellation request would be based on severity of the error. The app would probably want to keep a detailed count of entities converted. 3. Someone is implementing an IFC importer. Each API call is fast enough that cancelation/progress requests are handled by the application. Problems with data should be reported to the user, but the conversion should go on regardless. The app collects its own conversion statistics. The app developer implements logMessage() to accumulate reported errors and appends the formatted results to her conversion report. The overloaded logMessage() always returns true, since all cancellations are handled by the app.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
bool ProcessMessage(
    DataExchangeMessageId messageId,
    DataExchangeMessageSeverity messageSeverity,
    IList<string> entityIds
)
Visual Basic
Function ProcessMessage ( _
    messageId As DataExchangeMessageId, _
    messageSeverity As DataExchangeMessageSeverity, _
    entityIds As IList(Of String) _
) As Boolean
Visual C++
bool ProcessMessage(
    DataExchangeMessageId messageId,
    DataExchangeMessageSeverity messageSeverity,
    IList<String^>^ entityIds
)

Parameters

messageId
Type: Autodesk.Revit.DB..::..DataExchangeMessageId
Indicates a specific event during data conversion.
messageSeverity
Type: Autodesk.Revit.DB..::..DataExchangeMessageSeverity
Indicates a severity of the event.
entityIds
Type: System.Collections.Generic..::..IList<(Of <(<'String>)>)>
Input objects affected by the reported event.

Return Value

If the function returns true, the import API will continue conversion. Otherwise, it will be cancelled and all intermediate data reset.

See Also

IDataConversionMonitor Interface


IDuplicateTypeNamesHandler Interface

[image]

Revit 2024 API
IDuplicateTypeNamesHandler Interface
Members See Also Send Feedback
An interface for custom handlers of duplicate type names encountered during a paste operation. When the destination document contains types that have the same names as the types being copied, but different internals, a decision must be made on how to proceed - whether to cancel the operation or continue, but only copy types with unique names.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public interface IDuplicateTypeNamesHandler
Visual Basic
Public Interface IDuplicateTypeNamesHandler
Visual C++
public interface class IDuplicateTypeNamesHandler

See Also

IDuplicateTypeNamesHandler Members


IDuplicateTypeNamesHandler Members

[image] [image]

Revit 2024 API
IDuplicateTypeNamesHandler Members
IDuplicateTypeNamesHandler Interface Methods See Also Send Feedback

The IDuplicateTypeNamesHandler type exposes the following members.

Methods

 | Name | Description
Public method | OnDuplicateTypeNamesFound | Called when the destination document contains types with the same names as the types being copied.

See Also

IDuplicateTypeNamesHandler Interface


OnDuplicateTypeNamesFound Method

[image]

Revit 2024 API
IDuplicateTypeNamesHandler..::..OnDuplicateTypeNamesFound Method
IDuplicateTypeNamesHandler Interface See Also Send Feedback
Called when the destination document contains types with the same names as the types being copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
DuplicateTypeAction OnDuplicateTypeNamesFound(
    DuplicateTypeNamesHandlerArgs args
)
Visual Basic
Function OnDuplicateTypeNamesFound ( _
    args As DuplicateTypeNamesHandlerArgs _
) As DuplicateTypeAction
Visual C++
DuplicateTypeAction OnDuplicateTypeNamesFound(
    DuplicateTypeNamesHandlerArgs^ args
)

Parameters

args
Type: Autodesk.Revit.DB..::..DuplicateTypeNamesHandlerArgs
The information about the types with duplicate names.

Return Value

The action to be taken: copy only types with unique names or cancel the operation.

See Also

IDuplicateTypeNamesHandler Interface


IExportContext Interface

[image]

Revit 2024 API
IExportContext Interface
Members See Also Send Feedback
An interface that is used in custom export to process a Revit model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public interface IExportContext
Visual Basic
Public Interface IExportContext
Visual C++
public interface class IExportContext

Remarks

An instance of a class that implements this interface is passed in as a parameter of the CustomExporter constructor. The methods of the context are then called at times of exporting entities of the model.

This is a base class for two other interfaces derived from it: IPhotoRenderContext and IModelExportContext. This base class contains methods that are common to both the leaf interfaces. Although it is still possible to use classes deriving directly from this base interface (for backward compatibility), future applications should implement the new leaf interfaces only.

See Also

IExportContext Members


IExportContext Members

[image] [image]

Revit 2024 API
IExportContext Members
IExportContext Interface Methods See Also Send Feedback

The IExportContext type exposes the following members.

Methods

 | Name | Description
Public method | Finish | This method is called at the very end of the export process, after all entities were processed (or after the process was cancelled).
Public method | IsCanceled | This method is queried at the beginning of every element.
Public method | OnElementBegin | This method marks the beginning of an element to be exported.
Public method | OnElementEnd | This method marks the end of an element being exported.
Public method | OnFaceBegin | This method marks the beginning of a Face to be exported.
Public method | OnFaceEnd | This method marks the end of the current face being exported.
Public method | OnInstanceBegin | This method marks the start of processing of an instance node (e.g. a family instance).
Public method | OnInstanceEnd | This method marks the end of processing of an Instance Node (e.g. a family instance).
Public method | OnLight | This method marks the beginning of export of a light which is enabled for rendering.
Public method | OnLinkBegin | This method marks the beginning of a link instance to be exported.
Public method | OnLinkEnd | This method marks the end of a link instance being exported.
Public method | OnMaterial | This method marks a change of the material.
Public method | OnPolymesh | This method is called when a tessellated polymesh of a 3d face is being output.
Public method | OnRPC | This method marks the beginning of export of an RPC object.
Public method | OnViewBegin | This method marks the beginning of a 3D view to be exported.
Public method | OnViewEnd | This method marks the end of a 3D view being exported.
Public method | Start | This method is called at the very start of the export process, still before the first entity of the model was send out.

See Also

IExportContext Interface


Finish Method

[image]

Revit 2024 API
IExportContext..::..Finish Method
IExportContext Interface See Also Send Feedback
This method is called at the very end of the export process, after all entities were processed (or after the process was cancelled).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
void Finish()
Visual Basic
Sub Finish
Visual C++
void Finish()

See Also

IExportContext Interface


IsCanceled Method

[image]

Revit 2024 API
IExportContext..::..IsCanceled Method
IExportContext Interface See Also Send Feedback
This method is queried at the beginning of every element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
bool IsCanceled()
Visual Basic
Function IsCanceled As Boolean
Visual C++
bool IsCanceled()

Return Value

Return True if you wish to cancel the exporting process, or False otherwise.

See Also

IExportContext Interface


OnElementEnd Method

[image]

Revit 2024 API
IExportContext..::..OnElementEnd Method
IExportContext Interface See Also Send Feedback
This method marks the end of an element being exported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
void OnElementEnd(
    ElementId elementId
)
Visual Basic
Sub OnElementEnd ( _
    elementId As ElementId _
)
Visual C++
void OnElementEnd(
    ElementId^ elementId
)

Parameters

elementId
Type: Autodesk.Revit.DB..::..ElementId
The Id of the element that has just been processed.

Remarks

This method is never called for 2D export (see cref="Autodesk::Revit::DB::IExportContext2D").

See Also

IExportContext Interface


OnFaceBegin Method

[image]

Revit 2024 API
IExportContext..::..OnFaceBegin Method
IExportContext Interface Example See Also Send Feedback
This method marks the beginning of a Face to be exported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
RenderNodeAction OnFaceBegin(
    FaceNode node
)
Visual Basic
Function OnFaceBegin ( _
    node As FaceNode _
) As RenderNodeAction
Visual C++
RenderNodeAction OnFaceBegin(
    FaceNode^ node
)

Parameters

node
Type: Autodesk.Revit.DB..::..FaceNode
An output node that represents a Face.

Return Value

Return RenderNodeAction. Proceed if you wish to receive geometry (polymesh) for this face, or return RenderNodeAction.Skip otherwise.

Remarks

Note that this method (as well as OnFaceEnd) is invoked only if the custom exporter was set up to include geometric objects in the output stream. See IncludeGeometricObjects for mode details.

Examples

CopyC#
/// <summary>
/// This code demonstrates how to process face geometry
/// </summary>
/// <remarks>
/// This method is invoked only if the custom exporter was set to include faces.
/// </remarks>
public RenderNodeAction OnFaceBegin(FaceNode node)
{
   // Get the get the actual geometric face and all information about it
   // and its edges by using standard API for Face and Edge
   Face theFace = node.GetFace();
   double area = theFace.Area;
   if (theFace.HasRegions)
   {
      IList<Face> regionedFaces = theFace.GetRegions();
   }

   // We can either skip this face or proceed with rendering it depending on
   // whether our export process can handle face geometry or not. If we choose
   // to proceed, we get calls to export tessellated meshes for this face.
   if (true == ExportAFace(theFace))
   {
      return RenderNodeAction.Skip;
   }
   return RenderNodeAction.Proceed;
}

/// <summary>
/// This code marks the end of processing a face
/// </summary>
/// <remarks>
/// This method is invoked only if the custom exporter was set to include faces.
/// </remarks>
public void OnFaceEnd(FaceNode node)
{
   // Note: This method is invoked even for faces that were skipped.
}

/// <summary>
/// Assuming this would be the method that processes faces and exports them in our proprietary format.
/// </summary>
/// <remarks>
/// For example, we can decide that our format supports planar faces only, but no curved surfaces.
/// Or we can support basic surfaces only (planar, spherical, cylindrical), but not complex faces.
/// This is, naturally, depending on what a particular custom exporter is designed to output.
/// </remarks>
/// <returns>
/// Should return True if the face could be handled (exported), False otherwise.
/// </returns>
private bool ExportAFace(Face face)
{
   return false;  // in this case,
}
CopyVB.NET
' <summary>
' This code demonstrates how to process face geometry
' </summary>
' <remarks>
' This method is invoked only if the custom exporter was set to include faces.
' </remarks>
Public Function OnFaceBegin(node As FaceNode) As RenderNodeAction Implements IExportContext.OnFaceBegin
    ' Get the get the actual geometric face and all information about it
    ' and its edges by using standard API for Face and Edge
    Dim theFace As Face = node.GetFace()
    Dim area As Double = theFace.Area
    If theFace.HasRegions Then
        Dim regionedFaces As IList(Of Face) = theFace.GetRegions()
    End If

    ' We can either skip this face or proceed with rendering it depending on
    ' whether our export process can handle face geometry or not. If we choose
    ' to proceed, we get calls to export tessellated meshes for this face.
    If True = ExportAFace(theFace) Then
        Return RenderNodeAction.Skip
    End If
    Return RenderNodeAction.Proceed
End Function

' <summary>
' This code marks the end of processing a face
' </summary>
' <remarks>
' This method is invoked only if the custom exporter was set to include faces.
' </remarks>
Public Sub OnFaceEnd(node As FaceNode) Implements IExportContext.OnFaceEnd
    ' Note: This method is invoked even for faces that were skipped.
End Sub

' <summary>
' Assuming this would be the method that processes faces and exports them in our proprietary format.
' </summary>
' <remarks>
' For example, we can decide that our format supports planar faces only, but no curved surfaces.
' Or we can support basic surfaces only (planar, spherical, cylindrical), but not complex faces.
' This is, naturally, depending on what a particular custom exporter is designed to output.
' </remarks>
' <returns>
' Should return True if the face could be handled (exported), False otherwise.
' </returns>
Private Function ExportAFace(face As Face) As Boolean
    Return False
    ' in this case,
End Function

See Also

IExportContext Interface


OnFaceEnd Method

[image]

Revit 2024 API
IExportContext..::..OnFaceEnd Method
IExportContext Interface See Also Send Feedback
This method marks the end of the current face being exported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
void OnFaceEnd(
    FaceNode node
)
Visual Basic
Sub OnFaceEnd ( _
    node As FaceNode _
)
Visual C++
void OnFaceEnd(
    FaceNode^ node
)

Parameters

node
Type: Autodesk.Revit.DB..::..FaceNode
An output node that represents a Face.

See Also

IExportContext Interface


OnInstanceBegin Method

[image]

Revit 2024 API
IExportContext..::..OnInstanceBegin Method
IExportContext Interface Example See Also Send Feedback
This method marks the start of processing of an instance node (e.g. a family instance).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
RenderNodeAction OnInstanceBegin(
    InstanceNode node
)
Visual Basic
Function OnInstanceBegin ( _
    node As InstanceNode _
) As RenderNodeAction
Visual C++
RenderNodeAction OnInstanceBegin(
    InstanceNode^ node
)

Parameters

node
Type: Autodesk.Revit.DB..::..InstanceNode

Return Value

Return RenderNodeAction.Skip if you wish to skip processing this family instance, or return RenderNodeAction.Proceed otherwise.

Examples

CopyC#
/// <summary>
/// This method marks the start of processing of an Instance node (e.g. a family instance).
/// </summary>
public RenderNodeAction OnInstanceBegin(InstanceNode node)
{
   // We can get particular information about the family instance and its type if we need to
   ElementId symbolId = node.GetSymbolGeometryId().SymbolId;
   FamilySymbol famSymbol = m_document.GetElement(symbolId) as FamilySymbol;

   // Typically, an export context has to manage a stack of transformation
   // for all nested objects, such as instances, lights, links, etc.
   // A combined transformation needs to be applied to the incoming geometry
   // (providing all geometry is to be flattened in the resultant format.)
   m_TransformationStack.Push(m_TransformationStack.Peek().Multiply(node.GetTransform()));

   // We can either skip this instance or proceed with rendering it.
   return RenderNodeAction.Proceed;
}

/// <summary>
/// This method marks the end of processing of an Instance Node (e.g. a family instance).
/// </summary>
public void OnInstanceEnd(InstanceNode node)
{
   // Note: This method is invoked even for instances that were skipped.

   // If we maintain a transformation stack, we need to remove the latest one from it.
   m_TransformationStack.Pop();
}
CopyVB.NET
' <summary>
' This method marks the end of processing of an Instance Node (e.g. a family instance).
' </summary>
Public Function OnInstanceBegin(node As InstanceNode) As RenderNodeAction Implements IExportContext.OnInstanceBegin
    ' We can get particular information about the family instance and its type if we need to
    Dim symbolId As ElementId = node.GetSymbolGeometryId().SymbolId
    Dim famSymbol As FamilySymbol = TryCast(m_document.GetElement(symbolId), FamilySymbol)

    ' Typically, an export context has to manage a stack of transformation
    ' for all nested objects, such as instances, lights, links, etc.
    ' A combined transformation needs to be applied to the incoming geometry
    ' (providing all geometry is to be flattened in the resultant format.)
    m_TransformationStack.Push(m_TransformationStack.Peek().Multiply(node.GetTransform()))

    ' We can either skip this instance or proceed with rendering it.
    Return RenderNodeAction.Proceed
End Function

' <summary>
' This method marks the end of processing a family instance
' </summary>
Public Sub OnInstanceEnd(node As InstanceNode) Implements IExportContext.OnInstanceEnd
    ' Note: This method is invoked even for instances that were skipped.

    ' If we maintain a transformation stack, we need to remove the latest one from it.
    m_TransformationStack.Pop()
End Sub

See Also

IExportContext Interface


OnLinkBegin Method

[image]

Revit 2024 API
IExportContext..::..OnLinkBegin Method
IExportContext Interface Example See Also Send Feedback
This method marks the beginning of a link instance to be exported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
RenderNodeAction OnLinkBegin(
    LinkNode node
)
Visual Basic
Function OnLinkBegin ( _
    node As LinkNode _
) As RenderNodeAction
Visual C++
RenderNodeAction OnLinkBegin(
    LinkNode^ node
)

Parameters

node
Type: Autodesk.Revit.DB..::..LinkNode

Return Value

Return RenderNodeAction.Skip if you wish to skip processing this link instance, or return RenderNodeAction.Proceed otherwise.

Examples

CopyC#
/// <summary>
/// This code demonstrates how to process instances of Revit links.
/// </summary>
public RenderNodeAction OnLinkBegin(LinkNode node)
{
   // We can get more information about the Revit Link and its type if we need to
   ElementId symbolId = node.SymbolId;
   RevitLinkType linkType = m_document.GetElement(symbolId) as RevitLinkType;
   String linkDocumentName = linkType.Name;

   // Typically, an export context has to manage a stack of transformation
   // for all nested objects, such as instances, lights, links, etc.
   // A combined transformation needs to be applied to the incoming geometry
   // (providing all geometry is to be flattened in the resultant format.)
   m_TransformationStack.Push(m_TransformationStack.Peek().Multiply(node.GetTransform()));

   // We can either skip this link instance or proceed with rendering it
   return RenderNodeAction.Proceed;
}

/// <summary>
/// This method marks the end of processing a Revit link
/// </summary>
public void OnLinkEnd(LinkNode node)
{
   // Note: This method is invoked even for instances that were skipped.

   // If we maintain a transformation stack, we need to remove the latest one from it.
   m_TransformationStack.Pop();
}
CopyVB.NET
' <summary>
' This code demonstrates how to process instances of Revit links.
' </summary>
Public Function OnLinkBegin(node As LinkNode) As RenderNodeAction Implements IExportContext.OnLinkBegin
    ' We can get more information about the Revit Link and its type if we need to
    Dim symbolId As ElementId = node.SymbolId
    Dim linkType As RevitLinkType = TryCast(m_document.GetElement(symbolId), RevitLinkType)
    Dim linkDocumentName As [String] = linkType.Name

    ' Typically, an export context has to manage a stack of transformation
    ' for all nested objects, such as instances, lights, links, etc.
    ' A combined transformation needs to be applied to the incoming geometry
    ' (providing all geometry is to be flattened in the resultant format.)
    m_TransformationStack.Push(m_TransformationStack.Peek().Multiply(node.GetTransform()))

    ' We can either skip this link instance or proceed with rendering it
    Return RenderNodeAction.Proceed
End Function

' <summary>
' This method marks the end of processing a Revit link
' </summary>
Public Sub OnLinkEnd(node As LinkNode) Implements IExportContext.OnLinkEnd
    ' Note: This method is invoked even for instances that were skipped.

    ' If we maintain a transformation stack, we need to remove the latest one from it.
    m_TransformationStack.Pop()
End Sub

See Also

IExportContext Interface


OnMaterial Method

[image]

Revit 2024 API
IExportContext..::..OnMaterial Method
IExportContext Interface Example See Also Send Feedback
This method marks a change of the material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
void OnMaterial(
    MaterialNode node
)
Visual Basic
Sub OnMaterial ( _
    node As MaterialNode _
)
Visual C++
void OnMaterial(
    MaterialNode^ node
)

Parameters

node
Type: Autodesk.Revit.DB..::..MaterialNode
A node describing the current material.

Examples

CopyC#
ElementId currentMaterialId = ElementId.InvalidElementId;
Color currentColor = new Color(0,0,0);
double currentTransparency = 0;
Asset currentAppearance = null;

/// <summary>
/// This code demonstrates how to process material information
/// </summary>
/// <remarks>
/// OnMaterial method can be invoked for every single out-coming mesh
/// even when the material has not actually changed. Thus it is usually
/// beneficial to store the current material and only get its attributes
/// when the material actually changes.
/// </remarks>
public void OnMaterial(MaterialNode node)
{
   // acquire properties of the material if it is different
   // than the material we have set as the currently applicable
   if (currentMaterialId != node.MaterialId)
   {
      if (node.MaterialId != ElementId.InvalidElementId)
      {
         currentColor = node.Color;
         currentTransparency = node.Transparency;
      }
      else
      {
         // the default material is being used in this case
      }

      // Appearance Asset is mainly for Revit internal use. However, if it is utilized
      // in the export context, it needs to be checked whether or not the asset of the
      // material is overridden by some local modification (e.g. by applying a decal)

      if (node.HasOverriddenAppearance)
      {
         currentAppearance = node.GetAppearanceOverride();
      }
      else
      {
         currentAppearance = node.GetAppearance();
      }
   }
}
CopyVB.NET
Private currentMaterialId As ElementId = ElementId.InvalidElementId
Private currentColor As New Color(0, 0, 0)
Private currentTransparency As Double = 0
Private currentAppearance As Asset = Nothing

' <summary>
' This code demonstrates how to process material information
' </summary>
' <remarks>
' OnMaterial method can be invoked for every single out-coming mesh
' even when the material has not actually changed. Thus it is usually
' beneficial to store the current material and only get its attributes
' when the material actually changes.
' </remarks>
Public Sub OnMaterial(node As MaterialNode) Implements IExportContext.OnMaterial
    ' acquire properties of the material if it is different
    ' than the material we have set as the currently applicable
    If currentMaterialId <> node.MaterialId Then
        If node.MaterialId <> ElementId.InvalidElementId Then
            currentColor = node.Color
            currentTransparency = node.Transparency
            ' the default material is being used in this case
        Else
        End If

        ' Appearance Asset is mainly for Revit internal use. However, if it is utilized
        ' in the export context, it needs to be checked whether or not the asset of the
        ' material is overridden by some local modification (e.g. by applying a decal)

        If node.HasOverriddenAppearance Then
            currentAppearance = node.GetAppearanceOverride()
        Else
            currentAppearance = node.GetAppearance()
        End If
    End If
End Sub

See Also

IExportContext Interface


OnPolymesh Method

[image]

Revit 2024 API
IExportContext..::..OnPolymesh Method
IExportContext Interface Example See Also Send Feedback
This method is called when a tessellated polymesh of a 3d face is being output.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
void OnPolymesh(
    PolymeshTopology node
)
Visual Basic
Sub OnPolymesh ( _
    node As PolymeshTopology _
)
Visual C++
void OnPolymesh(
    PolymeshTopology^ node
)

Parameters

node
Type: Autodesk.Revit.DB..::..PolymeshTopology
A node representing topology of the polymesh

Examples

CopyC#
/// <summary>
/// This method is called up for every face that was processed and tessellated
/// </summary>
/// <remarks>
/// The node provides all information about geometric topology if the mesh.
/// It is assumed that a concrete exporter would consume the part it can
/// understand and/or support (vertices, normals, UVs, etc.) and convert
/// them into the final, export format.
/// </remarks>
public void OnPolymesh(PolymeshTopology node)
{
   // Note: the current material will get applied to the polymesh.

   // If a stack of transformation is maintained by the context object,
   // the current combined transform will be applied to the points.
   Transform currentTransform = m_TransformationStack.Peek();

   // basic properties of the mesh

   int numberOfFacet = node.NumberOfFacets;
   int numberOfPoints = node.NumberOfPoints;
   int numberOfUVs = node.NumberOfUVs;
   int numberOfNormal = node.NumberOfNormals;

   // Note: Normals are associated with either points or facets of the polymesh
   // The export code must account for different processing of these two cases.

   // A) process points of the polymesh

   if( node.DistributionOfNormals == DistributionOfNormals.AtEachPoint )
   {
      ExportMeshPoints(node.GetPoints(), currentTransform, node.GetNormals() );
   }
   else if( node.DistributionOfNormals == DistributionOfNormals.OnePerFace )
   {
      ExportMeshPoints(node.GetPoints(), currentTransform, node.GetNormal(0) );
   }
   else  // DistributionOfNormals.OnEachFacet
   {
      // In this case, there is normal vector associated with each facet
      // Depending on the export, our format either support this case,
      // of we would have to determine what normals to apply at each
      // point by a way of combining normal of the surrounding facets.
      ExportMeshPoints(node.GetPoints(), currentTransform );
   }

   // B Process facets of the polymesh

   if( node.DistributionOfNormals == DistributionOfNormals.OnEachFacet )
   {
      ExportMeshFacets(node.GetFacets(), node.GetNormals() );
   }
   else
   {
      ExportMeshFacets(node.GetFacets(), null );
   }

   // B) Process UV coordinates if available (and applicable)

   if( node.NumberOfUVs > 0 )
   {
      ExportMeshUVs( node.GetUVs() );
   }
}

private void ExportMeshPoints(IList<XYZ> points, Transform trf, IList<XYZ> normals)
{
   // process points with normals
}

private void ExportMeshPoints(IList<XYZ> points, Transform trf, XYZ normal)
{
   // process points with only one normal vector (a planar face)
}

private void ExportMeshPoints(IList<XYZ> points, Transform trf)
{
   // process points without normal (assuming normals are associated with facets instead)
}

private void ExportMeshFacets(IList<PolymeshFacet> facets, IList<XYZ> normals)
{
   if (normals == null)
   {
      // process facets without normals  (assuming normals are associated with points instead)
   }
   else
   {
      // process facets with normals
   }
}

private void ExportMeshUVs(IList<UV> UVs)
{
   // process UVs
}
CopyVB.NET
' <summary>
' This method is called up for every face that was processed and tessellated
' </summary>
' <remarks>
' The node provides all information about geometric topology if the mesh.
' It is assumed that a concrete exporter would consume the part it can
' understand and/or support (vertices, normals, UVs, etc.) and convert
' them into the final, export format.
' </remarks>
Public Sub OnPolymesh(node As PolymeshTopology) Implements IExportContext.OnPolymesh
    ' Note: the current material will get applied to the polymesh.

    ' If a stack of transformation is maintained by the context object,
    ' the current combined transform will be applied to the points.
    Dim currentTransform As Transform = m_TransformationStack.Peek()

    ' basic properties of the mesh

    Dim numberOfFacet As Integer = node.NumberOfFacets
    Dim numberOfPoints As Integer = node.NumberOfPoints
    Dim numberOfUVs As Integer = node.NumberOfUVs
    Dim numberOfNormal As Integer = node.NumberOfNormals

    ' Note: Normals are associated with either points or facets of the polymesh
    ' The export code must account for different processing of these two cases.

    ' A) process points of the polymesh

    If node.DistributionOfNormals = DistributionOfNormals.AtEachPoint Then
        ExportMeshPoints(node.GetPoints(), currentTransform, node.GetNormals())
    ElseIf node.DistributionOfNormals = DistributionOfNormals.OnePerFace Then
        ExportMeshPoints(node.GetPoints(), currentTransform, node.GetNormal(0))
    Else
        ' DistributionOfNormals.OnEachFacet
        ' In this case, there is normal vector associated with each facet
        ' Depending on the export, our format either support this case,
        ' of we would have to determine what normals to apply at each
        ' point by a way of combining normal of the surrounding facets.
        ExportMeshPoints(node.GetPoints(), currentTransform)
    End If

    ' B Process facets of the polymesh

    If node.DistributionOfNormals = DistributionOfNormals.OnEachFacet Then
        ExportMeshFacets(node.GetFacets(), node.GetNormals())
    Else
        ExportMeshFacets(node.GetFacets(), Nothing)
    End If

    ' B) Process UV coordinates if available (and applicable)

    If node.NumberOfUVs > 0 Then
        ExportMeshUVs(node.GetUVs())
    End If
End Sub

Private Sub ExportMeshPoints(points As IList(Of XYZ), trf As Transform, normals As IList(Of XYZ))
    ' process points with normals
End Sub

Private Sub ExportMeshPoints(points As IList(Of XYZ), trf As Transform, normal As XYZ)
    ' process points with only one normal vector (a planar face)
End Sub

Private Sub ExportMeshPoints(points As IList(Of XYZ), trf As Transform)
    ' process points without normal (assuming normals are associated with facets instead)
End Sub

Private Sub ExportMeshFacets(facets As IList(Of PolymeshFacet), normals As IList(Of XYZ))
    ' process facets without normals  (assuming normals are associated with points instead)
    If normals Is Nothing Then
        ' process facets with normals
    Else
    End If
End Sub

Private Sub ExportMeshUVs(UVs As IList(Of UV))
    ' process UVs
End Sub

See Also

IExportContext Interface


OnViewBegin Method

[image]

Revit 2024 API
IExportContext..::..OnViewBegin Method
IExportContext Interface Example See Also Send Feedback
This method marks the beginning of a 3D view to be exported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
RenderNodeAction OnViewBegin(
    ViewNode node
)
Visual Basic
Function OnViewBegin ( _
    node As ViewNode _
) As RenderNodeAction
Visual C++
RenderNodeAction OnViewBegin(
    ViewNode^ node
)

Parameters

node
Type: Autodesk.Revit.DB..::..ViewNode
Geometry node associated with the view.

Return Value

Return RenderNodeAction.Skip if you wish to skip exporting this view, or return RenderNodeAction.Proceed otherwise.

Examples

CopyC#
/// <summary>
/// This method marks the start of processing a view (a 3D view)
/// </summary>
public RenderNodeAction OnViewBegin(ViewNode node)
{
   // If we did not do so before we invoked the custom export
   // we can get information about the view from the supplied view node,
   // That includes : rendering settings, sun settings, camera data, etc.

   // Get the view information from the node.
   View3D theView = m_document.GetElement(node.ViewId) as View3D;
   string viewName = theView.Name;

   // Get the view's Orientation information.
   ViewOrientation3D theOrientation = theView.GetOrientation();

   // Get the view's camera information, such as whether is a perspective view.
   CameraInfo camera = node.GetCameraInfo();
   bool isPerspective = camera.IsPespective;

   // Get the view's render setting information, such as background style.
   RenderingSettings renderSettings = theView.GetRenderingSettings();
   BackgroundStyle bkStyle = renderSettings.BackgroundStyle;

   // Get the view's sun related information
   SunAndShadowSettings sun = theView.SunAndShadowSettings;

   // We can also determine whether we need to process instance of light objects (OnLight)
   bool needToExportLight =
      (renderSettings.LightingSource != LightingSource.ExteriorSun) &&
      (renderSettings.LightingSource != LightingSource.InteriorSun);

   // We can either skip this view or proceed with rendering it
   return RenderNodeAction.Proceed;
}

/// <summary>
/// This method marks the end of processing a view (a 3D view)
/// </summary>
public void OnViewEnd(ElementId elementId)
{
   // elementId it indicates which view has just been exported

   // Note: This method is invoked even for a view that was skipped.
}
CopyVB.NET
' <summary>
' This method marks the start of processing a view (a 3D view)
' </summary>
Public Function OnViewBegin(node As ViewNode) As RenderNodeAction Implements IExportContext.OnViewBegin
    ' If we did not do so before we invoked the custom export
    ' we can get information about the view from the supplied view node,
    ' That includes : rendering settings, sun settings, camera data, etc.

    ' Get the view information from the node.
    Dim theView As View3D = TryCast(m_document.GetElement(node.ViewId), View3D)
    Dim viewName As String = theView.Name

    ' Get the view's Orientation information.
    Dim theOrientation As ViewOrientation3D = theView.GetOrientation()

    ' Get the view's camera information, such as whether is a perspective view.
    Dim camera As CameraInfo = node.GetCameraInfo()
    Dim isPerspective As Boolean = camera.IsPespective

    ' Get the view's render setting information, such as background style.
    Dim renderSettings As RenderingSettings = theView.GetRenderingSettings()
    Dim bkStyle As BackgroundStyle = renderSettings.BackgroundStyle

    ' Get the view's sun related information
    Dim sun As SunAndShadowSettings = theView.SunAndShadowSettings

    ' We can also determine whether we need to process instance of light objects (OnLight)
    Dim needToExportLight As Boolean = (renderSettings.LightingSource <> LightingSource.ExteriorSun) AndAlso (renderSettings.LightingSource <> LightingSource.InteriorSun)

    ' We can either skip this view or proceed with rendering it
    Return RenderNodeAction.Proceed
End Function

' <summary>
' This method marks the end of processing a view (a 3D view)
' </summary>
Public Sub OnViewEnd(elementId As ElementId) Implements IExportContext.OnViewEnd
    ' elementId it indicates which view has just been exported

    ' Note: This method is invoked even for a view that was skipped.
End Sub

See Also

IExportContext Interface


OnViewEnd Method

[image]

Revit 2024 API
IExportContext..::..OnViewEnd Method
IExportContext Interface See Also Send Feedback
This method marks the end of a 3D view being exported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
void OnViewEnd(
    ElementId elementId
)
Visual Basic
Sub OnViewEnd ( _
    elementId As ElementId _
)
Visual C++
void OnViewEnd(
    ElementId^ elementId
)

Parameters

elementId
Type: Autodesk.Revit.DB..::..ElementId
The Id of the 3D view that has just been processed.

See Also

IExportContext Interface


Start Method

[image]

Revit 2024 API
IExportContext..::..Start Method
IExportContext Interface Example See Also Send Feedback
This method is called at the very start of the export process, still before the first entity of the model was send out.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
bool Start()
Visual Basic
Function Start As Boolean
Visual C++
bool Start()

Return Value

Return True if you are ready to proceed with processing the export.

Examples

CopyC#
// A context would typically maintain a variable for the document being exported
private Document m_document = null;

// Some contexts may find it useful to have a flag indicating
// whether or not the process should be canceled (see Is
private bool m_cancelled = false;

// Typically, an export context has to manage a stack of transformation
// for all nested objects, such as instances, lights, links, etc.
private Stack<Transform> m_TransformationStack = new Stack<Transform>();

/// <summary>
/// Assuming that instance variables gets initiated in the context's constructor
/// </summary>
/// <param name="document"></param>
public MyExportContext(Document document)
{
   m_document = document;
   m_TransformationStack.Push(Transform.Identity);
}

/// <summary>
/// This method is the starting point of the export process.
/// </summary>
/// <remarks>
/// The method is called only once and is typically used to prepare
/// the context object, e.g. crate or open the output files,
/// or establish a connection to an on-line renderer, etc.
/// </remarks>
/// <returns>
/// Return true if the export process it good to start.
/// </returns>
public bool Start()
{
   return true;
}

/// <summary>
/// This method establishes the final point of the export process.
/// </summary>
/// <remarks>
/// Resources (such as files, pipes, threads, etc.) used by the context
/// should be properly released/closed inside this method.
/// </remarks>
public void Finish()
{
}

/// <summary>
/// This method is invoked many times during the export process.
/// </summary>
/// <remarks>
/// Depending on internal condition of the context, it can be decided
/// whether the export is to be immediately canceled or not.
/// </remarks>
public bool IsCanceled()
{
   return m_cancelled;
}
CopyVB.NET
' A context would typically maintain a variable for the document being exported
Private m_document As Document = Nothing

' Some contexts may find it useful to have a flag indicating
' whether or not the process should be canceled (see Is
Private m_cancelled As Boolean = False

' Typically, an export context has to manage a stack of transformation
' for all nested objects, such as instances, lights, links, etc.
Private m_TransformationStack As New Stack(Of Transform)()

' <summary>
' Assuming that instance variables gets initiated in the context's constructor
' </summary>
' <param name="document"></param>
Public Sub New(document As Document)
    m_document = document
    m_TransformationStack.Push(Transform.Identity)
End Sub

' <summary>
' This method is the starting point of the export process.
' </summary>
' <remarks>
' The method is called only once and is typically used to prepare
' the context object, e.g. crate or open the output files,
' or establish a connection to an on-line renderer, etc.
' </remarks>
' <returns>
' Return true if the export process it good to start.
' </returns>
Public Function Start() As Boolean Implements IExportContext.Start
    Return True
End Function

' <summary>
' This method establishes the final point of the export process.
' </summary>
' <remarks>
' Resources (such as files, pipes, threads, etc.) used by the context
' should be properly released/closed inside this method.
' </remarks>
Public Sub Finish() Implements IExportContext.Finish
End Sub

' <summary>
' This method is invoked many times during the export process.
' </summary>
' <remarks>
' Depending on internal condition of the context, it can be decided
' whether the export is to be immediately canceled or not.
' </remarks>
Public Function IsCanceled() As Boolean Implements IExportContext.IsCanceled
    Return m_cancelled
End Function

See Also

IExportContext Interface


IExportContext2D Interface

[image]

Revit 2024 API
IExportContext2D Interface
Members See Also Send Feedback
An interface that is used in custom export to export 2D views of a Revit model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public interface IExportContext2D : IExportContextBase
Visual Basic
Public Interface IExportContext2D _
    Inherits IExportContextBase
Visual C++
public interface class IExportContext2D : IExportContextBase

Remarks

An instance of a class that implements this interface is passed in as a parameter of the CustomExporter constructor. The interface methods are then called at times of drawing entities that are currently visible in the view being exported.

With this type of export context used to perform a custom export, Revit will traverse the model and output the model's geometry as if in the process of regular displaying or exporting a 2D View. It means that any geometry which is visible in an open view (taking any current visibility setting applicable to the view) will be processed and output. Optionally, annotation objects are also output.

Note 1. Curves passed to calls OnFaceEdge2D(FaceEdgeNode) and OnFaceSilhouette2D(FaceSilhouetteNode) may be partially duplicating each other.

Note 2. If element E is a FamilyInstance and it contains an imported instance then:

  • between the calls to OnElementBegin2D/OnElementEnd2D for element E there will be calls to OnInstanceBegin/OnInstanceEnd with the "node" argument pointing to the element with its symbol being of category BuiltInCategories.OST_ImportObjectStyles
  • all geometry exported for the element E has to be additionally subject to the transform T=E.GetTotalTransform()

See Also

IExportContext2D Members


IExportContext2D Members

[image] [image]

Revit 2024 API
IExportContext2D Members
IExportContext2D Interface Methods See Also Send Feedback

The IExportContext2D type exposes the following members.

Methods

Name Description
Public method OnCurve
This method is called when a Curve is being output.
(Inherited from IExportContextBase.)
Public method OnElementBegin2D
This method marks the beginning of an element to be exported.
Public method OnElementEnd2D
This method marks the end of an element being exported.
Public method OnFaceEdge2D
This method is called when a Face edge is being output.
Public method OnFaceSilhouette2D
This method is called when a Face silhouette is being output.
Public method OnLineSegment
This method is called after unhandled curve was tessellated to line segments and sent to the output.

Note for 2D export: if the export is performed for the view in non-Wireframe display style, then

  • this method is called outside of view, instance and link begin/end calls but still between OnElementBegin2D/OnElementEnd2D calls
  • this method is never called for annotation elements, i.e. their geometry should be processed in methods OnCurve and OnPolyline

(Inherited from IExportContextBase.)
Public method OnPolyline
This method is called when a Polyline is being output.
(Inherited from IExportContextBase.)
Public method OnPolylineSegments
This method is called after unhandled curve was tessellated to polyline segments and sent to the output.

Note for 2D export: if the export is performed for the view in non-Wireframe display style, then

  • this method is called outside of view, instance and link begin/end calls but still between OnElementBegin2D/OnElementEnd2D calls
  • this method is never called for annotation elements, i.e. their geometry should be processed in methods OnCurve and OnPolyline

(Inherited from IExportContextBase.)
Public method OnText
This method is called when a text annotation object is being output.
(Inherited from IExportContextBase.)

See Also

IExportContext2D Interface


IExportContext2D Methods

[image] [image]

Revit 2024 API
IExportContext2D Methods
IExportContext2D Interface See Also Send Feedback

The IExportContext2D type exposes the following members.

Methods

Name Description
Public method OnCurve
This method is called when a Curve is being output.
(Inherited from IExportContextBase.)
Public method OnElementBegin2D
This method marks the beginning of an element to be exported.
Public method OnElementEnd2D
This method marks the end of an element being exported.
Public method OnFaceEdge2D
This method is called when a Face edge is being output.
Public method OnFaceSilhouette2D
This method is called when a Face silhouette is being output.
Public method OnLineSegment
This method is called after unhandled curve was tessellated to line segments and sent to the output.

Note for 2D export: if the export is performed for the view in non-Wireframe display style, then

  • this method is called outside of view, instance and link begin/end calls but still between OnElementBegin2D/OnElementEnd2D calls
  • this method is never called for annotation elements, i.e. their geometry should be processed in methods OnCurve and OnPolyline

(Inherited from IExportContextBase.)
Public method OnPolyline
This method is called when a Polyline is being output.
(Inherited from IExportContextBase.)
Public method OnPolylineSegments
This method is called after unhandled curve was tessellated to polyline segments and sent to the output.

Note for 2D export: if the export is performed for the view in non-Wireframe display style, then

  • this method is called outside of view, instance and link begin/end calls but still between OnElementBegin2D/OnElementEnd2D calls
  • this method is never called for annotation elements, i.e. their geometry should be processed in methods OnCurve and OnPolyline

(Inherited from IExportContextBase.)
Public method OnText
This method is called when a text annotation object is being output.
(Inherited from IExportContextBase.)

See Also

IExportContext2D Interface


OnElementEnd2D Method

[image]

Revit 2024 API
IExportContext2D..::..OnElementEnd2D Method
IExportContext2D Interface See Also Send Feedback
This method marks the end of an element being exported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
void OnElementEnd2D(
    ElementNode node
)
Visual Basic
Sub OnElementEnd2D ( _
    node As ElementNode _
)
Visual C++
void OnElementEnd2D(
    ElementNode^ node
)

Parameters

node
Type: Autodesk.Revit.DB..::..ElementNode
An output node that represents an element.

Remarks

For views having non-Wireframe display style, geometry of elements is output outside of view, instance and link begin/end brackets. Therefore the argument to this method is ElementNode that has both element ID and the host document.

See Also

IExportContext2D Interface


OnFaceEdge2D Method

[image]

Revit 2024 API
IExportContext2D..::..OnFaceEdge2D Method
IExportContext2D Interface See Also Send Feedback
This method is called when a Face edge is being output.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
RenderNodeAction OnFaceEdge2D(
    FaceEdgeNode node
)
Visual Basic
Function OnFaceEdge2D ( _
    node As FaceEdgeNode _
) As RenderNodeAction
Visual C++
RenderNodeAction OnFaceEdge2D(
    FaceEdgeNode^ node
)

Parameters

node
Type: Autodesk.Revit.DB..::..FaceEdgeNode
An output node that represents a Face edge.

Return Value

Return RenderNodeAction.Proceed if you wish to receive tessellated geometry (line or polyline segments) for this face edge, or otherwise return RenderNodeAction.Skip.

Note: if the export is performed for the view in non-Wireframe display style tesselated geometry will be output regardless of the return value.

Remarks

Note that this method is invoked only if the custom exporter was set up to include geometric objects in the output stream. See IncludeGeometricObjects for mode details.

Note: if the export is performed for the view in non-Wireframe display style this method will be called regardless of whether the object will be eventially output, i.e. even if it's occluded by another element.

See Also

IExportContext2D Interface


IExportContextBase Interface

[image]

Revit 2024 API
IExportContextBase Interface
Members See Also Send Feedback
An interface that as common base for IModelExportContext and IExportContext2D.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public interface IExportContextBase : IExportContext
Visual Basic
Public Interface IExportContextBase _
    Inherits IExportContext
Visual C++
public interface class IExportContextBase : IExportContext

See Also

IExportContextBase Members


OnCurve Method

[image]

Revit 2024 API
IExportContextBase..::..OnCurve Method
IExportContextBase Interface See Also Send Feedback
This method is called when a Curve is being output.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
RenderNodeAction OnCurve(
    CurveNode node
)
Visual Basic
Function OnCurve ( _
    node As CurveNode _
) As RenderNodeAction
Visual C++
RenderNodeAction OnCurve(
    CurveNode^ node
)

Parameters

node
Type: Autodesk.Revit.DB..::..CurveNode
An output node that represents a Curve.

Return Value

Return RenderNodeAction.Proceed if you wish to receive tessellated geometry (line or polyline segments) for this curve, or otherwise return RenderNodeAction.Skip.

Note for 2D export: if the export is performed for the view in non-Wireframe display style tesselated geometry will be output regardless of the return value.

Remarks

Note that this method is invoked only if the custom exporter was set up to include geometric objects in the output stream. See IncludeGeometricObjects for mode details.

The curve can be one of the geometric object that derive from the Curve class, e.g. Line, Arc, NurbeSpline, etc. To get to the specific properties of the particular class, the curve obtained from the input node first needs to be cast accordingly depending on the curve's actual type.

Note for 2D export: if the export is performed for the view in non-Wireframe display style this method will be called regardless of whether the object will be eventially output, i.e. even if it's occluded by another element.

See Also

IExportContextBase Interface


OnLineSegment Method

[image]

Revit 2024 API
IExportContextBase..::..OnLineSegment Method
IExportContextBase Interface See Also Send Feedback
This method is called after unhandled curve was tessellated to line segments and sent to the output.

Note for 2D export: if the export is performed for the view in non-Wireframe display style, then

  • this method is called outside of view, instance and link begin/end calls but still between OnElementBegin2D/OnElementEnd2D calls
  • this method is never called for annotation elements, i.e. their geometry should be processed in methods OnCurve and OnPolyline

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
void OnLineSegment(
    LineSegment segment
)
Visual Basic
Sub OnLineSegment ( _
    segment As LineSegment _
)
Visual C++
void OnLineSegment(
    LineSegment^ segment
)

Parameters

segment
Type: Autodesk.Revit.DB..::..LineSegment
A structure describing the line segment.

See Also

IExportContextBase Interface


OnPolyline Method

[image]

Revit 2024 API
IExportContextBase..::..OnPolyline Method
IExportContextBase Interface See Also Send Feedback
This method is called when a Polyline is being output.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
RenderNodeAction OnPolyline(
    PolylineNode node
)
Visual Basic
Function OnPolyline ( _
    node As PolylineNode _
) As RenderNodeAction
Visual C++
RenderNodeAction OnPolyline(
    PolylineNode^ node
)

Parameters

node
Type: Autodesk.Revit.DB..::..PolylineNode
An output node that represents a Polyline.

Return Value

Return RenderNodeAction.Proceed if you wish to receive tessellated geometry (polyline segments) for this polyline, or otherwise return RenderNodeAction.Skip.

Note for 2D export: if the export is performed for the view in non-Wireframe display style tesselated geometry will be output regardless of the return value.

Remarks

Note that this method is invoked only if the custom exporter was set up to include geometric objects in the output stream. See IncludeGeometricObjects for mode details.

Note for 2D export: if the export is performed for the view in non-Wireframe display style this method will be called regardless of whether the object will be eventially output, i.e. even if it's occluded by another element.

See Also

IExportContextBase Interface


OnPolylineSegments Method

[image]

Revit 2024 API
IExportContextBase..::..OnPolylineSegments Method
IExportContextBase Interface See Also Send Feedback
This method is called after unhandled curve was tessellated to polyline segments and sent to the output.

Note for 2D export: if the export is performed for the view in non-Wireframe display style, then

  • this method is called outside of view, instance and link begin/end calls but still between OnElementBegin2D/OnElementEnd2D calls
  • this method is never called for annotation elements, i.e. their geometry should be processed in methods OnCurve and OnPolyline

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
void OnPolylineSegments(
    PolylineSegments segments
)
Visual Basic
Sub OnPolylineSegments ( _
    segments As PolylineSegments _
)
Visual C++
void OnPolylineSegments(
    PolylineSegments^ segments
)

Parameters

segments
Type: Autodesk.Revit.DB..::..PolylineSegments
A structure describing the polyline segments.

See Also

IExportContextBase Interface


OnText Method

[image]

Revit 2024 API
IExportContextBase..::..OnText Method
IExportContextBase Interface See Also Send Feedback
This method is called when a text annotation object is being output.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
void OnText(
    TextNode node
)
Visual Basic
Sub OnText ( _
    node As TextNode _
)
Visual C++
void OnText(
    TextNode^ node
)

Parameters

node
Type: Autodesk.Revit.DB..::..TextNode
An output node that represents a text annotation.

See Also

IExportContextBase Interface


IExtension Interface

[image]

Revit 2024 API
IExtension Interface
Members See Also Send Feedback
An interface that supports the additional operation for Extension Status

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public interface IExtension
Visual Basic
Public Interface IExtension
Visual C++
public interface class IExtension

Remarks

See Also

IExtension Members


IExtension Properties

[image] [image]

Revit 2024 API
IExtension Properties
IExtension Interface See Also Send Feedback

The IExtension type exposes the following members.

Properties

 | Name | Description
Public property | Extended | Retrieves or set the extension status at the end
Public property | HasMiter | Retrieves the miter status at the end
Public property | IsMiterLocked | Retrieves or set the miter locked status at the end.
Public property | SymbolicExtended | Retrieves or set the symbolic extension status at the end

See Also

IExtension Interface


HasMiter Property

[image]

Revit 2024 API
IExtension..::..HasMiter Property
IExtension Interface See Also Send Feedback
Retrieves the miter status at the end

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
bool this[
    int index
] { get; }
Visual Basic
ReadOnly Property HasMiter ( _
    index As Integer _
) As Boolean
    Get
Visual C++
property bool HasMiter[int index] {
    bool get (int index);
}

Parameters

index
Type: System..::..Int32

Remarks

Property index must be 0 or 1 to indicate two ends, otherwise exceptions will be thrown. For beams, this can check whether the beam is mitered with other beams at the end

See Also

IExtension Interface


IsMiterLocked Property

[image]

Revit 2024 API
IExtension..::..IsMiterLocked Property
IExtension Interface See Also Send Feedback
Retrieves or set the miter locked status at the end.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
bool this[
    int index
] { get; set; }
Visual Basic
Property IsMiterLocked ( _
    index As Integer _
) As Boolean
    Get
    Set
Visual C++
property bool IsMiterLocked[int index] {
    bool get (int index);
    void set (int index, bool value);
}

Parameters

index
Type: System..::..Int32

Remarks

Property index must be 0 or 1 to indicate two ends, otherwise exceptions will be thrown. For beams, only if the beam is extended and is mitered with other beams at the end, it can be locked. Otherwise, the setting is invalid

See Also

IExtension Interface


SymbolicExtended Property

[image]

Revit 2024 API
IExtension..::..SymbolicExtended Property
IExtension Interface See Also Send Feedback
Retrieves or set the symbolic extension status at the end

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
bool this[
    int index
] { get; set; }
Visual Basic
Property SymbolicExtended ( _
    index As Integer _
) As Boolean
    Get
    Set
Visual C++
property bool SymbolicExtended[int index] {
    bool get (int index);
    void set (int index, bool value);
}

Parameters

index
Type: System..::..Int32

Remarks

Property index must be 0 or 1 to indicate two ends, otherwise exceptions will be thrown. For beams, symbolic extension setting only works when the beam is extended, mitered, and miter locked at the end. Otherwise the setting is invalid

See Also

IExtension Interface


IExternalDBApplication Interface

[image]

Revit 2024 API
IExternalDBApplication Interface
Members See Also Send Feedback
An interface that supports addition of DB-level external applications to Revit, to subscribe to DB-level events and updaters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public interface IExternalDBApplication
Visual Basic
Public Interface IExternalDBApplication
Visual C++
public interface class IExternalDBApplication

Remarks

DB-level applications are permitted to add DB-level events and updaters to the session. They cannot create or modify UI.

See Also

IExternalDBApplication Members


IExternalDBApplication Members

[image] [image]

Revit 2024 API
IExternalDBApplication Members
IExternalDBApplication Interface Methods See Also Send Feedback

The IExternalDBApplication type exposes the following members.

Methods

 | Name | Description
Public method | OnShutdown | Implement this method to execute some tasks when Autodesk Revit shuts down.
Public method | OnStartup | Implement this method to execute some tasks when Autodesk Revit starts.

See Also

IExternalDBApplication Interface


OnShutdown Method

[image]

Revit 2024 API
IExternalDBApplication..::..OnShutdown Method
IExternalDBApplication Interface See Also Send Feedback
Implement this method to execute some tasks when Autodesk Revit shuts down.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
ExternalDBApplicationResult OnShutdown(
    ControlledApplication application
)
Visual Basic
Function OnShutdown ( _
    application As ControlledApplication _
) As ExternalDBApplicationResult
Visual C++
ExternalDBApplicationResult OnShutdown(
    ControlledApplication^ application
)

Parameters

application
Type: Autodesk.Revit.ApplicationServices..::..ControlledApplication
Handle to the Revit Application object.

Return Value

Indicates if the external db application completes its work successfully.

See Also

IExternalDBApplication Interface


OnStartup Method

[image]

Revit 2024 API
IExternalDBApplication..::..OnStartup Method
IExternalDBApplication Interface See Also Send Feedback
Implement this method to execute some tasks when Autodesk Revit starts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
ExternalDBApplicationResult OnStartup(
    ControlledApplication application
)
Visual Basic
Function OnStartup ( _
    application As ControlledApplication _
) As ExternalDBApplicationResult
Visual C++
ExternalDBApplicationResult OnStartup(
    ControlledApplication^ application
)

Parameters

application
Type: Autodesk.Revit.ApplicationServices..::..ControlledApplication
Handle to the Revit Application object.

Return Value

Indicates if the external db application completes its work successfully.

Remarks

Typically, event handlers and updaters are registered in this method.

See Also

IExternalDBApplication Interface


IExternalResourceServer Interface

[image]

Revit 2024 API
IExternalResourceServer Interface
Members See Also Send Feedback
The interface used to provide custom implementation to provide access to external resources (such as linked files) from arbitrary locations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public interface IExternalResourceServer : IExternalServer
Visual Basic
Public Interface IExternalResourceServer _
    Inherits IExternalServer
Visual C++
public interface class IExternalResourceServer : IExternalServer

Remarks

Certain resources used in a Revit model are stored outside of the .rvt file. For example, the data used for keynotes, images used as decals during rendering, CAD links, and Revit links are all stored outside the model. Creating a new implementation of this server allows the server to supply one or more types of such resources from an arbitrary source. For example, a server could provide the keynote data from a database or from a file format that Revit does not support.

If a model references resources supplied by this server, Revit will request the resource from the server when it is required. Most external resources are loaded into memory at the time the model is loaded. The server will also be invoked if the resource is explicitly reloaded.

IExternalResourceServer can declare that a resource is already up-to-date via GetResourceVersionStatus(ExternalResourceReference) If the resource is up-to-date, Revit will skip loading to improve performance.

Each resource load request will be associated with a GUID, so that server implementers can uniquely identify a given load request. This may be useful to, for example, store server-side errors associated with an attempt to load a particular resource.

If your server handles Revit or CAD links, you must take special care with link paths. When one of these file types is uploaded to your server, any nested references should be brought to the server along with the main link. Your server will need to repath any nested reference itself; Revit will not handle this automatically.

In the case of DWG links, your server will also need to download and possibly repath any xrefs when LoadResource is called for the top-level link. Revit will only request the top-level link directly.

In the case of Revit links, the ExternalResourceReferences for any nested links will also need to be modified in the host document. The host document should reference the Revit links at their server locations, not their local file locations. Revit may not be able to find links if the paths are not set up correctly. See [!:Autodesk::Revit::DB::TransmissionData::ReadTransmissionData] to inspect the set of links contained within a Revit model. See [!:Autodesk::Revit::DB::RevitLinkType::LoadFrom] to reload a Revit link from a server version.

Here is an example which uses nested Revit links: A user has a Revit model containing one link, Link.rvt, which contains one nested link, Nest.rvt. The user uploads Link.rvt to a server, using an add-in provided by that server. The server provider must also take Nest.rvt. Further, the server provider must open Link.rvt and modify the reference to Nest.rvt so that it references the version on the server. Otherwise, Revit will not be able to find Nest.rvt when another user tries to load Link.rvt from the server.

The external resource framework has been designed to allow server authors to display UI related to the resource load operation and UI browse operation. No UI should be displayed directly from an IExternalResourceServer. Instead, developers should create an IExternalResourceUIServer which will handle UI tasks on behalf of the IExternalResourceServer. For more information, see the documentation for the LoadResource(Guid, ExternalResourceType, ExternalResourceReference, ExternalResourceLoadContext, ExternalResourceLoadContent) and SetupBrowserData(ExternalResourceBrowserData) methods.

See Also

IExternalResourceServer Members


IExternalResourceServer Members

[image] [image]

Revit 2024 API
IExternalResourceServer Members
IExternalResourceServer Interface Methods See Also Send Feedback

The IExternalResourceServer type exposes the following members.

Methods

 | Name | Description
Public method | AreSameResources | Implement this method to indicate whether two given resources are the same.
Public method | GetDescription | Implement this method to return a description of the server. (Inherited from IExternalServer.)
Public method | GetIconPath | Implement this method to return the path to an icon file which will be displayed in Revit user interfaces associated to this server.
Public method | GetInformationLink | The method that Revit will invoke to obtain a URL address which provides more information about the server.
Public method | GetInSessionPath | Implement this method to provide the path that should be used for display and browsing to a given ExternalResourceReference during this Revit session.
Public method | GetName | Implement this method to return the name of the server. (Inherited from IExternalServer.)
Public method | GetResourceVersionStatus | Implement this method to indicate whether the given version of a resource is the most current version of the data.
Public method | GetServerId | Implement this method to return the id of the server. (Inherited from IExternalServer.)
Public method | GetServiceId | Implement this method to return the id of the service. (Inherited from IExternalServer.)
Public method | GetShortName | Implement this method to return the short name of the server.
Public method | GetTypeSpecificServerOperations | Implement this method to get operations supported by the external server for a particular type of external resource.
Public method | GetVendorId | Implement this method to return the id of the vendor of the server. (Inherited from IExternalServer.)
Public method | IsResourceWellFormed | Implement this method to check whether the given ExternalResourceReference is formatted correctly for this server.
Public method | LoadResource | Implement this method to load the requested resource.
Public method | SetupBrowserData | Implement this method to setup external resource browser data which will be accessed in Revit external resource browser UI.
Public method | SupportsExternalResourceType | Implement this method to indicate whether the server can provide data for a specified type of external resource.

See Also

IExternalResourceServer Interface


IExternalResourceServer Methods

[image] [image]

Revit 2024 API
IExternalResourceServer Methods
IExternalResourceServer Interface See Also Send Feedback

The IExternalResourceServer type exposes the following members.

Methods

 | Name | Description
Public method | AreSameResources | Implement this method to indicate whether two given resources are the same.
Public method | GetDescription | Implement this method to return a description of the server. (Inherited from IExternalServer.)
Public method | GetIconPath | Implement this method to return the path to an icon file which will be displayed in Revit user interfaces associated to this server.
Public method | GetInformationLink | The method that Revit will invoke to obtain a URL address which provides more information about the server.
Public method | GetInSessionPath | Implement this method to provide the path that should be used for display and browsing to a given ExternalResourceReference during this Revit session.
Public method | GetName | Implement this method to return the name of the server. (Inherited from IExternalServer.)
Public method | GetResourceVersionStatus | Implement this method to indicate whether the given version of a resource is the most current version of the data.
Public method | GetServerId | Implement this method to return the id of the server. (Inherited from IExternalServer.)
Public method | GetServiceId | Implement this method to return the id of the service. (Inherited from IExternalServer.)
Public method | GetShortName | Implement this method to return the short name of the server.
Public method | GetTypeSpecificServerOperations | Implement this method to get operations supported by the external server for a particular type of external resource.
Public method | GetVendorId | Implement this method to return the id of the vendor of the server. (Inherited from IExternalServer.)
Public method | IsResourceWellFormed | Implement this method to check whether the given ExternalResourceReference is formatted correctly for this server.
Public method | LoadResource | Implement this method to load the requested resource.
Public method | SetupBrowserData | Implement this method to setup external resource browser data which will be accessed in Revit external resource browser UI.
Public method | SupportsExternalResourceType | Implement this method to indicate whether the server can provide data for a specified type of external resource.

See Also

IExternalResourceServer Interface


AreSameResources Method

[image]

Revit 2024 API
IExternalResourceServer..::..AreSameResources Method
IExternalResourceServer Interface See Also Send Feedback
Implement this method to indicate whether two given resources are the same.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
bool AreSameResources(
    IDictionary<string, string> reference1,
    IDictionary<string, string> reference2
)
Visual Basic
Function AreSameResources ( _
    reference1 As IDictionary(Of String, String), _
    reference2 As IDictionary(Of String, String) _
) As Boolean
Visual C++
bool AreSameResources(
    IDictionary<String^, String^>^ reference1,
    IDictionary<String^, String^>^ reference2
)

Parameters

reference1
Type: System.Collections.Generic..::..IDictionary<(Of <(<'String, String>)>)>
reference2
Type: System.Collections.Generic..::..IDictionary<(Of <(<'String, String>)>)>

Return Value

True if two given resources are the same; otherwise false.

See Also

IExternalResourceServer Interface


GetShortName Method

[image]

Revit 2024 API
IExternalResourceServer..::..GetShortName Method
IExternalResourceServer Interface See Also Send Feedback
Implement this method to return the short name of the server.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
string GetShortName()
Visual Basic
Function GetShortName As String
Visual C++
String^ GetShortName()

Return Value

The short name of the server.

Remarks

The name is a unique path prefix included in full paths to external resources provided by this server. It is recommended that the short name length is at least 3 characters to make it useful for users to identify the server easily.

To ensure the server can be registered successfully, the name should match restrictions below:

  • The name cannot be empty or consist of only whitespace characters.
  • The name should not include any invalid characters such as \/:*?"<>|.
  • The name cannot duplicate any other external resource server names.
  • The name should not duplicate a Revit reserved path prefix(case insensitive), including: RSN, A360, buzzsaw, vault, redspark, ftp, http, https, files, file.

See Also

IExternalResourceServer Interface


IsResourceWellFormed Method

[image]

Revit 2024 API
IExternalResourceServer..::..IsResourceWellFormed Method
IExternalResourceServer Interface See Also Send Feedback
Implement this method to check whether the given ExternalResourceReference is formatted correctly for this server.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
bool IsResourceWellFormed(
    ExternalResourceReference extRef
)
Visual Basic
Function IsResourceWellFormed ( _
    extRef As ExternalResourceReference _
) As Boolean
Visual C++
bool IsResourceWellFormed(
    ExternalResourceReference^ extRef
)

Parameters

extRef
Type: Autodesk.Revit.DB..::..ExternalResourceReference
The ExternalResourceReference to check.

Return Value

True if the ExternalResourceReference represents a well-formed resource. False otherwise.

Remarks

Different servers will have different requirements.

A server which loads references from a website might require that the reference map contain a key called "URL" and a value that is a valid URL.

A server which loads references from a network drive might require a key called "Drive" with a value that represents a drive name, plus a key called "Path" with a value that corresponds to a path relative to the root of the drive.

This function should not check that the resource exists on the server. It should only check that the resource is formatted correctly.

See Also

IExternalResourceServer Interface


SetupBrowserData Method

[image]

Revit 2024 API
IExternalResourceServer..::..SetupBrowserData Method
IExternalResourceServer Interface See Also Send Feedback
Implement this method to setup external resource browser data which will be accessed in Revit external resource browser UI.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
void SetupBrowserData(
    ExternalResourceBrowserData browseData
)
Visual Basic
Sub SetupBrowserData ( _
    browseData As ExternalResourceBrowserData _
)
Visual C++
void SetupBrowserData(
    ExternalResourceBrowserData^ browseData
)

Parameters

browseData
Type: Autodesk.Revit.DB..::..ExternalResourceBrowserData
The input context to match the external resources and browser results returned by the server.

Remarks

If errors occur during setup, store this information externally, and then retrieve and deal with the errors during the call to HandleBrowseResult() of your IExternalResourceUIServer.

See Also

IExternalResourceServer Interface


SupportsExternalResourceType Method

[image]

Revit 2024 API
IExternalResourceServer..::..SupportsExternalResourceType Method
IExternalResourceServer Interface See Also Send Feedback
Implement this method to indicate whether the server can provide data for a specified type of external resource.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
bool SupportsExternalResourceType(
    ExternalResourceType type
)
Visual Basic
Function SupportsExternalResourceType ( _
    type As ExternalResourceType _
) As Boolean
Visual C++
bool SupportsExternalResourceType(
    ExternalResourceType^ type
)

Parameters

type
Type: Autodesk.Revit.DB..::..ExternalResourceType
The ExternalResourceType of interest to the caller. For example, KeynoteTable - to determine if the server provides data for Revit's keynote table.

Return Value

True if the server supports the specified type of external resource

See Also

IExternalResourceServer Interface


IFailuresPreprocessor Interface

[image]

Revit 2024 API
IFailuresPreprocessor Interface
Members Example See Also Send Feedback
An interface that may be used to perform a preprocessing step to either filter out anticipated transaction failures or to mark certain failures as non-continuable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public interface IFailuresPreprocessor
Visual Basic
Public Interface IFailuresPreprocessor
Visual C++
public interface class IFailuresPreprocessor

Remarks

This interface, if provided, is invoked when there are failures found at the end of a transaction. An instance of this interface can be set in the failure handling options of transaction object.

Examples

CopyC#
public class RoomWarningSwallower : IFailuresPreprocessor
{
    public FailureProcessingResult PreprocessFailures(FailuresAccessor failuresAccessor)
    {
        IList<FailureMessageAccessor> failList = new List<FailureMessageAccessor>();
        // Inside event handler, get all warnings
        failList = failuresAccessor.GetFailureMessages();
        foreach (FailureMessageAccessor failure in failList)
        {
            // check FailureDefinitionIds against ones that you want to dismiss,
            FailureDefinitionId failID = failure.GetFailureDefinitionId();
            // prevent Revit from showing Unenclosed room warnings
            if (failID == BuiltInFailures.RoomFailures.RoomNotEnclosed)
            {
                failuresAccessor.DeleteWarning(failure);
            }
        }

        return FailureProcessingResult.Continue;
    }
}
CopyVB.NET
Public Class RoomWarningSwallower
    Implements IFailuresPreprocessor
    Public Function PreprocessFailures(failuresAccessor As FailuresAccessor) As FailureProcessingResult Implements IFailuresPreprocessor.PreprocessFailures
        Dim failList As IList(Of FailureMessageAccessor) = New List(Of FailureMessageAccessor)()
        ' Inside event handler, get all warnings
        failList = failuresAccessor.GetFailureMessages()
        For Each failure As FailureMessageAccessor In failList
            ' check FailureDefinitionIds against ones that you want to dismiss,
            Dim failID As FailureDefinitionId = failure.GetFailureDefinitionId()
            ' prevent Revit from showing Unenclosed room warnings
            If failID = BuiltInFailures.RoomFailures.RoomNotEnclosed Then
                failuresAccessor.DeleteWarning(failure)
            End If
        Next

        Return FailureProcessingResult.[Continue]
    End Function
End Class

See Also

IFailuresPreprocessor Members


IFailuresPreprocessor Methods

[image] [image]

Revit 2024 API
IFailuresPreprocessor Methods
IFailuresPreprocessor Interface See Also Send Feedback

The IFailuresPreprocessor type exposes the following members.

Methods

 | Name | Description
Public method | PreprocessFailures | This method is called when there have been failures found at the end of a transaction and Revit is about to start processing them.

See Also

IFailuresPreprocessor Interface


PreprocessFailures Method

[image]

Revit 2024 API
IFailuresPreprocessor..::..PreprocessFailures Method
IFailuresPreprocessor Interface See Also Send Feedback
This method is called when there have been failures found at the end of a transaction and Revit is about to start processing them.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
FailureProcessingResult PreprocessFailures(
    FailuresAccessor failuresAccessor
)
Visual Basic
Function PreprocessFailures ( _
    failuresAccessor As FailuresAccessor _
) As FailureProcessingResult
Visual C++
FailureProcessingResult PreprocessFailures(
    FailuresAccessor^ failuresAccessor
)

Parameters

failuresAccessor
Type: Autodesk.Revit.DB..::..FailuresAccessor
The Interface class that provides access to the failure information.

Return Value

Notifies end of transaction code about further actions required. Return values are interpreted as follows:
  • Continue - the failure processing will continue. Failures will be shown to the user, even if they were addressed by this method.
  • ProceedWithCommit - end of transaction checks and failure processing will restart from the beginning. If some failures were resolved here, they will be removed and not delivered to the user. ProceedWithCommit cannot be returned if transaction is being rolled back.
  • ProceedWithRollBack - the failure processing will continue. Failures will be shown to the user, but user will have no option to resolve or ignore them - only cancel option will be available. If intent is to roll back transaction without showing failures to the user, it can be achieved by setting failure handling option to remove failures before returning ProceedWithRollBack.
Other return values are not allowed.

See Also

IFailuresPreprocessor Interface


IFailuresProcessor Interface

[image]

Revit 2024 API
IFailuresProcessor Interface
Members Example See Also Send Feedback
To create your own UI or fully automated tool to process Revit Failures, derive a class from this interface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public interface IFailuresProcessor
Visual Basic
Public Interface IFailuresProcessor
Visual C++
public interface class IFailuresProcessor

Remarks

To override Revit default Failures Processing UI, instantiate your own processor derived from this interface and register it in Revit application.

Examples

CopyC#
[Autodesk.Revit.Attributes.Transaction(Autodesk.Revit.Attributes.TransactionMode.Manual)]

public class MyFailuresUI : IExternalApplication
{
    static AddInId m_appId = new AddInId(new Guid("9F179363-B349-4541-823F-A2DDB2B86AF3"));
    public Result OnStartup(UIControlledApplication application)
    {
        IFailuresProcessor myFailUI = new FailUI();
        Autodesk.Revit.ApplicationServices.Application.RegisterFailuresProcessor(myFailUI);
        return Result.Succeeded;
    }

    public Result OnShutdown(UIControlledApplication application)
    {
        return Result.Succeeded;
    }

    public class FailUI : IFailuresProcessor
    {
        public void Dismiss(Document document)
        {
            // This method is being called in case of exception or document destruction to
            // dismiss any possible pending failure UI that may have left on the screen
        }

        public FailureProcessingResult ProcessFailures(FailuresAccessor failuresAccessor)
        {
            IList<FailureResolutionType> resolutionTypeList = new List<FailureResolutionType>();
            IList<FailureMessageAccessor> failList = new List<FailureMessageAccessor>();
            // Inside event handler, get all warnings
            failList = failuresAccessor.GetFailureMessages();
            string errorString = "";
            bool hasFailures = false;
            foreach (FailureMessageAccessor failure in failList)
            {
                // check how many resolutions types were attempted to try to prevent
                // entering infinite loop
                resolutionTypeList = failuresAccessor.GetAttemptedResolutionTypes(failure);
                if (resolutionTypeList.Count >= 3)
                {
                    TaskDialog.Show("Error", "Cannot resolve failures - transaction will be rolled back.");
                    return FailureProcessingResult.ProceedWithRollBack;
                }

                errorString += "IDs ";
                foreach (ElementId id in failure.GetFailingElementIds())
                {
                    errorString += id.ToString() + ", ";
                    hasFailures = true;
                }
                errorString += "\nWill be deleted because: " + failure.GetDescriptionText() + "\n";
                failuresAccessor.DeleteElements(failure.GetFailingElementIds() as IList<ElementId>);
            }
            if (hasFailures)
            {
                TaskDialog.Show("Error", errorString);
                return FailureProcessingResult.ProceedWithCommit;
            }

            return FailureProcessingResult.Continue;
        }
    }
}
CopyVB.NET
<Autodesk.Revit.Attributes.Transaction(Autodesk.Revit.Attributes.TransactionMode.Manual)> _
Public Class MyFailuresUI
    Implements IExternalApplication
    Shared m_appId As New AddInId(New Guid("9F179363-B349-4541-823F-A2DDB2B86AF3"))
    Public Function OnStartup(application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnStartup
        Dim myFailUI As IFailuresProcessor = New FailUI()
        'Autodesk.Revit.ApplicationServices.Application.RegisterFailuresProcessor(myFailUI);
        Return Result.Succeeded
    End Function

    Public Function OnShutdown(application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnShutdown
        Return Result.Succeeded
    End Function

    Public Class FailUI
        Implements IFailuresProcessor
        Public Sub Dismiss(document As Document) Implements IFailuresProcessor.Dismiss
            ' This method is being called in case of exception or document destruction to
            ' dismiss any possible pending failure UI that may have left on the screen
        End Sub

        Public Function ProcessFailures(failuresAccessor As FailuresAccessor) As FailureProcessingResult Implements IFailuresProcessor.ProcessFailures
            Dim resolutionTypeList As IList(Of FailureResolutionType) = New List(Of FailureResolutionType)()
            Dim failList As IList(Of FailureMessageAccessor) = New List(Of FailureMessageAccessor)()
            ' Inside event handler, get all warnings
            failList = failuresAccessor.GetFailureMessages()
            Dim errorString As String = ""
            Dim hasFailures As Boolean = False
            For Each failure As FailureMessageAccessor In failList
                ' check how many resolutions types were attempted to try to prevent
                ' entering infinite loop
                resolutionTypeList = failuresAccessor.GetAttemptedResolutionTypes(failure)
                If resolutionTypeList.Count >= 3 Then
                    TaskDialog.Show("Error", "Cannot resolve failures - transaction will be rolled back.")
                    Return FailureProcessingResult.ProceedWithRollBack
                End If

                errorString += "IDs "
                For Each id As ElementId In failure.GetFailingElementIds()
                    errorString += id.ToString() + ", "
                    hasFailures = True
                Next
                errorString += vbLf & "Will be deleted because: " + failure.GetDescriptionText() + vbLf
                failuresAccessor.DeleteElements(TryCast(failure.GetFailingElementIds(), IList(Of ElementId)))
            Next
            If hasFailures Then
                TaskDialog.Show("Error", errorString)
                Return FailureProcessingResult.ProceedWithCommit
            End If

            Return FailureProcessingResult.[Continue]
        End Function
    End Class
End Class

See Also

IFailuresProcessor Members


IFailuresProcessor Members

[image] [image]

Revit 2024 API
IFailuresProcessor Members
IFailuresProcessor Interface Methods See Also Send Feedback

The IFailuresProcessor type exposes the following members.

Methods

 | Name | Description
Public method | Dismiss | This method is being called in case of exception or document destruction to dismiss any possible pending failure UI that may have left on the screen
Public method | ProcessFailures | Method that Revit will invoke to process failures at the end of transaction.

See Also

IFailuresProcessor Interface


IFailuresProcessor Methods

[image] [image]

Revit 2024 API
IFailuresProcessor Methods
IFailuresProcessor Interface See Also Send Feedback

The IFailuresProcessor type exposes the following members.

Methods

 | Name | Description
Public method | Dismiss | This method is being called in case of exception or document destruction to dismiss any possible pending failure UI that may have left on the screen
Public method | ProcessFailures | Method that Revit will invoke to process failures at the end of transaction.

See Also

IFailuresProcessor Interface


Dismiss Method

[image]

Revit 2024 API
IFailuresProcessor..::..Dismiss Method
IFailuresProcessor Interface See Also Send Feedback
This method is being called in case of exception or document destruction to dismiss any possible pending failure UI that may have left on the screen

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
void Dismiss(
    Document document
)
Visual Basic
Sub Dismiss ( _
    document As Document _
)
Visual C++
void Dismiss(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Document for which pending failures processing UI should be dismissed

See Also

IFailuresProcessor Interface


ProcessFailures Method

[image]

Revit 2024 API
IFailuresProcessor..::..ProcessFailures Method
IFailuresProcessor Interface See Also Send Feedback
Method that Revit will invoke to process failures at the end of transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
FailureProcessingResult ProcessFailures(
    FailuresAccessor data
)
Visual Basic
Function ProcessFailures ( _
    data As FailuresAccessor _
) As FailureProcessingResult
Visual C++
FailureProcessingResult ProcessFailures(
    FailuresAccessor^ data
)

Parameters

data
Type: Autodesk.Revit.DB..::..FailuresAccessor
Provides all necessary data to perform the resolution of failures.

Return Value

The result of the failures processing.
  • Continue - Should be returned if there were no failures or highest failure severity was "Warning" and all warnings were deleted. If some failures are still present and "Continue" is returned, it will be treated as "ProceedWithRollback". Note: If this method has attempted to resolve failures, it should return "ProceedWithCommit" to repeat end of transaction checks and failures processing.
  • ProceedWithCommit - End of transaction checks and failure processing will restart from the beginning. If some failures were resolved, they will be removed and not delivered to the user. ProceedWithCommit cannot be returned if transaction is being rolled back.
  • ProceedWithRollBack - Transaction will be rolled back even if Commit was originally requested.
  • WaitForUserInput - Should be returned if method has activated modeless user interaction and is waiting for an external event (typically user input) to complete failures processing.

Remarks

This method is invoked after some failures may have been handled by any FailuresPreprocessor and/or FailureProcessing event subscribers.

See Also

IFailuresProcessor Interface


IFamilyLoadOptions Members

[image] [image]

Revit 2024 API
IFamilyLoadOptions Members
IFamilyLoadOptions Interface Methods See Also Send Feedback

The IFamilyLoadOptions type exposes the following members.

Methods

 | Name | Description
Public method | OnFamilyFound | A method called when the family was found in the target document.
Public method | OnSharedFamilyFound | A method called when the shared family was found in the target document.

See Also

IFamilyLoadOptions Interface


IFamilyLoadOptions Methods

[image] [image]

Revit 2024 API
IFamilyLoadOptions Methods
IFamilyLoadOptions Interface See Also Send Feedback

The IFamilyLoadOptions type exposes the following members.

Methods

 | Name | Description
Public method | OnFamilyFound | A method called when the family was found in the target document.
Public method | OnSharedFamilyFound | A method called when the shared family was found in the target document.

See Also

IFamilyLoadOptions Interface


OnFamilyFound Method

[image]

Revit 2024 API
IFamilyLoadOptions..::..OnFamilyFound Method
IFamilyLoadOptions Interface See Also Send Feedback
A method called when the family was found in the target document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
bool OnFamilyFound(
    bool familyInUse,
    out bool overwriteParameterValues
)
Visual Basic
Function OnFamilyFound ( _
    familyInUse As Boolean, _
    <OutAttribute> ByRef overwriteParameterValues As Boolean _
) As Boolean
Visual C++
bool OnFamilyFound(
    bool familyInUse,
    [OutAttribute] bool% overwriteParameterValues
)

Parameters

familyInUse
Type: System..::..Boolean
Indicates if one or more instances of the family is placed in the project.
overwriteParameterValues
Type: System..::..Boolean%
This determines whether or not to overwrite the parameter values of existing types. The default value is false.

Return Value

Return true to continue loading the family, false to cancel.

Remarks

Triggered only when the family is both loaded and changed.

See Also

IFamilyLoadOptions Interface


OnSharedFamilyFound Method

[image]

Revit 2024 API
IFamilyLoadOptions..::..OnSharedFamilyFound Method
IFamilyLoadOptions Interface See Also Send Feedback
A method called when the shared family was found in the target document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
bool OnSharedFamilyFound(
    Family sharedFamily,
    bool familyInUse,
    out FamilySource source,
    out bool overwriteParameterValues
)
Visual Basic
Function OnSharedFamilyFound ( _
    sharedFamily As Family, _
    familyInUse As Boolean, _
    <OutAttribute> ByRef source As FamilySource, _
    <OutAttribute> ByRef overwriteParameterValues As Boolean _
) As Boolean
Visual C++
bool OnSharedFamilyFound(
    Family^ sharedFamily,
    bool familyInUse,
    [OutAttribute] FamilySource% source,
    [OutAttribute] bool% overwriteParameterValues
)

Parameters

sharedFamily
Type: Autodesk.Revit.DB..::..Family
The shared family in the current family document.
familyInUse
Type: System..::..Boolean
Indicates if one or more instances of the family is placed in the project.
source
Type: Autodesk.Revit.DB..::..FamilySource %
This indicates if the family will load from the project or the current family.
overwriteParameterValues
Type: System..::..Boolean%
This indicates whether or not to overwrite the parameter values of existing types.

Return Value

Return true to continue loading the family, false to cancel.

Remarks

Triggered only when the family is both loaded and changed.

See Also

IFamilyLoadOptions Interface


IFCExportElement Enumeration

[image]

Revit 2024 API
IFCExportElement Enumeration
See Also Send Feedback
An enumerated type defining if an element is exported to IFC or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum IFCExportElement
Visual Basic
Public Enumeration IFCExportElement
Visual C++
public enum class IFCExportElement

Members

Member name | Description
ByType | Export element to IFC according to type settings.
Yes | Export element to IFC regardless of type or category settings.
No | Don't export element to IFC regardless of type or category settings.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


IFCExportElementType Enumeration

[image]

Revit 2024 API
IFCExportElementType Enumeration
See Also Send Feedback
An enumerated type defining if an element type is exported to IFC or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum IFCExportElementType
Visual Basic
Public Enumeration IFCExportElementType
Visual C++
public enum class IFCExportElementType

Members

Member name | Description
Default | Export element type to IFC according to category or Revit element settings.
Yes | Export element type to IFC regardless of category or Revit element settings.
No | Don't export element type to IFC regardless of category or Revit element settings.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


IFCExportOptions Members

[image] [image]

Revit 2024 API
IFCExportOptions Members
IFCExportOptions Class Constructors Methods Properties See Also Send Feedback

The IFCExportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | IFCExportOptions()()()() | Default constructor. Initializes FileVersion to Default. WallAndColumnSplitting and ExportBaseQuantities are set to false. FamilyMappingFile is set to empty.
Public method | IFCExportOptions(IFCExportOptions) | Creates a copy of an IFCExportOptions.

Methods

 | Name | Description
Public method | AddOption | Adds a new named option to the options structure.
Public method | Assign | Assigns the values of the IFCExportOptions to this options object.
Public method | Dispose | Releases all resources used by the IFCExportOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ExportBaseQuantities | Option to export IFC standard quantities currently supported by Revit.
Public property | FamilyMappingFile | Path to a file containing family mapping.
Public property | FileVersion | IFC file version.
Public property | FilterViewId | Id of the view whose visibility settings will govern the contents in the exported IFC file.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SpaceBoundaryLevel | Level of space boundaries exported in IFC file.
Public property | WallAndColumnSplitting | Option to allow division of multi-level walls and columns by levels.

See Also

IFCExportOptions Class


IFCExportOptions Constructor (IFCExportOptions)

[image]

Revit 2024 API
IFCExportOptions Constructor (IFCExportOptions)
IFCExportOptions Class See Also Send Feedback
Creates a copy of an IFCExportOptions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public IFCExportOptions(
    IFCExportOptions from
)
Visual Basic
Public Sub New ( _
    from As IFCExportOptions _
)
Visual C++
public:
IFCExportOptions(
    IFCExportOptions^ from
)

Parameters

from
Type: Autodesk.Revit.DB..::..IFCExportOptions

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

IFCExportOptions Class
IFCExportOptions Overload


IFCExportOptions Methods

[image] [image]

Revit 2024 API
IFCExportOptions Methods
IFCExportOptions Class See Also Send Feedback

The IFCExportOptions type exposes the following members.

Methods

 | Name | Description
Public method | AddOption | Adds a new named option to the options structure.
Public method | Assign | Assigns the values of the IFCExportOptions to this options object.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

IFCExportOptions Class


AddOption Method

[image]

Revit 2024 API
IFCExportOptions..::..AddOption Method
IFCExportOptions Class See Also Send Feedback
Adds a new named option to the options structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void AddOption(
    string name,
    string value
)
Visual Basic
Public Sub AddOption ( _
    name As String, _
    value As String _
)
Visual C++
public:
void AddOption(
    String^ name,
    String^ value
)

Parameters

name
Type: System..::..String
The option name.
value
Type: System..::..String
The option value.

Remarks

Named options can be used to set options not accessible through the standard IFC export user interface. It is up to the implementation of the IExporterIFC interface to customize export behavior based on these options.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

IFCExportOptions Class


Assign Method

[image]

Revit 2024 API
IFCExportOptions..::..Assign Method
IFCExportOptions Class See Also Send Feedback
Assigns the values of the IFCExportOptions to this options object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public void Assign(
    IFCExportOptions sourceOptions
)
Visual Basic
Public Sub Assign ( _
    sourceOptions As IFCExportOptions _
)
Visual C++
public:
void Assign(
    IFCExportOptions^ sourceOptions
)

Parameters

sourceOptions
Type: Autodesk.Revit.DB..::..IFCExportOptions
The source IFCExportOptions.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

IFCExportOptions Class


IFCExportOptions Properties

[image] [image]

Revit 2024 API
IFCExportOptions Properties
IFCExportOptions Class See Also Send Feedback

The IFCExportOptions type exposes the following members.

Properties

 | Name | Description
Public property | ExportBaseQuantities | Option to export IFC standard quantities currently supported by Revit.
Public property | FamilyMappingFile | Path to a file containing family mapping.
Public property | FileVersion | IFC file version.
Public property | FilterViewId | Id of the view whose visibility settings will govern the contents in the exported IFC file.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SpaceBoundaryLevel | Level of space boundaries exported in IFC file.
Public property | WallAndColumnSplitting | Option to allow division of multi-level walls and columns by levels.

See Also

IFCExportOptions Class


ExportBaseQuantities Property

[image]

Revit 2024 API
IFCExportOptions..::..ExportBaseQuantities Property
IFCExportOptions Class See Also Send Feedback
Option to export IFC standard quantities currently supported by Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool ExportBaseQuantities { get; set; }
Visual Basic
Public Property ExportBaseQuantities As Boolean
    Get
    Set
Visual C++
public:
property bool ExportBaseQuantities {
    bool get ();
    void set (bool value);
}

Remarks

IFC has created a list of common quantities (e.g. length, area, volume, etc.) that can optionally be exported along with the 3D representation for many element types (e.g. walls, columns, doors). Setting this option to true will cause the export procedure to include the set of IFC quantities that Revit currently supports. Default is false.

See Also

IFCExportOptions Class


FileVersion Property

[image]

Revit 2024 API
IFCExportOptions..::..FileVersion Property
IFCExportOptions Class See Also Send Feedback
IFC file version.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public IFCVersion FileVersion { get; set; }
Visual Basic
Public Property FileVersion As IFCVersion
    Get
    Set
Visual C++
public:
property IFCVersion FileVersion {
    IFCVersion get ();
    void set (IFCVersion value);
}

Remarks

Default is IFCVersion.Default.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

IFCExportOptions Class


FilterViewId Property

[image]

Revit 2024 API
IFCExportOptions..::..FilterViewId Property
IFCExportOptions Class See Also Send Feedback
Id of the view whose visibility settings will govern the contents in the exported IFC file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public ElementId FilterViewId { get; set; }
Visual Basic
Public Property FilterViewId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ FilterViewId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Field Value

This should be set to the id of the view, or InvalidElementId if there is to be no special filtering applied (all model elements will be exported). Default is InvalidElementId.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

IFCExportOptions Class


IsValidObject Property

[image]

Revit 2024 API
IFCExportOptions..::..IsValidObject Property
IFCExportOptions Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

IFCExportOptions Class


WallAndColumnSplitting Property

[image]

Revit 2024 API
IFCExportOptions..::..WallAndColumnSplitting Property
IFCExportOptions Class See Also Send Feedback
Option to allow division of multi-level walls and columns by levels.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool WallAndColumnSplitting { get; set; }
Visual Basic
Public Property WallAndColumnSplitting As Boolean
    Get
    Set
Visual C++
public:
property bool WallAndColumnSplitting {
    bool get ();
    void set (bool value);
}

Remarks

This option will always be considered true when FileVersion is IFC-BCA. For other File Versions, default is false.

See Also

IFCExportOptions Class


IFCVersion Enumeration

[image]

Revit 2024 API
IFCVersion Enumeration
See Also Send Feedback
An enumerated type listing available IFC file versions into which a file may be exported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum IFCVersion
Visual Basic
Public Enumeration IFCVersion
Visual C++
public enum class IFCVersion

Members

Member name | Description
Default | The Autodesk Revit application's default export format. Note that this may change as the defaults change in the Revit user interface.
IFCBCA | IFC BCA file format. This is a certified variant of IFC 2x2 used for submitting files to the Singapore BCA ePlan Check Server.
IFC2x2 | IFC 2x2 file format.
IFC2x3 | IFC 2x3 file format.
IFCCOBIE | IFC GSA COBIE 2010 file format. This is a variant of IFC 2x3 used for submitting files that are COBIE 2010-complaint.
IFC2x3CV2 | IFC 2x3 Coordination View 2.0 file format. This is a variant of IFC 2x3 used for exporting files using the Coordination View 2.0 model view.
IFC4 | IFC 4 file format.
IFC2x3FM | IFC2x3 Extended FM Handover View
IFC4RV | IFC4 Reference View
IFC4DTV | IFC4 Design Transfer View
IFC2x3BFM | IFC2x3 Basic FM Handover View
IFC4x3 | IFC4x3 file format
IFCSG | IFC-SG MVD based on IFC4

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


IGetLocalPathForOpenCallback Interface

[image]

Revit 2024 API
IGetLocalPathForOpenCallback Interface
Members See Also Send Feedback
The interface used to provide custom support for the "Open (and Unload)" command for Revit Links obtained as external resources.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public interface IGetLocalPathForOpenCallback
Visual Basic
Public Interface IGetLocalPathForOpenCallback
Visual C++
public interface class IGetLocalPathForOpenCallback

Remarks

Revit documents that are linked into host documents are read-only. If the user wishes to edit a linked Revit file they can use the "Open (and Unload)" command to unload the link, and automatically load it directly as a top-level, modifiable document (Revit files cannot be edited while they are being used as links). To support this operation for Revit links obtained as external resources, IExternalResourceServer authors should implement this callback. They should return a local path from where Revit can open the linked document for edit. Ideally, this should be a path that is different than the location from where it has been loaded as a link.

Once the user opens a link as a top-level document, they will presumably make changes to it and save it. It is the responsibility of the server to upload whatever changes the user makes so that the version stored on the server remains the most current. Server providers can determine when changes have been made by the user to local file by watching for the DocumentSaved event.

See Also

IGetLocalPathForOpenCallback Members


IGetLocalPathForOpenCallback Members

[image] [image]

Revit 2024 API
IGetLocalPathForOpenCallback Members
IGetLocalPathForOpenCallback Interface Methods See Also Send Feedback

The IGetLocalPathForOpenCallback type exposes the following members.

Methods

 | Name | Description
Public method | GetLocalPathForOpen | Implement this method to specify the local path from where a copy of a Revit link external resource can be opened for modification without interfering with its use as a link in other open documents.

See Also

IGetLocalPathForOpenCallback Interface


IGetLocalPathForOpenCallback Methods

[image] [image]

Revit 2024 API
IGetLocalPathForOpenCallback Methods
IGetLocalPathForOpenCallback Interface See Also Send Feedback

The IGetLocalPathForOpenCallback type exposes the following members.

Methods

 | Name | Description
Public method | GetLocalPathForOpen | Implement this method to specify the local path from where a copy of a Revit link external resource can be opened for modification without interfering with its use as a link in other open documents.

See Also

IGetLocalPathForOpenCallback Interface


GetLocalPathForOpen Method

[image]

Revit 2024 API
IGetLocalPathForOpenCallback..::..GetLocalPathForOpen Method
IGetLocalPathForOpenCallback Interface See Also Send Feedback
Implement this method to specify the local path from where a copy of a Revit link external resource can be opened for modification without interfering with its use as a link in other open documents.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
string GetLocalPathForOpen(
    ExternalResourceReference desiredResource
)
Visual Basic
Function GetLocalPathForOpen ( _
    desiredResource As ExternalResourceReference _
) As String
Visual C++
String^ GetLocalPathForOpen(
    ExternalResourceReference^ desiredResource
)

Parameters

desiredResource
Type: Autodesk.Revit.DB..::..ExternalResourceReference
The ExternalResourceReference that needs to be opened for modification by Revit.

Return Value

The local path from where Revit can open the linked file as its own top-level document.

See Also

IGetLocalPathForOpenCallback Interface


ImageBackgroundSettings Class

[image]

Revit 2024 API
ImageBackgroundSettings Class
Members See Also Send Feedback
Represents the rendering image background settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public class ImageBackgroundSettings : BackgroundSettings
Visual Basic
Public Class ImageBackgroundSettings _
    Inherits BackgroundSettings
Visual C++
public ref class ImageBackgroundSettings : public BackgroundSettings

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BackgroundSettings
Autodesk.Revit.DB..::..ImageBackgroundSettings

See Also

ImageBackgroundSettings Members


ImageBackgroundSettings Members

[image] [image]

Revit 2024 API
ImageBackgroundSettings Members
ImageBackgroundSettings Class Methods Properties See Also Send Feedback

The ImageBackgroundSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from BackgroundSettings.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BackgroundImageFit | The background image fit type.
Public property | FilePath | File path of the image for the rendering background.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BackgroundSettings.)
Public property | OffsetHeight | The vertical offset of the rendering image to the rendering region.
Public property | OffsetWidth | The horizontal offset of the rendering image to the rendering region.

See Also

ImageBackgroundSettings Class


ImageBackgroundSettings Methods

[image] [image]

Revit 2024 API
ImageBackgroundSettings Methods
ImageBackgroundSettings Class See Also Send Feedback

The ImageBackgroundSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from BackgroundSettings.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ImageBackgroundSettings Class


ImageBackgroundSettings Properties

[image] [image]

Revit 2024 API
ImageBackgroundSettings Properties
ImageBackgroundSettings Class See Also Send Feedback

The ImageBackgroundSettings type exposes the following members.

Properties

 | Name | Description
Public property | BackgroundImageFit | The background image fit type.
Public property | FilePath | File path of the image for the rendering background.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BackgroundSettings.)
Public property | OffsetHeight | The vertical offset of the rendering image to the rendering region.
Public property | OffsetWidth | The horizontal offset of the rendering image to the rendering region.

See Also

ImageBackgroundSettings Class


BackgroundImageFit Property

[image]

Revit 2024 API
ImageBackgroundSettings..::..BackgroundImageFit Property
ImageBackgroundSettings Class See Also Send Feedback
The background image fit type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public BackgroundImageFit BackgroundImageFit { get; set; }
Visual Basic
Public Property BackgroundImageFit As BackgroundImageFit
    Get
    Set
Visual C++
public:
property BackgroundImageFit BackgroundImageFit {
    BackgroundImageFit get ();
    void set (BackgroundImageFit value);
}

Remarks

This value indicates how scale should be applied to the image in order to fit it to a page or screen.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

ImageBackgroundSettings Class


FilePath Property

[image]

Revit 2024 API
ImageBackgroundSettings..::..FilePath Property
ImageBackgroundSettings Class See Also Send Feedback
File path of the image for the rendering background.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public string FilePath { get; set; }
Visual Basic
Public Property FilePath As String
    Get
    Set
Visual C++
public:
property String^ FilePath {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The file specified by path is not an image file. A valid image file should be in one of the following formats: bmp, jpg, jpeg, png, tif.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | When setting this property: The file specified by path doesn't exist.

See Also

ImageBackgroundSettings Class


ImageExportOptions Class

[image]

Revit 2024 API
ImageExportOptions Class
Members See Also Send Feedback
This class defines options for exporting views and sheets as an image.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class ImageExportOptions : IDisposable
Visual Basic
Public Class ImageExportOptions _
    Implements IDisposable
Visual C++
public ref class ImageExportOptions : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ImageExportOptions

See Also

ImageExportOptions Members


ImageExportOptions Members

[image] [image]

Revit 2024 API
ImageExportOptions Members
ImageExportOptions Class Constructors Methods Properties See Also Send Feedback

The ImageExportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | ImageExportOptions | Constructs a new instance of the options class used to produce images.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ImageExportOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetFileName | Gets the file name that will be produced when exporting a view to an image.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetViewsAndSheets | Gets a list of views and sheets to be exported. Used only when ExportRange is SetOfViews.
 | IsValidFileName | Verify if File name is valid
 | IsValidForSaveToProjectAsImage | Verify if ImageExportOptions object is valid for calling saveToProjectAsImage
Public method | SetViewsAndSheets | Sets a list of views and sheets to be exported. Used only when ExportRange is SetOfViews.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ExportRange | The export range defining which view(s) will be exported.
Public property | FilePath | The file name and path for the exported file.
Public property | FitDirection | The fit direction. Used only if ZoomType is FitToPage.
Public property | HLRandWFViewsFileType | File type for exported HLR and wireframe views.
Public property | ImageResolution | The image resolution in dots per inch.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | PixelSize | The pixel size of an image in one direction. Used only if ZoomType is FitToPage.
Public property | ShadowViewsFileType | The file type for exported shadow views.
Public property | ShouldCreateWebSite | Whether or not to create a web site with a page for each export. Used only when ExportRange is SetOfViews.
Public property | ViewName | The name of the view to be created.
Public property | Zoom | The value for Zoom (as a percentage). Used only when ZoomType is Zoom.
Public property | ZoomType | The zoom type, which defines how the image size is determined.

See Also

ImageExportOptions Class


ImageExportOptions Methods

[image] [image]

Revit 2024 API
ImageExportOptions Methods
ImageExportOptions Class See Also Send Feedback

The ImageExportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetFileName | Gets the file name that will be produced when exporting a view to an image.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetViewsAndSheets | Gets a list of views and sheets to be exported. Used only when ExportRange is SetOfViews.
 | IsValidFileName | Verify if File name is valid
 | IsValidForSaveToProjectAsImage | Verify if ImageExportOptions object is valid for calling saveToProjectAsImage
Public method | SetViewsAndSheets | Sets a list of views and sheets to be exported. Used only when ExportRange is SetOfViews.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ImageExportOptions Class


Dispose Method

[image]

Revit 2024 API
ImageExportOptions..::..Dispose Method
ImageExportOptions Class See Also Send Feedback
Releases all resources used by the ImageExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ImageExportOptions Class


GetFileName Method

[image]

Revit 2024 API
ImageExportOptions..::..GetFileName Method
ImageExportOptions Class See Also Send Feedback
Gets the file name that will be produced when exporting a view to an image.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static string GetFileName(
    Document aDoc,
    ElementId dbViewId
)
Visual Basic
Public Shared Function GetFileName ( _
    aDoc As Document, _
    dbViewId As ElementId _
) As String
Visual C++
public:
static String^ GetFileName(
    Document^ aDoc,
    ElementId^ dbViewId
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
The document that owns the view.
dbViewId
Type: Autodesk.Revit.DB..::..ElementId
View which is to be exported as image.

Return Value

The generated exported image file name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ImageExportOptions Class


GetViewsAndSheets Method

[image]

Revit 2024 API
ImageExportOptions..::..GetViewsAndSheets Method
ImageExportOptions Class See Also Send Feedback
Gets a list of views and sheets to be exported. Used only when ExportRange is SetOfViews.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public IList<ElementId> GetViewsAndSheets()
Visual Basic
Public Function GetViewsAndSheets As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetViewsAndSheets()

Return Value

The ids of the views and sheets.

See Also

ImageExportOptions Class


IsValidForSaveToProjectAsImage Method

[image]

Revit 2024 API
ImageExportOptions..::..IsValidForSaveToProjectAsImage Method
ImageExportOptions Class See Also Send Feedback
Verify if ImageExportOptions object is valid for calling saveToProjectAsImage

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static bool IsValidForSaveToProjectAsImage(
    ImageExportOptions options,
    Document doc
)
Visual Basic
Public Shared Function IsValidForSaveToProjectAsImage ( _
    options As ImageExportOptions, _
    doc As Document _
) As Boolean
Visual C++
public:
static bool IsValidForSaveToProjectAsImage(
    ImageExportOptions^ options,
    Document^ doc
)

Parameters

options
Type: Autodesk.Revit.DB..::..ImageExportOptions
ImageExportOptions object to be validated
doc
Type: Autodesk.Revit.DB..::..Document
Document for view name verification

Return Value

True if ImageExportOptions object is valid for calling saveToProjectAsImage; false otherwise

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ImageExportOptions Class


ImageExportOptions Properties

[image] [image]

Revit 2024 API
ImageExportOptions Properties
ImageExportOptions Class See Also Send Feedback

The ImageExportOptions type exposes the following members.

Properties

 | Name | Description
Public property | ExportRange | The export range defining which view(s) will be exported.
Public property | FilePath | The file name and path for the exported file.
Public property | FitDirection | The fit direction. Used only if ZoomType is FitToPage.
Public property | HLRandWFViewsFileType | File type for exported HLR and wireframe views.
Public property | ImageResolution | The image resolution in dots per inch.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | PixelSize | The pixel size of an image in one direction. Used only if ZoomType is FitToPage.
Public property | ShadowViewsFileType | The file type for exported shadow views.
Public property | ShouldCreateWebSite | Whether or not to create a web site with a page for each export. Used only when ExportRange is SetOfViews.
Public property | ViewName | The name of the view to be created.
Public property | Zoom | The value for Zoom (as a percentage). Used only when ZoomType is Zoom.
Public property | ZoomType | The zoom type, which defines how the image size is determined.

See Also

ImageExportOptions Class


ExportRange Property

[image]

Revit 2024 API
ImageExportOptions..::..ExportRange Property
ImageExportOptions Class See Also Send Feedback
The export range defining which view(s) will be exported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public ExportRange ExportRange { get; set; }
Visual Basic
Public Property ExportRange As ExportRange
    Get
    Set
Visual C++
public:
property ExportRange ExportRange {
    ExportRange get ();
    void set (ExportRange value);
}

Remarks

Note that SetOfViews is not an acceptable value if these options are used to save an image to a project as a new view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

ImageExportOptions Class


FitDirection Property

[image]

Revit 2024 API
ImageExportOptions..::..FitDirection Property
ImageExportOptions Class See Also Send Feedback
The fit direction. Used only if ZoomType is FitToPage.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public FitDirectionType FitDirection { get; set; }
Visual Basic
Public Property FitDirection As FitDirectionType
    Get
    Set
Visual C++
public:
property FitDirectionType FitDirection {
    FitDirectionType get ();
    void set (FitDirectionType value);
}

Remarks

The default is Horizontal.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

ImageExportOptions Class


HLRandWFViewsFileType Property

[image]

Revit 2024 API
ImageExportOptions..::..HLRandWFViewsFileType Property
ImageExportOptions Class See Also Send Feedback
File type for exported HLR and wireframe views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public ImageFileType HLRandWFViewsFileType { get; set; }
Visual Basic
Public Property HLRandWFViewsFileType As ImageFileType
    Get
    Set
Visual C++
public:
property ImageFileType HLRandWFViewsFileType {
    ImageFileType get ();
    void set (ImageFileType value);
}

Remarks

The default is JPEGMedium. This field is ignored if used to save an image to a project as a new view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

ImageExportOptions Class


ImageResolution Property

[image]

Revit 2024 API
ImageExportOptions..::..ImageResolution Property
ImageExportOptions Class See Also Send Feedback
The image resolution in dots per inch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public ImageResolution ImageResolution { get; set; }
Visual Basic
Public Property ImageResolution As ImageResolution
    Get
    Set
Visual C++
public:
property ImageResolution ImageResolution {
    ImageResolution get ();
    void set (ImageResolution value);
}

Remarks

The default is DPI_72.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

ImageExportOptions Class


IsValidObject Property

[image]

Revit 2024 API
ImageExportOptions..::..IsValidObject Property
ImageExportOptions Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ImageExportOptions Class


PixelSize Property

[image]

Revit 2024 API
ImageExportOptions..::..PixelSize Property
ImageExportOptions Class See Also Send Feedback
The pixel size of an image in one direction. Used only if ZoomType is FitToPage.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public int PixelSize { get; set; }
Visual Basic
Public Property PixelSize As Integer
    Get
    Set
Visual C++
public:
property int PixelSize {
    int get ();
    void set (int value);
}

Remarks

The default is 512 pixels.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The PixelSize value is outside the permitted range.

See Also

ImageExportOptions Class


ShadowViewsFileType Property

[image]

Revit 2024 API
ImageExportOptions..::..ShadowViewsFileType Property
ImageExportOptions Class See Also Send Feedback
The file type for exported shadow views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public ImageFileType ShadowViewsFileType { get; set; }
Visual Basic
Public Property ShadowViewsFileType As ImageFileType
    Get
    Set
Visual C++
public:
property ImageFileType ShadowViewsFileType {
    ImageFileType get ();
    void set (ImageFileType value);
}

Remarks

The default is JPEGMedium. This field is ignored if used to save an image to a project as a new view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

ImageExportOptions Class


Zoom Property

[image]

Revit 2024 API
ImageExportOptions..::..Zoom Property
ImageExportOptions Class See Also Send Feedback
The value for Zoom (as a percentage). Used only when ZoomType is Zoom.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public int Zoom { get; set; }
Visual Basic
Public Property Zoom As Integer
    Get
    Set
Visual C++
public:
property int Zoom {
    int get ();
    void set (int value);
}

Remarks

The default is 50.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The Zoom value is outside the permitted range.

See Also

ImageExportOptions Class


ZoomType Property

[image]

Revit 2024 API
ImageExportOptions..::..ZoomType Property
ImageExportOptions Class See Also Send Feedback
The zoom type, which defines how the image size is determined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public ZoomFitType ZoomType { get; set; }
Visual Basic
Public Property ZoomType As ZoomFitType
    Get
    Set
Visual C++
public:
property ZoomFitType ZoomType {
    ZoomFitType get ();
    void set (ZoomFitType value);
}

Remarks

The default is FitToPage.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

ImageExportOptions Class


ImageFileType Enumeration

[image]

Revit 2024 API
ImageFileType Enumeration
See Also Send Feedback
This enum is used to define exported file type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public enum ImageFileType
Visual Basic
Public Enumeration ImageFileType
Visual C++
public enum class ImageFileType

Members

Member name | Description
BMP | BMP
JPEGLossless | JPEG with high quality picture
JPEGMedium | JPEG with medium quality picture
JPEGSmallest | JPEG with lower quality picture and small file size
PNG | PNG
TARGA | TARGA
TIFF | TIFF

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


ImageInstance Members

[image] [image]

Revit 2024 API
ImageInstance Members
ImageInstance Class Methods Properties See Also Send Feedback

The ImageInstance type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create | Creates a new ImageInstance element placed in a view.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLocation | Returns the location of one of the points of the ImageInstance
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
 | IsValidView | Check that the view is a valid view for ImageInstance elements
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetLocation | Moves the ImageInstance to the specified location
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanHaveSnaps | When true the ImageInstance has snaps that can be enabled with the EnableSnaps property
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | DrawLayer | The layer the ImageInstance will be drawn in.
Public property | EnableSnaps | When true the ImageInstance will have its snaps enabled, but only if CanHaveSnaps is true
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Height | The height of the ImageInstance.
Public property | HeightScale | The factor applied to the ImageType to calculate the Height of the ImageInstance.
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | LockProportions | When true the proportion of Width to Height will be maintained
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Width | The width of the ImageInstance.
Public property | WidthScale | The factor applied to the width of the ImageType to calculate the Width of the ImageInstance.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ImageInstance Class


ImageInstance Methods

[image] [image]

Revit 2024 API
ImageInstance Methods
ImageInstance Class See Also Send Feedback

The ImageInstance type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create | Creates a new ImageInstance element placed in a view.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLocation | Returns the location of one of the points of the ImageInstance
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
 | IsValidView | Check that the view is a valid view for ImageInstance elements
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetLocation | Moves the ImageInstance to the specified location
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ImageInstance Class


Create Method

[image]

Revit 2024 API
ImageInstance..::..Create Method
ImageInstance Class See Also Send Feedback
Creates a new ImageInstance element placed in a view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public static ImageInstance Create(
    Document document,
    View view,
    ElementId imageTypeId,
    ImagePlacementOptions placementOptions
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    view As View, _
    imageTypeId As ElementId, _
    placementOptions As ImagePlacementOptions _
) As ImageInstance
Visual C++
public:
static ImageInstance^ Create(
    Document^ document,
    View^ view,
    ElementId^ imageTypeId,
    ImagePlacementOptions^ placementOptions
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
view
Type: Autodesk.Revit.DB..::..View
The view in which the image will be placed.
imageTypeId
Type: Autodesk.Revit.DB..::..ElementId
The id of the ImageType element for this ImageInstance.
placementOptions
Type: Autodesk.Revit.DB..::..ImagePlacementOptions
Options that specify where the ImageInstance should be placed.

Return Value

The new ImageInstance.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given view cannot contain ImageInstance elements -or- The given imageTypeId can not be used as a ImageType for ImageInstance elements -or- The given placementOptions specify a location that is more than 10 miles from the origin of the model.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

ImageInstance Class


GetLocation Method

[image]

Revit 2024 API
ImageInstance..::..GetLocation Method
ImageInstance Class See Also Send Feedback
Returns the location of one of the points of the ImageInstance

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public XYZ GetLocation(
    BoxPlacement placementPoint
)
Visual Basic
Public Function GetLocation ( _
    placementPoint As BoxPlacement _
) As XYZ
Visual C++
public:
XYZ^ GetLocation(
    BoxPlacement placementPoint
)

Parameters

placementPoint
Type: Autodesk.Revit.DB..::..BoxPlacement
The placementPoint specifies for which point of the ImageInstance the location should be returned.

Return Value

The location of the specified point

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

ImageInstance Class


SetLocation Method

[image]

Revit 2024 API
ImageInstance..::..SetLocation Method
ImageInstance Class See Also Send Feedback
Moves the ImageInstance to the specified location

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public void SetLocation(
    XYZ newLocation,
    BoxPlacement placementPoint
)
Visual Basic
Public Sub SetLocation ( _
    newLocation As XYZ, _
    placementPoint As BoxPlacement _
)
Visual C++
public:
void SetLocation(
    XYZ^ newLocation,
    BoxPlacement placementPoint
)

Parameters

newLocation
Type: Autodesk.Revit.DB..::..XYZ
The new location of the specified point
placementPoint
Type: Autodesk.Revit.DB..::..BoxPlacement
The placementPoint specifies which point of the ImageInstance should be placed at the given location.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given newLocation is more than 10 miles from the origin of the model
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

ImageInstance Class


ImageInstance Properties

[image] [image]

Revit 2024 API
ImageInstance Properties
ImageInstance Class See Also Send Feedback

The ImageInstance type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanHaveSnaps | When true the ImageInstance has snaps that can be enabled with the EnableSnaps property
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | DrawLayer | The layer the ImageInstance will be drawn in.
Public property | EnableSnaps | When true the ImageInstance will have its snaps enabled, but only if CanHaveSnaps is true
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Height | The height of the ImageInstance.
Public property | HeightScale | The factor applied to the ImageType to calculate the Height of the ImageInstance.
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | LockProportions | When true the proportion of Width to Height will be maintained
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Width | The width of the ImageInstance.
Public property | WidthScale | The factor applied to the width of the ImageType to calculate the Width of the ImageInstance.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ImageInstance Class


CanHaveSnaps Property

[image]

Revit 2024 API
ImageInstance..::..CanHaveSnaps Property
ImageInstance Class See Also Send Feedback
When true the ImageInstance has snaps that can be enabled with the EnableSnaps property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public bool CanHaveSnaps { get; }
Visual Basic
Public ReadOnly Property CanHaveSnaps As Boolean
    Get
Visual C++
public:
property bool CanHaveSnaps {
    bool get ();
}

Remarks

Snaps are only available for images based on PDF files that are vector based.

See Also

ImageInstance Class


DrawLayer Property

[image]

Revit 2024 API
ImageInstance..::..DrawLayer Property
ImageInstance Class See Also Send Feedback
The layer the ImageInstance will be drawn in.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public DrawLayer DrawLayer { get; set; }
Visual Basic
Public Property DrawLayer As DrawLayer
    Get
    Set
Visual C++
public:
property DrawLayer DrawLayer {
    DrawLayer get ();
    void set (DrawLayer value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

ImageInstance Class


EnableSnaps Property

[image]

Revit 2024 API
ImageInstance..::..EnableSnaps Property
ImageInstance Class See Also Send Feedback
When true the ImageInstance will have its snaps enabled, but only if CanHaveSnaps is true

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public bool EnableSnaps { get; set; }
Visual Basic
Public Property EnableSnaps As Boolean
    Get
    Set
Visual C++
public:
property bool EnableSnaps {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The image does not have snaps

See Also

ImageInstance Class


Height Property

[image]

Revit 2024 API
ImageInstance..::..Height Property
ImageInstance Class See Also Send Feedback
The height of the ImageInstance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public double Height { get; set; }
Visual Basic
Public Property Height As Double
    Get
    Set
Visual C++
public:
property double Height {
    double get ();
    void set (double value);
}

Remarks

If LockProportions is true, then changes to the Height will also result in changes to the Width.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The given value for height results in a width that is more than 30000 feet because LockProportions is set to true.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for height must be between 0 and 30000 feet.

See Also

ImageInstance Class


HeightScale Property

[image]

Revit 2024 API
ImageInstance..::..HeightScale Property
ImageInstance Class See Also Send Feedback
The factor applied to the ImageType to calculate the Height of the ImageInstance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public double HeightScale { get; set; }
Visual Basic
Public Property HeightScale As Double
    Get
    Set
Visual C++
public:
property double HeightScale {
    double get ();
    void set (double value);
}

Remarks

If LockProportions is true, then changes to the HeightScale will also result in changes to the WidthScale.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The given value for heightScale results in a height that is more than 30000 feet. -or- When setting this property: The given value for heightScale results in a width that is more than 30000 feet because LockProportions is set to true.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for heightScale must be non-negative.

See Also

ImageInstance Class


LockProportions Property

[image]

Revit 2024 API
ImageInstance..::..LockProportions Property
ImageInstance Class See Also Send Feedback
When true the proportion of Width to Height will be maintained

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public bool LockProportions { get; set; }
Visual Basic
Public Property LockProportions As Boolean
    Get
    Set
Visual C++
public:
property bool LockProportions {
    bool get ();
    void set (bool value);
}

See Also

ImageInstance Class


Parameter Property

[image] [image]

Revit 2024 API
ImageInstance..::..Parameter Property
ImageInstance Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ImageInstance Class
ImageInstance Members


Width Property

[image]

Revit 2024 API
ImageInstance..::..Width Property
ImageInstance Class See Also Send Feedback
The width of the ImageInstance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public double Width { get; set; }
Visual Basic
Public Property Width As Double
    Get
    Set
Visual C++
public:
property double Width {
    double get ();
    void set (double value);
}

Remarks

If LockProportions is true, then changes to the Width will also result in changes to the Height.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The given value for width results in a height that is more than 30000 feet because LockProportions is set to true.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for width must be between 0 and 30000 feet.

See Also

ImageInstance Class


WidthScale Property

[image]

Revit 2024 API
ImageInstance..::..WidthScale Property
ImageInstance Class See Also Send Feedback
The factor applied to the width of the ImageType to calculate the Width of the ImageInstance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public double WidthScale { get; set; }
Visual Basic
Public Property WidthScale As Double
    Get
    Set
Visual C++
public:
property double WidthScale {
    double get ();
    void set (double value);
}

Remarks

If LockProportions is true, then changes to the WidthScale will also result in changes to the HeightScale.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The given value for widthScale results in a width that is more than 30000 feet. -or- When setting this property: The given value for widthScale results in a height that is more than 30000 feet because LockProportions is set to true.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for widthScale must be non-negative.

See Also

ImageInstance Class


ImagePlacementOptions Class

[image]

Revit 2024 API
ImagePlacementOptions Class
Members See Also Send Feedback
ImagePlacementOptions are used to describe where an ImageInstance should be placed in a view

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public class ImagePlacementOptions : IDisposable
Visual Basic
Public Class ImagePlacementOptions _
    Implements IDisposable
Visual C++
public ref class ImagePlacementOptions : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ImagePlacementOptions

See Also

ImagePlacementOptions Members


ImagePlacementOptions Constructor

[image] [image]

Revit 2024 API
ImagePlacementOptions Constructor
ImagePlacementOptions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ImagePlacementOptions()()()() | Constructs a new ImagePlacementOptions that will place an ImageInstance with its center at the origin of the model
Public method | ImagePlacementOptions(XYZ, BoxPlacement) | Constructs a new ImagePlacementOptions for placing an ImageInstance

See Also

ImagePlacementOptions Class
ImagePlacementOptions Members


ImagePlacementOptions Constructor

[image]

Revit 2024 API
ImagePlacementOptions Constructor
ImagePlacementOptions Class See Also Send Feedback
Constructs a new ImagePlacementOptions that will place an ImageInstance with its center at the origin of the model

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public ImagePlacementOptions()
Visual Basic
Public Sub New
Visual C++
public:
ImagePlacementOptions()

See Also

ImagePlacementOptions Class
ImagePlacementOptions Overload


ImagePlacementOptions Constructor (XYZ, BoxPlacement)

[image]

Revit 2024 API
ImagePlacementOptions Constructor (XYZ, BoxPlacement)
ImagePlacementOptions Class See Also Send Feedback
Constructs a new ImagePlacementOptions for placing an ImageInstance

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public ImagePlacementOptions(
    XYZ location,
    BoxPlacement placementPoint
)
Visual Basic
Public Sub New ( _
    location As XYZ, _
    placementPoint As BoxPlacement _
)
Visual C++
public:
ImagePlacementOptions(
    XYZ^ location,
    BoxPlacement placementPoint
)

Parameters

location
Type: Autodesk.Revit.DB..::..XYZ
The location where the image will be placed
placementPoint
Type: Autodesk.Revit.DB..::..BoxPlacement
The point of the image that will be aligned to the location in the view

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

ImagePlacementOptions Class
ImagePlacementOptions Overload


Dispose Method

[image]

Revit 2024 API
ImagePlacementOptions..::..Dispose Method
ImagePlacementOptions Class See Also Send Feedback
Releases all resources used by the ImagePlacementOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ImagePlacementOptions Class


ImagePlacementOptions Properties

[image] [image]

Revit 2024 API
ImagePlacementOptions Properties
ImagePlacementOptions Class See Also Send Feedback

The ImagePlacementOptions type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Location | The location in the model where a point of the ImageInstance, determined by the PlacementPoint property, is going to be inserted.
Public property | PlacementPoint | Identifies which point of the ImageInstance will be aligned to the Location

See Also

ImagePlacementOptions Class


IsValidObject Property

[image]

Revit 2024 API
ImagePlacementOptions..::..IsValidObject Property
ImagePlacementOptions Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ImagePlacementOptions Class


Location Property

[image]

Revit 2024 API
ImagePlacementOptions..::..Location Property
ImagePlacementOptions Class See Also Send Feedback
The location in the model where a point of the ImageInstance, determined by the PlacementPoint property, is going to be inserted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public XYZ Location { get; set; }
Visual Basic
Public Property Location As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ Location {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

The location represents a point in the model where the ImageInstance will be placed. The location of the image in the view is determined by the projection of this point onto the plane of the view. This means that in a plan view, for example, the z-coordinate has no effect.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ImagePlacementOptions Class


PlacementPoint Property

[image]

Revit 2024 API
ImagePlacementOptions..::..PlacementPoint Property
ImagePlacementOptions Class See Also Send Feedback
Identifies which point of the ImageInstance will be aligned to the Location

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public BoxPlacement PlacementPoint { get; set; }
Visual Basic
Public Property PlacementPoint As BoxPlacement
    Get
    Set
Visual C++
public:
property BoxPlacement PlacementPoint {
    BoxPlacement get ();
    void set (BoxPlacement value);
}

Remarks

The location of the corners of the image in the model depends on the size and orientation of the ImageInstance and the orientation of the view it is placed in.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

ImagePlacementOptions Class


ImageResolution Enumeration

[image]

Revit 2024 API
ImageResolution Enumeration
See Also Send Feedback
This enum is used to define image resolution in order to calculate the image size.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public enum ImageResolution
Visual Basic
Public Enumeration ImageResolution
Visual C++
public enum class ImageResolution

Members

Member name | Description
DPI_72 | 72 dpi
DPI_150 | 150 dpi
DPI_300 | 300 dpi
DPI_600 | 600 dpi

Remarks

This is used only if the Zoom option for ZoomType is set.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


ImageType Class

[image]

Revit 2024 API
ImageType Class
Members See Also Send Feedback
Represents a type containing a raster based image. ImageInstances of this type can be placed in 2D views, sheets, and schedules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public class ImageType : ElementType
Visual Basic
Public Class ImageType _
    Inherits ElementType
Visual C++
public ref class ImageType : public ElementType

Remarks

ImageType elements are created with the ImageType.Create(Document, ImageTypeOptions) method.

ImageType elements can be loaded from the following file types: *.bmp, *.jpg, *.jpeg, *.png, *.tif.

In addition, when PDF support is available, ImageType elements can also be loaded from *.pdf files. See: IsPDFImportAvailable()()()()

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..ImageType

See Also

ImageType Members


ImageType Methods

[image] [image]

Revit 2024 API
ImageType Methods
ImageType Class See Also Send Feedback

The ImageType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanReload | Check whether the ImageType can be reloaded from file.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create | Creates a new ImageType element and loads the image into it.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetImage | Get the bitmap image stored in the image symbol.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | Reload | Reloads the ImageType from the file found at the location specified by the Path property, using the same PageNumber and resolution.
Public method | ReloadFrom | Reloads the image in the ImageType from a new image file, and for a new PageNumber.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Unload | Unload the linked image.

See Also

ImageType Class


CanReload Method

[image]

Revit 2024 API
ImageType..::..CanReload Method
ImageType Class See Also Send Feedback
Check whether the ImageType can be reloaded from file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public bool CanReload()
Visual Basic
Public Function CanReload As Boolean
Visual C++
public:
bool CanReload()

Return Value

True if the ImageType can be reloaded. False, otherwise.

Remarks

The test first determines the candidate path for reloading the ImageType. Then the test checks that the corresponding file is a valid image file, that it is unencrypted, and that it contains the page corresponding to PageNumber.

See Also

ImageType Class


Create Method

[image]

Revit 2024 API
ImageType..::..Create Method
ImageType Class See Also Send Feedback
Creates a new ImageType element and loads the image into it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public static ImageType Create(
    Document document,
    ImageTypeOptions options
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    options As ImageTypeOptions _
) As ImageType
Visual C++
public:
static ImageType^ Create(
    Document^ document,
    ImageTypeOptions^ options
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
options
Type: Autodesk.Revit.DB..::..ImageTypeOptions
Options that specify what image to load.

Return Value

The new ImageType.

Remarks

The ImageType will be created but will not be placed into any view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The image filename is an empty string. -or- The image file is not a supported image file type. -or- The image file is password protected. -or- The image file does not contain the requested page number. -or- The image file could not be read and may be corrupt. -or- An error occurred while handling the external resource corresponding to the image.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | The image file does not exist.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

ImageType Class


GetImage Method

[image]

Revit 2024 API
ImageType..::..GetImage Method
ImageType Class See Also Send Feedback
Get the bitmap image stored in the image symbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public Bitmap GetImage()
Visual Basic
Public Function GetImage As Bitmap
Visual C++
public:
Bitmap^ GetImage()

Return Value

The bitmap image at the original loaded image size.

See Also

ImageType Class


Reload Method

[image]

Revit 2024 API
ImageType..::..Reload Method
ImageType Class See Also Send Feedback
Reloads the ImageType from the file found at the location specified by the Path property, using the same PageNumber and resolution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public void Reload()
Visual Basic
Public Sub Reload
Visual C++
public:
void Reload()

Remarks

If reload fails (because the image file doesn't exist, cannot be read, or does not have the correct page), the currently loaded image will remain unchanged.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..FileNotFoundException | The file represented by Path does not exist.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This ImageType was not loaded from a file. -or- The file represented by Path is not a supported image file type. -or- The image file represented by Path is a password protected PDF file. -or- The image file represented by Path does not contain the page specified by PageNumber. -or- The image file represented by Path could not be read and may be corrupt. -or- An error occurred while handling the external resource corresponding to the image.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document containing this ImageType is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document containing this ImageType is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document containing this ImageType has no open transaction.

See Also

ImageType Class


Unload Method

[image]

Revit 2024 API
ImageType..::..Unload Method
ImageType Class See Also Send Feedback
Unload the linked image.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public void Unload()
Visual Basic
Public Sub Unload
Visual C++
public:
void Unload()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This ImageType is not a link.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document containing this ImageType is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document containing this ImageType is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document containing this ImageType has no open transaction.

See Also

ImageType Class


ExternalResourceType Property

[image]

Revit 2024 API
ImageType..::..ExternalResourceType Property
ImageType Class See Also Send Feedback
The type of external resources that represents images.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public static ExternalResourceType ExternalResourceType { get; }
Visual Basic
Public Shared ReadOnly Property ExternalResourceType As ExternalResourceType
    Get
Visual C++
public:
static property ExternalResourceType^ ExternalResourceType {
    ExternalResourceType^ get ();
}

See Also

ImageType Class


PageNumber Property

[image]

Revit 2024 API
ImageType..::..PageNumber Property
ImageType Class See Also Send Feedback
The number of the page in a multi-page file, that was used to create the image in the ImageType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public int PageNumber { get; }
Visual Basic
Public ReadOnly Property PageNumber As Integer
    Get
Visual C++
public:
property int PageNumber {
    int get ();
}

Remarks

This number is set when the ImageType is created or reloaded.

See Also

ImageType Class


Parameter Property

[image] [image]

Revit 2024 API
ImageType..::..Parameter Property
ImageType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ImageType Class
ImageType Members


Path Property

[image]

Revit 2024 API
ImageType..::..Path Property
ImageType Class See Also Send Feedback
The path to the file from which the ImageType was loaded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public string Path { get; }
Visual Basic
Public ReadOnly Property Path As String
    Get
Visual C++
public:
property String^ Path {
    String^ get ();
}

Remarks

The path string can be in one of several formats: absolute local, relative local, or server (indicating that the file was provided by an external server). The format is determined by PathType

The path can be an empty string, for example for (but not limited to) ImageTypes created using "Save to Project as Image".

See Also

ImageType Class


PathType Property

[image]

Revit 2024 API
ImageType..::..PathType Property
ImageType Class See Also Send Feedback
The path type that was used to refer to the file from which the ImageType was loaded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public PathType PathType { get; }
Visual Basic
Public ReadOnly Property PathType As PathType
    Get
Visual C++
public:
property PathType PathType {
    PathType get ();
}

See Also

ImageType Class


Status Property

[image]

Revit 2024 API
ImageType..::..Status Property
ImageType Class See Also Send Feedback
The status of the image

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public ImageTypeStatus Status { get; }
Visual Basic
Public ReadOnly Property Status As ImageTypeStatus
    Get
Visual C++
public:
property ImageTypeStatus Status {
    ImageTypeStatus get ();
}

See Also

ImageType Class


Width Property

[image]

Revit 2024 API
ImageType..::..Width Property
ImageType Class See Also Send Feedback
The horizontal size of the image

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public double Width { get; }
Visual Basic
Public ReadOnly Property Width As Double
    Get
Visual C++
public:
property double Width {
    double get ();
}

See Also

ImageType Class


WidthInPixels Property

[image]

Revit 2024 API
ImageType..::..WidthInPixels Property
ImageType Class See Also Send Feedback
Number of pixels in the horizontal direction of the image

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public int WidthInPixels { get; }
Visual Basic
Public ReadOnly Property WidthInPixels As Integer
    Get
Visual C++
public:
property int WidthInPixels {
    int get ();
}

See Also

ImageType Class


ImageTypeOptions Class

[image]

Revit 2024 API
ImageTypeOptions Class
Members See Also Send Feedback
Represents the options used in ImageType::Create(Document, ImageTypeOptions) and ImageType.ReloadFrom(ImageTypeOptions) methods.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public class ImageTypeOptions : IDisposable
Visual Basic
Public Class ImageTypeOptions _
    Implements IDisposable
Visual C++
public ref class ImageTypeOptions : IDisposable

Remarks

ImageTypeOptions are used to describe how an ImageType should be created from an image file.

ImageTypeOptions are used to specify the location of the image file to use for the image using either a string path or an ExternalResourceReference.

ImageTypeOptions are used to specify if the file path should be stored as an absolute path, or a relative path. A relative path is relative to the location of the project file, unless the file is workshared, in which case the relative path is relative to the location of the central file. Note that the relative path option is only available if the project file has been saved.

ImageTypeOptions are used to specify whether the image should be imported or linked. For imported images the image data is added to the Revit project file. For linked images the image data is reloaded everytime the project file is opened. Linked images are only available if they were reloaded successfully, while imported images are always available.

For PDF files the ImageTypeOptions can be used to specify which page in the PDF file to use for the image. For raster based image files the page number must be 1 (the default).

ImageTypeOptions can be used to specify the resolution (in pixels per inch) to use for the image. For PDF files the resolution is used to determine how many pixels to use when rasterizing the PDF page. Using a higher resolution will increase the number of pixels. This will add more detail, but it will also make rendering the image slower. In addition, it will likely increase the amount of data stored in the project when the image is imported.

Raster based images have a fixed number of pixels. As a result, the resolution has no effect on the amount of detail or the amount of data that is stored. The resolution is only used to determine the size of image. Doubling the resolution will make the image appear half the size.

When a file is accessed with the help of an external server, it is likely that a local cache of the file will be created temporarily. ImageTypeOptions may refer to the cached copy of the file internally. For this reason, ImageTypeOptions should be treated as a transient object whose purpose is to become an argument to ImageType.Create(Document, ImageTypeOptions) or ImageType.ReloadFrom(ImageTypeOptions). An application should not create an ImageTypeOptions object and hold onto it for a long time.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ImageTypeOptions

See Also

ImageTypeOptions Members


ImageTypeOptions Members

[image] [image]

Revit 2024 API
ImageTypeOptions Members
ImageTypeOptions Class Constructors Methods Properties See Also Send Feedback

The ImageTypeOptions type exposes the following members.

Constructors

 | Name | Description
Public method | ImageTypeOptions(ExternalResourceReference, ImageTypeSource) | Constructs a new instance of the ImageTypeOptions object.
Public method | ImageTypeOptions(String, Boolean, ImageTypeSource) | Constructs a new instance of the ImageTypeOptions object. The provided string path must specify a local file. The path can be absolute or relative to the project's location. This constructor saves an additional setting that indicates whether the imagetype will be a link or an import.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ImageTypeOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid | If true the ImageTypeOptions can be used to create or reload an ImageType.
Public method | SetExternalResourceReference | Update the external resource reference to an image.
Public method | SetPath(String) | Update the path of the file that specifies the image to be used. The provided string path must specify a local file. The path can be absolute or relative to the project's location. ImageType will respectively use an absolute or relative path.
Public method | SetPath(String, Boolean) | Update the path of the file that specifies the image to be used. The provided string path must specify a local file. The path can be absolute or relative to the project's location. Additionally, indicate whether the path used by ImageType should be absolute or relative.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | PageNumber | The page in the file to be used for the image
Public property | Path | The path of the file that specifies the image to be used.
Public property | Resolution | The Resolution of the image is expressed in dots-per-inch and hence determines the size of a pixel in the image.
Public property | SourceType | Indicates whether the image type is a link or an import.

See Also

ImageTypeOptions Class


ImageTypeOptions Constructor

[image] [image]

Revit 2024 API
ImageTypeOptions Constructor
ImageTypeOptions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ImageTypeOptions(ExternalResourceReference, ImageTypeSource) | Constructs a new instance of the ImageTypeOptions object.
Public method | ImageTypeOptions(String, Boolean, ImageTypeSource) | Constructs a new instance of the ImageTypeOptions object. The provided string path must specify a local file. The path can be absolute or relative to the project's location. This constructor saves an additional setting that indicates whether the imagetype will be a link or an import.

See Also

ImageTypeOptions Class
ImageTypeOptions Members


ImageTypeOptions Constructor (String, Boolean, ImageTypeSource)

[image]

Revit 2024 API
ImageTypeOptions Constructor (String, Boolean, ImageTypeSource)
ImageTypeOptions Class See Also Send Feedback

Constructs a new instance of the ImageTypeOptions object.

The provided string path must specify a local file. The path can be absolute or relative to the project's location.

This constructor saves an additional setting that indicates whether the imagetype will be a link or an import.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public ImageTypeOptions(
    string path,
    bool useRelativePath,
    ImageTypeSource sourceType
)
Visual Basic
Public Sub New ( _
    path As String, _
    useRelativePath As Boolean, _
    sourceType As ImageTypeSource _
)
Visual C++
public:
ImageTypeOptions(
    String^ path,
    bool useRelativePath,
    ImageTypeSource sourceType
)

Parameters

path
Type: System..::..String
The file path that specifies the image to be used.
useRelativePath
Type: System..::..Boolean
True if ImageType should use a relative path, false otherwise.
sourceType
Type: Autodesk.Revit.DB..::..ImageTypeSource
Specifies the image type source. Valid values are 'Import' and 'Link'.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ImageType source is not correct. Only Link or Import values are allowed.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

ImageTypeOptions Class
ImageTypeOptions Overload


Dispose Method

[image]

Revit 2024 API
ImageTypeOptions..::..Dispose Method
ImageTypeOptions Class See Also Send Feedback
Releases all resources used by the ImageTypeOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ImageTypeOptions Class


IsValid Method

[image]

Revit 2024 API
ImageTypeOptions..::..IsValid Method
ImageTypeOptions Class See Also Send Feedback
If true the ImageTypeOptions can be used to create or reload an ImageType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public bool IsValid(
    Document document
)
Visual Basic
Public Function IsValid ( _
    document As Document _
) As Boolean
Visual C++
public:
bool IsValid(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.

Return Value

Returns True if the options can be used to create or reload an ImageType. False otherwise.

Remarks

This method returns true if all the following checks are true:
  • The Path points to a file that is a supported image file type.
  • The Path points to a file that is not encrypted, which can happen for PDF files.
  • The Path points to a file that contains the specified PageNumber.
  • Only imported images are allowed in family documents.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ImageTypeOptions Class


SetExternalResourceReference Method

[image]

Revit 2024 API
ImageTypeOptions..::..SetExternalResourceReference Method
ImageTypeOptions Class See Also Send Feedback
Update the external resource reference to an image.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public void SetExternalResourceReference(
    ExternalResourceReference resourceReference
)
Visual Basic
Public Sub SetExternalResourceReference ( _
    resourceReference As ExternalResourceReference _
)
Visual C++
public:
void SetExternalResourceReference(
    ExternalResourceReference^ resourceReference
)

Parameters

resourceReference
Type: Autodesk.Revit.DB..::..ExternalResourceReference
An external resource reference to an image.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ImageTypeOptions Class


SetPath Method

[image] [image]

Revit 2024 API
ImageTypeOptions..::..SetPath Method
ImageTypeOptions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetPath(String) | Update the path of the file that specifies the image to be used. The provided string path must specify a local file. The path can be absolute or relative to the project's location. ImageType will respectively use an absolute or relative path.
Public method | SetPath(String, Boolean) | Update the path of the file that specifies the image to be used. The provided string path must specify a local file. The path can be absolute or relative to the project's location. Additionally, indicate whether the path used by ImageType should be absolute or relative.

See Also

ImageTypeOptions Class
ImageTypeOptions Members


SetPath Method (String)

[image]

Revit 2024 API
ImageTypeOptions..::..SetPath Method (String)
ImageTypeOptions Class See Also Send Feedback

Update the path of the file that specifies the image to be used.

The provided string path must specify a local file. The path can be absolute or relative to the project's location. ImageType will respectively use an absolute or relative path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public void SetPath(
    string path
)
Visual Basic
Public Sub SetPath ( _
    path As String _
)
Visual C++
public:
void SetPath(
    String^ path
)

Parameters

path
Type: System..::..String
The file path that specifies the image to be used.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ImageTypeOptions Class
SetPath Overload


SetPath Method (String, Boolean)

[image]

Revit 2024 API
ImageTypeOptions..::..SetPath Method (String, Boolean)
ImageTypeOptions Class See Also Send Feedback

Update the path of the file that specifies the image to be used.

The provided string path must specify a local file. The path can be absolute or relative to the project's location.

Additionally, indicate whether the path used by ImageType should be absolute or relative.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public void SetPath(
    string path,
    bool useRelativePath
)
Visual Basic
Public Sub SetPath ( _
    path As String, _
    useRelativePath As Boolean _
)
Visual C++
public:
void SetPath(
    String^ path,
    bool useRelativePath
)

Parameters

path
Type: System..::..String
The file path that specifies the image to be used.
useRelativePath
Type: System..::..Boolean
True if ImageType should use a relative path, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ImageTypeOptions Class
SetPath Overload


ImageTypeOptions Properties

[image] [image]

Revit 2024 API
ImageTypeOptions Properties
ImageTypeOptions Class See Also Send Feedback

The ImageTypeOptions type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | PageNumber | The page in the file to be used for the image
Public property | Path | The path of the file that specifies the image to be used.
Public property | Resolution | The Resolution of the image is expressed in dots-per-inch and hence determines the size of a pixel in the image.
Public property | SourceType | Indicates whether the image type is a link or an import.

See Also

ImageTypeOptions Class


PageNumber Property

[image]

Revit 2024 API
ImageTypeOptions..::..PageNumber Property
ImageTypeOptions Class See Also Send Feedback
The page in the file to be used for the image

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public int PageNumber { get; set; }
Visual Basic
Public Property PageNumber As Integer
    Get
    Set
Visual C++
public:
property int PageNumber {
    int get ();
    void set (int value);
}

Remarks

The default value of this property is 1. This default is appropriate for most file types. This should be used for files, such as PDF files, that can have multiple pages. Valid values range from 1 to the number of pages in the file.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for pageNumber is not positive.

See Also

ImageTypeOptions Class


Path Property

[image]

Revit 2024 API
ImageTypeOptions..::..Path Property
ImageTypeOptions Class See Also Send Feedback
The path of the file that specifies the image to be used.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public string Path { get; }
Visual Basic
Public ReadOnly Property Path As String
    Get
Visual C++
public:
property String^ Path {
    String^ get ();
}

See Also

ImageTypeOptions Class


Resolution Property

[image]

Revit 2024 API
ImageTypeOptions..::..Resolution Property
ImageTypeOptions Class See Also Send Feedback
The Resolution of the image is expressed in dots-per-inch and hence determines the size of a pixel in the image.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public double Resolution { get; set; }
Visual Basic
Public Property Resolution As Double
    Get
    Set
Visual C++
public:
property double Resolution {
    double get ();
    void set (double value);
}

Remarks

For raster based image formats (*.bmp, *.jpg, *.jpeg, *.png, *.tif) the Resolution is used to calculate the size of the image from the number of pixels in the horizontal and vertical directions.

For PDF files, which have a known paper size, the Resolution is used to control the amount of detail to capture in the image. Increasing the Resolution of PDF based images will add more detail to the image, but will also increase the amount of data stored in the project file.

The default value of this property is 72 dpi.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for resolution must be positive.

See Also

ImageTypeOptions Class


SourceType Property

[image]

Revit 2024 API
ImageTypeOptions..::..SourceType Property
ImageTypeOptions Class See Also Send Feedback
Indicates whether the image type is a link or an import.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public ImageTypeSource SourceType { get; set; }
Visual Basic
Public Property SourceType As ImageTypeSource
    Get
    Set
Visual C++
public:
property ImageTypeSource SourceType {
    ImageTypeSource get ();
    void set (ImageTypeSource value);
}

Remarks

Use this property with the method ImageType::Create to create a linked image type. Use this property with the method ImageType::ReloadFrom to convert an import image type to a link and vice versa. Valid values are 'Import' and 'Link'.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The ImageType source is not correct. Only Link or Import values are allowed.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

ImageTypeOptions Class


ImageTypeSource Enumeration

[image]

Revit 2024 API
ImageTypeSource Enumeration
See Also Send Feedback
The source of the data used to generate the image.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021
Since: 2021

Syntax

C#
public enum ImageTypeSource
Visual Basic
Public Enumeration ImageTypeSource
Visual C++
public enum class ImageTypeSource

Members

Member name | Description
Link | The image data is from an externally linked image file.
Import | The image data was imported into the Revit document.
Internal | The image data was created internally. These are rendering images or views saved in the project as images.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


ImageTypeStatus Enumeration

[image]

Revit 2024 API
ImageTypeStatus Enumeration
See Also Send Feedback
Indicates the current state of the contents of the ImageType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021
Since: 2021

Syntax

C#
public enum ImageTypeStatus
Visual Basic
Public Enumeration ImageTypeStatus
Visual C++
public enum class ImageTypeStatus

Members

Member name | Description
Unknown | The linked image has not yet been loaded. No image is available. This status is only returned before the document is fully opened.
Loaded | The linked image was successfully loaded.
FailedToLoad

The linked image could not be loaded from file.

Some possible reasons are:
  • The file could not be found
  • The file could be corrupt or not contain image data
  • In case of PDF files, the file might be encrypted or not have the requested page
Unloaded | The linked images was unloaded by the user. No image is available.
Imported | The image was imported and is available.
Generated | The internally created image is available.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


ImageView Members

[image] [image]

Revit 2024 API
ImageView Members
ImageView Class Methods Properties See Also Send Feedback

The ImageView type exposes the following members.

Methods

 | Name | Description
Public method | AddFilter | Adds a filter to the view. (Inherited from View.)
Public method | AllowsAnalysisDisplay | Identifies if this view allows display of Analysis results. (Inherited from View.)
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of the input view that are not controlled by the current view template. (Inherited from View.)
Public method | AreGraphicsOverridesAllowed | Determines if Visibility/Graphics Overriddes can be applied to the view. (Inherited from View.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanApplyColorFillScheme | Checks if the id can be applied as the scheme id of specified category to this view. (Inherited from View.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanCategoryBeHidden | Checks whether the category can be hidden in the view. (Inherited from View.)
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view. (Inherited from View.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanEnableTemporaryViewPropertiesMode | Indicates if Temporary View Properties mode can be applied for view in current state. (Inherited from View.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified. (Inherited from View.)
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified. (Inherited from View.)
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified (Inherited from View.)
Public method | CanUseDepthCueing | Indicates if view can use Depth Cueing (Inherited from View.)
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes (Inherited from View.)
Public method | CanViewBeDuplicated | Identifies if this view can be duplicated. (Inherited from View.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view. (Inherited from View.)
Public method | ConvertToIndependent | Convert the dependent view to independent. (Inherited from View.)
 | Create | Create an ImageView containing an image imported from disk.
Public method | CreateViewTemplate | Creates a new view template instance from this view instance. (Inherited from View.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode. (Inherited from View.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates this view. (Inherited from View.)
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode. (Inherited from View.)
Public method | EnableTemporaryViewPropertiesMode | Turns Temporary View Properties mode on or off. In this mode, any changes made to the view are temporary and will be discarded once the mode is disabled. (Inherited from View.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetBackground | Returns the current background set for the view. (Inherited from View.)
Public method | GetCalloutParentId | Gets ID of the callout parent view. (Inherited from View.)
Public method | GetCategoryHidden | Checks if elements of the given category are set to be invisible (hidden) in this view. (Inherited from View.)
Public method | GetCategoryOverrides | Gets graphic overrides for a category in view. (Inherited from View.)
Public method | GetColorFillSchemeId | Returns id of the color fill scheme element applied to the view. (Inherited from View.)
Public method | GetCropRegionShapeManager | Returns an object for managing view crop region shape. (Inherited from View.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetDependentViewIds | Get the ids of dependent views. (Inherited from View.)
Public method | GetDepthCueing | Returns the current depth cueing settings for the view. (Inherited from View.)
Public method | GetDirectContext3DHandleOverrides | Returns DirectContext3D handle overrides object for the view. (Inherited from View.)
Public method | GetElementOverrides | Gets graphic overrides for an element in the view. (Inherited from View.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetFilterOverrides | Gets graphic overrides that a filter applies to the view. (Inherited from View.)
Public method | GetFilters | Gets the filters applied to the view. (Inherited from View.)
Public method | GetFilterVisibility | Gets the visibility of the elements associated with a filter. (Inherited from View.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIsFilterEnabled | Identifies if the filter is enabled in this view. (Inherited from View.)
Public method | GetLinkOverrides | Gets the graphic overrides of a RevitLinkType or RevitLinkInstance in view. (Inherited from View.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetModelToProjectionTransforms | Gets the transforms from the model space to the view projection space. (Inherited from View.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetNonControlledTemplateParameterIds | Returns a list of parameters that are not marked as included when this view is used as a template. (Inherited from View.)
Public method | GetOrderedFilters | Gets the filters applied to the view in the order they are applied. (Inherited from View.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPlacementOnSheetStatus | Determines if this view placed on a sheet completely or partially. (Inherited from View.)
Public method | GetPointCloudOverrides | Returns point cloud overrides object for the view. (Inherited from View.)
Public method | GetPrimaryViewId | Get the id of the primary view. (Inherited from View.)
Public method | GetReferenceCallouts | Returns element ids of all reference callouts in the view. (Inherited from View.)
Public method | GetReferenceElevations | Returns element ids of all reference elevations in the view. (Inherited from View.)
Public method | GetReferenceSections | Returns element ids of all reference sections in the view. (Inherited from View.)
Public method | GetSketchyLines | Returns the current sketchy lines settings for the view. (Inherited from View.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetTemplateParameterIds | Returns a list of parameter ids that may be controlled when this view is assigned as a template. (Inherited from View.)
Public method | GetTemporaryViewPropertiesId | When Temporary View Properties mode is in progress it provides view id that overrode settings for current view. Outside Temporary View Properties mode InvalidElementId will be returned. (Inherited from View.)
Public method | GetTemporaryViewPropertiesName | When Temporary View Properties mode is in progress, name of applied template is returned. Outside Temporary View Properties mode, empty string will be returned. (Inherited from View.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetViewDisplayModel | Returns the current view display model settings for the view. (Inherited from View.)
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view. (Inherited from View.)
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view. (Inherited from View.)
Public method | HasDetailLevel | Check if the view has a Detail Level property (Inherited from View.)
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property (Inherited from View.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property (Inherited from View.)
Public method | HasViewTransforms | Returns true if the view reports model space to view projection space transforms. (Inherited from View.)
Public method | HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View.)
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view. (Inherited from View.)
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view. (Inherited from View.)
Public method | HideElements | Sets the elements to be hidden in the view. (Inherited from View.)
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View.)
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View.)
Public method | IsCategoryOverridable | Checks whether the category can have graphic overrides in this view. (Inherited from View.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view. (Inherited from View.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsFilterApplied | Indicates if a filter is applied to the view. (Inherited from View.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode. (Inherited from View.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View.)
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories. (Inherited from View.)
Public method | IsTemporaryViewPropertiesModeEnabled | Returns true when Temporary View Properties mode is in progress, false otherwise. (Inherited from View.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | IsValidViewTemplate | Verifies that the view represented by templateId can be set as the controlling view template for this view. (Inherited from View.)
Public method | IsViewValidForTemplateCreation | Verifies that the view is valid for template creation. (Inherited from View.)
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view. (Inherited from View.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | RemoveCalloutParent | Replaces callout parent ID with InvalidElementId. (Inherited from View.)
Public method | RemoveFilter | Removes a filter from the view. (Inherited from View.)
Public method | RemoveLinkOverrides | Deletes the graphical link overrides in the current view. (Inherited from View.)
Public method | RestoreCalloutParent | Restores callout parent ID to the original view ID if that view is still available. (Inherited from View.)
Public method | SetBackground | Sets the background for the view. Background can only be set for 3d views and for Sections/Elevations. (Inherited from View.)
Public method | SetCategoryHidden | Sets if elements of the given category will be visible in this view. (Inherited from View.)
Public method | SetCategoryOverrides | Sets graphic overrides for a category in view. (Inherited from View.)
Public method | SetColorFillSchemeId | Applies color fill scheme to this view. (Inherited from View.)
Public method | SetDepthCueing | Sets the depth cueing settings for the view. (Inherited from View.)
Public method | SetElementOverrides | Sets graphic overrides for an element in the view. (Inherited from View.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetFilterOverrides | Sets the overrides associated with a filter. (Inherited from View.)
Public method | SetFilterVisibility | Sets the visibility of the elements associated with a filter. (Inherited from View.)
Public method | SetIsFilterEnabled | Sets the filter enabled flag. (Inherited from View.)
Public method | SetLinkOverrides | Sets the graphic overrides of a RevitLinkType or RevitLinkInstance in the view. (Inherited from View.)
Public method | SetNonControlledTemplateParameterIds | Sets the parameters that will not be included when this view is used as a template. (Inherited from View.)
Public method | SetSketchyLines | Sets the sketchy lines settings for the view. (Inherited from View.)
Public method | SetViewDisplayModel | Sets the view display model settings for the view. (Inherited from View.)
Public method | SetWorksetVisibility | Sets visibility for a workset in this view. (Inherited from View.)
Public method | SetWorksharingDisplayMode | Sets the worksharing display mode for this view. (Inherited from View.)
Public method | ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View.)
Public method | SupportedColorFillCategoryIds | Returns collection of all category ids that correspond to elements that can potentially be colored in this view according to a color fill scheme. The set may be different depending on the view type. (Inherited from View.)
Public method | SupportsRevealConstraints | Checks that the view can have the Reveal Constraints mode activated. (Inherited from View.)
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode. (Inherited from View.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

Properties

 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View.)
Public property | AreAnalyticalModelCategoriesHidden | Indicates if analytical model categories are currently hidden in the view. (Inherited from View.)
Public property | AreAnnotationCategoriesHidden | Indicates if annotation categories are currently hidden in the view. (Inherited from View.)
Public property | AreCoordinationModelHandlesHidden | Indicates if Coordination Model handles are currently hidden in the view. (Inherited from View.)
Public property | AreImportCategoriesHidden | Indicates if import categories are currently hidden in the view. (Inherited from View.)
Public property | AreModelCategoriesHidden | Indicates if model categories are currently hidden in the view. (Inherited from View.)
Public property | ArePointCloudsHidden | Indicates if point clouds are currently hidden in the view. (Inherited from View.)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view. (Inherited from View.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CropBox | The Crop Box applied to the view, or an outline encompassing the crop region applied to the view. (Inherited from View.)
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View.)
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DetailLevel | The detail level of this view. (Inherited from View.)
Public property | Discipline | The Discipline of the view. (Inherited from View.)
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style. (Inherited from View.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | GenLevel | The level for the view. (Inherited from View.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | ImageInstanceId | Id of the image in the view.
Public property | IsAssemblyView | Indicates if the view is assembly view. (Inherited from View.)
Public property | IsCallout | Indicates if the view is a callout view. (Inherited from View.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTemplate | Test whether the view is a view template. (Inherited from View.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Origin | Returns the origin of the screen. (Inherited from View.)
Public property | Outline | The bounds of the view in paper space (in feet). (Inherited from View.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PartsVisibility | The visibility setting for parts in this view. (Inherited from View.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RevealConstraintsMode | Indicates whether the Reveal Constraints mode is activated in the view. (Inherited from View.)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Public property | Scale | The scale of the view. (Inherited from View.)
Public property | ShadowIntensity | The intesity of cast shadows - 0 = no shadows, 100 = black. (Inherited from View.)
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View.)
Public property | SunlightIntensity | The intensity of the simulated (directional) sunlight. 0 = no directional light; maximum value is 100. (Inherited from View.)
Public property | TemporaryViewModes | Data of temporary view modes associated with this view. (Inherited from View.)
Public property | Title | The view title. This consists of the view name plus other modifiers, such as the view type, sheet number, area scheme, and/or assembly type, depending on the specifics of the view. (Inherited from View.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | ViewTemplateId | The id of the template view that controls this view's parameters. (Inherited from View.)
Public property | ViewType | The type of the view. (Inherited from View.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ImageView Class


ImageView Methods

[image] [image]

Revit 2024 API
ImageView Methods
ImageView Class See Also Send Feedback

The ImageView type exposes the following members.

Methods

 | Name | Description
Public method | AddFilter | Adds a filter to the view. (Inherited from View.)
Public method | AllowsAnalysisDisplay | Identifies if this view allows display of Analysis results. (Inherited from View.)
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of the input view that are not controlled by the current view template. (Inherited from View.)
Public method | AreGraphicsOverridesAllowed | Determines if Visibility/Graphics Overriddes can be applied to the view. (Inherited from View.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanApplyColorFillScheme | Checks if the id can be applied as the scheme id of specified category to this view. (Inherited from View.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanCategoryBeHidden | Checks whether the category can be hidden in the view. (Inherited from View.)
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view. (Inherited from View.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanEnableTemporaryViewPropertiesMode | Indicates if Temporary View Properties mode can be applied for view in current state. (Inherited from View.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified. (Inherited from View.)
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified. (Inherited from View.)
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified (Inherited from View.)
Public method | CanUseDepthCueing | Indicates if view can use Depth Cueing (Inherited from View.)
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes (Inherited from View.)
Public method | CanViewBeDuplicated | Identifies if this view can be duplicated. (Inherited from View.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view. (Inherited from View.)
Public method | ConvertToIndependent | Convert the dependent view to independent. (Inherited from View.)
 | Create | Create an ImageView containing an image imported from disk.
Public method | CreateViewTemplate | Creates a new view template instance from this view instance. (Inherited from View.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode. (Inherited from View.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates this view. (Inherited from View.)
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode. (Inherited from View.)
Public method | EnableTemporaryViewPropertiesMode | Turns Temporary View Properties mode on or off. In this mode, any changes made to the view are temporary and will be discarded once the mode is disabled. (Inherited from View.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetBackground | Returns the current background set for the view. (Inherited from View.)
Public method | GetCalloutParentId | Gets ID of the callout parent view. (Inherited from View.)
Public method | GetCategoryHidden | Checks if elements of the given category are set to be invisible (hidden) in this view. (Inherited from View.)
Public method | GetCategoryOverrides | Gets graphic overrides for a category in view. (Inherited from View.)
Public method | GetColorFillSchemeId | Returns id of the color fill scheme element applied to the view. (Inherited from View.)
Public method | GetCropRegionShapeManager | Returns an object for managing view crop region shape. (Inherited from View.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetDependentViewIds | Get the ids of dependent views. (Inherited from View.)
Public method | GetDepthCueing | Returns the current depth cueing settings for the view. (Inherited from View.)
Public method | GetDirectContext3DHandleOverrides | Returns DirectContext3D handle overrides object for the view. (Inherited from View.)
Public method | GetElementOverrides | Gets graphic overrides for an element in the view. (Inherited from View.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetFilterOverrides | Gets graphic overrides that a filter applies to the view. (Inherited from View.)
Public method | GetFilters | Gets the filters applied to the view. (Inherited from View.)
Public method | GetFilterVisibility | Gets the visibility of the elements associated with a filter. (Inherited from View.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIsFilterEnabled | Identifies if the filter is enabled in this view. (Inherited from View.)
Public method | GetLinkOverrides | Gets the graphic overrides of a RevitLinkType or RevitLinkInstance in view. (Inherited from View.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetModelToProjectionTransforms | Gets the transforms from the model space to the view projection space. (Inherited from View.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetNonControlledTemplateParameterIds | Returns a list of parameters that are not marked as included when this view is used as a template. (Inherited from View.)
Public method | GetOrderedFilters | Gets the filters applied to the view in the order they are applied. (Inherited from View.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPlacementOnSheetStatus | Determines if this view placed on a sheet completely or partially. (Inherited from View.)
Public method | GetPointCloudOverrides | Returns point cloud overrides object for the view. (Inherited from View.)
Public method | GetPrimaryViewId | Get the id of the primary view. (Inherited from View.)
Public method | GetReferenceCallouts | Returns element ids of all reference callouts in the view. (Inherited from View.)
Public method | GetReferenceElevations | Returns element ids of all reference elevations in the view. (Inherited from View.)
Public method | GetReferenceSections | Returns element ids of all reference sections in the view. (Inherited from View.)
Public method | GetSketchyLines | Returns the current sketchy lines settings for the view. (Inherited from View.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetTemplateParameterIds | Returns a list of parameter ids that may be controlled when this view is assigned as a template. (Inherited from View.)
Public method | GetTemporaryViewPropertiesId | When Temporary View Properties mode is in progress it provides view id that overrode settings for current view. Outside Temporary View Properties mode InvalidElementId will be returned. (Inherited from View.)
Public method | GetTemporaryViewPropertiesName | When Temporary View Properties mode is in progress, name of applied template is returned. Outside Temporary View Properties mode, empty string will be returned. (Inherited from View.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetViewDisplayModel | Returns the current view display model settings for the view. (Inherited from View.)
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view. (Inherited from View.)
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view. (Inherited from View.)
Public method | HasDetailLevel | Check if the view has a Detail Level property (Inherited from View.)
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property (Inherited from View.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property (Inherited from View.)
Public method | HasViewTransforms | Returns true if the view reports model space to view projection space transforms. (Inherited from View.)
Public method | HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View.)
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view. (Inherited from View.)
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view. (Inherited from View.)
Public method | HideElements | Sets the elements to be hidden in the view. (Inherited from View.)
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View.)
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View.)
Public method | IsCategoryOverridable | Checks whether the category can have graphic overrides in this view. (Inherited from View.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view. (Inherited from View.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsFilterApplied | Indicates if a filter is applied to the view. (Inherited from View.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode. (Inherited from View.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View.)
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories. (Inherited from View.)
Public method | IsTemporaryViewPropertiesModeEnabled | Returns true when Temporary View Properties mode is in progress, false otherwise. (Inherited from View.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | IsValidViewTemplate | Verifies that the view represented by templateId can be set as the controlling view template for this view. (Inherited from View.)
Public method | IsViewValidForTemplateCreation | Verifies that the view is valid for template creation. (Inherited from View.)
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view. (Inherited from View.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | RemoveCalloutParent | Replaces callout parent ID with InvalidElementId. (Inherited from View.)
Public method | RemoveFilter | Removes a filter from the view. (Inherited from View.)
Public method | RemoveLinkOverrides | Deletes the graphical link overrides in the current view. (Inherited from View.)
Public method | RestoreCalloutParent | Restores callout parent ID to the original view ID if that view is still available. (Inherited from View.)
Public method | SetBackground | Sets the background for the view. Background can only be set for 3d views and for Sections/Elevations. (Inherited from View.)
Public method | SetCategoryHidden | Sets if elements of the given category will be visible in this view. (Inherited from View.)
Public method | SetCategoryOverrides | Sets graphic overrides for a category in view. (Inherited from View.)
Public method | SetColorFillSchemeId | Applies color fill scheme to this view. (Inherited from View.)
Public method | SetDepthCueing | Sets the depth cueing settings for the view. (Inherited from View.)
Public method | SetElementOverrides | Sets graphic overrides for an element in the view. (Inherited from View.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetFilterOverrides | Sets the overrides associated with a filter. (Inherited from View.)
Public method | SetFilterVisibility | Sets the visibility of the elements associated with a filter. (Inherited from View.)
Public method | SetIsFilterEnabled | Sets the filter enabled flag. (Inherited from View.)
Public method | SetLinkOverrides | Sets the graphic overrides of a RevitLinkType or RevitLinkInstance in the view. (Inherited from View.)
Public method | SetNonControlledTemplateParameterIds | Sets the parameters that will not be included when this view is used as a template. (Inherited from View.)
Public method | SetSketchyLines | Sets the sketchy lines settings for the view. (Inherited from View.)
Public method | SetViewDisplayModel | Sets the view display model settings for the view. (Inherited from View.)
Public method | SetWorksetVisibility | Sets visibility for a workset in this view. (Inherited from View.)
Public method | SetWorksharingDisplayMode | Sets the worksharing display mode for this view. (Inherited from View.)
Public method | ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View.)
Public method | SupportedColorFillCategoryIds | Returns collection of all category ids that correspond to elements that can potentially be colored in this view according to a color fill scheme. The set may be different depending on the view type. (Inherited from View.)
Public method | SupportsRevealConstraints | Checks that the view can have the Reveal Constraints mode activated. (Inherited from View.)
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode. (Inherited from View.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

See Also

ImageView Class


Print Method

[image] [image]

Revit 2024 API
ImageView..::..Print Method
ImageView Class See Also Send Feedback
Print this view.

Overload List

 | Name | Description
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)

See Also

ImageView Class
ImageView Members


ImageInstanceId Property

[image]

Revit 2024 API
ImageView..::..ImageInstanceId Property
ImageView Class See Also Send Feedback
Id of the image in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElementId ImageInstanceId { get; }
Visual Basic
Public ReadOnly Property ImageInstanceId As ElementId
    Get
Visual C++
public:
property ElementId^ ImageInstanceId {
    ElementId^ get ();
}

See Also

ImageView Class


Parameter Property

[image] [image]

Revit 2024 API
ImageView..::..Parameter Property
ImageView Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ImageView Class
ImageView Members


IModelExportContext Interface

[image]

Revit 2024 API
IModelExportContext Interface
Members See Also Send Feedback
An interface that is used in custom export to export 3D views of a Revit model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public interface IModelExportContext : IExportContextBase
Visual Basic
Public Interface IModelExportContext _
    Inherits IExportContextBase
Visual C++
public interface class IModelExportContext : IExportContextBase

Remarks

An instance of a class that implements this interface is passed in as a parameter of the CustomExporter constructor. The interface methods are then called at times of drawing entities that are currently visible in the view being exported.

With this type of export context used to perform a custom export, Revit will traverse the model and output the model's geometry as if in the process of regular displaying or exporting a 3D View. It means that any geometry which is visible in an open view (taking any current visibility setting applicable to the view) will be processed and output.

See Also

IModelExportContext Members


IModelExportContext Methods

[image] [image]

Revit 2024 API
IModelExportContext Methods
IModelExportContext Interface See Also Send Feedback

The IModelExportContext type exposes the following members.

Methods

Name Description
Public method OnCurve
This method is called when a Curve is being output.
(Inherited from IExportContextBase.)
Public method OnLineSegment
This method is called after unhandled curve was tessellated to line segments and sent to the output.

Note for 2D export: if the export is performed for the view in non-Wireframe display style, then

  • this method is called outside of view, instance and link begin/end calls but still between OnElementBegin2D/OnElementEnd2D calls
  • this method is never called for annotation elements, i.e. their geometry should be processed in methods OnCurve and OnPolyline

(Inherited from IExportContextBase.)
Public method OnPoint
This method is called when a Point is being output.
Public method OnPolyline
This method is called when a Polyline is being output.
(Inherited from IExportContextBase.)
Public method OnPolylineSegments
This method is called after unhandled curve was tessellated to polyline segments and sent to the output.

Note for 2D export: if the export is performed for the view in non-Wireframe display style, then

  • this method is called outside of view, instance and link begin/end calls but still between OnElementBegin2D/OnElementEnd2D calls
  • this method is never called for annotation elements, i.e. their geometry should be processed in methods OnCurve and OnPolyline

(Inherited from IExportContextBase.)
Public method OnText
This method is called when a text annotation object is being output.
(Inherited from IExportContextBase.)

See Also

IModelExportContext Interface


OnPoint Method

[image]

Revit 2024 API
IModelExportContext..::..OnPoint Method
IModelExportContext Interface See Also Send Feedback
This method is called when a Point is being output.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
RenderNodeAction OnPoint(
    PointNode node
)
Visual Basic
Function OnPoint ( _
    node As PointNode _
) As RenderNodeAction
Visual C++
RenderNodeAction OnPoint(
    PointNode^ node
)

Parameters

node
Type: Autodesk.Revit.DB..::..PointNode
An output node that represents a Point.

Return Value

Return RenderNodeAction.Proceed if you wish to receive low-level geometry (line segments) for this point, or otherwise return RenderNodeAction.Skip.

Remarks

Note that this method is invoked only if the custom exporter was set up to include geometric objects in the output stream. See IncludeGeometricObjects for mode details.

See Also

IModelExportContext Interface


ImportColorMode Enumeration

[image]

Revit 2024 API
ImportColorMode Enumeration
See Also Send Feedback
An enumerated type listing how colors are handled in an import process.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Since: 2013

Syntax

C#
public enum ImportColorMode
Visual Basic
Public Enumeration ImportColorMode
Visual C++
public enum class ImportColorMode

Members

Member name | Description
Preserved | Colors in the imported drawing are preserved.
Inverted | Colors in the imported drawing are inverted.
BlackAndWhite | Colors in the imported drawing are converted to Black and White.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


ImportIFCOptions Class

[image]

Revit 2024 API
ImportIFCOptions Class
Members See Also Send Feedback
Provides access to settings that control linking and opening IFC files.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public class ImportIFCOptions : IDisposable
Visual Basic
Public Class ImportIFCOptions _
    Implements IDisposable
Visual C++
public ref class ImportIFCOptions : IDisposable

Remarks

These settings are stored in the Revit.ini file. All documents in Revit instances which use this Revit.ini will follow these settings.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ImportIFCOptions

See Also

ImportIFCOptions Members


ImportIFCOptions Members

[image] [image]

Revit 2024 API
ImportIFCOptions Members
ImportIFCOptions Class Methods Properties See Also Send Feedback

The ImportIFCOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ImportIFCOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetImportIFCOptions | Returns the current Revit instance's ImportIFCOptions.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LinkProcessor | Specifies the engine to use while doing a Link IFC operation.

See Also

ImportIFCOptions Class


ImportIFCOptions Methods

[image] [image]

Revit 2024 API
ImportIFCOptions Methods
ImportIFCOptions Class See Also Send Feedback

The ImportIFCOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetImportIFCOptions | Returns the current Revit instance's ImportIFCOptions.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ImportIFCOptions Class


Dispose Method

[image]

Revit 2024 API
ImportIFCOptions..::..Dispose Method
ImportIFCOptions Class See Also Send Feedback
Releases all resources used by the ImportIFCOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ImportIFCOptions Class


GetImportIFCOptions Method

[image]

Revit 2024 API
ImportIFCOptions..::..GetImportIFCOptions Method
ImportIFCOptions Class See Also Send Feedback
Returns the current Revit instance's ImportIFCOptions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static ImportIFCOptions GetImportIFCOptions()
Visual Basic
Public Shared Function GetImportIFCOptions As ImportIFCOptions
Visual C++
public:
static ImportIFCOptions^ GetImportIFCOptions()

Return Value

The ImportIFCOptions for the current Revit instance.

See Also

ImportIFCOptions Class


ImportIFCOptions Properties

[image] [image]

Revit 2024 API
ImportIFCOptions Properties
ImportIFCOptions Class See Also Send Feedback

The ImportIFCOptions type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LinkProcessor | Specifies the engine to use while doing a Link IFC operation.

See Also

ImportIFCOptions Class


IsValidObject Property

[image]

Revit 2024 API
ImportIFCOptions..::..IsValidObject Property
ImportIFCOptions Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ImportIFCOptions Class


LinkProcessor Property

[image]

Revit 2024 API
ImportIFCOptions..::..LinkProcessor Property
ImportIFCOptions Class See Also Send Feedback
Specifies the engine to use while doing a Link IFC operation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public string LinkProcessor { get; set; }
Visual Basic
Public Property LinkProcessor As String
    Get
    Set
Visual C++
public:
property String^ LinkProcessor {
    String^ get ();
    void set (String^ value);
}

Remarks

This setting allows the user to revert to the legacy Revit link IFC code when linking in IFC files, to preserve old behavior. There are three supported options: Default: let Revit decide the best processor. Legacy: use only the legacy Revit Link IFC processor. AnyCAD: use AnyCAD to help Link IFC files. Any other value (or no entry) will behave as "Default".

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ImportIFCOptions Class


ImportInstance Class

[image]

Revit 2024 API
ImportInstance Class
Members See Also Send Feedback
An element created during either import or link operation. It is an instance of CADLinkType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class ImportInstance : Instance
Visual Basic
Public Class ImportInstance _
    Inherits Instance
Visual C++
public ref class ImportInstance : public Instance

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..Instance
Autodesk.Revit.DB..::..ImportInstance

See Also

ImportInstance Members


ImportInstance Methods

[image] [image]

Revit 2024 API
ImportInstance Methods
ImportInstance Class See Also Send Feedback

The ImportInstance type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create(Document, ElementId, View) | Creates a new instance of an existing DWG link type.
 | Create(Document, View, ExternalResourceReference, DGNImportOptions, LinkLoadResult%) | Creates a new instance of DGN link type from an external resource reference and loads the linked file.
 | Create(Document, View, ExternalResourceReference, DWGImportOptions, LinkLoadResult%) | Creates a new instance of DWG link type from an external resource reference and loads the linked file.
 | Create(Document, View, ExternalResourceReference, ImportOptions3DM, LinkLoadResult%) | Creates a new instance of 3DM link type from an external resource reference and loads the linked file.
 | Create(Document, View, ExternalResourceReference, OBJImportOptions, LinkLoadResult%) | Creates a new instance of OBJ link type from an external resource reference and loads the linked file.
 | Create(Document, View, ExternalResourceReference, SATImportOptions, LinkLoadResult%) | Creates a new instance of SAT link type from an external resource reference and loads the linked file.
 | Create(Document, View, ExternalResourceReference, SKPImportOptions, LinkLoadResult%) | Creates a new instance of SKP link type from an external resource reference and loads the linked file.
 | Create(Document, View, ExternalResourceReference, STLImportOptions, LinkLoadResult%) | Creates a new instance of STL link type from an external resource reference and loads the linked file.
 | Create(Document, View, String, DWGImportOptions, LinkLoadResult%) | Creates a new instance of DWG or DXF link type from a file path and loads the linked file.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetTotalTransform | Gets the total transform, which includes the true north transform for instances like import instances. (Inherited from Instance.)
Public method | GetTransform | Gets the transform of the instance. (Inherited from Instance.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the import instance in a family document.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetVisibility | Sets the visibility for the import instance in a family document.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ImportInstance Class


Create Method (Document, ElementId, View)

[image]

Revit 2024 API
ImportInstance..::..Create Method (Document, ElementId, View)
ImportInstance Class See Also Send Feedback
Creates a new instance of an existing DWG link type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public static ImportInstance Create(
    Document document,
    ElementId typeId,
    View DBView
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    typeId As ElementId, _
    DBView As View _
) As ImportInstance
Visual C++
public:
static ImportInstance^ Create(
    Document^ document,
    ElementId^ typeId,
    View^ DBView
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which to create the new instacne of DWG link type.
typeId
Type: Autodesk.Revit.DB..::..ElementId
The element id of the existing DWG link type.
DBView
Type: Autodesk.Revit.DB..::..View
The view into which the new instance of DWG link type will be created.

Return Value

The new instance of the given DWG link type.

Remarks

This function regenerates the input document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- document is in an edit mode. -or- The view is not printable. -or- The element id is not of a valid CADLinkType.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

ImportInstance Class
Create Overload


Create Method (Document, View, ExternalResourceReference, DGNImportOptions, LinkLoadResult)

Collapse AllExpand All Code: All Code: Multiple Code: C# Code: Visual Basic Code: Visual C++

C#
Visual Basic
Visual C++

Revit 2024 API

ImportInstance..::..Create Method (Document, View, ExternalResourceReference, DGNImportOptions, LinkLoadResult%)

ImportInstance Class See Also Send Feedback

Creates a new instance of DGN link type from an external resource reference and loads the linked file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018
Syntax

C#
public static ImportInstance Create(
    Document document,
    View DBView,
    ExternalResourceReference resourceReference,
    DGNImportOptions options,
    out LinkLoadResult linkLoadResult
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    DBView As View, _
    resourceReference As ExternalResourceReference, _
    options As DGNImportOptions, _
    <OutAttribute> ByRef linkLoadResult As LinkLoadResult _
) As ImportInstance
Visual C++
public:
static ImportInstance^ Create(
    Document^ document,
    View^ DBView,
    ExternalResourceReference^ resourceReference,
    DGNImportOptions^ options,
    [OutAttribute] LinkLoadResult^% linkLoadResult
)
Parameters

document

Type: Autodesk.Revit.DB..::..Document
The document in which to create the DGN link.

DBView

Type: Autodesk.Revit.DB..::..View
The view into which the DGN link will be created.

resourceReference

Type: Autodesk.Revit.DB..::..ExternalResourceReference
The external resource reference describing the source of the DGN link.

options

Type: Autodesk.Revit.DB..::..DGNImportOptions
Various import options applicable to the DGN format. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.

linkLoadResult

Type: Autodesk.Revit.DB..::..LinkLoadResult %
An object containing the results of creating and loading the DGN link. It contains the ElementId of the new created DGN link type.

Return Value
The new instance of DGN link type created.

Remarks

This function creates a new DGN link type as well as a new instance of this DGN link type. The new instance of DGN link type is returned by this function and the element id of the new DGN link type is contained in the LinkLoadResult.

If the given external resource reference of the DWG link is already used by an existing DGN link type, a new instance of this existing DGN link type is created and returned. The element id of the existing DGN link type is contained in the LinkLoadResult.

This function regenerates the input document.

Exceptions

Exception

Condition

Autodesk.Revit.Exceptions..::..ArgumentException

document is not a project document. -or- document is in an edit mode. -or- Import is temporarily disabled. -or- The view is not printable. -or- ThisViewOnly cannot be true when importing a DWG|DGN drawing into a 3D view. -or- One or more strings describing layer selection is invalid or empty. -or- The scale is not valid as a CustomScale for use during import. -or- The server referenced by the ExternalResourceReference does not exist or does not implement IExternalResourceServer. -or- The server referenced by the ExternalResourceReference cannot support CAD links. -or- The ExternalResourceReference (resourceReference) is not in a format that is supported by its server.

Autodesk.Revit.Exceptions..::..ArgumentNullException

A non-optional argument was null

Autodesk.Revit.Exceptions..::..ModificationForbiddenException

The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.

Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException

The document has no open transaction.

Autodesk.Revit.Exceptions..::..OptionalFunctionalityNotAvailableException

The DGN Import/Link module is not available in the installed Revit.

See Also

ImportInstance Class

Create Overload


Create Method (Document, View, ExternalResourceReference, DWGImportOptions, LinkLoadResult)

[image]

Revit 2024 API
ImportInstance..::..Create Method (Document, View, ExternalResourceReference, DWGImportOptions, LinkLoadResult%)
ImportInstance Class See Also Send Feedback
Creates a new instance of DWG link type from an external resource reference and loads the linked file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public static ImportInstance Create(
    Document document,
    View DBView,
    ExternalResourceReference resourceReference,
    DWGImportOptions options,
    out LinkLoadResult linkLoadResult
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    DBView As View, _
    resourceReference As ExternalResourceReference, _
    options As DWGImportOptions, _
    <OutAttribute> ByRef linkLoadResult As LinkLoadResult _
) As ImportInstance
Visual C++
public:
static ImportInstance^ Create(
    Document^ document,
    View^ DBView,
    ExternalResourceReference^ resourceReference,
    DWGImportOptions^ options,
    [OutAttribute] LinkLoadResult^% linkLoadResult
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which to create the DWG link.
DBView
Type: Autodesk.Revit.DB..::..View
The view into which the DWG link will be created.
resourceReference
Type: Autodesk.Revit.DB..::..ExternalResourceReference
The external resource reference describing the source of the DWG link.
options
Type: Autodesk.Revit.DB..::..DWGImportOptions
Various import options applicable to the DWG format. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.
linkLoadResult
Type: Autodesk.Revit.DB..::..LinkLoadResult %
An object containing the results of creating and loading the DWG link. It contains the ElementId of the new created DWG link type.

Return Value

The new instance of DWG link type created.

Remarks

This function creates a new DWG link type as well as a new instance of this DWG link type. The new instance of DWG link type is returned by this function and the element id of the new DWG link type is contained in the LinkLoadResult.

If the given external resource reference of the DWG link is already used by an existing DWG link type, a new instance of this existing DWG link type is created and returned. The element id of the existing DWG link type is contained in the LinkLoadResult.

This function regenerates the input document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- document is in an edit mode. -or- Import is temporarily disabled. -or- The view is not printable. -or- ThisViewOnly cannot be true when importing a DWG|DGN drawing into a 3D view. -or- One or more strings describing layer selection is invalid or empty. -or- The line weights are not valid; either it contains an invalid number of line weights, or a line weight outside the valid range. -or- The scale is not valid as a CustomScale for use during import. -or- The server referenced by the ExternalResourceReference does not exist or does not implement IExternalResourceServer. -or- The server referenced by the ExternalResourceReference cannot support CAD links. -or- The ExternalResourceReference (resourceReference) is not in a format that is supported by its server.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.
Autodesk.Revit.Exceptions..::..OptionalFunctionalityNotAvailableException | The DWG Import/Link module is not available in the installed Revit.

See Also

ImportInstance Class
Create Overload


Create Method (Document, View, ExternalResourceReference, ImportOptions3DM, LinkLoadResult)

[image]

Revit 2024 API
ImportInstance..::..Create Method (Document, View, ExternalResourceReference, ImportOptions3DM, LinkLoadResult%)
ImportInstance Class See Also Send Feedback
Creates a new instance of 3DM link type from an external resource reference and loads the linked file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public static ImportInstance Create(
    Document document,
    View DBView,
    ExternalResourceReference resourceReference,
    ImportOptions3DM options,
    out LinkLoadResult linkLoadResult
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    DBView As View, _
    resourceReference As ExternalResourceReference, _
    options As ImportOptions3DM, _
    <OutAttribute> ByRef linkLoadResult As LinkLoadResult _
) As ImportInstance
Visual C++
public:
static ImportInstance^ Create(
    Document^ document,
    View^ DBView,
    ExternalResourceReference^ resourceReference,
    ImportOptions3DM^ options,
    [OutAttribute] LinkLoadResult^% linkLoadResult
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which to create the 3DM link.
DBView
Type: Autodesk.Revit.DB..::..View
The view into which the 3DM link will be created.
resourceReference
Type: Autodesk.Revit.DB..::..ExternalResourceReference
The external resource reference describing the source of the 3DM link.
options
Type: Autodesk.Revit.DB..::..ImportOptions3DM
Various import options applicable to the 3DM format. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.
linkLoadResult
Type: Autodesk.Revit.DB..::..LinkLoadResult %
An object containing the results of creating and loading the 3DM link. It contains the ElementId of the new created 3DM link type.

Return Value

The new instance of 3DM link type created.

Remarks

This function creates a new 3DM link type as well as a new instance of this 3DM link type. The new instance of 3DM link type is returned by this function and the element id of the new 3DM link type is contained in the LinkLoadResult.

If the given external resource reference of the 3DM link is already used by an existing 3DM link type, a new instance of this existing 3DM link type is created and returned. The element id of the existing 3DM link type is contained in the LinkLoadResult.

This function regenerates the input document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- document is in an edit mode. -or- Import is temporarily disabled. -or- The view is not printable. -or- ThisViewOnly cannot be true when importing a DWG|DGN drawing into a 3D view. -or- One or more strings describing layer selection is invalid or empty. -or- The scale is not valid as a CustomScale for use during import. -or- The server referenced by the ExternalResourceReference does not exist or does not implement IExternalResourceServer. -or- The server referenced by the ExternalResourceReference cannot support CAD links. -or- The ExternalResourceReference (resourceReference) is not in a format that is supported by its server.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.
Autodesk.Revit.Exceptions..::..OptionalFunctionalityNotAvailableException | The 3DM Import/Link module is not available in the installed Revit.

See Also

ImportInstance Class
Create Overload


Create Method (Document, View, ExternalResourceReference, OBJImportOptions, LinkLoadResult)

[image]

Revit 2024 API
ImportInstance..::..Create Method (Document, View, ExternalResourceReference, OBJImportOptions, LinkLoadResult%)
ImportInstance Class See Also Send Feedback
Creates a new instance of OBJ link type from an external resource reference and loads the linked file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public static ImportInstance Create(
    Document document,
    View DBView,
    ExternalResourceReference resourceReference,
    OBJImportOptions options,
    out LinkLoadResult linkLoadResult
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    DBView As View, _
    resourceReference As ExternalResourceReference, _
    options As OBJImportOptions, _
    <OutAttribute> ByRef linkLoadResult As LinkLoadResult _
) As ImportInstance
Visual C++
public:
static ImportInstance^ Create(
    Document^ document,
    View^ DBView,
    ExternalResourceReference^ resourceReference,
    OBJImportOptions^ options,
    [OutAttribute] LinkLoadResult^% linkLoadResult
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which to create the OBJ link.
DBView
Type: Autodesk.Revit.DB..::..View
The view into which the OBJ link will be created.
resourceReference
Type: Autodesk.Revit.DB..::..ExternalResourceReference
The external resource reference describing the source of the OBJ link.
options
Type: Autodesk.Revit.DB..::..OBJImportOptions
Various import options applicable to the OBJ format. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.
linkLoadResult
Type: Autodesk.Revit.DB..::..LinkLoadResult %
An object containing the results of creating and loading the OBJ link. It contains the ElementId of the new created OBJ link type.

Return Value

The new instance of OBJ link type created.

Remarks

This function creates a new OBJ link type as well as a new instance of this OBJ link type. The new instance of OBJ link type is returned by this function and the element id of the new OBJ link type is contained in the LinkLoadResult.

If the given external resource reference of the OBJ link is already used by an existing OBJ link type, a new instance of this existing OBJ link type is created and returned. The element id of the existing OBJ link type is contained in the LinkLoadResult.

This function regenerates the input document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- document is in an edit mode. -or- Import is temporarily disabled. -or- The view is not printable. -or- ThisViewOnly cannot be true when importing a DWG|DGN drawing into a 3D view. -or- One or more strings describing layer selection is invalid or empty. -or- The scale is not valid as a CustomScale for use during import. -or- The server referenced by the ExternalResourceReference does not exist or does not implement IExternalResourceServer. -or- The server referenced by the ExternalResourceReference cannot support CAD links. -or- The ExternalResourceReference (resourceReference) is not in a format that is supported by its server.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.
Autodesk.Revit.Exceptions..::..OptionalFunctionalityNotAvailableException | The OBJ Import/Link module is not available in the installed Revit.

See Also

ImportInstance Class
Create Overload


Create Method (Document, View, ExternalResourceReference, SATImportOptions, LinkLoadResult)

[image]

Revit 2024 API
ImportInstance..::..Create Method (Document, View, ExternalResourceReference, SATImportOptions, LinkLoadResult%)
ImportInstance Class See Also Send Feedback
Creates a new instance of SAT link type from an external resource reference and loads the linked file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public static ImportInstance Create(
    Document document,
    View DBView,
    ExternalResourceReference resourceReference,
    SATImportOptions options,
    out LinkLoadResult linkLoadResult
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    DBView As View, _
    resourceReference As ExternalResourceReference, _
    options As SATImportOptions, _
    <OutAttribute> ByRef linkLoadResult As LinkLoadResult _
) As ImportInstance
Visual C++
public:
static ImportInstance^ Create(
    Document^ document,
    View^ DBView,
    ExternalResourceReference^ resourceReference,
    SATImportOptions^ options,
    [OutAttribute] LinkLoadResult^% linkLoadResult
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which to create the SAT link.
DBView
Type: Autodesk.Revit.DB..::..View
The view into which the SAT link will be created.
resourceReference
Type: Autodesk.Revit.DB..::..ExternalResourceReference
The external resource reference describing the source of the DGN link.
options
Type: Autodesk.Revit.DB..::..SATImportOptions
Various import options applicable to the SAT format. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.
linkLoadResult
Type: Autodesk.Revit.DB..::..LinkLoadResult %
An object containing the results of creating and loading the SAT link. It contains the ElementId of the new created SAT link type.

Return Value

The new instance of SAT link type created.

Remarks

This function creates a new SAT link type as well as a new instance of this SAT link type. The new instance of SAT link type is returned by this function and the element id of the new SAT link type is contained in the LinkLoadResult.

If the given external resource reference of the DWG link is already used by an existing SAT link type, a new instance of this existing SAT link type is created and returned. The element id of the existing SAT link type is contained in the LinkLoadResult.

This function regenerates the input document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- document is in an edit mode. -or- Import is temporarily disabled. -or- The view is not printable. -or- ThisViewOnly cannot be true when importing a DWG|DGN drawing into a 3D view. -or- One or more strings describing layer selection is invalid or empty. -or- The scale is not valid as a CustomScale for use during import. -or- The server referenced by the ExternalResourceReference does not exist or does not implement IExternalResourceServer. -or- The server referenced by the ExternalResourceReference cannot support CAD links. -or- The ExternalResourceReference (resourceReference) is not in a format that is supported by its server.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.
Autodesk.Revit.Exceptions..::..OptionalFunctionalityNotAvailableException | The SAT Import/Link module is not available in the installed Revit.

See Also

ImportInstance Class
Create Overload


Create Method (Document, View, ExternalResourceReference, SKPImportOptions, LinkLoadResult)

[image]

Revit 2024 API
ImportInstance..::..Create Method (Document, View, ExternalResourceReference, SKPImportOptions, LinkLoadResult%)
ImportInstance Class See Also Send Feedback
Creates a new instance of SKP link type from an external resource reference and loads the linked file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public static ImportInstance Create(
    Document document,
    View DBView,
    ExternalResourceReference resourceReference,
    SKPImportOptions options,
    out LinkLoadResult linkLoadResult
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    DBView As View, _
    resourceReference As ExternalResourceReference, _
    options As SKPImportOptions, _
    <OutAttribute> ByRef linkLoadResult As LinkLoadResult _
) As ImportInstance
Visual C++
public:
static ImportInstance^ Create(
    Document^ document,
    View^ DBView,
    ExternalResourceReference^ resourceReference,
    SKPImportOptions^ options,
    [OutAttribute] LinkLoadResult^% linkLoadResult
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which to create the SKP link.
DBView
Type: Autodesk.Revit.DB..::..View
The view into which the SKP link will be created.
resourceReference
Type: Autodesk.Revit.DB..::..ExternalResourceReference
The external resource reference describing the source of the SKP link.
options
Type: Autodesk.Revit.DB..::..SKPImportOptions
Various import options applicable to the SKP format. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.
linkLoadResult
Type: Autodesk.Revit.DB..::..LinkLoadResult %
An object containing the results of creating and loading the SKP link. It contains the ElementId of the new created SKP link type.

Return Value

The new instance of SKP link type created.

Remarks

This function creates a new SKP link type as well as a new instance of this SKP link type. The new instance of SKP link type is returned by this function and the element id of the new SKP link type is contained in the LinkLoadResult.

If the given external resource reference of the SKP link is already used by an existing SKP link type, a new instance of this existing SKP link type is created and returned. The element id of the existing SKP link type is contained in the LinkLoadResult.

This function regenerates the input document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- document is in an edit mode. -or- Import is temporarily disabled. -or- The view is not printable. -or- ThisViewOnly cannot be true when importing a DWG|DGN drawing into a 3D view. -or- One or more strings describing layer selection is invalid or empty. -or- The scale is not valid as a CustomScale for use during import. -or- The server referenced by the ExternalResourceReference does not exist or does not implement IExternalResourceServer. -or- The server referenced by the ExternalResourceReference cannot support CAD links. -or- The ExternalResourceReference (resourceReference) is not in a format that is supported by its server.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.
Autodesk.Revit.Exceptions..::..OptionalFunctionalityNotAvailableException | The SKP Import/Link module is not available in the installed Revit.

See Also

ImportInstance Class
Create Overload


GetVisibility Method

[image]

Revit 2024 API
ImportInstance..::..GetVisibility Method
ImportInstance Class See Also Send Feedback
Gets the visibility for the import instance in a family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyElementVisibility GetVisibility()
Visual Basic
Public Function GetVisibility As FamilyElementVisibility
Visual C++
public:
FamilyElementVisibility^ GetVisibility()

Return Value

A copy of visibility settings for the import instance in a family document.

See Also

ImportInstance Class


SetVisibility Method

[image]

Revit 2024 API
ImportInstance..::..SetVisibility Method
ImportInstance Class See Also Send Feedback
Sets the visibility for the import instance in a family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetVisibility(
    FamilyElementVisibility visibility
)
Visual Basic
Public Sub SetVisibility ( _
    visibility As FamilyElementVisibility _
)
Visual C++
public:
void SetVisibility(
    FamilyElementVisibility^ visibility
)

Parameters

visibility
Type: Autodesk.Revit.DB..::..FamilyElementVisibility

Remarks

The visibility of the import instance geometry can be changed for different types of views and detail levels in the family document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when visibility is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when regeneration failed, or the import instance is in a project document.

See Also

ImportInstance Class


ImportInstance Properties

[image] [image]

Revit 2024 API
ImportInstance Properties
ImportInstance Class See Also Send Feedback

The ImportInstance type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsLinked | Identifies whether this instance is a linked object rather than imported one.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ImportInstance Class


IsLinked Property

[image]

Revit 2024 API
ImportInstance..::..IsLinked Property
ImportInstance Class See Also Send Feedback
Identifies whether this instance is a linked object rather than imported one.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool IsLinked { get; }
Visual Basic
Public ReadOnly Property IsLinked As Boolean
    Get
Visual C++
public:
property bool IsLinked {
    bool get ();
}

Remarks

True if the instance was imported as a link to an external file. False if the instance was imported as a copy of data from an external file.

See Also

ImportInstance Class


Parameter Property

[image] [image]

Revit 2024 API
ImportInstance..::..Parameter Property
ImportInstance Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ImportInstance Class
ImportInstance Members


ImportOptions3DM Class

[image]

Revit 2024 API
ImportOptions3DM Class
Members See Also Send Feedback
The import options used to import 3DM format files.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public class ImportOptions3DM : BaseImportOptions
Visual Basic
Public Class ImportOptions3DM _
    Inherits BaseImportOptions
Visual C++
public ref class ImportOptions3DM : public BaseImportOptions

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BaseImportOptions
Autodesk.Revit.DB..::..ImportOptions3DM

See Also

ImportOptions3DM Members


ImportOptions3DM Members

[image] [image]

Revit 2024 API
ImportOptions3DM Members
ImportOptions3DM Class Constructors Methods Properties See Also Send Feedback

The ImportOptions3DM type exposes the following members.

Constructors

 | Name | Description
Public method | ImportOptions3DM()()()() | Constructs a new instance of ImportOptions3DM with default values of all properties.
Public method | ImportOptions3DM(ImportOptions3DM) | Constructs a new instance of ImportOptions3DM as a copy of the provided import options.

Methods

 | Name | Description
Public method | Dispose | (Inherited from BaseImportOptions.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDefaultLengthUnit | Get the default length unit used for importing unitless files. (Inherited from BaseImportOptions.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLayerSelection | Get all set layers name which user want to import into Revit. (Inherited from BaseImportOptions.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultLengthUnit | Set the default length unit used for importing unitless files. (Inherited from BaseImportOptions.)
Public method | SetLayerSelection | Set the layers name which user want to import into Revit. (Inherited from BaseImportOptions.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AutoCorrectAlmostVHLines | Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines. (Inherited from BaseImportOptions.)
Public property | ColorMode | Color mode for the import. Three modes are supported. Black and White, Preserve Colors, and Invert Colors. (Inherited from BaseImportOptions.)
Public property | CustomScale | Scaling the import. If this is defined and a valid value (> 0.0), it takes priority over units. (Inherited from BaseImportOptions.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BaseImportOptions.)
Public property | OrientToView | Place the import at the same orientation as the view that was passed into the import method. This option can only be used when not importing into a single view.(i.e. ThisViewOnly is set to false) (Inherited from BaseImportOptions.)
Public property | Placement | Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates. (Inherited from BaseImportOptions.)
Public property | ReferencePoint | The 3D point in the document where the imported instance will be inserted. If not explicitly set, the instance will be inserted at the document origin. (Inherited from BaseImportOptions.)
Public property | ThisViewOnly | Imports drawings into the view that was passed into the import method. This option is not available in 3D views. (Inherited from BaseImportOptions.)
Public property | Unit | The unit of measure for imported geometry. (Inherited from BaseImportOptions.)
Public property | VisibleLayersOnly | Only import the visible layers. (Inherited from BaseImportOptions.)

See Also

ImportOptions3DM Class


ImportOptions3DM Constructor

[image] [image]

Revit 2024 API
ImportOptions3DM Constructor
ImportOptions3DM Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ImportOptions3DM()()()() | Constructs a new instance of ImportOptions3DM with default values of all properties.
Public method | ImportOptions3DM(ImportOptions3DM) | Constructs a new instance of ImportOptions3DM as a copy of the provided import options.

See Also

ImportOptions3DM Class
ImportOptions3DM Members


ImportOptions3DM Constructor

[image]

Revit 2024 API
ImportOptions3DM Constructor
ImportOptions3DM Class See Also Send Feedback
Constructs a new instance of ImportOptions3DM with default values of all properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public ImportOptions3DM()
Visual Basic
Public Sub New
Visual C++
public:
ImportOptions3DM()

See Also

ImportOptions3DM Class
ImportOptions3DM Overload


ImportOptions3DM Constructor (ImportOptions3DM)

[image]

Revit 2024 API
ImportOptions3DM Constructor (ImportOptions3DM)
ImportOptions3DM Class See Also Send Feedback
Constructs a new instance of ImportOptions3DM as a copy of the provided import options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public ImportOptions3DM(
    ImportOptions3DM option
)
Visual Basic
Public Sub New ( _
    option As ImportOptions3DM _
)
Visual C++
public:
ImportOptions3DM(
    ImportOptions3DM^ option
)

Parameters

option
Type: Autodesk.Revit.DB..::..ImportOptions3DM
The 3DM import options to be copied.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ImportOptions3DM Class
ImportOptions3DM Overload


ImportOptions3DM Methods

[image] [image]

Revit 2024 API
ImportOptions3DM Methods
ImportOptions3DM Class See Also Send Feedback

The ImportOptions3DM type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from BaseImportOptions.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDefaultLengthUnit | Get the default length unit used for importing unitless files. (Inherited from BaseImportOptions.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLayerSelection | Get all set layers name which user want to import into Revit. (Inherited from BaseImportOptions.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultLengthUnit | Set the default length unit used for importing unitless files. (Inherited from BaseImportOptions.)
Public method | SetLayerSelection | Set the layers name which user want to import into Revit. (Inherited from BaseImportOptions.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ImportOptions3DM Class


ImportOptions3DM Properties

[image] [image]

Revit 2024 API
ImportOptions3DM Properties
ImportOptions3DM Class See Also Send Feedback

The ImportOptions3DM type exposes the following members.

Properties

 | Name | Description
Public property | AutoCorrectAlmostVHLines | Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines. (Inherited from BaseImportOptions.)
Public property | ColorMode | Color mode for the import. Three modes are supported. Black and White, Preserve Colors, and Invert Colors. (Inherited from BaseImportOptions.)
Public property | CustomScale | Scaling the import. If this is defined and a valid value (> 0.0), it takes priority over units. (Inherited from BaseImportOptions.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BaseImportOptions.)
Public property | OrientToView | Place the import at the same orientation as the view that was passed into the import method. This option can only be used when not importing into a single view.(i.e. ThisViewOnly is set to false) (Inherited from BaseImportOptions.)
Public property | Placement | Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates. (Inherited from BaseImportOptions.)
Public property | ReferencePoint | The 3D point in the document where the imported instance will be inserted. If not explicitly set, the instance will be inserted at the document origin. (Inherited from BaseImportOptions.)
Public property | ThisViewOnly | Imports drawings into the view that was passed into the import method. This option is not available in 3D views. (Inherited from BaseImportOptions.)
Public property | Unit | The unit of measure for imported geometry. (Inherited from BaseImportOptions.)
Public property | VisibleLayersOnly | Only import the visible layers. (Inherited from BaseImportOptions.)

See Also

ImportOptions3DM Class


ImportPlacement Enumeration

[image]

Revit 2024 API
ImportPlacement Enumeration
See Also Send Feedback
An enumerated type listing possible placement modes for imported drawings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Since: 2013

Syntax

C#
public enum ImportPlacement
Visual Basic
Public Enumeration ImportPlacement
Visual C++
public enum class ImportPlacement

Members

Member name | Description
Site | Placement at Base Point. Useful for Revit links only. There must be a reference point in order for this option to be valid.
Origin | Placement at the Origin. If reference point is provided, then the import is placed so the point is at the model's origin. If no point is provided, then the document's origin is matched with the model's origin.
Centered | Placement at the Center. If reference point is provided, then the import is placed so the point is at the model's center. If no point is provided, then the document's center is matched with the model's origin.
Shared | Placement with respect to the shared coordinates. Revit Building places the imported geometry according to its location with respect to the shared coordinates between the two files. There must be shared coordinates in a Revit document in order for this option to be valid.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


ImportUnit Enumeration

[image]

Revit 2024 API
ImportUnit Enumeration
See Also Send Feedback
An enumerated type listing possible target units for CAD Import.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Since: 2013

Syntax

C#
public enum ImportUnit
Visual Basic
Public Enumeration ImportUnit
Visual C++
public enum class ImportUnit

Members

Member name | Description
Default | Unit (if available) from the document that is getting imported.
Foot | Feet and Inches in fractional notation.
Inch | Inches in fractional notation.
Meter | Meters as decimal values.
Decimeter | Decimeters as decimal values.
Centimeter | Centimeters as decimal values.
Millimeter | Millimeters as decimal values.
Custom | Custom values as decimal values
USSurveyFoot | US survey feet as decimal values

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


INavisworksExporter Interface

[image]

Revit 2024 API
INavisworksExporter Interface
Members See Also Send Feedback
The interface used to implement a Navisworks exporter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public interface INavisworksExporter : IExternalServer
Visual Basic
Public Interface INavisworksExporter _
    Inherits IExternalServer
Visual C++
public interface class INavisworksExporter : IExternalServer

Remarks

Implement this interface and register an instance of the derived class with the Navisworks external service.

See Also

INavisworksExporter Members


INavisworksExporter Members

[image] [image]

Revit 2024 API
INavisworksExporter Members
INavisworksExporter Interface Methods See Also Send Feedback

The INavisworksExporter type exposes the following members.

Methods

 | Name | Description
Public method | Export | The method that Revit will invoke to perform an export to Navisworks.
Public method | GetDescription | Implement this method to return a description of the server. (Inherited from IExternalServer.)
Public method | GetName | Implement this method to return the name of the server. (Inherited from IExternalServer.)
Public method | GetServerId | Implement this method to return the id of the server. (Inherited from IExternalServer.)
Public method | GetServiceId | Implement this method to return the id of the service. (Inherited from IExternalServer.)
Public method | GetVendorId | Implement this method to return the id of the vendor of the server. (Inherited from IExternalServer.)
Public method | ValidateExportOptions | Determines if the inputs are valid, and returns an error message if not.

See Also

INavisworksExporter Interface


Export Method

[image]

Revit 2024 API
INavisworksExporter..::..Export Method
INavisworksExporter Interface See Also Send Feedback
The method that Revit will invoke to perform an export to Navisworks.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
void Export(
    Document document,
    string folder,
    string name,
    NavisworksExportOptions options
)
Visual Basic
Sub Export ( _
    document As Document, _
    folder As String, _
    name As String, _
    options As NavisworksExportOptions _
)
Visual C++
void Export(
    Document^ document,
    String^ folder,
    String^ name,
    NavisworksExportOptions^ options
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to export.
folder
Type: System..::..String
The folder path.
name
Type: System..::..String
The file name.
options
Type: Autodesk.Revit.DB..::..NavisworksExportOptions
The export options.

See Also

INavisworksExporter Interface


ValidateExportOptions Method

[image]

Revit 2024 API
INavisworksExporter..::..ValidateExportOptions Method
INavisworksExporter Interface See Also Send Feedback
Determines if the inputs are valid, and returns an error message if not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
bool ValidateExportOptions(
    Document document,
    string folder,
    string name,
    NavisworksExportOptions options,
    out string exceptionMessage
)
Visual Basic
Function ValidateExportOptions ( _
    document As Document, _
    folder As String, _
    name As String, _
    options As NavisworksExportOptions, _
    <OutAttribute> ByRef exceptionMessage As String _
) As Boolean
Visual C++
bool ValidateExportOptions(
    Document^ document,
    String^ folder,
    String^ name,
    NavisworksExportOptions^ options,
    [OutAttribute] String^% exceptionMessage
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to export.
folder
Type: System..::..String
The folder path.
name
Type: System..::..String
The file name.
options
Type: Autodesk.Revit.DB..::..NavisworksExportOptions
The export options.
exceptionMessage
Type: System..::..String%
The message to show in the exception thrown. This is not an end-user visible message, it is a developer message, and does not have to be localized. Ignored if the function returns true.

Return Value

True if the options are valid, false otherwise.

See Also

INavisworksExporter Interface


InCanvasControlData Class

[image]

Revit 2024 API
InCanvasControlData Class
Members See Also Send Feedback
Represents a collection of data which is used by TemporaryGraphicsManager to create and update an in-canvas control.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public class InCanvasControlData : IDisposable
Visual Basic
Public Class InCanvasControlData _
    Implements IDisposable
Visual C++
public ref class InCanvasControlData : IDisposable

Remarks

So far, only bitmap file is supported for ImagePath. The rendered image is the same size in pixel dimensions as the original one. To get a better result, the caller should prepare the image with proper size, for exmaple: 32x32 or 64x64 in pixels, before use. To achive a "transparent" backgound color effect over the provided bitmap, the bitmap should use color RGB(0, 128, 128) as its background and it will be cleared during rendering by Revit.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..InCanvasControlData

See Also

InCanvasControlData Members


InCanvasControlData Members

[image] [image]

Revit 2024 API
InCanvasControlData Members
InCanvasControlData Class Constructors Methods Properties See Also Send Feedback

The InCanvasControlData type exposes the following members.

Constructors

 | Name | Description
Public method | InCanvasControlData(String) | Constructs an InCanvasControlData with specific values assigned.
Public method | InCanvasControlData(String, XYZ) | Constructs an InCanvasControlData with specific values assigned.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the InCanvasControlData
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ImagePath | The path to the image file to be used. This must be an absolute path to a location on disk.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Position | The position of the in-canvas control in model coordinates.

See Also

InCanvasControlData Class


InCanvasControlData Constructor

[image] [image]

Revit 2024 API
InCanvasControlData Constructor
InCanvasControlData Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InCanvasControlData(String) | Constructs an InCanvasControlData with specific values assigned.
Public method | InCanvasControlData(String, XYZ) | Constructs an InCanvasControlData with specific values assigned.

See Also

InCanvasControlData Class
InCanvasControlData Members


InCanvasControlData Constructor (String)

[image]

Revit 2024 API
InCanvasControlData Constructor (String)
InCanvasControlData Class See Also Send Feedback
Constructs an InCanvasControlData with specific values assigned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public InCanvasControlData(
    string imagePath
)
Visual Basic
Public Sub New ( _
    imagePath As String _
)
Visual C++
public:
InCanvasControlData(
    String^ imagePath
)

Parameters

imagePath
Type: System..::..String
File path with the image to be used. This must be an absolute path to a location on disk.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The file format specified by imagePath is an unsupported format - only *.bmp files are supported. -or- The file path specified by imagePath is not absolute.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | The file specified by imagePath doesn't exist.

See Also

InCanvasControlData Class
InCanvasControlData Overload


InCanvasControlData Methods

[image] [image]

Revit 2024 API
InCanvasControlData Methods
InCanvasControlData Class See Also Send Feedback

The InCanvasControlData type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

InCanvasControlData Class


Dispose Method

[image]

Revit 2024 API
InCanvasControlData..::..Dispose Method
InCanvasControlData Class See Also Send Feedback
Releases all resources used by the InCanvasControlData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

InCanvasControlData Class


InCanvasControlData Properties

[image] [image]

Revit 2024 API
InCanvasControlData Properties
InCanvasControlData Class See Also Send Feedback

The InCanvasControlData type exposes the following members.

Properties

 | Name | Description
Public property | ImagePath | The path to the image file to be used. This must be an absolute path to a location on disk.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Position | The position of the in-canvas control in model coordinates.

See Also

InCanvasControlData Class


ImagePath Property

[image]

Revit 2024 API
InCanvasControlData..::..ImagePath Property
InCanvasControlData Class See Also Send Feedback
The path to the image file to be used. This must be an absolute path to a location on disk.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public string ImagePath { get; set; }
Visual Basic
Public Property ImagePath As String
    Get
    Set
Visual C++
public:
property String^ ImagePath {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The file format specified by imagePath is an unsupported format - only *.bmp files are supported. -or- When setting this property: The file path specified by imagePath is not absolute.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | When setting this property: The file specified by imagePath doesn't exist.

See Also

InCanvasControlData Class


IsValidObject Property

[image]

Revit 2024 API
InCanvasControlData..::..IsValidObject Property
InCanvasControlData Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

InCanvasControlData Class


Position Property

[image]

Revit 2024 API
InCanvasControlData..::..Position Property
InCanvasControlData Class See Also Send Feedback
The position of the in-canvas control in model coordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public XYZ Position { get; set; }
Visual Basic
Public Property Position As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ Position {
    XYZ^ get ();
    void set (XYZ^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

InCanvasControlData Class


IndependentTag Members

[image] [image]

Revit 2024 API
IndependentTag Members
IndependentTag Class Methods Properties See Also Send Feedback

The IndependentTag type exposes the following members.

Methods

 | Name | Description
Public method | AddReferences | Adds the provided list of references to the tag's list of references.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanLeaderEndConditionBeAssigned | Checks whether the LeaderEndCondition can be changed.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create(Document, ElementId, ElementId, Reference, Boolean, TagOrientation, XYZ) | Places a tag on an element or subelement.
 | Create(Document, ElementId, Reference, Boolean, TagMode, TagOrientation, XYZ) | Places a tag on an element or subelement.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLeaderElbow | Returns the position of the elbow of the tag's leader that points to specified reference. Position of leader's elbow.
Public method | GetLeaderEnd | Returns the end position of the tag's leader that points to specified reference.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetTaggedElementIds | Returns a set of LinkElementId for all tagged elements, if any. A LinkElementId will be provided for each subelement that is being referenced by the tag.
Public method | GetTaggedLocalElementIds | Returns a set of IDs for all tagged local elements, if any. A local element ID will be provided for each subelement that is being referenced by the tag. Set of all the element ids in the local file. For each subelement a local element id will be provided.
Public method | GetTaggedLocalElements | Get the tagged local elements, if any. An Element will be provided for each subelement that is being referenced by the tag.
Public method | GetTaggedReferences | Get the host references of the tag. An array of all the tagged references.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasLeaderElbow | Whether the tag's leader that points to the reference has an elbow point or not.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasTagBehavior | Checks if the IndependentTag has a tag behavior.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsLeaderVisible | Returns if leader that points to specified reference is visible or not.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsTaggedOnSubelement | Returns true if the any of the tagged references is a subelement.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | RemoveReferences | Removes the provided list of references from the tag's list of references.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetIsLeaderVisible | Set tag's leader that points to specified reference to be visible or not. This option can be set only if the LeadersPresentationMode is ShowSpecificLeaders.
Public method | SetLeaderElbow | Set the position of the elbow of the tag's leader that points to specified reference. If this tag is a multileader tag and the elbows are merged, the input position will be set to all leaders.
Public method | SetLeaderEnd | Set the end position of the tag's leader that points to specified reference.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | HasLeader | Identifies if a tag has at least one visible leader, or if all leaders are hidden.
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsMaterialTag | Identifies if it is a material tag or not.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsMulticategoryTag | Identifies if it is a multi-category tag or not.
Public property | IsOrphaned | Identifies if the tag is orphaned or not.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LeaderEndCondition | The leader end condition of the tag, such as if the end of the leader is attached to the host or free floating.
Public property | LeadersPresentationMode | Identifies the Presentation Mode that is applied to tag leaders.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MergeElbows | Identifies if the leaders' elbows are merged or not. If they are are merged, all elbows are in the same point and they move together.
Public property | MultiLeader | Returns if the tag if referencing multiple elements and/or sub-elements.
Public property | MultiReferenceAnnotationId | The multi-reference annotation which owns this tag.
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RotationAngle | The rotation angle of the tag relative to its view
Public property | TagHeadPosition | The position of the head of tag in model coordinates.
Public property | TagOrientation | The tag orientation of the tag's head, such as horizontal or vertical.
Public property | TagText | The text associated with the tag. If there are several strings assiciated with the tag, the strings will be returned concatenated.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

IndependentTag Class


IndependentTag Methods

[image] [image]

Revit 2024 API
IndependentTag Methods
IndependentTag Class See Also Send Feedback

The IndependentTag type exposes the following members.

Methods

 | Name | Description
Public method | AddReferences | Adds the provided list of references to the tag's list of references.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanLeaderEndConditionBeAssigned | Checks whether the LeaderEndCondition can be changed.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create(Document, ElementId, ElementId, Reference, Boolean, TagOrientation, XYZ) | Places a tag on an element or subelement.
 | Create(Document, ElementId, Reference, Boolean, TagMode, TagOrientation, XYZ) | Places a tag on an element or subelement.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLeaderElbow | Returns the position of the elbow of the tag's leader that points to specified reference. Position of leader's elbow.
Public method | GetLeaderEnd | Returns the end position of the tag's leader that points to specified reference.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetTaggedElementIds | Returns a set of LinkElementId for all tagged elements, if any. A LinkElementId will be provided for each subelement that is being referenced by the tag.
Public method | GetTaggedLocalElementIds | Returns a set of IDs for all tagged local elements, if any. A local element ID will be provided for each subelement that is being referenced by the tag. Set of all the element ids in the local file. For each subelement a local element id will be provided.
Public method | GetTaggedLocalElements | Get the tagged local elements, if any. An Element will be provided for each subelement that is being referenced by the tag.
Public method | GetTaggedReferences | Get the host references of the tag. An array of all the tagged references.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasLeaderElbow | Whether the tag's leader that points to the reference has an elbow point or not.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasTagBehavior | Checks if the IndependentTag has a tag behavior.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsLeaderVisible | Returns if leader that points to specified reference is visible or not.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsTaggedOnSubelement | Returns true if the any of the tagged references is a subelement.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | RemoveReferences | Removes the provided list of references from the tag's list of references.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetIsLeaderVisible | Set tag's leader that points to specified reference to be visible or not. This option can be set only if the LeadersPresentationMode is ShowSpecificLeaders.
Public method | SetLeaderElbow | Set the position of the elbow of the tag's leader that points to specified reference. If this tag is a multileader tag and the elbows are merged, the input position will be set to all leaders.
Public method | SetLeaderEnd | Set the end position of the tag's leader that points to specified reference.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

IndependentTag Class


AddReferences Method

[image]

Revit 2024 API
IndependentTag..::..AddReferences Method
IndependentTag Class See Also Send Feedback
Adds the provided list of references to the tag's list of references.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public void AddReferences(
    IList<Reference> referencesToTag
)
Visual Basic
Public Sub AddReferences ( _
    referencesToTag As IList(Of Reference) _
)
Visual C++
public:
void AddReferences(
    IList<Reference^>^ referencesToTag
)

Parameters

referencesToTag
Type: System.Collections.Generic..::..IList<(Of <(<' Reference >)>)>
References to be tagged.

Remarks

The references must pass the following requirements to be added:

  • Must not be already tagged.
  • Must be of the same category when TagMode is TM_ADDBY_CATEGORY.
  • Must be taggable by this tag type.
If any of the above rules is not fulfilled, the execution will be stopped and an exception will be thrown

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The operation failed. Please verify that the references are all taggable and that they are not already tagged.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The IndependentTag object does not have a tag behavior. -or- This type of tag does not support multiple references.

See Also

IndependentTag Class


CanLeaderEndConditionBeAssigned Method

[image]

Revit 2024 API
IndependentTag..::..CanLeaderEndConditionBeAssigned Method
IndependentTag Class See Also Send Feedback
Checks whether the LeaderEndCondition can be changed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool CanLeaderEndConditionBeAssigned(
    LeaderEndCondition leaderEndCondition
)
Visual Basic
Public Function CanLeaderEndConditionBeAssigned ( _
    leaderEndCondition As LeaderEndCondition _
) As Boolean
Visual C++
public:
bool CanLeaderEndConditionBeAssigned(
    LeaderEndCondition leaderEndCondition
)

Parameters

leaderEndCondition
Type: Autodesk.Revit.DB..::..LeaderEndCondition
The leader end condition to check.

Return Value

True if the leader end condition of the tag can be assigned, or false otherwise.

Remarks

Material tags and material keynotes can only use the free end condition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

IndependentTag Class


Create Method

[image] [image]

Revit 2024 API
IndependentTag..::..Create Method
IndependentTag Class See Also Send Feedback

Overload List

Name | Description
Create(Document, ElementId, ElementId, Reference, Boolean, TagOrientation, XYZ) | Places a tag on an element or subelement.
Create(Document, ElementId, Reference, Boolean, TagMode, TagOrientation, XYZ) | Places a tag on an element or subelement.

See Also

IndependentTag Class
IndependentTag Members


Create Method (Document, ElementId, ElementId, Reference, Boolean, TagOrientation, XYZ)

[image]

Revit 2024 API
IndependentTag..::..Create Method (Document, ElementId, ElementId, Reference, Boolean, TagOrientation, XYZ)
IndependentTag Class See Also Send Feedback
Places a tag on an element or subelement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public static IndependentTag Create(
    Document document,
    ElementId symId,
    ElementId ownerDBViewId,
    Reference referenceToTag,
    bool addLeader,
    TagOrientation tagOrientation,
    XYZ pnt
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    symId As ElementId, _
    ownerDBViewId As ElementId, _
    referenceToTag As Reference, _
    addLeader As Boolean, _
    tagOrientation As TagOrientation, _
    pnt As XYZ _
) As IndependentTag
Visual C++
public:
static IndependentTag^ Create(
    Document^ document,
    ElementId^ symId,
    ElementId^ ownerDBViewId,
    Reference^ referenceToTag,
    bool addLeader,
    TagOrientation tagOrientation,
    XYZ^ pnt
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the tag will be added.
symId
Type: Autodesk.Revit.DB..::..ElementId
The id for the FamilySymbol which determines the tag's type.
ownerDBViewId
Type: Autodesk.Revit.DB..::..ElementId
The view in which the tag will be visible.
referenceToTag
Type: Autodesk.Revit.DB..::..Reference
The host reference of the tag. The reference can be to an element or subelement in a local or linked document.
addLeader
Type: System..::..Boolean
When true, the tag will be created with a straight leader with an attached end.
tagOrientation
Type: Autodesk.Revit.DB..::..TagOrientation
The orientation of the tag's head.
pnt
Type: Autodesk.Revit.DB..::..XYZ
For tags without leaders, this point is the position of the tag head. For tags with leaders, this point is the end point of the leader, and a leader of default length will be created from this point to the tag head.

Return Value

If successful the new tag is returned.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId ownerDBViewId does not correspond to a View. -or- The ElementId ownerDBViewId is a view template. -or- The ElementId ownerDBViewId is a perspective view. -or- The 3D view ownerDBViewId is not locked. -or- The ElementId symId does not correspond to a FamilySymbol. -or- The reference can not be tagged.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InternalException | Tag creation failed.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

IndependentTag Class
Create Overload


Create Method (Document, ElementId, Reference, Boolean, TagMode, TagOrientation, XYZ)

[image]

Revit 2024 API
IndependentTag..::..Create Method (Document, ElementId, Reference, Boolean, TagMode, TagOrientation, XYZ)
IndependentTag Class Example See Also Send Feedback
Places a tag on an element or subelement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public static IndependentTag Create(
    Document document,
    ElementId ownerDBViewId,
    Reference referenceToTag,
    bool addLeader,
    TagMode tagMode,
    TagOrientation tagOrientation,
    XYZ pnt
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    ownerDBViewId As ElementId, _
    referenceToTag As Reference, _
    addLeader As Boolean, _
    tagMode As TagMode, _
    tagOrientation As TagOrientation, _
    pnt As XYZ _
) As IndependentTag
Visual C++
public:
static IndependentTag^ Create(
    Document^ document,
    ElementId^ ownerDBViewId,
    Reference^ referenceToTag,
    bool addLeader,
    TagMode tagMode,
    TagOrientation tagOrientation,
    XYZ^ pnt
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the tag will be added.
ownerDBViewId
Type: Autodesk.Revit.DB..::..ElementId
The view in which the tag will be visible.
referenceToTag
Type: Autodesk.Revit.DB..::..Reference
The host reference of the tag. The reference can be to an element or subelement in a local or linked document.
addLeader
Type: System..::..Boolean
When true, the tag will be created with a straight leader with an attached end.
tagMode
Type: Autodesk.Revit.DB..::..TagMode
This argument determines the type of tag that will be created. Tag by category, multi-category tag, and material tag are allowed.
tagOrientation
Type: Autodesk.Revit.DB..::..TagOrientation
The orientation of the tag's head.
pnt
Type: Autodesk.Revit.DB..::..XYZ
For tags without leaders, this point is the position of the tag head. For tags with leaders, this point is the end point of the leader, and a leader of default length will be created from this point to the tag head.

Return Value

If successful the new tag is returned.

Remarks

Single category tags, multi-category tags and material tags can be placed.

Examples

CopyC#
private IndependentTag CreateIndependentTag(Autodesk.Revit.DB.Document document, Wall wall)
{
    // make sure active view is not a 3D view
    Autodesk.Revit.DB.View view = document.ActiveView;

    // define tag mode and tag orientation for new tag
    TagMode tagMode = TagMode.TM_ADDBY_CATEGORY;
    TagOrientation tagorn = TagOrientation.Horizontal;

    // Add the tag to the middle of the wall
    LocationCurve wallLoc = wall.Location as LocationCurve;
    XYZ wallStart = wallLoc.Curve.GetEndPoint(0);
    XYZ wallEnd = wallLoc.Curve.GetEndPoint(1);
    XYZ wallMid = wallLoc.Curve.Evaluate(0.5, true);
    Reference wallRef = new Reference(wall);

    IndependentTag newTag = IndependentTag.Create(document, view.Id,  wallRef, true, tagMode, tagorn, wallMid);
    if (null == newTag)
    {
        throw new Exception("Create IndependentTag Failed.");
    }

    // newTag.TagText is read-only, so we change the Type Mark type parameter to
    // set the tag text.  The label parameter for the tag family determines
    // what type parameter is used for the tag text.

    WallType type = wall.WallType;

    Parameter foundParameter = type.LookupParameter("Type Mark");
    bool result = foundParameter.Set("Hello");

    // set leader mode free
    // otherwise leader end point move with elbow point

    newTag.LeaderEndCondition = LeaderEndCondition.Free;
    XYZ elbowPnt = wallMid + new XYZ(5.0, 5.0, 0.0);
    newTag.SetLeaderElbow(wallRef, elbowPnt);
    XYZ headerPnt = wallMid + new XYZ(10.0, 10.0, 0.0);
    newTag.TagHeadPosition = headerPnt;

    // change tag orientation to AnyModelDirection
    newTag.TagOrientation = TagOrientation.AnyModelDirection;

    // change tag rotation angle to PI/4
    newTag.RotationAngle = Math.PI / 4;

    return newTag;
}
CopyVB.NET
Private Function CreateIndependentTag(document As Autodesk.Revit.DB.Document, wall As Wall) As IndependentTag
      ' make sure active view is not a 3D view
      Dim view As Autodesk.Revit.DB.View = document.ActiveView

      ' define tag mode and tag orientation for new tag
      Dim tagMode__1 As TagMode = TagMode.TM_ADDBY_CATEGORY
      Dim tagorn As TagOrientation = TagOrientation.Horizontal

      ' Add the tag to the middle of the wall
      Dim wallLoc As LocationCurve = TryCast(wall.Location, LocationCurve)
      Dim wallStart As XYZ = wallLoc.Curve.GetEndPoint(0)
      Dim wallEnd As XYZ = wallLoc.Curve.GetEndPoint(1)
      Dim wallMid As XYZ = wallLoc.Curve.Evaluate(0.5, True)
   Dim WallRef As Reference = New Reference(wall)

   Dim newTag As IndependentTag = IndependentTag.Create(document, view.Id, wallRef, True, tagMode__1, tagorn, wallMid)
      If newTag Is Nothing Then
          Throw New Exception("Create IndependentTag Failed.")
      End If

      ' newTag.TagText is read-only, so we change the Type Mark type parameter to
      ' set the tag text.  The label parameter for the tag family determines
      ' what type parameter is used for the tag text.

      Dim type As WallType = wall.WallType

      Dim foundParameter As Parameter = type.LookupParameter("Type Mark")
      Dim result As Boolean = foundParameter.[Set]("Hello")

      ' set leader mode free
      ' otherwise leader end point move with elbow point

      newTag.LeaderEndCondition = LeaderEndCondition.Free
      Dim elbowPnt As XYZ = wallMid + New XYZ(5.0, 5.0, 0.0)
      newTag.SetLeaderElbow(WallRef, elbowPnt)
      Dim headerPnt As XYZ = wallMid + New XYZ(10.0, 10.0, 0.0)
      newTag.TagHeadPosition = headerPnt

      ' change tag orientation to AnyModelDirection
      newTag.TagOrientation = TagOrientation.AnyModelDirection

      ' change tag rotation angle to PI/4
      newTag.RotationAngle = Math.PI / 4

      Return newTag
  End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId ownerDBViewId does not correspond to a View. -or- The ElementId ownerDBViewId is a view template. -or- The ElementId ownerDBViewId is a perspective view. -or- The 3D view ownerDBViewId is not locked. -or- The reference can not be tagged.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InternalException | Tag creation failed.
Autodesk.Revit.Exceptions..::..InvalidOperationException | There is no loaded tag type that can be used when tagging referenceToTag with tagMode.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

IndependentTag Class
Create Overload


GetTaggedElementIds Method

[image]

Revit 2024 API
IndependentTag..::..GetTaggedElementIds Method
IndependentTag Class See Also Send Feedback
Returns a set of LinkElementId for all tagged elements, if any. A LinkElementId will be provided for each subelement that is being referenced by the tag.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public ICollection<LinkElementId> GetTaggedElementIds()
Visual Basic
Public Function GetTaggedElementIds As ICollection(Of LinkElementId)
Visual C++
public:
ICollection<LinkElementId^>^ GetTaggedElementIds()

Return Value

Set of all the tagged elements ids for both local and linked files.

Remarks

All the returned LinkElementIds will be valid even when IsOrphaned is true.

See Also

IndependentTag Class


GetTaggedLocalElementIds Method

[image]

Revit 2024 API
IndependentTag..::..GetTaggedLocalElementIds Method
IndependentTag Class See Also Send Feedback
Returns a set of IDs for all tagged local elements, if any. A local element ID will be provided for each subelement that is being referenced by the tag. Set of all the element ids in the local file. For each subelement a local element id will be provided.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public ISet<ElementId> GetTaggedLocalElementIds()
Visual Basic
Public Function GetTaggedLocalElementIds As ISet(Of ElementId)
Visual C++
public:
ISet<ElementId^>^ GetTaggedLocalElementIds()

See Also

IndependentTag Class


GetTaggedReferences Method

[image]

Revit 2024 API
IndependentTag..::..GetTaggedReferences Method
IndependentTag Class See Also Send Feedback
Get the host references of the tag. An array of all the tagged references.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public IList<Reference> GetTaggedReferences()
Visual Basic
Public Function GetTaggedReferences As IList(Of Reference)
Visual C++
public:
IList<Reference^>^ GetTaggedReferences()

Remarks

The references can be to an element or subelement in a local or linked document.

See Also

IndependentTag Class


IsLeaderVisible Method

[image]

Revit 2024 API
IndependentTag..::..IsLeaderVisible Method
IndependentTag Class See Also Send Feedback
Returns if leader that points to specified reference is visible or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public bool IsLeaderVisible(
    Reference referenceTagged
)
Visual Basic
Public Function IsLeaderVisible ( _
    referenceTagged As Reference _
) As Boolean
Visual C++
public:
bool IsLeaderVisible(
    Reference^ referenceTagged
)

Parameters

referenceTagged
Type: Autodesk.Revit.DB..::..Reference
The reference which is tagged.

Return Value

Returns true if leader that points to specified reference is visible, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The specified reference is not currently tagged.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The IndependentTag object does not have a tag behavior.

See Also

IndependentTag Class


IsTaggedOnSubelement Method

[image]

Revit 2024 API
IndependentTag..::..IsTaggedOnSubelement Method
IndependentTag Class See Also Send Feedback
Returns true if the any of the tagged references is a subelement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public bool IsTaggedOnSubelement()
Visual Basic
Public Function IsTaggedOnSubelement As Boolean
Visual C++
public:
bool IsTaggedOnSubelement()

See Also

IndependentTag Class


RemoveReferences Method

[image]

Revit 2024 API
IndependentTag..::..RemoveReferences Method
IndependentTag Class See Also Send Feedback
Removes the provided list of references from the tag's list of references.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public void RemoveReferences(
    IList<Reference> referencesToRemove
)
Visual Basic
Public Sub RemoveReferences ( _
    referencesToRemove As IList(Of Reference) _
)
Visual C++
public:
void RemoveReferences(
    IList<Reference^>^ referencesToRemove
)

Parameters

referencesToRemove
Type: System.Collections.Generic..::..IList<(Of <(<' Reference >)>)>
References to be removed from tag.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The operation failed. Please verify that the references are all tagged before removing them.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The IndependentTag object does not have a tag behavior.

See Also

IndependentTag Class


SetIsLeaderVisible Method

[image]

Revit 2024 API
IndependentTag..::..SetIsLeaderVisible Method
IndependentTag Class See Also Send Feedback
Set tag's leader that points to specified reference to be visible or not. This option can be set only if the LeadersPresentationMode is ShowSpecificLeaders.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public void SetIsLeaderVisible(
    Reference referenceTagged,
    bool visible
)
Visual Basic
Public Sub SetIsLeaderVisible ( _
    referenceTagged As Reference, _
    visible As Boolean _
)
Visual C++
public:
void SetIsLeaderVisible(
    Reference^ referenceTagged,
    bool visible
)

Parameters

referenceTagged
Type: Autodesk.Revit.DB..::..Reference
The reference which is tagged.
visible
Type: System..::..Boolean
True for showing the leader, false to hide it.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The specified reference is not currently tagged.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The IndependentTag object does not have a tag behavior. -or- The LeadersPresentationMode should be set to ShowSpecificLeaders.

See Also

IndependentTag Class


IndependentTag Properties

[image] [image]

Revit 2024 API
IndependentTag Properties
IndependentTag Class See Also Send Feedback

The IndependentTag type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | HasLeader | Identifies if a tag has at least one visible leader, or if all leaders are hidden.
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsMaterialTag | Identifies if it is a material tag or not.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsMulticategoryTag | Identifies if it is a multi-category tag or not.
Public property | IsOrphaned | Identifies if the tag is orphaned or not.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LeaderEndCondition | The leader end condition of the tag, such as if the end of the leader is attached to the host or free floating.
Public property | LeadersPresentationMode | Identifies the Presentation Mode that is applied to tag leaders.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MergeElbows | Identifies if the leaders' elbows are merged or not. If they are are merged, all elbows are in the same point and they move together.
Public property | MultiLeader | Returns if the tag if referencing multiple elements and/or sub-elements.
Public property | MultiReferenceAnnotationId | The multi-reference annotation which owns this tag.
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RotationAngle | The rotation angle of the tag relative to its view
Public property | TagHeadPosition | The position of the head of tag in model coordinates.
Public property | TagOrientation | The tag orientation of the tag's head, such as horizontal or vertical.
Public property | TagText | The text associated with the tag. If there are several strings assiciated with the tag, the strings will be returned concatenated.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

IndependentTag Class


IsMaterialTag Property

[image]

Revit 2024 API
IndependentTag..::..IsMaterialTag Property
IndependentTag Class See Also Send Feedback
Identifies if it is a material tag or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsMaterialTag { get; }
Visual Basic
Public ReadOnly Property IsMaterialTag As Boolean
    Get
Visual C++
public:
property bool IsMaterialTag {
    bool get ();
}

See Also

IndependentTag Class


IsMulticategoryTag Property

[image]

Revit 2024 API
IndependentTag..::..IsMulticategoryTag Property
IndependentTag Class See Also Send Feedback
Identifies if it is a multi-category tag or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsMulticategoryTag { get; }
Visual Basic
Public ReadOnly Property IsMulticategoryTag As Boolean
    Get
Visual C++
public:
property bool IsMulticategoryTag {
    bool get ();
}

See Also

IndependentTag Class


IsOrphaned Property

[image]

Revit 2024 API
IndependentTag..::..IsOrphaned Property
IndependentTag Class See Also Send Feedback
Identifies if the tag is orphaned or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsOrphaned { get; }
Visual Basic
Public ReadOnly Property IsOrphaned As Boolean
    Get
Visual C++
public:
property bool IsOrphaned {
    bool get ();
}

Remarks

Orphaned tags are those tags that are associated with one or more linked host that is missing. Tags become orphaned when one or more associated linked host is missing from the link.

See Also

IndependentTag Class


LeaderEndCondition Property

[image]

Revit 2024 API
IndependentTag..::..LeaderEndCondition Property
IndependentTag Class See Also Send Feedback
The leader end condition of the tag, such as if the end of the leader is attached to the host or free floating.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public LeaderEndCondition LeaderEndCondition { get; set; }
Visual Basic
Public Property LeaderEndCondition As LeaderEndCondition
    Get
    Set
Visual C++
public:
property LeaderEndCondition LeaderEndCondition {
    LeaderEndCondition get ();
    void set (LeaderEndCondition value);
}

Remarks

LeaderEndCondition enumerates the supported leader end conditions. Material tags and material keynotes can only use the free end condition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: LeaderEndCondition cannot be assigned.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | The IndependentTag object does not have a tag behavior.

See Also

IndependentTag Class


MergeElbows Property

[image]

Revit 2024 API
IndependentTag..::..MergeElbows Property
IndependentTag Class See Also Send Feedback
Identifies if the leaders' elbows are merged or not. If they are are merged, all elbows are in the same point and they move together.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public bool MergeElbows { get; set; }
Visual Basic
Public Property MergeElbows As Boolean
    Get
    Set
Visual C++
public:
property bool MergeElbows {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The IndependentTag object does not have a tag behavior. -or- When setting this property: For this tag leaders are not allowed. -or- When setting this property: Can't merge elbows for tags that are part of a multi-reference annotation.

See Also

IndependentTag Class


MultiLeader Property

[image]

Revit 2024 API
IndependentTag..::..MultiLeader Property
IndependentTag Class See Also Send Feedback
Returns if the tag if referencing multiple elements and/or sub-elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public bool MultiLeader { get; }
Visual Basic
Public ReadOnly Property MultiLeader As Boolean
    Get
Visual C++
public:
property bool MultiLeader {
    bool get ();
}

See Also

IndependentTag Class


MultiReferenceAnnotationId Property

[image]

Revit 2024 API
IndependentTag..::..MultiReferenceAnnotationId Property
IndependentTag Class See Also Send Feedback
The multi-reference annotation which owns this tag.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElementId MultiReferenceAnnotationId { get; }
Visual Basic
Public ReadOnly Property MultiReferenceAnnotationId As ElementId
    Get
Visual C++
public:
property ElementId^ MultiReferenceAnnotationId {
    ElementId^ get ();
}

Remarks

[!:Autodesk::Revit::DB::MultiReferenceAnnotation] for more information.

See Also

IndependentTag Class


Parameter Property

[image] [image]

Revit 2024 API
IndependentTag..::..Parameter Property
IndependentTag Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

IndependentTag Class
IndependentTag Members


RotationAngle Property

[image]

Revit 2024 API
IndependentTag..::..RotationAngle Property
IndependentTag Class See Also Send Feedback
The rotation angle of the tag relative to its view

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public double RotationAngle { get; set; }
Visual Basic
Public Property RotationAngle As Double
    Get
    Set
Visual C++
public:
property double RotationAngle {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: Angle can only be changed for AnyModelDirection orientation

See Also

IndependentTag Class


TagHeadPosition Property

[image]

Revit 2024 API
IndependentTag..::..TagHeadPosition Property
IndependentTag Class See Also Send Feedback
The position of the head of tag in model coordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ TagHeadPosition { get; set; }
Visual Basic
Public Property TagHeadPosition As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ TagHeadPosition {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

The depth of the tag head position in the view does not matter because tags are drawn over model geometry in the view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

IndependentTag Class


TagText Property

[image]

Revit 2024 API
IndependentTag..::..TagText Property
IndependentTag Class See Also Send Feedback
The text associated with the tag. If there are several strings assiciated with the tag, the strings will be returned concatenated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string TagText { get; }
Visual Basic
Public ReadOnly Property TagText As String
    Get
Visual C++
public:
property String^ TagText {
    String^ get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The IndependentTag object does not have a tag behavior. -or- The tagging element is in the link.

See Also

IndependentTag Class


InsertableObject Class

[image]

Revit 2024 API
InsertableObject Class
Members See Also Send Feedback
A base class you all types that are insertable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class InsertableObject : ElementType
Visual Basic
Public Class InsertableObject _
    Inherits ElementType
Visual C++
public ref class InsertableObject : public ElementType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..InsertableObject
Autodesk.Revit.DB..::..FamilySymbol

See Also

InsertableObject Members


InsertableObject Members

[image] [image]

Revit 2024 API
InsertableObject Members
InsertableObject Class Methods Properties See Also Send Feedback

The InsertableObject type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

InsertableObject Class


InsertableObject Properties

[image] [image]

Revit 2024 API
InsertableObject Properties
InsertableObject Class See Also Send Feedback

The InsertableObject type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

InsertableObject Class


Parameter Property

[image] [image]

Revit 2024 API
InsertableObject..::..Parameter Property
InsertableObject Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

InsertableObject Class
InsertableObject Members


InsertOrientation Enumeration

[image]

Revit 2024 API
InsertOrientation Enumeration
See Also Send Feedback
The allowed values for the INSERT_ORIENTATION parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum InsertOrientation
Visual Basic
Public Enumeration InsertOrientation
Visual C++
public enum class InsertOrientation

Members

Member name | Description
Vertical | Insert is vertical regardless of the wall's slant.
Slanted | Insert is aligned with the Slanted wall's slant direction.
Exterior | Insert is aligned with the Tapered wall's exterior face.
Interior | Insert is aligned with the Tapered wall's interior face.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


InSessionPrintSetting Class

[image]

Revit 2024 API
InSessionPrintSetting Class
Members See Also Send Feedback
Represents the in-session Print Setup (Application Menu->Print->Print Setup) within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class InSessionPrintSetting : IPrintSetting,
    IDisposable
Visual Basic
Public Class InSessionPrintSetting _
    Implements IPrintSetting, IDisposable
Visual C++
public ref class InSessionPrintSetting : IPrintSetting,
    IDisposable

Remarks

The in-session PrintSetting can't be stored in document.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..InSessionPrintSetting

See Also

InSessionPrintSetting Members


InSessionPrintSetting Members

[image] [image]

Revit 2024 API
InSessionPrintSetting Members
InSessionPrintSetting Class Methods Properties See Also Send Feedback

The InSessionPrintSetting type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the InSessionPrintSetting
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | PrintParameters | Returns the Parameters of Print Setup.

See Also

InSessionPrintSetting Class


Dispose Method

[image]

Revit 2024 API
InSessionPrintSetting..::..Dispose Method
InSessionPrintSetting Class See Also Send Feedback
Releases all resources used by the InSessionPrintSetting

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

InSessionPrintSetting Class


InSessionPrintSetting Properties

[image] [image]

Revit 2024 API
InSessionPrintSetting Properties
InSessionPrintSetting Class See Also Send Feedback

The InSessionPrintSetting type exposes the following members.

Properties

 | Name | Description
Public property | PrintParameters | Returns the Parameters of Print Setup.

See Also

InSessionPrintSetting Class


InSessionViewSheetSet Class

[image]

Revit 2024 API
InSessionViewSheetSet Class
Members See Also Send Feedback
Represents the in-session ViewSheetSet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class InSessionViewSheetSet : IViewSheetSet,
    IDisposable
Visual Basic
Public Class InSessionViewSheetSet _
    Implements IViewSheetSet, IDisposable
Visual C++
public ref class InSessionViewSheetSet : IViewSheetSet,
    IDisposable

Remarks

The in-session ViewSheetSet can't be stored in document.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..InSessionViewSheetSet

See Also

InSessionViewSheetSet Members


InSessionViewSheetSet Members

[image] [image]

Revit 2024 API
InSessionViewSheetSet Members
InSessionViewSheetSet Class Methods Properties See Also Send Feedback

The InSessionViewSheetSet type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the InSessionViewSheetSet
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsAutomatic | Automatic order or manual order.
Public property | OrderedViewList | Ordered views.
Public property | SheetOrganizationId | ElementId to the BrowserOrganization for sheets.
Public property | ViewOrganizationId | ElementId to the BrowserOrganization for non-sheet views.
Public property | Views | The views.

See Also

InSessionViewSheetSet Class


InSessionViewSheetSet Methods

[image] [image]

Revit 2024 API
InSessionViewSheetSet Methods
InSessionViewSheetSet Class See Also Send Feedback

The InSessionViewSheetSet type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

InSessionViewSheetSet Class


Dispose Method

[image]

Revit 2024 API
InSessionViewSheetSet..::..Dispose Method
InSessionViewSheetSet Class See Also Send Feedback
Releases all resources used by the InSessionViewSheetSet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

InSessionViewSheetSet Class


InSessionViewSheetSet Properties

[image] [image]

Revit 2024 API
InSessionViewSheetSet Properties
InSessionViewSheetSet Class See Also Send Feedback

The InSessionViewSheetSet type exposes the following members.

Properties

 | Name | Description
Public property | IsAutomatic | Automatic order or manual order.
Public property | OrderedViewList | Ordered views.
Public property | SheetOrganizationId | ElementId to the BrowserOrganization for sheets.
Public property | ViewOrganizationId | ElementId to the BrowserOrganization for non-sheet views.
Public property | Views | The views.

See Also

InSessionViewSheetSet Class


IsAutomatic Property

[image]

Revit 2024 API
InSessionViewSheetSet..::..IsAutomatic Property
InSessionViewSheetSet Class See Also Send Feedback
Automatic order or manual order.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool IsAutomatic { get; set; }
Visual Basic
Public Overridable Property IsAutomatic As Boolean
    Get
    Set
Visual C++
public:
virtual property bool IsAutomatic {
    bool get ();
    void set (bool value);
}

Implements

IViewSheetSet..::..IsAutomatic

See Also

InSessionViewSheetSet Class


OrderedViewList Property

[image]

Revit 2024 API
InSessionViewSheetSet..::..OrderedViewList Property
InSessionViewSheetSet Class See Also Send Feedback
Ordered views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IReadOnlyList<View> OrderedViewList { get; set; }
Visual Basic
Public Overridable Property OrderedViewList As IReadOnlyList(Of View)
    Get
    Set
Visual C++
public:
virtual property IReadOnlyList<View^>^ OrderedViewList {
    IReadOnlyList<View^>^ get ();
    void set (IReadOnlyList<View^>^ value);
}

Implements

IViewSheetSet..::..OrderedViewList

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input ordered view list is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the set operation failed due to invalid view which cannot be printed.

See Also

InSessionViewSheetSet Class


SheetOrganizationId Property

[image]

Revit 2024 API
InSessionViewSheetSet..::..SheetOrganizationId Property
InSessionViewSheetSet Class See Also Send Feedback
ElementId to the BrowserOrganization for sheets.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual ElementId SheetOrganizationId { get; set; }
Visual Basic
Public Overridable Property SheetOrganizationId As ElementId
    Get
    Set
Visual C++
public:
virtual property ElementId^ SheetOrganizationId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Implements

IViewSheetSet..::..SheetOrganizationId

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the ElementId does not reference to BrowserOrganization, or the target type of BrowserOrganization is incompatible.

See Also

InSessionViewSheetSet Class


ViewOrganizationId Property

[image]

Revit 2024 API
InSessionViewSheetSet..::..ViewOrganizationId Property
InSessionViewSheetSet Class See Also Send Feedback
ElementId to the BrowserOrganization for non-sheet views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual ElementId ViewOrganizationId { get; set; }
Visual Basic
Public Overridable Property ViewOrganizationId As ElementId
    Get
    Set
Visual C++
public:
virtual property ElementId^ ViewOrganizationId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Implements

IViewSheetSet..::..ViewOrganizationId

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the ElementId does not reference to BrowserOrganization, or the target type of BrowserOrganization is incompatible.

See Also

InSessionViewSheetSet Class


Instance Class

[image]

Revit 2024 API
Instance Class
Members See Also Send Feedback
The base class for all instance objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class Instance : Element
Visual Basic
Public Class Instance _
    Inherits Element
Visual C++
public ref class Instance : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..Instance
Autodesk.Revit.DB..::..FamilyInstance
Autodesk.Revit.DB..::..ImportInstance
Autodesk.Revit.DB..::..PointCloudInstance
Autodesk.Revit.DB..::..ProjectLocation
Autodesk.Revit.DB..::..RevitLinkInstance

See Also

Instance Members


Instance Members

[image] [image]

Revit 2024 API
Instance Members
Instance Class Methods Properties See Also Send Feedback

The Instance type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetTotalTransform | Gets the total transform, which includes the true north transform for instances like import instances.
Public method | GetTransform | Gets the transform of the instance.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Instance Class


Instance Methods

[image] [image]

Revit 2024 API
Instance Methods
Instance Class See Also Send Feedback

The Instance type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetTotalTransform | Gets the total transform, which includes the true north transform for instances like import instances.
Public method | GetTransform | Gets the transform of the instance.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Instance Class


GetTotalTransform Method

[image]

Revit 2024 API
Instance..::..GetTotalTransform Method
Instance Class See Also Send Feedback
Gets the total transform, which includes the true north transform for instances like import instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public Transform GetTotalTransform()
Visual Basic
Public Function GetTotalTransform As Transform
Visual C++
public:
Transform^ GetTotalTransform()

Return Value

The calculated total transform.

Remarks

For most of other instances, it simply returns the inherent transform.

See Also

Instance Class


GetTransform Method

[image]

Revit 2024 API
Instance..::..GetTransform Method
Instance Class See Also Send Feedback
Gets the transform of the instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public Transform GetTransform()
Visual Basic
Public Function GetTransform As Transform
Visual C++
public:
Transform^ GetTransform()

Return Value

The inherent transform.

See Also

Instance Class


Instance Properties

[image] [image]

Revit 2024 API
Instance Properties
Instance Class See Also Send Feedback

The Instance type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Instance Class


Parameter Property

[image] [image]

Revit 2024 API
Instance..::..Parameter Property
Instance Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Instance Class
Instance Members


InstanceBinding Class

[image]

Revit 2024 API
InstanceBinding Class
Members Example See Also Send Feedback
The InstanceBinding object is used to signify a binding between a parameter definition and a parameter on each instance of an element, such as a wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class InstanceBinding : ElementBinding
Visual Basic
Public Class InstanceBinding _
    Inherits ElementBinding
Visual C++
public ref class InstanceBinding : public ElementBinding

Remarks

Once bound the parameter will appear on all instance of the element and changing the parameter on any one single instance will not change the value on any other instance.

Examples

CopyC#
public bool SetNewParameterToInstanceWall(UIApplication app, DefinitionFile myDefinitionFile)
{
    // create a new group in the shared parameters file
    DefinitionGroups myGroups = myDefinitionFile.Groups;
    DefinitionGroup myGroup = myGroups.Create("MyParameters1");

    // create an instance definition in definition group MyParameters
    ExternalDefinitionCreationOptions option = new ExternalDefinitionCreationOptions("Instance_ProductDate", SpecTypeId.String.Text);
    // Don't let the user modify the value, only the API
    option.UserModifiable = false;
    // Set tooltip
    option.Description = "Wall product date";
    Definition myDefinition_ProductDate = myGroup.Definitions.Create(option);

    // create a category set and insert category of wall to it
    CategorySet myCategories = app.Application.Create.NewCategorySet();
    // use BuiltInCategory to get category of wall
    Category myCategory = Category.GetCategory(app.ActiveUIDocument.Document, BuiltInCategory.OST_Walls);

    myCategories.Insert(myCategory);

    //Create an instance of InstanceBinding
    InstanceBinding instanceBinding = app.Application.Create.NewInstanceBinding(myCategories);

    // Get the BingdingMap of current document.
    BindingMap bindingMap = app.ActiveUIDocument.Document.ParameterBindings;

    // Bind the definitions to the document
    bool instanceBindOK = bindingMap.Insert(myDefinition_ProductDate,
                                    instanceBinding, GroupTypeId.Text);
    return instanceBindOK;
}
CopyVB.NET
Public Function SetNewParameterToInstanceWall(app As UIApplication, myDefinitionFile As DefinitionFile) As Boolean
   ' create a new group in the shared parameters file
   Dim myGroups As DefinitionGroups = myDefinitionFile.Groups
   Dim myGroup As DefinitionGroup = myGroups.Create("MyParameters1")

   ' create an instance definition in definition group MyParameters
   Dim [option] As New ExternalDefinitionCreationOptions("Instance_ProductDate", SpecTypeId.String.Text)
   ' Don't let the user modify the value, only the API
   [option].UserModifiable = False
   ' Set tooltip
   [option].Description = "Wall product date"
   Dim myDefinition_ProductDate As Definition = myGroup.Definitions.Create([option])

   ' create a category set and insert category of wall to it
   Dim myCategories As CategorySet = app.Application.Create.NewCategorySet()
   ' use BuiltInCategory to get category of wall
   Dim myCategory As Category = Category.GetCategory(app.ActiveUIDocument.Document, BuiltInCategory.OST_Walls)

   myCategories.Insert(myCategory)

   'Create an instance of InstanceBinding
   Dim instanceBinding As InstanceBinding = app.Application.Create.NewInstanceBinding(myCategories)

   ' Get the BingdingMap of current document.
   Dim bindingMap As BindingMap = app.ActiveUIDocument.Document.ParameterBindings

      ' Bind the definitions to the document
      Dim instanceBindOK As Boolean = bindingMap.Insert(myDefinition_ProductDate, instanceBinding, GroupTypeId.Text)
      Return instanceBindOK
End Function

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..Binding
Autodesk.Revit.DB..::..ElementBinding
Autodesk.Revit.DB..::..InstanceBinding

See Also

InstanceBinding Members


InstanceBinding Members

[image] [image]

Revit 2024 API
InstanceBinding Members
InstanceBinding Class Constructors Methods Properties See Also Send Feedback

The InstanceBinding type exposes the following members.

Constructors

 | Name | Description
Public method | InstanceBinding()()()() | Constructs an empty instance binding.
Public method | InstanceBinding(CategorySet) | Constructs an instance binding with the set of categories passed.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Categories | Retrieve or set the categories to which a parameter definition will be bound. (Inherited from ElementBinding.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

InstanceBinding Class


InstanceBinding Constructor

[image] [image]

Revit 2024 API
InstanceBinding Constructor
InstanceBinding Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InstanceBinding()()()() | Constructs an empty instance binding.
Public method | InstanceBinding(CategorySet) | Constructs an instance binding with the set of categories passed.

See Also

InstanceBinding Class
InstanceBinding Members


InstanceBinding Constructor

[image]

Revit 2024 API
InstanceBinding Constructor
InstanceBinding Class See Also Send Feedback
Constructs an empty instance binding.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public InstanceBinding()
Visual Basic
Public Sub New
Visual C++
public:
InstanceBinding()

Remarks

Categories can be set a later time by using the Categories property of this object.

See Also

InstanceBinding Class
InstanceBinding Overload


InstanceBinding Constructor (CategorySet)

[image]

Revit 2024 API
InstanceBinding Constructor (CategorySet)
InstanceBinding Class See Also Send Feedback
Constructs an instance binding with the set of categories passed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public InstanceBinding(
    CategorySet categories
)
Visual Basic
Public Sub New ( _
    categories As CategorySet _
)
Visual C++
public:
InstanceBinding(
    CategorySet^ categories
)

Parameters

categories
Type: Autodesk.Revit.DB..::..CategorySet

Remarks

Categories can be set or changed at a later time by using the Categories property of this object.

See Also

InstanceBinding Class
InstanceBinding Overload


InstanceBinding Properties

[image] [image]

Revit 2024 API
InstanceBinding Properties
InstanceBinding Class See Also Send Feedback

The InstanceBinding type exposes the following members.

Properties

 | Name | Description
Public property | Categories | Retrieve or set the categories to which a parameter definition will be bound. (Inherited from ElementBinding.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

InstanceBinding Class


InstanceNode Class

[image]

Revit 2024 API
InstanceNode Class
Members See Also Send Feedback
An output node that represents an instance of a geometry. It can be an instance of FamilyInstance, or it can be and instance of a part of symbol's geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class InstanceNode : GroupNode
Visual Basic
Public Class InstanceNode _
    Inherits GroupNode
Visual C++
public ref class InstanceNode : public GroupNode

Remarks

See also: [!:Autodesk::Revit::DB::IExportContext::OnInstanceBegin]. The SymbolGeometryId. contains the data for comparing if two InstanceNode points to the same geometry.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..RenderNode
Autodesk.Revit.DB..::..GroupNode
Autodesk.Revit.DB..::..InstanceNode

See Also

InstanceNode Members


InstanceNode Members

[image] [image]

Revit 2024 API
InstanceNode Members
InstanceNode Class Methods Properties See Also Send Feedback

The InstanceNode type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RenderNode.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSymbolGeometryId | Gets the SymbolGeometryId associated with the node.
Public method | GetTransform | A transformation matrix associated with the node. (Inherited from GroupNode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode.)
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode.)

See Also

InstanceNode Class


InstanceNode Methods

[image] [image]

Revit 2024 API
InstanceNode Methods
InstanceNode Class See Also Send Feedback

The InstanceNode type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RenderNode.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSymbolGeometryId | Gets the SymbolGeometryId associated with the node.
Public method | GetTransform | A transformation matrix associated with the node. (Inherited from GroupNode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

InstanceNode Class


GetSymbolGeometryId Method

[image]

Revit 2024 API
InstanceNode..::..GetSymbolGeometryId Method
InstanceNode Class See Also Send Feedback
Gets the SymbolGeometryId associated with the node.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public SymbolGeometryId GetSymbolGeometryId()
Visual Basic
Public Function GetSymbolGeometryId As SymbolGeometryId
Visual C++
public:
SymbolGeometryId^ GetSymbolGeometryId()

Remarks

Use the strings returned by SymbolGeometryId.AsIdentifier(bool) to check if two nodes point to the same geometry of the symbol.

See Also

InstanceNode Class


InstanceNode Properties

[image] [image]

Revit 2024 API
InstanceNode Properties
InstanceNode Class See Also Send Feedback

The InstanceNode type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode.)
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode.)

See Also

InstanceNode Class


InstanceVoidCutUtils Class

[image]

Revit 2024 API
InstanceVoidCutUtils Class
Members See Also Send Feedback
Utilities for cutting elements by unattached voids in family instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static class InstanceVoidCutUtils
Visual Basic
Public NotInheritable Class InstanceVoidCutUtils
Visual C++
public ref class InstanceVoidCutUtils abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..InstanceVoidCutUtils

See Also

InstanceVoidCutUtils Members


InstanceVoidCutUtils Members

[image] [image]

Revit 2024 API
InstanceVoidCutUtils Members
InstanceVoidCutUtils Class Methods See Also Send Feedback

The InstanceVoidCutUtils type exposes the following members.

Methods

Name | Description
AddInstanceVoidCut | Add a cut to an element using the unattached voids inside a cutting instance.
CanBeCutWithVoid | Indicates if the element can be cut by an instance with unattached voids.
GetCuttingVoidInstances | Return ids of the instances with unattached voids cutting the element.
GetElementsBeingCut | Return ids of the elements being cut by the instance
InstanceVoidCutExists | Check whether the instance is cutting the element
IsVoidInstanceCuttingElement | Indicates if the element is a family instance with unattached voids that can cut other elements.
RemoveInstanceVoidCut | Remove a cut applied to the element by a cutting instance with unattached voids.

See Also

InstanceVoidCutUtils Class


InstanceVoidCutUtils Methods

[image] [image]

Revit 2024 API
InstanceVoidCutUtils Methods
InstanceVoidCutUtils Class See Also Send Feedback

The InstanceVoidCutUtils type exposes the following members.

Methods

Name | Description
AddInstanceVoidCut | Add a cut to an element using the unattached voids inside a cutting instance.
CanBeCutWithVoid | Indicates if the element can be cut by an instance with unattached voids.
GetCuttingVoidInstances | Return ids of the instances with unattached voids cutting the element.
GetElementsBeingCut | Return ids of the elements being cut by the instance
InstanceVoidCutExists | Check whether the instance is cutting the element
IsVoidInstanceCuttingElement | Indicates if the element is a family instance with unattached voids that can cut other elements.
RemoveInstanceVoidCut | Remove a cut applied to the element by a cutting instance with unattached voids.

See Also

InstanceVoidCutUtils Class


AddInstanceVoidCut Method

[image]

Revit 2024 API
InstanceVoidCutUtils..::..AddInstanceVoidCut Method
InstanceVoidCutUtils Class Example See Also Send Feedback
Add a cut to an element using the unattached voids inside a cutting instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static void AddInstanceVoidCut(
    Document document,
    Element element,
    Element cuttingInstance
)
Visual Basic
Public Shared Sub AddInstanceVoidCut ( _
    document As Document, _
    element As Element, _
    cuttingInstance As Element _
)
Visual C++
public:
static void AddInstanceVoidCut(
    Document^ document,
    Element^ element,
    Element^ cuttingInstance
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document containing the two elements
element
Type: Autodesk.Revit.DB..::..Element
The element to be cut
cuttingInstance
Type: Autodesk.Revit.DB..::..Element
The cutting family instance

Examples

CopyC#
// Cut a beam with 3 instances of a void-cutting family
// The Family Parameter "Cut with Voids When Loaded" must be true for the cutting family
void CutBeamWithFamilyVoid(Autodesk.Revit.DB.Document doc, FamilyInstance beam, FamilySymbol cuttingSymbol)
{
    LocationCurve lc = beam.Location as LocationCurve;
    Curve beamCurve = lc.Curve;

    for (int i = 1; i <= 3; i++)
    {
        XYZ beamLocation = beamCurve.Evaluate(i * 0.25, true); // position on the beam for this cutting instance
        beamLocation = beamLocation - XYZ.BasisZ; // adjust for top-aligned curve

        Level level = doc.GetElement(beam.LevelId) as Level;
        FamilyInstance cuttingInstance = doc.Create.NewFamilyInstance(beamLocation, cuttingSymbol, level, StructuralType.NonStructural);
        InstanceVoidCutUtils.AddInstanceVoidCut(doc, beam, cuttingInstance);
    }
}
CopyVB.NET
' Cut a beam with 3 instances of a void-cutting family
' The Family Parameter "Cut with Voids When Loaded" must be true for the cutting family
Private Sub CutBeamWithFamilyVoid(doc As Autodesk.Revit.DB.Document, beam As FamilyInstance, cuttingSymbol As FamilySymbol)
    Dim lc As LocationCurve = TryCast(beam.Location, LocationCurve)
    Dim beamCurve As Curve = lc.Curve

    For i As Integer = 1 To 3
        Dim beamLocation As XYZ = beamCurve.Evaluate(i * 0.25, True)
        ' position on the beam for this cutting instance
        beamLocation = beamLocation - XYZ.BasisZ
        ' adjust for top-aligned curve
        Dim level As Level = TryCast(doc.GetElement(beam.LevelId), Level)
        Dim cuttingInstance As FamilyInstance = doc.Create.NewFamilyInstance(beamLocation, cuttingSymbol, level, StructuralType.NonStructural)
        InstanceVoidCutUtils.AddInstanceVoidCut(doc, beam, cuttingInstance)
    Next
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element cannot be cut with a void instance. -or- The element is not a family instance with an unattached void that can cut.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | This method may not be called during dynamic update.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Failed to cut element with the instances

See Also

InstanceVoidCutUtils Class


CanBeCutWithVoid Method

[image]

Revit 2024 API
InstanceVoidCutUtils..::..CanBeCutWithVoid Method
InstanceVoidCutUtils Class See Also Send Feedback
Indicates if the element can be cut by an instance with unattached voids.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static bool CanBeCutWithVoid(
    Element element
)
Visual Basic
Public Shared Function CanBeCutWithVoid ( _
    element As Element _
) As Boolean
Visual C++
public:
static bool CanBeCutWithVoid(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The element to be cut

Return Value

Returns true if the element can be cut by an instance with unattached voids.

Remarks

Elements in a project can be cut if they are host elements or family instances with a category Generic Model or one of the structural categories.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

InstanceVoidCutUtils Class


GetCuttingVoidInstances Method

[image]

Revit 2024 API
InstanceVoidCutUtils..::..GetCuttingVoidInstances Method
InstanceVoidCutUtils Class See Also Send Feedback
Return ids of the instances with unattached voids cutting the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static ICollection<ElementId> GetCuttingVoidInstances(
    Element element
)
Visual Basic
Public Shared Function GetCuttingVoidInstances ( _
    element As Element _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetCuttingVoidInstances(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The element being cut

Return Value

Ids of instances with unattached voids that cut this element

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

InstanceVoidCutUtils Class


InstanceVoidCutExists Method

[image]

Revit 2024 API
InstanceVoidCutUtils..::..InstanceVoidCutExists Method
InstanceVoidCutUtils Class See Also Send Feedback
Check whether the instance is cutting the element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static bool InstanceVoidCutExists(
    Element element,
    Element cuttingInstance
)
Visual Basic
Public Shared Function InstanceVoidCutExists ( _
    element As Element, _
    cuttingInstance As Element _
) As Boolean
Visual C++
public:
static bool InstanceVoidCutExists(
    Element^ element,
    Element^ cuttingInstance
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The element being cut
cuttingInstance
Type: Autodesk.Revit.DB..::..Element
The cutting family instance

Return Value

Returns true if the instance is cutting the element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

InstanceVoidCutUtils Class


RemoveInstanceVoidCut Method

[image]

Revit 2024 API
InstanceVoidCutUtils..::..RemoveInstanceVoidCut Method
InstanceVoidCutUtils Class Example See Also Send Feedback
Remove a cut applied to the element by a cutting instance with unattached voids.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static void RemoveInstanceVoidCut(
    Document document,
    Element element,
    Element cuttingInstance
)
Visual Basic
Public Shared Sub RemoveInstanceVoidCut ( _
    document As Document, _
    element As Element, _
    cuttingInstance As Element _
)
Visual C++
public:
static void RemoveInstanceVoidCut(
    Document^ document,
    Element^ element,
    Element^ cuttingInstance
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document containing the two elements
element
Type: Autodesk.Revit.DB..::..Element
The element being cut
cuttingInstance
Type: Autodesk.Revit.DB..::..Element
The cutting family instance

Examples

CopyC#
// remove all cuts in all family instances created by void-cutting instances
void RemoveVoidCuts(Autodesk.Revit.DB.Document doc, FamilySymbol cuttingSymbol)
{
    FilteredElementCollector collector = new FilteredElementCollector(doc);
    collector.WherePasses(new FamilyInstanceFilter(doc, cuttingSymbol.Id)); // find elements that are family instances of the cutting family

    foreach (FamilyInstance instance in collector)
    {
        foreach (ElementId elementId in InstanceVoidCutUtils.GetElementsBeingCut(instance)) // elements being cut by this instance of the cutting family
        {
            InstanceVoidCutUtils.RemoveInstanceVoidCut(doc, doc.GetElement(elementId), instance); // remove the cut
        }
    }
}
CopyVB.NET
' remove all cuts in all family instances created by void-cutting instances
Private Sub RemoveVoidCuts(doc As Autodesk.Revit.DB.Document, cuttingSymbol As FamilySymbol)
    Dim collector As New FilteredElementCollector(doc)
    collector.WherePasses(New FamilyInstanceFilter(doc, cuttingSymbol.Id))
    ' find elements that are family instances of the cutting family
    For Each instance As FamilyInstance In collector
        For Each elementId As ElementId In InstanceVoidCutUtils.GetElementsBeingCut(instance)
            ' elements being cut by this instance of the cutting family
                ' remove the cut
            InstanceVoidCutUtils.RemoveInstanceVoidCut(doc, doc.GetElement(elementId), instance)
        Next
    Next
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | No instance void cut exists between the two elements.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | Failed to remove the instance cut from the element

See Also

InstanceVoidCutUtils Class


InsulationLiningBase Class

[image]

Revit 2024 API
InsulationLiningBase Class
Members See Also Send Feedback
Acts as the base class for duct insulation, pipe insulation and duct lining elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public class InsulationLiningBase : MEPCurve
Visual Basic
Public Class InsulationLiningBase _
    Inherits MEPCurve
Visual C++
public ref class InsulationLiningBase : public MEPCurve

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB..::..MEPCurve
Autodesk.Revit.DB..::..InsulationLiningBase
Autodesk.Revit.DB.Mechanical..::..DuctInsulation
Autodesk.Revit.DB.Mechanical..::..DuctLining
Autodesk.Revit.DB.Plumbing..::..PipeInsulation

See Also

InsulationLiningBase Members


InsulationLiningBase Methods

[image] [image]

Revit 2024 API
InsulationLiningBase Methods
InsulationLiningBase Class See Also Send Feedback

The InsulationLiningBase type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInsulationIds | Returns the ids of the insulation elements associated to a given element.
 | GetLiningIds | Returns the ids of the lining elements associated to a given element.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
 | IsValidThickness | Identifies if the given thickness value is valid for assignment to insulation or lining elements.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

InsulationLiningBase Class


GetInsulationIds Method

[image]

Revit 2024 API
InsulationLiningBase..::..GetInsulationIds Method
InsulationLiningBase Class See Also Send Feedback
Returns the ids of the insulation elements associated to a given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static ICollection<ElementId> GetInsulationIds(
    Document document,
    ElementId elemId
)
Visual Basic
Public Shared Function GetInsulationIds ( _
    document As Document, _
    elemId As ElementId _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetInsulationIds(
    Document^ document,
    ElementId^ elemId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
elemId
Type: Autodesk.Revit.DB..::..ElementId
The element.

Return Value

A collection of the ids of the insulation elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This id does not represent a valid host for insulation.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

InsulationLiningBase Class


GetLiningIds Method

[image]

Revit 2024 API
InsulationLiningBase..::..GetLiningIds Method
InsulationLiningBase Class See Also Send Feedback
Returns the ids of the lining elements associated to a given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static ICollection<ElementId> GetLiningIds(
    Document document,
    ElementId elemId
)
Visual Basic
Public Shared Function GetLiningIds ( _
    document As Document, _
    elemId As ElementId _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetLiningIds(
    Document^ document,
    ElementId^ elemId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
elemId
Type: Autodesk.Revit.DB..::..ElementId
The element.

Return Value

A collection of the ids of the lining elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This id does not represent a duct, fitting, or accessory element.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

InsulationLiningBase Class


IsValidThickness Method

[image]

Revit 2024 API
InsulationLiningBase..::..IsValidThickness Method
InsulationLiningBase Class See Also Send Feedback
Identifies if the given thickness value is valid for assignment to insulation or lining elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static bool IsValidThickness(
    double thickness
)
Visual Basic
Public Shared Function IsValidThickness ( _
    thickness As Double _
) As Boolean
Visual C++
public:
static bool IsValidThickness(
    double thickness
)

Parameters

thickness
Type: System..::..Double
Thickness of the insulation and lining elements.

Return Value

True if the thickness is valid, false otherwise.

See Also

InsulationLiningBase Class


InsulationLiningBase Properties

[image] [image]

Revit 2024 API
InsulationLiningBase Properties
InsulationLiningBase Class See Also Send Feedback

The InsulationLiningBase type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ConnectorManager | The connector manager of this MEP curve. (Inherited from MEPCurve.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Diameter | The diameter of the MEP curve. (Inherited from MEPCurve.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Height | The height of the MEP curve. (Inherited from MEPCurve.)
Public property | HostElementId | The id of the host element for the insulation or lining element.
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | LevelOffset | The offset of the MEP curve. (Inherited from MEPCurve.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MEPSystem | The system of the MEP curve. (Inherited from MEPCurve.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ReferenceLevel | The reference level of the MEP curve. (Inherited from MEPCurve.)
Public property | Thickness | Thickness of the insulation or lining element.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Width | The width of the MEP curve. (Inherited from MEPCurve.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

InsulationLiningBase Class


HostElementId Property

[image]

Revit 2024 API
InsulationLiningBase..::..HostElementId Property
InsulationLiningBase Class See Also Send Feedback
The id of the host element for the insulation or lining element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public ElementId HostElementId { get; }
Visual Basic
Public ReadOnly Property HostElementId As ElementId
    Get
Visual C++
public:
property ElementId^ HostElementId {
    ElementId^ get ();
}

See Also

InsulationLiningBase Class


Parameter Property

[image] [image]

Revit 2024 API
InsulationLiningBase..::..Parameter Property
InsulationLiningBase Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

InsulationLiningBase Class
InsulationLiningBase Members


Thickness Property

[image]

Revit 2024 API
InsulationLiningBase..::..Thickness Property
InsulationLiningBase Class See Also Send Feedback
Thickness of the insulation or lining element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public double Thickness { get; set; }
Visual Basic
Public Property Thickness As Double
    Get
    Set
Visual C++
public:
property double Thickness {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: Thickness is not valid for assignment to insulation or lining elements.

See Also

InsulationLiningBase Class


IntegerParameterValue Class

[image]

Revit 2024 API
IntegerParameterValue Class
Members See Also Send Feedback
A class that holds an Integer value of a parameter element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Update

Syntax

C#
public class IntegerParameterValue : ParameterValue
Visual Basic
Public Class IntegerParameterValue _
    Inherits ParameterValue
Visual C++
public ref class IntegerParameterValue : public ParameterValue

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ParameterValue
Autodesk.Revit.DB..::..IntegerParameterValue

See Also

IntegerParameterValue Members


IntegerParameterValue Members

[image] [image]

Revit 2024 API
IntegerParameterValue Members
IntegerParameterValue Class Constructors Methods Properties See Also Send Feedback

The IntegerParameterValue type exposes the following members.

Constructors

 | Name | Description
Public method | IntegerParameterValue()()()() | Default constructor
Public method | IntegerParameterValue(Int32) | Value constructor

Methods

 | Name | Description
Public method | Copy | Makes an identical copy of the given parameter value. (Inherited from ParameterValue.)
Public method | Dispose | (Inherited from ParameterValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Tests equality with another instance of the same class. (Inherited from ParameterValue.)
Public method | IsSameType | Tests another instance is of the same value type. (Inherited from ParameterValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ParameterValue.)
Public property | Value | The stored value

See Also

IntegerParameterValue Class


IntegerParameterValue Constructor

[image]

Revit 2024 API
IntegerParameterValue Constructor
IntegerParameterValue Class See Also Send Feedback
Default constructor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Update

Syntax

C#
public IntegerParameterValue()
Visual Basic
Public Sub New
Visual C++
public:
IntegerParameterValue()

See Also

IntegerParameterValue Class
IntegerParameterValue Overload


IntegerParameterValue Methods

[image] [image]

Revit 2024 API
IntegerParameterValue Methods
IntegerParameterValue Class See Also Send Feedback

The IntegerParameterValue type exposes the following members.

Methods

 | Name | Description
Public method | Copy | Makes an identical copy of the given parameter value. (Inherited from ParameterValue.)
Public method | Dispose | (Inherited from ParameterValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Tests equality with another instance of the same class. (Inherited from ParameterValue.)
Public method | IsSameType | Tests another instance is of the same value type. (Inherited from ParameterValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

IntegerParameterValue Class


IntegerParameterValue Properties

[image] [image]

Revit 2024 API
IntegerParameterValue Properties
IntegerParameterValue Class See Also Send Feedback

The IntegerParameterValue type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ParameterValue.)
Public property | Value | The stored value

See Also

IntegerParameterValue Class


Value Property

[image]

Revit 2024 API
IntegerParameterValue..::..Value Property
IntegerParameterValue Class See Also Send Feedback
The stored value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Update

Syntax

C#
public int Value { get; set; }
Visual Basic
Public Property Value As Integer
    Get
    Set
Visual C++
public:
property int Value {
    int get ();
    void set (int value);
}

See Also

IntegerParameterValue Class


IntegerRange Class

[image]

Revit 2024 API
IntegerRange Class
Members See Also Send Feedback
A class to define a range of a sequence of consecutive integer numbers

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public class IntegerRange : IDisposable
Visual Basic
Public Class IntegerRange _
    Implements IDisposable
Visual C++
public ref class IntegerRange : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..IntegerRange

See Also

IntegerRange Members


IntegerRange Members

[image] [image]

Revit 2024 API
IntegerRange Members
IntegerRange Class Methods Properties See Also Send Feedback

The IntegerRange type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the IntegerRange
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | High | The upper limit of the range
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Low | The lower limit of the range

See Also

IntegerRange Class


IntegerRange Methods

[image] [image]

Revit 2024 API
IntegerRange Methods
IntegerRange Class See Also Send Feedback

The IntegerRange type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

IntegerRange Class


Dispose Method

[image]

Revit 2024 API
IntegerRange..::..Dispose Method
IntegerRange Class See Also Send Feedback
Releases all resources used by the IntegerRange

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

IntegerRange Class


IntegerRange Properties

[image] [image]

Revit 2024 API
IntegerRange Properties
IntegerRange Class See Also Send Feedback

The IntegerRange type exposes the following members.

Properties

 | Name | Description
Public property | High | The upper limit of the range
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Low | The lower limit of the range

See Also

IntegerRange Class


High Property

[image]

Revit 2024 API
IntegerRange..::..High Property
IntegerRange Class See Also Send Feedback
The upper limit of the range

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public int High { get; }
Visual Basic
Public ReadOnly Property High As Integer
    Get
Visual C++
public:
property int High {
    int get ();
}

See Also

IntegerRange Class


IsValidObject Property

[image]

Revit 2024 API
IntegerRange..::..IsValidObject Property
IntegerRange Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

IntegerRange Class


InternalDefinition Class

[image]

Revit 2024 API
InternalDefinition Class
Members See Also Send Feedback
This object represents a parameter definition in an Autodesk Revit model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class InternalDefinition : Definition,
    IDisposable
Visual Basic
Public Class InternalDefinition _
    Inherits Definition _
    Implements IDisposable
Visual C++
public ref class InternalDefinition : public Definition,
    IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Definition
Autodesk.Revit.DB..::..InternalDefinition

See Also

InternalDefinition Members


InternalDefinition Members

[image] [image]

Revit 2024 API
InternalDefinition Members
InternalDefinition Class Methods Properties See Also Send Feedback

The InternalDefinition type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the InternalDefinition
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDataType | Gets a ForgeTypeId identifying the data type describing values of the parameter. (Inherited from Definition.)
Public method | GetGroupTypeId | Gets the identifier of the built-in parameter group to which the parameter defined by this definition belongs. (Overrides Definition..::..GetGroupTypeId()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParameterTypeId | Tests whether this definition identifies a built-in parameter or not.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Gets the identifier of the parameter.
Public method | SetAllowVaryBetweenGroups | Whether or not the parameter values can vary across group members.
Public method | SetGroupTypeId | Sets the built-in parameter group to which the parameter defined by this definition belongs.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BuiltInParameter | Tests whether this definition identifies a built-in parameter or not.
Public property | Id | The id of the parameter.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | The user-visible name for the parameter. (Overrides Definition..::..Name.)
Public property | ParameterGroup | Obsolete. Id of a built-in parameter group to which the parameter defined by this definition belongs. (Overrides Definition..::..ParameterGroup.)
Public property | VariesAcrossGroups | Whether or not the parameter values can vary across group members.
Public property | Visible | Indicates if the parameter is visible in the Autodesk Revit user interface.

See Also

InternalDefinition Class


InternalDefinition Methods

[image] [image]

Revit 2024 API
InternalDefinition Methods
InternalDefinition Class See Also Send Feedback

The InternalDefinition type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDataType | Gets a ForgeTypeId identifying the data type describing values of the parameter. (Inherited from Definition.)
Public method | GetGroupTypeId | Gets the identifier of the built-in parameter group to which the parameter defined by this definition belongs. (Overrides Definition..::..GetGroupTypeId()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParameterTypeId | Tests whether this definition identifies a built-in parameter or not.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Gets the identifier of the parameter.
Public method | SetAllowVaryBetweenGroups | Whether or not the parameter values can vary across group members.
Public method | SetGroupTypeId | Sets the built-in parameter group to which the parameter defined by this definition belongs.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

InternalDefinition Class


Dispose Method

[image]

Revit 2024 API
InternalDefinition..::..Dispose Method
InternalDefinition Class See Also Send Feedback
Releases all resources used by the InternalDefinition

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

InternalDefinition Class


GetGroupTypeId Method

[image]

Revit 2024 API
InternalDefinition..::..GetGroupTypeId Method
InternalDefinition Class See Also Send Feedback
Gets the identifier of the built-in parameter group to which the parameter defined by this definition belongs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public override ForgeTypeId GetGroupTypeId()
Visual Basic
Public Overrides Function GetGroupTypeId As ForgeTypeId
Visual C++
public:
virtual ForgeTypeId^ GetGroupTypeId() override

See Also

InternalDefinition Class


GetParameterTypeId Method

[image]

Revit 2024 API
InternalDefinition..::..GetParameterTypeId Method
InternalDefinition Class See Also Send Feedback
Tests whether this definition identifies a built-in parameter or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ForgeTypeId GetParameterTypeId()
Visual Basic
Public Function GetParameterTypeId As ForgeTypeId
Visual C++
public:
ForgeTypeId^ GetParameterTypeId()

Remarks

For a built-in parameter this method returns one of the ParameterTypeId static properties. For custom-defined parameters, such as shared, global, or family parameters the value is null.

See Also

InternalDefinition Class


GetTypeId Method

[image]

Revit 2024 API
InternalDefinition..::..GetTypeId Method
InternalDefinition Class See Also Send Feedback
Gets the identifier of the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ForgeTypeId GetTypeId()
Visual Basic
Public Function GetTypeId As ForgeTypeId
Visual C++
public:
ForgeTypeId^ GetTypeId()

See Also

InternalDefinition Class


SetAllowVaryBetweenGroups Method

[image]

Revit 2024 API
InternalDefinition..::..SetAllowVaryBetweenGroups Method
InternalDefinition Class See Also Send Feedback
Whether or not the parameter values can vary across group members.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ICollection<ElementId> SetAllowVaryBetweenGroups(
    Document document,
    bool allowVaryBetweenGroups
)
Visual Basic
Public Function SetAllowVaryBetweenGroups ( _
    document As Document, _
    allowVaryBetweenGroups As Boolean _
) As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ SetAllowVaryBetweenGroups(
    Document^ document,
    bool allowVaryBetweenGroups
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document of this parameter.
allowVaryBetweenGroups
Type: System..::..Boolean
Whether this parameter should be allowed to vary between groups.

Return Value

The ids of elements that were updated to align the values between groups.

Remarks

When a parameter is set to not vary between groups Revit will automatically align the parameter values of any elements that actually varied between group instances.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This parameter does not support the specified value of allowVaryBetweenGroups. -or- document is not a project document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

InternalDefinition Class


SetGroupTypeId Method

[image]

Revit 2024 API
InternalDefinition..::..SetGroupTypeId Method
InternalDefinition Class See Also Send Feedback
Sets the built-in parameter group to which the parameter defined by this definition belongs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetGroupTypeId(
    ForgeTypeId groupTypeId
)
Visual Basic
Public Sub SetGroupTypeId ( _
    groupTypeId As ForgeTypeId _
)
Visual C++
public:
void SetGroupTypeId(
    ForgeTypeId^ groupTypeId
)

Parameters

groupTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
Identifier of the built-in parameter group.

Remarks

The parameter group can be changed, but only for parameters that are not built in. In other words: This method is only valid for parameter definitions for which GetParameterTypeId() returns a null identifier.

See Also

InternalDefinition Class


BuiltInParameter Property

[image]

Revit 2024 API
InternalDefinition..::..BuiltInParameter Property
InternalDefinition Class See Also Send Feedback
Tests whether this definition identifies a built-in parameter or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public BuiltInParameter BuiltInParameter { get; }
Visual Basic
Public ReadOnly Property BuiltInParameter As BuiltInParameter
    Get
Visual C++
public:
property BuiltInParameter BuiltInParameter {
    BuiltInParameter get ();
}

Remarks

For a build-in parameter this property equals one of the BuiltInParameter enumerated values. For custom-defined parameters, such as shared, global, or family parameters the value is always BuiltInParameter.INVALID.

See Also

InternalDefinition Class


Id Property

[image]

Revit 2024 API
InternalDefinition..::..Id Property
InternalDefinition Class See Also Send Feedback
The id of the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public ElementId Id { get; }
Visual Basic
Public ReadOnly Property Id As ElementId
    Get
Visual C++
public:
property ElementId^ Id {
    ElementId^ get ();
}

See Also

InternalDefinition Class


IsValidObject Property

[image]

Revit 2024 API
InternalDefinition..::..IsValidObject Property
InternalDefinition Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

InternalDefinition Class


Name Property

[image]

Revit 2024 API
InternalDefinition..::..Name Property
InternalDefinition Class See Also Send Feedback
The user-visible name for the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

See Also

InternalDefinition Class


ParameterGroup Property

[image]

Revit 2024 API
InternalDefinition..::..ParameterGroup Property
InternalDefinition Class See Also Send Feedback
Id of a built-in parameter group to which the parameter defined by this definition belongs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
[ObsoleteAttribute("This property is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use the `GetGroupTypeId()` method instead.")]
public override BuiltInParameterGroup ParameterGroup { get; set; }
Visual Basic
<ObsoleteAttribute("This property is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use the `GetGroupTypeId()` method instead.")> _
Public Overrides Property ParameterGroup As BuiltInParameterGroup
    Get
    Set
Visual C++
[ObsoleteAttribute(L"This property is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use the `GetGroupTypeId()` method instead.")]
public:
virtual property BuiltInParameterGroup ParameterGroup {
    BuiltInParameterGroup get () override;
    void set (BuiltInParameterGroup value) override;
}

Remarks

The parameter group can be changed, but only for parameters that are not built in. In other words: Modifying the value of this property is only valid for parameter definitions whose BuiltInParameter property returns BuiltInParameter.INVALID, e.g. Global Parameters.

See Also

InternalDefinition Class


VariesAcrossGroups Property

[image]

Revit 2024 API
InternalDefinition..::..VariesAcrossGroups Property
InternalDefinition Class See Also Send Feedback
Whether or not the parameter values can vary across group members.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool VariesAcrossGroups { get; }
Visual Basic
Public ReadOnly Property VariesAcrossGroups As Boolean
    Get
Visual C++
public:
property bool VariesAcrossGroups {
    bool get ();
}

Field Value

True if the values of this parameter can vary across the related members of group instances. False if the values will be consistent across the related members in group instances.

See Also

InternalDefinition Class


Visible Property

[image]

Revit 2024 API
InternalDefinition..::..Visible Property
InternalDefinition Class See Also Send Feedback
Indicates if the parameter is visible in the Autodesk Revit user interface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool Visible { get; }
Visual Basic
Public Overridable ReadOnly Property Visible As Boolean
    Get
Visual C++
public:
virtual property bool Visible {
    bool get ();
}

Remarks

The visible property controls whether a shared parameter is hidden from the user. This is useful if you wish to add data to an element that is only meaningful to your application and not to the user. This value can only be set when the shared parameter definition is created.

See Also

InternalDefinition Class


InternalDefinitions Class

[image]

Revit 2024 API
InternalDefinitions Class
Members See Also Send Feedback
This object blocks attempts to create new internal definitions as they are not permitted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class InternalDefinitions : Definitions
Visual Basic
Public Class InternalDefinitions _
    Inherits Definitions
Visual C++
public ref class InternalDefinitions : public Definitions

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Definitions
Autodesk.Revit.DB..::..InternalDefinitions

See Also

InternalDefinitions Members


InternalDefinitions Members

[image] [image]

Revit 2024 API
InternalDefinitions Members
InternalDefinitions Class Methods Properties See Also Send Feedback

The InternalDefinitions type exposes the following members.

Methods

 | Name | Description
Public method | Contains | Tests for the existence of a definition within the set. (Inherited from Definitions.)
Public method | Create | Creates a new parameter definition using specified options. (Inherited from Definitions.)
Public method | Dispose | (Inherited from Definitions.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Definitions.)
Public method | GetEnumerator | Retrieves an enumerator to the collection. (Inherited from Definitions.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Identifies if the definitions collection is empty. (Inherited from Definitions.)
Public property | Item | Retrieves a definition by a given name. (Inherited from Definitions.)
Public property | Size | The number of definitions in the collection. (Inherited from Definitions.)

See Also

InternalDefinitions Class


InternalDefinitions Methods

[image] [image]

Revit 2024 API
InternalDefinitions Methods
InternalDefinitions Class See Also Send Feedback

The InternalDefinitions type exposes the following members.

Methods

 | Name | Description
Public method | Contains | Tests for the existence of a definition within the set. (Inherited from Definitions.)
Public method | Create | Creates a new parameter definition using specified options. (Inherited from Definitions.)
Public method | Dispose | (Inherited from Definitions.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Definitions.)
Public method | GetEnumerator | Retrieves an enumerator to the collection. (Inherited from Definitions.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

InternalDefinitions Class


InternalOrigin Class

[image]

Revit 2024 API
InternalOrigin Class
Members See Also Send Feedback
A class representing the origin of internal coordinate system. Each Revit project contains one InternalOrigin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020.2

Syntax

C#
public class InternalOrigin : Element
Visual Basic
Public Class InternalOrigin _
    Inherits Element
Visual C++
public ref class InternalOrigin : public Element

Remarks

The internal origin cannot be selected (e.g. as a reference) nor can it be modified.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..InternalOrigin

See Also

InternalOrigin Members


InternalOrigin Members

[image] [image]

Revit 2024 API
InternalOrigin Members
InternalOrigin Class Methods Properties See Also Send Feedback

The InternalOrigin type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
 | Get | Gets the internal origin for the document.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Position | The position of the InternalOrigin.
Public property | SharedPosition | The position of the InternalOrigin relative to the active ProjectLocation set for the document.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

InternalOrigin Class


InternalOrigin Properties

[image] [image]

Revit 2024 API
InternalOrigin Properties
InternalOrigin Class See Also Send Feedback

The InternalOrigin type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Position | The position of the InternalOrigin.
Public property | SharedPosition | The position of the InternalOrigin relative to the active ProjectLocation set for the document.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

InternalOrigin Class


Position Property

[image]

Revit 2024 API
InternalOrigin..::..Position Property
InternalOrigin Class See Also Send Feedback
The position of the InternalOrigin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020.2

Syntax

C#
public XYZ Position { get; }
Visual Basic
Public ReadOnly Property Position As XYZ
    Get
Visual C++
public:
property XYZ^ Position {
    XYZ^ get ();
}

See Also

InternalOrigin Class


SharedPosition Property

[image]

Revit 2024 API
InternalOrigin..::..SharedPosition Property
InternalOrigin Class See Also Send Feedback
The position of the InternalOrigin relative to the active ProjectLocation set for the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020.2

Syntax

C#
public XYZ SharedPosition { get; }
Visual Basic
Public ReadOnly Property SharedPosition As XYZ
    Get
Visual C++
public:
property XYZ^ SharedPosition {
    XYZ^ get ();
}

See Also

InternalOrigin Class


IntersectionResult Class

[image]

Revit 2024 API
IntersectionResult Class
Members See Also Send Feedback
This class captures results of intersecting geometric entities. "Intersecting" is meant in generalized sense, so the same class will be used for projection, containment, etc. Refer to the documentation of the method providing the result for the precise meaning of properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class IntersectionResult : APIObject
Visual Basic
Public Class IntersectionResult _
    Inherits APIObject
Visual C++
public ref class IntersectionResult : public APIObject

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..IntersectionResult

See Also

IntersectionResult Members


IntersectionResult Members

[image] [image]

Revit 2024 API
IntersectionResult Members
IntersectionResult Class Constructors Methods Properties See Also Send Feedback

The IntersectionResult type exposes the following members.

Constructors

 | Name | Description
Public method | IntersectionResult | Initializes a new instance of the IntersectionResult class

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Distance | Distance from the original object to located point.
Public property | EdgeObject | Edge of the face close to the point of intersection.
Public property | EdgeParameter | Parameter of a point on the edge closest to the point of intersection.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Parameter | 1d parameter of the point of intersection.
Public property | UVPoint | 2d (or two 1d) parameters of the point of intersection.
Public property | XYZPoint | Point of intersection in local 3d coordinates.

See Also

IntersectionResult Class


IntersectionResult Properties

[image] [image]

Revit 2024 API
IntersectionResult Properties
IntersectionResult Class See Also Send Feedback

The IntersectionResult type exposes the following members.

Properties

 | Name | Description
Public property | Distance | Distance from the original object to located point.
Public property | EdgeObject | Edge of the face close to the point of intersection.
Public property | EdgeParameter | Parameter of a point on the edge closest to the point of intersection.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Parameter | 1d parameter of the point of intersection.
Public property | UVPoint | 2d (or two 1d) parameters of the point of intersection.
Public property | XYZPoint | Point of intersection in local 3d coordinates.

See Also

IntersectionResult Class


EdgeObject Property

[image]

Revit 2024 API
IntersectionResult..::..EdgeObject Property
IntersectionResult Class See Also Send Feedback
Edge of the face close to the point of intersection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Edge EdgeObject { get; internal set; }
Visual Basic
Public Property EdgeObject As Edge
    Get
    Friend Set
Visual C++
public:
property Edge^ EdgeObject {
    Edge^ get ();
    internal: void set (Edge^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown in the getter when this property has not been set by the method providing the result.

See Also

IntersectionResult Class


EdgeParameter Property

[image]

Revit 2024 API
IntersectionResult..::..EdgeParameter Property
IntersectionResult Class See Also Send Feedback
Parameter of a point on the edge closest to the point of intersection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double EdgeParameter { get; internal set; }
Visual Basic
Public Property EdgeParameter As Double
    Get
    Friend Set
Visual C++
public:
property double EdgeParameter {
    double get ();
    internal: void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown in the getter when this property has not been set by the method providing the result.

See Also

IntersectionResult Class


Parameter Property

[image]

Revit 2024 API
IntersectionResult..::..Parameter Property
IntersectionResult Class See Also Send Feedback
1d parameter of the point of intersection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double Parameter { get; internal set; }
Visual Basic
Public Property Parameter As Double
    Get
    Friend Set
Visual C++
public:
property double Parameter {
    double get ();
    internal: void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown in the getter when this property has not been set by the method providing the result.

See Also

IntersectionResult Class


UVPoint Property

[image]

Revit 2024 API
IntersectionResult..::..UVPoint Property
IntersectionResult Class See Also Send Feedback
2d (or two 1d) parameters of the point of intersection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public UV UVPoint { get; internal set; }
Visual Basic
Public Property UVPoint As UV
    Get
    Friend Set
Visual C++
public:
property UV^ UVPoint {
    UV^ get ();
    internal: void set (UV^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown in the getter when this property has not been set by the method providing the result.

See Also

IntersectionResult Class


XYZPoint Property

[image]

Revit 2024 API
IntersectionResult..::..XYZPoint Property
IntersectionResult Class See Also Send Feedback
Point of intersection in local 3d coordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ XYZPoint { get; internal set; }
Visual Basic
Public Property XYZPoint As XYZ
    Get
    Friend Set
Visual C++
public:
property XYZ^ XYZPoint {
    XYZ^ get ();
    internal: void set (XYZ^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown in the getter when this property has not been set by the method providing the result.

See Also

IntersectionResult Class


IntersectionResultArray Class

[image]

Revit 2024 API
IntersectionResultArray Class
Members See Also Send Feedback
An array that can contain any type of object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class IntersectionResultArray : APIObject,
    IEnumerable
Visual Basic
Public Class IntersectionResultArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class IntersectionResultArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..IntersectionResultArray

See Also

IntersectionResultArray Members


IntersectionResultArray Members

[image] [image]

Revit 2024 API
IntersectionResultArray Members
IntersectionResultArray Class Constructors Methods Properties See Also Send Feedback

The IntersectionResultArray type exposes the following members.

Constructors

 | Name | Description
Public method | IntersectionResultArray | Initializes a new instance of the IntersectionResultArray class

Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

IntersectionResultArray Class


IntersectionResultArray Methods

[image] [image]

Revit 2024 API
IntersectionResultArray Methods
IntersectionResultArray Class See Also Send Feedback

The IntersectionResultArray type exposes the following members.

Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

IntersectionResultArray Class


Append Method

[image]

Revit 2024 API
IntersectionResultArray..::..Append Method
IntersectionResultArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Append(
    IntersectionResult item
)
Visual Basic
Public Overridable Sub Append ( _
    item As IntersectionResult _
)
Visual C++
public:
virtual void Append(
    IntersectionResult^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..IntersectionResult

See Also

IntersectionResultArray Class


ForwardIterator Method

[image]

Revit 2024 API
IntersectionResultArray..::..ForwardIterator Method
IntersectionResultArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IntersectionResultArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As IntersectionResultArrayIterator
Visual C++
public:
virtual IntersectionResultArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

IntersectionResultArray Class


GetEnumerator Method

[image]

Revit 2024 API
IntersectionResultArray..::..GetEnumerator Method
IntersectionResultArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

IntersectionResultArray Class


ReverseIterator Method

[image]

Revit 2024 API
IntersectionResultArray..::..ReverseIterator Method
IntersectionResultArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IntersectionResultArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As IntersectionResultArrayIterator
Visual C++
public:
virtual IntersectionResultArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

IntersectionResultArray Class


IntersectionResultArray Properties

[image] [image]

Revit 2024 API
IntersectionResultArray Properties
IntersectionResultArray Class See Also Send Feedback

The IntersectionResultArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

IntersectionResultArray Class


IsEmpty Property

[image]

Revit 2024 API
IntersectionResultArray..::..IsEmpty Property
IntersectionResultArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

IntersectionResultArray Class


Item Property

[image]

Revit 2024 API
IntersectionResultArray..::..Item Property
IntersectionResultArray Class See Also Send Feedback
Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IntersectionResult this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As IntersectionResult
    Get
    Set
Visual C++
public:
virtual property IntersectionResult^ Item[int index] {
    IntersectionResult^ get (int index);
    void set (int index, IntersectionResult^ value);
}

Parameters

index
Type: System..::..Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

IntersectionResultArray Class


Size Property

[image]

Revit 2024 API
IntersectionResultArray..::..Size Property
IntersectionResultArray Class See Also Send Feedback
Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

IntersectionResultArray Class


IntersectionResultArrayIterator Class

[image]

Revit 2024 API
IntersectionResultArrayIterator Class
Members See Also Send Feedback
An iterator to a array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public abstract class IntersectionResultArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class IntersectionResultArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class IntersectionResultArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..IntersectionResultArrayIterator

See Also

IntersectionResultArrayIterator Members


IntersectionResultArrayIterator Members

[image] [image]

Revit 2024 API
IntersectionResultArrayIterator Members
IntersectionResultArrayIterator Class Constructors Methods Properties See Also Send Feedback

The IntersectionResultArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | IntersectionResultArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

IntersectionResultArrayIterator Class


IntersectionResultArrayIterator Constructor

[image]

Revit 2024 API
IntersectionResultArrayIterator Constructor
IntersectionResultArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public IntersectionResultArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
IntersectionResultArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

IntersectionResultArrayIterator Class


IntersectionResultArrayIterator Methods

[image] [image]

Revit 2024 API
IntersectionResultArrayIterator Methods
IntersectionResultArrayIterator Class See Also Send Feedback

The IntersectionResultArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

IntersectionResultArrayIterator Class


MoveNext Method

[image]

Revit 2024 API
IntersectionResultArrayIterator..::..MoveNext Method
IntersectionResultArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

IntersectionResultArrayIterator Class


IntersectionResultArrayIterator Properties

[image] [image]

Revit 2024 API
IntersectionResultArrayIterator Properties
IntersectionResultArrayIterator Class See Also Send Feedback

The IntersectionResultArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

IntersectionResultArrayIterator Class


Current Property

[image]

Revit 2024 API
IntersectionResultArrayIterator..::..Current Property
IntersectionResultArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

IntersectionResultArrayIterator Class


IOnLocalLinkSharedCoordinatesSavedCallback Interface

[image]

Revit 2024 API
IOnLocalLinkSharedCoordinatesSavedCallback Interface
Members See Also Send Feedback
A callback for notifying an IExternalResourceServer that shared coordinates changes have been saved back to one of the Revit or DWG links provided by that server.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public interface IOnLocalLinkSharedCoordinatesSavedCallback
Visual Basic
Public Interface IOnLocalLinkSharedCoordinatesSavedCallback
Visual C++
public interface class IOnLocalLinkSharedCoordinatesSavedCallback

Remarks

Revit will call OnLocalLinkSharedCoordinatesSaved whenever shared coordinates changes are saved to a linked document which is provided by an external server. This is a notification to the server provider so they can copy the updated link back up to their server.

See Also

IOnLocalLinkSharedCoordinatesSavedCallback Members


IOnLocalLinkSharedCoordinatesSavedCallback Members

[image] [image]

Revit 2024 API
IOnLocalLinkSharedCoordinatesSavedCallback Members
IOnLocalLinkSharedCoordinatesSavedCallback Interface Methods See Also Send Feedback

The IOnLocalLinkSharedCoordinatesSavedCallback type exposes the following members.

Methods

 | Name | Description
Public method | OnLocalLinkSharedCoordinatesSaved | Revit will call this method whenever shared coordinates changes are saved to a linked document provided by an IExternalResourceServer. This call is a notification to the server provider that one of their Revit or DWG links has changed locally, and they should upload the new version back to their server.

See Also

IOnLocalLinkSharedCoordinatesSavedCallback Interface


IOnLocalLinkSharedCoordinatesSavedCallback Methods

[image] [image]

Revit 2024 API
IOnLocalLinkSharedCoordinatesSavedCallback Methods
IOnLocalLinkSharedCoordinatesSavedCallback Interface See Also Send Feedback

The IOnLocalLinkSharedCoordinatesSavedCallback type exposes the following members.

Methods

 | Name | Description
Public method | OnLocalLinkSharedCoordinatesSaved | Revit will call this method whenever shared coordinates changes are saved to a linked document provided by an IExternalResourceServer. This call is a notification to the server provider that one of their Revit or DWG links has changed locally, and they should upload the new version back to their server.

See Also

IOnLocalLinkSharedCoordinatesSavedCallback Interface


OnLocalLinkSharedCoordinatesSaved Method

[image]

Revit 2024 API
IOnLocalLinkSharedCoordinatesSavedCallback..::..OnLocalLinkSharedCoordinatesSaved Method
IOnLocalLinkSharedCoordinatesSavedCallback Interface See Also Send Feedback
Revit will call this method whenever shared coordinates changes are saved to a linked document provided by an IExternalResourceServer. This call is a notification to the server provider that one of their Revit or DWG links has changed locally, and they should upload the new version back to their server.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
void OnLocalLinkSharedCoordinatesSaved(
    ExternalResourceReference changedResource
)
Visual Basic
Sub OnLocalLinkSharedCoordinatesSaved ( _
    changedResource As ExternalResourceReference _
)
Visual C++
void OnLocalLinkSharedCoordinatesSaved(
    ExternalResourceReference^ changedResource
)

Parameters

changedResource
Type: Autodesk.Revit.DB..::..ExternalResourceReference
The ExternalResourceReference whose shared coordinates have been saved.

See Also

IOnLocalLinkSharedCoordinatesSavedCallback Interface


IOpenFromCloudCallback Interface

[image]

Revit 2024 API
IOpenFromCloudCallback Interface
Members Example See Also Send Feedback
An interface that may be used to control Revit's behavior when opening a cloud model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public interface IOpenFromCloudCallback
Visual Basic
Public Interface IOpenFromCloudCallback
Visual C++
public interface class IOpenFromCloudCallback

Examples

CopyC#
class OpenFromCloudCallback : IOpenFromCloudCallback
{
   public OpenConflictResult OnOpenConflict(OpenConflictScenario scenario)
   {
      switch (scenario)
      {
         case OpenConflictScenario.OutOfDate:
            // Continue to open the model so that I can save my local changes to the central model
            return OpenConflictResult.KeepLocalChanges;

         case OpenConflictScenario.VersionArchived:
            // My local model is far behind the central model, so discard my local changes regardless what they are
            return OpenConflictResult.DiscardLocalChangesAndOpenLatestVersion;

         case OpenConflictScenario.Relinquished:
         case OpenConflictScenario.Rollback:
            // Detach the loal model from its central model, to examine local changes
            return OpenConflictResult.DetachFromCentral;
      }

      return OpenConflictResult.Cancel;
   }
}

static Document OpenCloudModelWithCallback(Application application, ModelPath modelPath)
{
   OpenOptions options = new OpenOptions();
   OpenFromCloudCallback callback = new OpenFromCloudCallback();

   return application.OpenDocumentFile(modelPath, options, callback);
}

See Also

IOpenFromCloudCallback Members


IOpenFromCloudCallback Methods

[image] [image]

Revit 2024 API
IOpenFromCloudCallback Methods
IOpenFromCloudCallback Interface See Also Send Feedback

The IOpenFromCloudCallback type exposes the following members.

Methods

 | Name | Description
Public method | OnOpenConflict | A method called when the conflict is happen during the model opening.

See Also

IOpenFromCloudCallback Interface


OnOpenConflict Method

[image]

Revit 2024 API
IOpenFromCloudCallback..::..OnOpenConflict Method
IOpenFromCloudCallback Interface See Also Send Feedback
A method called when the conflict is happen during the model opening.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
OpenConflictResult OnOpenConflict(
    OpenConflictScenario scenario
)
Visual Basic
Function OnOpenConflict ( _
    scenario As OpenConflictScenario _
) As OpenConflictResult
Visual C++
OpenConflictResult OnOpenConflict(
    OpenConflictScenario scenario
)

Parameters

scenario
Type: Autodesk.Revit.DB..::..OpenConflictScenario
The scenario of the conflict.

Return Value

Returns the result to indicate whether to keep the unsynchronized change, or open the latest version or cancel the open action.

See Also

IOpenFromCloudCallback Interface


IPerformanceAdviserRule Interface

[image]

Revit 2024 API
IPerformanceAdviserRule Interface
Members See Also Send Feedback
Base class to derive specific performance adviser rules from.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public interface IPerformanceAdviserRule
Visual Basic
Public Interface IPerformanceAdviserRule
Visual C++
public interface class IPerformanceAdviserRule

See Also

IPerformanceAdviserRule Members


IPerformanceAdviserRule Members

[image] [image]

Revit 2024 API
IPerformanceAdviserRule Members
IPerformanceAdviserRule Interface Methods See Also Send Feedback

The IPerformanceAdviserRule type exposes the following members.

Methods

 | Name | Description
Public method | ExecuteElementCheck | Invoked by performance advisor for each element to be checked.
Public method | FinalizeCheck | Invoked by performance advisor once in the end of the check.
Public method | GetDescription | Retrieves the description of the rule.
Public method | GetElementFilter | Retrieves a filter to restrict elements to be checked.
Public method | GetName | Retrieves the name of the rule.
Public method | InitCheck | Invoked by performance advisor once in the beginning of the check. If rule checks document as a whole, the check can be performed in this method.
Public method | WillCheckElements | Reports if rule needs to be executed on individual elements.

See Also

IPerformanceAdviserRule Interface


IPerformanceAdviserRule Methods

[image] [image]

Revit 2024 API
IPerformanceAdviserRule Methods
IPerformanceAdviserRule Interface See Also Send Feedback

The IPerformanceAdviserRule type exposes the following members.

Methods

 | Name | Description
Public method | ExecuteElementCheck | Invoked by performance advisor for each element to be checked.
Public method | FinalizeCheck | Invoked by performance advisor once in the end of the check.
Public method | GetDescription | Retrieves the description of the rule.
Public method | GetElementFilter | Retrieves a filter to restrict elements to be checked.
Public method | GetName | Retrieves the name of the rule.
Public method | InitCheck | Invoked by performance advisor once in the beginning of the check. If rule checks document as a whole, the check can be performed in this method.
Public method | WillCheckElements | Reports if rule needs to be executed on individual elements.

See Also

IPerformanceAdviserRule Interface


ExecuteElementCheck Method

[image]

Revit 2024 API
IPerformanceAdviserRule..::..ExecuteElementCheck Method
IPerformanceAdviserRule Interface See Also Send Feedback
Invoked by performance advisor for each element to be checked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
void ExecuteElementCheck(
    Document document,
    Element element
)
Visual Basic
Sub ExecuteElementCheck ( _
    document As Document, _
    element As Element _
)
Visual C++
void ExecuteElementCheck(
    Document^ document,
    Element^ element
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Document for which performance problems are being checked.
element
Type: Autodesk.Revit.DB..::..Element
The Element being checked for performance problems.

See Also

IPerformanceAdviserRule Interface


FinalizeCheck Method

[image]

Revit 2024 API
IPerformanceAdviserRule..::..FinalizeCheck Method
IPerformanceAdviserRule Interface See Also Send Feedback
Invoked by performance advisor once in the end of the check.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
void FinalizeCheck(
    Document document
)
Visual Basic
Sub FinalizeCheck ( _
    document As Document _
)
Visual C++
void FinalizeCheck(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Document for which performance problems are being checked.

See Also

IPerformanceAdviserRule Interface


GetDescription Method

[image]

Revit 2024 API
IPerformanceAdviserRule..::..GetDescription Method
IPerformanceAdviserRule Interface See Also Send Feedback
Retrieves the description of the rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
string GetDescription()
Visual Basic
Function GetDescription As String
Visual C++
String^ GetDescription()

Return Value

The description of the rule.

Remarks

Method should return a brief (one-two sentences) description of the rule. String should be localized.

See Also

IPerformanceAdviserRule Interface


GetElementFilter Method

[image]

Revit 2024 API
IPerformanceAdviserRule..::..GetElementFilter Method
IPerformanceAdviserRule Interface See Also Send Feedback
Retrieves a filter to restrict elements to be checked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
ElementFilter GetElementFilter(
    Document document
)
Visual Basic
Function GetElementFilter ( _
    document As Document _
) As ElementFilter
Visual C++
ElementFilter^ GetElementFilter(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Document for which performance problems are being checked.

Return Value

The filter to restrict elements to be checked.

Remarks

If the rule needs to be executed on individual elements, it should return a filter that defines what elements the rule should apply to. Otherwise, nothing (i.e. null) should be returned. If filter is returned, it should stay valid till the end of the check.

See Also

IPerformanceAdviserRule Interface


GetName Method

[image]

Revit 2024 API
IPerformanceAdviserRule..::..GetName Method
IPerformanceAdviserRule Interface See Also Send Feedback
Retrieves the name of the rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
string GetName()
Visual Basic
Function GetName As String
Visual C++
String^ GetName()

Return Value

The name of the rule.

Remarks

Method should return a short string naming the rule, typically as a one word in TitleCase. String should be localized.

See Also

IPerformanceAdviserRule Interface


InitCheck Method

[image]

Revit 2024 API
IPerformanceAdviserRule..::..InitCheck Method
IPerformanceAdviserRule Interface See Also Send Feedback
Invoked by performance advisor once in the beginning of the check. If rule checks document as a whole, the check can be performed in this method.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
void InitCheck(
    Document document
)
Visual Basic
Sub InitCheck ( _
    document As Document _
)
Visual C++
void InitCheck(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Document for which performance problems are being checked.

See Also

IPerformanceAdviserRule Interface


IPhotoRenderContext Members

[image] [image]

Revit 2024 API
IPhotoRenderContext Members
IPhotoRenderContext Interface Methods See Also Send Feedback

The IPhotoRenderContext type exposes the following members.

Methods

 | Name | Description
Public method | Finish | This method is called at the very end of the export process, after all entities were processed (or after the process was cancelled). (Inherited from IExportContext.)
Public method | IsCanceled | This method is queried at the beginning of every element. (Inherited from IExportContext.)
Public method | OnElementBegin | This method marks the beginning of an element to be exported. (Inherited from IExportContext.)
Public method | OnElementEnd | This method marks the end of an element being exported. (Inherited from IExportContext.)
Public method | OnFaceBegin | This method marks the beginning of a Face to be exported. (Inherited from IExportContext.)
Public method | OnFaceEnd | This method marks the end of the current face being exported. (Inherited from IExportContext.)
Public method | OnInstanceBegin | This method marks the start of processing of an instance node (e.g. a family instance). (Inherited from IExportContext.)
Public method | OnInstanceEnd | This method marks the end of processing of an Instance Node (e.g. a family instance). (Inherited from IExportContext.)
Public method | OnLight | This method marks the beginning of export of a light which is enabled for rendering. (Inherited from IExportContext.)
Public method | OnLinkBegin | This method marks the beginning of a link instance to be exported. (Inherited from IExportContext.)
Public method | OnLinkEnd | This method marks the end of a link instance being exported. (Inherited from IExportContext.)
Public method | OnMaterial | This method marks a change of the material. (Inherited from IExportContext.)
Public method | OnPolymesh | This method is called when a tessellated polymesh of a 3d face is being output. (Inherited from IExportContext.)
Public method | OnRPC | This method marks the beginning of export of an RPC object. (Inherited from IExportContext.)
Public method | OnViewBegin | This method marks the beginning of a 3D view to be exported. (Inherited from IExportContext.)
Public method | OnViewEnd | This method marks the end of a 3D view being exported. (Inherited from IExportContext.)
Public method | Start | This method is called at the very start of the export process, still before the first entity of the model was send out. (Inherited from IExportContext.)

See Also

IPhotoRenderContext Interface


IPhotoRenderContext Methods

[image] [image]

Revit 2024 API
IPhotoRenderContext Methods
IPhotoRenderContext Interface See Also Send Feedback

The IPhotoRenderContext type exposes the following members.

Methods

 | Name | Description
Public method | Finish | This method is called at the very end of the export process, after all entities were processed (or after the process was cancelled). (Inherited from IExportContext.)
Public method | IsCanceled | This method is queried at the beginning of every element. (Inherited from IExportContext.)
Public method | OnElementBegin | This method marks the beginning of an element to be exported. (Inherited from IExportContext.)
Public method | OnElementEnd | This method marks the end of an element being exported. (Inherited from IExportContext.)
Public method | OnFaceBegin | This method marks the beginning of a Face to be exported. (Inherited from IExportContext.)
Public method | OnFaceEnd | This method marks the end of the current face being exported. (Inherited from IExportContext.)
Public method | OnInstanceBegin | This method marks the start of processing of an instance node (e.g. a family instance). (Inherited from IExportContext.)
Public method | OnInstanceEnd | This method marks the end of processing of an Instance Node (e.g. a family instance). (Inherited from IExportContext.)
Public method | OnLight | This method marks the beginning of export of a light which is enabled for rendering. (Inherited from IExportContext.)
Public method | OnLinkBegin | This method marks the beginning of a link instance to be exported. (Inherited from IExportContext.)
Public method | OnLinkEnd | This method marks the end of a link instance being exported. (Inherited from IExportContext.)
Public method | OnMaterial | This method marks a change of the material. (Inherited from IExportContext.)
Public method | OnPolymesh | This method is called when a tessellated polymesh of a 3d face is being output. (Inherited from IExportContext.)
Public method | OnRPC | This method marks the beginning of export of an RPC object. (Inherited from IExportContext.)
Public method | OnViewBegin | This method marks the beginning of a 3D view to be exported. (Inherited from IExportContext.)
Public method | OnViewEnd | This method marks the end of a 3D view being exported. (Inherited from IExportContext.)
Public method | Start | This method is called at the very start of the export process, still before the first entity of the model was send out. (Inherited from IExportContext.)

See Also

IPhotoRenderContext Interface


IPrintSetting Members

[image] [image]

Revit 2024 API
IPrintSetting Members
IPrintSetting Interface Properties See Also Send Feedback

The IPrintSetting type exposes the following members.

Properties

 | Name | Description
Public property | PrintParameters | Returns the Parameters of Print Setup.

See Also

IPrintSetting Interface


IPrintSetting Properties

[image] [image]

Revit 2024 API
IPrintSetting Properties
IPrintSetting Interface See Also Send Feedback

The IPrintSetting type exposes the following members.

Properties

 | Name | Description
Public property | PrintParameters | Returns the Parameters of Print Setup.

See Also

IPrintSetting Interface


PrintParameters Property

[image]

Revit 2024 API
IPrintSetting..::..PrintParameters Property
IPrintSetting Interface See Also Send Feedback
Returns the Parameters of Print Setup.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
PrintParameters PrintParameters { get; }
Visual Basic
ReadOnly Property PrintParameters As PrintParameters
    Get
Visual C++
property PrintParameters^ PrintParameters {
    PrintParameters^ get ();
}

Remarks

The Parameters of Print Setup. Refer to the Print Setup dialog in Revit for details.

See Also

IPrintSetting Interface


ISaveSharedCoordinatesCallback Methods

[image] [image]

Revit 2024 API
ISaveSharedCoordinatesCallback Methods
ISaveSharedCoordinatesCallback Interface See Also Send Feedback

The ISaveSharedCoordinatesCallback type exposes the following members.

Methods

 | Name | Description
Public method | GetSaveModifiedLinksOption | Determines whether Revit should save the link, not save the link, or discard shared positioning entirely.

See Also

ISaveSharedCoordinatesCallback Interface


ISaveSharedCoordinatesCallbackForUnloadLocally Interface

[image]

Revit 2024 API
ISaveSharedCoordinatesCallbackForUnloadLocally Interface
Members See Also Send Feedback
An interface that is used to control Revit when trying to unload locally a Revit link with changes in shared coordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public interface ISaveSharedCoordinatesCallbackForUnloadLocally
Visual Basic
Public Interface ISaveSharedCoordinatesCallbackForUnloadLocally
Visual C++
public interface class ISaveSharedCoordinatesCallbackForUnloadLocally

See Also

ISaveSharedCoordinatesCallbackForUnloadLocally Members


ISaveSharedCoordinatesCallbackForUnloadLocally Members

[image] [image]

Revit 2024 API
ISaveSharedCoordinatesCallbackForUnloadLocally Members
ISaveSharedCoordinatesCallbackForUnloadLocally Interface Methods See Also Send Feedback

The ISaveSharedCoordinatesCallbackForUnloadLocally type exposes the following members.

Methods

 | Name | Description
Public method | GetSaveModifiedLinksOptionForUnloadLocally | Determines whether Revit should save the link or not prior to unloading the link locally.

See Also

ISaveSharedCoordinatesCallbackForUnloadLocally Interface


ISaveSharedCoordinatesCallbackForUnloadLocally Methods

[image] [image]

Revit 2024 API
ISaveSharedCoordinatesCallbackForUnloadLocally Methods
ISaveSharedCoordinatesCallbackForUnloadLocally Interface See Also Send Feedback

The ISaveSharedCoordinatesCallbackForUnloadLocally type exposes the following members.

Methods

 | Name | Description
Public method | GetSaveModifiedLinksOptionForUnloadLocally | Determines whether Revit should save the link or not prior to unloading the link locally.

See Also

ISaveSharedCoordinatesCallbackForUnloadLocally Interface


GetSaveModifiedLinksOptionForUnloadLocally Method

[image]

Revit 2024 API
ISaveSharedCoordinatesCallbackForUnloadLocally..::..GetSaveModifiedLinksOptionForUnloadLocally Method
ISaveSharedCoordinatesCallbackForUnloadLocally Interface See Also Send Feedback
Determines whether Revit should save the link or not prior to unloading the link locally.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
SaveModifiedLinksOptionsForUnloadLocally GetSaveModifiedLinksOptionForUnloadLocally(
    RevitLinkType link
)
Visual Basic
Function GetSaveModifiedLinksOptionForUnloadLocally ( _
    link As RevitLinkType _
) As SaveModifiedLinksOptionsForUnloadLocally
Visual C++
SaveModifiedLinksOptionsForUnloadLocally GetSaveModifiedLinksOptionForUnloadLocally(
    RevitLinkType^ link
)

Parameters

link
Type: Autodesk.Revit.DB..::..RevitLinkType
The Revit link which has modified shared coordinates.

Return Value

The saving option when unloading locally a linked file which has been modified in-memory by shared coordinates operations.

See Also

ISaveSharedCoordinatesCallbackForUnloadLocally Interface


ITransactionFinalizer Members

[image] [image]

Revit 2024 API
ITransactionFinalizer Members
ITransactionFinalizer Interface Methods See Also Send Feedback

The ITransactionFinalizer type exposes the following members.

Methods

 | Name | Description
Public method | OnCommitted | This method is called at the end of committing a transaction
Public method | OnRolledBack | This method is called at the end of rolling back a transaction

See Also

ITransactionFinalizer Interface


ITransactionFinalizer Methods

[image] [image]

Revit 2024 API
ITransactionFinalizer Methods
ITransactionFinalizer Interface See Also Send Feedback

The ITransactionFinalizer type exposes the following members.

Methods

 | Name | Description
Public method | OnCommitted | This method is called at the end of committing a transaction
Public method | OnRolledBack | This method is called at the end of rolling back a transaction

See Also

ITransactionFinalizer Interface


OnCommitted Method

[image]

Revit 2024 API
ITransactionFinalizer..::..OnCommitted Method
ITransactionFinalizer Interface See Also Send Feedback
This method is called at the end of committing a transaction

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
void OnCommitted(
    Document document,
    string strTransactionName
)
Visual Basic
Sub OnCommitted ( _
    document As Document, _
    strTransactionName As String _
)
Visual C++
void OnCommitted(
    Document^ document,
    String^ strTransactionName
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document associated with the transaction
strTransactionName
Type: System..::..String
The transaction's name

See Also

ITransactionFinalizer Interface


OnRolledBack Method

[image]

Revit 2024 API
ITransactionFinalizer..::..OnRolledBack Method
ITransactionFinalizer Interface See Also Send Feedback
This method is called at the end of rolling back a transaction

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
void OnRolledBack(
    Document document,
    string strTransactionName
)
Visual Basic
Sub OnRolledBack ( _
    document As Document, _
    strTransactionName As String _
)
Visual C++
void OnRolledBack(
    Document^ document,
    String^ strTransactionName
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document associated with the transaction
strTransactionName
Type: System..::..String
The transaction's name

See Also

ITransactionFinalizer Interface


ITransientElementMaker Interface

[image]

Revit 2024 API
ITransientElementMaker Interface
Members See Also Send Feedback
The interface to be implemented by an application that creates transient element(s) in Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public interface ITransientElementMaker
Visual Basic
Public Interface ITransientElementMaker
Visual C++
public interface class ITransientElementMaker

Remarks

An instance of the implemented interface is passed as an argument to the Document.MakeTransientElements() method, which will call back the Execute method of the interface.

During the execution of the method Revit will allow creation of certain elements, such as DirectShape, and will make them automatically transient . See (IsTransient for more details about transient elements.)

The code within the Execute method is not allowed to modify the model in any other way. An attempt to change the model or create elements of other kinds will result in an exception. This indirectly means that methods using a transaction internally are not allowed either. Such methods include document Save and SaveAs, certain import and export methods, creating links, syncing with central, etc.

Regenerating the model is also not allowed for the entire duration of the Execute method.

This interface is passed to MakeTransientElements(ITransientElementMaker) which does the actual transient element creation.

See Also

ITransientElementMaker Members


ITransientElementMaker Methods

[image] [image]

Revit 2024 API
ITransientElementMaker Methods
ITransientElementMaker Interface See Also Send Feedback

The ITransientElementMaker type exposes the following members.

Methods

 | Name | Description
Public method | Execute | Implement this method to create transient elements.

See Also

ITransientElementMaker Interface


Execute Method

[image]

Revit 2024 API
ITransientElementMaker..::..Execute Method
ITransientElementMaker Interface See Also Send Feedback
Implement this method to create transient elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
void Execute()
Visual Basic
Sub Execute
Visual C++
void Execute()

See Also

ITransientElementMaker Interface


IUpdater Interface

[image]

Revit 2024 API
IUpdater Interface
Members Example See Also Send Feedback
The interface used to create an updater capable of reacting to changes in the Revit model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public interface IUpdater
Visual Basic
Public Interface IUpdater
Visual C++
public interface class IUpdater

Remarks

Implement this interface and register an instance of the derived class with the UpdaterRegistry.

Examples

CopyC#
public class WallUpdaterApplication : Autodesk.Revit.UI.IExternalApplication
{
    public Result OnStartup(UIControlledApplication application)
    {
        // Register wall updater with Revit
        WallUpdater updater = new WallUpdater(application.ActiveAddInId);
        UpdaterRegistry.RegisterUpdater(updater);

        // Change Scope = any Wall element
        ElementClassFilter wallFilter = new ElementClassFilter(typeof(Wall));

        // Change type = element addition
        UpdaterRegistry.AddTrigger(updater.GetUpdaterId(), wallFilter,
                                    Element.GetChangeTypeElementAddition());
        return Result.Succeeded;
    }

    public Result OnShutdown(UIControlledApplication application)
    {
        WallUpdater updater = new WallUpdater(application.ActiveAddInId);
        UpdaterRegistry.UnregisterUpdater(updater.GetUpdaterId());
        return Result.Succeeded;
    }
}

public class WallUpdater : IUpdater
{
    static AddInId m_appId;
    static UpdaterId m_updaterId;
    WallType m_wallType = null;

    // constructor takes the AddInId for the add-in associated with this updater
    public WallUpdater(AddInId id)
    {
        m_appId = id;
        m_updaterId = new UpdaterId(m_appId, new Guid("FBFBF6B2-4C06-42d4-97C1-D1B4EB593EFF"));
    }

    public void Execute(UpdaterData data)
    {
        Document doc = data.GetDocument();

        // Cache the wall type
        if (m_wallType == null)
        {
            FilteredElementCollector collector = new FilteredElementCollector(doc);
            collector.OfClass(typeof(WallType));
            var wallTypes = from element in collector
                            where
                                element.Name == "Exterior - Brick on CMU"
                            select element;
            if (wallTypes.Count<Element>() > 0)
            {
                m_wallType = wallTypes.Cast<WallType>().ElementAt<WallType>(0);
            }
        }

        if (m_wallType != null)
        {
            // Change the wall to the cached wall type.
            foreach (ElementId addedElemId in data.GetAddedElementIds())
            {
                Wall wall = doc.GetElement(addedElemId) as Wall;
                if (wall != null)
                {
                    wall.WallType = m_wallType;
                }
            }
        }
    }

    public string GetAdditionalInformation()
    {
        return "Wall type updater example: updates all newly created walls to a special wall";
    }

    public ChangePriority GetChangePriority()
    {
        return ChangePriority.FloorsRoofsStructuralWalls;
    }

    public UpdaterId GetUpdaterId()
    {
        return m_updaterId;
    }

    public string GetUpdaterName()
    {
        return "Wall Type Updater";
    }
}
CopyVB.NET
Public Class WallUpdaterApplication
    Implements Autodesk.Revit.UI.IExternalApplication
    Public Function OnStartup(application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnStartup
        ' Register wall updater with Revit
        Dim updater As New WallUpdater(application.ActiveAddInId)
        UpdaterRegistry.RegisterUpdater(updater)

        ' Change Scope = any Wall element
        Dim wallFilter As New ElementClassFilter(GetType(Wall))

        ' Change type = element addition
        UpdaterRegistry.AddTrigger(updater.GetUpdaterId(), wallFilter, Element.GetChangeTypeElementAddition())
        Return Result.Succeeded
    End Function

    Public Function OnShutdown(application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnShutdown
        Dim updater As New WallUpdater(application.ActiveAddInId)
        UpdaterRegistry.UnregisterUpdater(updater.GetUpdaterId())
        Return Result.Succeeded
    End Function
End Class

Public Class WallUpdater
    Implements IUpdater
    Shared m_appId As AddInId
    Shared m_updaterId As UpdaterId
    Private m_wallType As WallType = Nothing

    ' constructor takes the AddInId for the add-in associated with this updater
    Public Sub New(id As AddInId)
        m_appId = id
        m_updaterId = New UpdaterId(m_appId, New Guid("FBFBF6B2-4C06-42d4-97C1-D1B4EB593EFF"))
    End Sub

    Public Sub Execute(data As UpdaterData) Implements IUpdater.Execute
        Dim doc As Document = data.GetDocument()

        ' Cache the wall type
        If m_wallType Is Nothing Then
            Dim collector As New FilteredElementCollector(doc)
            collector.OfClass(GetType(WallType))
            Dim wallTypes As System.Collections.Generic.IEnumerable(Of Autodesk.Revit.DB.Element)
            wallTypes = From element In collector _
             Where element.Name = "Exterior - Brick on CMU" _
             Select element
            If wallTypes.Count() > 0 Then
                m_wallType = wallTypes.Cast(Of WallType)().ElementAt(0)
            End If
        End If

        If m_wallType IsNot Nothing Then
            ' Change the wall to the cached wall type.
            For Each addedElemId As ElementId In data.GetAddedElementIds()
                Dim wall As Wall = TryCast(doc.GetElement(addedElemId), Wall)
                If wall IsNot Nothing Then
                    wall.WallType = m_wallType
                End If
            Next
        End If
    End Sub

    Public Function GetAdditionalInformation() As String Implements IUpdater.GetAdditionalInformation
        Return "Wall type updater example: updates all newly created walls to a special wall"
    End Function

    Public Function GetChangePriority() As ChangePriority Implements IUpdater.GetChangePriority
        Return ChangePriority.FloorsRoofsStructuralWalls
    End Function

    Public Function GetUpdaterId() As UpdaterId Implements IUpdater.GetUpdaterId
        Return m_updaterId
    End Function

    Public Function GetUpdaterName() As String Implements IUpdater.GetUpdaterName
        Return "Wall Type Updater"
    End Function
End Class

See Also

IUpdater Members


IUpdater Members

[image] [image]

Revit 2024 API
IUpdater Members
IUpdater Interface Methods See Also Send Feedback

The IUpdater type exposes the following members.

Methods

 | Name | Description
Public method | Execute | The method that Revit will invoke to perform an update.
Public method | GetAdditionalInformation | Auxiliary text that Revit will use to inform the end user when the Updater is not loaded
Public method | GetChangePriority | Identifies the nature of the change the Updater will be performing Used to identify order of execution of updaters Called once during registration of the updater
Public method | GetUpdaterId | Returns globally unique updater id - used to identify the Updater Called once during registration of the updater
Public method | GetUpdaterName | Returns a name that the Updater can be identified by to the user

See Also

IUpdater Interface


Execute Method

[image]

Revit 2024 API
IUpdater..::..Execute Method
IUpdater Interface See Also Send Feedback
The method that Revit will invoke to perform an update.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
void Execute(
    UpdaterData data
)
Visual Basic
Sub Execute ( _
    data As UpdaterData _
)
Visual C++
void Execute(
    UpdaterData^ data
)

Parameters

data
Type: Autodesk.Revit.DB..::..UpdaterData
Provides all necessary data needed to perform the update, including the document and information about the changes that triggered the update.

Remarks

The purpose of this method is to allow your updater to react to changes that have been made to the document, and make appropriate related changes to the same document. Although it can be used to also update data outside of the document, such changes will not become part of the original transaction and will not be subject to undo or redo when the original transaction is undone or redone. If you do use this method to modify data outside of the document, you should also subscribe to the DocumentChanged event to update your data when the original transaction is undone or redone.

The method is invoked by Revit at the end of a document transaction in which elements that matched the UpdateTrigger for this Updater were added, changed or deleted. The method may be invoked more than once for the same transaction due to changes made by other Updaters.

All changes to the document made during the invocation of this method will become a part of the invoking transaction, and maintained for undo and redo operations. When implementing this method you may not open any new transactions (an exception will be thrown), but you may use sub-transactions as required.

The following methods may not be called while executing an Updater, because they introduce cross references between elements. A ForbiddenForDynamicUpdateException will be thrown when an updater attempts to call any of these methods:

  • void Autodesk.Revit.DB.ViewSheet.AddView(Autodesk.Revit.DB.View, Autodesk.Revit.DB.UV)
  • Autodesk.Revit.DB.Family Autodesk.Revit.DB.Document.LoadFamily(Autodesk.Revit.DB.Document, Autodesk.Revit.DB.IFamilyLoadOptions)
  • Autodesk.Revit.DB.Structure.AreaReinforcement Autodesk.Revit.Creation.Document.NewAreaReinforcement(Autodesk.Revit.DB.Element, Autodesk.Revit.DB.CurveArray, Autodesk.Revit.DB.XYZ)
  • Autodesk.Revit.DB.Structure.PathReinforcement Autodesk.Revit.Creation.Document.NewPathReinforcement(Autodesk.Revit.DB.Element, Autodesk.Revit.DB.CurveArray, bool)
  • void Autodesk.Revit.DB.MEPSystem.Add(Autodesk.Revit.DB.ConnectorSet)

Although the following methods are allowed during execution of an updater, they can also throw ForbiddenForDynamicUpdateException when cross-references between elements are established as a result of the call. One such example could be creating a face wall that intersect with an existing face wall, so those two would have to be joined together. Apply caution when calling these methods from an updater:

  • Autodesk.Revit.DB.ElementSet Autodesk.Revit.Creation.ItemFactoryBase.NewFamilyInstances(System.Collections.Generic.List<Autodesk.Revit.Creation.FamilyInstanceCreationData>)
  • Autodesk.Revit.DB.FamilyInstance Autodesk.Revit.Creation.ItemFactoryBase.NewFamilyInstance(Autodesk.Revit.DB.XYZ, Autodesk.Revit.DB.FamilySymbol, Autodesk.Revit.DB.Element,Autodesk.Revit.DB.Structure.StructuralType)
  • Autodesk.Revit.DB.FamilyInstance Autodesk.Revit.Creation.ItemFactoryBase.NewFamilyInstance(Autodesk.Revit.DB.XYZ, Autodesk.Revit.DB.FamilySymbol, Autodesk.Revit.DB.Level,Autodesk.Revit.DB.Structure.StructuralType)
  • Autodesk.Revit.DB.FamilyInstance Autodesk.Revit.Creation.Document.NewFamilyInstance(Autodesk.Revit.DB.XYZ, Autodesk.Revit.DB.FamilySymbol, Autodesk.Revit.DB.Element, Autodesk.Revit.DB.Level, Autodesk.Revit.DB.Structure.StructuralType)
  • Autodesk.Revit.DB.FaceWall Autodesk.Revit.DB.FaceWall.Create(Autodesk.Revit.DB.Document, Autodesk.Revit.DB.ElementId, Autodesk.Revit.DB.WallLocationLine, Autodesk.Revit.DB.Reference)

Some UI methods may not be called while executing an Updater too, otherwise ForbiddenForDynamicUpdateException will be thrown. Such methods include: PickObject, PickObjects, PickElementsByRectangle, PickPoint, PickOne and WindowSelect.

Also, most of the methods of the UpdaterRegistry class may not be called during an updater's execution otherwise an InvalidOperationException would be thrown.

In addition to the forbidden methods listed above, other API methods that require documents to be in transaction-free state may not be called either. Such methods include but are not limited to Save, SaveAs, Close, LoadFamily, etc. Please refer to the documentation of the respective methods for more information.

See Also

IUpdater Interface


GetAdditionalInformation Method

[image]

Revit 2024 API
IUpdater..::..GetAdditionalInformation Method
IUpdater Interface See Also Send Feedback
Auxiliary text that Revit will use to inform the end user when the Updater is not loaded

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
string GetAdditionalInformation()
Visual Basic
Function GetAdditionalInformation As String
Visual C++
String^ GetAdditionalInformation()

See Also

IUpdater Interface


GetChangePriority Method

[image]

Revit 2024 API
IUpdater..::..GetChangePriority Method
IUpdater Interface See Also Send Feedback
Identifies the nature of the change the Updater will be performing Used to identify order of execution of updaters Called once during registration of the updater

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
ChangePriority GetChangePriority()
Visual Basic
Function GetChangePriority As ChangePriority
Visual C++
ChangePriority GetChangePriority()

See Also

IUpdater Interface


GetUpdaterName Method

[image]

Revit 2024 API
IUpdater..::..GetUpdaterName Method
IUpdater Interface See Also Send Feedback
Returns a name that the Updater can be identified by to the user

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
string GetUpdaterName()
Visual Basic
Function GetUpdaterName As String
Visual C++
String^ GetUpdaterName()

See Also

IUpdater Interface


IViewSheetSet Interface

[image]

Revit 2024 API
IViewSheetSet Interface
Members Example See Also Send Feedback
This interface represents a selected set of views/sheets which will be used for printing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public interface IViewSheetSet
Visual Basic
Public Interface IViewSheetSet
Visual C++
public interface class IViewSheetSet

Examples

CopyC#
private void SwitchToAutomaticOrder(Document doc, ViewSheetSetting viewSheetSetting)
{
   IViewSheetSet viewSheetSet = viewSheetSetting.CurrentViewSheetSet;
   var sheetBrowserOrg = BrowserOrganization.GetCurrentBrowserOrganizationForSheets(doc);
   var viewBrowserOrg = BrowserOrganization.GetCurrentBrowserOrganizationForViews(doc);
   viewSheetSet.SheetOrganizationId = sheetBrowserOrg.Id;
   viewSheetSet.ViewOrganizationId = viewBrowserOrg.Id;
   viewSheetSet.IsAutomatic = true; // IsAutomatic must be true then views and sheets will be ordered by Browser Organization
}

private void SwitchToCustomOrder(Document doc, ViewSheetSetting viewSheetSetting, IReadOnlyList<View> customViews)
{
   IViewSheetSet viewSheetSet = viewSheetSetting.CurrentViewSheetSet;
   // IsAutomatic must be false, then OrderedViewList will be organized in custom order
   // Note that the moment you set IsAutomatic from true to false, the order in OrderedViewList will be organized by Browser Organization
   viewSheetSet.IsAutomatic = false; // IMPORTANT: IsAutomatic before assigning OrderedViewList
   viewSheetSet.OrderedViewList = customViews;
}
CopyVB.NET
Private Sub SwitchToAutomaticOrder(ByVal doc As Document, ByVal viewSheetSetting As ViewSheetSetting)
    Dim viewSheetSet = viewSheetSetting.CurrentViewSheetSet
    Dim sheetBrowserOrg = BrowserOrganization.GetCurrentBrowserOrganizationForSheets(doc)
    Dim viewBrowserOrg = BrowserOrganization.GetCurrentBrowserOrganizationForViews(doc)
    viewSheetSet.SheetOrganizationId = sheetBrowserOrg.Id
    viewSheetSet.ViewOrganizationId = viewBrowserOrg.Id
    viewSheetSet.IsAutomatic = True ' IsAutomatic must be true then views and sheets will be ordered by Browser Organization
End Sub

Private Sub SwitchToCustomOrder(ByVal doc As Document, ByVal viewSheetSetting As ViewSheetSetting, ByVal customViews As IReadOnlyList(Of View))
    Dim viewSheetSet = viewSheetSetting.CurrentViewSheetSet
    ' IsAutomatic must be false, then OrderedViewList will be organized in custom order
    ' Note that the moment you set IsAutomatic from true to false, the order in OrderedViewList will be organized by Browser Organization
    viewSheetSet.IsAutomatic = False ' IMPORTANT: IsAutomatic before assigning OrderedViewList
    viewSheetSet.OrderedViewList = customViews
End Sub

See Also

IViewSheetSet Members


IViewSheetSet Members

[image] [image]

Revit 2024 API
IViewSheetSet Members
IViewSheetSet Interface Properties See Also Send Feedback

The IViewSheetSet type exposes the following members.

Properties

 | Name | Description
Public property | IsAutomatic | Automatic order or manual order.
Public property | OrderedViewList | Ordered views.
Public property | SheetOrganizationId | ElementId to the BrowserOrganization for sheets.
Public property | ViewOrganizationId | ElementId to the BrowserOrganization for non-sheet views.
Public property | Views | The views.

See Also

IViewSheetSet Interface


IViewSheetSet Properties

[image] [image]

Revit 2024 API
IViewSheetSet Properties
IViewSheetSet Interface See Also Send Feedback

The IViewSheetSet type exposes the following members.

Properties

 | Name | Description
Public property | IsAutomatic | Automatic order or manual order.
Public property | OrderedViewList | Ordered views.
Public property | SheetOrganizationId | ElementId to the BrowserOrganization for sheets.
Public property | ViewOrganizationId | ElementId to the BrowserOrganization for non-sheet views.
Public property | Views | The views.

See Also

IViewSheetSet Interface


IsAutomatic Property

[image]

Revit 2024 API
IViewSheetSet..::..IsAutomatic Property
IViewSheetSet Interface See Also Send Feedback
Automatic order or manual order.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
bool IsAutomatic { get; set; }
Visual Basic
Property IsAutomatic As Boolean
    Get
    Set
Visual C++
property bool IsAutomatic {
    bool get ();
    void set (bool value);
}

See Also

IViewSheetSet Interface


SheetOrganizationId Property

[image]

Revit 2024 API
IViewSheetSet..::..SheetOrganizationId Property
IViewSheetSet Interface See Also Send Feedback
ElementId to the BrowserOrganization for sheets.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
ElementId SheetOrganizationId { get; set; }
Visual Basic
Property SheetOrganizationId As ElementId
    Get
    Set
Visual C++
property ElementId^ SheetOrganizationId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the ElementId does not reference to BrowserOrganization, or the target type of BrowserOrganization is incompatible.

See Also

IViewSheetSet Interface


Views Property

[image]

Revit 2024 API
IViewSheetSet..::..Views Property
IViewSheetSet Interface See Also Send Feedback
The views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
ViewSet Views { get; set; }
Visual Basic
Property Views As ViewSet
    Get
    Set
Visual C++
property ViewSet^ Views {
    ViewSet^ get ();
    void set (ViewSet^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input views is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the set operation failed due to invalid view which cannot be printed.

See Also

IViewSheetSet Interface


JoinGeometryUtils Class

[image]

Revit 2024 API
JoinGeometryUtils Class
Members See Also Send Feedback
Utilities for joining and unjoining elements, and for managing the order in which elements are joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static class JoinGeometryUtils
Visual Basic
Public NotInheritable Class JoinGeometryUtils
Visual C++
public ref class JoinGeometryUtils abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..JoinGeometryUtils

See Also

JoinGeometryUtils Members


JoinGeometryUtils Members

[image] [image]

Revit 2024 API
JoinGeometryUtils Members
JoinGeometryUtils Class Methods See Also Send Feedback

The JoinGeometryUtils type exposes the following members.

Methods

Name | Description
AreElementsJoined | Determines whether two elements are joined.
GetJoinedElements | Returns all elements joined to given element.
IsCuttingElementInJoin | Determines whether the first of two joined elements is cutting the second element.
JoinGeometry | Creates clean joins between two elements that share a common face.
SwitchJoinOrder | Reverses the order in which two elements are joined.
UnjoinGeometry | Removes a join between two elements.

See Also

JoinGeometryUtils Class


JoinGeometryUtils Methods

[image] [image]

Revit 2024 API
JoinGeometryUtils Methods
JoinGeometryUtils Class See Also Send Feedback

The JoinGeometryUtils type exposes the following members.

Methods

Name | Description
AreElementsJoined | Determines whether two elements are joined.
GetJoinedElements | Returns all elements joined to given element.
IsCuttingElementInJoin | Determines whether the first of two joined elements is cutting the second element.
JoinGeometry | Creates clean joins between two elements that share a common face.
SwitchJoinOrder | Reverses the order in which two elements are joined.
UnjoinGeometry | Removes a join between two elements.

See Also

JoinGeometryUtils Class


AreElementsJoined Method

[image]

Revit 2024 API
JoinGeometryUtils..::..AreElementsJoined Method
JoinGeometryUtils Class See Also Send Feedback
Determines whether two elements are joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static bool AreElementsJoined(
    Document document,
    Element firstElement,
    Element secondElement
)
Visual Basic
Public Shared Function AreElementsJoined ( _
    document As Document, _
    firstElement As Element, _
    secondElement As Element _
) As Boolean
Visual C++
public:
static bool AreElementsJoined(
    Document^ document,
    Element^ firstElement,
    Element^ secondElement
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document containing the two elements.
firstElement
Type: Autodesk.Revit.DB..::..Element
The first element.
secondElement
Type: Autodesk.Revit.DB..::..Element
The second element.

Return Value

True if the two elements are joined.

Remarks

This functionality is not available for family documents.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- The element firstElement was not found in the given document. -or- The element secondElement was not found in the given document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

JoinGeometryUtils Class


GetJoinedElements Method

[image]

Revit 2024 API
JoinGeometryUtils..::..GetJoinedElements Method
JoinGeometryUtils Class See Also Send Feedback
Returns all elements joined to given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static ICollection<ElementId> GetJoinedElements(
    Document document,
    Element element
)
Visual Basic
Public Shared Function GetJoinedElements ( _
    document As Document, _
    element As Element _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetJoinedElements(
    Document^ document,
    Element^ element
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document containing the element.
element
Type: Autodesk.Revit.DB..::..Element
The element.

Return Value

The set of elements that are joined to the given element.

Remarks

This functionality is not available for family documents.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- The element element was not found in the given document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

JoinGeometryUtils Class


IsCuttingElementInJoin Method

[image]

Revit 2024 API
JoinGeometryUtils..::..IsCuttingElementInJoin Method
JoinGeometryUtils Class See Also Send Feedback
Determines whether the first of two joined elements is cutting the second element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static bool IsCuttingElementInJoin(
    Document document,
    Element firstElement,
    Element secondElement
)
Visual Basic
Public Shared Function IsCuttingElementInJoin ( _
    document As Document, _
    firstElement As Element, _
    secondElement As Element _
) As Boolean
Visual C++
public:
static bool IsCuttingElementInJoin(
    Document^ document,
    Element^ firstElement,
    Element^ secondElement
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document containing the two elements.
firstElement
Type: Autodesk.Revit.DB..::..Element
The first element.
secondElement
Type: Autodesk.Revit.DB..::..Element
The second element.

Return Value

True if the secondElement is cut by the firstElement, false if the secondElement is cut by the firstElement.

Remarks

This functionality is not available for family documents.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- The element firstElement was not found in the given document. -or- The element secondElement was not found in the given document. -or- The elements are not joined.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

JoinGeometryUtils Class


JoinGeometry Method

[image]

Revit 2024 API
JoinGeometryUtils..::..JoinGeometry Method
JoinGeometryUtils Class See Also Send Feedback
Creates clean joins between two elements that share a common face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static void JoinGeometry(
    Document document,
    Element firstElement,
    Element secondElement
)
Visual Basic
Public Shared Sub JoinGeometry ( _
    document As Document, _
    firstElement As Element, _
    secondElement As Element _
)
Visual C++
public:
static void JoinGeometry(
    Document^ document,
    Element^ firstElement,
    Element^ secondElement
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document containing the two elements.
firstElement
Type: Autodesk.Revit.DB..::..Element
The first element to be joined.
secondElement
Type: Autodesk.Revit.DB..::..Element
The second element to be joined. This element must not be joined to the first element.

Remarks

The visible edge between joined elements is removed. The joined elements then share the same line weight and fill pattern. This functionality is not available for family documents.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- The element firstElement was not found in the given document. -or- The element secondElement was not found in the given document. -or- The elements are already joined. -or- The elements cannot be joined.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | Please remove or add segments on curtain grids instead of joining or unjoining geometry of the panels.

See Also

JoinGeometryUtils Class


SwitchJoinOrder Method

[image]

Revit 2024 API
JoinGeometryUtils..::..SwitchJoinOrder Method
JoinGeometryUtils Class See Also Send Feedback
Reverses the order in which two elements are joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static void SwitchJoinOrder(
    Document document,
    Element firstElement,
    Element secondElement
)
Visual Basic
Public Shared Sub SwitchJoinOrder ( _
    document As Document, _
    firstElement As Element, _
    secondElement As Element _
)
Visual C++
public:
static void SwitchJoinOrder(
    Document^ document,
    Element^ firstElement,
    Element^ secondElement
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document containing the two elements.
firstElement
Type: Autodesk.Revit.DB..::..Element
The first element.
secondElement
Type: Autodesk.Revit.DB..::..Element
The second element. This element must be joined to the first element.

Remarks

The cutting element becomes the cut element and vice versa after the join order is switched. This functionality is not available for family documents.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- The element firstElement was not found in the given document. -or- The element secondElement was not found in the given document. -or- The elements are not joined. -or- The elements cannot be joined.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | Unable to switch the join order of these elements.

See Also

JoinGeometryUtils Class


UnjoinGeometry Method

[image]

Revit 2024 API
JoinGeometryUtils..::..UnjoinGeometry Method
JoinGeometryUtils Class See Also Send Feedback
Removes a join between two elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static void UnjoinGeometry(
    Document document,
    Element firstElement,
    Element secondElement
)
Visual Basic
Public Shared Sub UnjoinGeometry ( _
    document As Document, _
    firstElement As Element, _
    secondElement As Element _
)
Visual C++
public:
static void UnjoinGeometry(
    Document^ document,
    Element^ firstElement,
    Element^ secondElement
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document containing the two elements.
firstElement
Type: Autodesk.Revit.DB..::..Element
The first element to be unjoined.
secondElement
Type: Autodesk.Revit.DB..::..Element
The second element to be unjoined. This element must be joined to the fist element.

Remarks

This functionality is not available for family documents.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- The element firstElement was not found in the given document. -or- The element secondElement was not found in the given document. -or- The elements are not joined. -or- The elements cannot be unjoined.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | Please remove or add segments on curtain grids instead of joining or unjoining geometry of the panels.

See Also

JoinGeometryUtils Class


JunctionType Enumeration

[image]

Revit 2024 API
JunctionType Enumeration
See Also Send Feedback
An enumerated type listing all the junction types for MEP curve types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum JunctionType
Visual Basic
Public Enumeration JunctionType
Visual C++
public enum class JunctionType

Members

Member name | Description
Tap | The junction type is tap.
Tee | The junction type is tee.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


KeyBasedTreeEntries Class

[image]

Revit 2024 API
KeyBasedTreeEntries Class
Members See Also Send Feedback
A collection of KeyBasedTreeEntry objects that make up the key-based tree.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public class KeyBasedTreeEntries : IEnumerable<KeyBasedTreeEntry>,
    IDisposable
Visual Basic
Public Class KeyBasedTreeEntries _
    Implements IEnumerable(Of KeyBasedTreeEntry), IDisposable
Visual C++
public ref class KeyBasedTreeEntries : IEnumerable<KeyBasedTreeEntry^>,
    IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..KeyBasedTreeEntries
Autodesk.Revit.DB..::..ClassificationEntries
Autodesk.Revit.DB..::..KeynoteEntries

See Also

KeyBasedTreeEntries Members


KeyBasedTreeEntries Members

[image] [image]

Revit 2024 API
KeyBasedTreeEntries Members
KeyBasedTreeEntries Class Methods Properties See Also Send Feedback

The KeyBasedTreeEntries type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the KeyBasedTreeEntries
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindEntry | Finds the KeyBasedTreeEntry associated with the given key value.
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetKeyBasedTreeEntriesIterator | Returns a KeyBasedTreeEntriesIterator that iterates through the collection.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

KeyBasedTreeEntries Class


Dispose Method

[image]

Revit 2024 API
KeyBasedTreeEntries..::..Dispose Method
KeyBasedTreeEntries Class See Also Send Feedback
Releases all resources used by the KeyBasedTreeEntries

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

KeyBasedTreeEntries Class


FindEntry Method

[image]

Revit 2024 API
KeyBasedTreeEntries..::..FindEntry Method
KeyBasedTreeEntries Class See Also Send Feedback
Finds the KeyBasedTreeEntry associated with the given key value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public KeyBasedTreeEntry FindEntry(
    string key
)
Visual Basic
Public Function FindEntry ( _
    key As String _
) As KeyBasedTreeEntry
Visual C++
public:
KeyBasedTreeEntry^ FindEntry(
    String^ key
)

Parameters

key
Type: System..::..String
The specified key value.

Return Value

The KeyBasedTreeEntry corresponds to the given key value.

Remarks

If no matching KeyBasedTreeEntry can be found, null will be returned; The given key value cannot be an empty string.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | key is an empty string.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

KeyBasedTreeEntries Class


GetBasicIEnumerator Method

[image]

Revit 2024 API
KeyBasedTreeEntries..::..GetBasicIEnumerator Method
KeyBasedTreeEntries Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
internal virtual IEnumerator GetBasicIEnumerator()
Visual Basic
Friend Overridable Function GetBasicIEnumerator As IEnumerator
Visual C++
internal:
virtual IEnumerator^ GetBasicIEnumerator()

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

KeyBasedTreeEntries Class


GetKeyBasedTreeEntriesIterator Method

[image]

Revit 2024 API
KeyBasedTreeEntries..::..GetKeyBasedTreeEntriesIterator Method
KeyBasedTreeEntries Class See Also Send Feedback
Returns a KeyBasedTreeEntriesIterator that iterates through the collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public KeyBasedTreeEntriesIterator GetKeyBasedTreeEntriesIterator()
Visual Basic
Public Function GetKeyBasedTreeEntriesIterator As KeyBasedTreeEntriesIterator
Visual C++
public:
KeyBasedTreeEntriesIterator^ GetKeyBasedTreeEntriesIterator()

Return Value

A KeyBasedTreeEntriesIterator object that can be used to iterate through KeyBasedTreeEntry objects in the collection.

See Also

KeyBasedTreeEntries Class


KeyBasedTreeEntries Properties

[image] [image]

Revit 2024 API
KeyBasedTreeEntries Properties
KeyBasedTreeEntries Class See Also Send Feedback

The KeyBasedTreeEntries type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

KeyBasedTreeEntries Class


IsValidObject Property

[image]

Revit 2024 API
KeyBasedTreeEntries..::..IsValidObject Property
KeyBasedTreeEntries Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

KeyBasedTreeEntries Class


KeyBasedTreeEntriesIterator Members

[image] [image]

Revit 2024 API
KeyBasedTreeEntriesIterator Members
KeyBasedTreeEntriesIterator Class Methods Properties See Also Send Feedback

The KeyBasedTreeEntriesIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the KeyBasedTreeEntriesIterator
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next item.
Public method | Reset | Resets the iterator to the initial state.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

KeyBasedTreeEntriesIterator Class


KeyBasedTreeEntriesIterator Methods

[image] [image]

Revit 2024 API
KeyBasedTreeEntriesIterator Methods
KeyBasedTreeEntriesIterator Class See Also Send Feedback

The KeyBasedTreeEntriesIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next item.
Public method | Reset | Resets the iterator to the initial state.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

KeyBasedTreeEntriesIterator Class


Dispose Method

[image]

Revit 2024 API
KeyBasedTreeEntriesIterator..::..Dispose Method
KeyBasedTreeEntriesIterator Class See Also Send Feedback
Releases all resources used by the KeyBasedTreeEntriesIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

See Also

KeyBasedTreeEntriesIterator Class


IsDone Method

[image]

Revit 2024 API
KeyBasedTreeEntriesIterator..::..IsDone Method
KeyBasedTreeEntriesIterator Class See Also Send Feedback
Identifies if the iteration has completed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public virtual bool IsDone()
Visual Basic
Public Overridable Function IsDone As Boolean
Visual C++
public:
virtual bool IsDone()

Return Value

True if the iteration has no more items. False if there are more items to be iterated.

See Also

KeyBasedTreeEntriesIterator Class


Reset Method

[image]

Revit 2024 API
KeyBasedTreeEntriesIterator..::..Reset Method
KeyBasedTreeEntriesIterator Class See Also Send Feedback
Resets the iterator to the initial state.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

See Also

KeyBasedTreeEntriesIterator Class


KeyBasedTreeEntriesIterator Properties

[image] [image]

Revit 2024 API
KeyBasedTreeEntriesIterator Properties
KeyBasedTreeEntriesIterator Class See Also Send Feedback

The KeyBasedTreeEntriesIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

KeyBasedTreeEntriesIterator Class


Current Property

[image]

Revit 2024 API
KeyBasedTreeEntriesIterator..::..Current Property
KeyBasedTreeEntriesIterator Class See Also Send Feedback
Gets the item at the current position of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual KeyBasedTreeEntry Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As KeyBasedTreeEntry
    Get
Visual C++
public:
virtual property KeyBasedTreeEntry^ Current {
    KeyBasedTreeEntry^ get ();
}

Implements

IEnumerator<(Of <(<'T>)>)>..::..Current

Remarks

There is no current item if the iterator has not started yet or has been done.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | There is no current item in the iterator.

See Also

KeyBasedTreeEntriesIterator Class


CurrentObject Property

[image]

Revit 2024 API
KeyBasedTreeEntriesIterator..::..CurrentObject Property
KeyBasedTreeEntriesIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
internal Object CurrentObject { get; }
Visual Basic
Friend ReadOnly Property CurrentObject As Object
    Get
Visual C++
internal:
virtual property Object^ CurrentObject {
    Object^ get () sealed;
}

Implements

IEnumerator..::..Current

See Also

KeyBasedTreeEntriesIterator Class


IsValidObject Property

[image]

Revit 2024 API
KeyBasedTreeEntriesIterator..::..IsValidObject Property
KeyBasedTreeEntriesIterator Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

KeyBasedTreeEntriesIterator Class


KeyBasedTreeEntriesLoadContent Class

[image]

Revit 2024 API
KeyBasedTreeEntriesLoadContent Class
Members See Also Send Feedback
This class is used by IExternalResourceServers to return KeyBasedTreeEntries data to Revit when their LoadResource method is invoked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public class KeyBasedTreeEntriesLoadContent : ExternalResourceLoadContent
Visual Basic
Public Class KeyBasedTreeEntriesLoadContent _
    Inherits ExternalResourceLoadContent
Visual C++
public ref class KeyBasedTreeEntriesLoadContent : public ExternalResourceLoadContent

Remarks

The class contains a KeyBasedTreeEntries object which should hold the KeyBasedTreeEntries data generated by the IExternalResourceServer.

An ExternalResourceServer can create the KeyBasedTreeEntries from an arbitrary data source by using AddEntry to add individual KeyBasedTreeEntries. Once all the desired entries have been added, BuildEntries can be called to construct the KeyBasedTreeEntries object from the individual entries that were added.

KeyBasedTreeEntriesLoadContent must have a built KeyBasedTreeEntries before its LoadStatus property can be set to ExternalResourceLoadStatus.Success.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ExternalResourceLoadContent
Autodesk.Revit.DB..::..KeyBasedTreeEntriesLoadContent

See Also

KeyBasedTreeEntriesLoadContent Members


KeyBasedTreeEntriesLoadContent Members

[image] [image]

Revit 2024 API
KeyBasedTreeEntriesLoadContent Members
KeyBasedTreeEntriesLoadContent Class Methods Properties See Also Send Feedback

The KeyBasedTreeEntriesLoadContent type exposes the following members.

Methods

 | Name | Description
Public method | AddEntry | Adds one KeyBasedTreeEntry to this KeyBasedTreeEntriesLoadContent, which is used to build a KeyBasedTreeEntries object by BuildEntries function.
Public method | BuildEntries | Builds a KeyBasedTreeEntries object.
Public method | CanAddEntry | Verifies if the KeyBasedTreeEntry could be added in this KeyBasedTreeEntriesLoadContent.
Public method | Dispose | (Inherited from ExternalResourceLoadContent.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEntries | Gets a copy of KeyBasedTreeEntries object owned by this KeyBasedTreeEntriesLoadContent object.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLoadResults | Returns a copy of the KeyBasedTreeEntriesLoadResults owned by this KeyBasedTreeEntriesLoadContent object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsEntriesBuilt | Verifies that the KeyBasedTreeEntries object owned by a KeyBasedTreeEntriesLoadContent object is built.
Public method | Reset | Clears KeyBasedTreeEntriesLoadContent object, including KeyBasedTreeEntries and KeyBasedTreeEntriesLoadResults, owned by this KeyBasedTreeEntriesLoadContent object.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ExternalResourceLoadContent.)
Public property | LoadStatus | A value to indicate the status of an external resource load operation. IExternalResourceServers should set this in the LoadResource() method. (Inherited from ExternalResourceLoadContent.)
Public property | Version | The version of the external data that the server is providing in this object. (Inherited from ExternalResourceLoadContent.)

See Also

KeyBasedTreeEntriesLoadContent Class


KeyBasedTreeEntriesLoadContent Methods

[image] [image]

Revit 2024 API
KeyBasedTreeEntriesLoadContent Methods
KeyBasedTreeEntriesLoadContent Class See Also Send Feedback

The KeyBasedTreeEntriesLoadContent type exposes the following members.

Methods

 | Name | Description
Public method | AddEntry | Adds one KeyBasedTreeEntry to this KeyBasedTreeEntriesLoadContent, which is used to build a KeyBasedTreeEntries object by BuildEntries function.
Public method | BuildEntries | Builds a KeyBasedTreeEntries object.
Public method | CanAddEntry | Verifies if the KeyBasedTreeEntry could be added in this KeyBasedTreeEntriesLoadContent.
Public method | Dispose | (Inherited from ExternalResourceLoadContent.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEntries | Gets a copy of KeyBasedTreeEntries object owned by this KeyBasedTreeEntriesLoadContent object.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLoadResults | Returns a copy of the KeyBasedTreeEntriesLoadResults owned by this KeyBasedTreeEntriesLoadContent object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsEntriesBuilt | Verifies that the KeyBasedTreeEntries object owned by a KeyBasedTreeEntriesLoadContent object is built.
Public method | Reset | Clears KeyBasedTreeEntriesLoadContent object, including KeyBasedTreeEntries and KeyBasedTreeEntriesLoadResults, owned by this KeyBasedTreeEntriesLoadContent object.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

KeyBasedTreeEntriesLoadContent Class


AddEntry Method

[image]

Revit 2024 API
KeyBasedTreeEntriesLoadContent..::..AddEntry Method
KeyBasedTreeEntriesLoadContent Class See Also Send Feedback
Adds one KeyBasedTreeEntry to this KeyBasedTreeEntriesLoadContent, which is used to build a KeyBasedTreeEntries object by BuildEntries function.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool AddEntry(
    KeyBasedTreeEntry entry
)
Visual Basic
Public Function AddEntry ( _
    entry As KeyBasedTreeEntry _
) As Boolean
Visual C++
public:
bool AddEntry(
    KeyBasedTreeEntry^ entry
)

Parameters

entry
Type: Autodesk.Revit.DB..::..KeyBasedTreeEntry
The entry to be added.

Return Value

Returns true if an entry is added into the entry data set successfully, returns false if an entry fails to be added because this entry is invalid or a duplicate of one in the entry data set.

Remarks

The entry will not be added if it is invalid or duplicate with the added entries.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The KeyBasedTreeEntry object is not appropriate to be added in this KeyBasedTreeEntriesLoadContent.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The KeyBasedTreeEntries object owned by this KeyBasedTreeEntriesLoadContent object is built already. Adding more KeyBasedTreeEntries as well as repeated building, is not supported.

See Also

KeyBasedTreeEntriesLoadContent Class


CanAddEntry Method

[image]

Revit 2024 API
KeyBasedTreeEntriesLoadContent..::..CanAddEntry Method
KeyBasedTreeEntriesLoadContent Class See Also Send Feedback
Verifies if the KeyBasedTreeEntry could be added in this KeyBasedTreeEntriesLoadContent.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool CanAddEntry(
    KeyBasedTreeEntry entry
)
Visual Basic
Public Function CanAddEntry ( _
    entry As KeyBasedTreeEntry _
) As Boolean
Visual C++
public:
bool CanAddEntry(
    KeyBasedTreeEntry^ entry
)

Parameters

entry
Type: Autodesk.Revit.DB..::..KeyBasedTreeEntry
The KeyBasedTreeEntry object to be checked.

Return Value

True if the KeyBasedTreeEntry could be added in, otherwise false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

KeyBasedTreeEntriesLoadContent Class


GetEntries Method

[image]

Revit 2024 API
KeyBasedTreeEntriesLoadContent..::..GetEntries Method
KeyBasedTreeEntriesLoadContent Class See Also Send Feedback
Gets a copy of KeyBasedTreeEntries object owned by this KeyBasedTreeEntriesLoadContent object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public KeyBasedTreeEntries GetEntries()
Visual Basic
Public Function GetEntries As KeyBasedTreeEntries
Visual C++
public:
KeyBasedTreeEntries^ GetEntries()

Return Value

A copy of KeyBasedTreeEntries object owned by this KeyBasedTreeEntriesLoadContent object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The KeyBasedTreeEntries object owned by this KeyBasedTreeEntriesLoadContent object is not built yet. The information about this KeyBasedTreeEntries object is not available.

See Also

KeyBasedTreeEntriesLoadContent Class


GetLoadResults Method

[image]

Revit 2024 API
KeyBasedTreeEntriesLoadContent..::..GetLoadResults Method
KeyBasedTreeEntriesLoadContent Class See Also Send Feedback
Returns a copy of the KeyBasedTreeEntriesLoadResults owned by this KeyBasedTreeEntriesLoadContent object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public KeyBasedTreeEntriesLoadResults GetLoadResults()
Visual Basic
Public Function GetLoadResults As KeyBasedTreeEntriesLoadResults
Visual C++
public:
KeyBasedTreeEntriesLoadResults^ GetLoadResults()

Return Value

A copy of a KeyBasedTreeEntriesLoadResults owned by this KeyBasedTreeEntriesLoadContent object.

Remarks

IExternalResourceServers can use this object to report data and results back to Revit from their LoadResource methods.

See Also

KeyBasedTreeEntriesLoadContent Class


IsEntriesBuilt Method

[image]

Revit 2024 API
KeyBasedTreeEntriesLoadContent..::..IsEntriesBuilt Method
KeyBasedTreeEntriesLoadContent Class See Also Send Feedback
Verifies that the KeyBasedTreeEntries object owned by a KeyBasedTreeEntriesLoadContent object is built.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static bool IsEntriesBuilt(
    KeyBasedTreeEntriesLoadContent content
)
Visual Basic
Public Shared Function IsEntriesBuilt ( _
    content As KeyBasedTreeEntriesLoadContent _
) As Boolean
Visual C++
public:
static bool IsEntriesBuilt(
    KeyBasedTreeEntriesLoadContent^ content
)

Parameters

content
Type: Autodesk.Revit.DB..::..KeyBasedTreeEntriesLoadContent
The KeyBasedTreeEntriesLoadContent object to be checked.

Return Value

True if the KeyBasedTreeEntries object is built already, otherwise false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

KeyBasedTreeEntriesLoadContent Class


Reset Method

[image]

Revit 2024 API
KeyBasedTreeEntriesLoadContent..::..Reset Method
KeyBasedTreeEntriesLoadContent Class See Also Send Feedback
Clears KeyBasedTreeEntriesLoadContent object, including KeyBasedTreeEntries and KeyBasedTreeEntriesLoadResults, owned by this KeyBasedTreeEntriesLoadContent object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset
Visual C++
public:
void Reset()

Remarks

This method can be used to clear all data that has been added to this KeyBasedTreeEntriesLoadContent object to date so that the caller can start adding and building KeyBasedTreeEntries again.

See Also

KeyBasedTreeEntriesLoadContent Class


KeyBasedTreeEntriesLoadResults Members

[image] [image]

Revit 2024 API
KeyBasedTreeEntriesLoadResults Members
KeyBasedTreeEntriesLoadResults Class Constructors Methods Properties See Also Send Feedback

The KeyBasedTreeEntriesLoadResults type exposes the following members.

Constructors

 | Name | Description
Public method | KeyBasedTreeEntriesLoadResults | Creates an empty KeyBasedTreeEntriesLoadResults.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the KeyBasedTreeEntriesLoadResults
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetFailureMessages | Get all error or warnings created while attempting to load KeyBasedTreeEntries.
Public method | GetFileReadErrors | Gets the names of any files which could not be read due to access errors.
Public method | GetFileSyntaxErrors | Gets all the records in the key-based tree data text file that could not be parsed into KeyBasedTreeEntries.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetKeyBasedTreeEntryErrors()()()() | Gets information about KeyBasedTreeEntry objects that could not be included in the KeyBasedTreeEntries object due to errors.
Public method | GetKeyBasedTreeEntryErrors(KeyBasedTreeEntryErrorType) | Gets information about specific KeyBasedTreeEntry objects that could not be included in the KeyBasedTreeEntries object due to errors of a particular type.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

KeyBasedTreeEntriesLoadResults Class


KeyBasedTreeEntriesLoadResults Constructor

[image]

Revit 2024 API
KeyBasedTreeEntriesLoadResults Constructor
KeyBasedTreeEntriesLoadResults Class See Also Send Feedback
Creates an empty KeyBasedTreeEntriesLoadResults.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public KeyBasedTreeEntriesLoadResults()
Visual Basic
Public Sub New
Visual C++
public:
KeyBasedTreeEntriesLoadResults()

See Also

KeyBasedTreeEntriesLoadResults Class


KeyBasedTreeEntriesLoadResults Methods

[image] [image]

Revit 2024 API
KeyBasedTreeEntriesLoadResults Methods
KeyBasedTreeEntriesLoadResults Class See Also Send Feedback

The KeyBasedTreeEntriesLoadResults type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetFailureMessages | Get all error or warnings created while attempting to load KeyBasedTreeEntries.
Public method | GetFileReadErrors | Gets the names of any files which could not be read due to access errors.
Public method | GetFileSyntaxErrors | Gets all the records in the key-based tree data text file that could not be parsed into KeyBasedTreeEntries.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetKeyBasedTreeEntryErrors()()()() | Gets information about KeyBasedTreeEntry objects that could not be included in the KeyBasedTreeEntries object due to errors.
Public method | GetKeyBasedTreeEntryErrors(KeyBasedTreeEntryErrorType) | Gets information about specific KeyBasedTreeEntry objects that could not be included in the KeyBasedTreeEntries object due to errors of a particular type.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

KeyBasedTreeEntriesLoadResults Class


Dispose Method

[image]

Revit 2024 API
KeyBasedTreeEntriesLoadResults..::..Dispose Method
KeyBasedTreeEntriesLoadResults Class See Also Send Feedback
Releases all resources used by the KeyBasedTreeEntriesLoadResults

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

KeyBasedTreeEntriesLoadResults Class


GetFailureMessages Method

[image]

Revit 2024 API
KeyBasedTreeEntriesLoadResults..::..GetFailureMessages Method
KeyBasedTreeEntriesLoadResults Class See Also Send Feedback
Get all error or warnings created while attempting to load KeyBasedTreeEntries.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public IList<FailureMessage> GetFailureMessages()
Visual Basic
Public Function GetFailureMessages As IList(Of FailureMessage)
Visual C++
public:
IList<FailureMessage^>^ GetFailureMessages()

Return Value

A collection of FailureMessage objects, if any errors or warnings were encountered while loading and building the KeyBasedTreeEntries.

Remarks

Revit does not post these warnings. They are provided as a convenience to the API user, who may wish to post them.

The information in the warnings is also captured in the other error functions of KeyBasedTreeEntriesLoadResults.

See Also

KeyBasedTreeEntriesLoadResults Class


GetFileReadErrors Method

[image]

Revit 2024 API
KeyBasedTreeEntriesLoadResults..::..GetFileReadErrors Method
KeyBasedTreeEntriesLoadResults Class See Also Send Feedback
Gets the names of any files which could not be read due to access errors.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public IList<string> GetFileReadErrors()
Visual Basic
Public Function GetFileReadErrors As IList(Of String)
Visual C++
public:
IList<String^>^ GetFileReadErrors()

Return Value

An array of strings containing the filenames of files which could not be read.

Remarks

Only applies to KeyBasedTreeEntries built from text files.

See Also

KeyBasedTreeEntriesLoadResults Class


GetFileSyntaxErrors Method

[image]

Revit 2024 API
KeyBasedTreeEntriesLoadResults..::..GetFileSyntaxErrors Method
KeyBasedTreeEntriesLoadResults Class See Also Send Feedback
Gets all the records in the key-based tree data text file that could not be parsed into KeyBasedTreeEntries.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public IList<string> GetFileSyntaxErrors()
Visual Basic
Public Function GetFileSyntaxErrors As IList(Of String)
Visual C++
public:
IList<String^>^ GetFileSyntaxErrors()

Return Value

An array of strings that are copies of the records in the text file that could not be parsed.

Remarks

Only applies to KeyBasedTreeEntries built from text files.

See Also

KeyBasedTreeEntriesLoadResults Class


GetKeyBasedTreeEntryErrors Method

[image] [image]

Revit 2024 API
KeyBasedTreeEntriesLoadResults..::..GetKeyBasedTreeEntryErrors Method
KeyBasedTreeEntriesLoadResults Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetKeyBasedTreeEntryErrors()()()() | Gets information about KeyBasedTreeEntry objects that could not be included in the KeyBasedTreeEntries object due to errors.
Public method | GetKeyBasedTreeEntryErrors(KeyBasedTreeEntryErrorType) | Gets information about specific KeyBasedTreeEntry objects that could not be included in the KeyBasedTreeEntries object due to errors of a particular type.

See Also

KeyBasedTreeEntriesLoadResults Class
KeyBasedTreeEntriesLoadResults Members


GetKeyBasedTreeEntryErrors Method

[image]

Revit 2024 API
KeyBasedTreeEntriesLoadResults..::..GetKeyBasedTreeEntryErrors Method
KeyBasedTreeEntriesLoadResults Class See Also Send Feedback
Gets information about KeyBasedTreeEntry objects that could not be included in the KeyBasedTreeEntries object due to errors.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public IList<KeyBasedTreeEntryError> GetKeyBasedTreeEntryErrors()
Visual Basic
Public Function GetKeyBasedTreeEntryErrors As IList(Of KeyBasedTreeEntryError)
Visual C++
public:
IList<KeyBasedTreeEntryError^>^ GetKeyBasedTreeEntryErrors()

Return Value

An array of copies of the KeyBasedTreeEntryErrors contained in this object.

See Also

KeyBasedTreeEntriesLoadResults Class
GetKeyBasedTreeEntryErrors Overload


GetKeyBasedTreeEntryErrors Method (KeyBasedTreeEntryErrorType)

[image]

Revit 2024 API
KeyBasedTreeEntriesLoadResults..::..GetKeyBasedTreeEntryErrors Method (KeyBasedTreeEntryErrorType)
KeyBasedTreeEntriesLoadResults Class See Also Send Feedback
Gets information about specific KeyBasedTreeEntry objects that could not be included in the KeyBasedTreeEntries object due to errors of a particular type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public IList<KeyBasedTreeEntryError> GetKeyBasedTreeEntryErrors(
    KeyBasedTreeEntryErrorType type
)
Visual Basic
Public Function GetKeyBasedTreeEntryErrors ( _
    type As KeyBasedTreeEntryErrorType _
) As IList(Of KeyBasedTreeEntryError)
Visual C++
public:
IList<KeyBasedTreeEntryError^>^ GetKeyBasedTreeEntryErrors(
    KeyBasedTreeEntryErrorType type
)

Parameters

type
Type: Autodesk.Revit.DB..::..KeyBasedTreeEntryErrorType
The type of KeyBasedTreeEntryError to be returned.

Return Value

An array of copies of the KeyBasedTreeEntryErrors contained in this object matching the type specified.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

KeyBasedTreeEntriesLoadResults Class
GetKeyBasedTreeEntryErrors Overload


KeyBasedTreeEntriesLoadResults Properties

[image] [image]

Revit 2024 API
KeyBasedTreeEntriesLoadResults Properties
KeyBasedTreeEntriesLoadResults Class See Also Send Feedback

The KeyBasedTreeEntriesLoadResults type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

KeyBasedTreeEntriesLoadResults Class


IsValidObject Property

[image]

Revit 2024 API
KeyBasedTreeEntriesLoadResults..::..IsValidObject Property
KeyBasedTreeEntriesLoadResults Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

KeyBasedTreeEntriesLoadResults Class


KeyBasedTreeEntry Class

[image]

Revit 2024 API
KeyBasedTreeEntry Class
Members See Also Send Feedback
A key-based tree entry, containing the key, parent key, and children keys (if applicable).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public class KeyBasedTreeEntry : IDisposable
Visual Basic
Public Class KeyBasedTreeEntry _
    Implements IDisposable
Visual C++
public ref class KeyBasedTreeEntry : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..KeyBasedTreeEntry
Autodesk.Revit.DB..::..ClassificationEntry
Autodesk.Revit.DB..::..KeynoteEntry

See Also

KeyBasedTreeEntry Members


KeyBasedTreeEntry Members

[image] [image]

Revit 2024 API
KeyBasedTreeEntry Members
KeyBasedTreeEntry Class Methods Properties See Also Send Feedback

The KeyBasedTreeEntry type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the KeyBasedTreeEntry
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetChildrenKeys | Gets a collection containing the keys of all children entry objects from this entry.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Key | The key of this entry.
Public property | ParentKey | The parent key of this entry.

See Also

KeyBasedTreeEntry Class


KeyBasedTreeEntry Methods

[image] [image]

Revit 2024 API
KeyBasedTreeEntry Methods
KeyBasedTreeEntry Class See Also Send Feedback

The KeyBasedTreeEntry type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetChildrenKeys | Gets a collection containing the keys of all children entry objects from this entry.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

KeyBasedTreeEntry Class


Dispose Method

[image]

Revit 2024 API
KeyBasedTreeEntry..::..Dispose Method
KeyBasedTreeEntry Class See Also Send Feedback
Releases all resources used by the KeyBasedTreeEntry

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

KeyBasedTreeEntry Class


KeyBasedTreeEntry Properties

[image] [image]

Revit 2024 API
KeyBasedTreeEntry Properties
KeyBasedTreeEntry Class See Also Send Feedback

The KeyBasedTreeEntry type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Key | The key of this entry.
Public property | ParentKey | The parent key of this entry.

See Also

KeyBasedTreeEntry Class


IsValidObject Property

[image]

Revit 2024 API
KeyBasedTreeEntry..::..IsValidObject Property
KeyBasedTreeEntry Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

KeyBasedTreeEntry Class


Key Property

[image]

Revit 2024 API
KeyBasedTreeEntry..::..Key Property
KeyBasedTreeEntry Class See Also Send Feedback
The key of this entry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public string Key { get; }
Visual Basic
Public ReadOnly Property Key As String
    Get
Visual C++
public:
property String^ Key {
    String^ get ();
}

Remarks

This value will be used to do retrieval, sort and comparison. This value should not be empty.

See Also

KeyBasedTreeEntry Class


ParentKey Property

[image]

Revit 2024 API
KeyBasedTreeEntry..::..ParentKey Property
KeyBasedTreeEntry Class See Also Send Feedback
The parent key of this entry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public string ParentKey { get; }
Visual Basic
Public ReadOnly Property ParentKey As String
    Get
Visual C++
public:
property String^ ParentKey {
    String^ get ();
}

Remarks

This value will be the empty string if this entry does not have a parent.

See Also

KeyBasedTreeEntry Class


KeyBasedTreeEntryError Class

[image]

Revit 2024 API
KeyBasedTreeEntryError Class
Members See Also Send Feedback
This class contains information about a problem encountered while creating a KeyBasedTreeEntries object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public class KeyBasedTreeEntryError : IDisposable
Visual Basic
Public Class KeyBasedTreeEntryError _
    Implements IDisposable
Visual C++
public ref class KeyBasedTreeEntryError : IDisposable

Remarks

This problem might be a duplicate entry, or an error in the specified parent-child relationships, or something else. See BuiltInKeyBasedTreeEntryErrorType for details.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..KeyBasedTreeEntryError

See Also

KeyBasedTreeEntryError Members


KeyBasedTreeEntryError Members

[image] [image]

Revit 2024 API
KeyBasedTreeEntryError Members
KeyBasedTreeEntryError Class Methods Properties See Also Send Feedback

The KeyBasedTreeEntryError type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the KeyBasedTreeEntryError
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEntry | Gets the entry for which an error occurred while building the KeyBasedTreeEntries object.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ErrorType | Indicates which of possible types of problems with loading and/or building a KeyBasedTreeEntries that this KeyBasedTreeEntryError represents.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

KeyBasedTreeEntryError Class


KeyBasedTreeEntryError Methods

[image] [image]

Revit 2024 API
KeyBasedTreeEntryError Methods
KeyBasedTreeEntryError Class See Also Send Feedback

The KeyBasedTreeEntryError type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEntry | Gets the entry for which an error occurred while building the KeyBasedTreeEntries object.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

KeyBasedTreeEntryError Class


GetEntry Method

[image]

Revit 2024 API
KeyBasedTreeEntryError..::..GetEntry Method
KeyBasedTreeEntryError Class See Also Send Feedback
Gets the entry for which an error occurred while building the KeyBasedTreeEntries object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public KeyBasedTreeEntry GetEntry()
Visual Basic
Public Function GetEntry As KeyBasedTreeEntry
Visual C++
public:
KeyBasedTreeEntry^ GetEntry()

Return Value

A copy of the KeyBasedTreeEntry.

See Also

KeyBasedTreeEntryError Class


KeyBasedTreeEntryError Properties

[image] [image]

Revit 2024 API
KeyBasedTreeEntryError Properties
KeyBasedTreeEntryError Class See Also Send Feedback

The KeyBasedTreeEntryError type exposes the following members.

Properties

 | Name | Description
Public property | ErrorType | Indicates which of possible types of problems with loading and/or building a KeyBasedTreeEntries that this KeyBasedTreeEntryError represents.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

KeyBasedTreeEntryError Class


IsValidObject Property

[image]

Revit 2024 API
KeyBasedTreeEntryError..::..IsValidObject Property
KeyBasedTreeEntryError Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

KeyBasedTreeEntryError Class


KeyBasedTreeEntryErrorType Enumeration

[image]

Revit 2024 API
KeyBasedTreeEntryErrorType Enumeration
See Also Send Feedback
An Enum indicating the type of error associated with a KeyBasedTreeEntry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015
Since: 2015

Syntax

C#
public enum KeyBasedTreeEntryErrorType
Visual Basic
Public Enumeration KeyBasedTreeEntryErrorType
Visual C++
public enum class KeyBasedTreeEntryErrorType

Members

Member name | Description
DuplicateEntry | The same entry appears more than once in the KeyBasedTreeEntries object.
MissingParent | The parent specified for a entry does not exist in the KeyBasedTreeEntires object.
CircularParentage | A sub-node has been specified as a parent of one of its ancestors.
InvalidClassificationCode | The classification code does not match the level and parent code.
BadClassificationLevel | The classification level is not an integer in range between 1 and 5 inclusive.
BadClassificationCategoryId | The classification category id is not Revit BuiltInCategory id.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


KeyBasedTreeEntryTable Class

[image]

Revit 2024 API
KeyBasedTreeEntryTable Class
Members See Also Send Feedback
KeyBasedTreeEntryTable represents the collection of key-based tree entries for a document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public class KeyBasedTreeEntryTable : Element
Visual Basic
Public Class KeyBasedTreeEntryTable _
    Inherits Element
Visual C++
public ref class KeyBasedTreeEntryTable : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..KeyBasedTreeEntryTable
Autodesk.Revit.DB..::..AssemblyCodeTable
Autodesk.Revit.DB..::..KeynoteTable

See Also

KeyBasedTreeEntryTable Members


KeyBasedTreeEntryTable Methods

[image] [image]

Revit 2024 API
KeyBasedTreeEntryTable Methods
KeyBasedTreeEntryTable Class See Also Send Feedback

The KeyBasedTreeEntryTable type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetKeyBasedTreeEntries | Gets the KeyBasedTreeEntries for this table.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LoadFrom | Loads KeyBasedTreeEntries from the specified external resource into this KeyBasedTreeEntryTable.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | Reload | Reloads KeyBasedTreeEntries from their currently-stored location into this KeyBasedTreeEntryTable.
Public method | ServerSupports | Checks if the server referenced by the given ExternalResourceReference supports the ExternalResourceReferenceType of this KeyBasedTreeEntryTable.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

KeyBasedTreeEntryTable Class


LoadFrom Method

[image]

Revit 2024 API
KeyBasedTreeEntryTable..::..LoadFrom Method
KeyBasedTreeEntryTable Class See Also Send Feedback
Loads KeyBasedTreeEntries from the specified external resource into this KeyBasedTreeEntryTable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public ExternalResourceLoadStatus LoadFrom(
    ExternalResourceReference desiredResourceReference,
    KeyBasedTreeEntriesLoadResults loadResults
)
Visual Basic
Public Function LoadFrom ( _
    desiredResourceReference As ExternalResourceReference, _
    loadResults As KeyBasedTreeEntriesLoadResults _
) As ExternalResourceLoadStatus
Visual C++
public:
ExternalResourceLoadStatus LoadFrom(
    ExternalResourceReference^ desiredResourceReference,
    KeyBasedTreeEntriesLoadResults^ loadResults
)

Parameters

desiredResourceReference
Type: Autodesk.Revit.DB..::..ExternalResourceReference
An external resource reference describing the source of the desired KeyBasedTreeEntry data.
loadResults
Type: Autodesk.Revit.DB..::..KeyBasedTreeEntriesLoadResults

If provided, Revit will use this object to store any errors or warnings that were encountered.

This argument may be nullNothingnullptra null reference (Nothing in Visual Basic).

Return Value

Returns whether the operation succeeded or failed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The server referenced by the ExternalResourceReference does not exist or does not implement IExternalResourceServer. -or- The server referenced by the ExternalResourceReference cannot support the ExternalResourceReferenceType of this KeyBasedTreeEntryTable. -or- The ExternalResourceReference (desiredResourceReference) is not in a format that is supported by its server.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document containing this KeyBasedTreeEntryTable is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document containing this KeyBasedTreeEntryTable is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document containing this KeyBasedTreeEntryTable has no open transaction.

See Also

KeyBasedTreeEntryTable Class


Reload Method

[image]

Revit 2024 API
KeyBasedTreeEntryTable..::..Reload Method
KeyBasedTreeEntryTable Class See Also Send Feedback
Reloads KeyBasedTreeEntries from their currently-stored location into this KeyBasedTreeEntryTable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public ExternalResourceLoadStatus Reload(
    KeyBasedTreeEntriesLoadResults loadResults
)
Visual Basic
Public Function Reload ( _
    loadResults As KeyBasedTreeEntriesLoadResults _
) As ExternalResourceLoadStatus
Visual C++
public:
ExternalResourceLoadStatus Reload(
    KeyBasedTreeEntriesLoadResults^ loadResults
)

Parameters

loadResults
Type: Autodesk.Revit.DB..::..KeyBasedTreeEntriesLoadResults

If provided, Revit will use this object to store any errors or warnings that were encountered. Note that if the KeyBasedTreeEntries in the model are already up to date, no errors or warnings will be added to this object.

This argument may be nullNothingnullptra null reference (Nothing in Visual Basic).

Return Value

Returns the outcome of the reload operation.

Remarks

Revit will try to read KeyBasedTreeEntries from the resource reference stored within the KeyBasedTreeEntryTable. If the operation fails, the table will be unchanged.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document containing this KeyBasedTreeEntryTable is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document containing this KeyBasedTreeEntryTable is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document containing this KeyBasedTreeEntryTable has no open transaction.

See Also

KeyBasedTreeEntryTable Class


KeyBasedTreeEntryTable Properties

[image] [image]

Revit 2024 API
KeyBasedTreeEntryTable Properties
KeyBasedTreeEntryTable Class See Also Send Feedback

The KeyBasedTreeEntryTable type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

KeyBasedTreeEntryTable Class


Parameter Property

[image] [image]

Revit 2024 API
KeyBasedTreeEntryTable..::..Parameter Property
KeyBasedTreeEntryTable Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

KeyBasedTreeEntryTable Class
KeyBasedTreeEntryTable Members


KeynoteEntries Class

[image]

Revit 2024 API
KeynoteEntries Class
Members See Also Send Feedback
A collection of KeynoteEntry objects that make up the keynote table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public class KeynoteEntries : KeyBasedTreeEntries
Visual Basic
Public Class KeynoteEntries _
    Inherits KeyBasedTreeEntries
Visual C++
public ref class KeynoteEntries : public KeyBasedTreeEntries

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..KeyBasedTreeEntries
Autodesk.Revit.DB..::..KeynoteEntries

See Also

KeynoteEntries Members


KeynoteEntries Methods

[image] [image]

Revit 2024 API
KeynoteEntries Methods
KeynoteEntries Class See Also Send Feedback

The KeynoteEntries type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from KeyBasedTreeEntries.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindEntry | Finds the KeyBasedTreeEntry associated with the given key value. (Inherited from KeyBasedTreeEntries.)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection. (Inherited from KeyBasedTreeEntries.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from KeyBasedTreeEntries.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetKeyBasedTreeEntriesIterator | Returns a KeyBasedTreeEntriesIterator that iterates through the collection. (Inherited from KeyBasedTreeEntries.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | LoadKeynoteEntriesFromFile | Loads the contents of a keynote text file into the provided KeyBasedTreeEntriesLoadContent.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

KeynoteEntries Class


LoadKeynoteEntriesFromFile Method

[image]

Revit 2024 API
KeynoteEntries..::..LoadKeynoteEntriesFromFile Method
KeynoteEntries Class See Also Send Feedback
Loads the contents of a keynote text file into the provided KeyBasedTreeEntriesLoadContent.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static bool LoadKeynoteEntriesFromFile(
    string filePath,
    KeyBasedTreeEntriesLoadContent keynoteContent
)
Visual Basic
Public Shared Function LoadKeynoteEntriesFromFile ( _
    filePath As String, _
    keynoteContent As KeyBasedTreeEntriesLoadContent _
) As Boolean
Visual C++
public:
static bool LoadKeynoteEntriesFromFile(
    String^ filePath,
    KeyBasedTreeEntriesLoadContent^ keynoteContent
)

Parameters

filePath
Type: System..::..String
The full path of the existing keynotefile.
keynoteContent
Type: Autodesk.Revit.DB..::..KeyBasedTreeEntriesLoadContent
The keynote entries read from the filePath will be added to this object. A KeyBasedTreeEntriesLoadContent object will also be updated to contain status information, including information about any errors that occurred while reading the keynote entries from the specified file.

Return Value

True if reading the keynote file succeeds; False if the keynote file cannot be read.

Remarks

The entries read from the file will be added to any existing entries read from other files before this reading operation in the provided KeyBasedTreeEntriesLoadContent. if file A was read, and then file B was failed to read, all the entries from file A will still be there to build KeynoteEntries object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | filePath is an empty string. -or- The KeyBasedTreeEntries object owned by this KeyBasedTreeEntriesLoadContent object is built already. Adding more KeyBasedTreeEntries as well as repeated building, is not supported.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidPathArgumentException | The destination file name includes one or more invalid characters.

See Also

KeynoteEntries Class


KeynoteEntries Properties

[image] [image]

Revit 2024 API
KeynoteEntries Properties
KeynoteEntries Class See Also Send Feedback

The KeynoteEntries type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from KeyBasedTreeEntries.)

See Also

KeynoteEntries Class


KeynoteEntry Class

[image]

Revit 2024 API
KeynoteEntry Class
Members See Also Send Feedback
Represents an entry in the keynote table, containing the key value, keynote text, and parent key (if applicable).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public class KeynoteEntry : KeyBasedTreeEntry
Visual Basic
Public Class KeynoteEntry _
    Inherits KeyBasedTreeEntry
Visual C++
public ref class KeynoteEntry : public KeyBasedTreeEntry

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..KeyBasedTreeEntry
Autodesk.Revit.DB..::..KeynoteEntry

See Also

KeynoteEntry Members


KeynoteEntry Constructor

[image] [image]

Revit 2024 API
KeynoteEntry Constructor
KeynoteEntry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | KeynoteEntry(String, String) | Constructs a new KeynoteEntry from the given key name and keynote text. KeynoteEntry objects created from this constructor will not have parents.
Public method | KeynoteEntry(String, String, String) | Constructs a new KeynoteEntry from the given key name, parent key name, and keynote text.

See Also

KeynoteEntry Class
KeynoteEntry Members


KeynoteEntry Constructor (String, String)

[image]

Revit 2024 API
KeynoteEntry Constructor (String, String)
KeynoteEntry Class See Also Send Feedback
Constructs a new KeynoteEntry from the given key name and keynote text. KeynoteEntry objects created from this constructor will not have parents.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public KeynoteEntry(
    string key,
    string text
)
Visual Basic
Public Sub New ( _
    key As String, _
    text As String _
)
Visual C++
public:
KeynoteEntry(
    String^ key,
    String^ text
)

Parameters

key
Type: System..::..String
The key of this KeynoteEntry
text
Type: System..::..String
The text associated with this KeynoteEntry

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | key is an empty string.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

KeynoteEntry Class
KeynoteEntry Overload


KeynoteEntry Methods

[image] [image]

Revit 2024 API
KeynoteEntry Methods
KeynoteEntry Class See Also Send Feedback

The KeynoteEntry type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from KeyBasedTreeEntry.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetChildrenKeys | Gets a collection containing the keys of all children entry objects from this entry. (Inherited from KeyBasedTreeEntry.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

KeynoteEntry Class


KeynoteEntry Properties

[image] [image]

Revit 2024 API
KeynoteEntry Properties
KeynoteEntry Class See Also Send Feedback

The KeynoteEntry type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from KeyBasedTreeEntry.)
Public property | Key | The key of this entry. (Inherited from KeyBasedTreeEntry.)
Public property | KeynoteText | The text associated with this KeynoteEntry.
Public property | ParentKey | The parent key of this entry. (Inherited from KeyBasedTreeEntry.)

See Also

KeynoteEntry Class


KeynoteTable Members

[image] [image]

Revit 2024 API
KeynoteTable Members
KeynoteTable Class Methods Properties See Also Send Feedback

The KeynoteTable type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetKeyBasedTreeEntries | Gets the KeyBasedTreeEntries for this table. (Inherited from KeyBasedTreeEntryTable.)
 | GetKeynoteTable | Gets the KeynoteTable from a Revit document.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LoadFrom | Loads KeyBasedTreeEntries from the specified external resource into this KeyBasedTreeEntryTable. (Inherited from KeyBasedTreeEntryTable.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | Reload | Reloads KeyBasedTreeEntries from their currently-stored location into this KeyBasedTreeEntryTable. (Inherited from KeyBasedTreeEntryTable.)
Public method | ServerSupports | Checks if the server referenced by the given ExternalResourceReference supports the ExternalResourceReferenceType of this KeyBasedTreeEntryTable. (Inherited from KeyBasedTreeEntryTable.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

KeynoteTable Class


GetKeynoteTable Method

[image]

Revit 2024 API
KeynoteTable..::..GetKeynoteTable Method
KeynoteTable Class See Also Send Feedback
Gets the KeynoteTable from a Revit document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static KeynoteTable GetKeynoteTable(
    Document aDoc
)
Visual Basic
Public Shared Function GetKeynoteTable ( _
    aDoc As Document _
) As KeynoteTable
Visual C++
public:
static KeynoteTable^ GetKeynoteTable(
    Document^ aDoc
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
The Revit document.

Return Value

The KeynoteTable.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

KeynoteTable Class


KeynoteTable Properties

[image] [image]

Revit 2024 API
KeynoteTable Properties
KeynoteTable Class See Also Send Feedback

The KeynoteTable type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

KeynoteTable Class


Parameter Property

[image] [image]

Revit 2024 API
KeynoteTable..::..Parameter Property
KeynoteTable Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

KeynoteTable Class
KeynoteTable Members


LabelType Enumeration

[image]

Revit 2024 API
LabelType Enumeration
See Also Send Feedback
The label type in dimension equality formats.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update
Since: 2017 Subscription Update

Syntax

C#
public enum LabelType
Visual Basic
Public Enumeration LabelType
Visual C++
public enum class LabelType

Members

Member name | Description
NumberOfWitnessLines | The number of witness lines of the dimension.
NumberOfSegments | The number of segments of the dimension.
LengthOfSegment | The length of segments of the dimension.
TotalLength | The total length of the dimension.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


LabelUtils Class

[image]

Revit 2024 API
LabelUtils Class
Members See Also Send Feedback
Used to obtain user-visible names for enums.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class LabelUtils : IDisposable
Visual Basic
Public Class LabelUtils _
    Implements IDisposable
Visual C++
public ref class LabelUtils : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..LabelUtils

See Also

LabelUtils Members


LabelUtils Members

[image] [image]

Revit 2024 API
LabelUtils Members
LabelUtils Class Methods Properties See Also Send Feedback

The LabelUtils type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the LabelUtils
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLabelFor(BuiltInCategory) | Gets the user-visible name for a BuiltInCategory.
 | GetLabelFor(BuiltInParameter) | Gets the user-visible name for a BuiltInParameter.
 | GetLabelFor(BuiltInParameterGroup) | Obsolete. Gets the user-visible name for a BuiltInParameterGroup.
 | GetLabelFor(BuiltInParameter, LanguageType) | Gets the user-visible name for a BuiltInParameter in a specific LanguageType.
 | GetLabelFor(DuctLossMethodType, Document) | Gets the user-visible name for a DuctLossMethodType.
 | GetLabelFor(gbXMLBuildingType, Document) | Gets the user-visible name for a gbXMLBuildingType.
 | GetLabelFor(PipeFlowState, Document) | Gets the user-visible name for a PipeFlowState.
 | GetLabelFor(PipeLossMethodType, Document) | Gets the user-visible name for a PipeLossMethodType.
 | GetLabelForBuiltInParameter(ForgeTypeId) | Gets the user-visible name for a built-in parameter.
 | GetLabelForBuiltInParameter(ForgeTypeId, LanguageType) | Gets the user-visible name for a built-in parameter in a specific LanguageType.
 | GetLabelForDiscipline | Gets the user-visible name for a discipline.
 | GetLabelForGroup | Gets the user-visible name for a built-in parameter group. To get the name of parameter group "Other", pass an empty, default-constructed ForgeTypeId.
 | GetLabelForSpec | Gets the user-visible name for a spec.
 | GetLabelForSymbol | Gets the user-visible name for a symbol.
 | GetLabelForUnit | Gets the user-visible name for a unit.
 | GetStructuralSectionShapeName | Gets the user-visible name for a StructuralSectionShape.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

LabelUtils Class


LabelUtils Methods

[image] [image]

Revit 2024 API
LabelUtils Methods
LabelUtils Class See Also Send Feedback

The LabelUtils type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLabelFor(BuiltInCategory) | Gets the user-visible name for a BuiltInCategory.
 | GetLabelFor(BuiltInParameter) | Gets the user-visible name for a BuiltInParameter.
 | GetLabelFor(BuiltInParameterGroup) | Obsolete. Gets the user-visible name for a BuiltInParameterGroup.
 | GetLabelFor(BuiltInParameter, LanguageType) | Gets the user-visible name for a BuiltInParameter in a specific LanguageType.
 | GetLabelFor(DuctLossMethodType, Document) | Gets the user-visible name for a DuctLossMethodType.
 | GetLabelFor(gbXMLBuildingType, Document) | Gets the user-visible name for a gbXMLBuildingType.
 | GetLabelFor(PipeFlowState, Document) | Gets the user-visible name for a PipeFlowState.
 | GetLabelFor(PipeLossMethodType, Document) | Gets the user-visible name for a PipeLossMethodType.
 | GetLabelForBuiltInParameter(ForgeTypeId) | Gets the user-visible name for a built-in parameter.
 | GetLabelForBuiltInParameter(ForgeTypeId, LanguageType) | Gets the user-visible name for a built-in parameter in a specific LanguageType.
 | GetLabelForDiscipline | Gets the user-visible name for a discipline.
 | GetLabelForGroup | Gets the user-visible name for a built-in parameter group. To get the name of parameter group "Other", pass an empty, default-constructed ForgeTypeId.
 | GetLabelForSpec | Gets the user-visible name for a spec.
 | GetLabelForSymbol | Gets the user-visible name for a symbol.
 | GetLabelForUnit | Gets the user-visible name for a unit.
 | GetStructuralSectionShapeName | Gets the user-visible name for a StructuralSectionShape.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LabelUtils Class


Dispose Method

[image]

Revit 2024 API
LabelUtils..::..Dispose Method
LabelUtils Class See Also Send Feedback
Releases all resources used by the LabelUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

LabelUtils Class


GetLabelFor Method

[image] [image]

Revit 2024 API
LabelUtils..::..GetLabelFor Method
LabelUtils Class See Also Send Feedback

Overload List

Name | Description
GetLabelFor(BuiltInCategory) | Gets the user-visible name for a BuiltInCategory.
GetLabelFor(BuiltInParameter) | Gets the user-visible name for a BuiltInParameter.
GetLabelFor(BuiltInParameterGroup) | Obsolete. Gets the user-visible name for a BuiltInParameterGroup.
GetLabelFor(BuiltInParameter, LanguageType) | Gets the user-visible name for a BuiltInParameter in a specific LanguageType.
GetLabelFor(DuctLossMethodType, Document) | Gets the user-visible name for a DuctLossMethodType.
GetLabelFor(gbXMLBuildingType, Document) | Gets the user-visible name for a gbXMLBuildingType.
GetLabelFor(PipeFlowState, Document) | Gets the user-visible name for a PipeFlowState.
GetLabelFor(PipeLossMethodType, Document) | Gets the user-visible name for a PipeLossMethodType.

See Also

LabelUtils Class
LabelUtils Members


GetLabelFor Method (BuiltInCategory)

[image]

Revit 2024 API
LabelUtils..::..GetLabelFor Method (BuiltInCategory)
LabelUtils Class See Also Send Feedback
Gets the user-visible name for a BuiltInCategory.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public static string GetLabelFor(
    BuiltInCategory builtInCategory
)
Visual Basic
Public Shared Function GetLabelFor ( _
    builtInCategory As BuiltInCategory _
) As String
Visual C++
public:
static String^ GetLabelFor(
    BuiltInCategory builtInCategory
)

Parameters

builtInCategory
Type: Autodesk.Revit.DB..::..BuiltInCategory
The BuiltInCategory to get the user-visible name.

Remarks

The name is obtained in the current Revit language.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the builtin category is not valid.

See Also

LabelUtils Class
GetLabelFor Overload


GetLabelFor Method (BuiltInParameter)

[image]

Revit 2024 API
LabelUtils..::..GetLabelFor Method (BuiltInParameter)
LabelUtils Class See Also Send Feedback
Gets the user-visible name for a BuiltInParameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static string GetLabelFor(
    BuiltInParameter builtInParam
)
Visual Basic
Public Shared Function GetLabelFor ( _
    builtInParam As BuiltInParameter _
) As String
Visual C++
public:
static String^ GetLabelFor(
    BuiltInParameter builtInParam
)

Parameters

builtInParam
Type: Autodesk.Revit.DB..::..BuiltInParameter
The BuiltInParameter to get the user-visible name.

Remarks

The name is obtained in the current Revit language.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the BuiltInParameter cannot be found.

See Also

LabelUtils Class
GetLabelFor Overload


GetLabelFor Method (BuiltInParameterGroup)

[image]

Revit 2024 API
LabelUtils..::..GetLabelFor Method (BuiltInParameterGroup)
LabelUtils Class See Also Send Feedback
Gets the user-visible name for a BuiltInParameterGroup.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
[ObsoleteAttribute("This method is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use the `GetLabelForGroup(ForgeTypeId)` method instead.")]
public static string GetLabelFor(
    BuiltInParameterGroup builtInParamGroup
)
Visual Basic
<ObsoleteAttribute("This method is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use the `GetLabelForGroup(ForgeTypeId)` method instead.")> _
Public Shared Function GetLabelFor ( _
    builtInParamGroup As BuiltInParameterGroup _
) As String
Visual C++
[ObsoleteAttribute(L"This method is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use the `GetLabelForGroup(ForgeTypeId)` method instead.")]
public:
static String^ GetLabelFor(
    BuiltInParameterGroup builtInParamGroup
)

Parameters

builtInParamGroup
Type: Autodesk.Revit.DB..::..BuiltInParameterGroup
The BuiltInParameterGroup to get the user-visible name.

Remarks

The name is obtained in the current Revit language.

See Also

LabelUtils Class
GetLabelFor Overload


GetLabelFor Method (BuiltInParameter, LanguageType)

[image]

Revit 2024 API
LabelUtils..::..GetLabelFor Method (BuiltInParameter, LanguageType)
LabelUtils Class See Also Send Feedback
Gets the user-visible name for a BuiltInParameter in a specific LanguageType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public static string GetLabelFor(
    BuiltInParameter builtInParam,
    LanguageType language
)
Visual Basic
Public Shared Function GetLabelFor ( _
    builtInParam As BuiltInParameter, _
    language As LanguageType _
) As String
Visual C++
public:
static String^ GetLabelFor(
    BuiltInParameter builtInParam,
    LanguageType language
)

Parameters

builtInParam
Type: Autodesk.Revit.DB..::..BuiltInParameter
The BuiltInParameter to get the user-visible name.
language
Type: Autodesk.Revit.ApplicationServices..::..LanguageType
The desired LanguageType to get the user-visible name in.

Return Value

The BuiltInParameter name in the desired LanguageType.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the BuiltInParameter cannot be found.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the desired LanguageType cannot be found for the BuiltInParameter name.

See Also

LabelUtils Class
GetLabelFor Overload


GetLabelFor Method (DuctLossMethodType, Document)

[image]

Revit 2024 API
LabelUtils..::..GetLabelFor Method (DuctLossMethodType, Document)
LabelUtils Class See Also Send Feedback
Gets the user-visible name for a DuctLossMethodType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static string GetLabelFor(
    DuctLossMethodType ductLossMethodType,
    Document doc
)
Visual Basic
Public Shared Function GetLabelFor ( _
    ductLossMethodType As DuctLossMethodType, _
    doc As Document _
) As String
Visual C++
public:
static String^ GetLabelFor(
    DuctLossMethodType ductLossMethodType,
    Document^ doc
)

Parameters

ductLossMethodType
Type: Autodesk.Revit.DB.Mechanical..::..DuctLossMethodType
The DuctLossMethodType to get the user-visible name.
doc
Type: Autodesk.Revit.DB..::..Document
The document from which to get the DuctLossMethodType.

Remarks

The name is obtained in the current Revit language.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when information for the input DuctLossMethodType cannot be found.

See Also

LabelUtils Class
GetLabelFor Overload


GetLabelFor Method (gbXMLBuildingType, Document)

[image]

Revit 2024 API
LabelUtils..::..GetLabelFor Method (gbXMLBuildingType, Document)
LabelUtils Class See Also Send Feedback
Gets the user-visible name for a gbXMLBuildingType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static string GetLabelFor(
    gbXMLBuildingType buildingType,
    Document document
)
Visual Basic
Public Shared Function GetLabelFor ( _
    buildingType As gbXMLBuildingType, _
    document As Document _
) As String
Visual C++
public:
static String^ GetLabelFor(
    gbXMLBuildingType buildingType,
    Document^ document
)

Parameters

buildingType
Type: Autodesk.Revit.DB.Analysis..::..gbXMLBuildingType
The gbXMLBuildingType to get the user-visible name.
document
Type: Autodesk.Revit.DB..::..Document
The document from which to get the gbXMLBuildingType.

Remarks

The name is obtained in the current Revit language.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input gXMLBuildingType is not available in the document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

LabelUtils Class
GetLabelFor Overload


GetLabelFor Method (PipeFlowState, Document)

[image]

Revit 2024 API
LabelUtils..::..GetLabelFor Method (PipeFlowState, Document)
LabelUtils Class See Also Send Feedback
Gets the user-visible name for a PipeFlowState.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static string GetLabelFor(
    PipeFlowState pipeFlowState,
    Document doc
)
Visual Basic
Public Shared Function GetLabelFor ( _
    pipeFlowState As PipeFlowState, _
    doc As Document _
) As String
Visual C++
public:
static String^ GetLabelFor(
    PipeFlowState pipeFlowState,
    Document^ doc
)

Parameters

pipeFlowState
Type: Autodesk.Revit.DB.Plumbing..::..PipeFlowState
The PipeFlowState to get the user-visible name.
doc
Type: Autodesk.Revit.DB..::..Document
The document from which to get the PipeFlowState.

Remarks

The name is obtained in the current Revit language.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when information for the input PipeFlowState cannot be found.

See Also

LabelUtils Class
GetLabelFor Overload


GetLabelForBuiltInParameter Method

[image] [image]

Revit 2024 API
LabelUtils..::..GetLabelForBuiltInParameter Method
LabelUtils Class See Also Send Feedback

Overload List

Name | Description
GetLabelForBuiltInParameter(ForgeTypeId) | Gets the user-visible name for a built-in parameter.
GetLabelForBuiltInParameter(ForgeTypeId, LanguageType) | Gets the user-visible name for a built-in parameter in a specific LanguageType.

See Also

LabelUtils Class
LabelUtils Members


GetLabelForBuiltInParameter Method (ForgeTypeId)

[image]

Revit 2024 API
LabelUtils..::..GetLabelForBuiltInParameter Method (ForgeTypeId)
LabelUtils Class See Also Send Feedback
Gets the user-visible name for a built-in parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static string GetLabelForBuiltInParameter(
    ForgeTypeId parameterTypeId
)
Visual Basic
Public Shared Function GetLabelForBuiltInParameter ( _
    parameterTypeId As ForgeTypeId _
) As String
Visual C++
public:
static String^ GetLabelForBuiltInParameter(
    ForgeTypeId^ parameterTypeId
)

Parameters

parameterTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
Identifier of the built-in parameter to get the user-visible name.

Remarks

The name is obtained in the current Revit language.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the built-in parameter cannot be found.

See Also

LabelUtils Class
GetLabelForBuiltInParameter Overload


GetLabelForBuiltInParameter Method (ForgeTypeId, LanguageType)

[image]

Revit 2024 API
LabelUtils..::..GetLabelForBuiltInParameter Method (ForgeTypeId, LanguageType)
LabelUtils Class See Also Send Feedback
Gets the user-visible name for a built-in parameter in a specific LanguageType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public static string GetLabelForBuiltInParameter(
    ForgeTypeId parameterTypeId,
    LanguageType language
)
Visual Basic
Public Shared Function GetLabelForBuiltInParameter ( _
    parameterTypeId As ForgeTypeId, _
    language As LanguageType _
) As String
Visual C++
public:
static String^ GetLabelForBuiltInParameter(
    ForgeTypeId^ parameterTypeId,
    LanguageType language
)

Parameters

parameterTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
Identifier of the built-in parameter to get the user-visible name.
language
Type: Autodesk.Revit.ApplicationServices..::..LanguageType
The desired LanguageType to get the user-visible name in.

Return Value

The built-in parameter name in the desired LanguageType.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the built-in parameter cannot be found.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the desired LanguageType cannot be found for the built-in parameter name.

See Also

LabelUtils Class
GetLabelForBuiltInParameter Overload


GetLabelForDiscipline Method

[image]

Revit 2024 API
LabelUtils..::..GetLabelForDiscipline Method
LabelUtils Class See Also Send Feedback
Gets the user-visible name for a discipline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public static string GetLabelForDiscipline(
    ForgeTypeId disciplineTypeId
)
Visual Basic
Public Shared Function GetLabelForDiscipline ( _
    disciplineTypeId As ForgeTypeId _
) As String
Visual C++
public:
static String^ GetLabelForDiscipline(
    ForgeTypeId^ disciplineTypeId
)

Parameters

disciplineTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
Identifier of the discipline.

Remarks

The name is obtained in the current Revit language.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Discipline must have a definition.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

LabelUtils Class


GetLabelForSpec Method

[image]

Revit 2024 API
LabelUtils..::..GetLabelForSpec Method
LabelUtils Class See Also Send Feedback
Gets the user-visible name for a spec.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static string GetLabelForSpec(
    ForgeTypeId specTypeId
)
Visual Basic
Public Shared Function GetLabelForSpec ( _
    specTypeId As ForgeTypeId _
) As String
Visual C++
public:
static String^ GetLabelForSpec(
    ForgeTypeId^ specTypeId
)

Parameters

specTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
Identifier of the spec to get the user-visible name.

Remarks

The name is obtained in the current Revit language. If the given identifier is a category, this method returns the name of the Family Type spec with that category, e.g. "Family Type: Walls".

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given identifier is neither a spec nor a category.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

LabelUtils Class


GetLabelForUnit Method

[image]

Revit 2024 API
LabelUtils..::..GetLabelForUnit Method
LabelUtils Class See Also Send Feedback
Gets the user-visible name for a unit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static string GetLabelForUnit(
    ForgeTypeId unitTypeId
)
Visual Basic
Public Shared Function GetLabelForUnit ( _
    unitTypeId As ForgeTypeId _
) As String
Visual C++
public:
static String^ GetLabelForUnit(
    ForgeTypeId^ unitTypeId
)

Parameters

unitTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
Identifier of the unit to get the user-visible name.

Remarks

The name is obtained in the current Revit language.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Cannot find DisplayUnitTypeInfo for the given unit identifier.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

LabelUtils Class


GetStructuralSectionShapeName Method

[image]

Revit 2024 API
LabelUtils..::..GetStructuralSectionShapeName Method
LabelUtils Class See Also Send Feedback
Gets the user-visible name for a StructuralSectionShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static string GetStructuralSectionShapeName(
    StructuralSectionShape shape
)
Visual Basic
Public Shared Function GetStructuralSectionShapeName ( _
    shape As StructuralSectionShape _
) As String
Visual C++
public:
static String^ GetStructuralSectionShapeName(
    StructuralSectionShape shape
)

Parameters

shape
Type: Autodesk.Revit.DB.Structure.StructuralSections..::..StructuralSectionShape
The StructuralSectionShape to get the user-visible name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

LabelUtils Class


LabelUtils Properties

[image] [image]

Revit 2024 API
LabelUtils Properties
LabelUtils Class See Also Send Feedback

The LabelUtils type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

LabelUtils Class


IsValidObject Property

[image]

Revit 2024 API
LabelUtils..::..IsValidObject Property
LabelUtils Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

LabelUtils Class


LayerCategoryType Enumeration

[image]

Revit 2024 API
LayerCategoryType Enumeration
See Also Send Feedback
An enumerated type listing category types supported in an ExportLayerTable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014
Since: 2014

Syntax

C#
public enum LayerCategoryType
Visual Basic
Public Enumeration LayerCategoryType
Visual C++
public enum class LayerCategoryType

Members

Member name | Description
Unsorted | A default unsorted type.
Model | Model categories.
Annotation | Annotation categories.
AnalyticalModel | AnalyticalModel categories.
Imported | Imported categories.
Modifier | A special value related to modifiers.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


LayerModifier Class

[image]

Revit 2024 API
LayerModifier Class
Members See Also Send Feedback
A modifier used to designate extra strings to appear in the exported layer name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class LayerModifier : IDisposable
Visual Basic
Public Class LayerModifier _
    Implements IDisposable
Visual C++
public ref class LayerModifier : IDisposable

Remarks

A modifier consists of a type (from ModifierType and an optional separator. Apply a modifier to one or more ExportLayerInfo objects to modify the layer name that will be assigned when a Revit object is exported.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..LayerModifier

See Also

LayerModifier Members


LayerModifier Members

[image] [image]

Revit 2024 API
LayerModifier Members
LayerModifier Class Constructors Methods Properties See Also Send Feedback

The LayerModifier type exposes the following members.

Constructors

 | Name | Description
Public method | LayerModifier()()()() | Constructs a new LayerModifier with default values.
Public method | LayerModifier(ModifierType, String) | Constructs a new LayerModifier with modifierType and separator.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the LayerModifier
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ModifierType | The modifier type of LayerModifier.
Public property | Separator | The separator string that will follow this modifier in the export layer name.

See Also

LayerModifier Class


LayerModifier Constructor

[image]

Revit 2024 API
LayerModifier Constructor
LayerModifier Class See Also Send Feedback
Constructs a new LayerModifier with default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public LayerModifier()
Visual Basic
Public Sub New
Visual C++
public:
LayerModifier()

See Also

LayerModifier Class
LayerModifier Overload


LayerModifier Constructor (ModifierType, String)

[image]

Revit 2024 API
LayerModifier Constructor (ModifierType, String)
LayerModifier Class See Also Send Feedback
Constructs a new LayerModifier with modifierType and separator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public LayerModifier(
    ModifierType modifierType,
    string separator
)
Visual Basic
Public Sub New ( _
    modifierType As ModifierType, _
    separator As String _
)
Visual C++
public:
LayerModifier(
    ModifierType modifierType,
    String^ separator
)

Parameters

modifierType
Type: Autodesk.Revit.DB..::..ModifierType
The modifier type.
separator
Type: System..::..String
The separator string that will follow this modifier in the export layer name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The provided separator contains invalid characters (most special characters are invalid).
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

LayerModifier Class
LayerModifier Overload


LayerModifier Methods

[image] [image]

Revit 2024 API
LayerModifier Methods
LayerModifier Class See Also Send Feedback

The LayerModifier type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LayerModifier Class


Dispose Method

[image]

Revit 2024 API
LayerModifier..::..Dispose Method
LayerModifier Class See Also Send Feedback
Releases all resources used by the LayerModifier

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

LayerModifier Class


IsValidObject Property

[image]

Revit 2024 API
LayerModifier..::..IsValidObject Property
LayerModifier Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

LayerModifier Class


ModifierType Property

[image]

Revit 2024 API
LayerModifier..::..ModifierType Property
LayerModifier Class See Also Send Feedback
The modifier type of LayerModifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ModifierType ModifierType { get; set; }
Visual Basic
Public Property ModifierType As ModifierType
    Get
    Set
Visual C++
public:
property ModifierType ModifierType {
    ModifierType get ();
    void set (ModifierType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

LayerModifier Class


Separator Property

[image]

Revit 2024 API
LayerModifier..::..Separator Property
LayerModifier Class See Also Send Feedback
The separator string that will follow this modifier in the export layer name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public string Separator { get; set; }
Visual Basic
Public Property Separator As String
    Get
    Set
Visual C++
public:
property String^ Separator {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

LayerModifier Class


LayoutRule Class

[image]

Revit 2024 API
LayoutRule Class
Members See Also Send Feedback
The LayoutRule object is a base object for all type of layout rules for Beam System within the Autodesk Revit API.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public abstract class LayoutRule : APIObject
Visual Basic
Public MustInherit Class LayoutRule _
    Inherits APIObject
Visual C++
public ref class LayoutRule abstract : public APIObject

Remarks

This class just used as the base class of those concrete LayoutRule classes.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..LayoutRule
Autodesk.Revit.DB..::..LayoutRuleClearSpacing
Autodesk.Revit.DB..::..LayoutRuleFixedDistance
Autodesk.Revit.DB..::..LayoutRuleFixedNumber
Autodesk.Revit.DB..::..LayoutRuleMaximumSpacing

See Also

LayoutRule Members


LayoutRule Members

[image] [image]

Revit 2024 API
LayoutRule Members
LayoutRule Class Methods Properties See Also Send Feedback

The LayoutRule type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LayoutRule Class


LayoutRuleClearSpacing Class

[image]

Revit 2024 API
LayoutRuleClearSpacing Class
Members Example See Also Send Feedback
This class indicate the layout rule of a Beam System is Clear-Spacing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class LayoutRuleClearSpacing : LayoutRule
Visual Basic
Public Class LayoutRuleClearSpacing _
    Inherits LayoutRule
Visual C++
public ref class LayoutRuleClearSpacing : public LayoutRule

Remarks

To use this type of LayoutRule, the distance between the beams and the justify-type must be set.

Examples

CopyC#
private bool LayoutRuleClearSpacingInformation(BeamSystem beamSystem)
{
    //get the layoutRule of the beamsystem
    Autodesk.Revit.DB.LayoutRule layoutRule = beamSystem.LayoutRule;

    string message = "BeamSystem layout rule : " + layoutRule;

    //create a new instance of the LayoutRuleClearSpacing class
    LayoutRuleClearSpacing myLayoutRuleClearSpacing =
             new LayoutRuleClearSpacing(10.0, BeamSystemJustifyType.Beginning);

    //set the new layoutRule to the beamsystem
    beamSystem.LayoutRule = myLayoutRuleClearSpacing;

    LayoutRuleClearSpacing clearSpacing = beamSystem.LayoutRule as LayoutRuleClearSpacing;
    if (null == clearSpacing)
    {
        return false;
    }

    //try to get the property value of the beamsystem LayoutRule
    BeamSystemJustifyType justifyType = clearSpacing.JustifyType;

    double spacing = clearSpacing.Spacing;

    message += "\nNew BeamSystem layout rule: " + clearSpacing;
    message += "\nNew BeamSystem spacing: " + spacing;
    message += "\nNew BeamSystem justification: " + justifyType;

    TaskDialog.Show("Revit",message);

    return true;
}
CopyVB.NET
Private Function LayoutRuleClearSpacingInformation(beamSystem As BeamSystem) As Boolean
    'get the layoutRule of the beamsystem
    Dim layoutRule As Autodesk.Revit.DB.LayoutRule = beamSystem.LayoutRule

    Dim message As String = "BeamSystem layout rule : " & layoutRule.ToString()

    'create a new instance of the LayoutRuleClearSpacing class
    Dim myLayoutRuleClearSpacing As New LayoutRuleClearSpacing(10.0, BeamSystemJustifyType.Beginning)

    'set the new layoutRule to the beamsystem
    beamSystem.LayoutRule = myLayoutRuleClearSpacing

    Dim clearSpacing As LayoutRuleClearSpacing = TryCast(beamSystem.LayoutRule, LayoutRuleClearSpacing)
    If clearSpacing Is Nothing Then
        Return False
    End If

    'try to get the property value of the beamsystem LayoutRule
    Dim justifyType As BeamSystemJustifyType = clearSpacing.JustifyType

    Dim spacing As Double = clearSpacing.Spacing

    message += vbLf & "New BeamSystem layout rule: " & clearSpacing.ToString()
    message += vbLf & "New BeamSystem spacing: " & spacing
    message += vbLf & "New BeamSystem justification: " & justifyType

    TaskDialog.Show("Revit", message)

    Return True
End Function

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..LayoutRule
Autodesk.Revit.DB..::..LayoutRuleClearSpacing

See Also

LayoutRuleClearSpacing Members


LayoutRuleClearSpacing Members

[image] [image]

Revit 2024 API
LayoutRuleClearSpacing Members
LayoutRuleClearSpacing Class Constructors Methods Properties See Also Send Feedback

The LayoutRuleClearSpacing type exposes the following members.

Constructors

 | Name | Description
Public method | LayoutRuleClearSpacing | Constructor of LayoutRuleFixedDistance. Create LayoutRuleFixedDistance with the values passed in.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | JustifyType | Get or set the type of justification.
Public property | Spacing | Get or set the spacing of the beam system.

See Also

LayoutRuleClearSpacing Class


LayoutRuleClearSpacing Constructor

[image]

Revit 2024 API
LayoutRuleClearSpacing Constructor
LayoutRuleClearSpacing Class See Also Send Feedback
Constructor of LayoutRuleFixedDistance. Create LayoutRuleFixedDistance with the values passed in.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public LayoutRuleClearSpacing(
    double spacing,
    BeamSystemJustifyType justifyType
)
Visual Basic
Public Sub New ( _
    spacing As Double, _
    justifyType As BeamSystemJustifyType _
)
Visual C++
public:
LayoutRuleClearSpacing(
    double spacing,
    BeamSystemJustifyType justifyType
)

Parameters

spacing
Type: System..::..Double
The value of spacing must be in [0, 30000).
justifyType
Type: Autodesk.Revit.DB..::..BeamSystemJustifyType
The type of the justification, it's corresponding to the items in the element properties dialog.

Remarks

The value of spacing must be in [0, 30000), but in fact the spacing should not be too small or too great.

See Also

LayoutRuleClearSpacing Class


LayoutRuleClearSpacing Methods

[image] [image]

Revit 2024 API
LayoutRuleClearSpacing Methods
LayoutRuleClearSpacing Class See Also Send Feedback

The LayoutRuleClearSpacing type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LayoutRuleClearSpacing Class


LayoutRuleClearSpacing Properties

[image] [image]

Revit 2024 API
LayoutRuleClearSpacing Properties
LayoutRuleClearSpacing Class See Also Send Feedback

The LayoutRuleClearSpacing type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | JustifyType | Get or set the type of justification.
Public property | Spacing | Get or set the spacing of the beam system.

See Also

LayoutRuleClearSpacing Class


JustifyType Property

[image]

Revit 2024 API
LayoutRuleClearSpacing..::..JustifyType Property
LayoutRuleClearSpacing Class See Also Send Feedback
Get or set the type of justification.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public BeamSystemJustifyType JustifyType { get; set; }
Visual Basic
Public Property JustifyType As BeamSystemJustifyType
    Get
    Set
Visual C++
public:
property BeamSystemJustifyType JustifyType {
    BeamSystemJustifyType get ();
    void set (BeamSystemJustifyType value);
}

Remarks

The justifyType passed in must be a valid object.

See Also

LayoutRuleClearSpacing Class


Spacing Property

[image]

Revit 2024 API
LayoutRuleClearSpacing..::..Spacing Property
LayoutRuleClearSpacing Class See Also Send Feedback
Get or set the spacing of the beam system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double Spacing { get; set; }
Visual Basic
Public Property Spacing As Double
    Get
    Set
Visual C++
public:
property double Spacing {
    double get ();
    void set (double value);
}

Remarks

The value of spacing must be in [0, 30000), but in fact the spacing should not be too small or too great.

See Also

LayoutRuleClearSpacing Class


LayoutRuleFixedDistance Class

[image]

Revit 2024 API
LayoutRuleFixedDistance Class
Members Example See Also Send Feedback
This class indicate the layout rule of a Beam System is Fixed-Distance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class LayoutRuleFixedDistance : LayoutRule
Visual Basic
Public Class LayoutRuleFixedDistance _
    Inherits LayoutRule
Visual C++
public ref class LayoutRuleFixedDistance : public LayoutRule

Remarks

To use this type of LayoutRule, the distance between the beams and the justify-type must be set.

Examples

CopyC#
private bool LayoutRuleFixedDistanceInformation(BeamSystem beamSystem)
{
    //get the layoutRule of the beamsystem
    Autodesk.Revit.DB.LayoutRule layoutRule = beamSystem.LayoutRule;

    string message = "BeamSystem layout rule : " + layoutRule;

    //create a new instance of the LayoutRuleClearSpacing class
    LayoutRuleFixedDistance myLayoutRuleFixedDistance =
                new LayoutRuleFixedDistance(10.0, BeamSystemJustifyType.End);

    //set the new layoutRule to the beamsystem
    beamSystem.LayoutRule = myLayoutRuleFixedDistance;

    LayoutRuleFixedDistance fixedDistance = beamSystem.LayoutRule as LayoutRuleFixedDistance;
    if (null == fixedDistance)
    {
        return false;
    }
    //try to get the property value of the beamsystem LayoutRule
    BeamSystemJustifyType justifyType = fixedDistance.JustifyType;

    double spacing = fixedDistance.Spacing;

    message += "\nNew BeamSystem layout rule: " + fixedDistance;
    message += "\nNew BeamSystem spacing: " + spacing;
    message += "\nNew BeamSystem justification: " + justifyType;

    TaskDialog.Show("Revit",message);

    return true;
}
CopyVB.NET
Private Function LayoutRuleFixedDistanceInformation(beamSystem As BeamSystem) As Boolean
    'get the layoutRule of the beamsystem
    Dim layoutRule As Autodesk.Revit.DB.LayoutRule = beamSystem.LayoutRule

    Dim message As String = "BeamSystem layout rule : " & layoutRule.ToString()

    'create a new instance of the LayoutRuleClearSpacing class
    Dim myLayoutRuleFixedDistance As New LayoutRuleFixedDistance(10.0, BeamSystemJustifyType.[End])

    'set the new layoutRule to the beamsystem
    beamSystem.LayoutRule = myLayoutRuleFixedDistance

    Dim fixedDistance As LayoutRuleFixedDistance = TryCast(beamSystem.LayoutRule, LayoutRuleFixedDistance)
    If fixedDistance Is Nothing Then
        Return False
    End If
    'try to get the property value of the beamsystem LayoutRule
    Dim justifyType As BeamSystemJustifyType = fixedDistance.JustifyType

    Dim spacing As Double = fixedDistance.Spacing

    message += vbLf & "New BeamSystem layout rule: " & fixedDistance.ToString()
    message += vbLf & "New BeamSystem spacing: " & spacing
    message += vbLf & "New BeamSystem justification: " & justifyType

    TaskDialog.Show("Revit", message)

    Return True
End Function

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..LayoutRule
Autodesk.Revit.DB..::..LayoutRuleFixedDistance

See Also

LayoutRuleFixedDistance Members


LayoutRuleFixedDistance Members

[image] [image]

Revit 2024 API
LayoutRuleFixedDistance Members
LayoutRuleFixedDistance Class Constructors Methods Properties See Also Send Feedback

The LayoutRuleFixedDistance type exposes the following members.

Constructors

 | Name | Description
Public method | LayoutRuleFixedDistance | Constructor of LayoutRuleFixedDistance. Create LayoutRuleFixedDistance with the values passed in.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | JustifyType | Get or set the type of justification.
Public property | Spacing | Get or set spacing of the Beam System.

See Also

LayoutRuleFixedDistance Class


LayoutRuleFixedDistance Constructor

[image]

Revit 2024 API
LayoutRuleFixedDistance Constructor
LayoutRuleFixedDistance Class See Also Send Feedback
Constructor of LayoutRuleFixedDistance. Create LayoutRuleFixedDistance with the values passed in.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public LayoutRuleFixedDistance(
    double spacing,
    BeamSystemJustifyType justifyType
)
Visual Basic
Public Sub New ( _
    spacing As Double, _
    justifyType As BeamSystemJustifyType _
)
Visual C++
public:
LayoutRuleFixedDistance(
    double spacing,
    BeamSystemJustifyType justifyType
)

Parameters

spacing
Type: System..::..Double
The value of spacing must be between 0 and 30000.
justifyType
Type: Autodesk.Revit.DB..::..BeamSystemJustifyType
The type of the justification, it's corresponding to the items in the element properties dialog.

See Also

LayoutRuleFixedDistance Class


LayoutRuleFixedDistance Methods

[image] [image]

Revit 2024 API
LayoutRuleFixedDistance Methods
LayoutRuleFixedDistance Class See Also Send Feedback

The LayoutRuleFixedDistance type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LayoutRuleFixedDistance Class


JustifyType Property

[image]

Revit 2024 API
LayoutRuleFixedDistance..::..JustifyType Property
LayoutRuleFixedDistance Class See Also Send Feedback
Get or set the type of justification.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public BeamSystemJustifyType JustifyType { get; set; }
Visual Basic
Public Property JustifyType As BeamSystemJustifyType
    Get
    Set
Visual C++
public:
property BeamSystemJustifyType JustifyType {
    BeamSystemJustifyType get ();
    void set (BeamSystemJustifyType value);
}

Remarks

The justifyType passed in must be a valid object.

See Also

LayoutRuleFixedDistance Class


Spacing Property

[image]

Revit 2024 API
LayoutRuleFixedDistance..::..Spacing Property
LayoutRuleFixedDistance Class See Also Send Feedback
Get or set spacing of the Beam System.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double Spacing { get; set; }
Visual Basic
Public Property Spacing As Double
    Get
    Set
Visual C++
public:
property double Spacing {
    double get ();
    void set (double value);
}

Remarks

The value of spacing must be between 0 and 30000.

See Also

LayoutRuleFixedDistance Class


LayoutRuleFixedNumber Class

[image]

Revit 2024 API
LayoutRuleFixedNumber Class
Members Example See Also Send Feedback
This class indicate the layout rule of a Beam System is Fixed-Number.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class LayoutRuleFixedNumber : LayoutRule
Visual Basic
Public Class LayoutRuleFixedNumber _
    Inherits LayoutRule
Visual C++
public ref class LayoutRuleFixedNumber : public LayoutRule

Remarks

To use this type of LayoutRule, only the number of the beams must be set.

Examples

CopyC#
private bool LayoutRuleFixedNumberInformation(BeamSystem beamSystem)
{
    //get the layoutRule of the beamsystem
    Autodesk.Revit.DB.LayoutRule layoutRule = beamSystem.LayoutRule;

    string message = "BeamSystem layout rule : " + layoutRule;

    //create a new instance of the LayoutRuleClearSpacing class
    LayoutRuleFixedNumber myLayoutRuleFixedNumber =
                        new LayoutRuleFixedNumber(8);

    //set the new layoutRule to the beamsystem
    beamSystem.LayoutRule = myLayoutRuleFixedNumber;

    LayoutRuleFixedNumber fixedNumber = beamSystem.LayoutRule as LayoutRuleFixedNumber;

    if (null == fixedNumber)
    {
        return false;
    }
    //try to get the property value of the beamsystem LayoutRule
    int numberOfLines = fixedNumber.NumberOfLines;

    message += "\nNew BeamSystem layout rule: " + fixedNumber;
    message += "\nNew BeamSystem number of beams: " + numberOfLines;

    TaskDialog.Show("Revit",message);

    return true;
}
CopyVB.NET
Private Function LayoutRuleFixedNumberInformation(beamSystem As BeamSystem) As Boolean
    'get the layoutRule of the beamsystem
    Dim layoutRule As Autodesk.Revit.DB.LayoutRule = beamSystem.LayoutRule

    Dim message As String = "BeamSystem layout rule : " & layoutRule.ToString()

    'create a new instance of the LayoutRuleClearSpacing class
    Dim myLayoutRuleFixedNumber As New LayoutRuleFixedNumber(8)

    'set the new layoutRule to the beamsystem
    beamSystem.LayoutRule = myLayoutRuleFixedNumber

    Dim fixedNumber As LayoutRuleFixedNumber = TryCast(beamSystem.LayoutRule, LayoutRuleFixedNumber)

    If fixedNumber Is Nothing Then
        Return False
    End If
    'try to get the property value of the beamsystem LayoutRule
    Dim numberOfLines As Integer = fixedNumber.NumberOfLines

    message += vbLf & "New BeamSystem layout rule: " & fixedNumber.ToString()
    message += vbLf & "New BeamSystem number of beams: " & numberOfLines

    TaskDialog.Show("Revit", message)

    Return True
End Function

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..LayoutRule
Autodesk.Revit.DB..::..LayoutRuleFixedNumber

See Also

LayoutRuleFixedNumber Members


LayoutRuleFixedNumber Constructor

[image]

Revit 2024 API
LayoutRuleFixedNumber Constructor
LayoutRuleFixedNumber Class See Also Send Feedback
Constructor of LayoutRuleFixedNumber.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public LayoutRuleFixedNumber(
    int numberOfLines
)
Visual Basic
Public Sub New ( _
    numberOfLines As Integer _
)
Visual C++
public:
LayoutRuleFixedNumber(
    int numberOfLines
)

Parameters

numberOfLines
Type: System..::..Int32
The value of numberOfLines must be positive.

Remarks

Create a LayoutRuleFixedNumber object with the number of the beams and this number must be positive.

See Also

LayoutRuleFixedNumber Class


LayoutRuleFixedNumber Methods

[image] [image]

Revit 2024 API
LayoutRuleFixedNumber Methods
LayoutRuleFixedNumber Class See Also Send Feedback

The LayoutRuleFixedNumber type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LayoutRuleFixedNumber Class


LayoutRuleFixedNumber Properties

[image] [image]

Revit 2024 API
LayoutRuleFixedNumber Properties
LayoutRuleFixedNumber Class See Also Send Feedback

The LayoutRuleFixedNumber type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | NumberOfLines | Get or set the number of the beams in a beam system.

See Also

LayoutRuleFixedNumber Class


LayoutRuleMaximumSpacing Members

[image] [image]

Revit 2024 API
LayoutRuleMaximumSpacing Members
LayoutRuleMaximumSpacing Class Constructors Methods Properties See Also Send Feedback

The LayoutRuleMaximumSpacing type exposes the following members.

Constructors

 | Name | Description
Public method | LayoutRuleMaximumSpacing | Constructor of LayoutRuleMaximumSpacing.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Spacing | Get or set the spacing of the beam system.

See Also

LayoutRuleMaximumSpacing Class


LayoutRuleMaximumSpacing Constructor

[image]

Revit 2024 API
LayoutRuleMaximumSpacing Constructor
LayoutRuleMaximumSpacing Class See Also Send Feedback
Constructor of LayoutRuleMaximumSpacing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public LayoutRuleMaximumSpacing(
    double spacing
)
Visual Basic
Public Sub New ( _
    spacing As Double _
)
Visual C++
public:
LayoutRuleMaximumSpacing(
    double spacing
)

Parameters

spacing
Type: System..::..Double
The value of spacing must be in (0, 30000).

Remarks

The value of spacing must be in (0, 30000), but in fact the spacing should not be too small or too great.

See Also

LayoutRuleMaximumSpacing Class


LayoutRuleMaximumSpacing Methods

[image] [image]

Revit 2024 API
LayoutRuleMaximumSpacing Methods
LayoutRuleMaximumSpacing Class See Also Send Feedback

The LayoutRuleMaximumSpacing type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LayoutRuleMaximumSpacing Class


LayoutRuleMaximumSpacing Properties

[image] [image]

Revit 2024 API
LayoutRuleMaximumSpacing Properties
LayoutRuleMaximumSpacing Class See Also Send Feedback

The LayoutRuleMaximumSpacing type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Spacing | Get or set the spacing of the beam system.

See Also

LayoutRuleMaximumSpacing Class


Spacing Property

[image]

Revit 2024 API
LayoutRuleMaximumSpacing..::..Spacing Property
LayoutRuleMaximumSpacing Class See Also Send Feedback
Get or set the spacing of the beam system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double Spacing { get; set; }
Visual Basic
Public Property Spacing As Double
    Get
    Set
Visual C++
public:
property double Spacing {
    double get ();
    void set (double value);
}

Remarks

The value of spacing must be in (0, 30000), but in fact the spacing should not be too small or too great.

See Also

LayoutRuleMaximumSpacing Class


Leader Class

[image]

Revit 2024 API
Leader Class
Members See Also Send Feedback
A leader object that can be attached to annotation elements such as text notes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class Leader : APIObject
Visual Basic
Public Class Leader _
    Inherits APIObject
Visual C++
public ref class Leader : public APIObject

Remarks

For information on how to attach or get leaders to/from a text annotation refer to corresponding methods of TextNote class.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..Leader

See Also

Leader Members


Leader Methods

[image] [image]

Revit 2024 API
Leader Methods
Leader Class See Also Send Feedback

The Leader type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Leader Class


Leader Properties

[image] [image]

Revit 2024 API
Leader Properties
Leader Class See Also Send Feedback

The Leader type exposes the following members.

Properties

 | Name | Description
Public property | Anchor | Anchor point of the Leader
Public property | Elbow | Elbow point of the Leader.
Public property | End | End point of the Leader.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LeaderShape | Geometric style of the leader

See Also

Leader Class


Anchor Property

[image]

Revit 2024 API
Leader..::..Anchor Property
Leader Class See Also Send Feedback
Anchor point of the Leader

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public XYZ Anchor { get; }
Visual Basic
Public ReadOnly Property Anchor As XYZ
    Get
Visual C++
public:
property XYZ^ Anchor {
    XYZ^ get ();
}

Remarks

Anchor is the leader's point that is attached to an annotation (a tag, note, etc.) This is a read-only property, for the this point gets always computed based on various properties of the annotation element.

See Also

Leader Class


End Property

[image]

Revit 2024 API
Leader..::..End Property
Leader Class See Also Send Feedback
End point of the Leader.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ End { get; set; }
Visual Basic
Public Property End As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ End {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

The End point is the leader's end that points to the object being annotated.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: A valid point must not be father then 10 miles (approx. 16 km) from the origin. -or- When setting this property: The leader's End point may not be placed at the current position of the Anchor or Elbow point.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The leader is not currently owned by a valid element. A probable reason for that could be if the element has been independently deleted, or the leader has never been properly initialized.

See Also

Leader Class


LeaderShape Property

[image]

Revit 2024 API
Leader..::..LeaderShape Property
Leader Class See Also Send Feedback
Geometric style of the leader

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public LeaderShape LeaderShape { get; }
Visual Basic
Public ReadOnly Property LeaderShape As LeaderShape
    Get
Visual C++
public:
property LeaderShape LeaderShape {
    LeaderShape get ();
}

Remarks

While this property cannot be changed directly, it can change, with limitations, as an effect of other changes to either the leader itself or the annotation element the leader is associated with. For example, straight-line leaders have no elbow points; but if an elbow point is set for a straight leader, which is allowed, it will effectively change the leader's shape to a kinked line.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The leader is not currently owned by a valid element. A probable reason for that could be if the element has been independently deleted, or the leader has never been properly initialized.

See Also

Leader Class


LeaderArray Class

[image]

Revit 2024 API
LeaderArray Class
Members See Also Send Feedback
An array that can contain any number of leaders.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class LeaderArray : APIObject,
    IEnumerable
Visual Basic
Public Class LeaderArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class LeaderArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..LeaderArray

See Also

LeaderArray Members


LeaderArray Methods

[image] [image]

Revit 2024 API
LeaderArray Methods
LeaderArray Class See Also Send Feedback

The LeaderArray type exposes the following members.

Methods

 | Name | Description
Public method | Append | Add the item to the end of the array.
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LeaderArray Class


Clear Method

[image]

Revit 2024 API
LeaderArray..::..Clear Method
LeaderArray Class See Also Send Feedback
Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

LeaderArray Class


ForwardIterator Method

[image]

Revit 2024 API
LeaderArray..::..ForwardIterator Method
LeaderArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual LeaderArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As LeaderArrayIterator
Visual C++
public:
virtual LeaderArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

LeaderArray Class


GetEnumerator Method

[image]

Revit 2024 API
LeaderArray..::..GetEnumerator Method
LeaderArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

LeaderArray Class


LeaderArray Properties

[image] [image]

Revit 2024 API
LeaderArray Properties
LeaderArray Class See Also Send Feedback

The LeaderArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

LeaderArray Class


IsEmpty Property

[image]

Revit 2024 API
LeaderArray..::..IsEmpty Property
LeaderArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

LeaderArray Class


Item Property

[image]

Revit 2024 API
LeaderArray..::..Item Property
LeaderArray Class See Also Send Feedback
Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Leader this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As Leader
    Get
    Set
Visual C++
public:
virtual property Leader^ Item[int index] {
    Leader^ get (int index);
    void set (int index, Leader^ value);
}

Parameters

index
Type: System..::..Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

LeaderArray Class


Size Property

[image]

Revit 2024 API
LeaderArray..::..Size Property
LeaderArray Class See Also Send Feedback
Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

LeaderArray Class


LeaderArrayIterator Class

[image]

Revit 2024 API
LeaderArrayIterator Class
Members See Also Send Feedback
An iterator to an array of leaders.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public abstract class LeaderArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class LeaderArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class LeaderArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..LeaderArrayIterator

See Also

LeaderArrayIterator Members


LeaderArrayIterator Members

[image] [image]

Revit 2024 API
LeaderArrayIterator Members
LeaderArrayIterator Class Constructors Methods Properties See Also Send Feedback

The LeaderArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | LeaderArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LeaderArrayIterator Class


LeaderArrayIterator Methods

[image] [image]

Revit 2024 API
LeaderArrayIterator Methods
LeaderArrayIterator Class See Also Send Feedback

The LeaderArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LeaderArrayIterator Class


Reset Method

[image]

Revit 2024 API
LeaderArrayIterator..::..Reset Method
LeaderArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

LeaderArrayIterator Class


Current Property

[image]

Revit 2024 API
LeaderArrayIterator..::..Current Property
LeaderArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

LeaderArrayIterator Class


LeaderAtachement Enumeration

[image]

Revit 2024 API
LeaderAtachement Enumeration
See Also Send Feedback
Supported types of vertical attachments of a leader to a text note.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016
Since: 2016

Syntax

C#
public enum LeaderAtachement
Visual Basic
Public Enumeration LeaderAtachement
Visual C++
public enum class LeaderAtachement

Members

Member name | Description
TopLine | Leaders are attached at the position of the top (first) line of the text box, and, unless the text's border is visible, the leader's shoulder line extends all the way to the text, minus the current value of text border offset.
Midpoint | Leaders are aligned vertically with the midpoint of the text box and their shoulder line always ends at the box' border regardless of whether the border is visible on not.
BottomLine | Leaders are attached at the position of the bottom (last) line of the text box, and, unless the text's border is visible, the leader's shoulder line extends all the way to the text, minus the current value of text border offset.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


LeaderEndCondition Enumeration

[image]

Revit 2024 API
LeaderEndCondition Enumeration
See Also Send Feedback
An enumerated type listing Leader end conditions that are supported for IndependentTags.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum LeaderEndCondition
Visual Basic
Public Enumeration LeaderEndCondition
Visual C++
public enum class LeaderEndCondition

Members

Member name | Description
Attached | The Leader of the tag is attached.
Free | The Leader of the tag is free.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


LeaderShape Enumeration

[image]

Revit 2024 API
LeaderShape Enumeration
See Also Send Feedback
Supported geometric shapes of annotation leaders.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016
Since: 2016

Syntax

C#
public enum LeaderShape
Visual Basic
Public Enumeration LeaderShape
Visual C++
public enum class LeaderShape

Members

Member name | Description
Straight | A single straight line between the end point and anchor point.
Kinked | A kinked line with a shoulder defined by an elbow point.
Arc | An arc between between the end point and anchor point. In this shape the elbow point controls the arc's radius.

Remarks

Although the Leader class supports all available shapes, not all types of leaders may have the option to change its shape. For example, leaders of text annotations can be of any shape, while leaders of level lines are never curved.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


LeadersPresentationMode Enumeration

[image]

Revit 2024 API
LeadersPresentationMode Enumeration
See Also Send Feedback
Leaders Presentation Mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023
Since: 2023

Syntax

C#
public enum LeadersPresentationMode
Visual Basic
Public Enumeration LeadersPresentationMode
Visual C++
public enum class LeadersPresentationMode

Members

Member name | Description
ShowAll | Show all tag leaders.
HideAll | Hide all tag leaders.
ShowOnlyOne | Show only one leader.
ShowSpecificLeaders | Show specific leaders.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


Level Class

[image]

Revit 2024 API
Level Class
Members Example See Also Send Feedback
Represents a Level within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class Level : DatumPlane
Visual Basic
Public Class Level _
    Inherits DatumPlane
Visual C++
public ref class Level : public DatumPlane

Remarks

A Level is conceptually a horizontal rectangle of finite extents. It appears as a straight line in views that intersect the rectangle. The straight line represents the projection of the rectangle onto the view. The Name property can be used to retrieve the user visible name of the level that appears in the level bubble.

Examples

CopyC#
private void GetLevelInformation(Autodesk.Revit.DB.Element element)
{
    // Get the level object to which the element is assigned.
    if (element.LevelId.Equals(ElementId.InvalidElementId))
    {
        TaskDialog.Show("Revit","The element isn't based on a level.");
    }
    else
    {
        Level level = element.Document.GetElement(element.LevelId) as Level;

        // Format the prompt information(Name and elevation)
        String prompt = "The element is based on a level.";
        prompt += "\nThe level name is:  " + level.Name;
        prompt += "\nThe level elevation is:  " + level.Elevation;

        // Show the information to the user.
        TaskDialog.Show("Revit",prompt);
    }
}
CopyC#
private void Getinfo_Level(Document document)
{
    StringBuilder levelInformation = new StringBuilder();
    int levelNumber = 0;
    FilteredElementCollector collector = new FilteredElementCollector(document);
    ICollection<Element> collection = collector.OfClass(typeof(Level)).ToElements();
    foreach (Element e in collection)
    {
        Level level = e as Level;

        if (null != level)
        {
            // keep track of number of levels
            levelNumber++;

            //get the name of the level
            levelInformation.Append("\nLevel Name: " + level.Name);

            //get the elevation of the level
            levelInformation.Append("\n\tElevation: " + level.Elevation);

            // get the project elevation of the level
            levelInformation.Append("\n\tProject Elevation: " + level.ProjectElevation);
        }
    }

    //number of total levels in current document
    levelInformation.Append("\n\n There are " + levelNumber + " levels in the document!");

    //show the level information in the messagebox
    TaskDialog.Show("Revit",levelInformation.ToString());
}
CopyVB.NET
Private Sub GetLevelInformation(element As Autodesk.Revit.DB.Element)
    ' Get the level object to which the element is assigned.
    If element.LevelId.Equals(ElementId.InvalidElementId) Then
        TaskDialog.Show("Revit", "The element isn't based on a level.")
    Else
        Dim level As Level = TryCast(element.Document.GetElement(element.LevelId), Level)

        ' Format the prompt information(Name and elevation)
        Dim prompt As [String] = "The element is based on a level."
        prompt += vbLf & "The level name is:  " + level.Name
        prompt += vbLf & "The level elevation is:  " + level.Elevation

        ' Show the information to the user.
        TaskDialog.Show("Revit", prompt)
    End If
End Sub
CopyVB.NET
Private Sub Getinfo_Level(document As Document)
    Dim levelInformation As New StringBuilder()
    Dim levelNumber As Integer = 0
    Dim collector As New FilteredElementCollector(document)
    Dim collection As ICollection(Of Element) = collector.OfClass(GetType(Level)).ToElements()
    For Each e As Element In collection
        Dim level As Level = TryCast(e, Level)

        If level IsNot Nothing Then
            ' keep track of number of levels
            levelNumber += 1

            'get the name of the level
            levelInformation.Append(vbLf & "Level Name: " + level.Name)

            'get the elevation of the level
            levelInformation.Append(vbLf & vbTab & "Elevation: " + level.Elevation)

            ' get the project elevation of the level
            levelInformation.Append(vbLf & vbTab & "Project Elevation: " + level.ProjectElevation)
        End If
    Next

    'number of total levels in current document
    levelInformation.Append(vbLf & vbLf & " There are " & levelNumber & " levels in the document!")

    'show the level information in the messagebox
    TaskDialog.Show("Revit", levelInformation.ToString())
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..DatumPlane
Autodesk.Revit.DB..::..Level

See Also

Level Members


Level Members

[image] [image]

Revit 2024 API
Level Members
Level Class Methods Properties See Also Send Feedback

The Level type exposes the following members.

Methods

 | Name | Description
Public method | AddLeader | Adds a default Leader for the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders). (Inherited from DatumPlane.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanBeVisibleInView | Checks if the datum plane can be visible in the view. (Inherited from DatumPlane.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create | Creates a new instance of level based on an input elevation.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | FindAssociatedPlanViewId | Finds the id of the first available associated floor or structural plan view associated with this level.
Public method | GetCurvesInView | Gets a collection of curves representing the DatumPlane element in the given view. (Inherited from DatumPlane.)
Public method | GetDatumExtentTypeInView | Identifies whether the curve representing the datum plane is displayed according to its actual 3d extents, or else according to a view specific setting. (Inherited from DatumPlane.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLeader | Gets a copy of the leader applied to the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders). (Inherited from DatumPlane.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
 | GetNearestLevelId(Document, Double) | Returns id of the Level which is closest to the specified elevation.
 | GetNearestLevelId(Document, Double, Double%) | Returns id of the Level which is closest to the specified elevation.
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPlaneReference | Returns a reference to this element as a plane.
Public method | GetPropagationViews | Gets a list of candidate views which are parallel to the current view and to which the extents of the datum may be propagated. (Inherited from DatumPlane.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasBubbleInView | Identifies if the DatumPlane has bubble or not. (Inherited from DatumPlane.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HideBubbleInView | Hides the bubble in a view. This method does not apply to Reference planes. (Inherited from DatumPlane.)
Public method | IsBubbleVisibleInView | Identifies if the bubble is visible or not in a view. (Inherited from DatumPlane.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsCurveValidInView | Checks if the curve is valid to be as the extents for the datum plane in a view. The curve must be bound and coincident with the original one of the datum plane. (Inherited from DatumPlane.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsLeaderValid | Identifies if the leader valid or not for this DatumPlane. This method does not apply to Reference planes (which do not support leaders). (Inherited from DatumPlane.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | Maximize3DExtents | Computes the 3d extents of all model geometry and levels, and extends the 3d extents of this datum surface to include the model extents. (Inherited from DatumPlane.)
Public method | PropagateToViews | Propagates the extents applied to this datum in the view to the specified parallel views. (Inherited from DatumPlane.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetCurveInView | Sets the extents to match the curve. (Inherited from DatumPlane.)
Public method | SetDatumExtentType | Sets whether the curve representing the datum plane is displayed according to its 3d extents, or else according to a view specific setting. (Inherited from DatumPlane.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetLeader | Sets the leader to the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders). (Inherited from DatumPlane.)
Public method | ShowBubbleInView | Shows the bubble in a view. This method does not apply to Reference planes. (Inherited from DatumPlane.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Elevation | Retrieves or changes the elevation above or below the ground level.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ProjectElevation | Retrieves the elevation relative to project origin, no matter what values of the Elevation Base parameter is set.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Level Class


Level Methods

[image] [image]

Revit 2024 API
Level Methods
Level Class See Also Send Feedback

The Level type exposes the following members.

Methods

 | Name | Description
Public method | AddLeader | Adds a default Leader for the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders). (Inherited from DatumPlane.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanBeVisibleInView | Checks if the datum plane can be visible in the view. (Inherited from DatumPlane.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create | Creates a new instance of level based on an input elevation.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | FindAssociatedPlanViewId | Finds the id of the first available associated floor or structural plan view associated with this level.
Public method | GetCurvesInView | Gets a collection of curves representing the DatumPlane element in the given view. (Inherited from DatumPlane.)
Public method | GetDatumExtentTypeInView | Identifies whether the curve representing the datum plane is displayed according to its actual 3d extents, or else according to a view specific setting. (Inherited from DatumPlane.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLeader | Gets a copy of the leader applied to the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders). (Inherited from DatumPlane.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
 | GetNearestLevelId(Document, Double) | Returns id of the Level which is closest to the specified elevation.
 | GetNearestLevelId(Document, Double, Double%) | Returns id of the Level which is closest to the specified elevation.
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPlaneReference | Returns a reference to this element as a plane.
Public method | GetPropagationViews | Gets a list of candidate views which are parallel to the current view and to which the extents of the datum may be propagated. (Inherited from DatumPlane.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasBubbleInView | Identifies if the DatumPlane has bubble or not. (Inherited from DatumPlane.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HideBubbleInView | Hides the bubble in a view. This method does not apply to Reference planes. (Inherited from DatumPlane.)
Public method | IsBubbleVisibleInView | Identifies if the bubble is visible or not in a view. (Inherited from DatumPlane.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsCurveValidInView | Checks if the curve is valid to be as the extents for the datum plane in a view. The curve must be bound and coincident with the original one of the datum plane. (Inherited from DatumPlane.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsLeaderValid | Identifies if the leader valid or not for this DatumPlane. This method does not apply to Reference planes (which do not support leaders). (Inherited from DatumPlane.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | Maximize3DExtents | Computes the 3d extents of all model geometry and levels, and extends the 3d extents of this datum surface to include the model extents. (Inherited from DatumPlane.)
Public method | PropagateToViews | Propagates the extents applied to this datum in the view to the specified parallel views. (Inherited from DatumPlane.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetCurveInView | Sets the extents to match the curve. (Inherited from DatumPlane.)
Public method | SetDatumExtentType | Sets whether the curve representing the datum plane is displayed according to its 3d extents, or else according to a view specific setting. (Inherited from DatumPlane.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetLeader | Sets the leader to the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders). (Inherited from DatumPlane.)
Public method | ShowBubbleInView | Shows the bubble in a view. This method does not apply to Reference planes. (Inherited from DatumPlane.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Level Class


GetNearestLevelId Method

[image] [image]

Revit 2024 API
Level..::..GetNearestLevelId Method
Level Class See Also Send Feedback

Overload List

Name | Description
GetNearestLevelId(Document, Double) | Returns id of the Level which is closest to the specified elevation.
GetNearestLevelId(Document, Double, Double%) | Returns id of the Level which is closest to the specified elevation.

See Also

Level Class
Level Members


GetNearestLevelId Method (Document, Double)

[image]

Revit 2024 API
Level..::..GetNearestLevelId Method (Document, Double)
Level Class See Also Send Feedback
Returns id of the Level which is closest to the specified elevation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public static ElementId GetNearestLevelId(
    Document document,
    double elevation
)
Visual Basic
Public Shared Function GetNearestLevelId ( _
    document As Document, _
    elevation As Double _
) As ElementId
Visual C++
public:
static ElementId^ GetNearestLevelId(
    Document^ document,
    double elevation
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
elevation
Type: System..::..Double
Target Elevation.

Remarks

The level can be at, above or below the target elevation. If there is more than one Level at the same distance from the elevation, the Level with the lowest Id will be returned.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Level Class
GetNearestLevelId Overload


GetNearestLevelId Method (Document, Double, Double)

[image]

Revit 2024 API
Level..::..GetNearestLevelId Method (Document, Double, Double%)
Level Class See Also Send Feedback
Returns id of the Level which is closest to the specified elevation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public static ElementId GetNearestLevelId(
    Document document,
    double elevation,
    out double offset
)
Visual Basic
Public Shared Function GetNearestLevelId ( _
    document As Document, _
    elevation As Double, _
    <OutAttribute> ByRef offset As Double _
) As ElementId
Visual C++
public:
static ElementId^ GetNearestLevelId(
    Document^ document,
    double elevation,
    [OutAttribute] double% offset
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
elevation
Type: System..::..Double
Target Elevation.
offset
Type: System..::..Double%
Vertical offset from the level to the target elevation.

Remarks

The level can be at, above or below the target elevation. If there is more than one Level at the same distance from the elevation, the Level with the lowest Id will be returned.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Level Class
GetNearestLevelId Overload


GetPlaneReference Method

[image]

Revit 2024 API
Level..::..GetPlaneReference Method
Level Class See Also Send Feedback
Returns a reference to this element as a plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public Reference GetPlaneReference()
Visual Basic
Public Function GetPlaneReference As Reference
Visual C++
public:
Reference^ GetPlaneReference()

See Also

Level Class


Level Properties

[image] [image]

Revit 2024 API
Level Properties
Level Class See Also Send Feedback

The Level type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Elevation | Retrieves or changes the elevation above or below the ground level.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ProjectElevation | Retrieves the elevation relative to project origin, no matter what values of the Elevation Base parameter is set.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Level Class


Elevation Property

[image]

Revit 2024 API
Level..::..Elevation Property
Level Class See Also Send Feedback
Retrieves or changes the elevation above or below the ground level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double Elevation { get; set; }
Visual Basic
Public Property Elevation As Double
    Get
    Set
Visual C++
public:
property double Elevation {
    double get ();
    void set (double value);
}

Remarks

This property retrieves or changes the elevation above or below the ground level of the project. If the Elevation Base parameter is set to Project, the elevation is relative to project origin. If the Elevation Base parameter is set to Shared, the elevation is relative to shared origin which can be changed by relocate operation. The value is given in decimal feet.

See Also

Level Class


Parameter Property

[image] [image]

Revit 2024 API
Level..::..Parameter Property
Level Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Level Class
Level Members


ProjectElevation Property

[image]

Revit 2024 API
Level..::..ProjectElevation Property
Level Class See Also Send Feedback
Retrieves the elevation relative to project origin, no matter what values of the Elevation Base parameter is set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double ProjectElevation { get; }
Visual Basic
Public ReadOnly Property ProjectElevation As Double
    Get
Visual C++
public:
property double ProjectElevation {
    double get ();
}

Remarks

This read only property returns the elevation relative to project origin.

See Also

Level Class


LevelAssociationData Methods

[image] [image]

Revit 2024 API
LevelAssociationData Methods
LevelAssociationData Class See Also Send Feedback

The LevelAssociationData type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAssociatedLevel | Returns the Associated Level id.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLevelAssociationData | Returns LevelAssociationData associated with this element, if it exists.
Public method | GetLevelOffset | Returns the offset from the Associated Level.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetAssociatedLevel | Sets the Associated Level.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LevelAssociationData Class


Dispose Method

[image]

Revit 2024 API
LevelAssociationData..::..Dispose Method
LevelAssociationData Class See Also Send Feedback
Releases all resources used by the LevelAssociationData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

LevelAssociationData Class


GetLevelAssociationData Method

[image]

Revit 2024 API
LevelAssociationData..::..GetLevelAssociationData Method
LevelAssociationData Class See Also Send Feedback
Returns LevelAssociationData associated with this element, if it exists.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public static LevelAssociationData GetLevelAssociationData(
    Element element
)
Visual Basic
Public Shared Function GetLevelAssociationData ( _
    element As Element _
) As LevelAssociationData
Visual C++
public:
static LevelAssociationData^ GetLevelAssociationData(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The element from which we try to obtain LevelAssociationData.

Remarks

If the input element doesn't have LevelAssociationData than it retuns nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

LevelAssociationData Class


GetLevelOffset Method

[image]

Revit 2024 API
LevelAssociationData..::..GetLevelOffset Method
LevelAssociationData Class See Also Send Feedback
Returns the offset from the Associated Level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public double GetLevelOffset()
Visual Basic
Public Function GetLevelOffset As Double
Visual C++
public:
double GetLevelOffset()

See Also

LevelAssociationData Class


LevelAssociationData Properties

[image] [image]

Revit 2024 API
LevelAssociationData Properties
LevelAssociationData Class See Also Send Feedback

The LevelAssociationData type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

LevelAssociationData Class


IsValidObject Property

[image]

Revit 2024 API
LevelAssociationData..::..IsValidObject Property
LevelAssociationData Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

LevelAssociationData Class


LevelType Members

[image] [image]

Revit 2024 API
LevelType Members
LevelType Class Methods Properties See Also Send Feedback

The LevelType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

LevelType Class


LevelType Methods

[image] [image]

Revit 2024 API
LevelType Methods
LevelType Class See Also Send Feedback

The LevelType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LevelType Class


Parameter Property

[image] [image]

Revit 2024 API
LevelType..::..Parameter Property
LevelType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

LevelType Class
LevelType Members


LightAndMaterialAccuracyMode Enumeration

[image]

Revit 2024 API
LightAndMaterialAccuracyMode Enumeration
See Also Send Feedback
An enumerated type containing possible Light and Material Accuracy modes for Raytracer render.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public enum LightAndMaterialAccuracyMode
Visual Basic
Public Enumeration LightAndMaterialAccuracyMode
Visual C++
public enum class LightAndMaterialAccuracyMode

Members

Member name | Description
Simplified | Rough and semi-rough materials are approximated. Consequently, materials may look more shinier than expected. Lighting is approximated so shadows will lack in details.
Advanced | Soft shadows and soft reflections from semi-rough materials will be rendered with a high quality level. This is the standard setting that you typically want to rely on for final high quality renderings.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


LightNode Class

[image]

Revit 2024 API
LightNode Class
Members See Also Send Feedback
This class represents a Light element in a model-exporting process.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class LightNode : ContentNode
Visual Basic
Public Class LightNode _
    Inherits ContentNode
Visual C++
public ref class LightNode : public ContentNode

Remarks

See also: [!:Autodesk::Revit::DB::IExportContext::OnLight].

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..RenderNode
Autodesk.Revit.DB..::..ContentNode
Autodesk.Revit.DB..::..LightNode

See Also

LightNode Members


LightNode Properties

[image] [image]

Revit 2024 API
LightNode Properties
LightNode Class See Also Send Feedback

The LightNode type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode.)
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode.)

See Also

LightNode Class


Line Members

[image] [image]

Revit 2024 API
Line Members
Line Class Methods Properties See Also Send Feedback

The Line type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns a copy of this curve. (Inherited from Curve.)
Public method | ComputeClosestPoints | Find the closest points between two curves. Closest points mean closest pairs of points, each pair consisting of a point on this, say P1, and a point on other curve, say P2. P1 and P2 are closest locally. Each pairs of closest points will be represented by the corresponding parameter values with respect to the two curves and the 3d points. A closest pair is also known as a pair of critical points of the distance function between points of the two curves. If the input parameter returnAllCriticalPoints is set to false, then the function will return only pairs with minimum distance. (Inherited from Curve.)
Public method | ComputeDerivatives | Returns the vectors describing the curve at the specified parameter. (Inherited from Curve.)
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve.)
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve.)
 | CreateBound | Creates a new instance of a bound linear curve.
Public method | CreateOffset | Creates a new curve that is an offset of the existing curve. (Inherited from Curve.)
Public method | CreateReversed | Creates a new curve with the opposite orientation of the existing curve. (Inherited from Curve.)
Public method | CreateTransformed | Crates a new instance of a curve as a transformation of this curve. (Inherited from Curve.)
 | CreateUnbound | Creates a new instance of an unbound linear curve.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates and returns the point that matches a parameter along the curve. (Inherited from Curve.)
Public method | GetEndParameter | Returns the raw parameter value at the start or end of this curve. (Inherited from Curve.)
Public method | GetEndPoint | Returns the 3D point at the start or end of this curve. (Inherited from Curve.)
Public method | GetEndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve.)
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve.)
Public method | IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve.)
Public method | MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve.)
Public method | MakeUnbound | Makes this curve unbound. (Inherited from Curve.)
Public method | Project | Projects the specified point on this curve. (Inherited from Curve.)
Public method | SetGraphicsStyleId | Sets the graphics style id for this curve. (Inherited from Curve.)
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
Public property | Direction | Returns the direction of the line.
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject.)
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
Public property | IsClosed | Describes whether the curve is closed. (Inherited from Curve.)
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Length | The exact length of the curve. (Inherited from Curve.)
Public property | Origin | Returns the origin of the line.
Public property | Period | The period of this curve. (Inherited from Curve.)
Public property | Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Line Class


Line Methods

[image] [image]

Revit 2024 API
Line Methods
Line Class See Also Send Feedback

The Line type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns a copy of this curve. (Inherited from Curve.)
Public method | ComputeClosestPoints | Find the closest points between two curves. Closest points mean closest pairs of points, each pair consisting of a point on this, say P1, and a point on other curve, say P2. P1 and P2 are closest locally. Each pairs of closest points will be represented by the corresponding parameter values with respect to the two curves and the 3d points. A closest pair is also known as a pair of critical points of the distance function between points of the two curves. If the input parameter returnAllCriticalPoints is set to false, then the function will return only pairs with minimum distance. (Inherited from Curve.)
Public method | ComputeDerivatives | Returns the vectors describing the curve at the specified parameter. (Inherited from Curve.)
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve.)
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve.)
 | CreateBound | Creates a new instance of a bound linear curve.
Public method | CreateOffset | Creates a new curve that is an offset of the existing curve. (Inherited from Curve.)
Public method | CreateReversed | Creates a new curve with the opposite orientation of the existing curve. (Inherited from Curve.)
Public method | CreateTransformed | Crates a new instance of a curve as a transformation of this curve. (Inherited from Curve.)
 | CreateUnbound | Creates a new instance of an unbound linear curve.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates and returns the point that matches a parameter along the curve. (Inherited from Curve.)
Public method | GetEndParameter | Returns the raw parameter value at the start or end of this curve. (Inherited from Curve.)
Public method | GetEndPoint | Returns the 3D point at the start or end of this curve. (Inherited from Curve.)
Public method | GetEndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve.)
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve.)
Public method | IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve.)
Public method | MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve.)
Public method | MakeUnbound | Makes this curve unbound. (Inherited from Curve.)
Public method | Project | Projects the specified point on this curve. (Inherited from Curve.)
Public method | SetGraphicsStyleId | Sets the graphics style id for this curve. (Inherited from Curve.)
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Line Class


CreateBound Method

[image]

Revit 2024 API
Line..::..CreateBound Method
Line Class Example See Also Send Feedback
Creates a new instance of a bound linear curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static Line CreateBound(
    XYZ endpoint1,
    XYZ endpoint2
)
Visual Basic
Public Shared Function CreateBound ( _
    endpoint1 As XYZ, _
    endpoint2 As XYZ _
) As Line
Visual C++
public:
static Line^ CreateBound(
    XYZ^ endpoint1,
    XYZ^ endpoint2
)

Parameters

endpoint1
Type: Autodesk.Revit.DB..::..XYZ
The first line endpoint.
endpoint2
Type: Autodesk.Revit.DB..::..XYZ
The second line endpoint.

Return Value

The new bound line.

Examples

CopyC#
// define start and end for bound line
XYZ startPoint = new XYZ(0, 0, 0);
XYZ endPoint = new XYZ(10, 10, 10);

// create line
Line line = Line.CreateBound(startPoint, endPoint);
CopyVB.NET
' define start and end for bound line
Dim startPoint As New XYZ(0, 0, 0)
Dim endPoint As New XYZ(10, 10, 10)

' create line
Dim line__1 As Line = Line.CreateBound(startPoint, endPoint)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | Curve length is too small for Revit's tolerance (as identified by Application.ShortCurveTolerance).

See Also

Line Class


CreateUnbound Method

[image]

Revit 2024 API
Line..::..CreateUnbound Method
Line Class Example See Also Send Feedback
Creates a new instance of an unbound linear curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static Line CreateUnbound(
    XYZ origin,
    XYZ direction
)
Visual Basic
Public Shared Function CreateUnbound ( _
    origin As XYZ, _
    direction As XYZ _
) As Line
Visual C++
public:
static Line^ CreateUnbound(
    XYZ^ origin,
    XYZ^ direction
)

Parameters

origin
Type: Autodesk.Revit.DB..::..XYZ
The origin of the unbound line.
direction
Type: Autodesk.Revit.DB..::..XYZ
The direction of the unbound line.

Return Value

The new unbound line.

Examples

CopyC#
// define start point and direction for unbound line
XYZ startPoint = new XYZ(0, 0, 0);
XYZ directionPt = new XYZ(10, 10, 10);

// create line
Line line = Line.CreateUnbound(startPoint, directionPt);
CopyVB.NET
' define start point and direction for unbound line
Dim startPoint As New XYZ(0, 0, 0)
Dim directionPt As New XYZ(10, 10, 10)

' create line
Dim line__1 As Line = Line.CreateUnbound(startPoint, directionPt)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | direction has zero length.
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | Vector and origin cannot form a proper unbound line.

See Also

Line Class


Intersect Method

[image] [image]

Revit 2024 API
Line..::..Intersect Method
Line Class See Also Send Feedback
Calculates the intersection of this curve with the specified curve.

Overload List

 | Name | Description
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve.)

See Also

Line Class
Line Members


IsInside Method

[image] [image]

Revit 2024 API
Line..::..IsInside Method
Line Class See Also Send Feedback
Indicates whether the specified parameter value is within this curve's bounds.

Overload List

 | Name | Description
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve.)
Public method | IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve.)

See Also

Line Class
Line Members


Line Properties

[image] [image]

Revit 2024 API
Line Properties
Line Class See Also Send Feedback

The Line type exposes the following members.

Properties

 | Name | Description
Public property | ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
Public property | Direction | Returns the direction of the line.
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject.)
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
Public property | IsClosed | Describes whether the curve is closed. (Inherited from Curve.)
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Length | The exact length of the curve. (Inherited from Curve.)
Public property | Origin | Returns the origin of the line.
Public property | Period | The period of this curve. (Inherited from Curve.)
Public property | Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Line Class


Direction Property

[image]

Revit 2024 API
Line..::..Direction Property
Line Class See Also Send Feedback
Returns the direction of the line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ Direction { get; }
Visual Basic
Public ReadOnly Property Direction As XYZ
    Get
Visual C++
public:
property XYZ^ Direction {
    XYZ^ get ();
}

See Also

Line Class


Origin Property

[image]

Revit 2024 API
Line..::..Origin Property
Line Class See Also Send Feedback
Returns the origin of the line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ Origin { get; }
Visual Basic
Public ReadOnly Property Origin As XYZ
    Get
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
}

See Also

Line Class


LineAndTextAttrSymbol Class

[image]

Revit 2024 API
LineAndTextAttrSymbol Class
Members See Also Send Feedback
An object that represents a dimension style.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class LineAndTextAttrSymbol : ElementType
Visual Basic
Public Class LineAndTextAttrSymbol _
    Inherits ElementType
Visual C++
public ref class LineAndTextAttrSymbol : public ElementType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..LineAndTextAttrSymbol
Autodesk.Revit.DB..::..FilledRegionType
Autodesk.Revit.DB..::..GridType
Autodesk.Revit.DB..::..LevelType
Autodesk.Revit.DB..::..TextElementType

See Also

LineAndTextAttrSymbol Members


LineAndTextAttrSymbol Members

[image] [image]

Revit 2024 API
LineAndTextAttrSymbol Members
LineAndTextAttrSymbol Class Methods Properties See Also Send Feedback

The LineAndTextAttrSymbol type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

LineAndTextAttrSymbol Class


LineAndTextAttrSymbol Methods

[image] [image]

Revit 2024 API
LineAndTextAttrSymbol Methods
LineAndTextAttrSymbol Class See Also Send Feedback

The LineAndTextAttrSymbol type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LineAndTextAttrSymbol Class


Parameter Property

[image] [image]

Revit 2024 API
LineAndTextAttrSymbol..::..Parameter Property
LineAndTextAttrSymbol Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

LineAndTextAttrSymbol Class
LineAndTextAttrSymbol Members


LinearArray Class

[image]

Revit 2024 API
LinearArray Class
Members See Also Send Feedback
An object that represents an Array created linearly within the Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class LinearArray : BaseArray
Visual Basic
Public Class LinearArray _
    Inherits BaseArray
Visual C++
public ref class LinearArray : public BaseArray

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..BaseArray
Autodesk.Revit.DB..::..LinearArray

See Also

LinearArray Members


LinearArray Members

[image] [image]

Revit 2024 API
LinearArray Members
LinearArray Class Methods Properties See Also Send Feedback

The LinearArray type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
 | ArrayElementsWithoutAssociation | Creates a new linear array from a set of elements.
 | ArrayElementWithoutAssociation | Creates a new linear array from a single element.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create(Document, View, ElementId, Int32, XYZ, ArrayAnchorMember) | Creates a new linear array element from a single element.
 | Create(Document, View, ICollection<(Of <<'(ElementId>)>>), Int32, XYZ, ArrayAnchorMember) | Creates a new linear array element from a set of elements.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetCopiedMemberIds | Retrieves the copied member Ids of the Array. (Overrides BaseArray..::..GetCopiedMemberIds()()()().)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetOriginalMemberIds | Retrieves the original member Ids of the Array. (Overrides BaseArray..::..GetOriginalMemberIds()()()().)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
 | IsElementArrayable | Indicates whether the input element is arrayable.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
 | IsValidArraySize | This indicates whether the input count is valid.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | Label | The family parameter label of the BaseArray. (Inherited from BaseArray.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Get and Set the Name property (Inherited from BaseArray.)
Public property | NumMembers | Retrieves or changes the number of the arrayed members. (Overrides BaseArray..::..NumMembers.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

LinearArray Class


ArrayElementsWithoutAssociation Method

[image]

Revit 2024 API
LinearArray..::..ArrayElementsWithoutAssociation Method
LinearArray Class See Also Send Feedback
Creates a new linear array from a set of elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ICollection<ElementId> ArrayElementsWithoutAssociation(
    Document aDoc,
    View dBView,
    ICollection<ElementId> ids,
    int count,
    XYZ translationToAnchorMember,
    ArrayAnchorMember anchorMember
)
Visual Basic
Public Shared Function ArrayElementsWithoutAssociation ( _
    aDoc As Document, _
    dBView As View, _
    ids As ICollection(Of ElementId), _
    count As Integer, _
    translationToAnchorMember As XYZ, _
    anchorMember As ArrayAnchorMember _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ ArrayElementsWithoutAssociation(
    Document^ aDoc,
    View^ dBView,
    ICollection<ElementId^>^ ids,
    int count,
    XYZ^ translationToAnchorMember,
    ArrayAnchorMember anchorMember
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
The document.
dBView
Type: Autodesk.Revit.DB..::..View
The view. If it is a 2d view, translation vector must be in the view plane if elements include view-specific elements. If elements include view-specific elements, they must belong to this view.
ids
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
The elements to array.
count
Type: System..::..Int32
The number of array members to create including the initial element grouping. Must between 2 and 200.
translationToAnchorMember
Type: Autodesk.Revit.DB..::..XYZ
The translation vector for the array.
anchorMember
Type: Autodesk.Revit.DB..::..ArrayAnchorMember
Indicates if the translation vector specifies the location of the second member of the array, or the last member of the array.

Return Value

The ids of the elements created during the operation.

Remarks

The resulting elements will not be associated with an array element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given element id set is empty. -or- One or more elements in ids do not exist in the document. -or- One or more elements in ids is owned by different views and thus cannot be arrayed together. -or- One or more elements in ids is not arrayable. -or- count must be between 2 and 200. -or- The view is invalid for specific view elements array. -or- The translation point vector is invalid to array the element.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | Failed to create the linear array.

See Also

LinearArray Class


ArrayElementWithoutAssociation Method

[image]

Revit 2024 API
LinearArray..::..ArrayElementWithoutAssociation Method
LinearArray Class See Also Send Feedback
Creates a new linear array from a single element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ICollection<ElementId> ArrayElementWithoutAssociation(
    Document aDoc,
    View dBView,
    ElementId id,
    int count,
    XYZ translationToAnchorMember,
    ArrayAnchorMember anchorMember
)
Visual Basic
Public Shared Function ArrayElementWithoutAssociation ( _
    aDoc As Document, _
    dBView As View, _
    id As ElementId, _
    count As Integer, _
    translationToAnchorMember As XYZ, _
    anchorMember As ArrayAnchorMember _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ ArrayElementWithoutAssociation(
    Document^ aDoc,
    View^ dBView,
    ElementId^ id,
    int count,
    XYZ^ translationToAnchorMember,
    ArrayAnchorMember anchorMember
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
The document.
dBView
Type: Autodesk.Revit.DB..::..View
The view. If it is a 2d view, translation vector must be in the view plane if the element is a view-specific element.
id
Type: Autodesk.Revit.DB..::..ElementId
The element to array.
count
Type: System..::..Int32
The number of array members to create including the initial element grouping. Must between 2 and 200.
translationToAnchorMember
Type: Autodesk.Revit.DB..::..XYZ
The translation vector for the array.
anchorMember
Type: Autodesk.Revit.DB..::..ArrayAnchorMember
Indicates if the translation vector specifies the location of the second member of the array, or the last member of the array.

Return Value

The ids of the elements created during the operation.

Remarks

The resulting elements will not be associated with an array element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element id does not exist in the document -or- id is not arrayable. -or- count must be between 2 and 200. -or- The view is invalid for specific view elements array. -or- The translation point vector is invalid to array the element.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | Failed to create the linear array.

See Also

LinearArray Class


Create Method

[image] [image]

Revit 2024 API
LinearArray..::..Create Method
LinearArray Class See Also Send Feedback

Overload List

Name | Description
Create(Document, View, ElementId, Int32, XYZ, ArrayAnchorMember) | Creates a new linear array element from a single element.
Create(Document, View, ICollection<(Of <<'(ElementId>)>>), Int32, XYZ, ArrayAnchorMember) | Creates a new linear array element from a set of elements.

See Also

LinearArray Class
LinearArray Members


Create Method (Document, View, ElementId, Int32, XYZ, ArrayAnchorMember)

[image]

Revit 2024 API
LinearArray..::..Create Method (Document, View, ElementId, Int32, XYZ, ArrayAnchorMember)
LinearArray Class See Also Send Feedback
Creates a new linear array element from a single element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static LinearArray Create(
    Document aDoc,
    View dBView,
    ElementId id,
    int count,
    XYZ translationToAnchorMember,
    ArrayAnchorMember anchorMember
)
Visual Basic
Public Shared Function Create ( _
    aDoc As Document, _
    dBView As View, _
    id As ElementId, _
    count As Integer, _
    translationToAnchorMember As XYZ, _
    anchorMember As ArrayAnchorMember _
) As LinearArray
Visual C++
public:
static LinearArray^ Create(
    Document^ aDoc,
    View^ dBView,
    ElementId^ id,
    int count,
    XYZ^ translationToAnchorMember,
    ArrayAnchorMember anchorMember
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
The document.
dBView
Type: Autodesk.Revit.DB..::..View
The view. If it is a 2d view, translation vector must be in the view plane if the element is a view-specific element.
id
Type: Autodesk.Revit.DB..::..ElementId
The element to array.
count
Type: System..::..Int32
The number of array members to create including the initial element grouping. Must between 2 and 200.
translationToAnchorMember
Type: Autodesk.Revit.DB..::..XYZ
The translation vector for the array.
anchorMember
Type: Autodesk.Revit.DB..::..ArrayAnchorMember
Indicates if the translation vector specifies the location of the second member of the array, or the last member of the array.

Return Value

The new linear array element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element id does not exist in the document -or- id is not arrayable. -or- count must be between 2 and 200. -or- The view is invalid for specific view elements array. -or- The translation point vector is invalid to array the element.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | Failed to create the linear array.

See Also

LinearArray Class
Create Overload


Create Method (Document, View, ICollection(ElementId), Int32, XYZ, ArrayAnchorMember)

[image]

Revit 2024 API
LinearArray..::..Create Method (Document, View, ICollection<(Of <(<'ElementId>)>)>, Int32, XYZ, ArrayAnchorMember)
LinearArray Class See Also Send Feedback
Creates a new linear array element from a set of elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static LinearArray Create(
    Document aDoc,
    View dBView,
    ICollection<ElementId> ids,
    int count,
    XYZ translationToAnchorMember,
    ArrayAnchorMember anchorMember
)
Visual Basic
Public Shared Function Create ( _
    aDoc As Document, _
    dBView As View, _
    ids As ICollection(Of ElementId), _
    count As Integer, _
    translationToAnchorMember As XYZ, _
    anchorMember As ArrayAnchorMember _
) As LinearArray
Visual C++
public:
static LinearArray^ Create(
    Document^ aDoc,
    View^ dBView,
    ICollection<ElementId^>^ ids,
    int count,
    XYZ^ translationToAnchorMember,
    ArrayAnchorMember anchorMember
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
The document.
dBView
Type: Autodesk.Revit.DB..::..View
The view. If it is a 2d view, translation vector must be in the view plane if elements include view-specific elements. If elements include view-specific elements, they must belong to this view.
ids
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
The elements to array.
count
Type: System..::..Int32
The number of array members to create including the initial element grouping. Must between 2 and 200.
translationToAnchorMember
Type: Autodesk.Revit.DB..::..XYZ
The translation vector for the array.
anchorMember
Type: Autodesk.Revit.DB..::..ArrayAnchorMember
Indicates if the translation vector specifies the location of the second member of the array, or the last member of the array.

Return Value

The new linear array element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given element id set is empty. -or- One or more elements in ids do not exist in the document. -or- One or more elements in ids is owned by different views and thus cannot be arrayed together. -or- One or more elements in ids is not arrayable. -or- count must be between 2 and 200. -or- The view is invalid for specific view elements array. -or- The translation point vector is invalid to array the element.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | Failed to create the linear array.

See Also

LinearArray Class
Create Overload


GetCopiedMemberIds Method

[image]

Revit 2024 API
LinearArray..::..GetCopiedMemberIds Method
LinearArray Class See Also Send Feedback
Retrieves the copied member Ids of the Array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public override ICollection<ElementId> GetCopiedMemberIds()
Visual Basic
Public Overrides Function GetCopiedMemberIds As ICollection(Of ElementId)
Visual C++
public:
virtual ICollection<ElementId^>^ GetCopiedMemberIds() override

Return Value

The copied member Ids of the Array

See Also

LinearArray Class


GetOriginalMemberIds Method

[image]

Revit 2024 API
LinearArray..::..GetOriginalMemberIds Method
LinearArray Class See Also Send Feedback
Retrieves the original member Ids of the Array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public override ICollection<ElementId> GetOriginalMemberIds()
Visual Basic
Public Overrides Function GetOriginalMemberIds As ICollection(Of ElementId)
Visual C++
public:
virtual ICollection<ElementId^>^ GetOriginalMemberIds() override

Return Value

The original member Ids of the Array

See Also

LinearArray Class


IsElementArrayable Method

[image]

Revit 2024 API
LinearArray..::..IsElementArrayable Method
LinearArray Class See Also Send Feedback
Indicates whether the input element is arrayable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static bool IsElementArrayable(
    Document aDoc,
    ElementId id
)
Visual Basic
Public Shared Function IsElementArrayable ( _
    aDoc As Document, _
    id As ElementId _
) As Boolean
Visual C++
public:
static bool IsElementArrayable(
    Document^ aDoc,
    ElementId^ id
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
The document.
id
Type: Autodesk.Revit.DB..::..ElementId
The element id.

Return Value

True if the input element is arrayable, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

LinearArray Class


Parameter Property

[image] [image]

Revit 2024 API
LinearArray..::..Parameter Property
LinearArray Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

LinearArray Class
LinearArray Members


LinePattern Class

[image]

Revit 2024 API
LinePattern Class
Members See Also Send Feedback
Represents a line pattern definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class LinePattern : IDisposable
Visual Basic
Public Class LinePattern _
    Implements IDisposable
Visual C++
public ref class LinePattern : IDisposable

Remarks

A line pattern is a pattern of dashes and dots used to control the way the lines of an object are drawn in Revit. Line patterns are used in the definition of GraphicsStyle objects. A line pattern is defined by a repeating sequence segments. Each segment is a dash, a dot or a space. A line pattern definition must contain an even number of segments, starting with a visible segment (a dash or a dot) and alternating between visible segments and spaces.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..LinePattern

See Also

LinePattern Members


LinePattern Members

[image] [image]

Revit 2024 API
LinePattern Members
LinePattern Class Constructors Methods Properties See Also Send Feedback

The LinePattern type exposes the following members.

Constructors

 | Name | Description
Public method | LinePattern()()()() | Creates a simple line pattern.
Public method | LinePattern(String) | Creates a line pattern with given name.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the LinePattern
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSegments | Gets the sequence of segments that defines this line pattern.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetSegments | Sets the sequence of segments that defines this line pattern.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | Line pattern name.

See Also

LinePattern Class


LinePattern Constructor

[image]

Revit 2024 API
LinePattern Constructor
LinePattern Class See Also Send Feedback
Creates a simple line pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public LinePattern()
Visual Basic
Public Sub New
Visual C++
public:
LinePattern()

See Also

LinePattern Class
LinePattern Overload


LinePattern Constructor (String)

[image]

Revit 2024 API
LinePattern Constructor (String)
LinePattern Class See Also Send Feedback
Creates a line pattern with given name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public LinePattern(
    string name
)
Visual Basic
Public Sub New ( _
    name As String _
)
Visual C++
public:
LinePattern(
    String^ name
)

Parameters

name
Type: System..::..String
The name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

LinePattern Class
LinePattern Overload


LinePattern Methods

[image] [image]

Revit 2024 API
LinePattern Methods
LinePattern Class See Also Send Feedback

The LinePattern type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSegments | Gets the sequence of segments that defines this line pattern.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetSegments | Sets the sequence of segments that defines this line pattern.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LinePattern Class


Dispose Method

[image]

Revit 2024 API
LinePattern..::..Dispose Method
LinePattern Class See Also Send Feedback
Releases all resources used by the LinePattern

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

LinePattern Class


GetSegments Method

[image]

Revit 2024 API
LinePattern..::..GetSegments Method
LinePattern Class See Also Send Feedback
Gets the sequence of segments that defines this line pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public IList<LinePatternSegment> GetSegments()
Visual Basic
Public Function GetSegments As IList(Of LinePatternSegment)
Visual C++
public:
IList<LinePatternSegment^>^ GetSegments()

Return Value

The sequence of segments.

See Also

LinePattern Class


SetSegments Method

[image]

Revit 2024 API
LinePattern..::..SetSegments Method
LinePattern Class See Also Send Feedback
Sets the sequence of segments that defines this line pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetSegments(
    IList<LinePatternSegment> lineSegs
)
Visual Basic
Public Sub SetSegments ( _
    lineSegs As IList(Of LinePatternSegment) _
)
Visual C++
public:
void SetSegments(
    IList<LinePatternSegment^>^ lineSegs
)

Parameters

lineSegs
Type: System.Collections.Generic..::..IList<(Of <(<' LinePatternSegment >)>)>
The sequence of segments.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

LinePattern Class


LinePattern Properties

[image] [image]

Revit 2024 API
LinePattern Properties
LinePattern Class See Also Send Feedback

The LinePattern type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | Line pattern name.

See Also

LinePattern Class


IsValidObject Property

[image]

Revit 2024 API
LinePattern..::..IsValidObject Property
LinePattern Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

LinePattern Class


Name Property

[image]

Revit 2024 API
LinePattern..::..Name Property
LinePattern Class See Also Send Feedback
Line pattern name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

LinePattern Class


LinePatternElement Class

[image]

Revit 2024 API
LinePatternElement Class
Members See Also Send Feedback
An element that represents a line pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public class LinePatternElement : Element
Visual Basic
Public Class LinePatternElement _
    Inherits Element
Visual C++
public ref class LinePatternElement : public Element

Remarks

The LinePatternElement represents a line pattern in a project. It enables the user to retrieve, modify or create a line pattern in a project.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..LinePatternElement

See Also

LinePatternElement Members


LinePatternElement Members

[image] [image]

Revit 2024 API
LinePatternElement Members
LinePatternElement Class Methods Properties See Also Send Feedback

The LinePatternElement type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create | Creates a new LinePatternElement.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLinePattern()()()() | Gets the LinePattern associated to this element.
 | GetLinePattern(Document, ElementId) | Gets the LinePattern associated to an element or from a built-in line pattern.
 | GetLinePatternElementByName | Retrieves the LinePatternElement by its name.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
 | GetSolidPatternId | Gets the solid line pattern element id.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetLinePattern | Sets the LinePattern associated to this element.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

LinePatternElement Class


LinePatternElement Methods

[image] [image]

Revit 2024 API
LinePatternElement Methods
LinePatternElement Class See Also Send Feedback

The LinePatternElement type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create | Creates a new LinePatternElement.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLinePattern()()()() | Gets the LinePattern associated to this element.
 | GetLinePattern(Document, ElementId) | Gets the LinePattern associated to an element or from a built-in line pattern.
 | GetLinePatternElementByName | Retrieves the LinePatternElement by its name.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
 | GetSolidPatternId | Gets the solid line pattern element id.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetLinePattern | Sets the LinePattern associated to this element.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LinePatternElement Class


Create Method

[image]

Revit 2024 API
LinePatternElement..::..Create Method
LinePatternElement Class See Also Send Feedback
Creates a new LinePatternElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static LinePatternElement Create(
    Document document,
    LinePattern linePattern
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    linePattern As LinePattern _
) As LinePatternElement
Visual C++
public:
static LinePatternElement^ Create(
    Document^ document,
    LinePattern^ linePattern
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which to create the LinePatternElement.
linePattern
Type: Autodesk.Revit.DB..::..LinePattern
The LinePattern associated to the newly created LinePatternElement.

Return Value

The newly created LinePatternElement.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The Line Pattern is not valid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

LinePatternElement Class


GetLinePattern Method (Document, ElementId)

[image]

Revit 2024 API
LinePatternElement..::..GetLinePattern Method (Document, ElementId)
LinePatternElement Class See Also Send Feedback
Gets the LinePattern associated to an element or from a built-in line pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static LinePattern GetLinePattern(
    Document document,
    ElementId elementId
)
Visual Basic
Public Shared Function GetLinePattern ( _
    document As Document, _
    elementId As ElementId _
) As LinePattern
Visual C++
public:
static LinePattern^ GetLinePattern(
    Document^ document,
    ElementId^ elementId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which to retrieve the LinePattern.
elementId
Type: Autodesk.Revit.DB..::..ElementId
The ElementId of the LinePatternElement or the built-in line pattern id.

Return Value

A copy of LinePattern object. nullNothingnullptra null reference (Nothing in Visual Basic) if the ElementId doesn't represent a line pattern element or built-in line pattern. nullNothingnullptra null reference (Nothing in Visual Basic) for Solid.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

LinePatternElement Class
GetLinePattern Overload


GetLinePatternElementByName Method

[image]

Revit 2024 API
LinePatternElement..::..GetLinePatternElementByName Method
LinePatternElement Class See Also Send Feedback
Retrieves the LinePatternElement by its name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static LinePatternElement GetLinePatternElementByName(
    Document document,
    string name
)
Visual Basic
Public Shared Function GetLinePatternElementByName ( _
    document As Document, _
    name As String _
) As LinePatternElement
Visual C++
public:
static LinePatternElement^ GetLinePatternElementByName(
    Document^ document,
    String^ name
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which to retrieve the LinePatternElement.
name
Type: System..::..String
The name of the LinePatternElement.

Return Value

The LinePatternElement.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

LinePatternElement Class


SetLinePattern Method

[image]

Revit 2024 API
LinePatternElement..::..SetLinePattern Method
LinePatternElement Class See Also Send Feedback
Sets the LinePattern associated to this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public void SetLinePattern(
    LinePattern newLinePattern
)
Visual Basic
Public Sub SetLinePattern ( _
    newLinePattern As LinePattern _
)
Visual C++
public:
void SetLinePattern(
    LinePattern^ newLinePattern
)

Parameters

newLinePattern
Type: Autodesk.Revit.DB..::..LinePattern
The new LinePattern object.

Remarks

The data stored inside the input LinePattern will be copied into this element. The input LinePattern itself will not be associated with the element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The Line Pattern is not valid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

LinePatternElement Class


LinePatternElement Properties

[image] [image]

Revit 2024 API
LinePatternElement Properties
LinePatternElement Class See Also Send Feedback

The LinePatternElement type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

LinePatternElement Class


Parameter Property

[image] [image]

Revit 2024 API
LinePatternElement..::..Parameter Property
LinePatternElement Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

LinePatternElement Class
LinePatternElement Members


LinePatternSegment Class

[image]

Revit 2024 API
LinePatternSegment Class
Members See Also Send Feedback
Represents a segment in a line pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class LinePatternSegment : IDisposable
Visual Basic
Public Class LinePatternSegment _
    Implements IDisposable
Visual C++
public ref class LinePatternSegment : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..LinePatternSegment

See Also

LinePatternSegment Members


LinePatternSegment Members

[image] [image]

Revit 2024 API
LinePatternSegment Members
LinePatternSegment Class Constructors Methods Properties See Also Send Feedback

The LinePatternSegment type exposes the following members.

Constructors

 | Name | Description
Public method | LinePatternSegment()()()() | Creates a line pattern segment.
Public method | LinePatternSegment(LinePatternSegmentType, Double) | Creates a line pattern segment with given type and length.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the LinePatternSegment
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Length | Gets and sets the length of the segment.
Public property | Type | Gets and sets the type of the segment.

See Also

LinePatternSegment Class


LinePatternSegment Constructor

[image] [image]

Revit 2024 API
LinePatternSegment Constructor
LinePatternSegment Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LinePatternSegment()()()() | Creates a line pattern segment.
Public method | LinePatternSegment(LinePatternSegmentType, Double) | Creates a line pattern segment with given type and length.

See Also

LinePatternSegment Class
LinePatternSegment Members


LinePatternSegment Constructor

[image]

Revit 2024 API
LinePatternSegment Constructor
LinePatternSegment Class See Also Send Feedback
Creates a line pattern segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public LinePatternSegment()
Visual Basic
Public Sub New
Visual C++
public:
LinePatternSegment()

See Also

LinePatternSegment Class
LinePatternSegment Overload


LinePatternSegment Constructor (LinePatternSegmentType, Double)

[image]

Revit 2024 API
LinePatternSegment Constructor (LinePatternSegmentType, Double)
LinePatternSegment Class See Also Send Feedback
Creates a line pattern segment with given type and length.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public LinePatternSegment(
    LinePatternSegmentType type,
    double length
)
Visual Basic
Public Sub New ( _
    type As LinePatternSegmentType, _
    length As Double _
)
Visual C++
public:
LinePatternSegment(
    LinePatternSegmentType type,
    double length
)

Parameters

type
Type: Autodesk.Revit.DB..::..LinePatternSegmentType
The segment type.
length
Type: System..::..Double
The length.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

LinePatternSegment Class
LinePatternSegment Overload


LinePatternSegment Methods

[image] [image]

Revit 2024 API
LinePatternSegment Methods
LinePatternSegment Class See Also Send Feedback

The LinePatternSegment type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LinePatternSegment Class


Dispose Method

[image]

Revit 2024 API
LinePatternSegment..::..Dispose Method
LinePatternSegment Class See Also Send Feedback
Releases all resources used by the LinePatternSegment

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

LinePatternSegment Class


LinePatternSegment Properties

[image] [image]

Revit 2024 API
LinePatternSegment Properties
LinePatternSegment Class See Also Send Feedback

The LinePatternSegment type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Length | Gets and sets the length of the segment.
Public property | Type | Gets and sets the type of the segment.

See Also

LinePatternSegment Class


IsValidObject Property

[image]

Revit 2024 API
LinePatternSegment..::..IsValidObject Property
LinePatternSegment Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

LinePatternSegment Class


Length Property

[image]

Revit 2024 API
LinePatternSegment..::..Length Property
LinePatternSegment Class See Also Send Feedback
Gets and sets the length of the segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double Length { get; set; }
Visual Basic
Public Property Length As Double
    Get
    Set
Visual C++
public:
property double Length {
    double get ();
    void set (double value);
}

Field Value

The length of the segment.

See Also

LinePatternSegment Class


Type Property

[image]

Revit 2024 API
LinePatternSegment..::..Type Property
LinePatternSegment Class See Also Send Feedback
Gets and sets the type of the segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public LinePatternSegmentType Type { get; set; }
Visual Basic
Public Property Type As LinePatternSegmentType
    Get
    Set
Visual C++
public:
property LinePatternSegmentType Type {
    LinePatternSegmentType get ();
    void set (LinePatternSegmentType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

LinePatternSegment Class


LinePatternSegmentType Enumeration

[image]

Revit 2024 API
LinePatternSegmentType Enumeration
See Also Send Feedback
Represents the type of a line pattern segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum LinePatternSegmentType
Visual Basic
Public Enumeration LinePatternSegmentType
Visual C++
public enum class LinePatternSegmentType

Members

Member name | Description
Dash | A dash
Space | A space
Dot | A dot
Invalid |

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


LineProperties Class

[image]

Revit 2024 API
LineProperties Class
Members See Also Send Feedback
A structure that has access to the pen properties of lines/curves that are currently being drawn/exported via an export context during a custom export process.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public class LineProperties : IDisposable
Visual Basic
Public Class LineProperties _
    Implements IDisposable
Visual C++
public ref class LineProperties : IDisposable

Remarks

For more about using properties of this class refer to the interface [!:Autodesk::Revit::DB::IModelExportContext] and its methods which handle geometric objects such as [!:Autodesk::Revit::DB::IModelExportContext::OnCurve], [!:Autodesk::Revit::DB::IModelExportContext::OnLineSegment], etc. LineProperties are available as a read-only property on the respective output nodes, i.e. [!:Autodesk::Revit::DB::CurveNode], [!:Autodesk::Revit::DB::LineSegment], etc.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..LineProperties

See Also

LineProperties Members


LineProperties Members

[image] [image]

Revit 2024 API
LineProperties Members
LineProperties Class Methods Properties See Also Send Feedback

The LineProperties type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the LineProperties
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Color | The current color used when drawing lines/curves.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LineWidth | The current width (thickness) of the pen stroke when drawing lines/curves.
Public property | PatternId | Id of the current Line pattern element used when drawing lines/curves.
Public property | Transparency | The current transparency level to be applied to the current color.

See Also

LineProperties Class


LineProperties Methods

[image] [image]

Revit 2024 API
LineProperties Methods
LineProperties Class See Also Send Feedback

The LineProperties type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LineProperties Class


Dispose Method

[image]

Revit 2024 API
LineProperties..::..Dispose Method
LineProperties Class See Also Send Feedback
Releases all resources used by the LineProperties

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

LineProperties Class


LineProperties Properties

[image] [image]

Revit 2024 API
LineProperties Properties
LineProperties Class See Also Send Feedback

The LineProperties type exposes the following members.

Properties

 | Name | Description
Public property | Color | The current color used when drawing lines/curves.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LineWidth | The current width (thickness) of the pen stroke when drawing lines/curves.
Public property | PatternId | Id of the current Line pattern element used when drawing lines/curves.
Public property | Transparency | The current transparency level to be applied to the current color.

See Also

LineProperties Class


Color Property

[image]

Revit 2024 API
LineProperties..::..Color Property
LineProperties Class See Also Send Feedback
The current color used when drawing lines/curves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public Color Color { get; }
Visual Basic
Public ReadOnly Property Color As Color
    Get
Visual C++
public:
property Color^ Color {
    Color^ get ();
}

See Also

LineProperties Class


LineWidth Property

[image]

Revit 2024 API
LineProperties..::..LineWidth Property
LineProperties Class See Also Send Feedback
The current width (thickness) of the pen stroke when drawing lines/curves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public double LineWidth { get; }
Visual Basic
Public ReadOnly Property LineWidth As Double
    Get
Visual C++
public:
property double LineWidth {
    double get ();
}

See Also

LineProperties Class


PatternId Property

[image]

Revit 2024 API
LineProperties..::..PatternId Property
LineProperties Class See Also Send Feedback
Id of the current Line pattern element used when drawing lines/curves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public ElementId PatternId { get; }
Visual Basic
Public ReadOnly Property PatternId As ElementId
    Get
Visual C++
public:
property ElementId^ PatternId {
    ElementId^ get ();
}

See Also

LineProperties Class


Transparency Property

[image]

Revit 2024 API
LineProperties..::..Transparency Property
LineProperties Class See Also Send Feedback
The current transparency level to be applied to the current color.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public int Transparency { get; }
Visual Basic
Public ReadOnly Property Transparency As Integer
    Get
Visual C++
public:
property int Transparency {
    int get ();
}

See Also

LineProperties Class


LineScaling Enumeration

[image]

Revit 2024 API
LineScaling Enumeration
See Also Send Feedback
An enumerated type listing possible LineType scaling modes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum LineScaling
Visual Basic
Public Enumeration LineScaling
Visual C++
public enum class LineScaling

Members

Member name | Description
ViewScale | Exporting lines as they were scaled by view scale. This option preserves visual fidelity.
ModelSpace | Modelspace scaling. LTSCALE is set to view scale and PSLTSCALE to 0.
PaperSpace | Paperspace scaling. Specifies the value 1 for both LTSCALE and PSLTSCALE.

Remarks

Whichever option is chosen, line type definitions are created so a dashed line always begins and ends with a dash. Using these options does change the default behavior of exported DWGs. Some lines expected to be dashed may appear solid or in a different scale.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


LineSegment Members

[image] [image]

Revit 2024 API
LineSegment Members
LineSegment Class Methods Properties See Also Send Feedback

The LineSegment type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the LineSegment
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | EndParameter | Parameter associated with the end point.
Public property | EndPoint | End point of the line segment.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LineProperties | Access to the line (pen) properties of the line
Public property | StartParameter | Parameter associated with the start point.
Public property | StartPoint | Start point of the line segment.

See Also

LineSegment Class


LineSegment Properties

[image] [image]

Revit 2024 API
LineSegment Properties
LineSegment Class See Also Send Feedback

The LineSegment type exposes the following members.

Properties

 | Name | Description
Public property | EndParameter | Parameter associated with the end point.
Public property | EndPoint | End point of the line segment.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LineProperties | Access to the line (pen) properties of the line
Public property | StartParameter | Parameter associated with the start point.
Public property | StartPoint | Start point of the line segment.

See Also

LineSegment Class


EndParameter Property

[image]

Revit 2024 API
LineSegment..::..EndParameter Property
LineSegment Class See Also Send Feedback
Parameter associated with the end point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public double EndParameter { get; }
Visual Basic
Public ReadOnly Property EndParameter As Double
    Get
Visual C++
public:
property double EndParameter {
    double get ();
}

See Also

LineSegment Class


IsValidObject Property

[image]

Revit 2024 API
LineSegment..::..IsValidObject Property
LineSegment Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

LineSegment Class


LineProperties Property

[image]

Revit 2024 API
LineSegment..::..LineProperties Property
LineSegment Class See Also Send Feedback
Access to the line (pen) properties of the line

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public LineProperties LineProperties { get; }
Visual Basic
Public ReadOnly Property LineProperties As LineProperties
    Get
Visual C++
public:
property LineProperties^ LineProperties {
    LineProperties^ get ();
}

See Also

LineSegment Class


StartParameter Property

[image]

Revit 2024 API
LineSegment..::..StartParameter Property
LineSegment Class See Also Send Feedback
Parameter associated with the start point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public double StartParameter { get; }
Visual Basic
Public ReadOnly Property StartParameter As Double
    Get
Visual C++
public:
property double StartParameter {
    double get ();
}

See Also

LineSegment Class


StartPoint Property

[image]

Revit 2024 API
LineSegment..::..StartPoint Property
LineSegment Class See Also Send Feedback
Start point of the line segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public XYZ StartPoint { get; }
Visual Basic
Public ReadOnly Property StartPoint As XYZ
    Get
Visual C++
public:
property XYZ^ StartPoint {
    XYZ^ get ();
}

See Also

LineSegment Class


LinkConversionData Class

[image]

Revit 2024 API
LinkConversionData Class
Members See Also Send Feedback
This class contains the information necessary to re-create a Revit document from an external source.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public class LinkConversionData : IDisposable
Visual Basic
Public Class LinkConversionData _
    Implements IDisposable
Visual C++
public ref class LinkConversionData : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..LinkConversionData

See Also

LinkConversionData Members


LinkConversionData Members

[image] [image]

Revit 2024 API
LinkConversionData Members
LinkConversionData Class Methods Properties See Also Send Feedback

The LinkConversionData type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the LinkConversionData
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOptions | Extra information used during the creation of the Revit document.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Path | The path to the source data used to generate the model.
Public property | ServerId | The service responsible for converting the data into a Revit file.

See Also

LinkConversionData Class


LinkConversionData Methods

[image] [image]

Revit 2024 API
LinkConversionData Methods
LinkConversionData Class See Also Send Feedback

The LinkConversionData type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOptions | Extra information used during the creation of the Revit document.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LinkConversionData Class


Dispose Method

[image]

Revit 2024 API
LinkConversionData..::..Dispose Method
LinkConversionData Class See Also Send Feedback
Releases all resources used by the LinkConversionData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

LinkConversionData Class


GetOptions Method

[image]

Revit 2024 API
LinkConversionData..::..GetOptions Method
LinkConversionData Class See Also Send Feedback
Extra information used during the creation of the Revit document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public IDictionary<string, string> GetOptions()
Visual Basic
Public Function GetOptions As IDictionary(Of String, String)
Visual C++
public:
IDictionary<String^, String^>^ GetOptions()

Return Value

The extra information used during the creation of the Revit document.

See Also

LinkConversionData Class


LinkConversionData Properties

[image] [image]

Revit 2024 API
LinkConversionData Properties
LinkConversionData Class See Also Send Feedback

The LinkConversionData type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Path | The path to the source data used to generate the model.
Public property | ServerId | The service responsible for converting the data into a Revit file.

See Also

LinkConversionData Class


IsValidObject Property

[image]

Revit 2024 API
LinkConversionData..::..IsValidObject Property
LinkConversionData Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

LinkConversionData Class


Path Property

[image]

Revit 2024 API
LinkConversionData..::..Path Property
LinkConversionData Class See Also Send Feedback
The path to the source data used to generate the model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public string Path { get; }
Visual Basic
Public ReadOnly Property Path As String
    Get
Visual C++
public:
property String^ Path {
    String^ get ();
}

See Also

LinkConversionData Class


ServerId Property

[image]

Revit 2024 API
LinkConversionData..::..ServerId Property
LinkConversionData Class See Also Send Feedback
The service responsible for converting the data into a Revit file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public Guid ServerId { get; }
Visual Basic
Public ReadOnly Property ServerId As Guid
    Get
Visual C++
public:
property Guid ServerId {
    Guid get ();
}

See Also

LinkConversionData Class


LinkedFileStatus Enumeration

[image]

Revit 2024 API
LinkedFileStatus Enumeration
See Also Send Feedback
Enum displaying the loaded status of a linked file

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public enum LinkedFileStatus
Visual Basic
Public Enumeration LinkedFileStatus
Visual C++
public enum class LinkedFileStatus

Members

Member name | Description
Invalid | This value is the uninitialized value for the enum. It indicates that the link has not been properly initialized.
Loaded | The link is loaded.
Unloaded | The link is unloaded.
Imported | The element represented by this value was imported into Revit rather than linked into Revit.
NotFound | The linked file was not able to be found the last time Revit tried to load it.
CanBeUpgraded | The linked point cloud file is obsolete and can be indexed into new format.
InClosedWorkset | The linked file is in a closed workset and will not be displayed.
LocallyUnloaded | The linked file is unloaded for the specific user. (If the linked file is both unloaded for the specific user and unloaded for all users, the link will report LinkedFileStatus.Unloaded.)

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


LinkElementId Class

[image]

Revit 2024 API
LinkElementId Class
Members See Also Send Feedback
LinkElementId represents an element in a linked document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class LinkElementId
Visual Basic
Public Class LinkElementId
Visual C++
public ref class LinkElementId

Remarks

The id contains two element ids:
  1. The id of the linked model element in host document.
  2. The id of the element in the linked model document.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..LinkElementId

See Also

LinkElementId Members


LinkElementId Constructor (ElementId)

[image]

Revit 2024 API
LinkElementId Constructor (ElementId)
LinkElementId Class See Also Send Feedback
Creates a new LinkElementId representing an element in the host document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public LinkElementId(
    ElementId elementId
)
Visual Basic
Public Sub New ( _
    elementId As ElementId _
)
Visual C++
public:
LinkElementId(
    ElementId^ elementId
)

Parameters

elementId
Type: Autodesk.Revit.DB..::..ElementId
The id of the element in the host document.

See Also

LinkElementId Class
LinkElementId Overload


Equals Method

[image]

Revit 2024 API
LinkElementId..::..Equals Method
LinkElementId Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
Another object.

See Also

LinkElementId Class


LinkElementId Operators

[image] [image]

Revit 2024 API
LinkElementId Operators
LinkElementId Class See Also Send Feedback

The LinkElementId type exposes the following members.

Operators

Name | Description
Equality | Determines whether these two LinkElementIds are the same.
Inequality | Determines whether these two LinkElementIds are different.

See Also

LinkElementId Class


Equality Operator

[image]

Revit 2024 API
LinkElementId..::..Equality Operator
LinkElementId Class See Also Send Feedback
Determines whether these two LinkElementIds are the same.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static bool operator ==(
    LinkElementId first,
    LinkElementId second
)
Visual Basic
Public Shared Operator = ( _
    first As LinkElementId, _
    second As LinkElementId _
) As Boolean
Visual C++
public:
static bool operator ==(
    LinkElementId^ first,
    LinkElementId^ second
)

Parameters

first
Type: Autodesk.Revit.DB..::..LinkElementId
The first LinkElementId.
second
Type: Autodesk.Revit.DB..::..LinkElementId
The second LinkElementId.

Return Value

True if the LinkElementIds are the same; otherwise, false.

See Also

LinkElementId Class


Inequality Operator

[image]

Revit 2024 API
LinkElementId..::..Inequality Operator
LinkElementId Class See Also Send Feedback
Determines whether these two LinkElementIds are different.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static bool operator !=(
    LinkElementId first,
    LinkElementId second
)
Visual Basic
Public Shared Operator <> ( _
    first As LinkElementId, _
    second As LinkElementId _
) As Boolean
Visual C++
public:
static bool operator !=(
    LinkElementId^ first,
    LinkElementId^ second
)

Parameters

first
Type: Autodesk.Revit.DB..::..LinkElementId
The first LinkElementId.
second
Type: Autodesk.Revit.DB..::..LinkElementId
The second LinkElementId.

Return Value

True if the LinkElementIds are different; otherwise, false.

See Also

LinkElementId Class


LinkElementId Properties

[image] [image]

Revit 2024 API
LinkElementId Properties
LinkElementId Class See Also Send Feedback

The LinkElementId type exposes the following members.

Properties

 | Name | Description
Public property | HostElementId | The id of the element in the host, or invalidElementId if there is a link.
Public property | LinkedElementId | The id of the element in the link, or invalidElementId if no link.
Public property | LinkInstanceId | The id of the link, or invalidElementId if no link.

See Also

LinkElementId Class


HostElementId Property

[image]

Revit 2024 API
LinkElementId..::..HostElementId Property
LinkElementId Class See Also Send Feedback
The id of the element in the host, or invalidElementId if there is a link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public ElementId HostElementId { get; }
Visual Basic
Public ReadOnly Property HostElementId As ElementId
    Get
Visual C++
public:
property ElementId^ HostElementId {
    ElementId^ get ();
}

See Also

LinkElementId Class


LinkedElementId Property

[image]

Revit 2024 API
LinkElementId..::..LinkedElementId Property
LinkElementId Class See Also Send Feedback
The id of the element in the link, or invalidElementId if no link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public ElementId LinkedElementId { get; }
Visual Basic
Public ReadOnly Property LinkedElementId As ElementId
    Get
Visual C++
public:
property ElementId^ LinkedElementId {
    ElementId^ get ();
}

See Also

LinkElementId Class


LinkInstanceId Property

[image]

Revit 2024 API
LinkElementId..::..LinkInstanceId Property
LinkElementId Class See Also Send Feedback
The id of the link, or invalidElementId if no link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElementId LinkInstanceId { get; }
Visual Basic
Public ReadOnly Property LinkInstanceId As ElementId
    Get
Visual C++
public:
property ElementId^ LinkInstanceId {
    ElementId^ get ();
}

See Also

LinkElementId Class


LinkLoadContent Class

[image]

Revit 2024 API
LinkLoadContent Class
Members See Also Send Feedback
This class is used by IExternalResourceServers to return Link data to Revit when their LoadResource method is invoked. It also contains additional information used by IExternalResourceUIServers to display link load status results to the user.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public class LinkLoadContent : ExternalResourceLoadContent
Visual Basic
Public Class LinkLoadContent _
    Inherits ExternalResourceLoadContent
Visual C++
public ref class LinkLoadContent : public ExternalResourceLoadContent

Remarks

This class handles Revit links.

Revit links must be loaded from a path accessible to Revit. Server implementors should provide Revit with a ModelPath representing a location from which to load the link. Revit will handle the actual file loading.

Servers which represent non-local file locations will need to create their own implementation for copying or moving files to a Revit-accessible location.

The link data path used for link loading may be different from the path displayed to the user. The link data path represents the literal location of the file, whereas the link's display path represents what the user sees as the name of the link. See [!:Autodesk::Revit::DB::ExternalResourceReference::InSessionPath] for more details on display paths.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ExternalResourceLoadContent
Autodesk.Revit.DB..::..LinkLoadContent

See Also

LinkLoadContent Members


LinkLoadContent Members

[image] [image]

Revit 2024 API
LinkLoadContent Members
LinkLoadContent Class Methods Properties See Also Send Feedback

The LinkLoadContent type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ExternalResourceLoadContent.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLinkDataPath | Returns the Link data path owned by this LinkLoadContent object.
Public method | GetLinkLoadResult | Retrieves the LinkLoadResult of the attempt to load or reload a Revit link.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetLinkDataPath | Sets the Link data path owned by this LinkLoadContent object.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ExternalResourceLoadContent.)
Public property | LoadStatus | A value to indicate the status of an external resource load operation. IExternalResourceServers should set this in the LoadResource() method. (Inherited from ExternalResourceLoadContent.)
Public property | Version | The version of the external data that the server is providing in this object. (Inherited from ExternalResourceLoadContent.)

See Also

LinkLoadContent Class


LinkLoadContent Methods

[image] [image]

Revit 2024 API
LinkLoadContent Methods
LinkLoadContent Class See Also Send Feedback

The LinkLoadContent type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ExternalResourceLoadContent.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLinkDataPath | Returns the Link data path owned by this LinkLoadContent object.
Public method | GetLinkLoadResult | Retrieves the LinkLoadResult of the attempt to load or reload a Revit link.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetLinkDataPath | Sets the Link data path owned by this LinkLoadContent object.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LinkLoadContent Class


GetLinkDataPath Method

[image]

Revit 2024 API
LinkLoadContent..::..GetLinkDataPath Method
LinkLoadContent Class See Also Send Feedback
Returns the Link data path owned by this LinkLoadContent object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public ModelPath GetLinkDataPath()
Visual Basic
Public Function GetLinkDataPath As ModelPath
Visual C++
public:
ModelPath^ GetLinkDataPath()

Return Value

The Links data path owned by this LinkLoadContent object.

Remarks

This path represents the physical location of the link. Revit will attempt to load the link from this location.

See Also

LinkLoadContent Class


GetLinkLoadResult Method

[image]

Revit 2024 API
LinkLoadContent..::..GetLinkLoadResult Method
LinkLoadContent Class See Also Send Feedback
Retrieves the LinkLoadResult of the attempt to load or reload a Revit link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public LinkLoadResult GetLinkLoadResult()
Visual Basic
Public Function GetLinkLoadResult As LinkLoadResult
Visual C++
public:
LinkLoadResult^ GetLinkLoadResult()

Return Value

A LinkLoadObject containing the status and other information about an attempt by Revit to load a Revit link.

Remarks

A LinkLoadResult object is included in the LinkLoadContent class so that IExternalResourceUIServers will have additional information about the status of the link to display to the user.

The LinkLoadResult is added to the LinkLoadContent object during the load operation, after the IExternalResourceServer LoadResource method has been called. Consequently, this method will return NULL if called from the LoadResource method of an IExternalResourceServer.

See Also

LinkLoadContent Class


SetLinkDataPath Method

[image]

Revit 2024 API
LinkLoadContent..::..SetLinkDataPath Method
LinkLoadContent Class See Also Send Feedback
Sets the Link data path owned by this LinkLoadContent object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public void SetLinkDataPath(
    ModelPath linkPath
)
Visual Basic
Public Sub SetLinkDataPath ( _
    linkPath As ModelPath _
)
Visual C++
public:
void SetLinkDataPath(
    ModelPath^ linkPath
)

Parameters

linkPath
Type: Autodesk.Revit.DB..::..ModelPath
The Links data path set for this LinkLoadContent object.

Remarks

This path must be a location accessible to Revit. Revit will attempt to load the link from this location.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

LinkLoadContent Class


LinkLoadResult Members

[image] [image]

Revit 2024 API
LinkLoadResult Members
LinkLoadResult Class Constructors Methods Properties See Also Send Feedback

The LinkLoadResult type exposes the following members.

Constructors

 | Name | Description
Public method | LinkLoadResult()()()() | Constructs a new uninitialized LinkLoadResult object.
Public method | LinkLoadResult(LinkLoadResult) | Constructs a new copy of the input LinkLoadResult object.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the LinkLoadResult
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCentralModelName | Gets the central model's name. If the link is not workshared, this returns an empty FilePath. If the link is itself a central model, this returns the link's name.
Public method | GetExternalResourceReference | Gets a copy of the ExternalResourceReference corresponding to the link.
Public method | GetExternalResourceReferencesFromFailedLoads | Searches this and all nested LinkLoadResults, and returns a list of ExternalResourceReferences for the links that failed to load.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLinkLoadResult | Searches this LinkLoadResult and all nested LinkLoadResults for the load operation results of a specified ExternalResourceReference.
Public method | GetModelName | Gets the name of the model.
Public method | GetNestedLinkLoadResults | Gets the results for this link's nested links.
Public method | GetParentModelName | Returns the name of the parent of the linked model, or an empty FilePath if the link is a top-level link.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsCodeSuccess | Check if load result code signifies success.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ElementId | The id of the created or loaded linked model.
Public property | IsCircularLink | True if these results are part of a link cycle.
Public property | IsNested | True if these results represent a nested link; false otherwise.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LoadResult | Holds the results of creating or loading a link. Results can be LinkLoadResultType.LinkLoaded for success, or a variety of errors. See LinkLoadResultType for the full list.

See Also

LinkLoadResult Class


LinkLoadResult Constructor

[image] [image]

Revit 2024 API
LinkLoadResult Constructor
LinkLoadResult Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LinkLoadResult()()()() | Constructs a new uninitialized LinkLoadResult object.
Public method | LinkLoadResult(LinkLoadResult) | Constructs a new copy of the input LinkLoadResult object.

See Also

LinkLoadResult Class
LinkLoadResult Members


LinkLoadResult Constructor

[image]

Revit 2024 API
LinkLoadResult Constructor
LinkLoadResult Class See Also Send Feedback
Constructs a new uninitialized LinkLoadResult object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public LinkLoadResult()
Visual Basic
Public Sub New
Visual C++
public:
LinkLoadResult()

See Also

LinkLoadResult Class
LinkLoadResult Overload


LinkLoadResult Constructor (LinkLoadResult)

[image]

Revit 2024 API
LinkLoadResult Constructor (LinkLoadResult)
LinkLoadResult Class See Also Send Feedback
Constructs a new copy of the input LinkLoadResult object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public LinkLoadResult(
    LinkLoadResult other
)
Visual Basic
Public Sub New ( _
    other As LinkLoadResult _
)
Visual C++
public:
LinkLoadResult(
    LinkLoadResult^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..LinkLoadResult

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

LinkLoadResult Class
LinkLoadResult Overload


LinkLoadResult Methods

[image] [image]

Revit 2024 API
LinkLoadResult Methods
LinkLoadResult Class See Also Send Feedback

The LinkLoadResult type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCentralModelName | Gets the central model's name. If the link is not workshared, this returns an empty FilePath. If the link is itself a central model, this returns the link's name.
Public method | GetExternalResourceReference | Gets a copy of the ExternalResourceReference corresponding to the link.
Public method | GetExternalResourceReferencesFromFailedLoads | Searches this and all nested LinkLoadResults, and returns a list of ExternalResourceReferences for the links that failed to load.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLinkLoadResult | Searches this LinkLoadResult and all nested LinkLoadResults for the load operation results of a specified ExternalResourceReference.
Public method | GetModelName | Gets the name of the model.
Public method | GetNestedLinkLoadResults | Gets the results for this link's nested links.
Public method | GetParentModelName | Returns the name of the parent of the linked model, or an empty FilePath if the link is a top-level link.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsCodeSuccess | Check if load result code signifies success.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LinkLoadResult Class


GetCentralModelName Method

[image]

Revit 2024 API
LinkLoadResult..::..GetCentralModelName Method
LinkLoadResult Class See Also Send Feedback
Gets the central model's name. If the link is not workshared, this returns an empty FilePath. If the link is itself a central model, this returns the link's name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ModelPath GetCentralModelName()
Visual Basic
Public Function GetCentralModelName As ModelPath
Visual C++
public:
ModelPath^ GetCentralModelName()

Remarks

If the link could not be found or loaded, this name may be blank. This function is only relevant for LinkLoadResult object for RvtLinkSymbol. ie. when getIsRvtLink() is true.

See Also

LinkLoadResult Class


GetExternalResourceReferencesFromFailedLoads Method

[image]

Revit 2024 API
LinkLoadResult..::..GetExternalResourceReferencesFromFailedLoads Method
LinkLoadResult Class See Also Send Feedback
Searches this and all nested LinkLoadResults, and returns a list of ExternalResourceReferences for the links that failed to load.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public IList<ExternalResourceReference> GetExternalResourceReferencesFromFailedLoads()
Visual Basic
Public Function GetExternalResourceReferencesFromFailedLoads As IList(Of ExternalResourceReference)
Visual C++
public:
IList<ExternalResourceReference^>^ GetExternalResourceReferencesFromFailedLoads()

Return Value

A collection of link ExternalResourceReferences which failed to load.

Remarks

In cases, where a nested structure of several links were loaded, this method is intended to be a convenient way for IExternalResourceUIServers to determine whether a top-level link, or any sub-link, which failed to load properly was provided by their IExternalResourceServer or another server.

If this link and all nested links loaded successfully, then an empty list is returned.

See Also

LinkLoadResult Class


GetLinkLoadResult Method

[image]

Revit 2024 API
LinkLoadResult..::..GetLinkLoadResult Method
LinkLoadResult Class See Also Send Feedback
Searches this LinkLoadResult and all nested LinkLoadResults for the load operation results of a specified ExternalResourceReference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public LinkLoadResult GetLinkLoadResult(
    ExternalResourceReference matchExtResRef
)
Visual Basic
Public Function GetLinkLoadResult ( _
    matchExtResRef As ExternalResourceReference _
) As LinkLoadResult
Visual C++
public:
LinkLoadResult^ GetLinkLoadResult(
    ExternalResourceReference^ matchExtResRef
)

Parameters

matchExtResRef
Type: Autodesk.Revit.DB..::..ExternalResourceReference
An ExternalResourceReference whose LinkLoadResults are contained in this object.

Return Value

A LinkLoadResult object with the load results for the specified ExternalResourceReference.

Remarks

In the case where there are multiple matches, then the LinkLoadResult closest to the top-level link will be returned. For example, if you are searching for C, starting with a top-level link, A, which links B and C, while B also links C directly, then the load results for C as a direct sub-link of A will be returned. It is expected that the LinkLoadResults for all instances of C in the nested load result tree will be the same. However, if you need to inspect each individual result, the LinkLoadResult class does provide methods to navigate the tree.

NULL is returned if a match for the ExternalResourceReference cannot be found.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

LinkLoadResult Class


GetModelName Method

[image]

Revit 2024 API
LinkLoadResult..::..GetModelName Method
LinkLoadResult Class See Also Send Feedback
Gets the name of the model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ModelPath GetModelName()
Visual Basic
Public Function GetModelName As ModelPath
Visual C++
public:
ModelPath^ GetModelName()

See Also

LinkLoadResult Class


GetNestedLinkLoadResults Method

[image]

Revit 2024 API
LinkLoadResult..::..GetNestedLinkLoadResults Method
LinkLoadResult Class See Also Send Feedback
Gets the results for this link's nested links.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public IDictionary<string, LinkLoadResult> GetNestedLinkLoadResults()
Visual Basic
Public Function GetNestedLinkLoadResults As IDictionary(Of String, LinkLoadResult)
Visual C++
public:
IDictionary<String^, LinkLoadResult^>^ GetNestedLinkLoadResults()

Return Value

A map from nested link paths to the load results for that nested link.

For links from external servers, the "path" will be the display name of the link.

Remarks

This function is only relevant for LinkLoadResult object for RvtLinkSymbol. ie. when getIsRvtLink() is true.

See Also

LinkLoadResult Class


IsCodeSuccess Method

[image]

Revit 2024 API
LinkLoadResult..::..IsCodeSuccess Method
LinkLoadResult Class See Also Send Feedback
Check if load result code signifies success.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static bool IsCodeSuccess(
    LinkLoadResultType code
)
Visual Basic
Public Shared Function IsCodeSuccess ( _
    code As LinkLoadResultType _
) As Boolean
Visual C++
public:
static bool IsCodeSuccess(
    LinkLoadResultType code
)

Parameters

code
Type: Autodesk.Revit.DB..::..LinkLoadResultType
Load result code to be verified.

Return Value

True if LinkLoadResultType argument is success, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

LinkLoadResult Class


IsCircularLink Property

[image]

Revit 2024 API
LinkLoadResult..::..IsCircularLink Property
LinkLoadResult Class See Also Send Feedback
True if these results are part of a link cycle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool IsCircularLink { get; }
Visual Basic
Public ReadOnly Property IsCircularLink As Boolean
    Get
Visual C++
public:
property bool IsCircularLink {
    bool get ();
}

Remarks

A link cycle occurs when, for example, model A links model B as an attachment, which links model C as an attachment, which links model A as an attachment. Revit will only load one copy of model A; it will ignore the instance of A linked under C. Circular links do not abort the load process, so they do not appear as a result type in LinkLoadResultType.Enum. This property is only relevant for LinkLoadResult object for RvtLinkSymbol. ie. when getIsRvtLink() is true.

See Also

LinkLoadResult Class


IsNested Property

[image]

Revit 2024 API
LinkLoadResult..::..IsNested Property
LinkLoadResult Class See Also Send Feedback
True if these results represent a nested link; false otherwise.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool IsNested { get; }
Visual Basic
Public ReadOnly Property IsNested As Boolean
    Get
Visual C++
public:
property bool IsNested {
    bool get ();
}

Remarks

This property is only relevant for LinkLoadResult object for RvtLinkSymbol. ie. when getIsRvtLink() is true.

See Also

LinkLoadResult Class


LoadResult Property

[image]

Revit 2024 API
LinkLoadResult..::..LoadResult Property
LinkLoadResult Class See Also Send Feedback
Holds the results of creating or loading a link. Results can be LinkLoadResultType.LinkLoaded for success, or a variety of errors. See LinkLoadResultType for the full list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public LinkLoadResultType LoadResult { get; }
Visual Basic
Public ReadOnly Property LoadResult As LinkLoadResultType
    Get
Visual C++
public:
property LinkLoadResultType LoadResult {
    LinkLoadResultType get ();
}

See Also

LinkLoadResult Class


LinkLoadResultType Enumeration

[image]

Revit 2024 API
LinkLoadResultType Enumeration
See Also Send Feedback
Enum listing the possible results after loading a linked model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Since: 2013

Syntax

C#
public enum LinkLoadResultType
Visual Basic
Public Enumeration LinkLoadResultType
Visual C++
public enum class LinkLoadResultType

Members

Member name | Description
Uninitialized | Revit has not tried to load the link, possibly because it is a nested link and its parent failed to load.
LinkLoaded | The linked model loaded correctly.
LinkNotFound | The linked model could not be found.
LinkNotOpenable | An error occurred trying to read the linked model. It could happen if a wrong link type is trying to be loaded.
LinkOpenAsHost | The linked model is already opened directly in Revit.
SameModelAsHost | The linked model has the same path as the currently active document.
SameCentralModelAsHost | Either the linked model and its host document are both locals of the same central model, or one is a local and the other is its central.
LinkNotLoadedOtherError | An unknown error occurred.
LinkMayBeUpgraded | Point cloud link loaded correctly but is obsolete and may be upgraded.
ExternalServerMissing | The external add-in required to load this link model could not be found.
LinkExists | Revit already has a link with the input location, so no new link can be created.
CouldNotChangeViewReference | The link previously had an invalid view reference and either no new view was provided or the input view was not usable for linking CAD files.
UsedExisting | Revit already has a link with the input location, so the same link is been reused.

Remarks

For all values except LinkLoadResultType.LinkLoaded, the linked model is not loaded and no new link is created (if Revit was trying to create a link).

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


LinkNode Class

[image]

Revit 2024 API
LinkNode Class
Members See Also Send Feedback
An output node that represents a linked Revit document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class LinkNode : GroupNode
Visual Basic
Public Class LinkNode _
    Inherits GroupNode
Visual C++
public ref class LinkNode : public GroupNode

Remarks

See also: [!:Autodesk::Revit::DB::IExportContext::OnLinkBegin].

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..RenderNode
Autodesk.Revit.DB..::..GroupNode
Autodesk.Revit.DB..::..LinkNode

See Also

LinkNode Members


LinkNode Members

[image] [image]

Revit 2024 API
LinkNode Members
LinkNode Class Methods Properties See Also Send Feedback

The LinkNode type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RenderNode.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDocument | Returns the document associated with the link.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTransform | A transformation matrix associated with the node. (Inherited from GroupNode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode.)
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode.)
Public property | SymbolId | Identifies the Id of the symbol associated with the node.

See Also

LinkNode Class


LinkNode Methods

[image] [image]

Revit 2024 API
LinkNode Methods
LinkNode Class See Also Send Feedback

The LinkNode type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RenderNode.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDocument | Returns the document associated with the link.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTransform | A transformation matrix associated with the node. (Inherited from GroupNode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LinkNode Class


LinkNode Properties

[image] [image]

Revit 2024 API
LinkNode Properties
LinkNode Class See Also Send Feedback

The LinkNode type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode.)
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode.)
Public property | SymbolId | Identifies the Id of the symbol associated with the node.

See Also

LinkNode Class


SymbolId Property

[image]

Revit 2024 API
LinkNode..::..SymbolId Property
LinkNode Class See Also Send Feedback
Identifies the Id of the symbol associated with the node.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public ElementId SymbolId { get; }
Visual Basic
Public ReadOnly Property SymbolId As ElementId
    Get
Visual C++
public:
property ElementId^ SymbolId {
    ElementId^ get ();
}

See Also

LinkNode Class


LinkOperations Class

[image]

Revit 2024 API
LinkOperations Class
Members See Also Send Feedback
This class is used to extend the IExternalResourceServer interface with methods to support operations for elements that are LinkTypes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public class LinkOperations : IDisposable
Visual Basic
Public Class LinkOperations _
    Implements IDisposable
Visual C++
public ref class LinkOperations : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..LinkOperations
Autodesk.Revit.DB..::..CADLinkOperations
Autodesk.Revit.DB..::..RevitLinkOperations

See Also

LinkOperations Members


LinkOperations Members

[image] [image]

Revit 2024 API
LinkOperations Members
LinkOperations Class Methods Properties See Also Send Feedback

The LinkOperations type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the LinkOperations
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetOnLocalLinkSharedCoordinatesSavedCallback | Sets the callback that will be called when the Revit user saves new shared coordinate settings to a linked document obtained from an IExternalResourceServer.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

LinkOperations Class


LinkOperations Methods

[image] [image]

Revit 2024 API
LinkOperations Methods
LinkOperations Class See Also Send Feedback

The LinkOperations type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetOnLocalLinkSharedCoordinatesSavedCallback | Sets the callback that will be called when the Revit user saves new shared coordinate settings to a linked document obtained from an IExternalResourceServer.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LinkOperations Class


SetOnLocalLinkSharedCoordinatesSavedCallback Method

[image]

Revit 2024 API
LinkOperations..::..SetOnLocalLinkSharedCoordinatesSavedCallback Method
LinkOperations Class See Also Send Feedback
Sets the callback that will be called when the Revit user saves new shared coordinate settings to a linked document obtained from an IExternalResourceServer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public void SetOnLocalLinkSharedCoordinatesSavedCallback(
    IOnLocalLinkSharedCoordinatesSavedCallback onLocalLinkSharedCoordinatesSaved
)
Visual Basic
Public Sub SetOnLocalLinkSharedCoordinatesSavedCallback ( _
    onLocalLinkSharedCoordinatesSaved As IOnLocalLinkSharedCoordinatesSavedCallback _
)
Visual C++
public:
void SetOnLocalLinkSharedCoordinatesSavedCallback(
    IOnLocalLinkSharedCoordinatesSavedCallback^ onLocalLinkSharedCoordinatesSaved
)

Parameters

onLocalLinkSharedCoordinatesSaved
Type: Autodesk.Revit.DB..::..IOnLocalLinkSharedCoordinatesSavedCallback
An IOnLocalLinkSharedCoordinatesSavedCallback object that can respond when the user saves new shared coordinates to a Revit link document obtained from IExternalResourceServer.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

LinkOperations Class


IsValidObject Property

[image]

Revit 2024 API
LinkOperations..::..IsValidObject Property
LinkOperations Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

LinkOperations Class


ListType Enumeration

[image]

Revit 2024 API
ListType Enumeration
See Also Send Feedback
An enumerated type indicating the style of list item for paragraphs that are part of ordered or unordered lists in FormattedText.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public enum ListType
Visual Basic
Public Enumeration ListType
Visual C++
public enum class ListType

Members

Member name | Description
Mixed | This value may be returned by FormattedText.GetListType() when there are multiple list types in the selected range.
None | The paragraph is not a part of a list.
Bullet | The paragraph is a part of a bulleted list.
ArabicNumbers | The paragraph is a part of an ordered list with Arabic number headings.
LowerCaseLetters | The paragraph is a part of an ordered list with lower-case letter headings.
UpperCaseLetters | The paragraph is a part of an ordered list with upper-case letter headings.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


LoadedFamilyIntegrityCheck Class

[image]

Revit 2024 API
LoadedFamilyIntegrityCheck Class
Members See Also Send Feedback
Functions for checking the integrity of loaded families.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class LoadedFamilyIntegrityCheck
Visual Basic
Public NotInheritable Class LoadedFamilyIntegrityCheck
Visual C++
public ref class LoadedFamilyIntegrityCheck abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..LoadedFamilyIntegrityCheck

See Also

LoadedFamilyIntegrityCheck Members


LoadedFamilyIntegrityCheck Members

[image] [image]

Revit 2024 API
LoadedFamilyIntegrityCheck Members
LoadedFamilyIntegrityCheck Class Methods See Also Send Feedback

The LoadedFamilyIntegrityCheck type exposes the following members.

Methods

Name | Description
CheckAllFamilies | Check that all families loaded in the host document have their content documents.
CheckAllFamiliesSlow | Check integrity of content documents of all families loaded in the host document.
CheckFamily | Check that the loaded family has its content document.

See Also

LoadedFamilyIntegrityCheck Class


LoadedFamilyIntegrityCheck Methods

[image] [image]

Revit 2024 API
LoadedFamilyIntegrityCheck Methods
LoadedFamilyIntegrityCheck Class See Also Send Feedback

The LoadedFamilyIntegrityCheck type exposes the following members.

Methods

Name | Description
CheckAllFamilies | Check that all families loaded in the host document have their content documents.
CheckAllFamiliesSlow | Check integrity of content documents of all families loaded in the host document.
CheckFamily | Check that the loaded family has its content document.

See Also

LoadedFamilyIntegrityCheck Class


CheckFamily Method

[image]

Revit 2024 API
LoadedFamilyIntegrityCheck..::..CheckFamily Method
LoadedFamilyIntegrityCheck Class See Also Send Feedback
Check that the loaded family has its content document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static bool CheckFamily(
    Document ADoc,
    ElementId familyId
)
Visual Basic
Public Shared Function CheckFamily ( _
    ADoc As Document, _
    familyId As ElementId _
) As Boolean
Visual C++
public:
static bool CheckFamily(
    Document^ ADoc,
    ElementId^ familyId
)

Parameters

ADoc
Type: Autodesk.Revit.DB..::..Document
The host document.
familyId
Type: Autodesk.Revit.DB..::..ElementId
The id of the family to check.

Return Value

Returns true if the family has its content document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

LoadedFamilyIntegrityCheck Class


Location Class

[image]

Revit 2024 API
Location Class
Members Example See Also Send Feedback
Provides location functionality for all elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class Location : APIObject
Visual Basic
Public Class Location _
    Inherits APIObject
Visual C++
public ref class Location : public APIObject

Remarks

The location object provides the ability to translate and rotate elements. More detailed location information and control can be found by using the derivatives of this object, such as LocationPoint or LocationCurve.

Examples

CopyC#
void ShowLocationUsage(Autodesk.Revit.ApplicationServices.Application application, Wall wall)
{
    // Get the location instance.
    Autodesk.Revit.DB.Location position = wall.Location;

    // Check whether the wall is pinned.
    if (wall.Pinned)
    {
        throw new Exception("The wall has been pinned.");
    }

    // Move the wall location, it provides same function as Move method of Document class.
    XYZ direction = new XYZ(10, 0, 0);
    bool result = position.Move(direction);
    if (!result)
    {
        throw new Exception("Move wall location failed.");
    }

    // Rotate the wall location, it provides same function as Rotate method of Document class.
    XYZ axisStart = new XYZ(0, 0, 0);
    XYZ axisEnd = new XYZ(0, 0, 1);
    Line axis = Line.CreateUnbound(axisStart, axisEnd);
    result = position.Rotate(axis, 30);
    if (!result)
    {
        throw new Exception("Rotate wall location failed.");
    }
}
CopyVB.NET
Private Sub ShowLocationUsage(application As Autodesk.Revit.ApplicationServices.Application, wall As Wall)
    ' Get the location instance.
    Dim position As Autodesk.Revit.DB.Location = wall.Location

    ' Check whether the wall is pinned.
    If wall.Pinned Then
        Throw New Exception("The wall has been pinned.")
    End If

    ' Move the wall location, it provides same function as Move method of Document class.
    Dim direction As New XYZ(10, 0, 0)
    Dim result As Boolean = position.Move(direction)
    If Not result Then
        Throw New Exception("Move wall location failed.")
    End If

    ' Rotate the wall location, it provides same function as Rotate method of Document class.
    Dim axisStart As New XYZ(0, 0, 0)
    Dim axisEnd As New XYZ(0, 0, 1)
    Dim axis As Line = Line.CreateUnbound(axisStart, axisEnd)
    result = position.Rotate(axis, 30)
    If Not result Then
        Throw New Exception("Rotate wall location failed.")
    End If
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..Location
Autodesk.Revit.DB..::..LocationCurve
Autodesk.Revit.DB..::..LocationPoint

See Also

Location Members


Location Members

[image] [image]

Revit 2024 API
Location Members
Location Class Methods Properties See Also Send Feedback

The Location type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Move | Move the element within the project by a specified vector.
Public method | Rotate | Rotate the element within the project by a specified angle around a given axis.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Location Class


Move Method

[image]

Revit 2024 API
Location..::..Move Method
Location Class Example See Also Send Feedback
Move the element within the project by a specified vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool Move(
    XYZ translation
)
Visual Basic
Public Function Move ( _
    translation As XYZ _
) As Boolean
Visual C++
public:
bool Move(
    XYZ^ translation
)

Parameters

translation
Type: Autodesk.Revit.DB..::..XYZ
The vector by which the element is to be moved.

Return Value

If the element is moved successfully then the method return True, otherwise False.

Remarks

The move method is used to move an element within the project. Other elements may also be moved when this element is moved, for example: if the element is wall and it contains windows, the windows will also be moved.

Examples

CopyC#
bool MoveUsingLocationCurve(Autodesk.Revit.ApplicationServices.Application application, Wall wall)
{
    LocationCurve wallLine = wall.Location as LocationCurve;
    XYZ translationVec = new XYZ(10, 20, 0);
    return (wallLine.Move(translationVec));
}
CopyVB.NET
Private Function MoveUsingLocationCurve(application As Autodesk.Revit.ApplicationServices.Application, wall As Wall) As Boolean
    Dim wallLine As LocationCurve = TryCast(wall.Location, LocationCurve)
    Dim translationVec As New XYZ(10, 20, 0)
    Return (wallLine.Move(translationVec))
End Function

See Also

Location Class


Location Properties

[image] [image]

Revit 2024 API
Location Properties
Location Class See Also Send Feedback

The Location type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Location Class


LocationCurve Class

[image]

Revit 2024 API
LocationCurve Class
Members See Also Send Feedback
Provides location functionality for all elements that are based upon a curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class LocationCurve : Location
Visual Basic
Public Class LocationCurve _
    Inherits Location
Visual C++
public ref class LocationCurve : public Location

Remarks

The location line objects adds additional functionality to its base location object class. This includes reading and writing the curve contained within the element.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..Location
Autodesk.Revit.DB..::..LocationCurve

See Also

LocationCurve Members


LocationCurve Members

[image] [image]

Revit 2024 API
LocationCurve Members
LocationCurve Class Methods Properties See Also Send Feedback

The LocationCurve type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Move | Move the element within the project by a specified vector. (Inherited from Location.)
Public method | Rotate | Rotate the element within the project by a specified angle around a given axis. (Inherited from Location.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Curve | Provides the ability to get and set the curve of a curve based element.
Public property | ElementsAtJoin | Get all elements joining to the end of this element's location curve or change the order of elements participation in the end join with this location curve's end.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | JoinType | Get/change the type of the join at the specified end.

See Also

LocationCurve Class


LocationCurve Methods

[image] [image]

Revit 2024 API
LocationCurve Methods
LocationCurve Class See Also Send Feedback

The LocationCurve type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Move | Move the element within the project by a specified vector. (Inherited from Location.)
Public method | Rotate | Rotate the element within the project by a specified angle around a given axis. (Inherited from Location.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LocationCurve Class


LocationCurve Properties

[image] [image]

Revit 2024 API
LocationCurve Properties
LocationCurve Class See Also Send Feedback

The LocationCurve type exposes the following members.

Properties

 | Name | Description
Public property | Curve | Provides the ability to get and set the curve of a curve based element.
Public property | ElementsAtJoin | Get all elements joining to the end of this element's location curve or change the order of elements participation in the end join with this location curve's end.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | JoinType | Get/change the type of the join at the specified end.

See Also

LocationCurve Class


Curve Property

[image]

Revit 2024 API
LocationCurve..::..Curve Property
LocationCurve Class Example See Also Send Feedback
Provides the ability to get and set the curve of a curve based element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Curve Curve { get; set; }
Visual Basic
Public Property Curve As Curve
    Get
    Set
Visual C++
public:
property Curve^ Curve {
    Curve^ get ();
    void set (Curve^ value);
}

Remarks

This property can be used to set the location of curve based element to any desired position. Many elements are curve based. Some examples are walls, beams and braces.

Examples

CopyC#
void MoveUsingCurveParam(Autodesk.Revit.ApplicationServices.Application application, Wall wall)
{
    LocationCurve wallLine = wall.Location as LocationCurve;
    XYZ p1 = XYZ.Zero;
    XYZ p2 = new XYZ(10, 20, 0);
    Line newWallLine = Line.CreateBound(p1, p2);

    // Change the wall line to a new line.
    wallLine.Curve = newWallLine;
}
CopyVB.NET
Private Sub MoveUsingCurveParam(application As Autodesk.Revit.ApplicationServices.Application, wall As Wall)
    Dim wallLine As LocationCurve = TryCast(wall.Location, LocationCurve)
    Dim p1 As XYZ = XYZ.Zero
    Dim p2 As New XYZ(10, 20, 0)
    Dim newWallLine As Line = Line.CreateBound(p1, p2)

    ' Change the wall line to a new line.
    wallLine.Curve = newWallLine
End Sub

See Also

LocationCurve Class


JoinType Property

[image]

Revit 2024 API
LocationCurve..::..JoinType Property
LocationCurve Class See Also Send Feedback
Get/change the type of the join at the specified end.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public JoinType this[
    int end
] { get; set; }
Visual Basic
Public Property JoinType ( _
    end As Integer _
) As JoinType
    Get
    Set
Visual C++
public:
property JoinType JoinType[int end] {
    JoinType get (int end);
    void set (int end, JoinType value);
}

Parameters

end
Type: System..::..Int32
The end of the location curve driver under question.

Remarks

This property allows to get join type of wall and concrete beam and to set wall's join type. The new join type is expected to be different from the current one for this end.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The element is neither a wall nor a concrete beam when it tries to get the property. The element is not a wall when it tries to set the property.
Autodesk.Revit.Exceptions..::..InvalidOperationException | A failure occurred while attempting to set the new type.

See Also

LocationCurve Class


LocationPoint Class

[image]

Revit 2024 API
LocationPoint Class
Members Example See Also Send Feedback
Provides location functionality for all elements that have a single insertion point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class LocationPoint : Location
Visual Basic
Public Class LocationPoint _
    Inherits Location
Visual C++
public ref class LocationPoint : public Location

Remarks

The location point objects adds additional functionality to its base location object class. This includes setting the elements location to a specific point and retrieving its rotation around its insertion point. Inplace families do not have a single insertion point and therefore do not have meaningful LocationPoint data.

Examples

CopyC#
void LocationInformation(LocationPoint position)
{
    String prompt = "The selected column location information:";
    prompt += "\nPoint:  (" + position.Point.X + ", "
            + position.Point.Y + ", " + position.Point.Z + ")";
    prompt += "\nRotation: " + position.Rotation;

    TaskDialog.Show("Revit",prompt);
}

bool LocationRotate(Autodesk.Revit.ApplicationServices.Application application, Autodesk.Revit.DB.Element element)
{
    bool rotated = false;
    LocationPoint location = element.Location as LocationPoint;

    if (null != location)
    {
        XYZ aa = location.Point;
        XYZ cc = new XYZ(aa.X, aa.Y, aa.Z + 10);
        Line axis = Line.CreateBound(aa,cc);
        rotated = location.Rotate(axis, Math.PI / 2.0);
    }

    return rotated;
}
CopyVB.NET
Private Sub LocationInformation(position As LocationPoint)
    Dim prompt As [String] = "The selected column location information:"
    prompt += vbLf & "Point:  (" & Convert.ToString(position.Point.X) & ", " & Convert.ToString(position.Point.Y) & ", " & Convert.ToString(position.Point.Z) & ")"
    prompt += vbLf & "Rotation: " & Convert.ToString(position.Rotation)

    TaskDialog.Show("Revit", prompt)
End Sub

Private Function LocationRotate(application As Autodesk.Revit.ApplicationServices.Application, element As Autodesk.Revit.DB.Element) As Boolean
    Dim rotated As Boolean = False
    Dim location As LocationPoint = TryCast(element.Location, LocationPoint)

    If location IsNot Nothing Then
        Dim aa As XYZ = location.Point
        Dim cc As New XYZ(aa.X, aa.Y, aa.Z + 10)
        Dim axis As Line = Line.CreateBound(aa, cc)
        rotated = location.Rotate(axis, Math.PI / 2.0)
    End If

    Return rotated
End Function

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..Location
Autodesk.Revit.DB..::..LocationPoint

See Also

LocationPoint Members


LocationPoint Methods

[image] [image]

Revit 2024 API
LocationPoint Methods
LocationPoint Class See Also Send Feedback

The LocationPoint type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Move | Move the element within the project by a specified vector. (Inherited from Location.)
Public method | Rotate | Rotate the element within the project by a specified angle around a given axis. (Inherited from Location.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LocationPoint Class


LocationPoint Properties

[image] [image]

Revit 2024 API
LocationPoint Properties
LocationPoint Class See Also Send Feedback

The LocationPoint type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Point | The physical location of the element.
Public property | Rotation | The angle of rotation around the insertion point, in radians.

See Also

LocationPoint Class


Point Property

[image]

Revit 2024 API
LocationPoint..::..Point Property
LocationPoint Class Example See Also Send Feedback
The physical location of the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ Point { get; set; }
Visual Basic
Public Property Point As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ Point {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

Setting this property is not supported for some elements supporting LocationPoints, such as SpotDimensions.

Examples

CopyC#
void LocationMove(FamilyInstance column)
{
    LocationPoint columnPoint = column.Location as LocationPoint;
    if (null != columnPoint)
    {
        XYZ newLocation = new XYZ(10, 20, 0);
        // Move the column to the new location
        columnPoint.Point = newLocation;
    }
}
CopyVB.NET
Private Sub LocationMove(column As FamilyInstance)
    Dim columnPoint As LocationPoint = TryCast(column.Location, LocationPoint)
    If columnPoint IsNot Nothing Then
        Dim newLocation As New XYZ(10, 20, 0)
        ' Move the column to the new location
        columnPoint.Point = newLocation
    End If
End Sub

See Also

LocationPoint Class


Rotation Property

[image]

Revit 2024 API
LocationPoint..::..Rotation Property
LocationPoint Class See Also Send Feedback
The angle of rotation around the insertion point, in radians.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double Rotation { get; }
Visual Basic
Public ReadOnly Property Rotation As Double
    Get
Visual C++
public:
property double Rotation {
    double get ();
}

Remarks

For view-based elements, the rotation angle is in the plane of the associated view. For model elements, the rotation angle is measured relative to the default coordinate system. This property is not supported for some elements supporting LocationPoints, such as AssemblyInstances, Groups, ModelText, Room, and SpotDimensions.

See Also

LocationPoint Class


LogicalAndFilter Class

[image]

Revit 2024 API
LogicalAndFilter Class
Members Example See Also Send Feedback
A filter that contains a set of filters. The filter passes when all filters in the set pass.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class LogicalAndFilter : ElementLogicalFilter
Visual Basic
Public Class LogicalAndFilter _
    Inherits ElementLogicalFilter
Visual C++
public ref class LogicalAndFilter : public ElementLogicalFilter

Remarks

The component filters may be reordered by Revit to cause the quickest acting filters to be evaluated first.

Examples

CopyC#
// Find all door instances in the project by finding all elements that both belong to the door
// category and are family instances.
ElementClassFilter familyInstanceFilter = new ElementClassFilter(typeof(FamilyInstance));

// Create a category filter for Doors
ElementCategoryFilter doorsCategoryfilter = new ElementCategoryFilter(BuiltInCategory.OST_Doors);

// Create a logic And filter for all Door FamilyInstances
LogicalAndFilter doorInstancesFilter = new LogicalAndFilter(familyInstanceFilter, doorsCategoryfilter);

// Apply the filter to the elements in the active document
FilteredElementCollector collector = new FilteredElementCollector(document);
IList<Element> doors = collector.WherePasses(doorInstancesFilter).ToElements();
CopyVB.NET
' Find all door instances in the project by finding all elements that both belong to the door
' category and are family instances.
Dim familyInstanceFilter As New ElementClassFilter(GetType(FamilyInstance))

' Create a category filter for Doors
Dim doorsCategoryfilter As New ElementCategoryFilter(BuiltInCategory.OST_Doors)

' Create a logic And filter for all Door FamilyInstances
Dim doorInstancesFilter As New LogicalAndFilter(familyInstanceFilter, doorsCategoryfilter)

' Apply the filter to the elements in the active document
Dim collector As New FilteredElementCollector(document)
Dim doors As IList(Of Element) = collector.WherePasses(doorInstancesFilter).ToElements()

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementLogicalFilter
Autodesk.Revit.DB..::..LogicalAndFilter

See Also

LogicalAndFilter Members


LogicalAndFilter Members

[image] [image]

Revit 2024 API
LogicalAndFilter Members
LogicalAndFilter Class Constructors Methods Properties See Also Send Feedback

The LogicalAndFilter type exposes the following members.

Constructors

 | Name | Description
Public method | LogicalAndFilter(IList<(Of <<'(ElementFilter>)>>)) | Constructs a new instance of the logical filter with any number of input filters.
Public method | LogicalAndFilter(ElementFilter, ElementFilter) | Constructs a new instance of the logical filter with two input filters.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetFilters | Returns an array of copies of the filters that are logically combined by this ElementLogicalFilter. (Inherited from ElementLogicalFilter.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | SetFilters | Replaces current filters in the logical filter with any number of input filters. (Inherited from ElementLogicalFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)

See Also

LogicalAndFilter Class


LogicalAndFilter Constructor

[image] [image]

Revit 2024 API
LogicalAndFilter Constructor
LogicalAndFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LogicalAndFilter(IList<(Of <<'(ElementFilter>)>>)) | Constructs a new instance of the logical filter with any number of input filters.
Public method | LogicalAndFilter(ElementFilter, ElementFilter) | Constructs a new instance of the logical filter with two input filters.

See Also

LogicalAndFilter Class
LogicalAndFilter Members


LogicalAndFilter Methods

[image] [image]

Revit 2024 API
LogicalAndFilter Methods
LogicalAndFilter Class See Also Send Feedback

The LogicalAndFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetFilters | Returns an array of copies of the filters that are logically combined by this ElementLogicalFilter. (Inherited from ElementLogicalFilter.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | SetFilters | Replaces current filters in the logical filter with any number of input filters. (Inherited from ElementLogicalFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LogicalAndFilter Class


PassesFilter Method

[image] [image]

Revit 2024 API
LogicalAndFilter..::..PassesFilter Method
LogicalAndFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

LogicalAndFilter Class
LogicalAndFilter Members


LogicalAndFilter Properties

[image] [image]

Revit 2024 API
LogicalAndFilter Properties
LogicalAndFilter Class See Also Send Feedback

The LogicalAndFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)

See Also

LogicalAndFilter Class


LogicalOrFilter Class

[image]

Revit 2024 API
LogicalOrFilter Class
Members See Also Send Feedback
A filter that contains a set of filters. The filter passes when any filter in the set passes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class LogicalOrFilter : ElementLogicalFilter
Visual Basic
Public Class LogicalOrFilter _
    Inherits ElementLogicalFilter
Visual C++
public ref class LogicalOrFilter : public ElementLogicalFilter

Remarks

The component filters may be reordered by Revit to cause the quickest acting filters to be evaluated first.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementLogicalFilter
Autodesk.Revit.DB..::..LogicalOrFilter

See Also

LogicalOrFilter Members


LogicalOrFilter Members

[image] [image]

Revit 2024 API
LogicalOrFilter Members
LogicalOrFilter Class Constructors Methods Properties See Also Send Feedback

The LogicalOrFilter type exposes the following members.

Constructors

 | Name | Description
Public method | LogicalOrFilter(IList<(Of <<'(ElementFilter>)>>)) | Constructs a new instance of the logical filter with any number of input filters.
Public method | LogicalOrFilter(ElementFilter, ElementFilter) | Constructs a new instance of the logical filter with two input filters.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetFilters | Returns an array of copies of the filters that are logically combined by this ElementLogicalFilter. (Inherited from ElementLogicalFilter.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | SetFilters | Replaces current filters in the logical filter with any number of input filters. (Inherited from ElementLogicalFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)

See Also

LogicalOrFilter Class


LogicalOrFilter Constructor

[image] [image]

Revit 2024 API
LogicalOrFilter Constructor
LogicalOrFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LogicalOrFilter(IList<(Of <<'(ElementFilter>)>>)) | Constructs a new instance of the logical filter with any number of input filters.
Public method | LogicalOrFilter(ElementFilter, ElementFilter) | Constructs a new instance of the logical filter with two input filters.

See Also

LogicalOrFilter Class
LogicalOrFilter Members


LogicalOrFilter Constructor (IList(ElementFilter))

[image]

Revit 2024 API
LogicalOrFilter Constructor (IList<(Of <(<'ElementFilter>)>)>)
LogicalOrFilter Class See Also Send Feedback
Constructs a new instance of the logical filter with any number of input filters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public LogicalOrFilter(
    IList<ElementFilter> filters
)
Visual Basic
Public Sub New ( _
    filters As IList(Of ElementFilter) _
)
Visual C++
public:
LogicalOrFilter(
    IList<ElementFilter^>^ filters
)

Parameters

filters
Type: System.Collections.Generic..::..IList<(Of <(<' ElementFilter >)>)>
A collection of input filters.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The filter collection is empty, or contains invalid inputs.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

LogicalOrFilter Class
LogicalOrFilter Overload


LogicalOrFilter Constructor (ElementFilter, ElementFilter)

[image]

Revit 2024 API
LogicalOrFilter Constructor (ElementFilter, ElementFilter)
LogicalOrFilter Class See Also Send Feedback
Constructs a new instance of the logical filter with two input filters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public LogicalOrFilter(
    ElementFilter filter1,
    ElementFilter filter2
)
Visual Basic
Public Sub New ( _
    filter1 As ElementFilter, _
    filter2 As ElementFilter _
)
Visual C++
public:
LogicalOrFilter(
    ElementFilter^ filter1,
    ElementFilter^ filter2
)

Parameters

filter1
Type: Autodesk.Revit.DB..::..ElementFilter
The first filter.
filter2
Type: Autodesk.Revit.DB..::..ElementFilter
The second filter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

LogicalOrFilter Class
LogicalOrFilter Overload


PassesFilter Method

[image] [image]

Revit 2024 API
LogicalOrFilter..::..PassesFilter Method
LogicalOrFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

LogicalOrFilter Class
LogicalOrFilter Members


LogicalOrFilter Properties

[image] [image]

Revit 2024 API
LogicalOrFilter Properties
LogicalOrFilter Class See Also Send Feedback

The LogicalOrFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)

See Also

LogicalOrFilter Class


MarginType Enumeration

[image]

Revit 2024 API
MarginType Enumeration
See Also Send Feedback
An enumerated type listing all Margin types of Print Setting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum MarginType
Visual Basic
Public Enumeration MarginType
Visual C++
public enum class MarginType

Members

Member name | Description
NoMargin | The type of Margin is No Margin.
PrinterLimit | The type of Margin is Printer Limit.
UserDefined | The type of Margin is User Defined.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


MassDisplayTemporaryOverrideType Enumeration

[image]

Revit 2024 API
MassDisplayTemporaryOverrideType Enumeration
See Also Send Feedback
This enum identifies the mass display overrides.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Since: 2012

Syntax

C#
public enum MassDisplayTemporaryOverrideType
Visual Basic
Public Enumeration MassDisplayTemporaryOverrideType
Visual C++
public enum class MassDisplayTemporaryOverrideType

Members

Member name | Description
ShowMassByViewSettings | Mass will be displayed in each view based on the visibility settings of that view.
ShowMassFormAndFloors | Mass form and mass floor subcategories will be displayed in all views.
ShowMassSurfaceTypes | Mass energy analysis surface subcategories (and Mass Floors) will be displayed.
ShowMassZonesAndShades | Mass zone and mass shade subcategories will be displayed.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


MassInstanceUtils Class

[image]

Revit 2024 API
MassInstanceUtils Class
Members See Also Send Feedback
A static class that contains methods for processing curves driven by points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public class MassInstanceUtils : IDisposable
Visual Basic
Public Class MassInstanceUtils _
    Implements IDisposable
Visual C++
public ref class MassInstanceUtils : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..MassInstanceUtils

See Also

MassInstanceUtils Members


MassInstanceUtils Members

[image] [image]

Revit 2024 API
MassInstanceUtils Members
MassInstanceUtils Class Methods Properties See Also Send Feedback

The MassInstanceUtils type exposes the following members.

Methods

 | Name | Description
 | AddMassLevelDataToMassInstance | Create a MassLevelData (Mass Floor) to associate a Level with a mass instance.
Public method | Dispose | Releases all resources used by the MassInstanceUtils
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetGrossFloorArea | Get the total occupiable floor area represented by a mass instance.
 | GetGrossSurfaceArea | Get the total exterior building surface area represented by a mass instance.
 | GetGrossVolume | Get the total building volume represented by a mass instance.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetJoinedElementIds | Get the ElementIds of Elements that are joined to a mass instance.
 | GetMassLevelDataIds | Get the ElementIds of the MassLevelDatas (Mass Floors) associated with a mass instance.
 | GetMassLevelIds | Get the ElementIds of the Levels associated with a mass instance.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | RemoveMassLevelDataFromMassInstance | Delete the MassLevelData (Mass Floor) that associates a Level with a mass instance.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

MassInstanceUtils Class


MassInstanceUtils Methods

[image] [image]

Revit 2024 API
MassInstanceUtils Methods
MassInstanceUtils Class See Also Send Feedback

The MassInstanceUtils type exposes the following members.

Methods

 | Name | Description
 | AddMassLevelDataToMassInstance | Create a MassLevelData (Mass Floor) to associate a Level with a mass instance.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetGrossFloorArea | Get the total occupiable floor area represented by a mass instance.
 | GetGrossSurfaceArea | Get the total exterior building surface area represented by a mass instance.
 | GetGrossVolume | Get the total building volume represented by a mass instance.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetJoinedElementIds | Get the ElementIds of Elements that are joined to a mass instance.
 | GetMassLevelDataIds | Get the ElementIds of the MassLevelDatas (Mass Floors) associated with a mass instance.
 | GetMassLevelIds | Get the ElementIds of the Levels associated with a mass instance.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | RemoveMassLevelDataFromMassInstance | Delete the MassLevelData (Mass Floor) that associates a Level with a mass instance.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MassInstanceUtils Class


Dispose Method

[image]

Revit 2024 API
MassInstanceUtils..::..Dispose Method
MassInstanceUtils Class See Also Send Feedback
Releases all resources used by the MassInstanceUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

MassInstanceUtils Class


GetGrossFloorArea Method

[image]

Revit 2024 API
MassInstanceUtils..::..GetGrossFloorArea Method
MassInstanceUtils Class See Also Send Feedback
Get the total occupiable floor area represented by a mass instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static double GetGrossFloorArea(
    Document document,
    ElementId massInstanceId
)
Visual Basic
Public Shared Function GetGrossFloorArea ( _
    document As Document, _
    massInstanceId As ElementId _
) As Double
Visual C++
public:
static double GetGrossFloorArea(
    Document^ document,
    ElementId^ massInstanceId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The Document.
massInstanceId
Type: Autodesk.Revit.DB..::..ElementId
The ElementId of the mass instance.

Return Value

The gross floor area in square feet.

Remarks

The area is computed from the cross sections that are created by intersecting the associated Levels with the mass instance Geometry.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId massInstanceId is not a mass instance.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

MassInstanceUtils Class


GetJoinedElementIds Method

[image]

Revit 2024 API
MassInstanceUtils..::..GetJoinedElementIds Method
MassInstanceUtils Class See Also Send Feedback
Get the ElementIds of Elements that are joined to a mass instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static IList<ElementId> GetJoinedElementIds(
    Document document,
    ElementId massInstanceId
)
Visual Basic
Public Shared Function GetJoinedElementIds ( _
    document As Document, _
    massInstanceId As ElementId _
) As IList(Of ElementId)
Visual C++
public:
static IList<ElementId^>^ GetJoinedElementIds(
    Document^ document,
    ElementId^ massInstanceId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The Document.
massInstanceId
Type: Autodesk.Revit.DB..::..ElementId
The ElementId of the mass instance.

Return Value

ElementIds of Elements joined to the mass instance.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId massInstanceId is not a mass instance.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

MassInstanceUtils Class


GetMassLevelDataIds Method

[image]

Revit 2024 API
MassInstanceUtils..::..GetMassLevelDataIds Method
MassInstanceUtils Class See Also Send Feedback
Get the ElementIds of the MassLevelDatas (Mass Floors) associated with a mass instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static IList<ElementId> GetMassLevelDataIds(
    Document document,
    ElementId massInstanceId
)
Visual Basic
Public Shared Function GetMassLevelDataIds ( _
    document As Document, _
    massInstanceId As ElementId _
) As IList(Of ElementId)
Visual C++
public:
static IList<ElementId^>^ GetMassLevelDataIds(
    Document^ document,
    ElementId^ massInstanceId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The Document.
massInstanceId
Type: Autodesk.Revit.DB..::..ElementId
The ElementId of the mass instance.

Return Value

The ElementIds of the MassLevelDatas.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId massInstanceId is not a mass instance.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

MassInstanceUtils Class


GetMassLevelIds Method

[image]

Revit 2024 API
MassInstanceUtils..::..GetMassLevelIds Method
MassInstanceUtils Class See Also Send Feedback
Get the ElementIds of the Levels associated with a mass instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static IList<ElementId> GetMassLevelIds(
    Document document,
    ElementId massInstanceId
)
Visual Basic
Public Shared Function GetMassLevelIds ( _
    document As Document, _
    massInstanceId As ElementId _
) As IList(Of ElementId)
Visual C++
public:
static IList<ElementId^>^ GetMassLevelIds(
    Document^ document,
    ElementId^ massInstanceId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The Document.
massInstanceId
Type: Autodesk.Revit.DB..::..ElementId
The ElementId of the mass instance.

Return Value

The ElementIds of the Levels

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId massInstanceId is not a mass instance.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

MassInstanceUtils Class


RemoveMassLevelDataFromMassInstance Method

[image]

Revit 2024 API
MassInstanceUtils..::..RemoveMassLevelDataFromMassInstance Method
MassInstanceUtils Class See Also Send Feedback
Delete the MassLevelData (Mass Floor) that associates a Level with a mass instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static void RemoveMassLevelDataFromMassInstance(
    Document document,
    ElementId massInstanceId,
    ElementId levelId
)
Visual Basic
Public Shared Sub RemoveMassLevelDataFromMassInstance ( _
    document As Document, _
    massInstanceId As ElementId, _
    levelId As ElementId _
)
Visual C++
public:
static void RemoveMassLevelDataFromMassInstance(
    Document^ document,
    ElementId^ massInstanceId,
    ElementId^ levelId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The Document.
massInstanceId
Type: Autodesk.Revit.DB..::..ElementId
The ElementId of the mass instance.
levelId
Type: Autodesk.Revit.DB..::..ElementId
The ElementId of the Level to disassociate from the mass instance.

Remarks

Alternatively, you could just delete the MassLevelData.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId massInstanceId is not a mass instance. -or- The ElementId levelId is not a Level.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

MassInstanceUtils Class


MassInstanceUtils Properties

[image] [image]

Revit 2024 API
MassInstanceUtils Properties
MassInstanceUtils Class See Also Send Feedback

The MassInstanceUtils type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

MassInstanceUtils Class


IsValidObject Property

[image]

Revit 2024 API
MassInstanceUtils..::..IsValidObject Property
MassInstanceUtils Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

MassInstanceUtils Class


Material Class

[image]

Revit 2024 API
Material Class
Members Example See Also Send Feedback
Represents a material element within an Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class Material : Element
Visual Basic
Public Class Material _
    Inherits Element
Visual C++
public ref class Material : public Element

Examples

CopyC#
private void GetMaterialInformation(Material material)
{
   StringBuilder message = new StringBuilder("Material : " + material.Name);
   //color of the material
   message.Append(string.Format("\nColor: Red[{0}]; Green[{1}]; Blue[{2}]",
                   material.Color.Red, material.Color.Green, material.Color.Blue));

   //foreground cut pattern and pattern color of the material
   FillPatternElement cutForegroundPattern = material.Document.GetElement(material.CutForegroundPatternId) as FillPatternElement;
   if (null != cutForegroundPattern)
   {
      message.Append("\nCut Foreground Pattern: " + cutForegroundPattern.Name);
      message.Append(string.Format("\nCut Foreground Pattern Color: Red[{0}]; Green[{1}]; Blue[{2}]",
                      material.CutForegroundPatternColor.Red, material.CutForegroundPatternColor.Green, material.CutForegroundPatternColor.Blue));
   }

   //foreground surface pattern and pattern color of the material
   FillPatternElement surfaceForegroundPattern = material.Document.GetElement(material.SurfaceForegroundPatternId) as FillPatternElement;
   if (null != surfaceForegroundPattern)
   {
      message.Append("\nSurface Foreground Pattern: " + surfaceForegroundPattern.Name);
      message.Append(string.Format("\nSurface Foreground Pattern Color: Red[{0}]; Green[{1}]; Blue[{2}]",
                      material.SurfaceForegroundPatternColor.Red, material.SurfaceForegroundPatternColor.Green, material.SurfaceForegroundPatternColor.Blue));
   }

   //background cut pattern and pattern color of the material
   FillPatternElement cutBackgroundPattern = material.Document.GetElement(material.CutBackgroundPatternId) as FillPatternElement;
   if (null != cutBackgroundPattern)
   {
      message.Append("\nCut Background Pattern: " + cutBackgroundPattern.Name);
      message.Append(string.Format("\nCut Background Pattern Color: Red[{0}]; Green[{1}]; Blue[{2}]",
                      material.CutBackgroundPatternColor.Red, material.CutBackgroundPatternColor.Green, material.CutBackgroundPatternColor.Blue));
   }

   //background surface pattern and pattern color of the material
   FillPatternElement surfaceBackgroundPattern = material.Document.GetElement(material.SurfaceBackgroundPatternId) as FillPatternElement;
   if (null != surfaceBackgroundPattern)
   {
      message.Append("\nSurface Background Pattern: " + surfaceBackgroundPattern.Name);
      message.Append(string.Format("\nSurface Background Pattern Color: Red[{0}]; Green[{1}]; Blue[{2}]",
                      material.SurfaceBackgroundPatternColor.Red, material.SurfaceBackgroundPatternColor.Green, material.SurfaceBackgroundPatternColor.Blue));
   }

   //some shading property of the material
   int shininess = material.Shininess;
   message.Append("\nShininess: " + shininess);
   int smoothness = material.Smoothness;
   message.Append("\nSmoothness: " + smoothness);
   int transparency = material.Transparency;
   message.Append("\nTransparency: " + transparency);

   TaskDialog.Show("Revit", message.ToString());
}
CopyVB.NET
Private Sub GetMaterialInformation(material As Material)
    Dim message As New StringBuilder("Material : " & Convert.ToString(material.Name))
    'color of the material
    message.Append(String.Format(vbLf & "Color: Red[{0}]; Green[{1}]; Blue[{2}]", material.Color.Red, material.Color.Green, material.Color.Blue))

    'foreground cut pattern and pattern color of the material
    Dim cutForegroundPattern As FillPatternElement = TryCast(material.Document.GetElement(material.CutForegroundPatternId), FillPatternElement)
    If cutForegroundPattern IsNot Nothing Then
        message.Append(vbLf & "Cut Foreground Pattern: " + cutForegroundPattern.Name)
        message.Append(String.Format(vbLf & "Cut Foreground Pattern Color: Red[{0}]; Green[{1}]; Blue[{2}]", material.CutForegroundPatternColor.Red, material.CutForegroundPatternColor.Green, material.CutForegroundPatternColor.Blue))
    End If

    'foreground surface pattern and pattern color of the material
    Dim surfaceForegroundPattern As FillPatternElement = TryCast(material.Document.GetElement(material.SurfaceForegroundPatternId), FillPatternElement)
    If surfaceForegroundPattern IsNot Nothing Then
        message.Append(vbLf & "Surface Foreground Pattern: " + surfaceForegroundPattern.Name)
        message.Append(String.Format(vbLf & "Surface Foreground Pattern Color: Red[{0}]; Green[{1}]; Blue[{2}]", material.SurfaceForegroundPatternColor.Red, material.SurfaceForegroundPatternColor.Green, material.SurfaceForegroundPatternColor.Blue))
    End If

    'background cut pattern and pattern color of the material
    Dim cutBackgroundPattern As FillPatternElement = TryCast(material.Document.GetElement(material.CutBackgroundPatternId), FillPatternElement)
    If cutBackgroundPattern IsNot Nothing Then
        message.Append(vbLf & "Cut Background Pattern: " + cutBackgroundPattern.Name)
        message.Append(String.Format(vbLf & "Cut Background Pattern Color: Red[{0}]; Green[{1}]; Blue[{2}]", material.CutBackgroundPatternColor.Red, material.CutBackgroundPatternColor.Green, material.CutBackgroundPatternColor.Blue))
    End If

    'background surface pattern and pattern color of the material
    Dim surfaceBackgroundPattern As FillPatternElement = TryCast(material.Document.GetElement(material.SurfaceBackgroundPatternId), FillPatternElement)
    If surfaceBackgroundPattern IsNot Nothing Then
        message.Append(vbLf & "Surface Background Pattern: " + surfaceBackgroundPattern.Name)
        message.Append(String.Format(vbLf & "Surface Background Pattern Color: Red[{0}]; Green[{1}]; Blue[{2}]", material.SurfaceBackgroundPatternColor.Red, material.SurfaceBackgroundPatternColor.Green, material.SurfaceBackgroundPatternColor.Blue))
    End If

    'some shading property of the material
    Dim shininess As Integer = material.Shininess
    message.Append(vbLf & "Shininess: " & shininess)
    Dim smoothness As Integer = material.Smoothness
    message.Append(vbLf & "Smoothness: " & smoothness)
    Dim transparency As Integer = material.Transparency
    message.Append(vbLf & "Transparency: " & transparency)

    TaskDialog.Show("Revit", message.ToString())
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..Material

See Also

Material Members


Material Members

[image] [image]

Revit 2024 API
Material Members
Material Class Methods Properties See Also Send Feedback

The Material type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | ClearMaterialAspect | Removes an aspect from the material.
 | Create | Creates a new material.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates the material
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
 | IsMaterialOrValidDefault | Validates whether the specified element id is a material element.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
 | IsNameUnique | Validates whether the material name is unique in document.
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetMaterialAspectByPropertySet | Sets an aspect of the material to a shared property set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AppearanceAssetId | The ElementId of the AppearanceAssetElement.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Color | The color of the material.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CutBackgroundPatternColor | The color of the material cut background pattern.
Public property | CutBackgroundPatternId | The id of the FillPatternElement used as the background pattern of faces with this material in cut views.
Public property | CutForegroundPatternColor | The color of the material cut foreground pattern.
Public property | CutForegroundPatternId | The id of the FillPatternElement used as the foreground pattern of faces with this material in cut views.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MaterialCategory | The name of the material category, e.g. 'Wood'
Public property | MaterialClass | The name of the general material type, e.g. 'Wood.'
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Shininess | The shininess of the material.
Public property | Smoothness | The smoothness of the material.
Public property | StructuralAssetId | The ElementId of the structural PropertySetElement.
Public property | SurfaceBackgroundPatternColor | The color of the material surface background pattern.
Public property | SurfaceBackgroundPatternId | The id of the FillPatternElement used as the background pattern of faces with this material in normal views.
Public property | SurfaceForegroundPatternColor | The color of the material surface foreground pattern.
Public property | SurfaceForegroundPatternId | The id of the FillPatternElement used as the foreground pattern of faces with this material in normal views.
Public property | ThermalAssetId | The ElementId of the thermal PropertySetElement.
Public property | Transparency | The transparency of the material.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UseRenderAppearanceForShading | True to use the render appearance settings for shaded view appearance; false to use the material's color and transparency value for shaded view appearance.
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Material Class


Create Method

[image]

Revit 2024 API
Material..::..Create Method
Material Class Example See Also Send Feedback
Creates a new material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ElementId Create(
    Document document,
    string name
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    name As String _
) As ElementId
Visual C++
public:
static ElementId^ Create(
    Document^ document,
    String^ name
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which to create the material.
name
Type: System..::..String
The name of the new material.

Return Value

Identifier of the new material.

Examples

CopyC#
//Create the material
ElementId materialId = Material.Create(document, "My Material");
Material material = document.GetElement(materialId) as Material;

//Create a new property set that can be used by this material
StructuralAsset strucAsset = new StructuralAsset("My Property Set", StructuralAssetClass.Concrete);
strucAsset.Behavior = StructuralBehavior.Isotropic;
strucAsset.Density = 232.0;

//Assign the property set to the material.
PropertySetElement pse = PropertySetElement.Create(document, strucAsset);
material.SetMaterialAspectByPropertySet(MaterialAspect.Structural, pse.Id);
CopyVB.NET
'Create the material
Dim materialId As ElementId = Material.Create(document, "My Material")
Dim material__1 As Material = TryCast(document.GetElement(materialId), Material)

'Create a new property set that can be used by this material
Dim strucAsset As New StructuralAsset("My Property Set", StructuralAssetClass.Concrete)
strucAsset.Behavior = StructuralBehavior.Isotropic
strucAsset.Density = 232.0

'Assign the property set to the material.
Dim pse As PropertySetElement = PropertySetElement.Create(document, strucAsset)
material__1.SetMaterialAspectByPropertySet(MaterialAspect.Structural, pse.Id)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- The given value for name is already in use as a material element name.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Material Class


Duplicate Method

[image]

Revit 2024 API
Material..::..Duplicate Method
Material Class Example See Also Send Feedback
Duplicates the material

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Material Duplicate(
    string name
)
Visual Basic
Public Function Duplicate ( _
    name As String _
) As Material
Visual C++
public:
Material^ Duplicate(
    String^ name
)

Parameters

name
Type: System..::..String
Name of the new material - this name must be correctly structured for Revit use and not duplicate the name of another material in the document.

Return Value

The new material.

Remarks

If duplication fails for reasons unrelated to the name, nullNothingnullptra null reference (Nothing in Visual Basic) will be returned.

Examples

CopyC#
private bool DuplicateMaterial(Material material)
{
   bool duplicated = false;
   //try to duplicate a new instance of Material class using duplicate method
   //make sure the name of new material is unique in MaterailSet
   string newName = "new" + material.Name;
   Material myMaterial = material.Duplicate(newName);
   if (null == myMaterial)
   {
      TaskDialog.Show("Revit", "Failed to duplicate a material!");
   }
   else
   {
      duplicated = true;
   }

   return duplicated;
}
CopyVB.NET
Private Function DuplicateMaterial(material As Material) As Boolean
    Dim duplicated As Boolean = False
    'try to duplicate a new instance of Material class using duplicate method
    'make sure the name of new material is unique in MaterailSet
    Dim newName As String = "new" & Convert.ToString(material.Name)
    Dim myMaterial As Material = material.Duplicate(newName)
    If myMaterial Is Nothing Then
        TaskDialog.Show("Revit", "Failed to duplicate a material!")
    Else
        duplicated = True
    End If

    Return duplicated
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- The given value for name is already in use as a material element name.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Material Class


IsMaterialOrValidDefault Method

[image]

Revit 2024 API
Material..::..IsMaterialOrValidDefault Method
Material Class See Also Send Feedback
Validates whether the specified element id is a material element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static bool IsMaterialOrValidDefault(
    Element pElem,
    ElementId materialId
)
Visual Basic
Public Shared Function IsMaterialOrValidDefault ( _
    pElem As Element, _
    materialId As ElementId _
) As Boolean
Visual C++
public:
static bool IsMaterialOrValidDefault(
    Element^ pElem,
    ElementId^ materialId
)

Parameters

pElem
Type: Autodesk.Revit.DB..::..Element
An element which will be applied the material
materialId
Type: Autodesk.Revit.DB..::..ElementId
The element id to be checked.

Return Value

True if the element a material element or invalidElementId, which means take material from category, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Material Class


IsNameUnique Method

[image]

Revit 2024 API
Material..::..IsNameUnique Method
Material Class See Also Send Feedback
Validates whether the material name is unique in document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static bool IsNameUnique(
    Document aDocument,
    string name
)
Visual Basic
Public Shared Function IsNameUnique ( _
    aDocument As Document, _
    name As String _
) As Boolean
Visual C++
public:
static bool IsNameUnique(
    Document^ aDocument,
    String^ name
)

Parameters

aDocument
Type: Autodesk.Revit.DB..::..Document
The document in which the name is being tested for uniqueness.
name
Type: System..::..String
The name tested for uniqueness.

Return Value

Returns true if the name is unique, and false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Material Class


SetMaterialAspectByPropertySet Method

[image]

Revit 2024 API
Material..::..SetMaterialAspectByPropertySet Method
Material Class See Also Send Feedback
Sets an aspect of the material to a shared property set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetMaterialAspectByPropertySet(
    MaterialAspect aspect,
    ElementId propertySetId
)
Visual Basic
Public Sub SetMaterialAspectByPropertySet ( _
    aspect As MaterialAspect, _
    propertySetId As ElementId _
)
Visual C++
public:
void SetMaterialAspectByPropertySet(
    MaterialAspect aspect,
    ElementId^ propertySetId
)

Parameters

aspect
Type: Autodesk.Revit.DB..::..MaterialAspect
The material aspect.
propertySetId
Type: Autodesk.Revit.DB..::..ElementId
Identifier of a shared property set (an instance of PropertySetElement).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

Material Class


Material Properties

[image] [image]

Revit 2024 API
Material Properties
Material Class See Also Send Feedback

The Material type exposes the following members.

Properties

 | Name | Description
Public property | AppearanceAssetId | The ElementId of the AppearanceAssetElement.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Color | The color of the material.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CutBackgroundPatternColor | The color of the material cut background pattern.
Public property | CutBackgroundPatternId | The id of the FillPatternElement used as the background pattern of faces with this material in cut views.
Public property | CutForegroundPatternColor | The color of the material cut foreground pattern.
Public property | CutForegroundPatternId | The id of the FillPatternElement used as the foreground pattern of faces with this material in cut views.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MaterialCategory | The name of the material category, e.g. 'Wood'
Public property | MaterialClass | The name of the general material type, e.g. 'Wood.'
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Shininess | The shininess of the material.
Public property | Smoothness | The smoothness of the material.
Public property | StructuralAssetId | The ElementId of the structural PropertySetElement.
Public property | SurfaceBackgroundPatternColor | The color of the material surface background pattern.
Public property | SurfaceBackgroundPatternId | The id of the FillPatternElement used as the background pattern of faces with this material in normal views.
Public property | SurfaceForegroundPatternColor | The color of the material surface foreground pattern.
Public property | SurfaceForegroundPatternId | The id of the FillPatternElement used as the foreground pattern of faces with this material in normal views.
Public property | ThermalAssetId | The ElementId of the thermal PropertySetElement.
Public property | Transparency | The transparency of the material.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UseRenderAppearanceForShading | True to use the render appearance settings for shaded view appearance; false to use the material's color and transparency value for shaded view appearance.
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Material Class


Color Property

[image]

Revit 2024 API
Material..::..Color Property
Material Class See Also Send Feedback
The color of the material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Color Color { get; set; }
Visual Basic
Public Property Color As Color
    Get
    Set
Visual C++
public:
property Color^ Color {
    Color^ get ();
    void set (Color^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

Material Class


CutBackgroundPatternId Property

[image]

Revit 2024 API
Material..::..CutBackgroundPatternId Property
Material Class See Also Send Feedback
The id of the FillPatternElement used as the background pattern of faces with this material in cut views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public ElementId CutBackgroundPatternId { get; set; }
Visual Basic
Public Property CutBackgroundPatternId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ CutBackgroundPatternId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Remarks

The FillPattern used for a cut pattern must have a 'Drafting' target.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The element id must represent a valid FillPatternElement. -or- When setting this property: The FillPattern target must be a drafting pattern.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

Material Class


CutForegroundPatternColor Property

[image]

Revit 2024 API
Material..::..CutForegroundPatternColor Property
Material Class See Also Send Feedback
The color of the material cut foreground pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public Color CutForegroundPatternColor { get; set; }
Visual Basic
Public Property CutForegroundPatternColor As Color
    Get
    Set
Visual C++
public:
property Color^ CutForegroundPatternColor {
    Color^ get ();
    void set (Color^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

Material Class


CutForegroundPatternId Property

[image]

Revit 2024 API
Material..::..CutForegroundPatternId Property
Material Class See Also Send Feedback
The id of the FillPatternElement used as the foreground pattern of faces with this material in cut views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public ElementId CutForegroundPatternId { get; set; }
Visual Basic
Public Property CutForegroundPatternId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ CutForegroundPatternId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Remarks

The FillPattern used for a cut foreground pattern must have a 'Drafting' target.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The element id must represent a valid FillPatternElement. -or- When setting this property: The FillPattern target must be a drafting pattern.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

Material Class


MaterialCategory Property

[image]

Revit 2024 API
Material..::..MaterialCategory Property
Material Class See Also Send Feedback
The name of the material category, e.g. 'Wood'

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public string MaterialCategory { get; set; }
Visual Basic
Public Property MaterialCategory As String
    Get
    Set
Visual C++
public:
property String^ MaterialCategory {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

Material Class


MaterialClass Property

[image]

Revit 2024 API
Material..::..MaterialClass Property
Material Class See Also Send Feedback
The name of the general material type, e.g. 'Wood.'

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string MaterialClass { get; set; }
Visual Basic
Public Property MaterialClass As String
    Get
    Set
Visual C++
public:
property String^ MaterialClass {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

Material Class


Smoothness Property

[image]

Revit 2024 API
Material..::..Smoothness Property
Material Class See Also Send Feedback
The smoothness of the material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public int Smoothness { get; set; }
Visual Basic
Public Property Smoothness As Integer
    Get
    Set
Visual C++
public:
property int Smoothness {
    int get ();
    void set (int value);
}

Field Value

The value ranges from 0 to 100.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: values for shininess must be between 0 and 128

See Also

Material Class


StructuralAssetId Property

[image]

Revit 2024 API
Material..::..StructuralAssetId Property
Material Class See Also Send Feedback
The ElementId of the structural PropertySetElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElementId StructuralAssetId { get; set; }
Visual Basic
Public Property StructuralAssetId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ StructuralAssetId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

Material Class


SurfaceBackgroundPatternId Property

[image]

Revit 2024 API
Material..::..SurfaceBackgroundPatternId Property
Material Class See Also Send Feedback
The id of the FillPatternElement used as the background pattern of faces with this material in normal views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public ElementId SurfaceBackgroundPatternId { get; set; }
Visual Basic
Public Property SurfaceBackgroundPatternId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ SurfaceBackgroundPatternId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Remarks

The FillPattern used for a background pattern must have a 'Drafting' target.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The element id must represent a valid FillPatternElement. -or- When setting this property: The FillPattern target must be a drafting pattern.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

Material Class


ThermalAssetId Property

[image]

Revit 2024 API
Material..::..ThermalAssetId Property
Material Class See Also Send Feedback
The ElementId of the thermal PropertySetElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElementId ThermalAssetId { get; set; }
Visual Basic
Public Property ThermalAssetId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ ThermalAssetId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

Material Class


Transparency Property

[image]

Revit 2024 API
Material..::..Transparency Property
Material Class See Also Send Feedback
The transparency of the material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public int Transparency { get; set; }
Visual Basic
Public Property Transparency As Integer
    Get
    Set
Visual C++
public:
property int Transparency {
    int get ();
    void set (int value);
}

Field Value

The value ranges from 0 to 100.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: values for shininess must be between 0 and 128

See Also

Material Class


UseRenderAppearanceForShading Property

[image]

Revit 2024 API
Material..::..UseRenderAppearanceForShading Property
Material Class See Also Send Feedback
True to use the render appearance settings for shaded view appearance; false to use the material's color and transparency value for shaded view appearance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool UseRenderAppearanceForShading { get; set; }
Visual Basic
Public Property UseRenderAppearanceForShading As Boolean
    Get
    Set
Visual C++
public:
property bool UseRenderAppearanceForShading {
    bool get ();
    void set (bool value);
}

See Also

Material Class


MaterialFunctionAssignment Enumeration

[image]

Revit 2024 API
MaterialFunctionAssignment Enumeration
See Also Send Feedback
Used in class CompoundStructure to specify the function of a layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public enum MaterialFunctionAssignment
Visual Basic
Public Enumeration MaterialFunctionAssignment
Visual C++
public enum class MaterialFunctionAssignment

Members

Member name | Description
None | Priority = 0 This is deprecated and should not be used.
Structure | Priority = 1 (highest priority)
Substrate | Priority = 2
Insulation | Priority = 3
Finish1 | Priority = 4
Finish2 | Priority = 5
Membrane | A membrane layer must have thickness 0. It is not represented graphically.
StructuralDeck | Indicates layer is a structural deck.

Remarks

The function is used primarily to determine layer priority which affects how layers of distinct elements interact at a join. Typically, layers penetrate lower priority layers and merge with layers of the same priority.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


MaterialNode Class

[image]

Revit 2024 API
MaterialNode Class
Members See Also Send Feedback
This class represents a change of material during a model-exporting process.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class MaterialNode : RenderNode
Visual Basic
Public Class MaterialNode _
    Inherits RenderNode
Visual C++
public ref class MaterialNode : public RenderNode

Remarks

Output nodes following this node are to be assumed using the material. The material remains in effect until another material node is sent to the output.

See also: [!:Autodesk::Revit::DB::IExportContext::OnMaterial].

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..RenderNode
Autodesk.Revit.DB..::..MaterialNode

See Also

MaterialNode Members


MaterialNode Members

[image] [image]

Revit 2024 API
MaterialNode Members
MaterialNode Class Methods Properties See Also Send Feedback

The MaterialNode type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RenderNode.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAppearance | Appearance properties associated with the material.
Public method | GetAppearanceOverride | Returns appearance properties that override the preset appearance of the material.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Color | The color the material is being rendered at
Public property | Glossiness | The level of glossiness of the material
Public property | HasOverriddenAppearance | Identifies if the default rendering appearance the material has is being overridden.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode.)
Public property | MaterialId | The Id of the element assocated with this material in the model.
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode.)
Public property | Smoothness | The level of smoothness of the material.
Public property | ThumbnailFile | The path if a file that contains a thumbnail image of the material.
Public property | Transparency | The value of transparency the material is being rendered with

See Also

MaterialNode Class


MaterialNode Methods

[image] [image]

Revit 2024 API
MaterialNode Methods
MaterialNode Class See Also Send Feedback

The MaterialNode type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RenderNode.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAppearance | Appearance properties associated with the material.
Public method | GetAppearanceOverride | Returns appearance properties that override the preset appearance of the material.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MaterialNode Class


GetAppearance Method

[image]

Revit 2024 API
MaterialNode..::..GetAppearance Method
MaterialNode Class See Also Send Feedback
Appearance properties associated with the material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public Asset GetAppearance()
Visual Basic
Public Function GetAppearance As Asset
Visual C++
public:
Asset^ GetAppearance()

Return Value

An instance of a rendering material asset

Remarks

Properties and attributes of the material's appearance can be accessed using the standard interface of the Asset class.

The structure of the properties, including their types and names is proprietary and as such it is not always useful to anyone who is not familiar with the particular schema. Also, the structure is not standardized and may change over time, therefore it is not recommended relaying on any appearance property to be present.

See Also

MaterialNode Class


GetAppearanceOverride Method

[image]

Revit 2024 API
MaterialNode..::..GetAppearanceOverride Method
MaterialNode Class See Also Send Feedback
Returns appearance properties that override the preset appearance of the material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public Asset GetAppearanceOverride()
Visual Basic
Public Function GetAppearanceOverride As Asset
Visual C++
public:
Asset^ GetAppearanceOverride()

Return Value

An instance of a rendering material asset, of null if there is no override.

Remarks

The returned instance of an Asset is valid only if there is an overide, which happens if there are decals applied to the face that has the base material. In such cases the rendering engine takes the asset of the material and merges it with the decal, which results to this override asset. If there are no decals, this instance is null and the HasOverriddenAppearance returns False.

See Also

MaterialNode Class


MaterialNode Properties

[image] [image]

Revit 2024 API
MaterialNode Properties
MaterialNode Class See Also Send Feedback

The MaterialNode type exposes the following members.

Properties

 | Name | Description
Public property | Color | The color the material is being rendered at
Public property | Glossiness | The level of glossiness of the material
Public property | HasOverriddenAppearance | Identifies if the default rendering appearance the material has is being overridden.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode.)
Public property | MaterialId | The Id of the element assocated with this material in the model.
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode.)
Public property | Smoothness | The level of smoothness of the material.
Public property | ThumbnailFile | The path if a file that contains a thumbnail image of the material.
Public property | Transparency | The value of transparency the material is being rendered with

See Also

MaterialNode Class


HasOverriddenAppearance Property

[image]

Revit 2024 API
MaterialNode..::..HasOverriddenAppearance Property
MaterialNode Class See Also Send Feedback
Identifies if the default rendering appearance the material has is being overridden.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool HasOverriddenAppearance { get; }
Visual Basic
Public ReadOnly Property HasOverriddenAppearance As Boolean
    Get
Visual C++
public:
property bool HasOverriddenAppearance {
    bool get ();
}

See Also

MaterialNode Class


MaterialId Property

[image]

Revit 2024 API
MaterialNode..::..MaterialId Property
MaterialNode Class See Also Send Feedback
The Id of the element assocated with this material in the model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ElementId MaterialId { get; }
Visual Basic
Public ReadOnly Property MaterialId As ElementId
    Get
Visual C++
public:
property ElementId^ MaterialId {
    ElementId^ get ();
}

Remarks

It is possible that no specific material is applied to a face, in which case the default material is used, and this property returns an InvalidElementId.

See Also

MaterialNode Class


Smoothness Property

[image]

Revit 2024 API
MaterialNode..::..Smoothness Property
MaterialNode Class See Also Send Feedback
The level of smoothness of the material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public int Smoothness { get; }
Visual Basic
Public ReadOnly Property Smoothness As Integer
    Get
Visual C++
public:
property int Smoothness {
    int get ();
}

See Also

MaterialNode Class


ThumbnailFile Property

[image]

Revit 2024 API
MaterialNode..::..ThumbnailFile Property
MaterialNode Class See Also Send Feedback
The path if a file that contains a thumbnail image of the material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public string ThumbnailFile { get; }
Visual Basic
Public ReadOnly Property ThumbnailFile As String
    Get
Visual C++
public:
property String^ ThumbnailFile {
    String^ get ();
}

See Also

MaterialNode Class


Transparency Property

[image]

Revit 2024 API
MaterialNode..::..Transparency Property
MaterialNode Class See Also Send Feedback
The value of transparency the material is being rendered with

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public double Transparency { get; }
Visual Basic
Public ReadOnly Property Transparency As Double
    Get
Visual C++
public:
property double Transparency {
    double get ();
}

See Also

MaterialNode Class


MaterialPropertyPathType Enumeration

[image]

Revit 2024 API
MaterialPropertyPathType Enumeration
See Also Send Feedback
Enum class indicating kinds of paths which ExternalFileReferenceType.Material references can have.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Since: 2012

Syntax

C#
public enum MaterialPropertyPathType
Visual Basic
Public Enumeration MaterialPropertyPathType
Visual C++
public enum class MaterialPropertyPathType

Members

Member name | Description
General | General image, for various material types
Transparency | Transparency image, for generic materials
Cutouts | Cutouts image, for generic or metal materials
Bump | Bump pattern, for generic materials
FinishBumps | Finish bumps, pattern for various material types
ReliefPattern | Relief pattern, for various material types
Weathering | Weathering image, for concrete materials

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


MathComparisonUtils Members

[image] [image]

Revit 2024 API
MathComparisonUtils Members
MathComparisonUtils Class Methods See Also Send Feedback

The MathComparisonUtils type exposes the following members.

Methods

Name | Description
IsAlmostEqual | Checks if two doubles are almost equal, using the internal tolerance.
IsAlmostZero | Checks if value is almost zero, using the internal tolerance.
IsGreaterThan | Checks if value1 is strictly greater than value2, using the internal tolerance.
IsGreaterThanOrAlmostEqual | Checks if value1 is greater than or almost equal to value2, using the internal tolerance.
IsLessThan | Checks if value1 is strictly less than value2, using the internal tolerance.
IsLessThanOrAlmostEqual | Checks if value1 is less than or almost equal to value2, using the internal tolerance.

See Also

MathComparisonUtils Class


MathComparisonUtils Methods

[image] [image]

Revit 2024 API
MathComparisonUtils Methods
MathComparisonUtils Class See Also Send Feedback

The MathComparisonUtils type exposes the following members.

Methods

Name | Description
IsAlmostEqual | Checks if two doubles are almost equal, using the internal tolerance.
IsAlmostZero | Checks if value is almost zero, using the internal tolerance.
IsGreaterThan | Checks if value1 is strictly greater than value2, using the internal tolerance.
IsGreaterThanOrAlmostEqual | Checks if value1 is greater than or almost equal to value2, using the internal tolerance.
IsLessThan | Checks if value1 is strictly less than value2, using the internal tolerance.
IsLessThanOrAlmostEqual | Checks if value1 is less than or almost equal to value2, using the internal tolerance.

See Also

MathComparisonUtils Class


IsAlmostZero Method

[image]

Revit 2024 API
MathComparisonUtils..::..IsAlmostZero Method
MathComparisonUtils Class See Also Send Feedback
Checks if value is almost zero, using the internal tolerance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static bool IsAlmostZero(
    double value
)
Visual Basic
Public Shared Function IsAlmostZero ( _
    value As Double _
) As Boolean
Visual C++
public:
static bool IsAlmostZero(
    double value
)

Parameters

value
Type: System..::..Double
The value to check.

Return Value

True if value is almost zero, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for value is not finite

See Also

MathComparisonUtils Class


IsGreaterThan Method

[image]

Revit 2024 API
MathComparisonUtils..::..IsGreaterThan Method
MathComparisonUtils Class See Also Send Feedback
Checks if value1 is strictly greater than value2, using the internal tolerance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static bool IsGreaterThan(
    double value1,
    double value2
)
Visual Basic
Public Shared Function IsGreaterThan ( _
    value1 As Double, _
    value2 As Double _
) As Boolean
Visual C++
public:
static bool IsGreaterThan(
    double value1,
    double value2
)

Parameters

value1
Type: System..::..Double
The first value.
value2
Type: System..::..Double
The second value.

Return Value

True if value1 is strictly greater than value2, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for value1 is not finite -or- The given value for value2 is not finite

See Also

MathComparisonUtils Class


IsGreaterThanOrAlmostEqual Method

[image]

Revit 2024 API
MathComparisonUtils..::..IsGreaterThanOrAlmostEqual Method
MathComparisonUtils Class See Also Send Feedback
Checks if value1 is greater than or almost equal to value2, using the internal tolerance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static bool IsGreaterThanOrAlmostEqual(
    double value1,
    double value2
)
Visual Basic
Public Shared Function IsGreaterThanOrAlmostEqual ( _
    value1 As Double, _
    value2 As Double _
) As Boolean
Visual C++
public:
static bool IsGreaterThanOrAlmostEqual(
    double value1,
    double value2
)

Parameters

value1
Type: System..::..Double
The first value.
value2
Type: System..::..Double
The second value.

Return Value

True if value1 is greater than or almost equal to value2, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for value1 is not finite -or- The given value for value2 is not finite

See Also

MathComparisonUtils Class


IsLessThan Method

[image]

Revit 2024 API
MathComparisonUtils..::..IsLessThan Method
MathComparisonUtils Class See Also Send Feedback
Checks if value1 is strictly less than value2, using the internal tolerance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static bool IsLessThan(
    double value1,
    double value2
)
Visual Basic
Public Shared Function IsLessThan ( _
    value1 As Double, _
    value2 As Double _
) As Boolean
Visual C++
public:
static bool IsLessThan(
    double value1,
    double value2
)

Parameters

value1
Type: System..::..Double
The first value.
value2
Type: System..::..Double
The second value.

Return Value

True if value1 is strictly less than value2, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for value1 is not finite -or- The given value for value2 is not finite

See Also

MathComparisonUtils Class


IsLessThanOrAlmostEqual Method

[image]

Revit 2024 API
MathComparisonUtils..::..IsLessThanOrAlmostEqual Method
MathComparisonUtils Class See Also Send Feedback
Checks if value1 is less than or almost equal to value2, using the internal tolerance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static bool IsLessThanOrAlmostEqual(
    double value1,
    double value2
)
Visual Basic
Public Shared Function IsLessThanOrAlmostEqual ( _
    value1 As Double, _
    value2 As Double _
) As Boolean
Visual C++
public:
static bool IsLessThanOrAlmostEqual(
    double value1,
    double value2
)

Parameters

value1
Type: System..::..Double
The first value.
value2
Type: System..::..Double
The second value.

Return Value

True if value1 is less than or almost equal to value2, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for value1 is not finite -or- The given value for value2 is not finite

See Also

MathComparisonUtils Class


MEPAnalyticalConnection Class

[image]

Revit 2024 API
MEPAnalyticalConnection Class
Members See Also Send Feedback
Represents an analytical element that connects mechanical equipment to piping network.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public class MEPAnalyticalConnection : MEPCurve
Visual Basic
Public Class MEPAnalyticalConnection _
    Inherits MEPCurve
Visual C++
public ref class MEPAnalyticalConnection : public MEPCurve

Remarks

The analytical connection takes mechanical equipment into account of network flow/pressure analysis. The connection remains the same even if the mechanical equipment moves and rotates. It enables a fast establishment of piping network to analyze the flow and pressure, especially at the early stage of the design process.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB..::..MEPCurve
Autodesk.Revit.DB..::..MEPAnalyticalConnection

See Also

MEPAnalyticalConnection Members


MEPAnalyticalConnection Members

[image] [image]

Revit 2024 API
MEPAnalyticalConnection Members
MEPAnalyticalConnection Class Methods Properties See Also Send Feedback

The MEPAnalyticalConnection type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
 | CanSupportAnalyticalConnection | Checks if the connector can support the analytical connection.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create | Creates a new analytical connection between two open connectors.
 | CreateMultipleConnections | Creates new analytical connections between the equipment connector and the nearest point on the curves.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetFlow | Gets the flow value of this analytical connection.
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ConnectorManager | The connector manager of this MEP curve. (Inherited from MEPCurve.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Diameter | The diameter of the MEP curve. (Inherited from MEPCurve.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Height | The height of the MEP curve. (Inherited from MEPCurve.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | LevelOffset | The offset of the MEP curve. (Inherited from MEPCurve.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MEPSystem | The system of the MEP curve. (Inherited from MEPCurve.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ReferenceLevel | The reference level of the MEP curve. (Inherited from MEPCurve.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Width | The width of the MEP curve. (Inherited from MEPCurve.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

MEPAnalyticalConnection Class


MEPAnalyticalConnection Methods

[image] [image]

Revit 2024 API
MEPAnalyticalConnection Methods
MEPAnalyticalConnection Class See Also Send Feedback

The MEPAnalyticalConnection type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
 | CanSupportAnalyticalConnection | Checks if the connector can support the analytical connection.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create | Creates a new analytical connection between two open connectors.
 | CreateMultipleConnections | Creates new analytical connections between the equipment connector and the nearest point on the curves.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetFlow | Gets the flow value of this analytical connection.
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MEPAnalyticalConnection Class


CanSupportAnalyticalConnection Method

[image]

Revit 2024 API
MEPAnalyticalConnection..::..CanSupportAnalyticalConnection Method
MEPAnalyticalConnection Class See Also Send Feedback
Checks if the connector can support the analytical connection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public static bool CanSupportAnalyticalConnection(
    Connector connector
)
Visual Basic
Public Shared Function CanSupportAnalyticalConnection ( _
    connector As Connector _
) As Boolean
Visual C++
public:
static bool CanSupportAnalyticalConnection(
    Connector^ connector
)

Parameters

connector
Type: Autodesk.Revit.DB..::..Connector
The testing connector.

Return Value

True if the connector can support the network flow/pressure analysis, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

MEPAnalyticalConnection Class


Create Method

[image]

Revit 2024 API
MEPAnalyticalConnection..::..Create Method
MEPAnalyticalConnection Class See Also Send Feedback
Creates a new analytical connection between two open connectors.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public static MEPAnalyticalConnection Create(
    Document doc,
    ElementId typeId,
    Connector startConnector,
    Connector endConnector
)
Visual Basic
Public Shared Function Create ( _
    doc As Document, _
    typeId As ElementId, _
    startConnector As Connector, _
    endConnector As Connector _
) As MEPAnalyticalConnection
Visual C++
public:
static MEPAnalyticalConnection^ Create(
    Document^ doc,
    ElementId^ typeId,
    Connector^ startConnector,
    Connector^ endConnector
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The document where the new element is created.
typeId
Type: Autodesk.Revit.DB..::..ElementId
The type of new analytical connection.
startConnector
Type: Autodesk.Revit.DB..::..Connector
The open connector on the equipment side, whose level is inherited by the analytical connection.
endConnector
Type: Autodesk.Revit.DB..::..Connector
The open connector on the network.

Return Value

The newly created analytical connection element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Invalid connection type. -or- The connector does not support analytical connection.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

MEPAnalyticalConnection Class


CreateMultipleConnections Method

[image]

Revit 2024 API
MEPAnalyticalConnection..::..CreateMultipleConnections Method
MEPAnalyticalConnection Class See Also Send Feedback
Creates new analytical connections between the equipment connector and the nearest point on the curves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public static ISet<ElementId> CreateMultipleConnections(
    Document doc,
    ElementId typeId,
    IList<Connector> equipmentOpenConnectors,
    IList<ElementId> curveIdsToConnect
)
Visual Basic
Public Shared Function CreateMultipleConnections ( _
    doc As Document, _
    typeId As ElementId, _
    equipmentOpenConnectors As IList(Of Connector), _
    curveIdsToConnect As IList(Of ElementId) _
) As ISet(Of ElementId)
Visual C++
public:
static ISet<ElementId^>^ CreateMultipleConnections(
    Document^ doc,
    ElementId^ typeId,
    IList<Connector^>^ equipmentOpenConnectors,
    IList<ElementId^>^ curveIdsToConnect
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The document where the new elements are created.
typeId
Type: Autodesk.Revit.DB..::..ElementId
The type of new analytical connections.
equipmentOpenConnectors
Type: System.Collections.Generic..::..IList<(Of <(<' Connector >)>)>
The open equipment connectors to be analytically connected.
curveIdsToConnect
Type: System.Collections.Generic..::..IList<(Of <(<' ElementId >)>)>
The curves which the equipment is connected to.

Return Value

The new analytical connection elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Invalid connection type. -or- Not all connectors support the analytical connection. -or- No connector included. -or- Not all elements are valid curve ids. -or- No curve included.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

MEPAnalyticalConnection Class


GetFlow Method

[image]

Revit 2024 API
MEPAnalyticalConnection..::..GetFlow Method
MEPAnalyticalConnection Class See Also Send Feedback
Gets the flow value of this analytical connection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public double GetFlow()
Visual Basic
Public Function GetFlow As Double
Visual C++
public:
double GetFlow()

Return Value

The flow value.

Remarks

If the network flow is asynchronously calculated, this method would wait until the calculation is completed. This ensures the returned flow value is always up to date.

See Also

MEPAnalyticalConnection Class


MEPAnalyticalConnection Properties

[image] [image]

Revit 2024 API
MEPAnalyticalConnection Properties
MEPAnalyticalConnection Class See Also Send Feedback

The MEPAnalyticalConnection type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ConnectorManager | The connector manager of this MEP curve. (Inherited from MEPCurve.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Diameter | The diameter of the MEP curve. (Inherited from MEPCurve.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Height | The height of the MEP curve. (Inherited from MEPCurve.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | LevelOffset | The offset of the MEP curve. (Inherited from MEPCurve.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MEPSystem | The system of the MEP curve. (Inherited from MEPCurve.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ReferenceLevel | The reference level of the MEP curve. (Inherited from MEPCurve.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Width | The width of the MEP curve. (Inherited from MEPCurve.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

MEPAnalyticalConnection Class


Parameter Property

[image] [image]

Revit 2024 API
MEPAnalyticalConnection..::..Parameter Property
MEPAnalyticalConnection Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

MEPAnalyticalConnection Class
MEPAnalyticalConnection Members


MEPAnalyticalConnectionType Class

[image]

Revit 2024 API
MEPAnalyticalConnectionType Class
Members See Also Send Feedback
Represents an analytical connection type between mechanical equipment and piping network.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public class MEPAnalyticalConnectionType : ElementType
Visual Basic
Public Class MEPAnalyticalConnectionType _
    Inherits ElementType
Visual C++
public ref class MEPAnalyticalConnectionType : public ElementType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..MEPAnalyticalConnectionType

See Also

MEPAnalyticalConnectionType Members


MEPAnalyticalConnectionType Methods

[image] [image]

Revit 2024 API
MEPAnalyticalConnectionType Methods
MEPAnalyticalConnectionType Class See Also Send Feedback

The MEPAnalyticalConnectionType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create | Creates an analytical connection type element.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
 | FindTypeByName | Finds the analytical connection type by its name.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
 | IsNameUnused | Checks if this is an unused name.
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MEPAnalyticalConnectionType Class


Create Method

[image]

Revit 2024 API
MEPAnalyticalConnectionType..::..Create Method
MEPAnalyticalConnectionType Class See Also Send Feedback
Creates an analytical connection type element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public static MEPAnalyticalConnectionType Create(
    Document doc,
    string name
)
Visual Basic
Public Shared Function Create ( _
    doc As Document, _
    name As String _
) As MEPAnalyticalConnectionType
Visual C++
public:
static MEPAnalyticalConnectionType^ Create(
    Document^ doc,
    String^ name
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The document.
name
Type: System..::..String
The name of the analytical type to be created.

Return Value

The created analytical connection type element.

Remarks

The newly created type would have the default pressure loss being 0. Use ElementType.duplicate to copy from any existing type.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This name is already used by an existing analytical connection type in the document. -or- name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- name is an empty string.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

MEPAnalyticalConnectionType Class


FindTypeByName Method

[image]

Revit 2024 API
MEPAnalyticalConnectionType..::..FindTypeByName Method
MEPAnalyticalConnectionType Class See Also Send Feedback
Finds the analytical connection type by its name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public static ElementId FindTypeByName(
    Document doc,
    string name
)
Visual Basic
Public Shared Function FindTypeByName ( _
    doc As Document, _
    name As String _
) As ElementId
Visual C++
public:
static ElementId^ FindTypeByName(
    Document^ doc,
    String^ name
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The document where the analytical conneciton type is expected.
name
Type: System..::..String
The name of the expected analytical connection type.

Return Value

The element id of matched analytical connection type, otherwise invalidElementId.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | name is an empty string.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

MEPAnalyticalConnectionType Class


IsNameUnused Method

[image]

Revit 2024 API
MEPAnalyticalConnectionType..::..IsNameUnused Method
MEPAnalyticalConnectionType Class See Also Send Feedback
Checks if this is an unused name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public static bool IsNameUnused(
    Document doc,
    string name
)
Visual Basic
Public Shared Function IsNameUnused ( _
    doc As Document, _
    name As String _
) As Boolean
Visual C++
public:
static bool IsNameUnused(
    Document^ doc,
    String^ name
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The document.
name
Type: System..::..String
The name to be verified.

Return Value

True if not used by an existing analytical connection type in this document, false if used.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

MEPAnalyticalConnectionType Class


MEPAnalyticalConnectionType Properties

[image] [image]

Revit 2024 API
MEPAnalyticalConnectionType Properties
MEPAnalyticalConnectionType Class See Also Send Feedback

The MEPAnalyticalConnectionType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | PressureLoss | The pressure loss of this analytical connection type.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

MEPAnalyticalConnectionType Class


Parameter Property

[image] [image]

Revit 2024 API
MEPAnalyticalConnectionType..::..Parameter Property
MEPAnalyticalConnectionType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

MEPAnalyticalConnectionType Class
MEPAnalyticalConnectionType Members


PressureLoss Property

[image]

Revit 2024 API
MEPAnalyticalConnectionType..::..PressureLoss Property
MEPAnalyticalConnectionType Class See Also Send Feedback
The pressure loss of this analytical connection type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public double PressureLoss { get; set; }
Visual Basic
Public Property PressureLoss As Double
    Get
    Set
Visual C++
public:
property double PressureLoss {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for pressureLoss must be non-negative.

See Also

MEPAnalyticalConnectionType Class


MEPCalculationServerInfo Class

[image]

Revit 2024 API
MEPCalculationServerInfo Class
Members See Also Send Feedback
a struct to hold the information about a MEP calucation servers

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class MEPCalculationServerInfo : IDisposable
Visual Basic
Public Class MEPCalculationServerInfo _
    Implements IDisposable
Visual C++
public ref class MEPCalculationServerInfo : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..MEPCalculationServerInfo

See Also

MEPCalculationServerInfo Members


MEPCalculationServerInfo Members

[image] [image]

Revit 2024 API
MEPCalculationServerInfo Members
MEPCalculationServerInfo Class Constructors Methods Properties See Also Send Feedback

The MEPCalculationServerInfo type exposes the following members.

Constructors

 | Name | Description
Public method | MEPCalculationServerInfo()()()() | Constructs a new MEPCalculationServerInfo with default settings.
Public method | MEPCalculationServerInfo(IExternalServer) | Create a new MEPCalculationServerInfo by an external server.
Public method | MEPCalculationServerInfo(MEPCalculationServerInfo) | Constructs a new copy of the input MEPCalculationServerInfo object.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the MEPCalculationServerInfo
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMEPCalculationServerInfo | Gets a MEPCalculationServerInfo by family instance.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Description | The Description of the server.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
 | PipeUseDefinitionOnTypeGUID | The guid value ("3BF616F9-6B98-4A21-80FF-DA1120C8F6D6") of Use Definition On Type. It is not a server id, but a guid to tell if the loss method is "Use Definition On Type" or not. If the loss method is "Use Definition On Type", we use the loss method of the family type to calculate.
Public property | ServerId | The Id of the server.
Public property | ServerName | The Name of the server.

See Also

MEPCalculationServerInfo Class


MEPCalculationServerInfo Constructor

[image] [image]

Revit 2024 API
MEPCalculationServerInfo Constructor
MEPCalculationServerInfo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MEPCalculationServerInfo()()()() | Constructs a new MEPCalculationServerInfo with default settings.
Public method | MEPCalculationServerInfo(IExternalServer) | Create a new MEPCalculationServerInfo by an external server.
Public method | MEPCalculationServerInfo(MEPCalculationServerInfo) | Constructs a new copy of the input MEPCalculationServerInfo object.

See Also

MEPCalculationServerInfo Class
MEPCalculationServerInfo Members


MEPCalculationServerInfo Constructor

[image]

Revit 2024 API
MEPCalculationServerInfo Constructor
MEPCalculationServerInfo Class See Also Send Feedback
Constructs a new MEPCalculationServerInfo with default settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public MEPCalculationServerInfo()
Visual Basic
Public Sub New
Visual C++
public:
MEPCalculationServerInfo()

See Also

MEPCalculationServerInfo Class
MEPCalculationServerInfo Overload


MEPCalculationServerInfo Constructor (IExternalServer)

[image]

Revit 2024 API
MEPCalculationServerInfo Constructor (IExternalServer)
MEPCalculationServerInfo Class See Also Send Feedback
Create a new MEPCalculationServerInfo by an external server.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public MEPCalculationServerInfo(
    IExternalServer server
)
Visual Basic
Public Sub New ( _
    server As IExternalServer _
)
Visual C++
public:
MEPCalculationServerInfo(
    IExternalServer^ server
)

Parameters

server
Type: Autodesk.Revit.DB.ExternalService..::..IExternalServer
The external server.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

MEPCalculationServerInfo Class
MEPCalculationServerInfo Overload


MEPCalculationServerInfo Constructor (MEPCalculationServerInfo)

[image]

Revit 2024 API
MEPCalculationServerInfo Constructor (MEPCalculationServerInfo)
MEPCalculationServerInfo Class See Also Send Feedback
Constructs a new copy of the input MEPCalculationServerInfo object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public MEPCalculationServerInfo(
    MEPCalculationServerInfo other
)
Visual Basic
Public Sub New ( _
    other As MEPCalculationServerInfo _
)
Visual C++
public:
MEPCalculationServerInfo(
    MEPCalculationServerInfo^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..MEPCalculationServerInfo

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

MEPCalculationServerInfo Class
MEPCalculationServerInfo Overload


MEPCalculationServerInfo Methods

[image] [image]

Revit 2024 API
MEPCalculationServerInfo Methods
MEPCalculationServerInfo Class See Also Send Feedback

The MEPCalculationServerInfo type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMEPCalculationServerInfo | Gets a MEPCalculationServerInfo by family instance.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MEPCalculationServerInfo Class


GetMEPCalculationServerInfo Method

[image]

Revit 2024 API
MEPCalculationServerInfo..::..GetMEPCalculationServerInfo Method
MEPCalculationServerInfo Class See Also Send Feedback
Gets a MEPCalculationServerInfo by family instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static MEPCalculationServerInfo GetMEPCalculationServerInfo(
    FamilyInstance famInst
)
Visual Basic
Public Shared Function GetMEPCalculationServerInfo ( _
    famInst As FamilyInstance _
) As MEPCalculationServerInfo
Visual C++
public:
static MEPCalculationServerInfo^ GetMEPCalculationServerInfo(
    FamilyInstance^ famInst
)

Parameters

famInst
Type: Autodesk.Revit.DB..::..FamilyInstance
The family instance.

Return Value

The MEPCalculationServerInfo.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

MEPCalculationServerInfo Class


MEPCalculationServerInfo Properties

[image] [image]

Revit 2024 API
MEPCalculationServerInfo Properties
MEPCalculationServerInfo Class See Also Send Feedback

The MEPCalculationServerInfo type exposes the following members.

Properties

 | Name | Description
Public property | Description | The Description of the server.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
 | PipeUseDefinitionOnTypeGUID | The guid value ("3BF616F9-6B98-4A21-80FF-DA1120C8F6D6") of Use Definition On Type. It is not a server id, but a guid to tell if the loss method is "Use Definition On Type" or not. If the loss method is "Use Definition On Type", we use the loss method of the family type to calculate.
Public property | ServerId | The Id of the server.
Public property | ServerName | The Name of the server.

See Also

MEPCalculationServerInfo Class


Description Property

[image]

Revit 2024 API
MEPCalculationServerInfo..::..Description Property
MEPCalculationServerInfo Class See Also Send Feedback
The Description of the server.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

MEPCalculationServerInfo Class


IsValidObject Property

[image]

Revit 2024 API
MEPCalculationServerInfo..::..IsValidObject Property
MEPCalculationServerInfo Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

MEPCalculationServerInfo Class


PipeUseDefinitionOnTypeGUID Property

[image]

Revit 2024 API
MEPCalculationServerInfo..::..PipeUseDefinitionOnTypeGUID Property
MEPCalculationServerInfo Class See Also Send Feedback
The guid value ("3BF616F9-6B98-4A21-80FF-DA1120C8F6D6") of Use Definition On Type. It is not a server id, but a guid to tell if the loss method is "Use Definition On Type" or not. If the loss method is "Use Definition On Type", we use the loss method of the family type to calculate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static Guid PipeUseDefinitionOnTypeGUID { get; }
Visual Basic
Public Shared ReadOnly Property PipeUseDefinitionOnTypeGUID As Guid
    Get
Visual C++
public:
static property Guid PipeUseDefinitionOnTypeGUID {
    Guid get ();
}

See Also

MEPCalculationServerInfo Class


ServerId Property

[image]

Revit 2024 API
MEPCalculationServerInfo..::..ServerId Property
MEPCalculationServerInfo Class See Also Send Feedback
The Id of the server.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Guid ServerId { get; set; }
Visual Basic
Public Property ServerId As Guid
    Get
    Set
Visual C++
public:
property Guid ServerId {
    Guid get ();
    void set (Guid value);
}

See Also

MEPCalculationServerInfo Class


ServerName Property

[image]

Revit 2024 API
MEPCalculationServerInfo..::..ServerName Property
MEPCalculationServerInfo Class See Also Send Feedback
The Name of the server.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string ServerName { get; set; }
Visual Basic
Public Property ServerName As String
    Get
    Set
Visual C++
public:
property String^ ServerName {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

MEPCalculationServerInfo Class


MEPConnectorInfo Class

[image]

Revit 2024 API
MEPConnectorInfo Class
Members See Also Send Feedback
MEP connector information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public class MEPConnectorInfo : IDisposable
Visual Basic
Public Class MEPConnectorInfo _
    Implements IDisposable
Visual C++
public ref class MEPConnectorInfo : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..MEPConnectorInfo
Autodesk.Revit.DB..::..MEPFamilyConnectorInfo

See Also

MEPConnectorInfo Members


MEPConnectorInfo Members

[image] [image]

Revit 2024 API
MEPConnectorInfo Members
MEPConnectorInfo Class Methods Properties See Also Send Feedback

The MEPConnectorInfo type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the MEPConnectorInfo
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsPrimary | True if this is the primary connector.
Public property | IsSecondary | True if this is the secondary connector.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LinkedConnector | The linked connector or nullNothingnullptra null reference (Nothing in Visual Basic) if there is no linked connector

See Also

MEPConnectorInfo Class


Dispose Method

[image]

Revit 2024 API
MEPConnectorInfo..::..Dispose Method
MEPConnectorInfo Class See Also Send Feedback
Releases all resources used by the MEPConnectorInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

MEPConnectorInfo Class


MEPConnectorInfo Properties

[image] [image]

Revit 2024 API
MEPConnectorInfo Properties
MEPConnectorInfo Class See Also Send Feedback

The MEPConnectorInfo type exposes the following members.

Properties

 | Name | Description
Public property | IsPrimary | True if this is the primary connector.
Public property | IsSecondary | True if this is the secondary connector.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LinkedConnector | The linked connector or nullNothingnullptra null reference (Nothing in Visual Basic) if there is no linked connector

See Also

MEPConnectorInfo Class


IsSecondary Property

[image]

Revit 2024 API
MEPConnectorInfo..::..IsSecondary Property
MEPConnectorInfo Class See Also Send Feedback
True if this is the secondary connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool IsSecondary { get; }
Visual Basic
Public ReadOnly Property IsSecondary As Boolean
    Get
Visual C++
public:
property bool IsSecondary {
    bool get ();
}

See Also

MEPConnectorInfo Class


IsValidObject Property

[image]

Revit 2024 API
MEPConnectorInfo..::..IsValidObject Property
MEPConnectorInfo Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

MEPConnectorInfo Class


MEPCurve Class

[image]

Revit 2024 API
MEPCurve Class
Members See Also Send Feedback
A curve object for duct or pipe blend elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class MEPCurve : HostObject
Visual Basic
Public Class MEPCurve _
    Inherits HostObject
Visual C++
public ref class MEPCurve : public HostObject

Remarks

The curve object is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB..::..MEPCurve
Autodesk.Revit.DB.Electrical..::..CableTrayConduitBase
Autodesk.Revit.DB.Electrical..::..Wire
Autodesk.Revit.DB..::..InsulationLiningBase
Autodesk.Revit.DB.Mechanical..::..Duct
Autodesk.Revit.DB.Mechanical..::..FlexDuct
Autodesk.Revit.DB..::..MEPAnalyticalConnection
Autodesk.Revit.DB.Plumbing..::..FlexPipe
Autodesk.Revit.DB.Plumbing..::..Pipe

See Also

MEPCurve Members


MEPCurve Members

[image] [image]

Revit 2024 API
MEPCurve Members
MEPCurve Class Methods Properties See Also Send Feedback

The MEPCurve type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ConnectorManager | The connector manager of this MEP curve.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Diameter | The diameter of the MEP curve.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Height | The height of the MEP curve.
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | LevelOffset | The offset of the MEP curve.
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MEPSystem | The system of the MEP curve.
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ReferenceLevel | The reference level of the MEP curve.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Width | The width of the MEP curve.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

MEPCurve Class


MEPCurve Methods

[image] [image]

Revit 2024 API
MEPCurve Methods
MEPCurve Class See Also Send Feedback

The MEPCurve type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MEPCurve Class


ConnectorManager Property

[image]

Revit 2024 API
MEPCurve..::..ConnectorManager Property
MEPCurve Class See Also Send Feedback
The connector manager of this MEP curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ConnectorManager ConnectorManager { get; }
Visual Basic
Public ReadOnly Property ConnectorManager As ConnectorManager
    Get
Visual C++
public:
property ConnectorManager^ ConnectorManager {
    ConnectorManager^ get ();
}

See Also

MEPCurve Class


Height Property

[image]

Revit 2024 API
MEPCurve..::..Height Property
MEPCurve Class See Also Send Feedback
The height of the MEP curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double Height { get; }
Visual Basic
Public ReadOnly Property Height As Double
    Get
Visual C++
public:
property double Height {
    double get ();
}

Remarks

This property is used to retrieve the height of the MEP curve.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the MEP curve's Shape is not rectangular.

See Also

MEPCurve Class


MEPSystem Property

[image]

Revit 2024 API
MEPCurve..::..MEPSystem Property
MEPCurve Class See Also Send Feedback
The system of the MEP curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public MEPSystem MEPSystem { get; }
Visual Basic
Public ReadOnly Property MEPSystem As MEPSystem
    Get
Visual C++
public:
property MEPSystem^ MEPSystem {
    MEPSystem^ get ();
}

Remarks

Returns the system of this MEP curve. If the curve does not belong to any systems, the value will be nullNothingnullptra null reference (Nothing in Visual Basic). If the curve belongs to more than one system, the first available value is returned.

See Also

MEPCurve Class


Parameter Property

[image] [image]

Revit 2024 API
MEPCurve..::..Parameter Property
MEPCurve Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

MEPCurve Class
MEPCurve Members


ReferenceLevel Property

[image]

Revit 2024 API
MEPCurve..::..ReferenceLevel Property
MEPCurve Class See Also Send Feedback
The reference level of the MEP curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Level ReferenceLevel { get; set; }
Visual Basic
Public Property ReferenceLevel As Level
    Get
    Set
Visual C++
public:
property Level^ ReferenceLevel {
    Level^ get ();
    void set (Level^ value);
}

Remarks

This property is used to retrieve the reference level of the MEP curve. If the curve is not in a horizontal plane, this value will be the start point's reference level.

See Also

MEPCurve Class


Width Property

[image]

Revit 2024 API
MEPCurve..::..Width Property
MEPCurve Class See Also Send Feedback
The width of the MEP curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double Width { get; }
Visual Basic
Public ReadOnly Property Width As Double
    Get
Visual C++
public:
property double Width {
    double get ();
}

Remarks

This property is used to retrieve the width of the MEP curve.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the MEP curve's shape is not rectangular.

See Also

MEPCurve Class


MEPCurveType Class

[image]

Revit 2024 API
MEPCurveType Class
Members See Also Send Feedback
The base type class for MEP curves, such as ducts, pipes, cable trays and conduits.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class MEPCurveType : HostObjAttributes
Visual Basic
Public Class MEPCurveType _
    Inherits HostObjAttributes
Visual C++
public ref class MEPCurveType : public HostObjAttributes

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..HostObjAttributes
Autodesk.Revit.DB..::..MEPCurveType
Autodesk.Revit.DB.Electrical..::..CableTrayType
Autodesk.Revit.DB.Electrical..::..ConduitType
Autodesk.Revit.DB.Mechanical..::..DuctType
Autodesk.Revit.DB.Mechanical..::..FlexDuctType
Autodesk.Revit.DB.Plumbing..::..FlexPipeType
Autodesk.Revit.DB.Plumbing..::..PipeType

See Also

MEPCurveType Members


MEPCurveType Members

[image] [image]

Revit 2024 API
MEPCurveType Members
MEPCurveType Class Methods Properties See Also Send Feedback

The MEPCurveType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | Cross | The default cross fitting of the MEP curve type.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Elbow | The default elbow fitting of the MEP curve type.
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MultiShapeTransition | The default multi shape transition fitting of the MEP curve type.
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | PreferredJunctionType | The preferred junction type of the MEP curve type.
Public property | Roughness | The roughness of the MEP curve type. For PipeTypes, please use Segment::Roughness
Public property | RoutingPreferenceManager | The RoutingPreferenceManager for the MEPCurveType
Public property | Shape | The shape of the profile.
Public property | Tap | The default tap fitting of the MEP curve type.
Public property | Tee | The default tee fitting of the MEP curve type.
Public property | Transition | The default transition fitting of the MEP curve type.
Public property | Union | The default union fitting of the MEP curve type.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

MEPCurveType Class


MEPCurveType Methods

[image] [image]

Revit 2024 API
MEPCurveType Methods
MEPCurveType Class See Also Send Feedback

The MEPCurveType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MEPCurveType Class


MEPCurveType Properties

[image] [image]

Revit 2024 API
MEPCurveType Properties
MEPCurveType Class See Also Send Feedback

The MEPCurveType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | Cross | The default cross fitting of the MEP curve type.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Elbow | The default elbow fitting of the MEP curve type.
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MultiShapeTransition | The default multi shape transition fitting of the MEP curve type.
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | PreferredJunctionType | The preferred junction type of the MEP curve type.
Public property | Roughness | The roughness of the MEP curve type. For PipeTypes, please use Segment::Roughness
Public property | RoutingPreferenceManager | The RoutingPreferenceManager for the MEPCurveType
Public property | Shape | The shape of the profile.
Public property | Tap | The default tap fitting of the MEP curve type.
Public property | Tee | The default tee fitting of the MEP curve type.
Public property | Transition | The default transition fitting of the MEP curve type.
Public property | Union | The default union fitting of the MEP curve type.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

MEPCurveType Class


Cross Property

[image]

Revit 2024 API
MEPCurveType..::..Cross Property
MEPCurveType Class See Also Send Feedback
The default cross fitting of the MEP curve type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilySymbol Cross { get; set; }
Visual Basic
Public Property Cross As FamilySymbol
    Get
    Set
Visual C++
public:
property FamilySymbol^ Cross {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}

Remarks

This property is used to retrieve the default cross fitting of the MEP curve type, and can be nullNothingnullptra null reference (Nothing in Visual Basic) if there is no default value. Use RoutingPreferenceManager to set this property for PipeType MEPCurves.

See Also

MEPCurveType Class


Elbow Property

[image]

Revit 2024 API
MEPCurveType..::..Elbow Property
MEPCurveType Class See Also Send Feedback
The default elbow fitting of the MEP curve type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilySymbol Elbow { get; set; }
Visual Basic
Public Property Elbow As FamilySymbol
    Get
    Set
Visual C++
public:
property FamilySymbol^ Elbow {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}

Remarks

This property is used to retrieve the default elbow fitting of the MEP curve type, and can be nullNothingnullptra null reference (Nothing in Visual Basic) if there is no default value. Use RoutingPreferenceManager to set this property for PipeType MEPCurves.

See Also

MEPCurveType Class


MultiShapeTransition Property

[image]

Revit 2024 API
MEPCurveType..::..MultiShapeTransition Property
MEPCurveType Class See Also Send Feedback
The default multi shape transition fitting of the MEP curve type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilySymbol MultiShapeTransition { get; set; }
Visual Basic
Public Property MultiShapeTransition As FamilySymbol
    Get
    Set
Visual C++
public:
property FamilySymbol^ MultiShapeTransition {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}

Remarks

This property is used to retrieve the default multi shape transition fitting of the MEP curve type, and can be nullNothingnullptra null reference (Nothing in Visual Basic) if there is no default value. Use RoutingPreferenceManager to set this property for PipeType MEPCurves.

See Also

MEPCurveType Class


Parameter Property

[image] [image]

Revit 2024 API
MEPCurveType..::..Parameter Property
MEPCurveType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

MEPCurveType Class
MEPCurveType Members


PreferredJunctionType Property

[image]

Revit 2024 API
MEPCurveType..::..PreferredJunctionType Property
MEPCurveType Class See Also Send Feedback
The preferred junction type of the MEP curve type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public JunctionType PreferredJunctionType { get; set; }
Visual Basic
Public Property PreferredJunctionType As JunctionType
    Get
    Set
Visual C++
public:
property JunctionType PreferredJunctionType {
    JunctionType get ();
    void set (JunctionType value);
}

Remarks

Use RoutingPreferenceManager to set this property for PipeType MEPCurves.

See Also

MEPCurveType Class


RoutingPreferenceManager Property

[image]

Revit 2024 API
MEPCurveType..::..RoutingPreferenceManager Property
MEPCurveType Class See Also Send Feedback
The RoutingPreferenceManager for the MEPCurveType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public RoutingPreferenceManager RoutingPreferenceManager { get; }
Visual Basic
Public ReadOnly Property RoutingPreferenceManager As RoutingPreferenceManager
    Get
Visual C++
public:
property RoutingPreferenceManager^ RoutingPreferenceManager {
    RoutingPreferenceManager^ get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

MEPCurveType Class


Shape Property

[image]

Revit 2024 API
MEPCurveType..::..Shape Property
MEPCurveType Class See Also Send Feedback
The shape of the profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public ConnectorProfileType Shape { get; }
Visual Basic
Public ReadOnly Property Shape As ConnectorProfileType
    Get
Visual C++
public:
property ConnectorProfileType Shape {
    ConnectorProfileType get ();
}

See Also

MEPCurveType Class


Tap Property

[image]

Revit 2024 API
MEPCurveType..::..Tap Property
MEPCurveType Class See Also Send Feedback
The default tap fitting of the MEP curve type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilySymbol Tap { get; set; }
Visual Basic
Public Property Tap As FamilySymbol
    Get
    Set
Visual C++
public:
property FamilySymbol^ Tap {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}

Remarks

This property is used to retrieve the default tap fitting of the MEP curve type, and can be nullNothingnullptra null reference (Nothing in Visual Basic) if there is no default value. Use RoutingPreferenceManager to set this property for PipeType MEPCurves.

See Also

MEPCurveType Class


Tee Property

[image]

Revit 2024 API
MEPCurveType..::..Tee Property
MEPCurveType Class See Also Send Feedback
The default tee fitting of the MEP curve type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilySymbol Tee { get; set; }
Visual Basic
Public Property Tee As FamilySymbol
    Get
    Set
Visual C++
public:
property FamilySymbol^ Tee {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}

Remarks

This property is used to retrieve the default tee fitting of the MEP curve type, and can be nullNothingnullptra null reference (Nothing in Visual Basic) if there is no default value. Use RoutingPreferenceManager to set this property for PipeType MEPCurves.

See Also

MEPCurveType Class


Transition Property

[image]

Revit 2024 API
MEPCurveType..::..Transition Property
MEPCurveType Class See Also Send Feedback
The default transition fitting of the MEP curve type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilySymbol Transition { get; set; }
Visual Basic
Public Property Transition As FamilySymbol
    Get
    Set
Visual C++
public:
property FamilySymbol^ Transition {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}

Remarks

This property is used to retrieve the default transition fitting of the MEP curve type, and can be nullNothingnullptra null reference (Nothing in Visual Basic) if there is no default value. Use RoutingPreferenceManager to set this property for PipeType MEPCurves.

See Also

MEPCurveType Class


MEPFamilyConnectorInfo Class

[image]

Revit 2024 API
MEPFamilyConnectorInfo Class
Members See Also Send Feedback
MEP family connector information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public class MEPFamilyConnectorInfo : MEPConnectorInfo
Visual Basic
Public Class MEPFamilyConnectorInfo _
    Inherits MEPConnectorInfo
Visual C++
public ref class MEPFamilyConnectorInfo : public MEPConnectorInfo

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..MEPConnectorInfo
Autodesk.Revit.DB..::..MEPFamilyConnectorInfo

See Also

MEPFamilyConnectorInfo Members


MEPFamilyConnectorInfo Members

[image] [image]

Revit 2024 API
MEPFamilyConnectorInfo Members
MEPFamilyConnectorInfo Class Methods Properties See Also Send Feedback

The MEPFamilyConnectorInfo type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from MEPConnectorInfo.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAssociateFamilyParameterId | Gets the associate family parameter id of the specified connector parameter id.
Public method | GetConnectorParameterValue | Gets the parameter value of the specified connector parameter id.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsPrimary | True if this is the primary connector. (Inherited from MEPConnectorInfo.)
Public property | IsSecondary | True if this is the secondary connector. (Inherited from MEPConnectorInfo.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from MEPConnectorInfo.)
Public property | LinkedConnector | The linked connector or nullNothingnullptra null reference (Nothing in Visual Basic) if there is no linked connector (Inherited from MEPConnectorInfo.)

See Also

MEPFamilyConnectorInfo Class


MEPFamilyConnectorInfo Methods

[image] [image]

Revit 2024 API
MEPFamilyConnectorInfo Methods
MEPFamilyConnectorInfo Class See Also Send Feedback

The MEPFamilyConnectorInfo type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from MEPConnectorInfo.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAssociateFamilyParameterId | Gets the associate family parameter id of the specified connector parameter id.
Public method | GetConnectorParameterValue | Gets the parameter value of the specified connector parameter id.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MEPFamilyConnectorInfo Class


GetAssociateFamilyParameterId Method

[image]

Revit 2024 API
MEPFamilyConnectorInfo..::..GetAssociateFamilyParameterId Method
MEPFamilyConnectorInfo Class See Also Send Feedback
Gets the associate family parameter id of the specified connector parameter id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public ElementId GetAssociateFamilyParameterId(
    ElementId connectorParameterId
)
Visual Basic
Public Function GetAssociateFamilyParameterId ( _
    connectorParameterId As ElementId _
) As ElementId
Visual C++
public:
ElementId^ GetAssociateFamilyParameterId(
    ElementId^ connectorParameterId
)

Parameters

connectorParameterId
Type: Autodesk.Revit.DB..::..ElementId
connectorParameterId is defined in the family connector element.

Return Value

Returns valid ElementId if the connectorParameterId associates to one family parameter; otherwise returns invalid ElementId.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

MEPFamilyConnectorInfo Class


GetConnectorParameterValue Method

[image]

Revit 2024 API
MEPFamilyConnectorInfo..::..GetConnectorParameterValue Method
MEPFamilyConnectorInfo Class See Also Send Feedback
Gets the parameter value of the specified connector parameter id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public ParameterValue GetConnectorParameterValue(
    ElementId connectorParameterId
)
Visual Basic
Public Function GetConnectorParameterValue ( _
    connectorParameterId As ElementId _
) As ParameterValue
Visual C++
public:
ParameterValue^ GetConnectorParameterValue(
    ElementId^ connectorParameterId
)

Parameters

connectorParameterId
Type: Autodesk.Revit.DB..::..ElementId
connectorParameterId is defined in the family connector element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

MEPFamilyConnectorInfo Class


MEPFamilyConnectorInfo Properties

[image] [image]

Revit 2024 API
MEPFamilyConnectorInfo Properties
MEPFamilyConnectorInfo Class See Also Send Feedback

The MEPFamilyConnectorInfo type exposes the following members.

Properties

 | Name | Description
Public property | IsPrimary | True if this is the primary connector. (Inherited from MEPConnectorInfo.)
Public property | IsSecondary | True if this is the secondary connector. (Inherited from MEPConnectorInfo.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from MEPConnectorInfo.)
Public property | LinkedConnector | The linked connector or nullNothingnullptra null reference (Nothing in Visual Basic) if there is no linked connector (Inherited from MEPConnectorInfo.)

See Also

MEPFamilyConnectorInfo Class


MEPModel Members

[image] [image]

Revit 2024 API
MEPModel Members
MEPModel Class Methods Properties See Also Send Feedback

The MEPModel type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAssignedElectricalSystems | Retrieves the electrical systems this electrical panel currently is assigned to.
Public method | GetElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConnectorManager | Retrieves the Connector Manager from this MEPModel.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

MEPModel Class


MEPModel Methods

[image] [image]

Revit 2024 API
MEPModel Methods
MEPModel Class See Also Send Feedback

The MEPModel type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAssignedElectricalSystems | Retrieves the electrical systems this electrical panel currently is assigned to.
Public method | GetElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MEPModel Class


MEPModel Properties

[image] [image]

Revit 2024 API
MEPModel Properties
MEPModel Class See Also Send Feedback

The MEPModel type exposes the following members.

Properties

 | Name | Description
Public property | ConnectorManager | Retrieves the Connector Manager from this MEPModel.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

MEPModel Class


IsValidObject Property

[image]

Revit 2024 API
MEPModel..::..IsValidObject Property
MEPModel Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

MEPModel Class


MEPSize Class

[image]

Revit 2024 API
MEPSize Class
Members See Also Send Feedback
Stores the basic size information for an MEP duct, pipe, cable tray, or conduit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public class MEPSize : IDisposable
Visual Basic
Public Class MEPSize _
    Implements IDisposable
Visual C++
public ref class MEPSize : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..MEPSize

See Also

MEPSize Members


MEPSize Members

[image] [image]

Revit 2024 API
MEPSize Members
MEPSize Class Constructors Methods Properties See Also Send Feedback

The MEPSize type exposes the following members.

Constructors

 | Name | Description
Public method | MEPSize | Constructs an object that stores the basic size information for MEP duct, pipe, cable tray and conduit.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the MEPSize
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | InnerDiameter | Inner diameter
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | NominalDiameter | Nominal diameter
Public property | OuterDiameter | Outer diameter
Public property | UsedInSizeLists | Whether it is used in size lists.
Public property | UsedInSizing | Whether is used in sizing.

See Also

MEPSize Class


MEPSize Constructor

[image]

Revit 2024 API
MEPSize Constructor
MEPSize Class See Also Send Feedback
Constructs an object that stores the basic size information for MEP duct, pipe, cable tray and conduit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public MEPSize(
    double nominalDiameter,
    double innerDiameter,
    double outerDiameter,
    bool usedInSizeLists,
    bool usedInSizing
)
Visual Basic
Public Sub New ( _
    nominalDiameter As Double, _
    innerDiameter As Double, _
    outerDiameter As Double, _
    usedInSizeLists As Boolean, _
    usedInSizing As Boolean _
)
Visual C++
public:
MEPSize(
    double nominalDiameter,
    double innerDiameter,
    double outerDiameter,
    bool usedInSizeLists,
    bool usedInSizing
)

Parameters

nominalDiameter
Type: System..::..Double
Nominal diameter. The value should be a valid, positive Revit length.
innerDiameter
Type: System..::..Double
Inner diameter. The value should be a valid, positive Revit length.
outerDiameter
Type: System..::..Double
Outer diameter. The value should be a valid, positive Revit length.
usedInSizeLists
Type: System..::..Boolean
Whether it is used in size lists.
usedInSizing
Type: System..::..Boolean
Whether is used in sizing.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given value for nominalDiameter must be greater than 0 and no more than 30000 feet. -or- The given value for innerDiameter must be greater than 0 and no more than 30000 feet. -or- The given value for outerDiameter must be greater than 0 and no more than 30000 feet.

See Also

MEPSize Class


Dispose Method

[image]

Revit 2024 API
MEPSize..::..Dispose Method
MEPSize Class See Also Send Feedback
Releases all resources used by the MEPSize

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

MEPSize Class


InnerDiameter Property

[image]

Revit 2024 API
MEPSize..::..InnerDiameter Property
MEPSize Class See Also Send Feedback
Inner diameter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public double InnerDiameter { get; }
Visual Basic
Public ReadOnly Property InnerDiameter As Double
    Get
Visual C++
public:
property double InnerDiameter {
    double get ();
}

See Also

MEPSize Class


NominalDiameter Property

[image]

Revit 2024 API
MEPSize..::..NominalDiameter Property
MEPSize Class See Also Send Feedback
Nominal diameter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public double NominalDiameter { get; }
Visual Basic
Public ReadOnly Property NominalDiameter As Double
    Get
Visual C++
public:
property double NominalDiameter {
    double get ();
}

See Also

MEPSize Class


UsedInSizing Property

[image]

Revit 2024 API
MEPSize..::..UsedInSizing Property
MEPSize Class See Also Send Feedback
Whether is used in sizing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public bool UsedInSizing { get; }
Visual Basic
Public ReadOnly Property UsedInSizing As Boolean
    Get
Visual C++
public:
property bool UsedInSizing {
    bool get ();
}

See Also

MEPSize Class


MEPSupportUtils Class

[image]

Revit 2024 API
MEPSupportUtils Class
Members See Also Send Feedback
General utility methods for the Autodesk Revit MEP Supporting components.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static class MEPSupportUtils
Visual Basic
Public NotInheritable Class MEPSupportUtils
Visual C++
public ref class MEPSupportUtils abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..MEPSupportUtils

See Also

MEPSupportUtils Members


MEPSupportUtils Members

[image] [image]

Revit 2024 API
MEPSupportUtils Members
MEPSupportUtils Class Methods See Also Send Feedback

The MEPSupportUtils type exposes the following members.

Methods

Name | Description
CreateDuctworkStiffener | Create family based stiffener on the specified fabrication ductwork.

See Also

MEPSupportUtils Class


MEPSupportUtils Methods

[image] [image]

Revit 2024 API
MEPSupportUtils Methods
MEPSupportUtils Class See Also Send Feedback

The MEPSupportUtils type exposes the following members.

Methods

Name | Description
CreateDuctworkStiffener | Create family based stiffener on the specified fabrication ductwork.

See Also

MEPSupportUtils Class


CreateDuctworkStiffener Method

[image]

Revit 2024 API
MEPSupportUtils..::..CreateDuctworkStiffener Method
MEPSupportUtils Class See Also Send Feedback
Create family based stiffener on the specified fabrication ductwork.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static FamilyInstance CreateDuctworkStiffener(
    Document document,
    ElementId familySymbolId,
    ElementId hostId,
    double distanceFromHostEnd
)
Visual Basic
Public Shared Function CreateDuctworkStiffener ( _
    document As Document, _
    familySymbolId As ElementId, _
    hostId As ElementId, _
    distanceFromHostEnd As Double _
) As FamilyInstance
Visual C++
public:
static FamilyInstance^ CreateDuctworkStiffener(
    Document^ document,
    ElementId^ familySymbolId,
    ElementId^ hostId,
    double distanceFromHostEnd
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
familySymbolId
Type: Autodesk.Revit.DB..::..ElementId
The id of a stiffener FamilySymbol.
hostId
Type: Autodesk.Revit.DB..::..ElementId
The id of the host ductwork.
distanceFromHostEnd
Type: System..::..Double
The distance from the host primary end to place the hosted instance. Units are in feet (ft).

Return Value

The new stiffener family instance.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- familySymbolId is not a valid Element identifier. -or- hostId is not a valid Element identifier. -or- Invalid familySymbolId for stiffeners. -or- Host is not a straight ductwork.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The distance from host primary end is out of range.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The profiles of family symbol and host are mismatch.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.
Autodesk.Revit.Exceptions..::..RegenerationFailedException | Failed to create stiffener due to document regenerate error.

See Also

MEPSupportUtils Class


MEPSystem Class

[image]

Revit 2024 API
MEPSystem Class
Members See Also Send Feedback
A system in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class MEPSystem : Element
Visual Basic
Public Class MEPSystem _
    Inherits Element
Visual C++
public ref class MEPSystem : public Element

Remarks

This is the base class for electrical, mechanical and piping systems, available only in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..MEPSystem
Autodesk.Revit.DB.Electrical..::..ElectricalSystem
Autodesk.Revit.DB.Mechanical..::..MechanicalSystem
Autodesk.Revit.DB.Plumbing..::..PipingSystem

See Also

MEPSystem Members


MEPSystem Methods

[image] [image]

Revit 2024 API
MEPSystem Methods
MEPSystem Class See Also Send Feedback

The MEPSystem type exposes the following members.

Methods

 | Name | Description
Public method | Add | Add elements into the system and connect them with the system using given connectors.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | DivideSystem | Divide the phyisical networks in the system and create a new system for each network.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetCriticalPathSectionNumbers | Obtains a list of the critical path section numbers.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPhysicalNetworksNumber | Get the physical networks number in the system.
Public method | GetSectionByIndex | Get the section from the index.
Public method | GetSectionByNumber | Get the Section from section number
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSystemDividable | Checks if the system is dividable. The system is dividable if there is more than one physical network in the system. Currently, only HVAC and piping systems support dividing.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | Remove(ConnectorSet) | Removes connectors from system.
Public method | Remove(ICollection<(Of <<'(ElementId>)>>)) | Remove elements from system.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MEPSystem Class


DivideSystem Method

[image]

Revit 2024 API
MEPSystem..::..DivideSystem Method
MEPSystem Class See Also Send Feedback
Divide the phyisical networks in the system and create a new system for each network.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ICollection<ElementId> DivideSystem(
    Document ADoc
)
Visual Basic
Public Function DivideSystem ( _
    ADoc As Document _
) As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ DivideSystem(
    Document^ ADoc
)

Parameters

ADoc
Type: Autodesk.Revit.DB..::..Document
The document.

Return Value

The id of new created systems.

Remarks

This function only works for Hvac and Piping system.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The system is not dividable.

See Also

MEPSystem Class


GetCriticalPathSectionNumbers Method

[image]

Revit 2024 API
MEPSystem..::..GetCriticalPathSectionNumbers Method
MEPSystem Class See Also Send Feedback
Obtains a list of the critical path section numbers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public IList<int> GetCriticalPathSectionNumbers()
Visual Basic
Public Function GetCriticalPathSectionNumbers As IList(Of Integer)
Visual C++
public:
IList<int>^ GetCriticalPathSectionNumbers()

Return Value

The section numbers.

Remarks

The section numbers are returned in order in the direction of flow.

See Also

MEPSystem Class


GetPhysicalNetworksNumber Method

[image]

Revit 2024 API
MEPSystem..::..GetPhysicalNetworksNumber Method
MEPSystem Class See Also Send Feedback
Get the physical networks number in the system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public int GetPhysicalNetworksNumber()
Visual Basic
Public Function GetPhysicalNetworksNumber As Integer
Visual C++
public:
int GetPhysicalNetworksNumber()

Return Value

The number of physical networks.

See Also

MEPSystem Class


GetSectionByNumber Method

[image]

Revit 2024 API
MEPSystem..::..GetSectionByNumber Method
MEPSystem Class See Also Send Feedback
Get the Section from section number

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public MEPSection GetSectionByNumber(
    int sectionNumber
)
Visual Basic
Public Function GetSectionByNumber ( _
    sectionNumber As Integer _
) As MEPSection
Visual C++
public:
MEPSection^ GetSectionByNumber(
    int sectionNumber
)

Parameters

sectionNumber
Type: System..::..Int32
The Section number.

Return Value

The section. nullNothingnullptra null reference (Nothing in Visual Basic) if the no section exists for the input section number.

See Also

MEPSystem Class


IsSystemDividable Method

[image]

Revit 2024 API
MEPSystem..::..IsSystemDividable Method
MEPSystem Class See Also Send Feedback
Checks if the system is dividable. The system is dividable if there is more than one physical network in the system. Currently, only HVAC and piping systems support dividing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsSystemDividable()
Visual Basic
Public Function IsSystemDividable As Boolean
Visual C++
public:
bool IsSystemDividable()

Return Value

True if the system can be divided.

See Also

MEPSystem Class


Remove Method

[image] [image]

Revit 2024 API
MEPSystem..::..Remove Method
MEPSystem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Remove(ConnectorSet) | Removes connectors from system.
Public method | Remove(ICollection<(Of <<'(ElementId>)>>)) | Remove elements from system.

See Also

MEPSystem Class
MEPSystem Members


Remove Method (ConnectorSet)

[image]

Revit 2024 API
MEPSystem..::..Remove Method (ConnectorSet)
MEPSystem Class See Also Send Feedback
Removes connectors from system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Remove(
    ConnectorSet connectors
)
Visual Basic
Public Sub Remove ( _
    connectors As ConnectorSet _
)
Visual C++
public:
void Remove(
    ConnectorSet^ connectors
)

Parameters

connectors
Type: Autodesk.Revit.DB..::..ConnectorSet
The connectors to be removed from the system.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument elements is nullNothingnullptra null reference (Nothing in Visual Basic), or any element in that collection is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when some of the connectors can't be removed, or when trying to remove all connectors from the system.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the operation failed.

See Also

MEPSystem Class
Remove Overload


Remove Method (ICollection(ElementId))

[image]

Revit 2024 API
MEPSystem..::..Remove Method (ICollection<(Of <(<'ElementId>)>)>)
MEPSystem Class See Also Send Feedback
Remove elements from system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Remove(
    ICollection<ElementId> elementIds
)
Visual Basic
Public Overridable Sub Remove ( _
    elementIds As ICollection(Of ElementId) _
)
Visual C++
public:
virtual void Remove(
    ICollection<ElementId^>^ elementIds
)

Parameters

elementIds
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
The elements to be removed from the system.

Remarks

It is forbidden to remove all terminal elements from system. Terminal elements will be removed from the system automatically after removing this system from document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument elements is nullNothingnullptra null reference (Nothing in Visual Basic), or any element in that collection is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when some of the elements can't be removed, or when trying to remove all elements from the system. The element which connect to the base equipment can't be removed,
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the operation failed.

See Also

MEPSystem Class
Remove Overload


MEPSystem Properties

[image] [image]

Revit 2024 API
MEPSystem Properties
MEPSystem Class See Also Send Feedback

The MEPSystem type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BaseEquipment | The base panel or equipment of the system.
Public property | BaseEquipmentConnector | The connector within base equipment which is used to connect with system.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ConnectorManager | Connector manager of the system.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Elements | Terminal elements in the system.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | HasDesignParts | Indicates if the system has one or more design parts.
Public property | HasFabricationParts | Indicates if the system has one or more fabrication parts.
Public property | HasPlaceholders | Indicates if the system has one or more placeholders.
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsEmpty | Indicates if the system is empty or not.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsMultipleNetwork | Indicates if the system is well connected or not. The flag will enable the "Divide System" button.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValid | Indicates if the system is valid or not. atom AtomValidateSystem default false
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | PressureLossOfCriticalPath | The total pressure loss of the sections in critical path.
Public property | SectionsCount | The number of sections.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

MEPSystem Class


BaseEquipment Property

[image]

Revit 2024 API
MEPSystem..::..BaseEquipment Property
MEPSystem Class See Also Send Feedback
The base panel or equipment of the system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyInstance BaseEquipment { get; }
Visual Basic
Public ReadOnly Property BaseEquipment As FamilyInstance
    Get
Visual C++
public:
property FamilyInstance^ BaseEquipment {
    FamilyInstance^ get ();
}

See Also

MEPSystem Class


BaseEquipmentConnector Property

[image]

Revit 2024 API
MEPSystem..::..BaseEquipmentConnector Property
MEPSystem Class See Also Send Feedback
The connector within base equipment which is used to connect with system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Connector BaseEquipmentConnector { get; }
Visual Basic
Public ReadOnly Property BaseEquipmentConnector As Connector
    Get
Visual C++
public:
property Connector^ BaseEquipmentConnector {
    Connector^ get ();
}

Return Value

Returns the connector which connects with the system within base equipment if base equipment has been assigned to system, otherwise returns nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

MEPSystem Class


ConnectorManager Property

[image]

Revit 2024 API
MEPSystem..::..ConnectorManager Property
MEPSystem Class See Also Send Feedback
Connector manager of the system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ConnectorManager ConnectorManager { get; }
Visual Basic
Public ReadOnly Property ConnectorManager As ConnectorManager
    Get
Visual C++
public:
property ConnectorManager^ ConnectorManager {
    ConnectorManager^ get ();
}

Remarks

The connector manager includes connectors which are used to connect with terminal elements and base equipment.

See Also

MEPSystem Class


Elements Property

[image]

Revit 2024 API
MEPSystem..::..Elements Property
MEPSystem Class See Also Send Feedback
Terminal elements in the system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElementSet Elements { get; }
Visual Basic
Public ReadOnly Property Elements As ElementSet
    Get
Visual C++
public:
property ElementSet^ Elements {
    ElementSet^ get ();
}

Remarks

The return value is a read only collection and doesn't include the base equipment or panel.

See Also

MEPSystem Class


HasDesignParts Property

[image]

Revit 2024 API
MEPSystem..::..HasDesignParts Property
MEPSystem Class See Also Send Feedback
Indicates if the system has one or more design parts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool HasDesignParts { get; }
Visual Basic
Public ReadOnly Property HasDesignParts As Boolean
    Get
Visual C++
public:
property bool HasDesignParts {
    bool get ();
}

See Also

MEPSystem Class


HasFabricationParts Property

[image]

Revit 2024 API
MEPSystem..::..HasFabricationParts Property
MEPSystem Class See Also Send Feedback
Indicates if the system has one or more fabrication parts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool HasFabricationParts { get; }
Visual Basic
Public ReadOnly Property HasFabricationParts As Boolean
    Get
Visual C++
public:
property bool HasFabricationParts {
    bool get ();
}

See Also

MEPSystem Class


IsEmpty Property

[image]

Revit 2024 API
MEPSystem..::..IsEmpty Property
MEPSystem Class See Also Send Feedback
Indicates if the system is empty or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool IsEmpty { get; }
Visual Basic
Public ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
property bool IsEmpty {
    bool get ();
}

Remarks

returns true if the system doesn't contain any components

See Also

MEPSystem Class


IsValid Property

[image]

Revit 2024 API
MEPSystem..::..IsValid Property
MEPSystem Class See Also Send Feedback
Indicates if the system is valid or not. atom AtomValidateSystem default false

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool IsValid { get; }
Visual Basic
Public ReadOnly Property IsValid As Boolean
    Get
Visual C++
public:
property bool IsValid {
    bool get ();
}

See Also

MEPSystem Class


SectionsCount Property

[image]

Revit 2024 API
MEPSystem..::..SectionsCount Property
MEPSystem Class See Also Send Feedback
The number of sections.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public int SectionsCount { get; }
Visual Basic
Public ReadOnly Property SectionsCount As Integer
    Get
Visual C++
public:
property int SectionsCount {
    int get ();
}

See Also

MEPSystem Class


MEPSystemClassification Enumeration

[image]

Revit 2024 API
MEPSystemClassification Enumeration
See Also Send Feedback
This enumeration is used to classify MEP connectors and systems and drives certain behavior for a particular system type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public enum MEPSystemClassification
Visual Basic
Public Enumeration MEPSystemClassification
Visual C++
public enum class MEPSystemClassification

Members

Member name | Description
UndefinedSystemClassification | A system classification not yet defined
SupplyAir | A supply air duct system
ReturnAir | A return air duct system
ExhaustAir | Obsolete classification not used anymore
OtherAir | An user classified air duct system
DataCircuit | An electrical data circuit
PowerCircuit | An electrical circuit
SupplyHydronic | A hydronic supply piping system
ReturnHydronic | A hydronic return piping system
Telephone | An electrical circuit classified as telephone
Security | An electrical security circuit
FireAlarm | An electrical fire alarm circuit
NurseCall | An electrical circuit classified as nurse call
Controls | An electrical circuit classified as controls
Communication | An electrical circuit classified as communication
CondensateDrain | Reserved for future use
Sanitary | A sanitary piping system
Vent | A piping ventilation system
Storm | Reserved for future use
DomesticHotWater | A hot water piping system
DomesticColdWater | A cold water piping system
Recirculation | Reserved for future use
OtherPipe | An user classified piping system
FireProtectWet | A wet fire protection system
FireProtectDry | A dry fire protection system
FireProtectPreaction | A preaction fire protection system
FireProtectOther | A user defined fire protection system
SwitchTopology | An electrical switch system
Fitting | Reserved for application usage, used for UI filtering in Family Editor
Global | Reserved for application usage, used for UI filtering in Family Editor
PowerBalanced | Equivalent with PowerCircuit
PowerUnBalanced | Equivalent with PowerCircuit
CableTrayConduit | Indicates the default type for cable trays and conduits

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


MEPSystemType Class

[image]

Revit 2024 API
MEPSystemType Class
Members See Also Send Feedback
A system type in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public class MEPSystemType : ElementType
Visual Basic
Public Class MEPSystemType _
    Inherits ElementType
Visual C++
public ref class MEPSystemType : public ElementType

Remarks

This is the base class for mechanical and piping system types, available only in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..MEPSystemType
Autodesk.Revit.DB.Mechanical..::..MechanicalSystemType
Autodesk.Revit.DB.Plumbing..::..PipingSystemType

See Also

MEPSystemType Members


MEPSystemType Members

[image] [image]

Revit 2024 API
MEPSystemType Members
MEPSystemType Class Methods Properties See Also Send Feedback

The MEPSystemType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Abbreviation | Identifies the abbreviation, the short name, for the system type
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CalculationLevel | Identifies the calculation level for the system type.
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | FillColor | Indicates the color that should override the fill color for all components in the system.
Public property | FillPatternId | Indicates the fill pattern id that should override the fill pattern id for all components in the system.
Public property | FillVisible | Indicates the visibility of the fill pattern for all components in the system.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | LineColor | Indicates the color that should override the line color for all components in the system.
Public property | LinePatternId | Indicates the line pattern id that should override the line pattern id for all components in the system.
Public property | LineWeight | Indicates the weight that should override the line weight for all components in the system.
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MaterialId | Indicates the material id that should override the material for all components in the system.
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SystemClassification | Identifies the classification for the system type
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

MEPSystemType Class


MEPSystemType Methods

[image] [image]

Revit 2024 API
MEPSystemType Methods
MEPSystemType Class See Also Send Feedback

The MEPSystemType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MEPSystemType Class


MEPSystemType Properties

[image] [image]

Revit 2024 API
MEPSystemType Properties
MEPSystemType Class See Also Send Feedback

The MEPSystemType type exposes the following members.

Properties

 | Name | Description
Public property | Abbreviation | Identifies the abbreviation, the short name, for the system type
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CalculationLevel | Identifies the calculation level for the system type.
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | FillColor | Indicates the color that should override the fill color for all components in the system.
Public property | FillPatternId | Indicates the fill pattern id that should override the fill pattern id for all components in the system.
Public property | FillVisible | Indicates the visibility of the fill pattern for all components in the system.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | LineColor | Indicates the color that should override the line color for all components in the system.
Public property | LinePatternId | Indicates the line pattern id that should override the line pattern id for all components in the system.
Public property | LineWeight | Indicates the weight that should override the line weight for all components in the system.
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MaterialId | Indicates the material id that should override the material for all components in the system.
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SystemClassification | Identifies the classification for the system type
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

MEPSystemType Class


Abbreviation Property

[image]

Revit 2024 API
MEPSystemType..::..Abbreviation Property
MEPSystemType Class See Also Send Feedback
Identifies the abbreviation, the short name, for the system type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public string Abbreviation { get; set; }
Visual Basic
Public Property Abbreviation As String
    Get
    Set
Visual C++
public:
property String^ Abbreviation {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

MEPSystemType Class


CalculationLevel Property

[image]

Revit 2024 API
MEPSystemType..::..CalculationLevel Property
MEPSystemType Class See Also Send Feedback
Identifies the calculation level for the system type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public SystemCalculationLevel CalculationLevel { get; set; }
Visual Basic
Public Property CalculationLevel As SystemCalculationLevel
    Get
    Set
Visual C++
public:
property SystemCalculationLevel CalculationLevel {
    SystemCalculationLevel get ();
    void set (SystemCalculationLevel value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

MEPSystemType Class


FillColor Property

[image]

Revit 2024 API
MEPSystemType..::..FillColor Property
MEPSystemType Class See Also Send Feedback
Indicates the color that should override the fill color for all components in the system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public Color FillColor { get; set; }
Visual Basic
Public Property FillColor As Color
    Get
    Set
Visual C++
public:
property Color^ FillColor {
    Color^ get ();
    void set (Color^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

MEPSystemType Class


FillVisible Property

[image]

Revit 2024 API
MEPSystemType..::..FillVisible Property
MEPSystemType Class See Also Send Feedback
Indicates the visibility of the fill pattern for all components in the system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public bool FillVisible { get; set; }
Visual Basic
Public Property FillVisible As Boolean
    Get
    Set
Visual C++
public:
property bool FillVisible {
    bool get ();
    void set (bool value);
}

See Also

MEPSystemType Class


LineColor Property

[image]

Revit 2024 API
MEPSystemType..::..LineColor Property
MEPSystemType Class See Also Send Feedback
Indicates the color that should override the line color for all components in the system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public Color LineColor { get; set; }
Visual Basic
Public Property LineColor As Color
    Get
    Set
Visual C++
public:
property Color^ LineColor {
    Color^ get ();
    void set (Color^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

MEPSystemType Class


LinePatternId Property

[image]

Revit 2024 API
MEPSystemType..::..LinePatternId Property
MEPSystemType Class See Also Send Feedback
Indicates the line pattern id that should override the line pattern id for all components in the system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public ElementId LinePatternId { get; set; }
Visual Basic
Public Property LinePatternId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ LinePatternId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

MEPSystemType Class


LineWeight Property

[image]

Revit 2024 API
MEPSystemType..::..LineWeight Property
MEPSystemType Class See Also Send Feedback
Indicates the weight that should override the line weight for all components in the system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public int LineWeight { get; set; }
Visual Basic
Public Property LineWeight As Integer
    Get
    Set
Visual C++
public:
property int LineWeight {
    int get ();
    void set (int value);
}

See Also

MEPSystemType Class


MaterialId Property

[image]

Revit 2024 API
MEPSystemType..::..MaterialId Property
MEPSystemType Class See Also Send Feedback
Indicates the material id that should override the material for all components in the system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public ElementId MaterialId { get; set; }
Visual Basic
Public Property MaterialId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ MaterialId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

MEPSystemType Class


Parameter Property

[image] [image]

Revit 2024 API
MEPSystemType..::..Parameter Property
MEPSystemType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

MEPSystemType Class
MEPSystemType Members


SystemClassification Property

[image]

Revit 2024 API
MEPSystemType..::..SystemClassification Property
MEPSystemType Class See Also Send Feedback
Identifies the classification for the system type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public MEPSystemClassification SystemClassification { get; }
Visual Basic
Public ReadOnly Property SystemClassification As MEPSystemClassification
    Get
Visual C++
public:
property MEPSystemClassification SystemClassification {
    MEPSystemClassification get ();
}

Remarks

The system classification drives certain behavior such as sizing and connections to other systems

See Also

MEPSystemType Class


Mesh Class

[image]

Revit 2024 API
Mesh Class
Members See Also Send Feedback
A triangular mesh.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class Mesh : GeometryObject
Visual Basic
Public Class Mesh _
    Inherits GeometryObject
Visual C++
public ref class Mesh : public GeometryObject

Remarks

Meshes are generated during triangulation of faces. They can also be encountered directly in Revit geometry (typically imported geometry). Meshes contain a single array of Vertices, and a corresponding array of triangles. Triangles can be accessed by index from Triangle[([( Int32])]) , and reference 3 vertices from the Vertices array.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeometryObject
Autodesk.Revit.DB..::..Mesh

See Also

Mesh Members


Mesh Members

[image] [image]

Revit 2024 API
Mesh Members
Mesh Class Methods Properties See Also Send Feedback

The Mesh type exposes the following members.

Methods

 | Name | Description
Public method | ComputeSurfaceArea | Computes and returns the surface area of the mesh. The surface area is the sum of the areas of the constituent facets of the mesh.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject.)
Public method | GetNormal | Returns a normal unit vector at the given index.
Public method | GetNormals | Returns all normals assigned to the mesh.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DistributionOfNormals | Indicates the distribution of normal vectors along the tessellated mesh surface.
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject.)
Public property | IsClosed | Indicates whether the mesh is closed.
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | MaterialElementId | Element ID of the material from which this mesh is composed.
Public property | NumberOfNormals | The number of normals associated with the mesh.
Public property | NumTriangles | The number of triangles that the mesh contains.
Public property | Transformed | Transforms this mesh and returns the result.
Public property | Triangle | Retrieves a specific triangle.
Public property | Vertices | Retrieves all vertices used to define this mesh. Intended for indexed access.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Mesh Class


Mesh Methods

[image] [image]

Revit 2024 API
Mesh Methods
Mesh Class See Also Send Feedback

The Mesh type exposes the following members.

Methods

 | Name | Description
Public method | ComputeSurfaceArea | Computes and returns the surface area of the mesh. The surface area is the sum of the areas of the constituent facets of the mesh.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject.)
Public method | GetNormal | Returns a normal unit vector at the given index.
Public method | GetNormals | Returns all normals assigned to the mesh.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Mesh Class


ComputeSurfaceArea Method

[image]

Revit 2024 API
Mesh..::..ComputeSurfaceArea Method
Mesh Class See Also Send Feedback
Computes and returns the surface area of the mesh. The surface area is the sum of the areas of the constituent facets of the mesh.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public double ComputeSurfaceArea()
Visual Basic
Public Function ComputeSurfaceArea As Double
Visual C++
public:
double ComputeSurfaceArea()

Return Value

A double, representing the surface area.

See Also

Mesh Class


GetNormal Method

[image]

Revit 2024 API
Mesh..::..GetNormal Method
Mesh Class See Also Send Feedback
Returns a normal unit vector at the given index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public XYZ GetNormal(
    int idx
)
Visual Basic
Public Function GetNormal ( _
    idx As Integer _
) As XYZ
Visual C++
public:
XYZ^ GetNormal(
    int idx
)

Parameters

idx
Type: System..::..Int32
A zero-based index. It must be consistent with the DistributionOfNormals.

Return Value

XYZ value representing a normal unit vector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value is not a valid index of a normal of the mesh. A valid value is not negative and is smaller than the number of normals in the mesh.

See Also

Mesh Class


GetNormals Method

[image]

Revit 2024 API
Mesh..::..GetNormals Method
Mesh Class See Also Send Feedback
Returns all normals assigned to the mesh.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public IList<XYZ> GetNormals()
Visual Basic
Public Function GetNormals As IList(Of XYZ)
Visual C++
public:
IList<XYZ^>^ GetNormals()

Return Value

An array of XYZ values, each representing a normal unit vector.

See Also

Mesh Class


Mesh Properties

[image] [image]

Revit 2024 API
Mesh Properties
Mesh Class See Also Send Feedback

The Mesh type exposes the following members.

Properties

 | Name | Description
Public property | DistributionOfNormals | Indicates the distribution of normal vectors along the tessellated mesh surface.
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject.)
Public property | IsClosed | Indicates whether the mesh is closed.
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | MaterialElementId | Element ID of the material from which this mesh is composed.
Public property | NumberOfNormals | The number of normals associated with the mesh.
Public property | NumTriangles | The number of triangles that the mesh contains.
Public property | Transformed | Transforms this mesh and returns the result.
Public property | Triangle | Retrieves a specific triangle.
Public property | Vertices | Retrieves all vertices used to define this mesh. Intended for indexed access.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Mesh Class


DistributionOfNormals Property

[image]

Revit 2024 API
Mesh..::..DistributionOfNormals Property
Mesh Class See Also Send Feedback
Indicates the distribution of normal vectors along the tessellated mesh surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public DistributionOfNormals DistributionOfNormals { get; }
Visual Basic
Public ReadOnly Property DistributionOfNormals As DistributionOfNormals
    Get
Visual C++
public:
property DistributionOfNormals DistributionOfNormals {
    DistributionOfNormals get ();
}

See Also

Mesh Class


MaterialElementId Property

[image]

Revit 2024 API
Mesh..::..MaterialElementId Property
Mesh Class See Also Send Feedback
Element ID of the material from which this mesh is composed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElementId MaterialElementId { get; }
Visual Basic
Public ReadOnly Property MaterialElementId As ElementId
    Get
Visual C++
public:
property ElementId^ MaterialElementId {
    ElementId^ get ();
}

See Also

Mesh Class


NumberOfNormals Property

[image]

Revit 2024 API
Mesh..::..NumberOfNormals Property
Mesh Class See Also Send Feedback
The number of normals associated with the mesh.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public int NumberOfNormals { get; }
Visual Basic
Public ReadOnly Property NumberOfNormals As Integer
    Get
Visual C++
public:
property int NumberOfNormals {
    int get ();
}

Remarks

The number is always equal either to '1', or the number of facets, or the number of points. The DistributionOfNormals property indicates how normals are distributed along the polymesh. If there is only one normal available, it applies to the entire mesh. Curved surfaces have normal vectors associated with either every facet or every point/vertex of the tessellated polymesh.

See Also

Mesh Class


NumTriangles Property

[image]

Revit 2024 API
Mesh..::..NumTriangles Property
Mesh Class See Also Send Feedback
The number of triangles that the mesh contains.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public int NumTriangles { get; }
Visual Basic
Public ReadOnly Property NumTriangles As Integer
    Get
Visual C++
public:
property int NumTriangles {
    int get ();
}

See Also

Mesh Class


Transformed Property

[image]

Revit 2024 API
Mesh..::..Transformed Property
Mesh Class See Also Send Feedback
Transforms this mesh and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Mesh this[
    Transform transform
] { get; }
Visual Basic
Public ReadOnly Property Transformed ( _
    transform As Transform _
) As Mesh
    Get
Visual C++
public:
property Mesh^ Transformed[Transform^ transform] {
    Mesh^ get (Transform^ transform);
}

Parameters

transform
Type: Autodesk.Revit.DB..::..Transform
The transformation used to transform the profile.

Return Value

The transformed mesh.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the handle of the specified transformation is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Mesh Class


Triangle Property

[image]

Revit 2024 API
Mesh..::..Triangle Property
Mesh Class See Also Send Feedback
Retrieves a specific triangle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public MeshTriangle this[
    int idx
] { get; }
Visual Basic
Public ReadOnly Property Triangle ( _
    idx As Integer _
) As MeshTriangle
    Get
Visual C++
public:
property MeshTriangle^ Triangle[int idx] {
    MeshTriangle^ get (int idx);
}

Parameters

idx
Type: System..::..Int32
Index of the triangle, must be in [0, NumTriangles).

See Also

Mesh Class


Vertices Property

[image]

Revit 2024 API
Mesh..::..Vertices Property
Mesh Class See Also Send Feedback
Retrieves all vertices used to define this mesh. Intended for indexed access.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public IList<XYZ> Vertices { get; }
Visual Basic
Public ReadOnly Property Vertices As IList(Of XYZ)
    Get
Visual C++
public:
property IList<XYZ^>^ Vertices {
    IList<XYZ^>^ get ();
}

See Also

Mesh Class


MeshFromGeometryOperationIssue Enumeration

[image]

Revit 2024 API
MeshFromGeometryOperationIssue Enumeration
See Also Send Feedback
Issues encountered while constructing meshes as fallbacks for geometrical operations.
Issues, which can be encountered while building a mesh as a fallback for geometrical operations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015
Since: 2015

Syntax

C#
public enum MeshFromGeometryOperationIssue
Visual Basic
Public Enumeration MeshFromGeometryOperationIssue
Visual C++
public enum class MeshFromGeometryOperationIssue

Members

Member name | Description
AllFine | No issues were encountered. Issues of this type should not be present in MeshFromGeometryOperationResult.
NoUsableCurveLoopsInInput | While one or more curve loops were expected as one of the input parameters while building a mesh, no loops containing curves were provided.
MissingCurveLoopsInInput | While several curve loops were expected as one of the input parameters while building a mesh, some of them were not provided.
EmptyCurveLoopsInInput | Among curve loops expected as input parameters while building a mesh, some are empty.
CurveLoopsWithoutCurvesInInput | Among curve loops expected as input parameters while building a mesh, some are not empty, but do not have any curves.
NonPlanarProfileLoop | Among curve loops expected as input parameters while building a mesh, some are not planar.
InputCurveLoopProblemWithFallback | An unidentified problem with an input curve loop. A fallback is attempted.
InputCurveLoopWrongOpenFlag | An input curve has incorrect open flag.
NonContinuousInputCurveLoop | A non-continuous input curve loop. Either wrong curve flips or genuine gaps.
MissingCurvesInInputLoop | An input curve loop has missing curves.
InternalUtilityError | An internal Revit problem. Issues of this type should not normally be present in MeshFromGeometryOperationResult. Please notify Autodesk support if encountered.
InternalMissingError | An internal Revit problem. Issues of this type should not be present in TessellatedShapeBuilderResult. Please notify Autodesk support if encountered.
InternalError | An internal Revit problem. Issues of this type should not normally be present in MeshFromGeometryOperationResult. Please notify Autodesk support if encountered.
NotSetYet | An issue has not been set yet.
NumberOfIssueTypes | Not a code of some issue, but the number of known types of issues. Issues of this type should not be present in TessellatedShapeBuilderResult. Please notify Autodesk support if encountered

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


MeshFromGeometryOperationResult Class

[image]

Revit 2024 API
MeshFromGeometryOperationResult Class
Members See Also Send Feedback
Describes what TessellatedShapeBuilder has built.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public class MeshFromGeometryOperationResult : IDisposable
Visual Basic
Public Class MeshFromGeometryOperationResult _
    Implements IDisposable
Visual C++
public ref class MeshFromGeometryOperationResult : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..MeshFromGeometryOperationResult

See Also

MeshFromGeometryOperationResult Members


MeshFromGeometryOperationResult Members

[image] [image]

Revit 2024 API
MeshFromGeometryOperationResult Members
MeshFromGeometryOperationResult Class Methods Properties See Also Send Feedback

The MeshFromGeometryOperationResult type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the MeshFromGeometryOperationResult
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIssues | Returns the array of issues encountered while building a mesh.
Public method | GetMesh | This returns a valid mesh only for the first call. Later calls will throw an exception as the mesh is no longer valid in this object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | HasInvalidData | Whether the provided data for which this result was obtained were internally inconsistent and could not be used in its entirety. For example, for extrusion operation, profile loops were degenerate or improperly oriented with respect to the extrsuion direction.
Public property | IsMeshAvailable | Shows whether the result still contains the mesh which was constructed, if any, or whether it has been relinquished by 'getMesh'. The former is true, the later is false.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Tessellated | Whether while constructing a mesh, it was necessary to extrude polylines instead of non-linear curves from the profile loops.

See Also

MeshFromGeometryOperationResult Class


MeshFromGeometryOperationResult Methods

[image] [image]

Revit 2024 API
MeshFromGeometryOperationResult Methods
MeshFromGeometryOperationResult Class See Also Send Feedback

The MeshFromGeometryOperationResult type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIssues | Returns the array of issues encountered while building a mesh.
Public method | GetMesh | This returns a valid mesh only for the first call. Later calls will throw an exception as the mesh is no longer valid in this object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MeshFromGeometryOperationResult Class


Dispose Method

[image]

Revit 2024 API
MeshFromGeometryOperationResult..::..Dispose Method
MeshFromGeometryOperationResult Class See Also Send Feedback
Releases all resources used by the MeshFromGeometryOperationResult

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

MeshFromGeometryOperationResult Class


GetIssues Method

[image]

Revit 2024 API
MeshFromGeometryOperationResult..::..GetIssues Method
MeshFromGeometryOperationResult Class See Also Send Feedback
Returns the array of issues encountered while building a mesh.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public IList<MeshFromGeometryOperationIssue> GetIssues()
Visual Basic
Public Function GetIssues As IList(Of MeshFromGeometryOperationIssue)
Visual C++
public:
IList<MeshFromGeometryOperationIssue>^ GetIssues()

Return Value

Array of issues encountered while building a mesh.

See Also

MeshFromGeometryOperationResult Class


GetMesh Method

[image]

Revit 2024 API
MeshFromGeometryOperationResult..::..GetMesh Method
MeshFromGeometryOperationResult Class See Also Send Feedback
This returns a valid mesh only for the first call. Later calls will throw an exception as the mesh is no longer valid in this object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public Mesh GetMesh()
Visual Basic
Public Function GetMesh As Mesh
Visual C++
public:
Mesh^ GetMesh()

Return Value

Mesh which built.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The Mesh has already been accessed by a previous GetMesh() call, and is no longer available for use.

See Also

MeshFromGeometryOperationResult Class


MeshFromGeometryOperationResult Properties

[image] [image]

Revit 2024 API
MeshFromGeometryOperationResult Properties
MeshFromGeometryOperationResult Class See Also Send Feedback

The MeshFromGeometryOperationResult type exposes the following members.

Properties

 | Name | Description
Public property | HasInvalidData | Whether the provided data for which this result was obtained were internally inconsistent and could not be used in its entirety. For example, for extrusion operation, profile loops were degenerate or improperly oriented with respect to the extrsuion direction.
Public property | IsMeshAvailable | Shows whether the result still contains the mesh which was constructed, if any, or whether it has been relinquished by 'getMesh'. The former is true, the later is false.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Tessellated | Whether while constructing a mesh, it was necessary to extrude polylines instead of non-linear curves from the profile loops.

See Also

MeshFromGeometryOperationResult Class


HasInvalidData Property

[image]

Revit 2024 API
MeshFromGeometryOperationResult..::..HasInvalidData Property
MeshFromGeometryOperationResult Class See Also Send Feedback
Whether the provided data for which this result was obtained were internally inconsistent and could not be used in its entirety. For example, for extrusion operation, profile loops were degenerate or improperly oriented with respect to the extrsuion direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool HasInvalidData { get; }
Visual Basic
Public ReadOnly Property HasInvalidData As Boolean
    Get
Visual C++
public:
property bool HasInvalidData {
    bool get ();
}

Remarks

This variable does not capture presence or absence of intersections between different profile loops.

See Also

MeshFromGeometryOperationResult Class


IsMeshAvailable Property

[image]

Revit 2024 API
MeshFromGeometryOperationResult..::..IsMeshAvailable Property
MeshFromGeometryOperationResult Class See Also Send Feedback
Shows whether the result still contains the mesh which was constructed, if any, or whether it has been relinquished by 'getMesh'. The former is true, the later is false.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool IsMeshAvailable { get; }
Visual Basic
Public ReadOnly Property IsMeshAvailable As Boolean
    Get
Visual C++
public:
property bool IsMeshAvailable {
    bool get ();
}

See Also

MeshFromGeometryOperationResult Class


Tessellated Property

[image]

Revit 2024 API
MeshFromGeometryOperationResult..::..Tessellated Property
MeshFromGeometryOperationResult Class See Also Send Feedback
Whether while constructing a mesh, it was necessary to extrude polylines instead of non-linear curves from the profile loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool Tessellated { get; }
Visual Basic
Public ReadOnly Property Tessellated As Boolean
    Get
Visual C++
public:
property bool Tessellated {
    bool get ();
}

See Also

MeshFromGeometryOperationResult Class


MeshTriangle Class

[image]

Revit 2024 API
MeshTriangle Class
Members See Also Send Feedback
One triangle of a mesh.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class MeshTriangle
Visual Basic
Public Class MeshTriangle
Visual C++
public ref class MeshTriangle

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..MeshTriangle

See Also

MeshTriangle Members


MeshTriangle Members

[image] [image]

Revit 2024 API
MeshTriangle Members
MeshTriangle Class Methods Properties See Also Send Feedback

The MeshTriangle type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Index | The index of the vertex in the Vertices array of the mesh, for indexed access.
Public property | Vertex | A vertex of the triangle.

See Also

MeshTriangle Class


MeshTriangle Methods

[image] [image]

Revit 2024 API
MeshTriangle Methods
MeshTriangle Class See Also Send Feedback

The MeshTriangle type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MeshTriangle Class


MeshTriangle Properties

[image] [image]

Revit 2024 API
MeshTriangle Properties
MeshTriangle Class See Also Send Feedback

The MeshTriangle type exposes the following members.

Properties

 | Name | Description
Public property | Index | The index of the vertex in the Vertices array of the mesh, for indexed access.
Public property | Vertex | A vertex of the triangle.

See Also

MeshTriangle Class


Index Property

[image]

Revit 2024 API
MeshTriangle..::..Index Property
MeshTriangle Class See Also Send Feedback
The index of the vertex in the Vertices array of the mesh, for indexed access.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public uint this[
    int idx
] { get; }
Visual Basic
Public ReadOnly Property Index ( _
    idx As Integer _
) As UInteger
    Get
Visual C++
public:
property unsigned int Index[int idx] {
    unsigned int get (int idx);
}

Parameters

idx
Type: System..::..Int32
Index of the vertex in the triangle: 0, 1 or 2.

See Also

MeshTriangle Class


Vertex Property

[image]

Revit 2024 API
MeshTriangle..::..Vertex Property
MeshTriangle Class See Also Send Feedback
A vertex of the triangle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ this[
    int idx
] { get; }
Visual Basic
Public ReadOnly Property Vertex ( _
    idx As Integer _
) As XYZ
    Get
Visual C++
public:
property XYZ^ Vertex[int idx] {
    XYZ^ get (int idx);
}

Parameters

idx
Type: System..::..Int32
Index of the vertex in the triangle: 0, 1 or 2.

See Also

MeshTriangle Class


ModelArc Class

[image]

Revit 2024 API
ModelArc Class
Members See Also Send Feedback
Represents a ModelArc within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class ModelArc : ModelCurve
Visual Basic
Public Class ModelArc _
    Inherits ModelCurve
Visual C++
public ref class ModelArc : public ModelCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from ModelCurve::geometryCurve property.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..CurveElement
Autodesk.Revit.DB..::..ModelCurve
Autodesk.Revit.DB..::..ModelArc

See Also

ModelArc Members


ModelArc Members

[image] [image]

Revit 2024 API
ModelArc Members
ModelArc Class Methods Properties See Also Send Feedback

The ModelArc type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeToReferenceLine | Changes this curve to a reference curve. (Inherited from ModelCurve.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point. (Inherited from CurveElement.)
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable. (Inherited from CurveElement.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element. (Inherited from CurveElement.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point. (Inherited from CurveElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point. (Inherited from CurveElement.)
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point. (Inherited from CurveElement.)
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end. (Inherited from CurveElement.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry. (Inherited from CurveElement.)
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement. (Inherited from CurveElement.)
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point. (Inherited from CurveElement.)
Public method | SetVisibility | Sets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveElementType | Type of the curve element. (Inherited from CurveElement.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsReferenceLine | Indicates if this curve is a reference curve. (Inherited from ModelCurve.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Public property | Subcategory | The subcategory. (Inherited from ModelCurve.)
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element. (Inherited from CurveElement.)
Public property | TrussCurveType | The truss curve type of this model curve. (Inherited from ModelCurve.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ModelArc Class


Parameter Property

[image] [image]

Revit 2024 API
ModelArc..::..Parameter Property
ModelArc Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ModelArc Class
ModelArc Members


ModelCurve Members

[image] [image]

Revit 2024 API
ModelCurve Members
ModelCurve Class Methods Properties See Also Send Feedback

The ModelCurve type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeToReferenceLine | Changes this curve to a reference curve.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point. (Inherited from CurveElement.)
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable. (Inherited from CurveElement.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element. (Inherited from CurveElement.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point. (Inherited from CurveElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the model curve in a family document.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point. (Inherited from CurveElement.)
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point. (Inherited from CurveElement.)
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end. (Inherited from CurveElement.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry. (Inherited from CurveElement.)
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement. (Inherited from CurveElement.)
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point. (Inherited from CurveElement.)
Public method | SetVisibility | Sets the visibility for the model curve in a family document.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveElementType | Type of the curve element. (Inherited from CurveElement.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsReferenceLine | Indicates if this curve is a reference curve.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Public property | Subcategory | The subcategory.
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element. (Inherited from CurveElement.)
Public property | TrussCurveType | The truss curve type of this model curve.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ModelCurve Class


ModelCurve Methods

[image] [image]

Revit 2024 API
ModelCurve Methods
ModelCurve Class See Also Send Feedback

The ModelCurve type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeToReferenceLine | Changes this curve to a reference curve.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point. (Inherited from CurveElement.)
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable. (Inherited from CurveElement.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element. (Inherited from CurveElement.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point. (Inherited from CurveElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the model curve in a family document.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point. (Inherited from CurveElement.)
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point. (Inherited from CurveElement.)
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end. (Inherited from CurveElement.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry. (Inherited from CurveElement.)
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement. (Inherited from CurveElement.)
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point. (Inherited from CurveElement.)
Public method | SetVisibility | Sets the visibility for the model curve in a family document.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ModelCurve Class


ChangeToReferenceLine Method

[image]

Revit 2024 API
ModelCurve..::..ChangeToReferenceLine Method
ModelCurve Class See Also Send Feedback
Changes this curve to a reference curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void ChangeToReferenceLine()
Visual Basic
Public Sub ChangeToReferenceLine
Visual C++
public:
void ChangeToReferenceLine()

See Also

ModelCurve Class


GetVisibility Method

[image]

Revit 2024 API
ModelCurve..::..GetVisibility Method
ModelCurve Class See Also Send Feedback
Gets the visibility for the model curve in a family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyElementVisibility GetVisibility()
Visual Basic
Public Function GetVisibility As FamilyElementVisibility
Visual C++
public:
FamilyElementVisibility^ GetVisibility()

Return Value

A copy of visibility settings for the model curve in a family document.

See Also

ModelCurve Class


SetVisibility Method

[image]

Revit 2024 API
ModelCurve..::..SetVisibility Method
ModelCurve Class See Also Send Feedback
Sets the visibility for the model curve in a family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetVisibility(
    FamilyElementVisibility visibility
)
Visual Basic
Public Sub SetVisibility ( _
    visibility As FamilyElementVisibility _
)
Visual C++
public:
void SetVisibility(
    FamilyElementVisibility^ visibility
)

Parameters

visibility
Type: Autodesk.Revit.DB..::..FamilyElementVisibility

Remarks

The visibility of the model curve geometry can be changed for different types of views and detail levels in the family document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when visibility is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when regeneration failed, or the model curve is in a project document.

See Also

ModelCurve Class


ModelCurve Properties

[image] [image]

Revit 2024 API
ModelCurve Properties
ModelCurve Class See Also Send Feedback

The ModelCurve type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveElementType | Type of the curve element. (Inherited from CurveElement.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsReferenceLine | Indicates if this curve is a reference curve.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Public property | Subcategory | The subcategory.
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element. (Inherited from CurveElement.)
Public property | TrussCurveType | The truss curve type of this model curve.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ModelCurve Class


IsReferenceLine Property

[image]

Revit 2024 API
ModelCurve..::..IsReferenceLine Property
ModelCurve Class See Also Send Feedback
Indicates if this curve is a reference curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsReferenceLine { get; }
Visual Basic
Public ReadOnly Property IsReferenceLine As Boolean
    Get
Visual C++
public:
property bool IsReferenceLine {
    bool get ();
}

See Also

ModelCurve Class


Parameter Property

[image] [image]

Revit 2024 API
ModelCurve..::..Parameter Property
ModelCurve Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ModelCurve Class
ModelCurve Members


Subcategory Property

[image]

Revit 2024 API
ModelCurve..::..Subcategory Property
ModelCurve Class See Also Send Feedback
The subcategory.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public GraphicsStyle Subcategory { get; set; }
Visual Basic
Public Property Subcategory As GraphicsStyle
    Get
    Set
Visual C++
public:
property GraphicsStyle^ Subcategory {
    GraphicsStyle^ get ();
    void set (GraphicsStyle^ value);
}

Remarks

If the family category is non-cuttable, the subcategory can be set to be the family category or one of its subcategories. If the family category is cuttable, the subcategory can be set as the graphics styles of the family category, its subcategories, or the invisible lines graphics style.

See Also

ModelCurve Class


ModelCurveArrArray Class

[image]

Revit 2024 API
ModelCurveArrArray Class
Members See Also Send Feedback
An array that can contain any type of object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class ModelCurveArrArray : APIObject,
    IEnumerable
Visual Basic
Public Class ModelCurveArrArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ModelCurveArrArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..ModelCurveArrArray

See Also

ModelCurveArrArray Members


ModelCurveArrArray Constructor

[image]

Revit 2024 API
ModelCurveArrArray Constructor
ModelCurveArrArray Class See Also Send Feedback
Initializes a new instance of the ModelCurveArrArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ModelCurveArrArray()
Visual Basic
Public Sub New
Visual C++
public:
ModelCurveArrArray()

See Also

ModelCurveArrArray Class


ModelCurveArrArray Methods

[image] [image]

Revit 2024 API
ModelCurveArrArray Methods
ModelCurveArrArray Class See Also Send Feedback

The ModelCurveArrArray type exposes the following members.

Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ModelCurveArrArray Class


Append Method

[image]

Revit 2024 API
ModelCurveArrArray..::..Append Method
ModelCurveArrArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Append(
    ModelCurveArray item
)
Visual Basic
Public Overridable Sub Append ( _
    item As ModelCurveArray _
)
Visual C++
public:
virtual void Append(
    ModelCurveArray^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..ModelCurveArray

See Also

ModelCurveArrArray Class


Clear Method

[image]

Revit 2024 API
ModelCurveArrArray..::..Clear Method
ModelCurveArrArray Class See Also Send Feedback
Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ModelCurveArrArray Class


ForwardIterator Method

[image]

Revit 2024 API
ModelCurveArrArray..::..ForwardIterator Method
ModelCurveArrArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual ModelCurveArrArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As ModelCurveArrArrayIterator
Visual C++
public:
virtual ModelCurveArrArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

ModelCurveArrArray Class


GetEnumerator Method

[image]

Revit 2024 API
ModelCurveArrArray..::..GetEnumerator Method
ModelCurveArrArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

ModelCurveArrArray Class


ReverseIterator Method

[image]

Revit 2024 API
ModelCurveArrArray..::..ReverseIterator Method
ModelCurveArrArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual ModelCurveArrArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As ModelCurveArrArrayIterator
Visual C++
public:
virtual ModelCurveArrArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

ModelCurveArrArray Class


IsEmpty Property

[image]

Revit 2024 API
ModelCurveArrArray..::..IsEmpty Property
ModelCurveArrArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

ModelCurveArrArray Class


Size Property

[image]

Revit 2024 API
ModelCurveArrArray..::..Size Property
ModelCurveArrArray Class See Also Send Feedback
Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ModelCurveArrArray Class


ModelCurveArrArrayIterator Constructor

[image]

Revit 2024 API
ModelCurveArrArrayIterator Constructor
ModelCurveArrArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ModelCurveArrArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
ModelCurveArrArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ModelCurveArrArrayIterator Class


ModelCurveArrArrayIterator Methods

[image] [image]

Revit 2024 API
ModelCurveArrArrayIterator Methods
ModelCurveArrArrayIterator Class See Also Send Feedback

The ModelCurveArrArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ModelCurveArrArrayIterator Class


MoveNext Method

[image]

Revit 2024 API
ModelCurveArrArrayIterator..::..MoveNext Method
ModelCurveArrArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ModelCurveArrArrayIterator Class


Reset Method

[image]

Revit 2024 API
ModelCurveArrArrayIterator..::..Reset Method
ModelCurveArrArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ModelCurveArrArrayIterator Class


ModelCurveArrArrayIterator Properties

[image] [image]

Revit 2024 API
ModelCurveArrArrayIterator Properties
ModelCurveArrArrayIterator Class See Also Send Feedback

The ModelCurveArrArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ModelCurveArrArrayIterator Class


ModelCurveArray Class

[image]

Revit 2024 API
ModelCurveArray Class
Members See Also Send Feedback
An array that contains model curves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class ModelCurveArray : APIObject,
    IEnumerable
Visual Basic
Public Class ModelCurveArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ModelCurveArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..ModelCurveArray

See Also

ModelCurveArray Members


ModelCurveArray Constructor

[image]

Revit 2024 API
ModelCurveArray Constructor
ModelCurveArray Class See Also Send Feedback
Initializes a new instance of the ModelCurveArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ModelCurveArray()
Visual Basic
Public Sub New
Visual C++
public:
ModelCurveArray()

See Also

ModelCurveArray Class


ModelCurveArray Methods

[image] [image]

Revit 2024 API
ModelCurveArray Methods
ModelCurveArray Class See Also Send Feedback

The ModelCurveArray type exposes the following members.

Methods

 | Name | Description
Public method | Append | Add the model curve to the end of the array.
Public method | Clear | Removes every model curve from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified model curve into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ModelCurveArray Class


Append Method

[image]

Revit 2024 API
ModelCurveArray..::..Append Method
ModelCurveArray Class See Also Send Feedback
Add the model curve to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Append(
    ModelCurve item
)
Visual Basic
Public Overridable Sub Append ( _
    item As ModelCurve _
)
Visual C++
public:
virtual void Append(
    ModelCurve^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..ModelCurve
The model curve to be added.

See Also

ModelCurveArray Class


Clear Method

[image]

Revit 2024 API
ModelCurveArray..::..Clear Method
ModelCurveArray Class See Also Send Feedback
Removes every model curve from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ModelCurveArray Class


ForwardIterator Method

[image]

Revit 2024 API
ModelCurveArray..::..ForwardIterator Method
ModelCurveArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual ModelCurveArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As ModelCurveArrayIterator
Visual C++
public:
virtual ModelCurveArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

ModelCurveArray Class


GetEnumerator Method

[image]

Revit 2024 API
ModelCurveArray..::..GetEnumerator Method
ModelCurveArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

ModelCurveArray Class


ReverseIterator Method

[image]

Revit 2024 API
ModelCurveArray..::..ReverseIterator Method
ModelCurveArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual ModelCurveArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As ModelCurveArrayIterator
Visual C++
public:
virtual ModelCurveArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

ModelCurveArray Class


ModelCurveArray Properties

[image] [image]

Revit 2024 API
ModelCurveArray Properties
ModelCurveArray Class See Also Send Feedback

The ModelCurveArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a model curve at a specified index within the array.
Public property | Size | Returns the number of model curves that are in the array.

See Also

ModelCurveArray Class


IsEmpty Property

[image]

Revit 2024 API
ModelCurveArray..::..IsEmpty Property
ModelCurveArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

ModelCurveArray Class


Item Property

[image]

Revit 2024 API
ModelCurveArray..::..Item Property
ModelCurveArray Class See Also Send Feedback
Gets or sets a model curve at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual ModelCurve this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As ModelCurve
    Get
    Set
Visual C++
public:
virtual property ModelCurve^ Item[int index] {
    ModelCurve^ get (int index);
    void set (int index, ModelCurve^ value);
}

Parameters

index
Type: System..::..Int32
The index of the model curve to be set or retrieved.

Return Value

Returns the model curve at the specified index.

See Also

ModelCurveArray Class


Size Property

[image]

Revit 2024 API
ModelCurveArray..::..Size Property
ModelCurveArray Class See Also Send Feedback
Returns the number of model curves that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ModelCurveArray Class


ModelCurveArrayIterator Members

[image] [image]

Revit 2024 API
ModelCurveArrayIterator Members
ModelCurveArrayIterator Class Constructors Methods Properties See Also Send Feedback

The ModelCurveArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | ModelCurveArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ModelCurveArrayIterator Class


MoveNext Method

[image]

Revit 2024 API
ModelCurveArrayIterator..::..MoveNext Method
ModelCurveArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ModelCurveArrayIterator Class


Reset Method

[image]

Revit 2024 API
ModelCurveArrayIterator..::..Reset Method
ModelCurveArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ModelCurveArrayIterator Class


ModelCurveArrayIterator Properties

[image] [image]

Revit 2024 API
ModelCurveArrayIterator Properties
ModelCurveArrayIterator Class See Also Send Feedback

The ModelCurveArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ModelCurveArrayIterator Class


Current Property

[image]

Revit 2024 API
ModelCurveArrayIterator..::..Current Property
ModelCurveArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ModelCurveArrayIterator Class


ModelCurveNode Class

[image]

Revit 2024 API
ModelCurveNode Class
Members See Also Send Feedback
A base class of output nodes that represent various model curves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public class ModelCurveNode : RenderNode
Visual Basic
Public Class ModelCurveNode _
    Inherits RenderNode
Visual C++
public ref class ModelCurveNode : public RenderNode

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..RenderNode
Autodesk.Revit.DB..::..ModelCurveNode
Autodesk.Revit.DB..::..CurveNode
Autodesk.Revit.DB..::..PointNode
Autodesk.Revit.DB..::..PolylineNode

See Also

ModelCurveNode Members


ModelCurveNode Members

[image] [image]

Revit 2024 API
ModelCurveNode Members
ModelCurveNode Class Methods Properties See Also Send Feedback

The ModelCurveNode type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RenderNode.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode.)
Public property | LineProperties | Access to the line (pen) properties of the curve being drawn
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode.)

See Also

ModelCurveNode Class


ModelCurveNode Methods

[image] [image]

Revit 2024 API
ModelCurveNode Methods
ModelCurveNode Class See Also Send Feedback

The ModelCurveNode type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RenderNode.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ModelCurveNode Class


ModelCurveNode Properties

[image] [image]

Revit 2024 API
ModelCurveNode Properties
ModelCurveNode Class See Also Send Feedback

The ModelCurveNode type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode.)
Public property | LineProperties | Access to the line (pen) properties of the curve being drawn
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode.)

See Also

ModelCurveNode Class


ModelEllipse Class

[image]

Revit 2024 API
ModelEllipse Class
Members See Also Send Feedback
Represents a ModelEllipse within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class ModelEllipse : ModelCurve
Visual Basic
Public Class ModelEllipse _
    Inherits ModelCurve
Visual C++
public ref class ModelEllipse : public ModelCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from ModelCurve::geometryCurve property.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..CurveElement
Autodesk.Revit.DB..::..ModelCurve
Autodesk.Revit.DB..::..ModelEllipse

See Also

ModelEllipse Members


ModelEllipse Members

[image] [image]

Revit 2024 API
ModelEllipse Members
ModelEllipse Class Methods Properties See Also Send Feedback

The ModelEllipse type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeToReferenceLine | Changes this curve to a reference curve. (Inherited from ModelCurve.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point. (Inherited from CurveElement.)
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable. (Inherited from CurveElement.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element. (Inherited from CurveElement.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point. (Inherited from CurveElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point. (Inherited from CurveElement.)
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point. (Inherited from CurveElement.)
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end. (Inherited from CurveElement.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry. (Inherited from CurveElement.)
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement. (Inherited from CurveElement.)
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point. (Inherited from CurveElement.)
Public method | SetVisibility | Sets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveElementType | Type of the curve element. (Inherited from CurveElement.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsReferenceLine | Indicates if this curve is a reference curve. (Inherited from ModelCurve.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Public property | Subcategory | The subcategory. (Inherited from ModelCurve.)
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element. (Inherited from CurveElement.)
Public property | TrussCurveType | The truss curve type of this model curve. (Inherited from ModelCurve.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ModelEllipse Class


ModelEllipse Methods

[image] [image]

Revit 2024 API
ModelEllipse Methods
ModelEllipse Class See Also Send Feedback

The ModelEllipse type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeToReferenceLine | Changes this curve to a reference curve. (Inherited from ModelCurve.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point. (Inherited from CurveElement.)
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable. (Inherited from CurveElement.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element. (Inherited from CurveElement.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point. (Inherited from CurveElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point. (Inherited from CurveElement.)
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point. (Inherited from CurveElement.)
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end. (Inherited from CurveElement.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry. (Inherited from CurveElement.)
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement. (Inherited from CurveElement.)
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point. (Inherited from CurveElement.)
Public method | SetVisibility | Sets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ModelEllipse Class


ModelEllipse Properties

[image] [image]

Revit 2024 API
ModelEllipse Properties
ModelEllipse Class See Also Send Feedback

The ModelEllipse type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveElementType | Type of the curve element. (Inherited from CurveElement.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsReferenceLine | Indicates if this curve is a reference curve. (Inherited from ModelCurve.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Public property | Subcategory | The subcategory. (Inherited from ModelCurve.)
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element. (Inherited from CurveElement.)
Public property | TrussCurveType | The truss curve type of this model curve. (Inherited from ModelCurve.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ModelEllipse Class


Parameter Property

[image] [image]

Revit 2024 API
ModelEllipse..::..Parameter Property
ModelEllipse Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ModelEllipse Class
ModelEllipse Members


ModelHermiteSpline Class

[image]

Revit 2024 API
ModelHermiteSpline Class
Members See Also Send Feedback
Represents a ModelHermiteSpline within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class ModelHermiteSpline : ModelCurve
Visual Basic
Public Class ModelHermiteSpline _
    Inherits ModelCurve
Visual C++
public ref class ModelHermiteSpline : public ModelCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from ModelCurve::geometryCurve property.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..CurveElement
Autodesk.Revit.DB..::..ModelCurve
Autodesk.Revit.DB..::..ModelHermiteSpline

See Also

ModelHermiteSpline Members


ModelHermiteSpline Members

[image] [image]

Revit 2024 API
ModelHermiteSpline Members
ModelHermiteSpline Class Methods Properties See Also Send Feedback

The ModelHermiteSpline type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeToReferenceLine | Changes this curve to a reference curve. (Inherited from ModelCurve.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point. (Inherited from CurveElement.)
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable. (Inherited from CurveElement.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element. (Inherited from CurveElement.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point. (Inherited from CurveElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point. (Inherited from CurveElement.)
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point. (Inherited from CurveElement.)
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end. (Inherited from CurveElement.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry. (Inherited from CurveElement.)
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement. (Inherited from CurveElement.)
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point. (Inherited from CurveElement.)
Public method | SetVisibility | Sets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveElementType | Type of the curve element. (Inherited from CurveElement.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsReferenceLine | Indicates if this curve is a reference curve. (Inherited from ModelCurve.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Public property | Subcategory | The subcategory. (Inherited from ModelCurve.)
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element. (Inherited from CurveElement.)
Public property | TrussCurveType | The truss curve type of this model curve. (Inherited from ModelCurve.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ModelHermiteSpline Class


ModelHermiteSpline Methods

[image] [image]

Revit 2024 API
ModelHermiteSpline Methods
ModelHermiteSpline Class See Also Send Feedback

The ModelHermiteSpline type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeToReferenceLine | Changes this curve to a reference curve. (Inherited from ModelCurve.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point. (Inherited from CurveElement.)
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable. (Inherited from CurveElement.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element. (Inherited from CurveElement.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point. (Inherited from CurveElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point. (Inherited from CurveElement.)
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point. (Inherited from CurveElement.)
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end. (Inherited from CurveElement.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry. (Inherited from CurveElement.)
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement. (Inherited from CurveElement.)
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point. (Inherited from CurveElement.)
Public method | SetVisibility | Sets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ModelHermiteSpline Class


ModelHermiteSpline Properties

[image] [image]

Revit 2024 API
ModelHermiteSpline Properties
ModelHermiteSpline Class See Also Send Feedback

The ModelHermiteSpline type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveElementType | Type of the curve element. (Inherited from CurveElement.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsReferenceLine | Indicates if this curve is a reference curve. (Inherited from ModelCurve.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Public property | Subcategory | The subcategory. (Inherited from ModelCurve.)
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element. (Inherited from CurveElement.)
Public property | TrussCurveType | The truss curve type of this model curve. (Inherited from ModelCurve.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ModelHermiteSpline Class


Parameter Property

[image] [image]

Revit 2024 API
ModelHermiteSpline..::..Parameter Property
ModelHermiteSpline Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ModelHermiteSpline Class
ModelHermiteSpline Members


ModelLine Class

[image]

Revit 2024 API
ModelLine Class
Members See Also Send Feedback
Represents a ModelLine within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class ModelLine : ModelCurve
Visual Basic
Public Class ModelLine _
    Inherits ModelCurve
Visual C++
public ref class ModelLine : public ModelCurve

Remarks

Geometry-related functionality is provided by the geometry curve object from the ModelCurve::geometryCurve property.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..CurveElement
Autodesk.Revit.DB..::..ModelCurve
Autodesk.Revit.DB..::..ModelLine

See Also

ModelLine Members


ModelLine Members

[image] [image]

Revit 2024 API
ModelLine Members
ModelLine Class Methods Properties See Also Send Feedback

The ModelLine type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeToReferenceLine | Changes this curve to a reference curve. (Inherited from ModelCurve.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point. (Inherited from CurveElement.)
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable. (Inherited from CurveElement.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element. (Inherited from CurveElement.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point. (Inherited from CurveElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point. (Inherited from CurveElement.)
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point. (Inherited from CurveElement.)
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end. (Inherited from CurveElement.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry. (Inherited from CurveElement.)
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement. (Inherited from CurveElement.)
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point. (Inherited from CurveElement.)
Public method | SetVisibility | Sets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveElementType | Type of the curve element. (Inherited from CurveElement.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsReferenceLine | Indicates if this curve is a reference curve. (Inherited from ModelCurve.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Public property | Subcategory | The subcategory. (Inherited from ModelCurve.)
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element. (Inherited from CurveElement.)
Public property | TrussCurveType | The truss curve type of this model curve. (Inherited from ModelCurve.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ModelLine Class


ModelLine Properties

[image] [image]

Revit 2024 API
ModelLine Properties
ModelLine Class See Also Send Feedback

The ModelLine type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveElementType | Type of the curve element. (Inherited from CurveElement.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsReferenceLine | Indicates if this curve is a reference curve. (Inherited from ModelCurve.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Public property | Subcategory | The subcategory. (Inherited from ModelCurve.)
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element. (Inherited from CurveElement.)
Public property | TrussCurveType | The truss curve type of this model curve. (Inherited from ModelCurve.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ModelLine Class


Parameter Property

[image] [image]

Revit 2024 API
ModelLine..::..Parameter Property
ModelLine Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ModelLine Class
ModelLine Members


ModelNurbSpline Class

[image]

Revit 2024 API
ModelNurbSpline Class
Members See Also Send Feedback
Represents a ModelNurbSpline within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class ModelNurbSpline : ModelCurve
Visual Basic
Public Class ModelNurbSpline _
    Inherits ModelCurve
Visual C++
public ref class ModelNurbSpline : public ModelCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from ModelCurve::geometryCurve property.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..CurveElement
Autodesk.Revit.DB..::..ModelCurve
Autodesk.Revit.DB..::..ModelNurbSpline

See Also

ModelNurbSpline Members


ModelNurbSpline Members

[image] [image]

Revit 2024 API
ModelNurbSpline Members
ModelNurbSpline Class Methods Properties See Also Send Feedback

The ModelNurbSpline type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeToReferenceLine | Changes this curve to a reference curve. (Inherited from ModelCurve.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point. (Inherited from CurveElement.)
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable. (Inherited from CurveElement.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element. (Inherited from CurveElement.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point. (Inherited from CurveElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point. (Inherited from CurveElement.)
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point. (Inherited from CurveElement.)
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end. (Inherited from CurveElement.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry. (Inherited from CurveElement.)
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement. (Inherited from CurveElement.)
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point. (Inherited from CurveElement.)
Public method | SetVisibility | Sets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveElementType | Type of the curve element. (Inherited from CurveElement.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsReferenceLine | Indicates if this curve is a reference curve. (Inherited from ModelCurve.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Public property | Subcategory | The subcategory. (Inherited from ModelCurve.)
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element. (Inherited from CurveElement.)
Public property | TrussCurveType | The truss curve type of this model curve. (Inherited from ModelCurve.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ModelNurbSpline Class


ModelNurbSpline Methods

[image] [image]

Revit 2024 API
ModelNurbSpline Methods
ModelNurbSpline Class See Also Send Feedback

The ModelNurbSpline type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeToReferenceLine | Changes this curve to a reference curve. (Inherited from ModelCurve.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point. (Inherited from CurveElement.)
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable. (Inherited from CurveElement.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element. (Inherited from CurveElement.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point. (Inherited from CurveElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point. (Inherited from CurveElement.)
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point. (Inherited from CurveElement.)
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end. (Inherited from CurveElement.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry. (Inherited from CurveElement.)
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement. (Inherited from CurveElement.)
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point. (Inherited from CurveElement.)
Public method | SetVisibility | Sets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ModelNurbSpline Class


ModelNurbSpline Properties

[image] [image]

Revit 2024 API
ModelNurbSpline Properties
ModelNurbSpline Class See Also Send Feedback

The ModelNurbSpline type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveElementType | Type of the curve element. (Inherited from CurveElement.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsReferenceLine | Indicates if this curve is a reference curve. (Inherited from ModelCurve.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Public property | Subcategory | The subcategory. (Inherited from ModelCurve.)
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element. (Inherited from CurveElement.)
Public property | TrussCurveType | The truss curve type of this model curve. (Inherited from ModelCurve.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ModelNurbSpline Class


ModelPath Class

[image]

Revit 2024 API
ModelPath Class
Members See Also Send Feedback
A path to a file stored on a disk or on a server.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public class ModelPath : IDisposable
Visual Basic
Public Class ModelPath _
    Implements IDisposable
Visual C++
public ref class ModelPath : IDisposable

Remarks

ModelPaths are paths to another file. They can refer to Revit models, or to any of Revit's external file references (DWG links, for example.) Paths can be relative or absolute, but they must include an extension indicating what kind of file it is. Relative paths are generally relative to the currently opened document. If the current document is workshared, paths will be treated as relative to the central model. To create a ModelPath, use the derived classes FilePath , ServerPath, or use [!:Autodesk::Revit::DB::ModelPathUtils::ConvertCloudGUIDsToCloudPath(System::Guid, System::Guid)] for a cloud model path. The class ModelPathUtils contains utility functions for converting ModelPaths to and from strings.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ModelPath
Autodesk.Revit.DB..::..FilePath
Autodesk.Revit.DB..::..ServerPath

See Also

ModelPath Members


Compare Method

[image]

Revit 2024 API
ModelPath..::..Compare Method
ModelPath Class See Also Send Feedback
Compares this ModelPath with another

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public int Compare(
    ModelPath otherPath
)
Visual Basic
Public Function Compare ( _
    otherPath As ModelPath _
) As Integer
Visual C++
public:
int Compare(
    ModelPath^ otherPath
)

Parameters

otherPath
Type: Autodesk.Revit.DB..::..ModelPath
The path to compare against.

Return Value

A signed integer indicating the lexical relationship between two ModelPaths. Value is less than zero if this path is less than the given path; zero if the two are the same; and more than zero otherwise

Remarks

The comparison is case-insensitive.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ModelPath Class


Dispose Method

[image]

Revit 2024 API
ModelPath..::..Dispose Method
ModelPath Class See Also Send Feedback
Releases all resources used by the ModelPath

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ModelPath Class


GetProjectGUID Method

[image]

Revit 2024 API
ModelPath..::..GetProjectGUID Method
ModelPath Class See Also Send Feedback
A GUID identifying the BIM 360 Docs or Autodesk Docs project to which the model is associated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public Guid GetProjectGUID()
Visual Basic
Public Function GetProjectGUID As Guid
Visual C++
public:
Guid GetProjectGUID()

See Also

ModelPath Class


ModelPath Properties

[image] [image]

Revit 2024 API
ModelPath Properties
ModelPath Class See Also Send Feedback

The ModelPath type exposes the following members.

Properties

 | Name | Description
Public property | CentralServerPath | The path to the location of the central Revit server or cloud.
Public property | CloudPath | Whether this path represents a path on an Autodesk server such as BIM360.
Public property | Empty | Whether this path is empty
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Region | The region of the BIM 360 Docs or Autodesk Docs account and project which contains this model.
Public property | ServerPath | Whether this path is a server path (as opposed to a file path or cloud path)

See Also

ModelPath Class


CentralServerPath Property

[image]

Revit 2024 API
ModelPath..::..CentralServerPath Property
ModelPath Class See Also Send Feedback
The path to the location of the central Revit server or cloud.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public string CentralServerPath { get; }
Visual Basic
Public ReadOnly Property CentralServerPath As String
    Get
Visual C++
public:
property String^ CentralServerPath {
    String^ get ();
}

See Also

ModelPath Class


CloudPath Property

[image]

Revit 2024 API
ModelPath..::..CloudPath Property
ModelPath Class See Also Send Feedback
Whether this path represents a path on an Autodesk server such as BIM360.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public bool CloudPath { get; }
Visual Basic
Public ReadOnly Property CloudPath As Boolean
    Get
Visual C++
public:
property bool CloudPath {
    bool get ();
}

See Also

ModelPath Class


Region Property

[image]

Revit 2024 API
ModelPath..::..Region Property
ModelPath Class See Also Send Feedback
The region of the BIM 360 Docs or Autodesk Docs account and project which contains this model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public string Region { get; }
Visual Basic
Public ReadOnly Property Region As String
    Get
Visual C++
public:
property String^ Region {
    String^ get ();
}

See Also

ModelPath Class


ServerPath Property

[image]

Revit 2024 API
ModelPath..::..ServerPath Property
ModelPath Class See Also Send Feedback
Whether this path is a server path (as opposed to a file path or cloud path)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public bool ServerPath { get; }
Visual Basic
Public ReadOnly Property ServerPath As Boolean
    Get
Visual C++
public:
property bool ServerPath {
    bool get ();
}

See Also

ModelPath Class


ModelPathUtils Members

[image] [image]

Revit 2024 API
ModelPathUtils Members
ModelPathUtils Class Methods Properties See Also Send Feedback

The ModelPathUtils type exposes the following members.

Methods

Name | Description
ConvertCloudGUIDsToCloudPath | Converts a pair of cloud project and model GUIDs to a valid cloud path.
ConvertModelPathToUserVisiblePath | Gets a string version of the path of a given ModelPath.
ConvertUserVisiblePathToModelPath | Converts a user-visible path (string) to a ModelPath.
IsValidUserVisibleFullServerPath | Determines whether the given string represents a valid server path.

Properties

Name | Description
CloudRegionEMEA | The name of cloud region EMEA.
CloudRegionUS | The name of cloud region US.

See Also

ModelPathUtils Class


ModelPathUtils Methods

[image] [image]

Revit 2024 API
ModelPathUtils Methods
ModelPathUtils Class See Also Send Feedback

The ModelPathUtils type exposes the following members.

Methods

Name | Description
ConvertCloudGUIDsToCloudPath | Converts a pair of cloud project and model GUIDs to a valid cloud path.
ConvertModelPathToUserVisiblePath | Gets a string version of the path of a given ModelPath.
ConvertUserVisiblePathToModelPath | Converts a user-visible path (string) to a ModelPath.
IsValidUserVisibleFullServerPath | Determines whether the given string represents a valid server path.

See Also

ModelPathUtils Class


ConvertCloudGUIDsToCloudPath Method

[image]

Revit 2024 API
ModelPathUtils..::..ConvertCloudGUIDsToCloudPath Method
ModelPathUtils Class See Also Send Feedback
Converts a pair of cloud project and model GUIDs to a valid cloud path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ModelPath ConvertCloudGUIDsToCloudPath(
    string region,
    Guid projectGuid,
    Guid modelGuid
)
Visual Basic
Public Shared Function ConvertCloudGUIDsToCloudPath ( _
    region As String, _
    projectGuid As Guid, _
    modelGuid As Guid _
) As ModelPath
Visual C++
public:
static ModelPath^ ConvertCloudGUIDsToCloudPath(
    String^ region,
    Guid projectGuid,
    Guid modelGuid
)

Parameters

region
Type: System..::..String
The region of the BIM 360 Docs or Autodesk Docs account and project which contains this model. Please see the reference values, like CloudRegionUS and CloudRegionEMEA, and the new regions from release note.
projectGuid
Type: System..::..Guid
The GUID of the cloud project which contains the model.
modelGuid
Type: System..::..Guid
The GUID of the Revit cloud model.

Return Value

The cloud model path.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..CentralModelException | The cloud project is missing.
Autodesk.Revit.Exceptions..::..RevitServerCommunicationException | The central server could not be reached.
Autodesk.Revit.Exceptions..::..RevitServerUnauthenticatedUserException | You must sign in to Autodesk 360 in order to complete action.
Autodesk.Revit.Exceptions..::..RevitServerUnauthorizedException | You are unauthorized to access this resource.

See Also

ModelPathUtils Class


ConvertModelPathToUserVisiblePath Method

[image]

Revit 2024 API
ModelPathUtils..::..ConvertModelPathToUserVisiblePath Method
ModelPathUtils Class See Also Send Feedback
Gets a string version of the path of a given ModelPath.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static string ConvertModelPathToUserVisiblePath(
    ModelPath path
)
Visual Basic
Public Shared Function ConvertModelPathToUserVisiblePath ( _
    path As ModelPath _
) As String
Visual C++
public:
static String^ ConvertModelPathToUserVisiblePath(
    ModelPath^ path
)

Parameters

path
Type: Autodesk.Revit.DB..::..ModelPath
A ModelPath representing a file path or a server path.

Return Value

The path in string form

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ModelPathUtils Class


ConvertUserVisiblePathToModelPath Method

[image]

Revit 2024 API
ModelPathUtils..::..ConvertUserVisiblePathToModelPath Method
ModelPathUtils Class See Also Send Feedback
Converts a user-visible path (string) to a ModelPath.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static ModelPath ConvertUserVisiblePathToModelPath(
    string strPath
)
Visual Basic
Public Shared Function ConvertUserVisiblePathToModelPath ( _
    strPath As String _
) As ModelPath
Visual C++
public:
static ModelPath^ ConvertUserVisiblePathToModelPath(
    String^ strPath
)

Parameters

strPath
Type: System..::..String
The path in string form, like RSN://{HostNodeName}/school/project.rvt

Return Value

A ModelPath representing either a server or file path.

Remarks

The path may be a server or file path.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ModelPathUtils Class


IsValidUserVisibleFullServerPath Method

[image]

Revit 2024 API
ModelPathUtils..::..IsValidUserVisibleFullServerPath Method
ModelPathUtils Class See Also Send Feedback
Determines whether the given string represents a valid server path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static bool IsValidUserVisibleFullServerPath(
    string strPath
)
Visual Basic
Public Shared Function IsValidUserVisibleFullServerPath ( _
    strPath As String _
) As Boolean
Visual C++
public:
static bool IsValidUserVisibleFullServerPath(
    String^ strPath
)

Parameters

strPath
Type: System..::..String
The path, in string form

Return Value

True if the given path is a valid server path, false otherwise.

Remarks

ServerPaths must refer to Revit models.

ServerPaths are relative to the central server location, and are of the form "RSN://{HostNodeName}/{model_path}".

The {model_path} portion is a relative path to a Revit model. For example:

  • RSN://EXS/hospital.rvt
  • RSN://EXS.autodesk.com/Old Files/hotel2.rvt
  • RSN://EXS.autodesk.com/Old Files/Last Week/Tuesday\hotel2.rvt
are all valid server paths.
  • //EXS/Old Files/.rvt
  • EXS/hospital
are not valid server paths. If this function returns false, it does not necessarily mean the given path is a file path. It may be a malformed string.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ModelPathUtils Class


ModelPathUtils Properties

[image] [image]

Revit 2024 API
ModelPathUtils Properties
ModelPathUtils Class See Also Send Feedback

The ModelPathUtils type exposes the following members.

Properties

Name | Description
CloudRegionEMEA | The name of cloud region EMEA.
CloudRegionUS | The name of cloud region US.

See Also

ModelPathUtils Class


CloudRegionEMEA Property

[image]

Revit 2024 API
ModelPathUtils..::..CloudRegionEMEA Property
ModelPathUtils Class See Also Send Feedback
The name of cloud region EMEA.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static string CloudRegionEMEA { get; }
Visual Basic
Public Shared ReadOnly Property CloudRegionEMEA As String
    Get
Visual C++
public:
static property String^ CloudRegionEMEA {
    String^ get ();
}

See Also

ModelPathUtils Class


CloudRegionUS Property

[image]

Revit 2024 API
ModelPathUtils..::..CloudRegionUS Property
ModelPathUtils Class See Also Send Feedback
The name of cloud region US.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static string CloudRegionUS { get; }
Visual Basic
Public Shared ReadOnly Property CloudRegionUS As String
    Get
Visual C++
public:
static property String^ CloudRegionUS {
    String^ get ();
}

See Also

ModelPathUtils Class


ModelText Class

[image]

Revit 2024 API
ModelText Class
Members See Also Send Feedback
A model text element in an Autodesk Revit family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class ModelText : Element
Visual Basic
Public Class ModelText _
    Inherits Element
Visual C++
public ref class ModelText : public Element

Remarks

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ModelText

See Also

ModelText Members


ModelText Methods

[image] [image]

Revit 2024 API
ModelText Methods
ModelText Class See Also Send Feedback

The ModelText type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the model text in a family document.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetVisibility | Sets the visibility for the model text in a family document.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ModelText Class


GetVisibility Method

[image]

Revit 2024 API
ModelText..::..GetVisibility Method
ModelText Class See Also Send Feedback
Gets the visibility for the model text in a family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyElementVisibility GetVisibility()
Visual Basic
Public Function GetVisibility As FamilyElementVisibility
Visual C++
public:
FamilyElementVisibility^ GetVisibility()

Return Value

A copy of visibility settings for the model text in a family document.

See Also

ModelText Class


ModelText Properties

[image] [image]

Revit 2024 API
ModelText Properties
ModelText Class See Also Send Feedback

The ModelText type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | Depth | The depth of the model text.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | HorizontalAlignment | The horizontal alignment.
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an instance within project. (Overrides Element..::..Location.)
Public property | ModelTextType | The type for the model text.
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Subcategory | The subcategory.
Public property | Text | The text string in the model text.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ModelText Class


Depth Property

[image]

Revit 2024 API
ModelText..::..Depth Property
ModelText Class See Also Send Feedback
The depth of the model text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double Depth { get; set; }
Visual Basic
Public Property Depth As Double
    Get
    Set
Visual C++
public:
property double Depth {
    double get ();
    void set (double value);
}

See Also

ModelText Class


HorizontalAlignment Property

[image]

Revit 2024 API
ModelText..::..HorizontalAlignment Property
ModelText Class See Also Send Feedback
The horizontal alignment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public HorizontalAlign HorizontalAlignment { get; set; }
Visual Basic
Public Property HorizontalAlignment As HorizontalAlign
    Get
    Set
Visual C++
public:
property HorizontalAlign HorizontalAlignment {
    HorizontalAlign get ();
    void set (HorizontalAlign value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when an invalid value is assigned to the property.

See Also

ModelText Class


Location Property

[image]

Revit 2024 API
ModelText..::..Location Property
ModelText Class See Also Send Feedback
This property is used to find the physical location of an instance within project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public override Location Location { get; }
Visual Basic
Public Overrides ReadOnly Property Location As Location
    Get
Visual C++
public:
virtual property Location^ Location {
    Location^ get () override;
}

See Also

ModelText Class


ModelTextType Property

[image]

Revit 2024 API
ModelText..::..ModelTextType Property
ModelText Class See Also Send Feedback
The type for the model text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ModelTextType ModelTextType { get; set; }
Visual Basic
Public Property ModelTextType As ModelTextType
    Get
    Set
Visual C++
public:
property ModelTextType^ ModelTextType {
    ModelTextType^ get ();
    void set (ModelTextType^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when nullNothingnullptra null reference (Nothing in Visual Basic) is assigned to this property.

See Also

ModelText Class


Parameter Property

[image] [image]

Revit 2024 API
ModelText..::..Parameter Property
ModelText Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ModelText Class
ModelText Members


Subcategory Property

[image]

Revit 2024 API
ModelText..::..Subcategory Property
ModelText Class See Also Send Feedback
The subcategory.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Category Subcategory { get; set; }
Visual Basic
Public Property Subcategory As Category
    Get
    Set
Visual C++
public:
property Category^ Subcategory {
    Category^ get ();
    void set (Category^ value);
}

Remarks

The subcategory can be set to either the family category or one of its subcategories.

See Also

ModelText Class


Text Property

[image]

Revit 2024 API
ModelText..::..Text Property
ModelText Class See Also Send Feedback
The text string in the model text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when nullNothingnullptra null reference (Nothing in Visual Basic) is assigned to text.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when an empty string is assigned to text.

See Also

ModelText Class


ModelTextType Class

[image]

Revit 2024 API
ModelTextType Class
Members See Also Send Feedback
A model text type symbol in the Autodesk Revit Family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class ModelTextType : ElementType
Visual Basic
Public Class ModelTextType _
    Inherits ElementType
Visual C++
public ref class ModelTextType : public ElementType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..ModelTextType

See Also

ModelTextType Members


ModelTextType Properties

[image] [image]

Revit 2024 API
ModelTextType Properties
ModelTextType Class See Also Send Feedback

The ModelTextType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ModelTextType Class


Parameter Property

[image] [image]

Revit 2024 API
ModelTextType..::..Parameter Property
ModelTextType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ModelTextType Class
ModelTextType Members


ModelUpdatesStatus Enumeration

[image]

Revit 2024 API
ModelUpdatesStatus Enumeration
See Also Send Feedback
Indicates whether an element in the current model has additional user changes in the central model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public enum ModelUpdatesStatus
Visual Basic
Public Enumeration ModelUpdatesStatus
Visual C++
public enum class ModelUpdatesStatus

Members

Member name | Description
CurrentWithCentral | The element has no additional changes in the central model.
NotYetInCentral | The element is new in the current model and has not been saved to the central model. Note that this status will apply to newly created elements even if they are created in the central model.
DeletedInCentral | The element has been deleted in the central model.
UpdatedInCentral | The element has additional user changes in the central model. A reload latest will be required before it can be modified in the current model.

Remarks

Note that this status only indicates that the element has user changes in the central model. A user change is typically an action specifically taken by a user. Making a user change to an element requires that the user making the change reload all other user changes made to the element in the central model. Making a user change also causes the element to be checked out to the current user so other users will not be able to make user changes to the same element.

Elements can also be modified by system changes. A system change is one which is done automatically by Revit to fully update the model after a user change occurs. Users may make changes to an element in their local model even if the element contains additional system changes in the central model.

Example: Suppose Alice and Bob are working on the same model. Alice moves a wall which contains windows. Then Alice synchronizes with the central file. The wall was explicitly changed by Alice and so it will report as "UpdatedInCentral" in Bob's model. Bob would have to reload latest before he could make user changes to that wall. In contrast, Revit automatically moved the windows with the wall, so the windows do not contain any user changes. The windows would therefore report "CurrentWithCentral" and Bob would be allowed to modify them in his local model without reloading latest.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


ModifierType Enumeration

[image]

Revit 2024 API
ModifierType Enumeration
See Also Send Feedback
An enumerated type listing options to appear in the exported layer name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014
Since: 2014

Syntax

C#
public enum ModifierType
Visual Basic
Public Enumeration ModifierType
Visual C++
public enum class ModifierType

Members

Member name | Description
UnknownType | An unknown (default) type of modifier, not acceptable for assignment.
Category | Signals that the name of the category will appear in the layer name.
Custom1 | Signals that the first custom string will appear in the layer name.
Custom2 | Signals that the second custom string will appear in the layer name.
Custom3 | Signals that the third custom string will appear in the layer name.
FireRating | Signals that the value of fire rating will appear in the layer name.
Function | Signals that the value of function will appear in the layer name.
Level | Signals that the name of the level will appear in the layer name.
PhaseCreated | Signals that the name of the created phase will appear in the layer name.
PhaseDemolished | Signals that the name of the demolition phase will appear in the layer name.
PhaseStatus | Signals that the value of of phase status will appear in the layer name.
StructuralMaterialType | Signals that the value of structural material type will appear in the layer name.
StructuralUsage | Signals that the value of structural usage will appear in the layer name.
SystemName | Signals that the system name will appear in the layer name.
SystemType | Signals that the system type will appear in the layer name.
Underlay | Signals that the name of the underlay will appear in the layer name.
ViewType | Signals that the view type will appear in the layer name.
Workset | Signals that the name of the workset will appear in the layer name.
AnalyzesAs | Signals that the value of the AnalyzesAs parameter will appear in the layer name.
SystemClassification | Signals that the system classification will appear in the layer name.
DomainType | Signals that the domain type will appear in the layer name.
FabricationService | Signals that the fabrication service will appear in the layer name.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


Mullion Class

[image]

Revit 2024 API
Mullion Class
Members See Also Send Feedback
Represents a CurtainGrid within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class Mullion : FamilyInstance
Visual Basic
Public Class Mullion _
    Inherits FamilyInstance
Visual C++
public ref class Mullion : public FamilyInstance

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..Instance
Autodesk.Revit.DB..::..FamilyInstance
Autodesk.Revit.DB..::..Mullion

See Also

Mullion Members


Mullion Methods

[image] [image]

Revit 2024 API
Mullion Methods
Mullion Class See Also Send Feedback

The Mullion type exposes the following members.

Methods

 | Name | Description
Public method | AddCoping | Adds a coping (cut) to a steel beam. (Inherited from FamilyInstance.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | BreakMullion | This method is used to break the current Mullion at ends with its neighboring mullions.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | flipFacing | The orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true. (Inherited from FamilyInstance.)
Public method | FlipFromToRoom | Flips the settings of "From Room" and "To Room" for the door or window instance. (Inherited from FamilyInstance.)
Public method | flipHand | The orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true. (Inherited from FamilyInstance.)
Public method | GetCopingIds | Lists the elements currently used as coping cutters for this element. (Inherited from FamilyInstance.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetFamilyPointPlacementReferences | Returns the Point Placement References for the Family Instance. (Inherited from FamilyInstance.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetOriginalGeometry | Returns the original geometry of the instance, before the instance is modified by joins, cuts, coping, extensions, or other post-processing. (Inherited from FamilyInstance.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetReferenceByName | Gets the family instance reference corresponding to the named reference plane in the instance's family. (Inherited from FamilyInstance.)
Public method | GetReferenceName | Gets the name of the reference plane in the family corresponding to the given family instance reference. (Inherited from FamilyInstance.)
Public method | GetReferences | Gets family instance references corresponding to the reference planes or reference lines of the given reference type in the instance's family. (Inherited from FamilyInstance.)
Public method | GetReferenceType | Gets the type of the reference plane or reference line in the instance's family corresponding to the given family instance reference. (Inherited from FamilyInstance.)
Public method | GetSpatialElementCalculationPoint | Gets the location of the calculation point for this instance. (Inherited from FamilyInstance.)
Public method | GetSpatialElementFromToCalculationPoints | Gets the locations for the calculation points for this instance. (Inherited from FamilyInstance.)
Public method | GetSubComponentIds | Gets the sub component ElementIds of the current family instance. (Inherited from FamilyInstance.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetSweptProfile | Gets the object that describes the profile that is swept along the driving curve for this instance. (Inherited from FamilyInstance.)
Public method | GetTotalTransform | Gets the total transform, which includes the true north transform for instances like import instances. (Inherited from Instance.)
Public method | GetTransform | Gets the transform of the instance. (Inherited from Instance.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasModifiedGeometry | Identifies if the geometry of this FamilyInstance has been modified from the automatically generated default. (Inherited from FamilyInstance.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasSweptProfile | Indicates if this instance can be represented as a swept profile. (Inherited from FamilyInstance.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | JoinMullion | This method is used to control the join condition the current Mullion with its neighboring mullions.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | RemoveCoping | Removes a coping (cut) from a steel beam. (Inherited from FamilyInstance.)
Public method | rotate | The family instance will be flipped by 180 degrees. If it can not be rotated, return false, otherwise return true. (Inherited from FamilyInstance.)
Public method | SetCopingIds | Specifies the set of coping cutters on this element. (Inherited from FamilyInstance.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | Split | Splits the family instance element at a point on its defining curve. (Inherited from FamilyInstance.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Mullion Class


BreakMullion Method

[image]

Revit 2024 API
Mullion..::..BreakMullion Method
Mullion Class See Also Send Feedback
This method is used to break the current Mullion at ends with its neighboring mullions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void BreakMullion()
Visual Basic
Public Sub BreakMullion
Visual C++
public:
void BreakMullion()

Remarks

The mullions being perpendicular to it will be joined accordingly.

See Also

Mullion Class


JoinMullion Method

[image]

Revit 2024 API
Mullion..::..JoinMullion Method
Mullion Class See Also Send Feedback
This method is used to control the join condition the current Mullion with its neighboring mullions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void JoinMullion()
Visual Basic
Public Sub JoinMullion
Visual C++
public:
void JoinMullion()

Remarks

The mullions being perpendicular to it will be broken accordingly.

See Also

Mullion Class


Mullion Properties

[image] [image]

Revit 2024 API
Mullion Properties
Mullion Class See Also Send Feedback

The Mullion type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanFlipFacing | Property to test whether the orientation of family instance facing can be flipped. (Inherited from FamilyInstance.)
Public property | CanFlipHand | Property to test whether the orientation of family instance hand can be flipped. (Inherited from FamilyInstance.)
Public property | CanFlipWorkPlane | Identifies if the instance can flip its work plane. (Inherited from FamilyInstance.)
Public property | CanRotate | Property to test whether the family instance can be rotated by 180 degrees. (Inherited from FamilyInstance.)
Public property | CanSplit | Identifies whether a particular family instance can be split at a point on it's defining curve (by Split(Double)). (Inherited from FamilyInstance.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | ExtensionUtility | Property to check whether the instance can be extended and return the interface for extension operation. (Inherited from FamilyInstance.)
Public property | FacingFlipped | Property to test whether the orientation of family instance facing is flipped. (Inherited from FamilyInstance.)
Public property | FacingOrientation | Property to get the orientation of family instance facing. (Inherited from FamilyInstance.)
Public property | FromRoom | The "From Room" set for the door or window in the last phase of the project. (Inherited from FamilyInstance.)
Public property | FromRoom[([( Phase])]) | (Inherited from FamilyInstance.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | HandFlipped | Property to test whether the orientation of family instance hand is flipped. (Inherited from FamilyInstance.)
Public property | HandOrientation | Property to get the orientation of family instance hand. (Inherited from FamilyInstance.)
Public property | HasSpatialElementCalculationPoint | Identifies if this instance has a single SpatialElementCalculationPoint used as the search point for Revit to identify if the instance is inside a room or space. (Inherited from FamilyInstance.)
Public property | HasSpatialElementFromToCalculationPoints | Identifies if this instance has a pair of SpatialElementCalculationPoints used as the search points for Revit to identify if the instance lies between up to two rooms or spaces. (Inherited from FamilyInstance.)
Public property | Host | If the instance is contained within another element, this property returns the containing element. An instance that is face hosted will return the element containing the face. (Inherited from FamilyInstance.)
Public property | HostFace | Property to get the reference to the host face of family instance. (Inherited from FamilyInstance.)
Public property | HostParameter | If the instance is hosted by a wall, this property returns the parameter value of the insertion point of the instance along the wall's location curve, as long as the family of the instance isn't work plane based. (Inherited from FamilyInstance.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | Invisible | Property to test whether the family instance is invisible. (Inherited from FamilyInstance.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsSlantedColumn | Indicates if the family instance is a slanted column. (Inherited from FamilyInstance.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | IsWorkPlaneFlipped | Identifies if the instance's work plane is flipped. (Inherited from FamilyInstance.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an instance within project. (Inherited from FamilyInstance.)
Public property | LocationCurve | This method get the curve location of the current Mullion.
Public property | Lock | Get - to get whether the Mullion line is locked. Set - Lock/unlock the Mullion.
Public property | Lockable | Get - to get whether the Mullion can be lock or unlock.
Public property | MEPModel | Retrieves the MEP model for the family instance. (Inherited from FamilyInstance.)
Public property | Mirrored | Property to test whether the family instance is mirrored. (only one axis is flipped) (Inherited from FamilyInstance.)
Public property | MullionType | The MullionType style of this Mullion. Get - to access type of mullion Set - change type of mullion. If the mullion is locked, InvalidOperationException exception will be thrown.
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Room | The room in which the instance is located (during the last phase of the project). (Inherited from FamilyInstance.)
Public property | Room[([( Phase])]) | (Inherited from FamilyInstance.)
Public property | Space | The space in which the instance is located (during the last phase of the project). (Inherited from FamilyInstance.)
Public property | Space[([( Phase])]) | (Inherited from FamilyInstance.)
Public property | StructuralMaterialId | Identifies the material that defines the instance's structural analysis properties. (Inherited from FamilyInstance.)
Public property | StructuralMaterialType | This property returns the physical material from which the instance is made. (Inherited from FamilyInstance.)
Public property | StructuralType | Provides the primary structural type of the instance, such as beam or column etc. (Inherited from FamilyInstance.)
Public property | StructuralUsage | Provides the primary structural usage of the instance, such as brace, girder etc. (Inherited from FamilyInstance.)
Public property | SuperComponent | Property to get the super component of current family instance. (Inherited from FamilyInstance.)
Public property | Symbol | Returns or changes the FamilySymbol object that represents the type of the instance. (Inherited from FamilyInstance.)
Public property | ToRoom | The "To Room" set for the door or window in the last phase of the project. (Inherited from FamilyInstance.)
Public property | ToRoom[([( Phase])]) | (Inherited from FamilyInstance.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Mullion Class


FromRoom Property

[image] [image]

Revit 2024 API
Mullion..::..FromRoom Property
Mullion Class See Also Send Feedback
The "From Room" set for the door or window.

Overload List

 | Name | Description
Public property | FromRoom | The "From Room" set for the door or window in the last phase of the project. (Inherited from FamilyInstance.)
Public property | FromRoom[([( Phase])]) | (Inherited from FamilyInstance.)

See Also

Mullion Class
Mullion Members


LocationCurve Property

[image]

Revit 2024 API
Mullion..::..LocationCurve Property
Mullion Class See Also Send Feedback
This method get the curve location of the current Mullion.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Curve LocationCurve { get; }
Visual Basic
Public ReadOnly Property LocationCurve As Curve
    Get
Visual C++
public:
property Curve^ LocationCurve {
    Curve^ get ();
}

See Also

Mullion Class


Lock Property

[image]

Revit 2024 API
Mullion..::..Lock Property
Mullion Class See Also Send Feedback
Get - to get whether the Mullion line is locked. Set - Lock/unlock the Mullion.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool Lock { get; set; }
Visual Basic
Public Property Lock As Boolean
    Get
    Set
Visual C++
public:
property bool Lock {
    bool get ();
    void set (bool value);
}

See Also

Mullion Class


Lockable Property

[image]

Revit 2024 API
Mullion..::..Lockable Property
Mullion Class See Also Send Feedback
Get - to get whether the Mullion can be lock or unlock.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool Lockable { get; }
Visual Basic
Public ReadOnly Property Lockable As Boolean
    Get
Visual C++
public:
property bool Lockable {
    bool get ();
}

See Also

Mullion Class


Parameter Property

[image] [image]

Revit 2024 API
Mullion..::..Parameter Property
Mullion Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Mullion Class
Mullion Members


Room Property

[image] [image]

Revit 2024 API
Mullion..::..Room Property
Mullion Class See Also Send Feedback
The room in which the instance is located.

Overload List

 | Name | Description
Public property | Room | The room in which the instance is located (during the last phase of the project). (Inherited from FamilyInstance.)
Public property | Room[([( Phase])]) | (Inherited from FamilyInstance.)

See Also

Mullion Class
Mullion Members


ToRoom Property

[image] [image]

Revit 2024 API
Mullion..::..ToRoom Property
Mullion Class See Also Send Feedback
The "To Room" set for the door or window.

Overload List

 | Name | Description
Public property | ToRoom | The "To Room" set for the door or window in the last phase of the project. (Inherited from FamilyInstance.)
Public property | ToRoom[([( Phase])]) | (Inherited from FamilyInstance.)

See Also

Mullion Class
Mullion Members


MullionType Methods

[image] [image]

Revit 2024 API
MullionType Methods
MullionType Class See Also Send Feedback

The MullionType type exposes the following members.

Methods

 | Name | Description
Public method | Activate | Activates the symbol to ensure that its geometry is accessible. (Inherited from FamilySymbol.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveStructuralSection | Identifies if this FamilySymbol can have a structural section. (Inherited from FamilySymbol.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetFamilyPointLocations | Returns the Point Locations for the Family Symbol. (Inherited from FamilySymbol.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetStructuralSection | Gets the structural section from element. (Inherited from FamilySymbol.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetThermalProperties | Gets the thermal properties for the given FamilySymbol. (Inherited from FamilySymbol.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasThermalProperties | Identifies if this FamilySymbol can include thermal properties. (Inherited from FamilySymbol.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetStructuralSection | Sets the structural section in element. (Inherited from FamilySymbol.)
Public method | SetThermalProperties | Sets the thermal properties for the given FamilySymbol. (Inherited from FamilySymbol.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MullionType Class


Parameter Property

[image] [image]

Revit 2024 API
MullionType..::..Parameter Property
MullionType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

MullionType Class
MullionType Members


MullionTypeSet Class

[image]

Revit 2024 API
MullionTypeSet Class
Members See Also Send Feedback
A set that contains mullion types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class MullionTypeSet : APIObject,
    IEnumerable
Visual Basic
Public Class MullionTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class MullionTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..MullionTypeSet

See Also

MullionTypeSet Members


MullionTypeSet Methods

[image] [image]

Revit 2024 API
MullionTypeSet Methods
MullionTypeSet Class See Also Send Feedback

The MullionTypeSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every mullion type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a mullion type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified mullion type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified mullion type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MullionTypeSet Class


Clear Method

[image]

Revit 2024 API
MullionTypeSet..::..Clear Method
MullionTypeSet Class See Also Send Feedback
Removes every mullion type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

MullionTypeSet Class


Contains Method

[image]

Revit 2024 API
MullionTypeSet..::..Contains Method
MullionTypeSet Class See Also Send Feedback
Tests for the existence of a mullion type within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool Contains(
    MullionType item
)
Visual Basic
Public Overridable Function Contains ( _
    item As MullionType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    MullionType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..MullionType
The mullion type to be searched for.

Return Value

The Contains method returns True if the mullion type is within the set, otherwise False.

See Also

MullionTypeSet Class


GetEnumerator Method

[image]

Revit 2024 API
MullionTypeSet..::..GetEnumerator Method
MullionTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

MullionTypeSet Class


Insert Method

[image]

Revit 2024 API
MullionTypeSet..::..Insert Method
MullionTypeSet Class See Also Send Feedback
Insert the specified mullion type into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool Insert(
    MullionType item
)
Visual Basic
Public Overridable Function Insert ( _
    item As MullionType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    MullionType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..MullionType
The mullion type to be inserted into the set.

Return Value

Returns whether the mullion type was inserted into the set.

See Also

MullionTypeSet Class


ReverseIterator Method

[image]

Revit 2024 API
MullionTypeSet..::..ReverseIterator Method
MullionTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual MullionTypeSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As MullionTypeSetIterator
Visual C++
public:
virtual MullionTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

MullionTypeSet Class


IsEmpty Property

[image]

Revit 2024 API
MullionTypeSet..::..IsEmpty Property
MullionTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

MullionTypeSet Class


Size Property

[image]

Revit 2024 API
MullionTypeSet..::..Size Property
MullionTypeSet Class See Also Send Feedback
Returns the number of mullion types that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

MullionTypeSet Class


MullionTypeSetIterator Class

[image]

Revit 2024 API
MullionTypeSetIterator Class
Members See Also Send Feedback
An iterator to a mullion type set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public abstract class MullionTypeSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class MullionTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class MullionTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..MullionTypeSetIterator

See Also

MullionTypeSetIterator Members


MullionTypeSetIterator Members

[image] [image]

Revit 2024 API
MullionTypeSetIterator Members
MullionTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The MullionTypeSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | MullionTypeSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

MullionTypeSetIterator Class


MullionTypeSetIterator Constructor

[image]

Revit 2024 API
MullionTypeSetIterator Constructor
MullionTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public MullionTypeSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
MullionTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

MullionTypeSetIterator Class


MullionTypeSetIterator Methods

[image] [image]

Revit 2024 API
MullionTypeSetIterator Methods
MullionTypeSetIterator Class See Also Send Feedback

The MullionTypeSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MullionTypeSetIterator Class


MoveNext Method

[image]

Revit 2024 API
MullionTypeSetIterator..::..MoveNext Method
MullionTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

MullionTypeSetIterator Class


Current Property

[image]

Revit 2024 API
MullionTypeSetIterator..::..Current Property
MullionTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

MullionTypeSetIterator Class


MultipleValuesIndicationSettings Members

[image] [image]

Revit 2024 API
MultipleValuesIndicationSettings Members
MultipleValuesIndicationSettings Class Methods Properties See Also Send Feedback

The MultipleValuesIndicationSettings type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
 | GetMultipleValuesIndicationSettings | Returns the MultipleValuesIndicationSettings element for a given document.
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | Custom | If true, CustomValue is used as multiple values indication, otherwise a hardcoded standard value.
Public property | CustomValue | Value used as multiple values indication if Custom is set to true.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | Value | Value to be used as multiple values indication in the document. If Custom is true, returns CustomValue, otherwise returns a hardcoded standard value.
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

MultipleValuesIndicationSettings Class


GetMultipleValuesIndicationSettings Method

[image]

Revit 2024 API
MultipleValuesIndicationSettings..::..GetMultipleValuesIndicationSettings Method
MultipleValuesIndicationSettings Class See Also Send Feedback
Returns the MultipleValuesIndicationSettings element for a given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public static MultipleValuesIndicationSettings GetMultipleValuesIndicationSettings(
    Document cda
)
Visual Basic
Public Shared Function GetMultipleValuesIndicationSettings ( _
    cda As Document _
) As MultipleValuesIndicationSettings
Visual C++
public:
static MultipleValuesIndicationSettings^ GetMultipleValuesIndicationSettings(
    Document^ cda
)

Parameters

cda
Type: Autodesk.Revit.DB..::..Document
The document for which to get the MultipleValuesIndicationSettings element.

Return Value

Returns the MultipleValuesIndicationSettings element in project documents or nullNothingnullptra null reference (Nothing in Visual Basic) for family documents

.

Remarks

Project documents have a MultipleValuesIndicationSettings element, one per document. Family documents do not have MultipleValuesIndicationSettings elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

MultipleValuesIndicationSettings Class


MultipleValuesIndicationSettings Properties

[image] [image]

Revit 2024 API
MultipleValuesIndicationSettings Properties
MultipleValuesIndicationSettings Class See Also Send Feedback

The MultipleValuesIndicationSettings type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | Custom | If true, CustomValue is used as multiple values indication, otherwise a hardcoded standard value.
Public property | CustomValue | Value used as multiple values indication if Custom is set to true.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | Value | Value to be used as multiple values indication in the document. If Custom is true, returns CustomValue, otherwise returns a hardcoded standard value.
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

MultipleValuesIndicationSettings Class


Custom Property

[image]

Revit 2024 API
MultipleValuesIndicationSettings..::..Custom Property
MultipleValuesIndicationSettings Class See Also Send Feedback
If true, CustomValue is used as multiple values indication, otherwise a hardcoded standard value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public bool Custom { get; set; }
Visual Basic
Public Property Custom As Boolean
    Get
    Set
Visual C++
public:
property bool Custom {
    bool get ();
    void set (bool value);
}

See Also

MultipleValuesIndicationSettings Class


CustomValue Property

[image]

Revit 2024 API
MultipleValuesIndicationSettings..::..CustomValue Property
MultipleValuesIndicationSettings Class See Also Send Feedback
Value used as multiple values indication if Custom is set to true.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public string CustomValue { get; set; }
Visual Basic
Public Property CustomValue As String
    Get
    Set
Visual C++
public:
property String^ CustomValue {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

MultipleValuesIndicationSettings Class


Parameter Property

[image] [image]

Revit 2024 API
MultipleValuesIndicationSettings..::..Parameter Property
MultipleValuesIndicationSettings Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

MultipleValuesIndicationSettings Class
MultipleValuesIndicationSettings Members


Value Property

[image]

Revit 2024 API
MultipleValuesIndicationSettings..::..Value Property
MultipleValuesIndicationSettings Class See Also Send Feedback
Value to be used as multiple values indication in the document. If Custom is true, returns CustomValue, otherwise returns a hardcoded standard value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public string Value { get; }
Visual Basic
Public ReadOnly Property Value As String
    Get
Visual C++
public:
property String^ Value {
    String^ get ();
}

See Also

MultipleValuesIndicationSettings Class


MultiReferenceAnnotation Class

[image]

Revit 2024 API
MultiReferenceAnnotation Class
Members See Also Send Feedback
Multi-reference annotations are annotations pointing to more than one reference, consisting of a dimension and associated tag.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class MultiReferenceAnnotation : Element
Visual Basic
Public Class MultiReferenceAnnotation _
    Inherits Element
Visual C++
public ref class MultiReferenceAnnotation : public Element

Remarks

Multi-reference annotations can be used to label and dimension Rebar elements, and are labeled in the user interface as "Multi-rebar annotations". MultiReferenceAnnotation is the annotation object instance. This class includes a reference to the associated dimension and tag element.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..MultiReferenceAnnotation

See Also

MultiReferenceAnnotation Members


MultiReferenceAnnotation Members

[image] [image]

Revit 2024 API
MultiReferenceAnnotation Members
MultiReferenceAnnotation Class Methods Properties See Also Send Feedback

The MultiReferenceAnnotation type exposes the following members.

Methods

 | Name | Description
 | AreElementsValidForMultiReferenceAnnotation | The method validates if the input elements match the element category id for the MultiReferenceAnnotationType.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
 | AreReferencesValidForLinearDimension | If the DimensionStyleType is Linear, validates that the references are valid for an aligned multi-reference annotation.
 | AreReferencesValidForLinearFixedDimension | If the DimensionStyleType is LinearFixed, validates that the references are valid for an aligned multi-reference annotation.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create | Creates a new MultiReferenceAnnotation.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
 | Is3DViewValidForDimension | If the DimensionStyle is LinearFixed, it cannot be created in a 3D View. If the DimensionStyle is Linear, it cannot be created in a 3D View if the view direction is perpendicular to the current work plane normal. Returns true if the ownerViewId is not a 3D view.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
 | IsLinearFixedDimensionDirectionValid | If the DimensionStyleType is LinearFixed, this function verifies that the dimension line direction matches either the view's vertical or horizontal direction.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DimensionId | The child dimension owned by this multi-reference annotation.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | TagId | The child IndependentTag owned by this multi-reference annotation.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

MultiReferenceAnnotation Class


MultiReferenceAnnotation Methods

[image] [image]

Revit 2024 API
MultiReferenceAnnotation Methods
MultiReferenceAnnotation Class See Also Send Feedback

The MultiReferenceAnnotation type exposes the following members.

Methods

 | Name | Description
 | AreElementsValidForMultiReferenceAnnotation | The method validates if the input elements match the element category id for the MultiReferenceAnnotationType.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
 | AreReferencesValidForLinearDimension | If the DimensionStyleType is Linear, validates that the references are valid for an aligned multi-reference annotation.
 | AreReferencesValidForLinearFixedDimension | If the DimensionStyleType is LinearFixed, validates that the references are valid for an aligned multi-reference annotation.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create | Creates a new MultiReferenceAnnotation.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
 | Is3DViewValidForDimension | If the DimensionStyle is LinearFixed, it cannot be created in a 3D View. If the DimensionStyle is Linear, it cannot be created in a 3D View if the view direction is perpendicular to the current work plane normal. Returns true if the ownerViewId is not a 3D view.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
 | IsLinearFixedDimensionDirectionValid | If the DimensionStyleType is LinearFixed, this function verifies that the dimension line direction matches either the view's vertical or horizontal direction.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MultiReferenceAnnotation Class


AreElementsValidForMultiReferenceAnnotation Method

[image]

Revit 2024 API
MultiReferenceAnnotation..::..AreElementsValidForMultiReferenceAnnotation Method
MultiReferenceAnnotation Class See Also Send Feedback
The method validates if the input elements match the element category id for the MultiReferenceAnnotationType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public static bool AreElementsValidForMultiReferenceAnnotation(
    Document document,
    MultiReferenceAnnotationOptions options
)
Visual Basic
Public Shared Function AreElementsValidForMultiReferenceAnnotation ( _
    document As Document, _
    options As MultiReferenceAnnotationOptions _
) As Boolean
Visual C++
public:
static bool AreElementsValidForMultiReferenceAnnotation(
    Document^ document,
    MultiReferenceAnnotationOptions^ options
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document for the multi-reference annotation.
options
Type: Autodesk.Revit.DB..::..MultiReferenceAnnotationOptions
The creation options for the new MultiReferenceAnnotation.

Return Value

Returns true if the input elements match the element category id for the MultiReferenceAnnotationType, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

MultiReferenceAnnotation Class


AreReferencesValidForLinearDimension Method

[image]

Revit 2024 API
MultiReferenceAnnotation..::..AreReferencesValidForLinearDimension Method
MultiReferenceAnnotation Class See Also Send Feedback
If the DimensionStyleType is Linear, validates that the references are valid for an aligned multi-reference annotation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static bool AreReferencesValidForLinearDimension(
    Document document,
    ElementId ownerViewId,
    MultiReferenceAnnotationOptions options
)
Visual Basic
Public Shared Function AreReferencesValidForLinearDimension ( _
    document As Document, _
    ownerViewId As ElementId, _
    options As MultiReferenceAnnotationOptions _
) As Boolean
Visual C++
public:
static bool AreReferencesValidForLinearDimension(
    Document^ document,
    ElementId^ ownerViewId,
    MultiReferenceAnnotationOptions^ options
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document for the multi-reference annotation.
ownerViewId
Type: Autodesk.Revit.DB..::..ElementId
The view in which the multi-reference annotation will appear.
options
Type: Autodesk.Revit.DB..::..MultiReferenceAnnotationOptions
Options containing the references which the dimension will witness.

Return Value

True DimensionStyleType does not equal Linear or if an aligned multi-reference annotation can be created from the references.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

MultiReferenceAnnotation Class


AreReferencesValidForLinearFixedDimension Method

[image]

Revit 2024 API
MultiReferenceAnnotation..::..AreReferencesValidForLinearFixedDimension Method
MultiReferenceAnnotation Class See Also Send Feedback
If the DimensionStyleType is LinearFixed, validates that the references are valid for an aligned multi-reference annotation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static bool AreReferencesValidForLinearFixedDimension(
    Document document,
    ElementId ownerViewId,
    MultiReferenceAnnotationOptions options
)
Visual Basic
Public Shared Function AreReferencesValidForLinearFixedDimension ( _
    document As Document, _
    ownerViewId As ElementId, _
    options As MultiReferenceAnnotationOptions _
) As Boolean
Visual C++
public:
static bool AreReferencesValidForLinearFixedDimension(
    Document^ document,
    ElementId^ ownerViewId,
    MultiReferenceAnnotationOptions^ options
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document for the multi-reference annotation.
ownerViewId
Type: Autodesk.Revit.DB..::..ElementId
The view in which the multi-reference annotation will appear.
options
Type: Autodesk.Revit.DB..::..MultiReferenceAnnotationOptions
Options containing the references which the dimension will witness.

Return Value

True DimensionStyleType does not equal LinearFixed or if an aligned multi-reference annotation can be created from the references.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

MultiReferenceAnnotation Class


Create Method

[image]

Revit 2024 API
MultiReferenceAnnotation..::..Create Method
MultiReferenceAnnotation Class See Also Send Feedback
Creates a new MultiReferenceAnnotation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static MultiReferenceAnnotation Create(
    Document document,
    ElementId ownerViewId,
    MultiReferenceAnnotationOptions options
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    ownerViewId As ElementId, _
    options As MultiReferenceAnnotationOptions _
) As MultiReferenceAnnotation
Visual C++
public:
static MultiReferenceAnnotation^ Create(
    Document^ document,
    ElementId^ ownerViewId,
    MultiReferenceAnnotationOptions^ options
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new MultiReferenceAnnotation will be added.
ownerViewId
Type: Autodesk.Revit.DB..::..ElementId
The view in which the multi-reference annotation will appear.
options
Type: Autodesk.Revit.DB..::..MultiReferenceAnnotationOptions
The creation options for the new MultiReferenceAnnotation.

Return Value

The new MultiReferenceAnnotation.

Remarks

New linear Dimension and IndependentTag elements will be created as children of the MultiReferenceAnnotation. The IndependentTag will only be created if the MultiReferenceAnnotationType property TagTypeId is valid.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- The ElementId ownerViewId does not correspond to a View. -or- The ElementId ownerViewId is a view template. -or- The ElementId ownerViewId is a perspective view. -or- The 3D view ownerViewId is not locked. -or- The input 3D view cannot be used to place a MultiReferenceAnnotation object. -or- dimension line direction and dimension plane normal are not orthogonal. -or- There is at least one element that doesn't match the reference category of the MultiReferenceAnnotationType, or there are no elements. -or- for DimensionStyleType LinearFixed dimensions the dimension line direction must be parallel to either the view's vertical or horizontal direction. -or- some references can't be used with a DimensionStyleType Linear dimension of this direction. References must either appear as points in the view or be linear references which are perpendicular to the dimension line. -or- some references can't be used with a DimensionStyleType LinearFixed dimension. Only references which appear as points in the view can be used.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

MultiReferenceAnnotation Class


Is3DViewValidForDimension Method

[image]

Revit 2024 API
MultiReferenceAnnotation..::..Is3DViewValidForDimension Method
MultiReferenceAnnotation Class See Also Send Feedback
If the DimensionStyle is LinearFixed, it cannot be created in a 3D View. If the DimensionStyle is Linear, it cannot be created in a 3D View if the view direction is perpendicular to the current work plane normal. Returns true if the ownerViewId is not a 3D view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public static bool Is3DViewValidForDimension(
    Document document,
    ElementId ownerViewId,
    MultiReferenceAnnotationOptions options
)
Visual Basic
Public Shared Function Is3DViewValidForDimension ( _
    document As Document, _
    ownerViewId As ElementId, _
    options As MultiReferenceAnnotationOptions _
) As Boolean
Visual C++
public:
static bool Is3DViewValidForDimension(
    Document^ document,
    ElementId^ ownerViewId,
    MultiReferenceAnnotationOptions^ options
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document for the multi-reference annotation.
ownerViewId
Type: Autodesk.Revit.DB..::..ElementId
The view in which the multi-reference annotation will appear.
options
Type: Autodesk.Revit.DB..::..MultiReferenceAnnotationOptions
Options containing the references which the dimension will witness.

Return Value

True if the view is suitable for placing the MultiReferenceAnnotation. False otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

MultiReferenceAnnotation Class


IsLinearFixedDimensionDirectionValid Method

[image]

Revit 2024 API
MultiReferenceAnnotation..::..IsLinearFixedDimensionDirectionValid Method
MultiReferenceAnnotation Class See Also Send Feedback
If the DimensionStyleType is LinearFixed, this function verifies that the dimension line direction matches either the view's vertical or horizontal direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static bool IsLinearFixedDimensionDirectionValid(
    Document document,
    ElementId viewId,
    MultiReferenceAnnotationOptions options
)
Visual Basic
Public Shared Function IsLinearFixedDimensionDirectionValid ( _
    document As Document, _
    viewId As ElementId, _
    options As MultiReferenceAnnotationOptions _
) As Boolean
Visual C++
public:
static bool IsLinearFixedDimensionDirectionValid(
    Document^ document,
    ElementId^ viewId,
    MultiReferenceAnnotationOptions^ options
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document for the view.
viewId
Type: Autodesk.Revit.DB..::..ElementId
The view in which the dimension line direction will be tested.
options
Type: Autodesk.Revit.DB..::..MultiReferenceAnnotationOptions
Options containing the DimensionStyleType and dimension line direction to test.

Return Value

True if the DimensionStyleType is LinearFixed and the dimension line direction can be used in the view. True if the DimensionStyleType is not LinearFixed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

MultiReferenceAnnotation Class


MultiReferenceAnnotation Properties

[image] [image]

Revit 2024 API
MultiReferenceAnnotation Properties
MultiReferenceAnnotation Class See Also Send Feedback

The MultiReferenceAnnotation type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DimensionId | The child dimension owned by this multi-reference annotation.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | TagId | The child IndependentTag owned by this multi-reference annotation.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

MultiReferenceAnnotation Class


DimensionId Property

[image]

Revit 2024 API
MultiReferenceAnnotation..::..DimensionId Property
MultiReferenceAnnotation Class See Also Send Feedback
The child dimension owned by this multi-reference annotation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ElementId DimensionId { get; }
Visual Basic
Public ReadOnly Property DimensionId As ElementId
    Get
Visual C++
public:
property ElementId^ DimensionId {
    ElementId^ get ();
}

See Also

MultiReferenceAnnotation Class


Parameter Property

[image] [image]

Revit 2024 API
MultiReferenceAnnotation..::..Parameter Property
MultiReferenceAnnotation Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

MultiReferenceAnnotation Class
MultiReferenceAnnotation Members


TagId Property

[image]

Revit 2024 API
MultiReferenceAnnotation..::..TagId Property
MultiReferenceAnnotation Class See Also Send Feedback
The child IndependentTag owned by this multi-reference annotation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ElementId TagId { get; }
Visual Basic
Public ReadOnly Property TagId As ElementId
    Get
Visual C++
public:
property ElementId^ TagId {
    ElementId^ get ();
}

See Also

MultiReferenceAnnotation Class


MultiReferenceAnnotationOptions Class

[image]

Revit 2024 API
MultiReferenceAnnotationOptions Class
Members See Also Send Feedback
Options which control the creation of MultiReferenceAnnotations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class MultiReferenceAnnotationOptions : IDisposable
Visual Basic
Public Class MultiReferenceAnnotationOptions _
    Implements IDisposable
Visual C++
public ref class MultiReferenceAnnotationOptions : IDisposable

Remarks

MultiReferenceAnnotationOptions include the specification of the associated elements and options for the dimension and tag placement.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..MultiReferenceAnnotationOptions

See Also

MultiReferenceAnnotationOptions Members


MultiReferenceAnnotationOptions Members

[image] [image]

Revit 2024 API
MultiReferenceAnnotationOptions Members
MultiReferenceAnnotationOptions Class Constructors Methods Properties See Also Send Feedback

The MultiReferenceAnnotationOptions type exposes the following members.

Constructors

 | Name | Description
Public method | MultiReferenceAnnotationOptions | Create an instance of Multi-Reference Annotation Options set with default values.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the MultiReferenceAnnotationOptions
Public method | ElementsMatchReferenceCategory | Verifies that all of the elements match the reference category required by the MultiReferenceAnnotationType.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAdditionalReferencesToDimension | Gets the additional references which the dimension will witness.
Public method | GetElementsToDimension | Gets the elements which the dimension will witness.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAllowedDimensionStyleType | Only Linear and LinearFixed dimension style types are allowed for new MultiReferenceAnnotations.
Public method | ReferencesDontMatchReferenceCategory | Verifies that all of the references belongs to elements which doesn't match the reference category required by the MultiReferenceAnnotationType.
Public method | SetAdditionalReferencesToDimension | Sets the additional references which the dimension will witness.
Public method | SetElementsToDimension | Sets the elements which the dimension will witness.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DimensionLineDirection | The direction vector of the dimension line.
Public property | DimensionLineOrigin | The origin point for the dimension line.
Public property | DimensionPlaneNormal | The normal vector to the dimension plane.
Public property | DimensionStyleType | The dimension style type to be used by the new MultiReferenceAnnotation.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MultiReferenceAnnotationType | The MultiReferenceAnnotationType to be used by the new MultiReferenceAnnotation.
Public property | TagHasLeader | When true the tag will be created with an attached leader. When false the tag will be created without a leader.
Public property | TagHeadPosition | The position for the tag's head.

See Also

MultiReferenceAnnotationOptions Class


MultiReferenceAnnotationOptions Constructor

[image]

Revit 2024 API
MultiReferenceAnnotationOptions Constructor
MultiReferenceAnnotationOptions Class See Also Send Feedback
Create an instance of Multi-Reference Annotation Options set with default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public MultiReferenceAnnotationOptions(
    MultiReferenceAnnotationType multiReferenceAnnotationType
)
Visual Basic
Public Sub New ( _
    multiReferenceAnnotationType As MultiReferenceAnnotationType _
)
Visual C++
public:
MultiReferenceAnnotationOptions(
    MultiReferenceAnnotationType^ multiReferenceAnnotationType
)

Parameters

multiReferenceAnnotationType
Type: Autodesk.Revit.DB..::..MultiReferenceAnnotationType
The MultiReferenceAnnotationType to be used by the new MultiReferenceAnnotation.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

MultiReferenceAnnotationOptions Class


MultiReferenceAnnotationOptions Methods

[image] [image]

Revit 2024 API
MultiReferenceAnnotationOptions Methods
MultiReferenceAnnotationOptions Class See Also Send Feedback

The MultiReferenceAnnotationOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | ElementsMatchReferenceCategory | Verifies that all of the elements match the reference category required by the MultiReferenceAnnotationType.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAdditionalReferencesToDimension | Gets the additional references which the dimension will witness.
Public method | GetElementsToDimension | Gets the elements which the dimension will witness.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAllowedDimensionStyleType | Only Linear and LinearFixed dimension style types are allowed for new MultiReferenceAnnotations.
Public method | ReferencesDontMatchReferenceCategory | Verifies that all of the references belongs to elements which doesn't match the reference category required by the MultiReferenceAnnotationType.
Public method | SetAdditionalReferencesToDimension | Sets the additional references which the dimension will witness.
Public method | SetElementsToDimension | Sets the elements which the dimension will witness.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MultiReferenceAnnotationOptions Class


Dispose Method

[image]

Revit 2024 API
MultiReferenceAnnotationOptions..::..Dispose Method
MultiReferenceAnnotationOptions Class See Also Send Feedback
Releases all resources used by the MultiReferenceAnnotationOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

MultiReferenceAnnotationOptions Class


ElementsMatchReferenceCategory Method

[image]

Revit 2024 API
MultiReferenceAnnotationOptions..::..ElementsMatchReferenceCategory Method
MultiReferenceAnnotationOptions Class See Also Send Feedback
Verifies that all of the elements match the reference category required by the MultiReferenceAnnotationType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool ElementsMatchReferenceCategory(
    ICollection<ElementId> elements
)
Visual Basic
Public Function ElementsMatchReferenceCategory ( _
    elements As ICollection(Of ElementId) _
) As Boolean
Visual C++
public:
bool ElementsMatchReferenceCategory(
    ICollection<ElementId^>^ elements
)

Parameters

elements
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
The elements to test.

Return Value

True if all the elements match the reference category required by the MultiReferenceAnnotationType.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

MultiReferenceAnnotationOptions Class


GetAdditionalReferencesToDimension Method

[image]

Revit 2024 API
MultiReferenceAnnotationOptions..::..GetAdditionalReferencesToDimension Method
MultiReferenceAnnotationOptions Class See Also Send Feedback
Gets the additional references which the dimension will witness.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public IList<Reference> GetAdditionalReferencesToDimension()
Visual Basic
Public Function GetAdditionalReferencesToDimension As IList(Of Reference)
Visual C++
public:
IList<Reference^>^ GetAdditionalReferencesToDimension()

Return Value

The additional references which the dimension will witness.

Remarks

These references may be to elements of other categories than the reference category returned by MultiReferenceAnnotationType.

See Also

MultiReferenceAnnotationOptions Class


GetElementsToDimension Method

[image]

Revit 2024 API
MultiReferenceAnnotationOptions..::..GetElementsToDimension Method
MultiReferenceAnnotationOptions Class See Also Send Feedback
Gets the elements which the dimension will witness.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ICollection<ElementId> GetElementsToDimension()
Visual Basic
Public Function GetElementsToDimension As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetElementsToDimension()

Return Value

The elements which the dimension will witness.

See Also

MultiReferenceAnnotationOptions Class


IsAllowedDimensionStyleType Method

[image]

Revit 2024 API
MultiReferenceAnnotationOptions..::..IsAllowedDimensionStyleType Method
MultiReferenceAnnotationOptions Class See Also Send Feedback
Only Linear and LinearFixed dimension style types are allowed for new MultiReferenceAnnotations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsAllowedDimensionStyleType(
    DimensionStyleType dimensionStyleType
)
Visual Basic
Public Function IsAllowedDimensionStyleType ( _
    dimensionStyleType As DimensionStyleType _
) As Boolean
Visual C++
public:
bool IsAllowedDimensionStyleType(
    DimensionStyleType dimensionStyleType
)

Parameters

dimensionStyleType
Type: Autodesk.Revit.DB..::..DimensionStyleType
The dimension style type to test.

Return Value

True if the type is allowed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

MultiReferenceAnnotationOptions Class


ReferencesDontMatchReferenceCategory Method

[image]

Revit 2024 API
MultiReferenceAnnotationOptions..::..ReferencesDontMatchReferenceCategory Method
MultiReferenceAnnotationOptions Class See Also Send Feedback
Verifies that all of the references belongs to elements which doesn't match the reference category required by the MultiReferenceAnnotationType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public bool ReferencesDontMatchReferenceCategory(
    IList<Reference> references
)
Visual Basic
Public Function ReferencesDontMatchReferenceCategory ( _
    references As IList(Of Reference) _
) As Boolean
Visual C++
public:
bool ReferencesDontMatchReferenceCategory(
    IList<Reference^>^ references
)

Parameters

references
Type: System.Collections.Generic..::..IList<(Of <(<' Reference >)>)>
The references to test.

Return Value

Returns true if the element categories of all tested references do not match the element category required by the MultiReferenceAnnotationType.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

MultiReferenceAnnotationOptions Class


SetAdditionalReferencesToDimension Method

[image]

Revit 2024 API
MultiReferenceAnnotationOptions..::..SetAdditionalReferencesToDimension Method
MultiReferenceAnnotationOptions Class See Also Send Feedback
Sets the additional references which the dimension will witness.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public void SetAdditionalReferencesToDimension(
    IList<Reference> referencesToDimension
)
Visual Basic
Public Sub SetAdditionalReferencesToDimension ( _
    referencesToDimension As IList(Of Reference) _
)
Visual C++
public:
void SetAdditionalReferencesToDimension(
    IList<Reference^>^ referencesToDimension
)

Parameters

referencesToDimension
Type: System.Collections.Generic..::..IList<(Of <(<' Reference >)>)>
The additional references which the dimension will witness.

Remarks

The additional references to dimension cannot come from the same category as the MultiReferenceAnnotationType's reference category.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Some references come from elements which directly match the reference category required by the MultiReferenceAnnotationType. For those elements please use SetElementsToDimension.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

MultiReferenceAnnotationOptions Class


SetElementsToDimension Method

[image]

Revit 2024 API
MultiReferenceAnnotationOptions..::..SetElementsToDimension Method
MultiReferenceAnnotationOptions Class See Also Send Feedback
Sets the elements which the dimension will witness.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void SetElementsToDimension(
    ICollection<ElementId> elementsToDimension
)
Visual Basic
Public Sub SetElementsToDimension ( _
    elementsToDimension As ICollection(Of ElementId) _
)
Visual C++
public:
void SetElementsToDimension(
    ICollection<ElementId^>^ elementsToDimension
)

Parameters

elementsToDimension
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
The elements which the dimension will witness.

Remarks

The dimension will automatically find geometric references in the elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | some elements do not match the reference category required by the MultiReferenceAnnotationType.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The MultiReferenceAnnotationType assigned to the options can't create MultiReferenceAnnotations by element.

See Also

MultiReferenceAnnotationOptions Class


DimensionPlaneNormal Property

[image]

Revit 2024 API
MultiReferenceAnnotationOptions..::..DimensionPlaneNormal Property
MultiReferenceAnnotationOptions Class See Also Send Feedback
The normal vector to the dimension plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public XYZ DimensionPlaneNormal { get; set; }
Visual Basic
Public Property DimensionPlaneNormal As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ DimensionPlaneNormal {
    XYZ^ get ();
    void set (XYZ^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: dimensionPlaneNormal is not length 1.0.

See Also

MultiReferenceAnnotationOptions Class


DimensionStyleType Property

[image]

Revit 2024 API
MultiReferenceAnnotationOptions..::..DimensionStyleType Property
MultiReferenceAnnotationOptions Class See Also Send Feedback
The dimension style type to be used by the new MultiReferenceAnnotation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public DimensionStyleType DimensionStyleType { get; set; }
Visual Basic
Public Property DimensionStyleType As DimensionStyleType
    Get
    Set
Visual C++
public:
property DimensionStyleType DimensionStyleType {
    DimensionStyleType get ();
    void set (DimensionStyleType value);
}

Remarks

Only Linear and LinearFixed types are allowed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: dimensionStyleType must be either Linear or LinearFixed to be used by MultiReferenceAnnotations.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

MultiReferenceAnnotationOptions Class


IsValidObject Property

[image]

Revit 2024 API
MultiReferenceAnnotationOptions..::..IsValidObject Property
MultiReferenceAnnotationOptions Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

MultiReferenceAnnotationOptions Class


MultiReferenceAnnotationType Property

[image]

Revit 2024 API
MultiReferenceAnnotationOptions..::..MultiReferenceAnnotationType Property
MultiReferenceAnnotationOptions Class See Also Send Feedback
The MultiReferenceAnnotationType to be used by the new MultiReferenceAnnotation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public MultiReferenceAnnotationType MultiReferenceAnnotationType { get; }
Visual Basic
Public ReadOnly Property MultiReferenceAnnotationType As MultiReferenceAnnotationType
    Get
Visual C++
public:
property MultiReferenceAnnotationType^ MultiReferenceAnnotationType {
    MultiReferenceAnnotationType^ get ();
}

See Also

MultiReferenceAnnotationOptions Class


TagHeadPosition Property

[image]

Revit 2024 API
MultiReferenceAnnotationOptions..::..TagHeadPosition Property
MultiReferenceAnnotationOptions Class See Also Send Feedback
The position for the tag's head.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public XYZ TagHeadPosition { get; set; }
Visual Basic
Public Property TagHeadPosition As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ TagHeadPosition {
    XYZ^ get ();
    void set (XYZ^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

MultiReferenceAnnotationOptions Class


MultiReferenceAnnotationType Class

[image]

Revit 2024 API
MultiReferenceAnnotationType Class
Members See Also Send Feedback
The type for MultiReferenceAnnotation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class MultiReferenceAnnotationType : ElementType
Visual Basic
Public Class MultiReferenceAnnotationType _
    Inherits ElementType
Visual C++
public ref class MultiReferenceAnnotationType : public ElementType

Remarks

Multi-reference annotations can be used to label and dimension Rebar elements, and are labeled in the user interface as "Multi-rebar annotations". The type specifies the tag and dimension types to be used in the multi-reference annotation, as well as associated display settings.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..MultiReferenceAnnotationType

See Also

MultiReferenceAnnotationType Members


MultiReferenceAnnotationType Members

[image] [image]

Revit 2024 API
MultiReferenceAnnotationType Members
MultiReferenceAnnotationType Class Methods Properties See Also Send Feedback

The MultiReferenceAnnotationType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | CreateDefault | Creates the first MultiReferenceAnnotationType element and adds it to the document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetAllowedTagCategory | Returns the category ID for the tag types which can be used by this multi-reference annotation type.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsAllowedDimensionStyle | Checks if the dimension style can be used with multi-reference annotations.
Public method | IsAllowedReferenceCategory | Checks if the reference category can be used with multi-reference annotations.
 | IsAllowedTagCategory | Returns true if tag types belonging to this category can be used with multi-reference annotation types.
Public method | IsAllowedTagType | Checks if the tag type can be assigned to this multi-reference annotation type.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DimensionStyleId | The dimension style which will be used by the child dimension of the multi-reference annotation.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | GroupTagHeads | Controls if parameter values for the annotation's references will be reported in one grouped tag head or if every reference will get its own tag head.
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ReferenceCategoryId | The category of elements to which this annotation applies.
Public property | ShowDimensionText | Controls if text from the multi-reference annotation's dimension will be shown.
Public property | TagTypeId | The tag type which will be used by the child tag the multi-reference annotation.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

MultiReferenceAnnotationType Class


MultiReferenceAnnotationType Methods

[image] [image]

Revit 2024 API
MultiReferenceAnnotationType Methods
MultiReferenceAnnotationType Class See Also Send Feedback

The MultiReferenceAnnotationType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | CreateDefault | Creates the first MultiReferenceAnnotationType element and adds it to the document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetAllowedTagCategory | Returns the category ID for the tag types which can be used by this multi-reference annotation type.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsAllowedDimensionStyle | Checks if the dimension style can be used with multi-reference annotations.
Public method | IsAllowedReferenceCategory | Checks if the reference category can be used with multi-reference annotations.
 | IsAllowedTagCategory | Returns true if tag types belonging to this category can be used with multi-reference annotation types.
Public method | IsAllowedTagType | Checks if the tag type can be assigned to this multi-reference annotation type.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MultiReferenceAnnotationType Class


CreateDefault Method

[image]

Revit 2024 API
MultiReferenceAnnotationType..::..CreateDefault Method
MultiReferenceAnnotationType Class See Also Send Feedback
Creates the first MultiReferenceAnnotationType element and adds it to the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static MultiReferenceAnnotationType CreateDefault(
    Document document
)
Visual Basic
Public Shared Function CreateDefault ( _
    document As Document _
) As MultiReferenceAnnotationType
Visual C++
public:
static MultiReferenceAnnotationType^ CreateDefault(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to be modified.

Return Value

The new MultiReferenceAnnotationType element.

Remarks

If there is no existing MultiReferenceAnnotationType a new one will be created, otherwise an exception will be thrown. Use Duplicate(String) to create all further MultiReferenceAnnotationTypes. The default MultiReferenceAnnotationType will use the document's current default linear dimension style and will have Structural Rebar as its reference category. No tag type will be set for the new MultiReferenceAnnotationType.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- There are existing MultiReferenceAnnotationTypes in the document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

MultiReferenceAnnotationType Class


GetAllowedTagCategory Method

[image]

Revit 2024 API
MultiReferenceAnnotationType..::..GetAllowedTagCategory Method
MultiReferenceAnnotationType Class See Also Send Feedback
Returns the category ID for the tag types which can be used by this multi-reference annotation type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ElementId GetAllowedTagCategory()
Visual Basic
Public Function GetAllowedTagCategory As ElementId
Visual C++
public:
ElementId^ GetAllowedTagCategory()

Return Value

The allowed tag category ID.

Remarks

The allowed tag category is determined by the reference category of this multi-reference annotation type.

See Also

MultiReferenceAnnotationType Class


IsAllowedReferenceCategory Method

[image]

Revit 2024 API
MultiReferenceAnnotationType..::..IsAllowedReferenceCategory Method
MultiReferenceAnnotationType Class See Also Send Feedback
Checks if the reference category can be used with multi-reference annotations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsAllowedReferenceCategory(
    ElementId referenceCategoryId
)
Visual Basic
Public Function IsAllowedReferenceCategory ( _
    referenceCategoryId As ElementId _
) As Boolean
Visual C++
public:
bool IsAllowedReferenceCategory(
    ElementId^ referenceCategoryId
)

Parameters

referenceCategoryId
Type: Autodesk.Revit.DB..::..ElementId
The reference category to check.

Return Value

True when the reference category can be used by multi-reference annotations.

Remarks

Only Structural Rebar is allowed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

MultiReferenceAnnotationType Class


IsAllowedTagCategory Method

[image]

Revit 2024 API
MultiReferenceAnnotationType..::..IsAllowedTagCategory Method
MultiReferenceAnnotationType Class See Also Send Feedback
Returns true if tag types belonging to this category can be used with multi-reference annotation types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static bool IsAllowedTagCategory(
    ElementId tagCategoryId
)
Visual Basic
Public Shared Function IsAllowedTagCategory ( _
    tagCategoryId As ElementId _
) As Boolean
Visual C++
public:
static bool IsAllowedTagCategory(
    ElementId^ tagCategoryId
)

Parameters

tagCategoryId
Type: Autodesk.Revit.DB..::..ElementId
The tag category to test.

Remarks

Only Structural Rebar Tags are allowed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

MultiReferenceAnnotationType Class


IsAllowedTagType Method

[image]

Revit 2024 API
MultiReferenceAnnotationType..::..IsAllowedTagType Method
MultiReferenceAnnotationType Class See Also Send Feedback
Checks if the tag type can be assigned to this multi-reference annotation type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsAllowedTagType(
    ElementId tagTypeId
)
Visual Basic
Public Function IsAllowedTagType ( _
    tagTypeId As ElementId _
) As Boolean
Visual C++
public:
bool IsAllowedTagType(
    ElementId^ tagTypeId
)

Parameters

tagTypeId
Type: Autodesk.Revit.DB..::..ElementId
The tag type to test.

Return Value

True if the tag type exclusively tags elements from the multi-reference annotation's reference category.

Remarks

Only tag types which exclusively tag elements from the multi-reference annotation's reference category can be used.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

MultiReferenceAnnotationType Class


MultiReferenceAnnotationType Properties

[image] [image]

Revit 2024 API
MultiReferenceAnnotationType Properties
MultiReferenceAnnotationType Class See Also Send Feedback

The MultiReferenceAnnotationType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DimensionStyleId | The dimension style which will be used by the child dimension of the multi-reference annotation.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | GroupTagHeads | Controls if parameter values for the annotation's references will be reported in one grouped tag head or if every reference will get its own tag head.
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ReferenceCategoryId | The category of elements to which this annotation applies.
Public property | ShowDimensionText | Controls if text from the multi-reference annotation's dimension will be shown.
Public property | TagTypeId | The tag type which will be used by the child tag the multi-reference annotation.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

MultiReferenceAnnotationType Class


DimensionStyleId Property

[image]

Revit 2024 API
MultiReferenceAnnotationType..::..DimensionStyleId Property
MultiReferenceAnnotationType Class See Also Send Feedback
The dimension style which will be used by the child dimension of the multi-reference annotation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ElementId DimensionStyleId { get; set; }
Visual Basic
Public Property DimensionStyleId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ DimensionStyleId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Field Value

Only linear dimension styles can be used.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The dimension style is not allowed.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

MultiReferenceAnnotationType Class


GroupTagHeads Property

[image]

Revit 2024 API
MultiReferenceAnnotationType..::..GroupTagHeads Property
MultiReferenceAnnotationType Class See Also Send Feedback
Controls if parameter values for the annotation's references will be reported in one grouped tag head or if every reference will get its own tag head.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool GroupTagHeads { get; set; }
Visual Basic
Public Property GroupTagHeads As Boolean
    Get
    Set
Visual C++
public:
property bool GroupTagHeads {
    bool get ();
    void set (bool value);
}

Field Value

When false, each reference will get one tag head. When true, if all references report the same parameter values, a single tag head will be created.

See Also

MultiReferenceAnnotationType Class


Parameter Property

[image] [image]

Revit 2024 API
MultiReferenceAnnotationType..::..Parameter Property
MultiReferenceAnnotationType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

MultiReferenceAnnotationType Class
MultiReferenceAnnotationType Members


ReferenceCategoryId Property

[image]

Revit 2024 API
MultiReferenceAnnotationType..::..ReferenceCategoryId Property
MultiReferenceAnnotationType Class See Also Send Feedback
The category of elements to which this annotation applies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ElementId ReferenceCategoryId { get; }
Visual Basic
Public ReadOnly Property ReferenceCategoryId As ElementId
    Get
Visual C++
public:
property ElementId^ ReferenceCategoryId {
    ElementId^ get ();
}

Remarks

The TagTypeId will be cleared because the user must set a new tag type of an appropriate category.

See Also

MultiReferenceAnnotationType Class


ShowDimensionText Property

[image]

Revit 2024 API
MultiReferenceAnnotationType..::..ShowDimensionText Property
MultiReferenceAnnotationType Class See Also Send Feedback
Controls if text from the multi-reference annotation's dimension will be shown.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool ShowDimensionText { get; set; }
Visual Basic
Public Property ShowDimensionText As Boolean
    Get
    Set
Visual C++
public:
property bool ShowDimensionText {
    bool get ();
    void set (bool value);
}

Field Value

When false, all dimension text including segment values will be hidden. When true, all dimension text will be shown.

See Also

MultiReferenceAnnotationType Class


TagTypeId Property

[image]

Revit 2024 API
MultiReferenceAnnotationType..::..TagTypeId Property
MultiReferenceAnnotationType Class See Also Send Feedback
The tag type which will be used by the child tag the multi-reference annotation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ElementId TagTypeId { get; set; }
Visual Basic
Public Property TagTypeId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ TagTypeId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Field Value

The tag type must be able to tag elements belonging to the multi-reference annotation's reference category.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The tag type is not allowed.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

MultiReferenceAnnotationType Class


MultiSegmentGrid Class

[image]

Revit 2024 API
MultiSegmentGrid Class
Members See Also Send Feedback
This element acts as a multi-segmented Grid. The individual grids associated to the MultiSegmentGrid behave as a single unit and all share the same text. They inherit their type (GridType) from the MultiSegmentGrid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public class MultiSegmentGrid : Element
Visual Basic
Public Class MultiSegmentGrid _
    Inherits Element
Visual C++
public ref class MultiSegmentGrid : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..MultiSegmentGrid

See Also

MultiSegmentGrid Members


MultiSegmentGrid Members

[image] [image]

Revit 2024 API
MultiSegmentGrid Members
MultiSegmentGrid Class Methods Properties See Also Send Feedback

The MultiSegmentGrid type exposes the following members.

Methods

 | Name | Description
 | AreGridsInSameMultiSegmentGrid | Determine whether two Grids are members of the same GridChain.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create | Create a MultiSegmentGrid element from the specified curve loop.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetGridIds | Get the element ids of the Grids that make up this MultiSegmentGrid.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
 | GetMultiSegementGridId | Retrieve the element id of the MultiSegmentGrid of which the specified Grid is a member.
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
 | IsValidCurveLoop | Identifies whether the specified curve loop is valid for creation of a MultiSegmentGrid.
 | IsValidSketchPlaneId | Identifies whether provided element id corresponds to a SketchPlane that is valid for GridChain creation.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Text | name shared by grids in this MultiSegmentGrid
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

MultiSegmentGrid Class


MultiSegmentGrid Methods

[image] [image]

Revit 2024 API
MultiSegmentGrid Methods
MultiSegmentGrid Class See Also Send Feedback

The MultiSegmentGrid type exposes the following members.

Methods

 | Name | Description
 | AreGridsInSameMultiSegmentGrid | Determine whether two Grids are members of the same GridChain.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create | Create a MultiSegmentGrid element from the specified curve loop.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetGridIds | Get the element ids of the Grids that make up this MultiSegmentGrid.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
 | GetMultiSegementGridId | Retrieve the element id of the MultiSegmentGrid of which the specified Grid is a member.
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
 | IsValidCurveLoop | Identifies whether the specified curve loop is valid for creation of a MultiSegmentGrid.
 | IsValidSketchPlaneId | Identifies whether provided element id corresponds to a SketchPlane that is valid for GridChain creation.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MultiSegmentGrid Class


AreGridsInSameMultiSegmentGrid Method

[image]

Revit 2024 API
MultiSegmentGrid..::..AreGridsInSameMultiSegmentGrid Method
MultiSegmentGrid Class See Also Send Feedback
Determine whether two Grids are members of the same GridChain.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static bool AreGridsInSameMultiSegmentGrid(
    Grid grid1,
    Grid grid2
)
Visual Basic
Public Shared Function AreGridsInSameMultiSegmentGrid ( _
    grid1 As Grid, _
    grid2 As Grid _
) As Boolean
Visual C++
public:
static bool AreGridsInSameMultiSegmentGrid(
    Grid^ grid1,
    Grid^ grid2
)

Parameters

grid1
Type: Autodesk.Revit.DB..::..Grid
A Grid.
grid2
Type: Autodesk.Revit.DB..::..Grid
A Grid.

Return Value

Returns true if both of the specified Grids are associated to the same MultiSegmentGrid, i.e. getMultiSegementGridId returns the same valid element id for both Grids.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

MultiSegmentGrid Class


Create Method

[image]

Revit 2024 API
MultiSegmentGrid..::..Create Method
MultiSegmentGrid Class See Also Send Feedback
Create a MultiSegmentGrid element from the specified curve loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static ElementId Create(
    Document document,
    ElementId typeId,
    CurveLoop curveLoop,
    ElementId sketchPlaneId
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    typeId As ElementId, _
    curveLoop As CurveLoop, _
    sketchPlaneId As ElementId _
) As ElementId
Visual C++
public:
static ElementId^ Create(
    Document^ document,
    ElementId^ typeId,
    CurveLoop^ curveLoop,
    ElementId^ sketchPlaneId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which to create the MultiSegmentGrid.
typeId
Type: Autodesk.Revit.DB..::..ElementId
Element id of a GridType element.
curveLoop
Type: Autodesk.Revit.DB..::..CurveLoop
An open curve loop consisting of lines and arcs.
sketchPlaneId
Type: Autodesk.Revit.DB..::..ElementId
Element id of a SketchPlane for the curves elements that will be created from the curveLoop.

Return Value

The element id of the new MultiSegmentGrid element.

Remarks

For each curve in the curve loop, a corresponding Grid will be created.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element id should refer to a valid horizontal SketchPlane. -or- The element id should refer to a GridType element. -or- The curve loop should be an open loop consisting of lines and arcs.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

MultiSegmentGrid Class


GetGridIds Method

[image]

Revit 2024 API
MultiSegmentGrid..::..GetGridIds Method
MultiSegmentGrid Class See Also Send Feedback
Get the element ids of the Grids that make up this MultiSegmentGrid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ICollection<ElementId> GetGridIds()
Visual Basic
Public Function GetGridIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetGridIds()

Return Value

Element ids of Grids that make up this MultiSegmentGrid.

See Also

MultiSegmentGrid Class


GetMultiSegementGridId Method

[image]

Revit 2024 API
MultiSegmentGrid..::..GetMultiSegementGridId Method
MultiSegmentGrid Class See Also Send Feedback
Retrieve the element id of the MultiSegmentGrid of which the specified Grid is a member.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static ElementId GetMultiSegementGridId(
    Grid grid
)
Visual Basic
Public Shared Function GetMultiSegementGridId ( _
    grid As Grid _
) As ElementId
Visual C++
public:
static ElementId^ GetMultiSegementGridId(
    Grid^ grid
)

Parameters

grid
Type: Autodesk.Revit.DB..::..Grid
A Grid.

Return Value

The element id of the associated GridChain. If the Grid is not associated to a GridChain, this will return invalidElementId.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

MultiSegmentGrid Class


IsValidSketchPlaneId Method

[image]

Revit 2024 API
MultiSegmentGrid..::..IsValidSketchPlaneId Method
MultiSegmentGrid Class See Also Send Feedback
Identifies whether provided element id corresponds to a SketchPlane that is valid for GridChain creation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static bool IsValidSketchPlaneId(
    Document document,
    ElementId elemId
)
Visual Basic
Public Shared Function IsValidSketchPlaneId ( _
    document As Document, _
    elemId As ElementId _
) As Boolean
Visual C++
public:
static bool IsValidSketchPlaneId(
    Document^ document,
    ElementId^ elemId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
elemId
Type: Autodesk.Revit.DB..::..ElementId
Element id.

Return Value

True if elemId is the element id of a horizontal SketchPlane.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

MultiSegmentGrid Class


MultiSegmentGrid Properties

[image] [image]

Revit 2024 API
MultiSegmentGrid Properties
MultiSegmentGrid Class See Also Send Feedback

The MultiSegmentGrid type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Text | name shared by grids in this MultiSegmentGrid
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

MultiSegmentGrid Class


Parameter Property

[image] [image]

Revit 2024 API
MultiSegmentGrid..::..Parameter Property
MultiSegmentGrid Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

MultiSegmentGrid Class
MultiSegmentGrid Members


Text Property

[image]

Revit 2024 API
MultiSegmentGrid..::..Text Property
MultiSegmentGrid Class See Also Send Feedback
name shared by grids in this MultiSegmentGrid

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

MultiSegmentGrid Class


NamingUtils Class

[image]

Revit 2024 API
NamingUtils Class
Members See Also Send Feedback
A collection of utilities related to element naming.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static class NamingUtils
Visual Basic
Public NotInheritable Class NamingUtils
Visual C++
public ref class NamingUtils abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..NamingUtils

See Also

NamingUtils Members


IsValidName Method

[image]

Revit 2024 API
NamingUtils..::..IsValidName Method
NamingUtils Class See Also Send Feedback
Identifies if the input string is valid for use as an object name in Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static bool IsValidName(
    string string
)
Visual Basic
Public Shared Function IsValidName ( _
    string As String _
) As Boolean
Visual C++
public:
static bool IsValidName(
    String^ string
)

Parameters

string
Type: System..::..String
The name to validate.

Return Value

True if the name is valid for use as a name in Revit, false if it contains prohibited characters and is invalid.

Remarks

This routine checks only for prohibited characters in the string. When setting the name for an object there are other specific considerations which are checked (for example, the same name cannot be used twice for different elements of the same type). This routine does not check those conditions.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

NamingUtils Class


NavisworksCoordinates Enumeration

[image]

Revit 2024 API
NavisworksCoordinates Enumeration
See Also Send Feedback
An enumerated type listing possible Coordinates of Navisworks Exporter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014
Since: 2014

Syntax

C#
public enum NavisworksCoordinates
Visual Basic
Public Enumeration NavisworksCoordinates
Visual C++
public enum class NavisworksCoordinates

Members

Member name | Description
Internal | Use Revit internal coordinates.
Shared | Shared coordinates can be viewed and modified outside of Revit.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


NavisworksExportOptions Class

[image]

Revit 2024 API
NavisworksExportOptions Class
Members See Also Send Feedback
Options which controls the Navisworks export.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class NavisworksExportOptions : IDisposable
Visual Basic
Public Class NavisworksExportOptions _
    Implements IDisposable
Visual C++
public ref class NavisworksExportOptions : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..NavisworksExportOptions

See Also

NavisworksExportOptions Members


NavisworksExportOptions Members

[image] [image]

Revit 2024 API
NavisworksExportOptions Members
NavisworksExportOptions Class Constructors Methods Properties See Also Send Feedback

The NavisworksExportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | NavisworksExportOptions | Create an instance of Navisworks Export Options set with default values.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the NavisworksExportOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSelectedElementIds | Returns the element ids of the elements to export. Empty by default.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetSelectedElementIds | Sets the element ids of the elements to export. Used only when ExportScope = SelectedElements.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConvertElementProperties | True to convert element properties, false otherwise. Default value is false.
Public property | ConvertLights | True to convert lights, false otherwise. Default value is false.
Public property | ConvertLinkedCADFormats | True to convert linked CAD formats, false otherwise. Default value is true.
Public property | Coordinates | Options which specifies the coordinates of Navisworks Exporter. Default value is Shared.
Public property | DivideFileIntoLevels | True to divide file into levels, false otherwise. Default value is true.
Public property | ExportElementIds | True to export Revit element ids, false to skip these values. Default value is true.
Public property | ExportLinks | True to export Revit links found in the main model, false to skip links. Default value is false.
Public property | ExportParts | True to export Revit part elements, false to export the original parent elements. Default value is false.
Public property | ExportRoomAsAttribute | True to export data for each room converts into a single shared room attribute, false otherwise. Default value is true.
Public property | ExportRoomGeometry | True to export Revit room geometry, false otherwise. Default value is true.
Public property | ExportScope | Options which specifies the export scope of Navisworks Exporter. Default value is Model.
Public property | ExportUrls | True to export URL parameters, false otherwise. Default value is true.
Public property | FacetingFactor | Faceting factor. Default value is 1.0.
Public property | FindMissingMaterials | True if the file exporter looks for a match for the materials missing from the export, false otherwise. Default value is true.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Parameters | Options which specifies the parameter conversion of Navisworks Exporter. Default value is All.
Public property | ViewId | The element id of the view to export. InvalidElementId by default. Used only when ExportScope = View.

See Also

NavisworksExportOptions Class


NavisworksExportOptions Constructor

[image]

Revit 2024 API
NavisworksExportOptions Constructor
NavisworksExportOptions Class See Also Send Feedback
Create an instance of Navisworks Export Options set with default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public NavisworksExportOptions()
Visual Basic
Public Sub New
Visual C++
public:
NavisworksExportOptions()

See Also

NavisworksExportOptions Class


NavisworksExportOptions Methods

[image] [image]

Revit 2024 API
NavisworksExportOptions Methods
NavisworksExportOptions Class See Also Send Feedback

The NavisworksExportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSelectedElementIds | Returns the element ids of the elements to export. Empty by default.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetSelectedElementIds | Sets the element ids of the elements to export. Used only when ExportScope = SelectedElements.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

NavisworksExportOptions Class


Dispose Method

[image]

Revit 2024 API
NavisworksExportOptions..::..Dispose Method
NavisworksExportOptions Class See Also Send Feedback
Releases all resources used by the NavisworksExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

NavisworksExportOptions Class


GetSelectedElementIds Method

[image]

Revit 2024 API
NavisworksExportOptions..::..GetSelectedElementIds Method
NavisworksExportOptions Class See Also Send Feedback
Returns the element ids of the elements to export. Empty by default.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ICollection<ElementId> GetSelectedElementIds()
Visual Basic
Public Function GetSelectedElementIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetSelectedElementIds()

See Also

NavisworksExportOptions Class


NavisworksExportOptions Properties

[image] [image]

Revit 2024 API
NavisworksExportOptions Properties
NavisworksExportOptions Class See Also Send Feedback

The NavisworksExportOptions type exposes the following members.

Properties

 | Name | Description
Public property | ConvertElementProperties | True to convert element properties, false otherwise. Default value is false.
Public property | ConvertLights | True to convert lights, false otherwise. Default value is false.
Public property | ConvertLinkedCADFormats | True to convert linked CAD formats, false otherwise. Default value is true.
Public property | Coordinates | Options which specifies the coordinates of Navisworks Exporter. Default value is Shared.
Public property | DivideFileIntoLevels | True to divide file into levels, false otherwise. Default value is true.
Public property | ExportElementIds | True to export Revit element ids, false to skip these values. Default value is true.
Public property | ExportLinks | True to export Revit links found in the main model, false to skip links. Default value is false.
Public property | ExportParts | True to export Revit part elements, false to export the original parent elements. Default value is false.
Public property | ExportRoomAsAttribute | True to export data for each room converts into a single shared room attribute, false otherwise. Default value is true.
Public property | ExportRoomGeometry | True to export Revit room geometry, false otherwise. Default value is true.
Public property | ExportScope | Options which specifies the export scope of Navisworks Exporter. Default value is Model.
Public property | ExportUrls | True to export URL parameters, false otherwise. Default value is true.
Public property | FacetingFactor | Faceting factor. Default value is 1.0.
Public property | FindMissingMaterials | True if the file exporter looks for a match for the materials missing from the export, false otherwise. Default value is true.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Parameters | Options which specifies the parameter conversion of Navisworks Exporter. Default value is All.
Public property | ViewId | The element id of the view to export. InvalidElementId by default. Used only when ExportScope = View.

See Also

NavisworksExportOptions Class


ConvertElementProperties Property

[image]

Revit 2024 API
NavisworksExportOptions..::..ConvertElementProperties Property
NavisworksExportOptions Class See Also Send Feedback
True to convert element properties, false otherwise. Default value is false.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool ConvertElementProperties { get; set; }
Visual Basic
Public Property ConvertElementProperties As Boolean
    Get
    Set
Visual C++
public:
property bool ConvertElementProperties {
    bool get ();
    void set (bool value);
}

See Also

NavisworksExportOptions Class


ConvertLights Property

[image]

Revit 2024 API
NavisworksExportOptions..::..ConvertLights Property
NavisworksExportOptions Class See Also Send Feedback
True to convert lights, false otherwise. Default value is false.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public bool ConvertLights { get; set; }
Visual Basic
Public Property ConvertLights As Boolean
    Get
    Set
Visual C++
public:
property bool ConvertLights {
    bool get ();
    void set (bool value);
}

See Also

NavisworksExportOptions Class


ConvertLinkedCADFormats Property

[image]

Revit 2024 API
NavisworksExportOptions..::..ConvertLinkedCADFormats Property
NavisworksExportOptions Class See Also Send Feedback
True to convert linked CAD formats, false otherwise. Default value is true.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public bool ConvertLinkedCADFormats { get; set; }
Visual Basic
Public Property ConvertLinkedCADFormats As Boolean
    Get
    Set
Visual C++
public:
property bool ConvertLinkedCADFormats {
    bool get ();
    void set (bool value);
}

See Also

NavisworksExportOptions Class


Coordinates Property

[image]

Revit 2024 API
NavisworksExportOptions..::..Coordinates Property
NavisworksExportOptions Class See Also Send Feedback
Options which specifies the coordinates of Navisworks Exporter. Default value is Shared.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public NavisworksCoordinates Coordinates { get; set; }
Visual Basic
Public Property Coordinates As NavisworksCoordinates
    Get
    Set
Visual C++
public:
property NavisworksCoordinates Coordinates {
    NavisworksCoordinates get ();
    void set (NavisworksCoordinates value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

NavisworksExportOptions Class


DivideFileIntoLevels Property

[image]

Revit 2024 API
NavisworksExportOptions..::..DivideFileIntoLevels Property
NavisworksExportOptions Class See Also Send Feedback
True to divide file into levels, false otherwise. Default value is true.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool DivideFileIntoLevels { get; set; }
Visual Basic
Public Property DivideFileIntoLevels As Boolean
    Get
    Set
Visual C++
public:
property bool DivideFileIntoLevels {
    bool get ();
    void set (bool value);
}

See Also

NavisworksExportOptions Class


ExportElementIds Property

[image]

Revit 2024 API
NavisworksExportOptions..::..ExportElementIds Property
NavisworksExportOptions Class See Also Send Feedback
True to export Revit element ids, false to skip these values. Default value is true.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool ExportElementIds { get; set; }
Visual Basic
Public Property ExportElementIds As Boolean
    Get
    Set
Visual C++
public:
property bool ExportElementIds {
    bool get ();
    void set (bool value);
}

See Also

NavisworksExportOptions Class


ExportLinks Property

[image]

Revit 2024 API
NavisworksExportOptions..::..ExportLinks Property
NavisworksExportOptions Class See Also Send Feedback
True to export Revit links found in the main model, false to skip links. Default value is false.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool ExportLinks { get; set; }
Visual Basic
Public Property ExportLinks As Boolean
    Get
    Set
Visual C++
public:
property bool ExportLinks {
    bool get ();
    void set (bool value);
}

See Also

NavisworksExportOptions Class


ExportParts Property

[image]

Revit 2024 API
NavisworksExportOptions..::..ExportParts Property
NavisworksExportOptions Class See Also Send Feedback
True to export Revit part elements, false to export the original parent elements. Default value is false.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool ExportParts { get; set; }
Visual Basic
Public Property ExportParts As Boolean
    Get
    Set
Visual C++
public:
property bool ExportParts {
    bool get ();
    void set (bool value);
}

See Also

NavisworksExportOptions Class


ExportRoomGeometry Property

[image]

Revit 2024 API
NavisworksExportOptions..::..ExportRoomGeometry Property
NavisworksExportOptions Class See Also Send Feedback
True to export Revit room geometry, false otherwise. Default value is true.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool ExportRoomGeometry { get; set; }
Visual Basic
Public Property ExportRoomGeometry As Boolean
    Get
    Set
Visual C++
public:
property bool ExportRoomGeometry {
    bool get ();
    void set (bool value);
}

See Also

NavisworksExportOptions Class


ExportScope Property

[image]

Revit 2024 API
NavisworksExportOptions..::..ExportScope Property
NavisworksExportOptions Class See Also Send Feedback
Options which specifies the export scope of Navisworks Exporter. Default value is Model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public NavisworksExportScope ExportScope { get; set; }
Visual Basic
Public Property ExportScope As NavisworksExportScope
    Get
    Set
Visual C++
public:
property NavisworksExportScope ExportScope {
    NavisworksExportScope get ();
    void set (NavisworksExportScope value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

NavisworksExportOptions Class


ExportUrls Property

[image]

Revit 2024 API
NavisworksExportOptions..::..ExportUrls Property
NavisworksExportOptions Class See Also Send Feedback
True to export URL parameters, false otherwise. Default value is true.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool ExportUrls { get; set; }
Visual Basic
Public Property ExportUrls As Boolean
    Get
    Set
Visual C++
public:
property bool ExportUrls {
    bool get ();
    void set (bool value);
}

See Also

NavisworksExportOptions Class


FacetingFactor Property

[image]

Revit 2024 API
NavisworksExportOptions..::..FacetingFactor Property
NavisworksExportOptions Class See Also Send Feedback
Faceting factor. Default value is 1.0.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public double FacetingFactor { get; set; }
Visual Basic
Public Property FacetingFactor As Double
    Get
    Set
Visual C++
public:
property double FacetingFactor {
    double get ();
    void set (double value);
}

See Also

NavisworksExportOptions Class


FindMissingMaterials Property

[image]

Revit 2024 API
NavisworksExportOptions..::..FindMissingMaterials Property
NavisworksExportOptions Class See Also Send Feedback
True if the file exporter looks for a match for the materials missing from the export, false otherwise. Default value is true.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool FindMissingMaterials { get; set; }
Visual Basic
Public Property FindMissingMaterials As Boolean
    Get
    Set
Visual C++
public:
property bool FindMissingMaterials {
    bool get ();
    void set (bool value);
}

See Also

NavisworksExportOptions Class


IsValidObject Property

[image]

Revit 2024 API
NavisworksExportOptions..::..IsValidObject Property
NavisworksExportOptions Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

NavisworksExportOptions Class


Parameters Property

[image]

Revit 2024 API
NavisworksExportOptions..::..Parameters Property
NavisworksExportOptions Class See Also Send Feedback
Options which specifies the parameter conversion of Navisworks Exporter. Default value is All.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public NavisworksParameters Parameters { get; set; }
Visual Basic
Public Property Parameters As NavisworksParameters
    Get
    Set
Visual C++
public:
property NavisworksParameters Parameters {
    NavisworksParameters get ();
    void set (NavisworksParameters value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

NavisworksExportOptions Class


ViewId Property

[image]

Revit 2024 API
NavisworksExportOptions..::..ViewId Property
NavisworksExportOptions Class See Also Send Feedback
The element id of the view to export. InvalidElementId by default. Used only when ExportScope = View.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ElementId ViewId { get; set; }
Visual Basic
Public Property ViewId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ ViewId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

NavisworksExportOptions Class


NavisworksExportScope Enumeration

[image]

Revit 2024 API
NavisworksExportScope Enumeration
See Also Send Feedback
An enumerated type listing possible "Element Scopes" of Navisworks Exporter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014
Since: 2014

Syntax

C#
public enum NavisworksExportScope
Visual Basic
Public Enumeration NavisworksExportScope
Visual C++
public enum class NavisworksExportScope

Members

Member name | Description
Model | Export all elements in the document.
View | Export the elements in a view.
SelectedElements | Export the selected elements.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


NavisworksParameters Enumeration

[image]

Revit 2024 API
NavisworksParameters Enumeration
See Also Send Feedback
An enumerated type listing possible "Parameter conversions" of Navisworks Exporter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014
Since: 2014

Syntax

C#
public enum NavisworksParameters
Visual Basic
Public Enumeration NavisworksParameters
Visual C++
public enum class NavisworksParameters

Members

Member name | Description
None | The file exporter does not convert parameters.
Elements | The file exporter converts parameters for all found elements.
All | The file exporter converts parameters for all found elements, including the referenced elements. As a result, extra property tabs are available in Autodesk Navisworks.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


NestedFamilyTypeReference Members

[image] [image]

Revit 2024 API
NestedFamilyTypeReference Members
NestedFamilyTypeReference Class Methods Properties See Also Send Feedback

The NestedFamilyTypeReference type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CategoryId | Category Id of the referenced family
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Name of the referenced family
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | TypeName | Type of the referenced family
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

NestedFamilyTypeReference Class


NestedFamilyTypeReference Methods

[image] [image]

Revit 2024 API
NestedFamilyTypeReference Methods
NestedFamilyTypeReference Class See Also Send Feedback

The NestedFamilyTypeReference type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

NestedFamilyTypeReference Class


NestedFamilyTypeReference Properties

[image] [image]

Revit 2024 API
NestedFamilyTypeReference Properties
NestedFamilyTypeReference Class See Also Send Feedback

The NestedFamilyTypeReference type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CategoryId | Category Id of the referenced family
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Name of the referenced family
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | TypeName | Type of the referenced family
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

NestedFamilyTypeReference Class


CategoryId Property

[image]

Revit 2024 API
NestedFamilyTypeReference..::..CategoryId Property
NestedFamilyTypeReference Class See Also Send Feedback
Category Id of the referenced family

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public ElementId CategoryId { get; }
Visual Basic
Public ReadOnly Property CategoryId As ElementId
    Get
Visual C++
public:
property ElementId^ CategoryId {
    ElementId^ get ();
}

See Also

NestedFamilyTypeReference Class


FamilyName Property

[image]

Revit 2024 API
NestedFamilyTypeReference..::..FamilyName Property
NestedFamilyTypeReference Class See Also Send Feedback
Name of the referenced family

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public string FamilyName { get; }
Visual Basic
Public ReadOnly Property FamilyName As String
    Get
Visual C++
public:
property String^ FamilyName {
    String^ get ();
}

See Also

NestedFamilyTypeReference Class


Parameter Property

[image] [image]

Revit 2024 API
NestedFamilyTypeReference..::..Parameter Property
NestedFamilyTypeReference Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

NestedFamilyTypeReference Class
NestedFamilyTypeReference Members


TypeName Property

[image]

Revit 2024 API
NestedFamilyTypeReference..::..TypeName Property
NestedFamilyTypeReference Class See Also Send Feedback
Type of the referenced family

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public string TypeName { get; }
Visual Basic
Public ReadOnly Property TypeName As String
    Get
Visual C++
public:
property String^ TypeName {
    String^ get ();
}

See Also

NestedFamilyTypeReference Class


NullParameterValue Methods

[image] [image]

Revit 2024 API
NullParameterValue Methods
NullParameterValue Class See Also Send Feedback

The NullParameterValue type exposes the following members.

Methods

 | Name | Description
Public method | Copy | Makes an identical copy of the given parameter value. (Inherited from ParameterValue.)
Public method | Dispose | (Inherited from ParameterValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Tests equality with another instance of the same class. (Inherited from ParameterValue.)
Public method | IsSameType | Tests another instance is of the same value type. (Inherited from ParameterValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

NullParameterValue Class


NullParameterValue Properties

[image] [image]

Revit 2024 API
NullParameterValue Properties
NullParameterValue Class See Also Send Feedback

The NullParameterValue type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ParameterValue.)

See Also

NullParameterValue Class


NumberingSchema Class

[image]

Revit 2024 API
NumberingSchema Class
Members Example See Also Send Feedback
A class to support assigning numbers to elements of a particular kind for the purpose of tagging and scheduling them.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public class NumberingSchema : Element
Visual Basic
Public Class NumberingSchema _
    Inherits Element
Visual C++
public ref class NumberingSchema : public Element

Remarks

Each NumberingSchema controls numbering of elements of one particular kind, typically of the same category such as Rebar or Fabric Reinforcement. Instances of NumberingSchema are also elements and there is always only one of each type in every Revit document. Available types of all built-in numbering schemas are enumerated in NumberingSchemaTypes class. At present, schema elements cannot be manually added, deleted, or copied. Attempts to do so will result in a failure warning and/or exceptions thrown.

Elements (e.g. Rebar) belonging to a particular schema (e.g. NumberingSchemaTypes.StructuralNumberingSchemas.Rebar) are organized and numbered in sequences. A sequence is a collection of elements that share the same numbering partition as defined by their respective values of the Partition parameter (NUMBER_PARTITION_PARAM). For a numbering sequence to exist it must contain at least one element. In other words, a sequence is established once there is at least one element of which the partition parameter has a value that differs from other elements (in the same numbering schema). If the last element is removed (deleted or moved to a different sequence) the then empty sequence ceases to exist.

Elements get assigned to sequences either upon their creation (based on the then current numbering partition value), or by explicitly modifying the Partition parameter of an element, or by using the AssignElementsToSequence method. It is highly recommended using that method over explicitly changing the Partition parameter, because the methods applies changes to sequences and element numbers immediately, while changed parameters get into effect only after the current transaction is closed.

In addition to directly or indirectly changing the Partition parameter of elements, numbering sequences can be reorganized by using methods of the NumberingSchema class. The MoveSequence method moves all elements of an existing sequence to a new sequence that does not exist yet in the schema, thus effectively renaming the Partition parameter on all the affected elements. The AppendSequence method removes all elements from one sequence and appends them to elements of another existing sequence while applying the matching policy. The method MergeSequences takes elements of all specified sequences and moves them all into a newly created sequence. All the merged elements will be renumbered and matched as needed based on the matching algorithm.

Elements in different sequences are numbered independently, meaning that there may be elements with the same number in two sequences even though the elements are different. Likewise, there may be perfectly identical elements in two or more sequences bearing different numbers. However, within each one numbering sequence any two identical elements will always have the same number, while different elements will never have the same number within a numbering sequence. Revit refers to this rule as the matching policy.

Enumerable elements are always numbered automatically upon their creation. Each new element will get an incrementally higher number. However, thanks to the matching policy, new elements that match existing elements within the same sequence will get the same number assigned. Elements will keep their assigned numbers as long as it is possible. This means, for example, that if some previously created elements (e.g. Rebar) get deleted, all remaining elements (within the same numbering sequence) will keep their numbers, which may result in gaps in the respective numbering sequence. Gaps can be removed by invoking RemoveGaps for sequences in which gaps are not desired.

Numbers are stored as values of a numbering parameter on each numbered element. The Id of the parameter is obtained by querying the NumberingParameterId property. The value of the number can be obtained by querying the parameter for the respective numbered element. The value is read-only and thus cannot be set; it is always computed based on relations of elements across numbering partitions and the matching policy within the numbering sequence of each element.

Even though numbers are always assigned automatically to all elements of a schema, the method ChangeNumber gives the programmer a way to explicitly overwrite a specific number as long as the new number is unique in the numbering sequence. The caller specifies a number to be changed and a new value that is to be applied, providing the value does not exist yet in the same numbering sequence. Although this operation may seem rather limited, it provides the programmer with freedom to change practically any number even if it may be achieved in multiple steps.

Examples

CopyC#
/// <summary>
/// This function consolidates the numbers on Rebar elements by removing
/// any remaining gaps in numbering sequences and setting the start number
/// of each sequence so numbers in sequences do not overlap.
/// </summary>
/// <param name="document">The document in which Rebar numbers are to be consolidated</param>
private void ConsolidateRebarNumbers(Document document)
{
    // Obtain a schema object for a particular kind of elements
    NumberingSchema schema = NumberingSchema.GetNumberingSchema(document,NumberingSchemaTypes.StructuralNumberingSchemas.Rebar);

    // Collect the names of partitions of all the numbering sequences currently contained in the schema
    IList<string> sequences = schema.GetNumberingSequences();

    using (Transaction transaction = new Transaction(document))
    {
        // Changes to numbers must be made inside a transaction
        transaction.Start("Consolidate Rebar Numbers");

        // First we make sure numbers in all sequences are consecutive
        // by removing possible gaps in numbers. Note: RemoveGaps does
        // nothing for a sequence where there are no gaps present.

        // We also want to find what the maximum range of numbers is
        // of all the sequences (the one the widest span of used numbers)
        int maxRange = 0;

        foreach (string name in sequences)
        {
            schema.RemoveGaps(name);

            // Here we use First() from the Linq extension.
            // There is always at least one range in every sequence,
            // and after gaps are closed there is exactly one range.
            IntegerRange range = schema.GetNumbers(name).First();
            int rangeSpan = 1 + (range.High - range.Low);
            if (rangeSpan > maxRange)
            {
                maxRange = rangeSpan;
            }
        }

        // Next we give sequences different start numbers
        // starting with 100 and then stepping by at least
        // the maximum range we found in the previous step
        int startNumber = 100;

        // We round the range up to the closest 100
        int step = 100 * (int)((maxRange + 99) / 100.0);

        foreach (string name in sequences)
        {
            schema.ShiftNumbers(name, startNumber);
            startNumber += step;
        }

        transaction.Commit();
    }
}
CopyVB.NET
''' <summary>
''' This function consolidates the numbers on Rebar elements by removing
''' any remaining gaps in numbering sequences and setting the start number
''' of each sequence so numbers in sequences do not overlap.
''' </summary>
''' <param name="document">The document in which Rebar numbers are to be consolidated</param>
Private Sub ConsolidateRebarNumbers(document As Document)
    ' Obtain a schema object for a particular kind of elements
    Dim schema As NumberingSchema = NumberingSchema.GetNumberingSchema(document, NumberingSchemaTypes.StructuralNumberingSchemas.Rebar)

    ' Collect the names of partitions of all the numbering sequences currently contained in the schema
    Dim sequences As IList(Of String) = schema.GetNumberingSequences()

    Using transaction As New Transaction(document)
        ' Changes to numbers must be made inside a transaction
        transaction.Start("Consolidate Rebar Numbers")

        ' First we make sure numbers in all sequences are consecutive
        ' by removing possible gaps in numbers. Note: RemoveGaps does
        ' nothing for a sequence where there are no gaps present.

        ' We also want to find what the maximum range of numbers is
        ' of all the sequences (the one the widest span of used numbers)
        Dim maxRange As Integer = 0

        For Each name As String In sequences
            schema.RemoveGaps(name)

            ' Here we use First() from the Linq extension.
            ' There is always at least one range in every sequence,
            ' and after gaps are closed there is exactly one range.
            Dim range As IntegerRange = schema.GetNumbers(name).First()
            Dim rangeSpan As Integer = 1 + (range.High - range.Low)
            If rangeSpan > maxRange Then
                maxRange = rangeSpan
            End If
        Next

        ' Next we give sequences different start numbers
        ' starting with 100 and then stepping by at least
        ' the maximum range we found in the previous step
        Dim startNumber As Integer = 100

        ' We round the range up to the closest 100
        Dim [step] As Integer = 100 * CInt(Math.Truncate((maxRange + 99) / 100.0))

        For Each name As String In sequences
            schema.ShiftNumbers(name, startNumber)
            startNumber += [step]
        Next

        transaction.Commit()
    End Using
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..NumberingSchema

See Also

NumberingSchema Members


NumberingSchema Members

[image] [image]

Revit 2024 API
NumberingSchema Members
NumberingSchema Class Methods Properties See Also Send Feedback

The NumberingSchema type exposes the following members.

Methods

 | Name | Description
Public method | AppendSequence | Appends all elements of one numbering sequence to the end of another sequence.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | AssignElementsToSequence | Assigns the input elements to a sequence identified by the given partition name.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeNumber | Replaces an existing number with a new one (that does not exist yet).
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
 | GetMinimumNumberOfDigits | Returns the minimum number of digits to be used for formating the Number parameter of all enumerable elements of the given document.
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
 | GetNumberingSchema | Returns an instance of the specified Numbering Schema in the given document.
Public method | GetNumberingSequences | Returns all numbering sequences within this numbering schema.
Public method | GetNumbers | Returns all numbers currently used in the given numbering sequence
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
 | GetSchemasInDocument | Returns a set of Ids of all Numbering Schema elements for a given document.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
 | IsValidPartitionName | Tests if the given string can be used as a name for a numbering partition.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | MergeSequences | Merges all elements from given numbering sequences to a new sequence.
Public method | MoveSequence | Moves all elements of a numbering sequence from one partition to another.
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | RemoveGaps | Removes gaps, if any, in a numbering sequence
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
 | SetMinimumNumberOfDigits | Sets a new value for the minimum number of digits to be used for formating the Number parameter of all numbered elements of the given document.
Public method | ShiftNumbers | Shifts all numbers in the sequence so the starting number has the given value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
 | MaximumStartingNumber | A static property defining the maximum number a numbering sequence can use as its starting number (the lowest number in the sequence).
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | NumberingParameterId | Id of the parameter that stores values of the numbers on enumerated elements.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SchemaType | Identifies the kind of elements/objects this numbering schema is used for.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

NumberingSchema Class


AppendSequence Method

[image]

Revit 2024 API
NumberingSchema..::..AppendSequence Method
NumberingSchema Class See Also Send Feedback
Appends all elements of one numbering sequence to the end of another sequence.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public void AppendSequence(
    string fromPartition,
    string toPartition
)
Visual Basic
Public Sub AppendSequence ( _
    fromPartition As String, _
    toPartition As String _
)
Visual C++
public:
void AppendSequence(
    String^ fromPartition,
    String^ toPartition
)

Parameters

fromPartition
Type: System..::..String
Name of the partition that determines which numbering sequence to append. The sequence must exist already, otherwise an exception will be thrown.
toPartition
Type: System..::..String
Name of a partition into which the source sequence is going to be appended. The sequence must exist already, otherwise an exception will be thrown.

Remarks

All numbers assigned to elements in the target sequence remain the same, but numbers in the source sequence (the one getting appended) will change. Elements that match elements in the target sequence will get the same numbers assigned. Remaining elements will get consecutive numbers in the creation order of the elements starting with the next highest number available in the target sequence.

This operation modifies the Partition parameter of all elements in the sequence that is getting appended. Therefore, all its elements must be accessible for editing, otherwise this operation will fail.

Elements can be appended only to a sequence that already exists. In order to reassign elements of one sequence to a partition that does not exist yet, use either the MoveSequence or MergeSequences methods.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The sequence fromPartition does not exist in the schema. -or- The sequence toPartition does not exist in the schema. -or- Given partition names fromPartition and toPartition must be different.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | Either the schema or its document cannot be modified at present. -or- Thrown if there is an element that cannot have new value of the NUMBER_PARTITION_PARAM parameter assigned. It may be an indication that the element is not free to be edited at present.

See Also

NumberingSchema Class


GetMinimumNumberOfDigits Method

[image]

Revit 2024 API
NumberingSchema..::..GetMinimumNumberOfDigits Method
NumberingSchema Class See Also Send Feedback
Returns the minimum number of digits to be used for formating the Number parameter of all enumerable elements of the given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static int GetMinimumNumberOfDigits(
    Document document
)
Visual Basic
Public Shared Function GetMinimumNumberOfDigits ( _
    document As Document _
) As Integer
Visual C++
public:
static int GetMinimumNumberOfDigits(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document this value is going to be applied to.

Return Value

The current number of formatting digits

Remarks

The number is used by all numbering schemas in the document.

The value can be modified by using the SetMinimumNumberOfDigits(Document, Int32) method.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

NumberingSchema Class


GetNumberingSequences Method

[image]

Revit 2024 API
NumberingSchema..::..GetNumberingSequences Method
NumberingSchema Class See Also Send Feedback
Returns all numbering sequences within this numbering schema.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public IList<string> GetNumberingSequences()
Visual Basic
Public Function GetNumberingSequences As IList(Of String)
Visual C++
public:
IList<String^>^ GetNumberingSequences()

Return Value

A collection of partition names of all numbering sequences currently present in this schema.

Remarks

The collection may be empty if there are no elements yet in this schema.

One of the strings can be an empty string, which would indicate presence of the default partition into which elements automatically belong if left unassigned to any other partition

See Also

NumberingSchema Class


GetNumbers Method

[image]

Revit 2024 API
NumberingSchema..::..GetNumbers Method
NumberingSchema Class See Also Send Feedback
Returns all numbers currently used in the given numbering sequence

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public IList<IntegerRange> GetNumbers(
    string partition
)
Visual Basic
Public Function GetNumbers ( _
    partition As String _
) As IList(Of IntegerRange)
Visual C++
public:
IList<IntegerRange^>^ GetNumbers(
    String^ partition
)

Parameters

partition
Type: System..::..String
Name of the partition that identifies the sequence. The sequence must exist.

Return Value

A collection of integer ranges

Remarks

Numbers are returned as a collection of ranges, where each range is a pair of two integer values, Low and High. As long as there is no gap currently in the sequence, there will be only one range.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The sequence partition does not exist in the schema.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

NumberingSchema Class


GetSchemasInDocument Method

[image]

Revit 2024 API
NumberingSchema..::..GetSchemasInDocument Method
NumberingSchema Class See Also Send Feedback
Returns a set of Ids of all Numbering Schema elements for a given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static ISet<ElementId> GetSchemasInDocument(
    Document document
)
Visual Basic
Public Shared Function GetSchemasInDocument ( _
    document As Document _
) As ISet(Of ElementId)
Visual C++
public:
static ISet<ElementId^>^ GetSchemasInDocument(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
A document to get numbering schema from.

Return Value

Ids of NumberingSchema elements. An empty set if no schemas are found in the given document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

NumberingSchema Class


IsValidPartitionName Method

[image]

Revit 2024 API
NumberingSchema..::..IsValidPartitionName Method
NumberingSchema Class See Also Send Feedback
Tests if the given string can be used as a name for a numbering partition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static bool IsValidPartitionName(
    string name,
    out string message
)
Visual Basic
Public Shared Function IsValidPartitionName ( _
    name As String, _
    <OutAttribute> ByRef message As String _
) As Boolean
Visual C++
public:
static bool IsValidPartitionName(
    String^ name,
    [OutAttribute] String^% message
)

Parameters

name
Type: System..::..String
A name to validate.
message
Type: System..::..String%
Optional string to receive an error message to possibly show to the end user in case the name is found invalid. This argument may be null.

Return Value

Returns True if the name can be used; or False if the string contains invalid characters.

Remarks

For a name to be considered valid it must contain only printable characters excluding any characters that may not be used in name of a file.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

NumberingSchema Class


MergeSequences Method

[image]

Revit 2024 API
NumberingSchema..::..MergeSequences Method
NumberingSchema Class See Also Send Feedback
Merges all elements from given numbering sequences to a new sequence.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public void MergeSequences(
    IList<string> sourcePartitions,
    string newPartition
)
Visual Basic
Public Sub MergeSequences ( _
    sourcePartitions As IList(Of String), _
    newPartition As String _
)
Visual C++
public:
void MergeSequences(
    IList<String^>^ sourcePartitions,
    String^ newPartition
)

Parameters

sourcePartitions
Type: System.Collections.Generic..::..IList<(Of <(<'String>)>)>
A collection of partition names identifying the sequences to be merged together. There must be at least two names in the list. All the sequences must exist already.
newPartition
Type: System..::..String
Name of a new partition into which the source sequences will be merged. Leading and trailing white space is ignored in the given string and will be removed automatically.

Remarks

Upon a successful merge, all elements in the new merged sequence will be renumbered in order of the element creation. There will be no gaps.

There must not be a sequence for the target partition in the schema yet, otherwise an exception will be thrown.

This operation modifies the Partition parameter of all elements in the sequences that are being merged. Therefore, all its elements must be accessible for editing, otherwise this operation will fail.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The sourcePartitions list must contain at least two names. -or- Either one or more sequences in the sourcePartitions list does not exist in the schema, or the list contains duplicated names. -or- The sequence newPartition does already exist in the schema. -or- the given newPartition cannot be used as a valid name of a numbering partition because it contains characters that are considered invalid, such as non-printable characters or those that cannot be used in a file's name.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | Either the schema or its document cannot be modified at present. -or- Thrown if there is an element that cannot have new value of the NUMBER_PARTITION_PARAM parameter assigned. It may be an indication that the element is not free to be edited at present.

See Also

NumberingSchema Class


MoveSequence Method

[image]

Revit 2024 API
NumberingSchema..::..MoveSequence Method
NumberingSchema Class Example See Also Send Feedback
Moves all elements of a numbering sequence from one partition to another.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public void MoveSequence(
    string fromPartition,
    string newPartition
)
Visual Basic
Public Sub MoveSequence ( _
    fromPartition As String, _
    newPartition As String _
)
Visual C++
public:
void MoveSequence(
    String^ fromPartition,
    String^ newPartition
)

Parameters

fromPartition
Type: System..::..String
Name of the partition that determines which numbering sequence to move. The sequence must exist already, otherwise an exception will be thrown.
newPartition
Type: System..::..String
Name of a partition into which the source sequence is going to be moved. The schema must not have a sequence for this partition yet (i.e. the schema does not have an element that was assigned to such a partition.)

Leading and trailing white space is ignored in the given string and will be removed automatically.

Remarks

All numbers assigned to elements in the sequence remain the same.

This operation modifies the Partition parameter of all elements in the given sequence. Therefore, all the elements must be accessible for editing.

Elements can be moved only to a partition that does not exist yet. To move elements to an existing partition use the AppendSequence method.

Examples

CopyC#
/// <summary>
/// This method uses multiple moving operations to swap numbers
/// for Rebars in two numbering sequences. The sequences are
/// identified by the names of two numbering partitions.
/// </summary>
/// <param name="document">Document to modify</param>
/// <param name="part1">Name of the partition of one numbering sequence</param>
/// <param name="part2">Name of the partition of another numbering sequence</param>
private void SwapNumberingSequences(Document document, string part1, string part2)
{
    // Obtain a schema object for a particular kind of elements
    NumberingSchema schema = NumberingSchema.GetNumberingSchema(document,NumberingSchemaTypes.StructuralNumberingSchemas.Rebar);

    using (Transaction transaction = new Transaction(document))
    {
        // Changes to numbering sequences must be made inside a transaction
        transaction.Start("Swap Numbering Sequences");

        // We will use a temporary partition for the swap operation,
        // for the move operation only works if the target partition
        // does not exist yet in the same numbering schema.
        // (We assume this TEMPORARY partition does not exist.)
        string tempPartition = "TEMPORARY";

        // Step 1
        // First we move all elements from one sequence into
        // a partition we know does not exist. This action will
        // create the temporary partition and remove the original
        // one (part1).
        schema.MoveSequence(part1, tempPartition);

        // Step 2
        // With the sequence in partition 'part1' removed
        // we can now move elements from the second sequence to it.
        // This action will re-create a sequence in partition 'part1'
        // and remove the sequence in partition 'part2'
        schema.MoveSequence(part2, part1);

        // Step 3
        // Finally, we can move elements 'parked' in the temporary
        // sequence to partition 'part2', for that partition was
        // removed in the previous step and thus can now be created
        // again. The temporary partition will be automatically
        // removed upon completing this step.
        schema.MoveSequence(tempPartition, part2);

        transaction.Commit();
    }
}
CopyVB.NET
''' <summary>
''' This method uses multiple moving operations to swap numbers
''' for Rebars in two numbering sequences. The sequences are
''' identified by the names of two numbering partitions.
''' </summary>
''' <param name="document">Document to modify</param>
''' <param name="part1">Name of the partition of one numbering sequence</param>
''' <param name="part2">Name of the partition of another numbering sequence</param>
Private Sub SwapNumberingSequences(document As Document, part1 As String, part2 As String)
    ' Obtain a schema object for a particular kind of elements
    Dim schema As NumberingSchema = NumberingSchema.GetNumberingSchema(document, NumberingSchemaTypes.StructuralNumberingSchemas.Rebar)

    Using transaction As New Transaction(document)
        ' Changes to numbering sequences must be made inside a transaction
        transaction.Start("Swap Numbering Sequences")

        ' We will use a temporary partition for the swap operation,
        ' for the move operation only works if the target partition
        ' does not exist yet in the same numbering schema.
        ' (We assume this TEMPORARY partition does not exist.)
        Dim tempPartition As String = "TEMPORARY"

        ' Step 1
        ' First we move all elements from one sequence into
        ' a partition we know does not exist. This action will
        ' create the temporary partition and remove the original
        ' one (part1).
        schema.MoveSequence(part1, tempPartition)

        ' Step 2
        ' With the sequence in partition 'part1' removed
        ' we can now move elements from the second sequence to it.
        ' This action will re-create a sequence in partition 'part1'
        ' and remove the sequence in partition 'part2'
        schema.MoveSequence(part2, part1)

        ' Step 3
        ' Finally, we can move elements 'parked' in the temporary
        ' sequence to partition 'part2', for that partition was
        ' removed in the previous step and thus can now be created
        ' again. The temporary partition will be automatically
        ' removed upon completing this step.
        schema.MoveSequence(tempPartition, part2)

        transaction.Commit()
    End Using
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The sequence fromPartition does not exist in the schema. -or- The sequence newPartition does already exist in the schema. -or- the given newPartition cannot be used as a valid name of a numbering partition because it contains characters that are considered invalid, such as non-printable characters or those that cannot be used in a file's name.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | Either the schema or its document cannot be modified at present. -or- Thrown if there is an element that cannot have new value of the NUMBER_PARTITION_PARAM parameter assigned. It may be an indication that the element is not free to be edited at present.

See Also

NumberingSchema Class


RemoveGaps Method

[image]

Revit 2024 API
NumberingSchema..::..RemoveGaps Method
NumberingSchema Class See Also Send Feedback
Removes gaps, if any, in a numbering sequence

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public void RemoveGaps(
    string partition
)
Visual Basic
Public Sub RemoveGaps ( _
    partition As String _
)
Visual C++
public:
void RemoveGaps(
    String^ partition
)

Parameters

partition
Type: System..::..String
Name of the partition that identifies the sequence. The sequence must exist.

Remarks

Gaps are removed by shifting numbers above each gap down by the amount of numbers skipped in the gap. The lowest number in the sequence will remain unchanged.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The sequence partition does not exist in the schema.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | Either the schema or its document cannot be modified at present.

See Also

NumberingSchema Class


SetMinimumNumberOfDigits Method

[image]

Revit 2024 API
NumberingSchema..::..SetMinimumNumberOfDigits Method
NumberingSchema Class See Also Send Feedback
Sets a new value for the minimum number of digits to be used for formating the Number parameter of all numbered elements of the given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static void SetMinimumNumberOfDigits(
    Document document,
    int value
)
Visual Basic
Public Shared Sub SetMinimumNumberOfDigits ( _
    document As Document, _
    value As Integer _
)
Visual C++
public:
static void SetMinimumNumberOfDigits(
    Document^ document,
    int value
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which the new value will be in applied.
value
Type: System..::..Int32
New value for the minimum number of digits.

Remarks

Valid values range from 1 to 10. Numbers with fewer digits than the minimum number will be padded with leading zeros.

The value affects all numbering schemas. Thus, once set, numbers for Rebar and Reinforcement Fabric will be formatted with the same minimum number of digits.

The current value can obtained by invoking the GetMinimumNumberOfDigits(Document) method.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The minimum number of digits must be in range from 1 to 10.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

NumberingSchema Class


ShiftNumbers Method

[image]

Revit 2024 API
NumberingSchema..::..ShiftNumbers Method
NumberingSchema Class See Also Send Feedback
Shifts all numbers in the sequence so the starting number has the given value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public void ShiftNumbers(
    string partition,
    int firstNumber
)
Visual Basic
Public Sub ShiftNumbers ( _
    partition As String, _
    firstNumber As Integer _
)
Visual C++
public:
void ShiftNumbers(
    String^ partition,
    int firstNumber
)

Parameters

partition
Type: System..::..String
Name of the partition that identifies the sequence. The sequence must exist.
firstNumber
Type: System..::..Int32
Value for the new first (lowest) number of the sequence.

Remarks

A shift of all numbers in the sequence will be computed and applied so the first (lowest) number in the sequence would have the given value. All the other numbers will then be shifted relatively by the same amount.

Any existing gaps in the current numbering sequence will be preserved.

Shifts that would make the start number less than 1 or bigger than MaximumStartingNumber are considered invalid.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The sequence partition does not exist in the schema.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | firstNumber must be in range between 1 and MaximumStartingNumber.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Either the schema or its document cannot be modified at present.

See Also

NumberingSchema Class


NumberingSchema Properties

[image] [image]

Revit 2024 API
NumberingSchema Properties
NumberingSchema Class See Also Send Feedback

The NumberingSchema type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
 | MaximumStartingNumber | A static property defining the maximum number a numbering sequence can use as its starting number (the lowest number in the sequence).
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | NumberingParameterId | Id of the parameter that stores values of the numbers on enumerated elements.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SchemaType | Identifies the kind of elements/objects this numbering schema is used for.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

NumberingSchema Class


NumberingParameterId Property

[image]

Revit 2024 API
NumberingSchema..::..NumberingParameterId Property
NumberingSchema Class See Also Send Feedback
Id of the parameter that stores values of the numbers on enumerated elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public ElementId NumberingParameterId { get; }
Visual Basic
Public ReadOnly Property NumberingParameterId As ElementId
    Get
Visual C++
public:
property ElementId^ NumberingParameterId {
    ElementId^ get ();
}

Remarks

Values of numbers can be obtained by querying this parameter for the respective numbered element. The value is read-only and thus cannot be set; it is always computed based on the order of created elements and the matching policy within each numbering sequence.

Note: Although the parameter cannot be changed directly, it can be modified indirectly (with restrictions) using the ChangeNumber(String, Int32, Int32) method.

See Also

NumberingSchema Class


SchemaType Property

[image]

Revit 2024 API
NumberingSchema..::..SchemaType Property
NumberingSchema Class See Also Send Feedback
Identifies the kind of elements/objects this numbering schema is used for.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public NumberingSchemaType SchemaType { get; }
Visual Basic
Public ReadOnly Property SchemaType As NumberingSchemaType
    Get
Visual C++
public:
property NumberingSchemaType^ SchemaType {
    NumberingSchemaType^ get ();
}

See Also

NumberingSchema Class


NumberingSchemaType Members

[image] [image]

Revit 2024 API
NumberingSchemaType Members
NumberingSchemaType Class Constructors Methods Operators Properties See Also Send Feedback

The NumberingSchemaType type exposes the following members.

Constructors

 | Name | Description
Public method | NumberingSchemaType | Creates a new NumberingSchemaType instance.

Methods

 | Name | Description
Public method | Equals | Compares two Guid-based enum object based on their concrete class and GUID value. (Inherited from GuidEnum.)
Public method | GetHashCode | Generates a hash code for this Guid-based enum object. (Inherited from GuidEnum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Operators

Name | Description
Equality | Compares two NumberingSchemaType instances.
Inequality | Compares two NumberingSchemaType instances.

Properties

 | Name | Description
Public property | Guid | The Guid of GUID-based enum object. (Inherited from GuidEnum.)

See Also

NumberingSchemaType Class


NumberingSchemaType Constructor

[image]

Revit 2024 API
NumberingSchemaType Constructor
NumberingSchemaType Class See Also Send Feedback
Creates a new NumberingSchemaType instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public NumberingSchemaType(
    Guid guid
)
Visual Basic
Public Sub New ( _
    guid As Guid _
)
Visual C++
public:
NumberingSchemaType(
    Guid guid
)

Parameters

guid
Type: System..::..Guid
The identifier for the NumberingSchemaType.

See Also

NumberingSchemaType Class


NumberingSchemaType Methods

[image] [image]

Revit 2024 API
NumberingSchemaType Methods
NumberingSchemaType Class See Also Send Feedback

The NumberingSchemaType type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Compares two Guid-based enum object based on their concrete class and GUID value. (Inherited from GuidEnum.)
Public method | GetHashCode | Generates a hash code for this Guid-based enum object. (Inherited from GuidEnum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

NumberingSchemaType Class


NumberingSchemaType Operators

[image] [image]

Revit 2024 API
NumberingSchemaType Operators
NumberingSchemaType Class See Also Send Feedback

The NumberingSchemaType type exposes the following members.

Operators

Name | Description
Equality | Compares two NumberingSchemaType instances.
Inequality | Compares two NumberingSchemaType instances.

See Also

NumberingSchemaType Class


NumberingSchemaType Properties

[image] [image]

Revit 2024 API
NumberingSchemaType Properties
NumberingSchemaType Class See Also Send Feedback

The NumberingSchemaType type exposes the following members.

Properties

 | Name | Description
Public property | Guid | The Guid of GUID-based enum object. (Inherited from GuidEnum.)

See Also

NumberingSchemaType Class


NumberingSchemaTypes.StructuralNumberingSchemas Properties

[image] [image]

Revit 2024 API
NumberingSchemaTypes..::..StructuralNumberingSchemas Properties
NumberingSchemaTypes..::..StructuralNumberingSchemas Class See Also Send Feedback

The NumberingSchemaTypes..::..StructuralNumberingSchemas type exposes the following members.

Properties

Name | Description
Rebar | Built-in schema used for numbering rebar elements
RebarCoupler | Built-in schema used for numbering rebar coupler elements
ReinforcementFabric | Built-in schema used for numbering fabric reinforcement elements

See Also

NumberingSchemaTypes..::..StructuralNumberingSchemas Class


RebarCoupler Property

[image]

Revit 2024 API
NumberingSchemaTypes..::..StructuralNumberingSchemas..::..RebarCoupler Property
NumberingSchemaTypes..::..StructuralNumberingSchemas Class See Also Send Feedback
Built-in schema used for numbering rebar coupler elements

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static NumberingSchemaType RebarCoupler { get; }
Visual Basic
Public Shared ReadOnly Property RebarCoupler As NumberingSchemaType
    Get
Visual C++
public:
static property NumberingSchemaType^ RebarCoupler {
    NumberingSchemaType^ get ();
}

See Also

NumberingSchemaTypes..::..StructuralNumberingSchemas Class


ReinforcementFabric Property

[image]

Revit 2024 API
NumberingSchemaTypes..::..StructuralNumberingSchemas..::..ReinforcementFabric Property
NumberingSchemaTypes..::..StructuralNumberingSchemas Class See Also Send Feedback
Built-in schema used for numbering fabric reinforcement elements

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static NumberingSchemaType ReinforcementFabric { get; }
Visual Basic
Public Shared ReadOnly Property ReinforcementFabric As NumberingSchemaType
    Get
Visual C++
public:
static property NumberingSchemaType^ ReinforcementFabric {
    NumberingSchemaType^ get ();
}

See Also

NumberingSchemaTypes..::..StructuralNumberingSchemas Class


NumberSystem Class

[image]

Revit 2024 API
NumberSystem Class
Members See Also Send Feedback
An annotation that consists of a series of numeric tags attached to and describing a host element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public class NumberSystem : Element
Visual Basic
Public Class NumberSystem _
    Inherits Element
Visual C++
public ref class NumberSystem : public Element

Remarks

For a component-based stair, you can display tread/riser numbers for a run in plan, elevation, or section view. Sketch-based stair is not supported.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..NumberSystem

See Also

NumberSystem Members


NumberSystem Members

[image] [image]

Revit 2024 API
NumberSystem Members
NumberSystem Class Methods Properties See Also Send Feedback

The NumberSystem type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create(Document, ElementId, LinkElementId, Reference) | Creates a new instance of a NumberSystem associated to a host element and a view.
 | Create(Document, ElementId, LinkElementId, StairsNumberSystemReferenceOption, LinkElementId) | Creates a new instance of a NumberSystem associated to a host element, a view, and a reference level of stairs if in a multistory stairs.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetReferencePick | Gets the reference curve.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetReferencePick | Sets the reference pick.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | JustifyOffset | The offset to the justification curve.
Public property | JustifyOption | The number justify option of number system.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | NumberDisplayRule | The display rule of the number system.
Public property | NumberedElementId | The LinkElementId of the numbered host element.
Public property | NumberOrientation | The number orientation of number system.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | PlacementLevelId | The id of the base level of stairs on which the NumberSystem is placed.
Public property | ReferenceOffset | The offset to the reference curve.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

NumberSystem Class


NumberSystem Methods

[image] [image]

Revit 2024 API
NumberSystem Methods
NumberSystem Class See Also Send Feedback

The NumberSystem type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create(Document, ElementId, LinkElementId, Reference) | Creates a new instance of a NumberSystem associated to a host element and a view.
 | Create(Document, ElementId, LinkElementId, StairsNumberSystemReferenceOption, LinkElementId) | Creates a new instance of a NumberSystem associated to a host element, a view, and a reference level of stairs if in a multistory stairs.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetReferencePick | Gets the reference curve.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetReferencePick | Sets the reference pick.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

NumberSystem Class


Create Method (Document, ElementId, LinkElementId, Reference)

[image]

Revit 2024 API
NumberSystem..::..Create Method (Document, ElementId, LinkElementId, Reference)
NumberSystem Class See Also Send Feedback
Creates a new instance of a NumberSystem associated to a host element and a view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public static NumberSystem Create(
    Document document,
    ElementId viewId,
    LinkElementId numberedElementId,
    Reference referenceCurve
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    viewId As ElementId, _
    numberedElementId As LinkElementId, _
    referenceCurve As Reference _
) As NumberSystem
Visual C++
public:
static NumberSystem^ Create(
    Document^ document,
    ElementId^ viewId,
    LinkElementId^ numberedElementId,
    Reference^ referenceCurve
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
viewId
Type: Autodesk.Revit.DB..::..ElementId
The view in which the NumberSystem will be created.
numberedElementId
Type: Autodesk.Revit.DB..::..LinkElementId
The host id on which the NumberSystem will be created.
referenceCurve
Type: Autodesk.Revit.DB..::..Reference
The reference curve along which the NumberSystem will be created. It is suggested to get the new reference via GetNumberSystemReference() from the host element.

Return Value

The created NumberSystem.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | viewId is not valid for placement of a NumberSystem (only floor plan views and elevation views are permitted). -or- numberedElementId is not valid as a host for NumberSystem (only StairsRun elements are permitted in this release). -or- The referenceCurve is not valid for NumberSystem on numberedElementId. -or- The numberedElementId already has a NumberSystem.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

NumberSystem Class
Create Overload


Create Method (Document, ElementId, LinkElementId, StairsNumberSystemReferenceOption, LinkElementId)

[image]

Revit 2024 API
NumberSystem..::..Create Method (Document, ElementId, LinkElementId, StairsNumberSystemReferenceOption, LinkElementId)
NumberSystem Class See Also Send Feedback
Creates a new instance of a NumberSystem associated to a host element, a view, and a reference level of stairs if in a multistory stairs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public static NumberSystem Create(
    Document document,
    ElementId viewId,
    LinkElementId hostElementId,
    StairsNumberSystemReferenceOption referenceOption,
    LinkElementId placementLevelId
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    viewId As ElementId, _
    hostElementId As LinkElementId, _
    referenceOption As StairsNumberSystemReferenceOption, _
    placementLevelId As LinkElementId _
) As NumberSystem
Visual C++
public:
static NumberSystem^ Create(
    Document^ document,
    ElementId^ viewId,
    LinkElementId^ hostElementId,
    StairsNumberSystemReferenceOption referenceOption,
    LinkElementId^ placementLevelId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
viewId
Type: Autodesk.Revit.DB..::..ElementId
The view in which the NumberSystem will be created.
hostElementId
Type: Autodesk.Revit.DB..::..LinkElementId
The host id on which the NumberSystem will be created.
referenceOption
Type: Autodesk.Revit.DB.Architecture..::..StairsNumberSystemReferenceOption
The reference option of the NumberSystem.
placementLevelId
Type: Autodesk.Revit.DB..::..LinkElementId
The id of the level on which the NumberSystem will be placed. The placement level must be one of the base levels of a stairs group members. It is suggested to get the level from MultistoryStairs.GetStairsPlacementLevels().

Return Value

The created NumberSystem.

Remarks

In multistory stairs, a stairs element could be a stair group or individual stair. This method allows to add a NumberSystem for a run of an individual stairs or a stairs group member on the placementLevelId.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | viewId is not valid for placement of a NumberSystem (only floor plan views and elevation views are permitted). -or- hostElementId is not valid as a host for NumberSystem (only StairsRun elements are permitted in this release). -or- The reference option is not valid for a NumberSystem. -or- The placementLevelId is not one of the stairs base levels. -or- The hostElementId already has a number system.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

NumberSystem Class
Create Overload


GetReferencePick Method

[image]

Revit 2024 API
NumberSystem..::..GetReferencePick Method
NumberSystem Class See Also Send Feedback
Gets the reference curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public Reference GetReferencePick()
Visual Basic
Public Function GetReferencePick As Reference
Visual C++
public:
Reference^ GetReferencePick()

Return Value

The pick of reference curve.

See Also

NumberSystem Class


NumberSystem Properties

[image] [image]

Revit 2024 API
NumberSystem Properties
NumberSystem Class See Also Send Feedback

The NumberSystem type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | JustifyOffset | The offset to the justification curve.
Public property | JustifyOption | The number justify option of number system.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | NumberDisplayRule | The display rule of the number system.
Public property | NumberedElementId | The LinkElementId of the numbered host element.
Public property | NumberOrientation | The number orientation of number system.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | PlacementLevelId | The id of the base level of stairs on which the NumberSystem is placed.
Public property | ReferenceOffset | The offset to the reference curve.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

NumberSystem Class


JustifyOffset Property

[image]

Revit 2024 API
NumberSystem..::..JustifyOffset Property
NumberSystem Class See Also Send Feedback
The offset to the justification curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double JustifyOffset { get; set; }
Visual Basic
Public Property JustifyOffset As Double
    Get
    Set
Visual C++
public:
property double JustifyOffset {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for justifyOffset must be no more than 30000 feet in absolute value.

See Also

NumberSystem Class


JustifyOption Property

[image]

Revit 2024 API
NumberSystem..::..JustifyOption Property
NumberSystem Class See Also Send Feedback
The number justify option of number system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public NumberSystemJustifyOption JustifyOption { get; set; }
Visual Basic
Public Property JustifyOption As NumberSystemJustifyOption
    Get
    Set
Visual C++
public:
property NumberSystemJustifyOption JustifyOption {
    NumberSystemJustifyOption get ();
    void set (NumberSystemJustifyOption value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

NumberSystem Class


NumberDisplayRule Property

[image]

Revit 2024 API
NumberSystem..::..NumberDisplayRule Property
NumberSystem Class See Also Send Feedback
The display rule of the number system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public NumberSystemDisplayRule NumberDisplayRule { get; set; }
Visual Basic
Public Property NumberDisplayRule As NumberSystemDisplayRule
    Get
    Set
Visual C++
public:
property NumberSystemDisplayRule NumberDisplayRule {
    NumberSystemDisplayRule get ();
    void set (NumberSystemDisplayRule value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

NumberSystem Class


NumberedElementId Property

[image]

Revit 2024 API
NumberSystem..::..NumberedElementId Property
NumberSystem Class See Also Send Feedback
The LinkElementId of the numbered host element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public LinkElementId NumberedElementId { get; }
Visual Basic
Public ReadOnly Property NumberedElementId As LinkElementId
    Get
Visual C++
public:
property LinkElementId^ NumberedElementId {
    LinkElementId^ get ();
}

See Also

NumberSystem Class


NumberOrientation Property

[image]

Revit 2024 API
NumberSystem..::..NumberOrientation Property
NumberSystem Class See Also Send Feedback
The number orientation of number system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public TagOrientation NumberOrientation { get; set; }
Visual Basic
Public Property NumberOrientation As TagOrientation
    Get
    Set
Visual C++
public:
property TagOrientation NumberOrientation {
    TagOrientation get ();
    void set (TagOrientation value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: Orientation AnyModelDirection is not supported -or- When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

NumberSystem Class


Parameter Property

[image] [image]

Revit 2024 API
NumberSystem..::..Parameter Property
NumberSystem Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

NumberSystem Class
NumberSystem Members


NumberSystemDisplayRule Enumeration

[image]

Revit 2024 API
NumberSystemDisplayRule Enumeration
See Also Send Feedback
The available options for display of numeric values in the number system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public enum NumberSystemDisplayRule
Visual Basic
Public Enumeration NumberSystemDisplayRule
Visual C++
public enum class NumberSystemDisplayRule

Members

Member name | Description
All | The number system will display all the numbers.
Odd | The number system will only display the odd numbers.
Even | The number system will only display the even numbers.
StartAndEnd | The number system will only display the start and end numbers.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


NumberSystemJustifyOption Enumeration

[image]

Revit 2024 API
NumberSystemJustifyOption Enumeration
See Also Send Feedback
The available options for justification of the numbers in a number system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public enum NumberSystemJustifyOption
Visual Basic
Public Enumeration NumberSystemJustifyOption
Visual C++
public enum class NumberSystemJustifyOption

Members

Member name | Description
Front | The number will locate in front of the annotated object along the annotating direction.
Center | The number will locate in the center of the annotated object along the annotating direction.
Back | The number will locate in back of the annotated object along the annotating direction.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


NumericRevisionSettings Class

[image]

Revit 2024 API
NumericRevisionSettings Class
Members See Also Send Feedback
Contains settings that apply to Revisions with the Numeric RevisionNumberType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public class NumericRevisionSettings : IDisposable
Visual Basic
Public Class NumericRevisionSettings _
    Implements IDisposable
Visual C++
public ref class NumericRevisionSettings : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..NumericRevisionSettings

See Also

NumericRevisionSettings Members


NumericRevisionSettings Members

[image] [image]

Revit 2024 API
NumericRevisionSettings Members
NumericRevisionSettings Class Constructors Methods Properties See Also Send Feedback

The NumericRevisionSettings type exposes the following members.

Constructors

 | Name | Description
Public method | NumericRevisionSettings()()()() | Constructs a NumericRevisionSettings with a simple, default numbering sequence.
Public method | NumericRevisionSettings(NumericRevisionSettings) | Constructs a new copy of the input NumericRevisionSettings object.
Public method | NumericRevisionSettings(Int32, String, String) | Constructs a NumericRevisionSettings object.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the NumericRevisionSettings
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Determines whether a specified NumericRevisionSettings is the same as 'this'.
Public method | IsValid | Determines whether the NumericRevisionSettings object is in a valid state.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MinimumDigits | Controls the minimum number of digits for a revision number.
Public property | Prefix | The prefix string that will be prepended to the number of each revision with Numeric RevisionNumberingType.
Public property | StartNumber | The start number for the sequence.
Public property | Suffix | The suffix string that will be appended to the number of each revision with Numeric RevisionNumberingType.

See Also

NumericRevisionSettings Class


NumericRevisionSettings Constructor

[image] [image]

Revit 2024 API
NumericRevisionSettings Constructor
NumericRevisionSettings Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NumericRevisionSettings()()()() | Constructs a NumericRevisionSettings with a simple, default numbering sequence.
Public method | NumericRevisionSettings(NumericRevisionSettings) | Constructs a new copy of the input NumericRevisionSettings object.
Public method | NumericRevisionSettings(Int32, String, String) | Constructs a NumericRevisionSettings object.

See Also

NumericRevisionSettings Class
NumericRevisionSettings Members


NumericRevisionSettings Constructor

[image]

Revit 2024 API
NumericRevisionSettings Constructor
NumericRevisionSettings Class See Also Send Feedback
Constructs a NumericRevisionSettings with a simple, default numbering sequence.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public NumericRevisionSettings()
Visual Basic
Public Sub New
Visual C++
public:
NumericRevisionSettings()

Remarks

Initializes startNumber to 1. The prefix and suffix strings are set to empty.

See Also

NumericRevisionSettings Class
NumericRevisionSettings Overload


NumericRevisionSettings Constructor (NumericRevisionSettings)

[image]

Revit 2024 API
NumericRevisionSettings Constructor (NumericRevisionSettings)
NumericRevisionSettings Class See Also Send Feedback
Constructs a new copy of the input NumericRevisionSettings object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public NumericRevisionSettings(
    NumericRevisionSettings other
)
Visual Basic
Public Sub New ( _
    other As NumericRevisionSettings _
)
Visual C++
public:
NumericRevisionSettings(
    NumericRevisionSettings^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..NumericRevisionSettings

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | other is not a valid NumericRevisionSettings.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

NumericRevisionSettings Class
NumericRevisionSettings Overload


NumericRevisionSettings Constructor (Int32, String, String)

[image]

Revit 2024 API
NumericRevisionSettings Constructor (Int32, String, String)
NumericRevisionSettings Class See Also Send Feedback
Constructs a NumericRevisionSettings object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public NumericRevisionSettings(
    int startNumber,
    string prefix,
    string suffix
)
Visual Basic
Public Sub New ( _
    startNumber As Integer, _
    prefix As String, _
    suffix As String _
)
Visual C++
public:
NumericRevisionSettings(
    int startNumber,
    String^ prefix,
    String^ suffix
)

Parameters

startNumber
Type: System..::..Int32
The start number for the sequence.
prefix
Type: System..::..String
The prefix string for each revision number in the sequence.
suffix
Type: System..::..String
The suffix string for each revision number in the sequence.

Remarks

The starting number parameter accepts any non-negative integer, and the prefix and suffix strings are allowed to be empty.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given value for startNumber is negative.

See Also

NumericRevisionSettings Class
NumericRevisionSettings Overload


NumericRevisionSettings Methods

[image] [image]

Revit 2024 API
NumericRevisionSettings Methods
NumericRevisionSettings Class See Also Send Feedback

The NumericRevisionSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Determines whether a specified NumericRevisionSettings is the same as 'this'.
Public method | IsValid | Determines whether the NumericRevisionSettings object is in a valid state.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

NumericRevisionSettings Class


IsEqual Method

[image]

Revit 2024 API
NumericRevisionSettings..::..IsEqual Method
NumericRevisionSettings Class See Also Send Feedback
Determines whether a specified NumericRevisionSettings is the same as 'this'.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool IsEqual(
    NumericRevisionSettings other
)
Visual Basic
Public Function IsEqual ( _
    other As NumericRevisionSettings _
) As Boolean
Visual C++
public:
bool IsEqual(
    NumericRevisionSettings^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..NumericRevisionSettings
The specified NumericRevisionSettings with which to compare.

Return Value

True, if two NumericRevisionSettings are the same.

Remarks

The two NumericRevisionSettings are regarded as the same only if they have the same start number, prefix and suffix strings.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

NumericRevisionSettings Class


IsValid Method

[image]

Revit 2024 API
NumericRevisionSettings..::..IsValid Method
NumericRevisionSettings Class See Also Send Feedback
Determines whether the NumericRevisionSettings object is in a valid state.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool IsValid()
Visual Basic
Public Function IsValid As Boolean
Visual C++
public:
bool IsValid()

Return Value

True if the NumericRevisionSettings is valid.

Remarks

The NumericRevisionSettings should at least contain a non-negative start number.

See Also

NumericRevisionSettings Class


MinimumDigits Property

[image]

Revit 2024 API
NumericRevisionSettings..::..MinimumDigits Property
NumericRevisionSettings Class See Also Send Feedback
Controls the minimum number of digits for a revision number.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public int MinimumDigits { get; set; }
Visual Basic
Public Property MinimumDigits As Integer
    Get
    Set
Visual C++
public:
property int MinimumDigits {
    int get ();
    void set (int value);
}

Remarks

Use MinimumDigits to force the minimum number of digits for a revision number. Zeros will be added to the front of the revision number until the minimum number of digits is satisfied. For example, if MinimumDigits is 3, then 9 will be printed as 009 and 10 will be printed as 010. If MinimumDigits is 1, then no zeros are added to the front of the revision number. The default value for MinimumDigits is 1. Values less than 1 are not allowed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for minimumDigits is not positive.

See Also

NumericRevisionSettings Class


Prefix Property

[image]

Revit 2024 API
NumericRevisionSettings..::..Prefix Property
NumericRevisionSettings Class See Also Send Feedback
The prefix string that will be prepended to the number of each revision with Numeric RevisionNumberingType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public string Prefix { get; set; }
Visual Basic
Public Property Prefix As String
    Get
    Set
Visual C++
public:
property String^ Prefix {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

NumericRevisionSettings Class


StartNumber Property

[image]

Revit 2024 API
NumericRevisionSettings..::..StartNumber Property
NumericRevisionSettings Class See Also Send Feedback
The start number for the sequence.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public int StartNumber { get; set; }
Visual Basic
Public Property StartNumber As Integer
    Get
    Set
Visual C++
public:
property int StartNumber {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for number is negative.

See Also

NumericRevisionSettings Class


Suffix Property

[image]

Revit 2024 API
NumericRevisionSettings..::..Suffix Property
NumericRevisionSettings Class See Also Send Feedback
The suffix string that will be appended to the number of each revision with Numeric RevisionNumberingType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public string Suffix { get; set; }
Visual Basic
Public Property Suffix As String
    Get
    Set
Visual C++
public:
property String^ Suffix {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

NumericRevisionSettings Class


NurbSpline Class

[image]

Revit 2024 API
NurbSpline Class
Members See Also Send Feedback
A nurb spline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class NurbSpline : Curve
Visual Basic
Public Class NurbSpline _
    Inherits Curve
Visual C++
public ref class NurbSpline : public Curve

Remarks

The nurb spline lies in the plane defined by control point, weight,knots,degree.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeometryObject
Autodesk.Revit.DB..::..Curve
Autodesk.Revit.DB..::..NurbSpline

See Also

NurbSpline Members


NurbSpline Members

[image] [image]

Revit 2024 API
NurbSpline Members
NurbSpline Class Methods Properties See Also Send Feedback

The NurbSpline type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns a copy of this curve. (Inherited from Curve.)
Public method | ComputeClosestPoints | Find the closest points between two curves. Closest points mean closest pairs of points, each pair consisting of a point on this, say P1, and a point on other curve, say P2. P1 and P2 are closest locally. Each pairs of closest points will be represented by the corresponding parameter values with respect to the two curves and the 3d points. A closest pair is also known as a pair of critical points of the distance function between points of the two curves. If the input parameter returnAllCriticalPoints is set to false, then the function will return only pairs with minimum distance. (Inherited from Curve.)
Public method | ComputeDerivatives | Returns the vectors describing the curve at the specified parameter. (Inherited from Curve.)
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve.)
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve.)
 | Create | Creates a new geometric NurbSpline object from a HermiteSpline.
 | CreateCurve(HermiteSpline) | Creates a new geometric Curve object by converting the given HermiteSpline. The created curve may be a NURBSpline or a simpler curve such as line or arc.
 | CreateCurve(IList<(Of <<'(XYZ>)>>), IList<(Of <<'(Double>)>>)) | Creates a new geometric Curve object from NURBS curve data containing just control points and weights. The created curve may be a NURBSpline or a simpler curve such as line or arc.
 | CreateCurve(Int32, IList<(Of <<'(Double>)>>), IList<(Of <<'(XYZ>)>>)) | Creates a new geometric Curve object from NURBS curve data, which does not include weights. The created curve may be a NURBSpline or a simpler curve such as line or arc.
 | CreateCurve(Int32, IList<(Of <<'(Double>)>>), IList<(Of <<'(XYZ>)>>), IList<(Of <<'(Double>)>>)) | Creates a new geometric Curve object from NURBS curve data, which includes weights. The created curve may be a NURBSpline or a simpler curve such as line or arc.
Public method | CreateOffset | Creates a new curve that is an offset of the existing curve. (Inherited from Curve.)
Public method | CreateReversed | Creates a new curve with the opposite orientation of the existing curve. (Inherited from Curve.)
Public method | CreateTransformed | Crates a new instance of a curve as a transformation of this curve. (Inherited from Curve.)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates and returns the point that matches a parameter along the curve. (Inherited from Curve.)
Public method | GetEndParameter | Returns the raw parameter value at the start or end of this curve. (Inherited from Curve.)
Public method | GetEndPoint | Returns the 3D point at the start or end of this curve. (Inherited from Curve.)
Public method | GetEndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve.)
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve.)
Public method | IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve.)
Public method | MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve.)
Public method | MakeUnbound | Makes this curve unbound. (Inherited from Curve.)
Public method | Project | Projects the specified point on this curve. (Inherited from Curve.)
Public method | SetControlPointsAndWeights | Set the control points, weights simultaneously.
Public method | SetGraphicsStyleId | Sets the graphics style id for this curve. (Inherited from Curve.)
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
Public property | CtrlPoints | Returns the control points of the nurb spline.
Public property | Degree | Returns the degree of the nurb spline.
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject.)
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
Public property | IsClosed | Describes whether the curve is closed. (Inherited from Curve.)
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | isRational | Returns whether the nurb spline is rational or not.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Knots | Return/set the knots of the nurb spline.
Public property | Length | The exact length of the curve. (Inherited from Curve.)
Public property | Period | The period of this curve. (Inherited from Curve.)
Public property | Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Public property | Visibility | The visibility. (Inherited from GeometryObject.)
Public property | Weights | Returns the weights of the nurb spline.

See Also

NurbSpline Class


Create Method

[image]

Revit 2024 API
NurbSpline..::..Create Method
NurbSpline Class See Also Send Feedback
Creates a new geometric NurbSpline object from a HermiteSpline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public static NurbSpline Create(
    HermiteSpline hermiteSpline
)
Visual Basic
Public Shared Function Create ( _
    hermiteSpline As HermiteSpline _
) As NurbSpline
Visual C++
public:
static NurbSpline^ Create(
    HermiteSpline^ hermiteSpline
)

Parameters

hermiteSpline
Type: Autodesk.Revit.DB..::..HermiteSpline
The hermite spline that will be converted to NurbSpline.

Return Value

The new NurbSpline object.

See Also

NurbSpline Class


CreateCurve Method

[image] [image]

Revit 2024 API
NurbSpline..::..CreateCurve Method
NurbSpline Class See Also Send Feedback

Overload List

Name | Description
CreateCurve(HermiteSpline) | Creates a new geometric Curve object by converting the given HermiteSpline. The created curve may be a NURBSpline or a simpler curve such as line or arc.
CreateCurve(IList<(Of <<'(XYZ>)>>), IList<(Of <<'(Double>)>>)) | Creates a new geometric Curve object from NURBS curve data containing just control points and weights. The created curve may be a NURBSpline or a simpler curve such as line or arc.
CreateCurve(Int32, IList<(Of <<'(Double>)>>), IList<(Of <<'(XYZ>)>>)) | Creates a new geometric Curve object from NURBS curve data, which does not include weights. The created curve may be a NURBSpline or a simpler curve such as line or arc.
CreateCurve(Int32, IList<(Of <<'(Double>)>>), IList<(Of <<'(XYZ>)>>), IList<(Of <<'(Double>)>>)) | Creates a new geometric Curve object from NURBS curve data, which includes weights. The created curve may be a NURBSpline or a simpler curve such as line or arc.

See Also

NurbSpline Class
NurbSpline Members


CreateCurve Method (HermiteSpline)

[image]

Revit 2024 API
NurbSpline..::..CreateCurve Method (HermiteSpline)
NurbSpline Class See Also Send Feedback
Creates a new geometric Curve object by converting the given HermiteSpline. The created curve may be a NURBSpline or a simpler curve such as line or arc.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public static Curve CreateCurve(
    HermiteSpline hermiteSpline
)
Visual Basic
Public Shared Function CreateCurve ( _
    hermiteSpline As HermiteSpline _
) As Curve
Visual C++
public:
static Curve^ CreateCurve(
    HermiteSpline^ hermiteSpline
)

Parameters

hermiteSpline
Type: Autodesk.Revit.DB..::..HermiteSpline
The HermiteSpline that will be converted.

Return Value

The new Curve object.

Remarks

The function does not support periodic Hermite curve.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given hermite spline has to be non-periodic. -or- Curve length is too small for Revit's tolerance (as identified by Application.ShortCurveTolerance).
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

NurbSpline Class
CreateCurve Overload


CreateCurve Method (IList(XYZ), IList(Double))

[image]

Revit 2024 API
NurbSpline..::..CreateCurve Method (IList<(Of <(<'XYZ>)>)>, IList<(Of <(<'Double>)>)>)
NurbSpline Class See Also Send Feedback
Creates a new geometric Curve object from NURBS curve data containing just control points and weights. The created curve may be a NURBSpline or a simpler curve such as line or arc.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public static Curve CreateCurve(
    IList<XYZ> controlPoints,
    IList<double> weights
)
Visual Basic
Public Shared Function CreateCurve ( _
    controlPoints As IList(Of XYZ), _
    weights As IList(Of Double) _
) As Curve
Visual C++
public:
static Curve^ CreateCurve(
    IList<XYZ^>^ controlPoints,
    IList<double>^ weights
)

Parameters

controlPoints
Type: System.Collections.Generic..::..IList<(Of <(<' XYZ >)>)>
The control points of the NURBSpline.
weights
Type: System.Collections.Generic..::..IList<(Of <(<'Double>)>)>
The weights of the NURBSpline.

Return Value

The new Curve object.

Remarks

There must be at least 2 control points. The number of weights must be equal to the the number of control points. The values of all weights must be positive.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The number of control points must be at least 2. -or- The number of weights must be the same as the number of control points and all weights must be positive.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | Curve length is too small for Revit's tolerance (as identified by Application.ShortCurveTolerance).

See Also

NurbSpline Class
CreateCurve Overload


CreateCurve Method (Int32, IList(Double), IList(XYZ))

[image]

Revit 2024 API
NurbSpline..::..CreateCurve Method (Int32, IList<(Of <(<'Double>)>)>, IList<(Of <(<'XYZ>)>)>)
NurbSpline Class See Also Send Feedback
Creates a new geometric Curve object from NURBS curve data, which does not include weights. The created curve may be a NURBSpline or a simpler curve such as line or arc.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public static Curve CreateCurve(
    int degree,
    IList<double> knots,
    IList<XYZ> controlPoints
)
Visual Basic
Public Shared Function CreateCurve ( _
    degree As Integer, _
    knots As IList(Of Double), _
    controlPoints As IList(Of XYZ) _
) As Curve
Visual C++
public:
static Curve^ CreateCurve(
    int degree,
    IList<double>^ knots,
    IList<XYZ^>^ controlPoints
)

Parameters

degree
Type: System..::..Int32
The degree of the NURBSpline.
knots
Type: System.Collections.Generic..::..IList<(Of <(<'Double>)>)>
The knots of the NURBSpline.
controlPoints
Type: System.Collections.Generic..::..IList<(Of <(<' XYZ >)>)>
The control points of the NURBSpline.

Return Value

The new Curve object.

Remarks

Degree must be 1 or greater. The number of control points must be greater than degree. The number of knots must equal the sum of degree, number of controlPoints and 1. The distinct knot values (ignoring multiplicities) must be in increasing order. The first degree+1 knots should be identical, as should the last degree+1 knots. The multiplicities of other (interior) knots should be less than degree -1.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The degree must be at least 1. -or- The number of control points must be greater than degree. -or- The number of knots must equal the sum of number of control points, degree and 1. -or- An interior knot must not repeat itself more than degree times.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | Curve length is too small for Revit's tolerance (as identified by Application.ShortCurveTolerance).

See Also

NurbSpline Class
CreateCurve Overload


CreateCurve Method (Int32, IList(Double), IList(XYZ), IList(Double))

[image]

Revit 2024 API
NurbSpline..::..CreateCurve Method (Int32, IList<(Of <(<'Double>)>)>, IList<(Of <(<'XYZ>)>)>, IList<(Of <(<'Double>)>)>)
NurbSpline Class See Also Send Feedback
Creates a new geometric Curve object from NURBS curve data, which includes weights. The created curve may be a NURBSpline or a simpler curve such as line or arc.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public static Curve CreateCurve(
    int degree,
    IList<double> knots,
    IList<XYZ> controlPoints,
    IList<double> weights
)
Visual Basic
Public Shared Function CreateCurve ( _
    degree As Integer, _
    knots As IList(Of Double), _
    controlPoints As IList(Of XYZ), _
    weights As IList(Of Double) _
) As Curve
Visual C++
public:
static Curve^ CreateCurve(
    int degree,
    IList<double>^ knots,
    IList<XYZ^>^ controlPoints,
    IList<double>^ weights
)

Parameters

degree
Type: System..::..Int32
The degree of the NURBSpline.
knots
Type: System.Collections.Generic..::..IList<(Of <(<'Double>)>)>
The knots of the NURBSpline.
controlPoints
Type: System.Collections.Generic..::..IList<(Of <(<' XYZ >)>)>
The control points of the NURBSpline.
weights
Type: System.Collections.Generic..::..IList<(Of <(<'Double>)>)>
The weights of the NURBSpline.

Return Value

The new Curve object.

Remarks

Degree must be 1 or greater. The number of control points must be greater than degree. The number of knots must equal the sum of degree, number of controlPoints and 1. The distinct knot values (ignoring multiplicities) must be in increasing order. The first degree+1 knots should be identical, as should the last degree+1 knots. The multiplicities of other (interior) knots should be less than degree -1. The number of weights must be equal to the the number of control points. The values of all weights must be positive.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The degree must be at least 1. -or- The number of control points must be greater than degree. -or- The number of knots must equal the sum of number of control points, degree and 1. -or- An interior knot must not repeat itself more than degree times. -or- The number of weights must be the same as the number of control points and all weights must be positive.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | Curve length is too small for Revit's tolerance (as identified by Application.ShortCurveTolerance).

See Also

NurbSpline Class
CreateCurve Overload


Intersect Method

[image] [image]

Revit 2024 API
NurbSpline..::..Intersect Method
NurbSpline Class See Also Send Feedback
Calculates the intersection of this curve with the specified curve.

Overload List

 | Name | Description
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve.)

See Also

NurbSpline Class
NurbSpline Members


IsInside Method

[image] [image]

Revit 2024 API
NurbSpline..::..IsInside Method
NurbSpline Class See Also Send Feedback
Indicates whether the specified parameter value is within this curve's bounds.

Overload List

 | Name | Description
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve.)
Public method | IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve.)

See Also

NurbSpline Class
NurbSpline Members


SetControlPointsAndWeights Method

[image]

Revit 2024 API
NurbSpline..::..SetControlPointsAndWeights Method
NurbSpline Class See Also Send Feedback
Set the control points, weights simultaneously.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetControlPointsAndWeights(
    IList<XYZ> ctrlPoints,
    DoubleArray weights
)
Visual Basic
Public Sub SetControlPointsAndWeights ( _
    ctrlPoints As IList(Of XYZ), _
    weights As DoubleArray _
)
Visual C++
public:
void SetControlPointsAndWeights(
    IList<XYZ^>^ ctrlPoints,
    DoubleArray^ weights
)

Parameters

ctrlPoints
Type: System.Collections.Generic..::..IList<(Of <(<' XYZ >)>)>
weights
Type: Autodesk.Revit.DB..::..DoubleArray

See Also

NurbSpline Class


CtrlPoints Property

[image]

Revit 2024 API
NurbSpline..::..CtrlPoints Property
NurbSpline Class See Also Send Feedback
Returns the control points of the nurb spline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public IList<XYZ> CtrlPoints { get; }
Visual Basic
Public ReadOnly Property CtrlPoints As IList(Of XYZ)
    Get
Visual C++
public:
property IList<XYZ^>^ CtrlPoints {
    IList<XYZ^>^ get ();
}

See Also

NurbSpline Class


Degree Property

[image]

Revit 2024 API
NurbSpline..::..Degree Property
NurbSpline Class See Also Send Feedback
Returns the degree of the nurb spline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public int Degree { get; }
Visual Basic
Public ReadOnly Property Degree As Integer
    Get
Visual C++
public:
property int Degree {
    int get ();
}

See Also

NurbSpline Class


isRational Property

[image]

Revit 2024 API
NurbSpline..::..isRational Property
NurbSpline Class See Also Send Feedback
Returns whether the nurb spline is rational or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool isRational { get; }
Visual Basic
Public ReadOnly Property isRational As Boolean
    Get
Visual C++
public:
property bool isRational {
    bool get ();
}

See Also

NurbSpline Class


Knots Property

[image]

Revit 2024 API
NurbSpline..::..Knots Property
NurbSpline Class See Also Send Feedback
Return/set the knots of the nurb spline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public DoubleArray Knots { get; set; }
Visual Basic
Public Property Knots As DoubleArray
    Get
    Set
Visual C++
public:
property DoubleArray^ Knots {
    DoubleArray^ get ();
    void set (DoubleArray^ value);
}

See Also

NurbSpline Class


Weights Property

[image]

Revit 2024 API
NurbSpline..::..Weights Property
NurbSpline Class See Also Send Feedback
Returns the weights of the nurb spline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public DoubleArray Weights { get; }
Visual Basic
Public ReadOnly Property Weights As DoubleArray
    Get
Visual C++
public:
property DoubleArray^ Weights {
    DoubleArray^ get ();
}

See Also

NurbSpline Class


NurbsSurfaceData Class

[image]

Revit 2024 API
NurbsSurfaceData Class
Members See Also Send Feedback
A class used to represent the definition of a NURBS surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public class NurbsSurfaceData : IDisposable
Visual Basic
Public Class NurbsSurfaceData _
    Implements IDisposable
Visual C++
public ref class NurbsSurfaceData : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..NurbsSurfaceData

See Also

NurbsSurfaceData Members


NurbsSurfaceData Members

[image] [image]

Revit 2024 API
NurbsSurfaceData Members
NurbsSurfaceData Class Constructors Methods Properties See Also Send Feedback

The NurbsSurfaceData type exposes the following members.

Constructors

 | Name | Description
Public method | NurbsSurfaceData | Copy constructor.

Methods

 | Name | Description
 | Create | Construct NurbsSurfaceData based on NURBS surface data, where the weights are supplied. The NURBS surface will be (piecewise) polynomial if all the weights are equal, rational if not. Note: A rational polynomial is a quotient of two polynomials; this includes a polynomial, which can be thought of as a quotient with denominator equal to 1.
Public method | Dispose | Releases all resources used by the NurbsSurfaceData
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetControlPoints | Get the list of control points.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetKnotsU | Get the list of knots in the u-direction.
Public method | GetKnotsV | Get the list of knots in the v-direction.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWeights | Get the list of weights.
Public method | IsValid | Check if the object contains a valid NurbsSurfaceData.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DegreeU | The degree of the spline in the u-direction.
Public property | DegreeV | The degree of the spline in the v-direction.
Public property | IsRational | Tells if the spline is rational or not. If it is true (rational), then the NURBS is a piecewise rational polynomial function. If it is false (non-rational), then the NURBS is a piecewise polynomial function.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ReverseOrientation | If true, the surface's orientation is opposite to the canonical parametric orientation, otherwise it is the same. The canonical parametric orientation is a counter-clockwise sense of rotation in the uv-parameter plane. Extrinsically, the oriented normal vector for the canonical parametric orientation points in the direction of the cross product dS/du x dS/dv, which S(u, v) is the parameterized surface.

See Also

NurbsSurfaceData Class


NurbsSurfaceData Constructor

[image]

Revit 2024 API
NurbsSurfaceData Constructor
NurbsSurfaceData Class See Also Send Feedback
Copy constructor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public NurbsSurfaceData(
    NurbsSurfaceData other
)
Visual Basic
Public Sub New ( _
    other As NurbsSurfaceData _
)
Visual C++
public:
NurbsSurfaceData(
    NurbsSurfaceData^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..NurbsSurfaceData
The NurbsSurfaceData to copy.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

NurbsSurfaceData Class


NurbsSurfaceData Methods

[image] [image]

Revit 2024 API
NurbsSurfaceData Methods
NurbsSurfaceData Class See Also Send Feedback

The NurbsSurfaceData type exposes the following members.

Methods

 | Name | Description
 | Create | Construct NurbsSurfaceData based on NURBS surface data, where the weights are supplied. The NURBS surface will be (piecewise) polynomial if all the weights are equal, rational if not. Note: A rational polynomial is a quotient of two polynomials; this includes a polynomial, which can be thought of as a quotient with denominator equal to 1.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetControlPoints | Get the list of control points.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetKnotsU | Get the list of knots in the u-direction.
Public method | GetKnotsV | Get the list of knots in the v-direction.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWeights | Get the list of weights.
Public method | IsValid | Check if the object contains a valid NurbsSurfaceData.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

NurbsSurfaceData Class


Create Method

[image]

Revit 2024 API
NurbsSurfaceData..::..Create Method
NurbsSurfaceData Class See Also Send Feedback
Construct NurbsSurfaceData based on NURBS surface data, where the weights are supplied. The NURBS surface will be (piecewise) polynomial if all the weights are equal, rational if not. Note: A rational polynomial is a quotient of two polynomials; this includes a polynomial, which can be thought of as a quotient with denominator equal to 1.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public static NurbsSurfaceData Create(
    int degreeU,
    int degreeV,
    IList<double> knotsU,
    IList<double> knotsV,
    IList<XYZ> controlPoints,
    IList<double> weights,
    bool bReverseOrientation
)
Visual Basic
Public Shared Function Create ( _
    degreeU As Integer, _
    degreeV As Integer, _
    knotsU As IList(Of Double), _
    knotsV As IList(Of Double), _
    controlPoints As IList(Of XYZ), _
    weights As IList(Of Double), _
    bReverseOrientation As Boolean _
) As NurbsSurfaceData
Visual C++
public:
static NurbsSurfaceData^ Create(
    int degreeU,
    int degreeV,
    IList<double>^ knotsU,
    IList<double>^ knotsV,
    IList<XYZ^>^ controlPoints,
    IList<double>^ weights,
    bool bReverseOrientation
)

Parameters

degreeU
Type: System..::..Int32
The degree of the spline in the u-direction; must be positive.
degreeV
Type: System..::..Int32
The degree of the spline in the v-direction; must be positive.
knotsU
Type: System.Collections.Generic..::..IList<(Of <(<'Double>)>)>
Knot values in the u-direction. The number of knots in the u-direction must be at least 2 * (degreeU + 1).
knotsV
Type: System.Collections.Generic..::..IList<(Of <(<'Double>)>)>
Knot values in the v-direction. The number of knots in the v-direction must be at least 2 * (degreeV + 1).
controlPoints
Type: System.Collections.Generic..::..IList<(Of <(<' XYZ >)>)>
One dimensional array of points representing the two dimensional net of control points of the NURBS surface in u and v directions.

The total number of control points must equal numControlPtsU times numControlPtsV, where numControlPtsU and numControlPtsV are the numbers of control points in u and v directions, and they must satisfy the following conditions:

  • numControlPtsU = number of knots in u - degreeU - 1.
  • numControlPtsV = number of knots in v - degreeV - 1.
The convention for 2d (idxU, idxV) to 1d (idx) conversion of array indexes: idxV first. That is, idxU is outer loop and idxV is inner loop. In other words, idx = idxU * numControlPtsV + idxV.

weights
Type: System.Collections.Generic..::..IList<(Of <(<'Double>)>)>
Array of weights assigned to the control points. The number of weights must equal the number of control points. All weights should be greater than zero.
bReverseOrientation
Type: System..::..Boolean
If true, the surface's orientation is opposite to the canonical parametric orientation, otherwise it is the same. The canonical parametric orientation is a counter-clockwise sense of rotation in the uv-parameter plane. Extrinsically, the oriented normal vector for the canonical parametric orientation points in the direction of the cross product dS/du x dS/dv, which S(u, v) is the parameterized surface.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The U-degree value must be at least 1. -or- The V-degree value must be at least 1. -or- The number of knots in the U direction must be at least 2 times the U-degree plus 1. -or- The number of knots in the V direction must be at least 2 times the V-degree plus 1. -or- The number of control points must equal (number of U-knots - U-degree - 1) * (number of V-knots - V-degree - 1). -or- The number of weights must be the same as the number of control points and all weights must be positive or all zero.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

NurbsSurfaceData Class


Dispose Method

[image]

Revit 2024 API
NurbsSurfaceData..::..Dispose Method
NurbsSurfaceData Class See Also Send Feedback
Releases all resources used by the NurbsSurfaceData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

NurbsSurfaceData Class


GetControlPoints Method

[image]

Revit 2024 API
NurbsSurfaceData..::..GetControlPoints Method
NurbsSurfaceData Class See Also Send Feedback
Get the list of control points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public IList<XYZ> GetControlPoints()
Visual Basic
Public Function GetControlPoints As IList(Of XYZ)
Visual C++
public:
IList<XYZ^>^ GetControlPoints()

See Also

NurbsSurfaceData Class


GetKnotsV Method

[image]

Revit 2024 API
NurbsSurfaceData..::..GetKnotsV Method
NurbsSurfaceData Class See Also Send Feedback
Get the list of knots in the v-direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public IList<double> GetKnotsV()
Visual Basic
Public Function GetKnotsV As IList(Of Double)
Visual C++
public:
IList<double>^ GetKnotsV()

See Also

NurbsSurfaceData Class


GetWeights Method

[image]

Revit 2024 API
NurbsSurfaceData..::..GetWeights Method
NurbsSurfaceData Class See Also Send Feedback
Get the list of weights.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public IList<double> GetWeights()
Visual Basic
Public Function GetWeights As IList(Of Double)
Visual C++
public:
IList<double>^ GetWeights()

See Also

NurbsSurfaceData Class


IsValid Method

[image]

Revit 2024 API
NurbsSurfaceData..::..IsValid Method
NurbsSurfaceData Class See Also Send Feedback
Check if the object contains a valid NurbsSurfaceData.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool IsValid()
Visual Basic
Public Function IsValid As Boolean
Visual C++
public:
bool IsValid()

Return Value

True if it is a valid NurbsSurfaceData, false otherwise.

See Also

NurbsSurfaceData Class


DegreeV Property

[image]

Revit 2024 API
NurbsSurfaceData..::..DegreeV Property
NurbsSurfaceData Class See Also Send Feedback
The degree of the spline in the v-direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public int DegreeV { get; }
Visual Basic
Public ReadOnly Property DegreeV As Integer
    Get
Visual C++
public:
property int DegreeV {
    int get ();
}

See Also

NurbsSurfaceData Class


IsValidObject Property

[image]

Revit 2024 API
NurbsSurfaceData..::..IsValidObject Property
NurbsSurfaceData Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

NurbsSurfaceData Class


ReverseOrientation Property

[image]

Revit 2024 API
NurbsSurfaceData..::..ReverseOrientation Property
NurbsSurfaceData Class See Also Send Feedback
If true, the surface's orientation is opposite to the canonical parametric orientation, otherwise it is the same. The canonical parametric orientation is a counter-clockwise sense of rotation in the uv-parameter plane. Extrinsically, the oriented normal vector for the canonical parametric orientation points in the direction of the cross product dS/du x dS/dv, which S(u, v) is the parameterized surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool ReverseOrientation { get; }
Visual Basic
Public ReadOnly Property ReverseOrientation As Boolean
    Get
Visual C++
public:
property bool ReverseOrientation {
    bool get ();
}

See Also

NurbsSurfaceData Class


OBJExportOptions Members

[image] [image]

Revit 2024 API
OBJExportOptions Members
OBJExportOptions Class Constructors Methods Properties See Also Send Feedback

The OBJExportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | OBJExportOptions()()()() | Constructs a new instance of OBJExportOptions with default values of all properties.
Public method | OBJExportOptions(ExportResolution) | Constructs a new instance of OBJExportOptions with all predefined tessellation settings, depending on export resolution type. Note: in case of Custom resolution type, tessellation settings won't be predefined and will have default values.

Methods

 | Name | Description
Public method | Dispose | (Inherited from BIMExportOptions.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsGridAspectRatioSet | Checks whether the GridAspectRatio tessellation parameter is explicitly set.
Public method | IsMaxEdgeLengthSet | Checks whether the MaxEdgeLength tessellation parameter is explicitly set.
Public method | IsNormalToleranceSet | Checks whether the NormalTolerance tessellation parameter is explicitly set.
Public method | IsSurfaceToleranceSet | Checks whether the SurfaceTolerance tessellation parameter is explicitly set.
 | IsValidForGridAspectRatio | Checks whether the value is allowed (is in the allowed range) for GridAspectRatio tessellation parameter.
 | IsValidForMaxEdgeLength | Checks whether the value is allowed (is in the allowed range) for MaxEdgeLength tessellation parameter.
 | IsValidForNormalTolerance | Checks whether the value is allowed (is in the allowed range) for NormalTolerance tessellation parameter.
 | IsValidForSurfaceTolerance | Checks whether the value is allowed (is in the allowed range) for SurfaceTolerance tessellation parameter.
Public method | SetTessellationSettings | Sets all the tessellation parameters to its predefined values for the given resolution type.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | GridAspectRatio | The maximum aspect ratio allowed in the grid placed across the face. The minimum allowed value is 1.0. The maximum allowed value is 10.0. By default this property is ignored.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BIMExportOptions.)
Public property | MaxEdgeLength | The maximum length allowed for any chord on an edge or between any two adjacent grid lines. This is a percentage value. By exporting, the real value of maximum edge length is calculated as a percent from the length of the diameter of the body bounding box. The minimum allowed value is 0.1%. The maximum allowed value is 10.0%. By default this property is ignored.
Public property | NormalTolerance | The maximum change in the surface normal between adjacent nodes in the mesh. This property is defined in degrees. The minimum allowed value is 1.0 degrees. The maximum allowed value is 45.0 degrees. Default value is 15.0 degrees.
Public property | SurfaceTolerance | The maximum distance between mesh triangles and model geometry. This is a percentage value. By exporting, the real value of surface tolerance is calculated as a percent from the length of the diameter of the body bounding box. The minimum allowed value is 0.001%. The maximum allowed value is 1.0%. Default value is 0.1%.
Public property | TargetUnit | The unit type of geometry in the resultant OBJ file. Default value is ExportUnit::Default.
Public property | ViewId | The element id of the 3D view to export. InvalidElementId by default. (Inherited from BIMExportOptions.)

See Also

OBJExportOptions Class


OBJExportOptions Constructor

[image] [image]

Revit 2024 API
OBJExportOptions Constructor
OBJExportOptions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | OBJExportOptions()()()() | Constructs a new instance of OBJExportOptions with default values of all properties.
Public method | OBJExportOptions(ExportResolution) | Constructs a new instance of OBJExportOptions with all predefined tessellation settings, depending on export resolution type. Note: in case of Custom resolution type, tessellation settings won't be predefined and will have default values.

See Also

OBJExportOptions Class
OBJExportOptions Members


OBJExportOptions Constructor

[image]

Revit 2024 API
OBJExportOptions Constructor
OBJExportOptions Class See Also Send Feedback
Constructs a new instance of OBJExportOptions with default values of all properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public OBJExportOptions()
Visual Basic
Public Sub New
Visual C++
public:
OBJExportOptions()

See Also

OBJExportOptions Class
OBJExportOptions Overload


OBJExportOptions Constructor (ExportResolution)

[image]

Revit 2024 API
OBJExportOptions Constructor (ExportResolution)
OBJExportOptions Class See Also Send Feedback
Constructs a new instance of OBJExportOptions with all predefined tessellation settings, depending on export resolution type. Note: in case of Custom resolution type, tessellation settings won't be predefined and will have default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public OBJExportOptions(
    ExportResolution resolutionType
)
Visual Basic
Public Sub New ( _
    resolutionType As ExportResolution _
)
Visual C++
public:
OBJExportOptions(
    ExportResolution resolutionType
)

Parameters

resolutionType
Type: Autodesk.Revit.DB..::..ExportResolution
The type of export resolution.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

OBJExportOptions Class
OBJExportOptions Overload


OBJExportOptions Methods

[image] [image]

Revit 2024 API
OBJExportOptions Methods
OBJExportOptions Class See Also Send Feedback

The OBJExportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from BIMExportOptions.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsGridAspectRatioSet | Checks whether the GridAspectRatio tessellation parameter is explicitly set.
Public method | IsMaxEdgeLengthSet | Checks whether the MaxEdgeLength tessellation parameter is explicitly set.
Public method | IsNormalToleranceSet | Checks whether the NormalTolerance tessellation parameter is explicitly set.
Public method | IsSurfaceToleranceSet | Checks whether the SurfaceTolerance tessellation parameter is explicitly set.
 | IsValidForGridAspectRatio | Checks whether the value is allowed (is in the allowed range) for GridAspectRatio tessellation parameter.
 | IsValidForMaxEdgeLength | Checks whether the value is allowed (is in the allowed range) for MaxEdgeLength tessellation parameter.
 | IsValidForNormalTolerance | Checks whether the value is allowed (is in the allowed range) for NormalTolerance tessellation parameter.
 | IsValidForSurfaceTolerance | Checks whether the value is allowed (is in the allowed range) for SurfaceTolerance tessellation parameter.
Public method | SetTessellationSettings | Sets all the tessellation parameters to its predefined values for the given resolution type.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

OBJExportOptions Class


IsGridAspectRatioSet Method

[image]

Revit 2024 API
OBJExportOptions..::..IsGridAspectRatioSet Method
OBJExportOptions Class See Also Send Feedback
Checks whether the GridAspectRatio tessellation parameter is explicitly set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public bool IsGridAspectRatioSet()
Visual Basic
Public Function IsGridAspectRatioSet As Boolean
Visual C++
public:
bool IsGridAspectRatioSet()

Return Value

True if GridAspectRatio tessellation parameter is explicitly set, false otherwise.

See Also

OBJExportOptions Class


IsNormalToleranceSet Method

[image]

Revit 2024 API
OBJExportOptions..::..IsNormalToleranceSet Method
OBJExportOptions Class See Also Send Feedback
Checks whether the NormalTolerance tessellation parameter is explicitly set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public bool IsNormalToleranceSet()
Visual Basic
Public Function IsNormalToleranceSet As Boolean
Visual C++
public:
bool IsNormalToleranceSet()

Return Value

True if NormalTolerance tessellation parameter is explicitly set, false otherwise.

See Also

OBJExportOptions Class


IsSurfaceToleranceSet Method

[image]

Revit 2024 API
OBJExportOptions..::..IsSurfaceToleranceSet Method
OBJExportOptions Class See Also Send Feedback
Checks whether the SurfaceTolerance tessellation parameter is explicitly set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public bool IsSurfaceToleranceSet()
Visual Basic
Public Function IsSurfaceToleranceSet As Boolean
Visual C++
public:
bool IsSurfaceToleranceSet()

Return Value

True if SurfaceTolerance tessellation parameter is explicitly set, false otherwise.

See Also

OBJExportOptions Class


IsValidForGridAspectRatio Method

[image]

Revit 2024 API
OBJExportOptions..::..IsValidForGridAspectRatio Method
OBJExportOptions Class See Also Send Feedback
Checks whether the value is allowed (is in the allowed range) for GridAspectRatio tessellation parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public static bool IsValidForGridAspectRatio(
    double value
)
Visual Basic
Public Shared Function IsValidForGridAspectRatio ( _
    value As Double _
) As Boolean
Visual C++
public:
static bool IsValidForGridAspectRatio(
    double value
)

Parameters

value
Type: System..::..Double
The value to be checked.

Return Value

True if the value is valid for GridAspectRatio, false otherwise.

See Also

OBJExportOptions Class


IsValidForNormalTolerance Method

[image]

Revit 2024 API
OBJExportOptions..::..IsValidForNormalTolerance Method
OBJExportOptions Class See Also Send Feedback
Checks whether the value is allowed (is in the allowed range) for NormalTolerance tessellation parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public static bool IsValidForNormalTolerance(
    double value
)
Visual Basic
Public Shared Function IsValidForNormalTolerance ( _
    value As Double _
) As Boolean
Visual C++
public:
static bool IsValidForNormalTolerance(
    double value
)

Parameters

value
Type: System..::..Double
The value to be checked.

Return Value

True if the value is valid for NormalTolerance, false otherwise.

See Also

OBJExportOptions Class


IsValidForSurfaceTolerance Method

[image]

Revit 2024 API
OBJExportOptions..::..IsValidForSurfaceTolerance Method
OBJExportOptions Class See Also Send Feedback
Checks whether the value is allowed (is in the allowed range) for SurfaceTolerance tessellation parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public static bool IsValidForSurfaceTolerance(
    double value
)
Visual Basic
Public Shared Function IsValidForSurfaceTolerance ( _
    value As Double _
) As Boolean
Visual C++
public:
static bool IsValidForSurfaceTolerance(
    double value
)

Parameters

value
Type: System..::..Double
The value to be checked.

Return Value

True if the value is valid for SurfaceTolerance, false otherwise.

See Also

OBJExportOptions Class


SetTessellationSettings Method

[image]

Revit 2024 API
OBJExportOptions..::..SetTessellationSettings Method
OBJExportOptions Class See Also Send Feedback
Sets all the tessellation parameters to its predefined values for the given resolution type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public void SetTessellationSettings(
    ExportResolution resolutionType
)
Visual Basic
Public Sub SetTessellationSettings ( _
    resolutionType As ExportResolution _
)
Visual C++
public:
void SetTessellationSettings(
    ExportResolution resolutionType
)

Parameters

resolutionType
Type: Autodesk.Revit.DB..::..ExportResolution
Type of exporting resolution.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

OBJExportOptions Class


OBJExportOptions Properties

[image] [image]

Revit 2024 API
OBJExportOptions Properties
OBJExportOptions Class See Also Send Feedback

The OBJExportOptions type exposes the following members.

Properties

 | Name | Description
Public property | GridAspectRatio | The maximum aspect ratio allowed in the grid placed across the face. The minimum allowed value is 1.0. The maximum allowed value is 10.0. By default this property is ignored.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BIMExportOptions.)
Public property | MaxEdgeLength | The maximum length allowed for any chord on an edge or between any two adjacent grid lines. This is a percentage value. By exporting, the real value of maximum edge length is calculated as a percent from the length of the diameter of the body bounding box. The minimum allowed value is 0.1%. The maximum allowed value is 10.0%. By default this property is ignored.
Public property | NormalTolerance | The maximum change in the surface normal between adjacent nodes in the mesh. This property is defined in degrees. The minimum allowed value is 1.0 degrees. The maximum allowed value is 45.0 degrees. Default value is 15.0 degrees.
Public property | SurfaceTolerance | The maximum distance between mesh triangles and model geometry. This is a percentage value. By exporting, the real value of surface tolerance is calculated as a percent from the length of the diameter of the body bounding box. The minimum allowed value is 0.001%. The maximum allowed value is 1.0%. Default value is 0.1%.
Public property | TargetUnit | The unit type of geometry in the resultant OBJ file. Default value is ExportUnit::Default.
Public property | ViewId | The element id of the 3D view to export. InvalidElementId by default. (Inherited from BIMExportOptions.)

See Also

OBJExportOptions Class


MaxEdgeLength Property

[image]

Revit 2024 API
OBJExportOptions..::..MaxEdgeLength Property
OBJExportOptions Class See Also Send Feedback
The maximum length allowed for any chord on an edge or between any two adjacent grid lines. This is a percentage value. By exporting, the real value of maximum edge length is calculated as a percent from the length of the diameter of the body bounding box. The minimum allowed value is 0.1%. The maximum allowed value is 10.0%. By default this property is ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public double MaxEdgeLength { get; set; }
Visual Basic
Public Property MaxEdgeLength As Double
    Get
    Set
Visual C++
public:
property double MaxEdgeLength {
    double get ();
    void set (double value);
}

Remarks

This property can be set by using export resolution type (by creation of OBJExportOptions or using [!:Autodesk::Revit::DB::OBJExportOptions::setTessellationSettings(ExportResolution::Enum)] method). In the case of Fine, Medium and Coarse resolutions, this property has the same value (10.0%) and it is considered as explicitly set by the user. In the case of Custom resolution type, this property is only allowed to be obtained if it has been explicitly set.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The value maxEdgeLength is outside the allowable range of values for MaxEdgeLength tessellation parameter.
Autodesk.Revit.Exceptions..::..InvalidOperationException | MaxEdgeLength tessellation parameter is default (hasn't been explicitly set by the user) and cannot be obtained now.

See Also

OBJExportOptions Class


NormalTolerance Property

[image]

Revit 2024 API
OBJExportOptions..::..NormalTolerance Property
OBJExportOptions Class See Also Send Feedback
The maximum change in the surface normal between adjacent nodes in the mesh. This property is defined in degrees. The minimum allowed value is 1.0 degrees. The maximum allowed value is 45.0 degrees. Default value is 15.0 degrees.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public double NormalTolerance { get; set; }
Visual Basic
Public Property NormalTolerance As Double
    Get
    Set
Visual C++
public:
property double NormalTolerance {
    double get ();
    void set (double value);
}

Remarks

This property can be set by using export resolution type (by creation of OBJExportOptions or using [!:Autodesk::Revit::DB::OBJExportOptions::setTessellationSettings(ExportResolution::Enum)] method). In the case of Fine (10.0 degrees), Medium (15.0 degrees) and Coarse (30.0 degrees) resolutions, this property is considered as explicitly set by the user. In the case of Custom resolution type, this property is only allowed to be obtained if it has been explicitly set.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The value normalTolerance is outside the allowable range of values for NormalTolerance tessellation parameter.
Autodesk.Revit.Exceptions..::..InvalidOperationException | NormalTolerance tessellation parameter is default (hasn't been explicitly set by the user) and cannot be obtained now.

See Also

OBJExportOptions Class


SurfaceTolerance Property

[image]

Revit 2024 API
OBJExportOptions..::..SurfaceTolerance Property
OBJExportOptions Class See Also Send Feedback
The maximum distance between mesh triangles and model geometry. This is a percentage value. By exporting, the real value of surface tolerance is calculated as a percent from the length of the diameter of the body bounding box. The minimum allowed value is 0.001%. The maximum allowed value is 1.0%. Default value is 0.1%.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public double SurfaceTolerance { get; set; }
Visual Basic
Public Property SurfaceTolerance As Double
    Get
    Set
Visual C++
public:
property double SurfaceTolerance {
    double get ();
    void set (double value);
}

Remarks

This property can be set by using export resolution type (by creation of OBJExportOptions or using [!:Autodesk::Revit::DB::OBJExportOptions::setTessellationSettings(ExportResolution::Enum)] method). In the case of Fine (0.005%), Medium (0.016%) and Coarse (0.04%) resolutions, this property is considered as explicitly set by the user. In the case of Custom resolution type, this property is only allowed to be obtained if it has been explicitly set.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The value surfaceTolerance is outside the allowable range of values for SurfaceTolerance tessellation parameter.
Autodesk.Revit.Exceptions..::..InvalidOperationException | SurfaceTolerance tessellation parameter is default (hasn't been explicitly set by the user) and cannot be obtained now.

See Also

OBJExportOptions Class


TargetUnit Property

[image]

Revit 2024 API
OBJExportOptions..::..TargetUnit Property
OBJExportOptions Class See Also Send Feedback
The unit type of geometry in the resultant OBJ file. Default value is ExportUnit::Default.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public ExportUnit TargetUnit { get; set; }
Visual Basic
Public Property TargetUnit As ExportUnit
    Get
    Set
Visual C++
public:
property ExportUnit TargetUnit {
    ExportUnit get ();
    void set (ExportUnit value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

OBJExportOptions Class


OBJImportOptions Class

[image]

Revit 2024 API
OBJImportOptions Class
Members See Also Send Feedback
The import options used to import OBJ format files.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022.1

Syntax

C#
public class OBJImportOptions : BaseImportOptions
Visual Basic
Public Class OBJImportOptions _
    Inherits BaseImportOptions
Visual C++
public ref class OBJImportOptions : public BaseImportOptions

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BaseImportOptions
Autodesk.Revit.DB..::..OBJImportOptions

See Also

OBJImportOptions Members


OBJImportOptions Members

[image] [image]

Revit 2024 API
OBJImportOptions Members
OBJImportOptions Class Constructors Methods Properties See Also Send Feedback

The OBJImportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | OBJImportOptions()()()() | Constructs a new instance of OBJImportOptions with default values of all properties.
Public method | OBJImportOptions(OBJImportOptions) | Constructs a new instance of OBJImportOptions as a copy of the import options.

Methods

 | Name | Description
Public method | Dispose | (Inherited from BaseImportOptions.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDefaultLengthUnit | Get the default length unit used for importing unitless files. (Inherited from BaseImportOptions.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLayerSelection | Get all set layers name which user want to import into Revit. (Inherited from BaseImportOptions.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultLengthUnit | Set the default length unit used for importing unitless files. (Inherited from BaseImportOptions.)
Public method | SetLayerSelection | Set the layers name which user want to import into Revit. (Inherited from BaseImportOptions.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AutoCorrectAlmostVHLines | Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines. (Inherited from BaseImportOptions.)
Public property | ColorMode | Color mode for the import. Three modes are supported. Black and White, Preserve Colors, and Invert Colors. (Inherited from BaseImportOptions.)
Public property | CustomScale | Scaling the import. If this is defined and a valid value (> 0.0), it takes priority over units. (Inherited from BaseImportOptions.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BaseImportOptions.)
Public property | OrientToView | Place the import at the same orientation as the view that was passed into the import method. This option can only be used when not importing into a single view.(i.e. ThisViewOnly is set to false) (Inherited from BaseImportOptions.)
Public property | Placement | Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates. (Inherited from BaseImportOptions.)
Public property | ReferencePoint | The 3D point in the document where the imported instance will be inserted. If not explicitly set, the instance will be inserted at the document origin. (Inherited from BaseImportOptions.)
Public property | ThisViewOnly | Imports drawings into the view that was passed into the import method. This option is not available in 3D views. (Inherited from BaseImportOptions.)
Public property | Unit | The unit of measure for imported geometry. (Inherited from BaseImportOptions.)
Public property | VisibleLayersOnly | Only import the visible layers. (Inherited from BaseImportOptions.)

See Also

OBJImportOptions Class


OBJImportOptions Constructor

[image] [image]

Revit 2024 API
OBJImportOptions Constructor
OBJImportOptions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | OBJImportOptions()()()() | Constructs a new instance of OBJImportOptions with default values of all properties.
Public method | OBJImportOptions(OBJImportOptions) | Constructs a new instance of OBJImportOptions as a copy of the import options.

See Also

OBJImportOptions Class
OBJImportOptions Members


OBJImportOptions Constructor

[image]

Revit 2024 API
OBJImportOptions Constructor
OBJImportOptions Class See Also Send Feedback
Constructs a new instance of OBJImportOptions with default values of all properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022.1

Syntax

C#
public OBJImportOptions()
Visual Basic
Public Sub New
Visual C++
public:
OBJImportOptions()

See Also

OBJImportOptions Class
OBJImportOptions Overload


OBJImportOptions Constructor (OBJImportOptions)

[image]

Revit 2024 API
OBJImportOptions Constructor (OBJImportOptions)
OBJImportOptions Class See Also Send Feedback
Constructs a new instance of OBJImportOptions as a copy of the import options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022.1

Syntax

C#
public OBJImportOptions(
    OBJImportOptions option
)
Visual Basic
Public Sub New ( _
    option As OBJImportOptions _
)
Visual C++
public:
OBJImportOptions(
    OBJImportOptions^ option
)

Parameters

option
Type: Autodesk.Revit.DB..::..OBJImportOptions
The OBJ options to be copied.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

OBJImportOptions Class
OBJImportOptions Overload


OBJImportOptions Methods

[image] [image]

Revit 2024 API
OBJImportOptions Methods
OBJImportOptions Class See Also Send Feedback

The OBJImportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from BaseImportOptions.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDefaultLengthUnit | Get the default length unit used for importing unitless files. (Inherited from BaseImportOptions.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLayerSelection | Get all set layers name which user want to import into Revit. (Inherited from BaseImportOptions.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultLengthUnit | Set the default length unit used for importing unitless files. (Inherited from BaseImportOptions.)
Public method | SetLayerSelection | Set the layers name which user want to import into Revit. (Inherited from BaseImportOptions.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

OBJImportOptions Class


OBJImportOptions Properties

[image] [image]

Revit 2024 API
OBJImportOptions Properties
OBJImportOptions Class See Also Send Feedback

The OBJImportOptions type exposes the following members.

Properties

 | Name | Description
Public property | AutoCorrectAlmostVHLines | Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines. (Inherited from BaseImportOptions.)
Public property | ColorMode | Color mode for the import. Three modes are supported. Black and White, Preserve Colors, and Invert Colors. (Inherited from BaseImportOptions.)
Public property | CustomScale | Scaling the import. If this is defined and a valid value (> 0.0), it takes priority over units. (Inherited from BaseImportOptions.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BaseImportOptions.)
Public property | OrientToView | Place the import at the same orientation as the view that was passed into the import method. This option can only be used when not importing into a single view.(i.e. ThisViewOnly is set to false) (Inherited from BaseImportOptions.)
Public property | Placement | Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates. (Inherited from BaseImportOptions.)
Public property | ReferencePoint | The 3D point in the document where the imported instance will be inserted. If not explicitly set, the instance will be inserted at the document origin. (Inherited from BaseImportOptions.)
Public property | ThisViewOnly | Imports drawings into the view that was passed into the import method. This option is not available in 3D views. (Inherited from BaseImportOptions.)
Public property | Unit | The unit of measure for imported geometry. (Inherited from BaseImportOptions.)
Public property | VisibleLayersOnly | Only import the visible layers. (Inherited from BaseImportOptions.)

See Also

OBJImportOptions Class


OffsetSurface Class

[image]

Revit 2024 API
OffsetSurface Class
Members See Also Send Feedback
A mathematical representation of an offset surface.

Definition of offset surface, quoted from the STEP manual ISO 10303-42:2000(E): This is a procedural definition of a simple offset surface at a normal distance from the originating surface. Distance may be positive, negative, or zero to indicate the preferred side of the surface. The offset surface takes its parametrization directly from that of its basis surface, corresponding points having identical parameter values. The offset surface is parametrized as O(u, v) = S(u, v) + d*N(u, v), where N(u, v) is the oriented unit normal vector of the basis surface S at parameter value (u, v), and d is the signed offset distance.

In Revit, we restrict the types of basis surfaces for which an OffsetSurf can be created for the following reasons:

  • The offsets of Plane, CylindricalSurface, ConicalSurface and RevolvedSurface are of the same type as the original surface and they have closed form solutions. So those surfaces are not taken as basis surfaces of the OffsetSurface class. That leaves HermiteSurface and RuledSurface.
  • As a Revit surface, we require the OffsetSurface to be C2 continuous. That implies that the basis surface should be C3 continuous. That is because the OffsetSurface evaluation involves the normal of the basis surface and the order of continuity of the normal is one less than that of the surface.
  • HermiteSurfaces in general are not C3 continuous, even though some of them can be. A RuledSurface will be C3 continuous if its parametric curves are C3 continuous. So we don't allow a HermiteSurface to be a basis surface and allow only RuledSurfaces whose parametric curves are C3 continuous as basis surfaces of the OffsetSurface class.

The OffsetSurface class will own a copy of the basis surface and use it for many of its methods, which may implicitly assume that the OffsetSurface and the basis surface have the same envelope. So we keep the envelopes of the OffsetSurf and its basis surface in sync.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public class OffsetSurface : Surface
Visual Basic
Public Class OffsetSurface _
    Inherits Surface
Visual C++
public ref class OffsetSurface : public Surface

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Surface
Autodesk.Revit.DB..::..OffsetSurface

See Also

OffsetSurface Members


OffsetSurface Members

[image] [image]

Revit 2024 API
OffsetSurface Members
OffsetSurface Class Methods Properties See Also Send Feedback

The OffsetSurface type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from Surface.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBasisSurface | Returns a copy of basis surface of this OffsetSurface.
Public method | GetBoundingBoxUV | Gets the UV bounding box of the surface. (Inherited from Surface.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOffsetDistance | Returns offset distance of this OffsetSurface.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsOrientationSameAsBasisSurface | Indicates whether the orientation of the OffsetSurface is same as that of its basis surface, in the sense that their oriented normals at any (u, v) have the same direction.
Public method | Project | Project a 3D point orthogonally onto a surface (to find the nearest point). Throws InvalidOperationException if the projection fails. (Inherited from Surface.)
Public method | ProjectWithGuessPoint | Project a 3D point orthogonally onto a surface (to find the nearest point). This method is meant to be used when a good approximate solution for the projection is available. Throws InvalidOperationException if the projection fails. (Inherited from Surface.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Surface.)
Public property | OrientationMatchesParametricOrientation | Indicates whether this Surface's orientation is the same as or opposite to its parametric orientation. (Inherited from Surface.)

See Also

OffsetSurface Class


OffsetSurface Methods

[image] [image]

Revit 2024 API
OffsetSurface Methods
OffsetSurface Class See Also Send Feedback

The OffsetSurface type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from Surface.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBasisSurface | Returns a copy of basis surface of this OffsetSurface.
Public method | GetBoundingBoxUV | Gets the UV bounding box of the surface. (Inherited from Surface.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOffsetDistance | Returns offset distance of this OffsetSurface.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsOrientationSameAsBasisSurface | Indicates whether the orientation of the OffsetSurface is same as that of its basis surface, in the sense that their oriented normals at any (u, v) have the same direction.
Public method | Project | Project a 3D point orthogonally onto a surface (to find the nearest point). Throws InvalidOperationException if the projection fails. (Inherited from Surface.)
Public method | ProjectWithGuessPoint | Project a 3D point orthogonally onto a surface (to find the nearest point). This method is meant to be used when a good approximate solution for the projection is available. Throws InvalidOperationException if the projection fails. (Inherited from Surface.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

OffsetSurface Class


GetBasisSurface Method

[image]

Revit 2024 API
OffsetSurface..::..GetBasisSurface Method
OffsetSurface Class See Also Send Feedback
Returns a copy of basis surface of this OffsetSurface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public Surface GetBasisSurface()
Visual Basic
Public Function GetBasisSurface As Surface
Visual C++
public:
Surface^ GetBasisSurface()

Return Value

Basis surface of this OffsetSurface.

See Also

OffsetSurface Class


GetOffsetDistance Method

[image]

Revit 2024 API
OffsetSurface..::..GetOffsetDistance Method
OffsetSurface Class See Also Send Feedback
Returns offset distance of this OffsetSurface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public double GetOffsetDistance()
Visual Basic
Public Function GetOffsetDistance As Double
Visual C++
public:
double GetOffsetDistance()

Return Value

Offset distance of this OffsetSurface.

See Also

OffsetSurface Class


OffsetSurface Properties

[image] [image]

Revit 2024 API
OffsetSurface Properties
OffsetSurface Class See Also Send Feedback

The OffsetSurface type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Surface.)
Public property | OrientationMatchesParametricOrientation | Indicates whether this Surface's orientation is the same as or opposite to its parametric orientation. (Inherited from Surface.)

See Also

OffsetSurface Class


OpenConflictResult Enumeration

[image]

Revit 2024 API
OpenConflictResult Enumeration
See Also Send Feedback
The result of the open conflict.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019
Since: 2019

Syntax

C#
public enum OpenConflictResult
Visual Basic
Public Enumeration OpenConflictResult
Visual C++
public enum class OpenConflictResult

Members

Member name | Description
KeepLocalChanges | Keeps the local changes and open the model.
DiscardLocalChangesAndOpenLatestVersion | Discard the local changes and open the latest version of the model.
Cancel | Cancel the open action.
DetachFromCentral | Detach the model from its central model, with worksets preserved.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


OpenConflictScenario Enumeration

[image]

Revit 2024 API
OpenConflictScenario Enumeration
See Also Send Feedback
The kinds of conflicts happened during open.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019
Since: 2019

Syntax

C#
public enum OpenConflictScenario
Visual Basic
Public Enumeration OpenConflictScenario
Visual C++
public enum class OpenConflictScenario

Members

Member name | Description
Rollback | Central model is restored to an earlier version.
Relinquished | Ownership to model elements is relinquished.
OutOfDate | Model is out of date.
VersionArchived | Last central version merged into the local model has been archived in the central model.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


OpenForeignOption Enumeration

[image]

Revit 2024 API
OpenForeignOption Enumeration
See Also Send Feedback
Options for opening files saved by an application that was not developed or licensed by Autodesk.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019.2

Syntax

C#
public enum OpenForeignOption
Visual Basic
Public Enumeration OpenForeignOption
Visual C++
public enum class OpenForeignOption

Members

Member name | Description
Open | Do not show any prompt to the user if a foreign file is detected. Proceed to open.
DoNotOpen | Do not show any prompt to the user if a foreign file is detected. Cancel this operation (do not open the file).
Prompt | If possible, show a prompt to the user if a foreign file is detected. The operation may proceed or cancel based on the response.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


Opening Class

[image]

Revit 2024 API
Opening Class
Members Example See Also Send Feedback
An opening in an Autodesk Revit project or family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class Opening : Element
Visual Basic
Public Class Opening _
    Inherits Element
Visual C++
public ref class Opening : public Element

Remarks

The object represents a variety of different types of openings:
  • A rectangular opening in a wall created by two boundary points in a revit project.
  • An opening created by a set of curves applied to a roof, floor, ceiling, beam, brace or column.
  • A vertical shaft opening extending one or more levels.
  • A simple opening created on a wall or ceiling in a family document.
Depending upon the type of opening, some of the properties of this class will not be available. This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object. This object also supports access to a structural analytical model but this feature is only available with Autodesk Revit Structure.

Examples

CopyC#
private void Getinfo_Opening(Opening opening)
{
    string message = "Opening:";

    //get the host element of this opening
    message += "\nThe id of the opening's host element is : " + opening.Host.Id.ToString();

    //get the information whether the opening has a rect boundary
    //If the opening has a rect boundary, we can get the geometry information from BoundaryRect property.
    //Otherwise we should get the geometry information from BoundaryCurves property
    if (opening.IsRectBoundary)
    {
        message += "\nThe opening has a rectangular boundary.";
        //array contains two XYZ objects: the max and min coords of boundary
        IList<XYZ> boundaryRect = opening.BoundaryRect;

        //get the coordinate value of the min coordinate point
        XYZ point = opening.BoundaryRect[0];
        message += "\nMin coordinate point:(" + point.X + ", "
                                + point.Y + ", " + point.Z + ")";

        //get the coordinate value of the Max coordinate point
        point = opening.BoundaryRect[1];
        message += "\nMax coordinate point: (" + point.X + ", "
                                + point.Y + ", " + point.Z + ")";
    }
    else
    {
        message += "\nThe opening doesn't have a rectangular boundary.";
        // Get curve number
        int curves = opening.BoundaryCurves.Size;
        message += "\nNumber of curves is : " + curves;
        for (int i = 0; i < curves; i++)
        {
            Autodesk.Revit.DB.Curve curve = opening.BoundaryCurves.get_Item(i);
            // Get curve start point
            message += "\nCurve start point: " + XYZToString(curve.GetEndPoint(0));
            // Get curve end point
            message += "; Curve end point: " + XYZToString(curve.GetEndPoint(1));
        }
    }
    TaskDialog.Show("Revit",message);
}

// output the point's three coordinates
string XYZToString(XYZ point)
{
    return "(" + point.X + ", " + point.Y + ", " + point.Z + ")";
}
CopyVB.NET
Private Sub Getinfo_Opening(opening As Opening)
    Dim message As String = "Opening:"

    'get the host element of this opening
    message += vbLf & "The id of the opening's host element is : " & opening.Host.Id.ToString()

    'get the information whether the opening has a rect boundary
    'If the opening has a rect boundary, we can get the geometry information from BoundaryRect property.
    'Otherwise we should get the geometry information from BoundaryCurves property
    If opening.IsRectBoundary Then
        message += vbLf & "The opening has a rectangular boundary."
        'array contains two XYZ objects: the max and min coords of boundary
        Dim boundaryRect As IList(Of XYZ) = opening.BoundaryRect

        'get the coordinate value of the min coordinate point
        Dim point As XYZ = opening.BoundaryRect(0)
        message += ((vbLf & "Min coordinate point:(" + point.X & ", ") + point.Y & ", ") + point.Z & ")"

        'get the coordinate value of the Max coordinate point
        point = opening.BoundaryRect(1)
        message += ((vbLf & "Max coordinate point: (" + point.X & ", ") + point.Y & ", ") + point.Z & ")"
    Else
        message += vbLf & "The opening doesn't have a rectangular boundary."
        ' Get curve number
        Dim curves As Integer = opening.BoundaryCurves.Size
        message += vbLf & "Number of curves is : " & curves
        For i As Integer = 0 To curves - 1
            Dim curve As Autodesk.Revit.DB.Curve = opening.BoundaryCurves.Item(i)
            ' Get curve start point
            message += vbLf & "Curve start point: " & XYZToString(curve.GetEndPoint(0))
            ' Get curve end point
            message += "; Curve end point: " & XYZToString(curve.GetEndPoint(1))
        Next
    End If
    TaskDialog.Show("Revit", message)
End Sub

' output the point's three coordinates
Private Function XYZToString(point As XYZ) As String
    Return "(" & Convert.ToString(point.X) & ", " & Convert.ToString(point.Y) & ", " & Convert.ToString(point.Z) & ")"
End Function

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..Opening

See Also

Opening Members


Opening Members

[image] [image]

Revit 2024 API
Opening Members
Opening Class Methods Properties See Also Send Feedback

The Opening type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundaryCurves | The geometry information for non-rectangular openings in project documents, or for all openings in family documents.
Public property | BoundaryRect | Retrieves the geometry information if the opening boundary is a rect.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Host | Retrieves the host element of this opening.
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsRectBoundary | Retrieves the information whether the opening has a rectangular boundary.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsTransparentIn3D | Indicates if the opening is transparent in 3D view when loaded into the project.
Public property | IsTransparentInElevation | Indicates if the opening is transparent in elevation view when loaded into the project.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchId | Returns id of the Sketch or invalidElementId if element deon't own the Sketch.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Opening Class


Opening Methods

[image] [image]

Revit 2024 API
Opening Methods
Opening Class See Also Send Feedback

The Opening type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Opening Class


Opening Properties

[image] [image]

Revit 2024 API
Opening Properties
Opening Class See Also Send Feedback

The Opening type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundaryCurves | The geometry information for non-rectangular openings in project documents, or for all openings in family documents.
Public property | BoundaryRect | Retrieves the geometry information if the opening boundary is a rect.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Host | Retrieves the host element of this opening.
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsRectBoundary | Retrieves the information whether the opening has a rectangular boundary.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsTransparentIn3D | Indicates if the opening is transparent in 3D view when loaded into the project.
Public property | IsTransparentInElevation | Indicates if the opening is transparent in elevation view when loaded into the project.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchId | Returns id of the Sketch or invalidElementId if element deon't own the Sketch.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Opening Class


BoundaryCurves Property

[image]

Revit 2024 API
Opening..::..BoundaryCurves Property
Opening Class See Also Send Feedback
The geometry information for non-rectangular openings in project documents, or for all openings in family documents.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CurveArray BoundaryCurves { get; }
Visual Basic
Public ReadOnly Property BoundaryCurves As CurveArray
    Get
Visual C++
public:
property CurveArray^ BoundaryCurves {
    CurveArray^ get ();
}

Remarks

If IsRectBoundary is true, this value is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Opening Class


BoundaryRect Property

[image]

Revit 2024 API
Opening..::..BoundaryRect Property
Opening Class See Also Send Feedback
Retrieves the geometry information if the opening boundary is a rect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public IList<XYZ> BoundaryRect { get; }
Visual Basic
Public ReadOnly Property BoundaryRect As IList(Of XYZ)
    Get
Visual C++
public:
property IList<XYZ^>^ BoundaryRect {
    IList<XYZ^>^ get ();
}

Remarks

If IsRectBoundary is false, this value is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Opening Class


Host Property

[image]

Revit 2024 API
Opening..::..Host Property
Opening Class See Also Send Feedback
Retrieves the host element of this opening.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Element Host { get; }
Visual Basic
Public ReadOnly Property Host As Element
    Get
Visual C++
public:
property Element^ Host {
    Element^ get ();
}

See Also

Opening Class


IsRectBoundary Property

[image]

Revit 2024 API
Opening..::..IsRectBoundary Property
Opening Class See Also Send Feedback
Retrieves the information whether the opening has a rectangular boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsRectBoundary { get; }
Visual Basic
Public ReadOnly Property IsRectBoundary As Boolean
    Get
Visual C++
public:
property bool IsRectBoundary {
    bool get ();
}

Remarks

If the opening has a rectangular boundary, we can get the geometry information from BoundaryRect property. Otherwise we should get the geometry information from BoundaryCurves property.

See Also

Opening Class


IsTransparentInElevation Property

[image]

Revit 2024 API
Opening..::..IsTransparentInElevation Property
Opening Class See Also Send Feedback
Indicates if the opening is transparent in elevation view when loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsTransparentInElevation { get; set; }
Visual Basic
Public Property IsTransparentInElevation As Boolean
    Get
    Set
Visual C++
public:
property bool IsTransparentInElevation {
    bool get ();
    void set (bool value);
}

Remarks

This property is only valid in Revit family documents.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when access this property in an opening belonging to a Revit project document.

See Also

Opening Class


Parameter Property

[image] [image]

Revit 2024 API
Opening..::..Parameter Property
Opening Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Opening Class
Opening Members


SketchId Property

[image]

Revit 2024 API
Opening..::..SketchId Property
Opening Class See Also Send Feedback
Returns id of the Sketch or invalidElementId if element deon't own the Sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public ElementId SketchId { get; }
Visual Basic
Public ReadOnly Property SketchId As ElementId
    Get
Visual C++
public:
property ElementId^ SketchId {
    ElementId^ get ();
}

See Also

Opening Class


OpenOptions Class

[image]

Revit 2024 API
OpenOptions Class
Members See Also Send Feedback
This class contains options available for opening a document from disk.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public class OpenOptions : IDisposable
Visual Basic
Public Class OpenOptions _
    Implements IDisposable
Visual C++
public ref class OpenOptions : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..OpenOptions

See Also

OpenOptions Members


OpenOptions Members

[image] [image]

Revit 2024 API
OpenOptions Members
OpenOptions Class Constructors Methods Properties See Also Send Feedback

The OpenOptions type exposes the following members.

Constructors

 | Name | Description
Public method | OpenOptions | Constructs a new instance of the options class using default values.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the OpenOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOpenWorksetsConfiguration | Gets the object used to configure the worksets to open when the model is opened.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetOpenWorksetsConfiguration | Sets the object used to configure the worksets to open when the model is opened.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AllowOpeningLocalByWrongUser | Specifies whether a local file is allowed to be opened as read-only by a user other than its owner.
Public property | Audit | Specifies whether to expand all elements in order to check for corruption.
Public property | DetachFromCentralOption | An option that specifies whether or not a workset-enabled document is detached from its central document.
Public property | IgnoreExtensibleStorageSchemaConflict | Specifies whether to ignore the error of schema conflict.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OpenForeignOption | An option that specifies how to open files saved by an application that was not developed or licensed by Autodesk.

See Also

OpenOptions Class


OpenOptions Methods

[image] [image]

Revit 2024 API
OpenOptions Methods
OpenOptions Class See Also Send Feedback

The OpenOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOpenWorksetsConfiguration | Gets the object used to configure the worksets to open when the model is opened.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetOpenWorksetsConfiguration | Sets the object used to configure the worksets to open when the model is opened.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

OpenOptions Class


Dispose Method

[image]

Revit 2024 API
OpenOptions..::..Dispose Method
OpenOptions Class See Also Send Feedback
Releases all resources used by the OpenOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

OpenOptions Class


SetOpenWorksetsConfiguration Method

[image]

Revit 2024 API
OpenOptions..::..SetOpenWorksetsConfiguration Method
OpenOptions Class Example See Also Send Feedback
Sets the object used to configure the worksets to open when the model is opened.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void SetOpenWorksetsConfiguration(
    WorksetConfiguration openConfiguration
)
Visual Basic
Public Sub SetOpenWorksetsConfiguration ( _
    openConfiguration As WorksetConfiguration _
)
Visual C++
public:
void SetOpenWorksetsConfiguration(
    WorksetConfiguration^ openConfiguration
)

Parameters

openConfiguration
Type: Autodesk.Revit.DB..::..WorksetConfiguration
The options. If nullNothingnullptra null reference (Nothing in Visual Basic), all user-created worksets will be opened.

Remarks

These options are ignored for non-workshared models.

Examples

CopyC#
Document OpenDocumentWithWorksets(Application app, ModelPath projectPath)
{
    Document doc = null;
    try
    {
        // Get info on all the user worksets in the project prior to opening
        IList<WorksetPreview> worksets = WorksharingUtils.GetUserWorksetInfo(projectPath);
        IList<WorksetId> worksetIds = new List<WorksetId>();
        // Find two predetermined worksets
        foreach (WorksetPreview worksetPrev in worksets)
        {
            if (worksetPrev.Name.CompareTo("Workset1") == 0 ||
                worksetPrev.Name.CompareTo("Workset2") == 0)
            {
                worksetIds.Add(worksetPrev.Id);
            }
        }

        OpenOptions openOptions = new OpenOptions();
        // Setup config to close all worksets by default
        WorksetConfiguration openConfig = new WorksetConfiguration(WorksetConfigurationOption.CloseAllWorksets);
        // Set list of worksets for opening
        openConfig.Open(worksetIds);
        openOptions.SetOpenWorksetsConfiguration(openConfig);
        doc = app.OpenDocumentFile(projectPath, openOptions);
    }
    catch (Exception e)
    {
        TaskDialog.Show("Open File Failed", e.Message);
    }

    return doc;
}
CopyVB.NET
Private Function OpenDocumentWithWorksets(app As Application, projectPath As ModelPath) As Document
    Dim doc As Document = Nothing
    Try
        ' Get info on all the user worksets in the project prior to opening
        Dim worksets As IList(Of WorksetPreview) = WorksharingUtils.GetUserWorksetInfo(projectPath)
        Dim worksetIds As IList(Of WorksetId) = New List(Of WorksetId)()
        ' Find two predetermined worksets
        For Each worksetPrev As WorksetPreview In worksets
            If worksetPrev.Name.CompareTo("Workset1") = 0 OrElse worksetPrev.Name.CompareTo("Workset2") = 0 Then
                worksetIds.Add(worksetPrev.Id)
            End If
        Next

        Dim openOptions As New OpenOptions()
        ' Setup config to close all worksets by default
        Dim openConfig As New WorksetConfiguration(WorksetConfigurationOption.CloseAllWorksets)
        ' Set list of worksets for opening
        openConfig.Open(worksetIds)
        openOptions.SetOpenWorksetsConfiguration(openConfig)
        doc = app.OpenDocumentFile(projectPath, openOptions)
    Catch e As Exception
        TaskDialog.Show("Open File Failed", e.Message)
    End Try

    Return doc
End Function

See Also

OpenOptions Class


AllowOpeningLocalByWrongUser Property

[image]

Revit 2024 API
OpenOptions..::..AllowOpeningLocalByWrongUser Property
OpenOptions Class See Also Send Feedback
Specifies whether a local file is allowed to be opened as read-only by a user other than its owner.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool AllowOpeningLocalByWrongUser { get; set; }
Visual Basic
Public Property AllowOpeningLocalByWrongUser As Boolean
    Get
    Set
Visual C++
public:
property bool AllowOpeningLocalByWrongUser {
    bool get ();
    void set (bool value);
}

Remarks

The default is false. This option is ignored for central and non-workshared models.

See Also

OpenOptions Class


Audit Property

[image]

Revit 2024 API
OpenOptions..::..Audit Property
OpenOptions Class See Also Send Feedback
Specifies whether to expand all elements in order to check for corruption.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool Audit { get; set; }
Visual Basic
Public Property Audit As Boolean
    Get
    Set
Visual C++
public:
property bool Audit {
    bool get ();
    void set (bool value);
}

Remarks

The default is false. Setting this to true will increase the time and memory required to open the file.

See Also

OpenOptions Class


DetachFromCentralOption Property

[image]

Revit 2024 API
OpenOptions..::..DetachFromCentralOption Property
OpenOptions Class See Also Send Feedback
An option that specifies whether or not a workset-enabled document is detached from its central document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public DetachFromCentralOption DetachFromCentralOption { get; set; }
Visual Basic
Public Property DetachFromCentralOption As DetachFromCentralOption
    Get
    Set
Visual C++
public:
property DetachFromCentralOption DetachFromCentralOption {
    DetachFromCentralOption get ();
    void set (DetachFromCentralOption value);
}

Field Value

The default value is DetachFromCentralOption.DoNotDetach.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

OpenOptions Class


IgnoreExtensibleStorageSchemaConflict Property

[image]

Revit 2024 API
OpenOptions..::..IgnoreExtensibleStorageSchemaConflict Property
OpenOptions Class See Also Send Feedback
Specifies whether to ignore the error of schema conflict.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public bool IgnoreExtensibleStorageSchemaConflict { get; set; }
Visual Basic
Public Property IgnoreExtensibleStorageSchemaConflict As Boolean
    Get
    Set
Visual C++
public:
property bool IgnoreExtensibleStorageSchemaConflict {
    bool get ();
    void set (bool value);
}

Remarks

The default is false. Setting this to true will ignore the exception of schema conflict while opening the model. Data in the existing schema with the same ID will be erased from the model.

See Also

OpenOptions Class


IsValidObject Property

[image]

Revit 2024 API
OpenOptions..::..IsValidObject Property
OpenOptions Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

OpenOptions Class


OptionalFunctionalityUtils Class

[image]

Revit 2024 API
OptionalFunctionalityUtils Class
Members See Also Send Feedback
A collection of utilities that can be used to determine if a particular set of functionality is installed and available.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class OptionalFunctionalityUtils
Visual Basic
Public NotInheritable Class OptionalFunctionalityUtils
Visual C++
public ref class OptionalFunctionalityUtils abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..OptionalFunctionalityUtils

See Also

OptionalFunctionalityUtils Members


OptionalFunctionalityUtils Members

[image] [image]

Revit 2024 API
OptionalFunctionalityUtils Members
OptionalFunctionalityUtils Class Methods See Also Send Feedback

The OptionalFunctionalityUtils type exposes the following members.

Methods

Name | Description
Is3DMImportLinkAvailable | Checks whether the 3DM Import/Link functionality is available in the installed Revit.
IsAXMImportLinkAvailable | Checks whether the AXM Import/Link functionality is available in the installed Revit.
IsDGNExportAvailable | Checks whether the DGN Export functionality is available in the installed Revit.
IsDGNImportLinkAvailable | Checks whether the DGN Import/Link functionality is available in the installed Revit.
IsDWFExportAvailable | Checks whether the DWF/DWFx Export functionality is available in the installed Revit.
IsDWGExportAvailable | Checks whether the DWG Export functionality is available in the installed Revit.
IsDWGImportLinkAvailable | Checks whether the DWG Import/Link functionality is available in the installed Revit.
IsDXFExportAvailable | Checks whether the DXF Export functionality is available in the installed Revit.
IsFBXExportAvailable | Checks whether the FBX Export functionality is available in the installed Revit.
IsGraphicsAvailable | Checks whether the graphics functionality is available to support display, print, and export functionality.
IsIFCAvailable | Checks whether IFC functionality is available in the installed Revit.
IsNavisworksExporterAvailable | Checks whether a Navisworks Exporter is available in the installed Revit.
IsOBJImportLinkAvailable | Checks whether the OBJ Import/Link functionality is available in the installed Revit.
IsPDFImportAvailable | Obsolete. Checks whether PDF import is available in the installed Revit.
IsSATImportLinkAvailable | Checks whether the SAT Import/Link functionality is available in the installed Revit.
IsShapeImporterAvailable | Checks whether the ShapeImporter functionality is available in the installed Revit.
IsSKPImportLinkAvailable | Checks whether the SKP Import/Link functionality is available in the installed Revit.
IsSTLImportLinkAvailable | Checks whether the STL Import/Link functionality is available in the installed Revit.

See Also

OptionalFunctionalityUtils Class


Is3DMImportLinkAvailable Method

[image]

Revit 2024 API
OptionalFunctionalityUtils..::..Is3DMImportLinkAvailable Method
OptionalFunctionalityUtils Class See Also Send Feedback
Checks whether the 3DM Import/Link functionality is available in the installed Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public static bool Is3DMImportLinkAvailable()
Visual Basic
Public Shared Function Is3DMImportLinkAvailable As Boolean
Visual C++
public:
static bool Is3DMImportLinkAvailable()

Return Value

True if the 3DM Import/Link functionality is available in the installed Revit.

Remarks

3DM Import/Link is optional functionality that does not have to be part of the Revit installation.

See Also

OptionalFunctionalityUtils Class


IsAXMImportLinkAvailable Method

[image]

Revit 2024 API
OptionalFunctionalityUtils..::..IsAXMImportLinkAvailable Method
OptionalFunctionalityUtils Class See Also Send Feedback
Checks whether the AXM Import/Link functionality is available in the installed Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022.1

Syntax

C#
public static bool IsAXMImportLinkAvailable()
Visual Basic
Public Shared Function IsAXMImportLinkAvailable As Boolean
Visual C++
public:
static bool IsAXMImportLinkAvailable()

Return Value

True if the AXM Import/Link functionality is available in the installed Revit.

Remarks

AXM Import/Link is optional functionality that does not have to be part of the Revit installation.

See Also

OptionalFunctionalityUtils Class


IsDGNExportAvailable Method

[image]

Revit 2024 API
OptionalFunctionalityUtils..::..IsDGNExportAvailable Method
OptionalFunctionalityUtils Class See Also Send Feedback
Checks whether the DGN Export functionality is available in the installed Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static bool IsDGNExportAvailable()
Visual Basic
Public Shared Function IsDGNExportAvailable As Boolean
Visual C++
public:
static bool IsDGNExportAvailable()

Return Value

True if the DGN Export functionality is available in the installed Revit.

Remarks

DGN Export requires presence of certain modules that are optional and may not be part of the installed Revit.

See Also

OptionalFunctionalityUtils Class


IsDGNImportLinkAvailable Method

[image]

Revit 2024 API
OptionalFunctionalityUtils..::..IsDGNImportLinkAvailable Method
OptionalFunctionalityUtils Class See Also Send Feedback
Checks whether the DGN Import/Link functionality is available in the installed Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static bool IsDGNImportLinkAvailable()
Visual Basic
Public Shared Function IsDGNImportLinkAvailable As Boolean
Visual C++
public:
static bool IsDGNImportLinkAvailable()

Return Value

True if the DGN Import/Link functionality is available in the installed Revit.

Remarks

DGN Import/Link is optional functionality that does not have to be part of the Revit installation.

See Also

OptionalFunctionalityUtils Class


IsDWFExportAvailable Method

[image]

Revit 2024 API
OptionalFunctionalityUtils..::..IsDWFExportAvailable Method
OptionalFunctionalityUtils Class See Also Send Feedback
Checks whether the DWF/DWFx Export functionality is available in the installed Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static bool IsDWFExportAvailable()
Visual Basic
Public Shared Function IsDWFExportAvailable As Boolean
Visual C++
public:
static bool IsDWFExportAvailable()

Return Value

True if the DWF/DWFx Export functionality is available in the installed Revit.

Remarks

DWF/DWFx Export requires presence of certain modules that are optional and may not be part of the installed Revit.

See Also

OptionalFunctionalityUtils Class


IsDWGImportLinkAvailable Method

[image]

Revit 2024 API
OptionalFunctionalityUtils..::..IsDWGImportLinkAvailable Method
OptionalFunctionalityUtils Class See Also Send Feedback
Checks whether the DWG Import/Link functionality is available in the installed Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static bool IsDWGImportLinkAvailable()
Visual Basic
Public Shared Function IsDWGImportLinkAvailable As Boolean
Visual C++
public:
static bool IsDWGImportLinkAvailable()

Return Value

True if the DWG Import/Link functionality is available in the installed Revit.

Remarks

DWG Import/Link is optional functionality that does not have to be part of the Revit installation.

See Also

OptionalFunctionalityUtils Class


IsDXFExportAvailable Method

[image]

Revit 2024 API
OptionalFunctionalityUtils..::..IsDXFExportAvailable Method
OptionalFunctionalityUtils Class See Also Send Feedback
Checks whether the DXF Export functionality is available in the installed Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static bool IsDXFExportAvailable()
Visual Basic
Public Shared Function IsDXFExportAvailable As Boolean
Visual C++
public:
static bool IsDXFExportAvailable()

Return Value

True if the DXF Export functionality is available in the installed Revit.

Remarks

DXF Export requires presence of certain modules that are optional and may not be part of the installed Revit.

See Also

OptionalFunctionalityUtils Class


IsFBXExportAvailable Method

[image]

Revit 2024 API
OptionalFunctionalityUtils..::..IsFBXExportAvailable Method
OptionalFunctionalityUtils Class See Also Send Feedback
Checks whether the FBX Export functionality is available in the installed Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static bool IsFBXExportAvailable()
Visual Basic
Public Shared Function IsFBXExportAvailable As Boolean
Visual C++
public:
static bool IsFBXExportAvailable()

Return Value

True if the FBX Export functionality is available in the installed Revit.

Remarks

FBX Export requires presence of certain modules that are optional and may not be part of the installed Revit.

See Also

OptionalFunctionalityUtils Class


IsGraphicsAvailable Method

[image]

Revit 2024 API
OptionalFunctionalityUtils..::..IsGraphicsAvailable Method
OptionalFunctionalityUtils Class See Also Send Feedback
Checks whether the graphics functionality is available to support display, print, and export functionality.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static bool IsGraphicsAvailable()
Visual Basic
Public Shared Function IsGraphicsAvailable As Boolean
Visual C++
public:
static bool IsGraphicsAvailable()

Return Value

True if the Graphics functionality is available in the installed Revit.

Remarks

Graphics functionality is optional functionality that does not have to be part of the Revit installation.

See Also

OptionalFunctionalityUtils Class


IsIFCAvailable Method

[image]

Revit 2024 API
OptionalFunctionalityUtils..::..IsIFCAvailable Method
OptionalFunctionalityUtils Class See Also Send Feedback
Checks whether IFC functionality is available in the installed Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static bool IsIFCAvailable()
Visual Basic
Public Shared Function IsIFCAvailable As Boolean
Visual C++
public:
static bool IsIFCAvailable()

Return Value

True if the IFC functionality is available in the installed Revit.

Remarks

IFC Import/Export requires presence of certain modules that are optional and may not be part of the installed Revit.

See Also

OptionalFunctionalityUtils Class


IsNavisworksExporterAvailable Method

[image]

Revit 2024 API
OptionalFunctionalityUtils..::..IsNavisworksExporterAvailable Method
OptionalFunctionalityUtils Class See Also Send Feedback
Checks whether a Navisworks Exporter is available in the installed Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static bool IsNavisworksExporterAvailable()
Visual Basic
Public Shared Function IsNavisworksExporterAvailable As Boolean
Visual C++
public:
static bool IsNavisworksExporterAvailable()

Return Value

True if a Navisworks Exporter is available in the installed Revit.

Remarks

A Navisworks exporter is registered via an external add-in. If no add-in has registered an exporter, this will not be a part of the session.

See Also

OptionalFunctionalityUtils Class


IsOBJImportLinkAvailable Method

[image]

Revit 2024 API
OptionalFunctionalityUtils..::..IsOBJImportLinkAvailable Method
OptionalFunctionalityUtils Class See Also Send Feedback
Checks whether the OBJ Import/Link functionality is available in the installed Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022.1

Syntax

C#
public static bool IsOBJImportLinkAvailable()
Visual Basic
Public Shared Function IsOBJImportLinkAvailable As Boolean
Visual C++
public:
static bool IsOBJImportLinkAvailable()

Return Value

True if the OBJ Import/Link functionality is available in the installed Revit.

Remarks

OBJ Import/Link is optional functionality that does not have to be a part of the Revit installation.

See Also

OptionalFunctionalityUtils Class


IsPDFImportAvailable Method

[image]

Revit 2024 API
OptionalFunctionalityUtils..::..IsPDFImportAvailable Method
OptionalFunctionalityUtils Class See Also Send Feedback
Checks whether PDF import is available in the installed Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
[ObsoleteAttribute("This method is deprecated in Revit 2024 because it will always return true. It will be removed in a future version of Revit")]
public static bool IsPDFImportAvailable()
Visual Basic
<ObsoleteAttribute("This method is deprecated in Revit 2024 because it will always return true. It will be removed in a future version of Revit")> _
Public Shared Function IsPDFImportAvailable As Boolean
Visual C++
[ObsoleteAttribute(L"This method is deprecated in Revit 2024 because it will always return true. It will be removed in a future version of Revit")]
public:
static bool IsPDFImportAvailable()

Return Value

True if a PDF import is available in the installed Revit.

Remarks

PDF Import requires the presence of certain modules that are optional and may not be part of the installed Revit.

See Also

OptionalFunctionalityUtils Class


IsShapeImporterAvailable Method

[image]

Revit 2024 API
OptionalFunctionalityUtils..::..IsShapeImporterAvailable Method
OptionalFunctionalityUtils Class See Also Send Feedback
Checks whether the ShapeImporter functionality is available in the installed Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public static bool IsShapeImporterAvailable()
Visual Basic
Public Shared Function IsShapeImporterAvailable As Boolean
Visual C++
public:
static bool IsShapeImporterAvailable()

Return Value

True if the ShapeImporter functionality is available in the installed Revit.

See Also

OptionalFunctionalityUtils Class


IsSKPImportLinkAvailable Method

[image]

Revit 2024 API
OptionalFunctionalityUtils..::..IsSKPImportLinkAvailable Method
OptionalFunctionalityUtils Class See Also Send Feedback
Checks whether the SKP Import/Link functionality is available in the installed Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static bool IsSKPImportLinkAvailable()
Visual Basic
Public Shared Function IsSKPImportLinkAvailable As Boolean
Visual C++
public:
static bool IsSKPImportLinkAvailable()

Return Value

True if the SKP Import/Link functionality is available in the installed Revit.

Remarks

SKP Import/Link is optional functionality that does not have to be part of the Revit installation.

See Also

OptionalFunctionalityUtils Class


IsSTLImportLinkAvailable Method

[image]

Revit 2024 API
OptionalFunctionalityUtils..::..IsSTLImportLinkAvailable Method
OptionalFunctionalityUtils Class See Also Send Feedback
Checks whether the STL Import/Link functionality is available in the installed Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022.1

Syntax

C#
public static bool IsSTLImportLinkAvailable()
Visual Basic
Public Shared Function IsSTLImportLinkAvailable As Boolean
Visual C++
public:
static bool IsSTLImportLinkAvailable()

Return Value

True if the STL Import/Link functionality is available in the installed Revit.

Remarks

STL Import/Link is optional functionality that does not have to be a part of the Revit installation.

See Also

OptionalFunctionalityUtils Class


Options Class

[image]

Revit 2024 API
Options Class
Members See Also Send Feedback
User preferences for parsing of geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class Options : APIObject
Visual Basic
Public Class Options _
    Inherits APIObject
Visual C++
public ref class Options : public APIObject

Remarks

This class determines the output of the Element.Geometry property.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..Options

See Also

Options Members


Options Members

[image] [image]

Revit 2024 API
Options Members
Options Class Constructors Methods Properties See Also Send Feedback

The Options type exposes the following members.

Constructors

 | Name | Description
Public method | Options()()()() | Creates a default Options object.
Public method | Options(Options) | Copy constructor.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ComputeReferences | Determines whether or not references to geometric objects are computed.
Public property | DetailLevel | The detail level for the geometry extracted with these options.
Public property | IncludeNonVisibleObjects | Whether to extract element geometry objects not set as Visible. The default is false.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | View | The view used for geometry extraction.

See Also

Options Class


Options Constructor

[image] [image]

Revit 2024 API
Options Constructor
Options Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Options()()()() | Creates a default Options object.
Public method | Options(Options) | Copy constructor.

See Also

Options Class
Options Members


Options Constructor

[image]

Revit 2024 API
Options Constructor
Options Class See Also Send Feedback
Creates a default Options object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Options()
Visual Basic
Public Sub New
Visual C++
public:
Options()

Remarks

Defaults to medium detail, no references and no view.

See Also

Options Class
Options Overload


Options Constructor (Options)

[image]

Revit 2024 API
Options Constructor (Options)
Options Class See Also Send Feedback
Copy constructor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Options(
    Options pOptions
)
Visual Basic
Public Sub New ( _
    pOptions As Options _
)
Visual C++
public:
Options(
    Options^ pOptions
)

Parameters

pOptions
Type: Autodesk.Revit.DB..::..Options

See Also

Options Class
Options Overload


Options Methods

[image] [image]

Revit 2024 API
Options Methods
Options Class See Also Send Feedback

The Options type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Options Class


Options Properties

[image] [image]

Revit 2024 API
Options Properties
Options Class See Also Send Feedback

The Options type exposes the following members.

Properties

 | Name | Description
Public property | ComputeReferences | Determines whether or not references to geometric objects are computed.
Public property | DetailLevel | The detail level for the geometry extracted with these options.
Public property | IncludeNonVisibleObjects | Whether to extract element geometry objects not set as Visible. The default is false.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | View | The view used for geometry extraction.

See Also

Options Class


DetailLevel Property

[image]

Revit 2024 API
Options..::..DetailLevel Property
Options Class See Also Send Feedback
The detail level for the geometry extracted with these options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ViewDetailLevel DetailLevel { get; set; }
Visual Basic
Public Property DetailLevel As ViewDetailLevel
    Get
    Set
Visual C++
public:
property ViewDetailLevel DetailLevel {
    ViewDetailLevel get ();
    void set (ViewDetailLevel value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when setting this property, if View is already set. When View is set the detail level of the view is used.

See Also

Options Class


IncludeNonVisibleObjects Property

[image]

Revit 2024 API
Options..::..IncludeNonVisibleObjects Property
Options Class See Also Send Feedback
Whether to extract element geometry objects not set as Visible. The default is false.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IncludeNonVisibleObjects { get; set; }
Visual Basic
Public Property IncludeNonVisibleObjects As Boolean
    Get
    Set
Visual C++
public:
property bool IncludeNonVisibleObjects {
    bool get ();
    void set (bool value);
}

See Also

Options Class


OrdinateDimensionLineStyle Enumeration

[image]

Revit 2024 API
OrdinateDimensionLineStyle Enumeration
See Also Send Feedback
The ordinate dimension line style.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update
Since: 2017 Subscription Update

Syntax

C#
public enum OrdinateDimensionLineStyle
Visual Basic
Public Enumeration OrdinateDimensionLineStyle
Visual C++
public enum class OrdinateDimensionLineStyle

Members

Member name | Description
None | Shows no dimension line. When you select the dimension line in the drawing area, a hidden line displays.
Continuous | Displays the dimension line as continuous.
Segmented | Segments the dimension line. Specify the length of the segments with the DimensionLineLength property.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


OrdinateDimensionSetting Members

[image] [image]

Revit 2024 API
OrdinateDimensionSetting Members
OrdinateDimensionSetting Class Constructors Methods Properties See Also Send Feedback

The OrdinateDimensionSetting type exposes the following members.

Constructors

 | Name | Description
Public method | OrdinateDimensionSetting | Constructs a new OrdinateDimensionSetting object with default settings.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the OrdinateDimensionSetting
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DimensionLineLength | Specifies the dimension line segment length. This setting is enabled when Dimension Line Style is Segmented.
Public property | DimensionLineStyle | Specifies the dimension line style.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OriginTickMarkId | Specifies the id of the tick mark element to use for the dimension origin.
Public property | OriginVisibility | Specifies thevisibility of the origin witness line for the ordinate dimension (this is the first witness line in the string).
Public property | TextOrientation | Specifies where to align the dimension text.
Public property | TextPosition | Specifies the dimension text position.

See Also

OrdinateDimensionSetting Class


OrdinateDimensionSetting Methods

[image] [image]

Revit 2024 API
OrdinateDimensionSetting Methods
OrdinateDimensionSetting Class See Also Send Feedback

The OrdinateDimensionSetting type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

OrdinateDimensionSetting Class


OrdinateDimensionSetting Properties

[image] [image]

Revit 2024 API
OrdinateDimensionSetting Properties
OrdinateDimensionSetting Class See Also Send Feedback

The OrdinateDimensionSetting type exposes the following members.

Properties

 | Name | Description
Public property | DimensionLineLength | Specifies the dimension line segment length. This setting is enabled when Dimension Line Style is Segmented.
Public property | DimensionLineStyle | Specifies the dimension line style.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OriginTickMarkId | Specifies the id of the tick mark element to use for the dimension origin.
Public property | OriginVisibility | Specifies thevisibility of the origin witness line for the ordinate dimension (this is the first witness line in the string).
Public property | TextOrientation | Specifies where to align the dimension text.
Public property | TextPosition | Specifies the dimension text position.

See Also

OrdinateDimensionSetting Class


DimensionLineLength Property

[image]

Revit 2024 API
OrdinateDimensionSetting..::..DimensionLineLength Property
OrdinateDimensionSetting Class See Also Send Feedback
Specifies the dimension line segment length. This setting is enabled when Dimension Line Style is Segmented.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update

Syntax

C#
public double DimensionLineLength { get; set; }
Visual Basic
Public Property DimensionLineLength As Double
    Get
    Set
Visual C++
public:
property double DimensionLineLength {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for dimensionLineLength must be greater than 0 and no more than 30000 feet.

See Also

OrdinateDimensionSetting Class


DimensionLineStyle Property

[image]

Revit 2024 API
OrdinateDimensionSetting..::..DimensionLineStyle Property
OrdinateDimensionSetting Class See Also Send Feedback
Specifies the dimension line style.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update

Syntax

C#
public OrdinateDimensionLineStyle DimensionLineStyle { get; set; }
Visual Basic
Public Property DimensionLineStyle As OrdinateDimensionLineStyle
    Get
    Set
Visual C++
public:
property OrdinateDimensionLineStyle DimensionLineStyle {
    OrdinateDimensionLineStyle get ();
    void set (OrdinateDimensionLineStyle value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

OrdinateDimensionSetting Class


IsValidObject Property

[image]

Revit 2024 API
OrdinateDimensionSetting..::..IsValidObject Property
OrdinateDimensionSetting Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

OrdinateDimensionSetting Class


OriginVisibility Property

[image]

Revit 2024 API
OrdinateDimensionSetting..::..OriginVisibility Property
OrdinateDimensionSetting Class See Also Send Feedback
Specifies thevisibility of the origin witness line for the ordinate dimension (this is the first witness line in the string).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update

Syntax

C#
public OrdinateOriginVisibility OriginVisibility { get; set; }
Visual Basic
Public Property OriginVisibility As OrdinateOriginVisibility
    Get
    Set
Visual C++
public:
property OrdinateOriginVisibility OriginVisibility {
    OrdinateOriginVisibility get ();
    void set (OrdinateOriginVisibility value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

OrdinateDimensionSetting Class


TextPosition Property

[image]

Revit 2024 API
OrdinateDimensionSetting..::..TextPosition Property
OrdinateDimensionSetting Class See Also Send Feedback
Specifies the dimension text position.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update

Syntax

C#
public OrdinateTextPosition TextPosition { get; set; }
Visual Basic
Public Property TextPosition As OrdinateTextPosition
    Get
    Set
Visual C++
public:
property OrdinateTextPosition TextPosition {
    OrdinateTextPosition get ();
    void set (OrdinateTextPosition value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

OrdinateDimensionSetting Class


Outline Class

[image]

Revit 2024 API
Outline Class
Members See Also Send Feedback
Outline is a generic object that provides a bounding box/bounding outline. It supports operations to scale and transform. It also supports intersections and contains operations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class Outline : IDisposable
Visual Basic
Public Class Outline _
    Implements IDisposable
Visual C++
public ref class Outline : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Outline

See Also

Outline Members


Outline Members

[image] [image]

Revit 2024 API
Outline Members
Outline Class Constructors Methods Properties See Also Send Feedback

The Outline type exposes the following members.

Constructors

 | Name | Description
Public method | Outline(Outline) | Constructs a new copy of the input Outline object.
Public method | Outline(XYZ, XYZ) | Constructor that uses a minimum and maximum XYZ point to initialize the outline.

Methods

 | Name | Description
Public method | AddPoint | Adds a point to the bounding box, expanding it if the point is outside the existing boundary.
Public method | Contains | Determine if this Outline contains the specified point to within a tolerance.
Public method | ContainsOtherOutline | Determine if this Outline contains another Outline to within tolerance.
Public method | Dispose | Releases all resources used by the Outline
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDiagonalLength | Get the length of outline's diagonal. If called on empty outline, 0. is returned
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersects | Determine if this Outline intersects the input Outline to within a specified tolerance.
Public method | IsScaleValid | Checks if given scale is valid. Should be greater than zero.
Public method | Scale | Scales the bounding box by given scale.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Identifies if the outline represents an empty outline.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MaximumPoint | The maximum point of the bounding box.
Public property | MinimumPoint | The minimum point of the bounding box.

See Also

Outline Class


Outline Constructor

[image] [image]

Revit 2024 API
Outline Constructor
Outline Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Outline(Outline) | Constructs a new copy of the input Outline object.
Public method | Outline(XYZ, XYZ) | Constructor that uses a minimum and maximum XYZ point to initialize the outline.

See Also

Outline Class
Outline Members


Outline Constructor (Outline)

[image]

Revit 2024 API
Outline Constructor (Outline)
Outline Class See Also Send Feedback
Constructs a new copy of the input Outline object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public Outline(
    Outline other
)
Visual Basic
Public Sub New ( _
    other As Outline _
)
Visual C++
public:
Outline(
    Outline^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..Outline

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

Outline Class
Outline Overload


Outline Constructor (XYZ, XYZ)

[image]

Revit 2024 API
Outline Constructor (XYZ, XYZ)
Outline Class See Also Send Feedback
Constructor that uses a minimum and maximum XYZ point to initialize the outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public Outline(
    XYZ minimumPoint,
    XYZ maximumPoint
)
Visual Basic
Public Sub New ( _
    minimumPoint As XYZ, _
    maximumPoint As XYZ _
)
Visual C++
public:
Outline(
    XYZ^ minimumPoint,
    XYZ^ maximumPoint
)

Parameters

minimumPoint
Type: Autodesk.Revit.DB..::..XYZ
The minimum point
maximumPoint
Type: Autodesk.Revit.DB..::..XYZ
The maximum point.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Outline Class
Outline Overload


Outline Methods

[image] [image]

Revit 2024 API
Outline Methods
Outline Class See Also Send Feedback

The Outline type exposes the following members.

Methods

 | Name | Description
Public method | AddPoint | Adds a point to the bounding box, expanding it if the point is outside the existing boundary.
Public method | Contains | Determine if this Outline contains the specified point to within a tolerance.
Public method | ContainsOtherOutline | Determine if this Outline contains another Outline to within tolerance.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDiagonalLength | Get the length of outline's diagonal. If called on empty outline, 0. is returned
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersects | Determine if this Outline intersects the input Outline to within a specified tolerance.
Public method | IsScaleValid | Checks if given scale is valid. Should be greater than zero.
Public method | Scale | Scales the bounding box by given scale.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Outline Class


AddPoint Method

[image]

Revit 2024 API
Outline..::..AddPoint Method
Outline Class See Also Send Feedback
Adds a point to the bounding box, expanding it if the point is outside the existing boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public void AddPoint(
    XYZ point
)
Visual Basic
Public Sub AddPoint ( _
    point As XYZ _
)
Visual C++
public:
void AddPoint(
    XYZ^ point
)

Parameters

point
Type: Autodesk.Revit.DB..::..XYZ
The point to add.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Outline Class


Contains Method

[image]

Revit 2024 API
Outline..::..Contains Method
Outline Class See Also Send Feedback
Determine if this Outline contains the specified point to within a tolerance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool Contains(
    XYZ point,
    double tolerance
)
Visual Basic
Public Function Contains ( _
    point As XYZ, _
    tolerance As Double _
) As Boolean
Visual C++
public:
bool Contains(
    XYZ^ point,
    double tolerance
)

Parameters

point
Type: Autodesk.Revit.DB..::..XYZ
The point to test for containment.
tolerance
Type: System..::..Double
The tolerance to use when determining whether the point is contained. Defaults to zero.

Return Value

True if this outline contains the given point, or false otherwise.

Remarks

If the tolerance is positive, the point may lie up to the tolerance amount outside the outline in each coordinate. If the tolerance is negative, the point must lie at least the tolerance amount inside the outline in each coordinate.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Outline Class


ContainsOtherOutline Method

[image]

Revit 2024 API
Outline..::..ContainsOtherOutline Method
Outline Class See Also Send Feedback
Determine if this Outline contains another Outline to within tolerance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool ContainsOtherOutline(
    Outline otherOutline,
    double tolerance
)
Visual Basic
Public Function ContainsOtherOutline ( _
    otherOutline As Outline, _
    tolerance As Double _
) As Boolean
Visual C++
public:
bool ContainsOtherOutline(
    Outline^ otherOutline,
    double tolerance
)

Parameters

otherOutline
Type: Autodesk.Revit.DB..::..Outline
The outline to test for containment.
tolerance
Type: System..::..Double
The tolerance to use when determining whether the point is contained. Defaults to zero.

Return Value

True if this outline contains the given outline, or false otherwise.

Remarks

If the tolerance is positive, the other Outline may extend the tolerance distance outside of this Outline in each coordinate. If the tolerance is negative, the other Outline must lie at least the tolerance distance inside of this Outline in each coordinate to be a match.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

Outline Class


GetDiagonalLength Method

[image]

Revit 2024 API
Outline..::..GetDiagonalLength Method
Outline Class See Also Send Feedback
Get the length of outline's diagonal. If called on empty outline, 0. is returned

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public double GetDiagonalLength()
Visual Basic
Public Function GetDiagonalLength As Double
Visual C++
public:
double GetDiagonalLength()

Return Value

The length of the diagonal.

See Also

Outline Class


Intersects Method

[image]

Revit 2024 API
Outline..::..Intersects Method
Outline Class See Also Send Feedback
Determine if this Outline intersects the input Outline to within a specified tolerance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool Intersects(
    Outline outline,
    double tolerance
)
Visual Basic
Public Function Intersects ( _
    outline As Outline, _
    tolerance As Double _
) As Boolean
Visual C++
public:
bool Intersects(
    Outline^ outline,
    double tolerance
)

Parameters

outline
Type: Autodesk.Revit.DB..::..Outline
The outline to test for intersection with this one.
tolerance
Type: System..::..Double
The tolerance to use when determining intersection. Defaults to zero.

Return Value

True if the given outline intersects this outline.

Remarks

If the tolerance is positive, the outlines may be separated by the tolerance distance in each coordinate. If the tolerance is negative, the outlines must overlap by at least the tolerance distance in each coordinate.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

Outline Class


IsScaleValid Method

[image]

Revit 2024 API
Outline..::..IsScaleValid Method
Outline Class See Also Send Feedback
Checks if given scale is valid. Should be greater than zero.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool IsScaleValid(
    double scale
)
Visual Basic
Public Function IsScaleValid ( _
    scale As Double _
) As Boolean
Visual C++
public:
bool IsScaleValid(
    double scale
)

Parameters

scale
Type: System..::..Double
The scale.

Return Value

True if the scale is valid, false otherwise.

See Also

Outline Class


Scale Method

[image]

Revit 2024 API
Outline..::..Scale Method
Outline Class See Also Send Feedback
Scales the bounding box by given scale.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public void Scale(
    double scale
)
Visual Basic
Public Sub Scale ( _
    scale As Double _
)
Visual C++
public:
void Scale(
    double scale
)

Parameters

scale
Type: System..::..Double
The scale value. It should be greater than zero.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The scale is invalid.

See Also

Outline Class


Outline Properties

[image] [image]

Revit 2024 API
Outline Properties
Outline Class See Also Send Feedback

The Outline type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Identifies if the outline represents an empty outline.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MaximumPoint | The maximum point of the bounding box.
Public property | MinimumPoint | The minimum point of the bounding box.

See Also

Outline Class


IsEmpty Property

[image]

Revit 2024 API
Outline..::..IsEmpty Property
Outline Class See Also Send Feedback
Identifies if the outline represents an empty outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool IsEmpty { get; }
Visual Basic
Public ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
property bool IsEmpty {
    bool get ();
}

See Also

Outline Class


IsValidObject Property

[image]

Revit 2024 API
Outline..::..IsValidObject Property
Outline Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

Outline Class


MaximumPoint Property

[image]

Revit 2024 API
Outline..::..MaximumPoint Property
Outline Class See Also Send Feedback
The maximum point of the bounding box.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public XYZ MaximumPoint { get; set; }
Visual Basic
Public Property MaximumPoint As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ MaximumPoint {
    XYZ^ get ();
    void set (XYZ^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

Outline Class


MinimumPoint Property

[image]

Revit 2024 API
Outline..::..MinimumPoint Property
Outline Class See Also Send Feedback
The minimum point of the bounding box.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public XYZ MinimumPoint { get; set; }
Visual Basic
Public Property MinimumPoint As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ MinimumPoint {
    XYZ^ get ();
    void set (XYZ^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

Outline Class


OverrideGraphicSettings Members

[image] [image]

Revit 2024 API
OverrideGraphicSettings Members
OverrideGraphicSettings Class Constructors Methods Properties See Also Send Feedback

The OverrideGraphicSettings type exposes the following members.

Constructors

 | Name | Description
Public method | OverrideGraphicSettings()()()() | Creates a new instance of an OverrideGraphicSettings object.
Public method | OverrideGraphicSettings(OverrideGraphicSettings) | Creates a new instance of an OverrideGraphicSettings object based on an existing OverrideGraphicSettings object.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the OverrideGraphicSettings
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetCutBackgroundPatternColor | Sets the override color of the background pattern of cut faces.
Public method | SetCutBackgroundPatternId | Sets the ElementId of the cut face background pattern override. The fill pattern must be a drafting pattern. A value of InvalidElementId means no override is set.
Public method | SetCutBackgroundPatternVisible | Sets the visibility of the cut face background fill pattern.
Public method | SetCutForegroundPatternColor | Sets the override color of the foreground pattern of cut faces.
Public method | SetCutForegroundPatternId | Sets the ElementId of the cut face foreground pattern override. The fill pattern must be a drafting pattern. A value of InvalidElementId means no override is set.
Public method | SetCutForegroundPatternVisible | Sets the visibility of the cut face foreground fill pattern.
Public method | SetCutLineColor | Sets the cut surface line color.
Public method | SetCutLinePatternId | Sets the ElementId of the cut surface line pattern.
Public method | SetCutLineWeight | Sets the cut surface line weight.
Public method | SetDetailLevel | Sets the detail level.
Public method | SetHalftone | Sets the halftone value.
Public method | SetProjectionLineColor | Sets the projection surface line color.
Public method | SetProjectionLinePatternId | Sets the ElementId of the projection surface line pattern.
Public method | SetProjectionLineWeight | Sets the projection surface line weight.
Public method | SetSurfaceBackgroundPatternColor | Sets the override color of the surface background pattern.
Public method | SetSurfaceBackgroundPatternId | Sets the ElementId of the surface background pattern override. The fill pattern must be a drafting pattern. A value of InvalidElementId means no override is set.
Public method | SetSurfaceBackgroundPatternVisible | Sets the visibility of the surface background fill pattern.
Public method | SetSurfaceForegroundPatternColor | Sets the override color of the surface foreground pattern.
Public method | SetSurfaceForegroundPatternId | Sets the ElementId of the surface foreground pattern override. The fill pattern must be a drafting pattern. A value of InvalidElementId means no override is set.
Public method | SetSurfaceForegroundPatternVisible | Sets the visibility of the surface foreground fill pattern.
Public method | SetSurfaceTransparency | Sets the projection surface transparency.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CutBackgroundPatternColor | The override color of the background pattern of cut faces.
Public property | CutBackgroundPatternId | The ElementId of the cut face background fill pattern override. A value of InvalidElementId means no override is set.
Public property | CutForegroundPatternColor | The override color of the foreground pattern of cut faces.
Public property | CutForegroundPatternId | The ElementId of the cut face foreground fill pattern override. A value of InvalidElementId means no override is set.
Public property | CutLineColor | Cut surface line color.
Public property | CutLinePatternId | ElementId of the cut surface line pattern.
Public property | CutLineWeight | Cut surface line weight.
Public property | DetailLevel | The detail level.
Public property | Halftone | Value of the halftone override.
 | InvalidPenNumber | The invalidPenNumber for clearing line weight overrides.
Public property | IsCutBackgroundPatternVisible | The visibility of the cut face background fill pattern.
Public property | IsCutForegroundPatternVisible | The visibility of the cut face foreground fill pattern.
Public property | IsSurfaceBackgroundPatternVisible | The visibility of the surface background fill pattern.
Public property | IsSurfaceForegroundPatternVisible | The visibility of the surface foreground fill pattern.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ProjectionLineColor | Projection surface line color.
Public property | ProjectionLinePatternId | Id of the projection surface line pattern.
Public property | ProjectionLineWeight | The projection surface line weight.
Public property | SurfaceBackgroundPatternColor | The override color of the surface background pattern.
Public property | SurfaceBackgroundPatternId | The ElementId of the surface background fill pattern override. A value of InvalidElementId means no override is set.
Public property | SurfaceForegroundPatternColor | The override color of the surface foreground pattern.
Public property | SurfaceForegroundPatternId | The ElementId of the surface foreground fill pattern override. A value of InvalidElementId means no override is set.
Public property | Transparency | Transparency of surfaces.

See Also

OverrideGraphicSettings Class


OverrideGraphicSettings Constructor

[image] [image]

Revit 2024 API
OverrideGraphicSettings Constructor
OverrideGraphicSettings Class See Also Send Feedback

Overload List

 | Name | Description
Public method | OverrideGraphicSettings()()()() | Creates a new instance of an OverrideGraphicSettings object.
Public method | OverrideGraphicSettings(OverrideGraphicSettings) | Creates a new instance of an OverrideGraphicSettings object based on an existing OverrideGraphicSettings object.

See Also

OverrideGraphicSettings Class
OverrideGraphicSettings Members


OverrideGraphicSettings Constructor

[image]

Revit 2024 API
OverrideGraphicSettings Constructor
OverrideGraphicSettings Class See Also Send Feedback
Creates a new instance of an OverrideGraphicSettings object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public OverrideGraphicSettings()
Visual Basic
Public Sub New
Visual C++
public:
OverrideGraphicSettings()

See Also

OverrideGraphicSettings Class
OverrideGraphicSettings Overload


OverrideGraphicSettings Methods

[image] [image]

Revit 2024 API
OverrideGraphicSettings Methods
OverrideGraphicSettings Class See Also Send Feedback

The OverrideGraphicSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetCutBackgroundPatternColor | Sets the override color of the background pattern of cut faces.
Public method | SetCutBackgroundPatternId | Sets the ElementId of the cut face background pattern override. The fill pattern must be a drafting pattern. A value of InvalidElementId means no override is set.
Public method | SetCutBackgroundPatternVisible | Sets the visibility of the cut face background fill pattern.
Public method | SetCutForegroundPatternColor | Sets the override color of the foreground pattern of cut faces.
Public method | SetCutForegroundPatternId | Sets the ElementId of the cut face foreground pattern override. The fill pattern must be a drafting pattern. A value of InvalidElementId means no override is set.
Public method | SetCutForegroundPatternVisible | Sets the visibility of the cut face foreground fill pattern.
Public method | SetCutLineColor | Sets the cut surface line color.
Public method | SetCutLinePatternId | Sets the ElementId of the cut surface line pattern.
Public method | SetCutLineWeight | Sets the cut surface line weight.
Public method | SetDetailLevel | Sets the detail level.
Public method | SetHalftone | Sets the halftone value.
Public method | SetProjectionLineColor | Sets the projection surface line color.
Public method | SetProjectionLinePatternId | Sets the ElementId of the projection surface line pattern.
Public method | SetProjectionLineWeight | Sets the projection surface line weight.
Public method | SetSurfaceBackgroundPatternColor | Sets the override color of the surface background pattern.
Public method | SetSurfaceBackgroundPatternId | Sets the ElementId of the surface background pattern override. The fill pattern must be a drafting pattern. A value of InvalidElementId means no override is set.
Public method | SetSurfaceBackgroundPatternVisible | Sets the visibility of the surface background fill pattern.
Public method | SetSurfaceForegroundPatternColor | Sets the override color of the surface foreground pattern.
Public method | SetSurfaceForegroundPatternId | Sets the ElementId of the surface foreground pattern override. The fill pattern must be a drafting pattern. A value of InvalidElementId means no override is set.
Public method | SetSurfaceForegroundPatternVisible | Sets the visibility of the surface foreground fill pattern.
Public method | SetSurfaceTransparency | Sets the projection surface transparency.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

OverrideGraphicSettings Class


Dispose Method

[image]

Revit 2024 API
OverrideGraphicSettings..::..Dispose Method
OverrideGraphicSettings Class See Also Send Feedback
Releases all resources used by the OverrideGraphicSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

OverrideGraphicSettings Class


SetCutBackgroundPatternColor Method

[image]

Revit 2024 API
OverrideGraphicSettings..::..SetCutBackgroundPatternColor Method
OverrideGraphicSettings Class See Also Send Feedback
Sets the override color of the background pattern of cut faces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public OverrideGraphicSettings SetCutBackgroundPatternColor(
    Color color
)
Visual Basic
Public Function SetCutBackgroundPatternColor ( _
    color As Color _
) As OverrideGraphicSettings
Visual C++
public:
OverrideGraphicSettings^ SetCutBackgroundPatternColor(
    Color^ color
)

Parameters

color
Type: Autodesk.Revit.DB..::..Color
Value of the cut face background color for the override. InvalidColorValue means no override is set.

Return Value

Reference to the changed object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

OverrideGraphicSettings Class


SetCutBackgroundPatternVisible Method

[image]

Revit 2024 API
OverrideGraphicSettings..::..SetCutBackgroundPatternVisible Method
OverrideGraphicSettings Class See Also Send Feedback
Sets the visibility of the cut face background fill pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public OverrideGraphicSettings SetCutBackgroundPatternVisible(
    bool fillPatternVisible
)
Visual Basic
Public Function SetCutBackgroundPatternVisible ( _
    fillPatternVisible As Boolean _
) As OverrideGraphicSettings
Visual C++
public:
OverrideGraphicSettings^ SetCutBackgroundPatternVisible(
    bool fillPatternVisible
)

Parameters

fillPatternVisible
Type: System..::..Boolean
Value of the visibility of the cut face background fill pattern.

Return Value

Reference to the changed object.

See Also

OverrideGraphicSettings Class


SetCutForegroundPatternColor Method

[image]

Revit 2024 API
OverrideGraphicSettings..::..SetCutForegroundPatternColor Method
OverrideGraphicSettings Class See Also Send Feedback
Sets the override color of the foreground pattern of cut faces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public OverrideGraphicSettings SetCutForegroundPatternColor(
    Color color
)
Visual Basic
Public Function SetCutForegroundPatternColor ( _
    color As Color _
) As OverrideGraphicSettings
Visual C++
public:
OverrideGraphicSettings^ SetCutForegroundPatternColor(
    Color^ color
)

Parameters

color
Type: Autodesk.Revit.DB..::..Color
Value of the cut face foreground color for the override. InvalidColorValue means no override is set.

Return Value

Reference to the changed object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

OverrideGraphicSettings Class


SetCutForegroundPatternId Method

[image]

Revit 2024 API
OverrideGraphicSettings..::..SetCutForegroundPatternId Method
OverrideGraphicSettings Class See Also Send Feedback
Sets the ElementId of the cut face foreground pattern override. The fill pattern must be a drafting pattern. A value of InvalidElementId means no override is set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public OverrideGraphicSettings SetCutForegroundPatternId(
    ElementId fillPatternId
)
Visual Basic
Public Function SetCutForegroundPatternId ( _
    fillPatternId As ElementId _
) As OverrideGraphicSettings
Visual C++
public:
OverrideGraphicSettings^ SetCutForegroundPatternId(
    ElementId^ fillPatternId
)

Parameters

fillPatternId
Type: Autodesk.Revit.DB..::..ElementId
Value of the cut face foreground fill pattern override.

Return Value

Reference to the changed object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

OverrideGraphicSettings Class


SetCutForegroundPatternVisible Method

[image]

Revit 2024 API
OverrideGraphicSettings..::..SetCutForegroundPatternVisible Method
OverrideGraphicSettings Class See Also Send Feedback
Sets the visibility of the cut face foreground fill pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public OverrideGraphicSettings SetCutForegroundPatternVisible(
    bool fillPatternVisible
)
Visual Basic
Public Function SetCutForegroundPatternVisible ( _
    fillPatternVisible As Boolean _
) As OverrideGraphicSettings
Visual C++
public:
OverrideGraphicSettings^ SetCutForegroundPatternVisible(
    bool fillPatternVisible
)

Parameters

fillPatternVisible
Type: System..::..Boolean
Value of the visibility of the cut face foreground fill pattern.

Return Value

Reference to the changed object.

See Also

OverrideGraphicSettings Class


SetCutLineColor Method

[image]

Revit 2024 API
OverrideGraphicSettings..::..SetCutLineColor Method
OverrideGraphicSettings Class See Also Send Feedback
Sets the cut surface line color.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public OverrideGraphicSettings SetCutLineColor(
    Color color
)
Visual Basic
Public Function SetCutLineColor ( _
    color As Color _
) As OverrideGraphicSettings
Visual C++
public:
OverrideGraphicSettings^ SetCutLineColor(
    Color^ color
)

Parameters

color
Type: Autodesk.Revit.DB..::..Color
Value of the cut surface line color for the override. InvalidColorValue means no override is set.

Return Value

Reference to the changed object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

OverrideGraphicSettings Class


SetCutLinePatternId Method

[image]

Revit 2024 API
OverrideGraphicSettings..::..SetCutLinePatternId Method
OverrideGraphicSettings Class See Also Send Feedback
Sets the ElementId of the cut surface line pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public OverrideGraphicSettings SetCutLinePatternId(
    ElementId linePatternId
)
Visual Basic
Public Function SetCutLinePatternId ( _
    linePatternId As ElementId _
) As OverrideGraphicSettings
Visual C++
public:
OverrideGraphicSettings^ SetCutLinePatternId(
    ElementId^ linePatternId
)

Parameters

linePatternId
Type: Autodesk.Revit.DB..::..ElementId
ElementId of the cut surface line pattern for the override. InvalidElementId means no override is set.

Return Value

Reference to the changed object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

OverrideGraphicSettings Class


SetCutLineWeight Method

[image]

Revit 2024 API
OverrideGraphicSettings..::..SetCutLineWeight Method
OverrideGraphicSettings Class See Also Send Feedback
Sets the cut surface line weight.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public OverrideGraphicSettings SetCutLineWeight(
    int lineWeight
)
Visual Basic
Public Function SetCutLineWeight ( _
    lineWeight As Integer _
) As OverrideGraphicSettings
Visual C++
public:
OverrideGraphicSettings^ SetCutLineWeight(
    int lineWeight
)

Parameters

lineWeight
Type: System..::..Int32
Value of the cut surface line weight for the override. InvalidPenNumber means no override is set.

Return Value

Reference to the changed object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Line weight must be a positive integer less than 17 or invalidPenNumber.

See Also

OverrideGraphicSettings Class


SetDetailLevel Method

[image]

Revit 2024 API
OverrideGraphicSettings..::..SetDetailLevel Method
OverrideGraphicSettings Class See Also Send Feedback
Sets the detail level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public OverrideGraphicSettings SetDetailLevel(
    ViewDetailLevel detailLevel
)
Visual Basic
Public Function SetDetailLevel ( _
    detailLevel As ViewDetailLevel _
) As OverrideGraphicSettings
Visual C++
public:
OverrideGraphicSettings^ SetDetailLevel(
    ViewDetailLevel detailLevel
)

Parameters

detailLevel
Type: Autodesk.Revit.DB..::..ViewDetailLevel
Value of the detail level. ViewDetailLevel.Undefined means no override is set.

Return Value

Reference to the changed object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

OverrideGraphicSettings Class


SetHalftone Method

[image]

Revit 2024 API
OverrideGraphicSettings..::..SetHalftone Method
OverrideGraphicSettings Class See Also Send Feedback
Sets the halftone value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public OverrideGraphicSettings SetHalftone(
    bool halftone
)
Visual Basic
Public Function SetHalftone ( _
    halftone As Boolean _
) As OverrideGraphicSettings
Visual C++
public:
OverrideGraphicSettings^ SetHalftone(
    bool halftone
)

Parameters

halftone
Type: System..::..Boolean
True if the override displays in halftone, false otherwise.

Return Value

Reference to the changed object.

See Also

OverrideGraphicSettings Class


SetProjectionLineColor Method

[image]

Revit 2024 API
OverrideGraphicSettings..::..SetProjectionLineColor Method
OverrideGraphicSettings Class See Also Send Feedback
Sets the projection surface line color.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public OverrideGraphicSettings SetProjectionLineColor(
    Color color
)
Visual Basic
Public Function SetProjectionLineColor ( _
    color As Color _
) As OverrideGraphicSettings
Visual C++
public:
OverrideGraphicSettings^ SetProjectionLineColor(
    Color^ color
)

Parameters

color
Type: Autodesk.Revit.DB..::..Color
Value of the projection surface line color for the override. InvalidColorValue means no override is set.

Return Value

Reference to the changed object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

OverrideGraphicSettings Class


SetProjectionLinePatternId Method

[image]

Revit 2024 API
OverrideGraphicSettings..::..SetProjectionLinePatternId Method
OverrideGraphicSettings Class See Also Send Feedback
Sets the ElementId of the projection surface line pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public OverrideGraphicSettings SetProjectionLinePatternId(
    ElementId linePatternId
)
Visual Basic
Public Function SetProjectionLinePatternId ( _
    linePatternId As ElementId _
) As OverrideGraphicSettings
Visual C++
public:
OverrideGraphicSettings^ SetProjectionLinePatternId(
    ElementId^ linePatternId
)

Parameters

linePatternId
Type: Autodesk.Revit.DB..::..ElementId
ElementId of the projection surface line pattern for the override. InvalidElementId means no override is set.

Return Value

Reference to the changed object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

OverrideGraphicSettings Class


SetSurfaceBackgroundPatternColor Method

[image]

Revit 2024 API
OverrideGraphicSettings..::..SetSurfaceBackgroundPatternColor Method
OverrideGraphicSettings Class See Also Send Feedback
Sets the override color of the surface background pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public OverrideGraphicSettings SetSurfaceBackgroundPatternColor(
    Color color
)
Visual Basic
Public Function SetSurfaceBackgroundPatternColor ( _
    color As Color _
) As OverrideGraphicSettings
Visual C++
public:
OverrideGraphicSettings^ SetSurfaceBackgroundPatternColor(
    Color^ color
)

Parameters

color
Type: Autodesk.Revit.DB..::..Color
Value of the surface background color for the override. InvalidColorValue means no override is set.

Return Value

Reference to the changed object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

OverrideGraphicSettings Class


SetSurfaceBackgroundPatternId Method

[image]

Revit 2024 API
OverrideGraphicSettings..::..SetSurfaceBackgroundPatternId Method
OverrideGraphicSettings Class See Also Send Feedback
Sets the ElementId of the surface background pattern override. The fill pattern must be a drafting pattern. A value of InvalidElementId means no override is set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public OverrideGraphicSettings SetSurfaceBackgroundPatternId(
    ElementId fillPatternId
)
Visual Basic
Public Function SetSurfaceBackgroundPatternId ( _
    fillPatternId As ElementId _
) As OverrideGraphicSettings
Visual C++
public:
OverrideGraphicSettings^ SetSurfaceBackgroundPatternId(
    ElementId^ fillPatternId
)

Parameters

fillPatternId
Type: Autodesk.Revit.DB..::..ElementId
Value of the surface background fill pattern override.

Return Value

Reference to the changed object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

OverrideGraphicSettings Class


SetSurfaceBackgroundPatternVisible Method

[image]

Revit 2024 API
OverrideGraphicSettings..::..SetSurfaceBackgroundPatternVisible Method
OverrideGraphicSettings Class See Also Send Feedback
Sets the visibility of the surface background fill pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public OverrideGraphicSettings SetSurfaceBackgroundPatternVisible(
    bool fillPatternVisible
)
Visual Basic
Public Function SetSurfaceBackgroundPatternVisible ( _
    fillPatternVisible As Boolean _
) As OverrideGraphicSettings
Visual C++
public:
OverrideGraphicSettings^ SetSurfaceBackgroundPatternVisible(
    bool fillPatternVisible
)

Parameters

fillPatternVisible
Type: System..::..Boolean
Value of the visibility of the surface background fill pattern.

Return Value

Reference to the changed object.

See Also

OverrideGraphicSettings Class


SetSurfaceForegroundPatternId Method

[image]

Revit 2024 API
OverrideGraphicSettings..::..SetSurfaceForegroundPatternId Method
OverrideGraphicSettings Class See Also Send Feedback
Sets the ElementId of the surface foreground pattern override. The fill pattern must be a drafting pattern. A value of InvalidElementId means no override is set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public OverrideGraphicSettings SetSurfaceForegroundPatternId(
    ElementId fillPatternId
)
Visual Basic
Public Function SetSurfaceForegroundPatternId ( _
    fillPatternId As ElementId _
) As OverrideGraphicSettings
Visual C++
public:
OverrideGraphicSettings^ SetSurfaceForegroundPatternId(
    ElementId^ fillPatternId
)

Parameters

fillPatternId
Type: Autodesk.Revit.DB..::..ElementId
Value of the surface foreground fill pattern override.

Return Value

Reference to the changed object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

OverrideGraphicSettings Class


SetSurfaceTransparency Method

[image]

Revit 2024 API
OverrideGraphicSettings..::..SetSurfaceTransparency Method
OverrideGraphicSettings Class See Also Send Feedback
Sets the projection surface transparency.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public OverrideGraphicSettings SetSurfaceTransparency(
    int transparency
)
Visual Basic
Public Function SetSurfaceTransparency ( _
    transparency As Integer _
) As OverrideGraphicSettings
Visual C++
public:
OverrideGraphicSettings^ SetSurfaceTransparency(
    int transparency
)

Parameters

transparency
Type: System..::..Int32
Value of the transparency of the projection surface (0 = opaque, 100 = fully transparent).

Return Value

Reference to the changed object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Transparency must be greater than 0 and less than 100.

See Also

OverrideGraphicSettings Class


OverrideGraphicSettings Properties

[image] [image]

Revit 2024 API
OverrideGraphicSettings Properties
OverrideGraphicSettings Class See Also Send Feedback

The OverrideGraphicSettings type exposes the following members.

Properties

 | Name | Description
Public property | CutBackgroundPatternColor | The override color of the background pattern of cut faces.
Public property | CutBackgroundPatternId | The ElementId of the cut face background fill pattern override. A value of InvalidElementId means no override is set.
Public property | CutForegroundPatternColor | The override color of the foreground pattern of cut faces.
Public property | CutForegroundPatternId | The ElementId of the cut face foreground fill pattern override. A value of InvalidElementId means no override is set.
Public property | CutLineColor | Cut surface line color.
Public property | CutLinePatternId | ElementId of the cut surface line pattern.
Public property | CutLineWeight | Cut surface line weight.
Public property | DetailLevel | The detail level.
Public property | Halftone | Value of the halftone override.
 | InvalidPenNumber | The invalidPenNumber for clearing line weight overrides.
Public property | IsCutBackgroundPatternVisible | The visibility of the cut face background fill pattern.
Public property | IsCutForegroundPatternVisible | The visibility of the cut face foreground fill pattern.
Public property | IsSurfaceBackgroundPatternVisible | The visibility of the surface background fill pattern.
Public property | IsSurfaceForegroundPatternVisible | The visibility of the surface foreground fill pattern.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ProjectionLineColor | Projection surface line color.
Public property | ProjectionLinePatternId | Id of the projection surface line pattern.
Public property | ProjectionLineWeight | The projection surface line weight.
Public property | SurfaceBackgroundPatternColor | The override color of the surface background pattern.
Public property | SurfaceBackgroundPatternId | The ElementId of the surface background fill pattern override. A value of InvalidElementId means no override is set.
Public property | SurfaceForegroundPatternColor | The override color of the surface foreground pattern.
Public property | SurfaceForegroundPatternId | The ElementId of the surface foreground fill pattern override. A value of InvalidElementId means no override is set.
Public property | Transparency | Transparency of surfaces.

See Also

OverrideGraphicSettings Class


CutBackgroundPatternColor Property

[image]

Revit 2024 API
OverrideGraphicSettings..::..CutBackgroundPatternColor Property
OverrideGraphicSettings Class See Also Send Feedback
The override color of the background pattern of cut faces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public Color CutBackgroundPatternColor { get; }
Visual Basic
Public ReadOnly Property CutBackgroundPatternColor As Color
    Get
Visual C++
public:
property Color^ CutBackgroundPatternColor {
    Color^ get ();
}

See Also

OverrideGraphicSettings Class


CutForegroundPatternColor Property

[image]

Revit 2024 API
OverrideGraphicSettings..::..CutForegroundPatternColor Property
OverrideGraphicSettings Class See Also Send Feedback
The override color of the foreground pattern of cut faces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public Color CutForegroundPatternColor { get; }
Visual Basic
Public ReadOnly Property CutForegroundPatternColor As Color
    Get
Visual C++
public:
property Color^ CutForegroundPatternColor {
    Color^ get ();
}

See Also

OverrideGraphicSettings Class


CutLineColor Property

[image]

Revit 2024 API
OverrideGraphicSettings..::..CutLineColor Property
OverrideGraphicSettings Class See Also Send Feedback
Cut surface line color.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public Color CutLineColor { get; }
Visual Basic
Public ReadOnly Property CutLineColor As Color
    Get
Visual C++
public:
property Color^ CutLineColor {
    Color^ get ();
}

See Also

OverrideGraphicSettings Class


CutLinePatternId Property

[image]

Revit 2024 API
OverrideGraphicSettings..::..CutLinePatternId Property
OverrideGraphicSettings Class See Also Send Feedback
ElementId of the cut surface line pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ElementId CutLinePatternId { get; }
Visual Basic
Public ReadOnly Property CutLinePatternId As ElementId
    Get
Visual C++
public:
property ElementId^ CutLinePatternId {
    ElementId^ get ();
}

See Also

OverrideGraphicSettings Class


Halftone Property

[image]

Revit 2024 API
OverrideGraphicSettings..::..Halftone Property
OverrideGraphicSettings Class See Also Send Feedback
Value of the halftone override.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool Halftone { get; }
Visual Basic
Public ReadOnly Property Halftone As Boolean
    Get
Visual C++
public:
property bool Halftone {
    bool get ();
}

See Also

OverrideGraphicSettings Class


IsCutBackgroundPatternVisible Property

[image]

Revit 2024 API
OverrideGraphicSettings..::..IsCutBackgroundPatternVisible Property
OverrideGraphicSettings Class See Also Send Feedback
The visibility of the cut face background fill pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public bool IsCutBackgroundPatternVisible { get; }
Visual Basic
Public ReadOnly Property IsCutBackgroundPatternVisible As Boolean
    Get
Visual C++
public:
property bool IsCutBackgroundPatternVisible {
    bool get ();
}

See Also

OverrideGraphicSettings Class


IsCutForegroundPatternVisible Property

[image]

Revit 2024 API
OverrideGraphicSettings..::..IsCutForegroundPatternVisible Property
OverrideGraphicSettings Class See Also Send Feedback
The visibility of the cut face foreground fill pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public bool IsCutForegroundPatternVisible { get; }
Visual Basic
Public ReadOnly Property IsCutForegroundPatternVisible As Boolean
    Get
Visual C++
public:
property bool IsCutForegroundPatternVisible {
    bool get ();
}

See Also

OverrideGraphicSettings Class


IsSurfaceForegroundPatternVisible Property

[image]

Revit 2024 API
OverrideGraphicSettings..::..IsSurfaceForegroundPatternVisible Property
OverrideGraphicSettings Class See Also Send Feedback
The visibility of the surface foreground fill pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public bool IsSurfaceForegroundPatternVisible { get; }
Visual Basic
Public ReadOnly Property IsSurfaceForegroundPatternVisible As Boolean
    Get
Visual C++
public:
property bool IsSurfaceForegroundPatternVisible {
    bool get ();
}

See Also

OverrideGraphicSettings Class


IsValidObject Property

[image]

Revit 2024 API
OverrideGraphicSettings..::..IsValidObject Property
OverrideGraphicSettings Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

OverrideGraphicSettings Class


ProjectionLineColor Property

[image]

Revit 2024 API
OverrideGraphicSettings..::..ProjectionLineColor Property
OverrideGraphicSettings Class See Also Send Feedback
Projection surface line color.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public Color ProjectionLineColor { get; }
Visual Basic
Public ReadOnly Property ProjectionLineColor As Color
    Get
Visual C++
public:
property Color^ ProjectionLineColor {
    Color^ get ();
}

See Also

OverrideGraphicSettings Class


ProjectionLinePatternId Property

[image]

Revit 2024 API
OverrideGraphicSettings..::..ProjectionLinePatternId Property
OverrideGraphicSettings Class See Also Send Feedback
Id of the projection surface line pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ElementId ProjectionLinePatternId { get; }
Visual Basic
Public ReadOnly Property ProjectionLinePatternId As ElementId
    Get
Visual C++
public:
property ElementId^ ProjectionLinePatternId {
    ElementId^ get ();
}

See Also

OverrideGraphicSettings Class


ProjectionLineWeight Property

[image]

Revit 2024 API
OverrideGraphicSettings..::..ProjectionLineWeight Property
OverrideGraphicSettings Class See Also Send Feedback
The projection surface line weight.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public int ProjectionLineWeight { get; }
Visual Basic
Public ReadOnly Property ProjectionLineWeight As Integer
    Get
Visual C++
public:
property int ProjectionLineWeight {
    int get ();
}

See Also

OverrideGraphicSettings Class


SurfaceBackgroundPatternColor Property

[image]

Revit 2024 API
OverrideGraphicSettings..::..SurfaceBackgroundPatternColor Property
OverrideGraphicSettings Class See Also Send Feedback
The override color of the surface background pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public Color SurfaceBackgroundPatternColor { get; }
Visual Basic
Public ReadOnly Property SurfaceBackgroundPatternColor As Color
    Get
Visual C++
public:
property Color^ SurfaceBackgroundPatternColor {
    Color^ get ();
}

See Also

OverrideGraphicSettings Class


SurfaceForegroundPatternColor Property

[image]

Revit 2024 API
OverrideGraphicSettings..::..SurfaceForegroundPatternColor Property
OverrideGraphicSettings Class See Also Send Feedback
The override color of the surface foreground pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public Color SurfaceForegroundPatternColor { get; }
Visual Basic
Public ReadOnly Property SurfaceForegroundPatternColor As Color
    Get
Visual C++
public:
property Color^ SurfaceForegroundPatternColor {
    Color^ get ();
}

See Also

OverrideGraphicSettings Class


Transparency Property

[image]

Revit 2024 API
OverrideGraphicSettings..::..Transparency Property
OverrideGraphicSettings Class See Also Send Feedback
Transparency of surfaces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public int Transparency { get; }
Visual Basic
Public ReadOnly Property Transparency As Integer
    Get
Visual C++
public:
property int Transparency {
    int get ();
}

See Also

OverrideGraphicSettings Class


PageOrientationType Enumeration

[image]

Revit 2024 API
PageOrientationType Enumeration
See Also Send Feedback
An enumerated type listing all Page Orientation types of Print Setting

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum PageOrientationType
Visual Basic
Public Enumeration PageOrientationType
Visual C++
public enum class PageOrientationType

Members

Member name | Description
Portrait | The type of Page Orientation is Portrait
Landscape | The type of Page Orientation is Landscape
Auto | Auto Page Orientation

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


Panel Class

[image]

Revit 2024 API
Panel Class
Members See Also Send Feedback
This object represents a curtain panel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class Panel : FamilyInstance
Visual Basic
Public Class Panel _
    Inherits FamilyInstance
Visual C++
public ref class Panel : public FamilyInstance

Remarks

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..Instance
Autodesk.Revit.DB..::..FamilyInstance
Autodesk.Revit.DB..::..Panel

See Also

Panel Members


Panel Members

[image] [image]

Revit 2024 API
Panel Members
Panel Class Methods Properties See Also Send Feedback

The Panel type exposes the following members.

Methods

 | Name | Description
Public method | AddCoping | Adds a coping (cut) to a steel beam. (Inherited from FamilyInstance.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | FindHostPanel | Finds the id of the host panel (i.e., wall) associated with this panel. If a host panel is present, then it is displayed instead of the curtain panel.
Public method | flipFacing | The orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true. (Inherited from FamilyInstance.)
Public method | FlipFromToRoom | Flips the settings of "From Room" and "To Room" for the door or window instance. (Inherited from FamilyInstance.)
Public method | flipHand | The orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true. (Inherited from FamilyInstance.)
Public method | GetCopingIds | Lists the elements currently used as coping cutters for this element. (Inherited from FamilyInstance.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetFamilyPointPlacementReferences | Returns the Point Placement References for the Family Instance. (Inherited from FamilyInstance.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetOriginalGeometry | Returns the original geometry of the instance, before the instance is modified by joins, cuts, coping, extensions, or other post-processing. (Inherited from FamilyInstance.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetReferenceByName | Gets the family instance reference corresponding to the named reference plane in the instance's family. (Inherited from FamilyInstance.)
Public method | GetReferenceName | Gets the name of the reference plane in the family corresponding to the given family instance reference. (Inherited from FamilyInstance.)
Public method | GetReferences | Gets family instance references corresponding to the reference planes or reference lines of the given reference type in the instance's family. (Inherited from FamilyInstance.)
Public method | GetReferenceType | Gets the type of the reference plane or reference line in the instance's family corresponding to the given family instance reference. (Inherited from FamilyInstance.)
Public method | GetRefGridLines | This method is used to get the reference gridlines.
Public method | GetSpatialElementCalculationPoint | Gets the location of the calculation point for this instance. (Inherited from FamilyInstance.)
Public method | GetSpatialElementFromToCalculationPoints | Gets the locations for the calculation points for this instance. (Inherited from FamilyInstance.)
Public method | GetSubComponentIds | Gets the sub component ElementIds of the current family instance. (Inherited from FamilyInstance.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetSweptProfile | Gets the object that describes the profile that is swept along the driving curve for this instance. (Inherited from FamilyInstance.)
Public method | GetTotalTransform | Gets the total transform, which includes the true north transform for instances like import instances. (Inherited from Instance.)
Public method | GetTransform | Gets the transform of the instance. (Inherited from Instance.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasModifiedGeometry | Identifies if the geometry of this FamilyInstance has been modified from the automatically generated default. (Inherited from FamilyInstance.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasSweptProfile | Indicates if this instance can be represented as a swept profile. (Inherited from FamilyInstance.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | RemoveCoping | Removes a coping (cut) from a steel beam. (Inherited from FamilyInstance.)
Public method | rotate | The family instance will be flipped by 180 degrees. If it can not be rotated, return false, otherwise return true. (Inherited from FamilyInstance.)
Public method | SetCopingIds | Specifies the set of coping cutters on this element. (Inherited from FamilyInstance.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | Split | Splits the family instance element at a point on its defining curve. (Inherited from FamilyInstance.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanFlipFacing | Property to test whether the orientation of family instance facing can be flipped. (Inherited from FamilyInstance.)
Public property | CanFlipHand | Property to test whether the orientation of family instance hand can be flipped. (Inherited from FamilyInstance.)
Public property | CanFlipWorkPlane | Identifies if the instance can flip its work plane. (Inherited from FamilyInstance.)
Public property | CanRotate | Property to test whether the family instance can be rotated by 180 degrees. (Inherited from FamilyInstance.)
Public property | CanSplit | Identifies whether a particular family instance can be split at a point on it's defining curve (by Split(Double)). (Inherited from FamilyInstance.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | ExtensionUtility | Property to check whether the instance can be extended and return the interface for extension operation. (Inherited from FamilyInstance.)
Public property | FacingFlipped | Property to test whether the orientation of family instance facing is flipped. (Inherited from FamilyInstance.)
Public property | FacingOrientation | Property to get the orientation of family instance facing. (Inherited from FamilyInstance.)
Public property | FromRoom | The "From Room" set for the door or window in the last phase of the project. (Inherited from FamilyInstance.)
Public property | FromRoom[([( Phase])]) | (Inherited from FamilyInstance.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | HandFlipped | Property to test whether the orientation of family instance hand is flipped. (Inherited from FamilyInstance.)
Public property | HandOrientation | Property to get the orientation of family instance hand. (Inherited from FamilyInstance.)
Public property | HasSpatialElementCalculationPoint | Identifies if this instance has a single SpatialElementCalculationPoint used as the search point for Revit to identify if the instance is inside a room or space. (Inherited from FamilyInstance.)
Public property | HasSpatialElementFromToCalculationPoints | Identifies if this instance has a pair of SpatialElementCalculationPoints used as the search points for Revit to identify if the instance lies between up to two rooms or spaces. (Inherited from FamilyInstance.)
Public property | Host | If the instance is contained within another element, this property returns the containing element. An instance that is face hosted will return the element containing the face. (Inherited from FamilyInstance.)
Public property | HostFace | Property to get the reference to the host face of family instance. (Inherited from FamilyInstance.)
Public property | HostParameter | If the instance is hosted by a wall, this property returns the parameter value of the insertion point of the instance along the wall's location curve, as long as the family of the instance isn't work plane based. (Inherited from FamilyInstance.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | Invisible | Property to test whether the family instance is invisible. (Inherited from FamilyInstance.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsSlantedColumn | Indicates if the family instance is a slanted column. (Inherited from FamilyInstance.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | IsWorkPlaneFlipped | Identifies if the instance's work plane is flipped. (Inherited from FamilyInstance.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an instance within project. (Inherited from FamilyInstance.)
Public property | Lockable | This property is used to know whether a panel can be locked.
Public property | MEPModel | Retrieves the MEP model for the family instance. (Inherited from FamilyInstance.)
Public property | Mirrored | Property to test whether the family instance is mirrored. (only one axis is flipped) (Inherited from FamilyInstance.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | PanelType | The Panel style of this Panel.
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Room | The room in which the instance is located (during the last phase of the project). (Inherited from FamilyInstance.)
Public property | Room[([( Phase])]) | (Inherited from FamilyInstance.)
Public property | Space | The space in which the instance is located (during the last phase of the project). (Inherited from FamilyInstance.)
Public property | Space[([( Phase])]) | (Inherited from FamilyInstance.)
Public property | StructuralMaterialId | Identifies the material that defines the instance's structural analysis properties. (Inherited from FamilyInstance.)
Public property | StructuralMaterialType | This property returns the physical material from which the instance is made. (Inherited from FamilyInstance.)
Public property | StructuralType | Provides the primary structural type of the instance, such as beam or column etc. (Inherited from FamilyInstance.)
Public property | StructuralUsage | Provides the primary structural usage of the instance, such as brace, girder etc. (Inherited from FamilyInstance.)
Public property | SuperComponent | Property to get the super component of current family instance. (Inherited from FamilyInstance.)
Public property | Symbol | Returns or changes the FamilySymbol object that represents the type of the instance. (Inherited from FamilyInstance.)
Public property | ToRoom | The "To Room" set for the door or window in the last phase of the project. (Inherited from FamilyInstance.)
Public property | ToRoom[([( Phase])]) | (Inherited from FamilyInstance.)
Public property | Transform | This property is used to find the transform of a curtain panel within project.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Panel Class


Panel Methods

[image] [image]

Revit 2024 API
Panel Methods
Panel Class See Also Send Feedback

The Panel type exposes the following members.

Methods

 | Name | Description
Public method | AddCoping | Adds a coping (cut) to a steel beam. (Inherited from FamilyInstance.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | FindHostPanel | Finds the id of the host panel (i.e., wall) associated with this panel. If a host panel is present, then it is displayed instead of the curtain panel.
Public method | flipFacing | The orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true. (Inherited from FamilyInstance.)
Public method | FlipFromToRoom | Flips the settings of "From Room" and "To Room" for the door or window instance. (Inherited from FamilyInstance.)
Public method | flipHand | The orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true. (Inherited from FamilyInstance.)
Public method | GetCopingIds | Lists the elements currently used as coping cutters for this element. (Inherited from FamilyInstance.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetFamilyPointPlacementReferences | Returns the Point Placement References for the Family Instance. (Inherited from FamilyInstance.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetOriginalGeometry | Returns the original geometry of the instance, before the instance is modified by joins, cuts, coping, extensions, or other post-processing. (Inherited from FamilyInstance.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetReferenceByName | Gets the family instance reference corresponding to the named reference plane in the instance's family. (Inherited from FamilyInstance.)
Public method | GetReferenceName | Gets the name of the reference plane in the family corresponding to the given family instance reference. (Inherited from FamilyInstance.)
Public method | GetReferences | Gets family instance references corresponding to the reference planes or reference lines of the given reference type in the instance's family. (Inherited from FamilyInstance.)
Public method | GetReferenceType | Gets the type of the reference plane or reference line in the instance's family corresponding to the given family instance reference. (Inherited from FamilyInstance.)
Public method | GetRefGridLines | This method is used to get the reference gridlines.
Public method | GetSpatialElementCalculationPoint | Gets the location of the calculation point for this instance. (Inherited from FamilyInstance.)
Public method | GetSpatialElementFromToCalculationPoints | Gets the locations for the calculation points for this instance. (Inherited from FamilyInstance.)
Public method | GetSubComponentIds | Gets the sub component ElementIds of the current family instance. (Inherited from FamilyInstance.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetSweptProfile | Gets the object that describes the profile that is swept along the driving curve for this instance. (Inherited from FamilyInstance.)
Public method | GetTotalTransform | Gets the total transform, which includes the true north transform for instances like import instances. (Inherited from Instance.)
Public method | GetTransform | Gets the transform of the instance. (Inherited from Instance.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasModifiedGeometry | Identifies if the geometry of this FamilyInstance has been modified from the automatically generated default. (Inherited from FamilyInstance.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasSweptProfile | Indicates if this instance can be represented as a swept profile. (Inherited from FamilyInstance.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | RemoveCoping | Removes a coping (cut) from a steel beam. (Inherited from FamilyInstance.)
Public method | rotate | The family instance will be flipped by 180 degrees. If it can not be rotated, return false, otherwise return true. (Inherited from FamilyInstance.)
Public method | SetCopingIds | Specifies the set of coping cutters on this element. (Inherited from FamilyInstance.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | Split | Splits the family instance element at a point on its defining curve. (Inherited from FamilyInstance.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Panel Class


FindHostPanel Method

[image]

Revit 2024 API
Panel..::..FindHostPanel Method
Panel Class See Also Send Feedback
Finds the id of the host panel (i.e., wall) associated with this panel. If a host panel is present, then it is displayed instead of the curtain panel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public ElementId FindHostPanel()
Visual Basic
Public Function FindHostPanel As ElementId
Visual C++
public:
ElementId^ FindHostPanel()

Return Value

Element id of the host panel associated with this panel. Otherwise, InvalidElementId is returned

See Also

Panel Class


GetRefGridLines Method

[image]

Revit 2024 API
Panel..::..GetRefGridLines Method
Panel Class See Also Send Feedback
This method is used to get the reference gridlines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void GetRefGridLines(
    ref ElementId uGridLineId,
    ref ElementId vGridLineId
)
Visual Basic
Public Sub GetRefGridLines ( _
    ByRef uGridLineId As ElementId, _
    ByRef vGridLineId As ElementId _
)
Visual C++
public:
void GetRefGridLines(
    ElementId^% uGridLineId,
    ElementId^% vGridLineId
)

Parameters

uGridLineId
Type: Autodesk.Revit.DB..::..ElementId %
vGridLineId
Type: Autodesk.Revit.DB..::..ElementId %

See Also

Panel Class


Panel Properties

[image] [image]

Revit 2024 API
Panel Properties
Panel Class See Also Send Feedback

The Panel type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanFlipFacing | Property to test whether the orientation of family instance facing can be flipped. (Inherited from FamilyInstance.)
Public property | CanFlipHand | Property to test whether the orientation of family instance hand can be flipped. (Inherited from FamilyInstance.)
Public property | CanFlipWorkPlane | Identifies if the instance can flip its work plane. (Inherited from FamilyInstance.)
Public property | CanRotate | Property to test whether the family instance can be rotated by 180 degrees. (Inherited from FamilyInstance.)
Public property | CanSplit | Identifies whether a particular family instance can be split at a point on it's defining curve (by Split(Double)). (Inherited from FamilyInstance.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | ExtensionUtility | Property to check whether the instance can be extended and return the interface for extension operation. (Inherited from FamilyInstance.)
Public property | FacingFlipped | Property to test whether the orientation of family instance facing is flipped. (Inherited from FamilyInstance.)
Public property | FacingOrientation | Property to get the orientation of family instance facing. (Inherited from FamilyInstance.)
Public property | FromRoom | The "From Room" set for the door or window in the last phase of the project. (Inherited from FamilyInstance.)
Public property | FromRoom[([( Phase])]) | (Inherited from FamilyInstance.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | HandFlipped | Property to test whether the orientation of family instance hand is flipped. (Inherited from FamilyInstance.)
Public property | HandOrientation | Property to get the orientation of family instance hand. (Inherited from FamilyInstance.)
Public property | HasSpatialElementCalculationPoint | Identifies if this instance has a single SpatialElementCalculationPoint used as the search point for Revit to identify if the instance is inside a room or space. (Inherited from FamilyInstance.)
Public property | HasSpatialElementFromToCalculationPoints | Identifies if this instance has a pair of SpatialElementCalculationPoints used as the search points for Revit to identify if the instance lies between up to two rooms or spaces. (Inherited from FamilyInstance.)
Public property | Host | If the instance is contained within another element, this property returns the containing element. An instance that is face hosted will return the element containing the face. (Inherited from FamilyInstance.)
Public property | HostFace | Property to get the reference to the host face of family instance. (Inherited from FamilyInstance.)
Public property | HostParameter | If the instance is hosted by a wall, this property returns the parameter value of the insertion point of the instance along the wall's location curve, as long as the family of the instance isn't work plane based. (Inherited from FamilyInstance.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | Invisible | Property to test whether the family instance is invisible. (Inherited from FamilyInstance.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsSlantedColumn | Indicates if the family instance is a slanted column. (Inherited from FamilyInstance.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | IsWorkPlaneFlipped | Identifies if the instance's work plane is flipped. (Inherited from FamilyInstance.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an instance within project. (Inherited from FamilyInstance.)
Public property | Lockable | This property is used to know whether a panel can be locked.
Public property | MEPModel | Retrieves the MEP model for the family instance. (Inherited from FamilyInstance.)
Public property | Mirrored | Property to test whether the family instance is mirrored. (only one axis is flipped) (Inherited from FamilyInstance.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | PanelType | The Panel style of this Panel.
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Room | The room in which the instance is located (during the last phase of the project). (Inherited from FamilyInstance.)
Public property | Room[([( Phase])]) | (Inherited from FamilyInstance.)
Public property | Space | The space in which the instance is located (during the last phase of the project). (Inherited from FamilyInstance.)
Public property | Space[([( Phase])]) | (Inherited from FamilyInstance.)
Public property | StructuralMaterialId | Identifies the material that defines the instance's structural analysis properties. (Inherited from FamilyInstance.)
Public property | StructuralMaterialType | This property returns the physical material from which the instance is made. (Inherited from FamilyInstance.)
Public property | StructuralType | Provides the primary structural type of the instance, such as beam or column etc. (Inherited from FamilyInstance.)
Public property | StructuralUsage | Provides the primary structural usage of the instance, such as brace, girder etc. (Inherited from FamilyInstance.)
Public property | SuperComponent | Property to get the super component of current family instance. (Inherited from FamilyInstance.)
Public property | Symbol | Returns or changes the FamilySymbol object that represents the type of the instance. (Inherited from FamilyInstance.)
Public property | ToRoom | The "To Room" set for the door or window in the last phase of the project. (Inherited from FamilyInstance.)
Public property | ToRoom[([( Phase])]) | (Inherited from FamilyInstance.)
Public property | Transform | This property is used to find the transform of a curtain panel within project.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Panel Class


FromRoom Property

[image] [image]

Revit 2024 API
Panel..::..FromRoom Property
Panel Class See Also Send Feedback
The "From Room" set for the door or window.

Overload List

 | Name | Description
Public property | FromRoom | The "From Room" set for the door or window in the last phase of the project. (Inherited from FamilyInstance.)
Public property | FromRoom[([( Phase])]) | (Inherited from FamilyInstance.)

See Also

Panel Class
Panel Members


PanelType Property

[image]

Revit 2024 API
Panel..::..PanelType Property
Panel Class See Also Send Feedback
The Panel style of this Panel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public PanelType PanelType { get; set; }
Visual Basic
Public Property PanelType As PanelType
    Get
    Set
Visual C++
public:
property PanelType^ PanelType {
    PanelType^ get ();
    void set (PanelType^ value);
}

Remarks

The Symbol property can be used to retrieve the kind of the panel. This property can also be used to change the type of a panel by setting it to a different type. All the panel types in the project can be found using the Document.CurtainPanelTypes property.

See Also

Panel Class


Parameter Property

[image] [image]

Revit 2024 API
Panel..::..Parameter Property
Panel Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Panel Class
Panel Members


Room Property

[image] [image]

Revit 2024 API
Panel..::..Room Property
Panel Class See Also Send Feedback
The room in which the instance is located.

Overload List

 | Name | Description
Public property | Room | The room in which the instance is located (during the last phase of the project). (Inherited from FamilyInstance.)
Public property | Room[([( Phase])]) | (Inherited from FamilyInstance.)

See Also

Panel Class
Panel Members


Space Property

[image] [image]

Revit 2024 API
Panel..::..Space Property
Panel Class See Also Send Feedback
The space in which the instance is located.

Overload List

 | Name | Description
Public property | Space | The space in which the instance is located (during the last phase of the project). (Inherited from FamilyInstance.)
Public property | Space[([( Phase])]) | (Inherited from FamilyInstance.)

See Also

Panel Class
Panel Members


Transform Property

[image]

Revit 2024 API
Panel..::..Transform Property
Panel Class See Also Send Feedback
This property is used to find the transform of a curtain panel within project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Transform Transform { get; }
Visual Basic
Public ReadOnly Property Transform As Transform
    Get
Visual C++
public:
property Transform^ Transform {
    Transform^ get ();
}

Remarks

The Transform property returns a Autodesk::Revit::DB::Transform object that can be used to find the transfer matrix of a curtain panel within the project.

See Also

Panel Class


PanelType Class

[image]

Revit 2024 API
PanelType Class
Members See Also Send Feedback
An object that represents a curtain panel type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class PanelType : FamilySymbol
Visual Basic
Public Class PanelType _
    Inherits FamilySymbol
Visual C++
public ref class PanelType : public FamilySymbol

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..InsertableObject
Autodesk.Revit.DB..::..FamilySymbol
Autodesk.Revit.DB..::..PanelType

See Also

PanelType Members


PanelType Members

[image] [image]

Revit 2024 API
PanelType Members
PanelType Class Methods Properties See Also Send Feedback

The PanelType type exposes the following members.

Methods

 | Name | Description
Public method | Activate | Activates the symbol to ensure that its geometry is accessible. (Inherited from FamilySymbol.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveStructuralSection | Identifies if this FamilySymbol can have a structural section. (Inherited from FamilySymbol.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetFamilyPointLocations | Returns the Point Locations for the Family Symbol. (Inherited from FamilySymbol.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetStructuralSection | Gets the structural section from element. (Inherited from FamilySymbol.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetThermalProperties | Gets the thermal properties for the given FamilySymbol. (Inherited from FamilySymbol.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasThermalProperties | Identifies if this FamilySymbol can include thermal properties. (Inherited from FamilySymbol.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetStructuralSection | Sets the structural section in element. (Inherited from FamilySymbol.)
Public method | SetThermalProperties | Sets the thermal properties for the given FamilySymbol. (Inherited from FamilySymbol.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Family | The Family object to which the symbol belongs. (Inherited from FamilySymbol.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsActive | Identifies whether the symbol is active. (Inherited from FamilySymbol.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | StructuralMaterialType | This property returns the physical material from which the type is made. (Inherited from FamilySymbol.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PanelType Class


PanelType Properties

[image] [image]

Revit 2024 API
PanelType Properties
PanelType Class See Also Send Feedback

The PanelType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Family | The Family object to which the symbol belongs. (Inherited from FamilySymbol.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsActive | Identifies whether the symbol is active. (Inherited from FamilySymbol.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | StructuralMaterialType | This property returns the physical material from which the type is made. (Inherited from FamilySymbol.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PanelType Class


Parameter Property

[image] [image]

Revit 2024 API
PanelType..::..Parameter Property
PanelType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

PanelType Class
PanelType Members


PanelTypeSet Class

[image]

Revit 2024 API
PanelTypeSet Class
Members See Also Send Feedback
A set that contains panel types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class PanelTypeSet : APIObject,
    IEnumerable
Visual Basic
Public Class PanelTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class PanelTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..PanelTypeSet

See Also

PanelTypeSet Members


PanelTypeSet Members

[image] [image]

Revit 2024 API
PanelTypeSet Members
PanelTypeSet Class Constructors Methods Properties See Also Send Feedback

The PanelTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | PanelTypeSet | Initializes a new instance of the PanelTypeSet class

Methods

 | Name | Description
Public method | Clear | Removes every panel type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a panel type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified panel type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified panel type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of panel types that are in the set.

See Also

PanelTypeSet Class


PanelTypeSet Methods

[image] [image]

Revit 2024 API
PanelTypeSet Methods
PanelTypeSet Class See Also Send Feedback

The PanelTypeSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every panel type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a panel type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified panel type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified panel type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PanelTypeSet Class


Clear Method

[image]

Revit 2024 API
PanelTypeSet..::..Clear Method
PanelTypeSet Class See Also Send Feedback
Removes every panel type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

PanelTypeSet Class


Erase Method

[image]

Revit 2024 API
PanelTypeSet..::..Erase Method
PanelTypeSet Class See Also Send Feedback
Removes a specified panel type from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Erase(
    PanelType item
)
Visual Basic
Public Overridable Function Erase ( _
    item As PanelType _
) As Integer
Visual C++
public:
virtual int Erase(
    PanelType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..PanelType
The panel type to be erased.

Return Value

The number of panel types that were erased from the set.

See Also

PanelTypeSet Class


GetEnumerator Method

[image]

Revit 2024 API
PanelTypeSet..::..GetEnumerator Method
PanelTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

PanelTypeSet Class


Insert Method

[image]

Revit 2024 API
PanelTypeSet..::..Insert Method
PanelTypeSet Class See Also Send Feedback
Insert the specified panel type into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool Insert(
    PanelType item
)
Visual Basic
Public Overridable Function Insert ( _
    item As PanelType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    PanelType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..PanelType
The panel type to be inserted into the set.

Return Value

Returns whether the panel type was inserted into the set.

See Also

PanelTypeSet Class


ReverseIterator Method

[image]

Revit 2024 API
PanelTypeSet..::..ReverseIterator Method
PanelTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual PanelTypeSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As PanelTypeSetIterator
Visual C++
public:
virtual PanelTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

PanelTypeSet Class


PanelTypeSet Properties

[image] [image]

Revit 2024 API
PanelTypeSet Properties
PanelTypeSet Class See Also Send Feedback

The PanelTypeSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of panel types that are in the set.

See Also

PanelTypeSet Class


PanelTypeSetIterator Class

[image]

Revit 2024 API
PanelTypeSetIterator Class
Members See Also Send Feedback
An iterator to a panel type set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public abstract class PanelTypeSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class PanelTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class PanelTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..PanelTypeSetIterator

See Also

PanelTypeSetIterator Members


PanelTypeSetIterator Members

[image] [image]

Revit 2024 API
PanelTypeSetIterator Members
PanelTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The PanelTypeSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | PanelTypeSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PanelTypeSetIterator Class


PanelTypeSetIterator Methods

[image] [image]

Revit 2024 API
PanelTypeSetIterator Methods
PanelTypeSetIterator Class See Also Send Feedback

The PanelTypeSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PanelTypeSetIterator Class


Reset Method

[image]

Revit 2024 API
PanelTypeSetIterator..::..Reset Method
PanelTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

PanelTypeSetIterator Class


Current Property

[image]

Revit 2024 API
PanelTypeSetIterator..::..Current Property
PanelTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

PanelTypeSetIterator Class


PaperPlacementType Enumeration

[image]

Revit 2024 API
PaperPlacementType Enumeration
See Also Send Feedback
An enumerated type listing all Paper Placement types of Print Setting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum PaperPlacementType
Visual Basic
Public Enumeration PaperPlacementType
Visual C++
public enum class PaperPlacementType

Members

Member name | Description
Center | The type of Paper Placement is Center.
LowerLeft | The type of Paper Placement is LowerLeft.
Margins | The type of Paper Placement is Margins. It's obsolete, use LowerLeft instead.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


PaperSize Class

[image]

Revit 2024 API
PaperSize Class
Members See Also Send Feedback
An object that represents a Paper Size of Print Setup within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class PaperSize : APIObject
Visual Basic
Public Class PaperSize _
    Inherits APIObject
Visual C++
public ref class PaperSize : public APIObject

Remarks

This object derived from the APIObject base object.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..PaperSize

See Also

PaperSize Members


PaperSize Members

[image] [image]

Revit 2024 API
PaperSize Members
PaperSize Class Methods Properties See Also Send Feedback

The PaperSize type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Retrieve the paper size name of current project.

See Also

PaperSize Class


PaperSize Methods

[image] [image]

Revit 2024 API
PaperSize Methods
PaperSize Class See Also Send Feedback

The PaperSize type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PaperSize Class


Name Property

[image]

Revit 2024 API
PaperSize..::..Name Property
PaperSize Class See Also Send Feedback
Retrieve the paper size name of current project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

PaperSize Class


PaperSizeSet Class

[image]

Revit 2024 API
PaperSizeSet Class
Members See Also Send Feedback
A set that can contain any number of paper size objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class PaperSizeSet : APIObject,
    IEnumerable
Visual Basic
Public Class PaperSizeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class PaperSizeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..PaperSizeSet

See Also

PaperSizeSet Members


PaperSizeSet Members

[image] [image]

Revit 2024 API
PaperSizeSet Members
PaperSizeSet Class Constructors Methods Properties See Also Send Feedback

The PaperSizeSet type exposes the following members.

Constructors

 | Name | Description
Public method | PaperSizeSet | Initializes a new instance of the PaperSizeSet class

Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of an item within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified object from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

PaperSizeSet Class


Clear Method

[image]

Revit 2024 API
PaperSizeSet..::..Clear Method
PaperSizeSet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

PaperSizeSet Class


Contains Method

[image]

Revit 2024 API
PaperSizeSet..::..Contains Method
PaperSizeSet Class See Also Send Feedback
Tests for the existence of an item within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool Contains(
    PaperSize item
)
Visual Basic
Public Overridable Function Contains ( _
    item As PaperSize _
) As Boolean
Visual C++
public:
virtual bool Contains(
    PaperSize^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..PaperSize
The item to be searched for.

Return Value

The Contains method returns True if the item is within the set, otherwise False.

See Also

PaperSizeSet Class


Erase Method

[image]

Revit 2024 API
PaperSizeSet..::..Erase Method
PaperSizeSet Class See Also Send Feedback
Removes a specified object from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Erase(
    PaperSize item
)
Visual Basic
Public Overridable Function Erase ( _
    item As PaperSize _
) As Integer
Visual C++
public:
virtual int Erase(
    PaperSize^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..PaperSize
The item to be erased.

Return Value

The number of items that were erased from the set.

See Also

PaperSizeSet Class


ForwardIterator Method

[image]

Revit 2024 API
PaperSizeSet..::..ForwardIterator Method
PaperSizeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual PaperSizeSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As PaperSizeSetIterator
Visual C++
public:
virtual PaperSizeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

PaperSizeSet Class


GetEnumerator Method

[image]

Revit 2024 API
PaperSizeSet..::..GetEnumerator Method
PaperSizeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

PaperSizeSet Class


Insert Method

[image]

Revit 2024 API
PaperSizeSet..::..Insert Method
PaperSizeSet Class See Also Send Feedback
Insert the specified item into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool Insert(
    PaperSize item
)
Visual Basic
Public Overridable Function Insert ( _
    item As PaperSize _
) As Boolean
Visual C++
public:
virtual bool Insert(
    PaperSize^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..PaperSize
The item to be inserted into the set.

Return Value

Returns whether the item was inserted into the set.

See Also

PaperSizeSet Class


ReverseIterator Method

[image]

Revit 2024 API
PaperSizeSet..::..ReverseIterator Method
PaperSizeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual PaperSizeSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As PaperSizeSetIterator
Visual C++
public:
virtual PaperSizeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

PaperSizeSet Class


PaperSizeSet Properties

[image] [image]

Revit 2024 API
PaperSizeSet Properties
PaperSizeSet Class See Also Send Feedback

The PaperSizeSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

PaperSizeSet Class


IsEmpty Property

[image]

Revit 2024 API
PaperSizeSet..::..IsEmpty Property
PaperSizeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

PaperSizeSet Class


PaperSizeSetIterator Class

[image]

Revit 2024 API
PaperSizeSetIterator Class
Members See Also Send Feedback
An iterator to a set of paper size objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public abstract class PaperSizeSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class PaperSizeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class PaperSizeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..PaperSizeSetIterator

See Also

PaperSizeSetIterator Members


PaperSizeSetIterator Members

[image] [image]

Revit 2024 API
PaperSizeSetIterator Members
PaperSizeSetIterator Class Constructors Methods Properties See Also Send Feedback

The PaperSizeSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | PaperSizeSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PaperSizeSetIterator Class


PaperSizeSetIterator Constructor

[image]

Revit 2024 API
PaperSizeSetIterator Constructor
PaperSizeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public PaperSizeSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
PaperSizeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PaperSizeSetIterator Class


PaperSizeSetIterator Methods

[image] [image]

Revit 2024 API
PaperSizeSetIterator Methods
PaperSizeSetIterator Class See Also Send Feedback

The PaperSizeSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PaperSizeSetIterator Class


MoveNext Method

[image]

Revit 2024 API
PaperSizeSetIterator..::..MoveNext Method
PaperSizeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

PaperSizeSetIterator Class


Current Property

[image]

Revit 2024 API
PaperSizeSetIterator..::..Current Property
PaperSizeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

PaperSizeSetIterator Class


PaperSource Class

[image]

Revit 2024 API
PaperSource Class
Members See Also Send Feedback
An object that represents a Paper Source of Print Setup within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class PaperSource : APIObject
Visual Basic
Public Class PaperSource _
    Inherits APIObject
Visual C++
public ref class PaperSource : public APIObject

Remarks

This object derived from the APIObject base object.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..PaperSource

See Also

PaperSource Members


PaperSource Members

[image] [image]

Revit 2024 API
PaperSource Members
PaperSource Class Methods Properties See Also Send Feedback

The PaperSource type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Retrieve the paper source name of current project.

See Also

PaperSource Class


PaperSource Methods

[image] [image]

Revit 2024 API
PaperSource Methods
PaperSource Class See Also Send Feedback

The PaperSource type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PaperSource Class


PaperSource Properties

[image] [image]

Revit 2024 API
PaperSource Properties
PaperSource Class See Also Send Feedback

The PaperSource type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Retrieve the paper source name of current project.

See Also

PaperSource Class


Name Property

[image]

Revit 2024 API
PaperSource..::..Name Property
PaperSource Class See Also Send Feedback
Retrieve the paper source name of current project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

PaperSource Class


PaperSourceSet Constructor

[image]

Revit 2024 API
PaperSourceSet Constructor
PaperSourceSet Class See Also Send Feedback
Initializes a new instance of the PaperSourceSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public PaperSourceSet()
Visual Basic
Public Sub New
Visual C++
public:
PaperSourceSet()

See Also

PaperSourceSet Class


PaperSourceSet Methods

[image] [image]

Revit 2024 API
PaperSourceSet Methods
PaperSourceSet Class See Also Send Feedback

The PaperSourceSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of an item within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified object from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PaperSourceSet Class


Contains Method

[image]

Revit 2024 API
PaperSourceSet..::..Contains Method
PaperSourceSet Class See Also Send Feedback
Tests for the existence of an item within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool Contains(
    PaperSource item
)
Visual Basic
Public Overridable Function Contains ( _
    item As PaperSource _
) As Boolean
Visual C++
public:
virtual bool Contains(
    PaperSource^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..PaperSource
The item to be searched for.

Return Value

The Contains method returns True if the item is within the set, otherwise False.

See Also

PaperSourceSet Class


Erase Method

[image]

Revit 2024 API
PaperSourceSet..::..Erase Method
PaperSourceSet Class See Also Send Feedback
Removes a specified object from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Erase(
    PaperSource item
)
Visual Basic
Public Overridable Function Erase ( _
    item As PaperSource _
) As Integer
Visual C++
public:
virtual int Erase(
    PaperSource^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..PaperSource
The item to be erased.

Return Value

The number of items that were erased from the set.

See Also

PaperSourceSet Class


ForwardIterator Method

[image]

Revit 2024 API
PaperSourceSet..::..ForwardIterator Method
PaperSourceSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual PaperSourceSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As PaperSourceSetIterator
Visual C++
public:
virtual PaperSourceSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

PaperSourceSet Class


GetEnumerator Method

[image]

Revit 2024 API
PaperSourceSet..::..GetEnumerator Method
PaperSourceSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

PaperSourceSet Class


Insert Method

[image]

Revit 2024 API
PaperSourceSet..::..Insert Method
PaperSourceSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool Insert(
    PaperSource item
)
Visual Basic
Public Overridable Function Insert ( _
    item As PaperSource _
) As Boolean
Visual C++
public:
virtual bool Insert(
    PaperSource^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..PaperSource

See Also

PaperSourceSet Class


ReverseIterator Method

[image]

Revit 2024 API
PaperSourceSet..::..ReverseIterator Method
PaperSourceSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual PaperSourceSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As PaperSourceSetIterator
Visual C++
public:
virtual PaperSourceSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

PaperSourceSet Class


PaperSourceSet Properties

[image] [image]

Revit 2024 API
PaperSourceSet Properties
PaperSourceSet Class See Also Send Feedback

The PaperSourceSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

PaperSourceSet Class


IsEmpty Property

[image]

Revit 2024 API
PaperSourceSet..::..IsEmpty Property
PaperSourceSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

PaperSourceSet Class


Size Property

[image]

Revit 2024 API
PaperSourceSet..::..Size Property
PaperSourceSet Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

PaperSourceSet Class


PaperSourceSetIterator Members

[image] [image]

Revit 2024 API
PaperSourceSetIterator Members
PaperSourceSetIterator Class Constructors Methods Properties See Also Send Feedback

The PaperSourceSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | PaperSourceSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PaperSourceSetIterator Class


PaperSourceSetIterator Constructor

[image]

Revit 2024 API
PaperSourceSetIterator Constructor
PaperSourceSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public PaperSourceSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
PaperSourceSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PaperSourceSetIterator Class


PaperSourceSetIterator Methods

[image] [image]

Revit 2024 API
PaperSourceSetIterator Methods
PaperSourceSetIterator Class See Also Send Feedback

The PaperSourceSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PaperSourceSetIterator Class


MoveNext Method

[image]

Revit 2024 API
PaperSourceSetIterator..::..MoveNext Method
PaperSourceSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

PaperSourceSetIterator Class


Reset Method

[image]

Revit 2024 API
PaperSourceSetIterator..::..Reset Method
PaperSourceSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

PaperSourceSetIterator Class


PaperSourceSetIterator Properties

[image] [image]

Revit 2024 API
PaperSourceSetIterator Properties
PaperSourceSetIterator Class See Also Send Feedback

The PaperSourceSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PaperSourceSetIterator Class


Current Property

[image]

Revit 2024 API
PaperSourceSetIterator..::..Current Property
PaperSourceSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

PaperSourceSetIterator Class


Parameter Class

[image]

Revit 2024 API
Parameter Class
Members See Also Send Feedback
The parameter object contains the value data assigned to that parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class Parameter : APIObject
Visual Basic
Public Class Parameter _
    Inherits APIObject
Visual C++
public ref class Parameter : public APIObject

Remarks

The piece of data contained within the parameter can be either a Double, Integer, String or ElementId. The parameter object can be retrieved from any Element object using either a built in id, definition object or shared parameter guid. All Elements within Autodesk Revit contain Parameters. These are options that can be accessed in a generic fashion. Revit contains many built in parameter types but users and now developers, via the API, can add their own parameters in the form of shared parameters. The developer should become familiar with the Revit user interface for added and managing parameters and shared parameters before using this API. The user interface components can be found in the following locations: Element Properties dialog, Shared Parameters dialog (available from the File menu), Project Parameters dialog (available from the Settings menu), Family Types dialog (available from the Settings menu when editing a family). There are several relationships between the objects that make up the APIs exposure of parameters. The parameter object contains the data value. Parameter objects can be retrieved from Elements if you know its built-in id, its definition or its shared parameter guid. Each parameter has a definition. New parameters can be added to Elements by adding a ParameterBinding object to the Document object.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..Parameter

See Also

Parameter Members


Parameter Members

[image] [image]

Revit 2024 API
Parameter Members
Parameter Class Methods Properties See Also Send Feedback

The Parameter type exposes the following members.

Methods

 | Name | Description
Public method | AsDouble | Provides access to the double precision number within the parameter.
Public method | AsElementId | Provides access to the Autodesk::Revit::DB::ElementId^ stored within the parameter.
Public method | AsInteger | Provides access to the integer number within the parameter.
Public method | AssociateWithGlobalParameter | Associates this parameter with a global parameter in the same document.
Public method | AsString | Provides access to the string contents of the parameter.
Public method | AsValueString()()()() | Get the parameter value as a string with units.
Public method | AsValueString(FormatOptions) | Get the parameter value as a string with units.
Public method | CanBeAssociatedWithGlobalParameter | Tests whether this parameter can be associated with the given global parameter.
Public method | CanBeAssociatedWithGlobalParameters | Tests whether this parameter can be associated with any global parameter.
Public method | ClearValue | Clears the parameter to its initial value.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | DissociateFromGlobalParameter | Dissociates this parameter from a global parameter.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAssociatedGlobalParameter | Returns a global parameter, if any, currently associated with this parameter.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Gets the identifier of the parameter.
Public method | GetUnitTypeId | Gets the identifier of the unit quantifying the parameter value.
Public method | Set(Double) | Sets the parameter to a new real number value.
Public method | Set(Int32) | Sets the parameter to a new integer value.
Public method | Set(String) | Sets the parameter to a new string of text.
Public method | Set(ElementId) | Sets the parameter to a new element id.
Public method | SetValueString | Set the parameter value according to the input string.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Definition | Returns the Definition object that describes the data type, name and other details of the parameter.
Public property | Element | The element to which this parameter belongs.
Public property | GUID | The Guid for a shared parameter.
Public property | HasValue | Identifies if the parameter has an assigned value.
Public property | Id | The id of the parameter.
Public property | IsReadOnly | Get the readonly property of the parameter. (Overrides APIObject..::..IsReadOnly.)
Public property | IsShared | Identifies if the parameter is a shared parameter.
Public property | StorageType | Describes the type that is used internally within the parameter to store its value.
Public property | UserModifiable | Indicates whether the interactive user can modify the value of this parameter.

See Also

Parameter Class


Parameter Methods

[image] [image]

Revit 2024 API
Parameter Methods
Parameter Class See Also Send Feedback

The Parameter type exposes the following members.

Methods

 | Name | Description
Public method | AsDouble | Provides access to the double precision number within the parameter.
Public method | AsElementId | Provides access to the Autodesk::Revit::DB::ElementId^ stored within the parameter.
Public method | AsInteger | Provides access to the integer number within the parameter.
Public method | AssociateWithGlobalParameter | Associates this parameter with a global parameter in the same document.
Public method | AsString | Provides access to the string contents of the parameter.
Public method | AsValueString()()()() | Get the parameter value as a string with units.
Public method | AsValueString(FormatOptions) | Get the parameter value as a string with units.
Public method | CanBeAssociatedWithGlobalParameter | Tests whether this parameter can be associated with the given global parameter.
Public method | CanBeAssociatedWithGlobalParameters | Tests whether this parameter can be associated with any global parameter.
Public method | ClearValue | Clears the parameter to its initial value.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | DissociateFromGlobalParameter | Dissociates this parameter from a global parameter.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAssociatedGlobalParameter | Returns a global parameter, if any, currently associated with this parameter.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Gets the identifier of the parameter.
Public method | GetUnitTypeId | Gets the identifier of the unit quantifying the parameter value.
Public method | Set(Double) | Sets the parameter to a new real number value.
Public method | Set(Int32) | Sets the parameter to a new integer value.
Public method | Set(String) | Sets the parameter to a new string of text.
Public method | Set(ElementId) | Sets the parameter to a new element id.
Public method | SetValueString | Set the parameter value according to the input string.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Parameter Class


AsDouble Method

[image]

Revit 2024 API
Parameter..::..AsDouble Method
Parameter Class See Also Send Feedback
Provides access to the double precision number within the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double AsDouble()
Visual Basic
Public Function AsDouble As Double
Visual C++
public:
double AsDouble()

Return Value

The double value contained in the parameter.

Remarks

The AsDouble method should only be used if the StorageType property returns that the internal contents of the parameter is a double.

See Also

Parameter Class


AsElementId Method

[image]

Revit 2024 API
Parameter..::..AsElementId Method
Parameter Class See Also Send Feedback
Provides access to the Autodesk::Revit::DB::ElementId^ stored within the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElementId AsElementId()
Visual Basic
Public Function AsElementId As ElementId
Visual C++
public:
ElementId^ AsElementId()

Return Value

The Autodesk::Revit::DB::ElementId^ contained in the parameter.

Remarks

The AsAutodesk::Revit::DB::ElementId^ method should only be used if the StorageType property returns that the internal contents of the parameter is an ElementId.

See Also

Parameter Class


AsInteger Method

[image]

Revit 2024 API
Parameter..::..AsInteger Method
Parameter Class See Also Send Feedback
Provides access to the integer number within the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public int AsInteger()
Visual Basic
Public Function AsInteger As Integer
Visual C++
public:
int AsInteger()

Return Value

The integer value contained in the parameter.

Remarks

The AsInteger method should only be used if the StorageType property returns that the internal contents of the parameter is an integer.

See Also

Parameter Class


AssociateWithGlobalParameter Method

[image]

Revit 2024 API
Parameter..::..AssociateWithGlobalParameter Method
Parameter Class See Also Send Feedback
Associates this parameter with a global parameter in the same document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Update

Syntax

C#
public void AssociateWithGlobalParameter(
    ElementId gpId
)
Visual Basic
Public Sub AssociateWithGlobalParameter ( _
    gpId As ElementId _
)
Visual C++
public:
void AssociateWithGlobalParameter(
    ElementId^ gpId
)

Parameters

gpId
Type: Autodesk.Revit.DB..::..ElementId
Id of a global parameter contained in this parameter's document

Remarks

The parameter must be parameterizable, meaning it cannot be read-only, driven by a formula, or have any other restrictions imposed by Revit.

The parameter's value type must match the type of the global parameter.

Once associated property can be later dissociated by calling the DissociateFromGlobalParameter()()()() method

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input gpId is not of a valid global parameter of the given document. -or- This parameter does not exist in the document anymore. -or- This parameter is either not parameterizable or does not match the type of the global parameter.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Parameter Class


AsString Method

[image]

Revit 2024 API
Parameter..::..AsString Method
Parameter Class See Also Send Feedback
Provides access to the string contents of the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string AsString()
Visual Basic
Public Function AsString As String
Visual C++
public:
String^ AsString()

Return Value

The string contained in the parameter.

Remarks

The AsString method should only be used if the StorageType property returns that the internal contents of the parameter is a string.

See Also

Parameter Class


AsValueString Method

[image] [image]

Revit 2024 API
Parameter..::..AsValueString Method
Parameter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AsValueString()()()() | Get the parameter value as a string with units.
Public method | AsValueString(FormatOptions) | Get the parameter value as a string with units.

See Also

Parameter Class
Parameter Members


AsValueString Method

[image]

Revit 2024 API
Parameter..::..AsValueString Method
Parameter Class Example See Also Send Feedback
Get the parameter value as a string with units.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string AsValueString()
Visual Basic
Public Function AsValueString As String
Visual C++
public:
String^ AsValueString()

Return Value

The string that represents the parameter value.

Examples

CopyC#
String ShowValueParameterInformation(Parameter attribute)
{
    string paramValue = null;
    switch (attribute.StorageType)
    {
        case StorageType.Integer:
            if (SpecTypeId.Boolean.YesNo
                                == attribute.Definition.GetDataType())
            {
                paramValue = null;
            }
            else
            {
                paramValue = attribute.AsValueString();
            }
            break;
        case StorageType.Double:
            paramValue = attribute.AsValueString();
            break;
        default:
            paramValue = null;
            break;
    }

    return paramValue;
}
CopyVB.NET
Private Function ShowValueParameterInformation(attribute As Parameter) As [String]
    Dim paramValue As String = Nothing
    Select Case attribute.StorageType
        Case StorageType.[Integer]
            If SpecTypeId.Boolean.YesNo = attribute.Definition.GetDataType() Then
                paramValue = Nothing
            Else
                paramValue = attribute.AsValueString()
            End If
            Exit Select
        Case StorageType.[Double]
            paramValue = attribute.AsValueString()
            Exit Select
        Case Else
            paramValue = Nothing
            Exit Select
    End Select

    Return paramValue
End Function

See Also

Parameter Class
AsValueString Overload


AsValueString Method (FormatOptions)

[image]

Revit 2024 API
Parameter..::..AsValueString Method (FormatOptions)
Parameter Class See Also Send Feedback
Get the parameter value as a string with units.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public string AsValueString(
    FormatOptions formatOptions
)
Visual Basic
Public Function AsValueString ( _
    formatOptions As FormatOptions _
) As String
Visual C++
public:
String^ AsValueString(
    FormatOptions^ formatOptions
)

Parameters

formatOptions
Type: Autodesk.Revit.DB..::..FormatOptions
Options for formatting the string.

Return Value

The string that represents the parameter value.

See Also

Parameter Class
AsValueString Overload


ClearValue Method

[image]

Revit 2024 API
Parameter..::..ClearValue Method
Parameter Class See Also Send Feedback
Clears the parameter to its initial value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public bool ClearValue()
Visual Basic
Public Function ClearValue As Boolean
Visual C++
public:
bool ClearValue()

Return Value

The ClearValue method will return True if the parameter was successfully cleared to its initial value, otherwise false.

Remarks

This method will only succeed for Shared parameters that have their HideWhenNoValue property set to true.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The parameter is read-only, or the parameter is not a shared parameter, or the shared parameter has HideWhenNoValue set to false.

See Also

Parameter Class


DissociateFromGlobalParameter Method

[image]

Revit 2024 API
Parameter..::..DissociateFromGlobalParameter Method
Parameter Class See Also Send Feedback
Dissociates this parameter from a global parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Update

Syntax

C#
public void DissociateFromGlobalParameter()
Visual Basic
Public Sub DissociateFromGlobalParameter
Visual C++
public:
void DissociateFromGlobalParameter()

Remarks

It is assumed this parameter has been previously associated with the global parameter by using the [!:AssociateWithGlobalParameter(Revit::DB::ElementId^)] method.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This parameter does not exist in the document anymore. -or- This parameter is either not parameterizable or does not match the type of the global parameter.

See Also

Parameter Class


GetAssociatedGlobalParameter Method

[image]

Revit 2024 API
Parameter..::..GetAssociatedGlobalParameter Method
Parameter Class See Also Send Feedback
Returns a global parameter, if any, currently associated with this parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Update

Syntax

C#
public ElementId GetAssociatedGlobalParameter()
Visual Basic
Public Function GetAssociatedGlobalParameter As ElementId
Visual C++
public:
ElementId^ GetAssociatedGlobalParameter()

Return Value

Id of a global parameter or InvalidElemetnId.

Remarks

InvalidElementId is returned in case this parameter is not associated with any global parameter. InvalidElementId is also returned if called for a parameter that cannot even be associated with a global parameters (i.e. a non-parametrizable parameter or parameter with a formula).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This parameter does not exist in the document anymore.

See Also

Parameter Class


GetTypeId Method

[image]

Revit 2024 API
Parameter..::..GetTypeId Method
Parameter Class See Also Send Feedback
Gets the identifier of the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public ForgeTypeId GetTypeId()
Visual Basic
Public Function GetTypeId As ForgeTypeId
Visual C++
public:
ForgeTypeId^ GetTypeId()

See Also

Parameter Class


Set Method

[image] [image]

Revit 2024 API
Parameter..::..Set Method
Parameter Class See Also Send Feedback
Sets the parameter to a new value.

Overload List

 | Name | Description
Public method | Set(Double) | Sets the parameter to a new real number value.
Public method | Set(Int32) | Sets the parameter to a new integer value.
Public method | Set(String) | Sets the parameter to a new string of text.
Public method | Set(ElementId) | Sets the parameter to a new element id.

See Also

Parameter Class
Parameter Members


Set Method (Double)

[image]

Revit 2024 API
Parameter..::..Set Method (Double)
Parameter Class Example See Also Send Feedback
Sets the parameter to a new real number value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool Set(
    double value
)
Visual Basic
Public Function Set ( _
    value As Double _
) As Boolean
Visual C++
public:
bool Set(
    double value
)

Parameters

value
Type: System..::..Double
The new double value to which the parameter is to be set.

Return Value

The Set method will return True if the parameter was successfully set to the new value, otherwise false.

Remarks

You should only use this method if the StorageType property reports the type of the parameter as a Double.

Examples

CopyC#
public bool SetParameter(Parameter parameter, double value)
{
    bool result = false;
    //if the parameter is readonly, you can�t change the value of it
    if (null != parameter && !parameter.IsReadOnly)
    {
        StorageType parameterType = parameter.StorageType;
        if (StorageType.Double != parameterType)
        {
            throw new Exception("The storagetypes of value and parameter are different!");
        }
        //If successful, the result is true
        result = parameter.Set(value);
    }

    return result;
}
CopyVB.NET
Public Function SetParameter(parameter As Parameter, value As Double) As Boolean
    Dim result As Boolean = False
    'if the parameter is readonly, you can�t change the value of it
    If parameter IsNot Nothing AndAlso Not parameter.IsReadOnly Then
        Dim parameterType As StorageType = parameter.StorageType
        If StorageType.[Double] <> parameterType Then
            Throw New Exception("The storagetypes of value and parameter are different!")
        End If
        'If successful, the result is true
        result = parameter.[Set](value)
    End If

    Return result
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The parameter is read-only.
Autodesk.Revit.Exceptions..::..ArgumentException | Value must be a finite number.

See Also

Parameter Class
Set Overload


Set Method (Int32)

[image]

Revit 2024 API
Parameter..::..Set Method (Int32)
Parameter Class See Also Send Feedback
Sets the parameter to a new integer value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool Set(
    int value
)
Visual Basic
Public Function Set ( _
    value As Integer _
) As Boolean
Visual C++
public:
bool Set(
    int value
)

Parameters

value
Type: System..::..Int32
The new integer value to which the parameter is to be set.

Return Value

The Set method will return True if the parameter was successfully set to the new value, otherwise false.

Remarks

You should only use this method if the StorageType property reports the type of the parameter as an integer.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The parameter is read-only.

See Also

Parameter Class
Set Overload


Set Method (String)

[image]

Revit 2024 API
Parameter..::..Set Method (String)
Parameter Class Example See Also Send Feedback
Sets the parameter to a new string of text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool Set(
    string value
)
Visual Basic
Public Function Set ( _
    value As String _
) As Boolean
Visual C++
public:
bool Set(
    String^ value
)

Parameters

value
Type: System..::..String
The new text value to which the parameter is to be set.

Return Value

The Set method will return True if the parameter was successfully set to the new value, otherwise false.

Remarks

You should only use this method if the StorageType property reports the type of the parameter as a String.

Examples

CopyC#
void AddInstanceComment(Wall wall)
{
    // Get the comment parameter of the element instance
    Parameter commentPara = wall.get_Parameter(BuiltInParameter.ALL_MODEL_INSTANCE_COMMENTS);
    if (null != commentPara)
    {
        // Add a greeting string to the comment
        commentPara.Set("Hello Everyone.");
    }
}
CopyVB.NET
Private Sub AddInstanceComment(wall As Wall)
    ' Get the comment parameter of the element instance
    Dim commentPara As Parameter = wall.Parameter(BuiltInParameter.ALL_MODEL_INSTANCE_COMMENTS)
    If commentPara IsNot Nothing Then
        ' Add a greeting string to the comment
        commentPara.[Set]("Hello Everyone.")
    End If
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The parameter is read-only.

See Also

Parameter Class
Set Overload


Set Method (ElementId)

[image]

Revit 2024 API
Parameter..::..Set Method (ElementId)
Parameter Class See Also Send Feedback
Sets the parameter to a new element id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool Set(
    ElementId value
)
Visual Basic
Public Function Set ( _
    value As ElementId _
) As Boolean
Visual C++
public:
bool Set(
    ElementId^ value
)

Parameters

value
Type: Autodesk.Revit.DB..::..ElementId
The new element id to which the parameter is to be set.

Return Value

The Set method will return True if the parameter was successfully set to the new value, otherwise false.

Remarks

You should only use this method if the StorageType property reports the type of the parameter as an ElementId.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The parameter is read-only.

See Also

Parameter Class
Set Overload


SetValueString Method

[image]

Revit 2024 API
Parameter..::..SetValueString Method
Parameter Class Example See Also Send Feedback
Set the parameter value according to the input string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool SetValueString(
    string valueString
)
Visual Basic
Public Function SetValueString ( _
    valueString As String _
) As Boolean
Visual C++
public:
bool SetValueString(
    String^ valueString
)

Parameters

valueString
Type: System..::..String
The string that represents the parameter value.

Return Value

Indicates whether the parameter value is successfully set.

Remarks

The method only applies to parameters of value types.

Examples

CopyC#
public bool SetWithValueString(Parameter foundParameter)
{
    bool result = false;
    if (!foundParameter.IsReadOnly)
    {
        //If successful, the result is true
        result = foundParameter.SetValueString("-22\'3\"");
    }
    return result;
}
CopyVB.NET
Public Function SetWithValueString(foundParameter As Parameter) As Boolean
    Dim result As Boolean = False
    If Not foundParameter.IsReadOnly Then
        'If successful, the result is true
        result = foundParameter.SetValueString("-22'3""")
    End If
    Return result
End Function

See Also

Parameter Class


Element Property

[image]

Revit 2024 API
Parameter..::..Element Property
Parameter Class See Also Send Feedback
The element to which this parameter belongs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Element Element { get; }
Visual Basic
Public ReadOnly Property Element As Element
    Get
Visual C++
public:
property Element^ Element {
    Element^ get ();
}

See Also

Parameter Class


GUID Property

[image]

Revit 2024 API
Parameter..::..GUID Property
Parameter Class See Also Send Feedback
The Guid for a shared parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public Guid GUID { get; }
Visual Basic
Public ReadOnly Property GUID As Guid
    Get
Visual C++
public:
property Guid GUID {
    Guid get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the parameter is not a shared parameter.

See Also

Parameter Class


HasValue Property

[image]

Revit 2024 API
Parameter..::..HasValue Property
Parameter Class See Also Send Feedback
Identifies if the parameter has an assigned value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public bool HasValue { get; }
Visual Basic
Public ReadOnly Property HasValue As Boolean
    Get
Visual C++
public:
property bool HasValue {
    bool get ();
}

See Also

Parameter Class


Id Property

[image]

Revit 2024 API
Parameter..::..Id Property
Parameter Class See Also Send Feedback
The id of the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public ElementId Id { get; }
Visual Basic
Public ReadOnly Property Id As ElementId
    Get
Visual C++
public:
property ElementId^ Id {
    ElementId^ get ();
}

See Also

Parameter Class


IsReadOnly Property

[image]

Revit 2024 API
Parameter..::..IsReadOnly Property
Parameter Class See Also Send Feedback
Get the readonly property of the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public override bool IsReadOnly { get; }
Visual Basic
Public Overrides ReadOnly Property IsReadOnly As Boolean
    Get
Visual C++
public:
virtual property bool IsReadOnly {
    bool get () override;
}

Remarks

This function can be used to check if the parameter is read-only.

See Also

Parameter Class


IsShared Property

[image]

Revit 2024 API
Parameter..::..IsShared Property
Parameter Class See Also Send Feedback
Identifies if the parameter is a shared parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool IsShared { get; }
Visual Basic
Public ReadOnly Property IsShared As Boolean
    Get
Visual C++
public:
property bool IsShared {
    bool get ();
}

See Also

Parameter Class


StorageType Property

[image]

Revit 2024 API
Parameter..::..StorageType Property
Parameter Class See Also Send Feedback
Describes the type that is used internally within the parameter to store its value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public StorageType StorageType { get; }
Visual Basic
Public ReadOnly Property StorageType As StorageType
    Get
Visual C++
public:
property StorageType StorageType {
    StorageType get ();
}

Remarks

The property will return one of the following possibilities: String, Integer, Double or ElementId. Based on the value of this property the correct access and set methods should be used to retrieve and set the parameter's data value.

See Also

Parameter Class


UserModifiable Property

[image]

Revit 2024 API
Parameter..::..UserModifiable Property
Parameter Class See Also Send Feedback
Indicates whether the interactive user can modify the value of this parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool UserModifiable { get; }
Visual Basic
Public ReadOnly Property UserModifiable As Boolean
    Get
Visual C++
public:
property bool UserModifiable {
    bool get ();
}

Remarks

Note that for shared parameters IsReadOnly can return false for shared parameters whose UserModifiable property is also false, because the value of those parameters can be modified by the API. If a parameter is governed by a formula, IsReadOnly would return true, even if the flag for UserModifiable was set to true when the shared parameter was created.

See Also

Parameter Class


ParameterDownloadOptions Class

[image]

Revit 2024 API
ParameterDownloadOptions Class
Members See Also Send Feedback
An option class used for downloading parameters from the Parameters Service.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public class ParameterDownloadOptions : IDisposable
Visual Basic
Public Class ParameterDownloadOptions _
    Implements IDisposable
Visual C++
public ref class ParameterDownloadOptions : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ParameterDownloadOptions

See Also

ParameterDownloadOptions Members


ParameterDownloadOptions Members

[image] [image]

Revit 2024 API
ParameterDownloadOptions Members
ParameterDownloadOptions Class Constructors Methods Properties See Also Send Feedback

The ParameterDownloadOptions type exposes the following members.

Constructors

 | Name | Description
Public method | ParameterDownloadOptions()()()() | Default constructor.
Public method | ParameterDownloadOptions(ISet<(Of <<'(ElementId>)>>), Boolean, Boolean, ForgeTypeId) | Creates a new ParameterDownloadOptions instance. Category bindings are represented by an ElementIdSet populated with category identifiers.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ParameterDownloadOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCategories | Get categories for binding.
Public method | GetGroupTypeId | Get properties palette group identifier.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetCategories | Set categories for binding.
Public method | SetGroupTypeId | Set properties palette group identifier.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsInstance | True if binding to Element instances, false if binding to Element types.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Visible | True if the parameter is visible to the user, false if it is hidden and accessible only via the API.

See Also

ParameterDownloadOptions Class


ParameterDownloadOptions Constructor

[image]

Revit 2024 API
ParameterDownloadOptions Constructor
ParameterDownloadOptions Class See Also Send Feedback
Default constructor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public ParameterDownloadOptions()
Visual Basic
Public Sub New
Visual C++
public:
ParameterDownloadOptions()

See Also

ParameterDownloadOptions Class
ParameterDownloadOptions Overload


ParameterDownloadOptions Methods

[image] [image]

Revit 2024 API
ParameterDownloadOptions Methods
ParameterDownloadOptions Class See Also Send Feedback

The ParameterDownloadOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCategories | Get categories for binding.
Public method | GetGroupTypeId | Get properties palette group identifier.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetCategories | Set categories for binding.
Public method | SetGroupTypeId | Set properties palette group identifier.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ParameterDownloadOptions Class


Dispose Method

[image]

Revit 2024 API
ParameterDownloadOptions..::..Dispose Method
ParameterDownloadOptions Class See Also Send Feedback
Releases all resources used by the ParameterDownloadOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ParameterDownloadOptions Class


GetGroupTypeId Method

[image]

Revit 2024 API
ParameterDownloadOptions..::..GetGroupTypeId Method
ParameterDownloadOptions Class See Also Send Feedback
Get properties palette group identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public ForgeTypeId GetGroupTypeId()
Visual Basic
Public Function GetGroupTypeId As ForgeTypeId
Visual C++
public:
ForgeTypeId^ GetGroupTypeId()

See Also

ParameterDownloadOptions Class


SetCategories Method

[image]

Revit 2024 API
ParameterDownloadOptions..::..SetCategories Method
ParameterDownloadOptions Class See Also Send Feedback
Set categories for binding.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public void SetCategories(
    ISet<ElementId> categories
)
Visual Basic
Public Sub SetCategories ( _
    categories As ISet(Of ElementId) _
)
Visual C++
public:
void SetCategories(
    ISet<ElementId^>^ categories
)

Parameters

categories
Type: System.Collections.Generic..::..ISet<(Of <(<' ElementId >)>)>

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterDownloadOptions Class


SetGroupTypeId Method

[image]

Revit 2024 API
ParameterDownloadOptions..::..SetGroupTypeId Method
ParameterDownloadOptions Class See Also Send Feedback
Set properties palette group identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public void SetGroupTypeId(
    ForgeTypeId groupTypeId
)
Visual Basic
Public Sub SetGroupTypeId ( _
    groupTypeId As ForgeTypeId _
)
Visual C++
public:
void SetGroupTypeId(
    ForgeTypeId^ groupTypeId
)

Parameters

groupTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterDownloadOptions Class


IsInstance Property

[image]

Revit 2024 API
ParameterDownloadOptions..::..IsInstance Property
ParameterDownloadOptions Class See Also Send Feedback
True if binding to Element instances, false if binding to Element types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public bool IsInstance { get; set; }
Visual Basic
Public Property IsInstance As Boolean
    Get
    Set
Visual C++
public:
property bool IsInstance {
    bool get ();
    void set (bool value);
}

See Also

ParameterDownloadOptions Class


Visible Property

[image]

Revit 2024 API
ParameterDownloadOptions..::..Visible Property
ParameterDownloadOptions Class See Also Send Feedback
True if the parameter is visible to the user, false if it is hidden and accessible only via the API.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public bool Visible { get; set; }
Visual Basic
Public Property Visible As Boolean
    Get
    Set
Visual C++
public:
property bool Visible {
    bool get ();
    void set (bool value);
}

See Also

ParameterDownloadOptions Class


ParameterElement Class

[image]

Revit 2024 API
ParameterElement Class
Members See Also Send Feedback
An Element that stores a user-defined parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public class ParameterElement : Element
Visual Basic
Public Class ParameterElement _
    Inherits Element
Visual C++
public ref class ParameterElement : public Element

Remarks

Revit supports both built-in and user-defined parameters. Built-in parameters ship with the application, and they are not stored in Revit documents. User-defined parameters are dynamically created, and they are stored in the documents that use them, wrapped in ParameterElement objects. Different subclasses of ParemeterElement represent different kinds of user-defined parameters.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ParameterElement
Autodesk.Revit.DB..::..GlobalParameter
Autodesk.Revit.DB..::..SharedParameterElement

See Also

ParameterElement Members


ParameterElement Members

[image] [image]

Revit 2024 API
ParameterElement Members
ParameterElement Class Methods Properties See Also Send Feedback

The ParameterElement type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDefinition | Get the definition representing this parameter element.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ParameterElement Class


ParameterElement Methods

[image] [image]

Revit 2024 API
ParameterElement Methods
ParameterElement Class See Also Send Feedback

The ParameterElement type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDefinition | Get the definition representing this parameter element.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ParameterElement Class


ParameterElement Properties

[image] [image]

Revit 2024 API
ParameterElement Properties
ParameterElement Class See Also Send Feedback

The ParameterElement type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ParameterElement Class


Parameter Property

[image] [image]

Revit 2024 API
ParameterElement..::..Parameter Property
ParameterElement Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ParameterElement Class
ParameterElement Members


ParameterFilterElement Class

[image]

Revit 2024 API
ParameterFilterElement Class
Members Example See Also Send Feedback
Admits elements that satisfy two conditions:
  1. The element's category must be one of a certain set of allowed categories.
  2. The element must pass a series of filter rules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class ParameterFilterElement : FilterElement
Visual Basic
Public Class ParameterFilterElement _
    Inherits FilterElement
Visual C++
public ref class ParameterFilterElement : public FilterElement

Examples

CopyC#
/// <summary>
/// Create an ElementFilter representing a conjunction ("ANDing together") of FilterRules.
/// </summary>
/// <param name="filterRules">A list of FilterRules</param>
/// <returns>The ElementFilter.</returns>
private static ElementFilter CreateElementFilterFromFilterRules(IList<FilterRule> filterRules)
{
   // We use a LogicalAndFilter containing one ElementParameterFilter
   // for each FilterRule. We could alternatively create a single
   // ElementParameterFilter containing the entire list of FilterRules.
   IList<ElementFilter> elemFilters = new List<ElementFilter>();
   foreach (FilterRule filterRule in filterRules)
   {
      ElementParameterFilter elemParamFilter = new ElementParameterFilter(filterRule);
      elemFilters.Add(elemParamFilter);
   }
   LogicalAndFilter elemFilter = new LogicalAndFilter(elemFilters);

   return elemFilter;
}

/// <summary>
/// Creates a new view filter matching multiple criteria.
/// </summary>
/// <param name="doc"></param>
/// <param name="view"></param>
public static void CreateViewFilter(Document doc, View view)
  {
      List<ElementId> categories = new List<ElementId>();
      categories.Add(new ElementId(BuiltInCategory.OST_Walls));
      List<FilterRule> filterRules = new List<FilterRule>();

      using (Transaction t = new Transaction(doc, "Add view filter"))
      {
          t.Start();

          // Create filter element assocated to the input categories
          ParameterFilterElement parameterFilterElement = ParameterFilterElement.Create(doc, "Example view filter", categories);

          // Criterion 1 - wall type Function is "Exterior"
          ElementId exteriorParamId = new ElementId(BuiltInParameter.FUNCTION_PARAM);
          filterRules.Add(ParameterFilterRuleFactory.CreateEqualsRule(exteriorParamId, (int)WallFunction.Exterior));

          // Criterion 2 - wall height > some number
          ElementId lengthId = new ElementId(BuiltInParameter.CURVE_ELEM_LENGTH);
          filterRules.Add(ParameterFilterRuleFactory.CreateGreaterOrEqualRule(lengthId, 28.0, 0.0001));

          // Criterion 3 - custom shared parameter value matches string pattern
          // Get the id for the shared parameter - the ElementId is not hardcoded, so we need to get an instance of this type to find it
          Guid spGuid = new Guid("96b00b61-7f5a-4f36-a828-5cd07890a02a");
          FilteredElementCollector collector = new FilteredElementCollector(doc);
          collector.OfClass(typeof(Wall));
          Wall wall = collector.FirstElement() as Wall;

          if (wall != null)
          {
              Parameter sharedParam = wall.get_Parameter(spGuid);
              ElementId sharedParamId = sharedParam.Id;

              filterRules.Add(ParameterFilterRuleFactory.CreateBeginsWithRule(sharedParamId, "15."));
          }

          ElementFilter elemFilter = CreateElementFilterFromFilterRules(filterRules);
          parameterFilterElement.SetElementFilter(elemFilter);

          // Apply filter to view
          view.AddFilter(parameterFilterElement.Id);
          view.SetFilterVisibility(parameterFilterElement.Id, false);
          t.Commit();
      }
  }
CopyVB.NET
Public Shared Sub CreateViewFilter(doc As Document, view As View)
      Dim categories As New List(Of ElementId)()
      categories.Add(New ElementId(BuiltInCategory.OST_Walls))
      Dim filterRules As New List(Of FilterRule)()

      Using t As New Transaction(doc, "Add view filter")
          t.Start()

          ' Create filter element assocated to the input categories
          Dim parameterFilterElement__1 As ParameterFilterElement = ParameterFilterElement.Create(doc, "Example view filter", categories)

          ' Criterion 1 - wall type Function is "Exterior"
          Dim exteriorParamId As New ElementId(BuiltInParameter.FUNCTION_PARAM)
          filterRules.Add(ParameterFilterRuleFactory.CreateEqualsRule(exteriorParamId, CInt(WallFunction.Exterior)))

          ' Criterion 2 - wall height > some number
          Dim lengthId As New ElementId(BuiltInParameter.CURVE_ELEM_LENGTH)
          filterRules.Add(ParameterFilterRuleFactory.CreateGreaterOrEqualRule(lengthId, 28.0, 0.0001))

          ' Criterion 3 - custom shared parameter value matches string pattern
          ' Get the id for the shared parameter - the ElementId is not hardcoded, so we need to get an instance of this type to find it
          Dim spGuid As New Guid("96b00b61-7f5a-4f36-a828-5cd07890a02a")
          Dim collector As New FilteredElementCollector(doc)
          collector.OfClass(GetType(Wall))
          Dim wall As Wall = TryCast(collector.FirstElement(), Wall)

          If wall IsNot Nothing Then
              Dim sharedParam As Parameter = wall.Parameter(spGuid)
              Dim sharedParamId As ElementId = sharedParam.Id

              filterRules.Add(ParameterFilterRuleFactory.CreateBeginsWithRule(sharedParamId, "15."))
          End If

      ' We use a LogicalAndFilter containing one ElementParameterFilter
      ' for each FilterRule. We could alternatively create a single
      ' ElementParameterFilter containing the entire list of FilterRules.
      Dim elemFilters As New List(Of ElementFilter)()
      For Each filterRule As FilterRule In filterRules
         Dim elemParamFilter As New ElementParameterFilter(filterRule)
         elemFilters.Add(elemParamFilter)
      Next
      Dim elemFilter As New LogicalAndFilter(elemFilters)
      parameterFilterElement__1.SetElementFilter(elemFilter)

      ' Apply filter to view
      view.AddFilter(parameterFilterElement__1.Id)
          view.SetFilterVisibility(parameterFilterElement__1.Id, False)
          t.Commit()
      End Using
  End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..FilterElement
Autodesk.Revit.DB..::..ParameterFilterElement

See Also

ParameterFilterElement Members


ParameterFilterElement Methods

[image] [image]

Revit 2024 API
ParameterFilterElement Methods
ParameterFilterElement Class See Also Send Feedback

The ParameterFilterElement type exposes the following members.

Methods

 | Name | Description
Public method | AllRuleParametersApplicable(ElementFilter) | Checks that the parameters of the rules used by the given ElementFilter are valid for this filter's categories.
 | AllRuleParametersApplicable(Document, ICollection<(Of <<'(ElementId>)>>), ElementFilter) | Checks that the parameters of the given ElementFilter (representing a combination of rules) are valid for the given set of categories.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | ClearRules | Removes all rules from this filter.
 | Create(Document, String, ICollection<(Of <<'(ElementId>)>>)) | Creates a new ParameterFilterElement in the given document.
 | Create(Document, String, ICollection<(Of <<'(ElementId>)>>), ElementFilter) | Creates a new ParameterFilterElement in the given document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | ElementFilterIsAcceptableForParameterFilterElement(ElementFilter) | Checks that an ElementFilter is acceptable for use in defining the filtering rules for a ParameterFilterElement (i.e., for view filtering).
 | ElementFilterIsAcceptableForParameterFilterElement(Document, ISet<(Of <<'(ElementId>)>>), ElementFilter) | Checks that an ElementFilter is acceptable for use in defining the filtering rules for a given list of categories (i.e., for view filtering).
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetCategories | Gets the categories admitted by this filter.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetElementFilter | Returns an ElementFilter representing the combination of rules used by this filter.
Public method | GetElementFilterParameters | Retrieves a list of the parameters associated with each rule in the filter.
Public method | GetElementFilterParametersForCategory | Retrieves a list of the parameters associated with all rules in the filter that are combined (using logical AND) with a FilterCategoryRule corresponding to single %categoryId%.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsNameUnique(String) | Determines whether a potential filter element name is unique. (Inherited from FilterElement.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetCategories | Sets the categories admitted by this filter.
Public method | SetElementFilter | Sets the rules that must be satisfied for a given element to pass this filter.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ParameterFilterElement Class


AllRuleParametersApplicable Method (ElementFilter)

[image]

Revit 2024 API
ParameterFilterElement..::..AllRuleParametersApplicable Method (ElementFilter)
ParameterFilterElement Class See Also Send Feedback
Checks that the parameters of the rules used by the given ElementFilter are valid for this filter's categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public bool AllRuleParametersApplicable(
    ElementFilter elementFilter
)
Visual Basic
Public Function AllRuleParametersApplicable ( _
    elementFilter As ElementFilter _
) As Boolean
Visual C++
public:
bool AllRuleParametersApplicable(
    ElementFilter^ elementFilter
)

Parameters

elementFilter
Type: Autodesk.Revit.DB..::..ElementFilter
The ElementFilter containing the rules to check.

Return Value

True if all the parameters of the given rules are valid for this filter, otherwise false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterFilterElement Class
AllRuleParametersApplicable Overload


AllRuleParametersApplicable Method (Document, ICollection(ElementId), ElementFilter)

[image]

Revit 2024 API
ParameterFilterElement..::..AllRuleParametersApplicable Method (Document, ICollection<(Of <(<'ElementId>)>)>, ElementFilter)
ParameterFilterElement Class See Also Send Feedback
Checks that the parameters of the given ElementFilter (representing a combination of rules) are valid for the given set of categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public static bool AllRuleParametersApplicable(
    Document aDocument,
    ICollection<ElementId> categories,
    ElementFilter elementFilter
)
Visual Basic
Public Shared Function AllRuleParametersApplicable ( _
    aDocument As Document, _
    categories As ICollection(Of ElementId), _
    elementFilter As ElementFilter _
) As Boolean
Visual C++
public:
static bool AllRuleParametersApplicable(
    Document^ aDocument,
    ICollection<ElementId^>^ categories,
    ElementFilter^ elementFilter
)

Parameters

aDocument
Type: Autodesk.Revit.DB..::..Document
The document containing the filter, categories, and parameters involved in this validation.
categories
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
The set of categories against which to check the rule parameters.
elementFilter
Type: Autodesk.Revit.DB..::..ElementFilter
The ElementFilter representing the combination of rules to check.

Return Value

True if all the parameters of the given rules are valid for this filter, otherwise false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterFilterElement Class
AllRuleParametersApplicable Overload


ClearRules Method

[image]

Revit 2024 API
ParameterFilterElement..::..ClearRules Method
ParameterFilterElement Class See Also Send Feedback
Removes all rules from this filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public void ClearRules()
Visual Basic
Public Sub ClearRules
Visual C++
public:
void ClearRules()

See Also

ParameterFilterElement Class


Create Method

[image] [image]

Revit 2024 API
ParameterFilterElement..::..Create Method
ParameterFilterElement Class See Also Send Feedback

Overload List

Name | Description
Create(Document, String, ICollection<(Of <<'(ElementId>)>>)) | Creates a new ParameterFilterElement in the given document.
Create(Document, String, ICollection<(Of <<'(ElementId>)>>), ElementFilter) | Creates a new ParameterFilterElement in the given document.

See Also

ParameterFilterElement Class
ParameterFilterElement Members


Create Method (Document, String, ICollection(ElementId))

[image]

Revit 2024 API
ParameterFilterElement..::..Create Method (Document, String, ICollection<(Of <(<'ElementId>)>)>)
ParameterFilterElement Class See Also Send Feedback
Creates a new ParameterFilterElement in the given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static ParameterFilterElement Create(
    Document aDocument,
    string name,
    ICollection<ElementId> categories
)
Visual Basic
Public Shared Function Create ( _
    aDocument As Document, _
    name As String, _
    categories As ICollection(Of ElementId) _
) As ParameterFilterElement
Visual C++
public:
static ParameterFilterElement^ Create(
    Document^ aDocument,
    String^ name,
    ICollection<ElementId^>^ categories
)

Parameters

aDocument
Type: Autodesk.Revit.DB..::..Document
The document in which to create the ParameterFilterElement.
name
Type: System..::..String
The user-visible name for the new ParameterFilterElement.
categories
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
The categories for the new ParameterFilterElement.

Return Value

A pointer to the new ParameterFilterElement.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | name is an empty string or contains only whitespace. -or- name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- The given value for name is already in use as a filter element name.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterFilterElement Class
Create Overload


Create Method (Document, String, ICollection(ElementId), ElementFilter)

[image]

Revit 2024 API
ParameterFilterElement..::..Create Method (Document, String, ICollection<(Of <(<'ElementId>)>)>, ElementFilter)
ParameterFilterElement Class See Also Send Feedback
Creates a new ParameterFilterElement in the given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public static ParameterFilterElement Create(
    Document aDocument,
    string name,
    ICollection<ElementId> categories,
    ElementFilter elementFilter
)
Visual Basic
Public Shared Function Create ( _
    aDocument As Document, _
    name As String, _
    categories As ICollection(Of ElementId), _
    elementFilter As ElementFilter _
) As ParameterFilterElement
Visual C++
public:
static ParameterFilterElement^ Create(
    Document^ aDocument,
    String^ name,
    ICollection<ElementId^>^ categories,
    ElementFilter^ elementFilter
)

Parameters

aDocument
Type: Autodesk.Revit.DB..::..Document
The document in which to create the ParameterFilterElement.
name
Type: System..::..String
The user-visible name for the new ParameterFilterElement.
categories
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
The categories for the new ParameterFilterElement.
elementFilter
Type: Autodesk.Revit.DB..::..ElementFilter
The rules for the new ParameterFilterElement, represented as an ElementFilter. ElementFilter is either an ElementParameterFilter or an ElementLogicalFilter representing a Boolean combination of ElementParameterFilters. In addition, we check that each ElementParameterFilter satisfies the following conditions: Its array of FilterRules is not empty and contains:
  • Any number of FilterRules of type FilterValueRule, FilterInverseRule, and SharedParameterApplicableRule or
  • Exactly one FilterCategoryRule containing only one category from categories stored by this ParameterFilterElement or
  • Exactly two rules: the first one is a FilterCategoryRule containing only one category from categories stored by this ParameterFilterElement and the second one is a FilterRule of type FilterValueRule, FilterInverseRule, or SharedParameterApplicableRule.
Note that cases in the second and third bullet are currently allowed only if the parent node of ElementParameterFilter is LogicalOrFilter.

Return Value

A pointer to the new ParameterFilterElement.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | name is an empty string or contains only whitespace. -or- name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- The given value for name is already in use as a filter element name. -or- One of the given rules refers to a parameter that does not apply to this filter's categories.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | The ElementFilter is not acceptable for use by a ParameterFilterElement.

See Also

ParameterFilterElement Class
Create Overload


ElementFilterIsAcceptableForParameterFilterElement Method

[image] [image]

Revit 2024 API
ParameterFilterElement..::..ElementFilterIsAcceptableForParameterFilterElement Method
ParameterFilterElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ElementFilterIsAcceptableForParameterFilterElement(ElementFilter) | Checks that an ElementFilter is acceptable for use in defining the filtering rules for a ParameterFilterElement (i.e., for view filtering).
 | ElementFilterIsAcceptableForParameterFilterElement(Document, ISet<(Of <<'(ElementId>)>>), ElementFilter) | Checks that an ElementFilter is acceptable for use in defining the filtering rules for a given list of categories (i.e., for view filtering).

See Also

ParameterFilterElement Class
ParameterFilterElement Members


ElementFilterIsAcceptableForParameterFilterElement Method (ElementFilter)

[image]

Revit 2024 API
ParameterFilterElement..::..ElementFilterIsAcceptableForParameterFilterElement Method (ElementFilter)
ParameterFilterElement Class See Also Send Feedback
Checks that an ElementFilter is acceptable for use in defining the filtering rules for a ParameterFilterElement (i.e., for view filtering).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public bool ElementFilterIsAcceptableForParameterFilterElement(
    ElementFilter elementFilter
)
Visual Basic
Public Function ElementFilterIsAcceptableForParameterFilterElement ( _
    elementFilter As ElementFilter _
) As Boolean
Visual C++
public:
bool ElementFilterIsAcceptableForParameterFilterElement(
    ElementFilter^ elementFilter
)

Parameters

elementFilter
Type: Autodesk.Revit.DB..::..ElementFilter
The ElementFilter to validate.

Return Value

True if the ElementFilter is acceptable for use by an ParameterFilterElement, false if not.

Remarks

ElementFilter is either an ElementParameterFilter or an ElementLogicalFilter representing a Boolean combination of ElementParameterFilters. In addition, we check that each ElementParameterFilter satisfies the following conditions: Its array of FilterRules is not empty and contains:
  • Any number of FilterRules of type FilterValueRule, FilterInverseRule, and SharedParameterApplicableRule or
  • Exactly one FilterCategoryRule containing only one category from categories stored by this ParameterFilterElement or
  • Exactly two rules: the first one is a FilterCategoryRule containing only one category from categories stored by this ParameterFilterElement and the second one is a FilterRule of type FilterValueRule, FilterInverseRule, or SharedParameterApplicableRule.
Note that cases in the second and third bullet are currently allowed only if the parent node of ElementParameterFilter is LogicalOrFilter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterFilterElement Class
ElementFilterIsAcceptableForParameterFilterElement Overload


ElementFilterIsAcceptableForParameterFilterElement Method (Document, ISet(ElementId), ElementFilter)

[image]

Revit 2024 API
ParameterFilterElement..::..ElementFilterIsAcceptableForParameterFilterElement Method (Document, ISet<(Of <(<'ElementId>)>)>, ElementFilter)
ParameterFilterElement Class See Also Send Feedback
Checks that an ElementFilter is acceptable for use in defining the filtering rules for a given list of categories (i.e., for view filtering).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public static bool ElementFilterIsAcceptableForParameterFilterElement(
    Document aDocument,
    ISet<ElementId> categories,
    ElementFilter elementFilter
)
Visual Basic
Public Shared Function ElementFilterIsAcceptableForParameterFilterElement ( _
    aDocument As Document, _
    categories As ISet(Of ElementId), _
    elementFilter As ElementFilter _
) As Boolean
Visual C++
public:
static bool ElementFilterIsAcceptableForParameterFilterElement(
    Document^ aDocument,
    ISet<ElementId^>^ categories,
    ElementFilter^ elementFilter
)

Parameters

aDocument
Type: Autodesk.Revit.DB..::..Document
The document in which to create the ParameterFilterElement.
categories
Type: System.Collections.Generic..::..ISet<(Of <(<' ElementId >)>)>
The categories for the new ParameterFilterElement.
elementFilter
Type: Autodesk.Revit.DB..::..ElementFilter
The ElementFilter to validate.

Remarks

ElementFilter is either an ElementParameterFilter or an ElementLogicalFilter representing a Boolean combination of ElementParameterFilters. In addition, we check that each ElementParameterFilter satisfies the following conditions: Its array of FilterRules is not empty and contains:
  • Any number of FilterRules of type FilterValueRule, FilterInverseRule, and SharedParameterApplicableRule or
  • Exactly one FilterCategoryRule containing only one category from categories stored by this ParameterFilterElement or
  • Exactly two rules: the first one is a FilterCategoryRule containing only one category from categories stored by this ParameterFilterElement and the second one is a FilterRule of type FilterValueRule, FilterInverseRule, or SharedParameterApplicableRule.
Note that cases in the second and third bullet are currently allowed only if the parent node of ElementParameterFilter is LogicalOrFilter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterFilterElement Class
ElementFilterIsAcceptableForParameterFilterElement Overload


GetCategories Method

[image]

Revit 2024 API
ParameterFilterElement..::..GetCategories Method
ParameterFilterElement Class See Also Send Feedback
Gets the categories admitted by this filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public ICollection<ElementId> GetCategories()
Visual Basic
Public Function GetCategories As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetCategories()

See Also

ParameterFilterElement Class


GetElementFilter Method

[image]

Revit 2024 API
ParameterFilterElement..::..GetElementFilter Method
ParameterFilterElement Class See Also Send Feedback
Returns an ElementFilter representing the combination of rules used by this filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public ElementFilter GetElementFilter()
Visual Basic
Public Function GetElementFilter As ElementFilter
Visual C++
public:
ElementFilter^ GetElementFilter()

Return Value

An ElementFilter representing the rules. It may be an ElementParameterFilter representing a conjunction of one or more FilterRules, or an ElementLogicalFilter (of type LogicalAndFilter or LogicalOrFilter) representing a logical combination of FilterRules, using AND/OR operations.

Remarks

May return nullNothingnullptra null reference (Nothing in Visual Basic) when no rules are sprcified in ParameterFilterElement, only categories. Note that in some situation, calling GetElementFilter after calling SetElementFilter may return an ElementFilter that is structurally different from the one passed as input to SetElementFilter. For example, if the input ElementFilter contains an ElementParameterFilter that contains more than one FilterRule, and if the view filters dialog box is used in between the calls to SetElementFilter and GetElementFilter, the output ElementFilter will use a single ElementParameterFilter for each of the FilterRules that were bundled in an input ElementParameterFilter. The two ElementFilters will be logically and functionally equivalent in the sense that any given Element will either be accepted by both ElementFilters or rejected by both ElementFilters.

See Also

ParameterFilterElement Class


GetElementFilterParameters Method

[image]

Revit 2024 API
ParameterFilterElement..::..GetElementFilterParameters Method
ParameterFilterElement Class See Also Send Feedback
Retrieves a list of the parameters associated with each rule in the filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public ISet<ElementId> GetElementFilterParameters()
Visual Basic
Public Function GetElementFilterParameters As ISet(Of ElementId)
Visual C++
public:
ISet<ElementId^>^ GetElementFilterParameters()

Return Value

A set of parameter identifiers.

Remarks

This function returns only parameters used by this ParameterFilterElement that are common to all categories specified in this ParameterFilterElement. The ElementFilter may also contain parameters specific to one of the categories and not necessarily common to all categories specified in this ParameterFilterElement. To get those parameters, use ParameterFilterElement.GetElementFilterParametersForCategory().

See Also

ParameterFilterElement Class


GetElementFilterParametersForCategory Method

[image]

Revit 2024 API
ParameterFilterElement..::..GetElementFilterParametersForCategory Method
ParameterFilterElement Class See Also Send Feedback
Retrieves a list of the parameters associated with all rules in the filter that are combined (using logical AND) with a FilterCategoryRule corresponding to single %categoryId%.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public ISet<ElementId> GetElementFilterParametersForCategory(
    ElementId categoryId
)
Visual Basic
Public Function GetElementFilterParametersForCategory ( _
    categoryId As ElementId _
) As ISet(Of ElementId)
Visual C++
public:
ISet<ElementId^>^ GetElementFilterParametersForCategory(
    ElementId^ categoryId
)

Parameters

categoryId
Type: Autodesk.Revit.DB..::..ElementId
The category for which parameters should be found.

Return Value

A set of parameter identifiers.

Remarks

Note that in the case when InvalidElementId specified as input %categoryId% this function returns parameters common to all categories used by this ParameterFilterElement, i.e. it is equivalent to ParameterFilterElement.GetElementFilterParameters().

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterFilterElement Class


SetCategories Method

[image]

Revit 2024 API
ParameterFilterElement..::..SetCategories Method
ParameterFilterElement Class See Also Send Feedback
Sets the categories admitted by this filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public void SetCategories(
    ICollection<ElementId> categories
)
Visual Basic
Public Sub SetCategories ( _
    categories As ICollection(Of ElementId) _
)
Visual C++
public:
void SetCategories(
    ICollection<ElementId^>^ categories
)

Parameters

categories
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>

Remarks

Testing that an element's category is a member of this set is, essentially, the first rule of the filter.

Changing the set of categories will clear any rules that use parameters that are not applicable for the new set of categories.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterFilterElement Class


SetElementFilter Method

[image]

Revit 2024 API
ParameterFilterElement..::..SetElementFilter Method
ParameterFilterElement Class See Also Send Feedback
Sets the rules that must be satisfied for a given element to pass this filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public bool SetElementFilter(
    ElementFilter elementFilter
)
Visual Basic
Public Function SetElementFilter ( _
    elementFilter As ElementFilter _
) As Boolean
Visual C++
public:
bool SetElementFilter(
    ElementFilter^ elementFilter
)

Parameters

elementFilter
Type: Autodesk.Revit.DB..::..ElementFilter
An ElementFilter representing the rules. It may be an ElementParameterFilter representing a conjunction of one or more FilterRules, or an ElementLogicalFilter (of type LogicalAndFilter or LogicalOrFilter) representing a logical combination of FilterRules, using AND/OR operations.

Return Value

Returns true if this ParameterFilterElement was changed, false if not. It will not be changed if the input rules are equivalent to the ParameterFilterElement's existing rules.

Remarks

Note that in some situation, calling GetElementFilter after calling SetElementFilter may return an ElementFilter that is structurally different from the one passed as input to SetElementFilter. For example, if the input ElementFilter contains an ElementParameterFilter that contains more than one FilterRule, and if the view filters dialog box is used in between the calls to SetElementFilter and GetElementFilter, the output ElementFilter will use a single ElementParameterFilter for each of the FilterRules that were bundled in an input ElementParameterFilter. The two ElementFilters will be logically and functionally equivalent in the sense that any given Element will either be accepted by both ElementFilters or rejected by both ElementFilters.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | One of the given rules refers to a parameter that does not apply to this filter's categories.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | The ElementFilter is not acceptable for use by a ParameterFilterElement.

See Also

ParameterFilterElement Class


ParameterFilterElement Properties

[image] [image]

Revit 2024 API
ParameterFilterElement Properties
ParameterFilterElement Class See Also Send Feedback

The ParameterFilterElement type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ParameterFilterElement Class


Parameter Property

[image] [image]

Revit 2024 API
ParameterFilterElement..::..Parameter Property
ParameterFilterElement Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ParameterFilterElement Class
ParameterFilterElement Members


ParameterFilterRuleFactory Class

[image]

Revit 2024 API
ParameterFilterRuleFactory Class
Members See Also Send Feedback
Contains functions that create appropriate FilterRule objects based on the parameters given.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class ParameterFilterRuleFactory : IDisposable
Visual Basic
Public Class ParameterFilterRuleFactory _
    Implements IDisposable
Visual C++
public ref class ParameterFilterRuleFactory : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ParameterFilterRuleFactory

See Also

ParameterFilterRuleFactory Members


CreateBeginsWithRule Method

[image] [image]

Revit 2024 API
ParameterFilterRuleFactory..::..CreateBeginsWithRule Method
ParameterFilterRuleFactory Class See Also Send Feedback

Overload List

Name | Description
CreateBeginsWithRule(ElementId, String) | Creates a filter rule that determines whether strings from the document begin with a certain string value.
CreateBeginsWithRule(ElementId, String, Boolean) | Obsolete. Creates a filter rule that determines whether strings from the document begin with a certain string value.

See Also

ParameterFilterRuleFactory Class
ParameterFilterRuleFactory Members


CreateBeginsWithRule Method (ElementId, String)

[image]

Revit 2024 API
ParameterFilterRuleFactory..::..CreateBeginsWithRule Method (ElementId, String)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether strings from the document begin with a certain string value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public static FilterRule CreateBeginsWithRule(
    ElementId parameter,
    string value
)
Visual Basic
Public Shared Function CreateBeginsWithRule ( _
    parameter As ElementId, _
    value As String _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateBeginsWithRule(
    ElementId^ parameter,
    String^ value
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
A string-typed parameter used to get values from the document for a given element.
value
Type: System..::..String
The user-supplied string value for which values from the document will be searched.

Return Value

Created filter rule object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterFilterRuleFactory Class
CreateBeginsWithRule Overload


CreateBeginsWithRule Method (ElementId, String, Boolean)

[image]

Revit 2024 API
ParameterFilterRuleFactory..::..CreateBeginsWithRule Method (ElementId, String, Boolean)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether strings from the document begin with a certain string value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
[ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
public static FilterRule CreateBeginsWithRule(
    ElementId parameter,
    string value,
    bool caseSensitive
)
Visual Basic
<ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")> _
Public Shared Function CreateBeginsWithRule ( _
    parameter As ElementId, _
    value As String, _
    caseSensitive As Boolean _
) As FilterRule
Visual C++
[ObsoleteAttribute(L"This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
public:
static FilterRule^ CreateBeginsWithRule(
    ElementId^ parameter,
    String^ value,
    bool caseSensitive
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
A string-typed parameter used to get values from the document for a given element.
value
Type: System..::..String
The user-supplied string value for which values from the document will be searched.
caseSensitive
Type: System..::..Boolean
If true, the string comparison will be case-sensitive.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterFilterRuleFactory Class
CreateBeginsWithRule Overload


CreateContainsRule Method (ElementId, String)

[image]

Revit 2024 API
ParameterFilterRuleFactory..::..CreateContainsRule Method (ElementId, String)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether strings from the document contain a certain string value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public static FilterRule CreateContainsRule(
    ElementId parameter,
    string value
)
Visual Basic
Public Shared Function CreateContainsRule ( _
    parameter As ElementId, _
    value As String _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateContainsRule(
    ElementId^ parameter,
    String^ value
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
A string-typed parameter used to get values from the document for a given element.
value
Type: System..::..String
The user-supplied string value for which values from the document will be searched.

Return Value

Created filter rule object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterFilterRuleFactory Class
CreateContainsRule Overload


CreateContainsRule Method (ElementId, String, Boolean)

[image]

Revit 2024 API
ParameterFilterRuleFactory..::..CreateContainsRule Method (ElementId, String, Boolean)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether strings from the document contain a certain string value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
[ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
public static FilterRule CreateContainsRule(
    ElementId parameter,
    string value,
    bool caseSensitive
)
Visual Basic
<ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")> _
Public Shared Function CreateContainsRule ( _
    parameter As ElementId, _
    value As String, _
    caseSensitive As Boolean _
) As FilterRule
Visual C++
[ObsoleteAttribute(L"This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
public:
static FilterRule^ CreateContainsRule(
    ElementId^ parameter,
    String^ value,
    bool caseSensitive
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
A string-typed parameter used to get values from the document for a given element.
value
Type: System..::..String
The user-supplied string value for which values from the document will be searched.
caseSensitive
Type: System..::..Boolean
If true, the string comparison will be case-sensitive.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterFilterRuleFactory Class
CreateContainsRule Overload


CreateEndsWithRule Method

[image] [image]

Revit 2024 API
ParameterFilterRuleFactory..::..CreateEndsWithRule Method
ParameterFilterRuleFactory Class See Also Send Feedback

Overload List

Name | Description
CreateEndsWithRule(ElementId, String) | Creates a filter rule that determines whether strings from the document end with a certain string value.
CreateEndsWithRule(ElementId, String, Boolean) | Obsolete. Creates a filter rule that determines whether strings from the document end with a certain string value.

See Also

ParameterFilterRuleFactory Class
ParameterFilterRuleFactory Members


CreateEndsWithRule Method (ElementId, String)

[image]

Revit 2024 API
ParameterFilterRuleFactory..::..CreateEndsWithRule Method (ElementId, String)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether strings from the document end with a certain string value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public static FilterRule CreateEndsWithRule(
    ElementId parameter,
    string value
)
Visual Basic
Public Shared Function CreateEndsWithRule ( _
    parameter As ElementId, _
    value As String _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateEndsWithRule(
    ElementId^ parameter,
    String^ value
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
A string-typed parameter used to get values from the document for a given element.
value
Type: System..::..String
The user-supplied string value for which values from the document will be searched.

Return Value

Created filter rule object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterFilterRuleFactory Class
CreateEndsWithRule Overload


CreateEndsWithRule Method (ElementId, String, Boolean)

[image]

Revit 2024 API
ParameterFilterRuleFactory..::..CreateEndsWithRule Method (ElementId, String, Boolean)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether strings from the document end with a certain string value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
[ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
public static FilterRule CreateEndsWithRule(
    ElementId parameter,
    string value,
    bool caseSensitive
)
Visual Basic
<ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")> _
Public Shared Function CreateEndsWithRule ( _
    parameter As ElementId, _
    value As String, _
    caseSensitive As Boolean _
) As FilterRule
Visual C++
[ObsoleteAttribute(L"This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
public:
static FilterRule^ CreateEndsWithRule(
    ElementId^ parameter,
    String^ value,
    bool caseSensitive
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
A string-typed parameter used to get values from the document for a given element.
value
Type: System..::..String
The user-supplied string value for which values from the document will be searched.
caseSensitive
Type: System..::..Boolean
If true, the string comparison will be case-sensitive.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterFilterRuleFactory Class
CreateEndsWithRule Overload


CreateEqualsRule Method

[image] [image]

Revit 2024 API
ParameterFilterRuleFactory..::..CreateEqualsRule Method
ParameterFilterRuleFactory Class See Also Send Feedback

Overload List

Name | Description
CreateEqualsRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document equal a certain value.
CreateEqualsRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document equal a certain value.
CreateEqualsRule(ElementId, String) | Creates a filter rule that determines whether strings from the document equal a certain value.
CreateEqualsRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document equal a certain value.
CreateEqualsRule(ElementId, String, Boolean) | Obsolete. Creates a filter rule that determines whether strings from the document equal a certain value.

See Also

ParameterFilterRuleFactory Class
ParameterFilterRuleFactory Members


CreateEqualsRule Method (ElementId, ElementId)

[image]

Revit 2024 API
ParameterFilterRuleFactory..::..CreateEqualsRule Method (ElementId, ElementId)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether ElementId values from the document equal a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static FilterRule CreateEqualsRule(
    ElementId parameter,
    ElementId value
)
Visual Basic
Public Shared Function CreateEqualsRule ( _
    parameter As ElementId, _
    value As ElementId _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateEqualsRule(
    ElementId^ parameter,
    ElementId^ value
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
An ElementId-typed parameter used to get values from the document for a given element.
value
Type: Autodesk.Revit.DB..::..ElementId
The user-supplied value against which values from the document will be compared.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterFilterRuleFactory Class
CreateEqualsRule Overload


CreateEqualsRule Method (ElementId, Int32)

[image]

Revit 2024 API
ParameterFilterRuleFactory..::..CreateEqualsRule Method (ElementId, Int32)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether integer values from the document equal a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static FilterRule CreateEqualsRule(
    ElementId parameter,
    int value
)
Visual Basic
Public Shared Function CreateEqualsRule ( _
    parameter As ElementId, _
    value As Integer _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateEqualsRule(
    ElementId^ parameter,
    int value
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
An integer-typed parameter used to get values from the document for a given element.
value
Type: System..::..Int32
The user-supplied value against which values from the document will be compared.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterFilterRuleFactory Class
CreateEqualsRule Overload


CreateEqualsRule Method (ElementId, String)

[image]

Revit 2024 API
ParameterFilterRuleFactory..::..CreateEqualsRule Method (ElementId, String)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether strings from the document equal a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public static FilterRule CreateEqualsRule(
    ElementId parameter,
    string value
)
Visual Basic
Public Shared Function CreateEqualsRule ( _
    parameter As ElementId, _
    value As String _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateEqualsRule(
    ElementId^ parameter,
    String^ value
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
A string-typed parameter used to get values from the document for a given element.
value
Type: System..::..String
The user-supplied string value against which values from the document will be compared.

Return Value

Created filter rule object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterFilterRuleFactory Class
CreateEqualsRule Overload


CreateEqualsRule Method (ElementId, Double, Double)

[image]

Revit 2024 API
ParameterFilterRuleFactory..::..CreateEqualsRule Method (ElementId, Double, Double)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether double-precision values from the document equal a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static FilterRule CreateEqualsRule(
    ElementId parameter,
    double value,
    double epsilon
)
Visual Basic
Public Shared Function CreateEqualsRule ( _
    parameter As ElementId, _
    value As Double, _
    epsilon As Double _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateEqualsRule(
    ElementId^ parameter,
    double value,
    double epsilon
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
A double-typed parameter used to get values from the document for a given element.
value
Type: System..::..Double
The user-supplied value against which values from the document will be compared.
epsilon
Type: System..::..Double
Defines the tolerance within which two values may be considered equal.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for value is not finite -or- The given value for value is not a number -or- The given value for epsilon is not finite -or- The given value for epsilon is not a number
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterFilterRuleFactory Class
CreateEqualsRule Overload


CreateEqualsRule Method (ElementId, String, Boolean)

[image]

Revit 2024 API
ParameterFilterRuleFactory..::..CreateEqualsRule Method (ElementId, String, Boolean)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether strings from the document equal a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
[ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
public static FilterRule CreateEqualsRule(
    ElementId parameter,
    string value,
    bool caseSensitive
)
Visual Basic
<ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")> _
Public Shared Function CreateEqualsRule ( _
    parameter As ElementId, _
    value As String, _
    caseSensitive As Boolean _
) As FilterRule
Visual C++
[ObsoleteAttribute(L"This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
public:
static FilterRule^ CreateEqualsRule(
    ElementId^ parameter,
    String^ value,
    bool caseSensitive
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
A string-typed parameter used to get values from the document for a given element.
value
Type: System..::..String
The user-supplied string value against which values from the document will be compared.
caseSensitive
Type: System..::..Boolean
If true, the string comparison will be case-sensitive.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterFilterRuleFactory Class
CreateEqualsRule Overload


CreateGreaterOrEqualRule Method

[image] [image]

Revit 2024 API
ParameterFilterRuleFactory..::..CreateGreaterOrEqualRule Method
ParameterFilterRuleFactory Class See Also Send Feedback

Overload List

Name | Description
CreateGreaterOrEqualRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document are greater than or equal to a certain value.
CreateGreaterOrEqualRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document are greater than or equal to a certain value.
CreateGreaterOrEqualRule(ElementId, String) | Creates a filter rule that determines whether strings from the document are greater than or equal to a certain value.
CreateGreaterOrEqualRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document are greater than or equal to a certain value.
CreateGreaterOrEqualRule(ElementId, String, Boolean) | Obsolete. Creates a filter rule that determines whether strings from the document are greater than or equal to a certain value.

See Also

ParameterFilterRuleFactory Class
ParameterFilterRuleFactory Members


CreateGreaterOrEqualRule Method (ElementId, ElementId)

[image]

Revit 2024 API
ParameterFilterRuleFactory..::..CreateGreaterOrEqualRule Method (ElementId, ElementId)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether ElementId values from the document are greater than or equal to a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static FilterRule CreateGreaterOrEqualRule(
    ElementId parameter,
    ElementId value
)
Visual Basic
Public Shared Function CreateGreaterOrEqualRule ( _
    parameter As ElementId, _
    value As ElementId _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateGreaterOrEqualRule(
    ElementId^ parameter,
    ElementId^ value
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
An ElementId-typed parameter used to get values from the document for a given element.
value
Type: Autodesk.Revit.DB..::..ElementId
The user-supplied value against which values from the document will be compared.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterFilterRuleFactory Class
CreateGreaterOrEqualRule Overload


CreateGreaterOrEqualRule Method (ElementId, Int32)

[image]

Revit 2024 API
ParameterFilterRuleFactory..::..CreateGreaterOrEqualRule Method (ElementId, Int32)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether integer values from the document are greater than or equal to a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static FilterRule CreateGreaterOrEqualRule(
    ElementId parameter,
    int value
)
Visual Basic
Public Shared Function CreateGreaterOrEqualRule ( _
    parameter As ElementId, _
    value As Integer _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateGreaterOrEqualRule(
    ElementId^ parameter,
    int value
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
An integer-typed parameter used to get values from the document for a given element.
value
Type: System..::..Int32
The user-supplied value against which values from the document will be compared.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterFilterRuleFactory Class
CreateGreaterOrEqualRule Overload


CreateGreaterOrEqualRule Method (ElementId, Double, Double)

[image]

Revit 2024 API
ParameterFilterRuleFactory..::..CreateGreaterOrEqualRule Method (ElementId, Double, Double)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether double-precision values from the document are greater than or equal to a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static FilterRule CreateGreaterOrEqualRule(
    ElementId parameter,
    double value,
    double epsilon
)
Visual Basic
Public Shared Function CreateGreaterOrEqualRule ( _
    parameter As ElementId, _
    value As Double, _
    epsilon As Double _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateGreaterOrEqualRule(
    ElementId^ parameter,
    double value,
    double epsilon
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
A double-typed parameter used to get values from the document for a given element.
value
Type: System..::..Double
The user-supplied value against which values from the document will be compared.
epsilon
Type: System..::..Double
Defines the tolerance within which two values may be considered equal.

Remarks

Values less than the user-supplied value but within epsilon are considered equal; therefore, such values satisfy the condition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for value is not finite -or- The given value for value is not a number -or- The given value for epsilon is not finite -or- The given value for epsilon is not a number
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterFilterRuleFactory Class
CreateGreaterOrEqualRule Overload


CreateGreaterOrEqualRule Method (ElementId, String, Boolean)

[image]

Revit 2024 API
ParameterFilterRuleFactory..::..CreateGreaterOrEqualRule Method (ElementId, String, Boolean)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether strings from the document are greater than or equal to a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
[ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
public static FilterRule CreateGreaterOrEqualRule(
    ElementId parameter,
    string value,
    bool caseSensitive
)
Visual Basic
<ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")> _
Public Shared Function CreateGreaterOrEqualRule ( _
    parameter As ElementId, _
    value As String, _
    caseSensitive As Boolean _
) As FilterRule
Visual C++
[ObsoleteAttribute(L"This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
public:
static FilterRule^ CreateGreaterOrEqualRule(
    ElementId^ parameter,
    String^ value,
    bool caseSensitive
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
A string-typed parameter used to get values from the document for a given element.
value
Type: System..::..String
The user-supplied string value against which values from the document will be compared.
caseSensitive
Type: System..::..Boolean
If true, the string comparison will be case-sensitive.

Remarks

For strings, a value is "greater" than another if it would appear after the other in an alphabetically-sorted list.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterFilterRuleFactory Class
CreateGreaterOrEqualRule Overload


CreateGreaterRule Method

[image] [image]

Revit 2024 API
ParameterFilterRuleFactory..::..CreateGreaterRule Method
ParameterFilterRuleFactory Class See Also Send Feedback

Overload List

Name | Description
CreateGreaterRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document are greater than a certain value.
CreateGreaterRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document are greater than a certain value.
CreateGreaterRule(ElementId, String) | Creates a filter rule that determines whether strings from the document are greater than a certain value.
CreateGreaterRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document are greater than a certain value.
CreateGreaterRule(ElementId, String, Boolean) | Obsolete. Creates a filter rule that determines whether strings from the document are greater than a certain value.

See Also

ParameterFilterRuleFactory Class
ParameterFilterRuleFactory Members


CreateGreaterRule Method (ElementId, ElementId)

[image]

Revit 2024 API
ParameterFilterRuleFactory..::..CreateGreaterRule Method (ElementId, ElementId)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether ElementId values from the document are greater than a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static FilterRule CreateGreaterRule(
    ElementId parameter,
    ElementId value
)
Visual Basic
Public Shared Function CreateGreaterRule ( _
    parameter As ElementId, _
    value As ElementId _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateGreaterRule(
    ElementId^ parameter,
    ElementId^ value
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
An ElementId-typed parameter used to get values from the document for a given element.
value
Type: Autodesk.Revit.DB..::..ElementId
The user-supplied value against which values from the document will be compared.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterFilterRuleFactory Class
CreateGreaterRule Overload


CreateGreaterRule Method (ElementId, Int32)

[image]

Revit 2024 API
ParameterFilterRuleFactory..::..CreateGreaterRule Method (ElementId, Int32)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether integer values from the document are greater than a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static FilterRule CreateGreaterRule(
    ElementId parameter,
    int value
)
Visual Basic
Public Shared Function CreateGreaterRule ( _
    parameter As ElementId, _
    value As Integer _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateGreaterRule(
    ElementId^ parameter,
    int value
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
An integer-typed parameter used to get values from the document for a given element.
value
Type: System..::..Int32
The user-supplied value against which values from the document will be compared.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterFilterRuleFactory Class
CreateGreaterRule Overload


CreateGreaterRule Method (ElementId, String)

[image]

Revit 2024 API
ParameterFilterRuleFactory..::..CreateGreaterRule Method (ElementId, String)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether strings from the document are greater than a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public static FilterRule CreateGreaterRule(
    ElementId parameter,
    string value
)
Visual Basic
Public Shared Function CreateGreaterRule ( _
    parameter As ElementId, _
    value As String _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateGreaterRule(
    ElementId^ parameter,
    String^ value
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
A string-typed parameter used to get values from the document for a given element.
value
Type: System..::..String
The user-supplied string value against which values from the document will be compared.

Return Value

Created filter rule object.

Remarks

For strings, a value is "greater" than another if it would appear after the other in an alphabetically-sorted list.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterFilterRuleFactory Class
CreateGreaterRule Overload


CreateGreaterRule Method (ElementId, Double, Double)

[image]

Revit 2024 API
ParameterFilterRuleFactory..::..CreateGreaterRule Method (ElementId, Double, Double)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether double-precision values from the document are greater than a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static FilterRule CreateGreaterRule(
    ElementId parameter,
    double value,
    double epsilon
)
Visual Basic
Public Shared Function CreateGreaterRule ( _
    parameter As ElementId, _
    value As Double, _
    epsilon As Double _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateGreaterRule(
    ElementId^ parameter,
    double value,
    double epsilon
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
A double-typed parameter used to get values from the document for a given element.
value
Type: System..::..Double
The user-supplied value against which values from the document will be compared.
epsilon
Type: System..::..Double
Defines the tolerance within which two values may be considered equal.

Remarks

Values greater than value but within epsilon are considered equal, not greater.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for value is not finite -or- The given value for value is not a number -or- The given value for epsilon is not finite -or- The given value for epsilon is not a number
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterFilterRuleFactory Class
CreateGreaterRule Overload


CreateGreaterRule Method (ElementId, String, Boolean)

[image]

Revit 2024 API
ParameterFilterRuleFactory..::..CreateGreaterRule Method (ElementId, String, Boolean)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether strings from the document are greater than a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
[ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
public static FilterRule CreateGreaterRule(
    ElementId parameter,
    string value,
    bool caseSensitive
)
Visual Basic
<ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")> _
Public Shared Function CreateGreaterRule ( _
    parameter As ElementId, _
    value As String, _
    caseSensitive As Boolean _
) As FilterRule
Visual C++
[ObsoleteAttribute(L"This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
public:
static FilterRule^ CreateGreaterRule(
    ElementId^ parameter,
    String^ value,
    bool caseSensitive
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
A string-typed parameter used to get values from the document for a given element.
value
Type: System..::..String
The user-supplied string value against which values from the document will be compared.
caseSensitive
Type: System..::..Boolean
If true, the string comparison will be case-sensitive.

Remarks

For strings, a value is "greater" than another if it would appear after the other in an alphabetically-sorted list.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterFilterRuleFactory Class
CreateGreaterRule Overload


CreateHasNoValueParameterRule Method

[image]

Revit 2024 API
ParameterFilterRuleFactory..::..CreateHasNoValueParameterRule Method
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether an element's parameter does not have a value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public static FilterRule CreateHasNoValueParameterRule(
    ElementId parameter
)
Visual Basic
Public Shared Function CreateHasNoValueParameterRule ( _
    parameter As ElementId _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateHasNoValueParameterRule(
    ElementId^ parameter
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
The parameter to be evaluated by the filter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterFilterRuleFactory Class


CreateIsNotAssociatedWithGlobalParameterRule Method

[image]

Revit 2024 API
ParameterFilterRuleFactory..::..CreateIsNotAssociatedWithGlobalParameterRule Method
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether a parameter is not associated with a certain global parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static FilterRule CreateIsNotAssociatedWithGlobalParameterRule(
    ElementId parameter,
    ElementId value
)
Visual Basic
Public Shared Function CreateIsNotAssociatedWithGlobalParameterRule ( _
    parameter As ElementId, _
    value As ElementId _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateIsNotAssociatedWithGlobalParameterRule(
    ElementId^ parameter,
    ElementId^ value
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
A parameter that can be associated with an existing global parameter of a compatible type.
value
Type: Autodesk.Revit.DB..::..ElementId
The global parameter used to test the association.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterFilterRuleFactory Class


CreateLessOrEqualRule Method

[image] [image]

Revit 2024 API
ParameterFilterRuleFactory..::..CreateLessOrEqualRule Method
ParameterFilterRuleFactory Class See Also Send Feedback

Overload List

Name | Description
CreateLessOrEqualRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document are less than or equal to a certain value.
CreateLessOrEqualRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document are less than or equal to a certain value.
CreateLessOrEqualRule(ElementId, String) | Creates a filter rule that determines whether strings from the document are less than or equal to a certain value.
CreateLessOrEqualRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document are less than or equal to a certain value.
CreateLessOrEqualRule(ElementId, String, Boolean) | Obsolete. Creates a filter rule that determines whether strings from the document are less than or equal to a certain value.

See Also

ParameterFilterRuleFactory Class
ParameterFilterRuleFactory Members


CreateLessOrEqualRule Method (ElementId, ElementId)

[image]

Revit 2024 API
ParameterFilterRuleFactory..::..CreateLessOrEqualRule Method (ElementId, ElementId)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether ElementId values from the document are less than or equal to a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static FilterRule CreateLessOrEqualRule(
    ElementId parameter,
    ElementId value
)
Visual Basic
Public Shared Function CreateLessOrEqualRule ( _
    parameter As ElementId, _
    value As ElementId _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateLessOrEqualRule(
    ElementId^ parameter,
    ElementId^ value
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
An ElementId-typed parameter used to get values from the document for a given element.
value
Type: Autodesk.Revit.DB..::..ElementId
The user-supplied value against which values from the document will be compared.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterFilterRuleFactory Class
CreateLessOrEqualRule Overload


CreateLessOrEqualRule Method (ElementId, Int32)

[image]

Revit 2024 API
ParameterFilterRuleFactory..::..CreateLessOrEqualRule Method (ElementId, Int32)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether integer values from the document are less than or equal to a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static FilterRule CreateLessOrEqualRule(
    ElementId parameter,
    int value
)
Visual Basic
Public Shared Function CreateLessOrEqualRule ( _
    parameter As ElementId, _
    value As Integer _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateLessOrEqualRule(
    ElementId^ parameter,
    int value
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
An integer-typed parameter used to get values from the document for a given element.
value
Type: System..::..Int32
The user-supplied value against which values from the document will be compared.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterFilterRuleFactory Class
CreateLessOrEqualRule Overload


CreateLessOrEqualRule Method (ElementId, Double, Double)

[image]

Revit 2024 API
ParameterFilterRuleFactory..::..CreateLessOrEqualRule Method (ElementId, Double, Double)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether double-precision values from the document are less than or equal to a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static FilterRule CreateLessOrEqualRule(
    ElementId parameter,
    double value,
    double epsilon
)
Visual Basic
Public Shared Function CreateLessOrEqualRule ( _
    parameter As ElementId, _
    value As Double, _
    epsilon As Double _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateLessOrEqualRule(
    ElementId^ parameter,
    double value,
    double epsilon
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
A double-typed parameter used to get values from the document for a given element.
value
Type: System..::..Double
The user-supplied value against which values from the document will be compared.
epsilon
Type: System..::..Double
Defines the tolerance within which two values may be considered equal.

Remarks

Values greater than the user-supplied value but within epsilon are considered equal; therefore, such values satisfy the condition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for value is not finite -or- The given value for value is not a number -or- The given value for epsilon is not finite -or- The given value for epsilon is not a number
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterFilterRuleFactory Class
CreateLessOrEqualRule Overload


CreateLessOrEqualRule Method (ElementId, String, Boolean)

[image]

Revit 2024 API
ParameterFilterRuleFactory..::..CreateLessOrEqualRule Method (ElementId, String, Boolean)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether strings from the document are less than or equal to a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
[ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
public static FilterRule CreateLessOrEqualRule(
    ElementId parameter,
    string value,
    bool caseSensitive
)
Visual Basic
<ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")> _
Public Shared Function CreateLessOrEqualRule ( _
    parameter As ElementId, _
    value As String, _
    caseSensitive As Boolean _
) As FilterRule
Visual C++
[ObsoleteAttribute(L"This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
public:
static FilterRule^ CreateLessOrEqualRule(
    ElementId^ parameter,
    String^ value,
    bool caseSensitive
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
A string-typed parameter used to get values from the document for a given element.
value
Type: System..::..String
The user-supplied string value against which values from the document will be compared.
caseSensitive
Type: System..::..Boolean
If true, the string comparison will be case-sensitive.

Remarks

For strings, a value is "less" than another if it would appear before the other in an alphabetically-sorted list.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterFilterRuleFactory Class
CreateLessOrEqualRule Overload


CreateLessRule Method (ElementId, ElementId)

[image]

Revit 2024 API
ParameterFilterRuleFactory..::..CreateLessRule Method (ElementId, ElementId)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether ElementId values from the document are less than a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static FilterRule CreateLessRule(
    ElementId parameter,
    ElementId value
)
Visual Basic
Public Shared Function CreateLessRule ( _
    parameter As ElementId, _
    value As ElementId _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateLessRule(
    ElementId^ parameter,
    ElementId^ value
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
An ElementId-typed parameter used to get values from the document for a given element.
value
Type: Autodesk.Revit.DB..::..ElementId
The user-supplied value against which values from the document will be compared.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterFilterRuleFactory Class
CreateLessRule Overload


CreateLessRule Method (ElementId, Int32)

[image]

Revit 2024 API
ParameterFilterRuleFactory..::..CreateLessRule Method (ElementId, Int32)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether integer values from the document are less than a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static FilterRule CreateLessRule(
    ElementId parameter,
    int value
)
Visual Basic
Public Shared Function CreateLessRule ( _
    parameter As ElementId, _
    value As Integer _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateLessRule(
    ElementId^ parameter,
    int value
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
An integer-typed parameter used to get values from the document for a given element.
value
Type: System..::..Int32
The user-supplied value against which values from the document will be compared.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterFilterRuleFactory Class
CreateLessRule Overload


CreateLessRule Method (ElementId, String)

[image]

Revit 2024 API
ParameterFilterRuleFactory..::..CreateLessRule Method (ElementId, String)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether strings from the document are less than a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public static FilterRule CreateLessRule(
    ElementId parameter,
    string value
)
Visual Basic
Public Shared Function CreateLessRule ( _
    parameter As ElementId, _
    value As String _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateLessRule(
    ElementId^ parameter,
    String^ value
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
A string-typed parameter used to get values from the document for a given element.
value
Type: System..::..String
The user-supplied string value against which values from the document will be compared.

Return Value

Created filter rule object.

Remarks

For strings, a value is "less" than another if it would appear before the other in an alphabetically-sorted list.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterFilterRuleFactory Class
CreateLessRule Overload


CreateLessRule Method (ElementId, String, Boolean)

[image]

Revit 2024 API
ParameterFilterRuleFactory..::..CreateLessRule Method (ElementId, String, Boolean)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether strings from the document are less than a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
[ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
public static FilterRule CreateLessRule(
    ElementId parameter,
    string value,
    bool caseSensitive
)
Visual Basic
<ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")> _
Public Shared Function CreateLessRule ( _
    parameter As ElementId, _
    value As String, _
    caseSensitive As Boolean _
) As FilterRule
Visual C++
[ObsoleteAttribute(L"This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
public:
static FilterRule^ CreateLessRule(
    ElementId^ parameter,
    String^ value,
    bool caseSensitive
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
A string-typed parameter used to get values from the document for a given element.
value
Type: System..::..String
The user-supplied string value against which values from the document will be compared.
caseSensitive
Type: System..::..Boolean
If true, the string comparison will be case-sensitive.

Remarks

For strings, a value is "less" than another if it would appear before the other in an alphabetically-sorted list.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterFilterRuleFactory Class
CreateLessRule Overload


CreateNotBeginsWithRule Method

[image] [image]

Revit 2024 API
ParameterFilterRuleFactory..::..CreateNotBeginsWithRule Method
ParameterFilterRuleFactory Class See Also Send Feedback

Overload List

Name | Description
CreateNotBeginsWithRule(ElementId, String) | Creates a filter rule that determines whether strings from the document do not begin with a certain string value.
CreateNotBeginsWithRule(ElementId, String, Boolean) | Obsolete. Creates a filter rule that determines whether strings from the document do not begin with a certain string value.

See Also

ParameterFilterRuleFactory Class
ParameterFilterRuleFactory Members


CreateNotBeginsWithRule Method (ElementId, String)

[image]

Revit 2024 API
ParameterFilterRuleFactory..::..CreateNotBeginsWithRule Method (ElementId, String)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether strings from the document do not begin with a certain string value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public static FilterRule CreateNotBeginsWithRule(
    ElementId parameter,
    string value
)
Visual Basic
Public Shared Function CreateNotBeginsWithRule ( _
    parameter As ElementId, _
    value As String _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateNotBeginsWithRule(
    ElementId^ parameter,
    String^ value
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
A string-typed parameter used to get values from the document for a given element.
value
Type: System..::..String
The user-supplied string value for which values from the document will be searched.

Return Value

Created filter rule object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterFilterRuleFactory Class
CreateNotBeginsWithRule Overload


CreateNotBeginsWithRule Method (ElementId, String, Boolean)

[image]

Revit 2024 API
ParameterFilterRuleFactory..::..CreateNotBeginsWithRule Method (ElementId, String, Boolean)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether strings from the document do not begin with a certain string value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
[ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
public static FilterRule CreateNotBeginsWithRule(
    ElementId parameter,
    string value,
    bool caseSensitive
)
Visual Basic
<ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")> _
Public Shared Function CreateNotBeginsWithRule ( _
    parameter As ElementId, _
    value As String, _
    caseSensitive As Boolean _
) As FilterRule
Visual C++
[ObsoleteAttribute(L"This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
public:
static FilterRule^ CreateNotBeginsWithRule(
    ElementId^ parameter,
    String^ value,
    bool caseSensitive
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
A string-typed parameter used to get values from the document for a given element.
value
Type: System..::..String
The user-supplied string value for which values from the document will be searched.
caseSensitive
Type: System..::..Boolean
If true, the string comparison will be case-sensitive.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterFilterRuleFactory Class
CreateNotBeginsWithRule Overload


CreateNotContainsRule Method

[image] [image]

Revit 2024 API
ParameterFilterRuleFactory..::..CreateNotContainsRule Method
ParameterFilterRuleFactory Class See Also Send Feedback

Overload List

Name | Description
CreateNotContainsRule(ElementId, String) | Creates a filter rule that determines whether strings from the document do not contain a certain string value.
CreateNotContainsRule(ElementId, String, Boolean) | Obsolete. Creates a filter rule that determines whether strings from the document do not contain a certain string value.

See Also

ParameterFilterRuleFactory Class
ParameterFilterRuleFactory Members


CreateNotContainsRule Method (ElementId, String)

[image]

Revit 2024 API
ParameterFilterRuleFactory..::..CreateNotContainsRule Method (ElementId, String)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether strings from the document do not contain a certain string value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public static FilterRule CreateNotContainsRule(
    ElementId parameter,
    string value
)
Visual Basic
Public Shared Function CreateNotContainsRule ( _
    parameter As ElementId, _
    value As String _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateNotContainsRule(
    ElementId^ parameter,
    String^ value
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
A string-typed parameter used to get values from the document for a given element.
value
Type: System..::..String
The user-supplied string value for which values from the document will be searched.

Return Value

Created filter rule object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterFilterRuleFactory Class
CreateNotContainsRule Overload


CreateNotContainsRule Method (ElementId, String, Boolean)

[image]

Revit 2024 API
ParameterFilterRuleFactory..::..CreateNotContainsRule Method (ElementId, String, Boolean)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether strings from the document do not contain a certain string value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
[ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
public static FilterRule CreateNotContainsRule(
    ElementId parameter,
    string value,
    bool caseSensitive
)
Visual Basic
<ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")> _
Public Shared Function CreateNotContainsRule ( _
    parameter As ElementId, _
    value As String, _
    caseSensitive As Boolean _
) As FilterRule
Visual C++
[ObsoleteAttribute(L"This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
public:
static FilterRule^ CreateNotContainsRule(
    ElementId^ parameter,
    String^ value,
    bool caseSensitive
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
A string-typed parameter used to get values from the document for a given element.
value
Type: System..::..String
The user-supplied string value for which values from the document will be searched.
caseSensitive
Type: System..::..Boolean
If true, the string comparison will be case-sensitive.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterFilterRuleFactory Class
CreateNotContainsRule Overload


CreateNotEndsWithRule Method

[image] [image]

Revit 2024 API
ParameterFilterRuleFactory..::..CreateNotEndsWithRule Method
ParameterFilterRuleFactory Class See Also Send Feedback

Overload List

Name | Description
CreateNotEndsWithRule(ElementId, String) | Creates a filter rule that determines whether strings from the document do not end with a certain string value.
CreateNotEndsWithRule(ElementId, String, Boolean) | Obsolete. Creates a filter rule that determines whether strings from the document do not end with a certain string value.

See Also

ParameterFilterRuleFactory Class
ParameterFilterRuleFactory Members


CreateNotEndsWithRule Method (ElementId, String, Boolean)

[image]

Revit 2024 API
ParameterFilterRuleFactory..::..CreateNotEndsWithRule Method (ElementId, String, Boolean)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether strings from the document do not end with a certain string value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
[ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
public static FilterRule CreateNotEndsWithRule(
    ElementId parameter,
    string value,
    bool caseSensitive
)
Visual Basic
<ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")> _
Public Shared Function CreateNotEndsWithRule ( _
    parameter As ElementId, _
    value As String, _
    caseSensitive As Boolean _
) As FilterRule
Visual C++
[ObsoleteAttribute(L"This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
public:
static FilterRule^ CreateNotEndsWithRule(
    ElementId^ parameter,
    String^ value,
    bool caseSensitive
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
A string-typed parameter used to get values from the document for a given element.
value
Type: System..::..String
The user-supplied string value for which values from the document will be searched.
caseSensitive
Type: System..::..Boolean
If true, the string comparison will be case-sensitive.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterFilterRuleFactory Class
CreateNotEndsWithRule Overload


CreateNotEqualsRule Method

[image] [image]

Revit 2024 API
ParameterFilterRuleFactory..::..CreateNotEqualsRule Method
ParameterFilterRuleFactory Class See Also Send Feedback

Overload List

Name | Description
CreateNotEqualsRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document do not equal a certain value.
CreateNotEqualsRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document do not equal a certain value.
CreateNotEqualsRule(ElementId, String) | Creates a filter rule that determines whether strings from the document do not equal a certain value.
CreateNotEqualsRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document do not equal a certain value.
CreateNotEqualsRule(ElementId, String, Boolean) | Obsolete. Creates a filter rule that determines whether strings from the document do not equal a certain value.

See Also

ParameterFilterRuleFactory Class
ParameterFilterRuleFactory Members


CreateNotEqualsRule Method (ElementId, Int32)

[image]

Revit 2024 API
ParameterFilterRuleFactory..::..CreateNotEqualsRule Method (ElementId, Int32)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether integer values from the document do not equal a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static FilterRule CreateNotEqualsRule(
    ElementId parameter,
    int value
)
Visual Basic
Public Shared Function CreateNotEqualsRule ( _
    parameter As ElementId, _
    value As Integer _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateNotEqualsRule(
    ElementId^ parameter,
    int value
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
An integer-typed parameter used to get values from the document for a given element.
value
Type: System..::..Int32
The user-supplied value against which values from the document will be compared.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterFilterRuleFactory Class
CreateNotEqualsRule Overload


CreateNotEqualsRule Method (ElementId, Double, Double)

[image]

Revit 2024 API
ParameterFilterRuleFactory..::..CreateNotEqualsRule Method (ElementId, Double, Double)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether double-precision values from the document do not equal a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static FilterRule CreateNotEqualsRule(
    ElementId parameter,
    double value,
    double epsilon
)
Visual Basic
Public Shared Function CreateNotEqualsRule ( _
    parameter As ElementId, _
    value As Double, _
    epsilon As Double _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateNotEqualsRule(
    ElementId^ parameter,
    double value,
    double epsilon
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
A double-typed parameter used to get values from the document for a given element.
value
Type: System..::..Double
The user-supplied value against which values from the document will be compared.
epsilon
Type: System..::..Double
Defines the tolerance within which two values may be considered equal.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for value is not finite -or- The given value for value is not a number -or- The given value for epsilon is not finite -or- The given value for epsilon is not a number
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterFilterRuleFactory Class
CreateNotEqualsRule Overload


CreateNotEqualsRule Method (ElementId, String, Boolean)

[image]

Revit 2024 API
ParameterFilterRuleFactory..::..CreateNotEqualsRule Method (ElementId, String, Boolean)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether strings from the document do not equal a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
[ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
public static FilterRule CreateNotEqualsRule(
    ElementId parameter,
    string value,
    bool caseSensitive
)
Visual Basic
<ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")> _
Public Shared Function CreateNotEqualsRule ( _
    parameter As ElementId, _
    value As String, _
    caseSensitive As Boolean _
) As FilterRule
Visual C++
[ObsoleteAttribute(L"This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
public:
static FilterRule^ CreateNotEqualsRule(
    ElementId^ parameter,
    String^ value,
    bool caseSensitive
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
A string-typed parameter used to get values from the document for a given element.
value
Type: System..::..String
The user-supplied string value against which values from the document will be compared.
caseSensitive
Type: System..::..Boolean
If true, the string comparison will be case-sensitive.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterFilterRuleFactory Class
CreateNotEqualsRule Overload


CreateSharedParameterApplicableRule Method

[image]

Revit 2024 API
ParameterFilterRuleFactory..::..CreateSharedParameterApplicableRule Method
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that tests elements for support of a shared parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static FilterRule CreateSharedParameterApplicableRule(
    string parameterName
)
Visual Basic
Public Shared Function CreateSharedParameterApplicableRule ( _
    parameterName As String _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateSharedParameterApplicableRule(
    String^ parameterName
)

Parameters

parameterName
Type: System..::..String
The name of the parameter that elements must support to satisfy this rule.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterFilterRuleFactory Class


ParameterFilterRuleFactory Properties

[image] [image]

Revit 2024 API
ParameterFilterRuleFactory Properties
ParameterFilterRuleFactory Class See Also Send Feedback

The ParameterFilterRuleFactory type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ParameterFilterRuleFactory Class


IsValidObject Property

[image]

Revit 2024 API
ParameterFilterRuleFactory..::..IsValidObject Property
ParameterFilterRuleFactory Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ParameterFilterRuleFactory Class


ParameterFilterUtilities Class

[image]

Revit 2024 API
ParameterFilterUtilities Class
Members See Also Send Feedback
Contains static utility functions for enumerating the categories and parameters that are available for use by ParameterFilterElement objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static class ParameterFilterUtilities
Visual Basic
Public NotInheritable Class ParameterFilterUtilities
Visual C++
public ref class ParameterFilterUtilities abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ParameterFilterUtilities

See Also

ParameterFilterUtilities Members


ParameterFilterUtilities Members

[image] [image]

Revit 2024 API
ParameterFilterUtilities Members
ParameterFilterUtilities Class Methods See Also Send Feedback

The ParameterFilterUtilities type exposes the following members.

Methods

Name | Description
GetAllFilterableCategories | Returns the set of categories that may be used in a ParameterFilterElement.
GetFilterableParametersInCommon | Returns the filterable parameters common to the given categories.
GetInapplicableParameters | Returns the parameters that are not among the set of filterable parameters common to the given categories.
IsParameterApplicable | Used to determine whether the element supports the given parameter.
RemoveUnfilterableCategories | Removes from the given set the categories that are not filterable.

See Also

ParameterFilterUtilities Class


ParameterFilterUtilities Methods

[image] [image]

Revit 2024 API
ParameterFilterUtilities Methods
ParameterFilterUtilities Class See Also Send Feedback

The ParameterFilterUtilities type exposes the following members.

Methods

Name | Description
GetAllFilterableCategories | Returns the set of categories that may be used in a ParameterFilterElement.
GetFilterableParametersInCommon | Returns the filterable parameters common to the given categories.
GetInapplicableParameters | Returns the parameters that are not among the set of filterable parameters common to the given categories.
IsParameterApplicable | Used to determine whether the element supports the given parameter.
RemoveUnfilterableCategories | Removes from the given set the categories that are not filterable.

See Also

ParameterFilterUtilities Class


GetAllFilterableCategories Method

[image]

Revit 2024 API
ParameterFilterUtilities..::..GetAllFilterableCategories Method
ParameterFilterUtilities Class See Also Send Feedback
Returns the set of categories that may be used in a ParameterFilterElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static ICollection<ElementId> GetAllFilterableCategories()
Visual Basic
Public Shared Function GetAllFilterableCategories As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetAllFilterableCategories()

Return Value

The set of all filterable categories.

See Also

ParameterFilterUtilities Class


GetFilterableParametersInCommon Method

[image]

Revit 2024 API
ParameterFilterUtilities..::..GetFilterableParametersInCommon Method
ParameterFilterUtilities Class See Also Send Feedback
Returns the filterable parameters common to the given categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static ICollection<ElementId> GetFilterableParametersInCommon(
    Document aDoc,
    ICollection<ElementId> categories
)
Visual Basic
Public Shared Function GetFilterableParametersInCommon ( _
    aDoc As Document, _
    categories As ICollection(Of ElementId) _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetFilterableParametersInCommon(
    Document^ aDoc,
    ICollection<ElementId^>^ categories
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
The document containing the categories and parameters to query.
categories
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
The categories for which to determine the common parameters.

Return Value

The set of filterable parameters common to the given categories.

Remarks

A filterable category in Revit has a set of filterable parameters. The filterable parameters common to a set of categories is the intersection of all these filterable parameter sets.

This set defines the set of parameters that may be used to define a rule on a ParameterFilterElement with a certain set of categories.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterFilterUtilities Class


GetInapplicableParameters Method

[image]

Revit 2024 API
ParameterFilterUtilities..::..GetInapplicableParameters Method
ParameterFilterUtilities Class See Also Send Feedback
Returns the parameters that are not among the set of filterable parameters common to the given categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static IList<ElementId> GetInapplicableParameters(
    Document aDoc,
    ICollection<ElementId> categories,
    IList<ElementId> parameters
)
Visual Basic
Public Shared Function GetInapplicableParameters ( _
    aDoc As Document, _
    categories As ICollection(Of ElementId), _
    parameters As IList(Of ElementId) _
) As IList(Of ElementId)
Visual C++
public:
static IList<ElementId^>^ GetInapplicableParameters(
    Document^ aDoc,
    ICollection<ElementId^>^ categories,
    IList<ElementId^>^ parameters
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
The document containing the categories and parameters to query.
categories
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
The categories that define the set of possibly filterable parameters.
parameters
Type: System.Collections.Generic..::..IList<(Of <(<' ElementId >)>)>
The parameters desired for use in a parameter filter.

Return Value

A list of parameters from the given array that are not valid for use in a parameter filter with the given categories.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterFilterUtilities Class


IsParameterApplicable Method

[image]

Revit 2024 API
ParameterFilterUtilities..::..IsParameterApplicable Method
ParameterFilterUtilities Class See Also Send Feedback
Used to determine whether the element supports the given parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static bool IsParameterApplicable(
    Element element,
    ElementId parameter
)
Visual Basic
Public Shared Function IsParameterApplicable ( _
    element As Element, _
    parameter As ElementId _
) As Boolean
Visual C++
public:
static bool IsParameterApplicable(
    Element^ element,
    ElementId^ parameter
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The element to query for support of the given parameter.
parameter
Type: Autodesk.Revit.DB..::..ElementId
The parameter for which to query support.

Return Value

True if the element supports the given parameter, false otherwise.

Remarks

This operation is supported for external (e.g., shared, project) parameters only.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterFilterUtilities Class


RemoveUnfilterableCategories Method

[image]

Revit 2024 API
ParameterFilterUtilities..::..RemoveUnfilterableCategories Method
ParameterFilterUtilities Class See Also Send Feedback
Removes from the given set the categories that are not filterable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static ICollection<ElementId> RemoveUnfilterableCategories(
    ICollection<ElementId> categories
)
Visual Basic
Public Shared Function RemoveUnfilterableCategories ( _
    categories As ICollection(Of ElementId) _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ RemoveUnfilterableCategories(
    ICollection<ElementId^>^ categories
)

Parameters

categories
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
The set of categories to check.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterFilterUtilities Class


ParameterMap Members

[image] [image]

Revit 2024 API
ParameterMap Members
ParameterMap Class Constructors Methods Properties See Also Send Feedback

The ParameterMap type exposes the following members.

Constructors

 | Name | Description
Public method | ParameterMap | Initializes a new instance of the ParameterMap class

Methods

 | Name | Description
Public method | Clear | Removes every item from the map, rendering it empty.
Public method | Contains | Tests for the existence of a key within the map.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a object with the specified key from the map.
Public method | ForwardIterator | Retrieve a forward moving iterator to the map.
Public method | GetEnumerator | Retrieve a forward moving iterator to the map.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item with the specified key into the map.
Public method | ReverseIterator | Retrieve a backward moving iterator to the map.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the map is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified key within the map.
Public property | Size | Returns the number of objects that are in the map.

See Also

ParameterMap Class


ParameterMap Constructor

[image]

Revit 2024 API
ParameterMap Constructor
ParameterMap Class See Also Send Feedback
Initializes a new instance of the ParameterMap class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ParameterMap()
Visual Basic
Public Sub New
Visual C++
public:
ParameterMap()

See Also

ParameterMap Class


ParameterMap Methods

[image] [image]

Revit 2024 API
ParameterMap Methods
ParameterMap Class See Also Send Feedback

The ParameterMap type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every item from the map, rendering it empty.
Public method | Contains | Tests for the existence of a key within the map.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a object with the specified key from the map.
Public method | ForwardIterator | Retrieve a forward moving iterator to the map.
Public method | GetEnumerator | Retrieve a forward moving iterator to the map.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item with the specified key into the map.
Public method | ReverseIterator | Retrieve a backward moving iterator to the map.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ParameterMap Class


Clear Method

[image]

Revit 2024 API
ParameterMap..::..Clear Method
ParameterMap Class See Also Send Feedback
Removes every item from the map, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ParameterMap Class


Contains Method

[image]

Revit 2024 API
ParameterMap..::..Contains Method
ParameterMap Class See Also Send Feedback
Tests for the existence of a key within the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool Contains(
    string key
)
Visual Basic
Public Overridable Function Contains ( _
    key As String _
) As Boolean
Visual C++
public:
virtual bool Contains(
    String^ key
)

Parameters

key
Type: System..::..String
The key to be searched for.

Return Value

The Contains method returns True if the key is within the map, otherwise False.

See Also

ParameterMap Class


Erase Method

[image]

Revit 2024 API
ParameterMap..::..Erase Method
ParameterMap Class See Also Send Feedback
Removes a object with the specified key from the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Erase(
    string key
)
Visual Basic
Public Overridable Function Erase ( _
    key As String _
) As Integer
Visual C++
public:
virtual int Erase(
    String^ key
)

Parameters

key
Type: System..::..String
The key of the item to be erased.

Return Value

The number of items that were erased from the map.

See Also

ParameterMap Class


ForwardIterator Method

[image]

Revit 2024 API
ParameterMap..::..ForwardIterator Method
ParameterMap Class See Also Send Feedback
Retrieve a forward moving iterator to the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual ParameterMapIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As ParameterMapIterator
Visual C++
public:
virtual ParameterMapIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the map.

See Also

ParameterMap Class


GetEnumerator Method

[image]

Revit 2024 API
ParameterMap..::..GetEnumerator Method
ParameterMap Class See Also Send Feedback
Retrieve a forward moving iterator to the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the map.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

ParameterMap Class


Insert Method

[image]

Revit 2024 API
ParameterMap..::..Insert Method
ParameterMap Class See Also Send Feedback
Insert the specified item with the specified key into the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool Insert(
    string key,
    Parameter item
)
Visual Basic
Public Overridable Function Insert ( _
    key As String, _
    item As Parameter _
) As Boolean
Visual C++
public:
virtual bool Insert(
    String^ key,
    Parameter^ item
)

Parameters

key
Type: System..::..String
The key to be used for inserting the item into the map.
item
Type: Autodesk.Revit.DB..::..Parameter
The item to be inserted into the map.

Return Value

Returns whether the item was inserted into the map.

See Also

ParameterMap Class


ReverseIterator Method

[image]

Revit 2024 API
ParameterMap..::..ReverseIterator Method
ParameterMap Class See Also Send Feedback
Retrieve a backward moving iterator to the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual ParameterMapIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As ParameterMapIterator
Visual C++
public:
virtual ParameterMapIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the map.

See Also

ParameterMap Class


ParameterMap Properties

[image] [image]

Revit 2024 API
ParameterMap Properties
ParameterMap Class See Also Send Feedback

The ParameterMap type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the map is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified key within the map.
Public property | Size | Returns the number of objects that are in the map.

See Also

ParameterMap Class


Item Property

[image]

Revit 2024 API
ParameterMap..::..Item Property
ParameterMap Class See Also Send Feedback
Gets or sets an item at a specified key within the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Parameter this[
    string key
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    key As String _
) As Parameter
    Get
    Set
Visual C++
public:
virtual property Parameter^ Item[String^ key] {
    Parameter^ get (String^ key);
    void set (String^ key, Parameter^ value);
}

Parameters

key
Type: System..::..String
The key of the item to be set or retrieved.

Return Value

Returns the object at the specified key.

See Also

ParameterMap Class


Size Property

[image]

Revit 2024 API
ParameterMap..::..Size Property
ParameterMap Class See Also Send Feedback
Returns the number of objects that are in the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ParameterMap Class


ParameterMapIterator Class

[image]

Revit 2024 API
ParameterMapIterator Class
Members See Also Send Feedback
An iterator to a map relating a parameter name (the key, a String) to a parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public abstract class ParameterMapIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class ParameterMapIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ParameterMapIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..ParameterMapIterator

See Also

ParameterMapIterator Members


ParameterMapIterator Members

[image] [image]

Revit 2024 API
ParameterMapIterator Members
ParameterMapIterator Class Constructors Methods Properties See Also Send Feedback

The ParameterMapIterator type exposes the following members.

Constructors

 | Name | Description
Public method | ParameterMapIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the map.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Key | Retrieves the key that is the current focus of the iterator.

See Also

ParameterMapIterator Class


ParameterMapIterator Methods

[image] [image]

Revit 2024 API
ParameterMapIterator Methods
ParameterMapIterator Class See Also Send Feedback

The ParameterMapIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the map.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ParameterMapIterator Class


MoveNext Method

[image]

Revit 2024 API
ParameterMapIterator..::..MoveNext Method
ParameterMapIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the map.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ParameterMapIterator Class


Reset Method

[image]

Revit 2024 API
ParameterMapIterator..::..Reset Method
ParameterMapIterator Class See Also Send Feedback
Bring the iterator back to the start of the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the map in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ParameterMapIterator Class


ParameterMapIterator Properties

[image] [image]

Revit 2024 API
ParameterMapIterator Properties
ParameterMapIterator Class See Also Send Feedback

The ParameterMapIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Key | Retrieves the key that is the current focus of the iterator.

See Also

ParameterMapIterator Class


Current Property

[image]

Revit 2024 API
ParameterMapIterator..::..Current Property
ParameterMapIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ParameterMapIterator Class


Key Property

[image]

Revit 2024 API
ParameterMapIterator..::..Key Property
ParameterMapIterator Class See Also Send Feedback
Retrieves the key that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual string Key { get; }
Visual Basic
Public Overridable ReadOnly Property Key As String
    Get
Visual C++
public:
virtual property String^ Key {
    String^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid key as per expected behavior of IEnumerator.

See Also

ParameterMapIterator Class


ParameterSet Class

[image]

Revit 2024 API
ParameterSet Class
Members See Also Send Feedback
A set that contains parameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class ParameterSet : APIObject,
    IEnumerable
Visual Basic
Public Class ParameterSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ParameterSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..ParameterSet

See Also

ParameterSet Members


ParameterSet Constructor

[image]

Revit 2024 API
ParameterSet Constructor
ParameterSet Class See Also Send Feedback
Initializes a new instance of the ParameterSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ParameterSet()
Visual Basic
Public Sub New
Visual C++
public:
ParameterSet()

See Also

ParameterSet Class


ParameterSet Methods

[image] [image]

Revit 2024 API
ParameterSet Methods
ParameterSet Class See Also Send Feedback

The ParameterSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every parameter from the set, rendering it empty.
Public method | Contains | Tests for the existence of a parameter within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified parameter from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified parameter into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ParameterSet Class


Contains Method

[image]

Revit 2024 API
ParameterSet..::..Contains Method
ParameterSet Class See Also Send Feedback
Tests for the existence of a parameter within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool Contains(
    Parameter item
)
Visual Basic
Public Overridable Function Contains ( _
    item As Parameter _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Parameter^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..Parameter
The parameter to be searched for.

Return Value

The Contains method returns True if the parameter is within the set, otherwise False.

See Also

ParameterSet Class


Erase Method

[image]

Revit 2024 API
ParameterSet..::..Erase Method
ParameterSet Class See Also Send Feedback
Removes a specified parameter from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Erase(
    Parameter item
)
Visual Basic
Public Overridable Function Erase ( _
    item As Parameter _
) As Integer
Visual C++
public:
virtual int Erase(
    Parameter^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..Parameter
The parameter to be erased.

Return Value

The number of parameters that were erased from the set.

See Also

ParameterSet Class


ReverseIterator Method

[image]

Revit 2024 API
ParameterSet..::..ReverseIterator Method
ParameterSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual ParameterSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As ParameterSetIterator
Visual C++
public:
virtual ParameterSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

ParameterSet Class


ParameterSet Properties

[image] [image]

Revit 2024 API
ParameterSet Properties
ParameterSet Class See Also Send Feedback

The ParameterSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of parameters that are in the set.

See Also

ParameterSet Class


IsEmpty Property

[image]

Revit 2024 API
ParameterSet..::..IsEmpty Property
ParameterSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

ParameterSet Class


Size Property

[image]

Revit 2024 API
ParameterSet..::..Size Property
ParameterSet Class See Also Send Feedback
Returns the number of parameters that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ParameterSet Class


ParameterSetIterator Class

[image]

Revit 2024 API
ParameterSetIterator Class
Members See Also Send Feedback
An iterator to a parameter set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public abstract class ParameterSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class ParameterSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ParameterSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..ParameterSetIterator

See Also

ParameterSetIterator Members


ParameterSetIterator Constructor

[image]

Revit 2024 API
ParameterSetIterator Constructor
ParameterSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ParameterSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
ParameterSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ParameterSetIterator Class


ParameterSetIterator Methods

[image] [image]

Revit 2024 API
ParameterSetIterator Methods
ParameterSetIterator Class See Also Send Feedback

The ParameterSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ParameterSetIterator Class


MoveNext Method

[image]

Revit 2024 API
ParameterSetIterator..::..MoveNext Method
ParameterSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ParameterSetIterator Class


Current Property

[image]

Revit 2024 API
ParameterSetIterator..::..Current Property
ParameterSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ParameterSetIterator Class


ParametersOrder Enumeration

[image]

Revit 2024 API
ParametersOrder Enumeration
See Also Send Feedback
The order of the parameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015
Since: 2015

Syntax

C#
public enum ParametersOrder
Visual Basic
Public Enumeration ParametersOrder
Visual C++
public enum class ParametersOrder

Members

Member name | Description
Ascending | Sort parameters are in ascending(A-Z) order.
Descending | Sort parameters are in descending(Z-A) order.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


ParameterTypeId Class

[image]

Revit 2024 API
ParameterTypeId Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class ParameterTypeId
Visual Basic
Public NotInheritable Class ParameterTypeId
Visual C++
public ref class ParameterTypeId abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ParameterTypeId

See Also

ParameterTypeId Members


ParameterTypeId Members

[image] [image]

Revit 2024 API
ParameterTypeId Members
ParameterTypeId Class Properties See Also Send Feedback

The ParameterTypeId type exposes the following members.

Properties

Name | Description
ActualMaxRidgeHeightParam | "Maximum Ridge Height"
AlignmentStationLabelDistance | "Distance": Currently not in use
AlignmentStationLabelIncludeStation | "Include Station"
AlignmentStationLabelIndStation | "Station Indicator"
AlignmentStationLabelSetEndStation | "Alignment Label Set End Station"
AlignmentStationLabelSetInterval | "Alignment Station Label Set Interval": The text is not used directly anywhere in the UI, instead the XAML specifies its own string for the value's label.
AlignmentStationLabelSetOffset | "Alignment Station Label Set Offset": The text is not used directly anywhere in the UI, instead the XAML specifies its own string for the value's label.
AlignmentStationLabelSetStartStation | "Alignment Label Set Start Station"
AlignmentStationLabelStationValue | "Station Value"
AlignmentStationPrefix | "Station Prefix"
AlignmentStationSuffix | "Station Suffix"
AllGridRotationForDivisionRule | "All Grid Rotation"
AllModelDescription | "Description"
AllModelImage | "Image"
AllModelInstanceComments | "Comments"
AllModelManufacturer | "Manufacturer"
AllModelModel | "Model"
AllModelTypeComments | "Type Comments"
AllModelTypeImage | "Type Image"
AllModelUrl | "URL"
AllowAutoEmbed | "Automatically Embed"
AlternateUnits | "Alternate Units"
AlternateUnitsPrefix | "Alternate Units Prefix"
AlternateUnitsSuffix | "Alternate Units Suffix"
AlwaysZeroLength | "Base Offset"
AnalyticalAbsorptance | "Absorptance"
AnalyticalAdjacentSpace | "Adjacent Analytical Space"
AnalyticalDefineThermalPropertiesBy | "Define Thermal Properties by"
AnalyticalElementHasAssociation | "Has Association": Used for Analytical Member, Analytical Panel, Structural Columns, Structural Framing, Floors, Walls, Structural Foundation
AnalyticalElementPhysicalAsset | "Physical Material Asset": Used for Analytical Elements.
AnalyticalElementStructuralRole | "Structural Role": Used for Analytical Elements
AnalyticalGeometryIsValid | "Analytical Model Correct"
AnalyticalHeatTransferCoefficient | "Heat Transfer Coefficient (U)"
AnalyticalLinkReleaseRotationX | "X Rotation"
AnalyticalLinkReleaseRotationY | "Y Rotation"
AnalyticalLinkReleaseRotationZ | "Z Rotation"
AnalyticalLinkReleaseTranslationX | "X Translation"
AnalyticalLinkReleaseTranslationY | "Y Translation"
AnalyticalLinkReleaseTranslationZ | "Z Translation"
AnalyticalMemberForceEndAllNonZero | "All non 0 forces at end"
AnalyticalMemberForceEndFx | "End Fx"
AnalyticalMemberForceEndFy | "End Fy"
AnalyticalMemberForceEndFz | "End Fz"
AnalyticalMemberForceEndMx | "End Mx"
AnalyticalMemberForceEndMy | "End My"
AnalyticalMemberForceEndMz | "End Mz"
AnalyticalMemberForceStartAllNonZero | "All non 0 forces at start"
AnalyticalMemberForceStartFx | "Start Fx"
AnalyticalMemberForceStartFy | "Start Fy"
AnalyticalMemberForceStartFz | "Start Fz"
AnalyticalMemberForceStartMx | "Start Mx"
AnalyticalMemberForceStartMy | "Start My"
AnalyticalMemberForceStartMz | "Start Mz"
AnalyticalMemberRotation | "Cross-Section Rotation": Used for Analytical Member
AnalyticalMemberSectionType | "Section Type": The id of the type from the structural Family assigned to the analytical member.
AnalyticalModelArea | "Area": The Area of Analytical Model
AnalyticalModelBaseAlignmentMethod | "Base Alignment Method"
AnalyticalModelBaseExtensionMethod | "Base Extension Method"
AnalyticalModelBaseYProjection | "Base y Projection"
AnalyticalModelBaseZProjection | "Base z Projection"
AnalyticalModelCodeChecking | "Code Checking": Used for Analytical wall, Analytical beam, Analytical column, Analytical floor, Analytical wall foundations, Analytical isolated foundations, Analytical foundations slab, Anaytical brace
AnalyticalModelColumnBaseExtension | "Base x Projection"
AnalyticalModelColumnTopExtension | "Top x Projection"
AnalyticalModelEndAlignmentMethod | "End Alignment Method"
AnalyticalModelEndProjectionOrthogonal | "End Projection Orthogonal"
AnalyticalModelEndYProjection | "End y Projection"
AnalyticalModelEndZProjection | "End z Projection"
AnalyticalModelFloorAlignmentMethod | "Alignment Method"
AnalyticalModelFloorProjection | "z Projection"
AnalyticalModelFoundationsMark | "Foundation Number": Used for isolated, wall foundations
AnalyticalModelLength | "Length": The length of Analytical Model
AnalyticalModelManuallyAdjusted | "Manually Adjusted"
AnalyticalModelNodesMark | "Node Number": Used for nodes
AnalyticalModelPerimeter | "Perimeter": The Perimeter of Analytical Model
AnalyticalModelPhysicalType | "Family Type": the Family Type of the physical element associated with the Analytical Model
AnalyticalModelRotation | "Cross-Section Rotation": The rotation of Analytical Model
AnalyticalModelSketchAlignmentMethod | "Alignment Method"
AnalyticalModelSketchProjection | "In-Plane Projection"
AnalyticalModelStartAlignmentMethod | "Start Alignment Method"
AnalyticalModelStartProjectionOrthogonal | "Start Projection Orthogonal"
AnalyticalModelStartYProjection | "Start y Projection"
AnalyticalModelStartZProjection | "Start z Projection"
AnalyticalModelStickElementsMark | "Member Number": Used for beams, braces, columns
AnalyticalModelSurfaceElementsMark | "Surface Number": Used for floors, slabs, walls
AnalyticalModelTopAlignmentMethod | "Top Alignment Method"
AnalyticalModelTopExtensionMethod | "Top Extension Method"
AnalyticalModelTopYProjection | "Top y Projection"
AnalyticalModelTopZProjection | "Top z Projection"
AnalyticalModelWallAlignmentMethod | "Alignment Method"
AnalyticalModelWallBaseProjection | "Base y Projection"
AnalyticalModelWallProjection | "z Projection"
AnalyticalModelWallTopProjection | "Top y Projection"
AnalyticalNodeConnectionStatus | "Connection Status"
AnalyticalPanelThickness | "Thickness": Used for Analytical Panel
AnalyticalRoughness | "Roughness"
AnalyticalSolarHeatGainCoefficient | "Solar Heat Gain Coefficient"
AnalyticalSpace | "Analytical Space"
AnalyticalSurface | "Analytical Surface"
AnalyticalThermalMass | "Thermal Mass"
AnalyticalThermalResistance | "Thermal Resistance (R)"
AnalyticalVisualLightTransmittance | "Visual Light Transmittance"
AnalyticalZone | "Analytical Zone"
AnalyticalZoneName | "Name"
AnalyticConstruction | "Analytic Construction"
AnalyticConstructionGbxmlTypeid | "Construction Type Id"
AnalyticConstructionLookupTable | "Analytic Construction"
AnyPatternIdParam | "Fill Pattern"
AnyPatternIdParamNoNo | "Fill Pattern"
ArcCenterMark | "Center Marks"
ArcLeaderParam | "Arc Leaders"
ArcWallCntrMrkVisible | "Center Mark Visible"
AreaSchemeId | "Area Scheme Id"
AreaSchemeName | "Name"
AreaType | "Area Type"
AreaTypeText | "Area Type"
ArrowCentered | "Tick Mark Centered"
ArrowClosed | "Arrow Closed"
ArrowFilled | "Fill Tick"
ArrowheadEndAtRiser | "End at Riser"
ArrowheadType | "Arrowhead Type"
ArrowSize | "Tick Size"
ArrowType | "Arrow Style"
AssemblyName | "Assembly Name"
AssemblyNamingCategory | "Naming Category"
AssemblyPrecastFreeze | "Disable Precast Updates"
AssignTemplateOnViewCreation | "New views are dependent on template"
AssociatedLevel | "Associated Level": The level associated with this cell.
AssociatedLevelOffset | "Associated Level Offset": The offset from the associated level.
AutoJoinCondition | "Join Condition"
AutoJoinConditionWall | "Join Condition"
AutoMullionBorder1Grid1 | "Border 1 Type"
AutoMullionBorder1Grid2 | "Border 1 Type"
AutoMullionBorder1Horiz | "Border 1 Type"
AutoMullionBorder1Vert | "Border 1 Type"
AutoMullionBorder2Grid1 | "Border 2 Type"
AutoMullionBorder2Grid2 | "Border 2 Type"
AutoMullionBorder2Horiz | "Border 2 Type"
AutoMullionBorder2Vert | "Border 2 Type"
AutoMullionInteriorGrid1 | "Interior Type"
AutoMullionInteriorGrid2 | "Interior Type"
AutoMullionInteriorHoriz | "Interior Type"
AutoMullionInteriorVert | "Interior Type"
AutoPanel | "Curtain Panel"
AutoPanelWall | "Curtain Panel"
Azimuth | "Azimuth"
BackgroundDraftPatternIdParam | "Background Fill Pattern"
BackgroundPatternColorParam | "Background Pattern Color"
BaselineDimOffset | "Baseline Offset"
BasepointAngletonParam | "Angle to True North"
BasepointEastwestParam | "E/W"
BasepointElevationParam | "Elev"
BasepointLatitudeParam | "Lat"
BasepointLongitudeParam | "Lon"
BasepointNorthsouthParam | "N/S"
BeamHJustification | "Lateral Justification"
BeamSystem3dParam | "3D"
BeamSystemTagInstParamAngle | "Beam System Tag Direction"
BeamSystemTagParamLeft | "Left"
BeamSystemTagParamRight | "Right"
BeamVJustification | "z-Direction Justification"
BeamVJustificationOtherValue | "z-Direction Offset Value"
BendingDetailAngularDimensionTextPosition | "Angle Text Position"
BendingDetailDetailLevel | "Detail Level"
BendingDetailRepesentationFor3dBars | "View for 3D Shape"
BendingDetailSegmenetRepesentation | "Representation"
BendingDetailSegmentLengthDimensionTextPosition | "Dimension Text Position"
BendingDetailTypeAngularDimensionOffset | "Angular Dimension Offset"
BendingDetailTypeAngularDimensionsEnabled | "Angular Dimensions"
BendingDetailTypeAngularDimensionsForHooksEnabled | "Hook Angles"
BendingDetailTypeAngularDimensionsMeasurement | "Angle Measurement"
BendingDetailTypeAngularDimensionTypeId | "Angular Dimension Style"
BendingDetailTypeBendDiameterDimensionsEnabled | "Bend Diameter Dimensions"
BendingDetailTypeBendDiameterDimensionsForHooksEnabled | "Hook Bends"
BendingDetailTypeBendDiameterDimensionsForSegmentsEnabled | "Segment Bends"
BendingDetailTypeDiameterDimensionTypeId | "Diameter Dimension Style"
BendingDetailTypeOrthogonalAndOverallDimesionsEnabled | "Other Dimensions"
BendingDetailTypeRadialDimensionTypeId | "Radial Dimension Style"
BendingDetailTypeSegmentLengthDimensionsEnabled | "Segment Length Dimensions"
BendingDetailTypeSegmentLengthDimensionsForHooksEnabled | "Hook Lengths"
BendingDetailTypeSegmentLengthDimensionsOffset | "Dimension Offset"
BendingDetailTypeSegmentLengthDimensionTypeId | "Linear Dimension Style"
BendingDetailTypeSegmentLengthsDisplayOption | "Straight Segment Lengths"
BendingDetailTypeSegmentLengthsForArcsDisplayOption | "Arc Segment Lengths"
BendingDetailTypeShowAngularDimensionsFor | "Show for Angles"
BendingDetailTypeShowBarBendingUsing | "Dimension Type"
BendingDetailVaryingRebarDimension | "Varying Rebar Set Dimensions"
BentFabricParamBendDirection | "Bend Direction": Direction in which FabricSheet is bent.
BentFabricParamLongitudinalCutLength | "Longitudinal Cut Length": Bent fabric longitudinal cut length.
BentFabricParamStraightWiresLocation | "Straight Wires Location": Location of straight wires in a bent fabric.
BlendEndParam | "Second End"
BlendStartParam | "First End"
BoundaryAreaRestraintX | "X Spring Modulus"
BoundaryAreaRestraintY | "Y Spring Modulus"
BoundaryAreaRestraintZ | "Z Spring Modulus"
BoundaryBearing | "Bearing"
BoundaryConditionsIsExt | "Is Boundary Conditions External?"
BoundaryConditionsType | "Boundary Conditions Type"
BoundaryDirectionRotX | "X Rotation"
BoundaryDirectionRotY | "Y Rotation"
BoundaryDirectionRotZ | "Z Rotation"
BoundaryDirectionX | "X Translation"
BoundaryDirectionY | "Y Translation"
BoundaryDirectionZ | "Z Translation"
BoundaryDistance | "Distance"
BoundaryLinearRestraintRotX | "X Spring Modulus"
BoundaryLinearRestraintX | "X Spring Modulus"
BoundaryLinearRestraintY | "Y Spring Modulus"
BoundaryLinearRestraintZ | "Z Spring Modulus"
BoundaryParamPreset | "State"
BoundaryParamPresetArea | "State"
BoundaryParamPresetLinear | "State"
BoundaryRadius | "Radius"
BoundaryRestraintRotX | "X Spring Modulus"
BoundaryRestraintRotY | "Y Spring Modulus"
BoundaryRestraintRotZ | "Z Spring Modulus"
BoundaryRestraintX | "X Spring Modulus"
BoundaryRestraintY | "Y Spring Modulus"
BoundaryRestraintZ | "Z Spring Modulus"
BoundaryXRotationFixed | "X Rotation - Fixed"
BoundaryXRotationSpring | "X Rotation - Spring"
BoundaryXTranslationFixed | "X Translation - Fixed"
BoundaryXTranslationSpring | "X Translation - Spring"
BoundaryYRotationFixed | "Y Rotation - Fixed"
BoundaryYRotationSpring | "Y Rotation - Spring"
BoundaryYTranslationFixed | "Y Translation - Fixed"
BoundaryYTranslationSpring | "Y Translation - Spring"
BoundaryZRotationFixed | "Z Rotation - Fixed"
BoundaryZRotationSpring | "Z Rotation - Spring"
BoundaryZTranslationFixed | "Z Translation - Fixed"
BoundaryZTranslationSpring | "Z Translation - Spring"
BrOrgFilter | "Filter"
BrOrgFolders | "Folders"
BuildingClosingTimeParam | "Closing Time"
BuildingCurveGstyle | "Line Style"
BuildingCurveGstylePlusInvisible | "Subcategory"
BuildingOpeningTimeParam | "Opening Time"
BuildingpadHeightabovelevelParam | "Height Offset From Level"
BuildingpadThickness | "Thickness"
BuildingUnoccupiedCoolingSetPointParam | "Unoccupied Cooling Set Point"
BuilidingPadStructureIdParam | "Structure"
CabletrayMinbendmultiplierParam | "Bend Radius Multiplier"
CalloutAttrHeadTag | "Callout Head"
CalloutCornerSheetRadius | "Corner Radius"
CalloutSyncronizeBoundOffsetFar | "Far Clip Settings"
CalloutTag | "Callout Tag"
CeilingAttrDefaultHeightParam | "Default Height above level"
CeilingAttrPatternParam | "Pattern"
CeilingAttrSpacing1Param | "Spacing Axis 1"
CeilingAttrSpacing2Param | "Spacing Axis 2"
CeilingAttrSystemnameParam | "System"
CeilingHasThicknessParam | "Has Thickness"
CeilingHeightabovelevelParam | "Height Offset From Level"
CeilingStructureIdParam | "Structure"
CeilingThickness | "Thickness"
CeilingThicknessParam | "Thickness"
CenterMarkSize | "Center Mark Size"
CircMullionRadius | "Radius"
CircuitLoadClassificationAbbreviationParam | "Load Classification Abbreviation"
CircuitLoadClassificationParam | "Load Classification"
CircuitPhaseParam | "Phase Label"
CircuitWaysParam | "Ways"
CircularFramingDiameter | "Circular Diameter"
ClearCover | "Rebar Cover"
ClearCoverBottom | "Rebar Cover - Bottom Face"
ClearCoverExterior | "Rebar Cover - Exterior Face"
ClearCoverInterior | "Rebar Cover - Interior Face"
ClearCoverOther | "Rebar Cover - Other Faces"
ClearCoverTop | "Rebar Cover - Top Face"
ClientName | "Client Name"
ClineSubcategory | "Subcategory"
CoarseScaleFillPatternColor | "Coarse Scale Fill Color"
CoarseScaleFillPatternIdParam | "Coarse Scale Fill Pattern"
ColorFillFilteredParam | "Values Displayed"
ColorFillSwatchHeightParam | "Swatch Height"
ColorFillSwatchWidthParam | "Swatch Width"
ColorSchemeLocation | "Color Scheme Location"
ColumnBaseAttachCutParam | "Base Attachment Cut"
ColumnBaseAttachedParam | "Base is Attached"
ColumnBaseAttachJustificationParam | "Attachment Justification At Base"
ColumnBaseAttachmentOffsetParam | "Offset From Attachment At Base"
ColumnLocationMark | "Column Location Mark"
ColumnTopAttachCutParam | "Top Attachment Cut"
ColumnTopAttachedParam | "Top is Attached"
ColumnTopAttachJustificationParam | "Attachment Justification At Top"
ColumnTopAttachmentOffsetParam | "Offset From Attachment At Top"
ConceptualConstructionMaterial | "Graphical Appearance"
ConduitStandardTypeParam | "Standard"
ConnectorAngle | "Angle"
ConnectorAngleOfDeflection | "Angle of Deflection"
ConnectorDiameter | "Diameter"
ConnectorEngagementLength | "Engagement Length"
ConnectorGenderType | "Connector Gender Type"
ConnectorHeight | "Height"
ConnectorIndex | "Index"
ConnectorInsideDiameter | "Inside Diameter"
ConnectorJointType | "Connector Joint Type"
ConnectorLength | "Length"
ConnectorProfileType | "Shape"
ConnectorRadius | "Radius"
ConnectorReferenceIndex | "Link Connector Index"
ConnectorUtilityParam | "Utility"
ConnectorVisibleSize | "Size on screen"
ConnectorWidth | "Width"
ConstraintFixedOffset | "Fixed offset"
ConstructionIsSchematic | "Schematic"
ConstructionName | "Name"
ContinuousFootingBearingWidth | "Width"
ContinuousFootingBottomHeel | "Bottom Heel Length"
ContinuousFootingBottomToe | "Bottom Toe Length"
ContinuousFootingBreakAtInsertsDisable | "Do Not Break At Inserts"
ContinuousFootingDefaultEndExtensionLength | "Default End Extension Length"
ContinuousFootingEccentricity | "Eccentricity"
ContinuousFootingLength | "Length"
ContinuousFootingStructuralUsage | "Structural Usage"
ContinuousFootingTopHeel | "Heel Length"
ContinuousFootingTopToe | "Toe Length"
ContinuousFootingWidth | "Width"
ContinuousrailBeginningTerminationAttachmentParam | "Extension Style"
ContinuousrailBeginningTerminationTypeParam | "Beginning/Bottom Termination"
ContinuousrailDefaultJoinTypeParam | "Default Join"
ContinuousrailEndExtensionLengthParam | "Length"
ContinuousrailEndTerminationAttachmentParam | "Extension Style"
ContinuousrailEndTerminationTypeParam | "End/Top Termination"
ContinuousrailExtensionLengthParam | "Length"
ContinuousrailFilletRadiusParam | "Fillet Radius"
ContinuousrailJoinTypeParam | "Rail Path Join"
ContinuousrailLengthParam | "Length"
ContinuousrailMaterialsParam | "Material"
ContinuousrailPlusTreadDepthParam | "Plus Tread Depth"
ContinuousrailProfileTypeParam | "Profile"
ContinuousrailTransitionTypeParam | "Transitions"
ContourElevation | "Elevation"
ContourElevationStep | "Increment"
ContourLabelsElevBaseType | "Elevation Base"
ContourLabelsLinearUnits | "Units Format"
ContourLabelsPrimaryOnly | "Label primary contours only"
ContourLabelsRelativeBase | "Relative Base"
CouplerCode | "Part Number"
CouplerCoupledBarSize | "Bar Size 2"
CouplerCoupledEndtreatment | "End Treatment 2"
CouplerCoupledEngagement | "Bar Engagement 2"
CouplerLength | "Total Length"
CouplerMainBarSize | "Bar Size 1"
CouplerMainEndtreatment | "End Treatment 1"
CouplerMainEngagement | "Bar Engagement 1"
CouplerMark | "Schedule Mark"
CouplerNumber | "Coupler Number"
CouplerQuantity | "Quantity"
CouplerRotationAngle | "Coupler Rotation"
CouplerWeight | "Mass"
CouplerWidth | "External Diameter"
CoverTypeLength | "Length"
CoverTypeName | "Name"
CurtaingridAdjustBorderHoriz | "Adjust for Mullion Size"
CurtaingridAdjustBordern1 | "Adjust for Mullion Size"
CurtaingridAdjustBordern2 | "Adjust for Mullion Size"
CurtaingridAdjustBorderU | "Adjust for Mullion Size"
CurtaingridAdjustBorderV | "Adjust for Mullion Size"
CurtaingridAdjustBorderVert | "Adjust for Mullion Size"
CurtaingridAngleHoriz | "Angle"
CurtaingridAnglen1 | "Angle"
CurtaingridAnglen2 | "Angle"
CurtaingridAngleU | "Grid Rotation"
CurtaingridAngleV | "Grid Rotation"
CurtaingridAngleVert | "Angle"
CurtainGridBaseOrientation | "Grid Base Orientation"
CurtaingridBeltHoriz | "Measurement Line"
CurtaingridBeltn1 | "Measurement Line"
CurtaingridBeltn2 | "Measurement Line"
CurtaingridBeltRation1 | "Measurement Line"
CurtaingridBeltRation2 | "Measurement Line"
CurtaingridBeltRatioU | "Belt Measurement"
CurtaingridBeltRatioV | "Belt Measurement"
CurtaingridBeltU | "Belt Measurement"
CurtaingridBeltV | "Belt Measurement"
CurtaingridBeltVert | "Measurement Line"
CurtaingridOriginHoriz | "Offset"
CurtaingridOriginn1 | "Offset"
CurtaingridOriginn2 | "Offset"
CurtaingridOriginU | "Offset"
CurtaingridOriginV | "Offset"
CurtaingridOriginVert | "Offset"
CurtaingridUseCurveDist | "Use Curve Distance"
CurtaingridUseCurveDistHoriz | "Use Curve Distance"
CurtaingridUseCurveDistn1 | "Use Curve Distance"
CurtaingridUseCurveDistn2 | "Use Curve Distance"
CurtaingridUseCurveDistU | "Use Curve Distance"
CurtaingridUseCurveDistV | "Use Curve Distance"
CurtaingridUseCurveDistVert | "Use Curve Distance"
CurtainVersionParam | "Curtain version"
CurtainWallPanelHostId | "Host Id"
CurtainWallPanelsHeight | "Height"
CurtainWallPanelsWidth | "Width"
CurtainWallSyspanelOffset | "Offset"
CurtainWallSyspanelThickness | "Thickness"
CurveBottomLevel | "Bottom Level"
CurveByPointsProjectionType | "Projection Type"
CurveDeterminesOrientation | "Determines Orientation"
CurveEdgeOffset | "Wall offset"
CurveElemArcEndAngle | "Angle 2"
CurveElemArcRadius | "Radius"
CurveElemArcRange | "Range"
CurveElemArcStartAngle | "Angle 1"
CurveElemDefinesSlope | "Defines Beam System Slope"
CurveElemLength | "Length"
CurveElemLineAngle | "Angle"
CurveHeightOffset | "Offset From Base"
CurveIsDetail | "Detail Line"
CurveIsFilled | "Filled"
CurveIsMultilevel | "Multilevel Boundary"
CurveIsReferenceLine | "Is Reference Line"
CurveIsSlopeDefining | "Defines Slope"
CurveLevel | "Level"
CurveNumberOfSegments | "Number of Full Segments"
CurveParamConcreteCantilever | "Concrete Cantilever"
CurveParamSteelCantilever | "Steel Cantilever"
CurveSupportOffset | "Wall offset"
CurveTopLevel | "Top Level"
CurveVisibilityParam | "Visibility/Graphics Overrides"
CurveWallOffset | "Wall offset"
CurveWallOffsetRoofs | "Overhang"
CustMullionThick | "Thickness"
CustMullionWidth1 | "Width on side 1"
CustMullionWidth2 | "Width on side 2"
CutLineAngle | "Cut Line Angle"
CutLineDistance | "Cut Line Distance"
CutLineExtension | "Cut Line Extension"
CutLineType | "Cut Line Type"
CutMarkSymbol | "Cut Mark Symbol"
CutMarkSymbolSize | "Cut Mark Symbol Size"
CwpAddGridPrefix | "Add prefix to Grid Name"
CwpAddGridSuffix | "Add suffix to Grid Name"
CwpAddLevelPrefix | "Add prefix to Level Name"
CwpAddLevelSuffix | "Add suffix to Level Name"
CwpCopyFloorInserts | "Copy openings/inserts"
CwpCopyRoofInserts | "Copy openings"
CwpCopyWallInserts | "Copy windows/doors/openings"
CwpLevelOffset | "Offset Level"
CwpLinkedRoomParams | "Parameters"
CwpLinkedRoomPhases | "Phases"
CwpReuseExistingGrids | "Reuse matching Grids"
CwpReuseExistingLevels | "Reuse matching Levels"
CwpReuseGridsSameName | "Reuse Grids with the same name"
CwpReuseLevelsSameName | "Reuse Levels with the same name"
CwpSplitColumnsAtLevels | "Split Columns by Levels"
DatumBubbleEndn1 | "Symbol at End 1 Default"
DatumBubbleEndn2 | "Symbol at End 2 Default"
DatumBubbleLocationInElev | "Non-Plan View Symbols (Default)"
DatumPlaneDefinesOrigin | "Defines Origin"
DatumPlaneDefinesWallClosure | "Wall Closure"
DatumText | "Name"
DatumVolumeOfInterest | "Scope Box"
DebugtabDataboundcontrolsdemoBoolean | "Boolean"
DebugtabDataboundcontrolsdemoDouble | "Double"
DebugtabDataboundcontrolsdemoEnum | "Options"
DebugtabDataboundcontrolsdemoInteger | "Integer"
DecalAttributes | "Decal Attributes"
DecalHeight | "Height"
DecalLockProportions | "Lock Proportions"
DecalSubcategoryId | "Subcategory"
DecalWidth | "Width"
DefaultConstructionExtWallUnderground | "Mass Exterior Wall - Underground"
DefaultConstructionMassExteriorWall | "Mass Exterior Wall"
DefaultConstructionMassFloor | "Mass Floor"
DefaultConstructionMassGlazing | "Mass Glazing"
DefaultConstructionMassInteriorWall | "Mass Interior Wall"
DefaultConstructionMassOpening | "Mass Opening"
DefaultConstructionMassRoof | "Mass Roof"
DefaultConstructionMassShade | "Mass Shade"
DefaultConstructionMassSkylight | "Mass Skylight"
DefaultConstructionMassSlab | "Mass Slab"
DefaultViewTemplate | "View Template applied to new views"
DefinesConstantHeight | "Defines Constant Height"
DesignOptionId | "Design Option"
DesignOptionParam | "Design Option"
DiameterSymbolLocation | "Diameter Symbol Location"
DiameterSymbolText | "Diameter Symbol Text"
DimDisplayEq | "Equality Display"
DimIsreporting | "Is Reporting"
DimLabel | "Label"
DimLabelGpShow | "Show Label in View"
DimLabelIsInstance | "Is Instance Parameter"
DimLeader | "Leader"
DimLeaderArrowhead | "Tick Mark"
DimLeaderDisplayCondition | "Show Leader When Text Moves"
DimLeaderShoulderLength | "Shoulder Length"
DimLeaderType | "Leader Type"
DimLineExtension | "Dimension Line Extension"
DimNotModifiable | "Non-modifiable"
DimPrefix | "Dimension Prefix"
DimReferenceCount | "Count"
DimStyleAngularUnits | "Units Format"
DimStyleAngularUnitsAlt | "Alternate Units Format"
DimStyleCenterlinePattern | "Centerline Pattern"
DimStyleCenterlineSymbol | "Centerline Symbol"
DimStyleCenterlineTickMark | "Centerline Tick Mark"
DimStyleDimLineSnapDist | "Dimension Line Snap Distance"
DimStyleFlippedDimLineExtension | "Flipped Dimension Line Extension"
DimStyleInteriorTickMark | "Interior Tick Mark"
DimStyleLeaderTickMark | "Leader Tick Mark"
DimStyleLinearUnits | "Units Format"
DimStyleLinearUnitsAlt | "Alternate Units Format"
DimStyleReadConvention | "Read Convention"
DimStyleShowOpeningHt | "Show Opening Height"
DimStyleSuppressSpaces | "Suppress Spaces"
DimSuffix | "Dimension Suffix"
DimTextBackground | "Text Background"
DimTextLocationForLeader | "Text Location"
DimToInserts | "Dimension To Openings"
DimToInsertType | "Dimension To Opening Type"
DimToIntersectingGrids | "Dimension To Intersecting Grids"
DimToIntersectingWalls | "Dimension To Intersecting Walls"
DimTotalLength | "Total Length"
DimValueAngle | "Value"
DimValueLength | "Value"
DimWitnsLineCntrl | "Witness Line Control"
DimWitnsLineExtensionBelow | "Witness Line Length"
Directcontext3dApplicationId | "ApplicationId"
Directcontext3dLoaded | "Loaded"
Directcontext3dName | "Name"
Directcontext3dServerId | "ServerId"
Directcontext3dSourceId | "Path"
DisplacedElementDisplacementX | "X Displacement"
DisplacedElementDisplacementY | "Y Displacement"
DisplacedElementDisplacementZ | "Z Displacement"
DisplacementPathDepth | "Depth"
DisplacementPathStyle | "Style"
DistanceToCutMark | "Distance to Cut Mark"
DividedpathBeginningIndent | "Beginning Indent"
DividedpathDisplayNodeNumbers | "Show Node Numbers"
DividedpathDisplayNodes | "Display Nodes"
DividedpathDisplayReferenceCurves | "Display Path"
DividedpathDistance | "Distance"
DividedpathEndIndent | "End Indent"
DividedpathFlipDirection | "Flip Direction"
DividedpathJustification | "Justification"
DividedpathLayout | "Layout"
DividedpathLayoutFixedNumPoint | "Number"
DividedpathMaxDistance | "Maximum Distance"
DividedpathMeasurementType | "Measurement Type"
DividedpathMergedPointNum | "Total Number of Nodes"
DividedpathMinDistance | "Minimum Distance"
DividedpathTotalPathLength | "Path Length"
DividedSurfaceAllGridRotation | "All Grid Rotation"
DividedSurfaceAllPoints | "Show all points"
DividedSurfaceComponentTrimType | "Component Trim"
DividedSurfaceCoverFaceCompletely | "Cover face completely"
DividedSurfaceDisplayComponents | "Components"
DividedSurfaceDisplayDiscardeddivisionlines | "Discarded Division Lines"
DividedSurfaceDisplayGridlines | "Gridlines"
DividedSurfaceDisplayNodes | "Nodes"
DividedSurfaceDisplayOriginalSurface | "Surface"
DividedSurfaceDisplayPatternFill | "Pattern Fill"
DividedSurfaceDisplayPatternLines | "Pattern Lines"
DividedSurfaceDisplaySurfaceOption | "Display Surface Option"
DividedSurfaceEdgeNumber | "Edge number"
DividedSurfaceFacetNumber | "Facet number"
DividedSurfaceGridlinesStyle | "Gridlines Style"
DividedSurfaceGridOptionParamn1 | "Option 1"
DividedSurfaceGridOptionParamn2 | "Option 2"
DividedSurfaceOffsetFromSurface | "Offset from surface"
DividedSurfaceOriginalSurfaceMaterial | "Surface Material"
DividedSurfacePattern | "Tile Pattern"
DividedSurfacePatternFillMaterial | "Pattern Fill Material"
DividedSurfacePatternFlip | "Component Flip"
DividedSurfacePatternIndentn1 | "Indent 1"
DividedSurfacePatternIndentn2 | "Indent 2"
DividedSurfacePatternLinesStyle | "Pattern Lines Style"
DividedSurfacePatternMirror | "Component Mirror"
DividedSurfacePatternRotationAngle | "Component Rotation"
DividedSurfacePointNumber | "Point number"
DividedSurfaceRule1Suspension | "Is grid 1 suspended?"
DividedSurfaceRule2Suspension | "Is grid 2 suspended?"
DividedSurfaceSurfaceArea | "Divided Surface Area"
DividedSurfaceTileBorder | "Border Tile"
DividedSurfaceTotalEdgeLength | "Total edge length"
DivisionPattern | "Division Pattern"
DivisionProfileWidth | "Width": Width
DivisionRuleParam | "Division Rule"
DivisionSketchCurveDivisionParamsOverrideParam | "Profile Override"
DivisionSketchCurveExtentdToSilhParam | "Extend to Silhouette"
DoorConstructionType | "Construction Type"
DoorCost | "Cost"
DoorEvacuationExitType | "Exit Access"
DoorFinish | "Finish"
DoorFrameMaterial | "Frame Material"
DoorFrameType | "Frame Type"
DoorNumber | "Mark"
DoorOperationType | "Operation"
DpartAreaComputed | "Area"
DpartBaseLevel | "Base Level"
DpartBaseLevelByOriginal | "Base Level By Original"
DpartCanHostRebar | "Can host rebar"
DpartExcluded | "Excluded"
DpartHeightComputed | "Height"
DpartLayerConstruction | "Construction"
DpartLayerFunction | "Layer Function"
DpartLayerIndex | "Layer Index"
DpartLayerWidth | "Thickness"
DpartLengthComputed | "Length"
DpartMaterialByOriginal | "Material By Original"
DpartMaterialIdParam | "Material"
DpartOriginalCategory | "Original Category"
DpartOriginalCategoryId | "Original Category"
DpartOriginalFamily | "Original Family"
DpartOriginalType | "Original Type"
DpartPhaseCreatedByOriginal | "Phase Created By Original"
DpartPhaseDemolishedByOriginal | "Phase Demolished By Original"
DpartShapeModified | "Shape is modified"
DpartVolumeComputed | "Volume"
DrawForEachRun | "Draw for Each Run"
DuctRoughness | "Roughness"
DuctTerminalEngagementLength | "Engagement Length"
EdgeLinework | "Line Style"
EditedBy | "Edited by"
ElecticalEquipVoltage | "Voltage"
ElecticalEquipWattage | "Wattage"
ElemCategoryParam | "Category"
ElemCategoryParamMt | "Category"
ElemDeletableInFamily | "Deletable"
ElementIsCutting | "Solid/Void"
ElementLockedParam | "Locked"
ElemFamilyAndTypeParam | "Family and Type"
ElemFamilyParam | "Family"
ElemIsReference | "Reference"
ElemPartitionParam | "Workset"
ElemReferenceName | "Is Reference"
ElemReferenceName2dXz | "Is Reference"
ElemRoomId | "Room Id"
ElemRoomName | "Room Name"
ElemRoomNumber | "Room Number"
ElemTypeLabel | "Label"
ElemTypeParam | "Type"
ElevArrowAngle | "Arrow Angle"
ElevArrowFilled | "Filled"
ElevAssocDatum | "Associated Datum"
ElevatnTag | "Elevation Tag"
ElevReferenceLabelPos | "Reference Label Position"
ElevShape | "Shape"
ElevShowViewName | "Show View Name"
ElevSymbolId | "Elevation Mark"
ElevTextPos | "Text Position"
ElevViewNamePos | "View Name Position"
ElevWidth | "Width"
EllipseFocusMrkVisible | "Focus Marks Visible"
EllipseXParam | "X-Radius Value for Ellipse (for Use with XAML Data Template example)"
EllipseYParam | "Y-Radius Value for Ellipse (for Use with XAML Data Template example)"
EndExtension | "End Extension"
EndJoinCutback | "End Join Cutback"
EndTreatment | "End Treatment"
EndYJustification | "End y Justification"
EndYOffsetValue | "End y Offset Value"
EndZJustification | "End z Justification"
EndZOffsetValue | "End z Offset Value"
EnergyAnalysisAdvancedOptions | "Other Options"
EnergyAnalysisBuildingOperatingSchedule | "Building Operating Schedule"
EnergyAnalysisConceptualConstruction | "Conceptual Types"
EnergyAnalysisCreateAnalyticalModel | "Create Energy Model"
EnergyAnalysisCurrentViewOnly | "Use Only Elements Visible In Current View"
EnergyAnalysisGlazingIsShaded | "Glazing is Shaded"
EnergyAnalysisHorizontalVoidThreshold | "Horizontal Void/Chase Area Threshold"
EnergyAnalysisHvacSystem | "HVAC System"
EnergyAnalysisMasszoneCoreoffset | "Perimeter Zone Depth"
EnergyAnalysisMasszoneDivideperimeter | "Perimeter Zone Division"
EnergyAnalysisMasszoneUseenergydatasettings | "Use Energy Data"
EnergyAnalysisMassZoning | "Mass Zoning"
EnergyAnalysisOutdoorAirInformationParam | "Outdoor Air Information"
EnergyAnalysisPercentageGlazing | "Target Percentage Glazing"
EnergyAnalysisPercentageSkylights | "Target Percentage Skylights"
EnergyAnalysisProjectPhase | "Phase"
EnergyAnalysisShadeDepth | "Shade Depth"
EnergyAnalysisSillHeight | "Target Sill Height"
EnergyAnalysisSkylightWidth | "Skylight Width & Depth"
EnergyAnalysisSpaceBoundingParam | "Analytical Space Bounding"
EnergyAnalysisVerticalVoidThreshold | "Average Vertical Void Height Threshold"
EqualityFormula | "Equality Formula"
EqualityTextForAngularDim | "Equality Text"
EqualityTextForContinuousLinearDim | "Equality Text"
EqualityWitnessDisplay | "Equality Witness Display"
ExchangeEntityId | "Exchange Entity ID"
ExchangeId | "Exchange ID"
ExtrusionAutoParams | "Auto ends"
ExtrusionEndParam | "Extrusion End"
ExtrusionLength | "Depth"
ExtrusionStartParam | "Extrusion Start"
FabricationBottomElevationIncludeInsulationOfPart | "Bottom Elevation with Insulation"
FabricationBottomElevationOfPart | "Bottom Elevation"
FabricationBottomOfPart | "Lower End Bottom of Insulation Elevation"
FabricationBranchSize | "Size of Primary Branch End"
FabricationChangeServiceParam | "Change Service"
FabricationDoublewallMaterialAbbreviation | "Double Wall Material Abbreviation"
FabricationDuctworkStiffenerSpec | "Stiffener Specification"
FabricationEndOffsetParam | "End Middle Elevation"
FabricationEndSize | "Size of Connector End"
FabricationFittingDescription | "Fabrication Fitting Description"
FabricationInsulationAbbreviation | "Insulation Abbreviation"
FabricationInsulationMaterialFinish | "Insulation Material"
FabricationInsulationSpec | "Insulation Specification"
FabricationInsulationSpecificationAbbreviation | "Insulation Specification Abbreviation"
FabricationLevelParam | "Reference Level"
FabricationMaterialAbbreviation | "Material Abbreviation"
FabricationOffsetParam | "Middle Elevation"
FabricationPartAlias | "Alias"
FabricationPartAngle | "Angle"
FabricationPartAngleOption | "Angle Option"
FabricationPartBoughtOut | "Bought Out"
FabricationPartCutType | "Cut Type"
FabricationPartDepthIn | "Main Primary Depth"
FabricationPartDepthInOption | "Main Primary Depth Option"
FabricationPartDepthOut | "Main Secondary Depth"
FabricationPartDepthOutOption | "Main Secondary Depth Option"
FabricationPartDiameterIn | "Main Primary Diameter"
FabricationPartDiameterInOption | "Main Primary Diameter Option"
FabricationPartDiameterOut | "Main Secondary Diameter"
FabricationPartDiameterOutOption | "Main Secondary Diameter Option"
FabricationPartDoublewallMaterial | "Double Wall Material"
FabricationPartDoublewallMaterialArea | "Double Wall Material Area"
FabricationPartDoublewallMaterialThickness | "Double Wall Material Thickness"
FabricationPartInsulationArea | "Insulation Area"
FabricationPartItemNumber | "Item Number"
FabricationPartLength | "Length"
FabricationPartLengthOption | "Length Option"
FabricationPartLiningArea | "Lining Area"
FabricationPartMaterial | "Part Material"
FabricationPartMaterialThickness | "Part Material Thickness"
FabricationPartNotes | "Fabrication Notes"
FabricationPartPatNo | "Part Pattern Number"
FabricationPartSheetmetalArea | "Part Sheet Metal Area"
FabricationPartTakeoffDialogParam | "More Parameters"
FabricationPartWeight | "Weight"
FabricationPartWidthIn | "Main Primary Width"
FabricationPartWidthInOption | "Main Primary Width Option"
FabricationPartWidthOut | "Main Secondary Width"
FabricationPartWidthOutOption | "Main Secondary Width Option"
FabricationPipeInvertElevation | "Pipe Invert Elevation": This parameter is obsolete. It exists only for compatibility.
FabricationPrimarySize | "Size of Primary End"
FabricationProductCode | "Product Code"
FabricationProductDataFinishDescription | "Product Finish Description"
FabricationProductDataInstallType | "Install Type"
FabricationProductDataItemDescription | "Product Short Description"
FabricationProductDataLongDescription | "Product Long Description"
FabricationProductDataMaterialDescription | "Product Material Description"
FabricationProductDataOem | "OEM"
FabricationProductDataProduct | "Product Name"
FabricationProductDataRange | "Product Range"
FabricationProductDataSizeDescription | "Product Size Description"
FabricationProductDataSpecification | "Product Specification Description"
FabricationProductEntry | "Product Entry"
FabricationRelativeFilename | "Relative File Name"
FabricationRoutingSolutionsUiParam | "x of XX"
FabricationSecondarySize | "Size of Secondary End"
FabricationServiceAbbreviation | "Fabrication Service Abbreviation"
FabricationServiceName | "Fabrication Service Name"
FabricationServiceParam | "Fabrication Service"
FabricationSetUpDownTag | "SU/SD from Top"
FabricationSetUpDownTagFromBottom | "SU/SD from Bottom"
FabricationSlopeParam | "Slope"
FabricationSpecification | "Specification"
FabricationSpecificationAbbreviation | "Specification Abbreviation"
FabricationStartOffsetParam | "Start Middle Elevation"
FabricationTopElevationIncludeInsulationOfPart | "Top Elevation with Insulation"
FabricationTopElevationOfPart | "Top Elevation"
FabricationTopOfPart | "Upper End Top of Insulation Elevation"
FabricationVendor | "Vendor"
FabricationVendorCode | "Vendor Code"
FabricBendDiameter | "Bend Diameter": Standard Bend Diameter of Fabric Wire.
FabricNumber | "Fabric Number"
FabricParamCoverOffset | "Additional Cover Offset": Additional cover offset of the fabric distribution.
FabricParamCutByHost | "Cut by Host Cover": Single Fabric Sheet is cut or not cut by the Host Cover.
FabricParamCutOverallLength | "Cut Overall Length": Provides a real sheet Length after definition
FabricParamCutOverallWidth | "Cut Overall Width": Provides a real sheet Width after definition
FabricParamCutSheetMass | "Cut Sheet Mass": Calculated cut sheet mass [Sheet Mass per Unit Area * (Cut Overall Length * Cut Overall Width)]
FabricParamLapsplicePosition | "Lap Splice Position": Fabric lap splice position in the fabric distribution
FabricParamLocationGeneric | "Location": Fabric location in the host.
FabricParamLocationSlab | "Location": Fabric location in the slab
FabricParamLocationWall | "Location": Fabric location in the wall
FabricParamMajorLapspliceLength | "Major Lap Splice Length": Fabric lap splice length in major direction in the fabric distribution.
FabricParamMinorLapspliceLength | "Minor Lap Splice Length": Fabric lap splice length in minor direction in the fabric distribution.
FabricParamRounding | "Rounding Overrides"
FabricParamSharedFamilyKey | "Shared family key"
FabricParamSheetType | "Fabric Sheet": List all Fabric Sheet types
FabricParamSpanSymBottom | "Bottom"
FabricParamSpanSymDBottom | "D_Bottom"
FabricParamSpanSymDLeft | "D_Left"
FabricParamSpanSymDRight | "D_Right"
FabricParamSpanSymDTop | "D_Top"
FabricParamSpanSymLeft | "Left"
FabricParamSpanSymRight | "Right"
FabricParamSpanSymTop | "Top"
FabricParamSpanTagComponentReference | "Tag Component Reference"
FabricParamTagView | "Tag new members in view": List of all Plan Views and None.
FabricParamTotalSheetMass | "Total Sheet Mass": Calculated all sheet mass: Volume of Wire * Unit Weight.
FabricSheetDefaultMajorLapspliceLength | "Default Major Lap Splice Length": Default Major Lap Splice Length
FabricSheetDefaultMinorLapspliceLength | "Default Minor Lap Splice Length": Default Minor Lap Splice Length
FabricSheetLength | "Length": Length
FabricSheetMajorDirectionWireType | "Major Direction Wire Type": Major Direction Wire Type
FabricSheetMajorEndOverhang | "Major End Overhang": Major End Overhang
FabricSheetMajorLayoutPattern | "Major Layout Pattern": Major Layout Pattern
FabricSheetMajorNumberOfWires | "Major Number of Wires": Major Number of Wires
FabricSheetMajorReinforcementArea | "Major Reinforcement Area": Major Reinforcement Area
FabricSheetMajorSpacing | "Major Spacing": Major Spacing
FabricSheetMajorStartOverhang | "Major Start Overhang": Major Start Overhang
FabricSheetMass | "Sheet Mass": Sheet Mass
FabricSheetMassunit | "Sheet Mass per Unit Area": Structural Sheet Mass per Unit Area [Sheet Mass / (Overall Length * Overall Width)]
FabricSheetMinorDirectionWireType | "Minor Direction Wire Type": Minor Direction Wire Type
FabricSheetMinorEndOverhang | "Minor End Overhang": Minor End Overhang
FabricSheetMinorLayoutPattern | "Minor Layout Pattern": Minor Layout Pattern
FabricSheetMinorNumberOfWires | "Minor Number of Wires": Minor Number of Wires
FabricSheetMinorReinforcementArea | "Minor Reinforcement Area": Minor Reinforcement Area
FabricSheetMinorSpacing | "Minor Spacing": Minor Spacing
FabricSheetMinorStartOverhang | "Minor Start Overhang": Minor Start Overhang
FabricSheetOverallLength | "Overall Length": Overall Length
FabricSheetOverallWidth | "Overall Width": Overall Width
FabricSheetPhysicalMaterialAsset | "Physical Material Asset": Physical Material Asset
FabricSheetWidth | "Width": Width
FabricWireDiameter | "Nominal Diameter": Nominal Diameter of Fabric Wire.
FabricWireDistance | "Wire distance": The distance between wires
FabricWireLength | "Wire length": The wire length
FabricWireOffset | "Offset along wire direction": Offset along wire direction
FabricWireType | "Wire type": The wire type assigned
FaceroofLevelParam | "Reference Level"
FaceroofOffsetParam | "Level Offset"
FamilyAllowCutWithVoids | "Cut with Voids When Loaded"
FamilyAlwaysVertical | "Always vertical"
FamilyAutojoin | "Automatically joins geometry to walls"
FamilyBaseLevelOffsetParam | "Base Offset"
FamilyBaseLevelParam | "Base Level"
FamilyCanHostRebar | "Can host rebar"
FamilyCategoryPseudoParam | "Category"
FamilyContentPartType | "Part Type"
FamilyCurveAttachmentProportion | "Attachment Point"
FamilyCurveGstyleFor2010Mass | "Subcategory"
FamilyCurveGstylePlusInvisible | "Subcategory"
FamilyCurveGstylePlusInvisibleMinusAnalytical | "Subcategory"
FamilyCurveGstylePlusInvisiblePlusStickSym | "Subcategory"
FamilyCurveGstylePlusInvisiblePlusStickSymMinusAnalytical | "Subcategory"
FamilyElectricalMaintainAnnotationOrientation | "Maintain Annotation Orientation"
FamilyElemSubcategory | "Subcategory"
FamilyEnableCuttingInViews | "Enable Cutting in Views"
FamilyExportAsGeometry | "Always export as geometry"
FamilyFreeinstDefaultElevation | "Default Elevation"
FamilyHeightParam | "Height"
FamilyHostingBehavior | "Host"
FamilyIsElevationMarkBody | "Elevation Mark Use"
FamilyIsParametric | "Is parametric"
FamilyKeepTextReadable | "Keep text readable"
FamilyKeyExtParam | "Filter Parameter"
FamilyKeywordProtected | "Content protection enabled"
FamilyLevelParam | "Level"
FamilyLineLengthParam | "Length"
FamilyNamePseudoParam | "Family"
FamilyRenderingType | "Render Appearance Source"
FamilyRfaPathPseudoParam | "File Path"
FamilyRotateTextWithComponent | "Rotate text with component"
FamilyRotateWithComponent | "Rotate with component"
FamilyRoughHeightParam | "Rough Height"
FamilyRoughWidthParam | "Rough Width"
FamilyRoundconnectorDimensiontype | "Round Connector Dimension"
FamilySelfOrienting | "Align to View"
FamilyShared | "Shared"
FamilyStructFootingUseCapTop | "Cap"
FamilyStructMaterialType | "Material for Model Behavior"
FamilySymbolicRep | "Symbolic Representation"
FamilyThicknessParam | "Thickness"
FamilyTopLevelOffsetParam | "Top Offset"
FamilyTopLevelParam | "Top Level"
FamilyUsagePseudoParam | "Usage"
FamilyUsePrecutShape | "Show family pre-cut in plan views"
FamilyWidthParam | "Width"
FamilyWindowInsetParam | "Inset"
FamilyWorkPlaneBased | "Work Plane-Based"
FamilyWpbDefaultElevation | "Default Elevation"
FamProfileDefinition | "Profile Definition"
FamProfileUsage | "Profile Usage"
FasciaDepthParam | "Fascia Depth"
FasciaMaterialParam | "Material"
FasciaProfileParam | "Profile"
FbxAssetType | "Light Source"
FbxLightAtADistance | "At a distance"
FbxLightBallastLoss | "Ballast Loss"
FbxLightColorFilter | "Color Filter"
FbxLightDimmingLightColor | "Dimming Lamp Color Temperature Shift"
FbxLightEfficacy | "Efficacy"
FbxLightEmitCircleDiameter | "Emit from Circle Diameter"
FbxLightEmitLineLength | "Emit from Line Length"
FbxLightEmitRectangleLength | "Emit from Rectangle Length"
FbxLightEmitRectangleWidth | "Emit from Rectangle Width"
FbxLightEmitShapeVisible | "Emit Shape Visible in Rendering"
FbxLightIlluminance | "Illuminance"
FbxLightInitialColorCtrl | "Initial Color"
FbxLightInitialColorName | "Temperature Color"
FbxLightInitialColorTemperature | "Initial Color Temperature"
FbxLightInitialIntensity | "Initial Intensity"
FbxLightInitialIntensityInputMethod | "Initial Light Intensity Input Method"
FbxLightLampLumenDepr | "Lamp Lumen Depreciation"
FbxLightLampTiltLoss | "Lamp Tilt Loss"
FbxLightLimunousFlux | "Luminous Flux"
FbxLightLimunousIntensity | "Luminous Intensity"
FbxLightLossFactorCtrl | "Light Loss Factor"
FbxLightLossFactorMethod | "Light Loss Input Method"
FbxLightLumenaireDirt | "Luminaire Dirt Depreciation"
FbxLightPhotometricFile | "Photometric Web File"
FbxLightPhotometricFileCache | "None"
FbxLightPhotometrics | "Light Source Definition"
FbxLightPhotometricsFam | "Light Source Definition (family)"
FbxLightSourceDiameter | "Light Source Symbol Size"
FbxLightSourceLength | "Light Source Symbol Length"
FbxLightSpotBeamAngle | "Spot Beam Angle"
FbxLightSpotFieldAngle | "Spot Field Angle"
FbxLightSpotTiltAngle | "Tilt Angle"
FbxLightSurfaceLoss | "Surface Depreciation Loss"
FbxLightTemperatureLoss | "Temperature Loss"
FbxLightTotalLightLoss | "Total Light Loss Factor"
FbxLightVoltageLoss | "Voltage Loss"
FbxLightWattage | "Wattage"
FilledRegionMasking | "Masking"
FillPatternIdParam | "Cut fill pattern"
FillPatternIdParamNoNo | "Fill Pattern"
FireRating | "Fire Rating"
FixedRotation | "Fixed Rotation"
FlexibleInstanceFlip | "Flip"
FloorAttrDefaultHeightParam | "Default Height above level"
FloorAttrDefaultThicknessParam | "Default Thickness"
FloorAttrThicknessParam | "Thickness"
FloorHeightabovelevelParam | "Height Offset From Level"
FloorParamIsStructural | "Structural"
FloorParamSpanDirection | "Span Direction"
FloorStructureIdParam | "Structure"
FollowSurface | "Follow Surface"
ForegroundAnyPatternIdParam | "Foreground Fill Pattern"
ForegroundDraftPatternIdParam | "Foreground Fill Pattern"
ForegroundPatternColorParam | "Foreground Pattern Color"
FramingLengthRoundoff | "Structural Framing Length Roundoff"
FramingShapeClassification | "Framing Shape"
FrictionFactor | "Friction Factor"
FunctionParam | "Function"
GbxmlEditDataParam | "Energy Settings"
GenericDepth | "Depth"
GenericZoneName | "Name"
GeoLocation | "Shared Site"
GeomVisibilityParam | "Visibility/Graphics Overrides"
GraphicDisplayOptions | "Graphic Display Options"
GraphicDisplayOptionsBackground | "Background"
GraphicDisplayOptionsFog | "Depth Cueing"
GraphicDisplayOptionsLighting | "Lighting"
GraphicDisplayOptionsModel | "Model Display"
GraphicDisplayOptionsPhotoExposure | "Photographic Exposure"
GraphicDisplayOptionsShadows | "Shadows"
GraphicDisplayOptionsSketchyLines | "Sketchy Lines"
GraphicDisplayOptionsSsIntensity | "Sun and Shadow Intensity"
GridBankColNum | "Column"
GridBankColWidth | "Column Distance"
GridBankRowHeight | "Row Distance"
GridBankRowNum | "Row"
GridBubbleEndn1 | "Plan View Symbols End 1 (Default)"
GridBubbleEndn2 | "Plan View Symbols End 2 (Default)"
GridBubbleLinePen | "Bubble Weight Number\n"
GridCenterSegmentColor | "Center Segment Color"
GridCenterSegmentPattern | "Center Segment Pattern"
GridCenterSegmentStyle | "Center Segment"
GridCenterSegmentWeight | "Center Segment Weight"
GridEndSegmentColor | "End Segment Color"
GridEndSegmentPattern | "End Segment Pattern"
GridEndSegmentsLength | "End Segments Length"
GridEndSegmentWeight | "End Segment Weight"
GridHeadTag | "Symbol"
GridlineSpecStatus | "Type Association"
GridNetLocationMark | "Location Mark": Provides grid system association information
GroupAllowedViewTypes | "Allowed View Types"
GroupAttachedParentName | "Attached to"
GroupLevel | "Reference Level"
GroupnameParam | "Group Name for Ribbon Combo Items (for Use with XAML)"
GroupOffsetFromLevel | "Origin Level Offset"
GuideGridNameParam | "Name"
GuideGridSpacingParam | "Guide Spacing"
GutterMaterialParam | "Material"
GutterProfileParam | "Profile"
HandrailHandClearanceParam | "Hand Clearance"
HandrailHeightParam | "Height"
HandrailProjectionParam | "Projection"
HandrailSupportsJustificationParam | "Justification"
HandrailSupportsLayoutParam | "Layout"
HandrailSupportsNumberParam | "Number"
HandrailSupportsSpacingParam | "Spacing"
HandrailSupportsTypeParam | "Family"
HeadOnPlacementMethod | "Draw in Foreground"
HeavyEndPen | "Heavy End Pen Weight"
HeavyTickMarkPen | "Heavy End Pen Weight"
HighestAssociatedLevel | "Highest Associated Level": The highest level associated with this Analytical Element.
HostAreaComputed | "Area"
HostIdParam | "Host Id"
HostPanelScheduleAsPanelParam | "Categorize as"
HostPerimeterComputed | "Perimeter"
HostSseCurvedEdgeConditionParam | "Curved Edge Condition"
HostVolumeComputed | "Volume"
IconIndexParam | "Index Into Image File Name Array (for Use with XAML)"
IdParam | "Id"
IfcApplicationName | "IfcApplicationName"
IfcApplicationVersion | "IfcApplicationVersion"
IfcBuildingGuid | "IfcBuilding GUID"
IfcExportElement | "Export to IFC"
IfcExportElementAs | "Export to IFC As"
IfcExportElementType | "Export Type to IFC"
IfcExportElementTypeAs | "Export Type to IFC As"
IfcExportPredefinedtype | "IFC Predefined Type"
IfcExportPredefinedtypeType | "Type IFC Predefined Type"
IfcGuid | "IfcGUID"
IfcOrganization | "IfcOrganization"
IfcProjectGuid | "IfcProject GUID"
IfcSiteGuid | "IfcSite GUID"
IfcTypeGuid | "Type IfcGUID"
ImportAdtComponentsDesc | "Component Description"
ImportAdtEntityHeight | "Height"
ImportAdtEntityLength | "Length"
ImportAdtEntityRoll | "Roll"
ImportAdtEntityStructType | "Structural Type Name"
ImportAdtEntityStyle | "Style Name"
ImportAdtEntityThickness | "Thickness"
ImportAdtEntityType | "Type Name"
ImportAdtEntityWidth | "Width"
ImportBackground | "Draw Layer"
ImportBaseLevel | "Work Plane"
ImportBaseLevelOffset | "Offset from Work Plane"
ImportDisplayUnits | "Import Units"
ImportInstanceCuttingInView | "Enable Cutting in Views"
ImportInstanceScale | "Instance Scale"
ImportScale | "Scale Factor"
ImportSymbolName | "Name"
InfrastructureAlignmentDescription | "Description"
InfrastructureAlignmentDisplayedEndStation | "Displayed End Station"
InfrastructureAlignmentDisplayedStartStation | "Displayed Start Station"
InfrastructureAlignmentName | "Name"
InsertOrientation | "Orientation"
InstanceElevationParam | "Elevation from Level"
InstanceFreeHostOffsetParam | "Offset from Host"
InstanceFreeHostParam | "Host"
InstanceHeadHeightParam | "Head Height"
InstanceLengthParam | "Length"
InstanceMoveBaseWithGrids | "Move Base With Grids"
InstanceMovesWithGridParam | "Moves With Grids"
InstanceMoveTopWithGrids | "Move Top With Grids"
InstanceOffsetPosParam | "Moves With Nearby Elements"
InstanceReferenceLevelParam | "Reference Level"
InstanceScheduleOnlyLevelParam | "Schedule Level"
InstanceSillHeightParam | "Sill Height"
InstanceStructUsageParam | "Structural Usage"
InsulationScale | "Insulation Bulge to Width Ratio (1/x)"
InsulationWidth | "Insulation Width"
InteriorTickDisplay | "Interior Tick Mark Display"
IsVisibleParam | "Visible"
JoinStrengthOrder | "Abstract Join Strength Order"
JoistSystemClearSpacingParam | "Clear Spacing"
JoistSystemElemTagNewMembersView | "Tag new members in view"
JoistSystemFixedSpacingParam | "Fixed Spacing"
JoistSystemJustificationParam | "Justification"
JoistSystemLayoutRuleParam | "Layout Rule"
JoistSystemMaximumSpacingParam | "Maximum Spacing"
JoistSystemNewBeamTypeNoFamNameParam | "Beam Type (No Family Name)"
JoistSystemNewBeamTypeParam | "Beam Type"
JoistSystemNumBeamsSameType | "Num. of Beams With Same Type"
JoistSystemNumberOfLinesParam | "Number of Lines"
JoistSystemSpacingParam | "Centerline Spacing"
KeepReadable | "Keep Readable"
KeynoteNumber | "Key Value"
KeynoteParam | "Keynote"
KeynoteText | "Keynote Text"
KeySourceParam | "Key Source"
KeyValue | "Key Value"
LayerElemAreaComputed | "Area"
LayerElemBaseConstraint | "Base Constraint"
LayerElemBaseExtensionDis | "Base Extension Distance"
LayerElemCompoundElemFamily | "Compound Element Family"
LayerElemCompoundElemType | "Compound Element Type"
LayerElemFunction | "Function": Function
LayerElemIsCoreLayer | "Is Core Layer"
LayerElemIsStructuralMaterial | "Is Structural Material"
LayerElemIsVariable | "Is Variable"
LayerElemMaterials | "Material": Material
LayerElemOffsetFromHost | "Offset From Host"
LayerElemScheduleFamily | "Family"
LayerElemThickness | "Thickness": Thickness
LayerElemTopConstraint | "Top Constraint"
LayerElemTopExtensionDis | "Top Extension Distance"
LayerElemVolumeComputed | "Volume"
LayerTypeMaterials | "Material": Material
LayerTypeThickness | "Thickness": Thickness
LayoutnodeCurvetypeParam | "Curve Type Reference"
LeaderArrowhead | "Leader Arrowhead"
LeaderArrowWidth | "Arrow Width Angle"
LeaderLeftAttachment | "Left Attachment"
LeaderLine | "Leader Line"
LeaderOffsetSheet | "Leader/Border Offset"
LeaderRightAttachment | "Right Attachment"
LegendComponent | "Component Type"
LegendComponentDetailLevel | "Detail Level"
LegendComponentLength | "Host Length"
LegendComponentView | "View Direction"
LevelAttrRoomComputationAutomatic | "Automatic Room Computation Height"
LevelAttrRoomComputationHeight | "Computation Height"
LevelDataFloorArea | "Floor Area"
LevelDataFloorPerimeter | "Floor Perimeter"
LevelDataMassFamilyAndTypeParam | "Mass: Family and Type"
LevelDataMassFamilyParam | "Mass: Family"
LevelDataMassInstanceComments | "Mass: Comments"
LevelDataMassTypeComments | "Mass: Type Comments"
LevelDataMassTypeDescription | "Mass: Description"
LevelDataMassTypeParam | "Mass: Type"
LevelDataOwningLevel | "Level"
LevelDataSpaceUsage | "Usage"
LevelDataSurfaceArea | "Exterior Surface Area"
LevelDataVolume | "Floor Volume"
LevelElev | "Elevation"
LevelHeadTag | "Symbol"
LevelIsBuildingStory | "Building Story"
LevelIsGroundPlane | "Is ground plane"
LevelIsStructural | "Structural"
LevelName | "Level"
LevelParam | "Level"
LevelRelativeBaseType | "Elevation Base"
LevelRoomComputationHeight | "Computation Height"
LevelUpToLevel | "Story Above"
LightingFixtureLamp | "Lamp"
LightingFixtureLightEmitter | "Light Emitter"
LightingFixtureWattage | "Wattage Comments"
LinearDimType | "Dimension String Type"
LinearFramingLength | "Length"
LineColor | "Color"
LinePattern | "Line Pattern"
LinePen | "Line Weight"
LineShapeAtCorner | "Line Shape at Landing Corner"
LoadAllNon0Loads | "All non 0 loads"
LoadAreaArea | "Area"
LoadAreaForceFx1 | "Fx 1"
LoadAreaForceFx2 | "Fx 2"
LoadAreaForceFx3 | "Fx 3"
LoadAreaForceFy1 | "Fy 1"
LoadAreaForceFy2 | "Fy 2"
LoadAreaForceFy3 | "Fy 3"
LoadAreaForceFz1 | "Fz 1"
LoadAreaForceFz2 | "Fz 2"
LoadAreaForceFz3 | "Fz 3"
LoadAreaIsProjected | "Projected Load"
LoadArrowSeparation | "Distance between arrows"
LoadAttrAreaForceScaleFactor | "Area force scale"
LoadAttrForceArrowType | "Force arrowhead"
LoadAttrForceScaleFactor | "Force scale"
LoadAttrLinearForceScaleFactor | "Linear force scale"
LoadAttrMomentArrowArc | "Moment arrowhead"
LoadAttrMomentArrowLine | "Moment arrowhead (alternate)"
LoadAttrMomentScaleFactor | "Moment scale"
LoadCaseId | "Load Case"
LoadCaseName | "Name"
LoadCaseNature | "Nature"
LoadCaseNatureText | "Nature"
LoadCaseNumber | "Case Number"
LoadCaseSubcategory | "Category"
LoadCombinationFactor | "Factor"
LoadCombinationName | "Name"
LoadComments | "Comments"
LoadDescription | "Description"
LoadForceFx | "Fx"
LoadForceFy | "Fy"
LoadForceFz | "Fz"
LoadIsConstrainedOnHost | "Is constrained on host"
LoadIsHosted | "Is Hosted"
LoadIsProjected | "Projected Load"
LoadIsReaction | "Is Reaction"
LoadIsUniform | "Uniform Load"
LoadLinearForceFx1 | "Fx 1"
LoadLinearForceFx2 | "Fx 2"
LoadLinearForceFy1 | "Fy 1"
LoadLinearForceFy2 | "Fy 2"
LoadLinearForceFz1 | "Fz 1"
LoadLinearForceFz2 | "Fz 2"
LoadLinearLength | "Length"
LoadMomentMx | "Mx"
LoadMomentMx1 | "Mx 1"
LoadMomentMx2 | "Mx 2"
LoadMomentMy | "My"
LoadMomentMy1 | "My 1"
LoadMomentMy2 | "My 2"
LoadMomentMz | "Mz"
LoadMomentMz1 | "Mz 1"
LoadMomentMz2 | "Mz 2"
LoadNatureName | "Name"
LoadUsageName | "Name"
LoadUseLocalCoordinateSystem | "Orient to"
LockAlignmentUiToggle | "Lock": This is used by the UI to allow selection of lock alignment.
LockedBaseOffset | "Negative Offset"
LockedEndOffset | "Positive Offset"
LockedStartOffset | "Negative Offset"
LockedTopOffset | "Positive Offset"
LowestAssociatedLevel | "Lowest Associated Level": The lowest level associated with this Analytical Element.
LvMullionLeg1 | "Leg 1"
LvMullionLeg2 | "Leg 2"
MarkupsCreated | "Created"
MarkupsCreator | "Creator"
MarkupsHistory | "History"
MarkupsLabel | "Label"
MarkupsModified | "Modified"
MarkupsNotes | "Notes"
MarkupsPrivate | "Private"
MarkupsStatus | "Status"
MassDataConceptualConstruction | "Conceptual Types"
MassDataGlazingIsShaded | "Glazing is Shaded"
MassDataMassExteriorWallArea | "Mass Exterior Wall Area"
MassDataMassInteriorWallArea | "Mass Interior Wall Area"
MassDataMassOpeningArea | "Mass Opening Area"
MassDataMassRoofArea | "Mass Roof Area"
MassDataMassSkylightArea | "Mass Skylight Area"
MassDataMassWindowArea | "Mass Window Area"
MassDataPercentageGlazing | "Target Percentage Glazing"
MassDataPercentageSkylights | "Target Percentage Skylights"
MassDataShadeDepth | "Shade Depth"
MassDataSillHeight | "Target Sill Height"
MassDataSkylightWidth | "Skylight Width & Depth"
MassDataSlab | "Slab"
MassDataSubcategory | "Subcategory"
MassDataSurfaceDataSource | "Values"
MassDataUnderground | "Underground"
MassFloorAreaLevels | "Mass Floors"
MassGrossArea | "Gross Floor Area"
MassGrossSurfaceArea | "Gross Surface Area"
MassGrossVolume | "Gross Volume"
MassingIntegrationLevel | "Constrain to Massing"
MassSurfacedataMaterial | "Graphical Appearance"
MassZoneConditionTypeParam | "Condition Type"
MassZoneFloorArea | "Mass Floor Area"
MassZoneMaterial | "Graphical Appearance"
MassZoneSpaceTypeParam | "Space Type"
MassZoneVolume | "Mass Zone Volume"
MatchlineBottomOffset | "Bottom Offset"
MatchlineBottomPlane | "Bottom Constraint"
MatchlineTopOffset | "Top Offset"
MatchlineTopPlane | "Top Constraint"
MaterialArea | "Area"
MaterialAspaint | "As Paint"
MaterialAssetParamAssetLibId | "Asset library id"
MaterialAssetParamCommonSharedAsset | "Sharing"
MaterialAssetParamExternalMaterialId | "External Material ID"
MaterialAssetParamSource | "Source"
MaterialAssetParamSourceUrl | "Source URL"
MaterialIdParam | "Material"
MaterialName | "Name"
MaterialParamColor | "Color"
MaterialParamGlow | "Glow"
MaterialParamShininess | "Shininess"
MaterialParamSmoothness | "Smoothness"
MaterialParamTransparency | "Transparency"
MaterialVolume | "Volume"
MeasureFromStructure | "Extend into wall (to core)"
MechanicalEquipmentSetIdParam | "Mechanical Equipment Set"
MechanicalEquipmentSetName | "Name"
MechanicalEquipmentSetOnDuty | "On Duty"
MechanicalEquipmentSetOnStandby | "On Standby"
MepAirloopFantype | "Fan"
MepAirloopHeatexchangerType | "Heat Exchanger"
MepAirloopPreheatCoiltype | "Preheat Coil"
MepAnalyticalCriticalpathParam | "Critical Path"
MepAnalyticalElecCurrent | "Current"
MepAnalyticalElecCurrentRating | "Current Rating"
MepAnalyticalElecVoltage | "Voltage"
MepAnalyticalEquipmentName | "Name"
MepAnalyticalLoopBoundaryParam | "Loop Boundary"
MepAnalyticalLoopName | "Name"
MepAnalyticalPipeDesignflow | "Design Flow"
MepChilledWaterLoop | "Chilled Water Loop"
MepCondenserWaterLoop | "Condenser Water Loop"
MepCoolingCoilType | "Cooling Coil"
MepElecZoneEquipmentType | "Equipment Type"
MepEquipmentCalcPipingflowParam | "Calculated Flow"
MepEquipmentCalcPipingpressuredropParam | "Calculated Pressure Drop"
MepEquipmentClassification | "Classification"
MepHeatingCoilType | "Heating Coil"
MepHeatingHotwaterLoop | "Heating Hot Water Loop"
MepIgnoreFlowAnalysis | "Ignore Flow Analysis"
MepLowerBottomElevation | "Lower End Bottom Elevation"
MepLowerBottomElevationIncludeInsulation | "Lower End Bottom of Insulation Elevation"
MepLowerCenterlineElevation | "Lower End Centerline Elevation"
MepLowerTopElevation | "Lower End Top Elevation"
MepLowerTopElevationIncludeInsulation | "Lower End Top of Insulation Elevation"
MepPipeLowerInvertElevation | "Lower End Invert Elevation"
MepPipeLowerObvertElevation | "Lower End Obvert Elevation"
MepPipeUpperInvertElevation | "Upper End Invert Elevation"
MepPipeUpperObvertElevation | "Upper End Obvert Elevation"
MepPreheatHotwaterLoop | "Preheat Hot Water Loop"
MepProfileTypeParam | "Shape"
MepReheatCoilType | "Reheat Coil"
MepReheatHotwaterLoop | "Reheat Hot Water Loop"
MepSpotBottomElevation | "Spot Bottom Elevation": used for both design and fabrication components
MepSpotBottomElevationIncludeInsulation | "Spot Bottom of Insulation Elevation"
MepSpotCenterlineElevation | "Spot Centerline Elevation": used for both design and fabrication components
MepSpotTopElevation | "Spot Top Elevation": used for both design and fabrication components
MepSpotTopElevationIncludeInsulation | "Spot Top of Insulation Elevation"
MepSystemFillGraphicsOverridesParam | "Fill Pattern Graphics Overrides"
MepSystemLineGraphicsOverridesParam | "Graphic Overrides"
MepUpperBottomElevation | "Upper End Bottom Elevation"
MepUpperBottomElevationIncludeInsulation | "Upper End Bottom of Insulation Elevation"
MepUpperCenterlineElevation | "Upper End Centerline Elevation"
MepUpperTopElevation | "Upper End Top Elevation"
MepUpperTopElevationIncludeInsulation | "Upper End Top of Insulation Elevation"
MepVrfLoop | "Variable Refrigerant Flow Loop"
MepWaterloopChillertype | "Chiller Type"
MepWaterloopType | "Loop Type"
MepZoneAirLoop | "Air System"
MepZoneEquipment | "Zone Equipment"
MepZoneEquipmentBehavior | "Behavior"
MepZoneEquipmentDrawVentilation | "Draw Ventilation"
MepZoneEquipmentType | "Equipment Type"
MepZoneHotwaterLoop | "Heating Hot Water Loop"
ModelCategoryIdParam | "Subcategory"
ModelGraphicsStyle | "Visual Style"
ModelGraphicsStyleAnonDraft | "Visual Style"
ModelOrSymbolic | "Model or Symbolic"
ModelTextSize | "Text Size"
MovesWithGridParam | "Moves With Grids": Disable attachment from grids.
MullionAngle | "Angle"
MullionCornerType | "Corner Mullion"
MullionDepth | "Depth"
MullionDepth1 | "Depth 1"
MullionDepth2 | "Depth 2"
MullionFamType | "Mullion Family General Shape"
MullionOffset | "Offset"
MullionPosition | "Position"
MullionProfile | "Profile"
MultipleAlignmentUiToggle | "Multiple Alignment": This is used by the UI to allow selection of multiple elements.
MultiReferenceAnnotationDimensionStyle | "Dimension Style"
MultiReferenceAnnotationGroupTagHeads | "Group Matching Tag Heads"
MultiReferenceAnnotationReferenceCategory | "Reference Category"
MultiReferenceAnnotationShowDimensionText | "Show Dimension Text"
MultiReferenceAnnotationTagType | "Tag Family"
MultistoryStairsActualTreadDepth | "Actual Tread Depth"
MultistoryStairsRefLevel | "Reference Level": The reference level of stairs
NodeConnectionStatus | "Connection Status"
NumberPartitionParam | "Partition"
NumberSystemDisplayRule | "Display Rule"
NumberSystemJustify | "Justify"
NumberSystemJustifyOffset | "Justify Offset"
NumberSystemOrientation | "Orientation"
NumberSystemReference | "Reference"
NumberSystemReferenceOffset | "Offset from Reference"
NumberSystemTagType | "Tag Type"
NumberSystemTextSize | "Number Size"
ObjectStyleMaterialIdParam | "Object Style Material"
OffsetfacesShowShapeHandles | "Show Shape Handles"
OffsetFromReferenceBase | "Offset from Reference Base"
OmniclassCode | "OmniClass Number"
OmniclassDescription | "OmniClass Title"
OptionName | "Name"
OptionSetId | "Design Option Set Id"
OptionSetName | "Name"
OrdinateDimSetting | "Ordinate Dimension Settings"
OrientByView | "Rotate With Text"
OriginatingElementName | "Originating Element"
OvalFramingHeight | "Oval Height"
OvalFramingWidth | "Oval Width"
PaddingLength | "Padding"
PanelScheduleName | "Panel Schedule Name"
PartMakerDivisionProfileOffset | "Profile Offset"
PartmakerParamDivisionGap | "Gap"
PartMakerSplitterProfile | "Division Profile"
PartMakerSplitterProfileEdgeMatch | "Edge Match"
PartMakerSplitterProfileFlipAcross | "Profile Across Flip"
PartMakerSplitterProfileFlipAlong | "Profile Along Flip"
PathOfTravelFromRoom | "From Room"
PathOfTravelLevelName | "Level"
PathOfTravelSpeed | "Speed"
PathOfTravelTime | "Time"
PathOfTravelToRoom | "To Room"
PathOfTravelViewName | "View Name"
PathReinAddlOffset | "Additional Offset"
PathReinAlternating | "Alternating Bars"
PathReinAltOffset | "Alternating Bar - Offset"
PathReinEndHookOrient1Slab | "Primary Bar - End Hook Orientation"
PathReinEndHookOrient1Wall | "Primary Bar - End Hook Orientation"
PathReinEndHookOrient2Slab | "Alternating Bar - End Hook Orientation"
PathReinEndHookOrient2Wall | "Alternating Bar - End Hook Orientation"
PathReinEndHookTypen1 | "Primary Bar - End Hook Type"
PathReinEndHookTypen2 | "Alternating Bar - End Hook Type"
PathReinEndSpanhookAlt | "End Hook Angle Alternating"
PathReinEndSpanhookPrim | "End Hook Angle Primary"
PathReinFaceSlab | "Face"
PathReinFaceWall | "Face"
PathReinHookOrient1Slab | "Primary Bar - Hook Orientation"
PathReinHookOrient1Wall | "Primary Bar - Hook Orientation"
PathReinHookOrient2Slab | "Alternating Bar - Hook Orientation"
PathReinHookOrient2Wall | "Alternating Bar - Hook Orientation"
PathReinHookTypen1 | "Primary Bar - Start Hook Type"
PathReinHookTypen2 | "Alternating Bar - Start Hook Type"
PathReinLengthn1 | "Primary Bar - Length"
PathReinLengthn2 | "Alternating Bar - Length"
PathReinNumberOfBars | "Number Of Bars"
PathReinShapen1 | "Primary Bar - Shape"
PathReinShapen2 | "Alternating Bar - Shape"
PathReinSpacing | "Bar Spacing"
PathReinSpanhookAlt | "Start Hook Angle Alternating"
PathReinSpanhookPrim | "Start Hook Angle Primary"
PathReinSpanlengthAltOffset | "Offset"
PathReinSpanlengthBarlengthAlt | "Length (Alternating Bar)"
PathReinSpanlengthBarlengthPrim | "Length (Primary Bar)"
PathReinSpanlengthBottomAlt | "Bottom (Alternating Bar)"
PathReinSpanlengthBottomPrim | "Bottom (Primary Bar)"
PathReinSpanlengthTopAlt | "Top (Alternating Bar)"
PathReinSummary | "Summary"
PathReinTypen1 | "Primary Bar - Type"
PathReinTypen2 | "Alternating Bar - Type"
PatternIndent1ForDivisionRule | "Indent 1"
PatternIndent2ForDivisionRule | "Indent 2"
PatternMirrorForDivisionRule | "Mirror"
PeakAirflowParam | "Peak Airflow"
PeakCoolingLoadParam | "Peak Cooling Load"
PeakHeatingLoadParam | "Peak Heating Load"
PeakLatentCoolingLoad | "Peak Latent Cooling Load"
PhaseCreated | "Phase Created"
PhaseDemolished | "Phase Demolished"
PhaseName | "Name"
PhaseSequenceNumber | "Sequence Number"
PhyMaterialParamAverageModulus | "Average Modulus"
PhyMaterialParamBehavior | "Behavior"
PhyMaterialParamBending | "Bending"
PhyMaterialParamBendingReinforcement | "Bending reinforcement"
PhyMaterialParamClass | "Class"
PhyMaterialParamCompressionParallel | "Compression parallel to grain"
PhyMaterialParamCompressionPerpendicular | "Compression perpendicular to grain"
PhyMaterialParamConcreteCompression | "Concrete compression"
PhyMaterialParamExpCoeff | "Thermal expansion coefficient"
PhyMaterialParamExpCoeff1 | "Thermal expansion coefficient X"
PhyMaterialParamExpCoeff2 | "Thermal expansion coefficient Y"
PhyMaterialParamExpCoeff3 | "Thermal expansion coefficient Z"
PhyMaterialParamExpCoeffn1 | "Thermal Expansion Coefficient 1"
PhyMaterialParamExpCoeffn2 | "Thermal Expansion Coefficient 2"
PhyMaterialParamFivepercentModulusOfElacticity | "5% Modulus of Elasticity"
PhyMaterialParamGrade | "Grade"
PhyMaterialParamLightWeight | "Lightweight"
PhyMaterialParamMinimumTensileStrength | "Minimum tensile strength"
PhyMaterialParamMinimumYieldStress | "Minimum yield stress"
PhyMaterialParamPoissonMod | "Poisson ratio"
PhyMaterialParamPoissonMod1 | "Poisson ratio X"
PhyMaterialParamPoissonMod12 | "Poisson Ratio 12"
PhyMaterialParamPoissonMod2 | "Poisson ratio Y"
PhyMaterialParamPoissonMod23 | "Poisson Ratio 23"
PhyMaterialParamPoissonMod3 | "Poisson ratio Z"
PhyMaterialParamReductionFactor | "Reduction factor for shear"
PhyMaterialParamResistanceCalcStrength | "Resistance calculation strength"
PhyMaterialParamShearMod | "Shear modulus"
PhyMaterialParamShearMod1 | "Shear modulus X"
PhyMaterialParamShearMod12 | "Shear Modulus 12"
PhyMaterialParamShearMod2 | "Shear modulus Y"
PhyMaterialParamShearMod3 | "Shear modulus Z"
PhyMaterialParamShearParallel | "Shear parallel to grain"
PhyMaterialParamShearPerpendicular | "Shear perpendicular to grain"
PhyMaterialParamShearReinforcement | "Shear reinforcement yield stress"
PhyMaterialParamShearStrengthReduction | "Shear strength modification"
PhyMaterialParamSpecies | "Species"
PhyMaterialParamStructuralDensity | "Density"
PhyMaterialParamStructuralSpecificHeat | "Specific Heat"
PhyMaterialParamStructuralThermalTreated | "Thermally Treated"
PhyMaterialParamSubclass | "Subclass"
PhyMaterialParamTensionParallel | "Tension Parallel to Grain"
PhyMaterialParamTensionPerpendicular | "Tension Perpendicular to Grain"
PhyMaterialParamThermalConductivity | "Thermal Conductivity"
PhyMaterialParamThermalConductivityX | "Thermal Conductivity X"
PhyMaterialParamThermalConductivityY | "Thermal Conductivity Y"
PhyMaterialParamThermalConductivityZ | "Thermal Conductivity Z"
PhyMaterialParamType | "Material Type"
PhyMaterialParamUnitWeight | "Unit weight"
PhyMaterialParamWoodConstruction | "Construction"
PhyMaterialParamYoungMod | "Young modulus"
PhyMaterialParamYoungMod1 | "Young modulus X"
PhyMaterialParamYoungMod2 | "Young modulus Y"
PhyMaterialParamYoungMod3 | "Young modulus Z"
PhyMaterialParamYoungModn1 | "Young's Modulus 1"
PhyMaterialParamYoungModn2 | "Young's Modulus 2"
PhyMaterialProperties | "Properties"
PipeRoughness | "Roughness"
PipeVelocityPressure | "Velocity Pressure"
PipingConnectionType | "Connection Type"
PipingGenderType | "Gender Type"
PlacementBottom | "Bottom"
PlacementCenterX | "Center X"
PlacementCenterY | "Center Y"
PlacementLeft | "Left"
PlacementParamsShow | "Enable Position Parameters"
PlacementRight | "Right"
PlacementTop | "Top"
PlanRegionViewRange | "View Range"
PlanViewCutPlaneHeight | "Cut Plane Height"
PlanViewLevel | "Associated Level"
PlanViewNorth | "Orientation"
PlanViewRange | "View Range"
PlanViewTopClipHeight | "Top Clip Height"
PlanViewViewDir | "View Direction"
PlumbingFixturesCwConnection | "CW Connection"
PlumbingFixturesDrain | "Drain"
PlumbingFixturesHwConnection | "HW Connection"
PlumbingFixturesSupplyFitting | "Supply Fitting"
PlumbingFixturesSupplyPipe | "Supply Pipe"
PlumbingFixturesTrap | "Trap"
PlumbingFixturesVentConnection | "Vent Connection"
PlumbingFixturesWasteConnection | "Waste Connection"
PocheMatId | "Coarse Poche Material"
PointAdaptiveConstrained | "Constrained"
PointAdaptiveNumParam | "Number"
PointAdaptiveOrientationType | "Orients to"
PointAdaptiveShowNumber | "Show Placement Number"
PointAdaptiveTypeParam | "Point"
PointcloudinstanceName | "Name": The name of the instance as it will show in the Property Palette
PointcloudtypeScale | "Scale": The scale for this instance
PointElementAngle | "Angle"
PointElementChordLength | "Chord Length"
PointElementDriven | "Driven by Host"
PointElementDriving | "Driving Curve(s)"
PointElementHostedOnFaceUParam | "Hosted U Parameter"
PointElementHostedOnFaceVParam | "Hosted V Parameter"
PointElementHostedParam | "Hosted Parameter"
PointElementMeasureFrom | "Measure From"
PointElementMeasurementType | "Measurement Type"
PointElementMirrored | "Mirrored"
PointElementNonNormalizedCurveParamater | "Non-Normalized Curve Parameter"
PointElementNormalizedCurveParamater | "Normalized Curve Parameter"
PointElementNormalizedSegmentLength | "Normalized Segment Length"
PointElementOffset | "Offset"
PointElementRotationAngle | "Rotation Angle"
PointElementSegmentLength | "Segment Length"
PointElementShowNormalPlaneOnly | "Show Normal Reference Plane Only"
PointElementShowPlanes | "Show Reference Planes"
PointElementZflipped | "Flipped"
PointElevation | "Elevation"
PointFlexibleConstrained | "Constrained"
PointFlexibleNumParam | "Number"
PointFlexibleOrientationType | "Orientation"
PointFlexibleShowNumber | "Show Placement Number"
PointNameParam | "Name"
PointVisibilityParam | "Visibility/Graphics Overrides"
PreferDimSideUiFilter | "Prefer:": This is used by the UI to allow select prefer dimension side.
PreferPatternAlignUiFilter | "Pattern:": This is used by the UI to allow to select the preferred preference of aligning pattern.
PrimaryOptionId | "Primary Option Id"
Profile1Angle | "Angle"
Profile1FamType | "Profile"
Profile1FlippedHor | "Profile Is Flipped"
Profile1OffsetX | "Horizontal Profile Offset"
Profile1OffsetY | "Vertical Profile Offset"
Profile2Angle | "Angle"
Profile2FamType | "Profile"
Profile2FlippedHor | "Profile Is Flipped"
Profile2OffsetX | "Horizontal Profile Offset"
Profile2OffsetY | "Vertical Profile Offset"
ProfileAngle | "Angle"
ProfileFamType | "Profile"
ProfileFamTypePlusNone | "Profile"
ProfileFlippedHor | "Profile Is Flipped"
ProfileOffsetX | "Horizontal Profile Offset"
ProfileOffsetY | "Vertical Profile Offset"
ProfileParamAlongPath | "Parameter along path"
ProjectAddress | "Project Address"
ProjectAuthor | "Author"
ProjectBuildingName | "Building Name"
ProjectBuildingType | "Building Type"
ProjectedSurfaceArea | "Projected Area"
ProjectIssueDate | "Project Issue Date"
ProjectName | "Project Name"
ProjectNumber | "Project Number"
ProjectOrganizationDescription | "Organization Description"
ProjectOrganizationName | "Organization Name"
ProjectPostalCode | "Postal Code"
ProjectRevisionEnumeration | "Numbering"
ProjectRevisionRevisionDate | "Revision Date"
ProjectRevisionRevisionDescription | "Revision Description"
ProjectRevisionRevisionIssued | "Issued"
ProjectRevisionRevisionIssuedBy | "Issued by"
ProjectRevisionRevisionIssuedTo | "Issued to"
ProjectRevisionRevisionNum | "Revision Number"
ProjectRevisionSequenceNum | "Revision Sequence": read_only Make this read-only again when NewSchedules_DisplayTags is cleaned up
ProjectStatus | "Project Status"
PropertyArea | "Area"
PropertyAreaOpen | "Area"
PropertyAreaUnits | "Area Units, Format"
PropertyLengthUnits | "Units Format"
PropertySegmentBearing | "Bearing"
PropertySegmentDistance | "Distance"
PropertySegmentEW | "E/W"
PropertySegmentLR | "L/R"
PropertySegmentNS | "N/S"
PropertySegmentRadius | "Radius"
PropertySegmentSubcategoryId | "Subcategory"
PropertySetDescription | "Description"
PropertySetKeywords | "Keywords"
PropertySetMaterialAspect | "Material aspect"
PropertySetName | "Property Set Name"
PropertySubcategoryId | "Subcategory"
RadialArrayArcRadius | "Radius"
RadiusSymbolLocation | "Radius Symbol Location"
RadiusSymbolText | "Radius Symbol Text"
RailingSystemHandrailsHeightParam | "Height"
RailingSystemHandrailsLatteralOffset | "Lateral Offset"
RailingSystemHandrailsPositionParam | "Position"
RailingSystemHandrailsTypesParam | "Type"
RailingSystemHasTopRail | "Use Top Rail": Whether railing has top rail
RailingSystemSecondaryHandrailsHeightParam | "Height"
RailingSystemSecondaryHandrailsLatteralOffset | "Lateral Offset"
RailingSystemSecondaryHandrailsPositionParam | "Position"
RailingSystemSecondaryHandrailsTypesParam | "Type"
RailingSystemTopRailHeightParam | "Height"
RailingSystemTopRailTypesParam | "Type"
RampAttrLeftBalusterAttachPt | "Left Baluster Location"
RampAttrMaterial | "Ramp Material"
RampAttrMinInvSlope | "Ramp Max Slope (1/x)"
RampAttrRightBalusterAttachPt | "Right Baluster Location"
RampAttrShape | "Shape"
RampAttrTextFont | "Text Font"
RampAttrTextSize | "Text Size"
RampAttrThickness | "Thickness"
RampMaxRunLength | "Maximum Incline Length"
RasterEnableSnaps | "Enable Snaps"
RasterHorizontalScale | "Horizontal Scale"
RasterLockProportions | "Lock Proportions"
RasterSheetheight | "Height"
RasterSheetwidth | "Width"
RasterSymbolFilename | "Loaded from file"
RasterSymbolHeight | "Height"
RasterSymbolLinkloadStatus | "Link Status"
RasterSymbolPagenumber | "Page Number"
RasterSymbolPixelheight | "Height (pixels)"
RasterSymbolPixelwidth | "Width (pixels)"
RasterSymbolResolution | "Resolution (dpi)"
RasterSymbolViewname | "View Name"
RasterSymbolWidth | "Width"
RasterVerticalScale | "Vertical Scale"
RbsAdditionalFlow | "Additional Flow"
RbsAdjustableConnector | "Allow Slope Adjustments"
RbsAreaBasedLoadType | "Area Based Load Type"
RbsBuildingConstructionclass | "Building Infiltration Class"
RbsBuildingUseloadcredits | "Use Load Credits"
RbsCabletrayBendradius | "Bend Radius"
RbsCabletrayconduitBendorfitting | "Bend or Fitting"
RbsCabletrayconduitConnectorelemType | "Connector Type"
RbsCabletrayconduitrunLengthParam | "Length"
RbsCabletrayconduitSystemType | "System Type"
RbsCabletrayHeightParam | "Height"
RbsCabletrayRungheight | "Rung Height"
RbsCabletrayRungspace | "Rung Space"
RbsCabletrayRungwidth | "Rung Width"
RbsCabletrayrunHeightParam | "Height"
RbsCabletrayrunWidthParam | "Width"
RbsCabletrayShapetype | "Shape"
RbsCabletrayThickness | "Thickness"
RbsCabletrayWidthParam | "Width"
RbsCalculatedSize | "Size"
RbsComponentClassificationParam | "Component Classification"
RbsConduitBendradius | "Bend Radius"
RbsConduitDiameterParam | "Diameter(Trade Size)"
RbsConduitInnerDiamParam | "Inside Diameter"
RbsConduitOuterDiamParam | "Outside Diameter"
RbsConduitrunDiameterParam | "Diameter(Trade Size)"
RbsConduitrunInnerDiamParam | "Inside Diameter"
RbsConduitrunOuterDiamParam | "Outside Diameter"
RbsConduitTradesize | "Conduit Size Lookup"
RbsConnectorDescription | "Connector Description"
RbsConnectorIsprimary | "Primary Connector"
RbsConnectorOffsetObsolete | "Connector Offset"
RbsConstructionSetParam | "Schematic Types"
RbsConstructionTypeShadingfactorParam | "Internal Shading Factor"
RbsCtcBottomElevation | "Lower End Bottom Elevation"
RbsCtcServiceType | "Service Type"
RbsCtcTopElevation | "Upper End Top Elevation"
RbsCurveDiameterParam | "Diameter"
RbsCurveHeightParam | "Height"
RbsCurveHorOffsetParam | "Horizontal Justification"
RbsCurveSlope | "Slope Percentage (%)"
RbsCurveSurfaceArea | "Area"
RbsCurvetypeDefaultBendParam | "Bend"
RbsCurvetypeDefaultCapParam | "Cap"
RbsCurvetypeDefaultCrossParam | "Cross"
RbsCurvetypeDefaultElbowdownParam | "Vertical Outside Bend"
RbsCurvetypeDefaultElbowParam | "Elbow"
RbsCurvetypeDefaultElbowupParam | "Vertical Inside Bend"
RbsCurvetypeDefaultHorizontalBendParam | "Horizontal Bend"
RbsCurvetypeDefaultMechjointParam | "Flange"
RbsCurvetypeDefaultTakeoffParam | "Tap"
RbsCurvetypeDefaultTeedownParam | "Tee Down"
RbsCurvetypeDefaultTeeParam | "Tee"
RbsCurvetypeDefaultTeeupParam | "Tee Up"
RbsCurvetypeDefaultTransitionParam | "Transition"
RbsCurvetypeDefaultUnionParam | "Union"
RbsCurvetypeMaxHeightParam | "Max Height"
RbsCurvetypeMaxWidthParam | "Max Width"
RbsCurvetypeMultishapeTransitionOvalroundParam | "Multi Shape Transition Oval to Round"
RbsCurvetypeMultishapeTransitionParam | "Multi Shape Transition Rect to Round"
RbsCurvetypeMultishapeTransitionRectovalParam | "Multi Shape Transition Rect to Oval"
RbsCurvetypePreferredBranchParam | "Preferred Junction Type"
RbsCurveUtslope | "Slope"
RbsCurveVertOffsetParam | "Vertical Justification"
RbsCurveWidthParam | "Width"
RbsDistributionsysConfigParam | "Configuration"
RbsDistributionsysNumwiresParam | "Wires"
RbsDistributionsysPhaseParam | "Phase"
RbsDistributionsysVlgParam | "Line to Ground Voltage"
RbsDistributionsysVllParam | "Line to Line Voltage"
RbsDuctBottomElevation | "Lower End Bottom Elevation"
RbsDuctCalculatedSize | "Duct Size"
RbsDuctConnectorSystemClassificationParam | "System Classification"
RbsDuctFittingLossMethodParam | "Loss Method"
RbsDuctFittingLossMethodServerParam | "Loss Method"
RbsDuctFittingLossMethodSettings | "Loss Method Settings"
RbsDuctFittingLossTableParam | "ASHRAE Table"
RbsDuctFlowConfigurationParam | "Flow Configuration"
RbsDuctFlowDirectionParam | "Flow Direction"
RbsDuctFlowParam | "Flow"
RbsDuctPipeSystemAbbreviationParam | "System Abbreviation"
RbsDuctPressureDrop | "Pressure Drop"
RbsDuctRoutingPreferenceParam | "Routing Preferences"
RbsDuctSizeFormattedParam | "Size"
RbsDuctSlope | "Slope"
RbsDuctStaticPressure | "Static Pressure"
RbsDuctSystemCalculationParam | "Calculations"
RbsDuctSystemTypeParam | "System Type"
RbsDuctTopElevation | "Upper End Top Elevation"
RbsDuctTypeParam | "Duct Type"
RbsElecAmbientTemperature | "Ambient Temperature"
RbsElecAnalyticalArea | "Area"
RbsElecAnalyticalFeederLength | "Length"
RbsElecAnalyticalLevelId | "Level"
RbsElecAnalyticalLoadDensity | "Power Density"
RbsElecAnalyticalLoadNameParam | "Name"
RbsElecAnalyticalLoadSetOnDuty | "Quantity of Prime"
RbsElecAnalyticalLoadSetOnStandby | "Quantity on Standby"
RbsElecAnalyticalLoadSetOnTotal | "Total Quantity"
RbsElecAnalyticalLoadsInSet | "Loads in Set"
RbsElecAnalyticalLoadTypeParam | "Load Type"
RbsElecAnalyticalTotalCoincidentLoad | "Total Coincident Loads"
RbsElecApparentCurrentParam | "Apparent Current"
RbsElecApparentCurrentPhaseaParam | "Apparent Current Phase A"
RbsElecApparentCurrentPhasebParam | "Apparent Current Phase B"
RbsElecApparentCurrentPhasecParam | "Apparent Current Phase C"
RbsElecApparentLoad | "Apparent Load"
RbsElecApparentLoadPhase1 | "Apparent Load Phase 1"
RbsElecApparentLoadPhase2 | "Apparent Load Phase 2"
RbsElecApparentLoadPhase3 | "Apparent Load Phase 3"
RbsElecApparentLoadPhasea | "Apparent Load Phase A"
RbsElecApparentLoadPhaseb | "Apparent Load Phase B"
RbsElecApparentLoadPhasec | "Apparent Load Phase C"
RbsElecApparentPowerDensity | "Apparent Power Density"
RbsElecBalancedLoad | "Balanced Load"
RbsElecCalcCoefficientUtilization | "Calculate Coefficient of Utilization"
RbsElecCircuitConnectionTypeParam | "Connection Type"
RbsElecCircuitFrameParam | "Frame"
RbsElecCircuitLengthParam | "Length"
RbsElecCircuitName | "Load Name"
RbsElecCircuitNaming | "Circuit Naming"
RbsElecCircuitNamingIndex | "Circuit Naming Index"
RbsElecCircuitNotesParam | "Schedule Circuit Notes"
RbsElecCircuitNumber | "Circuit Number"
RbsElecCircuitNumberingType | "Circuit Numbering Option"
RbsElecCircuitNumberOfElementsParam | "Number of Elements"
RbsElecCircuitPanelParam | "Panel"
RbsElecCircuitPathModeParam | "Path Mode"
RbsElecCircuitPathOffsetParam | "Offset"
RbsElecCircuitPrefix | "Circuit Prefix"
RbsElecCircuitPrefixSeparator | "Circuit Prefix Separator"
RbsElecCircuitRatingParam | "Rating"
RbsElecCircuitSlotIndex | "Slot Index"
RbsElecCircuitStartSlot | "Start Slot"
RbsElecCircuitType | "System Type"
RbsElecCircuitWireNumGroundsParam | "# of Ground Conductors"
RbsElecCircuitWireNumHotsParam | "# of Hot Conductors"
RbsElecCircuitWireNumNeutralsParam | "# of Neutral Conductors"
RbsElecCircuitWireNumRunsParam | "# of Runs"
RbsElecCircuitWireSizeParam | "Wire Size"
RbsElecCircuitWireTypeParam | "Wire Type"
RbsElecDemandfactorDemandloadParam | "Estimated Demand Load"
RbsElecDemandfactorLoadclassificationParam | "Load Classification"
RbsElecDemandfactorLoadParam | "Connected Load"
RbsElecDistributionNodeLoadSet | "Load Set"
RbsElecDistributionNodeSupplyFrom | "Supply From"
RbsElecDistributionNodeSupplyFrom1 | "Supply From 1"
RbsElecDistributionNodeSupplyFrom2 | "Supply From 2"
RbsElecDistributionNodeSupplyTo | "Supply To"
RbsElecEditCircuitNamingSettingsParam | "Circuit Naming Settings"
RbsElecEnclosure | "Enclosure"
RbsElecLoadClassification | "Load Classification"
RbsElecLoadsummaryConnectedCurrentParam | "Connected Current"
RbsElecLoadsummaryConnectedLoadParam | "Connected Load (VA)"
RbsElecLoadsummaryDemandCurrentParam | "Estimated Demand Current"
RbsElecLoadsummaryDemandFactorParam | "Demand Factor"
RbsElecLoadsummaryDemandFactorRuleParam | "Description"
RbsElecLoadsummaryDemandLoadParam | "Estimated Demand (VA)"
RbsElecLoadsummaryLoadclassificationParam | "Load Classification"
RbsElecMains | "Mains"
RbsElecMaxPoleBreakers | "Max Number of Single Pole Breakers"
RbsElecModifications | "Modifications"
RbsElecMounting | "Mounting"
RbsElecNumberOfCircuits | "Max Number of Circuits"
RbsElecNumberOfPoles | "Number of Poles"
RbsElecPanelBranchCircuitApparentLoadPhasea | "Branch Circuit Apparent Load Phase A"
RbsElecPanelBranchCircuitApparentLoadPhaseb | "Branch Circuit Apparent Load Phase B"
RbsElecPanelBranchCircuitApparentLoadPhasec | "Branch Circuit Apparent Load Phase C"
RbsElecPanelBranchCircuitCurrentPhasea | "Branch Circuit Current Phase A"
RbsElecPanelBranchCircuitCurrentPhaseb | "Branch Circuit Current Phase B"
RbsElecPanelBranchCircuitCurrentPhasec | "Branch Circuit Current Phase C"
RbsElecPanelBussingParam | "Bussing"
RbsElecPanelConfigurationParam | "Panel Configuration"
RbsElecPanelCurrentPhaseaParam | "Current Phase A"
RbsElecPanelCurrentPhasebParam | "Current Phase B"
RbsElecPanelCurrentPhasecParam | "Current Phase C"
RbsElecPanelFeedParam | "Feed"
RbsElecPanelFeedThruLugsApparentLoadPhasea | "Feed Through Lugs Apparent Load Phase A"
RbsElecPanelFeedThruLugsApparentLoadPhaseb | "Feed Through Lugs Apparent Load Phase B"
RbsElecPanelFeedThruLugsApparentLoadPhasec | "Feed Through Lugs Apparent Load Phase C"
RbsElecPanelFeedThruLugsCurrentPhasea | "Feed Through Lugs Current Phase A"
RbsElecPanelFeedThruLugsCurrentPhaseb | "Feed Through Lugs Current Phase B"
RbsElecPanelFeedThruLugsCurrentPhasec | "Feed Through Lugs Current Phase C"
RbsElecPanelFeedThruLugsParam | "Feed Through Lugs"
RbsElecPanelGroundBusParam | "Ground Bus"
RbsElecPanelLocationParam | "Location"
RbsElecPanelMainstypeParam | "Mains Type"
RbsElecPanelMcbRatingParam | "MCB Rating"
RbsElecPanelName | "Panel Name"
RbsElecPanelNeutralBusParam | "Neutral Bus"
RbsElecPanelNeutralRatingParam | "Neutral Rating"
RbsElecPanelNumphasesParam | "Number of Phases"
RbsElecPanelNumwiresParam | "Number of Wires"
RbsElecPanelScheduleFooterNotesParam | "Schedule Footer Notes"
RbsElecPanelScheduleHeaderNotesParam | "Schedule Header Notes"
RbsElecPanelSubfeedLugsParam | "SubFeed Lugs"
RbsElecPanelSupplyFromParam | "Supply From"
RbsElecPanelTotalConnectedCurrentParam | "Total Connected Current"
RbsElecPanelTotalDemandCurrentParam | "Total Estimated Demand Current"
RbsElecPanelTotalDemandFactorParam | "Total Demand Factor"
RbsElecPanelTotalestloadHvacParam | "HVAC Total Estimated Demand"
RbsElecPanelTotalestloadLightParam | "Lighting Total Estimated Demand"
RbsElecPanelTotalestloadOtherParam | "Other Total Estimated Demand"
RbsElecPanelTotalestloadParam | "Total Estimated Demand"
RbsElecPanelTotalestloadPowerParam | "Power Total Estimated Demand"
RbsElecPanelTotalloadHvacParam | "HVAC Total Connected"
RbsElecPanelTotalloadLightParam | "Lighting Total Connected"
RbsElecPanelTotalloadOtherParam | "Other Total Connected"
RbsElecPanelTotalloadParam | "Total Connected"
RbsElecPanelTotalloadPowerParam | "Power Total Connected"
RbsElecPowerFactor | "Power Factor"
RbsElecPowerFactorState | "Power Factor State"
RbsElecRoomAverageIllumination | "Average Estimated Illumination"
RbsElecRoomCavityRatio | "Room Cavity Ratio"
RbsElecRoomLightingCalcLuminaireplane | "Lighting Calculation Luminaire Plane"
RbsElecRoomLightingCalcWorkplane | "Lighting Calculation Workplane"
RbsElecRoomReflectivityCeiling | "Ceiling Reflectance"
RbsElecRoomReflectivityFloor | "Floor Reflectance"
RbsElecRoomReflectivityWalls | "Wall Reflectance"
RbsElecShortCircuitRating | "Short Circuit Rating"
RbsElecSwitchIdParam | "Switch ID"
RbsElectricalData | "Electrical Data"
RbsElecTrueCurrentParam | "True Current"
RbsElecTrueCurrentPhaseaParam | "True Current Phase A"
RbsElecTrueCurrentPhasebParam | "True Current Phase B"
RbsElecTrueCurrentPhasecParam | "True Current Phase C"
RbsElecTrueLoad | "True Load"
RbsElecTrueLoadPhase1 | "True Load Phase 1"
RbsElecTrueLoadPhase2 | "True Load Phase 2"
RbsElecTrueLoadPhase3 | "True Load Phase 3"
RbsElecTrueLoadPhasea | "True Load Phase A"
RbsElecTrueLoadPhaseb | "True Load Phase B"
RbsElecTrueLoadPhasec | "True Load Phase C"
RbsElecVoltage | "Voltage"
RbsElecVoltageDropParam | "Voltage Drop"
RbsElecWireCircuits | "Circuits"
RbsElecWireElevation | "Elevation"
RbsElecWireGroundAdjustment | "Ground Conductors"
RbsElecWireHotAdjustment | "Hot Conductors"
RbsElecWireNeutralAdjustment | "Neutral Conductors"
RbsElecWireShareGround | "Share Ground Conductor"
RbsElecWireShareNeutral | "Share Neutral Conductor"
RbsElecWireTickmarkState | "Tick Marks"
RbsElecWireType | "Type"
RbsEndLevelParam | "End Level"
RbsEndOffsetParam | "End Middle Elevation"
RbsEnergyAnalysisBuildingEnvelopeAnalyticalGridCellSize | "Analytical Grid Cell Size"
RbsEnergyAnalysisBuildingEnvelopeAnalyticalSpaceIdentificationResolution | "Analytical Space Resolution"
RbsEnergyAnalysisBuildingEnvelopeAnalyticalSurfaceIdentificationResolution | "Analytical Surface Resolution"
RbsEnergyAnalysisBuildingEnvelopeDeterminationParam | "Building Envelope"
RbsEnergyAnalysisExportCategoryParam | "Export Category"
RbsEnergyAnalysisExportComplexityParam | "Export Complexity"
RbsEnergyAnalysisExportGbxmlDefaultsParam | "Export Default Values"
RbsEnergyAnalysisGroundPlaneParam | "Ground Plane"
RbsEnergyAnalysisIncludeThermalProperties | "Detailed Elements"
RbsEnergyAnalysisMode | "Mode"
RbsEnergyAnalysisProjectPhaseParam | "Project Phase"
RbsEnergyAnalysisSliverSpaceTolerance | "Sliver Space Tolerance"
RbsEnergyAnalysisSurfaceAdjacentSpaceId1 | "Adjacent Space Id (1)"
RbsEnergyAnalysisSurfaceAdjacentSpaceId2 | "Adjacent Space Id (2)"
RbsEnergyAnalysisSurfaceAzimuth | "Azimuth"
RbsEnergyAnalysisSurfaceCadobjectid | "CADObjectID"
RbsEnergyAnalysisSurfaceOriginX | "Origin (X)"
RbsEnergyAnalysisSurfaceOriginY | "Origin (Y)"
RbsEnergyAnalysisSurfaceOriginZ | "Origin (Z)"
RbsEnergyAnalysisSurfaceTilt | "Tilt"
RbsEnergyAnalysisViewBuildingShellMode | "Show Analytical Building Shell"
RbsEnergyAnalysisViewCoordAxisMode | "Show a Coordinate System Symbol for each Surface"
RbsEnergyAnalysisViewInnerShellMode | "Show Inner Space Shells"
RbsEnergyAnalysisViewOuterShellMode | "Show Analytical Space Shells"
RbsEnergyAnalysisViewRbeMode | "Show Room Bounding Elements Dimmed and Underlay"
RbsEnergyAnalysisViewShadingSurfacesMode | "Show Shading Surfaces"
RbsEnergyAnalysisViewSurfacesMode | "Show Surfaces"
RbsEnergyAnalysisViewTransparentMode | "Show Surfaces Transparent"
RbsEnergyAnalysisViewUpdateSurfaces | "Update Surfaces"
RbsEqDiameterParam | "Equivalent Diameter"
RbsFamilyContentAnnotationDisplay | "Use Annotation Scale"
RbsFamilyContentDistributionSystem | "Distribution System"
RbsFamilyContentOffsetHeight | "OffsetHeight"
RbsFamilyContentOffsetWidth | "OffsetWidth"
RbsFamilyContentSecondaryDistribsys | "Secondary Distribution System"
RbsFamilyContentTakeoffFixedLength | "Takeoff Fixed Length"
RbsFamilyContentTakeoffLength | "Takeoff Length"
RbsFamilyContentTakeoffProjlength | "Takeoff Length Projection"
RbsFlexductRoundtypeParam | "Flex Duct Type"
RbsFlexDuctTypeParam | "Flex Duct Type"
RbsFlexPatternParam | "Flex Pattern"
RbsFlexPipeTypeParam | "Flex Pipe"
RbsFlowFactorParam | "Flow Factor"
RbsFlowObsolete | "Flow"
RbsFpSprinklerCoverageParam | "Coverage"
RbsFpSprinklerKFactorParam | "K-Factor"
RbsFpSprinklerOrificeParam | "Orifice"
RbsFpSprinklerOrificeSizeParam | "Orifice Size"
RbsFpSprinklerPressureClassParam | "Pressure Class"
RbsFpSprinklerResponseParam | "Response"
RbsFpSprinklerTemperatureRatingParam | "Temperature Rating"
RbsFriction | "Friction"
RbsGbxmlOpeningType | "Opening Type"
RbsGbxmlSurfaceArea | "Area"
RbsGbxmlSurfaceName | "Surface Name"
RbsGbxmlSurfaceType | "Surface Type"
RbsHvacloadDoorAreaParam | "Door Area"
RbsHvacloadDoorCoolingLoadParam | "Door Cooling Load"
RbsHvacloadFloorAreaParam | "Floor Area"
RbsHvacloadPartitionAreaParam | "Partition Area"
RbsHvacloadPartitionCoolingLoadParam | "Partition Cooling Load"
RbsHvacloadPlenumCoolingLoadParam | "Plenum Cooling Load"
RbsHvacloadRoofAreaParam | "Roof Area"
RbsHvacloadRoofCoolingLoadParam | "Roof Cooling Load"
RbsHvacloadSkylightAreaParam | "Skylight Area"
RbsHvacloadSkylightCoolingLoadParam | "Skylight Cooling Load"
RbsHvacloadWallAreaParam | "Wall Area"
RbsHvacloadWallCoolingLoadParam | "Wall Cooling Load"
RbsHvacloadWindowAreaParam | "Window Area"
RbsHvacloadWindowCoolingLoadParam | "Window Cooling Load"
RbsHydraulicDiameterParam | "Hydraulic Diameter"
RbsInsulationLiningVolume | "Volume"
RbsInsulationThickness | "Insulation Thickness"
RbsInsulationThicknessForDuct | "Insulation Thickness"
RbsInsulationThicknessForPipe | "Insulation Thickness"
RbsIsCustomFitting | "IsCustom"
RbsLiningThickness | "Lining Thickness"
RbsLiningThicknessForDuct | "Lining Thickness"
RbsLoadSubClassificationMotor | "Load Sub-Classification Motor"
RbsLookupTableName | "Lookup Table Name"
RbsLossCoefficient | "Loss Coefficient"
RbsMaxFlow | "Max Flow"
RbsMinFlow | "Min Flow"
RbsOffsetParam | "Middle Elevation"
RbsPanelScheduleSheetAppearanceInstParam | "Appearance"
RbsPanelScheduleSheetAppearanceParam | "Appearance On Sheet"
RbsParallelconduitsHorizontalNumber | "Horizontal Number for parallel conduits"
RbsParallelconduitsHorizontalOffsetValue | "Horizontal Offset value for parallel conduits"
RbsParallelconduitsVerticalNumber | "Vertical Number for parallel conduits"
RbsParallelconduitsVerticalOffsetValue | "Vertical Offset value for parallel conduits"
RbsParallelpipesHorizontalNumber | "Horizontal Number for parallel pipes"
RbsParallelpipesHorizontalOffsetValue | "Horizontal Offset value for parallel pipes"
RbsParallelpipesVerticalNumber | "Vertical Number for parallel pipes"
RbsParallelpipesVerticalOffsetValue | "Vertical Offset value for parallel pipes"
RbsPartType | "Part Type"
RbsPipeAdditionalFlowParam | "Additional Flow"
RbsPipeBottomElevation | "Lower End Bottom Elevation"
RbsPipeCalculatedSize | "Pipe Size"
RbsPipeClassParam | "Schedule/Type"
RbsPipeConnectiontypeParam | "Connection Type"
RbsPipeConnectorSystemClassificationParam | "System Classification"
RbsPipeCwfuParam | "CWFU"
RbsPipeDiameterParam | "Diameter"
RbsPipeFittingLossKfactorParam | "K Coefficient"
RbsPipeFittingLossMethodParam | "Loss Method"
RbsPipeFittingLossMethodServerParam | "Loss Method"
RbsPipeFittingLossMethodSettings | "Loss Method Settings"
RbsPipeFittingLossTableParam | "K Coefficient Table"
RbsPipeFixtureUnitsParam | "Fixture Units"
RbsPipeFlowConfigurationParam | "Flow Configuration"
RbsPipeFlowDirectionParam | "Flow Direction"
RbsPipeFlowParam | "Flow"
RbsPipeFlowStateParam | "Flow State"
RbsPipeFluidDensityParam | "Fluid Density"
RbsPipeFluidTemperatureParam | "Fluid Temperature"
RbsPipeFluidTypeParam | "Fluid Type"
RbsPipeFluidViscosityParam | "Fluid Dynamic Viscosity"
RbsPipeFrictionParam | "Friction"
RbsPipeHwfuParam | "HWFU"
RbsPipeInnerDiamParam | "Inside Diameter"
RbsPipeInsulationThickness | "Insulation Thickness"
RbsPipeInvertElevation | "Invert Elevation": This parameter is obsolete. It exists only for compatibility.
RbsPipeJointtypeParam | "Connection Type"
RbsPipeMaterialParam | "Material"
RbsPipeOuterDiameter | "Outside Diameter"
RbsPipePressuredropParam | "Pressure Drop"
RbsPipeReynoldsNumberParam | "Reynolds Number"
RbsPipeSegmentParam | "Pipe Segment"
RbsPipeSizeFormattedParam | "Size"
RbsPipeSizeMaximum | "Maximum Size"
RbsPipeSizeMinimum | "Minimum Size"
RbsPipeSlope | "Slope"
RbsPipeSlopeDefParam | "Pipe Slope Definitions"
RbsPipeSlopeOptionsDefParam | "Pipe Slope Options"
RbsPipeStaticPressure | "Static Pressure"
RbsPipeSystemCalculationParam | "Calculations"
RbsPipeSystemFixtureUnitParam | "Fixture Units"
RbsPipeTopElevation | "Upper End Top Elevation"
RbsPipeTypeFittingLossKfactorParam | "K Coefficient"
RbsPipeTypeFittingLossMethodParam | "Loss Method"
RbsPipeTypeFittingLossTableParam | "K Coefficient Table"
RbsPipeTypeParam | "Pipe Type"
RbsPipeTypeValveLossCvfactorParam | "Cv Coefficient"
RbsPipeValveLossCvfactorParam | "Cv Coefficient"
RbsPipeVelocityParam | "Velocity"
RbsPipeVolumeParam | "Volume"
RbsPipeWallThickness | "Wall Thickness"
RbsPipeWfuParam | "WFU"
RbsPipingSystemTypeParam | "System Type"
RbsPressureDrop | "Pressure Drop"
RbsProjectConstructionTypeShadingfactorParam | "Internal Shading Factor"
RbsProjectLocationParam | "Location"
RbsProjectReporttypeParam | "Report Type"
RbsReferenceFreesize | "Free Size"
RbsReferenceInsulationThickness | "Insulation Thickness"
RbsReferenceInsulationType | "Insulation Type"
RbsReferenceLiningThickness | "Lining Thickness"
RbsReferenceLiningType | "Lining Type"
RbsReferenceOverallsize | "Overall Size"
RbsReynoldsnumberParam | "Reynolds number"
RbsRoomCoefficientUtilization | "Coefficient of Utilization"
RbsRoutingPreferenceParam | "Routing Preferences"
RbsSection | "Section"
RbsSegmentDescriptionParam | "Segment Description"
RbsServiceTypeParam | "Building Service"
RbsShowProfileType | "Show Round"
RbsSizeLock | "Size Lock"
RbsStartLevelParam | "Reference Level"
RbsStartOffsetParam | "Start Middle Elevation"
RbsSystemAbbreviationParam | "Abbreviation"
RbsSystemBaseElementParam | "System Equipment"
RbsSystemClassificationParam | "System Classification"
RbsSystemFlowConversionMethodParam | "Flow Conversion Method"
RbsSystemNameParam | "System Name"
RbsSystemNumElementsParam | "Number of Elements"
RbsSystemRisedrop1linedropsymbolParam | "Single Line Drop Symbol"
RbsSystemRisedrop1linerisesymbolParam | "Single Line Rise Symbol"
RbsSystemRisedrop1lineteedownsymbolParam | "Single Line Tee Down Symbol"
RbsSystemRisedrop1lineteeupsymbolParam | "Single Line Tee Up Symbol"
RbsSystemRisedrop2linedropsymbolParam | "Two Line Drop Symbol"
RbsSystemRisedrop2linerisesymbolParam | "Two Line Rise Symbol"
RbsSystemRisedropParam | "Rise / Drop Symbol"
RbsVelocity | "Velocity"
RbsVelocityPressure | "Velocity Pressure"
RbsVoltagetypeMaxvoltageParam | "Maximum Voltage"
RbsVoltagetypeMinvoltageParam | "Minimum Voltage"
RbsVoltagetypeVoltageParam | "Actual Voltage"
RbsWireCircuitDescription | "Circuit Description"
RbsWireCircuitLoadName | "Circuit Load Name"
RbsWireConduitTypeParam | "Conduit Type"
RbsWireInsulationParam | "Insulation"
RbsWireMaterialParam | "Material"
RbsWireMaxConductorSizeParam | "Max Size"
RbsWireNeutralIncludedInBalancedLoadParam | "Neutral Included in Balanced Load"
RbsWireNeutralModeParam | "Neutral Size"
RbsWireNeutralMultiplierParam | "Neutral Multiplier"
RbsWireNumConductorsParam | "Number of Conductors"
RbsWireTemperatureRatingParam | "Temperature Rating"
RebarAlignmentOptions | "Bar Alignment"
RebarBarDeformationType | "Deformation"
RebarBarDiameter | "Bar Diameter"
RebarBarHookLengths | "Hook Lengths"
RebarBarMaximumBendRadius | "Maximum Bend Radius"
RebarBarStirrupBendDiameter | "Stirrup/Tie Bend Diameter"
RebarBarStyle | "Subcategory"
RebarContainerBarType | "Bar Type"
RebarDistributionType | "Distribution Type"
RebarElemBarSpacing | "Spacing"
RebarElemEndtreatmentEnd | "End Treatment At End"
RebarElemEndtreatmentStart | "End Treatment At Start"
RebarElementRounding | "Rounding Overrides"
RebarElementVisibility | "View Visibility States"
RebarElemHookEndOrient | "Hook Orientation At End"
RebarElemHookEndType | "Hook At End"
RebarElemHookStartOrient | "Hook Orientation At Start"
RebarElemHookStartType | "Hook At Start"
RebarElemHookStyle | "Style"
RebarElemHostMark | "Host Mark"
RebarElemLayoutRule | "Layout Rule"
RebarElemLength | "Bar Length"
RebarElemQuantityOfBars | "Quantity"
RebarElemScheduleMark | "Schedule Mark"
RebarElemTotalLength | "Total Bar Length"
RebarFreeFormHookEndPlaneAngle | "Hook Orientation At End"
RebarFreeFormHookStartPlaneAngle | "Hook Orientation At Start"
RebarGeometryType | "Geometry"
RebarHookAngle | "Hook Angle"
RebarHookLengthOverride | "Override Hook Lengths"
RebarHookLineLenFactor | "Extension Multiplier"
RebarHookRotationAtEnd | "Hook Rotation At End"
RebarHookRotationAtEndSchedulesTagsFilters | "Hook Rotation At End"
RebarHookRotationAtStart | "Hook Rotation At Start"
RebarHookRotationAtStartSchedulesTagsFilters | "Hook Rotation At Start"
RebarHookStyle | "Style"
RebarHostCategory | "Host Category"
RebarIncludeFirstBar | "Include First Bar"
RebarIncludeLastBar | "Include Last Bar"
RebarInstanceBarDiameter | "Bar Diameter"
RebarInstanceBarModelDiameter | "Model Bar Diameter"
RebarInstanceBendDiameter | "Bend Diameter"
RebarInstanceStirrupTieAttachment | "Stirrup/Tie Attachment"
RebarInternalMultiplanar | "INTERNAL: Multiplanar"
RebarInternalMultiplanarArcConnector | "INTERNAL: Multiplanar Arc Connector"
RebarInternalMultiplanarDuplicate | "INTERNAL: Multiplanar Duplicate"
RebarInternalMultiplanarEndConnector | "INTERNAL: Multiplanar End Connector"
RebarInternalMultiplanarStartConnector | "INTERNAL: Multiplanar Start Connector"
RebarMaximSuffix | "Maxim Suffix"
RebarMaxLength | "Maximum bar length"
RebarMinimSuffix | "Minim Suffix"
RebarMinLength | "Minimum bar length"
RebarModelBarDiameter | "Model Bar Diameter"
RebarModifiedSet | "Modified Rebar Set"
RebarNumber | "Rebar Number"
RebarNumberSuffix | "Rebar Number Suffix"
RebarQuanityByDistrib | "Quantity By Rebar Set"
RebarShape | "Shape"
RebarShapeAllowedBarTypes | "Allowable Rebar Bar Types"
RebarShapeEndHookLength | "End Hook Length"
RebarShapeEndHookOffset | "End Hook Offset Length"
RebarShapeEndtreatmentEndType | "End Treatment At End"
RebarShapeEndtreatmentStartType | "End Treatment At Start"
RebarShapeHookEndType | "Hook At End"
RebarShapeHookRotationAtEnd | "Hook Rotation At End"
RebarShapeHookRotationAtStart | "Hook Rotation At Start"
RebarShapeHookStartType | "Hook At Start"
RebarShapeHookStyle | "Style"
RebarShapeImage | "Shape Image"
RebarShapeOutOfPlaneBendDiameter | "Out of Plane Bend Diameter"
RebarShapeParamEndHookTanLen | "End Tangent Hook Length"
RebarShapeParamStartHookTanLen | "Start Tangent Hook Length"
RebarShapeSpiralBaseFinishingTurns | "Base Finishing Turns"
RebarShapeSpiralHeight | "Height"
RebarShapeSpiralPitch | "Pitch"
RebarShapeSpiralTopFinishingTurns | "Top Finishing Turns"
RebarShapeStartHookLength | "Start Hook Length"
RebarShapeStartHookOffset | "Start Hook Offset Length"
RebarShapeStirrupTieAttachment | "Stirrup/Tie Attachment"
RebarStandardBendDiameter | "Standard Bend Diameter"
RebarStandardHookBendDiameter | "Standard Hook Bend Diameter"
RebarSystemActiveBackDirn1 | "Interior Major Direction"
RebarSystemActiveBackDirn2 | "Interior Minor Direction"
RebarSystemActiveBottomDir1Generic | "Bottom/Interior Major Direction"
RebarSystemActiveBottomDir2Generic | "Bottom/Interior Minor Direction"
RebarSystemActiveBottomDirn1 | "Bottom Major Direction"
RebarSystemActiveBottomDirn2 | "Bottom Minor Direction"
RebarSystemActiveFrontDirn1 | "Exterior Major Direction"
RebarSystemActiveFrontDirn2 | "Exterior Minor Direction"
RebarSystemActiveTopDir1Generic | "Top/Exterior Major Direction"
RebarSystemActiveTopDir2Generic | "Top/Exterior Minor Direction"
RebarSystemActiveTopDirn1 | "Top Major Direction"
RebarSystemActiveTopDirn2 | "Top Minor Direction"
RebarSystemAddlBottomOffset | "Additional Bottom Cover Offset"
RebarSystemAddlExteriorOffset | "Additional Exterior Cover Offset"
RebarSystemAddlInteriorOffset | "Additional Interior Cover Offset"
RebarSystemAddlTopOffset | "Additional Top Cover Offset"
RebarSystemBarTypeBackDirn1 | "Interior Major Bar Type"
RebarSystemBarTypeBackDirn2 | "Interior Minor Bar Type"
RebarSystemBarTypeBottomDir1Generic | "Bottom/Interior Major Bar Type"
RebarSystemBarTypeBottomDir2Generic | "Bottom/Interior Minor Bar Type"
RebarSystemBarTypeBottomDirn1 | "Bottom Major Bar Type"
RebarSystemBarTypeBottomDirn2 | "Bottom Minor Bar Type"
RebarSystemBarTypeFrontDirn1 | "Exterior Major Bar Type"
RebarSystemBarTypeFrontDirn2 | "Exterior Minor Bar Type"
RebarSystemBarTypeTopDir1Generic | "Top/Exterior Major Bar Type"
RebarSystemBarTypeTopDir2Generic | "Top/Exterior Minor Bar Type"
RebarSystemBarTypeTopDirn1 | "Top Major Bar Type"
RebarSystemBarTypeTopDirn2 | "Top Minor Bar Type"
RebarSystemBottomMajorMatchesBottomMinor | "Bottom Major and Minor Layers Match"
RebarSystemCoverBottom | "Rebar Cover Bottom/Interior"
RebarSystemCoverSide | "Rebar Cover Side/Edge"
RebarSystemCoverTop | "Rebar Cover Top/Exterior"
RebarSystemHookOrientBackDirn1 | "Interior Major Hook Orientation"
RebarSystemHookOrientBackDirn2 | "Interior Minor Hook Orientation"
RebarSystemHookOrientBottomDirn1 | "Bottom Major Hook Orientation"
RebarSystemHookOrientBottomDirn2 | "Bottom Minor Hook Orientation"
RebarSystemHookOrientFrontDirn1 | "Exterior Major Hook Orientation"
RebarSystemHookOrientFrontDirn2 | "Exterior Minor Hook Orientation"
RebarSystemHookOrientTopDirn1 | "Top Major Hook Orientation"
RebarSystemHookOrientTopDirn2 | "Top Minor Hook Orientation"
RebarSystemHookTypeBackDirn1 | "Interior Major Hook Type"
RebarSystemHookTypeBackDirn2 | "Interior Minor Hook Type"
RebarSystemHookTypeBottomDirn1 | "Bottom Major Hook Type"
RebarSystemHookTypeBottomDirn2 | "Bottom Minor Hook Type"
RebarSystemHookTypeFrontDirn1 | "Exterior Major Hook Type"
RebarSystemHookTypeFrontDirn2 | "Exterior Minor Hook Type"
RebarSystemHookTypeTopDirn1 | "Top Major Hook Type"
RebarSystemHookTypeTopDirn2 | "Top Minor Hook Type"
RebarSystemLayerSummaryBottomDir1NoSpacing | "Bottom/Interior Major (Brief)"
RebarSystemLayerSummaryBottomDir1WithSpacing | "Bottom/Interior Major"
RebarSystemLayerSummaryBottomDir2NoSpacing | "Bottom/Interior Minor (Brief)"
RebarSystemLayerSummaryBottomDir2WithSpacing | "Bottom/Interior Minor"
RebarSystemLayerSummaryDir1NoSpacing | "Major, Both Faces (Brief)"
RebarSystemLayerSummaryDir1WithSpacing | "Major, Both Faces"
RebarSystemLayerSummaryDir2NoSpacing | "Minor, Both Faces (Brief)"
RebarSystemLayerSummaryDir2WithSpacing | "Minor, Both Faces"
RebarSystemLayerSummaryNoSpacing | "Layer Summary (Brief)"
RebarSystemLayerSummaryTopDir1NoSpacing | "Top/Exterior Major (Brief)"
RebarSystemLayerSummaryTopDir1WithSpacing | "Top/Exterior Major"
RebarSystemLayerSummaryTopDir2NoSpacing | "Top/Exterior Minor (Brief)"
RebarSystemLayerSummaryTopDir2WithSpacing | "Top/Exterior Minor"
RebarSystemLayerSummaryWithSpacing | "Layer Summary"
RebarSystemLayoutRule | "Layout Rule"
RebarSystemNumberOfLinesBackDirn1 | "Interior Major Number Of Lines"
RebarSystemNumberOfLinesBackDirn2 | "Interior Minor Number Of Lines"
RebarSystemNumberOfLinesBottomDir1Generic | "Bottom/Interior Major Number Of Lines"
RebarSystemNumberOfLinesBottomDir2Generic | "Bottom/Interior Minor Number Of Lines"
RebarSystemNumberOfLinesBottomDirn1 | "Bottom Major Number Of Lines"
RebarSystemNumberOfLinesBottomDirn2 | "Bottom Minor Number Of Lines"
RebarSystemNumberOfLinesFrontDirn1 | "Exterior Major Number Of Lines"
RebarSystemNumberOfLinesFrontDirn2 | "Exterior Minor Number Of Lines"
RebarSystemNumberOfLinesTopDir1Generic | "Top/Exterior Major Number Of Lines"
RebarSystemNumberOfLinesTopDir2Generic | "Top/Exterior Minor Number Of Lines"
RebarSystemNumberOfLinesTopDirn1 | "Top Major Number Of Lines"
RebarSystemNumberOfLinesTopDirn2 | "Top Minor Number Of Lines"
RebarSystemOverride | "Override Area Reinforcement Settings"
RebarSystemSpacingBackDirn1 | "Interior Major Spacing"
RebarSystemSpacingBackDirn2 | "Interior Minor Spacing"
RebarSystemSpacingBottomDir1Generic | "Bottom/Interior Major Spacing"
RebarSystemSpacingBottomDir2Generic | "Bottom/Interior Minor Spacing"
RebarSystemSpacingBottomDirn1 | "Bottom Major Spacing"
RebarSystemSpacingBottomDirn2 | "Bottom Minor Spacing"
RebarSystemSpacingFrontDirn1 | "Exterior Major Spacing"
RebarSystemSpacingFrontDirn2 | "Exterior Minor Spacing"
RebarSystemSpacingTopDir1Generic | "Top/Exterior Major Spacing"
RebarSystemSpacingTopDir2Generic | "Top/Exterior Minor Spacing"
RebarSystemSpacingTopDirn1 | "Top Major Spacing"
RebarSystemSpacingTopDirn2 | "Top Minor Spacing"
RebarSystemSpanactiveDirn1 | "Bars In Major Direction"
RebarSystemSpanactiveDirn2 | "Bars In Minor Direction"
RebarSystemSpanhookBottomDirn2 | "Hook Angle Bottom"
RebarSystemSpanhookLeftDirn1 | "Hook Angle Left"
RebarSystemSpanhookRightDirn1 | "Hook Angle Right"
RebarSystemSpanhookTopDirn2 | "Hook Angle Top"
RebarSystemTopMajorMatchesBottomMajor | "Top and Bottom Major Layers Match"
RebarSystemTopMajorMatchesTopMinor | "Top Major and Minor Layers Match"
RebarSystemTopMinorMatchesBottomMinor | "Top and Bottom Minor Layers Match"
RebarWorkshopInstructions | "Workshop Instructions"
RectMullionThick | "Thickness"
RectMullionWidth1 | "Width on side 1"
RectMullionWidth2 | "Width on side 2"
ReferenceBaseOnHost | "Reference Base on Host"
ReferencedView | "Referenced View": The view referenced by a section or callout.
ReferenceLineSubcategory | "Subcategory"
ReferenceOtherViewUiRefView | "Reference View": This is used by the UI to allow selection of view reference.
ReferenceOtherViewUiToggle | "Reference Other View": This is used to determine whether reference other view is enable or not.
ReferenceViewerAttrTag | "View Reference Tag"
ReferenceViewerTargetView | "Target view"
ReferenceViewerUiTargetFilter | "Filter": This is used by the UI to filter the list of target views.
ReferenceViewerUiTargetView | "Target view": This is used by the UI to allow selection of target view. It allows the UI to set a filter that is incompatible with the current target view (REFERENCE_VIEWER_TARGET_VIEW).
RefTableElemName | "Key Name"
RefTableParamName | "Parameter Name"
ReinEstBarLength | "Estimated Total Bar Length"
ReinEstBarVolume | "Estimated Reinforcement Volume"
ReinEstNumberOfBars | "Estimated Number of Bars"
ReinforcementVolume | "Reinforcement Volume"
RelatedToMass | "Related to Mass"
RelativeRoughness | "Relative Roughness"
RenderPlantHeight | "Height"
RenderPlantName | "Plant Name"
RenderPlantTrimHeight | "Plant Trim Height"
RenderRpcFilename | "Render Appearance"
RenderRpcProperties | "Render Appearance Properties"
RepeatingDetailElement | "Detail"
RepeatingDetailInside | "Inside"
RepeatingDetailLayout | "Layout"
RepeatingDetailNumber | "Number"
RepeatingDetailRotation | "Detail Rotation"
RepeatingDetailSpacing | "Spacing"
RevealProfileParam | "Profile"
RevisionCloudRevision | "Revision"
RevisionCloudRevisionDate | "Revision Date"
RevisionCloudRevisionDescription | "Revision Description"
RevisionCloudRevisionIssuedBy | "Issued by"
RevisionCloudRevisionIssuedTo | "Issued to"
RevisionCloudRevisionNum | "Revision Number"
RevolutionEndAngle | "End Angle"
RevolutionStartAngle | "Start Angle"
RgbBParam | "Blue value for RGB color spec. (for Use with XAML Data Template example)"
RgbGParam | "Green value for RGB color spec. (for Use with XAML Data Template example)"
RgbRParam | "Red value for RGB color spec. (for Use with XAML Data Template example)"
RoofAttrDefaultThicknessParam | "Default Thickness"
RoofAttrThicknessParam | "Thickness"
RoofBaseLevelParam | "Base Level"
RoofConstraintLevelParam | "Reference Level"
RoofConstraintOffsetParam | "Level Offset"
RoofCurveHeightAtWall | "Plate Offset From Base"
RoofCurveHeightOffset | "Offset From Roof Base"
RoofCurveIsSlopeDefining | "Defines Roof Slope"
RoofEaveCutParam | "Rafter Cut"
RoofFacesLocation | "Picked Faces Location"
RoofLevelOffsetParam | "Base Offset From Level"
RoofRafterOrTrussParam | "Rafter or Truss"
RoofSlope | "Slope"
RoofStructureIdParam | "Structure"
RoofUptoLevelOffsetParam | "Cutoff Offset"
RoofUptoLevelParam | "Cutoff Level"
RoomActualExhaustAirflowParam | "Actual Exhaust Airflow"
RoomActualLightingLoadParam | "Actual Lighting Load"
RoomActualLightingLoadPerAreaParam | "Actual Lighting Load per area"
RoomActualPowerLoadParam | "Actual Power Load"
RoomActualPowerLoadPerAreaParam | "Actual Power Load per area"
RoomActualReturnAirflowParam | "Actual Return Airflow"
RoomActualSupplyAirflowParam | "Actual Supply Airflow"
RoomAirChangesPerHourParam | "Air Changes per Hour"
RoomArea | "Area"
RoomAreaPerPersonParam | "Area per Person"
RoomBaseHeatLoadOnParam | "Heat Load Values"
RoomBaseLightingLoadOnParam | "Base Lighting Load on"
RoomBasePowerLoadOnParam | "Base Power Load on"
RoomBaseReturnAirflowOnParam | "Return Airflow"
RoomCalculatedCoolingLoadParam | "Calculated Cooling Load"
RoomCalculatedCoolingLoadPerAreaParam | "Calculated Cooling Load per area"
RoomCalculatedHeatingLoadParam | "Calculated Heating Load"
RoomCalculatedHeatingLoadPerAreaParam | "Calculated Heating Load per area"
RoomCalculatedSupplyAirflowParam | "Calculated Supply Airflow"
RoomCalculatedSupplyAirflowPerAreaParam | "Calculated Supply Airflow per area"
RoomCalculationPoint | "Room Calculation Point"
RoomComputationHeight | "Computation Height"
RoomComputationMethod | "Computation"
RoomConditionTypeParam | "Condition Type"
RoomConstructionSetParam | "Construction Type"
RoomDepartment | "Department"
RoomDesignCoolingLoadParam | "Design Cooling Load"
RoomDesignExhaustAirflowParam | "Specified Exhaust Airflow"
RoomDesignHeatingLoadParam | "Design Heating Load"
RoomDesignLightingLoadParam | "Specified Lighting Load"
RoomDesignLightingLoadPerAreaParam | "Specified Lighting Load per area"
RoomDesignMechanicalLoadPerAreaParam | "Design HVAC Load per area"
RoomDesignOtherLoadPerAreaParam | "Design Other Load per area"
RoomDesignPowerLoadParam | "Specified Power Load"
RoomDesignPowerLoadPerAreaParam | "Specified Power Load per area"
RoomDesignReturnAirflowParam | "Specified Return Airflow"
RoomDesignSupplyAirflowParam | "Specified Supply Airflow"
RoomEditElectricalLoadsParam | "Electrical Loads"
RoomEditPeopleLoadsParam | "People"
RoomFinishBase | "Base Finish"
RoomFinishCeiling | "Ceiling Finish"
RoomFinishFloor | "Floor Finish"
RoomFinishWall | "Wall Finish"
RoomHeight | "Unbounded Height"
RoomLevelId | "Level"
RoomLightingLoadUnitsParam | "Lighting Load Units"
RoomLowerOffset | "Base Offset"
RoomName | "Name"
RoomNumber | "Number"
RoomNumberOfPeopleParam | "Number of People"
RoomOccupancy | "Occupancy"
RoomOccupancyUnitParam | "Occupancy Unit"
RoomOutdoorAirflowParam | "Outdoor Airflow"
RoomOutdoorAirflowStandardParam | "Outdoor Air Method"
RoomOutdoorAirInfoParam | "Outdoor Air Information"
RoomOutdoorAirPerAreaParam | "Outdoor Air per Area"
RoomOutdoorAirPerPersonParam | "Outdoor Air per Person"
RoomPeopleLatentHeatGainPerPersonParam | "Latent Heat Gain per person"
RoomPeopleSensibleHeatGainPerPersonParam | "Sensible Heat Gain per person"
RoomPeopleTotalHeatGainPerPersonParam | "Total Heat Gain per person"
RoomPerimeter | "Perimeter"
RoomPhase | "Phase"
RoomPhaseId | "Phase Id"
RoomPlenumLightingParam | "Plenum Lighting Contribution"
RoomPowerLoadUnitsParam | "Power Load Units"
RoomSpaceTypeParam | "Space Type"
RoomTagOrientationParam | "Orientation"
RoomUpperLevel | "Upper Limit"
RoomUpperOffset | "Limit Offset"
RoomVolume | "Volume"
RouteAnalysisSettingsParam | "Route Analysis Settings"
RoutingPreferenceParam | "Routing Preference"
RvtHostLevel | "Map Levels..."
RvtLevelOffset | "Map Levels..."
RvtLinkFileNameWithoutExt | "File Name"
RvtLinkInstanceName | "Name"
RvtLinkInstanceProjectInformation | "Project Information"
RvtLinkPhaseMap | "Phase Mapping"
RvtLinkReferenceType | "Reference Type"
RvtSourceLevel | "Map Levels..."
ScheduleBaseLevelOffsetParam | "Base Offset"
ScheduleBaseLevelParam | "Base Level"
ScheduleCategory | "Category"
ScheduleEmbeddedParam | "Embedded Schedule"
ScheduleFieldsParam | "Fields"
ScheduleFilterParam | "Filter"
ScheduleFormatParam | "Formatting"
ScheduleGroupParam | "Sorting/Grouping"
ScheduleLevelParam | "Level"
ScheduleResizeRows | "Resize Rows"
ScheduleRotationOnSheet | "Rotation on Sheet"
ScheduleRowHeightInput | "Row Height"
ScheduleSheetAppearanceParam | "Appearance"
ScheduleTopLevelOffsetParam | "Top Offset"
ScheduleTopLevelParam | "Top Level"
ScheduleTypeForBrowser | "Schedule Type"
SectionAttrHeadTag | "Section Head"
SectionAttrTailLength | "Tail length"
SectionAttrTailTag | "Section Tail"
SectionAttrTailWidth | "Tail width"
SectionBrokenDisplayStyle | "Broken Section Display Style"
SectionCoarserScalePulldownImperial | "Hide at scales coarser than"
SectionCoarserScalePulldownMetric | "Hide at scales coarser than"
SectionParentViewName | "Parent View"
SectionShowInOneViewOnly | "Show in"
SectionTag | "Section Tag"
SeekItemId | "Seek Item ID"
SelectionEditableOnly | "Editable only"
SheetApprovedBy | "Approved By"
SheetAssemblyAssemblyCode | "Assembly: Assembly Code"
SheetAssemblyAssemblyDescription | "Assembly: Assembly Description"
SheetAssemblyCost | "Assembly: Cost"
SheetAssemblyDescription | "Assembly: Description"
SheetAssemblyKeynote | "Assembly: Keynote"
SheetAssemblyManufacturer | "Assembly: Manufacturer"
SheetAssemblyModel | "Assembly: Model"
SheetAssemblyName | "Assembly: Name"
SheetAssemblyTypeComments | "Assembly: Type Comments"
SheetAssemblyTypeMark | "Assembly: Type Mark"
SheetAssemblyUrl | "Assembly: URL"
SheetCheckedBy | "Checked By"
SheetCurrentRevision | "Current Revision"
SheetCurrentRevisionDate | "Current Revision Date"
SheetCurrentRevisionDescription | "Current Revision Description"
SheetCurrentRevisionIssued | "Current Revision Issued"
SheetCurrentRevisionIssuedBy | "Current Revision Issued By"
SheetCurrentRevisionIssuedTo | "Current Revision Issued To"
SheetDate | "Date/Time Stamp"
SheetDesignedBy | "Designed By"
SheetDrawnBy | "Drawn By"
SheetFilePath | "File Path"
SheetGuideGrid | "Guide Grid"
SheetHeight | "Sheet Height"
SheetIssueDate | "Sheet Issue Date"
SheetKeyNumber | "Sheet Key Number"
SheetName | "Sheet Name"
SheetNumber | "Sheet Number"
SheetRevisionsOnSheet | "Revisions on Sheet"
SheetScale | "Scale"
SheetScheduled | "Appears In Sheet List"
SheetWidth | "Sheet Width"
ShowArrowheadToCutMark | "Show Arrowhead to Cut Mark"
ShowIconParam | "Flag to display icon in Ribbon Combo Item"
ShowTitle | "Show Title"
SketchGridSpacingParam | "Work Plane Grid Spacing"
SketchPlaneParam | "Work Plane"
SlabEdgeMaterialParam | "Material"
SlabEdgeProfileParam | "Profile"
SlantedColumnBaseCutStyle | "Base Cut Style"
SlantedColumnBaseExtension | "Base Extension"
SlantedColumnGeometryTreatmentBase | "Base Geometry Alignment"
SlantedColumnGeometryTreatmentTop | "Top Geometry Alignment"
SlantedColumnTopCutStyle | "Top Cut Style"
SlantedColumnTopExtension | "Top Extension"
SlantedColumnTypeParam | "Column Style"
SlopeArrowLevelEnd | "Level at Head"
SlopeArrowLevelStart | "Level at Tail"
SlopeEndHeight | "Height Offset at Head"
SlopeStartHeight | "Height Offset at Tail"
SpaceAirChangesPerHour | "Air Changes per Hour"
SpaceAirflowPerAreaParam | "Airflow per area"
SpaceArea | "Area"
SpaceAreaPerPersonParam | "Area per person"
SpaceAssocRoomName | "Room Name"
SpaceAssocRoomNumber | "Room Number"
SpaceCarpetingParam | "Carpeting"
SpaceComposednameParam | "Composed Name"
SpaceConditionType | "Condition Type"
SpaceCoolingSetPoint | "Cooling Set Point"
SpaceDehumidificationSetPoint | "Dehumidification Set Point"
SpaceElecEquipmentRadiantPercentageParam | "Electrical Equipment Radiant"
SpaceHeatingSetPoint | "Heating Set Point"
SpaceHumidificationSetPoint | "Humidification Set Point"
SpaceInfiltrationAirflow | "Infiltration Airflow"
SpaceInfiltrationAirflowPerArea | "Infiltration Airflow per area"
SpaceInfiltrationParam | "Infiltration Airflow per area"
SpaceIsOccupiable | "Occupiable"
SpaceIsPlenum | "Plenum"
SpaceLightingLoadParam | "Lighting Load"
SpaceLightingLoadPerAreaParam | "Lighting Load per area"
SpaceLightingScheduleParam | "Lighting Schedule"
SpaceNameParam | "Name"
SpaceNumberOfPeople | "Number of People"
SpaceNumberParam | "Number"
SpaceOccupancyScheduleParam | "Occupancy Schedule"
SpaceOutdoorAirflow | "Outdoor Airflow"
SpaceOutdoorAirflowPerArea | "Outdoor Airflow per area"
SpaceOutdoorAirflowPerPerson | "Outdoor Airflow per person"
SpacePeopleActivityLevelParam | "People Activity Level"
SpacePeopleLatentHeatGainPerPersonParam | "Latent Heat Gain per person"
SpacePeopleLoadParam | "Occupancy Load"
SpacePeopleSensibleHeatGainPerPersonParam | "Sensible Heat Gain per person"
SpacePowerLoadParam | "Power Load"
SpacePowerLoadPerAreaParam | "Power Load per area"
SpacePowerScheduleParam | "Power Schedule"
SpaceReferenceLevelParam | "Reference Level"
SpaceTypeGbxml | "Space Type (gbXML)"
SpaceVolume | "Volume"
SpaceZoneName | "Zone"
SpacingAppend | "Append Position"
SpacingJustification | "Justification"
SpacingJustificationHoriz | "Justification"
SpacingJustificationn1 | "Justification"
SpacingJustificationn2 | "Justification"
SpacingJustificationU | "Justification"
SpacingJustificationV | "Justification"
SpacingJustificationVert | "Justification"
SpacingLayout | "Layout"
SpacingLayoutHoriz | "Layout"
SpacingLayoutn1 | "Layout"
SpacingLayoutn2 | "Layout"
SpacingLayoutU | "Layout"
SpacingLayoutV | "Layout"
SpacingLayoutVert | "Layout"
SpacingLength | "Spacing"
SpacingLengthHoriz | "Spacing"
SpacingLengthn1 | "Spacing"
SpacingLengthn2 | "Spacing"
SpacingLengthU | "Distance"
SpacingLengthV | "Distance"
SpacingLengthVert | "Spacing"
SpacingNumDivisions | "Number"
SpacingNumDivisionsHoriz | "Number"
SpacingNumDivisionsn1 | "Number"
SpacingNumDivisionsn2 | "Number"
SpacingNumDivisionsU | "Number"
SpacingNumDivisionsV | "Number"
SpacingNumDivisionsVert | "Number"
SpanDirInstParamAngle | "Span Direction"
SpanDirSymParamBottom | "Bottom"
SpanDirSymParamLeft | "Left"
SpanDirSymParamRight | "Right"
SpanDirSymParamTop | "Top"
SpatialFieldMgrCurrentName | "Analysis Configuration"
SpatialFieldMgrDescription | "Description"
SpatialFieldMgrLegendHeight | "Legend Height"
SpatialFieldMgrLegendHorOriginGap | "Legend Horizontal Origin Gap"
SpatialFieldMgrLegendShowConfigName | "Show Configuration Name"
SpatialFieldMgrLegendShowDescription | "Show Description"
SpatialFieldMgrLegendTextType | "Overall Legend Text"
SpatialFieldMgrLegendVertOriginGap | "Legend Vertical Origin Gap"
SpatialFieldMgrLegendWidth | "Legend Width"
SpatialFieldMgrRange | "Data Range"
SpatialFieldMgrResultsVisibility | "Results Visibility"
SpecifySlopeOrOffset | "Specify "
SpotCoordinateBase | "Coordinate Base"
SpotCoordinateBottomPrefix | "Bottom Coordinate Prefix"
SpotCoordinateBottomSuffix | "Bottom Coordinate Suffix"
SpotCoordinateElevationPrefix | "Elevation Prefix"
SpotCoordinateElevationSuffix | "Elevation Suffix"
SpotCoordinateIncludeElevation | "Include Elevation"
SpotCoordinateTopPrefix | "Top Coordinate Prefix"
SpotCoordinateTopSuffix | "Top Coordinate Suffix"
SpotDimLeader | "Leader"
SpotDimLeaderLine | "Leader Line"
SpotDimStyleSlopeUnits | "Units Format"
SpotDimStyleSlopeUnitsAlt | "Alternate Units Format"
SpotElevBase | "Elevation Base"
SpotElevBendLeader | "Leader Shoulder"
SpotElevBotValue | "Bottom Coordinate"
SpotElevDisplayElevations | "Display Elevations"
SpotElevFlipTextVert | "Auto Mirror"
SpotElevIndBottom | "Bottom Indicator"
SpotElevIndElevation | "Elevation Indicator"
SpotElevIndEw | "East / West Indicator"
SpotElevIndNs | "North / South Indicator"
SpotElevIndTop | "Top Indicator"
SpotElevIndType | "Indicator as Prefix / Suffix"
SpotElevIndTypeBottom | "Bottom Indicator as Prefix/Suffix"
SpotElevIndTypeElevation | "Elevation Indicator as Prefix/Suffix"
SpotElevIndTypeTop | "Top Indicator as Prefix/Suffix"
SpotElevLeaderArrowhead | "Leader Arrowhead"
SpotElevLinePen | "Leader Line Weight"
SpotElevLowerPrefix | "Lower Value Prefix"
SpotElevLowerSuffix | "Lower Value Suffix"
SpotElevLowerValue | "Lower Value"
SpotElevRelativeBase | "Relative Base"
SpotElevRotateWithComponent | "Rotate with Component"
SpotElevSingleOrUpperPrefix | "Single/Upper Value Prefix"
SpotElevSingleOrUpperSuffix | "Single/Upper Value Suffix"
SpotElevSingleOrUpperValue | "Single/Upper Value"
SpotElevSymbol | "Symbol"
SpotElevTextHorizOffset | "Text Offset from Symbol"
SpotElevTextLocation | "Text Location"
SpotElevTextOrientation | "Text Orientation"
SpotElevTickMarkPen | "Leader Arrowhead Line Weight"
SpotElevTopValue | "Top Coordinate"
SpotSlopeLeaderLength | "Leader Line Length"
SpotSlopeOffsetFromReference | "Offset from Reference"
SpotSlopePrefix | "Prefix"
SpotSlopeSlopeDirection | "Slope Direction"
SpotSlopeSlopeRepresentation | "Slope Representation"
SpotSlopeSuffix | "Suffix"
SpotTextFromLeader | "Text Offset from Leader"
SsePointBasetypeEnum | "Point Base Type"
SsePointElevation | "Elevation"
SsePointElevationBaseType | "Elevation Base Type"
SsePointOffsetFromSurface | "Offset from Surface"
StairsActualNumberOfRisers | "Actual Number of Risers": The total number of actually created risers in model
StairsActualNumRisers | "Actual Number of Risers"
StairsActualRiserHeight | "Actual Riser Height"
StairsActualTreadDepth | "Actual Tread Depth"
StairsAttrBodyMaterial | "Monolithic Material"
StairsAttrBreakSymInCutline | "Break Symbol in Plan"
StairsAttrCalcEnabled | "Calculation Rules"
StairsAttrCalcMax | "Calculation Rules"
StairsAttrCalcMin | "Calculation Rules"
StairsAttrEqResult | "Calculation Rules"
StairsAttrFirstRiser | "Begin with Riser"
StairsAttrLandingCarriage | "Landing Carriage Height"
StairsAttrLandingsOverlapping | "Landing Overlap"
StairsAttrLastRiser | "End with Riser"
StairsAttrLeftSideStringer | "Left Stringer"
StairsAttrMaxRiserHeight | "Maximum Riser Height"
StairsAttrMinimumTreadDepth | "Minimum Tread Depth"
StairsAttrMonolithicStairs | "Monolithic Stairs"
StairsAttrNosingLength | "Nosing Length"
StairsAttrNosingPlacement | "Apply Nosing Profile"
StairsAttrNumMidStringers | "Middle Stringers"
StairsAttrRightSideStringer | "Right Stringer"
StairsAttrRiserAngle | "Riser Angle"
StairsAttrRiserMaterial | "Riser Material"
StairsAttrRiserMult | "Riser Multiplier"
StairsAttrRisersPresent | "Risers Present"
StairsAttrRiserThickness | "Riser Thickness"
StairsAttrRiserTreadConnect | "Riser to Tread Connection"
StairsAttrRiserType | "Riser Type"
StairsAttrSideStringerTypeParam | "Type of Side Stringers"
StairsAttrStairCalculator | "Calculation Rules"
StairsAttrStairsBottom | "Underside of Winder"
StairsAttrStairsCutOffset | "Extend Below Base"
StairsAttrStringerCarriage | "Stringer Carriage Height"
StairsAttrStringerHeight | "Stringer Height"
StairsAttrStringerMaterial | "Stringer Material"
StairsAttrStringerOffset | "Open Stringer Offset"
StairsAttrStringerThickness | "Stringer Thickness"
StairsAttrTextFont | "Text Font"
StairsAttrTextSize | "Text Size"
StairsAttrTreadFrontProfile | "Nosing Profile"
StairsAttrTreadMaterial | "Tread Material"
StairsAttrTreadMult | "Tread Multiplier"
StairsAttrTreadThickness | "Tread Thickness"
StairsAttrTreadWidth | "Width"
StairsAttrTrimTop | "Trim Stringers at Top"
StairsBaseLevel | "Base Level": The base level of stairs
StairsBaseLevelParam | "Base Level"
StairsBaseOffset | "Base Offset"
StairsCurveType | "Stairs Line Type"
StairsDbgShowAnnotationCutMark | "Cut by Cut Plane"
StairsDbgShowBoundary2d | "Show Stairs' Boundary 2D"
StairsDbgShowBoundary3d | "Show Stairs' Boundary 3D"
StairsDbgShowLandingBoundary | "Show Landing Boundary"
StairsDbgShowLandingFaces | "Show Landing Faces"
StairsDbgShowLandingPath | "Show Landing Path"
StairsDbgShowLeftRunBoundary2d | "Show Run's Left Boundary 2D"
StairsDbgShowLeftRunBoundary3d | "Show Run's Left Boundary 3D"
StairsDbgShowMonolithicSupportCorseGeom | "Show Monolithic Support Corse Geometry"
StairsDbgShowMonolithicSupportGeom | "Show Monolithic Support Geometry"
StairsDbgShowRightRunBoundary2d | "Show Run's Right Boundary 2D"
StairsDbgShowRightRunBoundary3d | "Show Run's Right Boundary 3D"
StairsDbgShowRunCorseGeom | "Show Run Corse Geometry"
StairsDbgShowRunGeom | "Show Run Geometry"
StairsDbgShowRunNosing | "Show Run's Nosings"
StairsDbgShowRunOutlineForPlan | "Show Run Outline For Plan"
StairsDbgShowRunPath2d | "Show Run's Path 2D"
StairsDbgShowRunPath3d | "Show Run's Path 3D"
StairsDbgShowRunRiser | "Show Run's Risers"
StairsDbgShowSupportPath | "Show Support Path"
StairsDbgShowTreadFaces | "Show Run's Tread Faces"
StairsDbgShowTriserCorseGeom | "Show Triser Corse Geometry"
StairsDbgShowTriserGeom | "Show Triser Geometry"
StairsDesiredNumberOfRisers | "Desired Number of Risers": The number of risers is calculated based on stairs height
StairsDesiredNumRisers | "Desired Number of Risers"
StairsDownText | "Down Text"
StairsEnableCalculationRuleChecking | "Enable Calculator Rules Check": Enable calculation rule checking
StairsInstAlwaysUp | "Show Up arrow in all views"
StairsInstDownArrowOn | "Down arrow"
StairsInstDownLabelOn | "Down label"
StairsInstDownLabelText | "Down text"
StairsInstUpArrowOn | "Up arrow"
StairsInstUpLabelOn | "Up label"
StairsInstUpLabelText | "Up text"
StairsLandingBaseElevation | "Relative Height": Height
StairsLandingOverridden | "Overridden": Overridden
StairsLandingStructural | "Structural": Structural
StairsLandingThickness | "Total Thickness": Thickness
StairsLandingtypeHasMonolithicSupport | "Monolithic Support": Monolithic Support
StairsLandingtypeLandingMaterial | "Monolithic Material": Landing Material
StairsLandingtypeStructure | "Structure": Structure
StairsLandingtypeThickness | "Monolithic Thickness": Default thickness
StairsLandingtypeTreadriserType | "Type": Tread/Riser Type
StairsLandingtypeUseSameTriserAsRun | "Same as Run": Same as Run
StairsMinAutomaticLandingDepth | "Minimum Automatic Landing Depth": The minimum depth of automatic landing
StairsMultistoryTopLevelParam | "Multistory Top Level"
StairsMultistoryUpToLevel | "Multistory Top Level": The top level of multi-story stairs
StairsPathFullStepArrow | "Full Step Arrow"
StairsPathStartExtension | "Start Extension"
StairsPathStartFromRiser | "Start from Riser"
StairsRailingAngledConnection | "Angled Joins"
StairsRailingBalusterBottomAngle | "Bottom Cut Angle"
StairsRailingBalusterFamily | "Baluster Family"
StairsRailingBalusterHeight | "Baluster Height"
StairsRailingBalusterIsPost | "Post"
StairsRailingBalusterLength | "Baluster Length"
StairsRailingBalusterOffset | "Baluster Offset"
StairsRailingBalusterPlacement | "Baluster Placement"
StairsRailingBalusterShape | "Baluster Shape"
StairsRailingBalusterSlopeAngle | "Slope Angle"
StairsRailingBalusterSpacing | "Baluster Separation"
StairsRailingBalusterSpacingType | "Baluster Spacing Type (Stair Railing Only)"
StairsRailingBalustersPerTread | "Balusters Per Tread (Stair Railing Only)"
StairsRailingBalusterTopAngle | "Top Cut Angle"
StairsRailingBalusterWidth | "Baluster Width"
StairsRailingBaseLevelParam | "Base Level"
StairsRailingConnection | "Rail Connections"
StairsRailingHeight | "Railing Height"
StairsRailingHeightOffset | "Base Offset"
StairsRailingHeightShiftType | "Use Landing Height Adjustment"
StairsRailingHeightShiftVal | "Landing Height Adjustment"
StairsRailingPlacementOffset | "Offset from Path"
StairsRailingRailHeight | "Rail Height"
StairsRailingRailName | "Name"
StairsRailingRailOffset | "Rail Offset"
StairsRailingRailStructure | "Rail Structure (Non-Continuous)"
StairsRailingShape | "Rail Shape"
StairsRailingTangentConnection | "Tangent Joins"
StairsRailingThickness | "Railing Thickness"
StairsRailingWidth | "Railing Width"
StairsRunActualNumberOfRisers | "Actual Number of Risers": Actual Number of Risers
StairsRunActualNumberOfTreads | "Actual Number of Treads": Actual Number of Treads
StairsRunActualRiserHeight | "Actual Riser Height": Actual Riser Height
StairsRunActualRunWidth | "Actual Run Width": Actual Run Width
StairsRunActualTreadDepth | "Actual Tread Depth": Actual Tread Depth
StairsRunBeginWithRiser | "Begin with Riser": Begin with Riser
StairsRunBottomElevation | "Relative Base Height": Relative height to stairs bottom elevation
StairsRunCcw | "CCW": Revert the run preview
StairsRunCenterMarkVisible | "Center Mark Visible": Center Mark Visible
StairsRunCreateAutoLanding | "With Automatic Landing": Create automatic landing
StairsRunEndWithRiser | "End with Riser": End with Riser
StairsRunExtendBelowRiserBase | "Extend Below Riser Base": Extend Below Base
StairsRunExtendBelowTreadBase | "Extend Below Tread Base": Extend Below Tread Base
StairsRunHeight | "Run Height": Run Height
StairsRunLocationpathJustfication | "Location Line": Location Line
StairsRunOverridden | "Overridden": Overridden
StairsRunStructural | "Structural": Structural
StairsRunTopElevation | "Relative Top Height": Top height of run
StairsRuntypeHasMonolithicSupport | "Monolithic Support": Monolithic Support
StairsRuntypeRunMaterial | "Monolithic Material": Material
StairsRuntypeStructuralDepth | "Structural Depth": Structural Depth
StairsRuntypeStructure | "Structure": Structure
StairsRuntypeTotalDepth | "Total Depth": Total Depth
StairsRuntypeUndersideSurfaceType | "Underside Surface": Underside Surface
StairsRunWidthMeasurement | "Run Width Measurement": Run Width Measurement
StairsRunWinderBeginWithStraight | "Begin with Straight Run": Winder begin with straight run
StairsRunWinderEndWithStraight | "End with Straight Run": Winder end with straight run
StairsShowDownText | "Show Down Text"
StairsShowUpText | "Show Up Text"
StairsStairsHeight | "Desired Stair Height": Stairs unconnected height
StairsStringersPresent | "Stringer Position"
StairsSupportHorizontalOffset | "Lateral Offset": Distance from center or edge of boundary
StairsSupportLandingsupportType | "Landing Support Type": Landing Support Type
StairsSupportLowerEndCut | "Lower End Cut": Lower End Cut
StairsSupportOverridden | "Overridden": Overridden
StairsSupportTrimSupportUpper | "Trim Support at Upper": Trim Support at Upper
StairsSupporttypeFlipSectionProfile | "Flip Section Profile": Flip Section Profile
StairsSupporttypeMaterial | "Material": Material
StairsSupporttypeSectionProfile | "Section Profile": Section Profile
StairsSupporttypeStructuralDepth | "Structural Depth": Structural Depth
StairsSupporttypeStructuralDepthOnLanding | "Structural Depth On Landing": Structural Depth
StairsSupporttypeStructuralDepthOnRun | "Structural Depth On Run": Structural Depth
StairsSupporttypeTopsideSurface | "Topside Surface": Topside Surface
StairsSupporttypeTotalDepth | "Total Depth": Total Depth
StairsSupporttypeUndersideSurface | "Underside Surface": Underside Surface
StairsSupporttypeWidth | "Width": Width
StairsSupportUpperEndCut | "Upper End Cut": Upper End Cut
StairsSupportVerticalOffset | "Vertical Offset": Distance of top plane of edge stringer relative to the plane connecting tread nosing
StairsTextOrientation | "Orientation"
StairsTextType | "Text Type"
StairsTopLevel | "Top Level": The top level of stairs
StairsTopLevelParam | "Top Level"
StairsTopOffset | "Top Offset"
StairsTotalNumberOfRisers | "Total Number of Risers": Total number of risers
StairsTotalNumberOfTreads | "Total Number of Treads": Total number of treads
StairsTriserIsTypeOverridden | "Overridden": (OBSOLETE) Indicate whether selected individual step is governed by default type setting.
StairsTriserNumberBaseIndex | "Tread/Riser Start Number":
StairsTriserRiserMark | "Riser Mark": (OBSOLETE)
StairsTriserRiserNumber | "Riser Number": Count the sequential number of riser in the stair.
StairsTriserTreadMark | "Tread Mark": (OBSOLETE)
StairsTriserTreadNumber | "Tread Number": Count the sequential number of tread in the stair.
StairsTrisertypeBackNosing | "Back Nosing": (OBSOLETE)
StairsTrisertypeFrontNosing | "Front Nosing": (OBSOLETE)
StairsTrisertypeLeftNosing | "Left Nosing": (OBSOLETE)
StairsTrisertypeNosingLength | "Nosing Length"
StairsTrisertypeNosingPlacement | "Apply Nosing Profile"
StairsTrisertypeNosingProfile | "Nosing Profile"
StairsTrisertypeRightNosing | "Right Nosing": (OBSOLETE)
StairsTrisertypeRiser | "Riser"
StairsTrisertypeRiserIsSlanted | "Slanted"
StairsTrisertypeRiserMaterial | "Riser Material"
StairsTrisertypeRiserProfile | "Riser Profile"
StairsTrisertypeRiserStyle | "Riser Type": (OBSOLETE)
StairsTrisertypeRiserThickness | "Riser Thickness"
StairsTrisertypeRiserTreadConnection | "Riser To Tread Connection"
StairsTrisertypeTread | "Tread"
StairsTrisertypeTreadMaterial | "Tread Material"
StairsTrisertypeTreadProfile | "Tread Profile"
StairsTrisertypeTreadThickness | "Tread Thickness"
StairstypeCalcRuleMaxResult | "Max. Result": Calculation Rule Max Result
StairstypeCalcRuleMinResult | "Min. Result": Calculation Rule Min Result
StairstypeCalcRuleRiserMultiplier | "Riser Multiplier": Calculation Rule Riser Multiplier
StairstypeCalcRuleTargetResult | "Target Result": Calculation Rule Target Result
StairstypeCalcRuleTreadMultiplier | "Tread Multiplier": Calculation Rule Tread Multiplier
StairstypeCalculationRules | "Calculation Rules": Calculation Rules
StairstypeConstructionMethod | "Construction Method":
StairstypeCutmarkType | "Cut Mark Type": Cut Mark Type
StairstypeGeomunjoinedEndCutStyle | "Connection Method": Cut Style for Geometrically Unjoined End
StairstypeHasIntermediateSupport | "Middle Support": Whether stairs is assembled
StairstypeHasLeftSupport | "Left Support":
StairstypeHasRightSupport | "Right Support":
StairstypeIntermediateSupportType | "Middle Support Type": Intermediate Support Type
StairstypeIsAssembledStairs | "Assembled Stair": Whether stairs is assembled
StairstypeLandingType | "Landing Type": Landing Type
StairstypeLeftSideSupportType | "Left Support Type": Left Side Support Type
StairstypeLeftSupportLateralOffset | "Left Lateral Offset":
StairstypeMaximumRiserHeight | "Max. Riser Height": Maximum Riser Height
StairstypeMinimumRunWidth | "Minimum Run Width": Minimum Run Width
StairstypeMinimumTreadDepth | "Min. Tread Depth": Minimum Tread Depth
StairstypeMinimumTreadWidthInsideBoundary | "Min. Tread Depth on Winder Inner Boundary": Minimum Tread Width on Inside Boundary
StairstypeNotchCustomWidth | "Custom":
StairstypeNotchExtension | "Notch Extension":
StairstypeNotchHorizontalGap | "Horizontal Gap Distance":
StairstypeNotchThickness | "Notch Thickness":
StairstypeNotchVerticalGap | "Vertical Gap Distance":
StairstypeNotchWidth | "Notch Width":
StairstypeNumberOfIntermediateSupports | "Middle Support Number": Number of intermediate supports
StairstypeRightSideSupportType | "Right Support Type": Right Side Support Type
StairstypeRightSupportLateralOffset | "Right Lateral Offset":
StairstypeRunType | "Run Type": Run Type
StairstypeShowCutline | "Show Cut Line in Plan": Show Cut Line in Plan
StairstypeShowStairPath | "Show Stair Path in Plan": Show Stair Path in Plan
StairstypeShowUpdown | "Show Up/Down in Plan": Show Up/Down in Plan
StairstypeWinderStepFrontMeasurement | "Winder Algorithm": Winder Algorithm
StairsUpText | "Up Text"
StairsWinderpatternFilletInsideCorner | "Fillet on Corner": Fillet on inside corner
StairsWinderpatternMinimumWidthCorner | "Minimum Width on Inside Boundary": Minimum Width on Inside Boundary
StairsWinderpatternMinimumWidthInsideWalkline | "Minimum Width on Inside Walk Line": Minimum width on inside walkline
StairsWinderpatternNumberOfStraightStepsAtBegin | "Parallel Treads at Start": Number of straight steps at the begin of winder
StairsWinderpatternNumberOfStraightStepsAtEnd | "Parallel Treads at End": Number of straight steps at the begin of winder
StairsWinderpatternRadiusInterior | "Fillet Radius": The fillet corner radius on the interior boundary
StairsWinderpatternStairPathOffset | "Inside Walk Line Offset": The offset from inside walk line to interior boundary
StairsWinderpatternWinderStyle | "Winder Style": Winder Style
StartExtension | "Start Extension"
StartJoinCutback | "Start Join Cutback"
StartSymbolType | "Start Symbol Type"
StartYJustification | "Start y Justification"
StartYOffsetValue | "Start y Offset Value"
StartZJustification | "Start z Justification"
StartZOffsetValue | "Start z Offset Value"
SteelElemAnchorAssembly | "Assembly"
SteelElemAnchorDiameter | "Diameter"
SteelElemAnchorGrade | "Grade"
SteelElemAnchorLength | "Length"
SteelElemAnchorOrientation | "Anchor Orientation"
SteelElemAnchorStandard | "Standard"
SteelElemAnchorTotalWeight | "Total Weight"
SteelElemBoltAssembly | "Assembly"
SteelElemBoltCoating | "Coating"
SteelElemBoltDiameter | "Diameter"
SteelElemBoltFinishCalculationAtGap | "Finish Calculation At Gap"
SteelElemBoltGrade | "Grade"
SteelElemBoltGripLength | "Grip Length"
SteelElemBoltGripLengthIncrease | "Grip Length Increase"
SteelElemBoltInverted | "Inverted"
SteelElemBoltLength | "Bolt Length"
SteelElemBoltLocation | "Location"
SteelElemBoltStandard | "Standard"
SteelElemBoltTotalWeight | "Total Weight"
SteelElemCoating | "Coating"
SteelElemContourGapWidth | "Gap Width"
SteelElemContourSide1dist | "Boundary distance 1"
SteelElemContourSide2dist | "Boundary distance 2"
SteelElemCopeAroundAxis | "Around beam axis"
SteelElemCopeAxisAngle | "Tilt angle"
SteelElemCopeDistanceAxis | "Distance from axis"
SteelElemCopeWidthx | "Cutback"
SteelElemCopeXAngle | "Cross-section rotation"
SteelElemCopeZAngle | "Plan rotation"
SteelElemCutLength | "Cut Length"
SteelElemCutType | "Type"
SteelElemExactWeight | "Exact Weight"
SteelElemHoleAlpha | "Taper Angle"
SteelElemHoleAngle | "Chamfer angle"
SteelElemHoleBackTaperThread | "Back taper thread"
SteelElemHoleDefinition | "Hole Definition"
SteelElemHoleDepth | "Hole Depth"
SteelElemHoleDepthOfBoltHead | "Depth of bolt head"
SteelElemHoleDiameter | "Diameter"
SteelElemHoleHeadDiameter | "Head diameter"
SteelElemHoleSlotDirection | "Along side 1"
SteelElemHoleSlotLength | "Length of the slot"
SteelElemHoleTapping | "Right-handed thread"
SteelElemHoleTappingHole | "Tapping hole"
SteelElemHoleType | "Type"
SteelElemPaintArea | "Paint Area"
SteelElemParamBoringout | "Boring out"
SteelElemParamRadius | "Radius"
SteelElemPatternEdgeDistanceX | "Edge distance on side 1"
SteelElemPatternEdgeDistanceY | "Edge distance on side 2"
SteelElemPatternIntermediateDistanceX | "Intermediate distance on side 1"
SteelElemPatternIntermediateDistanceY | "Intermediate distance on side 2"
SteelElemPatternNumber | "Number"
SteelElemPatternNumberX | "Number on side 1"
SteelElemPatternNumberY | "Number on side 2"
SteelElemPatternRadius | "Radius"
SteelElemPatternTotalLength | "Length on side 1"
SteelElemPatternTotalWidth | "Length on side 2"
SteelElemPlateArea | "Area"
SteelElemPlateExactWeight | "Exact Weight"
SteelElemPlateJustification | "Justification"
SteelElemPlateLength | "Length"
SteelElemPlatePaintArea | "Paint Area"
SteelElemPlateShortenAngle | "Angle"
SteelElemPlateShortenCutstraight | "Cut straight"
SteelElemPlateShortenSuction | "Suction"
SteelElemPlateThickness | "Thickness"
SteelElemPlateType | "Type"
SteelElemPlateVolume | "Volume"
SteelElemPlateWeight | "Weight"
SteelElemPlateWidth | "Width"
SteelElemProfileLength | "Length"
SteelElemProfileType | "Profile Type"
SteelElemProfileVolume | "Volume"
SteelElemShearstudDiameter | "Diameter"
SteelElemShearstudGrade | "Grade"
SteelElemShearstudLength | "Length"
SteelElemShearstudStandard | "Standard"
SteelElemShearstudTotalWeight | "Total Weight"
SteelElemShortenAngley | "Angle along height"
SteelElemShortenAnglez | "Angle along width"
SteelElemShortenReflength | "Length"
SteelElemWeight | "Weight"
SteelElemWeldContinuous | "Continuous"
SteelElemWeldDoubleEffectivethroat | "Double Effective Throat"
SteelElemWeldDoublePrepdepth | "Double Preparation Depth"
SteelElemWeldDoubleRootopening | "Double Root Opening"
SteelElemWeldDoubleSurfaceshape | "Double Surface Shape"
SteelElemWeldDoubleText | "Double Text"
SteelElemWeldDoubleThickness | "Double Thickness"
SteelElemWeldDoubleType | "Double Type"
SteelElemWeldDoubleWeldprep | "Double Weld preparation"
SteelElemWeldLength | "Length"
SteelElemWeldLocation | "Location"
SteelElemWeldMainEffectivethroat | "Main Effective Throat"
SteelElemWeldMainPrepdepth | "Main Preparation Depth"
SteelElemWeldMainRootopening | "Main Root Opening"
SteelElemWeldMainSurfaceshape | "Surface Shape"
SteelElemWeldMainText | "Main Text"
SteelElemWeldMainThickness | "Main Thickness"
SteelElemWeldMainType | "Main Type"
SteelElemWeldMainWeldprep | "Main Weld preparation"
SteelElemWeldPitch | "Pitch"
SteelElemWeldPrefix | "Prefix"
SteelElemWeldTextModule | "Text module"
SteelElemXDistance | "Side 1"
SteelElemYDistance | "Side 2"
SteelElemZclipType | "Boundary"
StiffenerClassification | "Classification"
StructConnectionApplyTo | "Apply to"
StructConnectionBeamEnd | "End Connection"
StructConnectionBeamStart | "Start Connection"
StructConnectionColumnBase | "Base Connection"
StructConnectionColumnTop | "Top Connection"
StructConnectionCutback | "Automatic Cutback for Beams and Braces"
StructConnectionTypeName | "Name"
StructFramJoinStatus | "Join Status"
StructuralAnalyticalBeamHorizontalProjectionPlane | "Horizontal Projection"
StructuralAnalyticalBeamRigidLink | "Analytical Links"
StructuralAnalyticalColumnHorizontalProjectionPlane | "Horizontal Projection"
StructuralAnalyticalColumnRigidLink | "Analytical Links"
StructuralAnalyticalHardPoints | "Use hard-points"
StructuralAnalyticalModel | "Enable Analytical Model"
StructuralAnalyticalProjectFloorPlane | "Vertical Projection"
StructuralAnalyticalProjectMemberPlane | "Vertical Projection"
StructuralAnalyticalProjectMemberPlaneColumnBottom | "Bottom Vertical Projection"
StructuralAnalyticalProjectMemberPlaneColumnTop | "Top Vertical Projection"
StructuralAnalyticalTessDeviation | "Maximum discretized offset"
StructuralAnalyticalTessellate | "Approximate curve"
StructuralAnalyzesAs | "Analyze As"
StructuralAssetParam | "Physical Material Asset"
StructuralAttachmentBaseDistance | "Base Attachment Distance"
StructuralAttachmentBaseRatio | "Base Attachment Ratio"
StructuralAttachmentBaseReferencedend | "Base Attachment Referenced End"
StructuralAttachmentBaseType | "Base Attachment Type"
StructuralAttachmentEndLevelReference | "End Attachment Level Reference"
StructuralAttachmentEndRefelementEnd | "End of Attachment to Reference Element"
StructuralAttachmentEndType | "End Attachment Type"
StructuralAttachmentEndValueDistance | "End Attachment Distance"
StructuralAttachmentEndValueElevation | "End Attachment Elevation"
StructuralAttachmentEndValueRatio | "End attachment ratio"
StructuralAttachmentStartLevelReference | "Start Attachment Level Reference"
StructuralAttachmentStartRefelementEnd | "Start of Attachment to Reference Element"
StructuralAttachmentStartType | "Start Attachment Type"
StructuralAttachmentStartValueDistance | "Start Attachment Distance"
StructuralAttachmentStartValueElevation | "Start Attachment Elevation"
StructuralAttachmentStartValueRatio | "Start Attachment Ratio"
StructuralAttachmentTopDistance | "Top Attachment Distance"
StructuralAttachmentTopRatio | "Top Attachment Ratio"
StructuralAttachmentTopReferencedend | "Top Attachment Referenced End"
StructuralAttachmentTopType | "Top Attachment Type"
StructuralBeamCutbackForColumn | "Beam cutback in plan"
StructuralBeamEnd0Elevation | "Start Level Offset"
StructuralBeamEnd1Elevation | "End Level Offset"
StructuralBeamEndAttachmentDistance | "End Attachment Distance"
StructuralBeamEndAttachmentRefcolumnEnd | "End of Attachment to Reference Column"
StructuralBeamEndAttachmentType | "End Attachment Type"
StructuralBeamEndSupport | "Beam End Pocket Seat"
StructuralBeamOrientation | "Orientation"
StructuralBeamStartAttachmentDistance | "Start Attachment Distance"
StructuralBeamStartAttachmentRefcolumnEnd | "Start of Attachment to Reference Column"
StructuralBeamStartAttachmentType | "Start Attachment Type"
StructuralBeamStartSupport | "Beam Start Pocket Seat"
StructuralBendDirAngle | "Cross-Section Rotation"
StructuralBottomReleaseFx | "Base Fx"
StructuralBottomReleaseFy | "Base Fy"
StructuralBottomReleaseFz | "Base Fz"
StructuralBottomReleaseMx | "Base Mx"
StructuralBottomReleaseMy | "Base My"
StructuralBottomReleaseMz | "Base Mz"
StructuralBottomReleaseType | "Base Release"
StructuralBraceRepresentation | "Representation Type"
StructuralCamber | "Camber Size"
StructuralConnectionApprovalStatus | "Approval Status"
StructuralConnectionCodeCheckingStatus | "Code Checking Status"
StructuralConnectionEditRangesOfApplicability | "Modify Ranges of applicability"
StructuralConnectionEditType | "Modify Parameters"
StructuralConnectionInputElements | "Input Elements"
StructuralConnectionModifyConnectionParameters | "Detailed Parameters"
StructuralConnectionNobleStatus | "Noble Status"
StructuralConnectionOverrideType | "Override by Instance"
StructuralConnectionSymbol | "Connection Symbol"
StructuralCopingDistance | "Coping Distance"
StructuralDisplayInHiddenViews | "Display in Hidden Views"
StructuralDisplayInHiddenViewsColumn | "Display in Hidden Views"
StructuralDisplayInHiddenViewsFraming | "Display in Hidden Views"
StructuralElevationAtBottom | "Elevation at Bottom"
StructuralElevationAtBottomCore | "Elevation at Bottom Core"
StructuralElevationAtBottomSurvey | "Elevation at Bottom Survey"
StructuralElevationAtTop | "Elevation at Top"
StructuralElevationAtTopCore | "Elevation at Top Core"
StructuralElevationAtTopSurvey | "Elevation at Top Survey"
StructuralEndReleaseFx | "End Fx"
StructuralEndReleaseFy | "End Fy"
StructuralEndReleaseFz | "End Fz"
StructuralEndReleaseMx | "End Mx"
StructuralEndReleaseMy | "End My"
StructuralEndReleaseMz | "End Mz"
StructuralEndReleaseType | "End Release"
StructuralFamilyCodeName | "Code Name"
StructuralFamilyNameKey | "Family Name Key"
StructuralFloorAnalyzesAs | "Analyze As"
StructuralFloorCoreThickness | "Core Thickness"
StructuralFoundationLength | "Length"
StructuralFoundationThickness | "Foundation Thickness"
StructuralFoundationWidth | "Width"
StructuralFrameCutLength | "Cut Length"
StructuralMaterialParam | "Structural Material"
StructuralMaterialType | "Structural Material Type"
StructuralMemberForces | "Member Forces"
StructuralNumberOfStuds | "Number of studs"
StructuralReferenceLevelElevation | "Reference Level Elevation"
StructuralSectionArea | "Section Area"
StructuralSectionBottomCutHeight | "Bottom Cut Height"
StructuralSectionBottomCutWidth | "Bottom Cut Width"
StructuralSectionCantileverHeight | "Cantilever Height"
StructuralSectionCantileverLength | "Cantilever Length"
StructuralSectionCommonAlpha | "Principal Axes Angle"
StructuralSectionCommonCentroidHoriz | "Centroid Horizontal"
StructuralSectionCommonCentroidVertical | "Centroid Vertical"
StructuralSectionCommonDiameter | "Diameter"
StructuralSectionCommonElasticModulusStrongAxis | "Elastic Modulus strong axis"
StructuralSectionCommonElasticModulusWeakAxis | "Elastic Modulus weak axis"
StructuralSectionCommonHeight | "Height"
StructuralSectionCommonMomentOfInertiaStrongAxis | "Moment of Inertia strong axis"
StructuralSectionCommonMomentOfInertiaWeakAxis | "Moment of Inertia weak axis"
StructuralSectionCommonNominalWeight | "Nominal Weight"
StructuralSectionCommonPerimeter | "Perimeter"
StructuralSectionCommonPlasticModulusStrongAxis | "Plastic Modulus strong axis"
StructuralSectionCommonPlasticModulusWeakAxis | "Plastic Modulus weak axis"
StructuralSectionCommonShearAreaStrongAxis | "Shear Area strong axis"
StructuralSectionCommonShearAreaWeakAxis | "Shear Area weak axis"
StructuralSectionCommonTorsionalModulus | "Torsional Modulus"
StructuralSectionCommonTorsionalMomentOfInertia | "Torsional Moment of Inertia"
StructuralSectionCommonWarpingConstant | "Warping Constant"
StructuralSectionCommonWidth | "Width"
StructuralSectionCprofileFoldLength | "Fold Length"
StructuralSectionHssInnerfillet | "Inner Fillet"
StructuralSectionHssOuterfillet | "Outer Fillet"
StructuralSectionIshapeBoltDiameter | "Bolt Diameter"
StructuralSectionIshapeBoltSpacing | "Bolt Spacing"
StructuralSectionIshapeBoltSpacingBetweenRows | "Bolt Spacing between Rows"
StructuralSectionIshapeBoltSpacingTwoRows | "Bolt Spacing Two Rows"
StructuralSectionIshapeBoltSpacingWeb | "Bolt Spacing web"
StructuralSectionIshapeClearWebHeight | "Clear Web Height"
StructuralSectionIshapeFlangefillet | "Flange Fillet"
StructuralSectionIshapeFlangethickness | "Flange Thickness"
StructuralSectionIshapeFlangethicknessLocation | "Flange Thickness Location"
StructuralSectionIshapeFlangeToeOfFillet | "Flange Toe of Fillet"
StructuralSectionIshapeWebfillet | "Web Fillet"
StructuralSectionIshapeWebheight | "Web Height"
StructuralSectionIshapeWebthickness | "Web Thickness"
StructuralSectionIshapeWebthicknessLocation | "Web Thickness Location"
StructuralSectionIshapeWebToeOfFillet | "Web Toe of Fillet"
StructuralSectionIweldedBottomflangethickness | "Bottom Flange Thickness"
StructuralSectionIweldedBottomflangewidth | "Bottom Flange Width"
StructuralSectionIweldedTopflangethickness | "Top Flange Thickness"
StructuralSectionIweldedTopflangewidth | "Top Flange Width"
StructuralSectionLangleBoltDiameterLongerFlange | "Bolt Diameter Longer Flange"
StructuralSectionLangleBoltDiameterShorterFlange | "Bolt Diameter Shorter Flange"
StructuralSectionLangleBoltSpacing1LongerFlange | "Bolt Spacing 1 Longer Flange"
StructuralSectionLangleBoltSpacing2LongerFlange | "Bolt Spacing 2 Longer Flange"
StructuralSectionLangleBoltSpacingShorterFlange | "Bolt Spacing Shorter Flange"
StructuralSectionLprofileLipLength | "Lip Length"
StructuralSectionNameKey | "Section Name Key"
StructuralSectionPipestandardWalldesignthickness | "Wall Design Thickness"
StructuralSectionPipestandardWallnominalthickness | "Wall Nominal Thickness"
StructuralSectionShape | "Section Shape"
StructuralSectionSigmaProfileBendWidth | "Bend Width"
StructuralSectionSigmaProfileMiddleBendWidth | "Middle Bend Length"
StructuralSectionSigmaProfileTopBendWidth | "Top Bend Length"
StructuralSectionSlopedFlangeAngle | "Sloped Flange Angle"
StructuralSectionSlopedWebAngle | "Sloped Web Angle"
StructuralSectionTopCutHeight | "Top Cut Height"
StructuralSectionTopCutWidth | "Top Cut Width"
StructuralSectionTopWebFillet | "Top Web Fillet"
StructuralSectionZprofileBottomFlangeLength | "Bottom Flange Length"
StructuralStartReleaseFx | "Start Fx"
StructuralStartReleaseFy | "Start Fy"
StructuralStartReleaseFz | "Start Fz"
StructuralStartReleaseMx | "Start Mx"
StructuralStartReleaseMy | "Start My"
StructuralStartReleaseMz | "Start Mz"
StructuralStartReleaseType | "Start Release"
StructuralStickSymbolLocation | "Stick Symbol Location"
StructuralTopReleaseFx | "Top Fx"
StructuralTopReleaseFy | "Top Fy"
StructuralTopReleaseFz | "Top Fz"
StructuralTopReleaseMx | "Top Mx"
StructuralTopReleaseMy | "Top My"
StructuralTopReleaseMz | "Top Mz"
StructuralTopReleaseType | "Top Release"
StructuralWallBottomProjectionPlane | "Bottom Vertical Projection"
StructuralWallProjectionSurface | "Horizontal Projection"
StructuralWallTopProjectionPlane | "Top Vertical Projection"
SupportHandClearance | "Hand Clearance"
SupportHeight | "Height"
SurfaceArea | "Surface Area"
SurfaceName | "Name"
SurfacePatternIdParam | "Surface fill pattern"
SurfacePerimeter | "Perimeter"
SweepBaseFloorSubcategoryId | "Subcategory of Floors"
SweepBaseOffset | "Horizontal Profile Offset"
SweepBaseRoofSubcategoryId | "Subcategory of Roofs"
SweepBaseVertOffset | "Vertical Profile Offset"
SweepMaxSegAngle | "Maximum Segment Angle"
SweepTrajSegmented | "Trajectory Segmentation"
SymbolFamilyAndTypeNamesParam | "Family and Type"
SymbolFamilyNameParam | "Family Name"
SymbolIdParam | "Type Id"
SymbolNameParam | "Type Name"
SystemEquipmentSets | "Equipment Sets"
SystemsAnalysisReportFolder | "Reports Folder Path"
SystemsAnalysisReportStyle | "Report Style"
SystemZoneLevelId | "Level"
TagAngleParam | "Angle"
TagElementCount | "Host Count"
TagElevationBase | "Elevation Base"
TagLeaderType | "Leader Type"
TagNoBreakParamStrings | "Wrap between parameters only"
TagOnPlacementUi | "Tag on Placement"
TagOrientationParam | "Orientation"
TagSampleText | "Sample Text"
TagTag | "Label"
TemplateName | "Template"
TerminationExtensionLength | "Extension Length"
TextAlignHorz | "Horizontal Align"
TextAlignment | "Text Alignment"
TextAlignVert | "Vertical Align"
TextBackground | "Background"
TextBoxVisibility | "Show Border"
TextColor | "Color"
TextDistToLine | "Text Offset"
TextFont | "Text Font"
TextPosition | "Text Position"
TextSize | "Text Size"
TextStyleBold | "Bold"
TextStyleFont | "Font"
TextStyleItalic | "Italic"
TextStyleSize | "Size"
TextStyleUnderline | "Underline"
TextTabSize | "Tab Size"
TextText | "Text"
TextWidthScale | "Width Factor"
ThermalMaterialParamCompressibility | "Compressibility"
ThermalMaterialParamElectricalResistivity | "Electrical Resistivity"
ThermalMaterialParamEmissivity | "Emissivity"
ThermalMaterialParamGasViscosity | "Gas Viscosity"
ThermalMaterialParamLiquidViscosity | "Liquid Viscosity"
ThermalMaterialParamPermeability | "Permeability"
ThermalMaterialParamPorosity | "Porosity"
ThermalMaterialParamReflectivity | "Reflectivity"
ThermalMaterialParamSpecificHeatOfVaporization | "Specific Heat of Vaporization"
ThermalMaterialParamTransmitsLight | "Transmits Light"
ThermalMaterialParamVaporPressure | "Vapor Pressure"
TickMarkPen | "Tick Mark Line Weight"
TilePatternFamrefComponentExtents | "Component Extents"
TilePatternGridCellsX | "Number of horizontal cells"
TilePatternGridCellsY | "Number of vertical cells"
TilePatternGridUnitX | "Horizontal spacing"
TilePatternGridUnitY | "Vertical spacing"
Tilt | "Tilt"
TitleFont | "Font"
TitleSize | "Size"
TitleStyleBold | "Bold"
TitleStyleItalic | "Italic"
TitleStyleUnderline | "Underline"
TopographyLinkName | "Link Name"
TopographyLinkPath | "Saved Path"
ToposolidAttrThicknessParam | "Thickness"
ToposolidContourDisplaySettingsIdParam | "Contour Display"
ToposolidContourSubcategoryId | "Subcategory"
ToposolidElevationAtBottom | "Elevation at Bottom"
ToposolidElevationAtTop | "Elevation at Top"
ToposolidFunctionParam | "Function"
ToposolidHeightabovelevelParam | "Height Offset From Level"
ToposolidInheritContours | "Inherit Contours"
ToposolidStructureIdParam | "Structure"
ToposolidSubdivideHeignt | "Sub-divide Height"
ToposolidSubdivideMaterial | "Material"
ToposolidTypeDefaultThicknessParam | "Default Thickness"
ToposurfaceContourSubcategoryId | "Subcategory"
TrapMullWidth | "Center Width"
TrussBearingChordTopBottomParam | "Bearing Chord"
TrussElementAngleParam | "Rotation Angle"
TrussElementBearingJustParam | "Bearing Vertical Justification"
TrussElementClassParam | "Engineering Type"
TrussElementCreateBottomParam | "Create Bottom Chord"
TrussElementCreateTopParam | "Create Top Chord"
TrussElementEnd0Elevation | "Start Level Offset"
TrussElementEnd1Elevation | "End Level Offset"
TrussElementReferenceLevelParam | "Reference Level"
TrussElementRotateChordsWithTruss | "Rotate Chords With Truss"
TrussElementSpanParam | "Span"
TrussElementStickJustParam | "Stick Symbol Location"
TrussElementTagNewMembersView | "Tag new members in view"
TrussFamilyBottomChordAngleParam | "Angle"
TrussFamilyBottomChordEndReleaseType | "End Release"
TrussFamilyBottomChordStartReleaseType | "Start Release"
TrussFamilyBottomChordStructuralTypesParam | "Structural Framing Type"
TrussFamilyBottomChordVerticalProjectionParam | "Analytical Vertical Projection"
TrussFamilyDiagWebAngleParam | "Angle"
TrussFamilyDiagWebEndReleaseType | "End Release"
TrussFamilyDiagWebStartReleaseType | "Start Release"
TrussFamilyDiagWebStructuralTypesParam | "Structural Framing Type"
TrussFamilyTopChordAngleParam | "Angle"
TrussFamilyTopChordEndReleaseType | "End Release"
TrussFamilyTopChordStartReleaseType | "Start Release"
TrussFamilyTopChordStructuralTypesParam | "Structural Framing Type"
TrussFamilyTopChordVerticalProjectionParam | "Analytical Vertical Projection"
TrussFamilyTransformationParam | "Web Orientation"
TrussFamilyVertWebAngleParam | "Angle"
TrussFamilyVertWebEndReleaseType | "End Release"
TrussFamilyVertWebStartReleaseType | "Start Release"
TrussFamilyVertWebStructuralTypesParam | "Structural Framing Type"
TrussFamilyWebsHaveSymbolicCutbackParam | "Webs have symbolic cutback"
TrussHeight | "Truss Height"
TrussLength | "Truss Length"
TrussNonBearingOffsetParam | "Non Bearing Offset"
TypeWallClosure | "Wall Closure"
UniformatCode | "Assembly Code"
UniformatDescription | "Assembly Description"
ViewAnalysisDisplayStyle | "Default Analysis Display Style"
ViewAnalysisResultsVisibility | "Analysis Display Settings"
ViewAssociatedAssemblyInstanceId | "Associated Assembly Instance"
ViewBackClipping | "Depth Clipping"
ViewCameraOrientation | "Locked Orientation"
ViewCameraPosition | "Camera Position"
ViewCleanJoins | "Wall Join Display"
ViewDependency | "Dependency"
ViewDepth | "View Depth"
ViewDescription | "Title on Sheet"
ViewDesignOptionsConfig | "Design Option Configuration"
ViewDetailLevel | "Detail Level"
ViewDiscipline | "Discipline"
Viewer3dRenderSettings | "Rendering Settings"
ViewerAnnotationCropActive | "Annotation Crop"
ViewerBoundActiveBottom | "Bottom Clip Active"
ViewerBoundActiveFar | "Far Clip Active"
ViewerBoundActiveLeft | "Left Clip Active"
ViewerBoundActiveNear | "Near Clip Active"
ViewerBoundActiveRight | "Right Clip Active"
ViewerBoundActiveTop | "Top Clip Active"
ViewerBoundFarClipping | "Far Clipping"
ViewerBoundOffsetBottom | "Bottom Clip Offset"
ViewerBoundOffsetFar | "Far Clip Offset"
ViewerBoundOffsetLeft | "Left Clip Offset"
ViewerBoundOffsetNear | "Near Clip Offset"
ViewerBoundOffsetRight | "Right Clip Offset"
ViewerBoundOffsetTop | "Top Clip Offset"
ViewerCropRegion | "Crop View"
ViewerCropRegionDisabled | "Crop View"
ViewerCropRegionVisible | "Crop Region Visible"
ViewerDetailNumber | "Detail Number"
ViewerEyeElevation | "Eye Elevation"
ViewerIsReference | "Is a Reference"
ViewerModelClipBoxActive | "Section Box"
ViewerOptionVisibility | "Visible In Option"
ViewerPerspective | "Projection Mode"
ViewerReferenceLabel | "Reference Label"
ViewerReferenceLabelText | "Reference Label"
ViewerSheetNumber | "Sheet Number"
ViewerShowUncropped | "Show uncropped"
ViewerTargetElevation | "Target Elevation"
ViewerVolumeOfInterestCrop | "Scope Box"
ViewFamily | "Family"
ViewFamilyAndTypeSchedules | "Family and Type"
ViewFamilySchedules | "Family"
ViewFixedSketchPlane | "None"
ViewGraphSchedBottomLevel | "Bottom Level"
ViewGraphSchedGridAppearance | "Grid Appearance"
ViewGraphSchedGroupSimilar | "Group Similar Locations"
ViewGraphSchedHiddenLevels | "Hidden Levels"
ViewGraphSchedLevelRelativeBaseType | "Elevation Base for Levels"
ViewGraphSchedLocationsHigh | "Column Locations End"
ViewGraphSchedLocationsLow | "Column Locations Start"
ViewGraphSchedMaterialTypes | "Material Types"
ViewGraphSchedNumberColumns | "Column Locations per Segment"
ViewGraphSchedOffGrid | "Include Off-Grid Columns"
ViewGraphSchedRowsCount | "Segments in Viewport"
ViewGraphSchedRowsFrom | "Segment Start in Viewport"
ViewGraphSchedTextAppearance | "Text Appearance"
ViewGraphSchedTitle | "Title"
ViewGraphSchedTopLevel | "Top Level"
ViewGraphSchedTotalColumns | "Total Column Locations"
ViewGraphSchedTotalRows | "Total Segments"
ViewGraphSchedUnitsFormat | "Off-Grid Units Format"
ViewGraphSunPath | "Sun Path"
ViewGraphSunPathSize | "Sun path size (%)"
ViewModelDisplayMode | "Display Model"
ViewName | "View Name"
ViewPartsVisibility | "Parts Visibility"
ViewPhase | "Phase"
ViewPhaseFilter | "Phase Filter"
ViewportAttrLabelTag | "Title"
ViewportAttrOrientationOnSheet | "Rotation on Sheet"
ViewportAttrPreserveTitlePosition | "Preserve Title Position"
ViewportAttrShowBox | "Show Box"
ViewportAttrShowExtensionLine | "Show Extension Line"
ViewportAttrShowLabel | "Show Title"
ViewportDetailNumber | "Detail Number"
ViewportPositioning | "Viewport Positioning"
ViewportScale | "View Scale"
ViewportSheetName | "Sheet Name"
ViewportSheetNumber | "Sheet Number"
ViewportView | "View"
ViewportViewName | "View Name"
ViewReferencingDetail | "Referencing Detail"
ViewReferencingSheet | "Referencing Sheet"
ViewScale | "Scale Value 1:"
ViewScaleCustomname | "Display Name"
ViewScaleHavename | "Display Name"
ViewScalePulldownImperial | "View Scale"
ViewScalePulldownMetric | "View Scale"
ViewSchemaSettingForBuilding | "Color Scheme"
ViewSchemaSettingForSystem | "System Color Schemes"
ViewSchemaSettingForSystemTemplate | "System Color Schemes"
ViewSheetViewportInfo | "Viewport"
ViewShowGrids | "Show Grids"
ViewShowHiddenLines | "Show Hidden Lines"
ViewShowMassing | "Show Mass"
ViewSlantedColumnSymbolOffset | "Column Symbolic Offset"
ViewSolarstudyAnimationSpeedText | "Loop animation speed"
ViewSolarstudyAnimationSpeedValue | "Loop animation speed"
ViewSolarstudyCurrentStudyTypeIndex | "Study type"
ViewSolarstudyIsLightingStudyType | "Lighting study"
ViewSolarstudyIsMultidayStudyType | "Multi-day study"
ViewSolarstudyIsSingledayStudyType | "Single day study"
ViewSolarstudyIsStillimageStudyType | "Still image study"
ViewSolarstudyLightingAltitudeText | "Lighting altitude text"
ViewSolarstudyLightingAltitudeValue | "Lighting altitude"
ViewSolarstudyLightingAzimuthText | "Lighting azimuth text"
ViewSolarstudyLightingAzimuthValue | "Lighting azimuth"
ViewSolarstudyLightingPresetIndex | "Lighting presets combo"
ViewSolarstudyMultidayDatetimeText | "Multi-day date and time text"
ViewSolarstudyMultidayFrameText | "Multi-day frame text"
ViewSolarstudyMultidayFrameValue | "Multi-day frame"
ViewSolarstudyMultidayPresetIndex | "Multi-day presets combo"
ViewSolarstudyShadowsIntensityText | "Shadows intensity text"
ViewSolarstudyShadowsIntensityValue | "Shadows intensity"
ViewSolarstudySingledayDatetimeText | "Single day date and time text"
ViewSolarstudySingledayFrameText | "Single day frame text"
ViewSolarstudySingledayFrameValue | "Single day frame"
ViewSolarstudySingledayPresetIndex | "Single day presets combo"
ViewSolarstudyStillDateText | "Still date text"
ViewSolarstudyStillDateValue | "Still date"
ViewSolarstudyStillPresetIndex | "Still presets combo"
ViewSolarstudyStillTimeText | "Still time text"
ViewSolarstudyStillTimeValue | "Still time"
ViewSolarstudySunIntensityText | "Sun intensity text"
ViewSolarstudySunIntensityValue | "Sun intensity"
ViewTemplate | "View Template"
ViewTemplateForSchedule | "View Template"
ViewType | "Family and Type"
ViewTypeSchedules | "Type"
ViewUnderlayBottomId | "Range: Base Level"
ViewUnderlayOrientation | "Underlay Orientation"
ViewUnderlayTopId | "Range: Top Level"
ViewVisibleCategories | "Visibility/Graphics Overrides"
VisGraphicsAnalyticalModel | "V/G Overrides Analytical Model"
VisGraphicsAnnotation | "V/G Overrides Annotation"
VisGraphicsCoordinationModel | "V/G Overrides Coordination Model"
VisGraphicsDesignoptions | "V/G Overrides Design Options"
VisGraphicsFilters | "V/G Overrides Filters"
VisGraphicsImport | "V/G Overrides Import"
VisGraphicsModel | "V/G Overrides Model"
VisGraphicsPointClouds | "V/G Overrides Point Clouds"
VisGraphicsRvtLinks | "V/G Overrides RVT Links"
VisGraphicsWorksets | "V/G Overrides Worksets"
VoidCutsGeometry | "Cuts Geometry"
VolumeCut | "Cut"
VolumeFill | "Fill"
VolumeNet | "Net cut/fill"
VolumeOfInterestHeight | "Height"
VolumeOfInterestName | "Name"
VolumeOfInterestViewsVisible | "Views Visible"
WalkthroughFramesCount | "Walkthrough Frames"
WallAlignKeyRefParam | "Location line to align"
WallAttrDefheightParam | "Default height"
WallAttrHeightParam | "Height"
WallAttrRoomBounding | "Room Bounding"
WallAttrWidthParam | "Width"
WallBaseConstraint | "Base Constraint"
WallBaseHeightParam | "Base height"
WallBaseOffset | "Base Offset"
WallBottomExtensionDistParam | "Base Extension Distance"
WallBottomIsAttached | "Base is Attached"
WallCrossSection | "Cross-Section"
WallHeightType | "Top Constraint"
WallKeyRefParam | "Location Line"
WallLocationLineOffsetParam | "Location Line Offset"
WallSingleSlantAngleFromVertical | "Angle From Vertical"
WallStructuralSignificant | "Structural"
WallStructuralUsageParam | "Structural Usage"
WallStructureIdParam | "Structure"
WallSweepCutByInsertsParam | "Cut by Inserts"
WallSweepCutsWallParam | "Cuts Wall"
WallSweepDefaultSetbackParam | "Default Setback"
WallSweepLevelParam | "Level"
WallSweepOffsetParam | "Offset From Level"
WallSweepOrientation | "Orientation"
WallSweepProfileParam | "Profile"
WallSweepWallOffsetParam | "Offset From Wall"
WallSweepWallSubcategoryId | "Subcategory of Walls"
WallTaperedExteriorInwardAngle | "Exterior Angle"
WallTaperedInteriorInwardAngle | "Interior Angle"
WallTaperedUseInstanceAngles | "Enable Angle Overrides"
WallTaperedWidthAtBottom | "Bottom Width"
WallTaperedWidthAtTop | "Top Width"
WallTopExtensionDistParam | "Top Extension Distance"
WallTopIsAttached | "Top is Attached"
WallTopOffset | "Top Offset"
WallTypeDefaultTaperedExteriorInwardAngle | "Default Exterior Angle"
WallTypeDefaultTaperedInteriorInwardAngle | "Default Interior Angle"
WallTypeWidthMeasuredAt | "Width Measured At"
WallUserHeightParam | "Unconnected Height"
WindowTypeId | "Type Mark"
WindowTypeName | "Name"
WitnsLineExtension | "Witness Line Extension"
WitnsLineGapToElt | "Witness Line Gap to Element"
WitnsLineTickMark | "Witness Line Tick Mark"
WrappingAtEndsParam | "Wrapping at Ends"
WrappingAtInsertsParam | "Wrapping at Inserts"
YJustification | "y Justification"
YOffsetValue | "y Offset Value"
YzJustification | "yz Justification"
ZJustification | "z Justification"
ZOffsetValue | "z Offset Value"
ZoneAirChangesPerHour | "Air Changes per Hour"
ZoneAirVolumeCalculationTypeParam | "Air Volume Calculation Type"
ZoneArea | "Occupied Area"
ZoneAreaGross | "Gross Area"
ZoneCalculatedAreaPerCoolingLoadParam | "Calculated Area per Cooling Load"
ZoneCalculatedAreaPerHeatingLoadParam | "Calculated Area per Heating Load"
ZoneCalculatedCoolingLoadParam | "Calculated Cooling Load"
ZoneCalculatedCoolingLoadPerAreaParam | "Calculated Cooling Load per area"
ZoneCalculatedHeatingLoadParam | "Calculated Heating Load"
ZoneCalculatedHeatingLoadPerAreaParam | "Calculated Heating Load per area"
ZoneCalculatedHydronicCoolingflowParam | "Calculated Hydronic Cooling Flow"
ZoneCalculatedHydronicHeatingflowParam | "Calculated Hydronic Heating Flow"
ZoneCalculatedSupplyAirflowParam | "Calculated Supply Airflow"
ZoneCalculatedSupplyAirflowPerAreaParam | "Calculated Supply Airflow per area"
ZoneCoilBypassPercentageParam | "Coil Bypass"
ZoneCoolingAirTemperatureParam | "Cooling Air Temperature"
ZoneCoolingInformationParam | "Cooling Information"
ZoneCoolingSetPointParam | "Cooling Set Point"
ZoneDehumidificationSetPointParam | "Dehumidification Set Point"
ZoneDesignCoolTemperature | "Design Temperature for Cooling"
ZoneDesignHeatTemperature | "Design Temperature for Heating"
ZoneHeatingAirTemperatureParam | "Heating Air Temperature"
ZoneHeatingInformationParam | "Heating Information"
ZoneHeatingSetPointParam | "Heating Set Point"
ZoneHumidificationSetPointParam | "Humidification Set Point"
ZoneLevelId | "Level"
ZoneLevelOffset | "Level Offset"
ZoneLevelOffsetTop | "Top Offset"
ZoneName | "Name"
ZoneOaRatePerAchParam | "Outdoor Air Rate / Air Changes per Hour"
ZoneOutdoorAirInformationParam | "Outdoor Air Information"
ZoneOutsideAirFlowPerArea | "Outside Air Flow per Area"
ZoneOutsideAirFlowPerPerson | "Outside Air Flow per Person"
ZoneOutsideAirPerAreaParam | "Outdoor Air per Area"
ZoneOutsideAirPerPersonParam | "Outdoor Air per Person"
ZonePerimeter | "Perimeter"
ZonePhase | "Phase"
ZonePhaseId | "Phase Id"
ZoneServiceTypeParam | "Service Type"
ZoneSpaceOutdoorAirOptionParam | "Space Outdoor Air Option"
ZoneUseAirChangesPerHourParam | "Use Air Changes Per Hour"
ZoneUseDehumidificationSetpointParam | "Use Dehumidification Set Point"
ZoneUseHumidificationSetpointParam | "Use Humidification Set Point"
ZoneUseOutsideAirPerAreaParam | "Use Outside Air Per Area"
ZoneUseOutsideAirPerPersonParam | "Use Outside Air Per Person"
ZoneVolume | "Occupied Volume"
ZoneVolumeGross | "Gross Volume"

See Also

ParameterTypeId Class


ParameterTypeId Properties

[image] [image]

Revit 2024 API
ParameterTypeId Properties
ParameterTypeId Class See Also Send Feedback

The ParameterTypeId type exposes the following members.

Properties

Name | Description
ActualMaxRidgeHeightParam | "Maximum Ridge Height"
AlignmentStationLabelDistance | "Distance": Currently not in use
AlignmentStationLabelIncludeStation | "Include Station"
AlignmentStationLabelIndStation | "Station Indicator"
AlignmentStationLabelSetEndStation | "Alignment Label Set End Station"
AlignmentStationLabelSetInterval | "Alignment Station Label Set Interval": The text is not used directly anywhere in the UI, instead the XAML specifies its own string for the value's label.
AlignmentStationLabelSetOffset | "Alignment Station Label Set Offset": The text is not used directly anywhere in the UI, instead the XAML specifies its own string for the value's label.
AlignmentStationLabelSetStartStation | "Alignment Label Set Start Station"
AlignmentStationLabelStationValue | "Station Value"
AlignmentStationPrefix | "Station Prefix"
AlignmentStationSuffix | "Station Suffix"
AllGridRotationForDivisionRule | "All Grid Rotation"
AllModelDescription | "Description"
AllModelImage | "Image"
AllModelInstanceComments | "Comments"
AllModelManufacturer | "Manufacturer"
AllModelModel | "Model"
AllModelTypeComments | "Type Comments"
AllModelTypeImage | "Type Image"
AllModelUrl | "URL"
AllowAutoEmbed | "Automatically Embed"
AlternateUnits | "Alternate Units"
AlternateUnitsPrefix | "Alternate Units Prefix"
AlternateUnitsSuffix | "Alternate Units Suffix"
AlwaysZeroLength | "Base Offset"
AnalyticalAbsorptance | "Absorptance"
AnalyticalAdjacentSpace | "Adjacent Analytical Space"
AnalyticalDefineThermalPropertiesBy | "Define Thermal Properties by"
AnalyticalElementHasAssociation | "Has Association": Used for Analytical Member, Analytical Panel, Structural Columns, Structural Framing, Floors, Walls, Structural Foundation
AnalyticalElementPhysicalAsset | "Physical Material Asset": Used for Analytical Elements.
AnalyticalElementStructuralRole | "Structural Role": Used for Analytical Elements
AnalyticalGeometryIsValid | "Analytical Model Correct"
AnalyticalHeatTransferCoefficient | "Heat Transfer Coefficient (U)"
AnalyticalLinkReleaseRotationX | "X Rotation"
AnalyticalLinkReleaseRotationY | "Y Rotation"
AnalyticalLinkReleaseRotationZ | "Z Rotation"
AnalyticalLinkReleaseTranslationX | "X Translation"
AnalyticalLinkReleaseTranslationY | "Y Translation"
AnalyticalLinkReleaseTranslationZ | "Z Translation"
AnalyticalMemberForceEndAllNonZero | "All non 0 forces at end"
AnalyticalMemberForceEndFx | "End Fx"
AnalyticalMemberForceEndFy | "End Fy"
AnalyticalMemberForceEndFz | "End Fz"
AnalyticalMemberForceEndMx | "End Mx"
AnalyticalMemberForceEndMy | "End My"
AnalyticalMemberForceEndMz | "End Mz"
AnalyticalMemberForceStartAllNonZero | "All non 0 forces at start"
AnalyticalMemberForceStartFx | "Start Fx"
AnalyticalMemberForceStartFy | "Start Fy"
AnalyticalMemberForceStartFz | "Start Fz"
AnalyticalMemberForceStartMx | "Start Mx"
AnalyticalMemberForceStartMy | "Start My"
AnalyticalMemberForceStartMz | "Start Mz"
AnalyticalMemberRotation | "Cross-Section Rotation": Used for Analytical Member
AnalyticalMemberSectionType | "Section Type": The id of the type from the structural Family assigned to the analytical member.
AnalyticalModelArea | "Area": The Area of Analytical Model
AnalyticalModelBaseAlignmentMethod | "Base Alignment Method"
AnalyticalModelBaseExtensionMethod | "Base Extension Method"
AnalyticalModelBaseYProjection | "Base y Projection"
AnalyticalModelBaseZProjection | "Base z Projection"
AnalyticalModelCodeChecking | "Code Checking": Used for Analytical wall, Analytical beam, Analytical column, Analytical floor, Analytical wall foundations, Analytical isolated foundations, Analytical foundations slab, Anaytical brace
AnalyticalModelColumnBaseExtension | "Base x Projection"
AnalyticalModelColumnTopExtension | "Top x Projection"
AnalyticalModelEndAlignmentMethod | "End Alignment Method"
AnalyticalModelEndProjectionOrthogonal | "End Projection Orthogonal"
AnalyticalModelEndYProjection | "End y Projection"
AnalyticalModelEndZProjection | "End z Projection"
AnalyticalModelFloorAlignmentMethod | "Alignment Method"
AnalyticalModelFloorProjection | "z Projection"
AnalyticalModelFoundationsMark | "Foundation Number": Used for isolated, wall foundations
AnalyticalModelLength | "Length": The length of Analytical Model
AnalyticalModelManuallyAdjusted | "Manually Adjusted"
AnalyticalModelNodesMark | "Node Number": Used for nodes
AnalyticalModelPerimeter | "Perimeter": The Perimeter of Analytical Model
AnalyticalModelPhysicalType | "Family Type": the Family Type of the physical element associated with the Analytical Model
AnalyticalModelRotation | "Cross-Section Rotation": The rotation of Analytical Model
AnalyticalModelSketchAlignmentMethod | "Alignment Method"
AnalyticalModelSketchProjection | "In-Plane Projection"
AnalyticalModelStartAlignmentMethod | "Start Alignment Method"
AnalyticalModelStartProjectionOrthogonal | "Start Projection Orthogonal"
AnalyticalModelStartYProjection | "Start y Projection"
AnalyticalModelStartZProjection | "Start z Projection"
AnalyticalModelStickElementsMark | "Member Number": Used for beams, braces, columns
AnalyticalModelSurfaceElementsMark | "Surface Number": Used for floors, slabs, walls
AnalyticalModelTopAlignmentMethod | "Top Alignment Method"
AnalyticalModelTopExtensionMethod | "Top Extension Method"
AnalyticalModelTopYProjection | "Top y Projection"
AnalyticalModelTopZProjection | "Top z Projection"
AnalyticalModelWallAlignmentMethod | "Alignment Method"
AnalyticalModelWallBaseProjection | "Base y Projection"
AnalyticalModelWallProjection | "z Projection"
AnalyticalModelWallTopProjection | "Top y Projection"
AnalyticalNodeConnectionStatus | "Connection Status"
AnalyticalPanelThickness | "Thickness": Used for Analytical Panel
AnalyticalRoughness | "Roughness"
AnalyticalSolarHeatGainCoefficient | "Solar Heat Gain Coefficient"
AnalyticalSpace | "Analytical Space"
AnalyticalSurface | "Analytical Surface"
AnalyticalThermalMass | "Thermal Mass"
AnalyticalThermalResistance | "Thermal Resistance (R)"
AnalyticalVisualLightTransmittance | "Visual Light Transmittance"
AnalyticalZone | "Analytical Zone"
AnalyticalZoneName | "Name"
AnalyticConstruction | "Analytic Construction"
AnalyticConstructionGbxmlTypeid | "Construction Type Id"
AnalyticConstructionLookupTable | "Analytic Construction"
AnyPatternIdParam | "Fill Pattern"
AnyPatternIdParamNoNo | "Fill Pattern"
ArcCenterMark | "Center Marks"
ArcLeaderParam | "Arc Leaders"
ArcWallCntrMrkVisible | "Center Mark Visible"
AreaSchemeId | "Area Scheme Id"
AreaSchemeName | "Name"
AreaType | "Area Type"
AreaTypeText | "Area Type"
ArrowCentered | "Tick Mark Centered"
ArrowClosed | "Arrow Closed"
ArrowFilled | "Fill Tick"
ArrowheadEndAtRiser | "End at Riser"
ArrowheadType | "Arrowhead Type"
ArrowSize | "Tick Size"
ArrowType | "Arrow Style"
AssemblyName | "Assembly Name"
AssemblyNamingCategory | "Naming Category"
AssemblyPrecastFreeze | "Disable Precast Updates"
AssignTemplateOnViewCreation | "New views are dependent on template"
AssociatedLevel | "Associated Level": The level associated with this cell.
AssociatedLevelOffset | "Associated Level Offset": The offset from the associated level.
AutoJoinCondition | "Join Condition"
AutoJoinConditionWall | "Join Condition"
AutoMullionBorder1Grid1 | "Border 1 Type"
AutoMullionBorder1Grid2 | "Border 1 Type"
AutoMullionBorder1Horiz | "Border 1 Type"
AutoMullionBorder1Vert | "Border 1 Type"
AutoMullionBorder2Grid1 | "Border 2 Type"
AutoMullionBorder2Grid2 | "Border 2 Type"
AutoMullionBorder2Horiz | "Border 2 Type"
AutoMullionBorder2Vert | "Border 2 Type"
AutoMullionInteriorGrid1 | "Interior Type"
AutoMullionInteriorGrid2 | "Interior Type"
AutoMullionInteriorHoriz | "Interior Type"
AutoMullionInteriorVert | "Interior Type"
AutoPanel | "Curtain Panel"
AutoPanelWall | "Curtain Panel"
Azimuth | "Azimuth"
BackgroundDraftPatternIdParam | "Background Fill Pattern"
BackgroundPatternColorParam | "Background Pattern Color"
BaselineDimOffset | "Baseline Offset"
BasepointAngletonParam | "Angle to True North"
BasepointEastwestParam | "E/W"
BasepointElevationParam | "Elev"
BasepointLatitudeParam | "Lat"
BasepointLongitudeParam | "Lon"
BasepointNorthsouthParam | "N/S"
BeamHJustification | "Lateral Justification"
BeamSystem3dParam | "3D"
BeamSystemTagInstParamAngle | "Beam System Tag Direction"
BeamSystemTagParamLeft | "Left"
BeamSystemTagParamRight | "Right"
BeamVJustification | "z-Direction Justification"
BeamVJustificationOtherValue | "z-Direction Offset Value"
BendingDetailAngularDimensionTextPosition | "Angle Text Position"
BendingDetailDetailLevel | "Detail Level"
BendingDetailRepesentationFor3dBars | "View for 3D Shape"
BendingDetailSegmenetRepesentation | "Representation"
BendingDetailSegmentLengthDimensionTextPosition | "Dimension Text Position"
BendingDetailTypeAngularDimensionOffset | "Angular Dimension Offset"
BendingDetailTypeAngularDimensionsEnabled | "Angular Dimensions"
BendingDetailTypeAngularDimensionsForHooksEnabled | "Hook Angles"
BendingDetailTypeAngularDimensionsMeasurement | "Angle Measurement"
BendingDetailTypeAngularDimensionTypeId | "Angular Dimension Style"
BendingDetailTypeBendDiameterDimensionsEnabled | "Bend Diameter Dimensions"
BendingDetailTypeBendDiameterDimensionsForHooksEnabled | "Hook Bends"
BendingDetailTypeBendDiameterDimensionsForSegmentsEnabled | "Segment Bends"
BendingDetailTypeDiameterDimensionTypeId | "Diameter Dimension Style"
BendingDetailTypeOrthogonalAndOverallDimesionsEnabled | "Other Dimensions"
BendingDetailTypeRadialDimensionTypeId | "Radial Dimension Style"
BendingDetailTypeSegmentLengthDimensionsEnabled | "Segment Length Dimensions"
BendingDetailTypeSegmentLengthDimensionsForHooksEnabled | "Hook Lengths"
BendingDetailTypeSegmentLengthDimensionsOffset | "Dimension Offset"
BendingDetailTypeSegmentLengthDimensionTypeId | "Linear Dimension Style"
BendingDetailTypeSegmentLengthsDisplayOption | "Straight Segment Lengths"
BendingDetailTypeSegmentLengthsForArcsDisplayOption | "Arc Segment Lengths"
BendingDetailTypeShowAngularDimensionsFor | "Show for Angles"
BendingDetailTypeShowBarBendingUsing | "Dimension Type"
BendingDetailVaryingRebarDimension | "Varying Rebar Set Dimensions"
BentFabricParamBendDirection | "Bend Direction": Direction in which FabricSheet is bent.
BentFabricParamLongitudinalCutLength | "Longitudinal Cut Length": Bent fabric longitudinal cut length.
BentFabricParamStraightWiresLocation | "Straight Wires Location": Location of straight wires in a bent fabric.
BlendEndParam | "Second End"
BlendStartParam | "First End"
BoundaryAreaRestraintX | "X Spring Modulus"
BoundaryAreaRestraintY | "Y Spring Modulus"
BoundaryAreaRestraintZ | "Z Spring Modulus"
BoundaryBearing | "Bearing"
BoundaryConditionsIsExt | "Is Boundary Conditions External?"
BoundaryConditionsType | "Boundary Conditions Type"
BoundaryDirectionRotX | "X Rotation"
BoundaryDirectionRotY | "Y Rotation"
BoundaryDirectionRotZ | "Z Rotation"
BoundaryDirectionX | "X Translation"
BoundaryDirectionY | "Y Translation"
BoundaryDirectionZ | "Z Translation"
BoundaryDistance | "Distance"
BoundaryLinearRestraintRotX | "X Spring Modulus"
BoundaryLinearRestraintX | "X Spring Modulus"
BoundaryLinearRestraintY | "Y Spring Modulus"
BoundaryLinearRestraintZ | "Z Spring Modulus"
BoundaryParamPreset | "State"
BoundaryParamPresetArea | "State"
BoundaryParamPresetLinear | "State"
BoundaryRadius | "Radius"
BoundaryRestraintRotX | "X Spring Modulus"
BoundaryRestraintRotY | "Y Spring Modulus"
BoundaryRestraintRotZ | "Z Spring Modulus"
BoundaryRestraintX | "X Spring Modulus"
BoundaryRestraintY | "Y Spring Modulus"
BoundaryRestraintZ | "Z Spring Modulus"
BoundaryXRotationFixed | "X Rotation - Fixed"
BoundaryXRotationSpring | "X Rotation - Spring"
BoundaryXTranslationFixed | "X Translation - Fixed"
BoundaryXTranslationSpring | "X Translation - Spring"
BoundaryYRotationFixed | "Y Rotation - Fixed"
BoundaryYRotationSpring | "Y Rotation - Spring"
BoundaryYTranslationFixed | "Y Translation - Fixed"
BoundaryYTranslationSpring | "Y Translation - Spring"
BoundaryZRotationFixed | "Z Rotation - Fixed"
BoundaryZRotationSpring | "Z Rotation - Spring"
BoundaryZTranslationFixed | "Z Translation - Fixed"
BoundaryZTranslationSpring | "Z Translation - Spring"
BrOrgFilter | "Filter"
BrOrgFolders | "Folders"
BuildingClosingTimeParam | "Closing Time"
BuildingCurveGstyle | "Line Style"
BuildingCurveGstylePlusInvisible | "Subcategory"
BuildingOpeningTimeParam | "Opening Time"
BuildingpadHeightabovelevelParam | "Height Offset From Level"
BuildingpadThickness | "Thickness"
BuildingUnoccupiedCoolingSetPointParam | "Unoccupied Cooling Set Point"
BuilidingPadStructureIdParam | "Structure"
CabletrayMinbendmultiplierParam | "Bend Radius Multiplier"
CalloutAttrHeadTag | "Callout Head"
CalloutCornerSheetRadius | "Corner Radius"
CalloutSyncronizeBoundOffsetFar | "Far Clip Settings"
CalloutTag | "Callout Tag"
CeilingAttrDefaultHeightParam | "Default Height above level"
CeilingAttrPatternParam | "Pattern"
CeilingAttrSpacing1Param | "Spacing Axis 1"
CeilingAttrSpacing2Param | "Spacing Axis 2"
CeilingAttrSystemnameParam | "System"
CeilingHasThicknessParam | "Has Thickness"
CeilingHeightabovelevelParam | "Height Offset From Level"
CeilingStructureIdParam | "Structure"
CeilingThickness | "Thickness"
CeilingThicknessParam | "Thickness"
CenterMarkSize | "Center Mark Size"
CircMullionRadius | "Radius"
CircuitLoadClassificationAbbreviationParam | "Load Classification Abbreviation"
CircuitLoadClassificationParam | "Load Classification"
CircuitPhaseParam | "Phase Label"
CircuitWaysParam | "Ways"
CircularFramingDiameter | "Circular Diameter"
ClearCover | "Rebar Cover"
ClearCoverBottom | "Rebar Cover - Bottom Face"
ClearCoverExterior | "Rebar Cover - Exterior Face"
ClearCoverInterior | "Rebar Cover - Interior Face"
ClearCoverOther | "Rebar Cover - Other Faces"
ClearCoverTop | "Rebar Cover - Top Face"
ClientName | "Client Name"
ClineSubcategory | "Subcategory"
CoarseScaleFillPatternColor | "Coarse Scale Fill Color"
CoarseScaleFillPatternIdParam | "Coarse Scale Fill Pattern"
ColorFillFilteredParam | "Values Displayed"
ColorFillSwatchHeightParam | "Swatch Height"
ColorFillSwatchWidthParam | "Swatch Width"
ColorSchemeLocation | "Color Scheme Location"
ColumnBaseAttachCutParam | "Base Attachment Cut"
ColumnBaseAttachedParam | "Base is Attached"
ColumnBaseAttachJustificationParam | "Attachment Justification At Base"
ColumnBaseAttachmentOffsetParam | "Offset From Attachment At Base"
ColumnLocationMark | "Column Location Mark"
ColumnTopAttachCutParam | "Top Attachment Cut"
ColumnTopAttachedParam | "Top is Attached"
ColumnTopAttachJustificationParam | "Attachment Justification At Top"
ColumnTopAttachmentOffsetParam | "Offset From Attachment At Top"
ConceptualConstructionMaterial | "Graphical Appearance"
ConduitStandardTypeParam | "Standard"
ConnectorAngle | "Angle"
ConnectorAngleOfDeflection | "Angle of Deflection"
ConnectorDiameter | "Diameter"
ConnectorEngagementLength | "Engagement Length"
ConnectorGenderType | "Connector Gender Type"
ConnectorHeight | "Height"
ConnectorIndex | "Index"
ConnectorInsideDiameter | "Inside Diameter"
ConnectorJointType | "Connector Joint Type"
ConnectorLength | "Length"
ConnectorProfileType | "Shape"
ConnectorRadius | "Radius"
ConnectorReferenceIndex | "Link Connector Index"
ConnectorUtilityParam | "Utility"
ConnectorVisibleSize | "Size on screen"
ConnectorWidth | "Width"
ConstraintFixedOffset | "Fixed offset"
ConstructionIsSchematic | "Schematic"
ConstructionName | "Name"
ContinuousFootingBearingWidth | "Width"
ContinuousFootingBottomHeel | "Bottom Heel Length"
ContinuousFootingBottomToe | "Bottom Toe Length"
ContinuousFootingBreakAtInsertsDisable | "Do Not Break At Inserts"
ContinuousFootingDefaultEndExtensionLength | "Default End Extension Length"
ContinuousFootingEccentricity | "Eccentricity"
ContinuousFootingLength | "Length"
ContinuousFootingStructuralUsage | "Structural Usage"
ContinuousFootingTopHeel | "Heel Length"
ContinuousFootingTopToe | "Toe Length"
ContinuousFootingWidth | "Width"
ContinuousrailBeginningTerminationAttachmentParam | "Extension Style"
ContinuousrailBeginningTerminationTypeParam | "Beginning/Bottom Termination"
ContinuousrailDefaultJoinTypeParam | "Default Join"
ContinuousrailEndExtensionLengthParam | "Length"
ContinuousrailEndTerminationAttachmentParam | "Extension Style"
ContinuousrailEndTerminationTypeParam | "End/Top Termination"
ContinuousrailExtensionLengthParam | "Length"
ContinuousrailFilletRadiusParam | "Fillet Radius"
ContinuousrailJoinTypeParam | "Rail Path Join"
ContinuousrailLengthParam | "Length"
ContinuousrailMaterialsParam | "Material"
ContinuousrailPlusTreadDepthParam | "Plus Tread Depth"
ContinuousrailProfileTypeParam | "Profile"
ContinuousrailTransitionTypeParam | "Transitions"
ContourElevation | "Elevation"
ContourElevationStep | "Increment"
ContourLabelsElevBaseType | "Elevation Base"
ContourLabelsLinearUnits | "Units Format"
ContourLabelsPrimaryOnly | "Label primary contours only"
ContourLabelsRelativeBase | "Relative Base"
CouplerCode | "Part Number"
CouplerCoupledBarSize | "Bar Size 2"
CouplerCoupledEndtreatment | "End Treatment 2"
CouplerCoupledEngagement | "Bar Engagement 2"
CouplerLength | "Total Length"
CouplerMainBarSize | "Bar Size 1"
CouplerMainEndtreatment | "End Treatment 1"
CouplerMainEngagement | "Bar Engagement 1"
CouplerMark | "Schedule Mark"
CouplerNumber | "Coupler Number"
CouplerQuantity | "Quantity"
CouplerRotationAngle | "Coupler Rotation"
CouplerWeight | "Mass"
CouplerWidth | "External Diameter"
CoverTypeLength | "Length"
CoverTypeName | "Name"
CurtaingridAdjustBorderHoriz | "Adjust for Mullion Size"
CurtaingridAdjustBordern1 | "Adjust for Mullion Size"
CurtaingridAdjustBordern2 | "Adjust for Mullion Size"
CurtaingridAdjustBorderU | "Adjust for Mullion Size"
CurtaingridAdjustBorderV | "Adjust for Mullion Size"
CurtaingridAdjustBorderVert | "Adjust for Mullion Size"
CurtaingridAngleHoriz | "Angle"
CurtaingridAnglen1 | "Angle"
CurtaingridAnglen2 | "Angle"
CurtaingridAngleU | "Grid Rotation"
CurtaingridAngleV | "Grid Rotation"
CurtaingridAngleVert | "Angle"
CurtainGridBaseOrientation | "Grid Base Orientation"
CurtaingridBeltHoriz | "Measurement Line"
CurtaingridBeltn1 | "Measurement Line"
CurtaingridBeltn2 | "Measurement Line"
CurtaingridBeltRation1 | "Measurement Line"
CurtaingridBeltRation2 | "Measurement Line"
CurtaingridBeltRatioU | "Belt Measurement"
CurtaingridBeltRatioV | "Belt Measurement"
CurtaingridBeltU | "Belt Measurement"
CurtaingridBeltV | "Belt Measurement"
CurtaingridBeltVert | "Measurement Line"
CurtaingridOriginHoriz | "Offset"
CurtaingridOriginn1 | "Offset"
CurtaingridOriginn2 | "Offset"
CurtaingridOriginU | "Offset"
CurtaingridOriginV | "Offset"
CurtaingridOriginVert | "Offset"
CurtaingridUseCurveDist | "Use Curve Distance"
CurtaingridUseCurveDistHoriz | "Use Curve Distance"
CurtaingridUseCurveDistn1 | "Use Curve Distance"
CurtaingridUseCurveDistn2 | "Use Curve Distance"
CurtaingridUseCurveDistU | "Use Curve Distance"
CurtaingridUseCurveDistV | "Use Curve Distance"
CurtaingridUseCurveDistVert | "Use Curve Distance"
CurtainVersionParam | "Curtain version"
CurtainWallPanelHostId | "Host Id"
CurtainWallPanelsHeight | "Height"
CurtainWallPanelsWidth | "Width"
CurtainWallSyspanelOffset | "Offset"
CurtainWallSyspanelThickness | "Thickness"
CurveBottomLevel | "Bottom Level"
CurveByPointsProjectionType | "Projection Type"
CurveDeterminesOrientation | "Determines Orientation"
CurveEdgeOffset | "Wall offset"
CurveElemArcEndAngle | "Angle 2"
CurveElemArcRadius | "Radius"
CurveElemArcRange | "Range"
CurveElemArcStartAngle | "Angle 1"
CurveElemDefinesSlope | "Defines Beam System Slope"
CurveElemLength | "Length"
CurveElemLineAngle | "Angle"
CurveHeightOffset | "Offset From Base"
CurveIsDetail | "Detail Line"
CurveIsFilled | "Filled"
CurveIsMultilevel | "Multilevel Boundary"
CurveIsReferenceLine | "Is Reference Line"
CurveIsSlopeDefining | "Defines Slope"
CurveLevel | "Level"
CurveNumberOfSegments | "Number of Full Segments"
CurveParamConcreteCantilever | "Concrete Cantilever"
CurveParamSteelCantilever | "Steel Cantilever"
CurveSupportOffset | "Wall offset"
CurveTopLevel | "Top Level"
CurveVisibilityParam | "Visibility/Graphics Overrides"
CurveWallOffset | "Wall offset"
CurveWallOffsetRoofs | "Overhang"
CustMullionThick | "Thickness"
CustMullionWidth1 | "Width on side 1"
CustMullionWidth2 | "Width on side 2"
CutLineAngle | "Cut Line Angle"
CutLineDistance | "Cut Line Distance"
CutLineExtension | "Cut Line Extension"
CutLineType | "Cut Line Type"
CutMarkSymbol | "Cut Mark Symbol"
CutMarkSymbolSize | "Cut Mark Symbol Size"
CwpAddGridPrefix | "Add prefix to Grid Name"
CwpAddGridSuffix | "Add suffix to Grid Name"
CwpAddLevelPrefix | "Add prefix to Level Name"
CwpAddLevelSuffix | "Add suffix to Level Name"
CwpCopyFloorInserts | "Copy openings/inserts"
CwpCopyRoofInserts | "Copy openings"
CwpCopyWallInserts | "Copy windows/doors/openings"
CwpLevelOffset | "Offset Level"
CwpLinkedRoomParams | "Parameters"
CwpLinkedRoomPhases | "Phases"
CwpReuseExistingGrids | "Reuse matching Grids"
CwpReuseExistingLevels | "Reuse matching Levels"
CwpReuseGridsSameName | "Reuse Grids with the same name"
CwpReuseLevelsSameName | "Reuse Levels with the same name"
CwpSplitColumnsAtLevels | "Split Columns by Levels"
DatumBubbleEndn1 | "Symbol at End 1 Default"
DatumBubbleEndn2 | "Symbol at End 2 Default"
DatumBubbleLocationInElev | "Non-Plan View Symbols (Default)"
DatumPlaneDefinesOrigin | "Defines Origin"
DatumPlaneDefinesWallClosure | "Wall Closure"
DatumText | "Name"
DatumVolumeOfInterest | "Scope Box"
DebugtabDataboundcontrolsdemoBoolean | "Boolean"
DebugtabDataboundcontrolsdemoDouble | "Double"
DebugtabDataboundcontrolsdemoEnum | "Options"
DebugtabDataboundcontrolsdemoInteger | "Integer"
DecalAttributes | "Decal Attributes"
DecalHeight | "Height"
DecalLockProportions | "Lock Proportions"
DecalSubcategoryId | "Subcategory"
DecalWidth | "Width"
DefaultConstructionExtWallUnderground | "Mass Exterior Wall - Underground"
DefaultConstructionMassExteriorWall | "Mass Exterior Wall"
DefaultConstructionMassFloor | "Mass Floor"
DefaultConstructionMassGlazing | "Mass Glazing"
DefaultConstructionMassInteriorWall | "Mass Interior Wall"
DefaultConstructionMassOpening | "Mass Opening"
DefaultConstructionMassRoof | "Mass Roof"
DefaultConstructionMassShade | "Mass Shade"
DefaultConstructionMassSkylight | "Mass Skylight"
DefaultConstructionMassSlab | "Mass Slab"
DefaultViewTemplate | "View Template applied to new views"
DefinesConstantHeight | "Defines Constant Height"
DesignOptionId | "Design Option"
DesignOptionParam | "Design Option"
DiameterSymbolLocation | "Diameter Symbol Location"
DiameterSymbolText | "Diameter Symbol Text"
DimDisplayEq | "Equality Display"
DimIsreporting | "Is Reporting"
DimLabel | "Label"
DimLabelGpShow | "Show Label in View"
DimLabelIsInstance | "Is Instance Parameter"
DimLeader | "Leader"
DimLeaderArrowhead | "Tick Mark"
DimLeaderDisplayCondition | "Show Leader When Text Moves"
DimLeaderShoulderLength | "Shoulder Length"
DimLeaderType | "Leader Type"
DimLineExtension | "Dimension Line Extension"
DimNotModifiable | "Non-modifiable"
DimPrefix | "Dimension Prefix"
DimReferenceCount | "Count"
DimStyleAngularUnits | "Units Format"
DimStyleAngularUnitsAlt | "Alternate Units Format"
DimStyleCenterlinePattern | "Centerline Pattern"
DimStyleCenterlineSymbol | "Centerline Symbol"
DimStyleCenterlineTickMark | "Centerline Tick Mark"
DimStyleDimLineSnapDist | "Dimension Line Snap Distance"
DimStyleFlippedDimLineExtension | "Flipped Dimension Line Extension"
DimStyleInteriorTickMark | "Interior Tick Mark"
DimStyleLeaderTickMark | "Leader Tick Mark"
DimStyleLinearUnits | "Units Format"
DimStyleLinearUnitsAlt | "Alternate Units Format"
DimStyleReadConvention | "Read Convention"
DimStyleShowOpeningHt | "Show Opening Height"
DimStyleSuppressSpaces | "Suppress Spaces"
DimSuffix | "Dimension Suffix"
DimTextBackground | "Text Background"
DimTextLocationForLeader | "Text Location"
DimToInserts | "Dimension To Openings"
DimToInsertType | "Dimension To Opening Type"
DimToIntersectingGrids | "Dimension To Intersecting Grids"
DimToIntersectingWalls | "Dimension To Intersecting Walls"
DimTotalLength | "Total Length"
DimValueAngle | "Value"
DimValueLength | "Value"
DimWitnsLineCntrl | "Witness Line Control"
DimWitnsLineExtensionBelow | "Witness Line Length"
Directcontext3dApplicationId | "ApplicationId"
Directcontext3dLoaded | "Loaded"
Directcontext3dName | "Name"
Directcontext3dServerId | "ServerId"
Directcontext3dSourceId | "Path"
DisplacedElementDisplacementX | "X Displacement"
DisplacedElementDisplacementY | "Y Displacement"
DisplacedElementDisplacementZ | "Z Displacement"
DisplacementPathDepth | "Depth"
DisplacementPathStyle | "Style"
DistanceToCutMark | "Distance to Cut Mark"
DividedpathBeginningIndent | "Beginning Indent"
DividedpathDisplayNodeNumbers | "Show Node Numbers"
DividedpathDisplayNodes | "Display Nodes"
DividedpathDisplayReferenceCurves | "Display Path"
DividedpathDistance | "Distance"
DividedpathEndIndent | "End Indent"
DividedpathFlipDirection | "Flip Direction"
DividedpathJustification | "Justification"
DividedpathLayout | "Layout"
DividedpathLayoutFixedNumPoint | "Number"
DividedpathMaxDistance | "Maximum Distance"
DividedpathMeasurementType | "Measurement Type"
DividedpathMergedPointNum | "Total Number of Nodes"
DividedpathMinDistance | "Minimum Distance"
DividedpathTotalPathLength | "Path Length"
DividedSurfaceAllGridRotation | "All Grid Rotation"
DividedSurfaceAllPoints | "Show all points"
DividedSurfaceComponentTrimType | "Component Trim"
DividedSurfaceCoverFaceCompletely | "Cover face completely"
DividedSurfaceDisplayComponents | "Components"
DividedSurfaceDisplayDiscardeddivisionlines | "Discarded Division Lines"
DividedSurfaceDisplayGridlines | "Gridlines"
DividedSurfaceDisplayNodes | "Nodes"
DividedSurfaceDisplayOriginalSurface | "Surface"
DividedSurfaceDisplayPatternFill | "Pattern Fill"
DividedSurfaceDisplayPatternLines | "Pattern Lines"
DividedSurfaceDisplaySurfaceOption | "Display Surface Option"
DividedSurfaceEdgeNumber | "Edge number"
DividedSurfaceFacetNumber | "Facet number"
DividedSurfaceGridlinesStyle | "Gridlines Style"
DividedSurfaceGridOptionParamn1 | "Option 1"
DividedSurfaceGridOptionParamn2 | "Option 2"
DividedSurfaceOffsetFromSurface | "Offset from surface"
DividedSurfaceOriginalSurfaceMaterial | "Surface Material"
DividedSurfacePattern | "Tile Pattern"
DividedSurfacePatternFillMaterial | "Pattern Fill Material"
DividedSurfacePatternFlip | "Component Flip"
DividedSurfacePatternIndentn1 | "Indent 1"
DividedSurfacePatternIndentn2 | "Indent 2"
DividedSurfacePatternLinesStyle | "Pattern Lines Style"
DividedSurfacePatternMirror | "Component Mirror"
DividedSurfacePatternRotationAngle | "Component Rotation"
DividedSurfacePointNumber | "Point number"
DividedSurfaceRule1Suspension | "Is grid 1 suspended?"
DividedSurfaceRule2Suspension | "Is grid 2 suspended?"
DividedSurfaceSurfaceArea | "Divided Surface Area"
DividedSurfaceTileBorder | "Border Tile"
DividedSurfaceTotalEdgeLength | "Total edge length"
DivisionPattern | "Division Pattern"
DivisionProfileWidth | "Width": Width
DivisionRuleParam | "Division Rule"
DivisionSketchCurveDivisionParamsOverrideParam | "Profile Override"
DivisionSketchCurveExtentdToSilhParam | "Extend to Silhouette"
DoorConstructionType | "Construction Type"
DoorCost | "Cost"
DoorEvacuationExitType | "Exit Access"
DoorFinish | "Finish"
DoorFrameMaterial | "Frame Material"
DoorFrameType | "Frame Type"
DoorNumber | "Mark"
DoorOperationType | "Operation"
DpartAreaComputed | "Area"
DpartBaseLevel | "Base Level"
DpartBaseLevelByOriginal | "Base Level By Original"
DpartCanHostRebar | "Can host rebar"
DpartExcluded | "Excluded"
DpartHeightComputed | "Height"
DpartLayerConstruction | "Construction"
DpartLayerFunction | "Layer Function"
DpartLayerIndex | "Layer Index"
DpartLayerWidth | "Thickness"
DpartLengthComputed | "Length"
DpartMaterialByOriginal | "Material By Original"
DpartMaterialIdParam | "Material"
DpartOriginalCategory | "Original Category"
DpartOriginalCategoryId | "Original Category"
DpartOriginalFamily | "Original Family"
DpartOriginalType | "Original Type"
DpartPhaseCreatedByOriginal | "Phase Created By Original"
DpartPhaseDemolishedByOriginal | "Phase Demolished By Original"
DpartShapeModified | "Shape is modified"
DpartVolumeComputed | "Volume"
DrawForEachRun | "Draw for Each Run"
DuctRoughness | "Roughness"
DuctTerminalEngagementLength | "Engagement Length"
EdgeLinework | "Line Style"
EditedBy | "Edited by"
ElecticalEquipVoltage | "Voltage"
ElecticalEquipWattage | "Wattage"
ElemCategoryParam | "Category"
ElemCategoryParamMt | "Category"
ElemDeletableInFamily | "Deletable"
ElementIsCutting | "Solid/Void"
ElementLockedParam | "Locked"
ElemFamilyAndTypeParam | "Family and Type"
ElemFamilyParam | "Family"
ElemIsReference | "Reference"
ElemPartitionParam | "Workset"
ElemReferenceName | "Is Reference"
ElemReferenceName2dXz | "Is Reference"
ElemRoomId | "Room Id"
ElemRoomName | "Room Name"
ElemRoomNumber | "Room Number"
ElemTypeLabel | "Label"
ElemTypeParam | "Type"
ElevArrowAngle | "Arrow Angle"
ElevArrowFilled | "Filled"
ElevAssocDatum | "Associated Datum"
ElevatnTag | "Elevation Tag"
ElevReferenceLabelPos | "Reference Label Position"
ElevShape | "Shape"
ElevShowViewName | "Show View Name"
ElevSymbolId | "Elevation Mark"
ElevTextPos | "Text Position"
ElevViewNamePos | "View Name Position"
ElevWidth | "Width"
EllipseFocusMrkVisible | "Focus Marks Visible"
EllipseXParam | "X-Radius Value for Ellipse (for Use with XAML Data Template example)"
EllipseYParam | "Y-Radius Value for Ellipse (for Use with XAML Data Template example)"
EndExtension | "End Extension"
EndJoinCutback | "End Join Cutback"
EndTreatment | "End Treatment"
EndYJustification | "End y Justification"
EndYOffsetValue | "End y Offset Value"
EndZJustification | "End z Justification"
EndZOffsetValue | "End z Offset Value"
EnergyAnalysisAdvancedOptions | "Other Options"
EnergyAnalysisBuildingOperatingSchedule | "Building Operating Schedule"
EnergyAnalysisConceptualConstruction | "Conceptual Types"
EnergyAnalysisCreateAnalyticalModel | "Create Energy Model"
EnergyAnalysisCurrentViewOnly | "Use Only Elements Visible In Current View"
EnergyAnalysisGlazingIsShaded | "Glazing is Shaded"
EnergyAnalysisHorizontalVoidThreshold | "Horizontal Void/Chase Area Threshold"
EnergyAnalysisHvacSystem | "HVAC System"
EnergyAnalysisMasszoneCoreoffset | "Perimeter Zone Depth"
EnergyAnalysisMasszoneDivideperimeter | "Perimeter Zone Division"
EnergyAnalysisMasszoneUseenergydatasettings | "Use Energy Data"
EnergyAnalysisMassZoning | "Mass Zoning"
EnergyAnalysisOutdoorAirInformationParam | "Outdoor Air Information"
EnergyAnalysisPercentageGlazing | "Target Percentage Glazing"
EnergyAnalysisPercentageSkylights | "Target Percentage Skylights"
EnergyAnalysisProjectPhase | "Phase"
EnergyAnalysisShadeDepth | "Shade Depth"
EnergyAnalysisSillHeight | "Target Sill Height"
EnergyAnalysisSkylightWidth | "Skylight Width & Depth"
EnergyAnalysisSpaceBoundingParam | "Analytical Space Bounding"
EnergyAnalysisVerticalVoidThreshold | "Average Vertical Void Height Threshold"
EqualityFormula | "Equality Formula"
EqualityTextForAngularDim | "Equality Text"
EqualityTextForContinuousLinearDim | "Equality Text"
EqualityWitnessDisplay | "Equality Witness Display"
ExchangeEntityId | "Exchange Entity ID"
ExchangeId | "Exchange ID"
ExtrusionAutoParams | "Auto ends"
ExtrusionEndParam | "Extrusion End"
ExtrusionLength | "Depth"
ExtrusionStartParam | "Extrusion Start"
FabricationBottomElevationIncludeInsulationOfPart | "Bottom Elevation with Insulation"
FabricationBottomElevationOfPart | "Bottom Elevation"
FabricationBottomOfPart | "Lower End Bottom of Insulation Elevation"
FabricationBranchSize | "Size of Primary Branch End"
FabricationChangeServiceParam | "Change Service"
FabricationDoublewallMaterialAbbreviation | "Double Wall Material Abbreviation"
FabricationDuctworkStiffenerSpec | "Stiffener Specification"
FabricationEndOffsetParam | "End Middle Elevation"
FabricationEndSize | "Size of Connector End"
FabricationFittingDescription | "Fabrication Fitting Description"
FabricationInsulationAbbreviation | "Insulation Abbreviation"
FabricationInsulationMaterialFinish | "Insulation Material"
FabricationInsulationSpec | "Insulation Specification"
FabricationInsulationSpecificationAbbreviation | "Insulation Specification Abbreviation"
FabricationLevelParam | "Reference Level"
FabricationMaterialAbbreviation | "Material Abbreviation"
FabricationOffsetParam | "Middle Elevation"
FabricationPartAlias | "Alias"
FabricationPartAngle | "Angle"
FabricationPartAngleOption | "Angle Option"
FabricationPartBoughtOut | "Bought Out"
FabricationPartCutType | "Cut Type"
FabricationPartDepthIn | "Main Primary Depth"
FabricationPartDepthInOption | "Main Primary Depth Option"
FabricationPartDepthOut | "Main Secondary Depth"
FabricationPartDepthOutOption | "Main Secondary Depth Option"
FabricationPartDiameterIn | "Main Primary Diameter"
FabricationPartDiameterInOption | "Main Primary Diameter Option"
FabricationPartDiameterOut | "Main Secondary Diameter"
FabricationPartDiameterOutOption | "Main Secondary Diameter Option"
FabricationPartDoublewallMaterial | "Double Wall Material"
FabricationPartDoublewallMaterialArea | "Double Wall Material Area"
FabricationPartDoublewallMaterialThickness | "Double Wall Material Thickness"
FabricationPartInsulationArea | "Insulation Area"
FabricationPartItemNumber | "Item Number"
FabricationPartLength | "Length"
FabricationPartLengthOption | "Length Option"
FabricationPartLiningArea | "Lining Area"
FabricationPartMaterial | "Part Material"
FabricationPartMaterialThickness | "Part Material Thickness"
FabricationPartNotes | "Fabrication Notes"
FabricationPartPatNo | "Part Pattern Number"
FabricationPartSheetmetalArea | "Part Sheet Metal Area"
FabricationPartTakeoffDialogParam | "More Parameters"
FabricationPartWeight | "Weight"
FabricationPartWidthIn | "Main Primary Width"
FabricationPartWidthInOption | "Main Primary Width Option"
FabricationPartWidthOut | "Main Secondary Width"
FabricationPartWidthOutOption | "Main Secondary Width Option"
FabricationPipeInvertElevation | "Pipe Invert Elevation": This parameter is obsolete. It exists only for compatibility.
FabricationPrimarySize | "Size of Primary End"
FabricationProductCode | "Product Code"
FabricationProductDataFinishDescription | "Product Finish Description"
FabricationProductDataInstallType | "Install Type"
FabricationProductDataItemDescription | "Product Short Description"
FabricationProductDataLongDescription | "Product Long Description"
FabricationProductDataMaterialDescription | "Product Material Description"
FabricationProductDataOem | "OEM"
FabricationProductDataProduct | "Product Name"
FabricationProductDataRange | "Product Range"
FabricationProductDataSizeDescription | "Product Size Description"
FabricationProductDataSpecification | "Product Specification Description"
FabricationProductEntry | "Product Entry"
FabricationRelativeFilename | "Relative File Name"
FabricationRoutingSolutionsUiParam | "x of XX"
FabricationSecondarySize | "Size of Secondary End"
FabricationServiceAbbreviation | "Fabrication Service Abbreviation"
FabricationServiceName | "Fabrication Service Name"
FabricationServiceParam | "Fabrication Service"
FabricationSetUpDownTag | "SU/SD from Top"
FabricationSetUpDownTagFromBottom | "SU/SD from Bottom"
FabricationSlopeParam | "Slope"
FabricationSpecification | "Specification"
FabricationSpecificationAbbreviation | "Specification Abbreviation"
FabricationStartOffsetParam | "Start Middle Elevation"
FabricationTopElevationIncludeInsulationOfPart | "Top Elevation with Insulation"
FabricationTopElevationOfPart | "Top Elevation"
FabricationTopOfPart | "Upper End Top of Insulation Elevation"
FabricationVendor | "Vendor"
FabricationVendorCode | "Vendor Code"
FabricBendDiameter | "Bend Diameter": Standard Bend Diameter of Fabric Wire.
FabricNumber | "Fabric Number"
FabricParamCoverOffset | "Additional Cover Offset": Additional cover offset of the fabric distribution.
FabricParamCutByHost | "Cut by Host Cover": Single Fabric Sheet is cut or not cut by the Host Cover.
FabricParamCutOverallLength | "Cut Overall Length": Provides a real sheet Length after definition
FabricParamCutOverallWidth | "Cut Overall Width": Provides a real sheet Width after definition
FabricParamCutSheetMass | "Cut Sheet Mass": Calculated cut sheet mass [Sheet Mass per Unit Area * (Cut Overall Length * Cut Overall Width)]
FabricParamLapsplicePosition | "Lap Splice Position": Fabric lap splice position in the fabric distribution
FabricParamLocationGeneric | "Location": Fabric location in the host.
FabricParamLocationSlab | "Location": Fabric location in the slab
FabricParamLocationWall | "Location": Fabric location in the wall
FabricParamMajorLapspliceLength | "Major Lap Splice Length": Fabric lap splice length in major direction in the fabric distribution.
FabricParamMinorLapspliceLength | "Minor Lap Splice Length": Fabric lap splice length in minor direction in the fabric distribution.
FabricParamRounding | "Rounding Overrides"
FabricParamSharedFamilyKey | "Shared family key"
FabricParamSheetType | "Fabric Sheet": List all Fabric Sheet types
FabricParamSpanSymBottom | "Bottom"
FabricParamSpanSymDBottom | "D_Bottom"
FabricParamSpanSymDLeft | "D_Left"
FabricParamSpanSymDRight | "D_Right"
FabricParamSpanSymDTop | "D_Top"
FabricParamSpanSymLeft | "Left"
FabricParamSpanSymRight | "Right"
FabricParamSpanSymTop | "Top"
FabricParamSpanTagComponentReference | "Tag Component Reference"
FabricParamTagView | "Tag new members in view": List of all Plan Views and None.
FabricParamTotalSheetMass | "Total Sheet Mass": Calculated all sheet mass: Volume of Wire * Unit Weight.
FabricSheetDefaultMajorLapspliceLength | "Default Major Lap Splice Length": Default Major Lap Splice Length
FabricSheetDefaultMinorLapspliceLength | "Default Minor Lap Splice Length": Default Minor Lap Splice Length
FabricSheetLength | "Length": Length
FabricSheetMajorDirectionWireType | "Major Direction Wire Type": Major Direction Wire Type
FabricSheetMajorEndOverhang | "Major End Overhang": Major End Overhang
FabricSheetMajorLayoutPattern | "Major Layout Pattern": Major Layout Pattern
FabricSheetMajorNumberOfWires | "Major Number of Wires": Major Number of Wires
FabricSheetMajorReinforcementArea | "Major Reinforcement Area": Major Reinforcement Area
FabricSheetMajorSpacing | "Major Spacing": Major Spacing
FabricSheetMajorStartOverhang | "Major Start Overhang": Major Start Overhang
FabricSheetMass | "Sheet Mass": Sheet Mass
FabricSheetMassunit | "Sheet Mass per Unit Area": Structural Sheet Mass per Unit Area [Sheet Mass / (Overall Length * Overall Width)]
FabricSheetMinorDirectionWireType | "Minor Direction Wire Type": Minor Direction Wire Type
FabricSheetMinorEndOverhang | "Minor End Overhang": Minor End Overhang
FabricSheetMinorLayoutPattern | "Minor Layout Pattern": Minor Layout Pattern
FabricSheetMinorNumberOfWires | "Minor Number of Wires": Minor Number of Wires
FabricSheetMinorReinforcementArea | "Minor Reinforcement Area": Minor Reinforcement Area
FabricSheetMinorSpacing | "Minor Spacing": Minor Spacing
FabricSheetMinorStartOverhang | "Minor Start Overhang": Minor Start Overhang
FabricSheetOverallLength | "Overall Length": Overall Length
FabricSheetOverallWidth | "Overall Width": Overall Width
FabricSheetPhysicalMaterialAsset | "Physical Material Asset": Physical Material Asset
FabricSheetWidth | "Width": Width
FabricWireDiameter | "Nominal Diameter": Nominal Diameter of Fabric Wire.
FabricWireDistance | "Wire distance": The distance between wires
FabricWireLength | "Wire length": The wire length
FabricWireOffset | "Offset along wire direction": Offset along wire direction
FabricWireType | "Wire type": The wire type assigned
FaceroofLevelParam | "Reference Level"
FaceroofOffsetParam | "Level Offset"
FamilyAllowCutWithVoids | "Cut with Voids When Loaded"
FamilyAlwaysVertical | "Always vertical"
FamilyAutojoin | "Automatically joins geometry to walls"
FamilyBaseLevelOffsetParam | "Base Offset"
FamilyBaseLevelParam | "Base Level"
FamilyCanHostRebar | "Can host rebar"
FamilyCategoryPseudoParam | "Category"
FamilyContentPartType | "Part Type"
FamilyCurveAttachmentProportion | "Attachment Point"
FamilyCurveGstyleFor2010Mass | "Subcategory"
FamilyCurveGstylePlusInvisible | "Subcategory"
FamilyCurveGstylePlusInvisibleMinusAnalytical | "Subcategory"
FamilyCurveGstylePlusInvisiblePlusStickSym | "Subcategory"
FamilyCurveGstylePlusInvisiblePlusStickSymMinusAnalytical | "Subcategory"
FamilyElectricalMaintainAnnotationOrientation | "Maintain Annotation Orientation"
FamilyElemSubcategory | "Subcategory"
FamilyEnableCuttingInViews | "Enable Cutting in Views"
FamilyExportAsGeometry | "Always export as geometry"
FamilyFreeinstDefaultElevation | "Default Elevation"
FamilyHeightParam | "Height"
FamilyHostingBehavior | "Host"
FamilyIsElevationMarkBody | "Elevation Mark Use"
FamilyIsParametric | "Is parametric"
FamilyKeepTextReadable | "Keep text readable"
FamilyKeyExtParam | "Filter Parameter"
FamilyKeywordProtected | "Content protection enabled"
FamilyLevelParam | "Level"
FamilyLineLengthParam | "Length"
FamilyNamePseudoParam | "Family"
FamilyRenderingType | "Render Appearance Source"
FamilyRfaPathPseudoParam | "File Path"
FamilyRotateTextWithComponent | "Rotate text with component"
FamilyRotateWithComponent | "Rotate with component"
FamilyRoughHeightParam | "Rough Height"
FamilyRoughWidthParam | "Rough Width"
FamilyRoundconnectorDimensiontype | "Round Connector Dimension"
FamilySelfOrienting | "Align to View"
FamilyShared | "Shared"
FamilyStructFootingUseCapTop | "Cap"
FamilyStructMaterialType | "Material for Model Behavior"
FamilySymbolicRep | "Symbolic Representation"
FamilyThicknessParam | "Thickness"
FamilyTopLevelOffsetParam | "Top Offset"
FamilyTopLevelParam | "Top Level"
FamilyUsagePseudoParam | "Usage"
FamilyUsePrecutShape | "Show family pre-cut in plan views"
FamilyWidthParam | "Width"
FamilyWindowInsetParam | "Inset"
FamilyWorkPlaneBased | "Work Plane-Based"
FamilyWpbDefaultElevation | "Default Elevation"
FamProfileDefinition | "Profile Definition"
FamProfileUsage | "Profile Usage"
FasciaDepthParam | "Fascia Depth"
FasciaMaterialParam | "Material"
FasciaProfileParam | "Profile"
FbxAssetType | "Light Source"
FbxLightAtADistance | "At a distance"
FbxLightBallastLoss | "Ballast Loss"
FbxLightColorFilter | "Color Filter"
FbxLightDimmingLightColor | "Dimming Lamp Color Temperature Shift"
FbxLightEfficacy | "Efficacy"
FbxLightEmitCircleDiameter | "Emit from Circle Diameter"
FbxLightEmitLineLength | "Emit from Line Length"
FbxLightEmitRectangleLength | "Emit from Rectangle Length"
FbxLightEmitRectangleWidth | "Emit from Rectangle Width"
FbxLightEmitShapeVisible | "Emit Shape Visible in Rendering"
FbxLightIlluminance | "Illuminance"
FbxLightInitialColorCtrl | "Initial Color"
FbxLightInitialColorName | "Temperature Color"
FbxLightInitialColorTemperature | "Initial Color Temperature"
FbxLightInitialIntensity | "Initial Intensity"
FbxLightInitialIntensityInputMethod | "Initial Light Intensity Input Method"
FbxLightLampLumenDepr | "Lamp Lumen Depreciation"
FbxLightLampTiltLoss | "Lamp Tilt Loss"
FbxLightLimunousFlux | "Luminous Flux"
FbxLightLimunousIntensity | "Luminous Intensity"
FbxLightLossFactorCtrl | "Light Loss Factor"
FbxLightLossFactorMethod | "Light Loss Input Method"
FbxLightLumenaireDirt | "Luminaire Dirt Depreciation"
FbxLightPhotometricFile | "Photometric Web File"
FbxLightPhotometricFileCache | "None"
FbxLightPhotometrics | "Light Source Definition"
FbxLightPhotometricsFam | "Light Source Definition (family)"
FbxLightSourceDiameter | "Light Source Symbol Size"
FbxLightSourceLength | "Light Source Symbol Length"
FbxLightSpotBeamAngle | "Spot Beam Angle"
FbxLightSpotFieldAngle | "Spot Field Angle"
FbxLightSpotTiltAngle | "Tilt Angle"
FbxLightSurfaceLoss | "Surface Depreciation Loss"
FbxLightTemperatureLoss | "Temperature Loss"
FbxLightTotalLightLoss | "Total Light Loss Factor"
FbxLightVoltageLoss | "Voltage Loss"
FbxLightWattage | "Wattage"
FilledRegionMasking | "Masking"
FillPatternIdParam | "Cut fill pattern"
FillPatternIdParamNoNo | "Fill Pattern"
FireRating | "Fire Rating"
FixedRotation | "Fixed Rotation"
FlexibleInstanceFlip | "Flip"
FloorAttrDefaultHeightParam | "Default Height above level"
FloorAttrDefaultThicknessParam | "Default Thickness"
FloorAttrThicknessParam | "Thickness"
FloorHeightabovelevelParam | "Height Offset From Level"
FloorParamIsStructural | "Structural"
FloorParamSpanDirection | "Span Direction"
FloorStructureIdParam | "Structure"
FollowSurface | "Follow Surface"
ForegroundAnyPatternIdParam | "Foreground Fill Pattern"
ForegroundDraftPatternIdParam | "Foreground Fill Pattern"
ForegroundPatternColorParam | "Foreground Pattern Color"
FramingLengthRoundoff | "Structural Framing Length Roundoff"
FramingShapeClassification | "Framing Shape"
FrictionFactor | "Friction Factor"
FunctionParam | "Function"
GbxmlEditDataParam | "Energy Settings"
GenericDepth | "Depth"
GenericZoneName | "Name"
GeoLocation | "Shared Site"
GeomVisibilityParam | "Visibility/Graphics Overrides"
GraphicDisplayOptions | "Graphic Display Options"
GraphicDisplayOptionsBackground | "Background"
GraphicDisplayOptionsFog | "Depth Cueing"
GraphicDisplayOptionsLighting | "Lighting"
GraphicDisplayOptionsModel | "Model Display"
GraphicDisplayOptionsPhotoExposure | "Photographic Exposure"
GraphicDisplayOptionsShadows | "Shadows"
GraphicDisplayOptionsSketchyLines | "Sketchy Lines"
GraphicDisplayOptionsSsIntensity | "Sun and Shadow Intensity"
GridBankColNum | "Column"
GridBankColWidth | "Column Distance"
GridBankRowHeight | "Row Distance"
GridBankRowNum | "Row"
GridBubbleEndn1 | "Plan View Symbols End 1 (Default)"
GridBubbleEndn2 | "Plan View Symbols End 2 (Default)"
GridBubbleLinePen | "Bubble Weight Number\n"
GridCenterSegmentColor | "Center Segment Color"
GridCenterSegmentPattern | "Center Segment Pattern"
GridCenterSegmentStyle | "Center Segment"
GridCenterSegmentWeight | "Center Segment Weight"
GridEndSegmentColor | "End Segment Color"
GridEndSegmentPattern | "End Segment Pattern"
GridEndSegmentsLength | "End Segments Length"
GridEndSegmentWeight | "End Segment Weight"
GridHeadTag | "Symbol"
GridlineSpecStatus | "Type Association"
GridNetLocationMark | "Location Mark": Provides grid system association information
GroupAllowedViewTypes | "Allowed View Types"
GroupAttachedParentName | "Attached to"
GroupLevel | "Reference Level"
GroupnameParam | "Group Name for Ribbon Combo Items (for Use with XAML)"
GroupOffsetFromLevel | "Origin Level Offset"
GuideGridNameParam | "Name"
GuideGridSpacingParam | "Guide Spacing"
GutterMaterialParam | "Material"
GutterProfileParam | "Profile"
HandrailHandClearanceParam | "Hand Clearance"
HandrailHeightParam | "Height"
HandrailProjectionParam | "Projection"
HandrailSupportsJustificationParam | "Justification"
HandrailSupportsLayoutParam | "Layout"
HandrailSupportsNumberParam | "Number"
HandrailSupportsSpacingParam | "Spacing"
HandrailSupportsTypeParam | "Family"
HeadOnPlacementMethod | "Draw in Foreground"
HeavyEndPen | "Heavy End Pen Weight"
HeavyTickMarkPen | "Heavy End Pen Weight"
HighestAssociatedLevel | "Highest Associated Level": The highest level associated with this Analytical Element.
HostAreaComputed | "Area"
HostIdParam | "Host Id"
HostPanelScheduleAsPanelParam | "Categorize as"
HostPerimeterComputed | "Perimeter"
HostSseCurvedEdgeConditionParam | "Curved Edge Condition"
HostVolumeComputed | "Volume"
IconIndexParam | "Index Into Image File Name Array (for Use with XAML)"
IdParam | "Id"
IfcApplicationName | "IfcApplicationName"
IfcApplicationVersion | "IfcApplicationVersion"
IfcBuildingGuid | "IfcBuilding GUID"
IfcExportElement | "Export to IFC"
IfcExportElementAs | "Export to IFC As"
IfcExportElementType | "Export Type to IFC"
IfcExportElementTypeAs | "Export Type to IFC As"
IfcExportPredefinedtype | "IFC Predefined Type"
IfcExportPredefinedtypeType | "Type IFC Predefined Type"
IfcGuid | "IfcGUID"
IfcOrganization | "IfcOrganization"
IfcProjectGuid | "IfcProject GUID"
IfcSiteGuid | "IfcSite GUID"
IfcTypeGuid | "Type IfcGUID"
ImportAdtComponentsDesc | "Component Description"
ImportAdtEntityHeight | "Height"
ImportAdtEntityLength | "Length"
ImportAdtEntityRoll | "Roll"
ImportAdtEntityStructType | "Structural Type Name"
ImportAdtEntityStyle | "Style Name"
ImportAdtEntityThickness | "Thickness"
ImportAdtEntityType | "Type Name"
ImportAdtEntityWidth | "Width"
ImportBackground | "Draw Layer"
ImportBaseLevel | "Work Plane"
ImportBaseLevelOffset | "Offset from Work Plane"
ImportDisplayUnits | "Import Units"
ImportInstanceCuttingInView | "Enable Cutting in Views"
ImportInstanceScale | "Instance Scale"
ImportScale | "Scale Factor"
ImportSymbolName | "Name"
InfrastructureAlignmentDescription | "Description"
InfrastructureAlignmentDisplayedEndStation | "Displayed End Station"
InfrastructureAlignmentDisplayedStartStation | "Displayed Start Station"
InfrastructureAlignmentName | "Name"
InsertOrientation | "Orientation"
InstanceElevationParam | "Elevation from Level"
InstanceFreeHostOffsetParam | "Offset from Host"
InstanceFreeHostParam | "Host"
InstanceHeadHeightParam | "Head Height"
InstanceLengthParam | "Length"
InstanceMoveBaseWithGrids | "Move Base With Grids"
InstanceMovesWithGridParam | "Moves With Grids"
InstanceMoveTopWithGrids | "Move Top With Grids"
InstanceOffsetPosParam | "Moves With Nearby Elements"
InstanceReferenceLevelParam | "Reference Level"
InstanceScheduleOnlyLevelParam | "Schedule Level"
InstanceSillHeightParam | "Sill Height"
InstanceStructUsageParam | "Structural Usage"
InsulationScale | "Insulation Bulge to Width Ratio (1/x)"
InsulationWidth | "Insulation Width"
InteriorTickDisplay | "Interior Tick Mark Display"
IsVisibleParam | "Visible"
JoinStrengthOrder | "Abstract Join Strength Order"
JoistSystemClearSpacingParam | "Clear Spacing"
JoistSystemElemTagNewMembersView | "Tag new members in view"
JoistSystemFixedSpacingParam | "Fixed Spacing"
JoistSystemJustificationParam | "Justification"
JoistSystemLayoutRuleParam | "Layout Rule"
JoistSystemMaximumSpacingParam | "Maximum Spacing"
JoistSystemNewBeamTypeNoFamNameParam | "Beam Type (No Family Name)"
JoistSystemNewBeamTypeParam | "Beam Type"
JoistSystemNumBeamsSameType | "Num. of Beams With Same Type"
JoistSystemNumberOfLinesParam | "Number of Lines"
JoistSystemSpacingParam | "Centerline Spacing"
KeepReadable | "Keep Readable"
KeynoteNumber | "Key Value"
KeynoteParam | "Keynote"
KeynoteText | "Keynote Text"
KeySourceParam | "Key Source"
KeyValue | "Key Value"
LayerElemAreaComputed | "Area"
LayerElemBaseConstraint | "Base Constraint"
LayerElemBaseExtensionDis | "Base Extension Distance"
LayerElemCompoundElemFamily | "Compound Element Family"
LayerElemCompoundElemType | "Compound Element Type"
LayerElemFunction | "Function": Function
LayerElemIsCoreLayer | "Is Core Layer"
LayerElemIsStructuralMaterial | "Is Structural Material"
LayerElemIsVariable | "Is Variable"
LayerElemMaterials | "Material": Material
LayerElemOffsetFromHost | "Offset From Host"
LayerElemScheduleFamily | "Family"
LayerElemThickness | "Thickness": Thickness
LayerElemTopConstraint | "Top Constraint"
LayerElemTopExtensionDis | "Top Extension Distance"
LayerElemVolumeComputed | "Volume"
LayerTypeMaterials | "Material": Material
LayerTypeThickness | "Thickness": Thickness
LayoutnodeCurvetypeParam | "Curve Type Reference"
LeaderArrowhead | "Leader Arrowhead"
LeaderArrowWidth | "Arrow Width Angle"
LeaderLeftAttachment | "Left Attachment"
LeaderLine | "Leader Line"
LeaderOffsetSheet | "Leader/Border Offset"
LeaderRightAttachment | "Right Attachment"
LegendComponent | "Component Type"
LegendComponentDetailLevel | "Detail Level"
LegendComponentLength | "Host Length"
LegendComponentView | "View Direction"
LevelAttrRoomComputationAutomatic | "Automatic Room Computation Height"
LevelAttrRoomComputationHeight | "Computation Height"
LevelDataFloorArea | "Floor Area"
LevelDataFloorPerimeter | "Floor Perimeter"
LevelDataMassFamilyAndTypeParam | "Mass: Family and Type"
LevelDataMassFamilyParam | "Mass: Family"
LevelDataMassInstanceComments | "Mass: Comments"
LevelDataMassTypeComments | "Mass: Type Comments"
LevelDataMassTypeDescription | "Mass: Description"
LevelDataMassTypeParam | "Mass: Type"
LevelDataOwningLevel | "Level"
LevelDataSpaceUsage | "Usage"
LevelDataSurfaceArea | "Exterior Surface Area"
LevelDataVolume | "Floor Volume"
LevelElev | "Elevation"
LevelHeadTag | "Symbol"
LevelIsBuildingStory | "Building Story"
LevelIsGroundPlane | "Is ground plane"
LevelIsStructural | "Structural"
LevelName | "Level"
LevelParam | "Level"
LevelRelativeBaseType | "Elevation Base"
LevelRoomComputationHeight | "Computation Height"
LevelUpToLevel | "Story Above"
LightingFixtureLamp | "Lamp"
LightingFixtureLightEmitter | "Light Emitter"
LightingFixtureWattage | "Wattage Comments"
LinearDimType | "Dimension String Type"
LinearFramingLength | "Length"
LineColor | "Color"
LinePattern | "Line Pattern"
LinePen | "Line Weight"
LineShapeAtCorner | "Line Shape at Landing Corner"
LoadAllNon0Loads | "All non 0 loads"
LoadAreaArea | "Area"
LoadAreaForceFx1 | "Fx 1"
LoadAreaForceFx2 | "Fx 2"
LoadAreaForceFx3 | "Fx 3"
LoadAreaForceFy1 | "Fy 1"
LoadAreaForceFy2 | "Fy 2"
LoadAreaForceFy3 | "Fy 3"
LoadAreaForceFz1 | "Fz 1"
LoadAreaForceFz2 | "Fz 2"
LoadAreaForceFz3 | "Fz 3"
LoadAreaIsProjected | "Projected Load"
LoadArrowSeparation | "Distance between arrows"
LoadAttrAreaForceScaleFactor | "Area force scale"
LoadAttrForceArrowType | "Force arrowhead"
LoadAttrForceScaleFactor | "Force scale"
LoadAttrLinearForceScaleFactor | "Linear force scale"
LoadAttrMomentArrowArc | "Moment arrowhead"
LoadAttrMomentArrowLine | "Moment arrowhead (alternate)"
LoadAttrMomentScaleFactor | "Moment scale"
LoadCaseId | "Load Case"
LoadCaseName | "Name"
LoadCaseNature | "Nature"
LoadCaseNatureText | "Nature"
LoadCaseNumber | "Case Number"
LoadCaseSubcategory | "Category"
LoadCombinationFactor | "Factor"
LoadCombinationName | "Name"
LoadComments | "Comments"
LoadDescription | "Description"
LoadForceFx | "Fx"
LoadForceFy | "Fy"
LoadForceFz | "Fz"
LoadIsConstrainedOnHost | "Is constrained on host"
LoadIsHosted | "Is Hosted"
LoadIsProjected | "Projected Load"
LoadIsReaction | "Is Reaction"
LoadIsUniform | "Uniform Load"
LoadLinearForceFx1 | "Fx 1"
LoadLinearForceFx2 | "Fx 2"
LoadLinearForceFy1 | "Fy 1"
LoadLinearForceFy2 | "Fy 2"
LoadLinearForceFz1 | "Fz 1"
LoadLinearForceFz2 | "Fz 2"
LoadLinearLength | "Length"
LoadMomentMx | "Mx"
LoadMomentMx1 | "Mx 1"
LoadMomentMx2 | "Mx 2"
LoadMomentMy | "My"
LoadMomentMy1 | "My 1"
LoadMomentMy2 | "My 2"
LoadMomentMz | "Mz"
LoadMomentMz1 | "Mz 1"
LoadMomentMz2 | "Mz 2"
LoadNatureName | "Name"
LoadUsageName | "Name"
LoadUseLocalCoordinateSystem | "Orient to"
LockAlignmentUiToggle | "Lock": This is used by the UI to allow selection of lock alignment.
LockedBaseOffset | "Negative Offset"
LockedEndOffset | "Positive Offset"
LockedStartOffset | "Negative Offset"
LockedTopOffset | "Positive Offset"
LowestAssociatedLevel | "Lowest Associated Level": The lowest level associated with this Analytical Element.
LvMullionLeg1 | "Leg 1"
LvMullionLeg2 | "Leg 2"
MarkupsCreated | "Created"
MarkupsCreator | "Creator"
MarkupsHistory | "History"
MarkupsLabel | "Label"
MarkupsModified | "Modified"
MarkupsNotes | "Notes"
MarkupsPrivate | "Private"
MarkupsStatus | "Status"
MassDataConceptualConstruction | "Conceptual Types"
MassDataGlazingIsShaded | "Glazing is Shaded"
MassDataMassExteriorWallArea | "Mass Exterior Wall Area"
MassDataMassInteriorWallArea | "Mass Interior Wall Area"
MassDataMassOpeningArea | "Mass Opening Area"
MassDataMassRoofArea | "Mass Roof Area"
MassDataMassSkylightArea | "Mass Skylight Area"
MassDataMassWindowArea | "Mass Window Area"
MassDataPercentageGlazing | "Target Percentage Glazing"
MassDataPercentageSkylights | "Target Percentage Skylights"
MassDataShadeDepth | "Shade Depth"
MassDataSillHeight | "Target Sill Height"
MassDataSkylightWidth | "Skylight Width & Depth"
MassDataSlab | "Slab"
MassDataSubcategory | "Subcategory"
MassDataSurfaceDataSource | "Values"
MassDataUnderground | "Underground"
MassFloorAreaLevels | "Mass Floors"
MassGrossArea | "Gross Floor Area"
MassGrossSurfaceArea | "Gross Surface Area"
MassGrossVolume | "Gross Volume"
MassingIntegrationLevel | "Constrain to Massing"
MassSurfacedataMaterial | "Graphical Appearance"
MassZoneConditionTypeParam | "Condition Type"
MassZoneFloorArea | "Mass Floor Area"
MassZoneMaterial | "Graphical Appearance"
MassZoneSpaceTypeParam | "Space Type"
MassZoneVolume | "Mass Zone Volume"
MatchlineBottomOffset | "Bottom Offset"
MatchlineBottomPlane | "Bottom Constraint"
MatchlineTopOffset | "Top Offset"
MatchlineTopPlane | "Top Constraint"
MaterialArea | "Area"
MaterialAspaint | "As Paint"
MaterialAssetParamAssetLibId | "Asset library id"
MaterialAssetParamCommonSharedAsset | "Sharing"
MaterialAssetParamExternalMaterialId | "External Material ID"
MaterialAssetParamSource | "Source"
MaterialAssetParamSourceUrl | "Source URL"
MaterialIdParam | "Material"
MaterialName | "Name"
MaterialParamColor | "Color"
MaterialParamGlow | "Glow"
MaterialParamShininess | "Shininess"
MaterialParamSmoothness | "Smoothness"
MaterialParamTransparency | "Transparency"
MaterialVolume | "Volume"
MeasureFromStructure | "Extend into wall (to core)"
MechanicalEquipmentSetIdParam | "Mechanical Equipment Set"
MechanicalEquipmentSetName | "Name"
MechanicalEquipmentSetOnDuty | "On Duty"
MechanicalEquipmentSetOnStandby | "On Standby"
MepAirloopFantype | "Fan"
MepAirloopHeatexchangerType | "Heat Exchanger"
MepAirloopPreheatCoiltype | "Preheat Coil"
MepAnalyticalCriticalpathParam | "Critical Path"
MepAnalyticalElecCurrent | "Current"
MepAnalyticalElecCurrentRating | "Current Rating"
MepAnalyticalElecVoltage | "Voltage"
MepAnalyticalEquipmentName | "Name"
MepAnalyticalLoopBoundaryParam | "Loop Boundary"
MepAnalyticalLoopName | "Name"
MepAnalyticalPipeDesignflow | "Design Flow"
MepChilledWaterLoop | "Chilled Water Loop"
MepCondenserWaterLoop | "Condenser Water Loop"
MepCoolingCoilType | "Cooling Coil"
MepElecZoneEquipmentType | "Equipment Type"
MepEquipmentCalcPipingflowParam | "Calculated Flow"
MepEquipmentCalcPipingpressuredropParam | "Calculated Pressure Drop"
MepEquipmentClassification | "Classification"
MepHeatingCoilType | "Heating Coil"
MepHeatingHotwaterLoop | "Heating Hot Water Loop"
MepIgnoreFlowAnalysis | "Ignore Flow Analysis"
MepLowerBottomElevation | "Lower End Bottom Elevation"
MepLowerBottomElevationIncludeInsulation | "Lower End Bottom of Insulation Elevation"
MepLowerCenterlineElevation | "Lower End Centerline Elevation"
MepLowerTopElevation | "Lower End Top Elevation"
MepLowerTopElevationIncludeInsulation | "Lower End Top of Insulation Elevation"
MepPipeLowerInvertElevation | "Lower End Invert Elevation"
MepPipeLowerObvertElevation | "Lower End Obvert Elevation"
MepPipeUpperInvertElevation | "Upper End Invert Elevation"
MepPipeUpperObvertElevation | "Upper End Obvert Elevation"
MepPreheatHotwaterLoop | "Preheat Hot Water Loop"
MepProfileTypeParam | "Shape"
MepReheatCoilType | "Reheat Coil"
MepReheatHotwaterLoop | "Reheat Hot Water Loop"
MepSpotBottomElevation | "Spot Bottom Elevation": used for both design and fabrication components
MepSpotBottomElevationIncludeInsulation | "Spot Bottom of Insulation Elevation"
MepSpotCenterlineElevation | "Spot Centerline Elevation": used for both design and fabrication components
MepSpotTopElevation | "Spot Top Elevation": used for both design and fabrication components
MepSpotTopElevationIncludeInsulation | "Spot Top of Insulation Elevation"
MepSystemFillGraphicsOverridesParam | "Fill Pattern Graphics Overrides"
MepSystemLineGraphicsOverridesParam | "Graphic Overrides"
MepUpperBottomElevation | "Upper End Bottom Elevation"
MepUpperBottomElevationIncludeInsulation | "Upper End Bottom of Insulation Elevation"
MepUpperCenterlineElevation | "Upper End Centerline Elevation"
MepUpperTopElevation | "Upper End Top Elevation"
MepUpperTopElevationIncludeInsulation | "Upper End Top of Insulation Elevation"
MepVrfLoop | "Variable Refrigerant Flow Loop"
MepWaterloopChillertype | "Chiller Type"
MepWaterloopType | "Loop Type"
MepZoneAirLoop | "Air System"
MepZoneEquipment | "Zone Equipment"
MepZoneEquipmentBehavior | "Behavior"
MepZoneEquipmentDrawVentilation | "Draw Ventilation"
MepZoneEquipmentType | "Equipment Type"
MepZoneHotwaterLoop | "Heating Hot Water Loop"
ModelCategoryIdParam | "Subcategory"
ModelGraphicsStyle | "Visual Style"
ModelGraphicsStyleAnonDraft | "Visual Style"
ModelOrSymbolic | "Model or Symbolic"
ModelTextSize | "Text Size"
MovesWithGridParam | "Moves With Grids": Disable attachment from grids.
MullionAngle | "Angle"
MullionCornerType | "Corner Mullion"
MullionDepth | "Depth"
MullionDepth1 | "Depth 1"
MullionDepth2 | "Depth 2"
MullionFamType | "Mullion Family General Shape"
MullionOffset | "Offset"
MullionPosition | "Position"
MullionProfile | "Profile"
MultipleAlignmentUiToggle | "Multiple Alignment": This is used by the UI to allow selection of multiple elements.
MultiReferenceAnnotationDimensionStyle | "Dimension Style"
MultiReferenceAnnotationGroupTagHeads | "Group Matching Tag Heads"
MultiReferenceAnnotationReferenceCategory | "Reference Category"
MultiReferenceAnnotationShowDimensionText | "Show Dimension Text"
MultiReferenceAnnotationTagType | "Tag Family"
MultistoryStairsActualTreadDepth | "Actual Tread Depth"
MultistoryStairsRefLevel | "Reference Level": The reference level of stairs
NodeConnectionStatus | "Connection Status"
NumberPartitionParam | "Partition"
NumberSystemDisplayRule | "Display Rule"
NumberSystemJustify | "Justify"
NumberSystemJustifyOffset | "Justify Offset"
NumberSystemOrientation | "Orientation"
NumberSystemReference | "Reference"
NumberSystemReferenceOffset | "Offset from Reference"
NumberSystemTagType | "Tag Type"
NumberSystemTextSize | "Number Size"
ObjectStyleMaterialIdParam | "Object Style Material"
OffsetfacesShowShapeHandles | "Show Shape Handles"
OffsetFromReferenceBase | "Offset from Reference Base"
OmniclassCode | "OmniClass Number"
OmniclassDescription | "OmniClass Title"
OptionName | "Name"
OptionSetId | "Design Option Set Id"
OptionSetName | "Name"
OrdinateDimSetting | "Ordinate Dimension Settings"
OrientByView | "Rotate With Text"
OriginatingElementName | "Originating Element"
OvalFramingHeight | "Oval Height"
OvalFramingWidth | "Oval Width"
PaddingLength | "Padding"
PanelScheduleName | "Panel Schedule Name"
PartMakerDivisionProfileOffset | "Profile Offset"
PartmakerParamDivisionGap | "Gap"
PartMakerSplitterProfile | "Division Profile"
PartMakerSplitterProfileEdgeMatch | "Edge Match"
PartMakerSplitterProfileFlipAcross | "Profile Across Flip"
PartMakerSplitterProfileFlipAlong | "Profile Along Flip"
PathOfTravelFromRoom | "From Room"
PathOfTravelLevelName | "Level"
PathOfTravelSpeed | "Speed"
PathOfTravelTime | "Time"
PathOfTravelToRoom | "To Room"
PathOfTravelViewName | "View Name"
PathReinAddlOffset | "Additional Offset"
PathReinAlternating | "Alternating Bars"
PathReinAltOffset | "Alternating Bar - Offset"
PathReinEndHookOrient1Slab | "Primary Bar - End Hook Orientation"
PathReinEndHookOrient1Wall | "Primary Bar - End Hook Orientation"
PathReinEndHookOrient2Slab | "Alternating Bar - End Hook Orientation"
PathReinEndHookOrient2Wall | "Alternating Bar - End Hook Orientation"
PathReinEndHookTypen1 | "Primary Bar - End Hook Type"
PathReinEndHookTypen2 | "Alternating Bar - End Hook Type"
PathReinEndSpanhookAlt | "End Hook Angle Alternating"
PathReinEndSpanhookPrim | "End Hook Angle Primary"
PathReinFaceSlab | "Face"
PathReinFaceWall | "Face"
PathReinHookOrient1Slab | "Primary Bar - Hook Orientation"
PathReinHookOrient1Wall | "Primary Bar - Hook Orientation"
PathReinHookOrient2Slab | "Alternating Bar - Hook Orientation"
PathReinHookOrient2Wall | "Alternating Bar - Hook Orientation"
PathReinHookTypen1 | "Primary Bar - Start Hook Type"
PathReinHookTypen2 | "Alternating Bar - Start Hook Type"
PathReinLengthn1 | "Primary Bar - Length"
PathReinLengthn2 | "Alternating Bar - Length"
PathReinNumberOfBars | "Number Of Bars"
PathReinShapen1 | "Primary Bar - Shape"
PathReinShapen2 | "Alternating Bar - Shape"
PathReinSpacing | "Bar Spacing"
PathReinSpanhookAlt | "Start Hook Angle Alternating"
PathReinSpanhookPrim | "Start Hook Angle Primary"
PathReinSpanlengthAltOffset | "Offset"
PathReinSpanlengthBarlengthAlt | "Length (Alternating Bar)"
PathReinSpanlengthBarlengthPrim | "Length (Primary Bar)"
PathReinSpanlengthBottomAlt | "Bottom (Alternating Bar)"
PathReinSpanlengthBottomPrim | "Bottom (Primary Bar)"
PathReinSpanlengthTopAlt | "Top (Alternating Bar)"
PathReinSummary | "Summary"
PathReinTypen1 | "Primary Bar - Type"
PathReinTypen2 | "Alternating Bar - Type"
PatternIndent1ForDivisionRule | "Indent 1"
PatternIndent2ForDivisionRule | "Indent 2"
PatternMirrorForDivisionRule | "Mirror"
PeakAirflowParam | "Peak Airflow"
PeakCoolingLoadParam | "Peak Cooling Load"
PeakHeatingLoadParam | "Peak Heating Load"
PeakLatentCoolingLoad | "Peak Latent Cooling Load"
PhaseCreated | "Phase Created"
PhaseDemolished | "Phase Demolished"
PhaseName | "Name"
PhaseSequenceNumber | "Sequence Number"
PhyMaterialParamAverageModulus | "Average Modulus"
PhyMaterialParamBehavior | "Behavior"
PhyMaterialParamBending | "Bending"
PhyMaterialParamBendingReinforcement | "Bending reinforcement"
PhyMaterialParamClass | "Class"
PhyMaterialParamCompressionParallel | "Compression parallel to grain"
PhyMaterialParamCompressionPerpendicular | "Compression perpendicular to grain"
PhyMaterialParamConcreteCompression | "Concrete compression"
PhyMaterialParamExpCoeff | "Thermal expansion coefficient"
PhyMaterialParamExpCoeff1 | "Thermal expansion coefficient X"
PhyMaterialParamExpCoeff2 | "Thermal expansion coefficient Y"
PhyMaterialParamExpCoeff3 | "Thermal expansion coefficient Z"
PhyMaterialParamExpCoeffn1 | "Thermal Expansion Coefficient 1"
PhyMaterialParamExpCoeffn2 | "Thermal Expansion Coefficient 2"
PhyMaterialParamFivepercentModulusOfElacticity | "5% Modulus of Elasticity"
PhyMaterialParamGrade | "Grade"
PhyMaterialParamLightWeight | "Lightweight"
PhyMaterialParamMinimumTensileStrength | "Minimum tensile strength"
PhyMaterialParamMinimumYieldStress | "Minimum yield stress"
PhyMaterialParamPoissonMod | "Poisson ratio"
PhyMaterialParamPoissonMod1 | "Poisson ratio X"
PhyMaterialParamPoissonMod12 | "Poisson Ratio 12"
PhyMaterialParamPoissonMod2 | "Poisson ratio Y"
PhyMaterialParamPoissonMod23 | "Poisson Ratio 23"
PhyMaterialParamPoissonMod3 | "Poisson ratio Z"
PhyMaterialParamReductionFactor | "Reduction factor for shear"
PhyMaterialParamResistanceCalcStrength | "Resistance calculation strength"
PhyMaterialParamShearMod | "Shear modulus"
PhyMaterialParamShearMod1 | "Shear modulus X"
PhyMaterialParamShearMod12 | "Shear Modulus 12"
PhyMaterialParamShearMod2 | "Shear modulus Y"
PhyMaterialParamShearMod3 | "Shear modulus Z"
PhyMaterialParamShearParallel | "Shear parallel to grain"
PhyMaterialParamShearPerpendicular | "Shear perpendicular to grain"
PhyMaterialParamShearReinforcement | "Shear reinforcement yield stress"
PhyMaterialParamShearStrengthReduction | "Shear strength modification"
PhyMaterialParamSpecies | "Species"
PhyMaterialParamStructuralDensity | "Density"
PhyMaterialParamStructuralSpecificHeat | "Specific Heat"
PhyMaterialParamStructuralThermalTreated | "Thermally Treated"
PhyMaterialParamSubclass | "Subclass"
PhyMaterialParamTensionParallel | "Tension Parallel to Grain"
PhyMaterialParamTensionPerpendicular | "Tension Perpendicular to Grain"
PhyMaterialParamThermalConductivity | "Thermal Conductivity"
PhyMaterialParamThermalConductivityX | "Thermal Conductivity X"
PhyMaterialParamThermalConductivityY | "Thermal Conductivity Y"
PhyMaterialParamThermalConductivityZ | "Thermal Conductivity Z"
PhyMaterialParamType | "Material Type"
PhyMaterialParamUnitWeight | "Unit weight"
PhyMaterialParamWoodConstruction | "Construction"
PhyMaterialParamYoungMod | "Young modulus"
PhyMaterialParamYoungMod1 | "Young modulus X"
PhyMaterialParamYoungMod2 | "Young modulus Y"
PhyMaterialParamYoungMod3 | "Young modulus Z"
PhyMaterialParamYoungModn1 | "Young's Modulus 1"
PhyMaterialParamYoungModn2 | "Young's Modulus 2"
PhyMaterialProperties | "Properties"
PipeRoughness | "Roughness"
PipeVelocityPressure | "Velocity Pressure"
PipingConnectionType | "Connection Type"
PipingGenderType | "Gender Type"
PlacementBottom | "Bottom"
PlacementCenterX | "Center X"
PlacementCenterY | "Center Y"
PlacementLeft | "Left"
PlacementParamsShow | "Enable Position Parameters"
PlacementRight | "Right"
PlacementTop | "Top"
PlanRegionViewRange | "View Range"
PlanViewCutPlaneHeight | "Cut Plane Height"
PlanViewLevel | "Associated Level"
PlanViewNorth | "Orientation"
PlanViewRange | "View Range"
PlanViewTopClipHeight | "Top Clip Height"
PlanViewViewDir | "View Direction"
PlumbingFixturesCwConnection | "CW Connection"
PlumbingFixturesDrain | "Drain"
PlumbingFixturesHwConnection | "HW Connection"
PlumbingFixturesSupplyFitting | "Supply Fitting"
PlumbingFixturesSupplyPipe | "Supply Pipe"
PlumbingFixturesTrap | "Trap"
PlumbingFixturesVentConnection | "Vent Connection"
PlumbingFixturesWasteConnection | "Waste Connection"
PocheMatId | "Coarse Poche Material"
PointAdaptiveConstrained | "Constrained"
PointAdaptiveNumParam | "Number"
PointAdaptiveOrientationType | "Orients to"
PointAdaptiveShowNumber | "Show Placement Number"
PointAdaptiveTypeParam | "Point"
PointcloudinstanceName | "Name": The name of the instance as it will show in the Property Palette
PointcloudtypeScale | "Scale": The scale for this instance
PointElementAngle | "Angle"
PointElementChordLength | "Chord Length"
PointElementDriven | "Driven by Host"
PointElementDriving | "Driving Curve(s)"
PointElementHostedOnFaceUParam | "Hosted U Parameter"
PointElementHostedOnFaceVParam | "Hosted V Parameter"
PointElementHostedParam | "Hosted Parameter"
PointElementMeasureFrom | "Measure From"
PointElementMeasurementType | "Measurement Type"
PointElementMirrored | "Mirrored"
PointElementNonNormalizedCurveParamater | "Non-Normalized Curve Parameter"
PointElementNormalizedCurveParamater | "Normalized Curve Parameter"
PointElementNormalizedSegmentLength | "Normalized Segment Length"
PointElementOffset | "Offset"
PointElementRotationAngle | "Rotation Angle"
PointElementSegmentLength | "Segment Length"
PointElementShowNormalPlaneOnly | "Show Normal Reference Plane Only"
PointElementShowPlanes | "Show Reference Planes"
PointElementZflipped | "Flipped"
PointElevation | "Elevation"
PointFlexibleConstrained | "Constrained"
PointFlexibleNumParam | "Number"
PointFlexibleOrientationType | "Orientation"
PointFlexibleShowNumber | "Show Placement Number"
PointNameParam | "Name"
PointVisibilityParam | "Visibility/Graphics Overrides"
PreferDimSideUiFilter | "Prefer:": This is used by the UI to allow select prefer dimension side.
PreferPatternAlignUiFilter | "Pattern:": This is used by the UI to allow to select the preferred preference of aligning pattern.
PrimaryOptionId | "Primary Option Id"
Profile1Angle | "Angle"
Profile1FamType | "Profile"
Profile1FlippedHor | "Profile Is Flipped"
Profile1OffsetX | "Horizontal Profile Offset"
Profile1OffsetY | "Vertical Profile Offset"
Profile2Angle | "Angle"
Profile2FamType | "Profile"
Profile2FlippedHor | "Profile Is Flipped"
Profile2OffsetX | "Horizontal Profile Offset"
Profile2OffsetY | "Vertical Profile Offset"
ProfileAngle | "Angle"
ProfileFamType | "Profile"
ProfileFamTypePlusNone | "Profile"
ProfileFlippedHor | "Profile Is Flipped"
ProfileOffsetX | "Horizontal Profile Offset"
ProfileOffsetY | "Vertical Profile Offset"
ProfileParamAlongPath | "Parameter along path"
ProjectAddress | "Project Address"
ProjectAuthor | "Author"
ProjectBuildingName | "Building Name"
ProjectBuildingType | "Building Type"
ProjectedSurfaceArea | "Projected Area"
ProjectIssueDate | "Project Issue Date"
ProjectName | "Project Name"
ProjectNumber | "Project Number"
ProjectOrganizationDescription | "Organization Description"
ProjectOrganizationName | "Organization Name"
ProjectPostalCode | "Postal Code"
ProjectRevisionEnumeration | "Numbering"
ProjectRevisionRevisionDate | "Revision Date"
ProjectRevisionRevisionDescription | "Revision Description"
ProjectRevisionRevisionIssued | "Issued"
ProjectRevisionRevisionIssuedBy | "Issued by"
ProjectRevisionRevisionIssuedTo | "Issued to"
ProjectRevisionRevisionNum | "Revision Number"
ProjectRevisionSequenceNum | "Revision Sequence": read_only Make this read-only again when NewSchedules_DisplayTags is cleaned up
ProjectStatus | "Project Status"
PropertyArea | "Area"
PropertyAreaOpen | "Area"
PropertyAreaUnits | "Area Units, Format"
PropertyLengthUnits | "Units Format"
PropertySegmentBearing | "Bearing"
PropertySegmentDistance | "Distance"
PropertySegmentEW | "E/W"
PropertySegmentLR | "L/R"
PropertySegmentNS | "N/S"
PropertySegmentRadius | "Radius"
PropertySegmentSubcategoryId | "Subcategory"
PropertySetDescription | "Description"
PropertySetKeywords | "Keywords"
PropertySetMaterialAspect | "Material aspect"
PropertySetName | "Property Set Name"
PropertySubcategoryId | "Subcategory"
RadialArrayArcRadius | "Radius"
RadiusSymbolLocation | "Radius Symbol Location"
RadiusSymbolText | "Radius Symbol Text"
RailingSystemHandrailsHeightParam | "Height"
RailingSystemHandrailsLatteralOffset | "Lateral Offset"
RailingSystemHandrailsPositionParam | "Position"
RailingSystemHandrailsTypesParam | "Type"
RailingSystemHasTopRail | "Use Top Rail": Whether railing has top rail
RailingSystemSecondaryHandrailsHeightParam | "Height"
RailingSystemSecondaryHandrailsLatteralOffset | "Lateral Offset"
RailingSystemSecondaryHandrailsPositionParam | "Position"
RailingSystemSecondaryHandrailsTypesParam | "Type"
RailingSystemTopRailHeightParam | "Height"
RailingSystemTopRailTypesParam | "Type"
RampAttrLeftBalusterAttachPt | "Left Baluster Location"
RampAttrMaterial | "Ramp Material"
RampAttrMinInvSlope | "Ramp Max Slope (1/x)"
RampAttrRightBalusterAttachPt | "Right Baluster Location"
RampAttrShape | "Shape"
RampAttrTextFont | "Text Font"
RampAttrTextSize | "Text Size"
RampAttrThickness | "Thickness"
RampMaxRunLength | "Maximum Incline Length"
RasterEnableSnaps | "Enable Snaps"
RasterHorizontalScale | "Horizontal Scale"
RasterLockProportions | "Lock Proportions"
RasterSheetheight | "Height"
RasterSheetwidth | "Width"
RasterSymbolFilename | "Loaded from file"
RasterSymbolHeight | "Height"
RasterSymbolLinkloadStatus | "Link Status"
RasterSymbolPagenumber | "Page Number"
RasterSymbolPixelheight | "Height (pixels)"
RasterSymbolPixelwidth | "Width (pixels)"
RasterSymbolResolution | "Resolution (dpi)"
RasterSymbolViewname | "View Name"
RasterSymbolWidth | "Width"
RasterVerticalScale | "Vertical Scale"
RbsAdditionalFlow | "Additional Flow"
RbsAdjustableConnector | "Allow Slope Adjustments"
RbsAreaBasedLoadType | "Area Based Load Type"
RbsBuildingConstructionclass | "Building Infiltration Class"
RbsBuildingUseloadcredits | "Use Load Credits"
RbsCabletrayBendradius | "Bend Radius"
RbsCabletrayconduitBendorfitting | "Bend or Fitting"
RbsCabletrayconduitConnectorelemType | "Connector Type"
RbsCabletrayconduitrunLengthParam | "Length"
RbsCabletrayconduitSystemType | "System Type"
RbsCabletrayHeightParam | "Height"
RbsCabletrayRungheight | "Rung Height"
RbsCabletrayRungspace | "Rung Space"
RbsCabletrayRungwidth | "Rung Width"
RbsCabletrayrunHeightParam | "Height"
RbsCabletrayrunWidthParam | "Width"
RbsCabletrayShapetype | "Shape"
RbsCabletrayThickness | "Thickness"
RbsCabletrayWidthParam | "Width"
RbsCalculatedSize | "Size"
RbsComponentClassificationParam | "Component Classification"
RbsConduitBendradius | "Bend Radius"
RbsConduitDiameterParam | "Diameter(Trade Size)"
RbsConduitInnerDiamParam | "Inside Diameter"
RbsConduitOuterDiamParam | "Outside Diameter"
RbsConduitrunDiameterParam | "Diameter(Trade Size)"
RbsConduitrunInnerDiamParam | "Inside Diameter"
RbsConduitrunOuterDiamParam | "Outside Diameter"
RbsConduitTradesize | "Conduit Size Lookup"
RbsConnectorDescription | "Connector Description"
RbsConnectorIsprimary | "Primary Connector"
RbsConnectorOffsetObsolete | "Connector Offset"
RbsConstructionSetParam | "Schematic Types"
RbsConstructionTypeShadingfactorParam | "Internal Shading Factor"
RbsCtcBottomElevation | "Lower End Bottom Elevation"
RbsCtcServiceType | "Service Type"
RbsCtcTopElevation | "Upper End Top Elevation"
RbsCurveDiameterParam | "Diameter"
RbsCurveHeightParam | "Height"
RbsCurveHorOffsetParam | "Horizontal Justification"
RbsCurveSlope | "Slope Percentage (%)"
RbsCurveSurfaceArea | "Area"
RbsCurvetypeDefaultBendParam | "Bend"
RbsCurvetypeDefaultCapParam | "Cap"
RbsCurvetypeDefaultCrossParam | "Cross"
RbsCurvetypeDefaultElbowdownParam | "Vertical Outside Bend"
RbsCurvetypeDefaultElbowParam | "Elbow"
RbsCurvetypeDefaultElbowupParam | "Vertical Inside Bend"
RbsCurvetypeDefaultHorizontalBendParam | "Horizontal Bend"
RbsCurvetypeDefaultMechjointParam | "Flange"
RbsCurvetypeDefaultTakeoffParam | "Tap"
RbsCurvetypeDefaultTeedownParam | "Tee Down"
RbsCurvetypeDefaultTeeParam | "Tee"
RbsCurvetypeDefaultTeeupParam | "Tee Up"
RbsCurvetypeDefaultTransitionParam | "Transition"
RbsCurvetypeDefaultUnionParam | "Union"
RbsCurvetypeMaxHeightParam | "Max Height"
RbsCurvetypeMaxWidthParam | "Max Width"
RbsCurvetypeMultishapeTransitionOvalroundParam | "Multi Shape Transition Oval to Round"
RbsCurvetypeMultishapeTransitionParam | "Multi Shape Transition Rect to Round"
RbsCurvetypeMultishapeTransitionRectovalParam | "Multi Shape Transition Rect to Oval"
RbsCurvetypePreferredBranchParam | "Preferred Junction Type"
RbsCurveUtslope | "Slope"
RbsCurveVertOffsetParam | "Vertical Justification"
RbsCurveWidthParam | "Width"
RbsDistributionsysConfigParam | "Configuration"
RbsDistributionsysNumwiresParam | "Wires"
RbsDistributionsysPhaseParam | "Phase"
RbsDistributionsysVlgParam | "Line to Ground Voltage"
RbsDistributionsysVllParam | "Line to Line Voltage"
RbsDuctBottomElevation | "Lower End Bottom Elevation"
RbsDuctCalculatedSize | "Duct Size"
RbsDuctConnectorSystemClassificationParam | "System Classification"
RbsDuctFittingLossMethodParam | "Loss Method"
RbsDuctFittingLossMethodServerParam | "Loss Method"
RbsDuctFittingLossMethodSettings | "Loss Method Settings"
RbsDuctFittingLossTableParam | "ASHRAE Table"
RbsDuctFlowConfigurationParam | "Flow Configuration"
RbsDuctFlowDirectionParam | "Flow Direction"
RbsDuctFlowParam | "Flow"
RbsDuctPipeSystemAbbreviationParam | "System Abbreviation"
RbsDuctPressureDrop | "Pressure Drop"
RbsDuctRoutingPreferenceParam | "Routing Preferences"
RbsDuctSizeFormattedParam | "Size"
RbsDuctSlope | "Slope"
RbsDuctStaticPressure | "Static Pressure"
RbsDuctSystemCalculationParam | "Calculations"
RbsDuctSystemTypeParam | "System Type"
RbsDuctTopElevation | "Upper End Top Elevation"
RbsDuctTypeParam | "Duct Type"
RbsElecAmbientTemperature | "Ambient Temperature"
RbsElecAnalyticalArea | "Area"
RbsElecAnalyticalFeederLength | "Length"
RbsElecAnalyticalLevelId | "Level"
RbsElecAnalyticalLoadDensity | "Power Density"
RbsElecAnalyticalLoadNameParam | "Name"
RbsElecAnalyticalLoadSetOnDuty | "Quantity of Prime"
RbsElecAnalyticalLoadSetOnStandby | "Quantity on Standby"
RbsElecAnalyticalLoadSetOnTotal | "Total Quantity"
RbsElecAnalyticalLoadsInSet | "Loads in Set"
RbsElecAnalyticalLoadTypeParam | "Load Type"
RbsElecAnalyticalTotalCoincidentLoad | "Total Coincident Loads"
RbsElecApparentCurrentParam | "Apparent Current"
RbsElecApparentCurrentPhaseaParam | "Apparent Current Phase A"
RbsElecApparentCurrentPhasebParam | "Apparent Current Phase B"
RbsElecApparentCurrentPhasecParam | "Apparent Current Phase C"
RbsElecApparentLoad | "Apparent Load"
RbsElecApparentLoadPhase1 | "Apparent Load Phase 1"
RbsElecApparentLoadPhase2 | "Apparent Load Phase 2"
RbsElecApparentLoadPhase3 | "Apparent Load Phase 3"
RbsElecApparentLoadPhasea | "Apparent Load Phase A"
RbsElecApparentLoadPhaseb | "Apparent Load Phase B"
RbsElecApparentLoadPhasec | "Apparent Load Phase C"
RbsElecApparentPowerDensity | "Apparent Power Density"
RbsElecBalancedLoad | "Balanced Load"
RbsElecCalcCoefficientUtilization | "Calculate Coefficient of Utilization"
RbsElecCircuitConnectionTypeParam | "Connection Type"
RbsElecCircuitFrameParam | "Frame"
RbsElecCircuitLengthParam | "Length"
RbsElecCircuitName | "Load Name"
RbsElecCircuitNaming | "Circuit Naming"
RbsElecCircuitNamingIndex | "Circuit Naming Index"
RbsElecCircuitNotesParam | "Schedule Circuit Notes"
RbsElecCircuitNumber | "Circuit Number"
RbsElecCircuitNumberingType | "Circuit Numbering Option"
RbsElecCircuitNumberOfElementsParam | "Number of Elements"
RbsElecCircuitPanelParam | "Panel"
RbsElecCircuitPathModeParam | "Path Mode"
RbsElecCircuitPathOffsetParam | "Offset"
RbsElecCircuitPrefix | "Circuit Prefix"
RbsElecCircuitPrefixSeparator | "Circuit Prefix Separator"
RbsElecCircuitRatingParam | "Rating"
RbsElecCircuitSlotIndex | "Slot Index"
RbsElecCircuitStartSlot | "Start Slot"
RbsElecCircuitType | "System Type"
RbsElecCircuitWireNumGroundsParam | "# of Ground Conductors"
RbsElecCircuitWireNumHotsParam | "# of Hot Conductors"
RbsElecCircuitWireNumNeutralsParam | "# of Neutral Conductors"
RbsElecCircuitWireNumRunsParam | "# of Runs"
RbsElecCircuitWireSizeParam | "Wire Size"
RbsElecCircuitWireTypeParam | "Wire Type"
RbsElecDemandfactorDemandloadParam | "Estimated Demand Load"
RbsElecDemandfactorLoadclassificationParam | "Load Classification"
RbsElecDemandfactorLoadParam | "Connected Load"
RbsElecDistributionNodeLoadSet | "Load Set"
RbsElecDistributionNodeSupplyFrom | "Supply From"
RbsElecDistributionNodeSupplyFrom1 | "Supply From 1"
RbsElecDistributionNodeSupplyFrom2 | "Supply From 2"
RbsElecDistributionNodeSupplyTo | "Supply To"
RbsElecEditCircuitNamingSettingsParam | "Circuit Naming Settings"
RbsElecEnclosure | "Enclosure"
RbsElecLoadClassification | "Load Classification"
RbsElecLoadsummaryConnectedCurrentParam | "Connected Current"
RbsElecLoadsummaryConnectedLoadParam | "Connected Load (VA)"
RbsElecLoadsummaryDemandCurrentParam | "Estimated Demand Current"
RbsElecLoadsummaryDemandFactorParam | "Demand Factor"
RbsElecLoadsummaryDemandFactorRuleParam | "Description"
RbsElecLoadsummaryDemandLoadParam | "Estimated Demand (VA)"
RbsElecLoadsummaryLoadclassificationParam | "Load Classification"
RbsElecMains | "Mains"
RbsElecMaxPoleBreakers | "Max Number of Single Pole Breakers"
RbsElecModifications | "Modifications"
RbsElecMounting | "Mounting"
RbsElecNumberOfCircuits | "Max Number of Circuits"
RbsElecNumberOfPoles | "Number of Poles"
RbsElecPanelBranchCircuitApparentLoadPhasea | "Branch Circuit Apparent Load Phase A"
RbsElecPanelBranchCircuitApparentLoadPhaseb | "Branch Circuit Apparent Load Phase B"
RbsElecPanelBranchCircuitApparentLoadPhasec | "Branch Circuit Apparent Load Phase C"
RbsElecPanelBranchCircuitCurrentPhasea | "Branch Circuit Current Phase A"
RbsElecPanelBranchCircuitCurrentPhaseb | "Branch Circuit Current Phase B"
RbsElecPanelBranchCircuitCurrentPhasec | "Branch Circuit Current Phase C"
RbsElecPanelBussingParam | "Bussing"
RbsElecPanelConfigurationParam | "Panel Configuration"
RbsElecPanelCurrentPhaseaParam | "Current Phase A"
RbsElecPanelCurrentPhasebParam | "Current Phase B"
RbsElecPanelCurrentPhasecParam | "Current Phase C"
RbsElecPanelFeedParam | "Feed"
RbsElecPanelFeedThruLugsApparentLoadPhasea | "Feed Through Lugs Apparent Load Phase A"
RbsElecPanelFeedThruLugsApparentLoadPhaseb | "Feed Through Lugs Apparent Load Phase B"
RbsElecPanelFeedThruLugsApparentLoadPhasec | "Feed Through Lugs Apparent Load Phase C"
RbsElecPanelFeedThruLugsCurrentPhasea | "Feed Through Lugs Current Phase A"
RbsElecPanelFeedThruLugsCurrentPhaseb | "Feed Through Lugs Current Phase B"
RbsElecPanelFeedThruLugsCurrentPhasec | "Feed Through Lugs Current Phase C"
RbsElecPanelFeedThruLugsParam | "Feed Through Lugs"
RbsElecPanelGroundBusParam | "Ground Bus"
RbsElecPanelLocationParam | "Location"
RbsElecPanelMainstypeParam | "Mains Type"
RbsElecPanelMcbRatingParam | "MCB Rating"
RbsElecPanelName | "Panel Name"
RbsElecPanelNeutralBusParam | "Neutral Bus"
RbsElecPanelNeutralRatingParam | "Neutral Rating"
RbsElecPanelNumphasesParam | "Number of Phases"
RbsElecPanelNumwiresParam | "Number of Wires"
RbsElecPanelScheduleFooterNotesParam | "Schedule Footer Notes"
RbsElecPanelScheduleHeaderNotesParam | "Schedule Header Notes"
RbsElecPanelSubfeedLugsParam | "SubFeed Lugs"
RbsElecPanelSupplyFromParam | "Supply From"
RbsElecPanelTotalConnectedCurrentParam | "Total Connected Current"
RbsElecPanelTotalDemandCurrentParam | "Total Estimated Demand Current"
RbsElecPanelTotalDemandFactorParam | "Total Demand Factor"
RbsElecPanelTotalestloadHvacParam | "HVAC Total Estimated Demand"
RbsElecPanelTotalestloadLightParam | "Lighting Total Estimated Demand"
RbsElecPanelTotalestloadOtherParam | "Other Total Estimated Demand"
RbsElecPanelTotalestloadParam | "Total Estimated Demand"
RbsElecPanelTotalestloadPowerParam | "Power Total Estimated Demand"
RbsElecPanelTotalloadHvacParam | "HVAC Total Connected"
RbsElecPanelTotalloadLightParam | "Lighting Total Connected"
RbsElecPanelTotalloadOtherParam | "Other Total Connected"
RbsElecPanelTotalloadParam | "Total Connected"
RbsElecPanelTotalloadPowerParam | "Power Total Connected"
RbsElecPowerFactor | "Power Factor"
RbsElecPowerFactorState | "Power Factor State"
RbsElecRoomAverageIllumination | "Average Estimated Illumination"
RbsElecRoomCavityRatio | "Room Cavity Ratio"
RbsElecRoomLightingCalcLuminaireplane | "Lighting Calculation Luminaire Plane"
RbsElecRoomLightingCalcWorkplane | "Lighting Calculation Workplane"
RbsElecRoomReflectivityCeiling | "Ceiling Reflectance"
RbsElecRoomReflectivityFloor | "Floor Reflectance"
RbsElecRoomReflectivityWalls | "Wall Reflectance"
RbsElecShortCircuitRating | "Short Circuit Rating"
RbsElecSwitchIdParam | "Switch ID"
RbsElectricalData | "Electrical Data"
RbsElecTrueCurrentParam | "True Current"
RbsElecTrueCurrentPhaseaParam | "True Current Phase A"
RbsElecTrueCurrentPhasebParam | "True Current Phase B"
RbsElecTrueCurrentPhasecParam | "True Current Phase C"
RbsElecTrueLoad | "True Load"
RbsElecTrueLoadPhase1 | "True Load Phase 1"
RbsElecTrueLoadPhase2 | "True Load Phase 2"
RbsElecTrueLoadPhase3 | "True Load Phase 3"
RbsElecTrueLoadPhasea | "True Load Phase A"
RbsElecTrueLoadPhaseb | "True Load Phase B"
RbsElecTrueLoadPhasec | "True Load Phase C"
RbsElecVoltage | "Voltage"
RbsElecVoltageDropParam | "Voltage Drop"
RbsElecWireCircuits | "Circuits"
RbsElecWireElevation | "Elevation"
RbsElecWireGroundAdjustment | "Ground Conductors"
RbsElecWireHotAdjustment | "Hot Conductors"
RbsElecWireNeutralAdjustment | "Neutral Conductors"
RbsElecWireShareGround | "Share Ground Conductor"
RbsElecWireShareNeutral | "Share Neutral Conductor"
RbsElecWireTickmarkState | "Tick Marks"
RbsElecWireType | "Type"
RbsEndLevelParam | "End Level"
RbsEndOffsetParam | "End Middle Elevation"
RbsEnergyAnalysisBuildingEnvelopeAnalyticalGridCellSize | "Analytical Grid Cell Size"
RbsEnergyAnalysisBuildingEnvelopeAnalyticalSpaceIdentificationResolution | "Analytical Space Resolution"
RbsEnergyAnalysisBuildingEnvelopeAnalyticalSurfaceIdentificationResolution | "Analytical Surface Resolution"
RbsEnergyAnalysisBuildingEnvelopeDeterminationParam | "Building Envelope"
RbsEnergyAnalysisExportCategoryParam | "Export Category"
RbsEnergyAnalysisExportComplexityParam | "Export Complexity"
RbsEnergyAnalysisExportGbxmlDefaultsParam | "Export Default Values"
RbsEnergyAnalysisGroundPlaneParam | "Ground Plane"
RbsEnergyAnalysisIncludeThermalProperties | "Detailed Elements"
RbsEnergyAnalysisMode | "Mode"
RbsEnergyAnalysisProjectPhaseParam | "Project Phase"
RbsEnergyAnalysisSliverSpaceTolerance | "Sliver Space Tolerance"
RbsEnergyAnalysisSurfaceAdjacentSpaceId1 | "Adjacent Space Id (1)"
RbsEnergyAnalysisSurfaceAdjacentSpaceId2 | "Adjacent Space Id (2)"
RbsEnergyAnalysisSurfaceAzimuth | "Azimuth"
RbsEnergyAnalysisSurfaceCadobjectid | "CADObjectID"
RbsEnergyAnalysisSurfaceOriginX | "Origin (X)"
RbsEnergyAnalysisSurfaceOriginY | "Origin (Y)"
RbsEnergyAnalysisSurfaceOriginZ | "Origin (Z)"
RbsEnergyAnalysisSurfaceTilt | "Tilt"
RbsEnergyAnalysisViewBuildingShellMode | "Show Analytical Building Shell"
RbsEnergyAnalysisViewCoordAxisMode | "Show a Coordinate System Symbol for each Surface"
RbsEnergyAnalysisViewInnerShellMode | "Show Inner Space Shells"
RbsEnergyAnalysisViewOuterShellMode | "Show Analytical Space Shells"
RbsEnergyAnalysisViewRbeMode | "Show Room Bounding Elements Dimmed and Underlay"
RbsEnergyAnalysisViewShadingSurfacesMode | "Show Shading Surfaces"
RbsEnergyAnalysisViewSurfacesMode | "Show Surfaces"
RbsEnergyAnalysisViewTransparentMode | "Show Surfaces Transparent"
RbsEnergyAnalysisViewUpdateSurfaces | "Update Surfaces"
RbsEqDiameterParam | "Equivalent Diameter"
RbsFamilyContentAnnotationDisplay | "Use Annotation Scale"
RbsFamilyContentDistributionSystem | "Distribution System"
RbsFamilyContentOffsetHeight | "OffsetHeight"
RbsFamilyContentOffsetWidth | "OffsetWidth"
RbsFamilyContentSecondaryDistribsys | "Secondary Distribution System"
RbsFamilyContentTakeoffFixedLength | "Takeoff Fixed Length"
RbsFamilyContentTakeoffLength | "Takeoff Length"
RbsFamilyContentTakeoffProjlength | "Takeoff Length Projection"
RbsFlexductRoundtypeParam | "Flex Duct Type"
RbsFlexDuctTypeParam | "Flex Duct Type"
RbsFlexPatternParam | "Flex Pattern"
RbsFlexPipeTypeParam | "Flex Pipe"
RbsFlowFactorParam | "Flow Factor"
RbsFlowObsolete | "Flow"
RbsFpSprinklerCoverageParam | "Coverage"
RbsFpSprinklerKFactorParam | "K-Factor"
RbsFpSprinklerOrificeParam | "Orifice"
RbsFpSprinklerOrificeSizeParam | "Orifice Size"
RbsFpSprinklerPressureClassParam | "Pressure Class"
RbsFpSprinklerResponseParam | "Response"
RbsFpSprinklerTemperatureRatingParam | "Temperature Rating"
RbsFriction | "Friction"
RbsGbxmlOpeningType | "Opening Type"
RbsGbxmlSurfaceArea | "Area"
RbsGbxmlSurfaceName | "Surface Name"
RbsGbxmlSurfaceType | "Surface Type"
RbsHvacloadDoorAreaParam | "Door Area"
RbsHvacloadDoorCoolingLoadParam | "Door Cooling Load"
RbsHvacloadFloorAreaParam | "Floor Area"
RbsHvacloadPartitionAreaParam | "Partition Area"
RbsHvacloadPartitionCoolingLoadParam | "Partition Cooling Load"
RbsHvacloadPlenumCoolingLoadParam | "Plenum Cooling Load"
RbsHvacloadRoofAreaParam | "Roof Area"
RbsHvacloadRoofCoolingLoadParam | "Roof Cooling Load"
RbsHvacloadSkylightAreaParam | "Skylight Area"
RbsHvacloadSkylightCoolingLoadParam | "Skylight Cooling Load"
RbsHvacloadWallAreaParam | "Wall Area"
RbsHvacloadWallCoolingLoadParam | "Wall Cooling Load"
RbsHvacloadWindowAreaParam | "Window Area"
RbsHvacloadWindowCoolingLoadParam | "Window Cooling Load"
RbsHydraulicDiameterParam | "Hydraulic Diameter"
RbsInsulationLiningVolume | "Volume"
RbsInsulationThickness | "Insulation Thickness"
RbsInsulationThicknessForDuct | "Insulation Thickness"
RbsInsulationThicknessForPipe | "Insulation Thickness"
RbsIsCustomFitting | "IsCustom"
RbsLiningThickness | "Lining Thickness"
RbsLiningThicknessForDuct | "Lining Thickness"
RbsLoadSubClassificationMotor | "Load Sub-Classification Motor"
RbsLookupTableName | "Lookup Table Name"
RbsLossCoefficient | "Loss Coefficient"
RbsMaxFlow | "Max Flow"
RbsMinFlow | "Min Flow"
RbsOffsetParam | "Middle Elevation"
RbsPanelScheduleSheetAppearanceInstParam | "Appearance"
RbsPanelScheduleSheetAppearanceParam | "Appearance On Sheet"
RbsParallelconduitsHorizontalNumber | "Horizontal Number for parallel conduits"
RbsParallelconduitsHorizontalOffsetValue | "Horizontal Offset value for parallel conduits"
RbsParallelconduitsVerticalNumber | "Vertical Number for parallel conduits"
RbsParallelconduitsVerticalOffsetValue | "Vertical Offset value for parallel conduits"
RbsParallelpipesHorizontalNumber | "Horizontal Number for parallel pipes"
RbsParallelpipesHorizontalOffsetValue | "Horizontal Offset value for parallel pipes"
RbsParallelpipesVerticalNumber | "Vertical Number for parallel pipes"
RbsParallelpipesVerticalOffsetValue | "Vertical Offset value for parallel pipes"
RbsPartType | "Part Type"
RbsPipeAdditionalFlowParam | "Additional Flow"
RbsPipeBottomElevation | "Lower End Bottom Elevation"
RbsPipeCalculatedSize | "Pipe Size"
RbsPipeClassParam | "Schedule/Type"
RbsPipeConnectiontypeParam | "Connection Type"
RbsPipeConnectorSystemClassificationParam | "System Classification"
RbsPipeCwfuParam | "CWFU"
RbsPipeDiameterParam | "Diameter"
RbsPipeFittingLossKfactorParam | "K Coefficient"
RbsPipeFittingLossMethodParam | "Loss Method"
RbsPipeFittingLossMethodServerParam | "Loss Method"
RbsPipeFittingLossMethodSettings | "Loss Method Settings"
RbsPipeFittingLossTableParam | "K Coefficient Table"
RbsPipeFixtureUnitsParam | "Fixture Units"
RbsPipeFlowConfigurationParam | "Flow Configuration"
RbsPipeFlowDirectionParam | "Flow Direction"
RbsPipeFlowParam | "Flow"
RbsPipeFlowStateParam | "Flow State"
RbsPipeFluidDensityParam | "Fluid Density"
RbsPipeFluidTemperatureParam | "Fluid Temperature"
RbsPipeFluidTypeParam | "Fluid Type"
RbsPipeFluidViscosityParam | "Fluid Dynamic Viscosity"
RbsPipeFrictionParam | "Friction"
RbsPipeHwfuParam | "HWFU"
RbsPipeInnerDiamParam | "Inside Diameter"
RbsPipeInsulationThickness | "Insulation Thickness"
RbsPipeInvertElevation | "Invert Elevation": This parameter is obsolete. It exists only for compatibility.
RbsPipeJointtypeParam | "Connection Type"
RbsPipeMaterialParam | "Material"
RbsPipeOuterDiameter | "Outside Diameter"
RbsPipePressuredropParam | "Pressure Drop"
RbsPipeReynoldsNumberParam | "Reynolds Number"
RbsPipeSegmentParam | "Pipe Segment"
RbsPipeSizeFormattedParam | "Size"
RbsPipeSizeMaximum | "Maximum Size"
RbsPipeSizeMinimum | "Minimum Size"
RbsPipeSlope | "Slope"
RbsPipeSlopeDefParam | "Pipe Slope Definitions"
RbsPipeSlopeOptionsDefParam | "Pipe Slope Options"
RbsPipeStaticPressure | "Static Pressure"
RbsPipeSystemCalculationParam | "Calculations"
RbsPipeSystemFixtureUnitParam | "Fixture Units"
RbsPipeTopElevation | "Upper End Top Elevation"
RbsPipeTypeFittingLossKfactorParam | "K Coefficient"
RbsPipeTypeFittingLossMethodParam | "Loss Method"
RbsPipeTypeFittingLossTableParam | "K Coefficient Table"
RbsPipeTypeParam | "Pipe Type"
RbsPipeTypeValveLossCvfactorParam | "Cv Coefficient"
RbsPipeValveLossCvfactorParam | "Cv Coefficient"
RbsPipeVelocityParam | "Velocity"
RbsPipeVolumeParam | "Volume"
RbsPipeWallThickness | "Wall Thickness"
RbsPipeWfuParam | "WFU"
RbsPipingSystemTypeParam | "System Type"
RbsPressureDrop | "Pressure Drop"
RbsProjectConstructionTypeShadingfactorParam | "Internal Shading Factor"
RbsProjectLocationParam | "Location"
RbsProjectReporttypeParam | "Report Type"
RbsReferenceFreesize | "Free Size"
RbsReferenceInsulationThickness | "Insulation Thickness"
RbsReferenceInsulationType | "Insulation Type"
RbsReferenceLiningThickness | "Lining Thickness"
RbsReferenceLiningType | "Lining Type"
RbsReferenceOverallsize | "Overall Size"
RbsReynoldsnumberParam | "Reynolds number"
RbsRoomCoefficientUtilization | "Coefficient of Utilization"
RbsRoutingPreferenceParam | "Routing Preferences"
RbsSection | "Section"
RbsSegmentDescriptionParam | "Segment Description"
RbsServiceTypeParam | "Building Service"
RbsShowProfileType | "Show Round"
RbsSizeLock | "Size Lock"
RbsStartLevelParam | "Reference Level"
RbsStartOffsetParam | "Start Middle Elevation"
RbsSystemAbbreviationParam | "Abbreviation"
RbsSystemBaseElementParam | "System Equipment"
RbsSystemClassificationParam | "System Classification"
RbsSystemFlowConversionMethodParam | "Flow Conversion Method"
RbsSystemNameParam | "System Name"
RbsSystemNumElementsParam | "Number of Elements"
RbsSystemRisedrop1linedropsymbolParam | "Single Line Drop Symbol"
RbsSystemRisedrop1linerisesymbolParam | "Single Line Rise Symbol"
RbsSystemRisedrop1lineteedownsymbolParam | "Single Line Tee Down Symbol"
RbsSystemRisedrop1lineteeupsymbolParam | "Single Line Tee Up Symbol"
RbsSystemRisedrop2linedropsymbolParam | "Two Line Drop Symbol"
RbsSystemRisedrop2linerisesymbolParam | "Two Line Rise Symbol"
RbsSystemRisedropParam | "Rise / Drop Symbol"
RbsVelocity | "Velocity"
RbsVelocityPressure | "Velocity Pressure"
RbsVoltagetypeMaxvoltageParam | "Maximum Voltage"
RbsVoltagetypeMinvoltageParam | "Minimum Voltage"
RbsVoltagetypeVoltageParam | "Actual Voltage"
RbsWireCircuitDescription | "Circuit Description"
RbsWireCircuitLoadName | "Circuit Load Name"
RbsWireConduitTypeParam | "Conduit Type"
RbsWireInsulationParam | "Insulation"
RbsWireMaterialParam | "Material"
RbsWireMaxConductorSizeParam | "Max Size"
RbsWireNeutralIncludedInBalancedLoadParam | "Neutral Included in Balanced Load"
RbsWireNeutralModeParam | "Neutral Size"
RbsWireNeutralMultiplierParam | "Neutral Multiplier"
RbsWireNumConductorsParam | "Number of Conductors"
RbsWireTemperatureRatingParam | "Temperature Rating"
RebarAlignmentOptions | "Bar Alignment"
RebarBarDeformationType | "Deformation"
RebarBarDiameter | "Bar Diameter"
RebarBarHookLengths | "Hook Lengths"
RebarBarMaximumBendRadius | "Maximum Bend Radius"
RebarBarStirrupBendDiameter | "Stirrup/Tie Bend Diameter"
RebarBarStyle | "Subcategory"
RebarContainerBarType | "Bar Type"
RebarDistributionType | "Distribution Type"
RebarElemBarSpacing | "Spacing"
RebarElemEndtreatmentEnd | "End Treatment At End"
RebarElemEndtreatmentStart | "End Treatment At Start"
RebarElementRounding | "Rounding Overrides"
RebarElementVisibility | "View Visibility States"
RebarElemHookEndOrient | "Hook Orientation At End"
RebarElemHookEndType | "Hook At End"
RebarElemHookStartOrient | "Hook Orientation At Start"
RebarElemHookStartType | "Hook At Start"
RebarElemHookStyle | "Style"
RebarElemHostMark | "Host Mark"
RebarElemLayoutRule | "Layout Rule"
RebarElemLength | "Bar Length"
RebarElemQuantityOfBars | "Quantity"
RebarElemScheduleMark | "Schedule Mark"
RebarElemTotalLength | "Total Bar Length"
RebarFreeFormHookEndPlaneAngle | "Hook Orientation At End"
RebarFreeFormHookStartPlaneAngle | "Hook Orientation At Start"
RebarGeometryType | "Geometry"
RebarHookAngle | "Hook Angle"
RebarHookLengthOverride | "Override Hook Lengths"
RebarHookLineLenFactor | "Extension Multiplier"
RebarHookRotationAtEnd | "Hook Rotation At End"
RebarHookRotationAtEndSchedulesTagsFilters | "Hook Rotation At End"
RebarHookRotationAtStart | "Hook Rotation At Start"
RebarHookRotationAtStartSchedulesTagsFilters | "Hook Rotation At Start"
RebarHookStyle | "Style"
RebarHostCategory | "Host Category"
RebarIncludeFirstBar | "Include First Bar"
RebarIncludeLastBar | "Include Last Bar"
RebarInstanceBarDiameter | "Bar Diameter"
RebarInstanceBarModelDiameter | "Model Bar Diameter"
RebarInstanceBendDiameter | "Bend Diameter"
RebarInstanceStirrupTieAttachment | "Stirrup/Tie Attachment"
RebarInternalMultiplanar | "INTERNAL: Multiplanar"
RebarInternalMultiplanarArcConnector | "INTERNAL: Multiplanar Arc Connector"
RebarInternalMultiplanarDuplicate | "INTERNAL: Multiplanar Duplicate"
RebarInternalMultiplanarEndConnector | "INTERNAL: Multiplanar End Connector"
RebarInternalMultiplanarStartConnector | "INTERNAL: Multiplanar Start Connector"
RebarMaximSuffix | "Maxim Suffix"
RebarMaxLength | "Maximum bar length"
RebarMinimSuffix | "Minim Suffix"
RebarMinLength | "Minimum bar length"
RebarModelBarDiameter | "Model Bar Diameter"
RebarModifiedSet | "Modified Rebar Set"
RebarNumber | "Rebar Number"
RebarNumberSuffix | "Rebar Number Suffix"
RebarQuanityByDistrib | "Quantity By Rebar Set"
RebarShape | "Shape"
RebarShapeAllowedBarTypes | "Allowable Rebar Bar Types"
RebarShapeEndHookLength | "End Hook Length"
RebarShapeEndHookOffset | "End Hook Offset Length"
RebarShapeEndtreatmentEndType | "End Treatment At End"
RebarShapeEndtreatmentStartType | "End Treatment At Start"
RebarShapeHookEndType | "Hook At End"
RebarShapeHookRotationAtEnd | "Hook Rotation At End"
RebarShapeHookRotationAtStart | "Hook Rotation At Start"
RebarShapeHookStartType | "Hook At Start"
RebarShapeHookStyle | "Style"
RebarShapeImage | "Shape Image"
RebarShapeOutOfPlaneBendDiameter | "Out of Plane Bend Diameter"
RebarShapeParamEndHookTanLen | "End Tangent Hook Length"
RebarShapeParamStartHookTanLen | "Start Tangent Hook Length"
RebarShapeSpiralBaseFinishingTurns | "Base Finishing Turns"
RebarShapeSpiralHeight | "Height"
RebarShapeSpiralPitch | "Pitch"
RebarShapeSpiralTopFinishingTurns | "Top Finishing Turns"
RebarShapeStartHookLength | "Start Hook Length"
RebarShapeStartHookOffset | "Start Hook Offset Length"
RebarShapeStirrupTieAttachment | "Stirrup/Tie Attachment"
RebarStandardBendDiameter | "Standard Bend Diameter"
RebarStandardHookBendDiameter | "Standard Hook Bend Diameter"
RebarSystemActiveBackDirn1 | "Interior Major Direction"
RebarSystemActiveBackDirn2 | "Interior Minor Direction"
RebarSystemActiveBottomDir1Generic | "Bottom/Interior Major Direction"
RebarSystemActiveBottomDir2Generic | "Bottom/Interior Minor Direction"
RebarSystemActiveBottomDirn1 | "Bottom Major Direction"
RebarSystemActiveBottomDirn2 | "Bottom Minor Direction"
RebarSystemActiveFrontDirn1 | "Exterior Major Direction"
RebarSystemActiveFrontDirn2 | "Exterior Minor Direction"
RebarSystemActiveTopDir1Generic | "Top/Exterior Major Direction"
RebarSystemActiveTopDir2Generic | "Top/Exterior Minor Direction"
RebarSystemActiveTopDirn1 | "Top Major Direction"
RebarSystemActiveTopDirn2 | "Top Minor Direction"
RebarSystemAddlBottomOffset | "Additional Bottom Cover Offset"
RebarSystemAddlExteriorOffset | "Additional Exterior Cover Offset"
RebarSystemAddlInteriorOffset | "Additional Interior Cover Offset"
RebarSystemAddlTopOffset | "Additional Top Cover Offset"
RebarSystemBarTypeBackDirn1 | "Interior Major Bar Type"
RebarSystemBarTypeBackDirn2 | "Interior Minor Bar Type"
RebarSystemBarTypeBottomDir1Generic | "Bottom/Interior Major Bar Type"
RebarSystemBarTypeBottomDir2Generic | "Bottom/Interior Minor Bar Type"
RebarSystemBarTypeBottomDirn1 | "Bottom Major Bar Type"
RebarSystemBarTypeBottomDirn2 | "Bottom Minor Bar Type"
RebarSystemBarTypeFrontDirn1 | "Exterior Major Bar Type"
RebarSystemBarTypeFrontDirn2 | "Exterior Minor Bar Type"
RebarSystemBarTypeTopDir1Generic | "Top/Exterior Major Bar Type"
RebarSystemBarTypeTopDir2Generic | "Top/Exterior Minor Bar Type"
RebarSystemBarTypeTopDirn1 | "Top Major Bar Type"
RebarSystemBarTypeTopDirn2 | "Top Minor Bar Type"
RebarSystemBottomMajorMatchesBottomMinor | "Bottom Major and Minor Layers Match"
RebarSystemCoverBottom | "Rebar Cover Bottom/Interior"
RebarSystemCoverSide | "Rebar Cover Side/Edge"
RebarSystemCoverTop | "Rebar Cover Top/Exterior"
RebarSystemHookOrientBackDirn1 | "Interior Major Hook Orientation"
RebarSystemHookOrientBackDirn2 | "Interior Minor Hook Orientation"
RebarSystemHookOrientBottomDirn1 | "Bottom Major Hook Orientation"
RebarSystemHookOrientBottomDirn2 | "Bottom Minor Hook Orientation"
RebarSystemHookOrientFrontDirn1 | "Exterior Major Hook Orientation"
RebarSystemHookOrientFrontDirn2 | "Exterior Minor Hook Orientation"
RebarSystemHookOrientTopDirn1 | "Top Major Hook Orientation"
RebarSystemHookOrientTopDirn2 | "Top Minor Hook Orientation"
RebarSystemHookTypeBackDirn1 | "Interior Major Hook Type"
RebarSystemHookTypeBackDirn2 | "Interior Minor Hook Type"
RebarSystemHookTypeBottomDirn1 | "Bottom Major Hook Type"
RebarSystemHookTypeBottomDirn2 | "Bottom Minor Hook Type"
RebarSystemHookTypeFrontDirn1 | "Exterior Major Hook Type"
RebarSystemHookTypeFrontDirn2 | "Exterior Minor Hook Type"
RebarSystemHookTypeTopDirn1 | "Top Major Hook Type"
RebarSystemHookTypeTopDirn2 | "Top Minor Hook Type"
RebarSystemLayerSummaryBottomDir1NoSpacing | "Bottom/Interior Major (Brief)"
RebarSystemLayerSummaryBottomDir1WithSpacing | "Bottom/Interior Major"
RebarSystemLayerSummaryBottomDir2NoSpacing | "Bottom/Interior Minor (Brief)"
RebarSystemLayerSummaryBottomDir2WithSpacing | "Bottom/Interior Minor"
RebarSystemLayerSummaryDir1NoSpacing | "Major, Both Faces (Brief)"
RebarSystemLayerSummaryDir1WithSpacing | "Major, Both Faces"
RebarSystemLayerSummaryDir2NoSpacing | "Minor, Both Faces (Brief)"
RebarSystemLayerSummaryDir2WithSpacing | "Minor, Both Faces"
RebarSystemLayerSummaryNoSpacing | "Layer Summary (Brief)"
RebarSystemLayerSummaryTopDir1NoSpacing | "Top/Exterior Major (Brief)"
RebarSystemLayerSummaryTopDir1WithSpacing | "Top/Exterior Major"
RebarSystemLayerSummaryTopDir2NoSpacing | "Top/Exterior Minor (Brief)"
RebarSystemLayerSummaryTopDir2WithSpacing | "Top/Exterior Minor"
RebarSystemLayerSummaryWithSpacing | "Layer Summary"
RebarSystemLayoutRule | "Layout Rule"
RebarSystemNumberOfLinesBackDirn1 | "Interior Major Number Of Lines"
RebarSystemNumberOfLinesBackDirn2 | "Interior Minor Number Of Lines"
RebarSystemNumberOfLinesBottomDir1Generic | "Bottom/Interior Major Number Of Lines"
RebarSystemNumberOfLinesBottomDir2Generic | "Bottom/Interior Minor Number Of Lines"
RebarSystemNumberOfLinesBottomDirn1 | "Bottom Major Number Of Lines"
RebarSystemNumberOfLinesBottomDirn2 | "Bottom Minor Number Of Lines"
RebarSystemNumberOfLinesFrontDirn1 | "Exterior Major Number Of Lines"
RebarSystemNumberOfLinesFrontDirn2 | "Exterior Minor Number Of Lines"
RebarSystemNumberOfLinesTopDir1Generic | "Top/Exterior Major Number Of Lines"
RebarSystemNumberOfLinesTopDir2Generic | "Top/Exterior Minor Number Of Lines"
RebarSystemNumberOfLinesTopDirn1 | "Top Major Number Of Lines"
RebarSystemNumberOfLinesTopDirn2 | "Top Minor Number Of Lines"
RebarSystemOverride | "Override Area Reinforcement Settings"
RebarSystemSpacingBackDirn1 | "Interior Major Spacing"
RebarSystemSpacingBackDirn2 | "Interior Minor Spacing"
RebarSystemSpacingBottomDir1Generic | "Bottom/Interior Major Spacing"
RebarSystemSpacingBottomDir2Generic | "Bottom/Interior Minor Spacing"
RebarSystemSpacingBottomDirn1 | "Bottom Major Spacing"
RebarSystemSpacingBottomDirn2 | "Bottom Minor Spacing"
RebarSystemSpacingFrontDirn1 | "Exterior Major Spacing"
RebarSystemSpacingFrontDirn2 | "Exterior Minor Spacing"
RebarSystemSpacingTopDir1Generic | "Top/Exterior Major Spacing"
RebarSystemSpacingTopDir2Generic | "Top/Exterior Minor Spacing"
RebarSystemSpacingTopDirn1 | "Top Major Spacing"
RebarSystemSpacingTopDirn2 | "Top Minor Spacing"
RebarSystemSpanactiveDirn1 | "Bars In Major Direction"
RebarSystemSpanactiveDirn2 | "Bars In Minor Direction"
RebarSystemSpanhookBottomDirn2 | "Hook Angle Bottom"
RebarSystemSpanhookLeftDirn1 | "Hook Angle Left"
RebarSystemSpanhookRightDirn1 | "Hook Angle Right"
RebarSystemSpanhookTopDirn2 | "Hook Angle Top"
RebarSystemTopMajorMatchesBottomMajor | "Top and Bottom Major Layers Match"
RebarSystemTopMajorMatchesTopMinor | "Top Major and Minor Layers Match"
RebarSystemTopMinorMatchesBottomMinor | "Top and Bottom Minor Layers Match"
RebarWorkshopInstructions | "Workshop Instructions"
RectMullionThick | "Thickness"
RectMullionWidth1 | "Width on side 1"
RectMullionWidth2 | "Width on side 2"
ReferenceBaseOnHost | "Reference Base on Host"
ReferencedView | "Referenced View": The view referenced by a section or callout.
ReferenceLineSubcategory | "Subcategory"
ReferenceOtherViewUiRefView | "Reference View": This is used by the UI to allow selection of view reference.
ReferenceOtherViewUiToggle | "Reference Other View": This is used to determine whether reference other view is enable or not.
ReferenceViewerAttrTag | "View Reference Tag"
ReferenceViewerTargetView | "Target view"
ReferenceViewerUiTargetFilter | "Filter": This is used by the UI to filter the list of target views.
ReferenceViewerUiTargetView | "Target view": This is used by the UI to allow selection of target view. It allows the UI to set a filter that is incompatible with the current target view (REFERENCE_VIEWER_TARGET_VIEW).
RefTableElemName | "Key Name"
RefTableParamName | "Parameter Name"
ReinEstBarLength | "Estimated Total Bar Length"
ReinEstBarVolume | "Estimated Reinforcement Volume"
ReinEstNumberOfBars | "Estimated Number of Bars"
ReinforcementVolume | "Reinforcement Volume"
RelatedToMass | "Related to Mass"
RelativeRoughness | "Relative Roughness"
RenderPlantHeight | "Height"
RenderPlantName | "Plant Name"
RenderPlantTrimHeight | "Plant Trim Height"
RenderRpcFilename | "Render Appearance"
RenderRpcProperties | "Render Appearance Properties"
RepeatingDetailElement | "Detail"
RepeatingDetailInside | "Inside"
RepeatingDetailLayout | "Layout"
RepeatingDetailNumber | "Number"
RepeatingDetailRotation | "Detail Rotation"
RepeatingDetailSpacing | "Spacing"
RevealProfileParam | "Profile"
RevisionCloudRevision | "Revision"
RevisionCloudRevisionDate | "Revision Date"
RevisionCloudRevisionDescription | "Revision Description"
RevisionCloudRevisionIssuedBy | "Issued by"
RevisionCloudRevisionIssuedTo | "Issued to"
RevisionCloudRevisionNum | "Revision Number"
RevolutionEndAngle | "End Angle"
RevolutionStartAngle | "Start Angle"
RgbBParam | "Blue value for RGB color spec. (for Use with XAML Data Template example)"
RgbGParam | "Green value for RGB color spec. (for Use with XAML Data Template example)"
RgbRParam | "Red value for RGB color spec. (for Use with XAML Data Template example)"
RoofAttrDefaultThicknessParam | "Default Thickness"
RoofAttrThicknessParam | "Thickness"
RoofBaseLevelParam | "Base Level"
RoofConstraintLevelParam | "Reference Level"
RoofConstraintOffsetParam | "Level Offset"
RoofCurveHeightAtWall | "Plate Offset From Base"
RoofCurveHeightOffset | "Offset From Roof Base"
RoofCurveIsSlopeDefining | "Defines Roof Slope"
RoofEaveCutParam | "Rafter Cut"
RoofFacesLocation | "Picked Faces Location"
RoofLevelOffsetParam | "Base Offset From Level"
RoofRafterOrTrussParam | "Rafter or Truss"
RoofSlope | "Slope"
RoofStructureIdParam | "Structure"
RoofUptoLevelOffsetParam | "Cutoff Offset"
RoofUptoLevelParam | "Cutoff Level"
RoomActualExhaustAirflowParam | "Actual Exhaust Airflow"
RoomActualLightingLoadParam | "Actual Lighting Load"
RoomActualLightingLoadPerAreaParam | "Actual Lighting Load per area"
RoomActualPowerLoadParam | "Actual Power Load"
RoomActualPowerLoadPerAreaParam | "Actual Power Load per area"
RoomActualReturnAirflowParam | "Actual Return Airflow"
RoomActualSupplyAirflowParam | "Actual Supply Airflow"
RoomAirChangesPerHourParam | "Air Changes per Hour"
RoomArea | "Area"
RoomAreaPerPersonParam | "Area per Person"
RoomBaseHeatLoadOnParam | "Heat Load Values"
RoomBaseLightingLoadOnParam | "Base Lighting Load on"
RoomBasePowerLoadOnParam | "Base Power Load on"
RoomBaseReturnAirflowOnParam | "Return Airflow"
RoomCalculatedCoolingLoadParam | "Calculated Cooling Load"
RoomCalculatedCoolingLoadPerAreaParam | "Calculated Cooling Load per area"
RoomCalculatedHeatingLoadParam | "Calculated Heating Load"
RoomCalculatedHeatingLoadPerAreaParam | "Calculated Heating Load per area"
RoomCalculatedSupplyAirflowParam | "Calculated Supply Airflow"
RoomCalculatedSupplyAirflowPerAreaParam | "Calculated Supply Airflow per area"
RoomCalculationPoint | "Room Calculation Point"
RoomComputationHeight | "Computation Height"
RoomComputationMethod | "Computation"
RoomConditionTypeParam | "Condition Type"
RoomConstructionSetParam | "Construction Type"
RoomDepartment | "Department"
RoomDesignCoolingLoadParam | "Design Cooling Load"
RoomDesignExhaustAirflowParam | "Specified Exhaust Airflow"
RoomDesignHeatingLoadParam | "Design Heating Load"
RoomDesignLightingLoadParam | "Specified Lighting Load"
RoomDesignLightingLoadPerAreaParam | "Specified Lighting Load per area"
RoomDesignMechanicalLoadPerAreaParam | "Design HVAC Load per area"
RoomDesignOtherLoadPerAreaParam | "Design Other Load per area"
RoomDesignPowerLoadParam | "Specified Power Load"
RoomDesignPowerLoadPerAreaParam | "Specified Power Load per area"
RoomDesignReturnAirflowParam | "Specified Return Airflow"
RoomDesignSupplyAirflowParam | "Specified Supply Airflow"
RoomEditElectricalLoadsParam | "Electrical Loads"
RoomEditPeopleLoadsParam | "People"
RoomFinishBase | "Base Finish"
RoomFinishCeiling | "Ceiling Finish"
RoomFinishFloor | "Floor Finish"
RoomFinishWall | "Wall Finish"
RoomHeight | "Unbounded Height"
RoomLevelId | "Level"
RoomLightingLoadUnitsParam | "Lighting Load Units"
RoomLowerOffset | "Base Offset"
RoomName | "Name"
RoomNumber | "Number"
RoomNumberOfPeopleParam | "Number of People"
RoomOccupancy | "Occupancy"
RoomOccupancyUnitParam | "Occupancy Unit"
RoomOutdoorAirflowParam | "Outdoor Airflow"
RoomOutdoorAirflowStandardParam | "Outdoor Air Method"
RoomOutdoorAirInfoParam | "Outdoor Air Information"
RoomOutdoorAirPerAreaParam | "Outdoor Air per Area"
RoomOutdoorAirPerPersonParam | "Outdoor Air per Person"
RoomPeopleLatentHeatGainPerPersonParam | "Latent Heat Gain per person"
RoomPeopleSensibleHeatGainPerPersonParam | "Sensible Heat Gain per person"
RoomPeopleTotalHeatGainPerPersonParam | "Total Heat Gain per person"
RoomPerimeter | "Perimeter"
RoomPhase | "Phase"
RoomPhaseId | "Phase Id"
RoomPlenumLightingParam | "Plenum Lighting Contribution"
RoomPowerLoadUnitsParam | "Power Load Units"
RoomSpaceTypeParam | "Space Type"
RoomTagOrientationParam | "Orientation"
RoomUpperLevel | "Upper Limit"
RoomUpperOffset | "Limit Offset"
RoomVolume | "Volume"
RouteAnalysisSettingsParam | "Route Analysis Settings"
RoutingPreferenceParam | "Routing Preference"
RvtHostLevel | "Map Levels..."
RvtLevelOffset | "Map Levels..."
RvtLinkFileNameWithoutExt | "File Name"
RvtLinkInstanceName | "Name"
RvtLinkInstanceProjectInformation | "Project Information"
RvtLinkPhaseMap | "Phase Mapping"
RvtLinkReferenceType | "Reference Type"
RvtSourceLevel | "Map Levels..."
ScheduleBaseLevelOffsetParam | "Base Offset"
ScheduleBaseLevelParam | "Base Level"
ScheduleCategory | "Category"
ScheduleEmbeddedParam | "Embedded Schedule"
ScheduleFieldsParam | "Fields"
ScheduleFilterParam | "Filter"
ScheduleFormatParam | "Formatting"
ScheduleGroupParam | "Sorting/Grouping"
ScheduleLevelParam | "Level"
ScheduleResizeRows | "Resize Rows"
ScheduleRotationOnSheet | "Rotation on Sheet"
ScheduleRowHeightInput | "Row Height"
ScheduleSheetAppearanceParam | "Appearance"
ScheduleTopLevelOffsetParam | "Top Offset"
ScheduleTopLevelParam | "Top Level"
ScheduleTypeForBrowser | "Schedule Type"
SectionAttrHeadTag | "Section Head"
SectionAttrTailLength | "Tail length"
SectionAttrTailTag | "Section Tail"
SectionAttrTailWidth | "Tail width"
SectionBrokenDisplayStyle | "Broken Section Display Style"
SectionCoarserScalePulldownImperial | "Hide at scales coarser than"
SectionCoarserScalePulldownMetric | "Hide at scales coarser than"
SectionParentViewName | "Parent View"
SectionShowInOneViewOnly | "Show in"
SectionTag | "Section Tag"
SeekItemId | "Seek Item ID"
SelectionEditableOnly | "Editable only"
SheetApprovedBy | "Approved By"
SheetAssemblyAssemblyCode | "Assembly: Assembly Code"
SheetAssemblyAssemblyDescription | "Assembly: Assembly Description"
SheetAssemblyCost | "Assembly: Cost"
SheetAssemblyDescription | "Assembly: Description"
SheetAssemblyKeynote | "Assembly: Keynote"
SheetAssemblyManufacturer | "Assembly: Manufacturer"
SheetAssemblyModel | "Assembly: Model"
SheetAssemblyName | "Assembly: Name"
SheetAssemblyTypeComments | "Assembly: Type Comments"
SheetAssemblyTypeMark | "Assembly: Type Mark"
SheetAssemblyUrl | "Assembly: URL"
SheetCheckedBy | "Checked By"
SheetCurrentRevision | "Current Revision"
SheetCurrentRevisionDate | "Current Revision Date"
SheetCurrentRevisionDescription | "Current Revision Description"
SheetCurrentRevisionIssued | "Current Revision Issued"
SheetCurrentRevisionIssuedBy | "Current Revision Issued By"
SheetCurrentRevisionIssuedTo | "Current Revision Issued To"
SheetDate | "Date/Time Stamp"
SheetDesignedBy | "Designed By"
SheetDrawnBy | "Drawn By"
SheetFilePath | "File Path"
SheetGuideGrid | "Guide Grid"
SheetHeight | "Sheet Height"
SheetIssueDate | "Sheet Issue Date"
SheetKeyNumber | "Sheet Key Number"
SheetName | "Sheet Name"
SheetNumber | "Sheet Number"
SheetRevisionsOnSheet | "Revisions on Sheet"
SheetScale | "Scale"
SheetScheduled | "Appears In Sheet List"
SheetWidth | "Sheet Width"
ShowArrowheadToCutMark | "Show Arrowhead to Cut Mark"
ShowIconParam | "Flag to display icon in Ribbon Combo Item"
ShowTitle | "Show Title"
SketchGridSpacingParam | "Work Plane Grid Spacing"
SketchPlaneParam | "Work Plane"
SlabEdgeMaterialParam | "Material"
SlabEdgeProfileParam | "Profile"
SlantedColumnBaseCutStyle | "Base Cut Style"
SlantedColumnBaseExtension | "Base Extension"
SlantedColumnGeometryTreatmentBase | "Base Geometry Alignment"
SlantedColumnGeometryTreatmentTop | "Top Geometry Alignment"
SlantedColumnTopCutStyle | "Top Cut Style"
SlantedColumnTopExtension | "Top Extension"
SlantedColumnTypeParam | "Column Style"
SlopeArrowLevelEnd | "Level at Head"
SlopeArrowLevelStart | "Level at Tail"
SlopeEndHeight | "Height Offset at Head"
SlopeStartHeight | "Height Offset at Tail"
SpaceAirChangesPerHour | "Air Changes per Hour"
SpaceAirflowPerAreaParam | "Airflow per area"
SpaceArea | "Area"
SpaceAreaPerPersonParam | "Area per person"
SpaceAssocRoomName | "Room Name"
SpaceAssocRoomNumber | "Room Number"
SpaceCarpetingParam | "Carpeting"
SpaceComposednameParam | "Composed Name"
SpaceConditionType | "Condition Type"
SpaceCoolingSetPoint | "Cooling Set Point"
SpaceDehumidificationSetPoint | "Dehumidification Set Point"
SpaceElecEquipmentRadiantPercentageParam | "Electrical Equipment Radiant"
SpaceHeatingSetPoint | "Heating Set Point"
SpaceHumidificationSetPoint | "Humidification Set Point"
SpaceInfiltrationAirflow | "Infiltration Airflow"
SpaceInfiltrationAirflowPerArea | "Infiltration Airflow per area"
SpaceInfiltrationParam | "Infiltration Airflow per area"
SpaceIsOccupiable | "Occupiable"
SpaceIsPlenum | "Plenum"
SpaceLightingLoadParam | "Lighting Load"
SpaceLightingLoadPerAreaParam | "Lighting Load per area"
SpaceLightingScheduleParam | "Lighting Schedule"
SpaceNameParam | "Name"
SpaceNumberOfPeople | "Number of People"
SpaceNumberParam | "Number"
SpaceOccupancyScheduleParam | "Occupancy Schedule"
SpaceOutdoorAirflow | "Outdoor Airflow"
SpaceOutdoorAirflowPerArea | "Outdoor Airflow per area"
SpaceOutdoorAirflowPerPerson | "Outdoor Airflow per person"
SpacePeopleActivityLevelParam | "People Activity Level"
SpacePeopleLatentHeatGainPerPersonParam | "Latent Heat Gain per person"
SpacePeopleLoadParam | "Occupancy Load"
SpacePeopleSensibleHeatGainPerPersonParam | "Sensible Heat Gain per person"
SpacePowerLoadParam | "Power Load"
SpacePowerLoadPerAreaParam | "Power Load per area"
SpacePowerScheduleParam | "Power Schedule"
SpaceReferenceLevelParam | "Reference Level"
SpaceTypeGbxml | "Space Type (gbXML)"
SpaceVolume | "Volume"
SpaceZoneName | "Zone"
SpacingAppend | "Append Position"
SpacingJustification | "Justification"
SpacingJustificationHoriz | "Justification"
SpacingJustificationn1 | "Justification"
SpacingJustificationn2 | "Justification"
SpacingJustificationU | "Justification"
SpacingJustificationV | "Justification"
SpacingJustificationVert | "Justification"
SpacingLayout | "Layout"
SpacingLayoutHoriz | "Layout"
SpacingLayoutn1 | "Layout"
SpacingLayoutn2 | "Layout"
SpacingLayoutU | "Layout"
SpacingLayoutV | "Layout"
SpacingLayoutVert | "Layout"
SpacingLength | "Spacing"
SpacingLengthHoriz | "Spacing"
SpacingLengthn1 | "Spacing"
SpacingLengthn2 | "Spacing"
SpacingLengthU | "Distance"
SpacingLengthV | "Distance"
SpacingLengthVert | "Spacing"
SpacingNumDivisions | "Number"
SpacingNumDivisionsHoriz | "Number"
SpacingNumDivisionsn1 | "Number"
SpacingNumDivisionsn2 | "Number"
SpacingNumDivisionsU | "Number"
SpacingNumDivisionsV | "Number"
SpacingNumDivisionsVert | "Number"
SpanDirInstParamAngle | "Span Direction"
SpanDirSymParamBottom | "Bottom"
SpanDirSymParamLeft | "Left"
SpanDirSymParamRight | "Right"
SpanDirSymParamTop | "Top"
SpatialFieldMgrCurrentName | "Analysis Configuration"
SpatialFieldMgrDescription | "Description"
SpatialFieldMgrLegendHeight | "Legend Height"
SpatialFieldMgrLegendHorOriginGap | "Legend Horizontal Origin Gap"
SpatialFieldMgrLegendShowConfigName | "Show Configuration Name"
SpatialFieldMgrLegendShowDescription | "Show Description"
SpatialFieldMgrLegendTextType | "Overall Legend Text"
SpatialFieldMgrLegendVertOriginGap | "Legend Vertical Origin Gap"
SpatialFieldMgrLegendWidth | "Legend Width"
SpatialFieldMgrRange | "Data Range"
SpatialFieldMgrResultsVisibility | "Results Visibility"
SpecifySlopeOrOffset | "Specify "
SpotCoordinateBase | "Coordinate Base"
SpotCoordinateBottomPrefix | "Bottom Coordinate Prefix"
SpotCoordinateBottomSuffix | "Bottom Coordinate Suffix"
SpotCoordinateElevationPrefix | "Elevation Prefix"
SpotCoordinateElevationSuffix | "Elevation Suffix"
SpotCoordinateIncludeElevation | "Include Elevation"
SpotCoordinateTopPrefix | "Top Coordinate Prefix"
SpotCoordinateTopSuffix | "Top Coordinate Suffix"
SpotDimLeader | "Leader"
SpotDimLeaderLine | "Leader Line"
SpotDimStyleSlopeUnits | "Units Format"
SpotDimStyleSlopeUnitsAlt | "Alternate Units Format"
SpotElevBase | "Elevation Base"
SpotElevBendLeader | "Leader Shoulder"
SpotElevBotValue | "Bottom Coordinate"
SpotElevDisplayElevations | "Display Elevations"
SpotElevFlipTextVert | "Auto Mirror"
SpotElevIndBottom | "Bottom Indicator"
SpotElevIndElevation | "Elevation Indicator"
SpotElevIndEw | "East / West Indicator"
SpotElevIndNs | "North / South Indicator"
SpotElevIndTop | "Top Indicator"
SpotElevIndType | "Indicator as Prefix / Suffix"
SpotElevIndTypeBottom | "Bottom Indicator as Prefix/Suffix"
SpotElevIndTypeElevation | "Elevation Indicator as Prefix/Suffix"
SpotElevIndTypeTop | "Top Indicator as Prefix/Suffix"
SpotElevLeaderArrowhead | "Leader Arrowhead"
SpotElevLinePen | "Leader Line Weight"
SpotElevLowerPrefix | "Lower Value Prefix"
SpotElevLowerSuffix | "Lower Value Suffix"
SpotElevLowerValue | "Lower Value"
SpotElevRelativeBase | "Relative Base"
SpotElevRotateWithComponent | "Rotate with Component"
SpotElevSingleOrUpperPrefix | "Single/Upper Value Prefix"
SpotElevSingleOrUpperSuffix | "Single/Upper Value Suffix"
SpotElevSingleOrUpperValue | "Single/Upper Value"
SpotElevSymbol | "Symbol"
SpotElevTextHorizOffset | "Text Offset from Symbol"
SpotElevTextLocation | "Text Location"
SpotElevTextOrientation | "Text Orientation"
SpotElevTickMarkPen | "Leader Arrowhead Line Weight"
SpotElevTopValue | "Top Coordinate"
SpotSlopeLeaderLength | "Leader Line Length"
SpotSlopeOffsetFromReference | "Offset from Reference"
SpotSlopePrefix | "Prefix"
SpotSlopeSlopeDirection | "Slope Direction"
SpotSlopeSlopeRepresentation | "Slope Representation"
SpotSlopeSuffix | "Suffix"
SpotTextFromLeader | "Text Offset from Leader"
SsePointBasetypeEnum | "Point Base Type"
SsePointElevation | "Elevation"
SsePointElevationBaseType | "Elevation Base Type"
SsePointOffsetFromSurface | "Offset from Surface"
StairsActualNumberOfRisers | "Actual Number of Risers": The total number of actually created risers in model
StairsActualNumRisers | "Actual Number of Risers"
StairsActualRiserHeight | "Actual Riser Height"
StairsActualTreadDepth | "Actual Tread Depth"
StairsAttrBodyMaterial | "Monolithic Material"
StairsAttrBreakSymInCutline | "Break Symbol in Plan"
StairsAttrCalcEnabled | "Calculation Rules"
StairsAttrCalcMax | "Calculation Rules"
StairsAttrCalcMin | "Calculation Rules"
StairsAttrEqResult | "Calculation Rules"
StairsAttrFirstRiser | "Begin with Riser"
StairsAttrLandingCarriage | "Landing Carriage Height"
StairsAttrLandingsOverlapping | "Landing Overlap"
StairsAttrLastRiser | "End with Riser"
StairsAttrLeftSideStringer | "Left Stringer"
StairsAttrMaxRiserHeight | "Maximum Riser Height"
StairsAttrMinimumTreadDepth | "Minimum Tread Depth"
StairsAttrMonolithicStairs | "Monolithic Stairs"
StairsAttrNosingLength | "Nosing Length"
StairsAttrNosingPlacement | "Apply Nosing Profile"
StairsAttrNumMidStringers | "Middle Stringers"
StairsAttrRightSideStringer | "Right Stringer"
StairsAttrRiserAngle | "Riser Angle"
StairsAttrRiserMaterial | "Riser Material"
StairsAttrRiserMult | "Riser Multiplier"
StairsAttrRisersPresent | "Risers Present"
StairsAttrRiserThickness | "Riser Thickness"
StairsAttrRiserTreadConnect | "Riser to Tread Connection"
StairsAttrRiserType | "Riser Type"
StairsAttrSideStringerTypeParam | "Type of Side Stringers"
StairsAttrStairCalculator | "Calculation Rules"
StairsAttrStairsBottom | "Underside of Winder"
StairsAttrStairsCutOffset | "Extend Below Base"
StairsAttrStringerCarriage | "Stringer Carriage Height"
StairsAttrStringerHeight | "Stringer Height"
StairsAttrStringerMaterial | "Stringer Material"
StairsAttrStringerOffset | "Open Stringer Offset"
StairsAttrStringerThickness | "Stringer Thickness"
StairsAttrTextFont | "Text Font"
StairsAttrTextSize | "Text Size"
StairsAttrTreadFrontProfile | "Nosing Profile"
StairsAttrTreadMaterial | "Tread Material"
StairsAttrTreadMult | "Tread Multiplier"
StairsAttrTreadThickness | "Tread Thickness"
StairsAttrTreadWidth | "Width"
StairsAttrTrimTop | "Trim Stringers at Top"
StairsBaseLevel | "Base Level": The base level of stairs
StairsBaseLevelParam | "Base Level"
StairsBaseOffset | "Base Offset"
StairsCurveType | "Stairs Line Type"
StairsDbgShowAnnotationCutMark | "Cut by Cut Plane"
StairsDbgShowBoundary2d | "Show Stairs' Boundary 2D"
StairsDbgShowBoundary3d | "Show Stairs' Boundary 3D"
StairsDbgShowLandingBoundary | "Show Landing Boundary"
StairsDbgShowLandingFaces | "Show Landing Faces"
StairsDbgShowLandingPath | "Show Landing Path"
StairsDbgShowLeftRunBoundary2d | "Show Run's Left Boundary 2D"
StairsDbgShowLeftRunBoundary3d | "Show Run's Left Boundary 3D"
StairsDbgShowMonolithicSupportCorseGeom | "Show Monolithic Support Corse Geometry"
StairsDbgShowMonolithicSupportGeom | "Show Monolithic Support Geometry"
StairsDbgShowRightRunBoundary2d | "Show Run's Right Boundary 2D"
StairsDbgShowRightRunBoundary3d | "Show Run's Right Boundary 3D"
StairsDbgShowRunCorseGeom | "Show Run Corse Geometry"
StairsDbgShowRunGeom | "Show Run Geometry"
StairsDbgShowRunNosing | "Show Run's Nosings"
StairsDbgShowRunOutlineForPlan | "Show Run Outline For Plan"
StairsDbgShowRunPath2d | "Show Run's Path 2D"
StairsDbgShowRunPath3d | "Show Run's Path 3D"
StairsDbgShowRunRiser | "Show Run's Risers"
StairsDbgShowSupportPath | "Show Support Path"
StairsDbgShowTreadFaces | "Show Run's Tread Faces"
StairsDbgShowTriserCorseGeom | "Show Triser Corse Geometry"
StairsDbgShowTriserGeom | "Show Triser Geometry"
StairsDesiredNumberOfRisers | "Desired Number of Risers": The number of risers is calculated based on stairs height
StairsDesiredNumRisers | "Desired Number of Risers"
StairsDownText | "Down Text"
StairsEnableCalculationRuleChecking | "Enable Calculator Rules Check": Enable calculation rule checking
StairsInstAlwaysUp | "Show Up arrow in all views"
StairsInstDownArrowOn | "Down arrow"
StairsInstDownLabelOn | "Down label"
StairsInstDownLabelText | "Down text"
StairsInstUpArrowOn | "Up arrow"
StairsInstUpLabelOn | "Up label"
StairsInstUpLabelText | "Up text"
StairsLandingBaseElevation | "Relative Height": Height
StairsLandingOverridden | "Overridden": Overridden
StairsLandingStructural | "Structural": Structural
StairsLandingThickness | "Total Thickness": Thickness
StairsLandingtypeHasMonolithicSupport | "Monolithic Support": Monolithic Support
StairsLandingtypeLandingMaterial | "Monolithic Material": Landing Material
StairsLandingtypeStructure | "Structure": Structure
StairsLandingtypeThickness | "Monolithic Thickness": Default thickness
StairsLandingtypeTreadriserType | "Type": Tread/Riser Type
StairsLandingtypeUseSameTriserAsRun | "Same as Run": Same as Run
StairsMinAutomaticLandingDepth | "Minimum Automatic Landing Depth": The minimum depth of automatic landing
StairsMultistoryTopLevelParam | "Multistory Top Level"
StairsMultistoryUpToLevel | "Multistory Top Level": The top level of multi-story stairs
StairsPathFullStepArrow | "Full Step Arrow"
StairsPathStartExtension | "Start Extension"
StairsPathStartFromRiser | "Start from Riser"
StairsRailingAngledConnection | "Angled Joins"
StairsRailingBalusterBottomAngle | "Bottom Cut Angle"
StairsRailingBalusterFamily | "Baluster Family"
StairsRailingBalusterHeight | "Baluster Height"
StairsRailingBalusterIsPost | "Post"
StairsRailingBalusterLength | "Baluster Length"
StairsRailingBalusterOffset | "Baluster Offset"
StairsRailingBalusterPlacement | "Baluster Placement"
StairsRailingBalusterShape | "Baluster Shape"
StairsRailingBalusterSlopeAngle | "Slope Angle"
StairsRailingBalusterSpacing | "Baluster Separation"
StairsRailingBalusterSpacingType | "Baluster Spacing Type (Stair Railing Only)"
StairsRailingBalustersPerTread | "Balusters Per Tread (Stair Railing Only)"
StairsRailingBalusterTopAngle | "Top Cut Angle"
StairsRailingBalusterWidth | "Baluster Width"
StairsRailingBaseLevelParam | "Base Level"
StairsRailingConnection | "Rail Connections"
StairsRailingHeight | "Railing Height"
StairsRailingHeightOffset | "Base Offset"
StairsRailingHeightShiftType | "Use Landing Height Adjustment"
StairsRailingHeightShiftVal | "Landing Height Adjustment"
StairsRailingPlacementOffset | "Offset from Path"
StairsRailingRailHeight | "Rail Height"
StairsRailingRailName | "Name"
StairsRailingRailOffset | "Rail Offset"
StairsRailingRailStructure | "Rail Structure (Non-Continuous)"
StairsRailingShape | "Rail Shape"
StairsRailingTangentConnection | "Tangent Joins"
StairsRailingThickness | "Railing Thickness"
StairsRailingWidth | "Railing Width"
StairsRunActualNumberOfRisers | "Actual Number of Risers": Actual Number of Risers
StairsRunActualNumberOfTreads | "Actual Number of Treads": Actual Number of Treads
StairsRunActualRiserHeight | "Actual Riser Height": Actual Riser Height
StairsRunActualRunWidth | "Actual Run Width": Actual Run Width
StairsRunActualTreadDepth | "Actual Tread Depth": Actual Tread Depth
StairsRunBeginWithRiser | "Begin with Riser": Begin with Riser
StairsRunBottomElevation | "Relative Base Height": Relative height to stairs bottom elevation
StairsRunCcw | "CCW": Revert the run preview
StairsRunCenterMarkVisible | "Center Mark Visible": Center Mark Visible
StairsRunCreateAutoLanding | "With Automatic Landing": Create automatic landing
StairsRunEndWithRiser | "End with Riser": End with Riser
StairsRunExtendBelowRiserBase | "Extend Below Riser Base": Extend Below Base
StairsRunExtendBelowTreadBase | "Extend Below Tread Base": Extend Below Tread Base
StairsRunHeight | "Run Height": Run Height
StairsRunLocationpathJustfication | "Location Line": Location Line
StairsRunOverridden | "Overridden": Overridden
StairsRunStructural | "Structural": Structural
StairsRunTopElevation | "Relative Top Height": Top height of run
StairsRuntypeHasMonolithicSupport | "Monolithic Support": Monolithic Support
StairsRuntypeRunMaterial | "Monolithic Material": Material
StairsRuntypeStructuralDepth | "Structural Depth": Structural Depth
StairsRuntypeStructure | "Structure": Structure
StairsRuntypeTotalDepth | "Total Depth": Total Depth
StairsRuntypeUndersideSurfaceType | "Underside Surface": Underside Surface
StairsRunWidthMeasurement | "Run Width Measurement": Run Width Measurement
StairsRunWinderBeginWithStraight | "Begin with Straight Run": Winder begin with straight run
StairsRunWinderEndWithStraight | "End with Straight Run": Winder end with straight run
StairsShowDownText | "Show Down Text"
StairsShowUpText | "Show Up Text"
StairsStairsHeight | "Desired Stair Height": Stairs unconnected height
StairsStringersPresent | "Stringer Position"
StairsSupportHorizontalOffset | "Lateral Offset": Distance from center or edge of boundary
StairsSupportLandingsupportType | "Landing Support Type": Landing Support Type
StairsSupportLowerEndCut | "Lower End Cut": Lower End Cut
StairsSupportOverridden | "Overridden": Overridden
StairsSupportTrimSupportUpper | "Trim Support at Upper": Trim Support at Upper
StairsSupporttypeFlipSectionProfile | "Flip Section Profile": Flip Section Profile
StairsSupporttypeMaterial | "Material": Material
StairsSupporttypeSectionProfile | "Section Profile": Section Profile
StairsSupporttypeStructuralDepth | "Structural Depth": Structural Depth
StairsSupporttypeStructuralDepthOnLanding | "Structural Depth On Landing": Structural Depth
StairsSupporttypeStructuralDepthOnRun | "Structural Depth On Run": Structural Depth
StairsSupporttypeTopsideSurface | "Topside Surface": Topside Surface
StairsSupporttypeTotalDepth | "Total Depth": Total Depth
StairsSupporttypeUndersideSurface | "Underside Surface": Underside Surface
StairsSupporttypeWidth | "Width": Width
StairsSupportUpperEndCut | "Upper End Cut": Upper End Cut
StairsSupportVerticalOffset | "Vertical Offset": Distance of top plane of edge stringer relative to the plane connecting tread nosing
StairsTextOrientation | "Orientation"
StairsTextType | "Text Type"
StairsTopLevel | "Top Level": The top level of stairs
StairsTopLevelParam | "Top Level"
StairsTopOffset | "Top Offset"
StairsTotalNumberOfRisers | "Total Number of Risers": Total number of risers
StairsTotalNumberOfTreads | "Total Number of Treads": Total number of treads
StairsTriserIsTypeOverridden | "Overridden": (OBSOLETE) Indicate whether selected individual step is governed by default type setting.
StairsTriserNumberBaseIndex | "Tread/Riser Start Number":
StairsTriserRiserMark | "Riser Mark": (OBSOLETE)
StairsTriserRiserNumber | "Riser Number": Count the sequential number of riser in the stair.
StairsTriserTreadMark | "Tread Mark": (OBSOLETE)
StairsTriserTreadNumber | "Tread Number": Count the sequential number of tread in the stair.
StairsTrisertypeBackNosing | "Back Nosing": (OBSOLETE)
StairsTrisertypeFrontNosing | "Front Nosing": (OBSOLETE)
StairsTrisertypeLeftNosing | "Left Nosing": (OBSOLETE)
StairsTrisertypeNosingLength | "Nosing Length"
StairsTrisertypeNosingPlacement | "Apply Nosing Profile"
StairsTrisertypeNosingProfile | "Nosing Profile"
StairsTrisertypeRightNosing | "Right Nosing": (OBSOLETE)
StairsTrisertypeRiser | "Riser"
StairsTrisertypeRiserIsSlanted | "Slanted"
StairsTrisertypeRiserMaterial | "Riser Material"
StairsTrisertypeRiserProfile | "Riser Profile"
StairsTrisertypeRiserStyle | "Riser Type": (OBSOLETE)
StairsTrisertypeRiserThickness | "Riser Thickness"
StairsTrisertypeRiserTreadConnection | "Riser To Tread Connection"
StairsTrisertypeTread | "Tread"
StairsTrisertypeTreadMaterial | "Tread Material"
StairsTrisertypeTreadProfile | "Tread Profile"
StairsTrisertypeTreadThickness | "Tread Thickness"
StairstypeCalcRuleMaxResult | "Max. Result": Calculation Rule Max Result
StairstypeCalcRuleMinResult | "Min. Result": Calculation Rule Min Result
StairstypeCalcRuleRiserMultiplier | "Riser Multiplier": Calculation Rule Riser Multiplier
StairstypeCalcRuleTargetResult | "Target Result": Calculation Rule Target Result
StairstypeCalcRuleTreadMultiplier | "Tread Multiplier": Calculation Rule Tread Multiplier
StairstypeCalculationRules | "Calculation Rules": Calculation Rules
StairstypeConstructionMethod | "Construction Method":
StairstypeCutmarkType | "Cut Mark Type": Cut Mark Type
StairstypeGeomunjoinedEndCutStyle | "Connection Method": Cut Style for Geometrically Unjoined End
StairstypeHasIntermediateSupport | "Middle Support": Whether stairs is assembled
StairstypeHasLeftSupport | "Left Support":
StairstypeHasRightSupport | "Right Support":
StairstypeIntermediateSupportType | "Middle Support Type": Intermediate Support Type
StairstypeIsAssembledStairs | "Assembled Stair": Whether stairs is assembled
StairstypeLandingType | "Landing Type": Landing Type
StairstypeLeftSideSupportType | "Left Support Type": Left Side Support Type
StairstypeLeftSupportLateralOffset | "Left Lateral Offset":
StairstypeMaximumRiserHeight | "Max. Riser Height": Maximum Riser Height
StairstypeMinimumRunWidth | "Minimum Run Width": Minimum Run Width
StairstypeMinimumTreadDepth | "Min. Tread Depth": Minimum Tread Depth
StairstypeMinimumTreadWidthInsideBoundary | "Min. Tread Depth on Winder Inner Boundary": Minimum Tread Width on Inside Boundary
StairstypeNotchCustomWidth | "Custom":
StairstypeNotchExtension | "Notch Extension":
StairstypeNotchHorizontalGap | "Horizontal Gap Distance":
StairstypeNotchThickness | "Notch Thickness":
StairstypeNotchVerticalGap | "Vertical Gap Distance":
StairstypeNotchWidth | "Notch Width":
StairstypeNumberOfIntermediateSupports | "Middle Support Number": Number of intermediate supports
StairstypeRightSideSupportType | "Right Support Type": Right Side Support Type
StairstypeRightSupportLateralOffset | "Right Lateral Offset":
StairstypeRunType | "Run Type": Run Type
StairstypeShowCutline | "Show Cut Line in Plan": Show Cut Line in Plan
StairstypeShowStairPath | "Show Stair Path in Plan": Show Stair Path in Plan
StairstypeShowUpdown | "Show Up/Down in Plan": Show Up/Down in Plan
StairstypeWinderStepFrontMeasurement | "Winder Algorithm": Winder Algorithm
StairsUpText | "Up Text"
StairsWinderpatternFilletInsideCorner | "Fillet on Corner": Fillet on inside corner
StairsWinderpatternMinimumWidthCorner | "Minimum Width on Inside Boundary": Minimum Width on Inside Boundary
StairsWinderpatternMinimumWidthInsideWalkline | "Minimum Width on Inside Walk Line": Minimum width on inside walkline
StairsWinderpatternNumberOfStraightStepsAtBegin | "Parallel Treads at Start": Number of straight steps at the begin of winder
StairsWinderpatternNumberOfStraightStepsAtEnd | "Parallel Treads at End": Number of straight steps at the begin of winder
StairsWinderpatternRadiusInterior | "Fillet Radius": The fillet corner radius on the interior boundary
StairsWinderpatternStairPathOffset | "Inside Walk Line Offset": The offset from inside walk line to interior boundary
StairsWinderpatternWinderStyle | "Winder Style": Winder Style
StartExtension | "Start Extension"
StartJoinCutback | "Start Join Cutback"
StartSymbolType | "Start Symbol Type"
StartYJustification | "Start y Justification"
StartYOffsetValue | "Start y Offset Value"
StartZJustification | "Start z Justification"
StartZOffsetValue | "Start z Offset Value"
SteelElemAnchorAssembly | "Assembly"
SteelElemAnchorDiameter | "Diameter"
SteelElemAnchorGrade | "Grade"
SteelElemAnchorLength | "Length"
SteelElemAnchorOrientation | "Anchor Orientation"
SteelElemAnchorStandard | "Standard"
SteelElemAnchorTotalWeight | "Total Weight"
SteelElemBoltAssembly | "Assembly"
SteelElemBoltCoating | "Coating"
SteelElemBoltDiameter | "Diameter"
SteelElemBoltFinishCalculationAtGap | "Finish Calculation At Gap"
SteelElemBoltGrade | "Grade"
SteelElemBoltGripLength | "Grip Length"
SteelElemBoltGripLengthIncrease | "Grip Length Increase"
SteelElemBoltInverted | "Inverted"
SteelElemBoltLength | "Bolt Length"
SteelElemBoltLocation | "Location"
SteelElemBoltStandard | "Standard"
SteelElemBoltTotalWeight | "Total Weight"
SteelElemCoating | "Coating"
SteelElemContourGapWidth | "Gap Width"
SteelElemContourSide1dist | "Boundary distance 1"
SteelElemContourSide2dist | "Boundary distance 2"
SteelElemCopeAroundAxis | "Around beam axis"
SteelElemCopeAxisAngle | "Tilt angle"
SteelElemCopeDistanceAxis | "Distance from axis"
SteelElemCopeWidthx | "Cutback"
SteelElemCopeXAngle | "Cross-section rotation"
SteelElemCopeZAngle | "Plan rotation"
SteelElemCutLength | "Cut Length"
SteelElemCutType | "Type"
SteelElemExactWeight | "Exact Weight"
SteelElemHoleAlpha | "Taper Angle"
SteelElemHoleAngle | "Chamfer angle"
SteelElemHoleBackTaperThread | "Back taper thread"
SteelElemHoleDefinition | "Hole Definition"
SteelElemHoleDepth | "Hole Depth"
SteelElemHoleDepthOfBoltHead | "Depth of bolt head"
SteelElemHoleDiameter | "Diameter"
SteelElemHoleHeadDiameter | "Head diameter"
SteelElemHoleSlotDirection | "Along side 1"
SteelElemHoleSlotLength | "Length of the slot"
SteelElemHoleTapping | "Right-handed thread"
SteelElemHoleTappingHole | "Tapping hole"
SteelElemHoleType | "Type"
SteelElemPaintArea | "Paint Area"
SteelElemParamBoringout | "Boring out"
SteelElemParamRadius | "Radius"
SteelElemPatternEdgeDistanceX | "Edge distance on side 1"
SteelElemPatternEdgeDistanceY | "Edge distance on side 2"
SteelElemPatternIntermediateDistanceX | "Intermediate distance on side 1"
SteelElemPatternIntermediateDistanceY | "Intermediate distance on side 2"
SteelElemPatternNumber | "Number"
SteelElemPatternNumberX | "Number on side 1"
SteelElemPatternNumberY | "Number on side 2"
SteelElemPatternRadius | "Radius"
SteelElemPatternTotalLength | "Length on side 1"
SteelElemPatternTotalWidth | "Length on side 2"
SteelElemPlateArea | "Area"
SteelElemPlateExactWeight | "Exact Weight"
SteelElemPlateJustification | "Justification"
SteelElemPlateLength | "Length"
SteelElemPlatePaintArea | "Paint Area"
SteelElemPlateShortenAngle | "Angle"
SteelElemPlateShortenCutstraight | "Cut straight"
SteelElemPlateShortenSuction | "Suction"
SteelElemPlateThickness | "Thickness"
SteelElemPlateType | "Type"
SteelElemPlateVolume | "Volume"
SteelElemPlateWeight | "Weight"
SteelElemPlateWidth | "Width"
SteelElemProfileLength | "Length"
SteelElemProfileType | "Profile Type"
SteelElemProfileVolume | "Volume"
SteelElemShearstudDiameter | "Diameter"
SteelElemShearstudGrade | "Grade"
SteelElemShearstudLength | "Length"
SteelElemShearstudStandard | "Standard"
SteelElemShearstudTotalWeight | "Total Weight"
SteelElemShortenAngley | "Angle along height"
SteelElemShortenAnglez | "Angle along width"
SteelElemShortenReflength | "Length"
SteelElemWeight | "Weight"
SteelElemWeldContinuous | "Continuous"
SteelElemWeldDoubleEffectivethroat | "Double Effective Throat"
SteelElemWeldDoublePrepdepth | "Double Preparation Depth"
SteelElemWeldDoubleRootopening | "Double Root Opening"
SteelElemWeldDoubleSurfaceshape | "Double Surface Shape"
SteelElemWeldDoubleText | "Double Text"
SteelElemWeldDoubleThickness | "Double Thickness"
SteelElemWeldDoubleType | "Double Type"
SteelElemWeldDoubleWeldprep | "Double Weld preparation"
SteelElemWeldLength | "Length"
SteelElemWeldLocation | "Location"
SteelElemWeldMainEffectivethroat | "Main Effective Throat"
SteelElemWeldMainPrepdepth | "Main Preparation Depth"
SteelElemWeldMainRootopening | "Main Root Opening"
SteelElemWeldMainSurfaceshape | "Surface Shape"
SteelElemWeldMainText | "Main Text"
SteelElemWeldMainThickness | "Main Thickness"
SteelElemWeldMainType | "Main Type"
SteelElemWeldMainWeldprep | "Main Weld preparation"
SteelElemWeldPitch | "Pitch"
SteelElemWeldPrefix | "Prefix"
SteelElemWeldTextModule | "Text module"
SteelElemXDistance | "Side 1"
SteelElemYDistance | "Side 2"
SteelElemZclipType | "Boundary"
StiffenerClassification | "Classification"
StructConnectionApplyTo | "Apply to"
StructConnectionBeamEnd | "End Connection"
StructConnectionBeamStart | "Start Connection"
StructConnectionColumnBase | "Base Connection"
StructConnectionColumnTop | "Top Connection"
StructConnectionCutback | "Automatic Cutback for Beams and Braces"
StructConnectionTypeName | "Name"
StructFramJoinStatus | "Join Status"
StructuralAnalyticalBeamHorizontalProjectionPlane | "Horizontal Projection"
StructuralAnalyticalBeamRigidLink | "Analytical Links"
StructuralAnalyticalColumnHorizontalProjectionPlane | "Horizontal Projection"
StructuralAnalyticalColumnRigidLink | "Analytical Links"
StructuralAnalyticalHardPoints | "Use hard-points"
StructuralAnalyticalModel | "Enable Analytical Model"
StructuralAnalyticalProjectFloorPlane | "Vertical Projection"
StructuralAnalyticalProjectMemberPlane | "Vertical Projection"
StructuralAnalyticalProjectMemberPlaneColumnBottom | "Bottom Vertical Projection"
StructuralAnalyticalProjectMemberPlaneColumnTop | "Top Vertical Projection"
StructuralAnalyticalTessDeviation | "Maximum discretized offset"
StructuralAnalyticalTessellate | "Approximate curve"
StructuralAnalyzesAs | "Analyze As"
StructuralAssetParam | "Physical Material Asset"
StructuralAttachmentBaseDistance | "Base Attachment Distance"
StructuralAttachmentBaseRatio | "Base Attachment Ratio"
StructuralAttachmentBaseReferencedend | "Base Attachment Referenced End"
StructuralAttachmentBaseType | "Base Attachment Type"
StructuralAttachmentEndLevelReference | "End Attachment Level Reference"
StructuralAttachmentEndRefelementEnd | "End of Attachment to Reference Element"
StructuralAttachmentEndType | "End Attachment Type"
StructuralAttachmentEndValueDistance | "End Attachment Distance"
StructuralAttachmentEndValueElevation | "End Attachment Elevation"
StructuralAttachmentEndValueRatio | "End attachment ratio"
StructuralAttachmentStartLevelReference | "Start Attachment Level Reference"
StructuralAttachmentStartRefelementEnd | "Start of Attachment to Reference Element"
StructuralAttachmentStartType | "Start Attachment Type"
StructuralAttachmentStartValueDistance | "Start Attachment Distance"
StructuralAttachmentStartValueElevation | "Start Attachment Elevation"
StructuralAttachmentStartValueRatio | "Start Attachment Ratio"
StructuralAttachmentTopDistance | "Top Attachment Distance"
StructuralAttachmentTopRatio | "Top Attachment Ratio"
StructuralAttachmentTopReferencedend | "Top Attachment Referenced End"
StructuralAttachmentTopType | "Top Attachment Type"
StructuralBeamCutbackForColumn | "Beam cutback in plan"
StructuralBeamEnd0Elevation | "Start Level Offset"
StructuralBeamEnd1Elevation | "End Level Offset"
StructuralBeamEndAttachmentDistance | "End Attachment Distance"
StructuralBeamEndAttachmentRefcolumnEnd | "End of Attachment to Reference Column"
StructuralBeamEndAttachmentType | "End Attachment Type"
StructuralBeamEndSupport | "Beam End Pocket Seat"
StructuralBeamOrientation | "Orientation"
StructuralBeamStartAttachmentDistance | "Start Attachment Distance"
StructuralBeamStartAttachmentRefcolumnEnd | "Start of Attachment to Reference Column"
StructuralBeamStartAttachmentType | "Start Attachment Type"
StructuralBeamStartSupport | "Beam Start Pocket Seat"
StructuralBendDirAngle | "Cross-Section Rotation"
StructuralBottomReleaseFx | "Base Fx"
StructuralBottomReleaseFy | "Base Fy"
StructuralBottomReleaseFz | "Base Fz"
StructuralBottomReleaseMx | "Base Mx"
StructuralBottomReleaseMy | "Base My"
StructuralBottomReleaseMz | "Base Mz"
StructuralBottomReleaseType | "Base Release"
StructuralBraceRepresentation | "Representation Type"
StructuralCamber | "Camber Size"
StructuralConnectionApprovalStatus | "Approval Status"
StructuralConnectionCodeCheckingStatus | "Code Checking Status"
StructuralConnectionEditRangesOfApplicability | "Modify Ranges of applicability"
StructuralConnectionEditType | "Modify Parameters"
StructuralConnectionInputElements | "Input Elements"
StructuralConnectionModifyConnectionParameters | "Detailed Parameters"
StructuralConnectionNobleStatus | "Noble Status"
StructuralConnectionOverrideType | "Override by Instance"
StructuralConnectionSymbol | "Connection Symbol"
StructuralCopingDistance | "Coping Distance"
StructuralDisplayInHiddenViews | "Display in Hidden Views"
StructuralDisplayInHiddenViewsColumn | "Display in Hidden Views"
StructuralDisplayInHiddenViewsFraming | "Display in Hidden Views"
StructuralElevationAtBottom | "Elevation at Bottom"
StructuralElevationAtBottomCore | "Elevation at Bottom Core"
StructuralElevationAtBottomSurvey | "Elevation at Bottom Survey"
StructuralElevationAtTop | "Elevation at Top"
StructuralElevationAtTopCore | "Elevation at Top Core"
StructuralElevationAtTopSurvey | "Elevation at Top Survey"
StructuralEndReleaseFx | "End Fx"
StructuralEndReleaseFy | "End Fy"
StructuralEndReleaseFz | "End Fz"
StructuralEndReleaseMx | "End Mx"
StructuralEndReleaseMy | "End My"
StructuralEndReleaseMz | "End Mz"
StructuralEndReleaseType | "End Release"
StructuralFamilyCodeName | "Code Name"
StructuralFamilyNameKey | "Family Name Key"
StructuralFloorAnalyzesAs | "Analyze As"
StructuralFloorCoreThickness | "Core Thickness"
StructuralFoundationLength | "Length"
StructuralFoundationThickness | "Foundation Thickness"
StructuralFoundationWidth | "Width"
StructuralFrameCutLength | "Cut Length"
StructuralMaterialParam | "Structural Material"
StructuralMaterialType | "Structural Material Type"
StructuralMemberForces | "Member Forces"
StructuralNumberOfStuds | "Number of studs"
StructuralReferenceLevelElevation | "Reference Level Elevation"
StructuralSectionArea | "Section Area"
StructuralSectionBottomCutHeight | "Bottom Cut Height"
StructuralSectionBottomCutWidth | "Bottom Cut Width"
StructuralSectionCantileverHeight | "Cantilever Height"
StructuralSectionCantileverLength | "Cantilever Length"
StructuralSectionCommonAlpha | "Principal Axes Angle"
StructuralSectionCommonCentroidHoriz | "Centroid Horizontal"
StructuralSectionCommonCentroidVertical | "Centroid Vertical"
StructuralSectionCommonDiameter | "Diameter"
StructuralSectionCommonElasticModulusStrongAxis | "Elastic Modulus strong axis"
StructuralSectionCommonElasticModulusWeakAxis | "Elastic Modulus weak axis"
StructuralSectionCommonHeight | "Height"
StructuralSectionCommonMomentOfInertiaStrongAxis | "Moment of Inertia strong axis"
StructuralSectionCommonMomentOfInertiaWeakAxis | "Moment of Inertia weak axis"
StructuralSectionCommonNominalWeight | "Nominal Weight"
StructuralSectionCommonPerimeter | "Perimeter"
StructuralSectionCommonPlasticModulusStrongAxis | "Plastic Modulus strong axis"
StructuralSectionCommonPlasticModulusWeakAxis | "Plastic Modulus weak axis"
StructuralSectionCommonShearAreaStrongAxis | "Shear Area strong axis"
StructuralSectionCommonShearAreaWeakAxis | "Shear Area weak axis"
StructuralSectionCommonTorsionalModulus | "Torsional Modulus"
StructuralSectionCommonTorsionalMomentOfInertia | "Torsional Moment of Inertia"
StructuralSectionCommonWarpingConstant | "Warping Constant"
StructuralSectionCommonWidth | "Width"
StructuralSectionCprofileFoldLength | "Fold Length"
StructuralSectionHssInnerfillet | "Inner Fillet"
StructuralSectionHssOuterfillet | "Outer Fillet"
StructuralSectionIshapeBoltDiameter | "Bolt Diameter"
StructuralSectionIshapeBoltSpacing | "Bolt Spacing"
StructuralSectionIshapeBoltSpacingBetweenRows | "Bolt Spacing between Rows"
StructuralSectionIshapeBoltSpacingTwoRows | "Bolt Spacing Two Rows"
StructuralSectionIshapeBoltSpacingWeb | "Bolt Spacing web"
StructuralSectionIshapeClearWebHeight | "Clear Web Height"
StructuralSectionIshapeFlangefillet | "Flange Fillet"
StructuralSectionIshapeFlangethickness | "Flange Thickness"
StructuralSectionIshapeFlangethicknessLocation | "Flange Thickness Location"
StructuralSectionIshapeFlangeToeOfFillet | "Flange Toe of Fillet"
StructuralSectionIshapeWebfillet | "Web Fillet"
StructuralSectionIshapeWebheight | "Web Height"
StructuralSectionIshapeWebthickness | "Web Thickness"
StructuralSectionIshapeWebthicknessLocation | "Web Thickness Location"
StructuralSectionIshapeWebToeOfFillet | "Web Toe of Fillet"
StructuralSectionIweldedBottomflangethickness | "Bottom Flange Thickness"
StructuralSectionIweldedBottomflangewidth | "Bottom Flange Width"
StructuralSectionIweldedTopflangethickness | "Top Flange Thickness"
StructuralSectionIweldedTopflangewidth | "Top Flange Width"
StructuralSectionLangleBoltDiameterLongerFlange | "Bolt Diameter Longer Flange"
StructuralSectionLangleBoltDiameterShorterFlange | "Bolt Diameter Shorter Flange"
StructuralSectionLangleBoltSpacing1LongerFlange | "Bolt Spacing 1 Longer Flange"
StructuralSectionLangleBoltSpacing2LongerFlange | "Bolt Spacing 2 Longer Flange"
StructuralSectionLangleBoltSpacingShorterFlange | "Bolt Spacing Shorter Flange"
StructuralSectionLprofileLipLength | "Lip Length"
StructuralSectionNameKey | "Section Name Key"
StructuralSectionPipestandardWalldesignthickness | "Wall Design Thickness"
StructuralSectionPipestandardWallnominalthickness | "Wall Nominal Thickness"
StructuralSectionShape | "Section Shape"
StructuralSectionSigmaProfileBendWidth | "Bend Width"
StructuralSectionSigmaProfileMiddleBendWidth | "Middle Bend Length"
StructuralSectionSigmaProfileTopBendWidth | "Top Bend Length"
StructuralSectionSlopedFlangeAngle | "Sloped Flange Angle"
StructuralSectionSlopedWebAngle | "Sloped Web Angle"
StructuralSectionTopCutHeight | "Top Cut Height"
StructuralSectionTopCutWidth | "Top Cut Width"
StructuralSectionTopWebFillet | "Top Web Fillet"
StructuralSectionZprofileBottomFlangeLength | "Bottom Flange Length"
StructuralStartReleaseFx | "Start Fx"
StructuralStartReleaseFy | "Start Fy"
StructuralStartReleaseFz | "Start Fz"
StructuralStartReleaseMx | "Start Mx"
StructuralStartReleaseMy | "Start My"
StructuralStartReleaseMz | "Start Mz"
StructuralStartReleaseType | "Start Release"
StructuralStickSymbolLocation | "Stick Symbol Location"
StructuralTopReleaseFx | "Top Fx"
StructuralTopReleaseFy | "Top Fy"
StructuralTopReleaseFz | "Top Fz"
StructuralTopReleaseMx | "Top Mx"
StructuralTopReleaseMy | "Top My"
StructuralTopReleaseMz | "Top Mz"
StructuralTopReleaseType | "Top Release"
StructuralWallBottomProjectionPlane | "Bottom Vertical Projection"
StructuralWallProjectionSurface | "Horizontal Projection"
StructuralWallTopProjectionPlane | "Top Vertical Projection"
SupportHandClearance | "Hand Clearance"
SupportHeight | "Height"
SurfaceArea | "Surface Area"
SurfaceName | "Name"
SurfacePatternIdParam | "Surface fill pattern"
SurfacePerimeter | "Perimeter"
SweepBaseFloorSubcategoryId | "Subcategory of Floors"
SweepBaseOffset | "Horizontal Profile Offset"
SweepBaseRoofSubcategoryId | "Subcategory of Roofs"
SweepBaseVertOffset | "Vertical Profile Offset"
SweepMaxSegAngle | "Maximum Segment Angle"
SweepTrajSegmented | "Trajectory Segmentation"
SymbolFamilyAndTypeNamesParam | "Family and Type"
SymbolFamilyNameParam | "Family Name"
SymbolIdParam | "Type Id"
SymbolNameParam | "Type Name"
SystemEquipmentSets | "Equipment Sets"
SystemsAnalysisReportFolder | "Reports Folder Path"
SystemsAnalysisReportStyle | "Report Style"
SystemZoneLevelId | "Level"
TagAngleParam | "Angle"
TagElementCount | "Host Count"
TagElevationBase | "Elevation Base"
TagLeaderType | "Leader Type"
TagNoBreakParamStrings | "Wrap between parameters only"
TagOnPlacementUi | "Tag on Placement"
TagOrientationParam | "Orientation"
TagSampleText | "Sample Text"
TagTag | "Label"
TemplateName | "Template"
TerminationExtensionLength | "Extension Length"
TextAlignHorz | "Horizontal Align"
TextAlignment | "Text Alignment"
TextAlignVert | "Vertical Align"
TextBackground | "Background"
TextBoxVisibility | "Show Border"
TextColor | "Color"
TextDistToLine | "Text Offset"
TextFont | "Text Font"
TextPosition | "Text Position"
TextSize | "Text Size"
TextStyleBold | "Bold"
TextStyleFont | "Font"
TextStyleItalic | "Italic"
TextStyleSize | "Size"
TextStyleUnderline | "Underline"
TextTabSize | "Tab Size"
TextText | "Text"
TextWidthScale | "Width Factor"
ThermalMaterialParamCompressibility | "Compressibility"
ThermalMaterialParamElectricalResistivity | "Electrical Resistivity"
ThermalMaterialParamEmissivity | "Emissivity"
ThermalMaterialParamGasViscosity | "Gas Viscosity"
ThermalMaterialParamLiquidViscosity | "Liquid Viscosity"
ThermalMaterialParamPermeability | "Permeability"
ThermalMaterialParamPorosity | "Porosity"
ThermalMaterialParamReflectivity | "Reflectivity"
ThermalMaterialParamSpecificHeatOfVaporization | "Specific Heat of Vaporization"
ThermalMaterialParamTransmitsLight | "Transmits Light"
ThermalMaterialParamVaporPressure | "Vapor Pressure"
TickMarkPen | "Tick Mark Line Weight"
TilePatternFamrefComponentExtents | "Component Extents"
TilePatternGridCellsX | "Number of horizontal cells"
TilePatternGridCellsY | "Number of vertical cells"
TilePatternGridUnitX | "Horizontal spacing"
TilePatternGridUnitY | "Vertical spacing"
Tilt | "Tilt"
TitleFont | "Font"
TitleSize | "Size"
TitleStyleBold | "Bold"
TitleStyleItalic | "Italic"
TitleStyleUnderline | "Underline"
TopographyLinkName | "Link Name"
TopographyLinkPath | "Saved Path"
ToposolidAttrThicknessParam | "Thickness"
ToposolidContourDisplaySettingsIdParam | "Contour Display"
ToposolidContourSubcategoryId | "Subcategory"
ToposolidElevationAtBottom | "Elevation at Bottom"
ToposolidElevationAtTop | "Elevation at Top"
ToposolidFunctionParam | "Function"
ToposolidHeightabovelevelParam | "Height Offset From Level"
ToposolidInheritContours | "Inherit Contours"
ToposolidStructureIdParam | "Structure"
ToposolidSubdivideHeignt | "Sub-divide Height"
ToposolidSubdivideMaterial | "Material"
ToposolidTypeDefaultThicknessParam | "Default Thickness"
ToposurfaceContourSubcategoryId | "Subcategory"
TrapMullWidth | "Center Width"
TrussBearingChordTopBottomParam | "Bearing Chord"
TrussElementAngleParam | "Rotation Angle"
TrussElementBearingJustParam | "Bearing Vertical Justification"
TrussElementClassParam | "Engineering Type"
TrussElementCreateBottomParam | "Create Bottom Chord"
TrussElementCreateTopParam | "Create Top Chord"
TrussElementEnd0Elevation | "Start Level Offset"
TrussElementEnd1Elevation | "End Level Offset"
TrussElementReferenceLevelParam | "Reference Level"
TrussElementRotateChordsWithTruss | "Rotate Chords With Truss"
TrussElementSpanParam | "Span"
TrussElementStickJustParam | "Stick Symbol Location"
TrussElementTagNewMembersView | "Tag new members in view"
TrussFamilyBottomChordAngleParam | "Angle"
TrussFamilyBottomChordEndReleaseType | "End Release"
TrussFamilyBottomChordStartReleaseType | "Start Release"
TrussFamilyBottomChordStructuralTypesParam | "Structural Framing Type"
TrussFamilyBottomChordVerticalProjectionParam | "Analytical Vertical Projection"
TrussFamilyDiagWebAngleParam | "Angle"
TrussFamilyDiagWebEndReleaseType | "End Release"
TrussFamilyDiagWebStartReleaseType | "Start Release"
TrussFamilyDiagWebStructuralTypesParam | "Structural Framing Type"
TrussFamilyTopChordAngleParam | "Angle"
TrussFamilyTopChordEndReleaseType | "End Release"
TrussFamilyTopChordStartReleaseType | "Start Release"
TrussFamilyTopChordStructuralTypesParam | "Structural Framing Type"
TrussFamilyTopChordVerticalProjectionParam | "Analytical Vertical Projection"
TrussFamilyTransformationParam | "Web Orientation"
TrussFamilyVertWebAngleParam | "Angle"
TrussFamilyVertWebEndReleaseType | "End Release"
TrussFamilyVertWebStartReleaseType | "Start Release"
TrussFamilyVertWebStructuralTypesParam | "Structural Framing Type"
TrussFamilyWebsHaveSymbolicCutbackParam | "Webs have symbolic cutback"
TrussHeight | "Truss Height"
TrussLength | "Truss Length"
TrussNonBearingOffsetParam | "Non Bearing Offset"
TypeWallClosure | "Wall Closure"
UniformatCode | "Assembly Code"
UniformatDescription | "Assembly Description"
ViewAnalysisDisplayStyle | "Default Analysis Display Style"
ViewAnalysisResultsVisibility | "Analysis Display Settings"
ViewAssociatedAssemblyInstanceId | "Associated Assembly Instance"
ViewBackClipping | "Depth Clipping"
ViewCameraOrientation | "Locked Orientation"
ViewCameraPosition | "Camera Position"
ViewCleanJoins | "Wall Join Display"
ViewDependency | "Dependency"
ViewDepth | "View Depth"
ViewDescription | "Title on Sheet"
ViewDesignOptionsConfig | "Design Option Configuration"
ViewDetailLevel | "Detail Level"
ViewDiscipline | "Discipline"
Viewer3dRenderSettings | "Rendering Settings"
ViewerAnnotationCropActive | "Annotation Crop"
ViewerBoundActiveBottom | "Bottom Clip Active"
ViewerBoundActiveFar | "Far Clip Active"
ViewerBoundActiveLeft | "Left Clip Active"
ViewerBoundActiveNear | "Near Clip Active"
ViewerBoundActiveRight | "Right Clip Active"
ViewerBoundActiveTop | "Top Clip Active"
ViewerBoundFarClipping | "Far Clipping"
ViewerBoundOffsetBottom | "Bottom Clip Offset"
ViewerBoundOffsetFar | "Far Clip Offset"
ViewerBoundOffsetLeft | "Left Clip Offset"
ViewerBoundOffsetNear | "Near Clip Offset"
ViewerBoundOffsetRight | "Right Clip Offset"
ViewerBoundOffsetTop | "Top Clip Offset"
ViewerCropRegion | "Crop View"
ViewerCropRegionDisabled | "Crop View"
ViewerCropRegionVisible | "Crop Region Visible"
ViewerDetailNumber | "Detail Number"
ViewerEyeElevation | "Eye Elevation"
ViewerIsReference | "Is a Reference"
ViewerModelClipBoxActive | "Section Box"
ViewerOptionVisibility | "Visible In Option"
ViewerPerspective | "Projection Mode"
ViewerReferenceLabel | "Reference Label"
ViewerReferenceLabelText | "Reference Label"
ViewerSheetNumber | "Sheet Number"
ViewerShowUncropped | "Show uncropped"
ViewerTargetElevation | "Target Elevation"
ViewerVolumeOfInterestCrop | "Scope Box"
ViewFamily | "Family"
ViewFamilyAndTypeSchedules | "Family and Type"
ViewFamilySchedules | "Family"
ViewFixedSketchPlane | "None"
ViewGraphSchedBottomLevel | "Bottom Level"
ViewGraphSchedGridAppearance | "Grid Appearance"
ViewGraphSchedGroupSimilar | "Group Similar Locations"
ViewGraphSchedHiddenLevels | "Hidden Levels"
ViewGraphSchedLevelRelativeBaseType | "Elevation Base for Levels"
ViewGraphSchedLocationsHigh | "Column Locations End"
ViewGraphSchedLocationsLow | "Column Locations Start"
ViewGraphSchedMaterialTypes | "Material Types"
ViewGraphSchedNumberColumns | "Column Locations per Segment"
ViewGraphSchedOffGrid | "Include Off-Grid Columns"
ViewGraphSchedRowsCount | "Segments in Viewport"
ViewGraphSchedRowsFrom | "Segment Start in Viewport"
ViewGraphSchedTextAppearance | "Text Appearance"
ViewGraphSchedTitle | "Title"
ViewGraphSchedTopLevel | "Top Level"
ViewGraphSchedTotalColumns | "Total Column Locations"
ViewGraphSchedTotalRows | "Total Segments"
ViewGraphSchedUnitsFormat | "Off-Grid Units Format"
ViewGraphSunPath | "Sun Path"
ViewGraphSunPathSize | "Sun path size (%)"
ViewModelDisplayMode | "Display Model"
ViewName | "View Name"
ViewPartsVisibility | "Parts Visibility"
ViewPhase | "Phase"
ViewPhaseFilter | "Phase Filter"
ViewportAttrLabelTag | "Title"
ViewportAttrOrientationOnSheet | "Rotation on Sheet"
ViewportAttrPreserveTitlePosition | "Preserve Title Position"
ViewportAttrShowBox | "Show Box"
ViewportAttrShowExtensionLine | "Show Extension Line"
ViewportAttrShowLabel | "Show Title"
ViewportDetailNumber | "Detail Number"
ViewportPositioning | "Viewport Positioning"
ViewportScale | "View Scale"
ViewportSheetName | "Sheet Name"
ViewportSheetNumber | "Sheet Number"
ViewportView | "View"
ViewportViewName | "View Name"
ViewReferencingDetail | "Referencing Detail"
ViewReferencingSheet | "Referencing Sheet"
ViewScale | "Scale Value 1:"
ViewScaleCustomname | "Display Name"
ViewScaleHavename | "Display Name"
ViewScalePulldownImperial | "View Scale"
ViewScalePulldownMetric | "View Scale"
ViewSchemaSettingForBuilding | "Color Scheme"
ViewSchemaSettingForSystem | "System Color Schemes"
ViewSchemaSettingForSystemTemplate | "System Color Schemes"
ViewSheetViewportInfo | "Viewport"
ViewShowGrids | "Show Grids"
ViewShowHiddenLines | "Show Hidden Lines"
ViewShowMassing | "Show Mass"
ViewSlantedColumnSymbolOffset | "Column Symbolic Offset"
ViewSolarstudyAnimationSpeedText | "Loop animation speed"
ViewSolarstudyAnimationSpeedValue | "Loop animation speed"
ViewSolarstudyCurrentStudyTypeIndex | "Study type"
ViewSolarstudyIsLightingStudyType | "Lighting study"
ViewSolarstudyIsMultidayStudyType | "Multi-day study"
ViewSolarstudyIsSingledayStudyType | "Single day study"
ViewSolarstudyIsStillimageStudyType | "Still image study"
ViewSolarstudyLightingAltitudeText | "Lighting altitude text"
ViewSolarstudyLightingAltitudeValue | "Lighting altitude"
ViewSolarstudyLightingAzimuthText | "Lighting azimuth text"
ViewSolarstudyLightingAzimuthValue | "Lighting azimuth"
ViewSolarstudyLightingPresetIndex | "Lighting presets combo"
ViewSolarstudyMultidayDatetimeText | "Multi-day date and time text"
ViewSolarstudyMultidayFrameText | "Multi-day frame text"
ViewSolarstudyMultidayFrameValue | "Multi-day frame"
ViewSolarstudyMultidayPresetIndex | "Multi-day presets combo"
ViewSolarstudyShadowsIntensityText | "Shadows intensity text"
ViewSolarstudyShadowsIntensityValue | "Shadows intensity"
ViewSolarstudySingledayDatetimeText | "Single day date and time text"
ViewSolarstudySingledayFrameText | "Single day frame text"
ViewSolarstudySingledayFrameValue | "Single day frame"
ViewSolarstudySingledayPresetIndex | "Single day presets combo"
ViewSolarstudyStillDateText | "Still date text"
ViewSolarstudyStillDateValue | "Still date"
ViewSolarstudyStillPresetIndex | "Still presets combo"
ViewSolarstudyStillTimeText | "Still time text"
ViewSolarstudyStillTimeValue | "Still time"
ViewSolarstudySunIntensityText | "Sun intensity text"
ViewSolarstudySunIntensityValue | "Sun intensity"
ViewTemplate | "View Template"
ViewTemplateForSchedule | "View Template"
ViewType | "Family and Type"
ViewTypeSchedules | "Type"
ViewUnderlayBottomId | "Range: Base Level"
ViewUnderlayOrientation | "Underlay Orientation"
ViewUnderlayTopId | "Range: Top Level"
ViewVisibleCategories | "Visibility/Graphics Overrides"
VisGraphicsAnalyticalModel | "V/G Overrides Analytical Model"
VisGraphicsAnnotation | "V/G Overrides Annotation"
VisGraphicsCoordinationModel | "V/G Overrides Coordination Model"
VisGraphicsDesignoptions | "V/G Overrides Design Options"
VisGraphicsFilters | "V/G Overrides Filters"
VisGraphicsImport | "V/G Overrides Import"
VisGraphicsModel | "V/G Overrides Model"
VisGraphicsPointClouds | "V/G Overrides Point Clouds"
VisGraphicsRvtLinks | "V/G Overrides RVT Links"
VisGraphicsWorksets | "V/G Overrides Worksets"
VoidCutsGeometry | "Cuts Geometry"
VolumeCut | "Cut"
VolumeFill | "Fill"
VolumeNet | "Net cut/fill"
VolumeOfInterestHeight | "Height"
VolumeOfInterestName | "Name"
VolumeOfInterestViewsVisible | "Views Visible"
WalkthroughFramesCount | "Walkthrough Frames"
WallAlignKeyRefParam | "Location line to align"
WallAttrDefheightParam | "Default height"
WallAttrHeightParam | "Height"
WallAttrRoomBounding | "Room Bounding"
WallAttrWidthParam | "Width"
WallBaseConstraint | "Base Constraint"
WallBaseHeightParam | "Base height"
WallBaseOffset | "Base Offset"
WallBottomExtensionDistParam | "Base Extension Distance"
WallBottomIsAttached | "Base is Attached"
WallCrossSection | "Cross-Section"
WallHeightType | "Top Constraint"
WallKeyRefParam | "Location Line"
WallLocationLineOffsetParam | "Location Line Offset"
WallSingleSlantAngleFromVertical | "Angle From Vertical"
WallStructuralSignificant | "Structural"
WallStructuralUsageParam | "Structural Usage"
WallStructureIdParam | "Structure"
WallSweepCutByInsertsParam | "Cut by Inserts"
WallSweepCutsWallParam | "Cuts Wall"
WallSweepDefaultSetbackParam | "Default Setback"
WallSweepLevelParam | "Level"
WallSweepOffsetParam | "Offset From Level"
WallSweepOrientation | "Orientation"
WallSweepProfileParam | "Profile"
WallSweepWallOffsetParam | "Offset From Wall"
WallSweepWallSubcategoryId | "Subcategory of Walls"
WallTaperedExteriorInwardAngle | "Exterior Angle"
WallTaperedInteriorInwardAngle | "Interior Angle"
WallTaperedUseInstanceAngles | "Enable Angle Overrides"
WallTaperedWidthAtBottom | "Bottom Width"
WallTaperedWidthAtTop | "Top Width"
WallTopExtensionDistParam | "Top Extension Distance"
WallTopIsAttached | "Top is Attached"
WallTopOffset | "Top Offset"
WallTypeDefaultTaperedExteriorInwardAngle | "Default Exterior Angle"
WallTypeDefaultTaperedInteriorInwardAngle | "Default Interior Angle"
WallTypeWidthMeasuredAt | "Width Measured At"
WallUserHeightParam | "Unconnected Height"
WindowTypeId | "Type Mark"
WindowTypeName | "Name"
WitnsLineExtension | "Witness Line Extension"
WitnsLineGapToElt | "Witness Line Gap to Element"
WitnsLineTickMark | "Witness Line Tick Mark"
WrappingAtEndsParam | "Wrapping at Ends"
WrappingAtInsertsParam | "Wrapping at Inserts"
YJustification | "y Justification"
YOffsetValue | "y Offset Value"
YzJustification | "yz Justification"
ZJustification | "z Justification"
ZOffsetValue | "z Offset Value"
ZoneAirChangesPerHour | "Air Changes per Hour"
ZoneAirVolumeCalculationTypeParam | "Air Volume Calculation Type"
ZoneArea | "Occupied Area"
ZoneAreaGross | "Gross Area"
ZoneCalculatedAreaPerCoolingLoadParam | "Calculated Area per Cooling Load"
ZoneCalculatedAreaPerHeatingLoadParam | "Calculated Area per Heating Load"
ZoneCalculatedCoolingLoadParam | "Calculated Cooling Load"
ZoneCalculatedCoolingLoadPerAreaParam | "Calculated Cooling Load per area"
ZoneCalculatedHeatingLoadParam | "Calculated Heating Load"
ZoneCalculatedHeatingLoadPerAreaParam | "Calculated Heating Load per area"
ZoneCalculatedHydronicCoolingflowParam | "Calculated Hydronic Cooling Flow"
ZoneCalculatedHydronicHeatingflowParam | "Calculated Hydronic Heating Flow"
ZoneCalculatedSupplyAirflowParam | "Calculated Supply Airflow"
ZoneCalculatedSupplyAirflowPerAreaParam | "Calculated Supply Airflow per area"
ZoneCoilBypassPercentageParam | "Coil Bypass"
ZoneCoolingAirTemperatureParam | "Cooling Air Temperature"
ZoneCoolingInformationParam | "Cooling Information"
ZoneCoolingSetPointParam | "Cooling Set Point"
ZoneDehumidificationSetPointParam | "Dehumidification Set Point"
ZoneDesignCoolTemperature | "Design Temperature for Cooling"
ZoneDesignHeatTemperature | "Design Temperature for Heating"
ZoneHeatingAirTemperatureParam | "Heating Air Temperature"
ZoneHeatingInformationParam | "Heating Information"
ZoneHeatingSetPointParam | "Heating Set Point"
ZoneHumidificationSetPointParam | "Humidification Set Point"
ZoneLevelId | "Level"
ZoneLevelOffset | "Level Offset"
ZoneLevelOffsetTop | "Top Offset"
ZoneName | "Name"
ZoneOaRatePerAchParam | "Outdoor Air Rate / Air Changes per Hour"
ZoneOutdoorAirInformationParam | "Outdoor Air Information"
ZoneOutsideAirFlowPerArea | "Outside Air Flow per Area"
ZoneOutsideAirFlowPerPerson | "Outside Air Flow per Person"
ZoneOutsideAirPerAreaParam | "Outdoor Air per Area"
ZoneOutsideAirPerPersonParam | "Outdoor Air per Person"
ZonePerimeter | "Perimeter"
ZonePhase | "Phase"
ZonePhaseId | "Phase Id"
ZoneServiceTypeParam | "Service Type"
ZoneSpaceOutdoorAirOptionParam | "Space Outdoor Air Option"
ZoneUseAirChangesPerHourParam | "Use Air Changes Per Hour"
ZoneUseDehumidificationSetpointParam | "Use Dehumidification Set Point"
ZoneUseHumidificationSetpointParam | "Use Humidification Set Point"
ZoneUseOutsideAirPerAreaParam | "Use Outside Air Per Area"
ZoneUseOutsideAirPerPersonParam | "Use Outside Air Per Person"
ZoneVolume | "Occupied Volume"
ZoneVolumeGross | "Gross Volume"

See Also

ParameterTypeId Class


ActualMaxRidgeHeightParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ActualMaxRidgeHeightParam Property
ParameterTypeId Class See Also Send Feedback
"Maximum Ridge Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ActualMaxRidgeHeightParam { get; }
Visual Basic
Public Shared ReadOnly Property ActualMaxRidgeHeightParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ActualMaxRidgeHeightParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AlignmentStationLabelDistance Property

[image]

Revit 2024 API
ParameterTypeId..::..AlignmentStationLabelDistance Property
ParameterTypeId Class See Also Send Feedback
"Distance": Currently not in use

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AlignmentStationLabelDistance { get; }
Visual Basic
Public Shared ReadOnly Property AlignmentStationLabelDistance As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AlignmentStationLabelDistance {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AlignmentStationLabelIncludeStation Property

[image]

Revit 2024 API
ParameterTypeId..::..AlignmentStationLabelIncludeStation Property
ParameterTypeId Class See Also Send Feedback
"Include Station"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AlignmentStationLabelIncludeStation { get; }
Visual Basic
Public Shared ReadOnly Property AlignmentStationLabelIncludeStation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AlignmentStationLabelIncludeStation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AlignmentStationLabelIndStation Property

[image]

Revit 2024 API
ParameterTypeId..::..AlignmentStationLabelIndStation Property
ParameterTypeId Class See Also Send Feedback
"Station Indicator"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AlignmentStationLabelIndStation { get; }
Visual Basic
Public Shared ReadOnly Property AlignmentStationLabelIndStation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AlignmentStationLabelIndStation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AlignmentStationLabelSetInterval Property

[image]

Revit 2024 API
ParameterTypeId..::..AlignmentStationLabelSetInterval Property
ParameterTypeId Class See Also Send Feedback
"Alignment Station Label Set Interval": The text is not used directly anywhere in the UI, instead the XAML specifies its own string for the value's label.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AlignmentStationLabelSetInterval { get; }
Visual Basic
Public Shared ReadOnly Property AlignmentStationLabelSetInterval As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AlignmentStationLabelSetInterval {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AlignmentStationLabelSetOffset Property

[image]

Revit 2024 API
ParameterTypeId..::..AlignmentStationLabelSetOffset Property
ParameterTypeId Class See Also Send Feedback
"Alignment Station Label Set Offset": The text is not used directly anywhere in the UI, instead the XAML specifies its own string for the value's label.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AlignmentStationLabelSetOffset { get; }
Visual Basic
Public Shared ReadOnly Property AlignmentStationLabelSetOffset As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AlignmentStationLabelSetOffset {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AlignmentStationLabelSetStartStation Property

[image]

Revit 2024 API
ParameterTypeId..::..AlignmentStationLabelSetStartStation Property
ParameterTypeId Class See Also Send Feedback
"Alignment Label Set Start Station"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AlignmentStationLabelSetStartStation { get; }
Visual Basic
Public Shared ReadOnly Property AlignmentStationLabelSetStartStation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AlignmentStationLabelSetStartStation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AlignmentStationLabelStationValue Property

[image]

Revit 2024 API
ParameterTypeId..::..AlignmentStationLabelStationValue Property
ParameterTypeId Class See Also Send Feedback
"Station Value"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AlignmentStationLabelStationValue { get; }
Visual Basic
Public Shared ReadOnly Property AlignmentStationLabelStationValue As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AlignmentStationLabelStationValue {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AlignmentStationPrefix Property

[image]

Revit 2024 API
ParameterTypeId..::..AlignmentStationPrefix Property
ParameterTypeId Class See Also Send Feedback
"Station Prefix"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AlignmentStationPrefix { get; }
Visual Basic
Public Shared ReadOnly Property AlignmentStationPrefix As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AlignmentStationPrefix {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AlignmentStationSuffix Property

[image]

Revit 2024 API
ParameterTypeId..::..AlignmentStationSuffix Property
ParameterTypeId Class See Also Send Feedback
"Station Suffix"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AlignmentStationSuffix { get; }
Visual Basic
Public Shared ReadOnly Property AlignmentStationSuffix As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AlignmentStationSuffix {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AllGridRotationForDivisionRule Property

[image]

Revit 2024 API
ParameterTypeId..::..AllGridRotationForDivisionRule Property
ParameterTypeId Class See Also Send Feedback
"All Grid Rotation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AllGridRotationForDivisionRule { get; }
Visual Basic
Public Shared ReadOnly Property AllGridRotationForDivisionRule As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AllGridRotationForDivisionRule {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AllModelDescription Property

[image]

Revit 2024 API
ParameterTypeId..::..AllModelDescription Property
ParameterTypeId Class See Also Send Feedback
"Description"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AllModelDescription { get; }
Visual Basic
Public Shared ReadOnly Property AllModelDescription As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AllModelDescription {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AllModelImage Property

[image]

Revit 2024 API
ParameterTypeId..::..AllModelImage Property
ParameterTypeId Class See Also Send Feedback
"Image"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AllModelImage { get; }
Visual Basic
Public Shared ReadOnly Property AllModelImage As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AllModelImage {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AllModelInstanceComments Property

[image]

Revit 2024 API
ParameterTypeId..::..AllModelInstanceComments Property
ParameterTypeId Class See Also Send Feedback
"Comments"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AllModelInstanceComments { get; }
Visual Basic
Public Shared ReadOnly Property AllModelInstanceComments As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AllModelInstanceComments {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AllModelManufacturer Property

[image]

Revit 2024 API
ParameterTypeId..::..AllModelManufacturer Property
ParameterTypeId Class See Also Send Feedback
"Manufacturer"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AllModelManufacturer { get; }
Visual Basic
Public Shared ReadOnly Property AllModelManufacturer As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AllModelManufacturer {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AllModelModel Property

[image]

Revit 2024 API
ParameterTypeId..::..AllModelModel Property
ParameterTypeId Class See Also Send Feedback
"Model"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AllModelModel { get; }
Visual Basic
Public Shared ReadOnly Property AllModelModel As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AllModelModel {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AllModelTypeComments Property

[image]

Revit 2024 API
ParameterTypeId..::..AllModelTypeComments Property
ParameterTypeId Class See Also Send Feedback
"Type Comments"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AllModelTypeComments { get; }
Visual Basic
Public Shared ReadOnly Property AllModelTypeComments As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AllModelTypeComments {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AllModelTypeImage Property

[image]

Revit 2024 API
ParameterTypeId..::..AllModelTypeImage Property
ParameterTypeId Class See Also Send Feedback
"Type Image"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AllModelTypeImage { get; }
Visual Basic
Public Shared ReadOnly Property AllModelTypeImage As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AllModelTypeImage {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AllowAutoEmbed Property

[image]

Revit 2024 API
ParameterTypeId..::..AllowAutoEmbed Property
ParameterTypeId Class See Also Send Feedback
"Automatically Embed"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AllowAutoEmbed { get; }
Visual Basic
Public Shared ReadOnly Property AllowAutoEmbed As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AllowAutoEmbed {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AlternateUnits Property

[image]

Revit 2024 API
ParameterTypeId..::..AlternateUnits Property
ParameterTypeId Class See Also Send Feedback
"Alternate Units"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AlternateUnits { get; }
Visual Basic
Public Shared ReadOnly Property AlternateUnits As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AlternateUnits {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AlternateUnitsPrefix Property

[image]

Revit 2024 API
ParameterTypeId..::..AlternateUnitsPrefix Property
ParameterTypeId Class See Also Send Feedback
"Alternate Units Prefix"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AlternateUnitsPrefix { get; }
Visual Basic
Public Shared ReadOnly Property AlternateUnitsPrefix As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AlternateUnitsPrefix {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AlternateUnitsSuffix Property

[image]

Revit 2024 API
ParameterTypeId..::..AlternateUnitsSuffix Property
ParameterTypeId Class See Also Send Feedback
"Alternate Units Suffix"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AlternateUnitsSuffix { get; }
Visual Basic
Public Shared ReadOnly Property AlternateUnitsSuffix As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AlternateUnitsSuffix {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AlwaysZeroLength Property

[image]

Revit 2024 API
ParameterTypeId..::..AlwaysZeroLength Property
ParameterTypeId Class See Also Send Feedback
"Base Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AlwaysZeroLength { get; }
Visual Basic
Public Shared ReadOnly Property AlwaysZeroLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AlwaysZeroLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalAbsorptance Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalAbsorptance Property
ParameterTypeId Class See Also Send Feedback
"Absorptance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalAbsorptance { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalAbsorptance As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalAbsorptance {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalAdjacentSpace Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalAdjacentSpace Property
ParameterTypeId Class See Also Send Feedback
"Adjacent Analytical Space"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalAdjacentSpace { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalAdjacentSpace As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalAdjacentSpace {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalDefineThermalPropertiesBy Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalDefineThermalPropertiesBy Property
ParameterTypeId Class See Also Send Feedback
"Define Thermal Properties by"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalDefineThermalPropertiesBy { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalDefineThermalPropertiesBy As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalDefineThermalPropertiesBy {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalElementHasAssociation Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalElementHasAssociation Property
ParameterTypeId Class See Also Send Feedback
"Has Association": Used for Analytical Member, Analytical Panel, Structural Columns, Structural Framing, Floors, Walls, Structural Foundation

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalElementHasAssociation { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalElementHasAssociation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalElementHasAssociation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalElementPhysicalAsset Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalElementPhysicalAsset Property
ParameterTypeId Class See Also Send Feedback
"Physical Material Asset": Used for Analytical Elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalElementPhysicalAsset { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalElementPhysicalAsset As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalElementPhysicalAsset {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalElementStructuralRole Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalElementStructuralRole Property
ParameterTypeId Class See Also Send Feedback
"Structural Role": Used for Analytical Elements

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalElementStructuralRole { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalElementStructuralRole As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalElementStructuralRole {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalGeometryIsValid Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalGeometryIsValid Property
ParameterTypeId Class See Also Send Feedback
"Analytical Model Correct"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalGeometryIsValid { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalGeometryIsValid As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalGeometryIsValid {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalHeatTransferCoefficient Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalHeatTransferCoefficient Property
ParameterTypeId Class See Also Send Feedback
"Heat Transfer Coefficient (U)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalHeatTransferCoefficient { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalHeatTransferCoefficient As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalHeatTransferCoefficient {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalLinkReleaseRotationX Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalLinkReleaseRotationX Property
ParameterTypeId Class See Also Send Feedback
"X Rotation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalLinkReleaseRotationX { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalLinkReleaseRotationX As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalLinkReleaseRotationX {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalLinkReleaseRotationZ Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalLinkReleaseRotationZ Property
ParameterTypeId Class See Also Send Feedback
"Z Rotation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalLinkReleaseRotationZ { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalLinkReleaseRotationZ As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalLinkReleaseRotationZ {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalLinkReleaseTranslationX Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalLinkReleaseTranslationX Property
ParameterTypeId Class See Also Send Feedback
"X Translation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalLinkReleaseTranslationX { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalLinkReleaseTranslationX As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalLinkReleaseTranslationX {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalLinkReleaseTranslationY Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalLinkReleaseTranslationY Property
ParameterTypeId Class See Also Send Feedback
"Y Translation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalLinkReleaseTranslationY { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalLinkReleaseTranslationY As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalLinkReleaseTranslationY {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalLinkReleaseTranslationZ Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalLinkReleaseTranslationZ Property
ParameterTypeId Class See Also Send Feedback
"Z Translation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalLinkReleaseTranslationZ { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalLinkReleaseTranslationZ As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalLinkReleaseTranslationZ {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalMemberForceEndAllNonZero Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalMemberForceEndAllNonZero Property
ParameterTypeId Class See Also Send Feedback
"All non 0 forces at end"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalMemberForceEndAllNonZero { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalMemberForceEndAllNonZero As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalMemberForceEndAllNonZero {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalMemberForceEndFx Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalMemberForceEndFx Property
ParameterTypeId Class See Also Send Feedback
"End Fx"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalMemberForceEndFx { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalMemberForceEndFx As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalMemberForceEndFx {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalMemberForceEndMx Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalMemberForceEndMx Property
ParameterTypeId Class See Also Send Feedback
"End Mx"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalMemberForceEndMx { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalMemberForceEndMx As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalMemberForceEndMx {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalMemberForceEndMy Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalMemberForceEndMy Property
ParameterTypeId Class See Also Send Feedback
"End My"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalMemberForceEndMy { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalMemberForceEndMy As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalMemberForceEndMy {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalMemberForceStartAllNonZero Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalMemberForceStartAllNonZero Property
ParameterTypeId Class See Also Send Feedback
"All non 0 forces at start"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalMemberForceStartAllNonZero { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalMemberForceStartAllNonZero As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalMemberForceStartAllNonZero {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalMemberForceStartFx Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalMemberForceStartFx Property
ParameterTypeId Class See Also Send Feedback
"Start Fx"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalMemberForceStartFx { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalMemberForceStartFx As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalMemberForceStartFx {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalMemberForceStartFy Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalMemberForceStartFy Property
ParameterTypeId Class See Also Send Feedback
"Start Fy"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalMemberForceStartFy { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalMemberForceStartFy As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalMemberForceStartFy {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalMemberForceStartFz Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalMemberForceStartFz Property
ParameterTypeId Class See Also Send Feedback
"Start Fz"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalMemberForceStartFz { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalMemberForceStartFz As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalMemberForceStartFz {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalMemberForceStartMx Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalMemberForceStartMx Property
ParameterTypeId Class See Also Send Feedback
"Start Mx"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalMemberForceStartMx { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalMemberForceStartMx As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalMemberForceStartMx {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalMemberForceStartMy Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalMemberForceStartMy Property
ParameterTypeId Class See Also Send Feedback
"Start My"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalMemberForceStartMy { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalMemberForceStartMy As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalMemberForceStartMy {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalMemberForceStartMz Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalMemberForceStartMz Property
ParameterTypeId Class See Also Send Feedback
"Start Mz"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalMemberForceStartMz { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalMemberForceStartMz As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalMemberForceStartMz {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalMemberSectionType Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalMemberSectionType Property
ParameterTypeId Class See Also Send Feedback
"Section Type": The id of the type from the structural Family assigned to the analytical member.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalMemberSectionType { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalMemberSectionType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalMemberSectionType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalModelBaseAlignmentMethod Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalModelBaseAlignmentMethod Property
ParameterTypeId Class See Also Send Feedback
"Base Alignment Method"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalModelBaseAlignmentMethod { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalModelBaseAlignmentMethod As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalModelBaseAlignmentMethod {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalModelBaseYProjection Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalModelBaseYProjection Property
ParameterTypeId Class See Also Send Feedback
"Base y Projection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalModelBaseYProjection { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalModelBaseYProjection As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalModelBaseYProjection {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalModelCodeChecking Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalModelCodeChecking Property
ParameterTypeId Class See Also Send Feedback
"Code Checking": Used for Analytical wall, Analytical beam, Analytical column, Analytical floor, Analytical wall foundations, Analytical isolated foundations, Analytical foundations slab, Anaytical brace

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalModelCodeChecking { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalModelCodeChecking As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalModelCodeChecking {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalModelColumnTopExtension Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalModelColumnTopExtension Property
ParameterTypeId Class See Also Send Feedback
"Top x Projection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalModelColumnTopExtension { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalModelColumnTopExtension As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalModelColumnTopExtension {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalModelEndYProjection Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalModelEndYProjection Property
ParameterTypeId Class See Also Send Feedback
"End y Projection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalModelEndYProjection { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalModelEndYProjection As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalModelEndYProjection {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalModelEndZProjection Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalModelEndZProjection Property
ParameterTypeId Class See Also Send Feedback
"End z Projection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalModelEndZProjection { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalModelEndZProjection As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalModelEndZProjection {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalModelFloorAlignmentMethod Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalModelFloorAlignmentMethod Property
ParameterTypeId Class See Also Send Feedback
"Alignment Method"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalModelFloorAlignmentMethod { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalModelFloorAlignmentMethod As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalModelFloorAlignmentMethod {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalModelFloorProjection Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalModelFloorProjection Property
ParameterTypeId Class See Also Send Feedback
"z Projection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalModelFloorProjection { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalModelFloorProjection As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalModelFloorProjection {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalModelFoundationsMark Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalModelFoundationsMark Property
ParameterTypeId Class See Also Send Feedback
"Foundation Number": Used for isolated, wall foundations

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalModelFoundationsMark { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalModelFoundationsMark As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalModelFoundationsMark {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalModelLength Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalModelLength Property
ParameterTypeId Class See Also Send Feedback
"Length": The length of Analytical Model

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalModelLength { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalModelLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalModelLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalModelManuallyAdjusted Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalModelManuallyAdjusted Property
ParameterTypeId Class See Also Send Feedback
"Manually Adjusted"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalModelManuallyAdjusted { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalModelManuallyAdjusted As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalModelManuallyAdjusted {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalModelNodesMark Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalModelNodesMark Property
ParameterTypeId Class See Also Send Feedback
"Node Number": Used for nodes

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalModelNodesMark { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalModelNodesMark As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalModelNodesMark {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalModelPerimeter Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalModelPerimeter Property
ParameterTypeId Class See Also Send Feedback
"Perimeter": The Perimeter of Analytical Model

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalModelPerimeter { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalModelPerimeter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalModelPerimeter {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalModelPhysicalType Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalModelPhysicalType Property
ParameterTypeId Class See Also Send Feedback
"Family Type": the Family Type of the physical element associated with the Analytical Model

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalModelPhysicalType { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalModelPhysicalType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalModelPhysicalType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalModelRotation Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalModelRotation Property
ParameterTypeId Class See Also Send Feedback
"Cross-Section Rotation": The rotation of Analytical Model

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalModelRotation { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalModelRotation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalModelRotation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalModelSketchAlignmentMethod Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalModelSketchAlignmentMethod Property
ParameterTypeId Class See Also Send Feedback
"Alignment Method"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalModelSketchAlignmentMethod { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalModelSketchAlignmentMethod As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalModelSketchAlignmentMethod {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalModelStartAlignmentMethod Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalModelStartAlignmentMethod Property
ParameterTypeId Class See Also Send Feedback
"Start Alignment Method"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalModelStartAlignmentMethod { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalModelStartAlignmentMethod As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalModelStartAlignmentMethod {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalModelStartProjectionOrthogonal Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalModelStartProjectionOrthogonal Property
ParameterTypeId Class See Also Send Feedback
"Start Projection Orthogonal"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalModelStartProjectionOrthogonal { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalModelStartProjectionOrthogonal As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalModelStartProjectionOrthogonal {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalModelStartYProjection Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalModelStartYProjection Property
ParameterTypeId Class See Also Send Feedback
"Start y Projection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalModelStartYProjection { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalModelStartYProjection As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalModelStartYProjection {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalModelStartZProjection Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalModelStartZProjection Property
ParameterTypeId Class See Also Send Feedback
"Start z Projection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalModelStartZProjection { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalModelStartZProjection As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalModelStartZProjection {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalModelSurfaceElementsMark Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalModelSurfaceElementsMark Property
ParameterTypeId Class See Also Send Feedback
"Surface Number": Used for floors, slabs, walls

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalModelSurfaceElementsMark { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalModelSurfaceElementsMark As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalModelSurfaceElementsMark {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalModelTopAlignmentMethod Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalModelTopAlignmentMethod Property
ParameterTypeId Class See Also Send Feedback
"Top Alignment Method"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalModelTopAlignmentMethod { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalModelTopAlignmentMethod As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalModelTopAlignmentMethod {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalModelTopExtensionMethod Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalModelTopExtensionMethod Property
ParameterTypeId Class See Also Send Feedback
"Top Extension Method"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalModelTopExtensionMethod { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalModelTopExtensionMethod As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalModelTopExtensionMethod {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalModelTopYProjection Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalModelTopYProjection Property
ParameterTypeId Class See Also Send Feedback
"Top y Projection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalModelTopYProjection { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalModelTopYProjection As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalModelTopYProjection {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalModelTopZProjection Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalModelTopZProjection Property
ParameterTypeId Class See Also Send Feedback
"Top z Projection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalModelTopZProjection { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalModelTopZProjection As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalModelTopZProjection {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalModelWallAlignmentMethod Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalModelWallAlignmentMethod Property
ParameterTypeId Class See Also Send Feedback
"Alignment Method"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalModelWallAlignmentMethod { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalModelWallAlignmentMethod As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalModelWallAlignmentMethod {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalModelWallBaseProjection Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalModelWallBaseProjection Property
ParameterTypeId Class See Also Send Feedback
"Base y Projection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalModelWallBaseProjection { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalModelWallBaseProjection As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalModelWallBaseProjection {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalModelWallTopProjection Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalModelWallTopProjection Property
ParameterTypeId Class See Also Send Feedback
"Top y Projection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalModelWallTopProjection { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalModelWallTopProjection As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalModelWallTopProjection {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalPanelThickness Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalPanelThickness Property
ParameterTypeId Class See Also Send Feedback
"Thickness": Used for Analytical Panel

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalPanelThickness { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalPanelThickness As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalPanelThickness {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalRoughness Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalRoughness Property
ParameterTypeId Class See Also Send Feedback
"Roughness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalRoughness { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalRoughness As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalRoughness {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalSolarHeatGainCoefficient Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalSolarHeatGainCoefficient Property
ParameterTypeId Class See Also Send Feedback
"Solar Heat Gain Coefficient"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalSolarHeatGainCoefficient { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalSolarHeatGainCoefficient As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalSolarHeatGainCoefficient {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalSpace Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalSpace Property
ParameterTypeId Class See Also Send Feedback
"Analytical Space"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalSpace { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalSpace As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalSpace {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalThermalMass Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalThermalMass Property
ParameterTypeId Class See Also Send Feedback
"Thermal Mass"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalThermalMass { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalThermalMass As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalThermalMass {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalThermalResistance Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalThermalResistance Property
ParameterTypeId Class See Also Send Feedback
"Thermal Resistance (R)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalThermalResistance { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalThermalResistance As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalThermalResistance {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalVisualLightTransmittance Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalVisualLightTransmittance Property
ParameterTypeId Class See Also Send Feedback
"Visual Light Transmittance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalVisualLightTransmittance { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalVisualLightTransmittance As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalVisualLightTransmittance {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticalZone Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticalZone Property
ParameterTypeId Class See Also Send Feedback
"Analytical Zone"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticalZone { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalZone As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticalZone {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticConstruction Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticConstruction Property
ParameterTypeId Class See Also Send Feedback
"Analytic Construction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticConstruction { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticConstruction As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticConstruction {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnalyticConstructionLookupTable Property

[image]

Revit 2024 API
ParameterTypeId..::..AnalyticConstructionLookupTable Property
ParameterTypeId Class See Also Send Feedback
"Analytic Construction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnalyticConstructionLookupTable { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticConstructionLookupTable As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnalyticConstructionLookupTable {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnyPatternIdParam Property

[image]

Revit 2024 API
ParameterTypeId..::..AnyPatternIdParam Property
ParameterTypeId Class See Also Send Feedback
"Fill Pattern"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnyPatternIdParam { get; }
Visual Basic
Public Shared ReadOnly Property AnyPatternIdParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnyPatternIdParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AnyPatternIdParamNoNo Property

[image]

Revit 2024 API
ParameterTypeId..::..AnyPatternIdParamNoNo Property
ParameterTypeId Class See Also Send Feedback
"Fill Pattern"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AnyPatternIdParamNoNo { get; }
Visual Basic
Public Shared ReadOnly Property AnyPatternIdParamNoNo As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AnyPatternIdParamNoNo {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ArcLeaderParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ArcLeaderParam Property
ParameterTypeId Class See Also Send Feedback
"Arc Leaders"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ArcLeaderParam { get; }
Visual Basic
Public Shared ReadOnly Property ArcLeaderParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ArcLeaderParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ArcWallCntrMrkVisible Property

[image]

Revit 2024 API
ParameterTypeId..::..ArcWallCntrMrkVisible Property
ParameterTypeId Class See Also Send Feedback
"Center Mark Visible"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ArcWallCntrMrkVisible { get; }
Visual Basic
Public Shared ReadOnly Property ArcWallCntrMrkVisible As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ArcWallCntrMrkVisible {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AreaSchemeId Property

[image]

Revit 2024 API
ParameterTypeId..::..AreaSchemeId Property
ParameterTypeId Class See Also Send Feedback
"Area Scheme Id"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AreaSchemeId { get; }
Visual Basic
Public Shared ReadOnly Property AreaSchemeId As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AreaSchemeId {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AreaType Property

[image]

Revit 2024 API
ParameterTypeId..::..AreaType Property
ParameterTypeId Class See Also Send Feedback
"Area Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AreaType { get; }
Visual Basic
Public Shared ReadOnly Property AreaType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AreaType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AreaTypeText Property

[image]

Revit 2024 API
ParameterTypeId..::..AreaTypeText Property
ParameterTypeId Class See Also Send Feedback
"Area Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AreaTypeText { get; }
Visual Basic
Public Shared ReadOnly Property AreaTypeText As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AreaTypeText {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ArrowCentered Property

[image]

Revit 2024 API
ParameterTypeId..::..ArrowCentered Property
ParameterTypeId Class See Also Send Feedback
"Tick Mark Centered"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ArrowCentered { get; }
Visual Basic
Public Shared ReadOnly Property ArrowCentered As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ArrowCentered {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ArrowClosed Property

[image]

Revit 2024 API
ParameterTypeId..::..ArrowClosed Property
ParameterTypeId Class See Also Send Feedback
"Arrow Closed"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ArrowClosed { get; }
Visual Basic
Public Shared ReadOnly Property ArrowClosed As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ArrowClosed {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ArrowFilled Property

[image]

Revit 2024 API
ParameterTypeId..::..ArrowFilled Property
ParameterTypeId Class See Also Send Feedback
"Fill Tick"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ArrowFilled { get; }
Visual Basic
Public Shared ReadOnly Property ArrowFilled As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ArrowFilled {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ArrowheadEndAtRiser Property

[image]

Revit 2024 API
ParameterTypeId..::..ArrowheadEndAtRiser Property
ParameterTypeId Class See Also Send Feedback
"End at Riser"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ArrowheadEndAtRiser { get; }
Visual Basic
Public Shared ReadOnly Property ArrowheadEndAtRiser As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ArrowheadEndAtRiser {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ArrowheadType Property

[image]

Revit 2024 API
ParameterTypeId..::..ArrowheadType Property
ParameterTypeId Class See Also Send Feedback
"Arrowhead Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ArrowheadType { get; }
Visual Basic
Public Shared ReadOnly Property ArrowheadType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ArrowheadType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ArrowSize Property

[image]

Revit 2024 API
ParameterTypeId..::..ArrowSize Property
ParameterTypeId Class See Also Send Feedback
"Tick Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ArrowSize { get; }
Visual Basic
Public Shared ReadOnly Property ArrowSize As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ArrowSize {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ArrowType Property

[image]

Revit 2024 API
ParameterTypeId..::..ArrowType Property
ParameterTypeId Class See Also Send Feedback
"Arrow Style"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ArrowType { get; }
Visual Basic
Public Shared ReadOnly Property ArrowType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ArrowType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AssemblyNamingCategory Property

[image]

Revit 2024 API
ParameterTypeId..::..AssemblyNamingCategory Property
ParameterTypeId Class See Also Send Feedback
"Naming Category"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AssemblyNamingCategory { get; }
Visual Basic
Public Shared ReadOnly Property AssemblyNamingCategory As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AssemblyNamingCategory {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AssemblyPrecastFreeze Property

[image]

Revit 2024 API
ParameterTypeId..::..AssemblyPrecastFreeze Property
ParameterTypeId Class See Also Send Feedback
"Disable Precast Updates"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AssemblyPrecastFreeze { get; }
Visual Basic
Public Shared ReadOnly Property AssemblyPrecastFreeze As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AssemblyPrecastFreeze {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AssociatedLevelOffset Property

[image]

Revit 2024 API
ParameterTypeId..::..AssociatedLevelOffset Property
ParameterTypeId Class See Also Send Feedback
"Associated Level Offset": The offset from the associated level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AssociatedLevelOffset { get; }
Visual Basic
Public Shared ReadOnly Property AssociatedLevelOffset As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AssociatedLevelOffset {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AutoJoinCondition Property

[image]

Revit 2024 API
ParameterTypeId..::..AutoJoinCondition Property
ParameterTypeId Class See Also Send Feedback
"Join Condition"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AutoJoinCondition { get; }
Visual Basic
Public Shared ReadOnly Property AutoJoinCondition As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AutoJoinCondition {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AutoMullionBorder1Grid1 Property

[image]

Revit 2024 API
ParameterTypeId..::..AutoMullionBorder1Grid1 Property
ParameterTypeId Class See Also Send Feedback
"Border 1 Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AutoMullionBorder1Grid1 { get; }
Visual Basic
Public Shared ReadOnly Property AutoMullionBorder1Grid1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AutoMullionBorder1Grid1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AutoMullionBorder1Grid2 Property

[image]

Revit 2024 API
ParameterTypeId..::..AutoMullionBorder1Grid2 Property
ParameterTypeId Class See Also Send Feedback
"Border 1 Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AutoMullionBorder1Grid2 { get; }
Visual Basic
Public Shared ReadOnly Property AutoMullionBorder1Grid2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AutoMullionBorder1Grid2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AutoMullionBorder2Grid1 Property

[image]

Revit 2024 API
ParameterTypeId..::..AutoMullionBorder2Grid1 Property
ParameterTypeId Class See Also Send Feedback
"Border 2 Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AutoMullionBorder2Grid1 { get; }
Visual Basic
Public Shared ReadOnly Property AutoMullionBorder2Grid1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AutoMullionBorder2Grid1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AutoMullionBorder2Grid2 Property

[image]

Revit 2024 API
ParameterTypeId..::..AutoMullionBorder2Grid2 Property
ParameterTypeId Class See Also Send Feedback
"Border 2 Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AutoMullionBorder2Grid2 { get; }
Visual Basic
Public Shared ReadOnly Property AutoMullionBorder2Grid2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AutoMullionBorder2Grid2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AutoMullionBorder2Horiz Property

[image]

Revit 2024 API
ParameterTypeId..::..AutoMullionBorder2Horiz Property
ParameterTypeId Class See Also Send Feedback
"Border 2 Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AutoMullionBorder2Horiz { get; }
Visual Basic
Public Shared ReadOnly Property AutoMullionBorder2Horiz As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AutoMullionBorder2Horiz {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AutoMullionBorder2Vert Property

[image]

Revit 2024 API
ParameterTypeId..::..AutoMullionBorder2Vert Property
ParameterTypeId Class See Also Send Feedback
"Border 2 Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AutoMullionBorder2Vert { get; }
Visual Basic
Public Shared ReadOnly Property AutoMullionBorder2Vert As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AutoMullionBorder2Vert {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AutoMullionInteriorGrid1 Property

[image]

Revit 2024 API
ParameterTypeId..::..AutoMullionInteriorGrid1 Property
ParameterTypeId Class See Also Send Feedback
"Interior Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AutoMullionInteriorGrid1 { get; }
Visual Basic
Public Shared ReadOnly Property AutoMullionInteriorGrid1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AutoMullionInteriorGrid1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AutoMullionInteriorGrid2 Property

[image]

Revit 2024 API
ParameterTypeId..::..AutoMullionInteriorGrid2 Property
ParameterTypeId Class See Also Send Feedback
"Interior Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AutoMullionInteriorGrid2 { get; }
Visual Basic
Public Shared ReadOnly Property AutoMullionInteriorGrid2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AutoMullionInteriorGrid2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AutoMullionInteriorVert Property

[image]

Revit 2024 API
ParameterTypeId..::..AutoMullionInteriorVert Property
ParameterTypeId Class See Also Send Feedback
"Interior Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AutoMullionInteriorVert { get; }
Visual Basic
Public Shared ReadOnly Property AutoMullionInteriorVert As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AutoMullionInteriorVert {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AutoPanel Property

[image]

Revit 2024 API
ParameterTypeId..::..AutoPanel Property
ParameterTypeId Class See Also Send Feedback
"Curtain Panel"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AutoPanel { get; }
Visual Basic
Public Shared ReadOnly Property AutoPanel As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AutoPanel {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


AutoPanelWall Property

[image]

Revit 2024 API
ParameterTypeId..::..AutoPanelWall Property
ParameterTypeId Class See Also Send Feedback
"Curtain Panel"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId AutoPanelWall { get; }
Visual Basic
Public Shared ReadOnly Property AutoPanelWall As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AutoPanelWall {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


Azimuth Property

[image]

Revit 2024 API
ParameterTypeId..::..Azimuth Property
ParameterTypeId Class See Also Send Feedback
"Azimuth"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId Azimuth { get; }
Visual Basic
Public Shared ReadOnly Property Azimuth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Azimuth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BackgroundDraftPatternIdParam Property

[image]

Revit 2024 API
ParameterTypeId..::..BackgroundDraftPatternIdParam Property
ParameterTypeId Class See Also Send Feedback
"Background Fill Pattern"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BackgroundDraftPatternIdParam { get; }
Visual Basic
Public Shared ReadOnly Property BackgroundDraftPatternIdParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BackgroundDraftPatternIdParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BaselineDimOffset Property

[image]

Revit 2024 API
ParameterTypeId..::..BaselineDimOffset Property
ParameterTypeId Class See Also Send Feedback
"Baseline Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BaselineDimOffset { get; }
Visual Basic
Public Shared ReadOnly Property BaselineDimOffset As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BaselineDimOffset {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BasepointAngletonParam Property

[image]

Revit 2024 API
ParameterTypeId..::..BasepointAngletonParam Property
ParameterTypeId Class See Also Send Feedback
"Angle to True North"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BasepointAngletonParam { get; }
Visual Basic
Public Shared ReadOnly Property BasepointAngletonParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BasepointAngletonParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BasepointEastwestParam Property

[image]

Revit 2024 API
ParameterTypeId..::..BasepointEastwestParam Property
ParameterTypeId Class See Also Send Feedback
"E/W"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BasepointEastwestParam { get; }
Visual Basic
Public Shared ReadOnly Property BasepointEastwestParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BasepointEastwestParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BasepointElevationParam Property

[image]

Revit 2024 API
ParameterTypeId..::..BasepointElevationParam Property
ParameterTypeId Class See Also Send Feedback
"Elev"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BasepointElevationParam { get; }
Visual Basic
Public Shared ReadOnly Property BasepointElevationParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BasepointElevationParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BasepointLatitudeParam Property

[image]

Revit 2024 API
ParameterTypeId..::..BasepointLatitudeParam Property
ParameterTypeId Class See Also Send Feedback
"Lat"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BasepointLatitudeParam { get; }
Visual Basic
Public Shared ReadOnly Property BasepointLatitudeParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BasepointLatitudeParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BasepointLongitudeParam Property

[image]

Revit 2024 API
ParameterTypeId..::..BasepointLongitudeParam Property
ParameterTypeId Class See Also Send Feedback
"Lon"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BasepointLongitudeParam { get; }
Visual Basic
Public Shared ReadOnly Property BasepointLongitudeParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BasepointLongitudeParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BasepointNorthsouthParam Property

[image]

Revit 2024 API
ParameterTypeId..::..BasepointNorthsouthParam Property
ParameterTypeId Class See Also Send Feedback
"N/S"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BasepointNorthsouthParam { get; }
Visual Basic
Public Shared ReadOnly Property BasepointNorthsouthParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BasepointNorthsouthParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BeamSystem3dParam Property

[image]

Revit 2024 API
ParameterTypeId..::..BeamSystem3dParam Property
ParameterTypeId Class See Also Send Feedback
"3D"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BeamSystem3dParam { get; }
Visual Basic
Public Shared ReadOnly Property BeamSystem3dParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BeamSystem3dParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BeamSystemTagInstParamAngle Property

[image]

Revit 2024 API
ParameterTypeId..::..BeamSystemTagInstParamAngle Property
ParameterTypeId Class See Also Send Feedback
"Beam System Tag Direction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BeamSystemTagInstParamAngle { get; }
Visual Basic
Public Shared ReadOnly Property BeamSystemTagInstParamAngle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BeamSystemTagInstParamAngle {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BeamSystemTagParamRight Property

[image]

Revit 2024 API
ParameterTypeId..::..BeamSystemTagParamRight Property
ParameterTypeId Class See Also Send Feedback
"Right"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BeamSystemTagParamRight { get; }
Visual Basic
Public Shared ReadOnly Property BeamSystemTagParamRight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BeamSystemTagParamRight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BeamVJustification Property

[image]

Revit 2024 API
ParameterTypeId..::..BeamVJustification Property
ParameterTypeId Class See Also Send Feedback
"z-Direction Justification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BeamVJustification { get; }
Visual Basic
Public Shared ReadOnly Property BeamVJustification As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BeamVJustification {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BeamVJustificationOtherValue Property

[image]

Revit 2024 API
ParameterTypeId..::..BeamVJustificationOtherValue Property
ParameterTypeId Class See Also Send Feedback
"z-Direction Offset Value"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BeamVJustificationOtherValue { get; }
Visual Basic
Public Shared ReadOnly Property BeamVJustificationOtherValue As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BeamVJustificationOtherValue {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BendingDetailDetailLevel Property

[image]

Revit 2024 API
ParameterTypeId..::..BendingDetailDetailLevel Property
ParameterTypeId Class See Also Send Feedback
"Detail Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BendingDetailDetailLevel { get; }
Visual Basic
Public Shared ReadOnly Property BendingDetailDetailLevel As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BendingDetailDetailLevel {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BendingDetailSegmenetRepesentation Property

[image]

Revit 2024 API
ParameterTypeId..::..BendingDetailSegmenetRepesentation Property
ParameterTypeId Class See Also Send Feedback
"Representation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BendingDetailSegmenetRepesentation { get; }
Visual Basic
Public Shared ReadOnly Property BendingDetailSegmenetRepesentation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BendingDetailSegmenetRepesentation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BendingDetailSegmentLengthDimensionTextPosition Property

[image]

Revit 2024 API
ParameterTypeId..::..BendingDetailSegmentLengthDimensionTextPosition Property
ParameterTypeId Class See Also Send Feedback
"Dimension Text Position"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BendingDetailSegmentLengthDimensionTextPosition { get; }
Visual Basic
Public Shared ReadOnly Property BendingDetailSegmentLengthDimensionTextPosition As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BendingDetailSegmentLengthDimensionTextPosition {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BendingDetailTypeAngularDimensionOffset Property

[image]

Revit 2024 API
ParameterTypeId..::..BendingDetailTypeAngularDimensionOffset Property
ParameterTypeId Class See Also Send Feedback
"Angular Dimension Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BendingDetailTypeAngularDimensionOffset { get; }
Visual Basic
Public Shared ReadOnly Property BendingDetailTypeAngularDimensionOffset As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BendingDetailTypeAngularDimensionOffset {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BendingDetailTypeAngularDimensionsEnabled Property

[image]

Revit 2024 API
ParameterTypeId..::..BendingDetailTypeAngularDimensionsEnabled Property
ParameterTypeId Class See Also Send Feedback
"Angular Dimensions"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BendingDetailTypeAngularDimensionsEnabled { get; }
Visual Basic
Public Shared ReadOnly Property BendingDetailTypeAngularDimensionsEnabled As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BendingDetailTypeAngularDimensionsEnabled {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BendingDetailTypeAngularDimensionsForHooksEnabled Property

[image]

Revit 2024 API
ParameterTypeId..::..BendingDetailTypeAngularDimensionsForHooksEnabled Property
ParameterTypeId Class See Also Send Feedback
"Hook Angles"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BendingDetailTypeAngularDimensionsForHooksEnabled { get; }
Visual Basic
Public Shared ReadOnly Property BendingDetailTypeAngularDimensionsForHooksEnabled As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BendingDetailTypeAngularDimensionsForHooksEnabled {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BendingDetailTypeAngularDimensionsMeasurement Property

[image]

Revit 2024 API
ParameterTypeId..::..BendingDetailTypeAngularDimensionsMeasurement Property
ParameterTypeId Class See Also Send Feedback
"Angle Measurement"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BendingDetailTypeAngularDimensionsMeasurement { get; }
Visual Basic
Public Shared ReadOnly Property BendingDetailTypeAngularDimensionsMeasurement As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BendingDetailTypeAngularDimensionsMeasurement {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BendingDetailTypeAngularDimensionTypeId Property

[image]

Revit 2024 API
ParameterTypeId..::..BendingDetailTypeAngularDimensionTypeId Property
ParameterTypeId Class See Also Send Feedback
"Angular Dimension Style"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BendingDetailTypeAngularDimensionTypeId { get; }
Visual Basic
Public Shared ReadOnly Property BendingDetailTypeAngularDimensionTypeId As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BendingDetailTypeAngularDimensionTypeId {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BendingDetailTypeBendDiameterDimensionsEnabled Property

[image]

Revit 2024 API
ParameterTypeId..::..BendingDetailTypeBendDiameterDimensionsEnabled Property
ParameterTypeId Class See Also Send Feedback
"Bend Diameter Dimensions"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BendingDetailTypeBendDiameterDimensionsEnabled { get; }
Visual Basic
Public Shared ReadOnly Property BendingDetailTypeBendDiameterDimensionsEnabled As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BendingDetailTypeBendDiameterDimensionsEnabled {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BendingDetailTypeOrthogonalAndOverallDimesionsEnabled Property

[image]

Revit 2024 API
ParameterTypeId..::..BendingDetailTypeOrthogonalAndOverallDimesionsEnabled Property
ParameterTypeId Class See Also Send Feedback
"Other Dimensions"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BendingDetailTypeOrthogonalAndOverallDimesionsEnabled { get; }
Visual Basic
Public Shared ReadOnly Property BendingDetailTypeOrthogonalAndOverallDimesionsEnabled As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BendingDetailTypeOrthogonalAndOverallDimesionsEnabled {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BendingDetailTypeRadialDimensionTypeId Property

[image]

Revit 2024 API
ParameterTypeId..::..BendingDetailTypeRadialDimensionTypeId Property
ParameterTypeId Class See Also Send Feedback
"Radial Dimension Style"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BendingDetailTypeRadialDimensionTypeId { get; }
Visual Basic
Public Shared ReadOnly Property BendingDetailTypeRadialDimensionTypeId As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BendingDetailTypeRadialDimensionTypeId {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BendingDetailTypeSegmentLengthDimensionsEnabled Property

[image]

Revit 2024 API
ParameterTypeId..::..BendingDetailTypeSegmentLengthDimensionsEnabled Property
ParameterTypeId Class See Also Send Feedback
"Segment Length Dimensions"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BendingDetailTypeSegmentLengthDimensionsEnabled { get; }
Visual Basic
Public Shared ReadOnly Property BendingDetailTypeSegmentLengthDimensionsEnabled As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BendingDetailTypeSegmentLengthDimensionsEnabled {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BendingDetailTypeSegmentLengthDimensionsOffset Property

[image]

Revit 2024 API
ParameterTypeId..::..BendingDetailTypeSegmentLengthDimensionsOffset Property
ParameterTypeId Class See Also Send Feedback
"Dimension Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BendingDetailTypeSegmentLengthDimensionsOffset { get; }
Visual Basic
Public Shared ReadOnly Property BendingDetailTypeSegmentLengthDimensionsOffset As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BendingDetailTypeSegmentLengthDimensionsOffset {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BendingDetailTypeSegmentLengthDimensionTypeId Property

[image]

Revit 2024 API
ParameterTypeId..::..BendingDetailTypeSegmentLengthDimensionTypeId Property
ParameterTypeId Class See Also Send Feedback
"Linear Dimension Style"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BendingDetailTypeSegmentLengthDimensionTypeId { get; }
Visual Basic
Public Shared ReadOnly Property BendingDetailTypeSegmentLengthDimensionTypeId As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BendingDetailTypeSegmentLengthDimensionTypeId {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BendingDetailTypeSegmentLengthsDisplayOption Property

[image]

Revit 2024 API
ParameterTypeId..::..BendingDetailTypeSegmentLengthsDisplayOption Property
ParameterTypeId Class See Also Send Feedback
"Straight Segment Lengths"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BendingDetailTypeSegmentLengthsDisplayOption { get; }
Visual Basic
Public Shared ReadOnly Property BendingDetailTypeSegmentLengthsDisplayOption As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BendingDetailTypeSegmentLengthsDisplayOption {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BendingDetailTypeSegmentLengthsForArcsDisplayOption Property

[image]

Revit 2024 API
ParameterTypeId..::..BendingDetailTypeSegmentLengthsForArcsDisplayOption Property
ParameterTypeId Class See Also Send Feedback
"Arc Segment Lengths"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BendingDetailTypeSegmentLengthsForArcsDisplayOption { get; }
Visual Basic
Public Shared ReadOnly Property BendingDetailTypeSegmentLengthsForArcsDisplayOption As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BendingDetailTypeSegmentLengthsForArcsDisplayOption {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BendingDetailTypeShowAngularDimensionsFor Property

[image]

Revit 2024 API
ParameterTypeId..::..BendingDetailTypeShowAngularDimensionsFor Property
ParameterTypeId Class See Also Send Feedback
"Show for Angles"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BendingDetailTypeShowAngularDimensionsFor { get; }
Visual Basic
Public Shared ReadOnly Property BendingDetailTypeShowAngularDimensionsFor As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BendingDetailTypeShowAngularDimensionsFor {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BendingDetailTypeShowBarBendingUsing Property

[image]

Revit 2024 API
ParameterTypeId..::..BendingDetailTypeShowBarBendingUsing Property
ParameterTypeId Class See Also Send Feedback
"Dimension Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BendingDetailTypeShowBarBendingUsing { get; }
Visual Basic
Public Shared ReadOnly Property BendingDetailTypeShowBarBendingUsing As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BendingDetailTypeShowBarBendingUsing {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BendingDetailVaryingRebarDimension Property

[image]

Revit 2024 API
ParameterTypeId..::..BendingDetailVaryingRebarDimension Property
ParameterTypeId Class See Also Send Feedback
"Varying Rebar Set Dimensions"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BendingDetailVaryingRebarDimension { get; }
Visual Basic
Public Shared ReadOnly Property BendingDetailVaryingRebarDimension As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BendingDetailVaryingRebarDimension {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BentFabricParamLongitudinalCutLength Property

[image]

Revit 2024 API
ParameterTypeId..::..BentFabricParamLongitudinalCutLength Property
ParameterTypeId Class See Also Send Feedback
"Longitudinal Cut Length": Bent fabric longitudinal cut length.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BentFabricParamLongitudinalCutLength { get; }
Visual Basic
Public Shared ReadOnly Property BentFabricParamLongitudinalCutLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BentFabricParamLongitudinalCutLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BentFabricParamStraightWiresLocation Property

[image]

Revit 2024 API
ParameterTypeId..::..BentFabricParamStraightWiresLocation Property
ParameterTypeId Class See Also Send Feedback
"Straight Wires Location": Location of straight wires in a bent fabric.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BentFabricParamStraightWiresLocation { get; }
Visual Basic
Public Shared ReadOnly Property BentFabricParamStraightWiresLocation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BentFabricParamStraightWiresLocation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BlendEndParam Property

[image]

Revit 2024 API
ParameterTypeId..::..BlendEndParam Property
ParameterTypeId Class See Also Send Feedback
"Second End"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BlendEndParam { get; }
Visual Basic
Public Shared ReadOnly Property BlendEndParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BlendEndParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BlendStartParam Property

[image]

Revit 2024 API
ParameterTypeId..::..BlendStartParam Property
ParameterTypeId Class See Also Send Feedback
"First End"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BlendStartParam { get; }
Visual Basic
Public Shared ReadOnly Property BlendStartParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BlendStartParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BoundaryAreaRestraintY Property

[image]

Revit 2024 API
ParameterTypeId..::..BoundaryAreaRestraintY Property
ParameterTypeId Class See Also Send Feedback
"Y Spring Modulus"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BoundaryAreaRestraintY { get; }
Visual Basic
Public Shared ReadOnly Property BoundaryAreaRestraintY As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BoundaryAreaRestraintY {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BoundaryAreaRestraintZ Property

[image]

Revit 2024 API
ParameterTypeId..::..BoundaryAreaRestraintZ Property
ParameterTypeId Class See Also Send Feedback
"Z Spring Modulus"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BoundaryAreaRestraintZ { get; }
Visual Basic
Public Shared ReadOnly Property BoundaryAreaRestraintZ As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BoundaryAreaRestraintZ {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BoundaryBearing Property

[image]

Revit 2024 API
ParameterTypeId..::..BoundaryBearing Property
ParameterTypeId Class See Also Send Feedback
"Bearing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BoundaryBearing { get; }
Visual Basic
Public Shared ReadOnly Property BoundaryBearing As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BoundaryBearing {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BoundaryConditionsIsExt Property

[image]

Revit 2024 API
ParameterTypeId..::..BoundaryConditionsIsExt Property
ParameterTypeId Class See Also Send Feedback
"Is Boundary Conditions External?"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BoundaryConditionsIsExt { get; }
Visual Basic
Public Shared ReadOnly Property BoundaryConditionsIsExt As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BoundaryConditionsIsExt {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BoundaryConditionsType Property

[image]

Revit 2024 API
ParameterTypeId..::..BoundaryConditionsType Property
ParameterTypeId Class See Also Send Feedback
"Boundary Conditions Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BoundaryConditionsType { get; }
Visual Basic
Public Shared ReadOnly Property BoundaryConditionsType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BoundaryConditionsType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BoundaryDirectionRotX Property

[image]

Revit 2024 API
ParameterTypeId..::..BoundaryDirectionRotX Property
ParameterTypeId Class See Also Send Feedback
"X Rotation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BoundaryDirectionRotX { get; }
Visual Basic
Public Shared ReadOnly Property BoundaryDirectionRotX As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BoundaryDirectionRotX {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BoundaryDirectionRotY Property

[image]

Revit 2024 API
ParameterTypeId..::..BoundaryDirectionRotY Property
ParameterTypeId Class See Also Send Feedback
"Y Rotation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BoundaryDirectionRotY { get; }
Visual Basic
Public Shared ReadOnly Property BoundaryDirectionRotY As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BoundaryDirectionRotY {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BoundaryDirectionY Property

[image]

Revit 2024 API
ParameterTypeId..::..BoundaryDirectionY Property
ParameterTypeId Class See Also Send Feedback
"Y Translation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BoundaryDirectionY { get; }
Visual Basic
Public Shared ReadOnly Property BoundaryDirectionY As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BoundaryDirectionY {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BoundaryDirectionZ Property

[image]

Revit 2024 API
ParameterTypeId..::..BoundaryDirectionZ Property
ParameterTypeId Class See Also Send Feedback
"Z Translation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BoundaryDirectionZ { get; }
Visual Basic
Public Shared ReadOnly Property BoundaryDirectionZ As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BoundaryDirectionZ {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BoundaryDistance Property

[image]

Revit 2024 API
ParameterTypeId..::..BoundaryDistance Property
ParameterTypeId Class See Also Send Feedback
"Distance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BoundaryDistance { get; }
Visual Basic
Public Shared ReadOnly Property BoundaryDistance As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BoundaryDistance {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BoundaryLinearRestraintRotX Property

[image]

Revit 2024 API
ParameterTypeId..::..BoundaryLinearRestraintRotX Property
ParameterTypeId Class See Also Send Feedback
"X Spring Modulus"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BoundaryLinearRestraintRotX { get; }
Visual Basic
Public Shared ReadOnly Property BoundaryLinearRestraintRotX As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BoundaryLinearRestraintRotX {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BoundaryLinearRestraintY Property

[image]

Revit 2024 API
ParameterTypeId..::..BoundaryLinearRestraintY Property
ParameterTypeId Class See Also Send Feedback
"Y Spring Modulus"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BoundaryLinearRestraintY { get; }
Visual Basic
Public Shared ReadOnly Property BoundaryLinearRestraintY As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BoundaryLinearRestraintY {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BoundaryLinearRestraintZ Property

[image]

Revit 2024 API
ParameterTypeId..::..BoundaryLinearRestraintZ Property
ParameterTypeId Class See Also Send Feedback
"Z Spring Modulus"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BoundaryLinearRestraintZ { get; }
Visual Basic
Public Shared ReadOnly Property BoundaryLinearRestraintZ As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BoundaryLinearRestraintZ {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BoundaryParamPresetArea Property

[image]

Revit 2024 API
ParameterTypeId..::..BoundaryParamPresetArea Property
ParameterTypeId Class See Also Send Feedback
"State"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BoundaryParamPresetArea { get; }
Visual Basic
Public Shared ReadOnly Property BoundaryParamPresetArea As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BoundaryParamPresetArea {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BoundaryParamPresetLinear Property

[image]

Revit 2024 API
ParameterTypeId..::..BoundaryParamPresetLinear Property
ParameterTypeId Class See Also Send Feedback
"State"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BoundaryParamPresetLinear { get; }
Visual Basic
Public Shared ReadOnly Property BoundaryParamPresetLinear As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BoundaryParamPresetLinear {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BoundaryRestraintRotX Property

[image]

Revit 2024 API
ParameterTypeId..::..BoundaryRestraintRotX Property
ParameterTypeId Class See Also Send Feedback
"X Spring Modulus"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BoundaryRestraintRotX { get; }
Visual Basic
Public Shared ReadOnly Property BoundaryRestraintRotX As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BoundaryRestraintRotX {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BoundaryRestraintRotY Property

[image]

Revit 2024 API
ParameterTypeId..::..BoundaryRestraintRotY Property
ParameterTypeId Class See Also Send Feedback
"Y Spring Modulus"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BoundaryRestraintRotY { get; }
Visual Basic
Public Shared ReadOnly Property BoundaryRestraintRotY As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BoundaryRestraintRotY {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BoundaryRestraintRotZ Property

[image]

Revit 2024 API
ParameterTypeId..::..BoundaryRestraintRotZ Property
ParameterTypeId Class See Also Send Feedback
"Z Spring Modulus"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BoundaryRestraintRotZ { get; }
Visual Basic
Public Shared ReadOnly Property BoundaryRestraintRotZ As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BoundaryRestraintRotZ {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BoundaryRestraintX Property

[image]

Revit 2024 API
ParameterTypeId..::..BoundaryRestraintX Property
ParameterTypeId Class See Also Send Feedback
"X Spring Modulus"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BoundaryRestraintX { get; }
Visual Basic
Public Shared ReadOnly Property BoundaryRestraintX As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BoundaryRestraintX {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BoundaryRestraintY Property

[image]

Revit 2024 API
ParameterTypeId..::..BoundaryRestraintY Property
ParameterTypeId Class See Also Send Feedback
"Y Spring Modulus"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BoundaryRestraintY { get; }
Visual Basic
Public Shared ReadOnly Property BoundaryRestraintY As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BoundaryRestraintY {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BoundaryRestraintZ Property

[image]

Revit 2024 API
ParameterTypeId..::..BoundaryRestraintZ Property
ParameterTypeId Class See Also Send Feedback
"Z Spring Modulus"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BoundaryRestraintZ { get; }
Visual Basic
Public Shared ReadOnly Property BoundaryRestraintZ As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BoundaryRestraintZ {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BoundaryXRotationFixed Property

[image]

Revit 2024 API
ParameterTypeId..::..BoundaryXRotationFixed Property
ParameterTypeId Class See Also Send Feedback
"X Rotation - Fixed"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BoundaryXRotationFixed { get; }
Visual Basic
Public Shared ReadOnly Property BoundaryXRotationFixed As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BoundaryXRotationFixed {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BoundaryXRotationSpring Property

[image]

Revit 2024 API
ParameterTypeId..::..BoundaryXRotationSpring Property
ParameterTypeId Class See Also Send Feedback
"X Rotation - Spring"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BoundaryXRotationSpring { get; }
Visual Basic
Public Shared ReadOnly Property BoundaryXRotationSpring As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BoundaryXRotationSpring {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BoundaryXTranslationFixed Property

[image]

Revit 2024 API
ParameterTypeId..::..BoundaryXTranslationFixed Property
ParameterTypeId Class See Also Send Feedback
"X Translation - Fixed"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BoundaryXTranslationFixed { get; }
Visual Basic
Public Shared ReadOnly Property BoundaryXTranslationFixed As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BoundaryXTranslationFixed {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BoundaryYRotationFixed Property

[image]

Revit 2024 API
ParameterTypeId..::..BoundaryYRotationFixed Property
ParameterTypeId Class See Also Send Feedback
"Y Rotation - Fixed"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BoundaryYRotationFixed { get; }
Visual Basic
Public Shared ReadOnly Property BoundaryYRotationFixed As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BoundaryYRotationFixed {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BoundaryYRotationSpring Property

[image]

Revit 2024 API
ParameterTypeId..::..BoundaryYRotationSpring Property
ParameterTypeId Class See Also Send Feedback
"Y Rotation - Spring"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BoundaryYRotationSpring { get; }
Visual Basic
Public Shared ReadOnly Property BoundaryYRotationSpring As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BoundaryYRotationSpring {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BoundaryYTranslationFixed Property

[image]

Revit 2024 API
ParameterTypeId..::..BoundaryYTranslationFixed Property
ParameterTypeId Class See Also Send Feedback
"Y Translation - Fixed"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BoundaryYTranslationFixed { get; }
Visual Basic
Public Shared ReadOnly Property BoundaryYTranslationFixed As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BoundaryYTranslationFixed {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BoundaryYTranslationSpring Property

[image]

Revit 2024 API
ParameterTypeId..::..BoundaryYTranslationSpring Property
ParameterTypeId Class See Also Send Feedback
"Y Translation - Spring"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BoundaryYTranslationSpring { get; }
Visual Basic
Public Shared ReadOnly Property BoundaryYTranslationSpring As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BoundaryYTranslationSpring {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BoundaryZRotationSpring Property

[image]

Revit 2024 API
ParameterTypeId..::..BoundaryZRotationSpring Property
ParameterTypeId Class See Also Send Feedback
"Z Rotation - Spring"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BoundaryZRotationSpring { get; }
Visual Basic
Public Shared ReadOnly Property BoundaryZRotationSpring As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BoundaryZRotationSpring {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BoundaryZTranslationFixed Property

[image]

Revit 2024 API
ParameterTypeId..::..BoundaryZTranslationFixed Property
ParameterTypeId Class See Also Send Feedback
"Z Translation - Fixed"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BoundaryZTranslationFixed { get; }
Visual Basic
Public Shared ReadOnly Property BoundaryZTranslationFixed As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BoundaryZTranslationFixed {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BrOrgFilter Property

[image]

Revit 2024 API
ParameterTypeId..::..BrOrgFilter Property
ParameterTypeId Class See Also Send Feedback
"Filter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BrOrgFilter { get; }
Visual Basic
Public Shared ReadOnly Property BrOrgFilter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BrOrgFilter {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BrOrgFolders Property

[image]

Revit 2024 API
ParameterTypeId..::..BrOrgFolders Property
ParameterTypeId Class See Also Send Feedback
"Folders"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BrOrgFolders { get; }
Visual Basic
Public Shared ReadOnly Property BrOrgFolders As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BrOrgFolders {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BuildingClosingTimeParam Property

[image]

Revit 2024 API
ParameterTypeId..::..BuildingClosingTimeParam Property
ParameterTypeId Class See Also Send Feedback
"Closing Time"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BuildingClosingTimeParam { get; }
Visual Basic
Public Shared ReadOnly Property BuildingClosingTimeParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BuildingClosingTimeParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BuildingCurveGstyle Property

[image]

Revit 2024 API
ParameterTypeId..::..BuildingCurveGstyle Property
ParameterTypeId Class See Also Send Feedback
"Line Style"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BuildingCurveGstyle { get; }
Visual Basic
Public Shared ReadOnly Property BuildingCurveGstyle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BuildingCurveGstyle {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BuildingCurveGstylePlusInvisible Property

[image]

Revit 2024 API
ParameterTypeId..::..BuildingCurveGstylePlusInvisible Property
ParameterTypeId Class See Also Send Feedback
"Subcategory"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BuildingCurveGstylePlusInvisible { get; }
Visual Basic
Public Shared ReadOnly Property BuildingCurveGstylePlusInvisible As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BuildingCurveGstylePlusInvisible {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BuildingOpeningTimeParam Property

[image]

Revit 2024 API
ParameterTypeId..::..BuildingOpeningTimeParam Property
ParameterTypeId Class See Also Send Feedback
"Opening Time"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BuildingOpeningTimeParam { get; }
Visual Basic
Public Shared ReadOnly Property BuildingOpeningTimeParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BuildingOpeningTimeParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BuildingUnoccupiedCoolingSetPointParam Property

[image]

Revit 2024 API
ParameterTypeId..::..BuildingUnoccupiedCoolingSetPointParam Property
ParameterTypeId Class See Also Send Feedback
"Unoccupied Cooling Set Point"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BuildingUnoccupiedCoolingSetPointParam { get; }
Visual Basic
Public Shared ReadOnly Property BuildingUnoccupiedCoolingSetPointParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BuildingUnoccupiedCoolingSetPointParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


BuilidingPadStructureIdParam Property

[image]

Revit 2024 API
ParameterTypeId..::..BuilidingPadStructureIdParam Property
ParameterTypeId Class See Also Send Feedback
"Structure"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId BuilidingPadStructureIdParam { get; }
Visual Basic
Public Shared ReadOnly Property BuilidingPadStructureIdParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BuilidingPadStructureIdParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CabletrayMinbendmultiplierParam Property

[image]

Revit 2024 API
ParameterTypeId..::..CabletrayMinbendmultiplierParam Property
ParameterTypeId Class See Also Send Feedback
"Bend Radius Multiplier"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CabletrayMinbendmultiplierParam { get; }
Visual Basic
Public Shared ReadOnly Property CabletrayMinbendmultiplierParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CabletrayMinbendmultiplierParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CalloutAttrHeadTag Property

[image]

Revit 2024 API
ParameterTypeId..::..CalloutAttrHeadTag Property
ParameterTypeId Class See Also Send Feedback
"Callout Head"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CalloutAttrHeadTag { get; }
Visual Basic
Public Shared ReadOnly Property CalloutAttrHeadTag As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CalloutAttrHeadTag {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CalloutSyncronizeBoundOffsetFar Property

[image]

Revit 2024 API
ParameterTypeId..::..CalloutSyncronizeBoundOffsetFar Property
ParameterTypeId Class See Also Send Feedback
"Far Clip Settings"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CalloutSyncronizeBoundOffsetFar { get; }
Visual Basic
Public Shared ReadOnly Property CalloutSyncronizeBoundOffsetFar As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CalloutSyncronizeBoundOffsetFar {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CalloutTag Property

[image]

Revit 2024 API
ParameterTypeId..::..CalloutTag Property
ParameterTypeId Class See Also Send Feedback
"Callout Tag"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CalloutTag { get; }
Visual Basic
Public Shared ReadOnly Property CalloutTag As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CalloutTag {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CeilingAttrDefaultHeightParam Property

[image]

Revit 2024 API
ParameterTypeId..::..CeilingAttrDefaultHeightParam Property
ParameterTypeId Class See Also Send Feedback
"Default Height above level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CeilingAttrDefaultHeightParam { get; }
Visual Basic
Public Shared ReadOnly Property CeilingAttrDefaultHeightParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CeilingAttrDefaultHeightParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CeilingAttrPatternParam Property

[image]

Revit 2024 API
ParameterTypeId..::..CeilingAttrPatternParam Property
ParameterTypeId Class See Also Send Feedback
"Pattern"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CeilingAttrPatternParam { get; }
Visual Basic
Public Shared ReadOnly Property CeilingAttrPatternParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CeilingAttrPatternParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CeilingAttrSpacing1Param Property

[image]

Revit 2024 API
ParameterTypeId..::..CeilingAttrSpacing1Param Property
ParameterTypeId Class See Also Send Feedback
"Spacing Axis 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CeilingAttrSpacing1Param { get; }
Visual Basic
Public Shared ReadOnly Property CeilingAttrSpacing1Param As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CeilingAttrSpacing1Param {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CeilingAttrSpacing2Param Property

[image]

Revit 2024 API
ParameterTypeId..::..CeilingAttrSpacing2Param Property
ParameterTypeId Class See Also Send Feedback
"Spacing Axis 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CeilingAttrSpacing2Param { get; }
Visual Basic
Public Shared ReadOnly Property CeilingAttrSpacing2Param As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CeilingAttrSpacing2Param {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CeilingAttrSystemnameParam Property

[image]

Revit 2024 API
ParameterTypeId..::..CeilingAttrSystemnameParam Property
ParameterTypeId Class See Also Send Feedback
"System"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CeilingAttrSystemnameParam { get; }
Visual Basic
Public Shared ReadOnly Property CeilingAttrSystemnameParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CeilingAttrSystemnameParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CeilingHasThicknessParam Property

[image]

Revit 2024 API
ParameterTypeId..::..CeilingHasThicknessParam Property
ParameterTypeId Class See Also Send Feedback
"Has Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CeilingHasThicknessParam { get; }
Visual Basic
Public Shared ReadOnly Property CeilingHasThicknessParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CeilingHasThicknessParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CeilingHeightabovelevelParam Property

[image]

Revit 2024 API
ParameterTypeId..::..CeilingHeightabovelevelParam Property
ParameterTypeId Class See Also Send Feedback
"Height Offset From Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CeilingHeightabovelevelParam { get; }
Visual Basic
Public Shared ReadOnly Property CeilingHeightabovelevelParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CeilingHeightabovelevelParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CeilingStructureIdParam Property

[image]

Revit 2024 API
ParameterTypeId..::..CeilingStructureIdParam Property
ParameterTypeId Class See Also Send Feedback
"Structure"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CeilingStructureIdParam { get; }
Visual Basic
Public Shared ReadOnly Property CeilingStructureIdParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CeilingStructureIdParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CeilingThickness Property

[image]

Revit 2024 API
ParameterTypeId..::..CeilingThickness Property
ParameterTypeId Class See Also Send Feedback
"Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CeilingThickness { get; }
Visual Basic
Public Shared ReadOnly Property CeilingThickness As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CeilingThickness {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CeilingThicknessParam Property

[image]

Revit 2024 API
ParameterTypeId..::..CeilingThicknessParam Property
ParameterTypeId Class See Also Send Feedback
"Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CeilingThicknessParam { get; }
Visual Basic
Public Shared ReadOnly Property CeilingThicknessParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CeilingThicknessParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CenterMarkSize Property

[image]

Revit 2024 API
ParameterTypeId..::..CenterMarkSize Property
ParameterTypeId Class See Also Send Feedback
"Center Mark Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CenterMarkSize { get; }
Visual Basic
Public Shared ReadOnly Property CenterMarkSize As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CenterMarkSize {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CircMullionRadius Property

[image]

Revit 2024 API
ParameterTypeId..::..CircMullionRadius Property
ParameterTypeId Class See Also Send Feedback
"Radius"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CircMullionRadius { get; }
Visual Basic
Public Shared ReadOnly Property CircMullionRadius As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CircMullionRadius {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CircuitLoadClassificationAbbreviationParam Property

[image]

Revit 2024 API
ParameterTypeId..::..CircuitLoadClassificationAbbreviationParam Property
ParameterTypeId Class See Also Send Feedback
"Load Classification Abbreviation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CircuitLoadClassificationAbbreviationParam { get; }
Visual Basic
Public Shared ReadOnly Property CircuitLoadClassificationAbbreviationParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CircuitLoadClassificationAbbreviationParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CircuitLoadClassificationParam Property

[image]

Revit 2024 API
ParameterTypeId..::..CircuitLoadClassificationParam Property
ParameterTypeId Class See Also Send Feedback
"Load Classification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CircuitLoadClassificationParam { get; }
Visual Basic
Public Shared ReadOnly Property CircuitLoadClassificationParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CircuitLoadClassificationParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CircuitPhaseParam Property

[image]

Revit 2024 API
ParameterTypeId..::..CircuitPhaseParam Property
ParameterTypeId Class See Also Send Feedback
"Phase Label"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CircuitPhaseParam { get; }
Visual Basic
Public Shared ReadOnly Property CircuitPhaseParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CircuitPhaseParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CircularFramingDiameter Property

[image]

Revit 2024 API
ParameterTypeId..::..CircularFramingDiameter Property
ParameterTypeId Class See Also Send Feedback
"Circular Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CircularFramingDiameter { get; }
Visual Basic
Public Shared ReadOnly Property CircularFramingDiameter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CircularFramingDiameter {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ClearCoverBottom Property

[image]

Revit 2024 API
ParameterTypeId..::..ClearCoverBottom Property
ParameterTypeId Class See Also Send Feedback
"Rebar Cover - Bottom Face"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ClearCoverBottom { get; }
Visual Basic
Public Shared ReadOnly Property ClearCoverBottom As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ClearCoverBottom {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ClearCoverExterior Property

[image]

Revit 2024 API
ParameterTypeId..::..ClearCoverExterior Property
ParameterTypeId Class See Also Send Feedback
"Rebar Cover - Exterior Face"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ClearCoverExterior { get; }
Visual Basic
Public Shared ReadOnly Property ClearCoverExterior As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ClearCoverExterior {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ClearCoverInterior Property

[image]

Revit 2024 API
ParameterTypeId..::..ClearCoverInterior Property
ParameterTypeId Class See Also Send Feedback
"Rebar Cover - Interior Face"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ClearCoverInterior { get; }
Visual Basic
Public Shared ReadOnly Property ClearCoverInterior As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ClearCoverInterior {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ClearCoverOther Property

[image]

Revit 2024 API
ParameterTypeId..::..ClearCoverOther Property
ParameterTypeId Class See Also Send Feedback
"Rebar Cover - Other Faces"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ClearCoverOther { get; }
Visual Basic
Public Shared ReadOnly Property ClearCoverOther As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ClearCoverOther {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ClearCoverTop Property

[image]

Revit 2024 API
ParameterTypeId..::..ClearCoverTop Property
ParameterTypeId Class See Also Send Feedback
"Rebar Cover - Top Face"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ClearCoverTop { get; }
Visual Basic
Public Shared ReadOnly Property ClearCoverTop As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ClearCoverTop {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ClientName Property

[image]

Revit 2024 API
ParameterTypeId..::..ClientName Property
ParameterTypeId Class See Also Send Feedback
"Client Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ClientName { get; }
Visual Basic
Public Shared ReadOnly Property ClientName As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ClientName {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ClineSubcategory Property

[image]

Revit 2024 API
ParameterTypeId..::..ClineSubcategory Property
ParameterTypeId Class See Also Send Feedback
"Subcategory"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ClineSubcategory { get; }
Visual Basic
Public Shared ReadOnly Property ClineSubcategory As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ClineSubcategory {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CoarseScaleFillPatternColor Property

[image]

Revit 2024 API
ParameterTypeId..::..CoarseScaleFillPatternColor Property
ParameterTypeId Class See Also Send Feedback
"Coarse Scale Fill Color"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CoarseScaleFillPatternColor { get; }
Visual Basic
Public Shared ReadOnly Property CoarseScaleFillPatternColor As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CoarseScaleFillPatternColor {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CoarseScaleFillPatternIdParam Property

[image]

Revit 2024 API
ParameterTypeId..::..CoarseScaleFillPatternIdParam Property
ParameterTypeId Class See Also Send Feedback
"Coarse Scale Fill Pattern"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CoarseScaleFillPatternIdParam { get; }
Visual Basic
Public Shared ReadOnly Property CoarseScaleFillPatternIdParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CoarseScaleFillPatternIdParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ColorFillSwatchHeightParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ColorFillSwatchHeightParam Property
ParameterTypeId Class See Also Send Feedback
"Swatch Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ColorFillSwatchHeightParam { get; }
Visual Basic
Public Shared ReadOnly Property ColorFillSwatchHeightParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ColorFillSwatchHeightParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ColorFillSwatchWidthParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ColorFillSwatchWidthParam Property
ParameterTypeId Class See Also Send Feedback
"Swatch Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ColorFillSwatchWidthParam { get; }
Visual Basic
Public Shared ReadOnly Property ColorFillSwatchWidthParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ColorFillSwatchWidthParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ColorSchemeLocation Property

[image]

Revit 2024 API
ParameterTypeId..::..ColorSchemeLocation Property
ParameterTypeId Class See Also Send Feedback
"Color Scheme Location"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ColorSchemeLocation { get; }
Visual Basic
Public Shared ReadOnly Property ColorSchemeLocation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ColorSchemeLocation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ColumnBaseAttachCutParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ColumnBaseAttachCutParam Property
ParameterTypeId Class See Also Send Feedback
"Base Attachment Cut"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ColumnBaseAttachCutParam { get; }
Visual Basic
Public Shared ReadOnly Property ColumnBaseAttachCutParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ColumnBaseAttachCutParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ColumnBaseAttachedParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ColumnBaseAttachedParam Property
ParameterTypeId Class See Also Send Feedback
"Base is Attached"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ColumnBaseAttachedParam { get; }
Visual Basic
Public Shared ReadOnly Property ColumnBaseAttachedParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ColumnBaseAttachedParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ColumnBaseAttachJustificationParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ColumnBaseAttachJustificationParam Property
ParameterTypeId Class See Also Send Feedback
"Attachment Justification At Base"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ColumnBaseAttachJustificationParam { get; }
Visual Basic
Public Shared ReadOnly Property ColumnBaseAttachJustificationParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ColumnBaseAttachJustificationParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ColumnTopAttachCutParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ColumnTopAttachCutParam Property
ParameterTypeId Class See Also Send Feedback
"Top Attachment Cut"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ColumnTopAttachCutParam { get; }
Visual Basic
Public Shared ReadOnly Property ColumnTopAttachCutParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ColumnTopAttachCutParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ColumnTopAttachedParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ColumnTopAttachedParam Property
ParameterTypeId Class See Also Send Feedback
"Top is Attached"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ColumnTopAttachedParam { get; }
Visual Basic
Public Shared ReadOnly Property ColumnTopAttachedParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ColumnTopAttachedParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ColumnTopAttachJustificationParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ColumnTopAttachJustificationParam Property
ParameterTypeId Class See Also Send Feedback
"Attachment Justification At Top"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ColumnTopAttachJustificationParam { get; }
Visual Basic
Public Shared ReadOnly Property ColumnTopAttachJustificationParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ColumnTopAttachJustificationParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ColumnTopAttachmentOffsetParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ColumnTopAttachmentOffsetParam Property
ParameterTypeId Class See Also Send Feedback
"Offset From Attachment At Top"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ColumnTopAttachmentOffsetParam { get; }
Visual Basic
Public Shared ReadOnly Property ColumnTopAttachmentOffsetParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ColumnTopAttachmentOffsetParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ConceptualConstructionMaterial Property

[image]

Revit 2024 API
ParameterTypeId..::..ConceptualConstructionMaterial Property
ParameterTypeId Class See Also Send Feedback
"Graphical Appearance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ConceptualConstructionMaterial { get; }
Visual Basic
Public Shared ReadOnly Property ConceptualConstructionMaterial As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ConceptualConstructionMaterial {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ConduitStandardTypeParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ConduitStandardTypeParam Property
ParameterTypeId Class See Also Send Feedback
"Standard"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ConduitStandardTypeParam { get; }
Visual Basic
Public Shared ReadOnly Property ConduitStandardTypeParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ConduitStandardTypeParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ConnectorAngleOfDeflection Property

[image]

Revit 2024 API
ParameterTypeId..::..ConnectorAngleOfDeflection Property
ParameterTypeId Class See Also Send Feedback
"Angle of Deflection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ConnectorAngleOfDeflection { get; }
Visual Basic
Public Shared ReadOnly Property ConnectorAngleOfDeflection As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ConnectorAngleOfDeflection {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ConnectorEngagementLength Property

[image]

Revit 2024 API
ParameterTypeId..::..ConnectorEngagementLength Property
ParameterTypeId Class See Also Send Feedback
"Engagement Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ConnectorEngagementLength { get; }
Visual Basic
Public Shared ReadOnly Property ConnectorEngagementLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ConnectorEngagementLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ConnectorGenderType Property

[image]

Revit 2024 API
ParameterTypeId..::..ConnectorGenderType Property
ParameterTypeId Class See Also Send Feedback
"Connector Gender Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ConnectorGenderType { get; }
Visual Basic
Public Shared ReadOnly Property ConnectorGenderType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ConnectorGenderType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ConnectorHeight Property

[image]

Revit 2024 API
ParameterTypeId..::..ConnectorHeight Property
ParameterTypeId Class See Also Send Feedback
"Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ConnectorHeight { get; }
Visual Basic
Public Shared ReadOnly Property ConnectorHeight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ConnectorHeight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ConnectorInsideDiameter Property

[image]

Revit 2024 API
ParameterTypeId..::..ConnectorInsideDiameter Property
ParameterTypeId Class See Also Send Feedback
"Inside Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ConnectorInsideDiameter { get; }
Visual Basic
Public Shared ReadOnly Property ConnectorInsideDiameter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ConnectorInsideDiameter {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ConnectorJointType Property

[image]

Revit 2024 API
ParameterTypeId..::..ConnectorJointType Property
ParameterTypeId Class See Also Send Feedback
"Connector Joint Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ConnectorJointType { get; }
Visual Basic
Public Shared ReadOnly Property ConnectorJointType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ConnectorJointType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ConnectorLength Property

[image]

Revit 2024 API
ParameterTypeId..::..ConnectorLength Property
ParameterTypeId Class See Also Send Feedback
"Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ConnectorLength { get; }
Visual Basic
Public Shared ReadOnly Property ConnectorLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ConnectorLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ConnectorProfileType Property

[image]

Revit 2024 API
ParameterTypeId..::..ConnectorProfileType Property
ParameterTypeId Class See Also Send Feedback
"Shape"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ConnectorProfileType { get; }
Visual Basic
Public Shared ReadOnly Property ConnectorProfileType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ConnectorProfileType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ConnectorRadius Property

[image]

Revit 2024 API
ParameterTypeId..::..ConnectorRadius Property
ParameterTypeId Class See Also Send Feedback
"Radius"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ConnectorRadius { get; }
Visual Basic
Public Shared ReadOnly Property ConnectorRadius As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ConnectorRadius {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ConnectorReferenceIndex Property

[image]

Revit 2024 API
ParameterTypeId..::..ConnectorReferenceIndex Property
ParameterTypeId Class See Also Send Feedback
"Link Connector Index"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ConnectorReferenceIndex { get; }
Visual Basic
Public Shared ReadOnly Property ConnectorReferenceIndex As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ConnectorReferenceIndex {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ConnectorUtilityParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ConnectorUtilityParam Property
ParameterTypeId Class See Also Send Feedback
"Utility"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ConnectorUtilityParam { get; }
Visual Basic
Public Shared ReadOnly Property ConnectorUtilityParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ConnectorUtilityParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ConnectorVisibleSize Property

[image]

Revit 2024 API
ParameterTypeId..::..ConnectorVisibleSize Property
ParameterTypeId Class See Also Send Feedback
"Size on screen"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ConnectorVisibleSize { get; }
Visual Basic
Public Shared ReadOnly Property ConnectorVisibleSize As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ConnectorVisibleSize {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ConnectorWidth Property

[image]

Revit 2024 API
ParameterTypeId..::..ConnectorWidth Property
ParameterTypeId Class See Also Send Feedback
"Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ConnectorWidth { get; }
Visual Basic
Public Shared ReadOnly Property ConnectorWidth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ConnectorWidth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ConstraintFixedOffset Property

[image]

Revit 2024 API
ParameterTypeId..::..ConstraintFixedOffset Property
ParameterTypeId Class See Also Send Feedback
"Fixed offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ConstraintFixedOffset { get; }
Visual Basic
Public Shared ReadOnly Property ConstraintFixedOffset As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ConstraintFixedOffset {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ConstructionIsSchematic Property

[image]

Revit 2024 API
ParameterTypeId..::..ConstructionIsSchematic Property
ParameterTypeId Class See Also Send Feedback
"Schematic"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ConstructionIsSchematic { get; }
Visual Basic
Public Shared ReadOnly Property ConstructionIsSchematic As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ConstructionIsSchematic {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ContinuousFootingBearingWidth Property

[image]

Revit 2024 API
ParameterTypeId..::..ContinuousFootingBearingWidth Property
ParameterTypeId Class See Also Send Feedback
"Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ContinuousFootingBearingWidth { get; }
Visual Basic
Public Shared ReadOnly Property ContinuousFootingBearingWidth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ContinuousFootingBearingWidth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ContinuousFootingBottomHeel Property

[image]

Revit 2024 API
ParameterTypeId..::..ContinuousFootingBottomHeel Property
ParameterTypeId Class See Also Send Feedback
"Bottom Heel Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ContinuousFootingBottomHeel { get; }
Visual Basic
Public Shared ReadOnly Property ContinuousFootingBottomHeel As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ContinuousFootingBottomHeel {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ContinuousFootingBottomToe Property

[image]

Revit 2024 API
ParameterTypeId..::..ContinuousFootingBottomToe Property
ParameterTypeId Class See Also Send Feedback
"Bottom Toe Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ContinuousFootingBottomToe { get; }
Visual Basic
Public Shared ReadOnly Property ContinuousFootingBottomToe As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ContinuousFootingBottomToe {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ContinuousFootingBreakAtInsertsDisable Property

[image]

Revit 2024 API
ParameterTypeId..::..ContinuousFootingBreakAtInsertsDisable Property
ParameterTypeId Class See Also Send Feedback
"Do Not Break At Inserts"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ContinuousFootingBreakAtInsertsDisable { get; }
Visual Basic
Public Shared ReadOnly Property ContinuousFootingBreakAtInsertsDisable As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ContinuousFootingBreakAtInsertsDisable {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ContinuousFootingDefaultEndExtensionLength Property

[image]

Revit 2024 API
ParameterTypeId..::..ContinuousFootingDefaultEndExtensionLength Property
ParameterTypeId Class See Also Send Feedback
"Default End Extension Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ContinuousFootingDefaultEndExtensionLength { get; }
Visual Basic
Public Shared ReadOnly Property ContinuousFootingDefaultEndExtensionLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ContinuousFootingDefaultEndExtensionLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ContinuousFootingEccentricity Property

[image]

Revit 2024 API
ParameterTypeId..::..ContinuousFootingEccentricity Property
ParameterTypeId Class See Also Send Feedback
"Eccentricity"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ContinuousFootingEccentricity { get; }
Visual Basic
Public Shared ReadOnly Property ContinuousFootingEccentricity As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ContinuousFootingEccentricity {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ContinuousFootingLength Property

[image]

Revit 2024 API
ParameterTypeId..::..ContinuousFootingLength Property
ParameterTypeId Class See Also Send Feedback
"Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ContinuousFootingLength { get; }
Visual Basic
Public Shared ReadOnly Property ContinuousFootingLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ContinuousFootingLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ContinuousFootingStructuralUsage Property

[image]

Revit 2024 API
ParameterTypeId..::..ContinuousFootingStructuralUsage Property
ParameterTypeId Class See Also Send Feedback
"Structural Usage"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ContinuousFootingStructuralUsage { get; }
Visual Basic
Public Shared ReadOnly Property ContinuousFootingStructuralUsage As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ContinuousFootingStructuralUsage {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ContinuousFootingTopHeel Property

[image]

Revit 2024 API
ParameterTypeId..::..ContinuousFootingTopHeel Property
ParameterTypeId Class See Also Send Feedback
"Heel Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ContinuousFootingTopHeel { get; }
Visual Basic
Public Shared ReadOnly Property ContinuousFootingTopHeel As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ContinuousFootingTopHeel {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ContinuousFootingTopToe Property

[image]

Revit 2024 API
ParameterTypeId..::..ContinuousFootingTopToe Property
ParameterTypeId Class See Also Send Feedback
"Toe Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ContinuousFootingTopToe { get; }
Visual Basic
Public Shared ReadOnly Property ContinuousFootingTopToe As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ContinuousFootingTopToe {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ContinuousFootingWidth Property

[image]

Revit 2024 API
ParameterTypeId..::..ContinuousFootingWidth Property
ParameterTypeId Class See Also Send Feedback
"Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ContinuousFootingWidth { get; }
Visual Basic
Public Shared ReadOnly Property ContinuousFootingWidth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ContinuousFootingWidth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ContinuousrailBeginningTerminationAttachmentParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ContinuousrailBeginningTerminationAttachmentParam Property
ParameterTypeId Class See Also Send Feedback
"Extension Style"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ContinuousrailBeginningTerminationAttachmentParam { get; }
Visual Basic
Public Shared ReadOnly Property ContinuousrailBeginningTerminationAttachmentParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ContinuousrailBeginningTerminationAttachmentParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ContinuousrailBeginningTerminationTypeParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ContinuousrailBeginningTerminationTypeParam Property
ParameterTypeId Class See Also Send Feedback
"Beginning/Bottom Termination"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ContinuousrailBeginningTerminationTypeParam { get; }
Visual Basic
Public Shared ReadOnly Property ContinuousrailBeginningTerminationTypeParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ContinuousrailBeginningTerminationTypeParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ContinuousrailDefaultJoinTypeParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ContinuousrailDefaultJoinTypeParam Property
ParameterTypeId Class See Also Send Feedback
"Default Join"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ContinuousrailDefaultJoinTypeParam { get; }
Visual Basic
Public Shared ReadOnly Property ContinuousrailDefaultJoinTypeParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ContinuousrailDefaultJoinTypeParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ContinuousrailEndExtensionLengthParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ContinuousrailEndExtensionLengthParam Property
ParameterTypeId Class See Also Send Feedback
"Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ContinuousrailEndExtensionLengthParam { get; }
Visual Basic
Public Shared ReadOnly Property ContinuousrailEndExtensionLengthParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ContinuousrailEndExtensionLengthParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ContinuousrailEndTerminationAttachmentParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ContinuousrailEndTerminationAttachmentParam Property
ParameterTypeId Class See Also Send Feedback
"Extension Style"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ContinuousrailEndTerminationAttachmentParam { get; }
Visual Basic
Public Shared ReadOnly Property ContinuousrailEndTerminationAttachmentParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ContinuousrailEndTerminationAttachmentParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ContinuousrailEndTerminationTypeParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ContinuousrailEndTerminationTypeParam Property
ParameterTypeId Class See Also Send Feedback
"End/Top Termination"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ContinuousrailEndTerminationTypeParam { get; }
Visual Basic
Public Shared ReadOnly Property ContinuousrailEndTerminationTypeParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ContinuousrailEndTerminationTypeParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ContinuousrailExtensionLengthParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ContinuousrailExtensionLengthParam Property
ParameterTypeId Class See Also Send Feedback
"Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ContinuousrailExtensionLengthParam { get; }
Visual Basic
Public Shared ReadOnly Property ContinuousrailExtensionLengthParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ContinuousrailExtensionLengthParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ContinuousrailJoinTypeParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ContinuousrailJoinTypeParam Property
ParameterTypeId Class See Also Send Feedback
"Rail Path Join"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ContinuousrailJoinTypeParam { get; }
Visual Basic
Public Shared ReadOnly Property ContinuousrailJoinTypeParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ContinuousrailJoinTypeParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ContinuousrailLengthParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ContinuousrailLengthParam Property
ParameterTypeId Class See Also Send Feedback
"Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ContinuousrailLengthParam { get; }
Visual Basic
Public Shared ReadOnly Property ContinuousrailLengthParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ContinuousrailLengthParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ContinuousrailMaterialsParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ContinuousrailMaterialsParam Property
ParameterTypeId Class See Also Send Feedback
"Material"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ContinuousrailMaterialsParam { get; }
Visual Basic
Public Shared ReadOnly Property ContinuousrailMaterialsParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ContinuousrailMaterialsParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ContinuousrailPlusTreadDepthParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ContinuousrailPlusTreadDepthParam Property
ParameterTypeId Class See Also Send Feedback
"Plus Tread Depth"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ContinuousrailPlusTreadDepthParam { get; }
Visual Basic
Public Shared ReadOnly Property ContinuousrailPlusTreadDepthParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ContinuousrailPlusTreadDepthParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ContinuousrailProfileTypeParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ContinuousrailProfileTypeParam Property
ParameterTypeId Class See Also Send Feedback
"Profile"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ContinuousrailProfileTypeParam { get; }
Visual Basic
Public Shared ReadOnly Property ContinuousrailProfileTypeParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ContinuousrailProfileTypeParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ContinuousrailTransitionTypeParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ContinuousrailTransitionTypeParam Property
ParameterTypeId Class See Also Send Feedback
"Transitions"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ContinuousrailTransitionTypeParam { get; }
Visual Basic
Public Shared ReadOnly Property ContinuousrailTransitionTypeParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ContinuousrailTransitionTypeParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ContourLabelsElevBaseType Property

[image]

Revit 2024 API
ParameterTypeId..::..ContourLabelsElevBaseType Property
ParameterTypeId Class See Also Send Feedback
"Elevation Base"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ContourLabelsElevBaseType { get; }
Visual Basic
Public Shared ReadOnly Property ContourLabelsElevBaseType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ContourLabelsElevBaseType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ContourLabelsRelativeBase Property

[image]

Revit 2024 API
ParameterTypeId..::..ContourLabelsRelativeBase Property
ParameterTypeId Class See Also Send Feedback
"Relative Base"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ContourLabelsRelativeBase { get; }
Visual Basic
Public Shared ReadOnly Property ContourLabelsRelativeBase As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ContourLabelsRelativeBase {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CouplerCode Property

[image]

Revit 2024 API
ParameterTypeId..::..CouplerCode Property
ParameterTypeId Class See Also Send Feedback
"Part Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CouplerCode { get; }
Visual Basic
Public Shared ReadOnly Property CouplerCode As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CouplerCode {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CouplerCoupledEngagement Property

[image]

Revit 2024 API
ParameterTypeId..::..CouplerCoupledEngagement Property
ParameterTypeId Class See Also Send Feedback
"Bar Engagement 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CouplerCoupledEngagement { get; }
Visual Basic
Public Shared ReadOnly Property CouplerCoupledEngagement As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CouplerCoupledEngagement {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CouplerLength Property

[image]

Revit 2024 API
ParameterTypeId..::..CouplerLength Property
ParameterTypeId Class See Also Send Feedback
"Total Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CouplerLength { get; }
Visual Basic
Public Shared ReadOnly Property CouplerLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CouplerLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CouplerMainEngagement Property

[image]

Revit 2024 API
ParameterTypeId..::..CouplerMainEngagement Property
ParameterTypeId Class See Also Send Feedback
"Bar Engagement 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CouplerMainEngagement { get; }
Visual Basic
Public Shared ReadOnly Property CouplerMainEngagement As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CouplerMainEngagement {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CouplerMark Property

[image]

Revit 2024 API
ParameterTypeId..::..CouplerMark Property
ParameterTypeId Class See Also Send Feedback
"Schedule Mark"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CouplerMark { get; }
Visual Basic
Public Shared ReadOnly Property CouplerMark As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CouplerMark {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CouplerNumber Property

[image]

Revit 2024 API
ParameterTypeId..::..CouplerNumber Property
ParameterTypeId Class See Also Send Feedback
"Coupler Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CouplerNumber { get; }
Visual Basic
Public Shared ReadOnly Property CouplerNumber As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CouplerNumber {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CouplerQuantity Property

[image]

Revit 2024 API
ParameterTypeId..::..CouplerQuantity Property
ParameterTypeId Class See Also Send Feedback
"Quantity"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CouplerQuantity { get; }
Visual Basic
Public Shared ReadOnly Property CouplerQuantity As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CouplerQuantity {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CouplerRotationAngle Property

[image]

Revit 2024 API
ParameterTypeId..::..CouplerRotationAngle Property
ParameterTypeId Class See Also Send Feedback
"Coupler Rotation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CouplerRotationAngle { get; }
Visual Basic
Public Shared ReadOnly Property CouplerRotationAngle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CouplerRotationAngle {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CouplerWeight Property

[image]

Revit 2024 API
ParameterTypeId..::..CouplerWeight Property
ParameterTypeId Class See Also Send Feedback
"Mass"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CouplerWeight { get; }
Visual Basic
Public Shared ReadOnly Property CouplerWeight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CouplerWeight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CouplerWidth Property

[image]

Revit 2024 API
ParameterTypeId..::..CouplerWidth Property
ParameterTypeId Class See Also Send Feedback
"External Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CouplerWidth { get; }
Visual Basic
Public Shared ReadOnly Property CouplerWidth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CouplerWidth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CoverTypeLength Property

[image]

Revit 2024 API
ParameterTypeId..::..CoverTypeLength Property
ParameterTypeId Class See Also Send Feedback
"Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CoverTypeLength { get; }
Visual Basic
Public Shared ReadOnly Property CoverTypeLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CoverTypeLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CoverTypeName Property

[image]

Revit 2024 API
ParameterTypeId..::..CoverTypeName Property
ParameterTypeId Class See Also Send Feedback
"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CoverTypeName { get; }
Visual Basic
Public Shared ReadOnly Property CoverTypeName As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CoverTypeName {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CurtaingridAdjustBordern1 Property

[image]

Revit 2024 API
ParameterTypeId..::..CurtaingridAdjustBordern1 Property
ParameterTypeId Class See Also Send Feedback
"Adjust for Mullion Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CurtaingridAdjustBordern1 { get; }
Visual Basic
Public Shared ReadOnly Property CurtaingridAdjustBordern1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurtaingridAdjustBordern1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CurtaingridAdjustBordern2 Property

[image]

Revit 2024 API
ParameterTypeId..::..CurtaingridAdjustBordern2 Property
ParameterTypeId Class See Also Send Feedback
"Adjust for Mullion Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CurtaingridAdjustBordern2 { get; }
Visual Basic
Public Shared ReadOnly Property CurtaingridAdjustBordern2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurtaingridAdjustBordern2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CurtaingridAdjustBorderU Property

[image]

Revit 2024 API
ParameterTypeId..::..CurtaingridAdjustBorderU Property
ParameterTypeId Class See Also Send Feedback
"Adjust for Mullion Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CurtaingridAdjustBorderU { get; }
Visual Basic
Public Shared ReadOnly Property CurtaingridAdjustBorderU As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurtaingridAdjustBorderU {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CurtaingridAdjustBorderV Property

[image]

Revit 2024 API
ParameterTypeId..::..CurtaingridAdjustBorderV Property
ParameterTypeId Class See Also Send Feedback
"Adjust for Mullion Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CurtaingridAdjustBorderV { get; }
Visual Basic
Public Shared ReadOnly Property CurtaingridAdjustBorderV As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurtaingridAdjustBorderV {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CurtaingridAdjustBorderVert Property

[image]

Revit 2024 API
ParameterTypeId..::..CurtaingridAdjustBorderVert Property
ParameterTypeId Class See Also Send Feedback
"Adjust for Mullion Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CurtaingridAdjustBorderVert { get; }
Visual Basic
Public Shared ReadOnly Property CurtaingridAdjustBorderVert As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurtaingridAdjustBorderVert {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CurtaingridAngleHoriz Property

[image]

Revit 2024 API
ParameterTypeId..::..CurtaingridAngleHoriz Property
ParameterTypeId Class See Also Send Feedback
"Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CurtaingridAngleHoriz { get; }
Visual Basic
Public Shared ReadOnly Property CurtaingridAngleHoriz As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurtaingridAngleHoriz {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CurtaingridAnglen1 Property

[image]

Revit 2024 API
ParameterTypeId..::..CurtaingridAnglen1 Property
ParameterTypeId Class See Also Send Feedback
"Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CurtaingridAnglen1 { get; }
Visual Basic
Public Shared ReadOnly Property CurtaingridAnglen1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurtaingridAnglen1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CurtaingridAnglen2 Property

[image]

Revit 2024 API
ParameterTypeId..::..CurtaingridAnglen2 Property
ParameterTypeId Class See Also Send Feedback
"Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CurtaingridAnglen2 { get; }
Visual Basic
Public Shared ReadOnly Property CurtaingridAnglen2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurtaingridAnglen2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CurtaingridAngleVert Property

[image]

Revit 2024 API
ParameterTypeId..::..CurtaingridAngleVert Property
ParameterTypeId Class See Also Send Feedback
"Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CurtaingridAngleVert { get; }
Visual Basic
Public Shared ReadOnly Property CurtaingridAngleVert As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurtaingridAngleVert {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CurtainGridBaseOrientation Property

[image]

Revit 2024 API
ParameterTypeId..::..CurtainGridBaseOrientation Property
ParameterTypeId Class See Also Send Feedback
"Grid Base Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CurtainGridBaseOrientation { get; }
Visual Basic
Public Shared ReadOnly Property CurtainGridBaseOrientation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurtainGridBaseOrientation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CurtaingridBeltn1 Property

[image]

Revit 2024 API
ParameterTypeId..::..CurtaingridBeltn1 Property
ParameterTypeId Class See Also Send Feedback
"Measurement Line"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CurtaingridBeltn1 { get; }
Visual Basic
Public Shared ReadOnly Property CurtaingridBeltn1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurtaingridBeltn1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CurtaingridBeltn2 Property

[image]

Revit 2024 API
ParameterTypeId..::..CurtaingridBeltn2 Property
ParameterTypeId Class See Also Send Feedback
"Measurement Line"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CurtaingridBeltn2 { get; }
Visual Basic
Public Shared ReadOnly Property CurtaingridBeltn2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurtaingridBeltn2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CurtaingridBeltRation1 Property

[image]

Revit 2024 API
ParameterTypeId..::..CurtaingridBeltRation1 Property
ParameterTypeId Class See Also Send Feedback
"Measurement Line"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CurtaingridBeltRation1 { get; }
Visual Basic
Public Shared ReadOnly Property CurtaingridBeltRation1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurtaingridBeltRation1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CurtaingridBeltRation2 Property

[image]

Revit 2024 API
ParameterTypeId..::..CurtaingridBeltRation2 Property
ParameterTypeId Class See Also Send Feedback
"Measurement Line"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CurtaingridBeltRation2 { get; }
Visual Basic
Public Shared ReadOnly Property CurtaingridBeltRation2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurtaingridBeltRation2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CurtaingridBeltRatioU Property

[image]

Revit 2024 API
ParameterTypeId..::..CurtaingridBeltRatioU Property
ParameterTypeId Class See Also Send Feedback
"Belt Measurement"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CurtaingridBeltRatioU { get; }
Visual Basic
Public Shared ReadOnly Property CurtaingridBeltRatioU As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurtaingridBeltRatioU {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CurtaingridBeltRatioV Property

[image]

Revit 2024 API
ParameterTypeId..::..CurtaingridBeltRatioV Property
ParameterTypeId Class See Also Send Feedback
"Belt Measurement"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CurtaingridBeltRatioV { get; }
Visual Basic
Public Shared ReadOnly Property CurtaingridBeltRatioV As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurtaingridBeltRatioV {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CurtaingridBeltU Property

[image]

Revit 2024 API
ParameterTypeId..::..CurtaingridBeltU Property
ParameterTypeId Class See Also Send Feedback
"Belt Measurement"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CurtaingridBeltU { get; }
Visual Basic
Public Shared ReadOnly Property CurtaingridBeltU As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurtaingridBeltU {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CurtaingridBeltV Property

[image]

Revit 2024 API
ParameterTypeId..::..CurtaingridBeltV Property
ParameterTypeId Class See Also Send Feedback
"Belt Measurement"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CurtaingridBeltV { get; }
Visual Basic
Public Shared ReadOnly Property CurtaingridBeltV As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurtaingridBeltV {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CurtaingridOriginn2 Property

[image]

Revit 2024 API
ParameterTypeId..::..CurtaingridOriginn2 Property
ParameterTypeId Class See Also Send Feedback
"Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CurtaingridOriginn2 { get; }
Visual Basic
Public Shared ReadOnly Property CurtaingridOriginn2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurtaingridOriginn2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CurtaingridOriginU Property

[image]

Revit 2024 API
ParameterTypeId..::..CurtaingridOriginU Property
ParameterTypeId Class See Also Send Feedback
"Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CurtaingridOriginU { get; }
Visual Basic
Public Shared ReadOnly Property CurtaingridOriginU As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurtaingridOriginU {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CurtaingridOriginV Property

[image]

Revit 2024 API
ParameterTypeId..::..CurtaingridOriginV Property
ParameterTypeId Class See Also Send Feedback
"Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CurtaingridOriginV { get; }
Visual Basic
Public Shared ReadOnly Property CurtaingridOriginV As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurtaingridOriginV {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CurtaingridOriginVert Property

[image]

Revit 2024 API
ParameterTypeId..::..CurtaingridOriginVert Property
ParameterTypeId Class See Also Send Feedback
"Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CurtaingridOriginVert { get; }
Visual Basic
Public Shared ReadOnly Property CurtaingridOriginVert As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurtaingridOriginVert {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CurtaingridUseCurveDistU Property

[image]

Revit 2024 API
ParameterTypeId..::..CurtaingridUseCurveDistU Property
ParameterTypeId Class See Also Send Feedback
"Use Curve Distance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CurtaingridUseCurveDistU { get; }
Visual Basic
Public Shared ReadOnly Property CurtaingridUseCurveDistU As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurtaingridUseCurveDistU {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CurtaingridUseCurveDistV Property

[image]

Revit 2024 API
ParameterTypeId..::..CurtaingridUseCurveDistV Property
ParameterTypeId Class See Also Send Feedback
"Use Curve Distance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CurtaingridUseCurveDistV { get; }
Visual Basic
Public Shared ReadOnly Property CurtaingridUseCurveDistV As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurtaingridUseCurveDistV {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CurtaingridUseCurveDistVert Property

[image]

Revit 2024 API
ParameterTypeId..::..CurtaingridUseCurveDistVert Property
ParameterTypeId Class See Also Send Feedback
"Use Curve Distance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CurtaingridUseCurveDistVert { get; }
Visual Basic
Public Shared ReadOnly Property CurtaingridUseCurveDistVert As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurtaingridUseCurveDistVert {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CurtainVersionParam Property

[image]

Revit 2024 API
ParameterTypeId..::..CurtainVersionParam Property
ParameterTypeId Class See Also Send Feedback
"Curtain version"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CurtainVersionParam { get; }
Visual Basic
Public Shared ReadOnly Property CurtainVersionParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurtainVersionParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CurtainWallPanelHostId Property

[image]

Revit 2024 API
ParameterTypeId..::..CurtainWallPanelHostId Property
ParameterTypeId Class See Also Send Feedback
"Host Id"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CurtainWallPanelHostId { get; }
Visual Basic
Public Shared ReadOnly Property CurtainWallPanelHostId As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurtainWallPanelHostId {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CurtainWallPanelsHeight Property

[image]

Revit 2024 API
ParameterTypeId..::..CurtainWallPanelsHeight Property
ParameterTypeId Class See Also Send Feedback
"Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CurtainWallPanelsHeight { get; }
Visual Basic
Public Shared ReadOnly Property CurtainWallPanelsHeight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurtainWallPanelsHeight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CurtainWallPanelsWidth Property

[image]

Revit 2024 API
ParameterTypeId..::..CurtainWallPanelsWidth Property
ParameterTypeId Class See Also Send Feedback
"Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CurtainWallPanelsWidth { get; }
Visual Basic
Public Shared ReadOnly Property CurtainWallPanelsWidth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurtainWallPanelsWidth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CurtainWallSyspanelOffset Property

[image]

Revit 2024 API
ParameterTypeId..::..CurtainWallSyspanelOffset Property
ParameterTypeId Class See Also Send Feedback
"Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CurtainWallSyspanelOffset { get; }
Visual Basic
Public Shared ReadOnly Property CurtainWallSyspanelOffset As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurtainWallSyspanelOffset {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CurtainWallSyspanelThickness Property

[image]

Revit 2024 API
ParameterTypeId..::..CurtainWallSyspanelThickness Property
ParameterTypeId Class See Also Send Feedback
"Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CurtainWallSyspanelThickness { get; }
Visual Basic
Public Shared ReadOnly Property CurtainWallSyspanelThickness As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurtainWallSyspanelThickness {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CurveBottomLevel Property

[image]

Revit 2024 API
ParameterTypeId..::..CurveBottomLevel Property
ParameterTypeId Class See Also Send Feedback
"Bottom Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CurveBottomLevel { get; }
Visual Basic
Public Shared ReadOnly Property CurveBottomLevel As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurveBottomLevel {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CurveByPointsProjectionType Property

[image]

Revit 2024 API
ParameterTypeId..::..CurveByPointsProjectionType Property
ParameterTypeId Class See Also Send Feedback
"Projection Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CurveByPointsProjectionType { get; }
Visual Basic
Public Shared ReadOnly Property CurveByPointsProjectionType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurveByPointsProjectionType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CurveEdgeOffset Property

[image]

Revit 2024 API
ParameterTypeId..::..CurveEdgeOffset Property
ParameterTypeId Class See Also Send Feedback
"Wall offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CurveEdgeOffset { get; }
Visual Basic
Public Shared ReadOnly Property CurveEdgeOffset As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurveEdgeOffset {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CurveElemArcEndAngle Property

[image]

Revit 2024 API
ParameterTypeId..::..CurveElemArcEndAngle Property
ParameterTypeId Class See Also Send Feedback
"Angle 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CurveElemArcEndAngle { get; }
Visual Basic
Public Shared ReadOnly Property CurveElemArcEndAngle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurveElemArcEndAngle {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CurveElemArcRange Property

[image]

Revit 2024 API
ParameterTypeId..::..CurveElemArcRange Property
ParameterTypeId Class See Also Send Feedback
"Range"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CurveElemArcRange { get; }
Visual Basic
Public Shared ReadOnly Property CurveElemArcRange As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurveElemArcRange {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CurveElemLength Property

[image]

Revit 2024 API
ParameterTypeId..::..CurveElemLength Property
ParameterTypeId Class See Also Send Feedback
"Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CurveElemLength { get; }
Visual Basic
Public Shared ReadOnly Property CurveElemLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurveElemLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CurveElemLineAngle Property

[image]

Revit 2024 API
ParameterTypeId..::..CurveElemLineAngle Property
ParameterTypeId Class See Also Send Feedback
"Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CurveElemLineAngle { get; }
Visual Basic
Public Shared ReadOnly Property CurveElemLineAngle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurveElemLineAngle {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CurveHeightOffset Property

[image]

Revit 2024 API
ParameterTypeId..::..CurveHeightOffset Property
ParameterTypeId Class See Also Send Feedback
"Offset From Base"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CurveHeightOffset { get; }
Visual Basic
Public Shared ReadOnly Property CurveHeightOffset As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurveHeightOffset {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CurveIsDetail Property

[image]

Revit 2024 API
ParameterTypeId..::..CurveIsDetail Property
ParameterTypeId Class See Also Send Feedback
"Detail Line"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CurveIsDetail { get; }
Visual Basic
Public Shared ReadOnly Property CurveIsDetail As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurveIsDetail {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CurveIsFilled Property

[image]

Revit 2024 API
ParameterTypeId..::..CurveIsFilled Property
ParameterTypeId Class See Also Send Feedback
"Filled"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CurveIsFilled { get; }
Visual Basic
Public Shared ReadOnly Property CurveIsFilled As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurveIsFilled {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CurveIsReferenceLine Property

[image]

Revit 2024 API
ParameterTypeId..::..CurveIsReferenceLine Property
ParameterTypeId Class See Also Send Feedback
"Is Reference Line"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CurveIsReferenceLine { get; }
Visual Basic
Public Shared ReadOnly Property CurveIsReferenceLine As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurveIsReferenceLine {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CurveIsSlopeDefining Property

[image]

Revit 2024 API
ParameterTypeId..::..CurveIsSlopeDefining Property
ParameterTypeId Class See Also Send Feedback
"Defines Slope"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CurveIsSlopeDefining { get; }
Visual Basic
Public Shared ReadOnly Property CurveIsSlopeDefining As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurveIsSlopeDefining {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CurveLevel Property

[image]

Revit 2024 API
ParameterTypeId..::..CurveLevel Property
ParameterTypeId Class See Also Send Feedback
"Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CurveLevel { get; }
Visual Basic
Public Shared ReadOnly Property CurveLevel As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurveLevel {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CurveNumberOfSegments Property

[image]

Revit 2024 API
ParameterTypeId..::..CurveNumberOfSegments Property
ParameterTypeId Class See Also Send Feedback
"Number of Full Segments"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CurveNumberOfSegments { get; }
Visual Basic
Public Shared ReadOnly Property CurveNumberOfSegments As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurveNumberOfSegments {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CurveParamConcreteCantilever Property

[image]

Revit 2024 API
ParameterTypeId..::..CurveParamConcreteCantilever Property
ParameterTypeId Class See Also Send Feedback
"Concrete Cantilever"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CurveParamConcreteCantilever { get; }
Visual Basic
Public Shared ReadOnly Property CurveParamConcreteCantilever As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurveParamConcreteCantilever {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CurveSupportOffset Property

[image]

Revit 2024 API
ParameterTypeId..::..CurveSupportOffset Property
ParameterTypeId Class See Also Send Feedback
"Wall offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CurveSupportOffset { get; }
Visual Basic
Public Shared ReadOnly Property CurveSupportOffset As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurveSupportOffset {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CurveTopLevel Property

[image]

Revit 2024 API
ParameterTypeId..::..CurveTopLevel Property
ParameterTypeId Class See Also Send Feedback
"Top Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CurveTopLevel { get; }
Visual Basic
Public Shared ReadOnly Property CurveTopLevel As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurveTopLevel {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CurveVisibilityParam Property

[image]

Revit 2024 API
ParameterTypeId..::..CurveVisibilityParam Property
ParameterTypeId Class See Also Send Feedback
"Visibility/Graphics Overrides"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CurveVisibilityParam { get; }
Visual Basic
Public Shared ReadOnly Property CurveVisibilityParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurveVisibilityParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CurveWallOffset Property

[image]

Revit 2024 API
ParameterTypeId..::..CurveWallOffset Property
ParameterTypeId Class See Also Send Feedback
"Wall offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CurveWallOffset { get; }
Visual Basic
Public Shared ReadOnly Property CurveWallOffset As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurveWallOffset {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CustMullionWidth1 Property

[image]

Revit 2024 API
ParameterTypeId..::..CustMullionWidth1 Property
ParameterTypeId Class See Also Send Feedback
"Width on side 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CustMullionWidth1 { get; }
Visual Basic
Public Shared ReadOnly Property CustMullionWidth1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CustMullionWidth1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CustMullionWidth2 Property

[image]

Revit 2024 API
ParameterTypeId..::..CustMullionWidth2 Property
ParameterTypeId Class See Also Send Feedback
"Width on side 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CustMullionWidth2 { get; }
Visual Basic
Public Shared ReadOnly Property CustMullionWidth2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CustMullionWidth2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CutLineAngle Property

[image]

Revit 2024 API
ParameterTypeId..::..CutLineAngle Property
ParameterTypeId Class See Also Send Feedback
"Cut Line Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CutLineAngle { get; }
Visual Basic
Public Shared ReadOnly Property CutLineAngle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CutLineAngle {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CutLineType Property

[image]

Revit 2024 API
ParameterTypeId..::..CutLineType Property
ParameterTypeId Class See Also Send Feedback
"Cut Line Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CutLineType { get; }
Visual Basic
Public Shared ReadOnly Property CutLineType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CutLineType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CutMarkSymbol Property

[image]

Revit 2024 API
ParameterTypeId..::..CutMarkSymbol Property
ParameterTypeId Class See Also Send Feedback
"Cut Mark Symbol"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CutMarkSymbol { get; }
Visual Basic
Public Shared ReadOnly Property CutMarkSymbol As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CutMarkSymbol {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CutMarkSymbolSize Property

[image]

Revit 2024 API
ParameterTypeId..::..CutMarkSymbolSize Property
ParameterTypeId Class See Also Send Feedback
"Cut Mark Symbol Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CutMarkSymbolSize { get; }
Visual Basic
Public Shared ReadOnly Property CutMarkSymbolSize As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CutMarkSymbolSize {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CwpAddGridSuffix Property

[image]

Revit 2024 API
ParameterTypeId..::..CwpAddGridSuffix Property
ParameterTypeId Class See Also Send Feedback
"Add suffix to Grid Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CwpAddGridSuffix { get; }
Visual Basic
Public Shared ReadOnly Property CwpAddGridSuffix As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CwpAddGridSuffix {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CwpAddLevelPrefix Property

[image]

Revit 2024 API
ParameterTypeId..::..CwpAddLevelPrefix Property
ParameterTypeId Class See Also Send Feedback
"Add prefix to Level Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CwpAddLevelPrefix { get; }
Visual Basic
Public Shared ReadOnly Property CwpAddLevelPrefix As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CwpAddLevelPrefix {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CwpCopyFloorInserts Property

[image]

Revit 2024 API
ParameterTypeId..::..CwpCopyFloorInserts Property
ParameterTypeId Class See Also Send Feedback
"Copy openings/inserts"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CwpCopyFloorInserts { get; }
Visual Basic
Public Shared ReadOnly Property CwpCopyFloorInserts As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CwpCopyFloorInserts {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CwpCopyWallInserts Property

[image]

Revit 2024 API
ParameterTypeId..::..CwpCopyWallInserts Property
ParameterTypeId Class See Also Send Feedback
"Copy windows/doors/openings"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CwpCopyWallInserts { get; }
Visual Basic
Public Shared ReadOnly Property CwpCopyWallInserts As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CwpCopyWallInserts {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CwpLinkedRoomParams Property

[image]

Revit 2024 API
ParameterTypeId..::..CwpLinkedRoomParams Property
ParameterTypeId Class See Also Send Feedback
"Parameters"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CwpLinkedRoomParams { get; }
Visual Basic
Public Shared ReadOnly Property CwpLinkedRoomParams As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CwpLinkedRoomParams {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CwpLinkedRoomPhases Property

[image]

Revit 2024 API
ParameterTypeId..::..CwpLinkedRoomPhases Property
ParameterTypeId Class See Also Send Feedback
"Phases"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CwpLinkedRoomPhases { get; }
Visual Basic
Public Shared ReadOnly Property CwpLinkedRoomPhases As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CwpLinkedRoomPhases {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CwpReuseExistingGrids Property

[image]

Revit 2024 API
ParameterTypeId..::..CwpReuseExistingGrids Property
ParameterTypeId Class See Also Send Feedback
"Reuse matching Grids"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CwpReuseExistingGrids { get; }
Visual Basic
Public Shared ReadOnly Property CwpReuseExistingGrids As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CwpReuseExistingGrids {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CwpReuseGridsSameName Property

[image]

Revit 2024 API
ParameterTypeId..::..CwpReuseGridsSameName Property
ParameterTypeId Class See Also Send Feedback
"Reuse Grids with the same name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CwpReuseGridsSameName { get; }
Visual Basic
Public Shared ReadOnly Property CwpReuseGridsSameName As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CwpReuseGridsSameName {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CwpReuseLevelsSameName Property

[image]

Revit 2024 API
ParameterTypeId..::..CwpReuseLevelsSameName Property
ParameterTypeId Class See Also Send Feedback
"Reuse Levels with the same name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CwpReuseLevelsSameName { get; }
Visual Basic
Public Shared ReadOnly Property CwpReuseLevelsSameName As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CwpReuseLevelsSameName {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


CwpSplitColumnsAtLevels Property

[image]

Revit 2024 API
ParameterTypeId..::..CwpSplitColumnsAtLevels Property
ParameterTypeId Class See Also Send Feedback
"Split Columns by Levels"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId CwpSplitColumnsAtLevels { get; }
Visual Basic
Public Shared ReadOnly Property CwpSplitColumnsAtLevels As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CwpSplitColumnsAtLevels {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DatumBubbleEndn1 Property

[image]

Revit 2024 API
ParameterTypeId..::..DatumBubbleEndn1 Property
ParameterTypeId Class See Also Send Feedback
"Symbol at End 1 Default"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DatumBubbleEndn1 { get; }
Visual Basic
Public Shared ReadOnly Property DatumBubbleEndn1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DatumBubbleEndn1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DatumBubbleEndn2 Property

[image]

Revit 2024 API
ParameterTypeId..::..DatumBubbleEndn2 Property
ParameterTypeId Class See Also Send Feedback
"Symbol at End 2 Default"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DatumBubbleEndn2 { get; }
Visual Basic
Public Shared ReadOnly Property DatumBubbleEndn2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DatumBubbleEndn2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DatumBubbleLocationInElev Property

[image]

Revit 2024 API
ParameterTypeId..::..DatumBubbleLocationInElev Property
ParameterTypeId Class See Also Send Feedback
"Non-Plan View Symbols (Default)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DatumBubbleLocationInElev { get; }
Visual Basic
Public Shared ReadOnly Property DatumBubbleLocationInElev As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DatumBubbleLocationInElev {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DatumPlaneDefinesOrigin Property

[image]

Revit 2024 API
ParameterTypeId..::..DatumPlaneDefinesOrigin Property
ParameterTypeId Class See Also Send Feedback
"Defines Origin"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DatumPlaneDefinesOrigin { get; }
Visual Basic
Public Shared ReadOnly Property DatumPlaneDefinesOrigin As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DatumPlaneDefinesOrigin {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DatumPlaneDefinesWallClosure Property

[image]

Revit 2024 API
ParameterTypeId..::..DatumPlaneDefinesWallClosure Property
ParameterTypeId Class See Also Send Feedback
"Wall Closure"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DatumPlaneDefinesWallClosure { get; }
Visual Basic
Public Shared ReadOnly Property DatumPlaneDefinesWallClosure As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DatumPlaneDefinesWallClosure {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DatumText Property

[image]

Revit 2024 API
ParameterTypeId..::..DatumText Property
ParameterTypeId Class See Also Send Feedback
"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DatumText { get; }
Visual Basic
Public Shared ReadOnly Property DatumText As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DatumText {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DatumVolumeOfInterest Property

[image]

Revit 2024 API
ParameterTypeId..::..DatumVolumeOfInterest Property
ParameterTypeId Class See Also Send Feedback
"Scope Box"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DatumVolumeOfInterest { get; }
Visual Basic
Public Shared ReadOnly Property DatumVolumeOfInterest As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DatumVolumeOfInterest {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DebugtabDataboundcontrolsdemoBoolean Property

[image]

Revit 2024 API
ParameterTypeId..::..DebugtabDataboundcontrolsdemoBoolean Property
ParameterTypeId Class See Also Send Feedback
"Boolean"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DebugtabDataboundcontrolsdemoBoolean { get; }
Visual Basic
Public Shared ReadOnly Property DebugtabDataboundcontrolsdemoBoolean As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DebugtabDataboundcontrolsdemoBoolean {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DebugtabDataboundcontrolsdemoInteger Property

[image]

Revit 2024 API
ParameterTypeId..::..DebugtabDataboundcontrolsdemoInteger Property
ParameterTypeId Class See Also Send Feedback
"Integer"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DebugtabDataboundcontrolsdemoInteger { get; }
Visual Basic
Public Shared ReadOnly Property DebugtabDataboundcontrolsdemoInteger As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DebugtabDataboundcontrolsdemoInteger {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DecalHeight Property

[image]

Revit 2024 API
ParameterTypeId..::..DecalHeight Property
ParameterTypeId Class See Also Send Feedback
"Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DecalHeight { get; }
Visual Basic
Public Shared ReadOnly Property DecalHeight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DecalHeight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DecalLockProportions Property

[image]

Revit 2024 API
ParameterTypeId..::..DecalLockProportions Property
ParameterTypeId Class See Also Send Feedback
"Lock Proportions"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DecalLockProportions { get; }
Visual Basic
Public Shared ReadOnly Property DecalLockProportions As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DecalLockProportions {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DecalWidth Property

[image]

Revit 2024 API
ParameterTypeId..::..DecalWidth Property
ParameterTypeId Class See Also Send Feedback
"Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DecalWidth { get; }
Visual Basic
Public Shared ReadOnly Property DecalWidth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DecalWidth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DefaultConstructionExtWallUnderground Property

[image]

Revit 2024 API
ParameterTypeId..::..DefaultConstructionExtWallUnderground Property
ParameterTypeId Class See Also Send Feedback
"Mass Exterior Wall - Underground"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DefaultConstructionExtWallUnderground { get; }
Visual Basic
Public Shared ReadOnly Property DefaultConstructionExtWallUnderground As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DefaultConstructionExtWallUnderground {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DefaultConstructionMassExteriorWall Property

[image]

Revit 2024 API
ParameterTypeId..::..DefaultConstructionMassExteriorWall Property
ParameterTypeId Class See Also Send Feedback
"Mass Exterior Wall"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DefaultConstructionMassExteriorWall { get; }
Visual Basic
Public Shared ReadOnly Property DefaultConstructionMassExteriorWall As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DefaultConstructionMassExteriorWall {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DefaultConstructionMassFloor Property

[image]

Revit 2024 API
ParameterTypeId..::..DefaultConstructionMassFloor Property
ParameterTypeId Class See Also Send Feedback
"Mass Floor"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DefaultConstructionMassFloor { get; }
Visual Basic
Public Shared ReadOnly Property DefaultConstructionMassFloor As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DefaultConstructionMassFloor {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DefaultConstructionMassGlazing Property

[image]

Revit 2024 API
ParameterTypeId..::..DefaultConstructionMassGlazing Property
ParameterTypeId Class See Also Send Feedback
"Mass Glazing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DefaultConstructionMassGlazing { get; }
Visual Basic
Public Shared ReadOnly Property DefaultConstructionMassGlazing As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DefaultConstructionMassGlazing {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DefaultConstructionMassInteriorWall Property

[image]

Revit 2024 API
ParameterTypeId..::..DefaultConstructionMassInteriorWall Property
ParameterTypeId Class See Also Send Feedback
"Mass Interior Wall"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DefaultConstructionMassInteriorWall { get; }
Visual Basic
Public Shared ReadOnly Property DefaultConstructionMassInteriorWall As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DefaultConstructionMassInteriorWall {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DefaultConstructionMassOpening Property

[image]

Revit 2024 API
ParameterTypeId..::..DefaultConstructionMassOpening Property
ParameterTypeId Class See Also Send Feedback
"Mass Opening"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DefaultConstructionMassOpening { get; }
Visual Basic
Public Shared ReadOnly Property DefaultConstructionMassOpening As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DefaultConstructionMassOpening {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DefaultConstructionMassShade Property

[image]

Revit 2024 API
ParameterTypeId..::..DefaultConstructionMassShade Property
ParameterTypeId Class See Also Send Feedback
"Mass Shade"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DefaultConstructionMassShade { get; }
Visual Basic
Public Shared ReadOnly Property DefaultConstructionMassShade As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DefaultConstructionMassShade {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DefaultConstructionMassSkylight Property

[image]

Revit 2024 API
ParameterTypeId..::..DefaultConstructionMassSkylight Property
ParameterTypeId Class See Also Send Feedback
"Mass Skylight"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DefaultConstructionMassSkylight { get; }
Visual Basic
Public Shared ReadOnly Property DefaultConstructionMassSkylight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DefaultConstructionMassSkylight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DefaultConstructionMassSlab Property

[image]

Revit 2024 API
ParameterTypeId..::..DefaultConstructionMassSlab Property
ParameterTypeId Class See Also Send Feedback
"Mass Slab"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DefaultConstructionMassSlab { get; }
Visual Basic
Public Shared ReadOnly Property DefaultConstructionMassSlab As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DefaultConstructionMassSlab {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DefaultViewTemplate Property

[image]

Revit 2024 API
ParameterTypeId..::..DefaultViewTemplate Property
ParameterTypeId Class See Also Send Feedback
"View Template applied to new views"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DefaultViewTemplate { get; }
Visual Basic
Public Shared ReadOnly Property DefaultViewTemplate As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DefaultViewTemplate {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DefinesConstantHeight Property

[image]

Revit 2024 API
ParameterTypeId..::..DefinesConstantHeight Property
ParameterTypeId Class See Also Send Feedback
"Defines Constant Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DefinesConstantHeight { get; }
Visual Basic
Public Shared ReadOnly Property DefinesConstantHeight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DefinesConstantHeight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DesignOptionId Property

[image]

Revit 2024 API
ParameterTypeId..::..DesignOptionId Property
ParameterTypeId Class See Also Send Feedback
"Design Option"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DesignOptionId { get; }
Visual Basic
Public Shared ReadOnly Property DesignOptionId As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DesignOptionId {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DesignOptionParam Property

[image]

Revit 2024 API
ParameterTypeId..::..DesignOptionParam Property
ParameterTypeId Class See Also Send Feedback
"Design Option"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DesignOptionParam { get; }
Visual Basic
Public Shared ReadOnly Property DesignOptionParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DesignOptionParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DiameterSymbolText Property

[image]

Revit 2024 API
ParameterTypeId..::..DiameterSymbolText Property
ParameterTypeId Class See Also Send Feedback
"Diameter Symbol Text"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DiameterSymbolText { get; }
Visual Basic
Public Shared ReadOnly Property DiameterSymbolText As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DiameterSymbolText {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DimDisplayEq Property

[image]

Revit 2024 API
ParameterTypeId..::..DimDisplayEq Property
ParameterTypeId Class See Also Send Feedback
"Equality Display"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DimDisplayEq { get; }
Visual Basic
Public Shared ReadOnly Property DimDisplayEq As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DimDisplayEq {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DimIsreporting Property

[image]

Revit 2024 API
ParameterTypeId..::..DimIsreporting Property
ParameterTypeId Class See Also Send Feedback
"Is Reporting"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DimIsreporting { get; }
Visual Basic
Public Shared ReadOnly Property DimIsreporting As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DimIsreporting {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DimLabel Property

[image]

Revit 2024 API
ParameterTypeId..::..DimLabel Property
ParameterTypeId Class See Also Send Feedback
"Label"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DimLabel { get; }
Visual Basic
Public Shared ReadOnly Property DimLabel As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DimLabel {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DimLabelIsInstance Property

[image]

Revit 2024 API
ParameterTypeId..::..DimLabelIsInstance Property
ParameterTypeId Class See Also Send Feedback
"Is Instance Parameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DimLabelIsInstance { get; }
Visual Basic
Public Shared ReadOnly Property DimLabelIsInstance As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DimLabelIsInstance {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DimLeader Property

[image]

Revit 2024 API
ParameterTypeId..::..DimLeader Property
ParameterTypeId Class See Also Send Feedback
"Leader"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DimLeader { get; }
Visual Basic
Public Shared ReadOnly Property DimLeader As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DimLeader {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DimLeaderArrowhead Property

[image]

Revit 2024 API
ParameterTypeId..::..DimLeaderArrowhead Property
ParameterTypeId Class See Also Send Feedback
"Tick Mark"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DimLeaderArrowhead { get; }
Visual Basic
Public Shared ReadOnly Property DimLeaderArrowhead As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DimLeaderArrowhead {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DimLeaderDisplayCondition Property

[image]

Revit 2024 API
ParameterTypeId..::..DimLeaderDisplayCondition Property
ParameterTypeId Class See Also Send Feedback
"Show Leader When Text Moves"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DimLeaderDisplayCondition { get; }
Visual Basic
Public Shared ReadOnly Property DimLeaderDisplayCondition As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DimLeaderDisplayCondition {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DimLeaderShoulderLength Property

[image]

Revit 2024 API
ParameterTypeId..::..DimLeaderShoulderLength Property
ParameterTypeId Class See Also Send Feedback
"Shoulder Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DimLeaderShoulderLength { get; }
Visual Basic
Public Shared ReadOnly Property DimLeaderShoulderLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DimLeaderShoulderLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DimLineExtension Property

[image]

Revit 2024 API
ParameterTypeId..::..DimLineExtension Property
ParameterTypeId Class See Also Send Feedback
"Dimension Line Extension"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DimLineExtension { get; }
Visual Basic
Public Shared ReadOnly Property DimLineExtension As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DimLineExtension {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DimNotModifiable Property

[image]

Revit 2024 API
ParameterTypeId..::..DimNotModifiable Property
ParameterTypeId Class See Also Send Feedback
"Non-modifiable"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DimNotModifiable { get; }
Visual Basic
Public Shared ReadOnly Property DimNotModifiable As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DimNotModifiable {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DimPrefix Property

[image]

Revit 2024 API
ParameterTypeId..::..DimPrefix Property
ParameterTypeId Class See Also Send Feedback
"Dimension Prefix"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DimPrefix { get; }
Visual Basic
Public Shared ReadOnly Property DimPrefix As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DimPrefix {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DimReferenceCount Property

[image]

Revit 2024 API
ParameterTypeId..::..DimReferenceCount Property
ParameterTypeId Class See Also Send Feedback
"Count"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DimReferenceCount { get; }
Visual Basic
Public Shared ReadOnly Property DimReferenceCount As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DimReferenceCount {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DimStyleAngularUnits Property

[image]

Revit 2024 API
ParameterTypeId..::..DimStyleAngularUnits Property
ParameterTypeId Class See Also Send Feedback
"Units Format"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DimStyleAngularUnits { get; }
Visual Basic
Public Shared ReadOnly Property DimStyleAngularUnits As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DimStyleAngularUnits {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DimStyleAngularUnitsAlt Property

[image]

Revit 2024 API
ParameterTypeId..::..DimStyleAngularUnitsAlt Property
ParameterTypeId Class See Also Send Feedback
"Alternate Units Format"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DimStyleAngularUnitsAlt { get; }
Visual Basic
Public Shared ReadOnly Property DimStyleAngularUnitsAlt As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DimStyleAngularUnitsAlt {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DimStyleCenterlinePattern Property

[image]

Revit 2024 API
ParameterTypeId..::..DimStyleCenterlinePattern Property
ParameterTypeId Class See Also Send Feedback
"Centerline Pattern"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DimStyleCenterlinePattern { get; }
Visual Basic
Public Shared ReadOnly Property DimStyleCenterlinePattern As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DimStyleCenterlinePattern {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DimStyleCenterlineSymbol Property

[image]

Revit 2024 API
ParameterTypeId..::..DimStyleCenterlineSymbol Property
ParameterTypeId Class See Also Send Feedback
"Centerline Symbol"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DimStyleCenterlineSymbol { get; }
Visual Basic
Public Shared ReadOnly Property DimStyleCenterlineSymbol As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DimStyleCenterlineSymbol {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DimStyleCenterlineTickMark Property

[image]

Revit 2024 API
ParameterTypeId..::..DimStyleCenterlineTickMark Property
ParameterTypeId Class See Also Send Feedback
"Centerline Tick Mark"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DimStyleCenterlineTickMark { get; }
Visual Basic
Public Shared ReadOnly Property DimStyleCenterlineTickMark As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DimStyleCenterlineTickMark {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DimStyleDimLineSnapDist Property

[image]

Revit 2024 API
ParameterTypeId..::..DimStyleDimLineSnapDist Property
ParameterTypeId Class See Also Send Feedback
"Dimension Line Snap Distance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DimStyleDimLineSnapDist { get; }
Visual Basic
Public Shared ReadOnly Property DimStyleDimLineSnapDist As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DimStyleDimLineSnapDist {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DimStyleFlippedDimLineExtension Property

[image]

Revit 2024 API
ParameterTypeId..::..DimStyleFlippedDimLineExtension Property
ParameterTypeId Class See Also Send Feedback
"Flipped Dimension Line Extension"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DimStyleFlippedDimLineExtension { get; }
Visual Basic
Public Shared ReadOnly Property DimStyleFlippedDimLineExtension As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DimStyleFlippedDimLineExtension {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DimStyleInteriorTickMark Property

[image]

Revit 2024 API
ParameterTypeId..::..DimStyleInteriorTickMark Property
ParameterTypeId Class See Also Send Feedback
"Interior Tick Mark"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DimStyleInteriorTickMark { get; }
Visual Basic
Public Shared ReadOnly Property DimStyleInteriorTickMark As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DimStyleInteriorTickMark {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DimStyleLeaderTickMark Property

[image]

Revit 2024 API
ParameterTypeId..::..DimStyleLeaderTickMark Property
ParameterTypeId Class See Also Send Feedback
"Leader Tick Mark"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DimStyleLeaderTickMark { get; }
Visual Basic
Public Shared ReadOnly Property DimStyleLeaderTickMark As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DimStyleLeaderTickMark {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DimStyleLinearUnitsAlt Property

[image]

Revit 2024 API
ParameterTypeId..::..DimStyleLinearUnitsAlt Property
ParameterTypeId Class See Also Send Feedback
"Alternate Units Format"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DimStyleLinearUnitsAlt { get; }
Visual Basic
Public Shared ReadOnly Property DimStyleLinearUnitsAlt As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DimStyleLinearUnitsAlt {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DimStyleReadConvention Property

[image]

Revit 2024 API
ParameterTypeId..::..DimStyleReadConvention Property
ParameterTypeId Class See Also Send Feedback
"Read Convention"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DimStyleReadConvention { get; }
Visual Basic
Public Shared ReadOnly Property DimStyleReadConvention As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DimStyleReadConvention {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DimStyleShowOpeningHt Property

[image]

Revit 2024 API
ParameterTypeId..::..DimStyleShowOpeningHt Property
ParameterTypeId Class See Also Send Feedback
"Show Opening Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DimStyleShowOpeningHt { get; }
Visual Basic
Public Shared ReadOnly Property DimStyleShowOpeningHt As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DimStyleShowOpeningHt {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DimSuffix Property

[image]

Revit 2024 API
ParameterTypeId..::..DimSuffix Property
ParameterTypeId Class See Also Send Feedback
"Dimension Suffix"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DimSuffix { get; }
Visual Basic
Public Shared ReadOnly Property DimSuffix As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DimSuffix {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DimToInserts Property

[image]

Revit 2024 API
ParameterTypeId..::..DimToInserts Property
ParameterTypeId Class See Also Send Feedback
"Dimension To Openings"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DimToInserts { get; }
Visual Basic
Public Shared ReadOnly Property DimToInserts As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DimToInserts {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DimToInsertType Property

[image]

Revit 2024 API
ParameterTypeId..::..DimToInsertType Property
ParameterTypeId Class See Also Send Feedback
"Dimension To Opening Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DimToInsertType { get; }
Visual Basic
Public Shared ReadOnly Property DimToInsertType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DimToInsertType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DimToIntersectingGrids Property

[image]

Revit 2024 API
ParameterTypeId..::..DimToIntersectingGrids Property
ParameterTypeId Class See Also Send Feedback
"Dimension To Intersecting Grids"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DimToIntersectingGrids { get; }
Visual Basic
Public Shared ReadOnly Property DimToIntersectingGrids As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DimToIntersectingGrids {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DimToIntersectingWalls Property

[image]

Revit 2024 API
ParameterTypeId..::..DimToIntersectingWalls Property
ParameterTypeId Class See Also Send Feedback
"Dimension To Intersecting Walls"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DimToIntersectingWalls { get; }
Visual Basic
Public Shared ReadOnly Property DimToIntersectingWalls As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DimToIntersectingWalls {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DimTotalLength Property

[image]

Revit 2024 API
ParameterTypeId..::..DimTotalLength Property
ParameterTypeId Class See Also Send Feedback
"Total Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DimTotalLength { get; }
Visual Basic
Public Shared ReadOnly Property DimTotalLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DimTotalLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DimValueAngle Property

[image]

Revit 2024 API
ParameterTypeId..::..DimValueAngle Property
ParameterTypeId Class See Also Send Feedback
"Value"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DimValueAngle { get; }
Visual Basic
Public Shared ReadOnly Property DimValueAngle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DimValueAngle {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DimValueLength Property

[image]

Revit 2024 API
ParameterTypeId..::..DimValueLength Property
ParameterTypeId Class See Also Send Feedback
"Value"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DimValueLength { get; }
Visual Basic
Public Shared ReadOnly Property DimValueLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DimValueLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DimWitnsLineCntrl Property

[image]

Revit 2024 API
ParameterTypeId..::..DimWitnsLineCntrl Property
ParameterTypeId Class See Also Send Feedback
"Witness Line Control"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DimWitnsLineCntrl { get; }
Visual Basic
Public Shared ReadOnly Property DimWitnsLineCntrl As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DimWitnsLineCntrl {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


Directcontext3dApplicationId Property

[image]

Revit 2024 API
ParameterTypeId..::..Directcontext3dApplicationId Property
ParameterTypeId Class See Also Send Feedback
"ApplicationId"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId Directcontext3dApplicationId { get; }
Visual Basic
Public Shared ReadOnly Property Directcontext3dApplicationId As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Directcontext3dApplicationId {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


Directcontext3dLoaded Property

[image]

Revit 2024 API
ParameterTypeId..::..Directcontext3dLoaded Property
ParameterTypeId Class See Also Send Feedback
"Loaded"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId Directcontext3dLoaded { get; }
Visual Basic
Public Shared ReadOnly Property Directcontext3dLoaded As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Directcontext3dLoaded {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


Directcontext3dName Property

[image]

Revit 2024 API
ParameterTypeId..::..Directcontext3dName Property
ParameterTypeId Class See Also Send Feedback
"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId Directcontext3dName { get; }
Visual Basic
Public Shared ReadOnly Property Directcontext3dName As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Directcontext3dName {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


Directcontext3dServerId Property

[image]

Revit 2024 API
ParameterTypeId..::..Directcontext3dServerId Property
ParameterTypeId Class See Also Send Feedback
"ServerId"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId Directcontext3dServerId { get; }
Visual Basic
Public Shared ReadOnly Property Directcontext3dServerId As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Directcontext3dServerId {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DisplacedElementDisplacementX Property

[image]

Revit 2024 API
ParameterTypeId..::..DisplacedElementDisplacementX Property
ParameterTypeId Class See Also Send Feedback
"X Displacement"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DisplacedElementDisplacementX { get; }
Visual Basic
Public Shared ReadOnly Property DisplacedElementDisplacementX As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DisplacedElementDisplacementX {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DisplacedElementDisplacementY Property

[image]

Revit 2024 API
ParameterTypeId..::..DisplacedElementDisplacementY Property
ParameterTypeId Class See Also Send Feedback
"Y Displacement"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DisplacedElementDisplacementY { get; }
Visual Basic
Public Shared ReadOnly Property DisplacedElementDisplacementY As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DisplacedElementDisplacementY {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DisplacedElementDisplacementZ Property

[image]

Revit 2024 API
ParameterTypeId..::..DisplacedElementDisplacementZ Property
ParameterTypeId Class See Also Send Feedback
"Z Displacement"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DisplacedElementDisplacementZ { get; }
Visual Basic
Public Shared ReadOnly Property DisplacedElementDisplacementZ As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DisplacedElementDisplacementZ {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DisplacementPathStyle Property

[image]

Revit 2024 API
ParameterTypeId..::..DisplacementPathStyle Property
ParameterTypeId Class See Also Send Feedback
"Style"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DisplacementPathStyle { get; }
Visual Basic
Public Shared ReadOnly Property DisplacementPathStyle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DisplacementPathStyle {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DistanceToCutMark Property

[image]

Revit 2024 API
ParameterTypeId..::..DistanceToCutMark Property
ParameterTypeId Class See Also Send Feedback
"Distance to Cut Mark"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DistanceToCutMark { get; }
Visual Basic
Public Shared ReadOnly Property DistanceToCutMark As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DistanceToCutMark {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DividedpathBeginningIndent Property

[image]

Revit 2024 API
ParameterTypeId..::..DividedpathBeginningIndent Property
ParameterTypeId Class See Also Send Feedback
"Beginning Indent"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DividedpathBeginningIndent { get; }
Visual Basic
Public Shared ReadOnly Property DividedpathBeginningIndent As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DividedpathBeginningIndent {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DividedpathDisplayNodeNumbers Property

[image]

Revit 2024 API
ParameterTypeId..::..DividedpathDisplayNodeNumbers Property
ParameterTypeId Class See Also Send Feedback
"Show Node Numbers"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DividedpathDisplayNodeNumbers { get; }
Visual Basic
Public Shared ReadOnly Property DividedpathDisplayNodeNumbers As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DividedpathDisplayNodeNumbers {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DividedpathDisplayReferenceCurves Property

[image]

Revit 2024 API
ParameterTypeId..::..DividedpathDisplayReferenceCurves Property
ParameterTypeId Class See Also Send Feedback
"Display Path"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DividedpathDisplayReferenceCurves { get; }
Visual Basic
Public Shared ReadOnly Property DividedpathDisplayReferenceCurves As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DividedpathDisplayReferenceCurves {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DividedpathDistance Property

[image]

Revit 2024 API
ParameterTypeId..::..DividedpathDistance Property
ParameterTypeId Class See Also Send Feedback
"Distance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DividedpathDistance { get; }
Visual Basic
Public Shared ReadOnly Property DividedpathDistance As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DividedpathDistance {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DividedpathEndIndent Property

[image]

Revit 2024 API
ParameterTypeId..::..DividedpathEndIndent Property
ParameterTypeId Class See Also Send Feedback
"End Indent"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DividedpathEndIndent { get; }
Visual Basic
Public Shared ReadOnly Property DividedpathEndIndent As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DividedpathEndIndent {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DividedpathFlipDirection Property

[image]

Revit 2024 API
ParameterTypeId..::..DividedpathFlipDirection Property
ParameterTypeId Class See Also Send Feedback
"Flip Direction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DividedpathFlipDirection { get; }
Visual Basic
Public Shared ReadOnly Property DividedpathFlipDirection As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DividedpathFlipDirection {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DividedpathJustification Property

[image]

Revit 2024 API
ParameterTypeId..::..DividedpathJustification Property
ParameterTypeId Class See Also Send Feedback
"Justification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DividedpathJustification { get; }
Visual Basic
Public Shared ReadOnly Property DividedpathJustification As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DividedpathJustification {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DividedpathLayout Property

[image]

Revit 2024 API
ParameterTypeId..::..DividedpathLayout Property
ParameterTypeId Class See Also Send Feedback
"Layout"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DividedpathLayout { get; }
Visual Basic
Public Shared ReadOnly Property DividedpathLayout As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DividedpathLayout {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DividedpathLayoutFixedNumPoint Property

[image]

Revit 2024 API
ParameterTypeId..::..DividedpathLayoutFixedNumPoint Property
ParameterTypeId Class See Also Send Feedback
"Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DividedpathLayoutFixedNumPoint { get; }
Visual Basic
Public Shared ReadOnly Property DividedpathLayoutFixedNumPoint As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DividedpathLayoutFixedNumPoint {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DividedpathMaxDistance Property

[image]

Revit 2024 API
ParameterTypeId..::..DividedpathMaxDistance Property
ParameterTypeId Class See Also Send Feedback
"Maximum Distance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DividedpathMaxDistance { get; }
Visual Basic
Public Shared ReadOnly Property DividedpathMaxDistance As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DividedpathMaxDistance {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DividedpathMinDistance Property

[image]

Revit 2024 API
ParameterTypeId..::..DividedpathMinDistance Property
ParameterTypeId Class See Also Send Feedback
"Minimum Distance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DividedpathMinDistance { get; }
Visual Basic
Public Shared ReadOnly Property DividedpathMinDistance As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DividedpathMinDistance {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DividedSurfaceAllGridRotation Property

[image]

Revit 2024 API
ParameterTypeId..::..DividedSurfaceAllGridRotation Property
ParameterTypeId Class See Also Send Feedback
"All Grid Rotation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DividedSurfaceAllGridRotation { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceAllGridRotation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DividedSurfaceAllGridRotation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DividedSurfaceAllPoints Property

[image]

Revit 2024 API
ParameterTypeId..::..DividedSurfaceAllPoints Property
ParameterTypeId Class See Also Send Feedback
"Show all points"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DividedSurfaceAllPoints { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceAllPoints As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DividedSurfaceAllPoints {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DividedSurfaceComponentTrimType Property

[image]

Revit 2024 API
ParameterTypeId..::..DividedSurfaceComponentTrimType Property
ParameterTypeId Class See Also Send Feedback
"Component Trim"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DividedSurfaceComponentTrimType { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceComponentTrimType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DividedSurfaceComponentTrimType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DividedSurfaceDisplayDiscardeddivisionlines Property

[image]

Revit 2024 API
ParameterTypeId..::..DividedSurfaceDisplayDiscardeddivisionlines Property
ParameterTypeId Class See Also Send Feedback
"Discarded Division Lines"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DividedSurfaceDisplayDiscardeddivisionlines { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceDisplayDiscardeddivisionlines As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DividedSurfaceDisplayDiscardeddivisionlines {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DividedSurfaceDisplayGridlines Property

[image]

Revit 2024 API
ParameterTypeId..::..DividedSurfaceDisplayGridlines Property
ParameterTypeId Class See Also Send Feedback
"Gridlines"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DividedSurfaceDisplayGridlines { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceDisplayGridlines As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DividedSurfaceDisplayGridlines {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DividedSurfaceDisplayNodes Property

[image]

Revit 2024 API
ParameterTypeId..::..DividedSurfaceDisplayNodes Property
ParameterTypeId Class See Also Send Feedback
"Nodes"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DividedSurfaceDisplayNodes { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceDisplayNodes As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DividedSurfaceDisplayNodes {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DividedSurfaceDisplayOriginalSurface Property

[image]

Revit 2024 API
ParameterTypeId..::..DividedSurfaceDisplayOriginalSurface Property
ParameterTypeId Class See Also Send Feedback
"Surface"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DividedSurfaceDisplayOriginalSurface { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceDisplayOriginalSurface As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DividedSurfaceDisplayOriginalSurface {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DividedSurfaceDisplayPatternFill Property

[image]

Revit 2024 API
ParameterTypeId..::..DividedSurfaceDisplayPatternFill Property
ParameterTypeId Class See Also Send Feedback
"Pattern Fill"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DividedSurfaceDisplayPatternFill { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceDisplayPatternFill As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DividedSurfaceDisplayPatternFill {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DividedSurfaceDisplaySurfaceOption Property

[image]

Revit 2024 API
ParameterTypeId..::..DividedSurfaceDisplaySurfaceOption Property
ParameterTypeId Class See Also Send Feedback
"Display Surface Option"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DividedSurfaceDisplaySurfaceOption { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceDisplaySurfaceOption As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DividedSurfaceDisplaySurfaceOption {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DividedSurfaceEdgeNumber Property

[image]

Revit 2024 API
ParameterTypeId..::..DividedSurfaceEdgeNumber Property
ParameterTypeId Class See Also Send Feedback
"Edge number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DividedSurfaceEdgeNumber { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceEdgeNumber As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DividedSurfaceEdgeNumber {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DividedSurfaceFacetNumber Property

[image]

Revit 2024 API
ParameterTypeId..::..DividedSurfaceFacetNumber Property
ParameterTypeId Class See Also Send Feedback
"Facet number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DividedSurfaceFacetNumber { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceFacetNumber As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DividedSurfaceFacetNumber {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DividedSurfaceGridlinesStyle Property

[image]

Revit 2024 API
ParameterTypeId..::..DividedSurfaceGridlinesStyle Property
ParameterTypeId Class See Also Send Feedback
"Gridlines Style"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DividedSurfaceGridlinesStyle { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceGridlinesStyle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DividedSurfaceGridlinesStyle {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DividedSurfaceGridOptionParamn2 Property

[image]

Revit 2024 API
ParameterTypeId..::..DividedSurfaceGridOptionParamn2 Property
ParameterTypeId Class See Also Send Feedback
"Option 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DividedSurfaceGridOptionParamn2 { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceGridOptionParamn2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DividedSurfaceGridOptionParamn2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DividedSurfaceOffsetFromSurface Property

[image]

Revit 2024 API
ParameterTypeId..::..DividedSurfaceOffsetFromSurface Property
ParameterTypeId Class See Also Send Feedback
"Offset from surface"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DividedSurfaceOffsetFromSurface { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceOffsetFromSurface As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DividedSurfaceOffsetFromSurface {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DividedSurfacePattern Property

[image]

Revit 2024 API
ParameterTypeId..::..DividedSurfacePattern Property
ParameterTypeId Class See Also Send Feedback
"Tile Pattern"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DividedSurfacePattern { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfacePattern As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DividedSurfacePattern {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DividedSurfacePatternFillMaterial Property

[image]

Revit 2024 API
ParameterTypeId..::..DividedSurfacePatternFillMaterial Property
ParameterTypeId Class See Also Send Feedback
"Pattern Fill Material"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DividedSurfacePatternFillMaterial { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfacePatternFillMaterial As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DividedSurfacePatternFillMaterial {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DividedSurfacePatternFlip Property

[image]

Revit 2024 API
ParameterTypeId..::..DividedSurfacePatternFlip Property
ParameterTypeId Class See Also Send Feedback
"Component Flip"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DividedSurfacePatternFlip { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfacePatternFlip As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DividedSurfacePatternFlip {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DividedSurfacePatternLinesStyle Property

[image]

Revit 2024 API
ParameterTypeId..::..DividedSurfacePatternLinesStyle Property
ParameterTypeId Class See Also Send Feedback
"Pattern Lines Style"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DividedSurfacePatternLinesStyle { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfacePatternLinesStyle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DividedSurfacePatternLinesStyle {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DividedSurfacePatternMirror Property

[image]

Revit 2024 API
ParameterTypeId..::..DividedSurfacePatternMirror Property
ParameterTypeId Class See Also Send Feedback
"Component Mirror"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DividedSurfacePatternMirror { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfacePatternMirror As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DividedSurfacePatternMirror {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DividedSurfacePatternRotationAngle Property

[image]

Revit 2024 API
ParameterTypeId..::..DividedSurfacePatternRotationAngle Property
ParameterTypeId Class See Also Send Feedback
"Component Rotation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DividedSurfacePatternRotationAngle { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfacePatternRotationAngle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DividedSurfacePatternRotationAngle {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DividedSurfaceRule1Suspension Property

[image]

Revit 2024 API
ParameterTypeId..::..DividedSurfaceRule1Suspension Property
ParameterTypeId Class See Also Send Feedback
"Is grid 1 suspended?"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DividedSurfaceRule1Suspension { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceRule1Suspension As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DividedSurfaceRule1Suspension {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DividedSurfaceRule2Suspension Property

[image]

Revit 2024 API
ParameterTypeId..::..DividedSurfaceRule2Suspension Property
ParameterTypeId Class See Also Send Feedback
"Is grid 2 suspended?"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DividedSurfaceRule2Suspension { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceRule2Suspension As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DividedSurfaceRule2Suspension {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DividedSurfaceSurfaceArea Property

[image]

Revit 2024 API
ParameterTypeId..::..DividedSurfaceSurfaceArea Property
ParameterTypeId Class See Also Send Feedback
"Divided Surface Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DividedSurfaceSurfaceArea { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceSurfaceArea As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DividedSurfaceSurfaceArea {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DividedSurfaceTileBorder Property

[image]

Revit 2024 API
ParameterTypeId..::..DividedSurfaceTileBorder Property
ParameterTypeId Class See Also Send Feedback
"Border Tile"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DividedSurfaceTileBorder { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceTileBorder As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DividedSurfaceTileBorder {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DividedSurfaceTotalEdgeLength Property

[image]

Revit 2024 API
ParameterTypeId..::..DividedSurfaceTotalEdgeLength Property
ParameterTypeId Class See Also Send Feedback
"Total edge length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DividedSurfaceTotalEdgeLength { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceTotalEdgeLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DividedSurfaceTotalEdgeLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DivisionPattern Property

[image]

Revit 2024 API
ParameterTypeId..::..DivisionPattern Property
ParameterTypeId Class See Also Send Feedback
"Division Pattern"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DivisionPattern { get; }
Visual Basic
Public Shared ReadOnly Property DivisionPattern As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DivisionPattern {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DivisionRuleParam Property

[image]

Revit 2024 API
ParameterTypeId..::..DivisionRuleParam Property
ParameterTypeId Class See Also Send Feedback
"Division Rule"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DivisionRuleParam { get; }
Visual Basic
Public Shared ReadOnly Property DivisionRuleParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DivisionRuleParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DivisionSketchCurveDivisionParamsOverrideParam Property

[image]

Revit 2024 API
ParameterTypeId..::..DivisionSketchCurveDivisionParamsOverrideParam Property
ParameterTypeId Class See Also Send Feedback
"Profile Override"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DivisionSketchCurveDivisionParamsOverrideParam { get; }
Visual Basic
Public Shared ReadOnly Property DivisionSketchCurveDivisionParamsOverrideParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DivisionSketchCurveDivisionParamsOverrideParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DoorConstructionType Property

[image]

Revit 2024 API
ParameterTypeId..::..DoorConstructionType Property
ParameterTypeId Class See Also Send Feedback
"Construction Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DoorConstructionType { get; }
Visual Basic
Public Shared ReadOnly Property DoorConstructionType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DoorConstructionType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DoorFinish Property

[image]

Revit 2024 API
ParameterTypeId..::..DoorFinish Property
ParameterTypeId Class See Also Send Feedback
"Finish"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DoorFinish { get; }
Visual Basic
Public Shared ReadOnly Property DoorFinish As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DoorFinish {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DoorNumber Property

[image]

Revit 2024 API
ParameterTypeId..::..DoorNumber Property
ParameterTypeId Class See Also Send Feedback
"Mark"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DoorNumber { get; }
Visual Basic
Public Shared ReadOnly Property DoorNumber As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DoorNumber {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DoorOperationType Property

[image]

Revit 2024 API
ParameterTypeId..::..DoorOperationType Property
ParameterTypeId Class See Also Send Feedback
"Operation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DoorOperationType { get; }
Visual Basic
Public Shared ReadOnly Property DoorOperationType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DoorOperationType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DpartAreaComputed Property

[image]

Revit 2024 API
ParameterTypeId..::..DpartAreaComputed Property
ParameterTypeId Class See Also Send Feedback
"Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DpartAreaComputed { get; }
Visual Basic
Public Shared ReadOnly Property DpartAreaComputed As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DpartAreaComputed {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DpartBaseLevelByOriginal Property

[image]

Revit 2024 API
ParameterTypeId..::..DpartBaseLevelByOriginal Property
ParameterTypeId Class See Also Send Feedback
"Base Level By Original"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DpartBaseLevelByOriginal { get; }
Visual Basic
Public Shared ReadOnly Property DpartBaseLevelByOriginal As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DpartBaseLevelByOriginal {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DpartHeightComputed Property

[image]

Revit 2024 API
ParameterTypeId..::..DpartHeightComputed Property
ParameterTypeId Class See Also Send Feedback
"Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DpartHeightComputed { get; }
Visual Basic
Public Shared ReadOnly Property DpartHeightComputed As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DpartHeightComputed {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DpartLayerFunction Property

[image]

Revit 2024 API
ParameterTypeId..::..DpartLayerFunction Property
ParameterTypeId Class See Also Send Feedback
"Layer Function"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DpartLayerFunction { get; }
Visual Basic
Public Shared ReadOnly Property DpartLayerFunction As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DpartLayerFunction {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DpartLayerWidth Property

[image]

Revit 2024 API
ParameterTypeId..::..DpartLayerWidth Property
ParameterTypeId Class See Also Send Feedback
"Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DpartLayerWidth { get; }
Visual Basic
Public Shared ReadOnly Property DpartLayerWidth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DpartLayerWidth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DpartMaterialByOriginal Property

[image]

Revit 2024 API
ParameterTypeId..::..DpartMaterialByOriginal Property
ParameterTypeId Class See Also Send Feedback
"Material By Original"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DpartMaterialByOriginal { get; }
Visual Basic
Public Shared ReadOnly Property DpartMaterialByOriginal As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DpartMaterialByOriginal {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DpartMaterialIdParam Property

[image]

Revit 2024 API
ParameterTypeId..::..DpartMaterialIdParam Property
ParameterTypeId Class See Also Send Feedback
"Material"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DpartMaterialIdParam { get; }
Visual Basic
Public Shared ReadOnly Property DpartMaterialIdParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DpartMaterialIdParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DpartOriginalFamily Property

[image]

Revit 2024 API
ParameterTypeId..::..DpartOriginalFamily Property
ParameterTypeId Class See Also Send Feedback
"Original Family"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DpartOriginalFamily { get; }
Visual Basic
Public Shared ReadOnly Property DpartOriginalFamily As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DpartOriginalFamily {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DpartOriginalType Property

[image]

Revit 2024 API
ParameterTypeId..::..DpartOriginalType Property
ParameterTypeId Class See Also Send Feedback
"Original Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DpartOriginalType { get; }
Visual Basic
Public Shared ReadOnly Property DpartOriginalType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DpartOriginalType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DpartPhaseCreatedByOriginal Property

[image]

Revit 2024 API
ParameterTypeId..::..DpartPhaseCreatedByOriginal Property
ParameterTypeId Class See Also Send Feedback
"Phase Created By Original"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DpartPhaseCreatedByOriginal { get; }
Visual Basic
Public Shared ReadOnly Property DpartPhaseCreatedByOriginal As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DpartPhaseCreatedByOriginal {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DpartPhaseDemolishedByOriginal Property

[image]

Revit 2024 API
ParameterTypeId..::..DpartPhaseDemolishedByOriginal Property
ParameterTypeId Class See Also Send Feedback
"Phase Demolished By Original"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DpartPhaseDemolishedByOriginal { get; }
Visual Basic
Public Shared ReadOnly Property DpartPhaseDemolishedByOriginal As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DpartPhaseDemolishedByOriginal {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DpartShapeModified Property

[image]

Revit 2024 API
ParameterTypeId..::..DpartShapeModified Property
ParameterTypeId Class See Also Send Feedback
"Shape is modified"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DpartShapeModified { get; }
Visual Basic
Public Shared ReadOnly Property DpartShapeModified As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DpartShapeModified {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DpartVolumeComputed Property

[image]

Revit 2024 API
ParameterTypeId..::..DpartVolumeComputed Property
ParameterTypeId Class See Also Send Feedback
"Volume"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DpartVolumeComputed { get; }
Visual Basic
Public Shared ReadOnly Property DpartVolumeComputed As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DpartVolumeComputed {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DrawForEachRun Property

[image]

Revit 2024 API
ParameterTypeId..::..DrawForEachRun Property
ParameterTypeId Class See Also Send Feedback
"Draw for Each Run"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DrawForEachRun { get; }
Visual Basic
Public Shared ReadOnly Property DrawForEachRun As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DrawForEachRun {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


DuctRoughness Property

[image]

Revit 2024 API
ParameterTypeId..::..DuctRoughness Property
ParameterTypeId Class See Also Send Feedback
"Roughness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId DuctRoughness { get; }
Visual Basic
Public Shared ReadOnly Property DuctRoughness As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DuctRoughness {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


EdgeLinework Property

[image]

Revit 2024 API
ParameterTypeId..::..EdgeLinework Property
ParameterTypeId Class See Also Send Feedback
"Line Style"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId EdgeLinework { get; }
Visual Basic
Public Shared ReadOnly Property EdgeLinework As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ EdgeLinework {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ElecticalEquipVoltage Property

[image]

Revit 2024 API
ParameterTypeId..::..ElecticalEquipVoltage Property
ParameterTypeId Class See Also Send Feedback
"Voltage"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ElecticalEquipVoltage { get; }
Visual Basic
Public Shared ReadOnly Property ElecticalEquipVoltage As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ElecticalEquipVoltage {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ElecticalEquipWattage Property

[image]

Revit 2024 API
ParameterTypeId..::..ElecticalEquipWattage Property
ParameterTypeId Class See Also Send Feedback
"Wattage"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ElecticalEquipWattage { get; }
Visual Basic
Public Shared ReadOnly Property ElecticalEquipWattage As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ElecticalEquipWattage {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ElemCategoryParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ElemCategoryParam Property
ParameterTypeId Class See Also Send Feedback
"Category"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ElemCategoryParam { get; }
Visual Basic
Public Shared ReadOnly Property ElemCategoryParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ElemCategoryParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ElemCategoryParamMt Property

[image]

Revit 2024 API
ParameterTypeId..::..ElemCategoryParamMt Property
ParameterTypeId Class See Also Send Feedback
"Category"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ElemCategoryParamMt { get; }
Visual Basic
Public Shared ReadOnly Property ElemCategoryParamMt As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ElemCategoryParamMt {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ElemDeletableInFamily Property

[image]

Revit 2024 API
ParameterTypeId..::..ElemDeletableInFamily Property
ParameterTypeId Class See Also Send Feedback
"Deletable"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ElemDeletableInFamily { get; }
Visual Basic
Public Shared ReadOnly Property ElemDeletableInFamily As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ElemDeletableInFamily {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ElementIsCutting Property

[image]

Revit 2024 API
ParameterTypeId..::..ElementIsCutting Property
ParameterTypeId Class See Also Send Feedback
"Solid/Void"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ElementIsCutting { get; }
Visual Basic
Public Shared ReadOnly Property ElementIsCutting As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ElementIsCutting {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ElemFamilyAndTypeParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ElemFamilyAndTypeParam Property
ParameterTypeId Class See Also Send Feedback
"Family and Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ElemFamilyAndTypeParam { get; }
Visual Basic
Public Shared ReadOnly Property ElemFamilyAndTypeParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ElemFamilyAndTypeParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ElemFamilyParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ElemFamilyParam Property
ParameterTypeId Class See Also Send Feedback
"Family"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ElemFamilyParam { get; }
Visual Basic
Public Shared ReadOnly Property ElemFamilyParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ElemFamilyParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ElemIsReference Property

[image]

Revit 2024 API
ParameterTypeId..::..ElemIsReference Property
ParameterTypeId Class See Also Send Feedback
"Reference"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ElemIsReference { get; }
Visual Basic
Public Shared ReadOnly Property ElemIsReference As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ElemIsReference {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ElemPartitionParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ElemPartitionParam Property
ParameterTypeId Class See Also Send Feedback
"Workset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ElemPartitionParam { get; }
Visual Basic
Public Shared ReadOnly Property ElemPartitionParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ElemPartitionParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ElemReferenceName2dXz Property

[image]

Revit 2024 API
ParameterTypeId..::..ElemReferenceName2dXz Property
ParameterTypeId Class See Also Send Feedback
"Is Reference"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ElemReferenceName2dXz { get; }
Visual Basic
Public Shared ReadOnly Property ElemReferenceName2dXz As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ElemReferenceName2dXz {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ElemRoomId Property

[image]

Revit 2024 API
ParameterTypeId..::..ElemRoomId Property
ParameterTypeId Class See Also Send Feedback
"Room Id"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ElemRoomId { get; }
Visual Basic
Public Shared ReadOnly Property ElemRoomId As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ElemRoomId {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ElemTypeLabel Property

[image]

Revit 2024 API
ParameterTypeId..::..ElemTypeLabel Property
ParameterTypeId Class See Also Send Feedback
"Label"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ElemTypeLabel { get; }
Visual Basic
Public Shared ReadOnly Property ElemTypeLabel As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ElemTypeLabel {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ElemTypeParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ElemTypeParam Property
ParameterTypeId Class See Also Send Feedback
"Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ElemTypeParam { get; }
Visual Basic
Public Shared ReadOnly Property ElemTypeParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ElemTypeParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ElevArrowAngle Property

[image]

Revit 2024 API
ParameterTypeId..::..ElevArrowAngle Property
ParameterTypeId Class See Also Send Feedback
"Arrow Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ElevArrowAngle { get; }
Visual Basic
Public Shared ReadOnly Property ElevArrowAngle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ElevArrowAngle {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ElevArrowFilled Property

[image]

Revit 2024 API
ParameterTypeId..::..ElevArrowFilled Property
ParameterTypeId Class See Also Send Feedback
"Filled"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ElevArrowFilled { get; }
Visual Basic
Public Shared ReadOnly Property ElevArrowFilled As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ElevArrowFilled {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ElevAssocDatum Property

[image]

Revit 2024 API
ParameterTypeId..::..ElevAssocDatum Property
ParameterTypeId Class See Also Send Feedback
"Associated Datum"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ElevAssocDatum { get; }
Visual Basic
Public Shared ReadOnly Property ElevAssocDatum As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ElevAssocDatum {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ElevatnTag Property

[image]

Revit 2024 API
ParameterTypeId..::..ElevatnTag Property
ParameterTypeId Class See Also Send Feedback
"Elevation Tag"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ElevatnTag { get; }
Visual Basic
Public Shared ReadOnly Property ElevatnTag As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ElevatnTag {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ElevReferenceLabelPos Property

[image]

Revit 2024 API
ParameterTypeId..::..ElevReferenceLabelPos Property
ParameterTypeId Class See Also Send Feedback
"Reference Label Position"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ElevReferenceLabelPos { get; }
Visual Basic
Public Shared ReadOnly Property ElevReferenceLabelPos As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ElevReferenceLabelPos {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ElevShape Property

[image]

Revit 2024 API
ParameterTypeId..::..ElevShape Property
ParameterTypeId Class See Also Send Feedback
"Shape"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ElevShape { get; }
Visual Basic
Public Shared ReadOnly Property ElevShape As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ElevShape {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ElevShowViewName Property

[image]

Revit 2024 API
ParameterTypeId..::..ElevShowViewName Property
ParameterTypeId Class See Also Send Feedback
"Show View Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ElevShowViewName { get; }
Visual Basic
Public Shared ReadOnly Property ElevShowViewName As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ElevShowViewName {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ElevSymbolId Property

[image]

Revit 2024 API
ParameterTypeId..::..ElevSymbolId Property
ParameterTypeId Class See Also Send Feedback
"Elevation Mark"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ElevSymbolId { get; }
Visual Basic
Public Shared ReadOnly Property ElevSymbolId As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ElevSymbolId {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ElevTextPos Property

[image]

Revit 2024 API
ParameterTypeId..::..ElevTextPos Property
ParameterTypeId Class See Also Send Feedback
"Text Position"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ElevTextPos { get; }
Visual Basic
Public Shared ReadOnly Property ElevTextPos As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ElevTextPos {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ElevViewNamePos Property

[image]

Revit 2024 API
ParameterTypeId..::..ElevViewNamePos Property
ParameterTypeId Class See Also Send Feedback
"View Name Position"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ElevViewNamePos { get; }
Visual Basic
Public Shared ReadOnly Property ElevViewNamePos As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ElevViewNamePos {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ElevWidth Property

[image]

Revit 2024 API
ParameterTypeId..::..ElevWidth Property
ParameterTypeId Class See Also Send Feedback
"Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ElevWidth { get; }
Visual Basic
Public Shared ReadOnly Property ElevWidth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ElevWidth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


EllipseFocusMrkVisible Property

[image]

Revit 2024 API
ParameterTypeId..::..EllipseFocusMrkVisible Property
ParameterTypeId Class See Also Send Feedback
"Focus Marks Visible"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId EllipseFocusMrkVisible { get; }
Visual Basic
Public Shared ReadOnly Property EllipseFocusMrkVisible As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ EllipseFocusMrkVisible {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


EllipseXParam Property

[image]

Revit 2024 API
ParameterTypeId..::..EllipseXParam Property
ParameterTypeId Class See Also Send Feedback
"X-Radius Value for Ellipse (for Use with XAML Data Template example)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId EllipseXParam { get; }
Visual Basic
Public Shared ReadOnly Property EllipseXParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ EllipseXParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


EllipseYParam Property

[image]

Revit 2024 API
ParameterTypeId..::..EllipseYParam Property
ParameterTypeId Class See Also Send Feedback
"Y-Radius Value for Ellipse (for Use with XAML Data Template example)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId EllipseYParam { get; }
Visual Basic
Public Shared ReadOnly Property EllipseYParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ EllipseYParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


EndJoinCutback Property

[image]

Revit 2024 API
ParameterTypeId..::..EndJoinCutback Property
ParameterTypeId Class See Also Send Feedback
"End Join Cutback"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId EndJoinCutback { get; }
Visual Basic
Public Shared ReadOnly Property EndJoinCutback As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ EndJoinCutback {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


EndTreatment Property

[image]

Revit 2024 API
ParameterTypeId..::..EndTreatment Property
ParameterTypeId Class See Also Send Feedback
"End Treatment"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId EndTreatment { get; }
Visual Basic
Public Shared ReadOnly Property EndTreatment As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ EndTreatment {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


EndYJustification Property

[image]

Revit 2024 API
ParameterTypeId..::..EndYJustification Property
ParameterTypeId Class See Also Send Feedback
"End y Justification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId EndYJustification { get; }
Visual Basic
Public Shared ReadOnly Property EndYJustification As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ EndYJustification {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


EndYOffsetValue Property

[image]

Revit 2024 API
ParameterTypeId..::..EndYOffsetValue Property
ParameterTypeId Class See Also Send Feedback
"End y Offset Value"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId EndYOffsetValue { get; }
Visual Basic
Public Shared ReadOnly Property EndYOffsetValue As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ EndYOffsetValue {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


EndZJustification Property

[image]

Revit 2024 API
ParameterTypeId..::..EndZJustification Property
ParameterTypeId Class See Also Send Feedback
"End z Justification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId EndZJustification { get; }
Visual Basic
Public Shared ReadOnly Property EndZJustification As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ EndZJustification {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


EndZOffsetValue Property

[image]

Revit 2024 API
ParameterTypeId..::..EndZOffsetValue Property
ParameterTypeId Class See Also Send Feedback
"End z Offset Value"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId EndZOffsetValue { get; }
Visual Basic
Public Shared ReadOnly Property EndZOffsetValue As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ EndZOffsetValue {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


EnergyAnalysisAdvancedOptions Property

[image]

Revit 2024 API
ParameterTypeId..::..EnergyAnalysisAdvancedOptions Property
ParameterTypeId Class See Also Send Feedback
"Other Options"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId EnergyAnalysisAdvancedOptions { get; }
Visual Basic
Public Shared ReadOnly Property EnergyAnalysisAdvancedOptions As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ EnergyAnalysisAdvancedOptions {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


EnergyAnalysisBuildingOperatingSchedule Property

[image]

Revit 2024 API
ParameterTypeId..::..EnergyAnalysisBuildingOperatingSchedule Property
ParameterTypeId Class See Also Send Feedback
"Building Operating Schedule"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId EnergyAnalysisBuildingOperatingSchedule { get; }
Visual Basic
Public Shared ReadOnly Property EnergyAnalysisBuildingOperatingSchedule As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ EnergyAnalysisBuildingOperatingSchedule {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


EnergyAnalysisConceptualConstruction Property

[image]

Revit 2024 API
ParameterTypeId..::..EnergyAnalysisConceptualConstruction Property
ParameterTypeId Class See Also Send Feedback
"Conceptual Types"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId EnergyAnalysisConceptualConstruction { get; }
Visual Basic
Public Shared ReadOnly Property EnergyAnalysisConceptualConstruction As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ EnergyAnalysisConceptualConstruction {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


EnergyAnalysisCreateAnalyticalModel Property

[image]

Revit 2024 API
ParameterTypeId..::..EnergyAnalysisCreateAnalyticalModel Property
ParameterTypeId Class See Also Send Feedback
"Create Energy Model"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId EnergyAnalysisCreateAnalyticalModel { get; }
Visual Basic
Public Shared ReadOnly Property EnergyAnalysisCreateAnalyticalModel As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ EnergyAnalysisCreateAnalyticalModel {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


EnergyAnalysisCurrentViewOnly Property

[image]

Revit 2024 API
ParameterTypeId..::..EnergyAnalysisCurrentViewOnly Property
ParameterTypeId Class See Also Send Feedback
"Use Only Elements Visible In Current View"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId EnergyAnalysisCurrentViewOnly { get; }
Visual Basic
Public Shared ReadOnly Property EnergyAnalysisCurrentViewOnly As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ EnergyAnalysisCurrentViewOnly {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


EnergyAnalysisGlazingIsShaded Property

[image]

Revit 2024 API
ParameterTypeId..::..EnergyAnalysisGlazingIsShaded Property
ParameterTypeId Class See Also Send Feedback
"Glazing is Shaded"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId EnergyAnalysisGlazingIsShaded { get; }
Visual Basic
Public Shared ReadOnly Property EnergyAnalysisGlazingIsShaded As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ EnergyAnalysisGlazingIsShaded {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


EnergyAnalysisHorizontalVoidThreshold Property

[image]

Revit 2024 API
ParameterTypeId..::..EnergyAnalysisHorizontalVoidThreshold Property
ParameterTypeId Class See Also Send Feedback
"Horizontal Void/Chase Area Threshold"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId EnergyAnalysisHorizontalVoidThreshold { get; }
Visual Basic
Public Shared ReadOnly Property EnergyAnalysisHorizontalVoidThreshold As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ EnergyAnalysisHorizontalVoidThreshold {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


EnergyAnalysisHvacSystem Property

[image]

Revit 2024 API
ParameterTypeId..::..EnergyAnalysisHvacSystem Property
ParameterTypeId Class See Also Send Feedback
"HVAC System"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId EnergyAnalysisHvacSystem { get; }
Visual Basic
Public Shared ReadOnly Property EnergyAnalysisHvacSystem As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ EnergyAnalysisHvacSystem {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


EnergyAnalysisMasszoneCoreoffset Property

[image]

Revit 2024 API
ParameterTypeId..::..EnergyAnalysisMasszoneCoreoffset Property
ParameterTypeId Class See Also Send Feedback
"Perimeter Zone Depth"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId EnergyAnalysisMasszoneCoreoffset { get; }
Visual Basic
Public Shared ReadOnly Property EnergyAnalysisMasszoneCoreoffset As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ EnergyAnalysisMasszoneCoreoffset {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


EnergyAnalysisMasszoneDivideperimeter Property

[image]

Revit 2024 API
ParameterTypeId..::..EnergyAnalysisMasszoneDivideperimeter Property
ParameterTypeId Class See Also Send Feedback
"Perimeter Zone Division"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId EnergyAnalysisMasszoneDivideperimeter { get; }
Visual Basic
Public Shared ReadOnly Property EnergyAnalysisMasszoneDivideperimeter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ EnergyAnalysisMasszoneDivideperimeter {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


EnergyAnalysisMassZoning Property

[image]

Revit 2024 API
ParameterTypeId..::..EnergyAnalysisMassZoning Property
ParameterTypeId Class See Also Send Feedback
"Mass Zoning"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId EnergyAnalysisMassZoning { get; }
Visual Basic
Public Shared ReadOnly Property EnergyAnalysisMassZoning As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ EnergyAnalysisMassZoning {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


EnergyAnalysisPercentageGlazing Property

[image]

Revit 2024 API
ParameterTypeId..::..EnergyAnalysisPercentageGlazing Property
ParameterTypeId Class See Also Send Feedback
"Target Percentage Glazing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId EnergyAnalysisPercentageGlazing { get; }
Visual Basic
Public Shared ReadOnly Property EnergyAnalysisPercentageGlazing As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ EnergyAnalysisPercentageGlazing {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


EnergyAnalysisProjectPhase Property

[image]

Revit 2024 API
ParameterTypeId..::..EnergyAnalysisProjectPhase Property
ParameterTypeId Class See Also Send Feedback
"Phase"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId EnergyAnalysisProjectPhase { get; }
Visual Basic
Public Shared ReadOnly Property EnergyAnalysisProjectPhase As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ EnergyAnalysisProjectPhase {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


EnergyAnalysisSillHeight Property

[image]

Revit 2024 API
ParameterTypeId..::..EnergyAnalysisSillHeight Property
ParameterTypeId Class See Also Send Feedback
"Target Sill Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId EnergyAnalysisSillHeight { get; }
Visual Basic
Public Shared ReadOnly Property EnergyAnalysisSillHeight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ EnergyAnalysisSillHeight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


EnergyAnalysisSkylightWidth Property

[image]

Revit 2024 API
ParameterTypeId..::..EnergyAnalysisSkylightWidth Property
ParameterTypeId Class See Also Send Feedback
"Skylight Width & Depth"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId EnergyAnalysisSkylightWidth { get; }
Visual Basic
Public Shared ReadOnly Property EnergyAnalysisSkylightWidth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ EnergyAnalysisSkylightWidth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


EnergyAnalysisVerticalVoidThreshold Property

[image]

Revit 2024 API
ParameterTypeId..::..EnergyAnalysisVerticalVoidThreshold Property
ParameterTypeId Class See Also Send Feedback
"Average Vertical Void Height Threshold"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId EnergyAnalysisVerticalVoidThreshold { get; }
Visual Basic
Public Shared ReadOnly Property EnergyAnalysisVerticalVoidThreshold As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ EnergyAnalysisVerticalVoidThreshold {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


EqualityFormula Property

[image]

Revit 2024 API
ParameterTypeId..::..EqualityFormula Property
ParameterTypeId Class See Also Send Feedback
"Equality Formula"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId EqualityFormula { get; }
Visual Basic
Public Shared ReadOnly Property EqualityFormula As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ EqualityFormula {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


EqualityTextForAngularDim Property

[image]

Revit 2024 API
ParameterTypeId..::..EqualityTextForAngularDim Property
ParameterTypeId Class See Also Send Feedback
"Equality Text"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId EqualityTextForAngularDim { get; }
Visual Basic
Public Shared ReadOnly Property EqualityTextForAngularDim As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ EqualityTextForAngularDim {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


EqualityTextForContinuousLinearDim Property

[image]

Revit 2024 API
ParameterTypeId..::..EqualityTextForContinuousLinearDim Property
ParameterTypeId Class See Also Send Feedback
"Equality Text"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId EqualityTextForContinuousLinearDim { get; }
Visual Basic
Public Shared ReadOnly Property EqualityTextForContinuousLinearDim As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ EqualityTextForContinuousLinearDim {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ExchangeEntityId Property

[image]

Revit 2024 API
ParameterTypeId..::..ExchangeEntityId Property
ParameterTypeId Class See Also Send Feedback
"Exchange Entity ID"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ExchangeEntityId { get; }
Visual Basic
Public Shared ReadOnly Property ExchangeEntityId As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ExchangeEntityId {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ExchangeId Property

[image]

Revit 2024 API
ParameterTypeId..::..ExchangeId Property
ParameterTypeId Class See Also Send Feedback
"Exchange ID"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ExchangeId { get; }
Visual Basic
Public Shared ReadOnly Property ExchangeId As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ExchangeId {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ExtrusionAutoParams Property

[image]

Revit 2024 API
ParameterTypeId..::..ExtrusionAutoParams Property
ParameterTypeId Class See Also Send Feedback
"Auto ends"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ExtrusionAutoParams { get; }
Visual Basic
Public Shared ReadOnly Property ExtrusionAutoParams As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ExtrusionAutoParams {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ExtrusionEndParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ExtrusionEndParam Property
ParameterTypeId Class See Also Send Feedback
"Extrusion End"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ExtrusionEndParam { get; }
Visual Basic
Public Shared ReadOnly Property ExtrusionEndParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ExtrusionEndParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ExtrusionLength Property

[image]

Revit 2024 API
ParameterTypeId..::..ExtrusionLength Property
ParameterTypeId Class See Also Send Feedback
"Depth"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ExtrusionLength { get; }
Visual Basic
Public Shared ReadOnly Property ExtrusionLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ExtrusionLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ExtrusionStartParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ExtrusionStartParam Property
ParameterTypeId Class See Also Send Feedback
"Extrusion Start"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ExtrusionStartParam { get; }
Visual Basic
Public Shared ReadOnly Property ExtrusionStartParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ExtrusionStartParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationBottomElevationIncludeInsulationOfPart Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationBottomElevationIncludeInsulationOfPart Property
ParameterTypeId Class See Also Send Feedback
"Bottom Elevation with Insulation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationBottomElevationIncludeInsulationOfPart { get; }
Visual Basic
Public Shared ReadOnly Property FabricationBottomElevationIncludeInsulationOfPart As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationBottomElevationIncludeInsulationOfPart {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationBottomElevationOfPart Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationBottomElevationOfPart Property
ParameterTypeId Class See Also Send Feedback
"Bottom Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationBottomElevationOfPart { get; }
Visual Basic
Public Shared ReadOnly Property FabricationBottomElevationOfPart As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationBottomElevationOfPart {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationBottomOfPart Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationBottomOfPart Property
ParameterTypeId Class See Also Send Feedback
"Lower End Bottom of Insulation Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationBottomOfPart { get; }
Visual Basic
Public Shared ReadOnly Property FabricationBottomOfPart As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationBottomOfPart {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationBranchSize Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationBranchSize Property
ParameterTypeId Class See Also Send Feedback
"Size of Primary Branch End"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationBranchSize { get; }
Visual Basic
Public Shared ReadOnly Property FabricationBranchSize As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationBranchSize {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationChangeServiceParam Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationChangeServiceParam Property
ParameterTypeId Class See Also Send Feedback
"Change Service"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationChangeServiceParam { get; }
Visual Basic
Public Shared ReadOnly Property FabricationChangeServiceParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationChangeServiceParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationDoublewallMaterialAbbreviation Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationDoublewallMaterialAbbreviation Property
ParameterTypeId Class See Also Send Feedback
"Double Wall Material Abbreviation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationDoublewallMaterialAbbreviation { get; }
Visual Basic
Public Shared ReadOnly Property FabricationDoublewallMaterialAbbreviation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationDoublewallMaterialAbbreviation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationDuctworkStiffenerSpec Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationDuctworkStiffenerSpec Property
ParameterTypeId Class See Also Send Feedback
"Stiffener Specification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationDuctworkStiffenerSpec { get; }
Visual Basic
Public Shared ReadOnly Property FabricationDuctworkStiffenerSpec As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationDuctworkStiffenerSpec {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationEndSize Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationEndSize Property
ParameterTypeId Class See Also Send Feedback
"Size of Connector End"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationEndSize { get; }
Visual Basic
Public Shared ReadOnly Property FabricationEndSize As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationEndSize {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationInsulationAbbreviation Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationInsulationAbbreviation Property
ParameterTypeId Class See Also Send Feedback
"Insulation Abbreviation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationInsulationAbbreviation { get; }
Visual Basic
Public Shared ReadOnly Property FabricationInsulationAbbreviation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationInsulationAbbreviation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationInsulationMaterialFinish Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationInsulationMaterialFinish Property
ParameterTypeId Class See Also Send Feedback
"Insulation Material"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationInsulationMaterialFinish { get; }
Visual Basic
Public Shared ReadOnly Property FabricationInsulationMaterialFinish As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationInsulationMaterialFinish {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationInsulationSpec Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationInsulationSpec Property
ParameterTypeId Class See Also Send Feedback
"Insulation Specification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationInsulationSpec { get; }
Visual Basic
Public Shared ReadOnly Property FabricationInsulationSpec As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationInsulationSpec {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationInsulationSpecificationAbbreviation Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationInsulationSpecificationAbbreviation Property
ParameterTypeId Class See Also Send Feedback
"Insulation Specification Abbreviation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationInsulationSpecificationAbbreviation { get; }
Visual Basic
Public Shared ReadOnly Property FabricationInsulationSpecificationAbbreviation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationInsulationSpecificationAbbreviation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationLevelParam Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationLevelParam Property
ParameterTypeId Class See Also Send Feedback
"Reference Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationLevelParam { get; }
Visual Basic
Public Shared ReadOnly Property FabricationLevelParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationLevelParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationMaterialAbbreviation Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationMaterialAbbreviation Property
ParameterTypeId Class See Also Send Feedback
"Material Abbreviation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationMaterialAbbreviation { get; }
Visual Basic
Public Shared ReadOnly Property FabricationMaterialAbbreviation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationMaterialAbbreviation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationPartAlias Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationPartAlias Property
ParameterTypeId Class See Also Send Feedback
"Alias"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationPartAlias { get; }
Visual Basic
Public Shared ReadOnly Property FabricationPartAlias As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationPartAlias {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationPartAngle Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationPartAngle Property
ParameterTypeId Class See Also Send Feedback
"Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationPartAngle { get; }
Visual Basic
Public Shared ReadOnly Property FabricationPartAngle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationPartAngle {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationPartBoughtOut Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationPartBoughtOut Property
ParameterTypeId Class See Also Send Feedback
"Bought Out"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationPartBoughtOut { get; }
Visual Basic
Public Shared ReadOnly Property FabricationPartBoughtOut As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationPartBoughtOut {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationPartCutType Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationPartCutType Property
ParameterTypeId Class See Also Send Feedback
"Cut Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationPartCutType { get; }
Visual Basic
Public Shared ReadOnly Property FabricationPartCutType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationPartCutType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationPartDepthIn Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationPartDepthIn Property
ParameterTypeId Class See Also Send Feedback
"Main Primary Depth"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationPartDepthIn { get; }
Visual Basic
Public Shared ReadOnly Property FabricationPartDepthIn As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationPartDepthIn {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationPartDepthOut Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationPartDepthOut Property
ParameterTypeId Class See Also Send Feedback
"Main Secondary Depth"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationPartDepthOut { get; }
Visual Basic
Public Shared ReadOnly Property FabricationPartDepthOut As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationPartDepthOut {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationPartDepthOutOption Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationPartDepthOutOption Property
ParameterTypeId Class See Also Send Feedback
"Main Secondary Depth Option"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationPartDepthOutOption { get; }
Visual Basic
Public Shared ReadOnly Property FabricationPartDepthOutOption As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationPartDepthOutOption {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationPartDiameterIn Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationPartDiameterIn Property
ParameterTypeId Class See Also Send Feedback
"Main Primary Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationPartDiameterIn { get; }
Visual Basic
Public Shared ReadOnly Property FabricationPartDiameterIn As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationPartDiameterIn {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationPartDiameterInOption Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationPartDiameterInOption Property
ParameterTypeId Class See Also Send Feedback
"Main Primary Diameter Option"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationPartDiameterInOption { get; }
Visual Basic
Public Shared ReadOnly Property FabricationPartDiameterInOption As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationPartDiameterInOption {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationPartDoublewallMaterial Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationPartDoublewallMaterial Property
ParameterTypeId Class See Also Send Feedback
"Double Wall Material"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationPartDoublewallMaterial { get; }
Visual Basic
Public Shared ReadOnly Property FabricationPartDoublewallMaterial As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationPartDoublewallMaterial {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationPartDoublewallMaterialArea Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationPartDoublewallMaterialArea Property
ParameterTypeId Class See Also Send Feedback
"Double Wall Material Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationPartDoublewallMaterialArea { get; }
Visual Basic
Public Shared ReadOnly Property FabricationPartDoublewallMaterialArea As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationPartDoublewallMaterialArea {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationPartDoublewallMaterialThickness Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationPartDoublewallMaterialThickness Property
ParameterTypeId Class See Also Send Feedback
"Double Wall Material Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationPartDoublewallMaterialThickness { get; }
Visual Basic
Public Shared ReadOnly Property FabricationPartDoublewallMaterialThickness As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationPartDoublewallMaterialThickness {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationPartInsulationArea Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationPartInsulationArea Property
ParameterTypeId Class See Also Send Feedback
"Insulation Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationPartInsulationArea { get; }
Visual Basic
Public Shared ReadOnly Property FabricationPartInsulationArea As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationPartInsulationArea {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationPartItemNumber Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationPartItemNumber Property
ParameterTypeId Class See Also Send Feedback
"Item Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationPartItemNumber { get; }
Visual Basic
Public Shared ReadOnly Property FabricationPartItemNumber As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationPartItemNumber {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationPartLengthOption Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationPartLengthOption Property
ParameterTypeId Class See Also Send Feedback
"Length Option"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationPartLengthOption { get; }
Visual Basic
Public Shared ReadOnly Property FabricationPartLengthOption As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationPartLengthOption {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationPartLiningArea Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationPartLiningArea Property
ParameterTypeId Class See Also Send Feedback
"Lining Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationPartLiningArea { get; }
Visual Basic
Public Shared ReadOnly Property FabricationPartLiningArea As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationPartLiningArea {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationPartMaterial Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationPartMaterial Property
ParameterTypeId Class See Also Send Feedback
"Part Material"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationPartMaterial { get; }
Visual Basic
Public Shared ReadOnly Property FabricationPartMaterial As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationPartMaterial {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationPartNotes Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationPartNotes Property
ParameterTypeId Class See Also Send Feedback
"Fabrication Notes"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationPartNotes { get; }
Visual Basic
Public Shared ReadOnly Property FabricationPartNotes As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationPartNotes {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationPartPatNo Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationPartPatNo Property
ParameterTypeId Class See Also Send Feedback
"Part Pattern Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationPartPatNo { get; }
Visual Basic
Public Shared ReadOnly Property FabricationPartPatNo As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationPartPatNo {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationPartSheetmetalArea Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationPartSheetmetalArea Property
ParameterTypeId Class See Also Send Feedback
"Part Sheet Metal Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationPartSheetmetalArea { get; }
Visual Basic
Public Shared ReadOnly Property FabricationPartSheetmetalArea As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationPartSheetmetalArea {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationPartWeight Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationPartWeight Property
ParameterTypeId Class See Also Send Feedback
"Weight"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationPartWeight { get; }
Visual Basic
Public Shared ReadOnly Property FabricationPartWeight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationPartWeight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationPartWidthInOption Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationPartWidthInOption Property
ParameterTypeId Class See Also Send Feedback
"Main Primary Width Option"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationPartWidthInOption { get; }
Visual Basic
Public Shared ReadOnly Property FabricationPartWidthInOption As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationPartWidthInOption {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationPartWidthOut Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationPartWidthOut Property
ParameterTypeId Class See Also Send Feedback
"Main Secondary Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationPartWidthOut { get; }
Visual Basic
Public Shared ReadOnly Property FabricationPartWidthOut As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationPartWidthOut {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationPartWidthOutOption Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationPartWidthOutOption Property
ParameterTypeId Class See Also Send Feedback
"Main Secondary Width Option"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationPartWidthOutOption { get; }
Visual Basic
Public Shared ReadOnly Property FabricationPartWidthOutOption As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationPartWidthOutOption {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationPrimarySize Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationPrimarySize Property
ParameterTypeId Class See Also Send Feedback
"Size of Primary End"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationPrimarySize { get; }
Visual Basic
Public Shared ReadOnly Property FabricationPrimarySize As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationPrimarySize {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationProductCode Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationProductCode Property
ParameterTypeId Class See Also Send Feedback
"Product Code"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationProductCode { get; }
Visual Basic
Public Shared ReadOnly Property FabricationProductCode As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationProductCode {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationProductDataInstallType Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationProductDataInstallType Property
ParameterTypeId Class See Also Send Feedback
"Install Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationProductDataInstallType { get; }
Visual Basic
Public Shared ReadOnly Property FabricationProductDataInstallType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationProductDataInstallType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationProductDataItemDescription Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationProductDataItemDescription Property
ParameterTypeId Class See Also Send Feedback
"Product Short Description"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationProductDataItemDescription { get; }
Visual Basic
Public Shared ReadOnly Property FabricationProductDataItemDescription As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationProductDataItemDescription {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationProductDataLongDescription Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationProductDataLongDescription Property
ParameterTypeId Class See Also Send Feedback
"Product Long Description"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationProductDataLongDescription { get; }
Visual Basic
Public Shared ReadOnly Property FabricationProductDataLongDescription As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationProductDataLongDescription {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationProductDataMaterialDescription Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationProductDataMaterialDescription Property
ParameterTypeId Class See Also Send Feedback
"Product Material Description"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationProductDataMaterialDescription { get; }
Visual Basic
Public Shared ReadOnly Property FabricationProductDataMaterialDescription As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationProductDataMaterialDescription {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationProductDataProduct Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationProductDataProduct Property
ParameterTypeId Class See Also Send Feedback
"Product Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationProductDataProduct { get; }
Visual Basic
Public Shared ReadOnly Property FabricationProductDataProduct As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationProductDataProduct {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationProductDataSizeDescription Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationProductDataSizeDescription Property
ParameterTypeId Class See Also Send Feedback
"Product Size Description"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationProductDataSizeDescription { get; }
Visual Basic
Public Shared ReadOnly Property FabricationProductDataSizeDescription As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationProductDataSizeDescription {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationProductDataSpecification Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationProductDataSpecification Property
ParameterTypeId Class See Also Send Feedback
"Product Specification Description"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationProductDataSpecification { get; }
Visual Basic
Public Shared ReadOnly Property FabricationProductDataSpecification As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationProductDataSpecification {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationRelativeFilename Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationRelativeFilename Property
ParameterTypeId Class See Also Send Feedback
"Relative File Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationRelativeFilename { get; }
Visual Basic
Public Shared ReadOnly Property FabricationRelativeFilename As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationRelativeFilename {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationServiceParam Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationServiceParam Property
ParameterTypeId Class See Also Send Feedback
"Fabrication Service"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationServiceParam { get; }
Visual Basic
Public Shared ReadOnly Property FabricationServiceParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationServiceParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationSetUpDownTagFromBottom Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationSetUpDownTagFromBottom Property
ParameterTypeId Class See Also Send Feedback
"SU/SD from Bottom"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationSetUpDownTagFromBottom { get; }
Visual Basic
Public Shared ReadOnly Property FabricationSetUpDownTagFromBottom As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationSetUpDownTagFromBottom {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationSpecification Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationSpecification Property
ParameterTypeId Class See Also Send Feedback
"Specification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationSpecification { get; }
Visual Basic
Public Shared ReadOnly Property FabricationSpecification As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationSpecification {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationSpecificationAbbreviation Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationSpecificationAbbreviation Property
ParameterTypeId Class See Also Send Feedback
"Specification Abbreviation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationSpecificationAbbreviation { get; }
Visual Basic
Public Shared ReadOnly Property FabricationSpecificationAbbreviation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationSpecificationAbbreviation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationStartOffsetParam Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationStartOffsetParam Property
ParameterTypeId Class See Also Send Feedback
"Start Middle Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationStartOffsetParam { get; }
Visual Basic
Public Shared ReadOnly Property FabricationStartOffsetParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationStartOffsetParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationTopElevationIncludeInsulationOfPart Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationTopElevationIncludeInsulationOfPart Property
ParameterTypeId Class See Also Send Feedback
"Top Elevation with Insulation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationTopElevationIncludeInsulationOfPart { get; }
Visual Basic
Public Shared ReadOnly Property FabricationTopElevationIncludeInsulationOfPart As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationTopElevationIncludeInsulationOfPart {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationTopElevationOfPart Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationTopElevationOfPart Property
ParameterTypeId Class See Also Send Feedback
"Top Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationTopElevationOfPart { get; }
Visual Basic
Public Shared ReadOnly Property FabricationTopElevationOfPart As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationTopElevationOfPart {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricationTopOfPart Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricationTopOfPart Property
ParameterTypeId Class See Also Send Feedback
"Upper End Top of Insulation Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricationTopOfPart { get; }
Visual Basic
Public Shared ReadOnly Property FabricationTopOfPart As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricationTopOfPart {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricBendDiameter Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricBendDiameter Property
ParameterTypeId Class See Also Send Feedback
"Bend Diameter": Standard Bend Diameter of Fabric Wire.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricBendDiameter { get; }
Visual Basic
Public Shared ReadOnly Property FabricBendDiameter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricBendDiameter {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricNumber Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricNumber Property
ParameterTypeId Class See Also Send Feedback
"Fabric Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricNumber { get; }
Visual Basic
Public Shared ReadOnly Property FabricNumber As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricNumber {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricParamCoverOffset Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricParamCoverOffset Property
ParameterTypeId Class See Also Send Feedback
"Additional Cover Offset": Additional cover offset of the fabric distribution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricParamCoverOffset { get; }
Visual Basic
Public Shared ReadOnly Property FabricParamCoverOffset As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricParamCoverOffset {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricParamCutByHost Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricParamCutByHost Property
ParameterTypeId Class See Also Send Feedback
"Cut by Host Cover": Single Fabric Sheet is cut or not cut by the Host Cover.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricParamCutByHost { get; }
Visual Basic
Public Shared ReadOnly Property FabricParamCutByHost As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricParamCutByHost {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricParamCutOverallLength Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricParamCutOverallLength Property
ParameterTypeId Class See Also Send Feedback
"Cut Overall Length": Provides a real sheet Length after definition

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricParamCutOverallLength { get; }
Visual Basic
Public Shared ReadOnly Property FabricParamCutOverallLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricParamCutOverallLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricParamCutOverallWidth Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricParamCutOverallWidth Property
ParameterTypeId Class See Also Send Feedback
"Cut Overall Width": Provides a real sheet Width after definition

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricParamCutOverallWidth { get; }
Visual Basic
Public Shared ReadOnly Property FabricParamCutOverallWidth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricParamCutOverallWidth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricParamCutSheetMass Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricParamCutSheetMass Property
ParameterTypeId Class See Also Send Feedback
"Cut Sheet Mass": Calculated cut sheet mass [Sheet Mass per Unit Area * (Cut Overall Length * Cut Overall Width)]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricParamCutSheetMass { get; }
Visual Basic
Public Shared ReadOnly Property FabricParamCutSheetMass As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricParamCutSheetMass {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricParamLocationGeneric Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricParamLocationGeneric Property
ParameterTypeId Class See Also Send Feedback
"Location": Fabric location in the host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricParamLocationGeneric { get; }
Visual Basic
Public Shared ReadOnly Property FabricParamLocationGeneric As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricParamLocationGeneric {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricParamMajorLapspliceLength Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricParamMajorLapspliceLength Property
ParameterTypeId Class See Also Send Feedback
"Major Lap Splice Length": Fabric lap splice length in major direction in the fabric distribution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricParamMajorLapspliceLength { get; }
Visual Basic
Public Shared ReadOnly Property FabricParamMajorLapspliceLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricParamMajorLapspliceLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricParamMinorLapspliceLength Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricParamMinorLapspliceLength Property
ParameterTypeId Class See Also Send Feedback
"Minor Lap Splice Length": Fabric lap splice length in minor direction in the fabric distribution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricParamMinorLapspliceLength { get; }
Visual Basic
Public Shared ReadOnly Property FabricParamMinorLapspliceLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricParamMinorLapspliceLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricParamRounding Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricParamRounding Property
ParameterTypeId Class See Also Send Feedback
"Rounding Overrides"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricParamRounding { get; }
Visual Basic
Public Shared ReadOnly Property FabricParamRounding As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricParamRounding {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricParamSharedFamilyKey Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricParamSharedFamilyKey Property
ParameterTypeId Class See Also Send Feedback
"Shared family key"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricParamSharedFamilyKey { get; }
Visual Basic
Public Shared ReadOnly Property FabricParamSharedFamilyKey As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricParamSharedFamilyKey {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricParamSheetType Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricParamSheetType Property
ParameterTypeId Class See Also Send Feedback
"Fabric Sheet": List all Fabric Sheet types

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricParamSheetType { get; }
Visual Basic
Public Shared ReadOnly Property FabricParamSheetType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricParamSheetType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricParamSpanSymBottom Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricParamSpanSymBottom Property
ParameterTypeId Class See Also Send Feedback
"Bottom"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricParamSpanSymBottom { get; }
Visual Basic
Public Shared ReadOnly Property FabricParamSpanSymBottom As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricParamSpanSymBottom {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricParamSpanSymDBottom Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricParamSpanSymDBottom Property
ParameterTypeId Class See Also Send Feedback
"D_Bottom"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricParamSpanSymDBottom { get; }
Visual Basic
Public Shared ReadOnly Property FabricParamSpanSymDBottom As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricParamSpanSymDBottom {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricParamSpanSymDLeft Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricParamSpanSymDLeft Property
ParameterTypeId Class See Also Send Feedback
"D_Left"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricParamSpanSymDLeft { get; }
Visual Basic
Public Shared ReadOnly Property FabricParamSpanSymDLeft As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricParamSpanSymDLeft {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricParamSpanSymDRight Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricParamSpanSymDRight Property
ParameterTypeId Class See Also Send Feedback
"D_Right"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricParamSpanSymDRight { get; }
Visual Basic
Public Shared ReadOnly Property FabricParamSpanSymDRight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricParamSpanSymDRight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricParamSpanSymDTop Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricParamSpanSymDTop Property
ParameterTypeId Class See Also Send Feedback
"D_Top"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricParamSpanSymDTop { get; }
Visual Basic
Public Shared ReadOnly Property FabricParamSpanSymDTop As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricParamSpanSymDTop {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricParamSpanSymLeft Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricParamSpanSymLeft Property
ParameterTypeId Class See Also Send Feedback
"Left"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricParamSpanSymLeft { get; }
Visual Basic
Public Shared ReadOnly Property FabricParamSpanSymLeft As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricParamSpanSymLeft {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricParamSpanSymRight Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricParamSpanSymRight Property
ParameterTypeId Class See Also Send Feedback
"Right"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricParamSpanSymRight { get; }
Visual Basic
Public Shared ReadOnly Property FabricParamSpanSymRight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricParamSpanSymRight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricParamSpanSymTop Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricParamSpanSymTop Property
ParameterTypeId Class See Also Send Feedback
"Top"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricParamSpanSymTop { get; }
Visual Basic
Public Shared ReadOnly Property FabricParamSpanSymTop As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricParamSpanSymTop {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricParamSpanTagComponentReference Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricParamSpanTagComponentReference Property
ParameterTypeId Class See Also Send Feedback
"Tag Component Reference"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricParamSpanTagComponentReference { get; }
Visual Basic
Public Shared ReadOnly Property FabricParamSpanTagComponentReference As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricParamSpanTagComponentReference {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricParamTotalSheetMass Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricParamTotalSheetMass Property
ParameterTypeId Class See Also Send Feedback
"Total Sheet Mass": Calculated all sheet mass: Volume of Wire * Unit Weight.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricParamTotalSheetMass { get; }
Visual Basic
Public Shared ReadOnly Property FabricParamTotalSheetMass As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricParamTotalSheetMass {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricSheetDefaultMajorLapspliceLength Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricSheetDefaultMajorLapspliceLength Property
ParameterTypeId Class See Also Send Feedback
"Default Major Lap Splice Length": Default Major Lap Splice Length

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricSheetDefaultMajorLapspliceLength { get; }
Visual Basic
Public Shared ReadOnly Property FabricSheetDefaultMajorLapspliceLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricSheetDefaultMajorLapspliceLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricSheetDefaultMinorLapspliceLength Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricSheetDefaultMinorLapspliceLength Property
ParameterTypeId Class See Also Send Feedback
"Default Minor Lap Splice Length": Default Minor Lap Splice Length

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricSheetDefaultMinorLapspliceLength { get; }
Visual Basic
Public Shared ReadOnly Property FabricSheetDefaultMinorLapspliceLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricSheetDefaultMinorLapspliceLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricSheetLength Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricSheetLength Property
ParameterTypeId Class See Also Send Feedback
"Length": Length

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricSheetLength { get; }
Visual Basic
Public Shared ReadOnly Property FabricSheetLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricSheetLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricSheetMajorEndOverhang Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricSheetMajorEndOverhang Property
ParameterTypeId Class See Also Send Feedback
"Major End Overhang": Major End Overhang

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricSheetMajorEndOverhang { get; }
Visual Basic
Public Shared ReadOnly Property FabricSheetMajorEndOverhang As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricSheetMajorEndOverhang {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricSheetMajorLayoutPattern Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricSheetMajorLayoutPattern Property
ParameterTypeId Class See Also Send Feedback
"Major Layout Pattern": Major Layout Pattern

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricSheetMajorLayoutPattern { get; }
Visual Basic
Public Shared ReadOnly Property FabricSheetMajorLayoutPattern As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricSheetMajorLayoutPattern {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricSheetMajorStartOverhang Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricSheetMajorStartOverhang Property
ParameterTypeId Class See Also Send Feedback
"Major Start Overhang": Major Start Overhang

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricSheetMajorStartOverhang { get; }
Visual Basic
Public Shared ReadOnly Property FabricSheetMajorStartOverhang As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricSheetMajorStartOverhang {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricSheetMassunit Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricSheetMassunit Property
ParameterTypeId Class See Also Send Feedback
"Sheet Mass per Unit Area": Structural Sheet Mass per Unit Area [Sheet Mass / (Overall Length * Overall Width)]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricSheetMassunit { get; }
Visual Basic
Public Shared ReadOnly Property FabricSheetMassunit As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricSheetMassunit {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricSheetMinorDirectionWireType Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricSheetMinorDirectionWireType Property
ParameterTypeId Class See Also Send Feedback
"Minor Direction Wire Type": Minor Direction Wire Type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricSheetMinorDirectionWireType { get; }
Visual Basic
Public Shared ReadOnly Property FabricSheetMinorDirectionWireType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricSheetMinorDirectionWireType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricSheetMinorEndOverhang Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricSheetMinorEndOverhang Property
ParameterTypeId Class See Also Send Feedback
"Minor End Overhang": Minor End Overhang

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricSheetMinorEndOverhang { get; }
Visual Basic
Public Shared ReadOnly Property FabricSheetMinorEndOverhang As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricSheetMinorEndOverhang {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricSheetMinorLayoutPattern Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricSheetMinorLayoutPattern Property
ParameterTypeId Class See Also Send Feedback
"Minor Layout Pattern": Minor Layout Pattern

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricSheetMinorLayoutPattern { get; }
Visual Basic
Public Shared ReadOnly Property FabricSheetMinorLayoutPattern As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricSheetMinorLayoutPattern {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricSheetMinorNumberOfWires Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricSheetMinorNumberOfWires Property
ParameterTypeId Class See Also Send Feedback
"Minor Number of Wires": Minor Number of Wires

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricSheetMinorNumberOfWires { get; }
Visual Basic
Public Shared ReadOnly Property FabricSheetMinorNumberOfWires As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricSheetMinorNumberOfWires {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricSheetMinorReinforcementArea Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricSheetMinorReinforcementArea Property
ParameterTypeId Class See Also Send Feedback
"Minor Reinforcement Area": Minor Reinforcement Area

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricSheetMinorReinforcementArea { get; }
Visual Basic
Public Shared ReadOnly Property FabricSheetMinorReinforcementArea As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricSheetMinorReinforcementArea {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricSheetMinorSpacing Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricSheetMinorSpacing Property
ParameterTypeId Class See Also Send Feedback
"Minor Spacing": Minor Spacing

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricSheetMinorSpacing { get; }
Visual Basic
Public Shared ReadOnly Property FabricSheetMinorSpacing As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricSheetMinorSpacing {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricSheetMinorStartOverhang Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricSheetMinorStartOverhang Property
ParameterTypeId Class See Also Send Feedback
"Minor Start Overhang": Minor Start Overhang

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricSheetMinorStartOverhang { get; }
Visual Basic
Public Shared ReadOnly Property FabricSheetMinorStartOverhang As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricSheetMinorStartOverhang {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricSheetOverallLength Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricSheetOverallLength Property
ParameterTypeId Class See Also Send Feedback
"Overall Length": Overall Length

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricSheetOverallLength { get; }
Visual Basic
Public Shared ReadOnly Property FabricSheetOverallLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricSheetOverallLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricSheetPhysicalMaterialAsset Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricSheetPhysicalMaterialAsset Property
ParameterTypeId Class See Also Send Feedback
"Physical Material Asset": Physical Material Asset

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricSheetPhysicalMaterialAsset { get; }
Visual Basic
Public Shared ReadOnly Property FabricSheetPhysicalMaterialAsset As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricSheetPhysicalMaterialAsset {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricWireLength Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricWireLength Property
ParameterTypeId Class See Also Send Feedback
"Wire length": The wire length

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricWireLength { get; }
Visual Basic
Public Shared ReadOnly Property FabricWireLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricWireLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricWireOffset Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricWireOffset Property
ParameterTypeId Class See Also Send Feedback
"Offset along wire direction": Offset along wire direction

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricWireOffset { get; }
Visual Basic
Public Shared ReadOnly Property FabricWireOffset As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricWireOffset {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FabricWireType Property

[image]

Revit 2024 API
ParameterTypeId..::..FabricWireType Property
ParameterTypeId Class See Also Send Feedback
"Wire type": The wire type assigned

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FabricWireType { get; }
Visual Basic
Public Shared ReadOnly Property FabricWireType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FabricWireType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FaceroofLevelParam Property

[image]

Revit 2024 API
ParameterTypeId..::..FaceroofLevelParam Property
ParameterTypeId Class See Also Send Feedback
"Reference Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FaceroofLevelParam { get; }
Visual Basic
Public Shared ReadOnly Property FaceroofLevelParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FaceroofLevelParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FaceroofOffsetParam Property

[image]

Revit 2024 API
ParameterTypeId..::..FaceroofOffsetParam Property
ParameterTypeId Class See Also Send Feedback
"Level Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FaceroofOffsetParam { get; }
Visual Basic
Public Shared ReadOnly Property FaceroofOffsetParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FaceroofOffsetParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FamilyAllowCutWithVoids Property

[image]

Revit 2024 API
ParameterTypeId..::..FamilyAllowCutWithVoids Property
ParameterTypeId Class See Also Send Feedback
"Cut with Voids When Loaded"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FamilyAllowCutWithVoids { get; }
Visual Basic
Public Shared ReadOnly Property FamilyAllowCutWithVoids As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FamilyAllowCutWithVoids {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FamilyAlwaysVertical Property

[image]

Revit 2024 API
ParameterTypeId..::..FamilyAlwaysVertical Property
ParameterTypeId Class See Also Send Feedback
"Always vertical"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FamilyAlwaysVertical { get; }
Visual Basic
Public Shared ReadOnly Property FamilyAlwaysVertical As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FamilyAlwaysVertical {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FamilyBaseLevelParam Property

[image]

Revit 2024 API
ParameterTypeId..::..FamilyBaseLevelParam Property
ParameterTypeId Class See Also Send Feedback
"Base Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FamilyBaseLevelParam { get; }
Visual Basic
Public Shared ReadOnly Property FamilyBaseLevelParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FamilyBaseLevelParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FamilyCanHostRebar Property

[image]

Revit 2024 API
ParameterTypeId..::..FamilyCanHostRebar Property
ParameterTypeId Class See Also Send Feedback
"Can host rebar"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FamilyCanHostRebar { get; }
Visual Basic
Public Shared ReadOnly Property FamilyCanHostRebar As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FamilyCanHostRebar {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FamilyCategoryPseudoParam Property

[image]

Revit 2024 API
ParameterTypeId..::..FamilyCategoryPseudoParam Property
ParameterTypeId Class See Also Send Feedback
"Category"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FamilyCategoryPseudoParam { get; }
Visual Basic
Public Shared ReadOnly Property FamilyCategoryPseudoParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FamilyCategoryPseudoParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FamilyContentPartType Property

[image]

Revit 2024 API
ParameterTypeId..::..FamilyContentPartType Property
ParameterTypeId Class See Also Send Feedback
"Part Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FamilyContentPartType { get; }
Visual Basic
Public Shared ReadOnly Property FamilyContentPartType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FamilyContentPartType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FamilyCurveGstyleFor2010Mass Property

[image]

Revit 2024 API
ParameterTypeId..::..FamilyCurveGstyleFor2010Mass Property
ParameterTypeId Class See Also Send Feedback
"Subcategory"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FamilyCurveGstyleFor2010Mass { get; }
Visual Basic
Public Shared ReadOnly Property FamilyCurveGstyleFor2010Mass As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FamilyCurveGstyleFor2010Mass {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FamilyCurveGstylePlusInvisible Property

[image]

Revit 2024 API
ParameterTypeId..::..FamilyCurveGstylePlusInvisible Property
ParameterTypeId Class See Also Send Feedback
"Subcategory"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FamilyCurveGstylePlusInvisible { get; }
Visual Basic
Public Shared ReadOnly Property FamilyCurveGstylePlusInvisible As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FamilyCurveGstylePlusInvisible {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FamilyCurveGstylePlusInvisibleMinusAnalytical Property

[image]

Revit 2024 API
ParameterTypeId..::..FamilyCurveGstylePlusInvisibleMinusAnalytical Property
ParameterTypeId Class See Also Send Feedback
"Subcategory"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FamilyCurveGstylePlusInvisibleMinusAnalytical { get; }
Visual Basic
Public Shared ReadOnly Property FamilyCurveGstylePlusInvisibleMinusAnalytical As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FamilyCurveGstylePlusInvisibleMinusAnalytical {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FamilyCurveGstylePlusInvisiblePlusStickSym Property

[image]

Revit 2024 API
ParameterTypeId..::..FamilyCurveGstylePlusInvisiblePlusStickSym Property
ParameterTypeId Class See Also Send Feedback
"Subcategory"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FamilyCurveGstylePlusInvisiblePlusStickSym { get; }
Visual Basic
Public Shared ReadOnly Property FamilyCurveGstylePlusInvisiblePlusStickSym As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FamilyCurveGstylePlusInvisiblePlusStickSym {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FamilyCurveGstylePlusInvisiblePlusStickSymMinusAnalytical Property

[image]

Revit 2024 API
ParameterTypeId..::..FamilyCurveGstylePlusInvisiblePlusStickSymMinusAnalytical Property
ParameterTypeId Class See Also Send Feedback
"Subcategory"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FamilyCurveGstylePlusInvisiblePlusStickSymMinusAnalytical { get; }
Visual Basic
Public Shared ReadOnly Property FamilyCurveGstylePlusInvisiblePlusStickSymMinusAnalytical As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FamilyCurveGstylePlusInvisiblePlusStickSymMinusAnalytical {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FamilyElectricalMaintainAnnotationOrientation Property

[image]

Revit 2024 API
ParameterTypeId..::..FamilyElectricalMaintainAnnotationOrientation Property
ParameterTypeId Class See Also Send Feedback
"Maintain Annotation Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FamilyElectricalMaintainAnnotationOrientation { get; }
Visual Basic
Public Shared ReadOnly Property FamilyElectricalMaintainAnnotationOrientation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FamilyElectricalMaintainAnnotationOrientation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FamilyElemSubcategory Property

[image]

Revit 2024 API
ParameterTypeId..::..FamilyElemSubcategory Property
ParameterTypeId Class See Also Send Feedback
"Subcategory"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FamilyElemSubcategory { get; }
Visual Basic
Public Shared ReadOnly Property FamilyElemSubcategory As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FamilyElemSubcategory {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FamilyExportAsGeometry Property

[image]

Revit 2024 API
ParameterTypeId..::..FamilyExportAsGeometry Property
ParameterTypeId Class See Also Send Feedback
"Always export as geometry"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FamilyExportAsGeometry { get; }
Visual Basic
Public Shared ReadOnly Property FamilyExportAsGeometry As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FamilyExportAsGeometry {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FamilyFreeinstDefaultElevation Property

[image]

Revit 2024 API
ParameterTypeId..::..FamilyFreeinstDefaultElevation Property
ParameterTypeId Class See Also Send Feedback
"Default Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FamilyFreeinstDefaultElevation { get; }
Visual Basic
Public Shared ReadOnly Property FamilyFreeinstDefaultElevation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FamilyFreeinstDefaultElevation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FamilyHeightParam Property

[image]

Revit 2024 API
ParameterTypeId..::..FamilyHeightParam Property
ParameterTypeId Class See Also Send Feedback
"Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FamilyHeightParam { get; }
Visual Basic
Public Shared ReadOnly Property FamilyHeightParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FamilyHeightParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FamilyHostingBehavior Property

[image]

Revit 2024 API
ParameterTypeId..::..FamilyHostingBehavior Property
ParameterTypeId Class See Also Send Feedback
"Host"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FamilyHostingBehavior { get; }
Visual Basic
Public Shared ReadOnly Property FamilyHostingBehavior As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FamilyHostingBehavior {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FamilyIsElevationMarkBody Property

[image]

Revit 2024 API
ParameterTypeId..::..FamilyIsElevationMarkBody Property
ParameterTypeId Class See Also Send Feedback
"Elevation Mark Use"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FamilyIsElevationMarkBody { get; }
Visual Basic
Public Shared ReadOnly Property FamilyIsElevationMarkBody As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FamilyIsElevationMarkBody {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FamilyIsParametric Property

[image]

Revit 2024 API
ParameterTypeId..::..FamilyIsParametric Property
ParameterTypeId Class See Also Send Feedback
"Is parametric"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FamilyIsParametric { get; }
Visual Basic
Public Shared ReadOnly Property FamilyIsParametric As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FamilyIsParametric {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FamilyKeepTextReadable Property

[image]

Revit 2024 API
ParameterTypeId..::..FamilyKeepTextReadable Property
ParameterTypeId Class See Also Send Feedback
"Keep text readable"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FamilyKeepTextReadable { get; }
Visual Basic
Public Shared ReadOnly Property FamilyKeepTextReadable As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FamilyKeepTextReadable {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FamilyKeyExtParam Property

[image]

Revit 2024 API
ParameterTypeId..::..FamilyKeyExtParam Property
ParameterTypeId Class See Also Send Feedback
"Filter Parameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FamilyKeyExtParam { get; }
Visual Basic
Public Shared ReadOnly Property FamilyKeyExtParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FamilyKeyExtParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FamilyKeywordProtected Property

[image]

Revit 2024 API
ParameterTypeId..::..FamilyKeywordProtected Property
ParameterTypeId Class See Also Send Feedback
"Content protection enabled"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FamilyKeywordProtected { get; }
Visual Basic
Public Shared ReadOnly Property FamilyKeywordProtected As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FamilyKeywordProtected {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FamilyLevelParam Property

[image]

Revit 2024 API
ParameterTypeId..::..FamilyLevelParam Property
ParameterTypeId Class See Also Send Feedback
"Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FamilyLevelParam { get; }
Visual Basic
Public Shared ReadOnly Property FamilyLevelParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FamilyLevelParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FamilyLineLengthParam Property

[image]

Revit 2024 API
ParameterTypeId..::..FamilyLineLengthParam Property
ParameterTypeId Class See Also Send Feedback
"Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FamilyLineLengthParam { get; }
Visual Basic
Public Shared ReadOnly Property FamilyLineLengthParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FamilyLineLengthParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FamilyNamePseudoParam Property

[image]

Revit 2024 API
ParameterTypeId..::..FamilyNamePseudoParam Property
ParameterTypeId Class See Also Send Feedback
"Family"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FamilyNamePseudoParam { get; }
Visual Basic
Public Shared ReadOnly Property FamilyNamePseudoParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FamilyNamePseudoParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FamilyRenderingType Property

[image]

Revit 2024 API
ParameterTypeId..::..FamilyRenderingType Property
ParameterTypeId Class See Also Send Feedback
"Render Appearance Source"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FamilyRenderingType { get; }
Visual Basic
Public Shared ReadOnly Property FamilyRenderingType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FamilyRenderingType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FamilyRotateTextWithComponent Property

[image]

Revit 2024 API
ParameterTypeId..::..FamilyRotateTextWithComponent Property
ParameterTypeId Class See Also Send Feedback
"Rotate text with component"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FamilyRotateTextWithComponent { get; }
Visual Basic
Public Shared ReadOnly Property FamilyRotateTextWithComponent As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FamilyRotateTextWithComponent {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FamilyRoughHeightParam Property

[image]

Revit 2024 API
ParameterTypeId..::..FamilyRoughHeightParam Property
ParameterTypeId Class See Also Send Feedback
"Rough Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FamilyRoughHeightParam { get; }
Visual Basic
Public Shared ReadOnly Property FamilyRoughHeightParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FamilyRoughHeightParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FamilyRoughWidthParam Property

[image]

Revit 2024 API
ParameterTypeId..::..FamilyRoughWidthParam Property
ParameterTypeId Class See Also Send Feedback
"Rough Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FamilyRoughWidthParam { get; }
Visual Basic
Public Shared ReadOnly Property FamilyRoughWidthParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FamilyRoughWidthParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FamilyRoundconnectorDimensiontype Property

[image]

Revit 2024 API
ParameterTypeId..::..FamilyRoundconnectorDimensiontype Property
ParameterTypeId Class See Also Send Feedback
"Round Connector Dimension"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FamilyRoundconnectorDimensiontype { get; }
Visual Basic
Public Shared ReadOnly Property FamilyRoundconnectorDimensiontype As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FamilyRoundconnectorDimensiontype {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FamilySelfOrienting Property

[image]

Revit 2024 API
ParameterTypeId..::..FamilySelfOrienting Property
ParameterTypeId Class See Also Send Feedback
"Align to View"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FamilySelfOrienting { get; }
Visual Basic
Public Shared ReadOnly Property FamilySelfOrienting As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FamilySelfOrienting {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FamilyStructFootingUseCapTop Property

[image]

Revit 2024 API
ParameterTypeId..::..FamilyStructFootingUseCapTop Property
ParameterTypeId Class See Also Send Feedback
"Cap"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FamilyStructFootingUseCapTop { get; }
Visual Basic
Public Shared ReadOnly Property FamilyStructFootingUseCapTop As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FamilyStructFootingUseCapTop {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FamilyStructMaterialType Property

[image]

Revit 2024 API
ParameterTypeId..::..FamilyStructMaterialType Property
ParameterTypeId Class See Also Send Feedback
"Material for Model Behavior"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FamilyStructMaterialType { get; }
Visual Basic
Public Shared ReadOnly Property FamilyStructMaterialType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FamilyStructMaterialType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FamilySymbolicRep Property

[image]

Revit 2024 API
ParameterTypeId..::..FamilySymbolicRep Property
ParameterTypeId Class See Also Send Feedback
"Symbolic Representation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FamilySymbolicRep { get; }
Visual Basic
Public Shared ReadOnly Property FamilySymbolicRep As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FamilySymbolicRep {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FamilyThicknessParam Property

[image]

Revit 2024 API
ParameterTypeId..::..FamilyThicknessParam Property
ParameterTypeId Class See Also Send Feedback
"Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FamilyThicknessParam { get; }
Visual Basic
Public Shared ReadOnly Property FamilyThicknessParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FamilyThicknessParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FamilyTopLevelOffsetParam Property

[image]

Revit 2024 API
ParameterTypeId..::..FamilyTopLevelOffsetParam Property
ParameterTypeId Class See Also Send Feedback
"Top Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FamilyTopLevelOffsetParam { get; }
Visual Basic
Public Shared ReadOnly Property FamilyTopLevelOffsetParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FamilyTopLevelOffsetParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FamilyTopLevelParam Property

[image]

Revit 2024 API
ParameterTypeId..::..FamilyTopLevelParam Property
ParameterTypeId Class See Also Send Feedback
"Top Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FamilyTopLevelParam { get; }
Visual Basic
Public Shared ReadOnly Property FamilyTopLevelParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FamilyTopLevelParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FamilyUsagePseudoParam Property

[image]

Revit 2024 API
ParameterTypeId..::..FamilyUsagePseudoParam Property
ParameterTypeId Class See Also Send Feedback
"Usage"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FamilyUsagePseudoParam { get; }
Visual Basic
Public Shared ReadOnly Property FamilyUsagePseudoParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FamilyUsagePseudoParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FamilyUsePrecutShape Property

[image]

Revit 2024 API
ParameterTypeId..::..FamilyUsePrecutShape Property
ParameterTypeId Class See Also Send Feedback
"Show family pre-cut in plan views"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FamilyUsePrecutShape { get; }
Visual Basic
Public Shared ReadOnly Property FamilyUsePrecutShape As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FamilyUsePrecutShape {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FamilyWidthParam Property

[image]

Revit 2024 API
ParameterTypeId..::..FamilyWidthParam Property
ParameterTypeId Class See Also Send Feedback
"Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FamilyWidthParam { get; }
Visual Basic
Public Shared ReadOnly Property FamilyWidthParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FamilyWidthParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FamilyWindowInsetParam Property

[image]

Revit 2024 API
ParameterTypeId..::..FamilyWindowInsetParam Property
ParameterTypeId Class See Also Send Feedback
"Inset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FamilyWindowInsetParam { get; }
Visual Basic
Public Shared ReadOnly Property FamilyWindowInsetParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FamilyWindowInsetParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FamilyWpbDefaultElevation Property

[image]

Revit 2024 API
ParameterTypeId..::..FamilyWpbDefaultElevation Property
ParameterTypeId Class See Also Send Feedback
"Default Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FamilyWpbDefaultElevation { get; }
Visual Basic
Public Shared ReadOnly Property FamilyWpbDefaultElevation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FamilyWpbDefaultElevation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FamProfileDefinition Property

[image]

Revit 2024 API
ParameterTypeId..::..FamProfileDefinition Property
ParameterTypeId Class See Also Send Feedback
"Profile Definition"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FamProfileDefinition { get; }
Visual Basic
Public Shared ReadOnly Property FamProfileDefinition As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FamProfileDefinition {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FamProfileUsage Property

[image]

Revit 2024 API
ParameterTypeId..::..FamProfileUsage Property
ParameterTypeId Class See Also Send Feedback
"Profile Usage"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FamProfileUsage { get; }
Visual Basic
Public Shared ReadOnly Property FamProfileUsage As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FamProfileUsage {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FasciaMaterialParam Property

[image]

Revit 2024 API
ParameterTypeId..::..FasciaMaterialParam Property
ParameterTypeId Class See Also Send Feedback
"Material"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FasciaMaterialParam { get; }
Visual Basic
Public Shared ReadOnly Property FasciaMaterialParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FasciaMaterialParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FbxAssetType Property

[image]

Revit 2024 API
ParameterTypeId..::..FbxAssetType Property
ParameterTypeId Class See Also Send Feedback
"Light Source"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FbxAssetType { get; }
Visual Basic
Public Shared ReadOnly Property FbxAssetType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FbxAssetType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FbxLightAtADistance Property

[image]

Revit 2024 API
ParameterTypeId..::..FbxLightAtADistance Property
ParameterTypeId Class See Also Send Feedback
"At a distance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FbxLightAtADistance { get; }
Visual Basic
Public Shared ReadOnly Property FbxLightAtADistance As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FbxLightAtADistance {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FbxLightBallastLoss Property

[image]

Revit 2024 API
ParameterTypeId..::..FbxLightBallastLoss Property
ParameterTypeId Class See Also Send Feedback
"Ballast Loss"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FbxLightBallastLoss { get; }
Visual Basic
Public Shared ReadOnly Property FbxLightBallastLoss As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FbxLightBallastLoss {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FbxLightDimmingLightColor Property

[image]

Revit 2024 API
ParameterTypeId..::..FbxLightDimmingLightColor Property
ParameterTypeId Class See Also Send Feedback
"Dimming Lamp Color Temperature Shift"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FbxLightDimmingLightColor { get; }
Visual Basic
Public Shared ReadOnly Property FbxLightDimmingLightColor As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FbxLightDimmingLightColor {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FbxLightEfficacy Property

[image]

Revit 2024 API
ParameterTypeId..::..FbxLightEfficacy Property
ParameterTypeId Class See Also Send Feedback
"Efficacy"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FbxLightEfficacy { get; }
Visual Basic
Public Shared ReadOnly Property FbxLightEfficacy As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FbxLightEfficacy {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FbxLightEmitLineLength Property

[image]

Revit 2024 API
ParameterTypeId..::..FbxLightEmitLineLength Property
ParameterTypeId Class See Also Send Feedback
"Emit from Line Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FbxLightEmitLineLength { get; }
Visual Basic
Public Shared ReadOnly Property FbxLightEmitLineLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FbxLightEmitLineLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FbxLightEmitRectangleLength Property

[image]

Revit 2024 API
ParameterTypeId..::..FbxLightEmitRectangleLength Property
ParameterTypeId Class See Also Send Feedback
"Emit from Rectangle Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FbxLightEmitRectangleLength { get; }
Visual Basic
Public Shared ReadOnly Property FbxLightEmitRectangleLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FbxLightEmitRectangleLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FbxLightEmitShapeVisible Property

[image]

Revit 2024 API
ParameterTypeId..::..FbxLightEmitShapeVisible Property
ParameterTypeId Class See Also Send Feedback
"Emit Shape Visible in Rendering"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FbxLightEmitShapeVisible { get; }
Visual Basic
Public Shared ReadOnly Property FbxLightEmitShapeVisible As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FbxLightEmitShapeVisible {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FbxLightIlluminance Property

[image]

Revit 2024 API
ParameterTypeId..::..FbxLightIlluminance Property
ParameterTypeId Class See Also Send Feedback
"Illuminance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FbxLightIlluminance { get; }
Visual Basic
Public Shared ReadOnly Property FbxLightIlluminance As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FbxLightIlluminance {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FbxLightInitialColorCtrl Property

[image]

Revit 2024 API
ParameterTypeId..::..FbxLightInitialColorCtrl Property
ParameterTypeId Class See Also Send Feedback
"Initial Color"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FbxLightInitialColorCtrl { get; }
Visual Basic
Public Shared ReadOnly Property FbxLightInitialColorCtrl As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FbxLightInitialColorCtrl {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FbxLightInitialColorName Property

[image]

Revit 2024 API
ParameterTypeId..::..FbxLightInitialColorName Property
ParameterTypeId Class See Also Send Feedback
"Temperature Color"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FbxLightInitialColorName { get; }
Visual Basic
Public Shared ReadOnly Property FbxLightInitialColorName As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FbxLightInitialColorName {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FbxLightInitialColorTemperature Property

[image]

Revit 2024 API
ParameterTypeId..::..FbxLightInitialColorTemperature Property
ParameterTypeId Class See Also Send Feedback
"Initial Color Temperature"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FbxLightInitialColorTemperature { get; }
Visual Basic
Public Shared ReadOnly Property FbxLightInitialColorTemperature As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FbxLightInitialColorTemperature {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FbxLightInitialIntensity Property

[image]

Revit 2024 API
ParameterTypeId..::..FbxLightInitialIntensity Property
ParameterTypeId Class See Also Send Feedback
"Initial Intensity"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FbxLightInitialIntensity { get; }
Visual Basic
Public Shared ReadOnly Property FbxLightInitialIntensity As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FbxLightInitialIntensity {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FbxLightInitialIntensityInputMethod Property

[image]

Revit 2024 API
ParameterTypeId..::..FbxLightInitialIntensityInputMethod Property
ParameterTypeId Class See Also Send Feedback
"Initial Light Intensity Input Method"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FbxLightInitialIntensityInputMethod { get; }
Visual Basic
Public Shared ReadOnly Property FbxLightInitialIntensityInputMethod As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FbxLightInitialIntensityInputMethod {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FbxLightLampLumenDepr Property

[image]

Revit 2024 API
ParameterTypeId..::..FbxLightLampLumenDepr Property
ParameterTypeId Class See Also Send Feedback
"Lamp Lumen Depreciation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FbxLightLampLumenDepr { get; }
Visual Basic
Public Shared ReadOnly Property FbxLightLampLumenDepr As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FbxLightLampLumenDepr {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FbxLightLampTiltLoss Property

[image]

Revit 2024 API
ParameterTypeId..::..FbxLightLampTiltLoss Property
ParameterTypeId Class See Also Send Feedback
"Lamp Tilt Loss"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FbxLightLampTiltLoss { get; }
Visual Basic
Public Shared ReadOnly Property FbxLightLampTiltLoss As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FbxLightLampTiltLoss {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FbxLightLimunousFlux Property

[image]

Revit 2024 API
ParameterTypeId..::..FbxLightLimunousFlux Property
ParameterTypeId Class See Also Send Feedback
"Luminous Flux"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FbxLightLimunousFlux { get; }
Visual Basic
Public Shared ReadOnly Property FbxLightLimunousFlux As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FbxLightLimunousFlux {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FbxLightLimunousIntensity Property

[image]

Revit 2024 API
ParameterTypeId..::..FbxLightLimunousIntensity Property
ParameterTypeId Class See Also Send Feedback
"Luminous Intensity"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FbxLightLimunousIntensity { get; }
Visual Basic
Public Shared ReadOnly Property FbxLightLimunousIntensity As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FbxLightLimunousIntensity {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FbxLightLossFactorCtrl Property

[image]

Revit 2024 API
ParameterTypeId..::..FbxLightLossFactorCtrl Property
ParameterTypeId Class See Also Send Feedback
"Light Loss Factor"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FbxLightLossFactorCtrl { get; }
Visual Basic
Public Shared ReadOnly Property FbxLightLossFactorCtrl As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FbxLightLossFactorCtrl {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FbxLightPhotometricFile Property

[image]

Revit 2024 API
ParameterTypeId..::..FbxLightPhotometricFile Property
ParameterTypeId Class See Also Send Feedback
"Photometric Web File"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FbxLightPhotometricFile { get; }
Visual Basic
Public Shared ReadOnly Property FbxLightPhotometricFile As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FbxLightPhotometricFile {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FbxLightPhotometrics Property

[image]

Revit 2024 API
ParameterTypeId..::..FbxLightPhotometrics Property
ParameterTypeId Class See Also Send Feedback
"Light Source Definition"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FbxLightPhotometrics { get; }
Visual Basic
Public Shared ReadOnly Property FbxLightPhotometrics As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FbxLightPhotometrics {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FbxLightPhotometricsFam Property

[image]

Revit 2024 API
ParameterTypeId..::..FbxLightPhotometricsFam Property
ParameterTypeId Class See Also Send Feedback
"Light Source Definition (family)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FbxLightPhotometricsFam { get; }
Visual Basic
Public Shared ReadOnly Property FbxLightPhotometricsFam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FbxLightPhotometricsFam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FbxLightSourceDiameter Property

[image]

Revit 2024 API
ParameterTypeId..::..FbxLightSourceDiameter Property
ParameterTypeId Class See Also Send Feedback
"Light Source Symbol Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FbxLightSourceDiameter { get; }
Visual Basic
Public Shared ReadOnly Property FbxLightSourceDiameter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FbxLightSourceDiameter {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FbxLightSourceLength Property

[image]

Revit 2024 API
ParameterTypeId..::..FbxLightSourceLength Property
ParameterTypeId Class See Also Send Feedback
"Light Source Symbol Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FbxLightSourceLength { get; }
Visual Basic
Public Shared ReadOnly Property FbxLightSourceLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FbxLightSourceLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FbxLightSpotBeamAngle Property

[image]

Revit 2024 API
ParameterTypeId..::..FbxLightSpotBeamAngle Property
ParameterTypeId Class See Also Send Feedback
"Spot Beam Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FbxLightSpotBeamAngle { get; }
Visual Basic
Public Shared ReadOnly Property FbxLightSpotBeamAngle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FbxLightSpotBeamAngle {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FbxLightSpotFieldAngle Property

[image]

Revit 2024 API
ParameterTypeId..::..FbxLightSpotFieldAngle Property
ParameterTypeId Class See Also Send Feedback
"Spot Field Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FbxLightSpotFieldAngle { get; }
Visual Basic
Public Shared ReadOnly Property FbxLightSpotFieldAngle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FbxLightSpotFieldAngle {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FbxLightSpotTiltAngle Property

[image]

Revit 2024 API
ParameterTypeId..::..FbxLightSpotTiltAngle Property
ParameterTypeId Class See Also Send Feedback
"Tilt Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FbxLightSpotTiltAngle { get; }
Visual Basic
Public Shared ReadOnly Property FbxLightSpotTiltAngle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FbxLightSpotTiltAngle {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FbxLightSurfaceLoss Property

[image]

Revit 2024 API
ParameterTypeId..::..FbxLightSurfaceLoss Property
ParameterTypeId Class See Also Send Feedback
"Surface Depreciation Loss"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FbxLightSurfaceLoss { get; }
Visual Basic
Public Shared ReadOnly Property FbxLightSurfaceLoss As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FbxLightSurfaceLoss {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FbxLightTemperatureLoss Property

[image]

Revit 2024 API
ParameterTypeId..::..FbxLightTemperatureLoss Property
ParameterTypeId Class See Also Send Feedback
"Temperature Loss"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FbxLightTemperatureLoss { get; }
Visual Basic
Public Shared ReadOnly Property FbxLightTemperatureLoss As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FbxLightTemperatureLoss {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FbxLightTotalLightLoss Property

[image]

Revit 2024 API
ParameterTypeId..::..FbxLightTotalLightLoss Property
ParameterTypeId Class See Also Send Feedback
"Total Light Loss Factor"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FbxLightTotalLightLoss { get; }
Visual Basic
Public Shared ReadOnly Property FbxLightTotalLightLoss As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FbxLightTotalLightLoss {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FbxLightVoltageLoss Property

[image]

Revit 2024 API
ParameterTypeId..::..FbxLightVoltageLoss Property
ParameterTypeId Class See Also Send Feedback
"Voltage Loss"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FbxLightVoltageLoss { get; }
Visual Basic
Public Shared ReadOnly Property FbxLightVoltageLoss As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FbxLightVoltageLoss {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FilledRegionMasking Property

[image]

Revit 2024 API
ParameterTypeId..::..FilledRegionMasking Property
ParameterTypeId Class See Also Send Feedback
"Masking"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FilledRegionMasking { get; }
Visual Basic
Public Shared ReadOnly Property FilledRegionMasking As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FilledRegionMasking {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FireRating Property

[image]

Revit 2024 API
ParameterTypeId..::..FireRating Property
ParameterTypeId Class See Also Send Feedback
"Fire Rating"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FireRating { get; }
Visual Basic
Public Shared ReadOnly Property FireRating As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FireRating {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FixedRotation Property

[image]

Revit 2024 API
ParameterTypeId..::..FixedRotation Property
ParameterTypeId Class See Also Send Feedback
"Fixed Rotation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FixedRotation { get; }
Visual Basic
Public Shared ReadOnly Property FixedRotation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FixedRotation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FlexibleInstanceFlip Property

[image]

Revit 2024 API
ParameterTypeId..::..FlexibleInstanceFlip Property
ParameterTypeId Class See Also Send Feedback
"Flip"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FlexibleInstanceFlip { get; }
Visual Basic
Public Shared ReadOnly Property FlexibleInstanceFlip As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FlexibleInstanceFlip {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FloorAttrDefaultHeightParam Property

[image]

Revit 2024 API
ParameterTypeId..::..FloorAttrDefaultHeightParam Property
ParameterTypeId Class See Also Send Feedback
"Default Height above level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FloorAttrDefaultHeightParam { get; }
Visual Basic
Public Shared ReadOnly Property FloorAttrDefaultHeightParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FloorAttrDefaultHeightParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FloorAttrDefaultThicknessParam Property

[image]

Revit 2024 API
ParameterTypeId..::..FloorAttrDefaultThicknessParam Property
ParameterTypeId Class See Also Send Feedback
"Default Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FloorAttrDefaultThicknessParam { get; }
Visual Basic
Public Shared ReadOnly Property FloorAttrDefaultThicknessParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FloorAttrDefaultThicknessParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FloorAttrThicknessParam Property

[image]

Revit 2024 API
ParameterTypeId..::..FloorAttrThicknessParam Property
ParameterTypeId Class See Also Send Feedback
"Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FloorAttrThicknessParam { get; }
Visual Basic
Public Shared ReadOnly Property FloorAttrThicknessParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FloorAttrThicknessParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FloorHeightabovelevelParam Property

[image]

Revit 2024 API
ParameterTypeId..::..FloorHeightabovelevelParam Property
ParameterTypeId Class See Also Send Feedback
"Height Offset From Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FloorHeightabovelevelParam { get; }
Visual Basic
Public Shared ReadOnly Property FloorHeightabovelevelParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FloorHeightabovelevelParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FloorParamIsStructural Property

[image]

Revit 2024 API
ParameterTypeId..::..FloorParamIsStructural Property
ParameterTypeId Class See Also Send Feedback
"Structural"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FloorParamIsStructural { get; }
Visual Basic
Public Shared ReadOnly Property FloorParamIsStructural As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FloorParamIsStructural {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FloorParamSpanDirection Property

[image]

Revit 2024 API
ParameterTypeId..::..FloorParamSpanDirection Property
ParameterTypeId Class See Also Send Feedback
"Span Direction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FloorParamSpanDirection { get; }
Visual Basic
Public Shared ReadOnly Property FloorParamSpanDirection As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FloorParamSpanDirection {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FollowSurface Property

[image]

Revit 2024 API
ParameterTypeId..::..FollowSurface Property
ParameterTypeId Class See Also Send Feedback
"Follow Surface"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FollowSurface { get; }
Visual Basic
Public Shared ReadOnly Property FollowSurface As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FollowSurface {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ForegroundAnyPatternIdParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ForegroundAnyPatternIdParam Property
ParameterTypeId Class See Also Send Feedback
"Foreground Fill Pattern"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ForegroundAnyPatternIdParam { get; }
Visual Basic
Public Shared ReadOnly Property ForegroundAnyPatternIdParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ForegroundAnyPatternIdParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ForegroundDraftPatternIdParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ForegroundDraftPatternIdParam Property
ParameterTypeId Class See Also Send Feedback
"Foreground Fill Pattern"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ForegroundDraftPatternIdParam { get; }
Visual Basic
Public Shared ReadOnly Property ForegroundDraftPatternIdParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ForegroundDraftPatternIdParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ForegroundPatternColorParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ForegroundPatternColorParam Property
ParameterTypeId Class See Also Send Feedback
"Foreground Pattern Color"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ForegroundPatternColorParam { get; }
Visual Basic
Public Shared ReadOnly Property ForegroundPatternColorParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ForegroundPatternColorParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FramingLengthRoundoff Property

[image]

Revit 2024 API
ParameterTypeId..::..FramingLengthRoundoff Property
ParameterTypeId Class See Also Send Feedback
"Structural Framing Length Roundoff"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FramingLengthRoundoff { get; }
Visual Basic
Public Shared ReadOnly Property FramingLengthRoundoff As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FramingLengthRoundoff {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FramingShapeClassification Property

[image]

Revit 2024 API
ParameterTypeId..::..FramingShapeClassification Property
ParameterTypeId Class See Also Send Feedback
"Framing Shape"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FramingShapeClassification { get; }
Visual Basic
Public Shared ReadOnly Property FramingShapeClassification As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FramingShapeClassification {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FrictionFactor Property

[image]

Revit 2024 API
ParameterTypeId..::..FrictionFactor Property
ParameterTypeId Class See Also Send Feedback
"Friction Factor"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FrictionFactor { get; }
Visual Basic
Public Shared ReadOnly Property FrictionFactor As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FrictionFactor {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


FunctionParam Property

[image]

Revit 2024 API
ParameterTypeId..::..FunctionParam Property
ParameterTypeId Class See Also Send Feedback
"Function"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FunctionParam { get; }
Visual Basic
Public Shared ReadOnly Property FunctionParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FunctionParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


GbxmlEditDataParam Property

[image]

Revit 2024 API
ParameterTypeId..::..GbxmlEditDataParam Property
ParameterTypeId Class See Also Send Feedback
"Energy Settings"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId GbxmlEditDataParam { get; }
Visual Basic
Public Shared ReadOnly Property GbxmlEditDataParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ GbxmlEditDataParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


GeomVisibilityParam Property

[image]

Revit 2024 API
ParameterTypeId..::..GeomVisibilityParam Property
ParameterTypeId Class See Also Send Feedback
"Visibility/Graphics Overrides"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId GeomVisibilityParam { get; }
Visual Basic
Public Shared ReadOnly Property GeomVisibilityParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ GeomVisibilityParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


GraphicDisplayOptions Property

[image]

Revit 2024 API
ParameterTypeId..::..GraphicDisplayOptions Property
ParameterTypeId Class See Also Send Feedback
"Graphic Display Options"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId GraphicDisplayOptions { get; }
Visual Basic
Public Shared ReadOnly Property GraphicDisplayOptions As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ GraphicDisplayOptions {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


GraphicDisplayOptionsFog Property

[image]

Revit 2024 API
ParameterTypeId..::..GraphicDisplayOptionsFog Property
ParameterTypeId Class See Also Send Feedback
"Depth Cueing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId GraphicDisplayOptionsFog { get; }
Visual Basic
Public Shared ReadOnly Property GraphicDisplayOptionsFog As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ GraphicDisplayOptionsFog {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


GraphicDisplayOptionsLighting Property

[image]

Revit 2024 API
ParameterTypeId..::..GraphicDisplayOptionsLighting Property
ParameterTypeId Class See Also Send Feedback
"Lighting"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId GraphicDisplayOptionsLighting { get; }
Visual Basic
Public Shared ReadOnly Property GraphicDisplayOptionsLighting As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ GraphicDisplayOptionsLighting {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


GraphicDisplayOptionsModel Property

[image]

Revit 2024 API
ParameterTypeId..::..GraphicDisplayOptionsModel Property
ParameterTypeId Class See Also Send Feedback
"Model Display"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId GraphicDisplayOptionsModel { get; }
Visual Basic
Public Shared ReadOnly Property GraphicDisplayOptionsModel As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ GraphicDisplayOptionsModel {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


GraphicDisplayOptionsShadows Property

[image]

Revit 2024 API
ParameterTypeId..::..GraphicDisplayOptionsShadows Property
ParameterTypeId Class See Also Send Feedback
"Shadows"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId GraphicDisplayOptionsShadows { get; }
Visual Basic
Public Shared ReadOnly Property GraphicDisplayOptionsShadows As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ GraphicDisplayOptionsShadows {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


GraphicDisplayOptionsSketchyLines Property

[image]

Revit 2024 API
ParameterTypeId..::..GraphicDisplayOptionsSketchyLines Property
ParameterTypeId Class See Also Send Feedback
"Sketchy Lines"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId GraphicDisplayOptionsSketchyLines { get; }
Visual Basic
Public Shared ReadOnly Property GraphicDisplayOptionsSketchyLines As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ GraphicDisplayOptionsSketchyLines {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


GraphicDisplayOptionsSsIntensity Property

[image]

Revit 2024 API
ParameterTypeId..::..GraphicDisplayOptionsSsIntensity Property
ParameterTypeId Class See Also Send Feedback
"Sun and Shadow Intensity"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId GraphicDisplayOptionsSsIntensity { get; }
Visual Basic
Public Shared ReadOnly Property GraphicDisplayOptionsSsIntensity As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ GraphicDisplayOptionsSsIntensity {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


GridBankColNum Property

[image]

Revit 2024 API
ParameterTypeId..::..GridBankColNum Property
ParameterTypeId Class See Also Send Feedback
"Column"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId GridBankColNum { get; }
Visual Basic
Public Shared ReadOnly Property GridBankColNum As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ GridBankColNum {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


GridBankColWidth Property

[image]

Revit 2024 API
ParameterTypeId..::..GridBankColWidth Property
ParameterTypeId Class See Also Send Feedback
"Column Distance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId GridBankColWidth { get; }
Visual Basic
Public Shared ReadOnly Property GridBankColWidth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ GridBankColWidth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


GridBankRowHeight Property

[image]

Revit 2024 API
ParameterTypeId..::..GridBankRowHeight Property
ParameterTypeId Class See Also Send Feedback
"Row Distance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId GridBankRowHeight { get; }
Visual Basic
Public Shared ReadOnly Property GridBankRowHeight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ GridBankRowHeight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


GridBankRowNum Property

[image]

Revit 2024 API
ParameterTypeId..::..GridBankRowNum Property
ParameterTypeId Class See Also Send Feedback
"Row"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId GridBankRowNum { get; }
Visual Basic
Public Shared ReadOnly Property GridBankRowNum As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ GridBankRowNum {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


GridBubbleEndn1 Property

[image]

Revit 2024 API
ParameterTypeId..::..GridBubbleEndn1 Property
ParameterTypeId Class See Also Send Feedback
"Plan View Symbols End 1 (Default)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId GridBubbleEndn1 { get; }
Visual Basic
Public Shared ReadOnly Property GridBubbleEndn1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ GridBubbleEndn1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


GridBubbleEndn2 Property

[image]

Revit 2024 API
ParameterTypeId..::..GridBubbleEndn2 Property
ParameterTypeId Class See Also Send Feedback
"Plan View Symbols End 2 (Default)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId GridBubbleEndn2 { get; }
Visual Basic
Public Shared ReadOnly Property GridBubbleEndn2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ GridBubbleEndn2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


GridBubbleLinePen Property

[image]

Revit 2024 API
ParameterTypeId..::..GridBubbleLinePen Property
ParameterTypeId Class See Also Send Feedback
"Bubble Weight Number\n"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId GridBubbleLinePen { get; }
Visual Basic
Public Shared ReadOnly Property GridBubbleLinePen As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ GridBubbleLinePen {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


GridCenterSegmentColor Property

[image]

Revit 2024 API
ParameterTypeId..::..GridCenterSegmentColor Property
ParameterTypeId Class See Also Send Feedback
"Center Segment Color"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId GridCenterSegmentColor { get; }
Visual Basic
Public Shared ReadOnly Property GridCenterSegmentColor As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ GridCenterSegmentColor {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


GridCenterSegmentPattern Property

[image]

Revit 2024 API
ParameterTypeId..::..GridCenterSegmentPattern Property
ParameterTypeId Class See Also Send Feedback
"Center Segment Pattern"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId GridCenterSegmentPattern { get; }
Visual Basic
Public Shared ReadOnly Property GridCenterSegmentPattern As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ GridCenterSegmentPattern {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


GridCenterSegmentStyle Property

[image]

Revit 2024 API
ParameterTypeId..::..GridCenterSegmentStyle Property
ParameterTypeId Class See Also Send Feedback
"Center Segment"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId GridCenterSegmentStyle { get; }
Visual Basic
Public Shared ReadOnly Property GridCenterSegmentStyle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ GridCenterSegmentStyle {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


GridEndSegmentColor Property

[image]

Revit 2024 API
ParameterTypeId..::..GridEndSegmentColor Property
ParameterTypeId Class See Also Send Feedback
"End Segment Color"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId GridEndSegmentColor { get; }
Visual Basic
Public Shared ReadOnly Property GridEndSegmentColor As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ GridEndSegmentColor {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


GridEndSegmentPattern Property

[image]

Revit 2024 API
ParameterTypeId..::..GridEndSegmentPattern Property
ParameterTypeId Class See Also Send Feedback
"End Segment Pattern"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId GridEndSegmentPattern { get; }
Visual Basic
Public Shared ReadOnly Property GridEndSegmentPattern As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ GridEndSegmentPattern {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


GridEndSegmentWeight Property

[image]

Revit 2024 API
ParameterTypeId..::..GridEndSegmentWeight Property
ParameterTypeId Class See Also Send Feedback
"End Segment Weight"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId GridEndSegmentWeight { get; }
Visual Basic
Public Shared ReadOnly Property GridEndSegmentWeight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ GridEndSegmentWeight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


GridHeadTag Property

[image]

Revit 2024 API
ParameterTypeId..::..GridHeadTag Property
ParameterTypeId Class See Also Send Feedback
"Symbol"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId GridHeadTag { get; }
Visual Basic
Public Shared ReadOnly Property GridHeadTag As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ GridHeadTag {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


GridlineSpecStatus Property

[image]

Revit 2024 API
ParameterTypeId..::..GridlineSpecStatus Property
ParameterTypeId Class See Also Send Feedback
"Type Association"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId GridlineSpecStatus { get; }
Visual Basic
Public Shared ReadOnly Property GridlineSpecStatus As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ GridlineSpecStatus {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


GroupAllowedViewTypes Property

[image]

Revit 2024 API
ParameterTypeId..::..GroupAllowedViewTypes Property
ParameterTypeId Class See Also Send Feedback
"Allowed View Types"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId GroupAllowedViewTypes { get; }
Visual Basic
Public Shared ReadOnly Property GroupAllowedViewTypes As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ GroupAllowedViewTypes {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


GroupLevel Property

[image]

Revit 2024 API
ParameterTypeId..::..GroupLevel Property
ParameterTypeId Class See Also Send Feedback
"Reference Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId GroupLevel { get; }
Visual Basic
Public Shared ReadOnly Property GroupLevel As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ GroupLevel {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


GroupnameParam Property

[image]

Revit 2024 API
ParameterTypeId..::..GroupnameParam Property
ParameterTypeId Class See Also Send Feedback
"Group Name for Ribbon Combo Items (for Use with XAML)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId GroupnameParam { get; }
Visual Basic
Public Shared ReadOnly Property GroupnameParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ GroupnameParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


GroupOffsetFromLevel Property

[image]

Revit 2024 API
ParameterTypeId..::..GroupOffsetFromLevel Property
ParameterTypeId Class See Also Send Feedback
"Origin Level Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId GroupOffsetFromLevel { get; }
Visual Basic
Public Shared ReadOnly Property GroupOffsetFromLevel As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ GroupOffsetFromLevel {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


GuideGridNameParam Property

[image]

Revit 2024 API
ParameterTypeId..::..GuideGridNameParam Property
ParameterTypeId Class See Also Send Feedback
"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId GuideGridNameParam { get; }
Visual Basic
Public Shared ReadOnly Property GuideGridNameParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ GuideGridNameParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


GuideGridSpacingParam Property

[image]

Revit 2024 API
ParameterTypeId..::..GuideGridSpacingParam Property
ParameterTypeId Class See Also Send Feedback
"Guide Spacing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId GuideGridSpacingParam { get; }
Visual Basic
Public Shared ReadOnly Property GuideGridSpacingParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ GuideGridSpacingParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


GutterMaterialParam Property

[image]

Revit 2024 API
ParameterTypeId..::..GutterMaterialParam Property
ParameterTypeId Class See Also Send Feedback
"Material"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId GutterMaterialParam { get; }
Visual Basic
Public Shared ReadOnly Property GutterMaterialParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ GutterMaterialParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


GutterProfileParam Property

[image]

Revit 2024 API
ParameterTypeId..::..GutterProfileParam Property
ParameterTypeId Class See Also Send Feedback
"Profile"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId GutterProfileParam { get; }
Visual Basic
Public Shared ReadOnly Property GutterProfileParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ GutterProfileParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


HandrailHeightParam Property

[image]

Revit 2024 API
ParameterTypeId..::..HandrailHeightParam Property
ParameterTypeId Class See Also Send Feedback
"Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId HandrailHeightParam { get; }
Visual Basic
Public Shared ReadOnly Property HandrailHeightParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ HandrailHeightParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


HandrailProjectionParam Property

[image]

Revit 2024 API
ParameterTypeId..::..HandrailProjectionParam Property
ParameterTypeId Class See Also Send Feedback
"Projection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId HandrailProjectionParam { get; }
Visual Basic
Public Shared ReadOnly Property HandrailProjectionParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ HandrailProjectionParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


HandrailSupportsLayoutParam Property

[image]

Revit 2024 API
ParameterTypeId..::..HandrailSupportsLayoutParam Property
ParameterTypeId Class See Also Send Feedback
"Layout"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId HandrailSupportsLayoutParam { get; }
Visual Basic
Public Shared ReadOnly Property HandrailSupportsLayoutParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ HandrailSupportsLayoutParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


HandrailSupportsNumberParam Property

[image]

Revit 2024 API
ParameterTypeId..::..HandrailSupportsNumberParam Property
ParameterTypeId Class See Also Send Feedback
"Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId HandrailSupportsNumberParam { get; }
Visual Basic
Public Shared ReadOnly Property HandrailSupportsNumberParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ HandrailSupportsNumberParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


HandrailSupportsSpacingParam Property

[image]

Revit 2024 API
ParameterTypeId..::..HandrailSupportsSpacingParam Property
ParameterTypeId Class See Also Send Feedback
"Spacing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId HandrailSupportsSpacingParam { get; }
Visual Basic
Public Shared ReadOnly Property HandrailSupportsSpacingParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ HandrailSupportsSpacingParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


HandrailSupportsTypeParam Property

[image]

Revit 2024 API
ParameterTypeId..::..HandrailSupportsTypeParam Property
ParameterTypeId Class See Also Send Feedback
"Family"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId HandrailSupportsTypeParam { get; }
Visual Basic
Public Shared ReadOnly Property HandrailSupportsTypeParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ HandrailSupportsTypeParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


HeadOnPlacementMethod Property

[image]

Revit 2024 API
ParameterTypeId..::..HeadOnPlacementMethod Property
ParameterTypeId Class See Also Send Feedback
"Draw in Foreground"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId HeadOnPlacementMethod { get; }
Visual Basic
Public Shared ReadOnly Property HeadOnPlacementMethod As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ HeadOnPlacementMethod {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


HeavyTickMarkPen Property

[image]

Revit 2024 API
ParameterTypeId..::..HeavyTickMarkPen Property
ParameterTypeId Class See Also Send Feedback
"Heavy End Pen Weight"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId HeavyTickMarkPen { get; }
Visual Basic
Public Shared ReadOnly Property HeavyTickMarkPen As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ HeavyTickMarkPen {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


HighestAssociatedLevel Property

[image]

Revit 2024 API
ParameterTypeId..::..HighestAssociatedLevel Property
ParameterTypeId Class See Also Send Feedback
"Highest Associated Level": The highest level associated with this Analytical Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId HighestAssociatedLevel { get; }
Visual Basic
Public Shared ReadOnly Property HighestAssociatedLevel As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ HighestAssociatedLevel {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


HostAreaComputed Property

[image]

Revit 2024 API
ParameterTypeId..::..HostAreaComputed Property
ParameterTypeId Class See Also Send Feedback
"Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId HostAreaComputed { get; }
Visual Basic
Public Shared ReadOnly Property HostAreaComputed As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ HostAreaComputed {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


HostIdParam Property

[image]

Revit 2024 API
ParameterTypeId..::..HostIdParam Property
ParameterTypeId Class See Also Send Feedback
"Host Id"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId HostIdParam { get; }
Visual Basic
Public Shared ReadOnly Property HostIdParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ HostIdParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


HostPanelScheduleAsPanelParam Property

[image]

Revit 2024 API
ParameterTypeId..::..HostPanelScheduleAsPanelParam Property
ParameterTypeId Class See Also Send Feedback
"Categorize as"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId HostPanelScheduleAsPanelParam { get; }
Visual Basic
Public Shared ReadOnly Property HostPanelScheduleAsPanelParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ HostPanelScheduleAsPanelParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


HostSseCurvedEdgeConditionParam Property

[image]

Revit 2024 API
ParameterTypeId..::..HostSseCurvedEdgeConditionParam Property
ParameterTypeId Class See Also Send Feedback
"Curved Edge Condition"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId HostSseCurvedEdgeConditionParam { get; }
Visual Basic
Public Shared ReadOnly Property HostSseCurvedEdgeConditionParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ HostSseCurvedEdgeConditionParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


HostVolumeComputed Property

[image]

Revit 2024 API
ParameterTypeId..::..HostVolumeComputed Property
ParameterTypeId Class See Also Send Feedback
"Volume"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId HostVolumeComputed { get; }
Visual Basic
Public Shared ReadOnly Property HostVolumeComputed As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ HostVolumeComputed {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


IconIndexParam Property

[image]

Revit 2024 API
ParameterTypeId..::..IconIndexParam Property
ParameterTypeId Class See Also Send Feedback
"Index Into Image File Name Array (for Use with XAML)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId IconIndexParam { get; }
Visual Basic
Public Shared ReadOnly Property IconIndexParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ IconIndexParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


IdParam Property

[image]

Revit 2024 API
ParameterTypeId..::..IdParam Property
ParameterTypeId Class See Also Send Feedback
"Id"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId IdParam { get; }
Visual Basic
Public Shared ReadOnly Property IdParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ IdParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


IfcApplicationName Property

[image]

Revit 2024 API
ParameterTypeId..::..IfcApplicationName Property
ParameterTypeId Class See Also Send Feedback
"IfcApplicationName"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId IfcApplicationName { get; }
Visual Basic
Public Shared ReadOnly Property IfcApplicationName As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ IfcApplicationName {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


IfcApplicationVersion Property

[image]

Revit 2024 API
ParameterTypeId..::..IfcApplicationVersion Property
ParameterTypeId Class See Also Send Feedback
"IfcApplicationVersion"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId IfcApplicationVersion { get; }
Visual Basic
Public Shared ReadOnly Property IfcApplicationVersion As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ IfcApplicationVersion {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


IfcBuildingGuid Property

[image]

Revit 2024 API
ParameterTypeId..::..IfcBuildingGuid Property
ParameterTypeId Class See Also Send Feedback
"IfcBuilding GUID"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId IfcBuildingGuid { get; }
Visual Basic
Public Shared ReadOnly Property IfcBuildingGuid As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ IfcBuildingGuid {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


IfcExportElementAs Property

[image]

Revit 2024 API
ParameterTypeId..::..IfcExportElementAs Property
ParameterTypeId Class See Also Send Feedback
"Export to IFC As"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId IfcExportElementAs { get; }
Visual Basic
Public Shared ReadOnly Property IfcExportElementAs As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ IfcExportElementAs {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


IfcExportElementType Property

[image]

Revit 2024 API
ParameterTypeId..::..IfcExportElementType Property
ParameterTypeId Class See Also Send Feedback
"Export Type to IFC"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId IfcExportElementType { get; }
Visual Basic
Public Shared ReadOnly Property IfcExportElementType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ IfcExportElementType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


IfcExportElementTypeAs Property

[image]

Revit 2024 API
ParameterTypeId..::..IfcExportElementTypeAs Property
ParameterTypeId Class See Also Send Feedback
"Export Type to IFC As"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId IfcExportElementTypeAs { get; }
Visual Basic
Public Shared ReadOnly Property IfcExportElementTypeAs As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ IfcExportElementTypeAs {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


IfcExportPredefinedtypeType Property

[image]

Revit 2024 API
ParameterTypeId..::..IfcExportPredefinedtypeType Property
ParameterTypeId Class See Also Send Feedback
"Type IFC Predefined Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId IfcExportPredefinedtypeType { get; }
Visual Basic
Public Shared ReadOnly Property IfcExportPredefinedtypeType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ IfcExportPredefinedtypeType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


IfcGuid Property

[image]

Revit 2024 API
ParameterTypeId..::..IfcGuid Property
ParameterTypeId Class See Also Send Feedback
"IfcGUID"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId IfcGuid { get; }
Visual Basic
Public Shared ReadOnly Property IfcGuid As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ IfcGuid {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


IfcOrganization Property

[image]

Revit 2024 API
ParameterTypeId..::..IfcOrganization Property
ParameterTypeId Class See Also Send Feedback
"IfcOrganization"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId IfcOrganization { get; }
Visual Basic
Public Shared ReadOnly Property IfcOrganization As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ IfcOrganization {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


IfcTypeGuid Property

[image]

Revit 2024 API
ParameterTypeId..::..IfcTypeGuid Property
ParameterTypeId Class See Also Send Feedback
"Type IfcGUID"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId IfcTypeGuid { get; }
Visual Basic
Public Shared ReadOnly Property IfcTypeGuid As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ IfcTypeGuid {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ImportAdtEntityLength Property

[image]

Revit 2024 API
ParameterTypeId..::..ImportAdtEntityLength Property
ParameterTypeId Class See Also Send Feedback
"Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ImportAdtEntityLength { get; }
Visual Basic
Public Shared ReadOnly Property ImportAdtEntityLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ImportAdtEntityLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ImportAdtEntityRoll Property

[image]

Revit 2024 API
ParameterTypeId..::..ImportAdtEntityRoll Property
ParameterTypeId Class See Also Send Feedback
"Roll"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ImportAdtEntityRoll { get; }
Visual Basic
Public Shared ReadOnly Property ImportAdtEntityRoll As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ImportAdtEntityRoll {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ImportAdtEntityStructType Property

[image]

Revit 2024 API
ParameterTypeId..::..ImportAdtEntityStructType Property
ParameterTypeId Class See Also Send Feedback
"Structural Type Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ImportAdtEntityStructType { get; }
Visual Basic
Public Shared ReadOnly Property ImportAdtEntityStructType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ImportAdtEntityStructType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ImportAdtEntityThickness Property

[image]

Revit 2024 API
ParameterTypeId..::..ImportAdtEntityThickness Property
ParameterTypeId Class See Also Send Feedback
"Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ImportAdtEntityThickness { get; }
Visual Basic
Public Shared ReadOnly Property ImportAdtEntityThickness As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ImportAdtEntityThickness {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ImportAdtEntityType Property

[image]

Revit 2024 API
ParameterTypeId..::..ImportAdtEntityType Property
ParameterTypeId Class See Also Send Feedback
"Type Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ImportAdtEntityType { get; }
Visual Basic
Public Shared ReadOnly Property ImportAdtEntityType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ImportAdtEntityType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ImportAdtEntityWidth Property

[image]

Revit 2024 API
ParameterTypeId..::..ImportAdtEntityWidth Property
ParameterTypeId Class See Also Send Feedback
"Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ImportAdtEntityWidth { get; }
Visual Basic
Public Shared ReadOnly Property ImportAdtEntityWidth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ImportAdtEntityWidth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ImportBaseLevel Property

[image]

Revit 2024 API
ParameterTypeId..::..ImportBaseLevel Property
ParameterTypeId Class See Also Send Feedback
"Work Plane"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ImportBaseLevel { get; }
Visual Basic
Public Shared ReadOnly Property ImportBaseLevel As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ImportBaseLevel {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ImportBaseLevelOffset Property

[image]

Revit 2024 API
ParameterTypeId..::..ImportBaseLevelOffset Property
ParameterTypeId Class See Also Send Feedback
"Offset from Work Plane"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ImportBaseLevelOffset { get; }
Visual Basic
Public Shared ReadOnly Property ImportBaseLevelOffset As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ImportBaseLevelOffset {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ImportInstanceScale Property

[image]

Revit 2024 API
ParameterTypeId..::..ImportInstanceScale Property
ParameterTypeId Class See Also Send Feedback
"Instance Scale"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ImportInstanceScale { get; }
Visual Basic
Public Shared ReadOnly Property ImportInstanceScale As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ImportInstanceScale {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ImportScale Property

[image]

Revit 2024 API
ParameterTypeId..::..ImportScale Property
ParameterTypeId Class See Also Send Feedback
"Scale Factor"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ImportScale { get; }
Visual Basic
Public Shared ReadOnly Property ImportScale As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ImportScale {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ImportSymbolName Property

[image]

Revit 2024 API
ParameterTypeId..::..ImportSymbolName Property
ParameterTypeId Class See Also Send Feedback
"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ImportSymbolName { get; }
Visual Basic
Public Shared ReadOnly Property ImportSymbolName As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ImportSymbolName {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


InfrastructureAlignmentDescription Property

[image]

Revit 2024 API
ParameterTypeId..::..InfrastructureAlignmentDescription Property
ParameterTypeId Class See Also Send Feedback
"Description"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId InfrastructureAlignmentDescription { get; }
Visual Basic
Public Shared ReadOnly Property InfrastructureAlignmentDescription As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ InfrastructureAlignmentDescription {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


InfrastructureAlignmentDisplayedEndStation Property

[image]

Revit 2024 API
ParameterTypeId..::..InfrastructureAlignmentDisplayedEndStation Property
ParameterTypeId Class See Also Send Feedback
"Displayed End Station"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId InfrastructureAlignmentDisplayedEndStation { get; }
Visual Basic
Public Shared ReadOnly Property InfrastructureAlignmentDisplayedEndStation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ InfrastructureAlignmentDisplayedEndStation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


InfrastructureAlignmentDisplayedStartStation Property

[image]

Revit 2024 API
ParameterTypeId..::..InfrastructureAlignmentDisplayedStartStation Property
ParameterTypeId Class See Also Send Feedback
"Displayed Start Station"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId InfrastructureAlignmentDisplayedStartStation { get; }
Visual Basic
Public Shared ReadOnly Property InfrastructureAlignmentDisplayedStartStation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ InfrastructureAlignmentDisplayedStartStation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


InfrastructureAlignmentName Property

[image]

Revit 2024 API
ParameterTypeId..::..InfrastructureAlignmentName Property
ParameterTypeId Class See Also Send Feedback
"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId InfrastructureAlignmentName { get; }
Visual Basic
Public Shared ReadOnly Property InfrastructureAlignmentName As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ InfrastructureAlignmentName {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


InsertOrientation Property

[image]

Revit 2024 API
ParameterTypeId..::..InsertOrientation Property
ParameterTypeId Class See Also Send Feedback
"Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId InsertOrientation { get; }
Visual Basic
Public Shared ReadOnly Property InsertOrientation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ InsertOrientation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


InstanceElevationParam Property

[image]

Revit 2024 API
ParameterTypeId..::..InstanceElevationParam Property
ParameterTypeId Class See Also Send Feedback
"Elevation from Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId InstanceElevationParam { get; }
Visual Basic
Public Shared ReadOnly Property InstanceElevationParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ InstanceElevationParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


InstanceFreeHostOffsetParam Property

[image]

Revit 2024 API
ParameterTypeId..::..InstanceFreeHostOffsetParam Property
ParameterTypeId Class See Also Send Feedback
"Offset from Host"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId InstanceFreeHostOffsetParam { get; }
Visual Basic
Public Shared ReadOnly Property InstanceFreeHostOffsetParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ InstanceFreeHostOffsetParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


InstanceFreeHostParam Property

[image]

Revit 2024 API
ParameterTypeId..::..InstanceFreeHostParam Property
ParameterTypeId Class See Also Send Feedback
"Host"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId InstanceFreeHostParam { get; }
Visual Basic
Public Shared ReadOnly Property InstanceFreeHostParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ InstanceFreeHostParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


InstanceHeadHeightParam Property

[image]

Revit 2024 API
ParameterTypeId..::..InstanceHeadHeightParam Property
ParameterTypeId Class See Also Send Feedback
"Head Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId InstanceHeadHeightParam { get; }
Visual Basic
Public Shared ReadOnly Property InstanceHeadHeightParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ InstanceHeadHeightParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


InstanceLengthParam Property

[image]

Revit 2024 API
ParameterTypeId..::..InstanceLengthParam Property
ParameterTypeId Class See Also Send Feedback
"Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId InstanceLengthParam { get; }
Visual Basic
Public Shared ReadOnly Property InstanceLengthParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ InstanceLengthParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


InstanceMoveBaseWithGrids Property

[image]

Revit 2024 API
ParameterTypeId..::..InstanceMoveBaseWithGrids Property
ParameterTypeId Class See Also Send Feedback
"Move Base With Grids"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId InstanceMoveBaseWithGrids { get; }
Visual Basic
Public Shared ReadOnly Property InstanceMoveBaseWithGrids As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ InstanceMoveBaseWithGrids {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


InstanceMovesWithGridParam Property

[image]

Revit 2024 API
ParameterTypeId..::..InstanceMovesWithGridParam Property
ParameterTypeId Class See Also Send Feedback
"Moves With Grids"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId InstanceMovesWithGridParam { get; }
Visual Basic
Public Shared ReadOnly Property InstanceMovesWithGridParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ InstanceMovesWithGridParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


InstanceOffsetPosParam Property

[image]

Revit 2024 API
ParameterTypeId..::..InstanceOffsetPosParam Property
ParameterTypeId Class See Also Send Feedback
"Moves With Nearby Elements"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId InstanceOffsetPosParam { get; }
Visual Basic
Public Shared ReadOnly Property InstanceOffsetPosParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ InstanceOffsetPosParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


InstanceReferenceLevelParam Property

[image]

Revit 2024 API
ParameterTypeId..::..InstanceReferenceLevelParam Property
ParameterTypeId Class See Also Send Feedback
"Reference Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId InstanceReferenceLevelParam { get; }
Visual Basic
Public Shared ReadOnly Property InstanceReferenceLevelParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ InstanceReferenceLevelParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


InstanceScheduleOnlyLevelParam Property

[image]

Revit 2024 API
ParameterTypeId..::..InstanceScheduleOnlyLevelParam Property
ParameterTypeId Class See Also Send Feedback
"Schedule Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId InstanceScheduleOnlyLevelParam { get; }
Visual Basic
Public Shared ReadOnly Property InstanceScheduleOnlyLevelParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ InstanceScheduleOnlyLevelParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


InstanceSillHeightParam Property

[image]

Revit 2024 API
ParameterTypeId..::..InstanceSillHeightParam Property
ParameterTypeId Class See Also Send Feedback
"Sill Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId InstanceSillHeightParam { get; }
Visual Basic
Public Shared ReadOnly Property InstanceSillHeightParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ InstanceSillHeightParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


InstanceStructUsageParam Property

[image]

Revit 2024 API
ParameterTypeId..::..InstanceStructUsageParam Property
ParameterTypeId Class See Also Send Feedback
"Structural Usage"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId InstanceStructUsageParam { get; }
Visual Basic
Public Shared ReadOnly Property InstanceStructUsageParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ InstanceStructUsageParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


InsulationScale Property

[image]

Revit 2024 API
ParameterTypeId..::..InsulationScale Property
ParameterTypeId Class See Also Send Feedback
"Insulation Bulge to Width Ratio (1/x)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId InsulationScale { get; }
Visual Basic
Public Shared ReadOnly Property InsulationScale As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ InsulationScale {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


InteriorTickDisplay Property

[image]

Revit 2024 API
ParameterTypeId..::..InteriorTickDisplay Property
ParameterTypeId Class See Also Send Feedback
"Interior Tick Mark Display"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId InteriorTickDisplay { get; }
Visual Basic
Public Shared ReadOnly Property InteriorTickDisplay As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ InteriorTickDisplay {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


IsVisibleParam Property

[image]

Revit 2024 API
ParameterTypeId..::..IsVisibleParam Property
ParameterTypeId Class See Also Send Feedback
"Visible"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId IsVisibleParam { get; }
Visual Basic
Public Shared ReadOnly Property IsVisibleParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ IsVisibleParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


JoinStrengthOrder Property

[image]

Revit 2024 API
ParameterTypeId..::..JoinStrengthOrder Property
ParameterTypeId Class See Also Send Feedback
"Abstract Join Strength Order"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId JoinStrengthOrder { get; }
Visual Basic
Public Shared ReadOnly Property JoinStrengthOrder As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ JoinStrengthOrder {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


JoistSystemElemTagNewMembersView Property

[image]

Revit 2024 API
ParameterTypeId..::..JoistSystemElemTagNewMembersView Property
ParameterTypeId Class See Also Send Feedback
"Tag new members in view"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId JoistSystemElemTagNewMembersView { get; }
Visual Basic
Public Shared ReadOnly Property JoistSystemElemTagNewMembersView As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ JoistSystemElemTagNewMembersView {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


JoistSystemFixedSpacingParam Property

[image]

Revit 2024 API
ParameterTypeId..::..JoistSystemFixedSpacingParam Property
ParameterTypeId Class See Also Send Feedback
"Fixed Spacing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId JoistSystemFixedSpacingParam { get; }
Visual Basic
Public Shared ReadOnly Property JoistSystemFixedSpacingParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ JoistSystemFixedSpacingParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


JoistSystemJustificationParam Property

[image]

Revit 2024 API
ParameterTypeId..::..JoistSystemJustificationParam Property
ParameterTypeId Class See Also Send Feedback
"Justification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId JoistSystemJustificationParam { get; }
Visual Basic
Public Shared ReadOnly Property JoistSystemJustificationParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ JoistSystemJustificationParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


JoistSystemNewBeamTypeNoFamNameParam Property

[image]

Revit 2024 API
ParameterTypeId..::..JoistSystemNewBeamTypeNoFamNameParam Property
ParameterTypeId Class See Also Send Feedback
"Beam Type (No Family Name)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId JoistSystemNewBeamTypeNoFamNameParam { get; }
Visual Basic
Public Shared ReadOnly Property JoistSystemNewBeamTypeNoFamNameParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ JoistSystemNewBeamTypeNoFamNameParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


JoistSystemNewBeamTypeParam Property

[image]

Revit 2024 API
ParameterTypeId..::..JoistSystemNewBeamTypeParam Property
ParameterTypeId Class See Also Send Feedback
"Beam Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId JoistSystemNewBeamTypeParam { get; }
Visual Basic
Public Shared ReadOnly Property JoistSystemNewBeamTypeParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ JoistSystemNewBeamTypeParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


JoistSystemNumberOfLinesParam Property

[image]

Revit 2024 API
ParameterTypeId..::..JoistSystemNumberOfLinesParam Property
ParameterTypeId Class See Also Send Feedback
"Number of Lines"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId JoistSystemNumberOfLinesParam { get; }
Visual Basic
Public Shared ReadOnly Property JoistSystemNumberOfLinesParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ JoistSystemNumberOfLinesParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


KeepReadable Property

[image]

Revit 2024 API
ParameterTypeId..::..KeepReadable Property
ParameterTypeId Class See Also Send Feedback
"Keep Readable"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId KeepReadable { get; }
Visual Basic
Public Shared ReadOnly Property KeepReadable As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KeepReadable {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


KeynoteParam Property

[image]

Revit 2024 API
ParameterTypeId..::..KeynoteParam Property
ParameterTypeId Class See Also Send Feedback
"Keynote"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId KeynoteParam { get; }
Visual Basic
Public Shared ReadOnly Property KeynoteParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KeynoteParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


KeySourceParam Property

[image]

Revit 2024 API
ParameterTypeId..::..KeySourceParam Property
ParameterTypeId Class See Also Send Feedback
"Key Source"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId KeySourceParam { get; }
Visual Basic
Public Shared ReadOnly Property KeySourceParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KeySourceParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LayerElemAreaComputed Property

[image]

Revit 2024 API
ParameterTypeId..::..LayerElemAreaComputed Property
ParameterTypeId Class See Also Send Feedback
"Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LayerElemAreaComputed { get; }
Visual Basic
Public Shared ReadOnly Property LayerElemAreaComputed As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LayerElemAreaComputed {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LayerElemBaseConstraint Property

[image]

Revit 2024 API
ParameterTypeId..::..LayerElemBaseConstraint Property
ParameterTypeId Class See Also Send Feedback
"Base Constraint"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LayerElemBaseConstraint { get; }
Visual Basic
Public Shared ReadOnly Property LayerElemBaseConstraint As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LayerElemBaseConstraint {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LayerElemBaseExtensionDis Property

[image]

Revit 2024 API
ParameterTypeId..::..LayerElemBaseExtensionDis Property
ParameterTypeId Class See Also Send Feedback
"Base Extension Distance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LayerElemBaseExtensionDis { get; }
Visual Basic
Public Shared ReadOnly Property LayerElemBaseExtensionDis As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LayerElemBaseExtensionDis {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LayerElemCompoundElemFamily Property

[image]

Revit 2024 API
ParameterTypeId..::..LayerElemCompoundElemFamily Property
ParameterTypeId Class See Also Send Feedback
"Compound Element Family"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LayerElemCompoundElemFamily { get; }
Visual Basic
Public Shared ReadOnly Property LayerElemCompoundElemFamily As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LayerElemCompoundElemFamily {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LayerElemIsCoreLayer Property

[image]

Revit 2024 API
ParameterTypeId..::..LayerElemIsCoreLayer Property
ParameterTypeId Class See Also Send Feedback
"Is Core Layer"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LayerElemIsCoreLayer { get; }
Visual Basic
Public Shared ReadOnly Property LayerElemIsCoreLayer As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LayerElemIsCoreLayer {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LayerElemIsStructuralMaterial Property

[image]

Revit 2024 API
ParameterTypeId..::..LayerElemIsStructuralMaterial Property
ParameterTypeId Class See Also Send Feedback
"Is Structural Material"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LayerElemIsStructuralMaterial { get; }
Visual Basic
Public Shared ReadOnly Property LayerElemIsStructuralMaterial As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LayerElemIsStructuralMaterial {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LayerElemIsVariable Property

[image]

Revit 2024 API
ParameterTypeId..::..LayerElemIsVariable Property
ParameterTypeId Class See Also Send Feedback
"Is Variable"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LayerElemIsVariable { get; }
Visual Basic
Public Shared ReadOnly Property LayerElemIsVariable As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LayerElemIsVariable {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LayerElemMaterials Property

[image]

Revit 2024 API
ParameterTypeId..::..LayerElemMaterials Property
ParameterTypeId Class See Also Send Feedback
"Material": Material

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LayerElemMaterials { get; }
Visual Basic
Public Shared ReadOnly Property LayerElemMaterials As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LayerElemMaterials {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LayerElemTopConstraint Property

[image]

Revit 2024 API
ParameterTypeId..::..LayerElemTopConstraint Property
ParameterTypeId Class See Also Send Feedback
"Top Constraint"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LayerElemTopConstraint { get; }
Visual Basic
Public Shared ReadOnly Property LayerElemTopConstraint As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LayerElemTopConstraint {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LayerElemTopExtensionDis Property

[image]

Revit 2024 API
ParameterTypeId..::..LayerElemTopExtensionDis Property
ParameterTypeId Class See Also Send Feedback
"Top Extension Distance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LayerElemTopExtensionDis { get; }
Visual Basic
Public Shared ReadOnly Property LayerElemTopExtensionDis As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LayerElemTopExtensionDis {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LayerElemVolumeComputed Property

[image]

Revit 2024 API
ParameterTypeId..::..LayerElemVolumeComputed Property
ParameterTypeId Class See Also Send Feedback
"Volume"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LayerElemVolumeComputed { get; }
Visual Basic
Public Shared ReadOnly Property LayerElemVolumeComputed As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LayerElemVolumeComputed {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LayerTypeMaterials Property

[image]

Revit 2024 API
ParameterTypeId..::..LayerTypeMaterials Property
ParameterTypeId Class See Also Send Feedback
"Material": Material

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LayerTypeMaterials { get; }
Visual Basic
Public Shared ReadOnly Property LayerTypeMaterials As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LayerTypeMaterials {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LeaderArrowhead Property

[image]

Revit 2024 API
ParameterTypeId..::..LeaderArrowhead Property
ParameterTypeId Class See Also Send Feedback
"Leader Arrowhead"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LeaderArrowhead { get; }
Visual Basic
Public Shared ReadOnly Property LeaderArrowhead As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LeaderArrowhead {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LeaderArrowWidth Property

[image]

Revit 2024 API
ParameterTypeId..::..LeaderArrowWidth Property
ParameterTypeId Class See Also Send Feedback
"Arrow Width Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LeaderArrowWidth { get; }
Visual Basic
Public Shared ReadOnly Property LeaderArrowWidth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LeaderArrowWidth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LeaderLeftAttachment Property

[image]

Revit 2024 API
ParameterTypeId..::..LeaderLeftAttachment Property
ParameterTypeId Class See Also Send Feedback
"Left Attachment"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LeaderLeftAttachment { get; }
Visual Basic
Public Shared ReadOnly Property LeaderLeftAttachment As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LeaderLeftAttachment {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LeaderLine Property

[image]

Revit 2024 API
ParameterTypeId..::..LeaderLine Property
ParameterTypeId Class See Also Send Feedback
"Leader Line"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LeaderLine { get; }
Visual Basic
Public Shared ReadOnly Property LeaderLine As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LeaderLine {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LeaderOffsetSheet Property

[image]

Revit 2024 API
ParameterTypeId..::..LeaderOffsetSheet Property
ParameterTypeId Class See Also Send Feedback
"Leader/Border Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LeaderOffsetSheet { get; }
Visual Basic
Public Shared ReadOnly Property LeaderOffsetSheet As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LeaderOffsetSheet {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LeaderRightAttachment Property

[image]

Revit 2024 API
ParameterTypeId..::..LeaderRightAttachment Property
ParameterTypeId Class See Also Send Feedback
"Right Attachment"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LeaderRightAttachment { get; }
Visual Basic
Public Shared ReadOnly Property LeaderRightAttachment As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LeaderRightAttachment {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LegendComponentLength Property

[image]

Revit 2024 API
ParameterTypeId..::..LegendComponentLength Property
ParameterTypeId Class See Also Send Feedback
"Host Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LegendComponentLength { get; }
Visual Basic
Public Shared ReadOnly Property LegendComponentLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LegendComponentLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LegendComponentView Property

[image]

Revit 2024 API
ParameterTypeId..::..LegendComponentView Property
ParameterTypeId Class See Also Send Feedback
"View Direction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LegendComponentView { get; }
Visual Basic
Public Shared ReadOnly Property LegendComponentView As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LegendComponentView {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LevelAttrRoomComputationAutomatic Property

[image]

Revit 2024 API
ParameterTypeId..::..LevelAttrRoomComputationAutomatic Property
ParameterTypeId Class See Also Send Feedback
"Automatic Room Computation Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LevelAttrRoomComputationAutomatic { get; }
Visual Basic
Public Shared ReadOnly Property LevelAttrRoomComputationAutomatic As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LevelAttrRoomComputationAutomatic {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LevelDataFloorArea Property

[image]

Revit 2024 API
ParameterTypeId..::..LevelDataFloorArea Property
ParameterTypeId Class See Also Send Feedback
"Floor Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LevelDataFloorArea { get; }
Visual Basic
Public Shared ReadOnly Property LevelDataFloorArea As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LevelDataFloorArea {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LevelDataFloorPerimeter Property

[image]

Revit 2024 API
ParameterTypeId..::..LevelDataFloorPerimeter Property
ParameterTypeId Class See Also Send Feedback
"Floor Perimeter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LevelDataFloorPerimeter { get; }
Visual Basic
Public Shared ReadOnly Property LevelDataFloorPerimeter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LevelDataFloorPerimeter {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LevelDataMassFamilyAndTypeParam Property

[image]

Revit 2024 API
ParameterTypeId..::..LevelDataMassFamilyAndTypeParam Property
ParameterTypeId Class See Also Send Feedback
"Mass: Family and Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LevelDataMassFamilyAndTypeParam { get; }
Visual Basic
Public Shared ReadOnly Property LevelDataMassFamilyAndTypeParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LevelDataMassFamilyAndTypeParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LevelDataMassFamilyParam Property

[image]

Revit 2024 API
ParameterTypeId..::..LevelDataMassFamilyParam Property
ParameterTypeId Class See Also Send Feedback
"Mass: Family"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LevelDataMassFamilyParam { get; }
Visual Basic
Public Shared ReadOnly Property LevelDataMassFamilyParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LevelDataMassFamilyParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LevelDataMassTypeComments Property

[image]

Revit 2024 API
ParameterTypeId..::..LevelDataMassTypeComments Property
ParameterTypeId Class See Also Send Feedback
"Mass: Type Comments"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LevelDataMassTypeComments { get; }
Visual Basic
Public Shared ReadOnly Property LevelDataMassTypeComments As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LevelDataMassTypeComments {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LevelDataMassTypeDescription Property

[image]

Revit 2024 API
ParameterTypeId..::..LevelDataMassTypeDescription Property
ParameterTypeId Class See Also Send Feedback
"Mass: Description"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LevelDataMassTypeDescription { get; }
Visual Basic
Public Shared ReadOnly Property LevelDataMassTypeDescription As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LevelDataMassTypeDescription {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LevelDataMassTypeParam Property

[image]

Revit 2024 API
ParameterTypeId..::..LevelDataMassTypeParam Property
ParameterTypeId Class See Also Send Feedback
"Mass: Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LevelDataMassTypeParam { get; }
Visual Basic
Public Shared ReadOnly Property LevelDataMassTypeParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LevelDataMassTypeParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LevelDataSpaceUsage Property

[image]

Revit 2024 API
ParameterTypeId..::..LevelDataSpaceUsage Property
ParameterTypeId Class See Also Send Feedback
"Usage"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LevelDataSpaceUsage { get; }
Visual Basic
Public Shared ReadOnly Property LevelDataSpaceUsage As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LevelDataSpaceUsage {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LevelDataSurfaceArea Property

[image]

Revit 2024 API
ParameterTypeId..::..LevelDataSurfaceArea Property
ParameterTypeId Class See Also Send Feedback
"Exterior Surface Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LevelDataSurfaceArea { get; }
Visual Basic
Public Shared ReadOnly Property LevelDataSurfaceArea As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LevelDataSurfaceArea {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LevelDataVolume Property

[image]

Revit 2024 API
ParameterTypeId..::..LevelDataVolume Property
ParameterTypeId Class See Also Send Feedback
"Floor Volume"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LevelDataVolume { get; }
Visual Basic
Public Shared ReadOnly Property LevelDataVolume As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LevelDataVolume {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LevelElev Property

[image]

Revit 2024 API
ParameterTypeId..::..LevelElev Property
ParameterTypeId Class See Also Send Feedback
"Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LevelElev { get; }
Visual Basic
Public Shared ReadOnly Property LevelElev As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LevelElev {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LevelIsGroundPlane Property

[image]

Revit 2024 API
ParameterTypeId..::..LevelIsGroundPlane Property
ParameterTypeId Class See Also Send Feedback
"Is ground plane"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LevelIsGroundPlane { get; }
Visual Basic
Public Shared ReadOnly Property LevelIsGroundPlane As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LevelIsGroundPlane {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LevelIsStructural Property

[image]

Revit 2024 API
ParameterTypeId..::..LevelIsStructural Property
ParameterTypeId Class See Also Send Feedback
"Structural"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LevelIsStructural { get; }
Visual Basic
Public Shared ReadOnly Property LevelIsStructural As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LevelIsStructural {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LevelName Property

[image]

Revit 2024 API
ParameterTypeId..::..LevelName Property
ParameterTypeId Class See Also Send Feedback
"Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LevelName { get; }
Visual Basic
Public Shared ReadOnly Property LevelName As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LevelName {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LevelParam Property

[image]

Revit 2024 API
ParameterTypeId..::..LevelParam Property
ParameterTypeId Class See Also Send Feedback
"Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LevelParam { get; }
Visual Basic
Public Shared ReadOnly Property LevelParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LevelParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LevelRelativeBaseType Property

[image]

Revit 2024 API
ParameterTypeId..::..LevelRelativeBaseType Property
ParameterTypeId Class See Also Send Feedback
"Elevation Base"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LevelRelativeBaseType { get; }
Visual Basic
Public Shared ReadOnly Property LevelRelativeBaseType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LevelRelativeBaseType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LevelRoomComputationHeight Property

[image]

Revit 2024 API
ParameterTypeId..::..LevelRoomComputationHeight Property
ParameterTypeId Class See Also Send Feedback
"Computation Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LevelRoomComputationHeight { get; }
Visual Basic
Public Shared ReadOnly Property LevelRoomComputationHeight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LevelRoomComputationHeight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LevelUpToLevel Property

[image]

Revit 2024 API
ParameterTypeId..::..LevelUpToLevel Property
ParameterTypeId Class See Also Send Feedback
"Story Above"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LevelUpToLevel { get; }
Visual Basic
Public Shared ReadOnly Property LevelUpToLevel As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LevelUpToLevel {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LightingFixtureLightEmitter Property

[image]

Revit 2024 API
ParameterTypeId..::..LightingFixtureLightEmitter Property
ParameterTypeId Class See Also Send Feedback
"Light Emitter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LightingFixtureLightEmitter { get; }
Visual Basic
Public Shared ReadOnly Property LightingFixtureLightEmitter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LightingFixtureLightEmitter {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LinearDimType Property

[image]

Revit 2024 API
ParameterTypeId..::..LinearDimType Property
ParameterTypeId Class See Also Send Feedback
"Dimension String Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LinearDimType { get; }
Visual Basic
Public Shared ReadOnly Property LinearDimType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LinearDimType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LinearFramingLength Property

[image]

Revit 2024 API
ParameterTypeId..::..LinearFramingLength Property
ParameterTypeId Class See Also Send Feedback
"Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LinearFramingLength { get; }
Visual Basic
Public Shared ReadOnly Property LinearFramingLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LinearFramingLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LineColor Property

[image]

Revit 2024 API
ParameterTypeId..::..LineColor Property
ParameterTypeId Class See Also Send Feedback
"Color"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LineColor { get; }
Visual Basic
Public Shared ReadOnly Property LineColor As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LineColor {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LinePattern Property

[image]

Revit 2024 API
ParameterTypeId..::..LinePattern Property
ParameterTypeId Class See Also Send Feedback
"Line Pattern"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LinePattern { get; }
Visual Basic
Public Shared ReadOnly Property LinePattern As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LinePattern {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LinePen Property

[image]

Revit 2024 API
ParameterTypeId..::..LinePen Property
ParameterTypeId Class See Also Send Feedback
"Line Weight"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LinePen { get; }
Visual Basic
Public Shared ReadOnly Property LinePen As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LinePen {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LineShapeAtCorner Property

[image]

Revit 2024 API
ParameterTypeId..::..LineShapeAtCorner Property
ParameterTypeId Class See Also Send Feedback
"Line Shape at Landing Corner"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LineShapeAtCorner { get; }
Visual Basic
Public Shared ReadOnly Property LineShapeAtCorner As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LineShapeAtCorner {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LoadAllNon0Loads Property

[image]

Revit 2024 API
ParameterTypeId..::..LoadAllNon0Loads Property
ParameterTypeId Class See Also Send Feedback
"All non 0 loads"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LoadAllNon0Loads { get; }
Visual Basic
Public Shared ReadOnly Property LoadAllNon0Loads As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LoadAllNon0Loads {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LoadAreaArea Property

[image]

Revit 2024 API
ParameterTypeId..::..LoadAreaArea Property
ParameterTypeId Class See Also Send Feedback
"Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LoadAreaArea { get; }
Visual Basic
Public Shared ReadOnly Property LoadAreaArea As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LoadAreaArea {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LoadAreaForceFx1 Property

[image]

Revit 2024 API
ParameterTypeId..::..LoadAreaForceFx1 Property
ParameterTypeId Class See Also Send Feedback
"Fx 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LoadAreaForceFx1 { get; }
Visual Basic
Public Shared ReadOnly Property LoadAreaForceFx1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LoadAreaForceFx1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LoadAreaForceFx3 Property

[image]

Revit 2024 API
ParameterTypeId..::..LoadAreaForceFx3 Property
ParameterTypeId Class See Also Send Feedback
"Fx 3"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LoadAreaForceFx3 { get; }
Visual Basic
Public Shared ReadOnly Property LoadAreaForceFx3 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LoadAreaForceFx3 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LoadAreaForceFy1 Property

[image]

Revit 2024 API
ParameterTypeId..::..LoadAreaForceFy1 Property
ParameterTypeId Class See Also Send Feedback
"Fy 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LoadAreaForceFy1 { get; }
Visual Basic
Public Shared ReadOnly Property LoadAreaForceFy1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LoadAreaForceFy1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LoadAreaForceFy2 Property

[image]

Revit 2024 API
ParameterTypeId..::..LoadAreaForceFy2 Property
ParameterTypeId Class See Also Send Feedback
"Fy 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LoadAreaForceFy2 { get; }
Visual Basic
Public Shared ReadOnly Property LoadAreaForceFy2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LoadAreaForceFy2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LoadAreaForceFy3 Property

[image]

Revit 2024 API
ParameterTypeId..::..LoadAreaForceFy3 Property
ParameterTypeId Class See Also Send Feedback
"Fy 3"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LoadAreaForceFy3 { get; }
Visual Basic
Public Shared ReadOnly Property LoadAreaForceFy3 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LoadAreaForceFy3 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LoadAreaForceFz1 Property

[image]

Revit 2024 API
ParameterTypeId..::..LoadAreaForceFz1 Property
ParameterTypeId Class See Also Send Feedback
"Fz 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LoadAreaForceFz1 { get; }
Visual Basic
Public Shared ReadOnly Property LoadAreaForceFz1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LoadAreaForceFz1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LoadAreaForceFz2 Property

[image]

Revit 2024 API
ParameterTypeId..::..LoadAreaForceFz2 Property
ParameterTypeId Class See Also Send Feedback
"Fz 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LoadAreaForceFz2 { get; }
Visual Basic
Public Shared ReadOnly Property LoadAreaForceFz2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LoadAreaForceFz2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LoadAreaIsProjected Property

[image]

Revit 2024 API
ParameterTypeId..::..LoadAreaIsProjected Property
ParameterTypeId Class See Also Send Feedback
"Projected Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LoadAreaIsProjected { get; }
Visual Basic
Public Shared ReadOnly Property LoadAreaIsProjected As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LoadAreaIsProjected {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LoadArrowSeparation Property

[image]

Revit 2024 API
ParameterTypeId..::..LoadArrowSeparation Property
ParameterTypeId Class See Also Send Feedback
"Distance between arrows"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LoadArrowSeparation { get; }
Visual Basic
Public Shared ReadOnly Property LoadArrowSeparation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LoadArrowSeparation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LoadAttrAreaForceScaleFactor Property

[image]

Revit 2024 API
ParameterTypeId..::..LoadAttrAreaForceScaleFactor Property
ParameterTypeId Class See Also Send Feedback
"Area force scale"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LoadAttrAreaForceScaleFactor { get; }
Visual Basic
Public Shared ReadOnly Property LoadAttrAreaForceScaleFactor As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LoadAttrAreaForceScaleFactor {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LoadAttrForceArrowType Property

[image]

Revit 2024 API
ParameterTypeId..::..LoadAttrForceArrowType Property
ParameterTypeId Class See Also Send Feedback
"Force arrowhead"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LoadAttrForceArrowType { get; }
Visual Basic
Public Shared ReadOnly Property LoadAttrForceArrowType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LoadAttrForceArrowType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LoadAttrForceScaleFactor Property

[image]

Revit 2024 API
ParameterTypeId..::..LoadAttrForceScaleFactor Property
ParameterTypeId Class See Also Send Feedback
"Force scale"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LoadAttrForceScaleFactor { get; }
Visual Basic
Public Shared ReadOnly Property LoadAttrForceScaleFactor As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LoadAttrForceScaleFactor {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LoadAttrLinearForceScaleFactor Property

[image]

Revit 2024 API
ParameterTypeId..::..LoadAttrLinearForceScaleFactor Property
ParameterTypeId Class See Also Send Feedback
"Linear force scale"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LoadAttrLinearForceScaleFactor { get; }
Visual Basic
Public Shared ReadOnly Property LoadAttrLinearForceScaleFactor As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LoadAttrLinearForceScaleFactor {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LoadAttrMomentArrowArc Property

[image]

Revit 2024 API
ParameterTypeId..::..LoadAttrMomentArrowArc Property
ParameterTypeId Class See Also Send Feedback
"Moment arrowhead"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LoadAttrMomentArrowArc { get; }
Visual Basic
Public Shared ReadOnly Property LoadAttrMomentArrowArc As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LoadAttrMomentArrowArc {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LoadAttrMomentArrowLine Property

[image]

Revit 2024 API
ParameterTypeId..::..LoadAttrMomentArrowLine Property
ParameterTypeId Class See Also Send Feedback
"Moment arrowhead (alternate)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LoadAttrMomentArrowLine { get; }
Visual Basic
Public Shared ReadOnly Property LoadAttrMomentArrowLine As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LoadAttrMomentArrowLine {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LoadCaseId Property

[image]

Revit 2024 API
ParameterTypeId..::..LoadCaseId Property
ParameterTypeId Class See Also Send Feedback
"Load Case"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LoadCaseId { get; }
Visual Basic
Public Shared ReadOnly Property LoadCaseId As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LoadCaseId {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LoadCaseName Property

[image]

Revit 2024 API
ParameterTypeId..::..LoadCaseName Property
ParameterTypeId Class See Also Send Feedback
"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LoadCaseName { get; }
Visual Basic
Public Shared ReadOnly Property LoadCaseName As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LoadCaseName {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LoadCaseNature Property

[image]

Revit 2024 API
ParameterTypeId..::..LoadCaseNature Property
ParameterTypeId Class See Also Send Feedback
"Nature"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LoadCaseNature { get; }
Visual Basic
Public Shared ReadOnly Property LoadCaseNature As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LoadCaseNature {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LoadCaseNatureText Property

[image]

Revit 2024 API
ParameterTypeId..::..LoadCaseNatureText Property
ParameterTypeId Class See Also Send Feedback
"Nature"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LoadCaseNatureText { get; }
Visual Basic
Public Shared ReadOnly Property LoadCaseNatureText As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LoadCaseNatureText {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LoadCaseNumber Property

[image]

Revit 2024 API
ParameterTypeId..::..LoadCaseNumber Property
ParameterTypeId Class See Also Send Feedback
"Case Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LoadCaseNumber { get; }
Visual Basic
Public Shared ReadOnly Property LoadCaseNumber As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LoadCaseNumber {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LoadCaseSubcategory Property

[image]

Revit 2024 API
ParameterTypeId..::..LoadCaseSubcategory Property
ParameterTypeId Class See Also Send Feedback
"Category"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LoadCaseSubcategory { get; }
Visual Basic
Public Shared ReadOnly Property LoadCaseSubcategory As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LoadCaseSubcategory {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LoadCombinationFactor Property

[image]

Revit 2024 API
ParameterTypeId..::..LoadCombinationFactor Property
ParameterTypeId Class See Also Send Feedback
"Factor"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LoadCombinationFactor { get; }
Visual Basic
Public Shared ReadOnly Property LoadCombinationFactor As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LoadCombinationFactor {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LoadCombinationName Property

[image]

Revit 2024 API
ParameterTypeId..::..LoadCombinationName Property
ParameterTypeId Class See Also Send Feedback
"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LoadCombinationName { get; }
Visual Basic
Public Shared ReadOnly Property LoadCombinationName As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LoadCombinationName {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LoadDescription Property

[image]

Revit 2024 API
ParameterTypeId..::..LoadDescription Property
ParameterTypeId Class See Also Send Feedback
"Description"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LoadDescription { get; }
Visual Basic
Public Shared ReadOnly Property LoadDescription As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LoadDescription {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LoadForceFx Property

[image]

Revit 2024 API
ParameterTypeId..::..LoadForceFx Property
ParameterTypeId Class See Also Send Feedback
"Fx"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LoadForceFx { get; }
Visual Basic
Public Shared ReadOnly Property LoadForceFx As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LoadForceFx {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LoadIsConstrainedOnHost Property

[image]

Revit 2024 API
ParameterTypeId..::..LoadIsConstrainedOnHost Property
ParameterTypeId Class See Also Send Feedback
"Is constrained on host"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LoadIsConstrainedOnHost { get; }
Visual Basic
Public Shared ReadOnly Property LoadIsConstrainedOnHost As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LoadIsConstrainedOnHost {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LoadIsHosted Property

[image]

Revit 2024 API
ParameterTypeId..::..LoadIsHosted Property
ParameterTypeId Class See Also Send Feedback
"Is Hosted"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LoadIsHosted { get; }
Visual Basic
Public Shared ReadOnly Property LoadIsHosted As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LoadIsHosted {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LoadIsProjected Property

[image]

Revit 2024 API
ParameterTypeId..::..LoadIsProjected Property
ParameterTypeId Class See Also Send Feedback
"Projected Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LoadIsProjected { get; }
Visual Basic
Public Shared ReadOnly Property LoadIsProjected As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LoadIsProjected {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LoadIsReaction Property

[image]

Revit 2024 API
ParameterTypeId..::..LoadIsReaction Property
ParameterTypeId Class See Also Send Feedback
"Is Reaction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LoadIsReaction { get; }
Visual Basic
Public Shared ReadOnly Property LoadIsReaction As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LoadIsReaction {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LoadLinearForceFx1 Property

[image]

Revit 2024 API
ParameterTypeId..::..LoadLinearForceFx1 Property
ParameterTypeId Class See Also Send Feedback
"Fx 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LoadLinearForceFx1 { get; }
Visual Basic
Public Shared ReadOnly Property LoadLinearForceFx1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LoadLinearForceFx1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LoadLinearForceFx2 Property

[image]

Revit 2024 API
ParameterTypeId..::..LoadLinearForceFx2 Property
ParameterTypeId Class See Also Send Feedback
"Fx 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LoadLinearForceFx2 { get; }
Visual Basic
Public Shared ReadOnly Property LoadLinearForceFx2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LoadLinearForceFx2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LoadLinearForceFy1 Property

[image]

Revit 2024 API
ParameterTypeId..::..LoadLinearForceFy1 Property
ParameterTypeId Class See Also Send Feedback
"Fy 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LoadLinearForceFy1 { get; }
Visual Basic
Public Shared ReadOnly Property LoadLinearForceFy1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LoadLinearForceFy1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LoadLinearForceFy2 Property

[image]

Revit 2024 API
ParameterTypeId..::..LoadLinearForceFy2 Property
ParameterTypeId Class See Also Send Feedback
"Fy 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LoadLinearForceFy2 { get; }
Visual Basic
Public Shared ReadOnly Property LoadLinearForceFy2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LoadLinearForceFy2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LoadLinearForceFz1 Property

[image]

Revit 2024 API
ParameterTypeId..::..LoadLinearForceFz1 Property
ParameterTypeId Class See Also Send Feedback
"Fz 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LoadLinearForceFz1 { get; }
Visual Basic
Public Shared ReadOnly Property LoadLinearForceFz1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LoadLinearForceFz1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LoadLinearForceFz2 Property

[image]

Revit 2024 API
ParameterTypeId..::..LoadLinearForceFz2 Property
ParameterTypeId Class See Also Send Feedback
"Fz 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LoadLinearForceFz2 { get; }
Visual Basic
Public Shared ReadOnly Property LoadLinearForceFz2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LoadLinearForceFz2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LoadLinearLength Property

[image]

Revit 2024 API
ParameterTypeId..::..LoadLinearLength Property
ParameterTypeId Class See Also Send Feedback
"Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LoadLinearLength { get; }
Visual Basic
Public Shared ReadOnly Property LoadLinearLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LoadLinearLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LoadMomentMx1 Property

[image]

Revit 2024 API
ParameterTypeId..::..LoadMomentMx1 Property
ParameterTypeId Class See Also Send Feedback
"Mx 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LoadMomentMx1 { get; }
Visual Basic
Public Shared ReadOnly Property LoadMomentMx1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LoadMomentMx1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LoadMomentMx2 Property

[image]

Revit 2024 API
ParameterTypeId..::..LoadMomentMx2 Property
ParameterTypeId Class See Also Send Feedback
"Mx 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LoadMomentMx2 { get; }
Visual Basic
Public Shared ReadOnly Property LoadMomentMx2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LoadMomentMx2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LoadMomentMy Property

[image]

Revit 2024 API
ParameterTypeId..::..LoadMomentMy Property
ParameterTypeId Class See Also Send Feedback
"My"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LoadMomentMy { get; }
Visual Basic
Public Shared ReadOnly Property LoadMomentMy As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LoadMomentMy {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LoadMomentMy1 Property

[image]

Revit 2024 API
ParameterTypeId..::..LoadMomentMy1 Property
ParameterTypeId Class See Also Send Feedback
"My 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LoadMomentMy1 { get; }
Visual Basic
Public Shared ReadOnly Property LoadMomentMy1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LoadMomentMy1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LoadMomentMy2 Property

[image]

Revit 2024 API
ParameterTypeId..::..LoadMomentMy2 Property
ParameterTypeId Class See Also Send Feedback
"My 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LoadMomentMy2 { get; }
Visual Basic
Public Shared ReadOnly Property LoadMomentMy2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LoadMomentMy2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LoadMomentMz Property

[image]

Revit 2024 API
ParameterTypeId..::..LoadMomentMz Property
ParameterTypeId Class See Also Send Feedback
"Mz"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LoadMomentMz { get; }
Visual Basic
Public Shared ReadOnly Property LoadMomentMz As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LoadMomentMz {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LoadMomentMz1 Property

[image]

Revit 2024 API
ParameterTypeId..::..LoadMomentMz1 Property
ParameterTypeId Class See Also Send Feedback
"Mz 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LoadMomentMz1 { get; }
Visual Basic
Public Shared ReadOnly Property LoadMomentMz1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LoadMomentMz1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LoadMomentMz2 Property

[image]

Revit 2024 API
ParameterTypeId..::..LoadMomentMz2 Property
ParameterTypeId Class See Also Send Feedback
"Mz 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LoadMomentMz2 { get; }
Visual Basic
Public Shared ReadOnly Property LoadMomentMz2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LoadMomentMz2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LoadNatureName Property

[image]

Revit 2024 API
ParameterTypeId..::..LoadNatureName Property
ParameterTypeId Class See Also Send Feedback
"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LoadNatureName { get; }
Visual Basic
Public Shared ReadOnly Property LoadNatureName As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LoadNatureName {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LoadUsageName Property

[image]

Revit 2024 API
ParameterTypeId..::..LoadUsageName Property
ParameterTypeId Class See Also Send Feedback
"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LoadUsageName { get; }
Visual Basic
Public Shared ReadOnly Property LoadUsageName As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LoadUsageName {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LoadUseLocalCoordinateSystem Property

[image]

Revit 2024 API
ParameterTypeId..::..LoadUseLocalCoordinateSystem Property
ParameterTypeId Class See Also Send Feedback
"Orient to"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LoadUseLocalCoordinateSystem { get; }
Visual Basic
Public Shared ReadOnly Property LoadUseLocalCoordinateSystem As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LoadUseLocalCoordinateSystem {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LockedEndOffset Property

[image]

Revit 2024 API
ParameterTypeId..::..LockedEndOffset Property
ParameterTypeId Class See Also Send Feedback
"Positive Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LockedEndOffset { get; }
Visual Basic
Public Shared ReadOnly Property LockedEndOffset As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LockedEndOffset {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LockedStartOffset Property

[image]

Revit 2024 API
ParameterTypeId..::..LockedStartOffset Property
ParameterTypeId Class See Also Send Feedback
"Negative Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LockedStartOffset { get; }
Visual Basic
Public Shared ReadOnly Property LockedStartOffset As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LockedStartOffset {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LockedTopOffset Property

[image]

Revit 2024 API
ParameterTypeId..::..LockedTopOffset Property
ParameterTypeId Class See Also Send Feedback
"Positive Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LockedTopOffset { get; }
Visual Basic
Public Shared ReadOnly Property LockedTopOffset As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LockedTopOffset {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LowestAssociatedLevel Property

[image]

Revit 2024 API
ParameterTypeId..::..LowestAssociatedLevel Property
ParameterTypeId Class See Also Send Feedback
"Lowest Associated Level": The lowest level associated with this Analytical Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LowestAssociatedLevel { get; }
Visual Basic
Public Shared ReadOnly Property LowestAssociatedLevel As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LowestAssociatedLevel {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LvMullionLeg1 Property

[image]

Revit 2024 API
ParameterTypeId..::..LvMullionLeg1 Property
ParameterTypeId Class See Also Send Feedback
"Leg 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LvMullionLeg1 { get; }
Visual Basic
Public Shared ReadOnly Property LvMullionLeg1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LvMullionLeg1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


LvMullionLeg2 Property

[image]

Revit 2024 API
ParameterTypeId..::..LvMullionLeg2 Property
ParameterTypeId Class See Also Send Feedback
"Leg 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LvMullionLeg2 { get; }
Visual Basic
Public Shared ReadOnly Property LvMullionLeg2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LvMullionLeg2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MarkupsCreated Property

[image]

Revit 2024 API
ParameterTypeId..::..MarkupsCreated Property
ParameterTypeId Class See Also Send Feedback
"Created"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MarkupsCreated { get; }
Visual Basic
Public Shared ReadOnly Property MarkupsCreated As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MarkupsCreated {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MarkupsHistory Property

[image]

Revit 2024 API
ParameterTypeId..::..MarkupsHistory Property
ParameterTypeId Class See Also Send Feedback
"History"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MarkupsHistory { get; }
Visual Basic
Public Shared ReadOnly Property MarkupsHistory As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MarkupsHistory {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MarkupsLabel Property

[image]

Revit 2024 API
ParameterTypeId..::..MarkupsLabel Property
ParameterTypeId Class See Also Send Feedback
"Label"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MarkupsLabel { get; }
Visual Basic
Public Shared ReadOnly Property MarkupsLabel As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MarkupsLabel {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MarkupsModified Property

[image]

Revit 2024 API
ParameterTypeId..::..MarkupsModified Property
ParameterTypeId Class See Also Send Feedback
"Modified"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MarkupsModified { get; }
Visual Basic
Public Shared ReadOnly Property MarkupsModified As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MarkupsModified {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MarkupsPrivate Property

[image]

Revit 2024 API
ParameterTypeId..::..MarkupsPrivate Property
ParameterTypeId Class See Also Send Feedback
"Private"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MarkupsPrivate { get; }
Visual Basic
Public Shared ReadOnly Property MarkupsPrivate As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MarkupsPrivate {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MarkupsStatus Property

[image]

Revit 2024 API
ParameterTypeId..::..MarkupsStatus Property
ParameterTypeId Class See Also Send Feedback
"Status"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MarkupsStatus { get; }
Visual Basic
Public Shared ReadOnly Property MarkupsStatus As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MarkupsStatus {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MassDataConceptualConstruction Property

[image]

Revit 2024 API
ParameterTypeId..::..MassDataConceptualConstruction Property
ParameterTypeId Class See Also Send Feedback
"Conceptual Types"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MassDataConceptualConstruction { get; }
Visual Basic
Public Shared ReadOnly Property MassDataConceptualConstruction As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MassDataConceptualConstruction {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MassDataGlazingIsShaded Property

[image]

Revit 2024 API
ParameterTypeId..::..MassDataGlazingIsShaded Property
ParameterTypeId Class See Also Send Feedback
"Glazing is Shaded"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MassDataGlazingIsShaded { get; }
Visual Basic
Public Shared ReadOnly Property MassDataGlazingIsShaded As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MassDataGlazingIsShaded {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MassDataMassExteriorWallArea Property

[image]

Revit 2024 API
ParameterTypeId..::..MassDataMassExteriorWallArea Property
ParameterTypeId Class See Also Send Feedback
"Mass Exterior Wall Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MassDataMassExteriorWallArea { get; }
Visual Basic
Public Shared ReadOnly Property MassDataMassExteriorWallArea As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MassDataMassExteriorWallArea {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MassDataMassOpeningArea Property

[image]

Revit 2024 API
ParameterTypeId..::..MassDataMassOpeningArea Property
ParameterTypeId Class See Also Send Feedback
"Mass Opening Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MassDataMassOpeningArea { get; }
Visual Basic
Public Shared ReadOnly Property MassDataMassOpeningArea As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MassDataMassOpeningArea {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MassDataMassRoofArea Property

[image]

Revit 2024 API
ParameterTypeId..::..MassDataMassRoofArea Property
ParameterTypeId Class See Also Send Feedback
"Mass Roof Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MassDataMassRoofArea { get; }
Visual Basic
Public Shared ReadOnly Property MassDataMassRoofArea As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MassDataMassRoofArea {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MassDataMassSkylightArea Property

[image]

Revit 2024 API
ParameterTypeId..::..MassDataMassSkylightArea Property
ParameterTypeId Class See Also Send Feedback
"Mass Skylight Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MassDataMassSkylightArea { get; }
Visual Basic
Public Shared ReadOnly Property MassDataMassSkylightArea As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MassDataMassSkylightArea {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MassDataMassWindowArea Property

[image]

Revit 2024 API
ParameterTypeId..::..MassDataMassWindowArea Property
ParameterTypeId Class See Also Send Feedback
"Mass Window Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MassDataMassWindowArea { get; }
Visual Basic
Public Shared ReadOnly Property MassDataMassWindowArea As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MassDataMassWindowArea {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MassDataPercentageGlazing Property

[image]

Revit 2024 API
ParameterTypeId..::..MassDataPercentageGlazing Property
ParameterTypeId Class See Also Send Feedback
"Target Percentage Glazing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MassDataPercentageGlazing { get; }
Visual Basic
Public Shared ReadOnly Property MassDataPercentageGlazing As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MassDataPercentageGlazing {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MassDataPercentageSkylights Property

[image]

Revit 2024 API
ParameterTypeId..::..MassDataPercentageSkylights Property
ParameterTypeId Class See Also Send Feedback
"Target Percentage Skylights"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MassDataPercentageSkylights { get; }
Visual Basic
Public Shared ReadOnly Property MassDataPercentageSkylights As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MassDataPercentageSkylights {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MassDataShadeDepth Property

[image]

Revit 2024 API
ParameterTypeId..::..MassDataShadeDepth Property
ParameterTypeId Class See Also Send Feedback
"Shade Depth"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MassDataShadeDepth { get; }
Visual Basic
Public Shared ReadOnly Property MassDataShadeDepth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MassDataShadeDepth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MassDataSillHeight Property

[image]

Revit 2024 API
ParameterTypeId..::..MassDataSillHeight Property
ParameterTypeId Class See Also Send Feedback
"Target Sill Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MassDataSillHeight { get; }
Visual Basic
Public Shared ReadOnly Property MassDataSillHeight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MassDataSillHeight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MassDataSlab Property

[image]

Revit 2024 API
ParameterTypeId..::..MassDataSlab Property
ParameterTypeId Class See Also Send Feedback
"Slab"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MassDataSlab { get; }
Visual Basic
Public Shared ReadOnly Property MassDataSlab As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MassDataSlab {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MassDataSubcategory Property

[image]

Revit 2024 API
ParameterTypeId..::..MassDataSubcategory Property
ParameterTypeId Class See Also Send Feedback
"Subcategory"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MassDataSubcategory { get; }
Visual Basic
Public Shared ReadOnly Property MassDataSubcategory As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MassDataSubcategory {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MassDataSurfaceDataSource Property

[image]

Revit 2024 API
ParameterTypeId..::..MassDataSurfaceDataSource Property
ParameterTypeId Class See Also Send Feedback
"Values"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MassDataSurfaceDataSource { get; }
Visual Basic
Public Shared ReadOnly Property MassDataSurfaceDataSource As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MassDataSurfaceDataSource {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MassFloorAreaLevels Property

[image]

Revit 2024 API
ParameterTypeId..::..MassFloorAreaLevels Property
ParameterTypeId Class See Also Send Feedback
"Mass Floors"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MassFloorAreaLevels { get; }
Visual Basic
Public Shared ReadOnly Property MassFloorAreaLevels As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MassFloorAreaLevels {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MassGrossArea Property

[image]

Revit 2024 API
ParameterTypeId..::..MassGrossArea Property
ParameterTypeId Class See Also Send Feedback
"Gross Floor Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MassGrossArea { get; }
Visual Basic
Public Shared ReadOnly Property MassGrossArea As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MassGrossArea {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MassGrossVolume Property

[image]

Revit 2024 API
ParameterTypeId..::..MassGrossVolume Property
ParameterTypeId Class See Also Send Feedback
"Gross Volume"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MassGrossVolume { get; }
Visual Basic
Public Shared ReadOnly Property MassGrossVolume As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MassGrossVolume {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MassingIntegrationLevel Property

[image]

Revit 2024 API
ParameterTypeId..::..MassingIntegrationLevel Property
ParameterTypeId Class See Also Send Feedback
"Constrain to Massing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MassingIntegrationLevel { get; }
Visual Basic
Public Shared ReadOnly Property MassingIntegrationLevel As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MassingIntegrationLevel {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MassSurfacedataMaterial Property

[image]

Revit 2024 API
ParameterTypeId..::..MassSurfacedataMaterial Property
ParameterTypeId Class See Also Send Feedback
"Graphical Appearance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MassSurfacedataMaterial { get; }
Visual Basic
Public Shared ReadOnly Property MassSurfacedataMaterial As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MassSurfacedataMaterial {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MassZoneConditionTypeParam Property

[image]

Revit 2024 API
ParameterTypeId..::..MassZoneConditionTypeParam Property
ParameterTypeId Class See Also Send Feedback
"Condition Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MassZoneConditionTypeParam { get; }
Visual Basic
Public Shared ReadOnly Property MassZoneConditionTypeParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MassZoneConditionTypeParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MassZoneFloorArea Property

[image]

Revit 2024 API
ParameterTypeId..::..MassZoneFloorArea Property
ParameterTypeId Class See Also Send Feedback
"Mass Floor Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MassZoneFloorArea { get; }
Visual Basic
Public Shared ReadOnly Property MassZoneFloorArea As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MassZoneFloorArea {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MassZoneSpaceTypeParam Property

[image]

Revit 2024 API
ParameterTypeId..::..MassZoneSpaceTypeParam Property
ParameterTypeId Class See Also Send Feedback
"Space Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MassZoneSpaceTypeParam { get; }
Visual Basic
Public Shared ReadOnly Property MassZoneSpaceTypeParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MassZoneSpaceTypeParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MassZoneVolume Property

[image]

Revit 2024 API
ParameterTypeId..::..MassZoneVolume Property
ParameterTypeId Class See Also Send Feedback
"Mass Zone Volume"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MassZoneVolume { get; }
Visual Basic
Public Shared ReadOnly Property MassZoneVolume As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MassZoneVolume {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MatchlineBottomOffset Property

[image]

Revit 2024 API
ParameterTypeId..::..MatchlineBottomOffset Property
ParameterTypeId Class See Also Send Feedback
"Bottom Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MatchlineBottomOffset { get; }
Visual Basic
Public Shared ReadOnly Property MatchlineBottomOffset As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MatchlineBottomOffset {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MatchlineBottomPlane Property

[image]

Revit 2024 API
ParameterTypeId..::..MatchlineBottomPlane Property
ParameterTypeId Class See Also Send Feedback
"Bottom Constraint"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MatchlineBottomPlane { get; }
Visual Basic
Public Shared ReadOnly Property MatchlineBottomPlane As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MatchlineBottomPlane {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MatchlineTopPlane Property

[image]

Revit 2024 API
ParameterTypeId..::..MatchlineTopPlane Property
ParameterTypeId Class See Also Send Feedback
"Top Constraint"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MatchlineTopPlane { get; }
Visual Basic
Public Shared ReadOnly Property MatchlineTopPlane As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MatchlineTopPlane {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MaterialArea Property

[image]

Revit 2024 API
ParameterTypeId..::..MaterialArea Property
ParameterTypeId Class See Also Send Feedback
"Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MaterialArea { get; }
Visual Basic
Public Shared ReadOnly Property MaterialArea As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MaterialArea {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MaterialAspaint Property

[image]

Revit 2024 API
ParameterTypeId..::..MaterialAspaint Property
ParameterTypeId Class See Also Send Feedback
"As Paint"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MaterialAspaint { get; }
Visual Basic
Public Shared ReadOnly Property MaterialAspaint As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MaterialAspaint {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MaterialAssetParamExternalMaterialId Property

[image]

Revit 2024 API
ParameterTypeId..::..MaterialAssetParamExternalMaterialId Property
ParameterTypeId Class See Also Send Feedback
"External Material ID"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MaterialAssetParamExternalMaterialId { get; }
Visual Basic
Public Shared ReadOnly Property MaterialAssetParamExternalMaterialId As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MaterialAssetParamExternalMaterialId {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MaterialAssetParamSource Property

[image]

Revit 2024 API
ParameterTypeId..::..MaterialAssetParamSource Property
ParameterTypeId Class See Also Send Feedback
"Source"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MaterialAssetParamSource { get; }
Visual Basic
Public Shared ReadOnly Property MaterialAssetParamSource As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MaterialAssetParamSource {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MaterialIdParam Property

[image]

Revit 2024 API
ParameterTypeId..::..MaterialIdParam Property
ParameterTypeId Class See Also Send Feedback
"Material"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MaterialIdParam { get; }
Visual Basic
Public Shared ReadOnly Property MaterialIdParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MaterialIdParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MaterialName Property

[image]

Revit 2024 API
ParameterTypeId..::..MaterialName Property
ParameterTypeId Class See Also Send Feedback
"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MaterialName { get; }
Visual Basic
Public Shared ReadOnly Property MaterialName As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MaterialName {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MaterialParamColor Property

[image]

Revit 2024 API
ParameterTypeId..::..MaterialParamColor Property
ParameterTypeId Class See Also Send Feedback
"Color"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MaterialParamColor { get; }
Visual Basic
Public Shared ReadOnly Property MaterialParamColor As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MaterialParamColor {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MaterialParamShininess Property

[image]

Revit 2024 API
ParameterTypeId..::..MaterialParamShininess Property
ParameterTypeId Class See Also Send Feedback
"Shininess"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MaterialParamShininess { get; }
Visual Basic
Public Shared ReadOnly Property MaterialParamShininess As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MaterialParamShininess {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MaterialParamTransparency Property

[image]

Revit 2024 API
ParameterTypeId..::..MaterialParamTransparency Property
ParameterTypeId Class See Also Send Feedback
"Transparency"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MaterialParamTransparency { get; }
Visual Basic
Public Shared ReadOnly Property MaterialParamTransparency As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MaterialParamTransparency {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MaterialVolume Property

[image]

Revit 2024 API
ParameterTypeId..::..MaterialVolume Property
ParameterTypeId Class See Also Send Feedback
"Volume"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MaterialVolume { get; }
Visual Basic
Public Shared ReadOnly Property MaterialVolume As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MaterialVolume {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MeasureFromStructure Property

[image]

Revit 2024 API
ParameterTypeId..::..MeasureFromStructure Property
ParameterTypeId Class See Also Send Feedback
"Extend into wall (to core)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MeasureFromStructure { get; }
Visual Basic
Public Shared ReadOnly Property MeasureFromStructure As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MeasureFromStructure {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MechanicalEquipmentSetIdParam Property

[image]

Revit 2024 API
ParameterTypeId..::..MechanicalEquipmentSetIdParam Property
ParameterTypeId Class See Also Send Feedback
"Mechanical Equipment Set"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MechanicalEquipmentSetIdParam { get; }
Visual Basic
Public Shared ReadOnly Property MechanicalEquipmentSetIdParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MechanicalEquipmentSetIdParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MechanicalEquipmentSetName Property

[image]

Revit 2024 API
ParameterTypeId..::..MechanicalEquipmentSetName Property
ParameterTypeId Class See Also Send Feedback
"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MechanicalEquipmentSetName { get; }
Visual Basic
Public Shared ReadOnly Property MechanicalEquipmentSetName As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MechanicalEquipmentSetName {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MechanicalEquipmentSetOnDuty Property

[image]

Revit 2024 API
ParameterTypeId..::..MechanicalEquipmentSetOnDuty Property
ParameterTypeId Class See Also Send Feedback
"On Duty"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MechanicalEquipmentSetOnDuty { get; }
Visual Basic
Public Shared ReadOnly Property MechanicalEquipmentSetOnDuty As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MechanicalEquipmentSetOnDuty {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MechanicalEquipmentSetOnStandby Property

[image]

Revit 2024 API
ParameterTypeId..::..MechanicalEquipmentSetOnStandby Property
ParameterTypeId Class See Also Send Feedback
"On Standby"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MechanicalEquipmentSetOnStandby { get; }
Visual Basic
Public Shared ReadOnly Property MechanicalEquipmentSetOnStandby As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MechanicalEquipmentSetOnStandby {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MepAirloopFantype Property

[image]

Revit 2024 API
ParameterTypeId..::..MepAirloopFantype Property
ParameterTypeId Class See Also Send Feedback
"Fan"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MepAirloopFantype { get; }
Visual Basic
Public Shared ReadOnly Property MepAirloopFantype As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MepAirloopFantype {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MepAirloopHeatexchangerType Property

[image]

Revit 2024 API
ParameterTypeId..::..MepAirloopHeatexchangerType Property
ParameterTypeId Class See Also Send Feedback
"Heat Exchanger"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MepAirloopHeatexchangerType { get; }
Visual Basic
Public Shared ReadOnly Property MepAirloopHeatexchangerType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MepAirloopHeatexchangerType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MepAirloopPreheatCoiltype Property

[image]

Revit 2024 API
ParameterTypeId..::..MepAirloopPreheatCoiltype Property
ParameterTypeId Class See Also Send Feedback
"Preheat Coil"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MepAirloopPreheatCoiltype { get; }
Visual Basic
Public Shared ReadOnly Property MepAirloopPreheatCoiltype As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MepAirloopPreheatCoiltype {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MepAnalyticalElecCurrentRating Property

[image]

Revit 2024 API
ParameterTypeId..::..MepAnalyticalElecCurrentRating Property
ParameterTypeId Class See Also Send Feedback
"Current Rating"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MepAnalyticalElecCurrentRating { get; }
Visual Basic
Public Shared ReadOnly Property MepAnalyticalElecCurrentRating As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MepAnalyticalElecCurrentRating {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MepAnalyticalElecVoltage Property

[image]

Revit 2024 API
ParameterTypeId..::..MepAnalyticalElecVoltage Property
ParameterTypeId Class See Also Send Feedback
"Voltage"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MepAnalyticalElecVoltage { get; }
Visual Basic
Public Shared ReadOnly Property MepAnalyticalElecVoltage As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MepAnalyticalElecVoltage {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MepAnalyticalEquipmentName Property

[image]

Revit 2024 API
ParameterTypeId..::..MepAnalyticalEquipmentName Property
ParameterTypeId Class See Also Send Feedback
"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MepAnalyticalEquipmentName { get; }
Visual Basic
Public Shared ReadOnly Property MepAnalyticalEquipmentName As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MepAnalyticalEquipmentName {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MepAnalyticalLoopName Property

[image]

Revit 2024 API
ParameterTypeId..::..MepAnalyticalLoopName Property
ParameterTypeId Class See Also Send Feedback
"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MepAnalyticalLoopName { get; }
Visual Basic
Public Shared ReadOnly Property MepAnalyticalLoopName As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MepAnalyticalLoopName {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MepAnalyticalPipeDesignflow Property

[image]

Revit 2024 API
ParameterTypeId..::..MepAnalyticalPipeDesignflow Property
ParameterTypeId Class See Also Send Feedback
"Design Flow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MepAnalyticalPipeDesignflow { get; }
Visual Basic
Public Shared ReadOnly Property MepAnalyticalPipeDesignflow As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MepAnalyticalPipeDesignflow {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MepChilledWaterLoop Property

[image]

Revit 2024 API
ParameterTypeId..::..MepChilledWaterLoop Property
ParameterTypeId Class See Also Send Feedback
"Chilled Water Loop"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MepChilledWaterLoop { get; }
Visual Basic
Public Shared ReadOnly Property MepChilledWaterLoop As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MepChilledWaterLoop {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MepCondenserWaterLoop Property

[image]

Revit 2024 API
ParameterTypeId..::..MepCondenserWaterLoop Property
ParameterTypeId Class See Also Send Feedback
"Condenser Water Loop"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MepCondenserWaterLoop { get; }
Visual Basic
Public Shared ReadOnly Property MepCondenserWaterLoop As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MepCondenserWaterLoop {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MepCoolingCoilType Property

[image]

Revit 2024 API
ParameterTypeId..::..MepCoolingCoilType Property
ParameterTypeId Class See Also Send Feedback
"Cooling Coil"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MepCoolingCoilType { get; }
Visual Basic
Public Shared ReadOnly Property MepCoolingCoilType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MepCoolingCoilType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MepElecZoneEquipmentType Property

[image]

Revit 2024 API
ParameterTypeId..::..MepElecZoneEquipmentType Property
ParameterTypeId Class See Also Send Feedback
"Equipment Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MepElecZoneEquipmentType { get; }
Visual Basic
Public Shared ReadOnly Property MepElecZoneEquipmentType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MepElecZoneEquipmentType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MepEquipmentCalcPipingflowParam Property

[image]

Revit 2024 API
ParameterTypeId..::..MepEquipmentCalcPipingflowParam Property
ParameterTypeId Class See Also Send Feedback
"Calculated Flow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MepEquipmentCalcPipingflowParam { get; }
Visual Basic
Public Shared ReadOnly Property MepEquipmentCalcPipingflowParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MepEquipmentCalcPipingflowParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MepEquipmentCalcPipingpressuredropParam Property

[image]

Revit 2024 API
ParameterTypeId..::..MepEquipmentCalcPipingpressuredropParam Property
ParameterTypeId Class See Also Send Feedback
"Calculated Pressure Drop"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MepEquipmentCalcPipingpressuredropParam { get; }
Visual Basic
Public Shared ReadOnly Property MepEquipmentCalcPipingpressuredropParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MepEquipmentCalcPipingpressuredropParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MepEquipmentClassification Property

[image]

Revit 2024 API
ParameterTypeId..::..MepEquipmentClassification Property
ParameterTypeId Class See Also Send Feedback
"Classification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MepEquipmentClassification { get; }
Visual Basic
Public Shared ReadOnly Property MepEquipmentClassification As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MepEquipmentClassification {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MepHeatingCoilType Property

[image]

Revit 2024 API
ParameterTypeId..::..MepHeatingCoilType Property
ParameterTypeId Class See Also Send Feedback
"Heating Coil"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MepHeatingCoilType { get; }
Visual Basic
Public Shared ReadOnly Property MepHeatingCoilType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MepHeatingCoilType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MepHeatingHotwaterLoop Property

[image]

Revit 2024 API
ParameterTypeId..::..MepHeatingHotwaterLoop Property
ParameterTypeId Class See Also Send Feedback
"Heating Hot Water Loop"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MepHeatingHotwaterLoop { get; }
Visual Basic
Public Shared ReadOnly Property MepHeatingHotwaterLoop As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MepHeatingHotwaterLoop {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MepIgnoreFlowAnalysis Property

[image]

Revit 2024 API
ParameterTypeId..::..MepIgnoreFlowAnalysis Property
ParameterTypeId Class See Also Send Feedback
"Ignore Flow Analysis"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MepIgnoreFlowAnalysis { get; }
Visual Basic
Public Shared ReadOnly Property MepIgnoreFlowAnalysis As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MepIgnoreFlowAnalysis {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MepLowerBottomElevation Property

[image]

Revit 2024 API
ParameterTypeId..::..MepLowerBottomElevation Property
ParameterTypeId Class See Also Send Feedback
"Lower End Bottom Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MepLowerBottomElevation { get; }
Visual Basic
Public Shared ReadOnly Property MepLowerBottomElevation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MepLowerBottomElevation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MepLowerBottomElevationIncludeInsulation Property

[image]

Revit 2024 API
ParameterTypeId..::..MepLowerBottomElevationIncludeInsulation Property
ParameterTypeId Class See Also Send Feedback
"Lower End Bottom of Insulation Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MepLowerBottomElevationIncludeInsulation { get; }
Visual Basic
Public Shared ReadOnly Property MepLowerBottomElevationIncludeInsulation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MepLowerBottomElevationIncludeInsulation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MepLowerTopElevation Property

[image]

Revit 2024 API
ParameterTypeId..::..MepLowerTopElevation Property
ParameterTypeId Class See Also Send Feedback
"Lower End Top Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MepLowerTopElevation { get; }
Visual Basic
Public Shared ReadOnly Property MepLowerTopElevation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MepLowerTopElevation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MepLowerTopElevationIncludeInsulation Property

[image]

Revit 2024 API
ParameterTypeId..::..MepLowerTopElevationIncludeInsulation Property
ParameterTypeId Class See Also Send Feedback
"Lower End Top of Insulation Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MepLowerTopElevationIncludeInsulation { get; }
Visual Basic
Public Shared ReadOnly Property MepLowerTopElevationIncludeInsulation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MepLowerTopElevationIncludeInsulation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MepPipeUpperInvertElevation Property

[image]

Revit 2024 API
ParameterTypeId..::..MepPipeUpperInvertElevation Property
ParameterTypeId Class See Also Send Feedback
"Upper End Invert Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MepPipeUpperInvertElevation { get; }
Visual Basic
Public Shared ReadOnly Property MepPipeUpperInvertElevation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MepPipeUpperInvertElevation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MepPipeUpperObvertElevation Property

[image]

Revit 2024 API
ParameterTypeId..::..MepPipeUpperObvertElevation Property
ParameterTypeId Class See Also Send Feedback
"Upper End Obvert Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MepPipeUpperObvertElevation { get; }
Visual Basic
Public Shared ReadOnly Property MepPipeUpperObvertElevation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MepPipeUpperObvertElevation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MepPreheatHotwaterLoop Property

[image]

Revit 2024 API
ParameterTypeId..::..MepPreheatHotwaterLoop Property
ParameterTypeId Class See Also Send Feedback
"Preheat Hot Water Loop"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MepPreheatHotwaterLoop { get; }
Visual Basic
Public Shared ReadOnly Property MepPreheatHotwaterLoop As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MepPreheatHotwaterLoop {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MepProfileTypeParam Property

[image]

Revit 2024 API
ParameterTypeId..::..MepProfileTypeParam Property
ParameterTypeId Class See Also Send Feedback
"Shape"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MepProfileTypeParam { get; }
Visual Basic
Public Shared ReadOnly Property MepProfileTypeParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MepProfileTypeParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MepReheatCoilType Property

[image]

Revit 2024 API
ParameterTypeId..::..MepReheatCoilType Property
ParameterTypeId Class See Also Send Feedback
"Reheat Coil"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MepReheatCoilType { get; }
Visual Basic
Public Shared ReadOnly Property MepReheatCoilType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MepReheatCoilType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MepReheatHotwaterLoop Property

[image]

Revit 2024 API
ParameterTypeId..::..MepReheatHotwaterLoop Property
ParameterTypeId Class See Also Send Feedback
"Reheat Hot Water Loop"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MepReheatHotwaterLoop { get; }
Visual Basic
Public Shared ReadOnly Property MepReheatHotwaterLoop As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MepReheatHotwaterLoop {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MepSpotBottomElevation Property

[image]

Revit 2024 API
ParameterTypeId..::..MepSpotBottomElevation Property
ParameterTypeId Class See Also Send Feedback
"Spot Bottom Elevation": used for both design and fabrication components

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MepSpotBottomElevation { get; }
Visual Basic
Public Shared ReadOnly Property MepSpotBottomElevation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MepSpotBottomElevation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MepSpotBottomElevationIncludeInsulation Property

[image]

Revit 2024 API
ParameterTypeId..::..MepSpotBottomElevationIncludeInsulation Property
ParameterTypeId Class See Also Send Feedback
"Spot Bottom of Insulation Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MepSpotBottomElevationIncludeInsulation { get; }
Visual Basic
Public Shared ReadOnly Property MepSpotBottomElevationIncludeInsulation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MepSpotBottomElevationIncludeInsulation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MepSpotTopElevation Property

[image]

Revit 2024 API
ParameterTypeId..::..MepSpotTopElevation Property
ParameterTypeId Class See Also Send Feedback
"Spot Top Elevation": used for both design and fabrication components

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MepSpotTopElevation { get; }
Visual Basic
Public Shared ReadOnly Property MepSpotTopElevation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MepSpotTopElevation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MepSpotTopElevationIncludeInsulation Property

[image]

Revit 2024 API
ParameterTypeId..::..MepSpotTopElevationIncludeInsulation Property
ParameterTypeId Class See Also Send Feedback
"Spot Top of Insulation Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MepSpotTopElevationIncludeInsulation { get; }
Visual Basic
Public Shared ReadOnly Property MepSpotTopElevationIncludeInsulation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MepSpotTopElevationIncludeInsulation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MepSystemFillGraphicsOverridesParam Property

[image]

Revit 2024 API
ParameterTypeId..::..MepSystemFillGraphicsOverridesParam Property
ParameterTypeId Class See Also Send Feedback
"Fill Pattern Graphics Overrides"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MepSystemFillGraphicsOverridesParam { get; }
Visual Basic
Public Shared ReadOnly Property MepSystemFillGraphicsOverridesParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MepSystemFillGraphicsOverridesParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MepSystemLineGraphicsOverridesParam Property

[image]

Revit 2024 API
ParameterTypeId..::..MepSystemLineGraphicsOverridesParam Property
ParameterTypeId Class See Also Send Feedback
"Graphic Overrides"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MepSystemLineGraphicsOverridesParam { get; }
Visual Basic
Public Shared ReadOnly Property MepSystemLineGraphicsOverridesParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MepSystemLineGraphicsOverridesParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MepUpperBottomElevation Property

[image]

Revit 2024 API
ParameterTypeId..::..MepUpperBottomElevation Property
ParameterTypeId Class See Also Send Feedback
"Upper End Bottom Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MepUpperBottomElevation { get; }
Visual Basic
Public Shared ReadOnly Property MepUpperBottomElevation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MepUpperBottomElevation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MepUpperBottomElevationIncludeInsulation Property

[image]

Revit 2024 API
ParameterTypeId..::..MepUpperBottomElevationIncludeInsulation Property
ParameterTypeId Class See Also Send Feedback
"Upper End Bottom of Insulation Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MepUpperBottomElevationIncludeInsulation { get; }
Visual Basic
Public Shared ReadOnly Property MepUpperBottomElevationIncludeInsulation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MepUpperBottomElevationIncludeInsulation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MepUpperCenterlineElevation Property

[image]

Revit 2024 API
ParameterTypeId..::..MepUpperCenterlineElevation Property
ParameterTypeId Class See Also Send Feedback
"Upper End Centerline Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MepUpperCenterlineElevation { get; }
Visual Basic
Public Shared ReadOnly Property MepUpperCenterlineElevation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MepUpperCenterlineElevation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MepUpperTopElevation Property

[image]

Revit 2024 API
ParameterTypeId..::..MepUpperTopElevation Property
ParameterTypeId Class See Also Send Feedback
"Upper End Top Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MepUpperTopElevation { get; }
Visual Basic
Public Shared ReadOnly Property MepUpperTopElevation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MepUpperTopElevation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MepUpperTopElevationIncludeInsulation Property

[image]

Revit 2024 API
ParameterTypeId..::..MepUpperTopElevationIncludeInsulation Property
ParameterTypeId Class See Also Send Feedback
"Upper End Top of Insulation Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MepUpperTopElevationIncludeInsulation { get; }
Visual Basic
Public Shared ReadOnly Property MepUpperTopElevationIncludeInsulation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MepUpperTopElevationIncludeInsulation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MepVrfLoop Property

[image]

Revit 2024 API
ParameterTypeId..::..MepVrfLoop Property
ParameterTypeId Class See Also Send Feedback
"Variable Refrigerant Flow Loop"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MepVrfLoop { get; }
Visual Basic
Public Shared ReadOnly Property MepVrfLoop As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MepVrfLoop {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MepWaterloopType Property

[image]

Revit 2024 API
ParameterTypeId..::..MepWaterloopType Property
ParameterTypeId Class See Also Send Feedback
"Loop Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MepWaterloopType { get; }
Visual Basic
Public Shared ReadOnly Property MepWaterloopType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MepWaterloopType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MepZoneEquipment Property

[image]

Revit 2024 API
ParameterTypeId..::..MepZoneEquipment Property
ParameterTypeId Class See Also Send Feedback
"Zone Equipment"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MepZoneEquipment { get; }
Visual Basic
Public Shared ReadOnly Property MepZoneEquipment As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MepZoneEquipment {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MepZoneEquipmentDrawVentilation Property

[image]

Revit 2024 API
ParameterTypeId..::..MepZoneEquipmentDrawVentilation Property
ParameterTypeId Class See Also Send Feedback
"Draw Ventilation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MepZoneEquipmentDrawVentilation { get; }
Visual Basic
Public Shared ReadOnly Property MepZoneEquipmentDrawVentilation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MepZoneEquipmentDrawVentilation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MepZoneEquipmentType Property

[image]

Revit 2024 API
ParameterTypeId..::..MepZoneEquipmentType Property
ParameterTypeId Class See Also Send Feedback
"Equipment Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MepZoneEquipmentType { get; }
Visual Basic
Public Shared ReadOnly Property MepZoneEquipmentType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MepZoneEquipmentType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MepZoneHotwaterLoop Property

[image]

Revit 2024 API
ParameterTypeId..::..MepZoneHotwaterLoop Property
ParameterTypeId Class See Also Send Feedback
"Heating Hot Water Loop"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MepZoneHotwaterLoop { get; }
Visual Basic
Public Shared ReadOnly Property MepZoneHotwaterLoop As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MepZoneHotwaterLoop {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ModelCategoryIdParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ModelCategoryIdParam Property
ParameterTypeId Class See Also Send Feedback
"Subcategory"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ModelCategoryIdParam { get; }
Visual Basic
Public Shared ReadOnly Property ModelCategoryIdParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ModelCategoryIdParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ModelGraphicsStyle Property

[image]

Revit 2024 API
ParameterTypeId..::..ModelGraphicsStyle Property
ParameterTypeId Class See Also Send Feedback
"Visual Style"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ModelGraphicsStyle { get; }
Visual Basic
Public Shared ReadOnly Property ModelGraphicsStyle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ModelGraphicsStyle {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ModelOrSymbolic Property

[image]

Revit 2024 API
ParameterTypeId..::..ModelOrSymbolic Property
ParameterTypeId Class See Also Send Feedback
"Model or Symbolic"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ModelOrSymbolic { get; }
Visual Basic
Public Shared ReadOnly Property ModelOrSymbolic As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ModelOrSymbolic {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ModelTextSize Property

[image]

Revit 2024 API
ParameterTypeId..::..ModelTextSize Property
ParameterTypeId Class See Also Send Feedback
"Text Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ModelTextSize { get; }
Visual Basic
Public Shared ReadOnly Property ModelTextSize As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ModelTextSize {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MovesWithGridParam Property

[image]

Revit 2024 API
ParameterTypeId..::..MovesWithGridParam Property
ParameterTypeId Class See Also Send Feedback
"Moves With Grids": Disable attachment from grids.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MovesWithGridParam { get; }
Visual Basic
Public Shared ReadOnly Property MovesWithGridParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MovesWithGridParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MullionAngle Property

[image]

Revit 2024 API
ParameterTypeId..::..MullionAngle Property
ParameterTypeId Class See Also Send Feedback
"Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MullionAngle { get; }
Visual Basic
Public Shared ReadOnly Property MullionAngle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MullionAngle {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MullionCornerType Property

[image]

Revit 2024 API
ParameterTypeId..::..MullionCornerType Property
ParameterTypeId Class See Also Send Feedback
"Corner Mullion"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MullionCornerType { get; }
Visual Basic
Public Shared ReadOnly Property MullionCornerType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MullionCornerType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MullionDepth Property

[image]

Revit 2024 API
ParameterTypeId..::..MullionDepth Property
ParameterTypeId Class See Also Send Feedback
"Depth"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MullionDepth { get; }
Visual Basic
Public Shared ReadOnly Property MullionDepth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MullionDepth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MullionDepth1 Property

[image]

Revit 2024 API
ParameterTypeId..::..MullionDepth1 Property
ParameterTypeId Class See Also Send Feedback
"Depth 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MullionDepth1 { get; }
Visual Basic
Public Shared ReadOnly Property MullionDepth1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MullionDepth1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MullionDepth2 Property

[image]

Revit 2024 API
ParameterTypeId..::..MullionDepth2 Property
ParameterTypeId Class See Also Send Feedback
"Depth 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MullionDepth2 { get; }
Visual Basic
Public Shared ReadOnly Property MullionDepth2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MullionDepth2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MullionFamType Property

[image]

Revit 2024 API
ParameterTypeId..::..MullionFamType Property
ParameterTypeId Class See Also Send Feedback
"Mullion Family General Shape"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MullionFamType { get; }
Visual Basic
Public Shared ReadOnly Property MullionFamType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MullionFamType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MullionOffset Property

[image]

Revit 2024 API
ParameterTypeId..::..MullionOffset Property
ParameterTypeId Class See Also Send Feedback
"Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MullionOffset { get; }
Visual Basic
Public Shared ReadOnly Property MullionOffset As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MullionOffset {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MullionPosition Property

[image]

Revit 2024 API
ParameterTypeId..::..MullionPosition Property
ParameterTypeId Class See Also Send Feedback
"Position"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MullionPosition { get; }
Visual Basic
Public Shared ReadOnly Property MullionPosition As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MullionPosition {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MullionProfile Property

[image]

Revit 2024 API
ParameterTypeId..::..MullionProfile Property
ParameterTypeId Class See Also Send Feedback
"Profile"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MullionProfile { get; }
Visual Basic
Public Shared ReadOnly Property MullionProfile As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MullionProfile {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MultipleAlignmentUiToggle Property

[image]

Revit 2024 API
ParameterTypeId..::..MultipleAlignmentUiToggle Property
ParameterTypeId Class See Also Send Feedback
"Multiple Alignment": This is used by the UI to allow selection of multiple elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MultipleAlignmentUiToggle { get; }
Visual Basic
Public Shared ReadOnly Property MultipleAlignmentUiToggle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MultipleAlignmentUiToggle {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MultiReferenceAnnotationDimensionStyle Property

[image]

Revit 2024 API
ParameterTypeId..::..MultiReferenceAnnotationDimensionStyle Property
ParameterTypeId Class See Also Send Feedback
"Dimension Style"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MultiReferenceAnnotationDimensionStyle { get; }
Visual Basic
Public Shared ReadOnly Property MultiReferenceAnnotationDimensionStyle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MultiReferenceAnnotationDimensionStyle {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MultiReferenceAnnotationGroupTagHeads Property

[image]

Revit 2024 API
ParameterTypeId..::..MultiReferenceAnnotationGroupTagHeads Property
ParameterTypeId Class See Also Send Feedback
"Group Matching Tag Heads"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MultiReferenceAnnotationGroupTagHeads { get; }
Visual Basic
Public Shared ReadOnly Property MultiReferenceAnnotationGroupTagHeads As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MultiReferenceAnnotationGroupTagHeads {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MultiReferenceAnnotationShowDimensionText Property

[image]

Revit 2024 API
ParameterTypeId..::..MultiReferenceAnnotationShowDimensionText Property
ParameterTypeId Class See Also Send Feedback
"Show Dimension Text"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MultiReferenceAnnotationShowDimensionText { get; }
Visual Basic
Public Shared ReadOnly Property MultiReferenceAnnotationShowDimensionText As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MultiReferenceAnnotationShowDimensionText {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MultistoryStairsActualTreadDepth Property

[image]

Revit 2024 API
ParameterTypeId..::..MultistoryStairsActualTreadDepth Property
ParameterTypeId Class See Also Send Feedback
"Actual Tread Depth"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MultistoryStairsActualTreadDepth { get; }
Visual Basic
Public Shared ReadOnly Property MultistoryStairsActualTreadDepth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MultistoryStairsActualTreadDepth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


MultistoryStairsRefLevel Property

[image]

Revit 2024 API
ParameterTypeId..::..MultistoryStairsRefLevel Property
ParameterTypeId Class See Also Send Feedback
"Reference Level": The reference level of stairs

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MultistoryStairsRefLevel { get; }
Visual Basic
Public Shared ReadOnly Property MultistoryStairsRefLevel As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MultistoryStairsRefLevel {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


NodeConnectionStatus Property

[image]

Revit 2024 API
ParameterTypeId..::..NodeConnectionStatus Property
ParameterTypeId Class See Also Send Feedback
"Connection Status"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId NodeConnectionStatus { get; }
Visual Basic
Public Shared ReadOnly Property NodeConnectionStatus As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ NodeConnectionStatus {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


NumberPartitionParam Property

[image]

Revit 2024 API
ParameterTypeId..::..NumberPartitionParam Property
ParameterTypeId Class See Also Send Feedback
"Partition"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId NumberPartitionParam { get; }
Visual Basic
Public Shared ReadOnly Property NumberPartitionParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ NumberPartitionParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


NumberSystemJustify Property

[image]

Revit 2024 API
ParameterTypeId..::..NumberSystemJustify Property
ParameterTypeId Class See Also Send Feedback
"Justify"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId NumberSystemJustify { get; }
Visual Basic
Public Shared ReadOnly Property NumberSystemJustify As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ NumberSystemJustify {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


NumberSystemJustifyOffset Property

[image]

Revit 2024 API
ParameterTypeId..::..NumberSystemJustifyOffset Property
ParameterTypeId Class See Also Send Feedback
"Justify Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId NumberSystemJustifyOffset { get; }
Visual Basic
Public Shared ReadOnly Property NumberSystemJustifyOffset As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ NumberSystemJustifyOffset {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


NumberSystemReferenceOffset Property

[image]

Revit 2024 API
ParameterTypeId..::..NumberSystemReferenceOffset Property
ParameterTypeId Class See Also Send Feedback
"Offset from Reference"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId NumberSystemReferenceOffset { get; }
Visual Basic
Public Shared ReadOnly Property NumberSystemReferenceOffset As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ NumberSystemReferenceOffset {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


NumberSystemTagType Property

[image]

Revit 2024 API
ParameterTypeId..::..NumberSystemTagType Property
ParameterTypeId Class See Also Send Feedback
"Tag Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId NumberSystemTagType { get; }
Visual Basic
Public Shared ReadOnly Property NumberSystemTagType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ NumberSystemTagType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ObjectStyleMaterialIdParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ObjectStyleMaterialIdParam Property
ParameterTypeId Class See Also Send Feedback
"Object Style Material"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ObjectStyleMaterialIdParam { get; }
Visual Basic
Public Shared ReadOnly Property ObjectStyleMaterialIdParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ObjectStyleMaterialIdParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


OffsetfacesShowShapeHandles Property

[image]

Revit 2024 API
ParameterTypeId..::..OffsetfacesShowShapeHandles Property
ParameterTypeId Class See Also Send Feedback
"Show Shape Handles"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId OffsetfacesShowShapeHandles { get; }
Visual Basic
Public Shared ReadOnly Property OffsetfacesShowShapeHandles As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ OffsetfacesShowShapeHandles {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


OffsetFromReferenceBase Property

[image]

Revit 2024 API
ParameterTypeId..::..OffsetFromReferenceBase Property
ParameterTypeId Class See Also Send Feedback
"Offset from Reference Base"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId OffsetFromReferenceBase { get; }
Visual Basic
Public Shared ReadOnly Property OffsetFromReferenceBase As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ OffsetFromReferenceBase {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


OmniclassCode Property

[image]

Revit 2024 API
ParameterTypeId..::..OmniclassCode Property
ParameterTypeId Class See Also Send Feedback
"OmniClass Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId OmniclassCode { get; }
Visual Basic
Public Shared ReadOnly Property OmniclassCode As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ OmniclassCode {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


OmniclassDescription Property

[image]

Revit 2024 API
ParameterTypeId..::..OmniclassDescription Property
ParameterTypeId Class See Also Send Feedback
"OmniClass Title"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId OmniclassDescription { get; }
Visual Basic
Public Shared ReadOnly Property OmniclassDescription As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ OmniclassDescription {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


OptionName Property

[image]

Revit 2024 API
ParameterTypeId..::..OptionName Property
ParameterTypeId Class See Also Send Feedback
"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId OptionName { get; }
Visual Basic
Public Shared ReadOnly Property OptionName As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ OptionName {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


OptionSetId Property

[image]

Revit 2024 API
ParameterTypeId..::..OptionSetId Property
ParameterTypeId Class See Also Send Feedback
"Design Option Set Id"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId OptionSetId { get; }
Visual Basic
Public Shared ReadOnly Property OptionSetId As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ OptionSetId {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


OptionSetName Property

[image]

Revit 2024 API
ParameterTypeId..::..OptionSetName Property
ParameterTypeId Class See Also Send Feedback
"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId OptionSetName { get; }
Visual Basic
Public Shared ReadOnly Property OptionSetName As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ OptionSetName {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


OrdinateDimSetting Property

[image]

Revit 2024 API
ParameterTypeId..::..OrdinateDimSetting Property
ParameterTypeId Class See Also Send Feedback
"Ordinate Dimension Settings"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId OrdinateDimSetting { get; }
Visual Basic
Public Shared ReadOnly Property OrdinateDimSetting As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ OrdinateDimSetting {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


OrientByView Property

[image]

Revit 2024 API
ParameterTypeId..::..OrientByView Property
ParameterTypeId Class See Also Send Feedback
"Rotate With Text"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId OrientByView { get; }
Visual Basic
Public Shared ReadOnly Property OrientByView As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ OrientByView {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


OriginatingElementName Property

[image]

Revit 2024 API
ParameterTypeId..::..OriginatingElementName Property
ParameterTypeId Class See Also Send Feedback
"Originating Element"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId OriginatingElementName { get; }
Visual Basic
Public Shared ReadOnly Property OriginatingElementName As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ OriginatingElementName {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


OvalFramingHeight Property

[image]

Revit 2024 API
ParameterTypeId..::..OvalFramingHeight Property
ParameterTypeId Class See Also Send Feedback
"Oval Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId OvalFramingHeight { get; }
Visual Basic
Public Shared ReadOnly Property OvalFramingHeight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ OvalFramingHeight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


OvalFramingWidth Property

[image]

Revit 2024 API
ParameterTypeId..::..OvalFramingWidth Property
ParameterTypeId Class See Also Send Feedback
"Oval Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId OvalFramingWidth { get; }
Visual Basic
Public Shared ReadOnly Property OvalFramingWidth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ OvalFramingWidth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PaddingLength Property

[image]

Revit 2024 API
ParameterTypeId..::..PaddingLength Property
ParameterTypeId Class See Also Send Feedback
"Padding"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PaddingLength { get; }
Visual Basic
Public Shared ReadOnly Property PaddingLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PaddingLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PanelScheduleName Property

[image]

Revit 2024 API
ParameterTypeId..::..PanelScheduleName Property
ParameterTypeId Class See Also Send Feedback
"Panel Schedule Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PanelScheduleName { get; }
Visual Basic
Public Shared ReadOnly Property PanelScheduleName As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PanelScheduleName {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PartMakerDivisionProfileOffset Property

[image]

Revit 2024 API
ParameterTypeId..::..PartMakerDivisionProfileOffset Property
ParameterTypeId Class See Also Send Feedback
"Profile Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PartMakerDivisionProfileOffset { get; }
Visual Basic
Public Shared ReadOnly Property PartMakerDivisionProfileOffset As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PartMakerDivisionProfileOffset {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PartMakerSplitterProfile Property

[image]

Revit 2024 API
ParameterTypeId..::..PartMakerSplitterProfile Property
ParameterTypeId Class See Also Send Feedback
"Division Profile"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PartMakerSplitterProfile { get; }
Visual Basic
Public Shared ReadOnly Property PartMakerSplitterProfile As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PartMakerSplitterProfile {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PartMakerSplitterProfileEdgeMatch Property

[image]

Revit 2024 API
ParameterTypeId..::..PartMakerSplitterProfileEdgeMatch Property
ParameterTypeId Class See Also Send Feedback
"Edge Match"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PartMakerSplitterProfileEdgeMatch { get; }
Visual Basic
Public Shared ReadOnly Property PartMakerSplitterProfileEdgeMatch As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PartMakerSplitterProfileEdgeMatch {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PartMakerSplitterProfileFlipAcross Property

[image]

Revit 2024 API
ParameterTypeId..::..PartMakerSplitterProfileFlipAcross Property
ParameterTypeId Class See Also Send Feedback
"Profile Across Flip"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PartMakerSplitterProfileFlipAcross { get; }
Visual Basic
Public Shared ReadOnly Property PartMakerSplitterProfileFlipAcross As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PartMakerSplitterProfileFlipAcross {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PartMakerSplitterProfileFlipAlong Property

[image]

Revit 2024 API
ParameterTypeId..::..PartMakerSplitterProfileFlipAlong Property
ParameterTypeId Class See Also Send Feedback
"Profile Along Flip"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PartMakerSplitterProfileFlipAlong { get; }
Visual Basic
Public Shared ReadOnly Property PartMakerSplitterProfileFlipAlong As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PartMakerSplitterProfileFlipAlong {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PathOfTravelLevelName Property

[image]

Revit 2024 API
ParameterTypeId..::..PathOfTravelLevelName Property
ParameterTypeId Class See Also Send Feedback
"Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PathOfTravelLevelName { get; }
Visual Basic
Public Shared ReadOnly Property PathOfTravelLevelName As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PathOfTravelLevelName {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PathOfTravelTime Property

[image]

Revit 2024 API
ParameterTypeId..::..PathOfTravelTime Property
ParameterTypeId Class See Also Send Feedback
"Time"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PathOfTravelTime { get; }
Visual Basic
Public Shared ReadOnly Property PathOfTravelTime As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PathOfTravelTime {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PathOfTravelToRoom Property

[image]

Revit 2024 API
ParameterTypeId..::..PathOfTravelToRoom Property
ParameterTypeId Class See Also Send Feedback
"To Room"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PathOfTravelToRoom { get; }
Visual Basic
Public Shared ReadOnly Property PathOfTravelToRoom As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PathOfTravelToRoom {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PathOfTravelViewName Property

[image]

Revit 2024 API
ParameterTypeId..::..PathOfTravelViewName Property
ParameterTypeId Class See Also Send Feedback
"View Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PathOfTravelViewName { get; }
Visual Basic
Public Shared ReadOnly Property PathOfTravelViewName As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PathOfTravelViewName {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PathReinAddlOffset Property

[image]

Revit 2024 API
ParameterTypeId..::..PathReinAddlOffset Property
ParameterTypeId Class See Also Send Feedback
"Additional Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PathReinAddlOffset { get; }
Visual Basic
Public Shared ReadOnly Property PathReinAddlOffset As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PathReinAddlOffset {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PathReinAlternating Property

[image]

Revit 2024 API
ParameterTypeId..::..PathReinAlternating Property
ParameterTypeId Class See Also Send Feedback
"Alternating Bars"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PathReinAlternating { get; }
Visual Basic
Public Shared ReadOnly Property PathReinAlternating As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PathReinAlternating {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PathReinAltOffset Property

[image]

Revit 2024 API
ParameterTypeId..::..PathReinAltOffset Property
ParameterTypeId Class See Also Send Feedback
"Alternating Bar - Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PathReinAltOffset { get; }
Visual Basic
Public Shared ReadOnly Property PathReinAltOffset As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PathReinAltOffset {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PathReinEndHookOrient1Slab Property

[image]

Revit 2024 API
ParameterTypeId..::..PathReinEndHookOrient1Slab Property
ParameterTypeId Class See Also Send Feedback
"Primary Bar - End Hook Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PathReinEndHookOrient1Slab { get; }
Visual Basic
Public Shared ReadOnly Property PathReinEndHookOrient1Slab As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PathReinEndHookOrient1Slab {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PathReinEndHookOrient2Slab Property

[image]

Revit 2024 API
ParameterTypeId..::..PathReinEndHookOrient2Slab Property
ParameterTypeId Class See Also Send Feedback
"Alternating Bar - End Hook Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PathReinEndHookOrient2Slab { get; }
Visual Basic
Public Shared ReadOnly Property PathReinEndHookOrient2Slab As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PathReinEndHookOrient2Slab {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PathReinEndHookOrient2Wall Property

[image]

Revit 2024 API
ParameterTypeId..::..PathReinEndHookOrient2Wall Property
ParameterTypeId Class See Also Send Feedback
"Alternating Bar - End Hook Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PathReinEndHookOrient2Wall { get; }
Visual Basic
Public Shared ReadOnly Property PathReinEndHookOrient2Wall As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PathReinEndHookOrient2Wall {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PathReinEndHookTypen2 Property

[image]

Revit 2024 API
ParameterTypeId..::..PathReinEndHookTypen2 Property
ParameterTypeId Class See Also Send Feedback
"Alternating Bar - End Hook Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PathReinEndHookTypen2 { get; }
Visual Basic
Public Shared ReadOnly Property PathReinEndHookTypen2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PathReinEndHookTypen2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PathReinEndSpanhookAlt Property

[image]

Revit 2024 API
ParameterTypeId..::..PathReinEndSpanhookAlt Property
ParameterTypeId Class See Also Send Feedback
"End Hook Angle Alternating"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PathReinEndSpanhookAlt { get; }
Visual Basic
Public Shared ReadOnly Property PathReinEndSpanhookAlt As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PathReinEndSpanhookAlt {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PathReinEndSpanhookPrim Property

[image]

Revit 2024 API
ParameterTypeId..::..PathReinEndSpanhookPrim Property
ParameterTypeId Class See Also Send Feedback
"End Hook Angle Primary"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PathReinEndSpanhookPrim { get; }
Visual Basic
Public Shared ReadOnly Property PathReinEndSpanhookPrim As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PathReinEndSpanhookPrim {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PathReinFaceSlab Property

[image]

Revit 2024 API
ParameterTypeId..::..PathReinFaceSlab Property
ParameterTypeId Class See Also Send Feedback
"Face"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PathReinFaceSlab { get; }
Visual Basic
Public Shared ReadOnly Property PathReinFaceSlab As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PathReinFaceSlab {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PathReinFaceWall Property

[image]

Revit 2024 API
ParameterTypeId..::..PathReinFaceWall Property
ParameterTypeId Class See Also Send Feedback
"Face"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PathReinFaceWall { get; }
Visual Basic
Public Shared ReadOnly Property PathReinFaceWall As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PathReinFaceWall {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PathReinHookOrient1Slab Property

[image]

Revit 2024 API
ParameterTypeId..::..PathReinHookOrient1Slab Property
ParameterTypeId Class See Also Send Feedback
"Primary Bar - Hook Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PathReinHookOrient1Slab { get; }
Visual Basic
Public Shared ReadOnly Property PathReinHookOrient1Slab As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PathReinHookOrient1Slab {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PathReinHookOrient1Wall Property

[image]

Revit 2024 API
ParameterTypeId..::..PathReinHookOrient1Wall Property
ParameterTypeId Class See Also Send Feedback
"Primary Bar - Hook Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PathReinHookOrient1Wall { get; }
Visual Basic
Public Shared ReadOnly Property PathReinHookOrient1Wall As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PathReinHookOrient1Wall {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PathReinHookOrient2Slab Property

[image]

Revit 2024 API
ParameterTypeId..::..PathReinHookOrient2Slab Property
ParameterTypeId Class See Also Send Feedback
"Alternating Bar - Hook Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PathReinHookOrient2Slab { get; }
Visual Basic
Public Shared ReadOnly Property PathReinHookOrient2Slab As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PathReinHookOrient2Slab {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PathReinHookOrient2Wall Property

[image]

Revit 2024 API
ParameterTypeId..::..PathReinHookOrient2Wall Property
ParameterTypeId Class See Also Send Feedback
"Alternating Bar - Hook Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PathReinHookOrient2Wall { get; }
Visual Basic
Public Shared ReadOnly Property PathReinHookOrient2Wall As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PathReinHookOrient2Wall {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PathReinHookTypen1 Property

[image]

Revit 2024 API
ParameterTypeId..::..PathReinHookTypen1 Property
ParameterTypeId Class See Also Send Feedback
"Primary Bar - Start Hook Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PathReinHookTypen1 { get; }
Visual Basic
Public Shared ReadOnly Property PathReinHookTypen1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PathReinHookTypen1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PathReinHookTypen2 Property

[image]

Revit 2024 API
ParameterTypeId..::..PathReinHookTypen2 Property
ParameterTypeId Class See Also Send Feedback
"Alternating Bar - Start Hook Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PathReinHookTypen2 { get; }
Visual Basic
Public Shared ReadOnly Property PathReinHookTypen2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PathReinHookTypen2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PathReinLengthn1 Property

[image]

Revit 2024 API
ParameterTypeId..::..PathReinLengthn1 Property
ParameterTypeId Class See Also Send Feedback
"Primary Bar - Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PathReinLengthn1 { get; }
Visual Basic
Public Shared ReadOnly Property PathReinLengthn1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PathReinLengthn1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PathReinLengthn2 Property

[image]

Revit 2024 API
ParameterTypeId..::..PathReinLengthn2 Property
ParameterTypeId Class See Also Send Feedback
"Alternating Bar - Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PathReinLengthn2 { get; }
Visual Basic
Public Shared ReadOnly Property PathReinLengthn2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PathReinLengthn2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PathReinNumberOfBars Property

[image]

Revit 2024 API
ParameterTypeId..::..PathReinNumberOfBars Property
ParameterTypeId Class See Also Send Feedback
"Number Of Bars"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PathReinNumberOfBars { get; }
Visual Basic
Public Shared ReadOnly Property PathReinNumberOfBars As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PathReinNumberOfBars {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PathReinShapen1 Property

[image]

Revit 2024 API
ParameterTypeId..::..PathReinShapen1 Property
ParameterTypeId Class See Also Send Feedback
"Primary Bar - Shape"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PathReinShapen1 { get; }
Visual Basic
Public Shared ReadOnly Property PathReinShapen1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PathReinShapen1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PathReinShapen2 Property

[image]

Revit 2024 API
ParameterTypeId..::..PathReinShapen2 Property
ParameterTypeId Class See Also Send Feedback
"Alternating Bar - Shape"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PathReinShapen2 { get; }
Visual Basic
Public Shared ReadOnly Property PathReinShapen2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PathReinShapen2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PathReinSpacing Property

[image]

Revit 2024 API
ParameterTypeId..::..PathReinSpacing Property
ParameterTypeId Class See Also Send Feedback
"Bar Spacing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PathReinSpacing { get; }
Visual Basic
Public Shared ReadOnly Property PathReinSpacing As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PathReinSpacing {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PathReinSpanhookAlt Property

[image]

Revit 2024 API
ParameterTypeId..::..PathReinSpanhookAlt Property
ParameterTypeId Class See Also Send Feedback
"Start Hook Angle Alternating"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PathReinSpanhookAlt { get; }
Visual Basic
Public Shared ReadOnly Property PathReinSpanhookAlt As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PathReinSpanhookAlt {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PathReinSpanlengthBarlengthAlt Property

[image]

Revit 2024 API
ParameterTypeId..::..PathReinSpanlengthBarlengthAlt Property
ParameterTypeId Class See Also Send Feedback
"Length (Alternating Bar)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PathReinSpanlengthBarlengthAlt { get; }
Visual Basic
Public Shared ReadOnly Property PathReinSpanlengthBarlengthAlt As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PathReinSpanlengthBarlengthAlt {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PathReinSpanlengthBarlengthPrim Property

[image]

Revit 2024 API
ParameterTypeId..::..PathReinSpanlengthBarlengthPrim Property
ParameterTypeId Class See Also Send Feedback
"Length (Primary Bar)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PathReinSpanlengthBarlengthPrim { get; }
Visual Basic
Public Shared ReadOnly Property PathReinSpanlengthBarlengthPrim As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PathReinSpanlengthBarlengthPrim {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PathReinSpanlengthBottomPrim Property

[image]

Revit 2024 API
ParameterTypeId..::..PathReinSpanlengthBottomPrim Property
ParameterTypeId Class See Also Send Feedback
"Bottom (Primary Bar)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PathReinSpanlengthBottomPrim { get; }
Visual Basic
Public Shared ReadOnly Property PathReinSpanlengthBottomPrim As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PathReinSpanlengthBottomPrim {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PathReinSummary Property

[image]

Revit 2024 API
ParameterTypeId..::..PathReinSummary Property
ParameterTypeId Class See Also Send Feedback
"Summary"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PathReinSummary { get; }
Visual Basic
Public Shared ReadOnly Property PathReinSummary As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PathReinSummary {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PathReinTypen1 Property

[image]

Revit 2024 API
ParameterTypeId..::..PathReinTypen1 Property
ParameterTypeId Class See Also Send Feedback
"Primary Bar - Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PathReinTypen1 { get; }
Visual Basic
Public Shared ReadOnly Property PathReinTypen1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PathReinTypen1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PathReinTypen2 Property

[image]

Revit 2024 API
ParameterTypeId..::..PathReinTypen2 Property
ParameterTypeId Class See Also Send Feedback
"Alternating Bar - Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PathReinTypen2 { get; }
Visual Basic
Public Shared ReadOnly Property PathReinTypen2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PathReinTypen2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PatternIndent1ForDivisionRule Property

[image]

Revit 2024 API
ParameterTypeId..::..PatternIndent1ForDivisionRule Property
ParameterTypeId Class See Also Send Feedback
"Indent 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PatternIndent1ForDivisionRule { get; }
Visual Basic
Public Shared ReadOnly Property PatternIndent1ForDivisionRule As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PatternIndent1ForDivisionRule {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PatternIndent2ForDivisionRule Property

[image]

Revit 2024 API
ParameterTypeId..::..PatternIndent2ForDivisionRule Property
ParameterTypeId Class See Also Send Feedback
"Indent 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PatternIndent2ForDivisionRule { get; }
Visual Basic
Public Shared ReadOnly Property PatternIndent2ForDivisionRule As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PatternIndent2ForDivisionRule {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PatternMirrorForDivisionRule Property

[image]

Revit 2024 API
ParameterTypeId..::..PatternMirrorForDivisionRule Property
ParameterTypeId Class See Also Send Feedback
"Mirror"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PatternMirrorForDivisionRule { get; }
Visual Basic
Public Shared ReadOnly Property PatternMirrorForDivisionRule As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PatternMirrorForDivisionRule {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PeakAirflowParam Property

[image]

Revit 2024 API
ParameterTypeId..::..PeakAirflowParam Property
ParameterTypeId Class See Also Send Feedback
"Peak Airflow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PeakAirflowParam { get; }
Visual Basic
Public Shared ReadOnly Property PeakAirflowParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PeakAirflowParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PeakCoolingLoadParam Property

[image]

Revit 2024 API
ParameterTypeId..::..PeakCoolingLoadParam Property
ParameterTypeId Class See Also Send Feedback
"Peak Cooling Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PeakCoolingLoadParam { get; }
Visual Basic
Public Shared ReadOnly Property PeakCoolingLoadParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PeakCoolingLoadParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PeakHeatingLoadParam Property

[image]

Revit 2024 API
ParameterTypeId..::..PeakHeatingLoadParam Property
ParameterTypeId Class See Also Send Feedback
"Peak Heating Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PeakHeatingLoadParam { get; }
Visual Basic
Public Shared ReadOnly Property PeakHeatingLoadParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PeakHeatingLoadParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PeakLatentCoolingLoad Property

[image]

Revit 2024 API
ParameterTypeId..::..PeakLatentCoolingLoad Property
ParameterTypeId Class See Also Send Feedback
"Peak Latent Cooling Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PeakLatentCoolingLoad { get; }
Visual Basic
Public Shared ReadOnly Property PeakLatentCoolingLoad As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PeakLatentCoolingLoad {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PhaseDemolished Property

[image]

Revit 2024 API
ParameterTypeId..::..PhaseDemolished Property
ParameterTypeId Class See Also Send Feedback
"Phase Demolished"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PhaseDemolished { get; }
Visual Basic
Public Shared ReadOnly Property PhaseDemolished As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PhaseDemolished {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PhaseName Property

[image]

Revit 2024 API
ParameterTypeId..::..PhaseName Property
ParameterTypeId Class See Also Send Feedback
"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PhaseName { get; }
Visual Basic
Public Shared ReadOnly Property PhaseName As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PhaseName {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PhaseSequenceNumber Property

[image]

Revit 2024 API
ParameterTypeId..::..PhaseSequenceNumber Property
ParameterTypeId Class See Also Send Feedback
"Sequence Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PhaseSequenceNumber { get; }
Visual Basic
Public Shared ReadOnly Property PhaseSequenceNumber As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PhaseSequenceNumber {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PhyMaterialParamAverageModulus Property

[image]

Revit 2024 API
ParameterTypeId..::..PhyMaterialParamAverageModulus Property
ParameterTypeId Class See Also Send Feedback
"Average Modulus"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PhyMaterialParamAverageModulus { get; }
Visual Basic
Public Shared ReadOnly Property PhyMaterialParamAverageModulus As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PhyMaterialParamAverageModulus {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PhyMaterialParamBehavior Property

[image]

Revit 2024 API
ParameterTypeId..::..PhyMaterialParamBehavior Property
ParameterTypeId Class See Also Send Feedback
"Behavior"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PhyMaterialParamBehavior { get; }
Visual Basic
Public Shared ReadOnly Property PhyMaterialParamBehavior As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PhyMaterialParamBehavior {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PhyMaterialParamBending Property

[image]

Revit 2024 API
ParameterTypeId..::..PhyMaterialParamBending Property
ParameterTypeId Class See Also Send Feedback
"Bending"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PhyMaterialParamBending { get; }
Visual Basic
Public Shared ReadOnly Property PhyMaterialParamBending As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PhyMaterialParamBending {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PhyMaterialParamBendingReinforcement Property

[image]

Revit 2024 API
ParameterTypeId..::..PhyMaterialParamBendingReinforcement Property
ParameterTypeId Class See Also Send Feedback
"Bending reinforcement"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PhyMaterialParamBendingReinforcement { get; }
Visual Basic
Public Shared ReadOnly Property PhyMaterialParamBendingReinforcement As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PhyMaterialParamBendingReinforcement {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PhyMaterialParamClass Property

[image]

Revit 2024 API
ParameterTypeId..::..PhyMaterialParamClass Property
ParameterTypeId Class See Also Send Feedback
"Class"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PhyMaterialParamClass { get; }
Visual Basic
Public Shared ReadOnly Property PhyMaterialParamClass As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PhyMaterialParamClass {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PhyMaterialParamCompressionParallel Property

[image]

Revit 2024 API
ParameterTypeId..::..PhyMaterialParamCompressionParallel Property
ParameterTypeId Class See Also Send Feedback
"Compression parallel to grain"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PhyMaterialParamCompressionParallel { get; }
Visual Basic
Public Shared ReadOnly Property PhyMaterialParamCompressionParallel As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PhyMaterialParamCompressionParallel {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PhyMaterialParamCompressionPerpendicular Property

[image]

Revit 2024 API
ParameterTypeId..::..PhyMaterialParamCompressionPerpendicular Property
ParameterTypeId Class See Also Send Feedback
"Compression perpendicular to grain"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PhyMaterialParamCompressionPerpendicular { get; }
Visual Basic
Public Shared ReadOnly Property PhyMaterialParamCompressionPerpendicular As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PhyMaterialParamCompressionPerpendicular {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PhyMaterialParamExpCoeff Property

[image]

Revit 2024 API
ParameterTypeId..::..PhyMaterialParamExpCoeff Property
ParameterTypeId Class See Also Send Feedback
"Thermal expansion coefficient"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PhyMaterialParamExpCoeff { get; }
Visual Basic
Public Shared ReadOnly Property PhyMaterialParamExpCoeff As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PhyMaterialParamExpCoeff {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PhyMaterialParamExpCoeff1 Property

[image]

Revit 2024 API
ParameterTypeId..::..PhyMaterialParamExpCoeff1 Property
ParameterTypeId Class See Also Send Feedback
"Thermal expansion coefficient X"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PhyMaterialParamExpCoeff1 { get; }
Visual Basic
Public Shared ReadOnly Property PhyMaterialParamExpCoeff1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PhyMaterialParamExpCoeff1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PhyMaterialParamExpCoeff3 Property

[image]

Revit 2024 API
ParameterTypeId..::..PhyMaterialParamExpCoeff3 Property
ParameterTypeId Class See Also Send Feedback
"Thermal expansion coefficient Z"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PhyMaterialParamExpCoeff3 { get; }
Visual Basic
Public Shared ReadOnly Property PhyMaterialParamExpCoeff3 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PhyMaterialParamExpCoeff3 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PhyMaterialParamExpCoeffn1 Property

[image]

Revit 2024 API
ParameterTypeId..::..PhyMaterialParamExpCoeffn1 Property
ParameterTypeId Class See Also Send Feedback
"Thermal Expansion Coefficient 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PhyMaterialParamExpCoeffn1 { get; }
Visual Basic
Public Shared ReadOnly Property PhyMaterialParamExpCoeffn1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PhyMaterialParamExpCoeffn1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PhyMaterialParamExpCoeffn2 Property

[image]

Revit 2024 API
ParameterTypeId..::..PhyMaterialParamExpCoeffn2 Property
ParameterTypeId Class See Also Send Feedback
"Thermal Expansion Coefficient 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PhyMaterialParamExpCoeffn2 { get; }
Visual Basic
Public Shared ReadOnly Property PhyMaterialParamExpCoeffn2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PhyMaterialParamExpCoeffn2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PhyMaterialParamGrade Property

[image]

Revit 2024 API
ParameterTypeId..::..PhyMaterialParamGrade Property
ParameterTypeId Class See Also Send Feedback
"Grade"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PhyMaterialParamGrade { get; }
Visual Basic
Public Shared ReadOnly Property PhyMaterialParamGrade As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PhyMaterialParamGrade {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PhyMaterialParamLightWeight Property

[image]

Revit 2024 API
ParameterTypeId..::..PhyMaterialParamLightWeight Property
ParameterTypeId Class See Also Send Feedback
"Lightweight"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PhyMaterialParamLightWeight { get; }
Visual Basic
Public Shared ReadOnly Property PhyMaterialParamLightWeight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PhyMaterialParamLightWeight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PhyMaterialParamMinimumYieldStress Property

[image]

Revit 2024 API
ParameterTypeId..::..PhyMaterialParamMinimumYieldStress Property
ParameterTypeId Class See Also Send Feedback
"Minimum yield stress"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PhyMaterialParamMinimumYieldStress { get; }
Visual Basic
Public Shared ReadOnly Property PhyMaterialParamMinimumYieldStress As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PhyMaterialParamMinimumYieldStress {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PhyMaterialParamPoissonMod Property

[image]

Revit 2024 API
ParameterTypeId..::..PhyMaterialParamPoissonMod Property
ParameterTypeId Class See Also Send Feedback
"Poisson ratio"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PhyMaterialParamPoissonMod { get; }
Visual Basic
Public Shared ReadOnly Property PhyMaterialParamPoissonMod As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PhyMaterialParamPoissonMod {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PhyMaterialParamPoissonMod1 Property

[image]

Revit 2024 API
ParameterTypeId..::..PhyMaterialParamPoissonMod1 Property
ParameterTypeId Class See Also Send Feedback
"Poisson ratio X"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PhyMaterialParamPoissonMod1 { get; }
Visual Basic
Public Shared ReadOnly Property PhyMaterialParamPoissonMod1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PhyMaterialParamPoissonMod1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PhyMaterialParamPoissonMod12 Property

[image]

Revit 2024 API
ParameterTypeId..::..PhyMaterialParamPoissonMod12 Property
ParameterTypeId Class See Also Send Feedback
"Poisson Ratio 12"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PhyMaterialParamPoissonMod12 { get; }
Visual Basic
Public Shared ReadOnly Property PhyMaterialParamPoissonMod12 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PhyMaterialParamPoissonMod12 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PhyMaterialParamPoissonMod23 Property

[image]

Revit 2024 API
ParameterTypeId..::..PhyMaterialParamPoissonMod23 Property
ParameterTypeId Class See Also Send Feedback
"Poisson Ratio 23"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PhyMaterialParamPoissonMod23 { get; }
Visual Basic
Public Shared ReadOnly Property PhyMaterialParamPoissonMod23 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PhyMaterialParamPoissonMod23 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PhyMaterialParamPoissonMod3 Property

[image]

Revit 2024 API
ParameterTypeId..::..PhyMaterialParamPoissonMod3 Property
ParameterTypeId Class See Also Send Feedback
"Poisson ratio Z"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PhyMaterialParamPoissonMod3 { get; }
Visual Basic
Public Shared ReadOnly Property PhyMaterialParamPoissonMod3 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PhyMaterialParamPoissonMod3 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PhyMaterialParamReductionFactor Property

[image]

Revit 2024 API
ParameterTypeId..::..PhyMaterialParamReductionFactor Property
ParameterTypeId Class See Also Send Feedback
"Reduction factor for shear"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PhyMaterialParamReductionFactor { get; }
Visual Basic
Public Shared ReadOnly Property PhyMaterialParamReductionFactor As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PhyMaterialParamReductionFactor {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PhyMaterialParamResistanceCalcStrength Property

[image]

Revit 2024 API
ParameterTypeId..::..PhyMaterialParamResistanceCalcStrength Property
ParameterTypeId Class See Also Send Feedback
"Resistance calculation strength"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PhyMaterialParamResistanceCalcStrength { get; }
Visual Basic
Public Shared ReadOnly Property PhyMaterialParamResistanceCalcStrength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PhyMaterialParamResistanceCalcStrength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PhyMaterialParamShearMod Property

[image]

Revit 2024 API
ParameterTypeId..::..PhyMaterialParamShearMod Property
ParameterTypeId Class See Also Send Feedback
"Shear modulus"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PhyMaterialParamShearMod { get; }
Visual Basic
Public Shared ReadOnly Property PhyMaterialParamShearMod As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PhyMaterialParamShearMod {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PhyMaterialParamShearMod1 Property

[image]

Revit 2024 API
ParameterTypeId..::..PhyMaterialParamShearMod1 Property
ParameterTypeId Class See Also Send Feedback
"Shear modulus X"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PhyMaterialParamShearMod1 { get; }
Visual Basic
Public Shared ReadOnly Property PhyMaterialParamShearMod1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PhyMaterialParamShearMod1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PhyMaterialParamShearMod12 Property

[image]

Revit 2024 API
ParameterTypeId..::..PhyMaterialParamShearMod12 Property
ParameterTypeId Class See Also Send Feedback
"Shear Modulus 12"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PhyMaterialParamShearMod12 { get; }
Visual Basic
Public Shared ReadOnly Property PhyMaterialParamShearMod12 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PhyMaterialParamShearMod12 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PhyMaterialParamShearMod2 Property

[image]

Revit 2024 API
ParameterTypeId..::..PhyMaterialParamShearMod2 Property
ParameterTypeId Class See Also Send Feedback
"Shear modulus Y"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PhyMaterialParamShearMod2 { get; }
Visual Basic
Public Shared ReadOnly Property PhyMaterialParamShearMod2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PhyMaterialParamShearMod2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PhyMaterialParamShearMod3 Property

[image]

Revit 2024 API
ParameterTypeId..::..PhyMaterialParamShearMod3 Property
ParameterTypeId Class See Also Send Feedback
"Shear modulus Z"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PhyMaterialParamShearMod3 { get; }
Visual Basic
Public Shared ReadOnly Property PhyMaterialParamShearMod3 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PhyMaterialParamShearMod3 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PhyMaterialParamShearParallel Property

[image]

Revit 2024 API
ParameterTypeId..::..PhyMaterialParamShearParallel Property
ParameterTypeId Class See Also Send Feedback
"Shear parallel to grain"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PhyMaterialParamShearParallel { get; }
Visual Basic
Public Shared ReadOnly Property PhyMaterialParamShearParallel As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PhyMaterialParamShearParallel {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PhyMaterialParamShearPerpendicular Property

[image]

Revit 2024 API
ParameterTypeId..::..PhyMaterialParamShearPerpendicular Property
ParameterTypeId Class See Also Send Feedback
"Shear perpendicular to grain"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PhyMaterialParamShearPerpendicular { get; }
Visual Basic
Public Shared ReadOnly Property PhyMaterialParamShearPerpendicular As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PhyMaterialParamShearPerpendicular {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PhyMaterialParamShearReinforcement Property

[image]

Revit 2024 API
ParameterTypeId..::..PhyMaterialParamShearReinforcement Property
ParameterTypeId Class See Also Send Feedback
"Shear reinforcement yield stress"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PhyMaterialParamShearReinforcement { get; }
Visual Basic
Public Shared ReadOnly Property PhyMaterialParamShearReinforcement As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PhyMaterialParamShearReinforcement {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PhyMaterialParamShearStrengthReduction Property

[image]

Revit 2024 API
ParameterTypeId..::..PhyMaterialParamShearStrengthReduction Property
ParameterTypeId Class See Also Send Feedback
"Shear strength modification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PhyMaterialParamShearStrengthReduction { get; }
Visual Basic
Public Shared ReadOnly Property PhyMaterialParamShearStrengthReduction As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PhyMaterialParamShearStrengthReduction {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PhyMaterialParamSpecies Property

[image]

Revit 2024 API
ParameterTypeId..::..PhyMaterialParamSpecies Property
ParameterTypeId Class See Also Send Feedback
"Species"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PhyMaterialParamSpecies { get; }
Visual Basic
Public Shared ReadOnly Property PhyMaterialParamSpecies As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PhyMaterialParamSpecies {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PhyMaterialParamStructuralDensity Property

[image]

Revit 2024 API
ParameterTypeId..::..PhyMaterialParamStructuralDensity Property
ParameterTypeId Class See Also Send Feedback
"Density"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PhyMaterialParamStructuralDensity { get; }
Visual Basic
Public Shared ReadOnly Property PhyMaterialParamStructuralDensity As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PhyMaterialParamStructuralDensity {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PhyMaterialParamStructuralSpecificHeat Property

[image]

Revit 2024 API
ParameterTypeId..::..PhyMaterialParamStructuralSpecificHeat Property
ParameterTypeId Class See Also Send Feedback
"Specific Heat"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PhyMaterialParamStructuralSpecificHeat { get; }
Visual Basic
Public Shared ReadOnly Property PhyMaterialParamStructuralSpecificHeat As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PhyMaterialParamStructuralSpecificHeat {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PhyMaterialParamStructuralThermalTreated Property

[image]

Revit 2024 API
ParameterTypeId..::..PhyMaterialParamStructuralThermalTreated Property
ParameterTypeId Class See Also Send Feedback
"Thermally Treated"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PhyMaterialParamStructuralThermalTreated { get; }
Visual Basic
Public Shared ReadOnly Property PhyMaterialParamStructuralThermalTreated As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PhyMaterialParamStructuralThermalTreated {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PhyMaterialParamSubclass Property

[image]

Revit 2024 API
ParameterTypeId..::..PhyMaterialParamSubclass Property
ParameterTypeId Class See Also Send Feedback
"Subclass"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PhyMaterialParamSubclass { get; }
Visual Basic
Public Shared ReadOnly Property PhyMaterialParamSubclass As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PhyMaterialParamSubclass {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PhyMaterialParamTensionPerpendicular Property

[image]

Revit 2024 API
ParameterTypeId..::..PhyMaterialParamTensionPerpendicular Property
ParameterTypeId Class See Also Send Feedback
"Tension Perpendicular to Grain"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PhyMaterialParamTensionPerpendicular { get; }
Visual Basic
Public Shared ReadOnly Property PhyMaterialParamTensionPerpendicular As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PhyMaterialParamTensionPerpendicular {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PhyMaterialParamThermalConductivityX Property

[image]

Revit 2024 API
ParameterTypeId..::..PhyMaterialParamThermalConductivityX Property
ParameterTypeId Class See Also Send Feedback
"Thermal Conductivity X"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PhyMaterialParamThermalConductivityX { get; }
Visual Basic
Public Shared ReadOnly Property PhyMaterialParamThermalConductivityX As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PhyMaterialParamThermalConductivityX {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PhyMaterialParamThermalConductivityY Property

[image]

Revit 2024 API
ParameterTypeId..::..PhyMaterialParamThermalConductivityY Property
ParameterTypeId Class See Also Send Feedback
"Thermal Conductivity Y"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PhyMaterialParamThermalConductivityY { get; }
Visual Basic
Public Shared ReadOnly Property PhyMaterialParamThermalConductivityY As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PhyMaterialParamThermalConductivityY {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PhyMaterialParamType Property

[image]

Revit 2024 API
ParameterTypeId..::..PhyMaterialParamType Property
ParameterTypeId Class See Also Send Feedback
"Material Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PhyMaterialParamType { get; }
Visual Basic
Public Shared ReadOnly Property PhyMaterialParamType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PhyMaterialParamType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PhyMaterialParamUnitWeight Property

[image]

Revit 2024 API
ParameterTypeId..::..PhyMaterialParamUnitWeight Property
ParameterTypeId Class See Also Send Feedback
"Unit weight"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PhyMaterialParamUnitWeight { get; }
Visual Basic
Public Shared ReadOnly Property PhyMaterialParamUnitWeight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PhyMaterialParamUnitWeight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PhyMaterialParamYoungMod1 Property

[image]

Revit 2024 API
ParameterTypeId..::..PhyMaterialParamYoungMod1 Property
ParameterTypeId Class See Also Send Feedback
"Young modulus X"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PhyMaterialParamYoungMod1 { get; }
Visual Basic
Public Shared ReadOnly Property PhyMaterialParamYoungMod1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PhyMaterialParamYoungMod1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PhyMaterialParamYoungMod2 Property

[image]

Revit 2024 API
ParameterTypeId..::..PhyMaterialParamYoungMod2 Property
ParameterTypeId Class See Also Send Feedback
"Young modulus Y"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PhyMaterialParamYoungMod2 { get; }
Visual Basic
Public Shared ReadOnly Property PhyMaterialParamYoungMod2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PhyMaterialParamYoungMod2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PhyMaterialParamYoungMod3 Property

[image]

Revit 2024 API
ParameterTypeId..::..PhyMaterialParamYoungMod3 Property
ParameterTypeId Class See Also Send Feedback
"Young modulus Z"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PhyMaterialParamYoungMod3 { get; }
Visual Basic
Public Shared ReadOnly Property PhyMaterialParamYoungMod3 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PhyMaterialParamYoungMod3 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PhyMaterialParamYoungModn1 Property

[image]

Revit 2024 API
ParameterTypeId..::..PhyMaterialParamYoungModn1 Property
ParameterTypeId Class See Also Send Feedback
"Young's Modulus 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PhyMaterialParamYoungModn1 { get; }
Visual Basic
Public Shared ReadOnly Property PhyMaterialParamYoungModn1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PhyMaterialParamYoungModn1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PhyMaterialParamYoungModn2 Property

[image]

Revit 2024 API
ParameterTypeId..::..PhyMaterialParamYoungModn2 Property
ParameterTypeId Class See Also Send Feedback
"Young's Modulus 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PhyMaterialParamYoungModn2 { get; }
Visual Basic
Public Shared ReadOnly Property PhyMaterialParamYoungModn2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PhyMaterialParamYoungModn2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PhyMaterialProperties Property

[image]

Revit 2024 API
ParameterTypeId..::..PhyMaterialProperties Property
ParameterTypeId Class See Also Send Feedback
"Properties"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PhyMaterialProperties { get; }
Visual Basic
Public Shared ReadOnly Property PhyMaterialProperties As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PhyMaterialProperties {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PipeRoughness Property

[image]

Revit 2024 API
ParameterTypeId..::..PipeRoughness Property
ParameterTypeId Class See Also Send Feedback
"Roughness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PipeRoughness { get; }
Visual Basic
Public Shared ReadOnly Property PipeRoughness As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PipeRoughness {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PipeVelocityPressure Property

[image]

Revit 2024 API
ParameterTypeId..::..PipeVelocityPressure Property
ParameterTypeId Class See Also Send Feedback
"Velocity Pressure"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PipeVelocityPressure { get; }
Visual Basic
Public Shared ReadOnly Property PipeVelocityPressure As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PipeVelocityPressure {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PipingConnectionType Property

[image]

Revit 2024 API
ParameterTypeId..::..PipingConnectionType Property
ParameterTypeId Class See Also Send Feedback
"Connection Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PipingConnectionType { get; }
Visual Basic
Public Shared ReadOnly Property PipingConnectionType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PipingConnectionType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PipingGenderType Property

[image]

Revit 2024 API
ParameterTypeId..::..PipingGenderType Property
ParameterTypeId Class See Also Send Feedback
"Gender Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PipingGenderType { get; }
Visual Basic
Public Shared ReadOnly Property PipingGenderType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PipingGenderType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PlacementCenterX Property

[image]

Revit 2024 API
ParameterTypeId..::..PlacementCenterX Property
ParameterTypeId Class See Also Send Feedback
"Center X"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PlacementCenterX { get; }
Visual Basic
Public Shared ReadOnly Property PlacementCenterX As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PlacementCenterX {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PlacementCenterY Property

[image]

Revit 2024 API
ParameterTypeId..::..PlacementCenterY Property
ParameterTypeId Class See Also Send Feedback
"Center Y"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PlacementCenterY { get; }
Visual Basic
Public Shared ReadOnly Property PlacementCenterY As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PlacementCenterY {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PlacementLeft Property

[image]

Revit 2024 API
ParameterTypeId..::..PlacementLeft Property
ParameterTypeId Class See Also Send Feedback
"Left"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PlacementLeft { get; }
Visual Basic
Public Shared ReadOnly Property PlacementLeft As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PlacementLeft {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PlacementParamsShow Property

[image]

Revit 2024 API
ParameterTypeId..::..PlacementParamsShow Property
ParameterTypeId Class See Also Send Feedback
"Enable Position Parameters"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PlacementParamsShow { get; }
Visual Basic
Public Shared ReadOnly Property PlacementParamsShow As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PlacementParamsShow {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PlacementRight Property

[image]

Revit 2024 API
ParameterTypeId..::..PlacementRight Property
ParameterTypeId Class See Also Send Feedback
"Right"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PlacementRight { get; }
Visual Basic
Public Shared ReadOnly Property PlacementRight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PlacementRight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PlacementTop Property

[image]

Revit 2024 API
ParameterTypeId..::..PlacementTop Property
ParameterTypeId Class See Also Send Feedback
"Top"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PlacementTop { get; }
Visual Basic
Public Shared ReadOnly Property PlacementTop As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PlacementTop {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PlanRegionViewRange Property

[image]

Revit 2024 API
ParameterTypeId..::..PlanRegionViewRange Property
ParameterTypeId Class See Also Send Feedback
"View Range"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PlanRegionViewRange { get; }
Visual Basic
Public Shared ReadOnly Property PlanRegionViewRange As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PlanRegionViewRange {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PlanViewCutPlaneHeight Property

[image]

Revit 2024 API
ParameterTypeId..::..PlanViewCutPlaneHeight Property
ParameterTypeId Class See Also Send Feedback
"Cut Plane Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PlanViewCutPlaneHeight { get; }
Visual Basic
Public Shared ReadOnly Property PlanViewCutPlaneHeight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PlanViewCutPlaneHeight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PlanViewLevel Property

[image]

Revit 2024 API
ParameterTypeId..::..PlanViewLevel Property
ParameterTypeId Class See Also Send Feedback
"Associated Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PlanViewLevel { get; }
Visual Basic
Public Shared ReadOnly Property PlanViewLevel As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PlanViewLevel {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PlanViewNorth Property

[image]

Revit 2024 API
ParameterTypeId..::..PlanViewNorth Property
ParameterTypeId Class See Also Send Feedback
"Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PlanViewNorth { get; }
Visual Basic
Public Shared ReadOnly Property PlanViewNorth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PlanViewNorth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PlanViewRange Property

[image]

Revit 2024 API
ParameterTypeId..::..PlanViewRange Property
ParameterTypeId Class See Also Send Feedback
"View Range"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PlanViewRange { get; }
Visual Basic
Public Shared ReadOnly Property PlanViewRange As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PlanViewRange {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PlanViewTopClipHeight Property

[image]

Revit 2024 API
ParameterTypeId..::..PlanViewTopClipHeight Property
ParameterTypeId Class See Also Send Feedback
"Top Clip Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PlanViewTopClipHeight { get; }
Visual Basic
Public Shared ReadOnly Property PlanViewTopClipHeight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PlanViewTopClipHeight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PlanViewViewDir Property

[image]

Revit 2024 API
ParameterTypeId..::..PlanViewViewDir Property
ParameterTypeId Class See Also Send Feedback
"View Direction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PlanViewViewDir { get; }
Visual Basic
Public Shared ReadOnly Property PlanViewViewDir As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PlanViewViewDir {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PlumbingFixturesCwConnection Property

[image]

Revit 2024 API
ParameterTypeId..::..PlumbingFixturesCwConnection Property
ParameterTypeId Class See Also Send Feedback
"CW Connection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PlumbingFixturesCwConnection { get; }
Visual Basic
Public Shared ReadOnly Property PlumbingFixturesCwConnection As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PlumbingFixturesCwConnection {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PlumbingFixturesHwConnection Property

[image]

Revit 2024 API
ParameterTypeId..::..PlumbingFixturesHwConnection Property
ParameterTypeId Class See Also Send Feedback
"HW Connection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PlumbingFixturesHwConnection { get; }
Visual Basic
Public Shared ReadOnly Property PlumbingFixturesHwConnection As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PlumbingFixturesHwConnection {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PlumbingFixturesSupplyFitting Property

[image]

Revit 2024 API
ParameterTypeId..::..PlumbingFixturesSupplyFitting Property
ParameterTypeId Class See Also Send Feedback
"Supply Fitting"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PlumbingFixturesSupplyFitting { get; }
Visual Basic
Public Shared ReadOnly Property PlumbingFixturesSupplyFitting As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PlumbingFixturesSupplyFitting {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PlumbingFixturesTrap Property

[image]

Revit 2024 API
ParameterTypeId..::..PlumbingFixturesTrap Property
ParameterTypeId Class See Also Send Feedback
"Trap"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PlumbingFixturesTrap { get; }
Visual Basic
Public Shared ReadOnly Property PlumbingFixturesTrap As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PlumbingFixturesTrap {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PlumbingFixturesVentConnection Property

[image]

Revit 2024 API
ParameterTypeId..::..PlumbingFixturesVentConnection Property
ParameterTypeId Class See Also Send Feedback
"Vent Connection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PlumbingFixturesVentConnection { get; }
Visual Basic
Public Shared ReadOnly Property PlumbingFixturesVentConnection As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PlumbingFixturesVentConnection {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PointAdaptiveConstrained Property

[image]

Revit 2024 API
ParameterTypeId..::..PointAdaptiveConstrained Property
ParameterTypeId Class See Also Send Feedback
"Constrained"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PointAdaptiveConstrained { get; }
Visual Basic
Public Shared ReadOnly Property PointAdaptiveConstrained As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PointAdaptiveConstrained {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PointAdaptiveOrientationType Property

[image]

Revit 2024 API
ParameterTypeId..::..PointAdaptiveOrientationType Property
ParameterTypeId Class See Also Send Feedback
"Orients to"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PointAdaptiveOrientationType { get; }
Visual Basic
Public Shared ReadOnly Property PointAdaptiveOrientationType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PointAdaptiveOrientationType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PointAdaptiveShowNumber Property

[image]

Revit 2024 API
ParameterTypeId..::..PointAdaptiveShowNumber Property
ParameterTypeId Class See Also Send Feedback
"Show Placement Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PointAdaptiveShowNumber { get; }
Visual Basic
Public Shared ReadOnly Property PointAdaptiveShowNumber As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PointAdaptiveShowNumber {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PointAdaptiveTypeParam Property

[image]

Revit 2024 API
ParameterTypeId..::..PointAdaptiveTypeParam Property
ParameterTypeId Class See Also Send Feedback
"Point"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PointAdaptiveTypeParam { get; }
Visual Basic
Public Shared ReadOnly Property PointAdaptiveTypeParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PointAdaptiveTypeParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PointcloudinstanceName Property

[image]

Revit 2024 API
ParameterTypeId..::..PointcloudinstanceName Property
ParameterTypeId Class See Also Send Feedback
"Name": The name of the instance as it will show in the Property Palette

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PointcloudinstanceName { get; }
Visual Basic
Public Shared ReadOnly Property PointcloudinstanceName As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PointcloudinstanceName {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PointcloudtypeScale Property

[image]

Revit 2024 API
ParameterTypeId..::..PointcloudtypeScale Property
ParameterTypeId Class See Also Send Feedback
"Scale": The scale for this instance

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PointcloudtypeScale { get; }
Visual Basic
Public Shared ReadOnly Property PointcloudtypeScale As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PointcloudtypeScale {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PointElementAngle Property

[image]

Revit 2024 API
ParameterTypeId..::..PointElementAngle Property
ParameterTypeId Class See Also Send Feedback
"Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PointElementAngle { get; }
Visual Basic
Public Shared ReadOnly Property PointElementAngle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PointElementAngle {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PointElementChordLength Property

[image]

Revit 2024 API
ParameterTypeId..::..PointElementChordLength Property
ParameterTypeId Class See Also Send Feedback
"Chord Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PointElementChordLength { get; }
Visual Basic
Public Shared ReadOnly Property PointElementChordLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PointElementChordLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PointElementDriven Property

[image]

Revit 2024 API
ParameterTypeId..::..PointElementDriven Property
ParameterTypeId Class See Also Send Feedback
"Driven by Host"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PointElementDriven { get; }
Visual Basic
Public Shared ReadOnly Property PointElementDriven As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PointElementDriven {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PointElementDriving Property

[image]

Revit 2024 API
ParameterTypeId..::..PointElementDriving Property
ParameterTypeId Class See Also Send Feedback
"Driving Curve(s)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PointElementDriving { get; }
Visual Basic
Public Shared ReadOnly Property PointElementDriving As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PointElementDriving {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PointElementHostedOnFaceUParam Property

[image]

Revit 2024 API
ParameterTypeId..::..PointElementHostedOnFaceUParam Property
ParameterTypeId Class See Also Send Feedback
"Hosted U Parameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PointElementHostedOnFaceUParam { get; }
Visual Basic
Public Shared ReadOnly Property PointElementHostedOnFaceUParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PointElementHostedOnFaceUParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PointElementHostedParam Property

[image]

Revit 2024 API
ParameterTypeId..::..PointElementHostedParam Property
ParameterTypeId Class See Also Send Feedback
"Hosted Parameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PointElementHostedParam { get; }
Visual Basic
Public Shared ReadOnly Property PointElementHostedParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PointElementHostedParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PointElementMeasurementType Property

[image]

Revit 2024 API
ParameterTypeId..::..PointElementMeasurementType Property
ParameterTypeId Class See Also Send Feedback
"Measurement Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PointElementMeasurementType { get; }
Visual Basic
Public Shared ReadOnly Property PointElementMeasurementType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PointElementMeasurementType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PointElementMirrored Property

[image]

Revit 2024 API
ParameterTypeId..::..PointElementMirrored Property
ParameterTypeId Class See Also Send Feedback
"Mirrored"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PointElementMirrored { get; }
Visual Basic
Public Shared ReadOnly Property PointElementMirrored As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PointElementMirrored {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PointElementNonNormalizedCurveParamater Property

[image]

Revit 2024 API
ParameterTypeId..::..PointElementNonNormalizedCurveParamater Property
ParameterTypeId Class See Also Send Feedback
"Non-Normalized Curve Parameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PointElementNonNormalizedCurveParamater { get; }
Visual Basic
Public Shared ReadOnly Property PointElementNonNormalizedCurveParamater As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PointElementNonNormalizedCurveParamater {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PointElementNormalizedCurveParamater Property

[image]

Revit 2024 API
ParameterTypeId..::..PointElementNormalizedCurveParamater Property
ParameterTypeId Class See Also Send Feedback
"Normalized Curve Parameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PointElementNormalizedCurveParamater { get; }
Visual Basic
Public Shared ReadOnly Property PointElementNormalizedCurveParamater As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PointElementNormalizedCurveParamater {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PointElementNormalizedSegmentLength Property

[image]

Revit 2024 API
ParameterTypeId..::..PointElementNormalizedSegmentLength Property
ParameterTypeId Class See Also Send Feedback
"Normalized Segment Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PointElementNormalizedSegmentLength { get; }
Visual Basic
Public Shared ReadOnly Property PointElementNormalizedSegmentLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PointElementNormalizedSegmentLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PointElementOffset Property

[image]

Revit 2024 API
ParameterTypeId..::..PointElementOffset Property
ParameterTypeId Class See Also Send Feedback
"Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PointElementOffset { get; }
Visual Basic
Public Shared ReadOnly Property PointElementOffset As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PointElementOffset {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PointElementRotationAngle Property

[image]

Revit 2024 API
ParameterTypeId..::..PointElementRotationAngle Property
ParameterTypeId Class See Also Send Feedback
"Rotation Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PointElementRotationAngle { get; }
Visual Basic
Public Shared ReadOnly Property PointElementRotationAngle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PointElementRotationAngle {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PointElementSegmentLength Property

[image]

Revit 2024 API
ParameterTypeId..::..PointElementSegmentLength Property
ParameterTypeId Class See Also Send Feedback
"Segment Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PointElementSegmentLength { get; }
Visual Basic
Public Shared ReadOnly Property PointElementSegmentLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PointElementSegmentLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PointElementShowPlanes Property

[image]

Revit 2024 API
ParameterTypeId..::..PointElementShowPlanes Property
ParameterTypeId Class See Also Send Feedback
"Show Reference Planes"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PointElementShowPlanes { get; }
Visual Basic
Public Shared ReadOnly Property PointElementShowPlanes As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PointElementShowPlanes {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PointElementZflipped Property

[image]

Revit 2024 API
ParameterTypeId..::..PointElementZflipped Property
ParameterTypeId Class See Also Send Feedback
"Flipped"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PointElementZflipped { get; }
Visual Basic
Public Shared ReadOnly Property PointElementZflipped As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PointElementZflipped {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PointFlexibleNumParam Property

[image]

Revit 2024 API
ParameterTypeId..::..PointFlexibleNumParam Property
ParameterTypeId Class See Also Send Feedback
"Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PointFlexibleNumParam { get; }
Visual Basic
Public Shared ReadOnly Property PointFlexibleNumParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PointFlexibleNumParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PointFlexibleOrientationType Property

[image]

Revit 2024 API
ParameterTypeId..::..PointFlexibleOrientationType Property
ParameterTypeId Class See Also Send Feedback
"Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PointFlexibleOrientationType { get; }
Visual Basic
Public Shared ReadOnly Property PointFlexibleOrientationType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PointFlexibleOrientationType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PointNameParam Property

[image]

Revit 2024 API
ParameterTypeId..::..PointNameParam Property
ParameterTypeId Class See Also Send Feedback
"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PointNameParam { get; }
Visual Basic
Public Shared ReadOnly Property PointNameParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PointNameParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PointVisibilityParam Property

[image]

Revit 2024 API
ParameterTypeId..::..PointVisibilityParam Property
ParameterTypeId Class See Also Send Feedback
"Visibility/Graphics Overrides"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PointVisibilityParam { get; }
Visual Basic
Public Shared ReadOnly Property PointVisibilityParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PointVisibilityParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PreferPatternAlignUiFilter Property

[image]

Revit 2024 API
ParameterTypeId..::..PreferPatternAlignUiFilter Property
ParameterTypeId Class See Also Send Feedback
"Pattern:": This is used by the UI to allow to select the preferred preference of aligning pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PreferPatternAlignUiFilter { get; }
Visual Basic
Public Shared ReadOnly Property PreferPatternAlignUiFilter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PreferPatternAlignUiFilter {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PrimaryOptionId Property

[image]

Revit 2024 API
ParameterTypeId..::..PrimaryOptionId Property
ParameterTypeId Class See Also Send Feedback
"Primary Option Id"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PrimaryOptionId { get; }
Visual Basic
Public Shared ReadOnly Property PrimaryOptionId As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PrimaryOptionId {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


Profile1FamType Property

[image]

Revit 2024 API
ParameterTypeId..::..Profile1FamType Property
ParameterTypeId Class See Also Send Feedback
"Profile"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId Profile1FamType { get; }
Visual Basic
Public Shared ReadOnly Property Profile1FamType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Profile1FamType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


Profile1FlippedHor Property

[image]

Revit 2024 API
ParameterTypeId..::..Profile1FlippedHor Property
ParameterTypeId Class See Also Send Feedback
"Profile Is Flipped"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId Profile1FlippedHor { get; }
Visual Basic
Public Shared ReadOnly Property Profile1FlippedHor As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Profile1FlippedHor {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


Profile1OffsetX Property

[image]

Revit 2024 API
ParameterTypeId..::..Profile1OffsetX Property
ParameterTypeId Class See Also Send Feedback
"Horizontal Profile Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId Profile1OffsetX { get; }
Visual Basic
Public Shared ReadOnly Property Profile1OffsetX As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Profile1OffsetX {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


Profile1OffsetY Property

[image]

Revit 2024 API
ParameterTypeId..::..Profile1OffsetY Property
ParameterTypeId Class See Also Send Feedback
"Vertical Profile Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId Profile1OffsetY { get; }
Visual Basic
Public Shared ReadOnly Property Profile1OffsetY As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Profile1OffsetY {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


Profile2FamType Property

[image]

Revit 2024 API
ParameterTypeId..::..Profile2FamType Property
ParameterTypeId Class See Also Send Feedback
"Profile"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId Profile2FamType { get; }
Visual Basic
Public Shared ReadOnly Property Profile2FamType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Profile2FamType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


Profile2FlippedHor Property

[image]

Revit 2024 API
ParameterTypeId..::..Profile2FlippedHor Property
ParameterTypeId Class See Also Send Feedback
"Profile Is Flipped"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId Profile2FlippedHor { get; }
Visual Basic
Public Shared ReadOnly Property Profile2FlippedHor As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Profile2FlippedHor {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


Profile2OffsetY Property

[image]

Revit 2024 API
ParameterTypeId..::..Profile2OffsetY Property
ParameterTypeId Class See Also Send Feedback
"Vertical Profile Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId Profile2OffsetY { get; }
Visual Basic
Public Shared ReadOnly Property Profile2OffsetY As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Profile2OffsetY {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ProfileFamType Property

[image]

Revit 2024 API
ParameterTypeId..::..ProfileFamType Property
ParameterTypeId Class See Also Send Feedback
"Profile"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ProfileFamType { get; }
Visual Basic
Public Shared ReadOnly Property ProfileFamType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ProfileFamType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ProfileFamTypePlusNone Property

[image]

Revit 2024 API
ParameterTypeId..::..ProfileFamTypePlusNone Property
ParameterTypeId Class See Also Send Feedback
"Profile"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ProfileFamTypePlusNone { get; }
Visual Basic
Public Shared ReadOnly Property ProfileFamTypePlusNone As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ProfileFamTypePlusNone {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ProfileFlippedHor Property

[image]

Revit 2024 API
ParameterTypeId..::..ProfileFlippedHor Property
ParameterTypeId Class See Also Send Feedback
"Profile Is Flipped"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ProfileFlippedHor { get; }
Visual Basic
Public Shared ReadOnly Property ProfileFlippedHor As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ProfileFlippedHor {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ProfileOffsetX Property

[image]

Revit 2024 API
ParameterTypeId..::..ProfileOffsetX Property
ParameterTypeId Class See Also Send Feedback
"Horizontal Profile Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ProfileOffsetX { get; }
Visual Basic
Public Shared ReadOnly Property ProfileOffsetX As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ProfileOffsetX {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ProfileOffsetY Property

[image]

Revit 2024 API
ParameterTypeId..::..ProfileOffsetY Property
ParameterTypeId Class See Also Send Feedback
"Vertical Profile Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ProfileOffsetY { get; }
Visual Basic
Public Shared ReadOnly Property ProfileOffsetY As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ProfileOffsetY {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ProfileParamAlongPath Property

[image]

Revit 2024 API
ParameterTypeId..::..ProfileParamAlongPath Property
ParameterTypeId Class See Also Send Feedback
"Parameter along path"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ProfileParamAlongPath { get; }
Visual Basic
Public Shared ReadOnly Property ProfileParamAlongPath As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ProfileParamAlongPath {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ProjectAddress Property

[image]

Revit 2024 API
ParameterTypeId..::..ProjectAddress Property
ParameterTypeId Class See Also Send Feedback
"Project Address"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ProjectAddress { get; }
Visual Basic
Public Shared ReadOnly Property ProjectAddress As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ProjectAddress {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ProjectAuthor Property

[image]

Revit 2024 API
ParameterTypeId..::..ProjectAuthor Property
ParameterTypeId Class See Also Send Feedback
"Author"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ProjectAuthor { get; }
Visual Basic
Public Shared ReadOnly Property ProjectAuthor As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ProjectAuthor {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ProjectBuildingName Property

[image]

Revit 2024 API
ParameterTypeId..::..ProjectBuildingName Property
ParameterTypeId Class See Also Send Feedback
"Building Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ProjectBuildingName { get; }
Visual Basic
Public Shared ReadOnly Property ProjectBuildingName As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ProjectBuildingName {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ProjectName Property

[image]

Revit 2024 API
ParameterTypeId..::..ProjectName Property
ParameterTypeId Class See Also Send Feedback
"Project Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ProjectName { get; }
Visual Basic
Public Shared ReadOnly Property ProjectName As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ProjectName {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ProjectNumber Property

[image]

Revit 2024 API
ParameterTypeId..::..ProjectNumber Property
ParameterTypeId Class See Also Send Feedback
"Project Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ProjectNumber { get; }
Visual Basic
Public Shared ReadOnly Property ProjectNumber As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ProjectNumber {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ProjectOrganizationDescription Property

[image]

Revit 2024 API
ParameterTypeId..::..ProjectOrganizationDescription Property
ParameterTypeId Class See Also Send Feedback
"Organization Description"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ProjectOrganizationDescription { get; }
Visual Basic
Public Shared ReadOnly Property ProjectOrganizationDescription As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ProjectOrganizationDescription {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ProjectOrganizationName Property

[image]

Revit 2024 API
ParameterTypeId..::..ProjectOrganizationName Property
ParameterTypeId Class See Also Send Feedback
"Organization Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ProjectOrganizationName { get; }
Visual Basic
Public Shared ReadOnly Property ProjectOrganizationName As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ProjectOrganizationName {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ProjectPostalCode Property

[image]

Revit 2024 API
ParameterTypeId..::..ProjectPostalCode Property
ParameterTypeId Class See Also Send Feedback
"Postal Code"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ProjectPostalCode { get; }
Visual Basic
Public Shared ReadOnly Property ProjectPostalCode As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ProjectPostalCode {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ProjectRevisionEnumeration Property

[image]

Revit 2024 API
ParameterTypeId..::..ProjectRevisionEnumeration Property
ParameterTypeId Class See Also Send Feedback
"Numbering"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ProjectRevisionEnumeration { get; }
Visual Basic
Public Shared ReadOnly Property ProjectRevisionEnumeration As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ProjectRevisionEnumeration {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ProjectRevisionRevisionDate Property

[image]

Revit 2024 API
ParameterTypeId..::..ProjectRevisionRevisionDate Property
ParameterTypeId Class See Also Send Feedback
"Revision Date"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ProjectRevisionRevisionDate { get; }
Visual Basic
Public Shared ReadOnly Property ProjectRevisionRevisionDate As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ProjectRevisionRevisionDate {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ProjectRevisionRevisionIssued Property

[image]

Revit 2024 API
ParameterTypeId..::..ProjectRevisionRevisionIssued Property
ParameterTypeId Class See Also Send Feedback
"Issued"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ProjectRevisionRevisionIssued { get; }
Visual Basic
Public Shared ReadOnly Property ProjectRevisionRevisionIssued As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ProjectRevisionRevisionIssued {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ProjectRevisionRevisionIssuedTo Property

[image]

Revit 2024 API
ParameterTypeId..::..ProjectRevisionRevisionIssuedTo Property
ParameterTypeId Class See Also Send Feedback
"Issued to"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ProjectRevisionRevisionIssuedTo { get; }
Visual Basic
Public Shared ReadOnly Property ProjectRevisionRevisionIssuedTo As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ProjectRevisionRevisionIssuedTo {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ProjectRevisionRevisionNum Property

[image]

Revit 2024 API
ParameterTypeId..::..ProjectRevisionRevisionNum Property
ParameterTypeId Class See Also Send Feedback
"Revision Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ProjectRevisionRevisionNum { get; }
Visual Basic
Public Shared ReadOnly Property ProjectRevisionRevisionNum As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ProjectRevisionRevisionNum {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ProjectRevisionSequenceNum Property

[image]

Revit 2024 API
ParameterTypeId..::..ProjectRevisionSequenceNum Property
ParameterTypeId Class See Also Send Feedback
"Revision Sequence": read_only Make this read-only again when NewSchedules_DisplayTags is cleaned up

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ProjectRevisionSequenceNum { get; }
Visual Basic
Public Shared ReadOnly Property ProjectRevisionSequenceNum As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ProjectRevisionSequenceNum {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ProjectStatus Property

[image]

Revit 2024 API
ParameterTypeId..::..ProjectStatus Property
ParameterTypeId Class See Also Send Feedback
"Project Status"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ProjectStatus { get; }
Visual Basic
Public Shared ReadOnly Property ProjectStatus As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ProjectStatus {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PropertyArea Property

[image]

Revit 2024 API
ParameterTypeId..::..PropertyArea Property
ParameterTypeId Class See Also Send Feedback
"Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PropertyArea { get; }
Visual Basic
Public Shared ReadOnly Property PropertyArea As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PropertyArea {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PropertyAreaOpen Property

[image]

Revit 2024 API
ParameterTypeId..::..PropertyAreaOpen Property
ParameterTypeId Class See Also Send Feedback
"Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PropertyAreaOpen { get; }
Visual Basic
Public Shared ReadOnly Property PropertyAreaOpen As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PropertyAreaOpen {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PropertyAreaUnits Property

[image]

Revit 2024 API
ParameterTypeId..::..PropertyAreaUnits Property
ParameterTypeId Class See Also Send Feedback
"Area Units, Format"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PropertyAreaUnits { get; }
Visual Basic
Public Shared ReadOnly Property PropertyAreaUnits As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PropertyAreaUnits {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PropertyLengthUnits Property

[image]

Revit 2024 API
ParameterTypeId..::..PropertyLengthUnits Property
ParameterTypeId Class See Also Send Feedback
"Units Format"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PropertyLengthUnits { get; }
Visual Basic
Public Shared ReadOnly Property PropertyLengthUnits As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PropertyLengthUnits {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PropertySegmentBearing Property

[image]

Revit 2024 API
ParameterTypeId..::..PropertySegmentBearing Property
ParameterTypeId Class See Also Send Feedback
"Bearing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PropertySegmentBearing { get; }
Visual Basic
Public Shared ReadOnly Property PropertySegmentBearing As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PropertySegmentBearing {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PropertySegmentDistance Property

[image]

Revit 2024 API
ParameterTypeId..::..PropertySegmentDistance Property
ParameterTypeId Class See Also Send Feedback
"Distance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PropertySegmentDistance { get; }
Visual Basic
Public Shared ReadOnly Property PropertySegmentDistance As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PropertySegmentDistance {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PropertySegmentLR Property

[image]

Revit 2024 API
ParameterTypeId..::..PropertySegmentLR Property
ParameterTypeId Class See Also Send Feedback
"L/R"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PropertySegmentLR { get; }
Visual Basic
Public Shared ReadOnly Property PropertySegmentLR As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PropertySegmentLR {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PropertySegmentNS Property

[image]

Revit 2024 API
ParameterTypeId..::..PropertySegmentNS Property
ParameterTypeId Class See Also Send Feedback
"N/S"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PropertySegmentNS { get; }
Visual Basic
Public Shared ReadOnly Property PropertySegmentNS As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PropertySegmentNS {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PropertySegmentRadius Property

[image]

Revit 2024 API
ParameterTypeId..::..PropertySegmentRadius Property
ParameterTypeId Class See Also Send Feedback
"Radius"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PropertySegmentRadius { get; }
Visual Basic
Public Shared ReadOnly Property PropertySegmentRadius As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PropertySegmentRadius {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PropertySegmentSubcategoryId Property

[image]

Revit 2024 API
ParameterTypeId..::..PropertySegmentSubcategoryId Property
ParameterTypeId Class See Also Send Feedback
"Subcategory"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PropertySegmentSubcategoryId { get; }
Visual Basic
Public Shared ReadOnly Property PropertySegmentSubcategoryId As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PropertySegmentSubcategoryId {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PropertySetDescription Property

[image]

Revit 2024 API
ParameterTypeId..::..PropertySetDescription Property
ParameterTypeId Class See Also Send Feedback
"Description"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PropertySetDescription { get; }
Visual Basic
Public Shared ReadOnly Property PropertySetDescription As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PropertySetDescription {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PropertySetKeywords Property

[image]

Revit 2024 API
ParameterTypeId..::..PropertySetKeywords Property
ParameterTypeId Class See Also Send Feedback
"Keywords"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PropertySetKeywords { get; }
Visual Basic
Public Shared ReadOnly Property PropertySetKeywords As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PropertySetKeywords {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PropertySetMaterialAspect Property

[image]

Revit 2024 API
ParameterTypeId..::..PropertySetMaterialAspect Property
ParameterTypeId Class See Also Send Feedback
"Material aspect"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PropertySetMaterialAspect { get; }
Visual Basic
Public Shared ReadOnly Property PropertySetMaterialAspect As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PropertySetMaterialAspect {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


PropertySetName Property

[image]

Revit 2024 API
ParameterTypeId..::..PropertySetName Property
ParameterTypeId Class See Also Send Feedback
"Property Set Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId PropertySetName { get; }
Visual Basic
Public Shared ReadOnly Property PropertySetName As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PropertySetName {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RadialArrayArcRadius Property

[image]

Revit 2024 API
ParameterTypeId..::..RadialArrayArcRadius Property
ParameterTypeId Class See Also Send Feedback
"Radius"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RadialArrayArcRadius { get; }
Visual Basic
Public Shared ReadOnly Property RadialArrayArcRadius As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RadialArrayArcRadius {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RadiusSymbolLocation Property

[image]

Revit 2024 API
ParameterTypeId..::..RadiusSymbolLocation Property
ParameterTypeId Class See Also Send Feedback
"Radius Symbol Location"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RadiusSymbolLocation { get; }
Visual Basic
Public Shared ReadOnly Property RadiusSymbolLocation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RadiusSymbolLocation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RailingSystemHandrailsHeightParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RailingSystemHandrailsHeightParam Property
ParameterTypeId Class See Also Send Feedback
"Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RailingSystemHandrailsHeightParam { get; }
Visual Basic
Public Shared ReadOnly Property RailingSystemHandrailsHeightParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RailingSystemHandrailsHeightParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RailingSystemHandrailsPositionParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RailingSystemHandrailsPositionParam Property
ParameterTypeId Class See Also Send Feedback
"Position"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RailingSystemHandrailsPositionParam { get; }
Visual Basic
Public Shared ReadOnly Property RailingSystemHandrailsPositionParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RailingSystemHandrailsPositionParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RailingSystemHandrailsTypesParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RailingSystemHandrailsTypesParam Property
ParameterTypeId Class See Also Send Feedback
"Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RailingSystemHandrailsTypesParam { get; }
Visual Basic
Public Shared ReadOnly Property RailingSystemHandrailsTypesParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RailingSystemHandrailsTypesParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RailingSystemHasTopRail Property

[image]

Revit 2024 API
ParameterTypeId..::..RailingSystemHasTopRail Property
ParameterTypeId Class See Also Send Feedback
"Use Top Rail": Whether railing has top rail

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RailingSystemHasTopRail { get; }
Visual Basic
Public Shared ReadOnly Property RailingSystemHasTopRail As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RailingSystemHasTopRail {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RailingSystemSecondaryHandrailsHeightParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RailingSystemSecondaryHandrailsHeightParam Property
ParameterTypeId Class See Also Send Feedback
"Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RailingSystemSecondaryHandrailsHeightParam { get; }
Visual Basic
Public Shared ReadOnly Property RailingSystemSecondaryHandrailsHeightParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RailingSystemSecondaryHandrailsHeightParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RailingSystemSecondaryHandrailsPositionParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RailingSystemSecondaryHandrailsPositionParam Property
ParameterTypeId Class See Also Send Feedback
"Position"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RailingSystemSecondaryHandrailsPositionParam { get; }
Visual Basic
Public Shared ReadOnly Property RailingSystemSecondaryHandrailsPositionParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RailingSystemSecondaryHandrailsPositionParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RailingSystemTopRailHeightParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RailingSystemTopRailHeightParam Property
ParameterTypeId Class See Also Send Feedback
"Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RailingSystemTopRailHeightParam { get; }
Visual Basic
Public Shared ReadOnly Property RailingSystemTopRailHeightParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RailingSystemTopRailHeightParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RailingSystemTopRailTypesParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RailingSystemTopRailTypesParam Property
ParameterTypeId Class See Also Send Feedback
"Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RailingSystemTopRailTypesParam { get; }
Visual Basic
Public Shared ReadOnly Property RailingSystemTopRailTypesParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RailingSystemTopRailTypesParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RampAttrLeftBalusterAttachPt Property

[image]

Revit 2024 API
ParameterTypeId..::..RampAttrLeftBalusterAttachPt Property
ParameterTypeId Class See Also Send Feedback
"Left Baluster Location"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RampAttrLeftBalusterAttachPt { get; }
Visual Basic
Public Shared ReadOnly Property RampAttrLeftBalusterAttachPt As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RampAttrLeftBalusterAttachPt {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RampAttrMaterial Property

[image]

Revit 2024 API
ParameterTypeId..::..RampAttrMaterial Property
ParameterTypeId Class See Also Send Feedback
"Ramp Material"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RampAttrMaterial { get; }
Visual Basic
Public Shared ReadOnly Property RampAttrMaterial As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RampAttrMaterial {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RampAttrMinInvSlope Property

[image]

Revit 2024 API
ParameterTypeId..::..RampAttrMinInvSlope Property
ParameterTypeId Class See Also Send Feedback
"Ramp Max Slope (1/x)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RampAttrMinInvSlope { get; }
Visual Basic
Public Shared ReadOnly Property RampAttrMinInvSlope As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RampAttrMinInvSlope {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RampAttrShape Property

[image]

Revit 2024 API
ParameterTypeId..::..RampAttrShape Property
ParameterTypeId Class See Also Send Feedback
"Shape"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RampAttrShape { get; }
Visual Basic
Public Shared ReadOnly Property RampAttrShape As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RampAttrShape {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RampAttrTextFont Property

[image]

Revit 2024 API
ParameterTypeId..::..RampAttrTextFont Property
ParameterTypeId Class See Also Send Feedback
"Text Font"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RampAttrTextFont { get; }
Visual Basic
Public Shared ReadOnly Property RampAttrTextFont As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RampAttrTextFont {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RampMaxRunLength Property

[image]

Revit 2024 API
ParameterTypeId..::..RampMaxRunLength Property
ParameterTypeId Class See Also Send Feedback
"Maximum Incline Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RampMaxRunLength { get; }
Visual Basic
Public Shared ReadOnly Property RampMaxRunLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RampMaxRunLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RasterEnableSnaps Property

[image]

Revit 2024 API
ParameterTypeId..::..RasterEnableSnaps Property
ParameterTypeId Class See Also Send Feedback
"Enable Snaps"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RasterEnableSnaps { get; }
Visual Basic
Public Shared ReadOnly Property RasterEnableSnaps As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RasterEnableSnaps {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RasterHorizontalScale Property

[image]

Revit 2024 API
ParameterTypeId..::..RasterHorizontalScale Property
ParameterTypeId Class See Also Send Feedback
"Horizontal Scale"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RasterHorizontalScale { get; }
Visual Basic
Public Shared ReadOnly Property RasterHorizontalScale As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RasterHorizontalScale {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RasterLockProportions Property

[image]

Revit 2024 API
ParameterTypeId..::..RasterLockProportions Property
ParameterTypeId Class See Also Send Feedback
"Lock Proportions"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RasterLockProportions { get; }
Visual Basic
Public Shared ReadOnly Property RasterLockProportions As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RasterLockProportions {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RasterSheetheight Property

[image]

Revit 2024 API
ParameterTypeId..::..RasterSheetheight Property
ParameterTypeId Class See Also Send Feedback
"Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RasterSheetheight { get; }
Visual Basic
Public Shared ReadOnly Property RasterSheetheight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RasterSheetheight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RasterSheetwidth Property

[image]

Revit 2024 API
ParameterTypeId..::..RasterSheetwidth Property
ParameterTypeId Class See Also Send Feedback
"Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RasterSheetwidth { get; }
Visual Basic
Public Shared ReadOnly Property RasterSheetwidth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RasterSheetwidth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RasterSymbolFilename Property

[image]

Revit 2024 API
ParameterTypeId..::..RasterSymbolFilename Property
ParameterTypeId Class See Also Send Feedback
"Loaded from file"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RasterSymbolFilename { get; }
Visual Basic
Public Shared ReadOnly Property RasterSymbolFilename As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RasterSymbolFilename {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RasterSymbolHeight Property

[image]

Revit 2024 API
ParameterTypeId..::..RasterSymbolHeight Property
ParameterTypeId Class See Also Send Feedback
"Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RasterSymbolHeight { get; }
Visual Basic
Public Shared ReadOnly Property RasterSymbolHeight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RasterSymbolHeight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RasterSymbolPagenumber Property

[image]

Revit 2024 API
ParameterTypeId..::..RasterSymbolPagenumber Property
ParameterTypeId Class See Also Send Feedback
"Page Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RasterSymbolPagenumber { get; }
Visual Basic
Public Shared ReadOnly Property RasterSymbolPagenumber As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RasterSymbolPagenumber {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RasterSymbolPixelheight Property

[image]

Revit 2024 API
ParameterTypeId..::..RasterSymbolPixelheight Property
ParameterTypeId Class See Also Send Feedback
"Height (pixels)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RasterSymbolPixelheight { get; }
Visual Basic
Public Shared ReadOnly Property RasterSymbolPixelheight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RasterSymbolPixelheight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RasterSymbolPixelwidth Property

[image]

Revit 2024 API
ParameterTypeId..::..RasterSymbolPixelwidth Property
ParameterTypeId Class See Also Send Feedback
"Width (pixels)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RasterSymbolPixelwidth { get; }
Visual Basic
Public Shared ReadOnly Property RasterSymbolPixelwidth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RasterSymbolPixelwidth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RasterSymbolResolution Property

[image]

Revit 2024 API
ParameterTypeId..::..RasterSymbolResolution Property
ParameterTypeId Class See Also Send Feedback
"Resolution (dpi)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RasterSymbolResolution { get; }
Visual Basic
Public Shared ReadOnly Property RasterSymbolResolution As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RasterSymbolResolution {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RasterVerticalScale Property

[image]

Revit 2024 API
ParameterTypeId..::..RasterVerticalScale Property
ParameterTypeId Class See Also Send Feedback
"Vertical Scale"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RasterVerticalScale { get; }
Visual Basic
Public Shared ReadOnly Property RasterVerticalScale As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RasterVerticalScale {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsAdditionalFlow Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsAdditionalFlow Property
ParameterTypeId Class See Also Send Feedback
"Additional Flow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsAdditionalFlow { get; }
Visual Basic
Public Shared ReadOnly Property RbsAdditionalFlow As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsAdditionalFlow {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsAdjustableConnector Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsAdjustableConnector Property
ParameterTypeId Class See Also Send Feedback
"Allow Slope Adjustments"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsAdjustableConnector { get; }
Visual Basic
Public Shared ReadOnly Property RbsAdjustableConnector As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsAdjustableConnector {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsAreaBasedLoadType Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsAreaBasedLoadType Property
ParameterTypeId Class See Also Send Feedback
"Area Based Load Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsAreaBasedLoadType { get; }
Visual Basic
Public Shared ReadOnly Property RbsAreaBasedLoadType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsAreaBasedLoadType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsBuildingConstructionclass Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsBuildingConstructionclass Property
ParameterTypeId Class See Also Send Feedback
"Building Infiltration Class"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsBuildingConstructionclass { get; }
Visual Basic
Public Shared ReadOnly Property RbsBuildingConstructionclass As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsBuildingConstructionclass {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsBuildingUseloadcredits Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsBuildingUseloadcredits Property
ParameterTypeId Class See Also Send Feedback
"Use Load Credits"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsBuildingUseloadcredits { get; }
Visual Basic
Public Shared ReadOnly Property RbsBuildingUseloadcredits As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsBuildingUseloadcredits {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsCabletrayBendradius Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsCabletrayBendradius Property
ParameterTypeId Class See Also Send Feedback
"Bend Radius"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsCabletrayBendradius { get; }
Visual Basic
Public Shared ReadOnly Property RbsCabletrayBendradius As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsCabletrayBendradius {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsCabletrayconduitBendorfitting Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsCabletrayconduitBendorfitting Property
ParameterTypeId Class See Also Send Feedback
"Bend or Fitting"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsCabletrayconduitBendorfitting { get; }
Visual Basic
Public Shared ReadOnly Property RbsCabletrayconduitBendorfitting As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsCabletrayconduitBendorfitting {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsCabletrayconduitConnectorelemType Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsCabletrayconduitConnectorelemType Property
ParameterTypeId Class See Also Send Feedback
"Connector Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsCabletrayconduitConnectorelemType { get; }
Visual Basic
Public Shared ReadOnly Property RbsCabletrayconduitConnectorelemType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsCabletrayconduitConnectorelemType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsCabletrayconduitrunLengthParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsCabletrayconduitrunLengthParam Property
ParameterTypeId Class See Also Send Feedback
"Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsCabletrayconduitrunLengthParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsCabletrayconduitrunLengthParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsCabletrayconduitrunLengthParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsCabletrayconduitSystemType Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsCabletrayconduitSystemType Property
ParameterTypeId Class See Also Send Feedback
"System Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsCabletrayconduitSystemType { get; }
Visual Basic
Public Shared ReadOnly Property RbsCabletrayconduitSystemType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsCabletrayconduitSystemType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsCabletrayRungspace Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsCabletrayRungspace Property
ParameterTypeId Class See Also Send Feedback
"Rung Space"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsCabletrayRungspace { get; }
Visual Basic
Public Shared ReadOnly Property RbsCabletrayRungspace As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsCabletrayRungspace {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsCabletrayRungwidth Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsCabletrayRungwidth Property
ParameterTypeId Class See Also Send Feedback
"Rung Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsCabletrayRungwidth { get; }
Visual Basic
Public Shared ReadOnly Property RbsCabletrayRungwidth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsCabletrayRungwidth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsCabletrayrunHeightParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsCabletrayrunHeightParam Property
ParameterTypeId Class See Also Send Feedback
"Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsCabletrayrunHeightParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsCabletrayrunHeightParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsCabletrayrunHeightParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsCabletrayrunWidthParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsCabletrayrunWidthParam Property
ParameterTypeId Class See Also Send Feedback
"Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsCabletrayrunWidthParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsCabletrayrunWidthParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsCabletrayrunWidthParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsCabletrayShapetype Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsCabletrayShapetype Property
ParameterTypeId Class See Also Send Feedback
"Shape"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsCabletrayShapetype { get; }
Visual Basic
Public Shared ReadOnly Property RbsCabletrayShapetype As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsCabletrayShapetype {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsCabletrayThickness Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsCabletrayThickness Property
ParameterTypeId Class See Also Send Feedback
"Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsCabletrayThickness { get; }
Visual Basic
Public Shared ReadOnly Property RbsCabletrayThickness As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsCabletrayThickness {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsCabletrayWidthParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsCabletrayWidthParam Property
ParameterTypeId Class See Also Send Feedback
"Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsCabletrayWidthParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsCabletrayWidthParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsCabletrayWidthParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsConduitBendradius Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsConduitBendradius Property
ParameterTypeId Class See Also Send Feedback
"Bend Radius"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsConduitBendradius { get; }
Visual Basic
Public Shared ReadOnly Property RbsConduitBendradius As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsConduitBendradius {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsConduitDiameterParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsConduitDiameterParam Property
ParameterTypeId Class See Also Send Feedback
"Diameter(Trade Size)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsConduitDiameterParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsConduitDiameterParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsConduitDiameterParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsConduitOuterDiamParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsConduitOuterDiamParam Property
ParameterTypeId Class See Also Send Feedback
"Outside Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsConduitOuterDiamParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsConduitOuterDiamParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsConduitOuterDiamParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsConduitrunDiameterParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsConduitrunDiameterParam Property
ParameterTypeId Class See Also Send Feedback
"Diameter(Trade Size)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsConduitrunDiameterParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsConduitrunDiameterParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsConduitrunDiameterParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsConduitrunInnerDiamParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsConduitrunInnerDiamParam Property
ParameterTypeId Class See Also Send Feedback
"Inside Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsConduitrunInnerDiamParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsConduitrunInnerDiamParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsConduitrunInnerDiamParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsConduitrunOuterDiamParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsConduitrunOuterDiamParam Property
ParameterTypeId Class See Also Send Feedback
"Outside Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsConduitrunOuterDiamParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsConduitrunOuterDiamParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsConduitrunOuterDiamParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsConnectorDescription Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsConnectorDescription Property
ParameterTypeId Class See Also Send Feedback
"Connector Description"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsConnectorDescription { get; }
Visual Basic
Public Shared ReadOnly Property RbsConnectorDescription As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsConnectorDescription {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsConnectorOffsetObsolete Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsConnectorOffsetObsolete Property
ParameterTypeId Class See Also Send Feedback
"Connector Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsConnectorOffsetObsolete { get; }
Visual Basic
Public Shared ReadOnly Property RbsConnectorOffsetObsolete As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsConnectorOffsetObsolete {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsConstructionSetParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsConstructionSetParam Property
ParameterTypeId Class See Also Send Feedback
"Schematic Types"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsConstructionSetParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsConstructionSetParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsConstructionSetParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsConstructionTypeShadingfactorParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsConstructionTypeShadingfactorParam Property
ParameterTypeId Class See Also Send Feedback
"Internal Shading Factor"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsConstructionTypeShadingfactorParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsConstructionTypeShadingfactorParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsConstructionTypeShadingfactorParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsCtcBottomElevation Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsCtcBottomElevation Property
ParameterTypeId Class See Also Send Feedback
"Lower End Bottom Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsCtcBottomElevation { get; }
Visual Basic
Public Shared ReadOnly Property RbsCtcBottomElevation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsCtcBottomElevation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsCtcServiceType Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsCtcServiceType Property
ParameterTypeId Class See Also Send Feedback
"Service Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsCtcServiceType { get; }
Visual Basic
Public Shared ReadOnly Property RbsCtcServiceType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsCtcServiceType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsCtcTopElevation Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsCtcTopElevation Property
ParameterTypeId Class See Also Send Feedback
"Upper End Top Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsCtcTopElevation { get; }
Visual Basic
Public Shared ReadOnly Property RbsCtcTopElevation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsCtcTopElevation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsCurveDiameterParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsCurveDiameterParam Property
ParameterTypeId Class See Also Send Feedback
"Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsCurveDiameterParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsCurveDiameterParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsCurveDiameterParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsCurveHeightParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsCurveHeightParam Property
ParameterTypeId Class See Also Send Feedback
"Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsCurveHeightParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsCurveHeightParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsCurveHeightParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsCurvetypeDefaultBendParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsCurvetypeDefaultBendParam Property
ParameterTypeId Class See Also Send Feedback
"Bend"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsCurvetypeDefaultBendParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsCurvetypeDefaultBendParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsCurvetypeDefaultBendParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsCurvetypeDefaultCrossParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsCurvetypeDefaultCrossParam Property
ParameterTypeId Class See Also Send Feedback
"Cross"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsCurvetypeDefaultCrossParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsCurvetypeDefaultCrossParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsCurvetypeDefaultCrossParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsCurvetypeDefaultElbowParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsCurvetypeDefaultElbowParam Property
ParameterTypeId Class See Also Send Feedback
"Elbow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsCurvetypeDefaultElbowParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsCurvetypeDefaultElbowParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsCurvetypeDefaultElbowParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsCurvetypeDefaultElbowupParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsCurvetypeDefaultElbowupParam Property
ParameterTypeId Class See Also Send Feedback
"Vertical Inside Bend"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsCurvetypeDefaultElbowupParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsCurvetypeDefaultElbowupParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsCurvetypeDefaultElbowupParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsCurvetypeDefaultHorizontalBendParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsCurvetypeDefaultHorizontalBendParam Property
ParameterTypeId Class See Also Send Feedback
"Horizontal Bend"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsCurvetypeDefaultHorizontalBendParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsCurvetypeDefaultHorizontalBendParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsCurvetypeDefaultHorizontalBendParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsCurvetypeDefaultMechjointParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsCurvetypeDefaultMechjointParam Property
ParameterTypeId Class See Also Send Feedback
"Flange"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsCurvetypeDefaultMechjointParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsCurvetypeDefaultMechjointParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsCurvetypeDefaultMechjointParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsCurvetypeDefaultTakeoffParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsCurvetypeDefaultTakeoffParam Property
ParameterTypeId Class See Also Send Feedback
"Tap"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsCurvetypeDefaultTakeoffParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsCurvetypeDefaultTakeoffParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsCurvetypeDefaultTakeoffParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsCurvetypeDefaultTeedownParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsCurvetypeDefaultTeedownParam Property
ParameterTypeId Class See Also Send Feedback
"Tee Down"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsCurvetypeDefaultTeedownParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsCurvetypeDefaultTeedownParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsCurvetypeDefaultTeedownParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsCurvetypeDefaultTeeParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsCurvetypeDefaultTeeParam Property
ParameterTypeId Class See Also Send Feedback
"Tee"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsCurvetypeDefaultTeeParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsCurvetypeDefaultTeeParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsCurvetypeDefaultTeeParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsCurvetypeDefaultTeeupParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsCurvetypeDefaultTeeupParam Property
ParameterTypeId Class See Also Send Feedback
"Tee Up"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsCurvetypeDefaultTeeupParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsCurvetypeDefaultTeeupParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsCurvetypeDefaultTeeupParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsCurvetypeDefaultTransitionParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsCurvetypeDefaultTransitionParam Property
ParameterTypeId Class See Also Send Feedback
"Transition"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsCurvetypeDefaultTransitionParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsCurvetypeDefaultTransitionParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsCurvetypeDefaultTransitionParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsCurvetypeDefaultUnionParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsCurvetypeDefaultUnionParam Property
ParameterTypeId Class See Also Send Feedback
"Union"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsCurvetypeDefaultUnionParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsCurvetypeDefaultUnionParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsCurvetypeDefaultUnionParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsCurvetypeMaxWidthParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsCurvetypeMaxWidthParam Property
ParameterTypeId Class See Also Send Feedback
"Max Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsCurvetypeMaxWidthParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsCurvetypeMaxWidthParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsCurvetypeMaxWidthParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsCurvetypeMultishapeTransitionOvalroundParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsCurvetypeMultishapeTransitionOvalroundParam Property
ParameterTypeId Class See Also Send Feedback
"Multi Shape Transition Oval to Round"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsCurvetypeMultishapeTransitionOvalroundParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsCurvetypeMultishapeTransitionOvalroundParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsCurvetypeMultishapeTransitionOvalroundParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsCurvetypeMultishapeTransitionParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsCurvetypeMultishapeTransitionParam Property
ParameterTypeId Class See Also Send Feedback
"Multi Shape Transition Rect to Round"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsCurvetypeMultishapeTransitionParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsCurvetypeMultishapeTransitionParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsCurvetypeMultishapeTransitionParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsCurvetypeMultishapeTransitionRectovalParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsCurvetypeMultishapeTransitionRectovalParam Property
ParameterTypeId Class See Also Send Feedback
"Multi Shape Transition Rect to Oval"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsCurvetypeMultishapeTransitionRectovalParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsCurvetypeMultishapeTransitionRectovalParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsCurvetypeMultishapeTransitionRectovalParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsCurvetypePreferredBranchParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsCurvetypePreferredBranchParam Property
ParameterTypeId Class See Also Send Feedback
"Preferred Junction Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsCurvetypePreferredBranchParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsCurvetypePreferredBranchParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsCurvetypePreferredBranchParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsCurveUtslope Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsCurveUtslope Property
ParameterTypeId Class See Also Send Feedback
"Slope"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsCurveUtslope { get; }
Visual Basic
Public Shared ReadOnly Property RbsCurveUtslope As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsCurveUtslope {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsCurveVertOffsetParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsCurveVertOffsetParam Property
ParameterTypeId Class See Also Send Feedback
"Vertical Justification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsCurveVertOffsetParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsCurveVertOffsetParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsCurveVertOffsetParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsDistributionsysConfigParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsDistributionsysConfigParam Property
ParameterTypeId Class See Also Send Feedback
"Configuration"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsDistributionsysConfigParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsDistributionsysConfigParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsDistributionsysConfigParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsDistributionsysNumwiresParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsDistributionsysNumwiresParam Property
ParameterTypeId Class See Also Send Feedback
"Wires"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsDistributionsysNumwiresParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsDistributionsysNumwiresParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsDistributionsysNumwiresParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsDistributionsysPhaseParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsDistributionsysPhaseParam Property
ParameterTypeId Class See Also Send Feedback
"Phase"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsDistributionsysPhaseParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsDistributionsysPhaseParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsDistributionsysPhaseParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsDistributionsysVlgParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsDistributionsysVlgParam Property
ParameterTypeId Class See Also Send Feedback
"Line to Ground Voltage"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsDistributionsysVlgParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsDistributionsysVlgParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsDistributionsysVlgParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsDistributionsysVllParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsDistributionsysVllParam Property
ParameterTypeId Class See Also Send Feedback
"Line to Line Voltage"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsDistributionsysVllParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsDistributionsysVllParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsDistributionsysVllParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsDuctBottomElevation Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsDuctBottomElevation Property
ParameterTypeId Class See Also Send Feedback
"Lower End Bottom Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsDuctBottomElevation { get; }
Visual Basic
Public Shared ReadOnly Property RbsDuctBottomElevation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsDuctBottomElevation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsDuctCalculatedSize Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsDuctCalculatedSize Property
ParameterTypeId Class See Also Send Feedback
"Duct Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsDuctCalculatedSize { get; }
Visual Basic
Public Shared ReadOnly Property RbsDuctCalculatedSize As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsDuctCalculatedSize {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsDuctFittingLossMethodParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsDuctFittingLossMethodParam Property
ParameterTypeId Class See Also Send Feedback
"Loss Method"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsDuctFittingLossMethodParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsDuctFittingLossMethodParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsDuctFittingLossMethodParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsDuctFittingLossMethodServerParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsDuctFittingLossMethodServerParam Property
ParameterTypeId Class See Also Send Feedback
"Loss Method"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsDuctFittingLossMethodServerParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsDuctFittingLossMethodServerParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsDuctFittingLossMethodServerParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsDuctFlowConfigurationParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsDuctFlowConfigurationParam Property
ParameterTypeId Class See Also Send Feedback
"Flow Configuration"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsDuctFlowConfigurationParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsDuctFlowConfigurationParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsDuctFlowConfigurationParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsDuctFlowDirectionParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsDuctFlowDirectionParam Property
ParameterTypeId Class See Also Send Feedback
"Flow Direction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsDuctFlowDirectionParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsDuctFlowDirectionParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsDuctFlowDirectionParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsDuctFlowParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsDuctFlowParam Property
ParameterTypeId Class See Also Send Feedback
"Flow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsDuctFlowParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsDuctFlowParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsDuctFlowParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsDuctPipeSystemAbbreviationParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsDuctPipeSystemAbbreviationParam Property
ParameterTypeId Class See Also Send Feedback
"System Abbreviation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsDuctPipeSystemAbbreviationParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsDuctPipeSystemAbbreviationParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsDuctPipeSystemAbbreviationParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsDuctRoutingPreferenceParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsDuctRoutingPreferenceParam Property
ParameterTypeId Class See Also Send Feedback
"Routing Preferences"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsDuctRoutingPreferenceParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsDuctRoutingPreferenceParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsDuctRoutingPreferenceParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsDuctSizeFormattedParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsDuctSizeFormattedParam Property
ParameterTypeId Class See Also Send Feedback
"Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsDuctSizeFormattedParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsDuctSizeFormattedParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsDuctSizeFormattedParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsDuctSlope Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsDuctSlope Property
ParameterTypeId Class See Also Send Feedback
"Slope"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsDuctSlope { get; }
Visual Basic
Public Shared ReadOnly Property RbsDuctSlope As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsDuctSlope {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsDuctStaticPressure Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsDuctStaticPressure Property
ParameterTypeId Class See Also Send Feedback
"Static Pressure"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsDuctStaticPressure { get; }
Visual Basic
Public Shared ReadOnly Property RbsDuctStaticPressure As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsDuctStaticPressure {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsDuctSystemCalculationParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsDuctSystemCalculationParam Property
ParameterTypeId Class See Also Send Feedback
"Calculations"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsDuctSystemCalculationParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsDuctSystemCalculationParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsDuctSystemCalculationParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsDuctSystemTypeParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsDuctSystemTypeParam Property
ParameterTypeId Class See Also Send Feedback
"System Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsDuctSystemTypeParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsDuctSystemTypeParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsDuctSystemTypeParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsDuctTopElevation Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsDuctTopElevation Property
ParameterTypeId Class See Also Send Feedback
"Upper End Top Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsDuctTopElevation { get; }
Visual Basic
Public Shared ReadOnly Property RbsDuctTopElevation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsDuctTopElevation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsDuctTypeParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsDuctTypeParam Property
ParameterTypeId Class See Also Send Feedback
"Duct Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsDuctTypeParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsDuctTypeParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsDuctTypeParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecAmbientTemperature Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecAmbientTemperature Property
ParameterTypeId Class See Also Send Feedback
"Ambient Temperature"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecAmbientTemperature { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecAmbientTemperature As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecAmbientTemperature {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecAnalyticalArea Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecAnalyticalArea Property
ParameterTypeId Class See Also Send Feedback
"Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecAnalyticalArea { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecAnalyticalArea As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecAnalyticalArea {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecAnalyticalFeederLength Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecAnalyticalFeederLength Property
ParameterTypeId Class See Also Send Feedback
"Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecAnalyticalFeederLength { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecAnalyticalFeederLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecAnalyticalFeederLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecAnalyticalLoadDensity Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecAnalyticalLoadDensity Property
ParameterTypeId Class See Also Send Feedback
"Power Density"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecAnalyticalLoadDensity { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecAnalyticalLoadDensity As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecAnalyticalLoadDensity {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecAnalyticalLoadNameParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecAnalyticalLoadNameParam Property
ParameterTypeId Class See Also Send Feedback
"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecAnalyticalLoadNameParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecAnalyticalLoadNameParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecAnalyticalLoadNameParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecAnalyticalLoadSetOnDuty Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecAnalyticalLoadSetOnDuty Property
ParameterTypeId Class See Also Send Feedback
"Quantity of Prime"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecAnalyticalLoadSetOnDuty { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecAnalyticalLoadSetOnDuty As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecAnalyticalLoadSetOnDuty {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecAnalyticalLoadSetOnTotal Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecAnalyticalLoadSetOnTotal Property
ParameterTypeId Class See Also Send Feedback
"Total Quantity"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecAnalyticalLoadSetOnTotal { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecAnalyticalLoadSetOnTotal As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecAnalyticalLoadSetOnTotal {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecAnalyticalLoadsInSet Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecAnalyticalLoadsInSet Property
ParameterTypeId Class See Also Send Feedback
"Loads in Set"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecAnalyticalLoadsInSet { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecAnalyticalLoadsInSet As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecAnalyticalLoadsInSet {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecAnalyticalTotalCoincidentLoad Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecAnalyticalTotalCoincidentLoad Property
ParameterTypeId Class See Also Send Feedback
"Total Coincident Loads"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecAnalyticalTotalCoincidentLoad { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecAnalyticalTotalCoincidentLoad As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecAnalyticalTotalCoincidentLoad {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecApparentCurrentParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecApparentCurrentParam Property
ParameterTypeId Class See Also Send Feedback
"Apparent Current"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecApparentCurrentParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecApparentCurrentParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecApparentCurrentParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecApparentCurrentPhaseaParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecApparentCurrentPhaseaParam Property
ParameterTypeId Class See Also Send Feedback
"Apparent Current Phase A"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecApparentCurrentPhaseaParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecApparentCurrentPhaseaParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecApparentCurrentPhaseaParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecApparentCurrentPhasecParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecApparentCurrentPhasecParam Property
ParameterTypeId Class See Also Send Feedback
"Apparent Current Phase C"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecApparentCurrentPhasecParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecApparentCurrentPhasecParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecApparentCurrentPhasecParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecApparentLoad Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecApparentLoad Property
ParameterTypeId Class See Also Send Feedback
"Apparent Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecApparentLoad { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecApparentLoad As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecApparentLoad {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecApparentLoadPhase1 Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecApparentLoadPhase1 Property
ParameterTypeId Class See Also Send Feedback
"Apparent Load Phase 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecApparentLoadPhase1 { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecApparentLoadPhase1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecApparentLoadPhase1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecApparentLoadPhase2 Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecApparentLoadPhase2 Property
ParameterTypeId Class See Also Send Feedback
"Apparent Load Phase 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecApparentLoadPhase2 { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecApparentLoadPhase2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecApparentLoadPhase2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecApparentLoadPhase3 Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecApparentLoadPhase3 Property
ParameterTypeId Class See Also Send Feedback
"Apparent Load Phase 3"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecApparentLoadPhase3 { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecApparentLoadPhase3 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecApparentLoadPhase3 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecApparentLoadPhasea Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecApparentLoadPhasea Property
ParameterTypeId Class See Also Send Feedback
"Apparent Load Phase A"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecApparentLoadPhasea { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecApparentLoadPhasea As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecApparentLoadPhasea {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecApparentLoadPhaseb Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecApparentLoadPhaseb Property
ParameterTypeId Class See Also Send Feedback
"Apparent Load Phase B"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecApparentLoadPhaseb { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecApparentLoadPhaseb As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecApparentLoadPhaseb {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecApparentLoadPhasec Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecApparentLoadPhasec Property
ParameterTypeId Class See Also Send Feedback
"Apparent Load Phase C"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecApparentLoadPhasec { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecApparentLoadPhasec As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecApparentLoadPhasec {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecApparentPowerDensity Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecApparentPowerDensity Property
ParameterTypeId Class See Also Send Feedback
"Apparent Power Density"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecApparentPowerDensity { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecApparentPowerDensity As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecApparentPowerDensity {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecBalancedLoad Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecBalancedLoad Property
ParameterTypeId Class See Also Send Feedback
"Balanced Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecBalancedLoad { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecBalancedLoad As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecBalancedLoad {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecCalcCoefficientUtilization Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecCalcCoefficientUtilization Property
ParameterTypeId Class See Also Send Feedback
"Calculate Coefficient of Utilization"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecCalcCoefficientUtilization { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecCalcCoefficientUtilization As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecCalcCoefficientUtilization {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecCircuitName Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecCircuitName Property
ParameterTypeId Class See Also Send Feedback
"Load Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecCircuitName { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecCircuitName As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecCircuitName {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecCircuitNaming Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecCircuitNaming Property
ParameterTypeId Class See Also Send Feedback
"Circuit Naming"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecCircuitNaming { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecCircuitNaming As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecCircuitNaming {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecCircuitNotesParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecCircuitNotesParam Property
ParameterTypeId Class See Also Send Feedback
"Schedule Circuit Notes"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecCircuitNotesParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecCircuitNotesParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecCircuitNotesParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecCircuitNumber Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecCircuitNumber Property
ParameterTypeId Class See Also Send Feedback
"Circuit Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecCircuitNumber { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecCircuitNumber As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecCircuitNumber {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecCircuitNumberOfElementsParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecCircuitNumberOfElementsParam Property
ParameterTypeId Class See Also Send Feedback
"Number of Elements"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecCircuitNumberOfElementsParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecCircuitNumberOfElementsParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecCircuitNumberOfElementsParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecCircuitPanelParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecCircuitPanelParam Property
ParameterTypeId Class See Also Send Feedback
"Panel"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecCircuitPanelParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecCircuitPanelParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecCircuitPanelParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecCircuitPathModeParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecCircuitPathModeParam Property
ParameterTypeId Class See Also Send Feedback
"Path Mode"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecCircuitPathModeParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecCircuitPathModeParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecCircuitPathModeParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecCircuitPathOffsetParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecCircuitPathOffsetParam Property
ParameterTypeId Class See Also Send Feedback
"Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecCircuitPathOffsetParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecCircuitPathOffsetParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecCircuitPathOffsetParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecCircuitPrefix Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecCircuitPrefix Property
ParameterTypeId Class See Also Send Feedback
"Circuit Prefix"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecCircuitPrefix { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecCircuitPrefix As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecCircuitPrefix {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecCircuitPrefixSeparator Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecCircuitPrefixSeparator Property
ParameterTypeId Class See Also Send Feedback
"Circuit Prefix Separator"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecCircuitPrefixSeparator { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecCircuitPrefixSeparator As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecCircuitPrefixSeparator {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecCircuitRatingParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecCircuitRatingParam Property
ParameterTypeId Class See Also Send Feedback
"Rating"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecCircuitRatingParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecCircuitRatingParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecCircuitRatingParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecCircuitSlotIndex Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecCircuitSlotIndex Property
ParameterTypeId Class See Also Send Feedback
"Slot Index"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecCircuitSlotIndex { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecCircuitSlotIndex As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecCircuitSlotIndex {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecCircuitStartSlot Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecCircuitStartSlot Property
ParameterTypeId Class See Also Send Feedback
"Start Slot"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecCircuitStartSlot { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecCircuitStartSlot As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecCircuitStartSlot {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecCircuitWireNumHotsParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecCircuitWireNumHotsParam Property
ParameterTypeId Class See Also Send Feedback
"# of Hot Conductors"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecCircuitWireNumHotsParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecCircuitWireNumHotsParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecCircuitWireNumHotsParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecCircuitWireNumNeutralsParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecCircuitWireNumNeutralsParam Property
ParameterTypeId Class See Also Send Feedback
"# of Neutral Conductors"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecCircuitWireNumNeutralsParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecCircuitWireNumNeutralsParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecCircuitWireNumNeutralsParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecCircuitWireNumRunsParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecCircuitWireNumRunsParam Property
ParameterTypeId Class See Also Send Feedback
"# of Runs"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecCircuitWireNumRunsParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecCircuitWireNumRunsParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecCircuitWireNumRunsParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecDemandfactorDemandloadParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecDemandfactorDemandloadParam Property
ParameterTypeId Class See Also Send Feedback
"Estimated Demand Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecDemandfactorDemandloadParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecDemandfactorDemandloadParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecDemandfactorDemandloadParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecDemandfactorLoadclassificationParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecDemandfactorLoadclassificationParam Property
ParameterTypeId Class See Also Send Feedback
"Load Classification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecDemandfactorLoadclassificationParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecDemandfactorLoadclassificationParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecDemandfactorLoadclassificationParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecDemandfactorLoadParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecDemandfactorLoadParam Property
ParameterTypeId Class See Also Send Feedback
"Connected Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecDemandfactorLoadParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecDemandfactorLoadParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecDemandfactorLoadParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecDistributionNodeLoadSet Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecDistributionNodeLoadSet Property
ParameterTypeId Class See Also Send Feedback
"Load Set"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecDistributionNodeLoadSet { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecDistributionNodeLoadSet As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecDistributionNodeLoadSet {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecDistributionNodeSupplyFrom1 Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecDistributionNodeSupplyFrom1 Property
ParameterTypeId Class See Also Send Feedback
"Supply From 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecDistributionNodeSupplyFrom1 { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecDistributionNodeSupplyFrom1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecDistributionNodeSupplyFrom1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecDistributionNodeSupplyFrom2 Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecDistributionNodeSupplyFrom2 Property
ParameterTypeId Class See Also Send Feedback
"Supply From 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecDistributionNodeSupplyFrom2 { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecDistributionNodeSupplyFrom2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecDistributionNodeSupplyFrom2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecEditCircuitNamingSettingsParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecEditCircuitNamingSettingsParam Property
ParameterTypeId Class See Also Send Feedback
"Circuit Naming Settings"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecEditCircuitNamingSettingsParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecEditCircuitNamingSettingsParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecEditCircuitNamingSettingsParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecEnclosure Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecEnclosure Property
ParameterTypeId Class See Also Send Feedback
"Enclosure"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecEnclosure { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecEnclosure As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecEnclosure {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecLoadClassification Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecLoadClassification Property
ParameterTypeId Class See Also Send Feedback
"Load Classification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecLoadClassification { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecLoadClassification As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecLoadClassification {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecLoadsummaryConnectedCurrentParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecLoadsummaryConnectedCurrentParam Property
ParameterTypeId Class See Also Send Feedback
"Connected Current"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecLoadsummaryConnectedCurrentParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecLoadsummaryConnectedCurrentParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecLoadsummaryConnectedCurrentParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecLoadsummaryConnectedLoadParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecLoadsummaryConnectedLoadParam Property
ParameterTypeId Class See Also Send Feedback
"Connected Load (VA)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecLoadsummaryConnectedLoadParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecLoadsummaryConnectedLoadParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecLoadsummaryConnectedLoadParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecLoadsummaryDemandFactorParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecLoadsummaryDemandFactorParam Property
ParameterTypeId Class See Also Send Feedback
"Demand Factor"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecLoadsummaryDemandFactorParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecLoadsummaryDemandFactorParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecLoadsummaryDemandFactorParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecLoadsummaryDemandFactorRuleParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecLoadsummaryDemandFactorRuleParam Property
ParameterTypeId Class See Also Send Feedback
"Description"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecLoadsummaryDemandFactorRuleParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecLoadsummaryDemandFactorRuleParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecLoadsummaryDemandFactorRuleParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecLoadsummaryLoadclassificationParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecLoadsummaryLoadclassificationParam Property
ParameterTypeId Class See Also Send Feedback
"Load Classification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecLoadsummaryLoadclassificationParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecLoadsummaryLoadclassificationParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecLoadsummaryLoadclassificationParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecMains Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecMains Property
ParameterTypeId Class See Also Send Feedback
"Mains"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecMains { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecMains As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecMains {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecMaxPoleBreakers Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecMaxPoleBreakers Property
ParameterTypeId Class See Also Send Feedback
"Max Number of Single Pole Breakers"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecMaxPoleBreakers { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecMaxPoleBreakers As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecMaxPoleBreakers {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecModifications Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecModifications Property
ParameterTypeId Class See Also Send Feedback
"Modifications"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecModifications { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecModifications As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecModifications {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecMounting Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecMounting Property
ParameterTypeId Class See Also Send Feedback
"Mounting"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecMounting { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecMounting As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecMounting {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecNumberOfCircuits Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecNumberOfCircuits Property
ParameterTypeId Class See Also Send Feedback
"Max Number of Circuits"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecNumberOfCircuits { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecNumberOfCircuits As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecNumberOfCircuits {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecNumberOfPoles Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecNumberOfPoles Property
ParameterTypeId Class See Also Send Feedback
"Number of Poles"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecNumberOfPoles { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecNumberOfPoles As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecNumberOfPoles {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecPanelBranchCircuitApparentLoadPhaseb Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecPanelBranchCircuitApparentLoadPhaseb Property
ParameterTypeId Class See Also Send Feedback
"Branch Circuit Apparent Load Phase B"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecPanelBranchCircuitApparentLoadPhaseb { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecPanelBranchCircuitApparentLoadPhaseb As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecPanelBranchCircuitApparentLoadPhaseb {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecPanelBranchCircuitApparentLoadPhasec Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecPanelBranchCircuitApparentLoadPhasec Property
ParameterTypeId Class See Also Send Feedback
"Branch Circuit Apparent Load Phase C"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecPanelBranchCircuitApparentLoadPhasec { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecPanelBranchCircuitApparentLoadPhasec As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecPanelBranchCircuitApparentLoadPhasec {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecPanelBranchCircuitCurrentPhasea Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecPanelBranchCircuitCurrentPhasea Property
ParameterTypeId Class See Also Send Feedback
"Branch Circuit Current Phase A"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecPanelBranchCircuitCurrentPhasea { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecPanelBranchCircuitCurrentPhasea As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecPanelBranchCircuitCurrentPhasea {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecPanelBranchCircuitCurrentPhaseb Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecPanelBranchCircuitCurrentPhaseb Property
ParameterTypeId Class See Also Send Feedback
"Branch Circuit Current Phase B"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecPanelBranchCircuitCurrentPhaseb { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecPanelBranchCircuitCurrentPhaseb As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecPanelBranchCircuitCurrentPhaseb {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecPanelBranchCircuitCurrentPhasec Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecPanelBranchCircuitCurrentPhasec Property
ParameterTypeId Class See Also Send Feedback
"Branch Circuit Current Phase C"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecPanelBranchCircuitCurrentPhasec { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecPanelBranchCircuitCurrentPhasec As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecPanelBranchCircuitCurrentPhasec {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecPanelBussingParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecPanelBussingParam Property
ParameterTypeId Class See Also Send Feedback
"Bussing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecPanelBussingParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecPanelBussingParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecPanelBussingParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecPanelConfigurationParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecPanelConfigurationParam Property
ParameterTypeId Class See Also Send Feedback
"Panel Configuration"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecPanelConfigurationParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecPanelConfigurationParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecPanelConfigurationParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecPanelFeedParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecPanelFeedParam Property
ParameterTypeId Class See Also Send Feedback
"Feed"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecPanelFeedParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecPanelFeedParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecPanelFeedParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecPanelFeedThruLugsApparentLoadPhasea Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecPanelFeedThruLugsApparentLoadPhasea Property
ParameterTypeId Class See Also Send Feedback
"Feed Through Lugs Apparent Load Phase A"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecPanelFeedThruLugsApparentLoadPhasea { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecPanelFeedThruLugsApparentLoadPhasea As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecPanelFeedThruLugsApparentLoadPhasea {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecPanelFeedThruLugsApparentLoadPhaseb Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecPanelFeedThruLugsApparentLoadPhaseb Property
ParameterTypeId Class See Also Send Feedback
"Feed Through Lugs Apparent Load Phase B"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecPanelFeedThruLugsApparentLoadPhaseb { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecPanelFeedThruLugsApparentLoadPhaseb As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecPanelFeedThruLugsApparentLoadPhaseb {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecPanelFeedThruLugsCurrentPhaseb Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecPanelFeedThruLugsCurrentPhaseb Property
ParameterTypeId Class See Also Send Feedback
"Feed Through Lugs Current Phase B"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecPanelFeedThruLugsCurrentPhaseb { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecPanelFeedThruLugsCurrentPhaseb As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecPanelFeedThruLugsCurrentPhaseb {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecPanelFeedThruLugsCurrentPhasec Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecPanelFeedThruLugsCurrentPhasec Property
ParameterTypeId Class See Also Send Feedback
"Feed Through Lugs Current Phase C"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecPanelFeedThruLugsCurrentPhasec { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecPanelFeedThruLugsCurrentPhasec As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecPanelFeedThruLugsCurrentPhasec {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecPanelFeedThruLugsParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecPanelFeedThruLugsParam Property
ParameterTypeId Class See Also Send Feedback
"Feed Through Lugs"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecPanelFeedThruLugsParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecPanelFeedThruLugsParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecPanelFeedThruLugsParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecPanelGroundBusParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecPanelGroundBusParam Property
ParameterTypeId Class See Also Send Feedback
"Ground Bus"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecPanelGroundBusParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecPanelGroundBusParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecPanelGroundBusParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecPanelLocationParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecPanelLocationParam Property
ParameterTypeId Class See Also Send Feedback
"Location"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecPanelLocationParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecPanelLocationParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecPanelLocationParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecPanelMcbRatingParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecPanelMcbRatingParam Property
ParameterTypeId Class See Also Send Feedback
"MCB Rating"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecPanelMcbRatingParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecPanelMcbRatingParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecPanelMcbRatingParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecPanelNeutralBusParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecPanelNeutralBusParam Property
ParameterTypeId Class See Also Send Feedback
"Neutral Bus"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecPanelNeutralBusParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecPanelNeutralBusParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecPanelNeutralBusParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecPanelNeutralRatingParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecPanelNeutralRatingParam Property
ParameterTypeId Class See Also Send Feedback
"Neutral Rating"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecPanelNeutralRatingParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecPanelNeutralRatingParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecPanelNeutralRatingParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecPanelNumphasesParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecPanelNumphasesParam Property
ParameterTypeId Class See Also Send Feedback
"Number of Phases"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecPanelNumphasesParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecPanelNumphasesParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecPanelNumphasesParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecPanelNumwiresParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecPanelNumwiresParam Property
ParameterTypeId Class See Also Send Feedback
"Number of Wires"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecPanelNumwiresParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecPanelNumwiresParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecPanelNumwiresParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecPanelScheduleHeaderNotesParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecPanelScheduleHeaderNotesParam Property
ParameterTypeId Class See Also Send Feedback
"Schedule Header Notes"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecPanelScheduleHeaderNotesParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecPanelScheduleHeaderNotesParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecPanelScheduleHeaderNotesParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecPanelSubfeedLugsParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecPanelSubfeedLugsParam Property
ParameterTypeId Class See Also Send Feedback
"SubFeed Lugs"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecPanelSubfeedLugsParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecPanelSubfeedLugsParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecPanelSubfeedLugsParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecPanelTotalConnectedCurrentParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecPanelTotalConnectedCurrentParam Property
ParameterTypeId Class See Also Send Feedback
"Total Connected Current"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecPanelTotalConnectedCurrentParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecPanelTotalConnectedCurrentParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecPanelTotalConnectedCurrentParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecPanelTotalDemandCurrentParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecPanelTotalDemandCurrentParam Property
ParameterTypeId Class See Also Send Feedback
"Total Estimated Demand Current"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecPanelTotalDemandCurrentParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecPanelTotalDemandCurrentParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecPanelTotalDemandCurrentParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecPanelTotalDemandFactorParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecPanelTotalDemandFactorParam Property
ParameterTypeId Class See Also Send Feedback
"Total Demand Factor"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecPanelTotalDemandFactorParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecPanelTotalDemandFactorParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecPanelTotalDemandFactorParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecPanelTotalestloadHvacParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecPanelTotalestloadHvacParam Property
ParameterTypeId Class See Also Send Feedback
"HVAC Total Estimated Demand"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecPanelTotalestloadHvacParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecPanelTotalestloadHvacParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecPanelTotalestloadHvacParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecPanelTotalestloadLightParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecPanelTotalestloadLightParam Property
ParameterTypeId Class See Also Send Feedback
"Lighting Total Estimated Demand"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecPanelTotalestloadLightParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecPanelTotalestloadLightParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecPanelTotalestloadLightParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecPanelTotalestloadOtherParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecPanelTotalestloadOtherParam Property
ParameterTypeId Class See Also Send Feedback
"Other Total Estimated Demand"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecPanelTotalestloadOtherParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecPanelTotalestloadOtherParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecPanelTotalestloadOtherParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecPanelTotalestloadParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecPanelTotalestloadParam Property
ParameterTypeId Class See Also Send Feedback
"Total Estimated Demand"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecPanelTotalestloadParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecPanelTotalestloadParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecPanelTotalestloadParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecPanelTotalestloadPowerParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecPanelTotalestloadPowerParam Property
ParameterTypeId Class See Also Send Feedback
"Power Total Estimated Demand"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecPanelTotalestloadPowerParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecPanelTotalestloadPowerParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecPanelTotalestloadPowerParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecPanelTotalloadHvacParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecPanelTotalloadHvacParam Property
ParameterTypeId Class See Also Send Feedback
"HVAC Total Connected"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecPanelTotalloadHvacParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecPanelTotalloadHvacParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecPanelTotalloadHvacParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecPanelTotalloadLightParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecPanelTotalloadLightParam Property
ParameterTypeId Class See Also Send Feedback
"Lighting Total Connected"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecPanelTotalloadLightParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecPanelTotalloadLightParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecPanelTotalloadLightParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecPanelTotalloadOtherParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecPanelTotalloadOtherParam Property
ParameterTypeId Class See Also Send Feedback
"Other Total Connected"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecPanelTotalloadOtherParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecPanelTotalloadOtherParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecPanelTotalloadOtherParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecPanelTotalloadPowerParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecPanelTotalloadPowerParam Property
ParameterTypeId Class See Also Send Feedback
"Power Total Connected"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecPanelTotalloadPowerParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecPanelTotalloadPowerParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecPanelTotalloadPowerParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecPowerFactor Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecPowerFactor Property
ParameterTypeId Class See Also Send Feedback
"Power Factor"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecPowerFactor { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecPowerFactor As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecPowerFactor {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecPowerFactorState Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecPowerFactorState Property
ParameterTypeId Class See Also Send Feedback
"Power Factor State"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecPowerFactorState { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecPowerFactorState As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecPowerFactorState {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecRoomAverageIllumination Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecRoomAverageIllumination Property
ParameterTypeId Class See Also Send Feedback
"Average Estimated Illumination"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecRoomAverageIllumination { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecRoomAverageIllumination As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecRoomAverageIllumination {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecRoomCavityRatio Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecRoomCavityRatio Property
ParameterTypeId Class See Also Send Feedback
"Room Cavity Ratio"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecRoomCavityRatio { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecRoomCavityRatio As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecRoomCavityRatio {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecRoomLightingCalcLuminaireplane Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecRoomLightingCalcLuminaireplane Property
ParameterTypeId Class See Also Send Feedback
"Lighting Calculation Luminaire Plane"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecRoomLightingCalcLuminaireplane { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecRoomLightingCalcLuminaireplane As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecRoomLightingCalcLuminaireplane {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecRoomLightingCalcWorkplane Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecRoomLightingCalcWorkplane Property
ParameterTypeId Class See Also Send Feedback
"Lighting Calculation Workplane"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecRoomLightingCalcWorkplane { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecRoomLightingCalcWorkplane As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecRoomLightingCalcWorkplane {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecRoomReflectivityCeiling Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecRoomReflectivityCeiling Property
ParameterTypeId Class See Also Send Feedback
"Ceiling Reflectance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecRoomReflectivityCeiling { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecRoomReflectivityCeiling As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecRoomReflectivityCeiling {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecRoomReflectivityWalls Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecRoomReflectivityWalls Property
ParameterTypeId Class See Also Send Feedback
"Wall Reflectance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecRoomReflectivityWalls { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecRoomReflectivityWalls As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecRoomReflectivityWalls {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecShortCircuitRating Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecShortCircuitRating Property
ParameterTypeId Class See Also Send Feedback
"Short Circuit Rating"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecShortCircuitRating { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecShortCircuitRating As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecShortCircuitRating {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElectricalData Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElectricalData Property
ParameterTypeId Class See Also Send Feedback
"Electrical Data"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElectricalData { get; }
Visual Basic
Public Shared ReadOnly Property RbsElectricalData As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElectricalData {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecTrueCurrentParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecTrueCurrentParam Property
ParameterTypeId Class See Also Send Feedback
"True Current"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecTrueCurrentParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecTrueCurrentParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecTrueCurrentParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecTrueCurrentPhaseaParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecTrueCurrentPhaseaParam Property
ParameterTypeId Class See Also Send Feedback
"True Current Phase A"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecTrueCurrentPhaseaParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecTrueCurrentPhaseaParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecTrueCurrentPhaseaParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecTrueCurrentPhasebParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecTrueCurrentPhasebParam Property
ParameterTypeId Class See Also Send Feedback
"True Current Phase B"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecTrueCurrentPhasebParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecTrueCurrentPhasebParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecTrueCurrentPhasebParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecTrueCurrentPhasecParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecTrueCurrentPhasecParam Property
ParameterTypeId Class See Also Send Feedback
"True Current Phase C"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecTrueCurrentPhasecParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecTrueCurrentPhasecParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecTrueCurrentPhasecParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecTrueLoad Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecTrueLoad Property
ParameterTypeId Class See Also Send Feedback
"True Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecTrueLoad { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecTrueLoad As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecTrueLoad {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecTrueLoadPhase1 Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecTrueLoadPhase1 Property
ParameterTypeId Class See Also Send Feedback
"True Load Phase 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecTrueLoadPhase1 { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecTrueLoadPhase1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecTrueLoadPhase1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecTrueLoadPhase2 Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecTrueLoadPhase2 Property
ParameterTypeId Class See Also Send Feedback
"True Load Phase 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecTrueLoadPhase2 { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecTrueLoadPhase2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecTrueLoadPhase2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecTrueLoadPhase3 Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecTrueLoadPhase3 Property
ParameterTypeId Class See Also Send Feedback
"True Load Phase 3"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecTrueLoadPhase3 { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecTrueLoadPhase3 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecTrueLoadPhase3 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecTrueLoadPhasea Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecTrueLoadPhasea Property
ParameterTypeId Class See Also Send Feedback
"True Load Phase A"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecTrueLoadPhasea { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecTrueLoadPhasea As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecTrueLoadPhasea {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecTrueLoadPhaseb Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecTrueLoadPhaseb Property
ParameterTypeId Class See Also Send Feedback
"True Load Phase B"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecTrueLoadPhaseb { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecTrueLoadPhaseb As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecTrueLoadPhaseb {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecVoltage Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecVoltage Property
ParameterTypeId Class See Also Send Feedback
"Voltage"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecVoltage { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecVoltage As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecVoltage {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecVoltageDropParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecVoltageDropParam Property
ParameterTypeId Class See Also Send Feedback
"Voltage Drop"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecVoltageDropParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecVoltageDropParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecVoltageDropParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecWireElevation Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecWireElevation Property
ParameterTypeId Class See Also Send Feedback
"Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecWireElevation { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecWireElevation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecWireElevation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecWireGroundAdjustment Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecWireGroundAdjustment Property
ParameterTypeId Class See Also Send Feedback
"Ground Conductors"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecWireGroundAdjustment { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecWireGroundAdjustment As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecWireGroundAdjustment {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecWireHotAdjustment Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecWireHotAdjustment Property
ParameterTypeId Class See Also Send Feedback
"Hot Conductors"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecWireHotAdjustment { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecWireHotAdjustment As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecWireHotAdjustment {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecWireNeutralAdjustment Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecWireNeutralAdjustment Property
ParameterTypeId Class See Also Send Feedback
"Neutral Conductors"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecWireNeutralAdjustment { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecWireNeutralAdjustment As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecWireNeutralAdjustment {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecWireShareGround Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecWireShareGround Property
ParameterTypeId Class See Also Send Feedback
"Share Ground Conductor"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecWireShareGround { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecWireShareGround As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecWireShareGround {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecWireShareNeutral Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecWireShareNeutral Property
ParameterTypeId Class See Also Send Feedback
"Share Neutral Conductor"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecWireShareNeutral { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecWireShareNeutral As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecWireShareNeutral {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecWireTickmarkState Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecWireTickmarkState Property
ParameterTypeId Class See Also Send Feedback
"Tick Marks"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecWireTickmarkState { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecWireTickmarkState As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecWireTickmarkState {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsElecWireType Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsElecWireType Property
ParameterTypeId Class See Also Send Feedback
"Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsElecWireType { get; }
Visual Basic
Public Shared ReadOnly Property RbsElecWireType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsElecWireType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsEndLevelParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsEndLevelParam Property
ParameterTypeId Class See Also Send Feedback
"End Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsEndLevelParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsEndLevelParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsEndLevelParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsEnergyAnalysisBuildingEnvelopeAnalyticalSpaceIdentificationResolution Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsEnergyAnalysisBuildingEnvelopeAnalyticalSpaceIdentificationResolution Property
ParameterTypeId Class See Also Send Feedback
"Analytical Space Resolution"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsEnergyAnalysisBuildingEnvelopeAnalyticalSpaceIdentificationResolution { get; }
Visual Basic
Public Shared ReadOnly Property RbsEnergyAnalysisBuildingEnvelopeAnalyticalSpaceIdentificationResolution As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsEnergyAnalysisBuildingEnvelopeAnalyticalSpaceIdentificationResolution {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsEnergyAnalysisBuildingEnvelopeAnalyticalSurfaceIdentificationResolution Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsEnergyAnalysisBuildingEnvelopeAnalyticalSurfaceIdentificationResolution Property
ParameterTypeId Class See Also Send Feedback
"Analytical Surface Resolution"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsEnergyAnalysisBuildingEnvelopeAnalyticalSurfaceIdentificationResolution { get; }
Visual Basic
Public Shared ReadOnly Property RbsEnergyAnalysisBuildingEnvelopeAnalyticalSurfaceIdentificationResolution As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsEnergyAnalysisBuildingEnvelopeAnalyticalSurfaceIdentificationResolution {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsEnergyAnalysisBuildingEnvelopeDeterminationParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsEnergyAnalysisBuildingEnvelopeDeterminationParam Property
ParameterTypeId Class See Also Send Feedback
"Building Envelope"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsEnergyAnalysisBuildingEnvelopeDeterminationParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsEnergyAnalysisBuildingEnvelopeDeterminationParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsEnergyAnalysisBuildingEnvelopeDeterminationParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsEnergyAnalysisExportCategoryParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsEnergyAnalysisExportCategoryParam Property
ParameterTypeId Class See Also Send Feedback
"Export Category"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsEnergyAnalysisExportCategoryParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsEnergyAnalysisExportCategoryParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsEnergyAnalysisExportCategoryParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsEnergyAnalysisExportGbxmlDefaultsParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsEnergyAnalysisExportGbxmlDefaultsParam Property
ParameterTypeId Class See Also Send Feedback
"Export Default Values"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsEnergyAnalysisExportGbxmlDefaultsParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsEnergyAnalysisExportGbxmlDefaultsParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsEnergyAnalysisExportGbxmlDefaultsParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsEnergyAnalysisGroundPlaneParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsEnergyAnalysisGroundPlaneParam Property
ParameterTypeId Class See Also Send Feedback
"Ground Plane"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsEnergyAnalysisGroundPlaneParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsEnergyAnalysisGroundPlaneParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsEnergyAnalysisGroundPlaneParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsEnergyAnalysisIncludeThermalProperties Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsEnergyAnalysisIncludeThermalProperties Property
ParameterTypeId Class See Also Send Feedback
"Detailed Elements"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsEnergyAnalysisIncludeThermalProperties { get; }
Visual Basic
Public Shared ReadOnly Property RbsEnergyAnalysisIncludeThermalProperties As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsEnergyAnalysisIncludeThermalProperties {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsEnergyAnalysisMode Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsEnergyAnalysisMode Property
ParameterTypeId Class See Also Send Feedback
"Mode"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsEnergyAnalysisMode { get; }
Visual Basic
Public Shared ReadOnly Property RbsEnergyAnalysisMode As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsEnergyAnalysisMode {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsEnergyAnalysisProjectPhaseParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsEnergyAnalysisProjectPhaseParam Property
ParameterTypeId Class See Also Send Feedback
"Project Phase"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsEnergyAnalysisProjectPhaseParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsEnergyAnalysisProjectPhaseParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsEnergyAnalysisProjectPhaseParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsEnergyAnalysisSliverSpaceTolerance Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsEnergyAnalysisSliverSpaceTolerance Property
ParameterTypeId Class See Also Send Feedback
"Sliver Space Tolerance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsEnergyAnalysisSliverSpaceTolerance { get; }
Visual Basic
Public Shared ReadOnly Property RbsEnergyAnalysisSliverSpaceTolerance As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsEnergyAnalysisSliverSpaceTolerance {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsEnergyAnalysisSurfaceAdjacentSpaceId1 Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsEnergyAnalysisSurfaceAdjacentSpaceId1 Property
ParameterTypeId Class See Also Send Feedback
"Adjacent Space Id (1)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsEnergyAnalysisSurfaceAdjacentSpaceId1 { get; }
Visual Basic
Public Shared ReadOnly Property RbsEnergyAnalysisSurfaceAdjacentSpaceId1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsEnergyAnalysisSurfaceAdjacentSpaceId1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsEnergyAnalysisSurfaceAdjacentSpaceId2 Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsEnergyAnalysisSurfaceAdjacentSpaceId2 Property
ParameterTypeId Class See Also Send Feedback
"Adjacent Space Id (2)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsEnergyAnalysisSurfaceAdjacentSpaceId2 { get; }
Visual Basic
Public Shared ReadOnly Property RbsEnergyAnalysisSurfaceAdjacentSpaceId2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsEnergyAnalysisSurfaceAdjacentSpaceId2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsEnergyAnalysisSurfaceAzimuth Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsEnergyAnalysisSurfaceAzimuth Property
ParameterTypeId Class See Also Send Feedback
"Azimuth"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsEnergyAnalysisSurfaceAzimuth { get; }
Visual Basic
Public Shared ReadOnly Property RbsEnergyAnalysisSurfaceAzimuth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsEnergyAnalysisSurfaceAzimuth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsEnergyAnalysisSurfaceCadobjectid Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsEnergyAnalysisSurfaceCadobjectid Property
ParameterTypeId Class See Also Send Feedback
"CADObjectID"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsEnergyAnalysisSurfaceCadobjectid { get; }
Visual Basic
Public Shared ReadOnly Property RbsEnergyAnalysisSurfaceCadobjectid As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsEnergyAnalysisSurfaceCadobjectid {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsEnergyAnalysisSurfaceOriginX Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsEnergyAnalysisSurfaceOriginX Property
ParameterTypeId Class See Also Send Feedback
"Origin (X)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsEnergyAnalysisSurfaceOriginX { get; }
Visual Basic
Public Shared ReadOnly Property RbsEnergyAnalysisSurfaceOriginX As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsEnergyAnalysisSurfaceOriginX {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsEnergyAnalysisSurfaceOriginY Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsEnergyAnalysisSurfaceOriginY Property
ParameterTypeId Class See Also Send Feedback
"Origin (Y)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsEnergyAnalysisSurfaceOriginY { get; }
Visual Basic
Public Shared ReadOnly Property RbsEnergyAnalysisSurfaceOriginY As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsEnergyAnalysisSurfaceOriginY {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsEnergyAnalysisSurfaceOriginZ Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsEnergyAnalysisSurfaceOriginZ Property
ParameterTypeId Class See Also Send Feedback
"Origin (Z)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsEnergyAnalysisSurfaceOriginZ { get; }
Visual Basic
Public Shared ReadOnly Property RbsEnergyAnalysisSurfaceOriginZ As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsEnergyAnalysisSurfaceOriginZ {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsEnergyAnalysisViewBuildingShellMode Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsEnergyAnalysisViewBuildingShellMode Property
ParameterTypeId Class See Also Send Feedback
"Show Analytical Building Shell"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsEnergyAnalysisViewBuildingShellMode { get; }
Visual Basic
Public Shared ReadOnly Property RbsEnergyAnalysisViewBuildingShellMode As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsEnergyAnalysisViewBuildingShellMode {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsEnergyAnalysisViewCoordAxisMode Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsEnergyAnalysisViewCoordAxisMode Property
ParameterTypeId Class See Also Send Feedback
"Show a Coordinate System Symbol for each Surface"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsEnergyAnalysisViewCoordAxisMode { get; }
Visual Basic
Public Shared ReadOnly Property RbsEnergyAnalysisViewCoordAxisMode As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsEnergyAnalysisViewCoordAxisMode {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsEnergyAnalysisViewInnerShellMode Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsEnergyAnalysisViewInnerShellMode Property
ParameterTypeId Class See Also Send Feedback
"Show Inner Space Shells"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsEnergyAnalysisViewInnerShellMode { get; }
Visual Basic
Public Shared ReadOnly Property RbsEnergyAnalysisViewInnerShellMode As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsEnergyAnalysisViewInnerShellMode {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsEnergyAnalysisViewOuterShellMode Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsEnergyAnalysisViewOuterShellMode Property
ParameterTypeId Class See Also Send Feedback
"Show Analytical Space Shells"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsEnergyAnalysisViewOuterShellMode { get; }
Visual Basic
Public Shared ReadOnly Property RbsEnergyAnalysisViewOuterShellMode As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsEnergyAnalysisViewOuterShellMode {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsEnergyAnalysisViewRbeMode Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsEnergyAnalysisViewRbeMode Property
ParameterTypeId Class See Also Send Feedback
"Show Room Bounding Elements Dimmed and Underlay"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsEnergyAnalysisViewRbeMode { get; }
Visual Basic
Public Shared ReadOnly Property RbsEnergyAnalysisViewRbeMode As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsEnergyAnalysisViewRbeMode {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsEnergyAnalysisViewShadingSurfacesMode Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsEnergyAnalysisViewShadingSurfacesMode Property
ParameterTypeId Class See Also Send Feedback
"Show Shading Surfaces"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsEnergyAnalysisViewShadingSurfacesMode { get; }
Visual Basic
Public Shared ReadOnly Property RbsEnergyAnalysisViewShadingSurfacesMode As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsEnergyAnalysisViewShadingSurfacesMode {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsEnergyAnalysisViewSurfacesMode Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsEnergyAnalysisViewSurfacesMode Property
ParameterTypeId Class See Also Send Feedback
"Show Surfaces"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsEnergyAnalysisViewSurfacesMode { get; }
Visual Basic
Public Shared ReadOnly Property RbsEnergyAnalysisViewSurfacesMode As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsEnergyAnalysisViewSurfacesMode {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsEnergyAnalysisViewTransparentMode Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsEnergyAnalysisViewTransparentMode Property
ParameterTypeId Class See Also Send Feedback
"Show Surfaces Transparent"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsEnergyAnalysisViewTransparentMode { get; }
Visual Basic
Public Shared ReadOnly Property RbsEnergyAnalysisViewTransparentMode As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsEnergyAnalysisViewTransparentMode {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsEnergyAnalysisViewUpdateSurfaces Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsEnergyAnalysisViewUpdateSurfaces Property
ParameterTypeId Class See Also Send Feedback
"Update Surfaces"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsEnergyAnalysisViewUpdateSurfaces { get; }
Visual Basic
Public Shared ReadOnly Property RbsEnergyAnalysisViewUpdateSurfaces As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsEnergyAnalysisViewUpdateSurfaces {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsEqDiameterParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsEqDiameterParam Property
ParameterTypeId Class See Also Send Feedback
"Equivalent Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsEqDiameterParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsEqDiameterParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsEqDiameterParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsFamilyContentAnnotationDisplay Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsFamilyContentAnnotationDisplay Property
ParameterTypeId Class See Also Send Feedback
"Use Annotation Scale"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsFamilyContentAnnotationDisplay { get; }
Visual Basic
Public Shared ReadOnly Property RbsFamilyContentAnnotationDisplay As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsFamilyContentAnnotationDisplay {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsFamilyContentDistributionSystem Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsFamilyContentDistributionSystem Property
ParameterTypeId Class See Also Send Feedback
"Distribution System"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsFamilyContentDistributionSystem { get; }
Visual Basic
Public Shared ReadOnly Property RbsFamilyContentDistributionSystem As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsFamilyContentDistributionSystem {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsFamilyContentOffsetHeight Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsFamilyContentOffsetHeight Property
ParameterTypeId Class See Also Send Feedback
"OffsetHeight"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsFamilyContentOffsetHeight { get; }
Visual Basic
Public Shared ReadOnly Property RbsFamilyContentOffsetHeight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsFamilyContentOffsetHeight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsFamilyContentOffsetWidth Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsFamilyContentOffsetWidth Property
ParameterTypeId Class See Also Send Feedback
"OffsetWidth"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsFamilyContentOffsetWidth { get; }
Visual Basic
Public Shared ReadOnly Property RbsFamilyContentOffsetWidth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsFamilyContentOffsetWidth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsFamilyContentSecondaryDistribsys Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsFamilyContentSecondaryDistribsys Property
ParameterTypeId Class See Also Send Feedback
"Secondary Distribution System"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsFamilyContentSecondaryDistribsys { get; }
Visual Basic
Public Shared ReadOnly Property RbsFamilyContentSecondaryDistribsys As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsFamilyContentSecondaryDistribsys {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsFamilyContentTakeoffProjlength Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsFamilyContentTakeoffProjlength Property
ParameterTypeId Class See Also Send Feedback
"Takeoff Length Projection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsFamilyContentTakeoffProjlength { get; }
Visual Basic
Public Shared ReadOnly Property RbsFamilyContentTakeoffProjlength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsFamilyContentTakeoffProjlength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsFlexductRoundtypeParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsFlexductRoundtypeParam Property
ParameterTypeId Class See Also Send Feedback
"Flex Duct Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsFlexductRoundtypeParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsFlexductRoundtypeParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsFlexductRoundtypeParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsFlexDuctTypeParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsFlexDuctTypeParam Property
ParameterTypeId Class See Also Send Feedback
"Flex Duct Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsFlexDuctTypeParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsFlexDuctTypeParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsFlexDuctTypeParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsFlexPatternParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsFlexPatternParam Property
ParameterTypeId Class See Also Send Feedback
"Flex Pattern"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsFlexPatternParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsFlexPatternParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsFlexPatternParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsFlexPipeTypeParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsFlexPipeTypeParam Property
ParameterTypeId Class See Also Send Feedback
"Flex Pipe"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsFlexPipeTypeParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsFlexPipeTypeParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsFlexPipeTypeParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsFlowFactorParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsFlowFactorParam Property
ParameterTypeId Class See Also Send Feedback
"Flow Factor"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsFlowFactorParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsFlowFactorParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsFlowFactorParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsFpSprinklerCoverageParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsFpSprinklerCoverageParam Property
ParameterTypeId Class See Also Send Feedback
"Coverage"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsFpSprinklerCoverageParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsFpSprinklerCoverageParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsFpSprinklerCoverageParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsFpSprinklerKFactorParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsFpSprinklerKFactorParam Property
ParameterTypeId Class See Also Send Feedback
"K-Factor"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsFpSprinklerKFactorParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsFpSprinklerKFactorParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsFpSprinklerKFactorParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsFpSprinklerOrificeParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsFpSprinklerOrificeParam Property
ParameterTypeId Class See Also Send Feedback
"Orifice"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsFpSprinklerOrificeParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsFpSprinklerOrificeParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsFpSprinklerOrificeParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsFpSprinklerOrificeSizeParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsFpSprinklerOrificeSizeParam Property
ParameterTypeId Class See Also Send Feedback
"Orifice Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsFpSprinklerOrificeSizeParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsFpSprinklerOrificeSizeParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsFpSprinklerOrificeSizeParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsFpSprinklerResponseParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsFpSprinklerResponseParam Property
ParameterTypeId Class See Also Send Feedback
"Response"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsFpSprinklerResponseParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsFpSprinklerResponseParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsFpSprinklerResponseParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsFpSprinklerTemperatureRatingParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsFpSprinklerTemperatureRatingParam Property
ParameterTypeId Class See Also Send Feedback
"Temperature Rating"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsFpSprinklerTemperatureRatingParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsFpSprinklerTemperatureRatingParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsFpSprinklerTemperatureRatingParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsFriction Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsFriction Property
ParameterTypeId Class See Also Send Feedback
"Friction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsFriction { get; }
Visual Basic
Public Shared ReadOnly Property RbsFriction As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsFriction {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsGbxmlOpeningType Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsGbxmlOpeningType Property
ParameterTypeId Class See Also Send Feedback
"Opening Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsGbxmlOpeningType { get; }
Visual Basic
Public Shared ReadOnly Property RbsGbxmlOpeningType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsGbxmlOpeningType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsGbxmlSurfaceArea Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsGbxmlSurfaceArea Property
ParameterTypeId Class See Also Send Feedback
"Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsGbxmlSurfaceArea { get; }
Visual Basic
Public Shared ReadOnly Property RbsGbxmlSurfaceArea As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsGbxmlSurfaceArea {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsGbxmlSurfaceName Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsGbxmlSurfaceName Property
ParameterTypeId Class See Also Send Feedback
"Surface Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsGbxmlSurfaceName { get; }
Visual Basic
Public Shared ReadOnly Property RbsGbxmlSurfaceName As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsGbxmlSurfaceName {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsGbxmlSurfaceType Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsGbxmlSurfaceType Property
ParameterTypeId Class See Also Send Feedback
"Surface Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsGbxmlSurfaceType { get; }
Visual Basic
Public Shared ReadOnly Property RbsGbxmlSurfaceType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsGbxmlSurfaceType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsHvacloadDoorAreaParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsHvacloadDoorAreaParam Property
ParameterTypeId Class See Also Send Feedback
"Door Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsHvacloadDoorAreaParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsHvacloadDoorAreaParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsHvacloadDoorAreaParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsHvacloadDoorCoolingLoadParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsHvacloadDoorCoolingLoadParam Property
ParameterTypeId Class See Also Send Feedback
"Door Cooling Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsHvacloadDoorCoolingLoadParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsHvacloadDoorCoolingLoadParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsHvacloadDoorCoolingLoadParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsHvacloadPartitionAreaParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsHvacloadPartitionAreaParam Property
ParameterTypeId Class See Also Send Feedback
"Partition Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsHvacloadPartitionAreaParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsHvacloadPartitionAreaParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsHvacloadPartitionAreaParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsHvacloadPartitionCoolingLoadParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsHvacloadPartitionCoolingLoadParam Property
ParameterTypeId Class See Also Send Feedback
"Partition Cooling Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsHvacloadPartitionCoolingLoadParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsHvacloadPartitionCoolingLoadParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsHvacloadPartitionCoolingLoadParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsHvacloadPlenumCoolingLoadParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsHvacloadPlenumCoolingLoadParam Property
ParameterTypeId Class See Also Send Feedback
"Plenum Cooling Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsHvacloadPlenumCoolingLoadParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsHvacloadPlenumCoolingLoadParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsHvacloadPlenumCoolingLoadParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsHvacloadRoofAreaParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsHvacloadRoofAreaParam Property
ParameterTypeId Class See Also Send Feedback
"Roof Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsHvacloadRoofAreaParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsHvacloadRoofAreaParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsHvacloadRoofAreaParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsHvacloadSkylightAreaParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsHvacloadSkylightAreaParam Property
ParameterTypeId Class See Also Send Feedback
"Skylight Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsHvacloadSkylightAreaParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsHvacloadSkylightAreaParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsHvacloadSkylightAreaParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsHvacloadSkylightCoolingLoadParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsHvacloadSkylightCoolingLoadParam Property
ParameterTypeId Class See Also Send Feedback
"Skylight Cooling Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsHvacloadSkylightCoolingLoadParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsHvacloadSkylightCoolingLoadParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsHvacloadSkylightCoolingLoadParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsHvacloadWallCoolingLoadParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsHvacloadWallCoolingLoadParam Property
ParameterTypeId Class See Also Send Feedback
"Wall Cooling Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsHvacloadWallCoolingLoadParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsHvacloadWallCoolingLoadParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsHvacloadWallCoolingLoadParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsHvacloadWindowAreaParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsHvacloadWindowAreaParam Property
ParameterTypeId Class See Also Send Feedback
"Window Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsHvacloadWindowAreaParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsHvacloadWindowAreaParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsHvacloadWindowAreaParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsHvacloadWindowCoolingLoadParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsHvacloadWindowCoolingLoadParam Property
ParameterTypeId Class See Also Send Feedback
"Window Cooling Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsHvacloadWindowCoolingLoadParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsHvacloadWindowCoolingLoadParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsHvacloadWindowCoolingLoadParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsHydraulicDiameterParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsHydraulicDiameterParam Property
ParameterTypeId Class See Also Send Feedback
"Hydraulic Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsHydraulicDiameterParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsHydraulicDiameterParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsHydraulicDiameterParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsInsulationLiningVolume Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsInsulationLiningVolume Property
ParameterTypeId Class See Also Send Feedback
"Volume"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsInsulationLiningVolume { get; }
Visual Basic
Public Shared ReadOnly Property RbsInsulationLiningVolume As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsInsulationLiningVolume {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsIsCustomFitting Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsIsCustomFitting Property
ParameterTypeId Class See Also Send Feedback
"IsCustom"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsIsCustomFitting { get; }
Visual Basic
Public Shared ReadOnly Property RbsIsCustomFitting As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsIsCustomFitting {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsLoadSubClassificationMotor Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsLoadSubClassificationMotor Property
ParameterTypeId Class See Also Send Feedback
"Load Sub-Classification Motor"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsLoadSubClassificationMotor { get; }
Visual Basic
Public Shared ReadOnly Property RbsLoadSubClassificationMotor As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsLoadSubClassificationMotor {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsLookupTableName Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsLookupTableName Property
ParameterTypeId Class See Also Send Feedback
"Lookup Table Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsLookupTableName { get; }
Visual Basic
Public Shared ReadOnly Property RbsLookupTableName As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsLookupTableName {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsLossCoefficient Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsLossCoefficient Property
ParameterTypeId Class See Also Send Feedback
"Loss Coefficient"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsLossCoefficient { get; }
Visual Basic
Public Shared ReadOnly Property RbsLossCoefficient As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsLossCoefficient {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsMaxFlow Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsMaxFlow Property
ParameterTypeId Class See Also Send Feedback
"Max Flow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsMaxFlow { get; }
Visual Basic
Public Shared ReadOnly Property RbsMaxFlow As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsMaxFlow {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsMinFlow Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsMinFlow Property
ParameterTypeId Class See Also Send Feedback
"Min Flow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsMinFlow { get; }
Visual Basic
Public Shared ReadOnly Property RbsMinFlow As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsMinFlow {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsOffsetParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsOffsetParam Property
ParameterTypeId Class See Also Send Feedback
"Middle Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsOffsetParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsOffsetParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsOffsetParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsPanelScheduleSheetAppearanceInstParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsPanelScheduleSheetAppearanceInstParam Property
ParameterTypeId Class See Also Send Feedback
"Appearance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsPanelScheduleSheetAppearanceInstParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsPanelScheduleSheetAppearanceInstParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsPanelScheduleSheetAppearanceInstParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsPanelScheduleSheetAppearanceParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsPanelScheduleSheetAppearanceParam Property
ParameterTypeId Class See Also Send Feedback
"Appearance On Sheet"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsPanelScheduleSheetAppearanceParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsPanelScheduleSheetAppearanceParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsPanelScheduleSheetAppearanceParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsParallelconduitsHorizontalOffsetValue Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsParallelconduitsHorizontalOffsetValue Property
ParameterTypeId Class See Also Send Feedback
"Horizontal Offset value for parallel conduits"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsParallelconduitsHorizontalOffsetValue { get; }
Visual Basic
Public Shared ReadOnly Property RbsParallelconduitsHorizontalOffsetValue As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsParallelconduitsHorizontalOffsetValue {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsParallelconduitsVerticalNumber Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsParallelconduitsVerticalNumber Property
ParameterTypeId Class See Also Send Feedback
"Vertical Number for parallel conduits"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsParallelconduitsVerticalNumber { get; }
Visual Basic
Public Shared ReadOnly Property RbsParallelconduitsVerticalNumber As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsParallelconduitsVerticalNumber {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsParallelconduitsVerticalOffsetValue Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsParallelconduitsVerticalOffsetValue Property
ParameterTypeId Class See Also Send Feedback
"Vertical Offset value for parallel conduits"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsParallelconduitsVerticalOffsetValue { get; }
Visual Basic
Public Shared ReadOnly Property RbsParallelconduitsVerticalOffsetValue As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsParallelconduitsVerticalOffsetValue {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsParallelpipesHorizontalNumber Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsParallelpipesHorizontalNumber Property
ParameterTypeId Class See Also Send Feedback
"Horizontal Number for parallel pipes"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsParallelpipesHorizontalNumber { get; }
Visual Basic
Public Shared ReadOnly Property RbsParallelpipesHorizontalNumber As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsParallelpipesHorizontalNumber {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsParallelpipesVerticalNumber Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsParallelpipesVerticalNumber Property
ParameterTypeId Class See Also Send Feedback
"Vertical Number for parallel pipes"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsParallelpipesVerticalNumber { get; }
Visual Basic
Public Shared ReadOnly Property RbsParallelpipesVerticalNumber As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsParallelpipesVerticalNumber {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsParallelpipesVerticalOffsetValue Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsParallelpipesVerticalOffsetValue Property
ParameterTypeId Class See Also Send Feedback
"Vertical Offset value for parallel pipes"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsParallelpipesVerticalOffsetValue { get; }
Visual Basic
Public Shared ReadOnly Property RbsParallelpipesVerticalOffsetValue As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsParallelpipesVerticalOffsetValue {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsPartType Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsPartType Property
ParameterTypeId Class See Also Send Feedback
"Part Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsPartType { get; }
Visual Basic
Public Shared ReadOnly Property RbsPartType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsPartType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsPipeAdditionalFlowParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsPipeAdditionalFlowParam Property
ParameterTypeId Class See Also Send Feedback
"Additional Flow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsPipeAdditionalFlowParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsPipeAdditionalFlowParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsPipeAdditionalFlowParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsPipeBottomElevation Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsPipeBottomElevation Property
ParameterTypeId Class See Also Send Feedback
"Lower End Bottom Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsPipeBottomElevation { get; }
Visual Basic
Public Shared ReadOnly Property RbsPipeBottomElevation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsPipeBottomElevation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsPipeCalculatedSize Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsPipeCalculatedSize Property
ParameterTypeId Class See Also Send Feedback
"Pipe Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsPipeCalculatedSize { get; }
Visual Basic
Public Shared ReadOnly Property RbsPipeCalculatedSize As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsPipeCalculatedSize {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsPipeClassParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsPipeClassParam Property
ParameterTypeId Class See Also Send Feedback
"Schedule/Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsPipeClassParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsPipeClassParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsPipeClassParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsPipeConnectiontypeParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsPipeConnectiontypeParam Property
ParameterTypeId Class See Also Send Feedback
"Connection Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsPipeConnectiontypeParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsPipeConnectiontypeParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsPipeConnectiontypeParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsPipeConnectorSystemClassificationParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsPipeConnectorSystemClassificationParam Property
ParameterTypeId Class See Also Send Feedback
"System Classification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsPipeConnectorSystemClassificationParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsPipeConnectorSystemClassificationParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsPipeConnectorSystemClassificationParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsPipeCwfuParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsPipeCwfuParam Property
ParameterTypeId Class See Also Send Feedback
"CWFU"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsPipeCwfuParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsPipeCwfuParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsPipeCwfuParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsPipeDiameterParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsPipeDiameterParam Property
ParameterTypeId Class See Also Send Feedback
"Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsPipeDiameterParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsPipeDiameterParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsPipeDiameterParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsPipeFittingLossKfactorParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsPipeFittingLossKfactorParam Property
ParameterTypeId Class See Also Send Feedback
"K Coefficient"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsPipeFittingLossKfactorParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsPipeFittingLossKfactorParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsPipeFittingLossKfactorParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsPipeFittingLossMethodParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsPipeFittingLossMethodParam Property
ParameterTypeId Class See Also Send Feedback
"Loss Method"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsPipeFittingLossMethodParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsPipeFittingLossMethodParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsPipeFittingLossMethodParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsPipeFittingLossMethodServerParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsPipeFittingLossMethodServerParam Property
ParameterTypeId Class See Also Send Feedback
"Loss Method"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsPipeFittingLossMethodServerParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsPipeFittingLossMethodServerParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsPipeFittingLossMethodServerParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsPipeFittingLossTableParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsPipeFittingLossTableParam Property
ParameterTypeId Class See Also Send Feedback
"K Coefficient Table"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsPipeFittingLossTableParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsPipeFittingLossTableParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsPipeFittingLossTableParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsPipeFlowConfigurationParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsPipeFlowConfigurationParam Property
ParameterTypeId Class See Also Send Feedback
"Flow Configuration"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsPipeFlowConfigurationParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsPipeFlowConfigurationParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsPipeFlowConfigurationParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsPipeFlowStateParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsPipeFlowStateParam Property
ParameterTypeId Class See Also Send Feedback
"Flow State"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsPipeFlowStateParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsPipeFlowStateParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsPipeFlowStateParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsPipeFluidDensityParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsPipeFluidDensityParam Property
ParameterTypeId Class See Also Send Feedback
"Fluid Density"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsPipeFluidDensityParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsPipeFluidDensityParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsPipeFluidDensityParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsPipeFluidTemperatureParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsPipeFluidTemperatureParam Property
ParameterTypeId Class See Also Send Feedback
"Fluid Temperature"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsPipeFluidTemperatureParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsPipeFluidTemperatureParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsPipeFluidTemperatureParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsPipeFluidViscosityParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsPipeFluidViscosityParam Property
ParameterTypeId Class See Also Send Feedback
"Fluid Dynamic Viscosity"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsPipeFluidViscosityParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsPipeFluidViscosityParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsPipeFluidViscosityParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsPipeFrictionParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsPipeFrictionParam Property
ParameterTypeId Class See Also Send Feedback
"Friction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsPipeFrictionParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsPipeFrictionParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsPipeFrictionParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsPipeHwfuParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsPipeHwfuParam Property
ParameterTypeId Class See Also Send Feedback
"HWFU"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsPipeHwfuParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsPipeHwfuParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsPipeHwfuParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsPipeInsulationThickness Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsPipeInsulationThickness Property
ParameterTypeId Class See Also Send Feedback
"Insulation Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsPipeInsulationThickness { get; }
Visual Basic
Public Shared ReadOnly Property RbsPipeInsulationThickness As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsPipeInsulationThickness {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsPipeInvertElevation Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsPipeInvertElevation Property
ParameterTypeId Class See Also Send Feedback
"Invert Elevation": This parameter is obsolete. It exists only for compatibility.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsPipeInvertElevation { get; }
Visual Basic
Public Shared ReadOnly Property RbsPipeInvertElevation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsPipeInvertElevation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsPipeJointtypeParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsPipeJointtypeParam Property
ParameterTypeId Class See Also Send Feedback
"Connection Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsPipeJointtypeParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsPipeJointtypeParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsPipeJointtypeParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsPipeMaterialParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsPipeMaterialParam Property
ParameterTypeId Class See Also Send Feedback
"Material"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsPipeMaterialParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsPipeMaterialParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsPipeMaterialParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsPipeOuterDiameter Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsPipeOuterDiameter Property
ParameterTypeId Class See Also Send Feedback
"Outside Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsPipeOuterDiameter { get; }
Visual Basic
Public Shared ReadOnly Property RbsPipeOuterDiameter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsPipeOuterDiameter {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsPipeReynoldsNumberParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsPipeReynoldsNumberParam Property
ParameterTypeId Class See Also Send Feedback
"Reynolds Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsPipeReynoldsNumberParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsPipeReynoldsNumberParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsPipeReynoldsNumberParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsPipeSizeFormattedParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsPipeSizeFormattedParam Property
ParameterTypeId Class See Also Send Feedback
"Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsPipeSizeFormattedParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsPipeSizeFormattedParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsPipeSizeFormattedParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsPipeSizeMaximum Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsPipeSizeMaximum Property
ParameterTypeId Class See Also Send Feedback
"Maximum Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsPipeSizeMaximum { get; }
Visual Basic
Public Shared ReadOnly Property RbsPipeSizeMaximum As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsPipeSizeMaximum {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsPipeSizeMinimum Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsPipeSizeMinimum Property
ParameterTypeId Class See Also Send Feedback
"Minimum Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsPipeSizeMinimum { get; }
Visual Basic
Public Shared ReadOnly Property RbsPipeSizeMinimum As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsPipeSizeMinimum {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsPipeSlope Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsPipeSlope Property
ParameterTypeId Class See Also Send Feedback
"Slope"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsPipeSlope { get; }
Visual Basic
Public Shared ReadOnly Property RbsPipeSlope As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsPipeSlope {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsPipeSlopeDefParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsPipeSlopeDefParam Property
ParameterTypeId Class See Also Send Feedback
"Pipe Slope Definitions"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsPipeSlopeDefParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsPipeSlopeDefParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsPipeSlopeDefParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsPipeSlopeOptionsDefParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsPipeSlopeOptionsDefParam Property
ParameterTypeId Class See Also Send Feedback
"Pipe Slope Options"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsPipeSlopeOptionsDefParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsPipeSlopeOptionsDefParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsPipeSlopeOptionsDefParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsPipeStaticPressure Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsPipeStaticPressure Property
ParameterTypeId Class See Also Send Feedback
"Static Pressure"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsPipeStaticPressure { get; }
Visual Basic
Public Shared ReadOnly Property RbsPipeStaticPressure As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsPipeStaticPressure {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsPipeSystemFixtureUnitParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsPipeSystemFixtureUnitParam Property
ParameterTypeId Class See Also Send Feedback
"Fixture Units"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsPipeSystemFixtureUnitParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsPipeSystemFixtureUnitParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsPipeSystemFixtureUnitParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsPipeTopElevation Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsPipeTopElevation Property
ParameterTypeId Class See Also Send Feedback
"Upper End Top Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsPipeTopElevation { get; }
Visual Basic
Public Shared ReadOnly Property RbsPipeTopElevation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsPipeTopElevation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsPipeTypeFittingLossMethodParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsPipeTypeFittingLossMethodParam Property
ParameterTypeId Class See Also Send Feedback
"Loss Method"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsPipeTypeFittingLossMethodParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsPipeTypeFittingLossMethodParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsPipeTypeFittingLossMethodParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsPipeTypeFittingLossTableParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsPipeTypeFittingLossTableParam Property
ParameterTypeId Class See Also Send Feedback
"K Coefficient Table"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsPipeTypeFittingLossTableParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsPipeTypeFittingLossTableParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsPipeTypeFittingLossTableParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsPipeTypeParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsPipeTypeParam Property
ParameterTypeId Class See Also Send Feedback
"Pipe Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsPipeTypeParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsPipeTypeParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsPipeTypeParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsPipeTypeValveLossCvfactorParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsPipeTypeValveLossCvfactorParam Property
ParameterTypeId Class See Also Send Feedback
"Cv Coefficient"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsPipeTypeValveLossCvfactorParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsPipeTypeValveLossCvfactorParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsPipeTypeValveLossCvfactorParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsPipeValveLossCvfactorParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsPipeValveLossCvfactorParam Property
ParameterTypeId Class See Also Send Feedback
"Cv Coefficient"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsPipeValveLossCvfactorParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsPipeValveLossCvfactorParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsPipeValveLossCvfactorParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsPipeVelocityParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsPipeVelocityParam Property
ParameterTypeId Class See Also Send Feedback
"Velocity"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsPipeVelocityParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsPipeVelocityParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsPipeVelocityParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsPipeVolumeParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsPipeVolumeParam Property
ParameterTypeId Class See Also Send Feedback
"Volume"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsPipeVolumeParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsPipeVolumeParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsPipeVolumeParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsPipeWallThickness Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsPipeWallThickness Property
ParameterTypeId Class See Also Send Feedback
"Wall Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsPipeWallThickness { get; }
Visual Basic
Public Shared ReadOnly Property RbsPipeWallThickness As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsPipeWallThickness {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsPipingSystemTypeParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsPipingSystemTypeParam Property
ParameterTypeId Class See Also Send Feedback
"System Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsPipingSystemTypeParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsPipingSystemTypeParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsPipingSystemTypeParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsPressureDrop Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsPressureDrop Property
ParameterTypeId Class See Also Send Feedback
"Pressure Drop"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsPressureDrop { get; }
Visual Basic
Public Shared ReadOnly Property RbsPressureDrop As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsPressureDrop {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsProjectConstructionTypeShadingfactorParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsProjectConstructionTypeShadingfactorParam Property
ParameterTypeId Class See Also Send Feedback
"Internal Shading Factor"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsProjectConstructionTypeShadingfactorParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsProjectConstructionTypeShadingfactorParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsProjectConstructionTypeShadingfactorParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsProjectLocationParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsProjectLocationParam Property
ParameterTypeId Class See Also Send Feedback
"Location"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsProjectLocationParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsProjectLocationParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsProjectLocationParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsProjectReporttypeParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsProjectReporttypeParam Property
ParameterTypeId Class See Also Send Feedback
"Report Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsProjectReporttypeParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsProjectReporttypeParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsProjectReporttypeParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsReferenceFreesize Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsReferenceFreesize Property
ParameterTypeId Class See Also Send Feedback
"Free Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsReferenceFreesize { get; }
Visual Basic
Public Shared ReadOnly Property RbsReferenceFreesize As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsReferenceFreesize {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsReferenceInsulationType Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsReferenceInsulationType Property
ParameterTypeId Class See Also Send Feedback
"Insulation Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsReferenceInsulationType { get; }
Visual Basic
Public Shared ReadOnly Property RbsReferenceInsulationType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsReferenceInsulationType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsReferenceLiningType Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsReferenceLiningType Property
ParameterTypeId Class See Also Send Feedback
"Lining Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsReferenceLiningType { get; }
Visual Basic
Public Shared ReadOnly Property RbsReferenceLiningType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsReferenceLiningType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsReynoldsnumberParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsReynoldsnumberParam Property
ParameterTypeId Class See Also Send Feedback
"Reynolds number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsReynoldsnumberParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsReynoldsnumberParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsReynoldsnumberParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsRoomCoefficientUtilization Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsRoomCoefficientUtilization Property
ParameterTypeId Class See Also Send Feedback
"Coefficient of Utilization"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsRoomCoefficientUtilization { get; }
Visual Basic
Public Shared ReadOnly Property RbsRoomCoefficientUtilization As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsRoomCoefficientUtilization {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsRoutingPreferenceParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsRoutingPreferenceParam Property
ParameterTypeId Class See Also Send Feedback
"Routing Preferences"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsRoutingPreferenceParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsRoutingPreferenceParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsRoutingPreferenceParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsSection Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsSection Property
ParameterTypeId Class See Also Send Feedback
"Section"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsSection { get; }
Visual Basic
Public Shared ReadOnly Property RbsSection As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsSection {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsShowProfileType Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsShowProfileType Property
ParameterTypeId Class See Also Send Feedback
"Show Round"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsShowProfileType { get; }
Visual Basic
Public Shared ReadOnly Property RbsShowProfileType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsShowProfileType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsSizeLock Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsSizeLock Property
ParameterTypeId Class See Also Send Feedback
"Size Lock"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsSizeLock { get; }
Visual Basic
Public Shared ReadOnly Property RbsSizeLock As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsSizeLock {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsStartLevelParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsStartLevelParam Property
ParameterTypeId Class See Also Send Feedback
"Reference Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsStartLevelParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsStartLevelParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsStartLevelParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsSystemAbbreviationParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsSystemAbbreviationParam Property
ParameterTypeId Class See Also Send Feedback
"Abbreviation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsSystemAbbreviationParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsSystemAbbreviationParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsSystemAbbreviationParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsSystemBaseElementParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsSystemBaseElementParam Property
ParameterTypeId Class See Also Send Feedback
"System Equipment"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsSystemBaseElementParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsSystemBaseElementParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsSystemBaseElementParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsSystemClassificationParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsSystemClassificationParam Property
ParameterTypeId Class See Also Send Feedback
"System Classification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsSystemClassificationParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsSystemClassificationParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsSystemClassificationParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsSystemFlowConversionMethodParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsSystemFlowConversionMethodParam Property
ParameterTypeId Class See Also Send Feedback
"Flow Conversion Method"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsSystemFlowConversionMethodParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsSystemFlowConversionMethodParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsSystemFlowConversionMethodParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsSystemNameParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsSystemNameParam Property
ParameterTypeId Class See Also Send Feedback
"System Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsSystemNameParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsSystemNameParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsSystemNameParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsSystemNumElementsParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsSystemNumElementsParam Property
ParameterTypeId Class See Also Send Feedback
"Number of Elements"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsSystemNumElementsParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsSystemNumElementsParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsSystemNumElementsParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsSystemRisedrop1linedropsymbolParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsSystemRisedrop1linedropsymbolParam Property
ParameterTypeId Class See Also Send Feedback
"Single Line Drop Symbol"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsSystemRisedrop1linedropsymbolParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsSystemRisedrop1linedropsymbolParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsSystemRisedrop1linedropsymbolParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsSystemRisedrop1linerisesymbolParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsSystemRisedrop1linerisesymbolParam Property
ParameterTypeId Class See Also Send Feedback
"Single Line Rise Symbol"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsSystemRisedrop1linerisesymbolParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsSystemRisedrop1linerisesymbolParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsSystemRisedrop1linerisesymbolParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsSystemRisedrop2linedropsymbolParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsSystemRisedrop2linedropsymbolParam Property
ParameterTypeId Class See Also Send Feedback
"Two Line Drop Symbol"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsSystemRisedrop2linedropsymbolParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsSystemRisedrop2linedropsymbolParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsSystemRisedrop2linedropsymbolParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsSystemRisedrop2linerisesymbolParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsSystemRisedrop2linerisesymbolParam Property
ParameterTypeId Class See Also Send Feedback
"Two Line Rise Symbol"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsSystemRisedrop2linerisesymbolParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsSystemRisedrop2linerisesymbolParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsSystemRisedrop2linerisesymbolParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsSystemRisedropParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsSystemRisedropParam Property
ParameterTypeId Class See Also Send Feedback
"Rise / Drop Symbol"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsSystemRisedropParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsSystemRisedropParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsSystemRisedropParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsVelocity Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsVelocity Property
ParameterTypeId Class See Also Send Feedback
"Velocity"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsVelocity { get; }
Visual Basic
Public Shared ReadOnly Property RbsVelocity As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsVelocity {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsVelocityPressure Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsVelocityPressure Property
ParameterTypeId Class See Also Send Feedback
"Velocity Pressure"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsVelocityPressure { get; }
Visual Basic
Public Shared ReadOnly Property RbsVelocityPressure As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsVelocityPressure {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsVoltagetypeMaxvoltageParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsVoltagetypeMaxvoltageParam Property
ParameterTypeId Class See Also Send Feedback
"Maximum Voltage"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsVoltagetypeMaxvoltageParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsVoltagetypeMaxvoltageParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsVoltagetypeMaxvoltageParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsVoltagetypeMinvoltageParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsVoltagetypeMinvoltageParam Property
ParameterTypeId Class See Also Send Feedback
"Minimum Voltage"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsVoltagetypeMinvoltageParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsVoltagetypeMinvoltageParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsVoltagetypeMinvoltageParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsVoltagetypeVoltageParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsVoltagetypeVoltageParam Property
ParameterTypeId Class See Also Send Feedback
"Actual Voltage"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsVoltagetypeVoltageParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsVoltagetypeVoltageParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsVoltagetypeVoltageParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsWireCircuitLoadName Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsWireCircuitLoadName Property
ParameterTypeId Class See Also Send Feedback
"Circuit Load Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsWireCircuitLoadName { get; }
Visual Basic
Public Shared ReadOnly Property RbsWireCircuitLoadName As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsWireCircuitLoadName {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsWireInsulationParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsWireInsulationParam Property
ParameterTypeId Class See Also Send Feedback
"Insulation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsWireInsulationParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsWireInsulationParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsWireInsulationParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsWireMaterialParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsWireMaterialParam Property
ParameterTypeId Class See Also Send Feedback
"Material"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsWireMaterialParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsWireMaterialParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsWireMaterialParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsWireMaxConductorSizeParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsWireMaxConductorSizeParam Property
ParameterTypeId Class See Also Send Feedback
"Max Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsWireMaxConductorSizeParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsWireMaxConductorSizeParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsWireMaxConductorSizeParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsWireNeutralIncludedInBalancedLoadParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsWireNeutralIncludedInBalancedLoadParam Property
ParameterTypeId Class See Also Send Feedback
"Neutral Included in Balanced Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsWireNeutralIncludedInBalancedLoadParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsWireNeutralIncludedInBalancedLoadParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsWireNeutralIncludedInBalancedLoadParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsWireNeutralModeParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsWireNeutralModeParam Property
ParameterTypeId Class See Also Send Feedback
"Neutral Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsWireNeutralModeParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsWireNeutralModeParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsWireNeutralModeParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsWireNeutralMultiplierParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsWireNeutralMultiplierParam Property
ParameterTypeId Class See Also Send Feedback
"Neutral Multiplier"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsWireNeutralMultiplierParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsWireNeutralMultiplierParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsWireNeutralMultiplierParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RbsWireTemperatureRatingParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RbsWireTemperatureRatingParam Property
ParameterTypeId Class See Also Send Feedback
"Temperature Rating"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RbsWireTemperatureRatingParam { get; }
Visual Basic
Public Shared ReadOnly Property RbsWireTemperatureRatingParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RbsWireTemperatureRatingParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarBarDeformationType Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarBarDeformationType Property
ParameterTypeId Class See Also Send Feedback
"Deformation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarBarDeformationType { get; }
Visual Basic
Public Shared ReadOnly Property RebarBarDeformationType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarBarDeformationType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarBarDiameter Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarBarDiameter Property
ParameterTypeId Class See Also Send Feedback
"Bar Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarBarDiameter { get; }
Visual Basic
Public Shared ReadOnly Property RebarBarDiameter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarBarDiameter {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarBarMaximumBendRadius Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarBarMaximumBendRadius Property
ParameterTypeId Class See Also Send Feedback
"Maximum Bend Radius"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarBarMaximumBendRadius { get; }
Visual Basic
Public Shared ReadOnly Property RebarBarMaximumBendRadius As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarBarMaximumBendRadius {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarBarStirrupBendDiameter Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarBarStirrupBendDiameter Property
ParameterTypeId Class See Also Send Feedback
"Stirrup/Tie Bend Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarBarStirrupBendDiameter { get; }
Visual Basic
Public Shared ReadOnly Property RebarBarStirrupBendDiameter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarBarStirrupBendDiameter {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarContainerBarType Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarContainerBarType Property
ParameterTypeId Class See Also Send Feedback
"Bar Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarContainerBarType { get; }
Visual Basic
Public Shared ReadOnly Property RebarContainerBarType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarContainerBarType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarDistributionType Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarDistributionType Property
ParameterTypeId Class See Also Send Feedback
"Distribution Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarDistributionType { get; }
Visual Basic
Public Shared ReadOnly Property RebarDistributionType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarDistributionType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarElemBarSpacing Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarElemBarSpacing Property
ParameterTypeId Class See Also Send Feedback
"Spacing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarElemBarSpacing { get; }
Visual Basic
Public Shared ReadOnly Property RebarElemBarSpacing As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarElemBarSpacing {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarElemEndtreatmentEnd Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarElemEndtreatmentEnd Property
ParameterTypeId Class See Also Send Feedback
"End Treatment At End"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarElemEndtreatmentEnd { get; }
Visual Basic
Public Shared ReadOnly Property RebarElemEndtreatmentEnd As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarElemEndtreatmentEnd {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarElemEndtreatmentStart Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarElemEndtreatmentStart Property
ParameterTypeId Class See Also Send Feedback
"End Treatment At Start"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarElemEndtreatmentStart { get; }
Visual Basic
Public Shared ReadOnly Property RebarElemEndtreatmentStart As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarElemEndtreatmentStart {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarElemHookEndOrient Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarElemHookEndOrient Property
ParameterTypeId Class See Also Send Feedback
"Hook Orientation At End"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarElemHookEndOrient { get; }
Visual Basic
Public Shared ReadOnly Property RebarElemHookEndOrient As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarElemHookEndOrient {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarElemHookEndType Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarElemHookEndType Property
ParameterTypeId Class See Also Send Feedback
"Hook At End"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarElemHookEndType { get; }
Visual Basic
Public Shared ReadOnly Property RebarElemHookEndType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarElemHookEndType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarElemHookStartOrient Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarElemHookStartOrient Property
ParameterTypeId Class See Also Send Feedback
"Hook Orientation At Start"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarElemHookStartOrient { get; }
Visual Basic
Public Shared ReadOnly Property RebarElemHookStartOrient As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarElemHookStartOrient {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarElemHookStartType Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarElemHookStartType Property
ParameterTypeId Class See Also Send Feedback
"Hook At Start"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarElemHookStartType { get; }
Visual Basic
Public Shared ReadOnly Property RebarElemHookStartType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarElemHookStartType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarElemHookStyle Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarElemHookStyle Property
ParameterTypeId Class See Also Send Feedback
"Style"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarElemHookStyle { get; }
Visual Basic
Public Shared ReadOnly Property RebarElemHookStyle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarElemHookStyle {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarElemHostMark Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarElemHostMark Property
ParameterTypeId Class See Also Send Feedback
"Host Mark"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarElemHostMark { get; }
Visual Basic
Public Shared ReadOnly Property RebarElemHostMark As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarElemHostMark {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarElemLength Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarElemLength Property
ParameterTypeId Class See Also Send Feedback
"Bar Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarElemLength { get; }
Visual Basic
Public Shared ReadOnly Property RebarElemLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarElemLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarElemQuantityOfBars Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarElemQuantityOfBars Property
ParameterTypeId Class See Also Send Feedback
"Quantity"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarElemQuantityOfBars { get; }
Visual Basic
Public Shared ReadOnly Property RebarElemQuantityOfBars As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarElemQuantityOfBars {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarElemScheduleMark Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarElemScheduleMark Property
ParameterTypeId Class See Also Send Feedback
"Schedule Mark"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarElemScheduleMark { get; }
Visual Basic
Public Shared ReadOnly Property RebarElemScheduleMark As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarElemScheduleMark {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarElemTotalLength Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarElemTotalLength Property
ParameterTypeId Class See Also Send Feedback
"Total Bar Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarElemTotalLength { get; }
Visual Basic
Public Shared ReadOnly Property RebarElemTotalLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarElemTotalLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarFreeFormHookEndPlaneAngle Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarFreeFormHookEndPlaneAngle Property
ParameterTypeId Class See Also Send Feedback
"Hook Orientation At End"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarFreeFormHookEndPlaneAngle { get; }
Visual Basic
Public Shared ReadOnly Property RebarFreeFormHookEndPlaneAngle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarFreeFormHookEndPlaneAngle {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarGeometryType Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarGeometryType Property
ParameterTypeId Class See Also Send Feedback
"Geometry"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarGeometryType { get; }
Visual Basic
Public Shared ReadOnly Property RebarGeometryType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarGeometryType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarHookAngle Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarHookAngle Property
ParameterTypeId Class See Also Send Feedback
"Hook Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarHookAngle { get; }
Visual Basic
Public Shared ReadOnly Property RebarHookAngle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarHookAngle {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarHookLineLenFactor Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarHookLineLenFactor Property
ParameterTypeId Class See Also Send Feedback
"Extension Multiplier"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarHookLineLenFactor { get; }
Visual Basic
Public Shared ReadOnly Property RebarHookLineLenFactor As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarHookLineLenFactor {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarHookRotationAtEndSchedulesTagsFilters Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarHookRotationAtEndSchedulesTagsFilters Property
ParameterTypeId Class See Also Send Feedback
"Hook Rotation At End"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarHookRotationAtEndSchedulesTagsFilters { get; }
Visual Basic
Public Shared ReadOnly Property RebarHookRotationAtEndSchedulesTagsFilters As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarHookRotationAtEndSchedulesTagsFilters {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarHookRotationAtStartSchedulesTagsFilters Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarHookRotationAtStartSchedulesTagsFilters Property
ParameterTypeId Class See Also Send Feedback
"Hook Rotation At Start"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarHookRotationAtStartSchedulesTagsFilters { get; }
Visual Basic
Public Shared ReadOnly Property RebarHookRotationAtStartSchedulesTagsFilters As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarHookRotationAtStartSchedulesTagsFilters {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarHookStyle Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarHookStyle Property
ParameterTypeId Class See Also Send Feedback
"Style"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarHookStyle { get; }
Visual Basic
Public Shared ReadOnly Property RebarHookStyle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarHookStyle {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarIncludeLastBar Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarIncludeLastBar Property
ParameterTypeId Class See Also Send Feedback
"Include Last Bar"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarIncludeLastBar { get; }
Visual Basic
Public Shared ReadOnly Property RebarIncludeLastBar As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarIncludeLastBar {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarInstanceBarDiameter Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarInstanceBarDiameter Property
ParameterTypeId Class See Also Send Feedback
"Bar Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarInstanceBarDiameter { get; }
Visual Basic
Public Shared ReadOnly Property RebarInstanceBarDiameter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarInstanceBarDiameter {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarInstanceBarModelDiameter Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarInstanceBarModelDiameter Property
ParameterTypeId Class See Also Send Feedback
"Model Bar Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarInstanceBarModelDiameter { get; }
Visual Basic
Public Shared ReadOnly Property RebarInstanceBarModelDiameter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarInstanceBarModelDiameter {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarInternalMultiplanar Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarInternalMultiplanar Property
ParameterTypeId Class See Also Send Feedback
"INTERNAL: Multiplanar"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarInternalMultiplanar { get; }
Visual Basic
Public Shared ReadOnly Property RebarInternalMultiplanar As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarInternalMultiplanar {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarInternalMultiplanarArcConnector Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarInternalMultiplanarArcConnector Property
ParameterTypeId Class See Also Send Feedback
"INTERNAL: Multiplanar Arc Connector"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarInternalMultiplanarArcConnector { get; }
Visual Basic
Public Shared ReadOnly Property RebarInternalMultiplanarArcConnector As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarInternalMultiplanarArcConnector {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarInternalMultiplanarDuplicate Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarInternalMultiplanarDuplicate Property
ParameterTypeId Class See Also Send Feedback
"INTERNAL: Multiplanar Duplicate"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarInternalMultiplanarDuplicate { get; }
Visual Basic
Public Shared ReadOnly Property RebarInternalMultiplanarDuplicate As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarInternalMultiplanarDuplicate {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarInternalMultiplanarEndConnector Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarInternalMultiplanarEndConnector Property
ParameterTypeId Class See Also Send Feedback
"INTERNAL: Multiplanar End Connector"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarInternalMultiplanarEndConnector { get; }
Visual Basic
Public Shared ReadOnly Property RebarInternalMultiplanarEndConnector As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarInternalMultiplanarEndConnector {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarInternalMultiplanarStartConnector Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarInternalMultiplanarStartConnector Property
ParameterTypeId Class See Also Send Feedback
"INTERNAL: Multiplanar Start Connector"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarInternalMultiplanarStartConnector { get; }
Visual Basic
Public Shared ReadOnly Property RebarInternalMultiplanarStartConnector As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarInternalMultiplanarStartConnector {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarMaximSuffix Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarMaximSuffix Property
ParameterTypeId Class See Also Send Feedback
"Maxim Suffix"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarMaximSuffix { get; }
Visual Basic
Public Shared ReadOnly Property RebarMaximSuffix As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarMaximSuffix {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarMinimSuffix Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarMinimSuffix Property
ParameterTypeId Class See Also Send Feedback
"Minim Suffix"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarMinimSuffix { get; }
Visual Basic
Public Shared ReadOnly Property RebarMinimSuffix As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarMinimSuffix {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarMinLength Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarMinLength Property
ParameterTypeId Class See Also Send Feedback
"Minimum bar length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarMinLength { get; }
Visual Basic
Public Shared ReadOnly Property RebarMinLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarMinLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarModifiedSet Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarModifiedSet Property
ParameterTypeId Class See Also Send Feedback
"Modified Rebar Set"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarModifiedSet { get; }
Visual Basic
Public Shared ReadOnly Property RebarModifiedSet As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarModifiedSet {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarNumberSuffix Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarNumberSuffix Property
ParameterTypeId Class See Also Send Feedback
"Rebar Number Suffix"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarNumberSuffix { get; }
Visual Basic
Public Shared ReadOnly Property RebarNumberSuffix As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarNumberSuffix {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarQuanityByDistrib Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarQuanityByDistrib Property
ParameterTypeId Class See Also Send Feedback
"Quantity By Rebar Set"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarQuanityByDistrib { get; }
Visual Basic
Public Shared ReadOnly Property RebarQuanityByDistrib As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarQuanityByDistrib {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarShape Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarShape Property
ParameterTypeId Class See Also Send Feedback
"Shape"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarShape { get; }
Visual Basic
Public Shared ReadOnly Property RebarShape As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarShape {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarShapeAllowedBarTypes Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarShapeAllowedBarTypes Property
ParameterTypeId Class See Also Send Feedback
"Allowable Rebar Bar Types"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarShapeAllowedBarTypes { get; }
Visual Basic
Public Shared ReadOnly Property RebarShapeAllowedBarTypes As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarShapeAllowedBarTypes {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarShapeEndHookLength Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarShapeEndHookLength Property
ParameterTypeId Class See Also Send Feedback
"End Hook Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarShapeEndHookLength { get; }
Visual Basic
Public Shared ReadOnly Property RebarShapeEndHookLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarShapeEndHookLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarShapeEndHookOffset Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarShapeEndHookOffset Property
ParameterTypeId Class See Also Send Feedback
"End Hook Offset Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarShapeEndHookOffset { get; }
Visual Basic
Public Shared ReadOnly Property RebarShapeEndHookOffset As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarShapeEndHookOffset {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarShapeEndtreatmentStartType Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarShapeEndtreatmentStartType Property
ParameterTypeId Class See Also Send Feedback
"End Treatment At Start"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarShapeEndtreatmentStartType { get; }
Visual Basic
Public Shared ReadOnly Property RebarShapeEndtreatmentStartType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarShapeEndtreatmentStartType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarShapeHookRotationAtEnd Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarShapeHookRotationAtEnd Property
ParameterTypeId Class See Also Send Feedback
"Hook Rotation At End"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarShapeHookRotationAtEnd { get; }
Visual Basic
Public Shared ReadOnly Property RebarShapeHookRotationAtEnd As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarShapeHookRotationAtEnd {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarShapeHookStartType Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarShapeHookStartType Property
ParameterTypeId Class See Also Send Feedback
"Hook At Start"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarShapeHookStartType { get; }
Visual Basic
Public Shared ReadOnly Property RebarShapeHookStartType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarShapeHookStartType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarShapeImage Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarShapeImage Property
ParameterTypeId Class See Also Send Feedback
"Shape Image"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarShapeImage { get; }
Visual Basic
Public Shared ReadOnly Property RebarShapeImage As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarShapeImage {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarShapeOutOfPlaneBendDiameter Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarShapeOutOfPlaneBendDiameter Property
ParameterTypeId Class See Also Send Feedback
"Out of Plane Bend Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarShapeOutOfPlaneBendDiameter { get; }
Visual Basic
Public Shared ReadOnly Property RebarShapeOutOfPlaneBendDiameter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarShapeOutOfPlaneBendDiameter {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarShapeParamStartHookTanLen Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarShapeParamStartHookTanLen Property
ParameterTypeId Class See Also Send Feedback
"Start Tangent Hook Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarShapeParamStartHookTanLen { get; }
Visual Basic
Public Shared ReadOnly Property RebarShapeParamStartHookTanLen As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarShapeParamStartHookTanLen {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarShapeSpiralHeight Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarShapeSpiralHeight Property
ParameterTypeId Class See Also Send Feedback
"Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarShapeSpiralHeight { get; }
Visual Basic
Public Shared ReadOnly Property RebarShapeSpiralHeight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarShapeSpiralHeight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarShapeSpiralPitch Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarShapeSpiralPitch Property
ParameterTypeId Class See Also Send Feedback
"Pitch"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarShapeSpiralPitch { get; }
Visual Basic
Public Shared ReadOnly Property RebarShapeSpiralPitch As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarShapeSpiralPitch {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarShapeSpiralTopFinishingTurns Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarShapeSpiralTopFinishingTurns Property
ParameterTypeId Class See Also Send Feedback
"Top Finishing Turns"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarShapeSpiralTopFinishingTurns { get; }
Visual Basic
Public Shared ReadOnly Property RebarShapeSpiralTopFinishingTurns As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarShapeSpiralTopFinishingTurns {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarShapeStartHookLength Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarShapeStartHookLength Property
ParameterTypeId Class See Also Send Feedback
"Start Hook Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarShapeStartHookLength { get; }
Visual Basic
Public Shared ReadOnly Property RebarShapeStartHookLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarShapeStartHookLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarShapeStartHookOffset Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarShapeStartHookOffset Property
ParameterTypeId Class See Also Send Feedback
"Start Hook Offset Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarShapeStartHookOffset { get; }
Visual Basic
Public Shared ReadOnly Property RebarShapeStartHookOffset As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarShapeStartHookOffset {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarShapeStirrupTieAttachment Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarShapeStirrupTieAttachment Property
ParameterTypeId Class See Also Send Feedback
"Stirrup/Tie Attachment"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarShapeStirrupTieAttachment { get; }
Visual Basic
Public Shared ReadOnly Property RebarShapeStirrupTieAttachment As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarShapeStirrupTieAttachment {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarStandardBendDiameter Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarStandardBendDiameter Property
ParameterTypeId Class See Also Send Feedback
"Standard Bend Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarStandardBendDiameter { get; }
Visual Basic
Public Shared ReadOnly Property RebarStandardBendDiameter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarStandardBendDiameter {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemActiveBottomDir1Generic Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemActiveBottomDir1Generic Property
ParameterTypeId Class See Also Send Feedback
"Bottom/Interior Major Direction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemActiveBottomDir1Generic { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemActiveBottomDir1Generic As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemActiveBottomDir1Generic {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemActiveBottomDir2Generic Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemActiveBottomDir2Generic Property
ParameterTypeId Class See Also Send Feedback
"Bottom/Interior Minor Direction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemActiveBottomDir2Generic { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemActiveBottomDir2Generic As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemActiveBottomDir2Generic {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemActiveBottomDirn1 Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemActiveBottomDirn1 Property
ParameterTypeId Class See Also Send Feedback
"Bottom Major Direction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemActiveBottomDirn1 { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemActiveBottomDirn1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemActiveBottomDirn1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemActiveBottomDirn2 Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemActiveBottomDirn2 Property
ParameterTypeId Class See Also Send Feedback
"Bottom Minor Direction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemActiveBottomDirn2 { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemActiveBottomDirn2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemActiveBottomDirn2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemActiveFrontDirn2 Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemActiveFrontDirn2 Property
ParameterTypeId Class See Also Send Feedback
"Exterior Minor Direction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemActiveFrontDirn2 { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemActiveFrontDirn2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemActiveFrontDirn2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemActiveTopDir1Generic Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemActiveTopDir1Generic Property
ParameterTypeId Class See Also Send Feedback
"Top/Exterior Major Direction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemActiveTopDir1Generic { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemActiveTopDir1Generic As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemActiveTopDir1Generic {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemActiveTopDir2Generic Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemActiveTopDir2Generic Property
ParameterTypeId Class See Also Send Feedback
"Top/Exterior Minor Direction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemActiveTopDir2Generic { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemActiveTopDir2Generic As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemActiveTopDir2Generic {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemActiveTopDirn1 Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemActiveTopDirn1 Property
ParameterTypeId Class See Also Send Feedback
"Top Major Direction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemActiveTopDirn1 { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemActiveTopDirn1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemActiveTopDirn1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemActiveTopDirn2 Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemActiveTopDirn2 Property
ParameterTypeId Class See Also Send Feedback
"Top Minor Direction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemActiveTopDirn2 { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemActiveTopDirn2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemActiveTopDirn2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemAddlBottomOffset Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemAddlBottomOffset Property
ParameterTypeId Class See Also Send Feedback
"Additional Bottom Cover Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemAddlBottomOffset { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemAddlBottomOffset As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemAddlBottomOffset {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemAddlInteriorOffset Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemAddlInteriorOffset Property
ParameterTypeId Class See Also Send Feedback
"Additional Interior Cover Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemAddlInteriorOffset { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemAddlInteriorOffset As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemAddlInteriorOffset {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemAddlTopOffset Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemAddlTopOffset Property
ParameterTypeId Class See Also Send Feedback
"Additional Top Cover Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemAddlTopOffset { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemAddlTopOffset As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemAddlTopOffset {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemBarTypeBackDirn1 Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemBarTypeBackDirn1 Property
ParameterTypeId Class See Also Send Feedback
"Interior Major Bar Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemBarTypeBackDirn1 { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemBarTypeBackDirn1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemBarTypeBackDirn1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemBarTypeBackDirn2 Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemBarTypeBackDirn2 Property
ParameterTypeId Class See Also Send Feedback
"Interior Minor Bar Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemBarTypeBackDirn2 { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemBarTypeBackDirn2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemBarTypeBackDirn2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemBarTypeBottomDir1Generic Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemBarTypeBottomDir1Generic Property
ParameterTypeId Class See Also Send Feedback
"Bottom/Interior Major Bar Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemBarTypeBottomDir1Generic { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemBarTypeBottomDir1Generic As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemBarTypeBottomDir1Generic {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemBarTypeBottomDir2Generic Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemBarTypeBottomDir2Generic Property
ParameterTypeId Class See Also Send Feedback
"Bottom/Interior Minor Bar Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemBarTypeBottomDir2Generic { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemBarTypeBottomDir2Generic As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemBarTypeBottomDir2Generic {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemBarTypeBottomDirn1 Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemBarTypeBottomDirn1 Property
ParameterTypeId Class See Also Send Feedback
"Bottom Major Bar Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemBarTypeBottomDirn1 { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemBarTypeBottomDirn1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemBarTypeBottomDirn1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemBarTypeBottomDirn2 Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemBarTypeBottomDirn2 Property
ParameterTypeId Class See Also Send Feedback
"Bottom Minor Bar Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemBarTypeBottomDirn2 { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemBarTypeBottomDirn2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemBarTypeBottomDirn2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemBarTypeTopDir1Generic Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemBarTypeTopDir1Generic Property
ParameterTypeId Class See Also Send Feedback
"Top/Exterior Major Bar Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemBarTypeTopDir1Generic { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemBarTypeTopDir1Generic As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemBarTypeTopDir1Generic {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemBarTypeTopDir2Generic Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemBarTypeTopDir2Generic Property
ParameterTypeId Class See Also Send Feedback
"Top/Exterior Minor Bar Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemBarTypeTopDir2Generic { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemBarTypeTopDir2Generic As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemBarTypeTopDir2Generic {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemBarTypeTopDirn1 Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemBarTypeTopDirn1 Property
ParameterTypeId Class See Also Send Feedback
"Top Major Bar Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemBarTypeTopDirn1 { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemBarTypeTopDirn1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemBarTypeTopDirn1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemBarTypeTopDirn2 Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemBarTypeTopDirn2 Property
ParameterTypeId Class See Also Send Feedback
"Top Minor Bar Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemBarTypeTopDirn2 { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemBarTypeTopDirn2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemBarTypeTopDirn2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemBottomMajorMatchesBottomMinor Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemBottomMajorMatchesBottomMinor Property
ParameterTypeId Class See Also Send Feedback
"Bottom Major and Minor Layers Match"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemBottomMajorMatchesBottomMinor { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemBottomMajorMatchesBottomMinor As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemBottomMajorMatchesBottomMinor {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemCoverBottom Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemCoverBottom Property
ParameterTypeId Class See Also Send Feedback
"Rebar Cover Bottom/Interior"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemCoverBottom { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemCoverBottom As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemCoverBottom {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemCoverSide Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemCoverSide Property
ParameterTypeId Class See Also Send Feedback
"Rebar Cover Side/Edge"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemCoverSide { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemCoverSide As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemCoverSide {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemHookOrientBackDirn1 Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemHookOrientBackDirn1 Property
ParameterTypeId Class See Also Send Feedback
"Interior Major Hook Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemHookOrientBackDirn1 { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemHookOrientBackDirn1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemHookOrientBackDirn1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemHookOrientBackDirn2 Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemHookOrientBackDirn2 Property
ParameterTypeId Class See Also Send Feedback
"Interior Minor Hook Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemHookOrientBackDirn2 { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemHookOrientBackDirn2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemHookOrientBackDirn2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemHookOrientBottomDirn1 Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemHookOrientBottomDirn1 Property
ParameterTypeId Class See Also Send Feedback
"Bottom Major Hook Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemHookOrientBottomDirn1 { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemHookOrientBottomDirn1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemHookOrientBottomDirn1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemHookOrientBottomDirn2 Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemHookOrientBottomDirn2 Property
ParameterTypeId Class See Also Send Feedback
"Bottom Minor Hook Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemHookOrientBottomDirn2 { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemHookOrientBottomDirn2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemHookOrientBottomDirn2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemHookOrientFrontDirn2 Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemHookOrientFrontDirn2 Property
ParameterTypeId Class See Also Send Feedback
"Exterior Minor Hook Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemHookOrientFrontDirn2 { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemHookOrientFrontDirn2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemHookOrientFrontDirn2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemHookOrientTopDirn1 Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemHookOrientTopDirn1 Property
ParameterTypeId Class See Also Send Feedback
"Top Major Hook Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemHookOrientTopDirn1 { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemHookOrientTopDirn1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemHookOrientTopDirn1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemHookOrientTopDirn2 Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemHookOrientTopDirn2 Property
ParameterTypeId Class See Also Send Feedback
"Top Minor Hook Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemHookOrientTopDirn2 { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemHookOrientTopDirn2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemHookOrientTopDirn2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemHookTypeBackDirn2 Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemHookTypeBackDirn2 Property
ParameterTypeId Class See Also Send Feedback
"Interior Minor Hook Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemHookTypeBackDirn2 { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemHookTypeBackDirn2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemHookTypeBackDirn2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemHookTypeBottomDirn1 Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemHookTypeBottomDirn1 Property
ParameterTypeId Class See Also Send Feedback
"Bottom Major Hook Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemHookTypeBottomDirn1 { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemHookTypeBottomDirn1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemHookTypeBottomDirn1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemHookTypeBottomDirn2 Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemHookTypeBottomDirn2 Property
ParameterTypeId Class See Also Send Feedback
"Bottom Minor Hook Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemHookTypeBottomDirn2 { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemHookTypeBottomDirn2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemHookTypeBottomDirn2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemHookTypeFrontDirn1 Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemHookTypeFrontDirn1 Property
ParameterTypeId Class See Also Send Feedback
"Exterior Major Hook Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemHookTypeFrontDirn1 { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemHookTypeFrontDirn1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemHookTypeFrontDirn1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemHookTypeTopDirn1 Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemHookTypeTopDirn1 Property
ParameterTypeId Class See Also Send Feedback
"Top Major Hook Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemHookTypeTopDirn1 { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemHookTypeTopDirn1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemHookTypeTopDirn1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemHookTypeTopDirn2 Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemHookTypeTopDirn2 Property
ParameterTypeId Class See Also Send Feedback
"Top Minor Hook Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemHookTypeTopDirn2 { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemHookTypeTopDirn2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemHookTypeTopDirn2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemLayerSummaryBottomDir1WithSpacing Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemLayerSummaryBottomDir1WithSpacing Property
ParameterTypeId Class See Also Send Feedback
"Bottom/Interior Major"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemLayerSummaryBottomDir1WithSpacing { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemLayerSummaryBottomDir1WithSpacing As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemLayerSummaryBottomDir1WithSpacing {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemLayerSummaryBottomDir2NoSpacing Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemLayerSummaryBottomDir2NoSpacing Property
ParameterTypeId Class See Also Send Feedback
"Bottom/Interior Minor (Brief)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemLayerSummaryBottomDir2NoSpacing { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemLayerSummaryBottomDir2NoSpacing As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemLayerSummaryBottomDir2NoSpacing {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemLayerSummaryDir1NoSpacing Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemLayerSummaryDir1NoSpacing Property
ParameterTypeId Class See Also Send Feedback
"Major, Both Faces (Brief)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemLayerSummaryDir1NoSpacing { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemLayerSummaryDir1NoSpacing As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemLayerSummaryDir1NoSpacing {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemLayerSummaryDir1WithSpacing Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemLayerSummaryDir1WithSpacing Property
ParameterTypeId Class See Also Send Feedback
"Major, Both Faces"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemLayerSummaryDir1WithSpacing { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemLayerSummaryDir1WithSpacing As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemLayerSummaryDir1WithSpacing {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemLayerSummaryNoSpacing Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemLayerSummaryNoSpacing Property
ParameterTypeId Class See Also Send Feedback
"Layer Summary (Brief)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemLayerSummaryNoSpacing { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemLayerSummaryNoSpacing As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemLayerSummaryNoSpacing {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemLayerSummaryTopDir1NoSpacing Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemLayerSummaryTopDir1NoSpacing Property
ParameterTypeId Class See Also Send Feedback
"Top/Exterior Major (Brief)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemLayerSummaryTopDir1NoSpacing { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemLayerSummaryTopDir1NoSpacing As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemLayerSummaryTopDir1NoSpacing {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemLayerSummaryTopDir1WithSpacing Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemLayerSummaryTopDir1WithSpacing Property
ParameterTypeId Class See Also Send Feedback
"Top/Exterior Major"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemLayerSummaryTopDir1WithSpacing { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemLayerSummaryTopDir1WithSpacing As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemLayerSummaryTopDir1WithSpacing {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemLayerSummaryTopDir2NoSpacing Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemLayerSummaryTopDir2NoSpacing Property
ParameterTypeId Class See Also Send Feedback
"Top/Exterior Minor (Brief)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemLayerSummaryTopDir2NoSpacing { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemLayerSummaryTopDir2NoSpacing As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemLayerSummaryTopDir2NoSpacing {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemLayerSummaryTopDir2WithSpacing Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemLayerSummaryTopDir2WithSpacing Property
ParameterTypeId Class See Also Send Feedback
"Top/Exterior Minor"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemLayerSummaryTopDir2WithSpacing { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemLayerSummaryTopDir2WithSpacing As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemLayerSummaryTopDir2WithSpacing {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemLayerSummaryWithSpacing Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemLayerSummaryWithSpacing Property
ParameterTypeId Class See Also Send Feedback
"Layer Summary"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemLayerSummaryWithSpacing { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemLayerSummaryWithSpacing As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemLayerSummaryWithSpacing {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemLayoutRule Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemLayoutRule Property
ParameterTypeId Class See Also Send Feedback
"Layout Rule"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemLayoutRule { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemLayoutRule As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemLayoutRule {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemNumberOfLinesBackDirn2 Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemNumberOfLinesBackDirn2 Property
ParameterTypeId Class See Also Send Feedback
"Interior Minor Number Of Lines"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemNumberOfLinesBackDirn2 { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemNumberOfLinesBackDirn2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemNumberOfLinesBackDirn2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemNumberOfLinesBottomDir1Generic Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemNumberOfLinesBottomDir1Generic Property
ParameterTypeId Class See Also Send Feedback
"Bottom/Interior Major Number Of Lines"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemNumberOfLinesBottomDir1Generic { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemNumberOfLinesBottomDir1Generic As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemNumberOfLinesBottomDir1Generic {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemNumberOfLinesBottomDirn1 Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemNumberOfLinesBottomDirn1 Property
ParameterTypeId Class See Also Send Feedback
"Bottom Major Number Of Lines"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemNumberOfLinesBottomDirn1 { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemNumberOfLinesBottomDirn1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemNumberOfLinesBottomDirn1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemNumberOfLinesFrontDirn1 Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemNumberOfLinesFrontDirn1 Property
ParameterTypeId Class See Also Send Feedback
"Exterior Major Number Of Lines"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemNumberOfLinesFrontDirn1 { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemNumberOfLinesFrontDirn1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemNumberOfLinesFrontDirn1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemNumberOfLinesFrontDirn2 Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemNumberOfLinesFrontDirn2 Property
ParameterTypeId Class See Also Send Feedback
"Exterior Minor Number Of Lines"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemNumberOfLinesFrontDirn2 { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemNumberOfLinesFrontDirn2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemNumberOfLinesFrontDirn2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemNumberOfLinesTopDir1Generic Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemNumberOfLinesTopDir1Generic Property
ParameterTypeId Class See Also Send Feedback
"Top/Exterior Major Number Of Lines"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemNumberOfLinesTopDir1Generic { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemNumberOfLinesTopDir1Generic As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemNumberOfLinesTopDir1Generic {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemNumberOfLinesTopDirn1 Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemNumberOfLinesTopDirn1 Property
ParameterTypeId Class See Also Send Feedback
"Top Major Number Of Lines"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemNumberOfLinesTopDirn1 { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemNumberOfLinesTopDirn1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemNumberOfLinesTopDirn1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemOverride Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemOverride Property
ParameterTypeId Class See Also Send Feedback
"Override Area Reinforcement Settings"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemOverride { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemOverride As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemOverride {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemSpacingBackDirn1 Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemSpacingBackDirn1 Property
ParameterTypeId Class See Also Send Feedback
"Interior Major Spacing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemSpacingBackDirn1 { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemSpacingBackDirn1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemSpacingBackDirn1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemSpacingBackDirn2 Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemSpacingBackDirn2 Property
ParameterTypeId Class See Also Send Feedback
"Interior Minor Spacing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemSpacingBackDirn2 { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemSpacingBackDirn2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemSpacingBackDirn2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemSpacingBottomDir1Generic Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemSpacingBottomDir1Generic Property
ParameterTypeId Class See Also Send Feedback
"Bottom/Interior Major Spacing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemSpacingBottomDir1Generic { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemSpacingBottomDir1Generic As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemSpacingBottomDir1Generic {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemSpacingBottomDir2Generic Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemSpacingBottomDir2Generic Property
ParameterTypeId Class See Also Send Feedback
"Bottom/Interior Minor Spacing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemSpacingBottomDir2Generic { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemSpacingBottomDir2Generic As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemSpacingBottomDir2Generic {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemSpacingFrontDirn1 Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemSpacingFrontDirn1 Property
ParameterTypeId Class See Also Send Feedback
"Exterior Major Spacing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemSpacingFrontDirn1 { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemSpacingFrontDirn1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemSpacingFrontDirn1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemSpacingFrontDirn2 Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemSpacingFrontDirn2 Property
ParameterTypeId Class See Also Send Feedback
"Exterior Minor Spacing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemSpacingFrontDirn2 { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemSpacingFrontDirn2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemSpacingFrontDirn2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemSpacingTopDir1Generic Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemSpacingTopDir1Generic Property
ParameterTypeId Class See Also Send Feedback
"Top/Exterior Major Spacing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemSpacingTopDir1Generic { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemSpacingTopDir1Generic As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemSpacingTopDir1Generic {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemSpacingTopDir2Generic Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemSpacingTopDir2Generic Property
ParameterTypeId Class See Also Send Feedback
"Top/Exterior Minor Spacing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemSpacingTopDir2Generic { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemSpacingTopDir2Generic As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemSpacingTopDir2Generic {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemSpacingTopDirn1 Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemSpacingTopDirn1 Property
ParameterTypeId Class See Also Send Feedback
"Top Major Spacing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemSpacingTopDirn1 { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemSpacingTopDirn1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemSpacingTopDirn1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemSpacingTopDirn2 Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemSpacingTopDirn2 Property
ParameterTypeId Class See Also Send Feedback
"Top Minor Spacing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemSpacingTopDirn2 { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemSpacingTopDirn2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemSpacingTopDirn2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemSpanactiveDirn2 Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemSpanactiveDirn2 Property
ParameterTypeId Class See Also Send Feedback
"Bars In Minor Direction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemSpanactiveDirn2 { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemSpanactiveDirn2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemSpanactiveDirn2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemSpanhookLeftDirn1 Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemSpanhookLeftDirn1 Property
ParameterTypeId Class See Also Send Feedback
"Hook Angle Left"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemSpanhookLeftDirn1 { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemSpanhookLeftDirn1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemSpanhookLeftDirn1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemSpanhookRightDirn1 Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemSpanhookRightDirn1 Property
ParameterTypeId Class See Also Send Feedback
"Hook Angle Right"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemSpanhookRightDirn1 { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemSpanhookRightDirn1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemSpanhookRightDirn1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemSpanhookTopDirn2 Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemSpanhookTopDirn2 Property
ParameterTypeId Class See Also Send Feedback
"Hook Angle Top"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemSpanhookTopDirn2 { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemSpanhookTopDirn2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemSpanhookTopDirn2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemTopMajorMatchesBottomMajor Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemTopMajorMatchesBottomMajor Property
ParameterTypeId Class See Also Send Feedback
"Top and Bottom Major Layers Match"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemTopMajorMatchesBottomMajor { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemTopMajorMatchesBottomMajor As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemTopMajorMatchesBottomMajor {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemTopMajorMatchesTopMinor Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemTopMajorMatchesTopMinor Property
ParameterTypeId Class See Also Send Feedback
"Top Major and Minor Layers Match"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemTopMajorMatchesTopMinor { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemTopMajorMatchesTopMinor As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemTopMajorMatchesTopMinor {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarSystemTopMinorMatchesBottomMinor Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarSystemTopMinorMatchesBottomMinor Property
ParameterTypeId Class See Also Send Feedback
"Top and Bottom Minor Layers Match"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarSystemTopMinorMatchesBottomMinor { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemTopMinorMatchesBottomMinor As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarSystemTopMinorMatchesBottomMinor {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RebarWorkshopInstructions Property

[image]

Revit 2024 API
ParameterTypeId..::..RebarWorkshopInstructions Property
ParameterTypeId Class See Also Send Feedback
"Workshop Instructions"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RebarWorkshopInstructions { get; }
Visual Basic
Public Shared ReadOnly Property RebarWorkshopInstructions As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RebarWorkshopInstructions {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RectMullionThick Property

[image]

Revit 2024 API
ParameterTypeId..::..RectMullionThick Property
ParameterTypeId Class See Also Send Feedback
"Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RectMullionThick { get; }
Visual Basic
Public Shared ReadOnly Property RectMullionThick As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RectMullionThick {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RectMullionWidth1 Property

[image]

Revit 2024 API
ParameterTypeId..::..RectMullionWidth1 Property
ParameterTypeId Class See Also Send Feedback
"Width on side 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RectMullionWidth1 { get; }
Visual Basic
Public Shared ReadOnly Property RectMullionWidth1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RectMullionWidth1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ReferenceBaseOnHost Property

[image]

Revit 2024 API
ParameterTypeId..::..ReferenceBaseOnHost Property
ParameterTypeId Class See Also Send Feedback
"Reference Base on Host"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ReferenceBaseOnHost { get; }
Visual Basic
Public Shared ReadOnly Property ReferenceBaseOnHost As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ReferenceBaseOnHost {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ReferencedView Property

[image]

Revit 2024 API
ParameterTypeId..::..ReferencedView Property
ParameterTypeId Class See Also Send Feedback
"Referenced View": The view referenced by a section or callout.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ReferencedView { get; }
Visual Basic
Public Shared ReadOnly Property ReferencedView As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ReferencedView {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ReferenceOtherViewUiRefView Property

[image]

Revit 2024 API
ParameterTypeId..::..ReferenceOtherViewUiRefView Property
ParameterTypeId Class See Also Send Feedback
"Reference View": This is used by the UI to allow selection of view reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ReferenceOtherViewUiRefView { get; }
Visual Basic
Public Shared ReadOnly Property ReferenceOtherViewUiRefView As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ReferenceOtherViewUiRefView {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ReferenceOtherViewUiToggle Property

[image]

Revit 2024 API
ParameterTypeId..::..ReferenceOtherViewUiToggle Property
ParameterTypeId Class See Also Send Feedback
"Reference Other View": This is used to determine whether reference other view is enable or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ReferenceOtherViewUiToggle { get; }
Visual Basic
Public Shared ReadOnly Property ReferenceOtherViewUiToggle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ReferenceOtherViewUiToggle {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ReferenceViewerAttrTag Property

[image]

Revit 2024 API
ParameterTypeId..::..ReferenceViewerAttrTag Property
ParameterTypeId Class See Also Send Feedback
"View Reference Tag"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ReferenceViewerAttrTag { get; }
Visual Basic
Public Shared ReadOnly Property ReferenceViewerAttrTag As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ReferenceViewerAttrTag {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ReferenceViewerTargetView Property

[image]

Revit 2024 API
ParameterTypeId..::..ReferenceViewerTargetView Property
ParameterTypeId Class See Also Send Feedback
"Target view"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ReferenceViewerTargetView { get; }
Visual Basic
Public Shared ReadOnly Property ReferenceViewerTargetView As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ReferenceViewerTargetView {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ReferenceViewerUiTargetFilter Property

[image]

Revit 2024 API
ParameterTypeId..::..ReferenceViewerUiTargetFilter Property
ParameterTypeId Class See Also Send Feedback
"Filter": This is used by the UI to filter the list of target views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ReferenceViewerUiTargetFilter { get; }
Visual Basic
Public Shared ReadOnly Property ReferenceViewerUiTargetFilter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ReferenceViewerUiTargetFilter {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RefTableElemName Property

[image]

Revit 2024 API
ParameterTypeId..::..RefTableElemName Property
ParameterTypeId Class See Also Send Feedback
"Key Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RefTableElemName { get; }
Visual Basic
Public Shared ReadOnly Property RefTableElemName As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RefTableElemName {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RefTableParamName Property

[image]

Revit 2024 API
ParameterTypeId..::..RefTableParamName Property
ParameterTypeId Class See Also Send Feedback
"Parameter Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RefTableParamName { get; }
Visual Basic
Public Shared ReadOnly Property RefTableParamName As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RefTableParamName {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ReinEstBarLength Property

[image]

Revit 2024 API
ParameterTypeId..::..ReinEstBarLength Property
ParameterTypeId Class See Also Send Feedback
"Estimated Total Bar Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ReinEstBarLength { get; }
Visual Basic
Public Shared ReadOnly Property ReinEstBarLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ReinEstBarLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ReinEstBarVolume Property

[image]

Revit 2024 API
ParameterTypeId..::..ReinEstBarVolume Property
ParameterTypeId Class See Also Send Feedback
"Estimated Reinforcement Volume"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ReinEstBarVolume { get; }
Visual Basic
Public Shared ReadOnly Property ReinEstBarVolume As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ReinEstBarVolume {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ReinEstNumberOfBars Property

[image]

Revit 2024 API
ParameterTypeId..::..ReinEstNumberOfBars Property
ParameterTypeId Class See Also Send Feedback
"Estimated Number of Bars"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ReinEstNumberOfBars { get; }
Visual Basic
Public Shared ReadOnly Property ReinEstNumberOfBars As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ReinEstNumberOfBars {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ReinforcementVolume Property

[image]

Revit 2024 API
ParameterTypeId..::..ReinforcementVolume Property
ParameterTypeId Class See Also Send Feedback
"Reinforcement Volume"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ReinforcementVolume { get; }
Visual Basic
Public Shared ReadOnly Property ReinforcementVolume As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ReinforcementVolume {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RelatedToMass Property

[image]

Revit 2024 API
ParameterTypeId..::..RelatedToMass Property
ParameterTypeId Class See Also Send Feedback
"Related to Mass"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RelatedToMass { get; }
Visual Basic
Public Shared ReadOnly Property RelatedToMass As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RelatedToMass {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RelativeRoughness Property

[image]

Revit 2024 API
ParameterTypeId..::..RelativeRoughness Property
ParameterTypeId Class See Also Send Feedback
"Relative Roughness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RelativeRoughness { get; }
Visual Basic
Public Shared ReadOnly Property RelativeRoughness As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RelativeRoughness {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RenderPlantHeight Property

[image]

Revit 2024 API
ParameterTypeId..::..RenderPlantHeight Property
ParameterTypeId Class See Also Send Feedback
"Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RenderPlantHeight { get; }
Visual Basic
Public Shared ReadOnly Property RenderPlantHeight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RenderPlantHeight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RenderRpcFilename Property

[image]

Revit 2024 API
ParameterTypeId..::..RenderRpcFilename Property
ParameterTypeId Class See Also Send Feedback
"Render Appearance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RenderRpcFilename { get; }
Visual Basic
Public Shared ReadOnly Property RenderRpcFilename As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RenderRpcFilename {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RenderRpcProperties Property

[image]

Revit 2024 API
ParameterTypeId..::..RenderRpcProperties Property
ParameterTypeId Class See Also Send Feedback
"Render Appearance Properties"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RenderRpcProperties { get; }
Visual Basic
Public Shared ReadOnly Property RenderRpcProperties As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RenderRpcProperties {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RepeatingDetailElement Property

[image]

Revit 2024 API
ParameterTypeId..::..RepeatingDetailElement Property
ParameterTypeId Class See Also Send Feedback
"Detail"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RepeatingDetailElement { get; }
Visual Basic
Public Shared ReadOnly Property RepeatingDetailElement As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RepeatingDetailElement {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RepeatingDetailLayout Property

[image]

Revit 2024 API
ParameterTypeId..::..RepeatingDetailLayout Property
ParameterTypeId Class See Also Send Feedback
"Layout"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RepeatingDetailLayout { get; }
Visual Basic
Public Shared ReadOnly Property RepeatingDetailLayout As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RepeatingDetailLayout {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RepeatingDetailRotation Property

[image]

Revit 2024 API
ParameterTypeId..::..RepeatingDetailRotation Property
ParameterTypeId Class See Also Send Feedback
"Detail Rotation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RepeatingDetailRotation { get; }
Visual Basic
Public Shared ReadOnly Property RepeatingDetailRotation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RepeatingDetailRotation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RepeatingDetailSpacing Property

[image]

Revit 2024 API
ParameterTypeId..::..RepeatingDetailSpacing Property
ParameterTypeId Class See Also Send Feedback
"Spacing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RepeatingDetailSpacing { get; }
Visual Basic
Public Shared ReadOnly Property RepeatingDetailSpacing As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RepeatingDetailSpacing {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RevisionCloudRevision Property

[image]

Revit 2024 API
ParameterTypeId..::..RevisionCloudRevision Property
ParameterTypeId Class See Also Send Feedback
"Revision"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RevisionCloudRevision { get; }
Visual Basic
Public Shared ReadOnly Property RevisionCloudRevision As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RevisionCloudRevision {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RevisionCloudRevisionDescription Property

[image]

Revit 2024 API
ParameterTypeId..::..RevisionCloudRevisionDescription Property
ParameterTypeId Class See Also Send Feedback
"Revision Description"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RevisionCloudRevisionDescription { get; }
Visual Basic
Public Shared ReadOnly Property RevisionCloudRevisionDescription As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RevisionCloudRevisionDescription {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RevisionCloudRevisionIssuedBy Property

[image]

Revit 2024 API
ParameterTypeId..::..RevisionCloudRevisionIssuedBy Property
ParameterTypeId Class See Also Send Feedback
"Issued by"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RevisionCloudRevisionIssuedBy { get; }
Visual Basic
Public Shared ReadOnly Property RevisionCloudRevisionIssuedBy As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RevisionCloudRevisionIssuedBy {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RevisionCloudRevisionIssuedTo Property

[image]

Revit 2024 API
ParameterTypeId..::..RevisionCloudRevisionIssuedTo Property
ParameterTypeId Class See Also Send Feedback
"Issued to"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RevisionCloudRevisionIssuedTo { get; }
Visual Basic
Public Shared ReadOnly Property RevisionCloudRevisionIssuedTo As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RevisionCloudRevisionIssuedTo {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RevolutionStartAngle Property

[image]

Revit 2024 API
ParameterTypeId..::..RevolutionStartAngle Property
ParameterTypeId Class See Also Send Feedback
"Start Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RevolutionStartAngle { get; }
Visual Basic
Public Shared ReadOnly Property RevolutionStartAngle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RevolutionStartAngle {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RgbGParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RgbGParam Property
ParameterTypeId Class See Also Send Feedback
"Green value for RGB color spec. (for Use with XAML Data Template example)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RgbGParam { get; }
Visual Basic
Public Shared ReadOnly Property RgbGParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RgbGParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoofAttrDefaultThicknessParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RoofAttrDefaultThicknessParam Property
ParameterTypeId Class See Also Send Feedback
"Default Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoofAttrDefaultThicknessParam { get; }
Visual Basic
Public Shared ReadOnly Property RoofAttrDefaultThicknessParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoofAttrDefaultThicknessParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoofAttrThicknessParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RoofAttrThicknessParam Property
ParameterTypeId Class See Also Send Feedback
"Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoofAttrThicknessParam { get; }
Visual Basic
Public Shared ReadOnly Property RoofAttrThicknessParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoofAttrThicknessParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoofConstraintOffsetParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RoofConstraintOffsetParam Property
ParameterTypeId Class See Also Send Feedback
"Level Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoofConstraintOffsetParam { get; }
Visual Basic
Public Shared ReadOnly Property RoofConstraintOffsetParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoofConstraintOffsetParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoofCurveHeightAtWall Property

[image]

Revit 2024 API
ParameterTypeId..::..RoofCurveHeightAtWall Property
ParameterTypeId Class See Also Send Feedback
"Plate Offset From Base"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoofCurveHeightAtWall { get; }
Visual Basic
Public Shared ReadOnly Property RoofCurveHeightAtWall As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoofCurveHeightAtWall {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoofCurveHeightOffset Property

[image]

Revit 2024 API
ParameterTypeId..::..RoofCurveHeightOffset Property
ParameterTypeId Class See Also Send Feedback
"Offset From Roof Base"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoofCurveHeightOffset { get; }
Visual Basic
Public Shared ReadOnly Property RoofCurveHeightOffset As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoofCurveHeightOffset {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoofCurveIsSlopeDefining Property

[image]

Revit 2024 API
ParameterTypeId..::..RoofCurveIsSlopeDefining Property
ParameterTypeId Class See Also Send Feedback
"Defines Roof Slope"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoofCurveIsSlopeDefining { get; }
Visual Basic
Public Shared ReadOnly Property RoofCurveIsSlopeDefining As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoofCurveIsSlopeDefining {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoofEaveCutParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RoofEaveCutParam Property
ParameterTypeId Class See Also Send Feedback
"Rafter Cut"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoofEaveCutParam { get; }
Visual Basic
Public Shared ReadOnly Property RoofEaveCutParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoofEaveCutParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoofFacesLocation Property

[image]

Revit 2024 API
ParameterTypeId..::..RoofFacesLocation Property
ParameterTypeId Class See Also Send Feedback
"Picked Faces Location"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoofFacesLocation { get; }
Visual Basic
Public Shared ReadOnly Property RoofFacesLocation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoofFacesLocation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoofLevelOffsetParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RoofLevelOffsetParam Property
ParameterTypeId Class See Also Send Feedback
"Base Offset From Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoofLevelOffsetParam { get; }
Visual Basic
Public Shared ReadOnly Property RoofLevelOffsetParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoofLevelOffsetParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoofRafterOrTrussParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RoofRafterOrTrussParam Property
ParameterTypeId Class See Also Send Feedback
"Rafter or Truss"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoofRafterOrTrussParam { get; }
Visual Basic
Public Shared ReadOnly Property RoofRafterOrTrussParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoofRafterOrTrussParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoofSlope Property

[image]

Revit 2024 API
ParameterTypeId..::..RoofSlope Property
ParameterTypeId Class See Also Send Feedback
"Slope"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoofSlope { get; }
Visual Basic
Public Shared ReadOnly Property RoofSlope As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoofSlope {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoofStructureIdParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RoofStructureIdParam Property
ParameterTypeId Class See Also Send Feedback
"Structure"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoofStructureIdParam { get; }
Visual Basic
Public Shared ReadOnly Property RoofStructureIdParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoofStructureIdParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoofUptoLevelOffsetParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RoofUptoLevelOffsetParam Property
ParameterTypeId Class See Also Send Feedback
"Cutoff Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoofUptoLevelOffsetParam { get; }
Visual Basic
Public Shared ReadOnly Property RoofUptoLevelOffsetParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoofUptoLevelOffsetParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoofUptoLevelParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RoofUptoLevelParam Property
ParameterTypeId Class See Also Send Feedback
"Cutoff Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoofUptoLevelParam { get; }
Visual Basic
Public Shared ReadOnly Property RoofUptoLevelParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoofUptoLevelParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomActualExhaustAirflowParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomActualExhaustAirflowParam Property
ParameterTypeId Class See Also Send Feedback
"Actual Exhaust Airflow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomActualExhaustAirflowParam { get; }
Visual Basic
Public Shared ReadOnly Property RoomActualExhaustAirflowParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomActualExhaustAirflowParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomActualLightingLoadParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomActualLightingLoadParam Property
ParameterTypeId Class See Also Send Feedback
"Actual Lighting Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomActualLightingLoadParam { get; }
Visual Basic
Public Shared ReadOnly Property RoomActualLightingLoadParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomActualLightingLoadParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomActualLightingLoadPerAreaParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomActualLightingLoadPerAreaParam Property
ParameterTypeId Class See Also Send Feedback
"Actual Lighting Load per area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomActualLightingLoadPerAreaParam { get; }
Visual Basic
Public Shared ReadOnly Property RoomActualLightingLoadPerAreaParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomActualLightingLoadPerAreaParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomActualPowerLoadParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomActualPowerLoadParam Property
ParameterTypeId Class See Also Send Feedback
"Actual Power Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomActualPowerLoadParam { get; }
Visual Basic
Public Shared ReadOnly Property RoomActualPowerLoadParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomActualPowerLoadParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomActualPowerLoadPerAreaParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomActualPowerLoadPerAreaParam Property
ParameterTypeId Class See Also Send Feedback
"Actual Power Load per area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomActualPowerLoadPerAreaParam { get; }
Visual Basic
Public Shared ReadOnly Property RoomActualPowerLoadPerAreaParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomActualPowerLoadPerAreaParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomActualReturnAirflowParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomActualReturnAirflowParam Property
ParameterTypeId Class See Also Send Feedback
"Actual Return Airflow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomActualReturnAirflowParam { get; }
Visual Basic
Public Shared ReadOnly Property RoomActualReturnAirflowParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomActualReturnAirflowParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomActualSupplyAirflowParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomActualSupplyAirflowParam Property
ParameterTypeId Class See Also Send Feedback
"Actual Supply Airflow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomActualSupplyAirflowParam { get; }
Visual Basic
Public Shared ReadOnly Property RoomActualSupplyAirflowParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomActualSupplyAirflowParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomAirChangesPerHourParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomAirChangesPerHourParam Property
ParameterTypeId Class See Also Send Feedback
"Air Changes per Hour"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomAirChangesPerHourParam { get; }
Visual Basic
Public Shared ReadOnly Property RoomAirChangesPerHourParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomAirChangesPerHourParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomAreaPerPersonParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomAreaPerPersonParam Property
ParameterTypeId Class See Also Send Feedback
"Area per Person"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomAreaPerPersonParam { get; }
Visual Basic
Public Shared ReadOnly Property RoomAreaPerPersonParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomAreaPerPersonParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomBaseHeatLoadOnParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomBaseHeatLoadOnParam Property
ParameterTypeId Class See Also Send Feedback
"Heat Load Values"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomBaseHeatLoadOnParam { get; }
Visual Basic
Public Shared ReadOnly Property RoomBaseHeatLoadOnParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomBaseHeatLoadOnParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomBaseReturnAirflowOnParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomBaseReturnAirflowOnParam Property
ParameterTypeId Class See Also Send Feedback
"Return Airflow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomBaseReturnAirflowOnParam { get; }
Visual Basic
Public Shared ReadOnly Property RoomBaseReturnAirflowOnParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomBaseReturnAirflowOnParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomCalculatedCoolingLoadParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomCalculatedCoolingLoadParam Property
ParameterTypeId Class See Also Send Feedback
"Calculated Cooling Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomCalculatedCoolingLoadParam { get; }
Visual Basic
Public Shared ReadOnly Property RoomCalculatedCoolingLoadParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomCalculatedCoolingLoadParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomCalculatedHeatingLoadParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomCalculatedHeatingLoadParam Property
ParameterTypeId Class See Also Send Feedback
"Calculated Heating Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomCalculatedHeatingLoadParam { get; }
Visual Basic
Public Shared ReadOnly Property RoomCalculatedHeatingLoadParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomCalculatedHeatingLoadParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomCalculatedHeatingLoadPerAreaParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomCalculatedHeatingLoadPerAreaParam Property
ParameterTypeId Class See Also Send Feedback
"Calculated Heating Load per area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomCalculatedHeatingLoadPerAreaParam { get; }
Visual Basic
Public Shared ReadOnly Property RoomCalculatedHeatingLoadPerAreaParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomCalculatedHeatingLoadPerAreaParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomCalculatedSupplyAirflowParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomCalculatedSupplyAirflowParam Property
ParameterTypeId Class See Also Send Feedback
"Calculated Supply Airflow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomCalculatedSupplyAirflowParam { get; }
Visual Basic
Public Shared ReadOnly Property RoomCalculatedSupplyAirflowParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomCalculatedSupplyAirflowParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomCalculationPoint Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomCalculationPoint Property
ParameterTypeId Class See Also Send Feedback
"Room Calculation Point"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomCalculationPoint { get; }
Visual Basic
Public Shared ReadOnly Property RoomCalculationPoint As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomCalculationPoint {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomComputationHeight Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomComputationHeight Property
ParameterTypeId Class See Also Send Feedback
"Computation Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomComputationHeight { get; }
Visual Basic
Public Shared ReadOnly Property RoomComputationHeight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomComputationHeight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomComputationMethod Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomComputationMethod Property
ParameterTypeId Class See Also Send Feedback
"Computation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomComputationMethod { get; }
Visual Basic
Public Shared ReadOnly Property RoomComputationMethod As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomComputationMethod {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomConditionTypeParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomConditionTypeParam Property
ParameterTypeId Class See Also Send Feedback
"Condition Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomConditionTypeParam { get; }
Visual Basic
Public Shared ReadOnly Property RoomConditionTypeParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomConditionTypeParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomConstructionSetParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomConstructionSetParam Property
ParameterTypeId Class See Also Send Feedback
"Construction Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomConstructionSetParam { get; }
Visual Basic
Public Shared ReadOnly Property RoomConstructionSetParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomConstructionSetParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomDepartment Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomDepartment Property
ParameterTypeId Class See Also Send Feedback
"Department"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomDepartment { get; }
Visual Basic
Public Shared ReadOnly Property RoomDepartment As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomDepartment {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomDesignExhaustAirflowParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomDesignExhaustAirflowParam Property
ParameterTypeId Class See Also Send Feedback
"Specified Exhaust Airflow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomDesignExhaustAirflowParam { get; }
Visual Basic
Public Shared ReadOnly Property RoomDesignExhaustAirflowParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomDesignExhaustAirflowParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomDesignHeatingLoadParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomDesignHeatingLoadParam Property
ParameterTypeId Class See Also Send Feedback
"Design Heating Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomDesignHeatingLoadParam { get; }
Visual Basic
Public Shared ReadOnly Property RoomDesignHeatingLoadParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomDesignHeatingLoadParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomDesignLightingLoadParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomDesignLightingLoadParam Property
ParameterTypeId Class See Also Send Feedback
"Specified Lighting Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomDesignLightingLoadParam { get; }
Visual Basic
Public Shared ReadOnly Property RoomDesignLightingLoadParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomDesignLightingLoadParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomDesignLightingLoadPerAreaParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomDesignLightingLoadPerAreaParam Property
ParameterTypeId Class See Also Send Feedback
"Specified Lighting Load per area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomDesignLightingLoadPerAreaParam { get; }
Visual Basic
Public Shared ReadOnly Property RoomDesignLightingLoadPerAreaParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomDesignLightingLoadPerAreaParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomDesignMechanicalLoadPerAreaParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomDesignMechanicalLoadPerAreaParam Property
ParameterTypeId Class See Also Send Feedback
"Design HVAC Load per area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomDesignMechanicalLoadPerAreaParam { get; }
Visual Basic
Public Shared ReadOnly Property RoomDesignMechanicalLoadPerAreaParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomDesignMechanicalLoadPerAreaParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomDesignOtherLoadPerAreaParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomDesignOtherLoadPerAreaParam Property
ParameterTypeId Class See Also Send Feedback
"Design Other Load per area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomDesignOtherLoadPerAreaParam { get; }
Visual Basic
Public Shared ReadOnly Property RoomDesignOtherLoadPerAreaParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomDesignOtherLoadPerAreaParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomDesignPowerLoadParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomDesignPowerLoadParam Property
ParameterTypeId Class See Also Send Feedback
"Specified Power Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomDesignPowerLoadParam { get; }
Visual Basic
Public Shared ReadOnly Property RoomDesignPowerLoadParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomDesignPowerLoadParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomDesignReturnAirflowParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomDesignReturnAirflowParam Property
ParameterTypeId Class See Also Send Feedback
"Specified Return Airflow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomDesignReturnAirflowParam { get; }
Visual Basic
Public Shared ReadOnly Property RoomDesignReturnAirflowParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomDesignReturnAirflowParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomDesignSupplyAirflowParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomDesignSupplyAirflowParam Property
ParameterTypeId Class See Also Send Feedback
"Specified Supply Airflow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomDesignSupplyAirflowParam { get; }
Visual Basic
Public Shared ReadOnly Property RoomDesignSupplyAirflowParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomDesignSupplyAirflowParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomEditPeopleLoadsParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomEditPeopleLoadsParam Property
ParameterTypeId Class See Also Send Feedback
"People"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomEditPeopleLoadsParam { get; }
Visual Basic
Public Shared ReadOnly Property RoomEditPeopleLoadsParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomEditPeopleLoadsParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomFinishBase Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomFinishBase Property
ParameterTypeId Class See Also Send Feedback
"Base Finish"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomFinishBase { get; }
Visual Basic
Public Shared ReadOnly Property RoomFinishBase As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomFinishBase {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomFinishFloor Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomFinishFloor Property
ParameterTypeId Class See Also Send Feedback
"Floor Finish"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomFinishFloor { get; }
Visual Basic
Public Shared ReadOnly Property RoomFinishFloor As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomFinishFloor {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomFinishWall Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomFinishWall Property
ParameterTypeId Class See Also Send Feedback
"Wall Finish"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomFinishWall { get; }
Visual Basic
Public Shared ReadOnly Property RoomFinishWall As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomFinishWall {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomHeight Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomHeight Property
ParameterTypeId Class See Also Send Feedback
"Unbounded Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomHeight { get; }
Visual Basic
Public Shared ReadOnly Property RoomHeight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomHeight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomLightingLoadUnitsParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomLightingLoadUnitsParam Property
ParameterTypeId Class See Also Send Feedback
"Lighting Load Units"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomLightingLoadUnitsParam { get; }
Visual Basic
Public Shared ReadOnly Property RoomLightingLoadUnitsParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomLightingLoadUnitsParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomLowerOffset Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomLowerOffset Property
ParameterTypeId Class See Also Send Feedback
"Base Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomLowerOffset { get; }
Visual Basic
Public Shared ReadOnly Property RoomLowerOffset As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomLowerOffset {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomName Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomName Property
ParameterTypeId Class See Also Send Feedback
"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomName { get; }
Visual Basic
Public Shared ReadOnly Property RoomName As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomName {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomNumber Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomNumber Property
ParameterTypeId Class See Also Send Feedback
"Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomNumber { get; }
Visual Basic
Public Shared ReadOnly Property RoomNumber As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomNumber {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomNumberOfPeopleParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomNumberOfPeopleParam Property
ParameterTypeId Class See Also Send Feedback
"Number of People"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomNumberOfPeopleParam { get; }
Visual Basic
Public Shared ReadOnly Property RoomNumberOfPeopleParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomNumberOfPeopleParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomOccupancy Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomOccupancy Property
ParameterTypeId Class See Also Send Feedback
"Occupancy"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomOccupancy { get; }
Visual Basic
Public Shared ReadOnly Property RoomOccupancy As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomOccupancy {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomOccupancyUnitParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomOccupancyUnitParam Property
ParameterTypeId Class See Also Send Feedback
"Occupancy Unit"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomOccupancyUnitParam { get; }
Visual Basic
Public Shared ReadOnly Property RoomOccupancyUnitParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomOccupancyUnitParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomOutdoorAirflowParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomOutdoorAirflowParam Property
ParameterTypeId Class See Also Send Feedback
"Outdoor Airflow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomOutdoorAirflowParam { get; }
Visual Basic
Public Shared ReadOnly Property RoomOutdoorAirflowParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomOutdoorAirflowParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomOutdoorAirflowStandardParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomOutdoorAirflowStandardParam Property
ParameterTypeId Class See Also Send Feedback
"Outdoor Air Method"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomOutdoorAirflowStandardParam { get; }
Visual Basic
Public Shared ReadOnly Property RoomOutdoorAirflowStandardParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomOutdoorAirflowStandardParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomOutdoorAirInfoParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomOutdoorAirInfoParam Property
ParameterTypeId Class See Also Send Feedback
"Outdoor Air Information"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomOutdoorAirInfoParam { get; }
Visual Basic
Public Shared ReadOnly Property RoomOutdoorAirInfoParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomOutdoorAirInfoParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomOutdoorAirPerAreaParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomOutdoorAirPerAreaParam Property
ParameterTypeId Class See Also Send Feedback
"Outdoor Air per Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomOutdoorAirPerAreaParam { get; }
Visual Basic
Public Shared ReadOnly Property RoomOutdoorAirPerAreaParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomOutdoorAirPerAreaParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomOutdoorAirPerPersonParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomOutdoorAirPerPersonParam Property
ParameterTypeId Class See Also Send Feedback
"Outdoor Air per Person"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomOutdoorAirPerPersonParam { get; }
Visual Basic
Public Shared ReadOnly Property RoomOutdoorAirPerPersonParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomOutdoorAirPerPersonParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomPeopleLatentHeatGainPerPersonParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomPeopleLatentHeatGainPerPersonParam Property
ParameterTypeId Class See Also Send Feedback
"Latent Heat Gain per person"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomPeopleLatentHeatGainPerPersonParam { get; }
Visual Basic
Public Shared ReadOnly Property RoomPeopleLatentHeatGainPerPersonParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomPeopleLatentHeatGainPerPersonParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomPeopleTotalHeatGainPerPersonParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomPeopleTotalHeatGainPerPersonParam Property
ParameterTypeId Class See Also Send Feedback
"Total Heat Gain per person"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomPeopleTotalHeatGainPerPersonParam { get; }
Visual Basic
Public Shared ReadOnly Property RoomPeopleTotalHeatGainPerPersonParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomPeopleTotalHeatGainPerPersonParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomPerimeter Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomPerimeter Property
ParameterTypeId Class See Also Send Feedback
"Perimeter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomPerimeter { get; }
Visual Basic
Public Shared ReadOnly Property RoomPerimeter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomPerimeter {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomPhaseId Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomPhaseId Property
ParameterTypeId Class See Also Send Feedback
"Phase Id"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomPhaseId { get; }
Visual Basic
Public Shared ReadOnly Property RoomPhaseId As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomPhaseId {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomPlenumLightingParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomPlenumLightingParam Property
ParameterTypeId Class See Also Send Feedback
"Plenum Lighting Contribution"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomPlenumLightingParam { get; }
Visual Basic
Public Shared ReadOnly Property RoomPlenumLightingParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomPlenumLightingParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomSpaceTypeParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomSpaceTypeParam Property
ParameterTypeId Class See Also Send Feedback
"Space Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomSpaceTypeParam { get; }
Visual Basic
Public Shared ReadOnly Property RoomSpaceTypeParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomSpaceTypeParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomTagOrientationParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomTagOrientationParam Property
ParameterTypeId Class See Also Send Feedback
"Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomTagOrientationParam { get; }
Visual Basic
Public Shared ReadOnly Property RoomTagOrientationParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomTagOrientationParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomUpperOffset Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomUpperOffset Property
ParameterTypeId Class See Also Send Feedback
"Limit Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomUpperOffset { get; }
Visual Basic
Public Shared ReadOnly Property RoomUpperOffset As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomUpperOffset {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoomVolume Property

[image]

Revit 2024 API
ParameterTypeId..::..RoomVolume Property
ParameterTypeId Class See Also Send Feedback
"Volume"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoomVolume { get; }
Visual Basic
Public Shared ReadOnly Property RoomVolume As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoomVolume {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RouteAnalysisSettingsParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RouteAnalysisSettingsParam Property
ParameterTypeId Class See Also Send Feedback
"Route Analysis Settings"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RouteAnalysisSettingsParam { get; }
Visual Basic
Public Shared ReadOnly Property RouteAnalysisSettingsParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RouteAnalysisSettingsParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RoutingPreferenceParam Property

[image]

Revit 2024 API
ParameterTypeId..::..RoutingPreferenceParam Property
ParameterTypeId Class See Also Send Feedback
"Routing Preference"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RoutingPreferenceParam { get; }
Visual Basic
Public Shared ReadOnly Property RoutingPreferenceParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RoutingPreferenceParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RvtLevelOffset Property

[image]

Revit 2024 API
ParameterTypeId..::..RvtLevelOffset Property
ParameterTypeId Class See Also Send Feedback
"Map Levels..."

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RvtLevelOffset { get; }
Visual Basic
Public Shared ReadOnly Property RvtLevelOffset As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RvtLevelOffset {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RvtLinkFileNameWithoutExt Property

[image]

Revit 2024 API
ParameterTypeId..::..RvtLinkFileNameWithoutExt Property
ParameterTypeId Class See Also Send Feedback
"File Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RvtLinkFileNameWithoutExt { get; }
Visual Basic
Public Shared ReadOnly Property RvtLinkFileNameWithoutExt As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RvtLinkFileNameWithoutExt {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RvtLinkInstanceName Property

[image]

Revit 2024 API
ParameterTypeId..::..RvtLinkInstanceName Property
ParameterTypeId Class See Also Send Feedback
"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RvtLinkInstanceName { get; }
Visual Basic
Public Shared ReadOnly Property RvtLinkInstanceName As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RvtLinkInstanceName {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RvtLinkInstanceProjectInformation Property

[image]

Revit 2024 API
ParameterTypeId..::..RvtLinkInstanceProjectInformation Property
ParameterTypeId Class See Also Send Feedback
"Project Information"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RvtLinkInstanceProjectInformation { get; }
Visual Basic
Public Shared ReadOnly Property RvtLinkInstanceProjectInformation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RvtLinkInstanceProjectInformation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RvtLinkPhaseMap Property

[image]

Revit 2024 API
ParameterTypeId..::..RvtLinkPhaseMap Property
ParameterTypeId Class See Also Send Feedback
"Phase Mapping"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RvtLinkPhaseMap { get; }
Visual Basic
Public Shared ReadOnly Property RvtLinkPhaseMap As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RvtLinkPhaseMap {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RvtLinkReferenceType Property

[image]

Revit 2024 API
ParameterTypeId..::..RvtLinkReferenceType Property
ParameterTypeId Class See Also Send Feedback
"Reference Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RvtLinkReferenceType { get; }
Visual Basic
Public Shared ReadOnly Property RvtLinkReferenceType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RvtLinkReferenceType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


RvtSourceLevel Property

[image]

Revit 2024 API
ParameterTypeId..::..RvtSourceLevel Property
ParameterTypeId Class See Also Send Feedback
"Map Levels..."

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId RvtSourceLevel { get; }
Visual Basic
Public Shared ReadOnly Property RvtSourceLevel As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RvtSourceLevel {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ScheduleBaseLevelOffsetParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ScheduleBaseLevelOffsetParam Property
ParameterTypeId Class See Also Send Feedback
"Base Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ScheduleBaseLevelOffsetParam { get; }
Visual Basic
Public Shared ReadOnly Property ScheduleBaseLevelOffsetParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ScheduleBaseLevelOffsetParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ScheduleCategory Property

[image]

Revit 2024 API
ParameterTypeId..::..ScheduleCategory Property
ParameterTypeId Class See Also Send Feedback
"Category"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ScheduleCategory { get; }
Visual Basic
Public Shared ReadOnly Property ScheduleCategory As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ScheduleCategory {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ScheduleEmbeddedParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ScheduleEmbeddedParam Property
ParameterTypeId Class See Also Send Feedback
"Embedded Schedule"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ScheduleEmbeddedParam { get; }
Visual Basic
Public Shared ReadOnly Property ScheduleEmbeddedParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ScheduleEmbeddedParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ScheduleFieldsParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ScheduleFieldsParam Property
ParameterTypeId Class See Also Send Feedback
"Fields"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ScheduleFieldsParam { get; }
Visual Basic
Public Shared ReadOnly Property ScheduleFieldsParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ScheduleFieldsParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ScheduleFilterParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ScheduleFilterParam Property
ParameterTypeId Class See Also Send Feedback
"Filter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ScheduleFilterParam { get; }
Visual Basic
Public Shared ReadOnly Property ScheduleFilterParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ScheduleFilterParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ScheduleFormatParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ScheduleFormatParam Property
ParameterTypeId Class See Also Send Feedback
"Formatting"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ScheduleFormatParam { get; }
Visual Basic
Public Shared ReadOnly Property ScheduleFormatParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ScheduleFormatParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ScheduleGroupParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ScheduleGroupParam Property
ParameterTypeId Class See Also Send Feedback
"Sorting/Grouping"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ScheduleGroupParam { get; }
Visual Basic
Public Shared ReadOnly Property ScheduleGroupParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ScheduleGroupParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ScheduleLevelParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ScheduleLevelParam Property
ParameterTypeId Class See Also Send Feedback
"Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ScheduleLevelParam { get; }
Visual Basic
Public Shared ReadOnly Property ScheduleLevelParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ScheduleLevelParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ScheduleResizeRows Property

[image]

Revit 2024 API
ParameterTypeId..::..ScheduleResizeRows Property
ParameterTypeId Class See Also Send Feedback
"Resize Rows"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ScheduleResizeRows { get; }
Visual Basic
Public Shared ReadOnly Property ScheduleResizeRows As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ScheduleResizeRows {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ScheduleRotationOnSheet Property

[image]

Revit 2024 API
ParameterTypeId..::..ScheduleRotationOnSheet Property
ParameterTypeId Class See Also Send Feedback
"Rotation on Sheet"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ScheduleRotationOnSheet { get; }
Visual Basic
Public Shared ReadOnly Property ScheduleRotationOnSheet As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ScheduleRotationOnSheet {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ScheduleRowHeightInput Property

[image]

Revit 2024 API
ParameterTypeId..::..ScheduleRowHeightInput Property
ParameterTypeId Class See Also Send Feedback
"Row Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ScheduleRowHeightInput { get; }
Visual Basic
Public Shared ReadOnly Property ScheduleRowHeightInput As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ScheduleRowHeightInput {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ScheduleSheetAppearanceParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ScheduleSheetAppearanceParam Property
ParameterTypeId Class See Also Send Feedback
"Appearance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ScheduleSheetAppearanceParam { get; }
Visual Basic
Public Shared ReadOnly Property ScheduleSheetAppearanceParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ScheduleSheetAppearanceParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ScheduleTopLevelOffsetParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ScheduleTopLevelOffsetParam Property
ParameterTypeId Class See Also Send Feedback
"Top Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ScheduleTopLevelOffsetParam { get; }
Visual Basic
Public Shared ReadOnly Property ScheduleTopLevelOffsetParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ScheduleTopLevelOffsetParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ScheduleTopLevelParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ScheduleTopLevelParam Property
ParameterTypeId Class See Also Send Feedback
"Top Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ScheduleTopLevelParam { get; }
Visual Basic
Public Shared ReadOnly Property ScheduleTopLevelParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ScheduleTopLevelParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ScheduleTypeForBrowser Property

[image]

Revit 2024 API
ParameterTypeId..::..ScheduleTypeForBrowser Property
ParameterTypeId Class See Also Send Feedback
"Schedule Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ScheduleTypeForBrowser { get; }
Visual Basic
Public Shared ReadOnly Property ScheduleTypeForBrowser As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ScheduleTypeForBrowser {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SectionAttrHeadTag Property

[image]

Revit 2024 API
ParameterTypeId..::..SectionAttrHeadTag Property
ParameterTypeId Class See Also Send Feedback
"Section Head"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SectionAttrHeadTag { get; }
Visual Basic
Public Shared ReadOnly Property SectionAttrHeadTag As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SectionAttrHeadTag {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SectionAttrTailLength Property

[image]

Revit 2024 API
ParameterTypeId..::..SectionAttrTailLength Property
ParameterTypeId Class See Also Send Feedback
"Tail length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SectionAttrTailLength { get; }
Visual Basic
Public Shared ReadOnly Property SectionAttrTailLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SectionAttrTailLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SectionAttrTailWidth Property

[image]

Revit 2024 API
ParameterTypeId..::..SectionAttrTailWidth Property
ParameterTypeId Class See Also Send Feedback
"Tail width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SectionAttrTailWidth { get; }
Visual Basic
Public Shared ReadOnly Property SectionAttrTailWidth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SectionAttrTailWidth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SectionBrokenDisplayStyle Property

[image]

Revit 2024 API
ParameterTypeId..::..SectionBrokenDisplayStyle Property
ParameterTypeId Class See Also Send Feedback
"Broken Section Display Style"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SectionBrokenDisplayStyle { get; }
Visual Basic
Public Shared ReadOnly Property SectionBrokenDisplayStyle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SectionBrokenDisplayStyle {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SectionParentViewName Property

[image]

Revit 2024 API
ParameterTypeId..::..SectionParentViewName Property
ParameterTypeId Class See Also Send Feedback
"Parent View"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SectionParentViewName { get; }
Visual Basic
Public Shared ReadOnly Property SectionParentViewName As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SectionParentViewName {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SectionShowInOneViewOnly Property

[image]

Revit 2024 API
ParameterTypeId..::..SectionShowInOneViewOnly Property
ParameterTypeId Class See Also Send Feedback
"Show in"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SectionShowInOneViewOnly { get; }
Visual Basic
Public Shared ReadOnly Property SectionShowInOneViewOnly As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SectionShowInOneViewOnly {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SeekItemId Property

[image]

Revit 2024 API
ParameterTypeId..::..SeekItemId Property
ParameterTypeId Class See Also Send Feedback
"Seek Item ID"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SeekItemId { get; }
Visual Basic
Public Shared ReadOnly Property SeekItemId As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SeekItemId {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SelectionEditableOnly Property

[image]

Revit 2024 API
ParameterTypeId..::..SelectionEditableOnly Property
ParameterTypeId Class See Also Send Feedback
"Editable only"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SelectionEditableOnly { get; }
Visual Basic
Public Shared ReadOnly Property SelectionEditableOnly As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SelectionEditableOnly {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SheetAssemblyAssemblyCode Property

[image]

Revit 2024 API
ParameterTypeId..::..SheetAssemblyAssemblyCode Property
ParameterTypeId Class See Also Send Feedback
"Assembly: Assembly Code"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SheetAssemblyAssemblyCode { get; }
Visual Basic
Public Shared ReadOnly Property SheetAssemblyAssemblyCode As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SheetAssemblyAssemblyCode {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SheetAssemblyCost Property

[image]

Revit 2024 API
ParameterTypeId..::..SheetAssemblyCost Property
ParameterTypeId Class See Also Send Feedback
"Assembly: Cost"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SheetAssemblyCost { get; }
Visual Basic
Public Shared ReadOnly Property SheetAssemblyCost As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SheetAssemblyCost {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SheetAssemblyKeynote Property

[image]

Revit 2024 API
ParameterTypeId..::..SheetAssemblyKeynote Property
ParameterTypeId Class See Also Send Feedback
"Assembly: Keynote"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SheetAssemblyKeynote { get; }
Visual Basic
Public Shared ReadOnly Property SheetAssemblyKeynote As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SheetAssemblyKeynote {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SheetAssemblyName Property

[image]

Revit 2024 API
ParameterTypeId..::..SheetAssemblyName Property
ParameterTypeId Class See Also Send Feedback
"Assembly: Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SheetAssemblyName { get; }
Visual Basic
Public Shared ReadOnly Property SheetAssemblyName As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SheetAssemblyName {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SheetAssemblyTypeComments Property

[image]

Revit 2024 API
ParameterTypeId..::..SheetAssemblyTypeComments Property
ParameterTypeId Class See Also Send Feedback
"Assembly: Type Comments"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SheetAssemblyTypeComments { get; }
Visual Basic
Public Shared ReadOnly Property SheetAssemblyTypeComments As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SheetAssemblyTypeComments {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SheetAssemblyUrl Property

[image]

Revit 2024 API
ParameterTypeId..::..SheetAssemblyUrl Property
ParameterTypeId Class See Also Send Feedback
"Assembly: URL"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SheetAssemblyUrl { get; }
Visual Basic
Public Shared ReadOnly Property SheetAssemblyUrl As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SheetAssemblyUrl {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SheetCheckedBy Property

[image]

Revit 2024 API
ParameterTypeId..::..SheetCheckedBy Property
ParameterTypeId Class See Also Send Feedback
"Checked By"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SheetCheckedBy { get; }
Visual Basic
Public Shared ReadOnly Property SheetCheckedBy As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SheetCheckedBy {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SheetCurrentRevision Property

[image]

Revit 2024 API
ParameterTypeId..::..SheetCurrentRevision Property
ParameterTypeId Class See Also Send Feedback
"Current Revision"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SheetCurrentRevision { get; }
Visual Basic
Public Shared ReadOnly Property SheetCurrentRevision As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SheetCurrentRevision {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SheetCurrentRevisionDate Property

[image]

Revit 2024 API
ParameterTypeId..::..SheetCurrentRevisionDate Property
ParameterTypeId Class See Also Send Feedback
"Current Revision Date"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SheetCurrentRevisionDate { get; }
Visual Basic
Public Shared ReadOnly Property SheetCurrentRevisionDate As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SheetCurrentRevisionDate {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SheetCurrentRevisionDescription Property

[image]

Revit 2024 API
ParameterTypeId..::..SheetCurrentRevisionDescription Property
ParameterTypeId Class See Also Send Feedback
"Current Revision Description"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SheetCurrentRevisionDescription { get; }
Visual Basic
Public Shared ReadOnly Property SheetCurrentRevisionDescription As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SheetCurrentRevisionDescription {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SheetCurrentRevisionIssuedBy Property

[image]

Revit 2024 API
ParameterTypeId..::..SheetCurrentRevisionIssuedBy Property
ParameterTypeId Class See Also Send Feedback
"Current Revision Issued By"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SheetCurrentRevisionIssuedBy { get; }
Visual Basic
Public Shared ReadOnly Property SheetCurrentRevisionIssuedBy As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SheetCurrentRevisionIssuedBy {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SheetCurrentRevisionIssuedTo Property

[image]

Revit 2024 API
ParameterTypeId..::..SheetCurrentRevisionIssuedTo Property
ParameterTypeId Class See Also Send Feedback
"Current Revision Issued To"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SheetCurrentRevisionIssuedTo { get; }
Visual Basic
Public Shared ReadOnly Property SheetCurrentRevisionIssuedTo As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SheetCurrentRevisionIssuedTo {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SheetDesignedBy Property

[image]

Revit 2024 API
ParameterTypeId..::..SheetDesignedBy Property
ParameterTypeId Class See Also Send Feedback
"Designed By"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SheetDesignedBy { get; }
Visual Basic
Public Shared ReadOnly Property SheetDesignedBy As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SheetDesignedBy {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SheetFilePath Property

[image]

Revit 2024 API
ParameterTypeId..::..SheetFilePath Property
ParameterTypeId Class See Also Send Feedback
"File Path"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SheetFilePath { get; }
Visual Basic
Public Shared ReadOnly Property SheetFilePath As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SheetFilePath {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SheetGuideGrid Property

[image]

Revit 2024 API
ParameterTypeId..::..SheetGuideGrid Property
ParameterTypeId Class See Also Send Feedback
"Guide Grid"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SheetGuideGrid { get; }
Visual Basic
Public Shared ReadOnly Property SheetGuideGrid As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SheetGuideGrid {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SheetIssueDate Property

[image]

Revit 2024 API
ParameterTypeId..::..SheetIssueDate Property
ParameterTypeId Class See Also Send Feedback
"Sheet Issue Date"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SheetIssueDate { get; }
Visual Basic
Public Shared ReadOnly Property SheetIssueDate As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SheetIssueDate {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SheetKeyNumber Property

[image]

Revit 2024 API
ParameterTypeId..::..SheetKeyNumber Property
ParameterTypeId Class See Also Send Feedback
"Sheet Key Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SheetKeyNumber { get; }
Visual Basic
Public Shared ReadOnly Property SheetKeyNumber As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SheetKeyNumber {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SheetNumber Property

[image]

Revit 2024 API
ParameterTypeId..::..SheetNumber Property
ParameterTypeId Class See Also Send Feedback
"Sheet Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SheetNumber { get; }
Visual Basic
Public Shared ReadOnly Property SheetNumber As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SheetNumber {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SheetRevisionsOnSheet Property

[image]

Revit 2024 API
ParameterTypeId..::..SheetRevisionsOnSheet Property
ParameterTypeId Class See Also Send Feedback
"Revisions on Sheet"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SheetRevisionsOnSheet { get; }
Visual Basic
Public Shared ReadOnly Property SheetRevisionsOnSheet As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SheetRevisionsOnSheet {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SheetScale Property

[image]

Revit 2024 API
ParameterTypeId..::..SheetScale Property
ParameterTypeId Class See Also Send Feedback
"Scale"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SheetScale { get; }
Visual Basic
Public Shared ReadOnly Property SheetScale As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SheetScale {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SheetScheduled Property

[image]

Revit 2024 API
ParameterTypeId..::..SheetScheduled Property
ParameterTypeId Class See Also Send Feedback
"Appears In Sheet List"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SheetScheduled { get; }
Visual Basic
Public Shared ReadOnly Property SheetScheduled As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SheetScheduled {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SheetWidth Property

[image]

Revit 2024 API
ParameterTypeId..::..SheetWidth Property
ParameterTypeId Class See Also Send Feedback
"Sheet Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SheetWidth { get; }
Visual Basic
Public Shared ReadOnly Property SheetWidth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SheetWidth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ShowIconParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ShowIconParam Property
ParameterTypeId Class See Also Send Feedback
"Flag to display icon in Ribbon Combo Item"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ShowIconParam { get; }
Visual Basic
Public Shared ReadOnly Property ShowIconParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ShowIconParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ShowTitle Property

[image]

Revit 2024 API
ParameterTypeId..::..ShowTitle Property
ParameterTypeId Class See Also Send Feedback
"Show Title"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ShowTitle { get; }
Visual Basic
Public Shared ReadOnly Property ShowTitle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ShowTitle {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SketchPlaneParam Property

[image]

Revit 2024 API
ParameterTypeId..::..SketchPlaneParam Property
ParameterTypeId Class See Also Send Feedback
"Work Plane"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SketchPlaneParam { get; }
Visual Basic
Public Shared ReadOnly Property SketchPlaneParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SketchPlaneParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SlabEdgeMaterialParam Property

[image]

Revit 2024 API
ParameterTypeId..::..SlabEdgeMaterialParam Property
ParameterTypeId Class See Also Send Feedback
"Material"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SlabEdgeMaterialParam { get; }
Visual Basic
Public Shared ReadOnly Property SlabEdgeMaterialParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SlabEdgeMaterialParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SlabEdgeProfileParam Property

[image]

Revit 2024 API
ParameterTypeId..::..SlabEdgeProfileParam Property
ParameterTypeId Class See Also Send Feedback
"Profile"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SlabEdgeProfileParam { get; }
Visual Basic
Public Shared ReadOnly Property SlabEdgeProfileParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SlabEdgeProfileParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SlantedColumnBaseCutStyle Property

[image]

Revit 2024 API
ParameterTypeId..::..SlantedColumnBaseCutStyle Property
ParameterTypeId Class See Also Send Feedback
"Base Cut Style"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SlantedColumnBaseCutStyle { get; }
Visual Basic
Public Shared ReadOnly Property SlantedColumnBaseCutStyle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SlantedColumnBaseCutStyle {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SlantedColumnGeometryTreatmentTop Property

[image]

Revit 2024 API
ParameterTypeId..::..SlantedColumnGeometryTreatmentTop Property
ParameterTypeId Class See Also Send Feedback
"Top Geometry Alignment"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SlantedColumnGeometryTreatmentTop { get; }
Visual Basic
Public Shared ReadOnly Property SlantedColumnGeometryTreatmentTop As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SlantedColumnGeometryTreatmentTop {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SlantedColumnTopCutStyle Property

[image]

Revit 2024 API
ParameterTypeId..::..SlantedColumnTopCutStyle Property
ParameterTypeId Class See Also Send Feedback
"Top Cut Style"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SlantedColumnTopCutStyle { get; }
Visual Basic
Public Shared ReadOnly Property SlantedColumnTopCutStyle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SlantedColumnTopCutStyle {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SlantedColumnTopExtension Property

[image]

Revit 2024 API
ParameterTypeId..::..SlantedColumnTopExtension Property
ParameterTypeId Class See Also Send Feedback
"Top Extension"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SlantedColumnTopExtension { get; }
Visual Basic
Public Shared ReadOnly Property SlantedColumnTopExtension As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SlantedColumnTopExtension {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SlantedColumnTypeParam Property

[image]

Revit 2024 API
ParameterTypeId..::..SlantedColumnTypeParam Property
ParameterTypeId Class See Also Send Feedback
"Column Style"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SlantedColumnTypeParam { get; }
Visual Basic
Public Shared ReadOnly Property SlantedColumnTypeParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SlantedColumnTypeParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SlopeArrowLevelEnd Property

[image]

Revit 2024 API
ParameterTypeId..::..SlopeArrowLevelEnd Property
ParameterTypeId Class See Also Send Feedback
"Level at Head"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SlopeArrowLevelEnd { get; }
Visual Basic
Public Shared ReadOnly Property SlopeArrowLevelEnd As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SlopeArrowLevelEnd {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SlopeArrowLevelStart Property

[image]

Revit 2024 API
ParameterTypeId..::..SlopeArrowLevelStart Property
ParameterTypeId Class See Also Send Feedback
"Level at Tail"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SlopeArrowLevelStart { get; }
Visual Basic
Public Shared ReadOnly Property SlopeArrowLevelStart As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SlopeArrowLevelStart {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SlopeEndHeight Property

[image]

Revit 2024 API
ParameterTypeId..::..SlopeEndHeight Property
ParameterTypeId Class See Also Send Feedback
"Height Offset at Head"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SlopeEndHeight { get; }
Visual Basic
Public Shared ReadOnly Property SlopeEndHeight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SlopeEndHeight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SlopeStartHeight Property

[image]

Revit 2024 API
ParameterTypeId..::..SlopeStartHeight Property
ParameterTypeId Class See Also Send Feedback
"Height Offset at Tail"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SlopeStartHeight { get; }
Visual Basic
Public Shared ReadOnly Property SlopeStartHeight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SlopeStartHeight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpaceAirChangesPerHour Property

[image]

Revit 2024 API
ParameterTypeId..::..SpaceAirChangesPerHour Property
ParameterTypeId Class See Also Send Feedback
"Air Changes per Hour"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpaceAirChangesPerHour { get; }
Visual Basic
Public Shared ReadOnly Property SpaceAirChangesPerHour As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpaceAirChangesPerHour {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpaceAirflowPerAreaParam Property

[image]

Revit 2024 API
ParameterTypeId..::..SpaceAirflowPerAreaParam Property
ParameterTypeId Class See Also Send Feedback
"Airflow per area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpaceAirflowPerAreaParam { get; }
Visual Basic
Public Shared ReadOnly Property SpaceAirflowPerAreaParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpaceAirflowPerAreaParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpaceArea Property

[image]

Revit 2024 API
ParameterTypeId..::..SpaceArea Property
ParameterTypeId Class See Also Send Feedback
"Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpaceArea { get; }
Visual Basic
Public Shared ReadOnly Property SpaceArea As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpaceArea {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpaceAreaPerPersonParam Property

[image]

Revit 2024 API
ParameterTypeId..::..SpaceAreaPerPersonParam Property
ParameterTypeId Class See Also Send Feedback
"Area per person"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpaceAreaPerPersonParam { get; }
Visual Basic
Public Shared ReadOnly Property SpaceAreaPerPersonParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpaceAreaPerPersonParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpaceAssocRoomNumber Property

[image]

Revit 2024 API
ParameterTypeId..::..SpaceAssocRoomNumber Property
ParameterTypeId Class See Also Send Feedback
"Room Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpaceAssocRoomNumber { get; }
Visual Basic
Public Shared ReadOnly Property SpaceAssocRoomNumber As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpaceAssocRoomNumber {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpaceCarpetingParam Property

[image]

Revit 2024 API
ParameterTypeId..::..SpaceCarpetingParam Property
ParameterTypeId Class See Also Send Feedback
"Carpeting"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpaceCarpetingParam { get; }
Visual Basic
Public Shared ReadOnly Property SpaceCarpetingParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpaceCarpetingParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpaceCoolingSetPoint Property

[image]

Revit 2024 API
ParameterTypeId..::..SpaceCoolingSetPoint Property
ParameterTypeId Class See Also Send Feedback
"Cooling Set Point"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpaceCoolingSetPoint { get; }
Visual Basic
Public Shared ReadOnly Property SpaceCoolingSetPoint As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpaceCoolingSetPoint {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpaceDehumidificationSetPoint Property

[image]

Revit 2024 API
ParameterTypeId..::..SpaceDehumidificationSetPoint Property
ParameterTypeId Class See Also Send Feedback
"Dehumidification Set Point"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpaceDehumidificationSetPoint { get; }
Visual Basic
Public Shared ReadOnly Property SpaceDehumidificationSetPoint As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpaceDehumidificationSetPoint {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpaceElecEquipmentRadiantPercentageParam Property

[image]

Revit 2024 API
ParameterTypeId..::..SpaceElecEquipmentRadiantPercentageParam Property
ParameterTypeId Class See Also Send Feedback
"Electrical Equipment Radiant"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpaceElecEquipmentRadiantPercentageParam { get; }
Visual Basic
Public Shared ReadOnly Property SpaceElecEquipmentRadiantPercentageParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpaceElecEquipmentRadiantPercentageParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpaceHeatingSetPoint Property

[image]

Revit 2024 API
ParameterTypeId..::..SpaceHeatingSetPoint Property
ParameterTypeId Class See Also Send Feedback
"Heating Set Point"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpaceHeatingSetPoint { get; }
Visual Basic
Public Shared ReadOnly Property SpaceHeatingSetPoint As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpaceHeatingSetPoint {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpaceHumidificationSetPoint Property

[image]

Revit 2024 API
ParameterTypeId..::..SpaceHumidificationSetPoint Property
ParameterTypeId Class See Also Send Feedback
"Humidification Set Point"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpaceHumidificationSetPoint { get; }
Visual Basic
Public Shared ReadOnly Property SpaceHumidificationSetPoint As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpaceHumidificationSetPoint {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpaceInfiltrationAirflow Property

[image]

Revit 2024 API
ParameterTypeId..::..SpaceInfiltrationAirflow Property
ParameterTypeId Class See Also Send Feedback
"Infiltration Airflow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpaceInfiltrationAirflow { get; }
Visual Basic
Public Shared ReadOnly Property SpaceInfiltrationAirflow As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpaceInfiltrationAirflow {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpaceInfiltrationAirflowPerArea Property

[image]

Revit 2024 API
ParameterTypeId..::..SpaceInfiltrationAirflowPerArea Property
ParameterTypeId Class See Also Send Feedback
"Infiltration Airflow per area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpaceInfiltrationAirflowPerArea { get; }
Visual Basic
Public Shared ReadOnly Property SpaceInfiltrationAirflowPerArea As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpaceInfiltrationAirflowPerArea {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpaceInfiltrationParam Property

[image]

Revit 2024 API
ParameterTypeId..::..SpaceInfiltrationParam Property
ParameterTypeId Class See Also Send Feedback
"Infiltration Airflow per area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpaceInfiltrationParam { get; }
Visual Basic
Public Shared ReadOnly Property SpaceInfiltrationParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpaceInfiltrationParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpaceLightingLoadParam Property

[image]

Revit 2024 API
ParameterTypeId..::..SpaceLightingLoadParam Property
ParameterTypeId Class See Also Send Feedback
"Lighting Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpaceLightingLoadParam { get; }
Visual Basic
Public Shared ReadOnly Property SpaceLightingLoadParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpaceLightingLoadParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpaceLightingLoadPerAreaParam Property

[image]

Revit 2024 API
ParameterTypeId..::..SpaceLightingLoadPerAreaParam Property
ParameterTypeId Class See Also Send Feedback
"Lighting Load per area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpaceLightingLoadPerAreaParam { get; }
Visual Basic
Public Shared ReadOnly Property SpaceLightingLoadPerAreaParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpaceLightingLoadPerAreaParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpaceLightingScheduleParam Property

[image]

Revit 2024 API
ParameterTypeId..::..SpaceLightingScheduleParam Property
ParameterTypeId Class See Also Send Feedback
"Lighting Schedule"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpaceLightingScheduleParam { get; }
Visual Basic
Public Shared ReadOnly Property SpaceLightingScheduleParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpaceLightingScheduleParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpaceNameParam Property

[image]

Revit 2024 API
ParameterTypeId..::..SpaceNameParam Property
ParameterTypeId Class See Also Send Feedback
"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpaceNameParam { get; }
Visual Basic
Public Shared ReadOnly Property SpaceNameParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpaceNameParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpaceNumberOfPeople Property

[image]

Revit 2024 API
ParameterTypeId..::..SpaceNumberOfPeople Property
ParameterTypeId Class See Also Send Feedback
"Number of People"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpaceNumberOfPeople { get; }
Visual Basic
Public Shared ReadOnly Property SpaceNumberOfPeople As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpaceNumberOfPeople {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpaceNumberParam Property

[image]

Revit 2024 API
ParameterTypeId..::..SpaceNumberParam Property
ParameterTypeId Class See Also Send Feedback
"Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpaceNumberParam { get; }
Visual Basic
Public Shared ReadOnly Property SpaceNumberParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpaceNumberParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpaceOccupancyScheduleParam Property

[image]

Revit 2024 API
ParameterTypeId..::..SpaceOccupancyScheduleParam Property
ParameterTypeId Class See Also Send Feedback
"Occupancy Schedule"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpaceOccupancyScheduleParam { get; }
Visual Basic
Public Shared ReadOnly Property SpaceOccupancyScheduleParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpaceOccupancyScheduleParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpaceOutdoorAirflow Property

[image]

Revit 2024 API
ParameterTypeId..::..SpaceOutdoorAirflow Property
ParameterTypeId Class See Also Send Feedback
"Outdoor Airflow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpaceOutdoorAirflow { get; }
Visual Basic
Public Shared ReadOnly Property SpaceOutdoorAirflow As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpaceOutdoorAirflow {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpaceOutdoorAirflowPerArea Property

[image]

Revit 2024 API
ParameterTypeId..::..SpaceOutdoorAirflowPerArea Property
ParameterTypeId Class See Also Send Feedback
"Outdoor Airflow per area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpaceOutdoorAirflowPerArea { get; }
Visual Basic
Public Shared ReadOnly Property SpaceOutdoorAirflowPerArea As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpaceOutdoorAirflowPerArea {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpacePeopleActivityLevelParam Property

[image]

Revit 2024 API
ParameterTypeId..::..SpacePeopleActivityLevelParam Property
ParameterTypeId Class See Also Send Feedback
"People Activity Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpacePeopleActivityLevelParam { get; }
Visual Basic
Public Shared ReadOnly Property SpacePeopleActivityLevelParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpacePeopleActivityLevelParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpacePeopleLatentHeatGainPerPersonParam Property

[image]

Revit 2024 API
ParameterTypeId..::..SpacePeopleLatentHeatGainPerPersonParam Property
ParameterTypeId Class See Also Send Feedback
"Latent Heat Gain per person"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpacePeopleLatentHeatGainPerPersonParam { get; }
Visual Basic
Public Shared ReadOnly Property SpacePeopleLatentHeatGainPerPersonParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpacePeopleLatentHeatGainPerPersonParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpacePeopleSensibleHeatGainPerPersonParam Property

[image]

Revit 2024 API
ParameterTypeId..::..SpacePeopleSensibleHeatGainPerPersonParam Property
ParameterTypeId Class See Also Send Feedback
"Sensible Heat Gain per person"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpacePeopleSensibleHeatGainPerPersonParam { get; }
Visual Basic
Public Shared ReadOnly Property SpacePeopleSensibleHeatGainPerPersonParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpacePeopleSensibleHeatGainPerPersonParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpacePowerLoadParam Property

[image]

Revit 2024 API
ParameterTypeId..::..SpacePowerLoadParam Property
ParameterTypeId Class See Also Send Feedback
"Power Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpacePowerLoadParam { get; }
Visual Basic
Public Shared ReadOnly Property SpacePowerLoadParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpacePowerLoadParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpacePowerLoadPerAreaParam Property

[image]

Revit 2024 API
ParameterTypeId..::..SpacePowerLoadPerAreaParam Property
ParameterTypeId Class See Also Send Feedback
"Power Load per area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpacePowerLoadPerAreaParam { get; }
Visual Basic
Public Shared ReadOnly Property SpacePowerLoadPerAreaParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpacePowerLoadPerAreaParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpacePowerScheduleParam Property

[image]

Revit 2024 API
ParameterTypeId..::..SpacePowerScheduleParam Property
ParameterTypeId Class See Also Send Feedback
"Power Schedule"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpacePowerScheduleParam { get; }
Visual Basic
Public Shared ReadOnly Property SpacePowerScheduleParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpacePowerScheduleParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpaceReferenceLevelParam Property

[image]

Revit 2024 API
ParameterTypeId..::..SpaceReferenceLevelParam Property
ParameterTypeId Class See Also Send Feedback
"Reference Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpaceReferenceLevelParam { get; }
Visual Basic
Public Shared ReadOnly Property SpaceReferenceLevelParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpaceReferenceLevelParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpaceTypeGbxml Property

[image]

Revit 2024 API
ParameterTypeId..::..SpaceTypeGbxml Property
ParameterTypeId Class See Also Send Feedback
"Space Type (gbXML)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpaceTypeGbxml { get; }
Visual Basic
Public Shared ReadOnly Property SpaceTypeGbxml As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpaceTypeGbxml {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpaceZoneName Property

[image]

Revit 2024 API
ParameterTypeId..::..SpaceZoneName Property
ParameterTypeId Class See Also Send Feedback
"Zone"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpaceZoneName { get; }
Visual Basic
Public Shared ReadOnly Property SpaceZoneName As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpaceZoneName {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpacingAppend Property

[image]

Revit 2024 API
ParameterTypeId..::..SpacingAppend Property
ParameterTypeId Class See Also Send Feedback
"Append Position"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpacingAppend { get; }
Visual Basic
Public Shared ReadOnly Property SpacingAppend As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpacingAppend {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpacingJustification Property

[image]

Revit 2024 API
ParameterTypeId..::..SpacingJustification Property
ParameterTypeId Class See Also Send Feedback
"Justification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpacingJustification { get; }
Visual Basic
Public Shared ReadOnly Property SpacingJustification As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpacingJustification {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpacingJustificationHoriz Property

[image]

Revit 2024 API
ParameterTypeId..::..SpacingJustificationHoriz Property
ParameterTypeId Class See Also Send Feedback
"Justification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpacingJustificationHoriz { get; }
Visual Basic
Public Shared ReadOnly Property SpacingJustificationHoriz As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpacingJustificationHoriz {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpacingJustificationn1 Property

[image]

Revit 2024 API
ParameterTypeId..::..SpacingJustificationn1 Property
ParameterTypeId Class See Also Send Feedback
"Justification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpacingJustificationn1 { get; }
Visual Basic
Public Shared ReadOnly Property SpacingJustificationn1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpacingJustificationn1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpacingJustificationn2 Property

[image]

Revit 2024 API
ParameterTypeId..::..SpacingJustificationn2 Property
ParameterTypeId Class See Also Send Feedback
"Justification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpacingJustificationn2 { get; }
Visual Basic
Public Shared ReadOnly Property SpacingJustificationn2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpacingJustificationn2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpacingJustificationU Property

[image]

Revit 2024 API
ParameterTypeId..::..SpacingJustificationU Property
ParameterTypeId Class See Also Send Feedback
"Justification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpacingJustificationU { get; }
Visual Basic
Public Shared ReadOnly Property SpacingJustificationU As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpacingJustificationU {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpacingJustificationV Property

[image]

Revit 2024 API
ParameterTypeId..::..SpacingJustificationV Property
ParameterTypeId Class See Also Send Feedback
"Justification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpacingJustificationV { get; }
Visual Basic
Public Shared ReadOnly Property SpacingJustificationV As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpacingJustificationV {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpacingJustificationVert Property

[image]

Revit 2024 API
ParameterTypeId..::..SpacingJustificationVert Property
ParameterTypeId Class See Also Send Feedback
"Justification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpacingJustificationVert { get; }
Visual Basic
Public Shared ReadOnly Property SpacingJustificationVert As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpacingJustificationVert {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpacingLayout Property

[image]

Revit 2024 API
ParameterTypeId..::..SpacingLayout Property
ParameterTypeId Class See Also Send Feedback
"Layout"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpacingLayout { get; }
Visual Basic
Public Shared ReadOnly Property SpacingLayout As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpacingLayout {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpacingLayoutHoriz Property

[image]

Revit 2024 API
ParameterTypeId..::..SpacingLayoutHoriz Property
ParameterTypeId Class See Also Send Feedback
"Layout"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpacingLayoutHoriz { get; }
Visual Basic
Public Shared ReadOnly Property SpacingLayoutHoriz As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpacingLayoutHoriz {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpacingLayoutn2 Property

[image]

Revit 2024 API
ParameterTypeId..::..SpacingLayoutn2 Property
ParameterTypeId Class See Also Send Feedback
"Layout"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpacingLayoutn2 { get; }
Visual Basic
Public Shared ReadOnly Property SpacingLayoutn2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpacingLayoutn2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpacingLayoutU Property

[image]

Revit 2024 API
ParameterTypeId..::..SpacingLayoutU Property
ParameterTypeId Class See Also Send Feedback
"Layout"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpacingLayoutU { get; }
Visual Basic
Public Shared ReadOnly Property SpacingLayoutU As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpacingLayoutU {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpacingLayoutV Property

[image]

Revit 2024 API
ParameterTypeId..::..SpacingLayoutV Property
ParameterTypeId Class See Also Send Feedback
"Layout"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpacingLayoutV { get; }
Visual Basic
Public Shared ReadOnly Property SpacingLayoutV As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpacingLayoutV {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpacingLayoutVert Property

[image]

Revit 2024 API
ParameterTypeId..::..SpacingLayoutVert Property
ParameterTypeId Class See Also Send Feedback
"Layout"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpacingLayoutVert { get; }
Visual Basic
Public Shared ReadOnly Property SpacingLayoutVert As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpacingLayoutVert {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpacingLengthHoriz Property

[image]

Revit 2024 API
ParameterTypeId..::..SpacingLengthHoriz Property
ParameterTypeId Class See Also Send Feedback
"Spacing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpacingLengthHoriz { get; }
Visual Basic
Public Shared ReadOnly Property SpacingLengthHoriz As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpacingLengthHoriz {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpacingLengthn1 Property

[image]

Revit 2024 API
ParameterTypeId..::..SpacingLengthn1 Property
ParameterTypeId Class See Also Send Feedback
"Spacing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpacingLengthn1 { get; }
Visual Basic
Public Shared ReadOnly Property SpacingLengthn1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpacingLengthn1 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpacingLengthn2 Property

[image]

Revit 2024 API
ParameterTypeId..::..SpacingLengthn2 Property
ParameterTypeId Class See Also Send Feedback
"Spacing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpacingLengthn2 { get; }
Visual Basic
Public Shared ReadOnly Property SpacingLengthn2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpacingLengthn2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpacingLengthU Property

[image]

Revit 2024 API
ParameterTypeId..::..SpacingLengthU Property
ParameterTypeId Class See Also Send Feedback
"Distance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpacingLengthU { get; }
Visual Basic
Public Shared ReadOnly Property SpacingLengthU As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpacingLengthU {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpacingLengthVert Property

[image]

Revit 2024 API
ParameterTypeId..::..SpacingLengthVert Property
ParameterTypeId Class See Also Send Feedback
"Spacing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpacingLengthVert { get; }
Visual Basic
Public Shared ReadOnly Property SpacingLengthVert As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpacingLengthVert {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpacingNumDivisions Property

[image]

Revit 2024 API
ParameterTypeId..::..SpacingNumDivisions Property
ParameterTypeId Class See Also Send Feedback
"Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpacingNumDivisions { get; }
Visual Basic
Public Shared ReadOnly Property SpacingNumDivisions As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpacingNumDivisions {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpacingNumDivisionsn2 Property

[image]

Revit 2024 API
ParameterTypeId..::..SpacingNumDivisionsn2 Property
ParameterTypeId Class See Also Send Feedback
"Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpacingNumDivisionsn2 { get; }
Visual Basic
Public Shared ReadOnly Property SpacingNumDivisionsn2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpacingNumDivisionsn2 {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpacingNumDivisionsU Property

[image]

Revit 2024 API
ParameterTypeId..::..SpacingNumDivisionsU Property
ParameterTypeId Class See Also Send Feedback
"Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpacingNumDivisionsU { get; }
Visual Basic
Public Shared ReadOnly Property SpacingNumDivisionsU As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpacingNumDivisionsU {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpacingNumDivisionsV Property

[image]

Revit 2024 API
ParameterTypeId..::..SpacingNumDivisionsV Property
ParameterTypeId Class See Also Send Feedback
"Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpacingNumDivisionsV { get; }
Visual Basic
Public Shared ReadOnly Property SpacingNumDivisionsV As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpacingNumDivisionsV {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpacingNumDivisionsVert Property

[image]

Revit 2024 API
ParameterTypeId..::..SpacingNumDivisionsVert Property
ParameterTypeId Class See Also Send Feedback
"Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpacingNumDivisionsVert { get; }
Visual Basic
Public Shared ReadOnly Property SpacingNumDivisionsVert As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpacingNumDivisionsVert {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpanDirInstParamAngle Property

[image]

Revit 2024 API
ParameterTypeId..::..SpanDirInstParamAngle Property
ParameterTypeId Class See Also Send Feedback
"Span Direction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpanDirInstParamAngle { get; }
Visual Basic
Public Shared ReadOnly Property SpanDirInstParamAngle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpanDirInstParamAngle {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpanDirSymParamRight Property

[image]

Revit 2024 API
ParameterTypeId..::..SpanDirSymParamRight Property
ParameterTypeId Class See Also Send Feedback
"Right"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpanDirSymParamRight { get; }
Visual Basic
Public Shared ReadOnly Property SpanDirSymParamRight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpanDirSymParamRight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpanDirSymParamTop Property

[image]

Revit 2024 API
ParameterTypeId..::..SpanDirSymParamTop Property
ParameterTypeId Class See Also Send Feedback
"Top"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpanDirSymParamTop { get; }
Visual Basic
Public Shared ReadOnly Property SpanDirSymParamTop As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpanDirSymParamTop {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpatialFieldMgrDescription Property

[image]

Revit 2024 API
ParameterTypeId..::..SpatialFieldMgrDescription Property
ParameterTypeId Class See Also Send Feedback
"Description"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpatialFieldMgrDescription { get; }
Visual Basic
Public Shared ReadOnly Property SpatialFieldMgrDescription As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpatialFieldMgrDescription {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpatialFieldMgrLegendShowConfigName Property

[image]

Revit 2024 API
ParameterTypeId..::..SpatialFieldMgrLegendShowConfigName Property
ParameterTypeId Class See Also Send Feedback
"Show Configuration Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpatialFieldMgrLegendShowConfigName { get; }
Visual Basic
Public Shared ReadOnly Property SpatialFieldMgrLegendShowConfigName As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpatialFieldMgrLegendShowConfigName {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpatialFieldMgrLegendShowDescription Property

[image]

Revit 2024 API
ParameterTypeId..::..SpatialFieldMgrLegendShowDescription Property
ParameterTypeId Class See Also Send Feedback
"Show Description"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpatialFieldMgrLegendShowDescription { get; }
Visual Basic
Public Shared ReadOnly Property SpatialFieldMgrLegendShowDescription As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpatialFieldMgrLegendShowDescription {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpatialFieldMgrLegendTextType Property

[image]

Revit 2024 API
ParameterTypeId..::..SpatialFieldMgrLegendTextType Property
ParameterTypeId Class See Also Send Feedback
"Overall Legend Text"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpatialFieldMgrLegendTextType { get; }
Visual Basic
Public Shared ReadOnly Property SpatialFieldMgrLegendTextType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpatialFieldMgrLegendTextType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpatialFieldMgrLegendVertOriginGap Property

[image]

Revit 2024 API
ParameterTypeId..::..SpatialFieldMgrLegendVertOriginGap Property
ParameterTypeId Class See Also Send Feedback
"Legend Vertical Origin Gap"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpatialFieldMgrLegendVertOriginGap { get; }
Visual Basic
Public Shared ReadOnly Property SpatialFieldMgrLegendVertOriginGap As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpatialFieldMgrLegendVertOriginGap {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpatialFieldMgrLegendWidth Property

[image]

Revit 2024 API
ParameterTypeId..::..SpatialFieldMgrLegendWidth Property
ParameterTypeId Class See Also Send Feedback
"Legend Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpatialFieldMgrLegendWidth { get; }
Visual Basic
Public Shared ReadOnly Property SpatialFieldMgrLegendWidth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpatialFieldMgrLegendWidth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpatialFieldMgrRange Property

[image]

Revit 2024 API
ParameterTypeId..::..SpatialFieldMgrRange Property
ParameterTypeId Class See Also Send Feedback
"Data Range"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpatialFieldMgrRange { get; }
Visual Basic
Public Shared ReadOnly Property SpatialFieldMgrRange As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpatialFieldMgrRange {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpatialFieldMgrResultsVisibility Property

[image]

Revit 2024 API
ParameterTypeId..::..SpatialFieldMgrResultsVisibility Property
ParameterTypeId Class See Also Send Feedback
"Results Visibility"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpatialFieldMgrResultsVisibility { get; }
Visual Basic
Public Shared ReadOnly Property SpatialFieldMgrResultsVisibility As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpatialFieldMgrResultsVisibility {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpecifySlopeOrOffset Property

[image]

Revit 2024 API
ParameterTypeId..::..SpecifySlopeOrOffset Property
ParameterTypeId Class See Also Send Feedback
"Specify "

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpecifySlopeOrOffset { get; }
Visual Basic
Public Shared ReadOnly Property SpecifySlopeOrOffset As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpecifySlopeOrOffset {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpotCoordinateBase Property

[image]

Revit 2024 API
ParameterTypeId..::..SpotCoordinateBase Property
ParameterTypeId Class See Also Send Feedback
"Coordinate Base"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpotCoordinateBase { get; }
Visual Basic
Public Shared ReadOnly Property SpotCoordinateBase As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpotCoordinateBase {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpotCoordinateBottomPrefix Property

[image]

Revit 2024 API
ParameterTypeId..::..SpotCoordinateBottomPrefix Property
ParameterTypeId Class See Also Send Feedback
"Bottom Coordinate Prefix"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpotCoordinateBottomPrefix { get; }
Visual Basic
Public Shared ReadOnly Property SpotCoordinateBottomPrefix As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpotCoordinateBottomPrefix {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpotCoordinateBottomSuffix Property

[image]

Revit 2024 API
ParameterTypeId..::..SpotCoordinateBottomSuffix Property
ParameterTypeId Class See Also Send Feedback
"Bottom Coordinate Suffix"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpotCoordinateBottomSuffix { get; }
Visual Basic
Public Shared ReadOnly Property SpotCoordinateBottomSuffix As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpotCoordinateBottomSuffix {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpotCoordinateElevationPrefix Property

[image]

Revit 2024 API
ParameterTypeId..::..SpotCoordinateElevationPrefix Property
ParameterTypeId Class See Also Send Feedback
"Elevation Prefix"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpotCoordinateElevationPrefix { get; }
Visual Basic
Public Shared ReadOnly Property SpotCoordinateElevationPrefix As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpotCoordinateElevationPrefix {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpotCoordinateElevationSuffix Property

[image]

Revit 2024 API
ParameterTypeId..::..SpotCoordinateElevationSuffix Property
ParameterTypeId Class See Also Send Feedback
"Elevation Suffix"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpotCoordinateElevationSuffix { get; }
Visual Basic
Public Shared ReadOnly Property SpotCoordinateElevationSuffix As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpotCoordinateElevationSuffix {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpotCoordinateTopSuffix Property

[image]

Revit 2024 API
ParameterTypeId..::..SpotCoordinateTopSuffix Property
ParameterTypeId Class See Also Send Feedback
"Top Coordinate Suffix"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpotCoordinateTopSuffix { get; }
Visual Basic
Public Shared ReadOnly Property SpotCoordinateTopSuffix As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpotCoordinateTopSuffix {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpotDimLeader Property

[image]

Revit 2024 API
ParameterTypeId..::..SpotDimLeader Property
ParameterTypeId Class See Also Send Feedback
"Leader"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpotDimLeader { get; }
Visual Basic
Public Shared ReadOnly Property SpotDimLeader As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpotDimLeader {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpotDimLeaderLine Property

[image]

Revit 2024 API
ParameterTypeId..::..SpotDimLeaderLine Property
ParameterTypeId Class See Also Send Feedback
"Leader Line"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpotDimLeaderLine { get; }
Visual Basic
Public Shared ReadOnly Property SpotDimLeaderLine As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpotDimLeaderLine {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpotDimStyleSlopeUnits Property

[image]

Revit 2024 API
ParameterTypeId..::..SpotDimStyleSlopeUnits Property
ParameterTypeId Class See Also Send Feedback
"Units Format"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpotDimStyleSlopeUnits { get; }
Visual Basic
Public Shared ReadOnly Property SpotDimStyleSlopeUnits As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpotDimStyleSlopeUnits {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpotDimStyleSlopeUnitsAlt Property

[image]

Revit 2024 API
ParameterTypeId..::..SpotDimStyleSlopeUnitsAlt Property
ParameterTypeId Class See Also Send Feedback
"Alternate Units Format"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpotDimStyleSlopeUnitsAlt { get; }
Visual Basic
Public Shared ReadOnly Property SpotDimStyleSlopeUnitsAlt As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpotDimStyleSlopeUnitsAlt {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpotElevBase Property

[image]

Revit 2024 API
ParameterTypeId..::..SpotElevBase Property
ParameterTypeId Class See Also Send Feedback
"Elevation Base"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpotElevBase { get; }
Visual Basic
Public Shared ReadOnly Property SpotElevBase As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpotElevBase {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpotElevBendLeader Property

[image]

Revit 2024 API
ParameterTypeId..::..SpotElevBendLeader Property
ParameterTypeId Class See Also Send Feedback
"Leader Shoulder"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpotElevBendLeader { get; }
Visual Basic
Public Shared ReadOnly Property SpotElevBendLeader As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpotElevBendLeader {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpotElevBotValue Property

[image]

Revit 2024 API
ParameterTypeId..::..SpotElevBotValue Property
ParameterTypeId Class See Also Send Feedback
"Bottom Coordinate"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpotElevBotValue { get; }
Visual Basic
Public Shared ReadOnly Property SpotElevBotValue As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpotElevBotValue {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpotElevDisplayElevations Property

[image]

Revit 2024 API
ParameterTypeId..::..SpotElevDisplayElevations Property
ParameterTypeId Class See Also Send Feedback
"Display Elevations"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpotElevDisplayElevations { get; }
Visual Basic
Public Shared ReadOnly Property SpotElevDisplayElevations As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpotElevDisplayElevations {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpotElevIndBottom Property

[image]

Revit 2024 API
ParameterTypeId..::..SpotElevIndBottom Property
ParameterTypeId Class See Also Send Feedback
"Bottom Indicator"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpotElevIndBottom { get; }
Visual Basic
Public Shared ReadOnly Property SpotElevIndBottom As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpotElevIndBottom {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpotElevIndElevation Property

[image]

Revit 2024 API
ParameterTypeId..::..SpotElevIndElevation Property
ParameterTypeId Class See Also Send Feedback
"Elevation Indicator"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpotElevIndElevation { get; }
Visual Basic
Public Shared ReadOnly Property SpotElevIndElevation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpotElevIndElevation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpotElevIndEw Property

[image]

Revit 2024 API
ParameterTypeId..::..SpotElevIndEw Property
ParameterTypeId Class See Also Send Feedback
"East / West Indicator"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpotElevIndEw { get; }
Visual Basic
Public Shared ReadOnly Property SpotElevIndEw As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpotElevIndEw {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpotElevIndNs Property

[image]

Revit 2024 API
ParameterTypeId..::..SpotElevIndNs Property
ParameterTypeId Class See Also Send Feedback
"North / South Indicator"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpotElevIndNs { get; }
Visual Basic
Public Shared ReadOnly Property SpotElevIndNs As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpotElevIndNs {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpotElevIndTop Property

[image]

Revit 2024 API
ParameterTypeId..::..SpotElevIndTop Property
ParameterTypeId Class See Also Send Feedback
"Top Indicator"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpotElevIndTop { get; }
Visual Basic
Public Shared ReadOnly Property SpotElevIndTop As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpotElevIndTop {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpotElevIndTypeBottom Property

[image]

Revit 2024 API
ParameterTypeId..::..SpotElevIndTypeBottom Property
ParameterTypeId Class See Also Send Feedback
"Bottom Indicator as Prefix/Suffix"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpotElevIndTypeBottom { get; }
Visual Basic
Public Shared ReadOnly Property SpotElevIndTypeBottom As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpotElevIndTypeBottom {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpotElevIndTypeElevation Property

[image]

Revit 2024 API
ParameterTypeId..::..SpotElevIndTypeElevation Property
ParameterTypeId Class See Also Send Feedback
"Elevation Indicator as Prefix/Suffix"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpotElevIndTypeElevation { get; }
Visual Basic
Public Shared ReadOnly Property SpotElevIndTypeElevation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpotElevIndTypeElevation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpotElevIndTypeTop Property

[image]

Revit 2024 API
ParameterTypeId..::..SpotElevIndTypeTop Property
ParameterTypeId Class See Also Send Feedback
"Top Indicator as Prefix/Suffix"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpotElevIndTypeTop { get; }
Visual Basic
Public Shared ReadOnly Property SpotElevIndTypeTop As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpotElevIndTypeTop {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpotElevLeaderArrowhead Property

[image]

Revit 2024 API
ParameterTypeId..::..SpotElevLeaderArrowhead Property
ParameterTypeId Class See Also Send Feedback
"Leader Arrowhead"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpotElevLeaderArrowhead { get; }
Visual Basic
Public Shared ReadOnly Property SpotElevLeaderArrowhead As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpotElevLeaderArrowhead {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpotElevLowerPrefix Property

[image]

Revit 2024 API
ParameterTypeId..::..SpotElevLowerPrefix Property
ParameterTypeId Class See Also Send Feedback
"Lower Value Prefix"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpotElevLowerPrefix { get; }
Visual Basic
Public Shared ReadOnly Property SpotElevLowerPrefix As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpotElevLowerPrefix {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpotElevLowerValue Property

[image]

Revit 2024 API
ParameterTypeId..::..SpotElevLowerValue Property
ParameterTypeId Class See Also Send Feedback
"Lower Value"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpotElevLowerValue { get; }
Visual Basic
Public Shared ReadOnly Property SpotElevLowerValue As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpotElevLowerValue {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpotElevRelativeBase Property

[image]

Revit 2024 API
ParameterTypeId..::..SpotElevRelativeBase Property
ParameterTypeId Class See Also Send Feedback
"Relative Base"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpotElevRelativeBase { get; }
Visual Basic
Public Shared ReadOnly Property SpotElevRelativeBase As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpotElevRelativeBase {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpotElevRotateWithComponent Property

[image]

Revit 2024 API
ParameterTypeId..::..SpotElevRotateWithComponent Property
ParameterTypeId Class See Also Send Feedback
"Rotate with Component"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpotElevRotateWithComponent { get; }
Visual Basic
Public Shared ReadOnly Property SpotElevRotateWithComponent As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpotElevRotateWithComponent {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpotElevSingleOrUpperPrefix Property

[image]

Revit 2024 API
ParameterTypeId..::..SpotElevSingleOrUpperPrefix Property
ParameterTypeId Class See Also Send Feedback
"Single/Upper Value Prefix"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpotElevSingleOrUpperPrefix { get; }
Visual Basic
Public Shared ReadOnly Property SpotElevSingleOrUpperPrefix As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpotElevSingleOrUpperPrefix {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpotElevSingleOrUpperSuffix Property

[image]

Revit 2024 API
ParameterTypeId..::..SpotElevSingleOrUpperSuffix Property
ParameterTypeId Class See Also Send Feedback
"Single/Upper Value Suffix"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpotElevSingleOrUpperSuffix { get; }
Visual Basic
Public Shared ReadOnly Property SpotElevSingleOrUpperSuffix As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpotElevSingleOrUpperSuffix {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpotElevSingleOrUpperValue Property

[image]

Revit 2024 API
ParameterTypeId..::..SpotElevSingleOrUpperValue Property
ParameterTypeId Class See Also Send Feedback
"Single/Upper Value"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpotElevSingleOrUpperValue { get; }
Visual Basic
Public Shared ReadOnly Property SpotElevSingleOrUpperValue As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpotElevSingleOrUpperValue {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpotElevSymbol Property

[image]

Revit 2024 API
ParameterTypeId..::..SpotElevSymbol Property
ParameterTypeId Class See Also Send Feedback
"Symbol"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpotElevSymbol { get; }
Visual Basic
Public Shared ReadOnly Property SpotElevSymbol As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpotElevSymbol {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpotElevTextHorizOffset Property

[image]

Revit 2024 API
ParameterTypeId..::..SpotElevTextHorizOffset Property
ParameterTypeId Class See Also Send Feedback
"Text Offset from Symbol"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpotElevTextHorizOffset { get; }
Visual Basic
Public Shared ReadOnly Property SpotElevTextHorizOffset As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpotElevTextHorizOffset {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpotElevTextOrientation Property

[image]

Revit 2024 API
ParameterTypeId..::..SpotElevTextOrientation Property
ParameterTypeId Class See Also Send Feedback
"Text Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpotElevTextOrientation { get; }
Visual Basic
Public Shared ReadOnly Property SpotElevTextOrientation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpotElevTextOrientation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpotElevTickMarkPen Property

[image]

Revit 2024 API
ParameterTypeId..::..SpotElevTickMarkPen Property
ParameterTypeId Class See Also Send Feedback
"Leader Arrowhead Line Weight"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpotElevTickMarkPen { get; }
Visual Basic
Public Shared ReadOnly Property SpotElevTickMarkPen As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpotElevTickMarkPen {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpotElevTopValue Property

[image]

Revit 2024 API
ParameterTypeId..::..SpotElevTopValue Property
ParameterTypeId Class See Also Send Feedback
"Top Coordinate"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpotElevTopValue { get; }
Visual Basic
Public Shared ReadOnly Property SpotElevTopValue As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpotElevTopValue {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpotSlopePrefix Property

[image]

Revit 2024 API
ParameterTypeId..::..SpotSlopePrefix Property
ParameterTypeId Class See Also Send Feedback
"Prefix"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpotSlopePrefix { get; }
Visual Basic
Public Shared ReadOnly Property SpotSlopePrefix As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpotSlopePrefix {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpotSlopeSlopeDirection Property

[image]

Revit 2024 API
ParameterTypeId..::..SpotSlopeSlopeDirection Property
ParameterTypeId Class See Also Send Feedback
"Slope Direction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpotSlopeSlopeDirection { get; }
Visual Basic
Public Shared ReadOnly Property SpotSlopeSlopeDirection As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpotSlopeSlopeDirection {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpotSlopeSlopeRepresentation Property

[image]

Revit 2024 API
ParameterTypeId..::..SpotSlopeSlopeRepresentation Property
ParameterTypeId Class See Also Send Feedback
"Slope Representation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpotSlopeSlopeRepresentation { get; }
Visual Basic
Public Shared ReadOnly Property SpotSlopeSlopeRepresentation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpotSlopeSlopeRepresentation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SpotSlopeSuffix Property

[image]

Revit 2024 API
ParameterTypeId..::..SpotSlopeSuffix Property
ParameterTypeId Class See Also Send Feedback
"Suffix"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SpotSlopeSuffix { get; }
Visual Basic
Public Shared ReadOnly Property SpotSlopeSuffix As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpotSlopeSuffix {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SsePointBasetypeEnum Property

[image]

Revit 2024 API
ParameterTypeId..::..SsePointBasetypeEnum Property
ParameterTypeId Class See Also Send Feedback
"Point Base Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SsePointBasetypeEnum { get; }
Visual Basic
Public Shared ReadOnly Property SsePointBasetypeEnum As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SsePointBasetypeEnum {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SsePointElevation Property

[image]

Revit 2024 API
ParameterTypeId..::..SsePointElevation Property
ParameterTypeId Class See Also Send Feedback
"Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SsePointElevation { get; }
Visual Basic
Public Shared ReadOnly Property SsePointElevation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SsePointElevation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SsePointElevationBaseType Property

[image]

Revit 2024 API
ParameterTypeId..::..SsePointElevationBaseType Property
ParameterTypeId Class See Also Send Feedback
"Elevation Base Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SsePointElevationBaseType { get; }
Visual Basic
Public Shared ReadOnly Property SsePointElevationBaseType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SsePointElevationBaseType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SsePointOffsetFromSurface Property

[image]

Revit 2024 API
ParameterTypeId..::..SsePointOffsetFromSurface Property
ParameterTypeId Class See Also Send Feedback
"Offset from Surface"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SsePointOffsetFromSurface { get; }
Visual Basic
Public Shared ReadOnly Property SsePointOffsetFromSurface As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SsePointOffsetFromSurface {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsActualNumRisers Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsActualNumRisers Property
ParameterTypeId Class See Also Send Feedback
"Actual Number of Risers"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsActualNumRisers { get; }
Visual Basic
Public Shared ReadOnly Property StairsActualNumRisers As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsActualNumRisers {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsActualRiserHeight Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsActualRiserHeight Property
ParameterTypeId Class See Also Send Feedback
"Actual Riser Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsActualRiserHeight { get; }
Visual Basic
Public Shared ReadOnly Property StairsActualRiserHeight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsActualRiserHeight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsActualTreadDepth Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsActualTreadDepth Property
ParameterTypeId Class See Also Send Feedback
"Actual Tread Depth"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsActualTreadDepth { get; }
Visual Basic
Public Shared ReadOnly Property StairsActualTreadDepth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsActualTreadDepth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsAttrBodyMaterial Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsAttrBodyMaterial Property
ParameterTypeId Class See Also Send Feedback
"Monolithic Material"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsAttrBodyMaterial { get; }
Visual Basic
Public Shared ReadOnly Property StairsAttrBodyMaterial As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsAttrBodyMaterial {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsAttrBreakSymInCutline Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsAttrBreakSymInCutline Property
ParameterTypeId Class See Also Send Feedback
"Break Symbol in Plan"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsAttrBreakSymInCutline { get; }
Visual Basic
Public Shared ReadOnly Property StairsAttrBreakSymInCutline As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsAttrBreakSymInCutline {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsAttrCalcEnabled Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsAttrCalcEnabled Property
ParameterTypeId Class See Also Send Feedback
"Calculation Rules"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsAttrCalcEnabled { get; }
Visual Basic
Public Shared ReadOnly Property StairsAttrCalcEnabled As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsAttrCalcEnabled {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsAttrCalcMax Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsAttrCalcMax Property
ParameterTypeId Class See Also Send Feedback
"Calculation Rules"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsAttrCalcMax { get; }
Visual Basic
Public Shared ReadOnly Property StairsAttrCalcMax As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsAttrCalcMax {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsAttrCalcMin Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsAttrCalcMin Property
ParameterTypeId Class See Also Send Feedback
"Calculation Rules"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsAttrCalcMin { get; }
Visual Basic
Public Shared ReadOnly Property StairsAttrCalcMin As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsAttrCalcMin {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsAttrFirstRiser Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsAttrFirstRiser Property
ParameterTypeId Class See Also Send Feedback
"Begin with Riser"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsAttrFirstRiser { get; }
Visual Basic
Public Shared ReadOnly Property StairsAttrFirstRiser As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsAttrFirstRiser {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsAttrLandingCarriage Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsAttrLandingCarriage Property
ParameterTypeId Class See Also Send Feedback
"Landing Carriage Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsAttrLandingCarriage { get; }
Visual Basic
Public Shared ReadOnly Property StairsAttrLandingCarriage As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsAttrLandingCarriage {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsAttrLastRiser Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsAttrLastRiser Property
ParameterTypeId Class See Also Send Feedback
"End with Riser"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsAttrLastRiser { get; }
Visual Basic
Public Shared ReadOnly Property StairsAttrLastRiser As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsAttrLastRiser {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsAttrLeftSideStringer Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsAttrLeftSideStringer Property
ParameterTypeId Class See Also Send Feedback
"Left Stringer"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsAttrLeftSideStringer { get; }
Visual Basic
Public Shared ReadOnly Property StairsAttrLeftSideStringer As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsAttrLeftSideStringer {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsAttrMaxRiserHeight Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsAttrMaxRiserHeight Property
ParameterTypeId Class See Also Send Feedback
"Maximum Riser Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsAttrMaxRiserHeight { get; }
Visual Basic
Public Shared ReadOnly Property StairsAttrMaxRiserHeight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsAttrMaxRiserHeight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsAttrMinimumTreadDepth Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsAttrMinimumTreadDepth Property
ParameterTypeId Class See Also Send Feedback
"Minimum Tread Depth"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsAttrMinimumTreadDepth { get; }
Visual Basic
Public Shared ReadOnly Property StairsAttrMinimumTreadDepth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsAttrMinimumTreadDepth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsAttrMonolithicStairs Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsAttrMonolithicStairs Property
ParameterTypeId Class See Also Send Feedback
"Monolithic Stairs"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsAttrMonolithicStairs { get; }
Visual Basic
Public Shared ReadOnly Property StairsAttrMonolithicStairs As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsAttrMonolithicStairs {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsAttrNosingLength Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsAttrNosingLength Property
ParameterTypeId Class See Also Send Feedback
"Nosing Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsAttrNosingLength { get; }
Visual Basic
Public Shared ReadOnly Property StairsAttrNosingLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsAttrNosingLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsAttrNosingPlacement Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsAttrNosingPlacement Property
ParameterTypeId Class See Also Send Feedback
"Apply Nosing Profile"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsAttrNosingPlacement { get; }
Visual Basic
Public Shared ReadOnly Property StairsAttrNosingPlacement As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsAttrNosingPlacement {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsAttrNumMidStringers Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsAttrNumMidStringers Property
ParameterTypeId Class See Also Send Feedback
"Middle Stringers"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsAttrNumMidStringers { get; }
Visual Basic
Public Shared ReadOnly Property StairsAttrNumMidStringers As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsAttrNumMidStringers {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsAttrRightSideStringer Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsAttrRightSideStringer Property
ParameterTypeId Class See Also Send Feedback
"Right Stringer"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsAttrRightSideStringer { get; }
Visual Basic
Public Shared ReadOnly Property StairsAttrRightSideStringer As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsAttrRightSideStringer {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsAttrRiserMaterial Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsAttrRiserMaterial Property
ParameterTypeId Class See Also Send Feedback
"Riser Material"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsAttrRiserMaterial { get; }
Visual Basic
Public Shared ReadOnly Property StairsAttrRiserMaterial As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsAttrRiserMaterial {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsAttrRiserMult Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsAttrRiserMult Property
ParameterTypeId Class See Also Send Feedback
"Riser Multiplier"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsAttrRiserMult { get; }
Visual Basic
Public Shared ReadOnly Property StairsAttrRiserMult As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsAttrRiserMult {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsAttrRisersPresent Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsAttrRisersPresent Property
ParameterTypeId Class See Also Send Feedback
"Risers Present"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsAttrRisersPresent { get; }
Visual Basic
Public Shared ReadOnly Property StairsAttrRisersPresent As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsAttrRisersPresent {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsAttrRiserThickness Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsAttrRiserThickness Property
ParameterTypeId Class See Also Send Feedback
"Riser Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsAttrRiserThickness { get; }
Visual Basic
Public Shared ReadOnly Property StairsAttrRiserThickness As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsAttrRiserThickness {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsAttrRiserTreadConnect Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsAttrRiserTreadConnect Property
ParameterTypeId Class See Also Send Feedback
"Riser to Tread Connection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsAttrRiserTreadConnect { get; }
Visual Basic
Public Shared ReadOnly Property StairsAttrRiserTreadConnect As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsAttrRiserTreadConnect {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsAttrRiserType Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsAttrRiserType Property
ParameterTypeId Class See Also Send Feedback
"Riser Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsAttrRiserType { get; }
Visual Basic
Public Shared ReadOnly Property StairsAttrRiserType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsAttrRiserType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsAttrSideStringerTypeParam Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsAttrSideStringerTypeParam Property
ParameterTypeId Class See Also Send Feedback
"Type of Side Stringers"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsAttrSideStringerTypeParam { get; }
Visual Basic
Public Shared ReadOnly Property StairsAttrSideStringerTypeParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsAttrSideStringerTypeParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsAttrStairsBottom Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsAttrStairsBottom Property
ParameterTypeId Class See Also Send Feedback
"Underside of Winder"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsAttrStairsBottom { get; }
Visual Basic
Public Shared ReadOnly Property StairsAttrStairsBottom As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsAttrStairsBottom {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsAttrStringerCarriage Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsAttrStringerCarriage Property
ParameterTypeId Class See Also Send Feedback
"Stringer Carriage Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsAttrStringerCarriage { get; }
Visual Basic
Public Shared ReadOnly Property StairsAttrStringerCarriage As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsAttrStringerCarriage {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsAttrStringerHeight Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsAttrStringerHeight Property
ParameterTypeId Class See Also Send Feedback
"Stringer Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsAttrStringerHeight { get; }
Visual Basic
Public Shared ReadOnly Property StairsAttrStringerHeight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsAttrStringerHeight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsAttrStringerMaterial Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsAttrStringerMaterial Property
ParameterTypeId Class See Also Send Feedback
"Stringer Material"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsAttrStringerMaterial { get; }
Visual Basic
Public Shared ReadOnly Property StairsAttrStringerMaterial As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsAttrStringerMaterial {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsAttrStringerThickness Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsAttrStringerThickness Property
ParameterTypeId Class See Also Send Feedback
"Stringer Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsAttrStringerThickness { get; }
Visual Basic
Public Shared ReadOnly Property StairsAttrStringerThickness As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsAttrStringerThickness {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsAttrTextFont Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsAttrTextFont Property
ParameterTypeId Class See Also Send Feedback
"Text Font"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsAttrTextFont { get; }
Visual Basic
Public Shared ReadOnly Property StairsAttrTextFont As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsAttrTextFont {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsAttrTextSize Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsAttrTextSize Property
ParameterTypeId Class See Also Send Feedback
"Text Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsAttrTextSize { get; }
Visual Basic
Public Shared ReadOnly Property StairsAttrTextSize As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsAttrTextSize {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsAttrTreadFrontProfile Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsAttrTreadFrontProfile Property
ParameterTypeId Class See Also Send Feedback
"Nosing Profile"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsAttrTreadFrontProfile { get; }
Visual Basic
Public Shared ReadOnly Property StairsAttrTreadFrontProfile As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsAttrTreadFrontProfile {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsAttrTreadMaterial Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsAttrTreadMaterial Property
ParameterTypeId Class See Also Send Feedback
"Tread Material"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsAttrTreadMaterial { get; }
Visual Basic
Public Shared ReadOnly Property StairsAttrTreadMaterial As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsAttrTreadMaterial {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsAttrTreadMult Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsAttrTreadMult Property
ParameterTypeId Class See Also Send Feedback
"Tread Multiplier"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsAttrTreadMult { get; }
Visual Basic
Public Shared ReadOnly Property StairsAttrTreadMult As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsAttrTreadMult {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsAttrTreadThickness Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsAttrTreadThickness Property
ParameterTypeId Class See Also Send Feedback
"Tread Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsAttrTreadThickness { get; }
Visual Basic
Public Shared ReadOnly Property StairsAttrTreadThickness As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsAttrTreadThickness {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsAttrTreadWidth Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsAttrTreadWidth Property
ParameterTypeId Class See Also Send Feedback
"Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsAttrTreadWidth { get; }
Visual Basic
Public Shared ReadOnly Property StairsAttrTreadWidth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsAttrTreadWidth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsAttrTrimTop Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsAttrTrimTop Property
ParameterTypeId Class See Also Send Feedback
"Trim Stringers at Top"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsAttrTrimTop { get; }
Visual Basic
Public Shared ReadOnly Property StairsAttrTrimTop As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsAttrTrimTop {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsBaseLevel Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsBaseLevel Property
ParameterTypeId Class See Also Send Feedback
"Base Level": The base level of stairs

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsBaseLevel { get; }
Visual Basic
Public Shared ReadOnly Property StairsBaseLevel As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsBaseLevel {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsBaseLevelParam Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsBaseLevelParam Property
ParameterTypeId Class See Also Send Feedback
"Base Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsBaseLevelParam { get; }
Visual Basic
Public Shared ReadOnly Property StairsBaseLevelParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsBaseLevelParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsBaseOffset Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsBaseOffset Property
ParameterTypeId Class See Also Send Feedback
"Base Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsBaseOffset { get; }
Visual Basic
Public Shared ReadOnly Property StairsBaseOffset As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsBaseOffset {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsCurveType Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsCurveType Property
ParameterTypeId Class See Also Send Feedback
"Stairs Line Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsCurveType { get; }
Visual Basic
Public Shared ReadOnly Property StairsCurveType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsCurveType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsDbgShowAnnotationCutMark Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsDbgShowAnnotationCutMark Property
ParameterTypeId Class See Also Send Feedback
"Cut by Cut Plane"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsDbgShowAnnotationCutMark { get; }
Visual Basic
Public Shared ReadOnly Property StairsDbgShowAnnotationCutMark As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsDbgShowAnnotationCutMark {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsDbgShowBoundary2d Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsDbgShowBoundary2d Property
ParameterTypeId Class See Also Send Feedback
"Show Stairs' Boundary 2D"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsDbgShowBoundary2d { get; }
Visual Basic
Public Shared ReadOnly Property StairsDbgShowBoundary2d As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsDbgShowBoundary2d {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsDbgShowLandingFaces Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsDbgShowLandingFaces Property
ParameterTypeId Class See Also Send Feedback
"Show Landing Faces"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsDbgShowLandingFaces { get; }
Visual Basic
Public Shared ReadOnly Property StairsDbgShowLandingFaces As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsDbgShowLandingFaces {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsDbgShowLandingPath Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsDbgShowLandingPath Property
ParameterTypeId Class See Also Send Feedback
"Show Landing Path"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsDbgShowLandingPath { get; }
Visual Basic
Public Shared ReadOnly Property StairsDbgShowLandingPath As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsDbgShowLandingPath {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsDbgShowLeftRunBoundary3d Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsDbgShowLeftRunBoundary3d Property
ParameterTypeId Class See Also Send Feedback
"Show Run's Left Boundary 3D"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsDbgShowLeftRunBoundary3d { get; }
Visual Basic
Public Shared ReadOnly Property StairsDbgShowLeftRunBoundary3d As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsDbgShowLeftRunBoundary3d {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsDbgShowMonolithicSupportGeom Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsDbgShowMonolithicSupportGeom Property
ParameterTypeId Class See Also Send Feedback
"Show Monolithic Support Geometry"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsDbgShowMonolithicSupportGeom { get; }
Visual Basic
Public Shared ReadOnly Property StairsDbgShowMonolithicSupportGeom As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsDbgShowMonolithicSupportGeom {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsDbgShowRightRunBoundary3d Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsDbgShowRightRunBoundary3d Property
ParameterTypeId Class See Also Send Feedback
"Show Run's Right Boundary 3D"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsDbgShowRightRunBoundary3d { get; }
Visual Basic
Public Shared ReadOnly Property StairsDbgShowRightRunBoundary3d As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsDbgShowRightRunBoundary3d {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsDbgShowRunCorseGeom Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsDbgShowRunCorseGeom Property
ParameterTypeId Class See Also Send Feedback
"Show Run Corse Geometry"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsDbgShowRunCorseGeom { get; }
Visual Basic
Public Shared ReadOnly Property StairsDbgShowRunCorseGeom As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsDbgShowRunCorseGeom {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsDbgShowRunGeom Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsDbgShowRunGeom Property
ParameterTypeId Class See Also Send Feedback
"Show Run Geometry"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsDbgShowRunGeom { get; }
Visual Basic
Public Shared ReadOnly Property StairsDbgShowRunGeom As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsDbgShowRunGeom {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsDbgShowRunNosing Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsDbgShowRunNosing Property
ParameterTypeId Class See Also Send Feedback
"Show Run's Nosings"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsDbgShowRunNosing { get; }
Visual Basic
Public Shared ReadOnly Property StairsDbgShowRunNosing As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsDbgShowRunNosing {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsDbgShowRunOutlineForPlan Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsDbgShowRunOutlineForPlan Property
ParameterTypeId Class See Also Send Feedback
"Show Run Outline For Plan"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsDbgShowRunOutlineForPlan { get; }
Visual Basic
Public Shared ReadOnly Property StairsDbgShowRunOutlineForPlan As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsDbgShowRunOutlineForPlan {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsDbgShowRunPath2d Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsDbgShowRunPath2d Property
ParameterTypeId Class See Also Send Feedback
"Show Run's Path 2D"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsDbgShowRunPath2d { get; }
Visual Basic
Public Shared ReadOnly Property StairsDbgShowRunPath2d As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsDbgShowRunPath2d {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsDbgShowRunPath3d Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsDbgShowRunPath3d Property
ParameterTypeId Class See Also Send Feedback
"Show Run's Path 3D"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsDbgShowRunPath3d { get; }
Visual Basic
Public Shared ReadOnly Property StairsDbgShowRunPath3d As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsDbgShowRunPath3d {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsDbgShowRunRiser Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsDbgShowRunRiser Property
ParameterTypeId Class See Also Send Feedback
"Show Run's Risers"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsDbgShowRunRiser { get; }
Visual Basic
Public Shared ReadOnly Property StairsDbgShowRunRiser As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsDbgShowRunRiser {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsDbgShowTreadFaces Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsDbgShowTreadFaces Property
ParameterTypeId Class See Also Send Feedback
"Show Run's Tread Faces"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsDbgShowTreadFaces { get; }
Visual Basic
Public Shared ReadOnly Property StairsDbgShowTreadFaces As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsDbgShowTreadFaces {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsDesiredNumRisers Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsDesiredNumRisers Property
ParameterTypeId Class See Also Send Feedback
"Desired Number of Risers"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsDesiredNumRisers { get; }
Visual Basic
Public Shared ReadOnly Property StairsDesiredNumRisers As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsDesiredNumRisers {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsEnableCalculationRuleChecking Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsEnableCalculationRuleChecking Property
ParameterTypeId Class See Also Send Feedback
"Enable Calculator Rules Check": Enable calculation rule checking

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsEnableCalculationRuleChecking { get; }
Visual Basic
Public Shared ReadOnly Property StairsEnableCalculationRuleChecking As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsEnableCalculationRuleChecking {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsInstAlwaysUp Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsInstAlwaysUp Property
ParameterTypeId Class See Also Send Feedback
"Show Up arrow in all views"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsInstAlwaysUp { get; }
Visual Basic
Public Shared ReadOnly Property StairsInstAlwaysUp As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsInstAlwaysUp {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsInstDownArrowOn Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsInstDownArrowOn Property
ParameterTypeId Class See Also Send Feedback
"Down arrow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsInstDownArrowOn { get; }
Visual Basic
Public Shared ReadOnly Property StairsInstDownArrowOn As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsInstDownArrowOn {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsInstUpArrowOn Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsInstUpArrowOn Property
ParameterTypeId Class See Also Send Feedback
"Up arrow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsInstUpArrowOn { get; }
Visual Basic
Public Shared ReadOnly Property StairsInstUpArrowOn As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsInstUpArrowOn {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsInstUpLabelOn Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsInstUpLabelOn Property
ParameterTypeId Class See Also Send Feedback
"Up label"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsInstUpLabelOn { get; }
Visual Basic
Public Shared ReadOnly Property StairsInstUpLabelOn As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsInstUpLabelOn {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsLandingBaseElevation Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsLandingBaseElevation Property
ParameterTypeId Class See Also Send Feedback
"Relative Height": Height

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsLandingBaseElevation { get; }
Visual Basic
Public Shared ReadOnly Property StairsLandingBaseElevation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsLandingBaseElevation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsLandingOverridden Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsLandingOverridden Property
ParameterTypeId Class See Also Send Feedback
"Overridden": Overridden

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsLandingOverridden { get; }
Visual Basic
Public Shared ReadOnly Property StairsLandingOverridden As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsLandingOverridden {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsLandingStructural Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsLandingStructural Property
ParameterTypeId Class See Also Send Feedback
"Structural": Structural

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsLandingStructural { get; }
Visual Basic
Public Shared ReadOnly Property StairsLandingStructural As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsLandingStructural {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsLandingThickness Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsLandingThickness Property
ParameterTypeId Class See Also Send Feedback
"Total Thickness": Thickness

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsLandingThickness { get; }
Visual Basic
Public Shared ReadOnly Property StairsLandingThickness As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsLandingThickness {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsLandingtypeHasMonolithicSupport Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsLandingtypeHasMonolithicSupport Property
ParameterTypeId Class See Also Send Feedback
"Monolithic Support": Monolithic Support

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsLandingtypeHasMonolithicSupport { get; }
Visual Basic
Public Shared ReadOnly Property StairsLandingtypeHasMonolithicSupport As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsLandingtypeHasMonolithicSupport {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsLandingtypeStructure Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsLandingtypeStructure Property
ParameterTypeId Class See Also Send Feedback
"Structure": Structure

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsLandingtypeStructure { get; }
Visual Basic
Public Shared ReadOnly Property StairsLandingtypeStructure As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsLandingtypeStructure {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsLandingtypeThickness Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsLandingtypeThickness Property
ParameterTypeId Class See Also Send Feedback
"Monolithic Thickness": Default thickness

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsLandingtypeThickness { get; }
Visual Basic
Public Shared ReadOnly Property StairsLandingtypeThickness As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsLandingtypeThickness {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsLandingtypeTreadriserType Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsLandingtypeTreadriserType Property
ParameterTypeId Class See Also Send Feedback
"Type": Tread/Riser Type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsLandingtypeTreadriserType { get; }
Visual Basic
Public Shared ReadOnly Property StairsLandingtypeTreadriserType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsLandingtypeTreadriserType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsLandingtypeUseSameTriserAsRun Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsLandingtypeUseSameTriserAsRun Property
ParameterTypeId Class See Also Send Feedback
"Same as Run": Same as Run

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsLandingtypeUseSameTriserAsRun { get; }
Visual Basic
Public Shared ReadOnly Property StairsLandingtypeUseSameTriserAsRun As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsLandingtypeUseSameTriserAsRun {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsMinAutomaticLandingDepth Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsMinAutomaticLandingDepth Property
ParameterTypeId Class See Also Send Feedback
"Minimum Automatic Landing Depth": The minimum depth of automatic landing

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsMinAutomaticLandingDepth { get; }
Visual Basic
Public Shared ReadOnly Property StairsMinAutomaticLandingDepth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsMinAutomaticLandingDepth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsMultistoryTopLevelParam Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsMultistoryTopLevelParam Property
ParameterTypeId Class See Also Send Feedback
"Multistory Top Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsMultistoryTopLevelParam { get; }
Visual Basic
Public Shared ReadOnly Property StairsMultistoryTopLevelParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsMultistoryTopLevelParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsMultistoryUpToLevel Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsMultistoryUpToLevel Property
ParameterTypeId Class See Also Send Feedback
"Multistory Top Level": The top level of multi-story stairs

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsMultistoryUpToLevel { get; }
Visual Basic
Public Shared ReadOnly Property StairsMultistoryUpToLevel As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsMultistoryUpToLevel {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsPathStartFromRiser Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsPathStartFromRiser Property
ParameterTypeId Class See Also Send Feedback
"Start from Riser"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsPathStartFromRiser { get; }
Visual Basic
Public Shared ReadOnly Property StairsPathStartFromRiser As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsPathStartFromRiser {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsRailingAngledConnection Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsRailingAngledConnection Property
ParameterTypeId Class See Also Send Feedback
"Angled Joins"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsRailingAngledConnection { get; }
Visual Basic
Public Shared ReadOnly Property StairsRailingAngledConnection As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsRailingAngledConnection {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsRailingBalusterBottomAngle Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsRailingBalusterBottomAngle Property
ParameterTypeId Class See Also Send Feedback
"Bottom Cut Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsRailingBalusterBottomAngle { get; }
Visual Basic
Public Shared ReadOnly Property StairsRailingBalusterBottomAngle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsRailingBalusterBottomAngle {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsRailingBalusterFamily Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsRailingBalusterFamily Property
ParameterTypeId Class See Also Send Feedback
"Baluster Family"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsRailingBalusterFamily { get; }
Visual Basic
Public Shared ReadOnly Property StairsRailingBalusterFamily As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsRailingBalusterFamily {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsRailingBalusterHeight Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsRailingBalusterHeight Property
ParameterTypeId Class See Also Send Feedback
"Baluster Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsRailingBalusterHeight { get; }
Visual Basic
Public Shared ReadOnly Property StairsRailingBalusterHeight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsRailingBalusterHeight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsRailingBalusterIsPost Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsRailingBalusterIsPost Property
ParameterTypeId Class See Also Send Feedback
"Post"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsRailingBalusterIsPost { get; }
Visual Basic
Public Shared ReadOnly Property StairsRailingBalusterIsPost As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsRailingBalusterIsPost {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsRailingBalusterLength Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsRailingBalusterLength Property
ParameterTypeId Class See Also Send Feedback
"Baluster Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsRailingBalusterLength { get; }
Visual Basic
Public Shared ReadOnly Property StairsRailingBalusterLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsRailingBalusterLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsRailingBalusterOffset Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsRailingBalusterOffset Property
ParameterTypeId Class See Also Send Feedback
"Baluster Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsRailingBalusterOffset { get; }
Visual Basic
Public Shared ReadOnly Property StairsRailingBalusterOffset As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsRailingBalusterOffset {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsRailingBalusterPlacement Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsRailingBalusterPlacement Property
ParameterTypeId Class See Also Send Feedback
"Baluster Placement"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsRailingBalusterPlacement { get; }
Visual Basic
Public Shared ReadOnly Property StairsRailingBalusterPlacement As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsRailingBalusterPlacement {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsRailingBalusterShape Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsRailingBalusterShape Property
ParameterTypeId Class See Also Send Feedback
"Baluster Shape"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsRailingBalusterShape { get; }
Visual Basic
Public Shared ReadOnly Property StairsRailingBalusterShape As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsRailingBalusterShape {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsRailingBalusterSlopeAngle Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsRailingBalusterSlopeAngle Property
ParameterTypeId Class See Also Send Feedback
"Slope Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsRailingBalusterSlopeAngle { get; }
Visual Basic
Public Shared ReadOnly Property StairsRailingBalusterSlopeAngle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsRailingBalusterSlopeAngle {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsRailingBalusterSpacingType Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsRailingBalusterSpacingType Property
ParameterTypeId Class See Also Send Feedback
"Baluster Spacing Type (Stair Railing Only)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsRailingBalusterSpacingType { get; }
Visual Basic
Public Shared ReadOnly Property StairsRailingBalusterSpacingType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsRailingBalusterSpacingType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsRailingBalustersPerTread Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsRailingBalustersPerTread Property
ParameterTypeId Class See Also Send Feedback
"Balusters Per Tread (Stair Railing Only)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsRailingBalustersPerTread { get; }
Visual Basic
Public Shared ReadOnly Property StairsRailingBalustersPerTread As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsRailingBalustersPerTread {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsRailingBalusterTopAngle Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsRailingBalusterTopAngle Property
ParameterTypeId Class See Also Send Feedback
"Top Cut Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsRailingBalusterTopAngle { get; }
Visual Basic
Public Shared ReadOnly Property StairsRailingBalusterTopAngle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsRailingBalusterTopAngle {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsRailingBalusterWidth Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsRailingBalusterWidth Property
ParameterTypeId Class See Also Send Feedback
"Baluster Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsRailingBalusterWidth { get; }
Visual Basic
Public Shared ReadOnly Property StairsRailingBalusterWidth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsRailingBalusterWidth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsRailingBaseLevelParam Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsRailingBaseLevelParam Property
ParameterTypeId Class See Also Send Feedback
"Base Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsRailingBaseLevelParam { get; }
Visual Basic
Public Shared ReadOnly Property StairsRailingBaseLevelParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsRailingBaseLevelParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsRailingConnection Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsRailingConnection Property
ParameterTypeId Class See Also Send Feedback
"Rail Connections"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsRailingConnection { get; }
Visual Basic
Public Shared ReadOnly Property StairsRailingConnection As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsRailingConnection {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsRailingHeight Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsRailingHeight Property
ParameterTypeId Class See Also Send Feedback
"Railing Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsRailingHeight { get; }
Visual Basic
Public Shared ReadOnly Property StairsRailingHeight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsRailingHeight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsRailingHeightShiftType Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsRailingHeightShiftType Property
ParameterTypeId Class See Also Send Feedback
"Use Landing Height Adjustment"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsRailingHeightShiftType { get; }
Visual Basic
Public Shared ReadOnly Property StairsRailingHeightShiftType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsRailingHeightShiftType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsRailingHeightShiftVal Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsRailingHeightShiftVal Property
ParameterTypeId Class See Also Send Feedback
"Landing Height Adjustment"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsRailingHeightShiftVal { get; }
Visual Basic
Public Shared ReadOnly Property StairsRailingHeightShiftVal As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsRailingHeightShiftVal {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsRailingPlacementOffset Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsRailingPlacementOffset Property
ParameterTypeId Class See Also Send Feedback
"Offset from Path"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsRailingPlacementOffset { get; }
Visual Basic
Public Shared ReadOnly Property StairsRailingPlacementOffset As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsRailingPlacementOffset {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsRailingRailHeight Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsRailingRailHeight Property
ParameterTypeId Class See Also Send Feedback
"Rail Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsRailingRailHeight { get; }
Visual Basic
Public Shared ReadOnly Property StairsRailingRailHeight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsRailingRailHeight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsRailingRailName Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsRailingRailName Property
ParameterTypeId Class See Also Send Feedback
"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsRailingRailName { get; }
Visual Basic
Public Shared ReadOnly Property StairsRailingRailName As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsRailingRailName {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsRailingRailStructure Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsRailingRailStructure Property
ParameterTypeId Class See Also Send Feedback
"Rail Structure (Non-Continuous)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsRailingRailStructure { get; }
Visual Basic
Public Shared ReadOnly Property StairsRailingRailStructure As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsRailingRailStructure {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsRailingWidth Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsRailingWidth Property
ParameterTypeId Class See Also Send Feedback
"Railing Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsRailingWidth { get; }
Visual Basic
Public Shared ReadOnly Property StairsRailingWidth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsRailingWidth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsRunActualNumberOfRisers Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsRunActualNumberOfRisers Property
ParameterTypeId Class See Also Send Feedback
"Actual Number of Risers": Actual Number of Risers

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsRunActualNumberOfRisers { get; }
Visual Basic
Public Shared ReadOnly Property StairsRunActualNumberOfRisers As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsRunActualNumberOfRisers {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsRunActualNumberOfTreads Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsRunActualNumberOfTreads Property
ParameterTypeId Class See Also Send Feedback
"Actual Number of Treads": Actual Number of Treads

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsRunActualNumberOfTreads { get; }
Visual Basic
Public Shared ReadOnly Property StairsRunActualNumberOfTreads As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsRunActualNumberOfTreads {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsRunActualRiserHeight Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsRunActualRiserHeight Property
ParameterTypeId Class See Also Send Feedback
"Actual Riser Height": Actual Riser Height

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsRunActualRiserHeight { get; }
Visual Basic
Public Shared ReadOnly Property StairsRunActualRiserHeight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsRunActualRiserHeight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsRunActualRunWidth Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsRunActualRunWidth Property
ParameterTypeId Class See Also Send Feedback
"Actual Run Width": Actual Run Width

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsRunActualRunWidth { get; }
Visual Basic
Public Shared ReadOnly Property StairsRunActualRunWidth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsRunActualRunWidth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsRunBottomElevation Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsRunBottomElevation Property
ParameterTypeId Class See Also Send Feedback
"Relative Base Height": Relative height to stairs bottom elevation

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsRunBottomElevation { get; }
Visual Basic
Public Shared ReadOnly Property StairsRunBottomElevation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsRunBottomElevation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsRunCcw Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsRunCcw Property
ParameterTypeId Class See Also Send Feedback
"CCW": Revert the run preview

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsRunCcw { get; }
Visual Basic
Public Shared ReadOnly Property StairsRunCcw As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsRunCcw {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsRunEndWithRiser Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsRunEndWithRiser Property
ParameterTypeId Class See Also Send Feedback
"End with Riser": End with Riser

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsRunEndWithRiser { get; }
Visual Basic
Public Shared ReadOnly Property StairsRunEndWithRiser As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsRunEndWithRiser {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsRunExtendBelowRiserBase Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsRunExtendBelowRiserBase Property
ParameterTypeId Class See Also Send Feedback
"Extend Below Riser Base": Extend Below Base

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsRunExtendBelowRiserBase { get; }
Visual Basic
Public Shared ReadOnly Property StairsRunExtendBelowRiserBase As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsRunExtendBelowRiserBase {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsRunExtendBelowTreadBase Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsRunExtendBelowTreadBase Property
ParameterTypeId Class See Also Send Feedback
"Extend Below Tread Base": Extend Below Tread Base

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsRunExtendBelowTreadBase { get; }
Visual Basic
Public Shared ReadOnly Property StairsRunExtendBelowTreadBase As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsRunExtendBelowTreadBase {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsRunLocationpathJustfication Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsRunLocationpathJustfication Property
ParameterTypeId Class See Also Send Feedback
"Location Line": Location Line

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsRunLocationpathJustfication { get; }
Visual Basic
Public Shared ReadOnly Property StairsRunLocationpathJustfication As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsRunLocationpathJustfication {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsRunStructural Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsRunStructural Property
ParameterTypeId Class See Also Send Feedback
"Structural": Structural

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsRunStructural { get; }
Visual Basic
Public Shared ReadOnly Property StairsRunStructural As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsRunStructural {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsRunTopElevation Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsRunTopElevation Property
ParameterTypeId Class See Also Send Feedback
"Relative Top Height": Top height of run

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsRunTopElevation { get; }
Visual Basic
Public Shared ReadOnly Property StairsRunTopElevation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsRunTopElevation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsRuntypeStructuralDepth Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsRuntypeStructuralDepth Property
ParameterTypeId Class See Also Send Feedback
"Structural Depth": Structural Depth

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsRuntypeStructuralDepth { get; }
Visual Basic
Public Shared ReadOnly Property StairsRuntypeStructuralDepth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsRuntypeStructuralDepth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsRuntypeStructure Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsRuntypeStructure Property
ParameterTypeId Class See Also Send Feedback
"Structure": Structure

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsRuntypeStructure { get; }
Visual Basic
Public Shared ReadOnly Property StairsRuntypeStructure As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsRuntypeStructure {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsRuntypeUndersideSurfaceType Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsRuntypeUndersideSurfaceType Property
ParameterTypeId Class See Also Send Feedback
"Underside Surface": Underside Surface

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsRuntypeUndersideSurfaceType { get; }
Visual Basic
Public Shared ReadOnly Property StairsRuntypeUndersideSurfaceType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsRuntypeUndersideSurfaceType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsRunWinderBeginWithStraight Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsRunWinderBeginWithStraight Property
ParameterTypeId Class See Also Send Feedback
"Begin with Straight Run": Winder begin with straight run

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsRunWinderBeginWithStraight { get; }
Visual Basic
Public Shared ReadOnly Property StairsRunWinderBeginWithStraight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsRunWinderBeginWithStraight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsShowDownText Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsShowDownText Property
ParameterTypeId Class See Also Send Feedback
"Show Down Text"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsShowDownText { get; }
Visual Basic
Public Shared ReadOnly Property StairsShowDownText As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsShowDownText {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsStairsHeight Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsStairsHeight Property
ParameterTypeId Class See Also Send Feedback
"Desired Stair Height": Stairs unconnected height

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsStairsHeight { get; }
Visual Basic
Public Shared ReadOnly Property StairsStairsHeight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsStairsHeight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsStringersPresent Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsStringersPresent Property
ParameterTypeId Class See Also Send Feedback
"Stringer Position"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsStringersPresent { get; }
Visual Basic
Public Shared ReadOnly Property StairsStringersPresent As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsStringersPresent {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsSupportHorizontalOffset Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsSupportHorizontalOffset Property
ParameterTypeId Class See Also Send Feedback
"Lateral Offset": Distance from center or edge of boundary

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsSupportHorizontalOffset { get; }
Visual Basic
Public Shared ReadOnly Property StairsSupportHorizontalOffset As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsSupportHorizontalOffset {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsSupportLandingsupportType Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsSupportLandingsupportType Property
ParameterTypeId Class See Also Send Feedback
"Landing Support Type": Landing Support Type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsSupportLandingsupportType { get; }
Visual Basic
Public Shared ReadOnly Property StairsSupportLandingsupportType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsSupportLandingsupportType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsSupportLowerEndCut Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsSupportLowerEndCut Property
ParameterTypeId Class See Also Send Feedback
"Lower End Cut": Lower End Cut

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsSupportLowerEndCut { get; }
Visual Basic
Public Shared ReadOnly Property StairsSupportLowerEndCut As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsSupportLowerEndCut {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsSupportTrimSupportUpper Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsSupportTrimSupportUpper Property
ParameterTypeId Class See Also Send Feedback
"Trim Support at Upper": Trim Support at Upper

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsSupportTrimSupportUpper { get; }
Visual Basic
Public Shared ReadOnly Property StairsSupportTrimSupportUpper As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsSupportTrimSupportUpper {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsSupporttypeFlipSectionProfile Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsSupporttypeFlipSectionProfile Property
ParameterTypeId Class See Also Send Feedback
"Flip Section Profile": Flip Section Profile

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsSupporttypeFlipSectionProfile { get; }
Visual Basic
Public Shared ReadOnly Property StairsSupporttypeFlipSectionProfile As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsSupporttypeFlipSectionProfile {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsSupporttypeMaterial Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsSupporttypeMaterial Property
ParameterTypeId Class See Also Send Feedback
"Material": Material

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsSupporttypeMaterial { get; }
Visual Basic
Public Shared ReadOnly Property StairsSupporttypeMaterial As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsSupporttypeMaterial {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsSupporttypeSectionProfile Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsSupporttypeSectionProfile Property
ParameterTypeId Class See Also Send Feedback
"Section Profile": Section Profile

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsSupporttypeSectionProfile { get; }
Visual Basic
Public Shared ReadOnly Property StairsSupporttypeSectionProfile As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsSupporttypeSectionProfile {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsSupporttypeStructuralDepth Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsSupporttypeStructuralDepth Property
ParameterTypeId Class See Also Send Feedback
"Structural Depth": Structural Depth

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsSupporttypeStructuralDepth { get; }
Visual Basic
Public Shared ReadOnly Property StairsSupporttypeStructuralDepth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsSupporttypeStructuralDepth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsSupporttypeStructuralDepthOnLanding Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsSupporttypeStructuralDepthOnLanding Property
ParameterTypeId Class See Also Send Feedback
"Structural Depth On Landing": Structural Depth

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsSupporttypeStructuralDepthOnLanding { get; }
Visual Basic
Public Shared ReadOnly Property StairsSupporttypeStructuralDepthOnLanding As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsSupporttypeStructuralDepthOnLanding {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsSupporttypeStructuralDepthOnRun Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsSupporttypeStructuralDepthOnRun Property
ParameterTypeId Class See Also Send Feedback
"Structural Depth On Run": Structural Depth

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsSupporttypeStructuralDepthOnRun { get; }
Visual Basic
Public Shared ReadOnly Property StairsSupporttypeStructuralDepthOnRun As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsSupporttypeStructuralDepthOnRun {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsSupporttypeTopsideSurface Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsSupporttypeTopsideSurface Property
ParameterTypeId Class See Also Send Feedback
"Topside Surface": Topside Surface

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsSupporttypeTopsideSurface { get; }
Visual Basic
Public Shared ReadOnly Property StairsSupporttypeTopsideSurface As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsSupporttypeTopsideSurface {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsSupporttypeTotalDepth Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsSupporttypeTotalDepth Property
ParameterTypeId Class See Also Send Feedback
"Total Depth": Total Depth

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsSupporttypeTotalDepth { get; }
Visual Basic
Public Shared ReadOnly Property StairsSupporttypeTotalDepth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsSupporttypeTotalDepth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsSupporttypeUndersideSurface Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsSupporttypeUndersideSurface Property
ParameterTypeId Class See Also Send Feedback
"Underside Surface": Underside Surface

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsSupporttypeUndersideSurface { get; }
Visual Basic
Public Shared ReadOnly Property StairsSupporttypeUndersideSurface As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsSupporttypeUndersideSurface {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsSupporttypeWidth Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsSupporttypeWidth Property
ParameterTypeId Class See Also Send Feedback
"Width": Width

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsSupporttypeWidth { get; }
Visual Basic
Public Shared ReadOnly Property StairsSupporttypeWidth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsSupporttypeWidth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsSupportUpperEndCut Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsSupportUpperEndCut Property
ParameterTypeId Class See Also Send Feedback
"Upper End Cut": Upper End Cut

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsSupportUpperEndCut { get; }
Visual Basic
Public Shared ReadOnly Property StairsSupportUpperEndCut As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsSupportUpperEndCut {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsSupportVerticalOffset Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsSupportVerticalOffset Property
ParameterTypeId Class See Also Send Feedback
"Vertical Offset": Distance of top plane of edge stringer relative to the plane connecting tread nosing

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsSupportVerticalOffset { get; }
Visual Basic
Public Shared ReadOnly Property StairsSupportVerticalOffset As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsSupportVerticalOffset {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsTextOrientation Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsTextOrientation Property
ParameterTypeId Class See Also Send Feedback
"Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsTextOrientation { get; }
Visual Basic
Public Shared ReadOnly Property StairsTextOrientation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsTextOrientation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsTextType Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsTextType Property
ParameterTypeId Class See Also Send Feedback
"Text Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsTextType { get; }
Visual Basic
Public Shared ReadOnly Property StairsTextType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsTextType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsTopLevel Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsTopLevel Property
ParameterTypeId Class See Also Send Feedback
"Top Level": The top level of stairs

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsTopLevel { get; }
Visual Basic
Public Shared ReadOnly Property StairsTopLevel As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsTopLevel {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsTopLevelParam Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsTopLevelParam Property
ParameterTypeId Class See Also Send Feedback
"Top Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsTopLevelParam { get; }
Visual Basic
Public Shared ReadOnly Property StairsTopLevelParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsTopLevelParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsTopOffset Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsTopOffset Property
ParameterTypeId Class See Also Send Feedback
"Top Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsTopOffset { get; }
Visual Basic
Public Shared ReadOnly Property StairsTopOffset As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsTopOffset {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsTotalNumberOfRisers Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsTotalNumberOfRisers Property
ParameterTypeId Class See Also Send Feedback
"Total Number of Risers": Total number of risers

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsTotalNumberOfRisers { get; }
Visual Basic
Public Shared ReadOnly Property StairsTotalNumberOfRisers As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsTotalNumberOfRisers {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsTriserIsTypeOverridden Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsTriserIsTypeOverridden Property
ParameterTypeId Class See Also Send Feedback
"Overridden": (OBSOLETE) Indicate whether selected individual step is governed by default type setting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsTriserIsTypeOverridden { get; }
Visual Basic
Public Shared ReadOnly Property StairsTriserIsTypeOverridden As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsTriserIsTypeOverridden {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsTriserNumberBaseIndex Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsTriserNumberBaseIndex Property
ParameterTypeId Class See Also Send Feedback
"Tread/Riser Start Number":

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsTriserNumberBaseIndex { get; }
Visual Basic
Public Shared ReadOnly Property StairsTriserNumberBaseIndex As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsTriserNumberBaseIndex {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsTriserRiserMark Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsTriserRiserMark Property
ParameterTypeId Class See Also Send Feedback
"Riser Mark": (OBSOLETE)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsTriserRiserMark { get; }
Visual Basic
Public Shared ReadOnly Property StairsTriserRiserMark As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsTriserRiserMark {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsTriserTreadMark Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsTriserTreadMark Property
ParameterTypeId Class See Also Send Feedback
"Tread Mark": (OBSOLETE)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsTriserTreadMark { get; }
Visual Basic
Public Shared ReadOnly Property StairsTriserTreadMark As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsTriserTreadMark {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsTriserTreadNumber Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsTriserTreadNumber Property
ParameterTypeId Class See Also Send Feedback
"Tread Number": Count the sequential number of tread in the stair.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsTriserTreadNumber { get; }
Visual Basic
Public Shared ReadOnly Property StairsTriserTreadNumber As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsTriserTreadNumber {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsTrisertypeBackNosing Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsTrisertypeBackNosing Property
ParameterTypeId Class See Also Send Feedback
"Back Nosing": (OBSOLETE)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsTrisertypeBackNosing { get; }
Visual Basic
Public Shared ReadOnly Property StairsTrisertypeBackNosing As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsTrisertypeBackNosing {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsTrisertypeFrontNosing Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsTrisertypeFrontNosing Property
ParameterTypeId Class See Also Send Feedback
"Front Nosing": (OBSOLETE)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsTrisertypeFrontNosing { get; }
Visual Basic
Public Shared ReadOnly Property StairsTrisertypeFrontNosing As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsTrisertypeFrontNosing {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsTrisertypeLeftNosing Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsTrisertypeLeftNosing Property
ParameterTypeId Class See Also Send Feedback
"Left Nosing": (OBSOLETE)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsTrisertypeLeftNosing { get; }
Visual Basic
Public Shared ReadOnly Property StairsTrisertypeLeftNosing As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsTrisertypeLeftNosing {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsTrisertypeNosingLength Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsTrisertypeNosingLength Property
ParameterTypeId Class See Also Send Feedback
"Nosing Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsTrisertypeNosingLength { get; }
Visual Basic
Public Shared ReadOnly Property StairsTrisertypeNosingLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsTrisertypeNosingLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsTrisertypeNosingPlacement Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsTrisertypeNosingPlacement Property
ParameterTypeId Class See Also Send Feedback
"Apply Nosing Profile"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsTrisertypeNosingPlacement { get; }
Visual Basic
Public Shared ReadOnly Property StairsTrisertypeNosingPlacement As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsTrisertypeNosingPlacement {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsTrisertypeNosingProfile Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsTrisertypeNosingProfile Property
ParameterTypeId Class See Also Send Feedback
"Nosing Profile"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsTrisertypeNosingProfile { get; }
Visual Basic
Public Shared ReadOnly Property StairsTrisertypeNosingProfile As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsTrisertypeNosingProfile {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsTrisertypeRiser Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsTrisertypeRiser Property
ParameterTypeId Class See Also Send Feedback
"Riser"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsTrisertypeRiser { get; }
Visual Basic
Public Shared ReadOnly Property StairsTrisertypeRiser As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsTrisertypeRiser {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsTrisertypeRiserIsSlanted Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsTrisertypeRiserIsSlanted Property
ParameterTypeId Class See Also Send Feedback
"Slanted"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsTrisertypeRiserIsSlanted { get; }
Visual Basic
Public Shared ReadOnly Property StairsTrisertypeRiserIsSlanted As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsTrisertypeRiserIsSlanted {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsTrisertypeRiserProfile Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsTrisertypeRiserProfile Property
ParameterTypeId Class See Also Send Feedback
"Riser Profile"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsTrisertypeRiserProfile { get; }
Visual Basic
Public Shared ReadOnly Property StairsTrisertypeRiserProfile As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsTrisertypeRiserProfile {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsTrisertypeRiserThickness Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsTrisertypeRiserThickness Property
ParameterTypeId Class See Also Send Feedback
"Riser Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsTrisertypeRiserThickness { get; }
Visual Basic
Public Shared ReadOnly Property StairsTrisertypeRiserThickness As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsTrisertypeRiserThickness {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsTrisertypeRiserTreadConnection Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsTrisertypeRiserTreadConnection Property
ParameterTypeId Class See Also Send Feedback
"Riser To Tread Connection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsTrisertypeRiserTreadConnection { get; }
Visual Basic
Public Shared ReadOnly Property StairsTrisertypeRiserTreadConnection As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsTrisertypeRiserTreadConnection {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsTrisertypeTread Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsTrisertypeTread Property
ParameterTypeId Class See Also Send Feedback
"Tread"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsTrisertypeTread { get; }
Visual Basic
Public Shared ReadOnly Property StairsTrisertypeTread As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsTrisertypeTread {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsTrisertypeTreadMaterial Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsTrisertypeTreadMaterial Property
ParameterTypeId Class See Also Send Feedback
"Tread Material"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsTrisertypeTreadMaterial { get; }
Visual Basic
Public Shared ReadOnly Property StairsTrisertypeTreadMaterial As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsTrisertypeTreadMaterial {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsTrisertypeTreadProfile Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsTrisertypeTreadProfile Property
ParameterTypeId Class See Also Send Feedback
"Tread Profile"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsTrisertypeTreadProfile { get; }
Visual Basic
Public Shared ReadOnly Property StairsTrisertypeTreadProfile As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsTrisertypeTreadProfile {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairstypeCalcRuleMinResult Property

[image]

Revit 2024 API
ParameterTypeId..::..StairstypeCalcRuleMinResult Property
ParameterTypeId Class See Also Send Feedback
"Min. Result": Calculation Rule Min Result

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairstypeCalcRuleMinResult { get; }
Visual Basic
Public Shared ReadOnly Property StairstypeCalcRuleMinResult As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairstypeCalcRuleMinResult {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairstypeCalcRuleRiserMultiplier Property

[image]

Revit 2024 API
ParameterTypeId..::..StairstypeCalcRuleRiserMultiplier Property
ParameterTypeId Class See Also Send Feedback
"Riser Multiplier": Calculation Rule Riser Multiplier

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairstypeCalcRuleRiserMultiplier { get; }
Visual Basic
Public Shared ReadOnly Property StairstypeCalcRuleRiserMultiplier As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairstypeCalcRuleRiserMultiplier {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairstypeCalcRuleTargetResult Property

[image]

Revit 2024 API
ParameterTypeId..::..StairstypeCalcRuleTargetResult Property
ParameterTypeId Class See Also Send Feedback
"Target Result": Calculation Rule Target Result

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairstypeCalcRuleTargetResult { get; }
Visual Basic
Public Shared ReadOnly Property StairstypeCalcRuleTargetResult As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairstypeCalcRuleTargetResult {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairstypeCalcRuleTreadMultiplier Property

[image]

Revit 2024 API
ParameterTypeId..::..StairstypeCalcRuleTreadMultiplier Property
ParameterTypeId Class See Also Send Feedback
"Tread Multiplier": Calculation Rule Tread Multiplier

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairstypeCalcRuleTreadMultiplier { get; }
Visual Basic
Public Shared ReadOnly Property StairstypeCalcRuleTreadMultiplier As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairstypeCalcRuleTreadMultiplier {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairstypeCalculationRules Property

[image]

Revit 2024 API
ParameterTypeId..::..StairstypeCalculationRules Property
ParameterTypeId Class See Also Send Feedback
"Calculation Rules": Calculation Rules

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairstypeCalculationRules { get; }
Visual Basic
Public Shared ReadOnly Property StairstypeCalculationRules As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairstypeCalculationRules {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairstypeCutmarkType Property

[image]

Revit 2024 API
ParameterTypeId..::..StairstypeCutmarkType Property
ParameterTypeId Class See Also Send Feedback
"Cut Mark Type": Cut Mark Type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairstypeCutmarkType { get; }
Visual Basic
Public Shared ReadOnly Property StairstypeCutmarkType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairstypeCutmarkType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairstypeGeomunjoinedEndCutStyle Property

[image]

Revit 2024 API
ParameterTypeId..::..StairstypeGeomunjoinedEndCutStyle Property
ParameterTypeId Class See Also Send Feedback
"Connection Method": Cut Style for Geometrically Unjoined End

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairstypeGeomunjoinedEndCutStyle { get; }
Visual Basic
Public Shared ReadOnly Property StairstypeGeomunjoinedEndCutStyle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairstypeGeomunjoinedEndCutStyle {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairstypeHasIntermediateSupport Property

[image]

Revit 2024 API
ParameterTypeId..::..StairstypeHasIntermediateSupport Property
ParameterTypeId Class See Also Send Feedback
"Middle Support": Whether stairs is assembled

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairstypeHasIntermediateSupport { get; }
Visual Basic
Public Shared ReadOnly Property StairstypeHasIntermediateSupport As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairstypeHasIntermediateSupport {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairstypeHasLeftSupport Property

[image]

Revit 2024 API
ParameterTypeId..::..StairstypeHasLeftSupport Property
ParameterTypeId Class See Also Send Feedback
"Left Support":

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairstypeHasLeftSupport { get; }
Visual Basic
Public Shared ReadOnly Property StairstypeHasLeftSupport As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairstypeHasLeftSupport {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairstypeHasRightSupport Property

[image]

Revit 2024 API
ParameterTypeId..::..StairstypeHasRightSupport Property
ParameterTypeId Class See Also Send Feedback
"Right Support":

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairstypeHasRightSupport { get; }
Visual Basic
Public Shared ReadOnly Property StairstypeHasRightSupport As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairstypeHasRightSupport {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairstypeLandingType Property

[image]

Revit 2024 API
ParameterTypeId..::..StairstypeLandingType Property
ParameterTypeId Class See Also Send Feedback
"Landing Type": Landing Type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairstypeLandingType { get; }
Visual Basic
Public Shared ReadOnly Property StairstypeLandingType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairstypeLandingType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairstypeLeftSupportLateralOffset Property

[image]

Revit 2024 API
ParameterTypeId..::..StairstypeLeftSupportLateralOffset Property
ParameterTypeId Class See Also Send Feedback
"Left Lateral Offset":

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairstypeLeftSupportLateralOffset { get; }
Visual Basic
Public Shared ReadOnly Property StairstypeLeftSupportLateralOffset As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairstypeLeftSupportLateralOffset {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairstypeMaximumRiserHeight Property

[image]

Revit 2024 API
ParameterTypeId..::..StairstypeMaximumRiserHeight Property
ParameterTypeId Class See Also Send Feedback
"Max. Riser Height": Maximum Riser Height

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairstypeMaximumRiserHeight { get; }
Visual Basic
Public Shared ReadOnly Property StairstypeMaximumRiserHeight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairstypeMaximumRiserHeight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairstypeMinimumRunWidth Property

[image]

Revit 2024 API
ParameterTypeId..::..StairstypeMinimumRunWidth Property
ParameterTypeId Class See Also Send Feedback
"Minimum Run Width": Minimum Run Width

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairstypeMinimumRunWidth { get; }
Visual Basic
Public Shared ReadOnly Property StairstypeMinimumRunWidth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairstypeMinimumRunWidth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairstypeMinimumTreadDepth Property

[image]

Revit 2024 API
ParameterTypeId..::..StairstypeMinimumTreadDepth Property
ParameterTypeId Class See Also Send Feedback
"Min. Tread Depth": Minimum Tread Depth

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairstypeMinimumTreadDepth { get; }
Visual Basic
Public Shared ReadOnly Property StairstypeMinimumTreadDepth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairstypeMinimumTreadDepth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairstypeMinimumTreadWidthInsideBoundary Property

[image]

Revit 2024 API
ParameterTypeId..::..StairstypeMinimumTreadWidthInsideBoundary Property
ParameterTypeId Class See Also Send Feedback
"Min. Tread Depth on Winder Inner Boundary": Minimum Tread Width on Inside Boundary

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairstypeMinimumTreadWidthInsideBoundary { get; }
Visual Basic
Public Shared ReadOnly Property StairstypeMinimumTreadWidthInsideBoundary As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairstypeMinimumTreadWidthInsideBoundary {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairstypeNotchCustomWidth Property

[image]

Revit 2024 API
ParameterTypeId..::..StairstypeNotchCustomWidth Property
ParameterTypeId Class See Also Send Feedback
"Custom":

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairstypeNotchCustomWidth { get; }
Visual Basic
Public Shared ReadOnly Property StairstypeNotchCustomWidth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairstypeNotchCustomWidth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairstypeNotchExtension Property

[image]

Revit 2024 API
ParameterTypeId..::..StairstypeNotchExtension Property
ParameterTypeId Class See Also Send Feedback
"Notch Extension":

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairstypeNotchExtension { get; }
Visual Basic
Public Shared ReadOnly Property StairstypeNotchExtension As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairstypeNotchExtension {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairstypeNotchHorizontalGap Property

[image]

Revit 2024 API
ParameterTypeId..::..StairstypeNotchHorizontalGap Property
ParameterTypeId Class See Also Send Feedback
"Horizontal Gap Distance":

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairstypeNotchHorizontalGap { get; }
Visual Basic
Public Shared ReadOnly Property StairstypeNotchHorizontalGap As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairstypeNotchHorizontalGap {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairstypeNotchThickness Property

[image]

Revit 2024 API
ParameterTypeId..::..StairstypeNotchThickness Property
ParameterTypeId Class See Also Send Feedback
"Notch Thickness":

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairstypeNotchThickness { get; }
Visual Basic
Public Shared ReadOnly Property StairstypeNotchThickness As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairstypeNotchThickness {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairstypeNotchVerticalGap Property

[image]

Revit 2024 API
ParameterTypeId..::..StairstypeNotchVerticalGap Property
ParameterTypeId Class See Also Send Feedback
"Vertical Gap Distance":

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairstypeNotchVerticalGap { get; }
Visual Basic
Public Shared ReadOnly Property StairstypeNotchVerticalGap As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairstypeNotchVerticalGap {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairstypeNotchWidth Property

[image]

Revit 2024 API
ParameterTypeId..::..StairstypeNotchWidth Property
ParameterTypeId Class See Also Send Feedback
"Notch Width":

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairstypeNotchWidth { get; }
Visual Basic
Public Shared ReadOnly Property StairstypeNotchWidth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairstypeNotchWidth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairstypeNumberOfIntermediateSupports Property

[image]

Revit 2024 API
ParameterTypeId..::..StairstypeNumberOfIntermediateSupports Property
ParameterTypeId Class See Also Send Feedback
"Middle Support Number": Number of intermediate supports

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairstypeNumberOfIntermediateSupports { get; }
Visual Basic
Public Shared ReadOnly Property StairstypeNumberOfIntermediateSupports As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairstypeNumberOfIntermediateSupports {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairstypeRightSideSupportType Property

[image]

Revit 2024 API
ParameterTypeId..::..StairstypeRightSideSupportType Property
ParameterTypeId Class See Also Send Feedback
"Right Support Type": Right Side Support Type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairstypeRightSideSupportType { get; }
Visual Basic
Public Shared ReadOnly Property StairstypeRightSideSupportType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairstypeRightSideSupportType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairstypeRightSupportLateralOffset Property

[image]

Revit 2024 API
ParameterTypeId..::..StairstypeRightSupportLateralOffset Property
ParameterTypeId Class See Also Send Feedback
"Right Lateral Offset":

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairstypeRightSupportLateralOffset { get; }
Visual Basic
Public Shared ReadOnly Property StairstypeRightSupportLateralOffset As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairstypeRightSupportLateralOffset {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairstypeRunType Property

[image]

Revit 2024 API
ParameterTypeId..::..StairstypeRunType Property
ParameterTypeId Class See Also Send Feedback
"Run Type": Run Type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairstypeRunType { get; }
Visual Basic
Public Shared ReadOnly Property StairstypeRunType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairstypeRunType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairstypeShowStairPath Property

[image]

Revit 2024 API
ParameterTypeId..::..StairstypeShowStairPath Property
ParameterTypeId Class See Also Send Feedback
"Show Stair Path in Plan": Show Stair Path in Plan

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairstypeShowStairPath { get; }
Visual Basic
Public Shared ReadOnly Property StairstypeShowStairPath As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairstypeShowStairPath {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairstypeShowUpdown Property

[image]

Revit 2024 API
ParameterTypeId..::..StairstypeShowUpdown Property
ParameterTypeId Class See Also Send Feedback
"Show Up/Down in Plan": Show Up/Down in Plan

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairstypeShowUpdown { get; }
Visual Basic
Public Shared ReadOnly Property StairstypeShowUpdown As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairstypeShowUpdown {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairstypeWinderStepFrontMeasurement Property

[image]

Revit 2024 API
ParameterTypeId..::..StairstypeWinderStepFrontMeasurement Property
ParameterTypeId Class See Also Send Feedback
"Winder Algorithm": Winder Algorithm

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairstypeWinderStepFrontMeasurement { get; }
Visual Basic
Public Shared ReadOnly Property StairstypeWinderStepFrontMeasurement As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairstypeWinderStepFrontMeasurement {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsWinderpatternFilletInsideCorner Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsWinderpatternFilletInsideCorner Property
ParameterTypeId Class See Also Send Feedback
"Fillet on Corner": Fillet on inside corner

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsWinderpatternFilletInsideCorner { get; }
Visual Basic
Public Shared ReadOnly Property StairsWinderpatternFilletInsideCorner As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsWinderpatternFilletInsideCorner {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsWinderpatternMinimumWidthCorner Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsWinderpatternMinimumWidthCorner Property
ParameterTypeId Class See Also Send Feedback
"Minimum Width on Inside Boundary": Minimum Width on Inside Boundary

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsWinderpatternMinimumWidthCorner { get; }
Visual Basic
Public Shared ReadOnly Property StairsWinderpatternMinimumWidthCorner As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsWinderpatternMinimumWidthCorner {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsWinderpatternMinimumWidthInsideWalkline Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsWinderpatternMinimumWidthInsideWalkline Property
ParameterTypeId Class See Also Send Feedback
"Minimum Width on Inside Walk Line": Minimum width on inside walkline

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsWinderpatternMinimumWidthInsideWalkline { get; }
Visual Basic
Public Shared ReadOnly Property StairsWinderpatternMinimumWidthInsideWalkline As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsWinderpatternMinimumWidthInsideWalkline {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsWinderpatternNumberOfStraightStepsAtEnd Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsWinderpatternNumberOfStraightStepsAtEnd Property
ParameterTypeId Class See Also Send Feedback
"Parallel Treads at End": Number of straight steps at the begin of winder

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsWinderpatternNumberOfStraightStepsAtEnd { get; }
Visual Basic
Public Shared ReadOnly Property StairsWinderpatternNumberOfStraightStepsAtEnd As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsWinderpatternNumberOfStraightStepsAtEnd {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsWinderpatternRadiusInterior Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsWinderpatternRadiusInterior Property
ParameterTypeId Class See Also Send Feedback
"Fillet Radius": The fillet corner radius on the interior boundary

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsWinderpatternRadiusInterior { get; }
Visual Basic
Public Shared ReadOnly Property StairsWinderpatternRadiusInterior As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsWinderpatternRadiusInterior {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StairsWinderpatternWinderStyle Property

[image]

Revit 2024 API
ParameterTypeId..::..StairsWinderpatternWinderStyle Property
ParameterTypeId Class See Also Send Feedback
"Winder Style": Winder Style

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StairsWinderpatternWinderStyle { get; }
Visual Basic
Public Shared ReadOnly Property StairsWinderpatternWinderStyle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StairsWinderpatternWinderStyle {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StartExtension Property

[image]

Revit 2024 API
ParameterTypeId..::..StartExtension Property
ParameterTypeId Class See Also Send Feedback
"Start Extension"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StartExtension { get; }
Visual Basic
Public Shared ReadOnly Property StartExtension As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StartExtension {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StartSymbolType Property

[image]

Revit 2024 API
ParameterTypeId..::..StartSymbolType Property
ParameterTypeId Class See Also Send Feedback
"Start Symbol Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StartSymbolType { get; }
Visual Basic
Public Shared ReadOnly Property StartSymbolType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StartSymbolType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StartYJustification Property

[image]

Revit 2024 API
ParameterTypeId..::..StartYJustification Property
ParameterTypeId Class See Also Send Feedback
"Start y Justification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StartYJustification { get; }
Visual Basic
Public Shared ReadOnly Property StartYJustification As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StartYJustification {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StartYOffsetValue Property

[image]

Revit 2024 API
ParameterTypeId..::..StartYOffsetValue Property
ParameterTypeId Class See Also Send Feedback
"Start y Offset Value"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StartYOffsetValue { get; }
Visual Basic
Public Shared ReadOnly Property StartYOffsetValue As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StartYOffsetValue {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StartZJustification Property

[image]

Revit 2024 API
ParameterTypeId..::..StartZJustification Property
ParameterTypeId Class See Also Send Feedback
"Start z Justification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StartZJustification { get; }
Visual Basic
Public Shared ReadOnly Property StartZJustification As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StartZJustification {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StartZOffsetValue Property

[image]

Revit 2024 API
ParameterTypeId..::..StartZOffsetValue Property
ParameterTypeId Class See Also Send Feedback
"Start z Offset Value"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StartZOffsetValue { get; }
Visual Basic
Public Shared ReadOnly Property StartZOffsetValue As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StartZOffsetValue {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemAnchorAssembly Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemAnchorAssembly Property
ParameterTypeId Class See Also Send Feedback
"Assembly"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemAnchorAssembly { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemAnchorAssembly As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemAnchorAssembly {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemAnchorDiameter Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemAnchorDiameter Property
ParameterTypeId Class See Also Send Feedback
"Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemAnchorDiameter { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemAnchorDiameter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemAnchorDiameter {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemAnchorLength Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemAnchorLength Property
ParameterTypeId Class See Also Send Feedback
"Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemAnchorLength { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemAnchorLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemAnchorLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemAnchorStandard Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemAnchorStandard Property
ParameterTypeId Class See Also Send Feedback
"Standard"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemAnchorStandard { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemAnchorStandard As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemAnchorStandard {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemAnchorTotalWeight Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemAnchorTotalWeight Property
ParameterTypeId Class See Also Send Feedback
"Total Weight"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemAnchorTotalWeight { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemAnchorTotalWeight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemAnchorTotalWeight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemBoltAssembly Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemBoltAssembly Property
ParameterTypeId Class See Also Send Feedback
"Assembly"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemBoltAssembly { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemBoltAssembly As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemBoltAssembly {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemBoltCoating Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemBoltCoating Property
ParameterTypeId Class See Also Send Feedback
"Coating"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemBoltCoating { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemBoltCoating As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemBoltCoating {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemBoltGrade Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemBoltGrade Property
ParameterTypeId Class See Also Send Feedback
"Grade"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemBoltGrade { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemBoltGrade As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemBoltGrade {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemBoltGripLengthIncrease Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemBoltGripLengthIncrease Property
ParameterTypeId Class See Also Send Feedback
"Grip Length Increase"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemBoltGripLengthIncrease { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemBoltGripLengthIncrease As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemBoltGripLengthIncrease {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemBoltInverted Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemBoltInverted Property
ParameterTypeId Class See Also Send Feedback
"Inverted"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemBoltInverted { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemBoltInverted As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemBoltInverted {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemBoltLength Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemBoltLength Property
ParameterTypeId Class See Also Send Feedback
"Bolt Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemBoltLength { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemBoltLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemBoltLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemBoltLocation Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemBoltLocation Property
ParameterTypeId Class See Also Send Feedback
"Location"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemBoltLocation { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemBoltLocation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemBoltLocation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemCoating Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemCoating Property
ParameterTypeId Class See Also Send Feedback
"Coating"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemCoating { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemCoating As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemCoating {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemContourSide1dist Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemContourSide1dist Property
ParameterTypeId Class See Also Send Feedback
"Boundary distance 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemContourSide1dist { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemContourSide1dist As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemContourSide1dist {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemContourSide2dist Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemContourSide2dist Property
ParameterTypeId Class See Also Send Feedback
"Boundary distance 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemContourSide2dist { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemContourSide2dist As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemContourSide2dist {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemCopeAroundAxis Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemCopeAroundAxis Property
ParameterTypeId Class See Also Send Feedback
"Around beam axis"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemCopeAroundAxis { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemCopeAroundAxis As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemCopeAroundAxis {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemCopeWidthx Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemCopeWidthx Property
ParameterTypeId Class See Also Send Feedback
"Cutback"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemCopeWidthx { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemCopeWidthx As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemCopeWidthx {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemCopeXAngle Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemCopeXAngle Property
ParameterTypeId Class See Also Send Feedback
"Cross-section rotation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemCopeXAngle { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemCopeXAngle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemCopeXAngle {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemCutLength Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemCutLength Property
ParameterTypeId Class See Also Send Feedback
"Cut Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemCutLength { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemCutLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemCutLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemCutType Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemCutType Property
ParameterTypeId Class See Also Send Feedback
"Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemCutType { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemCutType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemCutType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemExactWeight Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemExactWeight Property
ParameterTypeId Class See Also Send Feedback
"Exact Weight"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemExactWeight { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemExactWeight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemExactWeight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemHoleAlpha Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemHoleAlpha Property
ParameterTypeId Class See Also Send Feedback
"Taper Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemHoleAlpha { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemHoleAlpha As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemHoleAlpha {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemHoleDefinition Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemHoleDefinition Property
ParameterTypeId Class See Also Send Feedback
"Hole Definition"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemHoleDefinition { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemHoleDefinition As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemHoleDefinition {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemHoleDepth Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemHoleDepth Property
ParameterTypeId Class See Also Send Feedback
"Hole Depth"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemHoleDepth { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemHoleDepth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemHoleDepth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemHoleDepthOfBoltHead Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemHoleDepthOfBoltHead Property
ParameterTypeId Class See Also Send Feedback
"Depth of bolt head"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemHoleDepthOfBoltHead { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemHoleDepthOfBoltHead As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemHoleDepthOfBoltHead {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemHoleHeadDiameter Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemHoleHeadDiameter Property
ParameterTypeId Class See Also Send Feedback
"Head diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemHoleHeadDiameter { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemHoleHeadDiameter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemHoleHeadDiameter {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemHoleSlotDirection Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemHoleSlotDirection Property
ParameterTypeId Class See Also Send Feedback
"Along side 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemHoleSlotDirection { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemHoleSlotDirection As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemHoleSlotDirection {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemHoleSlotLength Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemHoleSlotLength Property
ParameterTypeId Class See Also Send Feedback
"Length of the slot"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemHoleSlotLength { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemHoleSlotLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemHoleSlotLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemHoleTappingHole Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemHoleTappingHole Property
ParameterTypeId Class See Also Send Feedback
"Tapping hole"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemHoleTappingHole { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemHoleTappingHole As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemHoleTappingHole {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemHoleType Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemHoleType Property
ParameterTypeId Class See Also Send Feedback
"Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemHoleType { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemHoleType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemHoleType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemParamBoringout Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemParamBoringout Property
ParameterTypeId Class See Also Send Feedback
"Boring out"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemParamBoringout { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemParamBoringout As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemParamBoringout {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemParamRadius Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemParamRadius Property
ParameterTypeId Class See Also Send Feedback
"Radius"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemParamRadius { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemParamRadius As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemParamRadius {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemPatternEdgeDistanceX Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemPatternEdgeDistanceX Property
ParameterTypeId Class See Also Send Feedback
"Edge distance on side 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemPatternEdgeDistanceX { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemPatternEdgeDistanceX As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemPatternEdgeDistanceX {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemPatternIntermediateDistanceX Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemPatternIntermediateDistanceX Property
ParameterTypeId Class See Also Send Feedback
"Intermediate distance on side 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemPatternIntermediateDistanceX { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemPatternIntermediateDistanceX As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemPatternIntermediateDistanceX {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemPatternIntermediateDistanceY Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemPatternIntermediateDistanceY Property
ParameterTypeId Class See Also Send Feedback
"Intermediate distance on side 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemPatternIntermediateDistanceY { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemPatternIntermediateDistanceY As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemPatternIntermediateDistanceY {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemPatternNumberX Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemPatternNumberX Property
ParameterTypeId Class See Also Send Feedback
"Number on side 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemPatternNumberX { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemPatternNumberX As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemPatternNumberX {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemPatternNumberY Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemPatternNumberY Property
ParameterTypeId Class See Also Send Feedback
"Number on side 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemPatternNumberY { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemPatternNumberY As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemPatternNumberY {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemPatternRadius Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemPatternRadius Property
ParameterTypeId Class See Also Send Feedback
"Radius"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemPatternRadius { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemPatternRadius As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemPatternRadius {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemPatternTotalLength Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemPatternTotalLength Property
ParameterTypeId Class See Also Send Feedback
"Length on side 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemPatternTotalLength { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemPatternTotalLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemPatternTotalLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemPatternTotalWidth Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemPatternTotalWidth Property
ParameterTypeId Class See Also Send Feedback
"Length on side 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemPatternTotalWidth { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemPatternTotalWidth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemPatternTotalWidth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemPlateArea Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemPlateArea Property
ParameterTypeId Class See Also Send Feedback
"Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemPlateArea { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemPlateArea As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemPlateArea {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemPlateExactWeight Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemPlateExactWeight Property
ParameterTypeId Class See Also Send Feedback
"Exact Weight"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemPlateExactWeight { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemPlateExactWeight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemPlateExactWeight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemPlateJustification Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemPlateJustification Property
ParameterTypeId Class See Also Send Feedback
"Justification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemPlateJustification { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemPlateJustification As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemPlateJustification {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemPlateLength Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemPlateLength Property
ParameterTypeId Class See Also Send Feedback
"Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemPlateLength { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemPlateLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemPlateLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemPlatePaintArea Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemPlatePaintArea Property
ParameterTypeId Class See Also Send Feedback
"Paint Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemPlatePaintArea { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemPlatePaintArea As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemPlatePaintArea {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemPlateShortenAngle Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemPlateShortenAngle Property
ParameterTypeId Class See Also Send Feedback
"Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemPlateShortenAngle { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemPlateShortenAngle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemPlateShortenAngle {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemPlateShortenCutstraight Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemPlateShortenCutstraight Property
ParameterTypeId Class See Also Send Feedback
"Cut straight"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemPlateShortenCutstraight { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemPlateShortenCutstraight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemPlateShortenCutstraight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemPlateShortenSuction Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemPlateShortenSuction Property
ParameterTypeId Class See Also Send Feedback
"Suction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemPlateShortenSuction { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemPlateShortenSuction As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemPlateShortenSuction {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemPlateThickness Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemPlateThickness Property
ParameterTypeId Class See Also Send Feedback
"Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemPlateThickness { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemPlateThickness As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemPlateThickness {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemPlateType Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemPlateType Property
ParameterTypeId Class See Also Send Feedback
"Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemPlateType { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemPlateType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemPlateType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemPlateVolume Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemPlateVolume Property
ParameterTypeId Class See Also Send Feedback
"Volume"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemPlateVolume { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemPlateVolume As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemPlateVolume {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemPlateWeight Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemPlateWeight Property
ParameterTypeId Class See Also Send Feedback
"Weight"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemPlateWeight { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemPlateWeight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemPlateWeight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemPlateWidth Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemPlateWidth Property
ParameterTypeId Class See Also Send Feedback
"Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemPlateWidth { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemPlateWidth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemPlateWidth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemProfileLength Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemProfileLength Property
ParameterTypeId Class See Also Send Feedback
"Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemProfileLength { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemProfileLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemProfileLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemProfileType Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemProfileType Property
ParameterTypeId Class See Also Send Feedback
"Profile Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemProfileType { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemProfileType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemProfileType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemShearstudDiameter Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemShearstudDiameter Property
ParameterTypeId Class See Also Send Feedback
"Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemShearstudDiameter { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemShearstudDiameter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemShearstudDiameter {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemShearstudStandard Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemShearstudStandard Property
ParameterTypeId Class See Also Send Feedback
"Standard"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemShearstudStandard { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemShearstudStandard As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemShearstudStandard {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemShearstudTotalWeight Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemShearstudTotalWeight Property
ParameterTypeId Class See Also Send Feedback
"Total Weight"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemShearstudTotalWeight { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemShearstudTotalWeight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemShearstudTotalWeight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemShortenAngley Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemShortenAngley Property
ParameterTypeId Class See Also Send Feedback
"Angle along height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemShortenAngley { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemShortenAngley As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemShortenAngley {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemShortenAnglez Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemShortenAnglez Property
ParameterTypeId Class See Also Send Feedback
"Angle along width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemShortenAnglez { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemShortenAnglez As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemShortenAnglez {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemShortenReflength Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemShortenReflength Property
ParameterTypeId Class See Also Send Feedback
"Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemShortenReflength { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemShortenReflength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemShortenReflength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemWeight Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemWeight Property
ParameterTypeId Class See Also Send Feedback
"Weight"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemWeight { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemWeight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemWeight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemWeldContinuous Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemWeldContinuous Property
ParameterTypeId Class See Also Send Feedback
"Continuous"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemWeldContinuous { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemWeldContinuous As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemWeldContinuous {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemWeldDoubleEffectivethroat Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemWeldDoubleEffectivethroat Property
ParameterTypeId Class See Also Send Feedback
"Double Effective Throat"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemWeldDoubleEffectivethroat { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemWeldDoubleEffectivethroat As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemWeldDoubleEffectivethroat {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemWeldDoublePrepdepth Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemWeldDoublePrepdepth Property
ParameterTypeId Class See Also Send Feedback
"Double Preparation Depth"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemWeldDoublePrepdepth { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemWeldDoublePrepdepth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemWeldDoublePrepdepth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemWeldDoubleRootopening Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemWeldDoubleRootopening Property
ParameterTypeId Class See Also Send Feedback
"Double Root Opening"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemWeldDoubleRootopening { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemWeldDoubleRootopening As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemWeldDoubleRootopening {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemWeldDoubleText Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemWeldDoubleText Property
ParameterTypeId Class See Also Send Feedback
"Double Text"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemWeldDoubleText { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemWeldDoubleText As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemWeldDoubleText {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemWeldDoubleThickness Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemWeldDoubleThickness Property
ParameterTypeId Class See Also Send Feedback
"Double Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemWeldDoubleThickness { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemWeldDoubleThickness As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemWeldDoubleThickness {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemWeldDoubleType Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemWeldDoubleType Property
ParameterTypeId Class See Also Send Feedback
"Double Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemWeldDoubleType { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemWeldDoubleType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemWeldDoubleType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemWeldDoubleWeldprep Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemWeldDoubleWeldprep Property
ParameterTypeId Class See Also Send Feedback
"Double Weld preparation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemWeldDoubleWeldprep { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemWeldDoubleWeldprep As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemWeldDoubleWeldprep {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemWeldLength Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemWeldLength Property
ParameterTypeId Class See Also Send Feedback
"Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemWeldLength { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemWeldLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemWeldLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemWeldLocation Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemWeldLocation Property
ParameterTypeId Class See Also Send Feedback
"Location"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemWeldLocation { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemWeldLocation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemWeldLocation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemWeldMainEffectivethroat Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemWeldMainEffectivethroat Property
ParameterTypeId Class See Also Send Feedback
"Main Effective Throat"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemWeldMainEffectivethroat { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemWeldMainEffectivethroat As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemWeldMainEffectivethroat {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemWeldMainRootopening Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemWeldMainRootopening Property
ParameterTypeId Class See Also Send Feedback
"Main Root Opening"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemWeldMainRootopening { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemWeldMainRootopening As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemWeldMainRootopening {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemWeldMainText Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemWeldMainText Property
ParameterTypeId Class See Also Send Feedback
"Main Text"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemWeldMainText { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemWeldMainText As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemWeldMainText {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemWeldMainType Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemWeldMainType Property
ParameterTypeId Class See Also Send Feedback
"Main Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemWeldMainType { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemWeldMainType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemWeldMainType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemWeldPrefix Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemWeldPrefix Property
ParameterTypeId Class See Also Send Feedback
"Prefix"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemWeldPrefix { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemWeldPrefix As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemWeldPrefix {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemWeldTextModule Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemWeldTextModule Property
ParameterTypeId Class See Also Send Feedback
"Text module"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemWeldTextModule { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemWeldTextModule As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemWeldTextModule {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SteelElemYDistance Property

[image]

Revit 2024 API
ParameterTypeId..::..SteelElemYDistance Property
ParameterTypeId Class See Also Send Feedback
"Side 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SteelElemYDistance { get; }
Visual Basic
Public Shared ReadOnly Property SteelElemYDistance As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SteelElemYDistance {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StiffenerClassification Property

[image]

Revit 2024 API
ParameterTypeId..::..StiffenerClassification Property
ParameterTypeId Class See Also Send Feedback
"Classification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StiffenerClassification { get; }
Visual Basic
Public Shared ReadOnly Property StiffenerClassification As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StiffenerClassification {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructConnectionBeamEnd Property

[image]

Revit 2024 API
ParameterTypeId..::..StructConnectionBeamEnd Property
ParameterTypeId Class See Also Send Feedback
"End Connection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructConnectionBeamEnd { get; }
Visual Basic
Public Shared ReadOnly Property StructConnectionBeamEnd As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructConnectionBeamEnd {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructConnectionBeamStart Property

[image]

Revit 2024 API
ParameterTypeId..::..StructConnectionBeamStart Property
ParameterTypeId Class See Also Send Feedback
"Start Connection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructConnectionBeamStart { get; }
Visual Basic
Public Shared ReadOnly Property StructConnectionBeamStart As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructConnectionBeamStart {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructConnectionCutback Property

[image]

Revit 2024 API
ParameterTypeId..::..StructConnectionCutback Property
ParameterTypeId Class See Also Send Feedback
"Automatic Cutback for Beams and Braces"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructConnectionCutback { get; }
Visual Basic
Public Shared ReadOnly Property StructConnectionCutback As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructConnectionCutback {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructFramJoinStatus Property

[image]

Revit 2024 API
ParameterTypeId..::..StructFramJoinStatus Property
ParameterTypeId Class See Also Send Feedback
"Join Status"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructFramJoinStatus { get; }
Visual Basic
Public Shared ReadOnly Property StructFramJoinStatus As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructFramJoinStatus {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralAnalyticalBeamHorizontalProjectionPlane Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralAnalyticalBeamHorizontalProjectionPlane Property
ParameterTypeId Class See Also Send Feedback
"Horizontal Projection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralAnalyticalBeamHorizontalProjectionPlane { get; }
Visual Basic
Public Shared ReadOnly Property StructuralAnalyticalBeamHorizontalProjectionPlane As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralAnalyticalBeamHorizontalProjectionPlane {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralAnalyticalBeamRigidLink Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralAnalyticalBeamRigidLink Property
ParameterTypeId Class See Also Send Feedback
"Analytical Links"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralAnalyticalBeamRigidLink { get; }
Visual Basic
Public Shared ReadOnly Property StructuralAnalyticalBeamRigidLink As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralAnalyticalBeamRigidLink {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralAnalyticalColumnHorizontalProjectionPlane Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralAnalyticalColumnHorizontalProjectionPlane Property
ParameterTypeId Class See Also Send Feedback
"Horizontal Projection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralAnalyticalColumnHorizontalProjectionPlane { get; }
Visual Basic
Public Shared ReadOnly Property StructuralAnalyticalColumnHorizontalProjectionPlane As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralAnalyticalColumnHorizontalProjectionPlane {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralAnalyticalColumnRigidLink Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralAnalyticalColumnRigidLink Property
ParameterTypeId Class See Also Send Feedback
"Analytical Links"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralAnalyticalColumnRigidLink { get; }
Visual Basic
Public Shared ReadOnly Property StructuralAnalyticalColumnRigidLink As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralAnalyticalColumnRigidLink {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralAnalyticalHardPoints Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralAnalyticalHardPoints Property
ParameterTypeId Class See Also Send Feedback
"Use hard-points"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralAnalyticalHardPoints { get; }
Visual Basic
Public Shared ReadOnly Property StructuralAnalyticalHardPoints As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralAnalyticalHardPoints {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralAnalyticalModel Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralAnalyticalModel Property
ParameterTypeId Class See Also Send Feedback
"Enable Analytical Model"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralAnalyticalModel { get; }
Visual Basic
Public Shared ReadOnly Property StructuralAnalyticalModel As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralAnalyticalModel {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralAnalyticalProjectMemberPlane Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralAnalyticalProjectMemberPlane Property
ParameterTypeId Class See Also Send Feedback
"Vertical Projection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralAnalyticalProjectMemberPlane { get; }
Visual Basic
Public Shared ReadOnly Property StructuralAnalyticalProjectMemberPlane As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralAnalyticalProjectMemberPlane {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralAnalyticalProjectMemberPlaneColumnBottom Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralAnalyticalProjectMemberPlaneColumnBottom Property
ParameterTypeId Class See Also Send Feedback
"Bottom Vertical Projection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralAnalyticalProjectMemberPlaneColumnBottom { get; }
Visual Basic
Public Shared ReadOnly Property StructuralAnalyticalProjectMemberPlaneColumnBottom As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralAnalyticalProjectMemberPlaneColumnBottom {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralAnalyticalTessDeviation Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralAnalyticalTessDeviation Property
ParameterTypeId Class See Also Send Feedback
"Maximum discretized offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralAnalyticalTessDeviation { get; }
Visual Basic
Public Shared ReadOnly Property StructuralAnalyticalTessDeviation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralAnalyticalTessDeviation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralAnalyzesAs Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralAnalyzesAs Property
ParameterTypeId Class See Also Send Feedback
"Analyze As"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralAnalyzesAs { get; }
Visual Basic
Public Shared ReadOnly Property StructuralAnalyzesAs As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralAnalyzesAs {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralAssetParam Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralAssetParam Property
ParameterTypeId Class See Also Send Feedback
"Physical Material Asset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralAssetParam { get; }
Visual Basic
Public Shared ReadOnly Property StructuralAssetParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralAssetParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralAttachmentBaseDistance Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralAttachmentBaseDistance Property
ParameterTypeId Class See Also Send Feedback
"Base Attachment Distance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralAttachmentBaseDistance { get; }
Visual Basic
Public Shared ReadOnly Property StructuralAttachmentBaseDistance As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralAttachmentBaseDistance {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralAttachmentBaseRatio Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralAttachmentBaseRatio Property
ParameterTypeId Class See Also Send Feedback
"Base Attachment Ratio"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralAttachmentBaseRatio { get; }
Visual Basic
Public Shared ReadOnly Property StructuralAttachmentBaseRatio As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralAttachmentBaseRatio {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralAttachmentBaseReferencedend Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralAttachmentBaseReferencedend Property
ParameterTypeId Class See Also Send Feedback
"Base Attachment Referenced End"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralAttachmentBaseReferencedend { get; }
Visual Basic
Public Shared ReadOnly Property StructuralAttachmentBaseReferencedend As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralAttachmentBaseReferencedend {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralAttachmentBaseType Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralAttachmentBaseType Property
ParameterTypeId Class See Also Send Feedback
"Base Attachment Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralAttachmentBaseType { get; }
Visual Basic
Public Shared ReadOnly Property StructuralAttachmentBaseType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralAttachmentBaseType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralAttachmentEndLevelReference Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralAttachmentEndLevelReference Property
ParameterTypeId Class See Also Send Feedback
"End Attachment Level Reference"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralAttachmentEndLevelReference { get; }
Visual Basic
Public Shared ReadOnly Property StructuralAttachmentEndLevelReference As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralAttachmentEndLevelReference {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralAttachmentEndRefelementEnd Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralAttachmentEndRefelementEnd Property
ParameterTypeId Class See Also Send Feedback
"End of Attachment to Reference Element"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralAttachmentEndRefelementEnd { get; }
Visual Basic
Public Shared ReadOnly Property StructuralAttachmentEndRefelementEnd As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralAttachmentEndRefelementEnd {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralAttachmentEndType Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralAttachmentEndType Property
ParameterTypeId Class See Also Send Feedback
"End Attachment Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralAttachmentEndType { get; }
Visual Basic
Public Shared ReadOnly Property StructuralAttachmentEndType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralAttachmentEndType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralAttachmentEndValueDistance Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralAttachmentEndValueDistance Property
ParameterTypeId Class See Also Send Feedback
"End Attachment Distance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralAttachmentEndValueDistance { get; }
Visual Basic
Public Shared ReadOnly Property StructuralAttachmentEndValueDistance As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralAttachmentEndValueDistance {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralAttachmentStartLevelReference Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralAttachmentStartLevelReference Property
ParameterTypeId Class See Also Send Feedback
"Start Attachment Level Reference"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralAttachmentStartLevelReference { get; }
Visual Basic
Public Shared ReadOnly Property StructuralAttachmentStartLevelReference As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralAttachmentStartLevelReference {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralAttachmentStartRefelementEnd Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralAttachmentStartRefelementEnd Property
ParameterTypeId Class See Also Send Feedback
"Start of Attachment to Reference Element"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralAttachmentStartRefelementEnd { get; }
Visual Basic
Public Shared ReadOnly Property StructuralAttachmentStartRefelementEnd As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralAttachmentStartRefelementEnd {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralAttachmentStartType Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralAttachmentStartType Property
ParameterTypeId Class See Also Send Feedback
"Start Attachment Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralAttachmentStartType { get; }
Visual Basic
Public Shared ReadOnly Property StructuralAttachmentStartType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralAttachmentStartType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralAttachmentStartValueDistance Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralAttachmentStartValueDistance Property
ParameterTypeId Class See Also Send Feedback
"Start Attachment Distance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralAttachmentStartValueDistance { get; }
Visual Basic
Public Shared ReadOnly Property StructuralAttachmentStartValueDistance As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralAttachmentStartValueDistance {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralAttachmentStartValueRatio Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralAttachmentStartValueRatio Property
ParameterTypeId Class See Also Send Feedback
"Start Attachment Ratio"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralAttachmentStartValueRatio { get; }
Visual Basic
Public Shared ReadOnly Property StructuralAttachmentStartValueRatio As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralAttachmentStartValueRatio {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralAttachmentTopRatio Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralAttachmentTopRatio Property
ParameterTypeId Class See Also Send Feedback
"Top Attachment Ratio"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralAttachmentTopRatio { get; }
Visual Basic
Public Shared ReadOnly Property StructuralAttachmentTopRatio As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralAttachmentTopRatio {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralAttachmentTopType Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralAttachmentTopType Property
ParameterTypeId Class See Also Send Feedback
"Top Attachment Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralAttachmentTopType { get; }
Visual Basic
Public Shared ReadOnly Property StructuralAttachmentTopType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralAttachmentTopType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralBeamCutbackForColumn Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralBeamCutbackForColumn Property
ParameterTypeId Class See Also Send Feedback
"Beam cutback in plan"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralBeamCutbackForColumn { get; }
Visual Basic
Public Shared ReadOnly Property StructuralBeamCutbackForColumn As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralBeamCutbackForColumn {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralBeamEnd0Elevation Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralBeamEnd0Elevation Property
ParameterTypeId Class See Also Send Feedback
"Start Level Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralBeamEnd0Elevation { get; }
Visual Basic
Public Shared ReadOnly Property StructuralBeamEnd0Elevation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralBeamEnd0Elevation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralBeamEnd1Elevation Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralBeamEnd1Elevation Property
ParameterTypeId Class See Also Send Feedback
"End Level Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralBeamEnd1Elevation { get; }
Visual Basic
Public Shared ReadOnly Property StructuralBeamEnd1Elevation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralBeamEnd1Elevation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralBeamEndAttachmentRefcolumnEnd Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralBeamEndAttachmentRefcolumnEnd Property
ParameterTypeId Class See Also Send Feedback
"End of Attachment to Reference Column"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralBeamEndAttachmentRefcolumnEnd { get; }
Visual Basic
Public Shared ReadOnly Property StructuralBeamEndAttachmentRefcolumnEnd As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralBeamEndAttachmentRefcolumnEnd {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralBeamEndAttachmentType Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralBeamEndAttachmentType Property
ParameterTypeId Class See Also Send Feedback
"End Attachment Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralBeamEndAttachmentType { get; }
Visual Basic
Public Shared ReadOnly Property StructuralBeamEndAttachmentType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralBeamEndAttachmentType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralBeamEndSupport Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralBeamEndSupport Property
ParameterTypeId Class See Also Send Feedback
"Beam End Pocket Seat"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralBeamEndSupport { get; }
Visual Basic
Public Shared ReadOnly Property StructuralBeamEndSupport As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralBeamEndSupport {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralBeamOrientation Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralBeamOrientation Property
ParameterTypeId Class See Also Send Feedback
"Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralBeamOrientation { get; }
Visual Basic
Public Shared ReadOnly Property StructuralBeamOrientation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralBeamOrientation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralBeamStartAttachmentDistance Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralBeamStartAttachmentDistance Property
ParameterTypeId Class See Also Send Feedback
"Start Attachment Distance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralBeamStartAttachmentDistance { get; }
Visual Basic
Public Shared ReadOnly Property StructuralBeamStartAttachmentDistance As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralBeamStartAttachmentDistance {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralBeamStartAttachmentRefcolumnEnd Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralBeamStartAttachmentRefcolumnEnd Property
ParameterTypeId Class See Also Send Feedback
"Start of Attachment to Reference Column"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralBeamStartAttachmentRefcolumnEnd { get; }
Visual Basic
Public Shared ReadOnly Property StructuralBeamStartAttachmentRefcolumnEnd As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralBeamStartAttachmentRefcolumnEnd {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralBeamStartAttachmentType Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralBeamStartAttachmentType Property
ParameterTypeId Class See Also Send Feedback
"Start Attachment Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralBeamStartAttachmentType { get; }
Visual Basic
Public Shared ReadOnly Property StructuralBeamStartAttachmentType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralBeamStartAttachmentType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralBeamStartSupport Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralBeamStartSupport Property
ParameterTypeId Class See Also Send Feedback
"Beam Start Pocket Seat"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralBeamStartSupport { get; }
Visual Basic
Public Shared ReadOnly Property StructuralBeamStartSupport As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralBeamStartSupport {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralBendDirAngle Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralBendDirAngle Property
ParameterTypeId Class See Also Send Feedback
"Cross-Section Rotation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralBendDirAngle { get; }
Visual Basic
Public Shared ReadOnly Property StructuralBendDirAngle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralBendDirAngle {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralBottomReleaseFy Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralBottomReleaseFy Property
ParameterTypeId Class See Also Send Feedback
"Base Fy"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralBottomReleaseFy { get; }
Visual Basic
Public Shared ReadOnly Property StructuralBottomReleaseFy As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralBottomReleaseFy {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralBottomReleaseFz Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralBottomReleaseFz Property
ParameterTypeId Class See Also Send Feedback
"Base Fz"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralBottomReleaseFz { get; }
Visual Basic
Public Shared ReadOnly Property StructuralBottomReleaseFz As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralBottomReleaseFz {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralBottomReleaseMx Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralBottomReleaseMx Property
ParameterTypeId Class See Also Send Feedback
"Base Mx"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralBottomReleaseMx { get; }
Visual Basic
Public Shared ReadOnly Property StructuralBottomReleaseMx As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralBottomReleaseMx {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralBottomReleaseMy Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralBottomReleaseMy Property
ParameterTypeId Class See Also Send Feedback
"Base My"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralBottomReleaseMy { get; }
Visual Basic
Public Shared ReadOnly Property StructuralBottomReleaseMy As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralBottomReleaseMy {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralBottomReleaseMz Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralBottomReleaseMz Property
ParameterTypeId Class See Also Send Feedback
"Base Mz"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralBottomReleaseMz { get; }
Visual Basic
Public Shared ReadOnly Property StructuralBottomReleaseMz As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralBottomReleaseMz {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralBottomReleaseType Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralBottomReleaseType Property
ParameterTypeId Class See Also Send Feedback
"Base Release"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralBottomReleaseType { get; }
Visual Basic
Public Shared ReadOnly Property StructuralBottomReleaseType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralBottomReleaseType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralBraceRepresentation Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralBraceRepresentation Property
ParameterTypeId Class See Also Send Feedback
"Representation Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralBraceRepresentation { get; }
Visual Basic
Public Shared ReadOnly Property StructuralBraceRepresentation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralBraceRepresentation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralConnectionCodeCheckingStatus Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralConnectionCodeCheckingStatus Property
ParameterTypeId Class See Also Send Feedback
"Code Checking Status"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralConnectionCodeCheckingStatus { get; }
Visual Basic
Public Shared ReadOnly Property StructuralConnectionCodeCheckingStatus As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralConnectionCodeCheckingStatus {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralConnectionEditType Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralConnectionEditType Property
ParameterTypeId Class See Also Send Feedback
"Modify Parameters"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralConnectionEditType { get; }
Visual Basic
Public Shared ReadOnly Property StructuralConnectionEditType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralConnectionEditType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralConnectionInputElements Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralConnectionInputElements Property
ParameterTypeId Class See Also Send Feedback
"Input Elements"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralConnectionInputElements { get; }
Visual Basic
Public Shared ReadOnly Property StructuralConnectionInputElements As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralConnectionInputElements {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralConnectionModifyConnectionParameters Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralConnectionModifyConnectionParameters Property
ParameterTypeId Class See Also Send Feedback
"Detailed Parameters"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralConnectionModifyConnectionParameters { get; }
Visual Basic
Public Shared ReadOnly Property StructuralConnectionModifyConnectionParameters As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralConnectionModifyConnectionParameters {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralConnectionNobleStatus Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralConnectionNobleStatus Property
ParameterTypeId Class See Also Send Feedback
"Noble Status"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralConnectionNobleStatus { get; }
Visual Basic
Public Shared ReadOnly Property StructuralConnectionNobleStatus As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralConnectionNobleStatus {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralConnectionOverrideType Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralConnectionOverrideType Property
ParameterTypeId Class See Also Send Feedback
"Override by Instance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralConnectionOverrideType { get; }
Visual Basic
Public Shared ReadOnly Property StructuralConnectionOverrideType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralConnectionOverrideType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralConnectionSymbol Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralConnectionSymbol Property
ParameterTypeId Class See Also Send Feedback
"Connection Symbol"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralConnectionSymbol { get; }
Visual Basic
Public Shared ReadOnly Property StructuralConnectionSymbol As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralConnectionSymbol {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralCopingDistance Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralCopingDistance Property
ParameterTypeId Class See Also Send Feedback
"Coping Distance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralCopingDistance { get; }
Visual Basic
Public Shared ReadOnly Property StructuralCopingDistance As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralCopingDistance {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralDisplayInHiddenViews Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralDisplayInHiddenViews Property
ParameterTypeId Class See Also Send Feedback
"Display in Hidden Views"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralDisplayInHiddenViews { get; }
Visual Basic
Public Shared ReadOnly Property StructuralDisplayInHiddenViews As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralDisplayInHiddenViews {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralElevationAtBottom Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralElevationAtBottom Property
ParameterTypeId Class See Also Send Feedback
"Elevation at Bottom"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralElevationAtBottom { get; }
Visual Basic
Public Shared ReadOnly Property StructuralElevationAtBottom As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralElevationAtBottom {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralElevationAtBottomCore Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralElevationAtBottomCore Property
ParameterTypeId Class See Also Send Feedback
"Elevation at Bottom Core"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralElevationAtBottomCore { get; }
Visual Basic
Public Shared ReadOnly Property StructuralElevationAtBottomCore As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralElevationAtBottomCore {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralElevationAtTop Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralElevationAtTop Property
ParameterTypeId Class See Also Send Feedback
"Elevation at Top"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralElevationAtTop { get; }
Visual Basic
Public Shared ReadOnly Property StructuralElevationAtTop As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralElevationAtTop {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralElevationAtTopCore Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralElevationAtTopCore Property
ParameterTypeId Class See Also Send Feedback
"Elevation at Top Core"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralElevationAtTopCore { get; }
Visual Basic
Public Shared ReadOnly Property StructuralElevationAtTopCore As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralElevationAtTopCore {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralElevationAtTopSurvey Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralElevationAtTopSurvey Property
ParameterTypeId Class See Also Send Feedback
"Elevation at Top Survey"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralElevationAtTopSurvey { get; }
Visual Basic
Public Shared ReadOnly Property StructuralElevationAtTopSurvey As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralElevationAtTopSurvey {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralEndReleaseFx Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralEndReleaseFx Property
ParameterTypeId Class See Also Send Feedback
"End Fx"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralEndReleaseFx { get; }
Visual Basic
Public Shared ReadOnly Property StructuralEndReleaseFx As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralEndReleaseFx {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralEndReleaseFz Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralEndReleaseFz Property
ParameterTypeId Class See Also Send Feedback
"End Fz"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralEndReleaseFz { get; }
Visual Basic
Public Shared ReadOnly Property StructuralEndReleaseFz As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralEndReleaseFz {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralEndReleaseMx Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralEndReleaseMx Property
ParameterTypeId Class See Also Send Feedback
"End Mx"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralEndReleaseMx { get; }
Visual Basic
Public Shared ReadOnly Property StructuralEndReleaseMx As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralEndReleaseMx {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralEndReleaseMy Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralEndReleaseMy Property
ParameterTypeId Class See Also Send Feedback
"End My"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralEndReleaseMy { get; }
Visual Basic
Public Shared ReadOnly Property StructuralEndReleaseMy As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralEndReleaseMy {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralEndReleaseMz Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralEndReleaseMz Property
ParameterTypeId Class See Also Send Feedback
"End Mz"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralEndReleaseMz { get; }
Visual Basic
Public Shared ReadOnly Property StructuralEndReleaseMz As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralEndReleaseMz {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralEndReleaseType Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralEndReleaseType Property
ParameterTypeId Class See Also Send Feedback
"End Release"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralEndReleaseType { get; }
Visual Basic
Public Shared ReadOnly Property StructuralEndReleaseType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralEndReleaseType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralFamilyCodeName Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralFamilyCodeName Property
ParameterTypeId Class See Also Send Feedback
"Code Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralFamilyCodeName { get; }
Visual Basic
Public Shared ReadOnly Property StructuralFamilyCodeName As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralFamilyCodeName {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralFloorAnalyzesAs Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralFloorAnalyzesAs Property
ParameterTypeId Class See Also Send Feedback
"Analyze As"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralFloorAnalyzesAs { get; }
Visual Basic
Public Shared ReadOnly Property StructuralFloorAnalyzesAs As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralFloorAnalyzesAs {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralFloorCoreThickness Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralFloorCoreThickness Property
ParameterTypeId Class See Also Send Feedback
"Core Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralFloorCoreThickness { get; }
Visual Basic
Public Shared ReadOnly Property StructuralFloorCoreThickness As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralFloorCoreThickness {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralFoundationWidth Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralFoundationWidth Property
ParameterTypeId Class See Also Send Feedback
"Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralFoundationWidth { get; }
Visual Basic
Public Shared ReadOnly Property StructuralFoundationWidth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralFoundationWidth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralMaterialType Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralMaterialType Property
ParameterTypeId Class See Also Send Feedback
"Structural Material Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralMaterialType { get; }
Visual Basic
Public Shared ReadOnly Property StructuralMaterialType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralMaterialType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralMemberForces Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralMemberForces Property
ParameterTypeId Class See Also Send Feedback
"Member Forces"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralMemberForces { get; }
Visual Basic
Public Shared ReadOnly Property StructuralMemberForces As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralMemberForces {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralNumberOfStuds Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralNumberOfStuds Property
ParameterTypeId Class See Also Send Feedback
"Number of studs"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralNumberOfStuds { get; }
Visual Basic
Public Shared ReadOnly Property StructuralNumberOfStuds As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralNumberOfStuds {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralReferenceLevelElevation Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralReferenceLevelElevation Property
ParameterTypeId Class See Also Send Feedback
"Reference Level Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralReferenceLevelElevation { get; }
Visual Basic
Public Shared ReadOnly Property StructuralReferenceLevelElevation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralReferenceLevelElevation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionArea Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionArea Property
ParameterTypeId Class See Also Send Feedback
"Section Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionArea { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionArea As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionArea {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionBottomCutHeight Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionBottomCutHeight Property
ParameterTypeId Class See Also Send Feedback
"Bottom Cut Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionBottomCutHeight { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionBottomCutHeight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionBottomCutHeight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionBottomCutWidth Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionBottomCutWidth Property
ParameterTypeId Class See Also Send Feedback
"Bottom Cut Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionBottomCutWidth { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionBottomCutWidth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionBottomCutWidth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionCantileverHeight Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionCantileverHeight Property
ParameterTypeId Class See Also Send Feedback
"Cantilever Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionCantileverHeight { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionCantileverHeight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionCantileverHeight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionCantileverLength Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionCantileverLength Property
ParameterTypeId Class See Also Send Feedback
"Cantilever Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionCantileverLength { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionCantileverLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionCantileverLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionCommonAlpha Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionCommonAlpha Property
ParameterTypeId Class See Also Send Feedback
"Principal Axes Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionCommonAlpha { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionCommonAlpha As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionCommonAlpha {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionCommonCentroidHoriz Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionCommonCentroidHoriz Property
ParameterTypeId Class See Also Send Feedback
"Centroid Horizontal"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionCommonCentroidHoriz { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionCommonCentroidHoriz As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionCommonCentroidHoriz {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionCommonCentroidVertical Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionCommonCentroidVertical Property
ParameterTypeId Class See Also Send Feedback
"Centroid Vertical"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionCommonCentroidVertical { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionCommonCentroidVertical As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionCommonCentroidVertical {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionCommonDiameter Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionCommonDiameter Property
ParameterTypeId Class See Also Send Feedback
"Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionCommonDiameter { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionCommonDiameter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionCommonDiameter {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionCommonElasticModulusStrongAxis Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionCommonElasticModulusStrongAxis Property
ParameterTypeId Class See Also Send Feedback
"Elastic Modulus strong axis"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionCommonElasticModulusStrongAxis { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionCommonElasticModulusStrongAxis As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionCommonElasticModulusStrongAxis {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionCommonElasticModulusWeakAxis Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionCommonElasticModulusWeakAxis Property
ParameterTypeId Class See Also Send Feedback
"Elastic Modulus weak axis"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionCommonElasticModulusWeakAxis { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionCommonElasticModulusWeakAxis As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionCommonElasticModulusWeakAxis {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionCommonHeight Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionCommonHeight Property
ParameterTypeId Class See Also Send Feedback
"Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionCommonHeight { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionCommonHeight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionCommonHeight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionCommonMomentOfInertiaStrongAxis Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionCommonMomentOfInertiaStrongAxis Property
ParameterTypeId Class See Also Send Feedback
"Moment of Inertia strong axis"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionCommonMomentOfInertiaStrongAxis { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionCommonMomentOfInertiaStrongAxis As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionCommonMomentOfInertiaStrongAxis {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionCommonMomentOfInertiaWeakAxis Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionCommonMomentOfInertiaWeakAxis Property
ParameterTypeId Class See Also Send Feedback
"Moment of Inertia weak axis"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionCommonMomentOfInertiaWeakAxis { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionCommonMomentOfInertiaWeakAxis As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionCommonMomentOfInertiaWeakAxis {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionCommonNominalWeight Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionCommonNominalWeight Property
ParameterTypeId Class See Also Send Feedback
"Nominal Weight"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionCommonNominalWeight { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionCommonNominalWeight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionCommonNominalWeight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionCommonPlasticModulusStrongAxis Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionCommonPlasticModulusStrongAxis Property
ParameterTypeId Class See Also Send Feedback
"Plastic Modulus strong axis"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionCommonPlasticModulusStrongAxis { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionCommonPlasticModulusStrongAxis As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionCommonPlasticModulusStrongAxis {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionCommonPlasticModulusWeakAxis Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionCommonPlasticModulusWeakAxis Property
ParameterTypeId Class See Also Send Feedback
"Plastic Modulus weak axis"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionCommonPlasticModulusWeakAxis { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionCommonPlasticModulusWeakAxis As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionCommonPlasticModulusWeakAxis {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionCommonShearAreaWeakAxis Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionCommonShearAreaWeakAxis Property
ParameterTypeId Class See Also Send Feedback
"Shear Area weak axis"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionCommonShearAreaWeakAxis { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionCommonShearAreaWeakAxis As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionCommonShearAreaWeakAxis {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionCommonTorsionalModulus Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionCommonTorsionalModulus Property
ParameterTypeId Class See Also Send Feedback
"Torsional Modulus"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionCommonTorsionalModulus { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionCommonTorsionalModulus As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionCommonTorsionalModulus {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionCommonTorsionalMomentOfInertia Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionCommonTorsionalMomentOfInertia Property
ParameterTypeId Class See Also Send Feedback
"Torsional Moment of Inertia"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionCommonTorsionalMomentOfInertia { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionCommonTorsionalMomentOfInertia As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionCommonTorsionalMomentOfInertia {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionCommonWarpingConstant Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionCommonWarpingConstant Property
ParameterTypeId Class See Also Send Feedback
"Warping Constant"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionCommonWarpingConstant { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionCommonWarpingConstant As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionCommonWarpingConstant {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionCommonWidth Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionCommonWidth Property
ParameterTypeId Class See Also Send Feedback
"Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionCommonWidth { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionCommonWidth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionCommonWidth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionHssInnerfillet Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionHssInnerfillet Property
ParameterTypeId Class See Also Send Feedback
"Inner Fillet"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionHssInnerfillet { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionHssInnerfillet As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionHssInnerfillet {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionHssOuterfillet Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionHssOuterfillet Property
ParameterTypeId Class See Also Send Feedback
"Outer Fillet"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionHssOuterfillet { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionHssOuterfillet As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionHssOuterfillet {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionIshapeBoltDiameter Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionIshapeBoltDiameter Property
ParameterTypeId Class See Also Send Feedback
"Bolt Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionIshapeBoltDiameter { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionIshapeBoltDiameter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionIshapeBoltDiameter {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionIshapeBoltSpacing Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionIshapeBoltSpacing Property
ParameterTypeId Class See Also Send Feedback
"Bolt Spacing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionIshapeBoltSpacing { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionIshapeBoltSpacing As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionIshapeBoltSpacing {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionIshapeBoltSpacingBetweenRows Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionIshapeBoltSpacingBetweenRows Property
ParameterTypeId Class See Also Send Feedback
"Bolt Spacing between Rows"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionIshapeBoltSpacingBetweenRows { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionIshapeBoltSpacingBetweenRows As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionIshapeBoltSpacingBetweenRows {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionIshapeBoltSpacingTwoRows Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionIshapeBoltSpacingTwoRows Property
ParameterTypeId Class See Also Send Feedback
"Bolt Spacing Two Rows"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionIshapeBoltSpacingTwoRows { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionIshapeBoltSpacingTwoRows As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionIshapeBoltSpacingTwoRows {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionIshapeBoltSpacingWeb Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionIshapeBoltSpacingWeb Property
ParameterTypeId Class See Also Send Feedback
"Bolt Spacing web"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionIshapeBoltSpacingWeb { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionIshapeBoltSpacingWeb As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionIshapeBoltSpacingWeb {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionIshapeFlangefillet Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionIshapeFlangefillet Property
ParameterTypeId Class See Also Send Feedback
"Flange Fillet"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionIshapeFlangefillet { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionIshapeFlangefillet As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionIshapeFlangefillet {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionIshapeFlangethickness Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionIshapeFlangethickness Property
ParameterTypeId Class See Also Send Feedback
"Flange Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionIshapeFlangethickness { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionIshapeFlangethickness As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionIshapeFlangethickness {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionIshapeFlangethicknessLocation Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionIshapeFlangethicknessLocation Property
ParameterTypeId Class See Also Send Feedback
"Flange Thickness Location"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionIshapeFlangethicknessLocation { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionIshapeFlangethicknessLocation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionIshapeFlangethicknessLocation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionIshapeFlangeToeOfFillet Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionIshapeFlangeToeOfFillet Property
ParameterTypeId Class See Also Send Feedback
"Flange Toe of Fillet"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionIshapeFlangeToeOfFillet { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionIshapeFlangeToeOfFillet As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionIshapeFlangeToeOfFillet {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionIshapeWebfillet Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionIshapeWebfillet Property
ParameterTypeId Class See Also Send Feedback
"Web Fillet"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionIshapeWebfillet { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionIshapeWebfillet As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionIshapeWebfillet {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionIshapeWebthickness Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionIshapeWebthickness Property
ParameterTypeId Class See Also Send Feedback
"Web Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionIshapeWebthickness { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionIshapeWebthickness As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionIshapeWebthickness {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionIshapeWebthicknessLocation Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionIshapeWebthicknessLocation Property
ParameterTypeId Class See Also Send Feedback
"Web Thickness Location"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionIshapeWebthicknessLocation { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionIshapeWebthicknessLocation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionIshapeWebthicknessLocation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionIshapeWebToeOfFillet Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionIshapeWebToeOfFillet Property
ParameterTypeId Class See Also Send Feedback
"Web Toe of Fillet"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionIshapeWebToeOfFillet { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionIshapeWebToeOfFillet As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionIshapeWebToeOfFillet {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionIweldedBottomflangewidth Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionIweldedBottomflangewidth Property
ParameterTypeId Class See Also Send Feedback
"Bottom Flange Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionIweldedBottomflangewidth { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionIweldedBottomflangewidth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionIweldedBottomflangewidth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionIweldedTopflangethickness Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionIweldedTopflangethickness Property
ParameterTypeId Class See Also Send Feedback
"Top Flange Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionIweldedTopflangethickness { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionIweldedTopflangethickness As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionIweldedTopflangethickness {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionIweldedTopflangewidth Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionIweldedTopflangewidth Property
ParameterTypeId Class See Also Send Feedback
"Top Flange Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionIweldedTopflangewidth { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionIweldedTopflangewidth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionIweldedTopflangewidth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionLangleBoltDiameterShorterFlange Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionLangleBoltDiameterShorterFlange Property
ParameterTypeId Class See Also Send Feedback
"Bolt Diameter Shorter Flange"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionLangleBoltDiameterShorterFlange { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionLangleBoltDiameterShorterFlange As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionLangleBoltDiameterShorterFlange {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionLangleBoltSpacing1LongerFlange Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionLangleBoltSpacing1LongerFlange Property
ParameterTypeId Class See Also Send Feedback
"Bolt Spacing 1 Longer Flange"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionLangleBoltSpacing1LongerFlange { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionLangleBoltSpacing1LongerFlange As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionLangleBoltSpacing1LongerFlange {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionLangleBoltSpacing2LongerFlange Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionLangleBoltSpacing2LongerFlange Property
ParameterTypeId Class See Also Send Feedback
"Bolt Spacing 2 Longer Flange"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionLangleBoltSpacing2LongerFlange { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionLangleBoltSpacing2LongerFlange As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionLangleBoltSpacing2LongerFlange {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionLangleBoltSpacingShorterFlange Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionLangleBoltSpacingShorterFlange Property
ParameterTypeId Class See Also Send Feedback
"Bolt Spacing Shorter Flange"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionLangleBoltSpacingShorterFlange { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionLangleBoltSpacingShorterFlange As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionLangleBoltSpacingShorterFlange {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionLprofileLipLength Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionLprofileLipLength Property
ParameterTypeId Class See Also Send Feedback
"Lip Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionLprofileLipLength { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionLprofileLipLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionLprofileLipLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionNameKey Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionNameKey Property
ParameterTypeId Class See Also Send Feedback
"Section Name Key"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionNameKey { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionNameKey As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionNameKey {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionPipestandardWallnominalthickness Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionPipestandardWallnominalthickness Property
ParameterTypeId Class See Also Send Feedback
"Wall Nominal Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionPipestandardWallnominalthickness { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionPipestandardWallnominalthickness As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionPipestandardWallnominalthickness {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionShape Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionShape Property
ParameterTypeId Class See Also Send Feedback
"Section Shape"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionShape { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionShape As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionShape {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionSigmaProfileMiddleBendWidth Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionSigmaProfileMiddleBendWidth Property
ParameterTypeId Class See Also Send Feedback
"Middle Bend Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionSigmaProfileMiddleBendWidth { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionSigmaProfileMiddleBendWidth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionSigmaProfileMiddleBendWidth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionSigmaProfileTopBendWidth Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionSigmaProfileTopBendWidth Property
ParameterTypeId Class See Also Send Feedback
"Top Bend Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionSigmaProfileTopBendWidth { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionSigmaProfileTopBendWidth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionSigmaProfileTopBendWidth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionSlopedFlangeAngle Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionSlopedFlangeAngle Property
ParameterTypeId Class See Also Send Feedback
"Sloped Flange Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionSlopedFlangeAngle { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionSlopedFlangeAngle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionSlopedFlangeAngle {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionSlopedWebAngle Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionSlopedWebAngle Property
ParameterTypeId Class See Also Send Feedback
"Sloped Web Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionSlopedWebAngle { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionSlopedWebAngle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionSlopedWebAngle {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionTopCutHeight Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionTopCutHeight Property
ParameterTypeId Class See Also Send Feedback
"Top Cut Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionTopCutHeight { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionTopCutHeight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionTopCutHeight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionTopCutWidth Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionTopCutWidth Property
ParameterTypeId Class See Also Send Feedback
"Top Cut Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionTopCutWidth { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionTopCutWidth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionTopCutWidth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionTopWebFillet Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionTopWebFillet Property
ParameterTypeId Class See Also Send Feedback
"Top Web Fillet"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionTopWebFillet { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionTopWebFillet As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionTopWebFillet {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralSectionZprofileBottomFlangeLength Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralSectionZprofileBottomFlangeLength Property
ParameterTypeId Class See Also Send Feedback
"Bottom Flange Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralSectionZprofileBottomFlangeLength { get; }
Visual Basic
Public Shared ReadOnly Property StructuralSectionZprofileBottomFlangeLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralSectionZprofileBottomFlangeLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralStartReleaseFx Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralStartReleaseFx Property
ParameterTypeId Class See Also Send Feedback
"Start Fx"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralStartReleaseFx { get; }
Visual Basic
Public Shared ReadOnly Property StructuralStartReleaseFx As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralStartReleaseFx {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralStartReleaseFy Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralStartReleaseFy Property
ParameterTypeId Class See Also Send Feedback
"Start Fy"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralStartReleaseFy { get; }
Visual Basic
Public Shared ReadOnly Property StructuralStartReleaseFy As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralStartReleaseFy {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralStartReleaseFz Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralStartReleaseFz Property
ParameterTypeId Class See Also Send Feedback
"Start Fz"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralStartReleaseFz { get; }
Visual Basic
Public Shared ReadOnly Property StructuralStartReleaseFz As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralStartReleaseFz {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralStartReleaseMx Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralStartReleaseMx Property
ParameterTypeId Class See Also Send Feedback
"Start Mx"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralStartReleaseMx { get; }
Visual Basic
Public Shared ReadOnly Property StructuralStartReleaseMx As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralStartReleaseMx {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralStartReleaseMy Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralStartReleaseMy Property
ParameterTypeId Class See Also Send Feedback
"Start My"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralStartReleaseMy { get; }
Visual Basic
Public Shared ReadOnly Property StructuralStartReleaseMy As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralStartReleaseMy {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralStartReleaseType Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralStartReleaseType Property
ParameterTypeId Class See Also Send Feedback
"Start Release"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralStartReleaseType { get; }
Visual Basic
Public Shared ReadOnly Property StructuralStartReleaseType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralStartReleaseType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralStickSymbolLocation Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralStickSymbolLocation Property
ParameterTypeId Class See Also Send Feedback
"Stick Symbol Location"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralStickSymbolLocation { get; }
Visual Basic
Public Shared ReadOnly Property StructuralStickSymbolLocation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralStickSymbolLocation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralTopReleaseFx Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralTopReleaseFx Property
ParameterTypeId Class See Also Send Feedback
"Top Fx"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralTopReleaseFx { get; }
Visual Basic
Public Shared ReadOnly Property StructuralTopReleaseFx As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralTopReleaseFx {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralTopReleaseFy Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralTopReleaseFy Property
ParameterTypeId Class See Also Send Feedback
"Top Fy"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralTopReleaseFy { get; }
Visual Basic
Public Shared ReadOnly Property StructuralTopReleaseFy As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralTopReleaseFy {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralTopReleaseFz Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralTopReleaseFz Property
ParameterTypeId Class See Also Send Feedback
"Top Fz"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralTopReleaseFz { get; }
Visual Basic
Public Shared ReadOnly Property StructuralTopReleaseFz As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralTopReleaseFz {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralTopReleaseMx Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralTopReleaseMx Property
ParameterTypeId Class See Also Send Feedback
"Top Mx"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralTopReleaseMx { get; }
Visual Basic
Public Shared ReadOnly Property StructuralTopReleaseMx As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralTopReleaseMx {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralTopReleaseMy Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralTopReleaseMy Property
ParameterTypeId Class See Also Send Feedback
"Top My"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralTopReleaseMy { get; }
Visual Basic
Public Shared ReadOnly Property StructuralTopReleaseMy As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralTopReleaseMy {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralTopReleaseType Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralTopReleaseType Property
ParameterTypeId Class See Also Send Feedback
"Top Release"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralTopReleaseType { get; }
Visual Basic
Public Shared ReadOnly Property StructuralTopReleaseType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralTopReleaseType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralWallBottomProjectionPlane Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralWallBottomProjectionPlane Property
ParameterTypeId Class See Also Send Feedback
"Bottom Vertical Projection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralWallBottomProjectionPlane { get; }
Visual Basic
Public Shared ReadOnly Property StructuralWallBottomProjectionPlane As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralWallBottomProjectionPlane {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralWallProjectionSurface Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralWallProjectionSurface Property
ParameterTypeId Class See Also Send Feedback
"Horizontal Projection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralWallProjectionSurface { get; }
Visual Basic
Public Shared ReadOnly Property StructuralWallProjectionSurface As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralWallProjectionSurface {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


StructuralWallTopProjectionPlane Property

[image]

Revit 2024 API
ParameterTypeId..::..StructuralWallTopProjectionPlane Property
ParameterTypeId Class See Also Send Feedback
"Top Vertical Projection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId StructuralWallTopProjectionPlane { get; }
Visual Basic
Public Shared ReadOnly Property StructuralWallTopProjectionPlane As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralWallTopProjectionPlane {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SupportHandClearance Property

[image]

Revit 2024 API
ParameterTypeId..::..SupportHandClearance Property
ParameterTypeId Class See Also Send Feedback
"Hand Clearance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SupportHandClearance { get; }
Visual Basic
Public Shared ReadOnly Property SupportHandClearance As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SupportHandClearance {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SupportHeight Property

[image]

Revit 2024 API
ParameterTypeId..::..SupportHeight Property
ParameterTypeId Class See Also Send Feedback
"Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SupportHeight { get; }
Visual Basic
Public Shared ReadOnly Property SupportHeight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SupportHeight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SurfaceArea Property

[image]

Revit 2024 API
ParameterTypeId..::..SurfaceArea Property
ParameterTypeId Class See Also Send Feedback
"Surface Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SurfaceArea { get; }
Visual Basic
Public Shared ReadOnly Property SurfaceArea As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SurfaceArea {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SurfaceName Property

[image]

Revit 2024 API
ParameterTypeId..::..SurfaceName Property
ParameterTypeId Class See Also Send Feedback
"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SurfaceName { get; }
Visual Basic
Public Shared ReadOnly Property SurfaceName As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SurfaceName {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SurfacePatternIdParam Property

[image]

Revit 2024 API
ParameterTypeId..::..SurfacePatternIdParam Property
ParameterTypeId Class See Also Send Feedback
"Surface fill pattern"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SurfacePatternIdParam { get; }
Visual Basic
Public Shared ReadOnly Property SurfacePatternIdParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SurfacePatternIdParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SurfacePerimeter Property

[image]

Revit 2024 API
ParameterTypeId..::..SurfacePerimeter Property
ParameterTypeId Class See Also Send Feedback
"Perimeter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SurfacePerimeter { get; }
Visual Basic
Public Shared ReadOnly Property SurfacePerimeter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SurfacePerimeter {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SweepBaseFloorSubcategoryId Property

[image]

Revit 2024 API
ParameterTypeId..::..SweepBaseFloorSubcategoryId Property
ParameterTypeId Class See Also Send Feedback
"Subcategory of Floors"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SweepBaseFloorSubcategoryId { get; }
Visual Basic
Public Shared ReadOnly Property SweepBaseFloorSubcategoryId As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SweepBaseFloorSubcategoryId {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SweepBaseOffset Property

[image]

Revit 2024 API
ParameterTypeId..::..SweepBaseOffset Property
ParameterTypeId Class See Also Send Feedback
"Horizontal Profile Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SweepBaseOffset { get; }
Visual Basic
Public Shared ReadOnly Property SweepBaseOffset As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SweepBaseOffset {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SweepBaseRoofSubcategoryId Property

[image]

Revit 2024 API
ParameterTypeId..::..SweepBaseRoofSubcategoryId Property
ParameterTypeId Class See Also Send Feedback
"Subcategory of Roofs"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SweepBaseRoofSubcategoryId { get; }
Visual Basic
Public Shared ReadOnly Property SweepBaseRoofSubcategoryId As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SweepBaseRoofSubcategoryId {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SweepBaseVertOffset Property

[image]

Revit 2024 API
ParameterTypeId..::..SweepBaseVertOffset Property
ParameterTypeId Class See Also Send Feedback
"Vertical Profile Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SweepBaseVertOffset { get; }
Visual Basic
Public Shared ReadOnly Property SweepBaseVertOffset As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SweepBaseVertOffset {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SweepMaxSegAngle Property

[image]

Revit 2024 API
ParameterTypeId..::..SweepMaxSegAngle Property
ParameterTypeId Class See Also Send Feedback
"Maximum Segment Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SweepMaxSegAngle { get; }
Visual Basic
Public Shared ReadOnly Property SweepMaxSegAngle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SweepMaxSegAngle {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SweepTrajSegmented Property

[image]

Revit 2024 API
ParameterTypeId..::..SweepTrajSegmented Property
ParameterTypeId Class See Also Send Feedback
"Trajectory Segmentation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SweepTrajSegmented { get; }
Visual Basic
Public Shared ReadOnly Property SweepTrajSegmented As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SweepTrajSegmented {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SymbolFamilyNameParam Property

[image]

Revit 2024 API
ParameterTypeId..::..SymbolFamilyNameParam Property
ParameterTypeId Class See Also Send Feedback
"Family Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SymbolFamilyNameParam { get; }
Visual Basic
Public Shared ReadOnly Property SymbolFamilyNameParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SymbolFamilyNameParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SymbolNameParam Property

[image]

Revit 2024 API
ParameterTypeId..::..SymbolNameParam Property
ParameterTypeId Class See Also Send Feedback
"Type Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SymbolNameParam { get; }
Visual Basic
Public Shared ReadOnly Property SymbolNameParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SymbolNameParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SystemEquipmentSets Property

[image]

Revit 2024 API
ParameterTypeId..::..SystemEquipmentSets Property
ParameterTypeId Class See Also Send Feedback
"Equipment Sets"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SystemEquipmentSets { get; }
Visual Basic
Public Shared ReadOnly Property SystemEquipmentSets As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SystemEquipmentSets {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SystemsAnalysisReportFolder Property

[image]

Revit 2024 API
ParameterTypeId..::..SystemsAnalysisReportFolder Property
ParameterTypeId Class See Also Send Feedback
"Reports Folder Path"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SystemsAnalysisReportFolder { get; }
Visual Basic
Public Shared ReadOnly Property SystemsAnalysisReportFolder As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SystemsAnalysisReportFolder {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SystemsAnalysisReportStyle Property

[image]

Revit 2024 API
ParameterTypeId..::..SystemsAnalysisReportStyle Property
ParameterTypeId Class See Also Send Feedback
"Report Style"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SystemsAnalysisReportStyle { get; }
Visual Basic
Public Shared ReadOnly Property SystemsAnalysisReportStyle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SystemsAnalysisReportStyle {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


SystemZoneLevelId Property

[image]

Revit 2024 API
ParameterTypeId..::..SystemZoneLevelId Property
ParameterTypeId Class See Also Send Feedback
"Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId SystemZoneLevelId { get; }
Visual Basic
Public Shared ReadOnly Property SystemZoneLevelId As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SystemZoneLevelId {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TagAngleParam Property

[image]

Revit 2024 API
ParameterTypeId..::..TagAngleParam Property
ParameterTypeId Class See Also Send Feedback
"Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TagAngleParam { get; }
Visual Basic
Public Shared ReadOnly Property TagAngleParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TagAngleParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TagElementCount Property

[image]

Revit 2024 API
ParameterTypeId..::..TagElementCount Property
ParameterTypeId Class See Also Send Feedback
"Host Count"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TagElementCount { get; }
Visual Basic
Public Shared ReadOnly Property TagElementCount As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TagElementCount {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TagElevationBase Property

[image]

Revit 2024 API
ParameterTypeId..::..TagElevationBase Property
ParameterTypeId Class See Also Send Feedback
"Elevation Base"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TagElevationBase { get; }
Visual Basic
Public Shared ReadOnly Property TagElevationBase As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TagElevationBase {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TagLeaderType Property

[image]

Revit 2024 API
ParameterTypeId..::..TagLeaderType Property
ParameterTypeId Class See Also Send Feedback
"Leader Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TagLeaderType { get; }
Visual Basic
Public Shared ReadOnly Property TagLeaderType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TagLeaderType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TagNoBreakParamStrings Property

[image]

Revit 2024 API
ParameterTypeId..::..TagNoBreakParamStrings Property
ParameterTypeId Class See Also Send Feedback
"Wrap between parameters only"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TagNoBreakParamStrings { get; }
Visual Basic
Public Shared ReadOnly Property TagNoBreakParamStrings As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TagNoBreakParamStrings {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TagOnPlacementUi Property

[image]

Revit 2024 API
ParameterTypeId..::..TagOnPlacementUi Property
ParameterTypeId Class See Also Send Feedback
"Tag on Placement"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TagOnPlacementUi { get; }
Visual Basic
Public Shared ReadOnly Property TagOnPlacementUi As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TagOnPlacementUi {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TagTag Property

[image]

Revit 2024 API
ParameterTypeId..::..TagTag Property
ParameterTypeId Class See Also Send Feedback
"Label"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TagTag { get; }
Visual Basic
Public Shared ReadOnly Property TagTag As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TagTag {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TerminationExtensionLength Property

[image]

Revit 2024 API
ParameterTypeId..::..TerminationExtensionLength Property
ParameterTypeId Class See Also Send Feedback
"Extension Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TerminationExtensionLength { get; }
Visual Basic
Public Shared ReadOnly Property TerminationExtensionLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TerminationExtensionLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TextAlignHorz Property

[image]

Revit 2024 API
ParameterTypeId..::..TextAlignHorz Property
ParameterTypeId Class See Also Send Feedback
"Horizontal Align"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TextAlignHorz { get; }
Visual Basic
Public Shared ReadOnly Property TextAlignHorz As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TextAlignHorz {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TextAlignment Property

[image]

Revit 2024 API
ParameterTypeId..::..TextAlignment Property
ParameterTypeId Class See Also Send Feedback
"Text Alignment"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TextAlignment { get; }
Visual Basic
Public Shared ReadOnly Property TextAlignment As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TextAlignment {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TextAlignVert Property

[image]

Revit 2024 API
ParameterTypeId..::..TextAlignVert Property
ParameterTypeId Class See Also Send Feedback
"Vertical Align"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TextAlignVert { get; }
Visual Basic
Public Shared ReadOnly Property TextAlignVert As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TextAlignVert {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TextBoxVisibility Property

[image]

Revit 2024 API
ParameterTypeId..::..TextBoxVisibility Property
ParameterTypeId Class See Also Send Feedback
"Show Border"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TextBoxVisibility { get; }
Visual Basic
Public Shared ReadOnly Property TextBoxVisibility As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TextBoxVisibility {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TextColor Property

[image]

Revit 2024 API
ParameterTypeId..::..TextColor Property
ParameterTypeId Class See Also Send Feedback
"Color"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TextColor { get; }
Visual Basic
Public Shared ReadOnly Property TextColor As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TextColor {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TextDistToLine Property

[image]

Revit 2024 API
ParameterTypeId..::..TextDistToLine Property
ParameterTypeId Class See Also Send Feedback
"Text Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TextDistToLine { get; }
Visual Basic
Public Shared ReadOnly Property TextDistToLine As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TextDistToLine {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TextFont Property

[image]

Revit 2024 API
ParameterTypeId..::..TextFont Property
ParameterTypeId Class See Also Send Feedback
"Text Font"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TextFont { get; }
Visual Basic
Public Shared ReadOnly Property TextFont As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TextFont {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TextPosition Property

[image]

Revit 2024 API
ParameterTypeId..::..TextPosition Property
ParameterTypeId Class See Also Send Feedback
"Text Position"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TextPosition { get; }
Visual Basic
Public Shared ReadOnly Property TextPosition As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TextPosition {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TextSize Property

[image]

Revit 2024 API
ParameterTypeId..::..TextSize Property
ParameterTypeId Class See Also Send Feedback
"Text Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TextSize { get; }
Visual Basic
Public Shared ReadOnly Property TextSize As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TextSize {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TextStyleBold Property

[image]

Revit 2024 API
ParameterTypeId..::..TextStyleBold Property
ParameterTypeId Class See Also Send Feedback
"Bold"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TextStyleBold { get; }
Visual Basic
Public Shared ReadOnly Property TextStyleBold As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TextStyleBold {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TextStyleFont Property

[image]

Revit 2024 API
ParameterTypeId..::..TextStyleFont Property
ParameterTypeId Class See Also Send Feedback
"Font"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TextStyleFont { get; }
Visual Basic
Public Shared ReadOnly Property TextStyleFont As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TextStyleFont {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TextStyleSize Property

[image]

Revit 2024 API
ParameterTypeId..::..TextStyleSize Property
ParameterTypeId Class See Also Send Feedback
"Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TextStyleSize { get; }
Visual Basic
Public Shared ReadOnly Property TextStyleSize As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TextStyleSize {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TextText Property

[image]

Revit 2024 API
ParameterTypeId..::..TextText Property
ParameterTypeId Class See Also Send Feedback
"Text"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TextText { get; }
Visual Basic
Public Shared ReadOnly Property TextText As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TextText {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TextWidthScale Property

[image]

Revit 2024 API
ParameterTypeId..::..TextWidthScale Property
ParameterTypeId Class See Also Send Feedback
"Width Factor"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TextWidthScale { get; }
Visual Basic
Public Shared ReadOnly Property TextWidthScale As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TextWidthScale {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ThermalMaterialParamCompressibility Property

[image]

Revit 2024 API
ParameterTypeId..::..ThermalMaterialParamCompressibility Property
ParameterTypeId Class See Also Send Feedback
"Compressibility"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ThermalMaterialParamCompressibility { get; }
Visual Basic
Public Shared ReadOnly Property ThermalMaterialParamCompressibility As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ThermalMaterialParamCompressibility {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ThermalMaterialParamElectricalResistivity Property

[image]

Revit 2024 API
ParameterTypeId..::..ThermalMaterialParamElectricalResistivity Property
ParameterTypeId Class See Also Send Feedback
"Electrical Resistivity"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ThermalMaterialParamElectricalResistivity { get; }
Visual Basic
Public Shared ReadOnly Property ThermalMaterialParamElectricalResistivity As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ThermalMaterialParamElectricalResistivity {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ThermalMaterialParamGasViscosity Property

[image]

Revit 2024 API
ParameterTypeId..::..ThermalMaterialParamGasViscosity Property
ParameterTypeId Class See Also Send Feedback
"Gas Viscosity"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ThermalMaterialParamGasViscosity { get; }
Visual Basic
Public Shared ReadOnly Property ThermalMaterialParamGasViscosity As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ThermalMaterialParamGasViscosity {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ThermalMaterialParamLiquidViscosity Property

[image]

Revit 2024 API
ParameterTypeId..::..ThermalMaterialParamLiquidViscosity Property
ParameterTypeId Class See Also Send Feedback
"Liquid Viscosity"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ThermalMaterialParamLiquidViscosity { get; }
Visual Basic
Public Shared ReadOnly Property ThermalMaterialParamLiquidViscosity As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ThermalMaterialParamLiquidViscosity {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ThermalMaterialParamPorosity Property

[image]

Revit 2024 API
ParameterTypeId..::..ThermalMaterialParamPorosity Property
ParameterTypeId Class See Also Send Feedback
"Porosity"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ThermalMaterialParamPorosity { get; }
Visual Basic
Public Shared ReadOnly Property ThermalMaterialParamPorosity As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ThermalMaterialParamPorosity {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ThermalMaterialParamReflectivity Property

[image]

Revit 2024 API
ParameterTypeId..::..ThermalMaterialParamReflectivity Property
ParameterTypeId Class See Also Send Feedback
"Reflectivity"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ThermalMaterialParamReflectivity { get; }
Visual Basic
Public Shared ReadOnly Property ThermalMaterialParamReflectivity As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ThermalMaterialParamReflectivity {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ThermalMaterialParamTransmitsLight Property

[image]

Revit 2024 API
ParameterTypeId..::..ThermalMaterialParamTransmitsLight Property
ParameterTypeId Class See Also Send Feedback
"Transmits Light"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ThermalMaterialParamTransmitsLight { get; }
Visual Basic
Public Shared ReadOnly Property ThermalMaterialParamTransmitsLight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ThermalMaterialParamTransmitsLight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TickMarkPen Property

[image]

Revit 2024 API
ParameterTypeId..::..TickMarkPen Property
ParameterTypeId Class See Also Send Feedback
"Tick Mark Line Weight"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TickMarkPen { get; }
Visual Basic
Public Shared ReadOnly Property TickMarkPen As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TickMarkPen {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TilePatternGridCellsX Property

[image]

Revit 2024 API
ParameterTypeId..::..TilePatternGridCellsX Property
ParameterTypeId Class See Also Send Feedback
"Number of horizontal cells"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TilePatternGridCellsX { get; }
Visual Basic
Public Shared ReadOnly Property TilePatternGridCellsX As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TilePatternGridCellsX {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TilePatternGridCellsY Property

[image]

Revit 2024 API
ParameterTypeId..::..TilePatternGridCellsY Property
ParameterTypeId Class See Also Send Feedback
"Number of vertical cells"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TilePatternGridCellsY { get; }
Visual Basic
Public Shared ReadOnly Property TilePatternGridCellsY As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TilePatternGridCellsY {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TilePatternGridUnitY Property

[image]

Revit 2024 API
ParameterTypeId..::..TilePatternGridUnitY Property
ParameterTypeId Class See Also Send Feedback
"Vertical spacing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TilePatternGridUnitY { get; }
Visual Basic
Public Shared ReadOnly Property TilePatternGridUnitY As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TilePatternGridUnitY {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TitleFont Property

[image]

Revit 2024 API
ParameterTypeId..::..TitleFont Property
ParameterTypeId Class See Also Send Feedback
"Font"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TitleFont { get; }
Visual Basic
Public Shared ReadOnly Property TitleFont As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TitleFont {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TitleStyleBold Property

[image]

Revit 2024 API
ParameterTypeId..::..TitleStyleBold Property
ParameterTypeId Class See Also Send Feedback
"Bold"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TitleStyleBold { get; }
Visual Basic
Public Shared ReadOnly Property TitleStyleBold As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TitleStyleBold {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TitleStyleItalic Property

[image]

Revit 2024 API
ParameterTypeId..::..TitleStyleItalic Property
ParameterTypeId Class See Also Send Feedback
"Italic"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TitleStyleItalic { get; }
Visual Basic
Public Shared ReadOnly Property TitleStyleItalic As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TitleStyleItalic {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TitleStyleUnderline Property

[image]

Revit 2024 API
ParameterTypeId..::..TitleStyleUnderline Property
ParameterTypeId Class See Also Send Feedback
"Underline"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TitleStyleUnderline { get; }
Visual Basic
Public Shared ReadOnly Property TitleStyleUnderline As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TitleStyleUnderline {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TopographyLinkPath Property

[image]

Revit 2024 API
ParameterTypeId..::..TopographyLinkPath Property
ParameterTypeId Class See Also Send Feedback
"Saved Path"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TopographyLinkPath { get; }
Visual Basic
Public Shared ReadOnly Property TopographyLinkPath As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TopographyLinkPath {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ToposolidContourDisplaySettingsIdParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ToposolidContourDisplaySettingsIdParam Property
ParameterTypeId Class See Also Send Feedback
"Contour Display"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ToposolidContourDisplaySettingsIdParam { get; }
Visual Basic
Public Shared ReadOnly Property ToposolidContourDisplaySettingsIdParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ToposolidContourDisplaySettingsIdParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ToposolidContourSubcategoryId Property

[image]

Revit 2024 API
ParameterTypeId..::..ToposolidContourSubcategoryId Property
ParameterTypeId Class See Also Send Feedback
"Subcategory"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ToposolidContourSubcategoryId { get; }
Visual Basic
Public Shared ReadOnly Property ToposolidContourSubcategoryId As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ToposolidContourSubcategoryId {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ToposolidElevationAtBottom Property

[image]

Revit 2024 API
ParameterTypeId..::..ToposolidElevationAtBottom Property
ParameterTypeId Class See Also Send Feedback
"Elevation at Bottom"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ToposolidElevationAtBottom { get; }
Visual Basic
Public Shared ReadOnly Property ToposolidElevationAtBottom As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ToposolidElevationAtBottom {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ToposolidInheritContours Property

[image]

Revit 2024 API
ParameterTypeId..::..ToposolidInheritContours Property
ParameterTypeId Class See Also Send Feedback
"Inherit Contours"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ToposolidInheritContours { get; }
Visual Basic
Public Shared ReadOnly Property ToposolidInheritContours As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ToposolidInheritContours {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ToposolidStructureIdParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ToposolidStructureIdParam Property
ParameterTypeId Class See Also Send Feedback
"Structure"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ToposolidStructureIdParam { get; }
Visual Basic
Public Shared ReadOnly Property ToposolidStructureIdParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ToposolidStructureIdParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ToposolidSubdivideHeignt Property

[image]

Revit 2024 API
ParameterTypeId..::..ToposolidSubdivideHeignt Property
ParameterTypeId Class See Also Send Feedback
"Sub-divide Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ToposolidSubdivideHeignt { get; }
Visual Basic
Public Shared ReadOnly Property ToposolidSubdivideHeignt As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ToposolidSubdivideHeignt {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ToposolidSubdivideMaterial Property

[image]

Revit 2024 API
ParameterTypeId..::..ToposolidSubdivideMaterial Property
ParameterTypeId Class See Also Send Feedback
"Material"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ToposolidSubdivideMaterial { get; }
Visual Basic
Public Shared ReadOnly Property ToposolidSubdivideMaterial As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ToposolidSubdivideMaterial {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ToposolidTypeDefaultThicknessParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ToposolidTypeDefaultThicknessParam Property
ParameterTypeId Class See Also Send Feedback
"Default Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ToposolidTypeDefaultThicknessParam { get; }
Visual Basic
Public Shared ReadOnly Property ToposolidTypeDefaultThicknessParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ToposolidTypeDefaultThicknessParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TrapMullWidth Property

[image]

Revit 2024 API
ParameterTypeId..::..TrapMullWidth Property
ParameterTypeId Class See Also Send Feedback
"Center Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TrapMullWidth { get; }
Visual Basic
Public Shared ReadOnly Property TrapMullWidth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TrapMullWidth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TrussElementAngleParam Property

[image]

Revit 2024 API
ParameterTypeId..::..TrussElementAngleParam Property
ParameterTypeId Class See Also Send Feedback
"Rotation Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TrussElementAngleParam { get; }
Visual Basic
Public Shared ReadOnly Property TrussElementAngleParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TrussElementAngleParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TrussElementClassParam Property

[image]

Revit 2024 API
ParameterTypeId..::..TrussElementClassParam Property
ParameterTypeId Class See Also Send Feedback
"Engineering Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TrussElementClassParam { get; }
Visual Basic
Public Shared ReadOnly Property TrussElementClassParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TrussElementClassParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TrussElementCreateTopParam Property

[image]

Revit 2024 API
ParameterTypeId..::..TrussElementCreateTopParam Property
ParameterTypeId Class See Also Send Feedback
"Create Top Chord"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TrussElementCreateTopParam { get; }
Visual Basic
Public Shared ReadOnly Property TrussElementCreateTopParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TrussElementCreateTopParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TrussElementEnd0Elevation Property

[image]

Revit 2024 API
ParameterTypeId..::..TrussElementEnd0Elevation Property
ParameterTypeId Class See Also Send Feedback
"Start Level Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TrussElementEnd0Elevation { get; }
Visual Basic
Public Shared ReadOnly Property TrussElementEnd0Elevation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TrussElementEnd0Elevation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TrussElementEnd1Elevation Property

[image]

Revit 2024 API
ParameterTypeId..::..TrussElementEnd1Elevation Property
ParameterTypeId Class See Also Send Feedback
"End Level Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TrussElementEnd1Elevation { get; }
Visual Basic
Public Shared ReadOnly Property TrussElementEnd1Elevation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TrussElementEnd1Elevation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TrussElementReferenceLevelParam Property

[image]

Revit 2024 API
ParameterTypeId..::..TrussElementReferenceLevelParam Property
ParameterTypeId Class See Also Send Feedback
"Reference Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TrussElementReferenceLevelParam { get; }
Visual Basic
Public Shared ReadOnly Property TrussElementReferenceLevelParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TrussElementReferenceLevelParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TrussElementRotateChordsWithTruss Property

[image]

Revit 2024 API
ParameterTypeId..::..TrussElementRotateChordsWithTruss Property
ParameterTypeId Class See Also Send Feedback
"Rotate Chords With Truss"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TrussElementRotateChordsWithTruss { get; }
Visual Basic
Public Shared ReadOnly Property TrussElementRotateChordsWithTruss As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TrussElementRotateChordsWithTruss {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TrussElementTagNewMembersView Property

[image]

Revit 2024 API
ParameterTypeId..::..TrussElementTagNewMembersView Property
ParameterTypeId Class See Also Send Feedback
"Tag new members in view"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TrussElementTagNewMembersView { get; }
Visual Basic
Public Shared ReadOnly Property TrussElementTagNewMembersView As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TrussElementTagNewMembersView {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TrussFamilyBottomChordAngleParam Property

[image]

Revit 2024 API
ParameterTypeId..::..TrussFamilyBottomChordAngleParam Property
ParameterTypeId Class See Also Send Feedback
"Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TrussFamilyBottomChordAngleParam { get; }
Visual Basic
Public Shared ReadOnly Property TrussFamilyBottomChordAngleParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TrussFamilyBottomChordAngleParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TrussFamilyBottomChordStartReleaseType Property

[image]

Revit 2024 API
ParameterTypeId..::..TrussFamilyBottomChordStartReleaseType Property
ParameterTypeId Class See Also Send Feedback
"Start Release"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TrussFamilyBottomChordStartReleaseType { get; }
Visual Basic
Public Shared ReadOnly Property TrussFamilyBottomChordStartReleaseType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TrussFamilyBottomChordStartReleaseType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TrussFamilyBottomChordStructuralTypesParam Property

[image]

Revit 2024 API
ParameterTypeId..::..TrussFamilyBottomChordStructuralTypesParam Property
ParameterTypeId Class See Also Send Feedback
"Structural Framing Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TrussFamilyBottomChordStructuralTypesParam { get; }
Visual Basic
Public Shared ReadOnly Property TrussFamilyBottomChordStructuralTypesParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TrussFamilyBottomChordStructuralTypesParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TrussFamilyDiagWebAngleParam Property

[image]

Revit 2024 API
ParameterTypeId..::..TrussFamilyDiagWebAngleParam Property
ParameterTypeId Class See Also Send Feedback
"Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TrussFamilyDiagWebAngleParam { get; }
Visual Basic
Public Shared ReadOnly Property TrussFamilyDiagWebAngleParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TrussFamilyDiagWebAngleParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TrussFamilyDiagWebEndReleaseType Property

[image]

Revit 2024 API
ParameterTypeId..::..TrussFamilyDiagWebEndReleaseType Property
ParameterTypeId Class See Also Send Feedback
"End Release"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TrussFamilyDiagWebEndReleaseType { get; }
Visual Basic
Public Shared ReadOnly Property TrussFamilyDiagWebEndReleaseType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TrussFamilyDiagWebEndReleaseType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TrussFamilyDiagWebStartReleaseType Property

[image]

Revit 2024 API
ParameterTypeId..::..TrussFamilyDiagWebStartReleaseType Property
ParameterTypeId Class See Also Send Feedback
"Start Release"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TrussFamilyDiagWebStartReleaseType { get; }
Visual Basic
Public Shared ReadOnly Property TrussFamilyDiagWebStartReleaseType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TrussFamilyDiagWebStartReleaseType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TrussFamilyDiagWebStructuralTypesParam Property

[image]

Revit 2024 API
ParameterTypeId..::..TrussFamilyDiagWebStructuralTypesParam Property
ParameterTypeId Class See Also Send Feedback
"Structural Framing Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TrussFamilyDiagWebStructuralTypesParam { get; }
Visual Basic
Public Shared ReadOnly Property TrussFamilyDiagWebStructuralTypesParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TrussFamilyDiagWebStructuralTypesParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TrussFamilyTopChordAngleParam Property

[image]

Revit 2024 API
ParameterTypeId..::..TrussFamilyTopChordAngleParam Property
ParameterTypeId Class See Also Send Feedback
"Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TrussFamilyTopChordAngleParam { get; }
Visual Basic
Public Shared ReadOnly Property TrussFamilyTopChordAngleParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TrussFamilyTopChordAngleParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TrussFamilyTopChordEndReleaseType Property

[image]

Revit 2024 API
ParameterTypeId..::..TrussFamilyTopChordEndReleaseType Property
ParameterTypeId Class See Also Send Feedback
"End Release"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TrussFamilyTopChordEndReleaseType { get; }
Visual Basic
Public Shared ReadOnly Property TrussFamilyTopChordEndReleaseType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TrussFamilyTopChordEndReleaseType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TrussFamilyTopChordStartReleaseType Property

[image]

Revit 2024 API
ParameterTypeId..::..TrussFamilyTopChordStartReleaseType Property
ParameterTypeId Class See Also Send Feedback
"Start Release"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TrussFamilyTopChordStartReleaseType { get; }
Visual Basic
Public Shared ReadOnly Property TrussFamilyTopChordStartReleaseType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TrussFamilyTopChordStartReleaseType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TrussFamilyTopChordStructuralTypesParam Property

[image]

Revit 2024 API
ParameterTypeId..::..TrussFamilyTopChordStructuralTypesParam Property
ParameterTypeId Class See Also Send Feedback
"Structural Framing Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TrussFamilyTopChordStructuralTypesParam { get; }
Visual Basic
Public Shared ReadOnly Property TrussFamilyTopChordStructuralTypesParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TrussFamilyTopChordStructuralTypesParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TrussFamilyTopChordVerticalProjectionParam Property

[image]

Revit 2024 API
ParameterTypeId..::..TrussFamilyTopChordVerticalProjectionParam Property
ParameterTypeId Class See Also Send Feedback
"Analytical Vertical Projection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TrussFamilyTopChordVerticalProjectionParam { get; }
Visual Basic
Public Shared ReadOnly Property TrussFamilyTopChordVerticalProjectionParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TrussFamilyTopChordVerticalProjectionParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TrussFamilyTransformationParam Property

[image]

Revit 2024 API
ParameterTypeId..::..TrussFamilyTransformationParam Property
ParameterTypeId Class See Also Send Feedback
"Web Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TrussFamilyTransformationParam { get; }
Visual Basic
Public Shared ReadOnly Property TrussFamilyTransformationParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TrussFamilyTransformationParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TrussFamilyVertWebAngleParam Property

[image]

Revit 2024 API
ParameterTypeId..::..TrussFamilyVertWebAngleParam Property
ParameterTypeId Class See Also Send Feedback
"Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TrussFamilyVertWebAngleParam { get; }
Visual Basic
Public Shared ReadOnly Property TrussFamilyVertWebAngleParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TrussFamilyVertWebAngleParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TrussFamilyVertWebEndReleaseType Property

[image]

Revit 2024 API
ParameterTypeId..::..TrussFamilyVertWebEndReleaseType Property
ParameterTypeId Class See Also Send Feedback
"End Release"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TrussFamilyVertWebEndReleaseType { get; }
Visual Basic
Public Shared ReadOnly Property TrussFamilyVertWebEndReleaseType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TrussFamilyVertWebEndReleaseType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TrussFamilyVertWebStartReleaseType Property

[image]

Revit 2024 API
ParameterTypeId..::..TrussFamilyVertWebStartReleaseType Property
ParameterTypeId Class See Also Send Feedback
"Start Release"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TrussFamilyVertWebStartReleaseType { get; }
Visual Basic
Public Shared ReadOnly Property TrussFamilyVertWebStartReleaseType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TrussFamilyVertWebStartReleaseType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TrussHeight Property

[image]

Revit 2024 API
ParameterTypeId..::..TrussHeight Property
ParameterTypeId Class See Also Send Feedback
"Truss Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TrussHeight { get; }
Visual Basic
Public Shared ReadOnly Property TrussHeight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TrussHeight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TrussLength Property

[image]

Revit 2024 API
ParameterTypeId..::..TrussLength Property
ParameterTypeId Class See Also Send Feedback
"Truss Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TrussLength { get; }
Visual Basic
Public Shared ReadOnly Property TrussLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TrussLength {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TrussNonBearingOffsetParam Property

[image]

Revit 2024 API
ParameterTypeId..::..TrussNonBearingOffsetParam Property
ParameterTypeId Class See Also Send Feedback
"Non Bearing Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TrussNonBearingOffsetParam { get; }
Visual Basic
Public Shared ReadOnly Property TrussNonBearingOffsetParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TrussNonBearingOffsetParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


TypeWallClosure Property

[image]

Revit 2024 API
ParameterTypeId..::..TypeWallClosure Property
ParameterTypeId Class See Also Send Feedback
"Wall Closure"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId TypeWallClosure { get; }
Visual Basic
Public Shared ReadOnly Property TypeWallClosure As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TypeWallClosure {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


UniformatCode Property

[image]

Revit 2024 API
ParameterTypeId..::..UniformatCode Property
ParameterTypeId Class See Also Send Feedback
"Assembly Code"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId UniformatCode { get; }
Visual Basic
Public Shared ReadOnly Property UniformatCode As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ UniformatCode {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


UniformatDescription Property

[image]

Revit 2024 API
ParameterTypeId..::..UniformatDescription Property
ParameterTypeId Class See Also Send Feedback
"Assembly Description"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId UniformatDescription { get; }
Visual Basic
Public Shared ReadOnly Property UniformatDescription As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ UniformatDescription {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewAnalysisDisplayStyle Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewAnalysisDisplayStyle Property
ParameterTypeId Class See Also Send Feedback
"Default Analysis Display Style"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewAnalysisDisplayStyle { get; }
Visual Basic
Public Shared ReadOnly Property ViewAnalysisDisplayStyle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewAnalysisDisplayStyle {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewAnalysisResultsVisibility Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewAnalysisResultsVisibility Property
ParameterTypeId Class See Also Send Feedback
"Analysis Display Settings"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewAnalysisResultsVisibility { get; }
Visual Basic
Public Shared ReadOnly Property ViewAnalysisResultsVisibility As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewAnalysisResultsVisibility {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewAssociatedAssemblyInstanceId Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewAssociatedAssemblyInstanceId Property
ParameterTypeId Class See Also Send Feedback
"Associated Assembly Instance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewAssociatedAssemblyInstanceId { get; }
Visual Basic
Public Shared ReadOnly Property ViewAssociatedAssemblyInstanceId As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewAssociatedAssemblyInstanceId {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewCameraOrientation Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewCameraOrientation Property
ParameterTypeId Class See Also Send Feedback
"Locked Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewCameraOrientation { get; }
Visual Basic
Public Shared ReadOnly Property ViewCameraOrientation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewCameraOrientation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewCameraPosition Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewCameraPosition Property
ParameterTypeId Class See Also Send Feedback
"Camera Position"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewCameraPosition { get; }
Visual Basic
Public Shared ReadOnly Property ViewCameraPosition As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewCameraPosition {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewCleanJoins Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewCleanJoins Property
ParameterTypeId Class See Also Send Feedback
"Wall Join Display"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewCleanJoins { get; }
Visual Basic
Public Shared ReadOnly Property ViewCleanJoins As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewCleanJoins {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewDependency Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewDependency Property
ParameterTypeId Class See Also Send Feedback
"Dependency"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewDependency { get; }
Visual Basic
Public Shared ReadOnly Property ViewDependency As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewDependency {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewDepth Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewDepth Property
ParameterTypeId Class See Also Send Feedback
"View Depth"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewDepth { get; }
Visual Basic
Public Shared ReadOnly Property ViewDepth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewDepth {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewDescription Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewDescription Property
ParameterTypeId Class See Also Send Feedback
"Title on Sheet"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewDescription { get; }
Visual Basic
Public Shared ReadOnly Property ViewDescription As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewDescription {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewDetailLevel Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewDetailLevel Property
ParameterTypeId Class See Also Send Feedback
"Detail Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewDetailLevel { get; }
Visual Basic
Public Shared ReadOnly Property ViewDetailLevel As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewDetailLevel {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewDiscipline Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewDiscipline Property
ParameterTypeId Class See Also Send Feedback
"Discipline"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewDiscipline { get; }
Visual Basic
Public Shared ReadOnly Property ViewDiscipline As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewDiscipline {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


Viewer3dRenderSettings Property

[image]

Revit 2024 API
ParameterTypeId..::..Viewer3dRenderSettings Property
ParameterTypeId Class See Also Send Feedback
"Rendering Settings"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId Viewer3dRenderSettings { get; }
Visual Basic
Public Shared ReadOnly Property Viewer3dRenderSettings As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Viewer3dRenderSettings {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewerAnnotationCropActive Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewerAnnotationCropActive Property
ParameterTypeId Class See Also Send Feedback
"Annotation Crop"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewerAnnotationCropActive { get; }
Visual Basic
Public Shared ReadOnly Property ViewerAnnotationCropActive As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewerAnnotationCropActive {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewerBoundActiveNear Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewerBoundActiveNear Property
ParameterTypeId Class See Also Send Feedback
"Near Clip Active"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewerBoundActiveNear { get; }
Visual Basic
Public Shared ReadOnly Property ViewerBoundActiveNear As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewerBoundActiveNear {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewerBoundFarClipping Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewerBoundFarClipping Property
ParameterTypeId Class See Also Send Feedback
"Far Clipping"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewerBoundFarClipping { get; }
Visual Basic
Public Shared ReadOnly Property ViewerBoundFarClipping As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewerBoundFarClipping {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewerBoundOffsetBottom Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewerBoundOffsetBottom Property
ParameterTypeId Class See Also Send Feedback
"Bottom Clip Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewerBoundOffsetBottom { get; }
Visual Basic
Public Shared ReadOnly Property ViewerBoundOffsetBottom As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewerBoundOffsetBottom {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewerBoundOffsetFar Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewerBoundOffsetFar Property
ParameterTypeId Class See Also Send Feedback
"Far Clip Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewerBoundOffsetFar { get; }
Visual Basic
Public Shared ReadOnly Property ViewerBoundOffsetFar As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewerBoundOffsetFar {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewerBoundOffsetLeft Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewerBoundOffsetLeft Property
ParameterTypeId Class See Also Send Feedback
"Left Clip Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewerBoundOffsetLeft { get; }
Visual Basic
Public Shared ReadOnly Property ViewerBoundOffsetLeft As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewerBoundOffsetLeft {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewerBoundOffsetNear Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewerBoundOffsetNear Property
ParameterTypeId Class See Also Send Feedback
"Near Clip Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewerBoundOffsetNear { get; }
Visual Basic
Public Shared ReadOnly Property ViewerBoundOffsetNear As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewerBoundOffsetNear {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewerBoundOffsetRight Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewerBoundOffsetRight Property
ParameterTypeId Class See Also Send Feedback
"Right Clip Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewerBoundOffsetRight { get; }
Visual Basic
Public Shared ReadOnly Property ViewerBoundOffsetRight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewerBoundOffsetRight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewerBoundOffsetTop Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewerBoundOffsetTop Property
ParameterTypeId Class See Also Send Feedback
"Top Clip Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewerBoundOffsetTop { get; }
Visual Basic
Public Shared ReadOnly Property ViewerBoundOffsetTop As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewerBoundOffsetTop {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewerCropRegion Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewerCropRegion Property
ParameterTypeId Class See Also Send Feedback
"Crop View"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewerCropRegion { get; }
Visual Basic
Public Shared ReadOnly Property ViewerCropRegion As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewerCropRegion {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewerCropRegionDisabled Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewerCropRegionDisabled Property
ParameterTypeId Class See Also Send Feedback
"Crop View"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewerCropRegionDisabled { get; }
Visual Basic
Public Shared ReadOnly Property ViewerCropRegionDisabled As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewerCropRegionDisabled {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewerCropRegionVisible Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewerCropRegionVisible Property
ParameterTypeId Class See Also Send Feedback
"Crop Region Visible"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewerCropRegionVisible { get; }
Visual Basic
Public Shared ReadOnly Property ViewerCropRegionVisible As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewerCropRegionVisible {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewerDetailNumber Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewerDetailNumber Property
ParameterTypeId Class See Also Send Feedback
"Detail Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewerDetailNumber { get; }
Visual Basic
Public Shared ReadOnly Property ViewerDetailNumber As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewerDetailNumber {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewerEyeElevation Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewerEyeElevation Property
ParameterTypeId Class See Also Send Feedback
"Eye Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewerEyeElevation { get; }
Visual Basic
Public Shared ReadOnly Property ViewerEyeElevation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewerEyeElevation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewerIsReference Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewerIsReference Property
ParameterTypeId Class See Also Send Feedback
"Is a Reference"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewerIsReference { get; }
Visual Basic
Public Shared ReadOnly Property ViewerIsReference As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewerIsReference {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewerModelClipBoxActive Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewerModelClipBoxActive Property
ParameterTypeId Class See Also Send Feedback
"Section Box"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewerModelClipBoxActive { get; }
Visual Basic
Public Shared ReadOnly Property ViewerModelClipBoxActive As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewerModelClipBoxActive {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewerOptionVisibility Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewerOptionVisibility Property
ParameterTypeId Class See Also Send Feedback
"Visible In Option"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewerOptionVisibility { get; }
Visual Basic
Public Shared ReadOnly Property ViewerOptionVisibility As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewerOptionVisibility {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewerPerspective Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewerPerspective Property
ParameterTypeId Class See Also Send Feedback
"Projection Mode"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewerPerspective { get; }
Visual Basic
Public Shared ReadOnly Property ViewerPerspective As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewerPerspective {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewerReferenceLabel Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewerReferenceLabel Property
ParameterTypeId Class See Also Send Feedback
"Reference Label"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewerReferenceLabel { get; }
Visual Basic
Public Shared ReadOnly Property ViewerReferenceLabel As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewerReferenceLabel {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewerReferenceLabelText Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewerReferenceLabelText Property
ParameterTypeId Class See Also Send Feedback
"Reference Label"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewerReferenceLabelText { get; }
Visual Basic
Public Shared ReadOnly Property ViewerReferenceLabelText As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewerReferenceLabelText {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewerSheetNumber Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewerSheetNumber Property
ParameterTypeId Class See Also Send Feedback
"Sheet Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewerSheetNumber { get; }
Visual Basic
Public Shared ReadOnly Property ViewerSheetNumber As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewerSheetNumber {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewFamily Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewFamily Property
ParameterTypeId Class See Also Send Feedback
"Family"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewFamily { get; }
Visual Basic
Public Shared ReadOnly Property ViewFamily As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewFamily {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewFamilyAndTypeSchedules Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewFamilyAndTypeSchedules Property
ParameterTypeId Class See Also Send Feedback
"Family and Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewFamilyAndTypeSchedules { get; }
Visual Basic
Public Shared ReadOnly Property ViewFamilyAndTypeSchedules As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewFamilyAndTypeSchedules {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewFamilySchedules Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewFamilySchedules Property
ParameterTypeId Class See Also Send Feedback
"Family"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewFamilySchedules { get; }
Visual Basic
Public Shared ReadOnly Property ViewFamilySchedules As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewFamilySchedules {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewFixedSketchPlane Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewFixedSketchPlane Property
ParameterTypeId Class See Also Send Feedback
"None"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewFixedSketchPlane { get; }
Visual Basic
Public Shared ReadOnly Property ViewFixedSketchPlane As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewFixedSketchPlane {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewGraphSchedBottomLevel Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewGraphSchedBottomLevel Property
ParameterTypeId Class See Also Send Feedback
"Bottom Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewGraphSchedBottomLevel { get; }
Visual Basic
Public Shared ReadOnly Property ViewGraphSchedBottomLevel As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewGraphSchedBottomLevel {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewGraphSchedGroupSimilar Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewGraphSchedGroupSimilar Property
ParameterTypeId Class See Also Send Feedback
"Group Similar Locations"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewGraphSchedGroupSimilar { get; }
Visual Basic
Public Shared ReadOnly Property ViewGraphSchedGroupSimilar As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewGraphSchedGroupSimilar {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewGraphSchedLevelRelativeBaseType Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewGraphSchedLevelRelativeBaseType Property
ParameterTypeId Class See Also Send Feedback
"Elevation Base for Levels"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewGraphSchedLevelRelativeBaseType { get; }
Visual Basic
Public Shared ReadOnly Property ViewGraphSchedLevelRelativeBaseType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewGraphSchedLevelRelativeBaseType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewGraphSchedLocationsHigh Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewGraphSchedLocationsHigh Property
ParameterTypeId Class See Also Send Feedback
"Column Locations End"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewGraphSchedLocationsHigh { get; }
Visual Basic
Public Shared ReadOnly Property ViewGraphSchedLocationsHigh As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewGraphSchedLocationsHigh {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewGraphSchedLocationsLow Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewGraphSchedLocationsLow Property
ParameterTypeId Class See Also Send Feedback
"Column Locations Start"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewGraphSchedLocationsLow { get; }
Visual Basic
Public Shared ReadOnly Property ViewGraphSchedLocationsLow As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewGraphSchedLocationsLow {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewGraphSchedMaterialTypes Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewGraphSchedMaterialTypes Property
ParameterTypeId Class See Also Send Feedback
"Material Types"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewGraphSchedMaterialTypes { get; }
Visual Basic
Public Shared ReadOnly Property ViewGraphSchedMaterialTypes As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewGraphSchedMaterialTypes {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewGraphSchedOffGrid Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewGraphSchedOffGrid Property
ParameterTypeId Class See Also Send Feedback
"Include Off-Grid Columns"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewGraphSchedOffGrid { get; }
Visual Basic
Public Shared ReadOnly Property ViewGraphSchedOffGrid As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewGraphSchedOffGrid {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewGraphSchedRowsCount Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewGraphSchedRowsCount Property
ParameterTypeId Class See Also Send Feedback
"Segments in Viewport"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewGraphSchedRowsCount { get; }
Visual Basic
Public Shared ReadOnly Property ViewGraphSchedRowsCount As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewGraphSchedRowsCount {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewGraphSchedRowsFrom Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewGraphSchedRowsFrom Property
ParameterTypeId Class See Also Send Feedback
"Segment Start in Viewport"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewGraphSchedRowsFrom { get; }
Visual Basic
Public Shared ReadOnly Property ViewGraphSchedRowsFrom As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewGraphSchedRowsFrom {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewGraphSchedTextAppearance Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewGraphSchedTextAppearance Property
ParameterTypeId Class See Also Send Feedback
"Text Appearance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewGraphSchedTextAppearance { get; }
Visual Basic
Public Shared ReadOnly Property ViewGraphSchedTextAppearance As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewGraphSchedTextAppearance {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewGraphSchedTitle Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewGraphSchedTitle Property
ParameterTypeId Class See Also Send Feedback
"Title"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewGraphSchedTitle { get; }
Visual Basic
Public Shared ReadOnly Property ViewGraphSchedTitle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewGraphSchedTitle {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewGraphSchedTopLevel Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewGraphSchedTopLevel Property
ParameterTypeId Class See Also Send Feedback
"Top Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewGraphSchedTopLevel { get; }
Visual Basic
Public Shared ReadOnly Property ViewGraphSchedTopLevel As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewGraphSchedTopLevel {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewGraphSchedTotalColumns Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewGraphSchedTotalColumns Property
ParameterTypeId Class See Also Send Feedback
"Total Column Locations"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewGraphSchedTotalColumns { get; }
Visual Basic
Public Shared ReadOnly Property ViewGraphSchedTotalColumns As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewGraphSchedTotalColumns {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewGraphSunPathSize Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewGraphSunPathSize Property
ParameterTypeId Class See Also Send Feedback
"Sun path size (%)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewGraphSunPathSize { get; }
Visual Basic
Public Shared ReadOnly Property ViewGraphSunPathSize As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewGraphSunPathSize {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewModelDisplayMode Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewModelDisplayMode Property
ParameterTypeId Class See Also Send Feedback
"Display Model"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewModelDisplayMode { get; }
Visual Basic
Public Shared ReadOnly Property ViewModelDisplayMode As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewModelDisplayMode {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewName Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewName Property
ParameterTypeId Class See Also Send Feedback
"View Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewName { get; }
Visual Basic
Public Shared ReadOnly Property ViewName As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewName {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewPartsVisibility Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewPartsVisibility Property
ParameterTypeId Class See Also Send Feedback
"Parts Visibility"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewPartsVisibility { get; }
Visual Basic
Public Shared ReadOnly Property ViewPartsVisibility As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewPartsVisibility {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewPhase Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewPhase Property
ParameterTypeId Class See Also Send Feedback
"Phase"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewPhase { get; }
Visual Basic
Public Shared ReadOnly Property ViewPhase As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewPhase {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewportAttrLabelTag Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewportAttrLabelTag Property
ParameterTypeId Class See Also Send Feedback
"Title"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewportAttrLabelTag { get; }
Visual Basic
Public Shared ReadOnly Property ViewportAttrLabelTag As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewportAttrLabelTag {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewportAttrOrientationOnSheet Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewportAttrOrientationOnSheet Property
ParameterTypeId Class See Also Send Feedback
"Rotation on Sheet"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewportAttrOrientationOnSheet { get; }
Visual Basic
Public Shared ReadOnly Property ViewportAttrOrientationOnSheet As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewportAttrOrientationOnSheet {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewportAttrPreserveTitlePosition Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewportAttrPreserveTitlePosition Property
ParameterTypeId Class See Also Send Feedback
"Preserve Title Position"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewportAttrPreserveTitlePosition { get; }
Visual Basic
Public Shared ReadOnly Property ViewportAttrPreserveTitlePosition As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewportAttrPreserveTitlePosition {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewportAttrShowBox Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewportAttrShowBox Property
ParameterTypeId Class See Also Send Feedback
"Show Box"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewportAttrShowBox { get; }
Visual Basic
Public Shared ReadOnly Property ViewportAttrShowBox As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewportAttrShowBox {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewportAttrShowExtensionLine Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewportAttrShowExtensionLine Property
ParameterTypeId Class See Also Send Feedback
"Show Extension Line"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewportAttrShowExtensionLine { get; }
Visual Basic
Public Shared ReadOnly Property ViewportAttrShowExtensionLine As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewportAttrShowExtensionLine {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewportAttrShowLabel Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewportAttrShowLabel Property
ParameterTypeId Class See Also Send Feedback
"Show Title"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewportAttrShowLabel { get; }
Visual Basic
Public Shared ReadOnly Property ViewportAttrShowLabel As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewportAttrShowLabel {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewportDetailNumber Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewportDetailNumber Property
ParameterTypeId Class See Also Send Feedback
"Detail Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewportDetailNumber { get; }
Visual Basic
Public Shared ReadOnly Property ViewportDetailNumber As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewportDetailNumber {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewportPositioning Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewportPositioning Property
ParameterTypeId Class See Also Send Feedback
"Viewport Positioning"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewportPositioning { get; }
Visual Basic
Public Shared ReadOnly Property ViewportPositioning As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewportPositioning {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewportScale Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewportScale Property
ParameterTypeId Class See Also Send Feedback
"View Scale"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewportScale { get; }
Visual Basic
Public Shared ReadOnly Property ViewportScale As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewportScale {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewportSheetName Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewportSheetName Property
ParameterTypeId Class See Also Send Feedback
"Sheet Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewportSheetName { get; }
Visual Basic
Public Shared ReadOnly Property ViewportSheetName As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewportSheetName {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewportSheetNumber Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewportSheetNumber Property
ParameterTypeId Class See Also Send Feedback
"Sheet Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewportSheetNumber { get; }
Visual Basic
Public Shared ReadOnly Property ViewportSheetNumber As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewportSheetNumber {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewReferencingSheet Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewReferencingSheet Property
ParameterTypeId Class See Also Send Feedback
"Referencing Sheet"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewReferencingSheet { get; }
Visual Basic
Public Shared ReadOnly Property ViewReferencingSheet As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewReferencingSheet {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewScale Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewScale Property
ParameterTypeId Class See Also Send Feedback
"Scale Value 1:"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewScale { get; }
Visual Basic
Public Shared ReadOnly Property ViewScale As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewScale {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewScaleCustomname Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewScaleCustomname Property
ParameterTypeId Class See Also Send Feedback
"Display Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewScaleCustomname { get; }
Visual Basic
Public Shared ReadOnly Property ViewScaleCustomname As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewScaleCustomname {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewScaleHavename Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewScaleHavename Property
ParameterTypeId Class See Also Send Feedback
"Display Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewScaleHavename { get; }
Visual Basic
Public Shared ReadOnly Property ViewScaleHavename As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewScaleHavename {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewSchemaSettingForBuilding Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewSchemaSettingForBuilding Property
ParameterTypeId Class See Also Send Feedback
"Color Scheme"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewSchemaSettingForBuilding { get; }
Visual Basic
Public Shared ReadOnly Property ViewSchemaSettingForBuilding As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewSchemaSettingForBuilding {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewSchemaSettingForSystem Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewSchemaSettingForSystem Property
ParameterTypeId Class See Also Send Feedback
"System Color Schemes"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewSchemaSettingForSystem { get; }
Visual Basic
Public Shared ReadOnly Property ViewSchemaSettingForSystem As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewSchemaSettingForSystem {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewSheetViewportInfo Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewSheetViewportInfo Property
ParameterTypeId Class See Also Send Feedback
"Viewport"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewSheetViewportInfo { get; }
Visual Basic
Public Shared ReadOnly Property ViewSheetViewportInfo As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewSheetViewportInfo {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewShowGrids Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewShowGrids Property
ParameterTypeId Class See Also Send Feedback
"Show Grids"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewShowGrids { get; }
Visual Basic
Public Shared ReadOnly Property ViewShowGrids As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewShowGrids {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewSolarstudyAnimationSpeedText Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewSolarstudyAnimationSpeedText Property
ParameterTypeId Class See Also Send Feedback
"Loop animation speed"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewSolarstudyAnimationSpeedText { get; }
Visual Basic
Public Shared ReadOnly Property ViewSolarstudyAnimationSpeedText As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewSolarstudyAnimationSpeedText {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewSolarstudyIsLightingStudyType Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewSolarstudyIsLightingStudyType Property
ParameterTypeId Class See Also Send Feedback
"Lighting study"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewSolarstudyIsLightingStudyType { get; }
Visual Basic
Public Shared ReadOnly Property ViewSolarstudyIsLightingStudyType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewSolarstudyIsLightingStudyType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewSolarstudyIsSingledayStudyType Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewSolarstudyIsSingledayStudyType Property
ParameterTypeId Class See Also Send Feedback
"Single day study"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewSolarstudyIsSingledayStudyType { get; }
Visual Basic
Public Shared ReadOnly Property ViewSolarstudyIsSingledayStudyType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewSolarstudyIsSingledayStudyType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewSolarstudyIsStillimageStudyType Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewSolarstudyIsStillimageStudyType Property
ParameterTypeId Class See Also Send Feedback
"Still image study"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewSolarstudyIsStillimageStudyType { get; }
Visual Basic
Public Shared ReadOnly Property ViewSolarstudyIsStillimageStudyType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewSolarstudyIsStillimageStudyType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewSolarstudyLightingAltitudeValue Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewSolarstudyLightingAltitudeValue Property
ParameterTypeId Class See Also Send Feedback
"Lighting altitude"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewSolarstudyLightingAltitudeValue { get; }
Visual Basic
Public Shared ReadOnly Property ViewSolarstudyLightingAltitudeValue As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewSolarstudyLightingAltitudeValue {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewSolarstudyLightingAzimuthText Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewSolarstudyLightingAzimuthText Property
ParameterTypeId Class See Also Send Feedback
"Lighting azimuth text"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewSolarstudyLightingAzimuthText { get; }
Visual Basic
Public Shared ReadOnly Property ViewSolarstudyLightingAzimuthText As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewSolarstudyLightingAzimuthText {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewSolarstudyLightingAzimuthValue Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewSolarstudyLightingAzimuthValue Property
ParameterTypeId Class See Also Send Feedback
"Lighting azimuth"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewSolarstudyLightingAzimuthValue { get; }
Visual Basic
Public Shared ReadOnly Property ViewSolarstudyLightingAzimuthValue As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewSolarstudyLightingAzimuthValue {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewSolarstudyLightingPresetIndex Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewSolarstudyLightingPresetIndex Property
ParameterTypeId Class See Also Send Feedback
"Lighting presets combo"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewSolarstudyLightingPresetIndex { get; }
Visual Basic
Public Shared ReadOnly Property ViewSolarstudyLightingPresetIndex As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewSolarstudyLightingPresetIndex {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewSolarstudyMultidayDatetimeText Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewSolarstudyMultidayDatetimeText Property
ParameterTypeId Class See Also Send Feedback
"Multi-day date and time text"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewSolarstudyMultidayDatetimeText { get; }
Visual Basic
Public Shared ReadOnly Property ViewSolarstudyMultidayDatetimeText As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewSolarstudyMultidayDatetimeText {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewSolarstudyMultidayFrameText Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewSolarstudyMultidayFrameText Property
ParameterTypeId Class See Also Send Feedback
"Multi-day frame text"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewSolarstudyMultidayFrameText { get; }
Visual Basic
Public Shared ReadOnly Property ViewSolarstudyMultidayFrameText As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewSolarstudyMultidayFrameText {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewSolarstudyMultidayFrameValue Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewSolarstudyMultidayFrameValue Property
ParameterTypeId Class See Also Send Feedback
"Multi-day frame"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewSolarstudyMultidayFrameValue { get; }
Visual Basic
Public Shared ReadOnly Property ViewSolarstudyMultidayFrameValue As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewSolarstudyMultidayFrameValue {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewSolarstudyMultidayPresetIndex Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewSolarstudyMultidayPresetIndex Property
ParameterTypeId Class See Also Send Feedback
"Multi-day presets combo"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewSolarstudyMultidayPresetIndex { get; }
Visual Basic
Public Shared ReadOnly Property ViewSolarstudyMultidayPresetIndex As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewSolarstudyMultidayPresetIndex {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewSolarstudyShadowsIntensityText Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewSolarstudyShadowsIntensityText Property
ParameterTypeId Class See Also Send Feedback
"Shadows intensity text"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewSolarstudyShadowsIntensityText { get; }
Visual Basic
Public Shared ReadOnly Property ViewSolarstudyShadowsIntensityText As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewSolarstudyShadowsIntensityText {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewSolarstudyShadowsIntensityValue Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewSolarstudyShadowsIntensityValue Property
ParameterTypeId Class See Also Send Feedback
"Shadows intensity"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewSolarstudyShadowsIntensityValue { get; }
Visual Basic
Public Shared ReadOnly Property ViewSolarstudyShadowsIntensityValue As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewSolarstudyShadowsIntensityValue {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewSolarstudySingledayFrameText Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewSolarstudySingledayFrameText Property
ParameterTypeId Class See Also Send Feedback
"Single day frame text"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewSolarstudySingledayFrameText { get; }
Visual Basic
Public Shared ReadOnly Property ViewSolarstudySingledayFrameText As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewSolarstudySingledayFrameText {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewSolarstudySingledayFrameValue Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewSolarstudySingledayFrameValue Property
ParameterTypeId Class See Also Send Feedback
"Single day frame"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewSolarstudySingledayFrameValue { get; }
Visual Basic
Public Shared ReadOnly Property ViewSolarstudySingledayFrameValue As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewSolarstudySingledayFrameValue {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewSolarstudySingledayPresetIndex Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewSolarstudySingledayPresetIndex Property
ParameterTypeId Class See Also Send Feedback
"Single day presets combo"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewSolarstudySingledayPresetIndex { get; }
Visual Basic
Public Shared ReadOnly Property ViewSolarstudySingledayPresetIndex As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewSolarstudySingledayPresetIndex {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewSolarstudyStillDateText Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewSolarstudyStillDateText Property
ParameterTypeId Class See Also Send Feedback
"Still date text"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewSolarstudyStillDateText { get; }
Visual Basic
Public Shared ReadOnly Property ViewSolarstudyStillDateText As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewSolarstudyStillDateText {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewSolarstudyStillDateValue Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewSolarstudyStillDateValue Property
ParameterTypeId Class See Also Send Feedback
"Still date"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewSolarstudyStillDateValue { get; }
Visual Basic
Public Shared ReadOnly Property ViewSolarstudyStillDateValue As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewSolarstudyStillDateValue {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewSolarstudyStillTimeValue Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewSolarstudyStillTimeValue Property
ParameterTypeId Class See Also Send Feedback
"Still time"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewSolarstudyStillTimeValue { get; }
Visual Basic
Public Shared ReadOnly Property ViewSolarstudyStillTimeValue As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewSolarstudyStillTimeValue {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewSolarstudySunIntensityText Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewSolarstudySunIntensityText Property
ParameterTypeId Class See Also Send Feedback
"Sun intensity text"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewSolarstudySunIntensityText { get; }
Visual Basic
Public Shared ReadOnly Property ViewSolarstudySunIntensityText As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewSolarstudySunIntensityText {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewSolarstudySunIntensityValue Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewSolarstudySunIntensityValue Property
ParameterTypeId Class See Also Send Feedback
"Sun intensity"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewSolarstudySunIntensityValue { get; }
Visual Basic
Public Shared ReadOnly Property ViewSolarstudySunIntensityValue As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewSolarstudySunIntensityValue {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewTemplate Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewTemplate Property
ParameterTypeId Class See Also Send Feedback
"View Template"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewTemplate { get; }
Visual Basic
Public Shared ReadOnly Property ViewTemplate As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewTemplate {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewType Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewType Property
ParameterTypeId Class See Also Send Feedback
"Family and Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewType { get; }
Visual Basic
Public Shared ReadOnly Property ViewType As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewType {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewTypeSchedules Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewTypeSchedules Property
ParameterTypeId Class See Also Send Feedback
"Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewTypeSchedules { get; }
Visual Basic
Public Shared ReadOnly Property ViewTypeSchedules As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewTypeSchedules {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ViewVisibleCategories Property

[image]

Revit 2024 API
ParameterTypeId..::..ViewVisibleCategories Property
ParameterTypeId Class See Also Send Feedback
"Visibility/Graphics Overrides"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ViewVisibleCategories { get; }
Visual Basic
Public Shared ReadOnly Property ViewVisibleCategories As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ViewVisibleCategories {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


VisGraphicsAnalyticalModel Property

[image]

Revit 2024 API
ParameterTypeId..::..VisGraphicsAnalyticalModel Property
ParameterTypeId Class See Also Send Feedback
"V/G Overrides Analytical Model"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId VisGraphicsAnalyticalModel { get; }
Visual Basic
Public Shared ReadOnly Property VisGraphicsAnalyticalModel As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ VisGraphicsAnalyticalModel {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


VisGraphicsAnnotation Property

[image]

Revit 2024 API
ParameterTypeId..::..VisGraphicsAnnotation Property
ParameterTypeId Class See Also Send Feedback
"V/G Overrides Annotation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId VisGraphicsAnnotation { get; }
Visual Basic
Public Shared ReadOnly Property VisGraphicsAnnotation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ VisGraphicsAnnotation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


VisGraphicsDesignoptions Property

[image]

Revit 2024 API
ParameterTypeId..::..VisGraphicsDesignoptions Property
ParameterTypeId Class See Also Send Feedback
"V/G Overrides Design Options"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId VisGraphicsDesignoptions { get; }
Visual Basic
Public Shared ReadOnly Property VisGraphicsDesignoptions As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ VisGraphicsDesignoptions {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


VisGraphicsFilters Property

[image]

Revit 2024 API
ParameterTypeId..::..VisGraphicsFilters Property
ParameterTypeId Class See Also Send Feedback
"V/G Overrides Filters"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId VisGraphicsFilters { get; }
Visual Basic
Public Shared ReadOnly Property VisGraphicsFilters As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ VisGraphicsFilters {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


VisGraphicsImport Property

[image]

Revit 2024 API
ParameterTypeId..::..VisGraphicsImport Property
ParameterTypeId Class See Also Send Feedback
"V/G Overrides Import"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId VisGraphicsImport { get; }
Visual Basic
Public Shared ReadOnly Property VisGraphicsImport As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ VisGraphicsImport {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


VisGraphicsPointClouds Property

[image]

Revit 2024 API
ParameterTypeId..::..VisGraphicsPointClouds Property
ParameterTypeId Class See Also Send Feedback
"V/G Overrides Point Clouds"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId VisGraphicsPointClouds { get; }
Visual Basic
Public Shared ReadOnly Property VisGraphicsPointClouds As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ VisGraphicsPointClouds {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


VisGraphicsWorksets Property

[image]

Revit 2024 API
ParameterTypeId..::..VisGraphicsWorksets Property
ParameterTypeId Class See Also Send Feedback
"V/G Overrides Worksets"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId VisGraphicsWorksets { get; }
Visual Basic
Public Shared ReadOnly Property VisGraphicsWorksets As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ VisGraphicsWorksets {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


VoidCutsGeometry Property

[image]

Revit 2024 API
ParameterTypeId..::..VoidCutsGeometry Property
ParameterTypeId Class See Also Send Feedback
"Cuts Geometry"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId VoidCutsGeometry { get; }
Visual Basic
Public Shared ReadOnly Property VoidCutsGeometry As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ VoidCutsGeometry {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


VolumeCut Property

[image]

Revit 2024 API
ParameterTypeId..::..VolumeCut Property
ParameterTypeId Class See Also Send Feedback
"Cut"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId VolumeCut { get; }
Visual Basic
Public Shared ReadOnly Property VolumeCut As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ VolumeCut {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


VolumeFill Property

[image]

Revit 2024 API
ParameterTypeId..::..VolumeFill Property
ParameterTypeId Class See Also Send Feedback
"Fill"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId VolumeFill { get; }
Visual Basic
Public Shared ReadOnly Property VolumeFill As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ VolumeFill {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


VolumeNet Property

[image]

Revit 2024 API
ParameterTypeId..::..VolumeNet Property
ParameterTypeId Class See Also Send Feedback
"Net cut/fill"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId VolumeNet { get; }
Visual Basic
Public Shared ReadOnly Property VolumeNet As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ VolumeNet {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


VolumeOfInterestHeight Property

[image]

Revit 2024 API
ParameterTypeId..::..VolumeOfInterestHeight Property
ParameterTypeId Class See Also Send Feedback
"Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId VolumeOfInterestHeight { get; }
Visual Basic
Public Shared ReadOnly Property VolumeOfInterestHeight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ VolumeOfInterestHeight {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


VolumeOfInterestName Property

[image]

Revit 2024 API
ParameterTypeId..::..VolumeOfInterestName Property
ParameterTypeId Class See Also Send Feedback
"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId VolumeOfInterestName { get; }
Visual Basic
Public Shared ReadOnly Property VolumeOfInterestName As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ VolumeOfInterestName {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


VolumeOfInterestViewsVisible Property

[image]

Revit 2024 API
ParameterTypeId..::..VolumeOfInterestViewsVisible Property
ParameterTypeId Class See Also Send Feedback
"Views Visible"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId VolumeOfInterestViewsVisible { get; }
Visual Basic
Public Shared ReadOnly Property VolumeOfInterestViewsVisible As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ VolumeOfInterestViewsVisible {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


WalkthroughFramesCount Property

[image]

Revit 2024 API
ParameterTypeId..::..WalkthroughFramesCount Property
ParameterTypeId Class See Also Send Feedback
"Walkthrough Frames"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId WalkthroughFramesCount { get; }
Visual Basic
Public Shared ReadOnly Property WalkthroughFramesCount As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WalkthroughFramesCount {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


WallAlignKeyRefParam Property

[image]

Revit 2024 API
ParameterTypeId..::..WallAlignKeyRefParam Property
ParameterTypeId Class See Also Send Feedback
"Location line to align"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId WallAlignKeyRefParam { get; }
Visual Basic
Public Shared ReadOnly Property WallAlignKeyRefParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WallAlignKeyRefParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


WallAttrDefheightParam Property

[image]

Revit 2024 API
ParameterTypeId..::..WallAttrDefheightParam Property
ParameterTypeId Class See Also Send Feedback
"Default height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId WallAttrDefheightParam { get; }
Visual Basic
Public Shared ReadOnly Property WallAttrDefheightParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WallAttrDefheightParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


WallAttrHeightParam Property

[image]

Revit 2024 API
ParameterTypeId..::..WallAttrHeightParam Property
ParameterTypeId Class See Also Send Feedback
"Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId WallAttrHeightParam { get; }
Visual Basic
Public Shared ReadOnly Property WallAttrHeightParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WallAttrHeightParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


WallAttrRoomBounding Property

[image]

Revit 2024 API
ParameterTypeId..::..WallAttrRoomBounding Property
ParameterTypeId Class See Also Send Feedback
"Room Bounding"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId WallAttrRoomBounding { get; }
Visual Basic
Public Shared ReadOnly Property WallAttrRoomBounding As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WallAttrRoomBounding {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


WallAttrWidthParam Property

[image]

Revit 2024 API
ParameterTypeId..::..WallAttrWidthParam Property
ParameterTypeId Class See Also Send Feedback
"Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId WallAttrWidthParam { get; }
Visual Basic
Public Shared ReadOnly Property WallAttrWidthParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WallAttrWidthParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


WallBaseHeightParam Property

[image]

Revit 2024 API
ParameterTypeId..::..WallBaseHeightParam Property
ParameterTypeId Class See Also Send Feedback
"Base height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId WallBaseHeightParam { get; }
Visual Basic
Public Shared ReadOnly Property WallBaseHeightParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WallBaseHeightParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


WallBaseOffset Property

[image]

Revit 2024 API
ParameterTypeId..::..WallBaseOffset Property
ParameterTypeId Class See Also Send Feedback
"Base Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId WallBaseOffset { get; }
Visual Basic
Public Shared ReadOnly Property WallBaseOffset As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WallBaseOffset {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


WallBottomExtensionDistParam Property

[image]

Revit 2024 API
ParameterTypeId..::..WallBottomExtensionDistParam Property
ParameterTypeId Class See Also Send Feedback
"Base Extension Distance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId WallBottomExtensionDistParam { get; }
Visual Basic
Public Shared ReadOnly Property WallBottomExtensionDistParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WallBottomExtensionDistParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


WallBottomIsAttached Property

[image]

Revit 2024 API
ParameterTypeId..::..WallBottomIsAttached Property
ParameterTypeId Class See Also Send Feedback
"Base is Attached"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId WallBottomIsAttached { get; }
Visual Basic
Public Shared ReadOnly Property WallBottomIsAttached As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WallBottomIsAttached {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


WallKeyRefParam Property

[image]

Revit 2024 API
ParameterTypeId..::..WallKeyRefParam Property
ParameterTypeId Class See Also Send Feedback
"Location Line"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId WallKeyRefParam { get; }
Visual Basic
Public Shared ReadOnly Property WallKeyRefParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WallKeyRefParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


WallLocationLineOffsetParam Property

[image]

Revit 2024 API
ParameterTypeId..::..WallLocationLineOffsetParam Property
ParameterTypeId Class See Also Send Feedback
"Location Line Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId WallLocationLineOffsetParam { get; }
Visual Basic
Public Shared ReadOnly Property WallLocationLineOffsetParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WallLocationLineOffsetParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


WallSingleSlantAngleFromVertical Property

[image]

Revit 2024 API
ParameterTypeId..::..WallSingleSlantAngleFromVertical Property
ParameterTypeId Class See Also Send Feedback
"Angle From Vertical"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId WallSingleSlantAngleFromVertical { get; }
Visual Basic
Public Shared ReadOnly Property WallSingleSlantAngleFromVertical As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WallSingleSlantAngleFromVertical {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


WallStructuralUsageParam Property

[image]

Revit 2024 API
ParameterTypeId..::..WallStructuralUsageParam Property
ParameterTypeId Class See Also Send Feedback
"Structural Usage"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId WallStructuralUsageParam { get; }
Visual Basic
Public Shared ReadOnly Property WallStructuralUsageParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WallStructuralUsageParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


WallStructureIdParam Property

[image]

Revit 2024 API
ParameterTypeId..::..WallStructureIdParam Property
ParameterTypeId Class See Also Send Feedback
"Structure"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId WallStructureIdParam { get; }
Visual Basic
Public Shared ReadOnly Property WallStructureIdParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WallStructureIdParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


WallSweepCutByInsertsParam Property

[image]

Revit 2024 API
ParameterTypeId..::..WallSweepCutByInsertsParam Property
ParameterTypeId Class See Also Send Feedback
"Cut by Inserts"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId WallSweepCutByInsertsParam { get; }
Visual Basic
Public Shared ReadOnly Property WallSweepCutByInsertsParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WallSweepCutByInsertsParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


WallSweepDefaultSetbackParam Property

[image]

Revit 2024 API
ParameterTypeId..::..WallSweepDefaultSetbackParam Property
ParameterTypeId Class See Also Send Feedback
"Default Setback"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId WallSweepDefaultSetbackParam { get; }
Visual Basic
Public Shared ReadOnly Property WallSweepDefaultSetbackParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WallSweepDefaultSetbackParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


WallSweepLevelParam Property

[image]

Revit 2024 API
ParameterTypeId..::..WallSweepLevelParam Property
ParameterTypeId Class See Also Send Feedback
"Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId WallSweepLevelParam { get; }
Visual Basic
Public Shared ReadOnly Property WallSweepLevelParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WallSweepLevelParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


WallSweepOrientation Property

[image]

Revit 2024 API
ParameterTypeId..::..WallSweepOrientation Property
ParameterTypeId Class See Also Send Feedback
"Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId WallSweepOrientation { get; }
Visual Basic
Public Shared ReadOnly Property WallSweepOrientation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WallSweepOrientation {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


WallSweepProfileParam Property

[image]

Revit 2024 API
ParameterTypeId..::..WallSweepProfileParam Property
ParameterTypeId Class See Also Send Feedback
"Profile"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId WallSweepProfileParam { get; }
Visual Basic
Public Shared ReadOnly Property WallSweepProfileParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WallSweepProfileParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


WallSweepWallOffsetParam Property

[image]

Revit 2024 API
ParameterTypeId..::..WallSweepWallOffsetParam Property
ParameterTypeId Class See Also Send Feedback
"Offset From Wall"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId WallSweepWallOffsetParam { get; }
Visual Basic
Public Shared ReadOnly Property WallSweepWallOffsetParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WallSweepWallOffsetParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


WallSweepWallSubcategoryId Property

[image]

Revit 2024 API
ParameterTypeId..::..WallSweepWallSubcategoryId Property
ParameterTypeId Class See Also Send Feedback
"Subcategory of Walls"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId WallSweepWallSubcategoryId { get; }
Visual Basic
Public Shared ReadOnly Property WallSweepWallSubcategoryId As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WallSweepWallSubcategoryId {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


WallTaperedExteriorInwardAngle Property

[image]

Revit 2024 API
ParameterTypeId..::..WallTaperedExteriorInwardAngle Property
ParameterTypeId Class See Also Send Feedback
"Exterior Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId WallTaperedExteriorInwardAngle { get; }
Visual Basic
Public Shared ReadOnly Property WallTaperedExteriorInwardAngle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WallTaperedExteriorInwardAngle {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


WallTaperedInteriorInwardAngle Property

[image]

Revit 2024 API
ParameterTypeId..::..WallTaperedInteriorInwardAngle Property
ParameterTypeId Class See Also Send Feedback
"Interior Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId WallTaperedInteriorInwardAngle { get; }
Visual Basic
Public Shared ReadOnly Property WallTaperedInteriorInwardAngle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WallTaperedInteriorInwardAngle {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


WallTaperedUseInstanceAngles Property

[image]

Revit 2024 API
ParameterTypeId..::..WallTaperedUseInstanceAngles Property
ParameterTypeId Class See Also Send Feedback
"Enable Angle Overrides"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId WallTaperedUseInstanceAngles { get; }
Visual Basic
Public Shared ReadOnly Property WallTaperedUseInstanceAngles As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WallTaperedUseInstanceAngles {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


WallTaperedWidthAtBottom Property

[image]

Revit 2024 API
ParameterTypeId..::..WallTaperedWidthAtBottom Property
ParameterTypeId Class See Also Send Feedback
"Bottom Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId WallTaperedWidthAtBottom { get; }
Visual Basic
Public Shared ReadOnly Property WallTaperedWidthAtBottom As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WallTaperedWidthAtBottom {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


WallTaperedWidthAtTop Property

[image]

Revit 2024 API
ParameterTypeId..::..WallTaperedWidthAtTop Property
ParameterTypeId Class See Also Send Feedback
"Top Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId WallTaperedWidthAtTop { get; }
Visual Basic
Public Shared ReadOnly Property WallTaperedWidthAtTop As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WallTaperedWidthAtTop {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


WallTopOffset Property

[image]

Revit 2024 API
ParameterTypeId..::..WallTopOffset Property
ParameterTypeId Class See Also Send Feedback
"Top Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId WallTopOffset { get; }
Visual Basic
Public Shared ReadOnly Property WallTopOffset As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WallTopOffset {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


WallTypeDefaultTaperedExteriorInwardAngle Property

[image]

Revit 2024 API
ParameterTypeId..::..WallTypeDefaultTaperedExteriorInwardAngle Property
ParameterTypeId Class See Also Send Feedback
"Default Exterior Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId WallTypeDefaultTaperedExteriorInwardAngle { get; }
Visual Basic
Public Shared ReadOnly Property WallTypeDefaultTaperedExteriorInwardAngle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WallTypeDefaultTaperedExteriorInwardAngle {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


WallTypeDefaultTaperedInteriorInwardAngle Property

[image]

Revit 2024 API
ParameterTypeId..::..WallTypeDefaultTaperedInteriorInwardAngle Property
ParameterTypeId Class See Also Send Feedback
"Default Interior Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId WallTypeDefaultTaperedInteriorInwardAngle { get; }
Visual Basic
Public Shared ReadOnly Property WallTypeDefaultTaperedInteriorInwardAngle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WallTypeDefaultTaperedInteriorInwardAngle {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


WallTypeWidthMeasuredAt Property

[image]

Revit 2024 API
ParameterTypeId..::..WallTypeWidthMeasuredAt Property
ParameterTypeId Class See Also Send Feedback
"Width Measured At"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId WallTypeWidthMeasuredAt { get; }
Visual Basic
Public Shared ReadOnly Property WallTypeWidthMeasuredAt As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WallTypeWidthMeasuredAt {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


WallUserHeightParam Property

[image]

Revit 2024 API
ParameterTypeId..::..WallUserHeightParam Property
ParameterTypeId Class See Also Send Feedback
"Unconnected Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId WallUserHeightParam { get; }
Visual Basic
Public Shared ReadOnly Property WallUserHeightParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WallUserHeightParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


WindowTypeName Property

[image]

Revit 2024 API
ParameterTypeId..::..WindowTypeName Property
ParameterTypeId Class See Also Send Feedback
"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId WindowTypeName { get; }
Visual Basic
Public Shared ReadOnly Property WindowTypeName As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WindowTypeName {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


WitnsLineGapToElt Property

[image]

Revit 2024 API
ParameterTypeId..::..WitnsLineGapToElt Property
ParameterTypeId Class See Also Send Feedback
"Witness Line Gap to Element"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId WitnsLineGapToElt { get; }
Visual Basic
Public Shared ReadOnly Property WitnsLineGapToElt As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WitnsLineGapToElt {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


WrappingAtEndsParam Property

[image]

Revit 2024 API
ParameterTypeId..::..WrappingAtEndsParam Property
ParameterTypeId Class See Also Send Feedback
"Wrapping at Ends"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId WrappingAtEndsParam { get; }
Visual Basic
Public Shared ReadOnly Property WrappingAtEndsParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WrappingAtEndsParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


WrappingAtInsertsParam Property

[image]

Revit 2024 API
ParameterTypeId..::..WrappingAtInsertsParam Property
ParameterTypeId Class See Also Send Feedback
"Wrapping at Inserts"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId WrappingAtInsertsParam { get; }
Visual Basic
Public Shared ReadOnly Property WrappingAtInsertsParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WrappingAtInsertsParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


YJustification Property

[image]

Revit 2024 API
ParameterTypeId..::..YJustification Property
ParameterTypeId Class See Also Send Feedback
"y Justification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId YJustification { get; }
Visual Basic
Public Shared ReadOnly Property YJustification As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ YJustification {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


YOffsetValue Property

[image]

Revit 2024 API
ParameterTypeId..::..YOffsetValue Property
ParameterTypeId Class See Also Send Feedback
"y Offset Value"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId YOffsetValue { get; }
Visual Basic
Public Shared ReadOnly Property YOffsetValue As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ YOffsetValue {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


YzJustification Property

[image]

Revit 2024 API
ParameterTypeId..::..YzJustification Property
ParameterTypeId Class See Also Send Feedback
"yz Justification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId YzJustification { get; }
Visual Basic
Public Shared ReadOnly Property YzJustification As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ YzJustification {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ZOffsetValue Property

[image]

Revit 2024 API
ParameterTypeId..::..ZOffsetValue Property
ParameterTypeId Class See Also Send Feedback
"z Offset Value"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ZOffsetValue { get; }
Visual Basic
Public Shared ReadOnly Property ZOffsetValue As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ZOffsetValue {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ZoneAirChangesPerHour Property

[image]

Revit 2024 API
ParameterTypeId..::..ZoneAirChangesPerHour Property
ParameterTypeId Class See Also Send Feedback
"Air Changes per Hour"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ZoneAirChangesPerHour { get; }
Visual Basic
Public Shared ReadOnly Property ZoneAirChangesPerHour As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ZoneAirChangesPerHour {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ZoneAirVolumeCalculationTypeParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ZoneAirVolumeCalculationTypeParam Property
ParameterTypeId Class See Also Send Feedback
"Air Volume Calculation Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ZoneAirVolumeCalculationTypeParam { get; }
Visual Basic
Public Shared ReadOnly Property ZoneAirVolumeCalculationTypeParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ZoneAirVolumeCalculationTypeParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ZoneArea Property

[image]

Revit 2024 API
ParameterTypeId..::..ZoneArea Property
ParameterTypeId Class See Also Send Feedback
"Occupied Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ZoneArea { get; }
Visual Basic
Public Shared ReadOnly Property ZoneArea As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ZoneArea {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ZoneAreaGross Property

[image]

Revit 2024 API
ParameterTypeId..::..ZoneAreaGross Property
ParameterTypeId Class See Also Send Feedback
"Gross Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ZoneAreaGross { get; }
Visual Basic
Public Shared ReadOnly Property ZoneAreaGross As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ZoneAreaGross {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ZoneCalculatedAreaPerCoolingLoadParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ZoneCalculatedAreaPerCoolingLoadParam Property
ParameterTypeId Class See Also Send Feedback
"Calculated Area per Cooling Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ZoneCalculatedAreaPerCoolingLoadParam { get; }
Visual Basic
Public Shared ReadOnly Property ZoneCalculatedAreaPerCoolingLoadParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ZoneCalculatedAreaPerCoolingLoadParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ZoneCalculatedAreaPerHeatingLoadParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ZoneCalculatedAreaPerHeatingLoadParam Property
ParameterTypeId Class See Also Send Feedback
"Calculated Area per Heating Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ZoneCalculatedAreaPerHeatingLoadParam { get; }
Visual Basic
Public Shared ReadOnly Property ZoneCalculatedAreaPerHeatingLoadParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ZoneCalculatedAreaPerHeatingLoadParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ZoneCalculatedCoolingLoadParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ZoneCalculatedCoolingLoadParam Property
ParameterTypeId Class See Also Send Feedback
"Calculated Cooling Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ZoneCalculatedCoolingLoadParam { get; }
Visual Basic
Public Shared ReadOnly Property ZoneCalculatedCoolingLoadParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ZoneCalculatedCoolingLoadParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ZoneCalculatedCoolingLoadPerAreaParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ZoneCalculatedCoolingLoadPerAreaParam Property
ParameterTypeId Class See Also Send Feedback
"Calculated Cooling Load per area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ZoneCalculatedCoolingLoadPerAreaParam { get; }
Visual Basic
Public Shared ReadOnly Property ZoneCalculatedCoolingLoadPerAreaParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ZoneCalculatedCoolingLoadPerAreaParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ZoneCalculatedHeatingLoadParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ZoneCalculatedHeatingLoadParam Property
ParameterTypeId Class See Also Send Feedback
"Calculated Heating Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ZoneCalculatedHeatingLoadParam { get; }
Visual Basic
Public Shared ReadOnly Property ZoneCalculatedHeatingLoadParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ZoneCalculatedHeatingLoadParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ZoneCalculatedHeatingLoadPerAreaParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ZoneCalculatedHeatingLoadPerAreaParam Property
ParameterTypeId Class See Also Send Feedback
"Calculated Heating Load per area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ZoneCalculatedHeatingLoadPerAreaParam { get; }
Visual Basic
Public Shared ReadOnly Property ZoneCalculatedHeatingLoadPerAreaParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ZoneCalculatedHeatingLoadPerAreaParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ZoneCalculatedHydronicCoolingflowParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ZoneCalculatedHydronicCoolingflowParam Property
ParameterTypeId Class See Also Send Feedback
"Calculated Hydronic Cooling Flow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ZoneCalculatedHydronicCoolingflowParam { get; }
Visual Basic
Public Shared ReadOnly Property ZoneCalculatedHydronicCoolingflowParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ZoneCalculatedHydronicCoolingflowParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ZoneCalculatedHydronicHeatingflowParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ZoneCalculatedHydronicHeatingflowParam Property
ParameterTypeId Class See Also Send Feedback
"Calculated Hydronic Heating Flow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ZoneCalculatedHydronicHeatingflowParam { get; }
Visual Basic
Public Shared ReadOnly Property ZoneCalculatedHydronicHeatingflowParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ZoneCalculatedHydronicHeatingflowParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ZoneCalculatedSupplyAirflowPerAreaParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ZoneCalculatedSupplyAirflowPerAreaParam Property
ParameterTypeId Class See Also Send Feedback
"Calculated Supply Airflow per area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ZoneCalculatedSupplyAirflowPerAreaParam { get; }
Visual Basic
Public Shared ReadOnly Property ZoneCalculatedSupplyAirflowPerAreaParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ZoneCalculatedSupplyAirflowPerAreaParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ZoneCoilBypassPercentageParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ZoneCoilBypassPercentageParam Property
ParameterTypeId Class See Also Send Feedback
"Coil Bypass"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ZoneCoilBypassPercentageParam { get; }
Visual Basic
Public Shared ReadOnly Property ZoneCoilBypassPercentageParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ZoneCoilBypassPercentageParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ZoneCoolingInformationParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ZoneCoolingInformationParam Property
ParameterTypeId Class See Also Send Feedback
"Cooling Information"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ZoneCoolingInformationParam { get; }
Visual Basic
Public Shared ReadOnly Property ZoneCoolingInformationParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ZoneCoolingInformationParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ZoneCoolingSetPointParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ZoneCoolingSetPointParam Property
ParameterTypeId Class See Also Send Feedback
"Cooling Set Point"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ZoneCoolingSetPointParam { get; }
Visual Basic
Public Shared ReadOnly Property ZoneCoolingSetPointParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ZoneCoolingSetPointParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ZoneDehumidificationSetPointParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ZoneDehumidificationSetPointParam Property
ParameterTypeId Class See Also Send Feedback
"Dehumidification Set Point"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ZoneDehumidificationSetPointParam { get; }
Visual Basic
Public Shared ReadOnly Property ZoneDehumidificationSetPointParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ZoneDehumidificationSetPointParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ZoneDesignHeatTemperature Property

[image]

Revit 2024 API
ParameterTypeId..::..ZoneDesignHeatTemperature Property
ParameterTypeId Class See Also Send Feedback
"Design Temperature for Heating"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ZoneDesignHeatTemperature { get; }
Visual Basic
Public Shared ReadOnly Property ZoneDesignHeatTemperature As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ZoneDesignHeatTemperature {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ZoneHeatingAirTemperatureParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ZoneHeatingAirTemperatureParam Property
ParameterTypeId Class See Also Send Feedback
"Heating Air Temperature"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ZoneHeatingAirTemperatureParam { get; }
Visual Basic
Public Shared ReadOnly Property ZoneHeatingAirTemperatureParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ZoneHeatingAirTemperatureParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ZoneHeatingSetPointParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ZoneHeatingSetPointParam Property
ParameterTypeId Class See Also Send Feedback
"Heating Set Point"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ZoneHeatingSetPointParam { get; }
Visual Basic
Public Shared ReadOnly Property ZoneHeatingSetPointParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ZoneHeatingSetPointParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ZoneLevelId Property

[image]

Revit 2024 API
ParameterTypeId..::..ZoneLevelId Property
ParameterTypeId Class See Also Send Feedback
"Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ZoneLevelId { get; }
Visual Basic
Public Shared ReadOnly Property ZoneLevelId As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ZoneLevelId {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ZoneLevelOffset Property

[image]

Revit 2024 API
ParameterTypeId..::..ZoneLevelOffset Property
ParameterTypeId Class See Also Send Feedback
"Level Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ZoneLevelOffset { get; }
Visual Basic
Public Shared ReadOnly Property ZoneLevelOffset As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ZoneLevelOffset {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ZoneName Property

[image]

Revit 2024 API
ParameterTypeId..::..ZoneName Property
ParameterTypeId Class See Also Send Feedback
"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ZoneName { get; }
Visual Basic
Public Shared ReadOnly Property ZoneName As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ZoneName {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ZoneOaRatePerAchParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ZoneOaRatePerAchParam Property
ParameterTypeId Class See Also Send Feedback
"Outdoor Air Rate / Air Changes per Hour"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ZoneOaRatePerAchParam { get; }
Visual Basic
Public Shared ReadOnly Property ZoneOaRatePerAchParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ZoneOaRatePerAchParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ZoneOutdoorAirInformationParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ZoneOutdoorAirInformationParam Property
ParameterTypeId Class See Also Send Feedback
"Outdoor Air Information"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ZoneOutdoorAirInformationParam { get; }
Visual Basic
Public Shared ReadOnly Property ZoneOutdoorAirInformationParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ZoneOutdoorAirInformationParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ZoneOutsideAirFlowPerArea Property

[image]

Revit 2024 API
ParameterTypeId..::..ZoneOutsideAirFlowPerArea Property
ParameterTypeId Class See Also Send Feedback
"Outside Air Flow per Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ZoneOutsideAirFlowPerArea { get; }
Visual Basic
Public Shared ReadOnly Property ZoneOutsideAirFlowPerArea As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ZoneOutsideAirFlowPerArea {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ZoneOutsideAirFlowPerPerson Property

[image]

Revit 2024 API
ParameterTypeId..::..ZoneOutsideAirFlowPerPerson Property
ParameterTypeId Class See Also Send Feedback
"Outside Air Flow per Person"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ZoneOutsideAirFlowPerPerson { get; }
Visual Basic
Public Shared ReadOnly Property ZoneOutsideAirFlowPerPerson As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ZoneOutsideAirFlowPerPerson {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ZoneOutsideAirPerAreaParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ZoneOutsideAirPerAreaParam Property
ParameterTypeId Class See Also Send Feedback
"Outdoor Air per Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ZoneOutsideAirPerAreaParam { get; }
Visual Basic
Public Shared ReadOnly Property ZoneOutsideAirPerAreaParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ZoneOutsideAirPerAreaParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ZonePhase Property

[image]

Revit 2024 API
ParameterTypeId..::..ZonePhase Property
ParameterTypeId Class See Also Send Feedback
"Phase"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ZonePhase { get; }
Visual Basic
Public Shared ReadOnly Property ZonePhase As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ZonePhase {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ZonePhaseId Property

[image]

Revit 2024 API
ParameterTypeId..::..ZonePhaseId Property
ParameterTypeId Class See Also Send Feedback
"Phase Id"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ZonePhaseId { get; }
Visual Basic
Public Shared ReadOnly Property ZonePhaseId As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ZonePhaseId {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ZoneServiceTypeParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ZoneServiceTypeParam Property
ParameterTypeId Class See Also Send Feedback
"Service Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ZoneServiceTypeParam { get; }
Visual Basic
Public Shared ReadOnly Property ZoneServiceTypeParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ZoneServiceTypeParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ZoneUseAirChangesPerHourParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ZoneUseAirChangesPerHourParam Property
ParameterTypeId Class See Also Send Feedback
"Use Air Changes Per Hour"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ZoneUseAirChangesPerHourParam { get; }
Visual Basic
Public Shared ReadOnly Property ZoneUseAirChangesPerHourParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ZoneUseAirChangesPerHourParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ZoneUseDehumidificationSetpointParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ZoneUseDehumidificationSetpointParam Property
ParameterTypeId Class See Also Send Feedback
"Use Dehumidification Set Point"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ZoneUseDehumidificationSetpointParam { get; }
Visual Basic
Public Shared ReadOnly Property ZoneUseDehumidificationSetpointParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ZoneUseDehumidificationSetpointParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ZoneUseHumidificationSetpointParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ZoneUseHumidificationSetpointParam Property
ParameterTypeId Class See Also Send Feedback
"Use Humidification Set Point"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ZoneUseHumidificationSetpointParam { get; }
Visual Basic
Public Shared ReadOnly Property ZoneUseHumidificationSetpointParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ZoneUseHumidificationSetpointParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ZoneUseOutsideAirPerAreaParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ZoneUseOutsideAirPerAreaParam Property
ParameterTypeId Class See Also Send Feedback
"Use Outside Air Per Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ZoneUseOutsideAirPerAreaParam { get; }
Visual Basic
Public Shared ReadOnly Property ZoneUseOutsideAirPerAreaParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ZoneUseOutsideAirPerAreaParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ZoneUseOutsideAirPerPersonParam Property

[image]

Revit 2024 API
ParameterTypeId..::..ZoneUseOutsideAirPerPersonParam Property
ParameterTypeId Class See Also Send Feedback
"Use Outside Air Per Person"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ZoneUseOutsideAirPerPersonParam { get; }
Visual Basic
Public Shared ReadOnly Property ZoneUseOutsideAirPerPersonParam As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ZoneUseOutsideAirPerPersonParam {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ZoneVolume Property

[image]

Revit 2024 API
ParameterTypeId..::..ZoneVolume Property
ParameterTypeId Class See Also Send Feedback
"Occupied Volume"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ZoneVolume { get; }
Visual Basic
Public Shared ReadOnly Property ZoneVolume As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ZoneVolume {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ZoneVolumeGross Property

[image]

Revit 2024 API
ParameterTypeId..::..ZoneVolumeGross Property
ParameterTypeId Class See Also Send Feedback
"Gross Volume"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId ZoneVolumeGross { get; }
Visual Basic
Public Shared ReadOnly Property ZoneVolumeGross As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ZoneVolumeGross {
    ForgeTypeId^ get ();
}

See Also

ParameterTypeId Class


ParameterUtils Members

[image] [image]

Revit 2024 API
ParameterUtils Members
ParameterUtils Class Methods See Also Send Feedback

The ParameterUtils type exposes the following members.

Methods

Name | Description
DownloadCompanyName | Downloads the name of the given parameter's owning account and records it in the given document. If the owning account's name is already recorded in the given document, this method returns the name without downloading it again.
DownloadParameter | Create a shared parameter element in the given document according to a parameter definition downloaded from the Parameters Service.
DownloadParameterOptions | Retrieves settings associated with the given parameter from the Parameters Service.
GetAllBuiltInGroups | Gets the identifiers of all built-in parameter groups.
GetAllBuiltInParameters | Gets the identifiers of all built-in parameters.
GetBuiltInParameter | Gets the BuiltInParameter value corresponding to built-in parameter identified by the given ForgeTypeId.
GetBuiltInParameterGroup | Obsolete. Gets the BuiltInParameterGroup value corresponding to built-in parameter group identified by the given ForgeTypeId.
GetParameterGroupTypeId | Obsolete. Gets the ForgeTypeId identifying the built-in parameter group corresponding to BuiltInParameterGroup value.
GetParameterTypeId | Gets the ForgeTypeId identifying the built-in parameter corresponding to the given BuiltInParameter value.
IsBuiltInGroup | Checks whether a ForgeTypeId identifies a built-in parameter group.
IsBuiltInParameter(ElementId) | Checks whether an ElementId identifies a built-in parameter.
IsBuiltInParameter(ForgeTypeId) | Checks whether a ForgeTypeId identifies a built-in parameter.

See Also

ParameterUtils Class


DownloadCompanyName Method

[image]

Revit 2024 API
ParameterUtils..::..DownloadCompanyName Method
ParameterUtils Class See Also Send Feedback
Downloads the name of the given parameter's owning account and records it in the given document. If the owning account's name is already recorded in the given document, this method returns the name without downloading it again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static string DownloadCompanyName(
    Document document,
    ForgeTypeId parameterTypeId
)
Visual Basic
Public Shared Function DownloadCompanyName ( _
    document As Document, _
    parameterTypeId As ForgeTypeId _
) As String
Visual C++
public:
static String^ DownloadCompanyName(
    Document^ document,
    ForgeTypeId^ parameterTypeId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Document in which to record the name of the parameter's owning account.
parameterTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
Parameter identifier.

Return Value

Name of the owning account.

Remarks

In Revit, the account name appears in the parameter tooltip if available.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..AccessDeniedException | Thrown when the user is not authorized to access the requested information.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the parameter identifier does not include an account identifier.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
[!:Autodesk::Revit::Exceptions::NetworkCommunicationError] | Thrown when communication with the remote service is unsuccessful.
Autodesk.Revit.Exceptions..::..ResourceNotFoundException | Thrown when the requested information is not found.
Autodesk.Revit.Exceptions..::..ServerInternalException | Thrown when the remote service reports an internal error.
Autodesk.Revit.Exceptions..::..UnauthenticatedException | Thrown when the user is not signed in.

See Also

ParameterUtils Class


DownloadParameter Method

[image]

Revit 2024 API
ParameterUtils..::..DownloadParameter Method
ParameterUtils Class See Also Send Feedback
Create a shared parameter element in the given document according to a parameter definition downloaded from the Parameters Service.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static SharedParameterElement DownloadParameter(
    Document document,
    ParameterDownloadOptions options,
    ForgeTypeId parameterTypeId
)
Visual Basic
Public Shared Function DownloadParameter ( _
    document As Document, _
    options As ParameterDownloadOptions, _
    parameterTypeId As ForgeTypeId _
) As SharedParameterElement
Visual C++
public:
static SharedParameterElement^ DownloadParameter(
    Document^ document,
    ParameterDownloadOptions^ options,
    ForgeTypeId^ parameterTypeId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Document in which to create a shared parameter from a downloaded definition.
options
Type: Autodesk.Revit.DB..::..ParameterDownloadOptions
Parameter download options.
parameterTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
Parameter identifier.

Return Value

The shared parameter instance.

Remarks

The identifier of a user-defined parameter definition on the Parameters Service has the form "parameters.<accountId>:<schemaId>-<versionNumber>", where <versionNumber> is a semantic version number such as "1.0.0" and <accountId> and <schemaId> are GUIDs consisting of 32 hexadecimal digits. Revit will extract the <schemaId> GUID to identify the shared parameter element.

If a shared parameter with a matching GUID is not yet present in the document, this method will attempt to obtain the parameter and apply the given bindings. If the parameter definition is already available locally, Revit will use the local definition. Otherwise, Revit will attempt to download the requested parameter definition from the Parameters Service.

The given document may be either a project or a family document. The rules for adding parameters to project and family documents differ.

For family documents, requesting a parameter with a GUID matching that of a shared parameter already present in the family document is an error.

Family parameters must have unique names. There is an error if the target document is a family and the downloaded parameter is found to have a name that matches that of a parameter already present in the family document.

Family parameters must be initialized to a default value. There is an error if the target document is a family and the downloaded parameter is a Family Type parameter and no family of the requisite category exists in the family document.

When the target document is a project, if a parameter exactly matching the given ForgeTypeId is already present in the document, this method will not download anything. Otherwise, if a local shared parameter with a GUID colliding with the given ForgeTypeId is already present in the project document, this method will download the requested parameter from the Parameters Service, validate that the requested parameter is compatible with the existing local definition, and overwrite the existing local definition according to the downloaded definition. Attempting to download an incompatible definition that collides with an existing local shared parameter is an error. If the parameter or a compatible local parameter is already present in the target project document, this method will update the existing parameter's bindings according to the given bindings. When updating bindings, new category bindings may be added to the existing parameter but existing category bindings will not be removed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the parameter identifier does not include a GUID, when required bindings are not assigned, when the requested group identifier does not identify a group that accommodates user-defined parameters, when a parameter with a matching GUID is already present in the given family document, when the given project document already contains an incompatible parameter definition with the same GUID, or when a parameter with a matching name is already present in the given family document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..DefaultValueException | Thrown when the target document is a family and the downloaded parameter is a Family Type parameter and no family of the requisite category exists in the family document.
Autodesk.Revit.Exceptions..::..NetworkCommunicationException | Thrown when communication with the Parameters Service is unsuccessful.
Autodesk.Revit.Exceptions..::..ResourceNotFoundException | Thrown when the requested parameter definition is not found on the Parameters Service.
Autodesk.Revit.Exceptions..::..SchemaException | Thrown when there is an error interpreting a downloaded parameter definition.

See Also

ParameterUtils Class


GetAllBuiltInGroups Method

[image]

Revit 2024 API
ParameterUtils..::..GetAllBuiltInGroups Method
ParameterUtils Class See Also Send Feedback
Gets the identifiers of all built-in parameter groups.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public static IList<ForgeTypeId> GetAllBuiltInGroups()
Visual Basic
Public Shared Function GetAllBuiltInGroups As IList(Of ForgeTypeId)
Visual C++
public:
static IList<ForgeTypeId^>^ GetAllBuiltInGroups()

Return Value

The built-in group identifiers.

See Also

ParameterUtils Class


GetAllBuiltInParameters Method

[image]

Revit 2024 API
ParameterUtils..::..GetAllBuiltInParameters Method
ParameterUtils Class See Also Send Feedback
Gets the identifiers of all built-in parameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public static IList<ForgeTypeId> GetAllBuiltInParameters()
Visual Basic
Public Shared Function GetAllBuiltInParameters As IList(Of ForgeTypeId)
Visual C++
public:
static IList<ForgeTypeId^>^ GetAllBuiltInParameters()

Return Value

The built-in parameter identifiers.

See Also

ParameterUtils Class


GetBuiltInParameter Method

[image]

Revit 2024 API
ParameterUtils..::..GetBuiltInParameter Method
ParameterUtils Class See Also Send Feedback
Gets the BuiltInParameter value corresponding to built-in parameter identified by the given ForgeTypeId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static BuiltInParameter GetBuiltInParameter(
    ForgeTypeId parameterTypeId
)
Visual Basic
Public Shared Function GetBuiltInParameter ( _
    parameterTypeId As ForgeTypeId _
) As BuiltInParameter
Visual C++
public:
static BuiltInParameter GetBuiltInParameter(
    ForgeTypeId^ parameterTypeId
)

Parameters

parameterTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
The parameter identifier.

Return Value

The BuiltInParameter value corresponding to the given parameter identifier.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | parameterTypeId is not a built-in parameter identifier. See IsBuiltInParameter(ForgeTypeId) and GetParameterTypeId(BuiltInParameter).
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterUtils Class


GetBuiltInParameterGroup Method

[image]

Revit 2024 API
ParameterUtils..::..GetBuiltInParameterGroup Method
ParameterUtils Class See Also Send Feedback
Gets the BuiltInParameterGroup value corresponding to built-in parameter group identified by the given ForgeTypeId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
[ObsoleteAttribute("This method is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use members of the `GroupTypeId` class instead.")]
public static BuiltInParameterGroup GetBuiltInParameterGroup(
    ForgeTypeId groupTypeId
)
Visual Basic
<ObsoleteAttribute("This method is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use members of the `GroupTypeId` class instead.")> _
Public Shared Function GetBuiltInParameterGroup ( _
    groupTypeId As ForgeTypeId _
) As BuiltInParameterGroup
Visual C++
[ObsoleteAttribute(L"This method is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use members of the `GroupTypeId` class instead.")]
public:
static BuiltInParameterGroup GetBuiltInParameterGroup(
    ForgeTypeId^ groupTypeId
)

Parameters

groupTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
The parameter group identifier.

Return Value

The BuiltInParameterGroup value corresponding to the given parameter group identifier.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | groupTypeId is not a built-in parameter group identifier. See IsBuiltInParameterGroup(ForgeTypeId) and GetParameterGroupTypeId(BuiltInParameter).
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterUtils Class


GetParameterGroupTypeId Method

[image]

Revit 2024 API
ParameterUtils..::..GetParameterGroupTypeId Method
ParameterUtils Class See Also Send Feedback
Gets the ForgeTypeId identifying the built-in parameter group corresponding to BuiltInParameterGroup value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
[ObsoleteAttribute("This method is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use members of the `GroupTypeId` class instead.")]
public static ForgeTypeId GetParameterGroupTypeId(
    BuiltInParameterGroup builtInParamGroup
)
Visual Basic
<ObsoleteAttribute("This method is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use members of the `GroupTypeId` class instead.")> _
Public Shared Function GetParameterGroupTypeId ( _
    builtInParamGroup As BuiltInParameterGroup _
) As ForgeTypeId
Visual C++
[ObsoleteAttribute(L"This method is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use members of the `GroupTypeId` class instead.")]
public:
static ForgeTypeId^ GetParameterGroupTypeId(
    BuiltInParameterGroup builtInParamGroup
)

Parameters

builtInParamGroup
Type: Autodesk.Revit.DB..::..BuiltInParameterGroup
The BuiltInParameterGroup value.

Return Value

Identifier of the parameter group corresponding to the given BuiltInParameterGroup value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

ParameterUtils Class


GetParameterTypeId Method

[image]

Revit 2024 API
ParameterUtils..::..GetParameterTypeId Method
ParameterUtils Class See Also Send Feedback
Gets the ForgeTypeId identifying the built-in parameter corresponding to the given BuiltInParameter value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId GetParameterTypeId(
    BuiltInParameter builtInParam
)
Visual Basic
Public Shared Function GetParameterTypeId ( _
    builtInParam As BuiltInParameter _
) As ForgeTypeId
Visual C++
public:
static ForgeTypeId^ GetParameterTypeId(
    BuiltInParameter builtInParam
)

Parameters

builtInParam
Type: Autodesk.Revit.DB..::..BuiltInParameter
The BuiltInParameter value.

Return Value

Identifier of the parameter corresponding to the given BuiltInParameter value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

ParameterUtils Class


IsBuiltInGroup Method

[image]

Revit 2024 API
ParameterUtils..::..IsBuiltInGroup Method
ParameterUtils Class See Also Send Feedback
Checks whether a ForgeTypeId identifies a built-in parameter group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public static bool IsBuiltInGroup(
    ForgeTypeId groupTypeId
)
Visual Basic
Public Shared Function IsBuiltInGroup ( _
    groupTypeId As ForgeTypeId _
) As Boolean
Visual C++
public:
static bool IsBuiltInGroup(
    ForgeTypeId^ groupTypeId
)

Parameters

groupTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
The identifier to check.

Return Value

True if the ForgeTypeId identifies a built-in parameter group, false otherwise.

Remarks

A ForgeTypeId identifies a built-in parameter group if it corresponds to a valid BuiltInParameterGroup value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterUtils Class


IsBuiltInParameter Method (ElementId)

[image]

Revit 2024 API
ParameterUtils..::..IsBuiltInParameter Method (ElementId)
ParameterUtils Class See Also Send Feedback
Checks whether an ElementId identifies a built-in parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public static bool IsBuiltInParameter(
    ElementId parameterId
)
Visual Basic
Public Shared Function IsBuiltInParameter ( _
    parameterId As ElementId _
) As Boolean
Visual C++
public:
static bool IsBuiltInParameter(
    ElementId^ parameterId
)

Parameters

parameterId
Type: Autodesk.Revit.DB..::..ElementId
The identifier to check.

Return Value

True if the ElementId identifies a built-in parameter, false otherwise.

Remarks

An ElementId identifies a built-in parameter if it corresponds to a valid BuiltInParameter value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterUtils Class
IsBuiltInParameter Overload


ParameterValue Class

[image]

Revit 2024 API
ParameterValue Class
Members See Also Send Feedback
A class that holds a value of a parameter element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Update

Syntax

C#
public class ParameterValue : IDisposable
Visual Basic
Public Class ParameterValue _
    Implements IDisposable
Visual C++
public ref class ParameterValue : IDisposable

Remarks

This is a non-instantiable base class. Classes that actually store a value of a certain type are all derived from this base class, once class per each value type.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ParameterValue
Autodesk.Revit.DB..::..DoubleParameterValue
Autodesk.Revit.DB..::..ElementIdParameterValue
Autodesk.Revit.DB..::..IntegerParameterValue
Autodesk.Revit.DB..::..NullParameterValue
Autodesk.Revit.DB..::..StringParameterValue

See Also

ParameterValue Members


ParameterValue Methods

[image] [image]

Revit 2024 API
ParameterValue Methods
ParameterValue Class See Also Send Feedback

The ParameterValue type exposes the following members.

Methods

 | Name | Description
Public method | Copy | Makes an identical copy of the given parameter value.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Tests equality with another instance of the same class.
Public method | IsSameType | Tests another instance is of the same value type.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ParameterValue Class


Dispose Method

[image]

Revit 2024 API
ParameterValue..::..Dispose Method
ParameterValue Class See Also Send Feedback
Releases all resources used by the ParameterValue

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ParameterValue Class


IsEqual Method

[image]

Revit 2024 API
ParameterValue..::..IsEqual Method
ParameterValue Class See Also Send Feedback
Tests equality with another instance of the same class.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Update

Syntax

C#
public bool IsEqual(
    ParameterValue other
)
Visual Basic
Public Function IsEqual ( _
    other As ParameterValue _
) As Boolean
Visual C++
public:
bool IsEqual(
    ParameterValue^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..ParameterValue
The instance to compare with

Remarks

The result is always False if the two comparands are of a different value types.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterValue Class


IsSameType Method

[image]

Revit 2024 API
ParameterValue..::..IsSameType Method
ParameterValue Class See Also Send Feedback
Tests another instance is of the same value type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Update

Syntax

C#
public bool IsSameType(
    ParameterValue other
)
Visual Basic
Public Function IsSameType ( _
    other As ParameterValue _
) As Boolean
Visual C++
public:
bool IsSameType(
    ParameterValue^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..ParameterValue
The instance to compare with

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterValue Class


ParameterValue Properties

[image] [image]

Revit 2024 API
ParameterValue Properties
ParameterValue Class See Also Send Feedback

The ParameterValue type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ParameterValue Class


IsValidObject Property

[image]

Revit 2024 API
ParameterValue..::..IsValidObject Property
ParameterValue Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ParameterValue Class


ParameterValuePresenceRule Class

[image]

Revit 2024 API
ParameterValuePresenceRule Class
Members See Also Send Feedback
Tests whether an element's parameter has a value or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public class ParameterValuePresenceRule : FilterRule
Visual Basic
Public Class ParameterValuePresenceRule _
    Inherits FilterRule
Visual C++
public ref class ParameterValuePresenceRule : public FilterRule

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterRule
Autodesk.Revit.DB..::..ParameterValuePresenceRule
Autodesk.Revit.DB..::..HasNoValueFilterRule
Autodesk.Revit.DB..::..HasValueFilterRule

See Also

ParameterValuePresenceRule Members


ParameterValuePresenceRule Members

[image] [image]

Revit 2024 API
ParameterValuePresenceRule Members
ParameterValuePresenceRule Class Methods Properties See Also Send Feedback

The ParameterValuePresenceRule type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterRule.)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter. (Inherited from FilterRule.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterRule.)
Public property | Parameter | The parameter which will be evaluated to pass this rule.

See Also

ParameterValuePresenceRule Class


ParameterValuePresenceRule Properties

[image] [image]

Revit 2024 API
ParameterValuePresenceRule Properties
ParameterValuePresenceRule Class See Also Send Feedback

The ParameterValuePresenceRule type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterRule.)
Public property | Parameter | The parameter which will be evaluated to pass this rule.

See Also

ParameterValuePresenceRule Class


Parameter Property

[image]

Revit 2024 API
ParameterValuePresenceRule..::..Parameter Property
ParameterValuePresenceRule Class See Also Send Feedback
The parameter which will be evaluated to pass this rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public ElementId Parameter { get; set; }
Visual Basic
Public Property Parameter As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ Parameter {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ParameterValuePresenceRule Class


ParameterValueProvider Class

[image]

Revit 2024 API
ParameterValueProvider Class
Members See Also Send Feedback
Gets the value of a parameter from any element passed to GetStringValue, GetDoubleValue, GetIntegerValue, or GetElementIdValue.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class ParameterValueProvider : FilterableValueProvider
Visual Basic
Public Class ParameterValueProvider _
    Inherits FilterableValueProvider
Visual C++
public ref class ParameterValueProvider : public FilterableValueProvider

Remarks

For any parameter, only one of isStringValueSupported, isDoubleValueSupported, isIntegerValueSupported, isElementIdValueSupported will return true. No attempt to convert between types is made. For example, calling GetStringValue, passing the identifier of a numeric-typed parameter will give an empty string. No exception will be thrown, and ParameterValueProvider will not attempt to convert the numeric value to a string.

If an element doesn't have the requested parameter or the element's parameter doesn't have a valid value, ParameterValueProvider will attempt to get the parameter value from the element's type - see GetTypeId()()()().

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterableValueProvider
Autodesk.Revit.DB..::..ParameterValueProvider

See Also

ParameterValueProvider Members


ParameterValueProvider Constructor

[image]

Revit 2024 API
ParameterValueProvider Constructor
ParameterValueProvider Class See Also Send Feedback
Constructs an instance of ParameterValueProvider.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public ParameterValueProvider(
    ElementId parameter
)
Visual Basic
Public Sub New ( _
    parameter As ElementId _
)
Visual C++
public:
ParameterValueProvider(
    ElementId^ parameter
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
The parameter used to provide a string, integer, and double-precision, or ElementId value on request for a given element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ParameterValueProvider Class


ParameterValueProvider Methods

[image] [image]

Revit 2024 API
ParameterValueProvider Methods
ParameterValueProvider Class See Also Send Feedback

The ParameterValueProvider type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterableValueProvider.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAssociatedGlobalParameterValue | Gets a global parameter value associated with a parameter from the given element. (Inherited from FilterableValueProvider.)
Public method | GetDoubleValue | Gets a double-precision numeric value from the given element. (Inherited from FilterableValueProvider.)
Public method | GetElementIdValue | Gets an ElementId value from the given element. (Inherited from FilterableValueProvider.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIntegerValue | Gets an integer value from the given element. (Inherited from FilterableValueProvider.)
Public method | GetStringValue | Gets a string value from the given element. (Inherited from FilterableValueProvider.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDoubleValueSupported | Determines whether the provide can provide a double-precision numeric value for the given element. (Inherited from FilterableValueProvider.)
Public method | IsElementIdValueSupported | Determines whether the provide can provide an ElementId value for the given element. (Inherited from FilterableValueProvider.)
Public method | IsIntegerValueSupported | Determines whether the provide can provide an integer value for the given element. (Inherited from FilterableValueProvider.)
Public method | IsStringValueSupported | Determines whether the provide can provide a string value for the given element. (Inherited from FilterableValueProvider.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ParameterValueProvider Class


ParameterValueProvider Properties

[image] [image]

Revit 2024 API
ParameterValueProvider Properties
ParameterValueProvider Class See Also Send Feedback

The ParameterValueProvider type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterableValueProvider.)
Public property | Parameter | The parameter used to provide a string, integer, double-precision, or ElementId value on request for a given element.

See Also

ParameterValueProvider Class


Parameter Property

[image]

Revit 2024 API
ParameterValueProvider..::..Parameter Property
ParameterValueProvider Class See Also Send Feedback
The parameter used to provide a string, integer, double-precision, or ElementId value on request for a given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public ElementId Parameter { get; set; }
Visual Basic
Public Property Parameter As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ Parameter {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ParameterValueProvider Class


Part Class

[image]

Revit 2024 API
Part Class
Members See Also Send Feedback
This element represents a part of another element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public class Part : Element
Visual Basic
Public Class Part _
    Inherits Element
Visual C++
public ref class Part : public Element

Remarks

A part is associated with a PartMaker element that creates it.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..Part

See Also

Part Members


Part Methods

[image] [image]

Revit 2024 API
Part Methods
Part Class See Also Send Feedback

The Part type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanOffsetFace | Checks if it is possible to offset the given face.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetFaceOffset | Get face offset of the given part face.
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSourceElementIds | Gets a collection of elements from which this Part is created by the PartMaker. May return more than one source only if there is merge involved somewhere in the history of this Part.
Public method | GetSourceElementOriginalCategoryIds | Gets the category ids of the source elements which were used to form this part.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | ResetFaceOffset | Resets the offset applied to the given part face.
Public method | ResetPartShape | Resets all face offsets applied to part faces.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetFaceOffset | Offsets the given part face in the direction that points out of the solid shape with the specified amount. Negative value will offset the face into the solid shape.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Part Class


GetFaceOffset Method

[image]

Revit 2024 API
Part..::..GetFaceOffset Method
Part Class See Also Send Feedback
Get face offset of the given part face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public double GetFaceOffset(
    Face face
)
Visual Basic
Public Function GetFaceOffset ( _
    face As Face _
) As Double
Visual C++
public:
double GetFaceOffset(
    Face^ face
)

Parameters

face
Type: Autodesk.Revit.DB..::..Face
The face whose offset is required.

Return Value

Returns the value of the offset.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | face does not belong to the part.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Part Class


GetSourceElementIds Method

[image]

Revit 2024 API
Part..::..GetSourceElementIds Method
Part Class See Also Send Feedback
Gets a collection of elements from which this Part is created by the PartMaker. May return more than one source only if there is merge involved somewhere in the history of this Part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ICollection<LinkElementId> GetSourceElementIds()
Visual Basic
Public Function GetSourceElementIds As ICollection(Of LinkElementId)
Visual C++
public:
ICollection<LinkElementId^>^ GetSourceElementIds()

Return Value

The collection of elements

Remarks

A source element is one of the elements in the original file that the PartMaker uses to create a Part. For example, a floor or a wall used to create a Part can be called a source element.

See Also

Part Class


GetSourceElementOriginalCategoryIds Method

[image]

Revit 2024 API
Part..::..GetSourceElementOriginalCategoryIds Method
Part Class See Also Send Feedback
Gets the category ids of the source elements which were used to form this part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ICollection<ElementId> GetSourceElementOriginalCategoryIds()
Visual Basic
Public Function GetSourceElementOriginalCategoryIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetSourceElementOriginalCategoryIds()

Return Value

The category ids.

See Also

Part Class


ResetFaceOffset Method

[image]

Revit 2024 API
Part..::..ResetFaceOffset Method
Part Class See Also Send Feedback
Resets the offset applied to the given part face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public void ResetFaceOffset(
    Face face
)
Visual Basic
Public Sub ResetFaceOffset ( _
    face As Face _
)
Visual C++
public:
void ResetFaceOffset(
    Face^ face
)

Parameters

face
Type: Autodesk.Revit.DB..::..Face
The face whose offset needs to be reset.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | face does not belong to the part.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Part Class


ResetPartShape Method

[image]

Revit 2024 API
Part..::..ResetPartShape Method
Part Class See Also Send Feedback
Resets all face offsets applied to part faces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public void ResetPartShape()
Visual Basic
Public Sub ResetPartShape
Visual C++
public:
void ResetPartShape()

See Also

Part Class


SetFaceOffset Method

[image]

Revit 2024 API
Part..::..SetFaceOffset Method
Part Class See Also Send Feedback
Offsets the given part face in the direction that points out of the solid shape with the specified amount. Negative value will offset the face into the solid shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public void SetFaceOffset(
    Face face,
    double offset
)
Visual Basic
Public Sub SetFaceOffset ( _
    face As Face, _
    offset As Double _
)
Visual C++
public:
void SetFaceOffset(
    Face^ face,
    double offset
)

Parameters

face
Type: Autodesk.Revit.DB..::..Face
The face to offset.
offset
Type: System..::..Double
The magnitude of the offset.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | face does not belong to the part. -or- The face to be offset should be planar and satisfy constraints of its parent element
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Part Class


Part Properties

[image] [image]

Revit 2024 API
Part Properties
Part Class See Also Send Feedback

The Part type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Excluded | True if the part is excluded, false otherwise
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OriginalCategoryId | The category Id of the original element corresponding to this Part.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PartMaker | The PartMaker that created this Part.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Part Class


Excluded Property

[image]

Revit 2024 API
Part..::..Excluded Property
Part Class See Also Send Feedback
True if the part is excluded, false otherwise

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool Excluded { get; set; }
Visual Basic
Public Property Excluded As Boolean
    Get
    Set
Visual C++
public:
property bool Excluded {
    bool get ();
    void set (bool value);
}

See Also

Part Class


OriginalCategoryId Property

[image]

Revit 2024 API
Part..::..OriginalCategoryId Property
Part Class See Also Send Feedback
The category Id of the original element corresponding to this Part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ElementId OriginalCategoryId { get; set; }
Visual Basic
Public Property OriginalCategoryId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ OriginalCategoryId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: dPartOriginalCategoryId is not an available member of the original category ids of the elements which formed this Part.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

Part Class


Parameter Property

[image] [image]

Revit 2024 API
Part..::..Parameter Property
Part Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Part Class
Part Members


PartMaker Property

[image]

Revit 2024 API
Part..::..PartMaker Property
Part Class See Also Send Feedback
The PartMaker that created this Part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public PartMaker PartMaker { get; }
Visual Basic
Public ReadOnly Property PartMaker As PartMaker
    Get
Visual C++
public:
property PartMaker^ PartMaker {
    PartMaker^ get ();
}

See Also

Part Class


PartMaker Members

[image] [image]

Revit 2024 API
PartMaker Members
PartMaker Class Methods Properties See Also Send Feedback

The PartMaker type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSourceElementIds | Get the source elements for the PartMaker.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSourceElement | Is the element a source for this PartMaker
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetSourceElementIds | Set the source elements for the PartMaker.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PartMaker Class


GetSourceElementIds Method

[image]

Revit 2024 API
PartMaker..::..GetSourceElementIds Method
PartMaker Class See Also Send Feedback
Get the source elements for the PartMaker.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ICollection<LinkElementId> GetSourceElementIds()
Visual Basic
Public Function GetSourceElementIds As ICollection(Of LinkElementId)
Visual C++
public:
ICollection<LinkElementId^>^ GetSourceElementIds()

Return Value

Elements that are the sources for this PartMaker.

See Also

PartMaker Class


SetSourceElementIds Method

[image]

Revit 2024 API
PartMaker..::..SetSourceElementIds Method
PartMaker Class See Also Send Feedback
Set the source elements for the PartMaker.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void SetSourceElementIds(
    ICollection<ElementId> sourceElementIds
)
Visual Basic
Public Sub SetSourceElementIds ( _
    sourceElementIds As ICollection(Of ElementId) _
)
Visual C++
public:
void SetSourceElementIds(
    ICollection<ElementId^>^ sourceElementIds
)

Parameters

sourceElementIds
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
Elements to be the sources for this PartMaker.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | One or more element ids was not permitted to be a source for this PartMaker Elements should be Parts that have no PartMaker yet
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

PartMaker Class


Parameter Property

[image] [image]

Revit 2024 API
PartMaker..::..Parameter Property
PartMaker Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

PartMaker Class
PartMaker Members


PartMakerMethodToDivideVolumes Class

[image]

Revit 2024 API
PartMakerMethodToDivideVolumes Class
Members See Also Send Feedback
By-References dividing strategy used by PartMaker element. TODO_REFACTOR("LegacyMechanismOfMovingElements") returns true if - the Host Elements are not floors or walls - OR - the Host Elements that are referenced by this PartMaker are floors or walls - transformation has already been applied on those Host Elements

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public class PartMakerMethodToDivideVolumes : IDisposable
Visual Basic
Public Class PartMakerMethodToDivideVolumes _
    Implements IDisposable
Visual C++
public ref class PartMakerMethodToDivideVolumes : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..PartMakerMethodToDivideVolumes

See Also

PartMakerMethodToDivideVolumes Members


PartMakerMethodToDivideVolumes Members

[image] [image]

Revit 2024 API
PartMakerMethodToDivideVolumes Members
PartMakerMethodToDivideVolumes Class Methods Properties See Also Send Feedback

The PartMakerMethodToDivideVolumes type exposes the following members.

Methods

 | Name | Description
Public method | AddIntersectingReference | Adds intersecting reference with an offset.
Public method | AreElementsValidIntersectingReferences(ICollection<(Of <<'(ElementId>)>>)) | Identifies if provided members are valid.
 | AreElementsValidIntersectingReferences(Document, ICollection<(Of <<'(ElementId>)>>)) | Identifies if provided members are valid.
Public method | CanBeDivisionProfile(ElementId) | Checks whether a family defines a profile which can be used by this method.
 | CanBeDivisionProfile(ElementId, Document) | Checks whether a family defines a profile which can be used by this method.
Public method | Dispose | Releases all resources used by the PartMakerMethodToDivideVolumes
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOffsetForIntersectingReference | Gets offset for the intersecting reference.
Public method | GetPlaneOfSketch | Gets the plane of the sketch.
Public method | GetSketchCurves | Populates the array with copies of curves in the sketch.
Public method | GetSplitRefsOffsets | Returns offsets for plane-defining splitters.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsElementValidIntersectingReference(ElementId) | Identifies if the provided member is valid.
 | IsElementValidIntersectingReference(Document, ElementId) | Identifies if the provided member is valid.
 | IsValidSketchPlane | Identifies if provided sketch plane is valid.
Public method | RemoveIntersectingReference | Removed intersecting reference.
Public method | SetOffsetForIntersectingReference | Sets offset for the intersecting reference.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UsesReference | Identifies if the PartMaker uses the intersecting reference.

Properties

 | Name | Description
Public property | DivisionGap | The gap which is created between matching profiles of parts.
Public property | DivisionPatternMirror | Whether pattern defined by the division rule should be mirrored before application Mirroring is similar to changing indices of u-const gridlines.
Public property | DivisionRotationAngle | Angle by which both u- and v- gridlines of the division are rotated with respect to the natural u/v-const directions of the sketch plane.
Public property | DivisionRuleId | Id of the 'DivisionRule' which is used to augment the cutting sketch.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ProfileFlipAcross | True if the corresponding left/upper parts profile are mirrored with respect to the division line. False if the profile of left/upper parts are defined directly by the profile family.
Public property | ProfileFlipAlong | True if the corresponding left/upper parts profile are mirrored with respect to the center line of the hosts to be divided. False if the profile of left/upper parts are defined directly by the profile family.
Public property | ProfileMatch | Determines how two profiles match.
Public property | ProfileOffset | The offset which is applied to a family-defined profile in the direction away from the division line and toward left/upper part to obtain its profile.
Public property | ProfileType | The id of the profile family applied to boundaries between parts.
Public property | UConstDivisionIndent | Indentation for the application of division rule's pattern across u-const gridlines (i.e., similar to changing indices of u-const gridlines).
Public property | VConstDivisionIndent | Indentation for the application of division rule's pattern across v-const gridlines (i.e., similar to changing indices of v-const gridlines).

See Also

PartMakerMethodToDivideVolumes Class


PartMakerMethodToDivideVolumes Methods

[image] [image]

Revit 2024 API
PartMakerMethodToDivideVolumes Methods
PartMakerMethodToDivideVolumes Class See Also Send Feedback

The PartMakerMethodToDivideVolumes type exposes the following members.

Methods

 | Name | Description
Public method | AddIntersectingReference | Adds intersecting reference with an offset.
Public method | AreElementsValidIntersectingReferences(ICollection<(Of <<'(ElementId>)>>)) | Identifies if provided members are valid.
 | AreElementsValidIntersectingReferences(Document, ICollection<(Of <<'(ElementId>)>>)) | Identifies if provided members are valid.
Public method | CanBeDivisionProfile(ElementId) | Checks whether a family defines a profile which can be used by this method.
 | CanBeDivisionProfile(ElementId, Document) | Checks whether a family defines a profile which can be used by this method.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOffsetForIntersectingReference | Gets offset for the intersecting reference.
Public method | GetPlaneOfSketch | Gets the plane of the sketch.
Public method | GetSketchCurves | Populates the array with copies of curves in the sketch.
Public method | GetSplitRefsOffsets | Returns offsets for plane-defining splitters.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsElementValidIntersectingReference(ElementId) | Identifies if the provided member is valid.
 | IsElementValidIntersectingReference(Document, ElementId) | Identifies if the provided member is valid.
 | IsValidSketchPlane | Identifies if provided sketch plane is valid.
Public method | RemoveIntersectingReference | Removed intersecting reference.
Public method | SetOffsetForIntersectingReference | Sets offset for the intersecting reference.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UsesReference | Identifies if the PartMaker uses the intersecting reference.

See Also

PartMakerMethodToDivideVolumes Class


AreElementsValidIntersectingReferences Method

[image] [image]

Revit 2024 API
PartMakerMethodToDivideVolumes..::..AreElementsValidIntersectingReferences Method
PartMakerMethodToDivideVolumes Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AreElementsValidIntersectingReferences(ICollection<(Of <<'(ElementId>)>>)) | Identifies if provided members are valid.
 | AreElementsValidIntersectingReferences(Document, ICollection<(Of <<'(ElementId>)>>)) | Identifies if provided members are valid.

See Also

PartMakerMethodToDivideVolumes Class
PartMakerMethodToDivideVolumes Members


AreElementsValidIntersectingReferences Method (ICollection(ElementId))

[image]

Revit 2024 API
PartMakerMethodToDivideVolumes..::..AreElementsValidIntersectingReferences Method (ICollection<(Of <(<'ElementId>)>)>)
PartMakerMethodToDivideVolumes Class See Also Send Feedback
Identifies if provided members are valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool AreElementsValidIntersectingReferences(
    ICollection<ElementId> elementIds
)
Visual Basic
Public Function AreElementsValidIntersectingReferences ( _
    elementIds As ICollection(Of ElementId) _
) As Boolean
Visual C++
public:
bool AreElementsValidIntersectingReferences(
    ICollection<ElementId^>^ elementIds
)

Parameters

elementIds
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
Element ids to be tested for validity for intersecting references.

Return Value

True if all references are valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

PartMakerMethodToDivideVolumes Class
AreElementsValidIntersectingReferences Overload


AreElementsValidIntersectingReferences Method (Document, ICollection(ElementId))

[image]

Revit 2024 API
PartMakerMethodToDivideVolumes..::..AreElementsValidIntersectingReferences Method (Document, ICollection<(Of <(<'ElementId>)>)>)
PartMakerMethodToDivideVolumes Class See Also Send Feedback
Identifies if provided members are valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static bool AreElementsValidIntersectingReferences(
    Document document,
    ICollection<ElementId> elementIds
)
Visual Basic
Public Shared Function AreElementsValidIntersectingReferences ( _
    document As Document, _
    elementIds As ICollection(Of ElementId) _
) As Boolean
Visual C++
public:
static bool AreElementsValidIntersectingReferences(
    Document^ document,
    ICollection<ElementId^>^ elementIds
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
elementIds
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
Element ids to be tested for validity for intersecting references.

Return Value

True if all references are valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

PartMakerMethodToDivideVolumes Class
AreElementsValidIntersectingReferences Overload


CanBeDivisionProfile Method

[image] [image]

Revit 2024 API
PartMakerMethodToDivideVolumes..::..CanBeDivisionProfile Method
PartMakerMethodToDivideVolumes Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CanBeDivisionProfile(ElementId) | Checks whether a family defines a profile which can be used by this method.
 | CanBeDivisionProfile(ElementId, Document) | Checks whether a family defines a profile which can be used by this method.

See Also

PartMakerMethodToDivideVolumes Class
PartMakerMethodToDivideVolumes Members


Dispose Method

[image]

Revit 2024 API
PartMakerMethodToDivideVolumes..::..Dispose Method
PartMakerMethodToDivideVolumes Class See Also Send Feedback
Releases all resources used by the PartMakerMethodToDivideVolumes

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

PartMakerMethodToDivideVolumes Class


GetOffsetForIntersectingReference Method

[image]

Revit 2024 API
PartMakerMethodToDivideVolumes..::..GetOffsetForIntersectingReference Method
PartMakerMethodToDivideVolumes Class See Also Send Feedback
Gets offset for the intersecting reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double GetOffsetForIntersectingReference(
    ElementId intersectingReference
)
Visual Basic
Public Function GetOffsetForIntersectingReference ( _
    intersectingReference As ElementId _
) As Double
Visual C++
public:
double GetOffsetForIntersectingReference(
    ElementId^ intersectingReference
)

Parameters

intersectingReference
Type: Autodesk.Revit.DB..::..ElementId
The intersecting reference to obtain offset value from.

Return Value

The offset for the intersecting reference

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | PartMaker does not use the specified intersecting reference.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

PartMakerMethodToDivideVolumes Class


GetPlaneOfSketch Method

[image]

Revit 2024 API
PartMakerMethodToDivideVolumes..::..GetPlaneOfSketch Method
PartMakerMethodToDivideVolumes Class See Also Send Feedback
Gets the plane of the sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public Plane GetPlaneOfSketch()
Visual Basic
Public Function GetPlaneOfSketch As Plane
Visual C++
public:
Plane^ GetPlaneOfSketch()

Return Value

The plane of the sketch.

See Also

PartMakerMethodToDivideVolumes Class


GetSketchCurves Method

[image]

Revit 2024 API
PartMakerMethodToDivideVolumes..::..GetSketchCurves Method
PartMakerMethodToDivideVolumes Class See Also Send Feedback
Populates the array with copies of curves in the sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void GetSketchCurves(
    out IList<Curve> curveArray
)
Visual Basic
Public Sub GetSketchCurves ( _
    <OutAttribute> ByRef curveArray As IList(Of Curve) _
)
Visual C++
public:
void GetSketchCurves(
    [OutAttribute] IList<Curve^>^% curveArray
)

Parameters

curveArray
Type: System.Collections.Generic..::..IList<(Of <(<' Curve >)>)>%
Curves in the sketch. Tags of the curves are consistent with the curve tags used in part keys.

See Also

PartMakerMethodToDivideVolumes Class


GetSplitRefsOffsets Method

[image]

Revit 2024 API
PartMakerMethodToDivideVolumes..::..GetSplitRefsOffsets Method
PartMakerMethodToDivideVolumes Class See Also Send Feedback
Returns offsets for plane-defining splitters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public IDictionary<ElementId, double> GetSplitRefsOffsets()
Visual Basic
Public Function GetSplitRefsOffsets As IDictionary(Of ElementId, Double)
Visual C++
public:
IDictionary<ElementId^, double>^ GetSplitRefsOffsets()

See Also

PartMakerMethodToDivideVolumes Class


IsElementValidIntersectingReference Method (ElementId)

[image]

Revit 2024 API
PartMakerMethodToDivideVolumes..::..IsElementValidIntersectingReference Method (ElementId)
PartMakerMethodToDivideVolumes Class See Also Send Feedback
Identifies if the provided member is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool IsElementValidIntersectingReference(
    ElementId elementId
)
Visual Basic
Public Function IsElementValidIntersectingReference ( _
    elementId As ElementId _
) As Boolean
Visual C++
public:
bool IsElementValidIntersectingReference(
    ElementId^ elementId
)

Parameters

elementId
Type: Autodesk.Revit.DB..::..ElementId
Element ids to be tested for validity for intersecting references.

Return Value

True if the reference is valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

PartMakerMethodToDivideVolumes Class
IsElementValidIntersectingReference Overload


IsValidSketchPlane Method

[image]

Revit 2024 API
PartMakerMethodToDivideVolumes..::..IsValidSketchPlane Method
PartMakerMethodToDivideVolumes Class See Also Send Feedback
Identifies if provided sketch plane is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static bool IsValidSketchPlane(
    Document document,
    ElementId sketchPlaneId
)
Visual Basic
Public Shared Function IsValidSketchPlane ( _
    document As Document, _
    sketchPlaneId As ElementId _
) As Boolean
Visual C++
public:
static bool IsValidSketchPlane(
    Document^ document,
    ElementId^ sketchPlaneId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
sketchPlaneId
Type: Autodesk.Revit.DB..::..ElementId
SketchPlane ids to be tested for validity for PartMaker.

Return Value

True if SketchPlane valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

PartMakerMethodToDivideVolumes Class


RemoveIntersectingReference Method

[image]

Revit 2024 API
PartMakerMethodToDivideVolumes..::..RemoveIntersectingReference Method
PartMakerMethodToDivideVolumes Class See Also Send Feedback
Removed intersecting reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool RemoveIntersectingReference(
    ElementId intersectingReference
)
Visual Basic
Public Function RemoveIntersectingReference ( _
    intersectingReference As ElementId _
) As Boolean
Visual C++
public:
bool RemoveIntersectingReference(
    ElementId^ intersectingReference
)

Parameters

intersectingReference
Type: Autodesk.Revit.DB..::..ElementId
Id of the intersecting reference to remove.

Return Value

True if the PartMaker used this intersecting reference and this call removed it, false if the PartMaker did not use this intersecting reference.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element id was not permitted as intersecting references. Intersecting references should be levels, grids, or reference planes.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

PartMakerMethodToDivideVolumes Class


SetOffsetForIntersectingReference Method

[image]

Revit 2024 API
PartMakerMethodToDivideVolumes..::..SetOffsetForIntersectingReference Method
PartMakerMethodToDivideVolumes Class See Also Send Feedback
Sets offset for the intersecting reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void SetOffsetForIntersectingReference(
    ElementId intersectingReference,
    double offset
)
Visual Basic
Public Sub SetOffsetForIntersectingReference ( _
    intersectingReference As ElementId, _
    offset As Double _
)
Visual C++
public:
void SetOffsetForIntersectingReference(
    ElementId^ intersectingReference,
    double offset
)

Parameters

intersectingReference
Type: Autodesk.Revit.DB..::..ElementId
The intersecting reference that will be offset.
offset
Type: System..::..Double
The new offset.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | PartMaker does not use the specified intersecting reference.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

PartMakerMethodToDivideVolumes Class


UsesReference Method

[image]

Revit 2024 API
PartMakerMethodToDivideVolumes..::..UsesReference Method
PartMakerMethodToDivideVolumes Class See Also Send Feedback
Identifies if the PartMaker uses the intersecting reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool UsesReference(
    ElementId intersectingReference
)
Visual Basic
Public Function UsesReference ( _
    intersectingReference As ElementId _
) As Boolean
Visual C++
public:
bool UsesReference(
    ElementId^ intersectingReference
)

Parameters

intersectingReference
Type: Autodesk.Revit.DB..::..ElementId
Intersecting reference to be tested.

Return Value

True if the intersecting reference is used by the PartMaker.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

PartMakerMethodToDivideVolumes Class


PartMakerMethodToDivideVolumes Properties

[image] [image]

Revit 2024 API
PartMakerMethodToDivideVolumes Properties
PartMakerMethodToDivideVolumes Class See Also Send Feedback

The PartMakerMethodToDivideVolumes type exposes the following members.

Properties

 | Name | Description
Public property | DivisionGap | The gap which is created between matching profiles of parts.
Public property | DivisionPatternMirror | Whether pattern defined by the division rule should be mirrored before application Mirroring is similar to changing indices of u-const gridlines.
Public property | DivisionRotationAngle | Angle by which both u- and v- gridlines of the division are rotated with respect to the natural u/v-const directions of the sketch plane.
Public property | DivisionRuleId | Id of the 'DivisionRule' which is used to augment the cutting sketch.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ProfileFlipAcross | True if the corresponding left/upper parts profile are mirrored with respect to the division line. False if the profile of left/upper parts are defined directly by the profile family.
Public property | ProfileFlipAlong | True if the corresponding left/upper parts profile are mirrored with respect to the center line of the hosts to be divided. False if the profile of left/upper parts are defined directly by the profile family.
Public property | ProfileMatch | Determines how two profiles match.
Public property | ProfileOffset | The offset which is applied to a family-defined profile in the direction away from the division line and toward left/upper part to obtain its profile.
Public property | ProfileType | The id of the profile family applied to boundaries between parts.
Public property | UConstDivisionIndent | Indentation for the application of division rule's pattern across u-const gridlines (i.e., similar to changing indices of u-const gridlines).
Public property | VConstDivisionIndent | Indentation for the application of division rule's pattern across v-const gridlines (i.e., similar to changing indices of v-const gridlines).

See Also

PartMakerMethodToDivideVolumes Class


DivisionGap Property

[image]

Revit 2024 API
PartMakerMethodToDivideVolumes..::..DivisionGap Property
PartMakerMethodToDivideVolumes Class See Also Send Feedback
The gap which is created between matching profiles of parts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double DivisionGap { get; set; }
Visual Basic
Public Property DivisionGap As Double
    Get
    Set
Visual C++
public:
property double DivisionGap {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for divisionGap must be between 0 and 30000 feet.

See Also

PartMakerMethodToDivideVolumes Class


DivisionPatternMirror Property

[image]

Revit 2024 API
PartMakerMethodToDivideVolumes..::..DivisionPatternMirror Property
PartMakerMethodToDivideVolumes Class See Also Send Feedback
Whether pattern defined by the division rule should be mirrored before application Mirroring is similar to changing indices of u-const gridlines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool DivisionPatternMirror { get; set; }
Visual Basic
Public Property DivisionPatternMirror As Boolean
    Get
    Set
Visual C++
public:
property bool DivisionPatternMirror {
    bool get ();
    void set (bool value);
}

See Also

PartMakerMethodToDivideVolumes Class


IsValidObject Property

[image]

Revit 2024 API
PartMakerMethodToDivideVolumes..::..IsValidObject Property
PartMakerMethodToDivideVolumes Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

PartMakerMethodToDivideVolumes Class


ProfileFlipAcross Property

[image]

Revit 2024 API
PartMakerMethodToDivideVolumes..::..ProfileFlipAcross Property
PartMakerMethodToDivideVolumes Class See Also Send Feedback
True if the corresponding left/upper parts profile are mirrored with respect to the division line. False if the profile of left/upper parts are defined directly by the profile family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool ProfileFlipAcross { get; set; }
Visual Basic
Public Property ProfileFlipAcross As Boolean
    Get
    Set
Visual C++
public:
property bool ProfileFlipAcross {
    bool get ();
    void set (bool value);
}

See Also

PartMakerMethodToDivideVolumes Class


ProfileFlipAlong Property

[image]

Revit 2024 API
PartMakerMethodToDivideVolumes..::..ProfileFlipAlong Property
PartMakerMethodToDivideVolumes Class See Also Send Feedback
True if the corresponding left/upper parts profile are mirrored with respect to the center line of the hosts to be divided. False if the profile of left/upper parts are defined directly by the profile family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool ProfileFlipAlong { get; set; }
Visual Basic
Public Property ProfileFlipAlong As Boolean
    Get
    Set
Visual C++
public:
property bool ProfileFlipAlong {
    bool get ();
    void set (bool value);
}

See Also

PartMakerMethodToDivideVolumes Class


ProfileOffset Property

[image]

Revit 2024 API
PartMakerMethodToDivideVolumes..::..ProfileOffset Property
PartMakerMethodToDivideVolumes Class See Also Send Feedback
The offset which is applied to a family-defined profile in the direction away from the division line and toward left/upper part to obtain its profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double ProfileOffset { get; set; }
Visual Basic
Public Property ProfileOffset As Double
    Get
    Set
Visual C++
public:
property double ProfileOffset {
    double get ();
    void set (double value);
}

See Also

PartMakerMethodToDivideVolumes Class


ProfileType Property

[image]

Revit 2024 API
PartMakerMethodToDivideVolumes..::..ProfileType Property
PartMakerMethodToDivideVolumes Class See Also Send Feedback
The id of the profile family applied to boundaries between parts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ElementId ProfileType { get; set; }
Visual Basic
Public Property ProfileType As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ ProfileType {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

PartMakerMethodToDivideVolumes Class


UConstDivisionIndent Property

[image]

Revit 2024 API
PartMakerMethodToDivideVolumes..::..UConstDivisionIndent Property
PartMakerMethodToDivideVolumes Class See Also Send Feedback
Indentation for the application of division rule's pattern across u-const gridlines (i.e., similar to changing indices of u-const gridlines).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public int UConstDivisionIndent { get; set; }
Visual Basic
Public Property UConstDivisionIndent As Integer
    Get
    Set
Visual C++
public:
property int UConstDivisionIndent {
    int get ();
    void set (int value);
}

See Also

PartMakerMethodToDivideVolumes Class


PartsVisibility Enumeration

[image]

Revit 2024 API
PartsVisibility Enumeration
See Also Send Feedback
Indicates the visibility of parts for the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Since: 2012

Syntax

C#
public enum PartsVisibility
Visual Basic
Public Enumeration PartsVisibility
Visual C++
public enum class PartsVisibility

Members

Member name | Description
Unset | Parts visibility is not set for the view.
ShowPartsOnly | Show only parts for the view.
ShowOriginalOnly | Show original elements, not parts, for the view.
ShowPartsAndOriginal | Show both original elements and parts for the view.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


PartType Enumeration

[image]

Revit 2024 API
PartType Enumeration
See Also Send Feedback
An enumerated type listing all MEP family part types. A part type typically provides one unique set of type parameters that defines this part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum PartType
Visual Basic
Public Enumeration PartType
Visual C++
public enum class PartType

Members

Member name | Description
Undefined | Undefined part type
Normal | Normal part type
DuctMounted | Duct mounted part type
JunctionBox | JunctionBox part type
AttachesTo | Attaches to part type
BreaksInto | Breaks into part type
Elbow | Elbow part type
Tee | Tee part type
Transition | Transition part type
Cross | Cross part type
Cap | Cap part type
TapPerpendicular | Tap perpendicular part type
TapAdjustable | Tap adjustable part type
Offset | Offset part type
Union | Union part type
PanelBoard | Panel board part type
Transformer | Transformer part type
SwitchBoard | Switch board part type
OtherPanel | Other panel part type
EquipmentSwitch | Equipment switch part type
Switch | Switch part type
ValveBreaksInto | Valve breaks into part type
SpudPerpendicular | Spud perpendicular part type
SpudAdjustable | Spud adjustable part type
Damper | Damper part type
Wye | Wye part type
LateralTee | Lateral tee part type
LateralCross | Lateral cross part type
Pants | Pants part type
MultiPort | Multi port part type
ValveNormal | Valve normal part type
JunctionBoxTee | JunctionBox tee part type
JunctionBoxCross | JunctionBox cross part type
PipeFlange | Pipe flange part type
JunctionBoxElbow | JunctionBox elbow part type
ChannelCableTrayElbow | Channel CableTray Elbow part type
ChannelCableTrayVerticalElbow | Channel CableTray Vertical Elbow part type
ChannelCableTrayCross | Channel CableTray Cross part type
ChannelCableTrayTee | Channel CableTray Tee part type
ChannelCableTrayTransition | Channel CableTray Transition part type
ChannelCableTrayUnion | Channel CableTray Union part type
ChannelCableTrayOffset | Channel CableTray Offset part type
ChannelCableTrayMultiPort | Channel CableTray MultiPort part type
LadderCableTrayElbow | Ladder CableTray Elbow part type
LadderCableTrayVerticalElbow | Ladder CableTray Vertical Elbow part type
LadderCableTrayCross | Ladder CableTray Cross part type
LadderCableTrayTee | Ladder CableTray Tee part type
LadderCableTrayTransition | Ladder CableTray Transition part type
LadderCableTrayUnion | Ladder CableTray Union part type
LadderCableTrayOffset | Ladder CableTray Offset part type
LadderCableTrayMultiPort | Ladder CableTray MultiPort part type
InlineSensor | Inline Sensor part type
Sensor | Sensor part type
EndCap | EndCap part type
HandrailBracketHardware | Handrail Bracket Hardware part type
PanelBracketHardware | Panel Bracket Hardware part type
TerminationHardware | Termination Hardware part type
Rails | Rails part type
Handrails | Handrails part type
TopRails | Top Rails part type
PipeMechanicalCoupling | Pipe Mechanical Coupling part type

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


PartUtils Class

[image]

Revit 2024 API
PartUtils Class
Members See Also Send Feedback
General Part utility methods

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static class PartUtils
Visual Basic
Public NotInheritable Class PartUtils
Visual C++
public ref class PartUtils abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..PartUtils

See Also

PartUtils Members


PartUtils Members

[image] [image]

Revit 2024 API
PartUtils Members
PartUtils Class Methods See Also Send Feedback

The PartUtils type exposes the following members.

Methods

Name | Description
AreElementsValidForCreateParts | Identifies if the given elements can be used to create parts.
ArePartsValidForDivide | Identifies if provided members are valid for dividing parts.
ArePartsValidForMerge | Identifies whether Part elements may be merged.
CreateMergedPart | Create a single merged part which represents the Parts specified by partsToMerge.
CreateParts(Document, ICollection<(Of <<'(ElementId>)>>)) | Creates a new set of parts out of the original elements.
CreateParts(Document, ICollection<(Of <<'(LinkElementId>)>>)) | Creates a new set of parts out of the original elements.
DivideParts | Creates divided parts out of parts.
FindMergeableClusters | Segregates a set of elements into subsets which are valid for merge.
GetAssociatedPartMaker(Document, ElementId) | Gets associated PartMaker for an element.
GetAssociatedPartMaker(Document, LinkElementId) | Gets associated PartMaker for an element.
GetAssociatedParts(Document, ElementId, Boolean, Boolean) | Returns all Parts that are associated with the given element.
GetAssociatedParts(Document, LinkElementId, Boolean, Boolean) | Returns all Parts that are associated with the given element
GetChainLengthToOriginal | Calculates the length of the longest chain of divisions/merges to reach to an original non-Part element that is the source of the tested part.
GetMergedParts | Retrieves the element ids of the source elements of a merged part.
GetPartMakerMethodToDivideVolumeFW | Obtains the object allowing access to the divided volume properties of the PartMaker.
GetSplittingCurves(Document, ElementId) | Identifies the curves that were used to create the part.
GetSplittingCurves(Document, ElementId, Plane%) | Identifies the curves that were used to create the part and the plane in which they reside.
GetSplittingElements | Identifies the elements ( reference planes, levels, grids ) that were used to create the part.
HasAssociatedParts(Document, ElementId) | Checks if an element has associated parts.
HasAssociatedParts(Document, LinkElementId) | Checks if an element has associated parts.
IsMergedPart | Is the Part the result of a merge.
IsPartDerivedFromLink | Is the Part derived from link geometry.
IsValidForCreateParts | Identifies if the given element can be used to create parts.

See Also

PartUtils Class


PartUtils Methods

[image] [image]

Revit 2024 API
PartUtils Methods
PartUtils Class See Also Send Feedback

The PartUtils type exposes the following members.

Methods

Name | Description
AreElementsValidForCreateParts | Identifies if the given elements can be used to create parts.
ArePartsValidForDivide | Identifies if provided members are valid for dividing parts.
ArePartsValidForMerge | Identifies whether Part elements may be merged.
CreateMergedPart | Create a single merged part which represents the Parts specified by partsToMerge.
CreateParts(Document, ICollection<(Of <<'(ElementId>)>>)) | Creates a new set of parts out of the original elements.
CreateParts(Document, ICollection<(Of <<'(LinkElementId>)>>)) | Creates a new set of parts out of the original elements.
DivideParts | Creates divided parts out of parts.
FindMergeableClusters | Segregates a set of elements into subsets which are valid for merge.
GetAssociatedPartMaker(Document, ElementId) | Gets associated PartMaker for an element.
GetAssociatedPartMaker(Document, LinkElementId) | Gets associated PartMaker for an element.
GetAssociatedParts(Document, ElementId, Boolean, Boolean) | Returns all Parts that are associated with the given element.
GetAssociatedParts(Document, LinkElementId, Boolean, Boolean) | Returns all Parts that are associated with the given element
GetChainLengthToOriginal | Calculates the length of the longest chain of divisions/merges to reach to an original non-Part element that is the source of the tested part.
GetMergedParts | Retrieves the element ids of the source elements of a merged part.
GetPartMakerMethodToDivideVolumeFW | Obtains the object allowing access to the divided volume properties of the PartMaker.
GetSplittingCurves(Document, ElementId) | Identifies the curves that were used to create the part.
GetSplittingCurves(Document, ElementId, Plane%) | Identifies the curves that were used to create the part and the plane in which they reside.
GetSplittingElements | Identifies the elements ( reference planes, levels, grids ) that were used to create the part.
HasAssociatedParts(Document, ElementId) | Checks if an element has associated parts.
HasAssociatedParts(Document, LinkElementId) | Checks if an element has associated parts.
IsMergedPart | Is the Part the result of a merge.
IsPartDerivedFromLink | Is the Part derived from link geometry.
IsValidForCreateParts | Identifies if the given element can be used to create parts.

See Also

PartUtils Class


AreElementsValidForCreateParts Method

[image]

Revit 2024 API
PartUtils..::..AreElementsValidForCreateParts Method
PartUtils Class See Also Send Feedback
Identifies if the given elements can be used to create parts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static bool AreElementsValidForCreateParts(
    Document document,
    ICollection<ElementId> elementIds
)
Visual Basic
Public Shared Function AreElementsValidForCreateParts ( _
    document As Document, _
    elementIds As ICollection(Of ElementId) _
) As Boolean
Visual C++
public:
static bool AreElementsValidForCreateParts(
    Document^ document,
    ICollection<ElementId^>^ elementIds
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
elementIds
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
Element ids to be tested for validity for creating parts.

Return Value

True if all member ids are valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

PartUtils Class


CreateMergedPart Method

[image]

Revit 2024 API
PartUtils..::..CreateMergedPart Method
PartUtils Class See Also Send Feedback
Create a single merged part which represents the Parts specified by partsToMerge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static PartMaker CreateMergedPart(
    Document document,
    ICollection<ElementId> partIds
)
Visual Basic
Public Shared Function CreateMergedPart ( _
    document As Document, _
    partIds As ICollection(Of ElementId) _
) As PartMaker
Visual C++
public:
static PartMaker^ CreateMergedPart(
    Document^ document,
    ICollection<ElementId^>^ partIds
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
partIds
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
The elements that the merged part will be created from.

Return Value

The newly created PartMaker. nullNothingnullptra null reference (Nothing in Visual Basic) if no parts are merged.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | One or more element ids was not suitable for merging with the others. Specified elements should all be Parts, report the same material, creation and demolition phases, and have contiguous geometry.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

PartUtils Class


CreateParts Method

[image] [image]

Revit 2024 API
PartUtils..::..CreateParts Method
PartUtils Class See Also Send Feedback

Overload List

Name | Description
CreateParts(Document, ICollection<(Of <<'(ElementId>)>>)) | Creates a new set of parts out of the original elements.
CreateParts(Document, ICollection<(Of <<'(LinkElementId>)>>)) | Creates a new set of parts out of the original elements.

See Also

PartUtils Class
PartUtils Members


CreateParts Method (Document, ICollection(ElementId))

[image]

Revit 2024 API
PartUtils..::..CreateParts Method (Document, ICollection<(Of <(<'ElementId>)>)>)
PartUtils Class See Also Send Feedback
Creates a new set of parts out of the original elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static void CreateParts(
    Document document,
    ICollection<ElementId> elementIds
)
Visual Basic
Public Shared Sub CreateParts ( _
    document As Document, _
    elementIds As ICollection(Of ElementId) _
)
Visual C++
public:
static void CreateParts(
    Document^ document,
    ICollection<ElementId^>^ elementIds
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document containing the elements.
elementIds
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
The elements that parts will be created from.

Remarks

Parts will be added to the model after regeneration.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | One or more element ids was not permitted for creating parts. Elements should be of a valid category and the ids should be valid and should not already be divided into parts.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

PartUtils Class
CreateParts Overload


DivideParts Method

[image]

Revit 2024 API
PartUtils..::..DivideParts Method
PartUtils Class See Also Send Feedback
Creates divided parts out of parts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static PartMaker DivideParts(
    Document document,
    ICollection<ElementId> elementIdsToDivide,
    ICollection<ElementId> intersectingReferenceIds,
    IList<Curve> curveArray,
    ElementId sketchPlaneId
)
Visual Basic
Public Shared Function DivideParts ( _
    document As Document, _
    elementIdsToDivide As ICollection(Of ElementId), _
    intersectingReferenceIds As ICollection(Of ElementId), _
    curveArray As IList(Of Curve), _
    sketchPlaneId As ElementId _
) As PartMaker
Visual C++
public:
static PartMaker^ DivideParts(
    Document^ document,
    ICollection<ElementId^>^ elementIdsToDivide,
    ICollection<ElementId^>^ intersectingReferenceIds,
    IList<Curve^>^ curveArray,
    ElementId^ sketchPlaneId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document containing the parts.
elementIdsToDivide
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
The elements that will be divided.
intersectingReferenceIds
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
Intersecting references that will divide the elements.
curveArray
Type: System.Collections.Generic..::..IList<(Of <(<' Curve >)>)>
Array of curves that will divide the elements.
sketchPlaneId
Type: Autodesk.Revit.DB..::..ElementId
SketchPlane id for the curves that divide the elements.

Return Value

The newly created PartMaker. nullNothingnullptra null reference (Nothing in Visual Basic) if no parts are divided.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | One or more element ids was not permitted for dividing parts. Elements should be parts that are not yet divided and maximum distance from an original has not yet been reached. -or- One or more element ids was not permitted as intersecting references. Intersecting references should be levels, grids, or reference planes. -or- The element id should refer to a valid SketchPlane. -or- The input curveArray contains at least one helical curve and is not supported for this operation. -or- The input curveArray contains at least one NULL pointer and is not supported for this operation.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

PartUtils Class


FindMergeableClusters Method

[image]

Revit 2024 API
PartUtils..::..FindMergeableClusters Method
PartUtils Class See Also Send Feedback
Segregates a set of elements into subsets which are valid for merge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static IList<ICollection<ElementId>> FindMergeableClusters(
    Document doc,
    ICollection<ElementId> partIds
)
Visual Basic
Public Shared Function FindMergeableClusters ( _
    doc As Document, _
    partIds As ICollection(Of ElementId) _
) As IList(Of ICollection(Of ElementId))
Visual C++
public:
static IList<ICollection<ElementId^>^>^ FindMergeableClusters(
    Document^ doc,
    ICollection<ElementId^>^ partIds
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The document.
partIds
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
A set of element ids.

Return Value

An array of clusters such that all the elements in a single cluster are valid for merge. Each cluster will be maximal in that appending any of the other Parts specified as input will result in a collection that is not valid for merge.

Remarks

Element ids in the input set that do not correspond to Part elements will be ignored, as will element ids corresponding to Part elements that already have associated parts.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

PartUtils Class


GetAssociatedPartMaker Method (Document, LinkElementId)

[image]

Revit 2024 API
PartUtils..::..GetAssociatedPartMaker Method (Document, LinkElementId)
PartUtils Class See Also Send Feedback
Gets associated PartMaker for an element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static PartMaker GetAssociatedPartMaker(
    Document hostDocument,
    LinkElementId hostOrLinkElementId
)
Visual Basic
Public Shared Function GetAssociatedPartMaker ( _
    hostDocument As Document, _
    hostOrLinkElementId As LinkElementId _
) As PartMaker
Visual C++
public:
static PartMaker^ GetAssociatedPartMaker(
    Document^ hostDocument,
    LinkElementId^ hostOrLinkElementId
)

Parameters

hostDocument
Type: Autodesk.Revit.DB..::..Document
The document
hostOrLinkElementId
Type: Autodesk.Revit.DB..::..LinkElementId
The id for the element to be checked for associated Parts

Return Value

The PartMaker element that is making Parts for this element. nullNothingnullptra null reference (Nothing in Visual Basic) if there is no associated PartMaker.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

PartUtils Class
GetAssociatedPartMaker Overload


GetAssociatedParts Method

[image] [image]

Revit 2024 API
PartUtils..::..GetAssociatedParts Method
PartUtils Class See Also Send Feedback

Overload List

Name | Description
GetAssociatedParts(Document, ElementId, Boolean, Boolean) | Returns all Parts that are associated with the given element.
GetAssociatedParts(Document, LinkElementId, Boolean, Boolean) | Returns all Parts that are associated with the given element

See Also

PartUtils Class
PartUtils Members


GetAssociatedParts Method (Document, ElementId, Boolean, Boolean)

[image]

Revit 2024 API
PartUtils..::..GetAssociatedParts Method (Document, ElementId, Boolean, Boolean)
PartUtils Class See Also Send Feedback
Returns all Parts that are associated with the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static ICollection<ElementId> GetAssociatedParts(
    Document hostDocument,
    ElementId elementId,
    bool includePartsWithAssociatedParts,
    bool includeAllChildren
)
Visual Basic
Public Shared Function GetAssociatedParts ( _
    hostDocument As Document, _
    elementId As ElementId, _
    includePartsWithAssociatedParts As Boolean, _
    includeAllChildren As Boolean _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetAssociatedParts(
    Document^ hostDocument,
    ElementId^ elementId,
    bool includePartsWithAssociatedParts,
    bool includeAllChildren
)

Parameters

hostDocument
Type: Autodesk.Revit.DB..::..Document
The document of the element.
elementId
Type: Autodesk.Revit.DB..::..ElementId
The element to be checked for associated Parts.
includePartsWithAssociatedParts
Type: System..::..Boolean
If true, include parts that have associated parts.
includeAllChildren
Type: System..::..Boolean
If true, return all associated Parts recursively for all children. If false, only return immediate children.

Return Value

Parts that are associated to the element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

PartUtils Class
GetAssociatedParts Overload


GetAssociatedParts Method (Document, LinkElementId, Boolean, Boolean)

[image]

Revit 2024 API
PartUtils..::..GetAssociatedParts Method (Document, LinkElementId, Boolean, Boolean)
PartUtils Class See Also Send Feedback
Returns all Parts that are associated with the given element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static ICollection<ElementId> GetAssociatedParts(
    Document hostDocument,
    LinkElementId hostOrLinkElementId,
    bool includePartsWithAssociatedParts,
    bool includeAllChildren
)
Visual Basic
Public Shared Function GetAssociatedParts ( _
    hostDocument As Document, _
    hostOrLinkElementId As LinkElementId, _
    includePartsWithAssociatedParts As Boolean, _
    includeAllChildren As Boolean _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetAssociatedParts(
    Document^ hostDocument,
    LinkElementId^ hostOrLinkElementId,
    bool includePartsWithAssociatedParts,
    bool includeAllChildren
)

Parameters

hostDocument
Type: Autodesk.Revit.DB..::..Document
The document of the element
hostOrLinkElementId
Type: Autodesk.Revit.DB..::..LinkElementId
The element to be checked for associated Parts.
includePartsWithAssociatedParts
Type: System..::..Boolean
If true, include parts that have associated parts
includeAllChildren
Type: System..::..Boolean
If true, return all associated Parts recursively for all children If false, only return immediate children

Return Value

Parts that are associated to the element

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

PartUtils Class
GetAssociatedParts Overload


GetChainLengthToOriginal Method

[image]

Revit 2024 API
PartUtils..::..GetChainLengthToOriginal Method
PartUtils Class See Also Send Feedback
Calculates the length of the longest chain of divisions/merges to reach to an original non-Part element that is the source of the tested part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static int GetChainLengthToOriginal(
    Part part
)
Visual Basic
Public Shared Function GetChainLengthToOriginal ( _
    part As Part _
) As Integer
Visual C++
public:
static int GetChainLengthToOriginal(
    Part^ part
)

Parameters

part
Type: Autodesk.Revit.DB..::..Part
The part to be tested

Return Value

The length of the longest chain.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

PartUtils Class


GetMergedParts Method

[image]

Revit 2024 API
PartUtils..::..GetMergedParts Method
PartUtils Class See Also Send Feedback
Retrieves the element ids of the source elements of a merged part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static ICollection<ElementId> GetMergedParts(
    Part part
)
Visual Basic
Public Shared Function GetMergedParts ( _
    part As Part _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetMergedParts(
    Part^ part
)

Parameters

part
Type: Autodesk.Revit.DB..::..Part
A merged part.

Return Value

The element ids of the parts that were merged to create the specified merged part.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The specified Part is not a merged part.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

PartUtils Class


GetPartMakerMethodToDivideVolumeFW Method

[image]

Revit 2024 API
PartUtils..::..GetPartMakerMethodToDivideVolumeFW Method
PartUtils Class See Also Send Feedback
Obtains the object allowing access to the divided volume properties of the PartMaker.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static PartMakerMethodToDivideVolumes GetPartMakerMethodToDivideVolumeFW(
    PartMaker partMaker
)
Visual Basic
Public Shared Function GetPartMakerMethodToDivideVolumeFW ( _
    partMaker As PartMaker _
) As PartMakerMethodToDivideVolumes
Visual C++
public:
static PartMakerMethodToDivideVolumes^ GetPartMakerMethodToDivideVolumeFW(
    PartMaker^ partMaker
)

Parameters

partMaker
Type: Autodesk.Revit.DB..::..PartMaker
The PartMaker.

Return Value

The object handle. Returns nullNothingnullptra null reference (Nothing in Visual Basic) if the PartMaker does not represent divided volumes.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

PartUtils Class


GetSplittingCurves Method

[image] [image]

Revit 2024 API
PartUtils..::..GetSplittingCurves Method
PartUtils Class See Also Send Feedback

Overload List

Name | Description
GetSplittingCurves(Document, ElementId) | Identifies the curves that were used to create the part.
GetSplittingCurves(Document, ElementId, Plane%) | Identifies the curves that were used to create the part and the plane in which they reside.

See Also

PartUtils Class
PartUtils Members


GetSplittingCurves Method (Document, ElementId, Plane)

[image]

Revit 2024 API
PartUtils..::..GetSplittingCurves Method (Document, ElementId, Plane%)
PartUtils Class Example See Also Send Feedback
Identifies the curves that were used to create the part and the plane in which they reside.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019.1

Syntax

C#
public static IList<Curve> GetSplittingCurves(
    Document document,
    ElementId partId,
    out Plane sketchPlane
)
Visual Basic
Public Shared Function GetSplittingCurves ( _
    document As Document, _
    partId As ElementId, _
    <OutAttribute> ByRef sketchPlane As Plane _
) As IList(Of Curve)
Visual C++
public:
static IList<Curve^>^ GetSplittingCurves(
    Document^ document,
    ElementId^ partId,
    [OutAttribute] Plane^% sketchPlane
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The source document of the part.
partId
Type: Autodesk.Revit.DB..::..ElementId
The part id.
sketchPlane
Type: Autodesk.Revit.DB..::..Plane %
The plane in which the division curves were sketched.

Return Value

The curves that created the part. Empty if partId is not a part or Part is not divided.

Examples

CopyC#
public void GetCurveDividersAndPlane(Part part)
{
   StringBuilder message = new StringBuilder();
   Plane skP = Plane.CreateByThreePoints(new XYZ(0, 0, 1), new XYZ(1, 0, 0), new XYZ(0, 1, 0));

   // Get curve dividers.
   IList<Curve> divisionCurves = PartUtils.GetSplittingCurves(part.Document, part.Id, out skP);

   if(divisionCurves.Count == 0)
      message.AppendLine("Part is not divided.");
   else
   {
      message.AppendLine("The dividers are : ");
      if(divisionCurves.Count > 0)
         message.AppendLine(divisionCurves.Count.ToString() + " division curves");
   }

   TaskDialog.Show("Revit", message.ToString());
}
CopyVB.NET
Private Sub GetCurveDividersAndPlane(ByVal part As Part)
    Dim message As StringBuilder = New StringBuilder
    Dim skP As Plane = Plane.CreateByThreePoints(New XYZ(0, 0, 1), New XYZ(1, 0, 0), New XYZ(0, 1, 0))
    ' Get curve dividers.
    Dim divisionCurves As IList(Of Curve) = PartUtils.GetSplittingCurves(part.Document, part.Id, skP)
    If (divisionCurves.Count = 0) Then
        message.AppendLine("Part is not divided.")
    Else
        message.AppendLine("The dividers are : ")
        If (divisionCurves.Count > 0) Then
            message.AppendLine((divisionCurves.Count.ToString + " division curves"))
        End If

    End If

    TaskDialog.Show("Revit", message.ToString)
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

PartUtils Class
GetSplittingCurves Overload


GetSplittingElements Method

[image]

Revit 2024 API
PartUtils..::..GetSplittingElements Method
PartUtils Class Example See Also Send Feedback
Identifies the elements ( reference planes, levels, grids ) that were used to create the part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019.1

Syntax

C#
public static ISet<ElementId> GetSplittingElements(
    Document document,
    ElementId partId
)
Visual Basic
Public Shared Function GetSplittingElements ( _
    document As Document, _
    partId As ElementId _
) As ISet(Of ElementId)
Visual C++
public:
static ISet<ElementId^>^ GetSplittingElements(
    Document^ document,
    ElementId^ partId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The source document of the part.
partId
Type: Autodesk.Revit.DB..::..ElementId
The part id.

Return Value

The elements that created the part. Empty if partId is not a Part or Part is not divided.

Examples

CopyC#
public void GetElementDividers(Part part)
{
   StringBuilder message = new StringBuilder();

   // Get Element dividers.
   ISet<ElementId> divisionElements = PartUtils.GetSplittingElements(part.Document, part.Id);

   if (divisionElements.Count == 0)
      message.AppendLine("Part is not divided.");
   else
   {
      message.AppendLine("The dividers are : ");
      foreach (var reference in divisionElements)
      {
         Element element = part.Document.GetElement(reference);
         message.AppendLine(element.GetType().Name + " " + element.Id.ToString() + " ");
      }
   }

   TaskDialog.Show("Revit", message.ToString());
}
CopyVB.NET
Private Sub GetElementDividers(ByVal part As Part)
    Dim message As StringBuilder = New StringBuilder
    ' Get Element dividers.
    Dim divisionElements As ISet(Of ElementId) = PartUtils.GetSplittingElements(part.Document, part.Id)
    If (divisionElements.Count = 0) Then
        message.AppendLine("Part is not divided.")
    Else
        message.AppendLine("The dividers are : ")
        For Each reference In divisionElements
            Dim element As Element = part.Document.GetElement(reference)
            message.AppendLine(element.GetType.Name + " " + element.Id.ToString)
        Next
    End If

    TaskDialog.Show("Revit", message.ToString)
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

PartUtils Class


HasAssociatedParts Method

[image] [image]

Revit 2024 API
PartUtils..::..HasAssociatedParts Method
PartUtils Class See Also Send Feedback

Overload List

Name | Description
HasAssociatedParts(Document, ElementId) | Checks if an element has associated parts.
HasAssociatedParts(Document, LinkElementId) | Checks if an element has associated parts.

See Also

PartUtils Class
PartUtils Members


HasAssociatedParts Method (Document, ElementId)

[image]

Revit 2024 API
PartUtils..::..HasAssociatedParts Method (Document, ElementId)
PartUtils Class See Also Send Feedback
Checks if an element has associated parts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static bool HasAssociatedParts(
    Document hostDocument,
    ElementId elementId
)
Visual Basic
Public Shared Function HasAssociatedParts ( _
    hostDocument As Document, _
    elementId As ElementId _
) As Boolean
Visual C++
public:
static bool HasAssociatedParts(
    Document^ hostDocument,
    ElementId^ elementId
)

Parameters

hostDocument
Type: Autodesk.Revit.DB..::..Document
The document.
elementId
Type: Autodesk.Revit.DB..::..ElementId
The element to be checked for associated Parts

Return Value

True if the element has associated Parts.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

PartUtils Class
HasAssociatedParts Overload


HasAssociatedParts Method (Document, LinkElementId)

[image]

Revit 2024 API
PartUtils..::..HasAssociatedParts Method (Document, LinkElementId)
PartUtils Class See Also Send Feedback
Checks if an element has associated parts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static bool HasAssociatedParts(
    Document hostDocument,
    LinkElementId hostOrLinkElementId
)
Visual Basic
Public Shared Function HasAssociatedParts ( _
    hostDocument As Document, _
    hostOrLinkElementId As LinkElementId _
) As Boolean
Visual C++
public:
static bool HasAssociatedParts(
    Document^ hostDocument,
    LinkElementId^ hostOrLinkElementId
)

Parameters

hostDocument
Type: Autodesk.Revit.DB..::..Document
The document.
hostOrLinkElementId
Type: Autodesk.Revit.DB..::..LinkElementId
The element to be checked for associated Parts.

Return Value

True if the element has associated Parts.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

PartUtils Class
HasAssociatedParts Overload


IsPartDerivedFromLink Method

[image]

Revit 2024 API
PartUtils..::..IsPartDerivedFromLink Method
PartUtils Class See Also Send Feedback
Is the Part derived from link geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static bool IsPartDerivedFromLink(
    Part dPart
)
Visual Basic
Public Shared Function IsPartDerivedFromLink ( _
    dPart As Part _
) As Boolean
Visual C++
public:
static bool IsPartDerivedFromLink(
    Part^ dPart
)

Parameters

dPart
Type: Autodesk.Revit.DB..::..Part

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

PartUtils Class


IsValidForCreateParts Method

[image]

Revit 2024 API
PartUtils..::..IsValidForCreateParts Method
PartUtils Class See Also Send Feedback
Identifies if the given element can be used to create parts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static bool IsValidForCreateParts(
    Document document,
    LinkElementId hostOrLinkElementId
)
Visual Basic
Public Shared Function IsValidForCreateParts ( _
    document As Document, _
    hostOrLinkElementId As LinkElementId _
) As Boolean
Visual C++
public:
static bool IsValidForCreateParts(
    Document^ document,
    LinkElementId^ hostOrLinkElementId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
hostOrLinkElementId
Type: Autodesk.Revit.DB..::..LinkElementId
Id to be tested for validity for creating part.

Return Value

True if this id is valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

PartUtils Class


Path3d Class

[image]

Revit 2024 API
Path3d Class
Members See Also Send Feedback
Provides access to the Generic 3D path object in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class Path3d : SketchBase
Visual Basic
Public Class Path3d _
    Inherits SketchBase
Visual C++
public ref class Path3d : public SketchBase

Remarks

This object represents a 3D path sketch of Sweep.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..SketchBase
Autodesk.Revit.DB..::..Path3d

See Also

Path3d Members


Path3d Methods

[image] [image]

Revit 2024 API
Path3d Methods
Path3d Class See Also Send Feedback

The Path3d type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Path3d Class


AllCurveLoops Property

[image]

Revit 2024 API
Path3d..::..AllCurveLoops Property
Path3d Class See Also Send Feedback
Get all the Curve Loops of Path3d.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CurveArrArray AllCurveLoops { get; }
Visual Basic
Public ReadOnly Property AllCurveLoops As CurveArrArray
    Get
Visual C++
public:
property CurveArrArray^ AllCurveLoops {
    CurveArrArray^ get ();
}

Remarks

Returns all the Curve Loops of Path3d.

See Also

Path3d Class


CurveLoop Property

[image]

Revit 2024 API
Path3d..::..CurveLoop Property
Path3d Class See Also Send Feedback
Get the Curve Loop of Path3d via index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CurveArray this[
    int index
] { get; }
Visual Basic
Public ReadOnly Property CurveLoop ( _
    index As Integer _
) As CurveArray
    Get
Visual C++
public:
property CurveArray^ CurveLoop[int index] {
    CurveArray^ get (int index);
}

Parameters

index
Type: System..::..Int32

Remarks

Returns the index order Curve Loop of Path3d.

See Also

Path3d Class


NumCurveLoops Property

[image]

Revit 2024 API
Path3d..::..NumCurveLoops Property
Path3d Class See Also Send Feedback
Get the Number of Curve Loops of Path3d.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public int NumCurveLoops { get; }
Visual Basic
Public ReadOnly Property NumCurveLoops As Integer
    Get
Visual C++
public:
property int NumCurveLoops {
    int get ();
}

Remarks

Returns the Number of Curve Loops of Path3d.

See Also

Path3d Class


PDFExportOptions Members

[image] [image]

Revit 2024 API
PDFExportOptions Members
PDFExportOptions Class Constructors Methods Properties See Also Send Feedback

The PDFExportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | PDFExportOptions | Creates a default options object.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the PDFExportOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNamingRule | Gets a copy of the naming rule.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValidNamingRule | Whether naming rule is valid or not.
Public method | SetNamingRule | Sets the naming rule.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AlwaysUseRaster | If true completely use raster processing for graphics, otherwise use vector processing as much as possible.
Public property | ColorDepth | Color depth of either black/white, gray scale or color.
Public property | Combine | Whether export all views and sheets into one PDF file or multiple files.
Public property | ExportQuality | The preferred export quality (DPI).
Public property | FileName | File name of the PDF when Combine is trueTruetruetrue (True in Visual Basic).
Public property | HideCropBoundaries | Whether to hide crop boundaries.
Public property | HideReferencePlane | Whether to hide reference/work planes.
Public property | HideScopeBoxes | Whether to hide scope boxes.
Public property | HideUnreferencedViewTags | Whether to hide unreferenced view tags.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MaskCoincidentLines | Whether to mask coincident lines.
Public property | OriginOffsetX | Offset between left sides of pdf content and paper. Always stored in unit of Feet.
Public property | OriginOffsetY | Offset between bottom sides of pdf content and paper. Always stored in unit of Feet.
Public property | PaperFormat | Paper format.
Public property | PaperOrientation | Paper orientation - Portrait/Landscape/Auto
Public property | PaperPlacement | Paper placement of either center or offset from corner.
Public property | RasterQuality | The preferred raster quality (DPI).
Public property | ReplaceHalftoneWithThinLines | Whether to replace halftone with thin lines.
Public property | StopOnError | Whether export process should stop when a view fails to export
Public property | ViewLinksInBlue | Whether set view links blue.
Public property | ZoomPercentage | Percentage of the zoom for the view.
Public property | ZoomType | Zoom type of either fit to page or on a specific percentage.

See Also

PDFExportOptions Class


PDFExportOptions Constructor

[image]

Revit 2024 API
PDFExportOptions Constructor
PDFExportOptions Class See Also Send Feedback
Creates a default options object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public PDFExportOptions()
Visual Basic
Public Sub New
Visual C++
public:
PDFExportOptions()

See Also

PDFExportOptions Class


PDFExportOptions Methods

[image] [image]

Revit 2024 API
PDFExportOptions Methods
PDFExportOptions Class See Also Send Feedback

The PDFExportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNamingRule | Gets a copy of the naming rule.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValidNamingRule | Whether naming rule is valid or not.
Public method | SetNamingRule | Sets the naming rule.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PDFExportOptions Class


GetNamingRule Method

[image]

Revit 2024 API
PDFExportOptions..::..GetNamingRule Method
PDFExportOptions Class See Also Send Feedback
Gets a copy of the naming rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public IList<TableCellCombinedParameterData> GetNamingRule()
Visual Basic
Public Function GetNamingRule As IList(Of TableCellCombinedParameterData)
Visual C++
public:
IList<TableCellCombinedParameterData^>^ GetNamingRule()

Return Value

The naming rule.

See Also

PDFExportOptions Class


IsValidNamingRule Method

[image]

Revit 2024 API
PDFExportOptions..::..IsValidNamingRule Method
PDFExportOptions Class See Also Send Feedback
Whether naming rule is valid or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public static bool IsValidNamingRule(
    IList<TableCellCombinedParameterData> namingRule
)
Visual Basic
Public Shared Function IsValidNamingRule ( _
    namingRule As IList(Of TableCellCombinedParameterData) _
) As Boolean
Visual C++
public:
static bool IsValidNamingRule(
    IList<TableCellCombinedParameterData^>^ namingRule
)

Parameters

namingRule
Type: System.Collections.Generic..::..IList<(Of <(<' TableCellCombinedParameterData >)>)>
The naming rule to be validated.

Return Value

Whether or not the name is valid.

Remarks

If true, this naming rule is a valid. If false, this naming rule is not valid for empty naming rule or illegal characters, such as
CopyC#
\ / : * ? " < > |
.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

PDFExportOptions Class


SetNamingRule Method

[image]

Revit 2024 API
PDFExportOptions..::..SetNamingRule Method
PDFExportOptions Class See Also Send Feedback
Sets the naming rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public void SetNamingRule(
    IList<TableCellCombinedParameterData> namingRule
)
Visual Basic
Public Sub SetNamingRule ( _
    namingRule As IList(Of TableCellCombinedParameterData) _
)
Visual C++
public:
void SetNamingRule(
    IList<TableCellCombinedParameterData^>^ namingRule
)

Parameters

namingRule
Type: System.Collections.Generic..::..IList<(Of <(<' TableCellCombinedParameterData >)>)>
The naming rule.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The namingRule is empty or contains illegal characters.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

PDFExportOptions Class


PDFExportOptions Properties

[image] [image]

Revit 2024 API
PDFExportOptions Properties
PDFExportOptions Class See Also Send Feedback

The PDFExportOptions type exposes the following members.

Properties

 | Name | Description
Public property | AlwaysUseRaster | If true completely use raster processing for graphics, otherwise use vector processing as much as possible.
Public property | ColorDepth | Color depth of either black/white, gray scale or color.
Public property | Combine | Whether export all views and sheets into one PDF file or multiple files.
Public property | ExportQuality | The preferred export quality (DPI).
Public property | FileName | File name of the PDF when Combine is trueTruetruetrue (True in Visual Basic).
Public property | HideCropBoundaries | Whether to hide crop boundaries.
Public property | HideReferencePlane | Whether to hide reference/work planes.
Public property | HideScopeBoxes | Whether to hide scope boxes.
Public property | HideUnreferencedViewTags | Whether to hide unreferenced view tags.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MaskCoincidentLines | Whether to mask coincident lines.
Public property | OriginOffsetX | Offset between left sides of pdf content and paper. Always stored in unit of Feet.
Public property | OriginOffsetY | Offset between bottom sides of pdf content and paper. Always stored in unit of Feet.
Public property | PaperFormat | Paper format.
Public property | PaperOrientation | Paper orientation - Portrait/Landscape/Auto
Public property | PaperPlacement | Paper placement of either center or offset from corner.
Public property | RasterQuality | The preferred raster quality (DPI).
Public property | ReplaceHalftoneWithThinLines | Whether to replace halftone with thin lines.
Public property | StopOnError | Whether export process should stop when a view fails to export
Public property | ViewLinksInBlue | Whether set view links blue.
Public property | ZoomPercentage | Percentage of the zoom for the view.
Public property | ZoomType | Zoom type of either fit to page or on a specific percentage.

See Also

PDFExportOptions Class


AlwaysUseRaster Property

[image]

Revit 2024 API
PDFExportOptions..::..AlwaysUseRaster Property
PDFExportOptions Class See Also Send Feedback
If true completely use raster processing for graphics, otherwise use vector processing as much as possible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public bool AlwaysUseRaster { get; set; }
Visual Basic
Public Property AlwaysUseRaster As Boolean
    Get
    Set
Visual C++
public:
property bool AlwaysUseRaster {
    bool get ();
    void set (bool value);
}

See Also

PDFExportOptions Class


ColorDepth Property

[image]

Revit 2024 API
PDFExportOptions..::..ColorDepth Property
PDFExportOptions Class See Also Send Feedback
Color depth of either black/white, gray scale or color.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public ColorDepthType ColorDepth { get; set; }
Visual Basic
Public Property ColorDepth As ColorDepthType
    Get
    Set
Visual C++
public:
property ColorDepthType ColorDepth {
    ColorDepthType get ();
    void set (ColorDepthType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

PDFExportOptions Class


Combine Property

[image]

Revit 2024 API
PDFExportOptions..::..Combine Property
PDFExportOptions Class See Also Send Feedback
Whether export all views and sheets into one PDF file or multiple files.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public bool Combine { get; set; }
Visual Basic
Public Property Combine As Boolean
    Get
    Set
Visual C++
public:
property bool Combine {
    bool get ();
    void set (bool value);
}

Remarks

If trueTruetruetrue (True in Visual Basic), all exported views and sheets will be exported into one PDF file, whose file name would be specified by FileName. If falseFalsefalsefalse (False in Visual Basic), each exported view and sheet will have its own PDF file created, whose file name would be generated with [!:NamingRule].

See Also

PDFExportOptions Class


ExportQuality Property

[image]

Revit 2024 API
PDFExportOptions..::..ExportQuality Property
PDFExportOptions Class See Also Send Feedback
The preferred export quality (DPI).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public PDFExportQualityType ExportQuality { get; set; }
Visual Basic
Public Property ExportQuality As PDFExportQualityType
    Get
    Set
Visual C++
public:
property PDFExportQualityType ExportQuality {
    PDFExportQualityType get ();
    void set (PDFExportQualityType value);
}

Remarks

This quality setting is the equivalent of printer resolution found in advanced printer settings. An effect of the setting is to control tessellation quality.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

PDFExportOptions Class


FileName Property

[image]

Revit 2024 API
PDFExportOptions..::..FileName Property
PDFExportOptions Class See Also Send Feedback
File name of the PDF when Combine is trueTruetruetrue (True in Visual Basic).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public string FileName { get; set; }
Visual Basic
Public Property FileName As String
    Get
    Set
Visual C++
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}

Remarks

PDF file extension (".pdf") would be automatically appended to the result file. When Combine is falseFalsefalsefalse (False in Visual Basic), this would be ignored.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

PDFExportOptions Class


HideCropBoundaries Property

[image]

Revit 2024 API
PDFExportOptions..::..HideCropBoundaries Property
PDFExportOptions Class See Also Send Feedback
Whether to hide crop boundaries.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public bool HideCropBoundaries { get; set; }
Visual Basic
Public Property HideCropBoundaries As Boolean
    Get
    Set
Visual C++
public:
property bool HideCropBoundaries {
    bool get ();
    void set (bool value);
}

See Also

PDFExportOptions Class


HideReferencePlane Property

[image]

Revit 2024 API
PDFExportOptions..::..HideReferencePlane Property
PDFExportOptions Class See Also Send Feedback
Whether to hide reference/work planes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public bool HideReferencePlane { get; set; }
Visual Basic
Public Property HideReferencePlane As Boolean
    Get
    Set
Visual C++
public:
property bool HideReferencePlane {
    bool get ();
    void set (bool value);
}

See Also

PDFExportOptions Class


HideScopeBoxes Property

[image]

Revit 2024 API
PDFExportOptions..::..HideScopeBoxes Property
PDFExportOptions Class See Also Send Feedback
Whether to hide scope boxes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public bool HideScopeBoxes { get; set; }
Visual Basic
Public Property HideScopeBoxes As Boolean
    Get
    Set
Visual C++
public:
property bool HideScopeBoxes {
    bool get ();
    void set (bool value);
}

See Also

PDFExportOptions Class


IsValidObject Property

[image]

Revit 2024 API
PDFExportOptions..::..IsValidObject Property
PDFExportOptions Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

PDFExportOptions Class


MaskCoincidentLines Property

[image]

Revit 2024 API
PDFExportOptions..::..MaskCoincidentLines Property
PDFExportOptions Class See Also Send Feedback
Whether to mask coincident lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public bool MaskCoincidentLines { get; set; }
Visual Basic
Public Property MaskCoincidentLines As Boolean
    Get
    Set
Visual C++
public:
property bool MaskCoincidentLines {
    bool get ();
    void set (bool value);
}

See Also

PDFExportOptions Class


OriginOffsetX Property

[image]

Revit 2024 API
PDFExportOptions..::..OriginOffsetX Property
PDFExportOptions Class See Also Send Feedback
Offset between left sides of pdf content and paper. Always stored in unit of Feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public double OriginOffsetX { get; set; }
Visual Basic
Public Property OriginOffsetX As Double
    Get
    Set
Visual C++
public:
property double OriginOffsetX {
    double get ();
    void set (double value);
}

See Also

PDFExportOptions Class


PaperFormat Property

[image]

Revit 2024 API
PDFExportOptions..::..PaperFormat Property
PDFExportOptions Class See Also Send Feedback
Paper format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public ExportPaperFormat PaperFormat { get; set; }
Visual Basic
Public Property PaperFormat As ExportPaperFormat
    Get
    Set
Visual C++
public:
property ExportPaperFormat PaperFormat {
    ExportPaperFormat get ();
    void set (ExportPaperFormat value);
}

Remarks

When the PaperFormat is ExportPaperFormat.Default, which means "Use Sheet Size".

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The input paper format is invalid

See Also

PDFExportOptions Class


PaperOrientation Property

[image]

Revit 2024 API
PDFExportOptions..::..PaperOrientation Property
PDFExportOptions Class See Also Send Feedback
Paper orientation - Portrait/Landscape/Auto

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public PageOrientationType PaperOrientation { get; set; }
Visual Basic
Public Property PaperOrientation As PageOrientationType
    Get
    Set
Visual C++
public:
property PageOrientationType PaperOrientation {
    PageOrientationType get ();
    void set (PageOrientationType value);
}

Remarks

Ignored when the PaperFormat is ExportPaperFormat.Default, which means "Use Sheet Size".

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

PDFExportOptions Class


ReplaceHalftoneWithThinLines Property

[image]

Revit 2024 API
PDFExportOptions..::..ReplaceHalftoneWithThinLines Property
PDFExportOptions Class See Also Send Feedback
Whether to replace halftone with thin lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public bool ReplaceHalftoneWithThinLines { get; set; }
Visual Basic
Public Property ReplaceHalftoneWithThinLines As Boolean
    Get
    Set
Visual C++
public:
property bool ReplaceHalftoneWithThinLines {
    bool get ();
    void set (bool value);
}

See Also

PDFExportOptions Class


StopOnError Property

[image]

Revit 2024 API
PDFExportOptions..::..StopOnError Property
PDFExportOptions Class See Also Send Feedback
Whether export process should stop when a view fails to export

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public bool StopOnError { get; set; }
Visual Basic
Public Property StopOnError As Boolean
    Get
    Set
Visual C++
public:
property bool StopOnError {
    bool get ();
    void set (bool value);
}

See Also

PDFExportOptions Class


ViewLinksInBlue Property

[image]

Revit 2024 API
PDFExportOptions..::..ViewLinksInBlue Property
PDFExportOptions Class See Also Send Feedback
Whether set view links blue.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public bool ViewLinksInBlue { get; set; }
Visual Basic
Public Property ViewLinksInBlue As Boolean
    Get
    Set
Visual C++
public:
property bool ViewLinksInBlue {
    bool get ();
    void set (bool value);
}

Remarks

If true, links will be visible as blue. If false, they retain their default text color.

See Also

PDFExportOptions Class


ZoomPercentage Property

[image]

Revit 2024 API
PDFExportOptions..::..ZoomPercentage Property
PDFExportOptions Class See Also Send Feedback
Percentage of the zoom for the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public int ZoomPercentage { get; set; }
Visual Basic
Public Property ZoomPercentage As Integer
    Get
    Set
Visual C++
public:
property int ZoomPercentage {
    int get ();
    void set (int value);
}

Remarks

This property would be ignored if the ZoomType is FitToPage.

See Also

PDFExportOptions Class


ZoomType Property

[image]

Revit 2024 API
PDFExportOptions..::..ZoomType Property
PDFExportOptions Class See Also Send Feedback
Zoom type of either fit to page or on a specific percentage.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public ZoomType ZoomType { get; set; }
Visual Basic
Public Property ZoomType As ZoomType
    Get
    Set
Visual C++
public:
property ZoomType ZoomType {
    ZoomType get ();
    void set (ZoomType value);
}

Remarks

This property would be ignored if the PaperFormat is Default.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

PDFExportOptions Class


PDFExportQualityType Enumeration

[image]

Revit 2024 API
PDFExportQualityType Enumeration
See Also Send Feedback
An enumerated type listing the options for PDF export quality.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum PDFExportQualityType
Visual Basic
Public Enumeration PDFExportQualityType
Visual C++
public enum class PDFExportQualityType

Members

Member name | Description
DPI72 |
DPI144 |
DPI300 |
DPI600 |
DPI1200 |
DPI2400 |
DPI3600 |
DPI4000 |

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


PerformanceAdviser Members

[image] [image]

Revit 2024 API
PerformanceAdviser Members
PerformanceAdviser Class Methods Properties See Also Send Feedback

The PerformanceAdviser type exposes the following members.

Methods

 | Name | Description
Public method | AddRule | Adds a performance adviser rule to the list of rules.
Public method | DeleteRule | Deletes a performance adviser rule from the list of rules.
Public method | Dispose | Releases all resources used by the PerformanceAdviser
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExecuteAllRules | Executes all rules in the list on a given document.
Public method | ExecuteRules(Document, IList<(Of <<'(PerformanceAdviserRuleId>)>>)) | Executes selected rules on a given document.
Public method | ExecuteRules(Document, IList<(Of <<'(Int32>)>>)) | Executes selected rules on a given document.
Public method | GetAllRuleIds | Retrieves an enumeration of rule Ids.
Public method | GetElementFilterFromRule(Int32, Document) | Retrieves a filter to restrict elements to be checked.
Public method | GetElementFilterFromRule(PerformanceAdviserRuleId, Document) | Retrieves a filter to restrict elements to be checked.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNumberOfRules | Retrieves number of performance adviser rules in the list.
 | GetPerformanceAdviser | Returns the only instance of PerformanceAdviser in the Application.
Public method | GetRuleDescription(Int32) | Retrieves the description of the rule.
Public method | GetRuleDescription(PerformanceAdviserRuleId) | Retrieves the description of the rule.
Public method | GetRuleId | Retrieves an id of a rule for a given index in the list.
Public method | GetRuleName(Int32) | Retrieves the name of the rule.
Public method | GetRuleName(PerformanceAdviserRuleId) | Retrieves the name of the rule.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsRuleEnabled(Int32) | Retrieves an enabled/disabled status for the given rule.
Public method | IsRuleEnabled(PerformanceAdviserRuleId) | Retrieves an enabled/disabled status for the given rule.
Public method | PostWarning | Reports a problem detected during execution of a rule.
Public method | SetRuleEnabled(Int32, Boolean) | Retrieves an enabled/disabled status for the given rule.
Public method | SetRuleEnabled(PerformanceAdviserRuleId, Boolean) | Retrieves an enabled/disabled status for the given rule.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WillRuleCheckElements(Int32) | Reports if rule needs to be executed on individual elements.
Public method | WillRuleCheckElements(PerformanceAdviserRuleId) | Reports if rule needs to be executed on individual elements.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

PerformanceAdviser Class


PerformanceAdviser Methods

[image] [image]

Revit 2024 API
PerformanceAdviser Methods
PerformanceAdviser Class See Also Send Feedback

The PerformanceAdviser type exposes the following members.

Methods

 | Name | Description
Public method | AddRule | Adds a performance adviser rule to the list of rules.
Public method | DeleteRule | Deletes a performance adviser rule from the list of rules.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExecuteAllRules | Executes all rules in the list on a given document.
Public method | ExecuteRules(Document, IList<(Of <<'(PerformanceAdviserRuleId>)>>)) | Executes selected rules on a given document.
Public method | ExecuteRules(Document, IList<(Of <<'(Int32>)>>)) | Executes selected rules on a given document.
Public method | GetAllRuleIds | Retrieves an enumeration of rule Ids.
Public method | GetElementFilterFromRule(Int32, Document) | Retrieves a filter to restrict elements to be checked.
Public method | GetElementFilterFromRule(PerformanceAdviserRuleId, Document) | Retrieves a filter to restrict elements to be checked.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNumberOfRules | Retrieves number of performance adviser rules in the list.
 | GetPerformanceAdviser | Returns the only instance of PerformanceAdviser in the Application.
Public method | GetRuleDescription(Int32) | Retrieves the description of the rule.
Public method | GetRuleDescription(PerformanceAdviserRuleId) | Retrieves the description of the rule.
Public method | GetRuleId | Retrieves an id of a rule for a given index in the list.
Public method | GetRuleName(Int32) | Retrieves the name of the rule.
Public method | GetRuleName(PerformanceAdviserRuleId) | Retrieves the name of the rule.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsRuleEnabled(Int32) | Retrieves an enabled/disabled status for the given rule.
Public method | IsRuleEnabled(PerformanceAdviserRuleId) | Retrieves an enabled/disabled status for the given rule.
Public method | PostWarning | Reports a problem detected during execution of a rule.
Public method | SetRuleEnabled(Int32, Boolean) | Retrieves an enabled/disabled status for the given rule.
Public method | SetRuleEnabled(PerformanceAdviserRuleId, Boolean) | Retrieves an enabled/disabled status for the given rule.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WillRuleCheckElements(Int32) | Reports if rule needs to be executed on individual elements.
Public method | WillRuleCheckElements(PerformanceAdviserRuleId) | Reports if rule needs to be executed on individual elements.

See Also

PerformanceAdviser Class


AddRule Method

[image]

Revit 2024 API
PerformanceAdviser..::..AddRule Method
PerformanceAdviser Class See Also Send Feedback
Adds a performance adviser rule to the list of rules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public void AddRule(
    PerformanceAdviserRuleId id,
    IPerformanceAdviserRule rule
)
Visual Basic
Public Sub AddRule ( _
    id As PerformanceAdviserRuleId, _
    rule As IPerformanceAdviserRule _
)
Visual C++
public:
void AddRule(
    PerformanceAdviserRuleId^ id,
    IPerformanceAdviserRule^ rule
)

Parameters

id
Type: Autodesk.Revit.DB..::..PerformanceAdviserRuleId
An id of the rule to be added to the list of rules.
rule
Type: Autodesk.Revit.DB..::..IPerformanceAdviserRule
The rule to be added

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

PerformanceAdviser Class


DeleteRule Method

[image]

Revit 2024 API
PerformanceAdviser..::..DeleteRule Method
PerformanceAdviser Class See Also Send Feedback
Deletes a performance adviser rule from the list of rules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public void DeleteRule(
    PerformanceAdviserRuleId id
)
Visual Basic
Public Sub DeleteRule ( _
    id As PerformanceAdviserRuleId _
)
Visual C++
public:
void DeleteRule(
    PerformanceAdviserRuleId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::..PerformanceAdviserRuleId
An id of the rule to be deleted from the list of rules.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

PerformanceAdviser Class


Dispose Method

[image]

Revit 2024 API
PerformanceAdviser..::..Dispose Method
PerformanceAdviser Class See Also Send Feedback
Releases all resources used by the PerformanceAdviser

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

PerformanceAdviser Class


ExecuteAllRules Method

[image]

Revit 2024 API
PerformanceAdviser..::..ExecuteAllRules Method
PerformanceAdviser Class See Also Send Feedback
Executes all rules in the list on a given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public IList<FailureMessage> ExecuteAllRules(
    Document document
)
Visual Basic
Public Function ExecuteAllRules ( _
    document As Document _
) As IList(Of FailureMessage)
Visual C++
public:
IList<FailureMessage^>^ ExecuteAllRules(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Document on which the rules will be executed.

Return Value

Failure messages explaining performance problems detected in the document.

Remarks

Disabled rules are not executed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

PerformanceAdviser Class


ExecuteRules Method

[image] [image]

Revit 2024 API
PerformanceAdviser..::..ExecuteRules Method
PerformanceAdviser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ExecuteRules(Document, IList<(Of <<'(PerformanceAdviserRuleId>)>>)) | Executes selected rules on a given document.
Public method | ExecuteRules(Document, IList<(Of <<'(Int32>)>>)) | Executes selected rules on a given document.

See Also

PerformanceAdviser Class
PerformanceAdviser Members


GetElementFilterFromRule Method

[image] [image]

Revit 2024 API
PerformanceAdviser..::..GetElementFilterFromRule Method
PerformanceAdviser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetElementFilterFromRule(Int32, Document) | Retrieves a filter to restrict elements to be checked.
Public method | GetElementFilterFromRule(PerformanceAdviserRuleId, Document) | Retrieves a filter to restrict elements to be checked.

See Also

PerformanceAdviser Class
PerformanceAdviser Members


GetElementFilterFromRule Method (Int32, Document)

[image]

Revit 2024 API
PerformanceAdviser..::..GetElementFilterFromRule Method (Int32, Document)
PerformanceAdviser Class See Also Send Feedback
Retrieves a filter to restrict elements to be checked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public ElementFilter GetElementFilterFromRule(
    int index,
    Document document
)
Visual Basic
Public Function GetElementFilterFromRule ( _
    index As Integer, _
    document As Document _
) As ElementFilter
Visual C++
public:
ElementFilter^ GetElementFilterFromRule(
    int index,
    Document^ document
)

Parameters

index
Type: System..::..Int32
The rule index to get information for.
document
Type: Autodesk.Revit.DB..::..Document
Document for which performance problems are being checked.

Return Value

The filter to restrict elements to be checked.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

PerformanceAdviser Class
GetElementFilterFromRule Overload


GetElementFilterFromRule Method (PerformanceAdviserRuleId, Document)

[image]

Revit 2024 API
PerformanceAdviser..::..GetElementFilterFromRule Method (PerformanceAdviserRuleId, Document)
PerformanceAdviser Class See Also Send Feedback
Retrieves a filter to restrict elements to be checked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public ElementFilter GetElementFilterFromRule(
    PerformanceAdviserRuleId id,
    Document document
)
Visual Basic
Public Function GetElementFilterFromRule ( _
    id As PerformanceAdviserRuleId, _
    document As Document _
) As ElementFilter
Visual C++
public:
ElementFilter^ GetElementFilterFromRule(
    PerformanceAdviserRuleId^ id,
    Document^ document
)

Parameters

id
Type: Autodesk.Revit.DB..::..PerformanceAdviserRuleId
The rule id to get information for.
document
Type: Autodesk.Revit.DB..::..Document
Document for which performance problems are being checked.

Return Value

The filter to restrict elements to be checked.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

PerformanceAdviser Class
GetElementFilterFromRule Overload


GetNumberOfRules Method

[image]

Revit 2024 API
PerformanceAdviser..::..GetNumberOfRules Method
PerformanceAdviser Class See Also Send Feedback
Retrieves number of performance adviser rules in the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public int GetNumberOfRules()
Visual Basic
Public Function GetNumberOfRules As Integer
Visual C++
public:
int GetNumberOfRules()

Return Value

Number of performance adviser rules in the list.

See Also

PerformanceAdviser Class


GetPerformanceAdviser Method

[image]

Revit 2024 API
PerformanceAdviser..::..GetPerformanceAdviser Method
PerformanceAdviser Class See Also Send Feedback
Returns the only instance of PerformanceAdviser in the Application.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static PerformanceAdviser GetPerformanceAdviser()
Visual Basic
Public Shared Function GetPerformanceAdviser As PerformanceAdviser
Visual C++
public:
static PerformanceAdviser^ GetPerformanceAdviser()

Return Value

The only instance of PerformanceAdviser in the Application.

See Also

PerformanceAdviser Class


GetRuleDescription Method

[image] [image]

Revit 2024 API
PerformanceAdviser..::..GetRuleDescription Method
PerformanceAdviser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRuleDescription(Int32) | Retrieves the description of the rule.
Public method | GetRuleDescription(PerformanceAdviserRuleId) | Retrieves the description of the rule.

See Also

PerformanceAdviser Class
PerformanceAdviser Members


GetRuleDescription Method (Int32)

[image]

Revit 2024 API
PerformanceAdviser..::..GetRuleDescription Method (Int32)
PerformanceAdviser Class See Also Send Feedback
Retrieves the description of the rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public string GetRuleDescription(
    int index
)
Visual Basic
Public Function GetRuleDescription ( _
    index As Integer _
) As String
Visual C++
public:
String^ GetRuleDescription(
    int index
)

Parameters

index
Type: System..::..Int32
The rule index to get information for.

Return Value

The description of the rule.

See Also

PerformanceAdviser Class
GetRuleDescription Overload


GetRuleId Method

[image]

Revit 2024 API
PerformanceAdviser..::..GetRuleId Method
PerformanceAdviser Class See Also Send Feedback
Retrieves an id of a rule for a given index in the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public PerformanceAdviserRuleId GetRuleId(
    int index
)
Visual Basic
Public Function GetRuleId ( _
    index As Integer _
) As PerformanceAdviserRuleId
Visual C++
public:
PerformanceAdviserRuleId^ GetRuleId(
    int index
)

Parameters

index
Type: System..::..Int32
The index to retrieve the rule id for.

Return Value

The rule id.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The index is outside of acceptable range.

See Also

PerformanceAdviser Class


GetRuleName Method

[image] [image]

Revit 2024 API
PerformanceAdviser..::..GetRuleName Method
PerformanceAdviser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRuleName(Int32) | Retrieves the name of the rule.
Public method | GetRuleName(PerformanceAdviserRuleId) | Retrieves the name of the rule.

See Also

PerformanceAdviser Class
PerformanceAdviser Members


GetRuleName Method (Int32)

[image]

Revit 2024 API
PerformanceAdviser..::..GetRuleName Method (Int32)
PerformanceAdviser Class See Also Send Feedback
Retrieves the name of the rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public string GetRuleName(
    int index
)
Visual Basic
Public Function GetRuleName ( _
    index As Integer _
) As String
Visual C++
public:
String^ GetRuleName(
    int index
)

Parameters

index
Type: System..::..Int32
The rule index to get information for.

Return Value

The name of the rule.

See Also

PerformanceAdviser Class
GetRuleName Overload


GetRuleName Method (PerformanceAdviserRuleId)

[image]

Revit 2024 API
PerformanceAdviser..::..GetRuleName Method (PerformanceAdviserRuleId)
PerformanceAdviser Class See Also Send Feedback
Retrieves the name of the rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public string GetRuleName(
    PerformanceAdviserRuleId id
)
Visual Basic
Public Function GetRuleName ( _
    id As PerformanceAdviserRuleId _
) As String
Visual C++
public:
String^ GetRuleName(
    PerformanceAdviserRuleId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::..PerformanceAdviserRuleId
The rule id to get information for.

Return Value

The name of the rule.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

PerformanceAdviser Class
GetRuleName Overload


IsRuleEnabled Method

[image] [image]

Revit 2024 API
PerformanceAdviser..::..IsRuleEnabled Method
PerformanceAdviser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsRuleEnabled(Int32) | Retrieves an enabled/disabled status for the given rule.
Public method | IsRuleEnabled(PerformanceAdviserRuleId) | Retrieves an enabled/disabled status for the given rule.

See Also

PerformanceAdviser Class
PerformanceAdviser Members


IsRuleEnabled Method (Int32)

[image]

Revit 2024 API
PerformanceAdviser..::..IsRuleEnabled Method (Int32)
PerformanceAdviser Class See Also Send Feedback
Retrieves an enabled/disabled status for the given rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public bool IsRuleEnabled(
    int index
)
Visual Basic
Public Function IsRuleEnabled ( _
    index As Integer _
) As Boolean
Visual C++
public:
bool IsRuleEnabled(
    int index
)

Parameters

index
Type: System..::..Int32
The rule index to retrieve enabled/disabled status for.

Return Value

True if rule is disabled, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The index is outside of acceptable range.

See Also

PerformanceAdviser Class
IsRuleEnabled Overload


IsRuleEnabled Method (PerformanceAdviserRuleId)

[image]

Revit 2024 API
PerformanceAdviser..::..IsRuleEnabled Method (PerformanceAdviserRuleId)
PerformanceAdviser Class See Also Send Feedback
Retrieves an enabled/disabled status for the given rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public bool IsRuleEnabled(
    PerformanceAdviserRuleId id
)
Visual Basic
Public Function IsRuleEnabled ( _
    id As PerformanceAdviserRuleId _
) As Boolean
Visual C++
public:
bool IsRuleEnabled(
    PerformanceAdviserRuleId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::..PerformanceAdviserRuleId
The rule id to retrieve enabled/disabled status for.

Return Value

True if rule is disabled, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The id does not correspond to any registered rule.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

PerformanceAdviser Class
IsRuleEnabled Overload


PostWarning Method

[image]

Revit 2024 API
PerformanceAdviser..::..PostWarning Method
PerformanceAdviser Class See Also Send Feedback
Reports a problem detected during execution of a rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public void PostWarning(
    FailureMessage message
)
Visual Basic
Public Sub PostWarning ( _
    message As FailureMessage _
)
Visual C++
public:
void PostWarning(
    FailureMessage^ message
)

Parameters

message
Type: Autodesk.Revit.DB..::..FailureMessage
Warning describing the problem detected by a rule.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The message must have severity "warning".
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | Performance advisor is not executing rules.

See Also

PerformanceAdviser Class


SetRuleEnabled Method

[image] [image]

Revit 2024 API
PerformanceAdviser..::..SetRuleEnabled Method
PerformanceAdviser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetRuleEnabled(Int32, Boolean) | Retrieves an enabled/disabled status for the given rule.
Public method | SetRuleEnabled(PerformanceAdviserRuleId, Boolean) | Retrieves an enabled/disabled status for the given rule.

See Also

PerformanceAdviser Class
PerformanceAdviser Members


SetRuleEnabled Method (PerformanceAdviserRuleId, Boolean)

[image]

Revit 2024 API
PerformanceAdviser..::..SetRuleEnabled Method (PerformanceAdviserRuleId, Boolean)
PerformanceAdviser Class See Also Send Feedback
Retrieves an enabled/disabled status for the given rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public void SetRuleEnabled(
    PerformanceAdviserRuleId id,
    bool enabled
)
Visual Basic
Public Sub SetRuleEnabled ( _
    id As PerformanceAdviserRuleId, _
    enabled As Boolean _
)
Visual C++
public:
void SetRuleEnabled(
    PerformanceAdviserRuleId^ id,
    bool enabled
)

Parameters

id
Type: Autodesk.Revit.DB..::..PerformanceAdviserRuleId
The rule id to set enabled/disabled status for.
enabled
Type: System..::..Boolean
True enables the rule, false disables.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The id does not correspond to any registered rule.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

PerformanceAdviser Class
SetRuleEnabled Overload


WillRuleCheckElements Method

[image] [image]

Revit 2024 API
PerformanceAdviser..::..WillRuleCheckElements Method
PerformanceAdviser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WillRuleCheckElements(Int32) | Reports if rule needs to be executed on individual elements.
Public method | WillRuleCheckElements(PerformanceAdviserRuleId) | Reports if rule needs to be executed on individual elements.

See Also

PerformanceAdviser Class
PerformanceAdviser Members


WillRuleCheckElements Method (Int32)

[image]

Revit 2024 API
PerformanceAdviser..::..WillRuleCheckElements Method (Int32)
PerformanceAdviser Class See Also Send Feedback
Reports if rule needs to be executed on individual elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public bool WillRuleCheckElements(
    int index
)
Visual Basic
Public Function WillRuleCheckElements ( _
    index As Integer _
) As Boolean
Visual C++
public:
bool WillRuleCheckElements(
    int index
)

Parameters

index
Type: System..::..Int32
The rule index to get information for.

Return Value

True if rule needs to be executed on individual elements.

See Also

PerformanceAdviser Class
WillRuleCheckElements Overload


WillRuleCheckElements Method (PerformanceAdviserRuleId)

[image]

Revit 2024 API
PerformanceAdviser..::..WillRuleCheckElements Method (PerformanceAdviserRuleId)
PerformanceAdviser Class See Also Send Feedback
Reports if rule needs to be executed on individual elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public bool WillRuleCheckElements(
    PerformanceAdviserRuleId id
)
Visual Basic
Public Function WillRuleCheckElements ( _
    id As PerformanceAdviserRuleId _
) As Boolean
Visual C++
public:
bool WillRuleCheckElements(
    PerformanceAdviserRuleId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::..PerformanceAdviserRuleId
The rule id to get information for.

Return Value

True if rule needs to be executed on individual elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

PerformanceAdviser Class
WillRuleCheckElements Overload


PerformanceAdviser Properties

[image] [image]

Revit 2024 API
PerformanceAdviser Properties
PerformanceAdviser Class See Also Send Feedback

The PerformanceAdviser type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

PerformanceAdviser Class


PerformanceAdviserRuleId Class

[image]

Revit 2024 API
PerformanceAdviserRuleId Class
Members See Also Send Feedback
The unique identifier of a PerformanceAdviserRule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public class PerformanceAdviserRuleId : GuidEnum
Visual Basic
Public Class PerformanceAdviserRuleId _
    Inherits GuidEnum
Visual C++
public ref class PerformanceAdviserRuleId : public GuidEnum

Remarks

Each performance adviser rule registered in application must be given a unique id that can be used to identify and unregister rule later.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..GuidEnum
Autodesk.Revit.DB..::..PerformanceAdviserRuleId

See Also

PerformanceAdviserRuleId Members


PerformanceAdviserRuleId Members

[image] [image]

Revit 2024 API
PerformanceAdviserRuleId Members
PerformanceAdviserRuleId Class Constructors Methods Operators Properties See Also Send Feedback

The PerformanceAdviserRuleId type exposes the following members.

Constructors

 | Name | Description
Public method | PerformanceAdviserRuleId | Creates a new PerformanceAdviserRuleId instance.

Methods

 | Name | Description
Public method | Equals | Compares two Guid-based enum object based on their concrete class and GUID value. (Inherited from GuidEnum.)
Public method | GetHashCode | Generates a hash code for this Guid-based enum object. (Inherited from GuidEnum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Operators

Name | Description
Equality | Compares two PerformanceAdviserRuleId instances.
Inequality | Compares two PerformanceAdviserRuleId instances.

Properties

 | Name | Description
Public property | Guid | The Guid of GUID-based enum object. (Inherited from GuidEnum.)

See Also

PerformanceAdviserRuleId Class


PerformanceAdviserRuleId Constructor

[image]

Revit 2024 API
PerformanceAdviserRuleId Constructor
PerformanceAdviserRuleId Class See Also Send Feedback
Creates a new PerformanceAdviserRuleId instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public PerformanceAdviserRuleId(
    Guid guid
)
Visual Basic
Public Sub New ( _
    guid As Guid _
)
Visual C++
public:
PerformanceAdviserRuleId(
    Guid guid
)

Parameters

guid
Type: System..::..Guid
The identifier for the PerformanceAdviserRuleId.

See Also

PerformanceAdviserRuleId Class


PerformanceAdviserRuleId Methods

[image] [image]

Revit 2024 API
PerformanceAdviserRuleId Methods
PerformanceAdviserRuleId Class See Also Send Feedback

The PerformanceAdviserRuleId type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Compares two Guid-based enum object based on their concrete class and GUID value. (Inherited from GuidEnum.)
Public method | GetHashCode | Generates a hash code for this Guid-based enum object. (Inherited from GuidEnum.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PerformanceAdviserRuleId Class


PerformanceAdviserRuleId Operators

[image] [image]

Revit 2024 API
PerformanceAdviserRuleId Operators
PerformanceAdviserRuleId Class See Also Send Feedback

The PerformanceAdviserRuleId type exposes the following members.

Operators

Name | Description
Equality | Compares two PerformanceAdviserRuleId instances.
Inequality | Compares two PerformanceAdviserRuleId instances.

See Also

PerformanceAdviserRuleId Class


Equality Operator

[image]

Revit 2024 API
PerformanceAdviserRuleId..::..Equality Operator
PerformanceAdviserRuleId Class See Also Send Feedback
Compares two PerformanceAdviserRuleId instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static bool operator ==(
    PerformanceAdviserRuleId first,
    PerformanceAdviserRuleId second
)
Visual Basic
Public Shared Operator = ( _
    first As PerformanceAdviserRuleId, _
    second As PerformanceAdviserRuleId _
) As Boolean
Visual C++
public:
static bool operator ==(
    PerformanceAdviserRuleId^ first,
    PerformanceAdviserRuleId^ second
)

Parameters

first
Type: Autodesk.Revit.DB..::..PerformanceAdviserRuleId
The first PerformanceAdviserRuleId.
second
Type: Autodesk.Revit.DB..::..PerformanceAdviserRuleId
The second PerformanceAdviserRuleId.

Return Value

True if the inputs are identical, false if they are different.

See Also

PerformanceAdviserRuleId Class


PerformanceAdviserRuleId Properties

[image] [image]

Revit 2024 API
PerformanceAdviserRuleId Properties
PerformanceAdviserRuleId Class See Also Send Feedback

The PerformanceAdviserRuleId type exposes the following members.

Properties

 | Name | Description
Public property | Guid | The Guid of GUID-based enum object. (Inherited from GuidEnum.)

See Also

PerformanceAdviserRuleId Class


PerformanceAdviserRules Class

[image]

Revit 2024 API
PerformanceAdviserRules Class
See Also Send Feedback
Provides a container of all Revit built-in PerformanceAdviserRuleId instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static class PerformanceAdviserRules
Visual Basic
Public NotInheritable Class PerformanceAdviserRules
Visual C++
public ref class PerformanceAdviserRules abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..PerformanceAdviserRules

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


Phase Class

[image]

Revit 2024 API
Phase Class
Members See Also Send Feedback
Represents a phase in the life of a building.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class Phase : Element
Visual Basic
Public Class Phase _
    Inherits Element
Visual C++
public ref class Phase : public Element

Remarks

The lifetime of an element within a building can be controlled by using phases. Each element will have a construction phase but only those elements that have a finite lifetime will have a destruction phase. All the phases within a project can be retrieved from the Document object.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..Phase

See Also

Phase Members


Phase Methods

[image] [image]

Revit 2024 API
Phase Methods
Phase Class See Also Send Feedback

The Phase type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Phase Class


Parameter Property

[image] [image]

Revit 2024 API
Phase..::..Parameter Property
Phase Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Phase Class
Phase Members


PhaseArray Class

[image]

Revit 2024 API
PhaseArray Class
Members See Also Send Feedback
An array that contains phase objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class PhaseArray : APIObject, IEnumerable
Visual Basic
Public Class PhaseArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class PhaseArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..PhaseArray

See Also

PhaseArray Members


PhaseArray Methods

[image] [image]

Revit 2024 API
PhaseArray Methods
PhaseArray Class See Also Send Feedback

The PhaseArray type exposes the following members.

Methods

 | Name | Description
Public method | Append | Add the phase to the end of the array.
Public method | Clear | Removes every phase from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified phase into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PhaseArray Class


Append Method

[image]

Revit 2024 API
PhaseArray..::..Append Method
PhaseArray Class See Also Send Feedback
Add the phase to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Append(
    Phase item
)
Visual Basic
Public Overridable Sub Append ( _
    item As Phase _
)
Visual C++
public:
virtual void Append(
    Phase^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..Phase
The phase to be added.

See Also

PhaseArray Class


Clear Method

[image]

Revit 2024 API
PhaseArray..::..Clear Method
PhaseArray Class See Also Send Feedback
Removes every phase from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

PhaseArray Class


ForwardIterator Method

[image]

Revit 2024 API
PhaseArray..::..ForwardIterator Method
PhaseArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual PhaseArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As PhaseArrayIterator
Visual C++
public:
virtual PhaseArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

PhaseArray Class


GetEnumerator Method

[image]

Revit 2024 API
PhaseArray..::..GetEnumerator Method
PhaseArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

PhaseArray Class


Insert Method

[image]

Revit 2024 API
PhaseArray..::..Insert Method
PhaseArray Class See Also Send Feedback
Insert the specified phase into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Insert(
    Phase item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As Phase, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    Phase^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::..Phase
The phase to be inserted into the array.
index
Type: System..::..Int32
The phase will be inserted before this index.

Return Value

Returns whether the phase was inserted into the array.

See Also

PhaseArray Class


ReverseIterator Method

[image]

Revit 2024 API
PhaseArray..::..ReverseIterator Method
PhaseArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual PhaseArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As PhaseArrayIterator
Visual C++
public:
virtual PhaseArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

PhaseArray Class


PhaseArray Properties

[image] [image]

Revit 2024 API
PhaseArray Properties
PhaseArray Class See Also Send Feedback

The PhaseArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a phase at a specified index within the array.
Public property | Size | Returns the number of phases that are in the array.

See Also

PhaseArray Class


IsEmpty Property

[image]

Revit 2024 API
PhaseArray..::..IsEmpty Property
PhaseArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

PhaseArray Class


Size Property

[image]

Revit 2024 API
PhaseArray..::..Size Property
PhaseArray Class See Also Send Feedback
Returns the number of phases that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

PhaseArray Class


PhaseArrayIterator Class

[image]

Revit 2024 API
PhaseArrayIterator Class
Members See Also Send Feedback
An iterator to a phase array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public abstract class PhaseArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class PhaseArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class PhaseArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..PhaseArrayIterator

See Also

PhaseArrayIterator Members


PhaseArrayIterator Members

[image] [image]

Revit 2024 API
PhaseArrayIterator Members
PhaseArrayIterator Class Constructors Methods Properties See Also Send Feedback

The PhaseArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | PhaseArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PhaseArrayIterator Class


PhaseArrayIterator Constructor

[image]

Revit 2024 API
PhaseArrayIterator Constructor
PhaseArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public PhaseArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
PhaseArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PhaseArrayIterator Class


MoveNext Method

[image]

Revit 2024 API
PhaseArrayIterator..::..MoveNext Method
PhaseArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

PhaseArrayIterator Class


Reset Method

[image]

Revit 2024 API
PhaseArrayIterator..::..Reset Method
PhaseArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

PhaseArrayIterator Class


Current Property

[image]

Revit 2024 API
PhaseArrayIterator..::..Current Property
PhaseArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

PhaseArrayIterator Class


PhaseFilter Class

[image]

Revit 2024 API
PhaseFilter Class
Members See Also Send Feedback
Represents an phase filter within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public class PhaseFilter : Element
Visual Basic
Public Class PhaseFilter _
    Inherits Element
Visual C++
public ref class PhaseFilter : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..PhaseFilter

See Also

PhaseFilter Members


PhaseFilter Members

[image] [image]

Revit 2024 API
PhaseFilter Members
PhaseFilter Class Methods Properties See Also Send Feedback

The PhaseFilter type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create | Creates a new phase filter with default status presentation.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPhaseStatusPresentation | Gets the phase status presentation.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetPhaseStatusPresentation | Sets the phase status presentation.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsDefault | Indicates whether this filter is the default one.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PhaseFilter Class


Create Method

[image]

Revit 2024 API
PhaseFilter..::..Create Method
PhaseFilter Class See Also Send Feedback
Creates a new phase filter with default status presentation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static PhaseFilter Create(
    Document document,
    string name
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    name As String _
) As PhaseFilter
Visual C++
public:
static PhaseFilter^ Create(
    Document^ document,
    String^ name
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
name
Type: System..::..String
The name.

Return Value

The newly created phase filter.

Remarks

The default status presentation is ShowByCategory for New status, and ShowOverriden for Existing, Demolished and Temporary statuses.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | name is already in use.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

PhaseFilter Class


GetPhaseStatusPresentation Method

[image]

Revit 2024 API
PhaseFilter..::..GetPhaseStatusPresentation Method
PhaseFilter Class See Also Send Feedback
Gets the phase status presentation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public PhaseStatusPresentation GetPhaseStatusPresentation(
    ElementOnPhaseStatus status
)
Visual Basic
Public Function GetPhaseStatusPresentation ( _
    status As ElementOnPhaseStatus _
) As PhaseStatusPresentation
Visual C++
public:
PhaseStatusPresentation GetPhaseStatusPresentation(
    ElementOnPhaseStatus status
)

Parameters

status
Type: Autodesk.Revit.DB..::..ElementOnPhaseStatus
The element phase status.

Return Value

The phase status presentation.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | status is invalid for presentation query.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

PhaseFilter Class


SetPhaseStatusPresentation Method

[image]

Revit 2024 API
PhaseFilter..::..SetPhaseStatusPresentation Method
PhaseFilter Class See Also Send Feedback
Sets the phase status presentation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void SetPhaseStatusPresentation(
    ElementOnPhaseStatus status,
    PhaseStatusPresentation presentation
)
Visual Basic
Public Sub SetPhaseStatusPresentation ( _
    status As ElementOnPhaseStatus, _
    presentation As PhaseStatusPresentation _
)
Visual C++
public:
void SetPhaseStatusPresentation(
    ElementOnPhaseStatus status,
    PhaseStatusPresentation presentation
)

Parameters

status
Type: Autodesk.Revit.DB..::..ElementOnPhaseStatus
The element phase status.
presentation
Type: Autodesk.Revit.DB..::..PhaseStatusPresentation
The phase status presentation.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | status is invalid for presentation query.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

PhaseFilter Class


PhaseFilter Properties

[image] [image]

Revit 2024 API
PhaseFilter Properties
PhaseFilter Class See Also Send Feedback

The PhaseFilter type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsDefault | Indicates whether this filter is the default one.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PhaseFilter Class


Parameter Property

[image] [image]

Revit 2024 API
PhaseFilter..::..Parameter Property
PhaseFilter Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

PhaseFilter Class
PhaseFilter Members


PhaseStatusPresentation Enumeration

[image]

Revit 2024 API
PhaseStatusPresentation Enumeration
See Also Send Feedback
An enumerated type listing the options for element display in a phase filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public enum PhaseStatusPresentation
Visual Basic
Public Enumeration PhaseStatusPresentation
Visual C++
public enum class PhaseStatusPresentation

Members

Member name | Description
DontShow | Don't show elements from the given phase status.
ShowByCategory | Show elements from the given phase status by category.
ShowOverriden | Show elements from the given phase status by graphics overrides.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


PlanarFace Members

[image] [image]

Revit 2024 API
PlanarFace Members
PlanarFace Class Methods Properties See Also Send Feedback

The PlanarFace type exposes the following members.

Methods

 | Name | Description
Public method | ComputeDerivatives | Returns the first partial derivatives of the underlying surface at the specified point. (Inherited from Face.)
Public method | ComputeNormal | Returns the normal vector for the face at the given point. (Inherited from Face.)
Public method | ComputeSecondDerivatives | Returns the second partial derivatives of the face at the specified point. (Inherited from Face.)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates and returns the XYZ coordinates of a point at the indicated UV parameterization of the face. (Inherited from Face.)
Public method | GetBoundingBox | Returns the UV bounding box of the face. (Inherited from Face.)
Public method | GetEdgesAsCurveLoops | Returns a list of closed curve loops that correspond to the edge loops of the face. Curves in each curve loop correspond to individual edges. (Inherited from Face.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject.)
Public method | GetRegions | Gets the face regions (created, for example, by the Split Face command) of the face. (Inherited from Face.)
Public method | GetSurface | Returns a copy of this face's surface. (Inherited from Face.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Public method | Intersect(Face) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)
Public method | Intersect(Face, Curve%) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face.)
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional information about the point location. (Inherited from Face.)
Public method | Project | Projects the specified point on the face. (Inherited from Face.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Triangulate()()()() | Returns a triangular mesh approximation to the face. (Inherited from Face.)
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face. (Inherited from Face.)

Properties

 | Name | Description
Public property | Area | The area of this face. (Inherited from Face.)
Public property | EdgeLoops | A collection of edge loops. Each edge loop represents one of the closed boundaries of the face. (Inherited from Face.)
Public property | FaceNormal | Normal of the planar face.
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
Public property | HasRegions | Identifies if the face contains regions (which can be created, for example, by the Split Face command). (Inherited from Face.)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject.)
Public property | IsCyclic | Indicates whether the underlying surface is periodic in the specified parametric direction. (Inherited from Face.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate). (Inherited from Face.)
Public property | MaterialElementId | The element ID of the material from which this face is composed. (Inherited from Face.)
Public property | OrientationMatchesSurfaceOrientation | Returns true if this face's orientation matches the orientation of the face's surface, false if they have opposite orientations. (Inherited from Face.)
Public property | Origin | Origin of the surface.
Public property | Period | The period of the underlying surface in the specified parametric direction. (Inherited from Face.)
Public property | Reference | Returns a stable reference to the face. (Inherited from Face.)
Public property | Visibility | The visibility. (Inherited from GeometryObject.)
Public property | XVector | The X-vector of the planar face.
Public property | YVector | The Y-vector of the planar face.

See Also

PlanarFace Class


Intersect Method

[image] [image]

Revit 2024 API
PlanarFace..::..Intersect Method
PlanarFace Class See Also Send Feedback
Calculates the intersection of the specified curve with this face.

Overload List

 | Name | Description
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Public method | Intersect(Face) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)
Public method | Intersect(Face, Curve%) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face.)

See Also

PlanarFace Class
PlanarFace Members


IsInside Method

[image] [image]

Revit 2024 API
PlanarFace..::..IsInside Method
PlanarFace Class See Also Send Feedback
Indicates whether the specified point is within this face.

Overload List

 | Name | Description
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional information about the point location. (Inherited from Face.)

See Also

PlanarFace Class
PlanarFace Members


Triangulate Method

[image] [image]

Revit 2024 API
PlanarFace..::..Triangulate Method
PlanarFace Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Triangulate()()()() | Returns a triangular mesh approximation to the face. (Inherited from Face.)
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face. (Inherited from Face.)

See Also

PlanarFace Class
PlanarFace Members


PlanarFace Properties

[image] [image]

Revit 2024 API
PlanarFace Properties
PlanarFace Class See Also Send Feedback

The PlanarFace type exposes the following members.

Properties

 | Name | Description
Public property | Area | The area of this face. (Inherited from Face.)
Public property | EdgeLoops | A collection of edge loops. Each edge loop represents one of the closed boundaries of the face. (Inherited from Face.)
Public property | FaceNormal | Normal of the planar face.
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
Public property | HasRegions | Identifies if the face contains regions (which can be created, for example, by the Split Face command). (Inherited from Face.)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject.)
Public property | IsCyclic | Indicates whether the underlying surface is periodic in the specified parametric direction. (Inherited from Face.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate). (Inherited from Face.)
Public property | MaterialElementId | The element ID of the material from which this face is composed. (Inherited from Face.)
Public property | OrientationMatchesSurfaceOrientation | Returns true if this face's orientation matches the orientation of the face's surface, false if they have opposite orientations. (Inherited from Face.)
Public property | Origin | Origin of the surface.
Public property | Period | The period of the underlying surface in the specified parametric direction. (Inherited from Face.)
Public property | Reference | Returns a stable reference to the face. (Inherited from Face.)
Public property | Visibility | The visibility. (Inherited from GeometryObject.)
Public property | XVector | The X-vector of the planar face.
Public property | YVector | The Y-vector of the planar face.

See Also

PlanarFace Class


FaceNormal Property

[image]

Revit 2024 API
PlanarFace..::..FaceNormal Property
PlanarFace Class See Also Send Feedback
Normal of the planar face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ FaceNormal { get; }
Visual Basic
Public ReadOnly Property FaceNormal As XYZ
    Get
Visual C++
public:
property XYZ^ FaceNormal {
    XYZ^ get ();
}

Remarks

This property is the "face normal" vector, and thus should return a vector consistently pointing out of the solid that this face is a boundary for (if it is a part of a solid).

See Also

PlanarFace Class


Origin Property

[image]

Revit 2024 API
PlanarFace..::..Origin Property
PlanarFace Class See Also Send Feedback
Origin of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ Origin { get; }
Visual Basic
Public ReadOnly Property Origin As XYZ
    Get
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
}

See Also

PlanarFace Class


XVector Property

[image]

Revit 2024 API
PlanarFace..::..XVector Property
PlanarFace Class See Also Send Feedback
The X-vector of the planar face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ XVector { get; }
Visual Basic
Public ReadOnly Property XVector As XYZ
    Get
Visual C++
public:
property XYZ^ XVector {
    XYZ^ get ();
}

Remarks

Note that the cross product of X-vector and Y-vector may result in the reverse of the FaceNormal vector depending upon how Revit has structured this particular face.

See Also

PlanarFace Class


YVector Property

[image]

Revit 2024 API
PlanarFace..::..YVector Property
PlanarFace Class See Also Send Feedback
The Y-vector of the planar face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ YVector { get; }
Visual Basic
Public ReadOnly Property YVector As XYZ
    Get
Visual C++
public:
property XYZ^ YVector {
    XYZ^ get ();
}

Remarks

Note that the cross product of X-vector and Y-vector may result in the reverse of the FaceNormal vector depending upon how Revit has structured this particular face.

See Also

PlanarFace Class


PlanCircuit Class

[image]

Revit 2024 API
PlanCircuit Class
Members See Also Send Feedback
An object that represents an enclosed area in a plan view within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class PlanCircuit : APIObject
Visual Basic
Public Class PlanCircuit _
    Inherits APIObject
Visual C++
public ref class PlanCircuit : public APIObject

Remarks

Plan circuits are enclosed regions as seen on a plan view. They are used to determine the boundary extents of rooms based on the placement of walls. In the Autodesk Revit API, you can use plan circuits to create new rooms.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..PlanCircuit

See Also

PlanCircuit Members


PlanCircuit Members

[image] [image]

Revit 2024 API
PlanCircuit Members
PlanCircuit Class Methods Properties See Also Send Feedback

The PlanCircuit type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPointInside | Returns a point inside the circuit.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Area | The enclosed area of the circuit.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsRoomLocated | Reports whether there is a room located in this circuit.
Public property | SideNum | The number of sides in the circuit.

See Also

PlanCircuit Class


PlanCircuit Methods

[image] [image]

Revit 2024 API
PlanCircuit Methods
PlanCircuit Class See Also Send Feedback

The PlanCircuit type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPointInside | Returns a point inside the circuit.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PlanCircuit Class


PlanCircuit Properties

[image] [image]

Revit 2024 API
PlanCircuit Properties
PlanCircuit Class See Also Send Feedback

The PlanCircuit type exposes the following members.

Properties

 | Name | Description
Public property | Area | The enclosed area of the circuit.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsRoomLocated | Reports whether there is a room located in this circuit.
Public property | SideNum | The number of sides in the circuit.

See Also

PlanCircuit Class


Area Property

[image]

Revit 2024 API
PlanCircuit..::..Area Property
PlanCircuit Class See Also Send Feedback
The enclosed area of the circuit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double Area { get; }
Visual Basic
Public ReadOnly Property Area As Double
    Get
Visual C++
public:
property double Area {
    double get ();
}

See Also

PlanCircuit Class


IsRoomLocated Property

[image]

Revit 2024 API
PlanCircuit..::..IsRoomLocated Property
PlanCircuit Class See Also Send Feedback
Reports whether there is a room located in this circuit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsRoomLocated { get; }
Visual Basic
Public ReadOnly Property IsRoomLocated As Boolean
    Get
Visual C++
public:
property bool IsRoomLocated {
    bool get ();
}

Field Value

True if there is a room located in this circuit on the circuit's level, false if there is no room located in this circuit on the circuit's level.

See Also

PlanCircuit Class


SideNum Property

[image]

Revit 2024 API
PlanCircuit..::..SideNum Property
PlanCircuit Class See Also Send Feedback
The number of sides in the circuit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public int SideNum { get; }
Visual Basic
Public ReadOnly Property SideNum As Integer
    Get
Visual C++
public:
property int SideNum {
    int get ();
}

See Also

PlanCircuit Class


PlanCircuitSet Class

[image]

Revit 2024 API
PlanCircuitSet Class
Members See Also Send Feedback
A set that can contain any number of plan circuit objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class PlanCircuitSet : APIObject,
    IEnumerable
Visual Basic
Public Class PlanCircuitSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class PlanCircuitSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..PlanCircuitSet

See Also

PlanCircuitSet Members


PlanCircuitSet Members

[image] [image]

Revit 2024 API
PlanCircuitSet Members
PlanCircuitSet Class Constructors Methods Properties See Also Send Feedback

The PlanCircuitSet type exposes the following members.

Constructors

 | Name | Description
Public method | PlanCircuitSet | Initializes a new instance of the PlanCircuitSet class

Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of an item within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified object from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

PlanCircuitSet Class


PlanCircuitSet Constructor

[image]

Revit 2024 API
PlanCircuitSet Constructor
PlanCircuitSet Class See Also Send Feedback
Initializes a new instance of the PlanCircuitSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public PlanCircuitSet()
Visual Basic
Public Sub New
Visual C++
public:
PlanCircuitSet()

See Also

PlanCircuitSet Class


PlanCircuitSet Methods

[image] [image]

Revit 2024 API
PlanCircuitSet Methods
PlanCircuitSet Class See Also Send Feedback

The PlanCircuitSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of an item within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified object from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PlanCircuitSet Class


Clear Method

[image]

Revit 2024 API
PlanCircuitSet..::..Clear Method
PlanCircuitSet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

PlanCircuitSet Class


Contains Method

[image]

Revit 2024 API
PlanCircuitSet..::..Contains Method
PlanCircuitSet Class See Also Send Feedback
Tests for the existence of an item within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool Contains(
    PlanCircuit item
)
Visual Basic
Public Overridable Function Contains ( _
    item As PlanCircuit _
) As Boolean
Visual C++
public:
virtual bool Contains(
    PlanCircuit^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..PlanCircuit
The item to be searched for.

Return Value

The Contains method returns True if the item is within the set, otherwise False.

See Also

PlanCircuitSet Class


ForwardIterator Method

[image]

Revit 2024 API
PlanCircuitSet..::..ForwardIterator Method
PlanCircuitSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual PlanCircuitSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As PlanCircuitSetIterator
Visual C++
public:
virtual PlanCircuitSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

PlanCircuitSet Class


GetEnumerator Method

[image]

Revit 2024 API
PlanCircuitSet..::..GetEnumerator Method
PlanCircuitSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

PlanCircuitSet Class


Insert Method

[image]

Revit 2024 API
PlanCircuitSet..::..Insert Method
PlanCircuitSet Class See Also Send Feedback
Insert the specified item into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool Insert(
    PlanCircuit item
)
Visual Basic
Public Overridable Function Insert ( _
    item As PlanCircuit _
) As Boolean
Visual C++
public:
virtual bool Insert(
    PlanCircuit^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..PlanCircuit
The item to be inserted into the set.

Return Value

Returns whether the item was inserted into the set.

See Also

PlanCircuitSet Class


ReverseIterator Method

[image]

Revit 2024 API
PlanCircuitSet..::..ReverseIterator Method
PlanCircuitSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual PlanCircuitSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As PlanCircuitSetIterator
Visual C++
public:
virtual PlanCircuitSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

PlanCircuitSet Class


PlanCircuitSet Properties

[image] [image]

Revit 2024 API
PlanCircuitSet Properties
PlanCircuitSet Class See Also Send Feedback

The PlanCircuitSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

PlanCircuitSet Class


IsEmpty Property

[image]

Revit 2024 API
PlanCircuitSet..::..IsEmpty Property
PlanCircuitSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

PlanCircuitSet Class


Size Property

[image]

Revit 2024 API
PlanCircuitSet..::..Size Property
PlanCircuitSet Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

PlanCircuitSet Class


PlanCircuitSetIterator Class

[image]

Revit 2024 API
PlanCircuitSetIterator Class
Members See Also Send Feedback
An iterator to a set of plan circuit objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public abstract class PlanCircuitSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class PlanCircuitSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class PlanCircuitSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..PlanCircuitSetIterator

See Also

PlanCircuitSetIterator Members


PlanCircuitSetIterator Members

[image] [image]

Revit 2024 API
PlanCircuitSetIterator Members
PlanCircuitSetIterator Class Constructors Methods Properties See Also Send Feedback

The PlanCircuitSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | PlanCircuitSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PlanCircuitSetIterator Class


PlanCircuitSetIterator Constructor

[image]

Revit 2024 API
PlanCircuitSetIterator Constructor
PlanCircuitSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public PlanCircuitSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
PlanCircuitSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PlanCircuitSetIterator Class


PlanCircuitSetIterator Methods

[image] [image]

Revit 2024 API
PlanCircuitSetIterator Methods
PlanCircuitSetIterator Class See Also Send Feedback

The PlanCircuitSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PlanCircuitSetIterator Class


MoveNext Method

[image]

Revit 2024 API
PlanCircuitSetIterator..::..MoveNext Method
PlanCircuitSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

PlanCircuitSetIterator Class


Reset Method

[image]

Revit 2024 API
PlanCircuitSetIterator..::..Reset Method
PlanCircuitSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

PlanCircuitSetIterator Class


PlanCircuitSetIterator Properties

[image] [image]

Revit 2024 API
PlanCircuitSetIterator Properties
PlanCircuitSetIterator Class See Also Send Feedback

The PlanCircuitSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PlanCircuitSetIterator Class


Plane Class

[image]

Revit 2024 API
Plane Class
Members Example See Also Send Feedback
A Planar surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public class Plane : Surface
Visual Basic
Public Class Plane _
    Inherits Surface
Visual C++
public ref class Plane : public Surface

Remarks

The parametric equation of the plane is S(u, v) = origin + u*xVec + v*yVec.

Examples

CopyC#
public void GetPlaneInfo(Plane plane)
{
    XYZ origin = plane.Origin;
    XYZ normal = plane.Normal;
    XYZ xVec = plane.XVec;
    XYZ yVec = plane.YVec;

    StringBuilder info = new StringBuilder();
    info.AppendLine("Plane Data:");
    info.AppendLine(string.Format("     Origin: ({0},{1},{2})", origin.X, origin.Y, origin.Z));
    info.AppendLine(string.Format("     Normal: ({0},{1},{2})", normal.X, normal.Y, normal.Z));
    info.AppendLine(string.Format("     XVec: ({0},{1},{2})", xVec.X, xVec.Y, xVec.Z));
    info.AppendLine(string.Format("     YVec: ({0},{1},{2})", yVec.X, yVec.Y, yVec.Z));

    TaskDialog.Show("Revit",info.ToString());
}
CopyVB.NET
Public Sub GetPlaneInfo(plane As Plane)
    Dim origin As XYZ = plane.Origin
    Dim normal As XYZ = plane.Normal
    Dim xVec As XYZ = plane.XVec
    Dim yVec As XYZ = plane.YVec

    Dim info As New StringBuilder()
    info.AppendLine("Plane Data:")
    info.AppendLine(String.Format("     Origin: ({0},{1},{2})", origin.X, origin.Y, origin.Z))
    info.AppendLine(String.Format("     Normal: ({0},{1},{2})", normal.X, normal.Y, normal.Z))
    info.AppendLine(String.Format("     XVec: ({0},{1},{2})", xVec.X, xVec.Y, xVec.Z))
    info.AppendLine(String.Format("     YVec: ({0},{1},{2})", yVec.X, yVec.Y, yVec.Z))

    TaskDialog.Show("Revit", info.ToString())
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Surface
Autodesk.Revit.DB..::..Plane

See Also

Plane Members


Plane Methods

[image] [image]

Revit 2024 API
Plane Methods
Plane Class See Also Send Feedback

The Plane type exposes the following members.

Methods

 | Name | Description
 | Create | Creates a Plane object defined by a local frame of reference.
 | CreateByNormalAndOrigin | Constructs a Plane object from a normal and an origin represented as XYZ objects. Follows the standard conventions for a planar surface. The constructed Plane object will pass through origin and be perpendicular to normal. The X and Y axes of the plane will be defined arbitrarily.
 | CreateByOriginAndBasis | Creates a Plane object defined by the two orthogonal unit vectors and passing through the origin point supplied as arguments.
 | CreateByThreePoints | Creates a Plane object passing through three points supplied as arguments.
Public method | Dispose | (Inherited from Surface.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBoundingBoxUV | Gets the UV bounding box of the surface. (Inherited from Surface.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Project | Project a 3D point orthogonally onto a surface (to find the nearest point). Throws InvalidOperationException if the projection fails. (Inherited from Surface.)
Public method | ProjectWithGuessPoint | Project a 3D point orthogonally onto a surface (to find the nearest point). This method is meant to be used when a good approximate solution for the projection is available. Throws InvalidOperationException if the projection fails. (Inherited from Surface.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Plane Class


Create Method

[image]

Revit 2024 API
Plane..::..Create Method
Plane Class See Also Send Feedback
Creates a Plane object defined by a local frame of reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public static Plane Create(
    Frame frameOfReference
)
Visual Basic
Public Shared Function Create ( _
    frameOfReference As Frame _
) As Plane
Visual C++
public:
static Plane^ Create(
    Frame^ frameOfReference
)

Parameters

frameOfReference
Type: Autodesk.Revit.DB..::..Frame
frameOfReference is an orthonormal frame that defines a local coordinate system for the plane being constructed.
  • Frame.Origin is a point on plane.
  • Frame.BasisZ defines the plane's normal, while Frame.BasisX and Frame.BasisY are orthogonal to the normal.
  • The frame may be either left-handed or right-handed (see Frame.IsRightHanded).

Remarks

The parametric equation of the plane is S(u, v) = Frame.Origin + u*Frame.BasisX + v*Frame.BasisY. Frame.BasisZ defines the plane's normal.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This Frame object may not be used as a local frame of reference.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Plane Class


CreateByNormalAndOrigin Method

[image]

Revit 2024 API
Plane..::..CreateByNormalAndOrigin Method
Plane Class Example See Also Send Feedback
Constructs a Plane object from a normal and an origin represented as XYZ objects. Follows the standard conventions for a planar surface. The constructed Plane object will pass through origin and be perpendicular to normal. The X and Y axes of the plane will be defined arbitrarily.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public static Plane CreateByNormalAndOrigin(
    XYZ normal,
    XYZ origin
)
Visual Basic
Public Shared Function CreateByNormalAndOrigin ( _
    normal As XYZ, _
    origin As XYZ _
) As Plane
Visual C++
public:
static Plane^ CreateByNormalAndOrigin(
    XYZ^ normal,
    XYZ^ origin
)

Parameters

normal
Type: Autodesk.Revit.DB..::..XYZ
Plane normal. Expected to be a valid non-zero length vector. Doesn't need to be a unit vector.
origin
Type: Autodesk.Revit.DB..::..XYZ
Plane origin. Expected to lie within the Revit design limits IsWithinLengthLimits(XYZ).

Remarks

This function does not guarantee a specific parameterization of the created Plane. Use Plane.Create(Frame) to enforce a specific parameterization of the created Plane object.

Examples

CopyC#
 // Create a geometry plane in Revit application
XYZ normal = XYZ.BasisZ;    // use basis of the z-axis (0,0,1) for normal vector
XYZ origin = XYZ.Zero;  // origin is (0,0,0)
Plane geomPlane = Plane.CreateByNormalAndOrigin(normal, origin);
CopyVB.NET
   ' Create a geometry plane in Revit application
   Dim normal As XYZ = XYZ.BasisZ
   ' use basis of the z-axis (0,0,1) for normal vector
   Dim origin As XYZ = XYZ.Zero
   ' origin is (0,0,0)
Dim geomPlane As Plane = Plane.CreateByNormalAndOrigin(normal, origin)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input point lies outside of Revit design limits.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | normal has zero length.

See Also

Plane Class


CreateByOriginAndBasis Method

[image]

Revit 2024 API
Plane..::..CreateByOriginAndBasis Method
Plane Class See Also Send Feedback
Creates a Plane object defined by the two orthogonal unit vectors and passing through the origin point supplied as arguments.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public static Plane CreateByOriginAndBasis(
    XYZ origin,
    XYZ basisX,
    XYZ basisY
)
Visual Basic
Public Shared Function CreateByOriginAndBasis ( _
    origin As XYZ, _
    basisX As XYZ, _
    basisY As XYZ _
) As Plane
Visual C++
public:
static Plane^ CreateByOriginAndBasis(
    XYZ^ origin,
    XYZ^ basisX,
    XYZ^ basisY
)

Parameters

origin
Type: Autodesk.Revit.DB..::..XYZ
Plane origin. Expected to lie within the Revit design limits IsWithinLengthLimits(XYZ).
basisX
Type: Autodesk.Revit.DB..::..XYZ
First of the two unit vectors that define the plane. Must be orthogonal to the second one.
basisY
Type: Autodesk.Revit.DB..::..XYZ
Second of the two unit vectors that define the plane. Must be orthogonal to the first one.

Remarks

The parametric equation of the plane is S(u, v) = origin + u*basisX + v*basisY. The plane's normal is defined as basisX.Cross(basisY).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input point lies outside of Revit design limits.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | basisX is not length 1.0. -or- basisY is not length 1.0.
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | The vectors basisX and basisY are not perpendicular.

See Also

Plane Class


CreateByThreePoints Method

[image]

Revit 2024 API
Plane..::..CreateByThreePoints Method
Plane Class See Also Send Feedback
Creates a Plane object passing through three points supplied as arguments.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public static Plane CreateByThreePoints(
    XYZ point1,
    XYZ point2,
    XYZ point3
)
Visual Basic
Public Shared Function CreateByThreePoints ( _
    point1 As XYZ, _
    point2 As XYZ, _
    point3 As XYZ _
) As Plane
Visual C++
public:
static Plane^ CreateByThreePoints(
    XYZ^ point1,
    XYZ^ point2,
    XYZ^ point3
)

Parameters

point1
Type: Autodesk.Revit.DB..::..XYZ
First of the three points that define a unique plane. The created Plane object will pass through these points.
point2
Type: Autodesk.Revit.DB..::..XYZ
Second of the three points that define a unique plane.
point3
Type: Autodesk.Revit.DB..::..XYZ
Third of the three points that define a unique plane.

Remarks

The points supplied as arguments must fully define a plane: they may not lie on a straight line or be too close to each other. The points must lie within the Revit design limits. This function does not guarantee a specific parameterization of the created Plane. Use Plane.Create(Frame) to enforce a specific parameterization of the created Plane object. All three points are expected to lie within the Revit design limits IsWithinLengthLimits(XYZ).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input point lies outside of Revit design limits.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | Throws if the input points do not define a unique plane. This is typically caused by points being too close to each other, or all three points being on or close to a straight line.

See Also

Plane Class


Plane Properties

[image] [image]

Revit 2024 API
Plane Properties
Plane Class See Also Send Feedback

The Plane type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Surface.)
Public property | Normal | Plane normal.
Public property | OrientationMatchesParametricOrientation | Indicates whether this Surface's orientation is the same as or opposite to its parametric orientation. (Inherited from Surface.)
Public property | Origin | Plane origin.
Public property | XVec | Axis defining the first parametric direction of the plane.
Public property | YVec | Axis defining the second parametric direction of the plane.

See Also

Plane Class


Normal Property

[image]

Revit 2024 API
Plane..::..Normal Property
Plane Class See Also Send Feedback
Plane normal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public XYZ Normal { get; }
Visual Basic
Public ReadOnly Property Normal As XYZ
    Get
Visual C++
public:
property XYZ^ Normal {
    XYZ^ get ();
}

See Also

Plane Class


Origin Property

[image]

Revit 2024 API
Plane..::..Origin Property
Plane Class See Also Send Feedback
Plane origin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public XYZ Origin { get; }
Visual Basic
Public ReadOnly Property Origin As XYZ
    Get
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
}

See Also

Plane Class


XVec Property

[image]

Revit 2024 API
Plane..::..XVec Property
Plane Class See Also Send Feedback
Axis defining the first parametric direction of the plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public XYZ XVec { get; }
Visual Basic
Public ReadOnly Property XVec As XYZ
    Get
Visual C++
public:
property XYZ^ XVec {
    XYZ^ get ();
}

See Also

Plane Class


YVec Property

[image]

Revit 2024 API
Plane..::..YVec Property
Plane Class See Also Send Feedback
Axis defining the second parametric direction of the plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public XYZ YVec { get; }
Visual Basic
Public ReadOnly Property YVec As XYZ
    Get
Visual C++
public:
property XYZ^ YVec {
    XYZ^ get ();
}

See Also

Plane Class


PlanTopology Class

[image]

Revit 2024 API
PlanTopology Class
Members See Also Send Feedback
An object that represents a Plan Topology within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class PlanTopology : APIObject
Visual Basic
Public Class PlanTopology _
    Inherits APIObject
Visual C++
public ref class PlanTopology : public APIObject

Remarks

This object derived from the APIObject base object. It can be used access the properties of a Plan Topology.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..PlanTopology

See Also

PlanTopology Members


PlanTopology Members

[image] [image]

Revit 2024 API
PlanTopology Members
PlanTopology Class Methods Properties See Also Send Feedback

The PlanTopology type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRoomIds | Retrieves room ElementIds of the PlanTopology in the last phase.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Circuits | The Circuits of the PlanTopology.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | The Level of the PlanTopology.
Public property | Phase | The phase of the PlanTopology.

See Also

PlanTopology Class


GetRoomIds Method

[image]

Revit 2024 API
PlanTopology..::..GetRoomIds Method
PlanTopology Class See Also Send Feedback
Retrieves room ElementIds of the PlanTopology in the last phase.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ICollection<ElementId> GetRoomIds()
Visual Basic
Public Function GetRoomIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetRoomIds()

Return Value

The PlanTopology Room ElementIds of the last phase.

Remarks

The Rooms Ids returned are in the phase of PlanTopology and the current design option.

See Also

PlanTopology Class


PlanTopology Properties

[image] [image]

Revit 2024 API
PlanTopology Properties
PlanTopology Class See Also Send Feedback

The PlanTopology type exposes the following members.

Properties

 | Name | Description
Public property | Circuits | The Circuits of the PlanTopology.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | The Level of the PlanTopology.
Public property | Phase | The phase of the PlanTopology.

See Also

PlanTopology Class


Circuits Property

[image]

Revit 2024 API
PlanTopology..::..Circuits Property
PlanTopology Class See Also Send Feedback
The Circuits of the PlanTopology.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public PlanCircuitSet Circuits { get; }
Visual Basic
Public ReadOnly Property Circuits As PlanCircuitSet
    Get
Visual C++
public:
property PlanCircuitSet^ Circuits {
    PlanCircuitSet^ get ();
}

See Also

PlanTopology Class


Phase Property

[image]

Revit 2024 API
PlanTopology..::..Phase Property
PlanTopology Class See Also Send Feedback
The phase of the PlanTopology.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Phase Phase { get; }
Visual Basic
Public ReadOnly Property Phase As Phase
    Get
Visual C++
public:
property Phase^ Phase {
    Phase^ get ();
}

See Also

PlanTopology Class


PlanTopologySet Class

[image]

Revit 2024 API
PlanTopologySet Class
Members See Also Send Feedback
A set that can contain any number of plan topology objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class PlanTopologySet : APIObject,
    IEnumerable
Visual Basic
Public Class PlanTopologySet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class PlanTopologySet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..PlanTopologySet

See Also

PlanTopologySet Members


PlanTopologySet Members

[image] [image]

Revit 2024 API
PlanTopologySet Members
PlanTopologySet Class Constructors Methods Properties See Also Send Feedback

The PlanTopologySet type exposes the following members.

Constructors

 | Name | Description
Public method | PlanTopologySet | Initializes a new instance of the PlanTopologySet class

Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of an item within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified object from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

PlanTopologySet Class


PlanTopologySet Constructor

[image]

Revit 2024 API
PlanTopologySet Constructor
PlanTopologySet Class See Also Send Feedback
Initializes a new instance of the PlanTopologySet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public PlanTopologySet()
Visual Basic
Public Sub New
Visual C++
public:
PlanTopologySet()

See Also

PlanTopologySet Class


PlanTopologySet Methods

[image] [image]

Revit 2024 API
PlanTopologySet Methods
PlanTopologySet Class See Also Send Feedback

The PlanTopologySet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of an item within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified object from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PlanTopologySet Class


Clear Method

[image]

Revit 2024 API
PlanTopologySet..::..Clear Method
PlanTopologySet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

PlanTopologySet Class


Contains Method

[image]

Revit 2024 API
PlanTopologySet..::..Contains Method
PlanTopologySet Class See Also Send Feedback
Tests for the existence of an item within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool Contains(
    PlanTopology item
)
Visual Basic
Public Overridable Function Contains ( _
    item As PlanTopology _
) As Boolean
Visual C++
public:
virtual bool Contains(
    PlanTopology^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..PlanTopology
The item to be searched for.

Return Value

The Contains method returns True if the item is within the set, otherwise False.

See Also

PlanTopologySet Class


ForwardIterator Method

[image]

Revit 2024 API
PlanTopologySet..::..ForwardIterator Method
PlanTopologySet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual PlanTopologySetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As PlanTopologySetIterator
Visual C++
public:
virtual PlanTopologySetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

PlanTopologySet Class


GetEnumerator Method

[image]

Revit 2024 API
PlanTopologySet..::..GetEnumerator Method
PlanTopologySet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

PlanTopologySet Class


PlanTopologySet Properties

[image] [image]

Revit 2024 API
PlanTopologySet Properties
PlanTopologySet Class See Also Send Feedback

The PlanTopologySet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

PlanTopologySet Class


IsEmpty Property

[image]

Revit 2024 API
PlanTopologySet..::..IsEmpty Property
PlanTopologySet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

PlanTopologySet Class


Size Property

[image]

Revit 2024 API
PlanTopologySet..::..Size Property
PlanTopologySet Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

PlanTopologySet Class


PlanTopologySetIterator Class

[image]

Revit 2024 API
PlanTopologySetIterator Class
Members See Also Send Feedback
An iterator to a set of plan topology objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public abstract class PlanTopologySetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class PlanTopologySetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class PlanTopologySetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..PlanTopologySetIterator

See Also

PlanTopologySetIterator Members


PlanTopologySetIterator Members

[image] [image]

Revit 2024 API
PlanTopologySetIterator Members
PlanTopologySetIterator Class Constructors Methods Properties See Also Send Feedback

The PlanTopologySetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | PlanTopologySetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PlanTopologySetIterator Class


PlanTopologySetIterator Constructor

[image]

Revit 2024 API
PlanTopologySetIterator Constructor
PlanTopologySetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public PlanTopologySetIterator()
Visual Basic
Public Sub New
Visual C++
public:
PlanTopologySetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PlanTopologySetIterator Class


MoveNext Method

[image]

Revit 2024 API
PlanTopologySetIterator..::..MoveNext Method
PlanTopologySetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

PlanTopologySetIterator Class


Reset Method

[image]

Revit 2024 API
PlanTopologySetIterator..::..Reset Method
PlanTopologySetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

PlanTopologySetIterator Class


PlanTopologySetIterator Properties

[image] [image]

Revit 2024 API
PlanTopologySetIterator Properties
PlanTopologySetIterator Class See Also Send Feedback

The PlanTopologySetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PlanTopologySetIterator Class


Current Property

[image]

Revit 2024 API
PlanTopologySetIterator..::..Current Property
PlanTopologySetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

PlanTopologySetIterator Class


PlanViewDirection Enumeration

[image]

Revit 2024 API
PlanViewDirection Enumeration
See Also Send Feedback
This enumerated type represents the possible directions for a plan view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public enum PlanViewDirection
Visual Basic
Public Enumeration PlanViewDirection
Visual C++
public enum class PlanViewDirection

Members

Member name | Description
Undefined | View does not use Plan View Direction
Down | Revit looks down onto the plan view
Up | Revit looks up to the plan view

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


PlanViewPlane Enumeration

[image]

Revit 2024 API
PlanViewPlane Enumeration
See Also Send Feedback
Locations where view range offsets can be specified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public enum PlanViewPlane
Visual Basic
Public Enumeration PlanViewPlane
Visual C++
public enum class PlanViewPlane

Members

Member name | Description
CutPlane | Cut Plane
TopClipPlane | Top Clip Plane
BottomClipPlane | Bottom Clip Plane
ViewDepthPlane | View Depth Plane
UnderlayBottom | Underlay Bottom Plane

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


PlanViewRange Class

[image]

Revit 2024 API
PlanViewRange Class
Members Example See Also Send Feedback
This class represents the view range of a plan view or a plan region. It records the element ids of the levels which a plane is relative to and the offset of each plane from that level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public class PlanViewRange : IDisposable
Visual Basic
Public Class PlanViewRange _
    Implements IDisposable
Visual C++
public ref class PlanViewRange : IDisposable

Examples

CopyC#
private ElementId GetViewRangeTopClipPlane(Document doc, View view)
{
    ElementId topClipPlane = ElementId.InvalidElementId;

    if (view is ViewPlan)
    {
        ViewPlan viewPlan = view as ViewPlan;
        PlanViewRange viewRange = viewPlan.GetViewRange();

        topClipPlane = viewRange.GetLevelId(PlanViewPlane.TopClipPlane);
        double dOffset = viewRange.GetOffset(PlanViewPlane.TopClipPlane);

        if (topClipPlane != ElementId.InvalidElementId)
        {
            Element levelAbove = doc.GetElement(topClipPlane);
            TaskDialog.Show(view.Name, "Top Clip Plane: " + levelAbove.Name + "\r\nTop Offset: " + dOffset + " ft");
        }
    }

    return topClipPlane;
}
CopyVB.NET
Private Function GetViewRangeTopClipPlane(doc As Document, view As View) As ElementId
    Dim topClipPlane As ElementId = ElementId.InvalidElementId

    If TypeOf view Is ViewPlan Then
        Dim viewPlan As ViewPlan = TryCast(view, ViewPlan)
        Dim viewRange As PlanViewRange = viewPlan.GetViewRange()

        topClipPlane = viewRange.GetLevelId(PlanViewPlane.TopClipPlane)
        Dim dOffset As Double = viewRange.GetOffset(PlanViewPlane.TopClipPlane)

        If topClipPlane.Value > 0 Then
            Dim levelAbove As Element = doc.GetElement(topClipPlane)
            TaskDialog.Show(view.Name, "Top Clip Plane: " + levelAbove.Name + vbCr & vbLf & "Top Offset: " + dOffset + " ft")
        End If
    End If

    Return topClipPlane
End Function

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..PlanViewRange

See Also

PlanViewRange Members


PlanViewRange Members

[image] [image]

Revit 2024 API
PlanViewRange Members
PlanViewRange Class Methods Properties See Also Send Feedback

The PlanViewRange type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the PlanViewRange
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLevelId | Get the element id of the level for a View Depth plane
Public method | GetOffset | Get the offset value associated with a View Depth plane
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetLevelId | Set the level for a View Depth plane
Public method | SetOffset | Set the offset value associated with a View Depth plane
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
 | Current | View range for the current plane
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
 | LevelAbove | View range for the level above the specified plane
 | LevelBelow | View range for the level below the specified plane
 | Unlimited | View range is unlimited

See Also

PlanViewRange Class


PlanViewRange Methods

[image] [image]

Revit 2024 API
PlanViewRange Methods
PlanViewRange Class See Also Send Feedback

The PlanViewRange type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLevelId | Get the element id of the level for a View Depth plane
Public method | GetOffset | Get the offset value associated with a View Depth plane
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetLevelId | Set the level for a View Depth plane
Public method | SetOffset | Set the offset value associated with a View Depth plane
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PlanViewRange Class


GetLevelId Method

[image]

Revit 2024 API
PlanViewRange..::..GetLevelId Method
PlanViewRange Class See Also Send Feedback
Get the element id of the level for a View Depth plane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ElementId GetLevelId(
    PlanViewPlane planViewPlane
)
Visual Basic
Public Function GetLevelId ( _
    planViewPlane As PlanViewPlane _
) As ElementId
Visual C++
public:
ElementId^ GetLevelId(
    PlanViewPlane planViewPlane
)

Parameters

planViewPlane
Type: Autodesk.Revit.DB..::..PlanViewPlane
The plane whose level will be returned

Return Value

Id of the level

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

PlanViewRange Class


GetOffset Method

[image]

Revit 2024 API
PlanViewRange..::..GetOffset Method
PlanViewRange Class See Also Send Feedback
Get the offset value associated with a View Depth plane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double GetOffset(
    PlanViewPlane planViewPlane
)
Visual Basic
Public Function GetOffset ( _
    planViewPlane As PlanViewPlane _
) As Double
Visual C++
public:
double GetOffset(
    PlanViewPlane planViewPlane
)

Parameters

planViewPlane
Type: Autodesk.Revit.DB..::..PlanViewPlane
View Depth plane

Return Value

Offset value

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

PlanViewRange Class


SetOffset Method

[image]

Revit 2024 API
PlanViewRange..::..SetOffset Method
PlanViewRange Class See Also Send Feedback
Set the offset value associated with a View Depth plane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void SetOffset(
    PlanViewPlane planViewPlane,
    double offset
)
Visual Basic
Public Sub SetOffset ( _
    planViewPlane As PlanViewPlane, _
    offset As Double _
)
Visual C++
public:
void SetOffset(
    PlanViewPlane planViewPlane,
    double offset
)

Parameters

planViewPlane
Type: Autodesk.Revit.DB..::..PlanViewPlane
View Depth plane
offset
Type: System..::..Double
Offset value

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

PlanViewRange Class


PlanViewRange Properties

[image] [image]

Revit 2024 API
PlanViewRange Properties
PlanViewRange Class See Also Send Feedback

The PlanViewRange type exposes the following members.

Properties

 | Name | Description
 | Current | View range for the current plane
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
 | LevelAbove | View range for the level above the specified plane
 | LevelBelow | View range for the level below the specified plane
 | Unlimited | View range is unlimited

See Also

PlanViewRange Class


Current Property

[image]

Revit 2024 API
PlanViewRange..::..Current Property
PlanViewRange Class See Also Send Feedback
View range for the current plane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static ElementId Current { get; }
Visual Basic
Public Shared ReadOnly Property Current As ElementId
    Get
Visual C++
public:
static property ElementId^ Current {
    ElementId^ get ();
}

See Also

PlanViewRange Class


LevelAbove Property

[image]

Revit 2024 API
PlanViewRange..::..LevelAbove Property
PlanViewRange Class See Also Send Feedback
View range for the level above the specified plane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static ElementId LevelAbove { get; }
Visual Basic
Public Shared ReadOnly Property LevelAbove As ElementId
    Get
Visual C++
public:
static property ElementId^ LevelAbove {
    ElementId^ get ();
}

See Also

PlanViewRange Class


LevelBelow Property

[image]

Revit 2024 API
PlanViewRange..::..LevelBelow Property
PlanViewRange Class See Also Send Feedback
View range for the level below the specified plane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static ElementId LevelBelow { get; }
Visual Basic
Public Shared ReadOnly Property LevelBelow As ElementId
    Get
Visual C++
public:
static property ElementId^ LevelBelow {
    ElementId^ get ();
}

See Also

PlanViewRange Class


Unlimited Property

[image]

Revit 2024 API
PlanViewRange..::..Unlimited Property
PlanViewRange Class See Also Send Feedback
View range is unlimited

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static ElementId Unlimited { get; }
Visual Basic
Public Shared ReadOnly Property Unlimited As ElementId
    Get
Visual C++
public:
static property ElementId^ Unlimited {
    ElementId^ get ();
}

See Also

PlanViewRange Class


PlanViewRangeError Enumeration

[image]

Revit 2024 API
PlanViewRangeError Enumeration
See Also Send Feedback
Describes errors in the location of planes in a PlanViewRange object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public enum PlanViewRangeError
Visual Basic
Public Enumeration PlanViewRangeError
Visual C++
public enum class PlanViewRangeError

Members

Member name | Description
TopClipBelowCutPlane | Top clip plane is below the cut plane.
BottomClipAboveCutPlane | Bottom clip plane is above the cut plane.
ViewDepthAboveBottomClip | View depth is above the bottom clip plane.
ViewDepthBelowTopClip | View depth is below the top clip plane.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


Point Class

[image]

Revit 2024 API
Point Class
Members See Also Send Feedback
A 3D point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class Point : GeometryObject
Visual Basic
Public Class Point _
    Inherits GeometryObject
Visual C++
public ref class Point : public GeometryObject

Remarks

The point lies at a given XYZ coordinate location.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeometryObject
Autodesk.Revit.DB..::..Point

See Also

Point Members


Point Methods

[image] [image]

Revit 2024 API
Point Methods
Point Class See Also Send Feedback

The Point type exposes the following members.

Methods

 | Name | Description
 | Create(XYZ) | Creates a point at the given coordinates.
 | Create(XYZ, ElementId) | Creates a point at the given coordinates and assigns it the specified GraphicsStyle.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Point Class


Create Method (XYZ, ElementId)

[image]

Revit 2024 API
Point..::..Create Method (XYZ, ElementId)
Point Class See Also Send Feedback
Creates a point at the given coordinates and assigns it the specified GraphicsStyle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public static Point Create(
    XYZ coord,
    ElementId id
)
Visual Basic
Public Shared Function Create ( _
    coord As XYZ, _
    id As ElementId _
) As Point
Visual C++
public:
static Point^ Create(
    XYZ^ coord,
    ElementId^ id
)

Parameters

coord
Type: Autodesk.Revit.DB..::..XYZ
The coordinates where the point will be created.
id
Type: Autodesk.Revit.DB..::..ElementId
The id of the GraphicsStyle element from which to apply the point properties.

Return Value

A Point object.

See Also

Point Class
Create Overload


Point Properties

[image] [image]

Revit 2024 API
Point Properties
Point Class See Also Send Feedback

The Point type exposes the following members.

Properties

 | Name | Description
Public property | Coord | Returns the coordinates of the point.
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Reference | Returns a stable reference to the point.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Point Class


Coord Property

[image]

Revit 2024 API
Point..::..Coord Property
Point Class See Also Send Feedback
Returns the coordinates of the point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ Coord { get; }
Visual Basic
Public ReadOnly Property Coord As XYZ
    Get
Visual C++
public:
property XYZ^ Coord {
    XYZ^ get ();
}

See Also

Point Class


Reference Property

[image]

Revit 2024 API
Point..::..Reference Property
Point Class See Also Send Feedback
Returns a stable reference to the point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Reference Reference { get; }
Visual Basic
Public ReadOnly Property Reference As Reference
    Get
Visual C++
public:
property Reference^ Reference {
    Reference^ get ();
}

Remarks

This value is if the corresponding geometry object does not permit referencing.

See Also

Point Class


PointCloudColorMode Enumeration

[image]

Revit 2024 API
PointCloudColorMode Enumeration
See Also Send Feedback
Color mode of a point cloud or part of a point cloud

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public enum PointCloudColorMode
Visual Basic
Public Enumeration PointCloudColorMode
Visual C++
public enum class PointCloudColorMode

Members

Member name | Description
NoOverride | Show the actual colors
FixedColor | Show a single color
Elevation | Color by elevation
Intensity | Color by intensity (reflectivity)
Normals | Color by normal vectors

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


PointCloudFoundStatus Enumeration

[image]

Revit 2024 API
PointCloudFoundStatus Enumeration
See Also Send Feedback
Enumerated type representing the possible states related to searching for a point cloud file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public enum PointCloudFoundStatus
Visual Basic
Public Enumeration PointCloudFoundStatus
Visual C++
public enum class PointCloudFoundStatus

Members

Member name | Description
Unknown | Initial state. Loading of the Point Cloud hasn't been attempted.
NotFound | File-based Point Cloud cannot be located and hence can't be loaded.
FoundOK | File-based Point Cloud has been located and can be loaded.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


PointCloudInstance Members

[image] [image]

Revit 2024 API
PointCloudInstance Members
PointCloudInstance Class Methods Properties See Also Send Feedback

The PointCloudInstance type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | ContainsScan | Identifies whether the instance contains a scan.
 | Create | Creates a new instance of a point cloud based on an input point cloud type and transformation.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPoints | Extracts a collection of points based on a filter.
Public method | GetRegions | Returns array of region names.
Public method | GetScanOrigin | Returns the origin point of a scan in model coordinates.
Public method | GetScans | Returns array of scan names.
Public method | GetSelectionFilter | Returns the currently active selection filter for this point cloud.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetTotalTransform | Gets the total transform, which includes the true north transform for instances like import instances. (Inherited from Instance.)
Public method | GetTransform | Gets the transform of the instance. (Inherited from Instance.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasColor | Returns true if at least one scan of the element have color, false otherwise.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetSelectionFilter | Sets active selection filter by cloning of the one passed to it.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FilterAction | The action taken based on the results of the selection filter applied to this point cloud.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SupportsOverrides | Identifies whether the instance can have graphic overrides.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PointCloudInstance Class


PointCloudInstance Methods

[image] [image]

Revit 2024 API
PointCloudInstance Methods
PointCloudInstance Class See Also Send Feedback

The PointCloudInstance type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | ContainsScan | Identifies whether the instance contains a scan.
 | Create | Creates a new instance of a point cloud based on an input point cloud type and transformation.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPoints | Extracts a collection of points based on a filter.
Public method | GetRegions | Returns array of region names.
Public method | GetScanOrigin | Returns the origin point of a scan in model coordinates.
Public method | GetScans | Returns array of scan names.
Public method | GetSelectionFilter | Returns the currently active selection filter for this point cloud.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetTotalTransform | Gets the total transform, which includes the true north transform for instances like import instances. (Inherited from Instance.)
Public method | GetTransform | Gets the transform of the instance. (Inherited from Instance.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasColor | Returns true if at least one scan of the element have color, false otherwise.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetSelectionFilter | Sets active selection filter by cloning of the one passed to it.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PointCloudInstance Class


ContainsScan Method

[image]

Revit 2024 API
PointCloudInstance..::..ContainsScan Method
PointCloudInstance Class See Also Send Feedback
Identifies whether the instance contains a scan.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool ContainsScan(
    string scanName
)
Visual Basic
Public Function ContainsScan ( _
    scanName As String _
) As Boolean
Visual C++
public:
bool ContainsScan(
    String^ scanName
)

Parameters

scanName
Type: System..::..String
Name of the scan.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

PointCloudInstance Class


GetPoints Method

[image]

Revit 2024 API
PointCloudInstance..::..GetPoints Method
PointCloudInstance Class Example See Also Send Feedback
Extracts a collection of points based on a filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public PointCollection GetPoints(
    PointCloudFilter filter,
    double averageDistance,
    int numPoints
)
Visual Basic
Public Function GetPoints ( _
    filter As PointCloudFilter, _
    averageDistance As Double, _
    numPoints As Integer _
) As PointCollection
Visual C++
public:
PointCollection^ GetPoints(
    PointCloudFilter^ filter,
    double averageDistance,
    int numPoints
)

Parameters

filter
Type: Autodesk.Revit.DB.PointClouds..::..PointCloudFilter
The filter to control which points are extracted. The filter should be passed in the coordinates of the Revit model.
averageDistance
Type: System..::..Double
Desired average distance between "adjacent" cloud points (Revit units of length). The smaller the averageDistance the larger number of points will be returned up to the numPoints limit. Specifying this parameter makes actual number of points returned for a given filter independent of the density of coverage produced by the scanner.
numPoints
Type: System..::..Int32
The maximum number of points requested.

Return Value

A collection object containing points that pass the filter, but no more than the maximum number requested.

Remarks

If there are more points in the cloud passing the filter than the number requested in this function, the results may not be consistent if the same call is made again.

Examples

CopyC#
private void GetPointCloudDataByIteration(PointCloudInstance pcInstance, PointCloudFilter pointCloudFilter)
{
    // read points by iteration
    double averageDistance = 0.001;
    int numberOfPoints= 10000;
    // Get points. Number of points is determined by the needs of the client.
    PointCollection points = pcInstance.GetPoints(pointCloudFilter, averageDistance, numberOfPoints);
    foreach (CloudPoint point in points)
    {
        // Process each point
        System.Drawing.Color color = System.Drawing.ColorTranslator.FromWin32(point.Color);
        String pointDescription = String.Format("({0}, {1}, {2}, {3}", point.X, point.Y, point.Z, color.ToString());
    }
}
// read points by pointer
public unsafe void GetPointCloudDataByPointer(PointCloudInstance pcInstance, PointCloudFilter pointCloudFilter)
{
    double averageDistance = 0.001;
    int numOfPoints = 10000;
    // Get points. Number of points is determined by the needs of the client.
    PointCollection points = pcInstance.GetPoints(pointCloudFilter, averageDistance, numOfPoints);
    CloudPoint* pointBuffer = (CloudPoint*)points.GetPointBufferPointer().ToPointer();
    int totalCount = points.Count;
    for (int numberOfPoints = 0; numberOfPoints < totalCount; numberOfPoints++)
    {
        CloudPoint point = *(pointBuffer + numberOfPoints);
        // Process each point
        System.Drawing.Color color = System.Drawing.ColorTranslator.FromWin32(point.Color);
        String pointDescription = String.Format("({0}, {1}, {2}, {3}", point.X, point.Y, point.Z, color.ToString());
    }
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The number of points read must range from 1 to 1000000.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given value for averageDistance must be no more than 30000 feet in absolute value.

See Also

PointCloudInstance Class


GetRegions Method

[image]

Revit 2024 API
PointCloudInstance..::..GetRegions Method
PointCloudInstance Class See Also Send Feedback
Returns array of region names.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public IList<string> GetRegions()
Visual Basic
Public Function GetRegions As IList(Of String)
Visual C++
public:
IList<String^>^ GetRegions()

Return Value

Resulting array of region names.

See Also

PointCloudInstance Class


GetScanOrigin Method

[image]

Revit 2024 API
PointCloudInstance..::..GetScanOrigin Method
PointCloudInstance Class See Also Send Feedback
Returns the origin point of a scan in model coordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public XYZ GetScanOrigin(
    string scanName
)
Visual Basic
Public Function GetScanOrigin ( _
    scanName As String _
) As XYZ
Visual C++
public:
XYZ^ GetScanOrigin(
    String^ scanName
)

Parameters

scanName
Type: System..::..String
Name of the scan.

Return Value

Resulting origin point of the scan.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | PointCloudInstance does not contain scan scanName.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

PointCloudInstance Class


GetScans Method

[image]

Revit 2024 API
PointCloudInstance..::..GetScans Method
PointCloudInstance Class See Also Send Feedback
Returns array of scan names.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public IList<string> GetScans()
Visual Basic
Public Function GetScans As IList(Of String)
Visual C++
public:
IList<String^>^ GetScans()

Return Value

Resulting array of scan names.

See Also

PointCloudInstance Class


GetSelectionFilter Method

[image]

Revit 2024 API
PointCloudInstance..::..GetSelectionFilter Method
PointCloudInstance Class See Also Send Feedback
Returns the currently active selection filter for this point cloud.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public PointCloudFilter GetSelectionFilter()
Visual Basic
Public Function GetSelectionFilter As PointCloudFilter
Visual C++
public:
PointCloudFilter^ GetSelectionFilter()

Return Value

Currently active selection filter or nullNothingnullptra null reference (Nothing in Visual Basic) if none is active.

See Also

PointCloudInstance Class


HasColor Method

[image]

Revit 2024 API
PointCloudInstance..::..HasColor Method
PointCloudInstance Class See Also Send Feedback
Returns true if at least one scan of the element have color, false otherwise.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool HasColor()
Visual Basic
Public Function HasColor As Boolean
Visual C++
public:
bool HasColor()

Return Value

True if at least one scan of the element have color, false otherwise.

See Also

PointCloudInstance Class


SetSelectionFilter Method

[image]

Revit 2024 API
PointCloudInstance..::..SetSelectionFilter Method
PointCloudInstance Class See Also Send Feedback
Sets active selection filter by cloning of the one passed to it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetSelectionFilter(
    PointCloudFilter pFilter
)
Visual Basic
Public Sub SetSelectionFilter ( _
    pFilter As PointCloudFilter _
)
Visual C++
public:
void SetSelectionFilter(
    PointCloudFilter^ pFilter
)

Parameters

pFilter
Type: Autodesk.Revit.DB.PointClouds..::..PointCloudFilter
The filter object to be made active. If nullNothingnullptra null reference (Nothing in Visual Basic) is supplied, the active filter is removed.

Remarks

The filter is provided in the coordinates of the Revit model. If the point cloud is altered (e.g. by moving, rotating, scaling or other modifications) the point cloud filter is not modified and the set of highlighted or isolated points will change. The selection filter is not preserved when the Revit document is saved.

See Also

PointCloudInstance Class


PointCloudInstance Properties

[image] [image]

Revit 2024 API
PointCloudInstance Properties
PointCloudInstance Class See Also Send Feedback

The PointCloudInstance type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FilterAction | The action taken based on the results of the selection filter applied to this point cloud.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SupportsOverrides | Identifies whether the instance can have graphic overrides.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PointCloudInstance Class


FilterAction Property

[image]

Revit 2024 API
PointCloudInstance..::..FilterAction Property
PointCloudInstance Class See Also Send Feedback
The action taken based on the results of the selection filter applied to this point cloud.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public SelectionFilterAction FilterAction { get; set; }
Visual Basic
Public Property FilterAction As SelectionFilterAction
    Get
    Set
Visual C++
public:
property SelectionFilterAction FilterAction {
    SelectionFilterAction get ();
    void set (SelectionFilterAction value);
}

Remarks

If no selection filter is applied, changing this value will have no visible effect. The filter is provided in the coordinates of the Revit model. If the point cloud is altered (e.g. by moving, rotating, scaling or other modifications) the point cloud filter is not modified and the set of highlighted or isolated points will change. The filter action is not preserved when the Revit document is saved.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

PointCloudInstance Class


Parameter Property

[image] [image]

Revit 2024 API
PointCloudInstance..::..Parameter Property
PointCloudInstance Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

PointCloudInstance Class
PointCloudInstance Members


SupportsOverrides Property

[image]

Revit 2024 API
PointCloudInstance..::..SupportsOverrides Property
PointCloudInstance Class See Also Send Feedback
Identifies whether the instance can have graphic overrides.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool SupportsOverrides { get; }
Visual Basic
Public ReadOnly Property SupportsOverrides As Boolean
    Get
Visual C++
public:
property bool SupportsOverrides {
    bool get ();
}

See Also

PointCloudInstance Class


PointCloudType Class

[image]

Revit 2024 API
PointCloudType Class
Members See Also Send Feedback
Represents a type of point cloud loaded into a Revit document. Each PointCloudType maps to a single file or identifier (depending upon the type of Point Cloud Engine which governs it).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public class PointCloudType : ElementType
Visual Basic
Public Class PointCloudType _
    Inherits ElementType
Visual C++
public ref class PointCloudType : public ElementType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..PointCloudType

See Also

PointCloudType Members


PointCloudType Members

[image] [image]

Revit 2024 API
PointCloudType Members
PointCloudType Class Methods Properties See Also Send Feedback

The PointCloudType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create | Creates a new point cloud type for a given point cloud engine.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPath | Gets the path of the link source from which the points are loaded.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetReCapProject | This method provides a direct entry point to get access to an object from the ReCap SDK (ReCapWrapper.RCProject) from Revit. This object represents the point cloud from the RC file path stored in PointCloudType. The ReCap assembly AdskRcManaged.dll will need to be included into code using this method.
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ColorEncoding | The color encoding used by points extracted from instances of this point cloud.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EngineIdentifier | The identifier of the engine responsible for handling of the point cloud.
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | FoundStatus | Shows whether the Point Cloud external file could be found.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | Offset | Returns the offset stored in the point cloud.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Scale | The multiplier applied to the points in all instances of this point cloud.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PointCloudType Class


Create Method

[image]

Revit 2024 API
PointCloudType..::..Create Method
PointCloudType Class Example See Also Send Feedback
Creates a new point cloud type for a given point cloud engine.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static PointCloudType Create(
    Document document,
    string engineIdentifier,
    string typeIdentifier
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    engineIdentifier As String, _
    typeIdentifier As String _
) As PointCloudType
Visual C++
public:
static PointCloudType^ Create(
    Document^ document,
    String^ engineIdentifier,
    String^ typeIdentifier
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which to create the point cloud.
engineIdentifier
Type: System..::..String
The string identifying the engine to be invoked. It should be the file extension or engine identifier registered by the third party.
typeIdentifier
Type: System..::..String
The file name or the identification string for a non-file based engine.

Return Value

The newly created PointCloudType object to be used to create instances of this point cloud.

Remarks

A list of supported engine identifiers and whether they are file-based or not can be obtained from PointCloudEngineRegistry. The method GetSupportedEngines() returns a list of the identifiers registered for engines.

Examples

CopyC#
private PointCloudInstance CreatePointCloud(Document doc)
{
    PointCloudType type = PointCloudType.Create(doc, "rcs", "c:\\32_cafeteria.rcs");
    return (PointCloudInstance.Create(doc, type.Id, Transform.Identity));
}
CopyVB.NET
Private Function CreatePointCloud(doc As Document) As PointCloudInstance
    Dim type As PointCloudType = PointCloudType.Create(doc, "rcs", "c:\32_cafeteria.rcs")
    Return (PointCloudInstance.Create(doc, type.Id, Transform.Identity))
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The engine identifier was not found in the Revit session. -or- document is not a project document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..FileNotFoundException | The external file could not be found or loaded.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Unable to create a point cloud from the third party engine.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

PointCloudType Class


GetPath Method

[image]

Revit 2024 API
PointCloudType..::..GetPath Method
PointCloudType Class See Also Send Feedback
Gets the path of the link source from which the points are loaded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public ModelPath GetPath()
Visual Basic
Public Function GetPath As ModelPath
Visual C++
public:
ModelPath^ GetPath()

Return Value

Returns the file path for a file based point cloud or null for the non-file based point cloud.

See Also

PointCloudType Class


ColorEncoding Property

[image]

Revit 2024 API
PointCloudType..::..ColorEncoding Property
PointCloudType Class See Also Send Feedback
The color encoding used by points extracted from instances of this point cloud.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public PointCloudColorEncoding ColorEncoding { get; }
Visual Basic
Public ReadOnly Property ColorEncoding As PointCloudColorEncoding
    Get
Visual C++
public:
property PointCloudColorEncoding ColorEncoding {
    PointCloudColorEncoding get ();
}

See Also

PointCloudType Class


EngineIdentifier Property

[image]

Revit 2024 API
PointCloudType..::..EngineIdentifier Property
PointCloudType Class See Also Send Feedback
The identifier of the engine responsible for handling of the point cloud.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public string EngineIdentifier { get; }
Visual Basic
Public ReadOnly Property EngineIdentifier As String
    Get
Visual C++
public:
property String^ EngineIdentifier {
    String^ get ();
}

Remarks

The built-in engine provides "rcs" and "rcp" here.

See Also

PointCloudType Class


FoundStatus Property

[image]

Revit 2024 API
PointCloudType..::..FoundStatus Property
PointCloudType Class See Also Send Feedback
Shows whether the Point Cloud external file could be found.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public PointCloudFoundStatus FoundStatus { get; }
Visual Basic
Public ReadOnly Property FoundStatus As PointCloudFoundStatus
    Get
Visual C++
public:
property PointCloudFoundStatus FoundStatus {
    PointCloudFoundStatus get ();
}

See Also

PointCloudType Class


Scale Property

[image]

Revit 2024 API
PointCloudType..::..Scale Property
PointCloudType Class See Also Send Feedback
The multiplier applied to the points in all instances of this point cloud.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public double Scale { get; set; }
Visual Basic
Public Property Scale As Double
    Get
    Set
Visual C++
public:
property double Scale {
    double get ();
    void set (double value);
}

Remarks

Scale converts the units in which the coordinates of individual points of the point cloud are interpreted.

See Also

PointCloudType Class


PointElementReference Members

[image] [image]

Revit 2024 API
PointElementReference Members
PointElementReference Class Methods See Also Send Feedback

The PointElementReference type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PointElementReference Class


PointElementReference Methods

[image] [image]

Revit 2024 API
PointElementReference Methods
PointElementReference Class See Also Send Feedback

The PointElementReference type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PointElementReference Class


PointLocationOnCurve Members

[image] [image]

Revit 2024 API
PointLocationOnCurve Members
PointLocationOnCurve Class Constructors Methods Properties See Also Send Feedback

The PointLocationOnCurve type exposes the following members.

Constructors

 | Name | Description
Public method | PointLocationOnCurve | Constructs a new instance of a class, with given or default values, to place a point on a curve.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the PointLocationOnCurve
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MeasureFrom | The location on the curve from which the measurement is taken.
Public property | MeasurementType | The measurement type.
Public property | MeasurementValue | The measurement value.

See Also

PointLocationOnCurve Class


PointLocationOnCurve Constructor

[image]

Revit 2024 API
PointLocationOnCurve Constructor
PointLocationOnCurve Class See Also Send Feedback
Constructs a new instance of a class, with given or default values, to place a point on a curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public PointLocationOnCurve(
    PointOnCurveMeasurementType measType,
    double measValue,
    PointOnCurveMeasureFrom measFrom
)
Visual Basic
Public Sub New ( _
    measType As PointOnCurveMeasurementType, _
    measValue As Double, _
    measFrom As PointOnCurveMeasureFrom _
)
Visual C++
public:
PointLocationOnCurve(
    PointOnCurveMeasurementType measType,
    double measValue,
    PointOnCurveMeasureFrom measFrom
)

Parameters

measType
Type: Autodesk.Revit.DB..::..PointOnCurveMeasurementType
measValue
Type: System..::..Double
measFrom
Type: Autodesk.Revit.DB..::..PointOnCurveMeasureFrom

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

PointLocationOnCurve Class


Dispose Method

[image]

Revit 2024 API
PointLocationOnCurve..::..Dispose Method
PointLocationOnCurve Class See Also Send Feedback
Releases all resources used by the PointLocationOnCurve

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

PointLocationOnCurve Class


MeasureFrom Property

[image]

Revit 2024 API
PointLocationOnCurve..::..MeasureFrom Property
PointLocationOnCurve Class See Also Send Feedback
The location on the curve from which the measurement is taken.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public PointOnCurveMeasureFrom MeasureFrom { get; set; }
Visual Basic
Public Property MeasureFrom As PointOnCurveMeasureFrom
    Get
    Set
Visual C++
public:
property PointOnCurveMeasureFrom MeasureFrom {
    PointOnCurveMeasureFrom get ();
    void set (PointOnCurveMeasureFrom value);
}

Remarks

The measure-from is not checked until this class is assigned for a particular reference point on a particular curve. At that time, the measure-from must be valid for the curve.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

PointLocationOnCurve Class


MeasurementValue Property

[image]

Revit 2024 API
PointLocationOnCurve..::..MeasurementValue Property
PointLocationOnCurve Class See Also Send Feedback
The measurement value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public double MeasurementValue { get; set; }
Visual Basic
Public Property MeasurementValue As Double
    Get
    Set
Visual C++
public:
property double MeasurementValue {
    double get ();
    void set (double value);
}

Remarks

The measurement value is not checked until this class is assigned for a particular reference point on a particular curve. At that time, the measurement value must match the expected range for the curve for the given measurement type and measure-from.

See Also

PointLocationOnCurve Class


PointNode Class

[image]

Revit 2024 API
PointNode Class
Members See Also Send Feedback
An output node that represents a 3D point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public class PointNode : ModelCurveNode
Visual Basic
Public Class PointNode _
    Inherits ModelCurveNode
Visual C++
public ref class PointNode : public ModelCurveNode

Remarks

See also: [!:Autodesk::Revit::DB::IModelExportContext::OnPoint].

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..RenderNode
Autodesk.Revit.DB..::..ModelCurveNode
Autodesk.Revit.DB..::..PointNode

See Also

PointNode Members


PointNode Members

[image] [image]

Revit 2024 API
PointNode Members
PointNode Class Methods Properties See Also Send Feedback

The PointNode type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RenderNode.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPoint | Returns the point object corresponding to the node.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode.)
Public property | LineProperties | Access to the line (pen) properties of the curve being drawn (Inherited from ModelCurveNode.)
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode.)

See Also

PointNode Class


PointNode Methods

[image] [image]

Revit 2024 API
PointNode Methods
PointNode Class See Also Send Feedback

The PointNode type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RenderNode.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPoint | Returns the point object corresponding to the node.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PointNode Class


GetPoint Method

[image]

Revit 2024 API
PointNode..::..GetPoint Method
PointNode Class See Also Send Feedback
Returns the point object corresponding to the node.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public Point GetPoint()
Visual Basic
Public Function GetPoint As Point
Visual C++
public:
Point^ GetPoint()

Return Value

The point instance.

See Also

PointNode Class


PointOnCurveMeasureFrom Enumeration

[image]

Revit 2024 API
PointOnCurveMeasureFrom Enumeration
See Also Send Feedback
Point on curve MeasureFrom - It tells from which end of the host curve the point location is measured.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Since: 2012

Syntax

C#
public enum PointOnCurveMeasureFrom
Visual Basic
Public Enumeration PointOnCurveMeasureFrom
Visual C++
public enum class PointOnCurveMeasureFrom

Members

Member name | Description
Beginning | Beginning of the host curve.
End | End of the host curve.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


PointOnCurveMeasurementType Enumeration

[image]

Revit 2024 API
PointOnCurveMeasurementType Enumeration
See Also Send Feedback
Point on curve measurement type Defines the types of measurements that may be used when placing a point at a designated distance along a curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Since: 2012

Syntax

C#
public enum PointOnCurveMeasurementType
Visual Basic
Public Enumeration PointOnCurveMeasurementType
Visual C++
public enum class PointOnCurveMeasurementType

Members

Member name | Description
NonNormalizedCurveParameter | The non-normalized (actual) curve parameter value of the given point. The curve parameter is the defining parameter of the curve. It is also known as the raw/natural parameter.
NormalizedCurveParameter | Normalized value of the curve parameter. It is defined for curves with user defined bounds or natural bounds, start and end. It is measured as the fraction of the curve parameter (t) over the total parametric range = (t-start) / (end-start). Its value varies between 0 and 1. 0 corresponds to the start and 1 corresponds to the end.
SegmentLength | Length of the curve segment between the start point and the given point.
NormalizedSegmentLength | Normalized segment length. It is defined for curves with user defined bounds or natural bounds. It is measured as the fraction of the segment length over the total length of the curve. Its value varies between 0 and 1. 0 corresponds to the start and 1 corresponds to the end.
ChordLength | Chord length = length of the chord (line segment) joining the start point and the given point. Also known as 3D distance
Angle | Angle - defined only for arc and circle. It is the angle subtended at the center by the portion of the curve from the star to the given point.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


PointOnEdge Class

[image]

Revit 2024 API
PointOnEdge Class
Members See Also Send Feedback
Define a ReferencePoint relative to a referenceable edge or curve on another element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class PointOnEdge : PointElementReference
Visual Basic
Public Class PointOnEdge _
    Inherits PointElementReference
Visual C++
public ref class PointOnEdge : public PointElementReference

Remarks

The ReferencePoint's X basis vector is constrained to the tangent vector to the curve. The Y and Z vectors are free to rotate around the curve.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..PointElementReference
Autodesk.Revit.DB..::..PointOnEdge

See Also

PointOnEdge Members


PointOnEdge Members

[image] [image]

Revit 2024 API
PointOnEdge Members
PointOnEdge Class Methods Properties See Also Send Feedback

The PointOnEdge type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEdgeReference | Get a copy of the edge or curve reference.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetEdgeReference | Change the edge or curve reference.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | LocationOnCurve | The point location on curve.

See Also

PointOnEdge Class


PointOnEdge Methods

[image] [image]

Revit 2024 API
PointOnEdge Methods
PointOnEdge Class See Also Send Feedback

The PointOnEdge type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEdgeReference | Get a copy of the edge or curve reference.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetEdgeReference | Change the edge or curve reference.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PointOnEdge Class


PointOnEdge Properties

[image] [image]

Revit 2024 API
PointOnEdge Properties
PointOnEdge Class See Also Send Feedback

The PointOnEdge type exposes the following members.

Properties

 | Name | Description
Public property | LocationOnCurve | The point location on curve.

See Also

PointOnEdge Class


LocationOnCurve Property

[image]

Revit 2024 API
PointOnEdge..::..LocationOnCurve Property
PointOnEdge Class See Also Send Feedback
The point location on curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public PointLocationOnCurve LocationOnCurve { get; }
Visual Basic
Public ReadOnly Property LocationOnCurve As PointLocationOnCurve
    Get
Visual C++
public:
property PointLocationOnCurve^ LocationOnCurve {
    PointLocationOnCurve^ get ();
}

See Also

PointOnEdge Class


PointOnEdgeEdgeIntersection Class

[image]

Revit 2024 API
PointOnEdgeEdgeIntersection Class
Members See Also Send Feedback
Define a ReferencePoint at the intersection of two referenceable lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class PointOnEdgeEdgeIntersection : PointElementReference
Visual Basic
Public Class PointOnEdgeEdgeIntersection _
    Inherits PointElementReference
Visual C++
public ref class PointOnEdgeEdgeIntersection : public PointElementReference

Remarks

The ReferencePoint is actually placed on the first line (Edge1) at the closest point to the second line (Edge2). Its X basis vector is constrained to be parallel to the first line.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..PointElementReference
Autodesk.Revit.DB..::..PointOnEdgeEdgeIntersection

See Also

PointOnEdgeEdgeIntersection Members


PointOnEdgeEdgeIntersection Members

[image] [image]

Revit 2024 API
PointOnEdgeEdgeIntersection Members
PointOnEdgeEdgeIntersection Class Methods See Also Send Feedback

The PointOnEdgeEdgeIntersection type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEdgeReference1 | Get a copy of the first edge or curve reference.
Public method | GetEdgeReference2 | Get a copy of the second edge or curve reference.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetEdgeReference1 | Change the first edge or curve reference.
Public method | SetEdgeReference2 | Change the second edge or curve reference.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PointOnEdgeEdgeIntersection Class


SetEdgeReference1 Method

[image]

Revit 2024 API
PointOnEdgeEdgeIntersection..::..SetEdgeReference1 Method
PointOnEdgeEdgeIntersection Class See Also Send Feedback
Change the first edge or curve reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetEdgeReference1(
    Reference edgeReference
)
Visual Basic
Public Sub SetEdgeReference1 ( _
    edgeReference As Reference _
)
Visual C++
public:
void SetEdgeReference1(
    Reference^ edgeReference
)

Parameters

edgeReference
Type: Autodesk.Revit.DB..::..Reference

Remarks

The referenced element may be any model element, including FamilyInstance, FormElement, or NonPlanarSketch. The reference must be of type ElementReferenceType.REFERENCE_TYPE_LINEAR, and it must correspond to a straight line.

See Also

PointOnEdgeEdgeIntersection Class


SetEdgeReference2 Method

[image]

Revit 2024 API
PointOnEdgeEdgeIntersection..::..SetEdgeReference2 Method
PointOnEdgeEdgeIntersection Class See Also Send Feedback
Change the second edge or curve reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetEdgeReference2(
    Reference edgeReference
)
Visual Basic
Public Sub SetEdgeReference2 ( _
    edgeReference As Reference _
)
Visual C++
public:
void SetEdgeReference2(
    Reference^ edgeReference
)

Parameters

edgeReference
Type: Autodesk.Revit.DB..::..Reference

Remarks

The referenced element may be any model element, including FamilyInstance, FormElement, or NonPlanarSketch. The reference must be of type ElementReferenceType.REFERENCE_TYPE_LINEAR, and it must correspond to a straight line.

See Also

PointOnEdgeEdgeIntersection Class


PointOnEdgeFaceIntersection Class

[image]

Revit 2024 API
PointOnEdgeFaceIntersection Class
Members See Also Send Feedback
Define a ReferencePoint at the intersection of a referenceable edge or curve and a referenceable face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class PointOnEdgeFaceIntersection : PointElementReference
Visual Basic
Public Class PointOnEdgeFaceIntersection _
    Inherits PointElementReference
Visual C++
public ref class PointOnEdgeFaceIntersection : public PointElementReference

Remarks

The ReferencePoint's orientation is partially constrained either to the edge (in the manner of PointOnEdge) or to the face (in the manner of PointOnFace).

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..PointElementReference
Autodesk.Revit.DB..::..PointOnEdgeFaceIntersection

See Also

PointOnEdgeFaceIntersection Members


PointOnEdgeFaceIntersection Members

[image] [image]

Revit 2024 API
PointOnEdgeFaceIntersection Members
PointOnEdgeFaceIntersection Class Methods Properties See Also Send Feedback

The PointOnEdgeFaceIntersection type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEdgeReference | Get a copy of the edge or curve reference.
Public method | GetFaceReference | Get a copy of the face reference.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetEdgeReference | Change the edge or curve reference.
Public method | SetFaceReference | Change the face reference.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | OrientWithEdge | Whether to orient the ReferencePoint to the edge or the face.

See Also

PointOnEdgeFaceIntersection Class


PointOnEdgeFaceIntersection Methods

[image] [image]

Revit 2024 API
PointOnEdgeFaceIntersection Methods
PointOnEdgeFaceIntersection Class See Also Send Feedback

The PointOnEdgeFaceIntersection type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEdgeReference | Get a copy of the edge or curve reference.
Public method | GetFaceReference | Get a copy of the face reference.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetEdgeReference | Change the edge or curve reference.
Public method | SetFaceReference | Change the face reference.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PointOnEdgeFaceIntersection Class


GetEdgeReference Method

[image]

Revit 2024 API
PointOnEdgeFaceIntersection..::..GetEdgeReference Method
PointOnEdgeFaceIntersection Class See Also Send Feedback
Get a copy of the edge or curve reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Reference GetEdgeReference()
Visual Basic
Public Function GetEdgeReference As Reference
Visual C++
public:
Reference^ GetEdgeReference()

See Also

PointOnEdgeFaceIntersection Class


GetFaceReference Method

[image]

Revit 2024 API
PointOnEdgeFaceIntersection..::..GetFaceReference Method
PointOnEdgeFaceIntersection Class See Also Send Feedback
Get a copy of the face reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Reference GetFaceReference()
Visual Basic
Public Function GetFaceReference As Reference
Visual C++
public:
Reference^ GetFaceReference()

See Also

PointOnEdgeFaceIntersection Class


SetEdgeReference Method

[image]

Revit 2024 API
PointOnEdgeFaceIntersection..::..SetEdgeReference Method
PointOnEdgeFaceIntersection Class See Also Send Feedback
Change the edge or curve reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetEdgeReference(
    Reference edgeReference
)
Visual Basic
Public Sub SetEdgeReference ( _
    edgeReference As Reference _
)
Visual C++
public:
void SetEdgeReference(
    Reference^ edgeReference
)

Parameters

edgeReference
Type: Autodesk.Revit.DB..::..Reference

Remarks

The referenced element may be any model element, including FamilyInstance, FormElement, or CurveElement. The reference must be of type ElementReferenceType.REFERENCE_TYPE_LINEAR.

See Also

PointOnEdgeFaceIntersection Class


SetFaceReference Method

[image]

Revit 2024 API
PointOnEdgeFaceIntersection..::..SetFaceReference Method
PointOnEdgeFaceIntersection Class See Also Send Feedback
Change the face reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetFaceReference(
    Reference reference
)
Visual Basic
Public Sub SetFaceReference ( _
    reference As Reference _
)
Visual C++
public:
void SetFaceReference(
    Reference^ reference
)

Parameters

reference
Type: Autodesk.Revit.DB..::..Reference

Remarks

The referenced element may be any model element, including FamilyInstance or FormElement. The reference must be of type ElementReferenceType.REFERENCE_TYPE_SURFACE, and the surface must be of type Plane. The Reference's UVPoint property is ignored.

See Also

PointOnEdgeFaceIntersection Class


PointOnEdgeFaceIntersection Properties

[image] [image]

Revit 2024 API
PointOnEdgeFaceIntersection Properties
PointOnEdgeFaceIntersection Class See Also Send Feedback

The PointOnEdgeFaceIntersection type exposes the following members.

Properties

 | Name | Description
Public property | OrientWithEdge | Whether to orient the ReferencePoint to the edge or the face.

See Also

PointOnEdgeFaceIntersection Class


OrientWithEdge Property

[image]

Revit 2024 API
PointOnEdgeFaceIntersection..::..OrientWithEdge Property
PointOnEdgeFaceIntersection Class See Also Send Feedback
Whether to orient the ReferencePoint to the edge or the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool OrientWithEdge { get; set; }
Visual Basic
Public Property OrientWithEdge As Boolean
    Get
    Set
Visual C++
public:
property bool OrientWithEdge {
    bool get ();
    void set (bool value);
}

Remarks

If true, the X basis vector will be parallel to the edge. If false, the X and Y basis vectors will be parallel to the face.

See Also

PointOnEdgeFaceIntersection Class


PointOnFace Class

[image]

Revit 2024 API
PointOnFace Class
Members See Also Send Feedback
Define a ReferencePoint relative to a Face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class PointOnFace : PointElementReference
Visual Basic
Public Class PointOnFace _
    Inherits PointElementReference
Visual C++
public ref class PointOnFace : public PointElementReference

Remarks

A ReferencePoint on a Face has its X and Y basis vectors parallel to the Face, but is free to rotate around its Z basis vector. It must lie on the face (unlike PointOnPlane).

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..PointElementReference
Autodesk.Revit.DB..::..PointOnFace

See Also

PointOnFace Members


PointOnFace Members

[image] [image]

Revit 2024 API
PointOnFace Members
PointOnFace Class Methods Properties See Also Send Feedback

The PointOnFace type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetFaceReference | Get a copy of the face reference.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetFaceReference | Change the face reference.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | UV | The location of the point in the surface's coordinate system.

See Also

PointOnFace Class


PointOnFace Methods

[image] [image]

Revit 2024 API
PointOnFace Methods
PointOnFace Class See Also Send Feedback

The PointOnFace type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetFaceReference | Get a copy of the face reference.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetFaceReference | Change the face reference.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PointOnFace Class


GetFaceReference Method

[image]

Revit 2024 API
PointOnFace..::..GetFaceReference Method
PointOnFace Class See Also Send Feedback
Get a copy of the face reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Reference GetFaceReference()
Visual Basic
Public Function GetFaceReference As Reference
Visual C++
public:
Reference^ GetFaceReference()

See Also

PointOnFace Class


PointOnFace Properties

[image] [image]

Revit 2024 API
PointOnFace Properties
PointOnFace Class See Also Send Feedback

The PointOnFace type exposes the following members.

Properties

 | Name | Description
Public property | UV | The location of the point in the surface's coordinate system.

See Also

PointOnFace Class


UV Property

[image]

Revit 2024 API
PointOnFace..::..UV Property
PointOnFace Class See Also Send Feedback
The location of the point in the surface's coordinate system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public UV UV { get; set; }
Visual Basic
Public Property UV As UV
    Get
    Set
Visual C++
public:
property UV^ UV {
    UV^ get ();
    void set (UV^ value);
}

See Also

PointOnFace Class


PointOnPlane Members

[image] [image]

Revit 2024 API
PointOnPlane Members
PointOnPlane Class Methods Properties See Also Send Feedback

The PointOnPlane type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPlaneReference | The geometric plane reference.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValidPlaneReference | Check whether a geometry reference corresponds to a referenceable plane.
 | NewPointOnPlane | Construct a PointOnPlane given a reference and a location in space.
Public method | SetPlaneReference | Change the geometric plane reference.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Offset | Signed offset from the plane.
Public property | Position | The coordinates of the point (or its projection) on the plane.
Public property | XVec | The X-coordinate vector of the point, in the plane's coordinate system.

See Also

PointOnPlane Class


PointOnPlane Methods

[image] [image]

Revit 2024 API
PointOnPlane Methods
PointOnPlane Class See Also Send Feedback

The PointOnPlane type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPlaneReference | The geometric plane reference.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValidPlaneReference | Check whether a geometry reference corresponds to a referenceable plane.
 | NewPointOnPlane | Construct a PointOnPlane given a reference and a location in space.
Public method | SetPlaneReference | Change the geometric plane reference.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PointOnPlane Class


GetPlaneReference Method

[image]

Revit 2024 API
PointOnPlane..::..GetPlaneReference Method
PointOnPlane Class See Also Send Feedback
The geometric plane reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Reference GetPlaneReference()
Visual Basic
Public Function GetPlaneReference As Reference
Visual C++
public:
Reference^ GetPlaneReference()

Return Value

A copy of the reference stored in the PointOnPlane object.

See Also

PointOnPlane Class


IsValidPlaneReference Method

[image]

Revit 2024 API
PointOnPlane..::..IsValidPlaneReference Method
PointOnPlane Class See Also Send Feedback
Check whether a geometry reference corresponds to a referenceable plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static bool IsValidPlaneReference(
    Document doc,
    Reference planeReference
)
Visual Basic
Public Shared Function IsValidPlaneReference ( _
    doc As Document, _
    planeReference As Reference _
) As Boolean
Visual C++
public:
static bool IsValidPlaneReference(
    Document^ doc,
    Reference^ planeReference
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
planeReference
Type: Autodesk.Revit.DB..::..Reference

Remarks

Valid plane references include: planar faces of solids; the PlaneReference properties of Level and SketchPlane; the Reference property of ReferencePlane.

See Also

PointOnPlane Class


NewPointOnPlane Method

[image]

Revit 2024 API
PointOnPlane..::..NewPointOnPlane Method
PointOnPlane Class See Also Send Feedback
Construct a PointOnPlane given a reference and a location in space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static PointOnPlane NewPointOnPlane(
    Document doc,
    Reference planeReference,
    XYZ position,
    XYZ xvec
)
Visual Basic
Public Shared Function NewPointOnPlane ( _
    doc As Document, _
    planeReference As Reference, _
    position As XYZ, _
    xvec As XYZ _
) As PointOnPlane
Visual C++
public:
static PointOnPlane^ NewPointOnPlane(
    Document^ doc,
    Reference^ planeReference,
    XYZ^ position,
    XYZ^ xvec
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The document containing the plane reference.
planeReference
Type: Autodesk.Revit.DB..::..Reference
position
Type: Autodesk.Revit.DB..::..XYZ
A 3-dimensional position.
xvec
Type: Autodesk.Revit.DB..::..XYZ
The direction of the point's X-coordinate vector in the plane's coordinates. Optional; default value is the X-coordinate vector of the plane.

Return Value

A new PointOnPlane object with 2-dimensional Position, XVec, and Offset properties set to match the given 3-dimensional arguments.

See Also

PointOnPlane Class


SetPlaneReference Method

[image]

Revit 2024 API
PointOnPlane..::..SetPlaneReference Method
PointOnPlane Class See Also Send Feedback
Change the geometric plane reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetPlaneReference(
    Reference planeReference
)
Visual Basic
Public Sub SetPlaneReference ( _
    planeReference As Reference _
)
Visual C++
public:
void SetPlaneReference(
    Reference^ planeReference
)

Parameters

planeReference
Type: Autodesk.Revit.DB..::..Reference
A reference to some plane in the document. (Note: the reference must satisfy IsValidPlaneReference(), but this is not checked until this PointOnPlane object is assigned to a ReferencePoint.)

See Also

PointOnPlane Class


PointOnPlane Properties

[image] [image]

Revit 2024 API
PointOnPlane Properties
PointOnPlane Class See Also Send Feedback

The PointOnPlane type exposes the following members.

Properties

 | Name | Description
Public property | Offset | Signed offset from the plane.
Public property | Position | The coordinates of the point (or its projection) on the plane.
Public property | XVec | The X-coordinate vector of the point, in the plane's coordinate system.

See Also

PointOnPlane Class


Position Property

[image]

Revit 2024 API
PointOnPlane..::..Position Property
PointOnPlane Class See Also Send Feedback
The coordinates of the point (or its projection) on the plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public UV Position { get; set; }
Visual Basic
Public Property Position As UV
    Get
    Set
Visual C++
public:
property UV^ Position {
    UV^ get ();
    void set (UV^ value);
}

See Also

PointOnPlane Class


XVec Property

[image]

Revit 2024 API
PointOnPlane..::..XVec Property
PointOnPlane Class See Also Send Feedback
The X-coordinate vector of the point, in the plane's coordinate system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public UV XVec { get; set; }
Visual Basic
Public Property XVec As UV
    Get
    Set
Visual C++
public:
property UV^ XVec {
    UV^ get ();
    void set (UV^ value);
}

See Also

PointOnPlane Class


PointRelativeToPoint Members

[image] [image]

Revit 2024 API
PointRelativeToPoint Members
PointRelativeToPoint Class Methods See Also Send Feedback

The PointRelativeToPoint type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHostPointReference | Get a copy of the host point reference.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetHostPointReference | Change the host point reference.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PointRelativeToPoint Class


PointRelativeToPoint Methods

[image] [image]

Revit 2024 API
PointRelativeToPoint Methods
PointRelativeToPoint Class See Also Send Feedback

The PointRelativeToPoint type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHostPointReference | Get a copy of the host point reference.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetHostPointReference | Change the host point reference.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PointRelativeToPoint Class


GetHostPointReference Method

[image]

Revit 2024 API
PointRelativeToPoint..::..GetHostPointReference Method
PointRelativeToPoint Class See Also Send Feedback
Get a copy of the host point reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public Reference GetHostPointReference()
Visual Basic
Public Function GetHostPointReference As Reference
Visual C++
public:
Reference^ GetHostPointReference()

See Also

PointRelativeToPoint Class


SetHostPointReference Method

[image]

Revit 2024 API
PointRelativeToPoint..::..SetHostPointReference Method
PointRelativeToPoint Class See Also Send Feedback
Change the host point reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void SetHostPointReference(
    Reference hostPointReference
)
Visual Basic
Public Sub SetHostPointReference ( _
    hostPointReference As Reference _
)
Visual C++
public:
void SetHostPointReference(
    Reference^ hostPointReference
)

Parameters

hostPointReference
Type: Autodesk.Revit.DB..::..Reference

Remarks

Allowed references are to another Autodesk.Revit.DB.ReferencePoint element or to an Autodesk.Revit.DB.Point.

See Also

PointRelativeToPoint Class


PolyLine Members

[image] [image]

Revit 2024 API
PolyLine Members
PolyLine Class Methods Properties See Also Send Feedback

The PolyLine type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns a copy of this polyline.
 | Create | Creates a polyline with coordinate points provided.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates a parameter on the polyline.
Public method | GetCoordinate | Gets the coordinate point of the specified index.
Public method | GetCoordinates | Gets the coordinate points of the polyline.
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject.)
Public method | GetOutline | Gets the outline of the polyline.
Public method | GetTransformed | Gets the copy of the polyline which is applied the specified transformation.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | NumberOfCoordinates | Gets the number of the coordinate points.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

PolyLine Class


PolyLine Methods

[image] [image]

Revit 2024 API
PolyLine Methods
PolyLine Class See Also Send Feedback

The PolyLine type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns a copy of this polyline.
 | Create | Creates a polyline with coordinate points provided.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates a parameter on the polyline.
Public method | GetCoordinate | Gets the coordinate point of the specified index.
Public method | GetCoordinates | Gets the coordinate points of the polyline.
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject.)
Public method | GetOutline | Gets the outline of the polyline.
Public method | GetTransformed | Gets the copy of the polyline which is applied the specified transformation.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PolyLine Class


Clone Method

[image]

Revit 2024 API
PolyLine..::..Clone Method
PolyLine Class See Also Send Feedback
Returns a copy of this polyline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public PolyLine Clone()
Visual Basic
Public Function Clone As PolyLine
Visual C++
public:
PolyLine^ Clone()

See Also

PolyLine Class


Create Method

[image]

Revit 2024 API
PolyLine..::..Create Method
PolyLine Class See Also Send Feedback
Creates a polyline with coordinate points provided.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static PolyLine Create(
    IList<XYZ> coordinates
)
Visual Basic
Public Shared Function Create ( _
    coordinates As IList(Of XYZ) _
) As PolyLine
Visual C++
public:
static PolyLine^ Create(
    IList<XYZ^>^ coordinates
)

Parameters

coordinates
Type: System.Collections.Generic..::..IList<(Of <(<' XYZ >)>)>

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the count of coordinates is less than 2.

See Also

PolyLine Class


Evaluate Method

[image]

Revit 2024 API
PolyLine..::..Evaluate Method
PolyLine Class See Also Send Feedback
Evaluates a parameter on the polyline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ Evaluate(
    double param
)
Visual Basic
Public Function Evaluate ( _
    param As Double _
) As XYZ
Visual C++
public:
XYZ^ Evaluate(
    double param
)

Parameters

param
Type: System..::..Double
The parameter to be evaluated. It is expected to be in [0,1] interval mapped to the bounds of the whole polyline.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the param value is not between 0.0 and 1.0.

See Also

PolyLine Class


GetCoordinate Method

[image]

Revit 2024 API
PolyLine..::..GetCoordinate Method
PolyLine Class See Also Send Feedback
Gets the coordinate point of the specified index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ GetCoordinate(
    int index
)
Visual Basic
Public Function GetCoordinate ( _
    index As Integer _
) As XYZ
Visual C++
public:
XYZ^ GetCoordinate(
    int index
)

Parameters

index
Type: System..::..Int32
The index of the coordinates.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the index value is out of range.

See Also

PolyLine Class


GetOutline Method

[image]

Revit 2024 API
PolyLine..::..GetOutline Method
PolyLine Class See Also Send Feedback
Gets the outline of the polyline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Outline GetOutline()
Visual Basic
Public Function GetOutline As Outline
Visual C++
public:
Outline^ GetOutline()

See Also

PolyLine Class


GetTransformed Method

[image]

Revit 2024 API
PolyLine..::..GetTransformed Method
PolyLine Class See Also Send Feedback
Gets the copy of the polyline which is applied the specified transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public PolyLine GetTransformed(
    Transform transform
)
Visual Basic
Public Function GetTransformed ( _
    transform As Transform _
) As PolyLine
Visual C++
public:
PolyLine^ GetTransformed(
    Transform^ transform
)

Parameters

transform
Type: Autodesk.Revit.DB..::..Transform

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the transform is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

PolyLine Class


NumberOfCoordinates Property

[image]

Revit 2024 API
PolyLine..::..NumberOfCoordinates Property
PolyLine Class See Also Send Feedback
Gets the number of the coordinate points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public int NumberOfCoordinates { get; }
Visual Basic
Public ReadOnly Property NumberOfCoordinates As Integer
    Get
Visual C++
public:
property int NumberOfCoordinates {
    int get ();
}

See Also

PolyLine Class


PolylineNode Members

[image] [image]

Revit 2024 API
PolylineNode Members
PolylineNode Class Methods Properties See Also Send Feedback

The PolylineNode type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RenderNode.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPolyline | Returns the polyline object corresponding to the node.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode.)
Public property | LineProperties | Access to the line (pen) properties of the curve being drawn (Inherited from ModelCurveNode.)
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode.)

See Also

PolylineNode Class


PolylineNode Methods

[image] [image]

Revit 2024 API
PolylineNode Methods
PolylineNode Class See Also Send Feedback

The PolylineNode type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RenderNode.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPolyline | Returns the polyline object corresponding to the node.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PolylineNode Class


GetPolyline Method

[image]

Revit 2024 API
PolylineNode..::..GetPolyline Method
PolylineNode Class See Also Send Feedback
Returns the polyline object corresponding to the node.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public PolyLine GetPolyline()
Visual Basic
Public Function GetPolyline As PolyLine
Visual C++
public:
PolyLine^ GetPolyline()

Return Value

The polyline instance.

See Also

PolylineNode Class


PolylineSegments Methods

[image] [image]

Revit 2024 API
PolylineSegments Methods
PolylineSegments Class See Also Send Feedback

The PolylineSegments type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVertices | Returns an array of vertices of the polyline segments.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PolylineSegments Class


Dispose Method

[image]

Revit 2024 API
PolylineSegments..::..Dispose Method
PolylineSegments Class See Also Send Feedback
Releases all resources used by the PolylineSegments

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

PolylineSegments Class


PolylineSegments Properties

[image] [image]

Revit 2024 API
PolylineSegments Properties
PolylineSegments Class See Also Send Feedback

The PolylineSegments type exposes the following members.

Properties

 | Name | Description
Public property | EndLocalParameter | Local parameter associated with the end point.
Public property | EndParameter | Parameter associated with the end point.
Public property | IsFilled | Indicates whether the area enclosed by the polyline is to be filled or not.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LineProperties | Access to the line (pen) properties of the polyline
Public property | StartLocalParameter | Local parameter associated with the start point.
Public property | StartParameter | Parameter associated with the start point.

See Also

PolylineSegments Class


IsFilled Property

[image]

Revit 2024 API
PolylineSegments..::..IsFilled Property
PolylineSegments Class See Also Send Feedback
Indicates whether the area enclosed by the polyline is to be filled or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool IsFilled { get; }
Visual Basic
Public ReadOnly Property IsFilled As Boolean
    Get
Visual C++
public:
property bool IsFilled {
    bool get ();
}

See Also

PolylineSegments Class


IsValidObject Property

[image]

Revit 2024 API
PolylineSegments..::..IsValidObject Property
PolylineSegments Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

PolylineSegments Class


StartLocalParameter Property

[image]

Revit 2024 API
PolylineSegments..::..StartLocalParameter Property
PolylineSegments Class See Also Send Feedback
Local parameter associated with the start point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public double StartLocalParameter { get; }
Visual Basic
Public ReadOnly Property StartLocalParameter As Double
    Get
Visual C++
public:
property double StartLocalParameter {
    double get ();
}

See Also

PolylineSegments Class


StartParameter Property

[image]

Revit 2024 API
PolylineSegments..::..StartParameter Property
PolylineSegments Class See Also Send Feedback
Parameter associated with the start point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public double StartParameter { get; }
Visual Basic
Public ReadOnly Property StartParameter As Double
    Get
Visual C++
public:
property double StartParameter {
    double get ();
}

See Also

PolylineSegments Class


PolymeshFacet Class

[image]

Revit 2024 API
PolymeshFacet Class
Members See Also Send Feedback
A class representing one triangular piece - a facet - in a polymesh topology.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class PolymeshFacet
Visual Basic
Public Class PolymeshFacet
Visual C++
public ref class PolymeshFacet

Remarks

It can also be used to create TopographySurface. Each facet is defined by indices of three vertices of the polymesh.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..PolymeshFacet

See Also

PolymeshFacet Members


PolymeshFacet Members

[image] [image]

Revit 2024 API
PolymeshFacet Members
PolymeshFacet Class Constructors Methods Properties See Also Send Feedback

The PolymeshFacet type exposes the following members.

Constructors

 | Name | Description
Public method | PolymeshFacet | Creates a PolymeshFacet with the supplied vertices.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVertices | Returns the three vertices that define this facet
Public method | ToString | Returns formatted string showing (V1, V2, V3) with values formatted as regular integers (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | V1 | The first vertex of the facet
Public property | V2 | The second vertex of the facet
Public property | V3 | The third vertex of the facet

See Also

PolymeshFacet Class


PolymeshFacet Constructor

[image]

Revit 2024 API
PolymeshFacet Constructor
PolymeshFacet Class See Also Send Feedback
Creates a PolymeshFacet with the supplied vertices.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019.2

Syntax

C#
public PolymeshFacet(
    int v1,
    int v2,
    int v3
)
Visual Basic
Public Sub New ( _
    v1 As Integer, _
    v2 As Integer, _
    v3 As Integer _
)
Visual C++
public:
PolymeshFacet(
    int v1,
    int v2,
    int v3
)

Parameters

v1
Type: System..::..Int32
The first vertex.
v2
Type: System..::..Int32
The second vertex.
v3
Type: System..::..Int32
The third vertex.

See Also

PolymeshFacet Class


ToString Method

[image]

Revit 2024 API
PolymeshFacet..::..ToString Method
PolymeshFacet Class See Also Send Feedback
Returns formatted string showing (V1, V2, V3) with values formatted as regular integers

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

PolymeshFacet Class


PolymeshFacet Properties

[image] [image]

Revit 2024 API
PolymeshFacet Properties
PolymeshFacet Class See Also Send Feedback

The PolymeshFacet type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | V1 | The first vertex of the facet
Public property | V2 | The second vertex of the facet
Public property | V3 | The third vertex of the facet

See Also

PolymeshFacet Class


IsValidObject Property

[image]

Revit 2024 API
PolymeshFacet..::..IsValidObject Property
PolymeshFacet Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

This property is always True for a polymesh facet.

See Also

PolymeshFacet Class


V2 Property

[image]

Revit 2024 API
PolymeshFacet..::..V2 Property
PolymeshFacet Class See Also Send Feedback
The second vertex of the facet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public int V2 { get; }
Visual Basic
Public ReadOnly Property V2 As Integer
    Get
Visual C++
public:
property int V2 {
    int get ();
}

Field Value

An index of a vertex of a polymesh.

See Also

PolymeshFacet Class


V3 Property

[image]

Revit 2024 API
PolymeshFacet..::..V3 Property
PolymeshFacet Class See Also Send Feedback
The third vertex of the facet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public int V3 { get; }
Visual Basic
Public ReadOnly Property V3 As Integer
    Get
Visual C++
public:
property int V3 {
    int get ();
}

Field Value

An index of a vertex of a polymesh.

See Also

PolymeshFacet Class


PolymeshTopology Members

[image] [image]

Revit 2024 API
PolymeshTopology Members
PolymeshTopology Class Methods Properties See Also Send Feedback

The PolymeshTopology type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the PolymeshTopology
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetFacet | Returns a definition of one facet
Public method | GetFacets | Returns a definitions of all facets of the polymesh
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNormal | Returns a normal vector at the given index
Public method | GetNormals | Returns all normals assigned to the polymesh
Public method | GetPoint | Returns one point at the given index.
Public method | GetPoints | Returns all points of the polymesh.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUV | Returns one UV coordinate at the given index.
Public method | GetUVs | Returns all UV coordinates assigned to the polymesh
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DistributionOfNormals | Indicates the distribution of normal vectors along the tessellated polymesh surface.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | NumberOfFacets | The number of facet in the polymesh.
Public property | NumberOfNormals | The number of normals associated with the polymesh
Public property | NumberOfPoints | The number of points in the polymesh
Public property | NumberOfUVs | The number of UV coordinates available for the polymesh.

See Also

PolymeshTopology Class


PolymeshTopology Methods

[image] [image]

Revit 2024 API
PolymeshTopology Methods
PolymeshTopology Class See Also Send Feedback

The PolymeshTopology type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetFacet | Returns a definition of one facet
Public method | GetFacets | Returns a definitions of all facets of the polymesh
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNormal | Returns a normal vector at the given index
Public method | GetNormals | Returns all normals assigned to the polymesh
Public method | GetPoint | Returns one point at the given index.
Public method | GetPoints | Returns all points of the polymesh.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUV | Returns one UV coordinate at the given index.
Public method | GetUVs | Returns all UV coordinates assigned to the polymesh
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PolymeshTopology Class


Dispose Method

[image]

Revit 2024 API
PolymeshTopology..::..Dispose Method
PolymeshTopology Class See Also Send Feedback
Releases all resources used by the PolymeshTopology

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

PolymeshTopology Class


GetFacet Method

[image]

Revit 2024 API
PolymeshTopology..::..GetFacet Method
PolymeshTopology Class See Also Send Feedback
Returns a definition of one facet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public PolymeshFacet GetFacet(
    int idx
)
Visual Basic
Public Function GetFacet ( _
    idx As Integer _
) As PolymeshFacet
Visual C++
public:
PolymeshFacet^ GetFacet(
    int idx
)

Parameters

idx
Type: System..::..Int32
A zero-based index of the facet

Return Value

An instance of PolymeshFacet that represents one facet defined by 3 vertices of the polymesh.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value is not a valid index of a facet of the polymesh. A valid value is not negative and is smaller than the number of facets in the polymesh.

See Also

PolymeshTopology Class


GetFacets Method

[image]

Revit 2024 API
PolymeshTopology..::..GetFacets Method
PolymeshTopology Class See Also Send Feedback
Returns a definitions of all facets of the polymesh

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public IList<PolymeshFacet> GetFacets()
Visual Basic
Public Function GetFacets As IList(Of PolymeshFacet)
Visual C++
public:
IList<PolymeshFacet^>^ GetFacets()

Return Value

An array of PolymeshFacet instances, each of which represents one facet defined by 3 vertices of the polymesh.

See Also

PolymeshTopology Class


GetNormal Method

[image]

Revit 2024 API
PolymeshTopology..::..GetNormal Method
PolymeshTopology Class See Also Send Feedback
Returns a normal vector at the given index

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public XYZ GetNormal(
    int idx
)
Visual Basic
Public Function GetNormal ( _
    idx As Integer _
) As XYZ
Visual C++
public:
XYZ^ GetNormal(
    int idx
)

Parameters

idx
Type: System..::..Int32
A zero-based index

Return Value

XYZ value representing a normal vector

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value is not a valid index of a normal of the polymesh. A valid valure is not negative and is smaller than the number of normals in the polymesh.

See Also

PolymeshTopology Class


GetNormals Method

[image]

Revit 2024 API
PolymeshTopology..::..GetNormals Method
PolymeshTopology Class See Also Send Feedback
Returns all normals assigned to the polymesh

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public IList<XYZ> GetNormals()
Visual Basic
Public Function GetNormals As IList(Of XYZ)
Visual C++
public:
IList<XYZ^>^ GetNormals()

Return Value

An array of XYZ values, each representing a normal vector

See Also

PolymeshTopology Class


GetPoints Method

[image]

Revit 2024 API
PolymeshTopology..::..GetPoints Method
PolymeshTopology Class See Also Send Feedback
Returns all points of the polymesh.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public IList<XYZ> GetPoints()
Visual Basic
Public Function GetPoints As IList(Of XYZ)
Visual C++
public:
IList<XYZ^>^ GetPoints()

Return Value

An array of XYZ coordinates

See Also

PolymeshTopology Class


GetUVs Method

[image]

Revit 2024 API
PolymeshTopology..::..GetUVs Method
PolymeshTopology Class See Also Send Feedback
Returns all UV coordinates assigned to the polymesh

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public IList<UV> GetUVs()
Visual Basic
Public Function GetUVs As IList(Of UV)
Visual C++
public:
IList<UV^>^ GetUVs()

Return Value

An array of UV coordinates

See Also

PolymeshTopology Class


PolymeshTopology Properties

[image] [image]

Revit 2024 API
PolymeshTopology Properties
PolymeshTopology Class See Also Send Feedback

The PolymeshTopology type exposes the following members.

Properties

 | Name | Description
Public property | DistributionOfNormals | Indicates the distribution of normal vectors along the tessellated polymesh surface.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | NumberOfFacets | The number of facet in the polymesh.
Public property | NumberOfNormals | The number of normals associated with the polymesh
Public property | NumberOfPoints | The number of points in the polymesh
Public property | NumberOfUVs | The number of UV coordinates available for the polymesh.

See Also

PolymeshTopology Class


DistributionOfNormals Property

[image]

Revit 2024 API
PolymeshTopology..::..DistributionOfNormals Property
PolymeshTopology Class See Also Send Feedback
Indicates the distribution of normal vectors along the tessellated polymesh surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public DistributionOfNormals DistributionOfNormals { get; }
Visual Basic
Public ReadOnly Property DistributionOfNormals As DistributionOfNormals
    Get
Visual C++
public:
property DistributionOfNormals DistributionOfNormals {
    DistributionOfNormals get ();
}

See Also

PolymeshTopology Class


IsValidObject Property

[image]

Revit 2024 API
PolymeshTopology..::..IsValidObject Property
PolymeshTopology Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

PolymeshTopology Class


NumberOfFacets Property

[image]

Revit 2024 API
PolymeshTopology..::..NumberOfFacets Property
PolymeshTopology Class See Also Send Feedback
The number of facet in the polymesh.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public int NumberOfFacets { get; }
Visual Basic
Public ReadOnly Property NumberOfFacets As Integer
    Get
Visual C++
public:
property int NumberOfFacets {
    int get ();
}

See Also

PolymeshTopology Class


NumberOfNormals Property

[image]

Revit 2024 API
PolymeshTopology..::..NumberOfNormals Property
PolymeshTopology Class See Also Send Feedback
The number of normals associated with the polymesh

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public int NumberOfNormals { get; }
Visual Basic
Public ReadOnly Property NumberOfNormals As Integer
    Get
Visual C++
public:
property int NumberOfNormals {
    int get ();
}

Remarks

The number is always equal either to '1', or the number of facets, or the number of points. The DistributionOfNormals property indicates how normals are distributed along the polymesh. If there is only one normal available, it applies to the entire mesh. Curved surfaces have normal vectors associated with either every facet or every point/vertex of the tessellated polymesh.

See Also

PolymeshTopology Class


NumberOfPoints Property

[image]

Revit 2024 API
PolymeshTopology..::..NumberOfPoints Property
PolymeshTopology Class See Also Send Feedback
The number of points in the polymesh

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public int NumberOfPoints { get; }
Visual Basic
Public ReadOnly Property NumberOfPoints As Integer
    Get
Visual C++
public:
property int NumberOfPoints {
    int get ();
}

See Also

PolymeshTopology Class


NumberOfUVs Property

[image]

Revit 2024 API
PolymeshTopology..::..NumberOfUVs Property
PolymeshTopology Class See Also Send Feedback
The number of UV coordinates available for the polymesh.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public int NumberOfUVs { get; }
Visual Basic
Public ReadOnly Property NumberOfUVs As Integer
    Get
Visual C++
public:
property int NumberOfUVs {
    int get ();
}

Remarks

Normally, the number of UV coordinates corresponds to the number of points in a polymesh, but a polymesh does not have to have UVs assigned, in which case the value of this property is 0.

See Also

PolymeshTopology Class


PreferredJunctionType Enumeration

[image]

Revit 2024 API
PreferredJunctionType Enumeration
See Also Send Feedback
Enumerated type representing the possible options for the preferred junction for a routine preference rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Since: 2013

Syntax

C#
public enum PreferredJunctionType
Visual Basic
Public Enumeration PreferredJunctionType
Visual C++
public enum class PreferredJunctionType

Members

Member name | Description
Tee | Tee junction type.
Tap | Tap junction type.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


PrimaryDesignOptionMemberFilter Class

[image]

Revit 2024 API
PrimaryDesignOptionMemberFilter Class
Members Example See Also Send Feedback
A filter used to find elements contained in any primary design option of any design option set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class PrimaryDesignOptionMemberFilter : ElementSlowFilter
Visual Basic
Public Class PrimaryDesignOptionMemberFilter _
    Inherits ElementSlowFilter
Visual C++
public ref class PrimaryDesignOptionMemberFilter : public ElementSlowFilter

Remarks

This filter will only pass elements in a primary design option. It will not pass elements in the main model not associated to any design option. This filter is a slow filter. Slow filters require that the Element be obtained and expanded in memory first. Thus it is preferable to couple this filter with at least one ElementQuickFilter, which should minimize the number of Elements that are expanded.

Examples

CopyC#
// Create a PrimaryDesignOptionMember filter to find all Walls contained within all primary design options
PrimaryDesignOptionMemberFilter filter = new PrimaryDesignOptionMemberFilter();

// Apply the filter to the elements in the active document
// Use shortcut command OfClass() to only find wall instances
FilteredElementCollector collector = new FilteredElementCollector(document);
ICollection<Element> wallsOfPrimaryOpt = collector.OfClass(typeof(Wall)).WherePasses(filter).ToElements();

// Find walls not contained within primary design options: Use inverted filter to match walls
PrimaryDesignOptionMemberFilter notPrimaryOptFilter = new PrimaryDesignOptionMemberFilter(true); // inverted filter
collector = new FilteredElementCollector(document);
ICollection<Element> notPrimaryDesignOptFounds =
    collector.OfClass(typeof(Wall)).WherePasses(notPrimaryOptFilter).ToElements();
CopyVB.NET
' Create a PrimaryDesignOptionMember filter to find all Walls contained within all primary design options
Dim filter As New PrimaryDesignOptionMemberFilter()

' Apply the filter to the elements in the active document
' Use shortcut command OfClass() to only find wall instances
Dim collector As New FilteredElementCollector(document)
Dim wallsOfPrimaryOpt As ICollection(Of Element) = collector.OfClass(GetType(Wall)).WherePasses(filter).ToElements()

' Find walls not contained within primary design options: Use inverted filter to match walls
Dim notPrimaryOptFilter As New PrimaryDesignOptionMemberFilter(True)
' inverted filter
collector = New FilteredElementCollector(document)
Dim notPrimaryDesignOptFounds As ICollection(Of Element) = collector.OfClass(GetType(Wall)).WherePasses(notPrimaryOptFilter).ToElements()

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementSlowFilter
Autodesk.Revit.DB..::..PrimaryDesignOptionMemberFilter

See Also

PrimaryDesignOptionMemberFilter Members


PrimaryDesignOptionMemberFilter Members

[image] [image]

Revit 2024 API
PrimaryDesignOptionMemberFilter Members
PrimaryDesignOptionMemberFilter Class Constructors Methods Properties See Also Send Feedback

The PrimaryDesignOptionMemberFilter type exposes the following members.

Constructors

 | Name | Description
Public method | PrimaryDesignOptionMemberFilter()()()() | Constructs a new instance of a filter to match elements contained in any primary design option of any design option set.
Public method | PrimaryDesignOptionMemberFilter(Boolean) | Constructs a new instance of a filter to match elements contained in any primary design option of any design option set, with the option to invert the filter and find elements not contained in any primary design option of any design option set.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)

See Also

PrimaryDesignOptionMemberFilter Class


PrimaryDesignOptionMemberFilter Constructor

[image] [image]

Revit 2024 API
PrimaryDesignOptionMemberFilter Constructor
PrimaryDesignOptionMemberFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PrimaryDesignOptionMemberFilter()()()() | Constructs a new instance of a filter to match elements contained in any primary design option of any design option set.
Public method | PrimaryDesignOptionMemberFilter(Boolean) | Constructs a new instance of a filter to match elements contained in any primary design option of any design option set, with the option to invert the filter and find elements not contained in any primary design option of any design option set.

See Also

PrimaryDesignOptionMemberFilter Class
PrimaryDesignOptionMemberFilter Members


PrimaryDesignOptionMemberFilter Constructor

[image]

Revit 2024 API
PrimaryDesignOptionMemberFilter Constructor
PrimaryDesignOptionMemberFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements contained in any primary design option of any design option set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public PrimaryDesignOptionMemberFilter()
Visual Basic
Public Sub New
Visual C++
public:
PrimaryDesignOptionMemberFilter()

See Also

PrimaryDesignOptionMemberFilter Class
PrimaryDesignOptionMemberFilter Overload


PrimaryDesignOptionMemberFilter Constructor (Boolean)

[image]

Revit 2024 API
PrimaryDesignOptionMemberFilter Constructor (Boolean)
PrimaryDesignOptionMemberFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements contained in any primary design option of any design option set, with the option to invert the filter and find elements not contained in any primary design option of any design option set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public PrimaryDesignOptionMemberFilter(
    bool inverted
)
Visual Basic
Public Sub New ( _
    inverted As Boolean _
)
Visual C++
public:
PrimaryDesignOptionMemberFilter(
    bool inverted
)

Parameters

inverted
Type: System..::..Boolean
True if the filter should match all elements which are not contained within a particular design option.

See Also

PrimaryDesignOptionMemberFilter Class
PrimaryDesignOptionMemberFilter Overload


PrimaryDesignOptionMemberFilter Methods

[image] [image]

Revit 2024 API
PrimaryDesignOptionMemberFilter Methods
PrimaryDesignOptionMemberFilter Class See Also Send Feedback

The PrimaryDesignOptionMemberFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PrimaryDesignOptionMemberFilter Class


PrimaryDesignOptionMemberFilter Properties

[image] [image]

Revit 2024 API
PrimaryDesignOptionMemberFilter Properties
PrimaryDesignOptionMemberFilter Class See Also Send Feedback

The PrimaryDesignOptionMemberFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)

See Also

PrimaryDesignOptionMemberFilter Class


PrimarySizeCriterion Class

[image]

Revit 2024 API
PrimarySizeCriterion Class
Members See Also Send Feedback
This class contains a size criterion for a RoutingPreferenceRule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public class PrimarySizeCriterion : RoutingCriterionBase
Visual Basic
Public Class PrimarySizeCriterion _
    Inherits RoutingCriterionBase
Visual C++
public ref class PrimarySizeCriterion : public RoutingCriterionBase

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..RoutingCriterionBase
Autodesk.Revit.DB..::..PrimarySizeCriterion

See Also

PrimarySizeCriterion Members


PrimarySizeCriterion Members

[image] [image]

Revit 2024 API
PrimarySizeCriterion Members
PrimarySizeCriterion Class Constructors Methods Properties See Also Send Feedback

The PrimarySizeCriterion type exposes the following members.

Constructors

 | Name | Description
Public method | PrimarySizeCriterion | Constructs a PrimarySizeCriterion with a minimum and maximum size.

Methods

 | Name | Description
 | All | Creates a criterion with a range of all sizes.
Public method | Dispose | (Inherited from RoutingCriterionBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Verify if two criteria are the same. (Inherited from RoutingCriterionBase.)
 | None | Creates a criterion with a range of no sizes.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RoutingCriterionBase.)
Public property | MaximumSize | The maximum size of this criterion.
Public property | MinimumSize | The minimum size of this criterion.

See Also

PrimarySizeCriterion Class


PrimarySizeCriterion Constructor

[image]

Revit 2024 API
PrimarySizeCriterion Constructor
PrimarySizeCriterion Class See Also Send Feedback
Constructs a PrimarySizeCriterion with a minimum and maximum size.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public PrimarySizeCriterion(
    double minimumSize,
    double maximumSize
)
Visual Basic
Public Sub New ( _
    minimumSize As Double, _
    maximumSize As Double _
)
Visual C++
public:
PrimarySizeCriterion(
    double minimumSize,
    double maximumSize
)

Parameters

minimumSize
Type: System..::..Double
maximumSize
Type: System..::..Double

See Also

PrimarySizeCriterion Class


PrimarySizeCriterion Methods

[image] [image]

Revit 2024 API
PrimarySizeCriterion Methods
PrimarySizeCriterion Class See Also Send Feedback

The PrimarySizeCriterion type exposes the following members.

Methods

 | Name | Description
 | All | Creates a criterion with a range of all sizes.
Public method | Dispose | (Inherited from RoutingCriterionBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Verify if two criteria are the same. (Inherited from RoutingCriterionBase.)
 | None | Creates a criterion with a range of no sizes.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PrimarySizeCriterion Class


All Method

[image]

Revit 2024 API
PrimarySizeCriterion..::..All Method
PrimarySizeCriterion Class See Also Send Feedback
Creates a criterion with a range of all sizes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static PrimarySizeCriterion All()
Visual Basic
Public Shared Function All As PrimarySizeCriterion
Visual C++
public:
static PrimarySizeCriterion^ All()

Return Value

The new criterion.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

PrimarySizeCriterion Class


MinimumSize Property

[image]

Revit 2024 API
PrimarySizeCriterion..::..MinimumSize Property
PrimarySizeCriterion Class See Also Send Feedback
The minimum size of this criterion.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double MinimumSize { get; set; }
Visual Basic
Public Property MinimumSize As Double
    Get
    Set
Visual C++
public:
property double MinimumSize {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

PrimarySizeCriterion Class


PrinterResolution Enumeration

[image]

Revit 2024 API
PrinterResolution Enumeration
See Also Send Feedback
Controls the resolution level in rendering settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public enum PrinterResolution
Visual Basic
Public Enumeration PrinterResolution
Visual C++
public enum class PrinterResolution

Members

Member name | Description
Low | Low printer resolution.
Medium | Medium printer resolution.
High | High printer resolution.
VeryHigh | VeryHigh printer resolution.

Remarks

It is applicable only when using printer resolution. The suitable resolution value for each resolution level is decided by default in Revit.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


PrintManager Class

[image]

Revit 2024 API
PrintManager Class
Members Example See Also Send Feedback
The PrintManager object is used to configure the global print settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class PrintManager : APIObject
Visual Basic
Public Class PrintManager _
    Inherits APIObject
Visual C++
public ref class PrintManager : public APIObject

Remarks

Global print settings include PrintToFile, CombinedFile, PrintToFileName, PrintRange, CopyNumber, PrintOrderReverse, Collate. Once PrintManager is acquired from a document, changes of its global print setting properties are not automatically applied toward the global print setting. Should the local setting be used, the user needs to call the Apply method. If the user calls SubmitPrint methods, not only that printing will use the current state of properties of the (local) print manager, but the setting will also be applied to the global settings.

Examples

CopyC#
private void CreateAndPrintViewSet(Document document, ViewSet viewSet)
{
    PrintManager printManager = document.PrintManager;
    printManager.PrintRange = PrintRange.Select;
    ViewSheetSetting viewSheetSetting = printManager.ViewSheetSetting;
    viewSheetSetting.CurrentViewSheetSet.Views = viewSet;
    viewSheetSetting.SaveAs("MyViewSet");
    printManager.CombinedFile = true;
    printManager.SubmitPrint();
}
CopyVB.NET
Private Sub CreateAndPrintViewSet(document As Document, viewSet As ViewSet)
    Dim printManager As PrintManager = document.PrintManager
    printManager.PrintRange = PrintRange.[Select]
    Dim viewSheetSetting As ViewSheetSetting = printManager.ViewSheetSetting
    viewSheetSetting.CurrentViewSheetSet.Views = viewSet
    viewSheetSetting.SaveAs("MyViewSet")
    printManager.CombinedFile = True
    printManager.SubmitPrint()
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..PrintManager

See Also

PrintManager Members


PrintManager Members

[image] [image]

Revit 2024 API
PrintManager Members
PrintManager Class Methods Properties See Also Send Feedback

The PrintManager type exposes the following members.

Methods

 | Name | Description
Public method | Apply | Apply the local print settings to global for all documents.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SelectNewPrintDriver | Select a new printer.
Public method | SubmitPrint()()()() | Print the views and sheets defined in the current local PrintManager settings.
Public method | SubmitPrint(View) | Print a view with the current PrintManager settings.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Collate | Indicates whether to collate of the current print.
Public property | CombinedFile | Indicates whether to combine multiple selected views/sheets into a single file.
Public property | CopyNumber | The copy number.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsVirtual | The virtual type in Autodesk Revit.
Public property | PaperSizes | Get all print sizes of current printer.
Public property | PaperSources | Get all print sources of current printer.
Public property | PrinterName | The name of the current printer.
Public property | PrintOrderReverse | Indicates whether to reverse the print order of the current print.
Public property | PrintRange | The print range.
Public property | PrintSetup | The PrintSetup which manages the print settings of current document.
Public property | PrintToFile | Indicates whether to print to file.
Public property | PrintToFileName | The file name when printing to file.
Public property | ViewSheetSetting | The ViewSheetSetting which manages the view/sheet set information of current document, and you can change the default view/sheet set for current project.

See Also

PrintManager Class


PrintManager Methods

[image] [image]

Revit 2024 API
PrintManager Methods
PrintManager Class See Also Send Feedback

The PrintManager type exposes the following members.

Methods

 | Name | Description
Public method | Apply | Apply the local print settings to global for all documents.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SelectNewPrintDriver | Select a new printer.
Public method | SubmitPrint()()()() | Print the views and sheets defined in the current local PrintManager settings.
Public method | SubmitPrint(View) | Print a view with the current PrintManager settings.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PrintManager Class


Apply Method

[image]

Revit 2024 API
PrintManager..::..Apply Method
PrintManager Class See Also Send Feedback
Apply the local print settings to global for all documents.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Apply()
Visual Basic
Public Sub Apply
Visual C++
public:
void Apply()

Remarks

This method will change the settings for the current printer to match what is set in the Print Manager. When the user attempts to print with this printer in the future, the changes made by the API session will be visible.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when this operation is not allowed in the current application mode, or the print resource is occupied by others.

See Also

PrintManager Class


SelectNewPrintDriver Method

[image]

Revit 2024 API
PrintManager..::..SelectNewPrintDriver Method
PrintManager Class See Also Send Feedback
Select a new printer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SelectNewPrintDriver(
    string strPrinterName
)
Visual Basic
Public Sub SelectNewPrintDriver ( _
    strPrinterName As String _
)
Visual C++
public:
void SelectNewPrintDriver(
    String^ strPrinterName
)

Parameters

strPrinterName
Type: System..::..String
The name string of new printer.

Remarks

This property is the global print setting property for all documents.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-strPrinterName-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the assigned new printer is invalid, or the print resource is occupied by others.

See Also

PrintManager Class


SubmitPrint Method

[image] [image]

Revit 2024 API
PrintManager..::..SubmitPrint Method
PrintManager Class See Also Send Feedback
Print with the current PrintManager settings.

Overload List

 | Name | Description
Public method | SubmitPrint()()()() | Print the views and sheets defined in the current local PrintManager settings.
Public method | SubmitPrint(View) | Print a view with the current PrintManager settings.

See Also

PrintManager Class
PrintManager Members


SubmitPrint Method

[image]

Revit 2024 API
PrintManager..::..SubmitPrint Method
PrintManager Class See Also Send Feedback
Print the views and sheets defined in the current local PrintManager settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool SubmitPrint()
Visual Basic
Public Function SubmitPrint As Boolean
Visual C++
public:
bool SubmitPrint()

Return Value

True if successful, otherwise False.

Remarks

PrintManager will apply the local settings to global and print the view/views/sheets which user defined with the current settings.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when this operation is not allowed in the current application mode, or the print resource is occupied by others.

See Also

PrintManager Class
SubmitPrint Overload


SubmitPrint Method (View)

[image]

Revit 2024 API
PrintManager..::..SubmitPrint Method (View)
PrintManager Class See Also Send Feedback
Print a view with the current PrintManager settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool SubmitPrint(
    View view
)
Visual Basic
Public Function SubmitPrint ( _
    view As View _
) As Boolean
Visual C++
public:
bool SubmitPrint(
    View^ view
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The User-assigned view.

Return Value

True if successful, otherwise False.

Remarks

PrintManager will apply the local settings to global and print the user-assigned view with the current settings.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when this operation is not allowed in the current application mode, or the print resource is occupied by others.

See Also

PrintManager Class
SubmitPrint Overload


CombinedFile Property

[image]

Revit 2024 API
PrintManager..::..CombinedFile Property
PrintManager Class See Also Send Feedback
Indicates whether to combine multiple selected views/sheets into a single file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool CombinedFile { get; set; }
Visual Basic
Public Property CombinedFile As Boolean
    Get
    Set
Visual C++
public:
property bool CombinedFile {
    bool get ();
    void set (bool value);
}

Remarks

The value of this property represents the global print setting property used for print operations on any document. In order to make a change to this property, after setting it call the Apply() method, or one of the SubmitPrint() methods, which save the local changes as modifications to the global print settings.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the current printer is not a virtual printer.

See Also

PrintManager Class


CopyNumber Property

[image]

Revit 2024 API
PrintManager..::..CopyNumber Property
PrintManager Class See Also Send Feedback
The copy number.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public int CopyNumber { get; set; }
Visual Basic
Public Property CopyNumber As Integer
    Get
    Set
Visual C++
public:
property int CopyNumber {
    int get ();
    void set (int value);
}

Remarks

Returns 0 if current printer does not support CopyNumber property. The value of this property represents the global print setting property used for print operations on any document. In order to make a change to this property, after setting it call the Apply() method, or one of the SubmitPrint() methods, which save the local changes as modifications to the global print settings.

See Also

PrintManager Class


IsVirtual Property

[image]

Revit 2024 API
PrintManager..::..IsVirtual Property
PrintManager Class See Also Send Feedback
The virtual type in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public VirtualPrinterType IsVirtual { get; }
Visual Basic
Public ReadOnly Property IsVirtual As VirtualPrinterType
    Get
Visual C++
public:
property VirtualPrinterType IsVirtual {
    VirtualPrinterType get ();
}

See Also

PrintManager Class


PaperSizes Property

[image]

Revit 2024 API
PrintManager..::..PaperSizes Property
PrintManager Class See Also Send Feedback
Get all print sizes of current printer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public PaperSizeSet PaperSizes { get; }
Visual Basic
Public ReadOnly Property PaperSizes As PaperSizeSet
    Get
Visual C++
public:
property PaperSizeSet^ PaperSizes {
    PaperSizeSet^ get ();
}

Remarks

These are the valid paper sizes for the current printer.

See Also

PrintManager Class


PaperSources Property

[image]

Revit 2024 API
PrintManager..::..PaperSources Property
PrintManager Class See Also Send Feedback
Get all print sources of current printer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public PaperSourceSet PaperSources { get; }
Visual Basic
Public ReadOnly Property PaperSources As PaperSourceSet
    Get
Visual C++
public:
property PaperSourceSet^ PaperSources {
    PaperSourceSet^ get ();
}

Remarks

These are the valid paper source for the current printer.

See Also

PrintManager Class


PrinterName Property

[image]

Revit 2024 API
PrintManager..::..PrinterName Property
PrintManager Class See Also Send Feedback
The name of the current printer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string PrinterName { get; }
Visual Basic
Public ReadOnly Property PrinterName As String
    Get
Visual C++
public:
property String^ PrinterName {
    String^ get ();
}

See Also

PrintManager Class


PrintSetup Property

[image]

Revit 2024 API
PrintManager..::..PrintSetup Property
PrintManager Class See Also Send Feedback
The PrintSetup which manages the print settings of current document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public PrintSetup PrintSetup { get; }
Visual Basic
Public ReadOnly Property PrintSetup As PrintSetup
    Get
Visual C++
public:
property PrintSetup^ PrintSetup {
    PrintSetup^ get ();
}

Remarks

PrintSetup is an interface cluster just like File->Print->Settings->Setup or File->Print Setup in UI.

See Also

PrintManager Class


ViewSheetSetting Property

[image]

Revit 2024 API
PrintManager..::..ViewSheetSetting Property
PrintManager Class See Also Send Feedback
The ViewSheetSetting which manages the view/sheet set information of current document, and you can change the default view/sheet set for current project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ViewSheetSetting ViewSheetSetting { get; }
Visual Basic
Public ReadOnly Property ViewSheetSetting As ViewSheetSetting
    Get
Visual C++
public:
property ViewSheetSetting^ ViewSheetSetting {
    ViewSheetSetting^ get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the print range is not selected views/sheets.

See Also

PrintManager Class


PrintParameters Class

[image]

Revit 2024 API
PrintParameters Class
Members See Also Send Feedback
An object that contains settings used for printing the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class PrintParameters : APIObject
Visual Basic
Public Class PrintParameters _
    Inherits APIObject
Visual C++
public ref class PrintParameters : public APIObject

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..PrintParameters

See Also

PrintParameters Members


PrintParameters Members

[image] [image]

Revit 2024 API
PrintParameters Members
PrintParameters Class Methods Properties See Also Send Feedback

The PrintParameters type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ColorDepth | The color depth type.
Public property | HiddenLineViews | The hidden line views type.
Public property | HideCropBoundaries | Indicates whether to hide crop boundaries when printing.
Public property | HideReforWorkPlanes | Indicates whether to hide reference/work planes when printing.
Public property | HideScopeBoxes | Indicates whether to hide scope boxes when printing.
Public property | HideUnreferencedViewTags | Indicates whether to hide unreferenced view tags when printing.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | MarginType | The print margin type.
Public property | MaskCoincidentLines | Indicates whether to mask coincident lines when printing.
Public property | OriginOffsetX | The User defined X value of offset from left bottom corner. Unit is feet.
Public property | OriginOffsetY | The User defined Y value of offset from left bottom corner. Unit is feet.
Public property | PageOrientation | The Page Orientation of the Print Setting.
Public property | PaperPlacement | The paper placement type.
Public property | PaperSize | The page size.
Public property | PaperSource | The page source.
Public property | RasterQuality | The raster quality type.
Public property | ReplaceHalftoneWithThinLines | Indicates whether to replace halftone with thin lines when printing.
Public property | UserDefinedMarginX | Obsolete. The User defined X value of offset from left bottom corner. Unit is inch.
Public property | UserDefinedMarginY | Obsolete. The User defined Y value of offset from left bottom corner. Unit is inch.
Public property | ViewLinksinBlue | Indicates whether to view links in blue when printing.
Public property | Zoom | The zoom value to a percentage of the original size.
Public property | ZoomType | The zoom type.

See Also

PrintParameters Class


PrintParameters Properties

[image] [image]

Revit 2024 API
PrintParameters Properties
PrintParameters Class See Also Send Feedback

The PrintParameters type exposes the following members.

Properties

 | Name | Description
Public property | ColorDepth | The color depth type.
Public property | HiddenLineViews | The hidden line views type.
Public property | HideCropBoundaries | Indicates whether to hide crop boundaries when printing.
Public property | HideReforWorkPlanes | Indicates whether to hide reference/work planes when printing.
Public property | HideScopeBoxes | Indicates whether to hide scope boxes when printing.
Public property | HideUnreferencedViewTags | Indicates whether to hide unreferenced view tags when printing.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | MarginType | The print margin type.
Public property | MaskCoincidentLines | Indicates whether to mask coincident lines when printing.
Public property | OriginOffsetX | The User defined X value of offset from left bottom corner. Unit is feet.
Public property | OriginOffsetY | The User defined Y value of offset from left bottom corner. Unit is feet.
Public property | PageOrientation | The Page Orientation of the Print Setting.
Public property | PaperPlacement | The paper placement type.
Public property | PaperSize | The page size.
Public property | PaperSource | The page source.
Public property | RasterQuality | The raster quality type.
Public property | ReplaceHalftoneWithThinLines | Indicates whether to replace halftone with thin lines when printing.
Public property | UserDefinedMarginX | Obsolete. The User defined X value of offset from left bottom corner. Unit is inch.
Public property | UserDefinedMarginY | Obsolete. The User defined Y value of offset from left bottom corner. Unit is inch.
Public property | ViewLinksinBlue | Indicates whether to view links in blue when printing.
Public property | Zoom | The zoom value to a percentage of the original size.
Public property | ZoomType | The zoom type.

See Also

PrintParameters Class


ColorDepth Property

[image]

Revit 2024 API
PrintParameters..::..ColorDepth Property
PrintParameters Class See Also Send Feedback
The color depth type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ColorDepthType ColorDepth { get; set; }
Visual Basic
Public Property ColorDepth As ColorDepthType
    Get
    Set
Visual C++
public:
property ColorDepthType ColorDepth {
    ColorDepthType get ();
    void set (ColorDepthType value);
}

See Also

PrintParameters Class


HiddenLineViews Property

[image]

Revit 2024 API
PrintParameters..::..HiddenLineViews Property
PrintParameters Class See Also Send Feedback
The hidden line views type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public HiddenLineViewsType HiddenLineViews { get; set; }
Visual Basic
Public Property HiddenLineViews As HiddenLineViewsType
    Get
    Set
Visual C++
public:
property HiddenLineViewsType HiddenLineViews {
    HiddenLineViewsType get ();
    void set (HiddenLineViewsType value);
}

See Also

PrintParameters Class


HideCropBoundaries Property

[image]

Revit 2024 API
PrintParameters..::..HideCropBoundaries Property
PrintParameters Class See Also Send Feedback
Indicates whether to hide crop boundaries when printing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool HideCropBoundaries { get; set; }
Visual Basic
Public Property HideCropBoundaries As Boolean
    Get
    Set
Visual C++
public:
property bool HideCropBoundaries {
    bool get ();
    void set (bool value);
}

See Also

PrintParameters Class


HideReforWorkPlanes Property

[image]

Revit 2024 API
PrintParameters..::..HideReforWorkPlanes Property
PrintParameters Class See Also Send Feedback
Indicates whether to hide reference/work planes when printing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool HideReforWorkPlanes { get; set; }
Visual Basic
Public Property HideReforWorkPlanes As Boolean
    Get
    Set
Visual C++
public:
property bool HideReforWorkPlanes {
    bool get ();
    void set (bool value);
}

See Also

PrintParameters Class


HideScopeBoxes Property

[image]

Revit 2024 API
PrintParameters..::..HideScopeBoxes Property
PrintParameters Class See Also Send Feedback
Indicates whether to hide scope boxes when printing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool HideScopeBoxes { get; set; }
Visual Basic
Public Property HideScopeBoxes As Boolean
    Get
    Set
Visual C++
public:
property bool HideScopeBoxes {
    bool get ();
    void set (bool value);
}

See Also

PrintParameters Class


HideUnreferencedViewTags Property

[image]

Revit 2024 API
PrintParameters..::..HideUnreferencedViewTags Property
PrintParameters Class See Also Send Feedback
Indicates whether to hide unreferenced view tags when printing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool HideUnreferencedViewTags { get; set; }
Visual Basic
Public Property HideUnreferencedViewTags As Boolean
    Get
    Set
Visual C++
public:
property bool HideUnreferencedViewTags {
    bool get ();
    void set (bool value);
}

See Also

PrintParameters Class


MarginType Property

[image]

Revit 2024 API
PrintParameters..::..MarginType Property
PrintParameters Class See Also Send Feedback
The print margin type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public MarginType MarginType { get; set; }
Visual Basic
Public Property MarginType As MarginType
    Get
    Set
Visual C++
public:
property MarginType MarginType {
    MarginType get ();
    void set (MarginType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the input argument is out of range.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if the PaperPlacement is not Margins type.

See Also

PrintParameters Class


MaskCoincidentLines Property

[image]

Revit 2024 API
PrintParameters..::..MaskCoincidentLines Property
PrintParameters Class See Also Send Feedback
Indicates whether to mask coincident lines when printing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool MaskCoincidentLines { get; set; }
Visual Basic
Public Property MaskCoincidentLines As Boolean
    Get
    Set
Visual C++
public:
property bool MaskCoincidentLines {
    bool get ();
    void set (bool value);
}

See Also

PrintParameters Class


OriginOffsetY Property

[image]

Revit 2024 API
PrintParameters..::..OriginOffsetY Property
PrintParameters Class See Also Send Feedback
The User defined Y value of offset from left bottom corner. Unit is feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double OriginOffsetY { get; set; }
Visual Basic
Public Property OriginOffsetY As Double
    Get
    Set
Visual C++
public:
property double OriginOffsetY {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if PaperPlacement is not Margins and MarginType is not User defined type.

See Also

PrintParameters Class


PageOrientation Property

[image]

Revit 2024 API
PrintParameters..::..PageOrientation Property
PrintParameters Class See Also Send Feedback
The Page Orientation of the Print Setting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public PageOrientationType PageOrientation { get; set; }
Visual Basic
Public Property PageOrientation As PageOrientationType
    Get
    Set
Visual C++
public:
property PageOrientationType PageOrientation {
    PageOrientationType get ();
    void set (PageOrientationType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the input argument is out of range.

See Also

PrintParameters Class


PaperPlacement Property

[image]

Revit 2024 API
PrintParameters..::..PaperPlacement Property
PrintParameters Class See Also Send Feedback
The paper placement type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public PaperPlacementType PaperPlacement { get; set; }
Visual Basic
Public Property PaperPlacement As PaperPlacementType
    Get
    Set
Visual C++
public:
property PaperPlacementType PaperPlacement {
    PaperPlacementType get ();
    void set (PaperPlacementType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the input argument is out of range.

See Also

PrintParameters Class


PaperSize Property

[image]

Revit 2024 API
PrintParameters..::..PaperSize Property
PrintParameters Class See Also Send Feedback
The page size.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public PaperSize PaperSize { get; set; }
Visual Basic
Public Property PaperSize As PaperSize
    Get
    Set
Visual C++
public:
property PaperSize^ PaperSize {
    PaperSize^ get ();
    void set (PaperSize^ value);
}

Remarks

User can select the candidate via PaperSizes and then set the Page source of the Print Setting.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument is invalid for current printer.

See Also

PrintParameters Class


UserDefinedMarginX Property

[image]

Revit 2024 API
PrintParameters..::..UserDefinedMarginX Property
PrintParameters Class See Also Send Feedback
The User defined X value of offset from left bottom corner. Unit is inch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
[ObsoleteAttribute("This property is obsolete. Use OriginOffsetX instead.")]
public double UserDefinedMarginX { get; set; }
Visual Basic
<ObsoleteAttribute("This property is obsolete. Use OriginOffsetX instead.")> _
Public Property UserDefinedMarginX As Double
    Get
    Set
Visual C++
[ObsoleteAttribute(L"This property is obsolete. Use OriginOffsetX instead.")]
public:
property double UserDefinedMarginX {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if PaperPlacement is not Margins and MarginType is not User defined type.

See Also

PrintParameters Class


UserDefinedMarginY Property

[image]

Revit 2024 API
PrintParameters..::..UserDefinedMarginY Property
PrintParameters Class See Also Send Feedback
The User defined Y value of offset from left bottom corner. Unit is inch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
[ObsoleteAttribute("This property is obsolete. Use OriginOffsetY instead.")]
public double UserDefinedMarginY { get; set; }
Visual Basic
<ObsoleteAttribute("This property is obsolete. Use OriginOffsetY instead.")> _
Public Property UserDefinedMarginY As Double
    Get
    Set
Visual C++
[ObsoleteAttribute(L"This property is obsolete. Use OriginOffsetY instead.")]
public:
property double UserDefinedMarginY {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if PaperPlacement is not Margins and MarginType is not User defined type.

See Also

PrintParameters Class


ViewLinksinBlue Property

[image]

Revit 2024 API
PrintParameters..::..ViewLinksinBlue Property
PrintParameters Class See Also Send Feedback
Indicates whether to view links in blue when printing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool ViewLinksinBlue { get; set; }
Visual Basic
Public Property ViewLinksinBlue As Boolean
    Get
    Set
Visual C++
public:
property bool ViewLinksinBlue {
    bool get ();
    void set (bool value);
}

See Also

PrintParameters Class


PrintRange Enumeration

[image]

Revit 2024 API
PrintRange Enumeration
See Also Send Feedback
An enumerated type listing all Print Range types of Print.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum PrintRange
Visual Basic
Public Enumeration PrintRange
Visual C++
public enum class PrintRange

Members

Member name | Description
Current | A range that represents just the currently active view.
Visible | Visible portion of current window.
Select | A range that represents a list of selected views and sheets.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


PrintSetting Class

[image]

Revit 2024 API
PrintSetting Class
Members See Also Send Feedback
Represents the Print Setup (Application Menu->Print->Print Setup) within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class PrintSetting : Element,
    IPrintSetting
Visual Basic
Public Class PrintSetting _
    Inherits Element _
    Implements IPrintSetting
Visual C++
public ref class PrintSetting : public Element,
    IPrintSetting

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..PrintSetting

See Also

PrintSetting Members


PrintSetting Methods

[image] [image]

Revit 2024 API
PrintSetting Methods
PrintSetting Class See Also Send Feedback

The PrintSetting type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PrintSetting Class


PrintSetting Properties

[image] [image]

Revit 2024 API
PrintSetting Properties
PrintSetting Class See Also Send Feedback

The PrintSetting type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Returns the Name of Print Setup. (Overrides Element..::..Name.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | PrintParameters | Returns the Parameters of Print Setup.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PrintSetting Class


Name Property

[image]

Revit 2024 API
PrintSetting..::..Name Property
PrintSetting Class See Also Send Feedback
Returns the Name of Print Setup.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public override string Name { get; set; }
Visual Basic
Public Overrides Property Name As String
    Get
    Set
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}

Remarks

Retrieve/set the name of Print Setup.

See Also

PrintSetting Class


Parameter Property

[image] [image]

Revit 2024 API
PrintSetting..::..Parameter Property
PrintSetting Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

PrintSetting Class
PrintSetting Members


PrintParameters Property

[image]

Revit 2024 API
PrintSetting..::..PrintParameters Property
PrintSetting Class See Also Send Feedback
Returns the Parameters of Print Setup.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual PrintParameters PrintParameters { get; }
Visual Basic
Public Overridable ReadOnly Property PrintParameters As PrintParameters
    Get
Visual C++
public:
virtual property PrintParameters^ PrintParameters {
    PrintParameters^ get ();
}

Implements

IPrintSetting..::..PrintParameters

Remarks

The Parameters of Print Setup. Refer to the Print Setup dialog in Revit for details.

See Also

PrintSetting Class


PrintSetup Class

[image]

Revit 2024 API
PrintSetup Class
Members See Also Send Feedback
Represents the Print Setup (Application Menu->Print->Print Setup) within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class PrintSetup : APIObject
Visual Basic
Public Class PrintSetup _
    Inherits APIObject
Visual C++
public ref class PrintSetup : public APIObject

Remarks

The Print Setup object can only get from PrintManager object.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..PrintSetup

See Also

PrintSetup Members


PrintSetup Members

[image] [image]

Revit 2024 API
PrintSetup Members
PrintSetup Class Methods Properties See Also Send Feedback

The PrintSetup type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Delete the current print setting, and make the In-Session setting as the current one.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Rename | Rename the current print setting with the specified name.
Public method | Revert | Revert the current print setting.
Public method | Save | Save the changes for the current print setting.
Public method | SaveAs | Save the current print setting to another print setting with the specified name.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CurrentPrintSetting | The current Print Setting of Print Setup.
Public property | InSession | The in-session Print Setting of Print Setup.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PrintSetup Class


PrintSetup Methods

[image] [image]

Revit 2024 API
PrintSetup Methods
PrintSetup Class See Also Send Feedback

The PrintSetup type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Delete the current print setting, and make the In-Session setting as the current one.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Rename | Rename the current print setting with the specified name.
Public method | Revert | Revert the current print setting.
Public method | Save | Save the changes for the current print setting.
Public method | SaveAs | Save the current print setting to another print setting with the specified name.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PrintSetup Class


Delete Method

[image]

Revit 2024 API
PrintSetup..::..Delete Method
PrintSetup Class See Also Send Feedback
Delete the current print setting, and make the In-Session setting as the current one.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool Delete()
Visual Basic
Public Function Delete As Boolean
Visual C++
public:
bool Delete()

Return Value

False if Delete operation fails, otherwise true.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the current print setting is In-Session.

See Also

PrintSetup Class


SaveAs Method

[image]

Revit 2024 API
PrintSetup..::..SaveAs Method
PrintSetup Class See Also Send Feedback
Save the current print setting to another print setting with the specified name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool SaveAs(
    string newName
)
Visual Basic
Public Function SaveAs ( _
    newName As String _
) As Boolean
Visual C++
public:
bool SaveAs(
    String^ newName
)

Parameters

newName
Type: System..::..String
print setting name to be saved as.

Return Value

False if Save As operation fails, otherwise true.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the input newName already exists in current print setting list.

See Also

PrintSetup Class


CurrentPrintSetting Property

[image]

Revit 2024 API
PrintSetup..::..CurrentPrintSetting Property
PrintSetup Class See Also Send Feedback
The current Print Setting of Print Setup.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public IPrintSetting CurrentPrintSetting { get; set; }
Visual Basic
Public Property CurrentPrintSetting As IPrintSetting
    Get
    Set
Visual C++
public:
property IPrintSetting^ CurrentPrintSetting {
    IPrintSetting^ get ();
    void set (IPrintSetting^ value);
}

See Also

PrintSetup Class


InSession Property

[image]

Revit 2024 API
PrintSetup..::..InSession Property
PrintSetup Class See Also Send Feedback
The in-session Print Setting of Print Setup.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public InSessionPrintSetting InSession { get; }
Visual Basic
Public ReadOnly Property InSession As InSessionPrintSetting
    Get
Visual C++
public:
property InSessionPrintSetting^ InSession {
    InSessionPrintSetting^ get ();
}

See Also

PrintSetup Class


Profile Class

[image]

Revit 2024 API
Profile Class
Members Example See Also Send Feedback
A geometric profile consisting of a loop of curves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class Profile : GeometryObject
Visual Basic
Public Class Profile _
    Inherits GeometryObject
Visual C++
public ref class Profile : public GeometryObject

Remarks

The profile may be filled.

Examples

CopyC#
public void GetProfile(Element element)
{
    string messageInfo = "Profile : ";
    if (element is FamilyInstance)
    {
        FamilyInstance beam = element as FamilyInstance;
        if (beam.StructuralType == StructuralType.Beam)
        {
            // Get swept profile
            Autodesk.Revit.DB.SweptProfile sweptProfile = beam.GetSweptProfile();
            Autodesk.Revit.DB.Profile profile = sweptProfile.GetSweptProfile();
            // Get swept profile curves size
            messageInfo += "\nSelection name : " + beam.Name;
            messageInfo += "\nSwept Profile Driving Curve size is " + profile.Curves.Size;
            messageInfo += "\nProfile is filled :  " + profile.Filled;
            if (!profile.IsReadOnly)
            {
                profile.Filled = !profile.Filled;
                messageInfo += "\nProfile is filled after setting:  " + profile.Filled;
            }
            TaskDialog.Show("Revit",messageInfo);
        }
    }
}
CopyVB.NET
Public Sub GetProfile(element As Element)
    Dim messageInfo As String = "Profile : "
    If TypeOf element Is FamilyInstance Then
        Dim beam As FamilyInstance = TryCast(element, FamilyInstance)
        If beam.StructuralType = StructuralType.Beam Then
       ' Get swept profile
       Dim sweptProfile As Autodesk.Revit.DB.SweptProfile = beam.GetSweptProfile()
            Dim profile As Autodesk.Revit.DB.Profile = sweptProfile.GetSweptProfile()
       ' Get swept profile curves size
            messageInfo += vbLf & "Selection name : " + beam.Name
            messageInfo += vbLf & "Swept Profile Driving Curve size is " + profile.Curves.Size
            messageInfo += vbLf & "Profile is filled :  " + profile.Filled
            If Not profile.IsReadOnly Then
                profile.Filled = Not profile.Filled
                messageInfo += vbLf & "Profile is filled after setting:  " + profile.Filled
            End If
            TaskDialog.Show("Revit", messageInfo)
        End If
    End If
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeometryObject
Autodesk.Revit.DB..::..Profile

See Also

Profile Members


Profile Members

[image] [image]

Revit 2024 API
Profile Members
Profile Class Methods Properties See Also Send Feedback

The Profile type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns a copy of this profile.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Curves | Retrieve the curves that make up the boundary of the profile.
Public property | Filled | Get or set whether the profile is filled.
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Transformed | Transforms this profile and returns the result.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Profile Class


Profile Methods

[image] [image]

Revit 2024 API
Profile Methods
Profile Class See Also Send Feedback

The Profile type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns a copy of this profile.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Profile Class


Clone Method

[image]

Revit 2024 API
Profile..::..Clone Method
Profile Class See Also Send Feedback
Returns a copy of this profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Profile Clone()
Visual Basic
Public Function Clone As Profile
Visual C++
public:
Profile^ Clone()

See Also

Profile Class


Profile Properties

[image] [image]

Revit 2024 API
Profile Properties
Profile Class See Also Send Feedback

The Profile type exposes the following members.

Properties

 | Name | Description
Public property | Curves | Retrieve the curves that make up the boundary of the profile.
Public property | Filled | Get or set whether the profile is filled.
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Transformed | Transforms this profile and returns the result.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Profile Class


Curves Property

[image]

Revit 2024 API
Profile..::..Curves Property
Profile Class See Also Send Feedback
Retrieve the curves that make up the boundary of the profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CurveArray Curves { get; }
Visual Basic
Public ReadOnly Property Curves As CurveArray
    Get
Visual C++
public:
property CurveArray^ Curves {
    CurveArray^ get ();
}

See Also

Profile Class


Filled Property

[image]

Revit 2024 API
Profile..::..Filled Property
Profile Class See Also Send Feedback
Get or set whether the profile is filled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool Filled { get; set; }
Visual Basic
Public Property Filled As Boolean
    Get
    Set
Visual C++
public:
property bool Filled {
    bool get ();
    void set (bool value);
}

See Also

Profile Class


Transformed Property

[image]

Revit 2024 API
Profile..::..Transformed Property
Profile Class See Also Send Feedback
Transforms this profile and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Profile this[
    Transform transform
] { get; }
Visual Basic
Public ReadOnly Property Transformed ( _
    transform As Transform _
) As Profile
    Get
Visual C++
public:
property Profile^ Transformed[Transform^ transform] {
    Profile^ get (Transform^ transform);
}

Parameters

transform
Type: Autodesk.Revit.DB..::..Transform
The transformation used to transform the profile.

Return Value

The transformed profile.

Remarks

Transforms all the curves that define the boundary of this profile.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the handle of the specified transformation is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when failed to transform a curve in the profile.

See Also

Profile Class


ProfileFamilyUsage Enumeration

[image]

Revit 2024 API
ProfileFamilyUsage Enumeration
See Also Send Feedback
An enumerated type listing all types of profile families.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum ProfileFamilyUsage
Visual Basic
Public Enumeration ProfileFamilyUsage
Visual C++
public enum class ProfileFamilyUsage

Members

Member name | Description
Any | Any type of profile family.
WallSweep | Wall sweep.
Reveal | Reveal.
Fascia | Fascia.
Gutter | Gutter.
SlabEdge | Slab edge.
Railing | Railing.
StairNosing | Stair Nosing.
Mullion | Mullion.
SlabMetalDeck | Slab Metal Deck.
ContinuousFooting | Continuous Footing.
StairTread | Stair Tread.
StairRiser | Stair Riser.
StairSupport | Stair Support.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


ProfilePlaneLocation Enumeration

[image]

Revit 2024 API
ProfilePlaneLocation Enumeration
See Also Send Feedback
Indicates the location of Sweep profile plane on the path curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum ProfilePlaneLocation
Visual Basic
Public Enumeration ProfilePlaneLocation
Visual C++
public enum class ProfilePlaneLocation

Members

Member name | Description
Start | Indicates the profile plane located at the start of the path curve.
MidPoint | Indicates the profile plane located at the Middle point of the path curve.
End | Indicates the profile plane located at the End of the path curve.

Remarks

Use this enum in the NewSweep() method to create generic forms.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


ProjectInfo Members

[image] [image]

Revit 2024 API
ProjectInfo Members
ProjectInfo Class Methods Properties See Also Send Feedback

The ProjectInfo type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Address | Get or Set the Project Address of the Project Information.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | Author | Get or Set the Project Author of the Project Information.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | BuildingName | Get or Set the Building Name of the Project Information.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ClientName | Get or Set the Client Name of the Project Information.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IssueDate | Get or Set the Project Issue Date of the Project Information.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Get or Set the Project Name of the Project Information.
Public property | Number | Get or Set the Project Number of the Project Information.
Public property | OrganizationDescription | Get or Set the Organization Description of the Project Information.
Public property | OrganizationName | Get or Set the Organization Name of the Project Information.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Status | Get or Set the Project Status of the Project Information.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ProjectInfo Class


ProjectInfo Methods

[image] [image]

Revit 2024 API
ProjectInfo Methods
ProjectInfo Class See Also Send Feedback

The ProjectInfo type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ProjectInfo Class


Address Property

[image]

Revit 2024 API
ProjectInfo..::..Address Property
ProjectInfo Class See Also Send Feedback
Get or Set the Project Address of the Project Information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string Address { get; set; }
Visual Basic
Public Property Address As String
    Get
    Set
Visual C++
public:
property String^ Address {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used to get or set the Project Address of the Project Information.

See Also

ProjectInfo Class


Author Property

[image]

Revit 2024 API
ProjectInfo..::..Author Property
ProjectInfo Class See Also Send Feedback
Get or Set the Project Author of the Project Information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string Author { get; set; }
Visual Basic
Public Property Author As String
    Get
    Set
Visual C++
public:
property String^ Author {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used to get or set the Project Author of the Project Information.

See Also

ProjectInfo Class


ClientName Property

[image]

Revit 2024 API
ProjectInfo..::..ClientName Property
ProjectInfo Class See Also Send Feedback
Get or Set the Client Name of the Project Information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string ClientName { get; set; }
Visual Basic
Public Property ClientName As String
    Get
    Set
Visual C++
public:
property String^ ClientName {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used to get or set the Project Client Name of the Project Information.

See Also

ProjectInfo Class


Number Property

[image]

Revit 2024 API
ProjectInfo..::..Number Property
ProjectInfo Class See Also Send Feedback
Get or Set the Project Number of the Project Information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string Number { get; set; }
Visual Basic
Public Property Number As String
    Get
    Set
Visual C++
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used to get or set the Project Number of the Project Information.

See Also

ProjectInfo Class


OrganizationDescription Property

[image]

Revit 2024 API
ProjectInfo..::..OrganizationDescription Property
ProjectInfo Class See Also Send Feedback
Get or Set the Organization Description of the Project Information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string OrganizationDescription { get; set; }
Visual Basic
Public Property OrganizationDescription As String
    Get
    Set
Visual C++
public:
property String^ OrganizationDescription {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used to get or set the Project Number of the Project Information.

See Also

ProjectInfo Class


ProjectLocation Class

[image]

Revit 2024 API
ProjectLocation Class
Members Example See Also Send Feedback
A representation of a specific instance and location of the current project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class ProjectLocation : Instance
Visual Basic
Public Class ProjectLocation _
    Inherits Instance
Visual C++
public ref class ProjectLocation : public Instance

Remarks

When using shared coordinates, ProjectLocations can be used to specify specific locations for instances of a linked model. A ProjectLocation keeps track of the position of an instance in relationship to the project's SiteLocation.

By default, each Revit project contains at least one named location, called Internal. Existing ProjectLocation objects can be found by using the ProjectLocations property on the Document object. New project locations can be created by duplicating an existing project location using the Duplicate method, and modifying the location's project position.

See also SiteLocation

Examples

CopyC#
public void ShowActiveProjectLocationUsage(Autodesk.Revit.DB.Document document)
{
    // Get the project location handle
    ProjectLocation projectLocation = document.ActiveProjectLocation;

    // Show the information of current project location
    XYZ origin = new XYZ(0, 0, 0);
    ProjectPosition position = projectLocation.GetProjectPosition(origin);
    if (null == position)
    {
        throw new Exception("No project position in origin point.");
    }

    // Format the prompt string to show the message.
    String prompt = "Current project location information:\n";
    prompt += "\n\t" + "Origin point position:";
    prompt += "\n\t\t" + "Angle: " + position.Angle;
    prompt += "\n\t\t" + "East to West offset: " + position.EastWest;
    prompt += "\n\t\t" + "Elevation: " + position.Elevation;
    prompt += "\n\t\t" + "North to South offset: " + position.NorthSouth;

    // Angles are in radians when coming from Revit API, so we
    // convert to degrees for display
    const double angleRatio = Math.PI / 180;   // angle conversion factor

    SiteLocation site = projectLocation.GetSiteLocation();
    prompt += "\n\t" + "Site location:";
    prompt += "\n\t\t" + "Latitude: " + site.Latitude / angleRatio + "��";
    prompt += "\n\t\t" + "Longitude: " + site.Longitude / angleRatio + "��";
    prompt += "\n\t\t" + "TimeZone: " + site.TimeZone;

    // Give the user some information
    TaskDialog.Show("Revit",prompt);
}
CopyVB.NET
Public Sub ShowActiveProjectLocationUsage(document As Autodesk.Revit.DB.Document)
    ' Get the project location handle
    Dim projectLocation As ProjectLocation = document.ActiveProjectLocation

    ' Show the information of current project location
    Dim origin As New XYZ(0, 0, 0)
    Dim position As ProjectPosition = projectLocation.GetProjectPosition(origin)
    If position Is Nothing Then
        Throw New Exception("No project position in origin point.")
    End If

    ' Format the prompt string to show the message.
    Dim prompt As [String] = "Current project location information:" & vbLf
    prompt += vbLf & vbTab & "Origin point position:"
    prompt += (vbLf & vbTab & vbTab & "Angle: ") + position.Angle
    prompt += (vbLf & vbTab & vbTab & "East to West offset: ") + position.EastWest
    prompt += (vbLf & vbTab & vbTab & "Elevation: ") + position.Elevation
    prompt += (vbLf & vbTab & vbTab & "North to South offset: ") + position.NorthSouth

    ' Angles are in radians when coming from Revit API, so we
    ' convert to degrees for display
    Const angleRatio As Double = Math.PI / 180
    ' angle conversion factor
    Dim site As SiteLocation = projectLocation.GetSiteLocation()
    prompt += vbLf & vbTab & "Site location:"
    prompt += vbLf & vbTab & vbTab & "Latitude: " & site.Latitude / angleRatio & "��"
    prompt += vbLf & vbTab & vbTab & "Longitude: " & site.Longitude / angleRatio & "��"
    prompt += (vbLf & vbTab & vbTab & "TimeZone: ") + site.TimeZone

    ' Give the user some information
    TaskDialog.Show("Revit", prompt)
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..Instance
Autodesk.Revit.DB..::..ProjectLocation

See Also

ProjectLocation Members


ProjectLocation Members

[image] [image]

Revit 2024 API
ProjectLocation Members
ProjectLocation Class Methods Properties See Also Send Feedback

The ProjectLocation type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create | Create an instance of ProjectLocation in the document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Generate a copy of this project location with the specified name.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetProjectPosition | Gets the coordinates of a point in the ProjectLocation's coordinate system.
Public method | GetSiteLocation | Gets the site location to which this project location refers.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetTotalTransform | Gets the total transform, which includes the true north transform for instances like import instances. (Inherited from Instance.)
Public method | GetTransform | Gets the transform of the instance. (Inherited from Instance.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
 | IsProjectLocationNameUnique | Verifies that there is no existing ProjectLocation with the given name belonging to the given SiteLocation.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetProjectPosition | Sets the coordinates of a point in the ProjectLocation's coordinate system.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ProjectLocation Class


ProjectLocation Methods

[image] [image]

Revit 2024 API
ProjectLocation Methods
ProjectLocation Class See Also Send Feedback

The ProjectLocation type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create | Create an instance of ProjectLocation in the document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Generate a copy of this project location with the specified name.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetProjectPosition | Gets the coordinates of a point in the ProjectLocation's coordinate system.
Public method | GetSiteLocation | Gets the site location to which this project location refers.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetTotalTransform | Gets the total transform, which includes the true north transform for instances like import instances. (Inherited from Instance.)
Public method | GetTransform | Gets the transform of the instance. (Inherited from Instance.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
 | IsProjectLocationNameUnique | Verifies that there is no existing ProjectLocation with the given name belonging to the given SiteLocation.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetProjectPosition | Sets the coordinates of a point in the ProjectLocation's coordinate system.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ProjectLocation Class


Create Method

[image]

Revit 2024 API
ProjectLocation..::..Create Method
ProjectLocation Class See Also Send Feedback
Create an instance of ProjectLocation in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public static ProjectLocation Create(
    Document document,
    ElementId siteLocationId,
    string name
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    siteLocationId As ElementId, _
    name As String _
) As ProjectLocation
Visual C++
public:
static ProjectLocation^ Create(
    Document^ document,
    ElementId^ siteLocationId,
    String^ name
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document where the new instance of ProjectLocation would be created in.
siteLocationId
Type: Autodesk.Revit.DB..::..ElementId
The ElementId of the SiteLocation to which the new ProjectLocation would be created.
name
Type: System..::..String
The name of the instance of ProjectLocation to be created.

Return Value

The newly created instance of ProjectLocation.

Remarks

The created instace of ProjectLocation would have the specified name and an identity Transform.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- The element siteLocationId does not exist in the document -or- name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- There is already a ProjectLocation with this name in the given SiteLocation.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

ProjectLocation Class


Duplicate Method

[image]

Revit 2024 API
ProjectLocation..::..Duplicate Method
ProjectLocation Class Example See Also Send Feedback
Generate a copy of this project location with the specified name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ProjectLocation Duplicate(
    string name
)
Visual Basic
Public Function Duplicate ( _
    name As String _
) As ProjectLocation
Visual C++
public:
ProjectLocation^ Duplicate(
    String^ name
)

Parameters

name
Type: System..::..String

Return Value

A new ProjectLocation which is a duplicate of this location, with the input name.

Remarks

The name must not be the same as the name of any existing locations. This function will modify the document, as the new ProjectLocation will be added to it.

Examples

CopyC#
public ProjectLocation DuplicateLocation(Autodesk.Revit.DB.Document document, string newName)
{
    ProjectLocation currentLocation = document.ActiveProjectLocation;
    ProjectLocationSet locations = document.ProjectLocations;
    foreach (ProjectLocation projectLocation in locations)
    {
        if (projectLocation.Name == newName)
        {
            throw new Exception("The name is same as a project location's name, please change one.");
        }
    }
    return currentLocation.Duplicate(newName);
}
CopyVB.NET
Public Function DuplicateLocation(document As Autodesk.Revit.DB.Document, newName As String) As ProjectLocation
    Dim currentLocation As ProjectLocation = document.ActiveProjectLocation
    Dim locations As ProjectLocationSet = document.ProjectLocations
    For Each projectLocation As ProjectLocation In locations
        If projectLocation.Name = newName Then
            Throw New Exception("The name is same as a project location's name, please change one.")
        End If
    Next
    Return currentLocation.Duplicate(newName)
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ProjectLocation Class


GetProjectPosition Method

[image]

Revit 2024 API
ProjectLocation..::..GetProjectPosition Method
ProjectLocation Class Example See Also Send Feedback
Gets the coordinates of a point in the ProjectLocation's coordinate system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ProjectPosition GetProjectPosition(
    XYZ point
)
Visual Basic
Public Function GetProjectPosition ( _
    point As XYZ _
) As ProjectPosition
Visual C++
public:
ProjectPosition^ GetProjectPosition(
    XYZ^ point
)

Parameters

point
Type: Autodesk.Revit.DB..::..XYZ

Remarks

When getting this value, the North/South, East/West, and Elevation values report the coordinates of the point similar to the Revit command "Report Shared Coordinates". To get the values of the transformations applied by this project location, pass XYZ.Zero.

If the project has acquired shared coordinates from a linked model, the shared coordinate transformation will be reflected in the coordinates of the transformed point returned by this property.

Examples

CopyC#
//get and set the value of the projectlocation
public ProjectLocation GetProjectLocation(Autodesk.Revit.DB.Document document)
{
    ProjectLocation currentLocation = document.ActiveProjectLocation;

    //get the project position
    XYZ origin = new XYZ(0, 0, 0);

    const double angleRatio = Math.PI / 180;   // angle conversion factor

    ProjectPosition projectPosition = currentLocation.GetProjectPosition(origin);
    //Angle from True North
    double angle = 30.0 * angleRatio;   // convert degrees to radian
    double eastWest = 30.0;     //East to West offset
    double northSouth = 23.32;   //North to South offset
    double elevation = 22.14;    //Elevation above ground level

    //create a new project position
    ProjectPosition newPosition =
      document.Application.Create.NewProjectPosition(eastWest, northSouth, elevation, angle);

    if (null != newPosition)
    {
        //set the value of the project position
        currentLocation.SetProjectPosition(origin, newPosition);
    }

    return currentLocation;
}
CopyVB.NET
'get and set the value of the projectlocation
Public Function GetProjectLocation(document As Autodesk.Revit.DB.Document) As ProjectLocation
    Dim currentLocation As ProjectLocation = document.ActiveProjectLocation

    'get the project position
    Dim origin As New XYZ(0, 0, 0)

    Const angleRatio As Double = Math.PI / 180
    ' angle conversion factor
    Dim projectPosition As ProjectPosition = currentLocation.GetProjectPosition(origin)
    'Angle from True North
    Dim angle As Double = 30.0 * angleRatio
    ' convert degrees to radian
    Dim eastWest As Double = 30.0
    'East to West offset
    Dim northSouth As Double = 23.32
    'North to South offset
    Dim elevation As Double = 22.14
    'Elevation above ground level
    'create a new project position
    Dim newPosition As ProjectPosition = document.Application.Create.NewProjectPosition(eastWest, northSouth, elevation, angle)

    If newPosition IsNot Nothing Then
        'set the value of the project position
        currentLocation.SetProjectPosition(origin, newPosition)
    End If

    Return currentLocation
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | Unable to use the project position's transform to calculate the point.

See Also

ProjectLocation Class


GetSiteLocation Method

[image]

Revit 2024 API
ProjectLocation..::..GetSiteLocation Method
ProjectLocation Class See Also Send Feedback
Gets the site location to which this project location refers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public SiteLocation GetSiteLocation()
Visual Basic
Public Function GetSiteLocation As SiteLocation
Visual C++
public:
SiteLocation^ GetSiteLocation()

Remarks

The site location object contains the longitude, latitude, and time-zone of the entire project site.

See Also

ProjectLocation Class


ProjectLocation Properties

[image] [image]

Revit 2024 API
ProjectLocation Properties
ProjectLocation Class See Also Send Feedback

The ProjectLocation type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ProjectLocation Class


Parameter Property

[image] [image]

Revit 2024 API
ProjectLocation..::..Parameter Property
ProjectLocation Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ProjectLocation Class
ProjectLocation Members


ProjectLocationSet Constructor

[image]

Revit 2024 API
ProjectLocationSet Constructor
ProjectLocationSet Class See Also Send Feedback
Initializes a new instance of the ProjectLocationSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ProjectLocationSet()
Visual Basic
Public Sub New
Visual C++
public:
ProjectLocationSet()

See Also

ProjectLocationSet Class


ProjectLocationSet Methods

[image] [image]

Revit 2024 API
ProjectLocationSet Methods
ProjectLocationSet Class See Also Send Feedback

The ProjectLocationSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every project location from the set, rendering it empty.
Public method | Contains | Tests for the existence of a project location within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified project location from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified project location into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ProjectLocationSet Class


Contains Method

[image]

Revit 2024 API
ProjectLocationSet..::..Contains Method
ProjectLocationSet Class See Also Send Feedback
Tests for the existence of a project location within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool Contains(
    ProjectLocation item
)
Visual Basic
Public Overridable Function Contains ( _
    item As ProjectLocation _
) As Boolean
Visual C++
public:
virtual bool Contains(
    ProjectLocation^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..ProjectLocation
The project location to be searched for.

Return Value

The Contains method returns True if the project location is within the set, otherwise False.

See Also

ProjectLocationSet Class


Erase Method

[image]

Revit 2024 API
ProjectLocationSet..::..Erase Method
ProjectLocationSet Class See Also Send Feedback
Removes a specified project location from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Erase(
    ProjectLocation item
)
Visual Basic
Public Overridable Function Erase ( _
    item As ProjectLocation _
) As Integer
Visual C++
public:
virtual int Erase(
    ProjectLocation^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..ProjectLocation
The project location to be erased.

Return Value

The number of project locations that were erased from the set.

See Also

ProjectLocationSet Class


ForwardIterator Method

[image]

Revit 2024 API
ProjectLocationSet..::..ForwardIterator Method
ProjectLocationSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual ProjectLocationSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As ProjectLocationSetIterator
Visual C++
public:
virtual ProjectLocationSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

ProjectLocationSet Class


GetEnumerator Method

[image]

Revit 2024 API
ProjectLocationSet..::..GetEnumerator Method
ProjectLocationSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

ProjectLocationSet Class


Insert Method

[image]

Revit 2024 API
ProjectLocationSet..::..Insert Method
ProjectLocationSet Class See Also Send Feedback
Insert the specified project location into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool Insert(
    ProjectLocation item
)
Visual Basic
Public Overridable Function Insert ( _
    item As ProjectLocation _
) As Boolean
Visual C++
public:
virtual bool Insert(
    ProjectLocation^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..ProjectLocation
The project location to be inserted into the set.

Return Value

Returns whether the project location was inserted into the set.

See Also

ProjectLocationSet Class


ReverseIterator Method

[image]

Revit 2024 API
ProjectLocationSet..::..ReverseIterator Method
ProjectLocationSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual ProjectLocationSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As ProjectLocationSetIterator
Visual C++
public:
virtual ProjectLocationSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

ProjectLocationSet Class


ProjectLocationSet Properties

[image] [image]

Revit 2024 API
ProjectLocationSet Properties
ProjectLocationSet Class See Also Send Feedback

The ProjectLocationSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of project locations that are in the set.

See Also

ProjectLocationSet Class


IsEmpty Property

[image]

Revit 2024 API
ProjectLocationSet..::..IsEmpty Property
ProjectLocationSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

ProjectLocationSet Class


Size Property

[image]

Revit 2024 API
ProjectLocationSet..::..Size Property
ProjectLocationSet Class See Also Send Feedback
Returns the number of project locations that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ProjectLocationSet Class


ProjectLocationSetIterator Class

[image]

Revit 2024 API
ProjectLocationSetIterator Class
Members See Also Send Feedback
An iterator to a project location set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public abstract class ProjectLocationSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class ProjectLocationSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ProjectLocationSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..ProjectLocationSetIterator

See Also

ProjectLocationSetIterator Members


ProjectLocationSetIterator Constructor

[image]

Revit 2024 API
ProjectLocationSetIterator Constructor
ProjectLocationSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ProjectLocationSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
ProjectLocationSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ProjectLocationSetIterator Class


MoveNext Method

[image]

Revit 2024 API
ProjectLocationSetIterator..::..MoveNext Method
ProjectLocationSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ProjectLocationSetIterator Class


Reset Method

[image]

Revit 2024 API
ProjectLocationSetIterator..::..Reset Method
ProjectLocationSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ProjectLocationSetIterator Class


ProjectLocationSetIterator Properties

[image] [image]

Revit 2024 API
ProjectLocationSetIterator Properties
ProjectLocationSetIterator Class See Also Send Feedback

The ProjectLocationSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ProjectLocationSetIterator Class


Current Property

[image]

Revit 2024 API
ProjectLocationSetIterator..::..Current Property
ProjectLocationSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ProjectLocationSetIterator Class


ProjectPosition Class

[image]

Revit 2024 API
ProjectPosition Class
Members See Also Send Feedback
ProjectPosition is a class used to represent a geographical offset and rotation. It can be used to represent the position of a project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class ProjectPosition : IDisposable
Visual Basic
Public Class ProjectPosition _
    Implements IDisposable
Visual C++
public ref class ProjectPosition : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ProjectPosition

See Also

ProjectPosition Members


ProjectPosition Members

[image] [image]

Revit 2024 API
ProjectPosition Members
ProjectPosition Class Constructors Methods Properties See Also Send Feedback

The ProjectPosition type exposes the following members.

Constructors

 | Name | Description
Public method | ProjectPosition(ProjectPosition) | Creates a copy of the ProjectPosition.
Public method | ProjectPosition(Double, Double, Double, Double) | Construct a new ProjectPosition with the specified East/West offset, North/South offset, elevation offset, and angle of rotation.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ProjectPosition
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Angle | Angle from True North.
Public property | EastWest | East/West offset.
Public property | Elevation | Elevation above ground level.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | NorthSouth | North/South offset

See Also

ProjectPosition Class


ProjectPosition Constructor

[image] [image]

Revit 2024 API
ProjectPosition Constructor
ProjectPosition Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ProjectPosition(ProjectPosition) | Creates a copy of the ProjectPosition.
Public method | ProjectPosition(Double, Double, Double, Double) | Construct a new ProjectPosition with the specified East/West offset, North/South offset, elevation offset, and angle of rotation.

See Also

ProjectPosition Class
ProjectPosition Members


ProjectPosition Constructor (ProjectPosition)

[image]

Revit 2024 API
ProjectPosition Constructor (ProjectPosition)
ProjectPosition Class See Also Send Feedback
Creates a copy of the ProjectPosition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ProjectPosition(
    ProjectPosition other
)
Visual Basic
Public Sub New ( _
    other As ProjectPosition _
)
Visual C++
public:
ProjectPosition(
    ProjectPosition^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..ProjectPosition

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ProjectPosition Class
ProjectPosition Overload


ProjectPosition Constructor (Double, Double, Double, Double)

[image]

Revit 2024 API
ProjectPosition Constructor (Double, Double, Double, Double)
ProjectPosition Class See Also Send Feedback
Construct a new ProjectPosition with the specified East/West offset, North/South offset, elevation offset, and angle of rotation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ProjectPosition(
    double ew,
    double ns,
    double elevation,
    double angle
)
Visual Basic
Public Sub New ( _
    ew As Double, _
    ns As Double, _
    elevation As Double, _
    angle As Double _
)
Visual C++
public:
ProjectPosition(
    double ew,
    double ns,
    double elevation,
    double angle
)

Parameters

ew
Type: System..::..Double
East/West offset
ns
Type: System..::..Double
North/South offset
elevation
Type: System..::..Double
Elevation offset
angle
Type: System..::..Double
Rotation from true north, in radians

Remarks

The angle parameter must be in the range of -PI to PI. If the parameter value is outside that range, it will be shifted by 2*PI until it falls into range.

See Also

ProjectPosition Class
ProjectPosition Overload


ProjectPosition Methods

[image] [image]

Revit 2024 API
ProjectPosition Methods
ProjectPosition Class See Also Send Feedback

The ProjectPosition type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ProjectPosition Class


Dispose Method

[image]

Revit 2024 API
ProjectPosition..::..Dispose Method
ProjectPosition Class See Also Send Feedback
Releases all resources used by the ProjectPosition

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ProjectPosition Class


ProjectPosition Properties

[image] [image]

Revit 2024 API
ProjectPosition Properties
ProjectPosition Class See Also Send Feedback

The ProjectPosition type exposes the following members.

Properties

 | Name | Description
Public property | Angle | Angle from True North.
Public property | EastWest | East/West offset.
Public property | Elevation | Elevation above ground level.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | NorthSouth | North/South offset

See Also

ProjectPosition Class


Angle Property

[image]

Revit 2024 API
ProjectPosition..::..Angle Property
ProjectPosition Class See Also Send Feedback
Angle from True North.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double Angle { get; set; }
Visual Basic
Public Property Angle As Double
    Get
    Set
Visual C++
public:
property double Angle {
    double get ();
    void set (double value);
}

Remarks

This is the angle difference between project north and true north measured in radians. It can have a value from -PI to PI. If the parameter value is outside that range, it will be shifted by 2*PI until it falls into range.

See Also

ProjectPosition Class


EastWest Property

[image]

Revit 2024 API
ProjectPosition..::..EastWest Property
ProjectPosition Class See Also Send Feedback
East/West offset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double EastWest { get; set; }
Visual Basic
Public Property EastWest As Double
    Get
    Set
Visual C++
public:
property double EastWest {
    double get ();
    void set (double value);
}

Remarks

The offset of the project location from the site location in the east/west direction. Measured in decimal feet.

See Also

ProjectPosition Class


Elevation Property

[image]

Revit 2024 API
ProjectPosition..::..Elevation Property
ProjectPosition Class See Also Send Feedback
Elevation above ground level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double Elevation { get; set; }
Visual Basic
Public Property Elevation As Double
    Get
    Set
Visual C++
public:
property double Elevation {
    double get ();
    void set (double value);
}

Remarks

Negative values are allowed. Measured in decimal feet.

See Also

ProjectPosition Class


IsValidObject Property

[image]

Revit 2024 API
ProjectPosition..::..IsValidObject Property
ProjectPosition Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ProjectPosition Class


PropertyLine Class

[image]

Revit 2024 API
PropertyLine Class
Members See Also Send Feedback
Represents kinds of PropertyLines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class PropertyLine : Element
Visual Basic
Public Class PropertyLine _
    Inherits Element
Visual C++
public ref class PropertyLine : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..PropertyLine

See Also

PropertyLine Members


PropertyLine Members

[image] [image]

Revit 2024 API
PropertyLine Members
PropertyLine Class Methods Properties See Also Send Feedback

The PropertyLine type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PropertyLine Class


PropertyLine Properties

[image] [image]

Revit 2024 API
PropertyLine Properties
PropertyLine Class See Also Send Feedback

The PropertyLine type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PropertyLine Class


Parameter Property

[image] [image]

Revit 2024 API
PropertyLine..::..Parameter Property
PropertyLine Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

PropertyLine Class
PropertyLine Members


PropertySetElement Members

[image] [image]

Revit 2024 API
PropertySetElement Members
PropertySetElement Class Methods Properties See Also Send Feedback

The PropertySetElement type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create(Document, StructuralAsset) | Creates a new PropertySetElement to contain the given asset.
 | Create(Document, ThermalAsset) | Creates a new PropertySetElement to contain the given asset.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Creates a duplicate of this PropertySetElement.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetStructuralAsset | Gets a copy of the StructuralAsset.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetThermalAsset | Gets a copy of the ThermalAsset.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetStructuralAsset | Sets a copy of the given StucturalAsset to be used in the PropertySetElement.
Public method | SetThermalAsset | Sets a copy of the given ThermalAsset to be used in the PropertySetElement.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PropertySetElement Class


PropertySetElement Methods

[image] [image]

Revit 2024 API
PropertySetElement Methods
PropertySetElement Class See Also Send Feedback

The PropertySetElement type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create(Document, StructuralAsset) | Creates a new PropertySetElement to contain the given asset.
 | Create(Document, ThermalAsset) | Creates a new PropertySetElement to contain the given asset.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Creates a duplicate of this PropertySetElement.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetStructuralAsset | Gets a copy of the StructuralAsset.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetThermalAsset | Gets a copy of the ThermalAsset.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetStructuralAsset | Sets a copy of the given StucturalAsset to be used in the PropertySetElement.
Public method | SetThermalAsset | Sets a copy of the given ThermalAsset to be used in the PropertySetElement.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PropertySetElement Class


Create Method

[image] [image]

Revit 2024 API
PropertySetElement..::..Create Method
PropertySetElement Class See Also Send Feedback

Overload List

Name | Description
Create(Document, StructuralAsset) | Creates a new PropertySetElement to contain the given asset.
Create(Document, ThermalAsset) | Creates a new PropertySetElement to contain the given asset.

See Also

PropertySetElement Class
PropertySetElement Members


Create Method (Document, StructuralAsset)

[image]

Revit 2024 API
PropertySetElement..::..Create Method (Document, StructuralAsset)
PropertySetElement Class See Also Send Feedback
Creates a new PropertySetElement to contain the given asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static PropertySetElement Create(
    Document document,
    StructuralAsset structuralAsset
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    structuralAsset As StructuralAsset _
) As PropertySetElement
Visual C++
public:
static PropertySetElement^ Create(
    Document^ document,
    StructuralAsset^ structuralAsset
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which to create the PropertySetElement.
structuralAsset
Type: Autodesk.Revit.DB..::..StructuralAsset
The structural asset containing the values that will be present in the PropertySetElement.

Return Value

The new PropertySetElement.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the name of the asset is empty, contains prohibited characters, or is not unique
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

PropertySetElement Class
Create Overload


Duplicate Method

[image]

Revit 2024 API
PropertySetElement..::..Duplicate Method
PropertySetElement Class See Also Send Feedback
Creates a duplicate of this PropertySetElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public PropertySetElement Duplicate(
    Document document,
    string name
)
Visual Basic
Public Function Duplicate ( _
    document As Document, _
    name As String _
) As PropertySetElement
Visual C++
public:
PropertySetElement^ Duplicate(
    Document^ document,
    String^ name
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which to create the PropertySetElement.
name
Type: System..::..String
The name to use for the new PropertySetElement.

Return Value

The new PropertySetElement.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for name is already in use as a property set name. -or- name is an empty string. -or- name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~".
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

PropertySetElement Class


GetStructuralAsset Method

[image]

Revit 2024 API
PropertySetElement..::..GetStructuralAsset Method
PropertySetElement Class Example See Also Send Feedback
Gets a copy of the StructuralAsset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public StructuralAsset GetStructuralAsset()
Visual Basic
Public Function GetStructuralAsset As StructuralAsset
Visual C++
public:
StructuralAsset^ GetStructuralAsset()

Examples

CopyC#
private void ReadMaterialProps(Document document, Material material)
{
   ElementId strucAssetId = material.StructuralAssetId;
   if (strucAssetId != ElementId.InvalidElementId)
   {
      PropertySetElement pse = document.GetElement(strucAssetId) as PropertySetElement;
      if (pse != null)
      {
         StructuralAsset asset = pse.GetStructuralAsset();

         // Check the material behavior and only read if Isotropic
         if (asset.Behavior == StructuralBehavior.Isotropic)
         {
            // Get the class of material
            StructuralAssetClass assetClass = asset.StructuralAssetClass;

            // Get other material properties
            double poisson = asset.PoissonRatio.X;
            double youngMod = asset.YoungModulus.X;
            double thermCoeff = asset.ThermalExpansionCoefficient.X;
            double unitweight = asset.Density;
            double shearMod = asset.ShearModulus.X;

            if (assetClass == StructuralAssetClass.Metal)
            {
               double dMinStress = asset.MinimumYieldStress;
            }
            else if (assetClass == StructuralAssetClass.Concrete)
            {
               double dConcComp = asset.ConcreteCompression;
            }
         }
      }
   }
}
CopyVB.NET
Private Sub ReadMaterialProps(document As Document, material As Material)
    Dim strucAssetId As ElementId = material.StructuralAssetId
    If strucAssetId <> ElementId.InvalidElementId Then
        Dim pse As PropertySetElement = TryCast(document.GetElement(strucAssetId), PropertySetElement)
        If pse IsNot Nothing Then
            Dim asset As StructuralAsset = pse.GetStructuralAsset()

            ' Check the material behavior and only read if Isotropic
            If asset.Behavior = StructuralBehavior.Isotropic Then
                ' Get the class of material
                Dim assetClass As StructuralAssetClass = asset.StructuralAssetClass

                ' Get other material properties
                Dim poisson As Double = asset.PoissonRatio.X
                Dim youngMod As Double = asset.YoungModulus.X
                Dim thermCoeff As Double = asset.ThermalExpansionCoefficient.X
                Dim unitweight As Double = asset.Density
                Dim shearMod As Double = asset.ShearModulus.X

                If assetClass = StructuralAssetClass.Metal Then
                    Dim dMinStress As Double = asset.MinimumYieldStress
                ElseIf assetClass = StructuralAssetClass.Concrete Then
                    Dim dConcComp As Double = asset.ConcreteCompression
                End If
            End If
        End If
    End If
End Sub

See Also

PropertySetElement Class


GetThermalAsset Method

[image]

Revit 2024 API
PropertySetElement..::..GetThermalAsset Method
PropertySetElement Class Example See Also Send Feedback
Gets a copy of the ThermalAsset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public ThermalAsset GetThermalAsset()
Visual Basic
Public Function GetThermalAsset As ThermalAsset
Visual C++
public:
ThermalAsset^ GetThermalAsset()

Examples

CopyC#
private void ReadMaterialThermalProps(Document document, Material material)
{
   ElementId thermalAssetId = material.ThermalAssetId;
   if (thermalAssetId != ElementId.InvalidElementId)
   {
      PropertySetElement pse = document.GetElement(thermalAssetId) as PropertySetElement;
      if (pse != null)
      {
         ThermalAsset asset = pse.GetThermalAsset();

         // Check the thermal material type and only read if solid
         if (asset.ThermalMaterialType == ThermalMaterialType.Solid)
         {

            // Get the properties which are supported in solid type
            bool isTransmitsLight = asset.TransmitsLight;
            double permeability = asset.Permeability;
            double porosity = asset.Porosity;
            double reflectivity = asset.Reflectivity;
            double resistivity = asset.ElectricalResistivity;
            StructuralBehavior behavior = asset.Behavior;

            // Get the other properties.
            double heatOfVaporization = asset.SpecificHeatOfVaporization;
            double emissivity = asset.Emissivity;
            double conductivity = asset.ThermalConductivity;
            double density = asset.Density;
         }
      }
   }
}
CopyVB.NET
Private Sub ReadMaterialThermalProps(document As Document, material As Material)
    Dim thermalAssetId As ElementId = material.ThermalAssetId
    If thermalAssetId <> ElementId.InvalidElementId Then
        Dim pse As PropertySetElement = TryCast(document.GetElement(thermalAssetId), PropertySetElement)
        If pse IsNot Nothing Then
            Dim asset As ThermalAsset = pse.GetThermalAsset()

            ' Check the thermal material type and only read if solid
            If asset.ThermalMaterialType = ThermalMaterialType.Solid Then

                ' Get the properties which are supported in solid type
                Dim isTransmitsLight As Boolean = asset.TransmitsLight
                Dim permeability As Double = asset.Permeability
                Dim porosity As Double = asset.Porosity
                Dim reflectivity As Double = asset.Reflectivity
                Dim resistivity As Double = asset.ElectricalResistivity
                Dim behavior As StructuralBehavior = asset.Behavior

                ' Get the other properties.
                Dim heatOfVaporization As Double = asset.SpecificHeatOfVaporization
                Dim emissivity As Double = asset.Emissivity
                Dim conductivity As Double = asset.ThermalConductivity
                Dim density As Double = asset.Density
            End If
        End If
    End If
End Sub

See Also

PropertySetElement Class


SetStructuralAsset Method

[image]

Revit 2024 API
PropertySetElement..::..SetStructuralAsset Method
PropertySetElement Class See Also Send Feedback
Sets a copy of the given StucturalAsset to be used in the PropertySetElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public void SetStructuralAsset(
    StructuralAsset structuralAsset
)
Visual Basic
Public Sub SetStructuralAsset ( _
    structuralAsset As StructuralAsset _
)
Visual C++
public:
void SetStructuralAsset(
    StructuralAsset^ structuralAsset
)

Parameters

structuralAsset
Type: Autodesk.Revit.DB..::..StructuralAsset

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the name of the asset is empty, contains prohibited characters, or is not unique
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

PropertySetElement Class


SetThermalAsset Method

[image]

Revit 2024 API
PropertySetElement..::..SetThermalAsset Method
PropertySetElement Class See Also Send Feedback
Sets a copy of the given ThermalAsset to be used in the PropertySetElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public void SetThermalAsset(
    ThermalAsset thermalAsset
)
Visual Basic
Public Sub SetThermalAsset ( _
    thermalAsset As ThermalAsset _
)
Visual C++
public:
void SetThermalAsset(
    ThermalAsset^ thermalAsset
)

Parameters

thermalAsset
Type: Autodesk.Revit.DB..::..ThermalAsset

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the name of the asset is empty, contains prohibited characters, or is not unique
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

PropertySetElement Class


PropertySetElement Properties

[image] [image]

Revit 2024 API
PropertySetElement Properties
PropertySetElement Class See Also Send Feedback

The PropertySetElement type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PropertySetElement Class


PropOverrideMode Enumeration

[image]

Revit 2024 API
PropOverrideMode Enumeration
See Also Send Feedback
An enumerated type listing ways how overridden object styles get exported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum PropOverrideMode
Visual Basic
Public Enumeration PropOverrideMode
Visual C++
public enum class PropOverrideMode

Members

Member name | Description
ByEntity | Category properties BYLAYER, overrides BYENTITY. Entities generated by a specific category are assigned to a layer accordingly to the layer settings. To preserve visual fidelity, overridden attributes result in entity-specific attributes
ByLayer | All properties BYLAYER, no overrides Forces all entities to follow visual properties as set by their layer. Visual fidelity is lost, but this produces the least number of layers while still providing by-layer control over exported entities.
NewLayer | All properties BYLAYER, New Layers for overrides. Visual fidelity is preserved and there is by-layer control over all entities, although number of layers in the exported file might be increased.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


RadialArray Class

[image]

Revit 2024 API
RadialArray Class
Members See Also Send Feedback
An object that represents an Array created along a circle arc within the Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class RadialArray : BaseArray
Visual Basic
Public Class RadialArray _
    Inherits BaseArray
Visual C++
public ref class RadialArray : public BaseArray

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..BaseArray
Autodesk.Revit.DB..::..RadialArray

See Also

RadialArray Members


RadialArray Methods

[image] [image]

Revit 2024 API
RadialArray Methods
RadialArray Class See Also Send Feedback

The RadialArray type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
 | ArrayElementsWithoutAssociation | Creates a new radial array from a set of elements based on an input rotation axis.
 | ArrayElementWithoutAssociation | Creates a new radial array from a single element based on an input rotation axis.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create(Document, View, ElementId, Int32, Line, Double, ArrayAnchorMember) | Creates a new radial array element from a single element based on an input rotation axis.
 | Create(Document, View, ICollection<(Of <<'(ElementId>)>>), Int32, Line, Double, ArrayAnchorMember) | Creates a new radial array element from a set of elements based on an input rotation axis.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetCopiedMemberIds | Retrieves the copied member Ids of the Array. (Overrides BaseArray..::..GetCopiedMemberIds()()()().)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetOriginalMemberIds | Retrieves the original member Ids of the Array. (Overrides BaseArray..::..GetOriginalMemberIds()()()().)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
 | IsRotationAngleValid | This indicates whether the input angle is valid.
 | IsValidArraySize | This indicates whether the input count is valid.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RadialArray Class


ArrayElementsWithoutAssociation Method

[image]

Revit 2024 API
RadialArray..::..ArrayElementsWithoutAssociation Method
RadialArray Class See Also Send Feedback
Creates a new radial array from a set of elements based on an input rotation axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ICollection<ElementId> ArrayElementsWithoutAssociation(
    Document aDoc,
    View dBView,
    ICollection<ElementId> ids,
    int count,
    Line axis,
    double angle,
    ArrayAnchorMember anchorMember
)
Visual Basic
Public Shared Function ArrayElementsWithoutAssociation ( _
    aDoc As Document, _
    dBView As View, _
    ids As ICollection(Of ElementId), _
    count As Integer, _
    axis As Line, _
    angle As Double, _
    anchorMember As ArrayAnchorMember _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ ArrayElementsWithoutAssociation(
    Document^ aDoc,
    View^ dBView,
    ICollection<ElementId^>^ ids,
    int count,
    Line^ axis,
    double angle,
    ArrayAnchorMember anchorMember
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
The document.
dBView
Type: Autodesk.Revit.DB..::..View
The view. If it is a 2d view, translation vector must be in the view plane if elements include view-specific elements. If elements include view-specific elements, they must belong to this view.
ids
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
The set of elements to array. The position of the rotation axis is determined by the cumulative center of the elements' bounding boxes.
count
Type: System..::..Int32
The number of array members to create. The accepted range is from 3 to 200.
axis
Type: Autodesk.Revit.DB..::..Line
The rotation axis.
angle
Type: System..::..Double
The angle in radians of the rotation.
anchorMember
Type: Autodesk.Revit.DB..::..ArrayAnchorMember
Indicates if the translation vector specifies the location of the second member of the array, or the last member of the array.

Return Value

The elements created by the operation.

Remarks

The resulting elements will not be associated with an array element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given element id set is empty. -or- One or more elements in ids do not exist in the document. -or- One or more elements in ids is owned by different views and thus cannot be arrayed together. -or- One or more elements in ids is not arrayable. -or- count must be between 3 and 200. -or- The view is invalid for specific view elements array. -or- The rotation axis is invalid to array the elements. -or- Angle value must be not zero.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | Failed to create the radial array.

See Also

RadialArray Class


ArrayElementWithoutAssociation Method

[image]

Revit 2024 API
RadialArray..::..ArrayElementWithoutAssociation Method
RadialArray Class See Also Send Feedback
Creates a new radial array from a single element based on an input rotation axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ICollection<ElementId> ArrayElementWithoutAssociation(
    Document aDoc,
    View dBView,
    ElementId id,
    int count,
    Line axis,
    double angle,
    ArrayAnchorMember anchorMember
)
Visual Basic
Public Shared Function ArrayElementWithoutAssociation ( _
    aDoc As Document, _
    dBView As View, _
    id As ElementId, _
    count As Integer, _
    axis As Line, _
    angle As Double, _
    anchorMember As ArrayAnchorMember _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ ArrayElementWithoutAssociation(
    Document^ aDoc,
    View^ dBView,
    ElementId^ id,
    int count,
    Line^ axis,
    double angle,
    ArrayAnchorMember anchorMember
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
The view. If it is a 2d view, translation vector must be in the view plane if the element is a view-specific element.
dBView
Type: Autodesk.Revit.DB..::..View
The view.
id
Type: Autodesk.Revit.DB..::..ElementId
The element to array. The position of the rotation axis is determined by the center of the element's bounding boxes.
count
Type: System..::..Int32
The number of array members to create. The accepted range is from 3 to 200.
axis
Type: Autodesk.Revit.DB..::..Line
The rotation axis.
angle
Type: System..::..Double
The angle in radians of the rotation.
anchorMember
Type: Autodesk.Revit.DB..::..ArrayAnchorMember
Indicates if the translation vector specifies the location of the second member of the array, or the last member of the array.

Return Value

The elements created by the operation.

Remarks

The resulting elements will not be associated with an array element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element id does not exist in the document -or- id is not arrayable. -or- count must be between 3 and 200. -or- The view is invalid for specific view elements array. -or- The rotation axis is invalid to array the element. -or- Angle value must be not zero.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | Failed to create the radial array.

See Also

RadialArray Class


Create Method

[image] [image]

Revit 2024 API
RadialArray..::..Create Method
RadialArray Class See Also Send Feedback

Overload List

Name | Description
Create(Document, View, ElementId, Int32, Line, Double, ArrayAnchorMember) | Creates a new radial array element from a single element based on an input rotation axis.
Create(Document, View, ICollection<(Of <<'(ElementId>)>>), Int32, Line, Double, ArrayAnchorMember) | Creates a new radial array element from a set of elements based on an input rotation axis.

See Also

RadialArray Class
RadialArray Members


Create Method (Document, View, ElementId, Int32, Line, Double, ArrayAnchorMember)

[image]

Revit 2024 API
RadialArray..::..Create Method (Document, View, ElementId, Int32, Line, Double, ArrayAnchorMember)
RadialArray Class See Also Send Feedback
Creates a new radial array element from a single element based on an input rotation axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static RadialArray Create(
    Document aDoc,
    View dBView,
    ElementId id,
    int count,
    Line axis,
    double angle,
    ArrayAnchorMember anchorMember
)
Visual Basic
Public Shared Function Create ( _
    aDoc As Document, _
    dBView As View, _
    id As ElementId, _
    count As Integer, _
    axis As Line, _
    angle As Double, _
    anchorMember As ArrayAnchorMember _
) As RadialArray
Visual C++
public:
static RadialArray^ Create(
    Document^ aDoc,
    View^ dBView,
    ElementId^ id,
    int count,
    Line^ axis,
    double angle,
    ArrayAnchorMember anchorMember
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
The document.
dBView
Type: Autodesk.Revit.DB..::..View
The view. If it is a 2d view, translation vector must be in the view plane if the element is a view-specific element.
id
Type: Autodesk.Revit.DB..::..ElementId
The element to array. The position of the rotation axis is determined by the center of the element's bounding boxes.
count
Type: System..::..Int32
The number of array members to create. The accepted range is from 3 to 200.
axis
Type: Autodesk.Revit.DB..::..Line
The rotation axis.
angle
Type: System..::..Double
The angle in radians of the rotation.
anchorMember
Type: Autodesk.Revit.DB..::..ArrayAnchorMember
Indicates if the translation vector specifies the location of the second member of the array, or the last member of the array.

Return Value

The new radial array element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element id does not exist in the document -or- id is not arrayable. -or- count must be between 3 and 200. -or- The view is invalid for specific view elements array. -or- The rotation axis is invalid to array the element. -or- Angle value must be not zero.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | Failed to create the radial array.

See Also

RadialArray Class
Create Overload


Create Method (Document, View, ICollection(ElementId), Int32, Line, Double, ArrayAnchorMember)

[image]

Revit 2024 API
RadialArray..::..Create Method (Document, View, ICollection<(Of <(<'ElementId>)>)>, Int32, Line, Double, ArrayAnchorMember)
RadialArray Class See Also Send Feedback
Creates a new radial array element from a set of elements based on an input rotation axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static RadialArray Create(
    Document aDoc,
    View dBView,
    ICollection<ElementId> ids,
    int count,
    Line axis,
    double angle,
    ArrayAnchorMember anchorMember
)
Visual Basic
Public Shared Function Create ( _
    aDoc As Document, _
    dBView As View, _
    ids As ICollection(Of ElementId), _
    count As Integer, _
    axis As Line, _
    angle As Double, _
    anchorMember As ArrayAnchorMember _
) As RadialArray
Visual C++
public:
static RadialArray^ Create(
    Document^ aDoc,
    View^ dBView,
    ICollection<ElementId^>^ ids,
    int count,
    Line^ axis,
    double angle,
    ArrayAnchorMember anchorMember
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
The document.
dBView
Type: Autodesk.Revit.DB..::..View
The view. If it is a 2d view, translation vector must be in the view plane if elements include view-specific elements. If elements include view-specific elements, they must belong to this view.
ids
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
The set of elements to array. The position of the rotation axis is determined by the cumulative center of the elements' bounding boxes.
count
Type: System..::..Int32
The number of array members to create. The accepted range is from 3 to 200.
axis
Type: Autodesk.Revit.DB..::..Line
The rotation axis.
angle
Type: System..::..Double
The angle in radians of the rotation.
anchorMember
Type: Autodesk.Revit.DB..::..ArrayAnchorMember
Indicates if the translation vector specifies the location of the second member of the array, or the last member of the array.

Return Value

The new radial array element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given element id set is empty. -or- One or more elements in ids do not exist in the document. -or- One or more elements in ids is owned by different views and thus cannot be arrayed together. -or- One or more elements in ids is not arrayable. -or- count must be between 3 and 200. -or- The view is invalid for specific view elements array. -or- The rotation axis is invalid to array the elements. -or- Angle value must be not zero.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | Failed to create the radial array.

See Also

RadialArray Class
Create Overload


GetOriginalMemberIds Method

[image]

Revit 2024 API
RadialArray..::..GetOriginalMemberIds Method
RadialArray Class See Also Send Feedback
Retrieves the original member Ids of the Array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public override ICollection<ElementId> GetOriginalMemberIds()
Visual Basic
Public Overrides Function GetOriginalMemberIds As ICollection(Of ElementId)
Visual C++
public:
virtual ICollection<ElementId^>^ GetOriginalMemberIds() override

Return Value

The original member Ids of the Array

See Also

RadialArray Class


IsRotationAngleValid Method

[image]

Revit 2024 API
RadialArray..::..IsRotationAngleValid Method
RadialArray Class See Also Send Feedback
This indicates whether the input angle is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static bool IsRotationAngleValid(
    double angle
)
Visual Basic
Public Shared Function IsRotationAngleValid ( _
    angle As Double _
) As Boolean
Visual C++
public:
static bool IsRotationAngleValid(
    double angle
)

Parameters

angle
Type: System..::..Double
The angle.

Return Value

True if the value of angle is not zero, false otherwise.

See Also

RadialArray Class


IsValidArraySize Method

[image]

Revit 2024 API
RadialArray..::..IsValidArraySize Method
RadialArray Class See Also Send Feedback
This indicates whether the input count is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static bool IsValidArraySize(
    int count
)
Visual Basic
Public Shared Function IsValidArraySize ( _
    count As Integer _
) As Boolean
Visual C++
public:
static bool IsValidArraySize(
    int count
)

Parameters

count
Type: System..::..Int32
The count.

Return Value

True if the input count is between 3 and 200, false otherwise.

See Also

RadialArray Class


RadialArray Properties

[image] [image]

Revit 2024 API
RadialArray Properties
RadialArray Class See Also Send Feedback

The RadialArray type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | Label | The family parameter label of the BaseArray. (Inherited from BaseArray.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Get and Set the Name property (Inherited from BaseArray.)
Public property | NumMembers | Retrieves or changes the number of the arrayed members. (Overrides BaseArray..::..NumMembers.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

RadialArray Class


Parameter Property

[image] [image]

Revit 2024 API
RadialArray..::..Parameter Property
RadialArray Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

RadialArray Class
RadialArray Members


RasterQualityType Enumeration

[image]

Revit 2024 API
RasterQualityType Enumeration
See Also Send Feedback
An enumerated type listing the options for raster quality.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum RasterQualityType
Visual Basic
Public Enumeration RasterQualityType
Visual C++
public enum class RasterQualityType

Members

Member name | Description
Low | The type of Raster Quality is Low.
Medium | The type of Raster Quality is Medium.
High | The type of Raster Quality is High.
Presentation | The type of Raster Quality is Presentation.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


Rectangle Class

[image]

Revit 2024 API
Rectangle Class
Members See Also Send Feedback
Stores a set of four integers that represent the left, top, right and bottom of a rectangle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class Rectangle : IDisposable
Visual Basic
Public Class Rectangle _
    Implements IDisposable
Visual C++
public ref class Rectangle : IDisposable

Remarks

It usually represents a rectangle on the screen. Left must be less than right and top must be less than bottom.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Rectangle

See Also

Rectangle Members


Rectangle Members

[image] [image]

Revit 2024 API
Rectangle Members
Rectangle Class Constructors Methods Properties See Also Send Feedback

The Rectangle type exposes the following members.

Constructors

 | Name | Description
Public method | Rectangle()()()() | Create an empty Rectangle instance with values (0,0,0,0).
Public method | Rectangle(Rectangle) | Constructs a new copy of the input ScreenRectangle object.
Public method | Rectangle(Int32, Int32, Int32, Int32) | Creates an Rectangle instance with the specified four integers that represent the left, top, right and bottom of a rectangle.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the Rectangle
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsNormalized | Returns true if the rectangle coordinates are normalized to the screen coordinate space; that is, left is less than right and top is less than bottom.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Bottom | The y-coordinate of the bottom-right corner of the rectangle.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Left | The x-coordinate of the top-left corner of the rectangle.
Public property | Right | The x-coordinate of the bottom-right corner of the rectangle.
Public property | Top | The y-coordinate of the top-left corner of the rectangle.

See Also

Rectangle Class


Rectangle Constructor

[image] [image]

Revit 2024 API
Rectangle Constructor
Rectangle Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Rectangle()()()() | Create an empty Rectangle instance with values (0,0,0,0).
Public method | Rectangle(Rectangle) | Constructs a new copy of the input ScreenRectangle object.
Public method | Rectangle(Int32, Int32, Int32, Int32) | Creates an Rectangle instance with the specified four integers that represent the left, top, right and bottom of a rectangle.

See Also

Rectangle Class
Rectangle Members


Rectangle Constructor

[image]

Revit 2024 API
Rectangle Constructor
Rectangle Class See Also Send Feedback
Create an empty Rectangle instance with values (0,0,0,0).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public Rectangle()
Visual Basic
Public Sub New
Visual C++
public:
Rectangle()

See Also

Rectangle Class
Rectangle Overload


Rectangle Constructor (Rectangle)

[image]

Revit 2024 API
Rectangle Constructor (Rectangle)
Rectangle Class See Also Send Feedback
Constructs a new copy of the input ScreenRectangle object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public Rectangle(
    Rectangle other
)
Visual Basic
Public Sub New ( _
    other As Rectangle _
)
Visual C++
public:
Rectangle(
    Rectangle^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..Rectangle

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Rectangle Class
Rectangle Overload


Rectangle Constructor (Int32, Int32, Int32, Int32)

[image]

Revit 2024 API
Rectangle Constructor (Int32, Int32, Int32, Int32)
Rectangle Class See Also Send Feedback
Creates an Rectangle instance with the specified four integers that represent the left, top, right and bottom of a rectangle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public Rectangle(
    int left,
    int top,
    int right,
    int bottom
)
Visual Basic
Public Sub New ( _
    left As Integer, _
    top As Integer, _
    right As Integer, _
    bottom As Integer _
)
Visual C++
public:
Rectangle(
    int left,
    int top,
    int right,
    int bottom
)

Parameters

left
Type: System..::..Int32
The x-coordinate of the top-left corner.
top
Type: System..::..Int32
The y-coordinate of the top-left corner.
right
Type: System..::..Int32
The x-coordinate of the bottom-right corner.
bottom
Type: System..::..Int32
The y-coordinate of the bottom-right corner.

See Also

Rectangle Class
Rectangle Overload


Rectangle Methods

[image] [image]

Revit 2024 API
Rectangle Methods
Rectangle Class See Also Send Feedback

The Rectangle type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsNormalized | Returns true if the rectangle coordinates are normalized to the screen coordinate space; that is, left is less than right and top is less than bottom.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Rectangle Class


Dispose Method

[image]

Revit 2024 API
Rectangle..::..Dispose Method
Rectangle Class See Also Send Feedback
Releases all resources used by the Rectangle

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

Rectangle Class


IsNormalized Method

[image]

Revit 2024 API
Rectangle..::..IsNormalized Method
Rectangle Class See Also Send Feedback
Returns true if the rectangle coordinates are normalized to the screen coordinate space; that is, left is less than right and top is less than bottom.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsNormalized()
Visual Basic
Public Function IsNormalized As Boolean
Visual C++
public:
bool IsNormalized()

See Also

Rectangle Class


Rectangle Properties

[image] [image]

Revit 2024 API
Rectangle Properties
Rectangle Class See Also Send Feedback

The Rectangle type exposes the following members.

Properties

 | Name | Description
Public property | Bottom | The y-coordinate of the bottom-right corner of the rectangle.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Left | The x-coordinate of the top-left corner of the rectangle.
Public property | Right | The x-coordinate of the bottom-right corner of the rectangle.
Public property | Top | The y-coordinate of the top-left corner of the rectangle.

See Also

Rectangle Class


IsValidObject Property

[image]

Revit 2024 API
Rectangle..::..IsValidObject Property
Rectangle Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

Rectangle Class


Left Property

[image]

Revit 2024 API
Rectangle..::..Left Property
Rectangle Class See Also Send Feedback
The x-coordinate of the top-left corner of the rectangle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public int Left { get; set; }
Visual Basic
Public Property Left As Integer
    Get
    Set
Visual C++
public:
property int Left {
    int get ();
    void set (int value);
}

See Also

Rectangle Class


Top Property

[image]

Revit 2024 API
Rectangle..::..Top Property
Rectangle Class See Also Send Feedback
The y-coordinate of the top-left corner of the rectangle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public int Top { get; set; }
Visual Basic
Public Property Top As Integer
    Get
    Set
Visual C++
public:
property int Top {
    int get ();
    void set (int value);
}

See Also

Rectangle Class


Reference Members

[image] [image]

Revit 2024 API
Reference Members
Reference Class Constructors Methods Properties See Also Send Feedback

The Reference type exposes the following members.

Constructors

 | Name | Description
Public method | Reference | Creates a Reference with the supplied element.

Methods

 | Name | Description
Public method | Contains | Checks if given reference identifies part of object identified by this reference.
Public method | ConvertToStableRepresentation | Converts the reference to a stable String representation.
Public method | CreateLinkReference | Creates a Reference from a Reference in an RVT Link.
Public method | CreateReferenceInLink | Creates a Reference in an RVT Link from a Reference in the RVT host file.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EqualTo | Checks if given reference is equal to this reference.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | ParseFromStableRepresentation | Converts a stable String representation of a reference to a Reference object.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ElementId | The element id for this reference.
Public property | ElementReferenceType | The type of reference.
Public property | GlobalPoint | The position on which the reference is hit.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | LinkedElementId | The id of the top-level element in the linked document that is referred to by this reference.
Public property | UVPoint | The UV parameters of the reference, if the reference contains a face.

See Also

Reference Class


Reference Methods

[image] [image]

Revit 2024 API
Reference Methods
Reference Class See Also Send Feedback

The Reference type exposes the following members.

Methods

 | Name | Description
Public method | Contains | Checks if given reference identifies part of object identified by this reference.
Public method | ConvertToStableRepresentation | Converts the reference to a stable String representation.
Public method | CreateLinkReference | Creates a Reference from a Reference in an RVT Link.
Public method | CreateReferenceInLink | Creates a Reference in an RVT Link from a Reference in the RVT host file.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EqualTo | Checks if given reference is equal to this reference.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | ParseFromStableRepresentation | Converts a stable String representation of a reference to a Reference object.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Reference Class


Contains Method

[image]

Revit 2024 API
Reference..::..Contains Method
Reference Class See Also Send Feedback
Checks if given reference identifies part of object identified by this reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public bool Contains(
    Reference reference
)
Visual Basic
Public Function Contains ( _
    reference As Reference _
) As Boolean
Visual C++
public:
bool Contains(
    Reference^ reference
)

Parameters

reference
Type: Autodesk.Revit.DB..::..Reference
Another reference.

Return Value

Returns true if given reference identifies part of object identified by this reference, false otherwise.

Remarks

Can be used to check:
  • If given Reference is a part of a particular Subelement identified by this Reference.
  • If given Reference is a part of a particular Element identified by this Reference.
The input reference can refer to a subelement or a specific geometric item from an element or subelement.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when argument is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Reference Class


ConvertToStableRepresentation Method

[image]

Revit 2024 API
Reference..::..ConvertToStableRepresentation Method
Reference Class Example See Also Send Feedback
Converts the reference to a stable String representation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string ConvertToStableRepresentation(
    Document document
)
Visual Basic
Public Function ConvertToStableRepresentation ( _
    document As Document _
) As String
Visual C++
public:
String^ ConvertToStableRepresentation(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.

Remarks

The stable representation can be used to preserve and restore the reference later in the same Revit session or even in a different session where the same document is present. Use ParseFromStableRepresentation(Document, String) to restore the reference. The representation is based on the internal Revit structure and is not intended to be parsed expect by ParseFromStableRepresentation(Document, String).

Examples

CopyC#
public string SerializeReference(Document doc, Reference reference)
{
    String ids = String.Empty;
    ids = reference.ConvertToStableRepresentation(doc);
    TaskDialog.Show("SerializeReference", "Representation:\n" + ids);
    return ids;
}
CopyVB.NET
Public Function SerializeReference(doc As Document, reference As Reference) As String
    Dim ids As [String] = [String].Empty
    ids = reference.ConvertToStableRepresentation(doc)
    TaskDialog.Show("SerializeReference", "Representation:" & vbLf + ids)
    Return ids
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | document was nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidObjectException | Reference contained element ids not found in this document.

See Also

Reference Class


CreateLinkReference Method

[image]

Revit 2024 API
Reference..::..CreateLinkReference Method
Reference Class See Also Send Feedback
Creates a Reference from a Reference in an RVT Link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public Reference CreateLinkReference(
    RevitLinkInstance revitLinkInstance
)
Visual Basic
Public Function CreateLinkReference ( _
    revitLinkInstance As RevitLinkInstance _
) As Reference
Visual C++
public:
Reference^ CreateLinkReference(
    RevitLinkInstance^ revitLinkInstance
)

Parameters

revitLinkInstance
Type: Autodesk.Revit.DB..::..RevitLinkInstance
Id of the RevitLinkInstance that contains the reference.

Remarks

The reference that is returned can be used to create a family instance on a face in an RVT link.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when revitLinkInstance is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Reference Class


CreateReferenceInLink Method

[image]

Revit 2024 API
Reference..::..CreateReferenceInLink Method
Reference Class See Also Send Feedback
Creates a Reference in an RVT Link from a Reference in the RVT host file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public Reference CreateReferenceInLink()
Visual Basic
Public Function CreateReferenceInLink As Reference
Visual C++
public:
Reference^ CreateReferenceInLink()

See Also

Reference Class


Reference Properties

[image] [image]

Revit 2024 API
Reference Properties
Reference Class See Also Send Feedback

The Reference type exposes the following members.

Properties

 | Name | Description
Public property | ElementId | The element id for this reference.
Public property | ElementReferenceType | The type of reference.
Public property | GlobalPoint | The position on which the reference is hit.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | LinkedElementId | The id of the top-level element in the linked document that is referred to by this reference.
Public property | UVPoint | The UV parameters of the reference, if the reference contains a face.

See Also

Reference Class


ElementId Property

[image]

Revit 2024 API
Reference..::..ElementId Property
Reference Class See Also Send Feedback
The element id for this reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public ElementId ElementId { get; }
Visual Basic
Public ReadOnly Property ElementId As ElementId
    Get
Visual C++
public:
property ElementId^ ElementId {
    ElementId^ get ();
}

Remarks

InvalidElementId will be returned for references that don't refer to a particular element.

See Also

Reference Class


ElementReferenceType Property

[image]

Revit 2024 API
Reference..::..ElementReferenceType Property
Reference Class See Also Send Feedback
The type of reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElementReferenceType ElementReferenceType { get; }
Visual Basic
Public ReadOnly Property ElementReferenceType As ElementReferenceType
    Get
Visual C++
public:
property ElementReferenceType ElementReferenceType {
    ElementReferenceType get ();
}

See Also

Reference Class


GlobalPoint Property

[image]

Revit 2024 API
Reference..::..GlobalPoint Property
Reference Class See Also Send Feedback
The position on which the reference is hit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ GlobalPoint { get; }
Visual Basic
Public ReadOnly Property GlobalPoint As XYZ
    Get
Visual C++
public:
property XYZ^ GlobalPoint {
    XYZ^ get ();
}

Return Value

nullNothingnullptra null reference (Nothing in Visual Basic) if the reference doesn't have a global point.

Remarks

When using a plan view, the Z-value of a GlobalPoint is not meaningful.

See Also

Reference Class


LinkedElementId Property

[image]

Revit 2024 API
Reference..::..LinkedElementId Property
Reference Class See Also Send Feedback
The id of the top-level element in the linked document that is referred to by this reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ElementId LinkedElementId { get; }
Visual Basic
Public ReadOnly Property LinkedElementId As ElementId
    Get
Visual C++
public:
property ElementId^ LinkedElementId {
    ElementId^ get ();
}

Remarks

InvalidElementId will be returned for references that don't refer to an element in a linked RVT file.

See Also

Reference Class


UVPoint Property

[image]

Revit 2024 API
Reference..::..UVPoint Property
Reference Class See Also Send Feedback
The UV parameters of the reference, if the reference contains a face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public UV UVPoint { get; }
Visual Basic
Public ReadOnly Property UVPoint As UV
    Get
Visual C++
public:
property UV^ UVPoint {
    UV^ get ();
}

Remarks

This value is valid only for references of type REFERENCE_TYPE_SURFACE. It is nullNothingnullptra null reference (Nothing in Visual Basic) for all other types.

See Also

Reference Class


ReferenceableViewUtils Class

[image]

Revit 2024 API
ReferenceableViewUtils Class
Members See Also Send Feedback
Utilities related to reference views such as reference sections and reference callouts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static class ReferenceableViewUtils
Visual Basic
Public NotInheritable Class ReferenceableViewUtils
Visual C++
public ref class ReferenceableViewUtils abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ReferenceableViewUtils

See Also

ReferenceableViewUtils Members


GetReferencedViewId Method

[image]

Revit 2024 API
ReferenceableViewUtils..::..GetReferencedViewId Method
ReferenceableViewUtils Class See Also Send Feedback
Gets the id of the view referenced by a reference view (such as a reference section or reference callout).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static ElementId GetReferencedViewId(
    Document document,
    ElementId referenceId
)
Visual Basic
Public Shared Function GetReferencedViewId ( _
    document As Document, _
    referenceId As ElementId _
) As ElementId
Visual C++
public:
static ElementId^ GetReferencedViewId(
    Document^ document,
    ElementId^ referenceId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document containing the elements.
referenceId
Type: Autodesk.Revit.DB..::..ElementId
The reference view that will be changed to refer to a different View.

Return Value

The id of the referenced view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | referenceId is not a valid reference view.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ReferenceableViewUtils Class


ReferenceArray Class

[image]

Revit 2024 API
ReferenceArray Class
Members See Also Send Feedback
An array that contains reference objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class ReferenceArray : APIObject,
    IEnumerable
Visual Basic
Public Class ReferenceArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ReferenceArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..ReferenceArray

See Also

ReferenceArray Members


ReferenceArray Methods

[image] [image]

Revit 2024 API
ReferenceArray Methods
ReferenceArray Class See Also Send Feedback

The ReferenceArray type exposes the following members.

Methods

 | Name | Description
Public method | Append | Add the reference to the end of the array.
Public method | Clear | Removes every reference from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified reference into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ReferenceArray Class


Append Method

[image]

Revit 2024 API
ReferenceArray..::..Append Method
ReferenceArray Class See Also Send Feedback
Add the reference to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Append(
    Reference item
)
Visual Basic
Public Overridable Sub Append ( _
    item As Reference _
)
Visual C++
public:
virtual void Append(
    Reference^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..Reference
The reference to be added.

See Also

ReferenceArray Class


Clear Method

[image]

Revit 2024 API
ReferenceArray..::..Clear Method
ReferenceArray Class See Also Send Feedback
Removes every reference from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ReferenceArray Class


ForwardIterator Method

[image]

Revit 2024 API
ReferenceArray..::..ForwardIterator Method
ReferenceArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual ReferenceArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As ReferenceArrayIterator
Visual C++
public:
virtual ReferenceArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

ReferenceArray Class


GetEnumerator Method

[image]

Revit 2024 API
ReferenceArray..::..GetEnumerator Method
ReferenceArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

ReferenceArray Class


Insert Method

[image]

Revit 2024 API
ReferenceArray..::..Insert Method
ReferenceArray Class See Also Send Feedback
Insert the specified reference into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Insert(
    Reference item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As Reference, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    Reference^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::..Reference
The reference to be inserted into the array.
index
Type: System..::..Int32
The reference will be inserted before this index.

Return Value

Returns whether the reference was inserted into the array.

See Also

ReferenceArray Class


ReverseIterator Method

[image]

Revit 2024 API
ReferenceArray..::..ReverseIterator Method
ReferenceArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual ReferenceArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As ReferenceArrayIterator
Visual C++
public:
virtual ReferenceArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

ReferenceArray Class


IsEmpty Property

[image]

Revit 2024 API
ReferenceArray..::..IsEmpty Property
ReferenceArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

ReferenceArray Class


Item Property

[image]

Revit 2024 API
ReferenceArray..::..Item Property
ReferenceArray Class See Also Send Feedback
Gets or sets a reference at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Reference this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As Reference
    Get
    Set
Visual C++
public:
virtual property Reference^ Item[int index] {
    Reference^ get (int index);
    void set (int index, Reference^ value);
}

Parameters

index
Type: System..::..Int32
The index of the reference to be set or retrieved.

Return Value

Returns the reference at the specified index.

See Also

ReferenceArray Class


Size Property

[image]

Revit 2024 API
ReferenceArray..::..Size Property
ReferenceArray Class See Also Send Feedback
Returns the number of references that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ReferenceArray Class


ReferenceArrayArray Class

[image]

Revit 2024 API
ReferenceArrayArray Class
Members See Also Send Feedback
An array that contains ReferenceArray objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class ReferenceArrayArray : APIObject,
    IEnumerable
Visual Basic
Public Class ReferenceArrayArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ReferenceArrayArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..ReferenceArrayArray

See Also

ReferenceArrayArray Members


ReferenceArrayArray Constructor

[image]

Revit 2024 API
ReferenceArrayArray Constructor
ReferenceArrayArray Class See Also Send Feedback
Initializes a new instance of the ReferenceArrayArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ReferenceArrayArray()
Visual Basic
Public Sub New
Visual C++
public:
ReferenceArrayArray()

See Also

ReferenceArrayArray Class


ReferenceArrayArray Methods

[image] [image]

Revit 2024 API
ReferenceArrayArray Methods
ReferenceArrayArray Class See Also Send Feedback

The ReferenceArrayArray type exposes the following members.

Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every ReferenceArray from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ReferenceArrayArray Class


Append Method

[image]

Revit 2024 API
ReferenceArrayArray..::..Append Method
ReferenceArrayArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Append(
    ReferenceArray item
)
Visual Basic
Public Overridable Sub Append ( _
    item As ReferenceArray _
)
Visual C++
public:
virtual void Append(
    ReferenceArray^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..ReferenceArray

See Also

ReferenceArrayArray Class


Clear Method

[image]

Revit 2024 API
ReferenceArrayArray..::..Clear Method
ReferenceArrayArray Class See Also Send Feedback
Removes every ReferenceArray from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ReferenceArrayArray Class


GetEnumerator Method

[image]

Revit 2024 API
ReferenceArrayArray..::..GetEnumerator Method
ReferenceArrayArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

ReferenceArrayArray Class


Insert Method

[image]

Revit 2024 API
ReferenceArrayArray..::..Insert Method
ReferenceArrayArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Insert(
    ReferenceArray item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As ReferenceArray, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    ReferenceArray^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::..ReferenceArray
index
Type: System..::..Int32

See Also

ReferenceArrayArray Class


ReverseIterator Method

[image]

Revit 2024 API
ReferenceArrayArray..::..ReverseIterator Method
ReferenceArrayArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual ReferenceArrayArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As ReferenceArrayArrayIterator
Visual C++
public:
virtual ReferenceArrayArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

ReferenceArrayArray Class


ReferenceArrayArray Properties

[image] [image]

Revit 2024 API
ReferenceArrayArray Properties
ReferenceArrayArray Class See Also Send Feedback

The ReferenceArrayArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a ReferenceArray at a specified index within the array.
Public property | Size | Returns the number of ReferenceArrays that are in the array.

See Also

ReferenceArrayArray Class


IsEmpty Property

[image]

Revit 2024 API
ReferenceArrayArray..::..IsEmpty Property
ReferenceArrayArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

ReferenceArrayArray Class


Item Property

[image]

Revit 2024 API
ReferenceArrayArray..::..Item Property
ReferenceArrayArray Class See Also Send Feedback
Gets or sets a ReferenceArray at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual ReferenceArray this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As ReferenceArray
    Get
    Set
Visual C++
public:
virtual property ReferenceArray^ Item[int index] {
    ReferenceArray^ get (int index);
    void set (int index, ReferenceArray^ value);
}

Parameters

index
Type: System..::..Int32
The index of the ReferenceArray to be set or retrieved.

Return Value

Returns the ReferenceArray at the specified index.

See Also

ReferenceArrayArray Class


Size Property

[image]

Revit 2024 API
ReferenceArrayArray..::..Size Property
ReferenceArrayArray Class See Also Send Feedback
Returns the number of ReferenceArrays that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ReferenceArrayArray Class


ReferenceArrayArrayIterator Members

[image] [image]

Revit 2024 API
ReferenceArrayArrayIterator Members
ReferenceArrayArrayIterator Class Constructors Methods Properties See Also Send Feedback

The ReferenceArrayArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | ReferenceArrayArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ReferenceArrayArrayIterator Class


ReferenceArrayArrayIterator Constructor

[image]

Revit 2024 API
ReferenceArrayArrayIterator Constructor
ReferenceArrayArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ReferenceArrayArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
ReferenceArrayArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ReferenceArrayArrayIterator Class


ReferenceArrayArrayIterator Methods

[image] [image]

Revit 2024 API
ReferenceArrayArrayIterator Methods
ReferenceArrayArrayIterator Class See Also Send Feedback

The ReferenceArrayArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ReferenceArrayArrayIterator Class


MoveNext Method

[image]

Revit 2024 API
ReferenceArrayArrayIterator..::..MoveNext Method
ReferenceArrayArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ReferenceArrayArrayIterator Class


Reset Method

[image]

Revit 2024 API
ReferenceArrayArrayIterator..::..Reset Method
ReferenceArrayArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ReferenceArrayArrayIterator Class


ReferenceArrayArrayIterator Properties

[image] [image]

Revit 2024 API
ReferenceArrayArrayIterator Properties
ReferenceArrayArrayIterator Class See Also Send Feedback

The ReferenceArrayArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ReferenceArrayArrayIterator Class


Current Property

[image]

Revit 2024 API
ReferenceArrayArrayIterator..::..Current Property
ReferenceArrayArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ReferenceArrayArrayIterator Class


ReferenceArrayIterator Class

[image]

Revit 2024 API
ReferenceArrayIterator Class
Members See Also Send Feedback
An iterator to a reference array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public abstract class ReferenceArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class ReferenceArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ReferenceArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..ReferenceArrayIterator

See Also

ReferenceArrayIterator Members


ReferenceArrayIterator Members

[image] [image]

Revit 2024 API
ReferenceArrayIterator Members
ReferenceArrayIterator Class Constructors Methods Properties See Also Send Feedback

The ReferenceArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | ReferenceArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ReferenceArrayIterator Class


ReferenceArrayIterator Constructor

[image]

Revit 2024 API
ReferenceArrayIterator Constructor
ReferenceArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ReferenceArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
ReferenceArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ReferenceArrayIterator Class


MoveNext Method

[image]

Revit 2024 API
ReferenceArrayIterator..::..MoveNext Method
ReferenceArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ReferenceArrayIterator Class


Reset Method

[image]

Revit 2024 API
ReferenceArrayIterator..::..Reset Method
ReferenceArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ReferenceArrayIterator Class


ReferenceArrayIterator Properties

[image] [image]

Revit 2024 API
ReferenceArrayIterator Properties
ReferenceArrayIterator Class See Also Send Feedback

The ReferenceArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ReferenceArrayIterator Class


Current Property

[image]

Revit 2024 API
ReferenceArrayIterator..::..Current Property
ReferenceArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ReferenceArrayIterator Class


ReferenceBaseOnHostType Enumeration

[image]

Revit 2024 API
ReferenceBaseOnHostType Enumeration
See Also Send Feedback
This enumeration is used to classify the Reference Base on Host type .

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public enum ReferenceBaseOnHostType
Visual Basic
Public Enumeration ReferenceBaseOnHostType
Visual C++
public enum class ReferenceBaseOnHostType

Members

Member name | Description
PrimaryEnd |
SecondaryEnd |
Midpoint |

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


ReferenceIntersector Class

[image]

Revit 2024 API
ReferenceIntersector Class
Members Example See Also Send Feedback
A class used to find and return elements that intersect a ray created from an origin point and direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public class ReferenceIntersector : IDisposable
Visual Basic
Public Class ReferenceIntersector _
    Implements IDisposable
Visual C++
public ref class ReferenceIntersector : IDisposable

Remarks

An instance of this class can be constructed to return any 3D geometric element that intersects the ray created by the origin and direction, or to return a subset of elements based on filtering and flags. The caller can opt to filter the results using an ElementFilter, or by applying a specific list of acceptable elements. The caller can also specify the type of object to be returned, which might be whole elements, geometry objects, or a combination. In all cases the caller is required to supply a 3D view for evaluation; the view and visibility settings on the input view will determine if a particular element is returned (for example, hidden elements will never be returned by this tool, nor will elements whose geometry is outside the section box of the view).

The class is configured so that a single instance can be constructed and used for multiple evaluations of different rays. The results of the evaluation are not preserved between invocations on the same ReferenceIntersector.

The class also offers an option to return element results encountered in Revit Links. When the FindReferencesInRevitLinks flag is set, the results may include elements in the host document and in any RevitLinkInstance encountered, depending on the other flags set. See the remarks for FindReferencesInRevitLinks for details on how the flags affect the results obtained from links.

Examples

CopyC#
public class RayProjection : IExternalCommand
{
    public Result Execute(ExternalCommandData revit, ref string message, ElementSet elements)
    {
        Document doc = revit.Application.ActiveUIDocument.Document;

        ICollection<ElementId> selectedIds = revit.Application.ActiveUIDocument.Selection.GetElementIds();

        // If skylight is selected, process it.
        FamilyInstance skylight = null;
        if (selectedIds.Count == 1)
        {
            foreach (ElementId id in selectedIds)
            {
                Element e = doc.GetElement(id);
                if (e is FamilyInstance)
                {
                    FamilyInstance instance = e as FamilyInstance;
                    bool isWindow = (instance.Category.BuiltInCategory == BuiltInCategory.OST_Windows);
                    bool isHostedByRoof = (instance.Host.Category.BuiltInCategory == BuiltInCategory.OST_Roofs);

                    if (isWindow && isHostedByRoof)
                    {
                        skylight = instance;
                    }
                }
            }
        }

        if (skylight == null)
        {
            message = "Please select one skylight.";
            return Result.Cancelled;
        }

        // Calculate the height
        Line line = CalculateLineAboveFloor(doc, skylight);

        // Create a model curve to show the distance
        Plane plane = Plane.CreateByNormalAndOrigin(new XYZ(1, 0, 0), line.GetEndPoint(0));
        SketchPlane sketchPlane = SketchPlane.Create(doc, plane);

        ModelCurve curve = doc.Create.NewModelCurve(line, sketchPlane);

        // Show a message with the length value
        TaskDialog.Show("Distance", "Distance to floor: " + String.Format("{0:f2}", line.Length));

        return Result.Succeeded;
    }

    /// <summary>
    /// Determines the line segment that connects the skylight to the nearest floor.
    /// </summary>
    /// <returns>The line segment.</returns>
    private Line CalculateLineAboveFloor(Document doc, FamilyInstance skylight)
    {
        // Find a 3D view to use for the ReferenceIntersector constructor
        FilteredElementCollector collector = new FilteredElementCollector(doc);
        Func<View3D, bool> isNotTemplate = v3 => !(v3.IsTemplate);
        View3D view3D = collector.OfClass(typeof(View3D)).Cast<View3D>().First<View3D>(isNotTemplate);

        // Use the center of the skylight bounding box as the start point.
        BoundingBoxXYZ box = skylight.get_BoundingBox(view3D);
        XYZ center = box.Min.Add(box.Max).Multiply(0.5);

        // Project in the negative Z direction down to the floor.
        XYZ rayDirection = new XYZ(0, 0, -1);

        ElementClassFilter filter = new ElementClassFilter(typeof(Floor));

        ReferenceIntersector refIntersector = new ReferenceIntersector(filter, FindReferenceTarget.Face, view3D);
        ReferenceWithContext referenceWithContext = refIntersector.FindNearest(center, rayDirection);

        Reference reference = referenceWithContext.GetReference();
        XYZ intersection = reference.GlobalPoint;

        // Create line segment from the start point and intersection point.
        Line result = Line.CreateBound(center, intersection);
        return result;
    }
}
CopyVB.NET
<Autodesk.Revit.Attributes.Journaling(Autodesk.Revit.Attributes.JournalingMode.NoCommandData)> _
<Autodesk.Revit.Attributes.Transaction(Autodesk.Revit.Attributes.TransactionMode.Manual)> _
Public Class RayProjection
   Implements IExternalCommand
   Public Function Execute(revit As ExternalCommandData, ByRef message As String, elements As ElementSet) As Autodesk.Revit.UI.Result Implements IExternalCommand.Execute
      Dim doc As Document = revit.Application.ActiveUIDocument.Document

      Dim selectedIds As ICollection(Of ElementId) = revit.Application.ActiveUIDocument.Selection.GetElementIds()

      ' If skylight is selected, process it.
      Dim skylight As FamilyInstance = Nothing
      If selectedIds.Count = 1 Then
         For Each id As ElementId In selectedIds
            Dim e As Element = doc.GetElement(id)
            If TypeOf e Is FamilyInstance Then
               Dim instance As FamilyInstance = TryCast(e, FamilyInstance)
               Dim isWindow As Boolean = instance.Category.BuiltInCategory = BuiltInCategory.OST_Windows
               Dim isHostedByRoof As Boolean = instance.Host.Category.BuiltInCategory = BuiltInCategory.OST_Roofs

               If isWindow AndAlso isHostedByRoof Then
                  skylight = instance
               End If
            End If
         Next
      End If

      If skylight Is Nothing Then
         message = "Please select one skylight."
         Return Result.Cancelled
      End If

      ' Calculate the height
      Dim line As Line = CalculateLineAboveFloor(doc, skylight)

      ' Create a model curve to show the distance
      Dim plane As Plane = plane.CreateByNormalAndOrigin(New XYZ(1, 0, 0), line.GetEndPoint(0))
      Dim sketchPlane__1 As SketchPlane = SketchPlane.Create(doc, plane)

      Dim curve As ModelCurve = doc.Create.NewModelCurve(line, sketchPlane__1)

      ' Show a message with the length value
      TaskDialog.Show("Distance", "Distance to floor: " & [String].Format("{0:f2}", line.Length))

      Return Result.Succeeded
   End Function

   ' <summary>
   ' Determines the line segment that connects the skylight to the nearest floor.
   ' </summary>
   ' <returns>The line segment.</returns>
   Private Function CalculateLineAboveFloor(doc As Document, skylight As FamilyInstance) As Line
      ' Find a 3D view to use for the ReferenceIntersector constructor
      Dim collector As New FilteredElementCollector(doc)
      Dim isNotTemplate As Func(Of View3D, Boolean) = Function(v3) Not (v3.IsTemplate)
      Dim view3D As View3D = collector.OfClass(GetType(View3D)).Cast(Of View3D)().First(isNotTemplate)

      ' Use the center of the skylight bounding box as the start point.
      Dim box As BoundingBoxXYZ = skylight.BoundingBox(view3D)
      Dim center As XYZ = box.Min.Add(box.Max).Multiply(0.5)

      ' Project in the negative Z direction down to the floor.
      Dim rayDirection As New XYZ(0, 0, -1)

      Dim filter As New ElementClassFilter(GetType(Floor))

      Dim refIntersector As New ReferenceIntersector(filter, FindReferenceTarget.Face, view3D)
      Dim referenceWithContext As ReferenceWithContext = refIntersector.FindNearest(center, rayDirection)

      Dim reference As Reference = referenceWithContext.GetReference()
      Dim intersection As XYZ = reference.GlobalPoint

      ' Create line segment from the start point and intersection point.
      Dim result As Line = Line.CreateBound(center, intersection)
      Return result
   End Function
End Class

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ReferenceIntersector

See Also

ReferenceIntersector Members


ReferenceIntersector Members

[image] [image]

Revit 2024 API
ReferenceIntersector Members
ReferenceIntersector Class Constructors Methods Properties See Also Send Feedback

The ReferenceIntersector type exposes the following members.

Constructors

 | Name | Description
Public method | ReferenceIntersector(View3D) | Constructs a ReferenceIntersector which is set to return intersections from all elements and representing all reference target types.
Public method | ReferenceIntersector(ElementFilter, FindReferenceTarget, View3D) | Constructs a ReferenceIntersector which is set to return intersections from any element which passes an input filter.
Public method | ReferenceIntersector(ElementId, FindReferenceTarget, View3D) | Constructs a ReferenceIntersector which is set to return intersections from a single target element only.
Public method | ReferenceIntersector(ICollection<(Of <<'(ElementId>)>>), FindReferenceTarget, View3D) | Constructs a ReferenceIntersector which is set to return intersections from any of a set of target elements.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ReferenceIntersector
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Find | Projects a ray from the origin along the given direction, and returns all references from intersected elements which match the ReferenceIntersector's criteria.
Public method | FindNearest | Projects a ray from the origin along the given direction, and returns the nearest reference from intersected elements which match the ReferenceIntersector's criteria.
Public method | GetFilter | Gets the ElementFilter used in intersection testing.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTargetElementIds | Gets the set of ElementIds to test from in intersection testing.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetFilter | Sets the ElementFilter used in intersection testing.
Public method | SetTargetElementIds | Sets the set of ElementIds to test from in intersection testing.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FindReferencesInRevitLinks | Determines if references inside Revit Links should be found.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | TargetType | The type of reference to find.
Public property | ViewId | The id of the 3D view used for evaluation.

See Also

ReferenceIntersector Class


ReferenceIntersector Constructor (View3D)

[image]

Revit 2024 API
ReferenceIntersector Constructor (View3D)
ReferenceIntersector Class See Also Send Feedback
Constructs a ReferenceIntersector which is set to return intersections from all elements and representing all reference target types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ReferenceIntersector(
    View3D view3d
)
Visual Basic
Public Sub New ( _
    view3d As View3D _
)
Visual C++
public:
ReferenceIntersector(
    View3D^ view3d
)

Parameters

view3d
Type: Autodesk.Revit.DB..::..View3D
The view in which to find references.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Returns true if the view is not a view template.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ReferenceIntersector Class
ReferenceIntersector Overload


ReferenceIntersector Constructor (ElementFilter, FindReferenceTarget, View3D)

[image]

Revit 2024 API
ReferenceIntersector Constructor (ElementFilter, FindReferenceTarget, View3D)
ReferenceIntersector Class See Also Send Feedback
Constructs a ReferenceIntersector which is set to return intersections from any element which passes an input filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ReferenceIntersector(
    ElementFilter filter,
    FindReferenceTarget targetType,
    View3D view3d
)
Visual Basic
Public Sub New ( _
    filter As ElementFilter, _
    targetType As FindReferenceTarget, _
    view3d As View3D _
)
Visual C++
public:
ReferenceIntersector(
    ElementFilter^ filter,
    FindReferenceTarget targetType,
    View3D^ view3d
)

Parameters

filter
Type: Autodesk.Revit.DB..::..ElementFilter
The element filter. All references will belong to elements passing this filter.
targetType
Type: Autodesk.Revit.DB..::..FindReferenceTarget
The target type of references to return.
view3d
Type: Autodesk.Revit.DB..::..View3D
The view in which to find references.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Returns true if the view is not a view template.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

ReferenceIntersector Class
ReferenceIntersector Overload


ReferenceIntersector Constructor (ElementId, FindReferenceTarget, View3D)

[image]

Revit 2024 API
ReferenceIntersector Constructor (ElementId, FindReferenceTarget, View3D)
ReferenceIntersector Class See Also Send Feedback
Constructs a ReferenceIntersector which is set to return intersections from a single target element only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ReferenceIntersector(
    ElementId targetElementId,
    FindReferenceTarget targetType,
    View3D view3d
)
Visual Basic
Public Sub New ( _
    targetElementId As ElementId, _
    targetType As FindReferenceTarget, _
    view3d As View3D _
)
Visual C++
public:
ReferenceIntersector(
    ElementId^ targetElementId,
    FindReferenceTarget targetType,
    View3D^ view3d
)

Parameters

targetElementId
Type: Autodesk.Revit.DB..::..ElementId
The target element id.
targetType
Type: Autodesk.Revit.DB..::..FindReferenceTarget
The target type of references to return.
view3d
Type: Autodesk.Revit.DB..::..View3D
The view in which to find references.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Returns true if the view is not a view template.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

ReferenceIntersector Class
ReferenceIntersector Overload


ReferenceIntersector Constructor (ICollection(ElementId), FindReferenceTarget, View3D)

[image]

Revit 2024 API
ReferenceIntersector Constructor (ICollection<(Of <(<'ElementId>)>)>, FindReferenceTarget, View3D)
ReferenceIntersector Class See Also Send Feedback
Constructs a ReferenceIntersector which is set to return intersections from any of a set of target elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ReferenceIntersector(
    ICollection<ElementId> targetElementIds,
    FindReferenceTarget targetType,
    View3D view3d
)
Visual Basic
Public Sub New ( _
    targetElementIds As ICollection(Of ElementId), _
    targetType As FindReferenceTarget, _
    view3d As View3D _
)
Visual C++
public:
ReferenceIntersector(
    ICollection<ElementId^>^ targetElementIds,
    FindReferenceTarget targetType,
    View3D^ view3d
)

Parameters

targetElementIds
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
The target element ids.
targetType
Type: Autodesk.Revit.DB..::..FindReferenceTarget
The target type of references to return.
view3d
Type: Autodesk.Revit.DB..::..View3D
The view in which to find references.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Returns true if the view is not a view template.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

ReferenceIntersector Class
ReferenceIntersector Overload


ReferenceIntersector Methods

[image] [image]

Revit 2024 API
ReferenceIntersector Methods
ReferenceIntersector Class See Also Send Feedback

The ReferenceIntersector type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Find | Projects a ray from the origin along the given direction, and returns all references from intersected elements which match the ReferenceIntersector's criteria.
Public method | FindNearest | Projects a ray from the origin along the given direction, and returns the nearest reference from intersected elements which match the ReferenceIntersector's criteria.
Public method | GetFilter | Gets the ElementFilter used in intersection testing.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTargetElementIds | Gets the set of ElementIds to test from in intersection testing.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetFilter | Sets the ElementFilter used in intersection testing.
Public method | SetTargetElementIds | Sets the set of ElementIds to test from in intersection testing.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ReferenceIntersector Class


Dispose Method

[image]

Revit 2024 API
ReferenceIntersector..::..Dispose Method
ReferenceIntersector Class See Also Send Feedback
Releases all resources used by the ReferenceIntersector

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ReferenceIntersector Class


Find Method

[image]

Revit 2024 API
ReferenceIntersector..::..Find Method
ReferenceIntersector Class See Also Send Feedback
Projects a ray from the origin along the given direction, and returns all references from intersected elements which match the ReferenceIntersector's criteria.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public IList<ReferenceWithContext> Find(
    XYZ origin,
    XYZ direction
)
Visual Basic
Public Function Find ( _
    origin As XYZ, _
    direction As XYZ _
) As IList(Of ReferenceWithContext)
Visual C++
public:
IList<ReferenceWithContext^>^ Find(
    XYZ^ origin,
    XYZ^ direction
)

Parameters

origin
Type: Autodesk.Revit.DB..::..XYZ
The origin of the ray.
direction
Type: Autodesk.Revit.DB..::..XYZ
The direction of the ray.

Return Value

A collection containing the intersected references.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ReferenceIntersector Class


FindNearest Method

[image]

Revit 2024 API
ReferenceIntersector..::..FindNearest Method
ReferenceIntersector Class See Also Send Feedback
Projects a ray from the origin along the given direction, and returns the nearest reference from intersected elements which match the ReferenceIntersector's criteria.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ReferenceWithContext FindNearest(
    XYZ origin,
    XYZ direction
)
Visual Basic
Public Function FindNearest ( _
    origin As XYZ, _
    direction As XYZ _
) As ReferenceWithContext
Visual C++
public:
ReferenceWithContext^ FindNearest(
    XYZ^ origin,
    XYZ^ direction
)

Parameters

origin
Type: Autodesk.Revit.DB..::..XYZ
The origin of the ray.
direction
Type: Autodesk.Revit.DB..::..XYZ
The direction of the ray.

Return Value

The intersected reference nearest to the ray origin, nullNothingnullptra null reference (Nothing in Visual Basic) if none is found

Remarks

Note that FindNearest() is a convenience method, and other references that may be nearly the same distance from the origin can be obtained from Find(XYZ, XYZ).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ReferenceIntersector Class


GetFilter Method

[image]

Revit 2024 API
ReferenceIntersector..::..GetFilter Method
ReferenceIntersector Class See Also Send Feedback
Gets the ElementFilter used in intersection testing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ElementFilter GetFilter()
Visual Basic
Public Function GetFilter As ElementFilter
Visual C++
public:
ElementFilter^ GetFilter()

Return Value

The ElementFilter, or nullNothingnullptra null reference (Nothing in Visual Basic) if no filter is set.

See Also

ReferenceIntersector Class


SetTargetElementIds Method

[image]

Revit 2024 API
ReferenceIntersector..::..SetTargetElementIds Method
ReferenceIntersector Class See Also Send Feedback
Sets the set of ElementIds to test from in intersection testing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void SetTargetElementIds(
    ICollection<ElementId> elementIds
)
Visual Basic
Public Sub SetTargetElementIds ( _
    elementIds As ICollection(Of ElementId) _
)
Visual C++
public:
void SetTargetElementIds(
    ICollection<ElementId^>^ elementIds
)

Parameters

elementIds
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
The target ElementIds.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ReferenceIntersector Class


ReferenceIntersector Properties

[image] [image]

Revit 2024 API
ReferenceIntersector Properties
ReferenceIntersector Class See Also Send Feedback

The ReferenceIntersector type exposes the following members.

Properties

 | Name | Description
Public property | FindReferencesInRevitLinks | Determines if references inside Revit Links should be found.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | TargetType | The type of reference to find.
Public property | ViewId | The id of the 3D view used for evaluation.

See Also

ReferenceIntersector Class


FindReferencesInRevitLinks Property

[image]

Revit 2024 API
ReferenceIntersector..::..FindReferencesInRevitLinks Property
ReferenceIntersector Class See Also Send Feedback
Determines if references inside Revit Links should be found.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool FindReferencesInRevitLinks { get; set; }
Visual Basic
Public Property FindReferencesInRevitLinks As Boolean
    Get
    Set
Visual C++
public:
property bool FindReferencesInRevitLinks {
    bool get ();
    void set (bool value);
}

Remarks

If set to false, no Reference to any Element from a Revit Link will be found by the ReferenceIntersector, and you can be certain that any Reference returned will be to a host document Element only. If set to true, the results may include both References to Elements in hosts and References to Elements from a link instance.

Setting this value to true may interact with some other settings on the ReferenceIntersector. If a list of target ElementIds is set, references will be returned only if the ElementId matches the id of the intersected RevitLinkInstance. If there is a match, any intersecting elements in the link will be returned (their ids will not be compared with the target ids list). If there is an ElementFilter applied, the elements in the link will be evaluated against the stored ElementFilter.

Note that results may not be as expected if the filter applied is geometric (such as a BoundingBox filter or ElementIntersects filter). This is because the filter will be evaluated for linked elements in the coordinates of the linked model, which may not match the coordinates of the elements as they appear in the host model. Also, ElementFilters that accept a Document and/or ElementId as input during their instantiation will not correctly pass elements that appear in the link, because the filter will not be able to match link elements to the filter's criteria.

See Also

ReferenceIntersector Class


IsValidObject Property

[image]

Revit 2024 API
ReferenceIntersector..::..IsValidObject Property
ReferenceIntersector Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ReferenceIntersector Class


TargetType Property

[image]

Revit 2024 API
ReferenceIntersector..::..TargetType Property
ReferenceIntersector Class See Also Send Feedback
The type of reference to find.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public FindReferenceTarget TargetType { get; set; }
Visual Basic
Public Property TargetType As FindReferenceTarget
    Get
    Set
Visual C++
public:
property FindReferenceTarget TargetType {
    FindReferenceTarget get ();
    void set (FindReferenceTarget value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

ReferenceIntersector Class


ViewId Property

[image]

Revit 2024 API
ReferenceIntersector..::..ViewId Property
ReferenceIntersector Class See Also Send Feedback
The id of the 3D view used for evaluation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ElementId ViewId { get; set; }
Visual Basic
Public Property ViewId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ ViewId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: viewId is not the id of a 3D view.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ReferenceIntersector Class


ReferencePlane Members

[image] [image]

Revit 2024 API
ReferencePlane Members
ReferencePlane Class Methods Properties See Also Send Feedback

The ReferencePlane type exposes the following members.

Methods

 | Name | Description
Public method | AddLeader | Adds a default Leader for the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders). (Inherited from DatumPlane.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanBeVisibleInView | Checks if the datum plane can be visible in the view. (Inherited from DatumPlane.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | Flip | Flips the orientation of the reference plane.
Public method | GetCurvesInView | Gets a collection of curves representing the DatumPlane element in the given view. (Inherited from DatumPlane.)
Public method | GetDatumExtentTypeInView | Identifies whether the curve representing the datum plane is displayed according to its actual 3d extents, or else according to a view specific setting. (Inherited from DatumPlane.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLeader | Gets a copy of the leader applied to the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders). (Inherited from DatumPlane.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPlane | Returns the geometry plane to which the reference plane is assigned.
Public method | GetPropagationViews | Gets a list of candidate views which are parallel to the current view and to which the extents of the datum may be propagated. (Inherited from DatumPlane.)
Public method | GetReference | Returns the geometry reference of the reference plane.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasBubbleInView | Identifies if the DatumPlane has bubble or not. (Inherited from DatumPlane.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HideBubbleInView | Hides the bubble in a view. This method does not apply to Reference planes. (Inherited from DatumPlane.)
Public method | IsBubbleVisibleInView | Identifies if the bubble is visible or not in a view. (Inherited from DatumPlane.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsCurveValidInView | Checks if the curve is valid to be as the extents for the datum plane in a view. The curve must be bound and coincident with the original one of the datum plane. (Inherited from DatumPlane.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsLeaderValid | Identifies if the leader valid or not for this DatumPlane. This method does not apply to Reference planes (which do not support leaders). (Inherited from DatumPlane.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | Maximize3DExtents | Computes the 3d extents of all model geometry and levels, and extends the 3d extents of this datum surface to include the model extents. (Inherited from DatumPlane.)
Public method | PropagateToViews | Propagates the extents applied to this datum in the view to the specified parallel views. (Inherited from DatumPlane.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetCurveInView | Sets the extents to match the curve. (Inherited from DatumPlane.)
Public method | SetDatumExtentType | Sets whether the curve representing the datum plane is displayed according to its 3d extents, or else according to a view specific setting. (Inherited from DatumPlane.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetLeader | Sets the leader to the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders). (Inherited from DatumPlane.)
Public method | ShowBubbleInView | Shows the bubble in a view. This method does not apply to Reference planes. (Inherited from DatumPlane.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | BubbleEnd | The bubble end of the reference plane.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Direction | The direction of the reference plane.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FreeEnd | The free end of the reference plane.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | The name property of the reference plane.
Public property | Normal | The normal vector of the reference plane.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ReferencePlane Class


ReferencePlane Methods

[image] [image]

Revit 2024 API
ReferencePlane Methods
ReferencePlane Class See Also Send Feedback

The ReferencePlane type exposes the following members.

Methods

 | Name | Description
Public method | AddLeader | Adds a default Leader for the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders). (Inherited from DatumPlane.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanBeVisibleInView | Checks if the datum plane can be visible in the view. (Inherited from DatumPlane.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | Flip | Flips the orientation of the reference plane.
Public method | GetCurvesInView | Gets a collection of curves representing the DatumPlane element in the given view. (Inherited from DatumPlane.)
Public method | GetDatumExtentTypeInView | Identifies whether the curve representing the datum plane is displayed according to its actual 3d extents, or else according to a view specific setting. (Inherited from DatumPlane.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLeader | Gets a copy of the leader applied to the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders). (Inherited from DatumPlane.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPlane | Returns the geometry plane to which the reference plane is assigned.
Public method | GetPropagationViews | Gets a list of candidate views which are parallel to the current view and to which the extents of the datum may be propagated. (Inherited from DatumPlane.)
Public method | GetReference | Returns the geometry reference of the reference plane.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasBubbleInView | Identifies if the DatumPlane has bubble or not. (Inherited from DatumPlane.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HideBubbleInView | Hides the bubble in a view. This method does not apply to Reference planes. (Inherited from DatumPlane.)
Public method | IsBubbleVisibleInView | Identifies if the bubble is visible or not in a view. (Inherited from DatumPlane.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsCurveValidInView | Checks if the curve is valid to be as the extents for the datum plane in a view. The curve must be bound and coincident with the original one of the datum plane. (Inherited from DatumPlane.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsLeaderValid | Identifies if the leader valid or not for this DatumPlane. This method does not apply to Reference planes (which do not support leaders). (Inherited from DatumPlane.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | Maximize3DExtents | Computes the 3d extents of all model geometry and levels, and extends the 3d extents of this datum surface to include the model extents. (Inherited from DatumPlane.)
Public method | PropagateToViews | Propagates the extents applied to this datum in the view to the specified parallel views. (Inherited from DatumPlane.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetCurveInView | Sets the extents to match the curve. (Inherited from DatumPlane.)
Public method | SetDatumExtentType | Sets whether the curve representing the datum plane is displayed according to its 3d extents, or else according to a view specific setting. (Inherited from DatumPlane.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetLeader | Sets the leader to the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders). (Inherited from DatumPlane.)
Public method | ShowBubbleInView | Shows the bubble in a view. This method does not apply to Reference planes. (Inherited from DatumPlane.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ReferencePlane Class


Flip Method

[image]

Revit 2024 API
ReferencePlane..::..Flip Method
ReferencePlane Class See Also Send Feedback
Flips the orientation of the reference plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Flip()
Visual Basic
Public Sub Flip
Visual C++
public:
void Flip()

See Also

ReferencePlane Class


GetPlane Method

[image]

Revit 2024 API
ReferencePlane..::..GetPlane Method
ReferencePlane Class See Also Send Feedback
Returns the geometry plane to which the reference plane is assigned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public Plane GetPlane()
Visual Basic
Public Function GetPlane As Plane
Visual C++
public:
Plane^ GetPlane()

Return Value

The geometry plane to which the reference plane is assigned.

See Also

ReferencePlane Class


GetReference Method

[image]

Revit 2024 API
ReferencePlane..::..GetReference Method
ReferencePlane Class See Also Send Feedback
Returns the geometry reference of the reference plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public Reference GetReference()
Visual Basic
Public Function GetReference As Reference
Visual C++
public:
Reference^ GetReference()

Return Value

The geometry reference of the reference plane.

See Also

ReferencePlane Class


BubbleEnd Property

[image]

Revit 2024 API
ReferencePlane..::..BubbleEnd Property
ReferencePlane Class See Also Send Feedback
The bubble end of the reference plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ BubbleEnd { get; set; }
Visual Basic
Public Property BubbleEnd As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ BubbleEnd {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

When setting this property, an exception will be thrown if the bubble end is set to almost the same point as free end or if the vector from BubbleEnd -> FreeEnd is not perpendicular to the normal vector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ReferencePlane Class


Direction Property

[image]

Revit 2024 API
ReferencePlane..::..Direction Property
ReferencePlane Class See Also Send Feedback
The direction of the reference plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ Direction { get; set; }
Visual Basic
Public Property Direction As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ Direction {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

When setting this property, an exception will be thrown if the direction vector is not perpendicular to the normal vector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: newDir has zero length.

See Also

ReferencePlane Class


FreeEnd Property

[image]

Revit 2024 API
ReferencePlane..::..FreeEnd Property
ReferencePlane Class See Also Send Feedback
The free end of the reference plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ FreeEnd { get; set; }
Visual Basic
Public Property FreeEnd As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ FreeEnd {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

When setting this property, an exception will be thrown if the free end is set to almost the same point as bubble end or if the vector from BubbleEnd -> FreeEnd is not perpendicular to the normal vector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ReferencePlane Class


Name Property

[image]

Revit 2024 API
ReferencePlane..::..Name Property
ReferencePlane Class See Also Send Feedback
The name property of the reference plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Remarks

This property overrides Element's default implementation.

See Also

ReferencePlane Class


Normal Property

[image]

Revit 2024 API
ReferencePlane..::..Normal Property
ReferencePlane Class See Also Send Feedback
The normal vector of the reference plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ Normal { get; }
Visual Basic
Public ReadOnly Property Normal As XYZ
    Get
Visual C++
public:
property XYZ^ Normal {
    XYZ^ get ();
}

See Also

ReferencePlane Class


ReferencePoint Class

[image]

Revit 2024 API
ReferencePoint Class
Members See Also Send Feedback
A reference point in an Autodesk Revit family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class ReferencePoint : Element
Visual Basic
Public Class ReferencePoint _
    Inherits Element
Visual C++
public ref class ReferencePoint : public Element

Remarks

A ReferencePoint represents a point in space together with a local coordinate system. ReferencePoints can be free, or constrained to other elements in several ways. When the point is constrained, the coordinate system is also constrained in certain ways.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ReferencePoint

See Also

ReferencePoint Members


ReferencePoint Members

[image] [image]

Revit 2024 API
ReferencePoint Members
ReferencePoint Class Methods Properties See Also Send Feedback

The ReferencePoint type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetCoordinatePlaneReferenceXY | A reference for the XY plane of the coordinate system.
Public method | GetCoordinatePlaneReferenceXZ | A reference for the XZ plane of the coordinate system.
Public method | GetCoordinatePlaneReferenceYZ | A reference for the YZ plane of the coordinate system.
Public method | GetCoordinateSystem | The position and orientation of the ReferencePoint.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHubId | Id of associated Hub.
Public method | GetInterpolatingCurves | The set of CurveByPoints elements that interpolate a ReferencePoint.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPointElementReference | Retrieve a copy of the rule that computes the location of the ReferencePoint relative to other elements in the document.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the point.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetCoordinateSystem | The position and orientation of the ReferencePoint.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetPointElementReference | Change the rule for computing the location of the ReferencePoint relative to other elements in the document.
Public method | SetVisibility | Sets the visibility for the point.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CoordinatePlaneVisibility | Visibility settings for the coordinate reference planes.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | (Overrides Element..::..Name.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Position | The position of the ReferencePoint.
Public property | ShowNormalReferencePlaneOnly | Whether all three coordinate planes are shown, or only the normal (XY) plane.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Visible | Whether the point is visible when the family is loaded into a project.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ReferencePoint Class


ReferencePoint Methods

[image] [image]

Revit 2024 API
ReferencePoint Methods
ReferencePoint Class See Also Send Feedback

The ReferencePoint type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetCoordinatePlaneReferenceXY | A reference for the XY plane of the coordinate system.
Public method | GetCoordinatePlaneReferenceXZ | A reference for the XZ plane of the coordinate system.
Public method | GetCoordinatePlaneReferenceYZ | A reference for the YZ plane of the coordinate system.
Public method | GetCoordinateSystem | The position and orientation of the ReferencePoint.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHubId | Id of associated Hub.
Public method | GetInterpolatingCurves | The set of CurveByPoints elements that interpolate a ReferencePoint.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPointElementReference | Retrieve a copy of the rule that computes the location of the ReferencePoint relative to other elements in the document.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the point.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetCoordinateSystem | The position and orientation of the ReferencePoint.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetPointElementReference | Change the rule for computing the location of the ReferencePoint relative to other elements in the document.
Public method | SetVisibility | Sets the visibility for the point.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ReferencePoint Class


GetCoordinatePlaneReferenceXZ Method

[image]

Revit 2024 API
ReferencePoint..::..GetCoordinatePlaneReferenceXZ Method
ReferencePoint Class See Also Send Feedback
A reference for the XZ plane of the coordinate system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Reference GetCoordinatePlaneReferenceXZ()
Visual Basic
Public Function GetCoordinatePlaneReferenceXZ As Reference
Visual C++
public:
Reference^ GetCoordinatePlaneReferenceXZ()

See Also

ReferencePoint Class


GetCoordinatePlaneReferenceYZ Method

[image]

Revit 2024 API
ReferencePoint..::..GetCoordinatePlaneReferenceYZ Method
ReferencePoint Class See Also Send Feedback
A reference for the YZ plane of the coordinate system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Reference GetCoordinatePlaneReferenceYZ()
Visual Basic
Public Function GetCoordinatePlaneReferenceYZ As Reference
Visual C++
public:
Reference^ GetCoordinatePlaneReferenceYZ()

See Also

ReferencePoint Class


GetCoordinateSystem Method

[image]

Revit 2024 API
ReferencePoint..::..GetCoordinateSystem Method
ReferencePoint Class See Also Send Feedback
The position and orientation of the ReferencePoint.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Transform GetCoordinateSystem()
Visual Basic
Public Function GetCoordinateSystem As Transform
Visual C++
public:
Transform^ GetCoordinateSystem()

Remarks

The position of the point is given by CoordinateSystem.Origin, and the orientation is specified by the three unit vectors CoordinateSystem.BasisX, BasisY, BasisZ.

See Also

ReferencePoint Class


GetHubId Method

[image]

Revit 2024 API
ReferencePoint..::..GetHubId Method
ReferencePoint Class See Also Send Feedback
Id of associated Hub.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElementId GetHubId()
Visual Basic
Public Function GetHubId As ElementId
Visual C++
public:
ElementId^ GetHubId()

See Also

ReferencePoint Class


GetInterpolatingCurves Method

[image]

Revit 2024 API
ReferencePoint..::..GetInterpolatingCurves Method
ReferencePoint Class See Also Send Feedback
The set of CurveByPoints elements that interpolate a ReferencePoint.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CurveByPointsArray GetInterpolatingCurves()
Visual Basic
Public Function GetInterpolatingCurves As CurveByPointsArray
Visual C++
public:
CurveByPointsArray^ GetInterpolatingCurves()

Remarks

A CurveByPoints is in the GetInterpolatingCurves()()()() array if and only if the ReferencePoint is in the Points array of CurveByPoints.

See Also

ReferencePoint Class


GetPointElementReference Method

[image]

Revit 2024 API
ReferencePoint..::..GetPointElementReference Method
ReferencePoint Class See Also Send Feedback
Retrieve a copy of the rule that computes the location of the ReferencePoint relative to other elements in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public PointElementReference GetPointElementReference()
Visual Basic
Public Function GetPointElementReference As PointElementReference
Visual C++
public:
PointElementReference^ GetPointElementReference()

Return Value

A PointElementReference object, or nullNothingnullptra null reference (Nothing in Visual Basic) if the ReferencePoint does not have a reference.

See Also

ReferencePoint Class


GetVisibility Method

[image]

Revit 2024 API
ReferencePoint..::..GetVisibility Method
ReferencePoint Class See Also Send Feedback
Gets the visibility for the point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyElementVisibility GetVisibility()
Visual Basic
Public Function GetVisibility As FamilyElementVisibility
Visual C++
public:
FamilyElementVisibility^ GetVisibility()

Return Value

A copy of visibility settings for the ReferencePoint.

See Also

ReferencePoint Class


SetCoordinateSystem Method

[image]

Revit 2024 API
ReferencePoint..::..SetCoordinateSystem Method
ReferencePoint Class See Also Send Feedback
The position and orientation of the ReferencePoint.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetCoordinateSystem(
    Transform coordinateSystem
)
Visual Basic
Public Sub SetCoordinateSystem ( _
    coordinateSystem As Transform _
)
Visual C++
public:
void SetCoordinateSystem(
    Transform^ coordinateSystem
)

Parameters

coordinateSystem
Type: Autodesk.Revit.DB..::..Transform

Remarks

The position of the point is given by CoordinateSystem.Origin, and the orientation is specified by the three unit vectors CoordinateSystem.BasisX, BasisY, BasisZ. The basis vectors must be unit length and mutually perpendicular. Whenever the Reference property is not nullNothingnullptra null reference (Nothing in Visual Basic), changing the CoordinateSystem property has a compound effect. First the point is moved to the specified location. Then the point is moved to conform to its Reference, by the shortest possible distance.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when coordinateSystem does not specify an orthonormal basis.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when CoordinateSystem is set while the Reference property is not nullNothingnullptra null reference (Nothing in Visual Basic), and the ReferencePoint is unable to move to the new location.

See Also

ReferencePoint Class


SetPointElementReference Method

[image]

Revit 2024 API
ReferencePoint..::..SetPointElementReference Method
ReferencePoint Class See Also Send Feedback
Change the rule for computing the location of the ReferencePoint relative to other elements in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetPointElementReference(
    PointElementReference pointElementReference
)
Visual Basic
Public Sub SetPointElementReference ( _
    pointElementReference As PointElementReference _
)
Visual C++
public:
void SetPointElementReference(
    PointElementReference^ pointElementReference
)

Parameters

pointElementReference
Type: Autodesk.Revit.DB..::..PointElementReference
An object specifying a rule for the location and orientation of a ReferencePoint. (Note: The ReferencePoint object does not store the pointElementReference object after this call.)

Remarks

pointElementReference may be nullNothingnullptra null reference (Nothing in Visual Basic), in which case the ReferencePoint does not follow any other element. When Reference is changed from nullNothingnullptra null reference (Nothing in Visual Basic) to a non-null value, the point moves and rotates to the prescribed location and orientation. Where the coordinate system has some freedom, it will remain as close to the old orientation as possible. When the reference is set to nullNothingnullptra null reference (Nothing in Visual Basic), the point does not move or rotate.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when Reference is set to a non-null object, and the ReferencePoint is unable to move to the new reference.

See Also

ReferencePoint Class


SetVisibility Method

[image]

Revit 2024 API
ReferencePoint..::..SetVisibility Method
ReferencePoint Class See Also Send Feedback
Sets the visibility for the point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetVisibility(
    FamilyElementVisibility visibility
)
Visual Basic
Public Sub SetVisibility ( _
    visibility As FamilyElementVisibility _
)
Visual C++
public:
void SetVisibility(
    FamilyElementVisibility^ visibility
)

Parameters

visibility
Type: Autodesk.Revit.DB..::..FamilyElementVisibility

Remarks

The visibility of the point can be changed for different types of views and detail levels in the project.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when visibility is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when regeneration failed.

See Also

ReferencePoint Class


CoordinatePlaneVisibility Property

[image]

Revit 2024 API
ReferencePoint..::..CoordinatePlaneVisibility Property
ReferencePoint Class See Also Send Feedback
Visibility settings for the coordinate reference planes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CoordinatePlaneVisibility CoordinatePlaneVisibility { get; set; }
Visual Basic
Public Property CoordinatePlaneVisibility As CoordinatePlaneVisibility
    Get
    Set
Visual C++
public:
property CoordinatePlaneVisibility CoordinatePlaneVisibility {
    CoordinatePlaneVisibility get ();
    void set (CoordinatePlaneVisibility value);
}

See Also

ReferencePoint Class


Parameter Property

[image] [image]

Revit 2024 API
ReferencePoint..::..Parameter Property
ReferencePoint Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ReferencePoint Class
ReferencePoint Members


Position Property

[image]

Revit 2024 API
ReferencePoint..::..Position Property
ReferencePoint Class See Also Send Feedback
The position of the ReferencePoint.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ Position { get; set; }
Visual Basic
Public Property Position As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ Position {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

This is an alternate interface to the property CoordinateSystem.Origin. When set, the effect is the same as setting the CoordinateSystem property to the same as its current value but with a different Origin.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when CoordinateSystem is set while the Reference property is not nullNothingnullptra null reference (Nothing in Visual Basic), and the ReferencePoint is unable to move to the new location.

See Also

ReferencePoint Class


ShowNormalReferencePlaneOnly Property

[image]

Revit 2024 API
ReferencePoint..::..ShowNormalReferencePlaneOnly Property
ReferencePoint Class See Also Send Feedback
Whether all three coordinate planes are shown, or only the normal (XY) plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool ShowNormalReferencePlaneOnly { get; set; }
Visual Basic
Public Property ShowNormalReferencePlaneOnly As Boolean
    Get
    Set
Visual C++
public:
property bool ShowNormalReferencePlaneOnly {
    bool get ();
    void set (bool value);
}

See Also

ReferencePoint Class


ReferencePointArray Class

[image]

Revit 2024 API
ReferencePointArray Class
Members See Also Send Feedback
An array that contains reference objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class ReferencePointArray : APIObject,
    IEnumerable
Visual Basic
Public Class ReferencePointArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ReferencePointArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..ReferencePointArray

See Also

ReferencePointArray Members


ReferencePointArray Constructor

[image]

Revit 2024 API
ReferencePointArray Constructor
ReferencePointArray Class See Also Send Feedback
Initializes a new instance of the ReferencePointArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ReferencePointArray()
Visual Basic
Public Sub New
Visual C++
public:
ReferencePointArray()

See Also

ReferencePointArray Class


ReferencePointArray Methods

[image] [image]

Revit 2024 API
ReferencePointArray Methods
ReferencePointArray Class See Also Send Feedback

The ReferencePointArray type exposes the following members.

Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every reference from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ReferencePointArray Class


ForwardIterator Method

[image]

Revit 2024 API
ReferencePointArray..::..ForwardIterator Method
ReferencePointArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual ReferencePointArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As ReferencePointArrayIterator
Visual C++
public:
virtual ReferencePointArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

ReferencePointArray Class


GetEnumerator Method

[image]

Revit 2024 API
ReferencePointArray..::..GetEnumerator Method
ReferencePointArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

ReferencePointArray Class


Insert Method

[image]

Revit 2024 API
ReferencePointArray..::..Insert Method
ReferencePointArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Insert(
    ReferencePoint item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As ReferencePoint, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    ReferencePoint^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::..ReferencePoint
index
Type: System..::..Int32

See Also

ReferencePointArray Class


ReverseIterator Method

[image]

Revit 2024 API
ReferencePointArray..::..ReverseIterator Method
ReferencePointArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual ReferencePointArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As ReferencePointArrayIterator
Visual C++
public:
virtual ReferencePointArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

ReferencePointArray Class


ReferencePointArray Properties

[image] [image]

Revit 2024 API
ReferencePointArray Properties
ReferencePointArray Class See Also Send Feedback

The ReferencePointArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a reference at a specified index within the array.
Public property | Size | Returns the number of references that are in the array.

See Also

ReferencePointArray Class


IsEmpty Property

[image]

Revit 2024 API
ReferencePointArray..::..IsEmpty Property
ReferencePointArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

ReferencePointArray Class


Item Property

[image]

Revit 2024 API
ReferencePointArray..::..Item Property
ReferencePointArray Class See Also Send Feedback
Gets or sets a reference at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual ReferencePoint this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As ReferencePoint
    Get
    Set
Visual C++
public:
virtual property ReferencePoint^ Item[int index] {
    ReferencePoint^ get (int index);
    void set (int index, ReferencePoint^ value);
}

Parameters

index
Type: System..::..Int32
The index of the reference to be set or retrieved.

Return Value

Returns the reference at the specified index.

See Also

ReferencePointArray Class


Size Property

[image]

Revit 2024 API
ReferencePointArray..::..Size Property
ReferencePointArray Class See Also Send Feedback
Returns the number of references that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ReferencePointArray Class


ReferencePointArrayIterator Class

[image]

Revit 2024 API
ReferencePointArrayIterator Class
Members See Also Send Feedback
An iterator to a reference array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public abstract class ReferencePointArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class ReferencePointArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ReferencePointArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..ReferencePointArrayIterator

See Also

ReferencePointArrayIterator Members


ReferencePointArrayIterator Members

[image] [image]

Revit 2024 API
ReferencePointArrayIterator Members
ReferencePointArrayIterator Class Constructors Methods Properties See Also Send Feedback

The ReferencePointArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | ReferencePointArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ReferencePointArrayIterator Class


ReferencePointArrayIterator Constructor

[image]

Revit 2024 API
ReferencePointArrayIterator Constructor
ReferencePointArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ReferencePointArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
ReferencePointArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ReferencePointArrayIterator Class


Reset Method

[image]

Revit 2024 API
ReferencePointArrayIterator..::..Reset Method
ReferencePointArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ReferencePointArrayIterator Class


ReferencePointArrayIterator Properties

[image] [image]

Revit 2024 API
ReferencePointArrayIterator Properties
ReferencePointArrayIterator Class See Also Send Feedback

The ReferencePointArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ReferencePointArrayIterator Class


Current Property

[image]

Revit 2024 API
ReferencePointArrayIterator..::..Current Property
ReferencePointArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ReferencePointArrayIterator Class


ReferenceType Enumeration

[image]

Revit 2024 API
ReferenceType Enumeration
See Also Send Feedback
Reference types of curve element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum ReferenceType
Visual Basic
Public Enumeration ReferenceType
Visual C++
public enum class ReferenceType

Members

Member name | Description
None |
WeakReference |
StrongReference |

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


ReferenceWithContext Methods

[image] [image]

Revit 2024 API
ReferenceWithContext Methods
ReferenceWithContext Class See Also Send Feedback

The ReferenceWithContext type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInstanceTransform | Gets the transform of the instance.
Public method | GetReference | Gets the reference of the geometric object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ReferenceWithContext Class


Dispose Method

[image]

Revit 2024 API
ReferenceWithContext..::..Dispose Method
ReferenceWithContext Class See Also Send Feedback
Releases all resources used by the ReferenceWithContext

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ReferenceWithContext Class


GetInstanceTransform Method

[image]

Revit 2024 API
ReferenceWithContext..::..GetInstanceTransform Method
ReferenceWithContext Class See Also Send Feedback
Gets the transform of the instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public Transform GetInstanceTransform()
Visual Basic
Public Function GetInstanceTransform As Transform
Visual C++
public:
Transform^ GetInstanceTransform()

Return Value

The transform of an instance when the reference is returned by FindReferencesWithContextByDirection(XYZ, XYZ, View3D) or ReferenceIntersector.Find(XYZ, XYZ).

See Also

ReferenceWithContext Class


GetReference Method

[image]

Revit 2024 API
ReferenceWithContext..::..GetReference Method
ReferenceWithContext Class See Also Send Feedback
Gets the reference of the geometric object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public Reference GetReference()
Visual Basic
Public Function GetReference As Reference
Visual C++
public:
Reference^ GetReference()

Return Value

The reference of a geometric object when it is returned by FindReferencesWithContextByDirection(XYZ, XYZ, View3D) or ReferenceIntersector.Find(XYZ, XYZ).

See Also

ReferenceWithContext Class


ReferenceWithContext Properties

[image] [image]

Revit 2024 API
ReferenceWithContext Properties
ReferenceWithContext Class See Also Send Feedback

The ReferenceWithContext type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Proximity | The proximity value to the ray's origin when the reference is returned by FindReferencesWithContextByDirection(XYZ, XYZ, View3D) or ReferenceIntersector.Find(XYZ, XYZ).

See Also

ReferenceWithContext Class


IsValidObject Property

[image]

Revit 2024 API
ReferenceWithContext..::..IsValidObject Property
ReferenceWithContext Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ReferenceWithContext Class


RelinquishedItems Class

[image]

Revit 2024 API
RelinquishedItems Class
Members See Also Send Feedback
List of elements and worksets that were relinquished by the current user.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class RelinquishedItems : IDisposable
Visual Basic
Public Class RelinquishedItems _
    Implements IDisposable
Visual C++
public ref class RelinquishedItems : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..RelinquishedItems

See Also

RelinquishedItems Members


RelinquishedItems Methods

[image] [image]

Revit 2024 API
RelinquishedItems Methods
RelinquishedItems Class See Also Send Feedback

The RelinquishedItems type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRelinquishedElements | The elements that were relinquished by the current user.
Public method | GetRelinquishedWorksets | The elements that were relinquished by the current user.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RelinquishedItems Class


Dispose Method

[image]

Revit 2024 API
RelinquishedItems..::..Dispose Method
RelinquishedItems Class See Also Send Feedback
Releases all resources used by the RelinquishedItems

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

RelinquishedItems Class


GetRelinquishedWorksets Method

[image]

Revit 2024 API
RelinquishedItems..::..GetRelinquishedWorksets Method
RelinquishedItems Class See Also Send Feedback
The elements that were relinquished by the current user.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ICollection<WorksetId> GetRelinquishedWorksets()
Visual Basic
Public Function GetRelinquishedWorksets As ICollection(Of WorksetId)
Visual C++
public:
ICollection<WorksetId^>^ GetRelinquishedWorksets()

See Also

RelinquishedItems Class


RelinquishedItems Properties

[image] [image]

Revit 2024 API
RelinquishedItems Properties
RelinquishedItems Class See Also Send Feedback

The RelinquishedItems type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

RelinquishedItems Class


IsValidObject Property

[image]

Revit 2024 API
RelinquishedItems..::..IsValidObject Property
RelinquishedItems Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

RelinquishedItems Class


RelinquishOptions Class

[image]

Revit 2024 API
RelinquishOptions Class
Members See Also Send Feedback
Options to control behavior of relinquishing ownership of elements and worksets.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class RelinquishOptions : IDisposable
Visual Basic
Public Class RelinquishOptions _
    Implements IDisposable
Visual C++
public ref class RelinquishOptions : IDisposable

Remarks

The settings correspond to the checkboxes in the Synchronize with Central dialog in the section "After synchronizing, relinquish the following worksets and elements:".

An element can be owned (reflected in the "Edited By" parameter) either by being checked out ("borrowed") or by belonging to a checked out workset.

Relinquishing a workset will relinquish all its unmodified elements that the current user owns.

The subtle interactions between checking out elements and checking out worksets are beyond the scope of the documentation for this class. But as an example, if a wall is borrowed (explicitly checked out) and then its workset is checked out, then the wall is no longer considered borrowed because the workset ownership implicitly grants ownership of all elements in the workset (except elements borrowed by other users).

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..RelinquishOptions

See Also

RelinquishOptions Members


RelinquishOptions Members

[image] [image]

Revit 2024 API
RelinquishOptions Members
RelinquishOptions Class Constructors Methods Properties See Also Send Feedback

The RelinquishOptions type exposes the following members.

Constructors

 | Name | Description
Public method | RelinquishOptions | Constructs a new instance of RelinquishOptions.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the RelinquishOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CheckedOutElements | True means all elements checked out by the current user should be relinquished. False means none of these are relinquished.
Public property | FamilyWorksets | True means all family worksets owned by the current user should be relinquished. False means none of these are relinquished.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | StandardWorksets | True means all project standards worksets owned by the current user should be relinquished. False means none of these are relinquished.
Public property | UserWorksets | True means all user-created worksets owned by the current user should be relinquished. False means none of these are relinquished.
Public property | ViewWorksets | True means all view worksets owned by the current user should be relinquished. False means none of these are relinquished.

See Also

RelinquishOptions Class


RelinquishOptions Constructor

[image]

Revit 2024 API
RelinquishOptions Constructor
RelinquishOptions Class See Also Send Feedback
Constructs a new instance of RelinquishOptions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public RelinquishOptions(
    bool relinquishEverything
)
Visual Basic
Public Sub New ( _
    relinquishEverything As Boolean _
)
Visual C++
public:
RelinquishOptions(
    bool relinquishEverything
)

Parameters

relinquishEverything
Type: System..::..Boolean
The value to apply to all of the members.

See Also

RelinquishOptions Class


Dispose Method

[image]

Revit 2024 API
RelinquishOptions..::..Dispose Method
RelinquishOptions Class See Also Send Feedback
Releases all resources used by the RelinquishOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

RelinquishOptions Class


RelinquishOptions Properties

[image] [image]

Revit 2024 API
RelinquishOptions Properties
RelinquishOptions Class See Also Send Feedback

The RelinquishOptions type exposes the following members.

Properties

 | Name | Description
Public property | CheckedOutElements | True means all elements checked out by the current user should be relinquished. False means none of these are relinquished.
Public property | FamilyWorksets | True means all family worksets owned by the current user should be relinquished. False means none of these are relinquished.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | StandardWorksets | True means all project standards worksets owned by the current user should be relinquished. False means none of these are relinquished.
Public property | UserWorksets | True means all user-created worksets owned by the current user should be relinquished. False means none of these are relinquished.
Public property | ViewWorksets | True means all view worksets owned by the current user should be relinquished. False means none of these are relinquished.

See Also

RelinquishOptions Class


StandardWorksets Property

[image]

Revit 2024 API
RelinquishOptions..::..StandardWorksets Property
RelinquishOptions Class See Also Send Feedback
True means all project standards worksets owned by the current user should be relinquished. False means none of these are relinquished.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool StandardWorksets { get; set; }
Visual Basic
Public Property StandardWorksets As Boolean
    Get
    Set
Visual C++
public:
property bool StandardWorksets {
    bool get ();
    void set (bool value);
}

See Also

RelinquishOptions Class


UserWorksets Property

[image]

Revit 2024 API
RelinquishOptions..::..UserWorksets Property
RelinquishOptions Class See Also Send Feedback
True means all user-created worksets owned by the current user should be relinquished. False means none of these are relinquished.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool UserWorksets { get; set; }
Visual Basic
Public Property UserWorksets As Boolean
    Get
    Set
Visual C++
public:
property bool UserWorksets {
    bool get ();
    void set (bool value);
}

Remarks

This defaults to false in the User Interface.

See Also

RelinquishOptions Class


ViewWorksets Property

[image]

Revit 2024 API
RelinquishOptions..::..ViewWorksets Property
RelinquishOptions Class See Also Send Feedback
True means all view worksets owned by the current user should be relinquished. False means none of these are relinquished.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool ViewWorksets { get; set; }
Visual Basic
Public Property ViewWorksets As Boolean
    Get
    Set
Visual C++
public:
property bool ViewWorksets {
    bool get ();
    void set (bool value);
}

See Also

RelinquishOptions Class


ReloadLatestOptions Class

[image]

Revit 2024 API
ReloadLatestOptions Class
Members See Also Send Feedback
Options to control behavior of pure reload latest (not part of synchronize with central).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class ReloadLatestOptions : IDisposable
Visual Basic
Public Class ReloadLatestOptions _
    Implements IDisposable
Visual C++
public ref class ReloadLatestOptions : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ReloadLatestOptions

See Also

ReloadLatestOptions Members


ReloadLatestOptions Members

[image] [image]

Revit 2024 API
ReloadLatestOptions Members
ReloadLatestOptions Class Constructors Methods Properties See Also Send Feedback

The ReloadLatestOptions type exposes the following members.

Constructors

 | Name | Description
Public method | ReloadLatestOptions | Constructs a new ReloadLatestOptions object.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ReloadLatestOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ReloadLatestOptions Class


ReloadLatestOptions Constructor

[image]

Revit 2024 API
ReloadLatestOptions Constructor
ReloadLatestOptions Class See Also Send Feedback
Constructs a new ReloadLatestOptions object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ReloadLatestOptions()
Visual Basic
Public Sub New
Visual C++
public:
ReloadLatestOptions()

See Also

ReloadLatestOptions Class


ReloadLatestOptions Methods

[image] [image]

Revit 2024 API
ReloadLatestOptions Methods
ReloadLatestOptions Class See Also Send Feedback

The ReloadLatestOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ReloadLatestOptions Class


Dispose Method

[image]

Revit 2024 API
ReloadLatestOptions..::..Dispose Method
ReloadLatestOptions Class See Also Send Feedback
Releases all resources used by the ReloadLatestOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ReloadLatestOptions Class


ReloadSwapOutInfo Class

[image]

Revit 2024 API
ReloadSwapOutInfo Class
Members See Also Send Feedback
This object contains information about fabrication parts swapped out during reload.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public class ReloadSwapOutInfo : IDisposable
Visual Basic
Public Class ReloadSwapOutInfo _
    Implements IDisposable
Visual C++
public ref class ReloadSwapOutInfo : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ReloadSwapOutInfo

See Also

ReloadSwapOutInfo Members


ReloadSwapOutInfo Members

[image] [image]

Revit 2024 API
ReloadSwapOutInfo Members
ReloadSwapOutInfo Class Methods Properties See Also Send Feedback

The ReloadSwapOutInfo type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ReloadSwapOutInfo
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CurrentVersion | New version.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Part | The ElementId of part being swapped.
Public property | PreviousVersion | Previous version.
Public property | WasSwapped | Whether the swap out was successful.

See Also

ReloadSwapOutInfo Class


ReloadSwapOutInfo Methods

[image] [image]

Revit 2024 API
ReloadSwapOutInfo Methods
ReloadSwapOutInfo Class See Also Send Feedback

The ReloadSwapOutInfo type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ReloadSwapOutInfo Class


Dispose Method

[image]

Revit 2024 API
ReloadSwapOutInfo..::..Dispose Method
ReloadSwapOutInfo Class See Also Send Feedback
Releases all resources used by the ReloadSwapOutInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ReloadSwapOutInfo Class


ReloadSwapOutInfo Properties

[image] [image]

Revit 2024 API
ReloadSwapOutInfo Properties
ReloadSwapOutInfo Class See Also Send Feedback

The ReloadSwapOutInfo type exposes the following members.

Properties

 | Name | Description
Public property | CurrentVersion | New version.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Part | The ElementId of part being swapped.
Public property | PreviousVersion | Previous version.
Public property | WasSwapped | Whether the swap out was successful.

See Also

ReloadSwapOutInfo Class


Part Property

[image]

Revit 2024 API
ReloadSwapOutInfo..::..Part Property
ReloadSwapOutInfo Class See Also Send Feedback
The ElementId of part being swapped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public ElementId Part { get; }
Visual Basic
Public ReadOnly Property Part As ElementId
    Get
Visual C++
public:
property ElementId^ Part {
    ElementId^ get ();
}

See Also

ReloadSwapOutInfo Class


PreviousVersion Property

[image]

Revit 2024 API
ReloadSwapOutInfo..::..PreviousVersion Property
ReloadSwapOutInfo Class See Also Send Feedback
Previous version.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public int PreviousVersion { get; }
Visual Basic
Public ReadOnly Property PreviousVersion As Integer
    Get
Visual C++
public:
property int PreviousVersion {
    int get ();
}

See Also

ReloadSwapOutInfo Class


WasSwapped Property

[image]

Revit 2024 API
ReloadSwapOutInfo..::..WasSwapped Property
ReloadSwapOutInfo Class See Also Send Feedback
Whether the swap out was successful.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public bool WasSwapped { get; }
Visual Basic
Public ReadOnly Property WasSwapped As Boolean
    Get
Visual C++
public:
property bool WasSwapped {
    bool get ();
}

See Also

ReloadSwapOutInfo Class


RenderDuration Enumeration

[image]

Revit 2024 API
RenderDuration Enumeration
See Also Send Feedback
An enumerated type containing possible duration types to do Raytracer render.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public enum RenderDuration
Visual Basic
Public Enumeration RenderDuration
Visual C++
public enum class RenderDuration

Members

Member name | Description
ByLevel | Render by the defined iterations.
ByTime | Render by the defined time.
UntilSatisfactory | Render until satisfactory.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


RenderingImageExposureSettings Class

[image]

Revit 2024 API
RenderingImageExposureSettings Class
Members See Also Send Feedback
Represents the exposure settings of rendering.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public class RenderingImageExposureSettings : IDisposable
Visual Basic
Public Class RenderingImageExposureSettings _
    Implements IDisposable
Visual C++
public ref class RenderingImageExposureSettings : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..RenderingImageExposureSettings

See Also

RenderingImageExposureSettings Members


RenderingImageExposureSettings Members

[image] [image]

Revit 2024 API
RenderingImageExposureSettings Members
RenderingImageExposureSettings Class Methods Properties See Also Send Feedback

The RenderingImageExposureSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the RenderingImageExposureSettings
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ExposureValue | The value of rendering image exposure.
Public property | Highlights | The highlights value.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Saturation | The value of rendering image saturation.
Public property | Shadows | The shadows value.
Public property | WhitePoint | The white point value.

See Also

RenderingImageExposureSettings Class


RenderingImageExposureSettings Methods

[image] [image]

Revit 2024 API
RenderingImageExposureSettings Methods
RenderingImageExposureSettings Class See Also Send Feedback

The RenderingImageExposureSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RenderingImageExposureSettings Class


Dispose Method

[image]

Revit 2024 API
RenderingImageExposureSettings..::..Dispose Method
RenderingImageExposureSettings Class See Also Send Feedback
Releases all resources used by the RenderingImageExposureSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

RenderingImageExposureSettings Class


RenderingImageExposureSettings Properties

[image] [image]

Revit 2024 API
RenderingImageExposureSettings Properties
RenderingImageExposureSettings Class See Also Send Feedback

The RenderingImageExposureSettings type exposes the following members.

Properties

 | Name | Description
Public property | ExposureValue | The value of rendering image exposure.
Public property | Highlights | The highlights value.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Saturation | The value of rendering image saturation.
Public property | Shadows | The shadows value.
Public property | WhitePoint | The white point value.

See Also

RenderingImageExposureSettings Class


ExposureValue Property

[image]

Revit 2024 API
RenderingImageExposureSettings..::..ExposureValue Property
RenderingImageExposureSettings Class See Also Send Feedback
The value of rendering image exposure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double ExposureValue { get; set; }
Visual Basic
Public Property ExposureValue As Double
    Get
    Set
Visual C++
public:
property double ExposureValue {
    double get ();
    void set (double value);
}

Remarks

Default exposure value based on Lighting Scheme.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The value of rendering image exposure is not valid. The valid range is 0 to 21.

See Also

RenderingImageExposureSettings Class


Highlights Property

[image]

Revit 2024 API
RenderingImageExposureSettings..::..Highlights Property
RenderingImageExposureSettings Class See Also Send Feedback
The highlights value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double Highlights { get; set; }
Visual Basic
Public Property Highlights As Double
    Get
    Set
Visual C++
public:
property double Highlights {
    double get ();
    void set (double value);
}

Remarks

Increase this value to get brighter highlights.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The value of highlights is not valid. The valid range is 0 to 1.

See Also

RenderingImageExposureSettings Class


IsValidObject Property

[image]

Revit 2024 API
RenderingImageExposureSettings..::..IsValidObject Property
RenderingImageExposureSettings Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

RenderingImageExposureSettings Class


Saturation Property

[image]

Revit 2024 API
RenderingImageExposureSettings..::..Saturation Property
RenderingImageExposureSettings Class See Also Send Feedback
The value of rendering image saturation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double Saturation { get; set; }
Visual Basic
Public Property Saturation As Double
    Get
    Set
Visual C++
public:
property double Saturation {
    double get ();
    void set (double value);
}

Remarks

Increase this value to get more intense colors.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The value of saturation is not valid. The valid range is 0 to 5.

See Also

RenderingImageExposureSettings Class


Shadows Property

[image]

Revit 2024 API
RenderingImageExposureSettings..::..Shadows Property
RenderingImageExposureSettings Class See Also Send Feedback
The shadows value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double Shadows { get; set; }
Visual Basic
Public Property Shadows As Double
    Get
    Set
Visual C++
public:
property double Shadows {
    double get ();
    void set (double value);
}

Remarks

Increase this value to get darker shadows.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The value of shadows is not valid. The valid range is 0.1 to 4.

See Also

RenderingImageExposureSettings Class


WhitePoint Property

[image]

Revit 2024 API
RenderingImageExposureSettings..::..WhitePoint Property
RenderingImageExposureSettings Class See Also Send Feedback
The white point value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double WhitePoint { get; set; }
Visual Basic
Public Property WhitePoint As Double
    Get
    Set
Visual C++
public:
property double WhitePoint {
    double get ();
    void set (double value);
}

Remarks

Specify the white balance of the rendering(measured in Kelvin). Incandescent lighting:2800 K; Daylight 6500K.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The value of white point is not valid. The valid range is 1800 to 15000.

See Also

RenderingImageExposureSettings Class


RenderingQuality Enumeration

[image]

Revit 2024 API
RenderingQuality Enumeration
See Also Send Feedback
Indicates the rendering quality in rendering settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public enum RenderingQuality
Visual Basic
Public Enumeration RenderingQuality
Visual C++
public enum class RenderingQuality

Members

Member name | Description
Draft | Draft level quality.
Medium | Medium level quality.
High | High level quality.
VeryHigh | Very high level quality.
Custom | Custom level quality.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


RenderingQualitySettings Class

[image]

Revit 2024 API
RenderingQualitySettings Class
Members See Also Send Feedback
Represents the quality settings of rendering.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class RenderingQualitySettings : IDisposable
Visual Basic
Public Class RenderingQualitySettings _
    Implements IDisposable
Visual C++
public ref class RenderingQualitySettings : IDisposable

Remarks

The other properties in this class can only be modified if the RenderingQuality property is currently set to Custom.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..RenderingQualitySettings

See Also

RenderingQualitySettings Members


RenderingQualitySettings Members

[image] [image]

Revit 2024 API
RenderingQualitySettings Members
RenderingQualitySettings Class Methods Properties See Also Send Feedback

The RenderingQualitySettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the RenderingQualitySettings
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCustomQuality | Checks if the current rendering quality is custom or not.
Public method | IsValidRenderLevel | Validate the render level is between 1 and 40
Public method | IsValidRenderTime | Validate the render time is between 1 and 32768.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LightAndMaterialAccuracyMode | A value that controls light and material accuracy mode.
Public property | RenderDuration | A value that controls render duration.
Public property | RenderingQuality | The quality applied for rendering.
Public property | RenderLevel | The render target level as a numerical value between 1 and 40.
Public property | RenderTime | The render target time as a numerical value between 1 and 32768.

See Also

RenderingQualitySettings Class


RenderingQualitySettings Methods

[image] [image]

Revit 2024 API
RenderingQualitySettings Methods
RenderingQualitySettings Class See Also Send Feedback

The RenderingQualitySettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCustomQuality | Checks if the current rendering quality is custom or not.
Public method | IsValidRenderLevel | Validate the render level is between 1 and 40
Public method | IsValidRenderTime | Validate the render time is between 1 and 32768.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RenderingQualitySettings Class


Dispose Method

[image]

Revit 2024 API
RenderingQualitySettings..::..Dispose Method
RenderingQualitySettings Class See Also Send Feedback
Releases all resources used by the RenderingQualitySettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

RenderingQualitySettings Class


IsCustomQuality Method

[image]

Revit 2024 API
RenderingQualitySettings..::..IsCustomQuality Method
RenderingQualitySettings Class See Also Send Feedback
Checks if the current rendering quality is custom or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public bool IsCustomQuality()
Visual Basic
Public Function IsCustomQuality As Boolean
Visual C++
public:
bool IsCustomQuality()

Return Value

True if the current rendering quality is custom, false otherwise.

See Also

RenderingQualitySettings Class


IsValidRenderLevel Method

[image]

Revit 2024 API
RenderingQualitySettings..::..IsValidRenderLevel Method
RenderingQualitySettings Class See Also Send Feedback
Validate the render level is between 1 and 40

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public bool IsValidRenderLevel(
    int value
)
Visual Basic
Public Function IsValidRenderLevel ( _
    value As Integer _
) As Boolean
Visual C++
public:
bool IsValidRenderLevel(
    int value
)

Parameters

value
Type: System..::..Int32
The render level value to validate.

Return Value

True if the render level value is in the proper range, false otherwise.

See Also

RenderingQualitySettings Class


IsValidRenderTime Method

[image]

Revit 2024 API
RenderingQualitySettings..::..IsValidRenderTime Method
RenderingQualitySettings Class See Also Send Feedback
Validate the render time is between 1 and 32768.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public bool IsValidRenderTime(
    int value
)
Visual Basic
Public Function IsValidRenderTime ( _
    value As Integer _
) As Boolean
Visual C++
public:
bool IsValidRenderTime(
    int value
)

Parameters

value
Type: System..::..Int32
The render time value to validate.

Return Value

True if the value is in the proper range, false otherwise.

See Also

RenderingQualitySettings Class


RenderingQualitySettings Properties

[image] [image]

Revit 2024 API
RenderingQualitySettings Properties
RenderingQualitySettings Class See Also Send Feedback

The RenderingQualitySettings type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LightAndMaterialAccuracyMode | A value that controls light and material accuracy mode.
Public property | RenderDuration | A value that controls render duration.
Public property | RenderingQuality | The quality applied for rendering.
Public property | RenderLevel | The render target level as a numerical value between 1 and 40.
Public property | RenderTime | The render target time as a numerical value between 1 and 32768.

See Also

RenderingQualitySettings Class


IsValidObject Property

[image]

Revit 2024 API
RenderingQualitySettings..::..IsValidObject Property
RenderingQualitySettings Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

RenderingQualitySettings Class


LightAndMaterialAccuracyMode Property

[image]

Revit 2024 API
RenderingQualitySettings..::..LightAndMaterialAccuracyMode Property
RenderingQualitySettings Class See Also Send Feedback
A value that controls light and material accuracy mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public LightAndMaterialAccuracyMode LightAndMaterialAccuracyMode { get; set; }
Visual Basic
Public Property LightAndMaterialAccuracyMode As LightAndMaterialAccuracyMode
    Get
    Set
Visual C++
public:
property LightAndMaterialAccuracyMode LightAndMaterialAccuracyMode {
    LightAndMaterialAccuracyMode get ();
    void set (LightAndMaterialAccuracyMode value);
}

Remarks

The method of the renderer engine dealing with materials and shadows.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The RenderingQualitySettings does not use custom quality currently. To use custom quality, set RenderingQuality property to RenderingQuality.Custom.

See Also

RenderingQualitySettings Class


RenderingQuality Property

[image]

Revit 2024 API
RenderingQualitySettings..::..RenderingQuality Property
RenderingQualitySettings Class See Also Send Feedback
The quality applied for rendering.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public RenderingQuality RenderingQuality { get; set; }
Visual Basic
Public Property RenderingQuality As RenderingQuality
    Get
    Set
Visual C++
public:
property RenderingQuality RenderingQuality {
    RenderingQuality get ();
    void set (RenderingQuality value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

RenderingQualitySettings Class


RenderLevel Property

[image]

Revit 2024 API
RenderingQualitySettings..::..RenderLevel Property
RenderingQualitySettings Class See Also Send Feedback
The render target level as a numerical value between 1 and 40.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public int RenderLevel { get; set; }
Visual Basic
Public Property RenderLevel As Integer
    Get
    Set
Visual C++
public:
property int RenderLevel {
    int get ();
    void set (int value);
}

Remarks

Increase this value to increase render level.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The value is not valid for RenderLevel.
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The RenderingQualitySettings does not use custom quality currently. To use custom quality, set RenderingQuality property to RenderingQuality.Custom.

See Also

RenderingQualitySettings Class


RenderTime Property

[image]

Revit 2024 API
RenderingQualitySettings..::..RenderTime Property
RenderingQualitySettings Class See Also Send Feedback
The render target time as a numerical value between 1 and 32768.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public int RenderTime { get; set; }
Visual Basic
Public Property RenderTime As Integer
    Get
    Set
Visual C++
public:
property int RenderTime {
    int get ();
    void set (int value);
}

Remarks

Increase this value to increase render time.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The value is not valid RenderTime.
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The RenderingQualitySettings does not use custom quality currently. To use custom quality, set RenderingQuality property to RenderingQuality.Custom.

See Also

RenderingQualitySettings Class


RenderingSettings Class

[image]

Revit 2024 API
RenderingSettings Class
Members Example See Also Send Feedback
Represents the rendering settings for a 3d view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public class RenderingSettings : IDisposable
Visual Basic
Public Class RenderingSettings _
    Implements IDisposable
Visual C++
public ref class RenderingSettings : IDisposable

Examples

CopyC#
public void GetRenderingSettingsData(View3D view3D)
{
    RenderingSettings renderingSettings = view3D.GetRenderingSettings();

    // get print or screen resolution data
    if (renderingSettings.ResolutionTarget == ResolutionTarget.Printer) // for print resolution
    {
        PrinterResolution printResolution = renderingSettings.PrinterResolution;
        int resolutionValue = renderingSettings.ResolutionValue;
    }
    else    // for screen resolution
    {
        int resolutionValue = renderingSettings.ResolutionValue;
    }

    // Get the outline of the rendering region.
    renderingSettings.UsesRegionRendering = true;
    Outline regionOutline = renderingSettings.GetRenderingRegionOutline();
    XYZ max = regionOutline.MaximumPoint;
    XYZ min = regionOutline.MinimumPoint;

    // get lighting information.
    renderingSettings.LightingSource = LightingSource.ExteriorSun; // set lighting scheme type
    // Please note that the sun setting has been exposed in View.SunAndShadowSettings property already.
    SunAndShadowSettings sunSettings = view3D.SunAndShadowSettings;

    // get the background setting data
    switch (renderingSettings.BackgroundStyle)
    {
        case BackgroundStyle.Color: // for color style
            ColorBackgroundSettings colorBKSettings = renderingSettings.GetBackgroundSettings() as ColorBackgroundSettings;
            Color bkColor = colorBKSettings.Color;
            break;
        case BackgroundStyle.Image: // for image style
            ImageBackgroundSettings imageBKSettings = renderingSettings.GetBackgroundSettings() as ImageBackgroundSettings;
            BackgroundImageFit imageFit = imageBKSettings.BackgroundImageFit;
            string filePath = imageBKSettings.FilePath;
            break;
        case BackgroundStyle.SkyCloudy: // for sky related styles
        case BackgroundStyle.SkyFewClouds:
        case BackgroundStyle.SkyNoClouds:
        case BackgroundStyle.SkyVeryCloudy:
        case BackgroundStyle.SkyVeryFewClouds:
            SkyBackgroundSettings skyBKSettings = renderingSettings.GetBackgroundSettings() as SkyBackgroundSettings;
            //float fHaze = skyBKSettings.Haze;
            break;
        default:
            throw new InvalidOperationException("Not expected background style");
    }

    // Get the rendering image exposure settings
    RenderingImageExposureSettings exposureSettings = renderingSettings.GetRenderingImageExposureSettings();
    double imageShadows = exposureSettings.Shadows;

    // Get the rendering quality settings
    RenderingQualitySettings qualitySettings = renderingSettings.GetRenderingQualitySettings();

    if (qualitySettings.RenderingQuality == RenderingQuality.Custom)
    {
       // The user can set the data only in custom quality
       qualitySettings.RenderDuration = RenderDuration.ByTime;
       qualitySettings.RenderTime = 10;
    }
    else
    {
       // RenderLevel property value is returned according to its rendering quality style.
       // For example, it returns 1.0 for Draft quality and returns 5.0 for Medium quality.
       // RenderDuration and RenderTime property values are always the same for non-custom quality.
       int renderLevels = qualitySettings.RenderLevel;
    }
}
CopyVB.NET
Public Sub GetRenderingSettingsData(view3D As View3D)
   Dim renderingSettings As RenderingSettings = view3D.GetRenderingSettings()

   ' get print or screen resolution data
   If renderingSettings.ResolutionTarget = ResolutionTarget.Printer Then
      ' for print resolution
      Dim printResolution As PrinterResolution = renderingSettings.PrinterResolution
      Dim resolutionValue As Integer = renderingSettings.ResolutionValue
   Else
      ' for screen resolution
      Dim resolutionValue As Integer = renderingSettings.ResolutionValue
   End If

   ' Get the outline of the rendering region.
   renderingSettings.UsesRegionRendering = True
   Dim regionOutline As Outline = renderingSettings.GetRenderingRegionOutline()
   Dim max As XYZ = regionOutline.MaximumPoint
   Dim min As XYZ = regionOutline.MinimumPoint

   ' get lighting information.
   renderingSettings.LightingSource = LightingSource.ExteriorSun
   ' set lighting scheme type
   ' Please note that the sun setting has been exposed in View.SunAndShadowSettings property already.
   Dim sunSettings As SunAndShadowSettings = view3D.SunAndShadowSettings

   ' get the background setting data
   Select Case renderingSettings.BackgroundStyle
      Case BackgroundStyle.Color
         ' for color style
         Dim colorBKSettings As ColorBackgroundSettings = TryCast(renderingSettings.GetBackgroundSettings(), ColorBackgroundSettings)
         Dim bkColor As Color = colorBKSettings.Color
         Exit Select
      Case BackgroundStyle.Image
         ' for image style
         Dim imageBKSettings As ImageBackgroundSettings = TryCast(renderingSettings.GetBackgroundSettings(), ImageBackgroundSettings)
         Dim imageFit As BackgroundImageFit = imageBKSettings.BackgroundImageFit
         Dim filePath As String = imageBKSettings.FilePath
         Exit Select
         ' for sky related styles
      Case BackgroundStyle.SkyCloudy, BackgroundStyle.SkyFewClouds, BackgroundStyle.SkyNoClouds, BackgroundStyle.SkyVeryCloudy, BackgroundStyle.SkyVeryFewClouds
         Dim skyBKSettings As SkyBackgroundSettings = TryCast(renderingSettings.GetBackgroundSettings(), SkyBackgroundSettings)
              'Dim haze As Single = skyBKSettings.Haze
         Exit Select
      Case Else
         Throw New InvalidOperationException("Not expected background style")
   End Select

   ' Get the rendering image exposure settings
   Dim exposureSettings As RenderingImageExposureSettings = renderingSettings.GetRenderingImageExposureSettings()
      Dim imageShadows As Double = exposureSettings.[Shadows]

  ' Get the rendering quality settings
  Dim qualitySettings As RenderingQualitySettings = renderingSettings.GetRenderingQualitySettings()

  If qualitySettings.RenderingQuality = RenderingQuality.[Custom] Then
      ' The user can set the data only in custom quality
      qualitySettings.RenderDuration = RenderDuration.ByTime
      qualitySettings.RenderTime = 10
  Else
      ' RenderLevel property value is returned according to its rendering quality style.
      ' For example, it returns 1.0 for Draft quality and returns 5.0 for Medium quality.
      ' RenderDuration and RenderTime property values are always the same for non-custom quality.
      Dim renderLevels As Integer = qualitySettings.RenderLevel
  End If
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..RenderingSettings

See Also

RenderingSettings Members


RenderingSettings Methods

[image] [image]

Revit 2024 API
RenderingSettings Methods
RenderingSettings Class See Also Send Feedback

The RenderingSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBackgroundSettings | Returns an object that represents the rendering background settings.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRenderingImageExposureSettings | Returns an object that represents the rendering image exposure settings.
Public method | GetRenderingQualitySettings | Returns an object that represents the rendering quality settings.
Public method | GetRenderingRegionOutline | Returns the outline of the rendering region.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetBackgroundSettings | Changes the rendering background settings details for the current background style.
Public method | SetRenderingImageExposureSettings | Changes the rendering image exposure settings.
Public method | SetRenderingQualitySettings | Change rendering quality settings.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RenderingSettings Class


GetBackgroundSettings Method

[image]

Revit 2024 API
RenderingSettings..::..GetBackgroundSettings Method
RenderingSettings Class See Also Send Feedback
Returns an object that represents the rendering background settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public BackgroundSettings GetBackgroundSettings()
Visual Basic
Public Function GetBackgroundSettings As BackgroundSettings
Visual C++
public:
BackgroundSettings^ GetBackgroundSettings()

Return Value

The rendering background settings.

Remarks

Different kind of settings object will be returned according to different background style. It could be SkyBackgroundSettings, ColorBackgroundSettings, or ImageBackgroundSettings.

See Also

RenderingSettings Class


GetRenderingImageExposureSettings Method

[image]

Revit 2024 API
RenderingSettings..::..GetRenderingImageExposureSettings Method
RenderingSettings Class See Also Send Feedback
Returns an object that represents the rendering image exposure settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public RenderingImageExposureSettings GetRenderingImageExposureSettings()
Visual Basic
Public Function GetRenderingImageExposureSettings As RenderingImageExposureSettings
Visual C++
public:
RenderingImageExposureSettings^ GetRenderingImageExposureSettings()

Return Value

The rendering image exposure settings.

See Also

RenderingSettings Class


GetRenderingQualitySettings Method

[image]

Revit 2024 API
RenderingSettings..::..GetRenderingQualitySettings Method
RenderingSettings Class See Also Send Feedback
Returns an object that represents the rendering quality settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public RenderingQualitySettings GetRenderingQualitySettings()
Visual Basic
Public Function GetRenderingQualitySettings As RenderingQualitySettings
Visual C++
public:
RenderingQualitySettings^ GetRenderingQualitySettings()

Return Value

The rendering quality settings.

See Also

RenderingSettings Class


GetRenderingRegionOutline Method

[image]

Revit 2024 API
RenderingSettings..::..GetRenderingRegionOutline Method
RenderingSettings Class See Also Send Feedback
Returns the outline of the rendering region.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public Outline GetRenderingRegionOutline()
Visual Basic
Public Function GetRenderingRegionOutline As Outline
Visual C++
public:
Outline^ GetRenderingRegionOutline()

Return Value

The outline of the rendering region.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The RenderingSettings are not currently using region rendering.

See Also

RenderingSettings Class


SetRenderingImageExposureSettings Method

[image]

Revit 2024 API
RenderingSettings..::..SetRenderingImageExposureSettings Method
RenderingSettings Class See Also Send Feedback
Changes the rendering image exposure settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void SetRenderingImageExposureSettings(
    RenderingImageExposureSettings exposure
)
Visual Basic
Public Sub SetRenderingImageExposureSettings ( _
    exposure As RenderingImageExposureSettings _
)
Visual C++
public:
void SetRenderingImageExposureSettings(
    RenderingImageExposureSettings^ exposure
)

Parameters

exposure
Type: Autodesk.Revit.DB..::..RenderingImageExposureSettings
An instance of the new rendering image exposure settings.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

RenderingSettings Class


RenderingSettings Properties

[image] [image]

Revit 2024 API
RenderingSettings Properties
RenderingSettings Class See Also Send Feedback

The RenderingSettings type exposes the following members.

Properties

 | Name | Description
Public property | BackgroundStyle | The enum value that controls the background style for rendering.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LightingSource | The lighting scheme type.
Public property | PrinterResolution | The resolution level when using printer.
Public property | ResolutionTarget | The resolution target.
Public property | ResolutionValue | The rendering resolution in dots per inch (DPI).
Public property | UsesRegionRendering | The bool value that indicates whether to use region rendering.

See Also

RenderingSettings Class


BackgroundStyle Property

[image]

Revit 2024 API
RenderingSettings..::..BackgroundStyle Property
RenderingSettings Class See Also Send Feedback
The enum value that controls the background style for rendering.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public BackgroundStyle BackgroundStyle { get; set; }
Visual Basic
Public Property BackgroundStyle As BackgroundStyle
    Get
    Set
Visual C++
public:
property BackgroundStyle BackgroundStyle {
    BackgroundStyle get ();
    void set (BackgroundStyle value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

RenderingSettings Class


IsValidObject Property

[image]

Revit 2024 API
RenderingSettings..::..IsValidObject Property
RenderingSettings Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

RenderingSettings Class


LightingSource Property

[image]

Revit 2024 API
RenderingSettings..::..LightingSource Property
RenderingSettings Class See Also Send Feedback
The lighting scheme type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public LightingSource LightingSource { get; set; }
Visual Basic
Public Property LightingSource As LightingSource
    Get
    Set
Visual C++
public:
property LightingSource LightingSource {
    LightingSource get ();
    void set (LightingSource value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

RenderingSettings Class


ResolutionTarget Property

[image]

Revit 2024 API
RenderingSettings..::..ResolutionTarget Property
RenderingSettings Class See Also Send Feedback
The resolution target.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ResolutionTarget ResolutionTarget { get; set; }
Visual Basic
Public Property ResolutionTarget As ResolutionTarget
    Get
    Set
Visual C++
public:
property ResolutionTarget ResolutionTarget {
    ResolutionTarget get ();
    void set (ResolutionTarget value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

RenderingSettings Class


ResolutionValue Property

[image]

Revit 2024 API
RenderingSettings..::..ResolutionValue Property
RenderingSettings Class See Also Send Feedback
The rendering resolution in dots per inch (DPI).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public int ResolutionValue { get; }
Visual Basic
Public ReadOnly Property ResolutionValue As Integer
    Get
Visual C++
public:
property int ResolutionValue {
    int get ();
}

See Also

RenderingSettings Class


RenderNode Class

[image]

Revit 2024 API
RenderNode Class
Members See Also Send Feedback
This is the base class of all render nodes in a model-exporting process.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class RenderNode : IDisposable
Visual Basic
Public Class RenderNode _
    Implements IDisposable
Visual C++
public ref class RenderNode : IDisposable

Remarks

A node can be both geometric (such as an element, light, etc.) or non-geometric (e.g. material). Some types of nodes are container modes, which include other render nodes.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..RenderNode
Autodesk.Revit.DB..::..ContentNode
Autodesk.Revit.DB..::..ElementNode
Autodesk.Revit.DB..::..FaceDetailNode
Autodesk.Revit.DB..::..FaceNode
Autodesk.Revit.DB..::..GroupNode
Autodesk.Revit.DB..::..MaterialNode
Autodesk.Revit.DB..::..ModelCurveNode
Autodesk.Revit.DB..::..TextNode
Autodesk.Revit.DB..::..ViewNode

See Also

RenderNode Members


RenderNode Methods

[image] [image]

Revit 2024 API
RenderNode Methods
RenderNode Class See Also Send Feedback

The RenderNode type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RenderNode Class


Dispose Method

[image]

Revit 2024 API
RenderNode..::..Dispose Method
RenderNode Class See Also Send Feedback
Releases all resources used by the RenderNode

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

RenderNode Class


RenderNode Properties

[image] [image]

Revit 2024 API
RenderNode Properties
RenderNode Class See Also Send Feedback

The RenderNode type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | NodeName | A readable name of the output node.

See Also

RenderNode Class


IsValidObject Property

[image]

Revit 2024 API
RenderNode..::..IsValidObject Property
RenderNode Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

RenderNode Class


RenderNodeAction Enumeration

[image]

Revit 2024 API
RenderNodeAction Enumeration
See Also Send Feedback
Enumerated actions for processing a render node during custom export.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public enum RenderNodeAction
Visual Basic
Public Enumeration RenderNodeAction
Visual C++
public enum class RenderNodeAction

Members

Member name | Description
Proceed | Instruct the exporter to go on with processing the node. It means the exporter will continue handling the node by processing all its child nodes, if it has any, and their geometry where it is relevant.
Skip | Instruct the exporter to skip the node. It means the exporter will not process any child nodes (nor the geometry) of the node. The respective end-node notification will still be invoked though.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


RepeaterBounds Class

[image]

Revit 2024 API
RepeaterBounds Class
Members See Also Send Feedback
Represents bounds of the array of repeating references in 0, 1, or 2 dimensions. (See RepeatingReferenceSource).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class RepeaterBounds : IDisposable
Visual Basic
Public Class RepeaterBounds _
    Implements IDisposable
Visual C++
public ref class RepeaterBounds : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..RepeaterBounds

See Also

RepeaterBounds Members


RepeaterBounds Members

[image] [image]

Revit 2024 API
RepeaterBounds Members
RepeaterBounds Class Methods Properties See Also Send Feedback

The RepeaterBounds type exposes the following members.

Methods

 | Name | Description
Public method | AdjustForCyclicalBounds | Shifts the input coordinates in the cyclical dimensions so that they fall in the [lower bounds, upper bounds] range.
Public method | AreCoordinatesInBounds | Determines whether given coordinates are within the bounds.
Public method | Dispose | Releases all resources used by the RepeaterBounds
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLowerBound | Returns the smallest index of the array in the given dimension.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUpperBound | Returns the highest index of the array in the given dimension.
Public method | IsCyclical | True if the array doesn't have finite bounds in the given dimension. Cyclical bounds indicate that the array forms a closed loop in the given dimension.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DimensionCount | The number of dimensions of the bounds (0, 1 or 2 for zero, one or two dimensional arrays.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

RepeaterBounds Class


RepeaterBounds Methods

[image] [image]

Revit 2024 API
RepeaterBounds Methods
RepeaterBounds Class See Also Send Feedback

The RepeaterBounds type exposes the following members.

Methods

 | Name | Description
Public method | AdjustForCyclicalBounds | Shifts the input coordinates in the cyclical dimensions so that they fall in the [lower bounds, upper bounds] range.
Public method | AreCoordinatesInBounds | Determines whether given coordinates are within the bounds.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLowerBound | Returns the smallest index of the array in the given dimension.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUpperBound | Returns the highest index of the array in the given dimension.
Public method | IsCyclical | True if the array doesn't have finite bounds in the given dimension. Cyclical bounds indicate that the array forms a closed loop in the given dimension.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RepeaterBounds Class


AdjustForCyclicalBounds Method

[image]

Revit 2024 API
RepeaterBounds..::..AdjustForCyclicalBounds Method
RepeaterBounds Class See Also Send Feedback
Shifts the input coordinates in the cyclical dimensions so that they fall in the [lower bounds, upper bounds] range.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public RepeaterCoordinates AdjustForCyclicalBounds(
    RepeaterCoordinates coordinates
)
Visual Basic
Public Function AdjustForCyclicalBounds ( _
    coordinates As RepeaterCoordinates _
) As RepeaterCoordinates
Visual C++
public:
RepeaterCoordinates^ AdjustForCyclicalBounds(
    RepeaterCoordinates^ coordinates
)

Parameters

coordinates
Type: Autodesk.Revit.DB..::..RepeaterCoordinates
The coordinates.

Return Value

The adjusted coordinates.

Remarks

The coordinates must have the same number of dimensions as the bounds. This method does not apply to zero dimensional bounds.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The coordinates coordinates have incompatible number of dimensions.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The bounds must have at least one dimension.

See Also

RepeaterBounds Class


AreCoordinatesInBounds Method

[image]

Revit 2024 API
RepeaterBounds..::..AreCoordinatesInBounds Method
RepeaterBounds Class See Also Send Feedback
Determines whether given coordinates are within the bounds.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool AreCoordinatesInBounds(
    RepeaterCoordinates coordinates,
    bool treatCyclicalBoundsAsInfinite
)
Visual Basic
Public Function AreCoordinatesInBounds ( _
    coordinates As RepeaterCoordinates, _
    treatCyclicalBoundsAsInfinite As Boolean _
) As Boolean
Visual C++
public:
bool AreCoordinatesInBounds(
    RepeaterCoordinates^ coordinates,
    bool treatCyclicalBoundsAsInfinite
)

Parameters

coordinates
Type: Autodesk.Revit.DB..::..RepeaterCoordinates
The coordinates.
treatCyclicalBoundsAsInfinite
Type: System..::..Boolean
True if cyclical directions should be treated as unbounded.

Return Value

True if the coordinates are within the bounds.

Remarks

The coordinates must have the same number of dimensions as the bounds. This method does not apply to zero dimensional bounds.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The coordinates coordinates have incompatible number of dimensions.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The bounds must have at least one dimension.

See Also

RepeaterBounds Class


Dispose Method

[image]

Revit 2024 API
RepeaterBounds..::..Dispose Method
RepeaterBounds Class See Also Send Feedback
Releases all resources used by the RepeaterBounds

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

RepeaterBounds Class


GetLowerBound Method

[image]

Revit 2024 API
RepeaterBounds..::..GetLowerBound Method
RepeaterBounds Class See Also Send Feedback
Returns the smallest index of the array in the given dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public int GetLowerBound(
    int dimension
)
Visual Basic
Public Function GetLowerBound ( _
    dimension As Integer _
) As Integer
Visual C++
public:
int GetLowerBound(
    int dimension
)

Parameters

dimension
Type: System..::..Int32
The dimension.

Return Value

The smallest index of the array in the given dimension.

Remarks

The dimension begins at 0 and must be in the range [0, number of dimensions in the bounds - 1]. This method does not apply to zero dimensional bounds.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The dimension is invalid for these bounds.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The bounds must have at least one dimension.

See Also

RepeaterBounds Class


RepeaterBounds Properties

[image] [image]

Revit 2024 API
RepeaterBounds Properties
RepeaterBounds Class See Also Send Feedback

The RepeaterBounds type exposes the following members.

Properties

 | Name | Description
Public property | DimensionCount | The number of dimensions of the bounds (0, 1 or 2 for zero, one or two dimensional arrays.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

RepeaterBounds Class


DimensionCount Property

[image]

Revit 2024 API
RepeaterBounds..::..DimensionCount Property
RepeaterBounds Class See Also Send Feedback
The number of dimensions of the bounds (0, 1 or 2 for zero, one or two dimensional arrays.)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public int DimensionCount { get; }
Visual Basic
Public ReadOnly Property DimensionCount As Integer
    Get
Visual C++
public:
property int DimensionCount {
    int get ();
}

See Also

RepeaterBounds Class


RepeaterCoordinates Class

[image]

Revit 2024 API
RepeaterCoordinates Class
Members See Also Send Feedback
Represents coordinates in the array of repeating references in 0, 1, or 2 dimensions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class RepeaterCoordinates : IDisposable
Visual Basic
Public Class RepeaterCoordinates _
    Implements IDisposable
Visual C++
public ref class RepeaterCoordinates : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..RepeaterCoordinates

See Also

RepeaterCoordinates Members


RepeaterCoordinates Members

[image] [image]

Revit 2024 API
RepeaterCoordinates Members
RepeaterCoordinates Class Constructors Methods Properties See Also Send Feedback

The RepeaterCoordinates type exposes the following members.

Constructors

 | Name | Description
Public method | RepeaterCoordinates()()()() | Creates zero dimensional coordinates.
Public method | RepeaterCoordinates(Int32) | Creates one dimensional coordinates.
Public method | RepeaterCoordinates(Int32, Int32) | Creates two dimensional coordinates.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the RepeaterCoordinates
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCoordinate | Returns the coordinate in the given dimension.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DimensionCount | The number of dimensions of the coordinates (0, 1 or 2 for zero, one or two dimensional arrays.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

RepeaterCoordinates Class


RepeaterCoordinates Constructor (Int32)

[image]

Revit 2024 API
RepeaterCoordinates Constructor (Int32)
RepeaterCoordinates Class See Also Send Feedback
Creates one dimensional coordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public RepeaterCoordinates(
    int x
)
Visual Basic
Public Sub New ( _
    x As Integer _
)
Visual C++
public:
RepeaterCoordinates(
    int x
)

Parameters

x
Type: System..::..Int32
The coordinate.

See Also

RepeaterCoordinates Class
RepeaterCoordinates Overload


RepeaterCoordinates Constructor (Int32, Int32)

[image]

Revit 2024 API
RepeaterCoordinates Constructor (Int32, Int32)
RepeaterCoordinates Class See Also Send Feedback
Creates two dimensional coordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public RepeaterCoordinates(
    int x,
    int y
)
Visual Basic
Public Sub New ( _
    x As Integer, _
    y As Integer _
)
Visual C++
public:
RepeaterCoordinates(
    int x,
    int y
)

Parameters

x
Type: System..::..Int32
The coordinate in first dimension.
y
Type: System..::..Int32
The coordinate in second dimension.

See Also

RepeaterCoordinates Class
RepeaterCoordinates Overload


RepeaterCoordinates Methods

[image] [image]

Revit 2024 API
RepeaterCoordinates Methods
RepeaterCoordinates Class See Also Send Feedback

The RepeaterCoordinates type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCoordinate | Returns the coordinate in the given dimension.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RepeaterCoordinates Class


Dispose Method

[image]

Revit 2024 API
RepeaterCoordinates..::..Dispose Method
RepeaterCoordinates Class See Also Send Feedback
Releases all resources used by the RepeaterCoordinates

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

RepeaterCoordinates Class


GetCoordinate Method

[image]

Revit 2024 API
RepeaterCoordinates..::..GetCoordinate Method
RepeaterCoordinates Class See Also Send Feedback
Returns the coordinate in the given dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public int GetCoordinate(
    int dimension
)
Visual Basic
Public Function GetCoordinate ( _
    dimension As Integer _
) As Integer
Visual C++
public:
int GetCoordinate(
    int dimension
)

Parameters

dimension
Type: System..::..Int32
The dimension.

Return Value

The coordinate.

Remarks

The dimension begins at 0 and must be in the range [0, number of dimensions in the bounds - 1]. This method does not apply to zero dimensional coordinates.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The dimension is invalid for these coordinates.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The coordinates must have at least one dimension.

See Also

RepeaterCoordinates Class


RepeaterCoordinates Properties

[image] [image]

Revit 2024 API
RepeaterCoordinates Properties
RepeaterCoordinates Class See Also Send Feedback

The RepeaterCoordinates type exposes the following members.

Properties

 | Name | Description
Public property | DimensionCount | The number of dimensions of the coordinates (0, 1 or 2 for zero, one or two dimensional arrays.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

RepeaterCoordinates Class


DimensionCount Property

[image]

Revit 2024 API
RepeaterCoordinates..::..DimensionCount Property
RepeaterCoordinates Class See Also Send Feedback
The number of dimensions of the coordinates (0, 1 or 2 for zero, one or two dimensional arrays.)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public int DimensionCount { get; }
Visual Basic
Public ReadOnly Property DimensionCount As Integer
    Get
Visual C++
public:
property int DimensionCount {
    int get ();
}

See Also

RepeaterCoordinates Class


RepeatingReferenceSource Class

[image]

Revit 2024 API
RepeatingReferenceSource Class
Members See Also Send Feedback
Represents a collection of repeating references.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class RepeatingReferenceSource : IDisposable
Visual Basic
Public Class RepeatingReferenceSource _
    Implements IDisposable
Visual C++
public ref class RepeatingReferenceSource : IDisposable

Remarks

The RepeatingReferenceSource class is the building block for setting up component repeaters. Repeating references are arranged in zero, one or two dimensional arrays. The RepeatingReferenceSource class represents this array of references and provides access to individual repeating references.

Note that there may be gaps in the array (for example a repeating reference source formed by a divided surface with holes, or is non-rectangular surface.)

Repeating reference sources are a property of an element. Only point elements, divided paths and divided surface elements support repeating reference sources. These element respectively have 0, 1 and 2 dimensional repeating references. Use the HasRepeatingReferenceSource() method to query whether an element supports repeating reference sources and the GetDefaultRepeatingReferenceSource() method to obtain a repeating reference source from a given element.

See the ComponentRepeater and ComponentRepeaterSlot classes for more information.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..RepeatingReferenceSource

See Also

RepeatingReferenceSource Members


RepeatingReferenceSource Members

[image] [image]

Revit 2024 API
RepeatingReferenceSource Members
RepeatingReferenceSource Class Methods Properties See Also Send Feedback

The RepeatingReferenceSource type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the RepeatingReferenceSource
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBounds | Returns information about the boundaries of the repeating reference array.
 | GetDefaultRepeatingReferenceSource | Returns the default repeating reference source for a given element.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetReference | Returns an individual repeating reference given by coordinates in the array, or nullNothingnullptra null reference (Nothing in Visual Basic) if there is no reference at the coordinates (for example if there is a hole in a divided surface.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | HasRepeatingReferenceSource | Determines whether an element has any repeating reference sources that can be used when creating component repeaters.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DimensionCount | The dimension count of the repeating reference array.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

RepeatingReferenceSource Class


RepeatingReferenceSource Methods

[image] [image]

Revit 2024 API
RepeatingReferenceSource Methods
RepeatingReferenceSource Class See Also Send Feedback

The RepeatingReferenceSource type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBounds | Returns information about the boundaries of the repeating reference array.
 | GetDefaultRepeatingReferenceSource | Returns the default repeating reference source for a given element.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetReference | Returns an individual repeating reference given by coordinates in the array, or nullNothingnullptra null reference (Nothing in Visual Basic) if there is no reference at the coordinates (for example if there is a hole in a divided surface.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | HasRepeatingReferenceSource | Determines whether an element has any repeating reference sources that can be used when creating component repeaters.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RepeatingReferenceSource Class


Dispose Method

[image]

Revit 2024 API
RepeatingReferenceSource..::..Dispose Method
RepeatingReferenceSource Class See Also Send Feedback
Releases all resources used by the RepeatingReferenceSource

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

RepeatingReferenceSource Class


GetBounds Method

[image]

Revit 2024 API
RepeatingReferenceSource..::..GetBounds Method
RepeatingReferenceSource Class See Also Send Feedback
Returns information about the boundaries of the repeating reference array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public RepeaterBounds GetBounds()
Visual Basic
Public Function GetBounds As RepeaterBounds
Visual C++
public:
RepeaterBounds^ GetBounds()

Return Value

The bounds of the repeating reference source.

Remarks

See the RepeaterBounds structure for more information about repeating reference source bounds.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The repeating reference source is no longer valid.

See Also

RepeatingReferenceSource Class


GetDefaultRepeatingReferenceSource Method

[image]

Revit 2024 API
RepeatingReferenceSource..::..GetDefaultRepeatingReferenceSource Method
RepeatingReferenceSource Class See Also Send Feedback
Returns the default repeating reference source for a given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static RepeatingReferenceSource GetDefaultRepeatingReferenceSource(
    Document document,
    ElementId elementId
)
Visual Basic
Public Shared Function GetDefaultRepeatingReferenceSource ( _
    document As Document, _
    elementId As ElementId _
) As RepeatingReferenceSource
Visual C++
public:
static RepeatingReferenceSource^ GetDefaultRepeatingReferenceSource(
    Document^ document,
    ElementId^ elementId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document that contains the element.
elementId
Type: Autodesk.Revit.DB..::..ElementId
The id of the element.

Return Value

The default repeating reference source of the given element.

Remarks

The element must support repeating references. Use HasRepeatingReferenceSource() to find out whether an element has any repeating references.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element elementId does not exist in the document -or- The element does not have any repeating reference sources.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

RepeatingReferenceSource Class


RepeatingReferenceSource Properties

[image] [image]

Revit 2024 API
RepeatingReferenceSource Properties
RepeatingReferenceSource Class See Also Send Feedback

The RepeatingReferenceSource type exposes the following members.

Properties

 | Name | Description
Public property | DimensionCount | The dimension count of the repeating reference array.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

RepeatingReferenceSource Class


DimensionCount Property

[image]

Revit 2024 API
RepeatingReferenceSource..::..DimensionCount Property
RepeatingReferenceSource Class See Also Send Feedback
The dimension count of the repeating reference array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public int DimensionCount { get; }
Visual Basic
Public ReadOnly Property DimensionCount As Integer
    Get
Visual C++
public:
property int DimensionCount {
    int get ();
}

See Also

RepeatingReferenceSource Class


IsValidObject Property

[image]

Revit 2024 API
RepeatingReferenceSource..::..IsValidObject Property
RepeatingReferenceSource Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

RepeatingReferenceSource Class


ResolutionTarget Enumeration

[image]

Revit 2024 API
ResolutionTarget Enumeration
See Also Send Feedback
Indicates the resolution target(Screen or Printer) used for rendering settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public enum ResolutionTarget
Visual Basic
Public Enumeration ResolutionTarget
Visual C++
public enum class ResolutionTarget

Members

Member name | Description
Screen | Uses screen resolution for rendering output settings.
Printer | Uses printer resolution for rendering output settings.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


Revision Class

[image]

Revit 2024 API
Revision Class
Members See Also Send Feedback
Represents a single revision in the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public class Revision : Element
Visual Basic
Public Class Revision _
    Inherits Element
Visual C++
public ref class Revision : public Element

Remarks

The Revision object represents the data related to a single revision in the project. Revision clouds and tags can be associated with a particular Revision object to display its properties on sheets.

The revisions in the project are stored in a specific order called the revision sequence. The revision sequence represents the conceptual sequence in which revisions will be issued.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..Revision

See Also

Revision Members


Revision Members

[image] [image]

Revit 2024 API
Revision Members
Revision Class Methods Properties See Also Send Feedback

The Revision type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | CombineWithNext | Combines the specified Revision with the next Revision.
 | CombineWithPrevious | Combines the specified Revision with the previous Revision.
 | Create | Creates a new Revision in the project.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
 | GetAllRevisionIds | Returns the ids of all Revisions in the project ordered by sequence number.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
 | ReorderRevisionSequence | Reorders the sequence of Revisions in the project.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | Description | The description of this Revision.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | Issued | Indicates whether this Revision has been issued.
Public property | IssuedBy | Indicates who has issued or will issue this Revision.
Public property | IssuedTo | Indicates to whom this Revision was or will be issued.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RevisionDate | The date of this Revision.
Public property | RevisionNumber | The Revision number of this revision.
Public property | RevisionNumberingSequenceId | The id of the revision numbering sequence which controls this revision's numbering.
Public property | SequenceNumber | The Sequence Number of this Revision.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Visibility | Controls the visibility of revision clouds and revision tags related to this Revision.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Revision Class


Revision Methods

[image] [image]

Revit 2024 API
Revision Methods
Revision Class See Also Send Feedback

The Revision type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | CombineWithNext | Combines the specified Revision with the next Revision.
 | CombineWithPrevious | Combines the specified Revision with the previous Revision.
 | Create | Creates a new Revision in the project.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
 | GetAllRevisionIds | Returns the ids of all Revisions in the project ordered by sequence number.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
 | ReorderRevisionSequence | Reorders the sequence of Revisions in the project.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Revision Class


CombineWithNext Method

[image]

Revit 2024 API
Revision..::..CombineWithNext Method
Revision Class Example See Also Send Feedback
Combines the specified Revision with the next Revision.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static ISet<ElementId> CombineWithNext(
    Document document,
    ElementId revisionId
)
Visual Basic
Public Shared Function CombineWithNext ( _
    document As Document, _
    revisionId As ElementId _
) As ISet(Of ElementId)
Visual C++
public:
static ISet<ElementId^>^ CombineWithNext(
    Document^ document,
    ElementId^ revisionId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The Document containing the Revisions.
revisionId
Type: Autodesk.Revit.DB..::..ElementId
The Revision that should have its clouds and tags associated with the next Revision.

Return Value

The ids of all RevisionClouds that were reassigned to the next Revision.

Remarks

All RevisionClouds and tags associated with the specified Revision will be reassigned to the next Revision in the model and the specified Revision will be deleted from the model. The operation can only be performed if both the specified Revision and the next one are unissued.

Examples

CopyC#
private bool CombineRevision(Document document, Revision revision)
{
    bool combined = false;
    // Can only combine two revisions if neither have been issued
    if (revision.Issued == false)
    {
        ElementId revisionId = revision.Id;
        Revision nextRevsion = GetNextRevision(document, revisionId);
        if (nextRevsion != null && nextRevsion.Issued == false)
        {
            ISet<ElementId> revisionCloudIds = Revision.CombineWithNext(document, revisionId);
            combined = true;
            int movedClouds = revisionCloudIds.Count;
            if (movedClouds > 0)
            {
                RevisionCloud cloud = document.GetElement(revisionCloudIds.ElementAt(0)) as RevisionCloud;
                if (cloud != null)
                {
                    string msg = string.Format("Revision {0} deleted and {1} revision clouds were added to Revsion {2}",
                        revisionId.ToString(), movedClouds, cloud.RevisionId.ToString());
                    TaskDialog.Show("Revision Combined", msg);
                }
            }
        }
    }

    return combined;
}

private Revision GetNextRevision(Document document, ElementId currentRevisionId)
{
    Revision nextRevision = null;
    IList<ElementId> revisionIds = Revision.GetAllRevisionIds(document);
    int currentRevisionIndex = -1;
    for (int n = 0; n < revisionIds.Count; n++)
    {
        if (revisionIds[n] == currentRevisionId)
        {
            currentRevisionIndex = n;
            break;
        }
    }

    // if the current revision id was found and is not the last index
    if (currentRevisionIndex >= 0 && currentRevisionIndex < revisionIds.Count - 1)
    {
        ElementId nextRevisionId = revisionIds[currentRevisionIndex + 1];
        nextRevision = document.GetElement(nextRevisionId) as Revision;
    }

    return nextRevision;
}
CopyVB.NET
Private Function CombineRevision(document As Document, revision__1 As Revision) As Boolean
    Dim combined As Boolean = False
    ' Can only combine two revisions if neither have been issued
    If revision__1.Issued = False Then
        Dim revisionId As ElementId = revision__1.Id
        Dim nextRevsion As Revision = GetNextRevision(document, revisionId)
        If nextRevsion IsNot Nothing AndAlso nextRevsion.Issued = False Then
            Dim revisionCloudIds As ISet(Of ElementId) = Revision.CombineWithNext(document, revisionId)
            combined = True
            Dim movedClouds As Integer = revisionCloudIds.Count
            If movedClouds > 0 Then
                Dim cloud As RevisionCloud = TryCast(document.GetElement(revisionCloudIds.ElementAt(0)), RevisionCloud)
                If cloud IsNot Nothing Then
                    Dim msg As String = String.Format("Revision {0} deleted and {1} revision clouds were added to Revsion {2}", revisionId.ToString(), movedClouds, cloud.RevisionId.ToString())
                    TaskDialog.Show("Revision Combined", msg)
                End If
            End If
        End If
    End If

    Return combined
End Function

Private Function GetNextRevision(document As Document, currentRevisionId As ElementId) As Revision
    Dim nextRevision As Revision = Nothing
    Dim revisionIds As IList(Of ElementId) = Revision.GetAllRevisionIds(document)
    Dim currentRevisionIndex As Integer = -1
    For n As Integer = 0 To revisionIds.Count - 1
        If revisionIds(n) = currentRevisionId Then
            currentRevisionIndex = n
            Exit For
        End If
    Next

    ' if the current revision id was found and is not the last index
    If currentRevisionIndex >= 0 AndAlso currentRevisionIndex < revisionIds.Count - 1 Then
        Dim nextRevisionId As ElementId = revisionIds(currentRevisionIndex + 1)
        nextRevision = TryCast(document.GetElement(nextRevisionId), Revision)
    End If

    Return nextRevision
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | revisionId is not a valid Revision. -or- This operation cannot be performed because revisionId is an issued Revision. -or- revisionId cannot be combined with the next Revision because either revisionId is the last Revision or the next Revision has already been issued.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Revision Class


Create Method

[image]

Revit 2024 API
Revision..::..Create Method
Revision Class Example See Also Send Feedback
Creates a new Revision in the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static Revision Create(
    Document document
)
Visual Basic
Public Shared Function Create ( _
    document As Document _
) As Revision
Visual C++
public:
static Revision^ Create(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document of the new Revision.

Return Value

The newly created Revision.

Remarks

The new Revision will be added at the end of the sequence of existing Revisions.

Examples

CopyC#
private Revision AddNewRevision(Document document, string description, string issuedBy, string issuedTo, ElementId sequenceNumber, DateTime date)
{
    Revision newRevision = Revision.Create(document);
    newRevision.Description = description;
    newRevision.IssuedBy = issuedBy;
    newRevision.IssuedTo = issuedTo;
    newRevision.RevisionNumberingSequenceId = sequenceNumber;
    newRevision.RevisionDate = date.ToShortDateString();
    return newRevision;
}
CopyVB.NET
Private Function AddNewRevision(document As Document, description As String, issuedBy As String, issuedTo As String, sequenceNumber As ElementId, [date] As DateTime) As Revision
    Dim newRevision As Revision = Revision.Create(document)
    newRevision.Description = description
    newRevision.IssuedBy = issuedBy
    newRevision.IssuedTo = issuedTo
    newRevision.RevisionNumberingSequenceId = sequenceNumber
    newRevision.RevisionDate = [date].ToShortDateString()
    Return newRevision
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Revision Class


GetAllRevisionIds Method

[image]

Revit 2024 API
Revision..::..GetAllRevisionIds Method
Revision Class See Also Send Feedback
Returns the ids of all Revisions in the project ordered by sequence number.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static IList<ElementId> GetAllRevisionIds(
    Document document
)
Visual Basic
Public Shared Function GetAllRevisionIds ( _
    document As Document _
) As IList(Of ElementId)
Visual C++
public:
static IList<ElementId^>^ GetAllRevisionIds(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document containing the Revisions.

Return Value

The ids of all the Revisions in the document ordered by sequence number.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Revision Class


Revision Properties

[image] [image]

Revit 2024 API
Revision Properties
Revision Class See Also Send Feedback

The Revision type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | Description | The description of this Revision.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | Issued | Indicates whether this Revision has been issued.
Public property | IssuedBy | Indicates who has issued or will issue this Revision.
Public property | IssuedTo | Indicates to whom this Revision was or will be issued.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RevisionDate | The date of this Revision.
Public property | RevisionNumber | The Revision number of this revision.
Public property | RevisionNumberingSequenceId | The id of the revision numbering sequence which controls this revision's numbering.
Public property | SequenceNumber | The Sequence Number of this Revision.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Visibility | Controls the visibility of revision clouds and revision tags related to this Revision.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Revision Class


Description Property

[image]

Revit 2024 API
Revision..::..Description Property
Revision Class See Also Send Feedback
The description of this Revision.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: This operation cannot be performed on Revisions that have already been issued.

See Also

Revision Class


IssuedTo Property

[image]

Revit 2024 API
Revision..::..IssuedTo Property
Revision Class See Also Send Feedback
Indicates to whom this Revision was or will be issued.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public string IssuedTo { get; set; }
Visual Basic
Public Property IssuedTo As String
    Get
    Set
Visual C++
public:
property String^ IssuedTo {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: This operation cannot be performed on Revisions that have already been issued.

See Also

Revision Class


Parameter Property

[image] [image]

Revit 2024 API
Revision..::..Parameter Property
Revision Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Revision Class
Revision Members


RevisionDate Property

[image]

Revit 2024 API
Revision..::..RevisionDate Property
Revision Class See Also Send Feedback
The date of this Revision.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public string RevisionDate { get; set; }
Visual Basic
Public Property RevisionDate As String
    Get
    Set
Visual C++
public:
property String^ RevisionDate {
    String^ get ();
    void set (String^ value);
}

Remarks

The Revision date is an arbitrary String and can be blank. Revit will not attempt to interpret it as an actual date.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: This operation cannot be performed on Revisions that have already been issued.

See Also

Revision Class


RevisionNumberingSequenceId Property

[image]

Revit 2024 API
Revision..::..RevisionNumberingSequenceId Property
Revision Class See Also Send Feedback
The id of the revision numbering sequence which controls this revision's numbering.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public ElementId RevisionNumberingSequenceId { get; set; }
Visual Basic
Public Property RevisionNumberingSequenceId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ RevisionNumberingSequenceId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: revisionNumberingSequenceId doesn't represent a RevisionNumberingSequence element.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: This operation cannot be performed on Revisions that have already been issued.

See Also

Revision Class


Visibility Property

[image]

Revit 2024 API
Revision..::..Visibility Property
Revision Class See Also Send Feedback
Controls the visibility of revision clouds and revision tags related to this Revision.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public RevisionVisibility Visibility { get; set; }
Visual Basic
Public Property Visibility As RevisionVisibility
    Get
    Set
Visual C++
public:
property RevisionVisibility Visibility {
    RevisionVisibility get ();
    void set (RevisionVisibility value);
}

Remarks

This property provides project-wide control over the visibility of revision clouds and tags associated with this Revision. If clouds or tags are hidden by this property they will not be visible in any views regardless of the view's settings. If clouds or tags are visible according to this property they may still be hidden on a particular view or sheet.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

Revision Class


RevisionCloud Class

[image]

Revit 2024 API
RevisionCloud Class
Members See Also Send Feedback
A RevisionCloud is a graphical "cloud" that can be displayed on a view or sheet to indicate where revisions in the model have occurred.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public class RevisionCloud : Element
Visual Basic
Public Class RevisionCloud _
    Inherits Element
Visual C++
public ref class RevisionCloud : public Element

Remarks

RevisionClouds are view specific and can be created in most graphical views, except 3D. Unlike most Elements, RevisionClouds may be added directly to a ViewSheet. Each RevisionCloud is associated with one Revision.

When a RevisionCloud is visible on a ViewSheet (either because it is directly placed on that ViewSheet or because it is visible in a View placed on the ViewSheet), any revision schedules displayed on the ViewSheet will automatically include the Revision associated with the RevisionCloud.

Note also that when a RevisionCloud is created in a ViewLegend, it is treated as a legend representation of what a RevisionCloud looks like rather than as an actual indication of a change to the model. As a result, RevisionClouds in ViewLegends will not affect the contents of revision schedules.

RevisionClouds are created from a collection of sketched curves. Each curve will have a series of "cloud bumps" drawn along it to form the appearance of a cloud. There is no requirement that the curves form closed loops.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..RevisionCloud

See Also

RevisionCloud Members


RevisionCloud Members

[image] [image]

Revit 2024 API
RevisionCloud Members
RevisionCloud Class Methods Properties See Also Send Feedback

The RevisionCloud type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create | Creates a new RevisionCloud in the model.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSheetIds | Returns the ids of the ViewSheets where this RevisionCloud may appear and contribute to the sheet's revision schedule.
Public method | GetSketchCurves | Returns copies of the Curves that form this RevisionCloud.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsRevisionIssued | Indicates whether the Revision associated with this RevisionCloud has been issued.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RevisionId | The Revision associated with this RevisionCloud.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

RevisionCloud Class


RevisionCloud Methods

[image] [image]

Revit 2024 API
RevisionCloud Methods
RevisionCloud Class See Also Send Feedback

The RevisionCloud type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create | Creates a new RevisionCloud in the model.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSheetIds | Returns the ids of the ViewSheets where this RevisionCloud may appear and contribute to the sheet's revision schedule.
Public method | GetSketchCurves | Returns copies of the Curves that form this RevisionCloud.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsRevisionIssued | Indicates whether the Revision associated with this RevisionCloud has been issued.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RevisionCloud Class


Create Method

[image]

Revit 2024 API
RevisionCloud..::..Create Method
RevisionCloud Class Example See Also Send Feedback
Creates a new RevisionCloud in the model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static RevisionCloud Create(
    Document document,
    View view,
    ElementId revisionId,
    IList<Curve> curves
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    view As View, _
    revisionId As ElementId, _
    curves As IList(Of Curve) _
) As RevisionCloud
Visual C++
public:
static RevisionCloud^ Create(
    Document^ document,
    View^ view,
    ElementId^ revisionId,
    IList<Curve^>^ curves
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which the RevisionCloud should be created.
view
Type: Autodesk.Revit.DB..::..View
The View in which the RevisionCloud should appear.
revisionId
Type: Autodesk.Revit.DB..::..ElementId
The Revision to associate with the new RevisionCloud.
curves
Type: System.Collections.Generic..::..IList<(Of <(<' Curve >)>)>
The curves that will form the RevisionCloud's sketch.

Return Value

The newly created RevisionCloud.

Remarks

Creates a new RevisionCloud in the specified View. The new RevisionCloud will be associated with the specified Revision. RevisionClouds can only be created if the Revision has not yet been issued.

RevisionClouds can be created in most graphical Views, excepting 3D views and graphical column schedules. Unlike most other Elements, RevisionClouds can be created directly on a ViewSheet.

RevisionClouds are created based on a series of sketched curves. There is no requirement that the curves form closed loops and self-intersections are also permitted. The curves will be automatically projected onto the appropriate plane for the View. The list of curves cannot be empty and any lines cannot be perpendicular to the View's plane. If the View is a model View, the coordinates specified for the curves will be interpreted in model space. If the View is a non-model View (such as a ViewSheet) then the coordinates will be interpreted in the View's space.

The cloud graphics will be attached to the curves under the assumption that each curve is oriented in a clockwise direction. For lines, this means that the outside of the cloud is in the direction of the line's normal vector within the View's plane. Any closed loops should therefore be oriented clockwise to create the typical cloud shape.

Examples

CopyC#
private void CreateRevisionCloudInActiveView(Document document, Revision revision, IList<Curve> curves)
{
    using (Transaction newRevisionCloud = new Transaction(document, "Create Revision Cloud"))
    {
        newRevisionCloud.Start();
        // Can only create revision cloud for revision that is not issued
        if (revision.Issued == false)
        {
            RevisionCloud.Create(document, document.ActiveView, revision.Id, curves);
            newRevisionCloud.Commit();
        }
        else
        {
            newRevisionCloud.RollBack();
        }
    }
}
CopyVB.NET
Private Sub CreateRevisionCloudInActiveView(document As Document, revision As Revision, curves As IList(Of Curve))
    Using newRevisionCloud As New Transaction(document, "Create Revision Cloud")
        newRevisionCloud.Start()
        ' Can only create revision cloud for revision that is not issued
        If revision.Issued = False Then
            RevisionCloud.Create(document, document.ActiveView, revision.Id, curves)
            newRevisionCloud.Commit()
        Else
            newRevisionCloud.RollBack()
        End If
    End Using
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- revisionId is not a valid Revision. -or- This operation cannot be performed because revisionId is an issued Revision. -or- view is not a View that can support RevisionClouds. -or- The provided Curves curves cannot be used as the basis for a RevisionCloud. Either the list is empty or one or more of the Curves could not be projected onto the View's plane.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

RevisionCloud Class


GetSheetIds Method

[image]

Revit 2024 API
RevisionCloud..::..GetSheetIds Method
RevisionCloud Class See Also Send Feedback
Returns the ids of the ViewSheets where this RevisionCloud may appear and contribute to the sheet's revision schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public ISet<ElementId> GetSheetIds()
Visual Basic
Public Function GetSheetIds As ISet(Of ElementId)
Visual C++
public:
ISet<ElementId^>^ GetSheetIds()

Return Value

The ids of the ViewSheets where this RevisionCloud may appear.

Remarks

A RevisionCloud can appear on a ViewSheet because it is drawn directly on the ViewSheet or because its owner view is placed on the ViewSheet. If the RevisionCloud is owned by a view that is a dependent view or has associated dependent views, then the RevisionCloud can also be visible on the sheets where the related dependent or primary views have been placed.

This RevisionCloud may not be visible in all ViewSheets reported by this method. Additional factors, such as the visibility settings or annotation crop of the Views or the visibility settings of the associated Revision may still cause this RevisionCloud to not appear on a particular ViewSheet.

If this RevisionCloud is owned by a ViewLegend, no sheets will be returned because the RevisionCloud will not participate in revision schedules.

See Also

RevisionCloud Class


IsRevisionIssued Method

[image]

Revit 2024 API
RevisionCloud..::..IsRevisionIssued Method
RevisionCloud Class See Also Send Feedback
Indicates whether the Revision associated with this RevisionCloud has been issued.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool IsRevisionIssued()
Visual Basic
Public Function IsRevisionIssued As Boolean
Visual C++
public:
bool IsRevisionIssued()

Return Value

True if the Revision has been issued, False otherwise.

See Also

RevisionCloud Class


RevisionCloud Properties

[image] [image]

Revit 2024 API
RevisionCloud Properties
RevisionCloud Class See Also Send Feedback

The RevisionCloud type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RevisionId | The Revision associated with this RevisionCloud.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

RevisionCloud Class


Parameter Property

[image] [image]

Revit 2024 API
RevisionCloud..::..Parameter Property
RevisionCloud Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

RevisionCloud Class
RevisionCloud Members


RevisionId Property

[image]

Revit 2024 API
RevisionCloud..::..RevisionId Property
RevisionCloud Class See Also Send Feedback
The Revision associated with this RevisionCloud.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public ElementId RevisionId { get; set; }
Visual Basic
Public Property RevisionId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ RevisionId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Remarks

This property cannot be set to a Revision that has already been issued. If this RevisionCloud is already associated with a Revision that has been issued then this property cannot be changed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: revisionId is not a valid Revision. -or- When setting this property: This operation cannot be performed because revisionId is an issued Revision.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: This operation cannot be performed on a RevisionCloud associated with a Revision that has been issued.

See Also

RevisionCloud Class


RevisionNumberingSequence Class

[image]

Revit 2024 API
RevisionNumberingSequence Class
Members See Also Send Feedback
Defines the sequences by which numbers are assigned to Revisions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public class RevisionNumberingSequence : Element
Visual Basic
Public Class RevisionNumberingSequence _
    Inherits Element
Visual C++
public ref class RevisionNumberingSequence : public Element

Remarks

Revision numbering is numeric or alphanumeric. Revision numbering is assigned to Revisions to control the numbering scheme of that Revision.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..RevisionNumberingSequence

See Also

RevisionNumberingSequence Members


RevisionNumberingSequence Members

[image] [image]

Revit 2024 API
RevisionNumberingSequence Members
RevisionNumberingSequence Class Methods Properties See Also Send Feedback

The RevisionNumberingSequence type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | CreateAlphanumericSequence | Creates a new alphanumeric revision numbering sequence in the document.
 | CreateNumericSequence | Creates a new numeric revision numbering sequence in the document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
 | GetAllRevisionNumberingSequences | Gets all of the revision numbering sequences from the document.
Public method | GetAlphanumericRevisionSettings | Returns a copy of the AlphanumericRevisionSettings owned by this revision numbering sequence.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetNumericRevisionSettings | Returns a copy of the NumericRevisionSettings owned by this revision numbering sequence.
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasValidAlphanumericRevisionSettings | Checks whether the revision numbering sequence owns a valid alphanumeric revision settings.
Public method | HasValidNumericRevisionSettings | Checks whether the revision numbering sequence owns a valid numeric revision settings.
Public method | HasValidRevisionSettingsForNumberType | Checks whether the revision numbering sequence owns a valid revision settings for number type.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetAlphanumericRevisionSettings | Replaces the current alphanumeric revision numbering settings with the provided settings.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetNumericRevisionSettings | Replaces the current numeric revision numbering settings with the provided settings.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | NumberType | Indicates the revision number type of the revision numbering sequence.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SequenceName | The name of this revision numbering sequence.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

RevisionNumberingSequence Class


CreateAlphanumericSequence Method

[image]

Revit 2024 API
RevisionNumberingSequence..::..CreateAlphanumericSequence Method
RevisionNumberingSequence Class See Also Send Feedback
Creates a new alphanumeric revision numbering sequence in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public static RevisionNumberingSequence CreateAlphanumericSequence(
    Document document,
    string name,
    AlphanumericRevisionSettings settings
)
Visual Basic
Public Shared Function CreateAlphanumericSequence ( _
    document As Document, _
    name As String, _
    settings As AlphanumericRevisionSettings _
) As RevisionNumberingSequence
Visual C++
public:
static RevisionNumberingSequence^ CreateAlphanumericSequence(
    Document^ document,
    String^ name,
    AlphanumericRevisionSettings^ settings
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document of the new revision numbering sequence.
name
Type: System..::..String
The name for the revision numbering sequence.
settings
Type: Autodesk.Revit.DB..::..AlphanumericRevisionSettings
The alphanumeric settings for the revision numbering sequence.

Return Value

The newly created revision numbering sequence.

Remarks

The new revision numbering sequence will not be assigned to any revision. Use `Revision.SetRevisionNumberingSequenceId` to apply the sequence to a revision.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- name is an empty string or contains only whitespace. -or- name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- settings is not a valid AlphanumericRevisionSettings.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

RevisionNumberingSequence Class


CreateNumericSequence Method

[image]

Revit 2024 API
RevisionNumberingSequence..::..CreateNumericSequence Method
RevisionNumberingSequence Class See Also Send Feedback
Creates a new numeric revision numbering sequence in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public static RevisionNumberingSequence CreateNumericSequence(
    Document document,
    string name,
    NumericRevisionSettings settings
)
Visual Basic
Public Shared Function CreateNumericSequence ( _
    document As Document, _
    name As String, _
    settings As NumericRevisionSettings _
) As RevisionNumberingSequence
Visual C++
public:
static RevisionNumberingSequence^ CreateNumericSequence(
    Document^ document,
    String^ name,
    NumericRevisionSettings^ settings
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document of the new revision numbering sequence.
name
Type: System..::..String
The name for the revision numbering sequence.
settings
Type: Autodesk.Revit.DB..::..NumericRevisionSettings
The numeric settings for the revision numbering sequence.

Return Value

The newly created revision numbering sequence.

Remarks

The new revision numbering sequence will not be assigned to any revision. Use `Revision.SetRevisionNumberingSequenceId` to apply the sequence to a revision.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- name is an empty string or contains only whitespace. -or- name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- settings is not a valid NumericRevisionSettings.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

RevisionNumberingSequence Class


GetAlphanumericRevisionSettings Method

[image]

Revit 2024 API
RevisionNumberingSequence..::..GetAlphanumericRevisionSettings Method
RevisionNumberingSequence Class See Also Send Feedback
Returns a copy of the AlphanumericRevisionSettings owned by this revision numbering sequence.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public AlphanumericRevisionSettings GetAlphanumericRevisionSettings()
Visual Basic
Public Function GetAlphanumericRevisionSettings As AlphanumericRevisionSettings
Visual C++
public:
AlphanumericRevisionSettings^ GetAlphanumericRevisionSettings()

Return Value

The copy of the AlphaumericRevisionSettings owned by this revision numbering sequence.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This RevisionNumberingSequence doesn't own a valid alphanumeric revision settings.

See Also

RevisionNumberingSequence Class


GetNumericRevisionSettings Method

[image]

Revit 2024 API
RevisionNumberingSequence..::..GetNumericRevisionSettings Method
RevisionNumberingSequence Class See Also Send Feedback
Returns a copy of the NumericRevisionSettings owned by this revision numbering sequence.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public NumericRevisionSettings GetNumericRevisionSettings()
Visual Basic
Public Function GetNumericRevisionSettings As NumericRevisionSettings
Visual C++
public:
NumericRevisionSettings^ GetNumericRevisionSettings()

Return Value

The copy of the NumericRevisionSettings owned by this revision numbering sequence.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This RevisionNumberingSequence doesn't own a valid numeric revision settings.

See Also

RevisionNumberingSequence Class


HasValidAlphanumericRevisionSettings Method

[image]

Revit 2024 API
RevisionNumberingSequence..::..HasValidAlphanumericRevisionSettings Method
RevisionNumberingSequence Class See Also Send Feedback
Checks whether the revision numbering sequence owns a valid alphanumeric revision settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public bool HasValidAlphanumericRevisionSettings()
Visual Basic
Public Function HasValidAlphanumericRevisionSettings As Boolean
Visual C++
public:
bool HasValidAlphanumericRevisionSettings()

Return Value

True if the revision numbering sequence owns a valid alphanumeric revision settings.

See Also

RevisionNumberingSequence Class


HasValidNumericRevisionSettings Method

[image]

Revit 2024 API
RevisionNumberingSequence..::..HasValidNumericRevisionSettings Method
RevisionNumberingSequence Class See Also Send Feedback
Checks whether the revision numbering sequence owns a valid numeric revision settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public bool HasValidNumericRevisionSettings()
Visual Basic
Public Function HasValidNumericRevisionSettings As Boolean
Visual C++
public:
bool HasValidNumericRevisionSettings()

Return Value

True if the revision numbering sequence owns a valid numeric revision settings.

See Also

RevisionNumberingSequence Class


SetNumericRevisionSettings Method

[image]

Revit 2024 API
RevisionNumberingSequence..::..SetNumericRevisionSettings Method
RevisionNumberingSequence Class See Also Send Feedback
Replaces the current numeric revision numbering settings with the provided settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public void SetNumericRevisionSettings(
    NumericRevisionSettings settings
)
Visual Basic
Public Sub SetNumericRevisionSettings ( _
    settings As NumericRevisionSettings _
)
Visual C++
public:
void SetNumericRevisionSettings(
    NumericRevisionSettings^ settings
)

Parameters

settings
Type: Autodesk.Revit.DB..::..NumericRevisionSettings
The NumericRevisionSettings to be applied to numeric revision numbering.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | settings is not a valid NumericRevisionSettings.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

RevisionNumberingSequence Class


RevisionNumberingSequence Properties

[image] [image]

Revit 2024 API
RevisionNumberingSequence Properties
RevisionNumberingSequence Class See Also Send Feedback

The RevisionNumberingSequence type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | NumberType | Indicates the revision number type of the revision numbering sequence.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SequenceName | The name of this revision numbering sequence.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

RevisionNumberingSequence Class


NumberType Property

[image]

Revit 2024 API
RevisionNumberingSequence..::..NumberType Property
RevisionNumberingSequence Class See Also Send Feedback
Indicates the revision number type of the revision numbering sequence.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public RevisionNumberType NumberType { get; }
Visual Basic
Public ReadOnly Property NumberType As RevisionNumberType
    Get
Visual C++
public:
property RevisionNumberType NumberType {
    RevisionNumberType get ();
}

Remarks

This property can be used to figure out if a revision numbering sequence is numeric or alphanumeric. The returned RevisionNumberType is either RevisionNumberType::Numeric or RevisionNumberType::Alphanumeric.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This RevisionNumberingSequence doesn't own a valid revision settings for number type.

See Also

RevisionNumberingSequence Class


Parameter Property

[image] [image]

Revit 2024 API
RevisionNumberingSequence..::..Parameter Property
RevisionNumberingSequence Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

RevisionNumberingSequence Class
RevisionNumberingSequence Members


SequenceName Property

[image]

Revit 2024 API
RevisionNumberingSequence..::..SequenceName Property
RevisionNumberingSequence Class See Also Send Feedback
The name of this revision numbering sequence.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public string SequenceName { get; set; }
Visual Basic
Public Property SequenceName As String
    Get
    Set
Visual C++
public:
property String^ SequenceName {
    String^ get ();
    void set (String^ value);
}

Remarks

This name appears in the Sheet Issues/Revisions dialog as a numbering choice for each revision.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: sequenceName is an empty string or contains only whitespace. -or- When setting this property: sequenceName cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~".
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

RevisionNumberingSequence Class


RevisionNumberType Enumeration

[image]

Revit 2024 API
RevisionNumberType Enumeration
See Also Send Feedback
Determines how a particular revision will be numbered.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015
Since: 2015

Syntax

C#
public enum RevisionNumberType
Visual Basic
Public Enumeration RevisionNumberType
Visual C++
public enum class RevisionNumberType

Members

Member name | Description
Numeric | The Revision Number will be a number.
None | No Revision Number will be assigned.
Alphanumeric | The Revision Number will be a string taken from a user-specified sequence of arbitrary strings.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


RevisionSettings Class

[image]

Revit 2024 API
RevisionSettings Class
Members See Also Send Feedback
Provides access to project-wide settings related to revisions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public class RevisionSettings : Element
Visual Basic
Public Class RevisionSettings _
    Inherits Element
Visual C++
public ref class RevisionSettings : public Element

Remarks

This class provides access to the project-wide settings that affect the appearance and numbering of revisions and revision clouds. The settings are only available in project documents.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..RevisionSettings

See Also

RevisionSettings Members


RevisionSettings Members

[image] [image]

Revit 2024 API
RevisionSettings Members
RevisionSettings Class Methods Properties See Also Send Feedback

The RevisionSettings type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
 | GetRevisionSettings | Returns the RevisionSettings for the given project document.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsAcceptableRevisionCloudSpacing | Rounds the given raw value and checks whether it is an acceptable cloud spacing value after it is rounded.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
 | RoundRevisionCloudSpacing | Rounds the given revision cloud spacing value according to the document's settings.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RevisionCloudSpacing | Determines the size in paper space of revision clouds drawn in a project.
Public property | RevisionNumbering | Determines how the revision number values will display on sheets.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

RevisionSettings Class


RevisionSettings Methods

[image] [image]

Revit 2024 API
RevisionSettings Methods
RevisionSettings Class See Also Send Feedback

The RevisionSettings type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
 | GetRevisionSettings | Returns the RevisionSettings for the given project document.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsAcceptableRevisionCloudSpacing | Rounds the given raw value and checks whether it is an acceptable cloud spacing value after it is rounded.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
 | RoundRevisionCloudSpacing | Rounds the given revision cloud spacing value according to the document's settings.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RevisionSettings Class


GetRevisionSettings Method

[image]

Revit 2024 API
RevisionSettings..::..GetRevisionSettings Method
RevisionSettings Class See Also Send Feedback
Returns the RevisionSettings for the given project document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static RevisionSettings GetRevisionSettings(
    Document ccda
)
Visual Basic
Public Shared Function GetRevisionSettings ( _
    ccda As Document _
) As RevisionSettings
Visual C++
public:
static RevisionSettings^ GetRevisionSettings(
    Document^ ccda
)

Parameters

ccda
Type: Autodesk.Revit.DB..::..Document
The document to get the RevisionSettings from.

Return Value

The RevisionSettings for the document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | ccda is not a project document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

RevisionSettings Class


IsAcceptableRevisionCloudSpacing Method

[image]

Revit 2024 API
RevisionSettings..::..IsAcceptableRevisionCloudSpacing Method
RevisionSettings Class See Also Send Feedback
Rounds the given raw value and checks whether it is an acceptable cloud spacing value after it is rounded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool IsAcceptableRevisionCloudSpacing(
    double rawValue
)
Visual Basic
Public Function IsAcceptableRevisionCloudSpacing ( _
    rawValue As Double _
) As Boolean
Visual C++
public:
bool IsAcceptableRevisionCloudSpacing(
    double rawValue
)

Parameters

rawValue
Type: System..::..Double
The raw value to check. This value need not be rounded prior to calling this function.

Return Value

True if the value will be acceptable after rounding, False otherwise

Remarks

After rounding, the value must be a valid length that is greater than zero.

See Also

RevisionSettings Class


RoundRevisionCloudSpacing Method

[image]

Revit 2024 API
RevisionSettings..::..RoundRevisionCloudSpacing Method
RevisionSettings Class See Also Send Feedback
Rounds the given revision cloud spacing value according to the document's settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static double RoundRevisionCloudSpacing(
    Document ccda,
    double rawValue
)
Visual Basic
Public Shared Function RoundRevisionCloudSpacing ( _
    ccda As Document, _
    rawValue As Double _
) As Double
Visual C++
public:
static double RoundRevisionCloudSpacing(
    Document^ ccda,
    double rawValue
)

Parameters

ccda
Type: Autodesk.Revit.DB..::..Document
The document to use for rounding.
rawValue
Type: System..::..Double
The unrounded value.

Return Value

The rounded revision cloud spacing.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

RevisionSettings Class


RevisionSettings Properties

[image] [image]

Revit 2024 API
RevisionSettings Properties
RevisionSettings Class See Also Send Feedback

The RevisionSettings type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RevisionCloudSpacing | Determines the size in paper space of revision clouds drawn in a project.
Public property | RevisionNumbering | Determines how the revision number values will display on sheets.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

RevisionSettings Class


Parameter Property

[image] [image]

Revit 2024 API
RevisionSettings..::..Parameter Property
RevisionSettings Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

RevisionSettings Class
RevisionSettings Members


RevisionNumbering Property

[image]

Revit 2024 API
RevisionSettings..::..RevisionNumbering Property
RevisionSettings Class See Also Send Feedback
Determines how the revision number values will display on sheets.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public RevisionNumbering RevisionNumbering { get; set; }
Visual Basic
Public Property RevisionNumbering As RevisionNumbering
    Get
    Set
Visual C++
public:
property RevisionNumbering RevisionNumbering {
    RevisionNumbering get ();
    void set (RevisionNumbering value);
}

Remarks

When revision clouds appear on a sheet, the revision number of each revision can be displayed either by tagging the revision cloud or by a revision schedule within the sheet's titleblock. There are two ways the number can be determined:
  • Per project: The value of the Revision numbers will always correspond to the project-wide Revision Sequence Number assigned to the revision. For example, if revision clouds for revisions with sequence numbers 5, 7, and 8 are placed on a sheet then revision tags and schedules on that sheet would display 5, 7, and 8.
  • Per sheet: Revision numbers will be assigned consecutive numbers based on the revision clouds visible on that sheet. For example, if revision clouds for revisions assigned project-wide Revision Sequence Numbers 5, 7, and 8 are placed on a sheet then revision tags and schedules on that sheet would display 1, 2, and 3. The sequence on the sheet will still follow the relative ordering of the Revision Sequence Numbers, so in this example revision 5 would be displayed as 1 on the sheet, revision 7 would be displayed as 2, etc.

Note that changing this setting may change the numbering of revisions on any existing sheets. The numbering will be changed even for revisions that are already issued.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

RevisionSettings Class


RevisionVisibility Enumeration

[image]

Revit 2024 API
RevisionVisibility Enumeration
See Also Send Feedback
Determines whether Revision Clouds and Revision Tags will be visible in the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015
Since: 2015

Syntax

C#
public enum RevisionVisibility
Visual Basic
Public Enumeration RevisionVisibility
Visual C++
public enum class RevisionVisibility

Members

Member name | Description
Hidden | Revision Clouds and Revision Tags will not be visible in the project.
CloudAndTagVisible | Revision Clouds and Revision Tags will be visible in the project.
TagVisible | Revision Tags will be visible in the project but Revision Clouds will not be.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


RevitLinkGraphicsSettings Class

[image]

Revit 2024 API
RevitLinkGraphicsSettings Class
Members See Also Send Feedback
Settings to override display of Revit link in a view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public class RevitLinkGraphicsSettings : IDisposable
Visual Basic
Public Class RevitLinkGraphicsSettings _
    Implements IDisposable
Visual C++
public ref class RevitLinkGraphicsSettings : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..RevitLinkGraphicsSettings

See Also

RevitLinkGraphicsSettings Members


RevitLinkGraphicsSettings Members

[image] [image]

Revit 2024 API
RevitLinkGraphicsSettings Members
RevitLinkGraphicsSettings Class Constructors Methods Properties See Also Send Feedback

The RevitLinkGraphicsSettings type exposes the following members.

Constructors

 | Name | Description
Public method | RevitLinkGraphicsSettings | Creates a new RevitLinkGraphicsSettings instance.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the RevitLinkGraphicsSettings
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LinkedViewId | The id of the linked view associated with this RevitLinkGraphicsSettings, or InvalidElementId if no view is selected. If the LinkVisibilityType is set to ByLinkView, then there must be a valid LinkedViewId.
Public property | LinkVisibilityType | The visibility type of RevitLinkGraphicsSettings. If the type is set to ByHostView or ByLinkView, then the dependent properties of RevitLinkGraphicsSettings will be reset to their default state. The state of dependent properties can be changed later.

See Also

RevitLinkGraphicsSettings Class


Dispose Method

[image]

Revit 2024 API
RevitLinkGraphicsSettings..::..Dispose Method
RevitLinkGraphicsSettings Class See Also Send Feedback
Releases all resources used by the RevitLinkGraphicsSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

RevitLinkGraphicsSettings Class


IsValidObject Property

[image]

Revit 2024 API
RevitLinkGraphicsSettings..::..IsValidObject Property
RevitLinkGraphicsSettings Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

RevitLinkGraphicsSettings Class


LinkedViewId Property

[image]

Revit 2024 API
RevitLinkGraphicsSettings..::..LinkedViewId Property
RevitLinkGraphicsSettings Class See Also Send Feedback
The id of the linked view associated with this RevitLinkGraphicsSettings, or InvalidElementId if no view is selected. If the LinkVisibilityType is set to ByLinkView, then there must be a valid LinkedViewId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public ElementId LinkedViewId { get; set; }
Visual Basic
Public Property LinkedViewId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ LinkedViewId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

RevitLinkGraphicsSettings Class


RevitLinkInstance Class

[image]

Revit 2024 API
RevitLinkInstance Class
Members See Also Send Feedback
Represents an instance of a RevitLinkType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public class RevitLinkInstance : Instance
Visual Basic
Public Class RevitLinkInstance _
    Inherits Instance
Visual C++
public ref class RevitLinkInstance : public Instance

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..Instance
Autodesk.Revit.DB..::..RevitLinkInstance

See Also

RevitLinkInstance Members


RevitLinkInstance Members

[image] [image]

Revit 2024 API
RevitLinkInstance Members
RevitLinkInstance Class Methods Properties See Also Send Feedback

The RevitLinkInstance type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create(Document, ElementId) | Creates a new instance of a linked Revit project (RevitLinkType).
 | Create(Document, ElementId, ImportPlacement) | Creates a new instance of a linked Revit project (RevitLinkType).
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLinkDocument | The document associated with the Revit link.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetTotalTransform | Gets the total transform, which includes the true north transform for instances like import instances. (Inherited from Instance.)
Public method | GetTransform | Gets the transform of the instance. (Inherited from Instance.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | MoveBasePointToHostBasePoint | Moves this link instance so that the base point in the linked document is aligned to the base point in the host document. This is a one-time movement and does not set up any shared coordinates relationship. If the rotation angle of this link instance was changed after insertion, the rotation angle can be preserved or reset to the original insertion angle.
Public method | MoveOriginToHostOrigin | Moves this link instance so that the internal origin of the linked document is aligned to the internal origin of the host document. This is a one-time movement and does not set up any shared coordinates relationship. If the rotation angle of the link instance was changed after insertion, the rotation angle can be preserved or reset to the original insertion angle.
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

RevitLinkInstance Class


RevitLinkInstance Methods

[image] [image]

Revit 2024 API
RevitLinkInstance Methods
RevitLinkInstance Class See Also Send Feedback

The RevitLinkInstance type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create(Document, ElementId) | Creates a new instance of a linked Revit project (RevitLinkType).
 | Create(Document, ElementId, ImportPlacement) | Creates a new instance of a linked Revit project (RevitLinkType).
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLinkDocument | The document associated with the Revit link.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetTotalTransform | Gets the total transform, which includes the true north transform for instances like import instances. (Inherited from Instance.)
Public method | GetTransform | Gets the transform of the instance. (Inherited from Instance.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | MoveBasePointToHostBasePoint | Moves this link instance so that the base point in the linked document is aligned to the base point in the host document. This is a one-time movement and does not set up any shared coordinates relationship. If the rotation angle of this link instance was changed after insertion, the rotation angle can be preserved or reset to the original insertion angle.
Public method | MoveOriginToHostOrigin | Moves this link instance so that the internal origin of the linked document is aligned to the internal origin of the host document. This is a one-time movement and does not set up any shared coordinates relationship. If the rotation angle of the link instance was changed after insertion, the rotation angle can be preserved or reset to the original insertion angle.
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RevitLinkInstance Class


Create Method

[image] [image]

Revit 2024 API
RevitLinkInstance..::..Create Method
RevitLinkInstance Class See Also Send Feedback

Overload List

Name | Description
Create(Document, ElementId) | Creates a new instance of a linked Revit project (RevitLinkType).
Create(Document, ElementId, ImportPlacement) | Creates a new instance of a linked Revit project (RevitLinkType).

See Also

RevitLinkInstance Class
RevitLinkInstance Members


Create Method (Document, ElementId, ImportPlacement)

[image]

Revit 2024 API
RevitLinkInstance..::..Create Method (Document, ElementId, ImportPlacement)
RevitLinkInstance Class See Also Send Feedback
Creates a new instance of a linked Revit project (RevitLinkType).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public static RevitLinkInstance Create(
    Document document,
    ElementId revitLinkTypeId,
    ImportPlacement placement
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    revitLinkTypeId As ElementId, _
    placement As ImportPlacement _
) As RevitLinkInstance
Visual C++
public:
static RevitLinkInstance^ Create(
    Document^ document,
    ElementId^ revitLinkTypeId,
    ImportPlacement placement
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which the new instance should be created.
revitLinkTypeId
Type: Autodesk.Revit.DB..::..ElementId
The element id of the RevitLinkType.
placement
Type: Autodesk.Revit.DB..::..ImportPlacement
The mode where to place the RevitLinkInstance. Set this option to place the view at the origin or by shared coordinates.

Return Value

The newly-created RevitLinkInstance.

Remarks

Instances will be placed origin-to-origin or by shared coordinates. This function cannot be used to create instances of nested links.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | revitLinkTypeId isn't a RevitLinkType. -or- revitLinkTypeId is not a top-level link. -or- revitLinkTypeId is not a loaded RevitLinkType -or- document is not a project document. -or- placement isn't supported.Only Origin or Shared placement is supported.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | The placement is Shared, and the host model and the link do not share the same coordinate system. Or the placement is Shared, and the shared coordinates of the host model do not match the GIS coordinate system of the linked file.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

RevitLinkInstance Class
Create Overload


GetLinkDocument Method

[image]

Revit 2024 API
RevitLinkInstance..::..GetLinkDocument Method
RevitLinkInstance Class See Also Send Feedback
The document associated with the Revit link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public Document GetLinkDocument()
Visual Basic
Public Function GetLinkDocument As Document
Visual C++
public:
Document^ GetLinkDocument()

Remarks

Operations that require a transaction or modify the document's status in memory (such as Save and Close) cannot be performed on this document.

See Also

RevitLinkInstance Class


MoveBasePointToHostBasePoint Method

[image]

Revit 2024 API
RevitLinkInstance..::..MoveBasePointToHostBasePoint Method
RevitLinkInstance Class See Also Send Feedback

Moves this link instance so that the base point in the linked document is aligned to the base point in the host document. This is a one-time movement and does not set up any shared coordinates relationship.

If the rotation angle of this link instance was changed after insertion, the rotation angle can be preserved or reset to the original insertion angle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 SubscriptionUpdate

Syntax

C#
public void MoveBasePointToHostBasePoint(
    bool resetToOriginalRotation
)
Visual Basic
Public Sub MoveBasePointToHostBasePoint ( _
    resetToOriginalRotation As Boolean _
)
Visual C++
public:
void MoveBasePointToHostBasePoint(
    bool resetToOriginalRotation
)

Parameters

resetToOriginalRotation
Type: System..::..Boolean

Sets to true if:

  • restoring the original insertion angle of the link instance after it is moved if there was a rotation \ mirror transform on the link instance.
  • there was no a rotation \ mirror transform on the link instance.

Sets to false to retain the current angle of the link instance after it is moved if there was a rotation \ mirror transform on the link instance.

Remarks

The link must be loaded for Revit to find the location of the link's base point. This operation can only be performed on instances of top-level links.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This RevitLinkInstance is not an instance of a loaded RevitLinkType. -or- This RevitLinkInstance is not an instance of a top-level RevitLinkType. -or- The operation is not permitted because the element is pinned.

See Also

RevitLinkInstance Class


MoveOriginToHostOrigin Method

[image]

Revit 2024 API
RevitLinkInstance..::..MoveOriginToHostOrigin Method
RevitLinkInstance Class See Also Send Feedback

Moves this link instance so that the internal origin of the linked document is aligned to the internal origin of the host document. This is a one-time movement and does not set up any shared coordinates relationship.

If the rotation angle of the link instance was changed after insertion, the rotation angle can be preserved or reset to the original insertion angle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 SubscriptionUpdate

Syntax

C#
public void MoveOriginToHostOrigin(
    bool resetToOriginalRotation
)
Visual Basic
Public Sub MoveOriginToHostOrigin ( _
    resetToOriginalRotation As Boolean _
)
Visual C++
public:
void MoveOriginToHostOrigin(
    bool resetToOriginalRotation
)

Parameters

resetToOriginalRotation
Type: System..::..Boolean

Sets to true if:

  • restoring the original insertion angle of the link instance after it is moved if there was a rotation \ mirror transform on the link instance.
  • there was no a rotation \ mirror transform on the link instance.

Sets to false to retain the current angle of the link instance after it is moved if there was a rotation \ mirror transform on the link instance.

Remarks

This operation can only be performed on instances of top-level links. The internal origin is not necessarily the same location as the Project Base Point. See MoveBasePointToHostBasePoint(Boolean).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This RevitLinkInstance is not an instance of a loaded RevitLinkType. -or- This RevitLinkInstance is not an instance of a top-level RevitLinkType. -or- The operation is not permitted because the element is pinned.

See Also

RevitLinkInstance Class


RevitLinkInstance Properties

[image] [image]

Revit 2024 API
RevitLinkInstance Properties
RevitLinkInstance Class See Also Send Feedback

The RevitLinkInstance type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

RevitLinkInstance Class


Parameter Property

[image] [image]

Revit 2024 API
RevitLinkInstance..::..Parameter Property
RevitLinkInstance Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

RevitLinkInstance Class
RevitLinkInstance Members


RevitLinkOperations Class

[image]

Revit 2024 API
RevitLinkOperations Class
Members See Also Send Feedback
This class is used to extend the IExternalResourceServer interface with methods to support operations specifically related to Revit links.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public class RevitLinkOperations : LinkOperations
Visual Basic
Public Class RevitLinkOperations _
    Inherits LinkOperations
Visual C++
public ref class RevitLinkOperations : public LinkOperations

Remarks

The class owns single-method interfaces which are used as callbacks to perform specific operations on Revit link external resources.

An empty RevitLinkOperations instance is passed to an IExternalResourceServer (inside an ExternalResourceServerExtensions object) via the GetTypeSpecificServerOperations method. The server provider can then add their own implemented interface objects to the RevitLinkOperations, thus making them available to Revit to use as callbacks.

Supporting these additional, type-specific operations is not absolutely required, but is strongly recommended in order for users to be able to perform all the same operations they would with locally-accessed Revit links.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..LinkOperations
Autodesk.Revit.DB..::..RevitLinkOperations

See Also

RevitLinkOperations Members


RevitLinkOperations Members

[image] [image]

Revit 2024 API
RevitLinkOperations Members
RevitLinkOperations Class Methods Properties See Also Send Feedback

The RevitLinkOperations type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from LinkOperations.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetGetLocalPathForOpenCallback | Sets the IGetLocalPathForOpenCallback that will support the "Open (and Unload)" command for Revit links obtained from an IExternalResourceServer.
Public method | SetOnLocalLinkSharedCoordinatesSavedCallback | Sets the callback that will be called when the Revit user saves new shared coordinate settings to a linked document obtained from an IExternalResourceServer. (Inherited from LinkOperations.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from LinkOperations.)

See Also

RevitLinkOperations Class


RevitLinkOperations Methods

[image] [image]

Revit 2024 API
RevitLinkOperations Methods
RevitLinkOperations Class See Also Send Feedback

The RevitLinkOperations type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from LinkOperations.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetGetLocalPathForOpenCallback | Sets the IGetLocalPathForOpenCallback that will support the "Open (and Unload)" command for Revit links obtained from an IExternalResourceServer.
Public method | SetOnLocalLinkSharedCoordinatesSavedCallback | Sets the callback that will be called when the Revit user saves new shared coordinate settings to a linked document obtained from an IExternalResourceServer. (Inherited from LinkOperations.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RevitLinkOperations Class


RevitLinkOperations Properties

[image] [image]

Revit 2024 API
RevitLinkOperations Properties
RevitLinkOperations Class See Also Send Feedback

The RevitLinkOperations type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from LinkOperations.)

See Also

RevitLinkOperations Class


RevitLinkOptions Class

[image]

Revit 2024 API
RevitLinkOptions Class
Members See Also Send Feedback
This class contains the options in use when creating or loading a Revit link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public class RevitLinkOptions : IDisposable
Visual Basic
Public Class RevitLinkOptions _
    Implements IDisposable
Visual C++
public ref class RevitLinkOptions : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..RevitLinkOptions

See Also

RevitLinkOptions Members


RevitLinkOptions Members

[image] [image]

Revit 2024 API
RevitLinkOptions Members
RevitLinkOptions Class Constructors Methods Properties See Also Send Feedback

The RevitLinkOptions type exposes the following members.

Constructors

 | Name | Description
Public method | RevitLinkOptions(Boolean) | Creates a RevitLinkOptions object, specifying relative or absolute path type. If the link is workshared, all worksets will be opened.
Public method | RevitLinkOptions(RevitLinkOptions) | Constructs a new copy of the input RevitLinkOptions object.
Public method | RevitLinkOptions(Boolean, WorksetConfiguration) | Creates a RevitLinkOptions object, specifying relative or absolute path type, and the desired workset configuration.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the RevitLinkOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWorksetConfiguration | Gets the set of worksets to open when creating the link.
Public method | SetWorksetConfiguration | Sets the set of worksets to open when creating the link.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsRelative | The type of path to use when creating the link. If true, Revit will store a relative path for the link. If false, Revit will store an absolute path. If the link is to a Revit Server location, isRelative must be false.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

RevitLinkOptions Class


RevitLinkOptions Constructor

[image] [image]

Revit 2024 API
RevitLinkOptions Constructor
RevitLinkOptions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RevitLinkOptions(Boolean) | Creates a RevitLinkOptions object, specifying relative or absolute path type. If the link is workshared, all worksets will be opened.
Public method | RevitLinkOptions(RevitLinkOptions) | Constructs a new copy of the input RevitLinkOptions object.
Public method | RevitLinkOptions(Boolean, WorksetConfiguration) | Creates a RevitLinkOptions object, specifying relative or absolute path type, and the desired workset configuration.

See Also

RevitLinkOptions Class
RevitLinkOptions Members


RevitLinkOptions Constructor (RevitLinkOptions)

[image]

Revit 2024 API
RevitLinkOptions Constructor (RevitLinkOptions)
RevitLinkOptions Class See Also Send Feedback
Constructs a new copy of the input RevitLinkOptions object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public RevitLinkOptions(
    RevitLinkOptions other
)
Visual Basic
Public Sub New ( _
    other As RevitLinkOptions _
)
Visual C++
public:
RevitLinkOptions(
    RevitLinkOptions^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..RevitLinkOptions

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

RevitLinkOptions Class
RevitLinkOptions Overload


RevitLinkOptions Constructor (Boolean, WorksetConfiguration)

[image]

Revit 2024 API
RevitLinkOptions Constructor (Boolean, WorksetConfiguration)
RevitLinkOptions Class See Also Send Feedback
Creates a RevitLinkOptions object, specifying relative or absolute path type, and the desired workset configuration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public RevitLinkOptions(
    bool relative,
    WorksetConfiguration config
)
Visual Basic
Public Sub New ( _
    relative As Boolean, _
    config As WorksetConfiguration _
)
Visual C++
public:
RevitLinkOptions(
    bool relative,
    WorksetConfiguration^ config
)

Parameters

relative
Type: System..::..Boolean
True if the link should use a relative path. False if it should use an absolute path.
config
Type: Autodesk.Revit.DB..::..WorksetConfiguration
A WorksetConfiguration object specifying the worksets to open when creating the link. Leave as nullNothingnullptra null reference (Nothing in Visual Basic) if the file is not workshared. Optionally, this may also be nullNothingnullptra null reference (Nothing in Visual Basic) for a workshared file, in which case Revit will open all worksets.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

RevitLinkOptions Class
RevitLinkOptions Overload


Dispose Method

[image]

Revit 2024 API
RevitLinkOptions..::..Dispose Method
RevitLinkOptions Class See Also Send Feedback
Releases all resources used by the RevitLinkOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

RevitLinkOptions Class


GetWorksetConfiguration Method

[image]

Revit 2024 API
RevitLinkOptions..::..GetWorksetConfiguration Method
RevitLinkOptions Class Example See Also Send Feedback
Gets the set of worksets to open when creating the link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public WorksetConfiguration GetWorksetConfiguration()
Visual Basic
Public Function GetWorksetConfiguration As WorksetConfiguration
Visual C++
public:
WorksetConfiguration^ GetWorksetConfiguration()

Examples

CopyC#
public bool CreateRevitLinkWithOneWorksetOpen(Document doc, string pathName, string worksetName)
{
    FilePath path = new FilePath(pathName);
    RevitLinkOptions options = new RevitLinkOptions(true);

    // Get info on all the user worksets in the project prior to opening
    IList<WorksetPreview> worksets = WorksharingUtils.GetUserWorksetInfo(path);
    IList<WorksetId> worksetIds = new List<WorksetId>();
    // Find worksetName
    foreach (WorksetPreview worksetPrev in worksets)
    {
        if (worksetPrev.Name.CompareTo(worksetName) == 0)
        {
            worksetIds.Add(worksetPrev.Id);
            break;
        }
    }

    // close all worksets but the one specified
    WorksetConfiguration worksetConfig = new WorksetConfiguration(WorksetConfigurationOption.CloseAllWorksets);
    if (worksetIds.Count > 0)
    {
        worksetConfig.Open(worksetIds);
    }
    options.SetWorksetConfiguration(worksetConfig);

    LinkLoadResult result = RevitLinkType.Create(doc, path, options);
    RevitLinkType type = doc.GetElement(result.ElementId) as RevitLinkType;
    return (result.LoadResult == LinkLoadResultType.LinkLoaded);
}
CopyVB.NET
Public Function CreateRevitLinkWithOneWorksetOpen(doc As Document, pathName As String, worksetName As String) As Boolean
   Dim path As New FilePath(pathName)
   Dim options As New RevitLinkOptions(True)

   ' Get info on all the user worksets in the project prior to opening
   Dim worksets As IList(Of WorksetPreview) = WorksharingUtils.GetUserWorksetInfo(path)
   Dim worksetIds As IList(Of WorksetId) = New List(Of WorksetId)()
   ' Find worksetName
   For Each worksetPrev As WorksetPreview In worksets
      If worksetPrev.Name.CompareTo(worksetName) = 0 Then
         worksetIds.Add(worksetPrev.Id)
         Exit For
      End If
   Next

   ' close all worksets but the one specified
   Dim worksetConfig As New WorksetConfiguration(WorksetConfigurationOption.CloseAllWorksets)
   If worksetIds.Count > 0 Then
      worksetConfig.Open(worksetIds)
   End If
   options.SetWorksetConfiguration(worksetConfig)

   Dim result As LinkLoadResult = RevitLinkType.Create(doc, path, options)
   Dim type As RevitLinkType = TryCast(doc.GetElement(result.ElementId), RevitLinkType)
   Return (result.LoadResult = LinkLoadResultType.LinkLoaded)
End Function

See Also

RevitLinkOptions Class


SetWorksetConfiguration Method

[image]

Revit 2024 API
RevitLinkOptions..::..SetWorksetConfiguration Method
RevitLinkOptions Class See Also Send Feedback
Sets the set of worksets to open when creating the link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void SetWorksetConfiguration(
    WorksetConfiguration config
)
Visual Basic
Public Sub SetWorksetConfiguration ( _
    config As WorksetConfiguration _
)
Visual C++
public:
void SetWorksetConfiguration(
    WorksetConfiguration^ config
)

Parameters

config
Type: Autodesk.Revit.DB..::..WorksetConfiguration

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

RevitLinkOptions Class


IsRelative Property

[image]

Revit 2024 API
RevitLinkOptions..::..IsRelative Property
RevitLinkOptions Class See Also Send Feedback
The type of path to use when creating the link. If true, Revit will store a relative path for the link. If false, Revit will store an absolute path. If the link is to a Revit Server location, isRelative must be false.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool IsRelative { get; set; }
Visual Basic
Public Property IsRelative As Boolean
    Get
    Set
Visual C++
public:
property bool IsRelative {
    bool get ();
    void set (bool value);
}

See Also

RevitLinkOptions Class


IsValidObject Property

[image]

Revit 2024 API
RevitLinkOptions..::..IsValidObject Property
RevitLinkOptions Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

RevitLinkOptions Class


RevitLinkType Class

[image]

Revit 2024 API
RevitLinkType Class
Members See Also Send Feedback
This class represents another Revit Document ("link") brought into the current one ("host").

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public class RevitLinkType : ElementType
Visual Basic
Public Class RevitLinkType _
    Inherits ElementType
Visual C++
public ref class RevitLinkType : public ElementType

Remarks

Revit links can be nested - There can exist linked files which themselves contain links. A "top-level" link is one linked directly into the host, while a "nested" link is linked into some parent link. This can go through arbitrarily many layers. Some functions give the example "A -> B -> C". This means that there is a host file, A, which has a top-level link, B, and a nested link C which has been linked into B as an attachment.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..RevitLinkType

See Also

RevitLinkType Members


RevitLinkType Members

[image] [image]

Revit 2024 API
RevitLinkType Members
RevitLinkType Class Methods Properties See Also Send Feedback

The RevitLinkType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create(Document, ExternalResourceReference, RevitLinkOptions) | Creates a new Revit link type from an external resource reference and loads the linked document.
 | Create(Document, ModelPath, RevitLinkOptions) | Creates a new Revit link type and loads the linked document.
 | CreateFromIFC(Document, ExternalResourceReference, String, Boolean, RevitLinkOptions) | Creates a new Revit link type from an existing Revit file created via import by reference of an asscoiated IFC file.
 | CreateFromIFC(Document, String, String, Boolean, RevitLinkOptions) | Creates a new Revit link type from an existing Revit file created via import by reference of an asscoiated IFC file.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetChildIds | Gets the ids of the immediate children of this link.
Public method | GetConversionData | Returns the optional data that is necessary to generate the Revit file for this link.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLinkedFileStatus | Returns the LinkedFileStatus of this link.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetParentId | Gets the id of this link's immediate parent.
Public method | GetPhaseMap | Returns a mapping between phases in the host document and phases in the linked document.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetRootId | Gets the id of the top-level link which this link is linked into.
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
 | GetTopLevelLink(Document, ExternalResourceReference) | Returns the ElementId of the (top-level) linked model with the given ExternalResourceReference.
 | GetTopLevelLink(Document, ModelPath) | Returns the ElementId of the (top-level) linked model with the given path.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasSaveablePositions | Determines whether the link has changes to shared positioning that could be saved.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsFromLocalPath | Checks whether the Revit link uses a local path, such as a hard drive.
Public method | IsFromRevitServer | Checks whether the Revit link is located on Revit Server.
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
 | IsLoaded | Checks whether the link with this id is loaded.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsNotLoadedIntoMultipleOpenDocuments | Checks whether the link is loaded into more than one open document in this session of Revit. If the link is loaded into multiple open documents, reload will be disabled.
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | Load | Loads or reloads the Revit link from its currently-stored location. If the link is an external resource, Revit will contact the IExternalResourceServer to get the latest version of the link.
Public method | LoadFrom(ExternalResourceReference, WorksetConfiguration) | Loads or reloads the Revit link. The link will be loaded from the location given in the input ExternalResourceReference.
Public method | LoadFrom(ModelPath, WorksetConfiguration) | Loads or reloads the Revit link from disk or cloud. The link will be loaded from the input path.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | Reload | Loads or reloads the Revit link from its currently-stored location. If the link is an external resource, Revit will contact the IExternalResourceServer to get the latest version of the link.
Public method | RevertLocalUnloadStatus | Restores the workshared load status of a link that has been unloaded only for the current user, in a local copy of a workshared model.
Public method | SavePositions | Saves shared coordinates changes back to the linked document.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Unload | Unloads the Revit link.
Public method | UnloadLocally | Unloads a Revit link for the current user only.
Public method | UpdateFromIFC(Document, ExternalResourceReference, String, Boolean) | Updates a Revit link type from an IFC file and loads the linked document.
Public method | UpdateFromIFC(Document, String, String, Boolean) | Updates a Revit link type from an IFC file and loads the linked document.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | AttachmentType | The attachment/overlay status of this link.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsNestedLink | Indicates whether this link is a nested or top-level link.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | LocallyUnloaded | Checks whether a Revit link in a local model is unloaded only for the current user.
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PathType | The type of path the link uses.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

RevitLinkType Class


Create Method

[image] [image]

Revit 2024 API
RevitLinkType..::..Create Method
RevitLinkType Class See Also Send Feedback

Overload List

Name | Description
Create(Document, ExternalResourceReference, RevitLinkOptions) | Creates a new Revit link type from an external resource reference and loads the linked document.
Create(Document, ModelPath, RevitLinkOptions) | Creates a new Revit link type and loads the linked document.

See Also

RevitLinkType Class
RevitLinkType Members


Create Method (Document, ExternalResourceReference, RevitLinkOptions)

[image]

Revit 2024 API
RevitLinkType..::..Create Method (Document, ExternalResourceReference, RevitLinkOptions)
RevitLinkType Class See Also Send Feedback
Creates a new Revit link type from an external resource reference and loads the linked document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static LinkLoadResult Create(
    Document document,
    ExternalResourceReference resourceReference,
    RevitLinkOptions options
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    resourceReference As ExternalResourceReference, _
    options As RevitLinkOptions _
) As LinkLoadResult
Visual C++
public:
static LinkLoadResult^ Create(
    Document^ document,
    ExternalResourceReference^ resourceReference,
    RevitLinkOptions^ options
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which to create the Revit link.
resourceReference
Type: Autodesk.Revit.DB..::..ExternalResourceReference
An external resource reference describing the source of the linked Revit document.
options
Type: Autodesk.Revit.DB..::..RevitLinkOptions
An options class for loading Revit links. The path type information will be ignored.

Return Value

An object containing the results of creating and loading the Revit link type. It contains the ElementId of the new link.

Remarks

This function regenerates the input document.

Only the WorksetConfiguration information in the options argument will be used. The path type information will be ignored.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- The server referenced by the ExternalResourceReference does not exist or does not implement IExternalResourceServer. -or- The server referenced by the ExternalResourceReference cannot support Revit links. -or- The ExternalResourceReference (resourceReference) is not in a format that is supported by its server. -or- The link type referred to by the ExternalResourceReference "resourceReference" already exists in the document. You cannot create another copy of the link type. You can create instances with RevitLinkInstance.Create(), or reload the link using RevitLinkType.Reload().
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | Revit cannot customize worksets for this model.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

RevitLinkType Class
Create Overload


Create Method (Document, ModelPath, RevitLinkOptions)

[image]

Revit 2024 API
RevitLinkType..::..Create Method (Document, ModelPath, RevitLinkOptions)
RevitLinkType Class Example See Also Send Feedback
Creates a new Revit link type and loads the linked document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static LinkLoadResult Create(
    Document document,
    ModelPath path,
    RevitLinkOptions options
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    path As ModelPath, _
    options As RevitLinkOptions _
) As LinkLoadResult
Visual C++
public:
static LinkLoadResult^ Create(
    Document^ document,
    ModelPath^ path,
    RevitLinkOptions^ options
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which to create the Revit link.
path
Type: Autodesk.Revit.DB..::..ModelPath
The path of the link to load. This may be a path of local disk, Revit Server or Cloud. This must be a full path.
options
Type: Autodesk.Revit.DB..::..RevitLinkOptions
An options class for loading Revit links.

Return Value

An object containing the results of creating and loading the Revit link type. It contains the ElementId of the new link.

Remarks

This function regenerates the input document. While the options argument allows specification of a path type, the input path argument must be a full path. Relative vs. absolute determines how Revit will store the path, but it needs a complete path to find the linked document initially.

Examples

CopyC#
public ElementId CreateRevitLink(Document doc, string pathName)
{
    FilePath path = new FilePath(pathName);
    RevitLinkOptions options = new RevitLinkOptions(false);
    // Create new revit link storing absolute path to a file
    LinkLoadResult result = RevitLinkType.Create(doc, path, options);
    return (result.ElementId);
}
CopyVB.NET
Public Function CreateRevitLink(doc As Document, pathName As String) As ElementId
   Dim path As New FilePath(pathName)
   Dim options As New RevitLinkOptions(False)
   ' Create new revit link storing absolute path to a file
   Dim result As LinkLoadResult = RevitLinkType.Create(doc, path, options)
   Return (result.ElementId)
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- Server paths cannot be relative. -or- document already contains a linked model at path path. -or- The path to be linked in is empty. -or- The input path "path" does not represent a Revit model.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..FileAccessException | The model cannot be accessed due to lack of access privileges.
Autodesk.Revit.Exceptions..::..FileNotFoundException | The path to be linked in doesn't exist.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The model is not allowed to access. -or- Revit cannot customize worksets for this model. -or- Revit cannot link a cloud model to non-cloud model.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.
Autodesk.Revit.Exceptions..::..RevitServerInternalException | Could be for any of the reasons that failed on service side.
Autodesk.Revit.Exceptions..::..RevitServerUnauthenticatedUserException | User is not signed in with Autodesk id.
Autodesk.Revit.Exceptions..::..RevitServerUnauthorizedException | User is not authorized to access the specified cloud model.

See Also

RevitLinkType Class
Create Overload


CreateFromIFC Method

[image] [image]

Revit 2024 API
RevitLinkType..::..CreateFromIFC Method
RevitLinkType Class See Also Send Feedback

Overload List

Name | Description
CreateFromIFC(Document, ExternalResourceReference, String, Boolean, RevitLinkOptions) | Creates a new Revit link type from an existing Revit file created via import by reference of an asscoiated IFC file.
CreateFromIFC(Document, String, String, Boolean, RevitLinkOptions) | Creates a new Revit link type from an existing Revit file created via import by reference of an asscoiated IFC file.

See Also

RevitLinkType Class
RevitLinkType Members


CreateFromIFC Method (Document, String, String, Boolean, RevitLinkOptions)

[image]

Revit 2024 API
RevitLinkType..::..CreateFromIFC Method (Document, String, String, Boolean, RevitLinkOptions)
RevitLinkType Class See Also Send Feedback
Creates a new Revit link type from an existing Revit file created via import by reference of an asscoiated IFC file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static LinkLoadResult CreateFromIFC(
    Document document,
    string ifcFilePath,
    string revitLinkedFilePath,
    bool recreateLink,
    RevitLinkOptions options
)
Visual Basic
Public Shared Function CreateFromIFC ( _
    document As Document, _
    ifcFilePath As String, _
    revitLinkedFilePath As String, _
    recreateLink As Boolean, _
    options As RevitLinkOptions _
) As LinkLoadResult
Visual C++
public:
static LinkLoadResult^ CreateFromIFC(
    Document^ document,
    String^ ifcFilePath,
    String^ revitLinkedFilePath,
    bool recreateLink,
    RevitLinkOptions^ options
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which to create the Revit link.
ifcFilePath
Type: System..::..String
The path of the associated IFC file. This must be a full path.
revitLinkedFilePath
Type: System..::..String
The path of the existing Revit file that contains elements created via an import by reference operation. This must be a full path.
recreateLink
Type: System..::..Boolean
If true, the existing Revit file created via an import by reference operation will be updated based on the information in the IFC file. If false, the existing Revit file will be used as-is.
options
Type: Autodesk.Revit.DB..::..RevitLinkOptions
An options class for loading Revit links.

Return Value

An object containing the results of creating and loading the Revit link type. It contains the ElementId of the new link.

Remarks

This function is one of a series of steps necessary for linking an IFC file. To understand how it is used in context, please download the IFC open source code, and look in the Revit.IFC.Import project at Importer.ImportIFC(ImporterIFC importer), under the IFCImportAction.Link branch.

This function regenerates the input document. While the options argument allows specification of a path type, the input path argument must be a full path. Relative vs. absolute determines how Revit will store the path, but it needs a complete path to find the linked document initially.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- The input path "ifcFilePath" does not represent an IFC file. -or- document already contains a linked model at path revitLinkedFilePath. -or- The document is a cloud model.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..FileAccessException | The model cannot be accessed due to lack of access privileges.
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | There is not a valid Revit file at ifcFilePath's location -or- There is not a valid Revit file at revitLinkedFilePath's location
Autodesk.Revit.Exceptions..::..InvalidOperationException | The file is not allowed to access. -or- Revit cannot customize worksets for this model.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

RevitLinkType Class
CreateFromIFC Overload


GetChildIds Method

[image]

Revit 2024 API
RevitLinkType..::..GetChildIds Method
RevitLinkType Class See Also Send Feedback
Gets the ids of the immediate children of this link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public ICollection<ElementId> GetChildIds()
Visual Basic
Public Function GetChildIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetChildIds()

Return Value

The element ids of all links which are linked directly into this one (immediate children)

Remarks

This function only returns the ids of immediate children. Given the link structure A -> B -> C, then calling this function on A will only return B's id.

See Also

RevitLinkType Class


GetConversionData Method

[image]

Revit 2024 API
RevitLinkType..::..GetConversionData Method
RevitLinkType Class See Also Send Feedback
Returns the optional data that is necessary to generate the Revit file for this link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public LinkConversionData GetConversionData()
Visual Basic
Public Function GetConversionData As LinkConversionData
Visual C++
public:
LinkConversionData^ GetConversionData()

Return Value

The RvtLinkConversionData containing the necessary information.

See Also

RevitLinkType Class


GetLinkedFileStatus Method

[image]

Revit 2024 API
RevitLinkType..::..GetLinkedFileStatus Method
RevitLinkType Class See Also Send Feedback
Returns the LinkedFileStatus of this link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018.2

Syntax

C#
public LinkedFileStatus GetLinkedFileStatus()
Visual Basic
Public Function GetLinkedFileStatus As LinkedFileStatus
Visual C++
public:
LinkedFileStatus GetLinkedFileStatus()

See Also

RevitLinkType Class


GetParentId Method

[image]

Revit 2024 API
RevitLinkType..::..GetParentId Method
RevitLinkType Class See Also Send Feedback
Gets the id of this link's immediate parent.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public ElementId GetParentId()
Visual Basic
Public Function GetParentId As ElementId
Visual C++
public:
ElementId^ GetParentId()

Return Value

The id of the immediate parent of this link, or invalidElementId if this link is a top-level link.

Remarks

This function returns the immediate parent id. Given the link structure A -> B -> C, then calling this function on C will return B's id. Call GetRootId to get A's id.

See Also

RevitLinkType Class


GetPhaseMap Method

[image]

Revit 2024 API
RevitLinkType..::..GetPhaseMap Method
RevitLinkType Class See Also Send Feedback
Returns a mapping between phases in the host document and phases in the linked document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018.3

Syntax

C#
public IDictionary<ElementId, ElementId> GetPhaseMap()
Visual Basic
Public Function GetPhaseMap As IDictionary(Of ElementId, ElementId)
Visual C++
public:
IDictionary<ElementId^, ElementId^>^ GetPhaseMap()

Return Value

A map from phases in the host document to phases in the linked document. The first value in each pair is the ElementId of a phase in the host document. The second value is the ElementId of the matching phase in the linked document.

Remarks

This map is used to determine which phase in the linked document corresponds to each phase in the host document. This map is used to correctly calculate room geometry for room-bounding links. Multiple phases in the host document can correspond to the same phase in the linked document. Time order must be respected - if the host document has phases 1 and 2, and the linked document has phases A and B, it would not be proper to map 1 to B and 2 to A. If the user has not explicitly set the map values in the UI, the map will be as follows: Revit attempts to find a match for each host phase, moving in order from earliest to latest phase. First Revit will look for a phase in the linked document with the same name as the host phase. If there is no name match, the last phase in the link will be chosen as the match. Once Revit has matched a host phase to the last link phase, all other host phases will be matched to the last link phase, even if later host phases might have a name match.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The RvtLinkSymbol is not loaded. -or- This Revit link doesn't have a valid phase map.

See Also

RevitLinkType Class


GetTopLevelLink Method

[image] [image]

Revit 2024 API
RevitLinkType..::..GetTopLevelLink Method
RevitLinkType Class See Also Send Feedback

Overload List

Name | Description
GetTopLevelLink(Document, ExternalResourceReference) | Returns the ElementId of the (top-level) linked model with the given ExternalResourceReference.
GetTopLevelLink(Document, ModelPath) | Returns the ElementId of the (top-level) linked model with the given path.

See Also

RevitLinkType Class
RevitLinkType Members


GetTopLevelLink Method (Document, ExternalResourceReference)

[image]

Revit 2024 API
RevitLinkType..::..GetTopLevelLink Method (Document, ExternalResourceReference)
RevitLinkType Class See Also Send Feedback
Returns the ElementId of the (top-level) linked model with the given ExternalResourceReference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static ElementId GetTopLevelLink(
    Document document,
    ExternalResourceReference reference
)
Visual Basic
Public Shared Function GetTopLevelLink ( _
    document As Document, _
    reference As ExternalResourceReference _
) As ElementId
Visual C++
public:
static ElementId^ GetTopLevelLink(
    Document^ document,
    ExternalResourceReference^ reference
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to look for the linked model in.
reference
Type: Autodesk.Revit.DB..::..ExternalResourceReference
An ExternalResourceReference indicating which linked model to return.

Return Value

The id of the link with the given ExternalResourceReference, or InvalidElementId if there is no top-level link at that location.

Remarks

This function will not return nested links.

Revit will not check the version when checking for resource equality.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

RevitLinkType Class
GetTopLevelLink Overload


GetTopLevelLink Method (Document, ModelPath)

[image]

Revit 2024 API
RevitLinkType..::..GetTopLevelLink Method (Document, ModelPath)
RevitLinkType Class See Also Send Feedback
Returns the ElementId of the (top-level) linked model with the given path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static ElementId GetTopLevelLink(
    Document document,
    ModelPath path
)
Visual Basic
Public Shared Function GetTopLevelLink ( _
    document As Document, _
    path As ModelPath _
) As ElementId
Visual C++
public:
static ElementId^ GetTopLevelLink(
    Document^ document,
    ModelPath^ path
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to look for the linked model in.
path
Type: Autodesk.Revit.DB..::..ModelPath
A path indicating which linked model to return.

Return Value

The id of the link with the given path, or InvalidElementId if there is no top-level link at that path.

Remarks

This function will not return nested links.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

RevitLinkType Class
GetTopLevelLink Overload


HasSaveablePositions Method

[image]

Revit 2024 API
RevitLinkType..::..HasSaveablePositions Method
RevitLinkType Class See Also Send Feedback
Determines whether the link has changes to shared positioning that could be saved.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public bool HasSaveablePositions()
Visual Basic
Public Function HasSaveablePositions As Boolean
Visual C++
public:
bool HasSaveablePositions()

Return Value

True if the link has shared positioning changes which can be saved. False if there are no changes to shared coordinates, or if the changes cannot be saved.

See Also

RevitLinkType Class


IsFromRevitServer Method

[image]

Revit 2024 API
RevitLinkType..::..IsFromRevitServer Method
RevitLinkType Class See Also Send Feedback
Checks whether the Revit link is located on Revit Server.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool IsFromRevitServer()
Visual Basic
Public Function IsFromRevitServer As Boolean
Visual C++
public:
bool IsFromRevitServer()

Return Value

Returns true if the Revit link is located on Revit Server.

See Also

RevitLinkType Class


IsLoaded Method

[image]

Revit 2024 API
RevitLinkType..::..IsLoaded Method
RevitLinkType Class See Also Send Feedback
Checks whether the link with this id is loaded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static bool IsLoaded(
    Document document,
    ElementId typeId
)
Visual Basic
Public Shared Function IsLoaded ( _
    document As Document, _
    typeId As ElementId _
) As Boolean
Visual C++
public:
static bool IsLoaded(
    Document^ document,
    ElementId^ typeId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
A document. Revit will see if typeId corresponds to a loaded link in this document.
typeId
Type: Autodesk.Revit.DB..::..ElementId
An element id. Revit will check if typeId corresponds to a loaded link in the given document.

Return Value

True if typeId corresponds to a loaded RevitLinkType. False otherwise.

Remarks

Returns false if typeId is not the id of a RevitLinkType.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

RevitLinkType Class


IsNotLoadedIntoMultipleOpenDocuments Method

[image]

Revit 2024 API
RevitLinkType..::..IsNotLoadedIntoMultipleOpenDocuments Method
RevitLinkType Class See Also Send Feedback
Checks whether the link is loaded into more than one open document in this session of Revit. If the link is loaded into multiple open documents, reload will be disabled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsNotLoadedIntoMultipleOpenDocuments()
Visual Basic
Public Function IsNotLoadedIntoMultipleOpenDocuments As Boolean
Visual C++
public:
bool IsNotLoadedIntoMultipleOpenDocuments()

Return Value

True if the link is loaded into at most one open document. False if the link is loaded into more than one open document.

Remarks

Revit can open several documents which contain the same link. If this is the case, Revit cannot reload the link, as doing so would make changes to a non-active document. You will need to close one or more documents in order to modify the link.

If the link is loaded into multiple documents across multiple sessions of Revit, this function will return true. We only check the current session of Revit. It is safe to reload a link which is loaded into multiple sessions, as long as it is not loaded into more than one document in any one session.

If this function returns true, it is safe to reload the link.

See Also

RevitLinkType Class


LoadFrom Method (ModelPath, WorksetConfiguration)

[image]

Revit 2024 API
RevitLinkType..::..LoadFrom Method (ModelPath, WorksetConfiguration)
RevitLinkType Class See Also Send Feedback
Loads or reloads the Revit link from disk or cloud. The link will be loaded from the input path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public LinkLoadResult LoadFrom(
    ModelPath path,
    WorksetConfiguration config
)
Visual Basic
Public Function LoadFrom ( _
    path As ModelPath, _
    config As WorksetConfiguration _
) As LinkLoadResult
Visual C++
public:
LinkLoadResult^ LoadFrom(
    ModelPath^ path,
    WorksetConfiguration^ config
)

Parameters

path
Type: Autodesk.Revit.DB..::..ModelPath
A ModelPath indicating where to load the link from. This may be a path of local disk, Revit Server or Cloud. This must be an absolute path for local path.
config
Type: Autodesk.Revit.DB..::..WorksetConfiguration

A WorksetConfiguration object indicating which worksets in the link to open.

If you want to load the same set of worksets the link previously had, leave this argument as nullNothingnullptra null reference (Nothing in Visual Basic).

Return Value

An object containing the ElementId of the link and an enum value indicating any errors which occurred while trying to load.

Remarks

The input path must be absolute. Revit will store an absolute or relative path internally, according to the link's settings. Revit Server paths or cloud paths are acceptable.

If the link is currently loaded, Revit must unload the link before reloading it. Any changes made in-memory to the link's shared coordinates will be discarded.

Revit does not try to validate that the input path represents the "same" document. You can load a completely different document, which may invalidate references to linked elements.

This function regenerates the document.

The document's Undo history will be cleared by this command. As a result, this command and others executed before it cannot be undone. All transaction phases (e.g. transactions transaction groups and sub-transaction) that were explicitly started must be finished prior to calling this method.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input path "path" does not represent a Revit model.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..FileAccessException | The model cannot be accessed due to lack of access privileges.
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | The function is not permitted during dynamic update.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This RevitLinkType is not a top-level link. -or- The link "this RevitLinkType" is loaded into multiple documents and cannot be reloaded. -or- The element "this RevitLinkType" is in a closed workset. -or- The model is not allowed to access. -or- There is a transaction phase left open (such as a transaction, sub-transaction of transaction group) at the time of invoking this method. -or- The document is read-only. It cannot be modified. -or- The document is in an edit mode or is in family mode. -or- Revit cannot customize worksets for this model. -or- Revit cannot link a cloud model to non-cloud model.
Autodesk.Revit.Exceptions..::..RevitServerInternalException | Could be for any of the reasons that failed on service side.
Autodesk.Revit.Exceptions..::..RevitServerUnauthenticatedUserException | User is not signed in with Autodesk id.
Autodesk.Revit.Exceptions..::..RevitServerUnauthorizedException | User is not authorized to access the specified cloud model.

See Also

RevitLinkType Class
LoadFrom Overload


Reload Method

[image]

Revit 2024 API
RevitLinkType..::..Reload Method
RevitLinkType Class See Also Send Feedback
Loads or reloads the Revit link from its currently-stored location. If the link is an external resource, Revit will contact the IExternalResourceServer to get the latest version of the link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public LinkLoadResult Reload()
Visual Basic
Public Function Reload As LinkLoadResult
Visual C++
public:
LinkLoadResult^ Reload()

Return Value

An object containing the ElementId of the link and an enum value indicating any errors which occurred while trying to load. LinkLoadResultType.LinkLoaded indicates success.

Remarks

If the link is currently loaded, Revit must unload the link before reloading it. Any changes made in-memory to the link's shared coordinates will be discarded.

This function regenerates the document.

The document's Undo history will be cleared by this command. As a result, this command and others executed before it cannot be undone. All transaction phases (e.g. transactions transaction groups and sub-transaction) that were explicitly started must be finished prior to calling this method.

This function is identical to RevitLinkType.Load() and is included for convenience.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..FileAccessException | The model cannot be accessed due to lack of access privileges.
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | The element "this RevitLinkType" is in a ducument which is in dynamic update.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The element "this RevitLinkType" is in a family document or a document in in-place edit mode. -or- The element "this RevitLinkType" is in a document which is in an edit mode or is in family mode. -or- The element "this RevitLinkType" is in a read-only document. -or- This RevitLinkType is not a top-level link. -or- The link "this RevitLinkType" is loaded into multiple documents and cannot be reloaded. -or- The element "this RevitLinkType" is in a closed workset. -or- There is a transaction phase left open (such as a transaction, sub-transaction of transaction group) at the time of invoking this method.

See Also

RevitLinkType Class


RevertLocalUnloadStatus Method

[image]

Revit 2024 API
RevitLinkType..::..RevertLocalUnloadStatus Method
RevitLinkType Class See Also Send Feedback
Restores the workshared load status of a link that has been unloaded only for the current user, in a local copy of a workshared model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Update

Syntax

C#
public LinkedFileStatus RevertLocalUnloadStatus()
Visual Basic
Public Function RevertLocalUnloadStatus As LinkedFileStatus
Visual C++
public:
LinkedFileStatus RevertLocalUnloadStatus()

Return Value

The link's LinkedFileStatus that has resulted from reverting the local unloaded status.

Remarks

This function removes the local user's override of the link's workshared load status (see UnloadLocally method). That is, if the link is loaded in the central model for all worksharing users (and thus has been only unloaded for the local user), then this method will perform a full reload of the link for the local user. If the link is unloaded in the central model, then this method will simply clear the local user's unload override, so that the link will be reloaded in the local user's model, if it is ever reloaded in the central model.

This function should not be called on a Revit link:

  • in a document which is in an edit mode or is in family mode.
  • in a document which is in dynamic update.
  • in a document which is read only.
  • in a document in which there is transaction phase left open.
  • in a non-workshared file.
  • in a central model of workshared file.
  • which is nested.
  • which are not locally unloaded.

If the link is an external resource, Revit will contact the IExternalResourceServer to get the latest version of the link.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..FileAccessException | The model cannot be accessed due to lack of access privileges.
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | The element "this RevitLinkType" is in a ducument which is in dynamic update.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The element "this RevitLinkType" is in a family document or a document in in-place edit mode. -or- The element "this RevitLinkType" is in a document which is in an edit mode or is in family mode. -or- The element "this RevitLinkType" is in a read-only document. -or- This functionality is not available in Revit LT. -or- The element "this RevitLinkType" is in non-workshared document. -or- The element "this RevitLinkType" is not in a local model: the model is not workshared or it is central. -or- This RevitLinkType is not a top-level link. -or- The link is not locally unloaded. -or- There is a transaction phase left open (such as a transaction, sub-transaction of transaction group) at the time of invoking this method.

See Also

RevitLinkType Class


SavePositions Method

[image]

Revit 2024 API
RevitLinkType..::..SavePositions Method
RevitLinkType Class See Also Send Feedback
Saves shared coordinates changes back to the linked document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool SavePositions(
    ISaveSharedCoordinatesCallback callback
)
Visual Basic
Public Function SavePositions ( _
    callback As ISaveSharedCoordinatesCallback _
) As Boolean
Visual C++
public:
bool SavePositions(
    ISaveSharedCoordinatesCallback^ callback
)

Parameters

callback
Type: Autodesk.Revit.DB..::..ISaveSharedCoordinatesCallback
A callback object to resolve situations when Revit encounters modified links.

Return Value

True if we saved the link or if there were no changes to save. False if the operation failed.

Remarks

While this operation does not clear the document's undo history, you will not be able to undo this specific action, since it saves the link's shared coordinates changes to disk.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Revit could not save shared coordinates changes to the link or one of its nested links.

See Also

RevitLinkType Class


Unload Method

[image]

Revit 2024 API
RevitLinkType..::..Unload Method
RevitLinkType Class See Also Send Feedback
Unloads the Revit link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void Unload(
    ISaveSharedCoordinatesCallback callback
)
Visual Basic
Public Sub Unload ( _
    callback As ISaveSharedCoordinatesCallback _
)
Visual C++
public:
void Unload(
    ISaveSharedCoordinatesCallback^ callback
)

Parameters

callback
Type: Autodesk.Revit.DB..::..ISaveSharedCoordinatesCallback
A callback indicating what to do if Revit encounters links which have changes in shared coordinates. If nullNothingnullptra null reference (Nothing in Visual Basic), Revit will not save any shared coordinates changes to the link before unloading.

Remarks

This function regenerates the document.

The document's Undo history will be cleared by this command. As a result, this command and others executed before it cannot be undone. All transaction phases (e.g. transactions transaction groups and sub-transaction) that were explicitly started must be finished prior to calling this method.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | The function is not permitted during dynamic update.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This RevitLinkType is not a top-level link. -or- Revit could not save shared coordinates changes to the link or one of its nested links. -or- There is a transaction phase left open (such as a transaction, sub-transaction of transaction group) at the time of invoking this method. -or- The document is read-only. It cannot be modified. -or- The document is in an edit mode or is in family mode. -or- Revit cannot link a cloud model to non-cloud model
Autodesk.Revit.Exceptions..::..RevitServerInternalException | Could be for any of the reasons that failed on service side.
Autodesk.Revit.Exceptions..::..RevitServerUnauthenticatedUserException | User is not signed in with Autodesk id.
Autodesk.Revit.Exceptions..::..RevitServerUnauthorizedException | User is not authorized to access the specified cloud model.

See Also

RevitLinkType Class


UnloadLocally Method

[image]

Revit 2024 API
RevitLinkType..::..UnloadLocally Method
RevitLinkType Class See Also Send Feedback
Unloads a Revit link for the current user only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscripton Update

Syntax

C#
public bool UnloadLocally(
    ISaveSharedCoordinatesCallbackForUnloadLocally callback
)
Visual Basic
Public Function UnloadLocally ( _
    callback As ISaveSharedCoordinatesCallbackForUnloadLocally _
) As Boolean
Visual C++
public:
bool UnloadLocally(
    ISaveSharedCoordinatesCallbackForUnloadLocally^ callback
)

Parameters

callback
Type: Autodesk.Revit.DB..::..ISaveSharedCoordinatesCallbackForUnloadLocally
A callback indicating what to do if Revit encounters links which have changes in shared coordinates. The saving options for unloading locally only could be: save the link, not save the link. If nullNothingnullptra null reference (Nothing in Visual Basic), Revit will not save any shared coordinates changes to the link before unloading.

Return Value

Returns true if the attempt to unload the link locally was successful.

Remarks

This function unloads the Revit link for the current user, instead of all users, in the workshared files.

If you want to unload the Revit link for all users, please use Unload(ISaveSharedCoordinatesCallback).

This function should not be called on a Revit link:

  • in a document which is in an edit mode or is in family mode.
  • in a document which is in dynamic update.
  • in a document which is read only.
  • in a document in which there is transaction phase left open.
  • in a non-workshared file.
  • in a central model of workshared file.
  • which is nested.
  • which is unloaded locally already.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..FileAccessException | The model cannot be accessed due to lack of access privileges.
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | The element "this RevitLinkType" is in a ducument which is in dynamic update.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The element "this RevitLinkType" is in a family document or a document in in-place edit mode. -or- The element "this RevitLinkType" is in a document which is in an edit mode or is in family mode. -or- The element "this RevitLinkType" is in a read-only document. -or- This functionality is not available in Revit LT. -or- The element "this RevitLinkType" is in non-workshared document. -or- The element "this RevitLinkType" is not in a local model: the model is not workshared or it is central. -or- This RevitLinkType is not a top-level link. -or- The link "this RevitLinkType" is locally unloaded for current user already. -or- There is a transaction phase left open (such as a transaction, sub-transaction of transaction group) at the time of invoking this method.

See Also

RevitLinkType Class


UpdateFromIFC Method

[image] [image]

Revit 2024 API
RevitLinkType..::..UpdateFromIFC Method
RevitLinkType Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UpdateFromIFC(Document, ExternalResourceReference, String, Boolean) | Updates a Revit link type from an IFC file and loads the linked document.
Public method | UpdateFromIFC(Document, String, String, Boolean) | Updates a Revit link type from an IFC file and loads the linked document.

See Also

RevitLinkType Class
RevitLinkType Members


UpdateFromIFC Method (Document, ExternalResourceReference, String, Boolean)

[image]

Revit 2024 API
RevitLinkType..::..UpdateFromIFC Method (Document, ExternalResourceReference, String, Boolean)
RevitLinkType Class See Also Send Feedback
Updates a Revit link type from an IFC file and loads the linked document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public bool UpdateFromIFC(
    Document document,
    ExternalResourceReference resourceReference,
    string revitLinkedFilePath,
    bool recreateLink
)
Visual Basic
Public Function UpdateFromIFC ( _
    document As Document, _
    resourceReference As ExternalResourceReference, _
    revitLinkedFilePath As String, _
    recreateLink As Boolean _
) As Boolean
Visual C++
public:
bool UpdateFromIFC(
    Document^ document,
    ExternalResourceReference^ resourceReference,
    String^ revitLinkedFilePath,
    bool recreateLink
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document that contains Revit link.
resourceReference
Type: Autodesk.Revit.DB..::..ExternalResourceReference
An external resource reference describing the source of the IFC file used in creation.
revitLinkedFilePath
Type: System..::..String
The path of the Revit file to create to hold the IFC information. This must be a full path.
recreateLink
Type: System..::..Boolean
If true, the Revit file will be updated based on the information in the IFC file. If false, the existing Revit file will be used.

Return Value

Returns true if the update succeeded, false otherwise.

Remarks

This function regenerates the input document. While the options argument allows specification of a path type, the input path argument must be a full path. Relative vs. absolute determines how Revit will store the path, but it needs a complete path to find the linked document initially. Note that the IFC file will not be stored directly in the document; it will instead by stored in an intermediate Revit document, whose location is given by revitLinkedFilePath.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- The server referenced by the ExternalResourceReference does not exist or does not implement IExternalResourceServer. -or- The server referenced by the ExternalResourceReference cannot support IFC links. -or- The ExternalResourceReference (resourceReference) is not in a format that is supported by its server.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..FileAccessException | The model cannot be accessed due to lack of access privileges.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The file is not allowed to access. -or- Revit cannot customize worksets for this model.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

RevitLinkType Class
UpdateFromIFC Overload


UpdateFromIFC Method (Document, String, String, Boolean)

[image]

Revit 2024 API
RevitLinkType..::..UpdateFromIFC Method (Document, String, String, Boolean)
RevitLinkType Class See Also Send Feedback
Updates a Revit link type from an IFC file and loads the linked document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool UpdateFromIFC(
    Document document,
    string ifcFilePath,
    string revitLinkedFilePath,
    bool recreateLink
)
Visual Basic
Public Function UpdateFromIFC ( _
    document As Document, _
    ifcFilePath As String, _
    revitLinkedFilePath As String, _
    recreateLink As Boolean _
) As Boolean
Visual C++
public:
bool UpdateFromIFC(
    Document^ document,
    String^ ifcFilePath,
    String^ revitLinkedFilePath,
    bool recreateLink
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document that contains Revit link.
ifcFilePath
Type: System..::..String
The path of the IFC link to load. This must be a full path.
revitLinkedFilePath
Type: System..::..String
The path of the Revit file to create to hold the IFC information. This must be a full path.
recreateLink
Type: System..::..Boolean
If true, the Revit file will be updated based on the information in the IFC file. If false, the existing Revit file will be used.

Return Value

Returns true if the update succeeded, false otherwise.

Remarks

This function regenerates the input document. While the options argument allows specification of a path type, the input path argument must be a full path. Relative vs. absolute determines how Revit will store the path, but it needs a complete path to find the linked document initially. Note that the IFC file will not be stored directly in the document; it will instead by stored in an intermediate Revit document, whose location is given by revitLinkedFilePath.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- The input path "ifcFilePath" does not represent an IFC file. -or- The document is a cloud model.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..FileAccessException | The model cannot be accessed due to lack of access privileges.
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | There is not a valid Revit file at ifcFilePath's location
Autodesk.Revit.Exceptions..::..InvalidOperationException | The file is not allowed to access. -or- Revit cannot customize worksets for this model.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

RevitLinkType Class
UpdateFromIFC Overload


RevitLinkType Properties

[image] [image]

Revit 2024 API
RevitLinkType Properties
RevitLinkType Class See Also Send Feedback

The RevitLinkType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | AttachmentType | The attachment/overlay status of this link.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsNestedLink | Indicates whether this link is a nested or top-level link.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | LocallyUnloaded | Checks whether a Revit link in a local model is unloaded only for the current user.
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PathType | The type of path the link uses.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

RevitLinkType Class


AttachmentType Property

[image]

Revit 2024 API
RevitLinkType..::..AttachmentType Property
RevitLinkType Class See Also Send Feedback
The attachment/overlay status of this link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public AttachmentType AttachmentType { get; set; }
Visual Basic
Public Property AttachmentType As AttachmentType
    Get
    Set
Visual C++
public:
property AttachmentType AttachmentType {
    AttachmentType get ();
    void set (AttachmentType value);
}

Field Value

AttachmentType.Overlay if this link is an overlay, AttachmentType.Attachment if this link is an attachment.

Remarks

"Attachment" links are considered to be part of their parent link and will be brought along if their parent is linked into another document. "Overlay" links are only visible when their parent is open directly.

For example: A user has a file B which contains a link C, and they wish to link B into another file, A. If C is an overlay, C will not be loaded into A. If C is an attachment, then C will be loaded into A along with B.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: This RevitLinkType is not a top-level link.

See Also

RevitLinkType Class


LocallyUnloaded Property

[image]

Revit 2024 API
RevitLinkType..::..LocallyUnloaded Property
RevitLinkType Class See Also Send Feedback
Checks whether a Revit link in a local model is unloaded only for the current user.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public bool LocallyUnloaded { get; }
Visual Basic
Public ReadOnly Property LocallyUnloaded As Boolean
    Get
Visual C++
public:
property bool LocallyUnloaded {
    bool get ();
}

Remarks

Revit links can be unloaded for both the current user and for all users. If a Revit link is in a non-workshared file or in central model, this property is false.

See Also

RevitLinkType Class


PathType Property

[image]

Revit 2024 API
RevitLinkType..::..PathType Property
RevitLinkType Class See Also Send Feedback
The type of path the link uses.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public PathType PathType { get; set; }
Visual Basic
Public Property PathType As PathType
    Get
    Set
Visual C++
public:
property PathType PathType {
    PathType get ();
    void set (PathType value);
}

Remarks

You cannot change the PathType to or from PathType.Server. The path type will change automatically if you call RevitLinkType.LoadFrom with a Revit Server path.

Links from external resource servers are considered to have no path type. Attempts to access this property for an external server link will result in an exception.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | The PathType of the Revit link cannot be determined (or set), because it was not loaded from a local disk drive or from Revit Server. -or- When setting this property: The PathType for the link is not valid. PathType.Content is never valid for a Revit link. To change the type to or from PathType.Server, use RevitLinkType.LoadFrom and pick a server or file path.

See Also

RevitLinkType Class


Revolution Class

[image]

Revit 2024 API
Revolution Class
Members See Also Send Feedback
A revolution solid or void form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class Revolution : GenericForm
Visual Basic
Public Class Revolution _
    Inherits GenericForm
Visual C++
public ref class Revolution : public GenericForm

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..CombinableElement
Autodesk.Revit.DB..::..GenericForm
Autodesk.Revit.DB..::..Revolution

See Also

Revolution Members


Revolution Members

[image] [image]

Revit 2024 API
Revolution Members
Revolution Class Methods Properties See Also Send Feedback

The Revolution type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | Axis | Returns the Axis of the Revolution.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EndAngle | The end angle of the revolution relative to the sketch plane.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Get and Set the Name property (Inherited from GenericForm.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Sketch | Returns the Sketch of the Revolution.
Public property | StartAngle | The start angle of the revolution relative to the sketch plane.
Public property | Subcategory | The subcategory. (Inherited from GenericForm.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Visible | The visibility of the GenericForm. (Inherited from GenericForm.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Revolution Class


Revolution Properties

[image] [image]

Revit 2024 API
Revolution Properties
Revolution Class See Also Send Feedback

The Revolution type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | Axis | Returns the Axis of the Revolution.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EndAngle | The end angle of the revolution relative to the sketch plane.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Get and Set the Name property (Inherited from GenericForm.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Sketch | Returns the Sketch of the Revolution.
Public property | StartAngle | The start angle of the revolution relative to the sketch plane.
Public property | Subcategory | The subcategory. (Inherited from GenericForm.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Visible | The visibility of the GenericForm. (Inherited from GenericForm.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Revolution Class


Axis Property

[image]

Revit 2024 API
Revolution..::..Axis Property
Revolution Class See Also Send Feedback
Returns the Axis of the Revolution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ModelLine Axis { get; }
Visual Basic
Public ReadOnly Property Axis As ModelLine
    Get
Visual C++
public:
property ModelLine^ Axis {
    ModelLine^ get ();
}

Remarks

This property is used to retrieve the Axis of the Revolution.

See Also

Revolution Class


EndAngle Property

[image]

Revit 2024 API
Revolution..::..EndAngle Property
Revolution Class See Also Send Feedback
The end angle of the revolution relative to the sketch plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double EndAngle { get; set; }
Visual Basic
Public Property EndAngle As Double
    Get
    Set
Visual C++
public:
property double EndAngle {
    double get ();
    void set (double value);
}

Remarks

The direction of the angle is based on the normal of the sketch plane. A positive angle is on the same side as the normal, a negative angle on the opposite side.

See Also

Revolution Class


Parameter Property

[image] [image]

Revit 2024 API
Revolution..::..Parameter Property
Revolution Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Revolution Class
Revolution Members


Sketch Property

[image]

Revit 2024 API
Revolution..::..Sketch Property
Revolution Class See Also Send Feedback
Returns the Sketch of the Revolution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Sketch Sketch { get; }
Visual Basic
Public ReadOnly Property Sketch As Sketch
    Get
Visual C++
public:
property Sketch^ Sketch {
    Sketch^ get ();
}

Remarks

This property is used to retrieve the Sketch of the Revolution.

See Also

Revolution Class


StartAngle Property

[image]

Revit 2024 API
Revolution..::..StartAngle Property
Revolution Class See Also Send Feedback
The start angle of the revolution relative to the sketch plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double StartAngle { get; set; }
Visual Basic
Public Property StartAngle As Double
    Get
    Set
Visual C++
public:
property double StartAngle {
    double get ();
    void set (double value);
}

Remarks

The direction of the angle is based on the normal of the sketch plane. A positive angle is on the same side as the normal, a negative angle on the opposite side.

See Also

Revolution Class


RevolvedFace Class

[image]

Revit 2024 API
RevolvedFace Class
Members Example See Also Send Feedback
A revolved face of a 3d solid or open shell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class RevolvedFace : Face
Visual Basic
Public Class RevolvedFace _
    Inherits Face
Visual C++
public ref class RevolvedFace : public Face

Remarks

Revolved faces are defined by a profile curve and a local coordinate system. For details on the parameterization, refer to the documentation for RevolvedSurface

Examples

CopyC#
private void GetRevolvedFaceInfo(Face face)
{
    RevolvedFace revolvedFace = face as RevolvedFace;
    if (null != revolvedFace)
    {
       XYZ origin = revolvedFace.Origin;
       XYZ axis = revolvedFace.Axis;
        Curve curve = revolvedFace.Curve;
        XYZ redius = revolvedFace.get_Radius(0);
    }
}
CopyVB.NET
Private Sub GetRevolvedFaceInfo(face As Face)
    Dim revolvedFace As RevolvedFace = TryCast(face, RevolvedFace)
    If revolvedFace IsNot Nothing Then
        Dim origin As XYZ = revolvedFace.Origin
        Dim axis As XYZ = revolvedFace.Axis
        Dim curve As Curve = revolvedFace.Curve
        Dim redius As XYZ = revolvedFace.Radius(0)
    End If
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeometryObject
Autodesk.Revit.DB..::..Face
Autodesk.Revit.DB..::..RevolvedFace

See Also

RevolvedFace Members


RevolvedFace Members

[image] [image]

Revit 2024 API
RevolvedFace Members
RevolvedFace Class Methods Properties See Also Send Feedback

The RevolvedFace type exposes the following members.

Methods

 | Name | Description
Public method | ComputeDerivatives | Returns the first partial derivatives of the underlying surface at the specified point. (Inherited from Face.)
Public method | ComputeNormal | Returns the normal vector for the face at the given point. (Inherited from Face.)
Public method | ComputeSecondDerivatives | Returns the second partial derivatives of the face at the specified point. (Inherited from Face.)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates and returns the XYZ coordinates of a point at the indicated UV parameterization of the face. (Inherited from Face.)
Public method | GetBoundingBox | Returns the UV bounding box of the face. (Inherited from Face.)
Public method | GetEdgesAsCurveLoops | Returns a list of closed curve loops that correspond to the edge loops of the face. Curves in each curve loop correspond to individual edges. (Inherited from Face.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject.)
Public method | GetRegions | Gets the face regions (created, for example, by the Split Face command) of the face. (Inherited from Face.)
Public method | GetSurface | Returns a copy of this face's surface. (Inherited from Face.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Public method | Intersect(Face) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)
Public method | Intersect(Face, Curve%) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face.)
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional information about the point location. (Inherited from Face.)
Public method | Project | Projects the specified point on the face. (Inherited from Face.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Triangulate()()()() | Returns a triangular mesh approximation to the face. (Inherited from Face.)
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face. (Inherited from Face.)

Properties

 | Name | Description
Public property | Area | The area of this face. (Inherited from Face.)
Public property | Axis | Axis of the surface.
Public property | Curve | Profile curve of the surface.
Public property | EdgeLoops | A collection of edge loops. Each edge loop represents one of the closed boundaries of the face. (Inherited from Face.)
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
Public property | HasRegions | Identifies if the face contains regions (which can be created, for example, by the Split Face command). (Inherited from Face.)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject.)
Public property | IsCyclic | Indicates whether the underlying surface is periodic in the specified parametric direction. (Inherited from Face.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate). (Inherited from Face.)
Public property | MaterialElementId | The element ID of the material from which this face is composed. (Inherited from Face.)
Public property | OrientationMatchesSurfaceOrientation | Returns true if this face's orientation matches the orientation of the face's surface, false if they have opposite orientations. (Inherited from Face.)
Public property | Origin | Origin of the surface.
Public property | Period | The period of the underlying surface in the specified parametric direction. (Inherited from Face.)
Public property | Radius | Radius of the surface.
Public property | Reference | Returns a stable reference to the face. (Inherited from Face.)
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

RevolvedFace Class


RevolvedFace Methods

[image] [image]

Revit 2024 API
RevolvedFace Methods
RevolvedFace Class See Also Send Feedback

The RevolvedFace type exposes the following members.

Methods

 | Name | Description
Public method | ComputeDerivatives | Returns the first partial derivatives of the underlying surface at the specified point. (Inherited from Face.)
Public method | ComputeNormal | Returns the normal vector for the face at the given point. (Inherited from Face.)
Public method | ComputeSecondDerivatives | Returns the second partial derivatives of the face at the specified point. (Inherited from Face.)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates and returns the XYZ coordinates of a point at the indicated UV parameterization of the face. (Inherited from Face.)
Public method | GetBoundingBox | Returns the UV bounding box of the face. (Inherited from Face.)
Public method | GetEdgesAsCurveLoops | Returns a list of closed curve loops that correspond to the edge loops of the face. Curves in each curve loop correspond to individual edges. (Inherited from Face.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject.)
Public method | GetRegions | Gets the face regions (created, for example, by the Split Face command) of the face. (Inherited from Face.)
Public method | GetSurface | Returns a copy of this face's surface. (Inherited from Face.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Public method | Intersect(Face) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)
Public method | Intersect(Face, Curve%) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face.)
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional information about the point location. (Inherited from Face.)
Public method | Project | Projects the specified point on the face. (Inherited from Face.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Triangulate()()()() | Returns a triangular mesh approximation to the face. (Inherited from Face.)
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face. (Inherited from Face.)

See Also

RevolvedFace Class


Intersect Method

[image] [image]

Revit 2024 API
RevolvedFace..::..Intersect Method
RevolvedFace Class See Also Send Feedback
Calculates the intersection of the specified curve with this face.

Overload List

 | Name | Description
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Public method | Intersect(Face) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)
Public method | Intersect(Face, Curve%) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face.)

See Also

RevolvedFace Class
RevolvedFace Members


IsInside Method

[image] [image]

Revit 2024 API
RevolvedFace..::..IsInside Method
RevolvedFace Class See Also Send Feedback
Indicates whether the specified point is within this face.

Overload List

 | Name | Description
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional information about the point location. (Inherited from Face.)

See Also

RevolvedFace Class
RevolvedFace Members


Triangulate Method

[image] [image]

Revit 2024 API
RevolvedFace..::..Triangulate Method
RevolvedFace Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Triangulate()()()() | Returns a triangular mesh approximation to the face. (Inherited from Face.)
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face. (Inherited from Face.)

See Also

RevolvedFace Class
RevolvedFace Members


RevolvedFace Properties

[image] [image]

Revit 2024 API
RevolvedFace Properties
RevolvedFace Class See Also Send Feedback

The RevolvedFace type exposes the following members.

Properties

 | Name | Description
Public property | Area | The area of this face. (Inherited from Face.)
Public property | Axis | Axis of the surface.
Public property | Curve | Profile curve of the surface.
Public property | EdgeLoops | A collection of edge loops. Each edge loop represents one of the closed boundaries of the face. (Inherited from Face.)
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
Public property | HasRegions | Identifies if the face contains regions (which can be created, for example, by the Split Face command). (Inherited from Face.)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject.)
Public property | IsCyclic | Indicates whether the underlying surface is periodic in the specified parametric direction. (Inherited from Face.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate). (Inherited from Face.)
Public property | MaterialElementId | The element ID of the material from which this face is composed. (Inherited from Face.)
Public property | OrientationMatchesSurfaceOrientation | Returns true if this face's orientation matches the orientation of the face's surface, false if they have opposite orientations. (Inherited from Face.)
Public property | Origin | Origin of the surface.
Public property | Period | The period of the underlying surface in the specified parametric direction. (Inherited from Face.)
Public property | Radius | Radius of the surface.
Public property | Reference | Returns a stable reference to the face. (Inherited from Face.)
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

RevolvedFace Class


Axis Property

[image]

Revit 2024 API
RevolvedFace..::..Axis Property
RevolvedFace Class See Also Send Feedback
Axis of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ Axis { get; }
Visual Basic
Public ReadOnly Property Axis As XYZ
    Get
Visual C++
public:
property XYZ^ Axis {
    XYZ^ get ();
}

See Also

RevolvedFace Class


Curve Property

[image]

Revit 2024 API
RevolvedFace..::..Curve Property
RevolvedFace Class See Also Send Feedback
Profile curve of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Curve Curve { get; }
Visual Basic
Public ReadOnly Property Curve As Curve
    Get
Visual C++
public:
property Curve^ Curve {
    Curve^ get ();
}

See Also

RevolvedFace Class


Origin Property

[image]

Revit 2024 API
RevolvedFace..::..Origin Property
RevolvedFace Class See Also Send Feedback
Origin of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ Origin { get; }
Visual Basic
Public ReadOnly Property Origin As XYZ
    Get
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
}

See Also

RevolvedFace Class


RevolvedSurface Members

[image] [image]

Revit 2024 API
RevolvedSurface Members
RevolvedSurface Class Methods Properties See Also Send Feedback

The RevolvedSurface type exposes the following members.

Methods

 | Name | Description
 | Create(Frame, Curve) | Creates a Surface object coincident with the surface of revolution defined by a coordinate frame and a profile curve.
 | Create(XYZ, XYZ, Curve) | Creates a Surface object coincident with the surface of revolution defined by an axis and a profile curve.
 | Create(Frame, Curve, Double, Double) | Creates a Surface object coincident with the surface of revolution defined by a coordinate frame, a profile curve, and start and end angles of revolution.
 | Create(XYZ, XYZ, Curve, Double, Double) | Creates a Surface object coincident with the surface of revolution defined by an axis, a profile curve, and start and end angles of revolution.
Public method | Dispose | (Inherited from Surface.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBoundingBoxUV | Gets the UV bounding box of the surface. (Inherited from Surface.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProfileCurve | Returns a copy of the profile curve expressed in the surface's coordinate system.
Public method | GetProfileCurveInWorldCoordinates | Returns a copy of the profile curve expressed in the world coordinate system.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValidProfileCurve(Frame, Curve) | Checks if the input profile curve is valid to create a surface of revolution in the given frame of reference.
 | IsValidProfileCurve(XYZ, XYZ, Curve) | Checks if the input profile curve is valid to create a surface of revolution around the given axis.
Public method | Project | Project a 3D point orthogonally onto a surface (to find the nearest point). Throws InvalidOperationException if the projection fails. (Inherited from Surface.)
Public method | ProjectWithGuessPoint | Project a 3D point orthogonally onto a surface (to find the nearest point). This method is meant to be used when a good approximate solution for the projection is available. Throws InvalidOperationException if the projection fails. (Inherited from Surface.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Axis | Axis of the revolved surface. This is the Z axis of the local coordinate system associated with this revolved surface.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Surface.)
Public property | OrientationMatchesParametricOrientation | Indicates whether this Surface's orientation is the same as or opposite to its parametric orientation. (Inherited from Surface.)
Public property | Origin | Center of the circle that defines the base of the revolved surface. This is the origin of the local coordinate system associated with this revolved surface.
Public property | XDir | X axis of the local coordinate system associated with this revolved surface.
Public property | YDir | X axis of the local coordinate system associated with this revolved surface.

See Also

RevolvedSurface Class


RevolvedSurface Methods

[image] [image]

Revit 2024 API
RevolvedSurface Methods
RevolvedSurface Class See Also Send Feedback

The RevolvedSurface type exposes the following members.

Methods

 | Name | Description
 | Create(Frame, Curve) | Creates a Surface object coincident with the surface of revolution defined by a coordinate frame and a profile curve.
 | Create(XYZ, XYZ, Curve) | Creates a Surface object coincident with the surface of revolution defined by an axis and a profile curve.
 | Create(Frame, Curve, Double, Double) | Creates a Surface object coincident with the surface of revolution defined by a coordinate frame, a profile curve, and start and end angles of revolution.
 | Create(XYZ, XYZ, Curve, Double, Double) | Creates a Surface object coincident with the surface of revolution defined by an axis, a profile curve, and start and end angles of revolution.
Public method | Dispose | (Inherited from Surface.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBoundingBoxUV | Gets the UV bounding box of the surface. (Inherited from Surface.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProfileCurve | Returns a copy of the profile curve expressed in the surface's coordinate system.
Public method | GetProfileCurveInWorldCoordinates | Returns a copy of the profile curve expressed in the world coordinate system.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValidProfileCurve(Frame, Curve) | Checks if the input profile curve is valid to create a surface of revolution in the given frame of reference.
 | IsValidProfileCurve(XYZ, XYZ, Curve) | Checks if the input profile curve is valid to create a surface of revolution around the given axis.
Public method | Project | Project a 3D point orthogonally onto a surface (to find the nearest point). Throws InvalidOperationException if the projection fails. (Inherited from Surface.)
Public method | ProjectWithGuessPoint | Project a 3D point orthogonally onto a surface (to find the nearest point). This method is meant to be used when a good approximate solution for the projection is available. Throws InvalidOperationException if the projection fails. (Inherited from Surface.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RevolvedSurface Class


Create Method

[image] [image]

Revit 2024 API
RevolvedSurface..::..Create Method
RevolvedSurface Class See Also Send Feedback

Overload List

Name | Description
Create(Frame, Curve) | Creates a Surface object coincident with the surface of revolution defined by a coordinate frame and a profile curve.
Create(XYZ, XYZ, Curve) | Creates a Surface object coincident with the surface of revolution defined by an axis and a profile curve.
Create(Frame, Curve, Double, Double) | Creates a Surface object coincident with the surface of revolution defined by a coordinate frame, a profile curve, and start and end angles of revolution.
Create(XYZ, XYZ, Curve, Double, Double) | Creates a Surface object coincident with the surface of revolution defined by an axis, a profile curve, and start and end angles of revolution.

See Also

RevolvedSurface Class
RevolvedSurface Members


Create Method (Frame, Curve)

[image]

Revit 2024 API
RevolvedSurface..::..Create Method (Frame, Curve)
RevolvedSurface Class See Also Send Feedback
Creates a Surface object coincident with the surface of revolution defined by a coordinate frame and a profile curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public static Surface Create(
    Frame frameOfReference,
    Curve profileCurve
)
Visual Basic
Public Shared Function Create ( _
    frameOfReference As Frame, _
    profileCurve As Curve _
) As Surface
Visual C++
public:
static Surface^ Create(
    Frame^ frameOfReference,
    Curve^ profileCurve
)

Parameters

frameOfReference
Type: Autodesk.Revit.DB..::..Frame
frameOfReference is an orthonormal frame that defines a local coordinate system for the surface of revolution.
  • The frame can be "right-handed" or "left-handed".
  • The origin of the frame is the base of point of the axis of revolution.
  • The BasisZ of the frame is the direction of the axis.
profileCurve
Type: Autodesk.Revit.DB..::..Curve
The profile curve, which should satisfy the following conditions:
  • It is bounded and non-degenerate.
  • It is co-planar with the axis of revolution.
  • It lies on the xz plane of the frame.
  • It lies on the right side of the axis.
  • Only the end points of the profile curve can touch the axis.

Return Value

The created surface. Note that this surface may not be of type RevolvedSurface.

Remarks

The returned surface may not be of type RevolvedSurface - this function will create a surface of the simplest possible type (Plane, Cylinder, etc.) that can be used to represent the required surface of revolution. Given that the surface may be simplified, this function does not guarantee any particular parameterization of the surface.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This Frame object may not be used as a local frame of reference. -or- The input profile curve is not valid to create a surface revolution in the given frame.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

RevolvedSurface Class
Create Overload


Create Method (XYZ, XYZ, Curve)

[image]

Revit 2024 API
RevolvedSurface..::..Create Method (XYZ, XYZ, Curve)
RevolvedSurface Class See Also Send Feedback
Creates a Surface object coincident with the surface of revolution defined by an axis and a profile curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public static Surface Create(
    XYZ axisBasePoint,
    XYZ axisDirection,
    Curve profileCurve
)
Visual Basic
Public Shared Function Create ( _
    axisBasePoint As XYZ, _
    axisDirection As XYZ, _
    profileCurve As Curve _
) As Surface
Visual C++
public:
static Surface^ Create(
    XYZ^ axisBasePoint,
    XYZ^ axisDirection,
    Curve^ profileCurve
)

Parameters

axisBasePoint
Type: Autodesk.Revit.DB..::..XYZ
The base point of the axis of revolution. Expected to lie within the Revit design limits IsWithinLengthLimits(XYZ).
axisDirection
Type: Autodesk.Revit.DB..::..XYZ
The direction of the axis.
profileCurve
Type: Autodesk.Revit.DB..::..Curve
The profile curve, which should satisfy the following conditions:
  • It is bounded and non-degenerate.
  • It is co-planar with the axis of revolution.
  • It lies on only one side of the axis.
  • Only the end points of the profile curve can touch the axis.

Return Value

The created surface. Note that this surface may not be of type RevolvedSurface.

Remarks

The returned surface may not be of type RevolvedSurface - this function will create a surface of the simplest possible type (Plane, Cylinder, etc.) that can be used to represent the required surface of revolution. Given that the surface may be simplified, this function does not guarantee any particular parameterization of the surface.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input point lies outside of Revit design limits. -or- The input profile curve is not valid to create a surface revolution around the given axis.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | axisDirection has zero length.

See Also

RevolvedSurface Class
Create Overload


Create Method (XYZ, XYZ, Curve, Double, Double)

[image]

Revit 2024 API
RevolvedSurface..::..Create Method (XYZ, XYZ, Curve, Double, Double)
RevolvedSurface Class See Also Send Feedback
Creates a Surface object coincident with the surface of revolution defined by an axis, a profile curve, and start and end angles of revolution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public static Surface Create(
    XYZ axisBasePoint,
    XYZ axisDirection,
    Curve profileCurve,
    double startAngle,
    double endAngle
)
Visual Basic
Public Shared Function Create ( _
    axisBasePoint As XYZ, _
    axisDirection As XYZ, _
    profileCurve As Curve, _
    startAngle As Double, _
    endAngle As Double _
) As Surface
Visual C++
public:
static Surface^ Create(
    XYZ^ axisBasePoint,
    XYZ^ axisDirection,
    Curve^ profileCurve,
    double startAngle,
    double endAngle
)

Parameters

axisBasePoint
Type: Autodesk.Revit.DB..::..XYZ
The base point of the axis of revolution. Expected to lie within the Revit design limits IsWithinLengthLimits(XYZ).
axisDirection
Type: Autodesk.Revit.DB..::..XYZ
The direction of the axis.
profileCurve
Type: Autodesk.Revit.DB..::..Curve
The profile curve, which should satisfy the following conditions:
  • It is bounded and non-degenerate.
  • It is co-planar with the axis of revolution.
  • It lies on only one side of the axis.
  • Only the end points of the profile curve can touch the axis.
startAngle
Type: System..::..Double
Start angle of rotation. The angles are measured around the axis of revolution, using the right-hand rule. The profile curve is at the zero angle.
endAngle
Type: System..::..Double
End angle of rotation. Start angle must be less than end angle and their difference must be less than or equal to two times PI.

Return Value

The created surface. Note that this surface may not be of type RevolvedSurface.

Remarks

The returned surface may not be of type RevolvedSurface - this function will create a surface of the simplest possible type (Plane, Cylinder, etc.) that can be used to represent the required surface of revolution. Given that the surface may be simplified, this function does not guarantee any particular parameterization of the surface.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input point lies outside of Revit design limits. -or- The input profile curve is not valid to create a surface revolution around the given axis.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | axisDirection has zero length.
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | Start angle must be less than end angle and their difference must be less than or equal to two times PI.

See Also

RevolvedSurface Class
Create Overload


IsValidProfileCurve Method

[image] [image]

Revit 2024 API
RevolvedSurface..::..IsValidProfileCurve Method
RevolvedSurface Class See Also Send Feedback

Overload List

Name | Description
IsValidProfileCurve(Frame, Curve) | Checks if the input profile curve is valid to create a surface of revolution in the given frame of reference.
IsValidProfileCurve(XYZ, XYZ, Curve) | Checks if the input profile curve is valid to create a surface of revolution around the given axis.

See Also

RevolvedSurface Class
RevolvedSurface Members


IsValidProfileCurve Method (Frame, Curve)

[image]

Revit 2024 API
RevolvedSurface..::..IsValidProfileCurve Method (Frame, Curve)
RevolvedSurface Class See Also Send Feedback
Checks if the input profile curve is valid to create a surface of revolution in the given frame of reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public static bool IsValidProfileCurve(
    Frame frameOfReference,
    Curve profileCurve
)
Visual Basic
Public Shared Function IsValidProfileCurve ( _
    frameOfReference As Frame, _
    profileCurve As Curve _
) As Boolean
Visual C++
public:
static bool IsValidProfileCurve(
    Frame^ frameOfReference,
    Curve^ profileCurve
)

Parameters

frameOfReference
Type: Autodesk.Revit.DB..::..Frame
frameOfReference is an orthonormal frame that defines a local coordinate system for the surface of revolution.
  • The frame can be "right-handed" or "left-handed".
  • The origin of the frame is the base of point of the axis of revolution.
  • The BasisZ of the frame is the direction of the axis.
profileCurve
Type: Autodesk.Revit.DB..::..Curve
The profile curve.

Return Value

True if the profile curve is valid; False otherwise.

Remarks

The validity is defined as follows:
  • The profile curve is bounded and non-degenerate.
  • It is co-planar with the axis of revolution.
  • It lies on the xz plane of the frame.
  • It lies on the right side of the axis.
  • Only the end points of the profile curve can touch the axis.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

RevolvedSurface Class
IsValidProfileCurve Overload


IsValidProfileCurve Method (XYZ, XYZ, Curve)

[image]

Revit 2024 API
RevolvedSurface..::..IsValidProfileCurve Method (XYZ, XYZ, Curve)
RevolvedSurface Class See Also Send Feedback
Checks if the input profile curve is valid to create a surface of revolution around the given axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public static bool IsValidProfileCurve(
    XYZ axisBasePoint,
    XYZ axisDirection,
    Curve profileCurve
)
Visual Basic
Public Shared Function IsValidProfileCurve ( _
    axisBasePoint As XYZ, _
    axisDirection As XYZ, _
    profileCurve As Curve _
) As Boolean
Visual C++
public:
static bool IsValidProfileCurve(
    XYZ^ axisBasePoint,
    XYZ^ axisDirection,
    Curve^ profileCurve
)

Parameters

axisBasePoint
Type: Autodesk.Revit.DB..::..XYZ
The base point of the axis of revolution.
axisDirection
Type: Autodesk.Revit.DB..::..XYZ
The direction of the axis.
profileCurve
Type: Autodesk.Revit.DB..::..Curve
The profile curve.

Return Value

True if the profile curve is valid; False otherwise.

Remarks

The validity is defined as follows:
  • The profile curve is bounded and non-degenerate.
  • It is co-planar with the axis of revolution.
  • It lies on only one side of the axis.
  • Only the end points of the profile curve can touch the axis.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

RevolvedSurface Class
IsValidProfileCurve Overload


Origin Property

[image]

Revit 2024 API
RevolvedSurface..::..Origin Property
RevolvedSurface Class See Also Send Feedback
Center of the circle that defines the base of the revolved surface. This is the origin of the local coordinate system associated with this revolved surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public XYZ Origin { get; }
Visual Basic
Public ReadOnly Property Origin As XYZ
    Get
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
}

See Also

RevolvedSurface Class


XDir Property

[image]

Revit 2024 API
RevolvedSurface..::..XDir Property
RevolvedSurface Class See Also Send Feedback
X axis of the local coordinate system associated with this revolved surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public XYZ XDir { get; }
Visual Basic
Public ReadOnly Property XDir As XYZ
    Get
Visual C++
public:
property XYZ^ XDir {
    XYZ^ get ();
}

See Also

RevolvedSurface Class


YDir Property

[image]

Revit 2024 API
RevolvedSurface..::..YDir Property
RevolvedSurface Class See Also Send Feedback
X axis of the local coordinate system associated with this revolved surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public XYZ YDir { get; }
Visual Basic
Public ReadOnly Property YDir As XYZ
    Get
Visual C++
public:
property XYZ^ YDir {
    XYZ^ get ();
}

See Also

RevolvedSurface Class


RoofBase Members

[image] [image]

Revit 2024 API
RoofBase Members
RoofBase Class Methods Properties See Also Send Feedback

The RoofBase type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSlabShapeEditor | Gets a SlabShapeEditor that can used to add or modify points of this RoofBase.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EaveCuts | Retrieve or set the EaveCutterType.
Public property | FasciaDepth | Retrieve or set the FasciaDepth.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RoofType | Retrieve or set the Type.
Public property | SlabShapeEditor | Obsolete. Get the SlabShapeEditor used for slab shape editing.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

RoofBase Class


RoofBase Methods

[image] [image]

Revit 2024 API
RoofBase Methods
RoofBase Class See Also Send Feedback

The RoofBase type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSlabShapeEditor | Gets a SlabShapeEditor that can used to add or modify points of this RoofBase.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RoofBase Class


GetSlabShapeEditor Method

[image]

Revit 2024 API
RoofBase..::..GetSlabShapeEditor Method
RoofBase Class See Also Send Feedback
Gets a SlabShapeEditor that can used to add or modify points of this RoofBase.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public SlabShapeEditor GetSlabShapeEditor()
Visual Basic
Public Function GetSlabShapeEditor As SlabShapeEditor
Visual C++
public:
SlabShapeEditor^ GetSlabShapeEditor()

Return Value

The SlabShapeEditor object

See Also

RoofBase Class


RoofBase Properties

[image] [image]

Revit 2024 API
RoofBase Properties
RoofBase Class See Also Send Feedback

The RoofBase type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EaveCuts | Retrieve or set the EaveCutterType.
Public property | FasciaDepth | Retrieve or set the FasciaDepth.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RoofType | Retrieve or set the Type.
Public property | SlabShapeEditor | Obsolete. Get the SlabShapeEditor used for slab shape editing.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

RoofBase Class


EaveCuts Property

[image]

Revit 2024 API
RoofBase..::..EaveCuts Property
RoofBase Class See Also Send Feedback
Retrieve or set the EaveCutterType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public EaveCutterType EaveCuts { get; set; }
Visual Basic
Public Property EaveCuts As EaveCutterType
    Get
    Set
Visual C++
public:
property EaveCutterType EaveCuts {
    EaveCutterType get ();
    void set (EaveCutterType value);
}

See Also

RoofBase Class


Parameter Property

[image] [image]

Revit 2024 API
RoofBase..::..Parameter Property
RoofBase Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

RoofBase Class
RoofBase Members


RoofType Property

[image]

Revit 2024 API
RoofBase..::..RoofType Property
RoofBase Class See Also Send Feedback
Retrieve or set the Type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public RoofType RoofType { get; set; }
Visual Basic
Public Property RoofType As RoofType
    Get
    Set
Visual C++
public:
property RoofType^ RoofType {
    RoofType^ get ();
    void set (RoofType^ value);
}

See Also

RoofBase Class


RoofType Class

[image]

Revit 2024 API
RoofType Class
Members See Also Send Feedback
Represents a specific type of roof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class RoofType : HostObjAttributes
Visual Basic
Public Class RoofType _
    Inherits HostObjAttributes
Visual C++
public ref class RoofType : public HostObjAttributes

Remarks

All roof type objects available in the project can be retrieved from the Document object via the RoofTypes property. Every Roof object has a RoofType property that returns a RoofType object representing the type. This same RoofType property can also be used to change the type of the roof by setting it to a different type.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..HostObjAttributes
Autodesk.Revit.DB..::..RoofType

See Also

RoofType Members


RoofType Members

[image] [image]

Revit 2024 API
RoofType Members
RoofType Class Methods Properties See Also Send Feedback

The RoofType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ThermalProperties | The calculated and settable thermal properties of the RoofType
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

RoofType Class


RoofType Methods

[image] [image]

Revit 2024 API
RoofType Methods
RoofType Class See Also Send Feedback

The RoofType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RoofType Class


RoofType Properties

[image] [image]

Revit 2024 API
RoofType Properties
RoofType Class See Also Send Feedback

The RoofType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ThermalProperties | The calculated and settable thermal properties of the RoofType
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

RoofType Class


Parameter Property

[image] [image]

Revit 2024 API
RoofType..::..Parameter Property
RoofType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

RoofType Class
RoofType Members


ThermalProperties Property

[image]

Revit 2024 API
RoofType..::..ThermalProperties Property
RoofType Class See Also Send Feedback
The calculated and settable thermal properties of the RoofType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ThermalProperties ThermalProperties { get; }
Visual Basic
Public ReadOnly Property ThermalProperties As ThermalProperties
    Get
Visual C++
public:
property ThermalProperties^ ThermalProperties {
    ThermalProperties^ get ();
}

Remarks

Returns nullNothingnullptra null reference (Nothing in Visual Basic) if the roof has no thermal properties. Curtain roofs do not store thermal properties.

See Also

RoofType Class


RoundingMethod Enumeration

[image]

Revit 2024 API
RoundingMethod Enumeration
See Also Send Feedback
Rounding methods

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016
Since: 2016

Syntax

C#
public enum RoundingMethod
Visual Basic
Public Enumeration RoundingMethod
Visual C++
public enum class RoundingMethod

Members

Member name | Description
Nearest | Standard rounding: Round to Nearest
Up | Round Up
Down | Round Down

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


RoutingCondition Class

[image]

Revit 2024 API
RoutingCondition Class
Members See Also Send Feedback
RoutingCondition represents routing information that is used as input when determining if a routing criterion, such as minimum or maximum diameter, is met.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public class RoutingCondition : IDisposable
Visual Basic
Public Class RoutingCondition _
    Implements IDisposable
Visual C++
public ref class RoutingCondition : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..RoutingCondition

See Also

RoutingCondition Members


RoutingCondition Members

[image] [image]

Revit 2024 API
RoutingCondition Members
RoutingCondition Class Constructors Methods Properties See Also Send Feedback

The RoutingCondition type exposes the following members.

Constructors

 | Name | Description
Public method | RoutingCondition | Creates a new RoutingCondition.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the RoutingCondition
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Diameter | The diameter of the segment or fitting specified for the routing condition.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

RoutingCondition Class


RoutingCondition Constructor

[image]

Revit 2024 API
RoutingCondition Constructor
RoutingCondition Class See Also Send Feedback
Creates a new RoutingCondition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public RoutingCondition(
    double diameter
)
Visual Basic
Public Sub New ( _
    diameter As Double _
)
Visual C++
public:
RoutingCondition(
    double diameter
)

Parameters

diameter
Type: System..::..Double
The diameter of a routing segment.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given value for diameter must be greater than 0 and no more than 30000 feet.

See Also

RoutingCondition Class


RoutingCondition Methods

[image] [image]

Revit 2024 API
RoutingCondition Methods
RoutingCondition Class See Also Send Feedback

The RoutingCondition type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RoutingCondition Class


Dispose Method

[image]

Revit 2024 API
RoutingCondition..::..Dispose Method
RoutingCondition Class See Also Send Feedback
Releases all resources used by the RoutingCondition

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

RoutingCondition Class


RoutingCondition Properties

[image] [image]

Revit 2024 API
RoutingCondition Properties
RoutingCondition Class See Also Send Feedback

The RoutingCondition type exposes the following members.

Properties

 | Name | Description
Public property | Diameter | The diameter of the segment or fitting specified for the routing condition.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

RoutingCondition Class


Diameter Property

[image]

Revit 2024 API
RoutingCondition..::..Diameter Property
RoutingCondition Class See Also Send Feedback
The diameter of the segment or fitting specified for the routing condition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double Diameter { get; }
Visual Basic
Public ReadOnly Property Diameter As Double
    Get
Visual C++
public:
property double Diameter {
    double get ();
}

See Also

RoutingCondition Class


RoutingConditions Class

[image]

Revit 2024 API
RoutingConditions Class
Members See Also Send Feedback
RoutingConditions contain routing information that is used as input when determining if a routing criterion, such as minimum or maximum diameter, is met.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public class RoutingConditions : IDisposable
Visual Basic
Public Class RoutingConditions _
    Implements IDisposable
Visual C++
public ref class RoutingConditions : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..RoutingConditions

See Also

RoutingConditions Members


RoutingConditions Constructor

[image]

Revit 2024 API
RoutingConditions Constructor
RoutingConditions Class See Also Send Feedback
Constructs a new instance of a RoutingConditions object with an indicated error level for conditions that do not meet any routing preference rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public RoutingConditions(
    RoutingPreferenceErrorLevel errorLevel
)
Visual Basic
Public Sub New ( _
    errorLevel As RoutingPreferenceErrorLevel _
)
Visual C++
public:
RoutingConditions(
    RoutingPreferenceErrorLevel errorLevel
)

Parameters

errorLevel
Type: Autodesk.Revit.DB..::..RoutingPreferenceErrorLevel

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

RoutingConditions Class


AppendCondition Method

[image]

Revit 2024 API
RoutingConditions..::..AppendCondition Method
RoutingConditions Class See Also Send Feedback
Appends a routing condition to the end of existing routing conditions. Note that the first item (indexed at 0) is the condition for the primary connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void AppendCondition(
    RoutingCondition condition
)
Visual Basic
Public Sub AppendCondition ( _
    condition As RoutingCondition _
)
Visual C++
public:
void AppendCondition(
    RoutingCondition^ condition
)

Parameters

condition
Type: Autodesk.Revit.DB..::..RoutingCondition

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

RoutingConditions Class


Dispose Method

[image]

Revit 2024 API
RoutingConditions..::..Dispose Method
RoutingConditions Class See Also Send Feedback
Releases all resources used by the RoutingConditions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

RoutingConditions Class


GetConditionAt Method

[image]

Revit 2024 API
RoutingConditions..::..GetConditionAt Method
RoutingConditions Class See Also Send Feedback
Gets the routing condition at the specified index position.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public RoutingCondition GetConditionAt(
    int index
)
Visual Basic
Public Function GetConditionAt ( _
    index As Integer _
) As RoutingCondition
Visual C++
public:
RoutingCondition^ GetConditionAt(
    int index
)

Parameters

index
Type: System..::..Int32
The 0-based index to access the collection of available conditions. The method throws the exception ArgumentOutOfRangeException if the index is out of range.

Return Value

The found routing condition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | index is not within the valid range of available conditions.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

RoutingConditions Class


GetNumberOfConditions Method

[image]

Revit 2024 API
RoutingConditions..::..GetNumberOfConditions Method
RoutingConditions Class See Also Send Feedback
Gets the number of included routing conditions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public int GetNumberOfConditions()
Visual Basic
Public Function GetNumberOfConditions As Integer
Visual C++
public:
int GetNumberOfConditions()

See Also

RoutingConditions Class


IsValidObject Property

[image]

Revit 2024 API
RoutingConditions..::..IsValidObject Property
RoutingConditions Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

RoutingConditions Class


PreferredJunctionType Property

[image]

Revit 2024 API
RoutingConditions..::..PreferredJunctionType Property
RoutingConditions Class See Also Send Feedback
The junction type (Tee or Tap) to select if defined fittings of both junction types meet all routing conditions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public PreferredJunctionType PreferredJunctionType { get; set; }
Visual Basic
Public Property PreferredJunctionType As PreferredJunctionType
    Get
    Set
Visual C++
public:
property PreferredJunctionType PreferredJunctionType {
    PreferredJunctionType get ();
    void set (PreferredJunctionType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

RoutingConditions Class


RoutingCriterionBase Class

[image]

Revit 2024 API
RoutingCriterionBase Class
Members See Also Send Feedback
RoutingCriteriaBase is the base class for all routing criteria.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public class RoutingCriterionBase : IDisposable
Visual Basic
Public Class RoutingCriterionBase _
    Implements IDisposable
Visual C++
public ref class RoutingCriterionBase : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..RoutingCriterionBase
Autodesk.Revit.DB..::..PrimarySizeCriterion

See Also

RoutingCriterionBase Members


RoutingCriterionBase Members

[image] [image]

Revit 2024 API
RoutingCriterionBase Members
RoutingCriterionBase Class Methods Properties See Also Send Feedback

The RoutingCriterionBase type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the RoutingCriterionBase
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Verify if two criteria are the same.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

RoutingCriterionBase Class


RoutingCriterionBase Methods

[image] [image]

Revit 2024 API
RoutingCriterionBase Methods
RoutingCriterionBase Class See Also Send Feedback

The RoutingCriterionBase type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Verify if two criteria are the same.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RoutingCriterionBase Class


Dispose Method

[image]

Revit 2024 API
RoutingCriterionBase..::..Dispose Method
RoutingCriterionBase Class See Also Send Feedback
Releases all resources used by the RoutingCriterionBase

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

RoutingCriterionBase Class


IsEqual Method

[image]

Revit 2024 API
RoutingCriterionBase..::..IsEqual Method
RoutingCriterionBase Class See Also Send Feedback
Verify if two criteria are the same.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool IsEqual(
    RoutingCriterionBase pOther
)
Visual Basic
Public Function IsEqual ( _
    pOther As RoutingCriterionBase _
) As Boolean
Visual C++
public:
bool IsEqual(
    RoutingCriterionBase^ pOther
)

Parameters

pOther
Type: Autodesk.Revit.DB..::..RoutingCriterionBase

Return Value

True if the criterion is equal to the other, false otherwise

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

RoutingCriterionBase Class


IsValidObject Property

[image]

Revit 2024 API
RoutingCriterionBase..::..IsValidObject Property
RoutingCriterionBase Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

RoutingCriterionBase Class


RoutingPreferenceErrorLevel Enumeration

[image]

Revit 2024 API
RoutingPreferenceErrorLevel Enumeration
See Also Send Feedback
An enumerated type listing the options for posting errors or warnings when routing preferences are not satisfied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Since: 2013

Syntax

C#
public enum RoutingPreferenceErrorLevel
Visual Basic
Public Enumeration RoutingPreferenceErrorLevel
Visual C++
public enum class RoutingPreferenceErrorLevel

Members

Member name | Description
None | Do not post any warning or error if there is no rule in the routing preference satisfying the current condition.
Warning | Post Revit warnings if there is no rule in the routing preference satisfying the current condition.
Error | Post Revit errors if there is no rule in the routing preference satisfying the current condition.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


RoutingPreferenceManager Class

[image]

Revit 2024 API
RoutingPreferenceManager Class
Members See Also Send Feedback
Manages default pipe segments, fittings, and selection criteria for a given MEPCurveType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public class RoutingPreferenceManager : IDisposable
Visual Basic
Public Class RoutingPreferenceManager _
    Implements IDisposable
Visual C++
public ref class RoutingPreferenceManager : IDisposable

Remarks

MEPCurveTypes contain a RoutingPreferenceManager property. The RoutingPreferenceManager contains rules for selecting segment types and sizes as well as fitting types based on user selection criteria.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..RoutingPreferenceManager

See Also

RoutingPreferenceManager Members


RoutingPreferenceManager Members

[image] [image]

Revit 2024 API
RoutingPreferenceManager Members
RoutingPreferenceManager Class Methods Properties See Also Send Feedback

The RoutingPreferenceManager type exposes the following members.

Methods

 | Name | Description
Public method | AddRule(RoutingPreferenceRuleGroupType, RoutingPreferenceRule) | Adds a new routing preference rule to the rule group.
Public method | AddRule(RoutingPreferenceRuleGroupType, RoutingPreferenceRule, Int32) | Adds a new routing preference rule to the specified position in the rule group.
Public method | Dispose | Releases all resources used by the RoutingPreferenceManager
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMEPPartId | Gets a fitting or segment id of given routing preference group that meets the specified routing conditions.
Public method | GetNumberOfRules | The number of RoutingPreference rules in a group.
Public method | GetRule | Gets the specified rule.
Public method | GetSharedSizes | Gets a list of all segments of a given profile shape that define a given size.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveRule | Removes an existing routing preference rule. Thrown if the index is out of bounds.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OwnerId | The Id of the MEPCurveType that owns the RoutingPreferenceManager
Public property | PreferredJunctionType | The preferred junction type.

See Also

RoutingPreferenceManager Class


AddRule Method

[image] [image]

Revit 2024 API
RoutingPreferenceManager..::..AddRule Method
RoutingPreferenceManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddRule(RoutingPreferenceRuleGroupType, RoutingPreferenceRule) | Adds a new routing preference rule to the rule group.
Public method | AddRule(RoutingPreferenceRuleGroupType, RoutingPreferenceRule, Int32) | Adds a new routing preference rule to the specified position in the rule group.

See Also

RoutingPreferenceManager Class
RoutingPreferenceManager Members


AddRule Method (RoutingPreferenceRuleGroupType, RoutingPreferenceRule)

[image]

Revit 2024 API
RoutingPreferenceManager..::..AddRule Method (RoutingPreferenceRuleGroupType, RoutingPreferenceRule)
RoutingPreferenceManager Class See Also Send Feedback
Adds a new routing preference rule to the rule group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void AddRule(
    RoutingPreferenceRuleGroupType groupType,
    RoutingPreferenceRule rule
)
Visual Basic
Public Sub AddRule ( _
    groupType As RoutingPreferenceRuleGroupType, _
    rule As RoutingPreferenceRule _
)
Visual C++
public:
void AddRule(
    RoutingPreferenceRuleGroupType groupType,
    RoutingPreferenceRule^ rule
)

Parameters

groupType
Type: Autodesk.Revit.DB..::..RoutingPreferenceRuleGroupType
The routing preference group in which the rule should be added.
rule
Type: Autodesk.Revit.DB..::..RoutingPreferenceRule
The new rule to be added.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The rule cannot be added to the groupType. -or- Thrown if the index is out of bounds, or the rule is not valid for this group (e.g. an elbow may not be added to the junction group).
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

RoutingPreferenceManager Class
AddRule Overload


AddRule Method (RoutingPreferenceRuleGroupType, RoutingPreferenceRule, Int32)

[image]

Revit 2024 API
RoutingPreferenceManager..::..AddRule Method (RoutingPreferenceRuleGroupType, RoutingPreferenceRule, Int32)
RoutingPreferenceManager Class See Also Send Feedback
Adds a new routing preference rule to the specified position in the rule group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void AddRule(
    RoutingPreferenceRuleGroupType groupType,
    RoutingPreferenceRule rule,
    int index
)
Visual Basic
Public Sub AddRule ( _
    groupType As RoutingPreferenceRuleGroupType, _
    rule As RoutingPreferenceRule, _
    index As Integer _
)
Visual C++
public:
void AddRule(
    RoutingPreferenceRuleGroupType groupType,
    RoutingPreferenceRule^ rule,
    int index
)

Parameters

groupType
Type: Autodesk.Revit.DB..::..RoutingPreferenceRuleGroupType
The routing preference group type in which the rule should be added.
rule
Type: Autodesk.Revit.DB..::..RoutingPreferenceRule
The new rule to be added.
index
Type: System..::..Int32
The zero-based index position where the new rule will be added.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | index is not a valid zero-based index within groupType. -or- The rule cannot be added to the groupType. -or- Thrown if the index is out of bounds, or the rule is not valid for this group (e.g. an elbow may not be added to the junction group).
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

RoutingPreferenceManager Class
AddRule Overload


Dispose Method

[image]

Revit 2024 API
RoutingPreferenceManager..::..Dispose Method
RoutingPreferenceManager Class See Also Send Feedback
Releases all resources used by the RoutingPreferenceManager

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

RoutingPreferenceManager Class


GetMEPPartId Method

[image]

Revit 2024 API
RoutingPreferenceManager..::..GetMEPPartId Method
RoutingPreferenceManager Class See Also Send Feedback
Gets a fitting or segment id of given routing preference group that meets the specified routing conditions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ElementId GetMEPPartId(
    RoutingPreferenceRuleGroupType groupType,
    RoutingConditions conditions
)
Visual Basic
Public Function GetMEPPartId ( _
    groupType As RoutingPreferenceRuleGroupType, _
    conditions As RoutingConditions _
) As ElementId
Visual C++
public:
ElementId^ GetMEPPartId(
    RoutingPreferenceRuleGroupType groupType,
    RoutingConditions^ conditions
)

Parameters

groupType
Type: Autodesk.Revit.DB..::..RoutingPreferenceRuleGroupType
The routing preference group
conditions
Type: Autodesk.Revit.DB..::..RoutingConditions
A set of routing conditions

Return Value

The Id of the fitting or segment that met the given routing conditions.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

RoutingPreferenceManager Class


GetRule Method

[image]

Revit 2024 API
RoutingPreferenceManager..::..GetRule Method
RoutingPreferenceManager Class See Also Send Feedback
Gets the specified rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public RoutingPreferenceRule GetRule(
    RoutingPreferenceRuleGroupType groupType,
    int index
)
Visual Basic
Public Function GetRule ( _
    groupType As RoutingPreferenceRuleGroupType, _
    index As Integer _
) As RoutingPreferenceRule
Visual C++
public:
RoutingPreferenceRule^ GetRule(
    RoutingPreferenceRuleGroupType groupType,
    int index
)

Parameters

groupType
Type: Autodesk.Revit.DB..::..RoutingPreferenceRuleGroupType
The routing preference group type from which the rule should be returned.
index
Type: System..::..Int32
The zero-based index where the rule should be returned.

Return Value

The rule at the specified group and zero-based index position.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | index is not a valid zero-based index within groupType. -or- Thrown if the index is out of bounds
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

RoutingPreferenceManager Class


GetSharedSizes Method

[image]

Revit 2024 API
RoutingPreferenceManager..::..GetSharedSizes Method
RoutingPreferenceManager Class See Also Send Feedback
Gets a list of all segments of a given profile shape that define a given size.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public IList<ElementId> GetSharedSizes(
    double size,
    ConnectorProfileType shape
)
Visual Basic
Public Function GetSharedSizes ( _
    size As Double, _
    shape As ConnectorProfileType _
) As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetSharedSizes(
    double size,
    ConnectorProfileType shape
)

Parameters

size
Type: System..::..Double
The size to search for.
shape
Type: Autodesk.Revit.DB..::..ConnectorProfileType
The profile shape of segment object.

Return Value

A list of all segments that define a given size.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

RoutingPreferenceManager Class


RemoveRule Method

[image]

Revit 2024 API
RoutingPreferenceManager..::..RemoveRule Method
RoutingPreferenceManager Class See Also Send Feedback
Removes an existing routing preference rule. Thrown if the index is out of bounds.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void RemoveRule(
    RoutingPreferenceRuleGroupType groupType,
    int index
)
Visual Basic
Public Sub RemoveRule ( _
    groupType As RoutingPreferenceRuleGroupType, _
    index As Integer _
)
Visual C++
public:
void RemoveRule(
    RoutingPreferenceRuleGroupType groupType,
    int index
)

Parameters

groupType
Type: Autodesk.Revit.DB..::..RoutingPreferenceRuleGroupType
The routing preference group type in which the rule should be removed.
index
Type: System..::..Int32
The index position of removed routing preference rule in the group.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | index is not a valid zero-based index within groupType. -or-
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

RoutingPreferenceManager Class


RoutingPreferenceManager Properties

[image] [image]

Revit 2024 API
RoutingPreferenceManager Properties
RoutingPreferenceManager Class See Also Send Feedback

The RoutingPreferenceManager type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OwnerId | The Id of the MEPCurveType that owns the RoutingPreferenceManager
Public property | PreferredJunctionType | The preferred junction type.

See Also

RoutingPreferenceManager Class


IsValidObject Property

[image]

Revit 2024 API
RoutingPreferenceManager..::..IsValidObject Property
RoutingPreferenceManager Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

RoutingPreferenceManager Class


OwnerId Property

[image]

Revit 2024 API
RoutingPreferenceManager..::..OwnerId Property
RoutingPreferenceManager Class See Also Send Feedback
The Id of the MEPCurveType that owns the RoutingPreferenceManager

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ElementId OwnerId { get; }
Visual Basic
Public ReadOnly Property OwnerId As ElementId
    Get
Visual C++
public:
property ElementId^ OwnerId {
    ElementId^ get ();
}

See Also

RoutingPreferenceManager Class


PreferredJunctionType Property

[image]

Revit 2024 API
RoutingPreferenceManager..::..PreferredJunctionType Property
RoutingPreferenceManager Class See Also Send Feedback
The preferred junction type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public PreferredJunctionType PreferredJunctionType { get; set; }
Visual Basic
Public Property PreferredJunctionType As PreferredJunctionType
    Get
    Set
Visual C++
public:
property PreferredJunctionType PreferredJunctionType {
    PreferredJunctionType get ();
    void set (PreferredJunctionType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

RoutingPreferenceManager Class


RoutingPreferenceRule Class

[image]

Revit 2024 API
RoutingPreferenceRule Class
Members See Also Send Feedback
A class representing a rule set in MEP routing preferences.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public class RoutingPreferenceRule : IDisposable
Visual Basic
Public Class RoutingPreferenceRule _
    Implements IDisposable
Visual C++
public ref class RoutingPreferenceRule : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..RoutingPreferenceRule

See Also

RoutingPreferenceRule Members


RoutingPreferenceRule Members

[image] [image]

Revit 2024 API
RoutingPreferenceRule Members
RoutingPreferenceRule Class Constructors Methods Properties See Also Send Feedback

The RoutingPreferenceRule type exposes the following members.

Constructors

 | Name | Description
Public method | RoutingPreferenceRule | Constructs a RoutingPreferenceRule containing a segment or fitting Id (MEPPartId) and description.

Methods

 | Name | Description
Public method | AddCriterion | Adds a new routing criterion.
Public method | Dispose | Releases all resources used by the RoutingPreferenceRule
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCriterion | Gets the specified criteria.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveCriteron | Removes an existing criterion.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Description | The description of the routing preference rule.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MEPPartId | The referenced MEPPart (segment or fitting) type in this rule. It may be InvalidElementId if no MEPPart will be allowed when the conditions satisfy the criteria in this rule.
Public property | NumberOfCriteria | Gets the number of routing criteria.
Public property | RoutingPreferenceManager | Gets the routing preference manager that owns this rule.

See Also

RoutingPreferenceRule Class


RoutingPreferenceRule Constructor

[image]

Revit 2024 API
RoutingPreferenceRule Constructor
RoutingPreferenceRule Class See Also Send Feedback
Constructs a RoutingPreferenceRule containing a segment or fitting Id (MEPPartId) and description.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public RoutingPreferenceRule(
    ElementId MEPPartId,
    string description
)
Visual Basic
Public Sub New ( _
    MEPPartId As ElementId, _
    description As String _
)
Visual C++
public:
RoutingPreferenceRule(
    ElementId^ MEPPartId,
    String^ description
)

Parameters

MEPPartId
Type: Autodesk.Revit.DB..::..ElementId
The Id of the segment or fitting. InvalidElementId may be specified if no MEPPart will be allowed when the conditions satisfy the criteria in this rule.
description
Type: System..::..String
The description of the rule.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

RoutingPreferenceRule Class


RoutingPreferenceRule Methods

[image] [image]

Revit 2024 API
RoutingPreferenceRule Methods
RoutingPreferenceRule Class See Also Send Feedback

The RoutingPreferenceRule type exposes the following members.

Methods

 | Name | Description
Public method | AddCriterion | Adds a new routing criterion.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCriterion | Gets the specified criteria.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveCriteron | Removes an existing criterion.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RoutingPreferenceRule Class


AddCriterion Method

[image]

Revit 2024 API
RoutingPreferenceRule..::..AddCriterion Method
RoutingPreferenceRule Class See Also Send Feedback
Adds a new routing criterion.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void AddCriterion(
    RoutingCriterionBase myCriterion
)
Visual Basic
Public Sub AddCriterion ( _
    myCriterion As RoutingCriterionBase _
)
Visual C++
public:
void AddCriterion(
    RoutingCriterionBase^ myCriterion
)

Parameters

myCriterion
Type: Autodesk.Revit.DB..::..RoutingCriterionBase
The criterion to add.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

RoutingPreferenceRule Class


Dispose Method

[image]

Revit 2024 API
RoutingPreferenceRule..::..Dispose Method
RoutingPreferenceRule Class See Also Send Feedback
Releases all resources used by the RoutingPreferenceRule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

RoutingPreferenceRule Class


RemoveCriteron Method

[image]

Revit 2024 API
RoutingPreferenceRule..::..RemoveCriteron Method
RoutingPreferenceRule Class See Also Send Feedback
Removes an existing criterion.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void RemoveCriteron(
    int index
)
Visual Basic
Public Sub RemoveCriteron ( _
    index As Integer _
)
Visual C++
public:
void RemoveCriteron(
    int index
)

Parameters

index
Type: System..::..Int32
The index position of removed routing preference rule in the group.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | index is not a valid zero-based index. -or- Thrown if the index is out of bounds.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

RoutingPreferenceRule Class


RoutingPreferenceRule Properties

[image] [image]

Revit 2024 API
RoutingPreferenceRule Properties
RoutingPreferenceRule Class See Also Send Feedback

The RoutingPreferenceRule type exposes the following members.

Properties

 | Name | Description
Public property | Description | The description of the routing preference rule.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MEPPartId | The referenced MEPPart (segment or fitting) type in this rule. It may be InvalidElementId if no MEPPart will be allowed when the conditions satisfy the criteria in this rule.
Public property | NumberOfCriteria | Gets the number of routing criteria.
Public property | RoutingPreferenceManager | Gets the routing preference manager that owns this rule.

See Also

RoutingPreferenceRule Class


Description Property

[image]

Revit 2024 API
RoutingPreferenceRule..::..Description Property
RoutingPreferenceRule Class See Also Send Feedback
The description of the routing preference rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public string Description { get; }
Visual Basic
Public ReadOnly Property Description As String
    Get
Visual C++
public:
property String^ Description {
    String^ get ();
}

See Also

RoutingPreferenceRule Class


IsValidObject Property

[image]

Revit 2024 API
RoutingPreferenceRule..::..IsValidObject Property
RoutingPreferenceRule Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

RoutingPreferenceRule Class


MEPPartId Property

[image]

Revit 2024 API
RoutingPreferenceRule..::..MEPPartId Property
RoutingPreferenceRule Class See Also Send Feedback
The referenced MEPPart (segment or fitting) type in this rule. It may be InvalidElementId if no MEPPart will be allowed when the conditions satisfy the criteria in this rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ElementId MEPPartId { get; }
Visual Basic
Public ReadOnly Property MEPPartId As ElementId
    Get
Visual C++
public:
property ElementId^ MEPPartId {
    ElementId^ get ();
}

See Also

RoutingPreferenceRule Class


NumberOfCriteria Property

[image]

Revit 2024 API
RoutingPreferenceRule..::..NumberOfCriteria Property
RoutingPreferenceRule Class See Also Send Feedback
Gets the number of routing criteria.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public int NumberOfCriteria { get; }
Visual Basic
Public ReadOnly Property NumberOfCriteria As Integer
    Get
Visual C++
public:
property int NumberOfCriteria {
    int get ();
}

See Also

RoutingPreferenceRule Class


RoutingPreferenceRuleGroupType Enumeration

[image]

Revit 2024 API
RoutingPreferenceRuleGroupType Enumeration
See Also Send Feedback
Add more rule group type here.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Since: 2013

Syntax

C#
public enum RoutingPreferenceRuleGroupType
Visual Basic
Public Enumeration RoutingPreferenceRuleGroupType
Visual C++
public enum class RoutingPreferenceRuleGroupType

Members

Member name | Description
Undefined | The undefined group type, the default initial value.
Segments | The segment types (e.g. pipe stocks)
Elbows | The elbow types.
Junctions | The junction types (e.g. takeoff, tee, wye, tap).
Crosses | The cross types.
Transitions | The transition types (Note that the multi-shape transitions may have their own groups).
Unions | The union types that connect two segments together.
MechanicalJoints | The mechanical joint types that connect fitting to fitting, segment to fitting, or segment to segment.
TransitionsRectangularToRound | The multi-shape transition from the rectangular profile to the round profile.
TransitionsRectangularToOval | The multi-shape transition from the rectangular profile to the oval profile.
TransitionsOvalToRound | The multi-shape transition from the oval profile to the round profile.
Caps | The cap types

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


RowHeightOverrideOptions Enumeration

[image]

Revit 2024 API
RowHeightOverrideOptions Enumeration
See Also Send Feedback
Describes the options for overriding schedule body row heights (applied when viewed as a ScheduleSheetInstance on a ViewSheet).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024
Since: 2024

Syntax

C#
public enum RowHeightOverrideOptions
Visual Basic
Public Enumeration RowHeightOverrideOptions
Visual C++
public enum class RowHeightOverrideOptions

Members

Member name | Description
None | No override would be applied for the row height.
All | Override row height for any body rows in the schedule.
ImageRows | Override row height for body rows containing images in the schedule.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


RPCNode Class

[image]

Revit 2024 API
RPCNode Class
Members See Also Send Feedback
This class represents an RPC content in a model-exporting process.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class RPCNode : ContentNode
Visual Basic
Public Class RPCNode _
    Inherits ContentNode
Visual C++
public ref class RPCNode : public ContentNode

Remarks

See also: [!:Autodesk::Revit::DB::IExportContext::OnRPC].

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..RenderNode
Autodesk.Revit.DB..::..ContentNode
Autodesk.Revit.DB..::..RPCNode

See Also

RPCNode Members


RPCNode Members

[image] [image]

Revit 2024 API
RPCNode Members
RPCNode Class Methods Properties See Also Send Feedback

The RPCNode type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RenderNode.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAsset | Returns an an instance of an Asset object, which contains definitions of the content node. (Inherited from ContentNode.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTransform | A transformation matrix associated with the node. (Inherited from ContentNode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode.)
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode.)

See Also

RPCNode Class


RPCNode Methods

[image] [image]

Revit 2024 API
RPCNode Methods
RPCNode Class See Also Send Feedback

The RPCNode type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RenderNode.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAsset | Returns an an instance of an Asset object, which contains definitions of the content node. (Inherited from ContentNode.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTransform | A transformation matrix associated with the node. (Inherited from ContentNode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RPCNode Class


RPCNode Properties

[image] [image]

Revit 2024 API
RPCNode Properties
RPCNode Class See Also Send Feedback

The RPCNode type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode.)
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode.)

See Also

RPCNode Class


RuledFace Class

[image]

Revit 2024 API
RuledFace Class
Members Example See Also Send Feedback
A ruled face of a 3d solid or open shell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class RuledFace : Face
Visual Basic
Public Class RuledFace _
    Inherits Face
Visual C++
public ref class RuledFace : public Face

Remarks

A ruled surface is created by sweeping a line between two profile curves or between a curve and a point (a point and a curve). For details on the parameterization, refer to the documentation for RuledSurface.

Examples

CopyC#
private void GetRuledFaceInfo(Face face)
{
    RuledFace ruledFace = face as RuledFace;
    if (null != ruledFace)
    {
        Curve curve = ruledFace.get_Curve(0);
        XYZ point = ruledFace.get_Point(0);
    }
}
CopyVB.NET
Private Sub GetRuledFaceInfo(face As Face)
    Dim ruledFace As RuledFace = TryCast(face, RuledFace)
    If ruledFace IsNot Nothing Then
        Dim curve As Curve = ruledFace.Curve(0)
        Dim point As XYZ = ruledFace.Point(0)
    End If
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeometryObject
Autodesk.Revit.DB..::..Face
Autodesk.Revit.DB..::..RuledFace

See Also

RuledFace Members


RuledFace Members

[image] [image]

Revit 2024 API
RuledFace Members
RuledFace Class Methods Properties See Also Send Feedback

The RuledFace type exposes the following members.

Methods

 | Name | Description
Public method | ComputeDerivatives | Returns the first partial derivatives of the underlying surface at the specified point. (Inherited from Face.)
Public method | ComputeNormal | Returns the normal vector for the face at the given point. (Inherited from Face.)
Public method | ComputeSecondDerivatives | Returns the second partial derivatives of the face at the specified point. (Inherited from Face.)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates and returns the XYZ coordinates of a point at the indicated UV parameterization of the face. (Inherited from Face.)
Public method | GetBoundingBox | Returns the UV bounding box of the face. (Inherited from Face.)
Public method | GetEdgesAsCurveLoops | Returns a list of closed curve loops that correspond to the edge loops of the face. Curves in each curve loop correspond to individual edges. (Inherited from Face.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject.)
Public method | GetRegions | Gets the face regions (created, for example, by the Split Face command) of the face. (Inherited from Face.)
Public method | GetSurface | Returns a copy of this face's surface. (Inherited from Face.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Public method | Intersect(Face) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)
Public method | Intersect(Face, Curve%) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face.)
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional information about the point location. (Inherited from Face.)
Public method | Project | Projects the specified point on the face. (Inherited from Face.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Triangulate()()()() | Returns a triangular mesh approximation to the face. (Inherited from Face.)
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face. (Inherited from Face.)

Properties

 | Name | Description
Public property | Area | The area of this face. (Inherited from Face.)
Public property | Curve | Profile curves of the surface.
Public property | EdgeLoops | A collection of edge loops. Each edge loop represents one of the closed boundaries of the face. (Inherited from Face.)
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
Public property | HasRegions | Identifies if the face contains regions (which can be created, for example, by the Split Face command). (Inherited from Face.)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject.)
Public property | IsCyclic | Indicates whether the underlying surface is periodic in the specified parametric direction. (Inherited from Face.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsExtruded | Determines if this is an extruded ruled surface.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate). (Inherited from Face.)
Public property | MaterialElementId | The element ID of the material from which this face is composed. (Inherited from Face.)
Public property | OrientationMatchesSurfaceOrientation | Returns true if this face's orientation matches the orientation of the face's surface, false if they have opposite orientations. (Inherited from Face.)
Public property | Period | The period of the underlying surface in the specified parametric direction. (Inherited from Face.)
Public property | Point | Profile points of the surface.
Public property | Reference | Returns a stable reference to the face. (Inherited from Face.)
Public property | RulingsAreParallel | Determines if the rulings of this ruled surface are parallel.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

RuledFace Class


RuledFace Methods

[image] [image]

Revit 2024 API
RuledFace Methods
RuledFace Class See Also Send Feedback

The RuledFace type exposes the following members.

Methods

 | Name | Description
Public method | ComputeDerivatives | Returns the first partial derivatives of the underlying surface at the specified point. (Inherited from Face.)
Public method | ComputeNormal | Returns the normal vector for the face at the given point. (Inherited from Face.)
Public method | ComputeSecondDerivatives | Returns the second partial derivatives of the face at the specified point. (Inherited from Face.)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates and returns the XYZ coordinates of a point at the indicated UV parameterization of the face. (Inherited from Face.)
Public method | GetBoundingBox | Returns the UV bounding box of the face. (Inherited from Face.)
Public method | GetEdgesAsCurveLoops | Returns a list of closed curve loops that correspond to the edge loops of the face. Curves in each curve loop correspond to individual edges. (Inherited from Face.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject.)
Public method | GetRegions | Gets the face regions (created, for example, by the Split Face command) of the face. (Inherited from Face.)
Public method | GetSurface | Returns a copy of this face's surface. (Inherited from Face.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Public method | Intersect(Face) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)
Public method | Intersect(Face, Curve%) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face.)
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional information about the point location. (Inherited from Face.)
Public method | Project | Projects the specified point on the face. (Inherited from Face.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Triangulate()()()() | Returns a triangular mesh approximation to the face. (Inherited from Face.)
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face. (Inherited from Face.)

See Also

RuledFace Class


Intersect Method

[image] [image]

Revit 2024 API
RuledFace..::..Intersect Method
RuledFace Class See Also Send Feedback
Calculates the intersection of the specified curve with this face.

Overload List

 | Name | Description
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Public method | Intersect(Face) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)
Public method | Intersect(Face, Curve%) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face.)

See Also

RuledFace Class
RuledFace Members


IsInside Method

[image] [image]

Revit 2024 API
RuledFace..::..IsInside Method
RuledFace Class See Also Send Feedback
Indicates whether the specified point is within this face.

Overload List

 | Name | Description
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional information about the point location. (Inherited from Face.)

See Also

RuledFace Class
RuledFace Members


RuledFace Properties

[image] [image]

Revit 2024 API
RuledFace Properties
RuledFace Class See Also Send Feedback

The RuledFace type exposes the following members.

Properties

 | Name | Description
Public property | Area | The area of this face. (Inherited from Face.)
Public property | Curve | Profile curves of the surface.
Public property | EdgeLoops | A collection of edge loops. Each edge loop represents one of the closed boundaries of the face. (Inherited from Face.)
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
Public property | HasRegions | Identifies if the face contains regions (which can be created, for example, by the Split Face command). (Inherited from Face.)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject.)
Public property | IsCyclic | Indicates whether the underlying surface is periodic in the specified parametric direction. (Inherited from Face.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsExtruded | Determines if this is an extruded ruled surface.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate). (Inherited from Face.)
Public property | MaterialElementId | The element ID of the material from which this face is composed. (Inherited from Face.)
Public property | OrientationMatchesSurfaceOrientation | Returns true if this face's orientation matches the orientation of the face's surface, false if they have opposite orientations. (Inherited from Face.)
Public property | Period | The period of the underlying surface in the specified parametric direction. (Inherited from Face.)
Public property | Point | Profile points of the surface.
Public property | Reference | Returns a stable reference to the face. (Inherited from Face.)
Public property | RulingsAreParallel | Determines if the rulings of this ruled surface are parallel.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

RuledFace Class


Point Property

[image]

Revit 2024 API
RuledFace..::..Point Property
RuledFace Class See Also Send Feedback
Profile points of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ this[
    int index
] { get; }
Visual Basic
Public ReadOnly Property Point ( _
    index As Integer _
) As XYZ
    Get
Visual C++
public:
property XYZ^ Point[int index] {
    XYZ^ get (int index);
}

Parameters

index
Type: System..::..Int32

See Also

RuledFace Class


RulingsAreParallel Property

[image]

Revit 2024 API
RuledFace..::..RulingsAreParallel Property
RuledFace Class See Also Send Feedback
Determines if the rulings of this ruled surface are parallel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool RulingsAreParallel { get; }
Visual Basic
Public ReadOnly Property RulingsAreParallel As Boolean
    Get
Visual C++
public:
property bool RulingsAreParallel {
    bool get ();
}

See Also

RuledFace Class


RuledSurface Class

[image]

Revit 2024 API
RuledSurface Class
Members See Also Send Feedback
A ruled surface is created by sweeping a line between two profile curves or between a curve and a point (a point and a curve). Input curve(s) must be bounded or have natural bounds.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public class RuledSurface : Surface
Visual Basic
Public Class RuledSurface _
    Inherits Surface
Visual C++
public ref class RuledSurface : public Surface

Remarks

Both curves are evaluated in normalized parameters [0, 1] The parametric equations of a ruled surface are: Curve C1 and curve C2 : S(u, v) = C1(u) + v * (C2(u) - C1(u)); Point P1 and curve C2 : S(u, v) = P1 + v * (C2(u) - P1); Curve C1 and point P2 : S(u, v) = C1(u) + v * (P2 - C1(u)); The point/point case is not allowed as that would define a degenerate ruled surface.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Surface
Autodesk.Revit.DB..::..RuledSurface

See Also

RuledSurface Members


RuledSurface Members

[image] [image]

Revit 2024 API
RuledSurface Members
RuledSurface Class Methods Properties See Also Send Feedback

The RuledSurface type exposes the following members.

Methods

 | Name | Description
 | Create(Curve, Curve) | Creates a Surface object coincident with the ruled surface joining two bounded generating curves.
 | Create(Curve, XYZ) | Creates a Surface object coincident with the ruled surface joining a bounded generating curve to a point.
Public method | Dispose | (Inherited from Surface.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBoundingBoxUV | Gets the UV bounding box of the surface. (Inherited from Surface.)
Public method | GetFirstProfileCurve | Returns a copy of the first profile curve if it is set.
Public method | GetFirstProfilePoint | If a point was used to define the first profile, returns a copy of that point.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSecondProfileCurve | Returns a copy of the second profile curve if it is set.
Public method | GetSecondProfilePoint | If a point was used to define the second profile, returns a copy of that point.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasFirstProfilePoint | Checks if a point was used to define the first profile.
Public method | HasSecondProfilePoint | Checks if a point was used to define the second profile.
Public method | Project | Project a 3D point orthogonally onto a surface (to find the nearest point). Throws InvalidOperationException if the projection fails. (Inherited from Surface.)
Public method | ProjectWithGuessPoint | Project a 3D point orthogonally onto a surface (to find the nearest point). This method is meant to be used when a good approximate solution for the projection is available. Throws InvalidOperationException if the projection fails. (Inherited from Surface.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Surface.)
Public property | OrientationMatchesParametricOrientation | Indicates whether this Surface's orientation is the same as or opposite to its parametric orientation. (Inherited from Surface.)

See Also

RuledSurface Class


RuledSurface Methods

[image] [image]

Revit 2024 API
RuledSurface Methods
RuledSurface Class See Also Send Feedback

The RuledSurface type exposes the following members.

Methods

 | Name | Description
 | Create(Curve, Curve) | Creates a Surface object coincident with the ruled surface joining two bounded generating curves.
 | Create(Curve, XYZ) | Creates a Surface object coincident with the ruled surface joining a bounded generating curve to a point.
Public method | Dispose | (Inherited from Surface.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBoundingBoxUV | Gets the UV bounding box of the surface. (Inherited from Surface.)
Public method | GetFirstProfileCurve | Returns a copy of the first profile curve if it is set.
Public method | GetFirstProfilePoint | If a point was used to define the first profile, returns a copy of that point.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSecondProfileCurve | Returns a copy of the second profile curve if it is set.
Public method | GetSecondProfilePoint | If a point was used to define the second profile, returns a copy of that point.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasFirstProfilePoint | Checks if a point was used to define the first profile.
Public method | HasSecondProfilePoint | Checks if a point was used to define the second profile.
Public method | Project | Project a 3D point orthogonally onto a surface (to find the nearest point). Throws InvalidOperationException if the projection fails. (Inherited from Surface.)
Public method | ProjectWithGuessPoint | Project a 3D point orthogonally onto a surface (to find the nearest point). This method is meant to be used when a good approximate solution for the projection is available. Throws InvalidOperationException if the projection fails. (Inherited from Surface.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RuledSurface Class


Create Method

[image] [image]

Revit 2024 API
RuledSurface..::..Create Method
RuledSurface Class See Also Send Feedback

Overload List

Name | Description
Create(Curve, Curve) | Creates a Surface object coincident with the ruled surface joining two bounded generating curves.
Create(Curve, XYZ) | Creates a Surface object coincident with the ruled surface joining a bounded generating curve to a point.

See Also

RuledSurface Class
RuledSurface Members


Create Method (Curve, Curve)

[image]

Revit 2024 API
RuledSurface..::..Create Method (Curve, Curve)
RuledSurface Class See Also Send Feedback
Creates a Surface object coincident with the ruled surface joining two bounded generating curves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public static Surface Create(
    Curve profileCurve1,
    Curve profileCurve2
)
Visual Basic
Public Shared Function Create ( _
    profileCurve1 As Curve, _
    profileCurve2 As Curve _
) As Surface
Visual C++
public:
static Surface^ Create(
    Curve^ profileCurve1,
    Curve^ profileCurve2
)

Parameters

profileCurve1
Type: Autodesk.Revit.DB..::..Curve
The first profile curve; must be bounded and non-degenerate.
profileCurve2
Type: Autodesk.Revit.DB..::..Curve
The second profile curve; must be bounded and non-degenerate.

Return Value

The created surface. Note that this surface may not be of type RuledSurf.

Remarks

The returned surface may not be of type RuledSurf - this function will create a surface of the simplest possible type (Plane, CylindricalSurface, etc.) that can be used to represent the given ruled surface. Given that the surface may be simplified, this function does not guarantee any particular parameterization of the surface. The curves should be such that a ruled surface whose rulings connect points on the two curves with the same normalized coordinates has no self-intersections or interior singularities.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input profileCurve1 is not bound. -or- The profileCurve1 is degenerate (its length is too close to zero). -or- The input profileCurve2 is not bound. -or- The profileCurve2 is degenerate (its length is too close to zero).
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

RuledSurface Class
Create Overload


Create Method (Curve, XYZ)

[image]

Revit 2024 API
RuledSurface..::..Create Method (Curve, XYZ)
RuledSurface Class See Also Send Feedback
Creates a Surface object coincident with the ruled surface joining a bounded generating curve to a point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public static Surface Create(
    Curve profileCurve,
    XYZ point
)
Visual Basic
Public Shared Function Create ( _
    profileCurve As Curve, _
    point As XYZ _
) As Surface
Visual C++
public:
static Surface^ Create(
    Curve^ profileCurve,
    XYZ^ point
)

Parameters

profileCurve
Type: Autodesk.Revit.DB..::..Curve
The profile curve; must be bounded and non-degenerate.
point
Type: Autodesk.Revit.DB..::..XYZ
The point. Expected to lie within the Revit design limits IsWithinLengthLimits(XYZ).

Return Value

The created surface. Note that this surface may not be of type RuledSurf.

Remarks

The returned surface may not be of type RuledSurf - this function will create a surface of the simplest possible type (Plane, CylindricalSurface, etc.) that can be used to represent the given ruled surface. Given that the surface may be simplified, this function does not guarantee any particular parameterization of the surface.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input profileCurve is not bound. -or- The profileCurve is degenerate (its length is too close to zero). -or- The input point lies outside of Revit design limits.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

RuledSurface Class
Create Overload


GetFirstProfilePoint Method

[image]

Revit 2024 API
RuledSurface..::..GetFirstProfilePoint Method
RuledSurface Class See Also Send Feedback
If a point was used to define the first profile, returns a copy of that point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public XYZ GetFirstProfilePoint()
Visual Basic
Public Function GetFirstProfilePoint As XYZ
Visual C++
public:
XYZ^ GetFirstProfilePoint()

Return Value

The first profile point if it was set.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This surface element does not use a point to define the first profile.

See Also

RuledSurface Class


GetSecondProfilePoint Method

[image]

Revit 2024 API
RuledSurface..::..GetSecondProfilePoint Method
RuledSurface Class See Also Send Feedback
If a point was used to define the second profile, returns a copy of that point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public XYZ GetSecondProfilePoint()
Visual Basic
Public Function GetSecondProfilePoint As XYZ
Visual C++
public:
XYZ^ GetSecondProfilePoint()

Return Value

The second profile point if it was set.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This surface element does not use a point to define the second profile.

See Also

RuledSurface Class


HasSecondProfilePoint Method

[image]

Revit 2024 API
RuledSurface..::..HasSecondProfilePoint Method
RuledSurface Class See Also Send Feedback
Checks if a point was used to define the second profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public bool HasSecondProfilePoint()
Visual Basic
Public Function HasSecondProfilePoint As Boolean
Visual C++
public:
bool HasSecondProfilePoint()

Return Value

True if a point was used to define the second profile, false otherwise.

See Also

RuledSurface Class


RuledSurface Properties

[image] [image]

Revit 2024 API
RuledSurface Properties
RuledSurface Class See Also Send Feedback

The RuledSurface type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Surface.)
Public property | OrientationMatchesParametricOrientation | Indicates whether this Surface's orientation is the same as or opposite to its parametric orientation. (Inherited from Surface.)

See Also

RuledSurface Class


SATExportOptions Class

[image]

Revit 2024 API
SATExportOptions Class
Members See Also Send Feedback
The export options used by exporting SAT format file. So far, there is no option in it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class SATExportOptions : IDisposable
Visual Basic
Public Class SATExportOptions _
    Implements IDisposable
Visual C++
public ref class SATExportOptions : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..SATExportOptions

See Also

SATExportOptions Members


SATExportOptions Members

[image] [image]

Revit 2024 API
SATExportOptions Members
SATExportOptions Class Constructors Methods Properties See Also Send Feedback

The SATExportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | SATExportOptions()()()() | Constructs a new instance of SATImportOptions with default values of all properties.
Public method | SATExportOptions(SATExportOptions) | Constructs a new instance of SATImportOptions as a copy of the export options.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the SATExportOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

SATExportOptions Class


SATExportOptions Constructor

[image] [image]

Revit 2024 API
SATExportOptions Constructor
SATExportOptions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SATExportOptions()()()() | Constructs a new instance of SATImportOptions with default values of all properties.
Public method | SATExportOptions(SATExportOptions) | Constructs a new instance of SATImportOptions as a copy of the export options.

See Also

SATExportOptions Class
SATExportOptions Members


SATExportOptions Constructor

[image]

Revit 2024 API
SATExportOptions Constructor
SATExportOptions Class See Also Send Feedback
Constructs a new instance of SATImportOptions with default values of all properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public SATExportOptions()
Visual Basic
Public Sub New
Visual C++
public:
SATExportOptions()

See Also

SATExportOptions Class
SATExportOptions Overload


SATExportOptions Constructor (SATExportOptions)

[image]

Revit 2024 API
SATExportOptions Constructor (SATExportOptions)
SATExportOptions Class See Also Send Feedback
Constructs a new instance of SATImportOptions as a copy of the export options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public SATExportOptions(
    SATExportOptions option
)
Visual Basic
Public Sub New ( _
    option As SATExportOptions _
)
Visual C++
public:
SATExportOptions(
    SATExportOptions^ option
)

Parameters

option
Type: Autodesk.Revit.DB..::..SATExportOptions
The options to be copied.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

SATExportOptions Class
SATExportOptions Overload


SATExportOptions Methods

[image] [image]

Revit 2024 API
SATExportOptions Methods
SATExportOptions Class See Also Send Feedback

The SATExportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SATExportOptions Class


Dispose Method

[image]

Revit 2024 API
SATExportOptions..::..Dispose Method
SATExportOptions Class See Also Send Feedback
Releases all resources used by the SATExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

SATExportOptions Class


SATExportOptions Properties

[image] [image]

Revit 2024 API
SATExportOptions Properties
SATExportOptions Class See Also Send Feedback

The SATExportOptions type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

SATExportOptions Class


IsValidObject Property

[image]

Revit 2024 API
SATExportOptions..::..IsValidObject Property
SATExportOptions Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

SATExportOptions Class


SATImportOptions Class

[image]

Revit 2024 API
SATImportOptions Class
Members See Also Send Feedback
The import options used to import SAT format files.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class SATImportOptions : BaseImportOptions
Visual Basic
Public Class SATImportOptions _
    Inherits BaseImportOptions
Visual C++
public ref class SATImportOptions : public BaseImportOptions

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BaseImportOptions
Autodesk.Revit.DB..::..SATImportOptions

See Also

SATImportOptions Members


SATImportOptions Members

[image] [image]

Revit 2024 API
SATImportOptions Members
SATImportOptions Class Constructors Methods Properties See Also Send Feedback

The SATImportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | SATImportOptions()()()() | Constructs a new instance of SATImportOptions with default values of all properties.
Public method | SATImportOptions(SATImportOptions) | Constructs a new instance of SATImportOptions as a copy of the import options.

Methods

 | Name | Description
Public method | Dispose | (Inherited from BaseImportOptions.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDefaultLengthUnit | Get the default length unit used for importing unitless files. (Inherited from BaseImportOptions.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLayerSelection | Get all set layers name which user want to import into Revit. (Inherited from BaseImportOptions.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultLengthUnit | Set the default length unit used for importing unitless files. (Inherited from BaseImportOptions.)
Public method | SetLayerSelection | Set the layers name which user want to import into Revit. (Inherited from BaseImportOptions.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AutoCorrectAlmostVHLines | Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines. (Inherited from BaseImportOptions.)
Public property | ColorMode | Color mode for the import. Three modes are supported. Black and White, Preserve Colors, and Invert Colors. (Inherited from BaseImportOptions.)
Public property | CustomScale | Scaling the import. If this is defined and a valid value (> 0.0), it takes priority over units. (Inherited from BaseImportOptions.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BaseImportOptions.)
Public property | OrientToView | Place the import at the same orientation as the view that was passed into the import method. This option can only be used when not importing into a single view.(i.e. ThisViewOnly is set to false) (Inherited from BaseImportOptions.)
Public property | Placement | Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates. (Inherited from BaseImportOptions.)
Public property | ReferencePoint | The 3D point in the document where the imported instance will be inserted. If not explicitly set, the instance will be inserted at the document origin. (Inherited from BaseImportOptions.)
Public property | ThisViewOnly | Imports drawings into the view that was passed into the import method. This option is not available in 3D views. (Inherited from BaseImportOptions.)
Public property | Unit | The unit of measure for imported geometry. (Inherited from BaseImportOptions.)
Public property | VisibleLayersOnly | Only import the visible layers. (Inherited from BaseImportOptions.)

See Also

SATImportOptions Class


SATImportOptions Constructor

[image] [image]

Revit 2024 API
SATImportOptions Constructor
SATImportOptions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SATImportOptions()()()() | Constructs a new instance of SATImportOptions with default values of all properties.
Public method | SATImportOptions(SATImportOptions) | Constructs a new instance of SATImportOptions as a copy of the import options.

See Also

SATImportOptions Class
SATImportOptions Members


SATImportOptions Constructor

[image]

Revit 2024 API
SATImportOptions Constructor
SATImportOptions Class See Also Send Feedback
Constructs a new instance of SATImportOptions with default values of all properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public SATImportOptions()
Visual Basic
Public Sub New
Visual C++
public:
SATImportOptions()

See Also

SATImportOptions Class
SATImportOptions Overload


SATImportOptions Constructor (SATImportOptions)

[image]

Revit 2024 API
SATImportOptions Constructor (SATImportOptions)
SATImportOptions Class See Also Send Feedback
Constructs a new instance of SATImportOptions as a copy of the import options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public SATImportOptions(
    SATImportOptions option
)
Visual Basic
Public Sub New ( _
    option As SATImportOptions _
)
Visual C++
public:
SATImportOptions(
    SATImportOptions^ option
)

Parameters

option
Type: Autodesk.Revit.DB..::..SATImportOptions
The SAT options to be copied.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

SATImportOptions Class
SATImportOptions Overload


SATImportOptions Methods

[image] [image]

Revit 2024 API
SATImportOptions Methods
SATImportOptions Class See Also Send Feedback

The SATImportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from BaseImportOptions.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDefaultLengthUnit | Get the default length unit used for importing unitless files. (Inherited from BaseImportOptions.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLayerSelection | Get all set layers name which user want to import into Revit. (Inherited from BaseImportOptions.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultLengthUnit | Set the default length unit used for importing unitless files. (Inherited from BaseImportOptions.)
Public method | SetLayerSelection | Set the layers name which user want to import into Revit. (Inherited from BaseImportOptions.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SATImportOptions Class


SaveAsOptions Members

[image] [image]

Revit 2024 API
SaveAsOptions Members
SaveAsOptions Class Constructors Methods Properties See Also Send Feedback

The SaveAsOptions type exposes the following members.

Constructors

 | Name | Description
Public method | SaveAsOptions | Default constructor.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the SaveAsOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWorksharingOptions | Gets Worksharing options for SaveAs.
Public method | SetWorksharingOptions | Sets Worksharing options for SaveAs.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Compact | Default is false: let the OS eliminate as much or as little dead data as it wants to. True: force the OS to eliminate all dead data from the file on disk.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MaximumBackups | The maximum number of backups to keep on disk.
Public property | OverwriteExistingFile | Identifies if the operation should be able to overwrite an existing file.
Public property | PreviewViewId | The view id that will be used to generate the preview; this id is not saved to the document's permanent settings.

See Also

SaveAsOptions Class


SaveAsOptions Constructor

[image]

Revit 2024 API
SaveAsOptions Constructor
SaveAsOptions Class See Also Send Feedback
Default constructor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public SaveAsOptions()
Visual Basic
Public Sub New
Visual C++
public:
SaveAsOptions()

See Also

SaveAsOptions Class


SaveAsOptions Methods

[image] [image]

Revit 2024 API
SaveAsOptions Methods
SaveAsOptions Class See Also Send Feedback

The SaveAsOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWorksharingOptions | Gets Worksharing options for SaveAs.
Public method | SetWorksharingOptions | Sets Worksharing options for SaveAs.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SaveAsOptions Class


Dispose Method

[image]

Revit 2024 API
SaveAsOptions..::..Dispose Method
SaveAsOptions Class See Also Send Feedback
Releases all resources used by the SaveAsOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

SaveAsOptions Class


GetWorksharingOptions Method

[image]

Revit 2024 API
SaveAsOptions..::..GetWorksharingOptions Method
SaveAsOptions Class See Also Send Feedback
Gets Worksharing options for SaveAs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public WorksharingSaveAsOptions GetWorksharingOptions()
Visual Basic
Public Function GetWorksharingOptions As WorksharingSaveAsOptions
Visual C++
public:
WorksharingSaveAsOptions^ GetWorksharingOptions()

Return Value

Defaults to nullNothingnullptra null reference (Nothing in Visual Basic). For a workshared model, if nullNothingnullptra null reference (Nothing in Visual Basic) default values for WorksharingSaveAsOptions are used.

See Also

SaveAsOptions Class


SetWorksharingOptions Method

[image]

Revit 2024 API
SaveAsOptions..::..SetWorksharingOptions Method
SaveAsOptions Class See Also Send Feedback
Sets Worksharing options for SaveAs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void SetWorksharingOptions(
    WorksharingSaveAsOptions worksharingOptions
)
Visual Basic
Public Sub SetWorksharingOptions ( _
    worksharingOptions As WorksharingSaveAsOptions _
)
Visual C++
public:
void SetWorksharingOptions(
    WorksharingSaveAsOptions^ worksharingOptions
)

Parameters

worksharingOptions
Type: Autodesk.Revit.DB..::..WorksharingSaveAsOptions

Must be nullNothingnullptra null reference (Nothing in Visual Basic) for a non-workshared model.

Allowed to be nullNothingnullptra null reference (Nothing in Visual Basic) for a workshared model, in which case default values for WorksharingSaveAsOptions are used.

See Also

SaveAsOptions Class


SaveAsOptions Properties

[image] [image]

Revit 2024 API
SaveAsOptions Properties
SaveAsOptions Class See Also Send Feedback

The SaveAsOptions type exposes the following members.

Properties

 | Name | Description
Public property | Compact | Default is false: let the OS eliminate as much or as little dead data as it wants to. True: force the OS to eliminate all dead data from the file on disk.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MaximumBackups | The maximum number of backups to keep on disk.
Public property | OverwriteExistingFile | Identifies if the operation should be able to overwrite an existing file.
Public property | PreviewViewId | The view id that will be used to generate the preview; this id is not saved to the document's permanent settings.

See Also

SaveAsOptions Class


Compact Property

[image]

Revit 2024 API
SaveAsOptions..::..Compact Property
SaveAsOptions Class See Also Send Feedback
Default is false: let the OS eliminate as much or as little dead data as it wants to. True: force the OS to eliminate all dead data from the file on disk.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool Compact { get; set; }
Visual Basic
Public Property Compact As Boolean
    Get
    Set
Visual C++
public:
property bool Compact {
    bool get ();
    void set (bool value);
}

See Also

SaveAsOptions Class


IsValidObject Property

[image]

Revit 2024 API
SaveAsOptions..::..IsValidObject Property
SaveAsOptions Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

SaveAsOptions Class


MaximumBackups Property

[image]

Revit 2024 API
SaveAsOptions..::..MaximumBackups Property
SaveAsOptions Class See Also Send Feedback
The maximum number of backups to keep on disk.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public int MaximumBackups { get; set; }
Visual Basic
Public Property MaximumBackups As Integer
    Get
    Set
Visual C++
public:
property int MaximumBackups {
    int get ();
    void set (int value);
}

Field Value

A positive number means to keep at most that many backups.

The default value of -1 means to use Revit's defaults: 3 for non-workshared, 20 for workshared. After initialization, the setter can be used to choose a positive number, but cannot be used to restore this default value.

Remarks

Non-workshared models have whole-file backups, sequentially numbered.

File-based workshared models have eager, incremental backups in a backup folder adjacent to the model itself: Every save backs up all changed data and avoids recopying unchanged elements, so the latest backup is equivalent to the main copy on disk and the backup folder does not have huge amounts of redundant data.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The requested number of backups is out of range.

See Also

SaveAsOptions Class


OverwriteExistingFile Property

[image]

Revit 2024 API
SaveAsOptions..::..OverwriteExistingFile Property
SaveAsOptions Class See Also Send Feedback
Identifies if the operation should be able to overwrite an existing file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public bool OverwriteExistingFile { get; set; }
Visual Basic
Public Property OverwriteExistingFile As Boolean
    Get
    Set
Visual C++
public:
property bool OverwriteExistingFile {
    bool get ();
    void set (bool value);
}

Field Value

True if the SaveAs operation should silently overwrite an existing target file, if it exists. False if the operation should fail if there is already a file at the target location. Default is false.

See Also

SaveAsOptions Class


SaveModifiedLinksOptions Enumeration

[image]

Revit 2024 API
SaveModifiedLinksOptions Enumeration
See Also Send Feedback
Class giving options when saving linked files which have been modified in-memory by shared coordinates operations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014
Since: 2014

Syntax

C#
public enum SaveModifiedLinksOptions
Visual Basic
Public Enumeration SaveModifiedLinksOptions
Visual C++
public enum class SaveModifiedLinksOptions

Members

Member name | Description
SaveLinks | Any modified linked files will be saved.
DoNotSaveLinks | Any modified linked files will not be saved. The links will return to their previous position the next time the file is loaded.
DisableSharedPositioning | Any modified linked files will not be saved. Additionally, stop using shared positioning with any modified files.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


SaveModifiedLinksOptionsForUnloadLocally Enumeration

[image]

Revit 2024 API
SaveModifiedLinksOptionsForUnloadLocally Enumeration
See Also Send Feedback
Class giving options when saving linked files which are unloaded locally and have been modified in-memory by shared coordinates operations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017
Since: 2017

Syntax

C#
public enum SaveModifiedLinksOptionsForUnloadLocally
Visual Basic
Public Enumeration SaveModifiedLinksOptionsForUnloadLocally
Visual C++
public enum class SaveModifiedLinksOptionsForUnloadLocally

Members

Member name | Description
SaveLinks | Any modified linked files will be saved.
DoNotSaveLinks | Any modified linked files will not be saved. The links will return to their previous position the next time the file is loaded.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


SaveOptions Class

[image]

Revit 2024 API
SaveOptions Class
Members See Also Send Feedback
This class contains options available for saving a document to disk.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public class SaveOptions : IDisposable
Visual Basic
Public Class SaveOptions _
    Implements IDisposable
Visual C++
public ref class SaveOptions : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..SaveOptions

See Also

SaveOptions Members


SaveOptions Members

[image] [image]

Revit 2024 API
SaveOptions Members
SaveOptions Class Constructors Methods Properties See Also Send Feedback

The SaveOptions type exposes the following members.

Constructors

 | Name | Description
Public method | SaveOptions | Default constructor.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the SaveOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Compact | Default is false: let the OS eliminate as much or as little dead data as it wants to. True: force the OS to eliminate all dead data from the file on disk.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | PreviewViewId | The view id that will be used to generate the preview; this id is not saved to the document's permanent settings.

See Also

SaveOptions Class


SaveOptions Constructor

[image]

Revit 2024 API
SaveOptions Constructor
SaveOptions Class See Also Send Feedback
Default constructor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public SaveOptions()
Visual Basic
Public Sub New
Visual C++
public:
SaveOptions()

Remarks

PreviewViewId will be InvalidElementId.

See Also

SaveOptions Class


Dispose Method

[image]

Revit 2024 API
SaveOptions..::..Dispose Method
SaveOptions Class See Also Send Feedback
Releases all resources used by the SaveOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

SaveOptions Class


SaveOptions Properties

[image] [image]

Revit 2024 API
SaveOptions Properties
SaveOptions Class See Also Send Feedback

The SaveOptions type exposes the following members.

Properties

 | Name | Description
Public property | Compact | Default is false: let the OS eliminate as much or as little dead data as it wants to. True: force the OS to eliminate all dead data from the file on disk.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | PreviewViewId | The view id that will be used to generate the preview; this id is not saved to the document's permanent settings.

See Also

SaveOptions Class


Compact Property

[image]

Revit 2024 API
SaveOptions..::..Compact Property
SaveOptions Class See Also Send Feedback
Default is false: let the OS eliminate as much or as little dead data as it wants to. True: force the OS to eliminate all dead data from the file on disk.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool Compact { get; set; }
Visual Basic
Public Property Compact As Boolean
    Get
    Set
Visual C++
public:
property bool Compact {
    bool get ();
    void set (bool value);
}

See Also

SaveOptions Class


IsValidObject Property

[image]

Revit 2024 API
SaveOptions..::..IsValidObject Property
SaveOptions Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

SaveOptions Class


PreviewViewId Property

[image]

Revit 2024 API
SaveOptions..::..PreviewViewId Property
SaveOptions Class See Also Send Feedback
The view id that will be used to generate the preview; this id is not saved to the document's permanent settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public ElementId PreviewViewId { get; set; }
Visual Basic
Public Property PreviewViewId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ PreviewViewId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Field Value

The id must be valid for use as a preview view (check DocumentPreviewSettings.IsViewIdValidForPreview()). Revit does not check validity when setting this value, only when the options are used in a call to SaveAs().

Remarks

If this id is set, the indicated view will be used to generate the preview even if DocumentPreviewSettings.PreviewViewId is also set.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

SaveOptions Class


SchedulableField Class

[image]

Revit 2024 API
SchedulableField Class
Members See Also Send Feedback
A non-calculated field eligible to be included in a schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public class SchedulableField : IDisposable
Visual Basic
Public Class SchedulableField _
    Implements IDisposable
Visual C++
public ref class SchedulableField : IDisposable

Remarks

The SchedulableField class represents a non-calculated field that is eligible to be included in a schedule. A list of fields that can be included in a schedule can be obtained from ScheduleDefinition.GetSchedulableFields.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..SchedulableField

See Also

SchedulableField Members


SchedulableField Members

[image] [image]

Revit 2024 API
SchedulableField Members
SchedulableField Class Constructors Methods Operators Properties See Also Send Feedback

The SchedulableField type exposes the following members.

Constructors

 | Name | Description
Public method | SchedulableField()()()() | Creates a new SchedulableField.
Public method | SchedulableField(Guid) | Creates a new SchedulableField.
Public method | SchedulableField(ScheduleFieldType) | Creates a new SchedulableField.
Public method | SchedulableField(ScheduleFieldType, ElementId) | Creates a new SchedulableField.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the SchedulableField
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | GetCustomFieldData | Gets the data associated with this custom field. If this field isn't a CustomField will return nullNothingnullptra null reference (Nothing in Visual Basic).
Public method | GetHashCode | Gets the integer value of the SchedulableField as hash code (Overrides Object..::..GetHashCode()()()().)
Public method | GetName | Gets the name of the field.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Operators

Name | Description
Equality | Determines whether two SchedulableField are the same.
Inequality | Determines whether two SchedulableField are different.

Properties

 | Name | Description
Public property | FieldType | The type of data displayed by the field.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ParameterId | The ID of the parameter displayed by the field.

See Also

SchedulableField Class


SchedulableField Constructor

[image] [image]

Revit 2024 API
SchedulableField Constructor
SchedulableField Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SchedulableField()()()() | Creates a new SchedulableField.
Public method | SchedulableField(Guid) | Creates a new SchedulableField.
Public method | SchedulableField(ScheduleFieldType) | Creates a new SchedulableField.
Public method | SchedulableField(ScheduleFieldType, ElementId) | Creates a new SchedulableField.

See Also

SchedulableField Class
SchedulableField Members


SchedulableField Constructor

[image]

Revit 2024 API
SchedulableField Constructor
SchedulableField Class See Also Send Feedback
Creates a new SchedulableField.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public SchedulableField()
Visual Basic
Public Sub New
Visual C++
public:
SchedulableField()

See Also

SchedulableField Class
SchedulableField Overload


SchedulableField Constructor (Guid)

[image]

Revit 2024 API
SchedulableField Constructor (Guid)
SchedulableField Class See Also Send Feedback
Creates a new SchedulableField.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public SchedulableField(
    Guid customFieldId
)
Visual Basic
Public Sub New ( _
    customFieldId As Guid _
)
Visual C++
public:
SchedulableField(
    Guid customFieldId
)

Parameters

customFieldId
Type: System..::..Guid
The Guid that identifies the custom field.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The provided guid doens't represent a valid custom field.

See Also

SchedulableField Class
SchedulableField Overload


SchedulableField Constructor (ScheduleFieldType, ElementId)

[image]

Revit 2024 API
SchedulableField Constructor (ScheduleFieldType, ElementId)
SchedulableField Class See Also Send Feedback
Creates a new SchedulableField.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public SchedulableField(
    ScheduleFieldType fieldType,
    ElementId parameterId
)
Visual Basic
Public Sub New ( _
    fieldType As ScheduleFieldType, _
    parameterId As ElementId _
)
Visual C++
public:
SchedulableField(
    ScheduleFieldType fieldType,
    ElementId^ parameterId
)

Parameters

fieldType
Type: Autodesk.Revit.DB..::..ScheduleFieldType
The type of data displayed by the field.
parameterId
Type: Autodesk.Revit.DB..::..ElementId
The ID of the parameter displayed by the field.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | fieldType is not a schedulable field type -or- The fieldType can't be CustomField. To create a CustomField, you should use the constructor which receives the custom field server id as a parameter.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

SchedulableField Class
SchedulableField Overload


SchedulableField Methods

[image] [image]

Revit 2024 API
SchedulableField Methods
SchedulableField Class See Also Send Feedback

The SchedulableField type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | GetCustomFieldData | Gets the data associated with this custom field. If this field isn't a CustomField will return nullNothingnullptra null reference (Nothing in Visual Basic).
Public method | GetHashCode | Gets the integer value of the SchedulableField as hash code (Overrides Object..::..GetHashCode()()()().)
Public method | GetName | Gets the name of the field.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SchedulableField Class


Dispose Method

[image]

Revit 2024 API
SchedulableField..::..Dispose Method
SchedulableField Class See Also Send Feedback
Releases all resources used by the SchedulableField

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

SchedulableField Class


Equals Method

[image]

Revit 2024 API
SchedulableField..::..Equals Method
SchedulableField Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
The other object to evaluate.

See Also

SchedulableField Class


GetCustomFieldData Method

[image]

Revit 2024 API
SchedulableField..::..GetCustomFieldData Method
SchedulableField Class See Also Send Feedback
Gets the data associated with this custom field. If this field isn't a CustomField will return nullNothingnullptra null reference (Nothing in Visual Basic).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public CustomFieldData GetCustomFieldData()
Visual Basic
Public Function GetCustomFieldData As CustomFieldData
Visual C++
public:
CustomFieldData^ GetCustomFieldData()

Return Value

Returns the data associated with this custom field. If this field isn't a CustomField will return nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

SchedulableField Class


GetHashCode Method

[image]

Revit 2024 API
SchedulableField..::..GetHashCode Method
SchedulableField Class See Also Send Feedback
Gets the integer value of the SchedulableField as hash code

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

SchedulableField Class


GetName Method

[image]

Revit 2024 API
SchedulableField..::..GetName Method
SchedulableField Class See Also Send Feedback
Gets the name of the field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public string GetName(
    Document document
)
Visual Basic
Public Function GetName ( _
    document As Document _
) As String
Visual C++
public:
String^ GetName(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which the field will be used.

Return Value

The name of the field.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The parameter doesn't exist in document.

See Also

SchedulableField Class


SchedulableField Operators

[image] [image]

Revit 2024 API
SchedulableField Operators
SchedulableField Class See Also Send Feedback

The SchedulableField type exposes the following members.

Operators

Name | Description
Equality | Determines whether two SchedulableField are the same.
Inequality | Determines whether two SchedulableField are different.

See Also

SchedulableField Class


Equality Operator

[image]

Revit 2024 API
SchedulableField..::..Equality Operator
SchedulableField Class See Also Send Feedback
Determines whether two SchedulableField are the same.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static bool operator ==(
    SchedulableField first,
    SchedulableField second
)
Visual Basic
Public Shared Operator = ( _
    first As SchedulableField, _
    second As SchedulableField _
) As Boolean
Visual C++
public:
static bool operator ==(
    SchedulableField^ first,
    SchedulableField^ second
)

Parameters

first
Type: Autodesk.Revit.DB..::..SchedulableField
The first SchedulableField.
second
Type: Autodesk.Revit.DB..::..SchedulableField
The second SchedulableField.

Return Value

True if the SchedulableField are the same, otherwise false.

See Also

SchedulableField Class


Inequality Operator

[image]

Revit 2024 API
SchedulableField..::..Inequality Operator
SchedulableField Class See Also Send Feedback
Determines whether two SchedulableField are different.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static bool operator !=(
    SchedulableField first,
    SchedulableField second
)
Visual Basic
Public Shared Operator <> ( _
    first As SchedulableField, _
    second As SchedulableField _
) As Boolean
Visual C++
public:
static bool operator !=(
    SchedulableField^ first,
    SchedulableField^ second
)

Parameters

first
Type: Autodesk.Revit.DB..::..SchedulableField
The first SchedulableField.
second
Type: Autodesk.Revit.DB..::..SchedulableField
The second SchedulableField.

Return Value

True if the SchedulableField are different, otherwise false.

See Also

SchedulableField Class


FieldType Property

[image]

Revit 2024 API
SchedulableField..::..FieldType Property
SchedulableField Class See Also Send Feedback
The type of data displayed by the field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ScheduleFieldType FieldType { get; set; }
Visual Basic
Public Property FieldType As ScheduleFieldType
    Get
    Set
Visual C++
public:
property ScheduleFieldType FieldType {
    ScheduleFieldType get ();
    void set (ScheduleFieldType value);
}

Field Value

See ScheduleFieldType for details.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: fieldType is not a schedulable field type
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

SchedulableField Class


ParameterId Property

[image]

Revit 2024 API
SchedulableField..::..ParameterId Property
SchedulableField Class See Also Send Feedback
The ID of the parameter displayed by the field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ElementId ParameterId { get; set; }
Visual Basic
Public Property ParameterId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ ParameterId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Field Value

The parameter ID, or InvalidElementId.

Remarks

Most non-calculated field types require a parameter ID. The Count field doesn't have a parameter ID.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

SchedulableField Class


ScheduleDefinition Class

[image]

Revit 2024 API
ScheduleDefinition Class
Members See Also Send Feedback
Settings that define the contents of a schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public class ScheduleDefinition : IDisposable
Visual Basic
Public Class ScheduleDefinition _
    Implements IDisposable
Visual C++
public ref class ScheduleDefinition : IDisposable

Remarks

The ScheduleDefinition class contains various settings that define the contents of a schedule view, including:

  • The schedule's category and other basic properties that determine the type of schedule.
  • A set of fields that become the columns of the schedule.
  • Filters that restrict the set of elements visible in the schedule.
  • Sorting and grouping criteria.

Most schedules contain a single ScheduleDefinition. In Revit MEP, schedules of certain categories can contain an "embedded schedule" containing elements associated with the elements in the primary schedule, for example a room schedule showing the elements inside each room or a duct system schedule showing the elements associated with each system. An embedded schedule has its own category, fields, filters, etc. Those settings are stored in a second ScheduleDefinition object.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ScheduleDefinition

See Also

ScheduleDefinition Members


ScheduleDefinition Members

[image] [image]

Revit 2024 API
ScheduleDefinition Members
ScheduleDefinition Class Methods Properties See Also Send Feedback

The ScheduleDefinition type exposes the following members.

Methods

 | Name | Description
Public method | AddEmbeddedSchedule | Adds an embedded ScheduleDefinition.
Public method | AddField(SchedulableField) | Adds a regular field at the end of the list.
Public method | AddField(ScheduleFieldType) | Adds a regular field at the end of the list.
Public method | AddField(ScheduleFieldType, ElementId) | Adds a regular field at the end of the list.
Public method | AddFilter | Adds a new filter at the end of the list.
Public method | AddSortGroupField | Adds a new sorting/grouping field at the end of the list.
Public method | CanFilter | Checks whether filters can be added to this ScheduleDefinition.
Public method | CanFilterByGlobalParameters | Checks whether a field can be used with a global parameter-based filter.
Public method | CanFilterByParameterExistence | Checks whether a field can be used with a HasParameter filter.
Public method | CanFilterBySubstring | Checks whether a field can be used with a substring-based filter.
Public method | CanFilterByValue | Checks whether a field can be used with a value-based filter.
Public method | CanFilterByValuePresence | Checks whether a field can be used with a value presence-based filter.
Public method | CanHaveEmbeddedSchedule | Indicates if this ScheduleDefinition can have an embedded ScheduleDefinition added.
Public method | CanIncludeLinkedFiles | Checks whether the schedule is a type that supports including elements from linked files.
Public method | CanSortByField | Checks whether a field can be used for sorting/grouping.
Public method | ClearFields | Removes all fields.
Public method | ClearFilters | Removes all filters.
Public method | ClearSortGroupFields | Removes all sorting/grouping fields.
Public method | Dispose | Releases all resources used by the ScheduleDefinition
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetField(Int32) | Gets a field.
Public method | GetField(ScheduleFieldId) | Gets a field.
Public method | GetFieldCount | Gets the number of fields in this ScheduleDefinition.
Public method | GetFieldId | Converts a field index to the corresponding field ID.
Public method | GetFieldIndex | Converts a field ID to the corresponding field index.
Public method | GetFieldOrder | Gets the IDs of the current list of fields in order.
Public method | GetFilter | Gets a filter.
Public method | GetFilterCount | Gets the number of filters in this ScheduleDefinition.
Public method | GetFilters | Gets all filters in this ScheduleDefinition.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSchedulableFields | Gets a list of all non-calculated/non-combined fields that are eligible to be included in this schedule.
Public method | GetSortGroupField | Gets a sorting/grouping field.
Public method | GetSortGroupFieldCount | Gets the number of sorting/grouping fields in this ScheduleDefinition.
Public method | GetSortGroupFields | Gets all sorting/grouping fields in this ScheduleDefinition.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidCategoriesForEmbeddedSchedule | Get all categories that can be used for an embedded ScheduleDefinition in this ScheduleDefinition.
Public method | InsertCombinedParameterField | Adds a combined parameter field at the specified position in the list.
Public method | InsertField(SchedulableField, Int32) | Adds a regular field at the specified position in the list.
Public method | InsertField(ScheduleFieldType, Int32) | Adds a regular field at the specified position in the list.
Public method | InsertField(ScheduleFieldType, ElementId, Int32) | Adds a regular field at the specified position in the list.
Public method | InsertFilter | Adds a new filter at the specified position in the list.
Public method | InsertSortGroupField | Adds a new sorting/grouping field at the specified position in the list.
Public method | IsSchedulableField | Checks whether a non-calculated/non-combined field is eligible to be included in this schedule.
Public method | IsValidCategoryForEmbeddedSchedule | Indicates if a category can be used for an embedded ScheduleDefinition in this ScheduleDefinition.
Public method | IsValidCategoryForFilterBySheet | Checks whether a schedule can be filtered by sheet.
Public method | IsValidCombinedParameters | Checks if data is valid for combined parameters
Public method | IsValidFieldId | Checks whether a ScheduleFieldId is the ID of a field in this ScheduleDefinition.
Public method | IsValidFieldIndex | Checks whether an integer is a valid zero-based field index in this ScheduleDefinition.
Public method | RemoveEmbeddedSchedule | Removes the embedded ScheduleDefinition.
Public method | RemoveField(Int32) | Removes a field.
Public method | RemoveField(ScheduleFieldId) | Removes a field.
Public method | RemoveFilter | Removes a filter.
Public method | RemoveSortGroupField | Removes a sorting/grouping field.
Public method | SetFieldOrder | Reorders the fields in the schedule.
Public method | SetFilter | Replaces a filter.
Public method | SetFilters | Replaces all filters in this ScheduleDefinition.
Public method | SetSortGroupField | Replaces a sorting/grouping field.
Public method | SetSortGroupFields | Replaces all sorting/grouping fields in this ScheduleDefinition.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AreaSchemeId | In an area schedule, the ID of the area scheme to display.
Public property | CategoryId | The category ID of elements appearing in the schedule.
Public property | EmbeddedDefinition | The embedded ScheduleDefinition.
Public property | FamilyId | In a note block schedule, the ID of the Generic Annotation family displayed by the schedule.
Public property | GrandTotalTitle | The title name is used to display at the grand total row. The name is "Grand total", expressed in the Revit session language, by default.
Public property | HasEmbeddedSchedule | Indicates if this ScheduleDefinition has an embedded ScheduleDefinition.
Public property | IncludeLinkedFiles | Indicates if the schedule includes elements from linked files.
Public property | IsEmbedded | Indicates if this is an embedded ScheduleDefinition.
Public property | IsFilteredBySheet | Indicates if the schedule is set to filter by sheet.
Public property | IsItemized | Indicates if the schedule displays each element on a separate row or combines multiple grouped elements onto the same row.
Public property | IsKeySchedule | Indicates if the schedule is a key schedule.
Public property | IsMaterialTakeoff | Indicates if the schedule is a material takeoff.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ShowGrandTotal | Indicates if a grand total row should be displayed at the bottom of the schedule.
Public property | ShowGrandTotalCount | Indicates if the grand total row should display a count of elements in the schedule.
Public property | ShowGrandTotalTitle | Indicates if the grand total row should display a title.
Public property | ShowGridLines | Indicates if the schedule grid lines will be visible on a sheet.
Public property | ShowHeaders | Indicates if the headers will be displayed in the schedule.
Public property | ShowTitle | Indicates if the title will be displayed in the schedule.

See Also

ScheduleDefinition Class


AddEmbeddedSchedule Method

[image]

Revit 2024 API
ScheduleDefinition..::..AddEmbeddedSchedule Method
ScheduleDefinition Class See Also Send Feedback
Adds an embedded ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void AddEmbeddedSchedule(
    ElementId categoryId
)
Visual Basic
Public Sub AddEmbeddedSchedule ( _
    categoryId As ElementId _
)
Visual C++
public:
void AddEmbeddedSchedule(
    ElementId^ categoryId
)

Parameters

categoryId
Type: Autodesk.Revit.DB..::..ElementId
The category ID of elements to display in the embedded schedule.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | categoryId is not the ID of a category that can be used for an embedded ScheduleDefinition in this ScheduleDefinition.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This ScheduleDefinition is not a kind of schedule that supports adding an embedded ScheduleDefinition. -or- This ScheduleDefinition already has an embedded ScheduleDefinition.

See Also

ScheduleDefinition Class


AddField Method (SchedulableField)

[image]

Revit 2024 API
ScheduleDefinition..::..AddField Method (SchedulableField)
ScheduleDefinition Class Example See Also Send Feedback
Adds a regular field at the end of the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ScheduleField AddField(
    SchedulableField schedulableField
)
Visual Basic
Public Function AddField ( _
    schedulableField As SchedulableField _
) As ScheduleField
Visual C++
public:
ScheduleField^ AddField(
    SchedulableField^ schedulableField
)

Parameters

schedulableField
Type: Autodesk.Revit.DB..::..SchedulableField
A SchedulableField object representing the field.

Return Value

The new field.

Examples

CopyC#
/// <summary>
/// Add fields to view schedule.
/// </summary>
/// <param name="schedules">List of view schedule.</param>
public void AddFieldToSchedule(Document document, List<ViewSchedule> schedules)
{
    using (Transaction transaction = new Transaction(document, "Adding fields to schedule"))
    {
        transaction.Start();

        foreach (ViewSchedule vs in schedules)
        {
           //Get all schedulable fields from view schedule definition.
           IList<SchedulableField> schedulableFields = vs.Definition.GetSchedulableFields();

           foreach (SchedulableField sf in schedulableFields)
           {
               bool fieldAlreadyAdded = false;
               //Get all schedule field ids
               IList<ScheduleFieldId> ids = vs.Definition.GetFieldOrder();
               foreach (ScheduleFieldId id in ids)
               {
                   // If the GetSchedulableField() method of gotten schedule field returns same
                   // schedulable field, it means the field is already added to the view schedule.
                   if (vs.Definition.GetField(id).GetSchedulableField() == sf)
                   {
                       fieldAlreadyAdded = true;
                       break;
                   }
               }

               //If schedulable field doesn't exist in view schedule, add it.
               if (fieldAlreadyAdded == false)
               {
                   vs.Definition.AddField(sf);
               }
           }
        }

        transaction.Commit();
    }
}
CopyVB.NET
' <summary>
' Add fields to view schedule.
' </summary>
' <param name="schedules">List of view schedule.</param>
Public Sub AddFieldToSchedule(document As Document, schedules As List(Of ViewSchedule))
    Using transaction As New Transaction(document, "Adding fields to schedule")
        transaction.Start()

        For Each vs As ViewSchedule In schedules
            'Get all schedulable fields from view schedule definition.
            Dim schedulableFields As IList(Of SchedulableField) = vs.Definition.GetSchedulableFields()

            For Each sf As SchedulableField In schedulableFields
                Dim fieldAlreadyAdded As Boolean = False
                'Get all schedule field ids
                Dim ids As IList(Of ScheduleFieldId) = vs.Definition.GetFieldOrder()
                For Each id As ScheduleFieldId In ids
                    ' If the GetSchedulableField() method of gotten schedule field returns same
                    ' schedulable field, it means the field is already added to the view schedule.
                    If vs.Definition.GetField(id).GetSchedulableField() = sf Then
                        fieldAlreadyAdded = True
                        Exit For
                    End If
                Next

                'If schedulable field doesn't exist in view schedule, add it.
                If fieldAlreadyAdded = False Then
                    vs.Definition.AddField(sf)
                End If
            Next
        Next

        transaction.Commit()
    End Using
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The field specified by schedulableField may not included in this ScheduleDefinition. -or- The field specified by schedulableField is already included in this ScheduleDefinition.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ScheduleDefinition Class
AddField Overload


AddField Method (ScheduleFieldType)

[image]

Revit 2024 API
ScheduleDefinition..::..AddField Method (ScheduleFieldType)
ScheduleDefinition Class See Also Send Feedback
Adds a regular field at the end of the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ScheduleField AddField(
    ScheduleFieldType fieldType
)
Visual Basic
Public Function AddField ( _
    fieldType As ScheduleFieldType _
) As ScheduleField
Visual C++
public:
ScheduleField^ AddField(
    ScheduleFieldType fieldType
)

Parameters

fieldType
Type: Autodesk.Revit.DB..::..ScheduleFieldType
The type of data displayed by the field.

Return Value

The new field.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The field specified by fieldType may not included in this ScheduleDefinition. -or- The field specified by fieldType is already included in this ScheduleDefinition. -or- The fieldType can't be CustomField. To add a CustomField, you should create a Schedulable field and add it.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

ScheduleDefinition Class
AddField Overload


AddField Method (ScheduleFieldType, ElementId)

[image]

Revit 2024 API
ScheduleDefinition..::..AddField Method (ScheduleFieldType, ElementId)
ScheduleDefinition Class See Also Send Feedback
Adds a regular field at the end of the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ScheduleField AddField(
    ScheduleFieldType fieldType,
    ElementId parameterId
)
Visual Basic
Public Function AddField ( _
    fieldType As ScheduleFieldType, _
    parameterId As ElementId _
) As ScheduleField
Visual C++
public:
ScheduleField^ AddField(
    ScheduleFieldType fieldType,
    ElementId^ parameterId
)

Parameters

fieldType
Type: Autodesk.Revit.DB..::..ScheduleFieldType
The type of data displayed by the field.
parameterId
Type: Autodesk.Revit.DB..::..ElementId
The ID of the parameter displayed by the field.

Return Value

The new field.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | The field specified by fieldType and parameterId may not included in this ScheduleDefinition. -or- The field specified by fieldType and parameterId is already included in this ScheduleDefinition.

See Also

ScheduleDefinition Class
AddField Overload


AddFilter Method

[image]

Revit 2024 API
ScheduleDefinition..::..AddFilter Method
ScheduleDefinition Class Example See Also Send Feedback
Adds a new filter at the end of the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void AddFilter(
    ScheduleFilter filter
)
Visual Basic
Public Sub AddFilter ( _
    filter As ScheduleFilter _
)
Visual C++
public:
void AddFilter(
    ScheduleFilter^ filter
)

Parameters

filter
Type: Autodesk.Revit.DB..::..ScheduleFilter
The filter to add.

Examples

CopyC#
public static void AddFilterToSchedule(ViewSchedule schedule, ElementId levelId)
{
    // Find level field
    ScheduleDefinition definition = schedule.Definition;

    ScheduleField levelField = FindField(schedule, BuiltInParameter.ROOM_LEVEL_ID);

    // Add filter
    using (Transaction t = new Transaction(schedule.Document, "Add filter"))
    {
        t.Start();

        // If field not present, add it
        if (levelField == null)
        {
            levelField = definition.AddField(ScheduleFieldType.Instance, new ElementId(BuiltInParameter.ROOM_LEVEL_ID));
        }

        // Set field to hidden
        levelField.IsHidden = true;
        ScheduleFilter filter = new ScheduleFilter(levelField.FieldId, ScheduleFilterType.Equal, levelId);
        definition.AddFilter(filter);

        t.Commit();
    }
}

/// <summary>
/// Finds an existing ScheduleField matching the given parameter
/// </summary>
/// <param name="schedule"></param>
/// <param name="paramEnum"></param>
/// <returns></returns>
public static ScheduleField FindField(ViewSchedule schedule, BuiltInParameter paramEnum)
{
    ScheduleDefinition definition = schedule.Definition;
    ScheduleField foundField = null;
    ElementId paramId = new ElementId(paramEnum);

    foreach (ScheduleFieldId fieldId in definition.GetFieldOrder())
    {
        foundField = definition.GetField(fieldId);
        if (foundField.ParameterId == paramId)
        {
            return foundField;
        }
    }

    return null;
}
CopyVB.NET
Public Shared Sub AddFilterToSchedule(schedule As ViewSchedule, levelId As ElementId)
    ' Find level field
    Dim definition As ScheduleDefinition = schedule.Definition

    Dim levelField As ScheduleField = FindField(schedule, BuiltInParameter.ROOM_LEVEL_ID)

    ' Add filter
    Using t As New Transaction(schedule.Document, "Add filter")
        t.Start()

        ' If field not present, add it
        If levelField Is Nothing Then
            levelField = definition.AddField(ScheduleFieldType.Instance, New ElementId(BuiltInParameter.ROOM_LEVEL_ID))
        End If

        ' Set field to hidden
        levelField.IsHidden = True
        Dim filter As New ScheduleFilter(levelField.FieldId, ScheduleFilterType.Equal, levelId)
        definition.AddFilter(filter)

        t.Commit()
    End Using
End Sub

' <summary>
' Finds an existing ScheduleField matching the given parameter
' </summary>
' <param name="schedule"></param>
' <param name="paramEnum"></param>
' <returns></returns>
Public Shared Function FindField(schedule As ViewSchedule, paramEnum As BuiltInParameter) As ScheduleField
    Dim definition As ScheduleDefinition = schedule.Definition
    Dim foundField As ScheduleField = Nothing
    Dim paramId As New ElementId(paramEnum)

    For Each fieldId As ScheduleFieldId In definition.GetFieldOrder()
        foundField = definition.GetField(fieldId)
        If foundField.ParameterId = paramId Then
            Return foundField
        End If
    Next

    Return Nothing
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The field ID is not the ID of a field in this ScheduleDefinition. -or- The field and filter type cannot be used to filter this ScheduleDefinition. -or- The filter value is not valid for the field and filter type.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This ScheduleDefinition does not support filters. -or- The resulting filter count would be greater than 8.

See Also

ScheduleDefinition Class


CanFilterByGlobalParameters Method

[image]

Revit 2024 API
ScheduleDefinition..::..CanFilterByGlobalParameters Method
ScheduleDefinition Class See Also Send Feedback
Checks whether a field can be used with a global parameter-based filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public bool CanFilterByGlobalParameters(
    ScheduleFieldId fieldId
)
Visual Basic
Public Function CanFilterByGlobalParameters ( _
    fieldId As ScheduleFieldId _
) As Boolean
Visual C++
public:
bool CanFilterByGlobalParameters(
    ScheduleFieldId^ fieldId
)

Parameters

fieldId
Type: Autodesk.Revit.DB..::..ScheduleFieldId
The ID of the field to check.

Return Value

True if the field can be used with a global parameter-based filter, false otherwise.

Remarks

The global parameter-based filter types are IsAsociatedWith, IsNotAssociatedWith.

Only parameters which have a compatible type with at least one existing global parameter can be filtered.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | fieldId is not the ID of a field in this ScheduleDefinition.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ScheduleDefinition Class


CanFilterByParameterExistence Method

[image]

Revit 2024 API
ScheduleDefinition..::..CanFilterByParameterExistence Method
ScheduleDefinition Class See Also Send Feedback
Checks whether a field can be used with a HasParameter filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool CanFilterByParameterExistence(
    ScheduleFieldId fieldId
)
Visual Basic
Public Function CanFilterByParameterExistence ( _
    fieldId As ScheduleFieldId _
) As Boolean
Visual C++
public:
bool CanFilterByParameterExistence(
    ScheduleFieldId^ fieldId
)

Parameters

fieldId
Type: Autodesk.Revit.DB..::..ScheduleFieldId
The ID of the field to check.

Return Value

True if the field can be used with a HasParameter filter, false otherwise.

Remarks

The HasParameter filter type only supports shared parameters, and only with the Instance or ElementType field types.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | fieldId is not the ID of a field in this ScheduleDefinition.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ScheduleDefinition Class


CanFilterBySubstring Method

[image]

Revit 2024 API
ScheduleDefinition..::..CanFilterBySubstring Method
ScheduleDefinition Class See Also Send Feedback
Checks whether a field can be used with a substring-based filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool CanFilterBySubstring(
    ScheduleFieldId fieldId
)
Visual Basic
Public Function CanFilterBySubstring ( _
    fieldId As ScheduleFieldId _
) As Boolean
Visual C++
public:
bool CanFilterBySubstring(
    ScheduleFieldId^ fieldId
)

Parameters

fieldId
Type: Autodesk.Revit.DB..::..ScheduleFieldId
The ID of the field to check.

Return Value

True if the field can be used with a substring-based filter, false otherwise.

Remarks

The substring-based filter types are Contains, NotContains, BeginsWith, NonBeginsWith, EndsWith and NotEndsWith.

Only string parameters can be filtered by substring.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | fieldId is not the ID of a field in this ScheduleDefinition.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ScheduleDefinition Class


CanFilterByValue Method

[image]

Revit 2024 API
ScheduleDefinition..::..CanFilterByValue Method
ScheduleDefinition Class See Also Send Feedback
Checks whether a field can be used with a value-based filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool CanFilterByValue(
    ScheduleFieldId fieldId
)
Visual Basic
Public Function CanFilterByValue ( _
    fieldId As ScheduleFieldId _
) As Boolean
Visual C++
public:
bool CanFilterByValue(
    ScheduleFieldId^ fieldId
)

Parameters

fieldId
Type: Autodesk.Revit.DB..::..ScheduleFieldId
The ID of the field to check.

Return Value

True if the field can be used with a value based filter, false otherwise.

Remarks

The value-based filter types are Equal, NotEqual, GreaterThan, GreaterThanOrEqual, LessThan and LessThanOrEqual.

Only certain types of parameters can be filtered by value.

Note that some fields (for example, Workset, Family, Type, Family and Type) only support Equal, NotEqual, but not GreaterThan, GreaterThanOrEqual, LessThan and LessThanOrEqual.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | fieldId is not the ID of a field in this ScheduleDefinition.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ScheduleDefinition Class


CanHaveEmbeddedSchedule Method

[image]

Revit 2024 API
ScheduleDefinition..::..CanHaveEmbeddedSchedule Method
ScheduleDefinition Class See Also Send Feedback
Indicates if this ScheduleDefinition can have an embedded ScheduleDefinition added.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool CanHaveEmbeddedSchedule()
Visual Basic
Public Function CanHaveEmbeddedSchedule As Boolean
Visual C++
public:
bool CanHaveEmbeddedSchedule()

Return Value

True if this ScheduleDefinition can have an embedded ScheduleDefinition, false otherwise.

Remarks

Only schedules of the following categories can have an embedded ScheduleDefinition:

  • Rooms
  • Spaces
  • Electrical Circuits
  • Duct Systems
  • Piping Systems
  • Mechanical Equipment Sets
  • MEP Fabrication Ductwork
  • Fabrication Ductwork Stiffeners

Key schedules cannot have embedded schedules.

See Also

ScheduleDefinition Class


CanIncludeLinkedFiles Method

[image]

Revit 2024 API
ScheduleDefinition..::..CanIncludeLinkedFiles Method
ScheduleDefinition Class See Also Send Feedback
Checks whether the schedule is a type that supports including elements from linked files.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool CanIncludeLinkedFiles()
Visual Basic
Public Function CanIncludeLinkedFiles As Boolean
Visual C++
public:
bool CanIncludeLinkedFiles()

Return Value

True if elements from linked files can be included, false otherwise.

Remarks

Elements from linked files can be included in schedules of normal model elements and in sheet lists, but not in most other specialized kinds of schedules.

See Also

ScheduleDefinition Class


CanSortByField Method

[image]

Revit 2024 API
ScheduleDefinition..::..CanSortByField Method
ScheduleDefinition Class See Also Send Feedback
Checks whether a field can be used for sorting/grouping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool CanSortByField(
    ScheduleFieldId fieldId
)
Visual Basic
Public Function CanSortByField ( _
    fieldId As ScheduleFieldId _
) As Boolean
Visual C++
public:
bool CanSortByField(
    ScheduleFieldId^ fieldId
)

Parameters

fieldId
Type: Autodesk.Revit.DB..::..ScheduleFieldId
The ID of the field to check.

Return Value

True if the field can be used for sorting/grouping, false otherwise.

Remarks

Schedules cannot be sorted/grouped by the Count field, Percentage fields, or Formula fields that depend on Percentage fields because those types of fields don't have meaningful values until after sorting and grouping takes place.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | fieldId is not the ID of a field in this ScheduleDefinition.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ScheduleDefinition Class


ClearFields Method

[image]

Revit 2024 API
ScheduleDefinition..::..ClearFields Method
ScheduleDefinition Class See Also Send Feedback
Removes all fields.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void ClearFields()
Visual Basic
Public Sub ClearFields
Visual C++
public:
void ClearFields()

See Also

ScheduleDefinition Class


ClearFilters Method

[image]

Revit 2024 API
ScheduleDefinition..::..ClearFilters Method
ScheduleDefinition Class See Also Send Feedback
Removes all filters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void ClearFilters()
Visual Basic
Public Sub ClearFilters
Visual C++
public:
void ClearFilters()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This ScheduleDefinition does not support filters.

See Also

ScheduleDefinition Class


ClearSortGroupFields Method

[image]

Revit 2024 API
ScheduleDefinition..::..ClearSortGroupFields Method
ScheduleDefinition Class See Also Send Feedback
Removes all sorting/grouping fields.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void ClearSortGroupFields()
Visual Basic
Public Sub ClearSortGroupFields
Visual C++
public:
void ClearSortGroupFields()

See Also

ScheduleDefinition Class


Dispose Method

[image]

Revit 2024 API
ScheduleDefinition..::..Dispose Method
ScheduleDefinition Class See Also Send Feedback
Releases all resources used by the ScheduleDefinition

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ScheduleDefinition Class


GetField Method

[image] [image]

Revit 2024 API
ScheduleDefinition..::..GetField Method
ScheduleDefinition Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetField(Int32) | Gets a field.
Public method | GetField(ScheduleFieldId) | Gets a field.

See Also

ScheduleDefinition Class
ScheduleDefinition Members


GetField Method (Int32)

[image]

Revit 2024 API
ScheduleDefinition..::..GetField Method (Int32)
ScheduleDefinition Class See Also Send Feedback
Gets a field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ScheduleField GetField(
    int index
)
Visual Basic
Public Function GetField ( _
    index As Integer _
) As ScheduleField
Visual C++
public:
ScheduleField^ GetField(
    int index
)

Parameters

index
Type: System..::..Int32
The index of the field.

Return Value

The field.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | index is not a valid field index in this ScheduleDefinition.

See Also

ScheduleDefinition Class
GetField Overload


GetField Method (ScheduleFieldId)

[image]

Revit 2024 API
ScheduleDefinition..::..GetField Method (ScheduleFieldId)
ScheduleDefinition Class See Also Send Feedback
Gets a field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ScheduleField GetField(
    ScheduleFieldId fieldId
)
Visual Basic
Public Function GetField ( _
    fieldId As ScheduleFieldId _
) As ScheduleField
Visual C++
public:
ScheduleField^ GetField(
    ScheduleFieldId^ fieldId
)

Parameters

fieldId
Type: Autodesk.Revit.DB..::..ScheduleFieldId
The ID of the field.

Return Value

The field.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | fieldId is not the ID of a field in this ScheduleDefinition.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ScheduleDefinition Class
GetField Overload


GetFieldId Method

[image]

Revit 2024 API
ScheduleDefinition..::..GetFieldId Method
ScheduleDefinition Class See Also Send Feedback
Converts a field index to the corresponding field ID.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ScheduleFieldId GetFieldId(
    int index
)
Visual Basic
Public Function GetFieldId ( _
    index As Integer _
) As ScheduleFieldId
Visual C++
public:
ScheduleFieldId^ GetFieldId(
    int index
)

Parameters

index
Type: System..::..Int32
The field index.

Return Value

The field ID.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | index is not a valid field index in this ScheduleDefinition.

See Also

ScheduleDefinition Class


GetFieldOrder Method

[image]

Revit 2024 API
ScheduleDefinition..::..GetFieldOrder Method
ScheduleDefinition Class See Also Send Feedback
Gets the IDs of the current list of fields in order.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public IList<ScheduleFieldId> GetFieldOrder()
Visual Basic
Public Function GetFieldOrder As IList(Of ScheduleFieldId)
Visual C++
public:
IList<ScheduleFieldId^>^ GetFieldOrder()

Return Value

The IDs of the current list of fields.

See Also

ScheduleDefinition Class


GetFilter Method

[image]

Revit 2024 API
ScheduleDefinition..::..GetFilter Method
ScheduleDefinition Class See Also Send Feedback
Gets a filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ScheduleFilter GetFilter(
    int index
)
Visual Basic
Public Function GetFilter ( _
    index As Integer _
) As ScheduleFilter
Visual C++
public:
ScheduleFilter^ GetFilter(
    int index
)

Parameters

index
Type: System..::..Int32
The index of the filter.

Return Value

A copy of the filter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | index is not a valid filter index.

See Also

ScheduleDefinition Class


GetFilterCount Method

[image]

Revit 2024 API
ScheduleDefinition..::..GetFilterCount Method
ScheduleDefinition Class See Also Send Feedback
Gets the number of filters in this ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public int GetFilterCount()
Visual Basic
Public Function GetFilterCount As Integer
Visual C++
public:
int GetFilterCount()

Return Value

The number of filters.

See Also

ScheduleDefinition Class


GetFilters Method

[image]

Revit 2024 API
ScheduleDefinition..::..GetFilters Method
ScheduleDefinition Class See Also Send Feedback
Gets all filters in this ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public IList<ScheduleFilter> GetFilters()
Visual Basic
Public Function GetFilters As IList(Of ScheduleFilter)
Visual C++
public:
IList<ScheduleFilter^>^ GetFilters()

Return Value

A list of all filters.

See Also

ScheduleDefinition Class


GetSchedulableFields Method

[image]

Revit 2024 API
ScheduleDefinition..::..GetSchedulableFields Method
ScheduleDefinition Class See Also Send Feedback
Gets a list of all non-calculated/non-combined fields that are eligible to be included in this schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public IList<SchedulableField> GetSchedulableFields()
Visual Basic
Public Function GetSchedulableFields As IList(Of SchedulableField)
Visual C++
public:
IList<SchedulableField^>^ GetSchedulableFields()

Return Value

A list of SchedulableField objects representing the non-calculated/non-combined fields that may be included in the schedule.

See Also

ScheduleDefinition Class


GetSortGroupField Method

[image]

Revit 2024 API
ScheduleDefinition..::..GetSortGroupField Method
ScheduleDefinition Class See Also Send Feedback
Gets a sorting/grouping field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ScheduleSortGroupField GetSortGroupField(
    int index
)
Visual Basic
Public Function GetSortGroupField ( _
    index As Integer _
) As ScheduleSortGroupField
Visual C++
public:
ScheduleSortGroupField^ GetSortGroupField(
    int index
)

Parameters

index
Type: System..::..Int32
The index of the sorting/grouping field.

Return Value

A copy of the sorting/grouping field.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | index is not a valid sorting/grouping field index.

See Also

ScheduleDefinition Class


GetSortGroupFields Method

[image]

Revit 2024 API
ScheduleDefinition..::..GetSortGroupFields Method
ScheduleDefinition Class See Also Send Feedback
Gets all sorting/grouping fields in this ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public IList<ScheduleSortGroupField> GetSortGroupFields()
Visual Basic
Public Function GetSortGroupFields As IList(Of ScheduleSortGroupField)
Visual C++
public:
IList<ScheduleSortGroupField^>^ GetSortGroupFields()

Return Value

A list of all sorting/grouping fields.

See Also

ScheduleDefinition Class


GetValidCategoriesForEmbeddedSchedule Method

[image]

Revit 2024 API
ScheduleDefinition..::..GetValidCategoriesForEmbeddedSchedule Method
ScheduleDefinition Class See Also Send Feedback
Get all categories that can be used for an embedded ScheduleDefinition in this ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ICollection<ElementId> GetValidCategoriesForEmbeddedSchedule()
Visual Basic
Public Function GetValidCategoriesForEmbeddedSchedule As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetValidCategoriesForEmbeddedSchedule()

Return Value

The IDs of all valid categories.

See Also

ScheduleDefinition Class


InsertField Method

[image] [image]

Revit 2024 API
ScheduleDefinition..::..InsertField Method
ScheduleDefinition Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertField(SchedulableField, Int32) | Adds a regular field at the specified position in the list.
Public method | InsertField(ScheduleFieldType, Int32) | Adds a regular field at the specified position in the list.
Public method | InsertField(ScheduleFieldType, ElementId, Int32) | Adds a regular field at the specified position in the list.

See Also

ScheduleDefinition Class
ScheduleDefinition Members


InsertField Method (SchedulableField, Int32)

[image]

Revit 2024 API
ScheduleDefinition..::..InsertField Method (SchedulableField, Int32)
ScheduleDefinition Class See Also Send Feedback
Adds a regular field at the specified position in the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ScheduleField InsertField(
    SchedulableField schedulableField,
    int index
)
Visual Basic
Public Function InsertField ( _
    schedulableField As SchedulableField, _
    index As Integer _
) As ScheduleField
Visual C++
public:
ScheduleField^ InsertField(
    SchedulableField^ schedulableField,
    int index
)

Parameters

schedulableField
Type: Autodesk.Revit.DB..::..SchedulableField
A SchedulableField object representing the field.
index
Type: System..::..Int32
The index in the list of fields.

Return Value

The new field.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The field specified by schedulableField may not included in this ScheduleDefinition. -or- The field specified by schedulableField is already included in this ScheduleDefinition.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | index is not a valid insert position.

See Also

ScheduleDefinition Class
InsertField Overload


InsertField Method (ScheduleFieldType, Int32)

[image]

Revit 2024 API
ScheduleDefinition..::..InsertField Method (ScheduleFieldType, Int32)
ScheduleDefinition Class See Also Send Feedback
Adds a regular field at the specified position in the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ScheduleField InsertField(
    ScheduleFieldType fieldType,
    int index
)
Visual Basic
Public Function InsertField ( _
    fieldType As ScheduleFieldType, _
    index As Integer _
) As ScheduleField
Visual C++
public:
ScheduleField^ InsertField(
    ScheduleFieldType fieldType,
    int index
)

Parameters

fieldType
Type: Autodesk.Revit.DB..::..ScheduleFieldType
The type of data displayed by the field.
index
Type: System..::..Int32
The index in the list of fields.

Return Value

The new field.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The field specified by fieldType may not included in this ScheduleDefinition. -or- The field specified by fieldType is already included in this ScheduleDefinition. -or- The fieldType can't be CustomField. To add a CustomField, you should create a Schedulable field and add it.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | index is not a valid insert position. -or- A value passed for an enumeration argument is not a member of that enumeration

See Also

ScheduleDefinition Class
InsertField Overload


InsertField Method (ScheduleFieldType, ElementId, Int32)

[image]

Revit 2024 API
ScheduleDefinition..::..InsertField Method (ScheduleFieldType, ElementId, Int32)
ScheduleDefinition Class See Also Send Feedback
Adds a regular field at the specified position in the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ScheduleField InsertField(
    ScheduleFieldType fieldType,
    ElementId parameterId,
    int index
)
Visual Basic
Public Function InsertField ( _
    fieldType As ScheduleFieldType, _
    parameterId As ElementId, _
    index As Integer _
) As ScheduleField
Visual C++
public:
ScheduleField^ InsertField(
    ScheduleFieldType fieldType,
    ElementId^ parameterId,
    int index
)

Parameters

fieldType
Type: Autodesk.Revit.DB..::..ScheduleFieldType
The type of data displayed by the field.
parameterId
Type: Autodesk.Revit.DB..::..ElementId
The ID of the parameter displayed by the field.
index
Type: System..::..Int32
The index in the list of fields.

Return Value

The new field.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | index is not a valid insert position. -or- A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | The field specified by fieldType and parameterId may not included in this ScheduleDefinition. -or- The field specified by fieldType and parameterId is already included in this ScheduleDefinition.

See Also

ScheduleDefinition Class
InsertField Overload


InsertFilter Method

[image]

Revit 2024 API
ScheduleDefinition..::..InsertFilter Method
ScheduleDefinition Class See Also Send Feedback
Adds a new filter at the specified position in the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void InsertFilter(
    ScheduleFilter filter,
    int index
)
Visual Basic
Public Sub InsertFilter ( _
    filter As ScheduleFilter, _
    index As Integer _
)
Visual C++
public:
void InsertFilter(
    ScheduleFilter^ filter,
    int index
)

Parameters

filter
Type: Autodesk.Revit.DB..::..ScheduleFilter
The filter to add.
index
Type: System..::..Int32
The index in the list of filters.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The field ID is not the ID of a field in this ScheduleDefinition. -or- The field and filter type cannot be used to filter this ScheduleDefinition. -or- The filter value is not valid for the field and filter type.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | index is not a valid insert position.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This ScheduleDefinition does not support filters. -or- The resulting filter count would be greater than 8.

See Also

ScheduleDefinition Class


InsertSortGroupField Method

[image]

Revit 2024 API
ScheduleDefinition..::..InsertSortGroupField Method
ScheduleDefinition Class See Also Send Feedback
Adds a new sorting/grouping field at the specified position in the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void InsertSortGroupField(
    ScheduleSortGroupField sortGroupField,
    int index
)
Visual Basic
Public Sub InsertSortGroupField ( _
    sortGroupField As ScheduleSortGroupField, _
    index As Integer _
)
Visual C++
public:
void InsertSortGroupField(
    ScheduleSortGroupField^ sortGroupField,
    int index
)

Parameters

sortGroupField
Type: Autodesk.Revit.DB..::..ScheduleSortGroupField
The sorting/grouping field to add.
index
Type: System..::..Int32
The index in the list of sorting/grouping fields.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The field ID is not the ID of a field in this ScheduleDefinition. -or- The field cannot be used for sorting/grouping.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | index is not a valid insert position.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The resulting sorting/grouping field count would be greater than 4.

See Also

ScheduleDefinition Class


IsValidCategoryForEmbeddedSchedule Method

[image]

Revit 2024 API
ScheduleDefinition..::..IsValidCategoryForEmbeddedSchedule Method
ScheduleDefinition Class See Also Send Feedback
Indicates if a category can be used for an embedded ScheduleDefinition in this ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool IsValidCategoryForEmbeddedSchedule(
    ElementId categoryId
)
Visual Basic
Public Function IsValidCategoryForEmbeddedSchedule ( _
    categoryId As ElementId _
) As Boolean
Visual C++
public:
bool IsValidCategoryForEmbeddedSchedule(
    ElementId^ categoryId
)

Parameters

categoryId
Type: Autodesk.Revit.DB..::..ElementId
The category ID to check.

Return Value

True if the category can be used for an embedded ScheduleDefinition, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ScheduleDefinition Class


IsValidCategoryForFilterBySheet Method

[image]

Revit 2024 API
ScheduleDefinition..::..IsValidCategoryForFilterBySheet Method
ScheduleDefinition Class See Also Send Feedback
Checks whether a schedule can be filtered by sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public bool IsValidCategoryForFilterBySheet()
Visual Basic
Public Function IsValidCategoryForFilterBySheet As Boolean
Visual C++
public:
bool IsValidCategoryForFilterBySheet()

Return Value

True if the schedule can be filtered by sheet, false otherwise.

See Also

ScheduleDefinition Class


IsValidCombinedParameters Method

[image]

Revit 2024 API
ScheduleDefinition..::..IsValidCombinedParameters Method
ScheduleDefinition Class See Also Send Feedback
Checks if data is valid for combined parameters

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public bool IsValidCombinedParameters(
    IList<TableCellCombinedParameterData> data
)
Visual Basic
Public Function IsValidCombinedParameters ( _
    data As IList(Of TableCellCombinedParameterData) _
) As Boolean
Visual C++
public:
bool IsValidCombinedParameters(
    IList<TableCellCombinedParameterData^>^ data
)

Parameters

data
Type: System.Collections.Generic..::..IList<(Of <(<' TableCellCombinedParameterData >)>)>
data is array of TableCellCombinedParameterData to be set as combined parameters

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ScheduleDefinition Class


IsValidFieldId Method

[image]

Revit 2024 API
ScheduleDefinition..::..IsValidFieldId Method
ScheduleDefinition Class See Also Send Feedback
Checks whether a ScheduleFieldId is the ID of a field in this ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool IsValidFieldId(
    ScheduleFieldId fieldId
)
Visual Basic
Public Function IsValidFieldId ( _
    fieldId As ScheduleFieldId _
) As Boolean
Visual C++
public:
bool IsValidFieldId(
    ScheduleFieldId^ fieldId
)

Parameters

fieldId
Type: Autodesk.Revit.DB..::..ScheduleFieldId
The field ID to check.

Return Value

True if the field ID is valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ScheduleDefinition Class


IsValidFieldIndex Method

[image]

Revit 2024 API
ScheduleDefinition..::..IsValidFieldIndex Method
ScheduleDefinition Class See Also Send Feedback
Checks whether an integer is a valid zero-based field index in this ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool IsValidFieldIndex(
    int index
)
Visual Basic
Public Function IsValidFieldIndex ( _
    index As Integer _
) As Boolean
Visual C++
public:
bool IsValidFieldIndex(
    int index
)

Parameters

index
Type: System..::..Int32
The field index to check.

Return Value

True if the field index is valid, false otherwise.

See Also

ScheduleDefinition Class


RemoveEmbeddedSchedule Method

[image]

Revit 2024 API
ScheduleDefinition..::..RemoveEmbeddedSchedule Method
ScheduleDefinition Class See Also Send Feedback
Removes the embedded ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void RemoveEmbeddedSchedule()
Visual Basic
Public Sub RemoveEmbeddedSchedule
Visual C++
public:
void RemoveEmbeddedSchedule()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This ScheduleDefinition does not have an embedded ScheduleDefinition.

See Also

ScheduleDefinition Class


RemoveField Method (Int32)

[image]

Revit 2024 API
ScheduleDefinition..::..RemoveField Method (Int32)
ScheduleDefinition Class See Also Send Feedback
Removes a field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void RemoveField(
    int index
)
Visual Basic
Public Sub RemoveField ( _
    index As Integer _
)
Visual C++
public:
void RemoveField(
    int index
)

Parameters

index
Type: System..::..Int32
The index of the field to remove.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | index is not a valid field index in this ScheduleDefinition.

See Also

ScheduleDefinition Class
RemoveField Overload


RemoveField Method (ScheduleFieldId)

[image]

Revit 2024 API
ScheduleDefinition..::..RemoveField Method (ScheduleFieldId)
ScheduleDefinition Class See Also Send Feedback
Removes a field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void RemoveField(
    ScheduleFieldId fieldId
)
Visual Basic
Public Sub RemoveField ( _
    fieldId As ScheduleFieldId _
)
Visual C++
public:
void RemoveField(
    ScheduleFieldId^ fieldId
)

Parameters

fieldId
Type: Autodesk.Revit.DB..::..ScheduleFieldId
The ID of the field to remove.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | fieldId is not the ID of a field in this ScheduleDefinition.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ScheduleDefinition Class
RemoveField Overload


RemoveFilter Method

[image]

Revit 2024 API
ScheduleDefinition..::..RemoveFilter Method
ScheduleDefinition Class See Also Send Feedback
Removes a filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void RemoveFilter(
    int index
)
Visual Basic
Public Sub RemoveFilter ( _
    index As Integer _
)
Visual C++
public:
void RemoveFilter(
    int index
)

Parameters

index
Type: System..::..Int32
The index of the filter to remove.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | index is not a valid filter index.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This ScheduleDefinition does not support filters.

See Also

ScheduleDefinition Class


RemoveSortGroupField Method

[image]

Revit 2024 API
ScheduleDefinition..::..RemoveSortGroupField Method
ScheduleDefinition Class See Also Send Feedback
Removes a sorting/grouping field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void RemoveSortGroupField(
    int index
)
Visual Basic
Public Sub RemoveSortGroupField ( _
    index As Integer _
)
Visual C++
public:
void RemoveSortGroupField(
    int index
)

Parameters

index
Type: System..::..Int32
The index of the sorting/grouping field to remove.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | index is not a valid sorting/grouping field index.

See Also

ScheduleDefinition Class


SetFieldOrder Method

[image]

Revit 2024 API
ScheduleDefinition..::..SetFieldOrder Method
ScheduleDefinition Class See Also Send Feedback
Reorders the fields in the schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void SetFieldOrder(
    IList<ScheduleFieldId> fieldIds
)
Visual Basic
Public Sub SetFieldOrder ( _
    fieldIds As IList(Of ScheduleFieldId) _
)
Visual C++
public:
void SetFieldOrder(
    IList<ScheduleFieldId^>^ fieldIds
)

Parameters

fieldIds
Type: System.Collections.Generic..::..IList<(Of <(<' ScheduleFieldId >)>)>
The field IDs in a new order.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | fieldIds does not contain exactly the same field IDs as this ScheduleDefinition currently contains.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ScheduleDefinition Class


SetFilter Method

[image]

Revit 2024 API
ScheduleDefinition..::..SetFilter Method
ScheduleDefinition Class See Also Send Feedback
Replaces a filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void SetFilter(
    int index,
    ScheduleFilter filter
)
Visual Basic
Public Sub SetFilter ( _
    index As Integer, _
    filter As ScheduleFilter _
)
Visual C++
public:
void SetFilter(
    int index,
    ScheduleFilter^ filter
)

Parameters

index
Type: System..::..Int32
The index of the filter to replace.
filter
Type: Autodesk.Revit.DB..::..ScheduleFilter
The new filter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The field ID is not the ID of a field in this ScheduleDefinition. -or- The field and filter type cannot be used to filter this ScheduleDefinition. -or- The filter value is not valid for the field and filter type.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | index is not a valid filter index.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This ScheduleDefinition does not support filters.

See Also

ScheduleDefinition Class


SetSortGroupField Method

[image]

Revit 2024 API
ScheduleDefinition..::..SetSortGroupField Method
ScheduleDefinition Class See Also Send Feedback
Replaces a sorting/grouping field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void SetSortGroupField(
    int index,
    ScheduleSortGroupField sortGroupField
)
Visual Basic
Public Sub SetSortGroupField ( _
    index As Integer, _
    sortGroupField As ScheduleSortGroupField _
)
Visual C++
public:
void SetSortGroupField(
    int index,
    ScheduleSortGroupField^ sortGroupField
)

Parameters

index
Type: System..::..Int32
The index of the sorting/grouping field to replace.
sortGroupField
Type: Autodesk.Revit.DB..::..ScheduleSortGroupField
The new sorting/grouping field.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The field ID is not the ID of a field in this ScheduleDefinition. -or- The field cannot be used for sorting/grouping.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | index is not a valid sorting/grouping field index.

See Also

ScheduleDefinition Class


ScheduleDefinition Properties

[image] [image]

Revit 2024 API
ScheduleDefinition Properties
ScheduleDefinition Class See Also Send Feedback

The ScheduleDefinition type exposes the following members.

Properties

 | Name | Description
Public property | AreaSchemeId | In an area schedule, the ID of the area scheme to display.
Public property | CategoryId | The category ID of elements appearing in the schedule.
Public property | EmbeddedDefinition | The embedded ScheduleDefinition.
Public property | FamilyId | In a note block schedule, the ID of the Generic Annotation family displayed by the schedule.
Public property | GrandTotalTitle | The title name is used to display at the grand total row. The name is "Grand total", expressed in the Revit session language, by default.
Public property | HasEmbeddedSchedule | Indicates if this ScheduleDefinition has an embedded ScheduleDefinition.
Public property | IncludeLinkedFiles | Indicates if the schedule includes elements from linked files.
Public property | IsEmbedded | Indicates if this is an embedded ScheduleDefinition.
Public property | IsFilteredBySheet | Indicates if the schedule is set to filter by sheet.
Public property | IsItemized | Indicates if the schedule displays each element on a separate row or combines multiple grouped elements onto the same row.
Public property | IsKeySchedule | Indicates if the schedule is a key schedule.
Public property | IsMaterialTakeoff | Indicates if the schedule is a material takeoff.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ShowGrandTotal | Indicates if a grand total row should be displayed at the bottom of the schedule.
Public property | ShowGrandTotalCount | Indicates if the grand total row should display a count of elements in the schedule.
Public property | ShowGrandTotalTitle | Indicates if the grand total row should display a title.
Public property | ShowGridLines | Indicates if the schedule grid lines will be visible on a sheet.
Public property | ShowHeaders | Indicates if the headers will be displayed in the schedule.
Public property | ShowTitle | Indicates if the title will be displayed in the schedule.

See Also

ScheduleDefinition Class


AreaSchemeId Property

[image]

Revit 2024 API
ScheduleDefinition..::..AreaSchemeId Property
ScheduleDefinition Class See Also Send Feedback
In an area schedule, the ID of the area scheme to display.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ElementId AreaSchemeId { get; }
Visual Basic
Public ReadOnly Property AreaSchemeId As ElementId
    Get
Visual C++
public:
property ElementId^ AreaSchemeId {
    ElementId^ get ();
}

Remarks

Schedules of the Areas category show area elements belonging to a single area scheme.

Key schedules of the Areas category apply to all area schemes, so they don't have an area scheme ID.

See Also

ScheduleDefinition Class


EmbeddedDefinition Property

[image]

Revit 2024 API
ScheduleDefinition..::..EmbeddedDefinition Property
ScheduleDefinition Class See Also Send Feedback
The embedded ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ScheduleDefinition EmbeddedDefinition { get; }
Visual Basic
Public ReadOnly Property EmbeddedDefinition As ScheduleDefinition
    Get
Visual C++
public:
property ScheduleDefinition^ EmbeddedDefinition {
    ScheduleDefinition^ get ();
}

See Also

ScheduleDefinition Class


FamilyId Property

[image]

Revit 2024 API
ScheduleDefinition..::..FamilyId Property
ScheduleDefinition Class See Also Send Feedback
In a note block schedule, the ID of the Generic Annotation family displayed by the schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ElementId FamilyId { get; }
Visual Basic
Public ReadOnly Property FamilyId As ElementId
    Get
Visual C++
public:
property ElementId^ FamilyId {
    ElementId^ get ();
}

Remarks

A note block is a schedule of the Generic Annotations category that shows elements of a single family rather than all elements in the category.

See Also

ScheduleDefinition Class


GrandTotalTitle Property

[image]

Revit 2024 API
ScheduleDefinition..::..GrandTotalTitle Property
ScheduleDefinition Class See Also Send Feedback
The title name is used to display at the grand total row. The name is "Grand total", expressed in the Revit session language, by default.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public string GrandTotalTitle { get; set; }
Visual Basic
Public Property GrandTotalTitle As String
    Get
    Set
Visual C++
public:
property String^ GrandTotalTitle {
    String^ get ();
    void set (String^ value);
}

Remarks

GrandTotalTitle can only be set when both ShowGrandTotal and ShowGrandTotalTitle are enabled.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: Display of a grand total row is not enabled. -or- When setting this property: Display of grand total title is not enabled.

See Also

ScheduleDefinition Class


HasEmbeddedSchedule Property

[image]

Revit 2024 API
ScheduleDefinition..::..HasEmbeddedSchedule Property
ScheduleDefinition Class See Also Send Feedback
Indicates if this ScheduleDefinition has an embedded ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool HasEmbeddedSchedule { get; }
Visual Basic
Public ReadOnly Property HasEmbeddedSchedule As Boolean
    Get
Visual C++
public:
property bool HasEmbeddedSchedule {
    bool get ();
}

See Also

ScheduleDefinition Class


IsEmbedded Property

[image]

Revit 2024 API
ScheduleDefinition..::..IsEmbedded Property
ScheduleDefinition Class See Also Send Feedback
Indicates if this is an embedded ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool IsEmbedded { get; }
Visual Basic
Public ReadOnly Property IsEmbedded As Boolean
    Get
Visual C++
public:
property bool IsEmbedded {
    bool get ();
}

See Also

ScheduleDefinition Class


IsItemized Property

[image]

Revit 2024 API
ScheduleDefinition..::..IsItemized Property
ScheduleDefinition Class See Also Send Feedback
Indicates if the schedule displays each element on a separate row or combines multiple grouped elements onto the same row.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool IsItemized { get; set; }
Visual Basic
Public Property IsItemized As Boolean
    Get
    Set
Visual C++
public:
property bool IsItemized {
    bool get ();
    void set (bool value);
}

Field Value

True if the schedule displays each element on a separate row. False if multiple grouped elements are combined on the same row.

Remarks

In an itemized schedule, each scheduled element is displayed on a separate row.

In a non-itemized schedule, elements that are grouped together according to the schedule's grouping criteria are combined onto a single row. For example, if a schedule is grouped by Level and Type, elements having the same Level and Type will appear on the same row. In non-itemized schedules, the Count field can be used to display the number of elements on the row, and totaled fields will display the sum of the values from all elements on the row. If a field is not totaled and the elements on the row have different values for the field, an empty cell will be displayed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: This ScheduleDefinition is a key schedule.

See Also

ScheduleDefinition Class


IsMaterialTakeoff Property

[image]

Revit 2024 API
ScheduleDefinition..::..IsMaterialTakeoff Property
ScheduleDefinition Class See Also Send Feedback
Indicates if the schedule is a material takeoff.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool IsMaterialTakeoff { get; }
Visual Basic
Public ReadOnly Property IsMaterialTakeoff As Boolean
    Get
Visual C++
public:
property bool IsMaterialTakeoff {
    bool get ();
}

Remarks

A material takeoff is a schedule that displays information about the materials that make up elements in the model. Unlike regular schedules where each row (before grouping) represents a single element, each row in a material takeoff represents a single <element, material> pair.

See Also

ScheduleDefinition Class


IsValidObject Property

[image]

Revit 2024 API
ScheduleDefinition..::..IsValidObject Property
ScheduleDefinition Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ScheduleDefinition Class


ShowGrandTotal Property

[image]

Revit 2024 API
ScheduleDefinition..::..ShowGrandTotal Property
ScheduleDefinition Class See Also Send Feedback
Indicates if a grand total row should be displayed at the bottom of the schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool ShowGrandTotal { get; set; }
Visual Basic
Public Property ShowGrandTotal As Boolean
    Get
    Set
Visual C++
public:
property bool ShowGrandTotal {
    bool get ();
    void set (bool value);
}

Field Value

True if a grand total row should be displayed, false otherwise.

Remarks

The grand total row displays totals of each field for which totals are enabled. It can also optionally display a title (see ShowGrandTotalTitle) and a count of elements (see ShowGrandTotalCount).

See Also

ScheduleDefinition Class


ShowGrandTotalCount Property

[image]

Revit 2024 API
ScheduleDefinition..::..ShowGrandTotalCount Property
ScheduleDefinition Class See Also Send Feedback
Indicates if the grand total row should display a count of elements in the schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool ShowGrandTotalCount { get; set; }
Visual Basic
Public Property ShowGrandTotalCount As Boolean
    Get
    Set
Visual C++
public:
property bool ShowGrandTotalCount {
    bool get ();
    void set (bool value);
}

Field Value

True if an element count should be displayed, false otherwise.

Remarks

ShowGrandTotalCount can only be enabled if ShowGrandTotal is enabled.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: Display of a grand total row is not enabled.

See Also

ScheduleDefinition Class


ShowGrandTotalTitle Property

[image]

Revit 2024 API
ScheduleDefinition..::..ShowGrandTotalTitle Property
ScheduleDefinition Class See Also Send Feedback
Indicates if the grand total row should display a title.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool ShowGrandTotalTitle { get; set; }
Visual Basic
Public Property ShowGrandTotalTitle As Boolean
    Get
    Set
Visual C++
public:
property bool ShowGrandTotalTitle {
    bool get ();
    void set (bool value);
}

Field Value

True if a title should be displayed, false otherwise.

Remarks

The title consists of the text "Grand total".

ShowGrandTotalTitle can only be enabled if ShowGrandTotal is enabled.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: Display of a grand total row is not enabled.

See Also

ScheduleDefinition Class


ShowHeaders Property

[image]

Revit 2024 API
ScheduleDefinition..::..ShowHeaders Property
ScheduleDefinition Class See Also Send Feedback
Indicates if the headers will be displayed in the schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015 Subscription Update

Syntax

C#
public bool ShowHeaders { get; set; }
Visual Basic
Public Property ShowHeaders As Boolean
    Get
    Set
Visual C++
public:
property bool ShowHeaders {
    bool get ();
    void set (bool value);
}

See Also

ScheduleDefinition Class


ShowTitle Property

[image]

Revit 2024 API
ScheduleDefinition..::..ShowTitle Property
ScheduleDefinition Class See Also Send Feedback
Indicates if the title will be displayed in the schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015 Subscription Update

Syntax

C#
public bool ShowTitle { get; set; }
Visual Basic
Public Property ShowTitle As Boolean
    Get
    Set
Visual C++
public:
property bool ShowTitle {
    bool get ();
    void set (bool value);
}

See Also

ScheduleDefinition Class


ScheduleField Class

[image]

Revit 2024 API
ScheduleField Class
Members See Also Send Feedback
A field in a schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public class ScheduleField : IDisposable
Visual Basic
Public Class ScheduleField _
    Implements IDisposable
Visual C++
public ref class ScheduleField : IDisposable

Remarks

The ScheduleField class represents a single field in a ScheduleDefinition's list of fields. Each (non-hidden) field becomes a column in the schedule.

Most commonly, a field represents an instance or type parameter of elements appearing in the schedule. Some fields represent parameters of other related elements, like the room that a scheduled element belongs to. Fields can also represent data calculated from other fields in the schedule, specifically Formula and Percentage fields. Another type of field is Custom Field. For this one, the value for each row is computed based on the (sub)elements that are grouped on that row and can have a graphic representation when the schedule is placed on a sheet.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ScheduleField

See Also

ScheduleField Members


ScheduleField Members

[image] [image]

Revit 2024 API
ScheduleField Members
ScheduleField Class Methods Properties See Also Send Feedback

The ScheduleField type exposes the following members.

Methods

 | Name | Description
Public method | CanDisplayMinMax | Indicates if this field can display minimum and maximum values.
Public method | CanTotal | Indicates if totals can be enabled for this field.
Public method | CanTotalByAssemblyType | Indicates if totals by assembly type can be enabled for this field.
Public method | CreatesCircularReferences | Checks whether a field ID would create a circular chain of references when used by the PercentageOf property of this field.
Public method | Dispose | Releases all resources used by the ScheduleField
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCombinedParameters | Gets this field's combine parameter array if applicable
Public method | GetCustomFieldData | Gets the data associated with this custom field. If this field isn't a CustomField will return nullNothingnullptra null reference (Nothing in Visual Basic).
Public method | GetFormatOptions | Gets the FormatOptions to optionally override the default settings in the Units class.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetName | Gets the name of the field.
Public method | GetSchedulableField | Gets a SchedulableField object representing this field.
Public method | GetSpecTypeId | The spec describing values of this field, if applicable.
Public method | GetStyle | Gets the style of this field.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidCombinedParameters | Checks if data is valid for combined parameters
Public method | ResetOverride | Resets the override of this field.
Public method | SetCombinedParameters | Sets this field's combine parameter array if applicable
Public method | SetFormatOptions | Sets the FormatOptions to optionally override the default settings in the Units class.
Public method | SetStyle | Sets the style of this field.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ColumnHeading | The column heading text.
Public property | Definition | The ScheduleDefinition that this field belongs to.
Public property | DisplayType | Indicates the chosen display type for the field.
Public property | FieldId | The ID of the field in the containing ScheduleDefinition.
Public property | FieldIndex | The index of the field in the containing ScheduleDefinition.
Public property | FieldType | The type of data displayed by the field.
Public property | GridColumnWidth | The width of the column in the editable grid view, measured in feet.
Public property | HasSchedulableField | Identifies if this ScheduleField object has access to a SchedulableField. Calculated and combined parameter fields will not have the access.
Public property | HeadingOrientation | The orientation of the column heading text.
Public property | HorizontalAlignment | The horizontal alignment of the column's data.
Public property | IsCalculatedField | Indicates if the field is a calculated field (Formula or Percentage).
Public property | IsCombinedParameterField | Indicates if the field is a combined parameter field.
Public property | IsHidden | Indicates if the field is hidden in the schedule.
Public property | IsOverridden | Indicates if the field is overridden or not.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MultipleValuesCustomText | The custom multiple values text to be used when the schedule field displays multiple element values, used when MultipleValuesDisplayType is set to Custom.
Public property | MultipleValuesDisplayType | Determines the type of multiple value indication to be used when the schedule field displays multiple element values.
Public property | MultipleValuesText | The multiple values text to be used when the schedule field displays multiple element values, as specified by the display type MultipleValuesDisplayType.
Public property | ParameterId | The ID of the parameter displayed by the field.
Public property | PercentageBy | The ID of the grouped schedule field used to calculate percentage totals.
Public property | PercentageOf | The ID of the field to calculate percentages of.
Public property | Schedule | The schedule that this field belongs to.
Public property | SheetColumnWidth | The width of the column on a sheet, measured in feet.
Public property | TotalByAssemblyType | In an assembly schedule view, indicates if totals are calculated for all assembly instances of the same type or only for a single instance.
Public property | VerticalAlignment | The vertical alignment of the column's data.

See Also

ScheduleField Class


ScheduleField Methods

[image] [image]

Revit 2024 API
ScheduleField Methods
ScheduleField Class See Also Send Feedback

The ScheduleField type exposes the following members.

Methods

 | Name | Description
Public method | CanDisplayMinMax | Indicates if this field can display minimum and maximum values.
Public method | CanTotal | Indicates if totals can be enabled for this field.
Public method | CanTotalByAssemblyType | Indicates if totals by assembly type can be enabled for this field.
Public method | CreatesCircularReferences | Checks whether a field ID would create a circular chain of references when used by the PercentageOf property of this field.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCombinedParameters | Gets this field's combine parameter array if applicable
Public method | GetCustomFieldData | Gets the data associated with this custom field. If this field isn't a CustomField will return nullNothingnullptra null reference (Nothing in Visual Basic).
Public method | GetFormatOptions | Gets the FormatOptions to optionally override the default settings in the Units class.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetName | Gets the name of the field.
Public method | GetSchedulableField | Gets a SchedulableField object representing this field.
Public method | GetSpecTypeId | The spec describing values of this field, if applicable.
Public method | GetStyle | Gets the style of this field.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidCombinedParameters | Checks if data is valid for combined parameters
Public method | ResetOverride | Resets the override of this field.
Public method | SetCombinedParameters | Sets this field's combine parameter array if applicable
Public method | SetFormatOptions | Sets the FormatOptions to optionally override the default settings in the Units class.
Public method | SetStyle | Sets the style of this field.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ScheduleField Class


CanDisplayMinMax Method

[image]

Revit 2024 API
ScheduleField..::..CanDisplayMinMax Method
ScheduleField Class See Also Send Feedback
Indicates if this field can display minimum and maximum values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public bool CanDisplayMinMax()
Visual Basic
Public Function CanDisplayMinMax As Boolean
Visual C++
public:
bool CanDisplayMinMax()

Return Value

True if this field can display minimum and maximum values, false otherwise.

See Also

ScheduleField Class


CanTotal Method

[image]

Revit 2024 API
ScheduleField..::..CanTotal Method
ScheduleField Class See Also Send Feedback
Indicates if totals can be enabled for this field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool CanTotal()
Visual Basic
Public Function CanTotal As Boolean
Visual C++
public:
bool CanTotal()

Return Value

True if this field can be totaled, false otherwise.

See Also

ScheduleField Class


CanTotalByAssemblyType Method

[image]

Revit 2024 API
ScheduleField..::..CanTotalByAssemblyType Method
ScheduleField Class See Also Send Feedback
Indicates if totals by assembly type can be enabled for this field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool CanTotalByAssemblyType()
Visual Basic
Public Function CanTotalByAssemblyType As Boolean
Visual C++
public:
bool CanTotalByAssemblyType()

Return Value

True if this field can be totaled by assembly type, false otherwise.

See Also

ScheduleField Class


CreatesCircularReferences Method

[image]

Revit 2024 API
ScheduleField..::..CreatesCircularReferences Method
ScheduleField Class See Also Send Feedback
Checks whether a field ID would create a circular chain of references when used by the PercentageOf property of this field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool CreatesCircularReferences(
    ScheduleFieldId fieldId
)
Visual Basic
Public Function CreatesCircularReferences ( _
    fieldId As ScheduleFieldId _
) As Boolean
Visual C++
public:
bool CreatesCircularReferences(
    ScheduleFieldId^ fieldId
)

Parameters

fieldId
Type: Autodesk.Revit.DB..::..ScheduleFieldId
The field ID to check.

Return Value

True if the field ID would create a circular chain of references, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | fieldId is not InvalidScheduleFieldId or the ID of a field that can be used to calculated percentages.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ScheduleField Class


Dispose Method

[image]

Revit 2024 API
ScheduleField..::..Dispose Method
ScheduleField Class See Also Send Feedback
Releases all resources used by the ScheduleField

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ScheduleField Class


GetCustomFieldData Method

[image]

Revit 2024 API
ScheduleField..::..GetCustomFieldData Method
ScheduleField Class See Also Send Feedback
Gets the data associated with this custom field. If this field isn't a CustomField will return nullNothingnullptra null reference (Nothing in Visual Basic).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public CustomFieldData GetCustomFieldData()
Visual Basic
Public Function GetCustomFieldData As CustomFieldData
Visual C++
public:
CustomFieldData^ GetCustomFieldData()

Return Value

Returns the data associated with this custom field. If this field isn't a CustomField will return nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

ScheduleField Class


GetFormatOptions Method

[image]

Revit 2024 API
ScheduleField..::..GetFormatOptions Method
ScheduleField Class See Also Send Feedback
Gets the FormatOptions to optionally override the default settings in the Units class.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public FormatOptions GetFormatOptions()
Visual Basic
Public Function GetFormatOptions As FormatOptions
Visual C++
public:
FormatOptions^ GetFormatOptions()

Return Value

A copy of the FormatOptions.

See Also

ScheduleField Class


GetName Method

[image]

Revit 2024 API
ScheduleField..::..GetName Method
ScheduleField Class See Also Send Feedback
Gets the name of the field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public string GetName()
Visual Basic
Public Function GetName As String
Visual C++
public:
String^ GetName()

Return Value

The name of the field.

See Also

ScheduleField Class


GetStyle Method

[image]

Revit 2024 API
ScheduleField..::..GetStyle Method
ScheduleField Class See Also Send Feedback
Gets the style of this field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public TableCellStyle GetStyle()
Visual Basic
Public Function GetStyle As TableCellStyle
Visual C++
public:
TableCellStyle^ GetStyle()

See Also

ScheduleField Class


IsValidCombinedParameters Method

[image]

Revit 2024 API
ScheduleField..::..IsValidCombinedParameters Method
ScheduleField Class See Also Send Feedback
Checks if data is valid for combined parameters

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public bool IsValidCombinedParameters(
    IList<TableCellCombinedParameterData> data
)
Visual Basic
Public Function IsValidCombinedParameters ( _
    data As IList(Of TableCellCombinedParameterData) _
) As Boolean
Visual C++
public:
bool IsValidCombinedParameters(
    IList<TableCellCombinedParameterData^>^ data
)

Parameters

data
Type: System.Collections.Generic..::..IList<(Of <(<' TableCellCombinedParameterData >)>)>
data is array of TableCellCombinedParameterData to be set as combined parameters

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ScheduleField Class


ResetOverride Method

[image]

Revit 2024 API
ScheduleField..::..ResetOverride Method
ScheduleField Class See Also Send Feedback
Resets the override of this field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void ResetOverride()
Visual Basic
Public Sub ResetOverride
Visual C++
public:
void ResetOverride()

See Also

ScheduleField Class


SetCombinedParameters Method

[image]

Revit 2024 API
ScheduleField..::..SetCombinedParameters Method
ScheduleField Class See Also Send Feedback
Sets this field's combine parameter array if applicable

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public void SetCombinedParameters(
    IList<TableCellCombinedParameterData> data
)
Visual Basic
Public Sub SetCombinedParameters ( _
    data As IList(Of TableCellCombinedParameterData) _
)
Visual C++
public:
void SetCombinedParameters(
    IList<TableCellCombinedParameterData^>^ data
)

Parameters

data
Type: System.Collections.Generic..::..IList<(Of <(<' TableCellCombinedParameterData >)>)>
data is array of TableCellCombinedParameterData to be set as combined parameters

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ScheduleField Class


SetFormatOptions Method

[image]

Revit 2024 API
ScheduleField..::..SetFormatOptions Method
ScheduleField Class Example See Also Send Feedback
Sets the FormatOptions to optionally override the default settings in the Units class.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void SetFormatOptions(
    FormatOptions formatOptions
)
Visual Basic
Public Sub SetFormatOptions ( _
    formatOptions As FormatOptions _
)
Visual C++
public:
void SetFormatOptions(
    FormatOptions^ formatOptions
)

Parameters

formatOptions
Type: Autodesk.Revit.DB..::..FormatOptions
The FormatOptions.

Remarks

See the UnitType property to determine the unit type of this field.

Examples

CopyC#
// format length units to display in feet and inches format
public void FormatLengthFields(ViewSchedule schedule)
{
    int nFields = schedule.Definition.GetFieldCount();
    for (int n = 0; n < nFields; n++)
    {
        ScheduleField field = schedule.Definition.GetField(n);
        if (field.GetSpecTypeId() == SpecTypeId.Length)
        {
            FormatOptions formatOpts = new FormatOptions();
            formatOpts.UseDefault = false;
            formatOpts.SetUnitTypeId(UnitTypeId.FeetFractionalInches);
            field.SetFormatOptions(formatOpts);
        }
    }
}
CopyVB.NET
' format length units to display in feet and inches format
Public Sub FormatLengthFields(schedule As ViewSchedule)
    Dim nFields As Integer = schedule.Definition.GetFieldCount()
    For n As Integer = 0 To nFields - 1
        Dim field As ScheduleField = schedule.Definition.GetField(n)
        If field.GetSpecTypeId().Equals(SpecTypeId.Length) Then
            Dim formatOpts As New FormatOptions()
            formatOpts.UseDefault = False
            formatOpts.SetUnitTypeId(UnitTypeId.FeetFractionalInches)
            field.SetFormatOptions(formatOpts)
        End If
    Next
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The display unit in formatOptions is not a valid display unit for the unit type of this ScheduleField, or the rounding method in formatOptions is not set to Nearest. See UnitUtils.IsValidDisplayUnit(UnitType, DisplayUnitType), UnitUtils.GetValidDisplayUnits(UnitType) and FormatOptions.RoundingMethod.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ScheduleField Class


SetStyle Method

[image]

Revit 2024 API
ScheduleField..::..SetStyle Method
ScheduleField Class See Also Send Feedback
Sets the style of this field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void SetStyle(
    TableCellStyle style
)
Visual Basic
Public Sub SetStyle ( _
    style As TableCellStyle _
)
Visual C++
public:
void SetStyle(
    TableCellStyle^ style
)

Parameters

style
Type: Autodesk.Revit.DB..::..TableCellStyle

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ScheduleField Class


ScheduleField Properties

[image] [image]

Revit 2024 API
ScheduleField Properties
ScheduleField Class See Also Send Feedback

The ScheduleField type exposes the following members.

Properties

 | Name | Description
Public property | ColumnHeading | The column heading text.
Public property | Definition | The ScheduleDefinition that this field belongs to.
Public property | DisplayType | Indicates the chosen display type for the field.
Public property | FieldId | The ID of the field in the containing ScheduleDefinition.
Public property | FieldIndex | The index of the field in the containing ScheduleDefinition.
Public property | FieldType | The type of data displayed by the field.
Public property | GridColumnWidth | The width of the column in the editable grid view, measured in feet.
Public property | HasSchedulableField | Identifies if this ScheduleField object has access to a SchedulableField. Calculated and combined parameter fields will not have the access.
Public property | HeadingOrientation | The orientation of the column heading text.
Public property | HorizontalAlignment | The horizontal alignment of the column's data.
Public property | IsCalculatedField | Indicates if the field is a calculated field (Formula or Percentage).
Public property | IsCombinedParameterField | Indicates if the field is a combined parameter field.
Public property | IsHidden | Indicates if the field is hidden in the schedule.
Public property | IsOverridden | Indicates if the field is overridden or not.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MultipleValuesCustomText | The custom multiple values text to be used when the schedule field displays multiple element values, used when MultipleValuesDisplayType is set to Custom.
Public property | MultipleValuesDisplayType | Determines the type of multiple value indication to be used when the schedule field displays multiple element values.
Public property | MultipleValuesText | The multiple values text to be used when the schedule field displays multiple element values, as specified by the display type MultipleValuesDisplayType.
Public property | ParameterId | The ID of the parameter displayed by the field.
Public property | PercentageBy | The ID of the grouped schedule field used to calculate percentage totals.
Public property | PercentageOf | The ID of the field to calculate percentages of.
Public property | Schedule | The schedule that this field belongs to.
Public property | SheetColumnWidth | The width of the column on a sheet, measured in feet.
Public property | TotalByAssemblyType | In an assembly schedule view, indicates if totals are calculated for all assembly instances of the same type or only for a single instance.
Public property | VerticalAlignment | The vertical alignment of the column's data.

See Also

ScheduleField Class


ColumnHeading Property

[image]

Revit 2024 API
ScheduleField..::..ColumnHeading Property
ScheduleField Class See Also Send Feedback
The column heading text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public string ColumnHeading { get; set; }
Visual Basic
Public Property ColumnHeading As String
    Get
    Set
Visual C++
public:
property String^ ColumnHeading {
    String^ get ();
    void set (String^ value);
}

Field Value

The heading text.

Remarks

On initial creation of a ScheduleField, the column heading is initialized based on the field name (typically a parameter name).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ScheduleField Class


Definition Property

[image]

Revit 2024 API
ScheduleField..::..Definition Property
ScheduleField Class See Also Send Feedback
The ScheduleDefinition that this field belongs to.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ScheduleDefinition Definition { get; }
Visual Basic
Public ReadOnly Property Definition As ScheduleDefinition
    Get
Visual C++
public:
property ScheduleDefinition^ Definition {
    ScheduleDefinition^ get ();
}

See Also

ScheduleField Class


FieldIndex Property

[image]

Revit 2024 API
ScheduleField..::..FieldIndex Property
ScheduleField Class See Also Send Feedback
The index of the field in the containing ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public int FieldIndex { get; }
Visual Basic
Public ReadOnly Property FieldIndex As Integer
    Get
Visual C++
public:
property int FieldIndex {
    int get ();
}

See Also

ScheduleField Class


GridColumnWidth Property

[image]

Revit 2024 API
ScheduleField..::..GridColumnWidth Property
ScheduleField Class See Also Send Feedback
The width of the column in the editable grid view, measured in feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double GridColumnWidth { get; set; }
Visual Basic
Public Property GridColumnWidth As Double
    Get
    Set
Visual C++
public:
property double GridColumnWidth {
    double get ();
    void set (double value);
}

Remarks

In a schedule with an embedded ScheduleDefinition, a column may display two fields, one from each ScheduleDefinition. In that case, the larger of the two widths is used.

It is always aligned with the SheetColumnWidth.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: gridColumnWidth is negative.

See Also

ScheduleField Class


HasSchedulableField Property

[image]

Revit 2024 API
ScheduleField..::..HasSchedulableField Property
ScheduleField Class See Also Send Feedback
Identifies if this ScheduleField object has access to a SchedulableField. Calculated and combined parameter fields will not have the access.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool HasSchedulableField { get; }
Visual Basic
Public ReadOnly Property HasSchedulableField As Boolean
    Get
Visual C++
public:
property bool HasSchedulableField {
    bool get ();
}

See Also

ScheduleField Class


HeadingOrientation Property

[image]

Revit 2024 API
ScheduleField..::..HeadingOrientation Property
ScheduleField Class See Also Send Feedback
The orientation of the column heading text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ScheduleHeadingOrientation HeadingOrientation { get; set; }
Visual Basic
Public Property HeadingOrientation As ScheduleHeadingOrientation
    Get
    Set
Visual C++
public:
property ScheduleHeadingOrientation HeadingOrientation {
    ScheduleHeadingOrientation get ();
    void set (ScheduleHeadingOrientation value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

ScheduleField Class


IsCalculatedField Property

[image]

Revit 2024 API
ScheduleField..::..IsCalculatedField Property
ScheduleField Class See Also Send Feedback
Indicates if the field is a calculated field (Formula or Percentage).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsCalculatedField { get; }
Visual Basic
Public ReadOnly Property IsCalculatedField As Boolean
    Get
Visual C++
public:
property bool IsCalculatedField {
    bool get ();
}

See Also

ScheduleField Class


IsCombinedParameterField Property

[image]

Revit 2024 API
ScheduleField..::..IsCombinedParameterField Property
ScheduleField Class See Also Send Feedback
Indicates if the field is a combined parameter field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public bool IsCombinedParameterField { get; }
Visual Basic
Public ReadOnly Property IsCombinedParameterField As Boolean
    Get
Visual C++
public:
property bool IsCombinedParameterField {
    bool get ();
}

See Also

ScheduleField Class


IsOverridden Property

[image]

Revit 2024 API
ScheduleField..::..IsOverridden Property
ScheduleField Class See Also Send Feedback
Indicates if the field is overridden or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsOverridden { get; }
Visual Basic
Public ReadOnly Property IsOverridden As Boolean
    Get
Visual C++
public:
property bool IsOverridden {
    bool get ();
}

See Also

ScheduleField Class


IsValidObject Property

[image]

Revit 2024 API
ScheduleField..::..IsValidObject Property
ScheduleField Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ScheduleField Class


MultipleValuesCustomText Property

[image]

Revit 2024 API
ScheduleField..::..MultipleValuesCustomText Property
ScheduleField Class See Also Send Feedback
The custom multiple values text to be used when the schedule field displays multiple element values, used when MultipleValuesDisplayType is set to Custom.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public string MultipleValuesCustomText { get; set; }
Visual Basic
Public Property MultipleValuesCustomText As String
    Get
    Set
Visual C++
public:
property String^ MultipleValuesCustomText {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ScheduleField Class


MultipleValuesDisplayType Property

[image]

Revit 2024 API
ScheduleField..::..MultipleValuesDisplayType Property
ScheduleField Class See Also Send Feedback
Determines the type of multiple value indication to be used when the schedule field displays multiple element values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public ScheduleFieldMultipleValuesDisplayType MultipleValuesDisplayType { get; set; }
Visual Basic
Public Property MultipleValuesDisplayType As ScheduleFieldMultipleValuesDisplayType
    Get
    Set
Visual C++
public:
property ScheduleFieldMultipleValuesDisplayType MultipleValuesDisplayType {
    ScheduleFieldMultipleValuesDisplayType get ();
    void set (ScheduleFieldMultipleValuesDisplayType value);
}

Remarks

The default display type is Project, indicating that the project [!:Autodesk::Revit::DB::MultipleValuesIndicationSettings::Value] setting will be used.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

ScheduleField Class


MultipleValuesText Property

[image]

Revit 2024 API
ScheduleField..::..MultipleValuesText Property
ScheduleField Class See Also Send Feedback
The multiple values text to be used when the schedule field displays multiple element values, as specified by the display type MultipleValuesDisplayType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public string MultipleValuesText { get; }
Visual Basic
Public ReadOnly Property MultipleValuesText As String
    Get
Visual C++
public:
property String^ MultipleValuesText {
    String^ get ();
}

See Also

ScheduleField Class


PercentageBy Property

[image]

Revit 2024 API
ScheduleField..::..PercentageBy Property
ScheduleField Class See Also Send Feedback
The ID of the grouped schedule field used to calculate percentage totals.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ScheduleFieldId PercentageBy { get; set; }
Visual Basic
Public Property PercentageBy As ScheduleFieldId
    Get
    Set
Visual C++
public:
property ScheduleFieldId^ PercentageBy {
    ScheduleFieldId^ get ();
    void set (ScheduleFieldId^ value);
}

Field Value

InvalidElementId or the ID of the grouped field.

Remarks

A Percentage field calculates what percent of the total of another field each element represents. If PercentageBy is InvalidScheduleFieldId, the total is of all elements in the schedule. If PercentageBy is the ID of one of the fields that the schedule is grouped by, the total is of all elements in that group.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: percentageBy is not InvalidScheduleFieldId or the ID of a field that the schedule is grouped by.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: This ScheduleField is not a percentage field.

See Also

ScheduleField Class


PercentageOf Property

[image]

Revit 2024 API
ScheduleField..::..PercentageOf Property
ScheduleField Class See Also Send Feedback
The ID of the field to calculate percentages of.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ScheduleFieldId PercentageOf { get; set; }
Visual Basic
Public Property PercentageOf As ScheduleFieldId
    Get
    Set
Visual C++
public:
property ScheduleFieldId^ PercentageOf {
    ScheduleFieldId^ get ();
    void set (ScheduleFieldId^ value);
}

Field Value

The ID of the field, or InvalidElementId.

Remarks

A Percentage field calculates what percent of the total of another field each element represents. PercentageOf is the ID of the field used to calculate percentages. If PercentageOf is InvalidScheduleFieldId, no data is displayed.

Percentages can only be calculated for numeric fields. The Count field and other percentage fields cannot be used to calculate percentages.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: percentageOf is not InvalidScheduleFieldId or the ID of a field that can be used to calculated percentages. -or- When setting this property: percentageOf would create a circular chain of references.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: This ScheduleField is not a percentage field.

See Also

ScheduleField Class


Schedule Property

[image]

Revit 2024 API
ScheduleField..::..Schedule Property
ScheduleField Class See Also Send Feedback
The schedule that this field belongs to.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ViewSchedule Schedule { get; }
Visual Basic
Public ReadOnly Property Schedule As ViewSchedule
    Get
Visual C++
public:
property ViewSchedule^ Schedule {
    ViewSchedule^ get ();
}

See Also

ScheduleField Class


SheetColumnWidth Property

[image]

Revit 2024 API
ScheduleField..::..SheetColumnWidth Property
ScheduleField Class See Also Send Feedback
The width of the column on a sheet, measured in feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double SheetColumnWidth { get; set; }
Visual Basic
Public Property SheetColumnWidth As Double
    Get
    Set
Visual C++
public:
property double SheetColumnWidth {
    double get ();
    void set (double value);
}

Field Value

The width of the column.

Remarks

In a schedule with an embedded ScheduleDefinition, a column may display two fields, one from each ScheduleDefinition. In that case, the larger of the two widths is used.

It is always aligned with the GridColumnWidth.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: sheetColumnWidth is negative.

See Also

ScheduleField Class


TotalByAssemblyType Property

[image]

Revit 2024 API
ScheduleField..::..TotalByAssemblyType Property
ScheduleField Class See Also Send Feedback
In an assembly schedule view, indicates if totals are calculated for all assembly instances of the same type or only for a single instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool TotalByAssemblyType { get; set; }
Visual Basic
Public Property TotalByAssemblyType As Boolean
    Get
    Set
Visual C++
public:
property bool TotalByAssemblyType {
    bool get ();
    void set (bool value);
}

Field Value

True if totals are calculated for all assembly instances. False if totals are calculated for one instance.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: This ScheduleField cannot be totaled by assembly type. -or- When setting this property: Totals are not enabled for this ScheduleField.

See Also

ScheduleField Class


ScheduleFieldId Members

[image] [image]

Revit 2024 API
ScheduleFieldId Members
ScheduleFieldId Class Constructors Methods Operators Properties See Also Send Feedback

The ScheduleFieldId type exposes the following members.

Constructors

 | Name | Description
Public method | ScheduleFieldId | Initializes a new instance of the ScheduleFieldId class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | GetHashCode | Gets the integer value of the id as hash code (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Gets a String representation of the integer value of the id. (Overrides Object..::..ToString()()()().)

Operators

Name | Description
Equality | Determines whether two ScheduleFieldIds are the same.
Inequality | Determines whether two ScheduleFieldId are different.

Properties

 | Name | Description
Public property | IntegerValue | Provides the value of the ScheduleFieldId as an integer.
 | InvalidScheduleFieldId | Get the invalid ScheduleFieldId whose IntegerValue is -1.

See Also

ScheduleFieldId Class


ScheduleFieldId Constructor

[image]

Revit 2024 API
ScheduleFieldId Constructor
ScheduleFieldId Class See Also Send Feedback
Initializes a new instance of the ScheduleFieldId class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ScheduleFieldId(
    int id
)
Visual Basic
Public Sub New ( _
    id As Integer _
)
Visual C++
public:
ScheduleFieldId(
    int id
)

Parameters

id
Type: System..::..Int32

See Also

ScheduleFieldId Class


ScheduleFieldId Methods

[image] [image]

Revit 2024 API
ScheduleFieldId Methods
ScheduleFieldId Class See Also Send Feedback

The ScheduleFieldId type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | GetHashCode | Gets the integer value of the id as hash code (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Gets a String representation of the integer value of the id. (Overrides Object..::..ToString()()()().)

See Also

ScheduleFieldId Class


GetHashCode Method

[image]

Revit 2024 API
ScheduleFieldId..::..GetHashCode Method
ScheduleFieldId Class See Also Send Feedback
Gets the integer value of the id as hash code

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

ScheduleFieldId Class


ToString Method

[image]

Revit 2024 API
ScheduleFieldId..::..ToString Method
ScheduleFieldId Class See Also Send Feedback
Gets a String representation of the integer value of the id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

ScheduleFieldId Class


ScheduleFieldId Operators

[image] [image]

Revit 2024 API
ScheduleFieldId Operators
ScheduleFieldId Class See Also Send Feedback

The ScheduleFieldId type exposes the following members.

Operators

Name | Description
Equality | Determines whether two ScheduleFieldIds are the same.
Inequality | Determines whether two ScheduleFieldId are different.

See Also

ScheduleFieldId Class


Equality Operator

[image]

Revit 2024 API
ScheduleFieldId..::..Equality Operator
ScheduleFieldId Class See Also Send Feedback
Determines whether two ScheduleFieldIds are the same.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static bool operator ==(
    ScheduleFieldId first,
    ScheduleFieldId second
)
Visual Basic
Public Shared Operator = ( _
    first As ScheduleFieldId, _
    second As ScheduleFieldId _
) As Boolean
Visual C++
public:
static bool operator ==(
    ScheduleFieldId^ first,
    ScheduleFieldId^ second
)

Parameters

first
Type: Autodesk.Revit.DB..::..ScheduleFieldId
The first ScheduleFieldId.
second
Type: Autodesk.Revit.DB..::..ScheduleFieldId
The second ScheduleFieldId.

Return Value

True if the ScheduleFieldIds are the same, otherwise false.

See Also

ScheduleFieldId Class


Inequality Operator

[image]

Revit 2024 API
ScheduleFieldId..::..Inequality Operator
ScheduleFieldId Class See Also Send Feedback
Determines whether two ScheduleFieldId are different.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static bool operator !=(
    ScheduleFieldId first,
    ScheduleFieldId second
)
Visual Basic
Public Shared Operator <> ( _
    first As ScheduleFieldId, _
    second As ScheduleFieldId _
) As Boolean
Visual C++
public:
static bool operator !=(
    ScheduleFieldId^ first,
    ScheduleFieldId^ second
)

Parameters

first
Type: Autodesk.Revit.DB..::..ScheduleFieldId
The first ScheduleFieldId.
second
Type: Autodesk.Revit.DB..::..ScheduleFieldId
The second ScheduleFieldId.

Return Value

True if the ScheduleFieldId are different, otherwise false.

See Also

ScheduleFieldId Class


ScheduleFieldId Properties

[image] [image]

Revit 2024 API
ScheduleFieldId Properties
ScheduleFieldId Class See Also Send Feedback

The ScheduleFieldId type exposes the following members.

Properties

 | Name | Description
Public property | IntegerValue | Provides the value of the ScheduleFieldId as an integer.
 | InvalidScheduleFieldId | Get the invalid ScheduleFieldId whose IntegerValue is -1.

See Also

ScheduleFieldId Class


InvalidScheduleFieldId Property

[image]

Revit 2024 API
ScheduleFieldId..::..InvalidScheduleFieldId Property
ScheduleFieldId Class See Also Send Feedback
Get the invalid ScheduleFieldId whose IntegerValue is -1.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ScheduleFieldId InvalidScheduleFieldId { get; }
Visual Basic
Public Shared ReadOnly Property InvalidScheduleFieldId As ScheduleFieldId
    Get
Visual C++
public:
static property ScheduleFieldId^ InvalidScheduleFieldId {
    ScheduleFieldId^ get ();
}

See Also

ScheduleFieldId Class


ScheduleFieldType Enumeration

[image]

Revit 2024 API
ScheduleFieldType Enumeration
See Also Send Feedback
The type of data displayed in a schedule field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Since: 2013

Syntax

C#
public enum ScheduleFieldType
Visual Basic
Public Enumeration ScheduleFieldType
Visual C++
public enum class ScheduleFieldType

Members

Member name | Description
Instance | An instance parameter of the scheduled elements. All shared parameters also use this type, regardless of whether they are instance or type parameters.
ElementType | A type parameter of the scheduled elements.
Count | The number of elements appearing on the schedule row.
ViewBased

A specialized type of field used for a few parameters whose displayed values can change based on the settings of the view:

  • ROOM_AREA and ROOM_PERIMETER in room and space schedules.
  • PROJECT_REVISION_REVISION_NUM in revision schedules.
  • KEYNOTE_NUMBER in keynote legends that are numbered by sheet.
Formula | A formula calculated from the values of other fields in the schedule.
Percentage | A value indicating what percent of the total of another field each element represents.
Room | A parameter of the room that a scheduled element belongs to.
FromRoom | A parameter of the room on the "from" side of a door or window.
ToRoom | A parameter of the room on the "to" side of a door or window.
ProjectInfo | A parameter of the Project Info element in the project that the scheduled element belongs to, which may be a linked file. Only allowed in schedules that include elements from linked files.
Material | In a material takeoff, a parameter of one of the materials of a scheduled element.
MaterialQuantity | In a material takeoff, a value representing how a particular material is used within a scheduled element. The parameter ID can be MATERIAL_AREA, MATERIAL_VOLUME, or MATERIAL_ASPAINT.
RevitLinkInstance | A parameter of the RevitLinkInstance that an element in a linked file belongs to. Currently RVT_LINK_INSTANCE_NAME is the only supported parameter. Only allowed in schedules that include elements from linked files.
RevitLinkType | A parameter of the RevitLinkType that an element in a linked file belongs to. Currently RVT_LINK_FILE_NAME_WITHOUT_EXT is the only supported parameter. Only allowed in schedules that include elements from linked files.
StructuralMaterial | A parameter of the structural material of a scheduled element.
Space | A parameter of the space that a scheduled element belongs to.
Analytical | A parameter of the analytical element of a scheduled physical element.
PhysicalType | A type parameter of the physical element of a scheduled analytical element.
PhysicalInstance | An instance parameter of the physical element of a scheduled analytical element.
CombinedParameter | Combine parameters of the types that display in a specific part of a schedule. The values for the combined parameters will display in the same cell separated by a slash or other separator. You can add a prefix, suffix or sample value to the parameter.
HostCount | Counts the number of hosts with different mark.
CustomField | For this field type the value for each row is computed based on the (sub)elements that are grouped on that row and can have a graphic representation when the schedule is placed on a sheet.
Revision | A parameter of the revision element that the scheduled revision cloud element belongs to.
Views | A parameter of the primary view owning an annotation element (e.g. Revision Cloud)
Sheets | A parameter of the sheet view owning an annotation element (e.g. Revision Cloud)

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


ScheduleFilter Class

[image]

Revit 2024 API
ScheduleFilter Class
Members See Also Send Feedback
A filter in a schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public class ScheduleFilter : IDisposable
Visual Basic
Public Class ScheduleFilter _
    Implements IDisposable
Visual C++
public ref class ScheduleFilter : IDisposable

Remarks

The ScheduleFilter class represents a single filter in a schedule. A filter is a condition that must be satisfied for an element to appear in the schedule. All filters must be satisfied for an element to appear in the schedule.

A schedule can be filtered by data that is not displayed in the schedule by marking the field used for filtering as hidden using the ScheduleField.IsHidden property.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ScheduleFilter

See Also

ScheduleFilter Members


ScheduleFilter Members

[image] [image]

Revit 2024 API
ScheduleFilter Members
ScheduleFilter Class Constructors Methods Properties See Also Send Feedback

The ScheduleFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ScheduleFilter()()()() | Creates a new ScheduleFilter.
Public method | ScheduleFilter(ScheduleFieldId, ScheduleFilterType) | Creates a new ScheduleFilter.
Public method | ScheduleFilter(ScheduleFieldId, ScheduleFilterType, ElementId) | Creates a new ScheduleFilter.
Public method | ScheduleFilter(ScheduleFieldId, ScheduleFilterType, Double) | Creates a new ScheduleFilter.
Public method | ScheduleFilter(ScheduleFieldId, ScheduleFilterType, Int32) | Creates a new ScheduleFilter.
Public method | ScheduleFilter(ScheduleFieldId, ScheduleFilterType, String) | Creates a new ScheduleFilter.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ScheduleFilter
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDoubleValue | Gets the filter value for a filter using a double value.
Public method | GetElementIdValue | Gets the filter value for a filter using an ElementId value.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIntegerValue | Gets the filter value for a filter using an integer value.
Public method | GetStringValue | Gets the filter value for a filter using a string value.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetNullValue | Sets the filter to have no specified value (used for HasParameter filters).
Public method | SetValue(Double) | Set the filter value to a double.
Public method | SetValue(Int32) | Set the filter value to an integer.
Public method | SetValue(String) | Set the filter value to a string.
Public method | SetValue(ElementId) | Set the filter value to an ElementId.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FieldId | The ID of the field used to filter the schedule.
Public property | FilterType | The filter type.
Public property | IsDoubleValue | Indicates if the filter has a double value.
Public property | IsElementIdValue | Indicates if the filter has an ElementId value.
Public property | IsIntegerValue | Indicates if the filter has an integer value.
Public property | IsNullValue | Indicates if the filter has no specified value.
Public property | IsStringValue | Indicates if the filter has a string value.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ScheduleFilter Class


ScheduleFilter Constructor

[image]

Revit 2024 API
ScheduleFilter Constructor
ScheduleFilter Class See Also Send Feedback
Creates a new ScheduleFilter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ScheduleFilter()
Visual Basic
Public Sub New
Visual C++
public:
ScheduleFilter()

See Also

ScheduleFilter Class
ScheduleFilter Overload


ScheduleFilter Constructor (ScheduleFieldId, ScheduleFilterType, ElementId)

[image]

Revit 2024 API
ScheduleFilter Constructor (ScheduleFieldId, ScheduleFilterType, ElementId)
ScheduleFilter Class See Also Send Feedback
Creates a new ScheduleFilter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ScheduleFilter(
    ScheduleFieldId fieldId,
    ScheduleFilterType filterType,
    ElementId value
)
Visual Basic
Public Sub New ( _
    fieldId As ScheduleFieldId, _
    filterType As ScheduleFilterType, _
    value As ElementId _
)
Visual C++
public:
ScheduleFilter(
    ScheduleFieldId^ fieldId,
    ScheduleFilterType filterType,
    ElementId^ value
)

Parameters

fieldId
Type: Autodesk.Revit.DB..::..ScheduleFieldId
The ID of the field used to filter the schedule.
filterType
Type: Autodesk.Revit.DB..::..ScheduleFilterType
The filter type.
value
Type: Autodesk.Revit.DB..::..ElementId
The filter value for a filter using an ElementId value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

ScheduleFilter Class
ScheduleFilter Overload


ScheduleFilter Constructor (ScheduleFieldId, ScheduleFilterType, Double)

[image]

Revit 2024 API
ScheduleFilter Constructor (ScheduleFieldId, ScheduleFilterType, Double)
ScheduleFilter Class See Also Send Feedback
Creates a new ScheduleFilter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ScheduleFilter(
    ScheduleFieldId fieldId,
    ScheduleFilterType filterType,
    double value
)
Visual Basic
Public Sub New ( _
    fieldId As ScheduleFieldId, _
    filterType As ScheduleFilterType, _
    value As Double _
)
Visual C++
public:
ScheduleFilter(
    ScheduleFieldId^ fieldId,
    ScheduleFilterType filterType,
    double value
)

Parameters

fieldId
Type: Autodesk.Revit.DB..::..ScheduleFieldId
The ID of the field used to filter the schedule.
filterType
Type: Autodesk.Revit.DB..::..ScheduleFilterType
The filter type.
value
Type: System..::..Double
The filter value for a filter using a double value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

ScheduleFilter Class
ScheduleFilter Overload


ScheduleFilter Constructor (ScheduleFieldId, ScheduleFilterType, Int32)

[image]

Revit 2024 API
ScheduleFilter Constructor (ScheduleFieldId, ScheduleFilterType, Int32)
ScheduleFilter Class See Also Send Feedback
Creates a new ScheduleFilter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ScheduleFilter(
    ScheduleFieldId fieldId,
    ScheduleFilterType filterType,
    int value
)
Visual Basic
Public Sub New ( _
    fieldId As ScheduleFieldId, _
    filterType As ScheduleFilterType, _
    value As Integer _
)
Visual C++
public:
ScheduleFilter(
    ScheduleFieldId^ fieldId,
    ScheduleFilterType filterType,
    int value
)

Parameters

fieldId
Type: Autodesk.Revit.DB..::..ScheduleFieldId
The ID of the field used to filter the schedule.
filterType
Type: Autodesk.Revit.DB..::..ScheduleFilterType
The filter type.
value
Type: System..::..Int32
The filter value for a filter using an integer value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

ScheduleFilter Class
ScheduleFilter Overload


ScheduleFilter Constructor (ScheduleFieldId, ScheduleFilterType, String)

[image]

Revit 2024 API
ScheduleFilter Constructor (ScheduleFieldId, ScheduleFilterType, String)
ScheduleFilter Class See Also Send Feedback
Creates a new ScheduleFilter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ScheduleFilter(
    ScheduleFieldId fieldId,
    ScheduleFilterType filterType,
    string value
)
Visual Basic
Public Sub New ( _
    fieldId As ScheduleFieldId, _
    filterType As ScheduleFilterType, _
    value As String _
)
Visual C++
public:
ScheduleFilter(
    ScheduleFieldId^ fieldId,
    ScheduleFilterType filterType,
    String^ value
)

Parameters

fieldId
Type: Autodesk.Revit.DB..::..ScheduleFieldId
The ID of the field used to filter the schedule.
filterType
Type: Autodesk.Revit.DB..::..ScheduleFilterType
The filter type.
value
Type: System..::..String
The filter value for a filter using a string value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

ScheduleFilter Class
ScheduleFilter Overload


Dispose Method

[image]

Revit 2024 API
ScheduleFilter..::..Dispose Method
ScheduleFilter Class See Also Send Feedback
Releases all resources used by the ScheduleFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ScheduleFilter Class


GetDoubleValue Method

[image]

Revit 2024 API
ScheduleFilter..::..GetDoubleValue Method
ScheduleFilter Class See Also Send Feedback
Gets the filter value for a filter using a double value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double GetDoubleValue()
Visual Basic
Public Function GetDoubleValue As Double
Visual C++
public:
double GetDoubleValue()

Return Value

The filter value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The filter value is not a double.

See Also

ScheduleFilter Class


GetElementIdValue Method

[image]

Revit 2024 API
ScheduleFilter..::..GetElementIdValue Method
ScheduleFilter Class See Also Send Feedback
Gets the filter value for a filter using an ElementId value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ElementId GetElementIdValue()
Visual Basic
Public Function GetElementIdValue As ElementId
Visual C++
public:
ElementId^ GetElementIdValue()

Return Value

The filter value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The filter value is not an ElementId.

See Also

ScheduleFilter Class


GetStringValue Method

[image]

Revit 2024 API
ScheduleFilter..::..GetStringValue Method
ScheduleFilter Class See Also Send Feedback
Gets the filter value for a filter using a string value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public string GetStringValue()
Visual Basic
Public Function GetStringValue As String
Visual C++
public:
String^ GetStringValue()

Return Value

The filter value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The filter value is not a string.

See Also

ScheduleFilter Class


SetNullValue Method

[image]

Revit 2024 API
ScheduleFilter..::..SetNullValue Method
ScheduleFilter Class See Also Send Feedback
Sets the filter to have no specified value (used for HasParameter filters).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void SetNullValue()
Visual Basic
Public Sub SetNullValue
Visual C++
public:
void SetNullValue()

See Also

ScheduleFilter Class


SetValue Method (Double)

[image]

Revit 2024 API
ScheduleFilter..::..SetValue Method (Double)
ScheduleFilter Class See Also Send Feedback
Set the filter value to a double.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void SetValue(
    double value
)
Visual Basic
Public Sub SetValue ( _
    value As Double _
)
Visual C++
public:
void SetValue(
    double value
)

Parameters

value
Type: System..::..Double
The filter value.

See Also

ScheduleFilter Class
SetValue Overload


SetValue Method (Int32)

[image]

Revit 2024 API
ScheduleFilter..::..SetValue Method (Int32)
ScheduleFilter Class See Also Send Feedback
Set the filter value to an integer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void SetValue(
    int value
)
Visual Basic
Public Sub SetValue ( _
    value As Integer _
)
Visual C++
public:
void SetValue(
    int value
)

Parameters

value
Type: System..::..Int32
The filter value.

See Also

ScheduleFilter Class
SetValue Overload


SetValue Method (String)

[image]

Revit 2024 API
ScheduleFilter..::..SetValue Method (String)
ScheduleFilter Class See Also Send Feedback
Set the filter value to a string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void SetValue(
    string string
)
Visual Basic
Public Sub SetValue ( _
    string As String _
)
Visual C++
public:
void SetValue(
    String^ string
)

Parameters

string
Type: System..::..String
The filter value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ScheduleFilter Class
SetValue Overload


SetValue Method (ElementId)

[image]

Revit 2024 API
ScheduleFilter..::..SetValue Method (ElementId)
ScheduleFilter Class See Also Send Feedback
Set the filter value to an ElementId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void SetValue(
    ElementId id
)
Visual Basic
Public Sub SetValue ( _
    id As ElementId _
)
Visual C++
public:
void SetValue(
    ElementId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::..ElementId
The filter value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ScheduleFilter Class
SetValue Overload


ScheduleFilter Properties

[image] [image]

Revit 2024 API
ScheduleFilter Properties
ScheduleFilter Class See Also Send Feedback

The ScheduleFilter type exposes the following members.

Properties

 | Name | Description
Public property | FieldId | The ID of the field used to filter the schedule.
Public property | FilterType | The filter type.
Public property | IsDoubleValue | Indicates if the filter has a double value.
Public property | IsElementIdValue | Indicates if the filter has an ElementId value.
Public property | IsIntegerValue | Indicates if the filter has an integer value.
Public property | IsNullValue | Indicates if the filter has no specified value.
Public property | IsStringValue | Indicates if the filter has a string value.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ScheduleFilter Class


FieldId Property

[image]

Revit 2024 API
ScheduleFilter..::..FieldId Property
ScheduleFilter Class See Also Send Feedback
The ID of the field used to filter the schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ScheduleFieldId FieldId { get; set; }
Visual Basic
Public Property FieldId As ScheduleFieldId
    Get
    Set
Visual C++
public:
property ScheduleFieldId^ FieldId {
    ScheduleFieldId^ get ();
    void set (ScheduleFieldId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ScheduleFilter Class


FilterType Property

[image]

Revit 2024 API
ScheduleFilter..::..FilterType Property
ScheduleFilter Class See Also Send Feedback
The filter type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ScheduleFilterType FilterType { get; set; }
Visual Basic
Public Property FilterType As ScheduleFilterType
    Get
    Set
Visual C++
public:
property ScheduleFilterType FilterType {
    ScheduleFilterType get ();
    void set (ScheduleFilterType value);
}

Remarks

See ScheduleFilterType for details.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

ScheduleFilter Class


IsDoubleValue Property

[image]

Revit 2024 API
ScheduleFilter..::..IsDoubleValue Property
ScheduleFilter Class See Also Send Feedback
Indicates if the filter has a double value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool IsDoubleValue { get; }
Visual Basic
Public ReadOnly Property IsDoubleValue As Boolean
    Get
Visual C++
public:
property bool IsDoubleValue {
    bool get ();
}

See Also

ScheduleFilter Class


IsIntegerValue Property

[image]

Revit 2024 API
ScheduleFilter..::..IsIntegerValue Property
ScheduleFilter Class See Also Send Feedback
Indicates if the filter has an integer value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool IsIntegerValue { get; }
Visual Basic
Public ReadOnly Property IsIntegerValue As Boolean
    Get
Visual C++
public:
property bool IsIntegerValue {
    bool get ();
}

See Also

ScheduleFilter Class


IsNullValue Property

[image]

Revit 2024 API
ScheduleFilter..::..IsNullValue Property
ScheduleFilter Class See Also Send Feedback
Indicates if the filter has no specified value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool IsNullValue { get; }
Visual Basic
Public ReadOnly Property IsNullValue As Boolean
    Get
Visual C++
public:
property bool IsNullValue {
    bool get ();
}

See Also

ScheduleFilter Class


IsStringValue Property

[image]

Revit 2024 API
ScheduleFilter..::..IsStringValue Property
ScheduleFilter Class See Also Send Feedback
Indicates if the filter has a string value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool IsStringValue { get; }
Visual Basic
Public ReadOnly Property IsStringValue As Boolean
    Get
Visual C++
public:
property bool IsStringValue {
    bool get ();
}

See Also

ScheduleFilter Class


ScheduleFilterType Enumeration

[image]

Revit 2024 API
ScheduleFilterType Enumeration
See Also Send Feedback
Type of schedule filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public enum ScheduleFilterType
Visual Basic
Public Enumeration ScheduleFilterType
Visual C++
public enum class ScheduleFilterType

Members

Member name | Description
Invalid | An invalid filter. Do not use.
HasParameter | The element has the parameter specified by the field. Used with shared parameters. No value is specified for this filter type.
Equal | The field value is equal to the specified value.
NotEqual | The field value is not equal to the specified value.
GreaterThan | The field value is greater than the specified value.
GreaterThanOrEqual | The field value is greater than or equal to the specified value.
LessThan | Less The field value is less than to the specified value.
LessThanOrEqual | The field value is less than or equal to the specified value.
Contains | For a string field, the field value contains the specified string.
NotContains | For a string field, the field value does not contain the specified string.
BeginsWith | For a string field, the field value begins with the specified string.
NotBeginsWith | For a string field, the field value does not begin with the specified string.
EndsWith | For a string field, the field value ends with specified string.
NotEndsWith | For a string field, the field value does not end with the specified string.
IsAssociatedWithGlobalParameter | The field is associated with a specified global parameter of a compatible type
IsNotAssociatedWithGlobalParameter | The field is not associated with a specified global parameter of a compatible type
HasValue | The element has a value for the specified parameter. No value is specified.
HasNoValue | The element does not have a value for the specified parameter. No value is specified.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


ScheduleHeadingOrientation Enumeration

[image]

Revit 2024 API
ScheduleHeadingOrientation Enumeration
See Also Send Feedback
Orientation of schedule heading.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Since: 2013

Syntax

C#
public enum ScheduleHeadingOrientation
Visual Basic
Public Enumeration ScheduleHeadingOrientation
Visual C++
public enum class ScheduleHeadingOrientation

Members

Member name | Description
Horizontal | Horizontal
Vertical | Vertical

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


ScheduleHeightsOnSheet Class

[image]

Revit 2024 API
ScheduleHeightsOnSheet Class
Members See Also Send Feedback
Heights information of a schedule on sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022.1

Syntax

C#
public class ScheduleHeightsOnSheet : IDisposable
Visual Basic
Public Class ScheduleHeightsOnSheet _
    Implements IDisposable
Visual C++
public ref class ScheduleHeightsOnSheet : IDisposable

Remarks

This class returns the heights of schedule title, column header and each body row on sheet view.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ScheduleHeightsOnSheet

See Also

ScheduleHeightsOnSheet Members


ScheduleHeightsOnSheet Members

[image] [image]

Revit 2024 API
ScheduleHeightsOnSheet Members
ScheduleHeightsOnSheet Class Methods Properties See Also Send Feedback

The ScheduleHeightsOnSheet type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ScheduleHeightsOnSheet
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBodyRowHeights | Returns each row's height of schedule body on sheet view.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ColumnHeaderHeight | The height of all schedule header part, including the gap line between header and body.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | TitleHeight | The height of schedule title on sheet view.

See Also

ScheduleHeightsOnSheet Class


ScheduleHeightsOnSheet Methods

[image] [image]

Revit 2024 API
ScheduleHeightsOnSheet Methods
ScheduleHeightsOnSheet Class See Also Send Feedback

The ScheduleHeightsOnSheet type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBodyRowHeights | Returns each row's height of schedule body on sheet view.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ScheduleHeightsOnSheet Class


GetBodyRowHeights Method

[image]

Revit 2024 API
ScheduleHeightsOnSheet..::..GetBodyRowHeights Method
ScheduleHeightsOnSheet Class See Also Send Feedback
Returns each row's height of schedule body on sheet view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022.1

Syntax

C#
public IList<double> GetBodyRowHeights()
Visual Basic
Public Function GetBodyRowHeights As IList(Of Double)
Visual C++
public:
IList<double>^ GetBodyRowHeights()

Return Value

Each row's height of schedule body on sheet view.

See Also

ScheduleHeightsOnSheet Class


ScheduleHeightsOnSheet Properties

[image] [image]

Revit 2024 API
ScheduleHeightsOnSheet Properties
ScheduleHeightsOnSheet Class See Also Send Feedback

The ScheduleHeightsOnSheet type exposes the following members.

Properties

 | Name | Description
Public property | ColumnHeaderHeight | The height of all schedule header part, including the gap line between header and body.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | TitleHeight | The height of schedule title on sheet view.

See Also

ScheduleHeightsOnSheet Class


ScheduleHorizontalAlignment Enumeration

[image]

Revit 2024 API
ScheduleHorizontalAlignment Enumeration
See Also Send Feedback
Horizontal alignment of data in a schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Since: 2013

Syntax

C#
public enum ScheduleHorizontalAlignment
Visual Basic
Public Enumeration ScheduleHorizontalAlignment
Visual C++
public enum class ScheduleHorizontalAlignment

Members

Member name | Description
Left | Left aligned
Center | Center aligned
Right | Right aligned

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


ScheduleSheetInstance Class

[image]

Revit 2024 API
ScheduleSheetInstance Class
Members See Also Send Feedback
An element that represents a particular placement of a schedule on a sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public class ScheduleSheetInstance : Element
Visual Basic
Public Class ScheduleSheetInstance _
    Inherits Element
Visual C++
public ref class ScheduleSheetInstance : public Element

Remarks

Use ScheduleSheetInstance.OwnerViewId to find the sheet on which a schedule is placed.

When a schedule is set to filter by sheet and placed on a sheet, it will create a new schedule with elements visible in the Viewport(s) on that sheet. The instance created belongs to the newly created schedule.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ScheduleSheetInstance

See Also

ScheduleSheetInstance Members


ScheduleSheetInstance Members

[image] [image]

Revit 2024 API
ScheduleSheetInstance Members
ScheduleSheetInstance Class Methods Properties See Also Send Feedback

The ScheduleSheetInstance type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create(Document, ElementId, ElementId, XYZ) | Create an instance of a schedule on a sheet.
 | Create(Document, ElementId, ElementId, XYZ, Int32) | Creates an instance of a schedule segment on a sheet.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTitleblockRevisionSchedule | Identifies if this ScheduleSheetInstance is a revision schedule in a titleblock family.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Point | Location on the sheet where the ScheduleInstance is placed (in sheet coordinates).
Public property | Rotation | Rotation of the ScheduleInstance.
Public property | ScheduleId | Id of the primary schedule that generates this ScheduleInstance.
Public property | SegmentIndex | The schedule segment index of this ScheduleSheetInstance.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ScheduleSheetInstance Class


ScheduleSheetInstance Methods

[image] [image]

Revit 2024 API
ScheduleSheetInstance Methods
ScheduleSheetInstance Class See Also Send Feedback

The ScheduleSheetInstance type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create(Document, ElementId, ElementId, XYZ) | Create an instance of a schedule on a sheet.
 | Create(Document, ElementId, ElementId, XYZ, Int32) | Creates an instance of a schedule segment on a sheet.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ScheduleSheetInstance Class


Create Method

[image] [image]

Revit 2024 API
ScheduleSheetInstance..::..Create Method
ScheduleSheetInstance Class See Also Send Feedback

Overload List

Name | Description
Create(Document, ElementId, ElementId, XYZ) | Create an instance of a schedule on a sheet.
Create(Document, ElementId, ElementId, XYZ, Int32) | Creates an instance of a schedule segment on a sheet.

See Also

ScheduleSheetInstance Class
ScheduleSheetInstance Members


Create Method (Document, ElementId, ElementId, XYZ)

[image]

Revit 2024 API
ScheduleSheetInstance..::..Create Method (Document, ElementId, ElementId, XYZ)
ScheduleSheetInstance Class See Also Send Feedback
Create an instance of a schedule on a sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static ScheduleSheetInstance Create(
    Document document,
    ElementId viewSheetId,
    ElementId scheduleId,
    XYZ origin
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    viewSheetId As ElementId, _
    scheduleId As ElementId, _
    origin As XYZ _
) As ScheduleSheetInstance
Visual C++
public:
static ScheduleSheetInstance^ Create(
    Document^ document,
    ElementId^ viewSheetId,
    ElementId^ scheduleId,
    XYZ^ origin
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document
viewSheetId
Type: Autodesk.Revit.DB..::..ElementId
The id of the sheet where the schedule will be placed.
scheduleId
Type: Autodesk.Revit.DB..::..ElementId
The id of the schedule view.
origin
Type: Autodesk.Revit.DB..::..XYZ
Location on the sheet where the schedule will be placed.

Return Value

The new ScheduleInstance.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | scheduleId is not a ViewSchedule that can be added to sheets. "Internal" schedules are not user-visible but are filtered by sheet or used to manage Revisions, which cannot be added to sheets. -or- viewSheetId is not a ViewSheet.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

ScheduleSheetInstance Class
Create Overload


ScheduleSheetInstance Properties

[image] [image]

Revit 2024 API
ScheduleSheetInstance Properties
ScheduleSheetInstance Class See Also Send Feedback

The ScheduleSheetInstance type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTitleblockRevisionSchedule | Identifies if this ScheduleSheetInstance is a revision schedule in a titleblock family.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Point | Location on the sheet where the ScheduleInstance is placed (in sheet coordinates).
Public property | Rotation | Rotation of the ScheduleInstance.
Public property | ScheduleId | Id of the primary schedule that generates this ScheduleInstance.
Public property | SegmentIndex | The schedule segment index of this ScheduleSheetInstance.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ScheduleSheetInstance Class


IsTitleblockRevisionSchedule Property

[image]

Revit 2024 API
ScheduleSheetInstance..::..IsTitleblockRevisionSchedule Property
ScheduleSheetInstance Class See Also Send Feedback
Identifies if this ScheduleSheetInstance is a revision schedule in a titleblock family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool IsTitleblockRevisionSchedule { get; }
Visual Basic
Public ReadOnly Property IsTitleblockRevisionSchedule As Boolean
    Get
Visual C++
public:
property bool IsTitleblockRevisionSchedule {
    bool get ();
}

Remarks

These schedule instances should not be modified in the project environment. To modify the revision schedule on a titleblock, edit the titleblock family.

See Also

ScheduleSheetInstance Class


Parameter Property

[image] [image]

Revit 2024 API
ScheduleSheetInstance..::..Parameter Property
ScheduleSheetInstance Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ScheduleSheetInstance Class
ScheduleSheetInstance Members


Point Property

[image]

Revit 2024 API
ScheduleSheetInstance..::..Point Property
ScheduleSheetInstance Class See Also Send Feedback
Location on the sheet where the ScheduleInstance is placed (in sheet coordinates).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public XYZ Point { get; set; }
Visual Basic
Public Property Point As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ Point {
    XYZ^ get ();
    void set (XYZ^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: This operation is prohibited for ScheduleInstances associated with revision schedules in titleblocks.

See Also

ScheduleSheetInstance Class


Rotation Property

[image]

Revit 2024 API
ScheduleSheetInstance..::..Rotation Property
ScheduleSheetInstance Class See Also Send Feedback
Rotation of the ScheduleInstance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ViewportRotation Rotation { get; set; }
Visual Basic
Public Property Rotation As ViewportRotation
    Get
    Set
Visual C++
public:
property ViewportRotation Rotation {
    ViewportRotation get ();
    void set (ViewportRotation value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: This operation is prohibited for ScheduleInstances associated with revision schedules in titleblocks. -or- When setting this property: This operation is prohibited for ScheduleInstances that are pinned.

See Also

ScheduleSheetInstance Class


ScheduleId Property

[image]

Revit 2024 API
ScheduleSheetInstance..::..ScheduleId Property
ScheduleSheetInstance Class See Also Send Feedback
Id of the primary schedule that generates this ScheduleInstance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ElementId ScheduleId { get; }
Visual Basic
Public ReadOnly Property ScheduleId As ElementId
    Get
Visual C++
public:
property ElementId^ ScheduleId {
    ElementId^ get ();
}

See Also

ScheduleSheetInstance Class


SegmentIndex Property

[image]

Revit 2024 API
ScheduleSheetInstance..::..SegmentIndex Property
ScheduleSheetInstance Class See Also Send Feedback
The schedule segment index of this ScheduleSheetInstance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022.1

Syntax

C#
public int SegmentIndex { get; set; }
Visual Basic
Public Property SegmentIndex As Integer
    Get
    Set
Visual C++
public:
property int SegmentIndex {
    int get ();
    void set (int value);
}

Remarks

This property represents which schedule segment is referred to by this ScheduleSheetInstance. It normally starts with 0 and is less than the total number of the schedule segments, but there're some speccial cases:
  • The segment index value could be -1, which means referring to the whole schedule but not a specific segment.
  • The segment index value 0 should be considered the same as -1 if the referenced schedule is not split in normal cases.
  • The segment index value must be 0 if the schedule is a revision schedule and in a family.
  • The segment index value can't be modified if the schedule is filter by sheet. (In fact, The segment is referenced to is belongs to an internal schedule that only valid in the current view in this case.)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: segmentIndex is not a valid segment index.
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The schedule of this ScheduleSheetInstance is a titleblock revision schedule or a sheet specific schedule.

See Also

ScheduleSheetInstance Class


ScheduleSortGroupField Class

[image]

Revit 2024 API
ScheduleSortGroupField Class
Members See Also Send Feedback
A field that is used for sorting and/or grouping in a schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public class ScheduleSortGroupField : IDisposable
Visual Basic
Public Class ScheduleSortGroupField _
    Implements IDisposable
Visual C++
public ref class ScheduleSortGroupField : IDisposable

Remarks

A schedule may be sorted or grouped by one or more of the schedule's fields. The ScheduleSortGroupField class represents one of the fields that the schedule is sorted or grouped by.

Sorting and grouping are related operations. In either case, elements appearing in the schedule are sorted based on their values for the field that the schedule is sorted/grouped by, which automatically causes elements with identical values to be grouped together. By enabling extra header, footer, or blank rows, visual separation between groups can be achieved.

If ScheduleDefinition.IsItemized is false, elements having the same values for all of the fields used for sorting/grouping will be combined onto the same row.

A schedule can be sorted or grouped by data that is not displayed in the schedule by marking the field used for sorting/grouping as hidden using the ScheduleField.IsHidden property.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ScheduleSortGroupField

See Also

ScheduleSortGroupField Members


ScheduleSortGroupField Constructor

[image] [image]

Revit 2024 API
ScheduleSortGroupField Constructor
ScheduleSortGroupField Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScheduleSortGroupField()()()() | Creates a new ScheduleSortGroupField.
Public method | ScheduleSortGroupField(ScheduleFieldId) | Creates a new ScheduleSortGroupField.
Public method | ScheduleSortGroupField(ScheduleFieldId, ScheduleSortOrder) | Creates a new ScheduleSortGroupField.

See Also

ScheduleSortGroupField Class
ScheduleSortGroupField Members


ScheduleSortGroupField Constructor

[image]

Revit 2024 API
ScheduleSortGroupField Constructor
ScheduleSortGroupField Class See Also Send Feedback
Creates a new ScheduleSortGroupField.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ScheduleSortGroupField()
Visual Basic
Public Sub New
Visual C++
public:
ScheduleSortGroupField()

See Also

ScheduleSortGroupField Class
ScheduleSortGroupField Overload


ScheduleSortGroupField Constructor (ScheduleFieldId, ScheduleSortOrder)

[image]

Revit 2024 API
ScheduleSortGroupField Constructor (ScheduleFieldId, ScheduleSortOrder)
ScheduleSortGroupField Class See Also Send Feedback
Creates a new ScheduleSortGroupField.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ScheduleSortGroupField(
    ScheduleFieldId fieldId,
    ScheduleSortOrder sortOrder
)
Visual Basic
Public Sub New ( _
    fieldId As ScheduleFieldId, _
    sortOrder As ScheduleSortOrder _
)
Visual C++
public:
ScheduleSortGroupField(
    ScheduleFieldId^ fieldId,
    ScheduleSortOrder sortOrder
)

Parameters

fieldId
Type: Autodesk.Revit.DB..::..ScheduleFieldId
The ID of the field that the schedule will be sorted or grouped by.
sortOrder
Type: Autodesk.Revit.DB..::..ScheduleSortOrder
The sort order, ascending or descending.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

ScheduleSortGroupField Class
ScheduleSortGroupField Overload


ScheduleSortGroupField Methods

[image] [image]

Revit 2024 API
ScheduleSortGroupField Methods
ScheduleSortGroupField Class See Also Send Feedback

The ScheduleSortGroupField type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ScheduleSortGroupField Class


FieldId Property

[image]

Revit 2024 API
ScheduleSortGroupField..::..FieldId Property
ScheduleSortGroupField Class See Also Send Feedback
The ID of the field that the schedule will be sorted or grouped by.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ScheduleFieldId FieldId { get; set; }
Visual Basic
Public Property FieldId As ScheduleFieldId
    Get
    Set
Visual C++
public:
property ScheduleFieldId^ FieldId {
    ScheduleFieldId^ get ();
    void set (ScheduleFieldId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ScheduleSortGroupField Class


IsValidObject Property

[image]

Revit 2024 API
ScheduleSortGroupField..::..IsValidObject Property
ScheduleSortGroupField Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ScheduleSortGroupField Class


ShowBlankLine Property

[image]

Revit 2024 API
ScheduleSortGroupField..::..ShowBlankLine Property
ScheduleSortGroupField Class See Also Send Feedback
Indicates if an empty row should be displayed between groups.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool ShowBlankLine { get; set; }
Visual Basic
Public Property ShowBlankLine As Boolean
    Get
    Set
Visual C++
public:
property bool ShowBlankLine {
    bool get ();
    void set (bool value);
}

Remarks

True if an empty row should be displayed, false otherwise.

See Also

ScheduleSortGroupField Class


ShowFooter Property

[image]

Revit 2024 API
ScheduleSortGroupField..::..ShowFooter Property
ScheduleSortGroupField Class See Also Send Feedback
Indicates if a footer row should be displayed after each group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool ShowFooter { get; set; }
Visual Basic
Public Property ShowFooter As Boolean
    Get
    Set
Visual C++
public:
property bool ShowFooter {
    bool get ();
    void set (bool value);
}

Field Value

True if a footer row should be displayed, false otherwise.

Remarks

The footer row displays totals of each field for which totals are enabled. It can also optionally display a title (see ShowFooterTitle) and a count of elements (see ShowFooterCount).

See Also

ScheduleSortGroupField Class


ShowFooterCount Property

[image]

Revit 2024 API
ScheduleSortGroupField..::..ShowFooterCount Property
ScheduleSortGroupField Class See Also Send Feedback
Indicates if the footer row should display a count of elements in the group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool ShowFooterCount { get; set; }
Visual Basic
Public Property ShowFooterCount As Boolean
    Get
    Set
Visual C++
public:
property bool ShowFooterCount {
    bool get ();
    void set (bool value);
}

Field Value

True if an element count should be displayed, false otherwise.

Remarks

ShowFooterCount can only be enabled if ShowFooter is enabled.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: Display of footer rows is not enabled.

See Also

ScheduleSortGroupField Class


ShowFooterTitle Property

[image]

Revit 2024 API
ScheduleSortGroupField..::..ShowFooterTitle Property
ScheduleSortGroupField Class See Also Send Feedback
Indicates if the footer row should display a title.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool ShowFooterTitle { get; set; }
Visual Basic
Public Property ShowFooterTitle As Boolean
    Get
    Set
Visual C++
public:
property bool ShowFooterTitle {
    bool get ();
    void set (bool value);
}

Field Value

True if a title should be displayed, false otherwise.

Remarks

The title consists of the value of the field that the schedule is grouped by.

ShowFooterTitle can only be enabled if ShowFooter is enabled.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: Display of footer rows is not enabled.

See Also

ScheduleSortGroupField Class


ShowHeader Property

[image]

Revit 2024 API
ScheduleSortGroupField..::..ShowHeader Property
ScheduleSortGroupField Class See Also Send Feedback
Indicates if a header row should be displayed before each group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool ShowHeader { get; set; }
Visual Basic
Public Property ShowHeader As Boolean
    Get
    Set
Visual C++
public:
property bool ShowHeader {
    bool get ();
    void set (bool value);
}

Field Value

True if a header row should be displayed, false otherwise.

Remarks

The header row displays a title consisting of the value of the field that the schedule is grouped by.

See Also

ScheduleSortGroupField Class


SortOrder Property

[image]

Revit 2024 API
ScheduleSortGroupField..::..SortOrder Property
ScheduleSortGroupField Class See Also Send Feedback
Indicates if elements in the schedule will be sorted in ascending or descending order.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ScheduleSortOrder SortOrder { get; set; }
Visual Basic
Public Property SortOrder As ScheduleSortOrder
    Get
    Set
Visual C++
public:
property ScheduleSortOrder SortOrder {
    ScheduleSortOrder get ();
    void set (ScheduleSortOrder value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

ScheduleSortGroupField Class


ScheduleSortOrder Enumeration

[image]

Revit 2024 API
ScheduleSortOrder Enumeration
See Also Send Feedback
Options for sort order of rows in a schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public enum ScheduleSortOrder
Visual Basic
Public Enumeration ScheduleSortOrder
Visual C++
public enum class ScheduleSortOrder

Members

Member name | Description
Ascending | Sort in ascending order.
Descending | Sort in descending order.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


ScheduleVerticalAlignment Enumeration

[image]

Revit 2024 API
ScheduleVerticalAlignment Enumeration
See Also Send Feedback
Vertical alignment of data in a schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024
Since: 2024

Syntax

C#
public enum ScheduleVerticalAlignment
Visual Basic
Public Enumeration ScheduleVerticalAlignment
Visual C++
public enum class ScheduleVerticalAlignment

Members

Member name | Description
Top | Top aligned
Middle | Middle aligned
Bottom | Bottom aligned

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


SectionType Enumeration

[image]

Revit 2024 API
SectionType Enumeration
See Also Send Feedback
Declares the section data type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public enum SectionType
Visual Basic
Public Enumeration SectionType
Visual C++
public enum class SectionType

Members

Member name | Description
None |
Header |
Body |
Summary |
Footer |

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


Segment Class

[image]

Revit 2024 API
Segment Class
Members Example See Also Send Feedback
This element represents a segment of an MEP curve object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public class Segment : Element
Visual Basic
Public Class Segment _
    Inherits Element
Visual C++
public ref class Segment : public Element

Remarks

Currently, only pipe curves can be broken into separate segment elements.

Examples

CopyC#
private void GetPipeSegmentSizesFromDocument(Document document)
{
    FilteredElementCollector collectorPipeType = new FilteredElementCollector(document);
    collectorPipeType.OfClass(typeof(Segment));

    IEnumerable<Segment> segments = collectorPipeType.ToElements().Cast<Segment>();
    foreach (Segment segment in segments)
    {
        StringBuilder strPipeInfo = new StringBuilder();
        strPipeInfo.AppendLine("Segment: " + segment.Name);

        strPipeInfo.AppendLine("Roughness: " + segment.Roughness);

        strPipeInfo.AppendLine("Pipe Sizes:");
        double dLengthFac = 304.8;  // used to convert stored units from ft to mm for display
        foreach (MEPSize size in segment.GetSizes())
        {
            strPipeInfo.AppendLine(string.Format("Nominal: {0:F3}, ID: {1:F3}, OD: {2:F3}",
                                        size.NominalDiameter * dLengthFac, size.InnerDiameter * dLengthFac, size.OuterDiameter * dLengthFac));
        }

        TaskDialog.Show("PipeSetting Data", strPipeInfo.ToString());
        break;
    }
}
CopyVB.NET
Private Sub GetPipeSegmentSizesFromDocument(document As Document)
   Dim collectorPipeType As New FilteredElementCollector(document)
   collectorPipeType.OfClass(GetType(Segment))

   Dim segments As IEnumerable(Of Segment) = collectorPipeType.ToElements().Cast(Of Segment)()
   For Each segment As Segment In segments
      Dim strPipeInfo As New StringBuilder()
      strPipeInfo.AppendLine("Segment: " + segment.Name)

      strPipeInfo.AppendLine("Roughness: " + segment.Roughness)

      strPipeInfo.AppendLine("Pipe Sizes:")
      Dim dLengthFac As Double = 304.8
      ' used to convert stored units from ft to mm for display
      For Each size As MEPSize In segment.GetSizes()
         strPipeInfo.AppendLine(String.Format("Nominal: {0:F3}, ID: {1:F3}, OD: {2:F3}", size.NominalDiameter * dLengthFac, size.InnerDiameter * dLengthFac, size.OuterDiameter * dLengthFac))
      Next

      TaskDialog.Show("PipeSetting Data", strPipeInfo.ToString())
      Exit For
   Next
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..Segment
Autodesk.Revit.DB.Plumbing..::..PipeSegment

See Also

Segment Members


Segment Members

[image] [image]

Revit 2024 API
Segment Members
Segment Class Methods Properties See Also Send Feedback

The Segment type exposes the following members.

Methods

 | Name | Description
Public method | AddSize | Adds a new MEPSize to the segment.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSizes | Gets the defined sizes of the segment.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | RemoveSize | Remove the existing MEPSize with this nominal diameter from the segment.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | Description | The description of the segment.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MaterialId | The ElementId of the MaterialElem.
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Roughness | The roughness value for given material.
Public property | SizeCount | The number of size objects in the segment.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Segment Class


AddSize Method

[image]

Revit 2024 API
Segment..::..AddSize Method
Segment Class See Also Send Feedback
Adds a new MEPSize to the segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void AddSize(
    MEPSize size
)
Visual Basic
Public Sub AddSize ( _
    size As MEPSize _
)
Visual C++
public:
void AddSize(
    MEPSize^ size
)

Parameters

size
Type: Autodesk.Revit.DB..::..MEPSize
The new MEPSize to be added.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | There is already a same size in the settings. -or- The size already exists in the segment.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

Segment Class


GetSizes Method

[image]

Revit 2024 API
Segment..::..GetSizes Method
Segment Class See Also Send Feedback
Gets the defined sizes of the segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ICollection<MEPSize> GetSizes()
Visual Basic
Public Function GetSizes As ICollection(Of MEPSize)
Visual C++
public:
ICollection<MEPSize^>^ GetSizes()

See Also

Segment Class


RemoveSize Method

[image]

Revit 2024 API
Segment..::..RemoveSize Method
Segment Class See Also Send Feedback
Remove the existing MEPSize with this nominal diameter from the segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void RemoveSize(
    double nominalDiameter
)
Visual Basic
Public Sub RemoveSize ( _
    nominalDiameter As Double _
)
Visual C++
public:
void RemoveSize(
    double nominalDiameter
)

Parameters

nominalDiameter
Type: System..::..Double
The nominal diameter of the size.

Remarks

Does nothing if there is no existing MEPSize with this nominal diameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The last size of the segment cannot be removed.

See Also

Segment Class


Description Property

[image]

Revit 2024 API
Segment..::..Description Property
Segment Class See Also Send Feedback
The description of the segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

Segment Class


MaterialId Property

[image]

Revit 2024 API
Segment..::..MaterialId Property
Segment Class See Also Send Feedback
The ElementId of the MaterialElem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ElementId MaterialId { get; }
Visual Basic
Public ReadOnly Property MaterialId As ElementId
    Get
Visual C++
public:
property ElementId^ MaterialId {
    ElementId^ get ();
}

See Also

Segment Class


Parameter Property

[image] [image]

Revit 2024 API
Segment..::..Parameter Property
Segment Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Segment Class
Segment Members


Roughness Property

[image]

Revit 2024 API
Segment..::..Roughness Property
Segment Class See Also Send Feedback
The roughness value for given material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double Roughness { get; set; }
Visual Basic
Public Property Roughness As Double
    Get
    Set
Visual C++
public:
property double Roughness {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

Segment Class


SizeCount Property

[image]

Revit 2024 API
Segment..::..SizeCount Property
Segment Class See Also Send Feedback
The number of size objects in the segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public int SizeCount { get; }
Visual Basic
Public ReadOnly Property SizeCount As Integer
    Get
Visual C++
public:
property int SizeCount {
    int get ();
}

See Also

Segment Class


SelectionFilterAction Enumeration

[image]

Revit 2024 API
SelectionFilterAction Enumeration
See Also Send Feedback
An enumerated type containing the type of actions that may be taken with a selection filter applied to a point cloud.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public enum SelectionFilterAction
Visual Basic
Public Enumeration SelectionFilterAction
Visual C++
public enum class SelectionFilterAction

Members

Member name | Description
None | Selection filter is ignored.
Highlight | Points that pass the filter are highlighted.
Isolate | Only points that pass the filter are visible.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


SelectionFilterElement Class

[image]

Revit 2024 API
SelectionFilterElement Class
Members Example See Also Send Feedback
A filter element that stores an explicit list of ElementIds. Only elements whose ElementIds are in this list will pass the filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public class SelectionFilterElement : FilterElement
Visual Basic
Public Class SelectionFilterElement _
    Inherits FilterElement
Visual C++
public ref class SelectionFilterElement : public FilterElement

Examples

CopyC#
public static void CreateSelectionFilter(Document doc, View view)
{
    // find room tags in this view
    FilteredElementCollector collector = new FilteredElementCollector(doc, view.Id);
    collector.WherePasses(new RoomTagFilter());

    // collect tags whose room number matches criteria
    List<ElementId> tagIds = new List<ElementId>();

    foreach (RoomTag tag in collector.Cast<RoomTag>())
    {
        int number = Int32.Parse(tag.Room.Number);
        if (number % 3 == 0)
        {
            tagIds.Add(tag.Id);
        }
    }

    using (Transaction t = new Transaction(doc, "Create SelectionFilterElement"))
    {
        t.Start();

        // Create selection filter and assign ids
        SelectionFilterElement filterElement = SelectionFilterElement.Create(doc, "Room tags filter");
        filterElement.SetElementIds(tagIds);

        ElementId filterId = filterElement.Id;

        // Add the filter to the view
        view.AddFilter(filterId);

        doc.Regenerate();

        // Use the existing graphics settings, and change the color to Blue
        OverrideGraphicSettings overrideSettings = view.GetFilterOverrides(filterId);

        overrideSettings.SetProjectionLineColor(new Color(0x00, 0x00, 0xFF));

        view.SetFilterOverrides(filterId, overrideSettings);

        t.Commit();
    }
}
CopyVB.NET
Public Shared Sub CreateSelectionFilter(doc As Document, view As View)
    ' find room tags in this view
    Dim collector As New FilteredElementCollector(doc, view.Id)
    collector.WherePasses(New RoomTagFilter())

    ' collect tags whose room number matches criteria
    Dim tagIds As New List(Of ElementId)()

    For Each tag As RoomTag In collector.Cast(Of RoomTag)()
        Dim number As Integer = Int32.Parse(tag.Room.Number)
        If number Mod 3 = 0 Then
            tagIds.Add(tag.Id)
        End If
    Next

    Using t As New Transaction(doc, "Create SelectionFilterElement")
        t.Start()

        ' Create selection filter and assign ids
        Dim filterElement As SelectionFilterElement = SelectionFilterElement.Create(doc, "Room tags filter")
        filterElement.SetElementIds(tagIds)

        Dim filterId As ElementId = filterElement.Id

        ' Add the filter to the view
        view.AddFilter(filterId)

        doc.Regenerate()

        ' Use the existing graphics settings, and change the color to Blue
        Dim overrideSettings As OverrideGraphicSettings = view.GetFilterOverrides(filterId)

        overrideSettings.SetProjectionLineColor(New Color(&H0, &H0, &Hff))

        view.SetFilterOverrides(filterId, overrideSettings)

        t.Commit()
    End Using
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..FilterElement
Autodesk.Revit.DB..::..SelectionFilterElement

See Also

SelectionFilterElement Members


SelectionFilterElement Methods

[image] [image]

Revit 2024 API
SelectionFilterElement Methods
SelectionFilterElement Class See Also Send Feedback

The SelectionFilterElement type exposes the following members.

Methods

 | Name | Description
Public method | AddSet | Adds a set of ElementIds to the filter's set.
Public method | AddSingle | Adds a single ElementId to the filter's set.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | Clear | Removes all ElementIds from the filter.
Public method | Contains | Returns true if the given ElementId is a member of this filter's set.
 | Create | Creates a new SelectionFilterElement in the given document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetElementIds | Returns the set of ElementIds contained by this filter.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsEmpty | Determines whether this filter's set is empty or not.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsNameUnique(String) | Determines whether a potential filter element name is unique. (Inherited from FilterElement.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | RemoveSet | Removes a set of ElementIds from the filter's set.
Public method | RemoveSingle | Removes a single ElementId from the filter's set.
Public method | SetElementIds | Replaces the set of ElementIds contained by this filter.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SelectionFilterElement Class


AddSet Method

[image]

Revit 2024 API
SelectionFilterElement..::..AddSet Method
SelectionFilterElement Class See Also Send Feedback
Adds a set of ElementIds to the filter's set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void AddSet(
    ICollection<ElementId> ids
)
Visual Basic
Public Sub AddSet ( _
    ids As ICollection(Of ElementId) _
)
Visual C++
public:
void AddSet(
    ICollection<ElementId^>^ ids
)

Parameters

ids
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
The set of ElementIds to add.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

SelectionFilterElement Class


AddSingle Method

[image]

Revit 2024 API
SelectionFilterElement..::..AddSingle Method
SelectionFilterElement Class See Also Send Feedback
Adds a single ElementId to the filter's set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void AddSingle(
    ElementId id
)
Visual Basic
Public Sub AddSingle ( _
    id As ElementId _
)
Visual C++
public:
void AddSingle(
    ElementId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::..ElementId
The ElementId to add.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Invalid ElementId
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

SelectionFilterElement Class


Clear Method

[image]

Revit 2024 API
SelectionFilterElement..::..Clear Method
SelectionFilterElement Class See Also Send Feedback
Removes all ElementIds from the filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

See Also

SelectionFilterElement Class


Create Method

[image]

Revit 2024 API
SelectionFilterElement..::..Create Method
SelectionFilterElement Class See Also Send Feedback
Creates a new SelectionFilterElement in the given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static SelectionFilterElement Create(
    Document document,
    string name
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    name As String _
) As SelectionFilterElement
Visual C++
public:
static SelectionFilterElement^ Create(
    Document^ document,
    String^ name
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which to create the SelectionFilterElement.
name
Type: System..::..String
The name for the new SelectionFilterElement.

Return Value

The new SelectionFilterElement.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | name is an empty string or contains only whitespace. -or- name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- The given value for name is already in use as a filter element name.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

SelectionFilterElement Class


GetElementIds Method

[image]

Revit 2024 API
SelectionFilterElement..::..GetElementIds Method
SelectionFilterElement Class See Also Send Feedback
Returns the set of ElementIds contained by this filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ICollection<ElementId> GetElementIds()
Visual Basic
Public Function GetElementIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetElementIds()

Return Value

The set of ElementIds.

See Also

SelectionFilterElement Class


IsEmpty Method

[image]

Revit 2024 API
SelectionFilterElement..::..IsEmpty Method
SelectionFilterElement Class See Also Send Feedback
Determines whether this filter's set is empty or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool IsEmpty()
Visual Basic
Public Function IsEmpty As Boolean
Visual C++
public:
bool IsEmpty()

Return Value

True if the set is empty, otherwise false.

See Also

SelectionFilterElement Class


RemoveSet Method

[image]

Revit 2024 API
SelectionFilterElement..::..RemoveSet Method
SelectionFilterElement Class See Also Send Feedback
Removes a set of ElementIds from the filter's set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public int RemoveSet(
    ICollection<ElementId> ids
)
Visual Basic
Public Function RemoveSet ( _
    ids As ICollection(Of ElementId) _
) As Integer
Visual C++
public:
int RemoveSet(
    ICollection<ElementId^>^ ids
)

Parameters

ids
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
The set of ElementIds to remove.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

SelectionFilterElement Class


RemoveSingle Method

[image]

Revit 2024 API
SelectionFilterElement..::..RemoveSingle Method
SelectionFilterElement Class See Also Send Feedback
Removes a single ElementId from the filter's set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void RemoveSingle(
    ElementId id
)
Visual Basic
Public Sub RemoveSingle ( _
    id As ElementId _
)
Visual C++
public:
void RemoveSingle(
    ElementId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::..ElementId
The ElementId to remove.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Invalid ElementId
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

SelectionFilterElement Class


SetElementIds Method

[image]

Revit 2024 API
SelectionFilterElement..::..SetElementIds Method
SelectionFilterElement Class See Also Send Feedback
Replaces the set of ElementIds contained by this filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void SetElementIds(
    ICollection<ElementId> ids
)
Visual Basic
Public Sub SetElementIds ( _
    ids As ICollection(Of ElementId) _
)
Visual C++
public:
void SetElementIds(
    ICollection<ElementId^>^ ids
)

Parameters

ids
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
The new set of ElementIds.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

SelectionFilterElement Class


SelectionFilterElement Properties

[image] [image]

Revit 2024 API
SelectionFilterElement Properties
SelectionFilterElement Class See Also Send Feedback

The SelectionFilterElement type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SelectionFilterElement Class


Parameter Property

[image] [image]

Revit 2024 API
SelectionFilterElement..::..Parameter Property
SelectionFilterElement Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

SelectionFilterElement Class
SelectionFilterElement Members


ServerPath Class

[image]

Revit 2024 API
ServerPath Class
Members See Also Send Feedback
This class represents a path to a Revit Server location, rather than a location on disk or a network drive.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public class ServerPath : ModelPath
Visual Basic
Public Class ServerPath _
    Inherits ModelPath
Visual C++
public ref class ServerPath : public ModelPath

Remarks

ServerPaths must refer to Revit models.

ServerPaths are relative to the central server location, and are of the form "RSN://{HostNodeName}/{model_path}".

The {model_path} portion is a relative path to a Revit model. For example, the following are valid server paths:

  • RSN://EXS/hospital.rvt
  • RSN://EXS.autodesk.com/Old Files/hotel2.rvt
  • RSN://EXS.autodesk.com/Old Files/Last Week/Tuesday\hotel2.rvt
The following would not be valid server paths:
  • //EXS/Old Files/.rvt
  • EXS/hospital

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ModelPath
Autodesk.Revit.DB..::..ServerPath

See Also

ServerPath Members


ServerPath Members

[image] [image]

Revit 2024 API
ServerPath Members
ServerPath Class Constructors Methods Properties See Also Send Feedback

The ServerPath type exposes the following members.

Constructors

 | Name | Description
Public method | ServerPath | Constructs a ServerPath

Methods

 | Name | Description
Public method | Compare | Compares this ModelPath with another (Inherited from ModelPath.)
Public method | Dispose | (Inherited from ModelPath.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetModelGUID | A GUID identifying the Revit cloud model. (Inherited from ModelPath.)
Public method | GetProjectGUID | A GUID identifying the BIM 360 Docs or Autodesk Docs project to which the model is associated. (Inherited from ModelPath.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CentralServerPath | The path to the location of the central Revit server or cloud. (Inherited from ModelPath.)
Public property | CloudPath | Whether this path represents a path on an Autodesk server such as BIM360. (Inherited from ModelPath.)
Public property | Empty | Whether this path is empty (Inherited from ModelPath.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ModelPath.)
Public property | Region | The region of the BIM 360 Docs or Autodesk Docs account and project which contains this model. (Inherited from ModelPath.)
Public property | ServerPath | Whether this path is a server path (as opposed to a file path or cloud path) (Inherited from ModelPath.)

See Also

ServerPath Class


ServerPath Constructor

[image]

Revit 2024 API
ServerPath Constructor
ServerPath Class See Also Send Feedback
Constructs a ServerPath

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public ServerPath(
    string centralServerLocation,
    string path
)
Visual Basic
Public Sub New ( _
    centralServerLocation As String, _
    path As String _
)
Visual C++
public:
ServerPath(
    String^ centralServerLocation,
    String^ path
)

Parameters

centralServerLocation
Type: System..::..String
The name of the central Revit server
path
Type: System..::..String
The path of the model. This path must be relative.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ServerPath Class


ServerPath Methods

[image] [image]

Revit 2024 API
ServerPath Methods
ServerPath Class See Also Send Feedback

The ServerPath type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares this ModelPath with another (Inherited from ModelPath.)
Public method | Dispose | (Inherited from ModelPath.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetModelGUID | A GUID identifying the Revit cloud model. (Inherited from ModelPath.)
Public method | GetProjectGUID | A GUID identifying the BIM 360 Docs or Autodesk Docs project to which the model is associated. (Inherited from ModelPath.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ServerPath Class


ServerPath Properties

[image] [image]

Revit 2024 API
ServerPath Properties
ServerPath Class See Also Send Feedback

The ServerPath type exposes the following members.

Properties

 | Name | Description
Public property | CentralServerPath | The path to the location of the central Revit server or cloud. (Inherited from ModelPath.)
Public property | CloudPath | Whether this path represents a path on an Autodesk server such as BIM360. (Inherited from ModelPath.)
Public property | Empty | Whether this path is empty (Inherited from ModelPath.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ModelPath.)
Public property | Region | The region of the BIM 360 Docs or Autodesk Docs account and project which contains this model. (Inherited from ModelPath.)
Public property | ServerPath | Whether this path is a server path (as opposed to a file path or cloud path) (Inherited from ModelPath.)

See Also

ServerPath Class


SetComparisonResult Enumeration

[image]

Revit 2024 API
SetComparisonResult Enumeration
See Also Send Feedback
An enumerated type listing all the relationship types between two sets of arbitrary nature.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum SetComparisonResult
Visual Basic
Public Enumeration SetComparisonResult
Visual C++
public enum class SetComparisonResult

Members

Member name | Description
LeftEmpty | The left set is empty and the right set is not.
RightEmpty | The right set is empty and the left set is not.
BothEmpty | Both sets are empty.
Disjoint | Both sets are not empty and don't overlap.
Overlap | The overlap of two sets is not empty and strict subset of both.
Subset | Both sets are not empty and the left set is strict subset of the right.
Superset | Both sets are not empty and the left set is strict superset of the right.
Equal | Two nonempty sets are equal.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


Settings Class

[image]

Revit 2024 API
Settings Class
Members Example See Also Send Feedback
The settings object provides access to general components of the Autodesk Revit application, such as Categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class Settings : APIObject
Visual Basic
Public Class Settings _
    Inherits APIObject
Visual C++
public ref class Settings : public APIObject

Examples

CopyC#
// Get some of the settings information, including categories and FillPatterns
Settings settings = document.Settings;

// Format the prompt information string
String prompt = "Setting information: ";
prompt += "\nNumber of Categories: " + settings.Categories.Size;
FilteredElementCollector fillPatternCollector = new FilteredElementCollector(document);
prompt += "\nNumber of Fill Patterns: " + fillPatternCollector.OfClass(typeof(FillPatternElement)).Count();
FilteredElementCollector linePatternCollector = new FilteredElementCollector(document);
prompt += "\nNumber of Line Patterns: " + linePatternCollector.OfClass(typeof(LinePatternElement)).Count();

// Give the user some information
TaskDialog.Show("Revit",prompt);
CopyVB.NET
' Get some of the settings information, including categories and FillPatterns
Dim settings As Settings = document.Settings

' Format the prompt information string
Dim prompt As [String] = "Setting information: "
prompt += vbLf & "Number of Categories: " + settings.Categories.Size
Dim fillPatternCollector As New FilteredElementCollector(document)
prompt += vbLf & "Number of Fill Patterns: " & fillPatternCollector.OfClass(GetType(FillPatternElement)).Count()
Dim linePatternCollector As New FilteredElementCollector(document)
prompt += vbLf & "Number of Line Patterns: " & linePatternCollector.OfClass(GetType(LinePatternElement)).Count()

' Give the user some information
TaskDialog.Show("Revit", prompt)

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..Settings

See Also

Settings Members


Settings Members

[image] [image]

Revit 2024 API
Settings Members
Settings Class Methods Properties See Also Send Feedback

The Settings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Categories | Retrieves an object that provides access to all the categories contained in the Autodesk Revit application and project.
Public property | ElectricalSetting | Retrieves an object that provides access to all the electrical settings include voltage type, distribution system type, demand factor, wire type in the Autodesk Revit application and project.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | TilePatterns | Retrieves an object that provides access to the TilePattern objects in the document.

See Also

Settings Class


Settings Methods

[image] [image]

Revit 2024 API
Settings Methods
Settings Class See Also Send Feedback

The Settings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Settings Class


Settings Properties

[image] [image]

Revit 2024 API
Settings Properties
Settings Class See Also Send Feedback

The Settings type exposes the following members.

Properties

 | Name | Description
Public property | Categories | Retrieves an object that provides access to all the categories contained in the Autodesk Revit application and project.
Public property | ElectricalSetting | Retrieves an object that provides access to all the electrical settings include voltage type, distribution system type, demand factor, wire type in the Autodesk Revit application and project.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | TilePatterns | Retrieves an object that provides access to the TilePattern objects in the document.

See Also

Settings Class


Categories Property

[image]

Revit 2024 API
Settings..::..Categories Property
Settings Class See Also Send Feedback
Retrieves an object that provides access to all the categories contained in the Autodesk Revit application and project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Categories Categories { get; }
Visual Basic
Public ReadOnly Property Categories As Categories
    Get
Visual C++
public:
property Categories^ Categories {
    Categories^ get ();
}

See Also

Settings Class


ElectricalSetting Property

[image]

Revit 2024 API
Settings..::..ElectricalSetting Property
Settings Class See Also Send Feedback
Retrieves an object that provides access to all the electrical settings include voltage type, distribution system type, demand factor, wire type in the Autodesk Revit application and project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElectricalSetting ElectricalSetting { get; }
Visual Basic
Public ReadOnly Property ElectricalSetting As ElectricalSetting
    Get
Visual C++
public:
property ElectricalSetting^ ElectricalSetting {
    ElectricalSetting^ get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Electrical settings can be accessed only if Revit MEP product is available.

See Also

Settings Class


TilePatterns Property

[image]

Revit 2024 API
Settings..::..TilePatterns Property
Settings Class See Also Send Feedback
Retrieves an object that provides access to the TilePattern objects in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public TilePatterns TilePatterns { get; }
Visual Basic
Public ReadOnly Property TilePatterns As TilePatterns
    Get
Visual C++
public:
property TilePatterns^ TilePatterns {
    TilePatterns^ get ();
}

See Also

Settings Class


ShapeBuilder Class

[image]

Revit 2024 API
ShapeBuilder Class
Members See Also Send Feedback
The base class for geometry builder classes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public class ShapeBuilder : IDisposable
Visual Basic
Public Class ShapeBuilder _
    Implements IDisposable
Visual C++
public ref class ShapeBuilder : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ShapeBuilder
Autodesk.Revit.DB..::..BRepBuilder
Autodesk.Revit.DB..::..TessellatedShapeBuilder
Autodesk.Revit.DB..::..ViewShapeBuilder
Autodesk.Revit.DB..::..WireframeBuilder

See Also

ShapeBuilder Members


ShapeBuilder Methods

[image] [image]

Revit 2024 API
ShapeBuilder Methods
ShapeBuilder Class See Also Send Feedback

The ShapeBuilder type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ShapeBuilder Class


ShapeBuilder Properties

[image] [image]

Revit 2024 API
ShapeBuilder Properties
ShapeBuilder Class See Also Send Feedback

The ShapeBuilder type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ShapeBuilder Class


IsValidObject Property

[image]

Revit 2024 API
ShapeBuilder..::..IsValidObject Property
ShapeBuilder Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ShapeBuilder Class


ShapeImporter Members

[image] [image]

Revit 2024 API
ShapeImporter Members
ShapeImporter Class Constructors Methods Properties See Also Send Feedback

The ShapeImporter type exposes the following members.

Constructors

 | Name | Description
Public method | ShapeImporter | Default constructor. Initializes an instance of ShapeImporter that will automatically recognize the file format from its extension (ShapeImporterSourceFormat.Auto).

Methods

 | Name | Description
Public method | Convert | Converts the geometry stored in the external format into a collection of Revit geometry objects.
Public method | Dispose | Releases all resources used by the ShapeImporter
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsServiceAvailable | Checks whether the data conversion service is available.
Public method | SetDefaultLengthUnit | Sets the length unit to be used when the input is a unitless SAT file.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DefaultLengthUnit | The length unit to be used if not specified when the input is a unitless SAT file.
Public property | InputFormat | The format of the incoming data.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ShapeImporter Class


ShapeImporter Constructor

[image]

Revit 2024 API
ShapeImporter Constructor
ShapeImporter Class See Also Send Feedback
Default constructor. Initializes an instance of ShapeImporter that will automatically recognize the file format from its extension (ShapeImporterSourceFormat.Auto).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public ShapeImporter()
Visual Basic
Public Sub New
Visual C++
public:
ShapeImporter()

See Also

ShapeImporter Class


ShapeImporter Methods

[image] [image]

Revit 2024 API
ShapeImporter Methods
ShapeImporter Class See Also Send Feedback

The ShapeImporter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Converts the geometry stored in the external format into a collection of Revit geometry objects.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsServiceAvailable | Checks whether the data conversion service is available.
Public method | SetDefaultLengthUnit | Sets the length unit to be used when the input is a unitless SAT file.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ShapeImporter Class


Convert Method

[image]

Revit 2024 API
ShapeImporter..::..Convert Method
ShapeImporter Class See Also Send Feedback
Converts the geometry stored in the external format into a collection of Revit geometry objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public IList<GeometryObject> Convert(
    Document document,
    string filename
)
Visual Basic
Public Function Convert ( _
    document As Document, _
    filename As String _
) As IList(Of GeometryObject)
Visual C++
public:
IList<GeometryObject^>^ Convert(
    Document^ document,
    String^ filename
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The Revit document where the resulting Revit geometry objects will be used. This document may need to be modified to store dependent elements such as graphics styles and/or materials.
filename
Type: System..::..String
The full path to the input file.

Return Value

A collection of Revit geometry objects created from the incoming data.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | The given filename does not exist.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Data conversion service is not available.

See Also

ShapeImporter Class


Dispose Method

[image]

Revit 2024 API
ShapeImporter..::..Dispose Method
ShapeImporter Class See Also Send Feedback
Releases all resources used by the ShapeImporter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ShapeImporter Class


IsServiceAvailable Method

[image]

Revit 2024 API
ShapeImporter..::..IsServiceAvailable Method
ShapeImporter Class See Also Send Feedback
Checks whether the data conversion service is available.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public static bool IsServiceAvailable()
Visual Basic
Public Shared Function IsServiceAvailable As Boolean
Visual C++
public:
static bool IsServiceAvailable()

Return Value

True if the data conversion service is available, false otherwise.

Remarks

ShapeImporter relies on optional data conversion functionality. This function checks whether it is available.

See Also

ShapeImporter Class


SetDefaultLengthUnit Method

[image]

Revit 2024 API
ShapeImporter..::..SetDefaultLengthUnit Method
ShapeImporter Class See Also Send Feedback
Sets the length unit to be used when the input is a unitless SAT file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017_subscription_update

Syntax

C#
public ShapeImporter SetDefaultLengthUnit(
    ImportUnit defaultLengthUnit
)
Visual Basic
Public Function SetDefaultLengthUnit ( _
    defaultLengthUnit As ImportUnit _
) As ShapeImporter
Visual C++
public:
ShapeImporter^ SetDefaultLengthUnit(
    ImportUnit defaultLengthUnit
)

Parameters

defaultLengthUnit
Type: Autodesk.Revit.DB..::..ImportUnit
The length unit to be used for when the input is a unitless SAT file.

Remarks

Values ImportUnit::Default and ImportUnit::Custom are ignored. ImportUnit::Centimeter is used instead.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

ShapeImporter Class


ShapeImporter Properties

[image] [image]

Revit 2024 API
ShapeImporter Properties
ShapeImporter Class See Also Send Feedback

The ShapeImporter type exposes the following members.

Properties

 | Name | Description
Public property | DefaultLengthUnit | The length unit to be used if not specified when the input is a unitless SAT file.
Public property | InputFormat | The format of the incoming data.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ShapeImporter Class


ShapeImporterSourceFormat Enumeration

[image]

Revit 2024 API
ShapeImporterSourceFormat Enumeration
See Also Send Feedback
An enumerated type listing the possible formats supported by the Shapeimporter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017
Since: 2017

Syntax

C#
public enum ShapeImporterSourceFormat
Visual Basic
Public Enumeration ShapeImporterSourceFormat
Visual C++
public enum class ShapeImporterSourceFormat

Members

Member name | Description
Auto | The format of the incoming data will be determined from input file extension.
SAT | The incoming data is in SAT format (*.sat).
Rhino | The incoming data is in Rhino format (*.3dm).
SketchUp | The incoming data is in SketchUp format (*.skp).
OBJ | The incoming data is in OBJ format (*.obj).
STL | The incoming data is in STL format (*.stl).

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


SharedParameterApplicableRule Class

[image]

Revit 2024 API
SharedParameterApplicableRule Class
Members See Also Send Feedback
Tests whether an element supports a shared parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class SharedParameterApplicableRule : FilterRule
Visual Basic
Public Class SharedParameterApplicableRule _
    Inherits FilterRule
Visual C++
public ref class SharedParameterApplicableRule : public FilterRule

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterRule
Autodesk.Revit.DB..::..SharedParameterApplicableRule

See Also

SharedParameterApplicableRule Members


SharedParameterApplicableRule Members

[image] [image]

Revit 2024 API
SharedParameterApplicableRule Members
SharedParameterApplicableRule Class Constructors Methods Properties See Also Send Feedback

The SharedParameterApplicableRule type exposes the following members.

Constructors

 | Name | Description
Public method | SharedParameterApplicableRule | Constructs an instance of SharedParameterApplicableRule.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterRule.)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter. (Inherited from FilterRule.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterRule.)
Public property | ParameterName | The name of the parameter that an element must support to pass this rule.

See Also

SharedParameterApplicableRule Class


SharedParameterApplicableRule Constructor

[image]

Revit 2024 API
SharedParameterApplicableRule Constructor
SharedParameterApplicableRule Class See Also Send Feedback
Constructs an instance of SharedParameterApplicableRule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public SharedParameterApplicableRule(
    string parameterName
)
Visual Basic
Public Sub New ( _
    parameterName As String _
)
Visual C++
public:
SharedParameterApplicableRule(
    String^ parameterName
)

Parameters

parameterName
Type: System..::..String
The name of the parameter that an element must support to pass this rule.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

SharedParameterApplicableRule Class


SharedParameterApplicableRule Properties

[image] [image]

Revit 2024 API
SharedParameterApplicableRule Properties
SharedParameterApplicableRule Class See Also Send Feedback

The SharedParameterApplicableRule type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterRule.)
Public property | ParameterName | The name of the parameter that an element must support to pass this rule.

See Also

SharedParameterApplicableRule Class


ParameterName Property

[image]

Revit 2024 API
SharedParameterApplicableRule..::..ParameterName Property
SharedParameterApplicableRule Class See Also Send Feedback
The name of the parameter that an element must support to pass this rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public string ParameterName { get; set; }
Visual Basic
Public Property ParameterName As String
    Get
    Set
Visual C++
public:
property String^ ParameterName {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

SharedParameterApplicableRule Class


SharedParameterElement Members

[image] [image]

Revit 2024 API
SharedParameterElement Members
SharedParameterElement Class Methods Properties See Also Send Feedback

The SharedParameterElement type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create | Creates a new shared parameter element in the document representing the parameter stored in the input ExternalDefinition.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDefinition | Get the definition representing this parameter element. (Inherited from ParameterElement.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
 | Lookup | Finds the shared parameter element that corresponds to the given Guid.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ShouldHideWhenNoValue | Indicates whether the parameter should be hidden from the properties palette if it has no value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | GuidValue | The Guid that identifies this shared parameter.
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SharedParameterElement Class


SharedParameterElement Methods

[image] [image]

Revit 2024 API
SharedParameterElement Methods
SharedParameterElement Class See Also Send Feedback

The SharedParameterElement type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create | Creates a new shared parameter element in the document representing the parameter stored in the input ExternalDefinition.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDefinition | Get the definition representing this parameter element. (Inherited from ParameterElement.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
 | Lookup | Finds the shared parameter element that corresponds to the given Guid.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ShouldHideWhenNoValue | Indicates whether the parameter should be hidden from the properties palette if it has no value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SharedParameterElement Class


Create Method

[image]

Revit 2024 API
SharedParameterElement..::..Create Method
SharedParameterElement Class See Also Send Feedback
Creates a new shared parameter element in the document representing the parameter stored in the input ExternalDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public static SharedParameterElement Create(
    Document document,
    ExternalDefinition sharedParameterDefinition
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    sharedParameterDefinition As ExternalDefinition _
) As SharedParameterElement
Visual C++
public:
static SharedParameterElement^ Create(
    Document^ document,
    ExternalDefinition^ sharedParameterDefinition
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
sharedParameterDefinition
Type: Autodesk.Revit.DB..::..ExternalDefinition
Shared parameter definition.

Return Value

The newly created shared parameter instance.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | A shared parameter with the assigned GUID is already loaded into the document.

See Also

SharedParameterElement Class


Lookup Method

[image]

Revit 2024 API
SharedParameterElement..::..Lookup Method
SharedParameterElement Class See Also Send Feedback
Finds the shared parameter element that corresponds to the given Guid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public static SharedParameterElement Lookup(
    Document document,
    Guid guidValue
)
Visual Basic
Public Shared Function Lookup ( _
    document As Document, _
    guidValue As Guid _
) As SharedParameterElement
Visual C++
public:
static SharedParameterElement^ Lookup(
    Document^ document,
    Guid guidValue
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
guidValue
Type: System..::..Guid
Shared parameter Guid.

Return Value

The retrieved shared parameter instance, or nullNothingnullptra null reference (Nothing in Visual Basic) if the matching element is not found.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

SharedParameterElement Class


ShouldHideWhenNoValue Method

[image]

Revit 2024 API
SharedParameterElement..::..ShouldHideWhenNoValue Method
SharedParameterElement Class See Also Send Feedback
Indicates whether the parameter should be hidden from the properties palette if it has no value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool ShouldHideWhenNoValue()
Visual Basic
Public Function ShouldHideWhenNoValue As Boolean
Visual C++
public:
bool ShouldHideWhenNoValue()

See Also

SharedParameterElement Class


SharedParameterElement Properties

[image] [image]

Revit 2024 API
SharedParameterElement Properties
SharedParameterElement Class See Also Send Feedback

The SharedParameterElement type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | GuidValue | The Guid that identifies this shared parameter.
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SharedParameterElement Class


GuidValue Property

[image]

Revit 2024 API
SharedParameterElement..::..GuidValue Property
SharedParameterElement Class See Also Send Feedback
The Guid that identifies this shared parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public Guid GuidValue { get; }
Visual Basic
Public ReadOnly Property GuidValue As Guid
    Get
Visual C++
public:
property Guid GuidValue {
    Guid get ();
}

See Also

SharedParameterElement Class


Parameter Property

[image] [image]

Revit 2024 API
SharedParameterElement..::..Parameter Property
SharedParameterElement Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

SharedParameterElement Class
SharedParameterElement Members


SheetDuplicateOption Enumeration

[image]

Revit 2024 API
SheetDuplicateOption Enumeration
See Also Send Feedback
Options for duplicating sheets

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023
Since: 2023

Syntax

C#
public enum SheetDuplicateOption
Visual Basic
Public Enumeration SheetDuplicateOption
Visual C++
public enum class SheetDuplicateOption

Members

Member name | Description
DuplicateEmptySheet | Duplicate the sheet, only copy its title block.
DuplicateSheetWithDetailing | Duplicate the sheet, copy the title block and details.
DuplicateSheetWithViewsOnly | Duplicate the sheet. Copy its title block, details, viewports and contained views. The newly created sheet will reference the newly duplicated views.
DuplicateSheetWithViewsAndDetailing | Duplicate the sheet. Copy its title block, details, viewports, and duplicate its contained views with detailing. The newly created sheet will reference the newly duplicated views.
DuplicateSheetWithViewsAsDependent | Duplicate the sheet. Copy its title block, details, viewports, and duplicate its contained views as dependent. The newly created sheet will reference the newly duplicated dependent views.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


ShellLayerType Enumeration

[image]

Revit 2024 API
ShellLayerType Enumeration
See Also Send Feedback
Used to distinguish exterior and interior shell layers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public enum ShellLayerType
Visual Basic
Public Enumeration ShellLayerType
Visual C++
public enum class ShellLayerType

Members

Member name | Description
Interior | Interior shell layer.
Exterior | Exterior shell layer.

Remarks

Used as an argument to methods of CompoundStructure that deal with shell layers.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


ShowHiddenLinesValues Enumeration

[image]

Revit 2024 API
ShowHiddenLinesValues Enumeration
See Also Send Feedback
Provides options for display of hidden lines in a given view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum ShowHiddenLinesValues
Visual Basic
Public Enumeration ShowHiddenLinesValues
Visual C++
public enum class ShowHiddenLinesValues

Members

Member name | Description
None | Do not show any hidden lines.
ByDiscipline | Show hidden lines according to discipline.
All | Show all hidden lines.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


SimpleWorksetConfiguration Enumeration

[image]

Revit 2024 API
SimpleWorksetConfiguration Enumeration
See Also Send Feedback
Indicates the set of user-created worksets to open in memory

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public enum SimpleWorksetConfiguration
Visual Basic
Public Enumeration SimpleWorksetConfiguration
Visual C++
public enum class SimpleWorksetConfiguration

Members

Member name | Description
AllWorksets | All user-created worksets.
AllEditable | All user-created worksets checked out to the current user.
LastViewed | The set of user-created worksets last opened for this model.
AskUserToSpecify | Explicitly ask the user the specify which user-created worksets to open.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


SiteLocation Class

[image]

Revit 2024 API
SiteLocation Class
Members Example See Also Send Feedback
Contains the geographical location information for the project's site.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class SiteLocation : ElementType
Visual Basic
Public Class SiteLocation _
    Inherits ElementType
Visual C++
public ref class SiteLocation : public ElementType

Remarks

Each project may have one site which dictates where in the world the project is based. On this site there may be several locations of the same project. These are represented by ProjectLocation objects. The site location object can be found by using the SiteLocation property on the Document object. The properties of this object can be changed such that it represents any location on the planet or to a known city. Cities already programmed into Revit can be found from the Cities property on the Application object.

Examples

CopyC#
// Get the SiteLocation instance.
Autodesk.Revit.DB.SiteLocation site = document.SiteLocation;

// Angles are in radians when coming from Revit API, so we
// convert to degrees for display
const double angleRatio = Math.PI / 180;   // angle conversion factor

// Format the prompt information.
String prompt = "Current project's Site location information:";
prompt += "\n\t" + "Latitude: " + site.Latitude / angleRatio + " degrees";
prompt += "\n\t" + "Longitude: " + site.Longitude / angleRatio + " degrees";
// Give the user some information.
TaskDialog.Show("Revit",prompt);

// Change the SiteLocation property data.
site.Latitude = 0.5;    // latitude information
site.Longitude = 0.5;   // longitude information
site.TimeZone = -5;     // TimeZone information
CopyVB.NET
' Get the SiteLocation instance.
Dim site As Autodesk.Revit.DB.SiteLocation = document.SiteLocation

' Angles are in radians when coming from Revit API, so we
' convert to degrees for display
Const  angleRatio As Double = Math.PI / 180
' angle conversion factor
' Format the prompt information.
Dim prompt As [String] = "Current project's Site location information:"
prompt += vbLf & vbTab & "Latitude: " & site.Latitude / angleRatio & "°"
prompt += vbLf & vbTab & "Longitude: " & site.Longitude / angleRatio & "°"
prompt += (vbLf & vbTab & "TimeZone: ") + site.TimeZone

' Give the user some information.
TaskDialog.Show("Revit", prompt)

' Change the SiteLocation property data.
site.Latitude = 0.5
' latitude information
site.Longitude = 0.5
' longitude information
site.TimeZone = -5
' TimeZone information

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..SiteLocation

See Also

SiteLocation Members


SiteLocation Members

[image] [image]

Revit 2024 API
SiteLocation Members
SiteLocation Class Methods Properties See Also Send Feedback

The SiteLocation type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | ConvertFromProjectTime | Converts project time to UTC time.
Public method | ConvertToProjectTime | Converts local time or UTC time to project time.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCompatibleWith | Checks whether the geographic coordinate system of this site is compatible with the given site . True if he geographic coordinate system of this site is compatible with the given site, false otherwise.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetGeoCoordinateSystem | Set the geographic coordinate system for this site. Similar to acquire coordinate system from a link in the UI.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Elevation | The elevation of the site location.
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | GeoCoordinateSystemDefinition | The XML string which describes the geographic coordinate system.
Public property | GeoCoordinateSystemId | The geographic coordinate system ID, such as "AMG-50" and "Beijing1954/a.GK3d-40".
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | Latitude | The latitude of the site location.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Longitude | The longitude of the site location.
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | PlaceName | The place name of the site.
Public property | TimeZone | The time-zone for the site.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WeatherStationName | The name of the weather station at the site location.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SiteLocation Class


SiteLocation Methods

[image] [image]

Revit 2024 API
SiteLocation Methods
SiteLocation Class See Also Send Feedback

The SiteLocation type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | ConvertFromProjectTime | Converts project time to UTC time.
Public method | ConvertToProjectTime | Converts local time or UTC time to project time.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCompatibleWith | Checks whether the geographic coordinate system of this site is compatible with the given site . True if he geographic coordinate system of this site is compatible with the given site, false otherwise.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetGeoCoordinateSystem | Set the geographic coordinate system for this site. Similar to acquire coordinate system from a link in the UI.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SiteLocation Class


ConvertFromProjectTime Method

[image]

Revit 2024 API
SiteLocation..::..ConvertFromProjectTime Method
SiteLocation Class See Also Send Feedback
Converts project time to UTC time.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public DateTime ConvertFromProjectTime(
    DateTime projectTime
)
Visual Basic
Public Function ConvertFromProjectTime ( _
    projectTime As DateTime _
) As DateTime
Visual C++
public:
DateTime ConvertFromProjectTime(
    DateTime projectTime
)

Parameters

projectTime
Type: System..::..DateTime
The project time.

Remarks

Daylight savings time is not considered during this conversion.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the projectTime's kind is not Unspecified.

See Also

SiteLocation Class


IsCompatibleWith Method

[image]

Revit 2024 API
SiteLocation..::..IsCompatibleWith Method
SiteLocation Class See Also Send Feedback
Checks whether the geographic coordinate system of this site is compatible with the given site . True if he geographic coordinate system of this site is compatible with the given site, false otherwise.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public bool IsCompatibleWith(
    SiteLocation otherSiteLocation
)
Visual Basic
Public Function IsCompatibleWith ( _
    otherSiteLocation As SiteLocation _
) As Boolean
Visual C++
public:
bool IsCompatibleWith(
    SiteLocation^ otherSiteLocation
)

Parameters

otherSiteLocation
Type: Autodesk.Revit.DB..::..SiteLocation

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

SiteLocation Class


Elevation Property

[image]

Revit 2024 API
SiteLocation..::..Elevation Property
SiteLocation Class See Also Send Feedback
The elevation of the site location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014 UR2

Syntax

C#
public double Elevation { get; }
Visual Basic
Public ReadOnly Property Elevation As Double
    Get
Visual C++
public:
property double Elevation {
    double get ();
}

See Also

SiteLocation Class


GeoCoordinateSystemDefinition Property

[image]

Revit 2024 API
SiteLocation..::..GeoCoordinateSystemDefinition Property
SiteLocation Class See Also Send Feedback
The XML string which describes the geographic coordinate system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public string GeoCoordinateSystemDefinition { get; }
Visual Basic
Public ReadOnly Property GeoCoordinateSystemDefinition As String
    Get
Visual C++
public:
property String^ GeoCoordinateSystemDefinition {
    String^ get ();
}

Remarks

If the site does not have a geographic coordinate system, it returns an empty string for this property.

See Also

SiteLocation Class


Latitude Property

[image]

Revit 2024 API
SiteLocation..::..Latitude Property
SiteLocation Class See Also Send Feedback
The latitude of the site location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double Latitude { get; set; }
Visual Basic
Public Property Latitude As Double
    Get
    Set
Visual C++
public:
property double Latitude {
    double get ();
    void set (double value);
}

Remarks

A property that contains the latitude of the site location. The value of this property is in radians between +PI/2 and -PI/2.

When setting this property:

  1. Revit will attempt to match the coordinates to a city it knows about, and if a match is found, will set the name accordingly.
  2. Revit will attempt to automatically adjust the time zone value to match the new Latitude value set using [!:Autodesk::Revit::DB::SunAndShadowSettings::CalculateTimeZone]. For some boundary cases, the time zone calculated may not be correct. You can set the TimeZone property directly to the correct value if necessary.
  3. Revit will attempt to automatically update the weather station associated with the location's coordinates.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The latitude value is out of range. It must be between -PI/2 and PI/2.

See Also

SiteLocation Class


PlaceName Property

[image]

Revit 2024 API
SiteLocation..::..PlaceName Property
SiteLocation Class See Also Send Feedback
The place name of the site.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public string PlaceName { get; set; }
Visual Basic
Public Property PlaceName As String
    Get
    Set
Visual C++
public:
property String^ PlaceName {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

SiteLocation Class


TimeZone Property

[image]

Revit 2024 API
SiteLocation..::..TimeZone Property
SiteLocation Class See Also Send Feedback
The time-zone for the site.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double TimeZone { get; set; }
Visual Basic
Public Property TimeZone As Double
    Get
    Set
Visual C++
public:
property double TimeZone {
    double get ();
    void set (double value);
}

Field Value

Hours ranging from -12 to +12. 0 represents GMT. Note that if the input value is not in the valid range, it will be shifted by multiples of 24 until it is in range.

Remarks

Remarks

A property that returns the time zone in which the site resides. The value is in hours, ranging from +12 hours to -12 hours with 0 being GMT. If the input value is not in the valid range, it will be shifted by multiples of 24 until it is in range.

Set this property directly if for your desired latitude and longitude, Revit's calculation does not match with the actual time zone for your location. Note that there are no restrictions preventing you from setting this to an incorrect value for the site location, and incorrect times for Solar Studies may result.

See Also

SiteLocation Class


WeatherStationName Property

[image]

Revit 2024 API
SiteLocation..::..WeatherStationName Property
SiteLocation Class See Also Send Feedback
The name of the weather station at the site location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014 UR2

Syntax

C#
public string WeatherStationName { get; }
Visual Basic
Public ReadOnly Property WeatherStationName As String
    Get
Visual C++
public:
property String^ WeatherStationName {
    String^ get ();
}

See Also

SiteLocation Class


Sketch Class

[image]

Revit 2024 API
Sketch Class
Members See Also Send Feedback
Provides access to the Sketch in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class Sketch : SketchBase
Visual Basic
Public Class Sketch _
    Inherits SketchBase
Visual C++
public ref class Sketch : public SketchBase

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..SketchBase
Autodesk.Revit.DB..::..Sketch

See Also

Sketch Members


Sketch Members

[image] [image]

Revit 2024 API
Sketch Members
Sketch Class Methods Properties See Also Send Feedback

The Sketch type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetAllElements | Returns all elements which belong to the sketch.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerId | Returns id of the sketch owner element or invalidElementId if sketch does not build a geometry.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Profile | Returns the Profile of the Sketch.
Public property | SketchPlane | Returns the Sketch Plane of the Sketch.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Sketch Class


Sketch Methods

[image] [image]

Revit 2024 API
Sketch Methods
Sketch Class See Also Send Feedback

The Sketch type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetAllElements | Returns all elements which belong to the sketch.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Sketch Class


GetAllElements Method

[image]

Revit 2024 API
Sketch..::..GetAllElements Method
Sketch Class See Also Send Feedback
Returns all elements which belong to the sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public IList<ElementId> GetAllElements()
Visual Basic
Public Function GetAllElements As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetAllElements()

Return Value

Returns ids of elements which belong to that sketch.

Remarks

Following elements can belong to a sketch: ModelCurve, ReferencePlane, Dimension. To get matching between Curve from Profile and ModelCurve, use [!:Autodesk::Revit::DB::Curve::Reference::ElementId].

See Also

Sketch Class


Sketch Properties

[image] [image]

Revit 2024 API
Sketch Properties
Sketch Class See Also Send Feedback

The Sketch type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerId | Returns id of the sketch owner element or invalidElementId if sketch does not build a geometry.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Profile | Returns the Profile of the Sketch.
Public property | SketchPlane | Returns the Sketch Plane of the Sketch.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Sketch Class


OwnerId Property

[image]

Revit 2024 API
Sketch..::..OwnerId Property
Sketch Class See Also Send Feedback
Returns id of the sketch owner element or invalidElementId if sketch does not build a geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public ElementId OwnerId { get; }
Visual Basic
Public ReadOnly Property OwnerId As ElementId
    Get
Visual C++
public:
property ElementId^ OwnerId {
    ElementId^ get ();
}

See Also

Sketch Class


Profile Property

[image]

Revit 2024 API
Sketch..::..Profile Property
Sketch Class See Also Send Feedback
Returns the Profile of the Sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CurveArrArray Profile { get; }
Visual Basic
Public ReadOnly Property Profile As CurveArrArray
    Get
Visual C++
public:
property CurveArrArray^ Profile {
    CurveArrArray^ get ();
}

Remarks

This property is used to retrieve the Profile of Sketch.

See Also

Sketch Class


SketchBase Class

[image]

Revit 2024 API
SketchBase Class
Members See Also Send Feedback
Provides access to the SketchBase in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class SketchBase : Element
Visual Basic
Public Class SketchBase _
    Inherits Element
Visual C++
public ref class SketchBase : public Element

Remarks

SketchBase is the base class of Sketch.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..SketchBase
Autodesk.Revit.DB..::..Path3d
Autodesk.Revit.DB..::..Sketch

See Also

SketchBase Members


SketchBase Members

[image] [image]

Revit 2024 API
SketchBase Members
SketchBase Class Methods Properties See Also Send Feedback

The SketchBase type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SketchBase Class


SketchBase Methods

[image] [image]

Revit 2024 API
SketchBase Methods
SketchBase Class See Also Send Feedback

The SketchBase type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SketchBase Class


SketchBase Properties

[image] [image]

Revit 2024 API
SketchBase Properties
SketchBase Class See Also Send Feedback

The SketchBase type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SketchBase Class


SketchEditScope Class

[image]

Revit 2024 API
SketchEditScope Class
Members Example See Also Send Feedback
A SketchEditScope allows an application to create and maintain an editing session for a Sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public class SketchEditScope : EditScope
Visual Basic
Public Class SketchEditScope _
    Inherits EditScope
Visual C++
public ref class SketchEditScope : public EditScope

Remarks

Start/end of a SketchEditScope will start/end a transaction group. After a SketchEditScope is started, an application can start transactions and edit the sketch. Individual transactions the application creates inside SketchEditScope will not appear in the undo menu. All transactions committed during the edit mode will be merged into a single one which will bear the given name passed into SketchEditScope constructor.

Examples

CopyC#
public void ReplaceBoundaryLine(Document document)
{
   FilteredElementCollector floorCollector = new FilteredElementCollector(document)
      .WhereElementIsNotElementType()
      .OfCategory(BuiltInCategory.OST_Floors).OfClass(typeof(Floor));

   Floor floor = floorCollector.FirstOrDefault() as Floor;
   if (floor == null)
   {
      TaskDialog.Show("Error", "Document does not contain a floor.");
      return;
   }

   Sketch sketch = document.GetElement(floor.SketchId) as Sketch;

   Line line = null;
   foreach (CurveArray curveArray in sketch.Profile)
   {
      foreach (Curve curve in curveArray)
      {
         line = curve as Line;
         if (line != null)
         {
            break;
         }
      }
      if (line != null)
      {
         break;
      }
   }

   if (line == null)
   {
      TaskDialog.Show("Error", "Sketch does not contain a straight line.");
      return;
   }

   // Start a sketch edit scope
   SketchEditScope sketchEditScope = new SketchEditScope(document, "Replace line with an arc");
   sketchEditScope.Start(sketch.Id);

   using (Transaction transaction = new Transaction(document, "Modify sketch"))
   {
      transaction.Start();

      // Create arc
      XYZ normal = line.Direction.CrossProduct(XYZ.BasisZ).Normalize().Negate();
      XYZ middle = line.GetEndPoint(0).Add(line.Direction.Multiply(line.Length / 2));
      Curve arc = Arc.Create(line.GetEndPoint(0), line.GetEndPoint(1), middle.Add(normal.Multiply(20)));

      // Remove element referenced by the found line.
      document.Delete(line.Reference.ElementId);

      // Model curve creation automatically puts the curve into the sketch, if sketch edit scope is running.
      document.Create.NewModelCurve(arc, sketch.SketchPlane);

      transaction.Commit();
   }

   sketchEditScope.Commit(new FailuresPreprocessor());
}
CopyC#
public void ReplaceBoundaryLine(Document document)
{
   FilteredElementCollector floorCollector = new FilteredElementCollector(document)
      .WhereElementIsNotElementType()
      .OfCategory(BuiltInCategory.OST_Floors).OfClass(typeof(Floor));

   Floor floor = floorCollector.FirstOrDefault() as Floor;
   if (floor == null)
   {
      TaskDialog.Show("Error", "Document does not contain a floor.");
      return;
   }

   Sketch sketch = document.GetElement(floor.SketchId) as Sketch;

   Line line = null;
   foreach (CurveArray curveArray in sketch.Profile)
   {
      foreach (Curve curve in curveArray)
      {
         line = curve as Line;
         if (line != null)
         {
            break;
         }
      }
      if (line != null)
      {
         break;
      }
   }

   if (line == null)
   {
      TaskDialog.Show("Error", "Sketch does not contain a straight line.");
      return;
   }

   // Start a sketch edit scope
   SketchEditScope sketchEditScope = new SketchEditScope(document, "Replace line with an arc");
   sketchEditScope.Start(sketch.Id);

   using (Transaction transaction = new Transaction(document, "Modify sketch"))
   {
      transaction.Start();

      // Create arc
      XYZ normal = line.Direction.CrossProduct(XYZ.BasisZ).Normalize().Negate();
      XYZ middle = line.GetEndPoint(0).Add(line.Direction.Multiply(line.Length / 2));
      Curve arc = Arc.Create(line.GetEndPoint(0), line.GetEndPoint(1), middle.Add(normal.Multiply(20)));

      // Remove element referenced by the found line.
      document.Delete(line.Reference.ElementId);

      // Model curve creation automatically puts the curve into the sketch, if sketch edit scope is running.
      document.Create.NewModelCurve(arc, sketch.SketchPlane);

      transaction.Commit();
   }

   sketchEditScope.Commit(new FailuresPreprocessor());
}

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..EditScope
Autodesk.Revit.DB..::..SketchEditScope

See Also

SketchEditScope Members


SketchEditScope Members

[image] [image]

Revit 2024 API
SketchEditScope Members
SketchEditScope Class Constructors Methods Properties See Also Send Feedback

The SketchEditScope type exposes the following members.

Constructors

 | Name | Description
Public method | SketchEditScope | Instantiates a SketchEditScope object.

Methods

 | Name | Description
Public method | Cancel | Cancels the edit scope. (Inherited from EditScope.)
Public method | Commit | Finishes the edit scope. (Inherited from EditScope.)
Public method | Dispose | (Inherited from EditScope.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsElementWithoutSketch | Validates if an element can have a sketch but currently does not.
Public method | IsSketchEditingSupported | Checks whether sketch can be edited.
Public method | IsSketchEditingSupportedForSketchBasedElement | Checks whether the element supports sketch editing.
Public method | Start | Starts a sketch edit mode.
Public method | StartWithNewSketch | Starts a sketch edit mode for an element which, at this moment, doesn't have a sketch.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsActive | Tells if the EditScope is active. In other words, the EditScope has started but not committed/canceled yet. (Inherited from EditScope.)
Public property | IsPermitted | Tells if the edit scope is permitted to start. (Inherited from EditScope.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from EditScope.)

See Also

SketchEditScope Class


SketchEditScope Constructor

[image]

Revit 2024 API
SketchEditScope Constructor
SketchEditScope Class See Also Send Feedback
Instantiates a SketchEditScope object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public SketchEditScope(
    Document document,
    string transactionName
)
Visual Basic
Public Sub New ( _
    document As Document, _
    transactionName As String _
)
Visual C++
public:
SketchEditScope(
    Document^ document,
    String^ transactionName
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document for which this SketchEditScope is going to be used.
transactionName
Type: System..::..String
The name that will appear in the Undo menu in Revit after the SketchEditScope is successfully committed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a primary document, it is a linked document. -or- document is not a project document. -or- transactionName is an empty string.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

SketchEditScope Class


SketchEditScope Methods

[image] [image]

Revit 2024 API
SketchEditScope Methods
SketchEditScope Class See Also Send Feedback

The SketchEditScope type exposes the following members.

Methods

 | Name | Description
Public method | Cancel | Cancels the edit scope. (Inherited from EditScope.)
Public method | Commit | Finishes the edit scope. (Inherited from EditScope.)
Public method | Dispose | (Inherited from EditScope.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsElementWithoutSketch | Validates if an element can have a sketch but currently does not.
Public method | IsSketchEditingSupported | Checks whether sketch can be edited.
Public method | IsSketchEditingSupportedForSketchBasedElement | Checks whether the element supports sketch editing.
Public method | Start | Starts a sketch edit mode.
Public method | StartWithNewSketch | Starts a sketch edit mode for an element which, at this moment, doesn't have a sketch.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SketchEditScope Class


IsSketchEditingSupported Method

[image]

Revit 2024 API
SketchEditScope..::..IsSketchEditingSupported Method
SketchEditScope Class See Also Send Feedback
Checks whether sketch can be edited.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public bool IsSketchEditingSupported(
    ElementId sketchId
)
Visual Basic
Public Function IsSketchEditingSupported ( _
    sketchId As ElementId _
) As Boolean
Visual C++
public:
bool IsSketchEditingSupported(
    ElementId^ sketchId
)

Parameters

sketchId
Type: Autodesk.Revit.DB..::..ElementId
The element id of sketch.

Return Value

True if sketch can be edited, false otherwise.

Remarks

This method checks if this particular sketch can be edited. If you want to check if all sketches of an element can be edited please use IsSketchEditingSupportedForSketchBasedElement(ElementId)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

SketchEditScope Class


IsSketchEditingSupportedForSketchBasedElement Method

[image]

Revit 2024 API
SketchEditScope..::..IsSketchEditingSupportedForSketchBasedElement Method
SketchEditScope Class See Also Send Feedback
Checks whether the element supports sketch editing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public bool IsSketchEditingSupportedForSketchBasedElement(
    ElementId elemId
)
Visual Basic
Public Function IsSketchEditingSupportedForSketchBasedElement ( _
    elemId As ElementId _
) As Boolean
Visual C++
public:
bool IsSketchEditingSupportedForSketchBasedElement(
    ElementId^ elemId
)

Parameters

elemId
Type: Autodesk.Revit.DB..::..ElementId
The element id to be checked.

Return Value

True if element supports sketch editing, false otherwise.

Remarks

This method checks if the element supports edit to all its sketches. If you want to check if this element supports edit to a particular sketch please use IsSketchEditingSupported(ElementId).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

SketchEditScope Class


Start Method

[image]

Revit 2024 API
SketchEditScope..::..Start Method
SketchEditScope Class See Also Send Feedback
Starts a sketch edit mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public void Start(
    ElementId sketchId
)
Visual Basic
Public Sub Start ( _
    sketchId As ElementId _
)
Visual C++
public:
void Start(
    ElementId^ sketchId
)

Parameters

sketchId
Type: Autodesk.Revit.DB..::..ElementId
The Sketch element to be edited.

Remarks

The application will need to start a transaction to actually make changes to the Sketch element. SketchEditScope can only be started when there is no transaction active, thus it does not work for commands running in automatic transaction mode.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId sketchId does not represent a Sketch. -or- Sketch does not support editing. -or- Failed to start the sketch edit mode.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This SketchEditScope is not permitted to start at this moment for one of the following possible reasons: The document is in read-only state, or the document is currently modifiable, or there already is another edit mode active in the document.

See Also

SketchEditScope Class


StartWithNewSketch Method

[image]

Revit 2024 API
SketchEditScope..::..StartWithNewSketch Method
SketchEditScope Class Example See Also Send Feedback
Starts a sketch edit mode for an element which, at this moment, doesn't have a sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public void StartWithNewSketch(
    ElementId elementId
)
Visual Basic
Public Sub StartWithNewSketch ( _
    elementId As ElementId _
)
Visual C++
public:
void StartWithNewSketch(
    ElementId^ elementId
)

Parameters

elementId
Type: Autodesk.Revit.DB..::..ElementId
The Element without sketch to be edited.

Remarks

Some surface Revit elements (like some Walls or some Analytical Elements) does not have a valid sketch all the time so in order to edit them, we have to create a valid sketch first. The application will need to start a transaction to actually make changes to the element. SketchEditScope can only be started when there is no transaction active, thus it does not work for commands running in automatic transaction mode.

Examples

CopyC#
Document document = commandData.Application.ActiveUIDocument.Document;

//create analytical panel
AnalyticalPanel analyticalPanel = CreateAnalyticalPanel.CreateAMPanel(document);
if (analyticalPanel != null)
{
   // Start a sketch edit scope
   SketchEditScope sketchEditScope = new SketchEditScope(document, "Replace line with an arc");
   sketchEditScope.StartWithNewSketch(analyticalPanel.Id);

   using (Transaction transaction = new Transaction(document, "Modify sketch"))
   {
      transaction.Start();

      //replace a boundary line with an arc
      Line line = null;
      Sketch sketch = document.GetElement(analyticalPanel.SketchId) as Sketch;
      if (sketch != null)
      {
         foreach (CurveArray curveArray in sketch.Profile)
         {
            foreach (Curve curve in curveArray)
            {
               line = curve as Line;
               if (line != null)
               {
                  break;
               }
            }
            if (line != null)
            {
               break;
            }
         }
      }

      // Create arc
      XYZ normal = line.Direction.CrossProduct(XYZ.BasisZ).Normalize().Negate();
      XYZ middle = line.GetEndPoint(0).Add(line.Direction.Multiply(line.Length / 2));
      Curve arc = Arc.Create(line.GetEndPoint(0), line.GetEndPoint(1), middle.Add(normal.Multiply(20)));

      // Remove element referenced by the found line.
      document.Delete(line.Reference.ElementId);

      // Model curve creation automatically puts the curve into the sketch, if sketch edit scope is running.
      document.Create.NewModelCurve(arc, sketch.SketchPlane);

      transaction.Commit();
   }

   sketchEditScope.Commit(new FailurePreproccessor());

}

return Result.Succeeded;

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId elementId already has a sketch defined. -or- Element does not support sketch editing. -or- Failed to start the sketch edit mode.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This SketchEditScope is not permitted to start at this moment for one of the following possible reasons: The document is in read-only state, or the document is currently modifiable, or there already is another edit mode active in the document. -or- Cannot create sketch.

See Also

SketchEditScope Class


SketchedStairsCurveData Members

[image] [image]

Revit 2024 API
SketchedStairsCurveData Members
SketchedStairsCurveData Class Constructors Methods Properties See Also Send Feedback

The SketchedStairsCurveData type exposes the following members.

Constructors

 | Name | Description
Public method | SketchedStairsCurveData | Construct a SketchedStairsCurveData defined by a curve associated with its height and slope type.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the SketchedStairsCurveData
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCurve | Get a copy of the curve that is formed along this boundary.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

SketchedStairsCurveData Class


SketchedStairsCurveData Constructor

[image]

Revit 2024 API
SketchedStairsCurveData Constructor
SketchedStairsCurveData Class See Also Send Feedback
Construct a SketchedStairsCurveData defined by a curve associated with its height and slope type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public SketchedStairsCurveData(
    Curve boundaryCurve,
    double height,
    SketchedCurveSlopeOption slopeType
)
Visual Basic
Public Sub New ( _
    boundaryCurve As Curve, _
    height As Double, _
    slopeType As SketchedCurveSlopeOption _
)
Visual C++
public:
SketchedStairsCurveData(
    Curve^ boundaryCurve,
    double height,
    SketchedCurveSlopeOption slopeType
)

Parameters

boundaryCurve
Type: Autodesk.Revit.DB..::..Curve
height
Type: System..::..Double
slopeType
Type: Autodesk.Revit.DB.Architecture..::..SketchedCurveSlopeOption

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

SketchedStairsCurveData Class


Dispose Method

[image]

Revit 2024 API
SketchedStairsCurveData..::..Dispose Method
SketchedStairsCurveData Class See Also Send Feedback
Releases all resources used by the SketchedStairsCurveData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

SketchedStairsCurveData Class


GetCurve Method

[image]

Revit 2024 API
SketchedStairsCurveData..::..GetCurve Method
SketchedStairsCurveData Class See Also Send Feedback
Get a copy of the curve that is formed along this boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public Curve GetCurve()
Visual Basic
Public Function GetCurve As Curve
Visual C++
public:
Curve^ GetCurve()

Return Value

A copy of the curve.

See Also

SketchedStairsCurveData Class


SketchedStairsCurveData Properties

[image] [image]

Revit 2024 API
SketchedStairsCurveData Properties
SketchedStairsCurveData Class See Also Send Feedback

The SketchedStairsCurveData type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

SketchedStairsCurveData Class


IsValidObject Property

[image]

Revit 2024 API
SketchedStairsCurveData..::..IsValidObject Property
SketchedStairsCurveData Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

SketchedStairsCurveData Class


SketchPlane Class

[image]

Revit 2024 API
SketchPlane Class
Members Example See Also Send Feedback
Represents a sketch plane or work plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class SketchPlane : Element
Visual Basic
Public Class SketchPlane _
    Inherits Element
Visual C++
public ref class SketchPlane : public Element

Remarks

A SketchPlane object is used as an input to creation of sketch-referencing elements such as Model Curves or sketch-owning elements such as Generic Forms. The SketchPlane can be obtained from an existing element or created from a geometric plane or planar face. Note that the sketch plane element passed as input to create an element may not be the actual sketch plane assigned to that element; Revit may look for a geometrically equivalent plane to use, or may create a new one if the input plane is already used for other purposes. Some sketch planes (such as those obtained from detail curves) are suitable only for use in creating detail elements; they will be rejected when used for other element types.

Examples

CopyC#
public void ShowSketchPlane(SketchPlane sketchPlane)
{
    // get the information of the created sketch plane
    string information = "Sketch Plane: ";
    //get the corresponding Plane
    Autodesk.Revit.DB.Plane plane = sketchPlane.GetPlane();
    //show the plane's origin point
    information += "\norigin of the plane:  " + XYZToString(plane.Origin);
    //show the plane's normal vector
    information += "\nnormal of the plane:  " + XYZToString(plane.Normal);
    //show the plane's Xvec vector
    information += "\nXvec of the plane: (" + XYZToString(plane.XVec);
    //show the plane's Yvec vector
    information += "\nYvec of the plane: (" + XYZToString(plane.YVec);

    TaskDialog.Show("Revit",information);
}

// output the point's three coordinates
string XYZToString(XYZ point)
{
    return "(" + point.X + ", " + point.Y + ", " + point.Z + ")";
}
CopyVB.NET
Public Sub ShowSketchPlane(sketchPlane As SketchPlane)
    ' get the information of the created sketch plane
    Dim information As String = "Sketch Plane: "
    'get the corresponding Plane
    Dim plane As Autodesk.Revit.DB.Plane = sketchPlane.GetPlane()
    'show the plane's origin point
    information += vbLf & "origin of the plane:  " & XYZToString(plane.Origin)
    'show the plane's normal vector
    information += vbLf & "normal of the plane:  " & XYZToString(plane.Normal)
    'show the plane's Xvec vector
    information += vbLf & "Xvec of the plane: (" & XYZToString(plane.XVec)
    'show the plane's Yvec vector
    information += vbLf & "Yvec of the plane: (" & XYZToString(plane.YVec)

    TaskDialog.Show("Revit", information)
End Sub

' output the point's three coordinates
Private Function XYZToString(point As XYZ) As String
    Return "(" & Convert.ToString(point.X) & ", " & Convert.ToString(point.Y) & ", " & Convert.ToString(point.Z) & ")"
End Function

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..SketchPlane

See Also

SketchPlane Members


SketchPlane Members

[image] [image]

Revit 2024 API
SketchPlane Members
SketchPlane Class Methods Properties See Also Send Feedback

The SketchPlane type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create(Document, ElementId) | Creates a sketch plane from a grid, reference plane, or level.
 | Create(Document, Plane) | Creates a new sketch plane from a geometric plane.
 | Create(Document, Reference) | Creates a new sketch plane from a reference to a planar face.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPlane | Returns the corresponding Plane.
Public method | GetPlaneReference | Returns a reference to this element as a plane.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsSuitableForModelElements | Identifies if the sketch plane can be assigned to model elements.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SketchPlane Class


SketchPlane Methods

[image] [image]

Revit 2024 API
SketchPlane Methods
SketchPlane Class See Also Send Feedback

The SketchPlane type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create(Document, ElementId) | Creates a sketch plane from a grid, reference plane, or level.
 | Create(Document, Plane) | Creates a new sketch plane from a geometric plane.
 | Create(Document, Reference) | Creates a new sketch plane from a reference to a planar face.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPlane | Returns the corresponding Plane.
Public method | GetPlaneReference | Returns a reference to this element as a plane.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SketchPlane Class


Create Method

[image] [image]

Revit 2024 API
SketchPlane..::..Create Method
SketchPlane Class See Also Send Feedback

Overload List

Name | Description
Create(Document, ElementId) | Creates a sketch plane from a grid, reference plane, or level.
Create(Document, Plane) | Creates a new sketch plane from a geometric plane.
Create(Document, Reference) | Creates a new sketch plane from a reference to a planar face.

See Also

SketchPlane Class
SketchPlane Members


Create Method (Document, ElementId)

[image]

Revit 2024 API
SketchPlane..::..Create Method (Document, ElementId)
SketchPlane Class See Also Send Feedback
Creates a sketch plane from a grid, reference plane, or level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static SketchPlane Create(
    Document document,
    ElementId datumId
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    datumId As ElementId _
) As SketchPlane
Visual C++
public:
static SketchPlane^ Create(
    Document^ document,
    ElementId^ datumId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
datumId
Type: Autodesk.Revit.DB..::..ElementId
The id of the grid, reference plane, or level.

Return Value

The newly created sketch plane.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | datumId is not a valid Element identifier. -or- ElementId must correspond to a grid, reference plane, or level. -or- ElementId must correspond to a non-curved datum. -or- Sketch plane creation is not allowed in this family.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

SketchPlane Class
Create Overload


Create Method (Document, Plane)

[image]

Revit 2024 API
SketchPlane..::..Create Method (Document, Plane)
SketchPlane Class Example See Also Send Feedback
Creates a new sketch plane from a geometric plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static SketchPlane Create(
    Document document,
    Plane plane
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    plane As Plane _
) As SketchPlane
Visual C++
public:
static SketchPlane^ Create(
    Document^ document,
    Plane^ plane
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
plane
Type: Autodesk.Revit.DB..::..Plane
The geometry plane where the sketch plane will be created.

Return Value

The newly created sketch plane.

Remarks

There will not be a reference relationship established from the sketch plane to the input face. To create a SketchPlane with a reference to other geometry, use the overload with a Reference input.

Examples

CopyC#
public static SketchPlane CreateSketchPlane(Autodesk.Revit.DB.Document document, Plane plane)
{
    SketchPlane sketchPlane = null;

    // create a sketch plane using Geometry.Plane
    sketchPlane = SketchPlane.Create(document, plane);

    // throw exception if creation failed
    if (null == sketchPlane)
    {
        throw new Exception("Create the sketch plane failed.");
    }

    return sketchPlane;
}
CopyVB.NET
Public Shared Function CreateSketchPlane(document As Autodesk.Revit.DB.Document, plane As Plane) As SketchPlane
    Dim sketchPlane__1 As SketchPlane = Nothing

    ' create a sketch plane using Geometry.Plane
    sketchPlane__1 = SketchPlane.Create(document, plane)

    ' throw exception if creation failed
    If sketchPlane__1 Is Nothing Then
        Throw New Exception("Create the sketch plane failed.")
    End If

    Return sketchPlane__1
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Sketch plane creation is not allowed in this family.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

SketchPlane Class
Create Overload


GetPlaneReference Method

[image]

Revit 2024 API
SketchPlane..::..GetPlaneReference Method
SketchPlane Class See Also Send Feedback
Returns a reference to this element as a plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public Reference GetPlaneReference()
Visual Basic
Public Function GetPlaneReference As Reference
Visual C++
public:
Reference^ GetPlaneReference()

Return Value

The reference.

Remarks

The object returned here can be used with the PointOnPlane class.

See Also

SketchPlane Class


SketchPlane Properties

[image] [image]

Revit 2024 API
SketchPlane Properties
SketchPlane Class See Also Send Feedback

The SketchPlane type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsSuitableForModelElements | Identifies if the sketch plane can be assigned to model elements.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SketchPlane Class


IsSuitableForModelElements Property

[image]

Revit 2024 API
SketchPlane..::..IsSuitableForModelElements Property
SketchPlane Class See Also Send Feedback
Identifies if the sketch plane can be assigned to model elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsSuitableForModelElements { get; }
Visual Basic
Public ReadOnly Property IsSuitableForModelElements As Boolean
    Get
Visual C++
public:
property bool IsSuitableForModelElements {
    bool get ();
}

Remarks

Sketch planes with this property set to true are suitable to be used to create model elements. Planes where this property is false will be rejected when used to create model curves, symbolic curves, generic forms, or other sketched elements.

See Also

SketchPlane Class


Parameter Property

[image] [image]

Revit 2024 API
SketchPlane..::..Parameter Property
SketchPlane Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

SketchPlane Class
SketchPlane Members


SKPImportOptions Class

[image]

Revit 2024 API
SKPImportOptions Class
Members See Also Send Feedback
The import options used to import SKP format files.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class SKPImportOptions : BaseImportOptions
Visual Basic
Public Class SKPImportOptions _
    Inherits BaseImportOptions
Visual C++
public ref class SKPImportOptions : public BaseImportOptions

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BaseImportOptions
Autodesk.Revit.DB..::..SKPImportOptions

See Also

SKPImportOptions Members


SKPImportOptions Members

[image] [image]

Revit 2024 API
SKPImportOptions Members
SKPImportOptions Class Constructors Methods Properties See Also Send Feedback

The SKPImportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | SKPImportOptions()()()() | Constructs a new instance of SKPImportOptions with default values of all properties.
Public method | SKPImportOptions(SKPImportOptions) | Constructs a new instance of SKPImportOptions as a copy of the import options.

Methods

 | Name | Description
Public method | Dispose | (Inherited from BaseImportOptions.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDefaultLengthUnit | Get the default length unit used for importing unitless files. (Inherited from BaseImportOptions.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLayerSelection | Get all set layers name which user want to import into Revit. (Inherited from BaseImportOptions.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultLengthUnit | Set the default length unit used for importing unitless files. (Inherited from BaseImportOptions.)
Public method | SetLayerSelection | Set the layers name which user want to import into Revit. (Inherited from BaseImportOptions.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AutoCorrectAlmostVHLines | Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines. (Inherited from BaseImportOptions.)
Public property | ColorMode | Color mode for the import. Three modes are supported. Black and White, Preserve Colors, and Invert Colors. (Inherited from BaseImportOptions.)
Public property | CustomScale | Scaling the import. If this is defined and a valid value (> 0.0), it takes priority over units. (Inherited from BaseImportOptions.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BaseImportOptions.)
Public property | OrientToView | Place the import at the same orientation as the view that was passed into the import method. This option can only be used when not importing into a single view.(i.e. ThisViewOnly is set to false) (Inherited from BaseImportOptions.)
Public property | Placement | Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates. (Inherited from BaseImportOptions.)
Public property | ReferencePoint | The 3D point in the document where the imported instance will be inserted. If not explicitly set, the instance will be inserted at the document origin. (Inherited from BaseImportOptions.)
Public property | ThisViewOnly | Imports drawings into the view that was passed into the import method. This option is not available in 3D views. (Inherited from BaseImportOptions.)
Public property | Unit | The unit of measure for imported geometry. (Inherited from BaseImportOptions.)
Public property | VisibleLayersOnly | Only import the visible layers. (Inherited from BaseImportOptions.)

See Also

SKPImportOptions Class


SKPImportOptions Constructor (SKPImportOptions)

[image]

Revit 2024 API
SKPImportOptions Constructor (SKPImportOptions)
SKPImportOptions Class See Also Send Feedback
Constructs a new instance of SKPImportOptions as a copy of the import options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public SKPImportOptions(
    SKPImportOptions option
)
Visual Basic
Public Sub New ( _
    option As SKPImportOptions _
)
Visual C++
public:
SKPImportOptions(
    SKPImportOptions^ option
)

Parameters

option
Type: Autodesk.Revit.DB..::..SKPImportOptions
The SKP options to be copied.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

SKPImportOptions Class
SKPImportOptions Overload


SKPImportOptions Methods

[image] [image]

Revit 2024 API
SKPImportOptions Methods
SKPImportOptions Class See Also Send Feedback

The SKPImportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from BaseImportOptions.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDefaultLengthUnit | Get the default length unit used for importing unitless files. (Inherited from BaseImportOptions.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLayerSelection | Get all set layers name which user want to import into Revit. (Inherited from BaseImportOptions.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultLengthUnit | Set the default length unit used for importing unitless files. (Inherited from BaseImportOptions.)
Public method | SetLayerSelection | Set the layers name which user want to import into Revit. (Inherited from BaseImportOptions.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SKPImportOptions Class


SkyBackgroundSettings Members

[image] [image]

Revit 2024 API
SkyBackgroundSettings Members
SkyBackgroundSettings Class Methods Properties See Also Send Feedback

The SkyBackgroundSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from BackgroundSettings.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BackgroundSettings.)

See Also

SkyBackgroundSettings Class


SkyBackgroundSettings Methods

[image] [image]

Revit 2024 API
SkyBackgroundSettings Methods
SkyBackgroundSettings Class See Also Send Feedback

The SkyBackgroundSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from BackgroundSettings.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SkyBackgroundSettings Class


SkyBackgroundSettings Properties

[image] [image]

Revit 2024 API
SkyBackgroundSettings Properties
SkyBackgroundSettings Class See Also Send Feedback

The SkyBackgroundSettings type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BackgroundSettings.)

See Also

SkyBackgroundSettings Class


SlabEdge Class

[image]

Revit 2024 API
SlabEdge Class
Members See Also Send Feedback
An object that represents a slab edge within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class SlabEdge : HostedSweep
Visual Basic
Public Class SlabEdge _
    Inherits HostedSweep
Visual C++
public ref class SlabEdge : public HostedSweep

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB..::..HostedSweep
Autodesk.Revit.DB..::..SlabEdge

See Also

SlabEdge Members


SlabEdge Methods

[image] [image]

Revit 2024 API
SlabEdge Methods
SlabEdge Class See Also Send Feedback

The SlabEdge type exposes the following members.

Methods

 | Name | Description
Public method | AddSegment | Add segments to the slab edge. (Overrides HostedSweep..::..AddSegment(Reference).)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEndPointParameter | Retrieve segment's start point or end point parameter. (Inherited from HostedSweep.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HorizontalFlip | Flip the hosted sweep object along horizontal line. (Inherited from HostedSweep.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | RemoveSegment | Remove segments from the hosted sweep object. (Inherited from HostedSweep.)
Public method | SetEndPointParameter | Set segment's start point or end point parameter. (Inherited from HostedSweep.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | VerticalFlip | Flip the hosted sweep object along vertical line. (Inherited from HostedSweep.)

See Also

SlabEdge Class


AddSegment Method

[image]

Revit 2024 API
SlabEdge..::..AddSegment Method
SlabEdge Class See Also Send Feedback
Add segments to the slab edge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public override void AddSegment(
    Reference targetRef
)
Visual Basic
Public Overrides Sub AddSegment ( _
    targetRef As Reference _
)
Visual C++
public:
virtual void AddSegment(
    Reference^ targetRef
) override

Parameters

targetRef
Type: Autodesk.Revit.DB..::..Reference
Segment's reference on which want to be added.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | This exception will be thrown in following cases: 1. Input targetRef is nullNothingnullptra null reference (Nothing in Visual Basic). 2. Input targetRef is not nullNothingnullptra null reference (Nothing in Visual Basic) but contains nothing.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This exception will be thrown in following cases: 1. Input targetRef has already been added into the slab edge. 2. Internal code fails to create the segment object. 3. Regeneration fails.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | This exception will be thrown if the reference is suitable for creating a slab edge as required. The reference allowed is : 1. Model Line 2. Floor's horizontal edges 3. Other slab edge's horizontal edges

See Also

SlabEdge Class


SlabEdge Properties

[image] [image]

Revit 2024 API
SlabEdge Properties
SlabEdge Class See Also Send Feedback

The SlabEdge type exposes the following members.

Properties

 | Name | Description
Public property | Angle | Retrieve/set the angle of the hosted sweep object relative its references (Unit : Radian). (Inherited from HostedSweep.)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | HorizontalFlipped | Retrieve the horizontal flip status of the hosted sweep object. (Inherited from HostedSweep.)
Public property | HorizontalOffset | Retrieve/set the horizontal offset of the hosted sweep object. (Inherited from HostedSweep.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | Length | Retrieve the length of the hosted sweep object. (Inherited from HostedSweep.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ReferenceCurve | The curve on which the hosted sweep segment is created. (Inherited from HostedSweep.)
Public property | SlabEdgeType | Retrieves/set an object that represents the type of the SlabEdge.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | VerticalFlipped | Retrieve the vertical flip status of the hosted sweep object. (Inherited from HostedSweep.)
Public property | VerticalOffset | Retrieve/set the vertical offset of the hosted sweep object. (Inherited from HostedSweep.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SlabEdge Class


Parameter Property

[image] [image]

Revit 2024 API
SlabEdge..::..Parameter Property
SlabEdge Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

SlabEdge Class
SlabEdge Members


SlabEdgeType Class

[image]

Revit 2024 API
SlabEdgeType Class
Members See Also Send Feedback
An object that represents the slab edge type in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class SlabEdgeType : HostedSweepType
Visual Basic
Public Class SlabEdgeType _
    Inherits HostedSweepType
Visual C++
public ref class SlabEdgeType : public HostedSweepType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..HostObjAttributes
Autodesk.Revit.DB..::..HostedSweepType
Autodesk.Revit.DB..::..SlabEdgeType

See Also

SlabEdgeType Members


SlabEdgeType Members

[image] [image]

Revit 2024 API
SlabEdgeType Members
SlabEdgeType Class Methods Properties See Also Send Feedback

The SlabEdgeType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SlabEdgeType Class


SlabEdgeType Methods

[image] [image]

Revit 2024 API
SlabEdgeType Methods
SlabEdgeType Class See Also Send Feedback

The SlabEdgeType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SlabEdgeType Class


SlabEdgeType Properties

[image] [image]

Revit 2024 API
SlabEdgeType Properties
SlabEdgeType Class See Also Send Feedback

The SlabEdgeType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SlabEdgeType Class


SlabShapeCrease Class

[image]

Revit 2024 API
SlabShapeCrease Class
Members See Also Send Feedback
A crease used in Slab Shape Editing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class SlabShapeCrease
Visual Basic
Public Class SlabShapeCrease
Visual C++
public ref class SlabShapeCrease

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..SlabShapeCrease

See Also

SlabShapeCrease Members


SlabShapeCrease Members

[image] [image]

Revit 2024 API
SlabShapeCrease Members
SlabShapeCrease Class Methods Properties See Also Send Feedback

The SlabShapeCrease type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CreaseType | The type of the crease.
Public property | Curve | The geometry of the crease.
Public property | EndPoints | The vertices of the crease.

See Also

SlabShapeCrease Class


SlabShapeCrease Methods

[image] [image]

Revit 2024 API
SlabShapeCrease Methods
SlabShapeCrease Class See Also Send Feedback

The SlabShapeCrease type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SlabShapeCrease Class


SlabShapeCrease Properties

[image] [image]

Revit 2024 API
SlabShapeCrease Properties
SlabShapeCrease Class See Also Send Feedback

The SlabShapeCrease type exposes the following members.

Properties

 | Name | Description
Public property | CreaseType | The type of the crease.
Public property | Curve | The geometry of the crease.
Public property | EndPoints | The vertices of the crease.

See Also

SlabShapeCrease Class


CreaseType Property

[image]

Revit 2024 API
SlabShapeCrease..::..CreaseType Property
SlabShapeCrease Class See Also Send Feedback
The type of the crease.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public SlabShapeCreaseType CreaseType { get; }
Visual Basic
Public ReadOnly Property CreaseType As SlabShapeCreaseType
    Get
Visual C++
public:
property SlabShapeCreaseType CreaseType {
    SlabShapeCreaseType get ();
}

See Also

SlabShapeCrease Class


Curve Property

[image]

Revit 2024 API
SlabShapeCrease..::..Curve Property
SlabShapeCrease Class See Also Send Feedback
The geometry of the crease.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Curve Curve { get; }
Visual Basic
Public ReadOnly Property Curve As Curve
    Get
Visual C++
public:
property Curve^ Curve {
    Curve^ get ();
}

See Also

SlabShapeCrease Class


SlabShapeCreaseArray Members

[image] [image]

Revit 2024 API
SlabShapeCreaseArray Members
SlabShapeCreaseArray Class Constructors Methods Properties See Also Send Feedback

The SlabShapeCreaseArray type exposes the following members.

Constructors

 | Name | Description
Public method | SlabShapeCreaseArray | Initializes a new instance of the SlabShapeCreaseArray class

Methods

 | Name | Description
Public method | Append | Add the item to the end of the array.
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

SlabShapeCreaseArray Class


SlabShapeCreaseArray Constructor

[image]

Revit 2024 API
SlabShapeCreaseArray Constructor
SlabShapeCreaseArray Class See Also Send Feedback
Initializes a new instance of the SlabShapeCreaseArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public SlabShapeCreaseArray()
Visual Basic
Public Sub New
Visual C++
public:
SlabShapeCreaseArray()

See Also

SlabShapeCreaseArray Class


SlabShapeCreaseArray Methods

[image] [image]

Revit 2024 API
SlabShapeCreaseArray Methods
SlabShapeCreaseArray Class See Also Send Feedback

The SlabShapeCreaseArray type exposes the following members.

Methods

 | Name | Description
Public method | Append | Add the item to the end of the array.
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SlabShapeCreaseArray Class


Append Method

[image]

Revit 2024 API
SlabShapeCreaseArray..::..Append Method
SlabShapeCreaseArray Class See Also Send Feedback
Add the item to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Append(
    SlabShapeCrease item
)
Visual Basic
Public Overridable Sub Append ( _
    item As SlabShapeCrease _
)
Visual C++
public:
virtual void Append(
    SlabShapeCrease^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..SlabShapeCrease
The item to be added.

See Also

SlabShapeCreaseArray Class


Clear Method

[image]

Revit 2024 API
SlabShapeCreaseArray..::..Clear Method
SlabShapeCreaseArray Class See Also Send Feedback
Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

SlabShapeCreaseArray Class


ForwardIterator Method

[image]

Revit 2024 API
SlabShapeCreaseArray..::..ForwardIterator Method
SlabShapeCreaseArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual SlabShapeCreaseArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As SlabShapeCreaseArrayIterator
Visual C++
public:
virtual SlabShapeCreaseArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

SlabShapeCreaseArray Class


GetEnumerator Method

[image]

Revit 2024 API
SlabShapeCreaseArray..::..GetEnumerator Method
SlabShapeCreaseArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

SlabShapeCreaseArray Class


Insert Method

[image]

Revit 2024 API
SlabShapeCreaseArray..::..Insert Method
SlabShapeCreaseArray Class See Also Send Feedback
Insert the specified item into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Insert(
    SlabShapeCrease item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As SlabShapeCrease, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    SlabShapeCrease^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::..SlabShapeCrease
The item to be inserted into the array.
index
Type: System..::..Int32
The item will be inserted before this index.

Return Value

Returns whether the item was inserted into the array.

See Also

SlabShapeCreaseArray Class


ReverseIterator Method

[image]

Revit 2024 API
SlabShapeCreaseArray..::..ReverseIterator Method
SlabShapeCreaseArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual SlabShapeCreaseArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As SlabShapeCreaseArrayIterator
Visual C++
public:
virtual SlabShapeCreaseArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

SlabShapeCreaseArray Class


SlabShapeCreaseArray Properties

[image] [image]

Revit 2024 API
SlabShapeCreaseArray Properties
SlabShapeCreaseArray Class See Also Send Feedback

The SlabShapeCreaseArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

SlabShapeCreaseArray Class


Size Property

[image]

Revit 2024 API
SlabShapeCreaseArray..::..Size Property
SlabShapeCreaseArray Class See Also Send Feedback
Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

SlabShapeCreaseArray Class


SlabShapeCreaseArrayIterator Class

[image]

Revit 2024 API
SlabShapeCreaseArrayIterator Class
Members See Also Send Feedback
An iterator to an array of creases used for Slab Shape Editing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public abstract class SlabShapeCreaseArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class SlabShapeCreaseArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class SlabShapeCreaseArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..SlabShapeCreaseArrayIterator

See Also

SlabShapeCreaseArrayIterator Members


SlabShapeCreaseArrayIterator Members

[image] [image]

Revit 2024 API
SlabShapeCreaseArrayIterator Members
SlabShapeCreaseArrayIterator Class Constructors Methods Properties See Also Send Feedback

The SlabShapeCreaseArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | SlabShapeCreaseArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SlabShapeCreaseArrayIterator Class


SlabShapeCreaseArrayIterator Constructor

[image]

Revit 2024 API
SlabShapeCreaseArrayIterator Constructor
SlabShapeCreaseArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public SlabShapeCreaseArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
SlabShapeCreaseArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SlabShapeCreaseArrayIterator Class


MoveNext Method

[image]

Revit 2024 API
SlabShapeCreaseArrayIterator..::..MoveNext Method
SlabShapeCreaseArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

SlabShapeCreaseArrayIterator Class


Reset Method

[image]

Revit 2024 API
SlabShapeCreaseArrayIterator..::..Reset Method
SlabShapeCreaseArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

SlabShapeCreaseArrayIterator Class


SlabShapeCreaseArrayIterator Properties

[image] [image]

Revit 2024 API
SlabShapeCreaseArrayIterator Properties
SlabShapeCreaseArrayIterator Class See Also Send Feedback

The SlabShapeCreaseArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SlabShapeCreaseArrayIterator Class


Current Property

[image]

Revit 2024 API
SlabShapeCreaseArrayIterator..::..Current Property
SlabShapeCreaseArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

SlabShapeCreaseArrayIterator Class


SlabShapeCreaseType Enumeration

[image]

Revit 2024 API
SlabShapeCreaseType Enumeration
See Also Send Feedback
An enumerated type listing all Crease types of Slab Shape Edit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum SlabShapeCreaseType
Visual Basic
Public Enumeration SlabShapeCreaseType
Visual C++
public enum class SlabShapeCreaseType

Members

Member name | Description
Invalid | The type of Crease is Invalid.
Boundary | The type of Crease is Boundary.
UserDrawn | The type of Crease is UserDrawn.
Auto | The type of Crease is Auto.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


SlabShapeEditor Class

[image]

Revit 2024 API
SlabShapeEditor Class
Members See Also Send Feedback
An object used for Slab Shape Editing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class SlabShapeEditor : IDisposable
Visual Basic
Public Class SlabShapeEditor _
    Implements IDisposable
Visual C++
public ref class SlabShapeEditor : IDisposable

Remarks

The SlabShapeEditor can be obtained from a slab object, such as a roof or floor.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..SlabShapeEditor

See Also

SlabShapeEditor Members


SlabShapeEditor Members

[image] [image]

Revit 2024 API
SlabShapeEditor Members
SlabShapeEditor Class Methods Properties See Also Send Feedback

The SlabShapeEditor type exposes the following members.

Methods

 | Name | Description
Public method | CreateCreasesFromFoldingLines | Convert selected folding lines to split lines
Public method | Dispose | Releases all resources used by the SlabShapeEditor
Public method | DrawPoint | Adds a point to the corresponding slab, roof or floor.
Public method | DrawSplitLine | Draws a split line on the corresponding slab, roof or floor.
Public method | Enable | Enables the slab shape editing functionality.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ModifySubElement(SlabShapeCrease, Double) | Manipulates the crease on the corresponding slab, roof or floor.
Public method | ModifySubElement(SlabShapeVertex, Double) | Manipulates the vertex on the corresponding slab, roof or floor.
Public method | PickSupport | Picks an element to support the slab. This method will define split lines and create constant bearing lines for the slab.
Public method | ResetSlabShape | Removes the modifications made during editing and resets the element geometry back to the unmodified state.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEnabled | Identifies if the slab shape editing functionality is enabled.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SlabShapeCreases | All of the creases that can be edited.
Public property | SlabShapeVertices | All of the vertices that can be edited.

See Also

SlabShapeEditor Class


SlabShapeEditor Methods

[image] [image]

Revit 2024 API
SlabShapeEditor Methods
SlabShapeEditor Class See Also Send Feedback

The SlabShapeEditor type exposes the following members.

Methods

 | Name | Description
Public method | CreateCreasesFromFoldingLines | Convert selected folding lines to split lines
Public method | Dispose |
Public method | DrawPoint | Adds a point to the corresponding slab, roof or floor.
Public method | DrawSplitLine | Draws a split line on the corresponding slab, roof or floor.
Public method | Enable | Enables the slab shape editing functionality.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ModifySubElement(SlabShapeCrease, Double) | Manipulates the crease on the corresponding slab, roof or floor.
Public method | ModifySubElement(SlabShapeVertex, Double) | Manipulates the vertex on the corresponding slab, roof or floor.
Public method | PickSupport | Picks an element to support the slab. This method will define split lines and create constant bearing lines for the slab.
Public method | ResetSlabShape | Removes the modifications made during editing and resets the element geometry back to the unmodified state.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SlabShapeEditor Class


CreateCreasesFromFoldingLines Method

[image]

Revit 2024 API
SlabShapeEditor..::..CreateCreasesFromFoldingLines Method
SlabShapeEditor Class See Also Send Feedback
Convert selected folding lines to split lines

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public void CreateCreasesFromFoldingLines(
    Element hostObj,
    IList<Reference> references
)
Visual Basic
Public Sub CreateCreasesFromFoldingLines ( _
    hostObj As Element, _
    references As IList(Of Reference) _
)
Visual C++
public:
void CreateCreasesFromFoldingLines(
    Element^ hostObj,
    IList<Reference^>^ references
)

Parameters

hostObj
Type: Autodesk.Revit.DB..::..Element
object that hosts the SlabShapeEditor
references
Type: System.Collections.Generic..::..IList<(Of <(<' Reference >)>)>
References of selected folding lines.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | this operation failed.

See Also

SlabShapeEditor Class


Dispose Method

[image]

Revit 2024 API
SlabShapeEditor..::..Dispose Method
SlabShapeEditor Class See Also Send Feedback
Releases all resources used by the SlabShapeEditor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

SlabShapeEditor Class


DrawPoint Method

[image]

Revit 2024 API
SlabShapeEditor..::..DrawPoint Method
SlabShapeEditor Class See Also Send Feedback
Adds a point to the corresponding slab, roof or floor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public SlabShapeVertex DrawPoint(
    XYZ location
)
Visual Basic
Public Function DrawPoint ( _
    location As XYZ _
) As SlabShapeVertex
Visual C++
public:
SlabShapeVertex^ DrawPoint(
    XYZ^ location
)

Parameters

location
Type: Autodesk.Revit.DB..::..XYZ
The location of the point.

Return Value

The newly created vertex.

Remarks

If the input location is not on the top face of the slab, this function will return nullNothingnullptra null reference (Nothing in Visual Basic). Drawing a point on boundary crease may increase the number of creases. This method will regenerate the document even in manual regeneration mode.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the location is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

SlabShapeEditor Class


Enable Method

[image]

Revit 2024 API
SlabShapeEditor..::..Enable Method
SlabShapeEditor Class See Also Send Feedback
Enables the slab shape editing functionality.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Enable()
Visual Basic
Public Sub Enable
Visual C++
public:
void Enable()

See Also

SlabShapeEditor Class


ModifySubElement Method

[image] [image]

Revit 2024 API
SlabShapeEditor..::..ModifySubElement Method
SlabShapeEditor Class See Also Send Feedback
Manipulates an entity on the corresponding slab, roof or floor.

Overload List

 | Name | Description
Public method | ModifySubElement(SlabShapeCrease, Double) | Manipulates the crease on the corresponding slab, roof or floor.
Public method | ModifySubElement(SlabShapeVertex, Double) | Manipulates the vertex on the corresponding slab, roof or floor.

See Also

SlabShapeEditor Class
SlabShapeEditor Members


ModifySubElement Method (SlabShapeCrease, Double)

[image]

Revit 2024 API
SlabShapeEditor..::..ModifySubElement Method (SlabShapeCrease, Double)
SlabShapeEditor Class See Also Send Feedback
Manipulates the crease on the corresponding slab, roof or floor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void ModifySubElement(
    SlabShapeCrease crease,
    double offset
)
Visual Basic
Public Sub ModifySubElement ( _
    crease As SlabShapeCrease, _
    offset As Double _
)
Visual C++
public:
void ModifySubElement(
    SlabShapeCrease^ crease,
    double offset
)

Parameters

crease
Type: Autodesk.Revit.DB..::..SlabShapeCrease
The crease.
offset
Type: System..::..Double
The new value of the crease offset, which is the average of offsets of its ends.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the crease is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the crease is invalid.

See Also

SlabShapeEditor Class
ModifySubElement Overload


ModifySubElement Method (SlabShapeVertex, Double)

[image]

Revit 2024 API
SlabShapeEditor..::..ModifySubElement Method (SlabShapeVertex, Double)
SlabShapeEditor Class See Also Send Feedback
Manipulates the vertex on the corresponding slab, roof or floor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void ModifySubElement(
    SlabShapeVertex vertex,
    double offset
)
Visual Basic
Public Sub ModifySubElement ( _
    vertex As SlabShapeVertex, _
    offset As Double _
)
Visual C++
public:
void ModifySubElement(
    SlabShapeVertex^ vertex,
    double offset
)

Parameters

vertex
Type: Autodesk.Revit.DB..::..SlabShapeVertex
The vertex.
offset
Type: System..::..Double
The new value of the vertex offset.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the vertex is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the vertex is invalid.

See Also

SlabShapeEditor Class
ModifySubElement Overload


ResetSlabShape Method

[image]

Revit 2024 API
SlabShapeEditor..::..ResetSlabShape Method
SlabShapeEditor Class Example See Also Send Feedback
Removes the modifications made during editing and resets the element geometry back to the unmodified state.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void ResetSlabShape()
Visual Basic
Public Sub ResetSlabShape
Visual C++
public:
void ResetSlabShape()

Remarks

Calling this method will reset the slab back to its original state and disable Slab Shape Editing. If further editing is needed, call Enable again.

Examples

CopyC#
private void ResetSlabShapes(Autodesk.Revit.DB.Document document)
{
    UIDocument uidoc = new UIDocument(document);
    ICollection<ElementId> selectedIds = uidoc.Selection.GetElementIds();
    foreach (ElementId id in selectedIds)
    {
        Floor floor = document.GetElement(id) as Floor;
        if (floor != null)
        {
            SlabShapeEditor slabShapeEditor = floor.GetSlabShapeEditor();
            slabShapeEditor.ResetSlabShape();
        }
    }

}
CopyVB.NET
Private Sub ResetSlabShapes(document As Autodesk.Revit.DB.Document)
    Dim uidoc As New UIDocument(document)
    Dim selectedIds As ICollection(Of ElementId) = uidoc.Selection.GetElementIds()
    For Each id As ElementId In selectedIds
        Dim floor As Floor = TryCast(document.GetElement(id), Floor)
        If floor IsNot Nothing Then
            Dim slabShapeEditor As SlabShapeEditor = floor.GetSlabShapeEditor()
            slabShapeEditor.ResetSlabShape()
        End If
    Next

End Sub

See Also

SlabShapeEditor Class


IsEnabled Property

[image]

Revit 2024 API
SlabShapeEditor..::..IsEnabled Property
SlabShapeEditor Class See Also Send Feedback
Identifies if the slab shape editing functionality is enabled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsEnabled { get; }
Visual Basic
Public ReadOnly Property IsEnabled As Boolean
    Get
Visual C++
public:
property bool IsEnabled {
    bool get ();
}

Remarks

If true, the creases and vertices are accessible and modifiable. If false, no creases and vertices are accessible.

See Also

SlabShapeEditor Class


SlabShapeVertices Property

[image]

Revit 2024 API
SlabShapeEditor..::..SlabShapeVertices Property
SlabShapeEditor Class See Also Send Feedback
All of the vertices that can be edited.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public SlabShapeVertexArray SlabShapeVertices { get; }
Visual Basic
Public ReadOnly Property SlabShapeVertices As SlabShapeVertexArray
    Get
Visual C++
public:
property SlabShapeVertexArray^ SlabShapeVertices {
    SlabShapeVertexArray^ get ();
}

See Also

SlabShapeEditor Class


SlabShapeVertex Class

[image]

Revit 2024 API
SlabShapeVertex Class
Members See Also Send Feedback
A vertex used in Slab Shape Editing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class SlabShapeVertex
Visual Basic
Public Class SlabShapeVertex
Visual C++
public ref class SlabShapeVertex

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..SlabShapeVertex

See Also

SlabShapeVertex Members


SlabShapeVertex Methods

[image] [image]

Revit 2024 API
SlabShapeVertex Methods
SlabShapeVertex Class See Also Send Feedback

The SlabShapeVertex type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SlabShapeVertex Class


SlabShapeVertex Properties

[image] [image]

Revit 2024 API
SlabShapeVertex Properties
SlabShapeVertex Class See Also Send Feedback

The SlabShapeVertex type exposes the following members.

Properties

 | Name | Description
Public property | Position | The position of the vertex.
Public property | VertexType | The type of the vertex.

See Also

SlabShapeVertex Class


Position Property

[image]

Revit 2024 API
SlabShapeVertex..::..Position Property
SlabShapeVertex Class See Also Send Feedback
The position of the vertex.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ Position { get; }
Visual Basic
Public ReadOnly Property Position As XYZ
    Get
Visual C++
public:
property XYZ^ Position {
    XYZ^ get ();
}

See Also

SlabShapeVertex Class


VertexType Property

[image]

Revit 2024 API
SlabShapeVertex..::..VertexType Property
SlabShapeVertex Class See Also Send Feedback
The type of the vertex.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public SlabShapeVertexType VertexType { get; }
Visual Basic
Public ReadOnly Property VertexType As SlabShapeVertexType
    Get
Visual C++
public:
property SlabShapeVertexType VertexType {
    SlabShapeVertexType get ();
}

See Also

SlabShapeVertex Class


SlabShapeVertexArray Members

[image] [image]

Revit 2024 API
SlabShapeVertexArray Members
SlabShapeVertexArray Class Constructors Methods Properties See Also Send Feedback

The SlabShapeVertexArray type exposes the following members.

Constructors

 | Name | Description
Public method | SlabShapeVertexArray | Initializes a new instance of the SlabShapeVertexArray class

Methods

 | Name | Description
Public method | Append | Add the item to the end of the array.
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

SlabShapeVertexArray Class


SlabShapeVertexArray Constructor

[image]

Revit 2024 API
SlabShapeVertexArray Constructor
SlabShapeVertexArray Class See Also Send Feedback
Initializes a new instance of the SlabShapeVertexArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public SlabShapeVertexArray()
Visual Basic
Public Sub New
Visual C++
public:
SlabShapeVertexArray()

See Also

SlabShapeVertexArray Class


SlabShapeVertexArray Methods

[image] [image]

Revit 2024 API
SlabShapeVertexArray Methods
SlabShapeVertexArray Class See Also Send Feedback

The SlabShapeVertexArray type exposes the following members.

Methods

 | Name | Description
Public method | Append | Add the item to the end of the array.
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SlabShapeVertexArray Class


Append Method

[image]

Revit 2024 API
SlabShapeVertexArray..::..Append Method
SlabShapeVertexArray Class See Also Send Feedback
Add the item to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Append(
    SlabShapeVertex item
)
Visual Basic
Public Overridable Sub Append ( _
    item As SlabShapeVertex _
)
Visual C++
public:
virtual void Append(
    SlabShapeVertex^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..SlabShapeVertex
The item to be added.

See Also

SlabShapeVertexArray Class


ForwardIterator Method

[image]

Revit 2024 API
SlabShapeVertexArray..::..ForwardIterator Method
SlabShapeVertexArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual SlabShapeVertexArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As SlabShapeVertexArrayIterator
Visual C++
public:
virtual SlabShapeVertexArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

SlabShapeVertexArray Class


GetEnumerator Method

[image]

Revit 2024 API
SlabShapeVertexArray..::..GetEnumerator Method
SlabShapeVertexArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

SlabShapeVertexArray Class


Insert Method

[image]

Revit 2024 API
SlabShapeVertexArray..::..Insert Method
SlabShapeVertexArray Class See Also Send Feedback
Insert the specified item into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Insert(
    SlabShapeVertex item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As SlabShapeVertex, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    SlabShapeVertex^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::..SlabShapeVertex
The item to be inserted into the array.
index
Type: System..::..Int32
The item will be inserted before this index.

Return Value

Returns whether the item was inserted into the array.

See Also

SlabShapeVertexArray Class


ReverseIterator Method

[image]

Revit 2024 API
SlabShapeVertexArray..::..ReverseIterator Method
SlabShapeVertexArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual SlabShapeVertexArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As SlabShapeVertexArrayIterator
Visual C++
public:
virtual SlabShapeVertexArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

SlabShapeVertexArray Class


SlabShapeVertexArray Properties

[image] [image]

Revit 2024 API
SlabShapeVertexArray Properties
SlabShapeVertexArray Class See Also Send Feedback

The SlabShapeVertexArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

SlabShapeVertexArray Class


IsEmpty Property

[image]

Revit 2024 API
SlabShapeVertexArray..::..IsEmpty Property
SlabShapeVertexArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

SlabShapeVertexArray Class


Item Property

[image]

Revit 2024 API
SlabShapeVertexArray..::..Item Property
SlabShapeVertexArray Class See Also Send Feedback
Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual SlabShapeVertex this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As SlabShapeVertex
    Get
    Set
Visual C++
public:
virtual property SlabShapeVertex^ Item[int index] {
    SlabShapeVertex^ get (int index);
    void set (int index, SlabShapeVertex^ value);
}

Parameters

index
Type: System..::..Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

SlabShapeVertexArray Class


Size Property

[image]

Revit 2024 API
SlabShapeVertexArray..::..Size Property
SlabShapeVertexArray Class See Also Send Feedback
Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

SlabShapeVertexArray Class


SlabShapeVertexArrayIterator Class

[image]

Revit 2024 API
SlabShapeVertexArrayIterator Class
Members See Also Send Feedback
An iterator to an array of vertices used for Slab Shape Editing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public abstract class SlabShapeVertexArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class SlabShapeVertexArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class SlabShapeVertexArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..SlabShapeVertexArrayIterator

See Also

SlabShapeVertexArrayIterator Members


SlabShapeVertexArrayIterator Members

[image] [image]

Revit 2024 API
SlabShapeVertexArrayIterator Members
SlabShapeVertexArrayIterator Class Constructors Methods Properties See Also Send Feedback

The SlabShapeVertexArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | SlabShapeVertexArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SlabShapeVertexArrayIterator Class


MoveNext Method

[image]

Revit 2024 API
SlabShapeVertexArrayIterator..::..MoveNext Method
SlabShapeVertexArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

SlabShapeVertexArrayIterator Class


Reset Method

[image]

Revit 2024 API
SlabShapeVertexArrayIterator..::..Reset Method
SlabShapeVertexArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

SlabShapeVertexArrayIterator Class


Current Property

[image]

Revit 2024 API
SlabShapeVertexArrayIterator..::..Current Property
SlabShapeVertexArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

SlabShapeVertexArrayIterator Class


SlabShapeVertexType Enumeration

[image]

Revit 2024 API
SlabShapeVertexType Enumeration
See Also Send Feedback
An enumerated type listing all Vertex types of Slab Shape Edit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum SlabShapeVertexType
Visual Basic
Public Enumeration SlabShapeVertexType
Visual C++
public enum class SlabShapeVertexType

Members

Member name | Description
Invalid | The type of Vertex is Invalid.
Corner | The type of Vertex is Corner.
Edge | The type of Vertex is Edge.
Interior | The type of Vertex is Interior.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


SlantedOrVerticalColumnType Enumeration

[image]

Revit 2024 API
SlantedOrVerticalColumnType Enumeration
See Also Send Feedback
This enum class is used for the BuiltInParameter SLANTED_COLUMN_TYPE_PARAM.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum SlantedOrVerticalColumnType
Visual Basic
Public Enumeration SlantedOrVerticalColumnType
Visual C++
public enum class SlantedOrVerticalColumnType

Members

Member name | Description
CT_Vertical |
CT_Angle |
CT_EndPoint |

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


Solid Class

[image]

Revit 2024 API
Solid Class
Members Example See Also Send Feedback
A 3d solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class Solid : GeometryObject
Visual Basic
Public Class Solid _
    Inherits GeometryObject
Visual C++
public ref class Solid : public GeometryObject

Remarks

A solid is defined by the faces and edges that form its boundary.

Examples

CopyC#
private void GetAndTransformSolidInfo(Application application, Element element, Options geoOptions)
{
    // Get geometry element of the selected element
    Autodesk.Revit.DB.GeometryElement geoElement = element.get_Geometry(geoOptions);

    // Get geometry object
    foreach (GeometryObject geoObject in geoElement)
    {
        // Get the geometry instance which contains the geometry information
        Autodesk.Revit.DB.GeometryInstance instance = geoObject as Autodesk.Revit.DB.GeometryInstance;
        if (null != instance)
        {
            foreach (GeometryObject instObj in instance.SymbolGeometry)
            {
                Solid solid = instObj as Solid;
                if (null == solid || 0 == solid.Faces.Size || 0 == solid.Edges.Size)
                {
                    continue;
                }

                Transform instTransform = instance.Transform;
                // Get the faces and edges from solid, and transform the formed points
                foreach (Face face in solid.Faces)
                {
                    Mesh mesh = face.Triangulate();
                    foreach (XYZ ii in mesh.Vertices)
                    {
                       XYZ point = ii;
                        XYZ transformedPoint = instTransform.OfPoint(point);
                    }
                }
                foreach (Edge edge in solid.Edges)
                {
                   foreach (XYZ ii in edge.Tessellate())
                    {
                       XYZ point = ii;
                        XYZ transformedPoint = instTransform.OfPoint(point);
                    }
                }
            }
        }
    }

}
CopyVB.NET
Private Sub GetAndTransformSolidInfo(application As Application, element As Element, geoOptions As Options)
    ' Get geometry element of the selected element
    Dim geoElement As Autodesk.Revit.DB.GeometryElement = element.Geometry(geoOptions)

    ' Get geometry object
    For Each geoObject As GeometryObject In geoElement
        ' Get the geometry instance which contains the geometry information
        Dim instance As Autodesk.Revit.DB.GeometryInstance = TryCast(geoObject, Autodesk.Revit.DB.GeometryInstance)
        If instance IsNot Nothing Then
            For Each instObj As GeometryObject In instance.SymbolGeometry
                Dim solid As Solid = TryCast(instObj, Solid)
                If solid Is Nothing OrElse 0 = solid.Faces.Size OrElse 0 = solid.Edges.Size Then
                    Continue For
                End If

                Dim instTransform As Transform = instance.Transform
                ' Get the faces and edges from solid, and transform the formed points
                For Each face As Face In solid.Faces
                    Dim mesh As Mesh = face.Triangulate()
                    For Each ii As XYZ In mesh.Vertices
                        Dim point As XYZ = ii
                        Dim transformedPoint As XYZ = instTransform.OfPoint(point)
                    Next
                Next
                For Each edge As Edge In solid.Edges
                    For Each ii As XYZ In edge.Tessellate()
                        Dim point As XYZ = ii
                        Dim transformedPoint As XYZ = instTransform.OfPoint(point)
                    Next
                Next
            Next
        End If
    Next

End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeometryObject
Autodesk.Revit.DB..::..Solid

See Also

Solid Members


Solid Methods

[image] [image]

Revit 2024 API
Solid Methods
Solid Class See Also Send Feedback

The Solid type exposes the following members.

Methods

 | Name | Description
Public method | ComputeCentroid | Returns the Centroid of this solid.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | GetBoundingBox | Retrieves a box that circumscribes the solid geometry.
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectWithCurve | Calculates and returns the intersection between a curve and this solid.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Solid Class


ComputeCentroid Method

[image]

Revit 2024 API
Solid..::..ComputeCentroid Method
Solid Class See Also Send Feedback
Returns the Centroid of this solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ ComputeCentroid()
Visual Basic
Public Function ComputeCentroid As XYZ
Visual C++
public:
XYZ^ ComputeCentroid()

Return Value

The XYZ point of the Centroid of this solid.

Remarks

Calculates the centroid of the solid using an approximation, with an accuracy suitable for architectural purposes. This will correspond only with the center of gravity if the solid represents a homogeneous structure of a single material.

See Also

Solid Class


GetBoundingBox Method

[image]

Revit 2024 API
Solid..::..GetBoundingBox Method
Solid Class See Also Send Feedback
Retrieves a box that circumscribes the solid geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public BoundingBoxXYZ GetBoundingBox()
Visual Basic
Public Function GetBoundingBox As BoundingBoxXYZ
Visual C++
public:
BoundingBoxXYZ^ GetBoundingBox()

Remarks

The bounding box information is stored as bounds in local coordinates and a transform. So the transform is to be taken in to account when using the bounds. This is different from the bounding box returned by Element.BoundingBox in that the bounding box returned by that routine stores the bounds in modeling coordinates with an identity transform.

See Also

Solid Class


IntersectWithCurve Method

[image]

Revit 2024 API
Solid..::..IntersectWithCurve Method
Solid Class Example See Also Send Feedback
Calculates and returns the intersection between a curve and this solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public SolidCurveIntersection IntersectWithCurve(
    Curve curve,
    SolidCurveIntersectionOptions options
)
Visual Basic
Public Function IntersectWithCurve ( _
    curve As Curve, _
    options As SolidCurveIntersectionOptions _
) As SolidCurveIntersection
Visual C++
public:
SolidCurveIntersection^ IntersectWithCurve(
    Curve^ curve,
    SolidCurveIntersectionOptions^ options
)

Parameters

curve
Type: Autodesk.Revit.DB..::..Curve
The curve.
options
Type: Autodesk.Revit.DB..::..SolidCurveIntersectionOptions
The options. If NULL, the default options will be used.

Return Value

The intersection results.

Examples

CopyC#
private void FindColumnRebarIntersections(Document document, FamilyInstance column)
{
    // We will be computing the total length of the rebar inside the column
    double totalRebarLengthInColumn = 0;

    // Find rebar hosted by this column
    RebarHostData rebarHostData = RebarHostData.GetRebarHostData(column);
    if (rebarHostData == null)
    {
        return;
    }

    IList<Rebar> rebars = rebarHostData.GetRebarsInHost();
    if (rebars.Count == 0)
    {
        return;
    }

    // Retrieve geometry of the column
    Options geomOptions = new Options();
    geomOptions.ComputeReferences = true;
    geomOptions.DetailLevel = ViewDetailLevel.Fine;
    GeometryElement elemGeometry = column.get_Geometry(geomOptions);

    // Examine all geometry primitives of the column
    foreach (GeometryObject elemPrimitive in elemGeometry)
    {

        // Skip objects that are not geometry instances
        GeometryInstance gInstance = elemPrimitive as GeometryInstance;
        if (gInstance == null)
        {
            continue;
        }

        // Retrieve geometry of each found geometry instance
        GeometryElement instGeometry = gInstance.GetInstanceGeometry();
        foreach (GeometryObject instPrimitive in instGeometry)
        {

            // Skip non-solid sobject
            Solid solid = instPrimitive as Solid;
            if (solid == null)
            {
                continue;
            }

            SolidCurveIntersectionOptions intersectOptions = new SolidCurveIntersectionOptions();
            foreach (Rebar rebar in rebars)
            {
                // Get the centerlines for the rebar to find their intersection with the column
                bool selfIntersection = false;
                bool suppresHooks = false;
                bool suppresBends = false;
                IList<Curve> curves = rebar.GetCenterlineCurves(selfIntersection, suppresHooks, suppresBends, MultiplanarOption.IncludeOnlyPlanarCurves, 0);

                // Examine every segment of every curve of the centerline
                foreach (Curve curve in curves)
                {
                    SolidCurveIntersection intersection = solid.IntersectWithCurve(curve, intersectOptions);
                    for (int segment = 0; segment <= intersection.SegmentCount - 1; segment++)
                    {
                        // Calculate length of the rebar that is inside the column
                        Curve curveInside = intersection.GetCurveSegment(segment);
                        double rebarLengthInColumn = curveInside.Length;
                        totalRebarLengthInColumn = totalRebarLengthInColumn + rebarLengthInColumn;
                    }
                }

            }
        }
    }

}
CopyVB.NET
Private Sub FindColumnRebarIntersections(document As Document, column As FamilyInstance)
    ' We will be computing the total length of the rebar inside the column
    Dim totalRebarLengthInColumn As Double = 0

    ' Find rebar hosted by this column
    Dim rebarHostData__1 As RebarHostData = RebarHostData.GetRebarHostData(column)
    If rebarHostData__1 Is Nothing Then
        Return
    End If

    Dim rebars As IList(Of Rebar) = rebarHostData__1.GetRebarsInHost()
    If rebars.Count = 0 Then
        Return
    End If

    ' Retrieve geometry of the column
    Dim geomOptions As New Options()
    geomOptions.ComputeReferences = True
    geomOptions.DetailLevel = ViewDetailLevel.Fine
    Dim elemGeometry As GeometryElement = column.Geometry(geomOptions)

    ' Examine all geometry primitives of the column
    For Each elemPrimitive As GeometryObject In elemGeometry

        ' Skip objects that are not geometry instances
        Dim gInstance As GeometryInstance = TryCast(elemPrimitive, GeometryInstance)
        If gInstance Is Nothing Then
            Continue For
        End If

        ' Retrieve geometry of each found geometry instance
        Dim instGeometry As GeometryElement = gInstance.GetInstanceGeometry()
        For Each instPrimitive As GeometryObject In instGeometry

            ' Skip non-solid sobject
            Dim solid As Solid = TryCast(instPrimitive, Solid)
            If solid Is Nothing Then
                Continue For
            End If

            Dim intersectOptions As New SolidCurveIntersectionOptions()
            For Each rebar As Rebar In rebars
                ' Get the centerlines for the rebar to find their intersection with the column
                Dim selfIntersection As Boolean = False
                Dim suppresHooks As Boolean = False
                Dim suppresBends As Boolean = False
                Dim curves As IList(Of Curve) = rebar.GetCenterlineCurves(selfIntersection, suppresHooks, suppresBends, MultiplanarOption.IncludeOnlyPlanarCurves, 0)

                ' Examine every segment of every curve of the centerline
                For Each curve As Curve In curves
                    Dim intersection As SolidCurveIntersection = solid.IntersectWithCurve(curve, intersectOptions)
                    For segment As Integer = 0 To intersection.SegmentCount - 1
                        ' Calculate length of the rebar that is inside the column
                        Dim curveInside As Curve = intersection.GetCurveSegment(segment)
                        Dim rebarLengthInColumn As Double = curveInside.Length
                        totalRebarLengthInColumn = totalRebarLengthInColumn + rebarLengthInColumn
                    Next

                Next
            Next
        Next
    Next

End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input curve is not bound. -or- The input solid is not a closed volume.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Solid Class


Solid Properties

[image] [image]

Revit 2024 API
Solid Properties
Solid Class See Also Send Feedback

The Solid type exposes the following members.

Properties

 | Name | Description
Public property | Edges | The edges that belong to the solid.
Public property | Faces | The faces that belong to the solid.
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject.)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | SurfaceArea | Returns the total surface area of this solid.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)
Public property | Volume | Returns the signed volume of this solid.

See Also

Solid Class


Edges Property

[image]

Revit 2024 API
Solid..::..Edges Property
Solid Class See Also Send Feedback
The edges that belong to the solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public EdgeArray Edges { get; }
Visual Basic
Public ReadOnly Property Edges As EdgeArray
    Get
Visual C++
public:
property EdgeArray^ Edges {
    EdgeArray^ get ();
}

See Also

Solid Class


Faces Property

[image]

Revit 2024 API
Solid..::..Faces Property
Solid Class Example See Also Send Feedback
The faces that belong to the solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FaceArray Faces { get; }
Visual Basic
Public ReadOnly Property Faces As FaceArray
    Get
Visual C++
public:
property FaceArray^ Faces {
    FaceArray^ get ();
}

Remarks

A face may be degenerate. This can be determined with the Face property IsTwoSided.

Examples

CopyC#
private void GetFacesAndEdges(Wall wall)
{
    String faceInfo = "";

    Autodesk.Revit.DB.Options opt = new Options();
    Autodesk.Revit.DB.GeometryElement geomElem = wall.get_Geometry(opt);
    foreach (GeometryObject geomObj in geomElem)
    {
        Solid geomSolid = geomObj as Solid;
        if (null != geomSolid)
        {
            int faces = 0;
            double totalArea = 0;
            foreach (Face geomFace in geomSolid.Faces)
            {
                faces++;
                faceInfo += "Face " + faces + " area: " + geomFace.Area.ToString() + "\n";
                totalArea += geomFace.Area;
            }
            faceInfo += "Number of faces: " + faces + "\n";
            faceInfo += "Total area: " + totalArea.ToString() + "\n";
            foreach (Edge geomEdge in geomSolid.Edges)
            {
                // get wall's geometry edges
            }
        }
    }

    TaskDialog.Show("Revit",faceInfo);
}
CopyVB.NET
Private Sub GetFacesAndEdges(wall As Wall)
    Dim faceInfo As [String] = ""

    Dim opt As Autodesk.Revit.DB.Options = New Options()
    Dim geomElem As Autodesk.Revit.DB.GeometryElement = wall.Geometry(opt)
    For Each geomObj As GeometryObject In geomElem
        Dim geomSolid As Solid = TryCast(geomObj, Solid)
        If geomSolid IsNot Nothing Then
            Dim faces As Integer = 0
            Dim totalArea As Double = 0
            For Each geomFace As Face In geomSolid.Faces
                faces += 1
                faceInfo += "Face " + faces + " area: " + geomFace.Area.ToString() + vbLf
                totalArea += geomFace.Area
            Next
            faceInfo += "Number of faces: " + faces + vbLf
            faceInfo += "Total area: " + totalArea.ToString() + vbLf
            ' get wall's geometry edges
            For Each geomEdge As Edge In geomSolid.Edges
            Next
        End If
    Next

    TaskDialog.Show("Revit", faceInfo)
End Sub

See Also

Solid Class


SurfaceArea Property

[image]

Revit 2024 API
Solid..::..SurfaceArea Property
Solid Class See Also Send Feedback
Returns the total surface area of this solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double SurfaceArea { get; }
Visual Basic
Public ReadOnly Property SurfaceArea As Double
    Get
Visual C++
public:
property double SurfaceArea {
    double get ();
}

Return Value

The real number equal to the total area of this solid.

Remarks

Calculates the surface area by adding together the areas of faces comprising this solid. Will slightly underestimate if curved surfaces are present.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when this solid is not a valid Geometry object.

See Also

Solid Class


Volume Property

[image]

Revit 2024 API
Solid..::..Volume Property
Solid Class See Also Send Feedback
Returns the signed volume of this solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double Volume { get; }
Visual Basic
Public ReadOnly Property Volume As Double
    Get
Visual C++
public:
property double Volume {
    double get ();
}

Return Value

The real number equal to the signed volume of this solid.

Remarks

Revit attempts to compute the volume analytically, if possible. If an analytical solution is not possible, it uses tessellated faces to calculate a reasonable approximation for the volume. The calculated volume may be slightly underestimated or overestimated if curved surfaces are present.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when this solid is not a valid Geometry object or the volume calculation failed.

See Also

Solid Class


SolidCurveIntersection Class

[image]

Revit 2024 API
SolidCurveIntersection Class
Members See Also Send Feedback
This class represents the results of a calculation of intersection between a solid volume and a curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public class SolidCurveIntersection : IEnumerable<Curve>,
    IDisposable
Visual Basic
Public Class SolidCurveIntersection _
    Implements IEnumerable(Of Curve), IDisposable
Visual C++
public ref class SolidCurveIntersection : IEnumerable<Curve^>,
    IDisposable

Remarks

The results contain a collection of curves and a collection of curve extents (which are the parameters of intersection from the original input curve). Depending on the SolidCurveIntersectionMode option passed when executing the calculation, the curve segments and curve extents represent either the extents of the curve which exist inside the solid, or the extents of the curve which exist outside the solid. If the curve is entirely inside the solid, and the option is CurveSegmentsOutside, or if the curve is entirely outside the solid, and the option is CurveSegmentsInside, this results object will be empty. Note that curves aligned with the bounding faces of the solid are considered to be inside by this utility.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..SolidCurveIntersection

See Also

SolidCurveIntersection Members


SolidCurveIntersection Members

[image] [image]

Revit 2024 API
SolidCurveIntersection Members
SolidCurveIntersection Class Methods Properties See Also Send Feedback

The SolidCurveIntersection type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the SolidCurveIntersection
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetCurveSegment | Gets the curve segment generated by intersection.
Public method | GetCurveSegmentExtents | Gets the extents for the given curve segment generated by intersection.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ResultType | The result type used to calculate the intersections.
Public property | SegmentCount | The number of segments in the results.

See Also

SolidCurveIntersection Class


SolidCurveIntersection Methods

[image] [image]

Revit 2024 API
SolidCurveIntersection Methods
SolidCurveIntersection Class See Also Send Feedback

The SolidCurveIntersection type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetCurveSegment | Gets the curve segment generated by intersection.
Public method | GetCurveSegmentExtents | Gets the extents for the given curve segment generated by intersection.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SolidCurveIntersection Class


Dispose Method

[image]

Revit 2024 API
SolidCurveIntersection..::..Dispose Method
SolidCurveIntersection Class See Also Send Feedback
Releases all resources used by the SolidCurveIntersection

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

SolidCurveIntersection Class


GetBasicIEnumerator Method

[image]

Revit 2024 API
SolidCurveIntersection..::..GetBasicIEnumerator Method
SolidCurveIntersection Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
internal virtual IEnumerator GetBasicIEnumerator()
Visual Basic
Friend Overridable Function GetBasicIEnumerator As IEnumerator
Visual C++
internal:
virtual IEnumerator^ GetBasicIEnumerator()

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

SolidCurveIntersection Class


GetCurveSegment Method

[image]

Revit 2024 API
SolidCurveIntersection..::..GetCurveSegment Method
SolidCurveIntersection Class See Also Send Feedback
Gets the curve segment generated by intersection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public Curve GetCurveSegment(
    int index
)
Visual Basic
Public Function GetCurveSegment ( _
    index As Integer _
) As Curve
Visual C++
public:
Curve^ GetCurveSegment(
    int index
)

Parameters

index
Type: System..::..Int32
The index.

Return Value

The curve.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | index is out of range.

See Also

SolidCurveIntersection Class


GetCurveSegmentExtents Method

[image]

Revit 2024 API
SolidCurveIntersection..::..GetCurveSegmentExtents Method
SolidCurveIntersection Class See Also Send Feedback
Gets the extents for the given curve segment generated by intersection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public CurveExtents GetCurveSegmentExtents(
    int index
)
Visual Basic
Public Function GetCurveSegmentExtents ( _
    index As Integer _
) As CurveExtents
Visual C++
public:
CurveExtents^ GetCurveSegmentExtents(
    int index
)

Parameters

index
Type: System..::..Int32
The index.

Return Value

The curve extents.

Remarks

The parameters are raw parameters based on the raw parameter extents of the original input curve.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | index is out of range.

See Also

SolidCurveIntersection Class


GetEnumerator Method

[image]

Revit 2024 API
SolidCurveIntersection..::..GetEnumerator Method
SolidCurveIntersection Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IEnumerator<Curve> GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator(Of Curve)
Visual C++
public:
virtual IEnumerator<Curve^>^ GetEnumerator()

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

SolidCurveIntersection Class


SolidCurveIntersection Properties

[image] [image]

Revit 2024 API
SolidCurveIntersection Properties
SolidCurveIntersection Class See Also Send Feedback

The SolidCurveIntersection type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ResultType | The result type used to calculate the intersections.
Public property | SegmentCount | The number of segments in the results.

See Also

SolidCurveIntersection Class


IsValidObject Property

[image]

Revit 2024 API
SolidCurveIntersection..::..IsValidObject Property
SolidCurveIntersection Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

SolidCurveIntersection Class


SegmentCount Property

[image]

Revit 2024 API
SolidCurveIntersection..::..SegmentCount Property
SolidCurveIntersection Class See Also Send Feedback
The number of segments in the results.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public int SegmentCount { get; }
Visual Basic
Public ReadOnly Property SegmentCount As Integer
    Get
Visual C++
public:
property int SegmentCount {
    int get ();
}

See Also

SolidCurveIntersection Class


SolidCurveIntersectionMode Enumeration

[image]

Revit 2024 API
SolidCurveIntersectionMode Enumeration
See Also Send Feedback
Represents the types of results available for calculating the intersection between a solid and a curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public enum SolidCurveIntersectionMode
Visual Basic
Public Enumeration SolidCurveIntersectionMode
Visual C++
public enum class SolidCurveIntersectionMode

Members

Member name | Description
CurveSegmentsInside | The results will include only curve segments inside the solid volume. This also will include curve segments coincident with the face(s) of the volume.
CurveSegmentsOutside | The results will include only curve segments outside the solid volume.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


SolidCurveIntersectionOptions Constructor

[image]

Revit 2024 API
SolidCurveIntersectionOptions Constructor
SolidCurveIntersectionOptions Class See Also Send Feedback
Constructs a new SolidCurveIntersectionMode with default settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public SolidCurveIntersectionOptions()
Visual Basic
Public Sub New
Visual C++
public:
SolidCurveIntersectionOptions()

See Also

SolidCurveIntersectionOptions Class


SolidCurveIntersectionOptions Methods

[image] [image]

Revit 2024 API
SolidCurveIntersectionOptions Methods
SolidCurveIntersectionOptions Class See Also Send Feedback

The SolidCurveIntersectionOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SolidCurveIntersectionOptions Class


SolidCurveIntersectionOptions Properties

[image] [image]

Revit 2024 API
SolidCurveIntersectionOptions Properties
SolidCurveIntersectionOptions Class See Also Send Feedback

The SolidCurveIntersectionOptions type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ResultType | The type of results expected by the calculation. The default is CurveSegmentsInside.

See Also

SolidCurveIntersectionOptions Class


IsValidObject Property

[image]

Revit 2024 API
SolidCurveIntersectionOptions..::..IsValidObject Property
SolidCurveIntersectionOptions Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

SolidCurveIntersectionOptions Class


ResultType Property

[image]

Revit 2024 API
SolidCurveIntersectionOptions..::..ResultType Property
SolidCurveIntersectionOptions Class See Also Send Feedback
The type of results expected by the calculation. The default is CurveSegmentsInside.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public SolidCurveIntersectionMode ResultType { get; set; }
Visual Basic
Public Property ResultType As SolidCurveIntersectionMode
    Get
    Set
Visual C++
public:
property SolidCurveIntersectionMode ResultType {
    SolidCurveIntersectionMode get ();
    void set (SolidCurveIntersectionMode value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

SolidCurveIntersectionOptions Class


SolidGeometry Enumeration

[image]

Revit 2024 API
SolidGeometry Enumeration
See Also Send Feedback
An enumerated type listing possible ways of exporting solids in 3D views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum SolidGeometry
Visual Basic
Public Enumeration SolidGeometry
Visual C++
public enum class SolidGeometry

Members

Member name | Description
Polymesh | All visible solids are exported as polymesh.
ACIS | All visible Revit Building geometry is exported as ACIS 3D solids (except for any elements that are already a polymesh.)

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


SolidGeometryOptions Class

[image]

Revit 2024 API
SolidGeometryOptions Class
Members See Also Send Feedback
A class containing optional information to control the geometry generation of the Solid by the SolidUtils routines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public class SolidGeometryOptions : IDisposable
Visual Basic
Public Class SolidGeometryOptions _
    Implements IDisposable
Visual C++
public ref class SolidGeometryOptions : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..SolidGeometryOptions

See Also

SolidGeometryOptions Members


SolidGeometryOptions Members

[image] [image]

Revit 2024 API
SolidGeometryOptions Members
SolidGeometryOptions Class Constructors Methods Properties See Also Send Feedback

The SolidGeometryOptions type exposes the following members.

Constructors

 | Name | Description
Public method | SolidGeometryOptions | Creates a new SolidOptions class with solid tag settings.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the SolidGeometryOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SolidTag | Optional solid tag for the Solid.

See Also

SolidGeometryOptions Class


SolidGeometryOptions Constructor

[image]

Revit 2024 API
SolidGeometryOptions Constructor
SolidGeometryOptions Class See Also Send Feedback
Creates a new SolidOptions class with solid tag settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public SolidGeometryOptions(
    int solidTag
)
Visual Basic
Public Sub New ( _
    solidTag As Integer _
)
Visual C++
public:
SolidGeometryOptions(
    int solidTag
)

Parameters

solidTag
Type: System..::..Int32
The material id for the Solid.

See Also

SolidGeometryOptions Class


Dispose Method

[image]

Revit 2024 API
SolidGeometryOptions..::..Dispose Method
SolidGeometryOptions Class See Also Send Feedback
Releases all resources used by the SolidGeometryOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

SolidGeometryOptions Class


SolidGeometryOptions Properties

[image] [image]

Revit 2024 API
SolidGeometryOptions Properties
SolidGeometryOptions Class See Also Send Feedback

The SolidGeometryOptions type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SolidTag | Optional solid tag for the Solid.

See Also

SolidGeometryOptions Class


SolidTag Property

[image]

Revit 2024 API
SolidGeometryOptions..::..SolidTag Property
SolidGeometryOptions Class See Also Send Feedback
Optional solid tag for the Solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public int SolidTag { get; set; }
Visual Basic
Public Property SolidTag As Integer
    Get
    Set
Visual C++
public:
property int SolidTag {
    int get ();
    void set (int value);
}

See Also

SolidGeometryOptions Class


SolidOptions Class

[image]

Revit 2024 API
SolidOptions Class
Members See Also Send Feedback
A class containing optional information to control the properties of the Solid generated by the GeometryCreationUtilities routines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public class SolidOptions : IDisposable
Visual Basic
Public Class SolidOptions _
    Implements IDisposable
Visual C++
public ref class SolidOptions : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..SolidOptions

See Also

SolidOptions Members


SolidOptions Members

[image] [image]

Revit 2024 API
SolidOptions Members
SolidOptions Class Constructors Methods Properties See Also Send Feedback

The SolidOptions type exposes the following members.

Constructors

 | Name | Description
Public method | SolidOptions | Creates a new SolidOptions class with material and graphics style settings.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the SolidOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ExtraFaceAndEdgeHistoryKey | Optional extra key used to create face and edge histories for the Solid. If extraFaceAndEdgeHistoryKey is higher than -1, the Solid's face and edge histories will be created depending on the geometry generation of the Solid.
Public property | GraphicsStyleId | Defines the graphics style id for the Solid.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MaterialId | Defines the material id for the Solid.

See Also

SolidOptions Class


SolidOptions Constructor

[image]

Revit 2024 API
SolidOptions Constructor
SolidOptions Class See Also Send Feedback
Creates a new SolidOptions class with material and graphics style settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public SolidOptions(
    ElementId materialId,
    ElementId graphicsStyleId
)
Visual Basic
Public Sub New ( _
    materialId As ElementId, _
    graphicsStyleId As ElementId _
)
Visual C++
public:
SolidOptions(
    ElementId^ materialId,
    ElementId^ graphicsStyleId
)

Parameters

materialId
Type: Autodesk.Revit.DB..::..ElementId
The material id for the Solid.
graphicsStyleId
Type: Autodesk.Revit.DB..::..ElementId
The graphics style id for the Solid.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

SolidOptions Class


SolidOptions Methods

[image] [image]

Revit 2024 API
SolidOptions Methods
SolidOptions Class See Also Send Feedback

The SolidOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SolidOptions Class


Dispose Method

[image]

Revit 2024 API
SolidOptions..::..Dispose Method
SolidOptions Class See Also Send Feedback
Releases all resources used by the SolidOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

SolidOptions Class


ExtraFaceAndEdgeHistoryKey Property

[image]

Revit 2024 API
SolidOptions..::..ExtraFaceAndEdgeHistoryKey Property
SolidOptions Class See Also Send Feedback
Optional extra key used to create face and edge histories for the Solid. If extraFaceAndEdgeHistoryKey is higher than -1, the Solid's face and edge histories will be created depending on the geometry generation of the Solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public int ExtraFaceAndEdgeHistoryKey { get; set; }
Visual Basic
Public Property ExtraFaceAndEdgeHistoryKey As Integer
    Get
    Set
Visual C++
public:
property int ExtraFaceAndEdgeHistoryKey {
    int get ();
    void set (int value);
}

See Also

SolidOptions Class


GraphicsStyleId Property

[image]

Revit 2024 API
SolidOptions..::..GraphicsStyleId Property
SolidOptions Class See Also Send Feedback
Defines the graphics style id for the Solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public ElementId GraphicsStyleId { get; set; }
Visual Basic
Public Property GraphicsStyleId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ GraphicsStyleId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

SolidOptions Class


MaterialId Property

[image]

Revit 2024 API
SolidOptions..::..MaterialId Property
SolidOptions Class See Also Send Feedback
Defines the material id for the Solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public ElementId MaterialId { get; set; }
Visual Basic
Public Property MaterialId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ MaterialId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

SolidOptions Class


SolidOrShellTessellationControls Class

[image]

Revit 2024 API
SolidOrShellTessellationControls Class
Members See Also Send Feedback
Controls various aspects of the triangulation produced by [!:SolidUtils::tessellateSolidOrShell()] method.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public class SolidOrShellTessellationControls : IDisposable
Visual Basic
Public Class SolidOrShellTessellationControls _
    Implements IDisposable
Visual C++
public ref class SolidOrShellTessellationControls : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..SolidOrShellTessellationControls

See Also

SolidOrShellTessellationControls Members


SolidOrShellTessellationControls Methods

[image] [image]

Revit 2024 API
SolidOrShellTessellationControls Methods
SolidOrShellTessellationControls Class See Also Send Feedback

The SolidOrShellTessellationControls type exposes the following members.

Methods

 | Name | Description
Public method | DisableLevelOfDetail | Disables the use of levelOfDetail. The use of levelOfDetail is enabled by calling setLevelOfDetail (with a valid input).
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UseLevelOfDetail | Returns true if the use of levelOfDetail is enabled, false if not. The use of levelOfDetail is enabled by calling setLevelOfDetail (with a valid input).

See Also

SolidOrShellTessellationControls Class


Dispose Method

[image]

Revit 2024 API
SolidOrShellTessellationControls..::..Dispose Method
SolidOrShellTessellationControls Class See Also Send Feedback
Releases all resources used by the SolidOrShellTessellationControls

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

SolidOrShellTessellationControls Class


UseLevelOfDetail Method

[image]

Revit 2024 API
SolidOrShellTessellationControls..::..UseLevelOfDetail Method
SolidOrShellTessellationControls Class See Also Send Feedback
Returns true if the use of levelOfDetail is enabled, false if not. The use of levelOfDetail is enabled by calling setLevelOfDetail (with a valid input).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool UseLevelOfDetail()
Visual Basic
Public Function UseLevelOfDetail As Boolean
Visual C++
public:
bool UseLevelOfDetail()

See Also

SolidOrShellTessellationControls Class


Accuracy Property

[image]

Revit 2024 API
SolidOrShellTessellationControls..::..Accuracy Property
SolidOrShellTessellationControls Class See Also Send Feedback
A positive real number specifying how accurately a triangulation should approximate a solid or shell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double Accuracy { get; set; }
Visual Basic
Public Property Accuracy As Double
    Get
    Set
Visual C++
public:
property double Accuracy {
    double get ();
    void set (double value);
}

Remarks

The maximum distance from a point on the triangulation to the nearest point on the solid or shell should be no greater than the specified accuracy. This constraint may be approximately enforced.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for accuracy must be greater than 0 and no more than 30000 feet.

See Also

SolidOrShellTessellationControls Class


IsValidObject Property

[image]

Revit 2024 API
SolidOrShellTessellationControls..::..IsValidObject Property
SolidOrShellTessellationControls Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

SolidOrShellTessellationControls Class


LevelOfDetail Property

[image]

Revit 2024 API
SolidOrShellTessellationControls..::..LevelOfDetail Property
SolidOrShellTessellationControls Class See Also Send Feedback
An number between 0 and 1 (inclusive) specifying the level of detail for the triangulation of a solid or shell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double LevelOfDetail { get; set; }
Visual Basic
Public Property LevelOfDetail As Double
    Get
    Set
Visual C++
public:
property double LevelOfDetail {
    double get ();
    void set (double value);
}

Remarks

Smaller values yield coarser triangulations (fewer triangles), while larger values yield finer triangulations (more triangles).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for levelOfDetail must lie between 0 and 1 (inclusive).

See Also

SolidOrShellTessellationControls Class


MinAngleInTriangle Property

[image]

Revit 2024 API
SolidOrShellTessellationControls..::..MinAngleInTriangle Property
SolidOrShellTessellationControls Class See Also Send Feedback
A non-negative real number specifying the minimum allowed angle for any triangle in the triangulation, in radians.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double MinAngleInTriangle { get; set; }
Visual Basic
Public Property MinAngleInTriangle As Double
    Get
    Set
Visual C++
public:
property double MinAngleInTriangle {
    double get ();
    void set (double value);
}

Remarks

A small value can be useful when triangulating long, thin objects, in order to keep the number of triangles small, but it can result in long, thin triangles, which are not acceptable for all applications. If the value is too large, this constraint may not be satisfiable, causing the triangulation to fail. This constraint may be approximately enforced. A value of 0 means to ignore the minimum angle constraint.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for minAngleInTriangle must be at least 0 and less than 60 degrees, expressed in radians. The value 0 means to ignore the minimum angle constraint.

See Also

SolidOrShellTessellationControls Class


SolidSolidCutUtils Members

[image] [image]

Revit 2024 API
SolidSolidCutUtils Members
SolidSolidCutUtils Class Methods See Also Send Feedback

The SolidSolidCutUtils type exposes the following members.

Methods

Name | Description
AddCutBetweenSolids(Document, Element, Element) | Adds a solid-solid cut for the two elements.
AddCutBetweenSolids(Document, Element, Element, Boolean) | Adds a solid-solid cut for the two elements with the option to control splitting of faces of the cutting solid.
CanElementCutElement | Verifies if the cutting element can add a solid cut to the target element.
CutExistsBetweenElements | Checks that if there is a solid-solid cut between two elements.
GetCuttingSolids | Gets all the solids which cut the input element.
GetSolidsBeingCut | Get all the solids which are cut by the input element.
IsAllowedForSolidCut | Validates that the element is eligible for a solid-solid cut.
IsElementFromAppropriateContext | Validates that the element is from an appropriate document.
RemoveCutBetweenSolids | Removes the solid-solid cut between the two elements if it exists.
SplitFacesOfCuttingSolid | Causes the faces of the cutting element where it intersects the element it is cutting to be split or unsplit.

See Also

SolidSolidCutUtils Class


SolidSolidCutUtils Methods

[image] [image]

Revit 2024 API
SolidSolidCutUtils Methods
SolidSolidCutUtils Class See Also Send Feedback

The SolidSolidCutUtils type exposes the following members.

Methods

Name | Description
AddCutBetweenSolids(Document, Element, Element) | Adds a solid-solid cut for the two elements.
AddCutBetweenSolids(Document, Element, Element, Boolean) | Adds a solid-solid cut for the two elements with the option to control splitting of faces of the cutting solid.
CanElementCutElement | Verifies if the cutting element can add a solid cut to the target element.
CutExistsBetweenElements | Checks that if there is a solid-solid cut between two elements.
GetCuttingSolids | Gets all the solids which cut the input element.
GetSolidsBeingCut | Get all the solids which are cut by the input element.
IsAllowedForSolidCut | Validates that the element is eligible for a solid-solid cut.
IsElementFromAppropriateContext | Validates that the element is from an appropriate document.
RemoveCutBetweenSolids | Removes the solid-solid cut between the two elements if it exists.
SplitFacesOfCuttingSolid | Causes the faces of the cutting element where it intersects the element it is cutting to be split or unsplit.

See Also

SolidSolidCutUtils Class


AddCutBetweenSolids Method

[image] [image]

Revit 2024 API
SolidSolidCutUtils..::..AddCutBetweenSolids Method
SolidSolidCutUtils Class See Also Send Feedback

Overload List

Name | Description
AddCutBetweenSolids(Document, Element, Element) | Adds a solid-solid cut for the two elements.
AddCutBetweenSolids(Document, Element, Element, Boolean) | Adds a solid-solid cut for the two elements with the option to control splitting of faces of the cutting solid.

See Also

SolidSolidCutUtils Class
SolidSolidCutUtils Members


CanElementCutElement Method

[image]

Revit 2024 API
SolidSolidCutUtils..::..CanElementCutElement Method
SolidSolidCutUtils Class See Also Send Feedback
Verifies if the cutting element can add a solid cut to the target element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static bool CanElementCutElement(
    Element cuttingElement,
    Element cutElement,
    out CutFailureReason reason
)
Visual Basic
Public Shared Function CanElementCutElement ( _
    cuttingElement As Element, _
    cutElement As Element, _
    <OutAttribute> ByRef reason As CutFailureReason _
) As Boolean
Visual C++
public:
static bool CanElementCutElement(
    Element^ cuttingElement,
    Element^ cutElement,
    [OutAttribute] CutFailureReason% reason
)

Parameters

cuttingElement
Type: Autodesk.Revit.DB..::..Element
The cutting element.
cutElement
Type: Autodesk.Revit.DB..::..Element
The element to be cut.
reason
Type: Autodesk.Revit.DB..::..CutFailureReason %
The reason that the cutting element cannot add a solid cut to the cut element.

Return Value

True if the cutting element can add a solid cut to the target element, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

SolidSolidCutUtils Class


GetSolidsBeingCut Method

[image]

Revit 2024 API
SolidSolidCutUtils..::..GetSolidsBeingCut Method
SolidSolidCutUtils Class See Also Send Feedback
Get all the solids which are cut by the input element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static ICollection<ElementId> GetSolidsBeingCut(
    Element element
)
Visual Basic
Public Shared Function GetSolidsBeingCut ( _
    element As Element _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetSolidsBeingCut(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The input element.

Return Value

The ids of the solids which are cut by the input element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

SolidSolidCutUtils Class


IsAllowedForSolidCut Method

[image]

Revit 2024 API
SolidSolidCutUtils..::..IsAllowedForSolidCut Method
SolidSolidCutUtils Class See Also Send Feedback
Validates that the element is eligible for a solid-solid cut.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static bool IsAllowedForSolidCut(
    Element element
)
Visual Basic
Public Shared Function IsAllowedForSolidCut ( _
    element As Element _
) As Boolean
Visual C++
public:
static bool IsAllowedForSolidCut(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The solid to be cut or the cutting solid.

Return Value

True if the input element can participate in a solid-solid cut. False otherwise.

Remarks

The element must be solid and must be a GenericForm, GeomCombination, or a FamilyInstance.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

SolidSolidCutUtils Class


SplitFacesOfCuttingSolid Method

[image]

Revit 2024 API
SolidSolidCutUtils..::..SplitFacesOfCuttingSolid Method
SolidSolidCutUtils Class See Also Send Feedback
Causes the faces of the cutting element where it intersects the element it is cutting to be split or unsplit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static void SplitFacesOfCuttingSolid(
    Element first,
    Element second,
    bool split
)
Visual Basic
Public Shared Sub SplitFacesOfCuttingSolid ( _
    first As Element, _
    second As Element, _
    split As Boolean _
)
Visual C++
public:
static void SplitFacesOfCuttingSolid(
    Element^ first,
    Element^ second,
    bool split
)

Parameters

first
Type: Autodesk.Revit.DB..::..Element
The solid being cut or the cutting solid
second
Type: Autodesk.Revit.DB..::..Element
The solid being cut or the cutting solid
split
Type: System..::..Boolean
True to split the faces of intersection, false to unsplit them.

Remarks

There must be a cut between the input elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | There is no solid-solid cut between the input elements.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | Unable to split or unsplit faces of cutting solid

See Also

SolidSolidCutUtils Class


SolidUtils Class

[image]

Revit 2024 API
SolidUtils Class
Members See Also Send Feedback
Contains utility functions for solid operations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static class SolidUtils
Visual Basic
Public NotInheritable Class SolidUtils
Visual C++
public ref class SolidUtils abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..SolidUtils

See Also

SolidUtils Members


SolidUtils Members

[image] [image]

Revit 2024 API
SolidUtils Members
SolidUtils Class Methods See Also Send Feedback

The SolidUtils type exposes the following members.

Methods

Name | Description
Clone | Creates a new Solid which is a copy of the input Solid.
CreateTransformed | Creates a new Solid which is the transformation of the input Solid.
FindAllEdgeEndPointsAtVertex | Find all EdgeEndPoints at a vertex identified by the input EdgeEndPoint.
IsValidForTessellation | Tests if the input solid or shell is valid for tessellation.
SplitVolumes | Splits a solid geometry into several separate solids.
TessellateSolidOrShell | This function facets (i.e., triangulates) a solid or an open shell. Each boundary component of the solid or shell is represented by a single triangulated structure.

See Also

SolidUtils Class


SolidUtils Methods

[image] [image]

Revit 2024 API
SolidUtils Methods
SolidUtils Class See Also Send Feedback

The SolidUtils type exposes the following members.

Methods

Name | Description
Clone | Creates a new Solid which is a copy of the input Solid.
CreateTransformed | Creates a new Solid which is the transformation of the input Solid.
FindAllEdgeEndPointsAtVertex | Find all EdgeEndPoints at a vertex identified by the input EdgeEndPoint.
IsValidForTessellation | Tests if the input solid or shell is valid for tessellation.
SplitVolumes | Splits a solid geometry into several separate solids.
TessellateSolidOrShell | This function facets (i.e., triangulates) a solid or an open shell. Each boundary component of the solid or shell is represented by a single triangulated structure.

See Also

SolidUtils Class


Clone Method

[image]

Revit 2024 API
SolidUtils..::..Clone Method
SolidUtils Class See Also Send Feedback
Creates a new Solid which is a copy of the input Solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public static Solid Clone(
    Solid solid
)
Visual Basic
Public Shared Function Clone ( _
    solid As Solid _
) As Solid
Visual C++
public:
static Solid^ Clone(
    Solid^ solid
)

Parameters

solid
Type: Autodesk.Revit.DB..::..Solid
The input solid to be copied.

Return Value

The newly created Solid.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

SolidUtils Class


CreateTransformed Method

[image]

Revit 2024 API
SolidUtils..::..CreateTransformed Method
SolidUtils Class See Also Send Feedback
Creates a new Solid which is the transformation of the input Solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public static Solid CreateTransformed(
    Solid solid,
    Transform transform
)
Visual Basic
Public Shared Function CreateTransformed ( _
    solid As Solid, _
    transform As Transform _
) As Solid
Visual C++
public:
static Solid^ CreateTransformed(
    Solid^ solid,
    Transform^ transform
)

Parameters

solid
Type: Autodesk.Revit.DB..::..Solid
The input solid to be transformed.
transform
Type: Autodesk.Revit.DB..::..Transform
The transform (which must be conformal).

Return Value

The newly created Solid.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | transform is not conformal. -or- transform has a scale that is negative or zero.

See Also

SolidUtils Class


FindAllEdgeEndPointsAtVertex Method

[image]

Revit 2024 API
SolidUtils..::..FindAllEdgeEndPointsAtVertex Method
SolidUtils Class See Also Send Feedback
Find all EdgeEndPoints at a vertex identified by the input EdgeEndPoint.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static IList<EdgeEndPoint> FindAllEdgeEndPointsAtVertex(
    EdgeEndPoint edgeEndPoint
)
Visual Basic
Public Shared Function FindAllEdgeEndPointsAtVertex ( _
    edgeEndPoint As EdgeEndPoint _
) As IList(Of EdgeEndPoint)
Visual C++
public:
static IList<EdgeEndPoint^>^ FindAllEdgeEndPointsAtVertex(
    EdgeEndPoint^ edgeEndPoint
)

Parameters

edgeEndPoint
Type: Autodesk.Revit.DB..::..EdgeEndPoint
The input EdgeEndPoint that identifies the vertex.

Return Value

All EdgeEndPoints at the vertex. The input EdgeEndPoint is also included.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | Failed to find all EdgeEndPoints at a vertex identified by the input EdgeEndPoint.

See Also

SolidUtils Class


IsValidForTessellation Method

[image]

Revit 2024 API
SolidUtils..::..IsValidForTessellation Method
SolidUtils Class See Also Send Feedback
Tests if the input solid or shell is valid for tessellation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static bool IsValidForTessellation(
    Solid solidOrShell
)
Visual Basic
Public Shared Function IsValidForTessellation ( _
    solidOrShell As Solid _
) As Boolean
Visual C++
public:
static bool IsValidForTessellation(
    Solid^ solidOrShell
)

Parameters

solidOrShell
Type: Autodesk.Revit.DB..::..Solid
The solid or shell.

Return Value

True if the solid or shell is valid for tessellation, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

SolidUtils Class


SplitVolumes Method

[image]

Revit 2024 API
SolidUtils..::..SplitVolumes Method
SolidUtils Class See Also Send Feedback
Splits a solid geometry into several separate solids.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static IList<Solid> SplitVolumes(
    Solid solid
)
Visual Basic
Public Shared Function SplitVolumes ( _
    solid As Solid _
) As IList(Of Solid)
Visual C++
public:
static IList<Solid^>^ SplitVolumes(
    Solid^ solid
)

Parameters

solid
Type: Autodesk.Revit.DB..::..Solid
The solid.

Return Value

The split solid geometries.

Remarks

If no splitting is done, a copy of the input solid will be returned in the output array.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | Failed to split the solid geometry.

See Also

SolidUtils Class


SortingOrder Enumeration

[image]

Revit 2024 API
SortingOrder Enumeration
See Also Send Feedback
Enumerated type representing the sorting order of a collection of objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public enum SortingOrder
Visual Basic
Public Enumeration SortingOrder
Visual C++
public enum class SortingOrder

Members

Member name | Description
Ascending | Ascending sorting order
Descending | Descending sorting order

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


SpacingRule Methods

[image] [image]

Revit 2024 API
SpacingRule Methods
SpacingRule Class See Also Send Feedback

The SpacingRule type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetLayoutFixedDistance | Set the Layout property to FixedDistance.
Public method | SetLayoutFixedNumber | Set the Layout property to FixedNumber.
Public method | SetLayoutMaximumSpacing | Set the Layout property to MaximumSpacing.
Public method | SetLayoutMinimumSpacing | Set the Layout property to MinimumSpacing.
Public method | SetLayoutNone | Set the Layout property to None.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SpacingRule Class


SetLayoutFixedNumber Method

[image]

Revit 2024 API
SpacingRule..::..SetLayoutFixedNumber Method
SpacingRule Class See Also Send Feedback
Set the Layout property to FixedNumber.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetLayoutFixedNumber(
    int number,
    SpacingRuleJustification just,
    double gridlinesRotation,
    double offset
)
Visual Basic
Public Sub SetLayoutFixedNumber ( _
    number As Integer, _
    just As SpacingRuleJustification, _
    gridlinesRotation As Double, _
    offset As Double _
)
Visual C++
public:
void SetLayoutFixedNumber(
    int number,
    SpacingRuleJustification just,
    double gridlinesRotation,
    double offset
)

Parameters

number
Type: System..::..Int32
just
Type: Autodesk.Revit.DB..::..SpacingRuleJustification
gridlinesRotation
Type: System..::..Double
offset
Type: System..::..Double

Remarks

When changing the Layout to FixedNumber, you must also simultaneously set the Number, Justification, GridlinesRotation, and Offset properties.

See Also

SpacingRule Class


SetLayoutMaximumSpacing Method

[image]

Revit 2024 API
SpacingRule..::..SetLayoutMaximumSpacing Method
SpacingRule Class See Also Send Feedback
Set the Layout property to MaximumSpacing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetLayoutMaximumSpacing(
    double distance,
    SpacingRuleJustification just,
    double gridlinesRotation,
    double offset
)
Visual Basic
Public Sub SetLayoutMaximumSpacing ( _
    distance As Double, _
    just As SpacingRuleJustification, _
    gridlinesRotation As Double, _
    offset As Double _
)
Visual C++
public:
void SetLayoutMaximumSpacing(
    double distance,
    SpacingRuleJustification just,
    double gridlinesRotation,
    double offset
)

Parameters

distance
Type: System..::..Double
just
Type: Autodesk.Revit.DB..::..SpacingRuleJustification
gridlinesRotation
Type: System..::..Double
offset
Type: System..::..Double

Remarks

When changing the Layout to MaximumSpacing, you must also simultaneously set the Distance, Justification, GridlinesRotation, and Offset properties.

See Also

SpacingRule Class


SetLayoutNone Method

[image]

Revit 2024 API
SpacingRule..::..SetLayoutNone Method
SpacingRule Class See Also Send Feedback
Set the Layout property to None.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetLayoutNone()
Visual Basic
Public Sub SetLayoutNone
Visual C++
public:
void SetLayoutNone()

Remarks

No internal lines will be generated, but the effect is equivalent to having two lines, one at each end of the region.

See Also

SpacingRule Class


SpacingRule Properties

[image] [image]

Revit 2024 API
SpacingRule Properties
SpacingRule Class See Also Send Feedback

The SpacingRule type exposes the following members.

Properties

 | Name | Description
Public property | BeltMeasurement | On a curved surface, BeltMeasurement specifies where the grid's distances are measured.
Public property | Distance | The exact distance between layout lines.
Public property | GridlinesRotation | An additional rotation to be applied to this set of grid lines.
Public property | HasBeltMeasurement | True if the gridlines are not parallel due to surface curvature, and the BeltMeasurement property therefore applies.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Justification | The justification of the lines within the region.
Public property | Layout | A choice of several gridline layout rules.
Public property | Number | The exact number of lines in the region.
Public property | Offset | An additional offset applied to the first gridline.

See Also

SpacingRule Class


BeltMeasurement Property

[image]

Revit 2024 API
SpacingRule..::..BeltMeasurement Property
SpacingRule Class See Also Send Feedback
On a curved surface, BeltMeasurement specifies where the grid's distances are measured.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double BeltMeasurement { get; set; }
Visual Basic
Public Property BeltMeasurement As Double
    Get
    Set
Visual C++
public:
property double BeltMeasurement {
    double get ();
    void set (double value);
}

Remarks

On a conical surface, the distance between the radial gridlines is not constant. To interpret the Distance property, a circumferential gridline is taken as the "belt." Distance is then measured along the belt. The BeltMeasurement property gives the location of the belt relative to the extremes of the surface. The belt is used whenever gridlines are not parallel. It defaults to 0.5.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when beltMeasurement is outside the range [ 0.0, 1.0 ].
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the gridlines are guaranteed to be parallel; check the HasBeltMeasurement property before using this property.

See Also

SpacingRule Class


Distance Property

[image]

Revit 2024 API
SpacingRule..::..Distance Property
SpacingRule Class See Also Send Feedback
The exact distance between layout lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double Distance { get; set; }
Visual Basic
Public Property Distance As Double
    Get
    Set
Visual C++
public:
property double Distance {
    double get ();
    void set (double value);
}

Remarks

This property is only available when Layout is equal to FixedDistance, MaximumSpacing, or MinimumSpacing. Must be a positive value less than 30000'.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the Layout property is None or FixedNumber.

See Also

SpacingRule Class


HasBeltMeasurement Property

[image]

Revit 2024 API
SpacingRule..::..HasBeltMeasurement Property
SpacingRule Class See Also Send Feedback
True if the gridlines are not parallel due to surface curvature, and the BeltMeasurement property therefore applies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool HasBeltMeasurement { get; }
Visual Basic
Public ReadOnly Property HasBeltMeasurement As Boolean
    Get
Visual C++
public:
property bool HasBeltMeasurement {
    bool get ();
}

See Also

SpacingRule Class


Justification Property

[image]

Revit 2024 API
SpacingRule..::..Justification Property
SpacingRule Class See Also Send Feedback
The justification of the lines within the region.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public SpacingRuleJustification Justification { get; set; }
Visual Basic
Public Property Justification As SpacingRuleJustification
    Get
    Set
Visual C++
public:
property SpacingRuleJustification Justification {
    SpacingRuleJustification get ();
    void set (SpacingRuleJustification value);
}

Remarks

This property is only available when Layout is equal to FixedDistance, FixedNumber, MaximumSpacing, or MinimumSpacing.

See Also

SpacingRule Class


Layout Property

[image]

Revit 2024 API
SpacingRule..::..Layout Property
SpacingRule Class See Also Send Feedback
A choice of several gridline layout rules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public SpacingRuleLayout Layout { get; }
Visual Basic
Public ReadOnly Property Layout As SpacingRuleLayout
    Get
Visual C++
public:
property SpacingRuleLayout Layout {
    SpacingRuleLayout get ();
}

Remarks

If "None" is chosen, no internal lines will be generated, but the effect is equivalent to having two lines, one at each end of the region.

See Also

SpacingRule Class


Number Property

[image]

Revit 2024 API
SpacingRule..::..Number Property
SpacingRule Class See Also Send Feedback
The exact number of lines in the region.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public int Number { get; set; }
Visual Basic
Public Property Number As Integer
    Get
    Set
Visual C++
public:
property int Number {
    int get ();
    void set (int value);
}

Remarks

This property is only available when Layout is equal to FixedNumber. Lines will be placed exactly at the boundaries if possible, so if your region is 100' long and you specify Number = 11, your lines will be 10' apart. Must be between 1 and 200.

See Also

SpacingRule Class


SpacingRuleJustification Enumeration

[image]

Revit 2024 API
SpacingRuleJustification Enumeration
See Also Send Feedback
Justification property of spacing rule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum SpacingRuleJustification
Visual Basic
Public Enumeration SpacingRuleJustification
Visual C++
public enum class SpacingRuleJustification

Members

Member name | Description
Center |
Beginning |
End |

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


SpacingRuleLayout Enumeration

[image]

Revit 2024 API
SpacingRuleLayout Enumeration
See Also Send Feedback
Rules for laying out a series of equidistant points or parallel lines

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum SpacingRuleLayout
Visual Basic
Public Enumeration SpacingRuleLayout
Visual C++
public enum class SpacingRuleLayout

Members

Member name | Description
None | No points or lines will be created.
FixedDistance | Points or lines are separated by a fixed distance.
FixedNumber | Fixed number of points or lines with uniform distance between them.
MaximumSpacing | Points or lines are separated by at most the max distance.
MinimumSpacing | Points or lines are separated by at least the minimum distance.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


SpatialElement Members

[image] [image]

Revit 2024 API
SpatialElement Members
SpatialElement Class Methods Properties See Also Send Feedback

The SpatialElement type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetBoundarySegments | Returns the boundary segments.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSpatialElementDomainData | Gets the domain data for the spatial element. The domain data contains information of different spatial elements, such as electrical load area. Currently room/space/area don't have domain data.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Area | The area.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | Level | Gets the level of the room.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | The location of the element. (Overrides Element..::..Location.)
Public property | Name | A human readable name for the Element. (Overrides Element..::..Name.)
Public property | Number | The number.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Perimeter | The perimeter.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SpatialElementType | The spatial element type.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SpatialElement Class


SpatialElement Methods

[image] [image]

Revit 2024 API
SpatialElement Methods
SpatialElement Class See Also Send Feedback

The SpatialElement type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetBoundarySegments | Returns the boundary segments.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSpatialElementDomainData | Gets the domain data for the spatial element. The domain data contains information of different spatial elements, such as electrical load area. Currently room/space/area don't have domain data.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SpatialElement Class


GetBoundarySegments Method

[image]

Revit 2024 API
SpatialElement..::..GetBoundarySegments Method
SpatialElement Class See Also Send Feedback
Returns the boundary segments.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public IList<IList<BoundarySegment>> GetBoundarySegments(
    SpatialElementBoundaryOptions options
)
Visual Basic
Public Function GetBoundarySegments ( _
    options As SpatialElementBoundaryOptions _
) As IList(Of IList(Of BoundarySegment))
Visual C++
public:
IList<IList<BoundarySegment^>^>^ GetBoundarySegments(
    SpatialElementBoundaryOptions^ options
)

Parameters

options
Type: Autodesk.Revit.DB..::..SpatialElementBoundaryOptions
The SpatialElementBoundaryOptions.

Remarks

This method is used to retrieve the segments that constitute the boundary of the spatial element. Each spatial element may have several regions, each of which have several segments hence the data is returned in the form of an array of boundary segment arrays. See the BoundarySegment object for more details about the segments that make up the spatial element topology.

See Also

SpatialElement Class


GetSpatialElementDomainData Method

[image]

Revit 2024 API
SpatialElement..::..GetSpatialElementDomainData Method
SpatialElement Class See Also Send Feedback
Gets the domain data for the spatial element. The domain data contains information of different spatial elements, such as electrical load area. Currently room/space/area don't have domain data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public SpatialElementDomainData GetSpatialElementDomainData()
Visual Basic
Public Function GetSpatialElementDomainData As SpatialElementDomainData
Visual C++
public:
SpatialElementDomainData^ GetSpatialElementDomainData()

Return Value

Returns a pointer to the base class for specific domain requirements for the spatial element.

See Also

SpatialElement Class


SpatialElement Properties

[image] [image]

Revit 2024 API
SpatialElement Properties
SpatialElement Class See Also Send Feedback

The SpatialElement type exposes the following members.

Properties

 | Name | Description
Public property | Area | The area.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | Level | Gets the level of the room.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | The location of the element. (Overrides Element..::..Location.)
Public property | Name | A human readable name for the Element. (Overrides Element..::..Name.)
Public property | Number | The number.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Perimeter | The perimeter.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SpatialElementType | The spatial element type.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SpatialElement Class


Area Property

[image]

Revit 2024 API
SpatialElement..::..Area Property
SpatialElement Class See Also Send Feedback
The area.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double Area { get; }
Visual Basic
Public ReadOnly Property Area As Double
    Get
Visual C++
public:
property double Area {
    double get ();
}

See Also

SpatialElement Class


Level Property

[image]

Revit 2024 API
SpatialElement..::..Level Property
SpatialElement Class See Also Send Feedback
Gets the level of the room.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Level Level { get; }
Visual Basic
Public ReadOnly Property Level As Level
    Get
Visual C++
public:
property Level^ Level {
    Level^ get ();
}

See Also

SpatialElement Class


Location Property

[image]

Revit 2024 API
SpatialElement..::..Location Property
SpatialElement Class See Also Send Feedback
The location of the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public override Location Location { get; }
Visual Basic
Public Overrides ReadOnly Property Location As Location
    Get
Visual C++
public:
virtual property Location^ Location {
    Location^ get () override;
}

Remarks

This is the location of the room within the level. The Z location should be the elevation of the level and not changeable.

See Also

SpatialElement Class


Name Property

[image]

Revit 2024 API
SpatialElement..::..Name Property
SpatialElement Class See Also Send Feedback
A human readable name for the Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public override string Name { set; }
Visual Basic
Public Overrides WriteOnly Property Name As String
    Set
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Remarks

The Name property is a human readable name for the element, such as Wall.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the name of the element cannot be changed.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the element requires a unique name and a non-unique name is set.

See Also

SpatialElement Class


Parameter Property

[image] [image]

Revit 2024 API
SpatialElement..::..Parameter Property
SpatialElement Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

SpatialElement Class
SpatialElement Members


SpatialElementType Property

[image]

Revit 2024 API
SpatialElement..::..SpatialElementType Property
SpatialElement Class See Also Send Feedback
The spatial element type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public SpatialElementType SpatialElementType { get; }
Visual Basic
Public ReadOnly Property SpatialElementType As SpatialElementType
    Get
Visual C++
public:
property SpatialElementType SpatialElementType {
    SpatialElementType get ();
}

See Also

SpatialElement Class


SpatialElementBoundaryLocation Enumeration

[image]

Revit 2024 API
SpatialElementBoundaryLocation Enumeration
See Also Send Feedback
An enumerated type listing boundary options of spatial element geometry calculation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum SpatialElementBoundaryLocation
Visual Basic
Public Enumeration SpatialElementBoundaryLocation
Visual C++
public enum class SpatialElementBoundaryLocation

Members

Member name | Description
Finish | Spatial element finish face.
Center | Spatial element centerline.
CoreBoundary | Spatial element core boundary.
CoreCenter | Spatial element core center.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


SpatialElementBoundaryOptions Constructor

[image]

Revit 2024 API
SpatialElementBoundaryOptions Constructor
SpatialElementBoundaryOptions Class See Also Send Feedback
Constructs default options for calculation of the geometry of spatial elements (rooms, spaces).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public SpatialElementBoundaryOptions()
Visual Basic
Public Sub New
Visual C++
public:
SpatialElementBoundaryOptions()

See Also

SpatialElementBoundaryOptions Class


SpatialElementBoundaryOptions Methods

[image] [image]

Revit 2024 API
SpatialElementBoundaryOptions Methods
SpatialElementBoundaryOptions Class See Also Send Feedback

The SpatialElementBoundaryOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SpatialElementBoundaryOptions Class


Dispose Method

[image]

Revit 2024 API
SpatialElementBoundaryOptions..::..Dispose Method
SpatialElementBoundaryOptions Class See Also Send Feedback
Releases all resources used by the SpatialElementBoundaryOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

SpatialElementBoundaryOptions Class


SpatialElementBoundaryOptions Properties

[image] [image]

Revit 2024 API
SpatialElementBoundaryOptions Properties
SpatialElementBoundaryOptions Class See Also Send Feedback

The SpatialElementBoundaryOptions type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SpatialElementBoundaryLocation | The boundary of spatial element for geometry calculation.
Public property | StoreFreeBoundaryFaces | Indicates whether to include the free boundary faces in the result.

See Also

SpatialElementBoundaryOptions Class


IsValidObject Property

[image]

Revit 2024 API
SpatialElementBoundaryOptions..::..IsValidObject Property
SpatialElementBoundaryOptions Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

SpatialElementBoundaryOptions Class


SpatialElementBoundaryLocation Property

[image]

Revit 2024 API
SpatialElementBoundaryOptions..::..SpatialElementBoundaryLocation Property
SpatialElementBoundaryOptions Class See Also Send Feedback
The boundary of spatial element for geometry calculation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public SpatialElementBoundaryLocation SpatialElementBoundaryLocation { get; set; }
Visual Basic
Public Property SpatialElementBoundaryLocation As SpatialElementBoundaryLocation
    Get
    Set
Visual C++
public:
property SpatialElementBoundaryLocation SpatialElementBoundaryLocation {
    SpatialElementBoundaryLocation get ();
    void set (SpatialElementBoundaryLocation value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

SpatialElementBoundaryOptions Class


StoreFreeBoundaryFaces Property

[image]

Revit 2024 API
SpatialElementBoundaryOptions..::..StoreFreeBoundaryFaces Property
SpatialElementBoundaryOptions Class See Also Send Feedback
Indicates whether to include the free boundary faces in the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public bool StoreFreeBoundaryFaces { get; set; }
Visual Basic
Public Property StoreFreeBoundaryFaces As Boolean
    Get
    Set
Visual C++
public:
property bool StoreFreeBoundaryFaces {
    bool get ();
    void set (bool value);
}

Remarks

A free subface is a portion of a spatial element face that is not (partially) coincident with a face of a bounding element.

See Also

SpatialElementBoundaryOptions Class


SpatialElementBoundarySubface Class

[image]

Revit 2024 API
SpatialElementBoundarySubface Class
Members See Also Send Feedback
SpatialElementBoundarySubface represents the geometry boundary information of spatial element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public class SpatialElementBoundarySubface : IDisposable
Visual Basic
Public Class SpatialElementBoundarySubface _
    Implements IDisposable
Visual C++
public ref class SpatialElementBoundarySubface : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..SpatialElementBoundarySubface

See Also

SpatialElementBoundarySubface Members


SpatialElementBoundarySubface Members

[image] [image]

Revit 2024 API
SpatialElementBoundarySubface Members
SpatialElementBoundarySubface Class Methods Properties See Also Send Feedback

The SpatialElementBoundarySubface type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the SpatialElementBoundarySubface
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBoundingElementFace | Returns the face of the bounding element.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSpatialElementFace | Returns the face of the spatial element's 3D geometry.
Public method | GetSubface | Returns a face that represents the portion of the room face bounded by the boundary element.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SpatialBoundaryElement | Element that gave rise to this room face.
Public property | SubfaceArisesFromElementFace | Indicates if the subface is coincident with a portion of a (possibly offset) face of the element.
Public property | SubfaceType | Type of the subface.
Public property | Valid | Indicates if the subface instance is valid and can be used.

See Also

SpatialElementBoundarySubface Class


SpatialElementBoundarySubface Methods

[image] [image]

Revit 2024 API
SpatialElementBoundarySubface Methods
SpatialElementBoundarySubface Class See Also Send Feedback

The SpatialElementBoundarySubface type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBoundingElementFace | Returns the face of the bounding element.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSpatialElementFace | Returns the face of the spatial element's 3D geometry.
Public method | GetSubface | Returns a face that represents the portion of the room face bounded by the boundary element.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SpatialElementBoundarySubface Class


Dispose Method

[image]

Revit 2024 API
SpatialElementBoundarySubface..::..Dispose Method
SpatialElementBoundarySubface Class See Also Send Feedback
Releases all resources used by the SpatialElementBoundarySubface

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

SpatialElementBoundarySubface Class


GetBoundingElementFace Method

[image]

Revit 2024 API
SpatialElementBoundarySubface..::..GetBoundingElementFace Method
SpatialElementBoundarySubface Class See Also Send Feedback
Returns the face of the bounding element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public Face GetBoundingElementFace()
Visual Basic
Public Function GetBoundingElementFace As Face
Visual C++
public:
Face^ GetBoundingElementFace()

Return Value

The face of the bounding element.

Remarks

Applies only if the options chosen for the extraction of the element's geometry is Finish. Faces do not contain voids in room-bounding elements (such the voids in walls created by doors and windows).

See Also

SpatialElementBoundarySubface Class


GetSpatialElementFace Method

[image]

Revit 2024 API
SpatialElementBoundarySubface..::..GetSpatialElementFace Method
SpatialElementBoundarySubface Class See Also Send Feedback
Returns the face of the spatial element's 3D geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public Face GetSpatialElementFace()
Visual Basic
Public Function GetSpatialElementFace As Face
Visual C++
public:
Face^ GetSpatialElementFace()

Return Value

The face of the spatial element's 3D geometry.

See Also

SpatialElementBoundarySubface Class


GetSubface Method

[image]

Revit 2024 API
SpatialElementBoundarySubface..::..GetSubface Method
SpatialElementBoundarySubface Class See Also Send Feedback
Returns a face that represents the portion of the room face bounded by the boundary element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public Face GetSubface()
Visual Basic
Public Function GetSubface As Face
Visual C++
public:
Face^ GetSubface()

Return Value

The sub-face.

Remarks

If the spatial element's face is adjacent to multiple bounding elements (such as two different walls), there will be one sub-face for each portion of the spatial element's face where it is adjacent to one of those room-bounding elements. This is equivalent to the return of GetRoomFace() if the entire room face is created by the boundary element.

See Also

SpatialElementBoundarySubface Class


SpatialElementBoundarySubface Properties

[image] [image]

Revit 2024 API
SpatialElementBoundarySubface Properties
SpatialElementBoundarySubface Class See Also Send Feedback

The SpatialElementBoundarySubface type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SpatialBoundaryElement | Element that gave rise to this room face.
Public property | SubfaceArisesFromElementFace | Indicates if the subface is coincident with a portion of a (possibly offset) face of the element.
Public property | SubfaceType | Type of the subface.
Public property | Valid | Indicates if the subface instance is valid and can be used.

See Also

SpatialElementBoundarySubface Class


IsValidObject Property

[image]

Revit 2024 API
SpatialElementBoundarySubface..::..IsValidObject Property
SpatialElementBoundarySubface Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

SpatialElementBoundarySubface Class


SpatialBoundaryElement Property

[image]

Revit 2024 API
SpatialElementBoundarySubface..::..SpatialBoundaryElement Property
SpatialElementBoundarySubface Class See Also Send Feedback
Element that gave rise to this room face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public LinkElementId SpatialBoundaryElement { get; }
Visual Basic
Public ReadOnly Property SpatialBoundaryElement As LinkElementId
    Get
Visual C++
public:
property LinkElementId^ SpatialBoundaryElement {
    LinkElementId^ get ();
}

See Also

SpatialElementBoundarySubface Class


Valid Property

[image]

Revit 2024 API
SpatialElementBoundarySubface..::..Valid Property
SpatialElementBoundarySubface Class See Also Send Feedback
Indicates if the subface instance is valid and can be used.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public bool Valid { get; }
Visual Basic
Public ReadOnly Property Valid As Boolean
    Get
Visual C++
public:
property bool Valid {
    bool get ();
}

See Also

SpatialElementBoundarySubface Class


SpatialElementCalculationLocation Members

[image] [image]

Revit 2024 API
SpatialElementCalculationLocation Members
SpatialElementCalculationLocation Class Methods Properties See Also Send Feedback

The SpatialElementCalculationLocation type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MarkerPosition | The position of the spatial element calculation location marker.
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SpatialElementCalculationLocation Class


SpatialElementCalculationLocation Methods

[image] [image]

Revit 2024 API
SpatialElementCalculationLocation Methods
SpatialElementCalculationLocation Class See Also Send Feedback

The SpatialElementCalculationLocation type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SpatialElementCalculationLocation Class


SpatialElementCalculationLocation Properties

[image] [image]

Revit 2024 API
SpatialElementCalculationLocation Properties
SpatialElementCalculationLocation Class See Also Send Feedback

The SpatialElementCalculationLocation type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MarkerPosition | The position of the spatial element calculation location marker.
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SpatialElementCalculationLocation Class


MarkerPosition Property

[image]

Revit 2024 API
SpatialElementCalculationLocation..::..MarkerPosition Property
SpatialElementCalculationLocation Class See Also Send Feedback
The position of the spatial element calculation location marker.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public XYZ MarkerPosition { get; }
Visual Basic
Public ReadOnly Property MarkerPosition As XYZ
    Get
Visual C++
public:
property XYZ^ MarkerPosition {
    XYZ^ get ();
}

See Also

SpatialElementCalculationLocation Class


Parameter Property

[image] [image]

Revit 2024 API
SpatialElementCalculationLocation..::..Parameter Property
SpatialElementCalculationLocation Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

SpatialElementCalculationLocation Class
SpatialElementCalculationLocation Members


SpatialElementCalculationPoint Class

[image]

Revit 2024 API
SpatialElementCalculationPoint Class
Members See Also Send Feedback
SpatialElementCalculationPoint is used as the search point for family instances placement inside rooms and spaces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public class SpatialElementCalculationPoint : SpatialElementCalculationLocation
Visual Basic
Public Class SpatialElementCalculationPoint _
    Inherits SpatialElementCalculationLocation
Visual C++
public ref class SpatialElementCalculationPoint : public SpatialElementCalculationLocation

Remarks

The Spatial Element Calculation Point is graphically showed as a location point marker with a "snake" line from the origin of the family. If the Spatial Element Calculation Point is turned on, this point will be used as a search point for room and space relations for all instances of this family.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..SpatialElementCalculationLocation
Autodesk.Revit.DB..::..SpatialElementCalculationPoint

See Also

SpatialElementCalculationPoint Members


SpatialElementCalculationPoint Methods

[image] [image]

Revit 2024 API
SpatialElementCalculationPoint Methods
SpatialElementCalculationPoint Class See Also Send Feedback

The SpatialElementCalculationPoint type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SpatialElementCalculationPoint Class


SpatialElementCalculationPoint Properties

[image] [image]

Revit 2024 API
SpatialElementCalculationPoint Properties
SpatialElementCalculationPoint Class See Also Send Feedback

The SpatialElementCalculationPoint type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MarkerPosition | The position of the spatial element calculation location marker. (Inherited from SpatialElementCalculationLocation.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Position | The position of the "in" spatial element calculation point.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SpatialElementCalculationPoint Class


Parameter Property

[image] [image]

Revit 2024 API
SpatialElementCalculationPoint..::..Parameter Property
SpatialElementCalculationPoint Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

SpatialElementCalculationPoint Class
SpatialElementCalculationPoint Members


Position Property

[image]

Revit 2024 API
SpatialElementCalculationPoint..::..Position Property
SpatialElementCalculationPoint Class See Also Send Feedback
The position of the "in" spatial element calculation point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public XYZ Position { get; set; }
Visual Basic
Public Property Position As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ Position {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

This is the search point where a family instance will be considered to be located inside a room/space.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

SpatialElementCalculationPoint Class


SpatialElementDomainData Members

[image] [image]

Revit 2024 API
SpatialElementDomainData Members
SpatialElementDomainData Class Methods Properties See Also Send Feedback

The SpatialElementDomainData type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the SpatialElementDomainData
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

SpatialElementDomainData Class


SpatialElementDomainData Methods

[image] [image]

Revit 2024 API
SpatialElementDomainData Methods
SpatialElementDomainData Class See Also Send Feedback

The SpatialElementDomainData type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SpatialElementDomainData Class


Dispose Method

[image]

Revit 2024 API
SpatialElementDomainData..::..Dispose Method
SpatialElementDomainData Class See Also Send Feedback
Releases all resources used by the SpatialElementDomainData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

SpatialElementDomainData Class


SpatialElementDomainData Properties

[image] [image]

Revit 2024 API
SpatialElementDomainData Properties
SpatialElementDomainData Class See Also Send Feedback

The SpatialElementDomainData type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

SpatialElementDomainData Class


IsValidObject Property

[image]

Revit 2024 API
SpatialElementDomainData..::..IsValidObject Property
SpatialElementDomainData Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

SpatialElementDomainData Class


SpatialElementFromToCalculationPoints Class

[image]

Revit 2024 API
SpatialElementFromToCalculationPoints Class
Members See Also Send Feedback
SpatialElementFromToCalculationPoints is used to specify the search points for a family instance which connects two rooms or spaces, such as a door or window. The points determine which room or space is considered the "from" and which is considered the "to".

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class SpatialElementFromToCalculationPoints : SpatialElementCalculationLocation
Visual Basic
Public Class SpatialElementFromToCalculationPoints _
    Inherits SpatialElementCalculationLocation
Visual C++
public ref class SpatialElementFromToCalculationPoints : public SpatialElementCalculationLocation

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..SpatialElementCalculationLocation
Autodesk.Revit.DB..::..SpatialElementFromToCalculationPoints

See Also

SpatialElementFromToCalculationPoints Members


SpatialElementFromToCalculationPoints Members

[image] [image]

Revit 2024 API
SpatialElementFromToCalculationPoints Members
SpatialElementFromToCalculationPoints Class Methods Properties See Also Send Feedback

The SpatialElementFromToCalculationPoints type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | Flip | flip the direction of the "from" and "to" points
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsAcceptableFromPosition | Checks whether a given "from" position is valid.
Public method | IsAcceptableToPosition | Checks whether a given "to" position is valid.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | MakeFromPositionAcceptable | This function takes a potential "from" point and converts it to be a similar point on the opposite side of the family's host from the "to" point if necessary.
Public method | MakeToPositionAcceptable | This function takes a potential "to" point and converts it to be a similar point on the opposite side of the family's host from the "from" point if necessary.
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FromPosition | The "from" position of spatial element connecting calculation point.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MarkerPosition | The position of the spatial element calculation location marker. (Inherited from SpatialElementCalculationLocation.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ToPosition | The "to" position of spatial element connecting calculation point.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SpatialElementFromToCalculationPoints Class


SpatialElementFromToCalculationPoints Methods

[image] [image]

Revit 2024 API
SpatialElementFromToCalculationPoints Methods
SpatialElementFromToCalculationPoints Class See Also Send Feedback

The SpatialElementFromToCalculationPoints type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | Flip | flip the direction of the "from" and "to" points
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsAcceptableFromPosition | Checks whether a given "from" position is valid.
Public method | IsAcceptableToPosition | Checks whether a given "to" position is valid.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | MakeFromPositionAcceptable | This function takes a potential "from" point and converts it to be a similar point on the opposite side of the family's host from the "to" point if necessary.
Public method | MakeToPositionAcceptable | This function takes a potential "to" point and converts it to be a similar point on the opposite side of the family's host from the "from" point if necessary.
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SpatialElementFromToCalculationPoints Class


Flip Method

[image]

Revit 2024 API
SpatialElementFromToCalculationPoints..::..Flip Method
SpatialElementFromToCalculationPoints Class See Also Send Feedback
flip the direction of the "from" and "to" points

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void Flip()
Visual Basic
Public Sub Flip
Visual C++
public:
void Flip()

See Also

SpatialElementFromToCalculationPoints Class


IsAcceptableFromPosition Method

[image]

Revit 2024 API
SpatialElementFromToCalculationPoints..::..IsAcceptableFromPosition Method
SpatialElementFromToCalculationPoints Class See Also Send Feedback
Checks whether a given "from" position is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsAcceptableFromPosition(
    XYZ fromPosition
)
Visual Basic
Public Function IsAcceptableFromPosition ( _
    fromPosition As XYZ _
) As Boolean
Visual C++
public:
bool IsAcceptableFromPosition(
    XYZ^ fromPosition
)

Parameters

fromPosition
Type: Autodesk.Revit.DB..::..XYZ

Return Value

True if the input is an acceptable "from" position and False otherwise.

Remarks

The "from" position and the "to" position must be on opposite sides of the family's host. Flipping the calculation point will reverse the direction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

SpatialElementFromToCalculationPoints Class


IsAcceptableToPosition Method

[image]

Revit 2024 API
SpatialElementFromToCalculationPoints..::..IsAcceptableToPosition Method
SpatialElementFromToCalculationPoints Class See Also Send Feedback
Checks whether a given "to" position is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsAcceptableToPosition(
    XYZ toPosition
)
Visual Basic
Public Function IsAcceptableToPosition ( _
    toPosition As XYZ _
) As Boolean
Visual C++
public:
bool IsAcceptableToPosition(
    XYZ^ toPosition
)

Parameters

toPosition
Type: Autodesk.Revit.DB..::..XYZ

Return Value

True if the input is an acceptable "to" position and False otherwise.

Remarks

The "from" position and the "to" position must be on opposite sides of the family's host. Flipping the calculation point will reverse the direction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

SpatialElementFromToCalculationPoints Class


MakeFromPositionAcceptable Method

[image]

Revit 2024 API
SpatialElementFromToCalculationPoints..::..MakeFromPositionAcceptable Method
SpatialElementFromToCalculationPoints Class See Also Send Feedback
This function takes a potential "from" point and converts it to be a similar point on the opposite side of the family's host from the "to" point if necessary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public XYZ MakeFromPositionAcceptable(
    XYZ newFromLocation
)
Visual Basic
Public Function MakeFromPositionAcceptable ( _
    newFromLocation As XYZ _
) As XYZ
Visual C++
public:
XYZ^ MakeFromPositionAcceptable(
    XYZ^ newFromLocation
)

Parameters

newFromLocation
Type: Autodesk.Revit.DB..::..XYZ
The desired "from" location

Return Value

The valid "from" location.

Remarks

If the point is already an acceptable "from" location then the original point will be returned. Otherwise, the point's X and Y will be projected onto the centerline of the family's host.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

SpatialElementFromToCalculationPoints Class


MakeToPositionAcceptable Method

[image]

Revit 2024 API
SpatialElementFromToCalculationPoints..::..MakeToPositionAcceptable Method
SpatialElementFromToCalculationPoints Class See Also Send Feedback
This function takes a potential "to" point and converts it to be a similar point on the opposite side of the family's host from the "from" point if necessary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public XYZ MakeToPositionAcceptable(
    XYZ newToLocation
)
Visual Basic
Public Function MakeToPositionAcceptable ( _
    newToLocation As XYZ _
) As XYZ
Visual C++
public:
XYZ^ MakeToPositionAcceptable(
    XYZ^ newToLocation
)

Parameters

newToLocation
Type: Autodesk.Revit.DB..::..XYZ
The desired "to" location

Return Value

The valid "to" location.

Remarks

If the point is already an acceptable "to" location then the original point will be returned. Otherwise, the point's X and Y will be projected onto the centerline of the family's host.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

SpatialElementFromToCalculationPoints Class


SpatialElementFromToCalculationPoints Properties

[image] [image]

Revit 2024 API
SpatialElementFromToCalculationPoints Properties
SpatialElementFromToCalculationPoints Class See Also Send Feedback

The SpatialElementFromToCalculationPoints type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FromPosition | The "from" position of spatial element connecting calculation point.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MarkerPosition | The position of the spatial element calculation location marker. (Inherited from SpatialElementCalculationLocation.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ToPosition | The "to" position of spatial element connecting calculation point.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SpatialElementFromToCalculationPoints Class


FromPosition Property

[image]

Revit 2024 API
SpatialElementFromToCalculationPoints..::..FromPosition Property
SpatialElementFromToCalculationPoints Class See Also Send Feedback
The "from" position of spatial element connecting calculation point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public XYZ FromPosition { get; set; }
Visual Basic
Public Property FromPosition As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ FromPosition {
    XYZ^ get ();
    void set (XYZ^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: fromPosition must be on the opposite side of the family's host from the "to" position.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

SpatialElementFromToCalculationPoints Class


Parameter Property

[image] [image]

Revit 2024 API
SpatialElementFromToCalculationPoints..::..Parameter Property
SpatialElementFromToCalculationPoints Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

SpatialElementFromToCalculationPoints Class
SpatialElementFromToCalculationPoints Members


ToPosition Property

[image]

Revit 2024 API
SpatialElementFromToCalculationPoints..::..ToPosition Property
SpatialElementFromToCalculationPoints Class See Also Send Feedback
The "to" position of spatial element connecting calculation point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public XYZ ToPosition { get; set; }
Visual Basic
Public Property ToPosition As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ ToPosition {
    XYZ^ get ();
    void set (XYZ^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: toPosition must be on the opposite side of the family's host from the "from" position.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

SpatialElementFromToCalculationPoints Class


SpatialElementGeometryCalculator Class

[image]

Revit 2024 API
SpatialElementGeometryCalculator Class
Members Example See Also Send Feedback
Use this class to calculate the geometry of a spatial element and obtain the relationships between the geometry and the element's boundary elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public class SpatialElementGeometryCalculator : IDisposable
Visual Basic
Public Class SpatialElementGeometryCalculator _
    Implements IDisposable
Visual C++
public ref class SpatialElementGeometryCalculator : IDisposable

Remarks

This class maintains an internal cache for geometry it has already processed. If you intend to calculate geometry for several elements in the same project you should use a single instance of this class. Note that the cache will be cleared when any change is made to the document.

Examples

CopyC#
// Calculate a room's geometry and find its boundary faces
SpatialElementGeometryCalculator calculator = new SpatialElementGeometryCalculator(doc);
SpatialElementGeometryResults results = calculator.CalculateSpatialElementGeometry(room); // compute the room geometry
Solid roomSolid = results.GetGeometry(); // get the solid representing the room's geometry
foreach (Face face in roomSolid.Faces)
{
    double faceArea = face.Area;
    IList<SpatialElementBoundarySubface> subfaceList = results.GetBoundaryFaceInfo(face); // get the sub-faces for the face of the room
    foreach (SpatialElementBoundarySubface subface in subfaceList)
    {
        if (subfaceList.Count > 1) // there are multiple sub-faces that define the face
        {
            double subfaceArea = subface.GetSubface().Area; // get the area of each sub-face
            // sub-faces exist in situations such as when a room-bounding wall has been
            // horizontally split and the faces of each split wall combine to create the
            // entire face of the room
        }
    }
}
CopyVB.NET
' Calculate a room's geometry and find its boundary faces
Dim calculator As New SpatialElementGeometryCalculator(doc)
Dim results As SpatialElementGeometryResults = calculator.CalculateSpatialElementGeometry(room)
' compute the room geometry
Dim roomSolid As Solid = results.GetGeometry()
' get the solid representing the room's geometry
For Each face As Face In roomSolid.Faces
    Dim faceArea As Double = face.Area
    Dim subfaceList As IList(Of SpatialElementBoundarySubface) = results.GetBoundaryFaceInfo(face)
    ' get the sub-faces for the face of the room
    For Each subface As SpatialElementBoundarySubface In subfaceList
        If subfaceList.Count > 1 Then
            ' there are multiple sub-faces that define the face
            ' get the area of each sub-face
            ' sub-faces exist in situations such as when a room-bounding wall has been
            ' horizontally split and the faces of each split wall combine to create the
            ' entire face of the room
            Dim subfaceArea As Double = subface.GetSubface().Area
        End If
    Next
Next

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..SpatialElementGeometryCalculator

See Also

SpatialElementGeometryCalculator Members


SpatialElementGeometryCalculator Members

[image] [image]

Revit 2024 API
SpatialElementGeometryCalculator Members
SpatialElementGeometryCalculator Class Constructors Methods Properties See Also Send Feedback

The SpatialElementGeometryCalculator type exposes the following members.

Constructors

 | Name | Description
Public method | SpatialElementGeometryCalculator(Document) | Constructs a new calculator with default options for the geometry of spatial elements.
Public method | SpatialElementGeometryCalculator(Document, SpatialElementBoundaryOptions) | Constructs a new calculator for the geometry of spatial elements.

Methods

 | Name | Description
Public method | CalculateSpatialElementGeometry | Compute the spatial element geometry and returns the boundary face information.
 | CanCalculateGeometry | This indicates whether the input spatial element is a valid one.
Public method | Dispose | Releases all resources used by the SpatialElementGeometryCalculator
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOptions | The options that control the calculation.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsRoomOrSpace | This indicates whether the input spatial element is a room or a space.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

SpatialElementGeometryCalculator Class


SpatialElementGeometryCalculator Constructor

[image] [image]

Revit 2024 API
SpatialElementGeometryCalculator Constructor
SpatialElementGeometryCalculator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SpatialElementGeometryCalculator(Document) | Constructs a new calculator with default options for the geometry of spatial elements.
Public method | SpatialElementGeometryCalculator(Document, SpatialElementBoundaryOptions) | Constructs a new calculator for the geometry of spatial elements.

See Also

SpatialElementGeometryCalculator Class
SpatialElementGeometryCalculator Members


SpatialElementGeometryCalculator Methods

[image] [image]

Revit 2024 API
SpatialElementGeometryCalculator Methods
SpatialElementGeometryCalculator Class See Also Send Feedback

The SpatialElementGeometryCalculator type exposes the following members.

Methods

 | Name | Description
Public method | CalculateSpatialElementGeometry | Compute the spatial element geometry and returns the boundary face information.
 | CanCalculateGeometry | This indicates whether the input spatial element is a valid one.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOptions | The options that control the calculation.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsRoomOrSpace | This indicates whether the input spatial element is a room or a space.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SpatialElementGeometryCalculator Class


CalculateSpatialElementGeometry Method

[image]

Revit 2024 API
SpatialElementGeometryCalculator..::..CalculateSpatialElementGeometry Method
SpatialElementGeometryCalculator Class See Also Send Feedback
Compute the spatial element geometry and returns the boundary face information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public SpatialElementGeometryResults CalculateSpatialElementGeometry(
    SpatialElement spatialElement
)
Visual Basic
Public Function CalculateSpatialElementGeometry ( _
    spatialElement As SpatialElement _
) As SpatialElementGeometryResults
Visual C++
public:
SpatialElementGeometryResults^ CalculateSpatialElementGeometry(
    SpatialElement^ spatialElement
)

Parameters

spatialElement
Type: Autodesk.Revit.DB..::..SpatialElement
Specifies the spatial element needs to be computed, should be Room or Space.

Return Value

Requested boundary face information.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | spatialElement is not a room or a space, and thus has no 3D geometry to calculate. -or- spatialElement is not enclosed in 2d or has no location, or the height is too small, and thus has no 3D geometry to calculate.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | Failed to compute the given spatial element's geometry.

See Also

SpatialElementGeometryCalculator Class


CanCalculateGeometry Method

[image]

Revit 2024 API
SpatialElementGeometryCalculator..::..CanCalculateGeometry Method
SpatialElementGeometryCalculator Class See Also Send Feedback
This indicates whether the input spatial element is a valid one.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static bool CanCalculateGeometry(
    SpatialElement spatialElement
)
Visual Basic
Public Shared Function CanCalculateGeometry ( _
    spatialElement As SpatialElement _
) As Boolean
Visual C++
public:
static bool CanCalculateGeometry(
    SpatialElement^ spatialElement
)

Parameters

spatialElement
Type: Autodesk.Revit.DB..::..SpatialElement
The spatial element to be checked if its geometry can be calculated.

Return Value

It will return false if the room/space is not enclosed in 2d or has no location, or the height is too small.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

SpatialElementGeometryCalculator Class


GetOptions Method

[image]

Revit 2024 API
SpatialElementGeometryCalculator..::..GetOptions Method
SpatialElementGeometryCalculator Class See Also Send Feedback
The options that control the calculation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public SpatialElementBoundaryOptions GetOptions()
Visual Basic
Public Function GetOptions As SpatialElementBoundaryOptions
Visual C++
public:
SpatialElementBoundaryOptions^ GetOptions()

Return Value

The options.

See Also

SpatialElementGeometryCalculator Class


IsRoomOrSpace Method

[image]

Revit 2024 API
SpatialElementGeometryCalculator..::..IsRoomOrSpace Method
SpatialElementGeometryCalculator Class See Also Send Feedback
This indicates whether the input spatial element is a room or a space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static bool IsRoomOrSpace(
    SpatialElement spatialElement
)
Visual Basic
Public Shared Function IsRoomOrSpace ( _
    spatialElement As SpatialElement _
) As Boolean
Visual C++
public:
static bool IsRoomOrSpace(
    SpatialElement^ spatialElement
)

Parameters

spatialElement
Type: Autodesk.Revit.DB..::..SpatialElement
The spatial element to be checked if it is a room or a space or not.

Return Value

True if the input spatial element is a room or a space, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

SpatialElementGeometryCalculator Class


SpatialElementGeometryCalculator Properties

[image] [image]

Revit 2024 API
SpatialElementGeometryCalculator Properties
SpatialElementGeometryCalculator Class See Also Send Feedback

The SpatialElementGeometryCalculator type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

SpatialElementGeometryCalculator Class


IsValidObject Property

[image]

Revit 2024 API
SpatialElementGeometryCalculator..::..IsValidObject Property
SpatialElementGeometryCalculator Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

SpatialElementGeometryCalculator Class


SpatialElementGeometryResults Class

[image]

Revit 2024 API
SpatialElementGeometryResults Class
Members See Also Send Feedback
The results of spatial element geometry calculation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public class SpatialElementGeometryResults : IDisposable
Visual Basic
Public Class SpatialElementGeometryResults _
    Implements IDisposable
Visual C++
public ref class SpatialElementGeometryResults : IDisposable

Remarks

The subfaces of a SpatialElement at the base height and top height are not associated with floors, roofs, and ceilings at the same height.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..SpatialElementGeometryResults

See Also

SpatialElementGeometryResults Members


SpatialElementGeometryResults Members

[image] [image]

Revit 2024 API
SpatialElementGeometryResults Members
SpatialElementGeometryResults Class Methods Properties See Also Send Feedback

The SpatialElementGeometryResults type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the SpatialElementGeometryResults
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBoundaryFaceInfo | Query the spatial element boundary face information with the given face.
Public method | GetGeometry | The solid from the spatial element.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

SpatialElementGeometryResults Class


SpatialElementGeometryResults Methods

[image] [image]

Revit 2024 API
SpatialElementGeometryResults Methods
SpatialElementGeometryResults Class See Also Send Feedback

The SpatialElementGeometryResults type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBoundaryFaceInfo | Query the spatial element boundary face information with the given face.
Public method | GetGeometry | The solid from the spatial element.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SpatialElementGeometryResults Class


Dispose Method

[image]

Revit 2024 API
SpatialElementGeometryResults..::..Dispose Method
SpatialElementGeometryResults Class See Also Send Feedback
Releases all resources used by the SpatialElementGeometryResults

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

SpatialElementGeometryResults Class


GetBoundaryFaceInfo Method

[image]

Revit 2024 API
SpatialElementGeometryResults..::..GetBoundaryFaceInfo Method
SpatialElementGeometryResults Class See Also Send Feedback
Query the spatial element boundary face information with the given face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public IList<SpatialElementBoundarySubface> GetBoundaryFaceInfo(
    Face face
)
Visual Basic
Public Function GetBoundaryFaceInfo ( _
    face As Face _
) As IList(Of SpatialElementBoundarySubface)
Visual C++
public:
IList<SpatialElementBoundarySubface^>^ GetBoundaryFaceInfo(
    Face^ face
)

Parameters

face
Type: Autodesk.Revit.DB..::..Face
The face from the spatial element's geometry.

Return Value

Sub-faces related to the room bounding elements that define the spatial element face. Returns nullNothingnullptra null reference (Nothing in Visual Basic) if there is no corresponding boundary information with the given face.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

SpatialElementGeometryResults Class


GetGeometry Method

[image]

Revit 2024 API
SpatialElementGeometryResults..::..GetGeometry Method
SpatialElementGeometryResults Class See Also Send Feedback
The solid from the spatial element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public Solid GetGeometry()
Visual Basic
Public Function GetGeometry As Solid
Visual C++
public:
Solid^ GetGeometry()

Return Value

Requested solid.

See Also

SpatialElementGeometryResults Class


SpatialElementGeometryResults Properties

[image] [image]

Revit 2024 API
SpatialElementGeometryResults Properties
SpatialElementGeometryResults Class See Also Send Feedback

The SpatialElementGeometryResults type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

SpatialElementGeometryResults Class


SpatialElementTag Class

[image]

Revit 2024 API
SpatialElementTag Class
Members See Also Send Feedback
A tag attached to a SpatialElement (room, space or area) in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class SpatialElementTag : Element
Visual Basic
Public Class SpatialElementTag _
    Inherits Element
Visual C++
public ref class SpatialElementTag : public Element

Remarks

SpatialElementTag is the base class for RoomTag, SpaceTag and AreaTag. Zone tag is not derived from SpatialElementTag. See IndependentTag for more information.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..SpatialElementTag
Autodesk.Revit.DB.Architecture..::..RoomTag
Autodesk.Revit.DB..::..AreaTag
Autodesk.Revit.DB.Mechanical..::..SpaceTag

See Also

SpatialElementTag Members


SpatialElementTag Members

[image] [image]

Revit 2024 API
SpatialElementTag Members
SpatialElementTag Class Methods Properties See Also Send Feedback

The SpatialElementTag type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | HasElbow | Identifies if the tag's leader has an elbow point or not.
Public property | HasLeader | Identifies if a leader is displayed for the tag or not.
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsOrphaned | Identifies if the tag is orphaned or not.
Public property | IsTaggingLink | Identifies if the tag has reference to a spatial element in a linked document or not.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LeaderElbow | The position of the leader's elbow (middle point).
Public property | LeaderEnd | The position of the leader's end.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | The location of the tag. (Overrides Element..::..Location.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RotationAngle | The rotation angle of the tag relative to its view
Public property | TagHeadPosition | The position of the tag's head.
Public property | TagOrientation | The orientation of the tag.
Public property | TagText | The text displayed by the tag.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | View | The view in which the tag was placed.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SpatialElementTag Class


HasElbow Property

[image]

Revit 2024 API
SpatialElementTag..::..HasElbow Property
SpatialElementTag Class See Also Send Feedback
Identifies if the tag's leader has an elbow point or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool HasElbow { get; }
Visual Basic
Public ReadOnly Property HasElbow As Boolean
    Get
Visual C++
public:
property bool HasElbow {
    bool get ();
}

Remarks

Straight leaders do not have elbow points. Use LeaderElbow to get or set elbow point.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | There is no leader for this tag.

See Also

SpatialElementTag Class


HasLeader Property

[image]

Revit 2024 API
SpatialElementTag..::..HasLeader Property
SpatialElementTag Class See Also Send Feedback
Identifies if a leader is displayed for the tag or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool HasLeader { get; set; }
Visual Basic
Public Property HasLeader As Boolean
    Get
    Set
Visual C++
public:
property bool HasLeader {
    bool get ();
    void set (bool value);
}

Field Value

True if a leader is displayed, otherwise false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: SpatialElementTag is orphaned. -or- When setting this property: Thrown when attempting to turn off leader of the pinned tag when the tag's head position is located outside off the host element.

See Also

SpatialElementTag Class


IsTaggingLink Property

[image]

Revit 2024 API
SpatialElementTag..::..IsTaggingLink Property
SpatialElementTag Class See Also Send Feedback
Identifies if the tag has reference to a spatial element in a linked document or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public bool IsTaggingLink { get; }
Visual Basic
Public ReadOnly Property IsTaggingLink As Boolean
    Get
Visual C++
public:
property bool IsTaggingLink {
    bool get ();
}

See Also

SpatialElementTag Class


LeaderElbow Property

[image]

Revit 2024 API
SpatialElementTag..::..LeaderElbow Property
SpatialElementTag Class See Also Send Feedback
The position of the leader's elbow (middle point).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public XYZ LeaderElbow { get; set; }
Visual Basic
Public Property LeaderElbow As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ LeaderElbow {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

Returns the elbow point of the tag leader.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | There is no leader for this tag. -or- When setting this property: SpatialElementTag is pinned. -or- When setting this property: SpatialElementTag is orphaned.

See Also

SpatialElementTag Class


LeaderEnd Property

[image]

Revit 2024 API
SpatialElementTag..::..LeaderEnd Property
SpatialElementTag Class See Also Send Feedback
The position of the leader's end.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public XYZ LeaderEnd { get; set; }
Visual Basic
Public Property LeaderEnd As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ LeaderEnd {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

Returns the end point of the tag leader. Leader end point must be located inside of a room, space or an area. Use Room.IsPointInRoom or Space.IsPointInSpace method to check whether the leaderEnd is located in the host element or not.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The point is located outside of the spatial element.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | There is no leader for this tag. -or- When setting this property: SpatialElementTag is pinned. -or- When setting this property: SpatialElementTag is orphaned.

See Also

SpatialElementTag Class


Location Property

[image]

Revit 2024 API
SpatialElementTag..::..Location Property
SpatialElementTag Class See Also Send Feedback
The location of the tag.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public override Location Location { get; }
Visual Basic
Public Overrides ReadOnly Property Location As Location
    Get
Visual C++
public:
virtual property Location^ Location {
    Location^ get () override;
}

Remarks

Allows you to get and set the location of the tag within the level. The Z location should be the elevation of the level and is not changeable.

See Also

SpatialElementTag Class


Parameter Property

[image] [image]

Revit 2024 API
SpatialElementTag..::..Parameter Property
SpatialElementTag Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

SpatialElementTag Class
SpatialElementTag Members


RotationAngle Property

[image]

Revit 2024 API
SpatialElementTag..::..RotationAngle Property
SpatialElementTag Class See Also Send Feedback
The rotation angle of the tag relative to its view

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public double RotationAngle { get; set; }
Visual Basic
Public Property RotationAngle As Double
    Get
    Set
Visual C++
public:
property double RotationAngle {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: Angle can only be changed for Model orientation

See Also

SpatialElementTag Class


TagHeadPosition Property

[image]

Revit 2024 API
SpatialElementTag..::..TagHeadPosition Property
SpatialElementTag Class See Also Send Feedback
The position of the tag's head.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public XYZ TagHeadPosition { get; set; }
Visual Basic
Public Property TagHeadPosition As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ TagHeadPosition {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

Returns the end point of the tag leader. Leader end point must be located inside of a room, space or an area. Use Room.IsPointInRoom or Space.IsPointInSpace method to check whether the leaderEnd is located in the host element or not.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: Head position of the tag with no leader could not be located outside of the host element.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: SpatialElementTag is pinned. -or- When setting this property: SpatialElementTag is orphaned.

See Also

SpatialElementTag Class


TagOrientation Property

[image]

Revit 2024 API
SpatialElementTag..::..TagOrientation Property
SpatialElementTag Class See Also Send Feedback
The orientation of the tag.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public SpatialElementTagOrientation TagOrientation { get; set; }
Visual Basic
Public Property TagOrientation As SpatialElementTagOrientation
    Get
    Set
Visual C++
public:
property SpatialElementTagOrientation TagOrientation {
    SpatialElementTagOrientation get ();
    void set (SpatialElementTagOrientation value);
}

Remarks

See [!:Autodesk::Revit::DB::getSpatialElementTagOrientation] for the supported orientations.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

SpatialElementTag Class


TagText Property

[image]

Revit 2024 API
SpatialElementTag..::..TagText Property
SpatialElementTag Class See Also Send Feedback
The text displayed by the tag.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public string TagText { get; }
Visual Basic
Public ReadOnly Property TagText As String
    Get
Visual C++
public:
property String^ TagText {
    String^ get ();
}

Remarks

If there are several strings included in the tag, the strings will be returned concatenated.

See Also

SpatialElementTag Class


View Property

[image]

Revit 2024 API
SpatialElementTag..::..View Property
SpatialElementTag Class See Also Send Feedback
The view in which the tag was placed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public View View { get; }
Visual Basic
Public ReadOnly Property View As View
    Get
Visual C++
public:
property View^ View {
    View^ get ();
}

See Also

SpatialElementTag Class


SpatialElementTagOrientation Enumeration

[image]

Revit 2024 API
SpatialElementTagOrientation Enumeration
See Also Send Feedback
An enumerated type listing tag orientation options that are supported by SpatialElementTags.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum SpatialElementTagOrientation
Visual Basic
Public Enumeration SpatialElementTagOrientation
Visual C++
public enum class SpatialElementTagOrientation

Members

Member name | Description
Horizontal | The Orientation of tag is Horizontal.
Vertical | The Orientation of tag is Vertical.
Model | The Orientation of tag is Model.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


SpatialElementType Enumeration

[image]

Revit 2024 API
SpatialElementType Enumeration
See Also Send Feedback
An enumerated type listing types of spaces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public enum SpatialElementType
Visual Basic
Public Enumeration SpatialElementType
Visual C++
public enum class SpatialElementType

Members

Member name | Description
Room | Room
Area | Area
Space | Space
ElectricalLoadArea | Electrical Load Area

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


SpecialType Enumeration

[image]

Revit 2024 API
SpecialType Enumeration
See Also Send Feedback
An enumerated type listing special types that can appear in an ExportLayerTable. These types do not represent an independent category in Revit, but can be mapped to specific layers on export.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014
Since: 2014

Syntax

C#
public enum SpecialType
Visual Basic
Public Enumeration SpecialType
Visual C++
public enum class SpecialType

Members

Member name | Description
Default | The default value for most Revit categories and subcategories.
InteriorWall | The special type representing interior walls.
ExteriorWall | The special type representing exterior walls.
FoundationWall | The special type representing foundation walls.
RetainingWall | The special type representing retaining walls.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


SpecTypeId Class

[image]

Revit 2024 API
SpecTypeId Class
Members See Also Send Feedback
This class contains constants identifying specs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static class SpecTypeId
Visual Basic
Public NotInheritable Class SpecTypeId
Visual C++
public ref class SpecTypeId abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..SpecTypeId

See Also

SpecTypeId Members


SpecTypeId Members

[image] [image]

Revit 2024 API
SpecTypeId Members
SpecTypeId Class Properties See Also Send Feedback

The SpecTypeId type exposes the following members.

Properties

Name | Description
Acceleration | Acceleration, in discipline Structural.
AirFlow | Air Flow, in discipline HVAC.
AirFlowDensity | Air Flow Density, in discipline HVAC.
AirFlowDividedByCoolingLoad | Air Flow divided by Cooling Load, in discipline HVAC.
AirFlowDividedByVolume | Air Flow divided by Volume, in discipline HVAC.
Angle | Angle, in discipline Common.
AngularSpeed | Angular Speed, in discipline HVAC.
ApparentPower | Apparent Power, in discipline Electrical.
ApparentPowerDensity | Apparent Power Density, in discipline Electrical.
Area | Area, in discipline Common.
AreaDividedByCoolingLoad | Area divided by Cooling Load, in discipline HVAC.
AreaDividedByHeatingLoad | Area divided by Heating Load, in discipline HVAC.
AreaForce | Area Force, in discipline Structural.
AreaForceScale | Area Force Scale, in discipline Structural.
AreaSpringCoefficient | Area Spring Coefficient, in discipline Structural.
BarDiameter | Bar Diameter, in discipline Structural.
CableTraySize | Cable Tray Size, in discipline Electrical.
ColorTemperature | Color Temperature, in discipline Electrical.
ConduitSize | Conduit Size, in discipline Electrical.
CoolingLoad | Cooling Load, in discipline HVAC.
CoolingLoadDividedByArea | Cooling Load divided by Area, in discipline HVAC.
CoolingLoadDividedByVolume | Cooling Load divided by Volume, in discipline HVAC.
CostPerArea | Cost per Area, in discipline Common.
CostRateEnergy | Cost Rate Energy, in discipline Electrical.
CostRatePower | Cost Rate Power, in discipline Electrical.
CrackWidth | Crack Width, in discipline Structural.
CrossSection | Cross Section, in discipline HVAC.
Currency | Currency, in discipline Common.
Current | Current, in discipline Electrical.
Custom | Unrecognized custom spec.
DecimalSheetLength | Decimal Sheet Length, in discipline Common.
DemandFactor | Demand Factor, in discipline Electrical.
Diffusivity | Diffusivity, in discipline HVAC.
Displacement | Displacement/Deflection, in discipline Structural.
Distance | Distance, in discipline Common.
DuctInsulationThickness | Duct Insulation Thickness, in discipline HVAC.
DuctLiningThickness | Duct Lining Thickness, in discipline HVAC.
DuctSize | Duct Size, in discipline HVAC.
Efficacy | Efficacy, in discipline Electrical.
ElectricalFrequency | Frequency, in discipline Electrical.
ElectricalPotential | Electrical Potential, in discipline Electrical.
ElectricalPower | Power, in discipline Electrical.
ElectricalPowerDensity | Power Density, in discipline Electrical.
ElectricalResistivity | Electrical Resistivity, in discipline Electrical.
ElectricalTemperature | Temperature, in discipline Electrical.
ElectricalTemperatureDifference | Temperature Difference, in discipline Electrical.
Energy | Energy, in discipline Structural.
Factor | Factor, in discipline HVAC.
Flow | Flow, in discipline Piping.
FlowPerPower | Flow per Power, in discipline HVAC.
Force | Force, in discipline Structural.
ForceScale | Force Scale, in discipline Structural.
HeatCapacityPerArea | Heat Capacity per Area, in discipline Energy.
HeatGain | Heat Gain, in discipline HVAC.
HeatingLoad | Heating Load, in discipline HVAC.
HeatingLoadDividedByArea | Heating Load divided by Area, in discipline HVAC.
HeatingLoadDividedByVolume | Heating Load divided by Volume, in discipline HVAC.
HeatTransferCoefficient | Coefficient of Heat Transfer, in discipline Energy.
HvacDensity | Density, in discipline HVAC.
HvacEnergy | Energy, in discipline Energy.
HvacFriction | Friction, in discipline HVAC.
HvacMassPerTime | Mass per Time, in discipline HVAC.
HvacPower | Power, in discipline HVAC.
HvacPowerDensity | Power Density, in discipline HVAC.
HvacPressure | Pressure, in discipline HVAC.
HvacRoughness | Roughness, in discipline HVAC.
HvacSlope | Slope, in discipline HVAC.
HvacTemperature | Temperature, in discipline HVAC.
HvacTemperatureDifference | Temperature Difference, in discipline HVAC.
HvacVelocity | Velocity, in discipline HVAC.
HvacViscosity | Dynamic Viscosity, in discipline HVAC.
Illuminance | Illuminance, in discipline Electrical.
IsothermalMoistureCapacity | Isothermal Moisture Capacity, in discipline Energy.
Length | Length, in discipline Common.
LinearForce | Linear Force, in discipline Structural.
LinearForceScale | Linear Force Scale, in discipline Structural.
LinearMoment | Linear Moment, in discipline Structural.
LinearMomentScale | Linear Moment Scale, in discipline Structural.
LineSpringCoefficient | Line Spring Coefficient, in discipline Structural.
Luminance | Luminance, in discipline Electrical.
LuminousFlux | Luminous Flux, in discipline Electrical.
LuminousIntensity | Luminous Intensity, in discipline Electrical.
Mass | Mass, in discipline Structural.
MassDensity | Mass Density, in discipline Common.
MassPerUnitArea | Mass per Unit Area, in discipline Structural.
MassPerUnitLength | Mass per Unit Length, in discipline Structural.
Moment | Moment, in discipline Structural.
MomentOfInertia | Moment of Inertia, in discipline Structural.
MomentScale | Moment Scale, in discipline Structural.
Number | Number, in discipline Common.
Period | Period, in discipline Structural.
Permeability | Permeability, in discipline Energy.
PipeDimension | Pipe Dimension, in discipline Piping.
PipeInsulationThickness | Pipe Insulation Thickness, in discipline Piping.
PipeMassPerUnitLength | Mass per Unit Length, in discipline Piping.
PipeSize | Pipe Size, in discipline Piping.
PipingDensity | Density, in discipline Piping.
PipingFriction | Friction, in discipline Piping.
PipingMass | Mass, in discipline Piping.
PipingMassPerTime | Mass per Time, in discipline Piping.
PipingPressure | Pressure, in discipline Piping.
PipingRoughness | Roughness, in discipline Piping.
PipingSlope | Slope, in discipline Piping.
PipingTemperature | Temperature, in discipline Piping.
PipingTemperatureDifference | Temperature Difference, in discipline Piping.
PipingVelocity | Velocity, in discipline Piping.
PipingViscosity | Dynamic Viscosity, in discipline Piping.
PipingVolume | Volume, in discipline Piping.
PointSpringCoefficient | Point Spring Coefficient, in discipline Structural.
PowerPerFlow | Power per Flow, in discipline HVAC.
PowerPerLength | Power per Length, in discipline Electrical.
Pulsation | Pulsation, in discipline Structural.
ReinforcementArea | Reinforcement Area, in discipline Structural.
ReinforcementAreaPerUnitLength | Reinforcement Area per Unit Length, in discipline Structural.
ReinforcementCover | Reinforcement Cover, in discipline Structural.
ReinforcementLength | Reinforcement Length, in discipline Structural.
ReinforcementSpacing | Reinforcement Spacing, in discipline Structural.
ReinforcementVolume | Reinforcement Volume, in discipline Structural.
Rotation | Rotation, in discipline Structural.
RotationalLineSpringCoefficient | Rotational Line Spring Coefficient, in discipline Structural.
RotationalPointSpringCoefficient | Rotational Point Spring Coefficient, in discipline Structural.
RotationAngle | Rotation Angle, in discipline Common.
SectionArea | Section Area, in discipline Structural.
SectionDimension | Section Dimension, in discipline Structural.
SectionModulus | Section Modulus, in discipline Structural.
SectionProperty | Section Property, in discipline Structural.
SheetLength | Sheet Length, in discipline Common.
SiteAngle | Site Angle, in discipline Common.
Slope | Slope, in discipline Common.
SpecificHeat | Specific Heat, in discipline Energy.
SpecificHeatOfVaporization | Specific Heat of Vaporization, in discipline Energy.
Speed | Speed, in discipline Common.
Stationing | Stationing, in discipline Infrastructure.
StationingInterval | Stationing Interval, in discipline Infrastructure.
Stress | Stress, in discipline Structural.
StructuralFrequency | Frequency, in discipline Structural.
StructuralVelocity | Velocity, in discipline Structural.
SurfaceAreaPerUnitLength | Surface Area per Unit Length, in discipline Structural.
ThermalConductivity | Thermal Conductivity, in discipline Energy.
ThermalExpansionCoefficient | Thermal Expansion Coefficient, in discipline Structural.
ThermalGradientCoefficientForMoistureCapacity | Thermal Gradient Coefficient for Moisture Capacity, in discipline Energy.
ThermalMass | Thermal Mass, in discipline Energy.
ThermalResistance | Thermal Resistance, in discipline Energy.
Time | Time, in discipline Common.
UnitWeight | Unit Weight, in discipline Structural.
Volume | Volume, in discipline Common.
WarpingConstant | Warping Constant, in discipline Structural.
Wattage | Wattage, in discipline Electrical.
Weight | Weight, in discipline Structural.
WeightPerUnitLength | Weight per Unit Length, in discipline Structural.
WireDiameter | Wire Diameter, in discipline Electrical.

See Also

SpecTypeId Class


SpecTypeId Properties

[image] [image]

Revit 2024 API
SpecTypeId Properties
SpecTypeId Class See Also Send Feedback

The SpecTypeId type exposes the following members.

Properties

Name | Description
Acceleration | Acceleration, in discipline Structural.
AirFlow | Air Flow, in discipline HVAC.
AirFlowDensity | Air Flow Density, in discipline HVAC.
AirFlowDividedByCoolingLoad | Air Flow divided by Cooling Load, in discipline HVAC.
AirFlowDividedByVolume | Air Flow divided by Volume, in discipline HVAC.
Angle | Angle, in discipline Common.
AngularSpeed | Angular Speed, in discipline HVAC.
ApparentPower | Apparent Power, in discipline Electrical.
ApparentPowerDensity | Apparent Power Density, in discipline Electrical.
Area | Area, in discipline Common.
AreaDividedByCoolingLoad | Area divided by Cooling Load, in discipline HVAC.
AreaDividedByHeatingLoad | Area divided by Heating Load, in discipline HVAC.
AreaForce | Area Force, in discipline Structural.
AreaForceScale | Area Force Scale, in discipline Structural.
AreaSpringCoefficient | Area Spring Coefficient, in discipline Structural.
BarDiameter | Bar Diameter, in discipline Structural.
CableTraySize | Cable Tray Size, in discipline Electrical.
ColorTemperature | Color Temperature, in discipline Electrical.
ConduitSize | Conduit Size, in discipline Electrical.
CoolingLoad | Cooling Load, in discipline HVAC.
CoolingLoadDividedByArea | Cooling Load divided by Area, in discipline HVAC.
CoolingLoadDividedByVolume | Cooling Load divided by Volume, in discipline HVAC.
CostPerArea | Cost per Area, in discipline Common.
CostRateEnergy | Cost Rate Energy, in discipline Electrical.
CostRatePower | Cost Rate Power, in discipline Electrical.
CrackWidth | Crack Width, in discipline Structural.
CrossSection | Cross Section, in discipline HVAC.
Currency | Currency, in discipline Common.
Current | Current, in discipline Electrical.
Custom | Unrecognized custom spec.
DecimalSheetLength | Decimal Sheet Length, in discipline Common.
DemandFactor | Demand Factor, in discipline Electrical.
Diffusivity | Diffusivity, in discipline HVAC.
Displacement | Displacement/Deflection, in discipline Structural.
Distance | Distance, in discipline Common.
DuctInsulationThickness | Duct Insulation Thickness, in discipline HVAC.
DuctLiningThickness | Duct Lining Thickness, in discipline HVAC.
DuctSize | Duct Size, in discipline HVAC.
Efficacy | Efficacy, in discipline Electrical.
ElectricalFrequency | Frequency, in discipline Electrical.
ElectricalPotential | Electrical Potential, in discipline Electrical.
ElectricalPower | Power, in discipline Electrical.
ElectricalPowerDensity | Power Density, in discipline Electrical.
ElectricalResistivity | Electrical Resistivity, in discipline Electrical.
ElectricalTemperature | Temperature, in discipline Electrical.
ElectricalTemperatureDifference | Temperature Difference, in discipline Electrical.
Energy | Energy, in discipline Structural.
Factor | Factor, in discipline HVAC.
Flow | Flow, in discipline Piping.
FlowPerPower | Flow per Power, in discipline HVAC.
Force | Force, in discipline Structural.
ForceScale | Force Scale, in discipline Structural.
HeatCapacityPerArea | Heat Capacity per Area, in discipline Energy.
HeatGain | Heat Gain, in discipline HVAC.
HeatingLoad | Heating Load, in discipline HVAC.
HeatingLoadDividedByArea | Heating Load divided by Area, in discipline HVAC.
HeatingLoadDividedByVolume | Heating Load divided by Volume, in discipline HVAC.
HeatTransferCoefficient | Coefficient of Heat Transfer, in discipline Energy.
HvacDensity | Density, in discipline HVAC.
HvacEnergy | Energy, in discipline Energy.
HvacFriction | Friction, in discipline HVAC.
HvacMassPerTime | Mass per Time, in discipline HVAC.
HvacPower | Power, in discipline HVAC.
HvacPowerDensity | Power Density, in discipline HVAC.
HvacPressure | Pressure, in discipline HVAC.
HvacRoughness | Roughness, in discipline HVAC.
HvacSlope | Slope, in discipline HVAC.
HvacTemperature | Temperature, in discipline HVAC.
HvacTemperatureDifference | Temperature Difference, in discipline HVAC.
HvacVelocity | Velocity, in discipline HVAC.
HvacViscosity | Dynamic Viscosity, in discipline HVAC.
Illuminance | Illuminance, in discipline Electrical.
IsothermalMoistureCapacity | Isothermal Moisture Capacity, in discipline Energy.
Length | Length, in discipline Common.
LinearForce | Linear Force, in discipline Structural.
LinearForceScale | Linear Force Scale, in discipline Structural.
LinearMoment | Linear Moment, in discipline Structural.
LinearMomentScale | Linear Moment Scale, in discipline Structural.
LineSpringCoefficient | Line Spring Coefficient, in discipline Structural.
Luminance | Luminance, in discipline Electrical.
LuminousFlux | Luminous Flux, in discipline Electrical.
LuminousIntensity | Luminous Intensity, in discipline Electrical.
Mass | Mass, in discipline Structural.
MassDensity | Mass Density, in discipline Common.
MassPerUnitArea | Mass per Unit Area, in discipline Structural.
MassPerUnitLength | Mass per Unit Length, in discipline Structural.
Moment | Moment, in discipline Structural.
MomentOfInertia | Moment of Inertia, in discipline Structural.
MomentScale | Moment Scale, in discipline Structural.
Number | Number, in discipline Common.
Period | Period, in discipline Structural.
Permeability | Permeability, in discipline Energy.
PipeDimension | Pipe Dimension, in discipline Piping.
PipeInsulationThickness | Pipe Insulation Thickness, in discipline Piping.
PipeMassPerUnitLength | Mass per Unit Length, in discipline Piping.
PipeSize | Pipe Size, in discipline Piping.
PipingDensity | Density, in discipline Piping.
PipingFriction | Friction, in discipline Piping.
PipingMass | Mass, in discipline Piping.
PipingMassPerTime | Mass per Time, in discipline Piping.
PipingPressure | Pressure, in discipline Piping.
PipingRoughness | Roughness, in discipline Piping.
PipingSlope | Slope, in discipline Piping.
PipingTemperature | Temperature, in discipline Piping.
PipingTemperatureDifference | Temperature Difference, in discipline Piping.
PipingVelocity | Velocity, in discipline Piping.
PipingViscosity | Dynamic Viscosity, in discipline Piping.
PipingVolume | Volume, in discipline Piping.
PointSpringCoefficient | Point Spring Coefficient, in discipline Structural.
PowerPerFlow | Power per Flow, in discipline HVAC.
PowerPerLength | Power per Length, in discipline Electrical.
Pulsation | Pulsation, in discipline Structural.
ReinforcementArea | Reinforcement Area, in discipline Structural.
ReinforcementAreaPerUnitLength | Reinforcement Area per Unit Length, in discipline Structural.
ReinforcementCover | Reinforcement Cover, in discipline Structural.
ReinforcementLength | Reinforcement Length, in discipline Structural.
ReinforcementSpacing | Reinforcement Spacing, in discipline Structural.
ReinforcementVolume | Reinforcement Volume, in discipline Structural.
Rotation | Rotation, in discipline Structural.
RotationalLineSpringCoefficient | Rotational Line Spring Coefficient, in discipline Structural.
RotationalPointSpringCoefficient | Rotational Point Spring Coefficient, in discipline Structural.
RotationAngle | Rotation Angle, in discipline Common.
SectionArea | Section Area, in discipline Structural.
SectionDimension | Section Dimension, in discipline Structural.
SectionModulus | Section Modulus, in discipline Structural.
SectionProperty | Section Property, in discipline Structural.
SheetLength | Sheet Length, in discipline Common.
SiteAngle | Site Angle, in discipline Common.
Slope | Slope, in discipline Common.
SpecificHeat | Specific Heat, in discipline Energy.
SpecificHeatOfVaporization | Specific Heat of Vaporization, in discipline Energy.
Speed | Speed, in discipline Common.
Stationing | Stationing, in discipline Infrastructure.
StationingInterval | Stationing Interval, in discipline Infrastructure.
Stress | Stress, in discipline Structural.
StructuralFrequency | Frequency, in discipline Structural.
StructuralVelocity | Velocity, in discipline Structural.
SurfaceAreaPerUnitLength | Surface Area per Unit Length, in discipline Structural.
ThermalConductivity | Thermal Conductivity, in discipline Energy.
ThermalExpansionCoefficient | Thermal Expansion Coefficient, in discipline Structural.
ThermalGradientCoefficientForMoistureCapacity | Thermal Gradient Coefficient for Moisture Capacity, in discipline Energy.
ThermalMass | Thermal Mass, in discipline Energy.
ThermalResistance | Thermal Resistance, in discipline Energy.
Time | Time, in discipline Common.
UnitWeight | Unit Weight, in discipline Structural.
Volume | Volume, in discipline Common.
WarpingConstant | Warping Constant, in discipline Structural.
Wattage | Wattage, in discipline Electrical.
Weight | Weight, in discipline Structural.
WeightPerUnitLength | Weight per Unit Length, in discipline Structural.
WireDiameter | Wire Diameter, in discipline Electrical.

See Also

SpecTypeId Class


Acceleration Property

[image]

Revit 2024 API
SpecTypeId..::..Acceleration Property
SpecTypeId Class See Also Send Feedback
Acceleration, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Acceleration { get; }
Visual Basic
Public Shared ReadOnly Property Acceleration As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Acceleration {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


AirFlow Property

[image]

Revit 2024 API
SpecTypeId..::..AirFlow Property
SpecTypeId Class See Also Send Feedback
Air Flow, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId AirFlow { get; }
Visual Basic
Public Shared ReadOnly Property AirFlow As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AirFlow {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


AirFlowDensity Property

[image]

Revit 2024 API
SpecTypeId..::..AirFlowDensity Property
SpecTypeId Class See Also Send Feedback
Air Flow Density, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId AirFlowDensity { get; }
Visual Basic
Public Shared ReadOnly Property AirFlowDensity As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AirFlowDensity {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


AirFlowDividedByCoolingLoad Property

[image]

Revit 2024 API
SpecTypeId..::..AirFlowDividedByCoolingLoad Property
SpecTypeId Class See Also Send Feedback
Air Flow divided by Cooling Load, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId AirFlowDividedByCoolingLoad { get; }
Visual Basic
Public Shared ReadOnly Property AirFlowDividedByCoolingLoad As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AirFlowDividedByCoolingLoad {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


AirFlowDividedByVolume Property

[image]

Revit 2024 API
SpecTypeId..::..AirFlowDividedByVolume Property
SpecTypeId Class See Also Send Feedback
Air Flow divided by Volume, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId AirFlowDividedByVolume { get; }
Visual Basic
Public Shared ReadOnly Property AirFlowDividedByVolume As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AirFlowDividedByVolume {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


AngularSpeed Property

[image]

Revit 2024 API
SpecTypeId..::..AngularSpeed Property
SpecTypeId Class See Also Send Feedback
Angular Speed, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId AngularSpeed { get; }
Visual Basic
Public Shared ReadOnly Property AngularSpeed As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AngularSpeed {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


ApparentPower Property

[image]

Revit 2024 API
SpecTypeId..::..ApparentPower Property
SpecTypeId Class See Also Send Feedback
Apparent Power, in discipline Electrical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId ApparentPower { get; }
Visual Basic
Public Shared ReadOnly Property ApparentPower As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ApparentPower {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


AreaDividedByCoolingLoad Property

[image]

Revit 2024 API
SpecTypeId..::..AreaDividedByCoolingLoad Property
SpecTypeId Class See Also Send Feedback
Area divided by Cooling Load, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId AreaDividedByCoolingLoad { get; }
Visual Basic
Public Shared ReadOnly Property AreaDividedByCoolingLoad As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AreaDividedByCoolingLoad {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


AreaForceScale Property

[image]

Revit 2024 API
SpecTypeId..::..AreaForceScale Property
SpecTypeId Class See Also Send Feedback
Area Force Scale, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId AreaForceScale { get; }
Visual Basic
Public Shared ReadOnly Property AreaForceScale As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AreaForceScale {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


AreaSpringCoefficient Property

[image]

Revit 2024 API
SpecTypeId..::..AreaSpringCoefficient Property
SpecTypeId Class See Also Send Feedback
Area Spring Coefficient, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId AreaSpringCoefficient { get; }
Visual Basic
Public Shared ReadOnly Property AreaSpringCoefficient As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ AreaSpringCoefficient {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


BarDiameter Property

[image]

Revit 2024 API
SpecTypeId..::..BarDiameter Property
SpecTypeId Class See Also Send Feedback
Bar Diameter, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId BarDiameter { get; }
Visual Basic
Public Shared ReadOnly Property BarDiameter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BarDiameter {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


CableTraySize Property

[image]

Revit 2024 API
SpecTypeId..::..CableTraySize Property
SpecTypeId Class See Also Send Feedback
Cable Tray Size, in discipline Electrical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId CableTraySize { get; }
Visual Basic
Public Shared ReadOnly Property CableTraySize As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CableTraySize {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


ColorTemperature Property

[image]

Revit 2024 API
SpecTypeId..::..ColorTemperature Property
SpecTypeId Class See Also Send Feedback
Color Temperature, in discipline Electrical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId ColorTemperature { get; }
Visual Basic
Public Shared ReadOnly Property ColorTemperature As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ColorTemperature {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


CoolingLoad Property

[image]

Revit 2024 API
SpecTypeId..::..CoolingLoad Property
SpecTypeId Class See Also Send Feedback
Cooling Load, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId CoolingLoad { get; }
Visual Basic
Public Shared ReadOnly Property CoolingLoad As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CoolingLoad {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


CoolingLoadDividedByVolume Property

[image]

Revit 2024 API
SpecTypeId..::..CoolingLoadDividedByVolume Property
SpecTypeId Class See Also Send Feedback
Cooling Load divided by Volume, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId CoolingLoadDividedByVolume { get; }
Visual Basic
Public Shared ReadOnly Property CoolingLoadDividedByVolume As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CoolingLoadDividedByVolume {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


CostPerArea Property

[image]

Revit 2024 API
SpecTypeId..::..CostPerArea Property
SpecTypeId Class See Also Send Feedback
Cost per Area, in discipline Common.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId CostPerArea { get; }
Visual Basic
Public Shared ReadOnly Property CostPerArea As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CostPerArea {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


CostRateEnergy Property

[image]

Revit 2024 API
SpecTypeId..::..CostRateEnergy Property
SpecTypeId Class See Also Send Feedback
Cost Rate Energy, in discipline Electrical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId CostRateEnergy { get; }
Visual Basic
Public Shared ReadOnly Property CostRateEnergy As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CostRateEnergy {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


CrackWidth Property

[image]

Revit 2024 API
SpecTypeId..::..CrackWidth Property
SpecTypeId Class See Also Send Feedback
Crack Width, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId CrackWidth { get; }
Visual Basic
Public Shared ReadOnly Property CrackWidth As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CrackWidth {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


Current Property

[image]

Revit 2024 API
SpecTypeId..::..Current Property
SpecTypeId Class See Also Send Feedback
Current, in discipline Electrical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Current { get; }
Visual Basic
Public Shared ReadOnly Property Current As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Current {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


Custom Property

[image]

Revit 2024 API
SpecTypeId..::..Custom Property
SpecTypeId Class See Also Send Feedback
Unrecognized custom spec.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Custom { get; }
Visual Basic
Public Shared ReadOnly Property Custom As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Custom {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


DemandFactor Property

[image]

Revit 2024 API
SpecTypeId..::..DemandFactor Property
SpecTypeId Class See Also Send Feedback
Demand Factor, in discipline Electrical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId DemandFactor { get; }
Visual Basic
Public Shared ReadOnly Property DemandFactor As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DemandFactor {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


Displacement Property

[image]

Revit 2024 API
SpecTypeId..::..Displacement Property
SpecTypeId Class See Also Send Feedback
Displacement/Deflection, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Displacement { get; }
Visual Basic
Public Shared ReadOnly Property Displacement As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Displacement {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


Distance Property

[image]

Revit 2024 API
SpecTypeId..::..Distance Property
SpecTypeId Class See Also Send Feedback
Distance, in discipline Common.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Distance { get; }
Visual Basic
Public Shared ReadOnly Property Distance As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Distance {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


DuctInsulationThickness Property

[image]

Revit 2024 API
SpecTypeId..::..DuctInsulationThickness Property
SpecTypeId Class See Also Send Feedback
Duct Insulation Thickness, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId DuctInsulationThickness { get; }
Visual Basic
Public Shared ReadOnly Property DuctInsulationThickness As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DuctInsulationThickness {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


DuctLiningThickness Property

[image]

Revit 2024 API
SpecTypeId..::..DuctLiningThickness Property
SpecTypeId Class See Also Send Feedback
Duct Lining Thickness, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId DuctLiningThickness { get; }
Visual Basic
Public Shared ReadOnly Property DuctLiningThickness As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DuctLiningThickness {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


DuctSize Property

[image]

Revit 2024 API
SpecTypeId..::..DuctSize Property
SpecTypeId Class See Also Send Feedback
Duct Size, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId DuctSize { get; }
Visual Basic
Public Shared ReadOnly Property DuctSize As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DuctSize {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


Efficacy Property

[image]

Revit 2024 API
SpecTypeId..::..Efficacy Property
SpecTypeId Class See Also Send Feedback
Efficacy, in discipline Electrical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Efficacy { get; }
Visual Basic
Public Shared ReadOnly Property Efficacy As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Efficacy {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


ElectricalPotential Property

[image]

Revit 2024 API
SpecTypeId..::..ElectricalPotential Property
SpecTypeId Class See Also Send Feedback
Electrical Potential, in discipline Electrical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId ElectricalPotential { get; }
Visual Basic
Public Shared ReadOnly Property ElectricalPotential As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ElectricalPotential {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


ElectricalPower Property

[image]

Revit 2024 API
SpecTypeId..::..ElectricalPower Property
SpecTypeId Class See Also Send Feedback
Power, in discipline Electrical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId ElectricalPower { get; }
Visual Basic
Public Shared ReadOnly Property ElectricalPower As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ElectricalPower {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


ElectricalResistivity Property

[image]

Revit 2024 API
SpecTypeId..::..ElectricalResistivity Property
SpecTypeId Class See Also Send Feedback
Electrical Resistivity, in discipline Electrical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId ElectricalResistivity { get; }
Visual Basic
Public Shared ReadOnly Property ElectricalResistivity As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ElectricalResistivity {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


ElectricalTemperature Property

[image]

Revit 2024 API
SpecTypeId..::..ElectricalTemperature Property
SpecTypeId Class See Also Send Feedback
Temperature, in discipline Electrical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId ElectricalTemperature { get; }
Visual Basic
Public Shared ReadOnly Property ElectricalTemperature As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ElectricalTemperature {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


ElectricalTemperatureDifference Property

[image]

Revit 2024 API
SpecTypeId..::..ElectricalTemperatureDifference Property
SpecTypeId Class See Also Send Feedback
Temperature Difference, in discipline Electrical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId ElectricalTemperatureDifference { get; }
Visual Basic
Public Shared ReadOnly Property ElectricalTemperatureDifference As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ElectricalTemperatureDifference {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


Energy Property

[image]

Revit 2024 API
SpecTypeId..::..Energy Property
SpecTypeId Class See Also Send Feedback
Energy, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Energy { get; }
Visual Basic
Public Shared ReadOnly Property Energy As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Energy {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


Factor Property

[image]

Revit 2024 API
SpecTypeId..::..Factor Property
SpecTypeId Class See Also Send Feedback
Factor, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Factor { get; }
Visual Basic
Public Shared ReadOnly Property Factor As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Factor {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


Flow Property

[image]

Revit 2024 API
SpecTypeId..::..Flow Property
SpecTypeId Class See Also Send Feedback
Flow, in discipline Piping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Flow { get; }
Visual Basic
Public Shared ReadOnly Property Flow As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Flow {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


FlowPerPower Property

[image]

Revit 2024 API
SpecTypeId..::..FlowPerPower Property
SpecTypeId Class See Also Send Feedback
Flow per Power, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId FlowPerPower { get; }
Visual Basic
Public Shared ReadOnly Property FlowPerPower As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FlowPerPower {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


Force Property

[image]

Revit 2024 API
SpecTypeId..::..Force Property
SpecTypeId Class See Also Send Feedback
Force, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Force { get; }
Visual Basic
Public Shared ReadOnly Property Force As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Force {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


HeatCapacityPerArea Property

[image]

Revit 2024 API
SpecTypeId..::..HeatCapacityPerArea Property
SpecTypeId Class See Also Send Feedback
Heat Capacity per Area, in discipline Energy.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId HeatCapacityPerArea { get; }
Visual Basic
Public Shared ReadOnly Property HeatCapacityPerArea As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ HeatCapacityPerArea {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


HeatGain Property

[image]

Revit 2024 API
SpecTypeId..::..HeatGain Property
SpecTypeId Class See Also Send Feedback
Heat Gain, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId HeatGain { get; }
Visual Basic
Public Shared ReadOnly Property HeatGain As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ HeatGain {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


HeatingLoadDividedByVolume Property

[image]

Revit 2024 API
SpecTypeId..::..HeatingLoadDividedByVolume Property
SpecTypeId Class See Also Send Feedback
Heating Load divided by Volume, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId HeatingLoadDividedByVolume { get; }
Visual Basic
Public Shared ReadOnly Property HeatingLoadDividedByVolume As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ HeatingLoadDividedByVolume {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


HeatTransferCoefficient Property

[image]

Revit 2024 API
SpecTypeId..::..HeatTransferCoefficient Property
SpecTypeId Class See Also Send Feedback
Coefficient of Heat Transfer, in discipline Energy.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId HeatTransferCoefficient { get; }
Visual Basic
Public Shared ReadOnly Property HeatTransferCoefficient As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ HeatTransferCoefficient {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


HvacDensity Property

[image]

Revit 2024 API
SpecTypeId..::..HvacDensity Property
SpecTypeId Class See Also Send Feedback
Density, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId HvacDensity { get; }
Visual Basic
Public Shared ReadOnly Property HvacDensity As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ HvacDensity {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


HvacFriction Property

[image]

Revit 2024 API
SpecTypeId..::..HvacFriction Property
SpecTypeId Class See Also Send Feedback
Friction, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId HvacFriction { get; }
Visual Basic
Public Shared ReadOnly Property HvacFriction As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ HvacFriction {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


HvacMassPerTime Property

[image]

Revit 2024 API
SpecTypeId..::..HvacMassPerTime Property
SpecTypeId Class See Also Send Feedback
Mass per Time, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId HvacMassPerTime { get; }
Visual Basic
Public Shared ReadOnly Property HvacMassPerTime As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ HvacMassPerTime {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


HvacPower Property

[image]

Revit 2024 API
SpecTypeId..::..HvacPower Property
SpecTypeId Class See Also Send Feedback
Power, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId HvacPower { get; }
Visual Basic
Public Shared ReadOnly Property HvacPower As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ HvacPower {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


HvacPowerDensity Property

[image]

Revit 2024 API
SpecTypeId..::..HvacPowerDensity Property
SpecTypeId Class See Also Send Feedback
Power Density, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId HvacPowerDensity { get; }
Visual Basic
Public Shared ReadOnly Property HvacPowerDensity As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ HvacPowerDensity {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


HvacPressure Property

[image]

Revit 2024 API
SpecTypeId..::..HvacPressure Property
SpecTypeId Class See Also Send Feedback
Pressure, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId HvacPressure { get; }
Visual Basic
Public Shared ReadOnly Property HvacPressure As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ HvacPressure {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


HvacRoughness Property

[image]

Revit 2024 API
SpecTypeId..::..HvacRoughness Property
SpecTypeId Class See Also Send Feedback
Roughness, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId HvacRoughness { get; }
Visual Basic
Public Shared ReadOnly Property HvacRoughness As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ HvacRoughness {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


HvacSlope Property

[image]

Revit 2024 API
SpecTypeId..::..HvacSlope Property
SpecTypeId Class See Also Send Feedback
Slope, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId HvacSlope { get; }
Visual Basic
Public Shared ReadOnly Property HvacSlope As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ HvacSlope {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


HvacTemperature Property

[image]

Revit 2024 API
SpecTypeId..::..HvacTemperature Property
SpecTypeId Class See Also Send Feedback
Temperature, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId HvacTemperature { get; }
Visual Basic
Public Shared ReadOnly Property HvacTemperature As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ HvacTemperature {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


HvacTemperatureDifference Property

[image]

Revit 2024 API
SpecTypeId..::..HvacTemperatureDifference Property
SpecTypeId Class See Also Send Feedback
Temperature Difference, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId HvacTemperatureDifference { get; }
Visual Basic
Public Shared ReadOnly Property HvacTemperatureDifference As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ HvacTemperatureDifference {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


HvacVelocity Property

[image]

Revit 2024 API
SpecTypeId..::..HvacVelocity Property
SpecTypeId Class See Also Send Feedback
Velocity, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId HvacVelocity { get; }
Visual Basic
Public Shared ReadOnly Property HvacVelocity As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ HvacVelocity {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


HvacViscosity Property

[image]

Revit 2024 API
SpecTypeId..::..HvacViscosity Property
SpecTypeId Class See Also Send Feedback
Dynamic Viscosity, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId HvacViscosity { get; }
Visual Basic
Public Shared ReadOnly Property HvacViscosity As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ HvacViscosity {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


Illuminance Property

[image]

Revit 2024 API
SpecTypeId..::..Illuminance Property
SpecTypeId Class See Also Send Feedback
Illuminance, in discipline Electrical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Illuminance { get; }
Visual Basic
Public Shared ReadOnly Property Illuminance As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Illuminance {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


IsothermalMoistureCapacity Property

[image]

Revit 2024 API
SpecTypeId..::..IsothermalMoistureCapacity Property
SpecTypeId Class See Also Send Feedback
Isothermal Moisture Capacity, in discipline Energy.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId IsothermalMoistureCapacity { get; }
Visual Basic
Public Shared ReadOnly Property IsothermalMoistureCapacity As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ IsothermalMoistureCapacity {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


LinearForce Property

[image]

Revit 2024 API
SpecTypeId..::..LinearForce Property
SpecTypeId Class See Also Send Feedback
Linear Force, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId LinearForce { get; }
Visual Basic
Public Shared ReadOnly Property LinearForce As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LinearForce {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


LinearMoment Property

[image]

Revit 2024 API
SpecTypeId..::..LinearMoment Property
SpecTypeId Class See Also Send Feedback
Linear Moment, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId LinearMoment { get; }
Visual Basic
Public Shared ReadOnly Property LinearMoment As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LinearMoment {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


LinearMomentScale Property

[image]

Revit 2024 API
SpecTypeId..::..LinearMomentScale Property
SpecTypeId Class See Also Send Feedback
Linear Moment Scale, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId LinearMomentScale { get; }
Visual Basic
Public Shared ReadOnly Property LinearMomentScale As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LinearMomentScale {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


Luminance Property

[image]

Revit 2024 API
SpecTypeId..::..Luminance Property
SpecTypeId Class See Also Send Feedback
Luminance, in discipline Electrical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Luminance { get; }
Visual Basic
Public Shared ReadOnly Property Luminance As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Luminance {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


LuminousFlux Property

[image]

Revit 2024 API
SpecTypeId..::..LuminousFlux Property
SpecTypeId Class See Also Send Feedback
Luminous Flux, in discipline Electrical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId LuminousFlux { get; }
Visual Basic
Public Shared ReadOnly Property LuminousFlux As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LuminousFlux {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


LuminousIntensity Property

[image]

Revit 2024 API
SpecTypeId..::..LuminousIntensity Property
SpecTypeId Class See Also Send Feedback
Luminous Intensity, in discipline Electrical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId LuminousIntensity { get; }
Visual Basic
Public Shared ReadOnly Property LuminousIntensity As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LuminousIntensity {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


Mass Property

[image]

Revit 2024 API
SpecTypeId..::..Mass Property
SpecTypeId Class See Also Send Feedback
Mass, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Mass { get; }
Visual Basic
Public Shared ReadOnly Property Mass As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Mass {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


MassDensity Property

[image]

Revit 2024 API
SpecTypeId..::..MassDensity Property
SpecTypeId Class See Also Send Feedback
Mass Density, in discipline Common.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MassDensity { get; }
Visual Basic
Public Shared ReadOnly Property MassDensity As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MassDensity {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


MassPerUnitArea Property

[image]

Revit 2024 API
SpecTypeId..::..MassPerUnitArea Property
SpecTypeId Class See Also Send Feedback
Mass per Unit Area, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MassPerUnitArea { get; }
Visual Basic
Public Shared ReadOnly Property MassPerUnitArea As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MassPerUnitArea {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


MassPerUnitLength Property

[image]

Revit 2024 API
SpecTypeId..::..MassPerUnitLength Property
SpecTypeId Class See Also Send Feedback
Mass per Unit Length, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MassPerUnitLength { get; }
Visual Basic
Public Shared ReadOnly Property MassPerUnitLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MassPerUnitLength {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


Moment Property

[image]

Revit 2024 API
SpecTypeId..::..Moment Property
SpecTypeId Class See Also Send Feedback
Moment, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Moment { get; }
Visual Basic
Public Shared ReadOnly Property Moment As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Moment {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


MomentOfInertia Property

[image]

Revit 2024 API
SpecTypeId..::..MomentOfInertia Property
SpecTypeId Class See Also Send Feedback
Moment of Inertia, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MomentOfInertia { get; }
Visual Basic
Public Shared ReadOnly Property MomentOfInertia As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MomentOfInertia {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


MomentScale Property

[image]

Revit 2024 API
SpecTypeId..::..MomentScale Property
SpecTypeId Class See Also Send Feedback
Moment Scale, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MomentScale { get; }
Visual Basic
Public Shared ReadOnly Property MomentScale As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MomentScale {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


Number Property

[image]

Revit 2024 API
SpecTypeId..::..Number Property
SpecTypeId Class See Also Send Feedback
Number, in discipline Common.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Number { get; }
Visual Basic
Public Shared ReadOnly Property Number As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Number {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


Period Property

[image]

Revit 2024 API
SpecTypeId..::..Period Property
SpecTypeId Class See Also Send Feedback
Period, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Period { get; }
Visual Basic
Public Shared ReadOnly Property Period As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Period {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


Permeability Property

[image]

Revit 2024 API
SpecTypeId..::..Permeability Property
SpecTypeId Class See Also Send Feedback
Permeability, in discipline Energy.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Permeability { get; }
Visual Basic
Public Shared ReadOnly Property Permeability As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Permeability {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


PipeInsulationThickness Property

[image]

Revit 2024 API
SpecTypeId..::..PipeInsulationThickness Property
SpecTypeId Class See Also Send Feedback
Pipe Insulation Thickness, in discipline Piping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId PipeInsulationThickness { get; }
Visual Basic
Public Shared ReadOnly Property PipeInsulationThickness As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PipeInsulationThickness {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


PipeMassPerUnitLength Property

[image]

Revit 2024 API
SpecTypeId..::..PipeMassPerUnitLength Property
SpecTypeId Class See Also Send Feedback
Mass per Unit Length, in discipline Piping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId PipeMassPerUnitLength { get; }
Visual Basic
Public Shared ReadOnly Property PipeMassPerUnitLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PipeMassPerUnitLength {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


PipingFriction Property

[image]

Revit 2024 API
SpecTypeId..::..PipingFriction Property
SpecTypeId Class See Also Send Feedback
Friction, in discipline Piping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId PipingFriction { get; }
Visual Basic
Public Shared ReadOnly Property PipingFriction As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PipingFriction {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


PipingMassPerTime Property

[image]

Revit 2024 API
SpecTypeId..::..PipingMassPerTime Property
SpecTypeId Class See Also Send Feedback
Mass per Time, in discipline Piping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId PipingMassPerTime { get; }
Visual Basic
Public Shared ReadOnly Property PipingMassPerTime As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PipingMassPerTime {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


PipingPressure Property

[image]

Revit 2024 API
SpecTypeId..::..PipingPressure Property
SpecTypeId Class See Also Send Feedback
Pressure, in discipline Piping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId PipingPressure { get; }
Visual Basic
Public Shared ReadOnly Property PipingPressure As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PipingPressure {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


PipingRoughness Property

[image]

Revit 2024 API
SpecTypeId..::..PipingRoughness Property
SpecTypeId Class See Also Send Feedback
Roughness, in discipline Piping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId PipingRoughness { get; }
Visual Basic
Public Shared ReadOnly Property PipingRoughness As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PipingRoughness {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


PipingTemperature Property

[image]

Revit 2024 API
SpecTypeId..::..PipingTemperature Property
SpecTypeId Class See Also Send Feedback
Temperature, in discipline Piping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId PipingTemperature { get; }
Visual Basic
Public Shared ReadOnly Property PipingTemperature As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PipingTemperature {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


PipingTemperatureDifference Property

[image]

Revit 2024 API
SpecTypeId..::..PipingTemperatureDifference Property
SpecTypeId Class See Also Send Feedback
Temperature Difference, in discipline Piping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId PipingTemperatureDifference { get; }
Visual Basic
Public Shared ReadOnly Property PipingTemperatureDifference As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PipingTemperatureDifference {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


PipingVelocity Property

[image]

Revit 2024 API
SpecTypeId..::..PipingVelocity Property
SpecTypeId Class See Also Send Feedback
Velocity, in discipline Piping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId PipingVelocity { get; }
Visual Basic
Public Shared ReadOnly Property PipingVelocity As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PipingVelocity {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


PipingViscosity Property

[image]

Revit 2024 API
SpecTypeId..::..PipingViscosity Property
SpecTypeId Class See Also Send Feedback
Dynamic Viscosity, in discipline Piping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId PipingViscosity { get; }
Visual Basic
Public Shared ReadOnly Property PipingViscosity As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PipingViscosity {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


PipingVolume Property

[image]

Revit 2024 API
SpecTypeId..::..PipingVolume Property
SpecTypeId Class See Also Send Feedback
Volume, in discipline Piping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId PipingVolume { get; }
Visual Basic
Public Shared ReadOnly Property PipingVolume As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PipingVolume {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


PowerPerFlow Property

[image]

Revit 2024 API
SpecTypeId..::..PowerPerFlow Property
SpecTypeId Class See Also Send Feedback
Power per Flow, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId PowerPerFlow { get; }
Visual Basic
Public Shared ReadOnly Property PowerPerFlow As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PowerPerFlow {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


Pulsation Property

[image]

Revit 2024 API
SpecTypeId..::..Pulsation Property
SpecTypeId Class See Also Send Feedback
Pulsation, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Pulsation { get; }
Visual Basic
Public Shared ReadOnly Property Pulsation As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Pulsation {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


ReinforcementArea Property

[image]

Revit 2024 API
SpecTypeId..::..ReinforcementArea Property
SpecTypeId Class See Also Send Feedback
Reinforcement Area, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId ReinforcementArea { get; }
Visual Basic
Public Shared ReadOnly Property ReinforcementArea As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ReinforcementArea {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


ReinforcementAreaPerUnitLength Property

[image]

Revit 2024 API
SpecTypeId..::..ReinforcementAreaPerUnitLength Property
SpecTypeId Class See Also Send Feedback
Reinforcement Area per Unit Length, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId ReinforcementAreaPerUnitLength { get; }
Visual Basic
Public Shared ReadOnly Property ReinforcementAreaPerUnitLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ReinforcementAreaPerUnitLength {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


ReinforcementCover Property

[image]

Revit 2024 API
SpecTypeId..::..ReinforcementCover Property
SpecTypeId Class See Also Send Feedback
Reinforcement Cover, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId ReinforcementCover { get; }
Visual Basic
Public Shared ReadOnly Property ReinforcementCover As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ReinforcementCover {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


ReinforcementLength Property

[image]

Revit 2024 API
SpecTypeId..::..ReinforcementLength Property
SpecTypeId Class See Also Send Feedback
Reinforcement Length, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId ReinforcementLength { get; }
Visual Basic
Public Shared ReadOnly Property ReinforcementLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ReinforcementLength {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


ReinforcementSpacing Property

[image]

Revit 2024 API
SpecTypeId..::..ReinforcementSpacing Property
SpecTypeId Class See Also Send Feedback
Reinforcement Spacing, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId ReinforcementSpacing { get; }
Visual Basic
Public Shared ReadOnly Property ReinforcementSpacing As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ReinforcementSpacing {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


ReinforcementVolume Property

[image]

Revit 2024 API
SpecTypeId..::..ReinforcementVolume Property
SpecTypeId Class See Also Send Feedback
Reinforcement Volume, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId ReinforcementVolume { get; }
Visual Basic
Public Shared ReadOnly Property ReinforcementVolume As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ReinforcementVolume {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


RotationalPointSpringCoefficient Property

[image]

Revit 2024 API
SpecTypeId..::..RotationalPointSpringCoefficient Property
SpecTypeId Class See Also Send Feedback
Rotational Point Spring Coefficient, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId RotationalPointSpringCoefficient { get; }
Visual Basic
Public Shared ReadOnly Property RotationalPointSpringCoefficient As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RotationalPointSpringCoefficient {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


RotationAngle Property

[image]

Revit 2024 API
SpecTypeId..::..RotationAngle Property
SpecTypeId Class See Also Send Feedback
Rotation Angle, in discipline Common.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId RotationAngle { get; }
Visual Basic
Public Shared ReadOnly Property RotationAngle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RotationAngle {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


SectionArea Property

[image]

Revit 2024 API
SpecTypeId..::..SectionArea Property
SpecTypeId Class See Also Send Feedback
Section Area, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId SectionArea { get; }
Visual Basic
Public Shared ReadOnly Property SectionArea As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SectionArea {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


SectionDimension Property

[image]

Revit 2024 API
SpecTypeId..::..SectionDimension Property
SpecTypeId Class See Also Send Feedback
Section Dimension, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId SectionDimension { get; }
Visual Basic
Public Shared ReadOnly Property SectionDimension As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SectionDimension {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


SectionModulus Property

[image]

Revit 2024 API
SpecTypeId..::..SectionModulus Property
SpecTypeId Class See Also Send Feedback
Section Modulus, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId SectionModulus { get; }
Visual Basic
Public Shared ReadOnly Property SectionModulus As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SectionModulus {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


SheetLength Property

[image]

Revit 2024 API
SpecTypeId..::..SheetLength Property
SpecTypeId Class See Also Send Feedback
Sheet Length, in discipline Common.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId SheetLength { get; }
Visual Basic
Public Shared ReadOnly Property SheetLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SheetLength {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


SiteAngle Property

[image]

Revit 2024 API
SpecTypeId..::..SiteAngle Property
SpecTypeId Class See Also Send Feedback
Site Angle, in discipline Common.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId SiteAngle { get; }
Visual Basic
Public Shared ReadOnly Property SiteAngle As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SiteAngle {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


SpecificHeat Property

[image]

Revit 2024 API
SpecTypeId..::..SpecificHeat Property
SpecTypeId Class See Also Send Feedback
Specific Heat, in discipline Energy.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId SpecificHeat { get; }
Visual Basic
Public Shared ReadOnly Property SpecificHeat As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SpecificHeat {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


Stationing Property

[image]

Revit 2024 API
SpecTypeId..::..Stationing Property
SpecTypeId Class See Also Send Feedback
Stationing, in discipline Infrastructure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Stationing { get; }
Visual Basic
Public Shared ReadOnly Property Stationing As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Stationing {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


StationingInterval Property

[image]

Revit 2024 API
SpecTypeId..::..StationingInterval Property
SpecTypeId Class See Also Send Feedback
Stationing Interval, in discipline Infrastructure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId StationingInterval { get; }
Visual Basic
Public Shared ReadOnly Property StationingInterval As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StationingInterval {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


Stress Property

[image]

Revit 2024 API
SpecTypeId..::..Stress Property
SpecTypeId Class See Also Send Feedback
Stress, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Stress { get; }
Visual Basic
Public Shared ReadOnly Property Stress As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Stress {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


StructuralFrequency Property

[image]

Revit 2024 API
SpecTypeId..::..StructuralFrequency Property
SpecTypeId Class See Also Send Feedback
Frequency, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId StructuralFrequency { get; }
Visual Basic
Public Shared ReadOnly Property StructuralFrequency As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralFrequency {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


StructuralVelocity Property

[image]

Revit 2024 API
SpecTypeId..::..StructuralVelocity Property
SpecTypeId Class See Also Send Feedback
Velocity, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId StructuralVelocity { get; }
Visual Basic
Public Shared ReadOnly Property StructuralVelocity As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StructuralVelocity {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


SurfaceAreaPerUnitLength Property

[image]

Revit 2024 API
SpecTypeId..::..SurfaceAreaPerUnitLength Property
SpecTypeId Class See Also Send Feedback
Surface Area per Unit Length, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId SurfaceAreaPerUnitLength { get; }
Visual Basic
Public Shared ReadOnly Property SurfaceAreaPerUnitLength As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SurfaceAreaPerUnitLength {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


ThermalConductivity Property

[image]

Revit 2024 API
SpecTypeId..::..ThermalConductivity Property
SpecTypeId Class See Also Send Feedback
Thermal Conductivity, in discipline Energy.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId ThermalConductivity { get; }
Visual Basic
Public Shared ReadOnly Property ThermalConductivity As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ThermalConductivity {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


ThermalExpansionCoefficient Property

[image]

Revit 2024 API
SpecTypeId..::..ThermalExpansionCoefficient Property
SpecTypeId Class See Also Send Feedback
Thermal Expansion Coefficient, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId ThermalExpansionCoefficient { get; }
Visual Basic
Public Shared ReadOnly Property ThermalExpansionCoefficient As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ThermalExpansionCoefficient {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


ThermalGradientCoefficientForMoistureCapacity Property

[image]

Revit 2024 API
SpecTypeId..::..ThermalGradientCoefficientForMoistureCapacity Property
SpecTypeId Class See Also Send Feedback
Thermal Gradient Coefficient for Moisture Capacity, in discipline Energy.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId ThermalGradientCoefficientForMoistureCapacity { get; }
Visual Basic
Public Shared ReadOnly Property ThermalGradientCoefficientForMoistureCapacity As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ThermalGradientCoefficientForMoistureCapacity {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


ThermalMass Property

[image]

Revit 2024 API
SpecTypeId..::..ThermalMass Property
SpecTypeId Class See Also Send Feedback
Thermal Mass, in discipline Energy.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId ThermalMass { get; }
Visual Basic
Public Shared ReadOnly Property ThermalMass As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ThermalMass {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


ThermalResistance Property

[image]

Revit 2024 API
SpecTypeId..::..ThermalResistance Property
SpecTypeId Class See Also Send Feedback
Thermal Resistance, in discipline Energy.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId ThermalResistance { get; }
Visual Basic
Public Shared ReadOnly Property ThermalResistance As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ThermalResistance {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


Time Property

[image]

Revit 2024 API
SpecTypeId..::..Time Property
SpecTypeId Class See Also Send Feedback
Time, in discipline Common.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Time { get; }
Visual Basic
Public Shared ReadOnly Property Time As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Time {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


UnitWeight Property

[image]

Revit 2024 API
SpecTypeId..::..UnitWeight Property
SpecTypeId Class See Also Send Feedback
Unit Weight, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId UnitWeight { get; }
Visual Basic
Public Shared ReadOnly Property UnitWeight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ UnitWeight {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


Volume Property

[image]

Revit 2024 API
SpecTypeId..::..Volume Property
SpecTypeId Class See Also Send Feedback
Volume, in discipline Common.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Volume { get; }
Visual Basic
Public Shared ReadOnly Property Volume As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Volume {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


WarpingConstant Property

[image]

Revit 2024 API
SpecTypeId..::..WarpingConstant Property
SpecTypeId Class See Also Send Feedback
Warping Constant, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId WarpingConstant { get; }
Visual Basic
Public Shared ReadOnly Property WarpingConstant As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WarpingConstant {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


Wattage Property

[image]

Revit 2024 API
SpecTypeId..::..Wattage Property
SpecTypeId Class See Also Send Feedback
Wattage, in discipline Electrical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Wattage { get; }
Visual Basic
Public Shared ReadOnly Property Wattage As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Wattage {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


Weight Property

[image]

Revit 2024 API
SpecTypeId..::..Weight Property
SpecTypeId Class See Also Send Feedback
Weight, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Weight { get; }
Visual Basic
Public Shared ReadOnly Property Weight As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Weight {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


WireDiameter Property

[image]

Revit 2024 API
SpecTypeId..::..WireDiameter Property
SpecTypeId Class See Also Send Feedback
Wire Diameter, in discipline Electrical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId WireDiameter { get; }
Visual Basic
Public Shared ReadOnly Property WireDiameter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WireDiameter {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId Class


SpecTypeId.Boolean Class

[image]

Revit 2024 API
SpecTypeId..::..Boolean Class
SpecTypeId Class Members See Also Send Feedback
This class contains constants identifying Boolean specs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static class Boolean
Visual Basic
Public NotInheritable Class Boolean
Visual C++
public ref class Boolean abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..SpecTypeId..::..Boolean

See Also

SpecTypeId..::..Boolean Members


SpecTypeId.Boolean Members

[image] [image]

Revit 2024 API
SpecTypeId..::..Boolean Members
SpecTypeId..::..Boolean Class Properties See Also Send Feedback

This class contains constants identifying specs.

The SpecTypeId..::..Boolean type exposes the following members.

Properties

Name | Description
YesNo | Yes/No, in discipline Common.

See Also

SpecTypeId..::..Boolean Class


SpecTypeId.Boolean Properties

[image] [image]

Revit 2024 API
SpecTypeId..::..Boolean Properties
SpecTypeId..::..Boolean Class See Also Send Feedback

The SpecTypeId..::..Boolean type exposes the following members.

Properties

Name | Description
YesNo | Yes/No, in discipline Common.

See Also

SpecTypeId..::..Boolean Class


YesNo Property

[image]

Revit 2024 API
SpecTypeId..::..Boolean..::..YesNo Property
SpecTypeId..::..Boolean Class See Also Send Feedback
Yes/No, in discipline Common.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId YesNo { get; }
Visual Basic
Public Shared ReadOnly Property YesNo As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ YesNo {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId..::..Boolean Class


SpecTypeId.Int Class

[image]

Revit 2024 API
SpecTypeId..::..Int Class
SpecTypeId Class Members See Also Send Feedback
This class contains constants identifying integer specs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static class Int
Visual Basic
Public NotInheritable Class Int
Visual C++
public ref class Int abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..SpecTypeId..::..Int

See Also

SpecTypeId..::..Int Members


SpecTypeId.Int Members

[image] [image]

Revit 2024 API
SpecTypeId..::..Int Members
SpecTypeId..::..Int Class Properties See Also Send Feedback

This class contains constants identifying specs.

The SpecTypeId..::..Int type exposes the following members.

Properties

Name | Description
Integer | Integer, in discipline Common.
NumberOfPoles | Number of Poles, in discipline Electrical.

See Also

SpecTypeId..::..Int Class


SpecTypeId.Int Properties

[image] [image]

Revit 2024 API
SpecTypeId..::..Int Properties
SpecTypeId..::..Int Class See Also Send Feedback

The SpecTypeId..::..Int type exposes the following members.

Properties

Name | Description
Integer | Integer, in discipline Common.
NumberOfPoles | Number of Poles, in discipline Electrical.

See Also

SpecTypeId..::..Int Class


Integer Property

[image]

Revit 2024 API
SpecTypeId..::..Int..::..Integer Property
SpecTypeId..::..Int Class See Also Send Feedback
Integer, in discipline Common.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId Integer { get; }
Visual Basic
Public Shared ReadOnly Property Integer As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Integer {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId..::..Int Class


NumberOfPoles Property

[image]

Revit 2024 API
SpecTypeId..::..Int..::..NumberOfPoles Property
SpecTypeId..::..Int Class See Also Send Feedback
Number of Poles, in discipline Electrical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId NumberOfPoles { get; }
Visual Basic
Public Shared ReadOnly Property NumberOfPoles As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ NumberOfPoles {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId..::..Int Class


SpecTypeId.Reference Class

[image]

Revit 2024 API
SpecTypeId..::..Reference Class
SpecTypeId Class Members See Also Send Feedback
This class contains constants identifying reference specs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static class Reference
Visual Basic
Public NotInheritable Class Reference
Visual C++
public ref class Reference abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..SpecTypeId..::..Reference

See Also

SpecTypeId..::..Reference Members


SpecTypeId.Reference Members

[image] [image]

Revit 2024 API
SpecTypeId..::..Reference Members
SpecTypeId..::..Reference Class Properties See Also Send Feedback

This class contains constants identifying specs.

The SpecTypeId..::..Reference type exposes the following members.

Properties

Name | Description
FillPattern | Fill Pattern, in discipline Common.
Image | Image, in discipline Common.
LoadClassification | Load Classification, in discipline Electrical.
Material | Material, in discipline Common.

See Also

SpecTypeId..::..Reference Class


FillPattern Property

[image]

Revit 2024 API
SpecTypeId..::..Reference..::..FillPattern Property
SpecTypeId..::..Reference Class See Also Send Feedback
Fill Pattern, in discipline Common.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId FillPattern { get; }
Visual Basic
Public Shared ReadOnly Property FillPattern As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FillPattern {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId..::..Reference Class


Image Property

[image]

Revit 2024 API
SpecTypeId..::..Reference..::..Image Property
SpecTypeId..::..Reference Class See Also Send Feedback
Image, in discipline Common.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId Image { get; }
Visual Basic
Public Shared ReadOnly Property Image As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Image {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId..::..Reference Class


LoadClassification Property

[image]

Revit 2024 API
SpecTypeId..::..Reference..::..LoadClassification Property
SpecTypeId..::..Reference Class See Also Send Feedback
Load Classification, in discipline Electrical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId LoadClassification { get; }
Visual Basic
Public Shared ReadOnly Property LoadClassification As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LoadClassification {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId..::..Reference Class


SpecTypeId.String Class

[image]

Revit 2024 API
SpecTypeId..::..String Class
SpecTypeId Class Members See Also Send Feedback
This class contains constants identifying string specs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static class String
Visual Basic
Public NotInheritable Class String
Visual C++
public ref class String abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..SpecTypeId..::..String

See Also

SpecTypeId..::..String Members


SpecTypeId.String Members

[image] [image]

Revit 2024 API
SpecTypeId..::..String Members
SpecTypeId..::..String Class Properties See Also Send Feedback

This class contains constants identifying specs.

The SpecTypeId..::..String type exposes the following members.

Properties

Name | Description
MultilineText | Multiline Text, in discipline Common.
Text | Text, in discipline Common.
Url | URL, in discipline Common.

See Also

SpecTypeId..::..String Class


MultilineText Property

[image]

Revit 2024 API
SpecTypeId..::..String..::..MultilineText Property
SpecTypeId..::..String Class See Also Send Feedback
Multiline Text, in discipline Common.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId MultilineText { get; }
Visual Basic
Public Shared ReadOnly Property MultilineText As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MultilineText {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId..::..String Class


Text Property

[image]

Revit 2024 API
SpecTypeId..::..String..::..Text Property
SpecTypeId..::..String Class See Also Send Feedback
Text, in discipline Common.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId Text { get; }
Visual Basic
Public Shared ReadOnly Property Text As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Text {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId..::..String Class


Url Property

[image]

Revit 2024 API
SpecTypeId..::..String..::..Url Property
SpecTypeId..::..String Class See Also Send Feedback
URL, in discipline Common.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ForgeTypeId Url { get; }
Visual Basic
Public Shared ReadOnly Property Url As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Url {
    ForgeTypeId^ get ();
}

See Also

SpecTypeId..::..String Class


SpecUtils Class

[image]

Revit 2024 API
SpecUtils Class
Members See Also Send Feedback
A utility class of functions related to specs. A spec describes a data type that parameters can hold.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public static class SpecUtils
Visual Basic
Public NotInheritable Class SpecUtils
Visual C++
public ref class SpecUtils abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..SpecUtils

See Also

SpecUtils Members


SpecUtils Members

[image] [image]

Revit 2024 API
SpecUtils Members
SpecUtils Class Methods See Also Send Feedback

The SpecUtils type exposes the following members.

Methods

Name | Description
GetAllSpecs | Gets the identifiers of all specs.
IsSpec | Checks whether a ForgeTypeId identifies a spec.
IsValidDataType | Returns true if the given ForgeTypeId identifies a valid parameter data type.

See Also

SpecUtils Class


SpecUtils Methods

[image] [image]

Revit 2024 API
SpecUtils Methods
SpecUtils Class See Also Send Feedback

The SpecUtils type exposes the following members.

Methods

Name | Description
GetAllSpecs | Gets the identifiers of all specs.
IsSpec | Checks whether a ForgeTypeId identifies a spec.
IsValidDataType | Returns true if the given ForgeTypeId identifies a valid parameter data type.

See Also

SpecUtils Class


GetAllSpecs Method

[image]

Revit 2024 API
SpecUtils..::..GetAllSpecs Method
SpecUtils Class See Also Send Feedback
Gets the identifiers of all specs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public static IList<ForgeTypeId> GetAllSpecs()
Visual Basic
Public Shared Function GetAllSpecs As IList(Of ForgeTypeId)
Visual C++
public:
static IList<ForgeTypeId^>^ GetAllSpecs()

Return Value

The spec identifiers.

See Also

SpecUtils Class


IsSpec Method

[image]

Revit 2024 API
SpecUtils..::..IsSpec Method
SpecUtils Class See Also Send Feedback
Checks whether a ForgeTypeId identifies a spec.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public static bool IsSpec(
    ForgeTypeId specTypeId
)
Visual Basic
Public Shared Function IsSpec ( _
    specTypeId As ForgeTypeId _
) As Boolean
Visual C++
public:
static bool IsSpec(
    ForgeTypeId^ specTypeId
)

Parameters

specTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
The identifier to check.

Return Value

True if the ForgeTypeId identifies a spec, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

SpecUtils Class


SpotDimension Members

[image] [image]

Revit 2024 API
SpotDimension Members
SpotDimension Class Methods Properties See Also Send Feedback

The SpotDimension type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanFlip | Verifies that the direction of the dimension can be flipped.
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | Flip | Flips dimension to the other side of the host.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasOneSegment | Determines whether a dimension has one segment. (Inherited from Dimension.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsTextPositionAdjustable | Indicates if this dimension is supported to set/get TextPosition/LeaderEndPosition. (Inherited from Dimension.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | ResetTextPosition | Resets the text position of the dimension to the initial position determined by its type and parameters. (Inherited from Dimension.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Above | The text shown above the segment's value. (Inherited from Dimension.)
Public property | AreReferencesAvailable | Indicates if this dimension's references can be resolved. (Inherited from Dimension.)
Public property | AreSegmentsEqual | Indicates if all segments are forced to be equal. (Inherited from Dimension.)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | Below | The text shown below the segment's value. (Inherited from Dimension.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | Curve | A curve that represents the dimension line. (Inherited from Dimension.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DimensionShape | The shape of this dimension. (Inherited from Dimension.)
Public property | DimensionType | The dimension style of this dimension. (Inherited from Dimension.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyLabel | The family parameter label of the dimension. (Inherited from Dimension.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | HasLeader | True if dimension has leader, false otherwise. (Inherited from Dimension.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsLocked | Indicates if this dimension is locked. (Inherited from Dimension.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValid | Indicates if this dimension is valid. (Inherited from Dimension.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LeaderEndPosition | The position of the dimension's leader end point. (Inherited from Dimension.)
Public property | LeaderHasShoulder | True is dimension has leader with shoulder, false otherwise.
Public property | LeaderShoulderPosition | Position of spot dimension's leader shoulder point.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Retrieves or changes the name associated with the Dimension. (Inherited from Dimension.)
Public property | NumberOfSegments | The number of segments for the dimension. (Inherited from Dimension.)
Public property | Origin | The dimension origin. (Inherited from Dimension.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Prefix | The text shown before the segment's value. (Inherited from Dimension.)
Public property | References | Returns an array of geometric references to which the dimension is attached. (Inherited from Dimension.)
Public property | Segments | The segments in the dimension. (Inherited from Dimension.)
Public property | SpotDimensionType | The dimension style of this dimension.
Public property | Suffix | The text shown after the segment's value. (Inherited from Dimension.)
Public property | TextPosition | The position of the dimension text's drag point. (Inherited from Dimension.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | Value | The value of the dimension. (Inherited from Dimension.)
Public property | ValueOverride | The text that replaces the segment's value. (Inherited from Dimension.)
Public property | ValueString | The dimension value as a user visible string. (Inherited from Dimension.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | View | Supplies the view that contains the dimension if the dimension is view specific. (Inherited from Dimension.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SpotDimension Class


SpotDimension Methods

[image] [image]

Revit 2024 API
SpotDimension Methods
SpotDimension Class See Also Send Feedback

The SpotDimension type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanFlip | Verifies that the direction of the dimension can be flipped.
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | Flip | Flips dimension to the other side of the host.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasOneSegment | Determines whether a dimension has one segment. (Inherited from Dimension.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsTextPositionAdjustable | Indicates if this dimension is supported to set/get TextPosition/LeaderEndPosition. (Inherited from Dimension.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | ResetTextPosition | Resets the text position of the dimension to the initial position determined by its type and parameters. (Inherited from Dimension.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SpotDimension Class


CanFlip Method

[image]

Revit 2024 API
SpotDimension..::..CanFlip Method
SpotDimension Class See Also Send Feedback
Verifies that the direction of the dimension can be flipped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021.2

Syntax

C#
public bool CanFlip()
Visual Basic
Public Function CanFlip As Boolean
Visual C++
public:
bool CanFlip()

Return Value

True if the element can be flipped, false otherwise.

Remarks

Currently, flipping only allowed for non-pinned AlignmentStationLabels.

See Also

SpotDimension Class


SpotDimension Properties

[image] [image]

Revit 2024 API
SpotDimension Properties
SpotDimension Class See Also Send Feedback

The SpotDimension type exposes the following members.

Properties

 | Name | Description
Public property | Above | The text shown above the segment's value. (Inherited from Dimension.)
Public property | AreReferencesAvailable | Indicates if this dimension's references can be resolved. (Inherited from Dimension.)
Public property | AreSegmentsEqual | Indicates if all segments are forced to be equal. (Inherited from Dimension.)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | Below | The text shown below the segment's value. (Inherited from Dimension.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | Curve | A curve that represents the dimension line. (Inherited from Dimension.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DimensionShape | The shape of this dimension. (Inherited from Dimension.)
Public property | DimensionType | The dimension style of this dimension. (Inherited from Dimension.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyLabel | The family parameter label of the dimension. (Inherited from Dimension.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | HasLeader | True if dimension has leader, false otherwise. (Inherited from Dimension.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsLocked | Indicates if this dimension is locked. (Inherited from Dimension.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValid | Indicates if this dimension is valid. (Inherited from Dimension.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LeaderEndPosition | The position of the dimension's leader end point. (Inherited from Dimension.)
Public property | LeaderHasShoulder | True is dimension has leader with shoulder, false otherwise.
Public property | LeaderShoulderPosition | Position of spot dimension's leader shoulder point.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Retrieves or changes the name associated with the Dimension. (Inherited from Dimension.)
Public property | NumberOfSegments | The number of segments for the dimension. (Inherited from Dimension.)
Public property | Origin | The dimension origin. (Inherited from Dimension.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Prefix | The text shown before the segment's value. (Inherited from Dimension.)
Public property | References | Returns an array of geometric references to which the dimension is attached. (Inherited from Dimension.)
Public property | Segments | The segments in the dimension. (Inherited from Dimension.)
Public property | SpotDimensionType | The dimension style of this dimension.
Public property | Suffix | The text shown after the segment's value. (Inherited from Dimension.)
Public property | TextPosition | The position of the dimension text's drag point. (Inherited from Dimension.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | Value | The value of the dimension. (Inherited from Dimension.)
Public property | ValueOverride | The text that replaces the segment's value. (Inherited from Dimension.)
Public property | ValueString | The dimension value as a user visible string. (Inherited from Dimension.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | View | Supplies the view that contains the dimension if the dimension is view specific. (Inherited from Dimension.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SpotDimension Class


LeaderHasShoulder Property

[image]

Revit 2024 API
SpotDimension..::..LeaderHasShoulder Property
SpotDimension Class See Also Send Feedback
True is dimension has leader with shoulder, false otherwise.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021.1

Syntax

C#
public bool LeaderHasShoulder { get; set; }
Visual Basic
Public Property LeaderHasShoulder As Boolean
    Get
    Set
Visual C++
public:
property bool LeaderHasShoulder {
    bool get ();
    void set (bool value);
}

Exceptions

Exception Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException Dimension must have leader. -or- Thrown when:
  • SpotDimension style type is SpotSlope.
  • Using equality formula.
  • Dimension style is ordinate.
-or- The dimension is a SpotSlope or has no leader.

See Also

SpotDimension Class


Parameter Property

[image] [image]

Revit 2024 API
SpotDimension..::..Parameter Property
SpotDimension Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

SpotDimension Class
SpotDimension Members


SpotDimensionType Class

[image]

Revit 2024 API
SpotDimensionType Class
Members See Also Send Feedback
A type element containing the properties of a spot elevation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class SpotDimensionType : DimensionType
Visual Basic
Public Class SpotDimensionType _
    Inherits DimensionType
Visual C++
public ref class SpotDimensionType : public DimensionType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..DimensionType
Autodesk.Revit.DB..::..SpotDimensionType

See Also

SpotDimensionType Members


SpotDimensionType Members

[image] [image]

Revit 2024 API
SpotDimensionType Members
SpotDimensionType Class Methods Properties See Also Send Feedback

The SpotDimensionType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveEqualityFormula | Checks whether this DimensionType can have an equality formula. (Inherited from DimensionType.)
Public method | CanHaveOrdinateDimensionSetting | Checks whether this DimensionType can have an ordinate dimension settings. (Inherited from DimensionType.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetAlternateUnitsFormatOptions | Gets the FormatOptions to optionally override the default settings in the Units class for the alternate units value. (Inherited from DimensionType.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetEqualityFormula | Gets an ordered list of the entries in the equality formula definition. (Inherited from DimensionType.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetOrdinateDimensionSetting | Gets the ordinate dimension settings for this DimensionType. (Inherited from DimensionType.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSpecTypeId | Gets the spec of this dimension style. (Inherited from DimensionType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetUnitsFormatOptions | Gets the FormatOptions to optionally override the default settings in the Units class for the units value. (Inherited from DimensionType.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetAlternateUnitsFormatOptions | Sets the FormatOptions to optionally override the default settings in the Units class for the alternate units value. (Inherited from DimensionType.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetEqualityFormula | Sets an ordered list of the entries to use in the equality formula definition. (Inherited from DimensionType.)
Public method | SetOrdinateDimensionSetting | Sets the ordinate dimension settings for this DimensionType. (Inherited from DimensionType.)
Public method | SetUnitsFormatOptions | Sets the FormatOptions to optionally override the default settings in the Units class for the units value. (Inherited from DimensionType.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AlternateUnits | The alternate units display mode for this DimensionType. (Inherited from DimensionType.)
Public property | AlternateUnitsPrefix | The prefix text for the alternate units value. (Inherited from DimensionType.)
Public property | AlternateUnitsSuffix | The suffix text for the alternate units value. (Inherited from DimensionType.)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Prefix | The prefix text for the dimension value. (Inherited from DimensionType.)
Public property | StyleType | The dimension style type of this DimensionType. (Inherited from DimensionType.)
Public property | Suffix | The suffix text for the dimension value. (Inherited from DimensionType.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SpotDimensionType Class


SpotDimensionType Methods

[image] [image]

Revit 2024 API
SpotDimensionType Methods
SpotDimensionType Class See Also Send Feedback

The SpotDimensionType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveEqualityFormula | Checks whether this DimensionType can have an equality formula. (Inherited from DimensionType.)
Public method | CanHaveOrdinateDimensionSetting | Checks whether this DimensionType can have an ordinate dimension settings. (Inherited from DimensionType.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetAlternateUnitsFormatOptions | Gets the FormatOptions to optionally override the default settings in the Units class for the alternate units value. (Inherited from DimensionType.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetEqualityFormula | Gets an ordered list of the entries in the equality formula definition. (Inherited from DimensionType.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetOrdinateDimensionSetting | Gets the ordinate dimension settings for this DimensionType. (Inherited from DimensionType.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSpecTypeId | Gets the spec of this dimension style. (Inherited from DimensionType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetUnitsFormatOptions | Gets the FormatOptions to optionally override the default settings in the Units class for the units value. (Inherited from DimensionType.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetAlternateUnitsFormatOptions | Sets the FormatOptions to optionally override the default settings in the Units class for the alternate units value. (Inherited from DimensionType.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetEqualityFormula | Sets an ordered list of the entries to use in the equality formula definition. (Inherited from DimensionType.)
Public method | SetOrdinateDimensionSetting | Sets the ordinate dimension settings for this DimensionType. (Inherited from DimensionType.)
Public method | SetUnitsFormatOptions | Sets the FormatOptions to optionally override the default settings in the Units class for the units value. (Inherited from DimensionType.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SpotDimensionType Class


Parameter Property

[image] [image]

Revit 2024 API
SpotDimensionType..::..Parameter Property
SpotDimensionType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

SpotDimensionType Class
SpotDimensionType Members


SSEPointVisibilitySettings Class

[image]

Revit 2024 API
SSEPointVisibilitySettings Class
Members See Also Send Feedback
Represents the settings contained in the document associated to the point display of Floor, Roof and Toposolid. for serialization public api methods

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public class SSEPointVisibilitySettings : Element
Visual Basic
Public Class SSEPointVisibilitySettings _
    Inherits Element
Visual C++
public ref class SSEPointVisibilitySettings : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..SSEPointVisibilitySettings

See Also

SSEPointVisibilitySettings Members


SSEPointVisibilitySettings Members

[image] [image]

Revit 2024 API
SSEPointVisibilitySettings Members
SSEPointVisibilitySettings Class Methods Properties See Also Send Feedback

The SSEPointVisibilitySettings type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
 | GetVisibility | Gets the SSE point visibility for the given category.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
 | SetVisibility | Sets the SSE point visibility for the given category.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SSEPointVisibilitySettings Class


SSEPointVisibilitySettings Methods

[image] [image]

Revit 2024 API
SSEPointVisibilitySettings Methods
SSEPointVisibilitySettings Class See Also Send Feedback

The SSEPointVisibilitySettings type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
 | GetVisibility | Gets the SSE point visibility for the given category.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
 | SetVisibility | Sets the SSE point visibility for the given category.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SSEPointVisibilitySettings Class


SetVisibility Method

[image]

Revit 2024 API
SSEPointVisibilitySettings..::..SetVisibility Method
SSEPointVisibilitySettings Class See Also Send Feedback
Sets the SSE point visibility for the given category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static void SetVisibility(
    Document document,
    ElementId categoryId,
    bool isVisible
)
Visual Basic
Public Shared Sub SetVisibility ( _
    document As Document, _
    categoryId As ElementId, _
    isVisible As Boolean _
)
Visual C++
public:
static void SetVisibility(
    Document^ document,
    ElementId^ categoryId,
    bool isVisible
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
categoryId
Type: Autodesk.Revit.DB..::..ElementId
The category id.
isVisible
Type: System..::..Boolean
The visibility of the given category. True means the SSE points are visible.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The category is not valid for SSE.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

SSEPointVisibilitySettings Class


SSEPointVisibilitySettings Properties

[image] [image]

Revit 2024 API
SSEPointVisibilitySettings Properties
SSEPointVisibilitySettings Class See Also Send Feedback

The SSEPointVisibilitySettings type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SSEPointVisibilitySettings Class


Parameter Property

[image] [image]

Revit 2024 API
SSEPointVisibilitySettings..::..Parameter Property
SSEPointVisibilitySettings Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

SSEPointVisibilitySettings Class
SSEPointVisibilitySettings Members


StairsEditScope Class

[image]

Revit 2024 API
StairsEditScope Class
Members Example See Also Send Feedback
StairsEditScope allows user to maintain a stairs-editing session.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public class StairsEditScope : EditScope
Visual Basic
Public Class StairsEditScope _
    Inherits EditScope
Visual C++
public ref class StairsEditScope : public EditScope

Remarks

Start/end of a StairsEditScope will start/end a transaction group. After a StairsEditScope is started, user can start transactions and edit the stairs. Individual transactions the user creates inside StairsEditScope will not appear in the undo menu. All transactions committed during the edit mode will be merged into a single one which will bear the given name passed into StairsEditScope constructor.

Examples

CopyC#
private ElementId CreateStairs(Document document, Level levelBottom, Level levelTop)
{
    ElementId newStairsId = null;

    using (StairsEditScope newStairsScope = new StairsEditScope(document, "New Stairs"))
    {
        newStairsId = newStairsScope.Start(levelBottom.Id, levelTop.Id);

        using (Transaction stairsTrans = new Transaction(document, "Add Runs and Landings to Stairs"))
        {
            stairsTrans.Start();

            // Create a sketched run for the stairs
            IList<Curve> bdryCurves = new List<Curve>();
            IList<Curve> riserCurves = new List<Curve>();
            IList<Curve> pathCurves = new List<Curve>();
            XYZ pnt1 = new XYZ(0, 0, 0);
            XYZ pnt2 = new XYZ(15, 0, 0);
            XYZ pnt3 = new XYZ(0, 10, 0);
            XYZ pnt4 = new XYZ(15, 10, 0);

            // boundaries
            bdryCurves.Add(Line.CreateBound(pnt1, pnt2));
            bdryCurves.Add(Line.CreateBound(pnt3, pnt4));

            // riser curves
            const int riserNum = 20;
            for (int ii = 0; ii <= riserNum; ii++)
            {
                XYZ end0 = (pnt1 + pnt2) * ii / (double)riserNum;
                XYZ end1 = (pnt3 + pnt4) * ii / (double)riserNum;
                XYZ end2 = new XYZ(end1.X, 10, 0);
                riserCurves.Add(Line.CreateBound(end0, end2));
            }

            //stairs path curves
            XYZ pathEnd0 = (pnt1 + pnt3) / 2.0;
            XYZ pathEnd1 = (pnt2 + pnt4) / 2.0;
            pathCurves.Add(Line.CreateBound(pathEnd0, pathEnd1));

            StairsRun newRun1 = StairsRun.CreateSketchedRun(document, newStairsId, levelBottom.Elevation, bdryCurves, riserCurves, pathCurves);

            // Add a straight run
            Line locationLine = Line.CreateBound(new XYZ(20, -5, newRun1.TopElevation), new XYZ(35, -5, newRun1.TopElevation));
            StairsRun newRun2 = StairsRun.CreateStraightRun(document, newStairsId, locationLine, StairsRunJustification.Center);
            newRun2.ActualRunWidth = 10;

            // Add a landing between the runs
            CurveLoop landingLoop = new CurveLoop();
            XYZ p1 = new XYZ(15, 10, 0);
            XYZ p2 = new XYZ(20, 10, 0);
            XYZ p3 = new XYZ(20, -10, 0);
            XYZ p4 = new XYZ(15, -10, 0);
            Line curve_1 = Line.CreateBound(p1, p2);
            Line curve_2 = Line.CreateBound(p2, p3);
            Line curve_3 = Line.CreateBound(p3, p4);
            Line curve_4 = Line.CreateBound(p4, p1);

            landingLoop.Append(curve_1);
            landingLoop.Append(curve_2);
            landingLoop.Append(curve_3);
            landingLoop.Append(curve_4);
            StairsLanding newLanding = StairsLanding.CreateSketchedLanding(document, newStairsId, landingLoop, newRun1.TopElevation);

            stairsTrans.Commit();
        }
        // A failure preprocessor is to handle possible failures during the edit mode commitment process.
        newStairsScope.Commit(new StairsFailurePreprocessor());
    }

    return newStairsId;
}
CopyVB.NET
Private Function CreateStairs(document As Document, levelBottom As Level, levelTop As Level) As ElementId
    Dim newStairsId As ElementId = Nothing

    Using newStairsScope As New StairsEditScope(document, "New Stairs")
        newStairsId = newStairsScope.Start(levelBottom.Id, levelTop.Id)

        Using stairsTrans As New Transaction(document, "Add Runs and Landings to Stairs")
            stairsTrans.Start()

            ' Create a sketched run for the stairs
            Dim bdryCurves As IList(Of Curve) = New List(Of Curve)()
            Dim riserCurves As IList(Of Curve) = New List(Of Curve)()
            Dim pathCurves As IList(Of Curve) = New List(Of Curve)()
            Dim pnt1 As New XYZ(0, 0, 0)
            Dim pnt2 As New XYZ(15, 0, 0)
            Dim pnt3 As New XYZ(0, 10, 0)
            Dim pnt4 As New XYZ(15, 10, 0)

            ' boundaries
            bdryCurves.Add(Line.CreateBound(pnt1, pnt2))
            bdryCurves.Add(Line.CreateBound(pnt3, pnt4))

            ' riser curves
            Const riserNum As Integer = 20
            For ii As Integer = 0 To riserNum
                Dim end0 As XYZ = (pnt1 + pnt2) * ii / CDbl(riserNum)
                Dim end1 As XYZ = (pnt3 + pnt4) * ii / CDbl(riserNum)
                Dim end2 As New XYZ(end1.X, 10, 0)
                riserCurves.Add(Line.CreateBound(end0, end2))
            Next

            'stairs path curves
            Dim pathEnd0 As XYZ = (pnt1 + pnt3) / 2.0
            Dim pathEnd1 As XYZ = (pnt2 + pnt4) / 2.0
            pathCurves.Add(Line.CreateBound(pathEnd0, pathEnd1))

            Dim newRun1 As StairsRun = StairsRun.CreateSketchedRun(document, newStairsId, levelBottom.Elevation, bdryCurves, riserCurves, pathCurves)

            ' Add a straight run
            Dim locationLine As Line = Line.CreateBound(New XYZ(20, -5, newRun1.TopElevation), New XYZ(35, -5, newRun1.TopElevation))
            Dim newRun2 As StairsRun = StairsRun.CreateStraightRun(document, newStairsId, locationLine, StairsRunJustification.Center)
            newRun2.ActualRunWidth = 10

            ' Add a landing between the runs
            Dim landingLoop As New CurveLoop()
            Dim p1 As New XYZ(15, 10, 0)
            Dim p2 As New XYZ(20, 10, 0)
            Dim p3 As New XYZ(20, -10, 0)
            Dim p4 As New XYZ(15, -10, 0)
            Dim curve_1 As Line = Line.CreateBound(p1, p2)
            Dim curve_2 As Line = Line.CreateBound(p2, p3)
            Dim curve_3 As Line = Line.CreateBound(p3, p4)
            Dim curve_4 As Line = Line.CreateBound(p4, p1)

            landingLoop.Append(curve_1)
            landingLoop.Append(curve_2)
            landingLoop.Append(curve_3)
            landingLoop.Append(curve_4)
            Dim newLanding As StairsLanding = StairsLanding.CreateSketchedLanding(document, newStairsId, landingLoop, newRun1.TopElevation)

            stairsTrans.Commit()
        End Using
        ' A failure preprocessor is to handle possible failures during the edit mode commitment process.
        newStairsScope.Commit(New StairsFailurePreprocessor())
    End Using

    Return newStairsId
End Function

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..EditScope
Autodesk.Revit.DB..::..StairsEditScope

See Also

StairsEditScope Members


StairsEditScope Members

[image] [image]

Revit 2024 API
StairsEditScope Members
StairsEditScope Class Constructors Methods Properties See Also Send Feedback

The StairsEditScope type exposes the following members.

Constructors

 | Name | Description
Public method | StairsEditScope | Instantiates a StairsEditScope object.

Methods

 | Name | Description
Public method | Cancel | Cancels the edit scope. (Inherited from EditScope.)
Public method | Commit | Finishes the edit scope. (Inherited from EditScope.)
Public method | Dispose | (Inherited from EditScope.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Start(ElementId) | Starts an stairs edit mode for an existing Stairs element
Public method | Start(ElementId, ElementId) | Creates a new empty stairs element with a default stairs type in the specified levels and then starts stairs edit mode and editing the new stairs.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsActive | Tells if the EditScope is active. In other words, the EditScope has started but not committed/canceled yet. (Inherited from EditScope.)
Public property | IsPermitted | Tells if the edit scope is permitted to start. (Inherited from EditScope.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from EditScope.)

See Also

StairsEditScope Class


StairsEditScope Constructor

[image]

Revit 2024 API
StairsEditScope Constructor
StairsEditScope Class See Also Send Feedback
Instantiates a StairsEditScope object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public StairsEditScope(
    Document document,
    string transactionName
)
Visual Basic
Public Sub New ( _
    document As Document, _
    transactionName As String _
)
Visual C++
public:
StairsEditScope(
    Document^ document,
    String^ transactionName
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document for which this StairsEditScope is going to be used.
transactionName
Type: System..::..String
The name that will appear in the Undo menu in Revit after the StairsEditScope is successfully committed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a primary document, it is a linked document. -or- document is not a project document. -or- transactionName is an empty string.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

StairsEditScope Class


StairsEditScope Methods

[image] [image]

Revit 2024 API
StairsEditScope Methods
StairsEditScope Class See Also Send Feedback

The StairsEditScope type exposes the following members.

Methods

 | Name | Description
Public method | Cancel | Cancels the edit scope. (Inherited from EditScope.)
Public method | Commit | Finishes the edit scope. (Inherited from EditScope.)
Public method | Dispose | (Inherited from EditScope.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Start(ElementId) | Starts an stairs edit mode for an existing Stairs element
Public method | Start(ElementId, ElementId) | Creates a new empty stairs element with a default stairs type in the specified levels and then starts stairs edit mode and editing the new stairs.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

StairsEditScope Class


Start Method (ElementId)

[image]

Revit 2024 API
StairsEditScope..::..Start Method (ElementId)
StairsEditScope Class See Also Send Feedback
Starts an stairs edit mode for an existing Stairs element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ElementId Start(
    ElementId stairsId
)
Visual Basic
Public Function Start ( _
    stairsId As ElementId _
) As ElementId
Visual C++
public:
ElementId^ Start(
    ElementId^ stairsId
)

Parameters

stairsId
Type: Autodesk.Revit.DB..::..ElementId
The stairs element to be edited.

Return Value

ElementId of the editing stairs. It should be the same as the input stairsId

Remarks

User will need to start a transaction to actually make changes to the stairs element. StairsEditScope can only be started when there is no transaction active Thus it does not work for commands running in automatic transaction mode.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | It is not a Stair's id. -or- Stairs is not permitted to edit at this moment for the following reason: The Stairs is in an ElementGroup and it is not in Edit Group Mode.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This StairsEditScope is not permitted to start at this moment for one of the following possible reasons: The document is in read-only state, or the document is currently modifiable, or there already is another edit mode active in the document.

See Also

StairsEditScope Class
Start Overload


Start Method (ElementId, ElementId)

[image]

Revit 2024 API
StairsEditScope..::..Start Method (ElementId, ElementId)
StairsEditScope Class See Also Send Feedback
Creates a new empty stairs element with a default stairs type in the specified levels and then starts stairs edit mode and editing the new stairs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ElementId Start(
    ElementId baseLevelId,
    ElementId topLevelId
)
Visual Basic
Public Function Start ( _
    baseLevelId As ElementId, _
    topLevelId As ElementId _
) As ElementId
Visual C++
public:
ElementId^ Start(
    ElementId^ baseLevelId,
    ElementId^ topLevelId
)

Parameters

baseLevelId
Type: Autodesk.Revit.DB..::..ElementId
The base level on which the stairs is to be placed.
topLevelId
Type: Autodesk.Revit.DB..::..ElementId
The top level where the stairs is to reach.

Return Value

ElementId of the new stairs.

Remarks

A new stairs will be created after this operation. User will need to start a transaction to actually make changes to the stairs element. StairsEditScope can only be started when there is no transaction active Thus it does not work for commands running in automatic transaction mode.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | It is not a Level's id. -or- Top level should be higher than base level.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This StairsEditScope is not permitted to start at this moment for one of the following possible reasons: The document is in read-only state, or the document is currently modifiable, or there already is another edit mode active in the document.

See Also

StairsEditScope Class
Start Overload


StairsEditScope Properties

[image] [image]

Revit 2024 API
StairsEditScope Properties
StairsEditScope Class See Also Send Feedback

The StairsEditScope type exposes the following members.

Properties

 | Name | Description
Public property | IsActive | Tells if the EditScope is active. In other words, the EditScope has started but not committed/canceled yet. (Inherited from EditScope.)
Public property | IsPermitted | Tells if the edit scope is permitted to start. (Inherited from EditScope.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from EditScope.)

See Also

StairsEditScope Class


StartingViewSettings Class

[image]

Revit 2024 API
StartingViewSettings Class
Members See Also Send Feedback
The initial view settings for a document dictate which view will initially be open when this model is opened. These settings are available for all Revit project documents.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public class StartingViewSettings : Element
Visual Basic
Public Class StartingViewSettings _
    Inherits Element
Visual C++
public ref class StartingViewSettings : public Element

Remarks

If worksharing is enabled, the same settings will be used by the central model and all local files and the settings will live in the Project Info workset.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..StartingViewSettings

See Also

StartingViewSettings Members


StartingViewSettings Methods

[image] [image]

Revit 2024 API
StartingViewSettings Methods
StartingViewSettings Class See Also Send Feedback

The StartingViewSettings type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
 | GetStartingViewSettings | Returns the starting view settings for the specified document.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsAcceptableStartingView | Checks whether the given Id is an acceptable starting view. InvalidElementId corresponds to "Last Viewed" and is therefore also acceptable.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

StartingViewSettings Class


GetStartingViewSettings Method

[image]

Revit 2024 API
StartingViewSettings..::..GetStartingViewSettings Method
StartingViewSettings Class See Also Send Feedback
Returns the starting view settings for the specified document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static StartingViewSettings GetStartingViewSettings(
    Document doc
)
Visual Basic
Public Shared Function GetStartingViewSettings ( _
    doc As Document _
) As StartingViewSettings
Visual C++
public:
static StartingViewSettings^ GetStartingViewSettings(
    Document^ doc
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The document to get the settings from, which must be a project document.

Return Value

The starting view settings for the document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | doc is not a project document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

StartingViewSettings Class


IsAcceptableStartingView Method

[image]

Revit 2024 API
StartingViewSettings..::..IsAcceptableStartingView Method
StartingViewSettings Class See Also Send Feedback
Checks whether the given Id is an acceptable starting view. InvalidElementId corresponds to "Last Viewed" and is therefore also acceptable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public bool IsAcceptableStartingView(
    ElementId viewId
)
Visual Basic
Public Function IsAcceptableStartingView ( _
    viewId As ElementId _
) As Boolean
Visual C++
public:
bool IsAcceptableStartingView(
    ElementId^ viewId
)

Parameters

viewId
Type: Autodesk.Revit.DB..::..ElementId
The Id of the element to check.

Return Value

True if the view is acceptable, False if it is not.

Remarks

Model views (such as plans, ceiling plans, sections, elevations, and 3d views) are acceptable. In addition, drafting views, sheets, legends, schedules, and graphical column schedules are generally acceptable. Special views such as the project browser, system navigator, reports, revision schedules, internal schedules, sheets that are not actually in use, and views that belong to a family are not acceptable.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

StartingViewSettings Class


StartingViewSettings Properties

[image] [image]

Revit 2024 API
StartingViewSettings Properties
StartingViewSettings Class See Also Send Feedback

The StartingViewSettings type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewId | Indicates the specific view that will be opened when the model is loaded. InvalidElementId indicates that no view has been specified. In that case, Revit will open the last views that were open at the time the file was saved.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

StartingViewSettings Class


Parameter Property

[image] [image]

Revit 2024 API
StartingViewSettings..::..Parameter Property
StartingViewSettings Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

StartingViewSettings Class
StartingViewSettings Members


StdPostedWarning Class

[image]

Revit 2024 API
StdPostedWarning Class
Members See Also Send Feedback
Support for Reviewable Warnings sent from AddOn.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019

Syntax

C#
public class StdPostedWarning : IDisposable
Visual Basic
Public Class StdPostedWarning _
    Implements IDisposable
Visual C++
public ref class StdPostedWarning : IDisposable

Remarks

Used to create and send Reviewable Warning from AddOn.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..StdPostedWarning

See Also

StdPostedWarning Members


StdPostedWarning Members

[image] [image]

Revit 2024 API
StdPostedWarning Members
StdPostedWarning Class Methods Properties See Also Send Feedback

The StdPostedWarning type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the StdPostedWarning
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

StdPostedWarning Class


StdPostedWarning Methods

[image] [image]

Revit 2024 API
StdPostedWarning Methods
StdPostedWarning Class See Also Send Feedback

The StdPostedWarning type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

StdPostedWarning Class


StdPostedWarning Properties

[image] [image]

Revit 2024 API
StdPostedWarning Properties
StdPostedWarning Class See Also Send Feedback

The StdPostedWarning type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

StdPostedWarning Class


IsValidObject Property

[image]

Revit 2024 API
StdPostedWarning..::..IsValidObject Property
StdPostedWarning Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

StdPostedWarning Class


StiffenerClassification Enumeration

[image]

Revit 2024 API
StiffenerClassification Enumeration
See Also Send Feedback
This enumeration is used to classify the stiffener.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public enum StiffenerClassification
Visual Basic
Public Enumeration StiffenerClassification
Visual C++
public enum class StiffenerClassification

Members

Member name | Description
External |
Internal |

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


STLExportOptions Class

[image]

Revit 2024 API
STLExportOptions Class
Members See Also Send Feedback
The export options used by exporting STL format file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021.1

Syntax

C#
public class STLExportOptions : BIMExportOptions
Visual Basic
Public Class STLExportOptions _
    Inherits BIMExportOptions
Visual C++
public ref class STLExportOptions : public BIMExportOptions

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BIMExportOptions
Autodesk.Revit.DB..::..STLExportOptions

See Also

STLExportOptions Members


STLExportOptions Members

[image] [image]

Revit 2024 API
STLExportOptions Members
STLExportOptions Class Constructors Methods Properties See Also Send Feedback

The STLExportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | STLExportOptions()()()() | Constructs a new instance of STLExportOptions with default values of all properties.
Public method | STLExportOptions(ExportResolution) | Constructs a new instance of STLExportOptions with all predefined tessellation settings, depending on export resolution type. Note: in case of Custom resolution type, tessellation settings won't be predefined and will have default values.

Methods

 | Name | Description
Public method | Dispose | (Inherited from BIMExportOptions.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsGridAspectRatioSet | Checks whether the GridAspectRatio tessellation parameter is explicitly set.
Public method | IsMaxEdgeLengthSet | Checks whether the MaxEdgeLength tessellation parameter is explicitly set.
Public method | IsNormalToleranceSet | Checks whether the NormalTolerance tessellation parameter is explicitly set.
Public method | IsSurfaceToleranceSet | Checks whether the SurfaceTolerance tessellation parameter is explicitly set.
 | IsValidForGridAspectRatio | Checks whether the value is allowed (is in the allowed range) for GridAspectRatio tessellation parameter.
 | IsValidForMaxEdgeLength | Checks whether the value is allowed (is in the allowed range) for MaxEdgeLength tessellation parameter.
 | IsValidForNormalTolerance | Checks whether the value is allowed (is in the allowed range) for NormalTolerance tessellation parameter.
 | IsValidForSurfaceTolerance | Checks whether the value is allowed (is in the allowed range) for SurfaceTolerance tessellation parameter.
Public method | SetTessellationSettings | Sets all the tessellation parameters to its predefined values for the given resolution type.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ExportBinary | True to export in binary STL format, false to export in ASCII STL format. Default value is true.
Public property | ExportColor | True to export color information, false otherwise. Default value is false.
Public property | GridAspectRatio | The maximum aspect ratio allowed in the grid placed across the face. The minimum allowed value is 1.0. The maximum allowed value is 10.0. By default this property is ignored.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BIMExportOptions.)
Public property | MaxEdgeLength | The maximum length allowed for any chord on an edge or between any two adjacent grid lines. This is a percentage value. By exporting, the real value of maximum edge length is calculated as a percent from the length of the diameter of the body bounding box. The minimum allowed value is 0.1%. The maximum allowed value is 10.0%. By default this property is ignored.
Public property | NormalTolerance | The maximum change in the surface normal between adjacent nodes in the mesh. This property is defined in degrees. The minimum allowed value is 1.0 degrees. The maximum allowed value is 45.0 degrees. Default value is 15.0 degrees.
Public property | SurfaceTolerance | The maximum distance between mesh triangles and model geometry. This is a percentage value. By exporting, the real value of surface tolerance is calculated as a percent from the length of the diameter of the body bounding box. The minimum allowed value is 0.001%. The maximum allowed value is 1.0%. Default value is 0.1%.
Public property | TargetUnit | The unit type of geometry in the resultant STL file. Default value is ExportUnit::Default.
Public property | ViewId | The element id of the 3D view to export. InvalidElementId by default. (Inherited from BIMExportOptions.)

See Also

STLExportOptions Class


STLExportOptions Constructor

[image] [image]

Revit 2024 API
STLExportOptions Constructor
STLExportOptions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | STLExportOptions()()()() | Constructs a new instance of STLExportOptions with default values of all properties.
Public method | STLExportOptions(ExportResolution) | Constructs a new instance of STLExportOptions with all predefined tessellation settings, depending on export resolution type. Note: in case of Custom resolution type, tessellation settings won't be predefined and will have default values.

See Also

STLExportOptions Class
STLExportOptions Members


STLExportOptions Constructor

[image]

Revit 2024 API
STLExportOptions Constructor
STLExportOptions Class See Also Send Feedback
Constructs a new instance of STLExportOptions with default values of all properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021.1

Syntax

C#
public STLExportOptions()
Visual Basic
Public Sub New
Visual C++
public:
STLExportOptions()

See Also

STLExportOptions Class
STLExportOptions Overload


STLExportOptions Constructor (ExportResolution)

[image]

Revit 2024 API
STLExportOptions Constructor (ExportResolution)
STLExportOptions Class See Also Send Feedback
Constructs a new instance of STLExportOptions with all predefined tessellation settings, depending on export resolution type. Note: in case of Custom resolution type, tessellation settings won't be predefined and will have default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021.1

Syntax

C#
public STLExportOptions(
    ExportResolution resolutionType
)
Visual Basic
Public Sub New ( _
    resolutionType As ExportResolution _
)
Visual C++
public:
STLExportOptions(
    ExportResolution resolutionType
)

Parameters

resolutionType
Type: Autodesk.Revit.DB..::..ExportResolution
The type of export resolution.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

STLExportOptions Class
STLExportOptions Overload


IsGridAspectRatioSet Method

[image]

Revit 2024 API
STLExportOptions..::..IsGridAspectRatioSet Method
STLExportOptions Class See Also Send Feedback
Checks whether the GridAspectRatio tessellation parameter is explicitly set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021.1

Syntax

C#
public bool IsGridAspectRatioSet()
Visual Basic
Public Function IsGridAspectRatioSet As Boolean
Visual C++
public:
bool IsGridAspectRatioSet()

Return Value

True if GridAspectRatio tessellation parameter is explicitly set, false otherwise.

See Also

STLExportOptions Class


IsMaxEdgeLengthSet Method

[image]

Revit 2024 API
STLExportOptions..::..IsMaxEdgeLengthSet Method
STLExportOptions Class See Also Send Feedback
Checks whether the MaxEdgeLength tessellation parameter is explicitly set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021.1

Syntax

C#
public bool IsMaxEdgeLengthSet()
Visual Basic
Public Function IsMaxEdgeLengthSet As Boolean
Visual C++
public:
bool IsMaxEdgeLengthSet()

Return Value

True if MaxEdgeLength tessellation parameter is explicitly set, false otherwise.

See Also

STLExportOptions Class


IsValidForGridAspectRatio Method

[image]

Revit 2024 API
STLExportOptions..::..IsValidForGridAspectRatio Method
STLExportOptions Class See Also Send Feedback
Checks whether the value is allowed (is in the allowed range) for GridAspectRatio tessellation parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021.1

Syntax

C#
public static bool IsValidForGridAspectRatio(
    double value
)
Visual Basic
Public Shared Function IsValidForGridAspectRatio ( _
    value As Double _
) As Boolean
Visual C++
public:
static bool IsValidForGridAspectRatio(
    double value
)

Parameters

value
Type: System..::..Double
The value to be checked.

Return Value

True if the value is valid for GridAspectRatio, false otherwise.

See Also

STLExportOptions Class


IsValidForMaxEdgeLength Method

[image]

Revit 2024 API
STLExportOptions..::..IsValidForMaxEdgeLength Method
STLExportOptions Class See Also Send Feedback
Checks whether the value is allowed (is in the allowed range) for MaxEdgeLength tessellation parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021.1

Syntax

C#
public static bool IsValidForMaxEdgeLength(
    double value
)
Visual Basic
Public Shared Function IsValidForMaxEdgeLength ( _
    value As Double _
) As Boolean
Visual C++
public:
static bool IsValidForMaxEdgeLength(
    double value
)

Parameters

value
Type: System..::..Double
The value to be checked.

Return Value

True if the value is valid for MaxEdgeLength, false otherwise.

See Also

STLExportOptions Class


IsValidForNormalTolerance Method

[image]

Revit 2024 API
STLExportOptions..::..IsValidForNormalTolerance Method
STLExportOptions Class See Also Send Feedback
Checks whether the value is allowed (is in the allowed range) for NormalTolerance tessellation parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021.1

Syntax

C#
public static bool IsValidForNormalTolerance(
    double value
)
Visual Basic
Public Shared Function IsValidForNormalTolerance ( _
    value As Double _
) As Boolean
Visual C++
public:
static bool IsValidForNormalTolerance(
    double value
)

Parameters

value
Type: System..::..Double
The value to be checked.

Return Value

True if the value is valid for NormalTolerance, false otherwise.

See Also

STLExportOptions Class


IsValidForSurfaceTolerance Method

[image]

Revit 2024 API
STLExportOptions..::..IsValidForSurfaceTolerance Method
STLExportOptions Class See Also Send Feedback
Checks whether the value is allowed (is in the allowed range) for SurfaceTolerance tessellation parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021.1

Syntax

C#
public static bool IsValidForSurfaceTolerance(
    double value
)
Visual Basic
Public Shared Function IsValidForSurfaceTolerance ( _
    value As Double _
) As Boolean
Visual C++
public:
static bool IsValidForSurfaceTolerance(
    double value
)

Parameters

value
Type: System..::..Double
The value to be checked.

Return Value

True if the value is valid for SurfaceTolerance, false otherwise.

See Also

STLExportOptions Class


SetTessellationSettings Method

[image]

Revit 2024 API
STLExportOptions..::..SetTessellationSettings Method
STLExportOptions Class See Also Send Feedback
Sets all the tessellation parameters to its predefined values for the given resolution type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021.1

Syntax

C#
public void SetTessellationSettings(
    ExportResolution resolutionType
)
Visual Basic
Public Sub SetTessellationSettings ( _
    resolutionType As ExportResolution _
)
Visual C++
public:
void SetTessellationSettings(
    ExportResolution resolutionType
)

Parameters

resolutionType
Type: Autodesk.Revit.DB..::..ExportResolution
Type of exporting resolution.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

STLExportOptions Class


STLExportOptions Properties

[image] [image]

Revit 2024 API
STLExportOptions Properties
STLExportOptions Class See Also Send Feedback

The STLExportOptions type exposes the following members.

Properties

 | Name | Description
Public property | ExportBinary | True to export in binary STL format, false to export in ASCII STL format. Default value is true.
Public property | ExportColor | True to export color information, false otherwise. Default value is false.
Public property | GridAspectRatio | The maximum aspect ratio allowed in the grid placed across the face. The minimum allowed value is 1.0. The maximum allowed value is 10.0. By default this property is ignored.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BIMExportOptions.)
Public property | MaxEdgeLength | The maximum length allowed for any chord on an edge or between any two adjacent grid lines. This is a percentage value. By exporting, the real value of maximum edge length is calculated as a percent from the length of the diameter of the body bounding box. The minimum allowed value is 0.1%. The maximum allowed value is 10.0%. By default this property is ignored.
Public property | NormalTolerance | The maximum change in the surface normal between adjacent nodes in the mesh. This property is defined in degrees. The minimum allowed value is 1.0 degrees. The maximum allowed value is 45.0 degrees. Default value is 15.0 degrees.
Public property | SurfaceTolerance | The maximum distance between mesh triangles and model geometry. This is a percentage value. By exporting, the real value of surface tolerance is calculated as a percent from the length of the diameter of the body bounding box. The minimum allowed value is 0.001%. The maximum allowed value is 1.0%. Default value is 0.1%.
Public property | TargetUnit | The unit type of geometry in the resultant STL file. Default value is ExportUnit::Default.
Public property | ViewId | The element id of the 3D view to export. InvalidElementId by default. (Inherited from BIMExportOptions.)

See Also

STLExportOptions Class


ExportBinary Property

[image]

Revit 2024 API
STLExportOptions..::..ExportBinary Property
STLExportOptions Class See Also Send Feedback
True to export in binary STL format, false to export in ASCII STL format. Default value is true.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021.1

Syntax

C#
public bool ExportBinary { get; set; }
Visual Basic
Public Property ExportBinary As Boolean
    Get
    Set
Visual C++
public:
property bool ExportBinary {
    bool get ();
    void set (bool value);
}

See Also

STLExportOptions Class


ExportColor Property

[image]

Revit 2024 API
STLExportOptions..::..ExportColor Property
STLExportOptions Class See Also Send Feedback
True to export color information, false otherwise. Default value is false.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021.1

Syntax

C#
public bool ExportColor { get; set; }
Visual Basic
Public Property ExportColor As Boolean
    Get
    Set
Visual C++
public:
property bool ExportColor {
    bool get ();
    void set (bool value);
}

Remarks

Color information can be exported only in binary STL format, in the case of ASCII STL format this property will be ignored.

See Also

STLExportOptions Class


GridAspectRatio Property

[image]

Revit 2024 API
STLExportOptions..::..GridAspectRatio Property
STLExportOptions Class See Also Send Feedback
The maximum aspect ratio allowed in the grid placed across the face. The minimum allowed value is 1.0. The maximum allowed value is 10.0. By default this property is ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021.1

Syntax

C#
public double GridAspectRatio { get; set; }
Visual Basic
Public Property GridAspectRatio As Double
    Get
    Set
Visual C++
public:
property double GridAspectRatio {
    double get ();
    void set (double value);
}

Remarks

This property can be set by using export resolution type (by creation of STLExportOptions or using [!:Autodesk::Revit::DB::STLExportOptions::setTessellationSettings(ExportResolution::Enum)] method). In the case of Fine, Medium and Coarse resolutions, this property has the same value (10.0) and it is considered as explicitly set by the user. In the case of Custom resolution type, this property is only allowed to be obtained if it has been explicitly set.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The value gridAspectRatio is outside the allowable range of values for GridAspectRatio tessellation parameter.
Autodesk.Revit.Exceptions..::..InvalidOperationException | GridAspectRatio tessellation parameter is default (hasn't been explicitly set by the user) and cannot be obtained now.

See Also

STLExportOptions Class


MaxEdgeLength Property

[image]

Revit 2024 API
STLExportOptions..::..MaxEdgeLength Property
STLExportOptions Class See Also Send Feedback
The maximum length allowed for any chord on an edge or between any two adjacent grid lines. This is a percentage value. By exporting, the real value of maximum edge length is calculated as a percent from the length of the diameter of the body bounding box. The minimum allowed value is 0.1%. The maximum allowed value is 10.0%. By default this property is ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021.1

Syntax

C#
public double MaxEdgeLength { get; set; }
Visual Basic
Public Property MaxEdgeLength As Double
    Get
    Set
Visual C++
public:
property double MaxEdgeLength {
    double get ();
    void set (double value);
}

Remarks

This property can be set by using export resolution type (by creation of STLExportOptions or using [!:Autodesk::Revit::DB::STLExportOptions::setTessellationSettings(ExportResolution::Enum)] method). In the case of Fine, Medium and Coarse resolutions, this property has the same value (10.0%) and it is considered as explicitly set by the user. In the case of Custom resolution type, this property is only allowed to be obtained if it has been explicitly set.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The value maxEdgeLength is outside the allowable range of values for MaxEdgeLength tessellation parameter.
Autodesk.Revit.Exceptions..::..InvalidOperationException | MaxEdgeLength tessellation parameter is default (hasn't been explicitly set by the user) and cannot be obtained now.

See Also

STLExportOptions Class


NormalTolerance Property

[image]

Revit 2024 API
STLExportOptions..::..NormalTolerance Property
STLExportOptions Class See Also Send Feedback
The maximum change in the surface normal between adjacent nodes in the mesh. This property is defined in degrees. The minimum allowed value is 1.0 degrees. The maximum allowed value is 45.0 degrees. Default value is 15.0 degrees.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021.1

Syntax

C#
public double NormalTolerance { get; set; }
Visual Basic
Public Property NormalTolerance As Double
    Get
    Set
Visual C++
public:
property double NormalTolerance {
    double get ();
    void set (double value);
}

Remarks

This property can be set by using export resolution type (by creation of STLExportOptions or using [!:Autodesk::Revit::DB::STLExportOptions::setTessellationSettings(ExportResolution::Enum)] method). In the case of Fine (10.0 degrees), Medium (15.0 degrees) and Coarse (30.0 degrees) resolutions, this property is considered as explicitly set by the user. In the case of Custom resolution type, this property is only allowed to be obtained if it has been explicitly set.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The value normalTolerance is outside the allowable range of values for NormalTolerance tessellation parameter.
Autodesk.Revit.Exceptions..::..InvalidOperationException | NormalTolerance tessellation parameter is default (hasn't been explicitly set by the user) and cannot be obtained now.

See Also

STLExportOptions Class


SurfaceTolerance Property

[image]

Revit 2024 API
STLExportOptions..::..SurfaceTolerance Property
STLExportOptions Class See Also Send Feedback
The maximum distance between mesh triangles and model geometry. This is a percentage value. By exporting, the real value of surface tolerance is calculated as a percent from the length of the diameter of the body bounding box. The minimum allowed value is 0.001%. The maximum allowed value is 1.0%. Default value is 0.1%.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021.1

Syntax

C#
public double SurfaceTolerance { get; set; }
Visual Basic
Public Property SurfaceTolerance As Double
    Get
    Set
Visual C++
public:
property double SurfaceTolerance {
    double get ();
    void set (double value);
}

Remarks

This property can be set by using export resolution type (by creation of STLExportOptions or using [!:Autodesk::Revit::DB::STLExportOptions::setTessellationSettings(ExportResolution::Enum)] method). In the case of Fine (0.005%), Medium (0.016%) and Coarse (0.04%) resolutions, this property is considered as explicitly set by the user. In the case of Custom resolution type, this property is only allowed to be obtained if it has been explicitly set.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The value surfaceTolerance is outside the allowable range of values for SurfaceTolerance tessellation parameter.
Autodesk.Revit.Exceptions..::..InvalidOperationException | SurfaceTolerance tessellation parameter is default (hasn't been explicitly set by the user) and cannot be obtained now.

See Also

STLExportOptions Class


TargetUnit Property

[image]

Revit 2024 API
STLExportOptions..::..TargetUnit Property
STLExportOptions Class See Also Send Feedback
The unit type of geometry in the resultant STL file. Default value is ExportUnit::Default.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021.1

Syntax

C#
public ExportUnit TargetUnit { get; set; }
Visual Basic
Public Property TargetUnit As ExportUnit
    Get
    Set
Visual C++
public:
property ExportUnit TargetUnit {
    ExportUnit get ();
    void set (ExportUnit value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

STLExportOptions Class


STLImportOptions Class

[image]

Revit 2024 API
STLImportOptions Class
Members See Also Send Feedback
The import options used to import STL format files.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022.1

Syntax

C#
public class STLImportOptions : BaseImportOptions
Visual Basic
Public Class STLImportOptions _
    Inherits BaseImportOptions
Visual C++
public ref class STLImportOptions : public BaseImportOptions

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BaseImportOptions
Autodesk.Revit.DB..::..STLImportOptions

See Also

STLImportOptions Members


STLImportOptions Members

[image] [image]

Revit 2024 API
STLImportOptions Members
STLImportOptions Class Constructors Methods Properties See Also Send Feedback

The STLImportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | STLImportOptions()()()() | Constructs a new instance of STLImportOptions with default values of all properties.
Public method | STLImportOptions(STLImportOptions) | Constructs a new instance of STLImportOptions as a copy of the import options.

Methods

 | Name | Description
Public method | Dispose | (Inherited from BaseImportOptions.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDefaultLengthUnit | Get the default length unit used for importing unitless files. (Inherited from BaseImportOptions.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLayerSelection | Get all set layers name which user want to import into Revit. (Inherited from BaseImportOptions.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDefaultLengthUnit | Set the default length unit used for importing unitless files. (Inherited from BaseImportOptions.)
Public method | SetLayerSelection | Set the layers name which user want to import into Revit. (Inherited from BaseImportOptions.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AutoCorrectAlmostVHLines | Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines. (Inherited from BaseImportOptions.)
Public property | ColorMode | Color mode for the import. Three modes are supported. Black and White, Preserve Colors, and Invert Colors. (Inherited from BaseImportOptions.)
Public property | CustomScale | Scaling the import. If this is defined and a valid value (> 0.0), it takes priority over units. (Inherited from BaseImportOptions.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BaseImportOptions.)
Public property | OrientToView | Place the import at the same orientation as the view that was passed into the import method. This option can only be used when not importing into a single view.(i.e. ThisViewOnly is set to false) (Inherited from BaseImportOptions.)
Public property | Placement | Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates. (Inherited from BaseImportOptions.)
Public property | ReferencePoint | The 3D point in the document where the imported instance will be inserted. If not explicitly set, the instance will be inserted at the document origin. (Inherited from BaseImportOptions.)
Public property | ThisViewOnly | Imports drawings into the view that was passed into the import method. This option is not available in 3D views. (Inherited from BaseImportOptions.)
Public property | Unit | The unit of measure for imported geometry. (Inherited from BaseImportOptions.)
Public property | VisibleLayersOnly | Only import the visible layers. (Inherited from BaseImportOptions.)

See Also

STLImportOptions Class


STLImportOptions Constructor

[image] [image]

Revit 2024 API
STLImportOptions Constructor
STLImportOptions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | STLImportOptions()()()() | Constructs a new instance of STLImportOptions with default values of all properties.
Public method | STLImportOptions(STLImportOptions) | Constructs a new instance of STLImportOptions as a copy of the import options.

See Also

STLImportOptions Class
STLImportOptions Members


STLImportOptions Constructor (STLImportOptions)

[image]

Revit 2024 API
STLImportOptions Constructor (STLImportOptions)
STLImportOptions Class See Also Send Feedback
Constructs a new instance of STLImportOptions as a copy of the import options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022.1

Syntax

C#
public STLImportOptions(
    STLImportOptions option
)
Visual Basic
Public Sub New ( _
    option As STLImportOptions _
)
Visual C++
public:
STLImportOptions(
    STLImportOptions^ option
)

Parameters

option
Type: Autodesk.Revit.DB..::..STLImportOptions
The STL options to be copied.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

STLImportOptions Class
STLImportOptions Overload


STLImportOptions Properties

[image] [image]

Revit 2024 API
STLImportOptions Properties
STLImportOptions Class See Also Send Feedback

The STLImportOptions type exposes the following members.

Properties

 | Name | Description
Public property | AutoCorrectAlmostVHLines | Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines. (Inherited from BaseImportOptions.)
Public property | ColorMode | Color mode for the import. Three modes are supported. Black and White, Preserve Colors, and Invert Colors. (Inherited from BaseImportOptions.)
Public property | CustomScale | Scaling the import. If this is defined and a valid value (> 0.0), it takes priority over units. (Inherited from BaseImportOptions.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BaseImportOptions.)
Public property | OrientToView | Place the import at the same orientation as the view that was passed into the import method. This option can only be used when not importing into a single view.(i.e. ThisViewOnly is set to false) (Inherited from BaseImportOptions.)
Public property | Placement | Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates. (Inherited from BaseImportOptions.)
Public property | ReferencePoint | The 3D point in the document where the imported instance will be inserted. If not explicitly set, the instance will be inserted at the document origin. (Inherited from BaseImportOptions.)
Public property | ThisViewOnly | Imports drawings into the view that was passed into the import method. This option is not available in 3D views. (Inherited from BaseImportOptions.)
Public property | Unit | The unit of measure for imported geometry. (Inherited from BaseImportOptions.)
Public property | VisibleLayersOnly | Only import the visible layers. (Inherited from BaseImportOptions.)

See Also

STLImportOptions Class


StorageType Enumeration

[image]

Revit 2024 API
StorageType Enumeration
See Also Send Feedback
An enumerated type listing all of the internal parameter data storage types that Autodesk Revit supports.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum StorageType
Visual Basic
Public Enumeration StorageType
Visual C++
public enum class StorageType

Members

Member name | Description
None | None represents an invalid storage type. This value should not be used.
Integer | The internal data is stored in the form of a signed 32 bit integer.
Double | The data will be stored internally in the form of an 8 byte floating point number.
String | The internal data will be stored in the form of a string of characters.
ElementId | The data type represents an element and is stored as the id of the element.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


StringParameterValue Class

[image]

Revit 2024 API
StringParameterValue Class
Members See Also Send Feedback
A class that holds a String value of a parameter element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Update

Syntax

C#
public class StringParameterValue : ParameterValue
Visual Basic
Public Class StringParameterValue _
    Inherits ParameterValue
Visual C++
public ref class StringParameterValue : public ParameterValue

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ParameterValue
Autodesk.Revit.DB..::..StringParameterValue

See Also

StringParameterValue Members


StringParameterValue Members

[image] [image]

Revit 2024 API
StringParameterValue Members
StringParameterValue Class Constructors Methods Properties See Also Send Feedback

The StringParameterValue type exposes the following members.

Constructors

 | Name | Description
Public method | StringParameterValue()()()() | Default constructor
Public method | StringParameterValue(String) | Value constructor

Methods

 | Name | Description
Public method | Copy | Makes an identical copy of the given parameter value. (Inherited from ParameterValue.)
Public method | Dispose | (Inherited from ParameterValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Tests equality with another instance of the same class. (Inherited from ParameterValue.)
Public method | IsSameType | Tests another instance is of the same value type. (Inherited from ParameterValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ParameterValue.)
Public property | Value | The stored value

See Also

StringParameterValue Class


StringParameterValue Constructor

[image] [image]

Revit 2024 API
StringParameterValue Constructor
StringParameterValue Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StringParameterValue()()()() | Default constructor
Public method | StringParameterValue(String) | Value constructor

See Also

StringParameterValue Class
StringParameterValue Members


StringParameterValue Constructor

[image]

Revit 2024 API
StringParameterValue Constructor
StringParameterValue Class See Also Send Feedback
Default constructor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Update

Syntax

C#
public StringParameterValue()
Visual Basic
Public Sub New
Visual C++
public:
StringParameterValue()

See Also

StringParameterValue Class
StringParameterValue Overload


StringParameterValue Constructor (String)

[image]

Revit 2024 API
StringParameterValue Constructor (String)
StringParameterValue Class See Also Send Feedback
Value constructor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Update

Syntax

C#
public StringParameterValue(
    string value
)
Visual Basic
Public Sub New ( _
    value As String _
)
Visual C++
public:
StringParameterValue(
    String^ value
)

Parameters

value
Type: System..::..String

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

StringParameterValue Class
StringParameterValue Overload


StringParameterValue Methods

[image] [image]

Revit 2024 API
StringParameterValue Methods
StringParameterValue Class See Also Send Feedback

The StringParameterValue type exposes the following members.

Methods

 | Name | Description
Public method | Copy | Makes an identical copy of the given parameter value. (Inherited from ParameterValue.)
Public method | Dispose | (Inherited from ParameterValue.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Tests equality with another instance of the same class. (Inherited from ParameterValue.)
Public method | IsSameType | Tests another instance is of the same value type. (Inherited from ParameterValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

StringParameterValue Class


Value Property

[image]

Revit 2024 API
StringParameterValue..::..Value Property
StringParameterValue Class See Also Send Feedback
The stored value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Update

Syntax

C#
public string Value { get; set; }
Visual Basic
Public Property Value As String
    Get
    Set
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

StringParameterValue Class


StripedRowPattern Enumeration

[image]

Revit 2024 API
StripedRowPattern Enumeration
See Also Send Feedback
An enumerated type representing the possible sets of rows of a striped row schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021
Since: 2021

Syntax

C#
public enum StripedRowPattern
Visual Basic
Public Enumeration StripedRowPattern
Visual C++
public enum class StripedRowPattern

Members

Member name | Description
FirstRow | The first row and every other row thereafter.
SecondRow | The second row and every other row thereafter.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


StructDeckEmbeddingType Enumeration

[image]

Revit 2024 API
StructDeckEmbeddingType Enumeration
See Also Send Feedback
Used in class CompoundStructure to specify the usage of a layer whose function is StructuralDeck.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public enum StructDeckEmbeddingType
Visual Basic
Public Enumeration StructDeckEmbeddingType
Visual C++
public enum class StructDeckEmbeddingType

Members

Member name | Description
Invalid | Invalid usage.
MergeWithLayerAbove | Bound layer above.
Standalone | Standalone deck.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


StructuralAsset Class

[image]

Revit 2024 API
StructuralAsset Class
Members See Also Send Feedback
Represents the properties of a material pertinent to structural analysis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public class StructuralAsset : IDisposable
Visual Basic
Public Class StructuralAsset _
    Implements IDisposable
Visual C++
public ref class StructuralAsset : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..StructuralAsset

See Also

StructuralAsset Members


StructuralAsset Members

[image] [image]

Revit 2024 API
StructuralAsset Members
StructuralAsset Class Constructors Methods Properties See Also Send Feedback

The StructuralAsset type exposes the following members.

Constructors

 | Name | Description
Public method | StructuralAsset | Constructs an instance of StructuralAsset.

Methods

 | Name | Description
Public method | Copy | Produces a copy of the asset.
Public method | Dispose | Releases all resources used by the StructuralAsset
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(StructuralAsset) | Determines whether this structural asset is equal to another.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetPoissonRatio | Sets the Poisson ratio of the asset.
Public method | SetShearModulus | Sets the shear modulus of the asset.
Public method | SetThermalExpansionCoefficient | Sets the thermal expansion coefficient of the asset.
Public method | SetYoungModulus | Sets the Young's modulus of the asset.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Behavior | Flag indicating whether elements of this material behave isotropically or orthotropically.
Public property | ConcreteBendingReinforcement | The bending reinforcement of the asset.
Public property | ConcreteCompression | The compression strength of concrete-based assets.
Public property | ConcreteShearReinforcement | The shear reinforcement of the asset.
Public property | ConcreteShearStrengthReduction | The shear strength reduction of the asset.
Public property | Density | The density of the asset.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Lightweight | Flag indicating whether the asset describes a material that is light-weight or not.
Public property | MetalReductionFactor | The reduction factor of the asset.
Public property | MetalResistanceCalculationStrength | The resistance calculation strength of the asset.
Public property | MetalThermallyTreated | Flag indicating whether the asset describes a material that is thermally treated or not.
Public property | MinimumTensileStrength | The minimum tensile strength of the asset.
Public property | MinimumYieldStress | The minimum yield stress of the asset.
Public property | Name | The name of the structural asset.
Public property | PoissonRatio | The Poisson ratio of the asset.
Public property | ShearModulus | The shear modulus of the asset.
Public property | StructuralAssetClass | The type of material that this structural asset describes (e.g. wood, concrete, metal.)
Public property | SubClass | The sub-class of the asset.
Public property | ThermalExpansionCoefficient | The thermal expansion coefficient of the asset.
Public property | WoodBendingStrength | The bending strength of the asset.
Public property | WoodGrade | The grade of wood used in a wood-based asset.
Public property | WoodParallelCompressionStrength | The parallel compression strength of the asset.
Public property | WoodParallelShearStrength | The parallel shear strength of the asset.
Public property | WoodPerpendicularCompressionStrength | The perpendicular compression strength of the asset.
Public property | WoodPerpendicularShearStrength | The perpendicular shear strength of the asset.
Public property | WoodSpecies | The species of wood used in a wood-based asset.
Public property | YoungModulus | The Young's modulus of the asset.

See Also

StructuralAsset Class


StructuralAsset Constructor

[image]

Revit 2024 API
StructuralAsset Constructor
StructuralAsset Class See Also Send Feedback
Constructs an instance of StructuralAsset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public StructuralAsset(
    string name,
    StructuralAssetClass structuralAssetClass
)
Visual Basic
Public Sub New ( _
    name As String, _
    structuralAssetClass As StructuralAssetClass _
)
Visual C++
public:
StructuralAsset(
    String^ name,
    StructuralAssetClass structuralAssetClass
)

Parameters

name
Type: System..::..String
The name of the asset.
structuralAssetClass
Type: Autodesk.Revit.DB..::..StructuralAssetClass
The type of structural material that this asset will describe.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

StructuralAsset Class


StructuralAsset Methods

[image] [image]

Revit 2024 API
StructuralAsset Methods
StructuralAsset Class See Also Send Feedback

The StructuralAsset type exposes the following members.

Methods

 | Name | Description
Public method | Copy | Produces a copy of the asset.
Public method | Dispose |
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(StructuralAsset) | Determines whether this structural asset is equal to another.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetPoissonRatio | Sets the Poisson ratio of the asset.
Public method | SetShearModulus | Sets the shear modulus of the asset.
Public method | SetThermalExpansionCoefficient | Sets the thermal expansion coefficient of the asset.
Public method | SetYoungModulus | Sets the Young's modulus of the asset.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

StructuralAsset Class


Copy Method

[image]

Revit 2024 API
StructuralAsset..::..Copy Method
StructuralAsset Class See Also Send Feedback
Produces a copy of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public StructuralAsset Copy()
Visual Basic
Public Function Copy As StructuralAsset
Visual C++
public:
StructuralAsset^ Copy()

Return Value

A copy of the asset.

See Also

StructuralAsset Class


Equals Method

[image] [image]

Revit 2024 API
StructuralAsset..::..Equals Method
StructuralAsset Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(StructuralAsset) | Determines whether this structural asset is equal to another.

See Also

StructuralAsset Class
StructuralAsset Members


Equals Method (StructuralAsset)

[image]

Revit 2024 API
StructuralAsset..::..Equals Method (StructuralAsset)
StructuralAsset Class See Also Send Feedback
Determines whether this structural asset is equal to another.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool Equals(
    StructuralAsset other
)
Visual Basic
Public Function Equals ( _
    other As StructuralAsset _
) As Boolean
Visual C++
public:
bool Equals(
    StructuralAsset^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..StructuralAsset
The structural asset with which to compare this structural asset.

Return Value

True if the given structural asset is equal to this one, otherwise false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

StructuralAsset Class
Equals Overload


SetPoissonRatio Method

[image]

Revit 2024 API
StructuralAsset..::..SetPoissonRatio Method
StructuralAsset Class See Also Send Feedback
Sets the Poisson ratio of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void SetPoissonRatio(
    double poissonRatio
)
Visual Basic
Public Sub SetPoissonRatio ( _
    poissonRatio As Double _
)
Visual C++
public:
void SetPoissonRatio(
    double poissonRatio
)

Parameters

poissonRatio
Type: System..::..Double

Remarks

The Poisson ratio is one-dimensional for wood-based and isotropic materials. This method sets the x, y, and z components to the same value.

See Also

StructuralAsset Class


SetShearModulus Method

[image]

Revit 2024 API
StructuralAsset..::..SetShearModulus Method
StructuralAsset Class See Also Send Feedback
Sets the shear modulus of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void SetShearModulus(
    double shearModulus
)
Visual Basic
Public Sub SetShearModulus ( _
    shearModulus As Double _
)
Visual C++
public:
void SetShearModulus(
    double shearModulus
)

Parameters

shearModulus
Type: System..::..Double

Remarks

The shear modulus is one-dimensional for wood-based and isotropic materials. This method sets the x, y, and z components to the same value. The value is in Newtons per foot meter (N/(ft Â· m)).

See Also

StructuralAsset Class


SetThermalExpansionCoefficient Method

[image]

Revit 2024 API
StructuralAsset..::..SetThermalExpansionCoefficient Method
StructuralAsset Class See Also Send Feedback
Sets the thermal expansion coefficient of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void SetThermalExpansionCoefficient(
    double thermalExpCoeff
)
Visual Basic
Public Sub SetThermalExpansionCoefficient ( _
    thermalExpCoeff As Double _
)
Visual C++
public:
void SetThermalExpansionCoefficient(
    double thermalExpCoeff
)

Parameters

thermalExpCoeff
Type: System..::..Double

Remarks

The thermal expansion coefficient is one-dimensional for wood-based and isotropic materials. This method sets the x, y, and z components to the same value. The value is in inverse Kelvin (1/K).

See Also

StructuralAsset Class


SetYoungModulus Method

[image]

Revit 2024 API
StructuralAsset..::..SetYoungModulus Method
StructuralAsset Class See Also Send Feedback
Sets the Young's modulus of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void SetYoungModulus(
    double youngModulus
)
Visual Basic
Public Sub SetYoungModulus ( _
    youngModulus As Double _
)
Visual C++
public:
void SetYoungModulus(
    double youngModulus
)

Parameters

youngModulus
Type: System..::..Double

Remarks

The Young's modulus is one-dimensional for wood-based and isotropic materials. This method sets the x, y, and z components to the same value. The value is in Newtons per foot meter (N/(ft Â· m)).

See Also

StructuralAsset Class


Behavior Property

[image]

Revit 2024 API
StructuralAsset..::..Behavior Property
StructuralAsset Class See Also Send Feedback
Flag indicating whether elements of this material behave isotropically or orthotropically.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public StructuralBehavior Behavior { get; set; }
Visual Basic
Public Property Behavior As StructuralBehavior
    Get
    Set
Visual C++
public:
property StructuralBehavior Behavior {
    StructuralBehavior get ();
    void set (StructuralBehavior value);
}

Remarks

Applies to concrete, Metal, and generic structural assets. If the behavior is set to Isotropic, then the y and z components of Young modulus, Poisson modulus, shear modulus and thermal expansion coefficient will be changed to the value the same as their x components.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

StructuralAsset Class


ConcreteBendingReinforcement Property

[image]

Revit 2024 API
StructuralAsset..::..ConcreteBendingReinforcement Property
StructuralAsset Class See Also Send Feedback
The bending reinforcement of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double ConcreteBendingReinforcement { get; set; }
Visual Basic
Public Property ConcreteBendingReinforcement As Double
    Get
    Set
Visual C++
public:
property double ConcreteBendingReinforcement {
    double get ();
    void set (double value);
}

Remarks

Applies to concrete-based structural assets.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | When setting this property: the material type must be concrete to set this property.

See Also

StructuralAsset Class


ConcreteCompression Property

[image]

Revit 2024 API
StructuralAsset..::..ConcreteCompression Property
StructuralAsset Class See Also Send Feedback
The compression strength of concrete-based assets.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double ConcreteCompression { get; set; }
Visual Basic
Public Property ConcreteCompression As Double
    Get
    Set
Visual C++
public:
property double ConcreteCompression {
    double get ();
    void set (double value);
}

Remarks

Applies to concrete-based structural assets. The value is in Newtons per foot meter (N/(ft Â· m)).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | When setting this property: the material type must be concrete to set this property.

See Also

StructuralAsset Class


ConcreteShearReinforcement Property

[image]

Revit 2024 API
StructuralAsset..::..ConcreteShearReinforcement Property
StructuralAsset Class See Also Send Feedback
The shear reinforcement of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double ConcreteShearReinforcement { get; set; }
Visual Basic
Public Property ConcreteShearReinforcement As Double
    Get
    Set
Visual C++
public:
property double ConcreteShearReinforcement {
    double get ();
    void set (double value);
}

Remarks

Applies to concrete-based structural assets.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | When setting this property: the material type must be concrete to set this property.

See Also

StructuralAsset Class


ConcreteShearStrengthReduction Property

[image]

Revit 2024 API
StructuralAsset..::..ConcreteShearStrengthReduction Property
StructuralAsset Class See Also Send Feedback
The shear strength reduction of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double ConcreteShearStrengthReduction { get; set; }
Visual Basic
Public Property ConcreteShearStrengthReduction As Double
    Get
    Set
Visual C++
public:
property double ConcreteShearStrengthReduction {
    double get ();
    void set (double value);
}

Remarks

Applies to concrete-based structural assets.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | When setting this property: the material type must be concrete to set this property.

See Also

StructuralAsset Class


Density Property

[image]

Revit 2024 API
StructuralAsset..::..Density Property
StructuralAsset Class See Also Send Feedback
The density of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double Density { get; set; }
Visual Basic
Public Property Density As Double
    Get
    Set
Visual C++
public:
property double Density {
    double get ();
    void set (double value);
}

Remarks

Values are in kilograms per cubed feet (kg/ftÂ³) and must be non-negative.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for density must be non-negative.

See Also

StructuralAsset Class


MetalReductionFactor Property

[image]

Revit 2024 API
StructuralAsset..::..MetalReductionFactor Property
StructuralAsset Class See Also Send Feedback
The reduction factor of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double MetalReductionFactor { get; set; }
Visual Basic
Public Property MetalReductionFactor As Double
    Get
    Set
Visual C++
public:
property double MetalReductionFactor {
    double get ();
    void set (double value);
}

Remarks

Applies to Metal-based structural assets.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | When setting this property: the material type must be Metal to set this property.

See Also

StructuralAsset Class


MetalResistanceCalculationStrength Property

[image]

Revit 2024 API
StructuralAsset..::..MetalResistanceCalculationStrength Property
StructuralAsset Class See Also Send Feedback
The resistance calculation strength of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double MetalResistanceCalculationStrength { get; set; }
Visual Basic
Public Property MetalResistanceCalculationStrength As Double
    Get
    Set
Visual C++
public:
property double MetalResistanceCalculationStrength {
    double get ();
    void set (double value);
}

Remarks

Applies to metal-based structural assets.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | When setting this property: the material type must be Metal to set this property.

See Also

StructuralAsset Class


MinimumTensileStrength Property

[image]

Revit 2024 API
StructuralAsset..::..MinimumTensileStrength Property
StructuralAsset Class See Also Send Feedback
The minimum tensile strength of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double MinimumTensileStrength { get; set; }
Visual Basic
Public Property MinimumTensileStrength As Double
    Get
    Set
Visual C++
public:
property double MinimumTensileStrength {
    double get ();
    void set (double value);
}

Remarks

Applies to Metal-based and generic structural assets. The value is in Newtons per foot meter (N/(ft Â· m)).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | When setting this property: the material type must be Metal or generic to set this property.

See Also

StructuralAsset Class


MinimumYieldStress Property

[image]

Revit 2024 API
StructuralAsset..::..MinimumYieldStress Property
StructuralAsset Class See Also Send Feedback
The minimum yield stress of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double MinimumYieldStress { get; set; }
Visual Basic
Public Property MinimumYieldStress As Double
    Get
    Set
Visual C++
public:
property double MinimumYieldStress {
    double get ();
    void set (double value);
}

Remarks

Applies to Metal-based and generic structural assets. The value is in Newtons per foot meter (N/(ft Â· m)).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | When setting this property: the material type must be Metal or generic to set this property.

See Also

StructuralAsset Class


Name Property

[image]

Revit 2024 API
StructuralAsset..::..Name Property
StructuralAsset Class See Also Send Feedback
The name of the structural asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

StructuralAsset Class


PoissonRatio Property

[image]

Revit 2024 API
StructuralAsset..::..PoissonRatio Property
StructuralAsset Class See Also Send Feedback
The Poisson ratio of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public XYZ PoissonRatio { get; set; }
Visual Basic
Public Property PoissonRatio As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ PoissonRatio {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

This property cannot be used to set the Poisson ratio for wood-based and isotropic materials. For such assets, use setPoissonRatio instead.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null
Autodesk.Revit.Exceptions..::..InapplicableDataException | When setting this property: the material type is wood. -or- When setting this property: the behavior is isotropic.

See Also

StructuralAsset Class


ShearModulus Property

[image]

Revit 2024 API
StructuralAsset..::..ShearModulus Property
StructuralAsset Class See Also Send Feedback
The shear modulus of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public XYZ ShearModulus { get; set; }
Visual Basic
Public Property ShearModulus As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ ShearModulus {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

This property cannot be used to set the shear modulus for wood-based and isotropic materials. For such assets, use setShearModulus instead. The value is in Newtons per foot meter (N/(ft Â· m)).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null
Autodesk.Revit.Exceptions..::..InapplicableDataException | When setting this property: the material type is wood. -or- When setting this property: the behavior is isotropic.

See Also

StructuralAsset Class


StructuralAssetClass Property

[image]

Revit 2024 API
StructuralAsset..::..StructuralAssetClass Property
StructuralAsset Class See Also Send Feedback
The type of material that this structural asset describes (e.g. wood, concrete, metal.)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public StructuralAssetClass StructuralAssetClass { get; }
Visual Basic
Public ReadOnly Property StructuralAssetClass As StructuralAssetClass
    Get
Visual C++
public:
property StructuralAssetClass StructuralAssetClass {
    StructuralAssetClass get ();
}

See Also

StructuralAsset Class


SubClass Property

[image]

Revit 2024 API
StructuralAsset..::..SubClass Property
StructuralAsset Class See Also Send Feedback
The sub-class of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public string SubClass { get; set; }
Visual Basic
Public Property SubClass As String
    Get
    Set
Visual C++
public:
property String^ SubClass {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

StructuralAsset Class


ThermalExpansionCoefficient Property

[image]

Revit 2024 API
StructuralAsset..::..ThermalExpansionCoefficient Property
StructuralAsset Class See Also Send Feedback
The thermal expansion coefficient of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public XYZ ThermalExpansionCoefficient { get; set; }
Visual Basic
Public Property ThermalExpansionCoefficient As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ ThermalExpansionCoefficient {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

This property cannot be used to set the thermal expansion coefficient for wood-based and isotropic materials. For such assets, use setThermalExpansionCoefficient instead. The value is in inverse Kelvin (1/K).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null
Autodesk.Revit.Exceptions..::..InapplicableDataException | When setting this property: the material type is wood. -or- When setting this property: the behavior is isotropic.

See Also

StructuralAsset Class


WoodGrade Property

[image]

Revit 2024 API
StructuralAsset..::..WoodGrade Property
StructuralAsset Class See Also Send Feedback
The grade of wood used in a wood-based asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public string WoodGrade { get; set; }
Visual Basic
Public Property WoodGrade As String
    Get
    Set
Visual C++
public:
property String^ WoodGrade {
    String^ get ();
    void set (String^ value);
}

Remarks

Applies to wood-based structural assets.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null
Autodesk.Revit.Exceptions..::..InapplicableDataException | When setting this property: the material type must be wood to set this property.

See Also

StructuralAsset Class


WoodParallelCompressionStrength Property

[image]

Revit 2024 API
StructuralAsset..::..WoodParallelCompressionStrength Property
StructuralAsset Class See Also Send Feedback
The parallel compression strength of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double WoodParallelCompressionStrength { get; set; }
Visual Basic
Public Property WoodParallelCompressionStrength As Double
    Get
    Set
Visual C++
public:
property double WoodParallelCompressionStrength {
    double get ();
    void set (double value);
}

Remarks

Applies to wood-based structural assets. The value is in Newtons per foot meter (N/(ft Â· m)).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | When setting this property: the material type must be wood to set this property.

See Also

StructuralAsset Class


WoodParallelShearStrength Property

[image]

Revit 2024 API
StructuralAsset..::..WoodParallelShearStrength Property
StructuralAsset Class See Also Send Feedback
The parallel shear strength of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double WoodParallelShearStrength { get; set; }
Visual Basic
Public Property WoodParallelShearStrength As Double
    Get
    Set
Visual C++
public:
property double WoodParallelShearStrength {
    double get ();
    void set (double value);
}

Remarks

Applies to wood-based structural assets. The value is in Newtons per foot meter (N/(ft Â· m)).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | When setting this property: the material type must be wood to set this property.

See Also

StructuralAsset Class


WoodPerpendicularCompressionStrength Property

[image]

Revit 2024 API
StructuralAsset..::..WoodPerpendicularCompressionStrength Property
StructuralAsset Class See Also Send Feedback
The perpendicular compression strength of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double WoodPerpendicularCompressionStrength { get; set; }
Visual Basic
Public Property WoodPerpendicularCompressionStrength As Double
    Get
    Set
Visual C++
public:
property double WoodPerpendicularCompressionStrength {
    double get ();
    void set (double value);
}

Remarks

Applies to wood-based structural assets. The value is in Newtons per foot meter (N/(ft Â· m)).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | When setting this property: the material type must be wood to set this property.

See Also

StructuralAsset Class


WoodPerpendicularShearStrength Property

[image]

Revit 2024 API
StructuralAsset..::..WoodPerpendicularShearStrength Property
StructuralAsset Class See Also Send Feedback
The perpendicular shear strength of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double WoodPerpendicularShearStrength { get; set; }
Visual Basic
Public Property WoodPerpendicularShearStrength As Double
    Get
    Set
Visual C++
public:
property double WoodPerpendicularShearStrength {
    double get ();
    void set (double value);
}

Remarks

Applies to wood-based structural assets. The value is in Newtons per foot meter (N/(ft Â· m)).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | When setting this property: the material type must be wood to set this property.

See Also

StructuralAsset Class


WoodSpecies Property

[image]

Revit 2024 API
StructuralAsset..::..WoodSpecies Property
StructuralAsset Class See Also Send Feedback
The species of wood used in a wood-based asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public string WoodSpecies { get; set; }
Visual Basic
Public Property WoodSpecies As String
    Get
    Set
Visual C++
public:
property String^ WoodSpecies {
    String^ get ();
    void set (String^ value);
}

Remarks

Applies to wood-based structural assets.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null
Autodesk.Revit.Exceptions..::..InapplicableDataException | When setting this property: the material type must be wood to set this property.

See Also

StructuralAsset Class


YoungModulus Property

[image]

Revit 2024 API
StructuralAsset..::..YoungModulus Property
StructuralAsset Class See Also Send Feedback
The Young's modulus of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public XYZ YoungModulus { get; set; }
Visual Basic
Public Property YoungModulus As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ YoungModulus {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

This property cannot be used to set the Young's modulus for wood-based and isotropic materials. For such assets, use setYoungModulus instead. The value is in Newtons per foot meter (N/(ft Â· m)).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null
Autodesk.Revit.Exceptions..::..InapplicableDataException | When setting this property: the material type is wood. -or- When setting this property: the behavior is isotropic.

See Also

StructuralAsset Class


StructuralReleaseType Enumeration

[image]

Revit 2024 API
StructuralReleaseType Enumeration
See Also Send Feedback
Type of structural release, which is used for the BuiltIn parameter STRUCTURAL_END_RELEASE_TYPE.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum StructuralReleaseType
Visual Basic
Public Enumeration StructuralReleaseType
Visual C++
public enum class StructuralReleaseType

Members

Member name | Description
kFixed |
kPinned |
kBendingMoment |
kUserDefined |

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


Subelement Class

[image]

Revit 2024 API
Subelement Class
Members See Also Send Feedback
An object that represents an element or a subelement within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public class Subelement : IDisposable
Visual Basic
Public Class Subelement _
    Implements IDisposable
Visual C++
public ref class Subelement : IDisposable

Remarks

Subelements provide a way for parts of an element to behave as though they were real elements without incurring the overhead of adding more full elements to the model.

Many Revit features (for example parameters, schedules, and tags) were designed to operate on Elements. As a result, the Revit code needs to represent objects as Elements for them to participate in those features. This can lead to scalability problems, because every Element adds overhead and adding many Elements may decrease the performance of the model. An alternative is to use Subelements. An element can expose a set of "Subelements" that it contains, specifying characteristics like their category and parameters, and certain Revit capabilities will treat those Subelements the same as ordinary Elements. For example, a Subelement may contribute geometry to the main element and may be able to be selected independently of its parent Element. It will possibly have its own (settable) type as well as an assigned category which can be different from its parent Element.

In the API, the new Subelement class is used to refer to either an Element or a specific subelement of a given Element. It is typically directly related to a Reference to either the Element or the specific subelement. Note that creation of new Subelements for a given element is not done generically. Instead, the given Element may provide the ability to modify it's definition, resulting in the creation of new Subelements.

Examples of Elements which may have Subelements in practice include:

  • RebarContainer
  • Rebar
  • FabricSheet
  • Stairs elements which make up MultistoryStairs elements
  • Railing
  • [!:Autodesk::Revit::DB::Architecture::ContinuousRail]

To get access to a particular Subelement, you may use any of the following:

  • Create(Document, Reference)
  • IsValidSubelementReference(Document, Reference)
  • Autodesk.Revit.DB.Document.GetSubelement(Autodesk.Revit.DB.Reference) if you have a Reference to a Subelement.
  • Autodesk.Revit.DB.Document.GetSubelement(String) if you have a unique id of a Subelement.
  • GetSubelements()()()()

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Subelement

See Also

Subelement Members


Subelement Members

[image] [image]

Revit 2024 API
Subelement Members
Subelement Class Methods Properties See Also Send Feedback

The Subelement type exposes the following members.

Methods

 | Name | Description
Public method | CanHaveTypeAssigned | Identifies if the subelement can have a type assigned.
Public method | ChangeTypeId | Changes the type of the subelement.
 | Create | Creates an object representing element or subelement.
Public method | Dispose | Releases all resources used by the Subelement
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAllParameters | Returns all parameters of this subelement.
Public method | GetBoundingBox | Retrieves a box that circumscribes all geometry of the subelement.
Public method | GetGeometryObject | Retrieve one geometric primitive representing given subelement.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParameterValue | Obtains the current parameter value of this subelement given a parameter id.
Public method | GetReference | Obtains the reference to this subelement.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidTypes | Obtains a set of types that are valid for this subelement.
Public method | HasParameter | Checks if this subelement have given parameter.
Public method | IsParameterModifiable | Checks if given parameter of this subelement is modifiable.
 | IsValidSubelementReference | Checks if given Reference identifies either a valid element or subelement.
Public method | IsValidType | Checks if given type is valid for this subelement.
Public method | SetParameterValue | Sets a new parameter value of this subelement given a parameter id.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Category | Retrieves a Category object that represents the category or sub category of the subelement.
Public property | Document | The document in which the subelement resides.
Public property | Element | The element in which the subelement resides.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | TypeId | The identifier of this subelement's type.
Public property | UniqueId | A stable unique identifier for this subelement within the document.

See Also

Subelement Class


ChangeTypeId Method

[image]

Revit 2024 API
Subelement..::..ChangeTypeId Method
Subelement Class See Also Send Feedback
Changes the type of the subelement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public void ChangeTypeId(
    ElementId typeId
)
Visual Basic
Public Sub ChangeTypeId ( _
    typeId As ElementId _
)
Visual C++
public:
void ChangeTypeId(
    ElementId^ typeId
)

Parameters

typeId
Type: Autodesk.Revit.DB..::..ElementId
Identifier of the type to assign to this subelement.

Remarks

In rare cases, applying a change in type will result in a new element being created. The only active examples of this are when:
  • Applying a normal wall type to a curtain panel.
  • Converting such a wall back to a curtain panel.
  • Applying a new type to a railing subelement.
In this situation this subelement object will be redirected to the new element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The type typeId is not valid for this subelement.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This Subelement cannot have type assigned.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | This Subelement is an internal element, such as a component of a loaded family or a group type. -or- The document containing this Subelement is in Group Edit Mode, Sketch Edit Mode, or Paste Mode, and the element is not a member of the group, sketch, or clipboard. -or- This Subelement is a member of a group or sketch, and the document is not currently editing the group or sketch.

See Also

Subelement Class


Create Method

[image]

Revit 2024 API
Subelement..::..Create Method
Subelement Class See Also Send Feedback
Creates an object representing element or subelement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public static Subelement Create(
    Document aDoc,
    Reference reference
)
Visual Basic
Public Shared Function Create ( _
    aDoc As Document, _
    reference As Reference _
) As Subelement
Visual C++
public:
static Subelement^ Create(
    Document^ aDoc,
    Reference^ reference
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
The document.
reference
Type: Autodesk.Revit.DB..::..Reference
The reference that identifies element or subelement.

Return Value

The newly created subelement.

Remarks

If %reference% points to linked document:
  • The GetReference()()()() method of the newly created subelement will return the local reference in the linked document.
  • The Document property of the newly created subelement will return the linked document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | reference does not identify a valid element or subelement.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Subelement Class


Dispose Method

[image]

Revit 2024 API
Subelement..::..Dispose Method
Subelement Class See Also Send Feedback
Releases all resources used by the Subelement

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

Subelement Class


GetBoundingBox Method

[image]

Revit 2024 API
Subelement..::..GetBoundingBox Method
Subelement Class See Also Send Feedback
Retrieves a box that circumscribes all geometry of the subelement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public BoundingBoxXYZ GetBoundingBox(
    View dbView
)
Visual Basic
Public Function GetBoundingBox ( _
    dbView As View _
) As BoundingBoxXYZ
Visual C++
public:
BoundingBoxXYZ^ GetBoundingBox(
    View^ dbView
)

Parameters

dbView
Type: Autodesk.Revit.DB..::..View
The view for view-specific geometry or nullNothingnullptra null reference (Nothing in Visual Basic) for model geometry.

Return Value

The bounding box.

Remarks

Pass in a view to query view-specific (e.g., cut) geometry or nullNothingnullptra null reference (Nothing in Visual Basic) for model geometry. If the view box is not known or cannot be calculated, this will return the model box; if the model box is not known, this will return nullNothingnullptra null reference (Nothing in Visual Basic). The box will always be aligned to the default axes of the model coordinate system (thus no rotation should be applied to the return value). Also note that this bounding box volume may enclose geometry that is not obvious. For example, the "flip controls" that could be part of a family will be included in the computation of the bounding box even though they are not always visible in the family instance of the family.

See Also

Subelement Class


GetGeometryObject Method

[image]

Revit 2024 API
Subelement..::..GetGeometryObject Method
Subelement Class See Also Send Feedback
Retrieve one geometric primitive representing given subelement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public GeometryObject GetGeometryObject(
    View dbView
)
Visual Basic
Public Function GetGeometryObject ( _
    dbView As View _
) As GeometryObject
Visual C++
public:
GeometryObject^ GetGeometryObject(
    View^ dbView
)

Parameters

dbView
Type: Autodesk.Revit.DB..::..View
The view for view-specific geometry or nullNothingnullptra null reference (Nothing in Visual Basic) for model geometry.

Return Value

The geometric object representing this subelement.

Remarks

In case of whole element, geometric object representing element and its subelements will be returned. nullNothingnullptra null reference (Nothing in Visual Basic) will be returned if related geometric object could not be found in the model.

See Also

Subelement Class


GetParameterValue Method

[image]

Revit 2024 API
Subelement..::..GetParameterValue Method
Subelement Class See Also Send Feedback
Obtains the current parameter value of this subelement given a parameter id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public ParameterValue GetParameterValue(
    ElementId parameterId
)
Visual Basic
Public Function GetParameterValue ( _
    parameterId As ElementId _
) As ParameterValue
Visual C++
public:
ParameterValue^ GetParameterValue(
    ElementId^ parameterId
)

Parameters

parameterId
Type: Autodesk.Revit.DB..::..ElementId
Parameter id.

Return Value

Parameter value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | parameterId does not identify a valid parameter of this subelement.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Subelement Class


GetReference Method

[image]

Revit 2024 API
Subelement..::..GetReference Method
Subelement Class See Also Send Feedback
Obtains the reference to this subelement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public Reference GetReference()
Visual Basic
Public Function GetReference As Reference
Visual C++
public:
Reference^ GetReference()

Return Value

The reference to this subelement.

See Also

Subelement Class


HasParameter Method

[image]

Revit 2024 API
Subelement..::..HasParameter Method
Subelement Class See Also Send Feedback
Checks if this subelement have given parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public bool HasParameter(
    ElementId parameterId
)
Visual Basic
Public Function HasParameter ( _
    parameterId As ElementId _
) As Boolean
Visual C++
public:
bool HasParameter(
    ElementId^ parameterId
)

Parameters

parameterId
Type: Autodesk.Revit.DB..::..ElementId
Parameter id.

Return Value

True if %parameterId% identifies valid parameter of this subelement, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Subelement Class


IsParameterModifiable Method

[image]

Revit 2024 API
Subelement..::..IsParameterModifiable Method
Subelement Class See Also Send Feedback
Checks if given parameter of this subelement is modifiable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public bool IsParameterModifiable(
    ElementId parameterId
)
Visual Basic
Public Function IsParameterModifiable ( _
    parameterId As ElementId _
) As Boolean
Visual C++
public:
bool IsParameterModifiable(
    ElementId^ parameterId
)

Parameters

parameterId
Type: Autodesk.Revit.DB..::..ElementId
Parameter id.

Return Value

True if given parameter of this subelement is modifiable, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Subelement Class


IsValidSubelementReference Method

[image]

Revit 2024 API
Subelement..::..IsValidSubelementReference Method
Subelement Class See Also Send Feedback
Checks if given Reference identifies either a valid element or subelement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public static bool IsValidSubelementReference(
    Document aDoc,
    Reference reference
)
Visual Basic
Public Shared Function IsValidSubelementReference ( _
    aDoc As Document, _
    reference As Reference _
) As Boolean
Visual C++
public:
static bool IsValidSubelementReference(
    Document^ aDoc,
    Reference^ reference
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
The document.
reference
Type: Autodesk.Revit.DB..::..Reference
The reference that identifies an element or subelement.

Return Value

True if %reference% identifies a valid element or subelement, false otherwise.

Remarks

A reference to an element or subelement in a linked document is acceptable.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Subelement Class


IsValidType Method

[image]

Revit 2024 API
Subelement..::..IsValidType Method
Subelement Class See Also Send Feedback
Checks if given type is valid for this subelement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public bool IsValidType(
    ElementId typeId
)
Visual Basic
Public Function IsValidType ( _
    typeId As ElementId _
) As Boolean
Visual C++
public:
bool IsValidType(
    ElementId^ typeId
)

Parameters

typeId
Type: Autodesk.Revit.DB..::..ElementId
ElementId of the type to check.

Return Value

True if subelement can have a type assigned and this type is valid for this subelement, false otherwise.

Remarks

A type is valid for a subelement if it can be assigned to the subelement.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Subelement Class


SetParameterValue Method

[image]

Revit 2024 API
Subelement..::..SetParameterValue Method
Subelement Class See Also Send Feedback
Sets a new parameter value of this subelement given a parameter id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public void SetParameterValue(
    ElementId parameterId,
    ParameterValue pValue
)
Visual Basic
Public Sub SetParameterValue ( _
    parameterId As ElementId, _
    pValue As ParameterValue _
)
Visual C++
public:
void SetParameterValue(
    ElementId^ parameterId,
    ParameterValue^ pValue
)

Parameters

parameterId
Type: Autodesk.Revit.DB..::..ElementId
Parameter id.
pValue
Type: Autodesk.Revit.DB..::..ParameterValue
New value for the parameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | parameterId does not identify a valid parameter of this subelement. -or- The parameter parameterId is not modifiable for this subelement.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Subelement Class


Category Property

[image]

Revit 2024 API
Subelement..::..Category Property
Subelement Class See Also Send Feedback
Retrieves a Category object that represents the category or sub category of the subelement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Category Category { get; }
Visual Basic
Public ReadOnly Property Category As Category
    Get
Visual C++
public:
property Category^ Category {
    Category^ get ();
}

Remarks

All category objects can be retrieved from the application by using the Categories property of the Application.Settings object.

See Also

Subelement Class


Document Property

[image]

Revit 2024 API
Subelement..::..Document Property
Subelement Class See Also Send Feedback
The document in which the subelement resides.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public Document Document { get; }
Visual Basic
Public ReadOnly Property Document As Document
    Get
Visual C++
public:
property Document^ Document {
    Document^ get ();
}

See Also

Subelement Class


Element Property

[image]

Revit 2024 API
Subelement..::..Element Property
Subelement Class See Also Send Feedback
The element in which the subelement resides.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public Element Element { get; }
Visual Basic
Public ReadOnly Property Element As Element
    Get
Visual C++
public:
property Element^ Element {
    Element^ get ();
}

Remarks

If subelement refers to whole element, this element is returned.

See Also

Subelement Class


TypeId Property

[image]

Revit 2024 API
Subelement..::..TypeId Property
Subelement Class See Also Send Feedback
The identifier of this subelement's type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public ElementId TypeId { get; }
Visual Basic
Public ReadOnly Property TypeId As ElementId
    Get
Visual C++
public:
property ElementId^ TypeId {
    ElementId^ get ();
}

Remarks

Some subelements cannot have type assigned, in which case this method returns invalid element id.

See Also

Subelement Class


UniqueId Property

[image]

Revit 2024 API
Subelement..::..UniqueId Property
Subelement Class See Also Send Feedback
A stable unique identifier for this subelement within the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public string UniqueId { get; }
Visual Basic
Public ReadOnly Property UniqueId As String
    Get
Visual C++
public:
property String^ UniqueId {
    String^ get ();
}

See Also

Subelement Class


SubfaceType Enumeration

[image]

Revit 2024 API
SubfaceType Enumeration
See Also Send Feedback
Meaning of a subface's type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Since: 2012

Syntax

C#
public enum SubfaceType
Visual Basic
Public Enumeration SubfaceType
Visual C++
public enum class SubfaceType

Members

Member name | Description
Bottom | A horizontal face at the bottom of the room, as defined by the room's level and base offset, or a face of the room that is bounded below by a room-bounding element.
Top | A horizontal top face of the room as defined by the room's level and height, or a face of the room that is bounded above by a room-bounding element.
Side | Any face which does not meet the criteria to be Top or Bottom.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


SubTransaction Class

[image]

Revit 2024 API
SubTransaction Class
Members See Also Send Feedback
Sub-transactions are objects that provide control over a subset of changes in a document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class SubTransaction : IDisposable
Visual Basic
Public Class SubTransaction _
    Implements IDisposable
Visual C++
public ref class SubTransaction : IDisposable

Remarks

A Sub-transaction can only be active as a part of an open transaction. Sub-transactions may be nested inside each other, but with the restriction that every nested sub-transaction is entirely contained (opened and closed) in the parent sub-transaction.

If a sub-transaction was started and not committed or rolled back by the time the SubTransaction object is about to be disposed, the destructor will roll back the sub-transaction automatically, thus all changes made to the document during the sub-transaction will be discarded. It is not recommended to rely on this default behavior though. Instead, it is advised to always call either Commit or RollBack explicitly before the sub-transaction object gets disposed. Please note that unless invoked explicitly the actual destruction of an object in managed code might not happen until the object is collected by the garbage collector.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..SubTransaction

See Also

SubTransaction Members


SubTransaction Constructor

[image]

Revit 2024 API
SubTransaction Constructor
SubTransaction Class See Also Send Feedback
Instantiates a sub-transaction object

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public SubTransaction(
    Document document
)
Visual Basic
Public Sub New ( _
    document As Document _
)
Visual C++
public:
SubTransaction(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document for which this sub-transaction is going to be used.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

SubTransaction Class


SubTransaction Methods

[image] [image]

Revit 2024 API
SubTransaction Methods
SubTransaction Class See Also Send Feedback

The SubTransaction type exposes the following members.

Methods

 | Name | Description
Public method | Commit | Commits all changes made to the model made during the sub-transaction.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetStatus | Returns the current status of the sub-transaction.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasEnded | Determines whether the sub-transaction has ended already.
Public method | HasStarted | Determines whether the sub-transaction has been started yet.
Public method | RollBack | Discards all changes made to the model during the sub-transaction.
Public method | Start | Starts the sub-transaction.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SubTransaction Class


Commit Method

[image]

Revit 2024 API
SubTransaction..::..Commit Method
SubTransaction Class See Also Send Feedback
Commits all changes made to the model made during the sub-transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public TransactionStatus Commit()
Visual Basic
Public Function Commit As TransactionStatus
Visual C++
public:
TransactionStatus Commit()

Return Value

If finished successfully, this method returns TransactionStatus.Committed

Remarks

The changes are not permanently committed to the document yet. They will be committed only when the active transaction is committed. If the transaction is rolled back instead, the changes committed during this sub-transaction will be discarded.

Commit can be called only when all inner sub-transactions, if any, are already finished, i.e. they were either committed or rolled back. If there is still a sub-transaction open, an attempt to commit this outer sub-transaction will cause an exception.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | A sub-transaction can only be active inside an open Transaction. -or- The sub-transaction's current status is not TransactionStatus.Started, therefore it may not be committed or rolled back.

See Also

SubTransaction Class


GetStatus Method

[image]

Revit 2024 API
SubTransaction..::..GetStatus Method
SubTransaction Class See Also Send Feedback
Returns the current status of the sub-transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public TransactionStatus GetStatus()
Visual Basic
Public Function GetStatus As TransactionStatus
Visual C++
public:
TransactionStatus GetStatus()

Return Value

The current status of the sub-transaction.

See Also

SubTransaction Class


HasEnded Method

[image]

Revit 2024 API
SubTransaction..::..HasEnded Method
SubTransaction Class See Also Send Feedback
Determines whether the sub-transaction has ended already.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool HasEnded()
Visual Basic
Public Function HasEnded As Boolean
Visual C++
public:
bool HasEnded()

Return Value

True if the sub-transaction has already been committed or rolled back, False otherwise.

Remarks

A sub-transaction is ended by completing either the Commit or RollBack method. Another way of testing whether a sub-transaction has ended is by testing its current status returned from (see GetStatus()()()()). It must be either 'TransactionStatus.Committed' or 'TransactionStatus.RolledBack'

See Also

SubTransaction Class


RollBack Method

[image]

Revit 2024 API
SubTransaction..::..RollBack Method
SubTransaction Class See Also Send Feedback
Discards all changes made to the model during the sub-transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public TransactionStatus RollBack()
Visual Basic
Public Function RollBack As TransactionStatus
Visual C++
public:
TransactionStatus RollBack()

Return Value

If finished successfully, this method returns TransactionStatus.RolledBack.

Remarks

The parent transaction (or a parent sub-transaction, if any) can still be committed, but the changes rolled back by this method will not be part of the committed transaction.

RollBack can be called only when all inner sub-transaction, if any, are finished, i.e. they were either committed or rolled back. If there is still a sub-transaction open, an attempt to roll this outer sub-transaction back will cause an exception.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | A sub-transaction can only be active inside an open Transaction. -or- The sub-transaction's current status is not TransactionStatus.Started, therefore it may not be committed or rolled back.

See Also

SubTransaction Class


Start Method

[image]

Revit 2024 API
SubTransaction..::..Start Method
SubTransaction Class See Also Send Feedback
Starts the sub-transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public TransactionStatus Start()
Visual Basic
Public Function Start As TransactionStatus
Visual C++
public:
TransactionStatus Start()

Return Value

If started successfully, this method returns TransactionStatus.Started.

Remarks

A sub-transaction can only be started in an open transaction, and it must be closed (committed or rolled back) while still inside the open transaction.

A sub-transaction can be started in another open sub-transaction, but then it must be closed before the parent sub-transaction is closed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Cannot modify the document for either a read-only external command is being executed, or changes to the document are temporarily disabled. -or- A sub-transaction can only be active inside an open Transaction. -or- The sub-transaction was already started and has not finished yet.

See Also

SubTransaction Class


SubTransaction Properties

[image] [image]

Revit 2024 API
SubTransaction Properties
SubTransaction Class See Also Send Feedback

The SubTransaction type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

SubTransaction Class


IsValidObject Property

[image]

Revit 2024 API
SubTransaction..::..IsValidObject Property
SubTransaction Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

SubTransaction Class


SunAndShadowSettings Members

[image] [image]

Revit 2024 API
SunAndShadowSettings Members
SunAndShadowSettings Class Methods Properties See Also Send Feedback

The SunAndShadowSettings type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
 | CalculateTimeZone | Use Revit's utilities to calculate the time zone for a given longitude and latitude.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | FitToModel | Adjust SunAndShadowSettings to fit around the current model geometry.
 | GetActiveSunAndShadowSettings | Returns the current SunAndShadowSettings element assigned to the active view for the supplied document.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetFrameAltitude | Identifies the altitude of the sun (angle in radians) for a specific frame.
Public method | GetFrameAzimuth | Identifies the azimuth of the sun (angle in radians) for a specific frame.
Public method | GetFrameTime | Identifies the date and time of the SunAndShadowSettings element for a given frame.
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMatchingPreset | Finds the name of the 'per-document' SunAndShadowSettings that matches the properties of this per-view element.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetSunrise | Identifies the sunrise time for the SunAndShadowSettings element at its current location and indicated date.
Public method | GetSunset | Identifies the sunset time for the SunAndShadowSettings element at its current location and indicated date.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsAfterStartDateAndTime | Checks whether the end date and time is valid.
Public method | IsBeforeEndDateAndTime | Checks whether the start date and time is valid.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsFrameValid | Checks whether the frame is valid for the supplied SunAndShadowSettings.
Public method | IsGroundPlaneLevelValid | Checks whether the element represents a valid Ground Plane level.
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsTimeIntervalValid | Checks whether the time interval is valid for the SunAndShadowType.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActiveFrame | Identifies the active animation frame for a single-day or multi-day study, starting at 1.0 for the first frame and incrementing in intervals of 1.0.
Public property | ActiveFrameTime | Identifies the date and time of the SunAndShadowSettings element for the active frame.
Public property | Altitude | Altitude setting (angle in radians). This is only relevant when dealing with a SunAndShadowSettings element that uses lighting mode.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | Azimuth | Azimuth setting (angle in radians). This is only relevant when dealing with a SunAndShadowSettings element that uses lighting mode.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EndDateAndTime | Identifies the end date and time.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroundPlaneHeight | Identifies the ground plane height.
Public property | GroundPlaneLevelId | Identifies the element id of the Ground Plane level for the SunAndShadowSettings element.
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | Latitude | Identifies the current latitude used by the SunAndShadowSettings element.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Longitude | Identifies the current longitude used by the SunAndShadowSettings element.
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | NumberOfFrames | Identifies the total number of animation frames for a single-day or multi-day study.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ProjectLocationId | Identifies the ProjectLocation element used by the SunAndShadowSettings element.
Public property | ProjectLocationName | Identifies the name of the project location used by the SunAndShadowSettings element.
Public property | RelativeToView | Identifies whether the SunAndShadowSettings element is relative to the view direction. This is only relevant for lighting mode.
Public property | SharesSettings | Identifies whether settings are shared globally.
Public property | StartDateAndTime | Identifies the start or current date and time.
Public property | SunAndShadowType | Identifies the type of the SunAndShadowSettings element.
Public property | SunriseToSunset | Identifies whether the current single day sun study is set to run from sunrise to sunset.
Public property | TimeInterval | Identifies the time interval between animation frames.
Public property | TimeZone | Identifies the time zone.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UsesDST | Identifies whether the SunAndShadowSettings element is using daylight savings time.
Public property | UsesGroundPlane | Identifies whether the SunAndShadowSettings element uses a ground plane.
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Visible | Visibility in current view for a per-view SunAndShadowSettings element.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SunAndShadowSettings Class


SunAndShadowSettings Methods

[image] [image]

Revit 2024 API
SunAndShadowSettings Methods
SunAndShadowSettings Class See Also Send Feedback

The SunAndShadowSettings type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
 | CalculateTimeZone | Use Revit's utilities to calculate the time zone for a given longitude and latitude.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | FitToModel | Adjust SunAndShadowSettings to fit around the current model geometry.
 | GetActiveSunAndShadowSettings | Returns the current SunAndShadowSettings element assigned to the active view for the supplied document.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetFrameAltitude | Identifies the altitude of the sun (angle in radians) for a specific frame.
Public method | GetFrameAzimuth | Identifies the azimuth of the sun (angle in radians) for a specific frame.
Public method | GetFrameTime | Identifies the date and time of the SunAndShadowSettings element for a given frame.
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMatchingPreset | Finds the name of the 'per-document' SunAndShadowSettings that matches the properties of this per-view element.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetSunrise | Identifies the sunrise time for the SunAndShadowSettings element at its current location and indicated date.
Public method | GetSunset | Identifies the sunset time for the SunAndShadowSettings element at its current location and indicated date.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsAfterStartDateAndTime | Checks whether the end date and time is valid.
Public method | IsBeforeEndDateAndTime | Checks whether the start date and time is valid.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsFrameValid | Checks whether the frame is valid for the supplied SunAndShadowSettings.
Public method | IsGroundPlaneLevelValid | Checks whether the element represents a valid Ground Plane level.
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsTimeIntervalValid | Checks whether the time interval is valid for the SunAndShadowType.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SunAndShadowSettings Class


CalculateTimeZone Method

[image]

Revit 2024 API
SunAndShadowSettings..::..CalculateTimeZone Method
SunAndShadowSettings Class See Also Send Feedback
Use Revit's utilities to calculate the time zone for a given longitude and latitude.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static double CalculateTimeZone(
    double latitude,
    double longitude
)
Visual Basic
Public Shared Function CalculateTimeZone ( _
    latitude As Double, _
    longitude As Double _
) As Double
Visual C++
public:
static double CalculateTimeZone(
    double latitude,
    double longitude
)

Parameters

latitude
Type: System..::..Double
The latitude.
longitude
Type: System..::..Double
The longitude.

Return Value

The time zone, in hours, ranging from +12 hours to -12 hours with 0 being GMT.

Remarks

For some latitude and longitude boundary cases, the time zone calculated may not be correct. The API offers the ability to adjust the time zone independent of Revit's calculations for situations where this happens.

See Also

SunAndShadowSettings Class


FitToModel Method

[image]

Revit 2024 API
SunAndShadowSettings..::..FitToModel Method
SunAndShadowSettings Class See Also Send Feedback
Adjust SunAndShadowSettings to fit around the current model geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public void FitToModel()
Visual Basic
Public Sub FitToModel
Visual C++
public:
void FitToModel()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The SunAndShadowSettings is not view-specific.

See Also

SunAndShadowSettings Class


GetActiveSunAndShadowSettings Method

[image]

Revit 2024 API
SunAndShadowSettings..::..GetActiveSunAndShadowSettings Method
SunAndShadowSettings Class See Also Send Feedback
Returns the current SunAndShadowSettings element assigned to the active view for the supplied document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static Element GetActiveSunAndShadowSettings(
    Document aDocument
)
Visual Basic
Public Shared Function GetActiveSunAndShadowSettings ( _
    aDocument As Document _
) As Element
Visual C++
public:
static Element^ GetActiveSunAndShadowSettings(
    Document^ aDocument
)

Parameters

aDocument
Type: Autodesk.Revit.DB..::..Document
The document.

Return Value

The active SunAndShadowSettings element for the supplied document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

SunAndShadowSettings Class


GetFrameAltitude Method

[image]

Revit 2024 API
SunAndShadowSettings..::..GetFrameAltitude Method
SunAndShadowSettings Class See Also Send Feedback
Identifies the altitude of the sun (angle in radians) for a specific frame.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public double GetFrameAltitude(
    double frame
)
Visual Basic
Public Function GetFrameAltitude ( _
    frame As Double _
) As Double
Visual C++
public:
double GetFrameAltitude(
    double frame
)

Parameters

frame
Type: System..::..Double
Frame for which time is requested

Return Value

Altitude angle (radians)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | the frame value frame is not valid.

See Also

SunAndShadowSettings Class


GetFrameTime Method

[image]

Revit 2024 API
SunAndShadowSettings..::..GetFrameTime Method
SunAndShadowSettings Class See Also Send Feedback
Identifies the date and time of the SunAndShadowSettings element for a given frame.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public DateTime GetFrameTime(
    double frame
)
Visual Basic
Public Function GetFrameTime ( _
    frame As Double _
) As DateTime
Visual C++
public:
DateTime GetFrameTime(
    double frame
)

Parameters

frame
Type: System..::..Double
Frame for which time is requested

Return Value

The date and time. The value will be in Coordinated Universal Time (UTC).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | the frame value frame is not valid.

See Also

SunAndShadowSettings Class


GetSunrise Method

[image]

Revit 2024 API
SunAndShadowSettings..::..GetSunrise Method
SunAndShadowSettings Class See Also Send Feedback
Identifies the sunrise time for the SunAndShadowSettings element at its current location and indicated date.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public DateTime GetSunrise(
    DateTime date
)
Visual Basic
Public Function GetSunrise ( _
    date As DateTime _
) As DateTime
Visual C++
public:
DateTime GetSunrise(
    DateTime date
)

Parameters

date
Type: System..::..DateTime
The date for which to determine sunrise time.

Return Value

The date and time. The value will be in Coordinated Universal Time (UTC).

Remarks

The value returned is affected by the value of the UsesDST flag set for the current location. If this value is true, the sunrise value will be adjusted for Daylight Savings Time, regardless of the value of the input date.

See Also

SunAndShadowSettings Class


GetSunset Method

[image]

Revit 2024 API
SunAndShadowSettings..::..GetSunset Method
SunAndShadowSettings Class See Also Send Feedback
Identifies the sunset time for the SunAndShadowSettings element at its current location and indicated date.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public DateTime GetSunset(
    DateTime date
)
Visual Basic
Public Function GetSunset ( _
    date As DateTime _
) As DateTime
Visual C++
public:
DateTime GetSunset(
    DateTime date
)

Parameters

date
Type: System..::..DateTime
The date for which to determine sunset time.

Return Value

The date and time. The value will be in Coordinated Universal Time (UTC).

Remarks

The value returned is affected by the value of the UsesDST flag set for the current location. If this value is true, the sunset value will be adjusted for Daylight Savings Time, regardless of the value of the input date.

See Also

SunAndShadowSettings Class


IsAfterStartDateAndTime Method

[image]

Revit 2024 API
SunAndShadowSettings..::..IsAfterStartDateAndTime Method
SunAndShadowSettings Class See Also Send Feedback
Checks whether the end date and time is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool IsAfterStartDateAndTime(
    DateTime time
)
Visual Basic
Public Function IsAfterStartDateAndTime ( _
    time As DateTime _
) As Boolean
Visual C++
public:
bool IsAfterStartDateAndTime(
    DateTime time
)

Parameters

time
Type: System..::..DateTime
Date and time value

Return Value

True if the date and time is valid, false otherwise.

See Also

SunAndShadowSettings Class


IsFrameValid Method

[image]

Revit 2024 API
SunAndShadowSettings..::..IsFrameValid Method
SunAndShadowSettings Class See Also Send Feedback
Checks whether the frame is valid for the supplied SunAndShadowSettings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool IsFrameValid(
    double frame
)
Visual Basic
Public Function IsFrameValid ( _
    frame As Double _
) As Boolean
Visual C++
public:
bool IsFrameValid(
    double frame
)

Parameters

frame
Type: System..::..Double
Frame value

Return Value

True if the frame is valid for the SunAndShadowSettings, false otherwise.

See Also

SunAndShadowSettings Class


IsGroundPlaneLevelValid Method

[image]

Revit 2024 API
SunAndShadowSettings..::..IsGroundPlaneLevelValid Method
SunAndShadowSettings Class See Also Send Feedback
Checks whether the element represents a valid Ground Plane level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool IsGroundPlaneLevelValid(
    ElementId levelId
)
Visual Basic
Public Function IsGroundPlaneLevelValid ( _
    levelId As ElementId _
) As Boolean
Visual C++
public:
bool IsGroundPlaneLevelValid(
    ElementId^ levelId
)

Parameters

levelId
Type: Autodesk.Revit.DB..::..ElementId
Level element id.

Return Value

True if the element is a valid Ground Plane Level, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

SunAndShadowSettings Class


IsTimeIntervalValid Method

[image]

Revit 2024 API
SunAndShadowSettings..::..IsTimeIntervalValid Method
SunAndShadowSettings Class See Also Send Feedback
Checks whether the time interval is valid for the SunAndShadowType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool IsTimeIntervalValid(
    SunStudyTimeInterval interval
)
Visual Basic
Public Function IsTimeIntervalValid ( _
    interval As SunStudyTimeInterval _
) As Boolean
Visual C++
public:
bool IsTimeIntervalValid(
    SunStudyTimeInterval interval
)

Parameters

interval
Type: Autodesk.Revit.DB..::..SunStudyTimeInterval
Time interval value.

Return Value

True if the time interval is valid for the current SunAndShadowType, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

SunAndShadowSettings Class


SunAndShadowSettings Properties

[image] [image]

Revit 2024 API
SunAndShadowSettings Properties
SunAndShadowSettings Class See Also Send Feedback

The SunAndShadowSettings type exposes the following members.

Properties

 | Name | Description
Public property | ActiveFrame | Identifies the active animation frame for a single-day or multi-day study, starting at 1.0 for the first frame and incrementing in intervals of 1.0.
Public property | ActiveFrameTime | Identifies the date and time of the SunAndShadowSettings element for the active frame.
Public property | Altitude | Altitude setting (angle in radians). This is only relevant when dealing with a SunAndShadowSettings element that uses lighting mode.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | Azimuth | Azimuth setting (angle in radians). This is only relevant when dealing with a SunAndShadowSettings element that uses lighting mode.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EndDateAndTime | Identifies the end date and time.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroundPlaneHeight | Identifies the ground plane height.
Public property | GroundPlaneLevelId | Identifies the element id of the Ground Plane level for the SunAndShadowSettings element.
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | Latitude | Identifies the current latitude used by the SunAndShadowSettings element.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Longitude | Identifies the current longitude used by the SunAndShadowSettings element.
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | NumberOfFrames | Identifies the total number of animation frames for a single-day or multi-day study.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ProjectLocationId | Identifies the ProjectLocation element used by the SunAndShadowSettings element.
Public property | ProjectLocationName | Identifies the name of the project location used by the SunAndShadowSettings element.
Public property | RelativeToView | Identifies whether the SunAndShadowSettings element is relative to the view direction. This is only relevant for lighting mode.
Public property | SharesSettings | Identifies whether settings are shared globally.
Public property | StartDateAndTime | Identifies the start or current date and time.
Public property | SunAndShadowType | Identifies the type of the SunAndShadowSettings element.
Public property | SunriseToSunset | Identifies whether the current single day sun study is set to run from sunrise to sunset.
Public property | TimeInterval | Identifies the time interval between animation frames.
Public property | TimeZone | Identifies the time zone.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UsesDST | Identifies whether the SunAndShadowSettings element is using daylight savings time.
Public property | UsesGroundPlane | Identifies whether the SunAndShadowSettings element uses a ground plane.
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Visible | Visibility in current view for a per-view SunAndShadowSettings element.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SunAndShadowSettings Class


ActiveFrameTime Property

[image]

Revit 2024 API
SunAndShadowSettings..::..ActiveFrameTime Property
SunAndShadowSettings Class See Also Send Feedback
Identifies the date and time of the SunAndShadowSettings element for the active frame.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public DateTime ActiveFrameTime { get; }
Visual Basic
Public ReadOnly Property ActiveFrameTime As DateTime
    Get
Visual C++
public:
property DateTime ActiveFrameTime {
    DateTime get ();
}

See Also

SunAndShadowSettings Class


Altitude Property

[image]

Revit 2024 API
SunAndShadowSettings..::..Altitude Property
SunAndShadowSettings Class See Also Send Feedback
Altitude setting (angle in radians). This is only relevant when dealing with a SunAndShadowSettings element that uses lighting mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public double Altitude { get; set; }
Visual Basic
Public Property Altitude As Double
    Get
    Set
Visual C++
public:
property double Altitude {
    double get ();
    void set (double value);
}

Field Value

Altitude angle (radians)

See Also

SunAndShadowSettings Class


GroundPlaneHeight Property

[image]

Revit 2024 API
SunAndShadowSettings..::..GroundPlaneHeight Property
SunAndShadowSettings Class See Also Send Feedback
Identifies the ground plane height.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public double GroundPlaneHeight { get; }
Visual Basic
Public ReadOnly Property GroundPlaneHeight As Double
    Get
Visual C++
public:
property double GroundPlaneHeight {
    double get ();
}

See Also

SunAndShadowSettings Class


Latitude Property

[image]

Revit 2024 API
SunAndShadowSettings..::..Latitude Property
SunAndShadowSettings Class See Also Send Feedback
Identifies the current latitude used by the SunAndShadowSettings element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public double Latitude { get; }
Visual Basic
Public ReadOnly Property Latitude As Double
    Get
Visual C++
public:
property double Latitude {
    double get ();
}

See Also

SunAndShadowSettings Class


Longitude Property

[image]

Revit 2024 API
SunAndShadowSettings..::..Longitude Property
SunAndShadowSettings Class See Also Send Feedback
Identifies the current longitude used by the SunAndShadowSettings element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public double Longitude { get; }
Visual Basic
Public ReadOnly Property Longitude As Double
    Get
Visual C++
public:
property double Longitude {
    double get ();
}

See Also

SunAndShadowSettings Class


NumberOfFrames Property

[image]

Revit 2024 API
SunAndShadowSettings..::..NumberOfFrames Property
SunAndShadowSettings Class See Also Send Feedback
Identifies the total number of animation frames for a single-day or multi-day study.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public double NumberOfFrames { get; }
Visual Basic
Public ReadOnly Property NumberOfFrames As Double
    Get
Visual C++
public:
property double NumberOfFrames {
    double get ();
}

See Also

SunAndShadowSettings Class


Parameter Property

[image] [image]

Revit 2024 API
SunAndShadowSettings..::..Parameter Property
SunAndShadowSettings Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

SunAndShadowSettings Class
SunAndShadowSettings Members


RelativeToView Property

[image]

Revit 2024 API
SunAndShadowSettings..::..RelativeToView Property
SunAndShadowSettings Class See Also Send Feedback
Identifies whether the SunAndShadowSettings element is relative to the view direction. This is only relevant for lighting mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool RelativeToView { get; set; }
Visual Basic
Public Property RelativeToView As Boolean
    Get
    Set
Visual C++
public:
property bool RelativeToView {
    bool get ();
    void set (bool value);
}

See Also

SunAndShadowSettings Class


SharesSettings Property

[image]

Revit 2024 API
SunAndShadowSettings..::..SharesSettings Property
SunAndShadowSettings Class See Also Send Feedback
Identifies whether settings are shared globally.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool SharesSettings { get; set; }
Visual Basic
Public Property SharesSettings As Boolean
    Get
    Set
Visual C++
public:
property bool SharesSettings {
    bool get ();
    void set (bool value);
}

Remarks

Identifies whether the per-view SunAndShadowSettings element shares global settings. Global settings are a special case that allows multiple views to be associated together in order that a change in one view affects that same change in other views. There cannot be multiple such groups, and a SunAndShadowSettings element is either a global setting or not.

See Also

SunAndShadowSettings Class


SunAndShadowType Property

[image]

Revit 2024 API
SunAndShadowSettings..::..SunAndShadowType Property
SunAndShadowSettings Class See Also Send Feedback
Identifies the type of the SunAndShadowSettings element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public SunAndShadowType SunAndShadowType { get; set; }
Visual Basic
Public Property SunAndShadowType As SunAndShadowType
    Get
    Set
Visual C++
public:
property SunAndShadowType SunAndShadowType {
    SunAndShadowType get ();
    void set (SunAndShadowType value);
}

Remarks

There are no restrictions on setting the type, but do note that some properties are not relevant for certain types. For example, the property EndDateAndTime is not relevant for the type SunAndShadowType.StillImage. In this example (and elsewhere), the previous value for the property is remembered for when the type is reverted. If that property has not been set yet, default values will apply.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

SunAndShadowSettings Class


SunriseToSunset Property

[image]

Revit 2024 API
SunAndShadowSettings..::..SunriseToSunset Property
SunAndShadowSettings Class See Also Send Feedback
Identifies whether the current single day sun study is set to run from sunrise to sunset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool SunriseToSunset { get; set; }
Visual Basic
Public Property SunriseToSunset As Boolean
    Get
    Set
Visual C++
public:
property bool SunriseToSunset {
    bool get ();
    void set (bool value);
}

See Also

SunAndShadowSettings Class


TimeInterval Property

[image]

Revit 2024 API
SunAndShadowSettings..::..TimeInterval Property
SunAndShadowSettings Class See Also Send Feedback
Identifies the time interval between animation frames.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public SunStudyTimeInterval TimeInterval { get; set; }
Visual Basic
Public Property TimeInterval As SunStudyTimeInterval
    Get
    Set
Visual C++
public:
property SunStudyTimeInterval TimeInterval {
    SunStudyTimeInterval get ();
    void set (SunStudyTimeInterval value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: the time interval value interval is not valid for the current SunAndShadowType.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

SunAndShadowSettings Class


TimeZone Property

[image]

Revit 2024 API
SunAndShadowSettings..::..TimeZone Property
SunAndShadowSettings Class See Also Send Feedback
Identifies the time zone.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public double TimeZone { get; }
Visual Basic
Public ReadOnly Property TimeZone As Double
    Get
Visual C++
public:
property double TimeZone {
    double get ();
}

Remarks

Identifies the time zone used by the SunAndShadowSettings element. This property indicates the time zone in which the site resides. The value is in hours, ranging from +12 hours to -12 hours with 0 being GMT.

See Also

SunAndShadowSettings Class


UsesDST Property

[image]

Revit 2024 API
SunAndShadowSettings..::..UsesDST Property
SunAndShadowSettings Class See Also Send Feedback
Identifies whether the SunAndShadowSettings element is using daylight savings time.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool UsesDST { get; }
Visual Basic
Public ReadOnly Property UsesDST As Boolean
    Get
Visual C++
public:
property bool UsesDST {
    bool get ();
}

See Also

SunAndShadowSettings Class


UsesGroundPlane Property

[image]

Revit 2024 API
SunAndShadowSettings..::..UsesGroundPlane Property
SunAndShadowSettings Class See Also Send Feedback
Identifies whether the SunAndShadowSettings element uses a ground plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool UsesGroundPlane { get; set; }
Visual Basic
Public Property UsesGroundPlane As Boolean
    Get
    Set
Visual C++
public:
property bool UsesGroundPlane {
    bool get ();
    void set (bool value);
}

See Also

SunAndShadowSettings Class


Visible Property

[image]

Revit 2024 API
SunAndShadowSettings..::..Visible Property
SunAndShadowSettings Class See Also Send Feedback
Visibility in current view for a per-view SunAndShadowSettings element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool Visible { get; set; }
Visual Basic
Public Property Visible As Boolean
    Get
    Set
Visual C++
public:
property bool Visible {
    bool get ();
    void set (bool value);
}

Field Value

Visibility

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element is not view specific (in which case visibility is not relevant) or if internally its view is not accessible.

See Also

SunAndShadowSettings Class


SunAndShadowType Enumeration

[image]

Revit 2024 API
SunAndShadowType Enumeration
See Also Send Feedback
Sun study type enum of SunAndShadowSettings.
Enum of sun study type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011
Since: 2011

Syntax

C#
public enum SunAndShadowType
Visual Basic
Public Enumeration SunAndShadowType
Visual C++
public enum class SunAndShadowType

Members

Member name | Description
StillImage | Still image study type (single point in time).
OneDayStudy | Single day study type (time range over a specific day).
MultiDayStudy | Multi day study type (range over date and time).
Lighting | Lighting study type (fixed sun position regardless of date and time).

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


Surface Class

[image]

Revit 2024 API
Surface Class
Members See Also Send Feedback
A mathematical representation of a surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public class Surface : IDisposable
Visual Basic
Public Class Surface _
    Implements IDisposable
Visual C++
public ref class Surface : IDisposable

Remarks

This geometric object is not bounded by edges or edge loops. A bounded surface obtained from a Revit element will be represented by a Face instead.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Surface
Autodesk.Revit.DB..::..ConicalSurface
Autodesk.Revit.DB..::..CylindricalSurface
Autodesk.Revit.DB..::..HermiteSurface
Autodesk.Revit.DB..::..OffsetSurface
Autodesk.Revit.DB..::..Plane
Autodesk.Revit.DB..::..RevolvedSurface
Autodesk.Revit.DB..::..RuledSurface

See Also

Surface Members


Surface Members

[image] [image]

Revit 2024 API
Surface Members
Surface Class Methods Properties See Also Send Feedback

The Surface type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the Surface
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBoundingBoxUV | Gets the UV bounding box of the surface.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Project | Project a 3D point orthogonally onto a surface (to find the nearest point). Throws InvalidOperationException if the projection fails.
Public method | ProjectWithGuessPoint | Project a 3D point orthogonally onto a surface (to find the nearest point). This method is meant to be used when a good approximate solution for the projection is available. Throws InvalidOperationException if the projection fails.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OrientationMatchesParametricOrientation | Indicates whether this Surface's orientation is the same as or opposite to its parametric orientation.

See Also

Surface Class


Surface Methods

[image] [image]

Revit 2024 API
Surface Methods
Surface Class See Also Send Feedback

The Surface type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBoundingBoxUV | Gets the UV bounding box of the surface.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Project | Project a 3D point orthogonally onto a surface (to find the nearest point). Throws InvalidOperationException if the projection fails.
Public method | ProjectWithGuessPoint | Project a 3D point orthogonally onto a surface (to find the nearest point). This method is meant to be used when a good approximate solution for the projection is available. Throws InvalidOperationException if the projection fails.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Surface Class


Dispose Method

[image]

Revit 2024 API
Surface..::..Dispose Method
Surface Class See Also Send Feedback
Releases all resources used by the Surface

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

Surface Class


GetBoundingBoxUV Method

[image]

Revit 2024 API
Surface..::..GetBoundingBoxUV Method
Surface Class See Also Send Feedback
Gets the UV bounding box of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public BoundingBoxUV GetBoundingBoxUV()
Visual Basic
Public Function GetBoundingBoxUV As BoundingBoxUV
Visual C++
public:
BoundingBoxUV^ GetBoundingBoxUV()

Return Value

The UV bounding box of the surface.

Remarks

The UV bounding box may not be set.

See Also

Surface Class


Project Method

[image]

Revit 2024 API
Surface..::..Project Method
Surface Class See Also Send Feedback
Project a 3D point orthogonally onto a surface (to find the nearest point). Throws InvalidOperationException if the projection fails.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018.1

Syntax

C#
public void Project(
    XYZ point,
    out UV uv,
    out double distance
)
Visual Basic
Public Sub Project ( _
    point As XYZ, _
    <OutAttribute> ByRef uv As UV, _
    <OutAttribute> ByRef distance As Double _
)
Visual C++
public:
void Project(
    XYZ^ point,
    [OutAttribute] UV^% uv,
    [OutAttribute] double% distance
)

Parameters

point
Type: Autodesk.Revit.DB..::..XYZ
The point to project.
uv
Type: Autodesk.Revit.DB..::..UV %
The surface coordinates of the projected point.
distance
Type: System..::..Double%
Holds the distance from input point to its projection.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The projection failed.

See Also

Surface Class


Surface Properties

[image] [image]

Revit 2024 API
Surface Properties
Surface Class See Also Send Feedback

The Surface type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OrientationMatchesParametricOrientation | Indicates whether this Surface's orientation is the same as or opposite to its parametric orientation.

See Also

Surface Class


IsValidObject Property

[image]

Revit 2024 API
Surface..::..IsValidObject Property
Surface Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

Surface Class


OrientationMatchesParametricOrientation Property

[image]

Revit 2024 API
Surface..::..OrientationMatchesParametricOrientation Property
Surface Class See Also Send Feedback
Indicates whether this Surface's orientation is the same as or opposite to its parametric orientation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public bool OrientationMatchesParametricOrientation { get; }
Visual Basic
Public ReadOnly Property OrientationMatchesParametricOrientation As Boolean
    Get
Visual C++
public:
property bool OrientationMatchesParametricOrientation {
    bool get ();
}

Remarks

(Revit uses only orientable surfaces). At any point on a surface, the surface's orientation is specified by a choice of the direction for the normal vector at that point.The direction can either match or be opposite to the direction of the parametric normal vector, which is the cross product of the surface's first partial derivatives: dS/du x dS/dv. The parametric normal vectors define the parametric orientation. A surface's orientation is then defined by getOrientationMatchesParametricOrientation() - if getOrientationMatchesParametricOrientation() is true, the surface's orientation is the same as its parametric orientation; otherwise it is opposite to its parametric orientation. The purpose of this information to an API user: Some systems, Industry Foundation Classes (IFC) for example, may only have parametric orientation for its surfaces. In such a system, the surface normal will always be the parametric normal, whereas in Revit, the surface normal will be the same as or opposite to the parametric normal according as getOrientationMatchesParametricOrientation is true or false. A user who is not familiar with Revit's orientation conventions might assume that Revit's normal vector is the same as the parametric normal, which is not always correct. Hence, this information is needed if and when the user tries to export Revit Geometry to IFC, for example. See also Face::OrientationMatchesSurfaceOrientation.

See Also

Surface Class


Sweep Members

[image] [image]

Revit 2024 API
Sweep Members
Sweep Class Methods Properties See Also Send Feedback

The Sweep type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Public property | IsTrajectorySegmentationEnabled | The trajectory segmentation option for the sweep.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MaxSegmentAngle | The maximum segment angle of the sweep in radians.
Public property | Name | Get and Set the Name property (Inherited from GenericForm.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Path3d | The selected curves used for the sweep path.
Public property | PathSketch | The sketched path for the sweep.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ProfileSketch | The profile sketch of the sweep.
Public property | ProfileSymbol | The family symbol profile details for the sweep.
Public property | Subcategory | The subcategory. (Inherited from GenericForm.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Visible | The visibility of the GenericForm. (Inherited from GenericForm.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Sweep Class


Sweep Methods

[image] [image]

Revit 2024 API
Sweep Methods
Sweep Class See Also Send Feedback

The Sweep type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Sweep Class


Sweep Properties

[image] [image]

Revit 2024 API
Sweep Properties
Sweep Class See Also Send Feedback

The Sweep type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Public property | IsTrajectorySegmentationEnabled | The trajectory segmentation option for the sweep.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MaxSegmentAngle | The maximum segment angle of the sweep in radians.
Public property | Name | Get and Set the Name property (Inherited from GenericForm.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Path3d | The selected curves used for the sweep path.
Public property | PathSketch | The sketched path for the sweep.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ProfileSketch | The profile sketch of the sweep.
Public property | ProfileSymbol | The family symbol profile details for the sweep.
Public property | Subcategory | The subcategory. (Inherited from GenericForm.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Visible | The visibility of the GenericForm. (Inherited from GenericForm.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Sweep Class


MaxSegmentAngle Property

[image]

Revit 2024 API
Sweep..::..MaxSegmentAngle Property
Sweep Class See Also Send Feedback
The maximum segment angle of the sweep in radians.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double MaxSegmentAngle { get; set; }
Visual Basic
Public Property MaxSegmentAngle As Double
    Get
    Set
Visual C++
public:
property double MaxSegmentAngle {
    double get ();
    void set (double value);
}

Remarks

This property is used to retrieve/set the maximum segment angle of the sweep. It is settable only when the trajectory segmentation is enabled.

See Also

Sweep Class


Parameter Property

[image] [image]

Revit 2024 API
Sweep..::..Parameter Property
Sweep Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Sweep Class
Sweep Members


Path3d Property

[image]

Revit 2024 API
Sweep..::..Path3d Property
Sweep Class See Also Send Feedback
The selected curves used for the sweep path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Path3d Path3d { get; }
Visual Basic
Public ReadOnly Property Path3d As Path3d
    Get
Visual C++
public:
property Path3d^ Path3d {
    Path3d^ get ();
}

Remarks

If the sweep is based on a sketched path, this property is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Sweep Class


ProfileSketch Property

[image]

Revit 2024 API
Sweep..::..ProfileSketch Property
Sweep Class See Also Send Feedback
The profile sketch of the sweep.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Sketch ProfileSketch { get; }
Visual Basic
Public ReadOnly Property ProfileSketch As Sketch
    Get
Visual C++
public:
property Sketch^ ProfileSketch {
    Sketch^ get ();
}

Remarks

If the profile is not based on sketched curves, this property is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Sweep Class


ProfileSymbol Property

[image]

Revit 2024 API
Sweep..::..ProfileSymbol Property
Sweep Class See Also Send Feedback
The family symbol profile details for the sweep.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilySymbolProfile ProfileSymbol { get; }
Visual Basic
Public ReadOnly Property ProfileSymbol As FamilySymbolProfile
    Get
Visual C++
public:
property FamilySymbolProfile^ ProfileSymbol {
    FamilySymbolProfile^ get ();
}

Remarks

If the profile is not based on a profile family, this property is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Sweep Class


SweepProfile Class

[image]

Revit 2024 API
SweepProfile Class
Members See Also Send Feedback
Represents a profile for sweep or swept blend elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class SweepProfile : APIObject
Visual Basic
Public Class SweepProfile _
    Inherits APIObject
Visual C++
public ref class SweepProfile : public APIObject

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..SweepProfile
Autodesk.Revit.DB..::..CurveLoopsProfile
Autodesk.Revit.DB..::..FamilySymbolProfile

See Also

SweepProfile Members


SweepProfile Members

[image] [image]

Revit 2024 API
SweepProfile Members
SweepProfile Class Methods Properties See Also Send Feedback

The SweepProfile type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SweepProfile Class


SweepProfile Methods

[image] [image]

Revit 2024 API
SweepProfile Methods
SweepProfile Class See Also Send Feedback

The SweepProfile type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SweepProfile Class


SweepProfile Properties

[image] [image]

Revit 2024 API
SweepProfile Properties
SweepProfile Class See Also Send Feedback

The SweepProfile type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SweepProfile Class


SweptBlend Class

[image]

Revit 2024 API
SweptBlend Class
Members See Also Send Feedback
A swept blend solid or void form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class SweptBlend : GenericForm
Visual Basic
Public Class SweptBlend _
    Inherits GenericForm
Visual C++
public ref class SweptBlend : public GenericForm

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..CombinableElement
Autodesk.Revit.DB..::..GenericForm
Autodesk.Revit.DB..::..SweptBlend

See Also

SweptBlend Members


SweptBlend Members

[image] [image]

Revit 2024 API
SweptBlend Members
SweptBlend Class Methods Properties See Also Send Feedback

The SweptBlend type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVertexConnectionMap | Gets the mapping between the vertices in the top and bottom profiles.
Public method | GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetVertexConnectionMap | Sets the mapping between the vertices in the top and bottom profiles.
Public method | SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BottomProfile | The curves which make up the bottom profile of the sketch.
Public property | BottomProfileSymbol | The bottom family symbol profile of the swept blend.
Public property | BottomSketch | The bottom profile sketch of the swept blend.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Get and Set the Name property (Inherited from GenericForm.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PathSketch | The sketched path for the swept blend.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SelectedPath | The selected curve used for the swept blend path.
Public property | Subcategory | The subcategory. (Inherited from GenericForm.)
Public property | TopProfile | The curves which make up the top profile of the sketch.
Public property | TopProfileSymbol | The top family symbol profile of the swept blend.
Public property | TopSketch | The top profile sketch of the swept blend.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Visible | The visibility of the GenericForm. (Inherited from GenericForm.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SweptBlend Class


SweptBlend Methods

[image] [image]

Revit 2024 API
SweptBlend Methods
SweptBlend Class See Also Send Feedback

The SweptBlend type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVertexConnectionMap | Gets the mapping between the vertices in the top and bottom profiles.
Public method | GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetVertexConnectionMap | Sets the mapping between the vertices in the top and bottom profiles.
Public method | SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SweptBlend Class


SetVertexConnectionMap Method

[image]

Revit 2024 API
SweptBlend..::..SetVertexConnectionMap Method
SweptBlend Class See Also Send Feedback
Sets the mapping between the vertices in the top and bottom profiles.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetVertexConnectionMap(
    VertexIndexPairArray vertexMap
)
Visual Basic
Public Sub SetVertexConnectionMap ( _
    vertexMap As VertexIndexPairArray _
)
Visual C++
public:
void SetVertexConnectionMap(
    VertexIndexPairArray^ vertexMap
)

Parameters

vertexMap
Type: Autodesk.Revit.DB..::..VertexIndexPairArray

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"vertexMap"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the input argument-"vertexMap"-is empty.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the document failed to regenerate.

See Also

SweptBlend Class


SweptBlend Properties

[image] [image]

Revit 2024 API
SweptBlend Properties
SweptBlend Class See Also Send Feedback

The SweptBlend type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BottomProfile | The curves which make up the bottom profile of the sketch.
Public property | BottomProfileSymbol | The bottom family symbol profile of the swept blend.
Public property | BottomSketch | The bottom profile sketch of the swept blend.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Get and Set the Name property (Inherited from GenericForm.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PathSketch | The sketched path for the swept blend.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SelectedPath | The selected curve used for the swept blend path.
Public property | Subcategory | The subcategory. (Inherited from GenericForm.)
Public property | TopProfile | The curves which make up the top profile of the sketch.
Public property | TopProfileSymbol | The top family symbol profile of the swept blend.
Public property | TopSketch | The top profile sketch of the swept blend.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Visible | The visibility of the GenericForm. (Inherited from GenericForm.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SweptBlend Class


BottomProfile Property

[image]

Revit 2024 API
SweptBlend..::..BottomProfile Property
SweptBlend Class See Also Send Feedback
The curves which make up the bottom profile of the sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CurveArrArray BottomProfile { get; }
Visual Basic
Public ReadOnly Property BottomProfile As CurveArrArray
    Get
Visual C++
public:
property CurveArrArray^ BottomProfile {
    CurveArrArray^ get ();
}

Remarks

The indices of the curves in this array match the indices used in the vertex connection map.

See Also

SweptBlend Class


BottomProfileSymbol Property

[image]

Revit 2024 API
SweptBlend..::..BottomProfileSymbol Property
SweptBlend Class See Also Send Feedback
The bottom family symbol profile of the swept blend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilySymbolProfile BottomProfileSymbol { get; }
Visual Basic
Public ReadOnly Property BottomProfileSymbol As FamilySymbolProfile
    Get
Visual C++
public:
property FamilySymbolProfile^ BottomProfileSymbol {
    FamilySymbolProfile^ get ();
}

Remarks

If the bottom profile is sketch-based, this property is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

SweptBlend Class


BottomSketch Property

[image]

Revit 2024 API
SweptBlend..::..BottomSketch Property
SweptBlend Class See Also Send Feedback
The bottom profile sketch of the swept blend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Sketch BottomSketch { get; }
Visual Basic
Public ReadOnly Property BottomSketch As Sketch
    Get
Visual C++
public:
property Sketch^ BottomSketch {
    Sketch^ get ();
}

Remarks

If the bottom profile is based on a family symbol, this property is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

SweptBlend Class


Parameter Property

[image] [image]

Revit 2024 API
SweptBlend..::..Parameter Property
SweptBlend Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

SweptBlend Class
SweptBlend Members


PathSketch Property

[image]

Revit 2024 API
SweptBlend..::..PathSketch Property
SweptBlend Class See Also Send Feedback
The sketched path for the swept blend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Sketch PathSketch { get; }
Visual Basic
Public ReadOnly Property PathSketch As Sketch
    Get
Visual C++
public:
property Sketch^ PathSketch {
    Sketch^ get ();
}

Remarks

If the swept blend is based on selected 3d curve, this property is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

SweptBlend Class


SelectedPath Property

[image]

Revit 2024 API
SweptBlend..::..SelectedPath Property
SweptBlend Class See Also Send Feedback
The selected curve used for the swept blend path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Curve SelectedPath { get; }
Visual Basic
Public ReadOnly Property SelectedPath As Curve
    Get
Visual C++
public:
property Curve^ SelectedPath {
    Curve^ get ();
}

Remarks

If the swept blend is based on a sketched path, this property is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

SweptBlend Class


TopProfileSymbol Property

[image]

Revit 2024 API
SweptBlend..::..TopProfileSymbol Property
SweptBlend Class See Also Send Feedback
The top family symbol profile of the swept blend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilySymbolProfile TopProfileSymbol { get; }
Visual Basic
Public ReadOnly Property TopProfileSymbol As FamilySymbolProfile
    Get
Visual C++
public:
property FamilySymbolProfile^ TopProfileSymbol {
    FamilySymbolProfile^ get ();
}

Remarks

If the top profile is sketch-based, this property is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

SweptBlend Class


TopSketch Property

[image]

Revit 2024 API
SweptBlend..::..TopSketch Property
SweptBlend Class See Also Send Feedback
The top profile sketch of the swept blend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Sketch TopSketch { get; }
Visual Basic
Public ReadOnly Property TopSketch As Sketch
    Get
Visual C++
public:
property Sketch^ TopSketch {
    Sketch^ get ();
}

Remarks

If the top profile is based on a family symbol, this property is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

SweptBlend Class


SweptProfile Class

[image]

Revit 2024 API
SweptProfile Class
Members See Also Send Feedback
Represents an extruded profile swept along a driving curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public class SweptProfile : IDisposable
Visual Basic
Public Class SweptProfile _
    Implements IDisposable
Visual C++
public ref class SweptProfile : IDisposable

Remarks

Elements such as beams may be formed from a profile that has been swept along a curve. This class represents such a form and is used to access the cross section and the underlying curve that make up the Element.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..SweptProfile

See Also

SweptProfile Members


SweptProfile Members

[image] [image]

Revit 2024 API
SweptProfile Members
SweptProfile Class Methods Properties See Also Send Feedback

The SweptProfile type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the SweptProfile
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDrivingCurve | Provides access to the curve that dictates the path of the swept profile.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSweptProfile | Returns an object that describes the profile that is swept along the driving curve.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | EndSetBack | The distance from the end of the driving curve to the point where the sweep actually ends.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | StartSetBack | The distance from the start of the driving curve to the point where the sweep actually begins.

See Also

SweptProfile Class


SweptProfile Methods

[image] [image]

Revit 2024 API
SweptProfile Methods
SweptProfile Class See Also Send Feedback

The SweptProfile type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDrivingCurve | Provides access to the curve that dictates the path of the swept profile.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSweptProfile | Returns an object that describes the profile that is swept along the driving curve.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SweptProfile Class


Dispose Method

[image]

Revit 2024 API
SweptProfile..::..Dispose Method
SweptProfile Class See Also Send Feedback
Releases all resources used by the SweptProfile

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

SweptProfile Class


GetSweptProfile Method

[image]

Revit 2024 API
SweptProfile..::..GetSweptProfile Method
SweptProfile Class See Also Send Feedback
Returns an object that describes the profile that is swept along the driving curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public Profile GetSweptProfile()
Visual Basic
Public Function GetSweptProfile As Profile
Visual C++
public:
Profile^ GetSweptProfile()

Return Value

A geometric profile object.

Remarks

The profile is swept perpendicular to the driving curve.

See Also

SweptProfile Class


SweptProfile Properties

[image] [image]

Revit 2024 API
SweptProfile Properties
SweptProfile Class See Also Send Feedback

The SweptProfile type exposes the following members.

Properties

 | Name | Description
Public property | EndSetBack | The distance from the end of the driving curve to the point where the sweep actually ends.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | StartSetBack | The distance from the start of the driving curve to the point where the sweep actually begins.

See Also

SweptProfile Class


EndSetBack Property

[image]

Revit 2024 API
SweptProfile..::..EndSetBack Property
SweptProfile Class See Also Send Feedback
The distance from the end of the driving curve to the point where the sweep actually ends.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public double EndSetBack { get; }
Visual Basic
Public ReadOnly Property EndSetBack As Double
    Get
Visual C++
public:
property double EndSetBack {
    double get ();
}

See Also

SweptProfile Class


IsValidObject Property

[image]

Revit 2024 API
SweptProfile..::..IsValidObject Property
SweptProfile Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

SweptProfile Class


StartSetBack Property

[image]

Revit 2024 API
SweptProfile..::..StartSetBack Property
SweptProfile Class See Also Send Feedback
The distance from the start of the driving curve to the point where the sweep actually begins.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public double StartSetBack { get; }
Visual Basic
Public ReadOnly Property StartSetBack As Double
    Get
Visual C++
public:
property double StartSetBack {
    double get ();
}

See Also

SweptProfile Class


SymbolGeometryId Class

[image]

Revit 2024 API
SymbolGeometryId Class
Members See Also Send Feedback
This class is used to identify a piece of geometry managed by a symbol element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public class SymbolGeometryId : IDisposable
Visual Basic
Public Class SymbolGeometryId _
    Implements IDisposable
Visual C++
public ref class SymbolGeometryId : IDisposable

Remarks

This class can be used to compare if two instances points to the same piece of geometry managed by a symbol element. The string returned by AsIdentifier can be used to achieve this.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..SymbolGeometryId

See Also

SymbolGeometryId Members


SymbolGeometryId Members

[image] [image]

Revit 2024 API
SymbolGeometryId Members
SymbolGeometryId Class Methods Properties See Also Send Feedback

The SymbolGeometryId type exposes the following members.

Methods

 | Name | Description
Public method | AsUniqueIdentifier | Returns a string suitable to determine if two instances point to the same piece of geometry managed by the same symbol element.
Public method | Dispose | Releases all resources used by the SymbolGeometryId
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SymbolId | The id of the symbol that is containing the shared geometry.

See Also

SymbolGeometryId Class


SymbolGeometryId Methods

[image] [image]

Revit 2024 API
SymbolGeometryId Methods
SymbolGeometryId Class See Also Send Feedback

The SymbolGeometryId type exposes the following members.

Methods

 | Name | Description
Public method | AsUniqueIdentifier | Returns a string suitable to determine if two instances point to the same piece of geometry managed by the same symbol element.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SymbolGeometryId Class


AsUniqueIdentifier Method

[image]

Revit 2024 API
SymbolGeometryId..::..AsUniqueIdentifier Method
SymbolGeometryId Class See Also Send Feedback
Returns a string suitable to determine if two instances point to the same piece of geometry managed by the same symbol element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public string AsUniqueIdentifier()
Visual Basic
Public Function AsUniqueIdentifier As String
Visual C++
public:
String^ AsUniqueIdentifier()

Return Value

A string suitable to determine if two instances point to the same piece of geometry managed by the same symbol element.

See Also

SymbolGeometryId Class


Dispose Method

[image]

Revit 2024 API
SymbolGeometryId..::..Dispose Method
SymbolGeometryId Class See Also Send Feedback
Releases all resources used by the SymbolGeometryId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

SymbolGeometryId Class


SymbolGeometryId Properties

[image] [image]

Revit 2024 API
SymbolGeometryId Properties
SymbolGeometryId Class See Also Send Feedback

The SymbolGeometryId type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SymbolId | The id of the symbol that is containing the shared geometry.

See Also

SymbolGeometryId Class


IsValidObject Property

[image]

Revit 2024 API
SymbolGeometryId..::..IsValidObject Property
SymbolGeometryId Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

SymbolGeometryId Class


SymbolId Property

[image]

Revit 2024 API
SymbolGeometryId..::..SymbolId Property
SymbolGeometryId Class See Also Send Feedback
The id of the symbol that is containing the shared geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public ElementId SymbolId { get; }
Visual Basic
Public ReadOnly Property SymbolId As ElementId
    Get
Visual C++
public:
property ElementId^ SymbolId {
    ElementId^ get ();
}

See Also

SymbolGeometryId Class


SymbolicCurve Class

[image]

Revit 2024 API
SymbolicCurve Class
Members See Also Send Feedback
A curve that provides information but is not intended to represent actual geometry in an element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class SymbolicCurve : CurveElement
Visual Basic
Public Class SymbolicCurve _
    Inherits CurveElement
Visual C++
public ref class SymbolicCurve : public CurveElement

Remarks

For example, when creating a door family, you might sketch symbolic lines in an elevation view to represent a door swing. Symbolic curves are visible parallel to the view in which you sketch them.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..CurveElement
Autodesk.Revit.DB..::..SymbolicCurve

See Also

SymbolicCurve Members


SymbolicCurve Members

[image] [image]

Revit 2024 API
SymbolicCurve Members
SymbolicCurve Class Methods Properties See Also Send Feedback

The SymbolicCurve type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point. (Inherited from CurveElement.)
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable. (Inherited from CurveElement.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element. (Inherited from CurveElement.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point. (Inherited from CurveElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the symbolic curve.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point. (Inherited from CurveElement.)
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point. (Inherited from CurveElement.)
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end. (Inherited from CurveElement.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry. (Inherited from CurveElement.)
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement. (Inherited from CurveElement.)
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point. (Inherited from CurveElement.)
Public method | SetVisibility | Sets the visibility for the symbolic curve.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveElementType | Type of the curve element. (Inherited from CurveElement.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsDrawnInForeground | Indicates if this curve will be drawn in the foreground of the family instance.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ReferenceType | Indicates the type of reference.
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Public property | Subcategory | The subcategory.
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element. (Inherited from CurveElement.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SymbolicCurve Class


SymbolicCurve Methods

[image] [image]

Revit 2024 API
SymbolicCurve Methods
SymbolicCurve Class See Also Send Feedback

The SymbolicCurve type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point. (Inherited from CurveElement.)
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable. (Inherited from CurveElement.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element. (Inherited from CurveElement.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point. (Inherited from CurveElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the symbolic curve.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point. (Inherited from CurveElement.)
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point. (Inherited from CurveElement.)
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end. (Inherited from CurveElement.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry. (Inherited from CurveElement.)
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement. (Inherited from CurveElement.)
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point. (Inherited from CurveElement.)
Public method | SetVisibility | Sets the visibility for the symbolic curve.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SymbolicCurve Class


GetVisibility Method

[image]

Revit 2024 API
SymbolicCurve..::..GetVisibility Method
SymbolicCurve Class See Also Send Feedback
Gets the visibility for the symbolic curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyElementVisibility GetVisibility()
Visual Basic
Public Function GetVisibility As FamilyElementVisibility
Visual C++
public:
FamilyElementVisibility^ GetVisibility()

Return Value

A copy of visibility settings for the symbolic curve.

See Also

SymbolicCurve Class


SymbolicCurve Properties

[image] [image]

Revit 2024 API
SymbolicCurve Properties
SymbolicCurve Class See Also Send Feedback

The SymbolicCurve type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveElementType | Type of the curve element. (Inherited from CurveElement.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsDrawnInForeground | Indicates if this curve will be drawn in the foreground of the family instance.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ReferenceType | Indicates the type of reference.
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Public property | Subcategory | The subcategory.
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element. (Inherited from CurveElement.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SymbolicCurve Class


IsDrawnInForeground Property

[image]

Revit 2024 API
SymbolicCurve..::..IsDrawnInForeground Property
SymbolicCurve Class See Also Send Feedback
Indicates if this curve will be drawn in the foreground of the family instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsDrawnInForeground { get; set; }
Visual Basic
Public Property IsDrawnInForeground As Boolean
    Get
    Set
Visual C++
public:
property bool IsDrawnInForeground {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when regeneration failed. Thrown when the value for this property cannot be changed.

See Also

SymbolicCurve Class


Parameter Property

[image] [image]

Revit 2024 API
SymbolicCurve..::..Parameter Property
SymbolicCurve Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

SymbolicCurve Class
SymbolicCurve Members


ReferenceType Property

[image]

Revit 2024 API
SymbolicCurve..::..ReferenceType Property
SymbolicCurve Class See Also Send Feedback
Indicates the type of reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ReferenceType ReferenceType { get; set; }
Visual Basic
Public Property ReferenceType As ReferenceType
    Get
    Set
Visual C++
public:
property ReferenceType ReferenceType {
    ReferenceType get ();
    void set (ReferenceType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when argument is out of range.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when regeneration failed.

See Also

SymbolicCurve Class


SymbolicCurveArray Class

[image]

Revit 2024 API
SymbolicCurveArray Class
Members See Also Send Feedback
An array that contains model curves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class SymbolicCurveArray : APIObject,
    IEnumerable
Visual Basic
Public Class SymbolicCurveArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class SymbolicCurveArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..SymbolicCurveArray

See Also

SymbolicCurveArray Members


SymbolicCurveArray Members

[image] [image]

Revit 2024 API
SymbolicCurveArray Members
SymbolicCurveArray Class Constructors Methods Properties See Also Send Feedback

The SymbolicCurveArray type exposes the following members.

Constructors

 | Name | Description
Public method | SymbolicCurveArray | Initializes a new instance of the SymbolicCurveArray class

Methods

 | Name | Description
Public method | Append | Add the model curve to the end of the array.
Public method | Clear | Removes every model curve from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified model curve into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a model curve at a specified index within the array.
Public property | Size | Returns the number of model curves that are in the array.

See Also

SymbolicCurveArray Class


SymbolicCurveArray Constructor

[image]

Revit 2024 API
SymbolicCurveArray Constructor
SymbolicCurveArray Class See Also Send Feedback
Initializes a new instance of the SymbolicCurveArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public SymbolicCurveArray()
Visual Basic
Public Sub New
Visual C++
public:
SymbolicCurveArray()

See Also

SymbolicCurveArray Class


Append Method

[image]

Revit 2024 API
SymbolicCurveArray..::..Append Method
SymbolicCurveArray Class See Also Send Feedback
Add the model curve to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Append(
    SymbolicCurve item
)
Visual Basic
Public Overridable Sub Append ( _
    item As SymbolicCurve _
)
Visual C++
public:
virtual void Append(
    SymbolicCurve^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..SymbolicCurve
The model curve to be added.

See Also

SymbolicCurveArray Class


Clear Method

[image]

Revit 2024 API
SymbolicCurveArray..::..Clear Method
SymbolicCurveArray Class See Also Send Feedback
Removes every model curve from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

SymbolicCurveArray Class


ForwardIterator Method

[image]

Revit 2024 API
SymbolicCurveArray..::..ForwardIterator Method
SymbolicCurveArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual SymbolicCurveArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As SymbolicCurveArrayIterator
Visual C++
public:
virtual SymbolicCurveArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

SymbolicCurveArray Class


GetEnumerator Method

[image]

Revit 2024 API
SymbolicCurveArray..::..GetEnumerator Method
SymbolicCurveArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

SymbolicCurveArray Class


Insert Method

[image]

Revit 2024 API
SymbolicCurveArray..::..Insert Method
SymbolicCurveArray Class See Also Send Feedback
Insert the specified model curve into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Insert(
    SymbolicCurve item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As SymbolicCurve, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    SymbolicCurve^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::..SymbolicCurve
The model curve to be inserted into the array.
index
Type: System..::..Int32
The model curve will be inserted before this index.

Return Value

Returns whether the model curve was inserted into the array.

See Also

SymbolicCurveArray Class


ReverseIterator Method

[image]

Revit 2024 API
SymbolicCurveArray..::..ReverseIterator Method
SymbolicCurveArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual SymbolicCurveArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As SymbolicCurveArrayIterator
Visual C++
public:
virtual SymbolicCurveArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

SymbolicCurveArray Class


SymbolicCurveArray Properties

[image] [image]

Revit 2024 API
SymbolicCurveArray Properties
SymbolicCurveArray Class See Also Send Feedback

The SymbolicCurveArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a model curve at a specified index within the array.
Public property | Size | Returns the number of model curves that are in the array.

See Also

SymbolicCurveArray Class


Size Property

[image]

Revit 2024 API
SymbolicCurveArray..::..Size Property
SymbolicCurveArray Class See Also Send Feedback
Returns the number of model curves that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

SymbolicCurveArray Class


SymbolicCurveArrayIterator Class

[image]

Revit 2024 API
SymbolicCurveArrayIterator Class
Members See Also Send Feedback
An iterator to a model curve array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public abstract class SymbolicCurveArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class SymbolicCurveArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class SymbolicCurveArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..SymbolicCurveArrayIterator

See Also

SymbolicCurveArrayIterator Members


SymbolicCurveArrayIterator Members

[image] [image]

Revit 2024 API
SymbolicCurveArrayIterator Members
SymbolicCurveArrayIterator Class Constructors Methods Properties See Also Send Feedback

The SymbolicCurveArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | SymbolicCurveArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SymbolicCurveArrayIterator Class


SymbolicCurveArrayIterator Constructor

[image]

Revit 2024 API
SymbolicCurveArrayIterator Constructor
SymbolicCurveArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public SymbolicCurveArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
SymbolicCurveArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SymbolicCurveArrayIterator Class


SymbolicCurveArrayIterator Methods

[image] [image]

Revit 2024 API
SymbolicCurveArrayIterator Methods
SymbolicCurveArrayIterator Class See Also Send Feedback

The SymbolicCurveArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SymbolicCurveArrayIterator Class


MoveNext Method

[image]

Revit 2024 API
SymbolicCurveArrayIterator..::..MoveNext Method
SymbolicCurveArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

SymbolicCurveArrayIterator Class


SymbolicCurveArrayIterator Properties

[image] [image]

Revit 2024 API
SymbolicCurveArrayIterator Properties
SymbolicCurveArrayIterator Class See Also Send Feedback

The SymbolicCurveArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SymbolicCurveArrayIterator Class


SymbolTypeId Class

[image]

Revit 2024 API
SymbolTypeId Class
Members See Also Send Feedback
This class contains constants identifying symbols.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static class SymbolTypeId
Visual Basic
Public NotInheritable Class SymbolTypeId
Visual C++
public ref class SymbolTypeId abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..SymbolTypeId

See Also

SymbolTypeId Members


SymbolTypeId Members

[image] [image]

Revit 2024 API
SymbolTypeId Members
SymbolTypeId Class Properties See Also Send Feedback

The SymbolTypeId type exposes the following members.

Properties

Name | Description
Acres | Symbol acres, indicating unit Acres.
Ampere | Symbol A, indicating unit Amperes.
Atm | Symbol atm, indicating unit Atmospheres.
Baht | Symbol à¸¿, indicating unit Currency.
Bar | Symbol bar, indicating unit Bars.
Btu | Symbol Btu, indicating unit British thermal units.
BtuPerDegreeF | Symbol BTU/Â°F, indicating unit British thermal units per degree Fahrenheit.
BtuPerFtSup2DegreeF | Symbol BTU/(ftÂ²Â·Â°F), indicating unit British thermal units per square foot degree Fahrenheit.
BtuPerH | Symbol Btu/h, indicating unit British thermal units per hour.
BtuPerHFtDegreeF | Symbol BTU/(hÂ·ftÂ·Â°F), indicating unit British thermal units per hour foot degree Fahrenheit.
BtuPerHFtSup2 | Symbol Btu/(hÂ·ftÂ²), indicating unit British thermal units per hour square foot.
BtuPerHFtSup2DegreeF | Symbol BTU/(hÂ·ftÂ²Â·Â°F), indicating unit British thermal units per hour square foot degree Fahrenheit.
BtuPerHFtSup3 | Symbol Btu/(hÂ·ftÂ³), indicating unit British thermal units per hour cubic foot.
BtuPerLb | Symbol BTU/lb, indicating unit British thermal units per pound.
BtuPerLbDegreeF | Symbol BTU/(lbÂ·Â°F), indicating unit British thermal units per pound degree Fahrenheit.
BtuPerS | Symbol Btu/s, indicating unit British thermal units per second.
Cal | Symbol cal, indicating unit Calories.
CalPerS | Symbol cal/s, indicating unit Calories per second.
Cd | Symbol cd, indicating unit Candelas.
CdPerFtSup2 | Symbol cd/ftÂ², indicating unit Candelas per square foot.
CdPerMSup2 | Symbol cd/mÂ², indicating unit Candelas per square meter.
Cf | Symbol CF, indicating unit Cubic feet.
Cfh | Symbol CFH, indicating unit Cubic feet per hour.
Cfm | Symbol CFM, indicating unit Cubic feet per minute.
CfmPerCf | Symbol CFM/CF, indicating unit Cubic feet per minute cubic foot.
CfmPerFtSup2 | Symbol CFM/ftÂ², indicating unit Cubic feet per minute square foot.
CfmPerFtSup3 | Symbol CFM/ftÂ³, indicating unit Cubic feet per minute cubic foot.
CfmPerSf | Symbol CFM/SF, indicating unit Cubic feet per minute square foot.
CfmPerTon | Symbol CFM/ton, indicating unit Cubic feet per minute ton of refrigeration.
ChineseHongKongDollar | Symbol HK$, indicating unit Currency.
Cm | Symbol cm, indicating unit Centimeters.
CmCaret2 | Symbol cm^2, indicating unit Square centimeters.
CmCaret3 | Symbol cm^3, indicating unit Cubic centimeters.
Cmh | Symbol CMH, indicating unit Cubic meters per hour.
CmPerMin | Symbol cm/min, indicating unit Centimeters per minute.
Cms | Symbol CMS, indicating unit Cubic meters per second.
CmSup2 | Symbol cmÂ², indicating unit Square centimeters.
CmSup2PerM | Symbol cmÂ²/m, indicating unit Square centimeters per meter.
CmSup3 | Symbol cmÂ³, indicating unit Cubic centimeters.
CmSup4 | Symbol cmâ´, indicating unit Centimeters to the fourth power.
CmSup6 | Symbol cmâ¶, indicating unit Centimeters to the sixth power.
Colon1 | Symbol :1, indicating unit Ratio : 1.
Colon10 | Symbol :10, indicating unit Ratio : 10.
Colon12 | Symbol :12, indicating unit Ratio : 12.
CP | Symbol cP, indicating unit Centipoises.
Cps | Symbol cps, indicating unit Cycles per second.
Custom | Unrecognized custom symbol.
Cy | Symbol CY, indicating unit Cubic yards.
DaN | Symbol daN, indicating unit Dekanewtons.
DaNDashM | Symbol daN-m, indicating unit Dekanewton meters.
DaNDashMPerM | Symbol daN-m/m, indicating unit Dekanewton meters per meter.
DaNPerM | Symbol daN/m, indicating unit Dekanewtons per meter.
DaNPerMSup2 | Symbol daN/mÂ², indicating unit Dekanewtons per square meter.
Degree | Symbol Â°, indicating unit Degrees.
DegreeC | Symbol Â°C, indicating unit Celsius.
DegreeCInterval | Symbol Â°C, indicating unit Celsius interval.
DegreeF | Symbol Â°F, indicating unit Fahrenheit.
DegreeFInterval | Symbol Â°F, indicating unit Fahrenheit interval.
DegreeR | Symbol Â°R, indicating unit Rankine.
DegreeRInterval | Symbol Â°R, indicating unit Rankine interval.
DeltaDegreeC | Symbol deltaÂ°C, indicating unit Celsius interval.
DeltaDegreeF | Symbol deltaÂ°F, indicating unit Fahrenheit interval.
DeltaDegreeR | Symbol deltaÂ°R, indicating unit Rankine interval.
DeltaK | Symbol deltaK, indicating unit Kelvin interval.
Dm | Symbol dm, indicating unit Decimeters.
DollarHPerBtu | Symbol $Â·h/Btu, indicating unit Cost per British thermal unit per hour.
DollarPerBtu | Symbol $/Btu, indicating unit Cost per British thermal unit.
DollarPerFtSup2 | Symbol $/ftÂ², indicating unit Cost per square foot.
DollarPerMSup2 | Symbol $/mÂ², indicating unit Cost per square meter.
DollarPerW | Symbol $/W, indicating unit Cost per watt.
DollarPerWH | Symbol $/(WÂ·h), indicating unit Cost per watt hour.
Dong | Symbol â‚«, indicating unit Currency.
EuroPrefix | Symbol â‚¬, indicating unit Currency.
EuroSuffix | Symbol â‚¬, indicating unit Currency.
Fc | Symbol fc, indicating unit Footcandles.
FeetOfWater | Symbol Feet, indicating unit Feet of water (39.2 Â°F).
FeetOfWaterPer100ft | Symbol Feet/100ft, indicating unit Feet of water (39.2 Â°F) per 100 feet.
FL | Symbol fL, indicating unit Footlamberts.
FlLowercase | Symbol fl, indicating unit Footlamberts.
FootSingleQuote | Symbol ', indicating unit Feet.
Fpm | Symbol FPM, indicating unit Feet per minute.
Fps | Symbol FPS, indicating unit Feet per second.
Ft | Symbol ft, indicating unit Feet.
Ftc | Symbol Ftc, indicating unit Footcandles.
FtCaret2 | Symbol ft^2, indicating unit Square feet.
FtCaret3 | Symbol ft^3, indicating unit Cubic feet.
FtH2O | Symbol ftH2O, indicating unit Feet of water (39.2 Â°F).
FtH2OPer100ft | Symbol ftH2O/100ft, indicating unit Feet of water (39.2 Â°F) per 100 feet.
FtL | Symbol ftL, indicating unit Footlamberts.
FtOfWater | Symbol FT, indicating unit Feet of water (39.2 Â°F).
FtOfWaterPer100ft | Symbol FT/100ft, indicating unit Feet of water (39.2 Â°F) per 100 feet.
FtPerKip | Symbol ft/kip, indicating unit Feet per kip.
FtPerMin | Symbol ft/min, indicating unit Feet per minute.
FtPerS | Symbol ft/s, indicating unit Feet per second.
FtPerSSup2 | Symbol ft/sÂ², indicating unit Feet per second squared.
FtSup2 | Symbol ftÂ², indicating unit Square feet.
FtSup2HPerKbtu | Symbol ftÂ²Â·h/kBtu, indicating unit Square feet per thousand British thermal units per hour.
FtSup2PerFt | Symbol ftÂ²/ft, indicating unit Square feet per foot.
FtSup2PerKip | Symbol ftÂ²/kip, indicating unit Square feet per kip.
FtSup2PerMbh | Symbol ftÂ²/MBh, indicating unit Square feet per thousand British thermal units per hour.
FtSup2PerS | Symbol ftÂ²/s, indicating unit Square feet per second.
FtSup2PerTon | Symbol ftÂ²/ton, indicating unit Square feet per ton of refrigeration.
FtSup3 | Symbol ftÂ³, indicating unit Cubic feet.
FtSup3HPerMinBtu | Symbol ftÂ³Â·h/(minÂ·Btu), indicating unit Cubic feet per minute per British thermal unit per hour.
FtSup3PerH | Symbol ftÂ³/h, indicating unit Cubic feet per hour.
FtSup3PerKip | Symbol ftÂ³/kip, indicating unit Cubic feet per kip.
FtSup3PerLbMass | Symbol ftÂ³/lb, indicating unit Cubic feet per pound mass.
FtSup3PerMin | Symbol ftÂ³/min, indicating unit Cubic feet per minute.
FtSup4 | Symbol ftâ´, indicating unit Feet to the fourth power.
FtSup6 | Symbol ftâ¶, indicating unit Feet to the sixth power.
Gal | Symbol gal, indicating unit US gallons.
GalPerH | Symbol gal/h, indicating unit US gallons per hour.
GalPerMin | Symbol gal/min, indicating unit US gallons per minute.
Gph | Symbol GPH, indicating unit US gallons per hour.
Gpm | Symbol GPM, indicating unit US gallons per minute.
Grad | Symbol grad, indicating unit Gradians.
GrPerHFtSup2InHg | Symbol gr/(hÂ·ftÂ²Â·inHg), indicating unit Grains per hour square foot inch mercury.
Hectare | Symbol hectare, indicating unit Hectares.
HFtSup2DegreeFPerBtu | Symbol (hÂ·ftÂ²Â·Â°F)/BTU, indicating unit Hour square foot degrees Fahrenheit per British thermal unit.
Hour | Symbol h, indicating unit Hours.
Hp | Symbol hp, indicating unit Horsepower.
Hz | Symbol Hz, indicating unit Hertz.
In | Symbol in, indicating unit Inches.
InCaret2 | Symbol in^2, indicating unit Square inches.
InCaret3 | Symbol in^3, indicating unit Cubic inches.
InchDoubleQuote | Symbol ", indicating unit Inches.
InDashWg | Symbol in-wg, indicating unit Inches of water (60 Â°F).
InDashWgPer100ft | Symbol in-wg/100ft, indicating unit Inches of water (60 Â°F) per 100 feet.
InHg | Symbol inHg, indicating unit Inches of mercury (32 Â°F).
InPerSSup2 | Symbol in/sÂ², indicating unit Inches per second squared.
InSup2 | Symbol inÂ², indicating unit Square inches.
InSup2PerFt | Symbol inÂ²/ft, indicating unit Square inches per foot.
InSup3 | Symbol inÂ³, indicating unit Cubic inches.
InSup4 | Symbol inâ´, indicating unit Inches to the fourth power.
InSup6 | Symbol inâ¶, indicating unit Inches to the sixth power.
InvDegreeC | Symbol 1/Â°C, indicating unit Inverse degrees Celsius.
InvDegreeF | Symbol 1/Â°F, indicating unit Inverse degrees Fahrenheit.
InvKip | Symbol 1/kip, indicating unit Inverse kips.
InvKN | Symbol 1/kN, indicating unit Inverse kilonewtons.
Joule | Symbol J, indicating unit Joules.
JPerG | Symbol J/g, indicating unit Joules per gram.
JPerGDegreeC | Symbol J/(gÂ·Â°C), indicating unit Joules per gram degree Celsius.
JPerK | Symbol J/K, indicating unit Joules per Kelvin.
JPerKgDegreeC | Symbol J/(kgÂ·Â°C), indicating unit Joules per kilogram degree Celsius.
JPerMSup2K | Symbol J/(mÂ²Â·K), indicating unit Joules per square meter Kelvin.
KA | Symbol kA, indicating unit Kiloamperes.
Kcal | Symbol kcal, indicating unit Kilocalories.
KcalPerS | Symbol kcal/s, indicating unit Kilocalories per second.
Kelvin | Symbol K, indicating unit Kelvin.
KelvinInterval | Symbol K, indicating unit Kelvin interval.
Kg | Symbol kg, indicating unit Kilograms.
Kgf | Symbol kgf, indicating unit Kilograms force.
KgfDashM | Symbol kgf-m, indicating unit Kilogram force meters.
KgfDashMPerM | Symbol kgf-m/m, indicating unit Kilogram force meters per meter.
KgfPerM | Symbol kgf/m, indicating unit Kilograms force per meter.
KgfPerMSup2 | Symbol kgf/mÂ², indicating unit Kilograms force per square meter.
KgPerH | Symbol kg/h, indicating unit Kilograms per hour.
KgPerKgK | Symbol kg/(kgÂ·K), indicating unit Kilograms per kilogram kelvin.
KgPerM | Symbol kg/m, indicating unit Kilograms per meter.
KgPerMH | Symbol kg/(mÂ·h), indicating unit Kilograms per meter hour.
KgPerMin | Symbol kg/min, indicating unit Kilograms per minute.
KgPerMS | Symbol kg/(mÂ·s), indicating unit Kilograms per meter second.
KgPerMSup2 | Symbol kg/mÂ², indicating unit Kilograms per square meter.
KgPerMSup3 | Symbol kg/mÂ³, indicating unit Kilograms per cubic meter.
KgPerS | Symbol kg/s, indicating unit Kilograms per second.
Kip | Symbol kip, indicating unit Kips.
KipDashFt | Symbol kip-ft, indicating unit Kip feet.
KipDashFtPerDegree | Symbol kip-ft/Â°, indicating unit Kip feet per degree.
KipDashFtPerDegreePerFt | Symbol kip-ft/Â°/ft, indicating unit Kip feet per degree per foot.
KipDashFtPerFt | Symbol kip-ft/ft, indicating unit Kip feet per foot.
KipPerFt | Symbol kip/ft, indicating unit Kips per foot.
KipPerFtSup2 | Symbol kip/ftÂ², indicating unit Kips per square foot.
KipPerFtSup3 | Symbol kip/ftÂ³, indicating unit Kips per cubic foot.
KipPerIn | Symbol kip/in, indicating unit Kips per inch.
KipPerInSup2 | Symbol kip/inÂ², indicating unit Kips per square inch.
KipPerInSup3 | Symbol kip/inÂ³, indicating unit Kips per cubic inch.
KJ | Symbol kJ, indicating unit Kilojoules.
KJPerK | Symbol kJ/K, indicating unit Kilojoules per Kelvin.
KJPerMSup2K | Symbol kJ/(mÂ²Â·K), indicating unit Kilojoules per square meter Kelvin.
KmPerH | Symbol km/h, indicating unit Kilometers per hour.
KmPerSSup2 | Symbol km/sÂ², indicating unit Kilometers per second squared.
KN | Symbol kN, indicating unit Kilonewtons.
KNDashM | Symbol kN-m, indicating unit Kilonewton meters.
KNDashMPerDegree | Symbol kN-m/Â°, indicating unit Kilonewton meters per degree.
KNDashMPerDegreePerM | Symbol kN-m/Â°/m, indicating unit Kilonewton meters per degree per meter.
KNDashMPerM | Symbol kN-m/m, indicating unit Kilonewton meters per meter.
KNPerCmSup2 | Symbol kN/cmÂ², indicating unit Kilonewtons per square centimeter.
KNPerM | Symbol kN/m, indicating unit Kilonewtons per meter.
KNPerMmSup2 | Symbol kN/mmÂ², indicating unit Kilonewtons per square millimeter.
KNPerMSup2 | Symbol kN/mÂ², indicating unit Kilonewtons per square meter.
KNPerMSup3 | Symbol kN/mÂ³, indicating unit Kilonewtons per cubic meter.
KPa | Symbol kPa, indicating unit Kilopascals.
Krone | Symbol kr, indicating unit Currency.
Ksf | Symbol ksf, indicating unit Kips per square foot.
Ksi | Symbol ksi, indicating unit Kips per square inch.
KV | Symbol kV, indicating unit Kilovolts.
KVA | Symbol kVA, indicating unit Kilovolt amperes.
KW | Symbol kW, indicating unit Kilowatts.
KWh | Symbol kWh, indicating unit Kilowatt hours.
Lbf | Symbol lbf, indicating unit Pounds force.
LbfDashFt | Symbol lbf-ft, indicating unit Pound force feet.
LbfDashFtPerFt | Symbol lbf-ft/ft, indicating unit Pound force feet per foot.
LbForce | Symbol lb, indicating unit Pounds force.
LbForceDashFt | Symbol lb-ft, indicating unit Pound force feet.
LbForceDashFtPerFt | Symbol lb-ft/ft, indicating unit Pound force feet per foot.
LbForcePerFt | Symbol lb/ft, indicating unit Pounds force per foot.
LbForcePerFtSup2 | Symbol lb/ftÂ², indicating unit Pounds force per square foot.
LbForcePerFtSup3 | Symbol lb/ftÂ³, indicating unit Pounds force per cubic foot.
LbForcePerInSup2 | Symbol lb/inÂ², indicating unit Pounds force per square inch.
LbForceSPerFtSup2 | Symbol lbÂ·s/ftÂ², indicating unit Pound force seconds per square foot.
LbfPerFt | Symbol lbf/ft, indicating unit Pounds force per foot.
LbfPerFtSup2 | Symbol lbf/ftÂ², indicating unit Pounds force per square foot.
LbfPerFtSup3 | Symbol lbf/ftÂ³, indicating unit Pounds force per cubic foot.
LbfPerInSup2 | Symbol lbf/inÂ², indicating unit Pounds force per square inch.
Lbm | Symbol lbm, indicating unit Pounds mass.
LbMass | Symbol lb, indicating unit Pounds mass.
LbMassPerFt | Symbol lb/ft, indicating unit Pounds mass per foot.
LbMassPerFtDashH | Symbol lb/ft-h, indicating unit Pounds mass per foot hour.
LbMassPerFtDashS | Symbol lb/ft-s, indicating unit Pounds mass per foot second.
LbMassPerFtSup2 | Symbol lb/ftÂ², indicating unit Pounds mass per square foot.
LbMassPerFtSup3 | Symbol lb/ftÂ³, indicating unit Pounds mass per cubic foot.
LbMassPerH | Symbol lb/h, indicating unit Pounds mass per hour.
LbMassPerInSup3 | Symbol lb/inÂ³, indicating unit Pounds mass per cubic inch.
LbMassPerLbDegreeF | Symbol lb/(lbÂ·Â°F), indicating unit Pounds mass per pound degree Fahrenheit.
LbMassPerMin | Symbol lb/min, indicating unit Pounds mass per minute.
LbMassPerS | Symbol lb/s, indicating unit Pounds mass per second.
LbmPerFt | Symbol lbm/ft, indicating unit Pounds mass per foot.
LbmPerFtDashH | Symbol lbm/ft-h, indicating unit Pounds mass per foot hour.
LbmPerFtDashS | Symbol lbm/ft-s, indicating unit Pounds mass per foot second.
LbmPerFtSup3 | Symbol lbm/ftÂ³, indicating unit Pounds mass per cubic foot.
LbmPerInSup3 | Symbol lbm/inÂ³, indicating unit Pounds mass per cubic inch.
Lf | Symbol LF, indicating unit Feet.
Liter | Symbol L, indicating unit Liters.
Lm | Symbol lm, indicating unit Lumens.
LmPerW | Symbol lm/W, indicating unit Lumens per watt.
LPerH | Symbol L/h, indicating unit Liters per hour.
LPerMin | Symbol L/min, indicating unit Liters per minute.
LPerS | Symbol L/s, indicating unit Liters per second.
LPerSKw | Symbol L/(sÂ·kW), indicating unit Liters per second kilowatt.
LPerSMSup2 | Symbol L/(sÂ·mÂ²), indicating unit Liters per second square meter.
LPerSMSup3 | Symbol L/(sÂ·mÂ³), indicating unit Liters per second cubic meter.
Lpm | Symbol LPM, indicating unit Liters per minute.
Lps | Symbol LPS, indicating unit Liters per second.
LpsPerMSup2 | Symbol LPS/mÂ², indicating unit Liters per second square meter.
Lx | Symbol lx, indicating unit Lux.
MA | Symbol mA, indicating unit Milliamperes.
Mbh | Symbol MBH, indicating unit Thousand British thermal units per hour.
MCaret2 | Symbol m^2, indicating unit Square meters.
MCaret3 | Symbol m^3, indicating unit Cubic meters.
Meter | Symbol m, indicating unit Meters.
MH2O | Symbol mH2O, indicating unit Meters of water column.
MH2OPerM | Symbol mH2O/m, indicating unit Meters of water column per meter.
Min | Symbol min, indicating unit Minutes.
MiPerSSup2 | Symbol mi/sÂ², indicating unit Miles per second squared.
Mm | Symbol mm, indicating unit Millimeters.
MmCaret2 | Symbol mm^2, indicating unit Square millimeters.
MmCaret3 | Symbol mm^3, indicating unit Cubic millimeters.
MmH2O | Symbol mmH2O, indicating unit Millimeters of water column.
MmH2OPerM | Symbol mmH2O/m, indicating unit Millimeters of water column per meter.
MmHg | Symbol mmHg, indicating unit Millimeters of mercury.
MmSup2 | Symbol mmÂ², indicating unit Square millimeters.
MmSup2PerM | Symbol mmÂ²/m, indicating unit Square millimeters per meter.
MmSup3 | Symbol mmÂ³, indicating unit Cubic millimeters.
MmSup4 | Symbol mmâ´, indicating unit Millimeters to the fourth power.
MmSup6 | Symbol mmâ¶, indicating unit Millimeters to the sixth power.
MN | Symbol MN, indicating unit Meganewtons.
MNDashM | Symbol MN-m, indicating unit Meganewton meters.
MNDashMPerM | Symbol MN-m/m, indicating unit Meganewton meters per meter.
MNPerM | Symbol MN/m, indicating unit Meganewtons per meter.
MNPerMSup2 | Symbol MN/mÂ², indicating unit Meganewtons per square meter.
MPa | Symbol MPa, indicating unit Megapascals.
MPerKN | Symbol m/kN, indicating unit Meters per kilonewton.
MPerS | Symbol m/s, indicating unit Meters per second.
MPerSSup2 | Symbol m/sÂ², indicating unit Meters per second squared.
Mph | Symbol mph, indicating unit Miles per hour.
Ms | Symbol ms, indicating unit Milliseconds.
MSup2 | Symbol mÂ², indicating unit Square meters.
MSup2KPerW | Symbol (mÂ²Â·K)/W, indicating unit Square meter kelvins per watt.
MSup2PerKN | Symbol mÂ²/kN, indicating unit Square meters per kilonewton.
MSup2PerKw | Symbol mÂ²/kW, indicating unit Square meters per kilowatt.
MSup2PerM | Symbol mÂ²/m, indicating unit Square meters per meter.
MSup2PerS | Symbol mÂ²/s, indicating unit Square meters per second.
MSup3 | Symbol mÂ³, indicating unit Cubic meters.
MSup3PerH | Symbol mÂ³/h, indicating unit Cubic meters per hour.
MSup3PerHMSup2 | Symbol mÂ³/(hÂ·mÂ²), indicating unit Cubic meters per hour square meter.
MSup3PerHMSup3 | Symbol mÂ³/(hÂ·mÂ³), indicating unit Cubic meters per hour cubic meter.
MSup3PerKg | Symbol mÂ³/kg, indicating unit Cubic meters per kilogram.
MSup3PerKN | Symbol mÂ³/kN, indicating unit Cubic meters per kilonewton.
MSup3PerS | Symbol mÂ³/s, indicating unit Cubic meters per second.
MSup3PerWS | Symbol mÂ³/(WÂ·s), indicating unit Cubic meters per watt second.
MSup4 | Symbol mâ´, indicating unit Meters to the fourth power.
MSup6 | Symbol mâ¶, indicating unit Meters to the sixth power.
MV | Symbol mV, indicating unit Millivolts.
NDashM | Symbol N-m, indicating unit Newton meters.
NDashMPerM | Symbol N-m/m, indicating unit Newton meters per meter.
Newton | Symbol N, indicating unit Newtons.
NgPerPaSMSup2 | Symbol ng/(PaÂ·sÂ·mÂ²), indicating unit Nanograms per pascal second square meter.
NPerM | Symbol N/m, indicating unit Newtons per meter.
NPerMmSup2 | Symbol N/mmÂ², indicating unit Newtons per square millimeter.
NPerMSup2 | Symbol N/mÂ², indicating unit Newtons per square meter.
NSPerMSup2 | Symbol NÂ·s/mÂ², indicating unit Newton seconds per square meter.
OhmM | Symbol ohmÂ·m, indicating unit Ohm meters.
OneColon | Symbol 1:, indicating unit 1 : Ratio.
Pa | Symbol Pa, indicating unit Pascals.
PaDashS | Symbol Pa-s, indicating unit Pascal seconds.
PaPerM | Symbol Pa/m, indicating unit Pascals per meter.
Percent | Symbol %, indicating unit Percentage.
PerMille | Symbol â€°, indicating unit Per mille.
Pi | Symbol Ï€, indicating unit Multiples of Ï€.
Psf | Symbol psf, indicating unit Pounds force per square foot.
Psi | Symbol psi, indicating unit Pounds force per square inch.
Psia | Symbol psia, indicating unit Pounds force per square inch.
Psig | Symbol psig, indicating unit Pounds force per square inch.
Rad | Symbol rad, indicating unit Radians.
RadPerS | Symbol rad/s, indicating unit Radians per second.
Rpm | Symbol RPM, indicating unit Revolutions per minute.
Rps | Symbol RPS, indicating unit Revolutions per second.
Second | Symbol s, indicating unit Seconds.
Sf | Symbol SF, indicating unit Square feet.
SfHPerKbtu | Symbol SFÂ·h/kBtu, indicating unit Square feet per thousand British thermal units per hour.
SfPerMbh | Symbol SF/MBh, indicating unit Square feet per thousand British thermal units per hour.
SfPerTon | Symbol SF/ton, indicating unit Square feet per ton of refrigeration.
Shekel | Symbol â‚ª, indicating unit Currency.
SlopeDegree | Symbol Â°, indicating unit Slope degrees.
Stf | Symbol STf, indicating unit US tonnes force.
Tf | Symbol Tf, indicating unit Tonnes force.
TfDashM | Symbol Tf-m, indicating unit Tonne force meters.
TfDashMPerM | Symbol Tf-m/m, indicating unit Tonne force meters per meter.
TfPerM | Symbol Tf/m, indicating unit Tonnes force per meter.
TfPerMSup2 | Symbol Tf/mÂ², indicating unit Tonnes force per square meter.
Therm | Symbol therm, indicating unit Therms.
Ton | Symbol ton, indicating unit Tons of refrigeration.
Tonne | Symbol t, indicating unit Tonnes.
TonOfRefrigeration | Symbol ton of refrigeration, indicating unit Tons of refrigeration.
Tonsf | Symbol Tonsf, indicating unit US tonnes force.
UinPerInDegreeF | Symbol Âµin/(inÂ·Â°F), indicating unit Microinches per inch degree Fahrenheit.
UkPound | Symbol Â£, indicating unit Currency.
UmPerMDegreeC | Symbol Âµm/(mÂ·Â°C), indicating unit Micrometers per meter degree Celsius.
UsDollar | Symbol $, indicating unit Currency.
Usft | Symbol USft, indicating unit US survey feet.
Usgph | Symbol usgph, indicating unit US gallons per hour.
Usgpm | Symbol usgpm, indicating unit US gallons per minute.
UsTonnesForceSt | Symbol ST, indicating unit US tonnes force.
UsTonnesForceT | Symbol T, indicating unit US tonnes force.
UsTonnesForceTons | Symbol Tons, indicating unit US tonnes force.
UsTonnesMassSt | Symbol ST, indicating unit US tonnes mass.
UsTonnesMassT | Symbol T, indicating unit US tonnes mass.
UsTonnesMassTons | Symbol Tons, indicating unit US tonnes mass.
VA | Symbol VA, indicating unit Volt amperes.
VAPerFtSup2 | Symbol VA/ftÂ², indicating unit Volt amperes per square foot.
VAPerMSup2 | Symbol VA/mÂ², indicating unit Volt amperes per square meter.
Volt | Symbol V, indicating unit Volts.
Watt | Symbol W, indicating unit Watts.
WMinPerFtSup3 | Symbol WÂ·min/ftÂ³, indicating unit Watts per cubic foot per minute.
Won | Symbol â‚©, indicating unit Currency.
WPerFt | Symbol W/ft, indicating unit Watts per foot.
WPerFtSup2 | Symbol W/ftÂ², indicating unit Watts per square foot.
WPerFtSup3 | Symbol W/ftÂ³, indicating unit Watts per cubic foot.
WPerM | Symbol W/m, indicating unit Watts per meter.
WPerMK | Symbol W/(mÂ·K), indicating unit Watts per meter kelvin.
WPerMSup2 | Symbol W/mÂ², indicating unit Watts per square meter.
WPerMSup2K | Symbol W/(mÂ²Â·K), indicating unit Watts per square meter kelvin.
WPerMSup3 | Symbol W/mÂ³, indicating unit Watts per cubic meter.
WSPerMSup3 | Symbol WÂ·s/mÂ³, indicating unit Watts per cubic meter per second.
YdCaret3 | Symbol yd^3, indicating unit Cubic yards.
YdSup3 | Symbol ydÂ³, indicating unit Cubic yards.
Yen | Symbol Â¥, indicating unit Currency.

See Also

SymbolTypeId Class


SymbolTypeId Properties

[image] [image]

Revit 2024 API
SymbolTypeId Properties
SymbolTypeId Class See Also Send Feedback

The SymbolTypeId type exposes the following members.

Properties

Name | Description
Acres | Symbol acres, indicating unit Acres.
Ampere | Symbol A, indicating unit Amperes.
Atm | Symbol atm, indicating unit Atmospheres.
Baht | Symbol à¸¿, indicating unit Currency.
Bar | Symbol bar, indicating unit Bars.
Btu | Symbol Btu, indicating unit British thermal units.
BtuPerDegreeF | Symbol BTU/Â°F, indicating unit British thermal units per degree Fahrenheit.
BtuPerFtSup2DegreeF | Symbol BTU/(ftÂ²Â·Â°F), indicating unit British thermal units per square foot degree Fahrenheit.
BtuPerH | Symbol Btu/h, indicating unit British thermal units per hour.
BtuPerHFtDegreeF | Symbol BTU/(hÂ·ftÂ·Â°F), indicating unit British thermal units per hour foot degree Fahrenheit.
BtuPerHFtSup2 | Symbol Btu/(hÂ·ftÂ²), indicating unit British thermal units per hour square foot.
BtuPerHFtSup2DegreeF | Symbol BTU/(hÂ·ftÂ²Â·Â°F), indicating unit British thermal units per hour square foot degree Fahrenheit.
BtuPerHFtSup3 | Symbol Btu/(hÂ·ftÂ³), indicating unit British thermal units per hour cubic foot.
BtuPerLb | Symbol BTU/lb, indicating unit British thermal units per pound.
BtuPerLbDegreeF | Symbol BTU/(lbÂ·Â°F), indicating unit British thermal units per pound degree Fahrenheit.
BtuPerS | Symbol Btu/s, indicating unit British thermal units per second.
Cal | Symbol cal, indicating unit Calories.
CalPerS | Symbol cal/s, indicating unit Calories per second.
Cd | Symbol cd, indicating unit Candelas.
CdPerFtSup2 | Symbol cd/ftÂ², indicating unit Candelas per square foot.
CdPerMSup2 | Symbol cd/mÂ², indicating unit Candelas per square meter.
Cf | Symbol CF, indicating unit Cubic feet.
Cfh | Symbol CFH, indicating unit Cubic feet per hour.
Cfm | Symbol CFM, indicating unit Cubic feet per minute.
CfmPerCf | Symbol CFM/CF, indicating unit Cubic feet per minute cubic foot.
CfmPerFtSup2 | Symbol CFM/ftÂ², indicating unit Cubic feet per minute square foot.
CfmPerFtSup3 | Symbol CFM/ftÂ³, indicating unit Cubic feet per minute cubic foot.
CfmPerSf | Symbol CFM/SF, indicating unit Cubic feet per minute square foot.
CfmPerTon | Symbol CFM/ton, indicating unit Cubic feet per minute ton of refrigeration.
ChineseHongKongDollar | Symbol HK$, indicating unit Currency.
Cm | Symbol cm, indicating unit Centimeters.
CmCaret2 | Symbol cm^2, indicating unit Square centimeters.
CmCaret3 | Symbol cm^3, indicating unit Cubic centimeters.
Cmh | Symbol CMH, indicating unit Cubic meters per hour.
CmPerMin | Symbol cm/min, indicating unit Centimeters per minute.
Cms | Symbol CMS, indicating unit Cubic meters per second.
CmSup2 | Symbol cmÂ², indicating unit Square centimeters.
CmSup2PerM | Symbol cmÂ²/m, indicating unit Square centimeters per meter.
CmSup3 | Symbol cmÂ³, indicating unit Cubic centimeters.
CmSup4 | Symbol cmâ´, indicating unit Centimeters to the fourth power.
CmSup6 | Symbol cmâ¶, indicating unit Centimeters to the sixth power.
Colon1 | Symbol :1, indicating unit Ratio : 1.
Colon10 | Symbol :10, indicating unit Ratio : 10.
Colon12 | Symbol :12, indicating unit Ratio : 12.
CP | Symbol cP, indicating unit Centipoises.
Cps | Symbol cps, indicating unit Cycles per second.
Custom | Unrecognized custom symbol.
Cy | Symbol CY, indicating unit Cubic yards.
DaN | Symbol daN, indicating unit Dekanewtons.
DaNDashM | Symbol daN-m, indicating unit Dekanewton meters.
DaNDashMPerM | Symbol daN-m/m, indicating unit Dekanewton meters per meter.
DaNPerM | Symbol daN/m, indicating unit Dekanewtons per meter.
DaNPerMSup2 | Symbol daN/mÂ², indicating unit Dekanewtons per square meter.
Degree | Symbol Â°, indicating unit Degrees.
DegreeC | Symbol Â°C, indicating unit Celsius.
DegreeCInterval | Symbol Â°C, indicating unit Celsius interval.
DegreeF | Symbol Â°F, indicating unit Fahrenheit.
DegreeFInterval | Symbol Â°F, indicating unit Fahrenheit interval.
DegreeR | Symbol Â°R, indicating unit Rankine.
DegreeRInterval | Symbol Â°R, indicating unit Rankine interval.
DeltaDegreeC | Symbol deltaÂ°C, indicating unit Celsius interval.
DeltaDegreeF | Symbol deltaÂ°F, indicating unit Fahrenheit interval.
DeltaDegreeR | Symbol deltaÂ°R, indicating unit Rankine interval.
DeltaK | Symbol deltaK, indicating unit Kelvin interval.
Dm | Symbol dm, indicating unit Decimeters.
DollarHPerBtu | Symbol $Â·h/Btu, indicating unit Cost per British thermal unit per hour.
DollarPerBtu | Symbol $/Btu, indicating unit Cost per British thermal unit.
DollarPerFtSup2 | Symbol $/ftÂ², indicating unit Cost per square foot.
DollarPerMSup2 | Symbol $/mÂ², indicating unit Cost per square meter.
DollarPerW | Symbol $/W, indicating unit Cost per watt.
DollarPerWH | Symbol $/(WÂ·h), indicating unit Cost per watt hour.
Dong | Symbol â‚«, indicating unit Currency.
EuroPrefix | Symbol â‚¬, indicating unit Currency.
EuroSuffix | Symbol â‚¬, indicating unit Currency.
Fc | Symbol fc, indicating unit Footcandles.
FeetOfWater | Symbol Feet, indicating unit Feet of water (39.2 Â°F).
FeetOfWaterPer100ft | Symbol Feet/100ft, indicating unit Feet of water (39.2 Â°F) per 100 feet.
FL | Symbol fL, indicating unit Footlamberts.
FlLowercase | Symbol fl, indicating unit Footlamberts.
FootSingleQuote | Symbol ', indicating unit Feet.
Fpm | Symbol FPM, indicating unit Feet per minute.
Fps | Symbol FPS, indicating unit Feet per second.
Ft | Symbol ft, indicating unit Feet.
Ftc | Symbol Ftc, indicating unit Footcandles.
FtCaret2 | Symbol ft^2, indicating unit Square feet.
FtCaret3 | Symbol ft^3, indicating unit Cubic feet.
FtH2O | Symbol ftH2O, indicating unit Feet of water (39.2 Â°F).
FtH2OPer100ft | Symbol ftH2O/100ft, indicating unit Feet of water (39.2 Â°F) per 100 feet.
FtL | Symbol ftL, indicating unit Footlamberts.
FtOfWater | Symbol FT, indicating unit Feet of water (39.2 Â°F).
FtOfWaterPer100ft | Symbol FT/100ft, indicating unit Feet of water (39.2 Â°F) per 100 feet.
FtPerKip | Symbol ft/kip, indicating unit Feet per kip.
FtPerMin | Symbol ft/min, indicating unit Feet per minute.
FtPerS | Symbol ft/s, indicating unit Feet per second.
FtPerSSup2 | Symbol ft/sÂ², indicating unit Feet per second squared.
FtSup2 | Symbol ftÂ², indicating unit Square feet.
FtSup2HPerKbtu | Symbol ftÂ²Â·h/kBtu, indicating unit Square feet per thousand British thermal units per hour.
FtSup2PerFt | Symbol ftÂ²/ft, indicating unit Square feet per foot.
FtSup2PerKip | Symbol ftÂ²/kip, indicating unit Square feet per kip.
FtSup2PerMbh | Symbol ftÂ²/MBh, indicating unit Square feet per thousand British thermal units per hour.
FtSup2PerS | Symbol ftÂ²/s, indicating unit Square feet per second.
FtSup2PerTon | Symbol ftÂ²/ton, indicating unit Square feet per ton of refrigeration.
FtSup3 | Symbol ftÂ³, indicating unit Cubic feet.
FtSup3HPerMinBtu | Symbol ftÂ³Â·h/(minÂ·Btu), indicating unit Cubic feet per minute per British thermal unit per hour.
FtSup3PerH | Symbol ftÂ³/h, indicating unit Cubic feet per hour.
FtSup3PerKip | Symbol ftÂ³/kip, indicating unit Cubic feet per kip.
FtSup3PerLbMass | Symbol ftÂ³/lb, indicating unit Cubic feet per pound mass.
FtSup3PerMin | Symbol ftÂ³/min, indicating unit Cubic feet per minute.
FtSup4 | Symbol ftâ´, indicating unit Feet to the fourth power.
FtSup6 | Symbol ftâ¶, indicating unit Feet to the sixth power.
Gal | Symbol gal, indicating unit US gallons.
GalPerH | Symbol gal/h, indicating unit US gallons per hour.
GalPerMin | Symbol gal/min, indicating unit US gallons per minute.
Gph | Symbol GPH, indicating unit US gallons per hour.
Gpm | Symbol GPM, indicating unit US gallons per minute.
Grad | Symbol grad, indicating unit Gradians.
GrPerHFtSup2InHg | Symbol gr/(hÂ·ftÂ²Â·inHg), indicating unit Grains per hour square foot inch mercury.
Hectare | Symbol hectare, indicating unit Hectares.
HFtSup2DegreeFPerBtu | Symbol (hÂ·ftÂ²Â·Â°F)/BTU, indicating unit Hour square foot degrees Fahrenheit per British thermal unit.
Hour | Symbol h, indicating unit Hours.
Hp | Symbol hp, indicating unit Horsepower.
Hz | Symbol Hz, indicating unit Hertz.
In | Symbol in, indicating unit Inches.
InCaret2 | Symbol in^2, indicating unit Square inches.
InCaret3 | Symbol in^3, indicating unit Cubic inches.
InchDoubleQuote | Symbol ", indicating unit Inches.
InDashWg | Symbol in-wg, indicating unit Inches of water (60 Â°F).
InDashWgPer100ft | Symbol in-wg/100ft, indicating unit Inches of water (60 Â°F) per 100 feet.
InHg | Symbol inHg, indicating unit Inches of mercury (32 Â°F).
InPerSSup2 | Symbol in/sÂ², indicating unit Inches per second squared.
InSup2 | Symbol inÂ², indicating unit Square inches.
InSup2PerFt | Symbol inÂ²/ft, indicating unit Square inches per foot.
InSup3 | Symbol inÂ³, indicating unit Cubic inches.
InSup4 | Symbol inâ´, indicating unit Inches to the fourth power.
InSup6 | Symbol inâ¶, indicating unit Inches to the sixth power.
InvDegreeC | Symbol 1/Â°C, indicating unit Inverse degrees Celsius.
InvDegreeF | Symbol 1/Â°F, indicating unit Inverse degrees Fahrenheit.
InvKip | Symbol 1/kip, indicating unit Inverse kips.
InvKN | Symbol 1/kN, indicating unit Inverse kilonewtons.
Joule | Symbol J, indicating unit Joules.
JPerG | Symbol J/g, indicating unit Joules per gram.
JPerGDegreeC | Symbol J/(gÂ·Â°C), indicating unit Joules per gram degree Celsius.
JPerK | Symbol J/K, indicating unit Joules per Kelvin.
JPerKgDegreeC | Symbol J/(kgÂ·Â°C), indicating unit Joules per kilogram degree Celsius.
JPerMSup2K | Symbol J/(mÂ²Â·K), indicating unit Joules per square meter Kelvin.
KA | Symbol kA, indicating unit Kiloamperes.
Kcal | Symbol kcal, indicating unit Kilocalories.
KcalPerS | Symbol kcal/s, indicating unit Kilocalories per second.
Kelvin | Symbol K, indicating unit Kelvin.
KelvinInterval | Symbol K, indicating unit Kelvin interval.
Kg | Symbol kg, indicating unit Kilograms.
Kgf | Symbol kgf, indicating unit Kilograms force.
KgfDashM | Symbol kgf-m, indicating unit Kilogram force meters.
KgfDashMPerM | Symbol kgf-m/m, indicating unit Kilogram force meters per meter.
KgfPerM | Symbol kgf/m, indicating unit Kilograms force per meter.
KgfPerMSup2 | Symbol kgf/mÂ², indicating unit Kilograms force per square meter.
KgPerH | Symbol kg/h, indicating unit Kilograms per hour.
KgPerKgK | Symbol kg/(kgÂ·K), indicating unit Kilograms per kilogram kelvin.
KgPerM | Symbol kg/m, indicating unit Kilograms per meter.
KgPerMH | Symbol kg/(mÂ·h), indicating unit Kilograms per meter hour.
KgPerMin | Symbol kg/min, indicating unit Kilograms per minute.
KgPerMS | Symbol kg/(mÂ·s), indicating unit Kilograms per meter second.
KgPerMSup2 | Symbol kg/mÂ², indicating unit Kilograms per square meter.
KgPerMSup3 | Symbol kg/mÂ³, indicating unit Kilograms per cubic meter.
KgPerS | Symbol kg/s, indicating unit Kilograms per second.
Kip | Symbol kip, indicating unit Kips.
KipDashFt | Symbol kip-ft, indicating unit Kip feet.
KipDashFtPerDegree | Symbol kip-ft/Â°, indicating unit Kip feet per degree.
KipDashFtPerDegreePerFt | Symbol kip-ft/Â°/ft, indicating unit Kip feet per degree per foot.
KipDashFtPerFt | Symbol kip-ft/ft, indicating unit Kip feet per foot.
KipPerFt | Symbol kip/ft, indicating unit Kips per foot.
KipPerFtSup2 | Symbol kip/ftÂ², indicating unit Kips per square foot.
KipPerFtSup3 | Symbol kip/ftÂ³, indicating unit Kips per cubic foot.
KipPerIn | Symbol kip/in, indicating unit Kips per inch.
KipPerInSup2 | Symbol kip/inÂ², indicating unit Kips per square inch.
KipPerInSup3 | Symbol kip/inÂ³, indicating unit Kips per cubic inch.
KJ | Symbol kJ, indicating unit Kilojoules.
KJPerK | Symbol kJ/K, indicating unit Kilojoules per Kelvin.
KJPerMSup2K | Symbol kJ/(mÂ²Â·K), indicating unit Kilojoules per square meter Kelvin.
KmPerH | Symbol km/h, indicating unit Kilometers per hour.
KmPerSSup2 | Symbol km/sÂ², indicating unit Kilometers per second squared.
KN | Symbol kN, indicating unit Kilonewtons.
KNDashM | Symbol kN-m, indicating unit Kilonewton meters.
KNDashMPerDegree | Symbol kN-m/Â°, indicating unit Kilonewton meters per degree.
KNDashMPerDegreePerM | Symbol kN-m/Â°/m, indicating unit Kilonewton meters per degree per meter.
KNDashMPerM | Symbol kN-m/m, indicating unit Kilonewton meters per meter.
KNPerCmSup2 | Symbol kN/cmÂ², indicating unit Kilonewtons per square centimeter.
KNPerM | Symbol kN/m, indicating unit Kilonewtons per meter.
KNPerMmSup2 | Symbol kN/mmÂ², indicating unit Kilonewtons per square millimeter.
KNPerMSup2 | Symbol kN/mÂ², indicating unit Kilonewtons per square meter.
KNPerMSup3 | Symbol kN/mÂ³, indicating unit Kilonewtons per cubic meter.
KPa | Symbol kPa, indicating unit Kilopascals.
Krone | Symbol kr, indicating unit Currency.
Ksf | Symbol ksf, indicating unit Kips per square foot.
Ksi | Symbol ksi, indicating unit Kips per square inch.
KV | Symbol kV, indicating unit Kilovolts.
KVA | Symbol kVA, indicating unit Kilovolt amperes.
KW | Symbol kW, indicating unit Kilowatts.
KWh | Symbol kWh, indicating unit Kilowatt hours.
Lbf | Symbol lbf, indicating unit Pounds force.
LbfDashFt | Symbol lbf-ft, indicating unit Pound force feet.
LbfDashFtPerFt | Symbol lbf-ft/ft, indicating unit Pound force feet per foot.
LbForce | Symbol lb, indicating unit Pounds force.
LbForceDashFt | Symbol lb-ft, indicating unit Pound force feet.
LbForceDashFtPerFt | Symbol lb-ft/ft, indicating unit Pound force feet per foot.
LbForcePerFt | Symbol lb/ft, indicating unit Pounds force per foot.
LbForcePerFtSup2 | Symbol lb/ftÂ², indicating unit Pounds force per square foot.
LbForcePerFtSup3 | Symbol lb/ftÂ³, indicating unit Pounds force per cubic foot.
LbForcePerInSup2 | Symbol lb/inÂ², indicating unit Pounds force per square inch.
LbForceSPerFtSup2 | Symbol lbÂ·s/ftÂ², indicating unit Pound force seconds per square foot.
LbfPerFt | Symbol lbf/ft, indicating unit Pounds force per foot.
LbfPerFtSup2 | Symbol lbf/ftÂ², indicating unit Pounds force per square foot.
LbfPerFtSup3 | Symbol lbf/ftÂ³, indicating unit Pounds force per cubic foot.
LbfPerInSup2 | Symbol lbf/inÂ², indicating unit Pounds force per square inch.
Lbm | Symbol lbm, indicating unit Pounds mass.
LbMass | Symbol lb, indicating unit Pounds mass.
LbMassPerFt | Symbol lb/ft, indicating unit Pounds mass per foot.
LbMassPerFtDashH | Symbol lb/ft-h, indicating unit Pounds mass per foot hour.
LbMassPerFtDashS | Symbol lb/ft-s, indicating unit Pounds mass per foot second.
LbMassPerFtSup2 | Symbol lb/ftÂ², indicating unit Pounds mass per square foot.
LbMassPerFtSup3 | Symbol lb/ftÂ³, indicating unit Pounds mass per cubic foot.
LbMassPerH | Symbol lb/h, indicating unit Pounds mass per hour.
LbMassPerInSup3 | Symbol lb/inÂ³, indicating unit Pounds mass per cubic inch.
LbMassPerLbDegreeF | Symbol lb/(lbÂ·Â°F), indicating unit Pounds mass per pound degree Fahrenheit.
LbMassPerMin | Symbol lb/min, indicating unit Pounds mass per minute.
LbMassPerS | Symbol lb/s, indicating unit Pounds mass per second.
LbmPerFt | Symbol lbm/ft, indicating unit Pounds mass per foot.
LbmPerFtDashH | Symbol lbm/ft-h, indicating unit Pounds mass per foot hour.
LbmPerFtDashS | Symbol lbm/ft-s, indicating unit Pounds mass per foot second.
LbmPerFtSup3 | Symbol lbm/ftÂ³, indicating unit Pounds mass per cubic foot.
LbmPerInSup3 | Symbol lbm/inÂ³, indicating unit Pounds mass per cubic inch.
Lf | Symbol LF, indicating unit Feet.
Liter | Symbol L, indicating unit Liters.
Lm | Symbol lm, indicating unit Lumens.
LmPerW | Symbol lm/W, indicating unit Lumens per watt.
LPerH | Symbol L/h, indicating unit Liters per hour.
LPerMin | Symbol L/min, indicating unit Liters per minute.
LPerS | Symbol L/s, indicating unit Liters per second.
LPerSKw | Symbol L/(sÂ·kW), indicating unit Liters per second kilowatt.
LPerSMSup2 | Symbol L/(sÂ·mÂ²), indicating unit Liters per second square meter.
LPerSMSup3 | Symbol L/(sÂ·mÂ³), indicating unit Liters per second cubic meter.
Lpm | Symbol LPM, indicating unit Liters per minute.
Lps | Symbol LPS, indicating unit Liters per second.
LpsPerMSup2 | Symbol LPS/mÂ², indicating unit Liters per second square meter.
Lx | Symbol lx, indicating unit Lux.
MA | Symbol mA, indicating unit Milliamperes.
Mbh | Symbol MBH, indicating unit Thousand British thermal units per hour.
MCaret2 | Symbol m^2, indicating unit Square meters.
MCaret3 | Symbol m^3, indicating unit Cubic meters.
Meter | Symbol m, indicating unit Meters.
MH2O | Symbol mH2O, indicating unit Meters of water column.
MH2OPerM | Symbol mH2O/m, indicating unit Meters of water column per meter.
Min | Symbol min, indicating unit Minutes.
MiPerSSup2 | Symbol mi/sÂ², indicating unit Miles per second squared.
Mm | Symbol mm, indicating unit Millimeters.
MmCaret2 | Symbol mm^2, indicating unit Square millimeters.
MmCaret3 | Symbol mm^3, indicating unit Cubic millimeters.
MmH2O | Symbol mmH2O, indicating unit Millimeters of water column.
MmH2OPerM | Symbol mmH2O/m, indicating unit Millimeters of water column per meter.
MmHg | Symbol mmHg, indicating unit Millimeters of mercury.
MmSup2 | Symbol mmÂ², indicating unit Square millimeters.
MmSup2PerM | Symbol mmÂ²/m, indicating unit Square millimeters per meter.
MmSup3 | Symbol mmÂ³, indicating unit Cubic millimeters.
MmSup4 | Symbol mmâ´, indicating unit Millimeters to the fourth power.
MmSup6 | Symbol mmâ¶, indicating unit Millimeters to the sixth power.
MN | Symbol MN, indicating unit Meganewtons.
MNDashM | Symbol MN-m, indicating unit Meganewton meters.
MNDashMPerM | Symbol MN-m/m, indicating unit Meganewton meters per meter.
MNPerM | Symbol MN/m, indicating unit Meganewtons per meter.
MNPerMSup2 | Symbol MN/mÂ², indicating unit Meganewtons per square meter.
MPa | Symbol MPa, indicating unit Megapascals.
MPerKN | Symbol m/kN, indicating unit Meters per kilonewton.
MPerS | Symbol m/s, indicating unit Meters per second.
MPerSSup2 | Symbol m/sÂ², indicating unit Meters per second squared.
Mph | Symbol mph, indicating unit Miles per hour.
Ms | Symbol ms, indicating unit Milliseconds.
MSup2 | Symbol mÂ², indicating unit Square meters.
MSup2KPerW | Symbol (mÂ²Â·K)/W, indicating unit Square meter kelvins per watt.
MSup2PerKN | Symbol mÂ²/kN, indicating unit Square meters per kilonewton.
MSup2PerKw | Symbol mÂ²/kW, indicating unit Square meters per kilowatt.
MSup2PerM | Symbol mÂ²/m, indicating unit Square meters per meter.
MSup2PerS | Symbol mÂ²/s, indicating unit Square meters per second.
MSup3 | Symbol mÂ³, indicating unit Cubic meters.
MSup3PerH | Symbol mÂ³/h, indicating unit Cubic meters per hour.
MSup3PerHMSup2 | Symbol mÂ³/(hÂ·mÂ²), indicating unit Cubic meters per hour square meter.
MSup3PerHMSup3 | Symbol mÂ³/(hÂ·mÂ³), indicating unit Cubic meters per hour cubic meter.
MSup3PerKg | Symbol mÂ³/kg, indicating unit Cubic meters per kilogram.
MSup3PerKN | Symbol mÂ³/kN, indicating unit Cubic meters per kilonewton.
MSup3PerS | Symbol mÂ³/s, indicating unit Cubic meters per second.
MSup3PerWS | Symbol mÂ³/(WÂ·s), indicating unit Cubic meters per watt second.
MSup4 | Symbol mâ´, indicating unit Meters to the fourth power.
MSup6 | Symbol mâ¶, indicating unit Meters to the sixth power.
MV | Symbol mV, indicating unit Millivolts.
NDashM | Symbol N-m, indicating unit Newton meters.
NDashMPerM | Symbol N-m/m, indicating unit Newton meters per meter.
Newton | Symbol N, indicating unit Newtons.
NgPerPaSMSup2 | Symbol ng/(PaÂ·sÂ·mÂ²), indicating unit Nanograms per pascal second square meter.
NPerM | Symbol N/m, indicating unit Newtons per meter.
NPerMmSup2 | Symbol N/mmÂ², indicating unit Newtons per square millimeter.
NPerMSup2 | Symbol N/mÂ², indicating unit Newtons per square meter.
NSPerMSup2 | Symbol NÂ·s/mÂ², indicating unit Newton seconds per square meter.
OhmM | Symbol ohmÂ·m, indicating unit Ohm meters.
OneColon | Symbol 1:, indicating unit 1 : Ratio.
Pa | Symbol Pa, indicating unit Pascals.
PaDashS | Symbol Pa-s, indicating unit Pascal seconds.
PaPerM | Symbol Pa/m, indicating unit Pascals per meter.
Percent | Symbol %, indicating unit Percentage.
PerMille | Symbol â€°, indicating unit Per mille.
Pi | Symbol Ï€, indicating unit Multiples of Ï€.
Psf | Symbol psf, indicating unit Pounds force per square foot.
Psi | Symbol psi, indicating unit Pounds force per square inch.
Psia | Symbol psia, indicating unit Pounds force per square inch.
Psig | Symbol psig, indicating unit Pounds force per square inch.
Rad | Symbol rad, indicating unit Radians.
RadPerS | Symbol rad/s, indicating unit Radians per second.
Rpm | Symbol RPM, indicating unit Revolutions per minute.
Rps | Symbol RPS, indicating unit Revolutions per second.
Second | Symbol s, indicating unit Seconds.
Sf | Symbol SF, indicating unit Square feet.
SfHPerKbtu | Symbol SFÂ·h/kBtu, indicating unit Square feet per thousand British thermal units per hour.
SfPerMbh | Symbol SF/MBh, indicating unit Square feet per thousand British thermal units per hour.
SfPerTon | Symbol SF/ton, indicating unit Square feet per ton of refrigeration.
Shekel | Symbol â‚ª, indicating unit Currency.
SlopeDegree | Symbol Â°, indicating unit Slope degrees.
Stf | Symbol STf, indicating unit US tonnes force.
Tf | Symbol Tf, indicating unit Tonnes force.
TfDashM | Symbol Tf-m, indicating unit Tonne force meters.
TfDashMPerM | Symbol Tf-m/m, indicating unit Tonne force meters per meter.
TfPerM | Symbol Tf/m, indicating unit Tonnes force per meter.
TfPerMSup2 | Symbol Tf/mÂ², indicating unit Tonnes force per square meter.
Therm | Symbol therm, indicating unit Therms.
Ton | Symbol ton, indicating unit Tons of refrigeration.
Tonne | Symbol t, indicating unit Tonnes.
TonOfRefrigeration | Symbol ton of refrigeration, indicating unit Tons of refrigeration.
Tonsf | Symbol Tonsf, indicating unit US tonnes force.
UinPerInDegreeF | Symbol Âµin/(inÂ·Â°F), indicating unit Microinches per inch degree Fahrenheit.
UkPound | Symbol Â£, indicating unit Currency.
UmPerMDegreeC | Symbol Âµm/(mÂ·Â°C), indicating unit Micrometers per meter degree Celsius.
UsDollar | Symbol $, indicating unit Currency.
Usft | Symbol USft, indicating unit US survey feet.
Usgph | Symbol usgph, indicating unit US gallons per hour.
Usgpm | Symbol usgpm, indicating unit US gallons per minute.
UsTonnesForceSt | Symbol ST, indicating unit US tonnes force.
UsTonnesForceT | Symbol T, indicating unit US tonnes force.
UsTonnesForceTons | Symbol Tons, indicating unit US tonnes force.
UsTonnesMassSt | Symbol ST, indicating unit US tonnes mass.
UsTonnesMassT | Symbol T, indicating unit US tonnes mass.
UsTonnesMassTons | Symbol Tons, indicating unit US tonnes mass.
VA | Symbol VA, indicating unit Volt amperes.
VAPerFtSup2 | Symbol VA/ftÂ², indicating unit Volt amperes per square foot.
VAPerMSup2 | Symbol VA/mÂ², indicating unit Volt amperes per square meter.
Volt | Symbol V, indicating unit Volts.
Watt | Symbol W, indicating unit Watts.
WMinPerFtSup3 | Symbol WÂ·min/ftÂ³, indicating unit Watts per cubic foot per minute.
Won | Symbol â‚©, indicating unit Currency.
WPerFt | Symbol W/ft, indicating unit Watts per foot.
WPerFtSup2 | Symbol W/ftÂ², indicating unit Watts per square foot.
WPerFtSup3 | Symbol W/ftÂ³, indicating unit Watts per cubic foot.
WPerM | Symbol W/m, indicating unit Watts per meter.
WPerMK | Symbol W/(mÂ·K), indicating unit Watts per meter kelvin.
WPerMSup2 | Symbol W/mÂ², indicating unit Watts per square meter.
WPerMSup2K | Symbol W/(mÂ²Â·K), indicating unit Watts per square meter kelvin.
WPerMSup3 | Symbol W/mÂ³, indicating unit Watts per cubic meter.
WSPerMSup3 | Symbol WÂ·s/mÂ³, indicating unit Watts per cubic meter per second.
YdCaret3 | Symbol yd^3, indicating unit Cubic yards.
YdSup3 | Symbol ydÂ³, indicating unit Cubic yards.
Yen | Symbol Â¥, indicating unit Currency.

See Also

SymbolTypeId Class


Acres Property

[image]

Revit 2024 API
SymbolTypeId..::..Acres Property
SymbolTypeId Class See Also Send Feedback
Symbol acres, indicating unit Acres.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Acres { get; }
Visual Basic
Public Shared ReadOnly Property Acres As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Acres {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Ampere Property

[image]

Revit 2024 API
SymbolTypeId..::..Ampere Property
SymbolTypeId Class See Also Send Feedback
Symbol A, indicating unit Amperes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Ampere { get; }
Visual Basic
Public Shared ReadOnly Property Ampere As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Ampere {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Atm Property

[image]

Revit 2024 API
SymbolTypeId..::..Atm Property
SymbolTypeId Class See Also Send Feedback
Symbol atm, indicating unit Atmospheres.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Atm { get; }
Visual Basic
Public Shared ReadOnly Property Atm As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Atm {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Baht Property

[image]

Revit 2024 API
SymbolTypeId..::..Baht Property
SymbolTypeId Class See Also Send Feedback
Symbol à¸¿, indicating unit Currency.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Baht { get; }
Visual Basic
Public Shared ReadOnly Property Baht As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Baht {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


BtuPerFtSup2DegreeF Property

[image]

Revit 2024 API
SymbolTypeId..::..BtuPerFtSup2DegreeF Property
SymbolTypeId Class See Also Send Feedback
Symbol BTU/(ftÂ²Â·Â°F), indicating unit British thermal units per square foot degree Fahrenheit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId BtuPerFtSup2DegreeF { get; }
Visual Basic
Public Shared ReadOnly Property BtuPerFtSup2DegreeF As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BtuPerFtSup2DegreeF {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


BtuPerH Property

[image]

Revit 2024 API
SymbolTypeId..::..BtuPerH Property
SymbolTypeId Class See Also Send Feedback
Symbol Btu/h, indicating unit British thermal units per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId BtuPerH { get; }
Visual Basic
Public Shared ReadOnly Property BtuPerH As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BtuPerH {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


BtuPerHFtDegreeF Property

[image]

Revit 2024 API
SymbolTypeId..::..BtuPerHFtDegreeF Property
SymbolTypeId Class See Also Send Feedback
Symbol BTU/(hÂ·ftÂ·Â°F), indicating unit British thermal units per hour foot degree Fahrenheit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId BtuPerHFtDegreeF { get; }
Visual Basic
Public Shared ReadOnly Property BtuPerHFtDegreeF As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BtuPerHFtDegreeF {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


BtuPerHFtSup2 Property

[image]

Revit 2024 API
SymbolTypeId..::..BtuPerHFtSup2 Property
SymbolTypeId Class See Also Send Feedback
Symbol Btu/(hÂ·ftÂ²), indicating unit British thermal units per hour square foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId BtuPerHFtSup2 { get; }
Visual Basic
Public Shared ReadOnly Property BtuPerHFtSup2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BtuPerHFtSup2 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


BtuPerHFtSup2DegreeF Property

[image]

Revit 2024 API
SymbolTypeId..::..BtuPerHFtSup2DegreeF Property
SymbolTypeId Class See Also Send Feedback
Symbol BTU/(hÂ·ftÂ²Â·Â°F), indicating unit British thermal units per hour square foot degree Fahrenheit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId BtuPerHFtSup2DegreeF { get; }
Visual Basic
Public Shared ReadOnly Property BtuPerHFtSup2DegreeF As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BtuPerHFtSup2DegreeF {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


BtuPerHFtSup3 Property

[image]

Revit 2024 API
SymbolTypeId..::..BtuPerHFtSup3 Property
SymbolTypeId Class See Also Send Feedback
Symbol Btu/(hÂ·ftÂ³), indicating unit British thermal units per hour cubic foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId BtuPerHFtSup3 { get; }
Visual Basic
Public Shared ReadOnly Property BtuPerHFtSup3 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BtuPerHFtSup3 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


BtuPerLb Property

[image]

Revit 2024 API
SymbolTypeId..::..BtuPerLb Property
SymbolTypeId Class See Also Send Feedback
Symbol BTU/lb, indicating unit British thermal units per pound.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId BtuPerLb { get; }
Visual Basic
Public Shared ReadOnly Property BtuPerLb As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BtuPerLb {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


BtuPerLbDegreeF Property

[image]

Revit 2024 API
SymbolTypeId..::..BtuPerLbDegreeF Property
SymbolTypeId Class See Also Send Feedback
Symbol BTU/(lbÂ·Â°F), indicating unit British thermal units per pound degree Fahrenheit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId BtuPerLbDegreeF { get; }
Visual Basic
Public Shared ReadOnly Property BtuPerLbDegreeF As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BtuPerLbDegreeF {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


BtuPerS Property

[image]

Revit 2024 API
SymbolTypeId..::..BtuPerS Property
SymbolTypeId Class See Also Send Feedback
Symbol Btu/s, indicating unit British thermal units per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId BtuPerS { get; }
Visual Basic
Public Shared ReadOnly Property BtuPerS As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BtuPerS {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Cal Property

[image]

Revit 2024 API
SymbolTypeId..::..Cal Property
SymbolTypeId Class See Also Send Feedback
Symbol cal, indicating unit Calories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Cal { get; }
Visual Basic
Public Shared ReadOnly Property Cal As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Cal {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


CalPerS Property

[image]

Revit 2024 API
SymbolTypeId..::..CalPerS Property
SymbolTypeId Class See Also Send Feedback
Symbol cal/s, indicating unit Calories per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId CalPerS { get; }
Visual Basic
Public Shared ReadOnly Property CalPerS As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CalPerS {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Cd Property

[image]

Revit 2024 API
SymbolTypeId..::..Cd Property
SymbolTypeId Class See Also Send Feedback
Symbol cd, indicating unit Candelas.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Cd { get; }
Visual Basic
Public Shared ReadOnly Property Cd As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Cd {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


CdPerFtSup2 Property

[image]

Revit 2024 API
SymbolTypeId..::..CdPerFtSup2 Property
SymbolTypeId Class See Also Send Feedback
Symbol cd/ftÂ², indicating unit Candelas per square foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId CdPerFtSup2 { get; }
Visual Basic
Public Shared ReadOnly Property CdPerFtSup2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CdPerFtSup2 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


CdPerMSup2 Property

[image]

Revit 2024 API
SymbolTypeId..::..CdPerMSup2 Property
SymbolTypeId Class See Also Send Feedback
Symbol cd/mÂ², indicating unit Candelas per square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId CdPerMSup2 { get; }
Visual Basic
Public Shared ReadOnly Property CdPerMSup2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CdPerMSup2 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Cf Property

[image]

Revit 2024 API
SymbolTypeId..::..Cf Property
SymbolTypeId Class See Also Send Feedback
Symbol CF, indicating unit Cubic feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Cf { get; }
Visual Basic
Public Shared ReadOnly Property Cf As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Cf {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Cfh Property

[image]

Revit 2024 API
SymbolTypeId..::..Cfh Property
SymbolTypeId Class See Also Send Feedback
Symbol CFH, indicating unit Cubic feet per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Cfh { get; }
Visual Basic
Public Shared ReadOnly Property Cfh As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Cfh {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Cfm Property

[image]

Revit 2024 API
SymbolTypeId..::..Cfm Property
SymbolTypeId Class See Also Send Feedback
Symbol CFM, indicating unit Cubic feet per minute.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Cfm { get; }
Visual Basic
Public Shared ReadOnly Property Cfm As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Cfm {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


CfmPerCf Property

[image]

Revit 2024 API
SymbolTypeId..::..CfmPerCf Property
SymbolTypeId Class See Also Send Feedback
Symbol CFM/CF, indicating unit Cubic feet per minute cubic foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId CfmPerCf { get; }
Visual Basic
Public Shared ReadOnly Property CfmPerCf As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CfmPerCf {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


CfmPerFtSup2 Property

[image]

Revit 2024 API
SymbolTypeId..::..CfmPerFtSup2 Property
SymbolTypeId Class See Also Send Feedback
Symbol CFM/ftÂ², indicating unit Cubic feet per minute square foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId CfmPerFtSup2 { get; }
Visual Basic
Public Shared ReadOnly Property CfmPerFtSup2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CfmPerFtSup2 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


CfmPerFtSup3 Property

[image]

Revit 2024 API
SymbolTypeId..::..CfmPerFtSup3 Property
SymbolTypeId Class See Also Send Feedback
Symbol CFM/ftÂ³, indicating unit Cubic feet per minute cubic foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId CfmPerFtSup3 { get; }
Visual Basic
Public Shared ReadOnly Property CfmPerFtSup3 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CfmPerFtSup3 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


CfmPerTon Property

[image]

Revit 2024 API
SymbolTypeId..::..CfmPerTon Property
SymbolTypeId Class See Also Send Feedback
Symbol CFM/ton, indicating unit Cubic feet per minute ton of refrigeration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId CfmPerTon { get; }
Visual Basic
Public Shared ReadOnly Property CfmPerTon As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CfmPerTon {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


ChineseHongKongDollar Property

[image]

Revit 2024 API
SymbolTypeId..::..ChineseHongKongDollar Property
SymbolTypeId Class See Also Send Feedback
Symbol HK$, indicating unit Currency.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId ChineseHongKongDollar { get; }
Visual Basic
Public Shared ReadOnly Property ChineseHongKongDollar As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ ChineseHongKongDollar {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


CmCaret2 Property

[image]

Revit 2024 API
SymbolTypeId..::..CmCaret2 Property
SymbolTypeId Class See Also Send Feedback
Symbol cm^2, indicating unit Square centimeters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId CmCaret2 { get; }
Visual Basic
Public Shared ReadOnly Property CmCaret2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CmCaret2 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


CmCaret3 Property

[image]

Revit 2024 API
SymbolTypeId..::..CmCaret3 Property
SymbolTypeId Class See Also Send Feedback
Symbol cm^3, indicating unit Cubic centimeters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId CmCaret3 { get; }
Visual Basic
Public Shared ReadOnly Property CmCaret3 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CmCaret3 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Cmh Property

[image]

Revit 2024 API
SymbolTypeId..::..Cmh Property
SymbolTypeId Class See Also Send Feedback
Symbol CMH, indicating unit Cubic meters per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Cmh { get; }
Visual Basic
Public Shared ReadOnly Property Cmh As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Cmh {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


CmPerMin Property

[image]

Revit 2024 API
SymbolTypeId..::..CmPerMin Property
SymbolTypeId Class See Also Send Feedback
Symbol cm/min, indicating unit Centimeters per minute.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId CmPerMin { get; }
Visual Basic
Public Shared ReadOnly Property CmPerMin As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CmPerMin {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Cms Property

[image]

Revit 2024 API
SymbolTypeId..::..Cms Property
SymbolTypeId Class See Also Send Feedback
Symbol CMS, indicating unit Cubic meters per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Cms { get; }
Visual Basic
Public Shared ReadOnly Property Cms As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Cms {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


CmSup2 Property

[image]

Revit 2024 API
SymbolTypeId..::..CmSup2 Property
SymbolTypeId Class See Also Send Feedback
Symbol cmÂ², indicating unit Square centimeters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId CmSup2 { get; }
Visual Basic
Public Shared ReadOnly Property CmSup2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CmSup2 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


CmSup2PerM Property

[image]

Revit 2024 API
SymbolTypeId..::..CmSup2PerM Property
SymbolTypeId Class See Also Send Feedback
Symbol cmÂ²/m, indicating unit Square centimeters per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId CmSup2PerM { get; }
Visual Basic
Public Shared ReadOnly Property CmSup2PerM As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CmSup2PerM {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


CmSup3 Property

[image]

Revit 2024 API
SymbolTypeId..::..CmSup3 Property
SymbolTypeId Class See Also Send Feedback
Symbol cmÂ³, indicating unit Cubic centimeters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId CmSup3 { get; }
Visual Basic
Public Shared ReadOnly Property CmSup3 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CmSup3 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


CmSup4 Property

[image]

Revit 2024 API
SymbolTypeId..::..CmSup4 Property
SymbolTypeId Class See Also Send Feedback
Symbol cmâ´, indicating unit Centimeters to the fourth power.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId CmSup4 { get; }
Visual Basic
Public Shared ReadOnly Property CmSup4 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CmSup4 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


CmSup6 Property

[image]

Revit 2024 API
SymbolTypeId..::..CmSup6 Property
SymbolTypeId Class See Also Send Feedback
Symbol cmâ¶, indicating unit Centimeters to the sixth power.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId CmSup6 { get; }
Visual Basic
Public Shared ReadOnly Property CmSup6 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CmSup6 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Colon1 Property

[image]

Revit 2024 API
SymbolTypeId..::..Colon1 Property
SymbolTypeId Class See Also Send Feedback
Symbol :1, indicating unit Ratio : 1.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Colon1 { get; }
Visual Basic
Public Shared ReadOnly Property Colon1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Colon1 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Colon10 Property

[image]

Revit 2024 API
SymbolTypeId..::..Colon10 Property
SymbolTypeId Class See Also Send Feedback
Symbol :10, indicating unit Ratio : 10.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Colon10 { get; }
Visual Basic
Public Shared ReadOnly Property Colon10 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Colon10 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


CP Property

[image]

Revit 2024 API
SymbolTypeId..::..CP Property
SymbolTypeId Class See Also Send Feedback
Symbol cP, indicating unit Centipoises.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId CP { get; }
Visual Basic
Public Shared ReadOnly Property CP As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CP {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Custom Property

[image]

Revit 2024 API
SymbolTypeId..::..Custom Property
SymbolTypeId Class See Also Send Feedback
Unrecognized custom symbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Custom { get; }
Visual Basic
Public Shared ReadOnly Property Custom As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Custom {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Cy Property

[image]

Revit 2024 API
SymbolTypeId..::..Cy Property
SymbolTypeId Class See Also Send Feedback
Symbol CY, indicating unit Cubic yards.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Cy { get; }
Visual Basic
Public Shared ReadOnly Property Cy As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Cy {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


DaN Property

[image]

Revit 2024 API
SymbolTypeId..::..DaN Property
SymbolTypeId Class See Also Send Feedback
Symbol daN, indicating unit Dekanewtons.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId DaN { get; }
Visual Basic
Public Shared ReadOnly Property DaN As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DaN {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


DaNDashM Property

[image]

Revit 2024 API
SymbolTypeId..::..DaNDashM Property
SymbolTypeId Class See Also Send Feedback
Symbol daN-m, indicating unit Dekanewton meters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId DaNDashM { get; }
Visual Basic
Public Shared ReadOnly Property DaNDashM As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DaNDashM {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


DaNDashMPerM Property

[image]

Revit 2024 API
SymbolTypeId..::..DaNDashMPerM Property
SymbolTypeId Class See Also Send Feedback
Symbol daN-m/m, indicating unit Dekanewton meters per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId DaNDashMPerM { get; }
Visual Basic
Public Shared ReadOnly Property DaNDashMPerM As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DaNDashMPerM {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


DaNPerMSup2 Property

[image]

Revit 2024 API
SymbolTypeId..::..DaNPerMSup2 Property
SymbolTypeId Class See Also Send Feedback
Symbol daN/mÂ², indicating unit Dekanewtons per square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId DaNPerMSup2 { get; }
Visual Basic
Public Shared ReadOnly Property DaNPerMSup2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DaNPerMSup2 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


DegreeCInterval Property

[image]

Revit 2024 API
SymbolTypeId..::..DegreeCInterval Property
SymbolTypeId Class See Also Send Feedback
Symbol Â°C, indicating unit Celsius interval.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId DegreeCInterval { get; }
Visual Basic
Public Shared ReadOnly Property DegreeCInterval As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DegreeCInterval {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


DegreeF Property

[image]

Revit 2024 API
SymbolTypeId..::..DegreeF Property
SymbolTypeId Class See Also Send Feedback
Symbol Â°F, indicating unit Fahrenheit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId DegreeF { get; }
Visual Basic
Public Shared ReadOnly Property DegreeF As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DegreeF {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


DegreeFInterval Property

[image]

Revit 2024 API
SymbolTypeId..::..DegreeFInterval Property
SymbolTypeId Class See Also Send Feedback
Symbol Â°F, indicating unit Fahrenheit interval.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId DegreeFInterval { get; }
Visual Basic
Public Shared ReadOnly Property DegreeFInterval As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DegreeFInterval {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


DegreeR Property

[image]

Revit 2024 API
SymbolTypeId..::..DegreeR Property
SymbolTypeId Class See Also Send Feedback
Symbol Â°R, indicating unit Rankine.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId DegreeR { get; }
Visual Basic
Public Shared ReadOnly Property DegreeR As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DegreeR {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


DegreeRInterval Property

[image]

Revit 2024 API
SymbolTypeId..::..DegreeRInterval Property
SymbolTypeId Class See Also Send Feedback
Symbol Â°R, indicating unit Rankine interval.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId DegreeRInterval { get; }
Visual Basic
Public Shared ReadOnly Property DegreeRInterval As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DegreeRInterval {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


DeltaDegreeC Property

[image]

Revit 2024 API
SymbolTypeId..::..DeltaDegreeC Property
SymbolTypeId Class See Also Send Feedback
Symbol deltaÂ°C, indicating unit Celsius interval.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId DeltaDegreeC { get; }
Visual Basic
Public Shared ReadOnly Property DeltaDegreeC As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DeltaDegreeC {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


DeltaDegreeR Property

[image]

Revit 2024 API
SymbolTypeId..::..DeltaDegreeR Property
SymbolTypeId Class See Also Send Feedback
Symbol deltaÂ°R, indicating unit Rankine interval.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId DeltaDegreeR { get; }
Visual Basic
Public Shared ReadOnly Property DeltaDegreeR As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DeltaDegreeR {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


DeltaK Property

[image]

Revit 2024 API
SymbolTypeId..::..DeltaK Property
SymbolTypeId Class See Also Send Feedback
Symbol deltaK, indicating unit Kelvin interval.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId DeltaK { get; }
Visual Basic
Public Shared ReadOnly Property DeltaK As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DeltaK {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Dm Property

[image]

Revit 2024 API
SymbolTypeId..::..Dm Property
SymbolTypeId Class See Also Send Feedback
Symbol dm, indicating unit Decimeters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Dm { get; }
Visual Basic
Public Shared ReadOnly Property Dm As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Dm {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


DollarHPerBtu Property

[image]

Revit 2024 API
SymbolTypeId..::..DollarHPerBtu Property
SymbolTypeId Class See Also Send Feedback
Symbol $Â·h/Btu, indicating unit Cost per British thermal unit per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId DollarHPerBtu { get; }
Visual Basic
Public Shared ReadOnly Property DollarHPerBtu As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DollarHPerBtu {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


DollarPerBtu Property

[image]

Revit 2024 API
SymbolTypeId..::..DollarPerBtu Property
SymbolTypeId Class See Also Send Feedback
Symbol $/Btu, indicating unit Cost per British thermal unit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId DollarPerBtu { get; }
Visual Basic
Public Shared ReadOnly Property DollarPerBtu As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DollarPerBtu {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


DollarPerFtSup2 Property

[image]

Revit 2024 API
SymbolTypeId..::..DollarPerFtSup2 Property
SymbolTypeId Class See Also Send Feedback
Symbol $/ftÂ², indicating unit Cost per square foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId DollarPerFtSup2 { get; }
Visual Basic
Public Shared ReadOnly Property DollarPerFtSup2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DollarPerFtSup2 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


DollarPerMSup2 Property

[image]

Revit 2024 API
SymbolTypeId..::..DollarPerMSup2 Property
SymbolTypeId Class See Also Send Feedback
Symbol $/mÂ², indicating unit Cost per square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId DollarPerMSup2 { get; }
Visual Basic
Public Shared ReadOnly Property DollarPerMSup2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DollarPerMSup2 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


DollarPerW Property

[image]

Revit 2024 API
SymbolTypeId..::..DollarPerW Property
SymbolTypeId Class See Also Send Feedback
Symbol $/W, indicating unit Cost per watt.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId DollarPerW { get; }
Visual Basic
Public Shared ReadOnly Property DollarPerW As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DollarPerW {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


EuroPrefix Property

[image]

Revit 2024 API
SymbolTypeId..::..EuroPrefix Property
SymbolTypeId Class See Also Send Feedback
Symbol â‚¬, indicating unit Currency.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId EuroPrefix { get; }
Visual Basic
Public Shared ReadOnly Property EuroPrefix As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ EuroPrefix {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


EuroSuffix Property

[image]

Revit 2024 API
SymbolTypeId..::..EuroSuffix Property
SymbolTypeId Class See Also Send Feedback
Symbol â‚¬, indicating unit Currency.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId EuroSuffix { get; }
Visual Basic
Public Shared ReadOnly Property EuroSuffix As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ EuroSuffix {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Fc Property

[image]

Revit 2024 API
SymbolTypeId..::..Fc Property
SymbolTypeId Class See Also Send Feedback
Symbol fc, indicating unit Footcandles.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Fc { get; }
Visual Basic
Public Shared ReadOnly Property Fc As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Fc {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


FeetOfWaterPer100ft Property

[image]

Revit 2024 API
SymbolTypeId..::..FeetOfWaterPer100ft Property
SymbolTypeId Class See Also Send Feedback
Symbol Feet/100ft, indicating unit Feet of water (39.2 Â°F) per 100 feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId FeetOfWaterPer100ft { get; }
Visual Basic
Public Shared ReadOnly Property FeetOfWaterPer100ft As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FeetOfWaterPer100ft {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


FlLowercase Property

[image]

Revit 2024 API
SymbolTypeId..::..FlLowercase Property
SymbolTypeId Class See Also Send Feedback
Symbol fl, indicating unit Footlamberts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId FlLowercase { get; }
Visual Basic
Public Shared ReadOnly Property FlLowercase As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FlLowercase {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


FootSingleQuote Property

[image]

Revit 2024 API
SymbolTypeId..::..FootSingleQuote Property
SymbolTypeId Class See Also Send Feedback
Symbol ', indicating unit Feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId FootSingleQuote { get; }
Visual Basic
Public Shared ReadOnly Property FootSingleQuote As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FootSingleQuote {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Fps Property

[image]

Revit 2024 API
SymbolTypeId..::..Fps Property
SymbolTypeId Class See Also Send Feedback
Symbol FPS, indicating unit Feet per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Fps { get; }
Visual Basic
Public Shared ReadOnly Property Fps As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Fps {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Ft Property

[image]

Revit 2024 API
SymbolTypeId..::..Ft Property
SymbolTypeId Class See Also Send Feedback
Symbol ft, indicating unit Feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Ft { get; }
Visual Basic
Public Shared ReadOnly Property Ft As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Ft {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Ftc Property

[image]

Revit 2024 API
SymbolTypeId..::..Ftc Property
SymbolTypeId Class See Also Send Feedback
Symbol Ftc, indicating unit Footcandles.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Ftc { get; }
Visual Basic
Public Shared ReadOnly Property Ftc As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Ftc {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


FtCaret2 Property

[image]

Revit 2024 API
SymbolTypeId..::..FtCaret2 Property
SymbolTypeId Class See Also Send Feedback
Symbol ft^2, indicating unit Square feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId FtCaret2 { get; }
Visual Basic
Public Shared ReadOnly Property FtCaret2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FtCaret2 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


FtCaret3 Property

[image]

Revit 2024 API
SymbolTypeId..::..FtCaret3 Property
SymbolTypeId Class See Also Send Feedback
Symbol ft^3, indicating unit Cubic feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId FtCaret3 { get; }
Visual Basic
Public Shared ReadOnly Property FtCaret3 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FtCaret3 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


FtH2O Property

[image]

Revit 2024 API
SymbolTypeId..::..FtH2O Property
SymbolTypeId Class See Also Send Feedback
Symbol ftH2O, indicating unit Feet of water (39.2 Â°F).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId FtH2O { get; }
Visual Basic
Public Shared ReadOnly Property FtH2O As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FtH2O {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


FtH2OPer100ft Property

[image]

Revit 2024 API
SymbolTypeId..::..FtH2OPer100ft Property
SymbolTypeId Class See Also Send Feedback
Symbol ftH2O/100ft, indicating unit Feet of water (39.2 Â°F) per 100 feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId FtH2OPer100ft { get; }
Visual Basic
Public Shared ReadOnly Property FtH2OPer100ft As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FtH2OPer100ft {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


FtL Property

[image]

Revit 2024 API
SymbolTypeId..::..FtL Property
SymbolTypeId Class See Also Send Feedback
Symbol ftL, indicating unit Footlamberts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId FtL { get; }
Visual Basic
Public Shared ReadOnly Property FtL As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FtL {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


FtOfWater Property

[image]

Revit 2024 API
SymbolTypeId..::..FtOfWater Property
SymbolTypeId Class See Also Send Feedback
Symbol FT, indicating unit Feet of water (39.2 Â°F).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId FtOfWater { get; }
Visual Basic
Public Shared ReadOnly Property FtOfWater As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FtOfWater {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


FtOfWaterPer100ft Property

[image]

Revit 2024 API
SymbolTypeId..::..FtOfWaterPer100ft Property
SymbolTypeId Class See Also Send Feedback
Symbol FT/100ft, indicating unit Feet of water (39.2 Â°F) per 100 feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId FtOfWaterPer100ft { get; }
Visual Basic
Public Shared ReadOnly Property FtOfWaterPer100ft As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FtOfWaterPer100ft {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


FtPerKip Property

[image]

Revit 2024 API
SymbolTypeId..::..FtPerKip Property
SymbolTypeId Class See Also Send Feedback
Symbol ft/kip, indicating unit Feet per kip.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId FtPerKip { get; }
Visual Basic
Public Shared ReadOnly Property FtPerKip As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FtPerKip {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


FtPerMin Property

[image]

Revit 2024 API
SymbolTypeId..::..FtPerMin Property
SymbolTypeId Class See Also Send Feedback
Symbol ft/min, indicating unit Feet per minute.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId FtPerMin { get; }
Visual Basic
Public Shared ReadOnly Property FtPerMin As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FtPerMin {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


FtSup2 Property

[image]

Revit 2024 API
SymbolTypeId..::..FtSup2 Property
SymbolTypeId Class See Also Send Feedback
Symbol ftÂ², indicating unit Square feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId FtSup2 { get; }
Visual Basic
Public Shared ReadOnly Property FtSup2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FtSup2 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


FtSup2HPerKbtu Property

[image]

Revit 2024 API
SymbolTypeId..::..FtSup2HPerKbtu Property
SymbolTypeId Class See Also Send Feedback
Symbol ftÂ²Â·h/kBtu, indicating unit Square feet per thousand British thermal units per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId FtSup2HPerKbtu { get; }
Visual Basic
Public Shared ReadOnly Property FtSup2HPerKbtu As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FtSup2HPerKbtu {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


FtSup2PerMbh Property

[image]

Revit 2024 API
SymbolTypeId..::..FtSup2PerMbh Property
SymbolTypeId Class See Also Send Feedback
Symbol ftÂ²/MBh, indicating unit Square feet per thousand British thermal units per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId FtSup2PerMbh { get; }
Visual Basic
Public Shared ReadOnly Property FtSup2PerMbh As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FtSup2PerMbh {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


FtSup2PerS Property

[image]

Revit 2024 API
SymbolTypeId..::..FtSup2PerS Property
SymbolTypeId Class See Also Send Feedback
Symbol ftÂ²/s, indicating unit Square feet per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId FtSup2PerS { get; }
Visual Basic
Public Shared ReadOnly Property FtSup2PerS As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FtSup2PerS {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


FtSup2PerTon Property

[image]

Revit 2024 API
SymbolTypeId..::..FtSup2PerTon Property
SymbolTypeId Class See Also Send Feedback
Symbol ftÂ²/ton, indicating unit Square feet per ton of refrigeration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId FtSup2PerTon { get; }
Visual Basic
Public Shared ReadOnly Property FtSup2PerTon As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FtSup2PerTon {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


FtSup3HPerMinBtu Property

[image]

Revit 2024 API
SymbolTypeId..::..FtSup3HPerMinBtu Property
SymbolTypeId Class See Also Send Feedback
Symbol ftÂ³Â·h/(minÂ·Btu), indicating unit Cubic feet per minute per British thermal unit per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId FtSup3HPerMinBtu { get; }
Visual Basic
Public Shared ReadOnly Property FtSup3HPerMinBtu As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FtSup3HPerMinBtu {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


FtSup3PerH Property

[image]

Revit 2024 API
SymbolTypeId..::..FtSup3PerH Property
SymbolTypeId Class See Also Send Feedback
Symbol ftÂ³/h, indicating unit Cubic feet per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId FtSup3PerH { get; }
Visual Basic
Public Shared ReadOnly Property FtSup3PerH As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FtSup3PerH {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


FtSup3PerLbMass Property

[image]

Revit 2024 API
SymbolTypeId..::..FtSup3PerLbMass Property
SymbolTypeId Class See Also Send Feedback
Symbol ftÂ³/lb, indicating unit Cubic feet per pound mass.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId FtSup3PerLbMass { get; }
Visual Basic
Public Shared ReadOnly Property FtSup3PerLbMass As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FtSup3PerLbMass {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


FtSup3PerMin Property

[image]

Revit 2024 API
SymbolTypeId..::..FtSup3PerMin Property
SymbolTypeId Class See Also Send Feedback
Symbol ftÂ³/min, indicating unit Cubic feet per minute.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId FtSup3PerMin { get; }
Visual Basic
Public Shared ReadOnly Property FtSup3PerMin As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FtSup3PerMin {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


FtSup4 Property

[image]

Revit 2024 API
SymbolTypeId..::..FtSup4 Property
SymbolTypeId Class See Also Send Feedback
Symbol ftâ´, indicating unit Feet to the fourth power.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId FtSup4 { get; }
Visual Basic
Public Shared ReadOnly Property FtSup4 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FtSup4 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


FtSup6 Property

[image]

Revit 2024 API
SymbolTypeId..::..FtSup6 Property
SymbolTypeId Class See Also Send Feedback
Symbol ftâ¶, indicating unit Feet to the sixth power.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId FtSup6 { get; }
Visual Basic
Public Shared ReadOnly Property FtSup6 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FtSup6 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Gal Property

[image]

Revit 2024 API
SymbolTypeId..::..Gal Property
SymbolTypeId Class See Also Send Feedback
Symbol gal, indicating unit US gallons.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Gal { get; }
Visual Basic
Public Shared ReadOnly Property Gal As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Gal {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


GalPerH Property

[image]

Revit 2024 API
SymbolTypeId..::..GalPerH Property
SymbolTypeId Class See Also Send Feedback
Symbol gal/h, indicating unit US gallons per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId GalPerH { get; }
Visual Basic
Public Shared ReadOnly Property GalPerH As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ GalPerH {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


GalPerMin Property

[image]

Revit 2024 API
SymbolTypeId..::..GalPerMin Property
SymbolTypeId Class See Also Send Feedback
Symbol gal/min, indicating unit US gallons per minute.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId GalPerMin { get; }
Visual Basic
Public Shared ReadOnly Property GalPerMin As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ GalPerMin {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Gpm Property

[image]

Revit 2024 API
SymbolTypeId..::..Gpm Property
SymbolTypeId Class See Also Send Feedback
Symbol GPM, indicating unit US gallons per minute.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Gpm { get; }
Visual Basic
Public Shared ReadOnly Property Gpm As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Gpm {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


GrPerHFtSup2InHg Property

[image]

Revit 2024 API
SymbolTypeId..::..GrPerHFtSup2InHg Property
SymbolTypeId Class See Also Send Feedback
Symbol gr/(hÂ·ftÂ²Â·inHg), indicating unit Grains per hour square foot inch mercury.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId GrPerHFtSup2InHg { get; }
Visual Basic
Public Shared ReadOnly Property GrPerHFtSup2InHg As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ GrPerHFtSup2InHg {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Hectare Property

[image]

Revit 2024 API
SymbolTypeId..::..Hectare Property
SymbolTypeId Class See Also Send Feedback
Symbol hectare, indicating unit Hectares.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Hectare { get; }
Visual Basic
Public Shared ReadOnly Property Hectare As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Hectare {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


HFtSup2DegreeFPerBtu Property

[image]

Revit 2024 API
SymbolTypeId..::..HFtSup2DegreeFPerBtu Property
SymbolTypeId Class See Also Send Feedback
Symbol (hÂ·ftÂ²Â·Â°F)/BTU, indicating unit Hour square foot degrees Fahrenheit per British thermal unit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId HFtSup2DegreeFPerBtu { get; }
Visual Basic
Public Shared ReadOnly Property HFtSup2DegreeFPerBtu As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ HFtSup2DegreeFPerBtu {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Hour Property

[image]

Revit 2024 API
SymbolTypeId..::..Hour Property
SymbolTypeId Class See Also Send Feedback
Symbol h, indicating unit Hours.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Hour { get; }
Visual Basic
Public Shared ReadOnly Property Hour As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Hour {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Hp Property

[image]

Revit 2024 API
SymbolTypeId..::..Hp Property
SymbolTypeId Class See Also Send Feedback
Symbol hp, indicating unit Horsepower.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Hp { get; }
Visual Basic
Public Shared ReadOnly Property Hp As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Hp {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Hz Property

[image]

Revit 2024 API
SymbolTypeId..::..Hz Property
SymbolTypeId Class See Also Send Feedback
Symbol Hz, indicating unit Hertz.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Hz { get; }
Visual Basic
Public Shared ReadOnly Property Hz As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Hz {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


In Property

[image]

Revit 2024 API
SymbolTypeId..::..In Property
SymbolTypeId Class See Also Send Feedback
Symbol in, indicating unit Inches.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId In { get; }
Visual Basic
Public Shared ReadOnly Property In As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ In {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


InCaret2 Property

[image]

Revit 2024 API
SymbolTypeId..::..InCaret2 Property
SymbolTypeId Class See Also Send Feedback
Symbol in^2, indicating unit Square inches.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId InCaret2 { get; }
Visual Basic
Public Shared ReadOnly Property InCaret2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ InCaret2 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


InCaret3 Property

[image]

Revit 2024 API
SymbolTypeId..::..InCaret3 Property
SymbolTypeId Class See Also Send Feedback
Symbol in^3, indicating unit Cubic inches.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId InCaret3 { get; }
Visual Basic
Public Shared ReadOnly Property InCaret3 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ InCaret3 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


InchDoubleQuote Property

[image]

Revit 2024 API
SymbolTypeId..::..InchDoubleQuote Property
SymbolTypeId Class See Also Send Feedback
Symbol ", indicating unit Inches.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId InchDoubleQuote { get; }
Visual Basic
Public Shared ReadOnly Property InchDoubleQuote As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ InchDoubleQuote {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


InDashWg Property

[image]

Revit 2024 API
SymbolTypeId..::..InDashWg Property
SymbolTypeId Class See Also Send Feedback
Symbol in-wg, indicating unit Inches of water (60 Â°F).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId InDashWg { get; }
Visual Basic
Public Shared ReadOnly Property InDashWg As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ InDashWg {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


InDashWgPer100ft Property

[image]

Revit 2024 API
SymbolTypeId..::..InDashWgPer100ft Property
SymbolTypeId Class See Also Send Feedback
Symbol in-wg/100ft, indicating unit Inches of water (60 Â°F) per 100 feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId InDashWgPer100ft { get; }
Visual Basic
Public Shared ReadOnly Property InDashWgPer100ft As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ InDashWgPer100ft {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


InHg Property

[image]

Revit 2024 API
SymbolTypeId..::..InHg Property
SymbolTypeId Class See Also Send Feedback
Symbol inHg, indicating unit Inches of mercury (32 Â°F).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId InHg { get; }
Visual Basic
Public Shared ReadOnly Property InHg As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ InHg {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


InSup2PerFt Property

[image]

Revit 2024 API
SymbolTypeId..::..InSup2PerFt Property
SymbolTypeId Class See Also Send Feedback
Symbol inÂ²/ft, indicating unit Square inches per foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId InSup2PerFt { get; }
Visual Basic
Public Shared ReadOnly Property InSup2PerFt As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ InSup2PerFt {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


InSup3 Property

[image]

Revit 2024 API
SymbolTypeId..::..InSup3 Property
SymbolTypeId Class See Also Send Feedback
Symbol inÂ³, indicating unit Cubic inches.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId InSup3 { get; }
Visual Basic
Public Shared ReadOnly Property InSup3 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ InSup3 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


InSup4 Property

[image]

Revit 2024 API
SymbolTypeId..::..InSup4 Property
SymbolTypeId Class See Also Send Feedback
Symbol inâ´, indicating unit Inches to the fourth power.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId InSup4 { get; }
Visual Basic
Public Shared ReadOnly Property InSup4 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ InSup4 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


InvDegreeC Property

[image]

Revit 2024 API
SymbolTypeId..::..InvDegreeC Property
SymbolTypeId Class See Also Send Feedback
Symbol 1/Â°C, indicating unit Inverse degrees Celsius.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId InvDegreeC { get; }
Visual Basic
Public Shared ReadOnly Property InvDegreeC As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ InvDegreeC {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


InvDegreeF Property

[image]

Revit 2024 API
SymbolTypeId..::..InvDegreeF Property
SymbolTypeId Class See Also Send Feedback
Symbol 1/Â°F, indicating unit Inverse degrees Fahrenheit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId InvDegreeF { get; }
Visual Basic
Public Shared ReadOnly Property InvDegreeF As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ InvDegreeF {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


InvKip Property

[image]

Revit 2024 API
SymbolTypeId..::..InvKip Property
SymbolTypeId Class See Also Send Feedback
Symbol 1/kip, indicating unit Inverse kips.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId InvKip { get; }
Visual Basic
Public Shared ReadOnly Property InvKip As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ InvKip {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


InvKN Property

[image]

Revit 2024 API
SymbolTypeId..::..InvKN Property
SymbolTypeId Class See Also Send Feedback
Symbol 1/kN, indicating unit Inverse kilonewtons.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId InvKN { get; }
Visual Basic
Public Shared ReadOnly Property InvKN As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ InvKN {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Joule Property

[image]

Revit 2024 API
SymbolTypeId..::..Joule Property
SymbolTypeId Class See Also Send Feedback
Symbol J, indicating unit Joules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Joule { get; }
Visual Basic
Public Shared ReadOnly Property Joule As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Joule {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


JPerG Property

[image]

Revit 2024 API
SymbolTypeId..::..JPerG Property
SymbolTypeId Class See Also Send Feedback
Symbol J/g, indicating unit Joules per gram.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId JPerG { get; }
Visual Basic
Public Shared ReadOnly Property JPerG As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ JPerG {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


JPerGDegreeC Property

[image]

Revit 2024 API
SymbolTypeId..::..JPerGDegreeC Property
SymbolTypeId Class See Also Send Feedback
Symbol J/(gÂ·Â°C), indicating unit Joules per gram degree Celsius.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId JPerGDegreeC { get; }
Visual Basic
Public Shared ReadOnly Property JPerGDegreeC As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ JPerGDegreeC {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


JPerK Property

[image]

Revit 2024 API
SymbolTypeId..::..JPerK Property
SymbolTypeId Class See Also Send Feedback
Symbol J/K, indicating unit Joules per Kelvin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId JPerK { get; }
Visual Basic
Public Shared ReadOnly Property JPerK As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ JPerK {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


JPerMSup2K Property

[image]

Revit 2024 API
SymbolTypeId..::..JPerMSup2K Property
SymbolTypeId Class See Also Send Feedback
Symbol J/(mÂ²Â·K), indicating unit Joules per square meter Kelvin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId JPerMSup2K { get; }
Visual Basic
Public Shared ReadOnly Property JPerMSup2K As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ JPerMSup2K {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Kcal Property

[image]

Revit 2024 API
SymbolTypeId..::..Kcal Property
SymbolTypeId Class See Also Send Feedback
Symbol kcal, indicating unit Kilocalories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Kcal { get; }
Visual Basic
Public Shared ReadOnly Property Kcal As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Kcal {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


KcalPerS Property

[image]

Revit 2024 API
SymbolTypeId..::..KcalPerS Property
SymbolTypeId Class See Also Send Feedback
Symbol kcal/s, indicating unit Kilocalories per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KcalPerS { get; }
Visual Basic
Public Shared ReadOnly Property KcalPerS As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KcalPerS {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Kelvin Property

[image]

Revit 2024 API
SymbolTypeId..::..Kelvin Property
SymbolTypeId Class See Also Send Feedback
Symbol K, indicating unit Kelvin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Kelvin { get; }
Visual Basic
Public Shared ReadOnly Property Kelvin As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Kelvin {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Kg Property

[image]

Revit 2024 API
SymbolTypeId..::..Kg Property
SymbolTypeId Class See Also Send Feedback
Symbol kg, indicating unit Kilograms.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Kg { get; }
Visual Basic
Public Shared ReadOnly Property Kg As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Kg {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Kgf Property

[image]

Revit 2024 API
SymbolTypeId..::..Kgf Property
SymbolTypeId Class See Also Send Feedback
Symbol kgf, indicating unit Kilograms force.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Kgf { get; }
Visual Basic
Public Shared ReadOnly Property Kgf As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Kgf {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


KgfDashM Property

[image]

Revit 2024 API
SymbolTypeId..::..KgfDashM Property
SymbolTypeId Class See Also Send Feedback
Symbol kgf-m, indicating unit Kilogram force meters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KgfDashM { get; }
Visual Basic
Public Shared ReadOnly Property KgfDashM As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KgfDashM {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


KgfDashMPerM Property

[image]

Revit 2024 API
SymbolTypeId..::..KgfDashMPerM Property
SymbolTypeId Class See Also Send Feedback
Symbol kgf-m/m, indicating unit Kilogram force meters per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KgfDashMPerM { get; }
Visual Basic
Public Shared ReadOnly Property KgfDashMPerM As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KgfDashMPerM {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


KgfPerM Property

[image]

Revit 2024 API
SymbolTypeId..::..KgfPerM Property
SymbolTypeId Class See Also Send Feedback
Symbol kgf/m, indicating unit Kilograms force per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KgfPerM { get; }
Visual Basic
Public Shared ReadOnly Property KgfPerM As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KgfPerM {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


KgfPerMSup2 Property

[image]

Revit 2024 API
SymbolTypeId..::..KgfPerMSup2 Property
SymbolTypeId Class See Also Send Feedback
Symbol kgf/mÂ², indicating unit Kilograms force per square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KgfPerMSup2 { get; }
Visual Basic
Public Shared ReadOnly Property KgfPerMSup2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KgfPerMSup2 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


KgPerH Property

[image]

Revit 2024 API
SymbolTypeId..::..KgPerH Property
SymbolTypeId Class See Also Send Feedback
Symbol kg/h, indicating unit Kilograms per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KgPerH { get; }
Visual Basic
Public Shared ReadOnly Property KgPerH As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KgPerH {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


KgPerKgK Property

[image]

Revit 2024 API
SymbolTypeId..::..KgPerKgK Property
SymbolTypeId Class See Also Send Feedback
Symbol kg/(kgÂ·K), indicating unit Kilograms per kilogram kelvin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KgPerKgK { get; }
Visual Basic
Public Shared ReadOnly Property KgPerKgK As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KgPerKgK {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


KgPerM Property

[image]

Revit 2024 API
SymbolTypeId..::..KgPerM Property
SymbolTypeId Class See Also Send Feedback
Symbol kg/m, indicating unit Kilograms per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KgPerM { get; }
Visual Basic
Public Shared ReadOnly Property KgPerM As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KgPerM {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


KgPerMin Property

[image]

Revit 2024 API
SymbolTypeId..::..KgPerMin Property
SymbolTypeId Class See Also Send Feedback
Symbol kg/min, indicating unit Kilograms per minute.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KgPerMin { get; }
Visual Basic
Public Shared ReadOnly Property KgPerMin As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KgPerMin {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


KgPerMS Property

[image]

Revit 2024 API
SymbolTypeId..::..KgPerMS Property
SymbolTypeId Class See Also Send Feedback
Symbol kg/(mÂ·s), indicating unit Kilograms per meter second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KgPerMS { get; }
Visual Basic
Public Shared ReadOnly Property KgPerMS As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KgPerMS {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


KgPerMSup2 Property

[image]

Revit 2024 API
SymbolTypeId..::..KgPerMSup2 Property
SymbolTypeId Class See Also Send Feedback
Symbol kg/mÂ², indicating unit Kilograms per square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KgPerMSup2 { get; }
Visual Basic
Public Shared ReadOnly Property KgPerMSup2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KgPerMSup2 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


KgPerMSup3 Property

[image]

Revit 2024 API
SymbolTypeId..::..KgPerMSup3 Property
SymbolTypeId Class See Also Send Feedback
Symbol kg/mÂ³, indicating unit Kilograms per cubic meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KgPerMSup3 { get; }
Visual Basic
Public Shared ReadOnly Property KgPerMSup3 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KgPerMSup3 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Kip Property

[image]

Revit 2024 API
SymbolTypeId..::..Kip Property
SymbolTypeId Class See Also Send Feedback
Symbol kip, indicating unit Kips.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Kip { get; }
Visual Basic
Public Shared ReadOnly Property Kip As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Kip {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


KipDashFt Property

[image]

Revit 2024 API
SymbolTypeId..::..KipDashFt Property
SymbolTypeId Class See Also Send Feedback
Symbol kip-ft, indicating unit Kip feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KipDashFt { get; }
Visual Basic
Public Shared ReadOnly Property KipDashFt As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KipDashFt {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


KipDashFtPerDegree Property

[image]

Revit 2024 API
SymbolTypeId..::..KipDashFtPerDegree Property
SymbolTypeId Class See Also Send Feedback
Symbol kip-ft/Â°, indicating unit Kip feet per degree.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KipDashFtPerDegree { get; }
Visual Basic
Public Shared ReadOnly Property KipDashFtPerDegree As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KipDashFtPerDegree {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


KipPerFt Property

[image]

Revit 2024 API
SymbolTypeId..::..KipPerFt Property
SymbolTypeId Class See Also Send Feedback
Symbol kip/ft, indicating unit Kips per foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KipPerFt { get; }
Visual Basic
Public Shared ReadOnly Property KipPerFt As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KipPerFt {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


KipPerFtSup2 Property

[image]

Revit 2024 API
SymbolTypeId..::..KipPerFtSup2 Property
SymbolTypeId Class See Also Send Feedback
Symbol kip/ftÂ², indicating unit Kips per square foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KipPerFtSup2 { get; }
Visual Basic
Public Shared ReadOnly Property KipPerFtSup2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KipPerFtSup2 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


KipPerFtSup3 Property

[image]

Revit 2024 API
SymbolTypeId..::..KipPerFtSup3 Property
SymbolTypeId Class See Also Send Feedback
Symbol kip/ftÂ³, indicating unit Kips per cubic foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KipPerFtSup3 { get; }
Visual Basic
Public Shared ReadOnly Property KipPerFtSup3 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KipPerFtSup3 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


KipPerIn Property

[image]

Revit 2024 API
SymbolTypeId..::..KipPerIn Property
SymbolTypeId Class See Also Send Feedback
Symbol kip/in, indicating unit Kips per inch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KipPerIn { get; }
Visual Basic
Public Shared ReadOnly Property KipPerIn As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KipPerIn {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


KipPerInSup2 Property

[image]

Revit 2024 API
SymbolTypeId..::..KipPerInSup2 Property
SymbolTypeId Class See Also Send Feedback
Symbol kip/inÂ², indicating unit Kips per square inch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KipPerInSup2 { get; }
Visual Basic
Public Shared ReadOnly Property KipPerInSup2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KipPerInSup2 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


KJ Property

[image]

Revit 2024 API
SymbolTypeId..::..KJ Property
SymbolTypeId Class See Also Send Feedback
Symbol kJ, indicating unit Kilojoules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KJ { get; }
Visual Basic
Public Shared ReadOnly Property KJ As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KJ {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


KJPerK Property

[image]

Revit 2024 API
SymbolTypeId..::..KJPerK Property
SymbolTypeId Class See Also Send Feedback
Symbol kJ/K, indicating unit Kilojoules per Kelvin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KJPerK { get; }
Visual Basic
Public Shared ReadOnly Property KJPerK As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KJPerK {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


KJPerMSup2K Property

[image]

Revit 2024 API
SymbolTypeId..::..KJPerMSup2K Property
SymbolTypeId Class See Also Send Feedback
Symbol kJ/(mÂ²Â·K), indicating unit Kilojoules per square meter Kelvin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KJPerMSup2K { get; }
Visual Basic
Public Shared ReadOnly Property KJPerMSup2K As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KJPerMSup2K {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


KmPerH Property

[image]

Revit 2024 API
SymbolTypeId..::..KmPerH Property
SymbolTypeId Class See Also Send Feedback
Symbol km/h, indicating unit Kilometers per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KmPerH { get; }
Visual Basic
Public Shared ReadOnly Property KmPerH As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KmPerH {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


KmPerSSup2 Property

[image]

Revit 2024 API
SymbolTypeId..::..KmPerSSup2 Property
SymbolTypeId Class See Also Send Feedback
Symbol km/sÂ², indicating unit Kilometers per second squared.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KmPerSSup2 { get; }
Visual Basic
Public Shared ReadOnly Property KmPerSSup2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KmPerSSup2 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


KN Property

[image]

Revit 2024 API
SymbolTypeId..::..KN Property
SymbolTypeId Class See Also Send Feedback
Symbol kN, indicating unit Kilonewtons.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KN { get; }
Visual Basic
Public Shared ReadOnly Property KN As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KN {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


KNDashM Property

[image]

Revit 2024 API
SymbolTypeId..::..KNDashM Property
SymbolTypeId Class See Also Send Feedback
Symbol kN-m, indicating unit Kilonewton meters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KNDashM { get; }
Visual Basic
Public Shared ReadOnly Property KNDashM As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KNDashM {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


KNDashMPerDegree Property

[image]

Revit 2024 API
SymbolTypeId..::..KNDashMPerDegree Property
SymbolTypeId Class See Also Send Feedback
Symbol kN-m/Â°, indicating unit Kilonewton meters per degree.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KNDashMPerDegree { get; }
Visual Basic
Public Shared ReadOnly Property KNDashMPerDegree As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KNDashMPerDegree {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


KNDashMPerDegreePerM Property

[image]

Revit 2024 API
SymbolTypeId..::..KNDashMPerDegreePerM Property
SymbolTypeId Class See Also Send Feedback
Symbol kN-m/Â°/m, indicating unit Kilonewton meters per degree per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KNDashMPerDegreePerM { get; }
Visual Basic
Public Shared ReadOnly Property KNDashMPerDegreePerM As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KNDashMPerDegreePerM {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


KNPerMmSup2 Property

[image]

Revit 2024 API
SymbolTypeId..::..KNPerMmSup2 Property
SymbolTypeId Class See Also Send Feedback
Symbol kN/mmÂ², indicating unit Kilonewtons per square millimeter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KNPerMmSup2 { get; }
Visual Basic
Public Shared ReadOnly Property KNPerMmSup2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KNPerMmSup2 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


KNPerMSup3 Property

[image]

Revit 2024 API
SymbolTypeId..::..KNPerMSup3 Property
SymbolTypeId Class See Also Send Feedback
Symbol kN/mÂ³, indicating unit Kilonewtons per cubic meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KNPerMSup3 { get; }
Visual Basic
Public Shared ReadOnly Property KNPerMSup3 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KNPerMSup3 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


KPa Property

[image]

Revit 2024 API
SymbolTypeId..::..KPa Property
SymbolTypeId Class See Also Send Feedback
Symbol kPa, indicating unit Kilopascals.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KPa { get; }
Visual Basic
Public Shared ReadOnly Property KPa As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KPa {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Ksf Property

[image]

Revit 2024 API
SymbolTypeId..::..Ksf Property
SymbolTypeId Class See Also Send Feedback
Symbol ksf, indicating unit Kips per square foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Ksf { get; }
Visual Basic
Public Shared ReadOnly Property Ksf As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Ksf {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Ksi Property

[image]

Revit 2024 API
SymbolTypeId..::..Ksi Property
SymbolTypeId Class See Also Send Feedback
Symbol ksi, indicating unit Kips per square inch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Ksi { get; }
Visual Basic
Public Shared ReadOnly Property Ksi As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Ksi {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


KV Property

[image]

Revit 2024 API
SymbolTypeId..::..KV Property
SymbolTypeId Class See Also Send Feedback
Symbol kV, indicating unit Kilovolts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KV { get; }
Visual Basic
Public Shared ReadOnly Property KV As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KV {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


KVA Property

[image]

Revit 2024 API
SymbolTypeId..::..KVA Property
SymbolTypeId Class See Also Send Feedback
Symbol kVA, indicating unit Kilovolt amperes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KVA { get; }
Visual Basic
Public Shared ReadOnly Property KVA As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KVA {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


KW Property

[image]

Revit 2024 API
SymbolTypeId..::..KW Property
SymbolTypeId Class See Also Send Feedback
Symbol kW, indicating unit Kilowatts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KW { get; }
Visual Basic
Public Shared ReadOnly Property KW As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KW {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Lbf Property

[image]

Revit 2024 API
SymbolTypeId..::..Lbf Property
SymbolTypeId Class See Also Send Feedback
Symbol lbf, indicating unit Pounds force.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Lbf { get; }
Visual Basic
Public Shared ReadOnly Property Lbf As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Lbf {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


LbfDashFt Property

[image]

Revit 2024 API
SymbolTypeId..::..LbfDashFt Property
SymbolTypeId Class See Also Send Feedback
Symbol lbf-ft, indicating unit Pound force feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId LbfDashFt { get; }
Visual Basic
Public Shared ReadOnly Property LbfDashFt As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LbfDashFt {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


LbfDashFtPerFt Property

[image]

Revit 2024 API
SymbolTypeId..::..LbfDashFtPerFt Property
SymbolTypeId Class See Also Send Feedback
Symbol lbf-ft/ft, indicating unit Pound force feet per foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId LbfDashFtPerFt { get; }
Visual Basic
Public Shared ReadOnly Property LbfDashFtPerFt As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LbfDashFtPerFt {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


LbForceDashFt Property

[image]

Revit 2024 API
SymbolTypeId..::..LbForceDashFt Property
SymbolTypeId Class See Also Send Feedback
Symbol lb-ft, indicating unit Pound force feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId LbForceDashFt { get; }
Visual Basic
Public Shared ReadOnly Property LbForceDashFt As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LbForceDashFt {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


LbForceDashFtPerFt Property

[image]

Revit 2024 API
SymbolTypeId..::..LbForceDashFtPerFt Property
SymbolTypeId Class See Also Send Feedback
Symbol lb-ft/ft, indicating unit Pound force feet per foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId LbForceDashFtPerFt { get; }
Visual Basic
Public Shared ReadOnly Property LbForceDashFtPerFt As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LbForceDashFtPerFt {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


LbForcePerFt Property

[image]

Revit 2024 API
SymbolTypeId..::..LbForcePerFt Property
SymbolTypeId Class See Also Send Feedback
Symbol lb/ft, indicating unit Pounds force per foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId LbForcePerFt { get; }
Visual Basic
Public Shared ReadOnly Property LbForcePerFt As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LbForcePerFt {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


LbForcePerFtSup2 Property

[image]

Revit 2024 API
SymbolTypeId..::..LbForcePerFtSup2 Property
SymbolTypeId Class See Also Send Feedback
Symbol lb/ftÂ², indicating unit Pounds force per square foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId LbForcePerFtSup2 { get; }
Visual Basic
Public Shared ReadOnly Property LbForcePerFtSup2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LbForcePerFtSup2 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


LbForcePerFtSup3 Property

[image]

Revit 2024 API
SymbolTypeId..::..LbForcePerFtSup3 Property
SymbolTypeId Class See Also Send Feedback
Symbol lb/ftÂ³, indicating unit Pounds force per cubic foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId LbForcePerFtSup3 { get; }
Visual Basic
Public Shared ReadOnly Property LbForcePerFtSup3 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LbForcePerFtSup3 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


LbForcePerInSup2 Property

[image]

Revit 2024 API
SymbolTypeId..::..LbForcePerInSup2 Property
SymbolTypeId Class See Also Send Feedback
Symbol lb/inÂ², indicating unit Pounds force per square inch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId LbForcePerInSup2 { get; }
Visual Basic
Public Shared ReadOnly Property LbForcePerInSup2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LbForcePerInSup2 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


LbForceSPerFtSup2 Property

[image]

Revit 2024 API
SymbolTypeId..::..LbForceSPerFtSup2 Property
SymbolTypeId Class See Also Send Feedback
Symbol lbÂ·s/ftÂ², indicating unit Pound force seconds per square foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId LbForceSPerFtSup2 { get; }
Visual Basic
Public Shared ReadOnly Property LbForceSPerFtSup2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LbForceSPerFtSup2 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


LbfPerFtSup2 Property

[image]

Revit 2024 API
SymbolTypeId..::..LbfPerFtSup2 Property
SymbolTypeId Class See Also Send Feedback
Symbol lbf/ftÂ², indicating unit Pounds force per square foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId LbfPerFtSup2 { get; }
Visual Basic
Public Shared ReadOnly Property LbfPerFtSup2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LbfPerFtSup2 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


LbfPerFtSup3 Property

[image]

Revit 2024 API
SymbolTypeId..::..LbfPerFtSup3 Property
SymbolTypeId Class See Also Send Feedback
Symbol lbf/ftÂ³, indicating unit Pounds force per cubic foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId LbfPerFtSup3 { get; }
Visual Basic
Public Shared ReadOnly Property LbfPerFtSup3 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LbfPerFtSup3 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


LbfPerInSup2 Property

[image]

Revit 2024 API
SymbolTypeId..::..LbfPerInSup2 Property
SymbolTypeId Class See Also Send Feedback
Symbol lbf/inÂ², indicating unit Pounds force per square inch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId LbfPerInSup2 { get; }
Visual Basic
Public Shared ReadOnly Property LbfPerInSup2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LbfPerInSup2 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


LbMass Property

[image]

Revit 2024 API
SymbolTypeId..::..LbMass Property
SymbolTypeId Class See Also Send Feedback
Symbol lb, indicating unit Pounds mass.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId LbMass { get; }
Visual Basic
Public Shared ReadOnly Property LbMass As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LbMass {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


LbMassPerFt Property

[image]

Revit 2024 API
SymbolTypeId..::..LbMassPerFt Property
SymbolTypeId Class See Also Send Feedback
Symbol lb/ft, indicating unit Pounds mass per foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId LbMassPerFt { get; }
Visual Basic
Public Shared ReadOnly Property LbMassPerFt As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LbMassPerFt {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


LbMassPerFtDashH Property

[image]

Revit 2024 API
SymbolTypeId..::..LbMassPerFtDashH Property
SymbolTypeId Class See Also Send Feedback
Symbol lb/ft-h, indicating unit Pounds mass per foot hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId LbMassPerFtDashH { get; }
Visual Basic
Public Shared ReadOnly Property LbMassPerFtDashH As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LbMassPerFtDashH {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


LbMassPerFtDashS Property

[image]

Revit 2024 API
SymbolTypeId..::..LbMassPerFtDashS Property
SymbolTypeId Class See Also Send Feedback
Symbol lb/ft-s, indicating unit Pounds mass per foot second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId LbMassPerFtDashS { get; }
Visual Basic
Public Shared ReadOnly Property LbMassPerFtDashS As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LbMassPerFtDashS {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


LbMassPerFtSup2 Property

[image]

Revit 2024 API
SymbolTypeId..::..LbMassPerFtSup2 Property
SymbolTypeId Class See Also Send Feedback
Symbol lb/ftÂ², indicating unit Pounds mass per square foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId LbMassPerFtSup2 { get; }
Visual Basic
Public Shared ReadOnly Property LbMassPerFtSup2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LbMassPerFtSup2 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


LbMassPerFtSup3 Property

[image]

Revit 2024 API
SymbolTypeId..::..LbMassPerFtSup3 Property
SymbolTypeId Class See Also Send Feedback
Symbol lb/ftÂ³, indicating unit Pounds mass per cubic foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId LbMassPerFtSup3 { get; }
Visual Basic
Public Shared ReadOnly Property LbMassPerFtSup3 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LbMassPerFtSup3 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


LbMassPerInSup3 Property

[image]

Revit 2024 API
SymbolTypeId..::..LbMassPerInSup3 Property
SymbolTypeId Class See Also Send Feedback
Symbol lb/inÂ³, indicating unit Pounds mass per cubic inch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId LbMassPerInSup3 { get; }
Visual Basic
Public Shared ReadOnly Property LbMassPerInSup3 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LbMassPerInSup3 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


LbMassPerLbDegreeF Property

[image]

Revit 2024 API
SymbolTypeId..::..LbMassPerLbDegreeF Property
SymbolTypeId Class See Also Send Feedback
Symbol lb/(lbÂ·Â°F), indicating unit Pounds mass per pound degree Fahrenheit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId LbMassPerLbDegreeF { get; }
Visual Basic
Public Shared ReadOnly Property LbMassPerLbDegreeF As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LbMassPerLbDegreeF {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


LbMassPerMin Property

[image]

Revit 2024 API
SymbolTypeId..::..LbMassPerMin Property
SymbolTypeId Class See Also Send Feedback
Symbol lb/min, indicating unit Pounds mass per minute.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId LbMassPerMin { get; }
Visual Basic
Public Shared ReadOnly Property LbMassPerMin As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LbMassPerMin {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


LbMassPerS Property

[image]

Revit 2024 API
SymbolTypeId..::..LbMassPerS Property
SymbolTypeId Class See Also Send Feedback
Symbol lb/s, indicating unit Pounds mass per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId LbMassPerS { get; }
Visual Basic
Public Shared ReadOnly Property LbMassPerS As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LbMassPerS {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


LbmPerFt Property

[image]

Revit 2024 API
SymbolTypeId..::..LbmPerFt Property
SymbolTypeId Class See Also Send Feedback
Symbol lbm/ft, indicating unit Pounds mass per foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId LbmPerFt { get; }
Visual Basic
Public Shared ReadOnly Property LbmPerFt As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LbmPerFt {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


LbmPerFtDashH Property

[image]

Revit 2024 API
SymbolTypeId..::..LbmPerFtDashH Property
SymbolTypeId Class See Also Send Feedback
Symbol lbm/ft-h, indicating unit Pounds mass per foot hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId LbmPerFtDashH { get; }
Visual Basic
Public Shared ReadOnly Property LbmPerFtDashH As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LbmPerFtDashH {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


LbmPerFtDashS Property

[image]

Revit 2024 API
SymbolTypeId..::..LbmPerFtDashS Property
SymbolTypeId Class See Also Send Feedback
Symbol lbm/ft-s, indicating unit Pounds mass per foot second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId LbmPerFtDashS { get; }
Visual Basic
Public Shared ReadOnly Property LbmPerFtDashS As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LbmPerFtDashS {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


LbmPerFtSup3 Property

[image]

Revit 2024 API
SymbolTypeId..::..LbmPerFtSup3 Property
SymbolTypeId Class See Also Send Feedback
Symbol lbm/ftÂ³, indicating unit Pounds mass per cubic foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId LbmPerFtSup3 { get; }
Visual Basic
Public Shared ReadOnly Property LbmPerFtSup3 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LbmPerFtSup3 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Lf Property

[image]

Revit 2024 API
SymbolTypeId..::..Lf Property
SymbolTypeId Class See Also Send Feedback
Symbol LF, indicating unit Feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Lf { get; }
Visual Basic
Public Shared ReadOnly Property Lf As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Lf {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


LmPerW Property

[image]

Revit 2024 API
SymbolTypeId..::..LmPerW Property
SymbolTypeId Class See Also Send Feedback
Symbol lm/W, indicating unit Lumens per watt.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId LmPerW { get; }
Visual Basic
Public Shared ReadOnly Property LmPerW As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LmPerW {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


LPerMin Property

[image]

Revit 2024 API
SymbolTypeId..::..LPerMin Property
SymbolTypeId Class See Also Send Feedback
Symbol L/min, indicating unit Liters per minute.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId LPerMin { get; }
Visual Basic
Public Shared ReadOnly Property LPerMin As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LPerMin {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


LPerS Property

[image]

Revit 2024 API
SymbolTypeId..::..LPerS Property
SymbolTypeId Class See Also Send Feedback
Symbol L/s, indicating unit Liters per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId LPerS { get; }
Visual Basic
Public Shared ReadOnly Property LPerS As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LPerS {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


LPerSKw Property

[image]

Revit 2024 API
SymbolTypeId..::..LPerSKw Property
SymbolTypeId Class See Also Send Feedback
Symbol L/(sÂ·kW), indicating unit Liters per second kilowatt.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId LPerSKw { get; }
Visual Basic
Public Shared ReadOnly Property LPerSKw As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LPerSKw {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


LPerSMSup2 Property

[image]

Revit 2024 API
SymbolTypeId..::..LPerSMSup2 Property
SymbolTypeId Class See Also Send Feedback
Symbol L/(sÂ·mÂ²), indicating unit Liters per second square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId LPerSMSup2 { get; }
Visual Basic
Public Shared ReadOnly Property LPerSMSup2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LPerSMSup2 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


LPerSMSup3 Property

[image]

Revit 2024 API
SymbolTypeId..::..LPerSMSup3 Property
SymbolTypeId Class See Also Send Feedback
Symbol L/(sÂ·mÂ³), indicating unit Liters per second cubic meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId LPerSMSup3 { get; }
Visual Basic
Public Shared ReadOnly Property LPerSMSup3 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LPerSMSup3 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Lpm Property

[image]

Revit 2024 API
SymbolTypeId..::..Lpm Property
SymbolTypeId Class See Also Send Feedback
Symbol LPM, indicating unit Liters per minute.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Lpm { get; }
Visual Basic
Public Shared ReadOnly Property Lpm As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Lpm {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Lps Property

[image]

Revit 2024 API
SymbolTypeId..::..Lps Property
SymbolTypeId Class See Also Send Feedback
Symbol LPS, indicating unit Liters per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Lps { get; }
Visual Basic
Public Shared ReadOnly Property Lps As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Lps {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


LpsPerMSup2 Property

[image]

Revit 2024 API
SymbolTypeId..::..LpsPerMSup2 Property
SymbolTypeId Class See Also Send Feedback
Symbol LPS/mÂ², indicating unit Liters per second square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId LpsPerMSup2 { get; }
Visual Basic
Public Shared ReadOnly Property LpsPerMSup2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LpsPerMSup2 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Lx Property

[image]

Revit 2024 API
SymbolTypeId..::..Lx Property
SymbolTypeId Class See Also Send Feedback
Symbol lx, indicating unit Lux.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Lx { get; }
Visual Basic
Public Shared ReadOnly Property Lx As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Lx {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


MA Property

[image]

Revit 2024 API
SymbolTypeId..::..MA Property
SymbolTypeId Class See Also Send Feedback
Symbol mA, indicating unit Milliamperes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MA { get; }
Visual Basic
Public Shared ReadOnly Property MA As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MA {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


MCaret2 Property

[image]

Revit 2024 API
SymbolTypeId..::..MCaret2 Property
SymbolTypeId Class See Also Send Feedback
Symbol m^2, indicating unit Square meters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MCaret2 { get; }
Visual Basic
Public Shared ReadOnly Property MCaret2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MCaret2 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


MCaret3 Property

[image]

Revit 2024 API
SymbolTypeId..::..MCaret3 Property
SymbolTypeId Class See Also Send Feedback
Symbol m^3, indicating unit Cubic meters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MCaret3 { get; }
Visual Basic
Public Shared ReadOnly Property MCaret3 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MCaret3 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Meter Property

[image]

Revit 2024 API
SymbolTypeId..::..Meter Property
SymbolTypeId Class See Also Send Feedback
Symbol m, indicating unit Meters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Meter { get; }
Visual Basic
Public Shared ReadOnly Property Meter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Meter {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


MH2O Property

[image]

Revit 2024 API
SymbolTypeId..::..MH2O Property
SymbolTypeId Class See Also Send Feedback
Symbol mH2O, indicating unit Meters of water column.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MH2O { get; }
Visual Basic
Public Shared ReadOnly Property MH2O As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MH2O {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


MH2OPerM Property

[image]

Revit 2024 API
SymbolTypeId..::..MH2OPerM Property
SymbolTypeId Class See Also Send Feedback
Symbol mH2O/m, indicating unit Meters of water column per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MH2OPerM { get; }
Visual Basic
Public Shared ReadOnly Property MH2OPerM As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MH2OPerM {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Min Property

[image]

Revit 2024 API
SymbolTypeId..::..Min Property
SymbolTypeId Class See Also Send Feedback
Symbol min, indicating unit Minutes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Min { get; }
Visual Basic
Public Shared ReadOnly Property Min As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Min {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


MiPerSSup2 Property

[image]

Revit 2024 API
SymbolTypeId..::..MiPerSSup2 Property
SymbolTypeId Class See Also Send Feedback
Symbol mi/sÂ², indicating unit Miles per second squared.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MiPerSSup2 { get; }
Visual Basic
Public Shared ReadOnly Property MiPerSSup2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MiPerSSup2 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Mm Property

[image]

Revit 2024 API
SymbolTypeId..::..Mm Property
SymbolTypeId Class See Also Send Feedback
Symbol mm, indicating unit Millimeters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Mm { get; }
Visual Basic
Public Shared ReadOnly Property Mm As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Mm {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


MmH2O Property

[image]

Revit 2024 API
SymbolTypeId..::..MmH2O Property
SymbolTypeId Class See Also Send Feedback
Symbol mmH2O, indicating unit Millimeters of water column.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MmH2O { get; }
Visual Basic
Public Shared ReadOnly Property MmH2O As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MmH2O {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


MmH2OPerM Property

[image]

Revit 2024 API
SymbolTypeId..::..MmH2OPerM Property
SymbolTypeId Class See Also Send Feedback
Symbol mmH2O/m, indicating unit Millimeters of water column per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MmH2OPerM { get; }
Visual Basic
Public Shared ReadOnly Property MmH2OPerM As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MmH2OPerM {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


MmHg Property

[image]

Revit 2024 API
SymbolTypeId..::..MmHg Property
SymbolTypeId Class See Also Send Feedback
Symbol mmHg, indicating unit Millimeters of mercury.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MmHg { get; }
Visual Basic
Public Shared ReadOnly Property MmHg As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MmHg {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


MmSup2 Property

[image]

Revit 2024 API
SymbolTypeId..::..MmSup2 Property
SymbolTypeId Class See Also Send Feedback
Symbol mmÂ², indicating unit Square millimeters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MmSup2 { get; }
Visual Basic
Public Shared ReadOnly Property MmSup2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MmSup2 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


MmSup2PerM Property

[image]

Revit 2024 API
SymbolTypeId..::..MmSup2PerM Property
SymbolTypeId Class See Also Send Feedback
Symbol mmÂ²/m, indicating unit Square millimeters per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MmSup2PerM { get; }
Visual Basic
Public Shared ReadOnly Property MmSup2PerM As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MmSup2PerM {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


MmSup6 Property

[image]

Revit 2024 API
SymbolTypeId..::..MmSup6 Property
SymbolTypeId Class See Also Send Feedback
Symbol mmâ¶, indicating unit Millimeters to the sixth power.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MmSup6 { get; }
Visual Basic
Public Shared ReadOnly Property MmSup6 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MmSup6 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


MN Property

[image]

Revit 2024 API
SymbolTypeId..::..MN Property
SymbolTypeId Class See Also Send Feedback
Symbol MN, indicating unit Meganewtons.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MN { get; }
Visual Basic
Public Shared ReadOnly Property MN As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MN {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


MNDashM Property

[image]

Revit 2024 API
SymbolTypeId..::..MNDashM Property
SymbolTypeId Class See Also Send Feedback
Symbol MN-m, indicating unit Meganewton meters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MNDashM { get; }
Visual Basic
Public Shared ReadOnly Property MNDashM As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MNDashM {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


MNDashMPerM Property

[image]

Revit 2024 API
SymbolTypeId..::..MNDashMPerM Property
SymbolTypeId Class See Also Send Feedback
Symbol MN-m/m, indicating unit Meganewton meters per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MNDashMPerM { get; }
Visual Basic
Public Shared ReadOnly Property MNDashMPerM As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MNDashMPerM {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


MNPerM Property

[image]

Revit 2024 API
SymbolTypeId..::..MNPerM Property
SymbolTypeId Class See Also Send Feedback
Symbol MN/m, indicating unit Meganewtons per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MNPerM { get; }
Visual Basic
Public Shared ReadOnly Property MNPerM As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MNPerM {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


MPa Property

[image]

Revit 2024 API
SymbolTypeId..::..MPa Property
SymbolTypeId Class See Also Send Feedback
Symbol MPa, indicating unit Megapascals.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MPa { get; }
Visual Basic
Public Shared ReadOnly Property MPa As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MPa {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


MPerKN Property

[image]

Revit 2024 API
SymbolTypeId..::..MPerKN Property
SymbolTypeId Class See Also Send Feedback
Symbol m/kN, indicating unit Meters per kilonewton.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MPerKN { get; }
Visual Basic
Public Shared ReadOnly Property MPerKN As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MPerKN {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


MPerS Property

[image]

Revit 2024 API
SymbolTypeId..::..MPerS Property
SymbolTypeId Class See Also Send Feedback
Symbol m/s, indicating unit Meters per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MPerS { get; }
Visual Basic
Public Shared ReadOnly Property MPerS As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MPerS {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


MPerSSup2 Property

[image]

Revit 2024 API
SymbolTypeId..::..MPerSSup2 Property
SymbolTypeId Class See Also Send Feedback
Symbol m/sÂ², indicating unit Meters per second squared.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MPerSSup2 { get; }
Visual Basic
Public Shared ReadOnly Property MPerSSup2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MPerSSup2 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Mph Property

[image]

Revit 2024 API
SymbolTypeId..::..Mph Property
SymbolTypeId Class See Also Send Feedback
Symbol mph, indicating unit Miles per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Mph { get; }
Visual Basic
Public Shared ReadOnly Property Mph As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Mph {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Ms Property

[image]

Revit 2024 API
SymbolTypeId..::..Ms Property
SymbolTypeId Class See Also Send Feedback
Symbol ms, indicating unit Milliseconds.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Ms { get; }
Visual Basic
Public Shared ReadOnly Property Ms As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Ms {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


MSup2 Property

[image]

Revit 2024 API
SymbolTypeId..::..MSup2 Property
SymbolTypeId Class See Also Send Feedback
Symbol mÂ², indicating unit Square meters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MSup2 { get; }
Visual Basic
Public Shared ReadOnly Property MSup2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MSup2 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


MSup2KPerW Property

[image]

Revit 2024 API
SymbolTypeId..::..MSup2KPerW Property
SymbolTypeId Class See Also Send Feedback
Symbol (mÂ²Â·K)/W, indicating unit Square meter kelvins per watt.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MSup2KPerW { get; }
Visual Basic
Public Shared ReadOnly Property MSup2KPerW As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MSup2KPerW {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


MSup2PerKw Property

[image]

Revit 2024 API
SymbolTypeId..::..MSup2PerKw Property
SymbolTypeId Class See Also Send Feedback
Symbol mÂ²/kW, indicating unit Square meters per kilowatt.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MSup2PerKw { get; }
Visual Basic
Public Shared ReadOnly Property MSup2PerKw As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MSup2PerKw {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


MSup2PerM Property

[image]

Revit 2024 API
SymbolTypeId..::..MSup2PerM Property
SymbolTypeId Class See Also Send Feedback
Symbol mÂ²/m, indicating unit Square meters per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MSup2PerM { get; }
Visual Basic
Public Shared ReadOnly Property MSup2PerM As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MSup2PerM {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


MSup2PerS Property

[image]

Revit 2024 API
SymbolTypeId..::..MSup2PerS Property
SymbolTypeId Class See Also Send Feedback
Symbol mÂ²/s, indicating unit Square meters per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MSup2PerS { get; }
Visual Basic
Public Shared ReadOnly Property MSup2PerS As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MSup2PerS {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


MSup3 Property

[image]

Revit 2024 API
SymbolTypeId..::..MSup3 Property
SymbolTypeId Class See Also Send Feedback
Symbol mÂ³, indicating unit Cubic meters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MSup3 { get; }
Visual Basic
Public Shared ReadOnly Property MSup3 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MSup3 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


MSup3PerH Property

[image]

Revit 2024 API
SymbolTypeId..::..MSup3PerH Property
SymbolTypeId Class See Also Send Feedback
Symbol mÂ³/h, indicating unit Cubic meters per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MSup3PerH { get; }
Visual Basic
Public Shared ReadOnly Property MSup3PerH As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MSup3PerH {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


MSup3PerHMSup2 Property

[image]

Revit 2024 API
SymbolTypeId..::..MSup3PerHMSup2 Property
SymbolTypeId Class See Also Send Feedback
Symbol mÂ³/(hÂ·mÂ²), indicating unit Cubic meters per hour square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MSup3PerHMSup2 { get; }
Visual Basic
Public Shared ReadOnly Property MSup3PerHMSup2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MSup3PerHMSup2 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


MSup3PerHMSup3 Property

[image]

Revit 2024 API
SymbolTypeId..::..MSup3PerHMSup3 Property
SymbolTypeId Class See Also Send Feedback
Symbol mÂ³/(hÂ·mÂ³), indicating unit Cubic meters per hour cubic meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MSup3PerHMSup3 { get; }
Visual Basic
Public Shared ReadOnly Property MSup3PerHMSup3 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MSup3PerHMSup3 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


MSup3PerKg Property

[image]

Revit 2024 API
SymbolTypeId..::..MSup3PerKg Property
SymbolTypeId Class See Also Send Feedback
Symbol mÂ³/kg, indicating unit Cubic meters per kilogram.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MSup3PerKg { get; }
Visual Basic
Public Shared ReadOnly Property MSup3PerKg As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MSup3PerKg {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


MSup3PerS Property

[image]

Revit 2024 API
SymbolTypeId..::..MSup3PerS Property
SymbolTypeId Class See Also Send Feedback
Symbol mÂ³/s, indicating unit Cubic meters per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MSup3PerS { get; }
Visual Basic
Public Shared ReadOnly Property MSup3PerS As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MSup3PerS {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


MSup3PerWS Property

[image]

Revit 2024 API
SymbolTypeId..::..MSup3PerWS Property
SymbolTypeId Class See Also Send Feedback
Symbol mÂ³/(WÂ·s), indicating unit Cubic meters per watt second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MSup3PerWS { get; }
Visual Basic
Public Shared ReadOnly Property MSup3PerWS As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MSup3PerWS {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


MSup4 Property

[image]

Revit 2024 API
SymbolTypeId..::..MSup4 Property
SymbolTypeId Class See Also Send Feedback
Symbol mâ´, indicating unit Meters to the fourth power.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MSup4 { get; }
Visual Basic
Public Shared ReadOnly Property MSup4 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MSup4 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


MSup6 Property

[image]

Revit 2024 API
SymbolTypeId..::..MSup6 Property
SymbolTypeId Class See Also Send Feedback
Symbol mâ¶, indicating unit Meters to the sixth power.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MSup6 { get; }
Visual Basic
Public Shared ReadOnly Property MSup6 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MSup6 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


MV Property

[image]

Revit 2024 API
SymbolTypeId..::..MV Property
SymbolTypeId Class See Also Send Feedback
Symbol mV, indicating unit Millivolts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MV { get; }
Visual Basic
Public Shared ReadOnly Property MV As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MV {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


NDashM Property

[image]

Revit 2024 API
SymbolTypeId..::..NDashM Property
SymbolTypeId Class See Also Send Feedback
Symbol N-m, indicating unit Newton meters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId NDashM { get; }
Visual Basic
Public Shared ReadOnly Property NDashM As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ NDashM {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


NDashMPerM Property

[image]

Revit 2024 API
SymbolTypeId..::..NDashMPerM Property
SymbolTypeId Class See Also Send Feedback
Symbol N-m/m, indicating unit Newton meters per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId NDashMPerM { get; }
Visual Basic
Public Shared ReadOnly Property NDashMPerM As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ NDashMPerM {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Newton Property

[image]

Revit 2024 API
SymbolTypeId..::..Newton Property
SymbolTypeId Class See Also Send Feedback
Symbol N, indicating unit Newtons.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Newton { get; }
Visual Basic
Public Shared ReadOnly Property Newton As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Newton {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


NgPerPaSMSup2 Property

[image]

Revit 2024 API
SymbolTypeId..::..NgPerPaSMSup2 Property
SymbolTypeId Class See Also Send Feedback
Symbol ng/(PaÂ·sÂ·mÂ²), indicating unit Nanograms per pascal second square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId NgPerPaSMSup2 { get; }
Visual Basic
Public Shared ReadOnly Property NgPerPaSMSup2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ NgPerPaSMSup2 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


NPerM Property

[image]

Revit 2024 API
SymbolTypeId..::..NPerM Property
SymbolTypeId Class See Also Send Feedback
Symbol N/m, indicating unit Newtons per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId NPerM { get; }
Visual Basic
Public Shared ReadOnly Property NPerM As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ NPerM {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


NPerMmSup2 Property

[image]

Revit 2024 API
SymbolTypeId..::..NPerMmSup2 Property
SymbolTypeId Class See Also Send Feedback
Symbol N/mmÂ², indicating unit Newtons per square millimeter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId NPerMmSup2 { get; }
Visual Basic
Public Shared ReadOnly Property NPerMmSup2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ NPerMmSup2 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


NSPerMSup2 Property

[image]

Revit 2024 API
SymbolTypeId..::..NSPerMSup2 Property
SymbolTypeId Class See Also Send Feedback
Symbol NÂ·s/mÂ², indicating unit Newton seconds per square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId NSPerMSup2 { get; }
Visual Basic
Public Shared ReadOnly Property NSPerMSup2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ NSPerMSup2 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


OhmM Property

[image]

Revit 2024 API
SymbolTypeId..::..OhmM Property
SymbolTypeId Class See Also Send Feedback
Symbol ohmÂ·m, indicating unit Ohm meters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId OhmM { get; }
Visual Basic
Public Shared ReadOnly Property OhmM As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ OhmM {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


OneColon Property

[image]

Revit 2024 API
SymbolTypeId..::..OneColon Property
SymbolTypeId Class See Also Send Feedback
Symbol 1:, indicating unit 1 : Ratio.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId OneColon { get; }
Visual Basic
Public Shared ReadOnly Property OneColon As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ OneColon {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Pa Property

[image]

Revit 2024 API
SymbolTypeId..::..Pa Property
SymbolTypeId Class See Also Send Feedback
Symbol Pa, indicating unit Pascals.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Pa { get; }
Visual Basic
Public Shared ReadOnly Property Pa As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Pa {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


PaPerM Property

[image]

Revit 2024 API
SymbolTypeId..::..PaPerM Property
SymbolTypeId Class See Also Send Feedback
Symbol Pa/m, indicating unit Pascals per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId PaPerM { get; }
Visual Basic
Public Shared ReadOnly Property PaPerM As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PaPerM {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Percent Property

[image]

Revit 2024 API
SymbolTypeId..::..Percent Property
SymbolTypeId Class See Also Send Feedback
Symbol %, indicating unit Percentage.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Percent { get; }
Visual Basic
Public Shared ReadOnly Property Percent As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Percent {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


PerMille Property

[image]

Revit 2024 API
SymbolTypeId..::..PerMille Property
SymbolTypeId Class See Also Send Feedback
Symbol â€°, indicating unit Per mille.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId PerMille { get; }
Visual Basic
Public Shared ReadOnly Property PerMille As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PerMille {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Pi Property

[image]

Revit 2024 API
SymbolTypeId..::..Pi Property
SymbolTypeId Class See Also Send Feedback
Symbol Ï€, indicating unit Multiples of Ï€.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Pi { get; }
Visual Basic
Public Shared ReadOnly Property Pi As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Pi {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Psi Property

[image]

Revit 2024 API
SymbolTypeId..::..Psi Property
SymbolTypeId Class See Also Send Feedback
Symbol psi, indicating unit Pounds force per square inch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Psi { get; }
Visual Basic
Public Shared ReadOnly Property Psi As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Psi {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Psig Property

[image]

Revit 2024 API
SymbolTypeId..::..Psig Property
SymbolTypeId Class See Also Send Feedback
Symbol psig, indicating unit Pounds force per square inch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Psig { get; }
Visual Basic
Public Shared ReadOnly Property Psig As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Psig {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Rad Property

[image]

Revit 2024 API
SymbolTypeId..::..Rad Property
SymbolTypeId Class See Also Send Feedback
Symbol rad, indicating unit Radians.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Rad { get; }
Visual Basic
Public Shared ReadOnly Property Rad As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Rad {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Rps Property

[image]

Revit 2024 API
SymbolTypeId..::..Rps Property
SymbolTypeId Class See Also Send Feedback
Symbol RPS, indicating unit Revolutions per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Rps { get; }
Visual Basic
Public Shared ReadOnly Property Rps As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Rps {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Second Property

[image]

Revit 2024 API
SymbolTypeId..::..Second Property
SymbolTypeId Class See Also Send Feedback
Symbol s, indicating unit Seconds.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Second { get; }
Visual Basic
Public Shared ReadOnly Property Second As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Second {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Sf Property

[image]

Revit 2024 API
SymbolTypeId..::..Sf Property
SymbolTypeId Class See Also Send Feedback
Symbol SF, indicating unit Square feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Sf { get; }
Visual Basic
Public Shared ReadOnly Property Sf As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Sf {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


SfHPerKbtu Property

[image]

Revit 2024 API
SymbolTypeId..::..SfHPerKbtu Property
SymbolTypeId Class See Also Send Feedback
Symbol SFÂ·h/kBtu, indicating unit Square feet per thousand British thermal units per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId SfHPerKbtu { get; }
Visual Basic
Public Shared ReadOnly Property SfHPerKbtu As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SfHPerKbtu {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


SfPerMbh Property

[image]

Revit 2024 API
SymbolTypeId..::..SfPerMbh Property
SymbolTypeId Class See Also Send Feedback
Symbol SF/MBh, indicating unit Square feet per thousand British thermal units per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId SfPerMbh { get; }
Visual Basic
Public Shared ReadOnly Property SfPerMbh As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SfPerMbh {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


SfPerTon Property

[image]

Revit 2024 API
SymbolTypeId..::..SfPerTon Property
SymbolTypeId Class See Also Send Feedback
Symbol SF/ton, indicating unit Square feet per ton of refrigeration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId SfPerTon { get; }
Visual Basic
Public Shared ReadOnly Property SfPerTon As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SfPerTon {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


SlopeDegree Property

[image]

Revit 2024 API
SymbolTypeId..::..SlopeDegree Property
SymbolTypeId Class See Also Send Feedback
Symbol Â°, indicating unit Slope degrees.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId SlopeDegree { get; }
Visual Basic
Public Shared ReadOnly Property SlopeDegree As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SlopeDegree {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Stf Property

[image]

Revit 2024 API
SymbolTypeId..::..Stf Property
SymbolTypeId Class See Also Send Feedback
Symbol STf, indicating unit US tonnes force.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Stf { get; }
Visual Basic
Public Shared ReadOnly Property Stf As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Stf {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Tf Property

[image]

Revit 2024 API
SymbolTypeId..::..Tf Property
SymbolTypeId Class See Also Send Feedback
Symbol Tf, indicating unit Tonnes force.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Tf { get; }
Visual Basic
Public Shared ReadOnly Property Tf As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Tf {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


TfDashM Property

[image]

Revit 2024 API
SymbolTypeId..::..TfDashM Property
SymbolTypeId Class See Also Send Feedback
Symbol Tf-m, indicating unit Tonne force meters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId TfDashM { get; }
Visual Basic
Public Shared ReadOnly Property TfDashM As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TfDashM {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


TfDashMPerM Property

[image]

Revit 2024 API
SymbolTypeId..::..TfDashMPerM Property
SymbolTypeId Class See Also Send Feedback
Symbol Tf-m/m, indicating unit Tonne force meters per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId TfDashMPerM { get; }
Visual Basic
Public Shared ReadOnly Property TfDashMPerM As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TfDashMPerM {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


TfPerM Property

[image]

Revit 2024 API
SymbolTypeId..::..TfPerM Property
SymbolTypeId Class See Also Send Feedback
Symbol Tf/m, indicating unit Tonnes force per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId TfPerM { get; }
Visual Basic
Public Shared ReadOnly Property TfPerM As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TfPerM {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Therm Property

[image]

Revit 2024 API
SymbolTypeId..::..Therm Property
SymbolTypeId Class See Also Send Feedback
Symbol therm, indicating unit Therms.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Therm { get; }
Visual Basic
Public Shared ReadOnly Property Therm As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Therm {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Ton Property

[image]

Revit 2024 API
SymbolTypeId..::..Ton Property
SymbolTypeId Class See Also Send Feedback
Symbol ton, indicating unit Tons of refrigeration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Ton { get; }
Visual Basic
Public Shared ReadOnly Property Ton As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Ton {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Tonne Property

[image]

Revit 2024 API
SymbolTypeId..::..Tonne Property
SymbolTypeId Class See Also Send Feedback
Symbol t, indicating unit Tonnes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Tonne { get; }
Visual Basic
Public Shared ReadOnly Property Tonne As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Tonne {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


TonOfRefrigeration Property

[image]

Revit 2024 API
SymbolTypeId..::..TonOfRefrigeration Property
SymbolTypeId Class See Also Send Feedback
Symbol ton of refrigeration, indicating unit Tons of refrigeration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId TonOfRefrigeration { get; }
Visual Basic
Public Shared ReadOnly Property TonOfRefrigeration As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TonOfRefrigeration {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Tonsf Property

[image]

Revit 2024 API
SymbolTypeId..::..Tonsf Property
SymbolTypeId Class See Also Send Feedback
Symbol Tonsf, indicating unit US tonnes force.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Tonsf { get; }
Visual Basic
Public Shared ReadOnly Property Tonsf As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Tonsf {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


UinPerInDegreeF Property

[image]

Revit 2024 API
SymbolTypeId..::..UinPerInDegreeF Property
SymbolTypeId Class See Also Send Feedback
Symbol Âµin/(inÂ·Â°F), indicating unit Microinches per inch degree Fahrenheit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId UinPerInDegreeF { get; }
Visual Basic
Public Shared ReadOnly Property UinPerInDegreeF As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ UinPerInDegreeF {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


UkPound Property

[image]

Revit 2024 API
SymbolTypeId..::..UkPound Property
SymbolTypeId Class See Also Send Feedback
Symbol Â£, indicating unit Currency.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId UkPound { get; }
Visual Basic
Public Shared ReadOnly Property UkPound As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ UkPound {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


UmPerMDegreeC Property

[image]

Revit 2024 API
SymbolTypeId..::..UmPerMDegreeC Property
SymbolTypeId Class See Also Send Feedback
Symbol Âµm/(mÂ·Â°C), indicating unit Micrometers per meter degree Celsius.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId UmPerMDegreeC { get; }
Visual Basic
Public Shared ReadOnly Property UmPerMDegreeC As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ UmPerMDegreeC {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


UsDollar Property

[image]

Revit 2024 API
SymbolTypeId..::..UsDollar Property
SymbolTypeId Class See Also Send Feedback
Symbol $, indicating unit Currency.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId UsDollar { get; }
Visual Basic
Public Shared ReadOnly Property UsDollar As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ UsDollar {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Usft Property

[image]

Revit 2024 API
SymbolTypeId..::..Usft Property
SymbolTypeId Class See Also Send Feedback
Symbol USft, indicating unit US survey feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Usft { get; }
Visual Basic
Public Shared ReadOnly Property Usft As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Usft {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Usgpm Property

[image]

Revit 2024 API
SymbolTypeId..::..Usgpm Property
SymbolTypeId Class See Also Send Feedback
Symbol usgpm, indicating unit US gallons per minute.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Usgpm { get; }
Visual Basic
Public Shared ReadOnly Property Usgpm As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Usgpm {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


UsTonnesForceSt Property

[image]

Revit 2024 API
SymbolTypeId..::..UsTonnesForceSt Property
SymbolTypeId Class See Also Send Feedback
Symbol ST, indicating unit US tonnes force.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId UsTonnesForceSt { get; }
Visual Basic
Public Shared ReadOnly Property UsTonnesForceSt As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ UsTonnesForceSt {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


UsTonnesForceT Property

[image]

Revit 2024 API
SymbolTypeId..::..UsTonnesForceT Property
SymbolTypeId Class See Also Send Feedback
Symbol T, indicating unit US tonnes force.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId UsTonnesForceT { get; }
Visual Basic
Public Shared ReadOnly Property UsTonnesForceT As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ UsTonnesForceT {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


UsTonnesForceTons Property

[image]

Revit 2024 API
SymbolTypeId..::..UsTonnesForceTons Property
SymbolTypeId Class See Also Send Feedback
Symbol Tons, indicating unit US tonnes force.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId UsTonnesForceTons { get; }
Visual Basic
Public Shared ReadOnly Property UsTonnesForceTons As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ UsTonnesForceTons {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


UsTonnesMassSt Property

[image]

Revit 2024 API
SymbolTypeId..::..UsTonnesMassSt Property
SymbolTypeId Class See Also Send Feedback
Symbol ST, indicating unit US tonnes mass.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId UsTonnesMassSt { get; }
Visual Basic
Public Shared ReadOnly Property UsTonnesMassSt As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ UsTonnesMassSt {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


UsTonnesMassT Property

[image]

Revit 2024 API
SymbolTypeId..::..UsTonnesMassT Property
SymbolTypeId Class See Also Send Feedback
Symbol T, indicating unit US tonnes mass.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId UsTonnesMassT { get; }
Visual Basic
Public Shared ReadOnly Property UsTonnesMassT As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ UsTonnesMassT {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


UsTonnesMassTons Property

[image]

Revit 2024 API
SymbolTypeId..::..UsTonnesMassTons Property
SymbolTypeId Class See Also Send Feedback
Symbol Tons, indicating unit US tonnes mass.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId UsTonnesMassTons { get; }
Visual Basic
Public Shared ReadOnly Property UsTonnesMassTons As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ UsTonnesMassTons {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


VA Property

[image]

Revit 2024 API
SymbolTypeId..::..VA Property
SymbolTypeId Class See Also Send Feedback
Symbol VA, indicating unit Volt amperes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId VA { get; }
Visual Basic
Public Shared ReadOnly Property VA As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ VA {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


VAPerFtSup2 Property

[image]

Revit 2024 API
SymbolTypeId..::..VAPerFtSup2 Property
SymbolTypeId Class See Also Send Feedback
Symbol VA/ftÂ², indicating unit Volt amperes per square foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId VAPerFtSup2 { get; }
Visual Basic
Public Shared ReadOnly Property VAPerFtSup2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ VAPerFtSup2 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


VAPerMSup2 Property

[image]

Revit 2024 API
SymbolTypeId..::..VAPerMSup2 Property
SymbolTypeId Class See Also Send Feedback
Symbol VA/mÂ², indicating unit Volt amperes per square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId VAPerMSup2 { get; }
Visual Basic
Public Shared ReadOnly Property VAPerMSup2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ VAPerMSup2 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Volt Property

[image]

Revit 2024 API
SymbolTypeId..::..Volt Property
SymbolTypeId Class See Also Send Feedback
Symbol V, indicating unit Volts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Volt { get; }
Visual Basic
Public Shared ReadOnly Property Volt As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Volt {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Watt Property

[image]

Revit 2024 API
SymbolTypeId..::..Watt Property
SymbolTypeId Class See Also Send Feedback
Symbol W, indicating unit Watts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Watt { get; }
Visual Basic
Public Shared ReadOnly Property Watt As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Watt {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


WMinPerFtSup3 Property

[image]

Revit 2024 API
SymbolTypeId..::..WMinPerFtSup3 Property
SymbolTypeId Class See Also Send Feedback
Symbol WÂ·min/ftÂ³, indicating unit Watts per cubic foot per minute.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId WMinPerFtSup3 { get; }
Visual Basic
Public Shared ReadOnly Property WMinPerFtSup3 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WMinPerFtSup3 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


Won Property

[image]

Revit 2024 API
SymbolTypeId..::..Won Property
SymbolTypeId Class See Also Send Feedback
Symbol â‚©, indicating unit Currency.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Won { get; }
Visual Basic
Public Shared ReadOnly Property Won As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Won {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


WPerFt Property

[image]

Revit 2024 API
SymbolTypeId..::..WPerFt Property
SymbolTypeId Class See Also Send Feedback
Symbol W/ft, indicating unit Watts per foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId WPerFt { get; }
Visual Basic
Public Shared ReadOnly Property WPerFt As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WPerFt {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


WPerFtSup2 Property

[image]

Revit 2024 API
SymbolTypeId..::..WPerFtSup2 Property
SymbolTypeId Class See Also Send Feedback
Symbol W/ftÂ², indicating unit Watts per square foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId WPerFtSup2 { get; }
Visual Basic
Public Shared ReadOnly Property WPerFtSup2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WPerFtSup2 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


WPerFtSup3 Property

[image]

Revit 2024 API
SymbolTypeId..::..WPerFtSup3 Property
SymbolTypeId Class See Also Send Feedback
Symbol W/ftÂ³, indicating unit Watts per cubic foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId WPerFtSup3 { get; }
Visual Basic
Public Shared ReadOnly Property WPerFtSup3 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WPerFtSup3 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


WPerM Property

[image]

Revit 2024 API
SymbolTypeId..::..WPerM Property
SymbolTypeId Class See Also Send Feedback
Symbol W/m, indicating unit Watts per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId WPerM { get; }
Visual Basic
Public Shared ReadOnly Property WPerM As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WPerM {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


WPerMK Property

[image]

Revit 2024 API
SymbolTypeId..::..WPerMK Property
SymbolTypeId Class See Also Send Feedback
Symbol W/(mÂ·K), indicating unit Watts per meter kelvin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId WPerMK { get; }
Visual Basic
Public Shared ReadOnly Property WPerMK As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WPerMK {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


WPerMSup2 Property

[image]

Revit 2024 API
SymbolTypeId..::..WPerMSup2 Property
SymbolTypeId Class See Also Send Feedback
Symbol W/mÂ², indicating unit Watts per square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId WPerMSup2 { get; }
Visual Basic
Public Shared ReadOnly Property WPerMSup2 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WPerMSup2 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


WPerMSup2K Property

[image]

Revit 2024 API
SymbolTypeId..::..WPerMSup2K Property
SymbolTypeId Class See Also Send Feedback
Symbol W/(mÂ²Â·K), indicating unit Watts per square meter kelvin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId WPerMSup2K { get; }
Visual Basic
Public Shared ReadOnly Property WPerMSup2K As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WPerMSup2K {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


WPerMSup3 Property

[image]

Revit 2024 API
SymbolTypeId..::..WPerMSup3 Property
SymbolTypeId Class See Also Send Feedback
Symbol W/mÂ³, indicating unit Watts per cubic meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId WPerMSup3 { get; }
Visual Basic
Public Shared ReadOnly Property WPerMSup3 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WPerMSup3 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


WSPerMSup3 Property

[image]

Revit 2024 API
SymbolTypeId..::..WSPerMSup3 Property
SymbolTypeId Class See Also Send Feedback
Symbol WÂ·s/mÂ³, indicating unit Watts per cubic meter per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId WSPerMSup3 { get; }
Visual Basic
Public Shared ReadOnly Property WSPerMSup3 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WSPerMSup3 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


YdCaret3 Property

[image]

Revit 2024 API
SymbolTypeId..::..YdCaret3 Property
SymbolTypeId Class See Also Send Feedback
Symbol yd^3, indicating unit Cubic yards.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId YdCaret3 { get; }
Visual Basic
Public Shared ReadOnly Property YdCaret3 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ YdCaret3 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


YdSup3 Property

[image]

Revit 2024 API
SymbolTypeId..::..YdSup3 Property
SymbolTypeId Class See Also Send Feedback
Symbol ydÂ³, indicating unit Cubic yards.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId YdSup3 { get; }
Visual Basic
Public Shared ReadOnly Property YdSup3 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ YdSup3 {
    ForgeTypeId^ get ();
}

See Also

SymbolTypeId Class


SynchronizeWithCentralOptions Class

[image]

Revit 2024 API
SynchronizeWithCentralOptions Class
Members See Also Send Feedback
Options to control behavior of synchronization with central.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class SynchronizeWithCentralOptions : IDisposable
Visual Basic
Public Class SynchronizeWithCentralOptions _
    Implements IDisposable
Visual C++
public ref class SynchronizeWithCentralOptions : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..SynchronizeWithCentralOptions

See Also

SynchronizeWithCentralOptions Members


Dispose Method

[image]

Revit 2024 API
SynchronizeWithCentralOptions..::..Dispose Method
SynchronizeWithCentralOptions Class See Also Send Feedback
Releases all resources used by the SynchronizeWithCentralOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

SynchronizeWithCentralOptions Class


GetRelinquishOptions Method

[image]

Revit 2024 API
SynchronizeWithCentralOptions..::..GetRelinquishOptions Method
SynchronizeWithCentralOptions Class See Also Send Feedback
Gets the options which govern whether or not to relinquish elements and workset types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public RelinquishOptions GetRelinquishOptions()
Visual Basic
Public Function GetRelinquishOptions As RelinquishOptions
Visual C++
public:
RelinquishOptions^ GetRelinquishOptions()

Return Value

The options. If nullNothingnullptra null reference (Nothing in Visual Basic), synchronize with central will relinquish the current user's ownership of all worksets and all elements.

See Also

SynchronizeWithCentralOptions Class


SetRelinquishOptions Method

[image]

Revit 2024 API
SynchronizeWithCentralOptions..::..SetRelinquishOptions Method
SynchronizeWithCentralOptions Class See Also Send Feedback
Sets the options which govern whether or not to relinquish elements and workset types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void SetRelinquishOptions(
    RelinquishOptions relinquishOptions
)
Visual Basic
Public Sub SetRelinquishOptions ( _
    relinquishOptions As RelinquishOptions _
)
Visual C++
public:
void SetRelinquishOptions(
    RelinquishOptions^ relinquishOptions
)

Parameters

relinquishOptions
Type: Autodesk.Revit.DB..::..RelinquishOptions
The options. If nullNothingnullptra null reference (Nothing in Visual Basic), synchronize with central will relinquish the current user's ownership of all worksets and all elements.

See Also

SynchronizeWithCentralOptions Class


SynchronizeWithCentralOptions Properties

[image] [image]

Revit 2024 API
SynchronizeWithCentralOptions Properties
SynchronizeWithCentralOptions Class See Also Send Feedback

The SynchronizeWithCentralOptions type exposes the following members.

Properties

 | Name | Description
Public property | Comment | User description of changes made since the last Sync with Central. Empty by default.
Public property | Compact | Indicates whether Revit should compact the central model while synchronizing with central. This option reduces the size of the central model but many increase the time it takes to perform the save. False by default.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | RelinquishBorrowedElements | Indicates whether Revit should relinquish borrowed elements after synchronizing with central.
Public property | RelinquishFamilyWorksets | Indicates whether Revit should relinquish Family worksets after synchronizing with central.
Public property | RelinquishProjectStandardWorksets | Indicates whether Revit should relinquish Project Standard worksets after synchronizing with central.
Public property | RelinquishUserCreatedWorksets | Indicates whether Revit should relinquish user-created Standard worksets after synchronizing with central.
Public property | RelinquishViewWorksets | Indicates whether Revit should relinquish View worksets after synchronizing with central.
Public property | SaveLocalAfter | True means to save local after saving changes to central. True by default. Silently ignored if the model in the current session is central rather than local.
Public property | SaveLocalBefore | True means to save local before the first reload latest if there are changes not yet saved to local. True by default. Silently ignored if the model in the current session is central rather than local.
Public property | SaveLocalFile | Indicates whether Revit will save the local file at least once while synchronizing with central.

See Also

SynchronizeWithCentralOptions Class


Comment Property

[image]

Revit 2024 API
SynchronizeWithCentralOptions..::..Comment Property
SynchronizeWithCentralOptions Class See Also Send Feedback
User description of changes made since the last Sync with Central. Empty by default.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public string Comment { get; set; }
Visual Basic
Public Property Comment As String
    Get
    Set
Visual C++
public:
property String^ Comment {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: comment has more than 30,000 characters.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

SynchronizeWithCentralOptions Class


Compact Property

[image]

Revit 2024 API
SynchronizeWithCentralOptions..::..Compact Property
SynchronizeWithCentralOptions Class See Also Send Feedback
Indicates whether Revit should compact the central model while synchronizing with central. This option reduces the size of the central model but many increase the time it takes to perform the save. False by default.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool Compact { get; set; }
Visual Basic
Public Property Compact As Boolean
    Get
    Set
Visual C++
public:
property bool Compact {
    bool get ();
    void set (bool value);
}

See Also

SynchronizeWithCentralOptions Class


IsValidObject Property

[image]

Revit 2024 API
SynchronizeWithCentralOptions..::..IsValidObject Property
SynchronizeWithCentralOptions Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

SynchronizeWithCentralOptions Class


RelinquishBorrowedElements Property

[image]

Revit 2024 API
SynchronizeWithCentralOptions..::..RelinquishBorrowedElements Property
SynchronizeWithCentralOptions Class See Also Send Feedback
Indicates whether Revit should relinquish borrowed elements after synchronizing with central.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool RelinquishBorrowedElements { get; }
Visual Basic
Public ReadOnly Property RelinquishBorrowedElements As Boolean
    Get
Visual C++
public:
property bool RelinquishBorrowedElements {
    bool get ();
}

Remarks

This is a shortcut to access the value stored in CheckedOutElements.

See Also

SynchronizeWithCentralOptions Class


RelinquishFamilyWorksets Property

[image]

Revit 2024 API
SynchronizeWithCentralOptions..::..RelinquishFamilyWorksets Property
SynchronizeWithCentralOptions Class See Also Send Feedback
Indicates whether Revit should relinquish Family worksets after synchronizing with central.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool RelinquishFamilyWorksets { get; }
Visual Basic
Public ReadOnly Property RelinquishFamilyWorksets As Boolean
    Get
Visual C++
public:
property bool RelinquishFamilyWorksets {
    bool get ();
}

Remarks

This is a shortcut to access the value stored in FamilyWorksets.

See Also

SynchronizeWithCentralOptions Class


RelinquishProjectStandardWorksets Property

[image]

Revit 2024 API
SynchronizeWithCentralOptions..::..RelinquishProjectStandardWorksets Property
SynchronizeWithCentralOptions Class See Also Send Feedback
Indicates whether Revit should relinquish Project Standard worksets after synchronizing with central.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool RelinquishProjectStandardWorksets { get; }
Visual Basic
Public ReadOnly Property RelinquishProjectStandardWorksets As Boolean
    Get
Visual C++
public:
property bool RelinquishProjectStandardWorksets {
    bool get ();
}

Remarks

This is a shortcut to access the value stored in StandardWorksets.

See Also

SynchronizeWithCentralOptions Class


RelinquishUserCreatedWorksets Property

[image]

Revit 2024 API
SynchronizeWithCentralOptions..::..RelinquishUserCreatedWorksets Property
SynchronizeWithCentralOptions Class See Also Send Feedback
Indicates whether Revit should relinquish user-created Standard worksets after synchronizing with central.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool RelinquishUserCreatedWorksets { get; }
Visual Basic
Public ReadOnly Property RelinquishUserCreatedWorksets As Boolean
    Get
Visual C++
public:
property bool RelinquishUserCreatedWorksets {
    bool get ();
}

Remarks

This is a shortcut to access the value stored in UserWorksets.

See Also

SynchronizeWithCentralOptions Class


RelinquishViewWorksets Property

[image]

Revit 2024 API
SynchronizeWithCentralOptions..::..RelinquishViewWorksets Property
SynchronizeWithCentralOptions Class See Also Send Feedback
Indicates whether Revit should relinquish View worksets after synchronizing with central.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool RelinquishViewWorksets { get; }
Visual Basic
Public ReadOnly Property RelinquishViewWorksets As Boolean
    Get
Visual C++
public:
property bool RelinquishViewWorksets {
    bool get ();
}

Remarks

This is a shortcut to access the value stored in ViewWorksets.

See Also

SynchronizeWithCentralOptions Class


SaveLocalAfter Property

[image]

Revit 2024 API
SynchronizeWithCentralOptions..::..SaveLocalAfter Property
SynchronizeWithCentralOptions Class See Also Send Feedback
True means to save local after saving changes to central. True by default. Silently ignored if the model in the current session is central rather than local.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool SaveLocalAfter { get; set; }
Visual Basic
Public Property SaveLocalAfter As Boolean
    Get
    Set
Visual C++
public:
property bool SaveLocalAfter {
    bool get ();
    void set (bool value);
}

Remarks

It is recommended practice to save local after SWC because otherwise local becomes incompatible with central.

See Also

SynchronizeWithCentralOptions Class


SaveLocalBefore Property

[image]

Revit 2024 API
SynchronizeWithCentralOptions..::..SaveLocalBefore Property
SynchronizeWithCentralOptions Class See Also Send Feedback
True means to save local before the first reload latest if there are changes not yet saved to local. True by default. Silently ignored if the model in the current session is central rather than local.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool SaveLocalBefore { get; set; }
Visual Basic
Public Property SaveLocalBefore As Boolean
    Get
    Set
Visual C++
public:
property bool SaveLocalBefore {
    bool get ();
    void set (bool value);
}

See Also

SynchronizeWithCentralOptions Class


SaveLocalFile Property

[image]

Revit 2024 API
SynchronizeWithCentralOptions..::..SaveLocalFile Property
SynchronizeWithCentralOptions Class See Also Send Feedback
Indicates whether Revit will save the local file at least once while synchronizing with central.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool SaveLocalFile { get; }
Visual Basic
Public ReadOnly Property SaveLocalFile As Boolean
    Get
Visual C++
public:
property bool SaveLocalFile {
    bool get ();
}

See Also

SynchronizeWithCentralOptions Class


TableCellCalculatedValueData Members

[image] [image]

Revit 2024 API
TableCellCalculatedValueData Members
TableCellCalculatedValueData Class Methods Properties See Also Send Feedback

The TableCellCalculatedValueData type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the TableCellCalculatedValueData
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetName | Gets the name of the calculated value.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

TableCellCalculatedValueData Class


TableCellCalculatedValueData Methods

[image] [image]

Revit 2024 API
TableCellCalculatedValueData Methods
TableCellCalculatedValueData Class See Also Send Feedback

The TableCellCalculatedValueData type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetName | Gets the name of the calculated value.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TableCellCalculatedValueData Class


Dispose Method

[image]

Revit 2024 API
TableCellCalculatedValueData..::..Dispose Method
TableCellCalculatedValueData Class See Also Send Feedback
Releases all resources used by the TableCellCalculatedValueData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

TableCellCalculatedValueData Class


GetName Method

[image]

Revit 2024 API
TableCellCalculatedValueData..::..GetName Method
TableCellCalculatedValueData Class See Also Send Feedback
Gets the name of the calculated value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string GetName()
Visual Basic
Public Function GetName As String
Visual C++
public:
String^ GetName()

See Also

TableCellCalculatedValueData Class


TableCellCalculatedValueData Properties

[image] [image]

Revit 2024 API
TableCellCalculatedValueData Properties
TableCellCalculatedValueData Class See Also Send Feedback

The TableCellCalculatedValueData type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

TableCellCalculatedValueData Class


IsValidObject Property

[image]

Revit 2024 API
TableCellCalculatedValueData..::..IsValidObject Property
TableCellCalculatedValueData Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

TableCellCalculatedValueData Class


TableCellCombinedParameterData Members

[image] [image]

Revit 2024 API
TableCellCombinedParameterData Members
TableCellCombinedParameterData Class Methods Properties See Also Send Feedback

The TableCellCombinedParameterData type exposes the following members.

Methods

 | Name | Description
 | Create | construct a TableCellCombinedParameterData
Public method | Dispose | Releases all resources used by the TableCellCombinedParameterData
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CategoryId | Category id for this parameter
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ParamId | The parameter id
Public property | Prefix | The prefix for this parameter
Public property | SampleValue | The sample/example value for the parameter in text form
Public property | Separator | The separator for this parameter
Public property | Suffix | The suffix for this parameter

See Also

TableCellCombinedParameterData Class


TableCellCombinedParameterData Methods

[image] [image]

Revit 2024 API
TableCellCombinedParameterData Methods
TableCellCombinedParameterData Class See Also Send Feedback

The TableCellCombinedParameterData type exposes the following members.

Methods

 | Name | Description
 | Create | construct a TableCellCombinedParameterData
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TableCellCombinedParameterData Class


TableCellCombinedParameterData Properties

[image] [image]

Revit 2024 API
TableCellCombinedParameterData Properties
TableCellCombinedParameterData Class See Also Send Feedback

The TableCellCombinedParameterData type exposes the following members.

Properties

 | Name | Description
Public property | CategoryId | Category id for this parameter
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ParamId | The parameter id
Public property | Prefix | The prefix for this parameter
Public property | SampleValue | The sample/example value for the parameter in text form
Public property | Separator | The separator for this parameter
Public property | Suffix | The suffix for this parameter

See Also

TableCellCombinedParameterData Class


IsValidObject Property

[image]

Revit 2024 API
TableCellCombinedParameterData..::..IsValidObject Property
TableCellCombinedParameterData Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

TableCellCombinedParameterData Class


ParamId Property

[image]

Revit 2024 API
TableCellCombinedParameterData..::..ParamId Property
TableCellCombinedParameterData Class See Also Send Feedback
The parameter id

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElementId ParamId { get; set; }
Visual Basic
Public Property ParamId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ ParamId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

TableCellCombinedParameterData Class


Prefix Property

[image]

Revit 2024 API
TableCellCombinedParameterData..::..Prefix Property
TableCellCombinedParameterData Class See Also Send Feedback
The prefix for this parameter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string Prefix { get; set; }
Visual Basic
Public Property Prefix As String
    Get
    Set
Visual C++
public:
property String^ Prefix {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

TableCellCombinedParameterData Class


SampleValue Property

[image]

Revit 2024 API
TableCellCombinedParameterData..::..SampleValue Property
TableCellCombinedParameterData Class See Also Send Feedback
The sample/example value for the parameter in text form

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string SampleValue { get; set; }
Visual Basic
Public Property SampleValue As String
    Get
    Set
Visual C++
public:
property String^ SampleValue {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

TableCellCombinedParameterData Class


Separator Property

[image]

Revit 2024 API
TableCellCombinedParameterData..::..Separator Property
TableCellCombinedParameterData Class See Also Send Feedback
The separator for this parameter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string Separator { get; set; }
Visual Basic
Public Property Separator As String
    Get
    Set
Visual C++
public:
property String^ Separator {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

TableCellCombinedParameterData Class


TableCellStyle Members

[image] [image]

Revit 2024 API
TableCellStyle Members
TableCellStyle Class Constructors Methods Properties See Also Send Feedback

The TableCellStyle type exposes the following members.

Constructors

 | Name | Description
Public method | TableCellStyle()()()() | Constructs a new TableCellStyle with default settings.
Public method | TableCellStyle(TableCellStyle) | Constructs a new copy of the input TableCellStyle object.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the TableCellStyle
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCellStyleOverrideOptions | Gets cell style override options of this cell.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ResetOverride | Resets any overrides applied to this cell.
Public method | SetCellStyleOverrideOptions | Sets cell style override options of this cell.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BackgroundColor | The background color of this cell in the grid view.
Public property | BorderBottomLineStyle | The element id (GraphicsStyle element) for the bottom line of the cell border.
Public property | BorderLeftLineStyle | The element id (GraphicsStyle element) for the left line of the cell border.
Public property | BorderRightLineStyle | The element id (GraphicsStyle element) for the right line of the cell border.
Public property | BorderTopLineStyle | The element id (GraphicsStyle element) for the top line of the cell border.
Public property | FontHorizontalAlignment | The horizontal alignment style of text font.
Public property | FontName | The font used for this style
Public property | FontVerticalAlignment | The vertical alignment style of text font.
Public property | IsEnabled | Gets or sets the status whether this cell is enabled.
Public property | IsFontBold | Gets or sets whether the text font is set to bold of this cell.
Public property | IsFontItalic | Gets or sets whether the text font is set to italic of this cell.
Public property | IsFontUnderline | Gets or sets whether the text font is set to Underline of this cell.
Public property | IsInactivePhaseload | Gets or sets whether this is an inactive phase load cell.
Public property | IsOverridden | Indicates if the cell is overridden or not.
Public property | IsReadOnly | Gets or sets whether this cell is read only.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SheetBackgroundColor | The background color of this cell in the sheet view.
Public property | TextColor | The text color of this cell.
Public property | TextOrientation | The orientation of the cell (for vertical/horizontal text) with input in degrees multiplied by 10
Public property | TextSize | The text size.

See Also

TableCellStyle Class


TableCellStyle Constructor

[image] [image]

Revit 2024 API
TableCellStyle Constructor
TableCellStyle Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TableCellStyle()()()() | Constructs a new TableCellStyle with default settings.
Public method | TableCellStyle(TableCellStyle) | Constructs a new copy of the input TableCellStyle object.

See Also

TableCellStyle Class
TableCellStyle Members


TableCellStyle Constructor

[image]

Revit 2024 API
TableCellStyle Constructor
TableCellStyle Class See Also Send Feedback
Constructs a new TableCellStyle with default settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public TableCellStyle()
Visual Basic
Public Sub New
Visual C++
public:
TableCellStyle()

See Also

TableCellStyle Class
TableCellStyle Overload


TableCellStyle Methods

[image] [image]

Revit 2024 API
TableCellStyle Methods
TableCellStyle Class See Also Send Feedback

The TableCellStyle type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCellStyleOverrideOptions | Gets cell style override options of this cell.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ResetOverride | Resets any overrides applied to this cell.
Public method | SetCellStyleOverrideOptions | Sets cell style override options of this cell.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TableCellStyle Class


Dispose Method

[image]

Revit 2024 API
TableCellStyle..::..Dispose Method
TableCellStyle Class See Also Send Feedback
Releases all resources used by the TableCellStyle

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

TableCellStyle Class


GetCellStyleOverrideOptions Method

[image]

Revit 2024 API
TableCellStyle..::..GetCellStyleOverrideOptions Method
TableCellStyle Class See Also Send Feedback
Gets cell style override options of this cell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public TableCellStyleOverrideOptions GetCellStyleOverrideOptions()
Visual Basic
Public Function GetCellStyleOverrideOptions As TableCellStyleOverrideOptions
Visual C++
public:
TableCellStyleOverrideOptions^ GetCellStyleOverrideOptions()

See Also

TableCellStyle Class


SetCellStyleOverrideOptions Method

[image]

Revit 2024 API
TableCellStyle..::..SetCellStyleOverrideOptions Method
TableCellStyle Class Example See Also Send Feedback
Sets cell style override options of this cell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void SetCellStyleOverrideOptions(
    TableCellStyleOverrideOptions helper
)
Visual Basic
Public Sub SetCellStyleOverrideOptions ( _
    helper As TableCellStyleOverrideOptions _
)
Visual C++
public:
void SetCellStyleOverrideOptions(
    TableCellStyleOverrideOptions^ helper
)

Parameters

helper
Type: Autodesk.Revit.DB..::..TableCellStyleOverrideOptions

Examples

CopyC#
public static void ApplyFormattingToField(ViewSchedule schedule, int fieldIndex)
{
    // Get the field.
    ScheduleDefinition definition = schedule.Definition;
    ScheduleField field = definition.GetField(fieldIndex);

    // Build unit formatting for the field.
    FormatOptions options = field.GetFormatOptions();
    options.UseDefault = false;
    options.SetUnitTypeId(UnitTypeId.SquareInches);
    options.SetSymbolTypeId(SymbolTypeId.InSup2);

    // Build style overrides for the field
    // Use override options to indicate fields that are overridden and apply changes
    TableCellStyle style = field.GetStyle();
    TableCellStyleOverrideOptions overrideOptions = style.GetCellStyleOverrideOptions();
    overrideOptions.BackgroundColor = true;
    style.BackgroundColor = new Color(0x00, 0x00, 0xFF);
    overrideOptions.FontColor = true;
    style.TextColor = new Color(0xFF, 0xFF, 0xFF);
    overrideOptions.Italics = true;
    style.IsFontItalic = true;

    style.SetCellStyleOverrideOptions(overrideOptions);

    double width = field.GridColumnWidth;

    using (Transaction t = new Transaction(schedule.Document, "Set style etc"))
    {
        t.Start();
        field.SetStyle(style);
        field.SetFormatOptions(options);
        // Change column width (affects width in grid and on sheet) - units are in Revit length units - ft.
        field.GridColumnWidth = width + 0.5;
        t.Commit();
    }
}
CopyVB.NET
Public Shared Sub ApplyFormattingToField(schedule As ViewSchedule, fieldIndex As Integer)
    ' Get the field.
    Dim definition As ScheduleDefinition = schedule.Definition
    Dim field As ScheduleField = definition.GetField(fieldIndex)

    ' Build unit formatting for the field.
    Dim options As FormatOptions = field.GetFormatOptions()
    options.UseDefault = False
    options.SetUnitTypeId(UnitTypeId.SquareInches)
    options.SetSymbolTypeId(SymbolTypeId.InSup2)

    ' Build style overrides for the field
    ' Use override options to indicate fields that are overridden and apply changes
    Dim style As TableCellStyle = field.GetStyle()
    Dim overrideOptions As TableCellStyleOverrideOptions = style.GetCellStyleOverrideOptions()
    overrideOptions.BackgroundColor = True
    style.BackgroundColor = New Color(&H0, &H0, &HFF)
    overrideOptions.FontColor = True
    style.TextColor = New Color(&HFF, &HFF, &HFF)
    overrideOptions.Italics = True
    style.IsFontItalic = True

    style.SetCellStyleOverrideOptions(overrideOptions)

    Dim width As Double = field.GridColumnWidth

    Using t As New Transaction(schedule.Document, "Set style etc")
        t.Start()
        field.SetStyle(style)
        field.SetFormatOptions(options)
        ' Change column width (affects width in grid and on sheet) - units are in Revit length units - ft.
        field.GridColumnWidth = width + 0.5
        t.Commit()
    End Using
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

TableCellStyle Class


TableCellStyle Properties

[image] [image]

Revit 2024 API
TableCellStyle Properties
TableCellStyle Class See Also Send Feedback

The TableCellStyle type exposes the following members.

Properties

 | Name | Description
Public property | BackgroundColor | The background color of this cell in the grid view.
Public property | BorderBottomLineStyle | The element id (GraphicsStyle element) for the bottom line of the cell border.
Public property | BorderLeftLineStyle | The element id (GraphicsStyle element) for the left line of the cell border.
Public property | BorderRightLineStyle | The element id (GraphicsStyle element) for the right line of the cell border.
Public property | BorderTopLineStyle | The element id (GraphicsStyle element) for the top line of the cell border.
Public property | FontHorizontalAlignment | The horizontal alignment style of text font.
Public property | FontName | The font used for this style
Public property | FontVerticalAlignment | The vertical alignment style of text font.
Public property | IsEnabled | Gets or sets the status whether this cell is enabled.
Public property | IsFontBold | Gets or sets whether the text font is set to bold of this cell.
Public property | IsFontItalic | Gets or sets whether the text font is set to italic of this cell.
Public property | IsFontUnderline | Gets or sets whether the text font is set to Underline of this cell.
Public property | IsInactivePhaseload | Gets or sets whether this is an inactive phase load cell.
Public property | IsOverridden | Indicates if the cell is overridden or not.
Public property | IsReadOnly | Gets or sets whether this cell is read only.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SheetBackgroundColor | The background color of this cell in the sheet view.
Public property | TextColor | The text color of this cell.
Public property | TextOrientation | The orientation of the cell (for vertical/horizontal text) with input in degrees multiplied by 10
Public property | TextSize | The text size.

See Also

TableCellStyle Class


BackgroundColor Property

[image]

Revit 2024 API
TableCellStyle..::..BackgroundColor Property
TableCellStyle Class See Also Send Feedback
The background color of this cell in the grid view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Color BackgroundColor { get; set; }
Visual Basic
Public Property BackgroundColor As Color
    Get
    Set
Visual C++
public:
property Color^ BackgroundColor {
    Color^ get ();
    void set (Color^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

TableCellStyle Class


BorderBottomLineStyle Property

[image]

Revit 2024 API
TableCellStyle..::..BorderBottomLineStyle Property
TableCellStyle Class See Also Send Feedback
The element id (GraphicsStyle element) for the bottom line of the cell border.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElementId BorderBottomLineStyle { get; set; }
Visual Basic
Public Property BorderBottomLineStyle As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ BorderBottomLineStyle {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

TableCellStyle Class


BorderRightLineStyle Property

[image]

Revit 2024 API
TableCellStyle..::..BorderRightLineStyle Property
TableCellStyle Class See Also Send Feedback
The element id (GraphicsStyle element) for the right line of the cell border.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElementId BorderRightLineStyle { get; set; }
Visual Basic
Public Property BorderRightLineStyle As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ BorderRightLineStyle {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

TableCellStyle Class


BorderTopLineStyle Property

[image]

Revit 2024 API
TableCellStyle..::..BorderTopLineStyle Property
TableCellStyle Class See Also Send Feedback
The element id (GraphicsStyle element) for the top line of the cell border.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElementId BorderTopLineStyle { get; set; }
Visual Basic
Public Property BorderTopLineStyle As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ BorderTopLineStyle {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

TableCellStyle Class


FontHorizontalAlignment Property

[image]

Revit 2024 API
TableCellStyle..::..FontHorizontalAlignment Property
TableCellStyle Class See Also Send Feedback
The horizontal alignment style of text font.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public HorizontalAlignmentStyle FontHorizontalAlignment { get; set; }
Visual Basic
Public Property FontHorizontalAlignment As HorizontalAlignmentStyle
    Get
    Set
Visual C++
public:
property HorizontalAlignmentStyle FontHorizontalAlignment {
    HorizontalAlignmentStyle get ();
    void set (HorizontalAlignmentStyle value);
}

Field Value

Alignment style.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

TableCellStyle Class


FontName Property

[image]

Revit 2024 API
TableCellStyle..::..FontName Property
TableCellStyle Class See Also Send Feedback
The font used for this style

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string FontName { get; set; }
Visual Basic
Public Property FontName As String
    Get
    Set
Visual C++
public:
property String^ FontName {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

TableCellStyle Class


FontVerticalAlignment Property

[image]

Revit 2024 API
TableCellStyle..::..FontVerticalAlignment Property
TableCellStyle Class See Also Send Feedback
The vertical alignment style of text font.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public VerticalAlignmentStyle FontVerticalAlignment { get; set; }
Visual Basic
Public Property FontVerticalAlignment As VerticalAlignmentStyle
    Get
    Set
Visual C++
public:
property VerticalAlignmentStyle FontVerticalAlignment {
    VerticalAlignmentStyle get ();
    void set (VerticalAlignmentStyle value);
}

Field Value

Alignment style.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

TableCellStyle Class


IsEnabled Property

[image]

Revit 2024 API
TableCellStyle..::..IsEnabled Property
TableCellStyle Class See Also Send Feedback
Gets or sets the status whether this cell is enabled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsEnabled { get; set; }
Visual Basic
Public Property IsEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsEnabled {
    bool get ();
    void set (bool value);
}

Field Value

True if this cell is enabled; otherwise False.

See Also

TableCellStyle Class


IsFontItalic Property

[image]

Revit 2024 API
TableCellStyle..::..IsFontItalic Property
TableCellStyle Class See Also Send Feedback
Gets or sets whether the text font is set to italic of this cell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsFontItalic { get; set; }
Visual Basic
Public Property IsFontItalic As Boolean
    Get
    Set
Visual C++
public:
property bool IsFontItalic {
    bool get ();
    void set (bool value);
}

Field Value

true if the font is italic; otherwise false.

See Also

TableCellStyle Class


IsOverridden Property

[image]

Revit 2024 API
TableCellStyle..::..IsOverridden Property
TableCellStyle Class See Also Send Feedback
Indicates if the cell is overridden or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsOverridden { get; }
Visual Basic
Public ReadOnly Property IsOverridden As Boolean
    Get
Visual C++
public:
property bool IsOverridden {
    bool get ();
}

See Also

TableCellStyle Class


IsReadOnly Property

[image]

Revit 2024 API
TableCellStyle..::..IsReadOnly Property
TableCellStyle Class See Also Send Feedback
Gets or sets whether this cell is read only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsReadOnly { get; set; }
Visual Basic
Public Property IsReadOnly As Boolean
    Get
    Set
Visual C++
public:
property bool IsReadOnly {
    bool get ();
    void set (bool value);
}

Field Value

true if this cell is read only; otherwise false.

See Also

TableCellStyle Class


IsValidObject Property

[image]

Revit 2024 API
TableCellStyle..::..IsValidObject Property
TableCellStyle Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

TableCellStyle Class


TextColor Property

[image]

Revit 2024 API
TableCellStyle..::..TextColor Property
TableCellStyle Class See Also Send Feedback
The text color of this cell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Color TextColor { get; set; }
Visual Basic
Public Property TextColor As Color
    Get
    Set
Visual C++
public:
property Color^ TextColor {
    Color^ get ();
    void set (Color^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

TableCellStyle Class


TextOrientation Property

[image]

Revit 2024 API
TableCellStyle..::..TextOrientation Property
TableCellStyle Class See Also Send Feedback
The orientation of the cell (for vertical/horizontal text) with input in degrees multiplied by 10

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public int TextOrientation { get; set; }
Visual Basic
Public Property TextOrientation As Integer
    Get
    Set
Visual C++
public:
property int TextOrientation {
    int get ();
    void set (int value);
}

See Also

TableCellStyle Class


TableCellStyleOverrideOptions Class

[image]

Revit 2024 API
TableCellStyleOverrideOptions Class
Members See Also Send Feedback
This helper class represents the overridden characteristics of the associated cell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class TableCellStyleOverrideOptions : IDisposable
Visual Basic
Public Class TableCellStyleOverrideOptions _
    Implements IDisposable
Visual C++
public ref class TableCellStyleOverrideOptions : IDisposable

Remarks

The user can override the text appearance and cell graphic properties by setting the corresponding flag to true. The global base format will control the non-overridden characteristics.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..TableCellStyleOverrideOptions

See Also

TableCellStyleOverrideOptions Members


TableCellStyleOverrideOptions Members

[image] [image]

Revit 2024 API
TableCellStyleOverrideOptions Members
TableCellStyleOverrideOptions Class Constructors Methods Properties See Also Send Feedback

The TableCellStyleOverrideOptions type exposes the following members.

Constructors

 | Name | Description
Public method | TableCellStyleOverrideOptions()()()() | Creates a new instance with no style characteristics overridden.
Public method | TableCellStyleOverrideOptions(TableCellStyleOverrideOptions) | Creates a new instance by copying an existing instance.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the TableCellStyleOverrideOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetAllOverrides | Sets all overrides to a specific value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BackgroundColor | Indicates if the background color characteristic is overridden.
Public property | Bold | Indicates if the bold characteristic is overridden.
Public property | BorderBottomLineStyle | Indicates if the border bottom line style characteristic is overridden.
Public property | BorderLeftLineStyle | Indicates if the border left line style characteristic is overridden.
Public property | BorderLineStyle | Indicates if the border line style characteristic is overridden.
Public property | BorderRightLineStyle | Indicates if the border right line style characteristic is overridden.
Public property | BorderTopLineStyle | Indicates if the border top line style characteristic is overridden.
Public property | Font | Indicates if the font name characteristic is overridden.
Public property | FontColor | Indicates if the font color characteristic is overridden.
Public property | FontSize | Indicates if the font size characteristic is overridden.
Public property | HorizontalAlignment | Indicates if the horizontal alignment characteristic is overridden.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Italics | Indicates if the italics characteristic is overridden.
Public property | TextOrientation | Indicates if the text orientation characteristic is overridden.
Public property | Underline | Indicates if the underline characteristic is overridden.
Public property | VerticalAlignment | Indicates if the vertical alignment characteristic is overridden.

See Also

TableCellStyleOverrideOptions Class


TableCellStyleOverrideOptions Constructor

[image]

Revit 2024 API
TableCellStyleOverrideOptions Constructor
TableCellStyleOverrideOptions Class See Also Send Feedback
Creates a new instance with no style characteristics overridden.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public TableCellStyleOverrideOptions()
Visual Basic
Public Sub New
Visual C++
public:
TableCellStyleOverrideOptions()

See Also

TableCellStyleOverrideOptions Class
TableCellStyleOverrideOptions Overload


TableCellStyleOverrideOptions Methods

[image] [image]

Revit 2024 API
TableCellStyleOverrideOptions Methods
TableCellStyleOverrideOptions Class See Also Send Feedback

The TableCellStyleOverrideOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetAllOverrides | Sets all overrides to a specific value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TableCellStyleOverrideOptions Class


SetAllOverrides Method

[image]

Revit 2024 API
TableCellStyleOverrideOptions..::..SetAllOverrides Method
TableCellStyleOverrideOptions Class See Also Send Feedback
Sets all overrides to a specific value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void SetAllOverrides(
    bool bOverride
)
Visual Basic
Public Sub SetAllOverrides ( _
    bOverride As Boolean _
)
Visual C++
public:
void SetAllOverrides(
    bool bOverride
)

Parameters

bOverride
Type: System..::..Boolean
The value that will be assigned to all the overrides.

See Also

TableCellStyleOverrideOptions Class


TableCellStyleOverrideOptions Properties

[image] [image]

Revit 2024 API
TableCellStyleOverrideOptions Properties
TableCellStyleOverrideOptions Class See Also Send Feedback

The TableCellStyleOverrideOptions type exposes the following members.

Properties

 | Name | Description
Public property | BackgroundColor | Indicates if the background color characteristic is overridden.
Public property | Bold | Indicates if the bold characteristic is overridden.
Public property | BorderBottomLineStyle | Indicates if the border bottom line style characteristic is overridden.
Public property | BorderLeftLineStyle | Indicates if the border left line style characteristic is overridden.
Public property | BorderLineStyle | Indicates if the border line style characteristic is overridden.
Public property | BorderRightLineStyle | Indicates if the border right line style characteristic is overridden.
Public property | BorderTopLineStyle | Indicates if the border top line style characteristic is overridden.
Public property | Font | Indicates if the font name characteristic is overridden.
Public property | FontColor | Indicates if the font color characteristic is overridden.
Public property | FontSize | Indicates if the font size characteristic is overridden.
Public property | HorizontalAlignment | Indicates if the horizontal alignment characteristic is overridden.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Italics | Indicates if the italics characteristic is overridden.
Public property | TextOrientation | Indicates if the text orientation characteristic is overridden.
Public property | Underline | Indicates if the underline characteristic is overridden.
Public property | VerticalAlignment | Indicates if the vertical alignment characteristic is overridden.

See Also

TableCellStyleOverrideOptions Class


BackgroundColor Property

[image]

Revit 2024 API
TableCellStyleOverrideOptions..::..BackgroundColor Property
TableCellStyleOverrideOptions Class See Also Send Feedback
Indicates if the background color characteristic is overridden.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool BackgroundColor { get; set; }
Visual Basic
Public Property BackgroundColor As Boolean
    Get
    Set
Visual C++
public:
property bool BackgroundColor {
    bool get ();
    void set (bool value);
}

See Also

TableCellStyleOverrideOptions Class


Bold Property

[image]

Revit 2024 API
TableCellStyleOverrideOptions..::..Bold Property
TableCellStyleOverrideOptions Class See Also Send Feedback
Indicates if the bold characteristic is overridden.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool Bold { get; set; }
Visual Basic
Public Property Bold As Boolean
    Get
    Set
Visual C++
public:
property bool Bold {
    bool get ();
    void set (bool value);
}

See Also

TableCellStyleOverrideOptions Class


BorderBottomLineStyle Property

[image]

Revit 2024 API
TableCellStyleOverrideOptions..::..BorderBottomLineStyle Property
TableCellStyleOverrideOptions Class See Also Send Feedback
Indicates if the border bottom line style characteristic is overridden.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool BorderBottomLineStyle { get; set; }
Visual Basic
Public Property BorderBottomLineStyle As Boolean
    Get
    Set
Visual C++
public:
property bool BorderBottomLineStyle {
    bool get ();
    void set (bool value);
}

See Also

TableCellStyleOverrideOptions Class


BorderLineStyle Property

[image]

Revit 2024 API
TableCellStyleOverrideOptions..::..BorderLineStyle Property
TableCellStyleOverrideOptions Class See Also Send Feedback
Indicates if the border line style characteristic is overridden.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool BorderLineStyle { get; set; }
Visual Basic
Public Property BorderLineStyle As Boolean
    Get
    Set
Visual C++
public:
property bool BorderLineStyle {
    bool get ();
    void set (bool value);
}

See Also

TableCellStyleOverrideOptions Class


BorderRightLineStyle Property

[image]

Revit 2024 API
TableCellStyleOverrideOptions..::..BorderRightLineStyle Property
TableCellStyleOverrideOptions Class See Also Send Feedback
Indicates if the border right line style characteristic is overridden.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool BorderRightLineStyle { get; set; }
Visual Basic
Public Property BorderRightLineStyle As Boolean
    Get
    Set
Visual C++
public:
property bool BorderRightLineStyle {
    bool get ();
    void set (bool value);
}

See Also

TableCellStyleOverrideOptions Class


BorderTopLineStyle Property

[image]

Revit 2024 API
TableCellStyleOverrideOptions..::..BorderTopLineStyle Property
TableCellStyleOverrideOptions Class See Also Send Feedback
Indicates if the border top line style characteristic is overridden.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool BorderTopLineStyle { get; set; }
Visual Basic
Public Property BorderTopLineStyle As Boolean
    Get
    Set
Visual C++
public:
property bool BorderTopLineStyle {
    bool get ();
    void set (bool value);
}

See Also

TableCellStyleOverrideOptions Class


Font Property

[image]

Revit 2024 API
TableCellStyleOverrideOptions..::..Font Property
TableCellStyleOverrideOptions Class See Also Send Feedback
Indicates if the font name characteristic is overridden.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool Font { get; set; }
Visual Basic
Public Property Font As Boolean
    Get
    Set
Visual C++
public:
property bool Font {
    bool get ();
    void set (bool value);
}

See Also

TableCellStyleOverrideOptions Class


FontColor Property

[image]

Revit 2024 API
TableCellStyleOverrideOptions..::..FontColor Property
TableCellStyleOverrideOptions Class See Also Send Feedback
Indicates if the font color characteristic is overridden.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool FontColor { get; set; }
Visual Basic
Public Property FontColor As Boolean
    Get
    Set
Visual C++
public:
property bool FontColor {
    bool get ();
    void set (bool value);
}

See Also

TableCellStyleOverrideOptions Class


FontSize Property

[image]

Revit 2024 API
TableCellStyleOverrideOptions..::..FontSize Property
TableCellStyleOverrideOptions Class See Also Send Feedback
Indicates if the font size characteristic is overridden.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool FontSize { get; set; }
Visual Basic
Public Property FontSize As Boolean
    Get
    Set
Visual C++
public:
property bool FontSize {
    bool get ();
    void set (bool value);
}

See Also

TableCellStyleOverrideOptions Class


HorizontalAlignment Property

[image]

Revit 2024 API
TableCellStyleOverrideOptions..::..HorizontalAlignment Property
TableCellStyleOverrideOptions Class See Also Send Feedback
Indicates if the horizontal alignment characteristic is overridden.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool HorizontalAlignment { get; set; }
Visual Basic
Public Property HorizontalAlignment As Boolean
    Get
    Set
Visual C++
public:
property bool HorizontalAlignment {
    bool get ();
    void set (bool value);
}

See Also

TableCellStyleOverrideOptions Class


IsValidObject Property

[image]

Revit 2024 API
TableCellStyleOverrideOptions..::..IsValidObject Property
TableCellStyleOverrideOptions Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

TableCellStyleOverrideOptions Class


Italics Property

[image]

Revit 2024 API
TableCellStyleOverrideOptions..::..Italics Property
TableCellStyleOverrideOptions Class See Also Send Feedback
Indicates if the italics characteristic is overridden.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool Italics { get; set; }
Visual Basic
Public Property Italics As Boolean
    Get
    Set
Visual C++
public:
property bool Italics {
    bool get ();
    void set (bool value);
}

See Also

TableCellStyleOverrideOptions Class


TextOrientation Property

[image]

Revit 2024 API
TableCellStyleOverrideOptions..::..TextOrientation Property
TableCellStyleOverrideOptions Class See Also Send Feedback
Indicates if the text orientation characteristic is overridden.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool TextOrientation { get; set; }
Visual Basic
Public Property TextOrientation As Boolean
    Get
    Set
Visual C++
public:
property bool TextOrientation {
    bool get ();
    void set (bool value);
}

See Also

TableCellStyleOverrideOptions Class


Underline Property

[image]

Revit 2024 API
TableCellStyleOverrideOptions..::..Underline Property
TableCellStyleOverrideOptions Class See Also Send Feedback
Indicates if the underline characteristic is overridden.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool Underline { get; set; }
Visual Basic
Public Property Underline As Boolean
    Get
    Set
Visual C++
public:
property bool Underline {
    bool get ();
    void set (bool value);
}

See Also

TableCellStyleOverrideOptions Class


VerticalAlignment Property

[image]

Revit 2024 API
TableCellStyleOverrideOptions..::..VerticalAlignment Property
TableCellStyleOverrideOptions Class See Also Send Feedback
Indicates if the vertical alignment characteristic is overridden.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool VerticalAlignment { get; set; }
Visual Basic
Public Property VerticalAlignment As Boolean
    Get
    Set
Visual C++
public:
property bool VerticalAlignment {
    bool get ();
    void set (bool value);
}

See Also

TableCellStyleOverrideOptions Class


TableData Class

[image]

Revit 2024 API
TableData Class
Members See Also Send Feedback
The TableData class is implemented to hold most of the data that describe the style of the rows, columns, and cells in a table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class TableData : IDisposable
Visual Basic
Public Class TableData _
    Implements IDisposable
Visual C++
public ref class TableData : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..TableData
Autodesk.Revit.DB.Electrical..::..PanelScheduleData

See Also

TableData Members


TableData Members

[image] [image]

Revit 2024 API
TableData Members
TableData Class Methods Properties See Also Send Feedback

The TableData type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the TableData
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSectionData(Int32) | Returns the section data array element at the specified index.
Public method | GetSectionData(SectionType) | Returns the pointer to the section data array element at the specified section type.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Checks if this element is equal in value to the other element.
Public method | IsValidZoomLevel | Verifies if the value of zoom level is valid.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FreezeColumnsAndRows | set to true if the columns and rows should be unmovable by the slider grips
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | NumberOfSections | Gets the number of items in section data array.
Public property | Width | Gets or sets the table width in feet
Public property | WidthInPixels | Gets the width of the panel schedule in logical pixels
Public property | ZoomLevel | The value of zoom level for corresponding TableView.

See Also

TableData Class


TableData Methods

[image] [image]

Revit 2024 API
TableData Methods
TableData Class See Also Send Feedback

The TableData type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSectionData(Int32) | Returns the section data array element at the specified index.
Public method | GetSectionData(SectionType) | Returns the pointer to the section data array element at the specified section type.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Checks if this element is equal in value to the other element.
Public method | IsValidZoomLevel | Verifies if the value of zoom level is valid.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TableData Class


Dispose Method

[image]

Revit 2024 API
TableData..::..Dispose Method
TableData Class See Also Send Feedback
Releases all resources used by the TableData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

TableData Class


GetSectionData Method (Int32)

[image]

Revit 2024 API
TableData..::..GetSectionData Method (Int32)
TableData Class See Also Send Feedback
Returns the section data array element at the specified index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public TableSectionData GetSectionData(
    int nIndex
)
Visual Basic
Public Function GetSectionData ( _
    nIndex As Integer _
) As TableSectionData
Visual C++
public:
TableSectionData^ GetSectionData(
    int nIndex
)

Parameters

nIndex
Type: System..::..Int32
The index of section data array. If the index is out of the boundary of section data array, nullNothingnullptra null reference (Nothing in Visual Basic) is returned.

See Also

TableData Class
GetSectionData Overload


GetSectionData Method (SectionType)

[image]

Revit 2024 API
TableData..::..GetSectionData Method (SectionType)
TableData Class See Also Send Feedback
Returns the pointer to the section data array element at the specified section type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public TableSectionData GetSectionData(
    SectionType sectionType
)
Visual Basic
Public Function GetSectionData ( _
    sectionType As SectionType _
) As TableSectionData
Visual C++
public:
TableSectionData^ GetSectionData(
    SectionType sectionType
)

Parameters

sectionType
Type: Autodesk.Revit.DB..::..SectionType
The section type of section data array. If the integral value of the section type is out of the boundary of section data array, null is returned.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

TableData Class
GetSectionData Overload


IsEqual Method

[image]

Revit 2024 API
TableData..::..IsEqual Method
TableData Class See Also Send Feedback
Checks if this element is equal in value to the other element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsEqual(
    TableData OtherElem
)
Visual Basic
Public Function IsEqual ( _
    OtherElem As TableData _
) As Boolean
Visual C++
public:
bool IsEqual(
    TableData^ OtherElem
)

Parameters

OtherElem
Type: Autodesk.Revit.DB..::..TableData

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

TableData Class


IsValidZoomLevel Method

[image]

Revit 2024 API
TableData..::..IsValidZoomLevel Method
TableData Class See Also Send Feedback
Verifies if the value of zoom level is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019.2

Syntax

C#
public bool IsValidZoomLevel(
    int zoomLevel
)
Visual Basic
Public Function IsValidZoomLevel ( _
    zoomLevel As Integer _
) As Boolean
Visual C++
public:
bool IsValidZoomLevel(
    int zoomLevel
)

Parameters

zoomLevel
Type: System..::..Int32
The value of zoom level.

Return Value

True if the value of zoom level is inside of the acceptable range, false otherwise.

See Also

TableData Class


TableData Properties

[image] [image]

Revit 2024 API
TableData Properties
TableData Class See Also Send Feedback

The TableData type exposes the following members.

Properties

 | Name | Description
Public property | FreezeColumnsAndRows | set to true if the columns and rows should be unmovable by the slider grips
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | NumberOfSections | Gets the number of items in section data array.
Public property | Width | Gets or sets the table width in feet
Public property | WidthInPixels | Gets the width of the panel schedule in logical pixels
Public property | ZoomLevel | The value of zoom level for corresponding TableView.

See Also

TableData Class


FreezeColumnsAndRows Property

[image]

Revit 2024 API
TableData..::..FreezeColumnsAndRows Property
TableData Class See Also Send Feedback
set to true if the columns and rows should be unmovable by the slider grips

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool FreezeColumnsAndRows { get; set; }
Visual Basic
Public Property FreezeColumnsAndRows As Boolean
    Get
    Set
Visual C++
public:
property bool FreezeColumnsAndRows {
    bool get ();
    void set (bool value);
}

See Also

TableData Class


IsValidObject Property

[image]

Revit 2024 API
TableData..::..IsValidObject Property
TableData Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

TableData Class


NumberOfSections Property

[image]

Revit 2024 API
TableData..::..NumberOfSections Property
TableData Class See Also Send Feedback
Gets the number of items in section data array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public int NumberOfSections { get; }
Visual Basic
Public ReadOnly Property NumberOfSections As Integer
    Get
Visual C++
public:
property int NumberOfSections {
    int get ();
}

See Also

TableData Class


Width Property

[image]

Revit 2024 API
TableData..::..Width Property
TableData Class See Also Send Feedback
Gets or sets the table width in feet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double Width { get; set; }
Visual Basic
Public Property Width As Double
    Get
    Set
Visual C++
public:
property double Width {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The table width is outside of the acceptable range.

See Also

TableData Class


WidthInPixels Property

[image]

Revit 2024 API
TableData..::..WidthInPixels Property
TableData Class See Also Send Feedback
Gets the width of the panel schedule in logical pixels

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public int WidthInPixels { get; }
Visual Basic
Public ReadOnly Property WidthInPixels As Integer
    Get
Visual C++
public:
property int WidthInPixels {
    int get ();
}

See Also

TableData Class


TableMergedCell Members

[image] [image]

Revit 2024 API
TableMergedCell Members
TableMergedCell Class Constructors Methods Properties See Also Send Feedback

The TableMergedCell type exposes the following members.

Constructors

 | Name | Description
Public method | TableMergedCell()()()() | Default constructor.
Public method | TableMergedCell(Int32, Int32, Int32, Int32) | Constructor.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the TableMergedCell
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Bottom | Specifies the row index of the bottom-right corner of a table grid.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Left | Specifies the column index of the top-left corner of a table grid.
Public property | Right | Specifies the column index of the bottom-right corner of a table grid.
Public property | Top | Specifies the row index of the top-left corner of a table grid.

See Also

TableMergedCell Class


TableMergedCell Constructor

[image] [image]

Revit 2024 API
TableMergedCell Constructor
TableMergedCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TableMergedCell()()()() | Default constructor.
Public method | TableMergedCell(Int32, Int32, Int32, Int32) | Constructor.

See Also

TableMergedCell Class
TableMergedCell Members


TableMergedCell Constructor

[image]

Revit 2024 API
TableMergedCell Constructor
TableMergedCell Class See Also Send Feedback
Default constructor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public TableMergedCell()
Visual Basic
Public Sub New
Visual C++
public:
TableMergedCell()

See Also

TableMergedCell Class
TableMergedCell Overload


TableMergedCell Constructor (Int32, Int32, Int32, Int32)

[image]

Revit 2024 API
TableMergedCell Constructor (Int32, Int32, Int32, Int32)
TableMergedCell Class See Also Send Feedback
Constructor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public TableMergedCell(
    int top,
    int left,
    int bottom,
    int right
)
Visual Basic
Public Sub New ( _
    top As Integer, _
    left As Integer, _
    bottom As Integer, _
    right As Integer _
)
Visual C++
public:
TableMergedCell(
    int top,
    int left,
    int bottom,
    int right
)

Parameters

top
Type: System..::..Int32
Row index of the top-left of a table grid.
left
Type: System..::..Int32
Column index of the top-left of a table grid.
bottom
Type: System..::..Int32
Row index of the bottom-right of a table grid.
right
Type: System..::..Int32
Column index of the bottom-right of a table grid.

See Also

TableMergedCell Class
TableMergedCell Overload


Dispose Method

[image]

Revit 2024 API
TableMergedCell..::..Dispose Method
TableMergedCell Class See Also Send Feedback
Releases all resources used by the TableMergedCell

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

TableMergedCell Class


TableMergedCell Properties

[image] [image]

Revit 2024 API
TableMergedCell Properties
TableMergedCell Class See Also Send Feedback

The TableMergedCell type exposes the following members.

Properties

 | Name | Description
Public property | Bottom | Specifies the row index of the bottom-right corner of a table grid.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Left | Specifies the column index of the top-left corner of a table grid.
Public property | Right | Specifies the column index of the bottom-right corner of a table grid.
Public property | Top | Specifies the row index of the top-left corner of a table grid.

See Also

TableMergedCell Class


Bottom Property

[image]

Revit 2024 API
TableMergedCell..::..Bottom Property
TableMergedCell Class See Also Send Feedback
Specifies the row index of the bottom-right corner of a table grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public int Bottom { get; set; }
Visual Basic
Public Property Bottom As Integer
    Get
    Set
Visual C++
public:
property int Bottom {
    int get ();
    void set (int value);
}

See Also

TableMergedCell Class


IsValidObject Property

[image]

Revit 2024 API
TableMergedCell..::..IsValidObject Property
TableMergedCell Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

TableMergedCell Class


Left Property

[image]

Revit 2024 API
TableMergedCell..::..Left Property
TableMergedCell Class See Also Send Feedback
Specifies the column index of the top-left corner of a table grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public int Left { get; set; }
Visual Basic
Public Property Left As Integer
    Get
    Set
Visual C++
public:
property int Left {
    int get ();
    void set (int value);
}

See Also

TableMergedCell Class


Right Property

[image]

Revit 2024 API
TableMergedCell..::..Right Property
TableMergedCell Class See Also Send Feedback
Specifies the column index of the bottom-right corner of a table grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public int Right { get; set; }
Visual Basic
Public Property Right As Integer
    Get
    Set
Visual C++
public:
property int Right {
    int get ();
    void set (int value);
}

See Also

TableMergedCell Class


TableSectionData Class

[image]

Revit 2024 API
TableSectionData Class
Members See Also Send Feedback
The TableSectionData class represents a serialized version of an instance of section table data. The class holds row, column and cell data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class TableSectionData : IDisposable
Visual Basic
Public Class TableSectionData _
    Implements IDisposable
Visual C++
public ref class TableSectionData : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..TableSectionData

See Also

TableSectionData Members


TableSectionData Members

[image] [image]

Revit 2024 API
TableSectionData Members
TableSectionData Class Methods Properties See Also Send Feedback

The TableSectionData type exposes the following members.

Methods

 | Name | Description
Public method | AllowOverrideCellStyle | Identifies if the style can be overridden in the given cell.
Public method | CanInsertColumn | Verifies if a new column can be inserted at the given index.
Public method | CanInsertRow | Verifies if a new row can be inserted at the given index.
Public method | CanRemoveColumn | Verifies that if the column at the given index can be removed.
Public method | CanRemoveRow | Verifies that if the row at the given index can be removed..
Public method | ClearCell | Deletes text or image, or removes parameter of this cell.
Public method | Dispose | Releases all resources used by the TableSectionData
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCellCalculatedValue(Int32) | Gets the calculated value for the specified column
Public method | GetCellCalculatedValue(Int32, Int32) | Gets the calculated value for the specified cell
Public method | GetCellCategoryId(Int32) | Returns a column's ParamId Associated with the paramId to find the correct element
Public method | GetCellCategoryId(Int32, Int32) | Returns a cell's CategoryId and if no CategoryId exists for this cell, it would come from the column. Associated with the paramId to find the correct element.
Public method | GetCellCombinedParameters(Int32) | Returns an array of combined parameter data for the specified column
Public method | GetCellCombinedParameters(Int32, Int32) | Returns an array of combined parameter data for the specified cell
Public method | GetCellFormatOptions(Int32, Document) | Returns a column's cell FormatOptions and if no FormatOptions exists for this column, it would come from the section.
Public method | GetCellFormatOptions(Int32, Int32, Document) | Returns a cell's FormatOptions and if no FormatOptions exists for this cell, it would come from the column, or the row, or the section.
Public method | GetCellParamId(Int32) | Returns a column's ParamId
Public method | GetCellParamId(Int32, Int32) | Returns a cell's ParamId and if no ParamId exists for this cell, it would come from the column
Public method | GetCellSpec | Gets the spec describing values of a cell, if applicable.
Public method | GetCellText | Returns the text shown by this cell, if the cell's type is CellType.Text or CellType.ParameterText or CellType.CustomField.
Public method | GetCellType(Int32) | Returns a column's cell type and if no type exists for this column, it would come from the section
Public method | GetCellType(Int32, Int32) | Returns a cell's Type and if no Type exists for this cell, it would come from the column, or the row, or the section
Public method | GetColumnWidth | Returns a column's width in feet
Public method | GetColumnWidthInPixels | This returns a column's width in logical pixels
Public method | GetCustomFieldId | Gets custom field id from the cell.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMergedCell | Gets the whole merged cell that this cell is a part of.
Public method | GetRowHeight | Returns a row's height in feet
Public method | GetRowHeightInPixels | This returns a row's height in logical pixels
Public method | GetTableCellStyle | Returns a cell's style and if no style exists for this cell, it would come from the column, or the section
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertColumn | Inserts a new column at the specified index relative to the current set of columns.
Public method | InsertImage | Inserts a image in the given cell.
Public method | InsertRow | Inserts a row data at a specified index.
Public method | IsAcceptableParamIdAndCategoryId(ElementId, ElementId) | Identifies if the given parameter id and category id can be assigned to a cell in this table.
Public method | IsAcceptableParamIdAndCategoryId(Int32, ElementId, ElementId) | Identifies if the given parameter id and category id can be assigned to a cell in the given row in this table.
Public method | IsCellFormattable | Determines whether the cell is formattable or not
Public method | IsCellOverridden(Int32) | Indicates if the column is overridden or not.
Public method | IsCellOverridden(Int32, Int32) | Indicates if the cell is overridden or not.
Public method | IsDataOutOfDate | Indicates whether the data in this section is out of date.
Public method | IsValidColumnNumber | Verifies if the column number is valid.
Public method | IsValidImageSymbolId | Identifies if the element id represents a valid ImageSymbol element.
Public method | IsValidRowNumber | Verifies if the row number is valid.
Public method | MergeCells | Merges cells for the given area.
Public method | RefreshData | Rebuilds the data in this section if it is out of date.
Public method | RemoveColumn | Removes a column data at a specified index.
Public method | RemoveRow | Removes a row data at a specified index.
Public method | ResetCellOverride(Int32) | Resets the override of the column.
Public method | ResetCellOverride(Int32, Int32) | Resets the override of the cell.
Public method | SetCellCalculatedValue(Int32, TableCellCalculatedValueData) | Allows the caller to set the calculated value for a specified column
Public method | SetCellCalculatedValue(Int32, Int32, TableCellCalculatedValueData) | Allows the caller to set the calculated value for a specified cell
Public method | SetCellCombinedParameters(Int32, IList<(Of <<'(TableCellCombinedParameterData>)>>)) | Allows the caller to set combined parameter for a specified column
Public method | SetCellCombinedParameters(Int32, Int32, IList<(Of <<'(TableCellCombinedParameterData>)>>)) | Allows the caller to set combined parameter for a specified cell
Public method | SetCellFormatOptions | Sets a cell's FormatOptions.
Public method | SetCellParamIdAndCategoryId(Int32, ElementId, ElementId) | Sets a column's category and parameter Id
Public method | SetCellParamIdAndCategoryId(Int32, Int32, ElementId, ElementId) | Sets a cell's category and parameter Id
Public method | SetCellStyle(TableCellStyle) | Sets a section's style
Public method | SetCellStyle(Int32, TableCellStyle) | Sets a column's style.
Public method | SetCellStyle(Int32, Int32, TableCellStyle) | Sets a cell's style
Public method | SetCellText | Sets a cell's to display the specified text.
Public method | SetCellType(Int32, CellType) | Sets a column's cell type
Public method | SetCellType(Int32, Int32, CellType) | Sets a cell's Type
Public method | SetColumnWidth | Sets a column's width in feet
Public method | SetColumnWidthInPixels | This sets a column's width in logical pixels
Public method | SetMergedCell | Sets the merged cell that this cell is a part of.
Public method | SetRowHeight | Sets a row's height in feet
Public method | SetRowHeightInPixels | This sets a row's height in logical pixels
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FirstColumnNumber | The first column in this section of the table.
Public property | FirstRowNumber | The first row in this section of the table.
Public property | HideSection | Whether or not the section is hidden.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LastColumnNumber | The last column in this section of the table.
Public property | LastRowNumber | The last row in this section of the table.
Public property | NeedsRefresh | Indicates if the table data need to refresh.
Public property | NumberOfColumns | Gets or sets the number of items in column data array.
Public property | NumberOfRows | Gets or sets the number of items in row data array.

See Also

TableSectionData Class


TableSectionData Methods

[image] [image]

Revit 2024 API
TableSectionData Methods
TableSectionData Class See Also Send Feedback

The TableSectionData type exposes the following members.

Methods

 | Name | Description
Public method | AllowOverrideCellStyle | Identifies if the style can be overridden in the given cell.
Public method | CanInsertColumn | Verifies if a new column can be inserted at the given index.
Public method | CanInsertRow | Verifies if a new row can be inserted at the given index.
Public method | CanRemoveColumn | Verifies that if the column at the given index can be removed.
Public method | CanRemoveRow | Verifies that if the row at the given index can be removed..
Public method | ClearCell | Deletes text or image, or removes parameter of this cell.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCellCalculatedValue(Int32) | Gets the calculated value for the specified column
Public method | GetCellCalculatedValue(Int32, Int32) | Gets the calculated value for the specified cell
Public method | GetCellCategoryId(Int32) | Returns a column's ParamId Associated with the paramId to find the correct element
Public method | GetCellCategoryId(Int32, Int32) | Returns a cell's CategoryId and if no CategoryId exists for this cell, it would come from the column. Associated with the paramId to find the correct element.
Public method | GetCellCombinedParameters(Int32) | Returns an array of combined parameter data for the specified column
Public method | GetCellCombinedParameters(Int32, Int32) | Returns an array of combined parameter data for the specified cell
Public method | GetCellFormatOptions(Int32, Document) | Returns a column's cell FormatOptions and if no FormatOptions exists for this column, it would come from the section.
Public method | GetCellFormatOptions(Int32, Int32, Document) | Returns a cell's FormatOptions and if no FormatOptions exists for this cell, it would come from the column, or the row, or the section.
Public method | GetCellParamId(Int32) | Returns a column's ParamId
Public method | GetCellParamId(Int32, Int32) | Returns a cell's ParamId and if no ParamId exists for this cell, it would come from the column
Public method | GetCellSpec | Gets the spec describing values of a cell, if applicable.
Public method | GetCellText | Returns the text shown by this cell, if the cell's type is CellType.Text or CellType.ParameterText or CellType.CustomField.
Public method | GetCellType(Int32) | Returns a column's cell type and if no type exists for this column, it would come from the section
Public method | GetCellType(Int32, Int32) | Returns a cell's Type and if no Type exists for this cell, it would come from the column, or the row, or the section
Public method | GetColumnWidth | Returns a column's width in feet
Public method | GetColumnWidthInPixels | This returns a column's width in logical pixels
Public method | GetCustomFieldId | Gets custom field id from the cell.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMergedCell | Gets the whole merged cell that this cell is a part of.
Public method | GetRowHeight | Returns a row's height in feet
Public method | GetRowHeightInPixels | This returns a row's height in logical pixels
Public method | GetTableCellStyle | Returns a cell's style and if no style exists for this cell, it would come from the column, or the section
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InsertColumn | Inserts a new column at the specified index relative to the current set of columns.
Public method | InsertImage | Inserts a image in the given cell.
Public method | InsertRow | Inserts a row data at a specified index.
Public method | IsAcceptableParamIdAndCategoryId(ElementId, ElementId) | Identifies if the given parameter id and category id can be assigned to a cell in this table.
Public method | IsAcceptableParamIdAndCategoryId(Int32, ElementId, ElementId) | Identifies if the given parameter id and category id can be assigned to a cell in the given row in this table.
Public method | IsCellFormattable | Determines whether the cell is formattable or not
Public method | IsCellOverridden(Int32) | Indicates if the column is overridden or not.
Public method | IsCellOverridden(Int32, Int32) | Indicates if the cell is overridden or not.
Public method | IsDataOutOfDate | Indicates whether the data in this section is out of date.
Public method | IsValidColumnNumber | Verifies if the column number is valid.
Public method | IsValidImageSymbolId | Identifies if the element id represents a valid ImageSymbol element.
Public method | IsValidRowNumber | Verifies if the row number is valid.
Public method | MergeCells | Merges cells for the given area.
Public method | RefreshData | Rebuilds the data in this section if it is out of date.
Public method | RemoveColumn | Removes a column data at a specified index.
Public method | RemoveRow | Removes a row data at a specified index.
Public method | ResetCellOverride(Int32) | Resets the override of the column.
Public method | ResetCellOverride(Int32, Int32) | Resets the override of the cell.
Public method | SetCellCalculatedValue(Int32, TableCellCalculatedValueData) | Allows the caller to set the calculated value for a specified column
Public method | SetCellCalculatedValue(Int32, Int32, TableCellCalculatedValueData) | Allows the caller to set the calculated value for a specified cell
Public method | SetCellCombinedParameters(Int32, IList<(Of <<'(TableCellCombinedParameterData>)>>)) | Allows the caller to set combined parameter for a specified column
Public method | SetCellCombinedParameters(Int32, Int32, IList<(Of <<'(TableCellCombinedParameterData>)>>)) | Allows the caller to set combined parameter for a specified cell
Public method | SetCellFormatOptions | Sets a cell's FormatOptions.
Public method | SetCellParamIdAndCategoryId(Int32, ElementId, ElementId) | Sets a column's category and parameter Id
Public method | SetCellParamIdAndCategoryId(Int32, Int32, ElementId, ElementId) | Sets a cell's category and parameter Id
Public method | SetCellStyle(TableCellStyle) | Sets a section's style
Public method | SetCellStyle(Int32, TableCellStyle) | Sets a column's style.
Public method | SetCellStyle(Int32, Int32, TableCellStyle) | Sets a cell's style
Public method | SetCellText | Sets a cell's to display the specified text.
Public method | SetCellType(Int32, CellType) | Sets a column's cell type
Public method | SetCellType(Int32, Int32, CellType) | Sets a cell's Type
Public method | SetColumnWidth | Sets a column's width in feet
Public method | SetColumnWidthInPixels | This sets a column's width in logical pixels
Public method | SetMergedCell | Sets the merged cell that this cell is a part of.
Public method | SetRowHeight | Sets a row's height in feet
Public method | SetRowHeightInPixels | This sets a row's height in logical pixels
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TableSectionData Class


AllowOverrideCellStyle Method

[image]

Revit 2024 API
TableSectionData..::..AllowOverrideCellStyle Method
TableSectionData Class See Also Send Feedback
Identifies if the style can be overridden in the given cell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool AllowOverrideCellStyle(
    int nRow,
    int nCol
)
Visual Basic
Public Function AllowOverrideCellStyle ( _
    nRow As Integer, _
    nCol As Integer _
) As Boolean
Visual C++
public:
bool AllowOverrideCellStyle(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::..Int32
nCol
Type: System..::..Int32

Return Value

True if allow to override cell style.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given row number nRow is invalid. -or- The given column number nCol is invalid.

See Also

TableSectionData Class


CanInsertColumn Method

[image]

Revit 2024 API
TableSectionData..::..CanInsertColumn Method
TableSectionData Class See Also Send Feedback
Verifies if a new column can be inserted at the given index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool CanInsertColumn(
    int nIndex
)
Visual Basic
Public Function CanInsertColumn ( _
    nIndex As Integer _
) As Boolean
Visual C++
public:
bool CanInsertColumn(
    int nIndex
)

Parameters

nIndex
Type: System..::..Int32
An integer index.

Return Value

True if the column can be inserted, false otherwise.

See Also

TableSectionData Class


CanInsertRow Method

[image]

Revit 2024 API
TableSectionData..::..CanInsertRow Method
TableSectionData Class See Also Send Feedback
Verifies if a new row can be inserted at the given index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool CanInsertRow(
    int nIndex
)
Visual Basic
Public Function CanInsertRow ( _
    nIndex As Integer _
) As Boolean
Visual C++
public:
bool CanInsertRow(
    int nIndex
)

Parameters

nIndex
Type: System..::..Int32

Return Value

True if the row can be inserted, false otherwise.

See Also

TableSectionData Class


CanRemoveRow Method

[image]

Revit 2024 API
TableSectionData..::..CanRemoveRow Method
TableSectionData Class See Also Send Feedback
Verifies that if the row at the given index can be removed..

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool CanRemoveRow(
    int nIndex
)
Visual Basic
Public Function CanRemoveRow ( _
    nIndex As Integer _
) As Boolean
Visual C++
public:
bool CanRemoveRow(
    int nIndex
)

Parameters

nIndex
Type: System..::..Int32
An integer index.

Return Value

True if the row can be removed, false otherwise

See Also

TableSectionData Class


ClearCell Method

[image]

Revit 2024 API
TableSectionData..::..ClearCell Method
TableSectionData Class See Also Send Feedback
Deletes text or image, or removes parameter of this cell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void ClearCell(
    int nRow,
    int nCol
)
Visual Basic
Public Sub ClearCell ( _
    nRow As Integer, _
    nCol As Integer _
)
Visual C++
public:
void ClearCell(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::..Int32
nCol
Type: System..::..Int32

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given row number nRow is invalid. -or- The given column number nCol is invalid.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is forbidden for cells in standard schedule body sections.

See Also

TableSectionData Class


Dispose Method

[image]

Revit 2024 API
TableSectionData..::..Dispose Method
TableSectionData Class See Also Send Feedback
Releases all resources used by the TableSectionData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

TableSectionData Class


GetCellCalculatedValue Method

[image] [image]

Revit 2024 API
TableSectionData..::..GetCellCalculatedValue Method
TableSectionData Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetCellCalculatedValue(Int32) | Gets the calculated value for the specified column
Public method | GetCellCalculatedValue(Int32, Int32) | Gets the calculated value for the specified cell

See Also

TableSectionData Class
TableSectionData Members


GetCellCalculatedValue Method (Int32)

[image]

Revit 2024 API
TableSectionData..::..GetCellCalculatedValue Method (Int32)
TableSectionData Class See Also Send Feedback
Gets the calculated value for the specified column

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public TableCellCalculatedValueData GetCellCalculatedValue(
    int nCol
)
Visual Basic
Public Function GetCellCalculatedValue ( _
    nCol As Integer _
) As TableCellCalculatedValueData
Visual C++
public:
TableCellCalculatedValueData^ GetCellCalculatedValue(
    int nCol
)

Parameters

nCol
Type: System..::..Int32

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given column number nCol is invalid.

See Also

TableSectionData Class
GetCellCalculatedValue Overload


GetCellCalculatedValue Method (Int32, Int32)

[image]

Revit 2024 API
TableSectionData..::..GetCellCalculatedValue Method (Int32, Int32)
TableSectionData Class See Also Send Feedback
Gets the calculated value for the specified cell

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public TableCellCalculatedValueData GetCellCalculatedValue(
    int nRow,
    int nCol
)
Visual Basic
Public Function GetCellCalculatedValue ( _
    nRow As Integer, _
    nCol As Integer _
) As TableCellCalculatedValueData
Visual C++
public:
TableCellCalculatedValueData^ GetCellCalculatedValue(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::..Int32
nCol
Type: System..::..Int32

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given row number nRow is invalid. -or- The given column number nCol is invalid.

See Also

TableSectionData Class
GetCellCalculatedValue Overload


GetCellCategoryId Method

[image] [image]

Revit 2024 API
TableSectionData..::..GetCellCategoryId Method
TableSectionData Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetCellCategoryId(Int32) | Returns a column's ParamId Associated with the paramId to find the correct element
Public method | GetCellCategoryId(Int32, Int32) | Returns a cell's CategoryId and if no CategoryId exists for this cell, it would come from the column. Associated with the paramId to find the correct element.

See Also

TableSectionData Class
TableSectionData Members


GetCellCategoryId Method (Int32)

[image]

Revit 2024 API
TableSectionData..::..GetCellCategoryId Method (Int32)
TableSectionData Class See Also Send Feedback
Returns a column's ParamId Associated with the paramId to find the correct element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElementId GetCellCategoryId(
    int nCol
)
Visual Basic
Public Function GetCellCategoryId ( _
    nCol As Integer _
) As ElementId
Visual C++
public:
ElementId^ GetCellCategoryId(
    int nCol
)

Parameters

nCol
Type: System..::..Int32

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given column number nCol is invalid.

See Also

TableSectionData Class
GetCellCategoryId Overload


GetCellCategoryId Method (Int32, Int32)

[image]

Revit 2024 API
TableSectionData..::..GetCellCategoryId Method (Int32, Int32)
TableSectionData Class See Also Send Feedback
Returns a cell's CategoryId and if no CategoryId exists for this cell, it would come from the column. Associated with the paramId to find the correct element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElementId GetCellCategoryId(
    int nRow,
    int nCol
)
Visual Basic
Public Function GetCellCategoryId ( _
    nRow As Integer, _
    nCol As Integer _
) As ElementId
Visual C++
public:
ElementId^ GetCellCategoryId(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::..Int32
nCol
Type: System..::..Int32

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given row number nRow is invalid. -or- The given column number nCol is invalid.

See Also

TableSectionData Class
GetCellCategoryId Overload


GetCellCombinedParameters Method

[image] [image]

Revit 2024 API
TableSectionData..::..GetCellCombinedParameters Method
TableSectionData Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetCellCombinedParameters(Int32) | Returns an array of combined parameter data for the specified column
Public method | GetCellCombinedParameters(Int32, Int32) | Returns an array of combined parameter data for the specified cell

See Also

TableSectionData Class
TableSectionData Members


GetCellCombinedParameters Method (Int32)

[image]

Revit 2024 API
TableSectionData..::..GetCellCombinedParameters Method (Int32)
TableSectionData Class See Also Send Feedback
Returns an array of combined parameter data for the specified column

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public IList<TableCellCombinedParameterData> GetCellCombinedParameters(
    int nCol
)
Visual Basic
Public Function GetCellCombinedParameters ( _
    nCol As Integer _
) As IList(Of TableCellCombinedParameterData)
Visual C++
public:
IList<TableCellCombinedParameterData^>^ GetCellCombinedParameters(
    int nCol
)

Parameters

nCol
Type: System..::..Int32

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given column number nCol is invalid.

See Also

TableSectionData Class
GetCellCombinedParameters Overload


GetCellCombinedParameters Method (Int32, Int32)

[image]

Revit 2024 API
TableSectionData..::..GetCellCombinedParameters Method (Int32, Int32)
TableSectionData Class See Also Send Feedback
Returns an array of combined parameter data for the specified cell

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public IList<TableCellCombinedParameterData> GetCellCombinedParameters(
    int nRow,
    int nCol
)
Visual Basic
Public Function GetCellCombinedParameters ( _
    nRow As Integer, _
    nCol As Integer _
) As IList(Of TableCellCombinedParameterData)
Visual C++
public:
IList<TableCellCombinedParameterData^>^ GetCellCombinedParameters(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::..Int32
nCol
Type: System..::..Int32

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given row number nRow is invalid. -or- The given column number nCol is invalid.

See Also

TableSectionData Class
GetCellCombinedParameters Overload


GetCellFormatOptions Method (Int32, Document)

[image]

Revit 2024 API
TableSectionData..::..GetCellFormatOptions Method (Int32, Document)
TableSectionData Class See Also Send Feedback
Returns a column's cell FormatOptions and if no FormatOptions exists for this column, it would come from the section.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FormatOptions GetCellFormatOptions(
    int nCol,
    Document dcument
)
Visual Basic
Public Function GetCellFormatOptions ( _
    nCol As Integer, _
    dcument As Document _
) As FormatOptions
Visual C++
public:
FormatOptions^ GetCellFormatOptions(
    int nCol,
    Document^ dcument
)

Parameters

nCol
Type: System..::..Int32
dcument
Type: Autodesk.Revit.DB..::..Document

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given column number nCol is invalid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

TableSectionData Class
GetCellFormatOptions Overload


GetCellFormatOptions Method (Int32, Int32, Document)

[image]

Revit 2024 API
TableSectionData..::..GetCellFormatOptions Method (Int32, Int32, Document)
TableSectionData Class See Also Send Feedback
Returns a cell's FormatOptions and if no FormatOptions exists for this cell, it would come from the column, or the row, or the section.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FormatOptions GetCellFormatOptions(
    int nRow,
    int nCol,
    Document document
)
Visual Basic
Public Function GetCellFormatOptions ( _
    nRow As Integer, _
    nCol As Integer, _
    document As Document _
) As FormatOptions
Visual C++
public:
FormatOptions^ GetCellFormatOptions(
    int nRow,
    int nCol,
    Document^ document
)

Parameters

nRow
Type: System..::..Int32
nCol
Type: System..::..Int32
document
Type: Autodesk.Revit.DB..::..Document

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given row number nRow is invalid. -or- The given column number nCol is invalid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

TableSectionData Class
GetCellFormatOptions Overload


GetCellParamId Method

[image] [image]

Revit 2024 API
TableSectionData..::..GetCellParamId Method
TableSectionData Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetCellParamId(Int32) | Returns a column's ParamId
Public method | GetCellParamId(Int32, Int32) | Returns a cell's ParamId and if no ParamId exists for this cell, it would come from the column

See Also

TableSectionData Class
TableSectionData Members


GetCellParamId Method (Int32, Int32)

[image]

Revit 2024 API
TableSectionData..::..GetCellParamId Method (Int32, Int32)
TableSectionData Class See Also Send Feedback
Returns a cell's ParamId and if no ParamId exists for this cell, it would come from the column

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElementId GetCellParamId(
    int nRow,
    int nCol
)
Visual Basic
Public Function GetCellParamId ( _
    nRow As Integer, _
    nCol As Integer _
) As ElementId
Visual C++
public:
ElementId^ GetCellParamId(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::..Int32
nCol
Type: System..::..Int32

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given row number nRow is invalid. -or- The given column number nCol is invalid.

See Also

TableSectionData Class
GetCellParamId Overload


GetCellSpec Method

[image]

Revit 2024 API
TableSectionData..::..GetCellSpec Method
TableSectionData Class See Also Send Feedback
Gets the spec describing values of a cell, if applicable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ForgeTypeId GetCellSpec(
    int nRow,
    int nCol
)
Visual Basic
Public Function GetCellSpec ( _
    nRow As Integer, _
    nCol As Integer _
) As ForgeTypeId
Visual C++
public:
ForgeTypeId^ GetCellSpec(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::..Int32
The row index of the cell
nCol
Type: System..::..Int32
The column index of the cell

Return Value

Identifier of the spec, or empty if the cell does not contain a number with units.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given row number nRow is invalid. -or- The given column number nCol is invalid.

See Also

TableSectionData Class


GetCellText Method

[image]

Revit 2024 API
TableSectionData..::..GetCellText Method
TableSectionData Class See Also Send Feedback
Returns the text shown by this cell, if the cell's type is CellType.Text or CellType.ParameterText or CellType.CustomField.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string GetCellText(
    int nRow,
    int nCol
)
Visual Basic
Public Function GetCellText ( _
    nRow As Integer, _
    nCol As Integer _
) As String
Visual C++
public:
String^ GetCellText(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::..Int32
The cell row.
nCol
Type: System..::..Int32
The cell column.

Return Value

The text in the cell, or an empty string if the type if not CellType.Text or CellType.ParameterText or CellType.CustomField.

Remarks

For standard view schedules, to read the formatted text of the cell regardless of cell type, use GetCellText(SectionType, Int32, Int32).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given row number nRow is invalid. -or- The given column number nCol is invalid.

See Also

TableSectionData Class


GetCellType Method

[image] [image]

Revit 2024 API
TableSectionData..::..GetCellType Method
TableSectionData Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetCellType(Int32) | Returns a column's cell type and if no type exists for this column, it would come from the section
Public method | GetCellType(Int32, Int32) | Returns a cell's Type and if no Type exists for this cell, it would come from the column, or the row, or the section

See Also

TableSectionData Class
TableSectionData Members


GetCellType Method (Int32, Int32)

[image]

Revit 2024 API
TableSectionData..::..GetCellType Method (Int32, Int32)
TableSectionData Class See Also Send Feedback
Returns a cell's Type and if no Type exists for this cell, it would come from the column, or the row, or the section

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CellType GetCellType(
    int nRow,
    int nCol
)
Visual Basic
Public Function GetCellType ( _
    nRow As Integer, _
    nCol As Integer _
) As CellType
Visual C++
public:
CellType GetCellType(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::..Int32
nCol
Type: System..::..Int32

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given row number nRow is invalid. -or- The given column number nCol is invalid.

See Also

TableSectionData Class
GetCellType Overload


GetColumnWidth Method

[image]

Revit 2024 API
TableSectionData..::..GetColumnWidth Method
TableSectionData Class See Also Send Feedback
Returns a column's width in feet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double GetColumnWidth(
    int nCol
)
Visual Basic
Public Function GetColumnWidth ( _
    nCol As Integer _
) As Double
Visual C++
public:
double GetColumnWidth(
    int nCol
)

Parameters

nCol
Type: System..::..Int32

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given column number nCol is invalid.

See Also

TableSectionData Class


GetColumnWidthInPixels Method

[image]

Revit 2024 API
TableSectionData..::..GetColumnWidthInPixels Method
TableSectionData Class See Also Send Feedback
This returns a column's width in logical pixels

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public int GetColumnWidthInPixels(
    int nCol
)
Visual Basic
Public Function GetColumnWidthInPixels ( _
    nCol As Integer _
) As Integer
Visual C++
public:
int GetColumnWidthInPixels(
    int nCol
)

Parameters

nCol
Type: System..::..Int32

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given column number nCol is invalid.

See Also

TableSectionData Class


GetCustomFieldId Method

[image]

Revit 2024 API
TableSectionData..::..GetCustomFieldId Method
TableSectionData Class See Also Send Feedback
Gets custom field id from the cell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public Guid GetCustomFieldId(
    int row,
    int col
)
Visual Basic
Public Function GetCustomFieldId ( _
    row As Integer, _
    col As Integer _
) As Guid
Visual C++
public:
Guid GetCustomFieldId(
    int row,
    int col
)

Parameters

row
Type: System..::..Int32
The row of the cell.
col
Type: System..::..Int32
The column of the cell.

Return Value

Returns custom field id from the cell. If this cell is not of type CellType.CustomField it will return an empty Guid

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given row number row is invalid. -or- The given column number col is invalid.

See Also

TableSectionData Class


GetMergedCell Method

[image]

Revit 2024 API
TableSectionData..::..GetMergedCell Method
TableSectionData Class See Also Send Feedback
Gets the whole merged cell that this cell is a part of.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public TableMergedCell GetMergedCell(
    int nRow,
    int nCol
)
Visual Basic
Public Function GetMergedCell ( _
    nRow As Integer, _
    nCol As Integer _
) As TableMergedCell
Visual C++
public:
TableMergedCell^ GetMergedCell(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::..Int32
The cell row.
nCol
Type: System..::..Int32
The cell column.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given row number nRow is invalid. -or- The given column number nCol is invalid.

See Also

TableSectionData Class


GetRowHeight Method

[image]

Revit 2024 API
TableSectionData..::..GetRowHeight Method
TableSectionData Class See Also Send Feedback
Returns a row's height in feet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double GetRowHeight(
    int nRow
)
Visual Basic
Public Function GetRowHeight ( _
    nRow As Integer _
) As Double
Visual C++
public:
double GetRowHeight(
    int nRow
)

Parameters

nRow
Type: System..::..Int32

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given row number nRow is invalid.

See Also

TableSectionData Class


GetRowHeightInPixels Method

[image]

Revit 2024 API
TableSectionData..::..GetRowHeightInPixels Method
TableSectionData Class See Also Send Feedback
This returns a row's height in logical pixels

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public int GetRowHeightInPixels(
    int nRow
)
Visual Basic
Public Function GetRowHeightInPixels ( _
    nRow As Integer _
) As Integer
Visual C++
public:
int GetRowHeightInPixels(
    int nRow
)

Parameters

nRow
Type: System..::..Int32

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given row number nRow is invalid.

See Also

TableSectionData Class


GetTableCellStyle Method

[image]

Revit 2024 API
TableSectionData..::..GetTableCellStyle Method
TableSectionData Class See Also Send Feedback
Returns a cell's style and if no style exists for this cell, it would come from the column, or the section

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public TableCellStyle GetTableCellStyle(
    int nRow,
    int nCol
)
Visual Basic
Public Function GetTableCellStyle ( _
    nRow As Integer, _
    nCol As Integer _
) As TableCellStyle
Visual C++
public:
TableCellStyle^ GetTableCellStyle(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::..Int32
nCol
Type: System..::..Int32

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given row number nRow is invalid. -or- The given column number nCol is invalid.

See Also

TableSectionData Class


InsertColumn Method

[image]

Revit 2024 API
TableSectionData..::..InsertColumn Method
TableSectionData Class See Also Send Feedback
Inserts a new column at the specified index relative to the current set of columns.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public void InsertColumn(
    int index
)
Visual Basic
Public Sub InsertColumn ( _
    index As Integer _
)
Visual C++
public:
void InsertColumn(
    int index
)

Parameters

index
Type: System..::..Int32
An integer index.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | index is invalid index.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is forbidden for cells in standard schedule body sections.

See Also

TableSectionData Class


InsertImage Method

[image]

Revit 2024 API
TableSectionData..::..InsertImage Method
TableSectionData Class See Also Send Feedback
Inserts a image in the given cell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void InsertImage(
    int nRow,
    int nColumn,
    ElementId imageSymbolId
)
Visual Basic
Public Sub InsertImage ( _
    nRow As Integer, _
    nColumn As Integer, _
    imageSymbolId As ElementId _
)
Visual C++
public:
void InsertImage(
    int nRow,
    int nColumn,
    ElementId^ imageSymbolId
)

Parameters

nRow
Type: System..::..Int32
The given row index.
nColumn
Type: System..::..Int32
The given column index.
imageSymbolId
Type: Autodesk.Revit.DB..::..ElementId
The element id of the image symbol.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given row number nRow is invalid. -or- The given column number nColumn is invalid. -or- The image symbol id doesn't represent a valid image symbol element.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

TableSectionData Class


IsAcceptableParamIdAndCategoryId Method

[image] [image]

Revit 2024 API
TableSectionData..::..IsAcceptableParamIdAndCategoryId Method
TableSectionData Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsAcceptableParamIdAndCategoryId(ElementId, ElementId) | Identifies if the given parameter id and category id can be assigned to a cell in this table.
Public method | IsAcceptableParamIdAndCategoryId(Int32, ElementId, ElementId) | Identifies if the given parameter id and category id can be assigned to a cell in the given row in this table.

See Also

TableSectionData Class
TableSectionData Members


IsAcceptableParamIdAndCategoryId Method (ElementId, ElementId)

[image]

Revit 2024 API
TableSectionData..::..IsAcceptableParamIdAndCategoryId Method (ElementId, ElementId)
TableSectionData Class See Also Send Feedback
Identifies if the given parameter id and category id can be assigned to a cell in this table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsAcceptableParamIdAndCategoryId(
    ElementId paramId,
    ElementId categoryId
)
Visual Basic
Public Function IsAcceptableParamIdAndCategoryId ( _
    paramId As ElementId, _
    categoryId As ElementId _
) As Boolean
Visual C++
public:
bool IsAcceptableParamIdAndCategoryId(
    ElementId^ paramId,
    ElementId^ categoryId
)

Parameters

paramId
Type: Autodesk.Revit.DB..::..ElementId
categoryId
Type: Autodesk.Revit.DB..::..ElementId

Return Value

True if the ParamId and CategoryId are all acceptable.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

TableSectionData Class
IsAcceptableParamIdAndCategoryId Overload


IsAcceptableParamIdAndCategoryId Method (Int32, ElementId, ElementId)

[image]

Revit 2024 API
TableSectionData..::..IsAcceptableParamIdAndCategoryId Method (Int32, ElementId, ElementId)
TableSectionData Class See Also Send Feedback
Identifies if the given parameter id and category id can be assigned to a cell in the given row in this table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsAcceptableParamIdAndCategoryId(
    int nRow,
    ElementId paramId,
    ElementId categoryId
)
Visual Basic
Public Function IsAcceptableParamIdAndCategoryId ( _
    nRow As Integer, _
    paramId As ElementId, _
    categoryId As ElementId _
) As Boolean
Visual C++
public:
bool IsAcceptableParamIdAndCategoryId(
    int nRow,
    ElementId^ paramId,
    ElementId^ categoryId
)

Parameters

nRow
Type: System..::..Int32
row index
paramId
Type: Autodesk.Revit.DB..::..ElementId
categoryId
Type: Autodesk.Revit.DB..::..ElementId

Return Value

True if the ParamId and CategoryId are all valid.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given row number nRow is invalid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

TableSectionData Class
IsAcceptableParamIdAndCategoryId Overload


IsCellFormattable Method

[image]

Revit 2024 API
TableSectionData..::..IsCellFormattable Method
TableSectionData Class See Also Send Feedback
Determines whether the cell is formattable or not

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsCellFormattable(
    int nRow,
    int nCol
)
Visual Basic
Public Function IsCellFormattable ( _
    nRow As Integer, _
    nCol As Integer _
) As Boolean
Visual C++
public:
bool IsCellFormattable(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::..Int32
The row index of the cell
nCol
Type: System..::..Int32
The column index of the cell

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given row number nRow is invalid. -or- The given column number nCol is invalid.

See Also

TableSectionData Class


IsCellOverridden Method

[image] [image]

Revit 2024 API
TableSectionData..::..IsCellOverridden Method
TableSectionData Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsCellOverridden(Int32) | Indicates if the column is overridden or not.
Public method | IsCellOverridden(Int32, Int32) | Indicates if the cell is overridden or not.

See Also

TableSectionData Class
TableSectionData Members


IsCellOverridden Method (Int32)

[image]

Revit 2024 API
TableSectionData..::..IsCellOverridden Method (Int32)
TableSectionData Class See Also Send Feedback
Indicates if the column is overridden or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsCellOverridden(
    int nCol
)
Visual Basic
Public Function IsCellOverridden ( _
    nCol As Integer _
) As Boolean
Visual C++
public:
bool IsCellOverridden(
    int nCol
)

Parameters

nCol
Type: System..::..Int32

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given column number nCol is invalid.

See Also

TableSectionData Class
IsCellOverridden Overload


IsCellOverridden Method (Int32, Int32)

[image]

Revit 2024 API
TableSectionData..::..IsCellOverridden Method (Int32, Int32)
TableSectionData Class See Also Send Feedback
Indicates if the cell is overridden or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsCellOverridden(
    int nRow,
    int nCol
)
Visual Basic
Public Function IsCellOverridden ( _
    nRow As Integer, _
    nCol As Integer _
) As Boolean
Visual C++
public:
bool IsCellOverridden(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::..Int32
nCol
Type: System..::..Int32

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given row number nRow is invalid. -or- The given column number nCol is invalid.

See Also

TableSectionData Class
IsCellOverridden Overload


IsDataOutOfDate Method

[image]

Revit 2024 API
TableSectionData..::..IsDataOutOfDate Method
TableSectionData Class See Also Send Feedback
Indicates whether the data in this section is out of date.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsDataOutOfDate()
Visual Basic
Public Function IsDataOutOfDate As Boolean
Visual C++
public:
bool IsDataOutOfDate()

Return Value

True if the data in this section is out of date, false otherwise.

Remarks

To improve performance, some TableViews may contain TableSections that are only updated on demand. For example, the body section of a schedule is not updated when the ViewSchedule is closed. In this case, you need to call RefreshData to avoid getting the stale data.

See Also

TableSectionData Class


IsValidColumnNumber Method

[image]

Revit 2024 API
TableSectionData..::..IsValidColumnNumber Method
TableSectionData Class See Also Send Feedback
Verifies if the column number is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidColumnNumber(
    int nCol
)
Visual Basic
Public Function IsValidColumnNumber ( _
    nCol As Integer _
) As Boolean
Visual C++
public:
bool IsValidColumnNumber(
    int nCol
)

Parameters

nCol
Type: System..::..Int32
The column number.

Return Value

True if the column number is between FirstColumnNumber and LastColumnNumber, false otherwise.

See Also

TableSectionData Class


IsValidRowNumber Method

[image]

Revit 2024 API
TableSectionData..::..IsValidRowNumber Method
TableSectionData Class See Also Send Feedback
Verifies if the row number is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidRowNumber(
    int nRow
)
Visual Basic
Public Function IsValidRowNumber ( _
    nRow As Integer _
) As Boolean
Visual C++
public:
bool IsValidRowNumber(
    int nRow
)

Parameters

nRow
Type: System..::..Int32
The row number.

Return Value

True if the row number is between FirstRowNumber and LastRowNumber, false otherwise.

See Also

TableSectionData Class


RefreshData Method

[image]

Revit 2024 API
TableSectionData..::..RefreshData Method
TableSectionData Class See Also Send Feedback
Rebuilds the data in this section if it is out of date.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool RefreshData()
Visual Basic
Public Function RefreshData As Boolean
Visual C++
public:
bool RefreshData()

Return Value

True if the data is up to date after the refresh.

See Also

TableSectionData Class


RemoveRow Method

[image]

Revit 2024 API
TableSectionData..::..RemoveRow Method
TableSectionData Class See Also Send Feedback
Removes a row data at a specified index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void RemoveRow(
    int nIndex
)
Visual Basic
Public Sub RemoveRow ( _
    nIndex As Integer _
)
Visual C++
public:
void RemoveRow(
    int nIndex
)

Parameters

nIndex
Type: System..::..Int32
An integer index.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The row can't be removed because it's an element in linked file, default zone or it's a row in body section of Material Quantity Take Off Schedule or it's the last row in header section of standard schedule or nIndex is invalid index.

See Also

TableSectionData Class


ResetCellOverride Method

[image] [image]

Revit 2024 API
TableSectionData..::..ResetCellOverride Method
TableSectionData Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResetCellOverride(Int32) | Resets the override of the column.
Public method | ResetCellOverride(Int32, Int32) | Resets the override of the cell.

See Also

TableSectionData Class
TableSectionData Members


ResetCellOverride Method (Int32)

[image]

Revit 2024 API
TableSectionData..::..ResetCellOverride Method (Int32)
TableSectionData Class See Also Send Feedback
Resets the override of the column.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void ResetCellOverride(
    int nCol
)
Visual Basic
Public Sub ResetCellOverride ( _
    nCol As Integer _
)
Visual C++
public:
void ResetCellOverride(
    int nCol
)

Parameters

nCol
Type: System..::..Int32

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given column number nCol is invalid.

See Also

TableSectionData Class
ResetCellOverride Overload


ResetCellOverride Method (Int32, Int32)

[image]

Revit 2024 API
TableSectionData..::..ResetCellOverride Method (Int32, Int32)
TableSectionData Class See Also Send Feedback
Resets the override of the cell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void ResetCellOverride(
    int nRow,
    int nCol
)
Visual Basic
Public Sub ResetCellOverride ( _
    nRow As Integer, _
    nCol As Integer _
)
Visual C++
public:
void ResetCellOverride(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::..Int32
nCol
Type: System..::..Int32

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given row number nRow is invalid. -or- The given column number nCol is invalid. -or- Only allow to override cell style for header section or column header in body section.

See Also

TableSectionData Class
ResetCellOverride Overload


SetCellCalculatedValue Method (Int32, TableCellCalculatedValueData)

[image]

Revit 2024 API
TableSectionData..::..SetCellCalculatedValue Method (Int32, TableCellCalculatedValueData)
TableSectionData Class See Also Send Feedback
Allows the caller to set the calculated value for a specified column

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetCellCalculatedValue(
    int nCol,
    TableCellCalculatedValueData pCalcValue
)
Visual Basic
Public Sub SetCellCalculatedValue ( _
    nCol As Integer, _
    pCalcValue As TableCellCalculatedValueData _
)
Visual C++
public:
void SetCellCalculatedValue(
    int nCol,
    TableCellCalculatedValueData^ pCalcValue
)

Parameters

nCol
Type: System..::..Int32
pCalcValue
Type: Autodesk.Revit.DB..::..TableCellCalculatedValueData

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given column number nCol is invalid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is forbidden for cells in standard schedule header sections. -or- This operation is forbidden for cells in standard schedule body sections.

See Also

TableSectionData Class
SetCellCalculatedValue Overload


SetCellCalculatedValue Method (Int32, Int32, TableCellCalculatedValueData)

[image]

Revit 2024 API
TableSectionData..::..SetCellCalculatedValue Method (Int32, Int32, TableCellCalculatedValueData)
TableSectionData Class See Also Send Feedback
Allows the caller to set the calculated value for a specified cell

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetCellCalculatedValue(
    int nRow,
    int nCol,
    TableCellCalculatedValueData pCalcValue
)
Visual Basic
Public Sub SetCellCalculatedValue ( _
    nRow As Integer, _
    nCol As Integer, _
    pCalcValue As TableCellCalculatedValueData _
)
Visual C++
public:
void SetCellCalculatedValue(
    int nRow,
    int nCol,
    TableCellCalculatedValueData^ pCalcValue
)

Parameters

nRow
Type: System..::..Int32
nCol
Type: System..::..Int32
pCalcValue
Type: Autodesk.Revit.DB..::..TableCellCalculatedValueData

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given row number nRow is invalid. -or- The given column number nCol is invalid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is forbidden for cells in standard schedule header sections. -or- This operation is forbidden for cells in standard schedule body sections.

See Also

TableSectionData Class
SetCellCalculatedValue Overload


SetCellCombinedParameters Method (Int32, Int32, IList(TableCellCombinedParameterData))

[image]

Revit 2024 API
TableSectionData..::..SetCellCombinedParameters Method (Int32, Int32, IList<(Of <(<'TableCellCombinedParameterData>)>)>)
TableSectionData Class See Also Send Feedback
Allows the caller to set combined parameter for a specified cell

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetCellCombinedParameters(
    int nRow,
    int nCol,
    IList<TableCellCombinedParameterData> paramData
)
Visual Basic
Public Sub SetCellCombinedParameters ( _
    nRow As Integer, _
    nCol As Integer, _
    paramData As IList(Of TableCellCombinedParameterData) _
)
Visual C++
public:
void SetCellCombinedParameters(
    int nRow,
    int nCol,
    IList<TableCellCombinedParameterData^>^ paramData
)

Parameters

nRow
Type: System..::..Int32
nCol
Type: System..::..Int32
paramData
Type: System.Collections.Generic..::..IList<(Of <(<' TableCellCombinedParameterData >)>)>

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given row number nRow is invalid. -or- The given column number nCol is invalid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

TableSectionData Class
SetCellCombinedParameters Overload


SetCellFormatOptions Method

[image]

Revit 2024 API
TableSectionData..::..SetCellFormatOptions Method
TableSectionData Class See Also Send Feedback
Sets a cell's FormatOptions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void SetCellFormatOptions(
    int nRow,
    int nCol,
    FormatOptions options
)
Visual Basic
Public Sub SetCellFormatOptions ( _
    nRow As Integer, _
    nCol As Integer, _
    options As FormatOptions _
)
Visual C++
public:
void SetCellFormatOptions(
    int nRow,
    int nCol,
    FormatOptions^ options
)

Parameters

nRow
Type: System..::..Int32
The row index of the cell
nCol
Type: System..::..Int32
The column index of the cell
options
Type: Autodesk.Revit.DB..::..FormatOptions
The format option to assign

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given row number nRow is invalid. -or- The given column number nCol is invalid. -or- The display unit in options is not a valid display unit for the unit type of the cell, or the rounding method in options is not set to Nearest. See UnitUtils.IsValidDisplayUnit(UnitType, DisplayUnitType), UnitUtils.GetValidDisplayUnits(UnitType) and FormatOptions.RoundingMethod.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

TableSectionData Class


SetCellParamIdAndCategoryId Method

[image] [image]

Revit 2024 API
TableSectionData..::..SetCellParamIdAndCategoryId Method
TableSectionData Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetCellParamIdAndCategoryId(Int32, ElementId, ElementId) | Sets a column's category and parameter Id
Public method | SetCellParamIdAndCategoryId(Int32, Int32, ElementId, ElementId) | Sets a cell's category and parameter Id

See Also

TableSectionData Class
TableSectionData Members


SetCellParamIdAndCategoryId Method (Int32, ElementId, ElementId)

[image]

Revit 2024 API
TableSectionData..::..SetCellParamIdAndCategoryId Method (Int32, ElementId, ElementId)
TableSectionData Class See Also Send Feedback
Sets a column's category and parameter Id

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetCellParamIdAndCategoryId(
    int nCol,
    ElementId paramId,
    ElementId categoryId
)
Visual Basic
Public Sub SetCellParamIdAndCategoryId ( _
    nCol As Integer, _
    paramId As ElementId, _
    categoryId As ElementId _
)
Visual C++
public:
void SetCellParamIdAndCategoryId(
    int nCol,
    ElementId^ paramId,
    ElementId^ categoryId
)

Parameters

nCol
Type: System..::..Int32
paramId
Type: Autodesk.Revit.DB..::..ElementId
categoryId
Type: Autodesk.Revit.DB..::..ElementId

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given column number nCol is invalid. -or- The paramId or categoryId is not acceptable.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is forbidden for cells in standard schedule body sections.

See Also

TableSectionData Class
SetCellParamIdAndCategoryId Overload


SetCellParamIdAndCategoryId Method (Int32, Int32, ElementId, ElementId)

[image]

Revit 2024 API
TableSectionData..::..SetCellParamIdAndCategoryId Method (Int32, Int32, ElementId, ElementId)
TableSectionData Class See Also Send Feedback
Sets a cell's category and parameter Id

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetCellParamIdAndCategoryId(
    int nRow,
    int nCol,
    ElementId paramId,
    ElementId categoryId
)
Visual Basic
Public Sub SetCellParamIdAndCategoryId ( _
    nRow As Integer, _
    nCol As Integer, _
    paramId As ElementId, _
    categoryId As ElementId _
)
Visual C++
public:
void SetCellParamIdAndCategoryId(
    int nRow,
    int nCol,
    ElementId^ paramId,
    ElementId^ categoryId
)

Parameters

nRow
Type: System..::..Int32
nCol
Type: System..::..Int32
paramId
Type: Autodesk.Revit.DB..::..ElementId
categoryId
Type: Autodesk.Revit.DB..::..ElementId

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given row number nRow is invalid. -or- The given column number nCol is invalid. -or- The paramId or categoryId is not valid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

TableSectionData Class
SetCellParamIdAndCategoryId Overload


SetCellStyle Method

[image] [image]

Revit 2024 API
TableSectionData..::..SetCellStyle Method
TableSectionData Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetCellStyle(TableCellStyle) | Sets a section's style
Public method | SetCellStyle(Int32, TableCellStyle) | Sets a column's style.
Public method | SetCellStyle(Int32, Int32, TableCellStyle) | Sets a cell's style

See Also

TableSectionData Class
TableSectionData Members


SetCellStyle Method (TableCellStyle)

[image]

Revit 2024 API
TableSectionData..::..SetCellStyle Method (TableCellStyle)
TableSectionData Class See Also Send Feedback
Sets a section's style

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetCellStyle(
    TableCellStyle Style
)
Visual Basic
Public Sub SetCellStyle ( _
    Style As TableCellStyle _
)
Visual C++
public:
void SetCellStyle(
    TableCellStyle^ Style
)

Parameters

Style
Type: Autodesk.Revit.DB..::..TableCellStyle

Remarks

For standard schedule, must set the TableCellStyleOverrideOptions in the TableCellStyle to override this section.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

TableSectionData Class
SetCellStyle Overload


SetCellStyle Method (Int32, TableCellStyle)

[image]

Revit 2024 API
TableSectionData..::..SetCellStyle Method (Int32, TableCellStyle)
TableSectionData Class See Also Send Feedback
Sets a column's style.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetCellStyle(
    int nCol,
    TableCellStyle Style
)
Visual Basic
Public Sub SetCellStyle ( _
    nCol As Integer, _
    Style As TableCellStyle _
)
Visual C++
public:
void SetCellStyle(
    int nCol,
    TableCellStyle^ Style
)

Parameters

nCol
Type: System..::..Int32
Style
Type: Autodesk.Revit.DB..::..TableCellStyle

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given column number nCol is invalid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

TableSectionData Class
SetCellStyle Overload


SetCellStyle Method (Int32, Int32, TableCellStyle)

[image]

Revit 2024 API
TableSectionData..::..SetCellStyle Method (Int32, Int32, TableCellStyle)
TableSectionData Class Example See Also Send Feedback
Sets a cell's style

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetCellStyle(
    int nRow,
    int nCol,
    TableCellStyle Style
)
Visual Basic
Public Sub SetCellStyle ( _
    nRow As Integer, _
    nCol As Integer, _
    Style As TableCellStyle _
)
Visual C++
public:
void SetCellStyle(
    int nRow,
    int nCol,
    TableCellStyle^ Style
)

Parameters

nRow
Type: System..::..Int32
nCol
Type: System..::..Int32
Style
Type: Autodesk.Revit.DB..::..TableCellStyle

Remarks

For standard schedule, must set the TableCellStyleOverrideOptions in the TableCellStyle to override this cell. The global base format controls any non-overridden characteristics of this cell.

Examples

CopyC#
public void FormatSubtitle(ViewSchedule colSchedule)
{
    TableData colTableData = colSchedule.GetTableData();

    TableSectionData tsd = colTableData.GetSectionData(SectionType.Header);
    // Subtitle is second row, first column
    if (tsd.AllowOverrideCellStyle(tsd.FirstRowNumber + 1, tsd.FirstColumnNumber))
    {
        TableCellStyle tcs = new TableCellStyle();
        TableCellStyleOverrideOptions options = new TableCellStyleOverrideOptions();
        options.FontSize = true;
        options.Bold = true;
        tcs.SetCellStyleOverrideOptions(options);
        tcs.IsFontBold = true;
        tcs.TextSize = 10;
        tsd.SetCellStyle(tsd.FirstRowNumber + 1, tsd.FirstColumnNumber, tcs);
    }
}
CopyVB.NET
Public Sub FormatSubtitle(colSchedule As ViewSchedule)
    Dim colTableData As TableData = colSchedule.GetTableData()

    Dim tsd As TableSectionData = colTableData.GetSectionData(SectionType.Header)
    ' Subtitle is second row, first column
    If tsd.AllowOverrideCellStyle(tsd.FirstRowNumber + 1, tsd.FirstColumnNumber) Then
        Dim tcs As New TableCellStyle()
        Dim options As New TableCellStyleOverrideOptions()
        options.FontSize = True
        options.Bold = True
        tcs.SetCellStyleOverrideOptions(options)
        tcs.IsFontBold = True
        tcs.TextSize = 10
        tsd.SetCellStyle(tsd.FirstRowNumber + 1, tsd.FirstColumnNumber, tcs)
    End If
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given row number nRow is invalid. -or- The given column number nCol is invalid. -or- Only allow to override cell style for header section or column header in body section.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

TableSectionData Class
SetCellStyle Overload


SetCellText Method

[image]

Revit 2024 API
TableSectionData..::..SetCellText Method
TableSectionData Class See Also Send Feedback
Sets a cell's to display the specified text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetCellText(
    int nRow,
    int nCol,
    string text
)
Visual Basic
Public Sub SetCellText ( _
    nRow As Integer, _
    nCol As Integer, _
    text As String _
)
Visual C++
public:
void SetCellText(
    int nRow,
    int nCol,
    String^ text
)

Parameters

nRow
Type: System..::..Int32
The cell row.
nCol
Type: System..::..Int32
The cell column.
text
Type: System..::..String
The text to show in the cell.

Remarks

If this cell's type is not CellType.Text, and the operation is permitted on this cell, the cell type will be changed to type CellType.Text as a result of this call.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given row number nRow is invalid. -or- The given column number nCol is invalid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is forbidden for cells in standard schedule body sections.

See Also

TableSectionData Class


SetCellType Method

[image] [image]

Revit 2024 API
TableSectionData..::..SetCellType Method
TableSectionData Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetCellType(Int32, CellType) | Sets a column's cell type
Public method | SetCellType(Int32, Int32, CellType) | Sets a cell's Type

See Also

TableSectionData Class
TableSectionData Members


SetCellType Method (Int32, CellType)

[image]

Revit 2024 API
TableSectionData..::..SetCellType Method (Int32, CellType)
TableSectionData Class See Also Send Feedback
Sets a column's cell type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetCellType(
    int nCol,
    CellType type
)
Visual Basic
Public Sub SetCellType ( _
    nCol As Integer, _
    type As CellType _
)
Visual C++
public:
void SetCellType(
    int nCol,
    CellType type
)

Parameters

nCol
Type: System..::..Int32
type
Type: Autodesk.Revit.DB..::..CellType

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | A CellType.CustomField can't be set. -or- The given column number nCol is invalid.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is forbidden for cells in standard schedule body sections.

See Also

TableSectionData Class
SetCellType Overload


SetColumnWidth Method

[image]

Revit 2024 API
TableSectionData..::..SetColumnWidth Method
TableSectionData Class See Also Send Feedback
Sets a column's width in feet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetColumnWidth(
    int nCol,
    double width
)
Visual Basic
Public Sub SetColumnWidth ( _
    nCol As Integer, _
    width As Double _
)
Visual C++
public:
void SetColumnWidth(
    int nCol,
    double width
)

Parameters

nCol
Type: System..::..Int32
width
Type: System..::..Double

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given column number nCol is invalid. -or- The column width is outside of acceptable range.

See Also

TableSectionData Class


SetColumnWidthInPixels Method

[image]

Revit 2024 API
TableSectionData..::..SetColumnWidthInPixels Method
TableSectionData Class See Also Send Feedback
This sets a column's width in logical pixels

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetColumnWidthInPixels(
    int nCol,
    int width
)
Visual Basic
Public Sub SetColumnWidthInPixels ( _
    nCol As Integer, _
    width As Integer _
)
Visual C++
public:
void SetColumnWidthInPixels(
    int nCol,
    int width
)

Parameters

nCol
Type: System..::..Int32
width
Type: System..::..Int32

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given column number nCol is invalid. -or- The column width is outside of acceptable range.

See Also

TableSectionData Class


SetMergedCell Method

[image]

Revit 2024 API
TableSectionData..::..SetMergedCell Method
TableSectionData Class See Also Send Feedback
Sets the merged cell that this cell is a part of.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetMergedCell(
    int nRow,
    int nCol,
    TableMergedCell mergedCell
)
Visual Basic
Public Sub SetMergedCell ( _
    nRow As Integer, _
    nCol As Integer, _
    mergedCell As TableMergedCell _
)
Visual C++
public:
void SetMergedCell(
    int nRow,
    int nCol,
    TableMergedCell^ mergedCell
)

Parameters

nRow
Type: System..::..Int32
The cell row.
nCol
Type: System..::..Int32
The cell column.
mergedCell
Type: Autodesk.Revit.DB..::..TableMergedCell

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given row number nRow is invalid. -or- The given column number nCol is invalid. -or- The given TableMergedCell mergedCell is outside of acceptable range.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is forbidden for cells in standard schedule body sections.

See Also

TableSectionData Class


SetRowHeight Method

[image]

Revit 2024 API
TableSectionData..::..SetRowHeight Method
TableSectionData Class See Also Send Feedback
Sets a row's height in feet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetRowHeight(
    int nRow,
    double height
)
Visual Basic
Public Sub SetRowHeight ( _
    nRow As Integer, _
    height As Double _
)
Visual C++
public:
void SetRowHeight(
    int nRow,
    double height
)

Parameters

nRow
Type: System..::..Int32
height
Type: System..::..Double

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given row number nRow is invalid. -or- The row height is outside of acceptable range.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is forbidden for cells in standard schedule body sections.

See Also

TableSectionData Class


TableSectionData Properties

[image] [image]

Revit 2024 API
TableSectionData Properties
TableSectionData Class See Also Send Feedback

The TableSectionData type exposes the following members.

Properties

 | Name | Description
Public property | FirstColumnNumber | The first column in this section of the table.
Public property | FirstRowNumber | The first row in this section of the table.
Public property | HideSection | Whether or not the section is hidden.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LastColumnNumber | The last column in this section of the table.
Public property | LastRowNumber | The last row in this section of the table.
Public property | NeedsRefresh | Indicates if the table data need to refresh.
Public property | NumberOfColumns | Gets or sets the number of items in column data array.
Public property | NumberOfRows | Gets or sets the number of items in row data array.

See Also

TableSectionData Class


FirstColumnNumber Property

[image]

Revit 2024 API
TableSectionData..::..FirstColumnNumber Property
TableSectionData Class See Also Send Feedback
The first column in this section of the table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public int FirstColumnNumber { get; }
Visual Basic
Public ReadOnly Property FirstColumnNumber As Integer
    Get
Visual C++
public:
property int FirstColumnNumber {
    int get ();
}

Remarks

Some table sections have column 0 as their first column while others start with column 1.

See Also

TableSectionData Class


FirstRowNumber Property

[image]

Revit 2024 API
TableSectionData..::..FirstRowNumber Property
TableSectionData Class See Also Send Feedback
The first row in this section of the table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public int FirstRowNumber { get; }
Visual Basic
Public ReadOnly Property FirstRowNumber As Integer
    Get
Visual C++
public:
property int FirstRowNumber {
    int get ();
}

Remarks

Some table sections have row 0 as their first row while others start with row 1.

See Also

TableSectionData Class


LastColumnNumber Property

[image]

Revit 2024 API
TableSectionData..::..LastColumnNumber Property
TableSectionData Class See Also Send Feedback
The last column in this section of the table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public int LastColumnNumber { get; }
Visual Basic
Public ReadOnly Property LastColumnNumber As Integer
    Get
Visual C++
public:
property int LastColumnNumber {
    int get ();
}

See Also

TableSectionData Class


NeedsRefresh Property

[image]

Revit 2024 API
TableSectionData..::..NeedsRefresh Property
TableSectionData Class See Also Send Feedback
Indicates if the table data need to refresh.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool NeedsRefresh { get; set; }
Visual Basic
Public Property NeedsRefresh As Boolean
    Get
    Set
Visual C++
public:
property bool NeedsRefresh {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: This operation is forbidden for cells in standard schedule body sections.

See Also

TableSectionData Class


NumberOfRows Property

[image]

Revit 2024 API
TableSectionData..::..NumberOfRows Property
TableSectionData Class See Also Send Feedback
Gets or sets the number of items in row data array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public int NumberOfRows { get; set; }
Visual Basic
Public Property NumberOfRows As Integer
    Get
    Set
Visual C++
public:
property int NumberOfRows {
    int get ();
    void set (int value);
}

Remarks

Note that TableSections may use either 0 or 1 as the first row and column indices. To access the rows and columns:
  • Use FirstRowNumber and LastRowNumber to get the valid range of row indices.
  • Use FirstColumnNumber and LastColumnNumber to get the valid range of column indices.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: This operation is forbidden for cells in standard schedule body sections.

See Also

TableSectionData Class


TableView Class

[image]

Revit 2024 API
TableView Class
Members See Also Send Feedback
This represents a view that shows a table. Most of the layout data for the table is contained in the TableData class.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class TableView : View
Visual Basic
Public Class TableView _
    Inherits View
Visual C++
public ref class TableView : public View

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..View
Autodesk.Revit.DB..::..TableView
Autodesk.Revit.DB.Electrical..::..PanelScheduleView
Autodesk.Revit.DB..::..ViewSchedule

See Also

TableView Members


GetAvailableParameterCategories Method

[image]

Revit 2024 API
TableView..::..GetAvailableParameterCategories Method
TableView Class See Also Send Feedback
Get all available parameter categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public IList<ElementId> GetAvailableParameterCategories(
    SectionType sectionType,
    int row
)
Visual Basic
Public Function GetAvailableParameterCategories ( _
    sectionType As SectionType, _
    row As Integer _
) As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetAvailableParameterCategories(
    SectionType sectionType,
    int row
)

Parameters

sectionType
Type: Autodesk.Revit.DB..::..SectionType
The section the row lies in.
row
Type: System..::..Int32
The row.

Return Value

The available parameter categories.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The sectionType is not a valid type for this view.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given row number row is invalid. -or- A value passed for an enumeration argument is not a member of that enumeration

See Also

TableView Class


GetAvailableParameters Method

[image]

Revit 2024 API
TableView..::..GetAvailableParameters Method
TableView Class See Also Send Feedback
Gets a list of valid parameters for the specified category that can be used in the table view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static IList<ElementId> GetAvailableParameters(
    Document cda,
    ElementId categoryId
)
Visual Basic
Public Shared Function GetAvailableParameters ( _
    cda As Document, _
    categoryId As ElementId _
) As IList(Of ElementId)
Visual C++
public:
static IList<ElementId^>^ GetAvailableParameters(
    Document^ cda,
    ElementId^ categoryId
)

Parameters

cda
Type: Autodesk.Revit.DB..::..Document
The document.
categoryId
Type: Autodesk.Revit.DB..::..ElementId
The specified element category id.

Return Value

The IDs of all valid parameters.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

TableView Class


GetCalculatedValueName Method

[image]

Revit 2024 API
TableView..::..GetCalculatedValueName Method
TableView Class See Also Send Feedback
Gets the calculated value name for a cell from the template view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string GetCalculatedValueName(
    SectionType sectionType,
    int row,
    int column
)
Visual Basic
Public Function GetCalculatedValueName ( _
    sectionType As SectionType, _
    row As Integer, _
    column As Integer _
) As String
Visual C++
public:
String^ GetCalculatedValueName(
    SectionType sectionType,
    int row,
    int column
)

Parameters

sectionType
Type: Autodesk.Revit.DB..::..SectionType
The section type.
row
Type: System..::..Int32
The row.
column
Type: System..::..Int32
The column.

Return Value

The name of the calculated value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The sectionType is not a valid type for this view.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given row number row is invalid. -or- The given column number column is invalid. -or- A value passed for an enumeration argument is not a member of that enumeration

See Also

TableView Class


GetCalculatedValueText Method

[image]

Revit 2024 API
TableView..::..GetCalculatedValueText Method
TableView Class See Also Send Feedback
Gets the calculated value text for a cell from the instance view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string GetCalculatedValueText(
    SectionType sectionType,
    int row,
    int column
)
Visual Basic
Public Function GetCalculatedValueText ( _
    sectionType As SectionType, _
    row As Integer, _
    column As Integer _
) As String
Visual C++
public:
String^ GetCalculatedValueText(
    SectionType sectionType,
    int row,
    int column
)

Parameters

sectionType
Type: Autodesk.Revit.DB..::..SectionType
The section type.
row
Type: System..::..Int32
The row.
column
Type: System..::..Int32
The column.

Return Value

The calculated value text.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The sectionType is not a valid type for this view.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given row number row is invalid. -or- The given column number column is invalid. -or- A value passed for an enumeration argument is not a member of that enumeration

See Also

TableView Class


IsValidSectionType Method

[image]

Revit 2024 API
TableView..::..IsValidSectionType Method
TableView Class See Also Send Feedback
Identifies if the section type is valid for this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidSectionType(
    SectionType sectionType
)
Visual Basic
Public Function IsValidSectionType ( _
    sectionType As SectionType _
) As Boolean
Visual C++
public:
bool IsValidSectionType(
    SectionType sectionType
)

Parameters

sectionType
Type: Autodesk.Revit.DB..::..SectionType
The section type.

Return Value

True if the Section Type is valid, false otherwise.

Remarks

Some TableViews do not contain all of the possible section types. For example, standard schedules have only a Heading and Body.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

TableView Class


TableView Properties

[image] [image]

Revit 2024 API
TableView Properties
TableView Class See Also Send Feedback

The TableView type exposes the following members.

Properties

 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View.)
Public property | AreAnalyticalModelCategoriesHidden | Indicates if analytical model categories are currently hidden in the view. (Inherited from View.)
Public property | AreAnnotationCategoriesHidden | Indicates if annotation categories are currently hidden in the view. (Inherited from View.)
Public property | AreCoordinationModelHandlesHidden | Indicates if Coordination Model handles are currently hidden in the view. (Inherited from View.)
Public property | AreImportCategoriesHidden | Indicates if import categories are currently hidden in the view. (Inherited from View.)
Public property | AreModelCategoriesHidden | Indicates if model categories are currently hidden in the view. (Inherited from View.)
Public property | ArePointCloudsHidden | Indicates if point clouds are currently hidden in the view. (Inherited from View.)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view. (Inherited from View.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CropBox | The Crop Box applied to the view, or an outline encompassing the crop region applied to the view. (Inherited from View.)
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View.)
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DetailLevel | The detail level of this view. (Inherited from View.)
Public property | Discipline | The Discipline of the view. (Inherited from View.)
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style. (Inherited from View.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | GenLevel | The level for the view. (Inherited from View.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsAssemblyView | Indicates if the view is assembly view. (Inherited from View.)
Public property | IsCallout | Indicates if the view is a callout view. (Inherited from View.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTemplate | Test whether the view is a view template. (Inherited from View.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MaximumColumnWidth | Gets the maximum column width
Public property | MaximumGridWidth | Gets the allowed maximum grid width
Public property | MaximumRowHeight | Gets the maximum row height
Public property | MinimumColumnWidth | Gets the minimum column width
Public property | MinimumRowHeight | Gets the minimum row height
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Origin | Returns the origin of the screen. (Inherited from View.)
Public property | Outline | The bounds of the view in paper space (in feet). (Inherited from View.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PartsVisibility | The visibility setting for parts in this view. (Inherited from View.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RevealConstraintsMode | Indicates whether the Reveal Constraints mode is activated in the view. (Inherited from View.)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Public property | Scale | The scale of the view. (Inherited from View.)
Public property | ShadowIntensity | The intesity of cast shadows - 0 = no shadows, 100 = black. (Inherited from View.)
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View.)
Public property | SunlightIntensity | The intensity of the simulated (directional) sunlight. 0 = no directional light; maximum value is 100. (Inherited from View.)
Public property | TargetId | the element id of the element that is being viewed
Public property | TemporaryViewModes | Data of temporary view modes associated with this view. (Inherited from View.)
Public property | Title | The view title. This consists of the view name plus other modifiers, such as the view type, sheet number, area scheme, and/or assembly type, depending on the specifics of the view. (Inherited from View.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | ViewTemplateId | The id of the template view that controls this view's parameters. (Inherited from View.)
Public property | ViewType | The type of the view. (Inherited from View.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

TableView Class


MaximumColumnWidth Property

[image]

Revit 2024 API
TableView..::..MaximumColumnWidth Property
TableView Class See Also Send Feedback
Gets the maximum column width

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public int MaximumColumnWidth { get; }
Visual Basic
Public ReadOnly Property MaximumColumnWidth As Integer
    Get
Visual C++
public:
property int MaximumColumnWidth {
    int get ();
}

See Also

TableView Class


MaximumRowHeight Property

[image]

Revit 2024 API
TableView..::..MaximumRowHeight Property
TableView Class See Also Send Feedback
Gets the maximum row height

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public int MaximumRowHeight { get; }
Visual Basic
Public ReadOnly Property MaximumRowHeight As Integer
    Get
Visual C++
public:
property int MaximumRowHeight {
    int get ();
}

See Also

TableView Class


MinimumColumnWidth Property

[image]

Revit 2024 API
TableView..::..MinimumColumnWidth Property
TableView Class See Also Send Feedback
Gets the minimum column width

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public int MinimumColumnWidth { get; }
Visual Basic
Public ReadOnly Property MinimumColumnWidth As Integer
    Get
Visual C++
public:
property int MinimumColumnWidth {
    int get ();
}

See Also

TableView Class


MinimumRowHeight Property

[image]

Revit 2024 API
TableView..::..MinimumRowHeight Property
TableView Class See Also Send Feedback
Gets the minimum row height

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public int MinimumRowHeight { get; }
Visual Basic
Public ReadOnly Property MinimumRowHeight As Integer
    Get
Visual C++
public:
property int MinimumRowHeight {
    int get ();
}

See Also

TableView Class


Parameter Property

[image] [image]

Revit 2024 API
TableView..::..Parameter Property
TableView Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

TableView Class
TableView Members


TargetId Property

[image]

Revit 2024 API
TableView..::..TargetId Property
TableView Class See Also Send Feedback
the element id of the element that is being viewed

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElementId TargetId { get; set; }
Visual Basic
Public Property TargetId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ TargetId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

TableView Class


TagMode Enumeration

[image]

Revit 2024 API
TagMode Enumeration
See Also Send Feedback
The modes of tag creation that are supported for IndependentTags.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum TagMode
Visual Basic
Public Enumeration TagMode
Visual C++
public enum class TagMode

Members

Member name | Description
TM_ADDBY_CATEGORY | Add a single category tag.
TM_ADDBY_MULTICATEGORY | Add a multi-category tag.
TM_ADDBY_MATERIAL | Add a material tag.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


TagOrientation Enumeration

[image]

Revit 2024 API
TagOrientation Enumeration
See Also Send Feedback
An enumerated type listing tag orientation options that are supported by IndependentTags.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum TagOrientation
Visual Basic
Public Enumeration TagOrientation
Visual C++
public enum class TagOrientation

Members

Member name | Description
Horizontal | The Orientation of tag is Horizontal.
Vertical | The Orientation of tag is Vertical.
AnyModelDirection | The orientation of tag is Model.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


TemporaryGraphicsManager Class

[image]

Revit 2024 API
TemporaryGraphicsManager Class
Members See Also Send Feedback
A class that provides functionality to create temporary graphics in a Revit model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public class TemporaryGraphicsManager : IDisposable
Visual Basic
Public Class TemporaryGraphicsManager _
    Implements IDisposable
Visual C++
public ref class TemporaryGraphicsManager : IDisposable

Remarks

The graphics created by this class are temporary or transient. They are not subject to undo and are not saved. It's caller's responsiblity to manage their lifetime, creation and destruction, though Revit will destroy all of them when closing the model.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..TemporaryGraphicsManager

See Also

TemporaryGraphicsManager Members


TemporaryGraphicsManager Members

[image] [image]

Revit 2024 API
TemporaryGraphicsManager Members
TemporaryGraphicsManager Class Methods Properties See Also Send Feedback

The TemporaryGraphicsManager type exposes the following members.

Methods

 | Name | Description
Public method | AddControl | Creates an in-canvas control.
Public method | Clear | Clear all temporary graphics objects managed by this manager.
Public method | Dispose | Releases all resources used by the TemporaryGraphicsManager
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAll | Returns all temporary graphics object indexes managed by this manager.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetTemporaryGraphicsManager | Gets a TemporaryGraphicsManager reference of the document.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveControl | Deletes the existing control identified by the unique index.
Public method | SetVisibility | Changes the visibility of temporary graphics object.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateControl | Updates the in-canvas control identified by the unique index.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

TemporaryGraphicsManager Class


TemporaryGraphicsManager Methods

[image] [image]

Revit 2024 API
TemporaryGraphicsManager Methods
TemporaryGraphicsManager Class See Also Send Feedback

The TemporaryGraphicsManager type exposes the following members.

Methods

 | Name | Description
Public method | AddControl | Creates an in-canvas control.
Public method | Clear | Clear all temporary graphics objects managed by this manager.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAll | Returns all temporary graphics object indexes managed by this manager.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetTemporaryGraphicsManager | Gets a TemporaryGraphicsManager reference of the document.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveControl | Deletes the existing control identified by the unique index.
Public method | SetVisibility | Changes the visibility of temporary graphics object.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateControl | Updates the in-canvas control identified by the unique index.

See Also

TemporaryGraphicsManager Class


Dispose Method

[image]

Revit 2024 API
TemporaryGraphicsManager..::..Dispose Method
TemporaryGraphicsManager Class See Also Send Feedback
Releases all resources used by the TemporaryGraphicsManager

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

TemporaryGraphicsManager Class


GetAll Method

[image]

Revit 2024 API
TemporaryGraphicsManager..::..GetAll Method
TemporaryGraphicsManager Class See Also Send Feedback
Returns all temporary graphics object indexes managed by this manager.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public ICollection<int> GetAll()
Visual Basic
Public Function GetAll As ICollection(Of Integer)
Visual C++
public:
ICollection<int>^ GetAll()

Return Value

Collection of temporary graphics object indexes managed by this manager.

See Also

TemporaryGraphicsManager Class


GetTemporaryGraphicsManager Method

[image]

Revit 2024 API
TemporaryGraphicsManager..::..GetTemporaryGraphicsManager Method
TemporaryGraphicsManager Class See Also Send Feedback
Gets a TemporaryGraphicsManager reference of the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public static TemporaryGraphicsManager GetTemporaryGraphicsManager(
    Document document
)
Visual Basic
Public Shared Function GetTemporaryGraphicsManager ( _
    document As Document _
) As TemporaryGraphicsManager
Visual C++
public:
static TemporaryGraphicsManager^ GetTemporaryGraphicsManager(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.

Return Value

Instance of TemporaryGraphicsManager.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

TemporaryGraphicsManager Class


RemoveControl Method

[image]

Revit 2024 API
TemporaryGraphicsManager..::..RemoveControl Method
TemporaryGraphicsManager Class See Also Send Feedback
Deletes the existing control identified by the unique index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public void RemoveControl(
    int index
)
Visual Basic
Public Sub RemoveControl ( _
    index As Integer _
)
Visual C++
public:
void RemoveControl(
    int index
)

Parameters

index
Type: System..::..Int32
Unique index of the control to be deleted.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | index is out of range of TemporaryGraphicsManager managed objects, or the indexed object has been removed from the document.

See Also

TemporaryGraphicsManager Class


SetVisibility Method

[image]

Revit 2024 API
TemporaryGraphicsManager..::..SetVisibility Method
TemporaryGraphicsManager Class See Also Send Feedback
Changes the visibility of temporary graphics object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public void SetVisibility(
    int index,
    bool visible
)
Visual Basic
Public Sub SetVisibility ( _
    index As Integer, _
    visible As Boolean _
)
Visual C++
public:
void SetVisibility(
    int index,
    bool visible
)

Parameters

index
Type: System..::..Int32
Unique index of the temporary graphics object to be updated.
visible
Type: System..::..Boolean
if true, it will make the temporary graphics object visible. if false, it will make the temporary graphics object invisible.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | index is out of range of TemporaryGraphicsManager managed objects, or the indexed object has been removed from the document.

See Also

TemporaryGraphicsManager Class


TemporaryGraphicsManager Properties

[image] [image]

Revit 2024 API
TemporaryGraphicsManager Properties
TemporaryGraphicsManager Class See Also Send Feedback

The TemporaryGraphicsManager type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

TemporaryGraphicsManager Class


IsValidObject Property

[image]

Revit 2024 API
TemporaryGraphicsManager..::..IsValidObject Property
TemporaryGraphicsManager Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

TemporaryGraphicsManager Class


TemporaryViewMode Enumeration

[image]

Revit 2024 API
TemporaryViewMode Enumeration
See Also Send Feedback
Enumeration to represent the various temporary view modes a view can be in.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public enum TemporaryViewMode
Visual Basic
Public Enumeration TemporaryViewMode
Visual C++
public enum class TemporaryViewMode

Members

Member name | Description
RevealHiddenElements | The view is in reveal hidden elements mode
TemporaryHideIsolate | The view is in temporary hide/isolate mode
WorksharingDisplay | The view is in one of the worksharing display modes
TemporaryViewProperties | The view is in the selected View Properties applied temporarily.
ExplodedView | The view is in the mode that shows the model in exploded view and allows user changes/configurations
RevealConstraints | The view is in the mode that reveals constraints between elements in the model.
PreviewFamilyVisibility | The view is in the mode that shows visibility settings applied in the environment of a family document.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


TemporaryViewModes Members

[image] [image]

Revit 2024 API
TemporaryViewModes Members
TemporaryViewModes Class Methods Properties See Also Send Feedback

The TemporaryViewModes type exposes the following members.

Methods

 | Name | Description
Public method | DeactivateAllModes | Deactivates all temporary modes that are currently active.
Public method | DeactivateMode | Deactivates the given temporary mode.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCaption | A text caption to use for the given mode.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCustomized | Identifies if a custom temporary view mode is currently active. A custom mode is active if there is a non-empty string set for CustomTitle.
Public method | IsModeActive | Tests whether a given mode is currently active or not.
Public method | IsModeAvailable | Tests whether a temporary view mode is currently available in the associated view.
Public method | IsModeEnabled | Tests whether a temporary view mode is currently enabled in the associated view.
Public method | IsValidState | Tests whether the given state is valid for the associated view and the context the view is currently in.
Public method | RemoveCustomization | Removes all customized values for the TemporaryViewProperties mode.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CustomColor | Custom color for the TemporaryViewProperties mode.
Public property | CustomTitle | Custom title for the TemporaryViewProperties mode.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | PreviewFamilyVisibility | The current state of the PreviewFamilyVisibility mode in the associated view.
 | PreviewFamilyVisibilityDefaultOnState | Controls the default state of the PreviewFamilyVisibility mode in all views.
 | PreviewFamilyVisibilityDefaultUncutState | Controls the default type of the On state of the PreviewFamilyVisibility mode in cut-able views.
Public property | RevealConstraints | The current state of the RevealConstraints mode in the associated view.
Public property | RevealHiddenElements | The current state of the RevealHiddenElements mode in the associated view.
Public property | WorksharingDisplay | The current state of the WorksharingDisplay mode in the associated view.

See Also

TemporaryViewModes Class


TemporaryViewModes Methods

[image] [image]

Revit 2024 API
TemporaryViewModes Methods
TemporaryViewModes Class See Also Send Feedback

The TemporaryViewModes type exposes the following members.

Methods

 | Name | Description
Public method | DeactivateAllModes | Deactivates all temporary modes that are currently active.
Public method | DeactivateMode | Deactivates the given temporary mode.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCaption | A text caption to use for the given mode.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCustomized | Identifies if a custom temporary view mode is currently active. A custom mode is active if there is a non-empty string set for CustomTitle.
Public method | IsModeActive | Tests whether a given mode is currently active or not.
Public method | IsModeAvailable | Tests whether a temporary view mode is currently available in the associated view.
Public method | IsModeEnabled | Tests whether a temporary view mode is currently enabled in the associated view.
Public method | IsValidState | Tests whether the given state is valid for the associated view and the context the view is currently in.
Public method | RemoveCustomization | Removes all customized values for the TemporaryViewProperties mode.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TemporaryViewModes Class


DeactivateMode Method

[image]

Revit 2024 API
TemporaryViewModes..::..DeactivateMode Method
TemporaryViewModes Class See Also Send Feedback
Deactivates the given temporary mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Update

Syntax

C#
public void DeactivateMode(
    TemporaryViewMode mode
)
Visual Basic
Public Sub DeactivateMode ( _
    mode As TemporaryViewMode _
)
Visual C++
public:
void DeactivateMode(
    TemporaryViewMode mode
)

Parameters

mode
Type: Autodesk.Revit.DB..::..TemporaryViewMode
The mode to deactivate

Remarks

The method has no effect on modes that are already deactivated.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The temporary mode is not available in the associated view. The view is either of a type that does not support this mode, or is currently in a context that makes the mode presently inapplicable. -or- The temporary mode is presently not enabled in the associated view.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

TemporaryViewModes Class


GetCaption Method

[image]

Revit 2024 API
TemporaryViewModes..::..GetCaption Method
TemporaryViewModes Class See Also Send Feedback
A text caption to use for the given mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Update

Syntax

C#
public string GetCaption(
    TemporaryViewMode mode
)
Visual Basic
Public Function GetCaption ( _
    mode As TemporaryViewMode _
) As String
Visual C++
public:
String^ GetCaption(
    TemporaryViewMode mode
)

Parameters

mode
Type: Autodesk.Revit.DB..::..TemporaryViewMode
The mode to get a caption for.

Return Value

Text of the caption. The text is localized.

Remarks

The text appears in the UI on the temporary frame when the view is in the temporary mode.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

TemporaryViewModes Class


IsCustomized Method

[image]

Revit 2024 API
TemporaryViewModes..::..IsCustomized Method
TemporaryViewModes Class See Also Send Feedback
Identifies if a custom temporary view mode is currently active. A custom mode is active if there is a non-empty string set for CustomTitle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020.1

Syntax

C#
public bool IsCustomized()
Visual Basic
Public Function IsCustomized As Boolean
Visual C++
public:
bool IsCustomized()

Return Value

Returns true a custom temporary view mode is currently active, false otherwise. A custom mode is active if there is a non-empty string set for CustomTitle.

See Also

TemporaryViewModes Class


IsModeAvailable Method

[image]

Revit 2024 API
TemporaryViewModes..::..IsModeAvailable Method
TemporaryViewModes Class See Also Send Feedback
Tests whether a temporary view mode is currently available in the associated view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Update

Syntax

C#
public bool IsModeAvailable(
    TemporaryViewMode mode
)
Visual Basic
Public Function IsModeAvailable ( _
    mode As TemporaryViewMode _
) As Boolean
Visual C++
public:
bool IsModeAvailable(
    TemporaryViewMode mode
)

Parameters

mode
Type: Autodesk.Revit.DB..::..TemporaryViewMode
The mode to evaluate

Return Value

True of the temporary mode is currently available in the associated view.

Remarks

Not every mode is available in all views at all times. Some of the modes are only available in certain views, or only at certain time/context. Modes that are not available will not be visible on the view's tool bar in the UI.

Even modes that are available do not have to be currently enabled in the current context. Before using a mode its applicability should be tested by calling IsModeEnabled(TemporaryViewMode).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

TemporaryViewModes Class


IsValidState Method

[image]

Revit 2024 API
TemporaryViewModes..::..IsValidState Method
TemporaryViewModes Class See Also Send Feedback
Tests whether the given state is valid for the associated view and the context the view is currently in.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Update

Syntax

C#
public bool IsValidState(
    PreviewFamilyVisibilityMode state
)
Visual Basic
Public Function IsValidState ( _
    state As PreviewFamilyVisibilityMode _
) As Boolean
Visual C++
public:
bool IsValidState(
    PreviewFamilyVisibilityMode state
)

Parameters

state
Type: Autodesk.Revit.DB..::..PreviewFamilyVisibilityMode
A state of the PreviewFamilyVisibilityMode

Return Value

Returns True if the state is applicable for the view; False otherwise.

Remarks

As long as the PreviewFamilyVisibility mode is available and enabled in the associated view, the Off and On states are always valid. However, the Uncut state is only valid in plan views and reflected ceilings.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

TemporaryViewModes Class


RemoveCustomization Method

[image]

Revit 2024 API
TemporaryViewModes..::..RemoveCustomization Method
TemporaryViewModes Class See Also Send Feedback
Removes all customized values for the TemporaryViewProperties mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020.1

Syntax

C#
public void RemoveCustomization()
Visual Basic
Public Sub RemoveCustomization
Visual C++
public:
void RemoveCustomization()

See Also

TemporaryViewModes Class


TemporaryViewModes Properties

[image] [image]

Revit 2024 API
TemporaryViewModes Properties
TemporaryViewModes Class See Also Send Feedback

The TemporaryViewModes type exposes the following members.

Properties

 | Name | Description
Public property | CustomColor | Custom color for the TemporaryViewProperties mode.
Public property | CustomTitle | Custom title for the TemporaryViewProperties mode.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | PreviewFamilyVisibility | The current state of the PreviewFamilyVisibility mode in the associated view.
 | PreviewFamilyVisibilityDefaultOnState | Controls the default state of the PreviewFamilyVisibility mode in all views.
 | PreviewFamilyVisibilityDefaultUncutState | Controls the default type of the On state of the PreviewFamilyVisibility mode in cut-able views.
Public property | RevealConstraints | The current state of the RevealConstraints mode in the associated view.
Public property | RevealHiddenElements | The current state of the RevealHiddenElements mode in the associated view.
Public property | WorksharingDisplay | The current state of the WorksharingDisplay mode in the associated view.

See Also

TemporaryViewModes Class


CustomColor Property

[image]

Revit 2024 API
TemporaryViewModes..::..CustomColor Property
TemporaryViewModes Class See Also Send Feedback
Custom color for the TemporaryViewProperties mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020.1

Syntax

C#
public Color CustomColor { get; set; }
Visual Basic
Public Property CustomColor As Color
    Get
    Set
Visual C++
public:
property Color^ CustomColor {
    Color^ get ();
    void set (Color^ value);
}

Remarks

If custom title is not empty, Temporary View Properties mode displays the colored view frame in custom color.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

TemporaryViewModes Class


CustomTitle Property

[image]

Revit 2024 API
TemporaryViewModes..::..CustomTitle Property
TemporaryViewModes Class See Also Send Feedback
Custom title for the TemporaryViewProperties mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020.1

Syntax

C#
public string CustomTitle { get; set; }
Visual Basic
Public Property CustomTitle As String
    Get
    Set
Visual C++
public:
property String^ CustomTitle {
    String^ get ();
    void set (String^ value);
}

Remarks

If custom title is not empty, Temporary View Properties mode displays it in the upper left corner of colored view frame.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

TemporaryViewModes Class


IsValidObject Property

[image]

Revit 2024 API
TemporaryViewModes..::..IsValidObject Property
TemporaryViewModes Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

TemporaryViewModes Class


PreviewFamilyVisibility Property

[image]

Revit 2024 API
TemporaryViewModes..::..PreviewFamilyVisibility Property
TemporaryViewModes Class Example See Also Send Feedback
The current state of the PreviewFamilyVisibility mode in the associated view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Update

Syntax

C#
public PreviewFamilyVisibilityMode PreviewFamilyVisibility { get; set; }
Visual Basic
Public Property PreviewFamilyVisibility As PreviewFamilyVisibilityMode
    Get
    Set
Visual C++
public:
property PreviewFamilyVisibilityMode PreviewFamilyVisibility {
    PreviewFamilyVisibilityMode get ();
    void set (PreviewFamilyVisibilityMode value);
}

Remarks

The state of the PreviewFamilyVisibility mode can be set only if the mode is currently available and enabled in the view. Even in such a condition, however, not all states are valid in all views. To ensure that the state to be applied is valid in the view, call the IsValidState(PreviewFamilyVisibilityMode) method first.

Even views which generally support temporary modes will have this particular mode available only when the document of the view is in the environment of the family editor.

This property affect only the view associated with this instance of TemporaryViewModes. When a view is opened for the first time, its state of the PreviewFamilyVisibility mode is determined based on the default settings which is controlled through the properties PreviewFamilyVisibilityDefaultOnState and PreviewFamilyVisibilityDefaultUncutState.

Examples

CopyC#
public void SetDefaultPreviewFamilyVisibilityState()
{
    TemporaryViewModes.PreviewFamilyVisibilityDefaultOnState = true;
    TemporaryViewModes.PreviewFamilyVisibilityDefaultUncutState = true;
}
CopyVB.NET
Public Sub SetDefaultPreviewFamilyVisibilityState()
    TemporaryViewModes.PreviewFamilyVisibilityDefaultOnState = True
    TemporaryViewModes.PreviewFamilyVisibilityDefaultUncutState = True
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The given PreviewFamilyVisibilityMode is not applicable in the associated view.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The PreviewFamilyVisibility mode is either disabled or inapplicable in the associated view.

See Also

TemporaryViewModes Class


PreviewFamilyVisibilityDefaultOnState Property

[image]

Revit 2024 API
TemporaryViewModes..::..PreviewFamilyVisibilityDefaultOnState Property
TemporaryViewModes Class Example See Also Send Feedback
Controls the default state of the PreviewFamilyVisibility mode in all views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Update

Syntax

C#
public static bool PreviewFamilyVisibilityDefaultOnState { get; set; }
Visual Basic
Public Shared Property PreviewFamilyVisibilityDefaultOnState As Boolean
    Get
    Set
Visual C++
public:
static property bool PreviewFamilyVisibilityDefaultOnState {
    bool get ();
    void set (bool value);
}

Field Value

A boolean value to control whether the PreviewFamilyVisibility mode is to be turned On or Off in all views newly opened in a family editor.

Remarks

This flag controls whether each newly opened view is to have the PreviewFamilyVisibility mode turned On by default or not. This property is applicable to all types of views. Views that support both Cut and Non-cut preview (such as floor plans) can be controlled further via the PreviewFamilyVisibilityDefaultUncutState property.

The settings is applicable to the whole application rather than to individual family documents; the value persists between Revit sessions. Although the value is allowed to be set at any time, any changes made after the Revit application has been initialized will not have effect until the next session of Revit.

After a view is opened with the default family preview state applied, its PreviewFamilyVisibility mode may be independently modified through the PreviewFamilyVisibility property. Once explicitly modified, the settings stays in effect for the respective view even after the view is closed and later reopened again.

Examples

CopyC#
public void SetDefaultPreviewFamilyVisibilityState()
{
    TemporaryViewModes.PreviewFamilyVisibilityDefaultOnState = true;
    TemporaryViewModes.PreviewFamilyVisibilityDefaultUncutState = true;
}
CopyVB.NET
Public Sub SetDefaultPreviewFamilyVisibilityState()
    TemporaryViewModes.PreviewFamilyVisibilityDefaultOnState = True
    TemporaryViewModes.PreviewFamilyVisibilityDefaultUncutState = True
End Sub

See Also

TemporaryViewModes Class


PreviewFamilyVisibilityDefaultUncutState Property

[image]

Revit 2024 API
TemporaryViewModes..::..PreviewFamilyVisibilityDefaultUncutState Property
TemporaryViewModes Class See Also Send Feedback
Controls the default type of the On state of the PreviewFamilyVisibility mode in cut-able views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Update

Syntax

C#
public static bool PreviewFamilyVisibilityDefaultUncutState { get; set; }
Visual Basic
Public Shared Property PreviewFamilyVisibilityDefaultUncutState As Boolean
    Get
    Set
Visual C++
public:
static property bool PreviewFamilyVisibilityDefaultUncutState {
    bool get ();
    void set (bool value);
}

Field Value

A Boolean value to control whether to use a non-cut preview in applicable views, such as floor and ceiling plan views.

Remarks

Newly opened views which can have both Cut and Uncut preview will use this default cut/uncut state as long as the default On state is set to True. To control the default state of the PreviewFamilyVisibility in all views refer to the PreviewFamilyVisibilityDefaultOnState property.

The settings is applicable to the whole application rather than to individual family documents; the value persists between Revit sessions. Although the value is allowed to be set at any time, any changes made after the Revit application has been initialized will not have effect until the next session of Revit.

After a view is opened with the default family preview state applied, its PreviewFamilyVisibility mode may be independently modified through the PreviewFamilyVisibility property. Once explicitly modified, the settings stays in effect for the respective view even after the view is closed and later reopened again.

See Also

TemporaryViewModes Class


RevealHiddenElements Property

[image]

Revit 2024 API
TemporaryViewModes..::..RevealHiddenElements Property
TemporaryViewModes Class See Also Send Feedback
The current state of the RevealHiddenElements mode in the associated view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Update

Syntax

C#
public bool RevealHiddenElements { get; set; }
Visual Basic
Public Property RevealHiddenElements As Boolean
    Get
    Set
Visual C++
public:
property bool RevealHiddenElements {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The RevealHiddenElements mode is either disabled or inapplicable in the associated view.

See Also

TemporaryViewModes Class


WorksharingDisplay Property

[image]

Revit 2024 API
TemporaryViewModes..::..WorksharingDisplay Property
TemporaryViewModes Class See Also Send Feedback
The current state of the WorksharingDisplay mode in the associated view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Update

Syntax

C#
public WorksharingDisplayMode WorksharingDisplay { get; set; }
Visual Basic
Public Property WorksharingDisplay As WorksharingDisplayMode
    Get
    Set
Visual C++
public:
property WorksharingDisplayMode WorksharingDisplay {
    WorksharingDisplayMode get ();
    void set (WorksharingDisplayMode value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The WorksharingDisplay mode is either disabled or inapplicable in the associated view.

See Also

TemporaryViewModes Class


TessellatedBuildIssue Class

[image]

Revit 2024 API
TessellatedBuildIssue Class
Members See Also Send Feedback
Types of issues encountered while constructing geometrical objects from the tessellated face sets.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public class TessellatedBuildIssue : IDisposable
Visual Basic
Public Class TessellatedBuildIssue _
    Implements IDisposable
Visual C++
public ref class TessellatedBuildIssue : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..TessellatedBuildIssue

See Also

TessellatedBuildIssue Members


TessellatedBuildIssue Members

[image] [image]

Revit 2024 API
TessellatedBuildIssue Members
TessellatedBuildIssue Class Methods Properties See Also Send Feedback

The TessellatedBuildIssue type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the TessellatedBuildIssue
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIssueDescription | Gets a string describing the issue. If the issue does not present a problem, then an empty string is returned.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidIssue | Reports whether the issue is well-formed, valid and does describe a real problem.
Public method | MakesDataUnusable | Reports whether this issue makes some data unusable ('true') or is only shows that data format conventions were broken, but the data are still usable (false).
Public method | ReportIssueToDataSource | Reports whether this issue should be reported to the company which wrote the software which produced the face set data (true), or to Autodesk (false).
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | NumberEncountered | How many times this issue was encountered in its face set during the face set processing. This number can be less than the total number of such issues in the face set, as the face set processing could be aborted due to the presence of the issues which could not be handled.

See Also

TessellatedBuildIssue Class


TessellatedBuildIssue Methods

[image] [image]

Revit 2024 API
TessellatedBuildIssue Methods
TessellatedBuildIssue Class See Also Send Feedback

The TessellatedBuildIssue type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIssueDescription | Gets a string describing the issue. If the issue does not present a problem, then an empty string is returned.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValidIssue | Reports whether the issue is well-formed, valid and does describe a real problem.
Public method | MakesDataUnusable | Reports whether this issue makes some data unusable ('true') or is only shows that data format conventions were broken, but the data are still usable (false).
Public method | ReportIssueToDataSource | Reports whether this issue should be reported to the company which wrote the software which produced the face set data (true), or to Autodesk (false).
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TessellatedBuildIssue Class


Dispose Method

[image]

Revit 2024 API
TessellatedBuildIssue..::..Dispose Method
TessellatedBuildIssue Class See Also Send Feedback
Releases all resources used by the TessellatedBuildIssue

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

TessellatedBuildIssue Class


GetIssueDescription Method

[image]

Revit 2024 API
TessellatedBuildIssue..::..GetIssueDescription Method
TessellatedBuildIssue Class See Also Send Feedback
Gets a string describing the issue. If the issue does not present a problem, then an empty string is returned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public string GetIssueDescription()
Visual Basic
Public Function GetIssueDescription As String
Visual C++
public:
String^ GetIssueDescription()

Return Value

Description of the issue.

See Also

TessellatedBuildIssue Class


IsValidIssue Method

[image]

Revit 2024 API
TessellatedBuildIssue..::..IsValidIssue Method
TessellatedBuildIssue Class See Also Send Feedback
Reports whether the issue is well-formed, valid and does describe a real problem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool IsValidIssue()
Visual Basic
Public Function IsValidIssue As Boolean
Visual C++
public:
bool IsValidIssue()

Return Value

Whether the issue is well formed and does describe a real problem.

See Also

TessellatedBuildIssue Class


MakesDataUnusable Method

[image]

Revit 2024 API
TessellatedBuildIssue..::..MakesDataUnusable Method
TessellatedBuildIssue Class See Also Send Feedback
Reports whether this issue makes some data unusable ('true') or is only shows that data format conventions were broken, but the data are still usable (false).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool MakesDataUnusable()
Visual Basic
Public Function MakesDataUnusable As Boolean
Visual C++
public:
bool MakesDataUnusable()

See Also

TessellatedBuildIssue Class


TessellatedBuildIssue Properties

[image] [image]

Revit 2024 API
TessellatedBuildIssue Properties
TessellatedBuildIssue Class See Also Send Feedback

The TessellatedBuildIssue type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | NumberEncountered | How many times this issue was encountered in its face set during the face set processing. This number can be less than the total number of such issues in the face set, as the face set processing could be aborted due to the presence of the issues which could not be handled.

See Also

TessellatedBuildIssue Class


IsValidObject Property

[image]

Revit 2024 API
TessellatedBuildIssue..::..IsValidObject Property
TessellatedBuildIssue Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

TessellatedBuildIssue Class


NumberEncountered Property

[image]

Revit 2024 API
TessellatedBuildIssue..::..NumberEncountered Property
TessellatedBuildIssue Class See Also Send Feedback
How many times this issue was encountered in its face set during the face set processing. This number can be less than the total number of such issues in the face set, as the face set processing could be aborted due to the presence of the issues which could not be handled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public int NumberEncountered { get; }
Visual Basic
Public ReadOnly Property NumberEncountered As Integer
    Get
Visual C++
public:
property int NumberEncountered {
    int get ();
}

See Also

TessellatedBuildIssue Class


TessellatedBuildIssueType Enumeration

[image]

Revit 2024 API
TessellatedBuildIssueType Enumeration
See Also Send Feedback
Types of issues encountered while constructing geometrical objects from the tessellatted face sets.
Issues, which can be encountered while building a polymesh, or a shell, or a solid from data, describing tessellated shapes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015
Since: 2015

Syntax

C#
public enum TessellatedBuildIssueType
Visual Basic
Public Enumeration TessellatedBuildIssueType
Visual C++
public enum class TessellatedBuildIssueType

Members

Member name | Description
AllFine | No issues were encountered. Issues of this type should not be present in TessellatedShapeBuilderResult.
EmptyFace | A face which does not have any loops. An associated number is face index.
EmptyLoop | A face loop which does not have any points. Associated numbers are face index and loop index respectively.
TooFewOriginalVertices | A face loop, which from the very beginning does not have enough points. Associated numbers are face index and loop index respectively.
TooShortOriginalLoopMeshSegment | A face loop, containing a segment which is too short even for a mesh. Associated numbers are face, loop and point indices respectively (the segment goes from the previous point to this one).
TooShortOriginalLoopGeomSegment | A face loop, containing a segment which is too short for a geometry, but not for a mesh. Associated numbers are face, loop and point indices respectively (the segment goes from the previous point to this one).
LostTooManyLoopVertices | A face loop, which originally had enough vertices, but lost too many of them, while purging pseudo-duplicates. Associated numbers are face index and loop index respectively.
OriginalLoopGeomAcuteAngle | A face loop with a too acute angle between adjacent segments. This condition is not relevant for polymesh construction. Associated numbers are face, loop and point between segments indices respectively.
OriginalLoopMeshAcuteAngle | A face loop with a too acute angle between adjacent segments. This condition is not relevant for polymesh construction. Associated numbers are face, loop and point between segments indices respectively.
LostAllLoops | A face, which originally had enough loops lost all of them during purges. An associated number is face index.
NonPlanarFace | A face which is not planar. An associated number is face index.
OriginalPointsTooFarFromTheirPlane | A face whose original points taken together do define a plane, but some of them lie to far from it. An associated number is face index.
TooSmallVertexSegementDistInOriginalLoop | A face loop with too small vertex-segment distance. Associated numbers are face, loop, segment and vertex indices respectively.
LoopOnBestFitSelfIntersects | A face loop whose projection of the best-fit-plane self-intersects. Associated numbers are face, loop, and two segments indices respectively.
IntersectingOriginalLoops | A face whose loops intersect. Associated numbers are face and two loop indices respectively.
FaceWithIslands | A face which has a loop inside a loop inside a loop. Associated numbers are face and three loop indices respectively.
OriginalLoopsProximity | A face with excessive proximity between face loops. Associated numbers are face and two loop indices respectively.
OuterLoopIsNotFirst | A face have multiple loops, but the outer loop is not listed as the very first one. Associated numbers are face and loop indices respectively.
DegenOriginalLoop | A degenerate face loop is degenerate. Associated numbers are face and loop indices respectively.
InconsistentInnerOuterOriginalLoopCCW | A face where the CCW of inner loop is inconsistent with CCW of the outer loop. Associated numbers are face and inner loop indices respectively.
EdgeTwiceUsedByFace | A face with an edge encountered in the loops multiple times. Associated numbers are face and loop in which the problem became obvious indices respectively.
NonManifoldEdge | Same edge is used by more than two faces. This issue can be posted for topologically impossible face sets as well as for face sets with duplicate faces. Associated numbers are face and loop in which the problem became obvious indices respectively.
OverlappingAdjacentFaces | Adjacent faces which either exactly overlaps or have a too acute angle between them. This issue can be reported for face sets with duplicate faces as well. Associated numbers are face and loop indices of one face and face and loop indices of another face respectively.
PartitionPointsTooFarFromTrueEdge | Points representing partitions of input points are too far from the true edge. Associated numbers are face and loop indices, an index of the vertex in the beginning of the segment which is too far from the corresponding true edge, an index of another involved face respectively.
EdgeTraversalForFlip | A face edge with topological problems. Associated numbers are indices of the face, loop and vertex and an index of another involved face respectively.
InconsitentMultiEdgeTraversalForFlip | A face edge with topological problems. Associated numbers are indices of the involved faces.
TooSmallVertexSegementDistInFinalLoop | A face loop with too small vertex-segment distance. Associated numbers are face, loop, segment and vertex indices respectively
InternalUtilityError | An internal Revit problem. Issues of this type should not be present in TessellatedShapeBuilderResult. Please notify Autodesk support if encountered.
InternalError | An internal Revit problem. Issues of this type should not be present in TessellatedShapeBuilderResult. Please notify Autodesk support if encountered. Associated number is face index.
InternalLightError | An internal Revit problem. Issues of this type should not be present in TessellatedShapeBuilderResult. Please notify Autodesk support if encountered. Associated number is face index.
InternalMissingError | An internal Revit problem. Issues of this type should not be present in TessellatedShapeBuilderResult. Please notify Autodesk support if encountered. Associated number is face index.
UnarticulatedNonManifoldEdge | An input face is mising an edge conecting two non-adjacent vertices from its boundaries, which are adjacent in the boundaries of some other face(s). If such an edge would be added, it would split the face and result in 'NonManifoldEdge' or other issues. Associated numbers are indices of a face which misses an edge and indices of one or two faces in which boundaries such edge is present.
NotSetYet | An issue has not been set yet.
NumberOfIssueTypes | Not a code of some issue, but the number of known types of issues. Issues of this type should not be present in TessellatedShapeBuilderResult. Please notify Autodesk support if encountered

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


TessellatedFace Class

[image]

Revit 2024 API
TessellatedFace Class
Members See Also Send Feedback
Defines a planar face bounded by a polyline in 3d space. A face consists of a single connected component and can have holes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public class TessellatedFace : IDisposable
Visual Basic
Public Class TessellatedFace _
    Implements IDisposable
Visual C++
public ref class TessellatedFace : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..TessellatedFace

See Also

TessellatedFace Members


TessellatedFace Members

[image] [image]

Revit 2024 API
TessellatedFace Members
TessellatedFace Class Constructors Methods Properties See Also Send Feedback

The TessellatedFace type exposes the following members.

Constructors

 | Name | Description
Public method | TessellatedFace(IList<(Of <<'(XYZ>)>>), ElementId) | Constructs a tessellated face without holes. Face data is always set, even if the input data are invalid (e.g., describes a wildly non-planar face). A TessellatedShepeBuilder's function is used to check the data and heal them if possible.
Public method | TessellatedFace(IList<(Of <<'(IList<(Of <<'(XYZ>)>>)>)>>), ElementId) | Constructs a tessellated face, which, may be, have holes. Face data is always set, even if the input data are invalid (e.g., describes a wildly non-planar face). A TessellatedShepeBuilder's function is used to check the data and heal them if possible.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the TessellatedFace
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBoundaryLoops | Get loops bounding the face.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MaterialId | Material of the face.

See Also

TessellatedFace Class


TessellatedFace Constructor

[image] [image]

Revit 2024 API
TessellatedFace Constructor
TessellatedFace Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TessellatedFace(IList<(Of <<'(XYZ>)>>), ElementId) | Constructs a tessellated face without holes. Face data is always set, even if the input data are invalid (e.g., describes a wildly non-planar face). A TessellatedShepeBuilder's function is used to check the data and heal them if possible.
Public method | TessellatedFace(IList<(Of <<'(IList<(Of <<'(XYZ>)>>)>)>>), ElementId) | Constructs a tessellated face, which, may be, have holes. Face data is always set, even if the input data are invalid (e.g., describes a wildly non-planar face). A TessellatedShepeBuilder's function is used to check the data and heal them if possible.

See Also

TessellatedFace Class
TessellatedFace Members


TessellatedFace Constructor (IList(XYZ), ElementId)

[image]

Revit 2024 API
TessellatedFace Constructor (IList<(Of <(<'XYZ>)>)>, ElementId)
TessellatedFace Class See Also Send Feedback
Constructs a tessellated face without holes. Face data is always set, even if the input data are invalid (e.g., describes a wildly non-planar face). A TessellatedShepeBuilder's function is used to check the data and heal them if possible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public TessellatedFace(
    IList<XYZ> outerLoopVertices,
    ElementId materialId
)
Visual Basic
Public Sub New ( _
    outerLoopVertices As IList(Of XYZ), _
    materialId As ElementId _
)
Visual C++
public:
TessellatedFace(
    IList<XYZ^>^ outerLoopVertices,
    ElementId^ materialId
)

Parameters

outerLoopVertices
Type: System.Collections.Generic..::..IList<(Of <(<' XYZ >)>)>
Boundary vertices without duplication of the ends - i.e., a boundary of a triangular face consists of 3 (and NOT 4) vertices. It is expected that boundaries are in CCW order with respect to the face normal in the solid. Boundaries in CW order will still be handled by TessellatedShapeBuilder, but performance may deteriorate. Contents of this parameter will be changed while constructing the face.
materialId
Type: Autodesk.Revit.DB..::..ElementId
Material of the face to be used when the result is a Solid or a Sheet. If the result is a Mesh, a material will be assigned to the entire Mesh.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

TessellatedFace Class
TessellatedFace Overload


TessellatedFace Constructor (IList(IList(XYZ)), ElementId)

[image]

Revit 2024 API
TessellatedFace Constructor (IList<(Of <(<'IList<(Of <(<'XYZ>)>)>>)>)>, ElementId)
TessellatedFace Class See Also Send Feedback
Constructs a tessellated face, which, may be, have holes. Face data is always set, even if the input data are invalid (e.g., describes a wildly non-planar face). A TessellatedShepeBuilder's function is used to check the data and heal them if possible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public TessellatedFace(
    IList<IList<XYZ>> allLoopVertices,
    ElementId materialId
)
Visual Basic
Public Sub New ( _
    allLoopVertices As IList(Of IList(Of XYZ)), _
    materialId As ElementId _
)
Visual C++
public:
TessellatedFace(
    IList<IList<XYZ^>^>^ allLoopVertices,
    ElementId^ materialId
)

Parameters

allLoopVertices
Type: System.Collections.Generic..::..IList<(Of <(<'IList<(Of <(<' XYZ >)>)>>)>)>
Boundary vertices without duplication of the ends - i.e., a boundary of a triangular face consists of 3 (and NOT 4) vertices. The first array describes the outer loop, the following arrays, if any - inner loops. It is expected that vertices of outer boundary are listed in CCW order with respect to the face normal in the solid, while the vertices of inner loops - in CW order. The vertices listed in the wrong order will still be handled by TessellatedShapeBuilder, but performance may deteriorate. Contents of this parameter will be changed while constructing the face.
materialId
Type: Autodesk.Revit.DB..::..ElementId
Material of the face to be used when the result is a Solid or a Sheet. If the result is a Mesh, a material will be assigned to the entire Mesh.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

TessellatedFace Class
TessellatedFace Overload


TessellatedFace Methods

[image] [image]

Revit 2024 API
TessellatedFace Methods
TessellatedFace Class See Also Send Feedback

The TessellatedFace type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBoundaryLoops | Get loops bounding the face.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TessellatedFace Class


Dispose Method

[image]

Revit 2024 API
TessellatedFace..::..Dispose Method
TessellatedFace Class See Also Send Feedback
Releases all resources used by the TessellatedFace

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

TessellatedFace Class


GetBoundaryLoops Method

[image]

Revit 2024 API
TessellatedFace..::..GetBoundaryLoops Method
TessellatedFace Class See Also Send Feedback
Get loops bounding the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public IList<IList<XYZ>> GetBoundaryLoops()
Visual Basic
Public Function GetBoundaryLoops As IList(Of IList(Of XYZ))
Visual C++
public:
IList<IList<XYZ^>^>^ GetBoundaryLoops()

See Also

TessellatedFace Class


TessellatedFace Properties

[image] [image]

Revit 2024 API
TessellatedFace Properties
TessellatedFace Class See Also Send Feedback

The TessellatedFace type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MaterialId | Material of the face.

See Also

TessellatedFace Class


IsValidObject Property

[image]

Revit 2024 API
TessellatedFace..::..IsValidObject Property
TessellatedFace Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

TessellatedFace Class


MaterialId Property

[image]

Revit 2024 API
TessellatedFace..::..MaterialId Property
TessellatedFace Class See Also Send Feedback
Material of the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public ElementId MaterialId { get; set; }
Visual Basic
Public Property MaterialId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ MaterialId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

TessellatedFace Class


TessellatedShapeBuilder Class

[image]

Revit 2024 API
TessellatedShapeBuilder Class
Members Example See Also Send Feedback
A class that permits structured building of geometry or a mesh from a collection of connected faces. Contains all closed face sets and custom precisions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public class TessellatedShapeBuilder : ShapeBuilder
Visual Basic
Public Class TessellatedShapeBuilder _
    Inherits ShapeBuilder
Visual C++
public ref class TessellatedShapeBuilder : public ShapeBuilder

Remarks

Creates a geometry populated with faces defined by TessellatedFace objects stored in the input connected face sets. The faces defined by each connected face set may form an open shell or the boundary of a solid 3D region. All faces are planar and have polyline boundaries, defined as sequences of 3d coordinates. Faces are added to the builder as a part of connected face sets, representing faces which share edges. Order of faces in the sets is irrelevant. Faces can only be added to the builder when a face set has been opened and is available to take in faces (use OpenConnectedFaceSet(Boolean) to open a new face set). Before attempting to build Revit geometry from the builder the current face set should be closed (CloseConnectedFaceSet()()()()). The builder allows for the possibility of multiple face sets. The builder will try to create a geometry valid in Revit despite inconsistencies or omissions in the input data.
  • For each connected face set, it will check the face orientations and change them wherever needed so that the orientations of the faces in that set are consistent.
  • If a connected face set is closed, it will check if the face normals point outward. If not, it will reverse the orientations of all faces. That means, each closed connected face set will represent a solid.
Limitations in the current implementation:
  • It does not support the definition of a "void", even if the user had set the orientations of the faces to define a "void".
  • If there is more than one connected face set, it does not check if they intersect or overlap each other.

Examples

CopyC#
// Create a pyramid-shaped DirectShape using given material for the faces
public void CreateTessellatedShape(Document doc, ElementId materialId)
{
    List<XYZ> loopVertices = new List<XYZ>(4);

    TessellatedShapeBuilder builder = new TessellatedShapeBuilder();

    builder.OpenConnectedFaceSet(true);
    // create a pyramid with a square base 4' x 4' and 5' high
    double length = 4.0;
    double height = 5.0;

    XYZ basePt1 = XYZ.Zero;
    XYZ basePt2 = new XYZ(length, 0, 0);
    XYZ basePt3 = new XYZ(length, length, 0);
    XYZ basePt4 = new XYZ(0, length, 0);
    XYZ apex = new XYZ(length / 2, length / 2, height);

    loopVertices.Add(basePt1);
    loopVertices.Add(basePt2);
    loopVertices.Add(basePt3);
    loopVertices.Add(basePt4);
    builder.AddFace(new TessellatedFace(loopVertices, materialId));

    loopVertices.Clear();
    loopVertices.Add(basePt1);
    loopVertices.Add(apex);
    loopVertices.Add(basePt2);
    builder.AddFace(new TessellatedFace(loopVertices, materialId));

    loopVertices.Clear();
    loopVertices.Add(basePt2);
    loopVertices.Add(apex);
    loopVertices.Add(basePt3);
    builder.AddFace(new TessellatedFace(loopVertices, materialId));

    loopVertices.Clear();
    loopVertices.Add(basePt3);
    loopVertices.Add(apex);
    loopVertices.Add(basePt4);
    builder.AddFace(new TessellatedFace(loopVertices, materialId));

    loopVertices.Clear();
    loopVertices.Add(basePt4);
    loopVertices.Add(apex);
    loopVertices.Add(basePt1);
    builder.AddFace(new TessellatedFace(loopVertices, materialId));

    builder.CloseConnectedFaceSet();
    builder.Target = TessellatedShapeBuilderTarget.Solid;
    builder.Fallback = TessellatedShapeBuilderFallback.Abort;
    builder.Build();

    TessellatedShapeBuilderResult result = builder.GetBuildResult();

    using (Transaction t = new Transaction(doc, "Create tessellated direct shape"))
    {
        t.Start();

        DirectShape ds = DirectShape.CreateElement(doc, new ElementId(BuiltInCategory.OST_GenericModel));
       ds.ApplicationId = "Application id";
       ds.ApplicationDataId = "Geometry object id";

        ds.SetShape(result.GetGeometricalObjects());
        t.Commit();
    }
}
CopyVB.NET
' Create a pyramid-shaped DirectShape using given material for the faces
Public Sub CreateTessellatedShape(doc As Document, materialId As ElementId)
    Dim loopVertices As New List(Of XYZ)(4)

    Dim builder As New TessellatedShapeBuilder()

    builder.OpenConnectedFaceSet(True)
    ' create a pyramid with a square base 4' x 4' and 5' high
    Dim length As Double = 4.0
    Dim height As Double = 5.0

    Dim basePt1 As XYZ = XYZ.Zero
    Dim basePt2 As New XYZ(length, 0, 0)
    Dim basePt3 As New XYZ(length, length, 0)
    Dim basePt4 As New XYZ(0, length, 0)
    Dim apex As New XYZ(length / 2, length / 2, height)

    loopVertices.Add(basePt1)
    loopVertices.Add(basePt2)
    loopVertices.Add(basePt3)
    loopVertices.Add(basePt4)
    builder.AddFace(New TessellatedFace(loopVertices, materialId))

    loopVertices.Clear()
    loopVertices.Add(basePt1)
    loopVertices.Add(apex)
    loopVertices.Add(basePt2)
    builder.AddFace(New TessellatedFace(loopVertices, materialId))

    loopVertices.Clear()
    loopVertices.Add(basePt2)
    loopVertices.Add(apex)
    loopVertices.Add(basePt3)
    builder.AddFace(New TessellatedFace(loopVertices, materialId))

    loopVertices.Clear()
    loopVertices.Add(basePt3)
    loopVertices.Add(apex)
    loopVertices.Add(basePt4)
    builder.AddFace(New TessellatedFace(loopVertices, materialId))

    loopVertices.Clear()
    loopVertices.Add(basePt4)
    loopVertices.Add(apex)
    loopVertices.Add(basePt1)
    builder.AddFace(New TessellatedFace(loopVertices, materialId))

    builder.CloseConnectedFaceSet()
    builder.Target = TessellatedShapeBuilderTarget.Solid
    builder.Fallback = TessellatedShapeBuilderFallback.Abort
    builder.Build()

    Dim result As TessellatedShapeBuilderResult = builder.GetBuildResult()

    Using t As New Transaction(doc, "Create tessellated direct shape")
        t.Start()

        Dim ds As DirectShape = DirectShape.CreateElement(doc, New ElementId(BuiltInCategory.OST_GenericModel))
        ds.ApplicationId = "Application id"
        ds.ApplicationDataId = "Geometry object id"

        ds.SetShape(result.GetGeometricalObjects())
        t.Commit()
    End Using
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ShapeBuilder
Autodesk.Revit.DB..::..TessellatedShapeBuilder

See Also

TessellatedShapeBuilder Members


TessellatedShapeBuilder Members

[image] [image]

Revit 2024 API
TessellatedShapeBuilder Members
TessellatedShapeBuilder Class Constructors Methods Properties See Also Send Feedback

The TessellatedShapeBuilder type exposes the following members.

Constructors

 | Name | Description
Public method | TessellatedShapeBuilder | Constructs a new instance of a TessellatedShapeBuilder.

Methods

 | Name | Description
Public method | AddFace | Adds a face to the currently open connected face set.
Public method | AreTargetAndFallbackCompatible | Checks whether this combination of fallback and target parameters can be used as a valid combination of inputs.
Public method | Build | Builds the designated geometrical objects from the stored face sets. Stores the result in this TessellatedShapeBuilder object.
Public method | CancelConnectedFaceSet | Cancels the current face set - i.e., all data from it will be lost and the builder will have no open connected face set anymore.
Public method | Clear | Erases all face set and clears the logs, if any.
Public method | CloseConnectedFaceSet | Closes the currently open connected face set.
 | CreateMeshByExtrusion | Builds a mesh by extruding curve loop(s) along extrusion distance.
Public method | Dispose | (Inherited from ShapeBuilder.)
Public method | DoesFaceHaveEnoughLoopsAndVertices | Checks whether 'face' has enough loops and vertcies to be valid.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBuildResult | Get the built geometry, build status and other data stored in TessellatedShapeBuilderResult. Clears the stored data.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OpenConnectedFaceSet | Opens a new connected face set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Fallback | Defines acceptable fallback if the desired type of geometry can't be built.
Public property | GraphicsStyleId | Optional - if set, the built geometry will use that graphics style.
Public property | IsFaceSetOpen | Flag whether the current set of connected faces is open and additional tessellation faces can be added to it.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ShapeBuilder.)
Public property | LogInteger | Integer value used for logging, if it is performed. Usually the number of the face set(s) in the IFC file, from which they are imported. Any value is acceptable.
Public property | LogString | String used for logging, if any. Usually the name of the file from which face sets were imported.
Public property | NumberOfCompletedFaceSets | Number of completed face sets.
Public property | OwnerInfo | String used for logging, if any. Usually describes the element or object, which either defined or will own the geoemtrical objects to be built.
Public property | Target | Requests the type of geometry to be built.

See Also

TessellatedShapeBuilder Class


TessellatedShapeBuilder Constructor

[image]

Revit 2024 API
TessellatedShapeBuilder Constructor
TessellatedShapeBuilder Class See Also Send Feedback
Constructs a new instance of a TessellatedShapeBuilder.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public TessellatedShapeBuilder()
Visual Basic
Public Sub New
Visual C++
public:
TessellatedShapeBuilder()

See Also

TessellatedShapeBuilder Class


TessellatedShapeBuilder Methods

[image] [image]

Revit 2024 API
TessellatedShapeBuilder Methods
TessellatedShapeBuilder Class See Also Send Feedback

The TessellatedShapeBuilder type exposes the following members.

Methods

 | Name | Description
Public method | AddFace | Adds a face to the currently open connected face set.
Public method | AreTargetAndFallbackCompatible | Checks whether this combination of fallback and target parameters can be used as a valid combination of inputs.
Public method | Build | Builds the designated geometrical objects from the stored face sets. Stores the result in this TessellatedShapeBuilder object.
Public method | CancelConnectedFaceSet | Cancels the current face set - i.e., all data from it will be lost and the builder will have no open connected face set anymore.
Public method | Clear | Erases all face set and clears the logs, if any.
Public method | CloseConnectedFaceSet | Closes the currently open connected face set.
 | CreateMeshByExtrusion | Builds a mesh by extruding curve loop(s) along extrusion distance.
Public method | Dispose | (Inherited from ShapeBuilder.)
Public method | DoesFaceHaveEnoughLoopsAndVertices | Checks whether 'face' has enough loops and vertcies to be valid.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBuildResult | Get the built geometry, build status and other data stored in TessellatedShapeBuilderResult. Clears the stored data.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OpenConnectedFaceSet | Opens a new connected face set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TessellatedShapeBuilder Class


AddFace Method

[image]

Revit 2024 API
TessellatedShapeBuilder..::..AddFace Method
TessellatedShapeBuilder Class See Also Send Feedback
Adds a face to the currently open connected face set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public void AddFace(
    TessellatedFace face
)
Visual Basic
Public Sub AddFace ( _
    face As TessellatedFace _
)
Visual C++
public:
void AddFace(
    TessellatedFace^ face
)

Parameters

face
Type: Autodesk.Revit.DB..::..TessellatedFace
Face to add. The 'face' parameter can be added only once, as its boundary loops will be cleared while adding and 'face' will become unusable.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The 'face' does not have enough loops and/or vertices to be valid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | A face set is closed and faces cannot be added to it.

See Also

TessellatedShapeBuilder Class


Build Method

[image]

Revit 2024 API
TessellatedShapeBuilder..::..Build Method
TessellatedShapeBuilder Class See Also Send Feedback
Builds the designated geometrical objects from the stored face sets. Stores the result in this TessellatedShapeBuilder object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public void Build()
Visual Basic
Public Sub Build
Visual C++
public:
void Build()

Remarks

The behavior of this function is affected by Target, Fallback and GStyleId properties of this TessellatedShapeBuilder object. Currently only "Solid/Abort", "AnyGeometry/Mesh" and "Mesh/Salvage" target/fallback combinations are supported. Note that this function does not erase the face sets stored in the builder. If the same builder is used to construct geometrical objects for different collections of face sets, (Clear()()()()) should be called while switching from one collection to another.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Throws if data in the stored face sets are so inconsistent, that they cannot be used in their entirety, or if an attempt is made to create unacceptable geometry with too many facets.

See Also

TessellatedShapeBuilder Class


CancelConnectedFaceSet Method

[image]

Revit 2024 API
TessellatedShapeBuilder..::..CancelConnectedFaceSet Method
TessellatedShapeBuilder Class See Also Send Feedback
Cancels the current face set - i.e., all data from it will be lost and the builder will have no open connected face set anymore.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public void CancelConnectedFaceSet()
Visual Basic
Public Sub CancelConnectedFaceSet
Visual C++
public:
void CancelConnectedFaceSet()

Remarks

This function can be safely called upon builder without an open face set.

See Also

TessellatedShapeBuilder Class


Clear Method

[image]

Revit 2024 API
TessellatedShapeBuilder..::..Clear Method
TessellatedShapeBuilder Class See Also Send Feedback
Erases all face set and clears the logs, if any.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

Remarks

This function can be safely called upon builder without an open face set.

See Also

TessellatedShapeBuilder Class


CloseConnectedFaceSet Method

[image]

Revit 2024 API
TessellatedShapeBuilder..::..CloseConnectedFaceSet Method
TessellatedShapeBuilder Class See Also Send Feedback
Closes the currently open connected face set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public void CloseConnectedFaceSet()
Visual Basic
Public Sub CloseConnectedFaceSet
Visual C++
public:
void CloseConnectedFaceSet()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | A face set is empty and cannot be closed until some faces are added.

See Also

TessellatedShapeBuilder Class


CreateMeshByExtrusion Method

[image]

Revit 2024 API
TessellatedShapeBuilder..::..CreateMeshByExtrusion Method
TessellatedShapeBuilder Class See Also Send Feedback
Builds a mesh by extruding curve loop(s) along extrusion distance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static MeshFromGeometryOperationResult CreateMeshByExtrusion(
    IList<CurveLoop> profileLoops,
    XYZ extrusionDirection,
    double extrusionDistance,
    ElementId materialId
)
Visual Basic
Public Shared Function CreateMeshByExtrusion ( _
    profileLoops As IList(Of CurveLoop), _
    extrusionDirection As XYZ, _
    extrusionDistance As Double, _
    materialId As ElementId _
) As MeshFromGeometryOperationResult
Visual C++
public:
static MeshFromGeometryOperationResult^ CreateMeshByExtrusion(
    IList<CurveLoop^>^ profileLoops,
    XYZ^ extrusionDirection,
    double extrusionDistance,
    ElementId^ materialId
)

Parameters

profileLoops
Type: System.Collections.Generic..::..IList<(Of <(<' CurveLoop >)>)>
The profile loops to be extruded. The loops will not be modified.
extrusionDirection
Type: Autodesk.Revit.DB..::..XYZ
Direction of extrusion. The length of this vector is ignored.
extrusionDistance
Type: System..::..Double
The positive distance by which the loops are extruded in the direction of the input extrusionDir.
materialId
Type: Autodesk.Revit.DB..::..ElementId
Material which should be used by a constructed mesh.

Return Value

Returns a mesh, which was constructed, and some additional information.

Remarks

This function supports creation of a mesh given a collection of continuous curve loops, which are processed independently from each other. Loops with gaps or with curves with wrong flips will be split before processing.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input value cannot be used as thickness for an extrusion, or blend, or wall layer, or similar geometric construct.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | extrusionDirection has zero length.

See Also

TessellatedShapeBuilder Class


DoesFaceHaveEnoughLoopsAndVertices Method

[image]

Revit 2024 API
TessellatedShapeBuilder..::..DoesFaceHaveEnoughLoopsAndVertices Method
TessellatedShapeBuilder Class See Also Send Feedback
Checks whether 'face' has enough loops and vertcies to be valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool DoesFaceHaveEnoughLoopsAndVertices(
    TessellatedFace face
)
Visual Basic
Public Function DoesFaceHaveEnoughLoopsAndVertices ( _
    face As TessellatedFace _
) As Boolean
Visual C++
public:
bool DoesFaceHaveEnoughLoopsAndVertices(
    TessellatedFace^ face
)

Parameters

face
Type: Autodesk.Revit.DB..::..TessellatedFace
The face to check.

Remarks

Face 'face' is not modified.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

TessellatedShapeBuilder Class


GetBuildResult Method

[image]

Revit 2024 API
TessellatedShapeBuilder..::..GetBuildResult Method
TessellatedShapeBuilder Class See Also Send Feedback
Get the built geometry, build status and other data stored in TessellatedShapeBuilderResult. Clears the stored data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public TessellatedShapeBuilderResult GetBuildResult()
Visual Basic
Public Function GetBuildResult As TessellatedShapeBuilderResult
Visual C++
public:
TessellatedShapeBuilderResult^ GetBuildResult()

See Also

TessellatedShapeBuilder Class


OpenConnectedFaceSet Method

[image]

Revit 2024 API
TessellatedShapeBuilder..::..OpenConnectedFaceSet Method
TessellatedShapeBuilder Class See Also Send Feedback
Opens a new connected face set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public void OpenConnectedFaceSet(
    bool isSolid
)
Visual Basic
Public Sub OpenConnectedFaceSet ( _
    isSolid As Boolean _
)
Visual C++
public:
void OpenConnectedFaceSet(
    bool isSolid
)

Parameters

isSolid
Type: System..::..Boolean
Whether the face set, which is being open, should be build as a solid or as a void.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | A face set is open and a geometry cannot be build until it is closed.

See Also

TessellatedShapeBuilder Class


TessellatedShapeBuilder Properties

[image] [image]

Revit 2024 API
TessellatedShapeBuilder Properties
TessellatedShapeBuilder Class See Also Send Feedback

The TessellatedShapeBuilder type exposes the following members.

Properties

 | Name | Description
Public property | Fallback | Defines acceptable fallback if the desired type of geometry can't be built.
Public property | GraphicsStyleId | Optional - if set, the built geometry will use that graphics style.
Public property | IsFaceSetOpen | Flag whether the current set of connected faces is open and additional tessellation faces can be added to it.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ShapeBuilder.)
Public property | LogInteger | Integer value used for logging, if it is performed. Usually the number of the face set(s) in the IFC file, from which they are imported. Any value is acceptable.
Public property | LogString | String used for logging, if any. Usually the name of the file from which face sets were imported.
Public property | NumberOfCompletedFaceSets | Number of completed face sets.
Public property | OwnerInfo | String used for logging, if any. Usually describes the element or object, which either defined or will own the geoemtrical objects to be built.
Public property | Target | Requests the type of geometry to be built.

See Also

TessellatedShapeBuilder Class


Fallback Property

[image]

Revit 2024 API
TessellatedShapeBuilder..::..Fallback Property
TessellatedShapeBuilder Class See Also Send Feedback
Defines acceptable fallback if the desired type of geometry can't be built.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public TessellatedShapeBuilderFallback Fallback { get; set; }
Visual Basic
Public Property Fallback As TessellatedShapeBuilderFallback
    Get
    Set
Visual C++
public:
property TessellatedShapeBuilderFallback Fallback {
    TessellatedShapeBuilderFallback get ();
    void set (TessellatedShapeBuilderFallback value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

TessellatedShapeBuilder Class


GraphicsStyleId Property

[image]

Revit 2024 API
TessellatedShapeBuilder..::..GraphicsStyleId Property
TessellatedShapeBuilder Class See Also Send Feedback
Optional - if set, the built geometry will use that graphics style.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public ElementId GraphicsStyleId { get; set; }
Visual Basic
Public Property GraphicsStyleId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ GraphicsStyleId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

TessellatedShapeBuilder Class


IsFaceSetOpen Property

[image]

Revit 2024 API
TessellatedShapeBuilder..::..IsFaceSetOpen Property
TessellatedShapeBuilder Class See Also Send Feedback
Flag whether the current set of connected faces is open and additional tessellation faces can be added to it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool IsFaceSetOpen { get; }
Visual Basic
Public ReadOnly Property IsFaceSetOpen As Boolean
    Get
Visual C++
public:
property bool IsFaceSetOpen {
    bool get ();
}

See Also

TessellatedShapeBuilder Class


LogInteger Property

[image]

Revit 2024 API
TessellatedShapeBuilder..::..LogInteger Property
TessellatedShapeBuilder Class See Also Send Feedback
Integer value used for logging, if it is performed. Usually the number of the face set(s) in the IFC file, from which they are imported. Any value is acceptable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public int LogInteger { get; set; }
Visual Basic
Public Property LogInteger As Integer
    Get
    Set
Visual C++
public:
property int LogInteger {
    int get ();
    void set (int value);
}

See Also

TessellatedShapeBuilder Class


NumberOfCompletedFaceSets Property

[image]

Revit 2024 API
TessellatedShapeBuilder..::..NumberOfCompletedFaceSets Property
TessellatedShapeBuilder Class See Also Send Feedback
Number of completed face sets.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public int NumberOfCompletedFaceSets { get; }
Visual Basic
Public ReadOnly Property NumberOfCompletedFaceSets As Integer
    Get
Visual C++
public:
property int NumberOfCompletedFaceSets {
    int get ();
}

See Also

TessellatedShapeBuilder Class


OwnerInfo Property

[image]

Revit 2024 API
TessellatedShapeBuilder..::..OwnerInfo Property
TessellatedShapeBuilder Class See Also Send Feedback
String used for logging, if any. Usually describes the element or object, which either defined or will own the geoemtrical objects to be built.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public string OwnerInfo { get; set; }
Visual Basic
Public Property OwnerInfo As String
    Get
    Set
Visual C++
public:
property String^ OwnerInfo {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

TessellatedShapeBuilder Class


Target Property

[image]

Revit 2024 API
TessellatedShapeBuilder..::..Target Property
TessellatedShapeBuilder Class See Also Send Feedback
Requests the type of geometry to be built.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public TessellatedShapeBuilderTarget Target { get; set; }
Visual Basic
Public Property Target As TessellatedShapeBuilderTarget
    Get
    Set
Visual C++
public:
property TessellatedShapeBuilderTarget Target {
    TessellatedShapeBuilderTarget get ();
    void set (TessellatedShapeBuilderTarget value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

TessellatedShapeBuilder Class


TessellatedShapeBuilderResult Class

[image]

Revit 2024 API
TessellatedShapeBuilderResult Class
Members See Also Send Feedback
Describes what TessellatedShapeBuilder has construct.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public class TessellatedShapeBuilderResult : IDisposable
Visual Basic
Public Class TessellatedShapeBuilderResult _
    Implements IDisposable
Visual C++
public ref class TessellatedShapeBuilderResult : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..TessellatedShapeBuilderResult

See Also

TessellatedShapeBuilderResult Members


TessellatedShapeBuilderResult Members

[image] [image]

Revit 2024 API
TessellatedShapeBuilderResult Members
TessellatedShapeBuilderResult Class Methods Properties See Also Send Feedback

The TessellatedShapeBuilderResult type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the TessellatedShapeBuilderResult
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetGeometricalObjects | When called the first time, returns geometrical objects which were built. Later calls will throw exceptions.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIssuesForFaceSet | Returns the array of issues encountered while processing a face set with index 'setIndex'.
Public method | GetNumberOfFaceSets | Gets number of face sets for which 'this' result was obtained.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AreObjectsAvailable | Shows whether 'issues' still contains the original data or whether these data have already been relinquished by 'getGeometricalObjects'. The former is true, the later is false.
Public property | HasInvalidData | Whether there were any inconsistencies in the face sets, stored in the tessellated shape builder while building geometrical objects.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Outcome | What kinds of geometrical objects were built.

See Also

TessellatedShapeBuilderResult Class


TessellatedShapeBuilderResult Methods

[image] [image]

Revit 2024 API
TessellatedShapeBuilderResult Methods
TessellatedShapeBuilderResult Class See Also Send Feedback

The TessellatedShapeBuilderResult type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetGeometricalObjects | When called the first time, returns geometrical objects which were built. Later calls will throw exceptions.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIssuesForFaceSet | Returns the array of issues encountered while processing a face set with index 'setIndex'.
Public method | GetNumberOfFaceSets | Gets number of face sets for which 'this' result was obtained.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TessellatedShapeBuilderResult Class


Dispose Method

[image]

Revit 2024 API
TessellatedShapeBuilderResult..::..Dispose Method
TessellatedShapeBuilderResult Class See Also Send Feedback
Releases all resources used by the TessellatedShapeBuilderResult

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

TessellatedShapeBuilderResult Class


GetGeometricalObjects Method

[image]

Revit 2024 API
TessellatedShapeBuilderResult..::..GetGeometricalObjects Method
TessellatedShapeBuilderResult Class See Also Send Feedback
When called the first time, returns geometrical objects which were built. Later calls will throw exceptions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public IList<GeometryObject> GetGeometricalObjects()
Visual Basic
Public Function GetGeometricalObjects As IList(Of GeometryObject)
Visual C++
public:
IList<GeometryObject^>^ GetGeometricalObjects()

Return Value

Geometrical object which were built.

Remarks

Normally an array contains a single geometrical object corresponding to either 'target' or 'fallback' type', but if multiple face sets are being built with target/fallback of "AnyGeometry/Mesh", then a two-element array with both geometry as the 1st element and mesh as the 2nd can be returned. It happens if some of the face sets require a fallback processing and some do not.

See Also

TessellatedShapeBuilderResult Class


GetIssuesForFaceSet Method

[image]

Revit 2024 API
TessellatedShapeBuilderResult..::..GetIssuesForFaceSet Method
TessellatedShapeBuilderResult Class See Also Send Feedback
Returns the array of issues encountered while processing a face set with index 'setIndex'.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public IList<TessellatedBuildIssue> GetIssuesForFaceSet(
    int setIndex
)
Visual Basic
Public Function GetIssuesForFaceSet ( _
    setIndex As Integer _
) As IList(Of TessellatedBuildIssue)
Visual C++
public:
IList<TessellatedBuildIssue^>^ GetIssuesForFaceSet(
    int setIndex
)

Parameters

setIndex
Type: System..::..Int32
Index of the face set.

Return Value

Array of issues encountered while processing a face set with index 'setIndex'.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | 'SetIndex' is a valid face set index for the results stored in 'this'.

See Also

TessellatedShapeBuilderResult Class


GetNumberOfFaceSets Method

[image]

Revit 2024 API
TessellatedShapeBuilderResult..::..GetNumberOfFaceSets Method
TessellatedShapeBuilderResult Class See Also Send Feedback
Gets number of face sets for which 'this' result was obtained.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public int GetNumberOfFaceSets()
Visual Basic
Public Function GetNumberOfFaceSets As Integer
Visual C++
public:
int GetNumberOfFaceSets()

Return Value

The number of face sets.

See Also

TessellatedShapeBuilderResult Class


TessellatedShapeBuilderResult Properties

[image] [image]

Revit 2024 API
TessellatedShapeBuilderResult Properties
TessellatedShapeBuilderResult Class See Also Send Feedback

The TessellatedShapeBuilderResult type exposes the following members.

Properties

 | Name | Description
Public property | AreObjectsAvailable | Shows whether 'issues' still contains the original data or whether these data have already been relinquished by 'getGeometricalObjects'. The former is true, the later is false.
Public property | HasInvalidData | Whether there were any inconsistencies in the face sets, stored in the tessellated shape builder while building geometrical objects.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Outcome | What kinds of geometrical objects were built.

See Also

TessellatedShapeBuilderResult Class


HasInvalidData Property

[image]

Revit 2024 API
TessellatedShapeBuilderResult..::..HasInvalidData Property
TessellatedShapeBuilderResult Class See Also Send Feedback
Whether there were any inconsistencies in the face sets, stored in the tessellated shape builder while building geometrical objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool HasInvalidData { get; }
Visual Basic
Public ReadOnly Property HasInvalidData As Boolean
    Get
Visual C++
public:
property bool HasInvalidData {
    bool get ();
}

See Also

TessellatedShapeBuilderResult Class


IsValidObject Property

[image]

Revit 2024 API
TessellatedShapeBuilderResult..::..IsValidObject Property
TessellatedShapeBuilderResult Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

TessellatedShapeBuilderResult Class


Outcome Property

[image]

Revit 2024 API
TessellatedShapeBuilderResult..::..Outcome Property
TessellatedShapeBuilderResult Class See Also Send Feedback
What kinds of geometrical objects were built.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public TessellatedShapeBuilderOutcome Outcome { get; }
Visual Basic
Public ReadOnly Property Outcome As TessellatedShapeBuilderOutcome
    Get
Visual C++
public:
property TessellatedShapeBuilderOutcome Outcome {
    TessellatedShapeBuilderOutcome get ();
}

See Also

TessellatedShapeBuilderResult Class


TessellatedShapeBuilderTarget Enumeration

[image]

Revit 2024 API
TessellatedShapeBuilderTarget Enumeration
See Also Send Feedback
Describes what TessellatedShapeBuilder should generate, if possible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public enum TessellatedShapeBuilderTarget
Visual Basic
Public Enumeration TessellatedShapeBuilderTarget
Visual C++
public enum class TessellatedShapeBuilderTarget

Members

Member name | Description
Solid | A solid, i.e., a Geometry, where all edges are shared by two and only two faces and which divides all 3d space into bounded inner and infinite outer area(s).
AnyGeometry | A Geometry, which depending on input data can be a Solid or a 'sheet', where there is no fully enclosed volume formed by the generated faces.
Mesh | A mesh.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


TextAlignMask Enumeration

[image]

Revit 2024 API
TextAlignMask Enumeration
See Also Send Feedback
An enumerated type listing all the Text align mask.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum TextAlignMask
Visual Basic
Public Enumeration TextAlignMask
Visual C++
public enum class TextAlignMask

Members

Member name | Description
horzAlignMask | The mask of the Text object being aligned in the horizontal direction.
vertAlignMask | The mask of the Text object being aligned in the vertical direction.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


TextBaselineStyle Enumeration

[image]

Revit 2024 API
TextBaselineStyle Enumeration
See Also Send Feedback
Supported styles of text position relative to the normal baseline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016
Since: 2016

Syntax

C#
public enum TextBaselineStyle
Visual Basic
Public Enumeration TextBaselineStyle
Visual C++
public enum class TextBaselineStyle

Members

Member name | Description
Normal | Indicates a normal text with letters positioned on the baseline.
Subscript | Indicates a subsript text.
Superscript | Indicates a superscript text.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


TextElement Class

[image]

Revit 2024 API
TextElement Class
Members See Also Send Feedback
Base class representing text elements in Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class TextElement : Element
Visual Basic
Public Class TextElement _
    Inherits Element
Visual C++
public ref class TextElement : public Element

Remarks

TextElement is a base class for other annotation classes, like TextNote, which have additional, more specific functionality.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..TextElement
Autodesk.Revit.DB..::..TextNote

See Also

TextElement Members


TextElement Members

[image] [image]

Revit 2024 API
TextElement Members
TextElement Class Methods Properties See Also Send Feedback

The TextElement type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMaximumAllowedWidth()()()() | Returns the maximum width the text element can be assigned.
 | GetMaximumAllowedWidth(Document, ElementId) | Returns the maximum width the text element can be created with.
Public method | GetMinimumAllowedWidth()()()() | Returns the minimum width the text element can be assigned.
 | GetMinimumAllowedWidth(Document, ElementId) | Returns the minimum width a text element can be created with.
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BaseDirection | Direction of the base line of the text element.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Coord | Position of the text (in model coordinates.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Height | Height of the area of the text content.
Public property | HorizontalAlignment | Horizontal alignment of the text content within the text area of the element.
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTextWrappingActive | A flag identifying whether text-wrapping is currently active in this text element or not. If text wrapping is active the width of the text box remains constant and the text will wrap. The height of the text box will automatically adjust to accomodate the height of the text. If text wrapping is not active the text does not wrap and the width of the text box adjusts with the width of the longest line of text. As the text width changes, the position of the text may change depending on the HorizontalAlignment
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | KeepRotatedTextReadable | A flag to control how text behaves inside a rotated text element.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Symbol | Get the type of the TextElement object.
Public property | Text | The content of the element as a plain string stripped of all formating.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpDirection | Direction along the vertical axis of letters of the text note.
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | VerticalAlignment | Vertical alignment of the text.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Width | Width of the area of the text content.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

TextElement Class


TextElement Methods

[image] [image]

Revit 2024 API
TextElement Methods
TextElement Class See Also Send Feedback

The TextElement type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMaximumAllowedWidth()()()() | Returns the maximum width the text element can be assigned.
 | GetMaximumAllowedWidth(Document, ElementId) | Returns the maximum width the text element can be created with.
Public method | GetMinimumAllowedWidth()()()() | Returns the minimum width the text element can be assigned.
 | GetMinimumAllowedWidth(Document, ElementId) | Returns the minimum width a text element can be created with.
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TextElement Class


GetMaximumAllowedWidth Method

[image] [image]

Revit 2024 API
TextElement..::..GetMaximumAllowedWidth Method
TextElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMaximumAllowedWidth()()()() | Returns the maximum width the text element can be assigned.
 | GetMaximumAllowedWidth(Document, ElementId) | Returns the maximum width the text element can be created with.

See Also

TextElement Class
TextElement Members


GetMaximumAllowedWidth Method

[image]

Revit 2024 API
TextElement..::..GetMaximumAllowedWidth Method
TextElement Class See Also Send Feedback
Returns the maximum width the text element can be assigned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public double GetMaximumAllowedWidth()
Visual Basic
Public Function GetMaximumAllowedWidth As Double
Visual C++
public:
double GetMaximumAllowedWidth()

Return Value

The maximum allowed width in paper space [ft].

Remarks

Note that it is not necessarily a constant; it can be affected by properties of the text and its type, such as the width factor.

See Also

TextElement Class
GetMaximumAllowedWidth Overload


GetMaximumAllowedWidth Method (Document, ElementId)

[image]

Revit 2024 API
TextElement..::..GetMaximumAllowedWidth Method (Document, ElementId)
TextElement Class See Also Send Feedback
Returns the maximum width the text element can be created with.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public static double GetMaximumAllowedWidth(
    Document cdda,
    ElementId typeId
)
Visual Basic
Public Shared Function GetMaximumAllowedWidth ( _
    cdda As Document, _
    typeId As ElementId _
) As Double
Visual C++
public:
static double GetMaximumAllowedWidth(
    Document^ cdda,
    ElementId^ typeId
)

Parameters

cdda
Type: Autodesk.Revit.DB..::..Document
A document containing the new text element's type
typeId
Type: Autodesk.Revit.DB..::..ElementId
Id of the text type

Return Value

The maximum allowed width in paper space [ft].

Remarks

Note that it is not necessarily a constant; it can be affected by properties of the text type, such as the width factor.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

TextElement Class
GetMaximumAllowedWidth Overload


GetMinimumAllowedWidth Method

[image] [image]

Revit 2024 API
TextElement..::..GetMinimumAllowedWidth Method
TextElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMinimumAllowedWidth()()()() | Returns the minimum width the text element can be assigned.
 | GetMinimumAllowedWidth(Document, ElementId) | Returns the minimum width a text element can be created with.

See Also

TextElement Class
TextElement Members


GetMinimumAllowedWidth Method (Document, ElementId)

[image]

Revit 2024 API
TextElement..::..GetMinimumAllowedWidth Method (Document, ElementId)
TextElement Class Example See Also Send Feedback
Returns the minimum width a text element can be created with.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public static double GetMinimumAllowedWidth(
    Document cdda,
    ElementId typeId
)
Visual Basic
Public Shared Function GetMinimumAllowedWidth ( _
    cdda As Document, _
    typeId As ElementId _
) As Double
Visual C++
public:
static double GetMinimumAllowedWidth(
    Document^ cdda,
    ElementId^ typeId
)

Parameters

cdda
Type: Autodesk.Revit.DB..::..Document
A document containing the new text element's type
typeId
Type: Autodesk.Revit.DB..::..ElementId
Id of the text type

Return Value

The minimum allowed width in paper space [ft].

Remarks

Note that it is not necessarily a constant; it can be affected by properties of the text type, such as the width factor.

Examples

CopyC#
public TextNote AddNewTextNote(UIDocument uiDoc)
{
    Document doc = uiDoc.Document;
    XYZ textLoc = uiDoc.Selection.PickPoint("Pick a point for sample text.");
    ElementId defaultTextTypeId = doc.GetDefaultElementTypeId(ElementTypeGroup.TextNoteType);
    double noteWidth = .2;

    // make sure note width works for the text type
    double minWidth = TextNote.GetMinimumAllowedWidth(doc, defaultTextTypeId);
    double maxWidth = TextNote.GetMaximumAllowedWidth(doc, defaultTextTypeId);
    if (noteWidth < minWidth)
    {
        noteWidth = minWidth;
    }
    else if (noteWidth > maxWidth)
    {
        noteWidth = maxWidth;
    }

    TextNoteOptions opts = new TextNoteOptions(defaultTextTypeId);
    opts.HorizontalAlignment = HorizontalTextAlignment.Left;
    opts.Rotation = Math.PI / 4;

    TextNote textNote = TextNote.Create(doc, doc.ActiveView.Id, textLoc, noteWidth, "New sample text", opts);

    return textNote;
}
CopyVB.NET
Public Function AddNewTextNote(uiDoc As UIDocument) As TextNote
    Dim doc As Document = uiDoc.Document
    Dim textLoc As XYZ = uiDoc.Selection.PickPoint("Pick a point for sample text.")
    Dim defaultTextTypeId As ElementId = doc.GetDefaultElementTypeId(ElementTypeGroup.TextNoteType)
    Dim noteWidth As Double = 0.2

    ' make sure note width works for the text type
    Dim minWidth As Double = TextNote.GetMinimumAllowedWidth(doc, defaultTextTypeId)
    Dim maxWidth As Double = TextNote.GetMaximumAllowedWidth(doc, defaultTextTypeId)
    If noteWidth < minWidth Then
        noteWidth = minWidth
    ElseIf noteWidth > maxWidth Then
        noteWidth = maxWidth
    End If

    Dim opts As New TextNoteOptions(defaultTextTypeId)
    opts.HorizontalAlignment = HorizontalTextAlignment.Left
    opts.Rotation = Math.PI / 4

    Dim textNote__1 As TextNote = TextNote.Create(doc, doc.ActiveView.Id, textLoc, noteWidth, "New sample text", opts)

    Return textNote__1
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

TextElement Class
GetMinimumAllowedWidth Overload


TextElement Properties

[image] [image]

Revit 2024 API
TextElement Properties
TextElement Class See Also Send Feedback

The TextElement type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BaseDirection | Direction of the base line of the text element.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Coord | Position of the text (in model coordinates.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Height | Height of the area of the text content.
Public property | HorizontalAlignment | Horizontal alignment of the text content within the text area of the element.
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTextWrappingActive | A flag identifying whether text-wrapping is currently active in this text element or not. If text wrapping is active the width of the text box remains constant and the text will wrap. The height of the text box will automatically adjust to accomodate the height of the text. If text wrapping is not active the text does not wrap and the width of the text box adjusts with the width of the longest line of text. As the text width changes, the position of the text may change depending on the HorizontalAlignment
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | KeepRotatedTextReadable | A flag to control how text behaves inside a rotated text element.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Symbol | Get the type of the TextElement object.
Public property | Text | The content of the element as a plain string stripped of all formating.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpDirection | Direction along the vertical axis of letters of the text note.
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | VerticalAlignment | Vertical alignment of the text.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Width | Width of the area of the text content.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

TextElement Class


BaseDirection Property

[image]

Revit 2024 API
TextElement..::..BaseDirection Property
TextElement Class See Also Send Feedback
Direction of the base line of the text element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ BaseDirection { get; }
Visual Basic
Public ReadOnly Property BaseDirection As XYZ
    Get
Visual C++
public:
property XYZ^ BaseDirection {
    XYZ^ get ();
}

Remarks

Base direction is always perpendicular to Up direction. Those two vectors together define the plane of the text.

See Also

TextElement Class


Coord Property

[image]

Revit 2024 API
TextElement..::..Coord Property
TextElement Class See Also Send Feedback
Position of the text (in model coordinates.)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ Coord { get; set; }
Visual Basic
Public Property Coord As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ Coord {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

The position defines a point on the edge of the text area, not a point on the border (if a border is defined for the style.) It means that if the width of the border gets changed, the position of the text area remains unchanged.

The relation of the position point with respect to the text area depends on the text alignment as follows:

  • For Left-aligned text the point is at the Left-Top corned of the box.
  • For Center-aligned text the point is at the Middle-Top corned of the box.
  • For Right-aligned text the point is at the Right-Top corned of the box.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: A valid point must not be father then 10 miles (approx. 16 km) from the origin.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

TextElement Class


Height Property

[image]

Revit 2024 API
TextElement..::..Height Property
TextElement Class See Also Send Feedback
Height of the area of the text content.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double Height { get; }
Visual Basic
Public ReadOnly Property Height As Double
    Get
Visual C++
public:
property double Height {
    double get ();
}

Remarks

The value is in sheet units, meaning it is as when measured on a printed sheet. The measurement is of the text content only; the border around it (if specified) is excluded.

This is a read-only property, for the height of the text area is calculated depending on the text content and its wrapping.

See Also

TextElement Class


HorizontalAlignment Property

[image]

Revit 2024 API
TextElement..::..HorizontalAlignment Property
TextElement Class See Also Send Feedback
Horizontal alignment of the text content within the text area of the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public HorizontalTextAlignment HorizontalAlignment { get; set; }
Visual Basic
Public Property HorizontalAlignment As HorizontalTextAlignment
    Get
    Set
Visual C++
public:
property HorizontalTextAlignment HorizontalAlignment {
    HorizontalTextAlignment get ();
    void set (HorizontalTextAlignment value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

TextElement Class


IsTextWrappingActive Property

[image]

Revit 2024 API
TextElement..::..IsTextWrappingActive Property
TextElement Class See Also Send Feedback

A flag identifying whether text-wrapping is currently active in this text element or not.

If text wrapping is active the width of the text box remains constant and the text will wrap. The height of the text box will automatically adjust to accomodate the height of the text.

If text wrapping is not active the text does not wrap and the width of the text box adjusts with the width of the longest line of text. As the text width changes, the position of the text may change depending on the HorizontalAlignment

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool IsTextWrappingActive { get; }
Visual Basic
Public ReadOnly Property IsTextWrappingActive As Boolean
    Get
Visual C++
public:
property bool IsTextWrappingActive {
    bool get ();
}

Remarks

This is currently a read-only property and its value is set when the text element is created. If the element was created with a specified width or if an explicit width was set later, the wrapping would be automatically set as active. It means that any text line that is longer that the current width of the text-box will automatically wrapped onto the next line.

See Also

TextElement Class


KeepRotatedTextReadable Property

[image]

Revit 2024 API
TextElement..::..KeepRotatedTextReadable Property
TextElement Class See Also Send Feedback
A flag to control how text behaves inside a rotated text element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool KeepRotatedTextReadable { get; set; }
Visual Basic
Public Property KeepRotatedTextReadable As Boolean
    Get
    Set
Visual C++
public:
property bool KeepRotatedTextReadable {
    bool get ();
    void set (bool value);
}

Remarks

If the property is True then the text inside the text box gets oriented so it is readable when looking straight up at the sheet or from its right side; in other words, the text would never be upside down.

If the value is False, however, the text's orientation strictly follows the rotation of the text box, which means the text may be upside down when viewed on screen or printed on a sheet.

See Also

TextElement Class


Parameter Property

[image] [image]

Revit 2024 API
TextElement..::..Parameter Property
TextElement Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

TextElement Class
TextElement Members


Symbol Property

[image]

Revit 2024 API
TextElement..::..Symbol Property
TextElement Class See Also Send Feedback
Get the type of the TextElement object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public TextElementType Symbol { get; }
Visual Basic
Public ReadOnly Property Symbol As TextElementType
    Get
Visual C++
public:
property TextElementType^ Symbol {
    TextElementType^ get ();
}

Remarks

The user can call this property to get the related type.

See Also

TextElement Class


Text Property

[image]

Revit 2024 API
TextElement..::..Text Property
TextElement Class See Also Send Feedback
The content of the element as a plain string stripped of all formating.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Remarks

If a new text content is set, all previous formating that might have been set on parts of the original text will be lost. After setting the new text, only the formating parameters of the associated text type will be applied.

The value of this property can also be accessed via the TEXT_TEXT Built-In parameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

TextElement Class


UpDirection Property

[image]

Revit 2024 API
TextElement..::..UpDirection Property
TextElement Class See Also Send Feedback
Direction along the vertical axis of letters of the text note.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ UpDirection { get; }
Visual Basic
Public ReadOnly Property UpDirection As XYZ
    Get
Visual C++
public:
property XYZ^ UpDirection {
    XYZ^ get ();
}

Remarks

This vector points up from the base of the letters and is always perpendicular to the base direction. Those two vectors together define the plane of the text.

See Also

TextElement Class


VerticalAlignment Property

[image]

Revit 2024 API
TextElement..::..VerticalAlignment Property
TextElement Class See Also Send Feedback
Vertical alignment of the text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public VerticalTextAlignment VerticalAlignment { get; set; }
Visual Basic
Public Property VerticalAlignment As VerticalTextAlignment
    Get
    Set
Visual C++
public:
property VerticalTextAlignment VerticalAlignment {
    VerticalTextAlignment get ();
    void set (VerticalTextAlignment value);
}

Remarks

The vertical alignment determines the way text is positioned as the text height changes.
  • For Top-aligned text the top of the text will remain in place.
  • For Middle-aligned text the horizontal center line of the text will remain in place.
  • For Bottom-aligned text the bottom of the text will remain in place.
Changing this property will not affect the position of the text element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

TextElement Class


TextElementBackground Enumeration

[image]

Revit 2024 API
TextElementBackground Enumeration
See Also Send Feedback
An enumerated type listing all the background mode for the built-in parameter TEXT_BACKGROUND.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum TextElementBackground
Visual Basic
Public Enumeration TextElementBackground
Visual C++
public enum class TextElementBackground

Members

Member name | Description
TBGR_OPAQUE | The TextElement object is opaque.
TBGR_TRANSPARENT | The TextElement object is transparent.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


TextElementType Class

[image]

Revit 2024 API
TextElementType Class
Members See Also Send Feedback
An object that represents a text style.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class TextElementType : LineAndTextAttrSymbol
Visual Basic
Public Class TextElementType _
    Inherits LineAndTextAttrSymbol
Visual C++
public ref class TextElementType : public LineAndTextAttrSymbol

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..LineAndTextAttrSymbol
Autodesk.Revit.DB..::..TextElementType
Autodesk.Revit.DB..::..TextNoteType

See Also

TextElementType Members


TextElementType Members

[image] [image]

Revit 2024 API
TextElementType Members
TextElementType Class Methods Properties See Also Send Feedback

The TextElementType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

TextElementType Class


TextElementType Methods

[image] [image]

Revit 2024 API
TextElementType Methods
TextElementType Class See Also Send Feedback

The TextElementType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TextElementType Class


TextElementType Properties

[image] [image]

Revit 2024 API
TextElementType Properties
TextElementType Class See Also Send Feedback

The TextElementType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

TextElementType Class


TextListStyle Enumeration

[image]

Revit 2024 API
TextListStyle Enumeration
See Also Send Feedback
Supported styles of text list paragraphs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016
Since: 2016

Syntax

C#
public enum TextListStyle
Visual Basic
Public Enumeration TextListStyle
Visual C++
public enum class TextListStyle

Members

Member name | Description
None | Indicates that the paragraph is not a list.
Bullet | Indicates a list that uses standard bullets.
NumberArabic | Indicates a list that uses arabic numbers.
LetterLowercase | Indicates a list that uses lowercase letters.
LetterUppercase | Indicates a list that uses uppercase letters.
NumberRomanLowercase | Indicates a list that uses lowercase Roman numbers.
NumberRomanUppercase | Indicates a list that uses uppercase Roman numbers.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


TextNode Class

[image]

Revit 2024 API
TextNode Class
Members See Also Send Feedback
This class represents a text annotation object in a model-exporting process.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public class TextNode : RenderNode
Visual Basic
Public Class TextNode _
    Inherits RenderNode
Visual C++
public ref class TextNode : public RenderNode

Remarks

See also: [!:Autodesk::Revit::DB::IModelExportContext::OnText].

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..RenderNode
Autodesk.Revit.DB..::..TextNode

See Also

TextNode Members


TextNode Members

[image] [image]

Revit 2024 API
TextNode Members
TextNode Class Methods Properties See Also Send Feedback

The TextNode type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RenderNode.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetFormattedText | Returns an FormattedText object that contains text and associated formatting of this TextNode.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BaseDirection | Direction of the base line of the text object in model space.
Public property | Color | The color of the text.
Public property | FontHeight | Height [ft] of the text font, in model space.
Public property | FontName | The name of the text font.
Public property | Height | Height [ft] of the area of the text content in model space.
Public property | HorizontalAlignment | Indicates default horizontal alignment of the text.
Public property | IsBold | Indicates whether the default formatting is set to bold text.
Public property | IsItalic | Indicates whether the default formatting is set to italic text.
Public property | IsKeptReadable | Indicates text behavior inside a rotated text object.
Public property | IsTransparent | Indicates whether the text background is transparent or opaque.
Public property | IsUnderlined | Indicates whether the default formatting is set to underlined text.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode.)
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode.)
Public property | Position | Position of the text in model coordinates.
Public property | TabSize | The size [ft] of the interval between tab stops, in model space.
Public property | Text | The content of the text annotation as a plain string stripped of all formatting.
Public property | UpDirection | Direction along the vertical axis of letters of the text object in model space.
Public property | VerticalAlignment | Indicates default vertical alignment of the text.
Public property | Width | Width [ft] of the area of the text content in model space.
Public property | WidthScale | Scale applied to the width of the text.

See Also

TextNode Class


TextNode Methods

[image] [image]

Revit 2024 API
TextNode Methods
TextNode Class See Also Send Feedback

The TextNode type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RenderNode.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetFormattedText | Returns an FormattedText object that contains text and associated formatting of this TextNode.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TextNode Class


GetFormattedText Method

[image]

Revit 2024 API
TextNode..::..GetFormattedText Method
TextNode Class See Also Send Feedback
Returns an FormattedText object that contains text and associated formatting of this TextNode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public FormattedText GetFormattedText()
Visual Basic
Public Function GetFormattedText As FormattedText
Visual C++
public:
FormattedText^ GetFormattedText()

Return Value

The object that contains the text and associated formatting of of the text in this text note.

See Also

TextNode Class


TextNode Properties

[image] [image]

Revit 2024 API
TextNode Properties
TextNode Class See Also Send Feedback

The TextNode type exposes the following members.

Properties

 | Name | Description
Public property | BaseDirection | Direction of the base line of the text object in model space.
Public property | Color | The color of the text.
Public property | FontHeight | Height [ft] of the text font, in model space.
Public property | FontName | The name of the text font.
Public property | Height | Height [ft] of the area of the text content in model space.
Public property | HorizontalAlignment | Indicates default horizontal alignment of the text.
Public property | IsBold | Indicates whether the default formatting is set to bold text.
Public property | IsItalic | Indicates whether the default formatting is set to italic text.
Public property | IsKeptReadable | Indicates text behavior inside a rotated text object.
Public property | IsTransparent | Indicates whether the text background is transparent or opaque.
Public property | IsUnderlined | Indicates whether the default formatting is set to underlined text.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode.)
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode.)
Public property | Position | Position of the text in model coordinates.
Public property | TabSize | The size [ft] of the interval between tab stops, in model space.
Public property | Text | The content of the text annotation as a plain string stripped of all formatting.
Public property | UpDirection | Direction along the vertical axis of letters of the text object in model space.
Public property | VerticalAlignment | Indicates default vertical alignment of the text.
Public property | Width | Width [ft] of the area of the text content in model space.
Public property | WidthScale | Scale applied to the width of the text.

See Also

TextNode Class


FontHeight Property

[image]

Revit 2024 API
TextNode..::..FontHeight Property
TextNode Class See Also Send Feedback
Height [ft] of the text font, in model space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public double FontHeight { get; }
Visual Basic
Public ReadOnly Property FontHeight As Double
    Get
Visual C++
public:
property double FontHeight {
    double get ();
}

Remarks

This is the height of the 'M' glyph in the text font.

See Also

TextNode Class


FontName Property

[image]

Revit 2024 API
TextNode..::..FontName Property
TextNode Class See Also Send Feedback
The name of the text font.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public string FontName { get; }
Visual Basic
Public ReadOnly Property FontName As String
    Get
Visual C++
public:
property String^ FontName {
    String^ get ();
}

See Also

TextNode Class


Height Property

[image]

Revit 2024 API
TextNode..::..Height Property
TextNode Class See Also Send Feedback
Height [ft] of the area of the text content in model space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public double Height { get; }
Visual Basic
Public ReadOnly Property Height As Double
    Get
Visual C++
public:
property double Height {
    double get ();
}

See Also

TextNode Class


HorizontalAlignment Property

[image]

Revit 2024 API
TextNode..::..HorizontalAlignment Property
TextNode Class See Also Send Feedback
Indicates default horizontal alignment of the text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public HorizontalTextAlignment HorizontalAlignment { get; }
Visual Basic
Public ReadOnly Property HorizontalAlignment As HorizontalTextAlignment
    Get
Visual C++
public:
property HorizontalTextAlignment HorizontalAlignment {
    HorizontalTextAlignment get ();
}

See Also

TextNode Class


IsBold Property

[image]

Revit 2024 API
TextNode..::..IsBold Property
TextNode Class See Also Send Feedback
Indicates whether the default formatting is set to bold text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool IsBold { get; }
Visual Basic
Public ReadOnly Property IsBold As Boolean
    Get
Visual C++
public:
property bool IsBold {
    bool get ();
}

See Also

TextNode Class


IsItalic Property

[image]

Revit 2024 API
TextNode..::..IsItalic Property
TextNode Class See Also Send Feedback
Indicates whether the default formatting is set to italic text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool IsItalic { get; }
Visual Basic
Public ReadOnly Property IsItalic As Boolean
    Get
Visual C++
public:
property bool IsItalic {
    bool get ();
}

See Also

TextNode Class


IsKeptReadable Property

[image]

Revit 2024 API
TextNode..::..IsKeptReadable Property
TextNode Class See Also Send Feedback
Indicates text behavior inside a rotated text object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool IsKeptReadable { get; }
Visual Basic
Public ReadOnly Property IsKeptReadable As Boolean
    Get
Visual C++
public:
property bool IsKeptReadable {
    bool get ();
}

Remarks

If the property is True then the text inside the text box gets oriented so it is readable when looking straight up at the sheet or from its right side; in other words, the text would never be upside down.

If the value is False, however, the text's orientation strictly follows the rotation of the text box, which means the text may be upside down when viewed on screen or printed on a sheet.

See Also

TextNode Class


IsTransparent Property

[image]

Revit 2024 API
TextNode..::..IsTransparent Property
TextNode Class See Also Send Feedback
Indicates whether the text background is transparent or opaque.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool IsTransparent { get; }
Visual Basic
Public ReadOnly Property IsTransparent As Boolean
    Get
Visual C++
public:
property bool IsTransparent {
    bool get ();
}

See Also

TextNode Class


IsUnderlined Property

[image]

Revit 2024 API
TextNode..::..IsUnderlined Property
TextNode Class See Also Send Feedback
Indicates whether the default formatting is set to underlined text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool IsUnderlined { get; }
Visual Basic
Public ReadOnly Property IsUnderlined As Boolean
    Get
Visual C++
public:
property bool IsUnderlined {
    bool get ();
}

See Also

TextNode Class


Position Property

[image]

Revit 2024 API
TextNode..::..Position Property
TextNode Class See Also Send Feedback
Position of the text in model coordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public XYZ Position { get; }
Visual Basic
Public ReadOnly Property Position As XYZ
    Get
Visual C++
public:
property XYZ^ Position {
    XYZ^ get ();
}

Remarks

The relation of the position point with respect to the text area depends on the text alignment.

For example:

  • For Left-Top-aligned text the point is at the Left-Top corner of the box.
  • For Center-Bottom aligned text the point is at the Center-Bottom corner of the box.

See Also

TextNode Class


Text Property

[image]

Revit 2024 API
TextNode..::..Text Property
TextNode Class See Also Send Feedback
The content of the text annotation as a plain string stripped of all formatting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public string Text { get; }
Visual Basic
Public ReadOnly Property Text As String
    Get
Visual C++
public:
property String^ Text {
    String^ get ();
}

Remarks

The text may contain new-lines if there are any in the text annotation.

See Also

TextNode Class


VerticalAlignment Property

[image]

Revit 2024 API
TextNode..::..VerticalAlignment Property
TextNode Class See Also Send Feedback
Indicates default vertical alignment of the text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public VerticalTextAlignment VerticalAlignment { get; }
Visual Basic
Public ReadOnly Property VerticalAlignment As VerticalTextAlignment
    Get
Visual C++
public:
property VerticalTextAlignment VerticalAlignment {
    VerticalTextAlignment get ();
}

See Also

TextNode Class


Width Property

[image]

Revit 2024 API
TextNode..::..Width Property
TextNode Class See Also Send Feedback
Width [ft] of the area of the text content in model space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public double Width { get; }
Visual Basic
Public ReadOnly Property Width As Double
    Get
Visual C++
public:
property double Width {
    double get ();
}

Remarks

Specifies the actual width of the text, that is essentially the width of the longest line, including any spaces. The value represents the width after the width scale has been applied.

See Also

TextNode Class


TextNote Methods

[image] [image]

Revit 2024 API
TextNote Methods
TextNote Class See Also Send Feedback

The TextNote type exposes the following members.

Methods

 | Name | Description
Public method | AddLeader | Adds a leader to the text note.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create(Document, ElementId, XYZ, String, ElementId) | Creates a new unwrapped TextNote element with the given properties.
 | Create(Document, ElementId, XYZ, String, TextNoteOptions) | Creates a new unwrapped text note element with the given properties.
 | Create(Document, ElementId, XYZ, Double, String, ElementId) | Creates a new line-wrapping text note element of the given width and properties.
 | Create(Document, ElementId, XYZ, Double, String, TextNoteOptions) | Creates a new line-wrapping text note element of the given width and properties.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetFormattedText | Returns an object that contains text and associated formatting of this note.
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLeaders | Returns a collection of leaders currently attached to the text note.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMaximumAllowedWidth()()()() | Returns the maximum width the text element can be assigned. (Inherited from TextElement.)
Public method | GetMinimumAllowedWidth()()()() | Returns the minimum width the text element can be assigned. (Inherited from TextElement.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | RemoveLeaders | Removes all leaders currently attached to the text note.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetFormattedText | Sets the text and associated formatting of the text of in this text note with a given FormattedText object.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TextNote Class


AddLeader Method

[image]

Revit 2024 API
TextNote..::..AddLeader Method
TextNote Class See Also Send Feedback
Adds a leader to the text note.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Leader AddLeader(
    TextNoteLeaderTypes leaderType
)
Visual Basic
Public Function AddLeader ( _
    leaderType As TextNoteLeaderTypes _
) As Leader
Visual C++
public:
Leader^ AddLeader(
    TextNoteLeaderTypes leaderType
)

Parameters

leaderType
Type: Autodesk.Revit.DB..::..TextNoteLeaderTypes
Type of the leader being added.

Return Value

The newly added leader.

Remarks

If the geometric type of the new leader (line vs arc.) differs from the type of existing leaders, then the type of the existing leaders will be changed to match the type of the newly created leader.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

TextNote Class


Create Method

[image] [image]

Revit 2024 API
TextNote..::..Create Method
TextNote Class See Also Send Feedback

Overload List

Name | Description
Create(Document, ElementId, XYZ, String, ElementId) | Creates a new unwrapped TextNote element with the given properties.
Create(Document, ElementId, XYZ, String, TextNoteOptions) | Creates a new unwrapped text note element with the given properties.
Create(Document, ElementId, XYZ, Double, String, ElementId) | Creates a new line-wrapping text note element of the given width and properties.
Create(Document, ElementId, XYZ, Double, String, TextNoteOptions) | Creates a new line-wrapping text note element of the given width and properties.

See Also

TextNote Class
TextNote Members


Create Method (Document, ElementId, XYZ, String, ElementId)

[image]

Revit 2024 API
TextNote..::..Create Method (Document, ElementId, XYZ, String, ElementId)
TextNote Class See Also Send Feedback
Creates a new unwrapped TextNote element with the given properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public static TextNote Create(
    Document document,
    ElementId viewId,
    XYZ position,
    string text,
    ElementId typeId
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    viewId As ElementId, _
    position As XYZ, _
    text As String, _
    typeId As ElementId _
) As TextNote
Visual C++
public:
static TextNote^ Create(
    Document^ document,
    ElementId^ viewId,
    XYZ^ position,
    String^ text,
    ElementId^ typeId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
A valid Revit document that is currently modifiable (i.e. with an open transaction).
viewId
Type: Autodesk.Revit.DB..::..ElementId
Id of the graphic view in which the note is to be created.
position
Type: Autodesk.Revit.DB..::..XYZ
A model position of the new note.

For a left-aligned text (default), the origin is set at the top-left corner of the note's bounding box.

text
Type: System..::..String
Text to populate the text note with.
typeId
Type: Autodesk.Revit.DB..::..ElementId
Id of the text type to use for the new text note.

Return Value

The newly created text note.

Remarks

The new TextNote will consist of a single line of text unless there are carriage return ('\r') or vertical tab ('\v') characters in the given string. Once the text note is created its width gets adjusted to fit the longest (or the single one) line of text.

As a view-specific element the TextNote will be visible only in the specified view.

The new TextNote will be created using the given text type, which defines the style. The currently default style can be obtained from the Document.GetDefaultElementTypeId method.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The document is a family that cannot contain text notes. -or- The viewId does not represent a valid graphic view element in the given document. -or- The typeId does not represent a valid text type in the given document. -or- A valid point must not be father then 10 miles (approx. 16 km) from the origin.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

TextNote Class
Create Overload


Create Method (Document, ElementId, XYZ, String, TextNoteOptions)

[image]

Revit 2024 API
TextNote..::..Create Method (Document, ElementId, XYZ, String, TextNoteOptions)
TextNote Class See Also Send Feedback
Creates a new unwrapped text note element with the given properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public static TextNote Create(
    Document document,
    ElementId viewId,
    XYZ position,
    string text,
    TextNoteOptions options
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    viewId As ElementId, _
    position As XYZ, _
    text As String, _
    options As TextNoteOptions _
) As TextNote
Visual C++
public:
static TextNote^ Create(
    Document^ document,
    ElementId^ viewId,
    XYZ^ position,
    String^ text,
    TextNoteOptions^ options
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
A valid Revit document that is currently modifiable (i.e. with an open transaction).
viewId
Type: Autodesk.Revit.DB..::..ElementId
Id of the graphic view in which the note is to be created.
position
Type: Autodesk.Revit.DB..::..XYZ
A model position of the new note.

Note that the position's relation to the text's bounding box depends on the requested text alignment (set via the Options argument). It will be the box' top-left corner for a left-aligned text, the top-right corner for a right-aligned text, and middle-top point if the text is to be centered.

text
Type: System..::..String
Text to populate the text note with.
options
Type: Autodesk.Revit.DB..::..TextNoteOptions
Options to control behavior and appearance of the text note.

Return Value

The newly created text note.

Remarks

The new text note will consist of a single line of text unless there are line-break characters (CR) in the given string. Once the text note is created its width gets adjusted to fit the longest (or the single one) line of text.

As a view-specific element the text note will be visible only in the specified view.

The new text note will be created using the given text type, which defines the style. The currently default style can be obtained from the Document.GetDefaultElementTypeId method.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The document is a family that cannot contain text notes. -or- The viewId does not represent a valid graphic view element in the given document. -or- The options structure does not contain a valid text type to use for a new text note in the given document. -or- A valid point must not be father then 10 miles (approx. 16 km) from the origin.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

TextNote Class
Create Overload


Create Method (Document, ElementId, XYZ, Double, String, ElementId)

[image]

Revit 2024 API
TextNote..::..Create Method (Document, ElementId, XYZ, Double, String, ElementId)
TextNote Class See Also Send Feedback
Creates a new line-wrapping text note element of the given width and properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public static TextNote Create(
    Document document,
    ElementId viewId,
    XYZ position,
    double width,
    string text,
    ElementId typeId
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    viewId As ElementId, _
    position As XYZ, _
    width As Double, _
    text As String, _
    typeId As ElementId _
) As TextNote
Visual C++
public:
static TextNote^ Create(
    Document^ document,
    ElementId^ viewId,
    XYZ^ position,
    double width,
    String^ text,
    ElementId^ typeId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
A valid Revit document that is currently modifiable (i.e. with an open transaction).
viewId
Type: Autodesk.Revit.DB..::..ElementId
Id of the graphic view in which the note is to be created.
position
Type: Autodesk.Revit.DB..::..XYZ
A model position of the new note.

For a left-aligned text (default), the origin is set at the top-left corner of the note's bounding box.

width
Type: System..::..Double
Width [ft] of the text in paper space (i.e. as it is measured when printed.) If a line of text is longer than the specified Width, the text will be automatically wrapped. If a a zero Width is supplied then this method will create an unwrapped text note element.
text
Type: System..::..String
Text to populate the text note with.
typeId
Type: Autodesk.Revit.DB..::..ElementId
Id of the text type to use for the new text note. The text type allows its font name parameter to be set to a font unavailable on the current system. However, any text note created with or set to this font type will be displayed in a default substituted font (e.g. Arial) and the UI will show a blank value in the text type font name parameter. Once the document is opened on a system which has the font set on the text type, the text note will display with that font and the UI will show that font in the text type font name parameter.

Return Value

The newly created text note.

Remarks

As a view-specific element the text note will be visible only in the specified view.

The new text note will be created using the given text type, which defines the style. The currently default style can be obtained from the Document.GetDefaultElementTypeId method.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The document is a family that cannot contain text notes. -or- The viewId does not represent a valid graphic view element in the given document. -or- The typeId does not represent a valid text type in the given document. -or- A valid point must not be father then 10 miles (approx. 16 km) from the origin. -or- The given width is not valid. A valid value must be within the range returned by the static methods GetMinimumAllowedWidth and GetMaximumAllowedWidth.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

TextNote Class
Create Overload


GetFormattedText Method

[image]

Revit 2024 API
TextNote..::..GetFormattedText Method
TextNote Class Example See Also Send Feedback
Returns an object that contains text and associated formatting of this note.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public FormattedText GetFormattedText()
Visual Basic
Public Function GetFormattedText As FormattedText
Visual C++
public:
FormattedText^ GetFormattedText()

Return Value

The object that contains the text and associated formatting of of the text in this text note.

Remarks

The returned object is not attached to the text note and modifying it will not modify the contents of the text note. After changes are made to the FormattedText, use SetFormattedText(FormattedText) apply those changes to the TextNote.

Examples

CopyC#
#region Autodesk.Revit.DB.FormattedText.SetListType(Autodesk.Revit.DB.TextRange, Autodesk.Revit.DB.ListType)
#region Autodesk.Revit.DB.FormattedText.AsTextRange()
public void AppendText(TextNote textNote)
{
    FormattedText formatText = textNote.GetFormattedText();

    TextRange range = formatText.AsTextRange();

    range.Start = range.End - 1;
    // set Length to 0 to insert
    range.Length = 0;
    string someNewText = "\rThis is a new paragraph\vThis is a new line without a paragraph break\r";
    formatText.SetPlainText(range, someNewText);

    // get range for entire text
    range = formatText.AsTextRange();
    range.Start = range.End - 1;
    range.Length = 0;
    string someListText = "\rBulleted List item 1\rItem 2\vSecond line for Item 2\rThird bullet point";
    formatText.SetPlainText(range, someListText);
    range.Start++;
    range.Length = someListText.Length;
    formatText.SetListType(range, ListType.Bullet);

    if (formatText.GetAllCapsStatus(range) != FormatStatus.None)
    {
        formatText.SetAllCapsStatus(range, false);
    }

    textNote.SetFormattedText(formatText);
}
#endregion
#endregion
CopyVB.NET
#Region "Autodesk.Revit.DB.FormattedText.SetListType(Autodesk.Revit.DB.TextRange, Autodesk.Revit.DB.ListType)"
#Region "Autodesk.Revit.DB.FormattedText.AsTextRange()"
        Public Sub AppendText(textNote As TextNote)
            Dim formatText As FormattedText = textNote.GetFormattedText()

            Dim range As TextRange = formatText.AsTextRange()

            range.Start = range.[End] - 1
            ' set Length to 0 to insert
            range.Length = 0
            Dim someNewText As String = vbCr & "This is a new paragraph" & vbVerticalTab & "This is a new line without a paragraph break" & vbCr
            formatText.SetPlainText(range, someNewText)

            ' get range for entire text
            range = formatText.AsTextRange()
            range.Start = range.[End] - 1
            range.Length = 0
            Dim someListText As String = vbCr & "Bulleted List item 1" & vbCr & "Item 2" & vbVerticalTab & "Second line for Item 2" & vbCr & "Third bullet point"
            formatText.SetPlainText(range, someListText)
            range.Start += 1
            range.Length = someListText.Length
            formatText.SetListType(range, ListType.Bullet)

            If formatText.GetAllCapsStatus(range) <> FormatStatus.None Then
                formatText.SetAllCapsStatus(range, False)
            End If

            textNote.SetFormattedText(formatText)
        End Sub
#End Region
#End Region

See Also

TextNote Class


GetLeaders Method

[image]

Revit 2024 API
TextNote..::..GetLeaders Method
TextNote Class See Also Send Feedback
Returns a collection of leaders currently attached to the text note.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public IList<Leader> GetLeaders()
Visual Basic
Public Function GetLeaders As IList(Of Leader)
Visual C++
public:
IList<Leader^>^ GetLeaders()

Remarks

This method supersedes an older Leaders property which has been deprecated.

See Also

TextNote Class


RemoveLeaders Method

[image]

Revit 2024 API
TextNote..::..RemoveLeaders Method
TextNote Class See Also Send Feedback
Removes all leaders currently attached to the text note.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void RemoveLeaders()
Visual Basic
Public Sub RemoveLeaders
Visual C++
public:
void RemoveLeaders()

See Also

TextNote Class


SetFormattedText Method

[image]

Revit 2024 API
TextNote..::..SetFormattedText Method
TextNote Class Example See Also Send Feedback
Sets the text and associated formatting of the text of in this text note with a given FormattedText object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public void SetFormattedText(
    FormattedText formattedText
)
Visual Basic
Public Sub SetFormattedText ( _
    formattedText As FormattedText _
)
Visual C++
public:
void SetFormattedText(
    FormattedText^ formattedText
)

Parameters

formattedText
Type: Autodesk.Revit.DB..::..FormattedText
The FormattedText object containing the text and associated formatting of the text.

Examples

CopyC#
#region Autodesk.Revit.DB.FormattedText
public void FormatText(TextNote textNote)
{
    // TextNote created with "New sample text"
    FormattedText formatText = textNote.GetFormattedText();

    // italicize "New"
    TextRange range = new TextRange(0, 3);
    formatText.SetItalicStatus(range, true);

    // make "sample" bold
    range = formatText.Find("sample", 0, false, true);
    if (range.Length > 0)
        formatText.SetBoldStatus(range, true);

    // make "text" underlined
    range = formatText.Find("text", 0, false, true);
    if (range.Length > 0)
        formatText.SetUnderlineStatus(range, true);

    // make all text uppercase
    formatText.SetAllCapsStatus(true);

    textNote.SetFormattedText(formatText);
}
#endregion
CopyVB.NET
#Region "Autodesk.Revit.DB.FormattedText"
        Public Sub FormatText(textNote As TextNote)
            ' TextNote created with "New sample text"
            Dim formatText__1 As FormattedText = textNote.GetFormattedText()

            ' italicize "New"
            Dim range As New TextRange(0, 3)
            formatText__1.SetItalicStatus(range, True)

            ' make "sample" bold
            range = formatText__1.Find("sample", 0, False, True)
            If range.Length > 0 Then
                formatText__1.SetBoldStatus(range, True)
            End If

            ' make "text" underlined
            range = formatText__1.Find("text", 0, False, True)
            If range.Length > 0 Then
                formatText__1.SetUnderlineStatus(range, True)
            End If

            ' make all text uppercase
            formatText__1.SetAllCapsStatus(True)

            textNote.SetFormattedText(formatText__1)
        End Sub
#End Region

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

TextNote Class


TextNote Properties

[image] [image]

Revit 2024 API
TextNote Properties
TextNote Class See Also Send Feedback

The TextNote type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BaseDirection | Direction of the base line of the text element. (Inherited from TextElement.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Coord | Position of the text (in model coordinates.) (Inherited from TextElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Height | Height of the area of the text content. (Inherited from TextElement.)
Public property | HorizontalAlignment | Horizontal alignment of the text content within the text area of the element. (Inherited from TextElement.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTextWrappingActive | A flag identifying whether text-wrapping is currently active in this text element or not. If text wrapping is active the width of the text box remains constant and the text will wrap. The height of the text box will automatically adjust to accomodate the height of the text. If text wrapping is not active the text does not wrap and the width of the text box adjusts with the width of the longest line of text. As the text width changes, the position of the text may change depending on the HorizontalAlignment (Inherited from TextElement.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | KeepRotatedTextReadable | A flag to control how text behaves inside a rotated text element. (Inherited from TextElement.)
Public property | LeaderCount | Number of leader objects currently attached to the text note.
Public property | LeaderLeftAttachment | Attachment position of leaders on the left side of the text note.
Public property | LeaderRightAttachment | Attachment position of leaders on the right side of the text note.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Symbol | Get the type of the TextElement object. (Inherited from TextElement.)
Public property | Text | The content of the element as a plain string stripped of all formating. (Inherited from TextElement.)
Public property | TextNoteType | Access the type of the TextNote object.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpDirection | Direction along the vertical axis of letters of the text note. (Inherited from TextElement.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | VerticalAlignment | Vertical alignment of the text. (Inherited from TextElement.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Width | Width of the area of the text content. (Inherited from TextElement.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

TextNote Class


LeaderCount Property

[image]

Revit 2024 API
TextNote..::..LeaderCount Property
TextNote Class See Also Send Feedback
Number of leader objects currently attached to the text note.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public int LeaderCount { get; }
Visual Basic
Public ReadOnly Property LeaderCount As Integer
    Get
Visual C++
public:
property int LeaderCount {
    int get ();
}

See Also

TextNote Class


LeaderLeftAttachment Property

[image]

Revit 2024 API
TextNote..::..LeaderLeftAttachment Property
TextNote Class See Also Send Feedback
Attachment position of leaders on the left side of the text note.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public LeaderAtachement LeaderLeftAttachment { get; set; }
Visual Basic
Public Property LeaderLeftAttachment As LeaderAtachement
    Get
    Set
Visual C++
public:
property LeaderAtachement LeaderLeftAttachment {
    LeaderAtachement get ();
    void set (LeaderAtachement value);
}

Remarks

The property controls the vertical position of leaders attached to the left side of the note.

Change of the value will affect all leaders currently attached to the left side.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

TextNote Class


LeaderRightAttachment Property

[image]

Revit 2024 API
TextNote..::..LeaderRightAttachment Property
TextNote Class See Also Send Feedback
Attachment position of leaders on the right side of the text note.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public LeaderAtachement LeaderRightAttachment { get; set; }
Visual Basic
Public Property LeaderRightAttachment As LeaderAtachement
    Get
    Set
Visual C++
public:
property LeaderAtachement LeaderRightAttachment {
    LeaderAtachement get ();
    void set (LeaderAtachement value);
}

Remarks

The property controls the vertical position of leaders attached to the right side of the note.

Change of the value will affect all leaders currently attached to the right side.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

TextNote Class


TextNoteLeaderStyles Enumeration

[image]

Revit 2024 API
TextNoteLeaderStyles Enumeration
See Also Send Feedback
An enumerated type listing all the Leader styles.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum TextNoteLeaderStyles
Visual Basic
Public Enumeration TextNoteLeaderStyles
Visual C++
public enum class TextNoteLeaderStyles

Members

Member name | Description
LCS_NONE | No leader.
LCS_ONE_SEG_LINE | The leader only includes one line segment.
LCS_ONE_SEG_ARC | The leader is an arc.
LCS_TWO_SEG_LINE | The leader include two line segments.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


TextNoteLeaderTypes Enumeration

[image]

Revit 2024 API
TextNoteLeaderTypes Enumeration
See Also Send Feedback
Types of text-note leaders

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum TextNoteLeaderTypes
Visual Basic
Public Enumeration TextNoteLeaderTypes
Visual C++
public enum class TextNoteLeaderTypes

Members

Member name | Description
TNLT_STRAIGHT_L | A line leader attached from the left side of a text element
TNLT_STRAIGHT_R | A line leader attached from the right side of a text element
TNLT_ARC_L | An arc leader attached from the left side of a text element
TNLT_ARC_R | An arc leader attached from the right side of a text element

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


TextNoteOptions Class

[image]

Revit 2024 API
TextNoteOptions Class
Members Example See Also Send Feedback
Options to use when creating a new text note element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public class TextNoteOptions : IDisposable
Visual Basic
Public Class TextNoteOptions _
    Implements IDisposable
Visual C++
public ref class TextNoteOptions : IDisposable

Remarks

Use an instance of this class as an argument in the TextNote.Create methods.

Examples

CopyC#
#region Autodesk.Revit.DB.TextNote.Create(Autodesk.Revit.DB.Document, Autodesk.Revit.DB.ElementId, Autodesk.Revit.DB.XYZ, double, System.String, Autodesk.Revit.DB.TextNoteOptions)
#region Autodesk.Revit.DB.TextElement.GetMinimumAllowedWidth(Autodesk.Revit.DB.Document, Autodesk.Revit.DB.ElementId)
public TextNote AddNewTextNote(UIDocument uiDoc)
{
    Document doc = uiDoc.Document;
    XYZ textLoc = uiDoc.Selection.PickPoint("Pick a point for sample text.");
    ElementId defaultTextTypeId = doc.GetDefaultElementTypeId(ElementTypeGroup.TextNoteType);
    double noteWidth = .2;

    // make sure note width works for the text type
    double minWidth = TextNote.GetMinimumAllowedWidth(doc, defaultTextTypeId);
    double maxWidth = TextNote.GetMaximumAllowedWidth(doc, defaultTextTypeId);
    if (noteWidth < minWidth)
    {
        noteWidth = minWidth;
    }
    else if (noteWidth > maxWidth)
    {
        noteWidth = maxWidth;
    }

    TextNoteOptions opts = new TextNoteOptions(defaultTextTypeId);
    opts.HorizontalAlignment = HorizontalTextAlignment.Left;
    opts.Rotation = Math.PI / 4;

    TextNote textNote = TextNote.Create(doc, doc.ActiveView.Id, textLoc, noteWidth, "New sample text", opts);

    return textNote;
}
#endregion
#endregion
CopyVB.NET
#Region "Autodesk.Revit.DB.TextNote.Create(Autodesk.Revit.DB.Document, Autodesk.Revit.DB.ElementId, Autodesk.Revit.DB.XYZ, double, System.String, Autodesk.Revit.DB.TextNoteOptions)"
#Region "Autodesk.Revit.DB.TextElement.GetMinimumAllowedWidth(Autodesk.Revit.DB.Document, Autodesk.Revit.DB.ElementId)"
        Public Function AddNewTextNote(uiDoc As UIDocument) As TextNote
            Dim doc As Document = uiDoc.Document
            Dim textLoc As XYZ = uiDoc.Selection.PickPoint("Pick a point for sample text.")
            Dim defaultTextTypeId As ElementId = doc.GetDefaultElementTypeId(ElementTypeGroup.TextNoteType)
            Dim noteWidth As Double = 0.2

            ' make sure note width works for the text type
            Dim minWidth As Double = TextNote.GetMinimumAllowedWidth(doc, defaultTextTypeId)
            Dim maxWidth As Double = TextNote.GetMaximumAllowedWidth(doc, defaultTextTypeId)
            If noteWidth < minWidth Then
                noteWidth = minWidth
            ElseIf noteWidth > maxWidth Then
                noteWidth = maxWidth
            End If

            Dim opts As New TextNoteOptions(defaultTextTypeId)
            opts.HorizontalAlignment = HorizontalTextAlignment.Left
            opts.Rotation = Math.PI / 4

            Dim textNote__1 As TextNote = TextNote.Create(doc, doc.ActiveView.Id, textLoc, noteWidth, "New sample text", opts)

            Return textNote__1
        End Function
#End Region
#End Region

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..TextNoteOptions

See Also

TextNoteOptions Members


TextNoteOptions Constructor

[image] [image]

Revit 2024 API
TextNoteOptions Constructor
TextNoteOptions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TextNoteOptions()()()() | Default constructor; populates the options with their respective default values.
Public method | TextNoteOptions(ElementId) | Constructs text options to create text of the given type.

See Also

TextNoteOptions Class
TextNoteOptions Members


TextNoteOptions Constructor

[image]

Revit 2024 API
TextNoteOptions Constructor
TextNoteOptions Class See Also Send Feedback
Default constructor; populates the options with their respective default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public TextNoteOptions()
Visual Basic
Public Sub New
Visual C++
public:
TextNoteOptions()

Remarks

The constructed options need to be given a typeId before it can be used to create a text note.

See Also

TextNoteOptions Class
TextNoteOptions Overload


TextNoteOptions Methods

[image] [image]

Revit 2024 API
TextNoteOptions Methods
TextNoteOptions Class See Also Send Feedback

The TextNoteOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TextNoteOptions Class


Dispose Method

[image]

Revit 2024 API
TextNoteOptions..::..Dispose Method
TextNoteOptions Class See Also Send Feedback
Releases all resources used by the TextNoteOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

TextNoteOptions Class


TextNoteOptions Properties

[image] [image]

Revit 2024 API
TextNoteOptions Properties
TextNoteOptions Class See Also Send Feedback

The TextNoteOptions type exposes the following members.

Properties

 | Name | Description
Public property | HorizontalAlignment | Horizontal alignment of the text.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | KeepRotatedTextReadable | Flag controling whether a rotate text is to stay oriented to be always readable.
Public property | Rotation | Base line angle of a text note, in radians.
Public property | TypeId | Id of a text type that defines the style of a text note.
Public property | VerticalAlignment | Vertical alignment of the text.

See Also

TextNoteOptions Class


HorizontalAlignment Property

[image]

Revit 2024 API
TextNoteOptions..::..HorizontalAlignment Property
TextNoteOptions Class See Also Send Feedback
Horizontal alignment of the text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public HorizontalTextAlignment HorizontalAlignment { get; set; }
Visual Basic
Public Property HorizontalAlignment As HorizontalTextAlignment
    Get
    Set
Visual C++
public:
property HorizontalTextAlignment HorizontalAlignment {
    HorizontalTextAlignment get ();
    void set (HorizontalTextAlignment value);
}

Remarks

Default is Left alignment.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

TextNoteOptions Class


IsValidObject Property

[image]

Revit 2024 API
TextNoteOptions..::..IsValidObject Property
TextNoteOptions Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

TextNoteOptions Class


KeepRotatedTextReadable Property

[image]

Revit 2024 API
TextNoteOptions..::..KeepRotatedTextReadable Property
TextNoteOptions Class See Also Send Feedback
Flag controling whether a rotate text is to stay oriented to be always readable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool KeepRotatedTextReadable { get; set; }
Visual Basic
Public Property KeepRotatedTextReadable As Boolean
    Get
    Set
Visual C++
public:
property bool KeepRotatedTextReadable {
    bool get ();
    void set (bool value);
}

Remarks

Default value is True.

See Also

TextNoteOptions Class


Rotation Property

[image]

Revit 2024 API
TextNoteOptions..::..Rotation Property
TextNoteOptions Class See Also Send Feedback
Base line angle of a text note, in radians.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public double Rotation { get; set; }
Visual Basic
Public Property Rotation As Double
    Get
    Set
Visual C++
public:
property double Rotation {
    double get ();
    void set (double value);
}

Remarks

Default value is 0.0.

See Also

TextNoteOptions Class


TypeId Property

[image]

Revit 2024 API
TextNoteOptions..::..TypeId Property
TextNoteOptions Class See Also Send Feedback
Id of a text type that defines the style of a text note.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public ElementId TypeId { get; set; }
Visual Basic
Public Property TypeId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ TypeId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Remarks

No default value. A valid type element Id must be set prior using the options. The text type allows its font name parameter to be set to a font unavailable on the current system. However, any text note created with or set to this font type will be displayed in a default substituted font (e.g. Arial) and the UI will show a blank value in the text type font name parameter. Once the document is opened on a system which has the font set on the text type, the text note will display with that font and the UI will show that font in the text type font name parameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

TextNoteOptions Class


VerticalAlignment Property

[image]

Revit 2024 API
TextNoteOptions..::..VerticalAlignment Property
TextNoteOptions Class See Also Send Feedback
Vertical alignment of the text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public VerticalTextAlignment VerticalAlignment { get; set; }
Visual Basic
Public Property VerticalAlignment As VerticalTextAlignment
    Get
    Set
Visual C++
public:
property VerticalTextAlignment VerticalAlignment {
    VerticalTextAlignment get ();
    void set (VerticalTextAlignment value);
}

Remarks

Default is Top alignment.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

TextNoteOptions Class


TextNoteType Class

[image]

Revit 2024 API
TextNoteType Class
Members See Also Send Feedback
An object that represents a text note style.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class TextNoteType : TextElementType
Visual Basic
Public Class TextNoteType _
    Inherits TextElementType
Visual C++
public ref class TextNoteType : public TextElementType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..LineAndTextAttrSymbol
Autodesk.Revit.DB..::..TextElementType
Autodesk.Revit.DB..::..TextNoteType

See Also

TextNoteType Members


TextNoteType Members

[image] [image]

Revit 2024 API
TextNoteType Members
TextNoteType Class Methods Properties See Also Send Feedback

The TextNoteType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

TextNoteType Class


TextNoteType Methods

[image] [image]

Revit 2024 API
TextNoteType Methods
TextNoteType Class See Also Send Feedback

The TextNoteType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TextNoteType Class


Parameter Property

[image] [image]

Revit 2024 API
TextNoteType..::..Parameter Property
TextNoteType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

TextNoteType Class
TextNoteType Members


TextRange Class

[image]

Revit 2024 API
TextRange Class
Members See Also Send Feedback
An object that is used to identify a range of characters in a FormattedText.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public class TextRange : IDisposable
Visual Basic
Public Class TextRange _
    Implements IDisposable
Visual C++
public ref class TextRange : IDisposable

Remarks

A TextRange consists of a start, which is a zero-based index into the text, and a length, which is the number of characters in the range. The length can be zero.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..TextRange

See Also

TextRange Members


TextRange Members

[image] [image]

Revit 2024 API
TextRange Members
TextRange Class Constructors Methods Properties See Also Send Feedback

The TextRange type exposes the following members.

Constructors

 | Name | Description
Public method | TextRange()()()() | Constructs a TextRange with default values for start and length.
Public method | TextRange(TextRange) | Constructs a copy of the input TextRange object.
Public method | TextRange(Int32, Int32) | Constructs a TextRange with input start and length.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the TextRange
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | End | The index of the first character after the end of the range
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Length | The length of the range.
Public property | Start | The start index of a range within the FormattedText.

See Also

TextRange Class


TextRange Constructor

[image] [image]

Revit 2024 API
TextRange Constructor
TextRange Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TextRange()()()() | Constructs a TextRange with default values for start and length.
Public method | TextRange(TextRange) | Constructs a copy of the input TextRange object.
Public method | TextRange(Int32, Int32) | Constructs a TextRange with input start and length.

See Also

TextRange Class
TextRange Members


TextRange Constructor

[image]

Revit 2024 API
TextRange Constructor
TextRange Class See Also Send Feedback
Constructs a TextRange with default values for start and length.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public TextRange()
Visual Basic
Public Sub New
Visual C++
public:
TextRange()

Remarks

The start and length are set to be 0 by default.

See Also

TextRange Class
TextRange Overload


TextRange Constructor (TextRange)

[image]

Revit 2024 API
TextRange Constructor (TextRange)
TextRange Class See Also Send Feedback
Constructs a copy of the input TextRange object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public TextRange(
    TextRange other
)
Visual Basic
Public Sub New ( _
    other As TextRange _
)
Visual C++
public:
TextRange(
    TextRange^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..TextRange

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

TextRange Class
TextRange Overload


TextRange Constructor (Int32, Int32)

[image]

Revit 2024 API
TextRange Constructor (Int32, Int32)
TextRange Class See Also Send Feedback
Constructs a TextRange with input start and length.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public TextRange(
    int start,
    int length
)
Visual Basic
Public Sub New ( _
    start As Integer, _
    length As Integer _
)
Visual C++
public:
TextRange(
    int start,
    int length
)

Parameters

start
Type: System..::..Int32
length
Type: System..::..Int32

Remarks

The input value for start as well as length should not be negative.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given value for start is negative. -or- The given value for length is negative.

See Also

TextRange Class
TextRange Overload


Dispose Method

[image]

Revit 2024 API
TextRange..::..Dispose Method
TextRange Class See Also Send Feedback
Releases all resources used by the TextRange

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

TextRange Class


TextRange Properties

[image] [image]

Revit 2024 API
TextRange Properties
TextRange Class See Also Send Feedback

The TextRange type exposes the following members.

Properties

 | Name | Description
Public property | End | The index of the first character after the end of the range
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Length | The length of the range.
Public property | Start | The start index of a range within the FormattedText.

See Also

TextRange Class


IsValidObject Property

[image]

Revit 2024 API
TextRange..::..IsValidObject Property
TextRange Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

TextRange Class


Start Property

[image]

Revit 2024 API
TextRange..::..Start Property
TextRange Class See Also Send Feedback
The start index of a range within the FormattedText.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public int Start { get; set; }
Visual Basic
Public Property Start As Integer
    Get
    Set
Visual C++
public:
property int Start {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for start is negative.

See Also

TextRange Class


TextTreatment Enumeration

[image]

Revit 2024 API
TextTreatment Enumeration
See Also Send Feedback
An enumerated type listing possible text treatment modes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum TextTreatment
Visual Basic
Public Enumeration TextTreatment
Visual C++
public enum class TextTreatment

Members

Member name | Description
Exact | Export texts as exact visual fidelity. Formatting intelligence will be lost.
Approximate | Export texts as approximate visual fidelity. Formatting intelligence will be maintained.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


ThermalAsset Class

[image]

Revit 2024 API
ThermalAsset Class
Members See Also Send Feedback
Represents the properties of a material pertinent to energy analysis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public class ThermalAsset : IDisposable
Visual Basic
Public Class ThermalAsset _
    Implements IDisposable
Visual C++
public ref class ThermalAsset : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ThermalAsset

See Also

ThermalAsset Members


ThermalAsset Members

[image] [image]

Revit 2024 API
ThermalAsset Members
ThermalAsset Class Constructors Methods Properties See Also Send Feedback

The ThermalAsset type exposes the following members.

Constructors

 | Name | Description
Public method | ThermalAsset | Constructs an instance of ThermalAsset.

Methods

 | Name | Description
Public method | Copy | Produces a copy of the asset.
Public method | Dispose | Releases all resources used by the ThermalAsset
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(ThermalAsset) | Determines whether this thermal asset is equal to another.
Public method | EqualsThermalOnly | Determines whether this thermal asset is equal to another, but ignore data from base class.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Behavior | Flag indicating whether elements of this material behave isotropically or orthotropically.
Public property | Compressibility | The compressibility of the asset.
Public property | Density | The density of the asset.
Public property | ElectricalResistivity | The electrical resistivity of the asset.
Public property | Emissivity | The emissivity of the asset.
Public property | GasViscosity | The gas viscosity of the asset.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LiquidViscosity | The liquid viscosity of the asset.
Public property | Name | The name of the thermal asset.
Public property | Permeability | The permeability of the asset.
Public property | Porosity | The porosity of the asset.
Public property | Reflectivity | The reflectivity of the asset.
Public property | SpecificHeat | The specific heat of the asset.
Public property | SpecificHeatOfVaporization | The specific heat of vaporization of the asset.
Public property | ThermalConductivity | The thermal conductivity of the asset.
Public property | ThermalMaterialType | The type of material that this thermal asset describes (e.g. solid, liquid, gas.)
Public property | TransmitsLight | A boolean flag that indicates whether or not the asset transmits light.
Public property | VaporPressure | The vapor pressure of the asset.

See Also

ThermalAsset Class


ThermalAsset Constructor

[image]

Revit 2024 API
ThermalAsset Constructor
ThermalAsset Class See Also Send Feedback
Constructs an instance of ThermalAsset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ThermalAsset(
    string name,
    ThermalMaterialType materialType
)
Visual Basic
Public Sub New ( _
    name As String, _
    materialType As ThermalMaterialType _
)
Visual C++
public:
ThermalAsset(
    String^ name,
    ThermalMaterialType materialType
)

Parameters

name
Type: System..::..String
The name of the asset.
materialType
Type: Autodesk.Revit.DB..::..ThermalMaterialType
The type of thermal material that this asset will describe.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | name is an empty string. -or- name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~".
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

ThermalAsset Class


ThermalAsset Methods

[image] [image]

Revit 2024 API
ThermalAsset Methods
ThermalAsset Class See Also Send Feedback

The ThermalAsset type exposes the following members.

Methods

 | Name | Description
Public method | Copy | Produces a copy of the asset.
Public method | Dispose |
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(ThermalAsset) | Determines whether this thermal asset is equal to another.
Public method | EqualsThermalOnly | Determines whether this thermal asset is equal to another, but ignore data from base class.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ThermalAsset Class


Copy Method

[image]

Revit 2024 API
ThermalAsset..::..Copy Method
ThermalAsset Class See Also Send Feedback
Produces a copy of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ThermalAsset Copy()
Visual Basic
Public Function Copy As ThermalAsset
Visual C++
public:
ThermalAsset^ Copy()

Return Value

A copy of the asset.

See Also

ThermalAsset Class


Dispose Method

[image]

Revit 2024 API
ThermalAsset..::..Dispose Method
ThermalAsset Class See Also Send Feedback
Releases all resources used by the ThermalAsset

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ThermalAsset Class


Equals Method

[image] [image]

Revit 2024 API
ThermalAsset..::..Equals Method
ThermalAsset Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(ThermalAsset) | Determines whether this thermal asset is equal to another.

See Also

ThermalAsset Class
ThermalAsset Members


EqualsThermalOnly Method

[image]

Revit 2024 API
ThermalAsset..::..EqualsThermalOnly Method
ThermalAsset Class See Also Send Feedback
Determines whether this thermal asset is equal to another, but ignore data from base class.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool EqualsThermalOnly(
    ThermalAsset other
)
Visual Basic
Public Function EqualsThermalOnly ( _
    other As ThermalAsset _
) As Boolean
Visual C++
public:
bool EqualsThermalOnly(
    ThermalAsset^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..ThermalAsset
The thermal asset to compare with this one.

Return Value

True if the given thermal asset is equal to this one, otherwise false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ThermalAsset Class


ThermalAsset Properties

[image] [image]

Revit 2024 API
ThermalAsset Properties
ThermalAsset Class See Also Send Feedback

The ThermalAsset type exposes the following members.

Properties

 | Name | Description
Public property | Behavior | Flag indicating whether elements of this material behave isotropically or orthotropically.
Public property | Compressibility | The compressibility of the asset.
Public property | Density | The density of the asset.
Public property | ElectricalResistivity | The electrical resistivity of the asset.
Public property | Emissivity | The emissivity of the asset.
Public property | GasViscosity | The gas viscosity of the asset.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LiquidViscosity | The liquid viscosity of the asset.
Public property | Name | The name of the thermal asset.
Public property | Permeability | The permeability of the asset.
Public property | Porosity | The porosity of the asset.
Public property | Reflectivity | The reflectivity of the asset.
Public property | SpecificHeat | The specific heat of the asset.
Public property | SpecificHeatOfVaporization | The specific heat of vaporization of the asset.
Public property | ThermalConductivity | The thermal conductivity of the asset.
Public property | ThermalMaterialType | The type of material that this thermal asset describes (e.g. solid, liquid, gas.)
Public property | TransmitsLight | A boolean flag that indicates whether or not the asset transmits light.
Public property | VaporPressure | The vapor pressure of the asset.

See Also

ThermalAsset Class


Compressibility Property

[image]

Revit 2024 API
ThermalAsset..::..Compressibility Property
ThermalAsset Class See Also Send Feedback
The compressibility of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double Compressibility { get; set; }
Visual Basic
Public Property Compressibility As Double
    Get
    Set
Visual C++
public:
property double Compressibility {
    double get ();
    void set (double value);
}

Remarks

Values must be in the range 0 to 1.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for compressibility is out of range

See Also

ThermalAsset Class


Density Property

[image]

Revit 2024 API
ThermalAsset..::..Density Property
ThermalAsset Class See Also Send Feedback
The density of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double Density { get; set; }
Visual Basic
Public Property Density As Double
    Get
    Set
Visual C++
public:
property double Density {
    double get ();
    void set (double value);
}

Remarks

Values are in kilograms per cubed feet (kg/ftÂ³) and must be non-negative.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for density must be non-negative.

See Also

ThermalAsset Class


Emissivity Property

[image]

Revit 2024 API
ThermalAsset..::..Emissivity Property
ThermalAsset Class See Also Send Feedback
The emissivity of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double Emissivity { get; set; }
Visual Basic
Public Property Emissivity As Double
    Get
    Set
Visual C++
public:
property double Emissivity {
    double get ();
    void set (double value);
}

Remarks

Values must be in the range 0 to 1.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for emissivity is out of range

See Also

ThermalAsset Class


GasViscosity Property

[image]

Revit 2024 API
ThermalAsset..::..GasViscosity Property
ThermalAsset Class See Also Send Feedback
The gas viscosity of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double GasViscosity { get; set; }
Visual Basic
Public Property GasViscosity As Double
    Get
    Set
Visual C++
public:
property double GasViscosity {
    double get ();
    void set (double value);
}

Remarks

Values are in kilograms per feet-second (kg/(ft Â· s)) and must be non-negative.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for gasViscosity must be non-negative.
Autodesk.Revit.Exceptions..::..InapplicableDataException | When setting this property: the asset must be gas to set this property.

See Also

ThermalAsset Class


IsValidObject Property

[image]

Revit 2024 API
ThermalAsset..::..IsValidObject Property
ThermalAsset Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ThermalAsset Class


LiquidViscosity Property

[image]

Revit 2024 API
ThermalAsset..::..LiquidViscosity Property
ThermalAsset Class See Also Send Feedback
The liquid viscosity of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double LiquidViscosity { get; set; }
Visual Basic
Public Property LiquidViscosity As Double
    Get
    Set
Visual C++
public:
property double LiquidViscosity {
    double get ();
    void set (double value);
}

Remarks

Values are in kilograms per feet-second (kg/(ft Â· s)) and must be non-negative.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for liquidViscosity must be non-negative.
Autodesk.Revit.Exceptions..::..InapplicableDataException | When setting this property: the asset must be liquid to set this property.

See Also

ThermalAsset Class


Permeability Property

[image]

Revit 2024 API
ThermalAsset..::..Permeability Property
ThermalAsset Class See Also Send Feedback
The permeability of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double Permeability { get; set; }
Visual Basic
Public Property Permeability As Double
    Get
    Set
Visual C++
public:
property double Permeability {
    double get ();
    void set (double value);
}

Remarks

Values are in seconds per foot (s/ft) and must be non-negative.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for permeability must be non-negative.

See Also

ThermalAsset Class


Reflectivity Property

[image]

Revit 2024 API
ThermalAsset..::..Reflectivity Property
ThermalAsset Class See Also Send Feedback
The reflectivity of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double Reflectivity { get; set; }
Visual Basic
Public Property Reflectivity As Double
    Get
    Set
Visual C++
public:
property double Reflectivity {
    double get ();
    void set (double value);
}

Remarks

Values must be in the range 0 to 1.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for reflectivity is out of range

See Also

ThermalAsset Class


SpecificHeat Property

[image]

Revit 2024 API
ThermalAsset..::..SpecificHeat Property
ThermalAsset Class See Also Send Feedback
The specific heat of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public double SpecificHeat { get; set; }
Visual Basic
Public Property SpecificHeat As Double
    Get
    Set
Visual C++
public:
property double SpecificHeat {
    double get ();
    void set (double value);
}

Remarks

Values are in squared-feet per Kelvin, squared-second (ftÂ²/(K Â· sÂ²)) and must be non-negative.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for specificHeat must be non-negative.

See Also

ThermalAsset Class


SpecificHeatOfVaporization Property

[image]

Revit 2024 API
ThermalAsset..::..SpecificHeatOfVaporization Property
ThermalAsset Class See Also Send Feedback
The specific heat of vaporization of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double SpecificHeatOfVaporization { get; set; }
Visual Basic
Public Property SpecificHeatOfVaporization As Double
    Get
    Set
Visual C++
public:
property double SpecificHeatOfVaporization {
    double get ();
    void set (double value);
}

Remarks

Values are in feet per squared-second (ft/sÂ²) and must be non-negative.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for specificHeatOfVaporization must be non-negative.

See Also

ThermalAsset Class


ThermalConductivity Property

[image]

Revit 2024 API
ThermalAsset..::..ThermalConductivity Property
ThermalAsset Class See Also Send Feedback
The thermal conductivity of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double ThermalConductivity { get; set; }
Visual Basic
Public Property ThermalConductivity As Double
    Get
    Set
Visual C++
public:
property double ThermalConductivity {
    double get ();
    void set (double value);
}

Remarks

Values are in feet-kilograms per Kelvin-cubed-second ((ft Â· kg)/(K Â· sÂ³)) and must be non-negative.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for thermalConductivity must be non-negative.

See Also

ThermalAsset Class


ThermalMaterialType Property

[image]

Revit 2024 API
ThermalAsset..::..ThermalMaterialType Property
ThermalAsset Class See Also Send Feedback
The type of material that this thermal asset describes (e.g. solid, liquid, gas.)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ThermalMaterialType ThermalMaterialType { get; }
Visual Basic
Public ReadOnly Property ThermalMaterialType As ThermalMaterialType
    Get
Visual C++
public:
property ThermalMaterialType ThermalMaterialType {
    ThermalMaterialType get ();
}

See Also

ThermalAsset Class


TransmitsLight Property

[image]

Revit 2024 API
ThermalAsset..::..TransmitsLight Property
ThermalAsset Class See Also Send Feedback
A boolean flag that indicates whether or not the asset transmits light.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool TransmitsLight { get; set; }
Visual Basic
Public Property TransmitsLight As Boolean
    Get
    Set
Visual C++
public:
property bool TransmitsLight {
    bool get ();
    void set (bool value);
}

See Also

ThermalAsset Class


VaporPressure Property

[image]

Revit 2024 API
ThermalAsset..::..VaporPressure Property
ThermalAsset Class See Also Send Feedback
The vapor pressure of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double VaporPressure { get; set; }
Visual Basic
Public Property VaporPressure As Double
    Get
    Set
Visual C++
public:
property double VaporPressure {
    double get ();
    void set (double value);
}

Remarks

Values are in kilograms per feet, squared-second (kg/(ft Â· sÂ²)) and must be non-negative.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for vaporPressure must be non-negative.

See Also

ThermalAsset Class


ThermalMaterialType Enumeration

[image]

Revit 2024 API
ThermalMaterialType Enumeration
See Also Send Feedback
Represents the thermal material type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Since: 2013

Syntax

C#
public enum ThermalMaterialType
Visual Basic
Public Enumeration ThermalMaterialType
Visual C++
public enum class ThermalMaterialType

Members

Member name | Description
Undefined | Thermal material type is undefined.
Gas | Thermal material type is gas.
Liquid | Thermal material type is liquid.
Solid | Thermal material type is solid.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


ThermalProperties Class

[image]

Revit 2024 API
ThermalProperties Class
Members See Also Send Feedback
Class specific to thermal properties for assembly types, such as Wall, Floor, Ceiling, Roof and Building Pad.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public class ThermalProperties : APIObject
Visual Basic
Public Class ThermalProperties _
    Inherits APIObject
Visual C++
public ref class ThermalProperties : public APIObject

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..ThermalProperties

See Also

ThermalProperties Members


ThermalProperties Members

[image] [image]

Revit 2024 API
ThermalProperties Members
ThermalProperties Class Methods Properties See Also Send Feedback

The ThermalProperties type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Absorptance | Value of absorptance.
Public property | HeatTransferCoefficient | The heat transfer coefficient value (U-Value). The unit is watts per meter-squared kelvin (W/(m^2*K)).
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Roughness | Value of roughness.
Public property | ThermalMass | The calculated thermal mass value. The unit is kilogram feet-squared per second squared kelvin (kg ft^2/(s^2 K)).
Public property | ThermalResistance | The calculated thermal resistance value (R-Value). The unit is meter-squared kelvin per watt ((m^2*K)/Watt).

See Also

ThermalProperties Class


ThermalProperties Methods

[image] [image]

Revit 2024 API
ThermalProperties Methods
ThermalProperties Class See Also Send Feedback

The ThermalProperties type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ThermalProperties Class


ThermalProperties Properties

[image] [image]

Revit 2024 API
ThermalProperties Properties
ThermalProperties Class See Also Send Feedback

The ThermalProperties type exposes the following members.

Properties

 | Name | Description
Public property | Absorptance | Value of absorptance.
Public property | HeatTransferCoefficient | The heat transfer coefficient value (U-Value). The unit is watts per meter-squared kelvin (W/(m^2*K)).
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Roughness | Value of roughness.
Public property | ThermalMass | The calculated thermal mass value. The unit is kilogram feet-squared per second squared kelvin (kg ft^2/(s^2 K)).
Public property | ThermalResistance | The calculated thermal resistance value (R-Value). The unit is meter-squared kelvin per watt ((m^2*K)/Watt).

See Also

ThermalProperties Class


IsValidObject Property

[image]

Revit 2024 API
ThermalProperties..::..IsValidObject Property
ThermalProperties Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ThermalProperties Class


Roughness Property

[image]

Revit 2024 API
ThermalProperties..::..Roughness Property
ThermalProperties Class See Also Send Feedback
Value of roughness.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public int Roughness { get; set; }
Visual Basic
Public Property Roughness As Integer
    Get
    Set
Visual C++
public:
property int Roughness {
    int get ();
    void set (int value);
}

See Also

ThermalProperties Class


ThermalMass Property

[image]

Revit 2024 API
ThermalProperties..::..ThermalMass Property
ThermalProperties Class See Also Send Feedback
The calculated thermal mass value. The unit is kilogram feet-squared per second squared kelvin (kg ft^2/(s^2 K)).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public double ThermalMass { get; }
Visual Basic
Public ReadOnly Property ThermalMass As Double
    Get
Visual C++
public:
property double ThermalMass {
    double get ();
}

See Also

ThermalProperties Class


TilePattern Members

[image] [image]

Revit 2024 API
TilePattern Members
TilePattern Class Methods Properties See Also Send Feedback

The TilePattern type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | TilePatternType | The built-in system tile pattern specified by this object.
Public property | TilesPerSeedNode | Get the number of tiles located at each seed node.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

TilePattern Class


TilePattern Methods

[image] [image]

Revit 2024 API
TilePattern Methods
TilePattern Class See Also Send Feedback

The TilePattern type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TilePattern Class


TilePattern Properties

[image] [image]

Revit 2024 API
TilePattern Properties
TilePattern Class See Also Send Feedback

The TilePattern type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | TilePatternType | The built-in system tile pattern specified by this object.
Public property | TilesPerSeedNode | Get the number of tiles located at each seed node.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

TilePattern Class


Parameter Property

[image] [image]

Revit 2024 API
TilePattern..::..Parameter Property
TilePattern Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

TilePattern Class
TilePattern Members


TilePatternType Property

[image]

Revit 2024 API
TilePattern..::..TilePatternType Property
TilePattern Class See Also Send Feedback
The built-in system tile pattern specified by this object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public TilePatternsBuiltIn TilePatternType { get; }
Visual Basic
Public ReadOnly Property TilePatternType As TilePatternsBuiltIn
    Get
Visual C++
public:
property TilePatternsBuiltIn TilePatternType {
    TilePatternsBuiltIn get ();
}

See Also

TilePattern Class


TilePatterns Members

[image] [image]

Revit 2024 API
TilePatterns Members
TilePatterns Class Methods Properties See Also Send Feedback

The TilePatterns type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTilePattern | Retrieve a TilePattern object from a built-in type.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

TilePatterns Class


TilePatterns Methods

[image] [image]

Revit 2024 API
TilePatterns Methods
TilePatterns Class See Also Send Feedback

The TilePatterns type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTilePattern | Retrieve a TilePattern object from a built-in type.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TilePatterns Class


GetTilePattern Method

[image]

Revit 2024 API
TilePatterns..::..GetTilePattern Method
TilePatterns Class See Also Send Feedback
Retrieve a TilePattern object from a built-in type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public TilePattern GetTilePattern(
    TilePatternsBuiltIn tilePatternBuiltIn
)
Visual Basic
Public Function GetTilePattern ( _
    tilePatternBuiltIn As TilePatternsBuiltIn _
) As TilePattern
Visual C++
public:
TilePattern^ GetTilePattern(
    TilePatternsBuiltIn tilePatternBuiltIn
)

Parameters

tilePatternBuiltIn
Type: Autodesk.Revit.DB..::..TilePatternsBuiltIn

Return Value

A TilePattern object, or nullNothingnullptra null reference (Nothing in Visual Basic) if the document is not a Massing Family.

See Also

TilePatterns Class


TilePatterns Properties

[image] [image]

Revit 2024 API
TilePatterns Properties
TilePatterns Class See Also Send Feedback

The TilePatterns type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

TilePatterns Class


TilePatternsBuiltIn Enumeration

[image]

Revit 2024 API
TilePatternsBuiltIn Enumeration
See Also Send Feedback
Revit's built-in tile patterns. See TilePattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum TilePatternsBuiltIn
Visual Basic
Public Enumeration TilePatternsBuiltIn
Visual C++
public enum class TilePatternsBuiltIn

Members

Member name | Description
Rectangle |
Triangle_Bent |
Rhomboid |
Hexagon |
HalfStep |
ThirdStep |
TriangleCheckerboard_Bent |
RectangleCheckerboard |
RhomboidCheckerboard |
TriangleStep_Bent |
Arrows |
ZigZag |
Octagon |
OctagonRotate |
Triangle_Flat |
TriangleCheckerboard_Flat |

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


Toposolid Class

[image]

Revit 2024 API
Toposolid Class
Members See Also Send Feedback
An object that represents a Toposolid within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public class Toposolid : CeilingAndFloor
Visual Basic
Public Class Toposolid _
    Inherits CeilingAndFloor
Visual C++
public ref class Toposolid : public CeilingAndFloor

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB..::..CeilingAndFloor
Autodesk.Revit.DB..::..Toposolid

See Also

Toposolid Members


Toposolid Members

[image] [image]

Revit 2024 API
Toposolid Members
Toposolid Class Methods Properties See Also Send Feedback

The Toposolid type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create(Document, IList<(Of <<'(CurveLoop>)>>), ElementId, ElementId) | Creates a new instance of toposolid within the project.
 | Create(Document, IList<(Of <<'(XYZ>)>>), ElementId, ElementId) | Creates a new instance of toposolid within the project.
 | Create(Document, IList<(Of <<'(CurveLoop>)>>), IList<(Of <<'(XYZ>)>>), ElementId, ElementId) | Creates a new instance of toposolid within the project.
 | CreateFromTopographySurface | Creates a toposolid element from a host TopographySurface, and toposolid sub-divisions from its subregions.
Public method | CreateSubDivision | Create a toposolid subdivision element with the current toposolid as its host.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSlabShapeEditor | Gets a SlabShapeEditor that can be used to add or modify points of this Toposolid.
Public method | GetSubDivisionIds | Get all element ids of toposolid subdivisions with the current toposolid as its host.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | Simplify | Simplifies the toposolid by reducing the number of inner vertices to the given percentage.
Public method | Split | Split the toposolid by the given curve loops.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | HostTopoId | The host toposolid id of the current toposolid subdivision. If the object is not a toposolid subdivision, hostTopoId will be InvalidElementId.
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchId | Returns id of the sketch.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Toposolid Class


Toposolid Methods

[image] [image]

Revit 2024 API
Toposolid Methods
Toposolid Class See Also Send Feedback

The Toposolid type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create(Document, IList<(Of <<'(CurveLoop>)>>), ElementId, ElementId) | Creates a new instance of toposolid within the project.
 | Create(Document, IList<(Of <<'(XYZ>)>>), ElementId, ElementId) | Creates a new instance of toposolid within the project.
 | Create(Document, IList<(Of <<'(CurveLoop>)>>), IList<(Of <<'(XYZ>)>>), ElementId, ElementId) | Creates a new instance of toposolid within the project.
 | CreateFromTopographySurface | Creates a toposolid element from a host TopographySurface, and toposolid sub-divisions from its subregions.
Public method | CreateSubDivision | Create a toposolid subdivision element with the current toposolid as its host.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSlabShapeEditor | Gets a SlabShapeEditor that can be used to add or modify points of this Toposolid.
Public method | GetSubDivisionIds | Get all element ids of toposolid subdivisions with the current toposolid as its host.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | Simplify | Simplifies the toposolid by reducing the number of inner vertices to the given percentage.
Public method | Split | Split the toposolid by the given curve loops.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Toposolid Class


Create Method

[image] [image]

Revit 2024 API
Toposolid..::..Create Method
Toposolid Class See Also Send Feedback

Overload List

Name | Description
Create(Document, IList<(Of <<'(CurveLoop>)>>), ElementId, ElementId) | Creates a new instance of toposolid within the project.
Create(Document, IList<(Of <<'(XYZ>)>>), ElementId, ElementId) | Creates a new instance of toposolid within the project.
Create(Document, IList<(Of <<'(CurveLoop>)>>), IList<(Of <<'(XYZ>)>>), ElementId, ElementId) | Creates a new instance of toposolid within the project.

See Also

Toposolid Class
Toposolid Members


Create Method (Document, IList(CurveLoop), ElementId, ElementId)

[image]

Revit 2024 API
Toposolid..::..Create Method (Document, IList<(Of <(<'CurveLoop>)>)>, ElementId, ElementId)
Toposolid Class See Also Send Feedback
Creates a new instance of toposolid within the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static Toposolid Create(
    Document document,
    IList<CurveLoop> profiles,
    ElementId topoTypeId,
    ElementId levelId
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    profiles As IList(Of CurveLoop), _
    topoTypeId As ElementId, _
    levelId As ElementId _
) As Toposolid
Visual C++
public:
static Toposolid^ Create(
    Document^ document,
    IList<CurveLoop^>^ profiles,
    ElementId^ topoTypeId,
    ElementId^ levelId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which the new toposolid is created.
profiles
Type: System.Collections.Generic..::..IList<(Of <(<' CurveLoop >)>)>
An array of planar curve loops that represent the profiles of the toposolid.
topoTypeId
Type: Autodesk.Revit.DB..::..ElementId
Id of the toposolid type to be used by the new toposolid.
levelId
Type: Autodesk.Revit.DB..::..ElementId
Id of the level on which the toposolid is to be placed.

Return Value

A new toposolid object within the project if successful.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input curve loops cannot compose a valid boundary, that means: the "curveLoops" collection is empty; or some curve loops intersect with each other; or each curve loop is not closed individually; or each curve loop is not planar; or each curve loop is not in a plane parallel to the horizontal(XY) plane; or input curves contain at least one helical curve. -or- The ElementId levelId is not a Level. -or- Toposolid type is not valid for this toposolid. -or- Input curves build invalid sketch. -or- Failed to create curve elements.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | Cannot generate a sketch. -or- Failed to create new element.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

Toposolid Class
Create Overload


Create Method (Document, IList(CurveLoop), IList(XYZ), ElementId, ElementId)

[image]

Revit 2024 API
Toposolid..::..Create Method (Document, IList<(Of <(<'CurveLoop>)>)>, IList<(Of <(<'XYZ>)>)>, ElementId, ElementId)
Toposolid Class See Also Send Feedback
Creates a new instance of toposolid within the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static Toposolid Create(
    Document document,
    IList<CurveLoop> profiles,
    IList<XYZ> points,
    ElementId topoTypeId,
    ElementId levelId
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    profiles As IList(Of CurveLoop), _
    points As IList(Of XYZ), _
    topoTypeId As ElementId, _
    levelId As ElementId _
) As Toposolid
Visual C++
public:
static Toposolid^ Create(
    Document^ document,
    IList<CurveLoop^>^ profiles,
    IList<XYZ^>^ points,
    ElementId^ topoTypeId,
    ElementId^ levelId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which the new toposolid is created.
profiles
Type: System.Collections.Generic..::..IList<(Of <(<' CurveLoop >)>)>
An array of planar curve loops that represent the profiles of the toposolid.
points
Type: System.Collections.Generic..::..IList<(Of <(<' XYZ >)>)>
An array of points that used to construct the top face of the toposolid.
topoTypeId
Type: Autodesk.Revit.DB..::..ElementId
Id of the toposolid type to be used by the new toposolid.
levelId
Type: Autodesk.Revit.DB..::..ElementId
Id of the level on which the toposolid is to be placed.

Return Value

A new toposolid object within the project if successful.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input curve loops cannot compose a valid boundary, that means: the "curveLoops" collection is empty; or some curve loops intersect with each other; or each curve loop is not closed individually; or each curve loop is not planar; or each curve loop is not in a plane parallel to the horizontal(XY) plane; or input curves contain at least one helical curve. -or- The input point array size is less than 3. -or- The ElementId levelId is not a Level. -or- Toposolid type is not valid for this toposolid. -or- Input curves build invalid sketch. -or- Failed to create curve elements.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | Cannot generate a sketch. -or- Failed to create new element.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

Toposolid Class
Create Overload


CreateFromTopographySurface Method

[image]

Revit 2024 API
Toposolid..::..CreateFromTopographySurface Method
Toposolid Class See Also Send Feedback
Creates a toposolid element from a host TopographySurface, and toposolid sub-divisions from its subregions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public static Toposolid CreateFromTopographySurface(
    Document document,
    ElementId hostSurfaceId,
    ElementId topoTypeId,
    ElementId levelId
)
Visual Basic
Public Shared Function CreateFromTopographySurface ( _
    document As Document, _
    hostSurfaceId As ElementId, _
    topoTypeId As ElementId, _
    levelId As ElementId _
) As Toposolid
Visual C++
public:
static Toposolid^ CreateFromTopographySurface(
    Document^ document,
    ElementId^ hostSurfaceId,
    ElementId^ topoTypeId,
    ElementId^ levelId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which the new toposolid is created.
hostSurfaceId
Type: Autodesk.Revit.DB..::..ElementId
Id of the host TopogarphySurface element.
topoTypeId
Type: Autodesk.Revit.DB..::..ElementId
Id of the toposolid type to be used by the new toposolid.
levelId
Type: Autodesk.Revit.DB..::..ElementId
Id of the level on which the toposolid is to be placed.

Return Value

A new toposolid object within the project if successful.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Toposolid Class


CreateSubDivision Method

[image]

Revit 2024 API
Toposolid..::..CreateSubDivision Method
Toposolid Class See Also Send Feedback
Create a toposolid subdivision element with the current toposolid as its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public Toposolid CreateSubDivision(
    Document document,
    IList<CurveLoop> profiles
)
Visual Basic
Public Function CreateSubDivision ( _
    document As Document, _
    profiles As IList(Of CurveLoop) _
) As Toposolid
Visual C++
public:
Toposolid^ CreateSubDivision(
    Document^ document,
    IList<CurveLoop^>^ profiles
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which the new toposolid is created.
profiles
Type: System.Collections.Generic..::..IList<(Of <(<' CurveLoop >)>)>
An array of planar curve loops that represent the profiles of the toposolid.

Return Value

The toposolid subdivision object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input curve loops cannot compose a valid boundary, that means: the "curveLoops" collection is empty; or some curve loops intersect with each other; or each curve loop is not closed individually; or each curve loop is not planar; or each curve loop is not in a plane parallel to the horizontal(XY) plane; or input curves contain at least one helical curve.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Toposolid Class


GetSlabShapeEditor Method

[image]

Revit 2024 API
Toposolid..::..GetSlabShapeEditor Method
Toposolid Class See Also Send Feedback
Gets a SlabShapeEditor that can be used to add or modify points of this Toposolid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public SlabShapeEditor GetSlabShapeEditor()
Visual Basic
Public Function GetSlabShapeEditor As SlabShapeEditor
Visual C++
public:
SlabShapeEditor^ GetSlabShapeEditor()

Return Value

The SlabShapeEditor object

See Also

Toposolid Class


GetSubDivisionIds Method

[image]

Revit 2024 API
Toposolid..::..GetSubDivisionIds Method
Toposolid Class See Also Send Feedback
Get all element ids of toposolid subdivisions with the current toposolid as its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public IList<ElementId> GetSubDivisionIds()
Visual Basic
Public Function GetSubDivisionIds As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetSubDivisionIds()

Return Value

The array of toposolid subdivision ids.

See Also

Toposolid Class


Split Method

[image]

Revit 2024 API
Toposolid..::..Split Method
Toposolid Class See Also Send Feedback
Split the toposolid by the given curve loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public IList<ElementId> Split(
    IList<CurveLoop> splitCurveLoops
)
Visual Basic
Public Function Split ( _
    splitCurveLoops As IList(Of CurveLoop) _
) As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ Split(
    IList<CurveLoop^>^ splitCurveLoops
)

Parameters

splitCurveLoops
Type: System.Collections.Generic..::..IList<(Of <(<' CurveLoop >)>)>
An array of planar curve loops that are used to split the toposolid. All of the curve loops should lie on the sketch plane of the toposolid.

Return Value

An array of newly created toposolid ids after split.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The split curve loops should all lie on the sketch plane of the toposolid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Toposolid Class


Toposolid Properties

[image] [image]

Revit 2024 API
Toposolid Properties
Toposolid Class See Also Send Feedback

The Toposolid type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | HostTopoId | The host toposolid id of the current toposolid subdivision. If the object is not a toposolid subdivision, hostTopoId will be InvalidElementId.
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchId | Returns id of the sketch.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Toposolid Class


Parameter Property

[image] [image]

Revit 2024 API
Toposolid..::..Parameter Property
Toposolid Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Toposolid Class
Toposolid Members


ToposolidType Class

[image]

Revit 2024 API
ToposolidType Class
Members See Also Send Feedback
An object that specifies the type of a Toposolid in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public class ToposolidType : HostObjAttributes
Visual Basic
Public Class ToposolidType _
    Inherits HostObjAttributes
Visual C++
public ref class ToposolidType : public HostObjAttributes

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..HostObjAttributes
Autodesk.Revit.DB..::..ToposolidType

See Also

ToposolidType Members


ToposolidType Members

[image] [image]

Revit 2024 API
ToposolidType Members
ToposolidType Class Methods Properties See Also Send Feedback

The ToposolidType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | GetContourSetting | Get the contour setting object from the current toposolid type.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ToposolidType Class


ToposolidType Methods

[image] [image]

Revit 2024 API
ToposolidType Methods
ToposolidType Class See Also Send Feedback

The ToposolidType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | GetContourSetting | Get the contour setting object from the current toposolid type.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ToposolidType Class


GetContourSetting Method

[image]

Revit 2024 API
ToposolidType..::..GetContourSetting Method
ToposolidType Class See Also Send Feedback
Get the contour setting object from the current toposolid type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public ContourSetting GetContourSetting()
Visual Basic
Public Function GetContourSetting As ContourSetting
Visual C++
public:
ContourSetting^ GetContourSetting()

Return Value

The contour setting object.

See Also

ToposolidType Class


ToposolidType Properties

[image] [image]

Revit 2024 API
ToposolidType Properties
ToposolidType Class See Also Send Feedback

The ToposolidType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ToposolidType Class


Parameter Property

[image] [image]

Revit 2024 API
ToposolidType..::..Parameter Property
ToposolidType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ToposolidType Class
ToposolidType Members


Transaction Class

[image]

Revit 2024 API
Transaction Class
Members Example See Also Send Feedback
Transactions are context-like objects that guard any changes made to a Revit model

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class Transaction : IDisposable
Visual Basic
Public Class Transaction _
    Implements IDisposable
Visual C++
public ref class Transaction : IDisposable

Remarks

Any change to a document can only be made while there is an active transaction open for that document. Changes do not become part of the document until the active transaction is committed. Consequently, all changes made in a transaction can be rolled back either explicitly or implicitly by the transaction's destructor.

A document can have only one transaction open at any given time.

Transactions cannot be started when the document is in read-only mode, either permanently or temporarily. See the Document class methods IsReadOnly and IsModifiable for more details.

Transactions in linked documents are not permitted, for linked documents are not allowed to be modified.

If a transaction was started and not finished yet by the time the Transaction object is about to be disposed, the default destructor will roll it back automatically, thus all changes made to the document while this transaction was open will be discarded. It is not recommended to rely on this default behavior though. Instead, it is advised to always call either Commit or RollBack explicitly before the transaction object gets disposed. Please note that unless invoked explicitly the actual destruction of an object in managed code might not happen until the object is collected by the garbage collector.

Examples

CopyC#
public void CreatingSketch(UIApplication uiApplication)
{
    Autodesk.Revit.DB.Document document = uiApplication.ActiveUIDocument.Document;
    Autodesk.Revit.ApplicationServices.Application application = uiApplication.Application;

    // Create a few geometry lines. These lines are transaction (not in the model),
    // therefore they do not need to be created inside a document transaction.
    XYZ Point1 = XYZ.Zero;
    XYZ Point2 = new XYZ(10, 0, 0);
    XYZ Point3 = new XYZ(10, 10, 0);
    XYZ Point4 = new XYZ(0, 10, 0);

    Line geomLine1 = Line.CreateBound(Point1, Point2);
    Line geomLine2 = Line.CreateBound(Point4, Point3);
    Line geomLine3 = Line.CreateBound(Point1, Point4);

    // This geometry plane is also transaction and does not need a transaction
    XYZ origin = XYZ.Zero;
    XYZ normal = new XYZ(0, 0, 1);
    Plane geomPlane = Plane.CreateByNormalAndOrigin(normal, origin);

    // In order to a sketch plane with model curves in it, we need
    // to start a transaction because such operations modify the model.

    // All and any transaction should be enclosed in a 'using'
    // block or guarded within a try-catch-finally blocks
    // to guarantee that a transaction does not out-live its scope.
    using (Transaction transaction = new Transaction(document))
    {
       if (transaction.Start("Create model curves") == TransactionStatus.Started)
       {
           // Create a sketch plane in current document
           SketchPlane sketch = SketchPlane.Create(document,geomPlane);

           // Create a ModelLine elements using the geometry lines and sketch plane
           ModelLine line1 = document.Create.NewModelCurve(geomLine1, sketch) as ModelLine;
           ModelLine line2 = document.Create.NewModelCurve(geomLine2, sketch) as ModelLine;
           ModelLine line3 = document.Create.NewModelCurve(geomLine3, sketch) as ModelLine;

           // Ask the end user whether the changes are to be committed or not
           TaskDialog taskDialog = new TaskDialog("Revit");
           taskDialog.MainContent = "Click either [OK] to Commit, or [Cancel] to Roll back the transaction.";
           TaskDialogCommonButtons buttons = TaskDialogCommonButtons.Ok | TaskDialogCommonButtons.Cancel;
           taskDialog.CommonButtons = buttons;

           if (TaskDialogResult.Ok == taskDialog.Show())
           {
               // For many various reasons, a transaction may not be committed
               // if the changes made during the transaction do not result a valid model.
               // If committing a transaction fails or is canceled by the end user,
               // the resulting status would be RolledBack instead of Committed.
               if (TransactionStatus.Committed != transaction.Commit())
               {
                  TaskDialog.Show("Failure", "Transaction could not be committed");
               }
           }
           else
           {
               transaction.RollBack();
           }
       }
    }
}
CopyVB.NET
Public Sub CreatingSketch(uiApplication As UIApplication)
    Dim document As Autodesk.Revit.DB.Document = uiApplication.ActiveUIDocument.Document
    Dim application As Autodesk.Revit.ApplicationServices.Application = uiApplication.Application

    ' Create a few geometry lines. These lines are transaction (not in the model),
    ' therefore they do not need to be created inside a document transaction.
    Dim Point1 As XYZ = XYZ.Zero
    Dim Point2 As New XYZ(10, 0, 0)
    Dim Point3 As New XYZ(10, 10, 0)
    Dim Point4 As New XYZ(0, 10, 0)

    Dim geomLine1 As Line = Line.CreateBound(Point1, Point2)
    Dim geomLine2 As Line = Line.CreateBound(Point4, Point3)
    Dim geomLine3 As Line = Line.CreateBound(Point1, Point4)

    ' This geometry plane is also transaction and does not need a transaction
    Dim origin As XYZ = XYZ.Zero
    Dim normal As New XYZ(0, 0, 1)
 Dim geomPlane As Plane = Plane.CreateByNormalAndOrigin(normal, origin)

    ' In order to a sketch plane with model curves in it, we need
    ' to start a transaction because such operations modify the model.

    ' All and any transaction should be enclosed in a 'using'
    ' block or guarded within a try-catch-finally blocks
    ' to guarantee that a transaction does not out-live its scope.
    Using transaction As New Transaction(document)
        If transaction.Start("Create model curves") = TransactionStatus.Started Then
            ' Create a sketch plane in current document
            Dim sketch As SketchPlane = SketchPlane.Create(document, geomPlane)

            ' Create a ModelLine elements using the geometry lines and sketch plane
            Dim line1 As ModelLine = TryCast(document.Create.NewModelCurve(geomLine1, sketch), ModelLine)
            Dim line2 As ModelLine = TryCast(document.Create.NewModelCurve(geomLine2, sketch), ModelLine)
            Dim line3 As ModelLine = TryCast(document.Create.NewModelCurve(geomLine3, sketch), ModelLine)

            ' Ask the end user whether the changes are to be committed or not
            Dim taskDialog__1 As New TaskDialog("Revit")
            taskDialog__1.MainContent = "Click either [OK] to Commit, or [Cancel] to Roll back the transaction."
            Dim buttons As TaskDialogCommonButtons = TaskDialogCommonButtons.Ok Or TaskDialogCommonButtons.Cancel
            taskDialog__1.CommonButtons = buttons

            If TaskDialogResult.Ok = taskDialog__1.Show() Then
                ' For many various reasons, a transaction may not be committed
                ' if the changes made during the transaction do not result a valid model.
                ' If committing a transaction fails or is canceled by the end user,
                ' the resulting status would be RolledBack instead of Committed.
                If TransactionStatus.Committed <> transaction.Commit() Then
                    TaskDialog.Show("Failure", "Transaction could not be committed")
                End If
            Else
                transaction.RollBack()
            End If
        End If
    End Using
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Transaction

See Also

Transaction Members


Transaction Members

[image] [image]

Revit 2024 API
Transaction Members
Transaction Class Constructors Methods Properties See Also Send Feedback

The Transaction type exposes the following members.

Constructors

 | Name | Description
Public method | Transaction(Document) | Instantiates a transaction object.
Public method | Transaction(Document, String) | Instantiates a transaction object

Methods

 | Name | Description
Public method | Commit()()()() | Commits all changes made to the model during the transaction.
Public method | Commit(FailureHandlingOptions) | Commits all changes made to the model during the transaction.
Public method | Dispose | Releases all resources used by the Transaction
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetFailureHandlingOptions | Returns the current failure handling options.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetName | Returns the transaction's name.
Public method | GetStatus | Returns the current status of the transaction.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasEnded | Determines whether the transaction has ended already.
Public method | HasStarted | Determines whether the transaction has been started yet.
Public method | RollBack()()()() | Rolls back all changes made to the model during the transaction.
Public method | RollBack(FailureHandlingOptions) | Rolls back all changes made to the model during the transaction.
Public method | SetFailureHandlingOptions | Sets options for handling failures to be used when the transaction is being committed or rolled back.
Public method | SetName | Sets the transaction's name.
Public method | Start()()()() | Starts the transaction.
Public method | Start(String) | Starts the transaction with an assigned name.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

Transaction Class


Transaction Constructor

[image] [image]

Revit 2024 API
Transaction Constructor
Transaction Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Transaction(Document) | Instantiates a transaction object.
Public method | Transaction(Document, String) | Instantiates a transaction object

See Also

Transaction Class
Transaction Members


Transaction Constructor (Document)

[image]

Revit 2024 API
Transaction Constructor (Document)
Transaction Class See Also Send Feedback
Instantiates a transaction object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Transaction(
    Document document
)
Visual Basic
Public Sub New ( _
    document As Document _
)
Visual C++
public:
Transaction(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document for which this transaction is going to be used.

Remarks

The transaction does not start by creating a transaction object. One of the 'Start' methods will need to be called in order to start this transaction.

A transaction cannot start unless is has a valid (non-empty) name. Because this constructor does not take a name, a name must be assigned later before or during the 'Start' method.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Document is a linked file. Transactions can only be used in primary documents (projects or families.)
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Transaction Class
Transaction Overload


Transaction Constructor (Document, String)

[image]

Revit 2024 API
Transaction Constructor (Document, String)
Transaction Class See Also Send Feedback
Instantiates a transaction object

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Transaction(
    Document document,
    string name
)
Visual Basic
Public Sub New ( _
    document As Document, _
    name As String _
)
Visual C++
public:
Transaction(
    Document^ document,
    String^ name
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document for which this transaction is going to be used.
name
Type: System..::..String
The name of the transaction. This name will appear in the undo menu once the transaction is successfully committed. The name must not be empty. The name can be reset later by either calling SetName(String) or by using the name argument in the Start(String) method.

Remarks

The transaction does not start by creating a transaction object. One of the 'Start' methods will need to be called in order to start this transaction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The name argument is an empty string. -or- Document is a linked file. Transactions can only be used in primary documents (projects or families.)
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Transaction Class
Transaction Overload


Commit Method

[image] [image]

Revit 2024 API
Transaction..::..Commit Method
Transaction Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Commit()()()() | Commits all changes made to the model during the transaction.
Public method | Commit(FailureHandlingOptions) | Commits all changes made to the model during the transaction.

See Also

Transaction Class
Transaction Members


Commit Method

[image]

Revit 2024 API
Transaction..::..Commit Method
Transaction Class Example See Also Send Feedback
Commits all changes made to the model during the transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public TransactionStatus Commit()
Visual Basic
Public Function Commit As TransactionStatus
Visual C++
public:
TransactionStatus Commit()

Return Value

If finished successfully, this method returns TransactionStatus.Committed.

Note it is possible the RolledBack status is returned instead as an outcome of failure handling. If TransactionStatus::Pending is returned it means that failure handling has not been finalized yet and Revit awaits a user actions. Until committing is fully finalized, no changes to the document can be made (including starting of new transactions).

The returned status does not have to be necessarily the same as the status returned by GetStatus()()()() even when the method is called immediately after committing the transaction. Such a difference may happen due to actions made by a transaction finalizer, if there was one set. (See FailureHandlingOptions for more details.)

Remarks

By committing a transaction, all changes made to the model during the transaction are accepted. A new undo item will appear in the Undo menu in Revit, which allows the user to undo the changes. The undo item will have this transaction's name. Commit may only be called for a transaction that has been started. (Use the GetStatus()()()() method to check the current state.) Be aware that committing may fail or can be delayed (as a result of failure handling.) Callers should always check the returned status to test whether a transaction was committed successfully. Only after a transaction is successfully committed (or rolled back as a result of handling transaction failures), it may be started again.

Examples

CopyC#
public bool CreateLevel(Autodesk.Revit.DB.Document document, double elevation)
{
   // All and any transaction should be enclosed in a 'using'
   // block or guarded within a try-catch-finally blocks
   // to guarantee that a transaction does not out-live its scope.
   using (Transaction transaction = new Transaction(document, "Creating Level"))
    {
       // Must start a transaction to be able to modify a document

       if( TransactionStatus.Started == transaction.Start())
       {
          if (null != Level.Create(document, elevation))
          {
             // For many various reasons, a transaction may not be committed
             // if the changes made during the transaction do not result a valid model.
             // If committing a transaction fails or is canceled by the end user,
             // the resulting status would be RolledBack instead of Committed.
             return (TransactionStatus.Committed == transaction.Commit());
          }

          // For we were unable to create the level, we will roll the transaction back
          // (although on this simplified case we know there weren't any other changes)

          transaction.RollBack();
       }
    }
    return false;
}
CopyVB.NET
Public Function CreateLevel(document As Autodesk.Revit.DB.Document, elevation As Double) As Boolean
    ' All and any transaction should be enclosed in a 'using'
    ' block or guarded within a try-catch-finally blocks
    ' to guarantee that a transaction does not out-live its scope.
    Using transaction As New Transaction(document, "Creating Level")
        ' Must start a transaction to be able to modify a document

        If TransactionStatus.Started = transaction.Start() Then
       If Level.Create(document, elevation) IsNot Nothing Then
          ' For many various reasons, a transaction may not be committed
          ' if the changes made during the transaction do not result a valid model.
          ' If committing a transaction fails or is canceled by the end user,
          ' the resulting status would be RolledBack instead of Committed.
          Return (TransactionStatus.Committed = transaction.Commit())
       End If

            ' For we were unable to create the level, we will roll the transaction back
            ' (although on this simplified case we know there weren't any other changes)

            transaction.RollBack()
        End If
    End Using
    Return False
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The current status of the transaction is not 'Started'. Transaction must be started before calling Commit or Rollback. -or- The transaction's document is currently in failure mode. No transaction operations are permitted until failure handling is finished.

See Also

Transaction Class
Commit Overload


Commit Method (FailureHandlingOptions)

[image]

Revit 2024 API
Transaction..::..Commit Method (FailureHandlingOptions)
Transaction Class Example See Also Send Feedback
Commits all changes made to the model during the transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public TransactionStatus Commit(
    FailureHandlingOptions options
)
Visual Basic
Public Function Commit ( _
    options As FailureHandlingOptions _
) As TransactionStatus
Visual C++
public:
TransactionStatus Commit(
    FailureHandlingOptions^ options
)

Parameters

options
Type: Autodesk.Revit.DB..::..FailureHandlingOptions
A set of options to be used for handling eventual failures during this call.

The options are only used temporarily during the commitment process. After the transaction is finished, the options will be reset to their default values.

Return Value

If finished successfully, this method returns TransactionStatus.Committed

Note it is possible the RolledBack status is returned instead as an outcome of failure handling. If TransactionStatus.Pending is returned it means that failure handling has not been finalized yet and Revit awaits user's actions. Until committing is fully finalized, no changes to the document can be made (including starting of new transactions).

Be aware that the returned status does not have to be necessarily the same like the status returned by GetStatus()()()() even when the method is called immediately after committing the transaction. Such difference may happen due to actions made by a transaction finalizer, if there was one set. (See FailureHandlingOptions for more details.)

Examples

CopyC#
// All and any transaction should be enclosed in a 'using'
// block or guarded within a try-catch-finally blocks
// to guarantee that a transaction does not out-live its scope.
using (Transaction transaction = new Transaction(document))
{
   // Must start the transaction first to be able to modify a document
   transaction.Start("Creating Level");

   if (null != Level.Create(document, elevation))
   {
      // If we have a few transactions chained (for whatever reason)
      // we may wish to collect eventual warnings, if any, and show
      // them only when the last transaction of the chain is committed.
      FailureHandlingOptions options = transaction.GetFailureHandlingOptions();

      // Now, showing of any eventual mini-warnings will be
      // postponed until the following transaction.
      transaction.Commit(options.SetDelayedMiniWarnings(true));

      // Note, after a transaction is committed, the used failure options
      // are lost and replaced with default options again.
   }
}
CopyVB.NET
' All and any transaction should be enclosed in a 'using'
' block or guarded within a try-catch-finally blocks
' to guarantee that a transaction does not out-live its scope.
Using transaction As New Transaction(document)
    ' Must start the transaction first to be able to modify a document
    transaction.Start("Creating Level")

If Level.Create(document, elevation) IsNot Nothing Then
   ' If we have a few transactions chained (for whatever reason)
   ' we may wish to collect eventual warnings, if any, and show
   ' them only when the last transaction of the chain is committed.
   Dim options As FailureHandlingOptions = transaction.GetFailureHandlingOptions()

   ' Now, showing of any eventual mini-warnings will be
   ' postponed until the following transaction.

   ' Note, after a transaction is committed, the used failure options
   ' are lost and replaced with default options again.
   transaction.Commit(options.SetDelayedMiniWarnings(True))
End If
End Using

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The current status of the transaction is not 'Started'. Transaction must be started before calling Commit or Rollback. -or- The transaction's document is currently in failure mode. No transaction operations are permitted until failure handling is finished.

See Also

Transaction Class
Commit Overload


Dispose Method

[image]

Revit 2024 API
Transaction..::..Dispose Method
Transaction Class See Also Send Feedback
Releases all resources used by the Transaction

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

Transaction Class


HasEnded Method

[image]

Revit 2024 API
Transaction..::..HasEnded Method
Transaction Class See Also Send Feedback
Determines whether the transaction has ended already.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool HasEnded()
Visual Basic
Public Function HasEnded As Boolean
Visual C++
public:
bool HasEnded()

Return Value

True if the transaction has already been committed or rolled back, False otherwise.

Remarks

A transaction is ended by completing either the 'Commit' or 'RollBack' method. Another way of testing whether a transaction has ended is by testing the current status (see GetStatus()()()()). It must be either 'TransactionStatus.Committed' or 'TransactionStatus.RolledBack'

See Also

Transaction Class


HasStarted Method

[image]

Revit 2024 API
Transaction..::..HasStarted Method
Transaction Class See Also Send Feedback
Determines whether the transaction has been started yet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool HasStarted()
Visual Basic
Public Function HasStarted As Boolean
Visual C++
public:
bool HasStarted()

Return Value

True if the transaction has already started, False otherwise.

Remarks

A transaction is considered being started after a 'Start' method was called and until the transaction is either completely committed or rolled back.

HasStarted may return True even after 'Commit' or 'RollBack' was called if the method returned the TransactionStatus.Pending value.

A transaction can only be Started when HasStarted returns false.

See Also

Transaction Class


RollBack Method

[image] [image]

Revit 2024 API
Transaction..::..RollBack Method
Transaction Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RollBack()()()() | Rolls back all changes made to the model during the transaction.
Public method | RollBack(FailureHandlingOptions) | Rolls back all changes made to the model during the transaction.

See Also

Transaction Class
Transaction Members


RollBack Method

[image]

Revit 2024 API
Transaction..::..RollBack Method
Transaction Class Example See Also Send Feedback
Rolls back all changes made to the model during the transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public TransactionStatus RollBack()
Visual Basic
Public Function RollBack As TransactionStatus
Visual C++
public:
TransactionStatus RollBack()

Return Value

If finished successfully, this method returns TransactionStatus.RolledBack.

Be aware that the returned status does not have to be necessarily the same like the status returned by GetStatus()()()() even when the method is called immediately after rolling back the transaction. Such difference may happen due to actions made by a transaction finalizer, if there was one set. (See FailureHandlingOptions for more details.)

Remarks

By rolling back a transaction, all changes made to the model are discarded. RollBack may only be called for a transaction that has been started. (Use the GetStatus()()()() method to check the current state.) Be aware that rolling back may be delayed (as a result of failure handling.) Callers should always check the returned status to test whether a transaction was rolled back successfully. Only after rolling back is fully completed, the transaction may be started again.

Examples

CopyC#
public bool CreateGrid(Autodesk.Revit.DB.Document document, XYZ p1, XYZ p2)
{
   // All and any transaction should be enclosed in a 'using'
   // block or guarded within a try-catch-finally blocks
   // to guarantee that a transaction does not out-live its scope.
   using (Transaction transaction = new Transaction(document, "Creating Grid"))
   {
      // Must start a transaction to be able to modify a document
      if (TransactionStatus.Started == transaction.Start())
      {
         // We create a line and use it as an argument to create a grid
         Line gridLine = Line.CreateBound(p1, p2);

         if ((null != gridLine) && (null != Grid.Create(document, gridLine)))
         {
             if (TransactionStatus.Committed == transaction.Commit())
             {
                return true;
             }
         }

         // For we were unable to create the grid, we will roll the transaction back
         // (although on this simplified case we know there weren't any other changes)

         transaction.RollBack();
      }
   }
   return false;
}
CopyVB.NET
Public Function CreateGrid(document As Autodesk.Revit.DB.Document, p1 As XYZ, p2 As XYZ) As Boolean
    ' All and any transaction should be enclosed in a 'using'
    ' block or guarded within a try-catch-finally blocks
    ' to guarantee that a transaction does not out-live its scope.
    Using transaction As New Transaction(document, "Creating Grid")
        ' Must start a transaction to be able to modify a document
        If TransactionStatus.Started = transaction.Start() Then
            ' We create a line and use it as an argument to create a grid
            Dim gridLine As Line = Line.CreateBound(p1, p2)

       If (gridLine IsNot Nothing) AndAlso (Grid.Create(document, gridLine) IsNot Nothing) Then
          If TransactionStatus.Committed = transaction.Commit() Then
             Return True
          End If
       End If

            ' For we were unable to create the grid, we will roll the transaction back
            ' (although on this simplified case we know there weren't any other changes)

            transaction.RollBack()
        End If
    End Using
    Return False
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The current status of the transaction is not 'Started'. Transaction must be started before calling Commit or Rollback. -or- The transaction's document is currently in failure mode. No transaction operations are permitted until failure handling is finished.

See Also

Transaction Class
RollBack Overload


SetFailureHandlingOptions Method

[image]

Revit 2024 API
Transaction..::..SetFailureHandlingOptions Method
Transaction Class Example See Also Send Feedback
Sets options for handling failures to be used when the transaction is being committed or rolled back.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetFailureHandlingOptions(
    FailureHandlingOptions options
)
Visual Basic
Public Sub SetFailureHandlingOptions ( _
    options As FailureHandlingOptions _
)
Visual C++
public:
void SetFailureHandlingOptions(
    FailureHandlingOptions^ options
)

Parameters

options
Type: Autodesk.Revit.DB..::..FailureHandlingOptions
An instance of FailureHandlingOptions to be applied to the transaction

Remarks

Options can be set at any time before the transaction is either committed or rolled back. See FailureHandlingOptions for details about available options. Once committed or rolled back, the transaction object will reset its options to their default values.

Examples

CopyC#
// All and any transaction should be enclosed in a 'using'
// block or guarded within a try-catch-finally blocks
// to guarantee that a transaction does not out-live its scope.
using (Transaction transaction = new Transaction(doc))
{
   // Before we modify a document, we must start a transaction
   transaction.Start("Creating room");

   // obtain the current options and add failures preprocessor to it.
   // Note: preprocessor implements IFailuresProcessor and will receive
   // a notification about failures eventually posted during the transaction.
   FailureHandlingOptions options = transaction.GetFailureHandlingOptions();
   options.SetFailuresPreprocessor(new RoomWarningSwallower());
   transaction.SetFailureHandlingOptions(options);

   // Modify the document and commit the transaction.
   if (null != doc.Create.NewRoom(level, UV.Zero))
   {
      // Now, before the the transaction is committed, if there happened to
      // be any failure, the preprocessor would receive them first and would
      // have the option to analyze them, and ignore or re-qualify them.
      transaction.Commit();
   }
   else  // could not create the room; no need to commit the transaction
   {
      transaction.RollBack();
   }
}
CopyVB.NET
' All and any transaction should be enclosed in a 'using'
' block or guarded within a try-catch-finally blocks
' to guarantee that a transaction does not out-live its scope.
Using transaction As New Transaction(doc)
    ' Before we modify a document, we must start a transaction
    transaction.Start("Creating room")

    ' obtain the current options and add failures preprocessor to it.
    ' Note: preprocessor implements IFailuresProcessor and will receive
    ' a notification about failures eventually posted during the transaction.
    Dim options As FailureHandlingOptions = transaction.GetFailureHandlingOptions()
    options.SetFailuresPreprocessor(New RoomWarningSwallower())
    transaction.SetFailureHandlingOptions(options)

    ' Modify the document and commit the transaction.
    If doc.Create.NewRoom(level, UV.Zero) IsNot Nothing Then
        ' Now, before the the transaction is committed, if there happened to
        ' be any failure, the preprocessor would receive them first and would
        ' have the option to analyze them, and ignore or re-qualify them.
        transaction.Commit()
    Else
        ' could not create the room; no need to commit the transaction
        transaction.RollBack()
    End If
End Using

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Transaction Class


SetName Method

[image]

Revit 2024 API
Transaction..::..SetName Method
Transaction Class Example See Also Send Feedback
Sets the transaction's name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetName(
    string name
)
Visual Basic
Public Sub SetName ( _
    name As String _
)
Visual C++
public:
void SetName(
    String^ name
)

Parameters

name
Type: System..::..String
A name for the transaction.

Remarks

A transaction needs a name before it can be started, i.e. before one of the 'Start' method is invoked for this transaction object. The name will later appear in the Undo menu in Revit after a transaction is successfully committed.

Another ways of setting the name is either during construction or during the Start(String) method.

Examples

CopyC#
public bool ModelChangingMethod(Autodesk.Revit.DB.Document document)
{
    bool result = false;

    // All and any transaction should be enclosed in a 'using'
    // block or guarded within a try-catch-finally blocks
    // to guarantee that a transaction does not out-live its scope.
    using (Transaction transaction = new Transaction(document))
    {
        // We can either start a transaction with a name or give
        // it a name later, but we have to name it before we commit.
        transaction.Start();

        // Some modification(s) of the model here, likely resulting in
        // changes of the 'result' value
        // result = .....

        if (result == true)
        {
            // Since the transaction is still unnamed,
            // we have to give it a name now before we commit

            transaction.SetName("Model change");

            // Now we can commit
            if (TransactionStatus.Committed != transaction.Commit())
            {
                result = false;
            }
        }
        else  // if modifications failed, transaction is to be rolled back
        {
            transaction.RollBack();
        }
    }
    return result;
}
CopyVB.NET
Public Function ModelChangingMethod(document As Autodesk.Revit.DB.Document) As Boolean
    Dim result As Boolean = False

    ' All and any transaction should be enclosed in a 'using'
    ' block or guarded within a try-catch-finally blocks
    ' to guarantee that a transaction does not out-live its scope.
    Using transaction As New Transaction(document)
        ' We can either start a transaction with a name or give
        ' it a name later, but we have to name it before we commit.
        transaction.Start()

        ' Some modification(s) of the model here, likely resulting in
        ' changes of the 'result' value
        ' result = .....

        If result = True Then
            ' Since the transaction is still unnamed,
            ' we have to give it a name now before we commit

            transaction.SetName("Model change")

            ' Now we can commit
            If TransactionStatus.Committed <> transaction.Commit() Then
                result = False
            End If
        Else
            ' if modifications failed, transaction is to be rolled back
            transaction.RollBack()
        End If
    End Using
    Return result
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The name argument is an empty string.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Transaction Class


Start Method

[image] [image]

Revit 2024 API
Transaction..::..Start Method
Transaction Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Start()()()() | Starts the transaction.
Public method | Start(String) | Starts the transaction with an assigned name.

See Also

Transaction Class
Transaction Members


Start Method

[image]

Revit 2024 API
Transaction..::..Start Method
Transaction Class Example See Also Send Feedback
Starts the transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public TransactionStatus Start()
Visual Basic
Public Function Start As TransactionStatus
Visual C++
public:
TransactionStatus Start()

Return Value

If finished successfully, this method returns TransactionStatus.Started. Note that unless starting is successful, changes cannot be made to the document.

Remarks

A transaction may be started only after it was instantiated or after it was previously committed or rolled back. In order to start a transaction, it must have a name assigned. If the name was not specified when the transaction object was instantiated, it has to be set by calling the SetName(String) method.

Be aware that every time a transaction starts, Failure Handling Options will be reset to their default values. If a specific failure handling is required, programmers need to use SetFailureHandlingOptions(FailureHandlingOptions) before the transaction is committed or rolled back.

Examples

CopyC#
public void TransactionDuringElementCreation(UIApplication uiApplication, Level level)
{
    Autodesk.Revit.DB.Document document = uiApplication.ActiveUIDocument.Document;

    // Build a location line for the wall creation
    XYZ start = new XYZ(0, 0, 0);
    XYZ end = new XYZ(10, 10, 0);
    Autodesk.Revit.DB.Line geomLine = Line.CreateBound(start, end);

    // All and any transaction should be enclosed in a 'using'
    // block or guarded within a try-catch-finally blocks
    // to guarantee that a transaction does not out-live its scope.
    using (Transaction wallTransaction = new Transaction(document, "Creating wall"))
    {
       // To create a wall, a transaction must be first started
       if (wallTransaction.Start() == TransactionStatus.Started)
       {
           // Create a wall using the location line
           Wall wall = Wall.Create(document, geomLine, level.Id, true);

           // the transaction must be committed before you can
           // get the value of Geometry and AnalyticalModel.

           if (wallTransaction.Commit() == TransactionStatus.Committed)
           {
               Autodesk.Revit.DB.Options options = uiApplication.Application.Create.NewGeometryOptions();
               Autodesk.Revit.DB.GeometryElement geoelem = wall.get_Geometry(options);
           }
       }
    }
}
CopyVB.NET
Public Sub TransactionDuringElementCreation(uiApplication As UIApplication, level As Level)
    Dim document As Autodesk.Revit.DB.Document = uiApplication.ActiveUIDocument.Document

    ' Build a location line for the wall creation
    Dim start As New XYZ(0, 0, 0)
    Dim [end] As New XYZ(10, 10, 0)
    Dim geomLine As Autodesk.Revit.DB.Line = Line.CreateBound(start, [end])

    ' All and any transaction should be enclosed in a 'using'
    ' block or guarded within a try-catch-finally blocks
    ' to guarantee that a transaction does not out-live its scope.
    Using wallTransaction As New Transaction(document, "Creating wall")
        ' To create a wall, a transaction must be first started
        If wallTransaction.Start() = TransactionStatus.Started Then
            ' Create a wall using the location line
            Dim wall__1 As Wall = Wall.Create(document, geomLine, level.Id, True)

            ' the transaction must be committed before you can
            ' get the value of Geometry and AnalyticalModel.

            If wallTransaction.Commit() = TransactionStatus.Committed Then
                Dim options As Autodesk.Revit.DB.Options = uiApplication.Application.Create.NewGeometryOptions()
                Dim geoelem As Autodesk.Revit.DB.GeometryElement = wall__1.Geometry(options)
            End If
        End If
    End Using
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Cannot modify the document for either a read-only external command is being executed, or changes to the document are temporarily disabled. -or- The transaction's document is currently in failure mode. No transaction operations are permitted until failure handling is finished. -or- The transaction started already and has not been completed yet. -or- Starting a new transaction is not permitted. It could be because another transaction already started and has not been completed yet, or the document is in a state in which it cannot start a new transaction (e.g. during failure handling or a read-only mode, which could be either permanent or temporary). -or- The transaction does not have a valid name assigned yet.

See Also

Transaction Class
Start Overload


Start Method (String)

[image]

Revit 2024 API
Transaction..::..Start Method (String)
Transaction Class Example See Also Send Feedback
Starts the transaction with an assigned name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public TransactionStatus Start(
    string name
)
Visual Basic
Public Function Start ( _
    name As String _
) As TransactionStatus
Visual C++
public:
TransactionStatus Start(
    String^ name
)

Parameters

name
Type: System..::..String
Name of the transaction; If the transaction already has name, this new one will preplace it. The name will appear on the Undo menu in Revit if the transaction is successfully committed.

Return Value

If finished successfully, this method returns TransactionStatus.Started. Note that unless starting is successful, changes cannot be made to the document.

Remarks

A transaction may be started only after it was instantiated or after it was previously committed or rolled back.

Be aware that every time a transaction starts, Failure Handling Options will be reset to their default values. If a specific failure handling is required, programmers need to use SetFailureHandlingOptions(FailureHandlingOptions) before the transaction is committed or rolled back.

Examples

CopyC#
public bool TransactionBoundaries(Autodesk.Revit.DB.Document document)
{
    bool result = false;

    // All and any transaction should be enclosed in a 'using'
    // block or guarded within a try-catch-finally blocks
    // to guarantee that a transaction does not out-live its scope.
    using (Transaction transaction = new Transaction(document))
    {
       transaction.Start("Transaction name");

       // some modification of the document here, likely resulting in
       // changes of the 'result' value
       // .....

       if (result == true)
       {
          // Modifications ended successfully, but it is still possible
          // for the transaction to fail due to model regeneration
          // (and other internal processes that validate the model)
          if (TransactionStatus.Committed != transaction.Commit())
          {
             result = false;
          }
       }
       else  // if modifications failed, transaction is to be rolled back
       {
          transaction.RollBack();
       }
    }
    return result;
}
CopyVB.NET
Public Function TransactionBoundaries(document As Autodesk.Revit.DB.Document) As Boolean
    Dim result As Boolean = False

    ' All and any transaction should be enclosed in a 'using'
    ' block or guarded within a try-catch-finally blocks
    ' to guarantee that a transaction does not out-live its scope.
    Using transaction As New Transaction(document)
        transaction.Start("Transaction name")

        ' some modification of the document here, likely resulting in
        ' changes of the 'result' value
        ' .....

        If result = True Then
            ' Modifications ended successfully, but it is still possible
            ' for the transaction to fail due to model regeneration
            ' (and other internal processes that validate the model)
            If TransactionStatus.Committed <> transaction.Commit() Then
                result = False
            End If
        Else
            ' if modifications failed, transaction is to be rolled back
            transaction.RollBack()
        End If
    End Using
    Return result
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The name argument is an empty string.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | Cannot modify the document for either a read-only external command is being executed, or changes to the document are temporarily disabled. -or- The transaction's document is currently in failure mode. No transaction operations are permitted until failure handling is finished. -or- The transaction started already and has not been completed yet. -or- Starting a new transaction is not permitted. It could be because another transaction already started and has not been completed yet, or the document is in a state in which it cannot start a new transaction (e.g. during failure handling or a read-only mode, which could be either permanent or temporary).

See Also

Transaction Class
Start Overload


Transaction Properties

[image] [image]

Revit 2024 API
Transaction Properties
Transaction Class See Also Send Feedback

The Transaction type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

Transaction Class


IsValidObject Property

[image]

Revit 2024 API
Transaction..::..IsValidObject Property
Transaction Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

Transaction Class


TransactionGroup Constructor

[image] [image]

Revit 2024 API
TransactionGroup Constructor
TransactionGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TransactionGroup(Document) | Constructs a transaction group object.
Public method | TransactionGroup(Document, String) | It constructs a transaction group object

See Also

TransactionGroup Class
TransactionGroup Members


TransactionGroup Constructor (Document)

[image]

Revit 2024 API
TransactionGroup Constructor (Document)
TransactionGroup Class See Also Send Feedback
Constructs a transaction group object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public TransactionGroup(
    Document document
)
Visual Basic
Public Sub New ( _
    document As Document _
)
Visual C++
public:
TransactionGroup(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document for which this transaction group is being used.

Remarks

The group does not start until its Start method is called.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

TransactionGroup Class
TransactionGroup Overload


TransactionGroup Constructor (Document, String)

[image]

Revit 2024 API
TransactionGroup Constructor (Document, String)
TransactionGroup Class See Also Send Feedback
It constructs a transaction group object

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public TransactionGroup(
    Document document,
    string transGroupName
)
Visual Basic
Public Sub New ( _
    document As Document, _
    transGroupName As String _
)
Visual C++
public:
TransactionGroup(
    Document^ document,
    String^ transGroupName
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document for which this transaction group is being used.
transGroupName
Type: System..::..String
Name of the group. The name will be used only for a group that is assimilated at the end.

Remarks

The group does not start until its Start method is called.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

TransactionGroup Class
TransactionGroup Overload


TransactionGroup Methods

[image] [image]

Revit 2024 API
TransactionGroup Methods
TransactionGroup Class See Also Send Feedback

The TransactionGroup type exposes the following members.

Methods

 | Name | Description
Public method | Assimilate | Assimilates all inner transactions by merging them into a single undo item.
Public method | Commit | Commits the transaction group.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetName | Returns the transaction group's name. It could be an empty string.
Public method | GetStatus | Gets the current status of the transaction group.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasEnded | Determines whether the transaction group has ended already.
Public method | HasStarted | Determines whether the transaction has been started yet.
Public method | RollBack | Rolls back the transaction group, which effectively undoes all transactions committed inside the group.
Public method | SetName | Sets the transaction group's name.
Public method | Start()()()() | Starts the transaction group
Public method | Start(String) | Starts the transaction group with an assigned name.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TransactionGroup Class


Assimilate Method

[image]

Revit 2024 API
TransactionGroup..::..Assimilate Method
TransactionGroup Class Example See Also Send Feedback
Assimilates all inner transactions by merging them into a single undo item.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public TransactionStatus Assimilate()
Visual Basic
Public Function Assimilate As TransactionStatus
Visual C++
public:
TransactionStatus Assimilate()

Return Value

If finished successfully, this method returns TransactionStatus.Committed.

Remarks

After a successful assimilation the transaction group is committed.

All transactions committed inside this group will be merged into one single transaction. The resulting undo item will bear this group's name.

Assimilate can be called only when all inner transaction groups and transactions are finished, i.e. after they were either committed or rolled back.

Examples

CopyC#
public void CompoundOperation(Autodesk.Revit.DB.Document document)
{
   // All and any transaction group should be enclosed in a 'using' block or guarded within
   // a try-catch-finally blocks to guarantee that the group does not out-live its scope.
   using (TransactionGroup transGroup = new TransactionGroup(document, "Level and Grid"))
    {
       if (transGroup.Start() == TransactionStatus.Started)
       {
          // We are going to call two methods, each having its own local transaction.
          // For our compound operation to be considered successful, both the individual
          // transactions must succeed. If either one fails, we will roll our group back,
          // regardless of what transactions might have already been committed.

          if (CreateLevel(document, 25.0) && CreateGrid(document, new XYZ(0,0,0), new XYZ(10,0,0)))
          {
             // The process of assimilating will merge the two (or any number of) committed
             // transaction together and will assign the grid's name to the one resulting transaction,
             // which will become the only item from this compound operation appearing in the undo menu.
             transGroup.Assimilate();
          }
          else
          {
             // Since we could not successfully finish at least one of the individual
             // operation, we are going to roll the entire group back, which will
             // undo any transaction already committed while this group was open.
             transGroup.RollBack();
          }
       }
    }
}
CopyVB.NET
Public Sub CompoundOperation(document As Autodesk.Revit.DB.Document)
    ' All and any transaction group should be enclosed in a 'using' block or guarded within
    ' a try-catch-finally blocks to guarantee that the group does not out-live its scope.
    Using transGroup As New TransactionGroup(document, "Level and Grid")
        If transGroup.Start() = TransactionStatus.Started Then
            ' We are going to call two methods, each having its own local transaction.
            ' For our compound operation to be considered successful, both the individual
            ' transactions must succeed. If either one fails, we will roll our group back,
            ' regardless of what transactions might have already been committed.

            If CreateLevel(document, 25.0) AndAlso CreateGrid(document, New XYZ(0, 0, 0), New XYZ(10, 0, 0)) Then
                ' The process of assimilating will merge the two (or any number of) committed
                ' transaction together and will assign the grid's name to the one resulting transaction,
                ' which will become the only item from this compound operation appearing in the undo menu.
                transGroup.Assimilate()
            Else
                ' Since we could not successfully finish at least one of the individual
                ' operation, we are going to roll the entire group back, which will
                ' undo any transaction already committed while this group was open.
                transGroup.RollBack()
            End If
        End If
    End Using
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The Transaction group has not been started (its status is not 'Started').. -or- The transaction's document is currently in failure mode. Transaction groups cannot be closed until failure handling is finished. You may use a transaction finalizer to close a group after the failure handling ends.

See Also

TransactionGroup Class


Commit Method

[image]

Revit 2024 API
TransactionGroup..::..Commit Method
TransactionGroup Class Example See Also Send Feedback
Commits the transaction group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public TransactionStatus Commit()
Visual Basic
Public Function Commit As TransactionStatus
Visual C++
public:
TransactionStatus Commit()

Return Value

If finished successfully, this method returns TransactionStatus.Committed.

Remarks

Committing a group does not change the model. It only confirms the commitment of all inner groups and transactions.

Commit can be called only when all inner transaction groups and transactions are finished, i.e. after they were either committed or rolled back. If there is still a transaction or an inner transaction group open, an attempt to commit this outer group will cause an exception.

Examples

CopyC#
public void GroupedOperations(Autodesk.Revit.DB.Document document)
{
   // All and any transaction group should be enclosed in a 'using' block or guarded within
   // a try-catch-finally blocks to guarantee that the group does not out-live its scope.
   using (TransactionGroup transGroup = new TransactionGroup(document, "Level and Grid"))
   {
      if (transGroup.Start() == TransactionStatus.Started)
      {
         // We are going to call two methods, each having its own local transaction.
         // For our compound operation to be considered successful, both the individual
         // transactions must succeed. If either one fails, we will roll our group back,
         // regardless of what transactions might have already been committed.

         if (CreateLevel(document, 35.0) && CreateGrid(document, new XYZ(0, 0, 0), new XYZ(0, 10, 0)))
         {
            // The process of committing of a group does not do anything to the already committed
            // transactions. They will stay available on the undo menu and may still be undone
            // individually. If it is not desirable if one transaction from a multi-transaction
            // operation can be undone by th end user, then the transaction group must be
            // assimilated instead of committed. See TransactionGroup.Assimilate for details.
            transGroup.Commit();
         }
         else
         {
            // Since we could not successfully finish at least one of the individual
            // operation, we are going to roll the entire group back, which will
            // undo any transaction already committed while this group was open.
            transGroup.RollBack();
         }
      }
   }
}
CopyVB.NET
Public Sub GroupedOperations(document As Autodesk.Revit.DB.Document)
    ' All and any transaction group should be enclosed in a 'using' block or guarded within
    ' a try-catch-finally blocks to guarantee that the group does not out-live its scope.
    Using transGroup As New TransactionGroup(document, "Level and Grid")
        If transGroup.Start() = TransactionStatus.Started Then
            ' We are going to call two methods, each having its own local transaction.
            ' For our compound operation to be considered successful, both the individual
            ' transactions must succeed. If either one fails, we will roll our group back,
            ' regardless of what transactions might have already been committed.

            If CreateLevel(document, 35.0) AndAlso CreateGrid(document, New XYZ(0, 0, 0), New XYZ(0, 10, 0)) Then
                ' The process of committing of a group does not do anything to the already committed
                ' transactions. They will stay available on the undo menu and may still be undone
                ' individually. If it is not desirable if one transaction from a multi-transaction
                ' operation can be undone by th end user, then the transaction group must be
                ' assimilated instead of committed. See TransactionGroup.Assimilate for details.
                transGroup.Commit()
            Else
                ' Since we could not successfully finish at least one of the individual
                ' operation, we are going to roll the entire group back, which will
                ' undo any transaction already committed while this group was open.
                transGroup.RollBack()
            End If
        End If
    End Using
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The Transaction group has not been started (its status is not 'Started').. -or- The transaction's document is currently in failure mode. Transaction groups cannot be closed until failure handling is finished. You may use a transaction finalizer to close a group after the failure handling ends.

See Also

TransactionGroup Class


GetName Method

[image]

Revit 2024 API
TransactionGroup..::..GetName Method
TransactionGroup Class See Also Send Feedback
Returns the transaction group's name. It could be an empty string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public string GetName()
Visual Basic
Public Function GetName As String
Visual C++
public:
String^ GetName()

Return Value

The transaction group's current name.

See Also

TransactionGroup Class


GetStatus Method

[image]

Revit 2024 API
TransactionGroup..::..GetStatus Method
TransactionGroup Class See Also Send Feedback
Gets the current status of the transaction group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public TransactionStatus GetStatus()
Visual Basic
Public Function GetStatus As TransactionStatus
Visual C++
public:
TransactionStatus GetStatus()

Return Value

The current status of the transaction group.

See Also

TransactionGroup Class


HasStarted Method

[image]

Revit 2024 API
TransactionGroup..::..HasStarted Method
TransactionGroup Class See Also Send Feedback
Determines whether the transaction has been started yet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool HasStarted()
Visual Basic
Public Function HasStarted As Boolean
Visual C++
public:
bool HasStarted()

Return Value

True if the transaction group has already started, False otherwise.

Remarks

A transaction group is considered being started after the Start method was called and until the transaction group is either completely committed or rolled back. A transaction group can only be Started when HasStarted returns false.

See Also

TransactionGroup Class


RollBack Method

[image]

Revit 2024 API
TransactionGroup..::..RollBack Method
TransactionGroup Class See Also Send Feedback
Rolls back the transaction group, which effectively undoes all transactions committed inside the group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public TransactionStatus RollBack()
Visual Basic
Public Function RollBack As TransactionStatus
Visual C++
public:
TransactionStatus RollBack()

Return Value

If finished successfully, this method returns TransactionStatus.RolledBack.

Remarks

Note that once a group is rolled back, the undone transactions cannot be redone.

RollBack can be called only when all inner transaction groups and transactions are finished, i.e. after they were either committed or rolled back.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The Transaction group has not been started (its status is not 'Started').. -or- The transaction's document is currently in failure mode. Transaction groups cannot be closed until failure handling is finished. You may use a transaction finalizer to close a group after the failure handling ends.

See Also

TransactionGroup Class


SetName Method

[image]

Revit 2024 API
TransactionGroup..::..SetName Method
TransactionGroup Class See Also Send Feedback
Sets the transaction group's name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public void SetName(
    string name
)
Visual Basic
Public Sub SetName ( _
    name As String _
)
Visual C++
public:
void SetName(
    String^ name
)

Parameters

name
Type: System..::..String
A name for the transaction group.

Remarks

Transaction group only needs a name if it is going to be assimilated at the end.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

TransactionGroup Class


Start Method (String)

[image]

Revit 2024 API
TransactionGroup..::..Start Method (String)
TransactionGroup Class See Also Send Feedback
Starts the transaction group with an assigned name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public TransactionStatus Start(
    string transGroupName
)
Visual Basic
Public Function Start ( _
    transGroupName As String _
) As TransactionStatus
Visual C++
public:
TransactionStatus Start(
    String^ transGroupName
)

Parameters

transGroupName
Type: System..::..String
Name of the group. The name will be used only for a group that is assimilated at the end.

Return Value

If started successfully, this method returns TransactionStatus.Started.

Remarks

A transaction group can be started only when there is no transaction started currently. It can be started inside another transaction group though. With such group nesting it is required that inner transaction groups are finished (i.e. rolled back, committed, or assimilated) before outer groups are.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | Cannot modify the document for either a read-only external command is being executed, or changes to the document are temporarily disabled. -or- Transaction group cannot be started during an active transaction. -or- The Transaction group has already been started.

See Also

TransactionGroup Class
Start Overload


TransactionGroup Properties

[image] [image]

Revit 2024 API
TransactionGroup Properties
TransactionGroup Class See Also Send Feedback

The TransactionGroup type exposes the following members.

Properties

 | Name | Description
Public property | IsFailureHandlingForcedModal | Forces all transactions finished inside this group to use modal failure handling regardless of what failure handling options are set for those transactions.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

TransactionGroup Class


IsFailureHandlingForcedModal Property

[image]

Revit 2024 API
TransactionGroup..::..IsFailureHandlingForcedModal Property
TransactionGroup Class See Also Send Feedback
Forces all transactions finished inside this group to use modal failure handling regardless of what failure handling options are set for those transactions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool IsFailureHandlingForcedModal { get; set; }
Visual Basic
Public Property IsFailureHandlingForcedModal As Boolean
    Get
    Set
Visual C++
public:
property bool IsFailureHandlingForcedModal {
    bool get ();
    void set (bool value);
}

Remarks

This property is ignored during events, when failure handling is always modal.

See Also

TransactionGroup Class


IsValidObject Property

[image]

Revit 2024 API
TransactionGroup..::..IsValidObject Property
TransactionGroup Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

TransactionGroup Class


TransactionStatus Enumeration

[image]

Revit 2024 API
TransactionStatus Enumeration
See Also Send Feedback
An enumerated type listing the possible statuses associated with a Transaction, TransactionGroup, or SubTransaction, or the result of a particular method call on one of those objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public enum TransactionStatus
Visual Basic
Public Enumeration TransactionStatus
Visual C++
public enum class TransactionStatus

Members

Member name | Description
Uninitialized | initial value, the transaction has not been started yet in this status
Started | transaction has begun (until committed or rolled back)
RolledBack | rolled back (aborted)
Committed | simply committed, ended an empty transaction, flushed all, or undo is disabled
Pending | returned from error handling that took over managing the transaction
Error | error while committing or rolling back
Proceed | while still in error handling (internal status)

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


TransactWithCentralOptions Members

[image] [image]

Revit 2024 API
TransactWithCentralOptions Members
TransactWithCentralOptions Class Constructors Methods Properties See Also Send Feedback

The TransactWithCentralOptions type exposes the following members.

Constructors

 | Name | Description
Public method | TransactWithCentralOptions | Constructs a new TransactWithCentralOptions.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the TransactWithCentralOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLockCallback | Gets the callback object that changes Revit's default behavior of endlessly waiting and repeatedly trying to lock a central model.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetLockCallback | Sets or resets a callback object that would allow an external application to change Revit's default behavior of endlessly waiting and repeatedly trying to lock a central model.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

TransactWithCentralOptions Class


TransactWithCentralOptions Constructor

[image]

Revit 2024 API
TransactWithCentralOptions Constructor
TransactWithCentralOptions Class See Also Send Feedback
Constructs a new TransactWithCentralOptions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public TransactWithCentralOptions()
Visual Basic
Public Sub New
Visual C++
public:
TransactWithCentralOptions()

See Also

TransactWithCentralOptions Class


TransactWithCentralOptions Methods

[image] [image]

Revit 2024 API
TransactWithCentralOptions Methods
TransactWithCentralOptions Class See Also Send Feedback

The TransactWithCentralOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLockCallback | Gets the callback object that changes Revit's default behavior of endlessly waiting and repeatedly trying to lock a central model.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetLockCallback | Sets or resets a callback object that would allow an external application to change Revit's default behavior of endlessly waiting and repeatedly trying to lock a central model.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TransactWithCentralOptions Class


Dispose Method

[image]

Revit 2024 API
TransactWithCentralOptions..::..Dispose Method
TransactWithCentralOptions Class See Also Send Feedback
Releases all resources used by the TransactWithCentralOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

TransactWithCentralOptions Class


GetLockCallback Method

[image]

Revit 2024 API
TransactWithCentralOptions..::..GetLockCallback Method
TransactWithCentralOptions Class See Also Send Feedback
Gets the callback object that changes Revit's default behavior of endlessly waiting and repeatedly trying to lock a central model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ICentralLockedCallback GetLockCallback()
Visual Basic
Public Function GetLockCallback As ICentralLockedCallback
Visual C++
public:
ICentralLockedCallback^ GetLockCallback()

See Also

TransactWithCentralOptions Class


SetLockCallback Method

[image]

Revit 2024 API
TransactWithCentralOptions..::..SetLockCallback Method
TransactWithCentralOptions Class See Also Send Feedback
Sets or resets a callback object that would allow an external application to change Revit's default behavior of endlessly waiting and repeatedly trying to lock a central model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void SetLockCallback(
    ICentralLockedCallback lockCallback
)
Visual Basic
Public Sub SetLockCallback ( _
    lockCallback As ICentralLockedCallback _
)
Visual C++
public:
void SetLockCallback(
    ICentralLockedCallback^ lockCallback
)

Parameters

lockCallback
Type: Autodesk.Revit.DB..::..ICentralLockedCallback

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

TransactWithCentralOptions Class


IsValidObject Property

[image]

Revit 2024 API
TransactWithCentralOptions..::..IsValidObject Property
TransactWithCentralOptions Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

TransactWithCentralOptions Class


Transform Class

[image]

Revit 2024 API
Transform Class
Members Example See Also Send Feedback
A transformation of the affine 3-space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class Transform : APIObject
Visual Basic
Public Class Transform _
    Inherits APIObject
Visual C++
public ref class Transform : public APIObject

Examples

CopyC#
public static XYZ TransformPoint(XYZ point, Transform transform)
{
    double x = point.X;
    double y = point.Y;
    double z = point.Z;

    //transform basis of the old coordinate system in the new coordinate // system
    XYZ b0 = transform.get_Basis(0);
    XYZ b1 = transform.get_Basis(1);
    XYZ b2 = transform.get_Basis(2);
    XYZ origin = transform.Origin;

    //transform the origin of the old coordinate system in the new
    //coordinate system
    double xTemp = x * b0.X + y * b1.X + z * b2.X + origin.X;
    double yTemp = x * b0.Y + y * b1.Y + z * b2.Y + origin.Y;
    double zTemp = x * b0.Z + y * b1.Z + z * b2.Z + origin.Z;

    return new XYZ(xTemp, yTemp, zTemp);
}
CopyVB.NET
Public Shared Function TransformPoint(point As XYZ, transform As Transform) As XYZ
    Dim x As Double = point.X
    Dim y As Double = point.Y
    Dim z As Double = point.Z

    'transform basis of the old coordinate system in the new coordinate // system
    Dim b0 As XYZ = transform.Basis(0)
    Dim b1 As XYZ = transform.Basis(1)
    Dim b2 As XYZ = transform.Basis(2)
    Dim origin As XYZ = transform.Origin

    'transform the origin of the old coordinate system in the new
    'coordinate system
    Dim xTemp As Double = x * b0.X + y * b1.X + z * b2.X + origin.X
    Dim yTemp As Double = x * b0.Y + y * b1.Y + z * b2.Y + origin.Y
    Dim zTemp As Double = x * b0.Z + y * b1.Z + z * b2.Z + origin.Z

    Return New XYZ(xTemp, yTemp, zTemp)
End Function

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..Transform

See Also

Transform Members


Transform Members

[image] [image]

Revit 2024 API
Transform Members
Transform Class Constructors Methods Operators Properties See Also Send Feedback

The Transform type exposes the following members.

Constructors

 | Name | Description
Public method | Transform | The copy constructor.

Methods

 | Name | Description
Public method | AlmostEqual | Determines whether this transformation and the specified transformation are the same within the tolerance (1.0e-09).
 | CreateReflection | Creates a transform that represents a reflection across the given plane.
 | CreateRotation | Creates a transform that represents a rotation about the given axis at (0, 0, 0).
 | CreateRotationAtPoint | Creates a transform that represents a rotation about the given axis at the specified point.
 | CreateTranslation | Creates a transform that represents a translation via the specified vector.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Multiply | Multiplies this transformation by the specified transformation and returns the result.
Public method | OfPoint | Applies the transformation to the point and returns the result.
Public method | OfVector | Applies the transform to the vector
Public method | ScaleBasis | Scales the basis vectors of this transformation and returns the result.
Public method | ScaleBasisAndOrigin | Scales the basis vectors and the origin of this transformation and returns the result.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Operators

Name | Description
Multiply | Multiplies the two specified transforms.

Properties

 | Name | Description
Public property | Basis | Defines the basis of the old coordinate system in the new coordinate system.
Public property | BasisX | The basis of the X axis of this transformation.
Public property | BasisY | The basis of the Y axis of this transformation.
Public property | BasisZ | The basis of the Z axis of this transformation.
Public property | Determinant | The determinant of this transformation.
Public property | HasReflection | The boolean value that indicates whether this transformation produces reflection.
 | Identity | The identity transformation.
Public property | Inverse | The inverse transformation of this transformation.
Public property | IsConformal | The boolean value that indicates whether this transformation is conformal.
Public property | IsIdentity | The boolean value that indicates whether this transformation is an identity.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsTranslation | The boolean value that indicates whether this transformation is a translation.
Public property | Origin | Defines the origin of the old coordinate system in the new coordinate system.
Public property | Scale | The real number that represents the scale of the transformation.

See Also

Transform Class


Transform Constructor

[image]

Revit 2024 API
Transform Constructor
Transform Class See Also Send Feedback
The copy constructor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Transform(
    Transform source
)
Visual Basic
Public Sub New ( _
    source As Transform _
)
Visual C++
public:
Transform(
    Transform^ source
)

Parameters

source
Type: Autodesk.Revit.DB..::..Transform

See Also

Transform Class


Transform Methods

[image] [image]

Revit 2024 API
Transform Methods
Transform Class See Also Send Feedback

The Transform type exposes the following members.

Methods

 | Name | Description
Public method | AlmostEqual | Determines whether this transformation and the specified transformation are the same within the tolerance (1.0e-09).
 | CreateReflection | Creates a transform that represents a reflection across the given plane.
 | CreateRotation | Creates a transform that represents a rotation about the given axis at (0, 0, 0).
 | CreateRotationAtPoint | Creates a transform that represents a rotation about the given axis at the specified point.
 | CreateTranslation | Creates a transform that represents a translation via the specified vector.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Multiply | Multiplies this transformation by the specified transformation and returns the result.
Public method | OfPoint | Applies the transformation to the point and returns the result.
Public method | OfVector | Applies the transform to the vector
Public method | ScaleBasis | Scales the basis vectors of this transformation and returns the result.
Public method | ScaleBasisAndOrigin | Scales the basis vectors and the origin of this transformation and returns the result.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Transform Class


AlmostEqual Method

[image]

Revit 2024 API
Transform..::..AlmostEqual Method
Transform Class See Also Send Feedback
Determines whether this transformation and the specified transformation are the same within the tolerance (1.0e-09).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool AlmostEqual(
    Transform right
)
Visual Basic
Public Function AlmostEqual ( _
    right As Transform _
) As Boolean
Visual C++
public:
bool AlmostEqual(
    Transform^ right
)

Parameters

right
Type: Autodesk.Revit.DB..::..Transform
The transformation to compare with this transformation.

Return Value

True if the two transformations are equal; otherwise, false.

Remarks

The tolerance is applied memberwise for comparison.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the specified transformation is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Transform Class


CreateReflection Method

[image]

Revit 2024 API
Transform..::..CreateReflection Method
Transform Class Example See Also Send Feedback
Creates a transform that represents a reflection across the given plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static Transform CreateReflection(
    Plane plane
)
Visual Basic
Public Shared Function CreateReflection ( _
    plane As Plane _
) As Transform
Visual C++
public:
static Transform^ CreateReflection(
    Plane^ plane
)

Parameters

plane
Type: Autodesk.Revit.DB..::..Plane
The plane.

Return Value

The new transform.

Examples

CopyC#
private Transform Reflect(ReferencePlane refPlane)
{
    Transform mirTrans = Transform.CreateReflection(refPlane.GetPlane());

    return mirTrans;
}
CopyVB.NET
Private Function Reflect(refPlane As ReferencePlane) As Transform
    Dim mirTrans As Transform = Transform.CreateReflection(refPlane.GetPlane())

    Return mirTrans
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Transform Class


CreateRotation Method

[image]

Revit 2024 API
Transform..::..CreateRotation Method
Transform Class See Also Send Feedback
Creates a transform that represents a rotation about the given axis at (0, 0, 0).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static Transform CreateRotation(
    XYZ axis,
    double angle
)
Visual Basic
Public Shared Function CreateRotation ( _
    axis As XYZ, _
    angle As Double _
) As Transform
Visual C++
public:
static Transform^ CreateRotation(
    XYZ^ axis,
    double angle
)

Parameters

axis
Type: Autodesk.Revit.DB..::..XYZ
The rotation axis.
angle
Type: System..::..Double
The angle.

Return Value

The new transform.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for angle is not finite
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | axis has zero length.

See Also

Transform Class


CreateRotationAtPoint Method

[image]

Revit 2024 API
Transform..::..CreateRotationAtPoint Method
Transform Class See Also Send Feedback
Creates a transform that represents a rotation about the given axis at the specified point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static Transform CreateRotationAtPoint(
    XYZ axis,
    double angle,
    XYZ origin
)
Visual Basic
Public Shared Function CreateRotationAtPoint ( _
    axis As XYZ, _
    angle As Double, _
    origin As XYZ _
) As Transform
Visual C++
public:
static Transform^ CreateRotationAtPoint(
    XYZ^ axis,
    double angle,
    XYZ^ origin
)

Parameters

axis
Type: Autodesk.Revit.DB..::..XYZ
The rotation axis.
angle
Type: System..::..Double
The angle.
origin
Type: Autodesk.Revit.DB..::..XYZ
The origin point.

Return Value

The new transform.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for angle is not finite
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | axis has zero length.

See Also

Transform Class


CreateTranslation Method

[image]

Revit 2024 API
Transform..::..CreateTranslation Method
Transform Class See Also Send Feedback
Creates a transform that represents a translation via the specified vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static Transform CreateTranslation(
    XYZ vector
)
Visual Basic
Public Shared Function CreateTranslation ( _
    vector As XYZ _
) As Transform
Visual C++
public:
static Transform^ CreateTranslation(
    XYZ^ vector
)

Parameters

vector
Type: Autodesk.Revit.DB..::..XYZ
The translation vector.

Return Value

The new transform.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Transform Class


OfPoint Method

[image]

Revit 2024 API
Transform..::..OfPoint Method
Transform Class See Also Send Feedback
Applies the transformation to the point and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ OfPoint(
    XYZ point
)
Visual Basic
Public Function OfPoint ( _
    point As XYZ _
) As XYZ
Visual C++
public:
XYZ^ OfPoint(
    XYZ^ point
)

Parameters

point
Type: Autodesk.Revit.DB..::..XYZ
The point to transform.

Return Value

The transformed point.

Remarks

Transformation of a point is affected by the translational part of the transformation.

See Also

Transform Class


OfVector Method

[image]

Revit 2024 API
Transform..::..OfVector Method
Transform Class See Also Send Feedback
Applies the transform to the vector

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ OfVector(
    XYZ vec
)
Visual Basic
Public Function OfVector ( _
    vec As XYZ _
) As XYZ
Visual C++
public:
XYZ^ OfVector(
    XYZ^ vec
)

Parameters

vec
Type: Autodesk.Revit.DB..::..XYZ
The vector to be transformed

Return Value

The new vector after transform

Remarks

Transformation of a vector is not affected by the translational part of the transformation.

See Also

Transform Class


ScaleBasis Method

[image]

Revit 2024 API
Transform..::..ScaleBasis Method
Transform Class See Also Send Feedback
Scales the basis vectors of this transformation and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Transform ScaleBasis(
    double scale
)
Visual Basic
Public Function ScaleBasis ( _
    scale As Double _
) As Transform
Visual C++
public:
Transform^ ScaleBasis(
    double scale
)

Parameters

scale
Type: System..::..Double
The scale value.

Return Value

The transformation equal to the composition of the two transformations.

Remarks

The resulting transformation is equivalent to the application of the uniform scale and then this transformation, in this order.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the specified value is an infinite number.

See Also

Transform Class


ScaleBasisAndOrigin Method

[image]

Revit 2024 API
Transform..::..ScaleBasisAndOrigin Method
Transform Class See Also Send Feedback
Scales the basis vectors and the origin of this transformation and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Transform ScaleBasisAndOrigin(
    double scale
)
Visual Basic
Public Function ScaleBasisAndOrigin ( _
    scale As Double _
) As Transform
Visual C++
public:
Transform^ ScaleBasisAndOrigin(
    double scale
)

Parameters

scale
Type: System..::..Double
The scale value.

Return Value

The transformation equal to the composition of the two transformations.

Remarks

The resulting transformation is equivalent to the application of this transformation and then the uniform scale, in this order.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the specified value is an infinite number.

See Also

Transform Class


Transform Operators

[image] [image]

Revit 2024 API
Transform Operators
Transform Class See Also Send Feedback

The Transform type exposes the following members.

Operators

Name | Description
Multiply | Multiplies the two specified transforms.

See Also

Transform Class


Basis Property

[image]

Revit 2024 API
Transform..::..Basis Property
Transform Class See Also Send Feedback
Defines the basis of the old coordinate system in the new coordinate system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ this[
    int idx
] { get; set; }
Visual Basic
Public Property Basis ( _
    idx As Integer _
) As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ Basis[int idx] {
    XYZ^ get (int idx);
    void set (int idx, XYZ^ value);
}

Parameters

idx
Type: System..::..Int32
The index of the basis vector: 0, 1 or 2.

Remarks

This corresponds to the first three column vectors of the conventional 3x4 matrix representation.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the given index is larger than 2 in the getter and setter.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the transform is internally marked as read-only.

See Also

Transform Class


BasisX Property

[image]

Revit 2024 API
Transform..::..BasisX Property
Transform Class See Also Send Feedback
The basis of the X axis of this transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ BasisX { get; set; }
Visual Basic
Public Property BasisX As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ BasisX {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

The X axis of the old coordinate system in the new coordinate system, or the 1st column of the conventional 3x4 matrix representation.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the transform is internally marked as read-only.

See Also

Transform Class


Determinant Property

[image]

Revit 2024 API
Transform..::..Determinant Property
Transform Class See Also Send Feedback
The determinant of this transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double Determinant { get; }
Visual Basic
Public ReadOnly Property Determinant As Double
    Get
Visual C++
public:
property double Determinant {
    double get ();
}

Remarks

The geometric meaning of a determinant is as the scale factor for volume when applied as linear transformation.

See Also

Transform Class


Identity Property

[image]

Revit 2024 API
Transform..::..Identity Property
Transform Class See Also Send Feedback
The identity transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static Transform Identity { get; }
Visual Basic
Public Shared ReadOnly Property Identity As Transform
    Get
Visual C++
public:
static property Transform^ Identity {
    Transform^ get ();
}

Remarks

The identity transformation does not change a point or a vector that it is applied to.

See Also

Transform Class


Inverse Property

[image]

Revit 2024 API
Transform..::..Inverse Property
Transform Class See Also Send Feedback
The inverse transformation of this transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Transform Inverse { get; }
Visual Basic
Public ReadOnly Property Inverse As Transform
    Get
Visual C++
public:
property Transform^ Inverse {
    Transform^ get ();
}

Remarks

The transformation matrix A is invertible if there exists a transformation matrix B such that A*B = B*A = I (identity).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when this transformation is not conformal or invertible.

See Also

Transform Class


IsIdentity Property

[image]

Revit 2024 API
Transform..::..IsIdentity Property
Transform Class See Also Send Feedback
The boolean value that indicates whether this transformation is an identity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsIdentity { get; }
Visual Basic
Public ReadOnly Property IsIdentity As Boolean
    Get
Visual C++
public:
property bool IsIdentity {
    bool get ();
}

Remarks

The identity transformation does not change a point or a vector that it is applied to.

See Also

Transform Class


Origin Property

[image]

Revit 2024 API
Transform..::..Origin Property
Transform Class See Also Send Feedback
Defines the origin of the old coordinate system in the new coordinate system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ Origin { get; set; }
Visual Basic
Public Property Origin As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

This corresponds to the fourth column vector of the conventional 3x4 matrix representation. Also, this is the translation component of the transformation.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the transform is internally marked as read-only.

See Also

Transform Class


Scale Property

[image]

Revit 2024 API
Transform..::..Scale Property
Transform Class See Also Send Feedback
The real number that represents the scale of the transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double Scale { get; }
Visual Basic
Public ReadOnly Property Scale As Double
    Get
Visual C++
public:
property double Scale {
    double get ();
}

Remarks

When the transformation is conformal and can be decomposed as the product of a rigid-body motion, uniform scale and reflection, this property returns the scale value of the uniform scale transformation.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when this transformation is not conformal and the scale is undefined.

See Also

Transform Class


Transform1D Class

[image]

Revit 2024 API
Transform1D Class
Members See Also Send Feedback
An affine transform of 1D Euclidean space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public class Transform1D : IDisposable
Visual Basic
Public Class Transform1D _
    Implements IDisposable
Visual C++
public ref class Transform1D : IDisposable

Remarks

An affine transform is a linear transform plus a translation (which may be zero). 1D space is tranformed according to the following formula: t -> A*t + B where A and B are constants. Some functions only accept certain kinds of transform (e.g., rigid motion, conformal, non-singular, etc.).

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Transform1D

See Also

Transform1D Members


Transform1D Members

[image] [image]

Revit 2024 API
Transform1D Members
Transform1D Class Constructors Methods Properties See Also Send Feedback

The Transform1D type exposes the following members.

Constructors

 | Name | Description
Public method | Transform1D(Double) | Constructs the transformation by specifying the scale only.
Public method | Transform1D(Transform1D) | The copy constructor.
Public method | Transform1D(Double, Double) | Constructs the transformation by specifying the scale and the translation.

Methods

 | Name | Description
Public method | AlmostEqual | Determines whether this transformation and the specified transformation are the same within the tolerance (1.0e-09).
Public method | Assign | Assigns values from the input transformation to this transformation.
Public method | Dispose | Releases all resources used by the Transform1D
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInverse | Gets the inverse transformation of this transformation.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Multiply | Multiplies this transformation by the specified transformation and returns the result.
Public method | OfPoint | Applies the transformation to the 1-dimensional point and returns the result.
Public method | OfVector | Applies the transformation to the 1-dimensional vector (a "tangent vector" on the real line) and returns the result.
Public method | SetToIdentity | Set this TrfUV to the identity transform
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformParameterDomain | Performs a transform of the parameter range defined by domain, and ensures that the domain is ordered correctly.

Properties

 | Name | Description
Public property | Determinant | The determinant of this transformation.
Public property | IsIdentity | The boolean value that indicates whether this transformation is an identity.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Scale | The real number that represents the scale of this transformation.
Public property | Translation | The translational part of this transformation.

See Also

Transform1D Class


Transform1D Constructor

[image] [image]

Revit 2024 API
Transform1D Constructor
Transform1D Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Transform1D(Double) | Constructs the transformation by specifying the scale only.
Public method | Transform1D(Transform1D) | The copy constructor.
Public method | Transform1D(Double, Double) | Constructs the transformation by specifying the scale and the translation.

See Also

Transform1D Class
Transform1D Members


Transform1D Constructor (Double)

[image]

Revit 2024 API
Transform1D Constructor (Double)
Transform1D Class See Also Send Feedback
Constructs the transformation by specifying the scale only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public Transform1D(
    double scale
)
Visual Basic
Public Sub New ( _
    scale As Double _
)
Visual C++
public:
Transform1D(
    double scale
)

Parameters

scale
Type: System..::..Double
The scale of the transformation.

Remarks

The translation is set to zero. 1D space is tranformed according to the following formula: t --> scale*t + translation This constructor sets translation to zero.

See Also

Transform1D Class
Transform1D Overload


Transform1D Constructor (Transform1D)

[image]

Revit 2024 API
Transform1D Constructor (Transform1D)
Transform1D Class See Also Send Feedback
The copy constructor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public Transform1D(
    Transform1D other
)
Visual Basic
Public Sub New ( _
    other As Transform1D _
)
Visual C++
public:
Transform1D(
    Transform1D^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..Transform1D
The transformation to use as input.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Transform1D Class
Transform1D Overload


Transform1D Constructor (Double, Double)

[image]

Revit 2024 API
Transform1D Constructor (Double, Double)
Transform1D Class See Also Send Feedback
Constructs the transformation by specifying the scale and the translation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public Transform1D(
    double scale,
    double translation
)
Visual Basic
Public Sub New ( _
    scale As Double, _
    translation As Double _
)
Visual C++
public:
Transform1D(
    double scale,
    double translation
)

Parameters

scale
Type: System..::..Double
The scale of the transformation.
translation
Type: System..::..Double
The translational part of the transformation.

Remarks

1D space is tranformed according to the following formula: t --> scale*t + translation

See Also

Transform1D Class
Transform1D Overload


Transform1D Methods

[image] [image]

Revit 2024 API
Transform1D Methods
Transform1D Class See Also Send Feedback

The Transform1D type exposes the following members.

Methods

 | Name | Description
Public method | AlmostEqual | Determines whether this transformation and the specified transformation are the same within the tolerance (1.0e-09).
Public method | Assign | Assigns values from the input transformation to this transformation.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInverse | Gets the inverse transformation of this transformation.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Multiply | Multiplies this transformation by the specified transformation and returns the result.
Public method | OfPoint | Applies the transformation to the 1-dimensional point and returns the result.
Public method | OfVector | Applies the transformation to the 1-dimensional vector (a "tangent vector" on the real line) and returns the result.
Public method | SetToIdentity | Set this TrfUV to the identity transform
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformParameterDomain | Performs a transform of the parameter range defined by domain, and ensures that the domain is ordered correctly.

See Also

Transform1D Class


AlmostEqual Method

[image]

Revit 2024 API
Transform1D..::..AlmostEqual Method
Transform1D Class See Also Send Feedback
Determines whether this transformation and the specified transformation are the same within the tolerance (1.0e-09).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public bool AlmostEqual(
    Transform1D right
)
Visual Basic
Public Function AlmostEqual ( _
    right As Transform1D _
) As Boolean
Visual C++
public:
bool AlmostEqual(
    Transform1D^ right
)

Parameters

right
Type: Autodesk.Revit.DB..::..Transform1D
The transformation to compare with this transformation.

Return Value

True if the two transformations are equal, false otherwise.

Remarks

The tolerance is applied memberwise for comparison.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Transform1D Class


Dispose Method

[image]

Revit 2024 API
Transform1D..::..Dispose Method
Transform1D Class See Also Send Feedback
Releases all resources used by the Transform1D

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

Transform1D Class


GetInverse Method

[image]

Revit 2024 API
Transform1D..::..GetInverse Method
Transform1D Class See Also Send Feedback
Gets the inverse transformation of this transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public Transform1D GetInverse()
Visual Basic
Public Function GetInverse As Transform1D
Visual C++
public:
Transform1D^ GetInverse()

Remarks

The transformation matrix A is invertible if there exists a transformation matrix B such that A*B = B*A = I (identity).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This transformation is singular.

See Also

Transform1D Class


Multiply Method

[image]

Revit 2024 API
Transform1D..::..Multiply Method
Transform1D Class See Also Send Feedback
Multiplies this transformation by the specified transformation and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public Transform1D Multiply(
    Transform1D right
)
Visual Basic
Public Function Multiply ( _
    right As Transform1D _
) As Transform1D
Visual C++
public:
Transform1D^ Multiply(
    Transform1D^ right
)

Parameters

right
Type: Autodesk.Revit.DB..::..Transform1D
The input transformation.

Return Value

The transformation equal to the composition of the two transformations.

Remarks

The combined transformation has the same effect as applying the input transformation first, and this transformation, second. So, (T1(T2(p)) = (T1 * T2) (p).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Transform1D Class


OfVector Method

[image]

Revit 2024 API
Transform1D..::..OfVector Method
Transform1D Class See Also Send Feedback
Applies the transformation to the 1-dimensional vector (a "tangent vector" on the real line) and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public double OfVector(
    double vector
)
Visual Basic
Public Function OfVector ( _
    vector As Double _
) As Double
Visual C++
public:
double OfVector(
    double vector
)

Parameters

vector
Type: System..::..Double
The vector to transform.

Return Value

The transformed vector.

Remarks

Transformation of a vector is not affected by the translational part of the transformation.

See Also

Transform1D Class


SetToIdentity Method

[image]

Revit 2024 API
Transform1D..::..SetToIdentity Method
Transform1D Class See Also Send Feedback
Set this TrfUV to the identity transform

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public Transform1D SetToIdentity()
Visual Basic
Public Function SetToIdentity As Transform1D
Visual C++
public:
Transform1D^ SetToIdentity()

Return Value

Returns a pointer to "this" Transform1D.

See Also

Transform1D Class


Transform1D Properties

[image] [image]

Revit 2024 API
Transform1D Properties
Transform1D Class See Also Send Feedback

The Transform1D type exposes the following members.

Properties

 | Name | Description
Public property | Determinant | The determinant of this transformation.
Public property | IsIdentity | The boolean value that indicates whether this transformation is an identity.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Scale | The real number that represents the scale of this transformation.
Public property | Translation | The translational part of this transformation.

See Also

Transform1D Class


Determinant Property

[image]

Revit 2024 API
Transform1D..::..Determinant Property
Transform1D Class See Also Send Feedback
The determinant of this transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public double Determinant { get; }
Visual Basic
Public ReadOnly Property Determinant As Double
    Get
Visual C++
public:
property double Determinant {
    double get ();
}

See Also

Transform1D Class


IsIdentity Property

[image]

Revit 2024 API
Transform1D..::..IsIdentity Property
Transform1D Class See Also Send Feedback
The boolean value that indicates whether this transformation is an identity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public bool IsIdentity { get; }
Visual Basic
Public ReadOnly Property IsIdentity As Boolean
    Get
Visual C++
public:
property bool IsIdentity {
    bool get ();
}

Remarks

The identity transformation does not change a point or a vector that it is applied to.

See Also

Transform1D Class


IsValidObject Property

[image]

Revit 2024 API
Transform1D..::..IsValidObject Property
Transform1D Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

Transform1D Class


Scale Property

[image]

Revit 2024 API
Transform1D..::..Scale Property
Transform1D Class See Also Send Feedback
The real number that represents the scale of this transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public double Scale { get; set; }
Visual Basic
Public Property Scale As Double
    Get
    Set
Visual C++
public:
property double Scale {
    double get ();
    void set (double value);
}

See Also

Transform1D Class


Transform2D Class

[image]

Revit 2024 API
Transform2D Class
Members See Also Send Feedback
An affine transform of 2D Euclidean space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public class Transform2D : IDisposable
Visual Basic
Public Class Transform2D _
    Implements IDisposable
Visual C++
public ref class Transform2D : IDisposable

Remarks

An affine transform is a linear transform plus a translation (which may be zero). Some functions only accept certain kinds of transform (e.g., rigid motion, conformal, non-singular, etc.).

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Transform2D

See Also

Transform2D Members


Transform2D Members

[image] [image]

Revit 2024 API
Transform2D Members
Transform2D Class Constructors Methods Properties See Also Send Feedback

The Transform2D type exposes the following members.

Constructors

 | Name | Description
Public method | Transform2D(Transform2D) | The copy constructor.
Public method | Transform2D(UV, UV, UV) | Constructs the transformation by specifying the vectors and the origin.

Methods

 | Name | Description
Public method | AlmostEqual | Determines whether this transformation and the specified transformation are the same within the tolerance (1.0e-09).
Public method | Assign | Assigns values from the input transformation to this transformation.
 | CreateIdentity | Creates the identity transformation.
Public method | Dispose | Releases all resources used by the Transform2D
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInverse | Gets the inverse transformation of this transformation.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Multiply | Multiplies this transformation by the specified transformation and returns the result.
Public method | OfPoint | Applies the transformation to the point and returns the result.
Public method | OfVector | Applies the transformation to the vector and returns the result.
Public method | PostScale | Scales both the linear and translational parts of this transformation and returns the result.
Public method | PreScale | Scales the linear part of this transformation and returns the result.
Public method | SetToIdentity | Set this TrfUV to the identity transform.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TransformUVDomainIfPossible | Transforms an envelope (BoundingBoxUV) for one surface to an envelope for a coincident but differently parameterized surface.

Properties

 | Name | Description
Public property | BasisU | The image of (1, 0) under OfVector(UV).
Public property | BasisV | The image of (0, 1) under OfVector(UV).
Public property | Determinant | The determinant of this transformation.
Public property | HasReflection | The boolean value that indicates whether this transformation produces reflection (i.e., is orientation-reversing).
Public property | IsConformal | The boolean value that indicates whether this transformation is conformal.
Public property | IsIdentity | The boolean value that indicates whether this transformation is an identity.
Public property | IsTranslation | The boolean value that indicates whether this transformation is a translation.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Origin | The image of (0, 0) under OfPoint(UV). This defines the translational part of the transform.
Public property | Scale | The real number that represents the scale of the conformal transformation.

See Also

Transform2D Class


Transform2D Constructor

[image] [image]

Revit 2024 API
Transform2D Constructor
Transform2D Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Transform2D(Transform2D) | The copy constructor.
Public method | Transform2D(UV, UV, UV) | Constructs the transformation by specifying the vectors and the origin.

See Also

Transform2D Class
Transform2D Members


Transform2D Constructor (Transform2D)

[image]

Revit 2024 API
Transform2D Constructor (Transform2D)
Transform2D Class See Also Send Feedback
The copy constructor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public Transform2D(
    Transform2D other
)
Visual Basic
Public Sub New ( _
    other As Transform2D _
)
Visual C++
public:
Transform2D(
    Transform2D^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..Transform2D
The transformation to use as input.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Transform2D Class
Transform2D Overload


Transform2D Constructor (UV, UV, UV)

[image]

Revit 2024 API
Transform2D Constructor (UV, UV, UV)
Transform2D Class See Also Send Feedback
Constructs the transformation by specifying the vectors and the origin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public Transform2D(
    UV uVec,
    UV vVec,
    UV origin
)
Visual Basic
Public Sub New ( _
    uVec As UV, _
    vVec As UV, _
    origin As UV _
)
Visual C++
public:
Transform2D(
    UV^ uVec,
    UV^ vVec,
    UV^ origin
)

Parameters

uVec
Type: Autodesk.Revit.DB..::..UV
The image of (1, 0) under OfVector(UV).
vVec
Type: Autodesk.Revit.DB..::..UV
The image of (0, 1) under OfVector(UV).
origin
Type: Autodesk.Revit.DB..::..UV
The image of (0, 0) under OfPoint(UV). This defines the translational part of the transform.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Transform2D Class
Transform2D Overload


AlmostEqual Method

[image]

Revit 2024 API
Transform2D..::..AlmostEqual Method
Transform2D Class See Also Send Feedback
Determines whether this transformation and the specified transformation are the same within the tolerance (1.0e-09).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public bool AlmostEqual(
    Transform2D right
)
Visual Basic
Public Function AlmostEqual ( _
    right As Transform2D _
) As Boolean
Visual C++
public:
bool AlmostEqual(
    Transform2D^ right
)

Parameters

right
Type: Autodesk.Revit.DB..::..Transform2D
The transformation to compare with this transformation.

Return Value

True if the two transformations are equal, false otherwise.

Remarks

The tolerance is applied memberwise for comparison.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Transform2D Class


Assign Method

[image]

Revit 2024 API
Transform2D..::..Assign Method
Transform2D Class See Also Send Feedback
Assigns values from the input transformation to this transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public void Assign(
    Transform2D from
)
Visual Basic
Public Sub Assign ( _
    from As Transform2D _
)
Visual C++
public:
void Assign(
    Transform2D^ from
)

Parameters

from
Type: Autodesk.Revit.DB..::..Transform2D
The transformation to use as input.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Transform2D Class


CreateIdentity Method

[image]

Revit 2024 API
Transform2D..::..CreateIdentity Method
Transform2D Class See Also Send Feedback
Creates the identity transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static Transform2D CreateIdentity()
Visual Basic
Public Shared Function CreateIdentity As Transform2D
Visual C++
public:
static Transform2D^ CreateIdentity()

Return Value

The identity transformation.

Remarks

The identity transformation does not change a point or a vector that it is applied to.

See Also

Transform2D Class


GetInverse Method

[image]

Revit 2024 API
Transform2D..::..GetInverse Method
Transform2D Class See Also Send Feedback
Gets the inverse transformation of this transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public Transform2D GetInverse()
Visual Basic
Public Function GetInverse As Transform2D
Visual C++
public:
Transform2D^ GetInverse()

Remarks

The transformation matrix A is invertible if there exists a transformation matrix B such that A*B = B*A = I (identity).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This transformation is not conformal or invertible.

See Also

Transform2D Class


Multiply Method

[image]

Revit 2024 API
Transform2D..::..Multiply Method
Transform2D Class See Also Send Feedback
Multiplies this transformation by the specified transformation and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public Transform2D Multiply(
    Transform2D right
)
Visual Basic
Public Function Multiply ( _
    right As Transform2D _
) As Transform2D
Visual C++
public:
Transform2D^ Multiply(
    Transform2D^ right
)

Parameters

right
Type: Autodesk.Revit.DB..::..Transform2D

Return Value

The transformation equal to the composition of the two transformations.

Remarks

The combined transformation has the same effect as applying the right transformation first, and this transformation, second. So, denoting this transform by T1 and the right transform by T2, (T1(T2(p)) = (T1 * T2) (p).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Transform2D Class


OfPoint Method

[image]

Revit 2024 API
Transform2D..::..OfPoint Method
Transform2D Class See Also Send Feedback
Applies the transformation to the point and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public UV OfPoint(
    UV point
)
Visual Basic
Public Function OfPoint ( _
    point As UV _
) As UV
Visual C++
public:
UV^ OfPoint(
    UV^ point
)

Parameters

point
Type: Autodesk.Revit.DB..::..UV
The point to transform.

Return Value

The transformed point.

Remarks

Transformation of a point is affected by the translational part of the transformation.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Transform2D Class


OfVector Method

[image]

Revit 2024 API
Transform2D..::..OfVector Method
Transform2D Class See Also Send Feedback
Applies the transformation to the vector and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public UV OfVector(
    UV vector
)
Visual Basic
Public Function OfVector ( _
    vector As UV _
) As UV
Visual C++
public:
UV^ OfVector(
    UV^ vector
)

Parameters

vector
Type: Autodesk.Revit.DB..::..UV
The vector to transform.

Return Value

The transformed vector.

Remarks

Transformation of a vector is not affected by the translational part of the transformation.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Transform2D Class


PostScale Method

[image]

Revit 2024 API
Transform2D..::..PostScale Method
Transform2D Class See Also Send Feedback
Scales both the linear and translational parts of this transformation and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public Transform2D PostScale(
    double scale
)
Visual Basic
Public Function PostScale ( _
    scale As Double _
) As Transform2D
Visual C++
public:
Transform2D^ PostScale(
    double scale
)

Parameters

scale
Type: System..::..Double
The scale value.

Return Value

Returns a pointer to "this" Transform2D.

Remarks

The resulting transformation is equivalent to the application of this transformation and then the uniform scale, in this order.

See Also

Transform2D Class


PreScale Method

[image]

Revit 2024 API
Transform2D..::..PreScale Method
Transform2D Class See Also Send Feedback
Scales the linear part of this transformation and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public Transform2D PreScale(
    double scale
)
Visual Basic
Public Function PreScale ( _
    scale As Double _
) As Transform2D
Visual C++
public:
Transform2D^ PreScale(
    double scale
)

Parameters

scale
Type: System..::..Double
The scale value.

Return Value

Returns a pointer to "this" Transform2D.

Remarks

The resulting transformation is equivalent to the application of the uniform scale and then this transformation, in this order.

See Also

Transform2D Class


TransformUVDomainIfPossible Method

[image]

Revit 2024 API
Transform2D..::..TransformUVDomainIfPossible Method
Transform2D Class See Also Send Feedback
Transforms an envelope (BoundingBoxUV) for one surface to an envelope for a coincident but differently parameterized surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public BoundingBoxUV TransformUVDomainIfPossible(
    BoundingBoxUV uvDomain
)
Visual Basic
Public Function TransformUVDomainIfPossible ( _
    uvDomain As BoundingBoxUV _
) As BoundingBoxUV
Visual C++
public:
BoundingBoxUV^ TransformUVDomainIfPossible(
    BoundingBoxUV^ uvDomain
)

Parameters

uvDomain
Type: Autodesk.Revit.DB..::..BoundingBoxUV
The original surface envelope.

Return Value

If successful a new BoundingBoxUV transformed surface envelope, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

This method succeeds in the case when the uv-parameter transform between the surfaces has a simple form, that commonly occurs for analytic surfaces, such that the image of the input envelope under the transform is itself a rectangular region aligned with the UV coordinate axes.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | uvDomain is not set.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Transform2D Class


BasisU Property

[image]

Revit 2024 API
Transform2D..::..BasisU Property
Transform2D Class See Also Send Feedback
The image of (1, 0) under OfVector(UV).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public UV BasisU { get; set; }
Visual Basic
Public Property BasisU As UV
    Get
    Set
Visual C++
public:
property UV^ BasisU {
    UV^ get ();
    void set (UV^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

Transform2D Class


BasisV Property

[image]

Revit 2024 API
Transform2D..::..BasisV Property
Transform2D Class See Also Send Feedback
The image of (0, 1) under OfVector(UV).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public UV BasisV { get; set; }
Visual Basic
Public Property BasisV As UV
    Get
    Set
Visual C++
public:
property UV^ BasisV {
    UV^ get ();
    void set (UV^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

Transform2D Class


Determinant Property

[image]

Revit 2024 API
Transform2D..::..Determinant Property
Transform2D Class See Also Send Feedback
The determinant of this transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public double Determinant { get; }
Visual Basic
Public ReadOnly Property Determinant As Double
    Get
Visual C++
public:
property double Determinant {
    double get ();
}

Remarks

The geometric meaning of a determinant is as the scale factor for volume when applied as linear transformation.

See Also

Transform2D Class


HasReflection Property

[image]

Revit 2024 API
Transform2D..::..HasReflection Property
Transform2D Class See Also Send Feedback
The boolean value that indicates whether this transformation produces reflection (i.e., is orientation-reversing).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public bool HasReflection { get; }
Visual Basic
Public ReadOnly Property HasReflection As Boolean
    Get
Visual C++
public:
property bool HasReflection {
    bool get ();
}

Remarks

Reflection transformation changes the handedness of a coordinate system.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This transformation is singular and the reflection is undefined.

See Also

Transform2D Class


IsConformal Property

[image]

Revit 2024 API
Transform2D..::..IsConformal Property
Transform2D Class See Also Send Feedback
The boolean value that indicates whether this transformation is conformal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public bool IsConformal { get; }
Visual Basic
Public ReadOnly Property IsConformal As Boolean
    Get
Visual C++
public:
property bool IsConformal {
    bool get ();
}

Remarks

This property is true if this transformation can be decomposed as the product of a rigid-body motion, uniform scale and reflection. Such transformation preserves angles between vectors.

See Also

Transform2D Class


IsIdentity Property

[image]

Revit 2024 API
Transform2D..::..IsIdentity Property
Transform2D Class See Also Send Feedback
The boolean value that indicates whether this transformation is an identity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public bool IsIdentity { get; }
Visual Basic
Public ReadOnly Property IsIdentity As Boolean
    Get
Visual C++
public:
property bool IsIdentity {
    bool get ();
}

Remarks

The identity transformation does not change a point or a vector that it is applied to.

See Also

Transform2D Class


IsTranslation Property

[image]

Revit 2024 API
Transform2D..::..IsTranslation Property
Transform2D Class See Also Send Feedback
The boolean value that indicates whether this transformation is a translation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public bool IsTranslation { get; }
Visual Basic
Public ReadOnly Property IsTranslation As Boolean
    Get
Visual C++
public:
property bool IsTranslation {
    bool get ();
}

Remarks

This property is true if the only effect of transformation is translation. It checks that the linear part of the transform is identity. The translation vector may be zero (which would make this an identity transformation) or nonzero (which would make this a non-trivial translation).

See Also

Transform2D Class


IsValidObject Property

[image]

Revit 2024 API
Transform2D..::..IsValidObject Property
Transform2D Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

Transform2D Class


Origin Property

[image]

Revit 2024 API
Transform2D..::..Origin Property
Transform2D Class See Also Send Feedback
The image of (0, 0) under OfPoint(UV). This defines the translational part of the transform.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public UV Origin { get; set; }
Visual Basic
Public Property Origin As UV
    Get
    Set
Visual C++
public:
property UV^ Origin {
    UV^ get ();
    void set (UV^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

Transform2D Class


Scale Property

[image]

Revit 2024 API
Transform2D..::..Scale Property
Transform2D Class See Also Send Feedback
The real number that represents the scale of the conformal transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public double Scale { get; }
Visual Basic
Public ReadOnly Property Scale As Double
    Get
Visual C++
public:
property double Scale {
    double get ();
}

Remarks

When the transformation is conformal and can be decomposed as the product of a rigid-body motion, uniform scale and reflection, this property returns the scale value of the uniform scale transformation.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This transformation is not conformal and the scale is undefined.

See Also

Transform2D Class


TransformWithBoundary Class

[image]

Revit 2024 API
TransformWithBoundary Class
Members See Also Send Feedback
This class contains the transform from model space to projection space for a view and the boundary in model space in which the transform is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public class TransformWithBoundary : IDisposable
Visual Basic
Public Class TransformWithBoundary _
    Implements IDisposable
Visual C++
public ref class TransformWithBoundary : IDisposable

Remarks

Use the model-to-projection transform returned by GetModelToProjectionTransform()()()() to transform model points to the view's projection space. The model-to-projection transform is only valid for points in 3D model space that that can be seen through the 2D boundary returned by GetBoundary()()()(), when looking in the direction of [!:View.ViewDirection].

For views that are placed on sheets, you can combine the View's model-to-projection transform and the Viewport's projection-to-sheet transform to transform model points to sheet space:

sheetXYZ = projectionToSheetTransform * modelToProjectionTransform * modelXYZ

Model space is the global 3D coordinate space in which the 3D geometry of the model lives.

View projection space is the 3D Euclidean space with a coordinate system such that X and Y are horizontal and vertical directions in the view projection plane and Z is the cross product of X and Y. Distances in the projection space are the same as would be measured on paper if the view is printed without additional scaling.

Sheet space is the coordinate space of one sheet. This is the space in which viewports and titleblocks are arranged on the sheet.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..TransformWithBoundary

See Also

TransformWithBoundary Members


TransformWithBoundary Members

[image] [image]

Revit 2024 API
TransformWithBoundary Members
TransformWithBoundary Class Constructors Methods Properties See Also Send Feedback

The TransformWithBoundary type exposes the following members.

Constructors

 | Name | Description
Public method | TransformWithBoundary | Constructs a new copy of the input TransformWithBoundary object.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the TransformWithBoundary
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBoundary | Returns the boundary for the model space to view projection space transform.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetModelToProjectionTransform | Gets the model space to view projection space transform.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

TransformWithBoundary Class


TransformWithBoundary Constructor

[image]

Revit 2024 API
TransformWithBoundary Constructor
TransformWithBoundary Class See Also Send Feedback
Constructs a new copy of the input TransformWithBoundary object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public TransformWithBoundary(
    TransformWithBoundary other
)
Visual Basic
Public Sub New ( _
    other As TransformWithBoundary _
)
Visual C++
public:
TransformWithBoundary(
    TransformWithBoundary^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..TransformWithBoundary

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

TransformWithBoundary Class


Dispose Method

[image]

Revit 2024 API
TransformWithBoundary..::..Dispose Method
TransformWithBoundary Class See Also Send Feedback
Releases all resources used by the TransformWithBoundary

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

TransformWithBoundary Class


GetBoundary Method

[image]

Revit 2024 API
TransformWithBoundary..::..GetBoundary Method
TransformWithBoundary Class See Also Send Feedback
Returns the boundary for the model space to view projection space transform.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public CurveLoop GetBoundary()
Visual Basic
Public Function GetBoundary As CurveLoop
Visual C++
public:
CurveLoop^ GetBoundary()

Return Value

A closed loop in model space representing the region of model space to which the model space to view projection space transform applies.

Remarks

Before you transform a model point to view projection space using the transform returned by GetModelToProjectionTransform()()()(), test to make sure the model point is visible through this 2D boundary. The model space to view projection space transform is only valid for points in 3D model space that can be seen through the 2D boundary, when looking in the direction of [!:View.ViewDirection].

The boundary is one enclosed region of the view's crop.

For uncropped views 'null' is returned.

For cropped views that do not have split crop regions, the boundary is the shape of the view crop. Typically the boundary is rectangular, but more complex shapes are supported.

For cropped views that have split crop regions, the boundary is one rectangular region of the split view crop.

Even though the boundary represents the view crop - a 2D polygon drawn on the view's cut plane - any point in 3D model space that can be seen through the boundary when looking in the direction of the view (see [!:View.ViewDirection]) is considered to be inside the boundary and can be transformed using the model space to view projection space transform returned by GetModelToProjectionTransform()()()(). For example, if the shape of the CurveLoop is a circle, then there is an infinite cylinder in 3D model space and any point inside that cylinder can be transformed with the model space to view projection space transform.

To test if a point in 3D model space is within the boundary, first project the point and the CurveLoop onto a plane which is perpendicular to the view direction. Then use a point-in-polygon algorithm to check if the projected point is inside the polygon described by the CurveLoop.

It is guaranteed that the boundary CurveLoop lies on a plane which is perpendicular to [!:View.ViewDirection] and that the CurveLoop does not self-intersect and is closed. It is also guaranteed that the boundaries of different TransformWithBoundary regions of the same view don't overlap with each other.

See Also

TransformWithBoundary Class


GetModelToProjectionTransform Method

[image]

Revit 2024 API
TransformWithBoundary..::..GetModelToProjectionTransform Method
TransformWithBoundary Class See Also Send Feedback
Gets the model space to view projection space transform.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public Transform GetModelToProjectionTransform()
Visual Basic
Public Function GetModelToProjectionTransform As Transform
Visual C++
public:
Transform^ GetModelToProjectionTransform()

Return Value

The model space to view projection space transformation.

Remarks

The transform can be used to transform points from model space to view projection space.

Model space is the global 3D coordinate space in which the 3D geometry of the model lives.

View projection space is the 3D Euclidean space with a coordinate system such that X and Y are horizontal and vertical directions in the view projection plane and Z is the cross product of X and Y. Distances in the projection space are the same as would be measured on paper if the view is printed without additional scaling.

For uncropped views all model space points can be transformed to projection space using the this transform.

For cropped views only model points which lie inside the boundary returned by GetBoundary()()()() should be transformed to projection space using this transform.

See Also

TransformWithBoundary Class


TransformWithBoundary Properties

[image] [image]

Revit 2024 API
TransformWithBoundary Properties
TransformWithBoundary Class See Also Send Feedback

The TransformWithBoundary type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

TransformWithBoundary Class


TransmissionData Members

[image] [image]

Revit 2024 API
TransmissionData Members
TransmissionData Class Constructors Methods Properties See Also Send Feedback

The TransmissionData type exposes the following members.

Constructors

 | Name | Description
Public method | TransmissionData | Constructs a TransmissionData from another TransmissionData

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the TransmissionData
 | DocumentIsNotTransmitted | Determines whether the document at a given file location is not transmitted.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAllExternalFileReferenceIds | Gets the ids of all ExternalFileReferences.
Public method | GetDesiredReferenceData | Gets the ExternalFileReference representing path and load status information to be used the next time this TransmissionData's document is loaded.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLastSavedReferenceData | Gets the ExternalFileReference representing path and load status information concerning the most recent time this TransmissionData's document was opened.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsDocumentTransmitted | Determines whether the document at a given file location is transmitted.
 | ReadTransmissionData | Reads the TransmissionData associated with the file at the given location.
Public method | SetDesiredReferenceData | Sets the ExternalFileReference information which Revit should use the next time it opens the document which this TransmissionData belongs to.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | WriteTransmissionData | Writes the given TransmissionData into the Revit file at the given location.

Properties

 | Name | Description
Public property | IsTransmitted | Determines whether this file has been transmitted or not.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | UserData | A string which users can store notes in.
Public property | Version | The format version for TransmissionData

See Also

TransmissionData Class


TransmissionData Constructor

[image]

Revit 2024 API
TransmissionData Constructor
TransmissionData Class See Also Send Feedback
Constructs a TransmissionData from another TransmissionData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public TransmissionData(
    TransmissionData other
)
Visual Basic
Public Sub New ( _
    other As TransmissionData _
)
Visual C++
public:
TransmissionData(
    TransmissionData^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..TransmissionData

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

TransmissionData Class


TransmissionData Methods

[image] [image]

Revit 2024 API
TransmissionData Methods
TransmissionData Class See Also Send Feedback

The TransmissionData type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
 | DocumentIsNotTransmitted | Determines whether the document at a given file location is not transmitted.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAllExternalFileReferenceIds | Gets the ids of all ExternalFileReferences.
Public method | GetDesiredReferenceData | Gets the ExternalFileReference representing path and load status information to be used the next time this TransmissionData's document is loaded.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLastSavedReferenceData | Gets the ExternalFileReference representing path and load status information concerning the most recent time this TransmissionData's document was opened.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsDocumentTransmitted | Determines whether the document at a given file location is transmitted.
 | ReadTransmissionData | Reads the TransmissionData associated with the file at the given location.
Public method | SetDesiredReferenceData | Sets the ExternalFileReference information which Revit should use the next time it opens the document which this TransmissionData belongs to.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | WriteTransmissionData | Writes the given TransmissionData into the Revit file at the given location.

See Also

TransmissionData Class


Dispose Method

[image]

Revit 2024 API
TransmissionData..::..Dispose Method
TransmissionData Class See Also Send Feedback
Releases all resources used by the TransmissionData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

TransmissionData Class


DocumentIsNotTransmitted Method

[image]

Revit 2024 API
TransmissionData..::..DocumentIsNotTransmitted Method
TransmissionData Class See Also Send Feedback
Determines whether the document at a given file location is not transmitted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static bool DocumentIsNotTransmitted(
    ModelPath filePath
)
Visual Basic
Public Shared Function DocumentIsNotTransmitted ( _
    filePath As ModelPath _
) As Boolean
Visual C++
public:
static bool DocumentIsNotTransmitted(
    ModelPath^ filePath
)

Parameters

filePath
Type: Autodesk.Revit.DB..::..ModelPath
The path to the document whose transmitted state will be checked.

Return Value

False if the document is a transmitted file, true otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

TransmissionData Class


GetAllExternalFileReferenceIds Method

[image]

Revit 2024 API
TransmissionData..::..GetAllExternalFileReferenceIds Method
TransmissionData Class See Also Send Feedback
Gets the ids of all ExternalFileReferences.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public ICollection<ElementId> GetAllExternalFileReferenceIds()
Visual Basic
Public Function GetAllExternalFileReferenceIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetAllExternalFileReferenceIds()

Return Value

The ids of all ExternalFileReferences.

See Also

TransmissionData Class


GetDesiredReferenceData Method

[image]

Revit 2024 API
TransmissionData..::..GetDesiredReferenceData Method
TransmissionData Class See Also Send Feedback
Gets the ExternalFileReference representing path and load status information to be used the next time this TransmissionData's document is loaded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public ExternalFileReference GetDesiredReferenceData(
    ElementId elemId
)
Visual Basic
Public Function GetDesiredReferenceData ( _
    elemId As ElementId _
) As ExternalFileReference
Visual C++
public:
ExternalFileReference^ GetDesiredReferenceData(
    ElementId^ elemId
)

Parameters

elemId
Type: Autodesk.Revit.DB..::..ElementId
The ElementId of the Element which the external file reference is a component of.

Return Value

An ExternalFileReference containing the requested path and load status information for an external file

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | elemId does not correspond to an ExternalFileReference contained in this TransmissionData.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

TransmissionData Class


IsDocumentTransmitted Method

[image]

Revit 2024 API
TransmissionData..::..IsDocumentTransmitted Method
TransmissionData Class See Also Send Feedback
Determines whether the document at a given file location is transmitted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static bool IsDocumentTransmitted(
    ModelPath filePath
)
Visual Basic
Public Shared Function IsDocumentTransmitted ( _
    filePath As ModelPath _
) As Boolean
Visual C++
public:
static bool IsDocumentTransmitted(
    ModelPath^ filePath
)

Parameters

filePath
Type: Autodesk.Revit.DB..::..ModelPath
The path to the document whose transmitted state will be checked.

Return Value

True if the document is a transmitted file, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

TransmissionData Class


ReadTransmissionData Method

[image]

Revit 2024 API
TransmissionData..::..ReadTransmissionData Method
TransmissionData Class See Also Send Feedback
Reads the TransmissionData associated with the file at the given location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static TransmissionData ReadTransmissionData(
    ModelPath path
)
Visual Basic
Public Shared Function ReadTransmissionData ( _
    path As ModelPath _
) As TransmissionData
Visual C++
public:
static TransmissionData^ ReadTransmissionData(
    ModelPath^ path
)

Parameters

path
Type: Autodesk.Revit.DB..::..ModelPath
A ModelPath indicating the file Revit should read the TransmissionData of. If this ModelPath is a file path, it must be an absolute path.

Return Value

The TransmissionData containing external file information for the file at the given location.

Remarks

The TransmissionData returned by this function contains data about all ExternalFileReferences in the document. ExternalResourceReferences to extenal servers will not be returned by this function. TransmissionData contains information about local or Revit Server references only.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..CentralModelAccessDeniedException | Access to the central model was denied. A possible reason is because the model was under maintenance.
Autodesk.Revit.Exceptions..::..CentralModelContentionException | The central model are locked by another client.
Autodesk.Revit.Exceptions..::..CentralModelException | The central model is missing. -or- An internal error happened on the central model, please contact the server administrator.
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | There is not a valid Revit file at path's location
Autodesk.Revit.Exceptions..::..RevitServerCommunicationException | The server-based central model could not be accessed because of a network communication error.

See Also

TransmissionData Class


SetDesiredReferenceData Method

[image]

Revit 2024 API
TransmissionData..::..SetDesiredReferenceData Method
TransmissionData Class See Also Send Feedback
Sets the ExternalFileReference information which Revit should use the next time it opens the document which this TransmissionData belongs to.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public void SetDesiredReferenceData(
    ElementId elemId,
    ModelPath path,
    PathType pathType,
    bool shouldLoad
)
Visual Basic
Public Sub SetDesiredReferenceData ( _
    elemId As ElementId, _
    path As ModelPath, _
    pathType As PathType, _
    shouldLoad As Boolean _
)
Visual C++
public:
void SetDesiredReferenceData(
    ElementId^ elemId,
    ModelPath^ path,
    PathType pathType,
    bool shouldLoad
)

Parameters

elemId
Type: Autodesk.Revit.DB..::..ElementId
The id of the element associated with this reference.
path
Type: Autodesk.Revit.DB..::..ModelPath
A ModelPath indicating the location to load the external file reference from.
pathType
Type: Autodesk.Revit.DB..::..PathType
A PathType value indicating what type of path the ModelPath is.
shouldLoad
Type: System..::..Boolean
True if the external file should be loaded the next time Revit opens the document. False if it should be unloaded.

Remarks

There must already be a reference associated with the given id for this function to be valid. New references cannot be created in a closed file. See the documentation for a particular reference type to see its creation API.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | elemId does not correspond to an ExternalFileReference contained in this TransmissionData. -or- These inputs will not produce a valid ExternalFileReference.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

TransmissionData Class


WriteTransmissionData Method

[image]

Revit 2024 API
TransmissionData..::..WriteTransmissionData Method
TransmissionData Class See Also Send Feedback
Writes the given TransmissionData into the Revit file at the given location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public static void WriteTransmissionData(
    ModelPath path,
    TransmissionData data
)
Visual Basic
Public Shared Sub WriteTransmissionData ( _
    path As ModelPath, _
    data As TransmissionData _
)
Visual C++
public:
static void WriteTransmissionData(
    ModelPath^ path,
    TransmissionData^ data
)

Parameters

path
Type: Autodesk.Revit.DB..::..ModelPath
A ModelPath indicating the file Revit should write the TransmissionData of. This ModelPath must be a file path and an absolute path.
data
Type: Autodesk.Revit.DB..::..TransmissionData
The TransmissionData to be written into the document. Note that Revit will not check that the ElementIds in the TransmissionData correspond to real Elements.

Remarks

This function will overwrite the existing TransmissionData in the file.

This function will not support models on Revit Server. References may be to Revit Server, but the host model must be local.

This function must be called on a closed document.

This function cannot be used to convert a reference from a local file to an external server.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | There is not a valid Revit file at path's location
Autodesk.Revit.Exceptions..::..InvalidOperationException | Operation is not valid for Revit Server models. -or- This function cannot be called on an opened document.

See Also

TransmissionData Class


TransmissionData Properties

[image] [image]

Revit 2024 API
TransmissionData Properties
TransmissionData Class See Also Send Feedback

The TransmissionData type exposes the following members.

Properties

 | Name | Description
Public property | IsTransmitted | Determines whether this file has been transmitted or not.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | UserData | A string which users can store notes in.
Public property | Version | The format version for TransmissionData

See Also

TransmissionData Class


IsTransmitted Property

[image]

Revit 2024 API
TransmissionData..::..IsTransmitted Property
TransmissionData Class See Also Send Feedback
Determines whether this file has been transmitted or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public bool IsTransmitted { get; set; }
Visual Basic
Public Property IsTransmitted As Boolean
    Get
    Set
Visual C++
public:
property bool IsTransmitted {
    bool get ();
    void set (bool value);
}

Remarks

"Transmitted" files have been moved from one place to another and are considered to be in a not-final state. Revit will read the TransmissionData on file open and overwrite any data stored in the external file reference elements themselves.

See Also

TransmissionData Class


IsValidObject Property

[image]

Revit 2024 API
TransmissionData..::..IsValidObject Property
TransmissionData Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

TransmissionData Class


UserData Property

[image]

Revit 2024 API
TransmissionData..::..UserData Property
TransmissionData Class See Also Send Feedback
A string which users can store notes in.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public string UserData { get; set; }
Visual Basic
Public Property UserData As String
    Get
    Set
Visual C++
public:
property String^ UserData {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

TransmissionData Class


TriangleInShellComponent Members

[image] [image]

Revit 2024 API
TriangleInShellComponent Members
TriangleInShellComponent Class Constructors Methods Properties See Also Send Feedback

The TriangleInShellComponent type exposes the following members.

Constructors

 | Name | Description
Public method | TriangleInShellComponent | Creates a copy of the given TriangleInShellComponent

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the TriangleInShellComponent
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | VertexIndex0 | Index of the triangle's first vertex in the TriangulatedShellComponent's array of vertices.
Public property | VertexIndex1 | Index of the triangle's second vertex in the TriangulatedShellComponent's array of vertices.
Public property | VertexIndex2 | Index of the triangle's third vertex in the TriangulatedShellComponent's array of vertices.

See Also

TriangleInShellComponent Class


Dispose Method

[image]

Revit 2024 API
TriangleInShellComponent..::..Dispose Method
TriangleInShellComponent Class See Also Send Feedback
Releases all resources used by the TriangleInShellComponent

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

TriangleInShellComponent Class


TriangleInShellComponent Properties

[image] [image]

Revit 2024 API
TriangleInShellComponent Properties
TriangleInShellComponent Class See Also Send Feedback

The TriangleInShellComponent type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | VertexIndex0 | Index of the triangle's first vertex in the TriangulatedShellComponent's array of vertices.
Public property | VertexIndex1 | Index of the triangle's second vertex in the TriangulatedShellComponent's array of vertices.
Public property | VertexIndex2 | Index of the triangle's third vertex in the TriangulatedShellComponent's array of vertices.

See Also

TriangleInShellComponent Class


IsValidObject Property

[image]

Revit 2024 API
TriangleInShellComponent..::..IsValidObject Property
TriangleInShellComponent Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

TriangleInShellComponent Class


VertexIndex0 Property

[image]

Revit 2024 API
TriangleInShellComponent..::..VertexIndex0 Property
TriangleInShellComponent Class See Also Send Feedback
Index of the triangle's first vertex in the TriangulatedShellComponent's array of vertices.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public int VertexIndex0 { get; }
Visual Basic
Public ReadOnly Property VertexIndex0 As Integer
    Get
Visual C++
public:
property int VertexIndex0 {
    int get ();
}

See Also

TriangleInShellComponent Class


VertexIndex1 Property

[image]

Revit 2024 API
TriangleInShellComponent..::..VertexIndex1 Property
TriangleInShellComponent Class See Also Send Feedback
Index of the triangle's second vertex in the TriangulatedShellComponent's array of vertices.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public int VertexIndex1 { get; }
Visual Basic
Public ReadOnly Property VertexIndex1 As Integer
    Get
Visual C++
public:
property int VertexIndex1 {
    int get ();
}

See Also

TriangleInShellComponent Class


VertexIndex2 Property

[image]

Revit 2024 API
TriangleInShellComponent..::..VertexIndex2 Property
TriangleInShellComponent Class See Also Send Feedback
Index of the triangle's third vertex in the TriangulatedShellComponent's array of vertices.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public int VertexIndex2 { get; }
Visual Basic
Public ReadOnly Property VertexIndex2 As Integer
    Get
Visual C++
public:
property int VertexIndex2 {
    int get ();
}

See Also

TriangleInShellComponent Class


TriangulatedShellComponent Methods

[image] [image]

Revit 2024 API
TriangulatedShellComponent Methods
TriangulatedShellComponent Class See Also Send Feedback

The TriangulatedShellComponent type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Empties the contents of this TriangulatedShellComponent.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTriangle | Returns the triangle corresponding to the given index.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVertex | Returns the vertex with a given index.
Public method | GetVertices | Returns the vertices of the triangulation.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TriangulatedShellComponent Class


Clear Method

[image]

Revit 2024 API
TriangulatedShellComponent..::..Clear Method
TriangulatedShellComponent Class See Also Send Feedback
Empties the contents of this TriangulatedShellComponent.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

See Also

TriangulatedShellComponent Class


Dispose Method

[image]

Revit 2024 API
TriangulatedShellComponent..::..Dispose Method
TriangulatedShellComponent Class See Also Send Feedback
Releases all resources used by the TriangulatedShellComponent

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

TriangulatedShellComponent Class


GetVertex Method

[image]

Revit 2024 API
TriangulatedShellComponent..::..GetVertex Method
TriangulatedShellComponent Class See Also Send Feedback
Returns the vertex with a given index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public XYZ GetVertex(
    int vertexIndex
)
Visual Basic
Public Function GetVertex ( _
    vertexIndex As Integer _
) As XYZ
Visual C++
public:
XYZ^ GetVertex(
    int vertexIndex
)

Parameters

vertexIndex
Type: System..::..Int32
The index of the vertex (between 0 and getVertexCount()-1, inclusive).

Return Value

A copy of the requested vertex.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | vertexIndex is out of range.

See Also

TriangulatedShellComponent Class


GetVertices Method

[image]

Revit 2024 API
TriangulatedShellComponent..::..GetVertices Method
TriangulatedShellComponent Class See Also Send Feedback
Returns the vertices of the triangulation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public IList<XYZ> GetVertices()
Visual Basic
Public Function GetVertices As IList(Of XYZ)
Visual C++
public:
IList<XYZ^>^ GetVertices()

Return Value

The vertices of the triangulation.

See Also

TriangulatedShellComponent Class


IsClosed Property

[image]

Revit 2024 API
TriangulatedShellComponent..::..IsClosed Property
TriangulatedShellComponent Class See Also Send Feedback
True if and only if the triangulation represents a topologically closed shell (i.e., each edge is shared by two triangles).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool IsClosed { get; }
Visual Basic
Public ReadOnly Property IsClosed As Boolean
    Get
Visual C++
public:
property bool IsClosed {
    bool get ();
}

See Also

TriangulatedShellComponent Class


IsValidObject Property

[image]

Revit 2024 API
TriangulatedShellComponent..::..IsValidObject Property
TriangulatedShellComponent Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

TriangulatedShellComponent Class


VertexCount Property

[image]

Revit 2024 API
TriangulatedShellComponent..::..VertexCount Property
TriangulatedShellComponent Class See Also Send Feedback
The number of vertices in the triangulation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public int VertexCount { get; }
Visual Basic
Public ReadOnly Property VertexCount As Integer
    Get
Visual C++
public:
property int VertexCount {
    int get ();
}

See Also

TriangulatedShellComponent Class


TriangulatedSolidOrShell Class

[image]

Revit 2024 API
TriangulatedSolidOrShell Class
Members See Also Send Feedback
This class represents a triangulated solid or shell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public class TriangulatedSolidOrShell : IDisposable
Visual Basic
Public Class TriangulatedSolidOrShell _
    Implements IDisposable
Visual C++
public ref class TriangulatedSolidOrShell : IDisposable

Remarks

The triangulation consists of a number of TriangulatedShellComponents. For a solid, there will be one TriangulatedShellComponent for each component of the solid's boundary. For example, a solid cube has just one boundary component (containing six faces), so there will be just one TriangulatedShellComponent. A solid consisting of two disjoint cubes has two boundary components (the boundaries of the two cubes), so there will be two TriangulatedShellComponents. A solid consisting of a sphere with a round void (or hole) inside it also has two boundary components (the outer sphere and the inner sphere), so there will be two TriangulatedShellComponents.

For a shell, there will be one TriangulatedShellComponent for each component of the shell.

Note that this class does not contain information on the containment structure of the boundary components of a solid.

Be careful not to confuse the components of a solid with the solid's boundary components. This class deals only with the boundary components.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..TriangulatedSolidOrShell

See Also

TriangulatedSolidOrShell Members


TriangulatedSolidOrShell Members

[image] [image]

Revit 2024 API
TriangulatedSolidOrShell Members
TriangulatedSolidOrShell Class Methods Properties See Also Send Feedback

The TriangulatedSolidOrShell type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the TriangulatedSolidOrShell
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetShellComponent | Returns the specified shell component of a solid or shell. Input componentIndex must lie between 0 and ShellComponentCount-1, inclusive. The returned TriangulatedShellComponent should not be modified by the caller.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ShellComponentCount | The number of TriangulatedShellComponents that this TriangulatedSolidOrShell contains.

See Also

TriangulatedSolidOrShell Class


Dispose Method

[image]

Revit 2024 API
TriangulatedSolidOrShell..::..Dispose Method
TriangulatedSolidOrShell Class See Also Send Feedback
Releases all resources used by the TriangulatedSolidOrShell

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

TriangulatedSolidOrShell Class


GetShellComponent Method

[image]

Revit 2024 API
TriangulatedSolidOrShell..::..GetShellComponent Method
TriangulatedSolidOrShell Class See Also Send Feedback
Returns the specified shell component of a solid or shell. Input componentIndex must lie between 0 and ShellComponentCount-1, inclusive. The returned TriangulatedShellComponent should not be modified by the caller.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public TriangulatedShellComponent GetShellComponent(
    int componentIndex
)
Visual Basic
Public Function GetShellComponent ( _
    componentIndex As Integer _
) As TriangulatedShellComponent
Visual C++
public:
TriangulatedShellComponent^ GetShellComponent(
    int componentIndex
)

Parameters

componentIndex
Type: System..::..Int32
The component index, must be between 0 and ShellComponentCount â€“ 1, inclusive.

Return Value

The component.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Shell component index componentIndex is out of range.

See Also

TriangulatedSolidOrShell Class


TriangulatedSolidOrShell Properties

[image] [image]

Revit 2024 API
TriangulatedSolidOrShell Properties
TriangulatedSolidOrShell Class See Also Send Feedback

The TriangulatedSolidOrShell type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ShellComponentCount | The number of TriangulatedShellComponents that this TriangulatedSolidOrShell contains.

See Also

TriangulatedSolidOrShell Class


IsValidObject Property

[image]

Revit 2024 API
TriangulatedSolidOrShell..::..IsValidObject Property
TriangulatedSolidOrShell Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

TriangulatedSolidOrShell Class


ShellComponentCount Property

[image]

Revit 2024 API
TriangulatedSolidOrShell..::..ShellComponentCount Property
TriangulatedSolidOrShell Class See Also Send Feedback
The number of TriangulatedShellComponents that this TriangulatedSolidOrShell contains.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public int ShellComponentCount { get; }
Visual Basic
Public ReadOnly Property ShellComponentCount As Integer
    Get
Visual C++
public:
property int ShellComponentCount {
    int get ();
}

See Also

TriangulatedSolidOrShell Class


TriangulationInterface Class

[image]

Revit 2024 API
TriangulationInterface Class
Members See Also Send Feedback
This abstract class provides an interface for querying a triangulation structure (vertices and triangles).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public class TriangulationInterface : IDisposable
Visual Basic
Public Class TriangulationInterface _
    Implements IDisposable
Visual C++
public ref class TriangulationInterface : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..TriangulationInterface
Autodesk.Revit.DB..::..TriangulationInterfaceForTriangulatedShellComponent
Autodesk.Revit.DB..::..TriangulationInterfaceForTriangulatedSolidOrShell

See Also

TriangulationInterface Members


TriangulationInterface Members

[image] [image]

Revit 2024 API
TriangulationInterface Members
TriangulationInterface Class Methods Properties See Also Send Feedback

The TriangulationInterface type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the TriangulationInterface
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

TriangulationInterface Class


TriangulationInterface Methods

[image] [image]

Revit 2024 API
TriangulationInterface Methods
TriangulationInterface Class See Also Send Feedback

The TriangulationInterface type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TriangulationInterface Class


Dispose Method

[image]

Revit 2024 API
TriangulationInterface..::..Dispose Method
TriangulationInterface Class See Also Send Feedback
Releases all resources used by the TriangulationInterface

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

TriangulationInterface Class


TriangulationInterface Properties

[image] [image]

Revit 2024 API
TriangulationInterface Properties
TriangulationInterface Class See Also Send Feedback

The TriangulationInterface type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

TriangulationInterface Class


TriangulationInterfaceForTriangulatedShellComponent Class

[image]

Revit 2024 API
TriangulationInterfaceForTriangulatedShellComponent Class
Members See Also Send Feedback
This class is used to call FacetingUtils::convertTrianglesToQuads with a triangulation defined by a TriangulatedShellComponent.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public class TriangulationInterfaceForTriangulatedShellComponent : TriangulationInterface
Visual Basic
Public Class TriangulationInterfaceForTriangulatedShellComponent _
    Inherits TriangulationInterface
Visual C++
public ref class TriangulationInterfaceForTriangulatedShellComponent : public TriangulationInterface

Remarks

Compare to TriangulationInterfaceForTriangulatedSolidOrShell, which treats with the entire solid or shell as a single triangulated structure.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..TriangulationInterface
Autodesk.Revit.DB..::..TriangulationInterfaceForTriangulatedShellComponent

See Also

TriangulationInterfaceForTriangulatedShellComponent Members


TriangulationInterfaceForTriangulatedShellComponent Members

[image] [image]

Revit 2024 API
TriangulationInterfaceForTriangulatedShellComponent Members
TriangulationInterfaceForTriangulatedShellComponent Class Constructors Methods Properties See Also Send Feedback

The TriangulationInterfaceForTriangulatedShellComponent type exposes the following members.

Constructors

 | Name | Description
Public method | TriangulationInterfaceForTriangulatedShellComponent | Constructs an interface object for a TriangulatedShellComponent.

Methods

 | Name | Description
Public method | Dispose | (Inherited from TriangulationInterface.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from TriangulationInterface.)

See Also

TriangulationInterfaceForTriangulatedShellComponent Class


TriangulationInterfaceForTriangulatedShellComponent Constructor

[image]

Revit 2024 API
TriangulationInterfaceForTriangulatedShellComponent Constructor
TriangulationInterfaceForTriangulatedShellComponent Class See Also Send Feedback
Constructs an interface object for a TriangulatedShellComponent.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public TriangulationInterfaceForTriangulatedShellComponent(
    TriangulatedShellComponent externalTriangulatedShellComponent
)
Visual Basic
Public Sub New ( _
    externalTriangulatedShellComponent As TriangulatedShellComponent _
)
Visual C++
public:
TriangulationInterfaceForTriangulatedShellComponent(
    TriangulatedShellComponent^ externalTriangulatedShellComponent
)

Parameters

externalTriangulatedShellComponent
Type: Autodesk.Revit.DB..::..TriangulatedShellComponent
The TriangulatedShellComponent that the interface object represents.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

TriangulationInterfaceForTriangulatedShellComponent Class


TriangulationInterfaceForTriangulatedShellComponent Properties

[image] [image]

Revit 2024 API
TriangulationInterfaceForTriangulatedShellComponent Properties
TriangulationInterfaceForTriangulatedShellComponent Class See Also Send Feedback

The TriangulationInterfaceForTriangulatedShellComponent type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from TriangulationInterface.)

See Also

TriangulationInterfaceForTriangulatedShellComponent Class


TriangulationInterfaceForTriangulatedSolidOrShell Members

[image] [image]

Revit 2024 API
TriangulationInterfaceForTriangulatedSolidOrShell Members
TriangulationInterfaceForTriangulatedSolidOrShell Class Constructors Methods Properties See Also Send Feedback

The TriangulationInterfaceForTriangulatedSolidOrShell type exposes the following members.

Constructors

 | Name | Description
Public method | TriangulationInterfaceForTriangulatedSolidOrShell | Construct an interface object for a TriangulatedSolidOrShell.

Methods

 | Name | Description
Public method | Dispose | (Inherited from TriangulationInterface.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from TriangulationInterface.)

See Also

TriangulationInterfaceForTriangulatedSolidOrShell Class


TriangulationInterfaceForTriangulatedSolidOrShell Constructor

[image]

Revit 2024 API
TriangulationInterfaceForTriangulatedSolidOrShell Constructor
TriangulationInterfaceForTriangulatedSolidOrShell Class See Also Send Feedback
Construct an interface object for a TriangulatedSolidOrShell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public TriangulationInterfaceForTriangulatedSolidOrShell(
    TriangulatedSolidOrShell externalTriangulatedSolidOrShell
)
Visual Basic
Public Sub New ( _
    externalTriangulatedSolidOrShell As TriangulatedSolidOrShell _
)
Visual C++
public:
TriangulationInterfaceForTriangulatedSolidOrShell(
    TriangulatedSolidOrShell^ externalTriangulatedSolidOrShell
)

Parameters

externalTriangulatedSolidOrShell
Type: Autodesk.Revit.DB..::..TriangulatedSolidOrShell
The TriangulatedSolidOrShell that the interface object represents.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

TriangulationInterfaceForTriangulatedSolidOrShell Class


TriangulationInterfaceForTriangulatedSolidOrShell Methods

[image] [image]

Revit 2024 API
TriangulationInterfaceForTriangulatedSolidOrShell Methods
TriangulationInterfaceForTriangulatedSolidOrShell Class See Also Send Feedback

The TriangulationInterfaceForTriangulatedSolidOrShell type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from TriangulationInterface.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TriangulationInterfaceForTriangulatedSolidOrShell Class


TriangulationInterfaceForTriangulatedSolidOrShell Properties

[image] [image]

Revit 2024 API
TriangulationInterfaceForTriangulatedSolidOrShell Properties
TriangulationInterfaceForTriangulatedSolidOrShell Class See Also Send Feedback

The TriangulationInterfaceForTriangulatedSolidOrShell type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from TriangulationInterface.)

See Also

TriangulationInterfaceForTriangulatedSolidOrShell Class


TriOrQuadFacet Class

[image]

Revit 2024 API
TriOrQuadFacet Class
Members See Also Send Feedback
This class represents a triangle or quadrilateral in a faceted structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public class TriOrQuadFacet : IDisposable
Visual Basic
Public Class TriOrQuadFacet _
    Implements IDisposable
Visual C++
public ref class TriOrQuadFacet : IDisposable

Remarks

This class defines a triangle or quadrilateral with reference to an external triangulation structure. The vertices of this TriOrQuadFacet are indices into the triangulation structure's array of vertices.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..TriOrQuadFacet

See Also

TriOrQuadFacet Members


TriOrQuadFacet Members

[image] [image]

Revit 2024 API
TriOrQuadFacet Members
TriOrQuadFacet Class Methods Properties See Also Send Feedback

The TriOrQuadFacet type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the TriOrQuadFacet
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVertexIndex | Returns the index of the specified vertex of this facet (as an index into the external array of vertices in the TriangulationInterface that was used to create the list of TriOrQuadFacets).
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Normal | A unit normal vector for this facet.
Public property | NumberOfVertices | The number of vertices (3 for a triangle, 4 for a quadrilateral, 0 for an unset TriOrQuadFacet).

See Also

TriOrQuadFacet Class


TriOrQuadFacet Methods

[image] [image]

Revit 2024 API
TriOrQuadFacet Methods
TriOrQuadFacet Class See Also Send Feedback

The TriOrQuadFacet type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVertexIndex | Returns the index of the specified vertex of this facet (as an index into the external array of vertices in the TriangulationInterface that was used to create the list of TriOrQuadFacets).
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TriOrQuadFacet Class


Dispose Method

[image]

Revit 2024 API
TriOrQuadFacet..::..Dispose Method
TriOrQuadFacet Class See Also Send Feedback
Releases all resources used by the TriOrQuadFacet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

TriOrQuadFacet Class


GetVertexIndex Method

[image]

Revit 2024 API
TriOrQuadFacet..::..GetVertexIndex Method
TriOrQuadFacet Class See Also Send Feedback
Returns the index of the specified vertex of this facet (as an index into the external array of vertices in the TriangulationInterface that was used to create the list of TriOrQuadFacets).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public int GetVertexIndex(
    int index
)
Visual Basic
Public Function GetVertexIndex ( _
    index As Integer _
) As Integer
Visual C++
public:
int GetVertexIndex(
    int index
)

Parameters

index
Type: System..::..Int32
Index of the desired vertex in this TriOrQuadFacet (between 0 and NumberOfVertices-1, inclusive).

Return Value

The index of the specified vertex in the external array of vertices (only valid if NumberOfVertices >= 3).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | index is out of range..

See Also

TriOrQuadFacet Class


TriOrQuadFacet Properties

[image] [image]

Revit 2024 API
TriOrQuadFacet Properties
TriOrQuadFacet Class See Also Send Feedback

The TriOrQuadFacet type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Normal | A unit normal vector for this facet.
Public property | NumberOfVertices | The number of vertices (3 for a triangle, 4 for a quadrilateral, 0 for an unset TriOrQuadFacet).

See Also

TriOrQuadFacet Class


IsValidObject Property

[image]

Revit 2024 API
TriOrQuadFacet..::..IsValidObject Property
TriOrQuadFacet Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

TriOrQuadFacet Class


Normal Property

[image]

Revit 2024 API
TriOrQuadFacet..::..Normal Property
TriOrQuadFacet Class See Also Send Feedback
A unit normal vector for this facet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public XYZ Normal { get; }
Visual Basic
Public ReadOnly Property Normal As XYZ
    Get
Visual C++
public:
property XYZ^ Normal {
    XYZ^ get ();
}

See Also

TriOrQuadFacet Class


NumberOfVertices Property

[image]

Revit 2024 API
TriOrQuadFacet..::..NumberOfVertices Property
TriOrQuadFacet Class See Also Send Feedback
The number of vertices (3 for a triangle, 4 for a quadrilateral, 0 for an unset TriOrQuadFacet).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public int NumberOfVertices { get; }
Visual Basic
Public ReadOnly Property NumberOfVertices As Integer
    Get
Visual C++
public:
property int NumberOfVertices {
    int get ();
}

See Also

TriOrQuadFacet Class


TypeBinding Members

[image] [image]

Revit 2024 API
TypeBinding Members
TypeBinding Class Constructors Methods Properties See Also Send Feedback

The TypeBinding type exposes the following members.

Constructors

 | Name | Description
Public method | TypeBinding()()()() | Constructs an empty type binding.
Public method | TypeBinding(CategorySet) | Constructs a type binding with the set of categories passed.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Categories | Retrieve or set the categories to which a parameter definition will be bound. (Inherited from ElementBinding.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

TypeBinding Class


TypeBinding Constructor

[image] [image]

Revit 2024 API
TypeBinding Constructor
TypeBinding Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TypeBinding()()()() | Constructs an empty type binding.
Public method | TypeBinding(CategorySet) | Constructs a type binding with the set of categories passed.

See Also

TypeBinding Class
TypeBinding Members


TypeBinding Methods

[image] [image]

Revit 2024 API
TypeBinding Methods
TypeBinding Class See Also Send Feedback

The TypeBinding type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TypeBinding Class


TypeBinding Properties

[image] [image]

Revit 2024 API
TypeBinding Properties
TypeBinding Class See Also Send Feedback

The TypeBinding type exposes the following members.

Properties

 | Name | Description
Public property | Categories | Retrieve or set the categories to which a parameter definition will be bound. (Inherited from ElementBinding.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

TypeBinding Class


UnderlayOrientation Enumeration

[image]

Revit 2024 API
UnderlayOrientation Enumeration
See Also Send Feedback
Indicates how elements in the underlay are viewed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum UnderlayOrientation
Visual Basic
Public Enumeration UnderlayOrientation
Visual C++
public enum class UnderlayOrientation

Members

Member name | Description
LookingDown | Underlay elements are viewed as if looking down from above.
LookingUp | Underlay elements are viewed as if looking up from below.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


UnitFormatUtils Class

[image]

Revit 2024 API
UnitFormatUtils Class
Members See Also Send Feedback
A utility class for formatting and parsing numbers with units.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static class UnitFormatUtils
Visual Basic
Public NotInheritable Class UnitFormatUtils
Visual C++
public ref class UnitFormatUtils abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..UnitFormatUtils

See Also

UnitFormatUtils Members


UnitFormatUtils Members

[image] [image]

Revit 2024 API
UnitFormatUtils Members
UnitFormatUtils Class Methods See Also Send Feedback

Methods

Name | Description
Format(Units, ForgeTypeId, Double, Boolean) | Formats a number with units into a string.
Format(Units, ForgeTypeId, Double, Boolean, FormatValueOptions) | Formats a number with units into a string.
TryParse(Units, ForgeTypeId, String, Double%) | Parses a formatted string into a number with units if possible.
TryParse(Units, ForgeTypeId, String, ValueParsingOptions, Double%) | Parses a formatted string into a number with units if possible.
TryParse(Units, ForgeTypeId, String, Double%, String%) | Parses a formatted string into a number with units if possible.
TryParse(Units, ForgeTypeId, String, ValueParsingOptions, Double%, String%) | Parses a formatted string into a number with units if possible.

See Also

UnitFormatUtils Class


UnitFormatUtils Methods

[image] [image]

Revit 2024 API
UnitFormatUtils Methods
UnitFormatUtils Class See Also Send Feedback

Methods

Name | Description
Format(Units, ForgeTypeId, Double, Boolean) | Formats a number with units into a string.
Format(Units, ForgeTypeId, Double, Boolean, FormatValueOptions) | Formats a number with units into a string.
TryParse(Units, ForgeTypeId, String, Double%) | Parses a formatted string into a number with units if possible.
TryParse(Units, ForgeTypeId, String, ValueParsingOptions, Double%) | Parses a formatted string into a number with units if possible.
TryParse(Units, ForgeTypeId, String, Double%, String%) | Parses a formatted string into a number with units if possible.
TryParse(Units, ForgeTypeId, String, ValueParsingOptions, Double%, String%) | Parses a formatted string into a number with units if possible.

See Also

UnitFormatUtils Class


Format Method

[image] [image]

Revit 2024 API
UnitFormatUtils..::..Format Method
UnitFormatUtils Class See Also Send Feedback

Overload List

Name | Description
Format(Units, ForgeTypeId, Double, Boolean) | Formats a number with units into a string.
Format(Units, ForgeTypeId, Double, Boolean, FormatValueOptions) | Formats a number with units into a string.

See Also

UnitFormatUtils Class
UnitFormatUtils Members


Format Method (Units, ForgeTypeId, Double, Boolean, FormatValueOptions)

[image]

Revit 2024 API
UnitFormatUtils..::..Format Method (Units, ForgeTypeId, Double, Boolean, FormatValueOptions)
UnitFormatUtils Class See Also Send Feedback
Formats a number with units into a string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static string Format(
    Units units,
    ForgeTypeId specTypeId,
    double value,
    bool forEditing,
    FormatValueOptions formatValueOptions
)
Visual Basic
Public Shared Function Format ( _
    units As Units, _
    specTypeId As ForgeTypeId, _
    value As Double, _
    forEditing As Boolean, _
    formatValueOptions As FormatValueOptions _
) As String
Visual C++
public:
static String^ Format(
    Units^ units,
    ForgeTypeId^ specTypeId,
    double value,
    bool forEditing,
    FormatValueOptions^ formatValueOptions
)

Parameters

units
Type: Autodesk.Revit.DB..::..Units
The units formatting settings, typically obtained from Document.GetUnits().
specTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
Identifier of the spec of the value to format.
value
Type: System..::..Double
The value to format, in Revit's internal units.
forEditing
Type: System..::..Boolean
True if the formatting should be modified as necessary so that the formatted string can be successfully parsed, for example by suppressing digit grouping. False if unmodified settings should be used, suitable for display only.
formatValueOptions
Type: Autodesk.Revit.DB..::..FormatValueOptions
Additional formatting options.

Return Value

The formatted string.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | specTypeId is not a measurable spec identifier. See UnitUtils.IsMeasurableSpec(ForgeTypeId). -or- The given value for value is not finite -or- The unit in the FormatOptions in formatValueOptions is not a valid unit for specTypeId. See UnitUtils.IsValidUnit(ForgeTypeId, ForgeTypeId) and UnitUtils.GetValidUnits(ForgeTypeId).
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

UnitFormatUtils Class
Format Overload


TryParse Method

[image] [image]

Revit 2024 API
UnitFormatUtils..::..TryParse Method
UnitFormatUtils Class See Also Send Feedback

Overload List

Name | Description
TryParse(Units, ForgeTypeId, String, Double%) | Parses a formatted string into a number with units if possible.
TryParse(Units, ForgeTypeId, String, ValueParsingOptions, Double%) | Parses a formatted string into a number with units if possible.
TryParse(Units, ForgeTypeId, String, Double%, String%) | Parses a formatted string into a number with units if possible.
TryParse(Units, ForgeTypeId, String, ValueParsingOptions, Double%, String%) | Parses a formatted string into a number with units if possible.

See Also

UnitFormatUtils Class
UnitFormatUtils Members


TryParse Method (Units, ForgeTypeId, String, Double)

[image]

Revit 2024 API
UnitFormatUtils..::..TryParse Method (Units, ForgeTypeId, String, Double%)
UnitFormatUtils Class See Also Send Feedback
Parses a formatted string into a number with units if possible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static bool TryParse(
    Units units,
    ForgeTypeId specTypeId,
    string stringToParse,
    out double value
)
Visual Basic
Public Shared Function TryParse ( _
    units As Units, _
    specTypeId As ForgeTypeId, _
    stringToParse As String, _
    <OutAttribute> ByRef value As Double _
) As Boolean
Visual C++
public:
static bool TryParse(
    Units^ units,
    ForgeTypeId^ specTypeId,
    String^ stringToParse,
    [OutAttribute] double% value
)

Parameters

units
Type: Autodesk.Revit.DB..::..Units
The units formatting settings, typically obtained from Document.GetUnits().
specTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
Identifier of the target spec for the value.
stringToParse
Type: System..::..String
The string to parse.
value
Type: System..::..Double%
The parsed value. Ignore this value if the function returns false.

Return Value

True if the string can be parsed, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | specTypeId is not a measurable spec identifier. See UnitUtils.IsMeasurableSpec(ForgeTypeId).
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

UnitFormatUtils Class
TryParse Overload


TryParse Method (Units, ForgeTypeId, String, ValueParsingOptions, Double)

[image]

Revit 2024 API
UnitFormatUtils..::..TryParse Method (Units, ForgeTypeId, String, ValueParsingOptions, Double%)
UnitFormatUtils Class See Also Send Feedback
Parses a formatted string into a number with units if possible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static bool TryParse(
    Units units,
    ForgeTypeId specTypeId,
    string stringToParse,
    ValueParsingOptions valueParsingOptions,
    out double value
)
Visual Basic
Public Shared Function TryParse ( _
    units As Units, _
    specTypeId As ForgeTypeId, _
    stringToParse As String, _
    valueParsingOptions As ValueParsingOptions, _
    <OutAttribute> ByRef value As Double _
) As Boolean
Visual C++
public:
static bool TryParse(
    Units^ units,
    ForgeTypeId^ specTypeId,
    String^ stringToParse,
    ValueParsingOptions^ valueParsingOptions,
    [OutAttribute] double% value
)

Parameters

units
Type: Autodesk.Revit.DB..::..Units
The units formatting settings, typically obtained from Document.GetUnits().
specTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
Identifier of the target spec for the value.
stringToParse
Type: System..::..String
The string to parse.
valueParsingOptions
Type: Autodesk.Revit.DB..::..ValueParsingOptions
Additional parsing options.
value
Type: System..::..Double%
The parsed value. Ignore this value if the function returns false.

Return Value

True if the string can be parsed, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | specTypeId is not a measurable spec identifier. See UnitUtils.IsMeasurableSpec(ForgeTypeId). -or- The unit in the FormatOptions in valueParsingOptions is not a valid unit for specTypeId. See UnitUtils.IsValidUnit(ForgeTypeId, ForgeTypeId) and UnitUtils.GetValidUnits(ForgeTypeId).
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

UnitFormatUtils Class
TryParse Overload


TryParse Method (Units, ForgeTypeId, String, Double, String)

[image]

Revit 2024 API
UnitFormatUtils..::..TryParse Method (Units, ForgeTypeId, String, Double%, String%)
UnitFormatUtils Class See Also Send Feedback
Parses a formatted string into a number with units if possible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static bool TryParse(
    Units units,
    ForgeTypeId specTypeId,
    string stringToParse,
    out double value,
    out string message
)
Visual Basic
Public Shared Function TryParse ( _
    units As Units, _
    specTypeId As ForgeTypeId, _
    stringToParse As String, _
    <OutAttribute> ByRef value As Double, _
    <OutAttribute> ByRef message As String _
) As Boolean
Visual C++
public:
static bool TryParse(
    Units^ units,
    ForgeTypeId^ specTypeId,
    String^ stringToParse,
    [OutAttribute] double% value,
    [OutAttribute] String^% message
)

Parameters

units
Type: Autodesk.Revit.DB..::..Units
The units formatting settings, typically obtained from Document.GetUnits().
specTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
Identifier of the target spec for the value.
stringToParse
Type: System..::..String
The string to parse.
value
Type: System..::..Double%
The parsed value. Ignore this value if the function returns false.
message
Type: System..::..String%
A localized message that, if the parsing fails, explains the reason for failure.

Return Value

True if the string can be parsed, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | specTypeId is not a measurable spec identifier. See UnitUtils.IsMeasurableSpec(ForgeTypeId).
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

UnitFormatUtils Class
TryParse Overload


TryParse Method (Units, ForgeTypeId, String, ValueParsingOptions, Double, String)

[image]

Revit 2024 API
UnitFormatUtils..::..TryParse Method (Units, ForgeTypeId, String, ValueParsingOptions, Double%, String%)
UnitFormatUtils Class See Also Send Feedback
Parses a formatted string into a number with units if possible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static bool TryParse(
    Units units,
    ForgeTypeId specTypeId,
    string stringToParse,
    ValueParsingOptions valueParsingOptions,
    out double value,
    out string message
)
Visual Basic
Public Shared Function TryParse ( _
    units As Units, _
    specTypeId As ForgeTypeId, _
    stringToParse As String, _
    valueParsingOptions As ValueParsingOptions, _
    <OutAttribute> ByRef value As Double, _
    <OutAttribute> ByRef message As String _
) As Boolean
Visual C++
public:
static bool TryParse(
    Units^ units,
    ForgeTypeId^ specTypeId,
    String^ stringToParse,
    ValueParsingOptions^ valueParsingOptions,
    [OutAttribute] double% value,
    [OutAttribute] String^% message
)

Parameters

units
Type: Autodesk.Revit.DB..::..Units
The units formatting settings, typically obtained from Document.GetUnits().
specTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
Identifier of the target spec for the value.
stringToParse
Type: System..::..String
The string to parse.
valueParsingOptions
Type: Autodesk.Revit.DB..::..ValueParsingOptions
Additional parsing options.
value
Type: System..::..Double%
The parsed value. Ignore this value if the function returns false.
message
Type: System..::..String%
A localized message that, if the parsing fails, explains the reason for failure.

Return Value

True if the string can be parsed, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | specTypeId is not a measurable spec identifier. See UnitUtils.IsMeasurableSpec(ForgeTypeId). -or- The unit in the FormatOptions in valueParsingOptions is not a valid unit for specTypeId. See UnitUtils.IsValidUnit(ForgeTypeId, ForgeTypeId) and UnitUtils.GetValidUnits(ForgeTypeId).
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

UnitFormatUtils Class
TryParse Overload


Units Class

[image]

Revit 2024 API
Units Class
Members See Also Send Feedback
A document's default settings for formatting numbers with units.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class Units : IDisposable
Visual Basic
Public Class Units _
    Implements IDisposable
Visual C++
public ref class Units : IDisposable

Remarks

The Units class represents a document's default settings for formatting numbers with units as strings. It contains a FormatOptions object for each unit type as well as settings related to decimal symbol and digit grouping.

The Units class stores a FormatOptions object for every valid unit type, but not all of them can be directly modified. Some, like UT_Number and UT_SiteAngle, have fixed definitions. Others have definitions which are automatically derived from other unit types. For example, UT_SheetLength is derived from UT_Length and UT_ForceScale is derived from UT_Force. See IsModifiableUnitType() and GetModifiableUnitTypes().

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Units

See Also

Units Members


Units Constructor

[image]

Revit 2024 API
Units Constructor
Units Class See Also Send Feedback
Creates a new Units object with default settings for Metric or Imperial units.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public Units(
    UnitSystem unitSystem
)
Visual Basic
Public Sub New ( _
    unitSystem As UnitSystem _
)
Visual C++
public:
Units(
    UnitSystem unitSystem
)

Parameters

unitSystem
Type: Autodesk.Revit.DB..::..UnitSystem
Indicates whether the Units object should be initialized with default settings for Metric or Imperial units.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

Units Class


Units Methods

[image] [image]

Revit 2024 API
Units Methods
Units Class See Also Send Feedback

The Units type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetFormatOptions | Gets the default FormatOptions for a spec.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetModifiableSpecs | Gets all specs for which the default FormatOptions can be modified.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsModifiableSpec | Checks whether the default FormatOptions can be modified for a given spec.
Public method | SetFormatOptions | Sets the default FormatOptions for a spec.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Units Class


Dispose Method

[image]

Revit 2024 API
Units..::..Dispose Method
Units Class See Also Send Feedback
Releases all resources used by the Units

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

Units Class


GetFormatOptions Method

[image]

Revit 2024 API
Units..::..GetFormatOptions Method
Units Class See Also Send Feedback
Gets the default FormatOptions for a spec.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public FormatOptions GetFormatOptions(
    ForgeTypeId specTypeId
)
Visual Basic
Public Function GetFormatOptions ( _
    specTypeId As ForgeTypeId _
) As FormatOptions
Visual C++
public:
FormatOptions^ GetFormatOptions(
    ForgeTypeId^ specTypeId
)

Parameters

specTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
Identifier of the spec.

Return Value

A copy of the FormatOptions.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | specTypeId is not a measurable spec identifier. See UnitUtils.IsMeasurableSpec(ForgeTypeId).
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Units Class


SetFormatOptions Method

[image]

Revit 2024 API
Units..::..SetFormatOptions Method
Units Class See Also Send Feedback
Sets the default FormatOptions for a spec.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void SetFormatOptions(
    ForgeTypeId specTypeId,
    FormatOptions options
)
Visual Basic
Public Sub SetFormatOptions ( _
    specTypeId As ForgeTypeId, _
    options As FormatOptions _
)
Visual C++
public:
void SetFormatOptions(
    ForgeTypeId^ specTypeId,
    FormatOptions^ options
)

Parameters

specTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
Identifier of the spec.
options
Type: Autodesk.Revit.DB..::..FormatOptions
The FormatOptions.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | specTypeId is not a measurable spec identifier. See UnitUtils.IsMeasurableSpec(ForgeTypeId). -or- FormatOptions cannot be modified for specTypeId. See Units.IsModifiableSpec(ForgeTypeId) and Units.GetModifiableSpecs(). -or- UseDefault is true in options. -or- The unit in options is not valid for specTypeId. See UnitUtils.IsValidUnit(ForgeTypeId, ForgeTypeId) and UnitUtils.GetValidUnits(ForgeTypeId). -or- The rounding method in options is not set to Nearest.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Units Class


Units Properties

[image] [image]

Revit 2024 API
Units Properties
Units Class See Also Send Feedback

The Units type exposes the following members.

Properties

 | Name | Description
Public property | DecimalSymbol | The symbol used to separate the integer and fractional parts of a number.
Public property | DigitGroupingAmount | The number of digits in each group when numbers are formatted with digit grouping.
Public property | DigitGroupingSymbol | The symbol used to separate groups of digits when numbers are formatted with digit grouping.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

Units Class


DecimalSymbol Property

[image]

Revit 2024 API
Units..::..DecimalSymbol Property
Units Class See Also Send Feedback
The symbol used to separate the integer and fractional parts of a number.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public DecimalSymbol DecimalSymbol { get; set; }
Visual Basic
Public Property DecimalSymbol As DecimalSymbol
    Get
    Set
Visual C++
public:
property DecimalSymbol DecimalSymbol {
    DecimalSymbol get ();
    void set (DecimalSymbol value);
}

Field Value

The decimal symbol. The default is Dot.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

Units Class


DigitGroupingAmount Property

[image]

Revit 2024 API
Units..::..DigitGroupingAmount Property
Units Class See Also Send Feedback
The number of digits in each group when numbers are formatted with digit grouping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public DigitGroupingAmount DigitGroupingAmount { get; set; }
Visual Basic
Public Property DigitGroupingAmount As DigitGroupingAmount
    Get
    Set
Visual C++
public:
property DigitGroupingAmount DigitGroupingAmount {
    DigitGroupingAmount get ();
    void set (DigitGroupingAmount value);
}

Field Value

The number of digits in each group. The default is Three.

Remarks

This setting only has an effect when the UseDigitGrouping property is set to true in the FormatOptions object for the unit type being formatted.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

Units Class


DigitGroupingSymbol Property

[image]

Revit 2024 API
Units..::..DigitGroupingSymbol Property
Units Class See Also Send Feedback
The symbol used to separate groups of digits when numbers are formatted with digit grouping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public DigitGroupingSymbol DigitGroupingSymbol { get; set; }
Visual Basic
Public Property DigitGroupingSymbol As DigitGroupingSymbol
    Get
    Set
Visual C++
public:
property DigitGroupingSymbol DigitGroupingSymbol {
    DigitGroupingSymbol get ();
    void set (DigitGroupingSymbol value);
}

Field Value

The digit grouping symbol. The default is Comma.

Remarks

This setting only has an effect when the UseDigitGrouping property is set to true in the FormatOptions object for the unit type being formatted.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

Units Class


IsValidObject Property

[image]

Revit 2024 API
Units..::..IsValidObject Property
Units Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

Units Class


UnitSystem Enumeration

[image]

Revit 2024 API
UnitSystem Enumeration
See Also Send Feedback
A system of measurement: Metric or Imperial units.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014
Since: 2014

Syntax

C#
public enum UnitSystem
Visual Basic
Public Enumeration UnitSystem
Visual C++
public enum class UnitSystem

Members

Member name | Description
Metric | Metric units.
Imperial | Imperial units.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


UnitTypeId Class

[image]

Revit 2024 API
UnitTypeId Class
Members See Also Send Feedback
This class contains constants identifying units of measurement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static class UnitTypeId
Visual Basic
Public NotInheritable Class UnitTypeId
Visual C++
public ref class UnitTypeId abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..UnitTypeId

See Also

UnitTypeId Members


UnitTypeId Members

[image] [image]

Revit 2024 API
UnitTypeId Members
UnitTypeId Class Properties See Also Send Feedback

The UnitTypeId type exposes the following members.

Properties

Name | Description
Acres | Acres.
Amperes | Amperes.
Atmospheres | Atmospheres.
Bars | Bars.
BritishThermalUnits | British thermal units.
BritishThermalUnitsPerDegreeFahrenheit | British thermal units per degree Fahrenheit.
BritishThermalUnitsPerHour | British thermal units per hour.
BritishThermalUnitsPerHourCubicFoot | British thermal units per hour cubic foot.
BritishThermalUnitsPerHourFootDegreeFahrenheit | British thermal units per hour foot degree Fahrenheit.
BritishThermalUnitsPerHourSquareFoot | British thermal units per hour square foot.
BritishThermalUnitsPerHourSquareFootDegreeFahrenheit | British thermal units per hour square foot degree Fahrenheit.
BritishThermalUnitsPerPound | British thermal units per pound.
BritishThermalUnitsPerPoundDegreeFahrenheit | British thermal units per pound degree Fahrenheit.
BritishThermalUnitsPerSecond | British thermal units per second.
BritishThermalUnitsPerSquareFootDegreeFahrenheit | British thermal units per square foot degree Fahrenheit.
Calories | Calories.
CaloriesPerSecond | Calories per second.
Candelas | Candelas.
CandelasPerSquareFoot | Candelas per square foot.
CandelasPerSquareMeter | Candelas per square meter.
Celsius | Celsius.
CelsiusInterval | Celsius interval.
Centimeters | Centimeters.
CentimetersPerMinute | Centimeters per minute.
CentimetersToTheFourthPower | Centimeters to the fourth power.
CentimetersToTheSixthPower | Centimeters to the sixth power.
Centipoises | Centipoises.
CubicCentimeters | Cubic centimeters.
CubicFeet | Cubic feet.
CubicFeetPerHour | Cubic feet per hour.
CubicFeetPerKip | Cubic feet per kip.
CubicFeetPerMinute | Cubic feet per minute.
CubicFeetPerMinuteCubicFoot | Cubic feet per minute cubic foot.
CubicFeetPerMinutePerBritishThermalUnitPerHour | Cubic feet per minute per British thermal unit per hour.
CubicFeetPerMinuteSquareFoot | Cubic feet per minute square foot.
CubicFeetPerMinuteTonOfRefrigeration | Cubic feet per minute ton of refrigeration.
CubicFeetPerPoundMass | Cubic feet per pound mass.
CubicInches | Cubic inches.
CubicMeters | Cubic meters.
CubicMetersPerHour | Cubic meters per hour.
CubicMetersPerHourCubicMeter | Cubic meters per hour cubic meter.
CubicMetersPerHourSquareMeter | Cubic meters per hour square meter.
CubicMetersPerKilogram | Cubic meters per kilogram.
CubicMetersPerKilonewton | Cubic meters per kilonewton.
CubicMetersPerSecond | Cubic meters per second.
CubicMetersPerWattSecond | Cubic meters per watt second.
CubicMillimeters | Cubic millimeters.
CubicYards | Cubic yards.
Currency | Currency.
CurrencyPerBritishThermalUnit | Cost per British thermal unit.
CurrencyPerBritishThermalUnitPerHour | Cost per British thermal unit per hour.
CurrencyPerSquareFoot | Cost per square foot.
CurrencyPerSquareMeter | Cost per square meter.
CurrencyPerWatt | Cost per watt.
CurrencyPerWattHour | Cost per watt hour.
Custom | Unrecognized custom unit.
CyclesPerSecond | Cycles per second.
Decimeters | Decimeters.
Degrees | Degrees.
DegreesMinutes | Degrees minutes seconds.
DekanewtonMeters | Dekanewton meters.
DekanewtonMetersPerMeter | Dekanewton meters per meter.
Dekanewtons | Dekanewtons.
DekanewtonsPerMeter | Dekanewtons per meter.
DekanewtonsPerSquareMeter | Dekanewtons per square meter.
Fahrenheit | Fahrenheit.
FahrenheitInterval | Fahrenheit interval.
Feet | Feet.
FeetFractionalInches | Feet and fractional inches.
FeetOfWater39_2DegreesFahrenheit | Feet of water (39.2 Â°F).
FeetOfWater39_2DegreesFahrenheitPer100Feet | Feet of water (39.2 Â°F) per 100 feet.
FeetPerKip | Feet per kip.
FeetPerMinute | Feet per minute.
FeetPerSecond | Feet per second.
FeetPerSecondSquared | Feet per second squared.
FeetToTheFourthPower | Feet to the fourth power.
FeetToTheSixthPower | Feet to the sixth power.
Fixed | Fixed.
Footcandles | Footcandles.
Footlamberts | Footlamberts.
FractionalInches | Fractional inches.
General | General.
Gradians | Gradians.
GrainsPerHourSquareFootInchMercury | Grains per hour square foot inch mercury.
Hectares | Hectares.
Hertz | Hertz.
Horsepower | Horsepower.
Hours | Hours.
HourSquareFootDegreesFahrenheitPerBritishThermalUnit | Hour square foot degrees Fahrenheit per British thermal unit.
Inches | Inches.
InchesOfMercury32DegreesFahrenheit | Inches of mercury (32 Â°F).
InchesOfWater60DegreesFahrenheit | Inches of water (60 Â°F).
InchesOfWater60DegreesFahrenheitPer100Feet | Inches of water (60 Â°F) per 100 feet.
InchesPerSecondSquared | Inches per second squared.
InchesToTheFourthPower | Inches to the fourth power.
InchesToTheSixthPower | Inches to the sixth power.
InverseDegreesCelsius | Inverse degrees Celsius.
InverseDegreesFahrenheit | Inverse degrees Fahrenheit.
InverseKilonewtons | Inverse kilonewtons.
InverseKips | Inverse kips.
Joules | Joules.
JoulesPerGram | Joules per gram.
JoulesPerGramDegreeCelsius | Joules per gram degree Celsius.
JoulesPerKelvin | Joules per Kelvin.
JoulesPerKilogramDegreeCelsius | Joules per kilogram degree Celsius.
JoulesPerSquareMeterKelvin | Joules per square meter Kelvin.
Kelvin | Kelvin.
KelvinInterval | Kelvin interval.
Kiloamperes | Kiloamperes.
Kilocalories | Kilocalories.
KilocaloriesPerSecond | Kilocalories per second.
KilogramForceMeters | Kilogram force meters.
KilogramForceMetersPerMeter | Kilogram force meters per meter.
Kilograms | Kilograms.
KilogramsForce | Kilograms force.
KilogramsForcePerMeter | Kilograms force per meter.
KilogramsForcePerSquareMeter | Kilograms force per square meter.
KilogramsPerCubicMeter | Kilograms per cubic meter.
KilogramsPerHour | Kilograms per hour.
KilogramsPerKilogramKelvin | Kilograms per kilogram kelvin.
KilogramsPerMeter | Kilograms per meter.
KilogramsPerMeterHour | Kilograms per meter hour.
KilogramsPerMeterSecond | Kilograms per meter second.
KilogramsPerMinute | Kilograms per minute.
KilogramsPerSecond | Kilograms per second.
KilogramsPerSquareMeter | Kilograms per square meter.
Kilojoules | Kilojoules.
KilojoulesPerKelvin | Kilojoules per Kelvin.
KilojoulesPerSquareMeterKelvin | Kilojoules per square meter Kelvin.
KilometersPerHour | Kilometers per hour.
KilometersPerSecondSquared | Kilometers per second squared.
KilonewtonMeters | Kilonewton meters.
KilonewtonMetersPerDegree | Kilonewton meters per degree.
KilonewtonMetersPerDegreePerMeter | Kilonewton meters per degree per meter.
KilonewtonMetersPerMeter | Kilonewton meters per meter.
Kilonewtons | Kilonewtons.
KilonewtonsPerCubicMeter | Kilonewtons per cubic meter.
KilonewtonsPerMeter | Kilonewtons per meter.
KilonewtonsPerSquareCentimeter | Kilonewtons per square centimeter.
KilonewtonsPerSquareMeter | Kilonewtons per square meter.
KilonewtonsPerSquareMillimeter | Kilonewtons per square millimeter.
Kilopascals | Kilopascals.
KilovoltAmperes | Kilovolt amperes.
Kilovolts | Kilovolts.
KilowattHours | Kilowatt hours.
Kilowatts | Kilowatts.
KipFeet | Kip feet.
KipFeetPerDegree | Kip feet per degree.
KipFeetPerDegreePerFoot | Kip feet per degree per foot.
KipFeetPerFoot | Kip feet per foot.
Kips | Kips.
KipsPerCubicFoot | Kips per cubic foot.
KipsPerCubicInch | Kips per cubic inch.
KipsPerFoot | Kips per foot.
KipsPerInch | Kips per inch.
KipsPerSquareFoot | Kips per square foot.
KipsPerSquareInch | Kips per square inch.
Liters | Liters.
LitersPerHour | Liters per hour.
LitersPerMinute | Liters per minute.
LitersPerSecond | Liters per second.
LitersPerSecondCubicMeter | Liters per second cubic meter.
LitersPerSecondKilowatt | Liters per second kilowatt.
LitersPerSecondSquareMeter | Liters per second square meter.
Lumens | Lumens.
LumensPerWatt | Lumens per watt.
Lux | Lux.
MeganewtonMeters | Meganewton meters.
MeganewtonMetersPerMeter | Meganewton meters per meter.
Meganewtons | Meganewtons.
MeganewtonsPerMeter | Meganewtons per meter.
MeganewtonsPerSquareMeter | Meganewtons per square meter.
Megapascals | Megapascals.
Meters | Meters.
MetersCentimeters | Meters and centimeters.
MetersOfWaterColumn | Meters of water column.
MetersOfWaterColumnPerMeter | Meters of water column per meter.
MetersPerKilonewton | Meters per kilonewton.
MetersPerSecond | Meters per second.
MetersPerSecondSquared | Meters per second squared.
MetersToTheFourthPower | Meters to the fourth power.
MetersToTheSixthPower | Meters to the sixth power.
MicroinchesPerInchDegreeFahrenheit | Microinches per inch degree Fahrenheit.
MicrometersPerMeterDegreeCelsius | Micrometers per meter degree Celsius.
MilesPerHour | Miles per hour.
MilesPerSecondSquared | Miles per second squared.
Milliamperes | Milliamperes.
Millimeters | Millimeters.
MillimetersOfMercury | Millimeters of mercury.
MillimetersOfWaterColumn | Millimeters of water column.
MillimetersOfWaterColumnPerMeter | Millimeters of water column per meter.
MillimetersToTheFourthPower | Millimeters to the fourth power.
MillimetersToTheSixthPower | Millimeters to the sixth power.
Milliseconds | Milliseconds.
Millivolts | Millivolts.
Minutes | Minutes.
NanogramsPerPascalSecondSquareMeter | Nanograms per pascal second square meter.
NewtonMeters | Newton meters.
NewtonMetersPerMeter | Newton meters per meter.
Newtons | Newtons.
NewtonSecondsPerSquareMeter | Newton seconds per square meter.
NewtonsPerMeter | Newtons per meter.
NewtonsPerSquareMeter | Newtons per square meter.
NewtonsPerSquareMillimeter | Newtons per square millimeter.
OhmMeters | Ohm meters.
OneToRatio | 1 : Ratio.
Pascals | Pascals.
PascalSeconds | Pascal seconds.
PascalsPerMeter | Pascals per meter.
Percentage | Percentage.
PerMille | Per mille.
Pi | Multiples of Ï€.
PoundForceFeet | Pound force feet.
PoundForceFeetPerFoot | Pound force feet per foot.
PoundForceSecondsPerSquareFoot | Pound force seconds per square foot.
PoundsForce | Pounds force.
PoundsForcePerCubicFoot | Pounds force per cubic foot.
PoundsForcePerFoot | Pounds force per foot.
PoundsForcePerSquareFoot | Pounds force per square foot.
PoundsForcePerSquareInch | Pounds force per square inch.
PoundsMass | Pounds mass.
PoundsMassPerCubicFoot | Pounds mass per cubic foot.
PoundsMassPerCubicInch | Pounds mass per cubic inch.
PoundsMassPerFoot | Pounds mass per foot.
PoundsMassPerFootHour | Pounds mass per foot hour.
PoundsMassPerFootSecond | Pounds mass per foot second.
PoundsMassPerHour | Pounds mass per hour.
PoundsMassPerMinute | Pounds mass per minute.
PoundsMassPerPoundDegreeFahrenheit | Pounds mass per pound degree Fahrenheit.
PoundsMassPerSecond | Pounds mass per second.
PoundsMassPerSquareFoot | Pounds mass per square foot.
Radians | Radians.
RadiansPerSecond | Radians per second.
Rankine | Rankine.
RankineInterval | Rankine interval.
RatioTo1 | Ratio : 1.
RatioTo10 | Ratio : 10.
RatioTo12 | Ratio : 12.
RevolutionsPerMinute | Revolutions per minute.
RevolutionsPerSecond | Revolutions per second.
RiseDividedBy1000Millimeters | Rise / 1000 millimeters.
RiseDividedBy10Feet | Rise / 10 feet.
RiseDividedBy120Inches | Rise / 120 inches.
RiseDividedBy12Inches | Rise / 12 inches.
RiseDividedBy1Foot | Rise / 1 foot.
Seconds | Seconds.
SlopeDegrees | Degrees.
SquareCentimeters | Square centimeters.
SquareCentimetersPerMeter | Square centimeters per meter.
SquareFeet | Square feet.
SquareFeetPer1000BritishThermalUnitsPerHour | Square feet per thousand British thermal units per hour.
SquareFeetPerFoot | Square feet per foot.
SquareFeetPerKip | Square feet per kip.
SquareFeetPerSecond | Square feet per second.
SquareFeetPerTonOfRefrigeration | Square feet per ton of refrigeration.
SquareInches | Square inches.
SquareInchesPerFoot | Square inches per foot.
SquareMeterKelvinsPerWatt | Square meter kelvins per watt.
SquareMeters | Square meters.
SquareMetersPerKilonewton | Square meters per kilonewton.
SquareMetersPerKilowatt | Square meters per kilowatt.
SquareMetersPerMeter | Square meters per meter.
SquareMetersPerSecond | Square meters per second.
SquareMillimeters | Square millimeters.
SquareMillimetersPerMeter | Square millimeters per meter.
StationingFeet | Feet.
StationingMeters | Meters.
StationingSurveyFeet | US survey feet.
Therms | Therms.
ThousandBritishThermalUnitsPerHour | Thousand British thermal units per hour.
TonneForceMeters | Tonne force meters.
TonneForceMetersPerMeter | Tonne force meters per meter.
Tonnes | Tonnes.
TonnesForce | Tonnes force.
TonnesForcePerMeter | Tonnes force per meter.
TonnesForcePerSquareMeter | Tonnes force per square meter.
TonsOfRefrigeration | Tons of refrigeration.
UsGallons | US gallons.
UsGallonsPerHour | US gallons per hour.
UsGallonsPerMinute | US gallons per minute.
UsSurveyFeet | US survey feet.
UsTonnesForce | US tonnes force.
UsTonnesMass | US tonnes mass.
VoltAmperes | Volt amperes.
VoltAmperesPerSquareFoot | Volt amperes per square foot.
VoltAmperesPerSquareMeter | Volt amperes per square meter.
Volts | Volts.
Watts | Watts.
WattsPerCubicFoot | Watts per cubic foot.
WattsPerCubicFootPerMinute | Watts per cubic foot per minute.
WattsPerCubicMeter | Watts per cubic meter.
WattsPerCubicMeterPerSecond | Watts per cubic meter per second.
WattsPerFoot | Watts per foot.
WattsPerMeter | Watts per meter.
WattsPerMeterKelvin | Watts per meter kelvin.
WattsPerSquareFoot | Watts per square foot.
WattsPerSquareMeter | Watts per square meter.
WattsPerSquareMeterKelvin | Watts per square meter kelvin.

See Also

UnitTypeId Class


UnitTypeId Properties

[image] [image]

Revit 2024 API
UnitTypeId Properties
UnitTypeId Class See Also Send Feedback

The UnitTypeId type exposes the following members.

Properties

Name | Description
Acres | Acres.
Amperes | Amperes.
Atmospheres | Atmospheres.
Bars | Bars.
BritishThermalUnits | British thermal units.
BritishThermalUnitsPerDegreeFahrenheit | British thermal units per degree Fahrenheit.
BritishThermalUnitsPerHour | British thermal units per hour.
BritishThermalUnitsPerHourCubicFoot | British thermal units per hour cubic foot.
BritishThermalUnitsPerHourFootDegreeFahrenheit | British thermal units per hour foot degree Fahrenheit.
BritishThermalUnitsPerHourSquareFoot | British thermal units per hour square foot.
BritishThermalUnitsPerHourSquareFootDegreeFahrenheit | British thermal units per hour square foot degree Fahrenheit.
BritishThermalUnitsPerPound | British thermal units per pound.
BritishThermalUnitsPerPoundDegreeFahrenheit | British thermal units per pound degree Fahrenheit.
BritishThermalUnitsPerSecond | British thermal units per second.
BritishThermalUnitsPerSquareFootDegreeFahrenheit | British thermal units per square foot degree Fahrenheit.
Calories | Calories.
CaloriesPerSecond | Calories per second.
Candelas | Candelas.
CandelasPerSquareFoot | Candelas per square foot.
CandelasPerSquareMeter | Candelas per square meter.
Celsius | Celsius.
CelsiusInterval | Celsius interval.
Centimeters | Centimeters.
CentimetersPerMinute | Centimeters per minute.
CentimetersToTheFourthPower | Centimeters to the fourth power.
CentimetersToTheSixthPower | Centimeters to the sixth power.
Centipoises | Centipoises.
CubicCentimeters | Cubic centimeters.
CubicFeet | Cubic feet.
CubicFeetPerHour | Cubic feet per hour.
CubicFeetPerKip | Cubic feet per kip.
CubicFeetPerMinute | Cubic feet per minute.
CubicFeetPerMinuteCubicFoot | Cubic feet per minute cubic foot.
CubicFeetPerMinutePerBritishThermalUnitPerHour | Cubic feet per minute per British thermal unit per hour.
CubicFeetPerMinuteSquareFoot | Cubic feet per minute square foot.
CubicFeetPerMinuteTonOfRefrigeration | Cubic feet per minute ton of refrigeration.
CubicFeetPerPoundMass | Cubic feet per pound mass.
CubicInches | Cubic inches.
CubicMeters | Cubic meters.
CubicMetersPerHour | Cubic meters per hour.
CubicMetersPerHourCubicMeter | Cubic meters per hour cubic meter.
CubicMetersPerHourSquareMeter | Cubic meters per hour square meter.
CubicMetersPerKilogram | Cubic meters per kilogram.
CubicMetersPerKilonewton | Cubic meters per kilonewton.
CubicMetersPerSecond | Cubic meters per second.
CubicMetersPerWattSecond | Cubic meters per watt second.
CubicMillimeters | Cubic millimeters.
CubicYards | Cubic yards.
Currency | Currency.
CurrencyPerBritishThermalUnit | Cost per British thermal unit.
CurrencyPerBritishThermalUnitPerHour | Cost per British thermal unit per hour.
CurrencyPerSquareFoot | Cost per square foot.
CurrencyPerSquareMeter | Cost per square meter.
CurrencyPerWatt | Cost per watt.
CurrencyPerWattHour | Cost per watt hour.
Custom | Unrecognized custom unit.
CyclesPerSecond | Cycles per second.
Decimeters | Decimeters.
Degrees | Degrees.
DegreesMinutes | Degrees minutes seconds.
DekanewtonMeters | Dekanewton meters.
DekanewtonMetersPerMeter | Dekanewton meters per meter.
Dekanewtons | Dekanewtons.
DekanewtonsPerMeter | Dekanewtons per meter.
DekanewtonsPerSquareMeter | Dekanewtons per square meter.
Fahrenheit | Fahrenheit.
FahrenheitInterval | Fahrenheit interval.
Feet | Feet.
FeetFractionalInches | Feet and fractional inches.
FeetOfWater39_2DegreesFahrenheit | Feet of water (39.2 Â°F).
FeetOfWater39_2DegreesFahrenheitPer100Feet | Feet of water (39.2 Â°F) per 100 feet.
FeetPerKip | Feet per kip.
FeetPerMinute | Feet per minute.
FeetPerSecond | Feet per second.
FeetPerSecondSquared | Feet per second squared.
FeetToTheFourthPower | Feet to the fourth power.
FeetToTheSixthPower | Feet to the sixth power.
Fixed | Fixed.
Footcandles | Footcandles.
Footlamberts | Footlamberts.
FractionalInches | Fractional inches.
General | General.
Gradians | Gradians.
GrainsPerHourSquareFootInchMercury | Grains per hour square foot inch mercury.
Hectares | Hectares.
Hertz | Hertz.
Horsepower | Horsepower.
Hours | Hours.
HourSquareFootDegreesFahrenheitPerBritishThermalUnit | Hour square foot degrees Fahrenheit per British thermal unit.
Inches | Inches.
InchesOfMercury32DegreesFahrenheit | Inches of mercury (32 Â°F).
InchesOfWater60DegreesFahrenheit | Inches of water (60 Â°F).
InchesOfWater60DegreesFahrenheitPer100Feet | Inches of water (60 Â°F) per 100 feet.
InchesPerSecondSquared | Inches per second squared.
InchesToTheFourthPower | Inches to the fourth power.
InchesToTheSixthPower | Inches to the sixth power.
InverseDegreesCelsius | Inverse degrees Celsius.
InverseDegreesFahrenheit | Inverse degrees Fahrenheit.
InverseKilonewtons | Inverse kilonewtons.
InverseKips | Inverse kips.
Joules | Joules.
JoulesPerGram | Joules per gram.
JoulesPerGramDegreeCelsius | Joules per gram degree Celsius.
JoulesPerKelvin | Joules per Kelvin.
JoulesPerKilogramDegreeCelsius | Joules per kilogram degree Celsius.
JoulesPerSquareMeterKelvin | Joules per square meter Kelvin.
Kelvin | Kelvin.
KelvinInterval | Kelvin interval.
Kiloamperes | Kiloamperes.
Kilocalories | Kilocalories.
KilocaloriesPerSecond | Kilocalories per second.
KilogramForceMeters | Kilogram force meters.
KilogramForceMetersPerMeter | Kilogram force meters per meter.
Kilograms | Kilograms.
KilogramsForce | Kilograms force.
KilogramsForcePerMeter | Kilograms force per meter.
KilogramsForcePerSquareMeter | Kilograms force per square meter.
KilogramsPerCubicMeter | Kilograms per cubic meter.
KilogramsPerHour | Kilograms per hour.
KilogramsPerKilogramKelvin | Kilograms per kilogram kelvin.
KilogramsPerMeter | Kilograms per meter.
KilogramsPerMeterHour | Kilograms per meter hour.
KilogramsPerMeterSecond | Kilograms per meter second.
KilogramsPerMinute | Kilograms per minute.
KilogramsPerSecond | Kilograms per second.
KilogramsPerSquareMeter | Kilograms per square meter.
Kilojoules | Kilojoules.
KilojoulesPerKelvin | Kilojoules per Kelvin.
KilojoulesPerSquareMeterKelvin | Kilojoules per square meter Kelvin.
KilometersPerHour | Kilometers per hour.
KilometersPerSecondSquared | Kilometers per second squared.
KilonewtonMeters | Kilonewton meters.
KilonewtonMetersPerDegree | Kilonewton meters per degree.
KilonewtonMetersPerDegreePerMeter | Kilonewton meters per degree per meter.
KilonewtonMetersPerMeter | Kilonewton meters per meter.
Kilonewtons | Kilonewtons.
KilonewtonsPerCubicMeter | Kilonewtons per cubic meter.
KilonewtonsPerMeter | Kilonewtons per meter.
KilonewtonsPerSquareCentimeter | Kilonewtons per square centimeter.
KilonewtonsPerSquareMeter | Kilonewtons per square meter.
KilonewtonsPerSquareMillimeter | Kilonewtons per square millimeter.
Kilopascals | Kilopascals.
KilovoltAmperes | Kilovolt amperes.
Kilovolts | Kilovolts.
KilowattHours | Kilowatt hours.
Kilowatts | Kilowatts.
KipFeet | Kip feet.
KipFeetPerDegree | Kip feet per degree.
KipFeetPerDegreePerFoot | Kip feet per degree per foot.
KipFeetPerFoot | Kip feet per foot.
Kips | Kips.
KipsPerCubicFoot | Kips per cubic foot.
KipsPerCubicInch | Kips per cubic inch.
KipsPerFoot | Kips per foot.
KipsPerInch | Kips per inch.
KipsPerSquareFoot | Kips per square foot.
KipsPerSquareInch | Kips per square inch.
Liters | Liters.
LitersPerHour | Liters per hour.
LitersPerMinute | Liters per minute.
LitersPerSecond | Liters per second.
LitersPerSecondCubicMeter | Liters per second cubic meter.
LitersPerSecondKilowatt | Liters per second kilowatt.
LitersPerSecondSquareMeter | Liters per second square meter.
Lumens | Lumens.
LumensPerWatt | Lumens per watt.
Lux | Lux.
MeganewtonMeters | Meganewton meters.
MeganewtonMetersPerMeter | Meganewton meters per meter.
Meganewtons | Meganewtons.
MeganewtonsPerMeter | Meganewtons per meter.
MeganewtonsPerSquareMeter | Meganewtons per square meter.
Megapascals | Megapascals.
Meters | Meters.
MetersCentimeters | Meters and centimeters.
MetersOfWaterColumn | Meters of water column.
MetersOfWaterColumnPerMeter | Meters of water column per meter.
MetersPerKilonewton | Meters per kilonewton.
MetersPerSecond | Meters per second.
MetersPerSecondSquared | Meters per second squared.
MetersToTheFourthPower | Meters to the fourth power.
MetersToTheSixthPower | Meters to the sixth power.
MicroinchesPerInchDegreeFahrenheit | Microinches per inch degree Fahrenheit.
MicrometersPerMeterDegreeCelsius | Micrometers per meter degree Celsius.
MilesPerHour | Miles per hour.
MilesPerSecondSquared | Miles per second squared.
Milliamperes | Milliamperes.
Millimeters | Millimeters.
MillimetersOfMercury | Millimeters of mercury.
MillimetersOfWaterColumn | Millimeters of water column.
MillimetersOfWaterColumnPerMeter | Millimeters of water column per meter.
MillimetersToTheFourthPower | Millimeters to the fourth power.
MillimetersToTheSixthPower | Millimeters to the sixth power.
Milliseconds | Milliseconds.
Millivolts | Millivolts.
Minutes | Minutes.
NanogramsPerPascalSecondSquareMeter | Nanograms per pascal second square meter.
NewtonMeters | Newton meters.
NewtonMetersPerMeter | Newton meters per meter.
Newtons | Newtons.
NewtonSecondsPerSquareMeter | Newton seconds per square meter.
NewtonsPerMeter | Newtons per meter.
NewtonsPerSquareMeter | Newtons per square meter.
NewtonsPerSquareMillimeter | Newtons per square millimeter.
OhmMeters | Ohm meters.
OneToRatio | 1 : Ratio.
Pascals | Pascals.
PascalSeconds | Pascal seconds.
PascalsPerMeter | Pascals per meter.
Percentage | Percentage.
PerMille | Per mille.
Pi | Multiples of Ï€.
PoundForceFeet | Pound force feet.
PoundForceFeetPerFoot | Pound force feet per foot.
PoundForceSecondsPerSquareFoot | Pound force seconds per square foot.
PoundsForce | Pounds force.
PoundsForcePerCubicFoot | Pounds force per cubic foot.
PoundsForcePerFoot | Pounds force per foot.
PoundsForcePerSquareFoot | Pounds force per square foot.
PoundsForcePerSquareInch | Pounds force per square inch.
PoundsMass | Pounds mass.
PoundsMassPerCubicFoot | Pounds mass per cubic foot.
PoundsMassPerCubicInch | Pounds mass per cubic inch.
PoundsMassPerFoot | Pounds mass per foot.
PoundsMassPerFootHour | Pounds mass per foot hour.
PoundsMassPerFootSecond | Pounds mass per foot second.
PoundsMassPerHour | Pounds mass per hour.
PoundsMassPerMinute | Pounds mass per minute.
PoundsMassPerPoundDegreeFahrenheit | Pounds mass per pound degree Fahrenheit.
PoundsMassPerSecond | Pounds mass per second.
PoundsMassPerSquareFoot | Pounds mass per square foot.
Radians | Radians.
RadiansPerSecond | Radians per second.
Rankine | Rankine.
RankineInterval | Rankine interval.
RatioTo1 | Ratio : 1.
RatioTo10 | Ratio : 10.
RatioTo12 | Ratio : 12.
RevolutionsPerMinute | Revolutions per minute.
RevolutionsPerSecond | Revolutions per second.
RiseDividedBy1000Millimeters | Rise / 1000 millimeters.
RiseDividedBy10Feet | Rise / 10 feet.
RiseDividedBy120Inches | Rise / 120 inches.
RiseDividedBy12Inches | Rise / 12 inches.
RiseDividedBy1Foot | Rise / 1 foot.
Seconds | Seconds.
SlopeDegrees | Degrees.
SquareCentimeters | Square centimeters.
SquareCentimetersPerMeter | Square centimeters per meter.
SquareFeet | Square feet.
SquareFeetPer1000BritishThermalUnitsPerHour | Square feet per thousand British thermal units per hour.
SquareFeetPerFoot | Square feet per foot.
SquareFeetPerKip | Square feet per kip.
SquareFeetPerSecond | Square feet per second.
SquareFeetPerTonOfRefrigeration | Square feet per ton of refrigeration.
SquareInches | Square inches.
SquareInchesPerFoot | Square inches per foot.
SquareMeterKelvinsPerWatt | Square meter kelvins per watt.
SquareMeters | Square meters.
SquareMetersPerKilonewton | Square meters per kilonewton.
SquareMetersPerKilowatt | Square meters per kilowatt.
SquareMetersPerMeter | Square meters per meter.
SquareMetersPerSecond | Square meters per second.
SquareMillimeters | Square millimeters.
SquareMillimetersPerMeter | Square millimeters per meter.
StationingFeet | Feet.
StationingMeters | Meters.
StationingSurveyFeet | US survey feet.
Therms | Therms.
ThousandBritishThermalUnitsPerHour | Thousand British thermal units per hour.
TonneForceMeters | Tonne force meters.
TonneForceMetersPerMeter | Tonne force meters per meter.
Tonnes | Tonnes.
TonnesForce | Tonnes force.
TonnesForcePerMeter | Tonnes force per meter.
TonnesForcePerSquareMeter | Tonnes force per square meter.
TonsOfRefrigeration | Tons of refrigeration.
UsGallons | US gallons.
UsGallonsPerHour | US gallons per hour.
UsGallonsPerMinute | US gallons per minute.
UsSurveyFeet | US survey feet.
UsTonnesForce | US tonnes force.
UsTonnesMass | US tonnes mass.
VoltAmperes | Volt amperes.
VoltAmperesPerSquareFoot | Volt amperes per square foot.
VoltAmperesPerSquareMeter | Volt amperes per square meter.
Volts | Volts.
Watts | Watts.
WattsPerCubicFoot | Watts per cubic foot.
WattsPerCubicFootPerMinute | Watts per cubic foot per minute.
WattsPerCubicMeter | Watts per cubic meter.
WattsPerCubicMeterPerSecond | Watts per cubic meter per second.
WattsPerFoot | Watts per foot.
WattsPerMeter | Watts per meter.
WattsPerMeterKelvin | Watts per meter kelvin.
WattsPerSquareFoot | Watts per square foot.
WattsPerSquareMeter | Watts per square meter.
WattsPerSquareMeterKelvin | Watts per square meter kelvin.

See Also

UnitTypeId Class


Acres Property

[image]

Revit 2024 API
UnitTypeId..::..Acres Property
UnitTypeId Class See Also Send Feedback
Acres.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Acres { get; }
Visual Basic
Public Shared ReadOnly Property Acres As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Acres {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


Amperes Property

[image]

Revit 2024 API
UnitTypeId..::..Amperes Property
UnitTypeId Class See Also Send Feedback
Amperes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Amperes { get; }
Visual Basic
Public Shared ReadOnly Property Amperes As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Amperes {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


Atmospheres Property

[image]

Revit 2024 API
UnitTypeId..::..Atmospheres Property
UnitTypeId Class See Also Send Feedback
Atmospheres.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Atmospheres { get; }
Visual Basic
Public Shared ReadOnly Property Atmospheres As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Atmospheres {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


Bars Property

[image]

Revit 2024 API
UnitTypeId..::..Bars Property
UnitTypeId Class See Also Send Feedback
Bars.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Bars { get; }
Visual Basic
Public Shared ReadOnly Property Bars As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Bars {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


BritishThermalUnitsPerDegreeFahrenheit Property

[image]

Revit 2024 API
UnitTypeId..::..BritishThermalUnitsPerDegreeFahrenheit Property
UnitTypeId Class See Also Send Feedback
British thermal units per degree Fahrenheit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId BritishThermalUnitsPerDegreeFahrenheit { get; }
Visual Basic
Public Shared ReadOnly Property BritishThermalUnitsPerDegreeFahrenheit As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BritishThermalUnitsPerDegreeFahrenheit {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


BritishThermalUnitsPerHourCubicFoot Property

[image]

Revit 2024 API
UnitTypeId..::..BritishThermalUnitsPerHourCubicFoot Property
UnitTypeId Class See Also Send Feedback
British thermal units per hour cubic foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId BritishThermalUnitsPerHourCubicFoot { get; }
Visual Basic
Public Shared ReadOnly Property BritishThermalUnitsPerHourCubicFoot As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BritishThermalUnitsPerHourCubicFoot {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


BritishThermalUnitsPerHourFootDegreeFahrenheit Property

[image]

Revit 2024 API
UnitTypeId..::..BritishThermalUnitsPerHourFootDegreeFahrenheit Property
UnitTypeId Class See Also Send Feedback
British thermal units per hour foot degree Fahrenheit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId BritishThermalUnitsPerHourFootDegreeFahrenheit { get; }
Visual Basic
Public Shared ReadOnly Property BritishThermalUnitsPerHourFootDegreeFahrenheit As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BritishThermalUnitsPerHourFootDegreeFahrenheit {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


BritishThermalUnitsPerHourSquareFoot Property

[image]

Revit 2024 API
UnitTypeId..::..BritishThermalUnitsPerHourSquareFoot Property
UnitTypeId Class See Also Send Feedback
British thermal units per hour square foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId BritishThermalUnitsPerHourSquareFoot { get; }
Visual Basic
Public Shared ReadOnly Property BritishThermalUnitsPerHourSquareFoot As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BritishThermalUnitsPerHourSquareFoot {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


BritishThermalUnitsPerHourSquareFootDegreeFahrenheit Property

[image]

Revit 2024 API
UnitTypeId..::..BritishThermalUnitsPerHourSquareFootDegreeFahrenheit Property
UnitTypeId Class See Also Send Feedback
British thermal units per hour square foot degree Fahrenheit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId BritishThermalUnitsPerHourSquareFootDegreeFahrenheit { get; }
Visual Basic
Public Shared ReadOnly Property BritishThermalUnitsPerHourSquareFootDegreeFahrenheit As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BritishThermalUnitsPerHourSquareFootDegreeFahrenheit {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


BritishThermalUnitsPerSquareFootDegreeFahrenheit Property

[image]

Revit 2024 API
UnitTypeId..::..BritishThermalUnitsPerSquareFootDegreeFahrenheit Property
UnitTypeId Class See Also Send Feedback
British thermal units per square foot degree Fahrenheit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId BritishThermalUnitsPerSquareFootDegreeFahrenheit { get; }
Visual Basic
Public Shared ReadOnly Property BritishThermalUnitsPerSquareFootDegreeFahrenheit As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ BritishThermalUnitsPerSquareFootDegreeFahrenheit {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


Calories Property

[image]

Revit 2024 API
UnitTypeId..::..Calories Property
UnitTypeId Class See Also Send Feedback
Calories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Calories { get; }
Visual Basic
Public Shared ReadOnly Property Calories As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Calories {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


CaloriesPerSecond Property

[image]

Revit 2024 API
UnitTypeId..::..CaloriesPerSecond Property
UnitTypeId Class See Also Send Feedback
Calories per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId CaloriesPerSecond { get; }
Visual Basic
Public Shared ReadOnly Property CaloriesPerSecond As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CaloriesPerSecond {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


Candelas Property

[image]

Revit 2024 API
UnitTypeId..::..Candelas Property
UnitTypeId Class See Also Send Feedback
Candelas.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Candelas { get; }
Visual Basic
Public Shared ReadOnly Property Candelas As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Candelas {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


CandelasPerSquareFoot Property

[image]

Revit 2024 API
UnitTypeId..::..CandelasPerSquareFoot Property
UnitTypeId Class See Also Send Feedback
Candelas per square foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId CandelasPerSquareFoot { get; }
Visual Basic
Public Shared ReadOnly Property CandelasPerSquareFoot As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CandelasPerSquareFoot {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


CandelasPerSquareMeter Property

[image]

Revit 2024 API
UnitTypeId..::..CandelasPerSquareMeter Property
UnitTypeId Class See Also Send Feedback
Candelas per square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId CandelasPerSquareMeter { get; }
Visual Basic
Public Shared ReadOnly Property CandelasPerSquareMeter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CandelasPerSquareMeter {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


Celsius Property

[image]

Revit 2024 API
UnitTypeId..::..Celsius Property
UnitTypeId Class See Also Send Feedback
Celsius.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Celsius { get; }
Visual Basic
Public Shared ReadOnly Property Celsius As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Celsius {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


Centimeters Property

[image]

Revit 2024 API
UnitTypeId..::..Centimeters Property
UnitTypeId Class See Also Send Feedback
Centimeters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Centimeters { get; }
Visual Basic
Public Shared ReadOnly Property Centimeters As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Centimeters {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


CentimetersToTheFourthPower Property

[image]

Revit 2024 API
UnitTypeId..::..CentimetersToTheFourthPower Property
UnitTypeId Class See Also Send Feedback
Centimeters to the fourth power.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId CentimetersToTheFourthPower { get; }
Visual Basic
Public Shared ReadOnly Property CentimetersToTheFourthPower As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CentimetersToTheFourthPower {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


CentimetersToTheSixthPower Property

[image]

Revit 2024 API
UnitTypeId..::..CentimetersToTheSixthPower Property
UnitTypeId Class See Also Send Feedback
Centimeters to the sixth power.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId CentimetersToTheSixthPower { get; }
Visual Basic
Public Shared ReadOnly Property CentimetersToTheSixthPower As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CentimetersToTheSixthPower {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


CubicCentimeters Property

[image]

Revit 2024 API
UnitTypeId..::..CubicCentimeters Property
UnitTypeId Class See Also Send Feedback
Cubic centimeters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId CubicCentimeters { get; }
Visual Basic
Public Shared ReadOnly Property CubicCentimeters As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CubicCentimeters {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


CubicFeet Property

[image]

Revit 2024 API
UnitTypeId..::..CubicFeet Property
UnitTypeId Class See Also Send Feedback
Cubic feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId CubicFeet { get; }
Visual Basic
Public Shared ReadOnly Property CubicFeet As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CubicFeet {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


CubicFeetPerHour Property

[image]

Revit 2024 API
UnitTypeId..::..CubicFeetPerHour Property
UnitTypeId Class See Also Send Feedback
Cubic feet per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId CubicFeetPerHour { get; }
Visual Basic
Public Shared ReadOnly Property CubicFeetPerHour As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CubicFeetPerHour {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


CubicFeetPerKip Property

[image]

Revit 2024 API
UnitTypeId..::..CubicFeetPerKip Property
UnitTypeId Class See Also Send Feedback
Cubic feet per kip.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId CubicFeetPerKip { get; }
Visual Basic
Public Shared ReadOnly Property CubicFeetPerKip As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CubicFeetPerKip {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


CubicFeetPerMinute Property

[image]

Revit 2024 API
UnitTypeId..::..CubicFeetPerMinute Property
UnitTypeId Class See Also Send Feedback
Cubic feet per minute.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId CubicFeetPerMinute { get; }
Visual Basic
Public Shared ReadOnly Property CubicFeetPerMinute As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CubicFeetPerMinute {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


CubicFeetPerMinuteCubicFoot Property

[image]

Revit 2024 API
UnitTypeId..::..CubicFeetPerMinuteCubicFoot Property
UnitTypeId Class See Also Send Feedback
Cubic feet per minute cubic foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId CubicFeetPerMinuteCubicFoot { get; }
Visual Basic
Public Shared ReadOnly Property CubicFeetPerMinuteCubicFoot As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CubicFeetPerMinuteCubicFoot {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


CubicFeetPerMinutePerBritishThermalUnitPerHour Property

[image]

Revit 2024 API
UnitTypeId..::..CubicFeetPerMinutePerBritishThermalUnitPerHour Property
UnitTypeId Class See Also Send Feedback
Cubic feet per minute per British thermal unit per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId CubicFeetPerMinutePerBritishThermalUnitPerHour { get; }
Visual Basic
Public Shared ReadOnly Property CubicFeetPerMinutePerBritishThermalUnitPerHour As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CubicFeetPerMinutePerBritishThermalUnitPerHour {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


CubicFeetPerMinuteSquareFoot Property

[image]

Revit 2024 API
UnitTypeId..::..CubicFeetPerMinuteSquareFoot Property
UnitTypeId Class See Also Send Feedback
Cubic feet per minute square foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId CubicFeetPerMinuteSquareFoot { get; }
Visual Basic
Public Shared ReadOnly Property CubicFeetPerMinuteSquareFoot As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CubicFeetPerMinuteSquareFoot {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


CubicFeetPerMinuteTonOfRefrigeration Property

[image]

Revit 2024 API
UnitTypeId..::..CubicFeetPerMinuteTonOfRefrigeration Property
UnitTypeId Class See Also Send Feedback
Cubic feet per minute ton of refrigeration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId CubicFeetPerMinuteTonOfRefrigeration { get; }
Visual Basic
Public Shared ReadOnly Property CubicFeetPerMinuteTonOfRefrigeration As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CubicFeetPerMinuteTonOfRefrigeration {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


CubicFeetPerPoundMass Property

[image]

Revit 2024 API
UnitTypeId..::..CubicFeetPerPoundMass Property
UnitTypeId Class See Also Send Feedback
Cubic feet per pound mass.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId CubicFeetPerPoundMass { get; }
Visual Basic
Public Shared ReadOnly Property CubicFeetPerPoundMass As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CubicFeetPerPoundMass {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


CubicMetersPerHourSquareMeter Property

[image]

Revit 2024 API
UnitTypeId..::..CubicMetersPerHourSquareMeter Property
UnitTypeId Class See Also Send Feedback
Cubic meters per hour square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId CubicMetersPerHourSquareMeter { get; }
Visual Basic
Public Shared ReadOnly Property CubicMetersPerHourSquareMeter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CubicMetersPerHourSquareMeter {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


CubicMetersPerKilonewton Property

[image]

Revit 2024 API
UnitTypeId..::..CubicMetersPerKilonewton Property
UnitTypeId Class See Also Send Feedback
Cubic meters per kilonewton.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId CubicMetersPerKilonewton { get; }
Visual Basic
Public Shared ReadOnly Property CubicMetersPerKilonewton As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CubicMetersPerKilonewton {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


CubicMetersPerSecond Property

[image]

Revit 2024 API
UnitTypeId..::..CubicMetersPerSecond Property
UnitTypeId Class See Also Send Feedback
Cubic meters per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId CubicMetersPerSecond { get; }
Visual Basic
Public Shared ReadOnly Property CubicMetersPerSecond As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CubicMetersPerSecond {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


CubicMetersPerWattSecond Property

[image]

Revit 2024 API
UnitTypeId..::..CubicMetersPerWattSecond Property
UnitTypeId Class See Also Send Feedback
Cubic meters per watt second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId CubicMetersPerWattSecond { get; }
Visual Basic
Public Shared ReadOnly Property CubicMetersPerWattSecond As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CubicMetersPerWattSecond {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


Currency Property

[image]

Revit 2024 API
UnitTypeId..::..Currency Property
UnitTypeId Class See Also Send Feedback
Currency.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Currency { get; }
Visual Basic
Public Shared ReadOnly Property Currency As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Currency {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


CurrencyPerBritishThermalUnitPerHour Property

[image]

Revit 2024 API
UnitTypeId..::..CurrencyPerBritishThermalUnitPerHour Property
UnitTypeId Class See Also Send Feedback
Cost per British thermal unit per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId CurrencyPerBritishThermalUnitPerHour { get; }
Visual Basic
Public Shared ReadOnly Property CurrencyPerBritishThermalUnitPerHour As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurrencyPerBritishThermalUnitPerHour {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


CurrencyPerSquareFoot Property

[image]

Revit 2024 API
UnitTypeId..::..CurrencyPerSquareFoot Property
UnitTypeId Class See Also Send Feedback
Cost per square foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId CurrencyPerSquareFoot { get; }
Visual Basic
Public Shared ReadOnly Property CurrencyPerSquareFoot As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurrencyPerSquareFoot {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


CurrencyPerSquareMeter Property

[image]

Revit 2024 API
UnitTypeId..::..CurrencyPerSquareMeter Property
UnitTypeId Class See Also Send Feedback
Cost per square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId CurrencyPerSquareMeter { get; }
Visual Basic
Public Shared ReadOnly Property CurrencyPerSquareMeter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurrencyPerSquareMeter {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


CurrencyPerWattHour Property

[image]

Revit 2024 API
UnitTypeId..::..CurrencyPerWattHour Property
UnitTypeId Class See Also Send Feedback
Cost per watt hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId CurrencyPerWattHour { get; }
Visual Basic
Public Shared ReadOnly Property CurrencyPerWattHour As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CurrencyPerWattHour {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


Custom Property

[image]

Revit 2024 API
UnitTypeId..::..Custom Property
UnitTypeId Class See Also Send Feedback
Unrecognized custom unit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Custom { get; }
Visual Basic
Public Shared ReadOnly Property Custom As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Custom {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


CyclesPerSecond Property

[image]

Revit 2024 API
UnitTypeId..::..CyclesPerSecond Property
UnitTypeId Class See Also Send Feedback
Cycles per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId CyclesPerSecond { get; }
Visual Basic
Public Shared ReadOnly Property CyclesPerSecond As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ CyclesPerSecond {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


Decimeters Property

[image]

Revit 2024 API
UnitTypeId..::..Decimeters Property
UnitTypeId Class See Also Send Feedback
Decimeters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Decimeters { get; }
Visual Basic
Public Shared ReadOnly Property Decimeters As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Decimeters {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


Degrees Property

[image]

Revit 2024 API
UnitTypeId..::..Degrees Property
UnitTypeId Class See Also Send Feedback
Degrees.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Degrees { get; }
Visual Basic
Public Shared ReadOnly Property Degrees As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Degrees {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


DegreesMinutes Property

[image]

Revit 2024 API
UnitTypeId..::..DegreesMinutes Property
UnitTypeId Class See Also Send Feedback
Degrees minutes seconds.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId DegreesMinutes { get; }
Visual Basic
Public Shared ReadOnly Property DegreesMinutes As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DegreesMinutes {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


DekanewtonMeters Property

[image]

Revit 2024 API
UnitTypeId..::..DekanewtonMeters Property
UnitTypeId Class See Also Send Feedback
Dekanewton meters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId DekanewtonMeters { get; }
Visual Basic
Public Shared ReadOnly Property DekanewtonMeters As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DekanewtonMeters {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


DekanewtonMetersPerMeter Property

[image]

Revit 2024 API
UnitTypeId..::..DekanewtonMetersPerMeter Property
UnitTypeId Class See Also Send Feedback
Dekanewton meters per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId DekanewtonMetersPerMeter { get; }
Visual Basic
Public Shared ReadOnly Property DekanewtonMetersPerMeter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DekanewtonMetersPerMeter {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


DekanewtonsPerMeter Property

[image]

Revit 2024 API
UnitTypeId..::..DekanewtonsPerMeter Property
UnitTypeId Class See Also Send Feedback
Dekanewtons per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId DekanewtonsPerMeter { get; }
Visual Basic
Public Shared ReadOnly Property DekanewtonsPerMeter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DekanewtonsPerMeter {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


DekanewtonsPerSquareMeter Property

[image]

Revit 2024 API
UnitTypeId..::..DekanewtonsPerSquareMeter Property
UnitTypeId Class See Also Send Feedback
Dekanewtons per square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId DekanewtonsPerSquareMeter { get; }
Visual Basic
Public Shared ReadOnly Property DekanewtonsPerSquareMeter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ DekanewtonsPerSquareMeter {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


Fahrenheit Property

[image]

Revit 2024 API
UnitTypeId..::..Fahrenheit Property
UnitTypeId Class See Also Send Feedback
Fahrenheit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Fahrenheit { get; }
Visual Basic
Public Shared ReadOnly Property Fahrenheit As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Fahrenheit {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


FahrenheitInterval Property

[image]

Revit 2024 API
UnitTypeId..::..FahrenheitInterval Property
UnitTypeId Class See Also Send Feedback
Fahrenheit interval.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId FahrenheitInterval { get; }
Visual Basic
Public Shared ReadOnly Property FahrenheitInterval As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FahrenheitInterval {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


Feet Property

[image]

Revit 2024 API
UnitTypeId..::..Feet Property
UnitTypeId Class See Also Send Feedback
Feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Feet { get; }
Visual Basic
Public Shared ReadOnly Property Feet As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Feet {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


FeetFractionalInches Property

[image]

Revit 2024 API
UnitTypeId..::..FeetFractionalInches Property
UnitTypeId Class See Also Send Feedback
Feet and fractional inches.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId FeetFractionalInches { get; }
Visual Basic
Public Shared ReadOnly Property FeetFractionalInches As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FeetFractionalInches {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


FeetOfWater39_2DegreesFahrenheit Property

[image]

Revit 2024 API
UnitTypeId..::..FeetOfWater39_2DegreesFahrenheit Property
UnitTypeId Class See Also Send Feedback
Feet of water (39.2 Â°F).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId FeetOfWater39_2DegreesFahrenheit { get; }
Visual Basic
Public Shared ReadOnly Property FeetOfWater39_2DegreesFahrenheit As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FeetOfWater39_2DegreesFahrenheit {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


FeetPerKip Property

[image]

Revit 2024 API
UnitTypeId..::..FeetPerKip Property
UnitTypeId Class See Also Send Feedback
Feet per kip.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId FeetPerKip { get; }
Visual Basic
Public Shared ReadOnly Property FeetPerKip As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FeetPerKip {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


FeetPerMinute Property

[image]

Revit 2024 API
UnitTypeId..::..FeetPerMinute Property
UnitTypeId Class See Also Send Feedback
Feet per minute.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId FeetPerMinute { get; }
Visual Basic
Public Shared ReadOnly Property FeetPerMinute As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FeetPerMinute {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


FeetPerSecond Property

[image]

Revit 2024 API
UnitTypeId..::..FeetPerSecond Property
UnitTypeId Class See Also Send Feedback
Feet per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId FeetPerSecond { get; }
Visual Basic
Public Shared ReadOnly Property FeetPerSecond As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FeetPerSecond {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


FeetPerSecondSquared Property

[image]

Revit 2024 API
UnitTypeId..::..FeetPerSecondSquared Property
UnitTypeId Class See Also Send Feedback
Feet per second squared.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId FeetPerSecondSquared { get; }
Visual Basic
Public Shared ReadOnly Property FeetPerSecondSquared As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FeetPerSecondSquared {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


FeetToTheFourthPower Property

[image]

Revit 2024 API
UnitTypeId..::..FeetToTheFourthPower Property
UnitTypeId Class See Also Send Feedback
Feet to the fourth power.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId FeetToTheFourthPower { get; }
Visual Basic
Public Shared ReadOnly Property FeetToTheFourthPower As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FeetToTheFourthPower {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


FeetToTheSixthPower Property

[image]

Revit 2024 API
UnitTypeId..::..FeetToTheSixthPower Property
UnitTypeId Class See Also Send Feedback
Feet to the sixth power.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId FeetToTheSixthPower { get; }
Visual Basic
Public Shared ReadOnly Property FeetToTheSixthPower As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FeetToTheSixthPower {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


Fixed Property

[image]

Revit 2024 API
UnitTypeId..::..Fixed Property
UnitTypeId Class See Also Send Feedback
Fixed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Fixed { get; }
Visual Basic
Public Shared ReadOnly Property Fixed As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Fixed {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


Footlamberts Property

[image]

Revit 2024 API
UnitTypeId..::..Footlamberts Property
UnitTypeId Class See Also Send Feedback
Footlamberts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Footlamberts { get; }
Visual Basic
Public Shared ReadOnly Property Footlamberts As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Footlamberts {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


FractionalInches Property

[image]

Revit 2024 API
UnitTypeId..::..FractionalInches Property
UnitTypeId Class See Also Send Feedback
Fractional inches.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId FractionalInches { get; }
Visual Basic
Public Shared ReadOnly Property FractionalInches As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ FractionalInches {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


General Property

[image]

Revit 2024 API
UnitTypeId..::..General Property
UnitTypeId Class See Also Send Feedback
General.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId General { get; }
Visual Basic
Public Shared ReadOnly Property General As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ General {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


Gradians Property

[image]

Revit 2024 API
UnitTypeId..::..Gradians Property
UnitTypeId Class See Also Send Feedback
Gradians.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Gradians { get; }
Visual Basic
Public Shared ReadOnly Property Gradians As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Gradians {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


GrainsPerHourSquareFootInchMercury Property

[image]

Revit 2024 API
UnitTypeId..::..GrainsPerHourSquareFootInchMercury Property
UnitTypeId Class See Also Send Feedback
Grains per hour square foot inch mercury.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId GrainsPerHourSquareFootInchMercury { get; }
Visual Basic
Public Shared ReadOnly Property GrainsPerHourSquareFootInchMercury As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ GrainsPerHourSquareFootInchMercury {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


Hectares Property

[image]

Revit 2024 API
UnitTypeId..::..Hectares Property
UnitTypeId Class See Also Send Feedback
Hectares.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Hectares { get; }
Visual Basic
Public Shared ReadOnly Property Hectares As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Hectares {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


Hertz Property

[image]

Revit 2024 API
UnitTypeId..::..Hertz Property
UnitTypeId Class See Also Send Feedback
Hertz.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Hertz { get; }
Visual Basic
Public Shared ReadOnly Property Hertz As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Hertz {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


Horsepower Property

[image]

Revit 2024 API
UnitTypeId..::..Horsepower Property
UnitTypeId Class See Also Send Feedback
Horsepower.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Horsepower { get; }
Visual Basic
Public Shared ReadOnly Property Horsepower As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Horsepower {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


Hours Property

[image]

Revit 2024 API
UnitTypeId..::..Hours Property
UnitTypeId Class See Also Send Feedback
Hours.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Hours { get; }
Visual Basic
Public Shared ReadOnly Property Hours As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Hours {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


HourSquareFootDegreesFahrenheitPerBritishThermalUnit Property

[image]

Revit 2024 API
UnitTypeId..::..HourSquareFootDegreesFahrenheitPerBritishThermalUnit Property
UnitTypeId Class See Also Send Feedback
Hour square foot degrees Fahrenheit per British thermal unit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId HourSquareFootDegreesFahrenheitPerBritishThermalUnit { get; }
Visual Basic
Public Shared ReadOnly Property HourSquareFootDegreesFahrenheitPerBritishThermalUnit As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ HourSquareFootDegreesFahrenheitPerBritishThermalUnit {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


Inches Property

[image]

Revit 2024 API
UnitTypeId..::..Inches Property
UnitTypeId Class See Also Send Feedback
Inches.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Inches { get; }
Visual Basic
Public Shared ReadOnly Property Inches As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Inches {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


InchesOfMercury32DegreesFahrenheit Property

[image]

Revit 2024 API
UnitTypeId..::..InchesOfMercury32DegreesFahrenheit Property
UnitTypeId Class See Also Send Feedback
Inches of mercury (32 Â°F).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId InchesOfMercury32DegreesFahrenheit { get; }
Visual Basic
Public Shared ReadOnly Property InchesOfMercury32DegreesFahrenheit As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ InchesOfMercury32DegreesFahrenheit {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


InchesOfWater60DegreesFahrenheitPer100Feet Property

[image]

Revit 2024 API
UnitTypeId..::..InchesOfWater60DegreesFahrenheitPer100Feet Property
UnitTypeId Class See Also Send Feedback
Inches of water (60 Â°F) per 100 feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId InchesOfWater60DegreesFahrenheitPer100Feet { get; }
Visual Basic
Public Shared ReadOnly Property InchesOfWater60DegreesFahrenheitPer100Feet As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ InchesOfWater60DegreesFahrenheitPer100Feet {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


InchesPerSecondSquared Property

[image]

Revit 2024 API
UnitTypeId..::..InchesPerSecondSquared Property
UnitTypeId Class See Also Send Feedback
Inches per second squared.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId InchesPerSecondSquared { get; }
Visual Basic
Public Shared ReadOnly Property InchesPerSecondSquared As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ InchesPerSecondSquared {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


InchesToTheSixthPower Property

[image]

Revit 2024 API
UnitTypeId..::..InchesToTheSixthPower Property
UnitTypeId Class See Also Send Feedback
Inches to the sixth power.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId InchesToTheSixthPower { get; }
Visual Basic
Public Shared ReadOnly Property InchesToTheSixthPower As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ InchesToTheSixthPower {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


InverseDegreesCelsius Property

[image]

Revit 2024 API
UnitTypeId..::..InverseDegreesCelsius Property
UnitTypeId Class See Also Send Feedback
Inverse degrees Celsius.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId InverseDegreesCelsius { get; }
Visual Basic
Public Shared ReadOnly Property InverseDegreesCelsius As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ InverseDegreesCelsius {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


InverseKilonewtons Property

[image]

Revit 2024 API
UnitTypeId..::..InverseKilonewtons Property
UnitTypeId Class See Also Send Feedback
Inverse kilonewtons.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId InverseKilonewtons { get; }
Visual Basic
Public Shared ReadOnly Property InverseKilonewtons As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ InverseKilonewtons {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


InverseKips Property

[image]

Revit 2024 API
UnitTypeId..::..InverseKips Property
UnitTypeId Class See Also Send Feedback
Inverse kips.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId InverseKips { get; }
Visual Basic
Public Shared ReadOnly Property InverseKips As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ InverseKips {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


Joules Property

[image]

Revit 2024 API
UnitTypeId..::..Joules Property
UnitTypeId Class See Also Send Feedback
Joules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Joules { get; }
Visual Basic
Public Shared ReadOnly Property Joules As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Joules {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


JoulesPerGramDegreeCelsius Property

[image]

Revit 2024 API
UnitTypeId..::..JoulesPerGramDegreeCelsius Property
UnitTypeId Class See Also Send Feedback
Joules per gram degree Celsius.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId JoulesPerGramDegreeCelsius { get; }
Visual Basic
Public Shared ReadOnly Property JoulesPerGramDegreeCelsius As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ JoulesPerGramDegreeCelsius {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


JoulesPerKelvin Property

[image]

Revit 2024 API
UnitTypeId..::..JoulesPerKelvin Property
UnitTypeId Class See Also Send Feedback
Joules per Kelvin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId JoulesPerKelvin { get; }
Visual Basic
Public Shared ReadOnly Property JoulesPerKelvin As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ JoulesPerKelvin {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


JoulesPerKilogramDegreeCelsius Property

[image]

Revit 2024 API
UnitTypeId..::..JoulesPerKilogramDegreeCelsius Property
UnitTypeId Class See Also Send Feedback
Joules per kilogram degree Celsius.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId JoulesPerKilogramDegreeCelsius { get; }
Visual Basic
Public Shared ReadOnly Property JoulesPerKilogramDegreeCelsius As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ JoulesPerKilogramDegreeCelsius {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


KelvinInterval Property

[image]

Revit 2024 API
UnitTypeId..::..KelvinInterval Property
UnitTypeId Class See Also Send Feedback
Kelvin interval.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KelvinInterval { get; }
Visual Basic
Public Shared ReadOnly Property KelvinInterval As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KelvinInterval {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


Kilocalories Property

[image]

Revit 2024 API
UnitTypeId..::..Kilocalories Property
UnitTypeId Class See Also Send Feedback
Kilocalories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Kilocalories { get; }
Visual Basic
Public Shared ReadOnly Property Kilocalories As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Kilocalories {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


KilocaloriesPerSecond Property

[image]

Revit 2024 API
UnitTypeId..::..KilocaloriesPerSecond Property
UnitTypeId Class See Also Send Feedback
Kilocalories per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KilocaloriesPerSecond { get; }
Visual Basic
Public Shared ReadOnly Property KilocaloriesPerSecond As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KilocaloriesPerSecond {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


KilogramForceMeters Property

[image]

Revit 2024 API
UnitTypeId..::..KilogramForceMeters Property
UnitTypeId Class See Also Send Feedback
Kilogram force meters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KilogramForceMeters { get; }
Visual Basic
Public Shared ReadOnly Property KilogramForceMeters As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KilogramForceMeters {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


KilogramForceMetersPerMeter Property

[image]

Revit 2024 API
UnitTypeId..::..KilogramForceMetersPerMeter Property
UnitTypeId Class See Also Send Feedback
Kilogram force meters per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KilogramForceMetersPerMeter { get; }
Visual Basic
Public Shared ReadOnly Property KilogramForceMetersPerMeter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KilogramForceMetersPerMeter {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


Kilograms Property

[image]

Revit 2024 API
UnitTypeId..::..Kilograms Property
UnitTypeId Class See Also Send Feedback
Kilograms.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Kilograms { get; }
Visual Basic
Public Shared ReadOnly Property Kilograms As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Kilograms {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


KilogramsForce Property

[image]

Revit 2024 API
UnitTypeId..::..KilogramsForce Property
UnitTypeId Class See Also Send Feedback
Kilograms force.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KilogramsForce { get; }
Visual Basic
Public Shared ReadOnly Property KilogramsForce As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KilogramsForce {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


KilogramsForcePerMeter Property

[image]

Revit 2024 API
UnitTypeId..::..KilogramsForcePerMeter Property
UnitTypeId Class See Also Send Feedback
Kilograms force per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KilogramsForcePerMeter { get; }
Visual Basic
Public Shared ReadOnly Property KilogramsForcePerMeter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KilogramsForcePerMeter {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


KilogramsForcePerSquareMeter Property

[image]

Revit 2024 API
UnitTypeId..::..KilogramsForcePerSquareMeter Property
UnitTypeId Class See Also Send Feedback
Kilograms force per square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KilogramsForcePerSquareMeter { get; }
Visual Basic
Public Shared ReadOnly Property KilogramsForcePerSquareMeter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KilogramsForcePerSquareMeter {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


KilogramsPerCubicMeter Property

[image]

Revit 2024 API
UnitTypeId..::..KilogramsPerCubicMeter Property
UnitTypeId Class See Also Send Feedback
Kilograms per cubic meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KilogramsPerCubicMeter { get; }
Visual Basic
Public Shared ReadOnly Property KilogramsPerCubicMeter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KilogramsPerCubicMeter {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


KilogramsPerHour Property

[image]

Revit 2024 API
UnitTypeId..::..KilogramsPerHour Property
UnitTypeId Class See Also Send Feedback
Kilograms per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KilogramsPerHour { get; }
Visual Basic
Public Shared ReadOnly Property KilogramsPerHour As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KilogramsPerHour {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


KilogramsPerKilogramKelvin Property

[image]

Revit 2024 API
UnitTypeId..::..KilogramsPerKilogramKelvin Property
UnitTypeId Class See Also Send Feedback
Kilograms per kilogram kelvin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KilogramsPerKilogramKelvin { get; }
Visual Basic
Public Shared ReadOnly Property KilogramsPerKilogramKelvin As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KilogramsPerKilogramKelvin {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


KilogramsPerMeterHour Property

[image]

Revit 2024 API
UnitTypeId..::..KilogramsPerMeterHour Property
UnitTypeId Class See Also Send Feedback
Kilograms per meter hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KilogramsPerMeterHour { get; }
Visual Basic
Public Shared ReadOnly Property KilogramsPerMeterHour As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KilogramsPerMeterHour {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


KilogramsPerMeterSecond Property

[image]

Revit 2024 API
UnitTypeId..::..KilogramsPerMeterSecond Property
UnitTypeId Class See Also Send Feedback
Kilograms per meter second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KilogramsPerMeterSecond { get; }
Visual Basic
Public Shared ReadOnly Property KilogramsPerMeterSecond As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KilogramsPerMeterSecond {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


KilogramsPerSquareMeter Property

[image]

Revit 2024 API
UnitTypeId..::..KilogramsPerSquareMeter Property
UnitTypeId Class See Also Send Feedback
Kilograms per square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KilogramsPerSquareMeter { get; }
Visual Basic
Public Shared ReadOnly Property KilogramsPerSquareMeter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KilogramsPerSquareMeter {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


Kilojoules Property

[image]

Revit 2024 API
UnitTypeId..::..Kilojoules Property
UnitTypeId Class See Also Send Feedback
Kilojoules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Kilojoules { get; }
Visual Basic
Public Shared ReadOnly Property Kilojoules As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Kilojoules {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


KilojoulesPerKelvin Property

[image]

Revit 2024 API
UnitTypeId..::..KilojoulesPerKelvin Property
UnitTypeId Class See Also Send Feedback
Kilojoules per Kelvin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KilojoulesPerKelvin { get; }
Visual Basic
Public Shared ReadOnly Property KilojoulesPerKelvin As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KilojoulesPerKelvin {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


KilojoulesPerSquareMeterKelvin Property

[image]

Revit 2024 API
UnitTypeId..::..KilojoulesPerSquareMeterKelvin Property
UnitTypeId Class See Also Send Feedback
Kilojoules per square meter Kelvin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KilojoulesPerSquareMeterKelvin { get; }
Visual Basic
Public Shared ReadOnly Property KilojoulesPerSquareMeterKelvin As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KilojoulesPerSquareMeterKelvin {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


KilometersPerHour Property

[image]

Revit 2024 API
UnitTypeId..::..KilometersPerHour Property
UnitTypeId Class See Also Send Feedback
Kilometers per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KilometersPerHour { get; }
Visual Basic
Public Shared ReadOnly Property KilometersPerHour As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KilometersPerHour {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


KilometersPerSecondSquared Property

[image]

Revit 2024 API
UnitTypeId..::..KilometersPerSecondSquared Property
UnitTypeId Class See Also Send Feedback
Kilometers per second squared.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KilometersPerSecondSquared { get; }
Visual Basic
Public Shared ReadOnly Property KilometersPerSecondSquared As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KilometersPerSecondSquared {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


KilonewtonMeters Property

[image]

Revit 2024 API
UnitTypeId..::..KilonewtonMeters Property
UnitTypeId Class See Also Send Feedback
Kilonewton meters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KilonewtonMeters { get; }
Visual Basic
Public Shared ReadOnly Property KilonewtonMeters As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KilonewtonMeters {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


KilonewtonMetersPerDegree Property

[image]

Revit 2024 API
UnitTypeId..::..KilonewtonMetersPerDegree Property
UnitTypeId Class See Also Send Feedback
Kilonewton meters per degree.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KilonewtonMetersPerDegree { get; }
Visual Basic
Public Shared ReadOnly Property KilonewtonMetersPerDegree As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KilonewtonMetersPerDegree {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


KilonewtonMetersPerDegreePerMeter Property

[image]

Revit 2024 API
UnitTypeId..::..KilonewtonMetersPerDegreePerMeter Property
UnitTypeId Class See Also Send Feedback
Kilonewton meters per degree per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KilonewtonMetersPerDegreePerMeter { get; }
Visual Basic
Public Shared ReadOnly Property KilonewtonMetersPerDegreePerMeter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KilonewtonMetersPerDegreePerMeter {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


KilonewtonMetersPerMeter Property

[image]

Revit 2024 API
UnitTypeId..::..KilonewtonMetersPerMeter Property
UnitTypeId Class See Also Send Feedback
Kilonewton meters per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KilonewtonMetersPerMeter { get; }
Visual Basic
Public Shared ReadOnly Property KilonewtonMetersPerMeter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KilonewtonMetersPerMeter {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


Kilonewtons Property

[image]

Revit 2024 API
UnitTypeId..::..Kilonewtons Property
UnitTypeId Class See Also Send Feedback
Kilonewtons.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Kilonewtons { get; }
Visual Basic
Public Shared ReadOnly Property Kilonewtons As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Kilonewtons {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


KilonewtonsPerCubicMeter Property

[image]

Revit 2024 API
UnitTypeId..::..KilonewtonsPerCubicMeter Property
UnitTypeId Class See Also Send Feedback
Kilonewtons per cubic meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KilonewtonsPerCubicMeter { get; }
Visual Basic
Public Shared ReadOnly Property KilonewtonsPerCubicMeter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KilonewtonsPerCubicMeter {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


KilonewtonsPerMeter Property

[image]

Revit 2024 API
UnitTypeId..::..KilonewtonsPerMeter Property
UnitTypeId Class See Also Send Feedback
Kilonewtons per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KilonewtonsPerMeter { get; }
Visual Basic
Public Shared ReadOnly Property KilonewtonsPerMeter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KilonewtonsPerMeter {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


KilonewtonsPerSquareCentimeter Property

[image]

Revit 2024 API
UnitTypeId..::..KilonewtonsPerSquareCentimeter Property
UnitTypeId Class See Also Send Feedback
Kilonewtons per square centimeter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KilonewtonsPerSquareCentimeter { get; }
Visual Basic
Public Shared ReadOnly Property KilonewtonsPerSquareCentimeter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KilonewtonsPerSquareCentimeter {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


KilonewtonsPerSquareMeter Property

[image]

Revit 2024 API
UnitTypeId..::..KilonewtonsPerSquareMeter Property
UnitTypeId Class See Also Send Feedback
Kilonewtons per square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KilonewtonsPerSquareMeter { get; }
Visual Basic
Public Shared ReadOnly Property KilonewtonsPerSquareMeter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KilonewtonsPerSquareMeter {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


KilonewtonsPerSquareMillimeter Property

[image]

Revit 2024 API
UnitTypeId..::..KilonewtonsPerSquareMillimeter Property
UnitTypeId Class See Also Send Feedback
Kilonewtons per square millimeter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KilonewtonsPerSquareMillimeter { get; }
Visual Basic
Public Shared ReadOnly Property KilonewtonsPerSquareMillimeter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KilonewtonsPerSquareMillimeter {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


Kilopascals Property

[image]

Revit 2024 API
UnitTypeId..::..Kilopascals Property
UnitTypeId Class See Also Send Feedback
Kilopascals.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Kilopascals { get; }
Visual Basic
Public Shared ReadOnly Property Kilopascals As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Kilopascals {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


KilovoltAmperes Property

[image]

Revit 2024 API
UnitTypeId..::..KilovoltAmperes Property
UnitTypeId Class See Also Send Feedback
Kilovolt amperes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KilovoltAmperes { get; }
Visual Basic
Public Shared ReadOnly Property KilovoltAmperes As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KilovoltAmperes {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


Kilovolts Property

[image]

Revit 2024 API
UnitTypeId..::..Kilovolts Property
UnitTypeId Class See Also Send Feedback
Kilovolts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Kilovolts { get; }
Visual Basic
Public Shared ReadOnly Property Kilovolts As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Kilovolts {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


KilowattHours Property

[image]

Revit 2024 API
UnitTypeId..::..KilowattHours Property
UnitTypeId Class See Also Send Feedback
Kilowatt hours.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KilowattHours { get; }
Visual Basic
Public Shared ReadOnly Property KilowattHours As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KilowattHours {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


Kilowatts Property

[image]

Revit 2024 API
UnitTypeId..::..Kilowatts Property
UnitTypeId Class See Also Send Feedback
Kilowatts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Kilowatts { get; }
Visual Basic
Public Shared ReadOnly Property Kilowatts As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Kilowatts {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


KipFeetPerDegree Property

[image]

Revit 2024 API
UnitTypeId..::..KipFeetPerDegree Property
UnitTypeId Class See Also Send Feedback
Kip feet per degree.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KipFeetPerDegree { get; }
Visual Basic
Public Shared ReadOnly Property KipFeetPerDegree As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KipFeetPerDegree {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


KipFeetPerDegreePerFoot Property

[image]

Revit 2024 API
UnitTypeId..::..KipFeetPerDegreePerFoot Property
UnitTypeId Class See Also Send Feedback
Kip feet per degree per foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KipFeetPerDegreePerFoot { get; }
Visual Basic
Public Shared ReadOnly Property KipFeetPerDegreePerFoot As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KipFeetPerDegreePerFoot {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


Kips Property

[image]

Revit 2024 API
UnitTypeId..::..Kips Property
UnitTypeId Class See Also Send Feedback
Kips.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Kips { get; }
Visual Basic
Public Shared ReadOnly Property Kips As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Kips {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


KipsPerCubicFoot Property

[image]

Revit 2024 API
UnitTypeId..::..KipsPerCubicFoot Property
UnitTypeId Class See Also Send Feedback
Kips per cubic foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KipsPerCubicFoot { get; }
Visual Basic
Public Shared ReadOnly Property KipsPerCubicFoot As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KipsPerCubicFoot {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


KipsPerCubicInch Property

[image]

Revit 2024 API
UnitTypeId..::..KipsPerCubicInch Property
UnitTypeId Class See Also Send Feedback
Kips per cubic inch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KipsPerCubicInch { get; }
Visual Basic
Public Shared ReadOnly Property KipsPerCubicInch As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KipsPerCubicInch {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


KipsPerFoot Property

[image]

Revit 2024 API
UnitTypeId..::..KipsPerFoot Property
UnitTypeId Class See Also Send Feedback
Kips per foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KipsPerFoot { get; }
Visual Basic
Public Shared ReadOnly Property KipsPerFoot As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KipsPerFoot {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


KipsPerInch Property

[image]

Revit 2024 API
UnitTypeId..::..KipsPerInch Property
UnitTypeId Class See Also Send Feedback
Kips per inch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KipsPerInch { get; }
Visual Basic
Public Shared ReadOnly Property KipsPerInch As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KipsPerInch {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


KipsPerSquareFoot Property

[image]

Revit 2024 API
UnitTypeId..::..KipsPerSquareFoot Property
UnitTypeId Class See Also Send Feedback
Kips per square foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId KipsPerSquareFoot { get; }
Visual Basic
Public Shared ReadOnly Property KipsPerSquareFoot As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ KipsPerSquareFoot {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


LitersPerHour Property

[image]

Revit 2024 API
UnitTypeId..::..LitersPerHour Property
UnitTypeId Class See Also Send Feedback
Liters per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId LitersPerHour { get; }
Visual Basic
Public Shared ReadOnly Property LitersPerHour As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LitersPerHour {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


LitersPerMinute Property

[image]

Revit 2024 API
UnitTypeId..::..LitersPerMinute Property
UnitTypeId Class See Also Send Feedback
Liters per minute.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId LitersPerMinute { get; }
Visual Basic
Public Shared ReadOnly Property LitersPerMinute As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LitersPerMinute {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


LitersPerSecond Property

[image]

Revit 2024 API
UnitTypeId..::..LitersPerSecond Property
UnitTypeId Class See Also Send Feedback
Liters per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId LitersPerSecond { get; }
Visual Basic
Public Shared ReadOnly Property LitersPerSecond As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LitersPerSecond {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


LitersPerSecondCubicMeter Property

[image]

Revit 2024 API
UnitTypeId..::..LitersPerSecondCubicMeter Property
UnitTypeId Class See Also Send Feedback
Liters per second cubic meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId LitersPerSecondCubicMeter { get; }
Visual Basic
Public Shared ReadOnly Property LitersPerSecondCubicMeter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LitersPerSecondCubicMeter {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


LitersPerSecondKilowatt Property

[image]

Revit 2024 API
UnitTypeId..::..LitersPerSecondKilowatt Property
UnitTypeId Class See Also Send Feedback
Liters per second kilowatt.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId LitersPerSecondKilowatt { get; }
Visual Basic
Public Shared ReadOnly Property LitersPerSecondKilowatt As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LitersPerSecondKilowatt {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


LitersPerSecondSquareMeter Property

[image]

Revit 2024 API
UnitTypeId..::..LitersPerSecondSquareMeter Property
UnitTypeId Class See Also Send Feedback
Liters per second square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId LitersPerSecondSquareMeter { get; }
Visual Basic
Public Shared ReadOnly Property LitersPerSecondSquareMeter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ LitersPerSecondSquareMeter {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


MeganewtonMeters Property

[image]

Revit 2024 API
UnitTypeId..::..MeganewtonMeters Property
UnitTypeId Class See Also Send Feedback
Meganewton meters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MeganewtonMeters { get; }
Visual Basic
Public Shared ReadOnly Property MeganewtonMeters As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MeganewtonMeters {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


Meganewtons Property

[image]

Revit 2024 API
UnitTypeId..::..Meganewtons Property
UnitTypeId Class See Also Send Feedback
Meganewtons.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Meganewtons { get; }
Visual Basic
Public Shared ReadOnly Property Meganewtons As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Meganewtons {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


MeganewtonsPerMeter Property

[image]

Revit 2024 API
UnitTypeId..::..MeganewtonsPerMeter Property
UnitTypeId Class See Also Send Feedback
Meganewtons per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MeganewtonsPerMeter { get; }
Visual Basic
Public Shared ReadOnly Property MeganewtonsPerMeter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MeganewtonsPerMeter {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


Megapascals Property

[image]

Revit 2024 API
UnitTypeId..::..Megapascals Property
UnitTypeId Class See Also Send Feedback
Megapascals.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Megapascals { get; }
Visual Basic
Public Shared ReadOnly Property Megapascals As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Megapascals {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


Meters Property

[image]

Revit 2024 API
UnitTypeId..::..Meters Property
UnitTypeId Class See Also Send Feedback
Meters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Meters { get; }
Visual Basic
Public Shared ReadOnly Property Meters As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Meters {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


MetersCentimeters Property

[image]

Revit 2024 API
UnitTypeId..::..MetersCentimeters Property
UnitTypeId Class See Also Send Feedback
Meters and centimeters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MetersCentimeters { get; }
Visual Basic
Public Shared ReadOnly Property MetersCentimeters As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MetersCentimeters {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


MetersOfWaterColumn Property

[image]

Revit 2024 API
UnitTypeId..::..MetersOfWaterColumn Property
UnitTypeId Class See Also Send Feedback
Meters of water column.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MetersOfWaterColumn { get; }
Visual Basic
Public Shared ReadOnly Property MetersOfWaterColumn As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MetersOfWaterColumn {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


MetersPerKilonewton Property

[image]

Revit 2024 API
UnitTypeId..::..MetersPerKilonewton Property
UnitTypeId Class See Also Send Feedback
Meters per kilonewton.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MetersPerKilonewton { get; }
Visual Basic
Public Shared ReadOnly Property MetersPerKilonewton As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MetersPerKilonewton {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


MetersPerSecond Property

[image]

Revit 2024 API
UnitTypeId..::..MetersPerSecond Property
UnitTypeId Class See Also Send Feedback
Meters per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MetersPerSecond { get; }
Visual Basic
Public Shared ReadOnly Property MetersPerSecond As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MetersPerSecond {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


MetersPerSecondSquared Property

[image]

Revit 2024 API
UnitTypeId..::..MetersPerSecondSquared Property
UnitTypeId Class See Also Send Feedback
Meters per second squared.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MetersPerSecondSquared { get; }
Visual Basic
Public Shared ReadOnly Property MetersPerSecondSquared As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MetersPerSecondSquared {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


MetersToTheFourthPower Property

[image]

Revit 2024 API
UnitTypeId..::..MetersToTheFourthPower Property
UnitTypeId Class See Also Send Feedback
Meters to the fourth power.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MetersToTheFourthPower { get; }
Visual Basic
Public Shared ReadOnly Property MetersToTheFourthPower As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MetersToTheFourthPower {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


MetersToTheSixthPower Property

[image]

Revit 2024 API
UnitTypeId..::..MetersToTheSixthPower Property
UnitTypeId Class See Also Send Feedback
Meters to the sixth power.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MetersToTheSixthPower { get; }
Visual Basic
Public Shared ReadOnly Property MetersToTheSixthPower As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MetersToTheSixthPower {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


MicroinchesPerInchDegreeFahrenheit Property

[image]

Revit 2024 API
UnitTypeId..::..MicroinchesPerInchDegreeFahrenheit Property
UnitTypeId Class See Also Send Feedback
Microinches per inch degree Fahrenheit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MicroinchesPerInchDegreeFahrenheit { get; }
Visual Basic
Public Shared ReadOnly Property MicroinchesPerInchDegreeFahrenheit As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MicroinchesPerInchDegreeFahrenheit {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


MicrometersPerMeterDegreeCelsius Property

[image]

Revit 2024 API
UnitTypeId..::..MicrometersPerMeterDegreeCelsius Property
UnitTypeId Class See Also Send Feedback
Micrometers per meter degree Celsius.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MicrometersPerMeterDegreeCelsius { get; }
Visual Basic
Public Shared ReadOnly Property MicrometersPerMeterDegreeCelsius As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MicrometersPerMeterDegreeCelsius {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


MilesPerHour Property

[image]

Revit 2024 API
UnitTypeId..::..MilesPerHour Property
UnitTypeId Class See Also Send Feedback
Miles per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MilesPerHour { get; }
Visual Basic
Public Shared ReadOnly Property MilesPerHour As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MilesPerHour {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


MilesPerSecondSquared Property

[image]

Revit 2024 API
UnitTypeId..::..MilesPerSecondSquared Property
UnitTypeId Class See Also Send Feedback
Miles per second squared.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MilesPerSecondSquared { get; }
Visual Basic
Public Shared ReadOnly Property MilesPerSecondSquared As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MilesPerSecondSquared {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


Milliamperes Property

[image]

Revit 2024 API
UnitTypeId..::..Milliamperes Property
UnitTypeId Class See Also Send Feedback
Milliamperes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Milliamperes { get; }
Visual Basic
Public Shared ReadOnly Property Milliamperes As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Milliamperes {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


Millimeters Property

[image]

Revit 2024 API
UnitTypeId..::..Millimeters Property
UnitTypeId Class See Also Send Feedback
Millimeters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Millimeters { get; }
Visual Basic
Public Shared ReadOnly Property Millimeters As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Millimeters {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


MillimetersOfWaterColumn Property

[image]

Revit 2024 API
UnitTypeId..::..MillimetersOfWaterColumn Property
UnitTypeId Class See Also Send Feedback
Millimeters of water column.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MillimetersOfWaterColumn { get; }
Visual Basic
Public Shared ReadOnly Property MillimetersOfWaterColumn As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MillimetersOfWaterColumn {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


MillimetersOfWaterColumnPerMeter Property

[image]

Revit 2024 API
UnitTypeId..::..MillimetersOfWaterColumnPerMeter Property
UnitTypeId Class See Also Send Feedback
Millimeters of water column per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MillimetersOfWaterColumnPerMeter { get; }
Visual Basic
Public Shared ReadOnly Property MillimetersOfWaterColumnPerMeter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MillimetersOfWaterColumnPerMeter {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


MillimetersToTheFourthPower Property

[image]

Revit 2024 API
UnitTypeId..::..MillimetersToTheFourthPower Property
UnitTypeId Class See Also Send Feedback
Millimeters to the fourth power.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MillimetersToTheFourthPower { get; }
Visual Basic
Public Shared ReadOnly Property MillimetersToTheFourthPower As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MillimetersToTheFourthPower {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


MillimetersToTheSixthPower Property

[image]

Revit 2024 API
UnitTypeId..::..MillimetersToTheSixthPower Property
UnitTypeId Class See Also Send Feedback
Millimeters to the sixth power.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId MillimetersToTheSixthPower { get; }
Visual Basic
Public Shared ReadOnly Property MillimetersToTheSixthPower As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ MillimetersToTheSixthPower {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


Millivolts Property

[image]

Revit 2024 API
UnitTypeId..::..Millivolts Property
UnitTypeId Class See Also Send Feedback
Millivolts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Millivolts { get; }
Visual Basic
Public Shared ReadOnly Property Millivolts As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Millivolts {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


Minutes Property

[image]

Revit 2024 API
UnitTypeId..::..Minutes Property
UnitTypeId Class See Also Send Feedback
Minutes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Minutes { get; }
Visual Basic
Public Shared ReadOnly Property Minutes As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Minutes {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


NewtonMeters Property

[image]

Revit 2024 API
UnitTypeId..::..NewtonMeters Property
UnitTypeId Class See Also Send Feedback
Newton meters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId NewtonMeters { get; }
Visual Basic
Public Shared ReadOnly Property NewtonMeters As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ NewtonMeters {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


NewtonMetersPerMeter Property

[image]

Revit 2024 API
UnitTypeId..::..NewtonMetersPerMeter Property
UnitTypeId Class See Also Send Feedback
Newton meters per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId NewtonMetersPerMeter { get; }
Visual Basic
Public Shared ReadOnly Property NewtonMetersPerMeter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ NewtonMetersPerMeter {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


Newtons Property

[image]

Revit 2024 API
UnitTypeId..::..Newtons Property
UnitTypeId Class See Also Send Feedback
Newtons.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Newtons { get; }
Visual Basic
Public Shared ReadOnly Property Newtons As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Newtons {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


NewtonSecondsPerSquareMeter Property

[image]

Revit 2024 API
UnitTypeId..::..NewtonSecondsPerSquareMeter Property
UnitTypeId Class See Also Send Feedback
Newton seconds per square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId NewtonSecondsPerSquareMeter { get; }
Visual Basic
Public Shared ReadOnly Property NewtonSecondsPerSquareMeter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ NewtonSecondsPerSquareMeter {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


NewtonsPerMeter Property

[image]

Revit 2024 API
UnitTypeId..::..NewtonsPerMeter Property
UnitTypeId Class See Also Send Feedback
Newtons per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId NewtonsPerMeter { get; }
Visual Basic
Public Shared ReadOnly Property NewtonsPerMeter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ NewtonsPerMeter {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


NewtonsPerSquareMeter Property

[image]

Revit 2024 API
UnitTypeId..::..NewtonsPerSquareMeter Property
UnitTypeId Class See Also Send Feedback
Newtons per square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId NewtonsPerSquareMeter { get; }
Visual Basic
Public Shared ReadOnly Property NewtonsPerSquareMeter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ NewtonsPerSquareMeter {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


NewtonsPerSquareMillimeter Property

[image]

Revit 2024 API
UnitTypeId..::..NewtonsPerSquareMillimeter Property
UnitTypeId Class See Also Send Feedback
Newtons per square millimeter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId NewtonsPerSquareMillimeter { get; }
Visual Basic
Public Shared ReadOnly Property NewtonsPerSquareMillimeter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ NewtonsPerSquareMillimeter {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


OhmMeters Property

[image]

Revit 2024 API
UnitTypeId..::..OhmMeters Property
UnitTypeId Class See Also Send Feedback
Ohm meters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId OhmMeters { get; }
Visual Basic
Public Shared ReadOnly Property OhmMeters As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ OhmMeters {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


OneToRatio Property

[image]

Revit 2024 API
UnitTypeId..::..OneToRatio Property
UnitTypeId Class See Also Send Feedback
1 : Ratio.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId OneToRatio { get; }
Visual Basic
Public Shared ReadOnly Property OneToRatio As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ OneToRatio {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


Pascals Property

[image]

Revit 2024 API
UnitTypeId..::..Pascals Property
UnitTypeId Class See Also Send Feedback
Pascals.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Pascals { get; }
Visual Basic
Public Shared ReadOnly Property Pascals As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Pascals {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


PascalSeconds Property

[image]

Revit 2024 API
UnitTypeId..::..PascalSeconds Property
UnitTypeId Class See Also Send Feedback
Pascal seconds.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId PascalSeconds { get; }
Visual Basic
Public Shared ReadOnly Property PascalSeconds As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PascalSeconds {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


PascalsPerMeter Property

[image]

Revit 2024 API
UnitTypeId..::..PascalsPerMeter Property
UnitTypeId Class See Also Send Feedback
Pascals per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId PascalsPerMeter { get; }
Visual Basic
Public Shared ReadOnly Property PascalsPerMeter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PascalsPerMeter {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


Percentage Property

[image]

Revit 2024 API
UnitTypeId..::..Percentage Property
UnitTypeId Class See Also Send Feedback
Percentage.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Percentage { get; }
Visual Basic
Public Shared ReadOnly Property Percentage As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Percentage {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


PerMille Property

[image]

Revit 2024 API
UnitTypeId..::..PerMille Property
UnitTypeId Class See Also Send Feedback
Per mille.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId PerMille { get; }
Visual Basic
Public Shared ReadOnly Property PerMille As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PerMille {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


Pi Property

[image]

Revit 2024 API
UnitTypeId..::..Pi Property
UnitTypeId Class See Also Send Feedback
Multiples of Ï€.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Pi { get; }
Visual Basic
Public Shared ReadOnly Property Pi As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Pi {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


PoundForceFeet Property

[image]

Revit 2024 API
UnitTypeId..::..PoundForceFeet Property
UnitTypeId Class See Also Send Feedback
Pound force feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId PoundForceFeet { get; }
Visual Basic
Public Shared ReadOnly Property PoundForceFeet As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PoundForceFeet {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


PoundForceSecondsPerSquareFoot Property

[image]

Revit 2024 API
UnitTypeId..::..PoundForceSecondsPerSquareFoot Property
UnitTypeId Class See Also Send Feedback
Pound force seconds per square foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId PoundForceSecondsPerSquareFoot { get; }
Visual Basic
Public Shared ReadOnly Property PoundForceSecondsPerSquareFoot As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PoundForceSecondsPerSquareFoot {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


PoundsForce Property

[image]

Revit 2024 API
UnitTypeId..::..PoundsForce Property
UnitTypeId Class See Also Send Feedback
Pounds force.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId PoundsForce { get; }
Visual Basic
Public Shared ReadOnly Property PoundsForce As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PoundsForce {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


PoundsForcePerCubicFoot Property

[image]

Revit 2024 API
UnitTypeId..::..PoundsForcePerCubicFoot Property
UnitTypeId Class See Also Send Feedback
Pounds force per cubic foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId PoundsForcePerCubicFoot { get; }
Visual Basic
Public Shared ReadOnly Property PoundsForcePerCubicFoot As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PoundsForcePerCubicFoot {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


PoundsForcePerFoot Property

[image]

Revit 2024 API
UnitTypeId..::..PoundsForcePerFoot Property
UnitTypeId Class See Also Send Feedback
Pounds force per foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId PoundsForcePerFoot { get; }
Visual Basic
Public Shared ReadOnly Property PoundsForcePerFoot As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PoundsForcePerFoot {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


PoundsForcePerSquareFoot Property

[image]

Revit 2024 API
UnitTypeId..::..PoundsForcePerSquareFoot Property
UnitTypeId Class See Also Send Feedback
Pounds force per square foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId PoundsForcePerSquareFoot { get; }
Visual Basic
Public Shared ReadOnly Property PoundsForcePerSquareFoot As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PoundsForcePerSquareFoot {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


PoundsMass Property

[image]

Revit 2024 API
UnitTypeId..::..PoundsMass Property
UnitTypeId Class See Also Send Feedback
Pounds mass.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId PoundsMass { get; }
Visual Basic
Public Shared ReadOnly Property PoundsMass As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PoundsMass {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


PoundsMassPerCubicFoot Property

[image]

Revit 2024 API
UnitTypeId..::..PoundsMassPerCubicFoot Property
UnitTypeId Class See Also Send Feedback
Pounds mass per cubic foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId PoundsMassPerCubicFoot { get; }
Visual Basic
Public Shared ReadOnly Property PoundsMassPerCubicFoot As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PoundsMassPerCubicFoot {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


PoundsMassPerCubicInch Property

[image]

Revit 2024 API
UnitTypeId..::..PoundsMassPerCubicInch Property
UnitTypeId Class See Also Send Feedback
Pounds mass per cubic inch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId PoundsMassPerCubicInch { get; }
Visual Basic
Public Shared ReadOnly Property PoundsMassPerCubicInch As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PoundsMassPerCubicInch {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


PoundsMassPerFoot Property

[image]

Revit 2024 API
UnitTypeId..::..PoundsMassPerFoot Property
UnitTypeId Class See Also Send Feedback
Pounds mass per foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId PoundsMassPerFoot { get; }
Visual Basic
Public Shared ReadOnly Property PoundsMassPerFoot As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PoundsMassPerFoot {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


PoundsMassPerFootSecond Property

[image]

Revit 2024 API
UnitTypeId..::..PoundsMassPerFootSecond Property
UnitTypeId Class See Also Send Feedback
Pounds mass per foot second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId PoundsMassPerFootSecond { get; }
Visual Basic
Public Shared ReadOnly Property PoundsMassPerFootSecond As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PoundsMassPerFootSecond {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


PoundsMassPerHour Property

[image]

Revit 2024 API
UnitTypeId..::..PoundsMassPerHour Property
UnitTypeId Class See Also Send Feedback
Pounds mass per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId PoundsMassPerHour { get; }
Visual Basic
Public Shared ReadOnly Property PoundsMassPerHour As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PoundsMassPerHour {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


PoundsMassPerMinute Property

[image]

Revit 2024 API
UnitTypeId..::..PoundsMassPerMinute Property
UnitTypeId Class See Also Send Feedback
Pounds mass per minute.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId PoundsMassPerMinute { get; }
Visual Basic
Public Shared ReadOnly Property PoundsMassPerMinute As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PoundsMassPerMinute {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


PoundsMassPerPoundDegreeFahrenheit Property

[image]

Revit 2024 API
UnitTypeId..::..PoundsMassPerPoundDegreeFahrenheit Property
UnitTypeId Class See Also Send Feedback
Pounds mass per pound degree Fahrenheit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId PoundsMassPerPoundDegreeFahrenheit { get; }
Visual Basic
Public Shared ReadOnly Property PoundsMassPerPoundDegreeFahrenheit As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PoundsMassPerPoundDegreeFahrenheit {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


PoundsMassPerSecond Property

[image]

Revit 2024 API
UnitTypeId..::..PoundsMassPerSecond Property
UnitTypeId Class See Also Send Feedback
Pounds mass per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId PoundsMassPerSecond { get; }
Visual Basic
Public Shared ReadOnly Property PoundsMassPerSecond As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PoundsMassPerSecond {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


PoundsMassPerSquareFoot Property

[image]

Revit 2024 API
UnitTypeId..::..PoundsMassPerSquareFoot Property
UnitTypeId Class See Also Send Feedback
Pounds mass per square foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId PoundsMassPerSquareFoot { get; }
Visual Basic
Public Shared ReadOnly Property PoundsMassPerSquareFoot As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ PoundsMassPerSquareFoot {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


Radians Property

[image]

Revit 2024 API
UnitTypeId..::..Radians Property
UnitTypeId Class See Also Send Feedback
Radians.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Radians { get; }
Visual Basic
Public Shared ReadOnly Property Radians As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Radians {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


RadiansPerSecond Property

[image]

Revit 2024 API
UnitTypeId..::..RadiansPerSecond Property
UnitTypeId Class See Also Send Feedback
Radians per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId RadiansPerSecond { get; }
Visual Basic
Public Shared ReadOnly Property RadiansPerSecond As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RadiansPerSecond {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


Rankine Property

[image]

Revit 2024 API
UnitTypeId..::..Rankine Property
UnitTypeId Class See Also Send Feedback
Rankine.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Rankine { get; }
Visual Basic
Public Shared ReadOnly Property Rankine As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Rankine {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


RankineInterval Property

[image]

Revit 2024 API
UnitTypeId..::..RankineInterval Property
UnitTypeId Class See Also Send Feedback
Rankine interval.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId RankineInterval { get; }
Visual Basic
Public Shared ReadOnly Property RankineInterval As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RankineInterval {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


RatioTo1 Property

[image]

Revit 2024 API
UnitTypeId..::..RatioTo1 Property
UnitTypeId Class See Also Send Feedback
Ratio : 1.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId RatioTo1 { get; }
Visual Basic
Public Shared ReadOnly Property RatioTo1 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RatioTo1 {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


RatioTo10 Property

[image]

Revit 2024 API
UnitTypeId..::..RatioTo10 Property
UnitTypeId Class See Also Send Feedback
Ratio : 10.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId RatioTo10 { get; }
Visual Basic
Public Shared ReadOnly Property RatioTo10 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RatioTo10 {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


RatioTo12 Property

[image]

Revit 2024 API
UnitTypeId..::..RatioTo12 Property
UnitTypeId Class See Also Send Feedback
Ratio : 12.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId RatioTo12 { get; }
Visual Basic
Public Shared ReadOnly Property RatioTo12 As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RatioTo12 {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


RevolutionsPerMinute Property

[image]

Revit 2024 API
UnitTypeId..::..RevolutionsPerMinute Property
UnitTypeId Class See Also Send Feedback
Revolutions per minute.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId RevolutionsPerMinute { get; }
Visual Basic
Public Shared ReadOnly Property RevolutionsPerMinute As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RevolutionsPerMinute {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


RevolutionsPerSecond Property

[image]

Revit 2024 API
UnitTypeId..::..RevolutionsPerSecond Property
UnitTypeId Class See Also Send Feedback
Revolutions per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId RevolutionsPerSecond { get; }
Visual Basic
Public Shared ReadOnly Property RevolutionsPerSecond As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RevolutionsPerSecond {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


RiseDividedBy1000Millimeters Property

[image]

Revit 2024 API
UnitTypeId..::..RiseDividedBy1000Millimeters Property
UnitTypeId Class See Also Send Feedback
Rise / 1000 millimeters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId RiseDividedBy1000Millimeters { get; }
Visual Basic
Public Shared ReadOnly Property RiseDividedBy1000Millimeters As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RiseDividedBy1000Millimeters {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


RiseDividedBy120Inches Property

[image]

Revit 2024 API
UnitTypeId..::..RiseDividedBy120Inches Property
UnitTypeId Class See Also Send Feedback
Rise / 120 inches.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId RiseDividedBy120Inches { get; }
Visual Basic
Public Shared ReadOnly Property RiseDividedBy120Inches As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ RiseDividedBy120Inches {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


Seconds Property

[image]

Revit 2024 API
UnitTypeId..::..Seconds Property
UnitTypeId Class See Also Send Feedback
Seconds.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Seconds { get; }
Visual Basic
Public Shared ReadOnly Property Seconds As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Seconds {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


SlopeDegrees Property

[image]

Revit 2024 API
UnitTypeId..::..SlopeDegrees Property
UnitTypeId Class See Also Send Feedback
Degrees.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId SlopeDegrees { get; }
Visual Basic
Public Shared ReadOnly Property SlopeDegrees As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SlopeDegrees {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


SquareCentimeters Property

[image]

Revit 2024 API
UnitTypeId..::..SquareCentimeters Property
UnitTypeId Class See Also Send Feedback
Square centimeters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId SquareCentimeters { get; }
Visual Basic
Public Shared ReadOnly Property SquareCentimeters As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SquareCentimeters {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


SquareCentimetersPerMeter Property

[image]

Revit 2024 API
UnitTypeId..::..SquareCentimetersPerMeter Property
UnitTypeId Class See Also Send Feedback
Square centimeters per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId SquareCentimetersPerMeter { get; }
Visual Basic
Public Shared ReadOnly Property SquareCentimetersPerMeter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SquareCentimetersPerMeter {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


SquareFeet Property

[image]

Revit 2024 API
UnitTypeId..::..SquareFeet Property
UnitTypeId Class See Also Send Feedback
Square feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId SquareFeet { get; }
Visual Basic
Public Shared ReadOnly Property SquareFeet As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SquareFeet {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


SquareFeetPer1000BritishThermalUnitsPerHour Property

[image]

Revit 2024 API
UnitTypeId..::..SquareFeetPer1000BritishThermalUnitsPerHour Property
UnitTypeId Class See Also Send Feedback
Square feet per thousand British thermal units per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId SquareFeetPer1000BritishThermalUnitsPerHour { get; }
Visual Basic
Public Shared ReadOnly Property SquareFeetPer1000BritishThermalUnitsPerHour As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SquareFeetPer1000BritishThermalUnitsPerHour {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


SquareFeetPerFoot Property

[image]

Revit 2024 API
UnitTypeId..::..SquareFeetPerFoot Property
UnitTypeId Class See Also Send Feedback
Square feet per foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId SquareFeetPerFoot { get; }
Visual Basic
Public Shared ReadOnly Property SquareFeetPerFoot As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SquareFeetPerFoot {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


SquareFeetPerSecond Property

[image]

Revit 2024 API
UnitTypeId..::..SquareFeetPerSecond Property
UnitTypeId Class See Also Send Feedback
Square feet per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId SquareFeetPerSecond { get; }
Visual Basic
Public Shared ReadOnly Property SquareFeetPerSecond As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SquareFeetPerSecond {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


SquareFeetPerTonOfRefrigeration Property

[image]

Revit 2024 API
UnitTypeId..::..SquareFeetPerTonOfRefrigeration Property
UnitTypeId Class See Also Send Feedback
Square feet per ton of refrigeration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId SquareFeetPerTonOfRefrigeration { get; }
Visual Basic
Public Shared ReadOnly Property SquareFeetPerTonOfRefrigeration As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SquareFeetPerTonOfRefrigeration {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


SquareInchesPerFoot Property

[image]

Revit 2024 API
UnitTypeId..::..SquareInchesPerFoot Property
UnitTypeId Class See Also Send Feedback
Square inches per foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId SquareInchesPerFoot { get; }
Visual Basic
Public Shared ReadOnly Property SquareInchesPerFoot As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SquareInchesPerFoot {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


SquareMeterKelvinsPerWatt Property

[image]

Revit 2024 API
UnitTypeId..::..SquareMeterKelvinsPerWatt Property
UnitTypeId Class See Also Send Feedback
Square meter kelvins per watt.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId SquareMeterKelvinsPerWatt { get; }
Visual Basic
Public Shared ReadOnly Property SquareMeterKelvinsPerWatt As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SquareMeterKelvinsPerWatt {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


SquareMeters Property

[image]

Revit 2024 API
UnitTypeId..::..SquareMeters Property
UnitTypeId Class See Also Send Feedback
Square meters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId SquareMeters { get; }
Visual Basic
Public Shared ReadOnly Property SquareMeters As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SquareMeters {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


SquareMetersPerMeter Property

[image]

Revit 2024 API
UnitTypeId..::..SquareMetersPerMeter Property
UnitTypeId Class See Also Send Feedback
Square meters per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId SquareMetersPerMeter { get; }
Visual Basic
Public Shared ReadOnly Property SquareMetersPerMeter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SquareMetersPerMeter {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


SquareMetersPerSecond Property

[image]

Revit 2024 API
UnitTypeId..::..SquareMetersPerSecond Property
UnitTypeId Class See Also Send Feedback
Square meters per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId SquareMetersPerSecond { get; }
Visual Basic
Public Shared ReadOnly Property SquareMetersPerSecond As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SquareMetersPerSecond {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


SquareMillimeters Property

[image]

Revit 2024 API
UnitTypeId..::..SquareMillimeters Property
UnitTypeId Class See Also Send Feedback
Square millimeters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId SquareMillimeters { get; }
Visual Basic
Public Shared ReadOnly Property SquareMillimeters As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SquareMillimeters {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


SquareMillimetersPerMeter Property

[image]

Revit 2024 API
UnitTypeId..::..SquareMillimetersPerMeter Property
UnitTypeId Class See Also Send Feedback
Square millimeters per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId SquareMillimetersPerMeter { get; }
Visual Basic
Public Shared ReadOnly Property SquareMillimetersPerMeter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ SquareMillimetersPerMeter {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


StationingFeet Property

[image]

Revit 2024 API
UnitTypeId..::..StationingFeet Property
UnitTypeId Class See Also Send Feedback
Feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId StationingFeet { get; }
Visual Basic
Public Shared ReadOnly Property StationingFeet As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StationingFeet {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


StationingMeters Property

[image]

Revit 2024 API
UnitTypeId..::..StationingMeters Property
UnitTypeId Class See Also Send Feedback
Meters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId StationingMeters { get; }
Visual Basic
Public Shared ReadOnly Property StationingMeters As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StationingMeters {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


StationingSurveyFeet Property

[image]

Revit 2024 API
UnitTypeId..::..StationingSurveyFeet Property
UnitTypeId Class See Also Send Feedback
US survey feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId StationingSurveyFeet { get; }
Visual Basic
Public Shared ReadOnly Property StationingSurveyFeet As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ StationingSurveyFeet {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


Therms Property

[image]

Revit 2024 API
UnitTypeId..::..Therms Property
UnitTypeId Class See Also Send Feedback
Therms.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Therms { get; }
Visual Basic
Public Shared ReadOnly Property Therms As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Therms {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


TonneForceMeters Property

[image]

Revit 2024 API
UnitTypeId..::..TonneForceMeters Property
UnitTypeId Class See Also Send Feedback
Tonne force meters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId TonneForceMeters { get; }
Visual Basic
Public Shared ReadOnly Property TonneForceMeters As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TonneForceMeters {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


TonneForceMetersPerMeter Property

[image]

Revit 2024 API
UnitTypeId..::..TonneForceMetersPerMeter Property
UnitTypeId Class See Also Send Feedback
Tonne force meters per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId TonneForceMetersPerMeter { get; }
Visual Basic
Public Shared ReadOnly Property TonneForceMetersPerMeter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TonneForceMetersPerMeter {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


Tonnes Property

[image]

Revit 2024 API
UnitTypeId..::..Tonnes Property
UnitTypeId Class See Also Send Feedback
Tonnes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Tonnes { get; }
Visual Basic
Public Shared ReadOnly Property Tonnes As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Tonnes {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


TonnesForcePerMeter Property

[image]

Revit 2024 API
UnitTypeId..::..TonnesForcePerMeter Property
UnitTypeId Class See Also Send Feedback
Tonnes force per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId TonnesForcePerMeter { get; }
Visual Basic
Public Shared ReadOnly Property TonnesForcePerMeter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TonnesForcePerMeter {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


TonnesForcePerSquareMeter Property

[image]

Revit 2024 API
UnitTypeId..::..TonnesForcePerSquareMeter Property
UnitTypeId Class See Also Send Feedback
Tonnes force per square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId TonnesForcePerSquareMeter { get; }
Visual Basic
Public Shared ReadOnly Property TonnesForcePerSquareMeter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TonnesForcePerSquareMeter {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


TonsOfRefrigeration Property

[image]

Revit 2024 API
UnitTypeId..::..TonsOfRefrigeration Property
UnitTypeId Class See Also Send Feedback
Tons of refrigeration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId TonsOfRefrigeration { get; }
Visual Basic
Public Shared ReadOnly Property TonsOfRefrigeration As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ TonsOfRefrigeration {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


UsGallons Property

[image]

Revit 2024 API
UnitTypeId..::..UsGallons Property
UnitTypeId Class See Also Send Feedback
US gallons.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId UsGallons { get; }
Visual Basic
Public Shared ReadOnly Property UsGallons As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ UsGallons {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


UsGallonsPerHour Property

[image]

Revit 2024 API
UnitTypeId..::..UsGallonsPerHour Property
UnitTypeId Class See Also Send Feedback
US gallons per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId UsGallonsPerHour { get; }
Visual Basic
Public Shared ReadOnly Property UsGallonsPerHour As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ UsGallonsPerHour {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


UsGallonsPerMinute Property

[image]

Revit 2024 API
UnitTypeId..::..UsGallonsPerMinute Property
UnitTypeId Class See Also Send Feedback
US gallons per minute.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId UsGallonsPerMinute { get; }
Visual Basic
Public Shared ReadOnly Property UsGallonsPerMinute As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ UsGallonsPerMinute {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


UsSurveyFeet Property

[image]

Revit 2024 API
UnitTypeId..::..UsSurveyFeet Property
UnitTypeId Class See Also Send Feedback
US survey feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId UsSurveyFeet { get; }
Visual Basic
Public Shared ReadOnly Property UsSurveyFeet As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ UsSurveyFeet {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


UsTonnesForce Property

[image]

Revit 2024 API
UnitTypeId..::..UsTonnesForce Property
UnitTypeId Class See Also Send Feedback
US tonnes force.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId UsTonnesForce { get; }
Visual Basic
Public Shared ReadOnly Property UsTonnesForce As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ UsTonnesForce {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


UsTonnesMass Property

[image]

Revit 2024 API
UnitTypeId..::..UsTonnesMass Property
UnitTypeId Class See Also Send Feedback
US tonnes mass.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId UsTonnesMass { get; }
Visual Basic
Public Shared ReadOnly Property UsTonnesMass As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ UsTonnesMass {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


VoltAmperesPerSquareFoot Property

[image]

Revit 2024 API
UnitTypeId..::..VoltAmperesPerSquareFoot Property
UnitTypeId Class See Also Send Feedback
Volt amperes per square foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId VoltAmperesPerSquareFoot { get; }
Visual Basic
Public Shared ReadOnly Property VoltAmperesPerSquareFoot As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ VoltAmperesPerSquareFoot {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


Volts Property

[image]

Revit 2024 API
UnitTypeId..::..Volts Property
UnitTypeId Class See Also Send Feedback
Volts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Volts { get; }
Visual Basic
Public Shared ReadOnly Property Volts As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Volts {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


Watts Property

[image]

Revit 2024 API
UnitTypeId..::..Watts Property
UnitTypeId Class See Also Send Feedback
Watts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId Watts { get; }
Visual Basic
Public Shared ReadOnly Property Watts As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ Watts {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


WattsPerCubicFoot Property

[image]

Revit 2024 API
UnitTypeId..::..WattsPerCubicFoot Property
UnitTypeId Class See Also Send Feedback
Watts per cubic foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId WattsPerCubicFoot { get; }
Visual Basic
Public Shared ReadOnly Property WattsPerCubicFoot As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WattsPerCubicFoot {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


WattsPerCubicFootPerMinute Property

[image]

Revit 2024 API
UnitTypeId..::..WattsPerCubicFootPerMinute Property
UnitTypeId Class See Also Send Feedback
Watts per cubic foot per minute.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId WattsPerCubicFootPerMinute { get; }
Visual Basic
Public Shared ReadOnly Property WattsPerCubicFootPerMinute As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WattsPerCubicFootPerMinute {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


WattsPerCubicMeter Property

[image]

Revit 2024 API
UnitTypeId..::..WattsPerCubicMeter Property
UnitTypeId Class See Also Send Feedback
Watts per cubic meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId WattsPerCubicMeter { get; }
Visual Basic
Public Shared ReadOnly Property WattsPerCubicMeter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WattsPerCubicMeter {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


WattsPerCubicMeterPerSecond Property

[image]

Revit 2024 API
UnitTypeId..::..WattsPerCubicMeterPerSecond Property
UnitTypeId Class See Also Send Feedback
Watts per cubic meter per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId WattsPerCubicMeterPerSecond { get; }
Visual Basic
Public Shared ReadOnly Property WattsPerCubicMeterPerSecond As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WattsPerCubicMeterPerSecond {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


WattsPerMeter Property

[image]

Revit 2024 API
UnitTypeId..::..WattsPerMeter Property
UnitTypeId Class See Also Send Feedback
Watts per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId WattsPerMeter { get; }
Visual Basic
Public Shared ReadOnly Property WattsPerMeter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WattsPerMeter {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


WattsPerMeterKelvin Property

[image]

Revit 2024 API
UnitTypeId..::..WattsPerMeterKelvin Property
UnitTypeId Class See Also Send Feedback
Watts per meter kelvin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId WattsPerMeterKelvin { get; }
Visual Basic
Public Shared ReadOnly Property WattsPerMeterKelvin As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WattsPerMeterKelvin {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


WattsPerSquareFoot Property

[image]

Revit 2024 API
UnitTypeId..::..WattsPerSquareFoot Property
UnitTypeId Class See Also Send Feedback
Watts per square foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId WattsPerSquareFoot { get; }
Visual Basic
Public Shared ReadOnly Property WattsPerSquareFoot As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WattsPerSquareFoot {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


WattsPerSquareMeter Property

[image]

Revit 2024 API
UnitTypeId..::..WattsPerSquareMeter Property
UnitTypeId Class See Also Send Feedback
Watts per square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId WattsPerSquareMeter { get; }
Visual Basic
Public Shared ReadOnly Property WattsPerSquareMeter As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WattsPerSquareMeter {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


WattsPerSquareMeterKelvin Property

[image]

Revit 2024 API
UnitTypeId..::..WattsPerSquareMeterKelvin Property
UnitTypeId Class See Also Send Feedback
Watts per square meter kelvin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public static ForgeTypeId WattsPerSquareMeterKelvin { get; }
Visual Basic
Public Shared ReadOnly Property WattsPerSquareMeterKelvin As ForgeTypeId
    Get
Visual C++
public:
static property ForgeTypeId^ WattsPerSquareMeterKelvin {
    ForgeTypeId^ get ();
}

See Also

UnitTypeId Class


UnitUtils Class

[image]

Revit 2024 API
UnitUtils Class
Members See Also Send Feedback
A utility class of functions related to units.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static class UnitUtils
Visual Basic
Public NotInheritable Class UnitUtils
Visual C++
public ref class UnitUtils abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..UnitUtils

See Also

UnitUtils Members


UnitUtils Members

[image] [image]

Revit 2024 API
UnitUtils Members
UnitUtils Class Methods See Also Send Feedback

The UnitUtils type exposes the following members.

Methods

Name | Description
Convert | Converts a value from one unit to another, such as square feet to square meters.
ConvertFromInternalUnits | Converts a value from Revit's internal units to a given unit.
ConvertToInternalUnits | Converts a value from a given unit to Revit's internal units.
GetAllDisciplines | Gets the identifiers of all available disciplines.
GetAllMeasurableSpecs | Gets the identifiers of all available measurable specs.
GetAllUnits | Gets the identifiers of all available units.
GetDiscipline | Gets the discipline for a given measurable spec.
GetTypeCatalogStringForSpec | Gets the string used in type catalogs to identify a given measurable spec.
GetTypeCatalogStringForUnit | Gets the string used in type catalogs to identify a given unit.
GetValidUnits | Gets the identifiers of all valid units for a given measurable spec.
IsMeasurableSpec | Checks whether a ForgeTypeId identifies a spec associated with units of measurement.
IsSymbol | Checks whether a ForgeTypeId identifies a symbol.
IsUnit | Checks whether a ForgeTypeId identifies a unit.
IsValidUnit | Checks whether a unit is valid for a given measurable spec.

See Also

UnitUtils Class


Convert Method

[image]

Revit 2024 API
UnitUtils..::..Convert Method
UnitUtils Class See Also Send Feedback
Converts a value from one unit to another, such as square feet to square meters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static double Convert(
    double value,
    ForgeTypeId currentUnitTypeId,
    ForgeTypeId desiredUnitTypeId
)
Visual Basic
Public Shared Function Convert ( _
    value As Double, _
    currentUnitTypeId As ForgeTypeId, _
    desiredUnitTypeId As ForgeTypeId _
) As Double
Visual C++
public:
static double Convert(
    double value,
    ForgeTypeId^ currentUnitTypeId,
    ForgeTypeId^ desiredUnitTypeId
)

Parameters

value
Type: System..::..Double
The value to convert.
currentUnitTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
Identifier of the current unit.
desiredUnitTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
Identifier of the desired unit.

Return Value

The converted value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for value is not finite -or- currentUnitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType). -or- desiredUnitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType).
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | currentUnitTypeId and desiredUnitTypeId have different dimensions.

See Also

UnitUtils Class


ConvertFromInternalUnits Method

[image]

Revit 2024 API
UnitUtils..::..ConvertFromInternalUnits Method
UnitUtils Class See Also Send Feedback
Converts a value from Revit's internal units to a given unit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static double ConvertFromInternalUnits(
    double value,
    ForgeTypeId unitTypeId
)
Visual Basic
Public Shared Function ConvertFromInternalUnits ( _
    value As Double, _
    unitTypeId As ForgeTypeId _
) As Double
Visual C++
public:
static double ConvertFromInternalUnits(
    double value,
    ForgeTypeId^ unitTypeId
)

Parameters

value
Type: System..::..Double
The value to convert.
unitTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
Identifier of the desired unit.

Return Value

The converted value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for value is not finite -or- unitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType).
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

UnitUtils Class


ConvertToInternalUnits Method

[image]

Revit 2024 API
UnitUtils..::..ConvertToInternalUnits Method
UnitUtils Class See Also Send Feedback
Converts a value from a given unit to Revit's internal units.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static double ConvertToInternalUnits(
    double value,
    ForgeTypeId unitTypeId
)
Visual Basic
Public Shared Function ConvertToInternalUnits ( _
    value As Double, _
    unitTypeId As ForgeTypeId _
) As Double
Visual C++
public:
static double ConvertToInternalUnits(
    double value,
    ForgeTypeId^ unitTypeId
)

Parameters

value
Type: System..::..Double
The value to convert.
unitTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
Identifier of the unit quantifying the value.

Return Value

The converted value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for value is not finite -or- unitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType).
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

UnitUtils Class


GetAllDisciplines Method

[image]

Revit 2024 API
UnitUtils..::..GetAllDisciplines Method
UnitUtils Class See Also Send Feedback
Gets the identifiers of all available disciplines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static IList<ForgeTypeId> GetAllDisciplines()
Visual Basic
Public Shared Function GetAllDisciplines As IList(Of ForgeTypeId)
Visual C++
public:
static IList<ForgeTypeId^>^ GetAllDisciplines()

Return Value

The discipline identifiers.

See Also

UnitUtils Class


GetAllMeasurableSpecs Method

[image]

Revit 2024 API
UnitUtils..::..GetAllMeasurableSpecs Method
UnitUtils Class See Also Send Feedback
Gets the identifiers of all available measurable specs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static IList<ForgeTypeId> GetAllMeasurableSpecs()
Visual Basic
Public Shared Function GetAllMeasurableSpecs As IList(Of ForgeTypeId)
Visual C++
public:
static IList<ForgeTypeId^>^ GetAllMeasurableSpecs()

Return Value

The spec identifiers.

See Also

UnitUtils Class


GetAllUnits Method

[image]

Revit 2024 API
UnitUtils..::..GetAllUnits Method
UnitUtils Class See Also Send Feedback
Gets the identifiers of all available units.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static IList<ForgeTypeId> GetAllUnits()
Visual Basic
Public Shared Function GetAllUnits As IList(Of ForgeTypeId)
Visual C++
public:
static IList<ForgeTypeId^>^ GetAllUnits()

Return Value

The unit identifiers.

See Also

UnitUtils Class


GetDiscipline Method

[image]

Revit 2024 API
UnitUtils..::..GetDiscipline Method
UnitUtils Class See Also Send Feedback
Gets the discipline for a given measurable spec.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static ForgeTypeId GetDiscipline(
    ForgeTypeId specTypeId
)
Visual Basic
Public Shared Function GetDiscipline ( _
    specTypeId As ForgeTypeId _
) As ForgeTypeId
Visual C++
public:
static ForgeTypeId^ GetDiscipline(
    ForgeTypeId^ specTypeId
)

Parameters

specTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
Identifier of the measurable spec.

Return Value

Identifier of the discipline.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | specTypeId is not a measurable spec identifier. See UnitUtils.IsMeasurableSpec(ForgeTypeId).
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

UnitUtils Class


GetTypeCatalogStringForSpec Method

[image]

Revit 2024 API
UnitUtils..::..GetTypeCatalogStringForSpec Method
UnitUtils Class See Also Send Feedback
Gets the string used in type catalogs to identify a given measurable spec.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static string GetTypeCatalogStringForSpec(
    ForgeTypeId specTypeId
)
Visual Basic
Public Shared Function GetTypeCatalogStringForSpec ( _
    specTypeId As ForgeTypeId _
) As String
Visual C++
public:
static String^ GetTypeCatalogStringForSpec(
    ForgeTypeId^ specTypeId
)

Parameters

specTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
Identifier of the measurable spec.

Return Value

The type catalog string, or an empty string if the measurable spec cannot be used in type catalogs.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | specTypeId is not a measurable spec identifier. See UnitUtils.IsMeasurableSpec(ForgeTypeId).
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

UnitUtils Class


GetValidUnits Method

[image]

Revit 2024 API
UnitUtils..::..GetValidUnits Method
UnitUtils Class See Also Send Feedback
Gets the identifiers of all valid units for a given measurable spec.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static IList<ForgeTypeId> GetValidUnits(
    ForgeTypeId specTypeId
)
Visual Basic
Public Shared Function GetValidUnits ( _
    specTypeId As ForgeTypeId _
) As IList(Of ForgeTypeId)
Visual C++
public:
static IList<ForgeTypeId^>^ GetValidUnits(
    ForgeTypeId^ specTypeId
)

Parameters

specTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
Identifier of the measurable spec.

Return Value

Identifiers of the valid units.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | specTypeId is not a measurable spec identifier. See UnitUtils.IsMeasurableSpec(ForgeTypeId).
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

UnitUtils Class


IsMeasurableSpec Method

[image]

Revit 2024 API
UnitUtils..::..IsMeasurableSpec Method
UnitUtils Class See Also Send Feedback
Checks whether a ForgeTypeId identifies a spec associated with units of measurement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static bool IsMeasurableSpec(
    ForgeTypeId specTypeId
)
Visual Basic
Public Shared Function IsMeasurableSpec ( _
    specTypeId As ForgeTypeId _
) As Boolean
Visual C++
public:
static bool IsMeasurableSpec(
    ForgeTypeId^ specTypeId
)

Parameters

specTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
The identifier to check.

Return Value

True if the ForgeTypeId identifies a measurable spec, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

UnitUtils Class


IsSymbol Method

[image]

Revit 2024 API
UnitUtils..::..IsSymbol Method
UnitUtils Class See Also Send Feedback
Checks whether a ForgeTypeId identifies a symbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static bool IsSymbol(
    ForgeTypeId symbolTypeId
)
Visual Basic
Public Shared Function IsSymbol ( _
    symbolTypeId As ForgeTypeId _
) As Boolean
Visual C++
public:
static bool IsSymbol(
    ForgeTypeId^ symbolTypeId
)

Parameters

symbolTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
The identifier to check.

Return Value

True if the ForgeTypeId identifies a symbol, false otherwise.

Remarks

The SymbolTypeId class offers symbol identifiers.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

UnitUtils Class


IsValidUnit Method

[image]

Revit 2024 API
UnitUtils..::..IsValidUnit Method
UnitUtils Class See Also Send Feedback
Checks whether a unit is valid for a given measurable spec.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static bool IsValidUnit(
    ForgeTypeId specTypeId,
    ForgeTypeId unitTypeId
)
Visual Basic
Public Shared Function IsValidUnit ( _
    specTypeId As ForgeTypeId, _
    unitTypeId As ForgeTypeId _
) As Boolean
Visual C++
public:
static bool IsValidUnit(
    ForgeTypeId^ specTypeId,
    ForgeTypeId^ unitTypeId
)

Parameters

specTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
Identifier of the measurable spec.
unitTypeId
Type: Autodesk.Revit.DB..::..ForgeTypeId
Identifier of the unit to check.

Return Value

True if the unit is valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | specTypeId is not a measurable spec identifier. See UnitUtils.IsMeasurableSpec(ForgeTypeId).
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

UnitUtils Class


UpdaterData Class

[image]

Revit 2024 API
UpdaterData Class
Members See Also Send Feedback
Service class that is passed to an Updater to prove access to update execution context

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class UpdaterData : IDisposable
Visual Basic
Public Class UpdaterData _
    Implements IDisposable
Visual C++
public ref class UpdaterData : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..UpdaterData

See Also

UpdaterData Members


UpdaterData Methods

[image] [image]

Revit 2024 API
UpdaterData Methods
UpdaterData Class See Also Send Feedback

The UpdaterData type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAddedElementIds | Returns set of elements newly added to the document. This set is mutually exclusive of elements returned by getDeletedElementIds() and getModifiedElementIds().
Public method | GetDeletedElementIds | Returns set of elements that were deleted from the document. This set is mutually exclusive of elements returned by getAddedElementIds() and getModifiedElementIds().
Public method | GetDocument | Returns document associated with this UpdaterData
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetModifiedElementIds | Returns set of elements that were modified. This set is mutually exclusive of elements returned by getAddedElementIds() and getDeletedElementIds().
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsChangeTriggered | Allows updater to check if specific change has happened to an element. Compares input type to the types that caused Updater::execute() to be triggered. If input type was not registered as a trigger for the associated Updater, this method will always return false for that ChangeType. For example, if the only trigger registered for UpdaterX is ChangeTypeAny for Element A, then passing in ChangeTypeGeometry will return false even if the geometry of A changed because the registered trigger was ChangeTypeAny. However, passing in ChangeTypeAny will return true.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

UpdaterData Class


Dispose Method

[image]

Revit 2024 API
UpdaterData..::..Dispose Method
UpdaterData Class See Also Send Feedback
Releases all resources used by the UpdaterData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

UpdaterData Class


GetAddedElementIds Method

[image]

Revit 2024 API
UpdaterData..::..GetAddedElementIds Method
UpdaterData Class See Also Send Feedback
Returns set of elements newly added to the document. This set is mutually exclusive of elements returned by getDeletedElementIds() and getModifiedElementIds().

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public ICollection<ElementId> GetAddedElementIds()
Visual Basic
Public Function GetAddedElementIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetAddedElementIds()

Return Value

Set of elements that were added to the document and triggered the call to execute() Note: This will only return elements if the trigger registered for the associated updater contains the ChangeType returned by Element::getChangeTypeElementAddition()

See Also

UpdaterData Class


IsChangeTriggered Method

[image]

Revit 2024 API
UpdaterData..::..IsChangeTriggered Method
UpdaterData Class See Also Send Feedback
Allows updater to check if specific change has happened to an element. Compares input type to the types that caused Updater::execute() to be triggered. If input type was not registered as a trigger for the associated Updater, this method will always return false for that ChangeType. For example, if the only trigger registered for UpdaterX is ChangeTypeAny for Element A, then passing in ChangeTypeGeometry will return false even if the geometry of A changed because the registered trigger was ChangeTypeAny. However, passing in ChangeTypeAny will return true.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool IsChangeTriggered(
    ElementId id,
    ChangeType type
)
Visual Basic
Public Function IsChangeTriggered ( _
    id As ElementId, _
    type As ChangeType _
) As Boolean
Visual C++
public:
bool IsChangeTriggered(
    ElementId^ id,
    ChangeType^ type
)

Parameters

id
Type: Autodesk.Revit.DB..::..ElementId
Id of element to check
type
Type: Autodesk.Revit.DB..::..ChangeType
ChangeType to check

Return Value

True if ChangeType happened to specified element

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

UpdaterData Class


UpdaterData Properties

[image] [image]

Revit 2024 API
UpdaterData Properties
UpdaterData Class See Also Send Feedback

The UpdaterData type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

UpdaterData Class


UpdaterId Class

[image]

Revit 2024 API
UpdaterId Class
Members See Also Send Feedback
A unique identifier of an Updater

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class UpdaterId : IDisposable
Visual Basic
Public Class UpdaterId _
    Implements IDisposable
Visual C++
public ref class UpdaterId : IDisposable

Remarks

UpdaterID used as a key to register and unregister Updaters and UpdateTriggers in Revit application

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..UpdaterId

See Also

UpdaterId Members


UpdaterId Members

[image] [image]

Revit 2024 API
UpdaterId Members
UpdaterId Class Constructors Methods Properties See Also Send Feedback

The UpdaterId type exposes the following members.

Constructors

 | Name | Description
Public method | UpdaterId | creates an instance of UpdaterId for given AddInId and a given GUID value

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the UpdaterId
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAddInId | AddInId of the UpdaterId
Public method | GetGUID | GUID value of the UpdaterId
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

UpdaterId Class


UpdaterId Constructor

[image]

Revit 2024 API
UpdaterId Constructor
UpdaterId Class See Also Send Feedback
creates an instance of UpdaterId for given AddInId and a given GUID value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public UpdaterId(
    AddInId addInId,
    Guid val
)
Visual Basic
Public Sub New ( _
    addInId As AddInId, _
    val As Guid _
)
Visual C++
public:
UpdaterId(
    AddInId^ addInId,
    Guid val
)

Parameters

addInId
Type: Autodesk.Revit.DB..::..AddInId
Id of addin that registers an Updater
val
Type: System..::..Guid
a GUID identifying the Updater within addin

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | addInId is not valid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

UpdaterId Class


UpdaterId Methods

[image] [image]

Revit 2024 API
UpdaterId Methods
UpdaterId Class See Also Send Feedback

The UpdaterId type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAddInId | AddInId of the UpdaterId
Public method | GetGUID | GUID value of the UpdaterId
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

UpdaterId Class


Dispose Method

[image]

Revit 2024 API
UpdaterId..::..Dispose Method
UpdaterId Class See Also Send Feedback
Releases all resources used by the UpdaterId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

UpdaterId Class


GetAddInId Method

[image]

Revit 2024 API
UpdaterId..::..GetAddInId Method
UpdaterId Class See Also Send Feedback
AddInId of the UpdaterId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public AddInId GetAddInId()
Visual Basic
Public Function GetAddInId As AddInId
Visual C++
public:
AddInId^ GetAddInId()

See Also

UpdaterId Class


UpdaterId Properties

[image] [image]

Revit 2024 API
UpdaterId Properties
UpdaterId Class See Also Send Feedback

The UpdaterId type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

UpdaterId Class


UpdaterInfo Class

[image]

Revit 2024 API
UpdaterInfo Class
Members See Also Send Feedback
Information of an updater, such as: Name, AdditionalInformation, name of the application that owns the updater, etc.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public class UpdaterInfo : IDisposable
Visual Basic
Public Class UpdaterInfo _
    Implements IDisposable
Visual C++
public ref class UpdaterInfo : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..UpdaterInfo

See Also

UpdaterInfo Members


UpdaterInfo Methods

[image] [image]

Revit 2024 API
UpdaterInfo Methods
UpdaterInfo Class See Also Send Feedback

The UpdaterInfo type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

UpdaterInfo Class


Dispose Method

[image]

Revit 2024 API
UpdaterInfo..::..Dispose Method
UpdaterInfo Class See Also Send Feedback
Releases all resources used by the UpdaterInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

UpdaterInfo Class


UpdaterInfo Properties

[image] [image]

Revit 2024 API
UpdaterInfo Properties
UpdaterInfo Class See Also Send Feedback

The UpdaterInfo type exposes the following members.

Properties

 | Name | Description
Public property | AdditionalInformation | Additional information about the updater.
Public property | ApplicationName | Name of the application that owns the updater.
Public property | IsOptional | Whether the updater is optional or not.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | UpdaterName | Name of the updater.

See Also

UpdaterInfo Class


AdditionalInformation Property

[image]

Revit 2024 API
UpdaterInfo..::..AdditionalInformation Property
UpdaterInfo Class See Also Send Feedback
Additional information about the updater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public string AdditionalInformation { get; }
Visual Basic
Public ReadOnly Property AdditionalInformation As String
    Get
Visual C++
public:
property String^ AdditionalInformation {
    String^ get ();
}

See Also

UpdaterInfo Class


ApplicationName Property

[image]

Revit 2024 API
UpdaterInfo..::..ApplicationName Property
UpdaterInfo Class See Also Send Feedback
Name of the application that owns the updater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public string ApplicationName { get; }
Visual Basic
Public ReadOnly Property ApplicationName As String
    Get
Visual C++
public:
property String^ ApplicationName {
    String^ get ();
}

See Also

UpdaterInfo Class


IsOptional Property

[image]

Revit 2024 API
UpdaterInfo..::..IsOptional Property
UpdaterInfo Class See Also Send Feedback
Whether the updater is optional or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public bool IsOptional { get; }
Visual Basic
Public ReadOnly Property IsOptional As Boolean
    Get
Visual C++
public:
property bool IsOptional {
    bool get ();
}

See Also

UpdaterInfo Class


UpdaterRegistry Class

[image]

Revit 2024 API
UpdaterRegistry Class
Members See Also Send Feedback
An object that stores and manages all updaters registered in the current session.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public class UpdaterRegistry : IDisposable
Visual Basic
Public Class UpdaterRegistry _
    Implements IDisposable
Visual C++
public ref class UpdaterRegistry : IDisposable

Remarks

The registry is an application-wide singleton. It maintains all dynamic updaters currently registered, and also invokes them per their respective trigger condition during subsequent transactions.

Please note that only the application (an add-in, typically) which registered an updater is allowed to modify it later, including unregistering it. Also, an application is not allowed to register an updater with an Id, that is based on another application's Id.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..UpdaterRegistry

See Also

UpdaterRegistry Members


UpdaterRegistry Members

[image] [image]

Revit 2024 API
UpdaterRegistry Members
UpdaterRegistry Class Methods Properties See Also Send Feedback

The UpdaterRegistry type exposes the following members.

Methods

 | Name | Description
 | AddTrigger(UpdaterId, ElementFilter, ChangeType) | Adds trigger with the specified element filter and ChangeType for all documents associated with this Updater
 | AddTrigger(UpdaterId, Document, ElementFilter, ChangeType) | Adds trigger with the specified element filter and ChangeType for the specified document
 | AddTrigger(UpdaterId, Document, ICollection<(Of <<'(ElementId>)>>), ChangeType) | Adds a trigger to an updater with specified set of elements and ChangeType
 | DisableUpdater | Disables the updater.
Public method | Dispose | Releases all resources used by the UpdaterRegistry
 | EnableUpdater | Enables the updater.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIsUpdaterOptional | Check if the updater is optional or not.
 | GetRegisteredUpdaterInfos()()()() | Returns UpdaterInfos for all the application-wide updaters.
 | GetRegisteredUpdaterInfos(Document) | Returns information about all updaters applicable to the given document.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsUpdaterEnabled | Checks if the updater is enabled or not.
 | IsUpdaterRegistered(UpdaterId) | Checks whether updater with the given id is registered
 | IsUpdaterRegistered(UpdaterId, Document) | Checks whether updater with the given id is registered in a document.
 | RegisterUpdater(IUpdater) | Registers an updater application-wide, which means the updater may get triggered in any open document.
 | RegisterUpdater(IUpdater, Document) | Registers the updater for a specified document, which means the updater can only be triggered by changes made in that document.
 | RegisterUpdater(IUpdater, Boolean) | Registers an updater application-wide, which means the updater may get triggered in any open document.
 | RegisterUpdater(IUpdater, Document, Boolean) | Registers the updater for a specified document, which means the updater can only be triggered by changes made in that document.
 | RemoveAllTriggers | Removes all triggers associated with Updater with specified UpdaterId. Does not unregister updater.
 | RemoveDocumentTriggers | Removes all triggers associated with specified document and Updater Does not unregister updater.
 | SetExecutionOrder | Forces execution order between two updaters Execution order: first before second
 | SetIsUpdaterOptional | Sets a flag indicating whether an updater is optional or not.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | UnregisterUpdater(UpdaterId) | Removes the updater associated with the input id from the UpdaterRegistry. Also removes all triggers associated with the Updater.
 | UnregisterUpdater(UpdaterId, Document) | Unregisters an updater for the given document.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

UpdaterRegistry Class


UpdaterRegistry Methods

[image] [image]

Revit 2024 API
UpdaterRegistry Methods
UpdaterRegistry Class See Also Send Feedback

The UpdaterRegistry type exposes the following members.

Methods

 | Name | Description
 | AddTrigger(UpdaterId, ElementFilter, ChangeType) | Adds trigger with the specified element filter and ChangeType for all documents associated with this Updater
 | AddTrigger(UpdaterId, Document, ElementFilter, ChangeType) | Adds trigger with the specified element filter and ChangeType for the specified document
 | AddTrigger(UpdaterId, Document, ICollection<(Of <<'(ElementId>)>>), ChangeType) | Adds a trigger to an updater with specified set of elements and ChangeType
 | DisableUpdater | Disables the updater.
Public method | Dispose |
 | EnableUpdater | Enables the updater.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIsUpdaterOptional | Check if the updater is optional or not.
 | GetRegisteredUpdaterInfos()()()() | Returns UpdaterInfos for all the application-wide updaters.
 | GetRegisteredUpdaterInfos(Document) | Returns information about all updaters applicable to the given document.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsUpdaterEnabled | Checks if the updater is enabled or not.
 | IsUpdaterRegistered(UpdaterId) | Checks whether updater with the given id is registered
 | IsUpdaterRegistered(UpdaterId, Document) | Checks whether updater with the given id is registered in a document.
 | RegisterUpdater(IUpdater) | Registers an updater application-wide, which means the updater may get triggered in any open document.
 | RegisterUpdater(IUpdater, Document) | Registers the updater for a specified document, which means the updater can only be triggered by changes made in that document.
 | RegisterUpdater(IUpdater, Boolean) | Registers an updater application-wide, which means the updater may get triggered in any open document.
 | RegisterUpdater(IUpdater, Document, Boolean) | Registers the updater for a specified document, which means the updater can only be triggered by changes made in that document.
 | RemoveAllTriggers | Removes all triggers associated with Updater with specified UpdaterId. Does not unregister updater.
 | RemoveDocumentTriggers | Removes all triggers associated with specified document and Updater Does not unregister updater.
 | SetExecutionOrder | Forces execution order between two updaters Execution order: first before second
 | SetIsUpdaterOptional | Sets a flag indicating whether an updater is optional or not.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | UnregisterUpdater(UpdaterId) | Removes the updater associated with the input id from the UpdaterRegistry. Also removes all triggers associated with the Updater.
 | UnregisterUpdater(UpdaterId, Document) | Unregisters an updater for the given document.

See Also

UpdaterRegistry Class


AddTrigger Method

[image] [image]

Revit 2024 API
UpdaterRegistry..::..AddTrigger Method
UpdaterRegistry Class See Also Send Feedback

Overload List

Name | Description
AddTrigger(UpdaterId, ElementFilter, ChangeType) | Adds trigger with the specified element filter and ChangeType for all documents associated with this Updater
AddTrigger(UpdaterId, Document, ElementFilter, ChangeType) | Adds trigger with the specified element filter and ChangeType for the specified document
AddTrigger(UpdaterId, Document, ICollection<(Of <<'(ElementId>)>>), ChangeType) | Adds a trigger to an updater with specified set of elements and ChangeType

See Also

UpdaterRegistry Class
UpdaterRegistry Members


AddTrigger Method (UpdaterId, ElementFilter, ChangeType)

[image]

Revit 2024 API
UpdaterRegistry..::..AddTrigger Method (UpdaterId, ElementFilter, ChangeType)
UpdaterRegistry Class See Also Send Feedback
Adds trigger with the specified element filter and ChangeType for all documents associated with this Updater

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static void AddTrigger(
    UpdaterId id,
    ElementFilter filter,
    ChangeType change
)
Visual Basic
Public Shared Sub AddTrigger ( _
    id As UpdaterId, _
    filter As ElementFilter, _
    change As ChangeType _
)
Visual C++
public:
static void AddTrigger(
    UpdaterId^ id,
    ElementFilter^ filter,
    ChangeType^ change
)

Parameters

id
Type: Autodesk.Revit.DB..::..UpdaterId
Id of updater that trigger should be added to
filter
Type: Autodesk.Revit.DB..::..ElementFilter
Element filter that defines elements that affect this trigger
change
Type: Autodesk.Revit.DB..::..ChangeType
ChangeType associated with this trigger

Remarks

This method only works with CategoryFilter and ParameterFilter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The updater's owner's AddIn does not match the currently active AddIn. -or- The id does not correspond to any registered Updaters. -or- AddTrigger called while executing an updater.

See Also

UpdaterRegistry Class
AddTrigger Overload


AddTrigger Method (UpdaterId, Document, ElementFilter, ChangeType)

[image]

Revit 2024 API
UpdaterRegistry..::..AddTrigger Method (UpdaterId, Document, ElementFilter, ChangeType)
UpdaterRegistry Class See Also Send Feedback
Adds trigger with the specified element filter and ChangeType for the specified document

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static void AddTrigger(
    UpdaterId id,
    Document document,
    ElementFilter filter,
    ChangeType change
)
Visual Basic
Public Shared Sub AddTrigger ( _
    id As UpdaterId, _
    document As Document, _
    filter As ElementFilter, _
    change As ChangeType _
)
Visual C++
public:
static void AddTrigger(
    UpdaterId^ id,
    Document^ document,
    ElementFilter^ filter,
    ChangeType^ change
)

Parameters

id
Type: Autodesk.Revit.DB..::..UpdaterId
Id of updater that trigger should be added to
document
Type: Autodesk.Revit.DB..::..Document
Document that elements in 'elements' are contained in
filter
Type: Autodesk.Revit.DB..::..ElementFilter
Element filter that defines elements that affect this trigger
change
Type: Autodesk.Revit.DB..::..ChangeType
ChangeType associated with this trigger

Remarks

This method only works with CategoryFilter and ParameterFilter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The updater's owner's AddIn does not match the currently active AddIn. -or- The id does not correspond to any registered Updaters -or- AddTrigger called while executing an updater.

See Also

UpdaterRegistry Class
AddTrigger Overload


AddTrigger Method (UpdaterId, Document, ICollection(ElementId), ChangeType)

[image]

Revit 2024 API
UpdaterRegistry..::..AddTrigger Method (UpdaterId, Document, ICollection<(Of <(<'ElementId>)>)>, ChangeType)
UpdaterRegistry Class See Also Send Feedback
Adds a trigger to an updater with specified set of elements and ChangeType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static void AddTrigger(
    UpdaterId id,
    Document document,
    ICollection<ElementId> elements,
    ChangeType change
)
Visual Basic
Public Shared Sub AddTrigger ( _
    id As UpdaterId, _
    document As Document, _
    elements As ICollection(Of ElementId), _
    change As ChangeType _
)
Visual C++
public:
static void AddTrigger(
    UpdaterId^ id,
    Document^ document,
    ICollection<ElementId^>^ elements,
    ChangeType^ change
)

Parameters

id
Type: Autodesk.Revit.DB..::..UpdaterId
Id of updater that trigger should be added to
document
Type: Autodesk.Revit.DB..::..Document
Document that elements in 'elements' are contained in
elements
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
Set of elements which define this trigger
change
Type: Autodesk.Revit.DB..::..ChangeType
ChangeType associated with this trigger

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | updater's owner AddIn does not match the currently active AddIn -or- id does not correspond to any registered Updaters -or- AddTrigger called while executing an updater.

See Also

UpdaterRegistry Class
AddTrigger Overload


DisableUpdater Method

[image]

Revit 2024 API
UpdaterRegistry..::..DisableUpdater Method
UpdaterRegistry Class See Also Send Feedback
Disables the updater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static void DisableUpdater(
    UpdaterId id
)
Visual Basic
Public Shared Sub DisableUpdater ( _
    id As UpdaterId _
)
Visual C++
public:
static void DisableUpdater(
    UpdaterId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::..UpdaterId
The updater id.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Updater with this Id is not currently registered in Revit.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

UpdaterRegistry Class


EnableUpdater Method

[image]

Revit 2024 API
UpdaterRegistry..::..EnableUpdater Method
UpdaterRegistry Class See Also Send Feedback
Enables the updater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static void EnableUpdater(
    UpdaterId id
)
Visual Basic
Public Shared Sub EnableUpdater ( _
    id As UpdaterId _
)
Visual C++
public:
static void EnableUpdater(
    UpdaterId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::..UpdaterId
The updater id.

Remarks

Even when an updater is enabled it could still be suspended for misbehaving, in which case it would not be executed regardless of its enable/disable status.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Updater with this Id is not currently registered in Revit.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

UpdaterRegistry Class


GetRegisteredUpdaterInfos Method

[image] [image]

Revit 2024 API
UpdaterRegistry..::..GetRegisteredUpdaterInfos Method
UpdaterRegistry Class See Also Send Feedback

Overload List

Name | Description
GetRegisteredUpdaterInfos()()()() | Returns UpdaterInfos for all the application-wide updaters.
GetRegisteredUpdaterInfos(Document) | Returns information about all updaters applicable to the given document.

See Also

UpdaterRegistry Class
UpdaterRegistry Members


GetRegisteredUpdaterInfos Method

[image]

Revit 2024 API
UpdaterRegistry..::..GetRegisteredUpdaterInfos Method
UpdaterRegistry Class See Also Send Feedback
Returns UpdaterInfos for all the application-wide updaters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static IList<UpdaterInfo> GetRegisteredUpdaterInfos()
Visual Basic
Public Shared Function GetRegisteredUpdaterInfos As IList(Of UpdaterInfo)
Visual C++
public:
static IList<UpdaterInfo^>^ GetRegisteredUpdaterInfos()

Return Value

List of UpdaterInfo structures

See Also

UpdaterRegistry Class
GetRegisteredUpdaterInfos Overload


IsUpdaterEnabled Method

[image]

Revit 2024 API
UpdaterRegistry..::..IsUpdaterEnabled Method
UpdaterRegistry Class See Also Send Feedback
Checks if the updater is enabled or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static bool IsUpdaterEnabled(
    UpdaterId id
)
Visual Basic
Public Shared Function IsUpdaterEnabled ( _
    id As UpdaterId _
) As Boolean
Visual C++
public:
static bool IsUpdaterEnabled(
    UpdaterId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::..UpdaterId
The updater id.

Return Value

Returns true if the updater is enabled, false otherwise.

Remarks

Even when an updater is enabled it could still be suspended for misbehaving, in which case it would not be executed regardless of its enable/disable status.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Updater with this Id is not currently registered in Revit.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

UpdaterRegistry Class


IsUpdaterRegistered Method

[image] [image]

Revit 2024 API
UpdaterRegistry..::..IsUpdaterRegistered Method
UpdaterRegistry Class See Also Send Feedback

Overload List

Name | Description
IsUpdaterRegistered(UpdaterId) | Checks whether updater with the given id is registered
IsUpdaterRegistered(UpdaterId, Document) | Checks whether updater with the given id is registered in a document.

See Also

UpdaterRegistry Class
UpdaterRegistry Members


IsUpdaterRegistered Method (UpdaterId)

[image]

Revit 2024 API
UpdaterRegistry..::..IsUpdaterRegistered Method (UpdaterId)
UpdaterRegistry Class See Also Send Feedback
Checks whether updater with the given id is registered

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static bool IsUpdaterRegistered(
    UpdaterId id
)
Visual Basic
Public Shared Function IsUpdaterRegistered ( _
    id As UpdaterId _
) As Boolean
Visual C++
public:
static bool IsUpdaterRegistered(
    UpdaterId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::..UpdaterId
Id of the updater being tested.

Return Value

Returns true if the updater is registered.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

UpdaterRegistry Class
IsUpdaterRegistered Overload


IsUpdaterRegistered Method (UpdaterId, Document)

[image]

Revit 2024 API
UpdaterRegistry..::..IsUpdaterRegistered Method (UpdaterId, Document)
UpdaterRegistry Class See Also Send Feedback
Checks whether updater with the given id is registered in a document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static bool IsUpdaterRegistered(
    UpdaterId id,
    Document document
)
Visual Basic
Public Shared Function IsUpdaterRegistered ( _
    id As UpdaterId, _
    document As Document _
) As Boolean
Visual C++
public:
static bool IsUpdaterRegistered(
    UpdaterId^ id,
    Document^ document
)

Parameters

id
Type: Autodesk.Revit.DB..::..UpdaterId
Id of the updater being tested.
document
Type: Autodesk.Revit.DB..::..Document
Document in which this updater is tested whether it's registered or not.

Return Value

Returns True if the updater is registered in the given document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

UpdaterRegistry Class
IsUpdaterRegistered Overload


RegisterUpdater Method

[image] [image]

Revit 2024 API
UpdaterRegistry..::..RegisterUpdater Method
UpdaterRegistry Class See Also Send Feedback

Overload List

Name | Description
RegisterUpdater(IUpdater) | Registers an updater application-wide, which means the updater may get triggered in any open document.
RegisterUpdater(IUpdater, Document) | Registers the updater for a specified document, which means the updater can only be triggered by changes made in that document.
RegisterUpdater(IUpdater, Boolean) | Registers an updater application-wide, which means the updater may get triggered in any open document.
RegisterUpdater(IUpdater, Document, Boolean) | Registers the updater for a specified document, which means the updater can only be triggered by changes made in that document.

See Also

UpdaterRegistry Class
UpdaterRegistry Members


RegisterUpdater Method (IUpdater)

[image]

Revit 2024 API
UpdaterRegistry..::..RegisterUpdater Method (IUpdater)
UpdaterRegistry Class See Also Send Feedback
Registers an updater application-wide, which means the updater may get triggered in any open document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static void RegisterUpdater(
    IUpdater updater
)
Visual Basic
Public Shared Sub RegisterUpdater ( _
    updater As IUpdater _
)
Visual C++
public:
static void RegisterUpdater(
    IUpdater^ updater
)

Parameters

updater
Type: Autodesk.Revit.DB..::..IUpdater
Updater to be registered

Remarks

By registering an updater application-wide, any previous registration explicitly made for particular documents will be voided. That means the updater will no longer be connected with just those documents, and the methodIsUpdaterRegistered(id,document) will also return False. Consequently, any attempt to either register or unregister this updater to (or from, respectively) a document will cause an exception to be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Updater with the the same Id has already been registered on the application level. -or- Updater's Id is not valid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | Method is not allowed during execution of a dynamic update. -or- The updater's owner's AddIn does not match the currently active AddIn, i.e. IUpdater.GetUpdaterId().GetAddInId() differs from the addInId field in the manifest file of the currently executing external application.

See Also

UpdaterRegistry Class
RegisterUpdater Overload


RegisterUpdater Method (IUpdater, Document)

[image]

Revit 2024 API
UpdaterRegistry..::..RegisterUpdater Method (IUpdater, Document)
UpdaterRegistry Class See Also Send Feedback
Registers the updater for a specified document, which means the updater can only be triggered by changes made in that document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static void RegisterUpdater(
    IUpdater updater,
    Document document
)
Visual Basic
Public Shared Sub RegisterUpdater ( _
    updater As IUpdater, _
    document As Document _
)
Visual C++
public:
static void RegisterUpdater(
    IUpdater^ updater,
    Document^ document
)

Parameters

updater
Type: Autodesk.Revit.DB..::..IUpdater
Updater to be registered
document
Type: Autodesk.Revit.DB..::..Document
Document for which this updater is to be registered

Remarks

An updater may be registered in more than one document, but an updater may not be registered for a document and also for the entire application at the same time. If an updater has already been registered application-wide, an attempt to register it for a document will cause an exception.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Updater with the the same Id has already been registered on the application level. -or- Updater with the the same Id has already been registered either in the given document or on the application level. -or- Updater's Id is not valid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | Method is not allowed during execution of a dynamic update. -or- The updater's owner's AddIn does not match the currently active AddIn, i.e. IUpdater.GetUpdaterId().GetAddInId() differs from the addInId field in the manifest file of the currently executing external application.

See Also

UpdaterRegistry Class
RegisterUpdater Overload


RegisterUpdater Method (IUpdater, Document, Boolean)

[image]

Revit 2024 API
UpdaterRegistry..::..RegisterUpdater Method (IUpdater, Document, Boolean)
UpdaterRegistry Class See Also Send Feedback
Registers the updater for a specified document, which means the updater can only be triggered by changes made in that document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static void RegisterUpdater(
    IUpdater updater,
    Document document,
    bool isOptional
)
Visual Basic
Public Shared Sub RegisterUpdater ( _
    updater As IUpdater, _
    document As Document, _
    isOptional As Boolean _
)
Visual C++
public:
static void RegisterUpdater(
    IUpdater^ updater,
    Document^ document,
    bool isOptional
)

Parameters

updater
Type: Autodesk.Revit.DB..::..IUpdater
Updater to be registered.
document
Type: Autodesk.Revit.DB..::..Document
Document for which this updater is to be registered.
isOptional
Type: System..::..Boolean
This argument controls whether the updater should be required next time a document is open in which the updater had been previously used. If a non-optional updater is not found (i.e. currently not registered), the end user will be presented with a warning and choices to resolve the situation.

Remarks

An updater may be registered in more then one document, but an updater may not be registered for a document and also for the entire application at the same time. If an updater has already been registered application-wide, an attempt to register it for a document will cause an exception.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Updater with the the same Id has already been registered on the application level. -or- Updater with the the same Id has already been registered either in the given document or on the application level. -or- Updater's Id is not valid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | Method is not allowed during execution of a dynamic update. -or- The updater's owner's AddIn does not match the currently active AddIn, i.e. IUpdater.GetUpdaterId().GetAddInId() differs from the addInId field in the manifest file of the currently executing external application.

See Also

UpdaterRegistry Class
RegisterUpdater Overload


RemoveDocumentTriggers Method

[image]

Revit 2024 API
UpdaterRegistry..::..RemoveDocumentTriggers Method
UpdaterRegistry Class See Also Send Feedback
Removes all triggers associated with specified document and Updater Does not unregister updater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static void RemoveDocumentTriggers(
    UpdaterId id,
    Document document
)
Visual Basic
Public Shared Sub RemoveDocumentTriggers ( _
    id As UpdaterId, _
    document As Document _
)
Visual C++
public:
static void RemoveDocumentTriggers(
    UpdaterId^ id,
    Document^ document
)

Parameters

id
Type: Autodesk.Revit.DB..::..UpdaterId
Id of specified updater
document
Type: Autodesk.Revit.DB..::..Document
Document for which to remove triggers

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The updater's owner's AddIn does not match the currently active AddIn. -or- RemoveDocumentTriggers called while executing an updater.

See Also

UpdaterRegistry Class


SetExecutionOrder Method

[image]

Revit 2024 API
UpdaterRegistry..::..SetExecutionOrder Method
UpdaterRegistry Class See Also Send Feedback
Forces execution order between two updaters Execution order: first before second

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static void SetExecutionOrder(
    UpdaterId first,
    UpdaterId second
)
Visual Basic
Public Shared Sub SetExecutionOrder ( _
    first As UpdaterId, _
    second As UpdaterId _
)
Visual C++
public:
static void SetExecutionOrder(
    UpdaterId^ first,
    UpdaterId^ second
)

Parameters

first
Type: Autodesk.Revit.DB..::..UpdaterId
Id of first Updater
second
Type: Autodesk.Revit.DB..::..UpdaterId
Id of second Updater

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | One or both inputs are not valid UpdaterIds -or- One or both of the Updaters are not registered -or- first and second are the same id
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | The updaters do not report the same ChangePriority

See Also

UpdaterRegistry Class


SetIsUpdaterOptional Method

[image]

Revit 2024 API
UpdaterRegistry..::..SetIsUpdaterOptional Method
UpdaterRegistry Class See Also Send Feedback
Sets a flag indicating whether an updater is optional or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static void SetIsUpdaterOptional(
    UpdaterId id,
    bool isOptional
)
Visual Basic
Public Shared Sub SetIsUpdaterOptional ( _
    id As UpdaterId, _
    isOptional As Boolean _
)
Visual C++
public:
static void SetIsUpdaterOptional(
    UpdaterId^ id,
    bool isOptional
)

Parameters

id
Type: Autodesk.Revit.DB..::..UpdaterId
Id of the updater
isOptional
Type: System..::..Boolean
Use True to make the updater optional, false to make it a mandatory updater.

Remarks

This flag controls whether an updater is going to be required next time a document in which it had been used is opened. If a non-optional updater is not found (currently not registered) in a document, the end user will be presented with a warning and choices to resolve the situation.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Updater with this Id is not currently registered in Revit.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

UpdaterRegistry Class


UnregisterUpdater Method

[image] [image]

Revit 2024 API
UpdaterRegistry..::..UnregisterUpdater Method
UpdaterRegistry Class See Also Send Feedback

Overload List

Name | Description
UnregisterUpdater(UpdaterId) | Removes the updater associated with the input id from the UpdaterRegistry. Also removes all triggers associated with the Updater.
UnregisterUpdater(UpdaterId, Document) | Unregisters an updater for the given document.

See Also

UpdaterRegistry Class
UpdaterRegistry Members


UnregisterUpdater Method (UpdaterId)

[image]

Revit 2024 API
UpdaterRegistry..::..UnregisterUpdater Method (UpdaterId)
UpdaterRegistry Class See Also Send Feedback
Removes the updater associated with the input id from the UpdaterRegistry. Also removes all triggers associated with the Updater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static void UnregisterUpdater(
    UpdaterId id
)
Visual Basic
Public Shared Sub UnregisterUpdater ( _
    id As UpdaterId _
)
Visual C++
public:
static void UnregisterUpdater(
    UpdaterId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::..UpdaterId
Id of updater to be removed

Remarks

This methods works regardless of how the updater was registered. Whether the updater was registered application-wide or for a document (or a set of document), it will be removed from the registry and any connections with documents will also be lost.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Updater with this Id is not currently registered in Revit.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The updater's owner's AddIn does not match the currently active AddIn, i.e. IUpdater.GetUpdaterId().GetAddInId() differs from the addInId field in the manifest file of the currently executing external application. -or- Attempting to unregister an updater that is currently being executed.

See Also

UpdaterRegistry Class
UnregisterUpdater Overload


UnregisterUpdater Method (UpdaterId, Document)

[image]

Revit 2024 API
UpdaterRegistry..::..UnregisterUpdater Method (UpdaterId, Document)
UpdaterRegistry Class See Also Send Feedback
Unregisters an updater for the given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static void UnregisterUpdater(
    UpdaterId id,
    Document document
)
Visual Basic
Public Shared Sub UnregisterUpdater ( _
    id As UpdaterId, _
    document As Document _
)
Visual C++
public:
static void UnregisterUpdater(
    UpdaterId^ id,
    Document^ document
)

Parameters

id
Type: Autodesk.Revit.DB..::..UpdaterId
Id of updater to be unregistered.
document
Type: Autodesk.Revit.DB..::..Document
Document for which this updater is to be unregistered.

Remarks

Unregistering an updater from a document is only permitted if the updater was explicitly registered for that document.

If the updater was registered in other documents too, the remaining documents will still have the updater assigned.

However, if after unregistering from the document the updater is found not registered in any other (currently open) documents, the updater will be completely removed from the registry including its triggers. Should the updater be registered again later, the triggers need to be re-applied.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Updater with this Id is not currently registered in the document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The updater's owner's AddIn does not match the currently active AddIn, i.e. IUpdater.GetUpdaterId().GetAddInId() differs from the addInId field in the manifest file of the currently executing external application. -or- Attempting to unregister an updater that is currently being executed.

See Also

UpdaterRegistry Class
UnregisterUpdater Overload


UpdaterRegistry Properties

[image] [image]

Revit 2024 API
UpdaterRegistry Properties
UpdaterRegistry Class See Also Send Feedback

The UpdaterRegistry type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

UpdaterRegistry Class


UV Class

[image]

Revit 2024 API
UV Class
Members See Also Send Feedback
Object representing coordinates in 2-dimensional space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class UV
Visual Basic
Public Class UV
Visual C++
public ref class UV

Remarks

Usually this means parameters on a surface. In actual use, it could be interpreted as either point or vector in 2-dimensional space.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..UV

See Also

UV Members


UV Members

[image] [image]

Revit 2024 API
UV Members
UV Class Constructors Methods Operators Properties See Also Send Feedback

The UV type exposes the following members.

Constructors

 | Name | Description
Public method | UV()()()() | Creates a default UV with the values (0, 0).
Public method | UV(Double, Double) | Creates a UV with the supplied coordinates.

Methods

 | Name | Description
Public method | Add | Adds the specified 2-D vector to this 2-D vector and returns the result.
Public method | AngleTo | Returns the angle between this vector and the specified vector.
Public method | CrossProduct | The cross product of this 2-D vector and the specified 2-D vector.
Public method | DistanceTo | Returns the distance from this 2-D point to the specified 2-D point.
Public method | Divide | Divides this 2-D vector by the specified value and returns the result.
Public method | DotProduct | The dot product of this 2-D vector and the specified 2-D vector.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLength | The length of this 2-D vector.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAlmostEqualTo(UV) | Determines whether this 2-D vector and the specified 2-D vector are the same within the tolerance (1.0e-09).
Public method | IsAlmostEqualTo(UV, Double) | Determines whether this 2-D vector and the specified 2-D vector are the same within a specified tolerance.
Public method | IsUnitLength | The boolean value indicates whether this 2-D vector is of unit length.
Public method | IsZeroLength | The boolean value indicates whether this 2-D vector is a zero vector.
Public method | Multiply | Multiplies this 2-D vector by the specified value and returns the result.
Public method | Negate | Negates this 2-D vector.
Public method | Normalize | Returns a new UV whose coordinates are the normalized values from this vector.
Public method | Subtract | Subtracts the specified 2-D vector from this 2-D vector and returns the result.
Public method | ToString | Gets formatted string showing (U, V) with values formatted to 9 decimal places. (Overrides Object..::..ToString()()()().)

Operators

Name | Description
Addition | Adds the two specified 2-D vectors and returns the result.
Division | Divides the specified 2-D vector by the specified value.
Multiply(Double, UV) | The product of the specified number and the specified 2-D vector.
Multiply(UV, Double) | The product of the specified number and the specified 2-D vector.
Subtraction | Subtracts the two specified 2-D vectors and returns the result.
UnaryNegation | Negates this 2-D vector and returns the result.

Properties

 | Name | Description
 | BasisU | The basis of the U axis.
 | BasisV | The basis of the V axis.
Public property | Item |
Public property | U | Gets the first coordinate.
Public property | V | Gets the second coordinate.
 | Zero | The coordinate origin or zero 2-D vector.

See Also

UV Class


UV Constructor

[image] [image]

Revit 2024 API
UV Constructor
UV Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UV()()()() | Creates a default UV with the values (0, 0).
Public method | UV(Double, Double) | Creates a UV with the supplied coordinates.

See Also

UV Class
UV Members


UV Constructor

[image]

Revit 2024 API
UV Constructor
UV Class See Also Send Feedback
Creates a default UV with the values (0, 0).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public UV()
Visual Basic
Public Sub New
Visual C++
public:
UV()

See Also

UV Class
UV Overload


UV Constructor (Double, Double)

[image]

Revit 2024 API
UV Constructor (Double, Double)
UV Class See Also Send Feedback
Creates a UV with the supplied coordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public UV(
    double u,
    double v
)
Visual Basic
Public Sub New ( _
    u As Double, _
    v As Double _
)
Visual C++
public:
UV(
    double u,
    double v
)

Parameters

u
Type: System..::..Double
The first coordinate.
v
Type: System..::..Double
The second coordinate.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when setting an infinite number to the U or V property.

See Also

UV Class
UV Overload


UV Methods

[image] [image]

Revit 2024 API
UV Methods
UV Class See Also Send Feedback

The UV type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified 2-D vector to this 2-D vector and returns the result.
Public method | AngleTo | Returns the angle between this vector and the specified vector.
Public method | CrossProduct | The cross product of this 2-D vector and the specified 2-D vector.
Public method | DistanceTo | Returns the distance from this 2-D point to the specified 2-D point.
Public method | Divide | Divides this 2-D vector by the specified value and returns the result.
Public method | DotProduct | The dot product of this 2-D vector and the specified 2-D vector.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLength | The length of this 2-D vector.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAlmostEqualTo(UV) | Determines whether this 2-D vector and the specified 2-D vector are the same within the tolerance (1.0e-09).
Public method | IsAlmostEqualTo(UV, Double) | Determines whether this 2-D vector and the specified 2-D vector are the same within a specified tolerance.
Public method | IsUnitLength | The boolean value indicates whether this 2-D vector is of unit length.
Public method | IsZeroLength | The boolean value indicates whether this 2-D vector is a zero vector.
Public method | Multiply | Multiplies this 2-D vector by the specified value and returns the result.
Public method | Negate | Negates this 2-D vector.
Public method | Normalize | Returns a new UV whose coordinates are the normalized values from this vector.
Public method | Subtract | Subtracts the specified 2-D vector from this 2-D vector and returns the result.
Public method | ToString | Gets formatted string showing (U, V) with values formatted to 9 decimal places. (Overrides Object..::..ToString()()()().)

See Also

UV Class


Add Method

[image]

Revit 2024 API
UV..::..Add Method
UV Class See Also Send Feedback
Adds the specified 2-D vector to this 2-D vector and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public UV Add(
    UV source
)
Visual Basic
Public Function Add ( _
    source As UV _
) As UV
Visual C++
public:
UV^ Add(
    UV^ source
)

Parameters

source
Type: Autodesk.Revit.DB..::..UV
The vector to add to this vector.

Return Value

The 2-D vector equal to the sum of the two vectors.

Remarks

The added vector is obtained by adding each coordinate of the specified vector to the corresponding coordinate of this vector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

UV Class


AngleTo Method

[image]

Revit 2024 API
UV..::..AngleTo Method
UV Class See Also Send Feedback
Returns the angle between this vector and the specified vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double AngleTo(
    UV source
)
Visual Basic
Public Function AngleTo ( _
    source As UV _
) As Double
Visual C++
public:
double AngleTo(
    UV^ source
)

Parameters

source
Type: Autodesk.Revit.DB..::..UV
The specified vector.

Return Value

The real number between 0 and 2*PI equal to the angle between the two vectors in radians.

Remarks

The angle is measured counterclockwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

UV Class


CrossProduct Method

[image]

Revit 2024 API
UV..::..CrossProduct Method
UV Class See Also Send Feedback
The cross product of this 2-D vector and the specified 2-D vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double CrossProduct(
    UV source
)
Visual Basic
Public Function CrossProduct ( _
    source As UV _
) As Double
Visual C++
public:
double CrossProduct(
    UV^ source
)

Parameters

source
Type: Autodesk.Revit.DB..::..UV
The vector to multiply with this vector.

Return Value

The real number equal to the cross product.

Remarks

The cross product of the two vectors in 2-D space is equivalent to the area of the parallelogram they span.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

UV Class


DistanceTo Method

[image]

Revit 2024 API
UV..::..DistanceTo Method
UV Class See Also Send Feedback
Returns the distance from this 2-D point to the specified 2-D point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double DistanceTo(
    UV source
)
Visual Basic
Public Function DistanceTo ( _
    source As UV _
) As Double
Visual C++
public:
double DistanceTo(
    UV^ source
)

Parameters

source
Type: Autodesk.Revit.DB..::..UV
The specified point.

Return Value

The real number equal to the distance between the two points.

Remarks

The distance between the two points is equal to the length of the vector that joins the two points.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

UV Class


DotProduct Method

[image]

Revit 2024 API
UV..::..DotProduct Method
UV Class See Also Send Feedback
The dot product of this 2-D vector and the specified 2-D vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double DotProduct(
    UV source
)
Visual Basic
Public Function DotProduct ( _
    source As UV _
) As Double
Visual C++
public:
double DotProduct(
    UV^ source
)

Parameters

source
Type: Autodesk.Revit.DB..::..UV
The vector to multiply with this vector.

Return Value

The real number equal to the dot product.

Remarks

The dot product is the sum of the respective coordinates of the two vectors: Pu * Ru + Pv * Rv.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

UV Class


GetLength Method

[image]

Revit 2024 API
UV..::..GetLength Method
UV Class See Also Send Feedback
The length of this 2-D vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double GetLength()
Visual Basic
Public Function GetLength As Double
Visual C++
public:
double GetLength()

Remarks

In 2-D Euclidean space, the length of the vector is the square root of the sum of the two coordinates squared.

See Also

UV Class


IsAlmostEqualTo Method

[image] [image]

Revit 2024 API
UV..::..IsAlmostEqualTo Method
UV Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsAlmostEqualTo(UV) | Determines whether this 2-D vector and the specified 2-D vector are the same within the tolerance (1.0e-09).
Public method | IsAlmostEqualTo(UV, Double) | Determines whether this 2-D vector and the specified 2-D vector are the same within a specified tolerance.

See Also

UV Class
UV Members


IsAlmostEqualTo Method (UV)

[image]

Revit 2024 API
UV..::..IsAlmostEqualTo Method (UV)
UV Class See Also Send Feedback
Determines whether this 2-D vector and the specified 2-D vector are the same within the tolerance (1.0e-09).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsAlmostEqualTo(
    UV source
)
Visual Basic
Public Function IsAlmostEqualTo ( _
    source As UV _
) As Boolean
Visual C++
public:
bool IsAlmostEqualTo(
    UV^ source
)

Parameters

source
Type: Autodesk.Revit.DB..::..UV
The vector to compare with this vector.

Return Value

True if the vectors are the same; otherwise, false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when left is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

UV Class
IsAlmostEqualTo Overload


IsAlmostEqualTo Method (UV, Double)

[image]

Revit 2024 API
UV..::..IsAlmostEqualTo Method (UV, Double)
UV Class See Also Send Feedback
Determines whether this 2-D vector and the specified 2-D vector are the same within a specified tolerance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsAlmostEqualTo(
    UV source,
    double tolerance
)
Visual Basic
Public Function IsAlmostEqualTo ( _
    source As UV, _
    tolerance As Double _
) As Boolean
Visual C++
public:
bool IsAlmostEqualTo(
    UV^ source,
    double tolerance
)

Parameters

source
Type: Autodesk.Revit.DB..::..UV
The vector to compare with this vector.
tolerance
Type: System..::..Double
The tolerance for equality check.

Return Value

True if the vectors are the same; otherwise, false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when tolerance is less than 0.

See Also

UV Class
IsAlmostEqualTo Overload


IsUnitLength Method

[image]

Revit 2024 API
UV..::..IsUnitLength Method
UV Class See Also Send Feedback
The boolean value indicates whether this 2-D vector is of unit length.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsUnitLength()
Visual Basic
Public Function IsUnitLength As Boolean
Visual C++
public:
bool IsUnitLength()

Remarks

A unit length vector has a length of one, and is considered normalized.

See Also

UV Class


IsZeroLength Method

[image]

Revit 2024 API
UV..::..IsZeroLength Method
UV Class See Also Send Feedback
The boolean value indicates whether this 2-D vector is a zero vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsZeroLength()
Visual Basic
Public Function IsZeroLength As Boolean
Visual C++
public:
bool IsZeroLength()

Remarks

The zero vector's each component is zero within the tolerance (1.0e-09).

See Also

UV Class


Multiply Method

[image]

Revit 2024 API
UV..::..Multiply Method
UV Class See Also Send Feedback
Multiplies this 2-D vector by the specified value and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public UV Multiply(
    double value
)
Visual Basic
Public Function Multiply ( _
    value As Double _
) As UV
Visual C++
public:
UV^ Multiply(
    double value
)

Parameters

value
Type: System..::..Double
The value to multiply with this vector.

Return Value

The multiplied 2-D vector.

Remarks

The multiplied vector is obtained by multiplying each coordinate of this vector by the specified value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the specified value is an infinite number.

See Also

UV Class


Normalize Method

[image]

Revit 2024 API
UV..::..Normalize Method
UV Class See Also Send Feedback
Returns a new UV whose coordinates are the normalized values from this vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public UV Normalize()
Visual Basic
Public Function Normalize As UV
Visual C++
public:
UV^ Normalize()

Return Value

The normalized UV or zero if the vector is almost Zero.

Remarks

Normalized indicates that the length of this vector equals one (a unit vector).

See Also

UV Class


Subtract Method

[image]

Revit 2024 API
UV..::..Subtract Method
UV Class See Also Send Feedback
Subtracts the specified 2-D vector from this 2-D vector and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public UV Subtract(
    UV source
)
Visual Basic
Public Function Subtract ( _
    source As UV _
) As UV
Visual C++
public:
UV^ Subtract(
    UV^ source
)

Parameters

source
Type: Autodesk.Revit.DB..::..UV
The vector to subtract from this vector.

Return Value

The 2-D vector equal to the difference between the two vectors.

Remarks

The subtracted vector is obtained by subtracting each coordinate of the specified vector from the corresponding coordinate of this vector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when left is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

UV Class


ToString Method

[image]

Revit 2024 API
UV..::..ToString Method
UV Class See Also Send Feedback
Gets formatted string showing (U, V) with values formatted to 9 decimal places.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

UV Class


UV Operators

[image] [image]

Revit 2024 API
UV Operators
UV Class See Also Send Feedback

The UV type exposes the following members.

Operators

Name | Description
Addition | Adds the two specified 2-D vectors and returns the result.
Division | Divides the specified 2-D vector by the specified value.
Multiply(Double, UV) | The product of the specified number and the specified 2-D vector.
Multiply(UV, Double) | The product of the specified number and the specified 2-D vector.
Subtraction | Subtracts the two specified 2-D vectors and returns the result.
UnaryNegation | Negates this 2-D vector and returns the result.

See Also

UV Class


Addition Operator

[image]

Revit 2024 API
UV..::..Addition Operator
UV Class See Also Send Feedback
Adds the two specified 2-D vectors and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static UV operator +(
    UV left,
    UV right
)
Visual Basic
Public Shared Operator + ( _
    left As UV, _
    right As UV _
) As UV
Visual C++
public:
static UV^ operator +(
    UV^ left,
    UV^ right
)

Parameters

left
Type: Autodesk.Revit.DB..::..UV
The first vector.
right
Type: Autodesk.Revit.DB..::..UV
The second vector.

Return Value

The 2-D vector equal to the sum of the two source vectors.

Remarks

The added vector is obtained by adding each coordinate of the right vector to the corresponding coordinate of the left vector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when left or right is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

UV Class


Multiply Operator (Double, UV)

[image]

Revit 2024 API
UV..::..Multiply Operator (Double, UV)
UV Class See Also Send Feedback
The product of the specified number and the specified 2-D vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static UV operator *(
    double value,
    UV right
)
Visual Basic
Public Shared Operator * ( _
    value As Double, _
    right As UV _
) As UV
Visual C++
public:
static UV^ operator *(
    double value,
    UV^ right
)

Parameters

value
Type: System..::..Double
The value to multiply with the specified vector.
right
Type: Autodesk.Revit.DB..::..UV
The vector to multiply with the value.

Return Value

The multiplied 2-D vector.

Remarks

The multiplied vector is obtained by multiplying each coordinate of the specified vector by the specified value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the specified value is an infinite number.
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when right is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

UV Class
Multiply Overload


Multiply Operator (UV, Double)

[image]

Revit 2024 API
UV..::..Multiply Operator (UV, Double)
UV Class See Also Send Feedback
The product of the specified number and the specified 2-D vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static UV operator *(
    UV left,
    double value
)
Visual Basic
Public Shared Operator * ( _
    left As UV, _
    value As Double _
) As UV
Visual C++
public:
static UV^ operator *(
    UV^ left,
    double value
)

Parameters

left
Type: Autodesk.Revit.DB..::..UV
The vector to multiply with the value.
value
Type: System..::..Double
The value to multiply with the specified vector.

Return Value

The multiplied 2-D vector.

Remarks

The multiplied vector is obtained by multiplying each coordinate of the specified vector by the specified value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the specified value is an infinite number.
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when left is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

UV Class
Multiply Overload


Subtraction Operator

[image]

Revit 2024 API
UV..::..Subtraction Operator
UV Class See Also Send Feedback
Subtracts the two specified 2-D vectors and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static UV operator -(
    UV left,
    UV right
)
Visual Basic
Public Shared Operator - ( _
    left As UV, _
    right As UV _
) As UV
Visual C++
public:
static UV^ operator -(
    UV^ left,
    UV^ right
)

Parameters

left
Type: Autodesk.Revit.DB..::..UV
The first vector.
right
Type: Autodesk.Revit.DB..::..UV
The second vector.

Return Value

The 2-D vector equal to the difference between the two source vectors.

Remarks

The subtracted vector is obtained by subtracting each coordinate of the right vector from the corresponding coordinate of the left vector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when left or right is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

UV Class


UnaryNegation Operator

[image]

Revit 2024 API
UV..::..UnaryNegation Operator
UV Class See Also Send Feedback
Negates this 2-D vector and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static UV operator -(
    UV source
)
Visual Basic
Public Shared Operator - ( _
    source As UV _
) As UV
Visual C++
public:
static UV^ operator -(
    UV^ source
)

Parameters

source
Type: Autodesk.Revit.DB..::..UV

Return Value

The 2-D vector opposite to this vector.

Remarks

The negated vector is obtained by changing the sign of each coordinate of the specified vector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

UV Class


BasisV Property

[image]

Revit 2024 API
UV..::..BasisV Property
UV Class See Also Send Feedback
The basis of the V axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static UV BasisV { get; }
Visual Basic
Public Shared ReadOnly Property BasisV As UV
    Get
Visual C++
public:
static property UV^ BasisV {
    UV^ get ();
}

Remarks

The basis of the V axis is the vector (0,1), the unit vector on the V axis.

See Also

UV Class


Item Property

[image]

Revit 2024 API
UV..::..Item Property
UV Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double this[
    int idx
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    idx As Integer _
) As Double
    Get
Visual C++
public:
property double default[int idx] {
    double get (int idx);
}

Parameters

idx
Type: System..::..Int32

See Also

UV Class


V Property

[image]

Revit 2024 API
UV..::..V Property
UV Class See Also Send Feedback
Gets the second coordinate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double V { get; }
Visual Basic
Public ReadOnly Property V As Double
    Get
Visual C++
public:
property double V {
    double get ();
}

See Also

UV Class


Zero Property

[image]

Revit 2024 API
UV..::..Zero Property
UV Class See Also Send Feedback
The coordinate origin or zero 2-D vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static UV Zero { get; }
Visual Basic
Public Shared ReadOnly Property Zero As UV
    Get
Visual C++
public:
static property UV^ Zero {
    UV^ get ();
}

Remarks

The zero vector is (0,0).

See Also

UV Class


ValidateCurveLoopsOptions Class

[image]

Revit 2024 API
ValidateCurveLoopsOptions Class
Members See Also Send Feedback
Options for array of curve loops validation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public class ValidateCurveLoopsOptions : IDisposable
Visual Basic
Public Class ValidateCurveLoopsOptions _
    Implements IDisposable
Visual C++
public ref class ValidateCurveLoopsOptions : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ValidateCurveLoopsOptions

See Also

ValidateCurveLoopsOptions Members


ValidateCurveLoopsOptions Members

[image] [image]

Revit 2024 API
ValidateCurveLoopsOptions Members
ValidateCurveLoopsOptions Class Methods Properties See Also Send Feedback

The ValidateCurveLoopsOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ValidateCurveLoopsOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ValidateCurveLoopsOptions Class


ValidateCurveLoopsOptions Methods

[image] [image]

Revit 2024 API
ValidateCurveLoopsOptions Methods
ValidateCurveLoopsOptions Class See Also Send Feedback

The ValidateCurveLoopsOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ValidateCurveLoopsOptions Class


Dispose Method

[image]

Revit 2024 API
ValidateCurveLoopsOptions..::..Dispose Method
ValidateCurveLoopsOptions Class See Also Send Feedback
Releases all resources used by the ValidateCurveLoopsOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ValidateCurveLoopsOptions Class


ValueAtPointBase Class

[image]

Revit 2024 API
ValueAtPointBase Class
Members See Also Send Feedback
A base class representing storage of values at a given point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public class ValueAtPointBase : IDisposable
Visual Basic
Public Class ValueAtPointBase _
    Implements IDisposable
Visual C++
public ref class ValueAtPointBase : IDisposable

Remarks

This class stores a set of measurements and corresponding mapped flags. The flags are defined in the enumerated type ValueAtPointFlags.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ValueAtPointBase
Autodesk.Revit.DB.Analysis..::..ValueAtPoint
Autodesk.Revit.DB.Analysis..::..VectorAtPoint

See Also

ValueAtPointBase Members


ValueAtPointBase Members

[image] [image]

Revit 2024 API
ValueAtPointBase Members
ValueAtPointBase Class Methods Properties See Also Send Feedback

The ValueAtPointBase type exposes the following members.

Methods

 | Name | Description
Public method | ClearAllFlags | Sets flags for all measurements to ValueAtPointFlags::None.
Public method | ClearFlagsAt | Sets flags for the given measurement to ValueAtPointFlags::None.
Public method | Dispose | Releases all resources used by the ValueAtPointBase
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetFlags | Returns flags for the given measurement.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetFlags(IList<(Of <<'(Int32>)>>)) | Independently sets the flags associated to all measurements.
Public method | SetFlags(Int32) | Sets the flags associated to all measurements to the same value.
Public method | SetFlags(Int32, Int32) | Sets the flags associated to a given measurement.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ValueAtPointBase Class


ValueAtPointBase Methods

[image] [image]

Revit 2024 API
ValueAtPointBase Methods
ValueAtPointBase Class See Also Send Feedback

The ValueAtPointBase type exposes the following members.

Methods

 | Name | Description
Public method | ClearAllFlags | Sets flags for all measurements to ValueAtPointFlags::None.
Public method | ClearFlagsAt | Sets flags for the given measurement to ValueAtPointFlags::None.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetFlags | Returns flags for the given measurement.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetFlags(IList<(Of <<'(Int32>)>>)) | Independently sets the flags associated to all measurements.
Public method | SetFlags(Int32) | Sets the flags associated to all measurements to the same value.
Public method | SetFlags(Int32, Int32) | Sets the flags associated to a given measurement.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ValueAtPointBase Class


ClearAllFlags Method

[image]

Revit 2024 API
ValueAtPointBase..::..ClearAllFlags Method
ValueAtPointBase Class See Also Send Feedback
Sets flags for all measurements to ValueAtPointFlags::None.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public void ClearAllFlags()
Visual Basic
Public Sub ClearAllFlags
Visual C++
public:
void ClearAllFlags()

See Also

ValueAtPointBase Class


ClearFlagsAt Method

[image]

Revit 2024 API
ValueAtPointBase..::..ClearFlagsAt Method
ValueAtPointBase Class See Also Send Feedback
Sets flags for the given measurement to ValueAtPointFlags::None.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public void ClearFlagsAt(
    int measurement
)
Visual Basic
Public Sub ClearFlagsAt ( _
    measurement As Integer _
)
Visual C++
public:
void ClearFlagsAt(
    int measurement
)

Parameters

measurement
Type: System..::..Int32
Measurement for which to clear flags.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given value for measurement is negative.

See Also

ValueAtPointBase Class


Dispose Method

[image]

Revit 2024 API
ValueAtPointBase..::..Dispose Method
ValueAtPointBase Class See Also Send Feedback
Releases all resources used by the ValueAtPointBase

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ValueAtPointBase Class


GetFlags Method

[image]

Revit 2024 API
ValueAtPointBase..::..GetFlags Method
ValueAtPointBase Class See Also Send Feedback
Returns flags for the given measurement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public int GetFlags(
    int measurement
)
Visual Basic
Public Function GetFlags ( _
    measurement As Integer _
) As Integer
Visual C++
public:
int GetFlags(
    int measurement
)

Parameters

measurement
Type: System..::..Int32
Measurement number for which flags are returned.

Return Value

Flags value for the measurement.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given value for measurement is negative.

See Also

ValueAtPointBase Class


SetFlags Method (IList(Int32))

[image]

Revit 2024 API
ValueAtPointBase..::..SetFlags Method (IList<(Of <(<'Int32>)>)>)
ValueAtPointBase Class See Also Send Feedback
Independently sets the flags associated to all measurements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public void SetFlags(
    IList<int> flags
)
Visual Basic
Public Sub SetFlags ( _
    flags As IList(Of Integer) _
)
Visual C++
public:
void SetFlags(
    IList<int>^ flags
)

Parameters

flags
Type: System.Collections.Generic..::..IList<(Of <(<'Int32>)>)>
An array of flags values. Each member corresponds to a measurement. Flags values are defined in the enumerated class ValueAtPointFlags and are combined into the int value. Number of measurements is set at creation of SpatialFieldManager in method createSpatialFieldManager.

Remarks

If you set the array of flags to only contain one value, this flags value will apply to all measurements

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ValueAtPointBase Class
SetFlags Overload


SetFlags Method (Int32)

[image]

Revit 2024 API
ValueAtPointBase..::..SetFlags Method (Int32)
ValueAtPointBase Class See Also Send Feedback
Sets the flags associated to all measurements to the same value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public void SetFlags(
    int flags
)
Visual Basic
Public Sub SetFlags ( _
    flags As Integer _
)
Visual C++
public:
void SetFlags(
    int flags
)

Parameters

flags
Type: System..::..Int32
Value of flags, uniform for all measurements. Flags values are defined in the enumerated class ValueAtPointFlags and are combined into the int value.

See Also

ValueAtPointBase Class
SetFlags Overload


SetFlags Method (Int32, Int32)

[image]

Revit 2024 API
ValueAtPointBase..::..SetFlags Method (Int32, Int32)
ValueAtPointBase Class See Also Send Feedback
Sets the flags associated to a given measurement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void SetFlags(
    int flags,
    int measurement
)
Visual Basic
Public Sub SetFlags ( _
    flags As Integer, _
    measurement As Integer _
)
Visual C++
public:
void SetFlags(
    int flags,
    int measurement
)

Parameters

flags
Type: System..::..Int32
The value of the flags to set. Flags values are defined in the enumerated class ValueAtPointFlags and are combined into the int value.
measurement
Type: System..::..Int32
Measurement for which to set flags.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given value for measurement is negative.

See Also

ValueAtPointBase Class
SetFlags Overload


ValueAtPointBase Properties

[image] [image]

Revit 2024 API
ValueAtPointBase Properties
ValueAtPointBase Class See Also Send Feedback

The ValueAtPointBase type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ValueAtPointBase Class


IsValidObject Property

[image]

Revit 2024 API
ValueAtPointBase..::..IsValidObject Property
ValueAtPointBase Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ValueAtPointBase Class


ValueAtPointFlags Enumeration

[image]

Revit 2024 API
ValueAtPointFlags Enumeration
See Also Send Feedback
Enumerated type containing flags related to the display on particular points. Enumerated type that stores bit values of flags that can be set at any domain point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public enum ValueAtPointFlags
Visual Basic
Public Enumeration ValueAtPointFlags
Visual C++
public enum class ValueAtPointFlags

Members

Member name | Description
None | No flags set
DisplayText | Show text marker for the point if allowed by display style (applies only to certain display styles)
DisplayFence | Show fence for the point if allowed by display style (applies only to diagram display style)

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


ValueParsingOptions Class

[image]

Revit 2024 API
ValueParsingOptions Class
Members See Also Send Feedback
Options for parsing strings into numbers with units.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class ValueParsingOptions : IDisposable
Visual Basic
Public Class ValueParsingOptions _
    Implements IDisposable
Visual C++
public ref class ValueParsingOptions : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ValueParsingOptions

See Also

ValueParsingOptions Members


ValueParsingOptions Members

[image] [image]

Revit 2024 API
ValueParsingOptions Members
ValueParsingOptions Class Constructors Methods Properties See Also Send Feedback

The ValueParsingOptions type exposes the following members.

Constructors

 | Name | Description
Public method | ValueParsingOptions | Creates a new ValueParsingOptions object with default settings.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ValueParsingOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetFormatOptions | Gets the FormatOptions to optionally override the default settings in the Units class.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetFormatOptions | Sets the FormatOptions to optionally override the default settings in the Units class.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AllowedValues | The allowable range of values to be parsed.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ValueParsingOptions Class


ValueParsingOptions Constructor

[image]

Revit 2024 API
ValueParsingOptions Constructor
ValueParsingOptions Class See Also Send Feedback
Creates a new ValueParsingOptions object with default settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ValueParsingOptions()
Visual Basic
Public Sub New
Visual C++
public:
ValueParsingOptions()

See Also

ValueParsingOptions Class


ValueParsingOptions Methods

[image] [image]

Revit 2024 API
ValueParsingOptions Methods
ValueParsingOptions Class See Also Send Feedback

The ValueParsingOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetFormatOptions | Gets the FormatOptions to optionally override the default settings in the Units class.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetFormatOptions | Sets the FormatOptions to optionally override the default settings in the Units class.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ValueParsingOptions Class


Dispose Method

[image]

Revit 2024 API
ValueParsingOptions..::..Dispose Method
ValueParsingOptions Class See Also Send Feedback
Releases all resources used by the ValueParsingOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ValueParsingOptions Class


GetFormatOptions Method

[image]

Revit 2024 API
ValueParsingOptions..::..GetFormatOptions Method
ValueParsingOptions Class See Also Send Feedback
Gets the FormatOptions to optionally override the default settings in the Units class.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public FormatOptions GetFormatOptions()
Visual Basic
Public Function GetFormatOptions As FormatOptions
Visual C++
public:
FormatOptions^ GetFormatOptions()

Return Value

A copy of the FormatOptions.

Remarks

By default, the FormatOptions represents default formatting (UseDefault is true) and the FormatOptions in the Units class will be used.

See Also

ValueParsingOptions Class


SetFormatOptions Method

[image]

Revit 2024 API
ValueParsingOptions..::..SetFormatOptions Method
ValueParsingOptions Class See Also Send Feedback
Sets the FormatOptions to optionally override the default settings in the Units class.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void SetFormatOptions(
    FormatOptions formatOptions
)
Visual Basic
Public Sub SetFormatOptions ( _
    formatOptions As FormatOptions _
)
Visual C++
public:
void SetFormatOptions(
    FormatOptions^ formatOptions
)

Parameters

formatOptions
Type: Autodesk.Revit.DB..::..FormatOptions
The FormatOptions.

Remarks

By default, the FormatOptions represents default formatting (UseDefault is true) and the FormatOptions in the Units class will be used.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ValueParsingOptions Class


ValueParsingOptions Properties

[image] [image]

Revit 2024 API
ValueParsingOptions Properties
ValueParsingOptions Class See Also Send Feedback

The ValueParsingOptions type exposes the following members.

Properties

 | Name | Description
Public property | AllowedValues | The allowable range of values to be parsed.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.

See Also

ValueParsingOptions Class


AllowedValues Property

[image]

Revit 2024 API
ValueParsingOptions..::..AllowedValues Property
ValueParsingOptions Class See Also Send Feedback
The allowable range of values to be parsed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public AllowedValues AllowedValues { get; set; }
Visual Basic
Public Property AllowedValues As AllowedValues
    Get
    Set
Visual C++
public:
property AllowedValues AllowedValues {
    AllowedValues get ();
    void set (AllowedValues value);
}

Field Value

The allowable range of values. The default is All.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

ValueParsingOptions Class


IsValidObject Property

[image]

Revit 2024 API
ValueParsingOptions..::..IsValidObject Property
ValueParsingOptions Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ValueParsingOptions Class


VertexIndexPair Class

[image]

Revit 2024 API
VertexIndexPair Class
Members See Also Send Feedback
Represents a connection between vertices in the top and bottom profile of a blend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class VertexIndexPair
Visual Basic
Public Class VertexIndexPair
Visual C++
public ref class VertexIndexPair

Remarks

Use objects of this type in GetVertexConnectionMap()()()(), SetVertexConnectionMap(VertexIndexPairArray), GetVertexConnectionMap()()()() and SetVertexConnectionMap(VertexIndexPairArray) to get/set the vertex connection map.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..VertexIndexPair

See Also

VertexIndexPair Members


VertexIndexPair Members

[image] [image]

Revit 2024 API
VertexIndexPair Members
VertexIndexPair Class Constructors Methods Properties See Also Send Feedback

The VertexIndexPair type exposes the following members.

Constructors

 | Name | Description
Public method | VertexIndexPair | Initializes a new instance of the VertexIndexPair class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Bottom | The index of the vertex pair from the bottom profile.
Public property | Top | The index of the vertex pair from the top profile.

See Also

VertexIndexPair Class


VertexIndexPair Constructor

[image]

Revit 2024 API
VertexIndexPair Constructor
VertexIndexPair Class See Also Send Feedback
Initializes a new instance of the VertexIndexPair class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public VertexIndexPair(
    int iTop,
    int iBottom
)
Visual Basic
Public Sub New ( _
    iTop As Integer, _
    iBottom As Integer _
)
Visual C++
public:
VertexIndexPair(
    int iTop,
    int iBottom
)

Parameters

iTop
Type: System..::..Int32
iBottom
Type: System..::..Int32

See Also

VertexIndexPair Class


VertexIndexPair Properties

[image] [image]

Revit 2024 API
VertexIndexPair Properties
VertexIndexPair Class See Also Send Feedback

The VertexIndexPair type exposes the following members.

Properties

 | Name | Description
Public property | Bottom | The index of the vertex pair from the bottom profile.
Public property | Top | The index of the vertex pair from the top profile.

See Also

VertexIndexPair Class


Bottom Property

[image]

Revit 2024 API
VertexIndexPair..::..Bottom Property
VertexIndexPair Class See Also Send Feedback
The index of the vertex pair from the bottom profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public int Bottom { get; set; }
Visual Basic
Public Property Bottom As Integer
    Get
    Set
Visual C++
public:
property int Bottom {
    int get ();
    void set (int value);
}

See Also

VertexIndexPair Class


Top Property

[image]

Revit 2024 API
VertexIndexPair..::..Top Property
VertexIndexPair Class See Also Send Feedback
The index of the vertex pair from the top profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public int Top { get; set; }
Visual Basic
Public Property Top As Integer
    Get
    Set
Visual C++
public:
property int Top {
    int get ();
    void set (int value);
}

See Also

VertexIndexPair Class


VertexIndexPairArray Members

[image] [image]

Revit 2024 API
VertexIndexPairArray Members
VertexIndexPairArray Class Constructors Methods Properties See Also Send Feedback

The VertexIndexPairArray type exposes the following members.

Constructors

 | Name | Description
Public method | VertexIndexPairArray | Initializes a new instance of the VertexIndexPairArray class

Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every VertexIndex pair from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a VertexIndex pair at a specified index within the array.
Public property | Size | Returns the number of VertexIndex pairs that are in the array.

See Also

VertexIndexPairArray Class


VertexIndexPairArray Constructor

[image]

Revit 2024 API
VertexIndexPairArray Constructor
VertexIndexPairArray Class See Also Send Feedback
Initializes a new instance of the VertexIndexPairArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public VertexIndexPairArray()
Visual Basic
Public Sub New
Visual C++
public:
VertexIndexPairArray()

See Also

VertexIndexPairArray Class


VertexIndexPairArray Methods

[image] [image]

Revit 2024 API
VertexIndexPairArray Methods
VertexIndexPairArray Class See Also Send Feedback

The VertexIndexPairArray type exposes the following members.

Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every VertexIndex pair from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

VertexIndexPairArray Class


Append Method

[image]

Revit 2024 API
VertexIndexPairArray..::..Append Method
VertexIndexPairArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Append(
    VertexIndexPair item
)
Visual Basic
Public Overridable Sub Append ( _
    item As VertexIndexPair _
)
Visual C++
public:
virtual void Append(
    VertexIndexPair^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..VertexIndexPair

See Also

VertexIndexPairArray Class


Clear Method

[image]

Revit 2024 API
VertexIndexPairArray..::..Clear Method
VertexIndexPairArray Class See Also Send Feedback
Removes every VertexIndex pair from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

VertexIndexPairArray Class


ForwardIterator Method

[image]

Revit 2024 API
VertexIndexPairArray..::..ForwardIterator Method
VertexIndexPairArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual VertexIndexPairArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As VertexIndexPairArrayIterator
Visual C++
public:
virtual VertexIndexPairArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

VertexIndexPairArray Class


GetEnumerator Method

[image]

Revit 2024 API
VertexIndexPairArray..::..GetEnumerator Method
VertexIndexPairArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

VertexIndexPairArray Class


IsEmpty Property

[image]

Revit 2024 API
VertexIndexPairArray..::..IsEmpty Property
VertexIndexPairArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

VertexIndexPairArray Class


Item Property

[image]

Revit 2024 API
VertexIndexPairArray..::..Item Property
VertexIndexPairArray Class See Also Send Feedback
Gets or sets a VertexIndex pair at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual VertexIndexPair this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As VertexIndexPair
    Get
    Set
Visual C++
public:
virtual property VertexIndexPair^ Item[int index] {
    VertexIndexPair^ get (int index);
    void set (int index, VertexIndexPair^ value);
}

Parameters

index
Type: System..::..Int32
The index of the VertexIndex pair to be set or retrieved.

Return Value

Returns the VertexIndex pair at the specified index.

See Also

VertexIndexPairArray Class


Size Property

[image]

Revit 2024 API
VertexIndexPairArray..::..Size Property
VertexIndexPairArray Class See Also Send Feedback
Returns the number of VertexIndex pairs that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

VertexIndexPairArray Class


VertexIndexPairArrayIterator Members

[image] [image]

Revit 2024 API
VertexIndexPairArrayIterator Members
VertexIndexPairArrayIterator Class Constructors Methods Properties See Also Send Feedback

The VertexIndexPairArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | VertexIndexPairArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

VertexIndexPairArrayIterator Class


VertexIndexPairArrayIterator Constructor

[image]

Revit 2024 API
VertexIndexPairArrayIterator Constructor
VertexIndexPairArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public VertexIndexPairArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
VertexIndexPairArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

VertexIndexPairArrayIterator Class


VertexIndexPairArrayIterator Methods

[image] [image]

Revit 2024 API
VertexIndexPairArrayIterator Methods
VertexIndexPairArrayIterator Class See Also Send Feedback

The VertexIndexPairArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

VertexIndexPairArrayIterator Class


MoveNext Method

[image]

Revit 2024 API
VertexIndexPairArrayIterator..::..MoveNext Method
VertexIndexPairArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

VertexIndexPairArrayIterator Class


Reset Method

[image]

Revit 2024 API
VertexIndexPairArrayIterator..::..Reset Method
VertexIndexPairArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

VertexIndexPairArrayIterator Class


VertexIndexPairArrayIterator Properties

[image] [image]

Revit 2024 API
VertexIndexPairArrayIterator Properties
VertexIndexPairArrayIterator Class See Also Send Feedback

The VertexIndexPairArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

VertexIndexPairArrayIterator Class


Current Property

[image]

Revit 2024 API
VertexIndexPairArrayIterator..::..Current Property
VertexIndexPairArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

VertexIndexPairArrayIterator Class


VertexPair Class

[image]

Revit 2024 API
VertexPair Class
Members See Also Send Feedback
Indices of a pair of vertices in two CurveLoops(one vertex in each loop).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public class VertexPair : IDisposable
Visual Basic
Public Class VertexPair _
    Implements IDisposable
Visual C++
public ref class VertexPair : IDisposable

Remarks

A vertex is specified by the index in the CurveLoop of the curve having that vertex as its start point. Indexes start at 0.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..VertexPair

See Also

VertexPair Members


VertexPair Members

[image] [image]

Revit 2024 API
VertexPair Members
VertexPair Class Constructors Methods Properties See Also Send Feedback

The VertexPair type exposes the following members.

Constructors

 | Name | Description
Public method | VertexPair | Constructs a new VertexPair from a pair of indices in the curve loops.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the VertexPair
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | First | Identifies the first index of VertexPair.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Second | Identifies the second index of VertexPair.

See Also

VertexPair Class


VertexPair Constructor

[image]

Revit 2024 API
VertexPair Constructor
VertexPair Class See Also Send Feedback
Constructs a new VertexPair from a pair of indices in the curve loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public VertexPair(
    int firstVertexIdx,
    int secondVertexIdx
)
Visual Basic
Public Sub New ( _
    firstVertexIdx As Integer, _
    secondVertexIdx As Integer _
)
Visual C++
public:
VertexPair(
    int firstVertexIdx,
    int secondVertexIdx
)

Parameters

firstVertexIdx
Type: System..::..Int32
secondVertexIdx
Type: System..::..Int32

See Also

VertexPair Class


VertexPair Methods

[image] [image]

Revit 2024 API
VertexPair Methods
VertexPair Class See Also Send Feedback

The VertexPair type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

VertexPair Class


Dispose Method

[image]

Revit 2024 API
VertexPair..::..Dispose Method
VertexPair Class See Also Send Feedback
Releases all resources used by the VertexPair

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

VertexPair Class


VertexPair Properties

[image] [image]

Revit 2024 API
VertexPair Properties
VertexPair Class See Also Send Feedback

The VertexPair type exposes the following members.

Properties

 | Name | Description
Public property | First | Identifies the first index of VertexPair.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Second | Identifies the second index of VertexPair.

See Also

VertexPair Class


First Property

[image]

Revit 2024 API
VertexPair..::..First Property
VertexPair Class See Also Send Feedback
Identifies the first index of VertexPair.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public int First { get; set; }
Visual Basic
Public Property First As Integer
    Get
    Set
Visual C++
public:
property int First {
    int get ();
    void set (int value);
}

See Also

VertexPair Class


Second Property

[image]

Revit 2024 API
VertexPair..::..Second Property
VertexPair Class See Also Send Feedback
Identifies the second index of VertexPair.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public int Second { get; set; }
Visual Basic
Public Property Second As Integer
    Get
    Set
Visual C++
public:
property int Second {
    int get ();
    void set (int value);
}

See Also

VertexPair Class


VerticalAlignmentStyle Enumeration

[image]

Revit 2024 API
VerticalAlignmentStyle Enumeration
See Also Send Feedback
Declares the vertical alignment style of font.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public enum VerticalAlignmentStyle
Visual Basic
Public Enumeration VerticalAlignmentStyle
Visual C++
public enum class VerticalAlignmentStyle

Members

Member name | Description
Top | Alignment to top
Middle | Alignment to middle
Bottom | Alignment to bottom

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


VerticalTextAlignment Enumeration

[image]

Revit 2024 API
VerticalTextAlignment Enumeration
See Also Send Feedback
Supported types of vertical alignment of a text element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016
Since: 2016

Syntax

C#
public enum VerticalTextAlignment
Visual Basic
Public Enumeration VerticalTextAlignment
Visual C++
public enum class VerticalTextAlignment

Members

Member name | Description
Top | Top of the text box remains in place as the height of the text changes.
Bottom | Bottom of the text box remains in place as the height of the text changes.
Middle | The horizontal center line of the text box remains in place as the height of the text changes.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


View Methods

[image] [image]

Revit 2024 API
View Methods
View Class See Also Send Feedback

The View type exposes the following members.

Methods

 | Name | Description
Public method | AddFilter | Adds a filter to the view.
Public method | AllowsAnalysisDisplay | Identifies if this view allows display of Analysis results.
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of the input view that are not controlled by the current view template.
Public method | AreGraphicsOverridesAllowed | Determines if Visibility/Graphics Overriddes can be applied to the view.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanApplyColorFillScheme | Checks if the id can be applied as the scheme id of specified category to this view.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanCategoryBeHidden | Checks whether the category can be hidden in the view.
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view.
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanEnableTemporaryViewPropertiesMode | Indicates if Temporary View Properties mode can be applied for view in current state.
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified.
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified.
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified
Public method | CanUseDepthCueing | Indicates if view can use Depth Cueing
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes
Public method | CanViewBeDuplicated | Identifies if this view can be duplicated.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view.
Public method | ConvertToIndependent | Convert the dependent view to independent.
Public method | CreateViewTemplate | Creates a new view template instance from this view instance.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode.
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates this view.
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode.
Public method | EnableTemporaryViewPropertiesMode | Turns Temporary View Properties mode on or off. In this mode, any changes made to the view are temporary and will be discarded once the mode is disabled.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetBackground | Returns the current background set for the view.
Public method | GetCalloutParentId | Gets ID of the callout parent view.
Public method | GetCategoryHidden | Checks if elements of the given category are set to be invisible (hidden) in this view.
Public method | GetCategoryOverrides | Gets graphic overrides for a category in view.
Public method | GetColorFillSchemeId | Returns id of the color fill scheme element applied to the view.
Public method | GetCropRegionShapeManager | Returns an object for managing view crop region shape.
 | GetCropRegionShapeManagerForReferenceCallout | Returns an object for managing view crop region shape for reference callout.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetDependentViewIds | Get the ids of dependent views.
Public method | GetDepthCueing | Returns the current depth cueing settings for the view.
Public method | GetDirectContext3DHandleOverrides | Returns DirectContext3D handle overrides object for the view.
Public method | GetElementOverrides | Gets graphic overrides for an element in the view.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetFilterOverrides | Gets graphic overrides that a filter applies to the view.
Public method | GetFilters | Gets the filters applied to the view.
Public method | GetFilterVisibility | Gets the visibility of the elements associated with a filter.
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIsFilterEnabled | Identifies if the filter is enabled in this view.
Public method | GetLinkOverrides | Gets the graphic overrides of a RevitLinkType or RevitLinkInstance in view.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetModelToProjectionTransforms | Gets the transforms from the model space to the view projection space.
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetNonControlledTemplateParameterIds | Returns a list of parameters that are not marked as included when this view is used as a template.
Public method | GetOrderedFilters | Gets the filters applied to the view in the order they are applied.
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPlacementOnSheetStatus | Determines if this view placed on a sheet completely or partially.
Public method | GetPointCloudOverrides | Returns point cloud overrides object for the view.
Public method | GetPrimaryViewId | Get the id of the primary view.
Public method | GetReferenceCallouts | Returns element ids of all reference callouts in the view.
Public method | GetReferenceElevations | Returns element ids of all reference elevations in the view.
Public method | GetReferenceSections | Returns element ids of all reference sections in the view.
Public method | GetSketchyLines | Returns the current sketchy lines settings for the view.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetTemplateParameterIds | Returns a list of parameter ids that may be controlled when this view is assigned as a template.
Public method | GetTemporaryViewPropertiesId | When Temporary View Properties mode is in progress it provides view id that overrode settings for current view. Outside Temporary View Properties mode InvalidElementId will be returned.
Public method | GetTemporaryViewPropertiesName | When Temporary View Properties mode is in progress, name of applied template is returned. Outside Temporary View Properties mode, empty string will be returned.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetViewDisplayModel | Returns the current view display model settings for the view.
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view.
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view.
Public method | HasDetailLevel | Check if the view has a Detail Level property
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property
Public method | HasViewTransforms | Returns true if the view reports model space to view projection space transforms.
Public method | HideActiveWorkPlane | Hide the active work plane of the view.
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view.
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view.
Public method | HideElements | Sets the elements to be hidden in the view.
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input.
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input.
Public method | IsCategoryOverridable | Checks whether the category can have graphic overrides in this view.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsFilterApplied | Indicates if a filter is applied to the view.
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view.
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view.
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input.
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input.
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories.
Public method | IsTemporaryViewPropertiesModeEnabled | Returns true when Temporary View Properties mode is in progress, false otherwise.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
 | IsValidViewScale | This validator checks that the view scale is in the allowable range.
Public method | IsValidViewTemplate | Verifies that the view represented by templateId can be set as the controlling view template for this view.
Public method | IsViewValidForTemplateCreation | Verifies that the view is valid for template creation.
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document.
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document.
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document.
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document.
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | RemoveCalloutParent | Replaces callout parent ID with InvalidElementId.
Public method | RemoveFilter | Removes a filter from the view.
Public method | RemoveLinkOverrides | Deletes the graphical link overrides in the current view.
Public method | RestoreCalloutParent | Restores callout parent ID to the original view ID if that view is still available.
Public method | SetBackground | Sets the background for the view. Background can only be set for 3d views and for Sections/Elevations.
Public method | SetCategoryHidden | Sets if elements of the given category will be visible in this view.
Public method | SetCategoryOverrides | Sets graphic overrides for a category in view.
Public method | SetColorFillSchemeId | Applies color fill scheme to this view.
Public method | SetDepthCueing | Sets the depth cueing settings for the view.
Public method | SetElementOverrides | Sets graphic overrides for an element in the view.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetFilterOverrides | Sets the overrides associated with a filter.
Public method | SetFilterVisibility | Sets the visibility of the elements associated with a filter.
Public method | SetIsFilterEnabled | Sets the filter enabled flag.
Public method | SetLinkOverrides | Sets the graphic overrides of a RevitLinkType or RevitLinkInstance in the view.
Public method | SetNonControlledTemplateParameterIds | Sets the parameters that will not be included when this view is used as a template.
Public method | SetSketchyLines | Sets the sketchy lines settings for the view.
Public method | SetViewDisplayModel | Sets the view display model settings for the view.
Public method | SetWorksetVisibility | Sets visibility for a workset in this view.
Public method | SetWorksharingDisplayMode | Sets the worksharing display mode for this view.
Public method | ShowActiveWorkPlane | Show the active work plane of the view.
Public method | SupportedColorFillCategoryIds | Returns collection of all category ids that correspond to elements that can potentially be colored in this view according to a color fill scheme. The set may be different depending on the view type.
Public method | SupportsRevealConstraints | Checks that the view can have the Reveal Constraints mode activated.
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden.

See Also

View Class


AllowsAnalysisDisplay Method

[image]

Revit 2024 API
View..::..AllowsAnalysisDisplay Method
View Class See Also Send Feedback
Identifies if this view allows display of Analysis results.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool AllowsAnalysisDisplay()
Visual Basic
Public Function AllowsAnalysisDisplay As Boolean
Visual C++
public:
bool AllowsAnalysisDisplay()

Return Value

True if the view allows display of Analysis results, false otherwise.

See Also

View Class


ApplyViewTemplateParameters Method

[image]

Revit 2024 API
View..::..ApplyViewTemplateParameters Method
View Class See Also Send Feedback
Applies to this view the parameters of the input view that are not controlled by the current view template.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void ApplyViewTemplateParameters(
    View otherView
)
Visual Basic
Public Sub ApplyViewTemplateParameters ( _
    otherView As View _
)
Visual C++
public:
void ApplyViewTemplateParameters(
    View^ otherView
)

Parameters

otherView
Type: Autodesk.Revit.DB..::..View
The view whose parameters are to be applied to this view. It does not have to be a valid template (property IsTemplate can be true or false).

Remarks

Apply the view template parameters is a one-time operation, the association between the views is not preserved. To get all template parameters call GetTemplateParameterIds()()()() on the template. To get parameters that are not controlled by the template call GetNonControlledTemplateParameterIds()()()() on the template. To get current view template of this view use property ViewTemplateId.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

View Class


AreGraphicsOverridesAllowed Method

[image]

Revit 2024 API
View..::..AreGraphicsOverridesAllowed Method
View Class See Also Send Feedback
Determines if Visibility/Graphics Overriddes can be applied to the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool AreGraphicsOverridesAllowed()
Visual Basic
Public Function AreGraphicsOverridesAllowed As Boolean
Visual C++
public:
bool AreGraphicsOverridesAllowed()

Return Value

True if Overriddes can be applied to the view, false otherwise.

See Also

View Class


CanApplyColorFillScheme Method

[image]

Revit 2024 API
View..::..CanApplyColorFillScheme Method
View Class See Also Send Feedback
Checks if the id can be applied as the scheme id of specified category to this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public bool CanApplyColorFillScheme(
    ElementId categoryId,
    ElementId schemeId
)
Visual Basic
Public Function CanApplyColorFillScheme ( _
    categoryId As ElementId, _
    schemeId As ElementId _
) As Boolean
Visual C++
public:
bool CanApplyColorFillScheme(
    ElementId^ categoryId,
    ElementId^ schemeId
)

Parameters

categoryId
Type: Autodesk.Revit.DB..::..ElementId
The id of category.
schemeId
Type: Autodesk.Revit.DB..::..ElementId
The id of color fill scheme.

Return Value

True if the id can be applied as the scheme id of specified category in this view, false otherwise.

Remarks

The input scheme id could be InvalidElementId to clear the scheme for the specified category.

Some examples of returnning false:

  • The id is not a color fill scheme id.
  • The specified category is not supported by this view.
  • The category of scheme is not the same as the specified category.
  • The view is area plan but the scheme category is not OST_Areas, or their [!:Autodesk::Revit::DB::AreaScheme] are not the same.
  • Etc.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

View Class


CanCategoryBeHidden Method

[image]

Revit 2024 API
View..::..CanCategoryBeHidden Method
View Class See Also Send Feedback
Checks whether the category can be hidden in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool CanCategoryBeHidden(
    ElementId elementId
)
Visual Basic
Public Function CanCategoryBeHidden ( _
    elementId As ElementId _
) As Boolean
Visual C++
public:
bool CanCategoryBeHidden(
    ElementId^ elementId
)

Parameters

elementId
Type: Autodesk.Revit.DB..::..ElementId
ElementId of the category.

Return Value

True if the category can be hidden, false otherwise.

Remarks

Categories can be allowed to be hidden in some view types and prohibited from being hidden in others. E.g., categories cannot be hidden in ProjectBrowser

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

View Class


CanEnableTemporaryViewPropertiesMode Method

[image]

Revit 2024 API
View..::..CanEnableTemporaryViewPropertiesMode Method
View Class See Also Send Feedback
Indicates if Temporary View Properties mode can be applied for view in current state.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool CanEnableTemporaryViewPropertiesMode()
Visual Basic
Public Function CanEnableTemporaryViewPropertiesMode As Boolean
Visual C++
public:
bool CanEnableTemporaryViewPropertiesMode()

Return Value

True if view can use Temporary View Properties mode in current state.

See Also

View Class


CanModifyDetailLevel Method

[image]

Revit 2024 API
View..::..CanModifyDetailLevel Method
View Class See Also Send Feedback
Check if Detail Level can be modified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool CanModifyDetailLevel()
Visual Basic
Public Function CanModifyDetailLevel As Boolean
Visual C++
public:
bool CanModifyDetailLevel()

Return Value

True if Detail Level can be modified.

See Also

View Class


CanModifyDisplayStyle Method

[image]

Revit 2024 API
View..::..CanModifyDisplayStyle Method
View Class See Also Send Feedback
Indicates if DisplayStyle can be modified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool CanModifyDisplayStyle()
Visual Basic
Public Function CanModifyDisplayStyle As Boolean
Visual C++
public:
bool CanModifyDisplayStyle()

Return Value

True if DisplayStyle can be modified.

See Also

View Class


CanModifyViewDiscipline Method

[image]

Revit 2024 API
View..::..CanModifyViewDiscipline Method
View Class See Also Send Feedback
Indicates if the View Discipline can be modified

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool CanModifyViewDiscipline()
Visual Basic
Public Function CanModifyViewDiscipline As Boolean
Visual C++
public:
bool CanModifyViewDiscipline()

Return Value

True if View Discipline can be modified

See Also

View Class


CanUseDepthCueing Method

[image]

Revit 2024 API
View..::..CanUseDepthCueing Method
View Class See Also Send Feedback
Indicates if view can use Depth Cueing

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public bool CanUseDepthCueing()
Visual Basic
Public Function CanUseDepthCueing As Boolean
Visual C++
public:
bool CanUseDepthCueing()

Return Value

True if view can use Depth Cueing

See Also

View Class


CanUseTemporaryVisibilityModes Method

[image]

Revit 2024 API
View..::..CanUseTemporaryVisibilityModes Method
View Class See Also Send Feedback
Indicates if view can use temporary visibility modes

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool CanUseTemporaryVisibilityModes()
Visual Basic
Public Function CanUseTemporaryVisibilityModes As Boolean
Visual C++
public:
bool CanUseTemporaryVisibilityModes()

Return Value

True if view can use temporary visibility modes

See Also

View Class


CanViewBeDuplicated Method

[image]

Revit 2024 API
View..::..CanViewBeDuplicated Method
View Class See Also Send Feedback
Identifies if this view can be duplicated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool CanViewBeDuplicated(
    ViewDuplicateOption duplicateOption
)
Visual Basic
Public Function CanViewBeDuplicated ( _
    duplicateOption As ViewDuplicateOption _
) As Boolean
Visual C++
public:
bool CanViewBeDuplicated(
    ViewDuplicateOption duplicateOption
)

Parameters

duplicateOption
Type: Autodesk.Revit.DB..::..ViewDuplicateOption
The option to use when duplicating the view.

Return Value

True if the view can be duplicated, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

View Class


ConvertTemporaryHideIsolateToPermanent Method

[image]

Revit 2024 API
View..::..ConvertTemporaryHideIsolateToPermanent Method
View Class See Also Send Feedback
Convert all temporary hidden elements or categories to permanently hidden in view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void ConvertTemporaryHideIsolateToPermanent()
Visual Basic
Public Sub ConvertTemporaryHideIsolateToPermanent
Visual C++
public:
void ConvertTemporaryHideIsolateToPermanent()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The element "this View" does not belong to a project document.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | This View is an internal element, such as a component of a loaded family or a group type. -or- The document containing this View is in Group Edit Mode, Sketch Edit Mode, or Paste Mode, and the element is not a member of the group, sketch, or clipboard. -or- This View is a member of a group or sketch, and the document is not currently editing the group or sketch.

See Also

View Class


CreateViewTemplate Method

[image]

Revit 2024 API
View..::..CreateViewTemplate Method
View Class See Also Send Feedback
Creates a new view template instance from this view instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public View CreateViewTemplate()
Visual Basic
Public Function CreateViewTemplate As View
Visual C++
public:
View^ CreateViewTemplate()

Return Value

New view template instance

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The view is not valid for view template creation.

See Also

View Class


Duplicate Method

[image]

Revit 2024 API
View..::..Duplicate Method
View Class Example See Also Send Feedback
Duplicates this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ElementId Duplicate(
    ViewDuplicateOption duplicateOption
)
Visual Basic
Public Function Duplicate ( _
    duplicateOption As ViewDuplicateOption _
) As ElementId
Visual C++
public:
ElementId^ Duplicate(
    ViewDuplicateOption duplicateOption
)

Parameters

duplicateOption
Type: Autodesk.Revit.DB..::..ViewDuplicateOption
The option to use when duplicating the view.

Return Value

The id of the newly created view.

Examples

CopyC#
public View CreateDependentCopy(View view)
{
    View dependentView = null;
    ElementId newViewId = ElementId.InvalidElementId;
    if (view.CanViewBeDuplicated(ViewDuplicateOption.AsDependent))
    {
        newViewId = view.Duplicate(ViewDuplicateOption.AsDependent);
        dependentView = view.Document.GetElement(newViewId) as View;
        if (null != dependentView)
        {
            if (dependentView.GetPrimaryViewId() == view.Id)
            {
                TaskDialog.Show("Dependent View", "Dependent view created successfully!");
            }
        }
    }

    return dependentView;
}
CopyVB.NET
Public Function CreateDependentCopy(view As View) As View
    Dim dependentView As View = Nothing
    Dim newViewId As ElementId = ElementId.InvalidElementId
    If view.CanViewBeDuplicated(ViewDuplicateOption.AsDependent) Then
        newViewId = view.Duplicate(ViewDuplicateOption.AsDependent)
        dependentView = TryCast(view.Document.GetElement(newViewId), View)
        If dependentView IsNot Nothing Then
            If dependentView.GetPrimaryViewId() = view.Id Then
                TaskDialog.Show("Dependent View", "Dependent view created successfully!")
            End If
        End If
    End If

    Return dependentView
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | View cannot be duplicated

See Also

View Class


EnableRevealHiddenMode Method

[image]

Revit 2024 API
View..::..EnableRevealHiddenMode Method
View Class See Also Send Feedback
Enables Reveal Hidden elements mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void EnableRevealHiddenMode()
Visual Basic
Public Sub EnableRevealHiddenMode
Visual C++
public:
void EnableRevealHiddenMode()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | View cannot use temporary visibility modes.

See Also

View Class


EnableTemporaryViewPropertiesMode Method

[image]

Revit 2024 API
View..::..EnableTemporaryViewPropertiesMode Method
View Class See Also Send Feedback
Turns Temporary View Properties mode on or off. In this mode, any changes made to the view are temporary and will be discarded once the mode is disabled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool EnableTemporaryViewPropertiesMode(
    ElementId viewTemplateId
)
Visual Basic
Public Function EnableTemporaryViewPropertiesMode ( _
    viewTemplateId As ElementId _
) As Boolean
Visual C++
public:
bool EnableTemporaryViewPropertiesMode(
    ElementId^ viewTemplateId
)

Parameters

viewTemplateId
Type: Autodesk.Revit.DB..::..ElementId
If the id of a view template is provided, Temporary View Properties mode is turned on and the settings from the template are applied to the view for the duration of the mode. If the id provided is not that of a template but the id of the view itself, Temporary View Properties mode is turned on without any changes to the view. If ElementId.InvalidElementId is provided, Temporary View Properties mode is turned off.

Return Value

Returns true when the view template provided by viewTemplateId was applied and Temporary View Properties was successfully turned on. Also returns true if ElementId.InvalidElementId was provided as input and Temporary View Properties was successfully turned off.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | View cannot use Temporary View Properties mode in current state.

See Also

View Class


GetBackground Method

[image]

Revit 2024 API
View..::..GetBackground Method
View Class See Also Send Feedback
Returns the current background set for the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ViewDisplayBackground GetBackground()
Visual Basic
Public Function GetBackground As ViewDisplayBackground
Visual C++
public:
ViewDisplayBackground^ GetBackground()

Return Value

Current background.

See Also

View Class


GetCalloutParentId Method

[image]

Revit 2024 API
View..::..GetCalloutParentId Method
View Class See Also Send Feedback
Gets ID of the callout parent view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public ElementId GetCalloutParentId()
Visual Basic
Public Function GetCalloutParentId As ElementId
Visual C++
public:
ElementId^ GetCalloutParentId()

Return Value

ID of a view in which this callout was created or InvalidElementId if there is no parent.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This view is not a callout.

See Also

View Class


GetCategoryHidden Method

[image]

Revit 2024 API
View..::..GetCategoryHidden Method
View Class See Also Send Feedback
Checks if elements of the given category are set to be invisible (hidden) in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public bool GetCategoryHidden(
    ElementId categoryId
)
Visual Basic
Public Function GetCategoryHidden ( _
    categoryId As ElementId _
) As Boolean
Visual C++
public:
bool GetCategoryHidden(
    ElementId^ categoryId
)

Parameters

categoryId
Type: Autodesk.Revit.DB..::..ElementId
The ID of the category.

Return Value

True if the category is invisible (hidden), false otherwise.

Remarks

This checks only if the category is set visible or invisible individually. Other Revit mechanisms may also affect the visibility of elements of this category, including:
  • The category classes settings for model categories, annotation categories, import categories or analytical model categories.
  • View filters.
  • Elements hidden individually in the view.
Thus the return value may not reflect the actual visibility of elements of this category in the view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | categoryId does not correspond to a Category.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

View Class


GetColorFillSchemeId Method

[image]

Revit 2024 API
View..::..GetColorFillSchemeId Method
View Class See Also Send Feedback
Returns id of the color fill scheme element applied to the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public ElementId GetColorFillSchemeId(
    ElementId categoryId
)
Visual Basic
Public Function GetColorFillSchemeId ( _
    categoryId As ElementId _
) As ElementId
Visual C++
public:
ElementId^ GetColorFillSchemeId(
    ElementId^ categoryId
)

Parameters

categoryId
Type: Autodesk.Revit.DB..::..ElementId
The id of the category which the color fill scheme element belongs to.

Return Value

The id of the color fill scheme element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

View Class


GetCropRegionShapeManagerForReferenceCallout Method

[image]

Revit 2024 API
View..::..GetCropRegionShapeManagerForReferenceCallout Method
View Class See Also Send Feedback
Returns an object for managing view crop region shape for reference callout.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static ViewCropRegionShapeManager GetCropRegionShapeManagerForReferenceCallout(
    Document doc,
    ElementId callout
)
Visual Basic
Public Shared Function GetCropRegionShapeManagerForReferenceCallout ( _
    doc As Document, _
    callout As ElementId _
) As ViewCropRegionShapeManager
Visual C++
public:
static ViewCropRegionShapeManager^ GetCropRegionShapeManagerForReferenceCallout(
    Document^ doc,
    ElementId^ callout
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
Document to which the callout belongs.
callout
Type: Autodesk.Revit.DB..::..ElementId
Element id of reference callout.

Return Value

The crop region shape manager.

Remarks

Reference callout is a view-specific element referencing another view. It can have its own crop region shape which doesn't affect the referenced view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

View Class


GetDependentViewIds Method

[image]

Revit 2024 API
View..::..GetDependentViewIds Method
View Class See Also Send Feedback
Get the ids of dependent views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ICollection<ElementId> GetDependentViewIds()
Visual Basic
Public Function GetDependentViewIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetDependentViewIds()

Return Value

Ids of the dependent views.

See Also

View Class


GetDirectContext3DHandleOverrides Method

[image]

Revit 2024 API
View..::..GetDirectContext3DHandleOverrides Method
View Class See Also Send Feedback
Returns DirectContext3D handle overrides object for the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public DirectContext3DHandleOverrides GetDirectContext3DHandleOverrides()
Visual Basic
Public Function GetDirectContext3DHandleOverrides As DirectContext3DHandleOverrides
Visual C++
public:
DirectContext3DHandleOverrides^ GetDirectContext3DHandleOverrides()

Return Value

DirectContext3D handle overrides for the view

See Also

View Class


GetElementOverrides Method

[image]

Revit 2024 API
View..::..GetElementOverrides Method
View Class See Also Send Feedback
Gets graphic overrides for an element in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public OverrideGraphicSettings GetElementOverrides(
    ElementId elementId
)
Visual Basic
Public Function GetElementOverrides ( _
    elementId As ElementId _
) As OverrideGraphicSettings
Visual C++
public:
OverrideGraphicSettings^ GetElementOverrides(
    ElementId^ elementId
)

Parameters

elementId
Type: Autodesk.Revit.DB..::..ElementId
The element.

Return Value

An object representing all graphic overrides of the element elementId in view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | elementId is not a valid Element identifier.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The element "this View" does not belong to a project document. -or- The view type does not support Visibility/Graphics Overriddes.

See Also

View Class


GetFilterOverrides Method

[image]

Revit 2024 API
View..::..GetFilterOverrides Method
View Class See Also Send Feedback
Gets graphic overrides that a filter applies to the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public OverrideGraphicSettings GetFilterOverrides(
    ElementId filterElementId
)
Visual Basic
Public Function GetFilterOverrides ( _
    filterElementId As ElementId _
) As OverrideGraphicSettings
Visual C++
public:
OverrideGraphicSettings^ GetFilterOverrides(
    ElementId^ filterElementId
)

Parameters

filterElementId
Type: Autodesk.Revit.DB..::..ElementId
ElementId of the filter.

Return Value

Object representing all graphic overrides of the filter in the view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | ElementId is not associated with a FilterElement. -or- Filter is not applied to the view.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The element "this View" does not belong to a project document. -or- The view type does not support Visibility/Graphics Overriddes.

See Also

View Class


GetFilters Method

[image]

Revit 2024 API
View..::..GetFilters Method
View Class See Also Send Feedback
Gets the filters applied to the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ICollection<ElementId> GetFilters()
Visual Basic
Public Function GetFilters As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetFilters()

Return Value

The ElementIds of the Filters.

Remarks

Note that this method returns filters in a set sorted according to their ids. To get filters in the order they are applied to the view use GetOrderedFilters()()()().

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The element "this View" does not belong to a project document. -or- The view type does not support Visibility/Graphics Overriddes.

See Also

View Class


GetFilterVisibility Method

[image]

Revit 2024 API
View..::..GetFilterVisibility Method
View Class See Also Send Feedback
Gets the visibility of the elements associated with a filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool GetFilterVisibility(
    ElementId filterElementId
)
Visual Basic
Public Function GetFilterVisibility ( _
    filterElementId As ElementId _
) As Boolean
Visual C++
public:
bool GetFilterVisibility(
    ElementId^ filterElementId
)

Parameters

filterElementId
Type: Autodesk.Revit.DB..::..ElementId
The ElementId of the filter.

Return Value

True if the elements associated with the filter are visible in the view, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Filter is not applied to the view. -or- ElementId is not associated with a FilterElement.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The element "this View" does not belong to a project document. -or- The view type does not support Visibility/Graphics Overriddes.

See Also

View Class


GetIsFilterEnabled Method

[image]

Revit 2024 API
View..::..GetIsFilterEnabled Method
View Class See Also Send Feedback
Identifies if the filter is enabled in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public bool GetIsFilterEnabled(
    ElementId filterElementId
)
Visual Basic
Public Function GetIsFilterEnabled ( _
    filterElementId As ElementId _
) As Boolean
Visual C++
public:
bool GetIsFilterEnabled(
    ElementId^ filterElementId
)

Parameters

filterElementId
Type: Autodesk.Revit.DB..::..ElementId
The ElementId of the filter.

Return Value

True if the specified filter is enabled in this view, false otherwise.

Remarks

Several filters can be applied to a view in a certain order. This enable/disable flag allows one to quickly turn on/off the action of a particular filter in this view (without removing the filter from the set of applied filters and losing the corresponding overrides). By default, all the filters applied to a view are enabled.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Filter is not applied to the view. -or- ElementId is not associated with a FilterElement.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The element "this View" does not belong to a project document. -or- The view type does not support Visibility/Graphics Overriddes.

See Also

View Class


GetModelToProjectionTransforms Method

[image]

Revit 2024 API
View..::..GetModelToProjectionTransforms Method
View Class See Also Send Feedback
Gets the transforms from the model space to the view projection space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public IList<TransformWithBoundary> GetModelToProjectionTransforms()
Visual Basic
Public Function GetModelToProjectionTransforms As IList(Of TransformWithBoundary)
Visual C++
public:
IList<TransformWithBoundary^>^ GetModelToProjectionTransforms()

Return Value

The transformations from the model space to view projection space.

Remarks

Model space is the global 3D coordinate space in which the geometry of the model lives.

View projection space is the 3D Euclidean space with a coordinate system such that X and Y are horizontal and vertical directions in the view projection plane and Z is the cross product of X and Y. Distances in the projection space are the same as would be measured on paper if the view is printed without additional scaling.

Most views will return just one TransformWithBoundary. The exceptions are views with split crop regions. Split crop regions can be independently moved and therefore each region of a split crop gets its own transform and boundary. You can check if a view has split crop regions by getting the ViewCropRegionShapeManager and calling [!:ViewCropRegionShapeManager.IsSplit()].

When the view's crop region is split, many TransformWithBoundary objects will be returned. Each TransformWithBoundary corresponds to one region of the split crop. To determine which TransformWithBoundary to use when converting a model point into view projection space, first test to see which split crop region boundary contains the model point. See [!:TransformWithBoundary.GetBoundary()].

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The view does not return transforms. -or- The view is a perspective view.

See Also

View Class


GetNonControlledTemplateParameterIds Method

[image]

Revit 2024 API
View..::..GetNonControlledTemplateParameterIds Method
View Class See Also Send Feedback
Returns a list of parameters that are not marked as included when this view is used as a template.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ICollection<ElementId> GetNonControlledTemplateParameterIds()
Visual Basic
Public Function GetNonControlledTemplateParameterIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetNonControlledTemplateParameterIds()

Return Value

The parameter ids that are not marked to be included.

Remarks

This is a subset of the parameters returned by GetTemplateParameterIds()()()().

See Also

View Class


GetOrderedFilters Method

[image]

Revit 2024 API
View..::..GetOrderedFilters Method
View Class See Also Send Feedback
Gets the filters applied to the view in the order they are applied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public IList<ElementId> GetOrderedFilters()
Visual Basic
Public Function GetOrderedFilters As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetOrderedFilters()

Return Value

The ElementIds of the Filters.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The element "this View" does not belong to a project document. -or- The view type does not support Visibility/Graphics Overriddes.

See Also

View Class


GetPlacementOnSheetStatus Method

[image]

Revit 2024 API
View..::..GetPlacementOnSheetStatus Method
View Class See Also Send Feedback
Determines if this view placed on a sheet completely or partially.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public ViewPlacementOnSheetStatus GetPlacementOnSheetStatus()
Visual Basic
Public Function GetPlacementOnSheetStatus As ViewPlacementOnSheetStatus
Visual C++
public:
ViewPlacementOnSheetStatus GetPlacementOnSheetStatus()

Return Value

A value indicating whether and how the View is placed on a Sheet.

Remarks

Some Views can be placed on one or more Sheets completely or partially. For example, a Schedule divided in segments, and only some of them are placed on Sheets.

See Also

View Class


GetPointCloudOverrides Method

[image]

Revit 2024 API
View..::..GetPointCloudOverrides Method
View Class See Also Send Feedback
Returns point cloud overrides object for the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public PointCloudOverrides GetPointCloudOverrides()
Visual Basic
Public Function GetPointCloudOverrides As PointCloudOverrides
Visual C++
public:
PointCloudOverrides^ GetPointCloudOverrides()

Return Value

Point cloud overrides for the view

See Also

View Class


GetPrimaryViewId Method

[image]

Revit 2024 API
View..::..GetPrimaryViewId Method
View Class See Also Send Feedback
Get the id of the primary view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ElementId GetPrimaryViewId()
Visual Basic
Public Function GetPrimaryViewId As ElementId
Visual C++
public:
ElementId^ GetPrimaryViewId()

Return Value

The id of the primary view, or InvalidElementId if there is no primary view.

Remarks

The primary view is the view from which a dependent view is created.

See Also

View Class


GetReferenceCallouts Method

[image]

Revit 2024 API
View..::..GetReferenceCallouts Method
View Class See Also Send Feedback
Returns element ids of all reference callouts in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ICollection<ElementId> GetReferenceCallouts()
Visual Basic
Public Function GetReferenceCallouts As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetReferenceCallouts()

Return Value

Element ids of all reference callouts in the view.

See Also

View Class


GetReferenceElevations Method

[image]

Revit 2024 API
View..::..GetReferenceElevations Method
View Class See Also Send Feedback
Returns element ids of all reference elevations in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ICollection<ElementId> GetReferenceElevations()
Visual Basic
Public Function GetReferenceElevations As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetReferenceElevations()

Return Value

Element ids of all reference elevations in the view.

See Also

View Class


GetReferenceSections Method

[image]

Revit 2024 API
View..::..GetReferenceSections Method
View Class See Also Send Feedback
Returns element ids of all reference sections in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ICollection<ElementId> GetReferenceSections()
Visual Basic
Public Function GetReferenceSections As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetReferenceSections()

Return Value

Element ids of all reference sections in the view.

See Also

View Class


GetSketchyLines Method

[image]

Revit 2024 API
View..::..GetSketchyLines Method
View Class See Also Send Feedback
Returns the current sketchy lines settings for the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public ViewDisplaySketchyLines GetSketchyLines()
Visual Basic
Public Function GetSketchyLines As ViewDisplaySketchyLines
Visual C++
public:
ViewDisplaySketchyLines^ GetSketchyLines()

Return Value

Current sketchy lines settings.

See Also

View Class


GetTemplateParameterIds Method

[image]

Revit 2024 API
View..::..GetTemplateParameterIds Method
View Class See Also Send Feedback
Returns a list of parameter ids that may be controlled when this view is assigned as a template.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public IList<ElementId> GetTemplateParameterIds()
Visual Basic
Public Function GetTemplateParameterIds As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetTemplateParameterIds()

Return Value

The parameter ids that may be controlled.

See Also

View Class


GetTemporaryViewPropertiesId Method

[image]

Revit 2024 API
View..::..GetTemporaryViewPropertiesId Method
View Class See Also Send Feedback
When Temporary View Properties mode is in progress it provides view id that overrode settings for current view. Outside Temporary View Properties mode InvalidElementId will be returned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ElementId GetTemporaryViewPropertiesId()
Visual Basic
Public Function GetTemporaryViewPropertiesId As ElementId
Visual C++
public:
ElementId^ GetTemporaryViewPropertiesId()

Remarks

Returned ElementId might refer to element that was deleted. It will happen when Temporary View Properties mode was applied basing on template that next was deleted.

See Also

View Class


GetTemporaryViewPropertiesName Method

[image]

Revit 2024 API
View..::..GetTemporaryViewPropertiesName Method
View Class See Also Send Feedback
When Temporary View Properties mode is in progress, name of applied template is returned. Outside Temporary View Properties mode, empty string will be returned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public string GetTemporaryViewPropertiesName()
Visual Basic
Public Function GetTemporaryViewPropertiesName As String
Visual C++
public:
String^ GetTemporaryViewPropertiesName()

See Also

View Class


GetWorksetVisibility Method

[image]

Revit 2024 API
View..::..GetWorksetVisibility Method
View Class See Also Send Feedback
Returns the visibility settings of a workset for this particular view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public WorksetVisibility GetWorksetVisibility(
    WorksetId worksetId
)
Visual Basic
Public Function GetWorksetVisibility ( _
    worksetId As WorksetId _
) As WorksetVisibility
Visual C++
public:
WorksetVisibility GetWorksetVisibility(
    WorksetId^ worksetId
)

Parameters

worksetId
Type: Autodesk.Revit.DB..::..WorksetId
Id of the workset.

Return Value

The visibility of a workset for this particular view.

Remarks

The settings does not reflect the fact of whether a workset is currently closed or not.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | There is no workset with this Id in the document associated with this view.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

View Class


HasDetailLevel Method

[image]

Revit 2024 API
View..::..HasDetailLevel Method
View Class See Also Send Feedback
Check if the view has a Detail Level property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool HasDetailLevel()
Visual Basic
Public Function HasDetailLevel As Boolean
Visual C++
public:
bool HasDetailLevel()

Return Value

True if the view has a Detail Level, false otherwise

See Also

View Class


HasDisplayStyle Method

[image]

Revit 2024 API
View..::..HasDisplayStyle Method
View Class See Also Send Feedback
Indicates if view has a DisplayStyle property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool HasDisplayStyle()
Visual Basic
Public Function HasDisplayStyle As Boolean
Visual C++
public:
bool HasDisplayStyle()

Return Value

True if view has a DisplayStyle property

See Also

View Class


HasViewTransforms Method

[image]

Revit 2024 API
View..::..HasViewTransforms Method
View Class See Also Send Feedback
Returns true if the view reports model space to view projection space transforms.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public bool HasViewTransforms()
Visual Basic
Public Function HasViewTransforms As Boolean
Visual C++
public:
bool HasViewTransforms()

Return Value

True if the view returns transforms, false otherwise.

Remarks

Not all views return transforms. For example, schedules and legends do not report transforms.

See Also

View Class


HideCategoriesTemporary Method

[image]

Revit 2024 API
View..::..HideCategoriesTemporary Method
View Class See Also Send Feedback
Set multiple categories to be temporarily hidden in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void HideCategoriesTemporary(
    ICollection<ElementId> elementIds
)
Visual Basic
Public Sub HideCategoriesTemporary ( _
    elementIds As ICollection(Of ElementId) _
)
Visual C++
public:
void HideCategoriesTemporary(
    ICollection<ElementId^>^ elementIds
)

Parameters

elementIds
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
Ids of the categories to be hidden

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Some elements in elementIds do not correspond to a Category.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

View Class


HideCategoryTemporary Method

[image]

Revit 2024 API
View..::..HideCategoryTemporary Method
View Class See Also Send Feedback
Set one category to be temporarily hidden in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void HideCategoryTemporary(
    ElementId elementId
)
Visual Basic
Public Sub HideCategoryTemporary ( _
    elementId As ElementId _
)
Visual C++
public:
void HideCategoryTemporary(
    ElementId^ elementId
)

Parameters

elementId
Type: Autodesk.Revit.DB..::..ElementId
Id of the category to be hidden

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | elementId does not correspond to a Category.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

View Class


HideElements Method

[image]

Revit 2024 API
View..::..HideElements Method
View Class See Also Send Feedback
Sets the elements to be hidden in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void HideElements(
    ICollection<ElementId> elementIdSet
)
Visual Basic
Public Sub HideElements ( _
    elementIdSet As ICollection(Of ElementId) _
)
Visual C++
public:
void HideElements(
    ICollection<ElementId^>^ elementIdSet
)

Parameters

elementIdSet
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
A set of ElementIds to be hidden.

Remarks

This change is permanent until the elements are unhidden. All elements in the set must be currently unhidden and must be allowed to be hidden. An application can check this with IsHidden(View) and CanBeHidden(View).

Some elements cannot be hidden directly. Examples include: group, array, constraint, edit cut profile, face splitter and link to external documents.

Also, elements cannot be hidden in Revit family documents (but they can be hidden temporarily using [M:Autodesk.Revit.DB.View.HideElementsTemporary(System.Collections.Generic.ICollection`1{Autodesk.Revit.DB.ElementId})]).

To hide a group completely, you must also include all members of all groups and nested groups in your input.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the set of elements to be hidden is empty or one of the elements can not be hidden. Also thrown when the set of elements to be hidden includes the view itself.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when document regeneration failed.

See Also

View Class


HideElementsTemporary Method

[image]

Revit 2024 API
View..::..HideElementsTemporary Method
View Class See Also Send Feedback
Set multiple elements to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void HideElementsTemporary(
    ICollection<ElementId> elementIdSet
)
Visual Basic
Public Sub HideElementsTemporary ( _
    elementIdSet As ICollection(Of ElementId) _
)
Visual C++
public:
void HideElementsTemporary(
    ICollection<ElementId^>^ elementIdSet
)

Parameters

elementIdSet
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
Ids of the elements to be temporarily hidden.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

View Class


IsCategoryOverridable Method

[image]

Revit 2024 API
View..::..IsCategoryOverridable Method
View Class See Also Send Feedback
Checks whether the category can have graphic overrides in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsCategoryOverridable(
    ElementId categoryId
)
Visual Basic
Public Function IsCategoryOverridable ( _
    categoryId As ElementId _
) As Boolean
Visual C++
public:
bool IsCategoryOverridable(
    ElementId^ categoryId
)

Parameters

categoryId
Type: Autodesk.Revit.DB..::..ElementId
ElementId of the category.

Return Value

True if category can be overridden, false otherwise.

Remarks

Categories can be allowed to be overridden in some view types and prohibited from being overridden in others. E.g., categories cannot be overridden in ProjectBrowser

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

View Class


IsElementVisibleInTemporaryViewMode Method

[image]

Revit 2024 API
View..::..IsElementVisibleInTemporaryViewMode Method
View Class See Also Send Feedback
Identifies if the input element is visible for the temporary view mode for this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public bool IsElementVisibleInTemporaryViewMode(
    TemporaryViewMode mode,
    ElementId id
)
Visual Basic
Public Function IsElementVisibleInTemporaryViewMode ( _
    mode As TemporaryViewMode, _
    id As ElementId _
) As Boolean
Visual C++
public:
bool IsElementVisibleInTemporaryViewMode(
    TemporaryViewMode mode,
    ElementId^ id
)

Parameters

mode
Type: Autodesk.Revit.DB..::..TemporaryViewMode
The temporary view mode. Only TemporaryHideIsolate and AnalyticalModel modes are supported by this option. Other modes will result in an exception.
id
Type: Autodesk.Revit.DB..::..ElementId
The element id.

Return Value

True if the element is visible, false if the element is hidden in the view mode.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This view mode is not supported for checking element visibility.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

View Class


IsFilterApplied Method

[image]

Revit 2024 API
View..::..IsFilterApplied Method
View Class See Also Send Feedback
Indicates if a filter is applied to the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsFilterApplied(
    ElementId filterElementId
)
Visual Basic
Public Function IsFilterApplied ( _
    filterElementId As ElementId _
) As Boolean
Visual C++
public:
bool IsFilterApplied(
    ElementId^ filterElementId
)

Parameters

filterElementId
Type: Autodesk.Revit.DB..::..ElementId
ElementId of the filter.

Return Value

True if the filter is applied to the view, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | ElementId is not associated with a FilterElement.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The element "this View" does not belong to a project document. -or- The view type does not support Visibility/Graphics Overriddes.

See Also

View Class


IsInTemporaryViewMode Method

[image]

Revit 2024 API
View..::..IsInTemporaryViewMode Method
View Class See Also Send Feedback
Returns true if the view is in a particular temporary view mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public bool IsInTemporaryViewMode(
    TemporaryViewMode mode
)
Visual Basic
Public Function IsInTemporaryViewMode ( _
    mode As TemporaryViewMode _
) As Boolean
Visual C++
public:
bool IsInTemporaryViewMode(
    TemporaryViewMode mode
)

Parameters

mode
Type: Autodesk.Revit.DB..::..TemporaryViewMode
The mode.

Return Value

True if this view is in the temporary view mode indicated, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

View Class


IsolateCategoryTemporary Method

[image]

Revit 2024 API
View..::..IsolateCategoryTemporary Method
View Class See Also Send Feedback
Set one category to be temporarily isolated in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void IsolateCategoryTemporary(
    ElementId elementId
)
Visual Basic
Public Sub IsolateCategoryTemporary ( _
    elementId As ElementId _
)
Visual C++
public:
void IsolateCategoryTemporary(
    ElementId^ elementId
)

Parameters

elementId
Type: Autodesk.Revit.DB..::..ElementId
Id of category to be isolated.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | elementId does not correspond to a Category.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

View Class


IsolateElementTemporary Method

[image]

Revit 2024 API
View..::..IsolateElementTemporary Method
View Class See Also Send Feedback
Set one element to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void IsolateElementTemporary(
    ElementId elementId
)
Visual Basic
Public Sub IsolateElementTemporary ( _
    elementId As ElementId _
)
Visual C++
public:
void IsolateElementTemporary(
    ElementId^ elementId
)

Parameters

elementId
Type: Autodesk.Revit.DB..::..ElementId
Id of element to be isolated.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

View Class


IsTemporaryHideIsolateActive Method

[image]

Revit 2024 API
View..::..IsTemporaryHideIsolateActive Method
View Class See Also Send Feedback
Indicates if the view is temporarily hiding or isolating elements or categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool IsTemporaryHideIsolateActive()
Visual Basic
Public Function IsTemporaryHideIsolateActive As Boolean
Visual C++
public:
bool IsTemporaryHideIsolateActive()

Return Value

True if elements/categories are being temporarily hidden or isolated, false otherwise.

See Also

View Class


IsTemporaryViewPropertiesModeEnabled Method

[image]

Revit 2024 API
View..::..IsTemporaryViewPropertiesModeEnabled Method
View Class See Also Send Feedback
Returns true when Temporary View Properties mode is in progress, false otherwise.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsTemporaryViewPropertiesModeEnabled()
Visual Basic
Public Function IsTemporaryViewPropertiesModeEnabled As Boolean
Visual C++
public:
bool IsTemporaryViewPropertiesModeEnabled()

See Also

View Class


IsValidViewScale Method

[image]

Revit 2024 API
View..::..IsValidViewScale Method
View Class See Also Send Feedback
This validator checks that the view scale is in the allowable range.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static bool IsValidViewScale(
    int viewScale
)
Visual Basic
Public Shared Function IsValidViewScale ( _
    viewScale As Integer _
) As Boolean
Visual C++
public:
static bool IsValidViewScale(
    int viewScale
)

Parameters

viewScale
Type: System..::..Int32
The denominator X in the view scale 1/X.

Return Value

True if the view scale is within the allowable range, false otherwise.

Remarks

The view scale is expressed as 1/X, where X is an integer the range 1 to 24,000.

See Also

View Class


IsValidViewTemplate Method

[image]

Revit 2024 API
View..::..IsValidViewTemplate Method
View Class See Also Send Feedback
Verifies that the view represented by templateId can be set as the controlling view template for this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool IsValidViewTemplate(
    ElementId templateId
)
Visual Basic
Public Function IsValidViewTemplate ( _
    templateId As ElementId _
) As Boolean
Visual C++
public:
bool IsValidViewTemplate(
    ElementId^ templateId
)

Parameters

templateId
Type: Autodesk.Revit.DB..::..ElementId
The id to be validated as a view template for this view.

Return Value

True if the view is valid for us as a view template and compatible with this view, or if it is InvalidElementId, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

View Class


IsViewValidForTemplateCreation Method

[image]

Revit 2024 API
View..::..IsViewValidForTemplateCreation Method
View Class See Also Send Feedback
Verifies that the view is valid for template creation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020

Syntax

C#
public bool IsViewValidForTemplateCreation()
Visual Basic
Public Function IsViewValidForTemplateCreation As Boolean
Visual C++
public:
bool IsViewValidForTemplateCreation()

Return Value

True if the view can be used for view template creation, false otherwise.

See Also

View Class


IsWorksetVisible Method

[image]

Revit 2024 API
View..::..IsWorksetVisible Method
View Class See Also Send Feedback
Indicates whether the workset is visible in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012

Syntax

C#
public bool IsWorksetVisible(
    WorksetId worksetId
)
Visual Basic
Public Function IsWorksetVisible ( _
    worksetId As WorksetId _
) As Boolean
Visual C++
public:
bool IsWorksetVisible(
    WorksetId^ worksetId
)

Parameters

worksetId
Type: Autodesk.Revit.DB..::..WorksetId
Id of the workset.

Return Value

Whether the workset is visible.

Remarks

It will take into account whether the workset is opened or closed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | There is no workset with this Id in the document associated with this view.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

View Class


Print Method

[image] [image]

Revit 2024 API
View..::..Print Method
View Class See Also Send Feedback
Print this view.

Overload List

 | Name | Description
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document.
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document.
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document.
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document.

See Also

View Class
View Members


Print Method

[image]

Revit 2024 API
View..::..Print Method
View Class See Also Send Feedback
Print this view with the default view template and using the print setting of the current active document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Print()
Visual Basic
Public Sub Print
Visual C++
public:
void Print()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the view cannot be printed.

See Also

View Class
Print Overload


Print Method (View)

[image]

Revit 2024 API
View..::..Print Method (View)
View Class See Also Send Feedback
Print this view with the given view template and using the print setting of the current active document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Print(
    View viewTemplate
)
Visual Basic
Public Sub Print ( _
    viewTemplate As View _
)
Visual C++
public:
void Print(
    View^ viewTemplate
)

Parameters

viewTemplate
Type: Autodesk.Revit.DB..::..View
The view template which apply to the view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the view cannot be printed.

See Also

View Class
Print Overload


Print Method (View, Boolean)

[image]

Revit 2024 API
View..::..Print Method (View, Boolean)
View Class See Also Send Feedback
Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Print(
    View viewTemplate,
    bool useCurrentPrintSettings
)
Visual Basic
Public Sub Print ( _
    viewTemplate As View, _
    useCurrentPrintSettings As Boolean _
)
Visual C++
public:
void Print(
    View^ viewTemplate,
    bool useCurrentPrintSettings
)

Parameters

viewTemplate
Type: Autodesk.Revit.DB..::..View
The view template which apply to the view.
useCurrentPrintSettings
Type: System..::..Boolean
If true, print the view with the print setting of the current active document; otherwise with the view's document's print setting.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the view cannot be printed.

See Also

View Class
Print Overload


RemoveCalloutParent Method

[image]

Revit 2024 API
View..::..RemoveCalloutParent Method
View Class See Also Send Feedback
Replaces callout parent ID with InvalidElementId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void RemoveCalloutParent()
Visual Basic
Public Sub RemoveCalloutParent
Visual C++
public:
void RemoveCalloutParent()

Remarks

Nothing is done if the callout has already no parent.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This view is not a callout.

See Also

View Class


RemoveFilter Method

[image]

Revit 2024 API
View..::..RemoveFilter Method
View Class See Also Send Feedback
Removes a filter from the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void RemoveFilter(
    ElementId filterElementId
)
Visual Basic
Public Sub RemoveFilter ( _
    filterElementId As ElementId _
)
Visual C++
public:
void RemoveFilter(
    ElementId^ filterElementId
)

Parameters

filterElementId
Type: Autodesk.Revit.DB..::..ElementId
ElementId of the filter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Filter is not applied to the view. -or- ElementId is not associated with a FilterElement.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The element "this View" does not belong to a project document. -or- The view type does not support Visibility/Graphics Overriddes.

See Also

View Class


RemoveLinkOverrides Method

[image]

Revit 2024 API
View..::..RemoveLinkOverrides Method
View Class Example See Also Send Feedback
Deletes the graphical link overrides in the current view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public void RemoveLinkOverrides(
    ElementId linkId
)
Visual Basic
Public Sub RemoveLinkOverrides ( _
    linkId As ElementId _
)
Visual C++
public:
void RemoveLinkOverrides(
    ElementId^ linkId
)

Parameters

linkId
Type: Autodesk.Revit.DB..::..ElementId
The id of the RevitLinkType or RevitLinkInstance.

Remarks

If the input linkId references RevitLinkType, then the link overrides will be set to default. If the input linkId references RevitLinkInstance, then the link overrides will be removed and the settings of RevitLinkType will be used for this instance.

Examples

CopyC#
public static void RemoveLinkOverridesInView(View view, ElementId linkId)
{
    using (Transaction transaction = new Transaction(view.Document, "Remove link overrides"))
    {
        transaction.Start();
        view.RemoveLinkOverrides(linkId);
        transaction.Commit();
    }
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input id is not a valid RevitLinkInstance or RevitLinkType id.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The view type does not support Visibility/Graphics Overriddes. -or- The view does not support link graphical overrides.

See Also

View Class


RestoreCalloutParent Method

[image]

Revit 2024 API
View..::..RestoreCalloutParent Method
View Class See Also Send Feedback
Restores callout parent ID to the original view ID if that view is still available.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void RestoreCalloutParent()
Visual Basic
Public Sub RestoreCalloutParent
Visual C++
public:
void RestoreCalloutParent()

Remarks

Nothing is done if the callout already has parent or if the original callout parent is deleted or is not parallel to the callout view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This view is not a callout.

See Also

View Class


SetBackground Method

[image]

Revit 2024 API
View..::..SetBackground Method
View Class See Also Send Feedback
Sets the background for the view. Background can only be set for 3d views and for Sections/Elevations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void SetBackground(
    ViewDisplayBackground background
)
Visual Basic
Public Sub SetBackground ( _
    background As ViewDisplayBackground _
)
Visual C++
public:
void SetBackground(
    ViewDisplayBackground^ background
)

Parameters

background
Type: Autodesk.Revit.DB..::..ViewDisplayBackground
Background to set. See 'ViewDisplayBackground' class and its 'create' methods.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The background object is invalid, or view has 'Rendering' style.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This view does not contain display-related properties.

See Also

View Class


SetCategoryHidden Method

[image]

Revit 2024 API
View..::..SetCategoryHidden Method
View Class See Also Send Feedback
Sets if elements of the given category will be visible in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public void SetCategoryHidden(
    ElementId categoryId,
    bool hide
)
Visual Basic
Public Sub SetCategoryHidden ( _
    categoryId As ElementId, _
    hide As Boolean _
)
Visual C++
public:
void SetCategoryHidden(
    ElementId^ categoryId,
    bool hide
)

Parameters

categoryId
Type: Autodesk.Revit.DB..::..ElementId
The ID of the category.
hide
Type: System..::..Boolean
True to make elements of this category invisible, false to make them visible.

Remarks

This affects only if the category is set visible or invisible individually. Other Revit mechanisms may also affect the visibility of elements of this category, including:
  • The category classes settings for model categories, annotation categories, import categories or analytical model categories.
  • View filters.
  • Elements hidden individually in the view.
Thus setting this value may not affect the actual visibility of elements of this category in the view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | categoryId does not correspond to a Category. -or- Category cannot be hidden.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

View Class


SetColorFillSchemeId Method

[image]

Revit 2024 API
View..::..SetColorFillSchemeId Method
View Class See Also Send Feedback
Applies color fill scheme to this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public void SetColorFillSchemeId(
    ElementId categoryId,
    ElementId schemeId
)
Visual Basic
Public Sub SetColorFillSchemeId ( _
    categoryId As ElementId, _
    schemeId As ElementId _
)
Visual C++
public:
void SetColorFillSchemeId(
    ElementId^ categoryId,
    ElementId^ schemeId
)

Parameters

categoryId
Type: Autodesk.Revit.DB..::..ElementId
The id of category to apply a color fill scheme element.
schemeId
Type: Autodesk.Revit.DB..::..ElementId
The id of the color fill scheme element.

Remarks

There could be at most three [!:Autodesk::Revit::DB::ColorFillScheme] applied in a view: one for spatial elements (rooms, zones, spaces and areas), one for pipes and one for ducts.

Notes:

  • There's at most one scheme activated for all spatial categories.
  • For area plan view, the activated spatial scheme category must be OST_Areas and has the same [!:Autodesk::Revit::DB::AreaScheme] with this view if it is not used as a template.
  • To clear one of the above three schemes, use InvalidElementId as the parameter of this function.
  • To get list of element categories supportted to be colored in this view, use SupportedColorFillCategoryIds()()()().
  • To check whether an specified ElementId could be applied to this view, use CanApplyColorFillScheme(ElementId, ElementId).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The schemeId can not be applied as the scheme id of categoryId in this view.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

View Class


SetDepthCueing Method

[image]

Revit 2024 API
View..::..SetDepthCueing Method
View Class See Also Send Feedback
Sets the depth cueing settings for the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public void SetDepthCueing(
    ViewDisplayDepthCueing depthCueing
)
Visual Basic
Public Sub SetDepthCueing ( _
    depthCueing As ViewDisplayDepthCueing _
)
Visual C++
public:
void SetDepthCueing(
    ViewDisplayDepthCueing^ depthCueing
)

Parameters

depthCueing
Type: Autodesk.Revit.DB..::..ViewDisplayDepthCueing
Depth cueing settings to set.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This view does not contain display-related properties. -or- This view cannot use Depth Cueing

See Also

View Class


SetElementOverrides Method

[image]

Revit 2024 API
View..::..SetElementOverrides Method
View Class See Also Send Feedback
Sets graphic overrides for an element in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void SetElementOverrides(
    ElementId elementId,
    OverrideGraphicSettings overrideGraphicSettings
)
Visual Basic
Public Sub SetElementOverrides ( _
    elementId As ElementId, _
    overrideGraphicSettings As OverrideGraphicSettings _
)
Visual C++
public:
void SetElementOverrides(
    ElementId^ elementId,
    OverrideGraphicSettings^ overrideGraphicSettings
)

Parameters

elementId
Type: Autodesk.Revit.DB..::..ElementId
Element to override.
overrideGraphicSettings
Type: Autodesk.Revit.DB..::..OverrideGraphicSettings
An object representing all graphic overrides of the element in view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | elementId is not a valid Element identifier. -or- Fill pattern must be a drafting pattern. -or- Fill pattern Id must be invalidElementId or point to a LinePattern element.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The element "this View" does not belong to a project document. -or- The view type does not support Visibility/Graphics Overriddes.

See Also

View Class


SetFilterOverrides Method

[image]

Revit 2024 API
View..::..SetFilterOverrides Method
View Class Example See Also Send Feedback
Sets the overrides associated with a filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void SetFilterOverrides(
    ElementId filterElementId,
    OverrideGraphicSettings overrideGraphicSettings
)
Visual Basic
Public Sub SetFilterOverrides ( _
    filterElementId As ElementId, _
    overrideGraphicSettings As OverrideGraphicSettings _
)
Visual C++
public:
void SetFilterOverrides(
    ElementId^ filterElementId,
    OverrideGraphicSettings^ overrideGraphicSettings
)

Parameters

filterElementId
Type: Autodesk.Revit.DB..::..ElementId
ElementId of the filter.
overrideGraphicSettings
Type: Autodesk.Revit.DB..::..OverrideGraphicSettings
The overrides to apply to the filter.

Remarks

If the filter is not currently applied to the view, this will add the filter with the assigned overrides.

Examples

CopyC#
public static void ModifyExistingFilter(Document doc, View view)
{
    // Find any filter with overrides setting cut color to Red
    Dictionary<ElementId, OverrideGraphicSettings> filterIdsToChange = new Dictionary<ElementId, OverrideGraphicSettings>();

    foreach (ElementId filterId in view.GetFilters())
    {
        OverrideGraphicSettings overrideSettings = view.GetFilterOverrides(filterId);

        Color lineColor = overrideSettings.CutLineColor;

        if (lineColor == Color.InvalidColorValue)
            continue;

        // Save overrides setting the cut color to green
        if (lineColor.Red == 0xFF && lineColor.Green == 0x00 && lineColor.Blue == 0x00)
        {
            overrideSettings.SetCutLineColor(new Color(0x00, 0xFF, 0x00));
            filterIdsToChange[filterId] = overrideSettings;
        }
    }

    // Make the change to all found filters
    using (Transaction t = new Transaction(doc, "Change override filters"))
    {
        t.Start();

        foreach (ElementId filterId in filterIdsToChange.Keys)
        {
            view.SetFilterOverrides(filterId, filterIdsToChange[filterId]);
        }
        t.Commit();
    }
}
CopyVB.NET
Public Shared Sub ModifyExistingFilter(doc As Document, view As View)
    ' Find any filter with overrides setting cut color to Red
    Dim filterIdsToChange As New Dictionary(Of ElementId, OverrideGraphicSettings)()

    For Each filterId As ElementId In view.GetFilters()
        Dim overrideSettings As OverrideGraphicSettings = view.GetFilterOverrides(filterId)

        Dim lineColor As Color = overrideSettings.CutLineColor

        If lineColor.IsValid = False Then
            Continue For
        End If

        ' Save overrides setting the cut color to green
        If lineColor.Red = &Hff AndAlso lineColor.Green = &H0 AndAlso lineColor.Blue = &H0 Then
            overrideSettings.SetCutLineColor(New Color(&H0, &Hff, &H0))
            filterIdsToChange(filterId) = overrideSettings
        End If
    Next

    ' Make the change to all found filters
    Using t As New Transaction(doc, "Change override filters")
        t.Start()

        For Each filterId As ElementId In filterIdsToChange.Keys
            view.SetFilterOverrides(filterId, filterIdsToChange(filterId))
        Next
        t.Commit()
    End Using
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | ElementId is not associated with a FilterElement. -or- Fill pattern must be a drafting pattern. -or- Fill pattern Id must be invalidElementId or point to a LinePattern element.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The element "this View" does not belong to a project document. -or- The view type does not support Visibility/Graphics Overriddes.

See Also

View Class


SetIsFilterEnabled Method

[image]

Revit 2024 API
View..::..SetIsFilterEnabled Method
View Class See Also Send Feedback
Sets the filter enabled flag.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public void SetIsFilterEnabled(
    ElementId filterElementId,
    bool enable
)
Visual Basic
Public Sub SetIsFilterEnabled ( _
    filterElementId As ElementId, _
    enable As Boolean _
)
Visual C++
public:
void SetIsFilterEnabled(
    ElementId^ filterElementId,
    bool enable
)

Parameters

filterElementId
Type: Autodesk.Revit.DB..::..ElementId
The ElementId of the filter.
enable
Type: System..::..Boolean
True if the specified filter should be enabled in this view, false otherwise.

Remarks

Several filters can be applied to a view in a sertain order. This enable/disable flag allows one to quickly turn on/off the action of a particular filter in this view (without removing the filter from the set of applied filters and loosing the corresponding overrides). By default, all the filters applied to a view are enabled.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Filter is not applied to the view. -or- ElementId is not associated with a FilterElement.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The element "this View" does not belong to a project document. -or- The view type does not support Visibility/Graphics Overriddes.

See Also

View Class


SetLinkOverrides Method

[image]

Revit 2024 API
View..::..SetLinkOverrides Method
View Class Example See Also Send Feedback
Sets the graphic overrides of a RevitLinkType or RevitLinkInstance in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public void SetLinkOverrides(
    ElementId linkId,
    RevitLinkGraphicsSettings linkDisplaySettings
)
Visual Basic
Public Sub SetLinkOverrides ( _
    linkId As ElementId, _
    linkDisplaySettings As RevitLinkGraphicsSettings _
)
Visual C++
public:
void SetLinkOverrides(
    ElementId^ linkId,
    RevitLinkGraphicsSettings^ linkDisplaySettings
)

Parameters

linkId
Type: Autodesk.Revit.DB..::..ElementId
The id of the RevitLinkType or RevitLinkInstance.
linkDisplaySettings
Type: Autodesk.Revit.DB..::..RevitLinkGraphicsSettings
Settings representing all link graphic overrides in the view.

Examples

CopyC#
public static void UpdateOverridesInView(View view, ElementId linkElementId, ElementId linkedViewId)
{
    RevitLinkGraphicsSettings settings = new RevitLinkGraphicsSettings();
    settings.LinkVisibilityType = LinkVisibility.ByLinkView;
    settings.LinkedViewId = linkedViewId;

    using(Transaction transaction = new Transaction(view.Document, "Set link graphical overrides"))
    {
        transaction.Start();
        view.SetLinkOverrides(linkElementId, settings);
        transaction.Commit();
    }
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input id is not a valid RevitLinkInstance or RevitLinkType id. -or- Setting link overrides to type LinkVisibility.Custom is not supported via the API. -or- The LinkedViewId of linkDisplaySettings has incorrect value for the specified LinkVisibilityType.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The view type does not support Visibility/Graphics Overriddes. -or- The view does not support link graphical overrides.

See Also

View Class


SetNonControlledTemplateParameterIds Method

[image]

Revit 2024 API
View..::..SetNonControlledTemplateParameterIds Method
View Class See Also Send Feedback
Sets the parameters that will not be included when this view is used as a template.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void SetNonControlledTemplateParameterIds(
    ICollection<ElementId> newSet
)
Visual Basic
Public Sub SetNonControlledTemplateParameterIds ( _
    newSet As ICollection(Of ElementId) _
)
Visual C++
public:
void SetNonControlledTemplateParameterIds(
    ICollection<ElementId^>^ newSet
)

Parameters

newSet
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
The parameter ids that should not be marked to be included.

Remarks

This should be a subset of the parameters returned by GetTemplateParameterIds()()()() (other parameters will be ignored).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

View Class


SetSketchyLines Method

[image]

Revit 2024 API
View..::..SetSketchyLines Method
View Class See Also Send Feedback
Sets the sketchy lines settings for the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public void SetSketchyLines(
    ViewDisplaySketchyLines sketchyLines
)
Visual Basic
Public Sub SetSketchyLines ( _
    sketchyLines As ViewDisplaySketchyLines _
)
Visual C++
public:
void SetSketchyLines(
    ViewDisplaySketchyLines^ sketchyLines
)

Parameters

sketchyLines
Type: Autodesk.Revit.DB..::..ViewDisplaySketchyLines
Sketchy Lines settings to set.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This view does not contain display-related properties.

See Also

View Class


SetViewDisplayModel Method

[image]

Revit 2024 API
View..::..SetViewDisplayModel Method
View Class See Also Send Feedback
Sets the view display model settings for the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public void SetViewDisplayModel(
    ViewDisplayModel viewDisplayModel
)
Visual Basic
Public Sub SetViewDisplayModel ( _
    viewDisplayModel As ViewDisplayModel _
)
Visual C++
public:
void SetViewDisplayModel(
    ViewDisplayModel^ viewDisplayModel
)

Parameters

viewDisplayModel
Type: Autodesk.Revit.DB..::..ViewDisplayModel
View display model settings to set.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The silhouette line style id is not a valid line style to apply to the view.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This view does not contain display-related properties.

See Also

View Class


SetWorksharingDisplayMode Method

[image]

Revit 2024 API
View..::..SetWorksharingDisplayMode Method
View Class Example See Also Send Feedback
Sets the worksharing display mode for this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetWorksharingDisplayMode(
    WorksharingDisplayMode displayMode
)
Visual Basic
Public Sub SetWorksharingDisplayMode ( _
    displayMode As WorksharingDisplayMode _
)
Visual C++
public:
void SetWorksharingDisplayMode(
    WorksharingDisplayMode displayMode
)

Parameters

displayMode
Type: Autodesk.Revit.DB..::..WorksharingDisplayMode
The desired display mode. "Off" will turn off all worksharing display modes.

Remarks

Turning on a worksharing display mode will disable other temporary view modes such as reveal hidden elements and temporary hide/isolate.

Examples

CopyC#
public Result Execute(ExternalCommandData commandData, ref string message, ElementSet elements)
{
    View activeView = commandData.View;
    Document doc = activeView.Document;

    // Prepare settings
    Color red = new Color(0xFF, 0x00, 0x00);
    WorksharingDisplayGraphicSettings settingsToApply = new WorksharingDisplayGraphicSettings(true, red);

    // Toggle mode based on the current mode
    using (Transaction t = new Transaction(doc, "Toggle display mode"))
    {
        t.Start();

        WorksharingDisplaySettings settings = WorksharingDisplaySettings.GetOrCreateWorksharingDisplaySettings(doc);

        switch (activeView.GetWorksharingDisplayMode())
        {
            case WorksharingDisplayMode.Off:
                activeView.SetWorksharingDisplayMode(WorksharingDisplayMode.CheckoutStatus);
                settings.SetGraphicOverrides(CheckoutStatus.OwnedByOtherUser, settingsToApply);
                break;
            case WorksharingDisplayMode.CheckoutStatus:
                activeView.SetWorksharingDisplayMode(WorksharingDisplayMode.ModelUpdates);
                settings.SetGraphicOverrides(ModelUpdatesStatus.UpdatedInCentral, settingsToApply);
                break;
            case WorksharingDisplayMode.ModelUpdates:
                activeView.SetWorksharingDisplayMode(WorksharingDisplayMode.Owners);
                settings.SetGraphicOverrides("Target user", settingsToApply);
                break;
            case WorksharingDisplayMode.Owners:
                activeView.SetWorksharingDisplayMode(WorksharingDisplayMode.Worksets);
                settings.SetGraphicOverrides(doc.GetWorksetTable().GetActiveWorksetId(), settingsToApply);
                break;
            case WorksharingDisplayMode.Worksets:
                activeView.SetWorksharingDisplayMode(WorksharingDisplayMode.Off);
                break;
        }

        t.Commit();
    }

    return Result.Succeeded;
}
CopyVB.NET
Public Function Execute(commandData As ExternalCommandData, ByRef message As String, elements As ElementSet) As Result Implements IExternalCommand.Execute
    Dim activeView As View = commandData.View
    Dim doc As Document = activeView.Document

    ' Prepare settings
    Dim red As New Color(&HFF, &H0, &H0)
    Dim settingsToApply As New WorksharingDisplayGraphicSettings(True, red)

    ' Toggle mode based on the current mode
    Using t As New Transaction(doc, "Toggle display mode")
        t.Start()

        Dim settings As WorksharingDisplaySettings = WorksharingDisplaySettings.GetOrCreateWorksharingDisplaySettings(doc)

        Select Case activeView.GetWorksharingDisplayMode()
            Case WorksharingDisplayMode.Off
                activeView.SetWorksharingDisplayMode(WorksharingDisplayMode.CheckoutStatus)
                settings.SetGraphicOverrides(CheckoutStatus.OwnedByOtherUser, settingsToApply)
                Exit Select
            Case WorksharingDisplayMode.CheckoutStatus
                activeView.SetWorksharingDisplayMode(WorksharingDisplayMode.ModelUpdates)
                settings.SetGraphicOverrides(ModelUpdatesStatus.UpdatedInCentral, settingsToApply)
                Exit Select
            Case WorksharingDisplayMode.ModelUpdates
                activeView.SetWorksharingDisplayMode(WorksharingDisplayMode.Owners)
                settings.SetGraphicOverrides("Target user", settingsToApply)
                Exit Select
            Case WorksharingDisplayMode.Owners
                activeView.SetWorksharingDisplayMode(WorksharingDisplayMode.Worksets)
                settings.SetGraphicOverrides(doc.GetWorksetTable().GetActiveWorksetId(), settingsToApply)
                Exit Select
            Case WorksharingDisplayMode.Worksets
                activeView.SetWorksharingDisplayMode(WorksharingDisplayMode.Off)
                Exit Select
        End Select

        t.Commit()
    End Using

    Return Result.Succeeded
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This View does not support the requested worksharing display mode.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

View Class


ShowActiveWorkPlane Method

[image]

Revit 2024 API
View..::..ShowActiveWorkPlane Method
View Class See Also Send Feedback
Show the active work plane of the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public void ShowActiveWorkPlane()
Visual Basic
Public Sub ShowActiveWorkPlane
Visual C++
public:
void ShowActiveWorkPlane()

Remarks

If this method is invoked while the current work plane is hidden, only the outline of the updated work plane will be shown immediately. The updated sketch plane will be shown fully after the current transaction is committed. Therefore it is recommended the Add-On commits the transaction before performing UI operations (for example, PickPoint).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when there is no active sketch plane, or when an error occurs during setting the sketch plane visibility.

See Also

View Class


SupportedColorFillCategoryIds Method

[image]

Revit 2024 API
View..::..SupportedColorFillCategoryIds Method
View Class See Also Send Feedback
Returns collection of all category ids that correspond to elements that can potentially be colored in this view according to a color fill scheme. The set may be different depending on the view type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public ICollection<ElementId> SupportedColorFillCategoryIds()
Visual Basic
Public Function SupportedColorFillCategoryIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ SupportedColorFillCategoryIds()

Remarks

All of the possible categories are OST_Rooms, OST_HVAC_Zones, OST_MEPSpaces, OST_Areas, OST_DuctCurves and OST_PipeCurves.

See Also

View Class


SupportsRevealConstraints Method

[image]

Revit 2024 API
View..::..SupportsRevealConstraints Method
View Class See Also Send Feedback
Checks that the view can have the Reveal Constraints mode activated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool SupportsRevealConstraints()
Visual Basic
Public Function SupportsRevealConstraints As Boolean
Visual C++
public:
bool SupportsRevealConstraints()

Return Value

True if the view has a view type that allows Reveal Constraints mode to be activated.

Remarks

Reveal Constraints mode can only be activated for the following viewtypes:
  • 3D Views
  • Area Plans
  • Ceiling Plans
  • Detail Views
  • Drafting Views
  • Elevations
  • Floor Plans
  • Sections
  • Structural Plans

See Also

View Class


SupportsWorksharingDisplayMode Method

[image]

Revit 2024 API
View..::..SupportsWorksharingDisplayMode Method
View Class See Also Send Feedback
Checks whether this view supports the given worksharing display mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool SupportsWorksharingDisplayMode(
    WorksharingDisplayMode mode
)
Visual Basic
Public Function SupportsWorksharingDisplayMode ( _
    mode As WorksharingDisplayMode _
) As Boolean
Visual C++
public:
bool SupportsWorksharingDisplayMode(
    WorksharingDisplayMode mode
)

Parameters

mode
Type: Autodesk.Revit.DB..::..WorksharingDisplayMode
The mode of interest.

Return Value

Returns True if this view is a graphical view in a workshared document or if the desired mode is Off. Returns False if this view is a non-graphical view (such as a schedule or the project browser) or if this view is not in a workshared document.

Remarks

For convenience, the "Off" mode is always supported. Other display modes are supported by graphical views in workshared documents.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

View Class


View Properties

[image] [image]

Revit 2024 API
View Properties
View Class See Also Send Feedback

The View type exposes the following members.

Properties

 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view.
Public property | AreAnalyticalModelCategoriesHidden | Indicates if analytical model categories are currently hidden in the view.
Public property | AreAnnotationCategoriesHidden | Indicates if annotation categories are currently hidden in the view.
Public property | AreCoordinationModelHandlesHidden | Indicates if Coordination Model handles are currently hidden in the view.
Public property | AreImportCategoriesHidden | Indicates if import categories are currently hidden in the view.
Public property | AreModelCategoriesHidden | Indicates if model categories are currently hidden in the view.
Public property | ArePointCloudsHidden | Indicates if point clouds are currently hidden in the view.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBePrinted | Test whether the view can be printed.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CropBox | The Crop Box applied to the view, or an outline encompassing the crop region applied to the view.
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view.
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DetailLevel | The detail level of this view.
Public property | Discipline | The Discipline of the view.
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | GenLevel | The level for the view.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsAssemblyView | Indicates if the view is assembly view.
Public property | IsCallout | Indicates if the view is a callout view.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTemplate | Test whether the view is a view template.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Origin | Returns the origin of the screen.
Public property | Outline | The bounds of the view in paper space (in feet).
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PartsVisibility | The visibility setting for parts in this view.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RevealConstraintsMode | Indicates whether the Reveal Constraints mode is activated in the view.
Public property | RightDirection | The direction towards the right side of the screen.
Public property | Scale | The scale of the view.
Public property | ShadowIntensity | The intesity of cast shadows - 0 = no shadows, 100 = black.
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation.
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering.
Public property | SunlightIntensity | The intensity of the simulated (directional) sunlight. 0 = no directional light; maximum value is 100.
Public property | TemporaryViewModes | Data of temporary view modes associated with this view.
Public property | Title | The view title. This consists of the view name plus other modifiers, such as the view type, sheet number, area scheme, and/or assembly type, depending on the specifics of the view.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpDirection | The direction towards the top of the screen.
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewDirection | The direction towards the viewer.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | ViewTemplateId | The id of the template view that controls this view's parameters.
Public property | ViewType | The type of the view.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

View Class


AnalysisDisplayStyleId Property

[image]

Revit 2024 API
View..::..AnalysisDisplayStyleId Property
View Class See Also Send Feedback
Element id of Analysis Display Style associated with the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public ElementId AnalysisDisplayStyleId { get; set; }
Visual Basic
Public Property AnalysisDisplayStyleId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ AnalysisDisplayStyleId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: Cannot set the AnalysisDisplayStyleId for the specified view.

See Also

View Class


AreAnalyticalModelCategoriesHidden Property

[image]

Revit 2024 API
View..::..AreAnalyticalModelCategoriesHidden Property
View Class See Also Send Feedback
Indicates if analytical model categories are currently hidden in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool AreAnalyticalModelCategoriesHidden { get; set; }
Visual Basic
Public Property AreAnalyticalModelCategoriesHidden As Boolean
    Get
    Set
Visual C++
public:
property bool AreAnalyticalModelCategoriesHidden {
    bool get ();
    void set (bool value);
}

Field Value

True if analytical model categories are currently hidden in the view, false otherwise.

See Also

View Class


AreAnnotationCategoriesHidden Property

[image]

Revit 2024 API
View..::..AreAnnotationCategoriesHidden Property
View Class See Also Send Feedback
Indicates if annotation categories are currently hidden in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool AreAnnotationCategoriesHidden { get; set; }
Visual Basic
Public Property AreAnnotationCategoriesHidden As Boolean
    Get
    Set
Visual C++
public:
property bool AreAnnotationCategoriesHidden {
    bool get ();
    void set (bool value);
}

Field Value

True if annotation categories are currently hidden in the view, false otherwise.

See Also

View Class


AreCoordinationModelHandlesHidden Property

[image]

Revit 2024 API
View..::..AreCoordinationModelHandlesHidden Property
View Class See Also Send Feedback
Indicates if Coordination Model handles are currently hidden in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018

Syntax

C#
public bool AreCoordinationModelHandlesHidden { get; set; }
Visual Basic
Public Property AreCoordinationModelHandlesHidden As Boolean
    Get
    Set
Visual C++
public:
property bool AreCoordinationModelHandlesHidden {
    bool get ();
    void set (bool value);
}

Field Value

True if Coordination Model handles are currently hidden in the view, false otherwise.

See Also

View Class


AreImportCategoriesHidden Property

[image]

Revit 2024 API
View..::..AreImportCategoriesHidden Property
View Class See Also Send Feedback
Indicates if import categories are currently hidden in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool AreImportCategoriesHidden { get; set; }
Visual Basic
Public Property AreImportCategoriesHidden As Boolean
    Get
    Set
Visual C++
public:
property bool AreImportCategoriesHidden {
    bool get ();
    void set (bool value);
}

Field Value

True if import categories are currently hidden in the view, false otherwise.

See Also

View Class


AreModelCategoriesHidden Property

[image]

Revit 2024 API
View..::..AreModelCategoriesHidden Property
View Class See Also Send Feedback
Indicates if model categories are currently hidden in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool AreModelCategoriesHidden { get; set; }
Visual Basic
Public Property AreModelCategoriesHidden As Boolean
    Get
    Set
Visual C++
public:
property bool AreModelCategoriesHidden {
    bool get ();
    void set (bool value);
}

Field Value

True if model categories are currently hidden in the view, false otherwise.

See Also

View Class


ArePointCloudsHidden Property

[image]

Revit 2024 API
View..::..ArePointCloudsHidden Property
View Class See Also Send Feedback
Indicates if point clouds are currently hidden in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool ArePointCloudsHidden { get; set; }
Visual Basic
Public Property ArePointCloudsHidden As Boolean
    Get
    Set
Visual C++
public:
property bool ArePointCloudsHidden {
    bool get ();
    void set (bool value);
}

Field Value

True if point clouds are currently hidden in the view, false otherwise.

See Also

View Class


AssociatedAssemblyInstanceId Property

[image]

Revit 2024 API
View..::..AssociatedAssemblyInstanceId Property
View Class See Also Send Feedback
The Id of the assembly instance that owns the assembly view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElementId AssociatedAssemblyInstanceId { get; }
Visual Basic
Public ReadOnly Property AssociatedAssemblyInstanceId As ElementId
    Get
Visual C++
public:
property ElementId^ AssociatedAssemblyInstanceId {
    ElementId^ get ();
}

See Also

View Class


CanBePrinted Property

[image]

Revit 2024 API
View..::..CanBePrinted Property
View Class See Also Send Feedback
Test whether the view can be printed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool CanBePrinted { get; }
Visual Basic
Public ReadOnly Property CanBePrinted As Boolean
    Get
Visual C++
public:
property bool CanBePrinted {
    bool get ();
}

See Also

View Class


CropBoxActive Property

[image]

Revit 2024 API
View..::..CropBoxActive Property
View Class See Also Send Feedback
Whether or not the Crop Box/Region is active for the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool CropBoxActive { get; set; }
Visual Basic
Public Property CropBoxActive As Boolean
    Get
    Set
Visual C++
public:
property bool CropBoxActive {
    bool get ();
    void set (bool value);
}

Remarks

Identifies whether the crop region modifies the graphical appearance of elements in the view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | Thrown when getting this property, if the view is a template and cannot have a crop box applied.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when setting this property, if the view is a template and cannot have a crop box applied.

See Also

View Class


CropBoxVisible Property

[image]

Revit 2024 API
View..::..CropBoxVisible Property
View Class See Also Send Feedback
Whether or not the Crop Box/Region is visible for the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool CropBoxVisible { get; set; }
Visual Basic
Public Property CropBoxVisible As Boolean
    Get
    Set
Visual C++
public:
property bool CropBoxVisible {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | Thrown when getting this property, if the view is a template and cannot have a crop box applied.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when setting this property, if the view is a template and cannot have a crop box applied.

See Also

View Class


DetailLevel Property

[image]

Revit 2024 API
View..::..DetailLevel Property
View Class See Also Send Feedback
The detail level of this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ViewDetailLevel DetailLevel { get; set; }
Visual Basic
Public Property DetailLevel As ViewDetailLevel
    Get
    Set
Visual C++
public:
property ViewDetailLevel DetailLevel {
    ViewDetailLevel get ();
    void set (ViewDetailLevel value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: Cannot set ViewDetailLevel to Unassigned
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: View does not have a Detail Level property -or- When setting this property: Detail Level cannot be modified.

See Also

View Class


Discipline Property

[image]

Revit 2024 API
View..::..Discipline Property
View Class See Also Send Feedback
The Discipline of the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ViewDiscipline Discipline { get; set; }
Visual Basic
Public Property Discipline As ViewDiscipline
    Get
    Set
Visual C++
public:
property ViewDiscipline Discipline {
    ViewDiscipline get ();
    void set (ViewDiscipline value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | View must have a Discipline property -or- When setting this property: View Discipline must be modifiable.

See Also

View Class


GenLevel Property

[image]

Revit 2024 API
View..::..GenLevel Property
View Class See Also Send Feedback
The level for the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Level GenLevel { get; }
Visual Basic
Public ReadOnly Property GenLevel As Level
    Get
Visual C++
public:
property Level^ GenLevel {
    Level^ get ();
}

Remarks

This will obtain the level for views related to levels, such as Plan Views. If this View is not generated by a level, this property is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

View Class


IsAssemblyView Property

[image]

Revit 2024 API
View..::..IsAssemblyView Property
View Class See Also Send Feedback
Indicates if the view is assembly view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool IsAssemblyView { get; }
Visual Basic
Public ReadOnly Property IsAssemblyView As Boolean
    Get
Visual C++
public:
property bool IsAssemblyView {
    bool get ();
}

See Also

View Class


IsCallout Property

[image]

Revit 2024 API
View..::..IsCallout Property
View Class See Also Send Feedback
Indicates if the view is a callout view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public bool IsCallout { get; }
Visual Basic
Public ReadOnly Property IsCallout As Boolean
    Get
Visual C++
public:
property bool IsCallout {
    bool get ();
}

Remarks

Reference callouts are not treated as callout views. The view was created as a callout in its parent view but it may show as a section in orthogonal views.

See Also

View Class


IsTemplate Property

[image]

Revit 2024 API
View..::..IsTemplate Property
View Class See Also Send Feedback
Test whether the view is a view template.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool IsTemplate { get; }
Visual Basic
Public ReadOnly Property IsTemplate As Boolean
    Get
Visual C++
public:
property bool IsTemplate {
    bool get ();
}

See Also

View Class


Outline Property

[image]

Revit 2024 API
View..::..Outline Property
View Class See Also Send Feedback
The bounds of the view in paper space (in feet).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public BoundingBoxUV Outline { get; }
Visual Basic
Public ReadOnly Property Outline As BoundingBoxUV
    Get
Visual C++
public:
property BoundingBoxUV^ Outline {
    BoundingBoxUV^ get ();
}

Remarks

Returns all zeros for empty views.

See Also

View Class


RevealConstraintsMode Property

[image]

Revit 2024 API
View..::..RevealConstraintsMode Property
View Class See Also Send Feedback
Indicates whether the Reveal Constraints mode is activated in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool RevealConstraintsMode { get; set; }
Visual Basic
Public Property RevealConstraintsMode As Boolean
    Get
    Set
Visual C++
public:
property bool RevealConstraintsMode {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: View has a view type that does not allow Reveal Constraints mode to be activated.

See Also

View Class


RightDirection Property

[image]

Revit 2024 API
View..::..RightDirection Property
View Class See Also Send Feedback
The direction towards the right side of the screen.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ RightDirection { get; }
Visual Basic
Public ReadOnly Property RightDirection As XYZ
    Get
Visual C++
public:
property XYZ^ RightDirection {
    XYZ^ get ();
}

See Also

View Class


Scale Property

[image]

Revit 2024 API
View..::..Scale Property
View Class See Also Send Feedback
The scale of the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public int Scale { get; set; }
Visual Basic
Public Property Scale As Integer
    Get
    Set
Visual C++
public:
property int Scale {
    int get ();
    void set (int value);
}

Remarks

The scale is the ratio of true model size to paper size. This property is meaningless for perspective views. When setting the scale if the scale corresponds to a predefined scale, the predefined item will be applied. Otherwise, a custom scale will be applied.

See Also

View Class


SketchPlane Property

[image]

Revit 2024 API
View..::..SketchPlane Property
View Class See Also Send Feedback
The sketch plane assigned to the view for model curve creation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public SketchPlane SketchPlane { get; set; }
Visual Basic
Public Property SketchPlane As SketchPlane
    Get
    Set
Visual C++
public:
property SketchPlane^ SketchPlane {
    SketchPlane^ get ();
    void set (SketchPlane^ value);
}

Field Value

The sketch plane, or nullNothingnullptra null reference (Nothing in Visual Basic) for views which don't allow sketching (such as schedules) or for views that allow model curve creation but have no current sketch plane assigned.

Remarks

If this property is set in when the current work plane is visible, the updated work plane will not be shown until the current transaction is committed. Therefore it is recommended the Add-On commits the transaction before performing UI operations (for example, PickPoint).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when setting the property to nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when setting the property to a sketch plane that cannot be used to create model elements, or when the input sketch plane is orthogonal to the view orientation.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when setting the property to a view that does not permit model curve creation, or when other errors occur.

See Also

View Class


SunAndShadowSettings Property

[image]

Revit 2024 API
View..::..SunAndShadowSettings Property
View Class See Also Send Feedback
The sun and shadow settings assigned to the view for shadow calculation and rendering.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public SunAndShadowSettings SunAndShadowSettings { get; }
Visual Basic
Public ReadOnly Property SunAndShadowSettings As SunAndShadowSettings
    Get
Visual C++
public:
property SunAndShadowSettings^ SunAndShadowSettings {
    SunAndShadowSettings^ get ();
}

Field Value

The sun and shadow settings, or null for views which don't allow this (such as schedules).

See Also

View Class


TemporaryViewModes Property

[image]

Revit 2024 API
View..::..TemporaryViewModes Property
View Class See Also Send Feedback
Data of temporary view modes associated with this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Update

Syntax

C#
public TemporaryViewModes TemporaryViewModes { get; }
Visual Basic
Public ReadOnly Property TemporaryViewModes As TemporaryViewModes
    Get
Visual C++
public:
property TemporaryViewModes^ TemporaryViewModes {
    TemporaryViewModes^ get ();
}

Remarks

Temporary view modes are available in graphic views only.

See Also

View Class


Title Property

[image]

Revit 2024 API
View..::..Title Property
View Class See Also Send Feedback
The view title. This consists of the view name plus other modifiers, such as the view type, sheet number, area scheme, and/or assembly type, depending on the specifics of the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public string Title { get; }
Visual Basic
Public ReadOnly Property Title As String
    Get
Visual C++
public:
property String^ Title {
    String^ get ();
}

See Also

View Class


ViewDirection Property

[image]

Revit 2024 API
View..::..ViewDirection Property
View Class See Also Send Feedback
The direction towards the viewer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public XYZ ViewDirection { get; }
Visual Basic
Public ReadOnly Property ViewDirection As XYZ
    Get
Visual C++
public:
property XYZ^ ViewDirection {
    XYZ^ get ();
}

Remarks

In orthographic views, all objects are projected onto the screen along this direction. In perspective views, the view target point is projected along this direction, but other points are projected towards the eye along different vectors.

See Also

View Class


ViewTemplateId Property

[image]

Revit 2024 API
View..::..ViewTemplateId Property
View Class See Also Send Feedback
The id of the template view that controls this view's parameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ElementId ViewTemplateId { get; set; }
Visual Basic
Public Property ViewTemplateId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ ViewTemplateId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Field Value

The id of the template view that controls this view's parameters. InvalidElementId if there is no template set for this view.

Remarks

Parameters controlled by the template cannot be changed directly in this view. Any change to controlled parameters in the template will cause change of the corresponding parameters in this view. Use GetTemplateParameterIds()()()() on the template view to get a list of all template parameters. Use GetNonControlledTemplateParameterIds()()()() on the template view to get parameters that are not controlled by the template.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: val is not valid as a view template id for this view.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

View Class


ViewType Property

[image]

Revit 2024 API
View..::..ViewType Property
View Class Example See Also Send Feedback
The type of the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ViewType ViewType { get; }
Visual Basic
Public ReadOnly Property ViewType As ViewType
    Get
Visual C++
public:
property ViewType ViewType {
    ViewType get ();
}

Examples

CopyC#
public void GetViewType(Autodesk.Revit.DB.View view)
{
    // Get the view type of the given view, and format the prompt string
    String prompt = "The view is ";

    switch (view.ViewType)
    {
        case ViewType.AreaPlan:
            prompt += "an area view.";
            break;
        case ViewType.CeilingPlan:
            prompt += "a reflected ceiling plan view.";
            break;
        case ViewType.ColumnSchedule:
            prompt += "a column schedule view.";
            break;
        case ViewType.CostReport:
            prompt += "a cost report view.";
            break;
        case ViewType.Detail:
            prompt += "a detail view.";
            break;
        case ViewType.DraftingView:
            prompt += "a drafting view.";
            break;
        case ViewType.DrawingSheet:
            prompt += "a drawing sheet view.";
            break;
        case ViewType.Elevation:
            prompt += "an elevation view.";
            break;
        case ViewType.EngineeringPlan:
            prompt += "an engineering view.";
            break;
        case ViewType.FloorPlan:
            prompt += "afloor plan view.";
            break;
        case ViewType.Internal:
            prompt += "Revit's internal view.";
            break;
        case ViewType.Legend:
            prompt += "a legend view.";
            break;
        case ViewType.LoadsReport:
            prompt += "a loads report view.";
            break;
        case ViewType.PanelSchedule:
            prompt += "a panel schedule view.";
            break;
        case ViewType.PresureLossReport:
            prompt += "a pressure loss report view.";
            break;
        case ViewType.Rendering:
            prompt += "a rendering view.";
            break;
        case ViewType.Report:
            prompt += "a report view.";
            break;
        case ViewType.Schedule:
            prompt += "a schedule view.";
            break;
        case ViewType.Section:
            prompt += "a cross section view.";
            break;
        case ViewType.ThreeD:
            prompt += "a 3-D view.";
            break;
        case ViewType.Undefined:
            prompt += "an undefined/unspecified view.";
            break;
        case ViewType.Walkthrough:
            prompt += "a walkthrough view.";
            break;
        default:
            break;
    }

    // Give the user some information
    TaskDialog.Show("Revit",prompt);
}
CopyVB.NET
Public Sub GetViewType(view As Autodesk.Revit.DB.View)
    ' Get the view type of the given view, and format the prompt string
    Dim prompt As [String] = "The view is "

    Select Case view.ViewType
        Case ViewType.AreaPlan
            prompt += "an area view."
            Exit Select
        Case ViewType.CeilingPlan
            prompt += "a reflected ceiling plan view."
            Exit Select
        Case ViewType.ColumnSchedule
            prompt += "a column schedule view."
            Exit Select
        Case ViewType.CostReport
            prompt += "a cost report view."
            Exit Select
        Case ViewType.Detail
            prompt += "a detail view."
            Exit Select
        Case ViewType.DraftingView
            prompt += "a drafting view."
            Exit Select
        Case ViewType.DrawingSheet
            prompt += "a drawing sheet view."
            Exit Select
        Case ViewType.Elevation
            prompt += "an elevation view."
            Exit Select
        Case ViewType.EngineeringPlan
            prompt += "an engineering view."
            Exit Select
        Case ViewType.FloorPlan
            prompt += "afloor plan view."
            Exit Select
        Case ViewType.Internal
            prompt += "Revit's internal view."
            Exit Select
        Case ViewType.Legend
            prompt += "a legend view."
            Exit Select
        Case ViewType.LoadsReport
            prompt += "a loads report view."
            Exit Select
        Case ViewType.PanelSchedule
            prompt += "a panel schedule view."
            Exit Select
        Case ViewType.PresureLossReport
            prompt += "a pressure loss report view."
            Exit Select
        Case ViewType.Rendering
            prompt += "a rendering view."
            Exit Select
        Case ViewType.Report
            prompt += "a report view."
            Exit Select
        Case ViewType.Schedule
            prompt += "a schedule view."
            Exit Select
        Case ViewType.Section
            prompt += "a cross section view."
            Exit Select
        Case ViewType.ThreeD
            prompt += "a 3-D view."
            Exit Select
        Case ViewType.Undefined
            prompt += "an undefined/unspecified view."
            Exit Select
        Case ViewType.Walkthrough
            prompt += "a walkthrough view."
            Exit Select
        Case Else
            Exit Select
    End Select

    ' Give the user some information
    TaskDialog.Show("Revit", prompt)
End Sub

See Also

View Class


View3D Members

[image] [image]

Revit 2024 API
View3D Members
View3D Class Methods Properties See Also Send Feedback

The View3D type exposes the following members.

Methods

 | Name | Description
Public method | AddFilter | Adds a filter to the view. (Inherited from View.)
Public method | AllowsAnalysisDisplay | Identifies if this view allows display of Analysis results. (Inherited from View.)
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of the input view that are not controlled by the current view template. (Inherited from View.)
Public method | AreGraphicsOverridesAllowed | Determines if Visibility/Graphics Overriddes can be applied to the view. (Inherited from View.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanApplyColorFillScheme | Checks if the id can be applied as the scheme id of specified category to this view. (Inherited from View.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanCategoryBeHidden | Checks whether the category can be hidden in the view. (Inherited from View.)
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view. (Inherited from View.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanEnableTemporaryViewPropertiesMode | Indicates if Temporary View Properties mode can be applied for view in current state. (Inherited from View.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified. (Inherited from View.)
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified. (Inherited from View.)
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified (Inherited from View.)
Public method | CanResetCameraTarget | Checks whether the camera target can be reset for this view.
Public method | CanSaveOrientation | Returns true if the View3D's orientation can be saved, false otherwise.
Public method | CanToggleBetweenPerspectiveAndIsometric | Checks whether this view can toggle between perspective and isometric.
Public method | CanUseDepthCueing | Indicates if view can use Depth Cueing (Inherited from View.)
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes (Inherited from View.)
Public method | CanViewBeDuplicated | Identifies if this view can be duplicated. (Inherited from View.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view. (Inherited from View.)
Public method | ConvertToIndependent | Convert the dependent view to independent. (Inherited from View.)
 | CreateIsometric | Returns a new isometric View3D.
 | CreatePerspective | Returns a new perspective View3D.
Public method | CreateViewTemplate | Creates a new view template instance from this view instance. (Inherited from View.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode. (Inherited from View.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates this view. (Inherited from View.)
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode. (Inherited from View.)
Public method | EnableTemporaryViewPropertiesMode | Turns Temporary View Properties mode on or off. In this mode, any changes made to the view are temporary and will be discarded once the mode is disabled. (Inherited from View.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetBackground | Returns the current background set for the view. (Inherited from View.)
Public method | GetCalloutParentId | Gets ID of the callout parent view. (Inherited from View.)
Public method | GetCategoryHidden | Checks if elements of the given category are set to be invisible (hidden) in this view. (Inherited from View.)
Public method | GetCategoryOverrides | Gets graphic overrides for a category in view. (Inherited from View.)
Public method | GetColorFillSchemeId | Returns id of the color fill scheme element applied to the view. (Inherited from View.)
Public method | GetCropRegionShapeManager | Returns an object for managing view crop region shape. (Inherited from View.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetDependentViewIds | Get the ids of dependent views. (Inherited from View.)
Public method | GetDepthCueing | Returns the current depth cueing settings for the view. (Inherited from View.)
Public method | GetDirectContext3DHandleOverrides | Returns DirectContext3D handle overrides object for the view. (Inherited from View.)
Public method | GetElementOverrides | Gets graphic overrides for an element in the view. (Inherited from View.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetFilterOverrides | Gets graphic overrides that a filter applies to the view. (Inherited from View.)
Public method | GetFilters | Gets the filters applied to the view. (Inherited from View.)
Public method | GetFilterVisibility | Gets the visibility of the elements associated with a filter. (Inherited from View.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIsFilterEnabled | Identifies if the filter is enabled in this view. (Inherited from View.)
Public method | GetLevelsThatShowGrids | Returns the list of levels ids where grids are displayed in this 3D view.
Public method | GetLinkOverrides | Gets the graphic overrides of a RevitLinkType or RevitLinkInstance in view. (Inherited from View.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetModelToProjectionTransforms | Gets the transforms from the model space to the view projection space. (Inherited from View.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetNonControlledTemplateParameterIds | Returns a list of parameters that are not marked as included when this view is used as a template. (Inherited from View.)
Public method | GetOrderedFilters | Gets the filters applied to the view in the order they are applied. (Inherited from View.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetOrientation | Gets the current non-saved orientation of the View3D.
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPlacementOnSheetStatus | Determines if this view placed on a sheet completely or partially. (Inherited from View.)
Public method | GetPointCloudOverrides | Returns point cloud overrides object for the view. (Inherited from View.)
Public method | GetPrimaryViewId | Get the id of the primary view. (Inherited from View.)
Public method | GetReferenceCallouts | Returns element ids of all reference callouts in the view. (Inherited from View.)
Public method | GetReferenceElevations | Returns element ids of all reference elevations in the view. (Inherited from View.)
Public method | GetReferenceSections | Returns element ids of all reference sections in the view. (Inherited from View.)
Public method | GetRenderingSettings | Returns the current rendering settings for this 3d view.
Public method | GetSavedOrientation | Gets the saved orientation of the View3D.
Public method | GetSectionBox | Gets a copy of the section box for this 3D view.
Public method | GetSketchyLines | Returns the current sketchy lines settings for the view. (Inherited from View.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetTemplateParameterIds | Returns a list of parameter ids that may be controlled when this view is assigned as a template. (Inherited from View.)
Public method | GetTemporaryViewPropertiesId | When Temporary View Properties mode is in progress it provides view id that overrode settings for current view. Outside Temporary View Properties mode InvalidElementId will be returned. (Inherited from View.)
Public method | GetTemporaryViewPropertiesName | When Temporary View Properties mode is in progress, name of applied template is returned. Outside Temporary View Properties mode, empty string will be returned. (Inherited from View.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetViewDisplayModel | Returns the current view display model settings for the view. (Inherited from View.)
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view. (Inherited from View.)
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view. (Inherited from View.)
Public method | HasBeenLocked | Identifies if the view has ever been locked.
Public method | HasDetailLevel | Check if the view has a Detail Level property (Inherited from View.)
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property (Inherited from View.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property (Inherited from View.)
Public method | HasViewTransforms | Returns true if the view reports model space to view projection space transforms. (Inherited from View.)
Public method | HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View.)
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view. (Inherited from View.)
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view. (Inherited from View.)
Public method | HideElements | Sets the elements to be hidden in the view. (Inherited from View.)
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View.)
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View.)
Public method | HideGridsOnLevel | This method hides the grid lines in this 3D view on the given Level.
Public method | IsCategoryOverridable | Checks whether the category can have graphic overrides in this view. (Inherited from View.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view. (Inherited from View.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsFilterApplied | Indicates if a filter is applied to the view. (Inherited from View.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode. (Inherited from View.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View.)
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories. (Inherited from View.)
Public method | IsTemporaryViewPropertiesModeEnabled | Returns true when Temporary View Properties mode is in progress, false otherwise. (Inherited from View.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | IsValidViewTemplate | Verifies that the view represented by templateId can be set as the controlling view template for this view. (Inherited from View.)
Public method | IsViewValidForTemplateCreation | Verifies that the view is valid for template creation. (Inherited from View.)
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view. (Inherited from View.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | OrientTo | Reorients the view to align with the forward direction.
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | RemoveCalloutParent | Replaces callout parent ID with InvalidElementId. (Inherited from View.)
Public method | RemoveFilter | Removes a filter from the view. (Inherited from View.)
Public method | RemoveLinkOverrides | Deletes the graphical link overrides in the current view. (Inherited from View.)
Public method | ResetCameraTarget | Resets the camera target to the center of the field of view.
Public method | RestoreCalloutParent | Restores callout parent ID to the original view ID if that view is still available. (Inherited from View.)
Public method | RestoreOrientationAndLock | Locks the view and restores its orientation.
Public method | SaveOrientation | Converts the temporary orientation of the View3D into its saved orientation.
Public method | SaveOrientationAndLock | Locks the view and saves its orientation
Public method | SetBackground | Sets the background for the view. Background can only be set for 3d views and for Sections/Elevations. (Inherited from View.)
Public method | SetCategoryHidden | Sets if elements of the given category will be visible in this view. (Inherited from View.)
Public method | SetCategoryOverrides | Sets graphic overrides for a category in view. (Inherited from View.)
Public method | SetColorFillSchemeId | Applies color fill scheme to this view. (Inherited from View.)
Public method | SetDepthCueing | Sets the depth cueing settings for the view. (Inherited from View.)
Public method | SetElementOverrides | Sets graphic overrides for an element in the view. (Inherited from View.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetFilterOverrides | Sets the overrides associated with a filter. (Inherited from View.)
Public method | SetFilterVisibility | Sets the visibility of the elements associated with a filter. (Inherited from View.)
Public method | SetIsFilterEnabled | Sets the filter enabled flag. (Inherited from View.)
Public method | SetLinkOverrides | Sets the graphic overrides of a RevitLinkType or RevitLinkInstance in the view. (Inherited from View.)
Public method | SetNonControlledTemplateParameterIds | Sets the parameters that will not be included when this view is used as a template. (Inherited from View.)
Public method | SetOrientation | Sets the temporary orientation of the View3D. The new orientation is not saved in the document.
Public method | SetRenderingSettings | Changes the rendering settings for this 3d view.
Public method | SetSectionBox | Sets the section box for this 3D view.
Public method | SetSketchyLines | Sets the sketchy lines settings for the view. (Inherited from View.)
Public method | SetViewDisplayModel | Sets the view display model settings for the view. (Inherited from View.)
Public method | SetWorksetVisibility | Sets visibility for a workset in this view. (Inherited from View.)
Public method | SetWorksharingDisplayMode | Sets the worksharing display mode for this view. (Inherited from View.)
Public method | ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View.)
Public method | ShowGridsOnLevel | This method displays the grid lines in this 3DView on the given Level.
Public method | ShowGridsOnLevels | This method displays the grid lines in this 3D view on the given Levels.
Public method | SupportedColorFillCategoryIds | Returns collection of all category ids that correspond to elements that can potentially be colored in this view according to a color fill scheme. The set may be different depending on the view type. (Inherited from View.)
Public method | SupportsRevealConstraints | Checks that the view can have the Reveal Constraints mode activated. (Inherited from View.)
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode. (Inherited from View.)
Public method | ToggleToIsometric | Toggles this view to isometric.
Public method | ToggleToPerspective | Toggles this view to perspective.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)
Public method | Unlock | Unlocks the view. Has no effect if the view is already unlocked.

Properties

 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View.)
Public property | AreAnalyticalModelCategoriesHidden | Indicates if analytical model categories are currently hidden in the view. (Inherited from View.)
Public property | AreAnnotationCategoriesHidden | Indicates if annotation categories are currently hidden in the view. (Inherited from View.)
Public property | AreCoordinationModelHandlesHidden | Indicates if Coordination Model handles are currently hidden in the view. (Inherited from View.)
Public property | AreImportCategoriesHidden | Indicates if import categories are currently hidden in the view. (Inherited from View.)
Public property | AreModelCategoriesHidden | Indicates if model categories are currently hidden in the view. (Inherited from View.)
Public property | ArePointCloudsHidden | Indicates if point clouds are currently hidden in the view. (Inherited from View.)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view. (Inherited from View.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CropBox | The Crop Box applied to the view, or an outline encompassing the crop region applied to the view. (Inherited from View.)
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View.)
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DetailLevel | The detail level of this view. (Inherited from View.)
Public property | Discipline | The Discipline of the view. (Inherited from View.)
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style. (Inherited from View.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | GenLevel | The level for the view. (Inherited from View.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsAssemblyView | Indicates if the view is assembly view. (Inherited from View.)
Public property | IsCallout | Indicates if the view is a callout view. (Inherited from View.)
Public property | IsLocked | Indicates if the view is locked.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsPerspective | Identifies whether this is a perspective view.
Public property | IsSectionBoxActive | Identifies whether or not the section box is active in this 3D view.
Public property | IsTemplate | Test whether the view is a view template. (Inherited from View.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Origin | Returns the origin of the screen. (Inherited from View.)
Public property | Outline | The bounds of the view in paper space (in feet). (Inherited from View.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PartsVisibility | The visibility setting for parts in this view. (Inherited from View.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ProjectGridsOnSectionBox | This option projects all grids from the current 3d view on the bottom face of the section box. Only grids that are inside or intersects the section box
Public property | RevealConstraintsMode | Indicates whether the Reveal Constraints mode is activated in the view. (Inherited from View.)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Public property | Scale | The scale of the view. (Inherited from View.)
Public property | ShadowIntensity | The intesity of cast shadows - 0 = no shadows, 100 = black. (Inherited from View.)
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View.)
Public property | SunlightIntensity | The intensity of the simulated (directional) sunlight. 0 = no directional light; maximum value is 100. (Inherited from View.)
Public property | TemporaryViewModes | Data of temporary view modes associated with this view. (Inherited from View.)
Public property | Title | The view title. This consists of the view name plus other modifiers, such as the view type, sheet number, area scheme, and/or assembly type, depending on the specifics of the view. (Inherited from View.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | ViewTemplateId | The id of the template view that controls this view's parameters. (Inherited from View.)
Public property | ViewType | The type of the view. (Inherited from View.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

View3D Class


CanResetCameraTarget Method

[image]

Revit 2024 API
View3D..::..CanResetCameraTarget Method
View3D Class See Also Send Feedback
Checks whether the camera target can be reset for this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015 Subscription Update

Syntax

C#
public bool CanResetCameraTarget()
Visual Basic
Public Function CanResetCameraTarget As Boolean
Visual C++
public:
bool CanResetCameraTarget()

Return Value

True if camera target can be reset for this view, false otherwise.

Remarks

The camera target can only be reset for perspective view.

See Also

View3D Class


CanSaveOrientation Method

[image]

Revit 2024 API
View3D..::..CanSaveOrientation Method
View3D Class See Also Send Feedback
Returns true if the View3D's orientation can be saved, false otherwise.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool CanSaveOrientation()
Visual Basic
Public Function CanSaveOrientation As Boolean
Visual C++
public:
bool CanSaveOrientation()

Return Value

True if the View3D's orientation can be saved, false otherwise.

Remarks

The saved orientation of the default 3D view cannot be overwritten. To convert the default 3D view into a normal 3D view, rename the default 3D view.

See Also

View3D Class


CreateIsometric Method

[image]

Revit 2024 API
View3D..::..CreateIsometric Method
View3D Class Example See Also Send Feedback
Returns a new isometric View3D.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static View3D CreateIsometric(
    Document document,
    ElementId viewFamilyTypeId
)
Visual Basic
Public Shared Function CreateIsometric ( _
    document As Document, _
    viewFamilyTypeId As ElementId _
) As View3D
Visual C++
public:
static View3D^ CreateIsometric(
    Document^ document,
    ElementId^ viewFamilyTypeId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new View3D will be added.
viewFamilyTypeId
Type: Autodesk.Revit.DB..::..ElementId
The id of the ViewFamilyType which will be used by the new View3D. The type needs to be a ThreeDimensional ViewType.

Return Value

The new isometric View3D.

Remarks

The new View3D will receive a unique view name. The view will be oriented in the same position as the default 3D view.

Examples

CopyVB.NET
' Find a 3D view type
Dim collector1 As New FilteredElementCollector(document)
collector1 = collector1.OfClass(GetType(ViewFamilyType))
Dim viewFamilyTypes As IEnumerable(Of ViewFamilyType)

viewFamilyTypes = From elem In collector1 _
                  Let vftype = TryCast(elem, ViewFamilyType) _
                  Where vftype.ViewFamily = ViewFamily.ThreeDimensional _
                  Select vftype
' Create a new View3D
Dim view3D__1 As View3D = View3D.CreateIsometric(document, viewFamilyTypes.First().Id)
If view3D__1 IsNot Nothing Then
    ' By default, the 3D view uses a default orientation.
    ' Change the orientation by creating and setting a ViewOrientation3D
    Dim eye As New XYZ(10, 10, 10)
    Dim up As New XYZ(0, 1, 1)
    Dim forward As New XYZ(0, 1, -1)
    Dim viewOrientation3D As New ViewOrientation3D(eye, up, forward)
    view3D__1.SetOrientation(viewOrientation3D)
End If

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This View Family Type is not a ThreeDimensional view type. -or- 3D view creation is not allowed in this family.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

View3D Class


CreatePerspective Method

[image]

Revit 2024 API
View3D..::..CreatePerspective Method
View3D Class Example See Also Send Feedback
Returns a new perspective View3D.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static View3D CreatePerspective(
    Document document,
    ElementId viewFamilyTypeId
)
Visual Basic
Public Shared Function CreatePerspective ( _
    document As Document, _
    viewFamilyTypeId As ElementId _
) As View3D
Visual C++
public:
static View3D^ CreatePerspective(
    Document^ document,
    ElementId^ viewFamilyTypeId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new View3D will be added.
viewFamilyTypeId
Type: Autodesk.Revit.DB..::..ElementId
The id of the ViewFamilyType which will be used by the new View3D. The type needs to be a ThreeDimensional ViewType.

Return Value

The new perspective View3D.

Remarks

The new View3D will receive a unique view name. The view will be oriented in the same position as the default 3D view.

Examples

CopyVB.NET
' Find a 3D view type
Dim collector1 As New FilteredElementCollector(document)
collector1 = collector1.OfClass(GetType(ViewFamilyType))
Dim viewFamilyTypes As IEnumerable(Of ViewFamilyType)

viewFamilyTypes = From elem In collector1 _
                  Let vftype = TryCast(elem, ViewFamilyType) _
                  Where vftype.ViewFamily = ViewFamily.ThreeDimensional _
                  Select vftype
' Create a new Perspective View3D
Dim view3D__1 As View3D = View3D.CreatePerspective(document, viewFamilyTypes.First().Id)
If view3D__1 IsNot Nothing Then
    ' By default, the 3D view uses a default orientation.
    ' Change the orientation by creating and setting a ViewOrientation3D
    Dim eye As New XYZ(0, -100, 10)
    Dim up As New XYZ(0, 0, 1)
    Dim forward As New XYZ(0, 1, 0)
    view3D__1.SetOrientation(New ViewOrientation3D(eye, up, forward))

    ' turn off the far clip plane with standard parameter API
    Dim farClip As Parameter = view3D__1.LookupParameter("Far Clip Active")
    farClip.[Set](0)
End If

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This View Family Type is not a ThreeDimensional view type. -or- 3D view creation is not allowed in this family.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

View3D Class


GetLevelsThatShowGrids Method

[image]

Revit 2024 API
View3D..::..GetLevelsThatShowGrids Method
View3D Class See Also Send Feedback
Returns the list of levels ids where grids are displayed in this 3D view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public ISet<ElementId> GetLevelsThatShowGrids()
Visual Basic
Public Function GetLevelsThatShowGrids As ISet(Of ElementId)
Visual C++
public:
ISet<ElementId^>^ GetLevelsThatShowGrids()

Return Value

The list of levels ids where grids are displayed in 3D views.

See Also

View3D Class


GetOrientation Method

[image]

Revit 2024 API
View3D..::..GetOrientation Method
View3D Class See Also Send Feedback
Gets the current non-saved orientation of the View3D.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ViewOrientation3D GetOrientation()
Visual Basic
Public Function GetOrientation As ViewOrientation3D
Visual C++
public:
ViewOrientation3D^ GetOrientation()

Return Value

The current non-saved orientation of the View3D.

See Also

View3D Class


GetRenderingSettings Method

[image]

Revit 2024 API
View3D..::..GetRenderingSettings Method
View3D Class Example See Also Send Feedback
Returns the current rendering settings for this 3d view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public RenderingSettings GetRenderingSettings()
Visual Basic
Public Function GetRenderingSettings As RenderingSettings
Visual C++
public:
RenderingSettings^ GetRenderingSettings()

Return Value

The returned object represents the current rendering settings. If you change the returned object, you need to call SetRenderingSettings to apply the new settings back to Revit.

Examples

CopyC#
public RenderingSettings GetFirstRenderingSettings(Document document)
{
    // RenderingSettings isn't used to support family document.
    if (document.IsFamilyDocument)
        return null;

    // Get 3d view
    List<View3D> theView3Ds = new List<View3D>();
    foreach (View3D view3D in RetrieveElementByType<View3D>(document))
    {
        // It's strongly recommend to get  RenderingSettings from visible 3d view,
        // although it can retrieve data from an invisible one,
        if (view3D.IsTemplate || !view3D.CanBePrinted)
            continue;
        return view3D.GetRenderingSettings();
    }
    return null;
}

public static List<T> RetrieveElementByType<T>(Document document) where T : Autodesk.Revit.DB.Element
{
    FilteredElementCollector collector = new FilteredElementCollector(document);
    return collector.OfClass(typeof(T)).Cast<T>().ToList<T>();
}
CopyVB.NET
Public Function GetFirstRenderingSettings(document As Document) As RenderingSettings
   ' RenderingSettings isn't used to support family document.
   If document.IsFamilyDocument Then
      Return Nothing
   End If

   ' Get 3d view
   Dim theView3Ds As New List(Of View3D)()
   For Each view3D As View3D In RetrieveElementByType(Of View3D)(document)
      ' It's strongly recommend to get  RenderingSettings from visible 3d view,
      ' although it can retrieve data from an invisible one,
      If view3D.IsTemplate OrElse Not view3D.CanBePrinted Then
         Continue For
      End If
      Return view3D.GetRenderingSettings()
   Next
   Return Nothing
End Function

Public Shared Function RetrieveElementByType(Of T As Autodesk.Revit.DB.Element)(document As Document) As List(Of T)
   Dim collector As New FilteredElementCollector(document)
   Return collector.OfClass(GetType(T)).Cast(Of T)().ToList()
End Function

See Also

View3D Class


GetSavedOrientation Method

[image]

Revit 2024 API
View3D..::..GetSavedOrientation Method
View3D Class See Also Send Feedback
Gets the saved orientation of the View3D.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ViewOrientation3D GetSavedOrientation()
Visual Basic
Public Function GetSavedOrientation As ViewOrientation3D
Visual C++
public:
ViewOrientation3D^ GetSavedOrientation()

Return Value

The saved orientation of the View3D.

See Also

View3D Class


GetSectionBox Method

[image]

Revit 2024 API
View3D..::..GetSectionBox Method
View3D Class See Also Send Feedback
Gets a copy of the section box for this 3D view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public BoundingBoxXYZ GetSectionBox()
Visual Basic
Public Function GetSectionBox As BoundingBoxXYZ
Visual C++
public:
BoundingBoxXYZ^ GetSectionBox()

Return Value

The section box. Note that the section box can be rotated and transformed and thus you will need to use [!:Autodesk::Revit::DB::BoundingBoxXYZ::Transform] to interpret the coordinates of the corners or sides of the box in model coordinates.

Remarks

The section box cuts the model in this view by its boundaries.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Returns true if the view is not a view template.

See Also

View3D Class


HasBeenLocked Method

[image]

Revit 2024 API
View3D..::..HasBeenLocked Method
View3D Class See Also Send Feedback
Identifies if the view has ever been locked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool HasBeenLocked()
Visual Basic
Public Function HasBeenLocked As Boolean
Visual C++
public:
bool HasBeenLocked()

See Also

View3D Class


HideGridsOnLevel Method

[image]

Revit 2024 API
View3D..::..HideGridsOnLevel Method
View3D Class See Also Send Feedback
This method hides the grid lines in this 3D view on the given Level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public void HideGridsOnLevel(
    ElementId levelId
)
Visual Basic
Public Sub HideGridsOnLevel ( _
    levelId As ElementId _
)
Visual C++
public:
void HideGridsOnLevel(
    ElementId^ levelId
)

Parameters

levelId
Type: Autodesk.Revit.DB..::..ElementId
The id of the Level where grids will not be displayed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

View3D Class


OrientTo Method

[image]

Revit 2024 API
View3D..::..OrientTo Method
View3D Class See Also Send Feedback
Reorients the view to align with the forward direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public void OrientTo(
    XYZ forwardDirection
)
Visual Basic
Public Sub OrientTo ( _
    forwardDirection As XYZ _
)
Visual C++
public:
void OrientTo(
    XYZ^ forwardDirection
)

Parameters

forwardDirection
Type: Autodesk.Revit.DB..::..XYZ
The forward direction.

Remarks

This method adjusts the ViewOrientation to align with the input forward direction. The eye position will be automatically determined based on the shape of the viewing area and size of the model. The UpDirection will be aligned with the project Z axis.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | forwardDirection has zero length.
Autodesk.Revit.Exceptions..::..InvalidOperationException | View is locked and cannot be reoriented.

See Also

View3D Class


Print Method

[image] [image]

Revit 2024 API
View3D..::..Print Method
View3D Class See Also Send Feedback
Print this view.

Overload List

 | Name | Description
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)

See Also

View3D Class
View3D Members


ResetCameraTarget Method

[image]

Revit 2024 API
View3D..::..ResetCameraTarget Method
View3D Class See Also Send Feedback
Resets the camera target to the center of the field of view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015 Subscription Update

Syntax

C#
public void ResetCameraTarget()
Visual Basic
Public Sub ResetCameraTarget
Visual C++
public:
void ResetCameraTarget()

Remarks

The camera target can only be reset for perspective view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The camera target cannot be reset for the view.

See Also

View3D Class


SaveOrientationAndLock Method

[image]

Revit 2024 API
View3D..::..SaveOrientationAndLock Method
View3D Class See Also Send Feedback
Locks the view and saves its orientation

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void SaveOrientationAndLock()
Visual Basic
Public Sub SaveOrientationAndLock
Visual C++
public:
void SaveOrientationAndLock()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Returns true if the view is not a view template. -or- The orientation of the View3D cannot be saved.

See Also

View3D Class


SetRenderingSettings Method

[image]

Revit 2024 API
View3D..::..SetRenderingSettings Method
View3D Class See Also Send Feedback
Changes the rendering settings for this 3d view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void SetRenderingSettings(
    RenderingSettings settings
)
Visual Basic
Public Sub SetRenderingSettings ( _
    settings As RenderingSettings _
)
Visual C++
public:
void SetRenderingSettings(
    RenderingSettings^ settings
)

Parameters

settings
Type: Autodesk.Revit.DB..::..RenderingSettings
The new rendering settings to be applied to this view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

View3D Class


ShowGridsOnLevel Method

[image]

Revit 2024 API
View3D..::..ShowGridsOnLevel Method
View3D Class See Also Send Feedback
This method displays the grid lines in this 3DView on the given Level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public void ShowGridsOnLevel(
    ElementId levelId
)
Visual Basic
Public Sub ShowGridsOnLevel ( _
    levelId As ElementId _
)
Visual C++
public:
void ShowGridsOnLevel(
    ElementId^ levelId
)

Parameters

levelId
Type: Autodesk.Revit.DB..::..ElementId
The id of the Level where grids should be displayed.

Remarks

Grids will be displayed only if they intersects Level's plane.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

View3D Class


ShowGridsOnLevels Method

[image]

Revit 2024 API
View3D..::..ShowGridsOnLevels Method
View3D Class See Also Send Feedback
This method displays the grid lines in this 3D view on the given Levels.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public void ShowGridsOnLevels(
    ISet<ElementId> levelsIds
)
Visual Basic
Public Sub ShowGridsOnLevels ( _
    levelsIds As ISet(Of ElementId) _
)
Visual C++
public:
void ShowGridsOnLevels(
    ISet<ElementId^>^ levelsIds
)

Parameters

levelsIds
Type: System.Collections.Generic..::..ISet<(Of <(<' ElementId >)>)>
Levels ids where grids lines will be displayed.

Remarks

Previously selected Levels for showing grids will be replaced with the new ids.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

View3D Class


ToggleToIsometric Method

[image]

Revit 2024 API
View3D..::..ToggleToIsometric Method
View3D Class See Also Send Feedback
Toggles this view to isometric.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015 Subscription Update

Syntax

C#
public void ToggleToIsometric()
Visual Basic
Public Sub ToggleToIsometric
Visual C++
public:
void ToggleToIsometric()

Remarks

This view can only be toggled to isometric if no view specific elements are contained.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This view cannot be toggled.

See Also

View3D Class


Unlock Method

[image]

Revit 2024 API
View3D..::..Unlock Method
View3D Class See Also Send Feedback
Unlocks the view. Has no effect if the view is already unlocked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void Unlock()
Visual Basic
Public Sub Unlock
Visual C++
public:
void Unlock()

See Also

View3D Class


View3D Properties

[image] [image]

Revit 2024 API
View3D Properties
View3D Class See Also Send Feedback

The View3D type exposes the following members.

Properties

 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View.)
Public property | AreAnalyticalModelCategoriesHidden | Indicates if analytical model categories are currently hidden in the view. (Inherited from View.)
Public property | AreAnnotationCategoriesHidden | Indicates if annotation categories are currently hidden in the view. (Inherited from View.)
Public property | AreCoordinationModelHandlesHidden | Indicates if Coordination Model handles are currently hidden in the view. (Inherited from View.)
Public property | AreImportCategoriesHidden | Indicates if import categories are currently hidden in the view. (Inherited from View.)
Public property | AreModelCategoriesHidden | Indicates if model categories are currently hidden in the view. (Inherited from View.)
Public property | ArePointCloudsHidden | Indicates if point clouds are currently hidden in the view. (Inherited from View.)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view. (Inherited from View.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CropBox | The Crop Box applied to the view, or an outline encompassing the crop region applied to the view. (Inherited from View.)
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View.)
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DetailLevel | The detail level of this view. (Inherited from View.)
Public property | Discipline | The Discipline of the view. (Inherited from View.)
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style. (Inherited from View.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | GenLevel | The level for the view. (Inherited from View.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsAssemblyView | Indicates if the view is assembly view. (Inherited from View.)
Public property | IsCallout | Indicates if the view is a callout view. (Inherited from View.)
Public property | IsLocked | Indicates if the view is locked.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsPerspective | Identifies whether this is a perspective view.
Public property | IsSectionBoxActive | Identifies whether or not the section box is active in this 3D view.
Public property | IsTemplate | Test whether the view is a view template. (Inherited from View.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Origin | Returns the origin of the screen. (Inherited from View.)
Public property | Outline | The bounds of the view in paper space (in feet). (Inherited from View.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PartsVisibility | The visibility setting for parts in this view. (Inherited from View.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ProjectGridsOnSectionBox | This option projects all grids from the current 3d view on the bottom face of the section box. Only grids that are inside or intersects the section box
Public property | RevealConstraintsMode | Indicates whether the Reveal Constraints mode is activated in the view. (Inherited from View.)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Public property | Scale | The scale of the view. (Inherited from View.)
Public property | ShadowIntensity | The intesity of cast shadows - 0 = no shadows, 100 = black. (Inherited from View.)
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View.)
Public property | SunlightIntensity | The intensity of the simulated (directional) sunlight. 0 = no directional light; maximum value is 100. (Inherited from View.)
Public property | TemporaryViewModes | Data of temporary view modes associated with this view. (Inherited from View.)
Public property | Title | The view title. This consists of the view name plus other modifiers, such as the view type, sheet number, area scheme, and/or assembly type, depending on the specifics of the view. (Inherited from View.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | ViewTemplateId | The id of the template view that controls this view's parameters. (Inherited from View.)
Public property | ViewType | The type of the view. (Inherited from View.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

View3D Class


IsLocked Property

[image]

Revit 2024 API
View3D..::..IsLocked Property
View3D Class See Also Send Feedback
Indicates if the view is locked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool IsLocked { get; }
Visual Basic
Public ReadOnly Property IsLocked As Boolean
    Get
Visual C++
public:
property bool IsLocked {
    bool get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Returns true if the view is not a view template.

See Also

View3D Class


IsPerspective Property

[image]

Revit 2024 API
View3D..::..IsPerspective Property
View3D Class See Also Send Feedback
Identifies whether this is a perspective view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsPerspective { get; }
Visual Basic
Public ReadOnly Property IsPerspective As Boolean
    Get
Visual C++
public:
property bool IsPerspective {
    bool get ();
}

Remarks

In a perspective view, view direction is variable - it is the direction that connects a particular point on the model with the eye position. The property ViewDirection becomes less meaningful - it only describes the general orientation of the camera.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Returns true if the view is not a view template.

See Also

View3D Class


IsSectionBoxActive Property

[image]

Revit 2024 API
View3D..::..IsSectionBoxActive Property
View3D Class Example See Also Send Feedback
Identifies whether or not the section box is active in this 3D view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool IsSectionBoxActive { get; set; }
Visual Basic
Public Property IsSectionBoxActive As Boolean
    Get
    Set
Visual C++
public:
property bool IsSectionBoxActive {
    bool get ();
    void set (bool value);
}

Field Value

An active section box clips the geometry of the model in the 3D view. This affects the appearance of the view, and also will affect information returned from the API. For example:
  • Elements outside the active section box will not be returned in the list of elements obtained from [!:Autodesk::Revit::DB::FilteredElementCollector] when this view is passed when contructing the collector.
  • Elements clipped by the active section box will return clipped geometry from Geometry[([( Options])]) when this view is included in the options.

Examples

CopyC#
private void DisableSectionBox(View3D view3d)
{
    if (!view3d.IsSectionBoxActive)
    {
        TaskDialog.Show("Revit", "The section box for View3D isn't active.");
        return;
    }

    // Disable the section box (requires an open transaction)
    view3d.IsSectionBoxActive = false;
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Returns true if the view is not a view template.

See Also

View3D Class


Parameter Property

[image] [image]

Revit 2024 API
View3D..::..Parameter Property
View3D Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

View3D Class
View3D Members


ProjectGridsOnSectionBox Property

[image]

Revit 2024 API
View3D..::..ProjectGridsOnSectionBox Property
View3D Class See Also Send Feedback
This option projects all grids from the current 3d view on the bottom face of the section box. Only grids that are inside or intersects the section box

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public bool ProjectGridsOnSectionBox { get; set; }
Visual Basic
Public Property ProjectGridsOnSectionBox As Boolean
    Get
    Set
Visual C++
public:
property bool ProjectGridsOnSectionBox {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Returns true if the view is not a view template.

See Also

View3D Class


ViewCropRegionShapeManager Class

[image]

Revit 2024 API
ViewCropRegionShapeManager Class
Members Example See Also Send Feedback
A class that provides access to settings related to the crop assigned to a view or a reference callout.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class ViewCropRegionShapeManager : IDisposable
Visual Basic
Public Class ViewCropRegionShapeManager _
    Implements IDisposable
Visual C++
public ref class ViewCropRegionShapeManager : IDisposable

Remarks

This class manages all the settings that make up the model and annotation crop geometry for a given view or reference callout. You can obtain the settings for a view from GetCropRegionShapeManager()()()(). Obtain the settings for a reference callout from GetCropRegionShapeManagerForReferenceCallout(Document, ElementId).

The model crop region crops model elements, detail elements (such as insulation and detail lines), section boxes, and scope boxes at the model crop boundary. Visible crop boundaries of other related views are also cropped at the model crop boundary. The model crop region can be set as a polygonal boundary, a rectangular boundary, or rectangular boundary with one or more splits applied either horizontally or vertically. If a split is applied to the rectangular crop each resulting rectangular region is identified by a region index and occupies a percentage of the original crop rectangle. The regions may possibly be moved relative to one another.

The annotation crop region fully crops annotation elements when it touches any portion of the annotation element, so that no partial annotations are drawn. Annotations (such as symbols, tags, keynotes, and dimensions) that reference hidden or cropped model elements do not display in the view, even if they are inside the annotation crop region. The annotation crop region is always rectangular and at minimum occupies the same area as the rectangular model crop (or the corresponding rectangular boundary around the non-rectangular model crop), but can be offset to be bigger than the model crop in order to display more annotations.

Examples

CopyC#
public void CropAroundRoom(Room room, View view)
{
    if (view != null)
    {
        IList<IList<Autodesk.Revit.DB.BoundarySegment>> segments = room.GetBoundarySegments(new SpatialElementBoundaryOptions());

        if (null != segments)  //the room may not be bound
        {
            foreach (IList<Autodesk.Revit.DB.BoundarySegment> segmentList in segments)
            {
                CurveLoop loop = new CurveLoop();
                foreach (Autodesk.Revit.DB.BoundarySegment boundarySegment in segmentList)
                {
                    loop.Append(boundarySegment.GetCurve());
                }

                ViewCropRegionShapeManager vcrShapeMgr = view.GetCropRegionShapeManager();
                vcrShapeMgr.SetCropShape(loop);
                break;  // if more than one set of boundary segments for room, crop around the first one
            }
        }
    }
}
CopyVB.NET
Public Sub CropAroundRoom(room As Room, view As View)
    If view IsNot Nothing Then
        Dim segments As IList(Of IList(Of Autodesk.Revit.DB.BoundarySegment)) = room.GetBoundarySegments(New SpatialElementBoundaryOptions())

        If segments IsNot Nothing Then
            'the room may not be bound
            For Each segmentList As IList(Of Autodesk.Revit.DB.BoundarySegment) In segments
                Dim [loop] As New CurveLoop()
                For Each boundarySegment As Autodesk.Revit.DB.BoundarySegment In segmentList
                    [loop].Append(boundarySegment.GetCurve())
                Next

                Dim vcrShapeMgr As ViewCropRegionShapeManager = view.GetCropRegionShapeManager()
                vcrShapeMgr.SetCropShape([loop])
                    ' if more than one set of boundary segments for room, crop around the first one
                Exit For
            Next
        End If
    End If
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ViewCropRegionShapeManager

See Also

ViewCropRegionShapeManager Members


ViewCropRegionShapeManager Methods

[image] [image]

Revit 2024 API
ViewCropRegionShapeManager Methods
ViewCropRegionShapeManager Class See Also Send Feedback

The ViewCropRegionShapeManager type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnnotationCropShape | Gets the annotation crop box assigned to the view.
Public method | GetCropShape | Gets the crop boundaries that are curently active.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSplitRegionMaximum | Returns the proportional location of the maximum boundary of the specified split crop region.
Public method | GetSplitRegionMinimum | Returns the proportional location of the minimum boundary of the specified split crop region.
Public method | GetSplitRegionOffset | Returns the offset for the specified split crop region.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCropRegionShapeValid | Verifies that boundary represents one closed curve loop without self-intersections, consisting of non-zero length straight lines in a plane parallel to the view plane.
Public method | RemoveCropRegionShape | Removes any non-rectangular boundary of the view's crop.
Public method | RemoveSplit | Removes any split applied to the view's crop.
Public method | RemoveSplitRegion | Removes one region in split crop.
Public method | SetCropShape | Sets the boundary of the view's crop to the specified shape.
Public method | SplitRegionHorizontally | Splits horizontally one region in split crop.
Public method | SplitRegionVertically | Splits vertically one region in split crop.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ViewCropRegionShapeManager Class


Dispose Method

[image]

Revit 2024 API
ViewCropRegionShapeManager..::..Dispose Method
ViewCropRegionShapeManager Class See Also Send Feedback
Releases all resources used by the ViewCropRegionShapeManager

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ViewCropRegionShapeManager Class


GetAnnotationCropShape Method

[image]

Revit 2024 API
ViewCropRegionShapeManager..::..GetAnnotationCropShape Method
ViewCropRegionShapeManager Class See Also Send Feedback
Gets the annotation crop box assigned to the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public CurveLoop GetAnnotationCropShape()
Visual Basic
Public Function GetAnnotationCropShape As CurveLoop
Visual C++
public:
CurveLoop^ GetAnnotationCropShape()

Return Value

The annotation crop boundary.

Remarks

Currently, this method returns only the rectangular annotation crop box.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | View is not allowed to have an annotation crop.

See Also

ViewCropRegionShapeManager Class


GetCropShape Method

[image]

Revit 2024 API
ViewCropRegionShapeManager..::..GetCropShape Method
ViewCropRegionShapeManager Class See Also Send Feedback
Gets the crop boundaries that are curently active.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public IList<CurveLoop> GetCropShape()
Visual Basic
Public Function GetCropShape As IList(Of CurveLoop)
Visual C++
public:
IList<CurveLoop^>^ GetCropShape()

Return Value

The crop boundaries.

Remarks

This method returns a representation of the boundaries of the currently active crop for the associated view. If the view crop has a non-rectangular shape, the method returns that shape. Otherwise, if the view crop has been split, the method returns the multiple rectangular boundaries visible in the crop - note that this does not reflect any offsets that may have been applied to the boundary regions. If the crop is not split, this returns a single rectangle representing the crop. All coordinates are in the coordinate frame of the view.

See Also

ViewCropRegionShapeManager Class


GetSplitRegionMinimum Method

[image]

Revit 2024 API
ViewCropRegionShapeManager..::..GetSplitRegionMinimum Method
ViewCropRegionShapeManager Class See Also Send Feedback
Returns the proportional location of the minimum boundary of the specified split crop region.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public double GetSplitRegionMinimum(
    int regionIndex
)
Visual Basic
Public Function GetSplitRegionMinimum ( _
    regionIndex As Integer _
) As Double
Visual C++
public:
double GetSplitRegionMinimum(
    int regionIndex
)

Parameters

regionIndex
Type: System..::..Int32
Index of split crop region (numbering starts with 0).

Return Value

A value from 0 to 1 representing the minimum location for the region's split boundary. This number represents the location as a ratio along the non-split rectangular crop.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The provided region index is invalid.

See Also

ViewCropRegionShapeManager Class


RemoveSplit Method

[image]

Revit 2024 API
ViewCropRegionShapeManager..::..RemoveSplit Method
ViewCropRegionShapeManager Class See Also Send Feedback
Removes any split applied to the view's crop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void RemoveSplit()
Visual Basic
Public Sub RemoveSplit
Visual C++
public:
void RemoveSplit()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The crop of the associated view is not permitted to have multiple regions.

See Also

ViewCropRegionShapeManager Class


RemoveSplitRegion Method

[image]

Revit 2024 API
ViewCropRegionShapeManager..::..RemoveSplitRegion Method
ViewCropRegionShapeManager Class See Also Send Feedback
Removes one region in split crop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public void RemoveSplitRegion(
    int regionIndex
)
Visual Basic
Public Sub RemoveSplitRegion ( _
    regionIndex As Integer _
)
Visual C++
public:
void RemoveSplitRegion(
    int regionIndex
)

Parameters

regionIndex
Type: System..::..Int32
Index of region to be deleted (numbering starts with 0).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The provided region index cannot be deleted.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The crop of the associated view is not permitted to have multiple regions. -or- The view has non-rectangular crop shape set.

See Also

ViewCropRegionShapeManager Class


SetCropShape Method

[image]

Revit 2024 API
ViewCropRegionShapeManager..::..SetCropShape Method
ViewCropRegionShapeManager Class See Also Send Feedback
Sets the boundary of the view's crop to the specified shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void SetCropShape(
    CurveLoop boundary
)
Visual Basic
Public Sub SetCropShape ( _
    boundary As CurveLoop _
)
Visual C++
public:
void SetCropShape(
    CurveLoop^ boundary
)

Parameters

boundary
Type: Autodesk.Revit.DB..::..CurveLoop
The crop boundary.

Remarks

Depending on the shape of the argument, view's crop is set to be either rectangular or non-rectangular. If the crop is set to be rectangular and it is also split, then the multiple view regions will be displayed for the view, with the same proportions as the split prior to the change, but adjusted to the new rectangular shape.

This Method is reserved for setting crop shape in views that allow non-rectangular crop shapes - see property CanHaveShape. For views that don't allow non-rectangular crop shapes (e.g. View3D), please use property CropBox for that purpose.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Boundary in boundary should represent one closed curve loop without self-intersections, consisting of non-zero length straight lines in a plane parallel to the view plane.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The crop of the associated view is not permitted to have a non-rectangular shape.

See Also

ViewCropRegionShapeManager Class


SplitRegionHorizontally Method

[image]

Revit 2024 API
ViewCropRegionShapeManager..::..SplitRegionHorizontally Method
ViewCropRegionShapeManager Class See Also Send Feedback
Splits horizontally one region in split crop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public void SplitRegionHorizontally(
    int regionIndex,
    double leftPart,
    double rightPart
)
Visual Basic
Public Sub SplitRegionHorizontally ( _
    regionIndex As Integer, _
    leftPart As Double, _
    rightPart As Double _
)
Visual C++
public:
void SplitRegionHorizontally(
    int regionIndex,
    double leftPart,
    double rightPart
)

Parameters

regionIndex
Type: System..::..Int32
Index of region to be split horizontally (numbering starts with 0).
leftPart
Type: System..::..Double
Relative portion of the original region to become the new left region (0 to 1).
rightPart
Type: System..::..Double
Relative portion of the original region to become the new right region (0 to 1).

Remarks

This function splits the crop into two regions: one occupying the left quarter of the crop, and the other the right quarter of the crop.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The provided view region proportions are not valid. -or- The provided region index is invalid.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The crop of the associated view is not permitted to have multiple regions. -or- The view has non-rectangular crop shape set. -or- The view crop is already split vertically.

See Also

ViewCropRegionShapeManager Class


SplitRegionVertically Method

[image]

Revit 2024 API
ViewCropRegionShapeManager..::..SplitRegionVertically Method
ViewCropRegionShapeManager Class See Also Send Feedback
Splits vertically one region in split crop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public void SplitRegionVertically(
    int regionIndex,
    double topPart,
    double bottomPart
)
Visual Basic
Public Sub SplitRegionVertically ( _
    regionIndex As Integer, _
    topPart As Double, _
    bottomPart As Double _
)
Visual C++
public:
void SplitRegionVertically(
    int regionIndex,
    double topPart,
    double bottomPart
)

Parameters

regionIndex
Type: System..::..Int32
Index of region to be split vertically (numbering starts with 0).
topPart
Type: System..::..Double
Relative portion of the original region to become the new top region (0 to 1).
bottomPart
Type: System..::..Double
Relative portion of the original region to become the new bottom region (0 to 1).

Remarks

This function splits the crop into two regions: one occupying the top quarter of the crop, and the other the bottom quarter of the crop.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The provided view region proportions are not valid. -or- The provided region index is invalid.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The crop of the associated view is not permitted to have multiple regions. -or- The view has non-rectangular crop shape set. -or- The view crop is already split horizontally.

See Also

ViewCropRegionShapeManager Class


ViewCropRegionShapeManager Properties

[image] [image]

Revit 2024 API
ViewCropRegionShapeManager Properties
ViewCropRegionShapeManager Class See Also Send Feedback

The ViewCropRegionShapeManager type exposes the following members.

Properties

 | Name | Description
Public property | BottomAnnotationCropOffset | The offset from the bottom of the view crop that determines the location of the annotation crop bottom boundary.
Public property | CanBeSplit | Verifies that the crop of the associated view is permitted to have multiple regions.
Public property | CanHaveAnnotationCrop | Verifies that the view is allowed to have an annotation crop.
Public property | CanHaveShape | Verifies that the crop of the associated view is permitted to have a non-rectangular shape.
Public property | IsSplitHorizontally | Whether or not the view's crop is split (and the split is horizontal).
Public property | IsSplitVertically | Whether or not the view's crop is split (and the split is vertical).
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LeftAnnotationCropOffset | The offset from the left of the view crop that determines the location of the annotation crop left boundary.
Public property | NumberOfSplitRegions | The number of split crop regions (1 if the crop is not currently split).
Public property | RightAnnotationCropOffset | The offset from the right of the view crop that determines the location of the annotation crop right boundary.
Public property | ShapeSet | Whether or not the view crop has a non-rectangular shape set.
Public property | Split | Whether or not the view crop is split.
Public property | TopAnnotationCropOffset | The offset from the top of the view crop that determines the location of the annotation crop top boundary.

See Also

ViewCropRegionShapeManager Class


BottomAnnotationCropOffset Property

[image]

Revit 2024 API
ViewCropRegionShapeManager..::..BottomAnnotationCropOffset Property
ViewCropRegionShapeManager Class See Also Send Feedback
The offset from the bottom of the view crop that determines the location of the annotation crop bottom boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public double BottomAnnotationCropOffset { get; set; }
Visual Basic
Public Property BottomAnnotationCropOffset As Double
    Get
    Set
Visual C++
public:
property double BottomAnnotationCropOffset {
    double get ();
    void set (double value);
}

Remarks

This value must be a non-negative length in view units. Default value is 1/12' (1"), minimal value is 1/96' (1/8"). To get offset in model units, multiply the value by the view scale.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for offset must be non-negative.
Autodesk.Revit.Exceptions..::..InvalidOperationException | View is not allowed to have an annotation crop.

See Also

ViewCropRegionShapeManager Class


CanBeSplit Property

[image]

Revit 2024 API
ViewCropRegionShapeManager..::..CanBeSplit Property
ViewCropRegionShapeManager Class See Also Send Feedback
Verifies that the crop of the associated view is permitted to have multiple regions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool CanBeSplit { get; }
Visual Basic
Public ReadOnly Property CanBeSplit As Boolean
    Get
Visual C++
public:
property bool CanBeSplit {
    bool get ();
}

See Also

ViewCropRegionShapeManager Class


CanHaveAnnotationCrop Property

[image]

Revit 2024 API
ViewCropRegionShapeManager..::..CanHaveAnnotationCrop Property
ViewCropRegionShapeManager Class See Also Send Feedback
Verifies that the view is allowed to have an annotation crop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool CanHaveAnnotationCrop { get; }
Visual Basic
Public ReadOnly Property CanHaveAnnotationCrop As Boolean
    Get
Visual C++
public:
property bool CanHaveAnnotationCrop {
    bool get ();
}

See Also

ViewCropRegionShapeManager Class


CanHaveShape Property

[image]

Revit 2024 API
ViewCropRegionShapeManager..::..CanHaveShape Property
ViewCropRegionShapeManager Class See Also Send Feedback
Verifies that the crop of the associated view is permitted to have a non-rectangular shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool CanHaveShape { get; }
Visual Basic
Public ReadOnly Property CanHaveShape As Boolean
    Get
Visual C++
public:
property bool CanHaveShape {
    bool get ();
}

See Also

ViewCropRegionShapeManager Class


IsSplitHorizontally Property

[image]

Revit 2024 API
ViewCropRegionShapeManager..::..IsSplitHorizontally Property
ViewCropRegionShapeManager Class See Also Send Feedback
Whether or not the view's crop is split (and the split is horizontal).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool IsSplitHorizontally { get; }
Visual Basic
Public ReadOnly Property IsSplitHorizontally As Boolean
    Get
Visual C++
public:
property bool IsSplitHorizontally {
    bool get ();
}

See Also

ViewCropRegionShapeManager Class


IsSplitVertically Property

[image]

Revit 2024 API
ViewCropRegionShapeManager..::..IsSplitVertically Property
ViewCropRegionShapeManager Class See Also Send Feedback
Whether or not the view's crop is split (and the split is vertical).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool IsSplitVertically { get; }
Visual Basic
Public ReadOnly Property IsSplitVertically As Boolean
    Get
Visual C++
public:
property bool IsSplitVertically {
    bool get ();
}

See Also

ViewCropRegionShapeManager Class


LeftAnnotationCropOffset Property

[image]

Revit 2024 API
ViewCropRegionShapeManager..::..LeftAnnotationCropOffset Property
ViewCropRegionShapeManager Class See Also Send Feedback
The offset from the left of the view crop that determines the location of the annotation crop left boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public double LeftAnnotationCropOffset { get; set; }
Visual Basic
Public Property LeftAnnotationCropOffset As Double
    Get
    Set
Visual C++
public:
property double LeftAnnotationCropOffset {
    double get ();
    void set (double value);
}

Remarks

This value must be a non-negative length in view units. Default value is 1/12' (1"), minimal value is 1/96' (1/8"). To get offset in model units, multiply the value by the view scale.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for offset must be non-negative.
Autodesk.Revit.Exceptions..::..InvalidOperationException | View is not allowed to have an annotation crop.

See Also

ViewCropRegionShapeManager Class


NumberOfSplitRegions Property

[image]

Revit 2024 API
ViewCropRegionShapeManager..::..NumberOfSplitRegions Property
ViewCropRegionShapeManager Class See Also Send Feedback
The number of split crop regions (1 if the crop is not currently split).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public int NumberOfSplitRegions { get; }
Visual Basic
Public ReadOnly Property NumberOfSplitRegions As Integer
    Get
Visual C++
public:
property int NumberOfSplitRegions {
    int get ();
}

See Also

ViewCropRegionShapeManager Class


RightAnnotationCropOffset Property

[image]

Revit 2024 API
ViewCropRegionShapeManager..::..RightAnnotationCropOffset Property
ViewCropRegionShapeManager Class See Also Send Feedback
The offset from the right of the view crop that determines the location of the annotation crop right boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public double RightAnnotationCropOffset { get; set; }
Visual Basic
Public Property RightAnnotationCropOffset As Double
    Get
    Set
Visual C++
public:
property double RightAnnotationCropOffset {
    double get ();
    void set (double value);
}

Remarks

This value must be a non-negative length in view units. Default value is 1/12' (1"), minimal value is 1/96' (1/8"). To get offset in model units, multiply the value by the view scale.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for offset must be non-negative.
Autodesk.Revit.Exceptions..::..InvalidOperationException | View is not allowed to have an annotation crop.

See Also

ViewCropRegionShapeManager Class


ShapeSet Property

[image]

Revit 2024 API
ViewCropRegionShapeManager..::..ShapeSet Property
ViewCropRegionShapeManager Class See Also Send Feedback
Whether or not the view crop has a non-rectangular shape set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool ShapeSet { get; }
Visual Basic
Public ReadOnly Property ShapeSet As Boolean
    Get
Visual C++
public:
property bool ShapeSet {
    bool get ();
}

Remarks

This property reflects the actual shape of the crop region. Thus, if this property is true the view Split property is false.

See Also

ViewCropRegionShapeManager Class


Split Property

[image]

Revit 2024 API
ViewCropRegionShapeManager..::..Split Property
ViewCropRegionShapeManager Class See Also Send Feedback
Whether or not the view crop is split.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool Split { get; }
Visual Basic
Public ReadOnly Property Split As Boolean
    Get
Visual C++
public:
property bool Split {
    bool get ();
}

Remarks

This property reflects the actual visual split of the crop region. Thus, if the view has non-rectangular crop shape set, this property is false.

See Also

ViewCropRegionShapeManager Class


TopAnnotationCropOffset Property

[image]

Revit 2024 API
ViewCropRegionShapeManager..::..TopAnnotationCropOffset Property
ViewCropRegionShapeManager Class See Also Send Feedback
The offset from the top of the view crop that determines the location of the annotation crop top boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public double TopAnnotationCropOffset { get; set; }
Visual Basic
Public Property TopAnnotationCropOffset As Double
    Get
    Set
Visual C++
public:
property double TopAnnotationCropOffset {
    double get ();
    void set (double value);
}

Remarks

This value must be a non-negative length in view units. Default value is 1/12' (1"), minimal value is 1/96' (1/8"). To get offset in model units, multiply the value by the view scale.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for offset must be non-negative.
Autodesk.Revit.Exceptions..::..InvalidOperationException | View is not allowed to have an annotation crop.

See Also

ViewCropRegionShapeManager Class


ViewDetailLevel Enumeration

[image]

Revit 2024 API
ViewDetailLevel Enumeration
See Also Send Feedback
Detail level of the view

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public enum ViewDetailLevel
Visual Basic
Public Enumeration ViewDetailLevel
Visual C++
public enum class ViewDetailLevel

Members

Member name | Description
Undefined | View does not use Detail Level
Coarse | Coarse
Medium | Medium
Fine | Fine

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


ViewDiscipline Enumeration

[image]

Revit 2024 API
ViewDiscipline Enumeration
See Also Send Feedback
Discipline of the view

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public enum ViewDiscipline
Visual Basic
Public Enumeration ViewDiscipline
Visual C++
public enum class ViewDiscipline

Members

Member name | Description
Architectural | Architectural
Structural | Structural
Mechanical | Mechanical
Electrical | Electrical
Plumbing | Plumbing
Coordination | Coordination

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


ViewDisplayBackground Class

[image]

Revit 2024 API
ViewDisplayBackground Class
Members See Also Send Feedback
Set of values that control how background is drawn in a view. Background can only be set for a 3d view or for a section or elevation view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class ViewDisplayBackground : IDisposable
Visual Basic
Public Class ViewDisplayBackground _
    Implements IDisposable
Visual C++
public ref class ViewDisplayBackground : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ViewDisplayBackground

See Also

ViewDisplayBackground Members


ViewDisplayBackground Members

[image] [image]

Revit 2024 API
ViewDisplayBackground Members
ViewDisplayBackground Class Methods Properties See Also Send Feedback

The ViewDisplayBackground type exposes the following members.

Methods

 | Name | Description
 | CreateGradient | Creates an object that can be passed to View.SetBackground method to set the background of the Gradient type.
 | CreateImage | Creates an object that can be passed to View.SetBackground method to set the background of the Image type.
 | CreateSky | Creates an object that can be passed to View.SetBackground method to set the background of the SunAndClouds type.
Public method | Dispose | Releases all resources used by the ViewDisplayBackground
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BackgroundColor | The color of the horizon when the type is 'Gradient'.
Public property | GroundColor | The color of the ground when the type is 'Gradient' or 'SunAndClouds'.
Public property | HorizontalImageOffset | The distance between the left viewport boundary and the left edge of the background image.
Public property | HorizontalImageScale | The horizontal scale of the background image; the scale of 1.0 puts the image pixel-to-pixel.
Public property | ImageFlags | The image alignment indicators when the type is 'Image'.
Public property | ImagePath | The path to the image file when the type is 'Image'.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SkyColor | The color of the sky when the type is 'Gradient'.
Public property | Type | The type of the background.
Public property | VerticalImageOffset | The distance between the bottom viewport boundary and the bottom edge of the background image.
Public property | VerticalImageScale | The vertical scale of the background image; the scale of 1.0 puts the image pixel-to-pixel.

See Also

ViewDisplayBackground Class


ViewDisplayBackground Methods

[image] [image]

Revit 2024 API
ViewDisplayBackground Methods
ViewDisplayBackground Class See Also Send Feedback

The ViewDisplayBackground type exposes the following members.

Methods

 | Name | Description
 | CreateGradient | Creates an object that can be passed to View.SetBackground method to set the background of the Gradient type.
 | CreateImage | Creates an object that can be passed to View.SetBackground method to set the background of the Image type.
 | CreateSky | Creates an object that can be passed to View.SetBackground method to set the background of the SunAndClouds type.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ViewDisplayBackground Class


CreateGradient Method

[image]

Revit 2024 API
ViewDisplayBackground..::..CreateGradient Method
ViewDisplayBackground Class See Also Send Feedback
Creates an object that can be passed to View.SetBackground method to set the background of the Gradient type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static ViewDisplayBackground CreateGradient(
    Color skyColor,
    Color horizonColor,
    Color groundColor
)
Visual Basic
Public Shared Function CreateGradient ( _
    skyColor As Color, _
    horizonColor As Color, _
    groundColor As Color _
) As ViewDisplayBackground
Visual C++
public:
static ViewDisplayBackground^ CreateGradient(
    Color^ skyColor,
    Color^ horizonColor,
    Color^ groundColor
)

Parameters

skyColor
Type: Autodesk.Revit.DB..::..Color
The top of the sky gradient if the sky is visible.
horizonColor
Type: Autodesk.Revit.DB..::..Color
The bottom or the sky gradient if the sky is visible, or the top of the ground gradient otherwise.
groundColor
Type: Autodesk.Revit.DB..::..Color
The ground color if the sky is visible (ground shown in uniform color), or the bottom of the ground gradient if the sky is not visible.

Return Value

New background object to pass to View.SetBackground.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ViewDisplayBackground Class


CreateImage Method

[image]

Revit 2024 API
ViewDisplayBackground..::..CreateImage Method
ViewDisplayBackground Class See Also Send Feedback
Creates an object that can be passed to View.SetBackground method to set the background of the Image type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static ViewDisplayBackground CreateImage(
    string imagePath,
    ViewDisplayBackgroundImageFlags flags,
    UV imageOffsets,
    UV imageScales
)
Visual Basic
Public Shared Function CreateImage ( _
    imagePath As String, _
    flags As ViewDisplayBackgroundImageFlags, _
    imageOffsets As UV, _
    imageScales As UV _
) As ViewDisplayBackground
Visual C++
public:
static ViewDisplayBackground^ CreateImage(
    String^ imagePath,
    ViewDisplayBackgroundImageFlags flags,
    UV^ imageOffsets,
    UV^ imageScales
)

Parameters

imagePath
Type: System..::..String
File path with the image to be used.
flags
Type: Autodesk.Revit.DB..::..ViewDisplayBackgroundImageFlags
Combination of flags (binary) that control how image is displayed in relation to the view/crop boundary.
imageOffsets
Type: Autodesk.Revit.DB..::..UV
Horizontal (u) and vertical (v) offsets of the image.
imageScales
Type: Autodesk.Revit.DB..::..UV
Horizontal (u) and vertical (v) scales of the image (1 == no change).

Return Value

New background object to pass to View.SetBackground.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The file specified by imagePath is not an image file. A valid image file should be in one of the following formats: bmp, jpg, jpeg, png, tif.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | The file specified by imagePath doesn't exist.

See Also

ViewDisplayBackground Class


CreateSky Method

[image]

Revit 2024 API
ViewDisplayBackground..::..CreateSky Method
ViewDisplayBackground Class See Also Send Feedback
Creates an object that can be passed to View.SetBackground method to set the background of the SunAndClouds type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public static ViewDisplayBackground CreateSky()
Visual Basic
Public Shared Function CreateSky As ViewDisplayBackground
Visual C++
public:
static ViewDisplayBackground^ CreateSky()

Return Value

New background object to pass to View.SetBackground.

See Also

ViewDisplayBackground Class


Dispose Method

[image]

Revit 2024 API
ViewDisplayBackground..::..Dispose Method
ViewDisplayBackground Class See Also Send Feedback
Releases all resources used by the ViewDisplayBackground

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ViewDisplayBackground Class


ViewDisplayBackground Properties

[image] [image]

Revit 2024 API
ViewDisplayBackground Properties
ViewDisplayBackground Class See Also Send Feedback

The ViewDisplayBackground type exposes the following members.

Properties

 | Name | Description
Public property | BackgroundColor | The color of the horizon when the type is 'Gradient'.
Public property | GroundColor | The color of the ground when the type is 'Gradient' or 'SunAndClouds'.
Public property | HorizontalImageOffset | The distance between the left viewport boundary and the left edge of the background image.
Public property | HorizontalImageScale | The horizontal scale of the background image; the scale of 1.0 puts the image pixel-to-pixel.
Public property | ImageFlags | The image alignment indicators when the type is 'Image'.
Public property | ImagePath | The path to the image file when the type is 'Image'.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SkyColor | The color of the sky when the type is 'Gradient'.
Public property | Type | The type of the background.
Public property | VerticalImageOffset | The distance between the bottom viewport boundary and the bottom edge of the background image.
Public property | VerticalImageScale | The vertical scale of the background image; the scale of 1.0 puts the image pixel-to-pixel.

See Also

ViewDisplayBackground Class


BackgroundColor Property

[image]

Revit 2024 API
ViewDisplayBackground..::..BackgroundColor Property
ViewDisplayBackground Class See Also Send Feedback
The color of the horizon when the type is 'Gradient'.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public Color BackgroundColor { get; }
Visual Basic
Public ReadOnly Property BackgroundColor As Color
    Get
Visual C++
public:
property Color^ BackgroundColor {
    Color^ get ();
}

See Also

ViewDisplayBackground Class


GroundColor Property

[image]

Revit 2024 API
ViewDisplayBackground..::..GroundColor Property
ViewDisplayBackground Class See Also Send Feedback
The color of the ground when the type is 'Gradient' or 'SunAndClouds'.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public Color GroundColor { get; }
Visual Basic
Public ReadOnly Property GroundColor As Color
    Get
Visual C++
public:
property Color^ GroundColor {
    Color^ get ();
}

See Also

ViewDisplayBackground Class


HorizontalImageOffset Property

[image]

Revit 2024 API
ViewDisplayBackground..::..HorizontalImageOffset Property
ViewDisplayBackground Class See Also Send Feedback
The distance between the left viewport boundary and the left edge of the background image.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public double HorizontalImageOffset { get; }
Visual Basic
Public ReadOnly Property HorizontalImageOffset As Double
    Get
Visual C++
public:
property double HorizontalImageOffset {
    double get ();
}

See Also

ViewDisplayBackground Class


ImageFlags Property

[image]

Revit 2024 API
ViewDisplayBackground..::..ImageFlags Property
ViewDisplayBackground Class See Also Send Feedback
The image alignment indicators when the type is 'Image'.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ViewDisplayBackgroundImageFlags ImageFlags { get; }
Visual Basic
Public ReadOnly Property ImageFlags As ViewDisplayBackgroundImageFlags
    Get
Visual C++
public:
property ViewDisplayBackgroundImageFlags ImageFlags {
    ViewDisplayBackgroundImageFlags get ();
}

See Also

ViewDisplayBackground Class


IsValidObject Property

[image]

Revit 2024 API
ViewDisplayBackground..::..IsValidObject Property
ViewDisplayBackground Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ViewDisplayBackground Class


SkyColor Property

[image]

Revit 2024 API
ViewDisplayBackground..::..SkyColor Property
ViewDisplayBackground Class See Also Send Feedback
The color of the sky when the type is 'Gradient'.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public Color SkyColor { get; }
Visual Basic
Public ReadOnly Property SkyColor As Color
    Get
Visual C++
public:
property Color^ SkyColor {
    Color^ get ();
}

See Also

ViewDisplayBackground Class


Type Property

[image]

Revit 2024 API
ViewDisplayBackground..::..Type Property
ViewDisplayBackground Class See Also Send Feedback
The type of the background.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ViewDisplayBackgroundType Type { get; }
Visual Basic
Public ReadOnly Property Type As ViewDisplayBackgroundType
    Get
Visual C++
public:
property ViewDisplayBackgroundType Type {
    ViewDisplayBackgroundType get ();
}

See Also

ViewDisplayBackground Class


VerticalImageScale Property

[image]

Revit 2024 API
ViewDisplayBackground..::..VerticalImageScale Property
ViewDisplayBackground Class See Also Send Feedback
The vertical scale of the background image; the scale of 1.0 puts the image pixel-to-pixel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public double VerticalImageScale { get; }
Visual Basic
Public ReadOnly Property VerticalImageScale As Double
    Get
Visual C++
public:
property double VerticalImageScale {
    double get ();
}

See Also

ViewDisplayBackground Class


ViewDisplayBackgroundImageFlags Enumeration

[image]

Revit 2024 API
ViewDisplayBackgroundImageFlags Enumeration
See Also Send Feedback
A collection of bit flags that control how the background image is positioned in relation to the crop region (or the view boundary).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public enum ViewDisplayBackgroundImageFlags
Visual Basic
Public Enumeration ViewDisplayBackgroundImageFlags
Visual C++
public enum class ViewDisplayBackgroundImageFlags

Members

Member name | Description
None | The image is displayed pixel-to-pixel
FitToScreen | The image is stretched in both directions
FixedAspectRatio | The image is stretched but the ratio of its height to width is preserved.
UseTiling | The pixels of the background are filled by tiling of the image.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


ViewDisplayDepthCueing Class

[image]

Revit 2024 API
ViewDisplayDepthCueing Class
Members Example See Also Send Feedback
Represents the settings for depth cueing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public class ViewDisplayDepthCueing : IDisposable
Visual Basic
Public Class ViewDisplayDepthCueing _
    Implements IDisposable
Visual C++
public ref class ViewDisplayDepthCueing : IDisposable

Examples

CopyC#
private void AdjustDepthCueing(View view)
{
    if (view.CanUseDepthCueing())
    {
        using (Transaction t = new Transaction(view.Document, "Change depth cueing"))
        {
            t.Start();
            ViewDisplayDepthCueing depthCueing = view.GetDepthCueing();
            depthCueing.EnableDepthCueing = true;
            depthCueing.FadeTo = 50;    // set fade to percent
            depthCueing.SetStartEndPercentages(0, 75);
            view.SetDepthCueing(depthCueing);
            t.Commit();
        }
    }
}
CopyVB.NET
Private Sub AdjustDepthCueing(view As View)
    If view.CanUseDepthCueing() Then
        Using t As New Transaction(view.Document, "Change depth cueing")
            t.Start()
            Dim depthCueing As ViewDisplayDepthCueing = view.GetDepthCueing()
            depthCueing.EnableDepthCueing = True
            depthCueing.FadeTo = 50
            ' set fade to percent
            depthCueing.SetStartEndPercentages(0, 75)
            view.SetDepthCueing(depthCueing)
            t.Commit()
        End Using
    End If
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ViewDisplayDepthCueing

See Also

ViewDisplayDepthCueing Members


ViewDisplayDepthCueing Members

[image] [image]

Revit 2024 API
ViewDisplayDepthCueing Members
ViewDisplayDepthCueing Class Methods Properties See Also Send Feedback

The ViewDisplayDepthCueing type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ViewDisplayDepthCueing
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetStartEndPercentages | Sets start and end percentages.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | EnableDepthCueing | True to enable depth cueing. False to disable it.
Public property | EndPercentage | The end percentage defines where depth cueing ends. Values between 0 and 100.
Public property | FadeTo | The fade to defines the maximum fading in per cent. Values between 0 and 100.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | StartPercentage | The start percentage defines where depth cueing starts. Values between 0 and 100.

See Also

ViewDisplayDepthCueing Class


ViewDisplayDepthCueing Methods

[image] [image]

Revit 2024 API
ViewDisplayDepthCueing Methods
ViewDisplayDepthCueing Class See Also Send Feedback

The ViewDisplayDepthCueing type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetStartEndPercentages | Sets start and end percentages.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ViewDisplayDepthCueing Class


Dispose Method

[image]

Revit 2024 API
ViewDisplayDepthCueing..::..Dispose Method
ViewDisplayDepthCueing Class See Also Send Feedback
Releases all resources used by the ViewDisplayDepthCueing

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ViewDisplayDepthCueing Class


SetStartEndPercentages Method

[image]

Revit 2024 API
ViewDisplayDepthCueing..::..SetStartEndPercentages Method
ViewDisplayDepthCueing Class See Also Send Feedback
Sets start and end percentages.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public void SetStartEndPercentages(
    int startPercentage,
    int endPercentage
)
Visual Basic
Public Sub SetStartEndPercentages ( _
    startPercentage As Integer, _
    endPercentage As Integer _
)
Visual C++
public:
void SetStartEndPercentages(
    int startPercentage,
    int endPercentage
)

Parameters

startPercentage
Type: System..::..Int32
The start percentage defines where depth cueing starts.
endPercentage
Type: System..::..Int32
The end percentage defines where depth cueing ends.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The start and end percentages values are not valid. The valid range is 0 to 100 and start is smaller than end.

See Also

ViewDisplayDepthCueing Class


EnableDepthCueing Property

[image]

Revit 2024 API
ViewDisplayDepthCueing..::..EnableDepthCueing Property
ViewDisplayDepthCueing Class See Also Send Feedback
True to enable depth cueing. False to disable it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public bool EnableDepthCueing { get; set; }
Visual Basic
Public Property EnableDepthCueing As Boolean
    Get
    Set
Visual C++
public:
property bool EnableDepthCueing {
    bool get ();
    void set (bool value);
}

See Also

ViewDisplayDepthCueing Class


EndPercentage Property

[image]

Revit 2024 API
ViewDisplayDepthCueing..::..EndPercentage Property
ViewDisplayDepthCueing Class See Also Send Feedback
The end percentage defines where depth cueing ends. Values between 0 and 100.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public int EndPercentage { get; }
Visual Basic
Public ReadOnly Property EndPercentage As Integer
    Get
Visual C++
public:
property int EndPercentage {
    int get ();
}

See Also

ViewDisplayDepthCueing Class


FadeTo Property

[image]

Revit 2024 API
ViewDisplayDepthCueing..::..FadeTo Property
ViewDisplayDepthCueing Class See Also Send Feedback
The fade to defines the maximum fading in per cent. Values between 0 and 100.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public int FadeTo { get; set; }
Visual Basic
Public Property FadeTo As Integer
    Get
    Set
Visual C++
public:
property int FadeTo {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The fade to value is not valid. The valid range is 0 to 100.

See Also

ViewDisplayDepthCueing Class


IsValidObject Property

[image]

Revit 2024 API
ViewDisplayDepthCueing..::..IsValidObject Property
ViewDisplayDepthCueing Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ViewDisplayDepthCueing Class


StartPercentage Property

[image]

Revit 2024 API
ViewDisplayDepthCueing..::..StartPercentage Property
ViewDisplayDepthCueing Class See Also Send Feedback
The start percentage defines where depth cueing starts. Values between 0 and 100.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public int StartPercentage { get; }
Visual Basic
Public ReadOnly Property StartPercentage As Integer
    Get
Visual C++
public:
property int StartPercentage {
    int get ();
}

See Also

ViewDisplayDepthCueing Class


ViewDisplayEdges Enumeration

[image]

Revit 2024 API
ViewDisplayEdges Enumeration
See Also Send Feedback
A collection of settings defining how visible edges are displayed

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public enum ViewDisplayEdges
Visual Basic
Public Enumeration ViewDisplayEdges
Visual C++
public enum class ViewDisplayEdges

Members

Member name | Description
None | The edges are invisible
Simple | The edges are visible and drawn according to style

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


ViewDisplayModel Class

[image]

Revit 2024 API
ViewDisplayModel Class
Members See Also Send Feedback
Represents the settings for displaying model graphics. version 2: m_showHiddenLines type changed bool -> ShowHiddenLinesValues::Enum

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public class ViewDisplayModel : IDisposable
Visual Basic
Public Class ViewDisplayModel _
    Implements IDisposable
Visual C++
public ref class ViewDisplayModel : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ViewDisplayModel

See Also

ViewDisplayModel Members


ViewDisplayModel Members

[image] [image]

Revit 2024 API
ViewDisplayModel Members
ViewDisplayModel Class Methods Properties See Also Send Feedback

The ViewDisplayModel type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ViewDisplayModel
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | EnableSilhouettes | True to show silhouettes edges. False to disable showing them.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ShowHiddenLines | True to enable hidden lines. False to disable showing them.
Public property | SilhouetteEdgesGStyleId | Style ID for silhouette edges
Public property | SmoothEdges | True to enable "smooth edge" (anti-aliasing) effect. False to disable it.
Public property | Transparency | The percentage (0..100) of surface transparency 0 means the surfaces are opaque, 100 means they are fully transparent

See Also

ViewDisplayModel Class


ViewDisplayModel Methods

[image] [image]

Revit 2024 API
ViewDisplayModel Methods
ViewDisplayModel Class See Also Send Feedback

The ViewDisplayModel type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ViewDisplayModel Class


Dispose Method

[image]

Revit 2024 API
ViewDisplayModel..::..Dispose Method
ViewDisplayModel Class See Also Send Feedback
Releases all resources used by the ViewDisplayModel

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ViewDisplayModel Class


ViewDisplayModel Properties

[image] [image]

Revit 2024 API
ViewDisplayModel Properties
ViewDisplayModel Class See Also Send Feedback

The ViewDisplayModel type exposes the following members.

Properties

 | Name | Description
Public property | EnableSilhouettes | True to show silhouettes edges. False to disable showing them.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ShowHiddenLines | True to enable hidden lines. False to disable showing them.
Public property | SilhouetteEdgesGStyleId | Style ID for silhouette edges
Public property | SmoothEdges | True to enable "smooth edge" (anti-aliasing) effect. False to disable it.
Public property | Transparency | The percentage (0..100) of surface transparency 0 means the surfaces are opaque, 100 means they are fully transparent

See Also

ViewDisplayModel Class


EnableSilhouettes Property

[image]

Revit 2024 API
ViewDisplayModel..::..EnableSilhouettes Property
ViewDisplayModel Class See Also Send Feedback
True to show silhouettes edges. False to disable showing them.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool EnableSilhouettes { get; set; }
Visual Basic
Public Property EnableSilhouettes As Boolean
    Get
    Set
Visual C++
public:
property bool EnableSilhouettes {
    bool get ();
    void set (bool value);
}

See Also

ViewDisplayModel Class


IsValidObject Property

[image]

Revit 2024 API
ViewDisplayModel..::..IsValidObject Property
ViewDisplayModel Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ViewDisplayModel Class


ShowHiddenLines Property

[image]

Revit 2024 API
ViewDisplayModel..::..ShowHiddenLines Property
ViewDisplayModel Class See Also Send Feedback
True to enable hidden lines. False to disable showing them.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public ShowHiddenLinesValues ShowHiddenLines { get; set; }
Visual Basic
Public Property ShowHiddenLines As ShowHiddenLinesValues
    Get
    Set
Visual C++
public:
property ShowHiddenLinesValues ShowHiddenLines {
    ShowHiddenLinesValues get ();
    void set (ShowHiddenLinesValues value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

ViewDisplayModel Class


SilhouetteEdgesGStyleId Property

[image]

Revit 2024 API
ViewDisplayModel..::..SilhouetteEdgesGStyleId Property
ViewDisplayModel Class See Also Send Feedback
Style ID for silhouette edges

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public ElementId SilhouetteEdgesGStyleId { get; set; }
Visual Basic
Public Property SilhouetteEdgesGStyleId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ SilhouetteEdgesGStyleId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ViewDisplayModel Class


SmoothEdges Property

[image]

Revit 2024 API
ViewDisplayModel..::..SmoothEdges Property
ViewDisplayModel Class See Also Send Feedback
True to enable "smooth edge" (anti-aliasing) effect. False to disable it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool SmoothEdges { get; set; }
Visual Basic
Public Property SmoothEdges As Boolean
    Get
    Set
Visual C++
public:
property bool SmoothEdges {
    bool get ();
    void set (bool value);
}

See Also

ViewDisplayModel Class


ViewDisplaySketchyLines Class

[image]

Revit 2024 API
ViewDisplaySketchyLines Class
Members See Also Send Feedback
Represents the settings for sketchy lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public class ViewDisplaySketchyLines : IDisposable
Visual Basic
Public Class ViewDisplaySketchyLines _
    Implements IDisposable
Visual C++
public ref class ViewDisplaySketchyLines : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ViewDisplaySketchyLines

See Also

ViewDisplaySketchyLines Members


ViewDisplaySketchyLines Members

[image] [image]

Revit 2024 API
ViewDisplaySketchyLines Members
ViewDisplaySketchyLines Class Methods Properties See Also Send Feedback

The ViewDisplaySketchyLines type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ViewDisplaySketchyLines
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | EnableSketchyLines | True to enable sketchy lines visibility. False to disable it.
Public property | Extension | The extension scale value. Controls the magnitude of line's extension. Values between 0 and 10.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Jitter | The jitter defines jitteriness of the line. Values between 0 and 10.

See Also

ViewDisplaySketchyLines Class


ViewDisplaySketchyLines Methods

[image] [image]

Revit 2024 API
ViewDisplaySketchyLines Methods
ViewDisplaySketchyLines Class See Also Send Feedback

The ViewDisplaySketchyLines type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ViewDisplaySketchyLines Class


Dispose Method

[image]

Revit 2024 API
ViewDisplaySketchyLines..::..Dispose Method
ViewDisplaySketchyLines Class See Also Send Feedback
Releases all resources used by the ViewDisplaySketchyLines

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ViewDisplaySketchyLines Class


ViewDisplaySketchyLines Properties

[image] [image]

Revit 2024 API
ViewDisplaySketchyLines Properties
ViewDisplaySketchyLines Class See Also Send Feedback

The ViewDisplaySketchyLines type exposes the following members.

Properties

 | Name | Description
Public property | EnableSketchyLines | True to enable sketchy lines visibility. False to disable it.
Public property | Extension | The extension scale value. Controls the magnitude of line's extension. Values between 0 and 10.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Jitter | The jitter defines jitteriness of the line. Values between 0 and 10.

See Also

ViewDisplaySketchyLines Class


EnableSketchyLines Property

[image]

Revit 2024 API
ViewDisplaySketchyLines..::..EnableSketchyLines Property
ViewDisplaySketchyLines Class See Also Send Feedback
True to enable sketchy lines visibility. False to disable it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool EnableSketchyLines { get; set; }
Visual Basic
Public Property EnableSketchyLines As Boolean
    Get
    Set
Visual C++
public:
property bool EnableSketchyLines {
    bool get ();
    void set (bool value);
}

See Also

ViewDisplaySketchyLines Class


Extension Property

[image]

Revit 2024 API
ViewDisplaySketchyLines..::..Extension Property
ViewDisplaySketchyLines Class See Also Send Feedback
The extension scale value. Controls the magnitude of line's extension. Values between 0 and 10.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public int Extension { get; set; }
Visual Basic
Public Property Extension As Integer
    Get
    Set
Visual C++
public:
property int Extension {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The extension value is not valid. The valid range is 0 to 10.

See Also

ViewDisplaySketchyLines Class


IsValidObject Property

[image]

Revit 2024 API
ViewDisplaySketchyLines..::..IsValidObject Property
ViewDisplaySketchyLines Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ViewDisplaySketchyLines Class


Jitter Property

[image]

Revit 2024 API
ViewDisplaySketchyLines..::..Jitter Property
ViewDisplaySketchyLines Class See Also Send Feedback
The jitter defines jitteriness of the line. Values between 0 and 10.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public int Jitter { get; set; }
Visual Basic
Public Property Jitter As Integer
    Get
    Set
Visual C++
public:
property int Jitter {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The jitter value is not valid. The valid range is 0 to 10.

See Also

ViewDisplaySketchyLines Class


ViewDrafting Members

[image] [image]

Revit 2024 API
ViewDrafting Members
ViewDrafting Class Methods Properties See Also Send Feedback

The ViewDrafting type exposes the following members.

Methods

 | Name | Description
Public method | AddFilter | Adds a filter to the view. (Inherited from View.)
Public method | AllowsAnalysisDisplay | Identifies if this view allows display of Analysis results. (Inherited from View.)
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of the input view that are not controlled by the current view template. (Inherited from View.)
Public method | AreGraphicsOverridesAllowed | Determines if Visibility/Graphics Overriddes can be applied to the view. (Inherited from View.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanApplyColorFillScheme | Checks if the id can be applied as the scheme id of specified category to this view. (Inherited from View.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanCategoryBeHidden | Checks whether the category can be hidden in the view. (Inherited from View.)
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view. (Inherited from View.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanEnableTemporaryViewPropertiesMode | Indicates if Temporary View Properties mode can be applied for view in current state. (Inherited from View.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified. (Inherited from View.)
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified. (Inherited from View.)
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified (Inherited from View.)
Public method | CanUseDepthCueing | Indicates if view can use Depth Cueing (Inherited from View.)
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes (Inherited from View.)
Public method | CanViewBeDuplicated | Identifies if this view can be duplicated. (Inherited from View.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view. (Inherited from View.)
Public method | ConvertToIndependent | Convert the dependent view to independent. (Inherited from View.)
 | Create | Creates a new ViewDrafting in the model.
Public method | CreateViewTemplate | Creates a new view template instance from this view instance. (Inherited from View.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode. (Inherited from View.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates this view. (Inherited from View.)
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode. (Inherited from View.)
Public method | EnableTemporaryViewPropertiesMode | Turns Temporary View Properties mode on or off. In this mode, any changes made to the view are temporary and will be discarded once the mode is disabled. (Inherited from View.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetBackground | Returns the current background set for the view. (Inherited from View.)
Public method | GetCalloutParentId | Gets ID of the callout parent view. (Inherited from View.)
Public method | GetCategoryHidden | Checks if elements of the given category are set to be invisible (hidden) in this view. (Inherited from View.)
Public method | GetCategoryOverrides | Gets graphic overrides for a category in view. (Inherited from View.)
Public method | GetColorFillSchemeId | Returns id of the color fill scheme element applied to the view. (Inherited from View.)
Public method | GetCropRegionShapeManager | Returns an object for managing view crop region shape. (Inherited from View.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetDependentViewIds | Get the ids of dependent views. (Inherited from View.)
Public method | GetDepthCueing | Returns the current depth cueing settings for the view. (Inherited from View.)
Public method | GetDirectContext3DHandleOverrides | Returns DirectContext3D handle overrides object for the view. (Inherited from View.)
Public method | GetElementOverrides | Gets graphic overrides for an element in the view. (Inherited from View.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetFilterOverrides | Gets graphic overrides that a filter applies to the view. (Inherited from View.)
Public method | GetFilters | Gets the filters applied to the view. (Inherited from View.)
Public method | GetFilterVisibility | Gets the visibility of the elements associated with a filter. (Inherited from View.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIsFilterEnabled | Identifies if the filter is enabled in this view. (Inherited from View.)
Public method | GetLinkOverrides | Gets the graphic overrides of a RevitLinkType or RevitLinkInstance in view. (Inherited from View.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetModelToProjectionTransforms | Gets the transforms from the model space to the view projection space. (Inherited from View.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetNonControlledTemplateParameterIds | Returns a list of parameters that are not marked as included when this view is used as a template. (Inherited from View.)
Public method | GetOrderedFilters | Gets the filters applied to the view in the order they are applied. (Inherited from View.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPlacementOnSheetStatus | Determines if this view placed on a sheet completely or partially. (Inherited from View.)
Public method | GetPointCloudOverrides | Returns point cloud overrides object for the view. (Inherited from View.)
Public method | GetPrimaryViewId | Get the id of the primary view. (Inherited from View.)
Public method | GetReferenceCallouts | Returns element ids of all reference callouts in the view. (Inherited from View.)
Public method | GetReferenceElevations | Returns element ids of all reference elevations in the view. (Inherited from View.)
Public method | GetReferenceSections | Returns element ids of all reference sections in the view. (Inherited from View.)
Public method | GetSketchyLines | Returns the current sketchy lines settings for the view. (Inherited from View.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetTemplateParameterIds | Returns a list of parameter ids that may be controlled when this view is assigned as a template. (Inherited from View.)
Public method | GetTemporaryViewPropertiesId | When Temporary View Properties mode is in progress it provides view id that overrode settings for current view. Outside Temporary View Properties mode InvalidElementId will be returned. (Inherited from View.)
Public method | GetTemporaryViewPropertiesName | When Temporary View Properties mode is in progress, name of applied template is returned. Outside Temporary View Properties mode, empty string will be returned. (Inherited from View.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetViewDisplayModel | Returns the current view display model settings for the view. (Inherited from View.)
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view. (Inherited from View.)
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view. (Inherited from View.)
Public method | HasDetailLevel | Check if the view has a Detail Level property (Inherited from View.)
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property (Inherited from View.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property (Inherited from View.)
Public method | HasViewTransforms | Returns true if the view reports model space to view projection space transforms. (Inherited from View.)
Public method | HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View.)
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view. (Inherited from View.)
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view. (Inherited from View.)
Public method | HideElements | Sets the elements to be hidden in the view. (Inherited from View.)
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View.)
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View.)
Public method | IsCategoryOverridable | Checks whether the category can have graphic overrides in this view. (Inherited from View.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view. (Inherited from View.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsFilterApplied | Indicates if a filter is applied to the view. (Inherited from View.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode. (Inherited from View.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View.)
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories. (Inherited from View.)
Public method | IsTemporaryViewPropertiesModeEnabled | Returns true when Temporary View Properties mode is in progress, false otherwise. (Inherited from View.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | IsValidViewTemplate | Verifies that the view represented by templateId can be set as the controlling view template for this view. (Inherited from View.)
Public method | IsViewValidForTemplateCreation | Verifies that the view is valid for template creation. (Inherited from View.)
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view. (Inherited from View.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | RemoveCalloutParent | Replaces callout parent ID with InvalidElementId. (Inherited from View.)
Public method | RemoveFilter | Removes a filter from the view. (Inherited from View.)
Public method | RemoveLinkOverrides | Deletes the graphical link overrides in the current view. (Inherited from View.)
Public method | RestoreCalloutParent | Restores callout parent ID to the original view ID if that view is still available. (Inherited from View.)
Public method | SetBackground | Sets the background for the view. Background can only be set for 3d views and for Sections/Elevations. (Inherited from View.)
Public method | SetCategoryHidden | Sets if elements of the given category will be visible in this view. (Inherited from View.)
Public method | SetCategoryOverrides | Sets graphic overrides for a category in view. (Inherited from View.)
Public method | SetColorFillSchemeId | Applies color fill scheme to this view. (Inherited from View.)
Public method | SetDepthCueing | Sets the depth cueing settings for the view. (Inherited from View.)
Public method | SetElementOverrides | Sets graphic overrides for an element in the view. (Inherited from View.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetFilterOverrides | Sets the overrides associated with a filter. (Inherited from View.)
Public method | SetFilterVisibility | Sets the visibility of the elements associated with a filter. (Inherited from View.)
Public method | SetIsFilterEnabled | Sets the filter enabled flag. (Inherited from View.)
Public method | SetLinkOverrides | Sets the graphic overrides of a RevitLinkType or RevitLinkInstance in the view. (Inherited from View.)
Public method | SetNonControlledTemplateParameterIds | Sets the parameters that will not be included when this view is used as a template. (Inherited from View.)
Public method | SetSketchyLines | Sets the sketchy lines settings for the view. (Inherited from View.)
Public method | SetViewDisplayModel | Sets the view display model settings for the view. (Inherited from View.)
Public method | SetWorksetVisibility | Sets visibility for a workset in this view. (Inherited from View.)
Public method | SetWorksharingDisplayMode | Sets the worksharing display mode for this view. (Inherited from View.)
Public method | ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View.)
Public method | SupportedColorFillCategoryIds | Returns collection of all category ids that correspond to elements that can potentially be colored in this view according to a color fill scheme. The set may be different depending on the view type. (Inherited from View.)
Public method | SupportsRevealConstraints | Checks that the view can have the Reveal Constraints mode activated. (Inherited from View.)
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode. (Inherited from View.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

Properties

 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View.)
Public property | AreAnalyticalModelCategoriesHidden | Indicates if analytical model categories are currently hidden in the view. (Inherited from View.)
Public property | AreAnnotationCategoriesHidden | Indicates if annotation categories are currently hidden in the view. (Inherited from View.)
Public property | AreCoordinationModelHandlesHidden | Indicates if Coordination Model handles are currently hidden in the view. (Inherited from View.)
Public property | AreImportCategoriesHidden | Indicates if import categories are currently hidden in the view. (Inherited from View.)
Public property | AreModelCategoriesHidden | Indicates if model categories are currently hidden in the view. (Inherited from View.)
Public property | ArePointCloudsHidden | Indicates if point clouds are currently hidden in the view. (Inherited from View.)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view. (Inherited from View.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CropBox | The Crop Box applied to the view, or an outline encompassing the crop region applied to the view. (Inherited from View.)
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View.)
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DetailLevel | The detail level of this view. (Inherited from View.)
Public property | Discipline | The Discipline of the view. (Inherited from View.)
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style. (Inherited from View.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | GenLevel | The level for the view. (Inherited from View.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsAssemblyView | Indicates if the view is assembly view. (Inherited from View.)
Public property | IsCallout | Indicates if the view is a callout view. (Inherited from View.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTemplate | Test whether the view is a view template. (Inherited from View.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Origin | Returns the origin of the screen. (Inherited from View.)
Public property | Outline | The bounds of the view in paper space (in feet). (Inherited from View.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PartsVisibility | The visibility setting for parts in this view. (Inherited from View.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RevealConstraintsMode | Indicates whether the Reveal Constraints mode is activated in the view. (Inherited from View.)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Public property | Scale | The scale of the view. (Inherited from View.)
Public property | ShadowIntensity | The intesity of cast shadows - 0 = no shadows, 100 = black. (Inherited from View.)
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View.)
Public property | SunlightIntensity | The intensity of the simulated (directional) sunlight. 0 = no directional light; maximum value is 100. (Inherited from View.)
Public property | TemporaryViewModes | Data of temporary view modes associated with this view. (Inherited from View.)
Public property | Title | The view title. This consists of the view name plus other modifiers, such as the view type, sheet number, area scheme, and/or assembly type, depending on the specifics of the view. (Inherited from View.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | ViewTemplateId | The id of the template view that controls this view's parameters. (Inherited from View.)
Public property | ViewType | The type of the view. (Inherited from View.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ViewDrafting Class


ViewDrafting Methods

[image] [image]

Revit 2024 API
ViewDrafting Methods
ViewDrafting Class See Also Send Feedback

The ViewDrafting type exposes the following members.

Methods

 | Name | Description
Public method | AddFilter | Adds a filter to the view. (Inherited from View.)
Public method | AllowsAnalysisDisplay | Identifies if this view allows display of Analysis results. (Inherited from View.)
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of the input view that are not controlled by the current view template. (Inherited from View.)
Public method | AreGraphicsOverridesAllowed | Determines if Visibility/Graphics Overriddes can be applied to the view. (Inherited from View.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanApplyColorFillScheme | Checks if the id can be applied as the scheme id of specified category to this view. (Inherited from View.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanCategoryBeHidden | Checks whether the category can be hidden in the view. (Inherited from View.)
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view. (Inherited from View.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanEnableTemporaryViewPropertiesMode | Indicates if Temporary View Properties mode can be applied for view in current state. (Inherited from View.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified. (Inherited from View.)
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified. (Inherited from View.)
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified (Inherited from View.)
Public method | CanUseDepthCueing | Indicates if view can use Depth Cueing (Inherited from View.)
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes (Inherited from View.)
Public method | CanViewBeDuplicated | Identifies if this view can be duplicated. (Inherited from View.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view. (Inherited from View.)
Public method | ConvertToIndependent | Convert the dependent view to independent. (Inherited from View.)
 | Create | Creates a new ViewDrafting in the model.
Public method | CreateViewTemplate | Creates a new view template instance from this view instance. (Inherited from View.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode. (Inherited from View.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates this view. (Inherited from View.)
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode. (Inherited from View.)
Public method | EnableTemporaryViewPropertiesMode | Turns Temporary View Properties mode on or off. In this mode, any changes made to the view are temporary and will be discarded once the mode is disabled. (Inherited from View.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetBackground | Returns the current background set for the view. (Inherited from View.)
Public method | GetCalloutParentId | Gets ID of the callout parent view. (Inherited from View.)
Public method | GetCategoryHidden | Checks if elements of the given category are set to be invisible (hidden) in this view. (Inherited from View.)
Public method | GetCategoryOverrides | Gets graphic overrides for a category in view. (Inherited from View.)
Public method | GetColorFillSchemeId | Returns id of the color fill scheme element applied to the view. (Inherited from View.)
Public method | GetCropRegionShapeManager | Returns an object for managing view crop region shape. (Inherited from View.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetDependentViewIds | Get the ids of dependent views. (Inherited from View.)
Public method | GetDepthCueing | Returns the current depth cueing settings for the view. (Inherited from View.)
Public method | GetDirectContext3DHandleOverrides | Returns DirectContext3D handle overrides object for the view. (Inherited from View.)
Public method | GetElementOverrides | Gets graphic overrides for an element in the view. (Inherited from View.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetFilterOverrides | Gets graphic overrides that a filter applies to the view. (Inherited from View.)
Public method | GetFilters | Gets the filters applied to the view. (Inherited from View.)
Public method | GetFilterVisibility | Gets the visibility of the elements associated with a filter. (Inherited from View.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIsFilterEnabled | Identifies if the filter is enabled in this view. (Inherited from View.)
Public method | GetLinkOverrides | Gets the graphic overrides of a RevitLinkType or RevitLinkInstance in view. (Inherited from View.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetModelToProjectionTransforms | Gets the transforms from the model space to the view projection space. (Inherited from View.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetNonControlledTemplateParameterIds | Returns a list of parameters that are not marked as included when this view is used as a template. (Inherited from View.)
Public method | GetOrderedFilters | Gets the filters applied to the view in the order they are applied. (Inherited from View.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPlacementOnSheetStatus | Determines if this view placed on a sheet completely or partially. (Inherited from View.)
Public method | GetPointCloudOverrides | Returns point cloud overrides object for the view. (Inherited from View.)
Public method | GetPrimaryViewId | Get the id of the primary view. (Inherited from View.)
Public method | GetReferenceCallouts | Returns element ids of all reference callouts in the view. (Inherited from View.)
Public method | GetReferenceElevations | Returns element ids of all reference elevations in the view. (Inherited from View.)
Public method | GetReferenceSections | Returns element ids of all reference sections in the view. (Inherited from View.)
Public method | GetSketchyLines | Returns the current sketchy lines settings for the view. (Inherited from View.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetTemplateParameterIds | Returns a list of parameter ids that may be controlled when this view is assigned as a template. (Inherited from View.)
Public method | GetTemporaryViewPropertiesId | When Temporary View Properties mode is in progress it provides view id that overrode settings for current view. Outside Temporary View Properties mode InvalidElementId will be returned. (Inherited from View.)
Public method | GetTemporaryViewPropertiesName | When Temporary View Properties mode is in progress, name of applied template is returned. Outside Temporary View Properties mode, empty string will be returned. (Inherited from View.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetViewDisplayModel | Returns the current view display model settings for the view. (Inherited from View.)
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view. (Inherited from View.)
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view. (Inherited from View.)
Public method | HasDetailLevel | Check if the view has a Detail Level property (Inherited from View.)
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property (Inherited from View.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property (Inherited from View.)
Public method | HasViewTransforms | Returns true if the view reports model space to view projection space transforms. (Inherited from View.)
Public method | HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View.)
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view. (Inherited from View.)
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view. (Inherited from View.)
Public method | HideElements | Sets the elements to be hidden in the view. (Inherited from View.)
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View.)
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View.)
Public method | IsCategoryOverridable | Checks whether the category can have graphic overrides in this view. (Inherited from View.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view. (Inherited from View.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsFilterApplied | Indicates if a filter is applied to the view. (Inherited from View.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode. (Inherited from View.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View.)
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories. (Inherited from View.)
Public method | IsTemporaryViewPropertiesModeEnabled | Returns true when Temporary View Properties mode is in progress, false otherwise. (Inherited from View.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | IsValidViewTemplate | Verifies that the view represented by templateId can be set as the controlling view template for this view. (Inherited from View.)
Public method | IsViewValidForTemplateCreation | Verifies that the view is valid for template creation. (Inherited from View.)
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view. (Inherited from View.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | RemoveCalloutParent | Replaces callout parent ID with InvalidElementId. (Inherited from View.)
Public method | RemoveFilter | Removes a filter from the view. (Inherited from View.)
Public method | RemoveLinkOverrides | Deletes the graphical link overrides in the current view. (Inherited from View.)
Public method | RestoreCalloutParent | Restores callout parent ID to the original view ID if that view is still available. (Inherited from View.)
Public method | SetBackground | Sets the background for the view. Background can only be set for 3d views and for Sections/Elevations. (Inherited from View.)
Public method | SetCategoryHidden | Sets if elements of the given category will be visible in this view. (Inherited from View.)
Public method | SetCategoryOverrides | Sets graphic overrides for a category in view. (Inherited from View.)
Public method | SetColorFillSchemeId | Applies color fill scheme to this view. (Inherited from View.)
Public method | SetDepthCueing | Sets the depth cueing settings for the view. (Inherited from View.)
Public method | SetElementOverrides | Sets graphic overrides for an element in the view. (Inherited from View.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetFilterOverrides | Sets the overrides associated with a filter. (Inherited from View.)
Public method | SetFilterVisibility | Sets the visibility of the elements associated with a filter. (Inherited from View.)
Public method | SetIsFilterEnabled | Sets the filter enabled flag. (Inherited from View.)
Public method | SetLinkOverrides | Sets the graphic overrides of a RevitLinkType or RevitLinkInstance in the view. (Inherited from View.)
Public method | SetNonControlledTemplateParameterIds | Sets the parameters that will not be included when this view is used as a template. (Inherited from View.)
Public method | SetSketchyLines | Sets the sketchy lines settings for the view. (Inherited from View.)
Public method | SetViewDisplayModel | Sets the view display model settings for the view. (Inherited from View.)
Public method | SetWorksetVisibility | Sets visibility for a workset in this view. (Inherited from View.)
Public method | SetWorksharingDisplayMode | Sets the worksharing display mode for this view. (Inherited from View.)
Public method | ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View.)
Public method | SupportedColorFillCategoryIds | Returns collection of all category ids that correspond to elements that can potentially be colored in this view according to a color fill scheme. The set may be different depending on the view type. (Inherited from View.)
Public method | SupportsRevealConstraints | Checks that the view can have the Reveal Constraints mode activated. (Inherited from View.)
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode. (Inherited from View.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

See Also

ViewDrafting Class


Create Method

[image]

Revit 2024 API
ViewDrafting..::..Create Method
ViewDrafting Class Example See Also Send Feedback
Creates a new ViewDrafting in the model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static ViewDrafting Create(
    Document document,
    ElementId viewFamilyTypeId
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    viewFamilyTypeId As ElementId _
) As ViewDrafting
Visual C++
public:
static ViewDrafting^ Create(
    Document^ document,
    ElementId^ viewFamilyTypeId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which the new drafting view will be created.
viewFamilyTypeId
Type: Autodesk.Revit.DB..::..ElementId
The id of the ViewFamilyType that should be assigned to the new drafting view.

Return Value

The newly created drafting view.

Examples

CopyC#
// For simplicity, we'll look what drafting view types are already available,
// and we'll use the first one we can find to create our new drafting view.
FilteredElementCollector collector = new FilteredElementCollector(document);
collector.OfClass(typeof(ViewFamilyType));
ViewFamilyType viewFamilyType = collector.Cast<ViewFamilyType>().First(vft => vft.ViewFamily == ViewFamily.Drafting);

// Create a new ViewDrafting instance
ViewDrafting view = ViewDrafting.Create(document, viewFamilyType.Id);
view.Name = "MyViewDrafting";

// Set the CropBox
BoundingBoxXYZ boundingBox = new BoundingBoxXYZ();
boundingBox.Max = new XYZ(100, 100, 50);
boundingBox.Min = new XYZ(-100, -100, -50);
view.CropBox = boundingBox;
CopyVB.NET
' For simplicity, we'll look what drafting view types are already available,
' and we'll use the first one we can find to create our new drafting view.
Dim collector As New FilteredElementCollector(document)
collector.OfClass(GetType(ViewFamilyType))
Dim viewFamilyType As ViewFamilyType = collector.Cast(Of ViewFamilyType)().First(Function(vft) vft.ViewFamily = ViewFamily.Drafting)

' Create a new ViewDrafting instance
Dim view As ViewDrafting = ViewDrafting.Create(document, viewFamilyType.Id)
view.Name = "MyViewDrafting"

' Set the CropBox
Dim boundingBox As New BoundingBoxXYZ()
boundingBox.Max = New XYZ(100, 100, 50)
boundingBox.Min = New XYZ(-100, -100, -50)
view.CropBox = boundingBox

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | viewFamilyTypeId is not a valid ViewFamilyType for a drafting view.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ViewDrafting Class


Print Method

[image] [image]

Revit 2024 API
ViewDrafting..::..Print Method
ViewDrafting Class See Also Send Feedback
Print this view.

Overload List

 | Name | Description
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)

See Also

ViewDrafting Class
ViewDrafting Members


Parameter Property

[image] [image]

Revit 2024 API
ViewDrafting..::..Parameter Property
ViewDrafting Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ViewDrafting Class
ViewDrafting Members


ViewDuplicateOption Enumeration

[image]

Revit 2024 API
ViewDuplicateOption Enumeration
See Also Send Feedback
Options for duplicating views

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Since: 2013

Syntax

C#
public enum ViewDuplicateOption
Visual Basic
Public Enumeration ViewDuplicateOption
Visual C++
public enum class ViewDuplicateOption

Members

Member name | Description
Duplicate | Duplicate view
AsDependent | Duplicate as Dependent
WithDetailing | Duplicate with Detailing

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


ViewFamily Enumeration

[image]

Revit 2024 API
ViewFamily Enumeration
See Also Send Feedback
An enumerated type that corresponds to the type of a Revit view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public enum ViewFamily
Visual Basic
Public Enumeration ViewFamily
Visual C++
public enum class ViewFamily

Members

Member name | Description
Invalid | Invalid view type.
ThreeDimensional | 3D view.
Walkthrough | Walkthrough view.
ImageView | Rendering view.
Schedule | Schedule view.
CostReport | Cost report view (obsolete).
Sheet | Sheet view.
Drafting | Drafting view.
FloorPlan | Floor plan view.
AreaPlan | Area plan view.
CeilingPlan | Ceiling plan view.
Section | Section view.
Detail | Detail view.
Elevation | Elevation view.
LoadsReport | HVAC load report.
PressureLossReport | Pressure loss report.
Legend | Legend view.
PanelSchedule | Panel schedule.
GraphicalColumnSchedule | Graphical column schedule.
StructuralPlan | Structural plan view.
SystemsAnalysisReport | Systems analysis report.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


ViewFamilyType Members

[image] [image]

Revit 2024 API
ViewFamilyType Members
ViewFamilyType Class Methods Properties See Also Send Feedback

The ViewFamilyType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidDefaultTemplate | Verifies that the input can be used as a default template for this view type.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DefaultTemplateId | The default template id assigned to this view type.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | PlanViewDirection | The PlanViewDirection of this view.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewFamily | The ViewFamily for this view type.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ViewFamilyType Class


ViewFamilyType Methods

[image] [image]

Revit 2024 API
ViewFamilyType Methods
ViewFamilyType Class See Also Send Feedback

The ViewFamilyType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType.)
Public method | IsValidDefaultTemplate | Verifies that the input can be used as a default template for this view type.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ViewFamilyType Class


ViewFamilyType Properties

[image] [image]

Revit 2024 API
ViewFamilyType Properties
ViewFamilyType Class See Also Send Feedback

The ViewFamilyType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType.)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType.)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DefaultTemplateId | The default template id assigned to this view type.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | PlanViewDirection | The PlanViewDirection of this view.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewFamily | The ViewFamily for this view type.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ViewFamilyType Class


DefaultTemplateId Property

[image]

Revit 2024 API
ViewFamilyType..::..DefaultTemplateId Property
ViewFamilyType Class See Also Send Feedback
The default template id assigned to this view type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ElementId DefaultTemplateId { get; set; }
Visual Basic
Public Property DefaultTemplateId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ DefaultTemplateId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Remarks

This value will be the view template for all newly created instances of this view type.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: val is not valid as a default template id.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ViewFamilyType Class


Parameter Property

[image] [image]

Revit 2024 API
ViewFamilyType..::..Parameter Property
ViewFamilyType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ViewFamilyType Class
ViewFamilyType Members


PlanViewDirection Property

[image]

Revit 2024 API
ViewFamilyType..::..PlanViewDirection Property
ViewFamilyType Class See Also Send Feedback
The PlanViewDirection of this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public PlanViewDirection PlanViewDirection { get; set; }
Visual Basic
Public Property PlanViewDirection As PlanViewDirection
    Get
    Set
Visual C++
public:
property PlanViewDirection PlanViewDirection {
    PlanViewDirection get ();
    void set (PlanViewDirection value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: PlanViewDirection cannot be set to Undefined
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: View must be a Structural Plan

See Also

ViewFamilyType Class


ViewFamily Property

[image]

Revit 2024 API
ViewFamilyType..::..ViewFamily Property
ViewFamilyType Class Example See Also Send Feedback
The ViewFamily for this view type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ViewFamily ViewFamily { get; }
Visual Basic
Public ReadOnly Property ViewFamily As ViewFamily
    Get
Visual C++
public:
property ViewFamily ViewFamily {
    ViewFamily get ();
}

Examples

CopyC#
public ViewFamily GetViewFamily(Document doc, View view)
{
    ViewFamily viewFamily = ViewFamily.Invalid;

    ElementId viewTypeId = view.GetTypeId();
    ElementId viewTypeIdOne = new ElementId(1L);
    if (viewTypeId > viewTypeIdOne) // some views may not have a ViewFamilyType
    {
        ViewFamilyType viewFamilyType = doc.GetElement(viewTypeId) as ViewFamilyType;
        viewFamily = viewFamilyType.ViewFamily;
    }

    return viewFamily;
}
CopyVB.NET
Public Function GetViewFamily(doc As Document, view As View) As ViewFamily
    Dim viewFamily__1 As ViewFamily = ViewFamily.Invalid

    Dim viewTypeId As ElementId = view.GetTypeId()
    Dim viewTypeIdOne As ElementId = New ElementId(1L)
    If viewTypeId > viewTypeIdOne Then
        ' some views may not have a ViewFamilyType
        Dim viewFamilyType As ViewFamilyType = TryCast(doc.GetElement(viewTypeId), ViewFamilyType)
        viewFamily__1 = viewFamilyType.ViewFamily
    End If

    Return viewFamily__1
End Function

See Also

ViewFamilyType Class


ViewNavigationToolSettings Class

[image]

Revit 2024 API
ViewNavigationToolSettings Class
Members See Also Send Feedback
Represents the settings contained in the document associated to the View Navigation tools (such as the View Cube).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public class ViewNavigationToolSettings : Element
Visual Basic
Public Class ViewNavigationToolSettings _
    Inherits Element
Visual C++
public ref class ViewNavigationToolSettings : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ViewNavigationToolSettings

See Also

ViewNavigationToolSettings Members


ViewNavigationToolSettings Members

[image] [image]

Revit 2024 API
ViewNavigationToolSettings Members
ViewNavigationToolSettings Class Methods Properties See Also Send Feedback

The ViewNavigationToolSettings type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHomeCamera | Gets a copy of the structure containing information about the store Home view orientation.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
 | GetViewNavigationToolSettings | Gets the instance of the settings for the given document.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsHomeCameraSet | Checks if the home view is set in the settings.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ViewNavigationToolSettings Class


ViewNavigationToolSettings Methods

[image] [image]

Revit 2024 API
ViewNavigationToolSettings Methods
ViewNavigationToolSettings Class See Also Send Feedback

The ViewNavigationToolSettings type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHomeCamera | Gets a copy of the structure containing information about the store Home view orientation.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
 | GetViewNavigationToolSettings | Gets the instance of the settings for the given document.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsHomeCameraSet | Checks if the home view is set in the settings.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ViewNavigationToolSettings Class


GetViewNavigationToolSettings Method

[image]

Revit 2024 API
ViewNavigationToolSettings..::..GetViewNavigationToolSettings Method
ViewNavigationToolSettings Class See Also Send Feedback
Gets the instance of the settings for the given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public static ViewNavigationToolSettings GetViewNavigationToolSettings(
    Document pADoc
)
Visual Basic
Public Shared Function GetViewNavigationToolSettings ( _
    pADoc As Document _
) As ViewNavigationToolSettings
Visual C++
public:
static ViewNavigationToolSettings^ GetViewNavigationToolSettings(
    Document^ pADoc
)

Parameters

pADoc
Type: Autodesk.Revit.DB..::..Document
The document.

Return Value

The instance of the settings for the given document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ViewNavigationToolSettings Class


IsHomeCameraSet Method

[image]

Revit 2024 API
ViewNavigationToolSettings..::..IsHomeCameraSet Method
ViewNavigationToolSettings Class See Also Send Feedback
Checks if the home view is set in the settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public bool IsHomeCameraSet()
Visual Basic
Public Function IsHomeCameraSet As Boolean
Visual C++
public:
bool IsHomeCameraSet()

Return Value

Returns true if home view is set, otherwise false.

See Also

ViewNavigationToolSettings Class


ViewNavigationToolSettings Properties

[image] [image]

Revit 2024 API
ViewNavigationToolSettings Properties
ViewNavigationToolSettings Class See Also Send Feedback

The ViewNavigationToolSettings type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ViewNavigationToolSettings Class


Parameter Property

[image] [image]

Revit 2024 API
ViewNavigationToolSettings..::..Parameter Property
ViewNavigationToolSettings Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ViewNavigationToolSettings Class
ViewNavigationToolSettings Members


ViewNode Class

[image]

Revit 2024 API
ViewNode Class
Members See Also Send Feedback
A render node that represents a view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public class ViewNode : RenderNode
Visual Basic
Public Class ViewNode _
    Inherits RenderNode
Visual C++
public ref class ViewNode : public RenderNode

Remarks

See also: [!:Autodesk::Revit::DB::IExportContext::OnViewBegin].

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..RenderNode
Autodesk.Revit.DB..::..ViewNode

See Also

ViewNode Members


ViewNode Members

[image] [image]

Revit 2024 API
ViewNode Members
ViewNode Class Methods Properties See Also Send Feedback

The ViewNode type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RenderNode.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCameraInfo | Information about the observation point (the camera) of the view.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode.)
Public property | LevelOfDetail | The level of detail the view is going to be rendered at.
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode.)
Public property | ViewId | The Id of the view element.

See Also

ViewNode Class


ViewNode Methods

[image] [image]

Revit 2024 API
ViewNode Methods
ViewNode Class See Also Send Feedback

The ViewNode type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RenderNode.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCameraInfo | Information about the observation point (the camera) of the view.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ViewNode Class


GetCameraInfo Method

[image]

Revit 2024 API
ViewNode..::..GetCameraInfo Method
ViewNode Class See Also Send Feedback
Information about the observation point (the camera) of the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public CameraInfo GetCameraInfo()
Visual Basic
Public Function GetCameraInfo As CameraInfo
Visual C++
public:
CameraInfo^ GetCameraInfo()

Return Value

An instance of CameraInfo or nullNothingnullptra null reference (Nothing in Visual Basic) if there is no info associated with the view

See Also

ViewNode Class


ViewNode Properties

[image] [image]

Revit 2024 API
ViewNode Properties
ViewNode Class See Also Send Feedback

The ViewNode type exposes the following members.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode.)
Public property | LevelOfDetail | The level of detail the view is going to be rendered at.
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode.)
Public property | ViewId | The Id of the view element.

See Also

ViewNode Class


ViewId Property

[image]

Revit 2024 API
ViewNode..::..ViewId Property
ViewNode Class See Also Send Feedback
The Id of the view element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ElementId ViewId { get; }
Visual Basic
Public ReadOnly Property ViewId As ElementId
    Get
Visual C++
public:
property ElementId^ ViewId {
    ElementId^ get ();
}

See Also

ViewNode Class


ViewOrientation3D Class

[image]

Revit 2024 API
ViewOrientation3D Class
Members See Also Send Feedback
Container for the point and vectors which define View3D's orientation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public class ViewOrientation3D : IDisposable
Visual Basic
Public Class ViewOrientation3D _
    Implements IDisposable
Visual C++
public ref class ViewOrientation3D : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ViewOrientation3D

See Also

ViewOrientation3D Members


ViewOrientation3D Members

[image] [image]

Revit 2024 API
ViewOrientation3D Members
ViewOrientation3D Class Constructors Methods Properties See Also Send Feedback

The ViewOrientation3D type exposes the following members.

Constructors

 | Name | Description
Public method | ViewOrientation3D | Constructs a new ViewOrientation3D using the input eye position, up and forward directions.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ViewOrientation3D
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | EyePosition | The eye position point
Public property | ForwardDirection | The forward direction vector
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | UpDirection | The up direction vector

See Also

ViewOrientation3D Class


ViewOrientation3D Constructor

[image]

Revit 2024 API
ViewOrientation3D Constructor
ViewOrientation3D Class See Also Send Feedback
Constructs a new ViewOrientation3D using the input eye position, up and forward directions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ViewOrientation3D(
    XYZ eyePosition,
    XYZ upDirection,
    XYZ forwardDirection
)
Visual Basic
Public Sub New ( _
    eyePosition As XYZ, _
    upDirection As XYZ, _
    forwardDirection As XYZ _
)
Visual C++
public:
ViewOrientation3D(
    XYZ^ eyePosition,
    XYZ^ upDirection,
    XYZ^ forwardDirection
)

Parameters

eyePosition
Type: Autodesk.Revit.DB..::..XYZ
The eye position
upDirection
Type: Autodesk.Revit.DB..::..XYZ
The up direction. This vector will be normalized. Up direction must be perpendicular to the forward direction.
forwardDirection
Type: Autodesk.Revit.DB..::..XYZ
The forward direction. This vector will be normalized. Forward direction must be perpendicular to the up direction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | One or both of the input vectors cannot be normalized.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | upDirection has zero length. -or- forwardDirection has zero length.
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | The vectors upDirection and forwardDirection are not perpendicular.

See Also

ViewOrientation3D Class


ViewOrientation3D Methods

[image] [image]

Revit 2024 API
ViewOrientation3D Methods
ViewOrientation3D Class See Also Send Feedback

The ViewOrientation3D type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ViewOrientation3D Class


Dispose Method

[image]

Revit 2024 API
ViewOrientation3D..::..Dispose Method
ViewOrientation3D Class See Also Send Feedback
Releases all resources used by the ViewOrientation3D

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ViewOrientation3D Class


ViewOrientation3D Properties

[image] [image]

Revit 2024 API
ViewOrientation3D Properties
ViewOrientation3D Class See Also Send Feedback

The ViewOrientation3D type exposes the following members.

Properties

 | Name | Description
Public property | EyePosition | The eye position point
Public property | ForwardDirection | The forward direction vector
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | UpDirection | The up direction vector

See Also

ViewOrientation3D Class


EyePosition Property

[image]

Revit 2024 API
ViewOrientation3D..::..EyePosition Property
ViewOrientation3D Class See Also Send Feedback
The eye position point

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public XYZ EyePosition { get; }
Visual Basic
Public ReadOnly Property EyePosition As XYZ
    Get
Visual C++
public:
property XYZ^ EyePosition {
    XYZ^ get ();
}

See Also

ViewOrientation3D Class


ForwardDirection Property

[image]

Revit 2024 API
ViewOrientation3D..::..ForwardDirection Property
ViewOrientation3D Class See Also Send Feedback
The forward direction vector

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public XYZ ForwardDirection { get; }
Visual Basic
Public ReadOnly Property ForwardDirection As XYZ
    Get
Visual C++
public:
property XYZ^ ForwardDirection {
    XYZ^ get ();
}

See Also

ViewOrientation3D Class


IsValidObject Property

[image]

Revit 2024 API
ViewOrientation3D..::..IsValidObject Property
ViewOrientation3D Class See Also Send Feedback
Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidObject { get; }
Visual Basic
Public ReadOnly Property IsValidObject As Boolean
    Get
Visual C++
public:
property bool IsValidObject {
    bool get ();
}

Return Value

True if the API object holds a valid Revit native object, false otherwise.

Remarks

If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.

See Also

ViewOrientation3D Class


UpDirection Property

[image]

Revit 2024 API
ViewOrientation3D..::..UpDirection Property
ViewOrientation3D Class See Also Send Feedback
The up direction vector

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public XYZ UpDirection { get; }
Visual Basic
Public ReadOnly Property UpDirection As XYZ
    Get
Visual C++
public:
property XYZ^ UpDirection {
    XYZ^ get ();
}

See Also

ViewOrientation3D Class


ViewPlan Class

[image]

Revit 2024 API
ViewPlan Class
Members See Also Send Feedback
Represents floor plan, area plan, ceiling plan, and structural plan views in Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class ViewPlan : View
Visual Basic
Public Class ViewPlan _
    Inherits View
Visual C++
public ref class ViewPlan : public View

Remarks

In a plan view, the model is viewed as if cut by the cut plane and viewed from above, looking down. In ceiling plan views and structural plan views which look up, the model is viewed as if cut by the cut plane, and viewed as if looking down at a mirror.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..View
Autodesk.Revit.DB..::..ViewPlan

See Also

ViewPlan Members


ViewPlan Members

[image] [image]

Revit 2024 API
ViewPlan Members
ViewPlan Class Methods Properties See Also Send Feedback

The ViewPlan type exposes the following members.

Methods

 | Name | Description
Public method | AddFilter | Adds a filter to the view. (Inherited from View.)
Public method | AllowsAnalysisDisplay | Identifies if this view allows display of Analysis results. (Inherited from View.)
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of the input view that are not controlled by the current view template. (Inherited from View.)
Public method | AreGraphicsOverridesAllowed | Determines if Visibility/Graphics Overriddes can be applied to the view. (Inherited from View.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanApplyColorFillScheme | Checks if the id can be applied as the scheme id of specified category to this view. (Inherited from View.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanCategoryBeHidden | Checks whether the category can be hidden in the view. (Inherited from View.)
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view. (Inherited from View.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanEnableTemporaryViewPropertiesMode | Indicates if Temporary View Properties mode can be applied for view in current state. (Inherited from View.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified. (Inherited from View.)
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified. (Inherited from View.)
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified (Inherited from View.)
Public method | CanUseDepthCueing | Indicates if view can use Depth Cueing (Inherited from View.)
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes (Inherited from View.)
Public method | CanViewBeDuplicated | Identifies if this view can be duplicated. (Inherited from View.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | CheckPlanViewRangeValidity | Checks if the plan view range is valid.
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view. (Inherited from View.)
Public method | ConvertToIndependent | Convert the dependent view to independent. (Inherited from View.)
 | Create | Creates a new ViewPlan.
 | CreateAreaPlan | Creates a new area plan ViewPlan.
Public method | CreateViewTemplate | Creates a new view template instance from this view instance. (Inherited from View.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode. (Inherited from View.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates this view. (Inherited from View.)
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode. (Inherited from View.)
Public method | EnableTemporaryViewPropertiesMode | Turns Temporary View Properties mode on or off. In this mode, any changes made to the view are temporary and will be discarded once the mode is disabled. (Inherited from View.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetBackground | Returns the current background set for the view. (Inherited from View.)
Public method | GetCalloutParentId | Gets ID of the callout parent view. (Inherited from View.)
Public method | GetCategoryHidden | Checks if elements of the given category are set to be invisible (hidden) in this view. (Inherited from View.)
Public method | GetCategoryOverrides | Gets graphic overrides for a category in view. (Inherited from View.)
Public method | GetColorFillSchemeId | Returns id of the color fill scheme element applied to the view. (Inherited from View.)
Public method | GetCropRegionShapeManager | Returns an object for managing view crop region shape. (Inherited from View.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetDependentViewIds | Get the ids of dependent views. (Inherited from View.)
Public method | GetDepthCueing | Returns the current depth cueing settings for the view. (Inherited from View.)
Public method | GetDirectContext3DHandleOverrides | Returns DirectContext3D handle overrides object for the view. (Inherited from View.)
Public method | GetElementOverrides | Gets graphic overrides for an element in the view. (Inherited from View.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetFilterOverrides | Gets graphic overrides that a filter applies to the view. (Inherited from View.)
Public method | GetFilters | Gets the filters applied to the view. (Inherited from View.)
Public method | GetFilterVisibility | Gets the visibility of the elements associated with a filter. (Inherited from View.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIsFilterEnabled | Identifies if the filter is enabled in this view. (Inherited from View.)
Public method | GetLinkOverrides | Gets the graphic overrides of a RevitLinkType or RevitLinkInstance in view. (Inherited from View.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetModelToProjectionTransforms | Gets the transforms from the model space to the view projection space. (Inherited from View.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetNonControlledTemplateParameterIds | Returns a list of parameters that are not marked as included when this view is used as a template. (Inherited from View.)
Public method | GetOrderedFilters | Gets the filters applied to the view in the order they are applied. (Inherited from View.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPlacementOnSheetStatus | Determines if this view placed on a sheet completely or partially. (Inherited from View.)
Public method | GetPointCloudOverrides | Returns point cloud overrides object for the view. (Inherited from View.)
Public method | GetPrimaryViewId | Get the id of the primary view. (Inherited from View.)
Public method | GetReferenceCallouts | Returns element ids of all reference callouts in the view. (Inherited from View.)
Public method | GetReferenceElevations | Returns element ids of all reference elevations in the view. (Inherited from View.)
Public method | GetReferenceSections | Returns element ids of all reference sections in the view. (Inherited from View.)
Public method | GetSketchyLines | Returns the current sketchy lines settings for the view. (Inherited from View.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetTemplateParameterIds | Returns a list of parameter ids that may be controlled when this view is assigned as a template. (Inherited from View.)
Public method | GetTemporaryViewPropertiesId | When Temporary View Properties mode is in progress it provides view id that overrode settings for current view. Outside Temporary View Properties mode InvalidElementId will be returned. (Inherited from View.)
Public method | GetTemporaryViewPropertiesName | When Temporary View Properties mode is in progress, name of applied template is returned. Outside Temporary View Properties mode, empty string will be returned. (Inherited from View.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetUnderlayBaseLevel | Returns the element id of the level that defines the bottom of the underlay range.
Public method | GetUnderlayOrientation | Returns the underlay orientation of this view.
Public method | GetUnderlayTopLevel | Returns the element id of the level that defines the top of the underlay range.
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetViewDisplayModel | Returns the current view display model settings for the view. (Inherited from View.)
Public method | GetViewRange | Gets the view range.
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view. (Inherited from View.)
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view. (Inherited from View.)
Public method | HasDetailLevel | Check if the view has a Detail Level property (Inherited from View.)
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property (Inherited from View.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property (Inherited from View.)
Public method | HasViewTransforms | Returns true if the view reports model space to view projection space transforms. (Inherited from View.)
Public method | HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View.)
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view. (Inherited from View.)
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view. (Inherited from View.)
Public method | HideElements | Sets the elements to be hidden in the view. (Inherited from View.)
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View.)
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View.)
Public method | IsCategoryOverridable | Checks whether the category can have graphic overrides in this view. (Inherited from View.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view. (Inherited from View.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsFilterApplied | Indicates if a filter is applied to the view. (Inherited from View.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode. (Inherited from View.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View.)
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories. (Inherited from View.)
Public method | IsTemporaryViewPropertiesModeEnabled | Returns true when Temporary View Properties mode is in progress, false otherwise. (Inherited from View.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | IsValidViewTemplate | Verifies that the view represented by templateId can be set as the controlling view template for this view. (Inherited from View.)
Public method | IsViewValidForTemplateCreation | Verifies that the view is valid for template creation. (Inherited from View.)
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view. (Inherited from View.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | RemoveCalloutParent | Replaces callout parent ID with InvalidElementId. (Inherited from View.)
Public method | RemoveFilter | Removes a filter from the view. (Inherited from View.)
Public method | RemoveLinkOverrides | Deletes the graphical link overrides in the current view. (Inherited from View.)
Public method | RestoreCalloutParent | Restores callout parent ID to the original view ID if that view is still available. (Inherited from View.)
Public method | SetBackground | Sets the background for the view. Background can only be set for 3d views and for Sections/Elevations. (Inherited from View.)
Public method | SetCategoryHidden | Sets if elements of the given category will be visible in this view. (Inherited from View.)
Public method | SetCategoryOverrides | Sets graphic overrides for a category in view. (Inherited from View.)
Public method | SetColorFillSchemeId | Applies color fill scheme to this view. (Inherited from View.)
Public method | SetDepthCueing | Sets the depth cueing settings for the view. (Inherited from View.)
Public method | SetElementOverrides | Sets graphic overrides for an element in the view. (Inherited from View.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetFilterOverrides | Sets the overrides associated with a filter. (Inherited from View.)
Public method | SetFilterVisibility | Sets the visibility of the elements associated with a filter. (Inherited from View.)
Public method | SetIsFilterEnabled | Sets the filter enabled flag. (Inherited from View.)
Public method | SetLinkOverrides | Sets the graphic overrides of a RevitLinkType or RevitLinkInstance in the view. (Inherited from View.)
Public method | SetNonControlledTemplateParameterIds | Sets the parameters that will not be included when this view is used as a template. (Inherited from View.)
Public method | SetSketchyLines | Sets the sketchy lines settings for the view. (Inherited from View.)
Public method | SetUnderlayBaseLevel | Sets the level whose elevation will determine the bottom of the underlay range. The elevation of the next highest level will be used to determine the top of the underlay range.
Public method | SetUnderlayOrientation | Sets the underlay orientation for this view.
Public method | SetUnderlayRange | Sets the underlay base and underlay top to the specified levels.
Public method | SetViewDisplayModel | Sets the view display model settings for the view. (Inherited from View.)
Public method | SetViewRange | Sets the view range.
Public method | SetWorksetVisibility | Sets visibility for a workset in this view. (Inherited from View.)
Public method | SetWorksharingDisplayMode | Sets the worksharing display mode for this view. (Inherited from View.)
Public method | ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View.)
Public method | SupportedColorFillCategoryIds | Returns collection of all category ids that correspond to elements that can potentially be colored in this view according to a color fill scheme. The set may be different depending on the view type. (Inherited from View.)
Public method | SupportsRevealConstraints | Checks that the view can have the Reveal Constraints mode activated. (Inherited from View.)
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode. (Inherited from View.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

Properties

 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View.)
Public property | AreAnalyticalModelCategoriesHidden | Indicates if analytical model categories are currently hidden in the view. (Inherited from View.)
Public property | AreAnnotationCategoriesHidden | Indicates if annotation categories are currently hidden in the view. (Inherited from View.)
Public property | AreaScheme | The area scheme.
Public property | AreCoordinationModelHandlesHidden | Indicates if Coordination Model handles are currently hidden in the view. (Inherited from View.)
Public property | AreImportCategoriesHidden | Indicates if import categories are currently hidden in the view. (Inherited from View.)
Public property | AreModelCategoriesHidden | Indicates if model categories are currently hidden in the view. (Inherited from View.)
Public property | ArePointCloudsHidden | Indicates if point clouds are currently hidden in the view. (Inherited from View.)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view. (Inherited from View.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CropBox | The Crop Box applied to the view, or an outline encompassing the crop region applied to the view. (Inherited from View.)
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View.)
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DetailLevel | The detail level of this view. (Inherited from View.)
Public property | Discipline | The Discipline of the view. (Inherited from View.)
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style. (Inherited from View.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | GenLevel | The level for the view. (Inherited from View.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsAssemblyView | Indicates if the view is assembly view. (Inherited from View.)
Public property | IsCallout | Indicates if the view is a callout view. (Inherited from View.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTemplate | Test whether the view is a view template. (Inherited from View.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Origin | Returns the origin of the screen. (Inherited from View.)
Public property | Outline | The bounds of the view in paper space (in feet). (Inherited from View.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PartsVisibility | The visibility setting for parts in this view. (Inherited from View.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RevealConstraintsMode | Indicates whether the Reveal Constraints mode is activated in the view. (Inherited from View.)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Public property | Scale | The scale of the view. (Inherited from View.)
Public property | ShadowIntensity | The intesity of cast shadows - 0 = no shadows, 100 = black. (Inherited from View.)
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View.)
Public property | SunlightIntensity | The intensity of the simulated (directional) sunlight. 0 = no directional light; maximum value is 100. (Inherited from View.)
Public property | TemporaryViewModes | Data of temporary view modes associated with this view. (Inherited from View.)
Public property | Title | The view title. This consists of the view name plus other modifiers, such as the view type, sheet number, area scheme, and/or assembly type, depending on the specifics of the view. (Inherited from View.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | ViewTemplateId | The id of the template view that controls this view's parameters. (Inherited from View.)
Public property | ViewType | The type of the view. (Inherited from View.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ViewPlan Class


ViewPlan Methods

[image] [image]

Revit 2024 API
ViewPlan Methods
ViewPlan Class See Also Send Feedback

The ViewPlan type exposes the following members.

Methods

 | Name | Description
Public method | AddFilter | Adds a filter to the view. (Inherited from View.)
Public method | AllowsAnalysisDisplay | Identifies if this view allows display of Analysis results. (Inherited from View.)
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of the input view that are not controlled by the current view template. (Inherited from View.)
Public method | AreGraphicsOverridesAllowed | Determines if Visibility/Graphics Overriddes can be applied to the view. (Inherited from View.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanApplyColorFillScheme | Checks if the id can be applied as the scheme id of specified category to this view. (Inherited from View.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanCategoryBeHidden | Checks whether the category can be hidden in the view. (Inherited from View.)
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view. (Inherited from View.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanEnableTemporaryViewPropertiesMode | Indicates if Temporary View Properties mode can be applied for view in current state. (Inherited from View.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified. (Inherited from View.)
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified. (Inherited from View.)
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified (Inherited from View.)
Public method | CanUseDepthCueing | Indicates if view can use Depth Cueing (Inherited from View.)
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes (Inherited from View.)
Public method | CanViewBeDuplicated | Identifies if this view can be duplicated. (Inherited from View.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | CheckPlanViewRangeValidity | Checks if the plan view range is valid.
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view. (Inherited from View.)
Public method | ConvertToIndependent | Convert the dependent view to independent. (Inherited from View.)
 | Create | Creates a new ViewPlan.
 | CreateAreaPlan | Creates a new area plan ViewPlan.
Public method | CreateViewTemplate | Creates a new view template instance from this view instance. (Inherited from View.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode. (Inherited from View.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates this view. (Inherited from View.)
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode. (Inherited from View.)
Public method | EnableTemporaryViewPropertiesMode | Turns Temporary View Properties mode on or off. In this mode, any changes made to the view are temporary and will be discarded once the mode is disabled. (Inherited from View.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetBackground | Returns the current background set for the view. (Inherited from View.)
Public method | GetCalloutParentId | Gets ID of the callout parent view. (Inherited from View.)
Public method | GetCategoryHidden | Checks if elements of the given category are set to be invisible (hidden) in this view. (Inherited from View.)
Public method | GetCategoryOverrides | Gets graphic overrides for a category in view. (Inherited from View.)
Public method | GetColorFillSchemeId | Returns id of the color fill scheme element applied to the view. (Inherited from View.)
Public method | GetCropRegionShapeManager | Returns an object for managing view crop region shape. (Inherited from View.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetDependentViewIds | Get the ids of dependent views. (Inherited from View.)
Public method | GetDepthCueing | Returns the current depth cueing settings for the view. (Inherited from View.)
Public method | GetDirectContext3DHandleOverrides | Returns DirectContext3D handle overrides object for the view. (Inherited from View.)
Public method | GetElementOverrides | Gets graphic overrides for an element in the view. (Inherited from View.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetFilterOverrides | Gets graphic overrides that a filter applies to the view. (Inherited from View.)
Public method | GetFilters | Gets the filters applied to the view. (Inherited from View.)
Public method | GetFilterVisibility | Gets the visibility of the elements associated with a filter. (Inherited from View.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIsFilterEnabled | Identifies if the filter is enabled in this view. (Inherited from View.)
Public method | GetLinkOverrides | Gets the graphic overrides of a RevitLinkType or RevitLinkInstance in view. (Inherited from View.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetModelToProjectionTransforms | Gets the transforms from the model space to the view projection space. (Inherited from View.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetNonControlledTemplateParameterIds | Returns a list of parameters that are not marked as included when this view is used as a template. (Inherited from View.)
Public method | GetOrderedFilters | Gets the filters applied to the view in the order they are applied. (Inherited from View.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPlacementOnSheetStatus | Determines if this view placed on a sheet completely or partially. (Inherited from View.)
Public method | GetPointCloudOverrides | Returns point cloud overrides object for the view. (Inherited from View.)
Public method | GetPrimaryViewId | Get the id of the primary view. (Inherited from View.)
Public method | GetReferenceCallouts | Returns element ids of all reference callouts in the view. (Inherited from View.)
Public method | GetReferenceElevations | Returns element ids of all reference elevations in the view. (Inherited from View.)
Public method | GetReferenceSections | Returns element ids of all reference sections in the view. (Inherited from View.)
Public method | GetSketchyLines | Returns the current sketchy lines settings for the view. (Inherited from View.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetTemplateParameterIds | Returns a list of parameter ids that may be controlled when this view is assigned as a template. (Inherited from View.)
Public method | GetTemporaryViewPropertiesId | When Temporary View Properties mode is in progress it provides view id that overrode settings for current view. Outside Temporary View Properties mode InvalidElementId will be returned. (Inherited from View.)
Public method | GetTemporaryViewPropertiesName | When Temporary View Properties mode is in progress, name of applied template is returned. Outside Temporary View Properties mode, empty string will be returned. (Inherited from View.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetUnderlayBaseLevel | Returns the element id of the level that defines the bottom of the underlay range.
Public method | GetUnderlayOrientation | Returns the underlay orientation of this view.
Public method | GetUnderlayTopLevel | Returns the element id of the level that defines the top of the underlay range.
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetViewDisplayModel | Returns the current view display model settings for the view. (Inherited from View.)
Public method | GetViewRange | Gets the view range.
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view. (Inherited from View.)
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view. (Inherited from View.)
Public method | HasDetailLevel | Check if the view has a Detail Level property (Inherited from View.)
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property (Inherited from View.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property (Inherited from View.)
Public method | HasViewTransforms | Returns true if the view reports model space to view projection space transforms. (Inherited from View.)
Public method | HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View.)
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view. (Inherited from View.)
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view. (Inherited from View.)
Public method | HideElements | Sets the elements to be hidden in the view. (Inherited from View.)
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View.)
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View.)
Public method | IsCategoryOverridable | Checks whether the category can have graphic overrides in this view. (Inherited from View.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view. (Inherited from View.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsFilterApplied | Indicates if a filter is applied to the view. (Inherited from View.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode. (Inherited from View.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View.)
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories. (Inherited from View.)
Public method | IsTemporaryViewPropertiesModeEnabled | Returns true when Temporary View Properties mode is in progress, false otherwise. (Inherited from View.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | IsValidViewTemplate | Verifies that the view represented by templateId can be set as the controlling view template for this view. (Inherited from View.)
Public method | IsViewValidForTemplateCreation | Verifies that the view is valid for template creation. (Inherited from View.)
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view. (Inherited from View.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | RemoveCalloutParent | Replaces callout parent ID with InvalidElementId. (Inherited from View.)
Public method | RemoveFilter | Removes a filter from the view. (Inherited from View.)
Public method | RemoveLinkOverrides | Deletes the graphical link overrides in the current view. (Inherited from View.)
Public method | RestoreCalloutParent | Restores callout parent ID to the original view ID if that view is still available. (Inherited from View.)
Public method | SetBackground | Sets the background for the view. Background can only be set for 3d views and for Sections/Elevations. (Inherited from View.)
Public method | SetCategoryHidden | Sets if elements of the given category will be visible in this view. (Inherited from View.)
Public method | SetCategoryOverrides | Sets graphic overrides for a category in view. (Inherited from View.)
Public method | SetColorFillSchemeId | Applies color fill scheme to this view. (Inherited from View.)
Public method | SetDepthCueing | Sets the depth cueing settings for the view. (Inherited from View.)
Public method | SetElementOverrides | Sets graphic overrides for an element in the view. (Inherited from View.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetFilterOverrides | Sets the overrides associated with a filter. (Inherited from View.)
Public method | SetFilterVisibility | Sets the visibility of the elements associated with a filter. (Inherited from View.)
Public method | SetIsFilterEnabled | Sets the filter enabled flag. (Inherited from View.)
Public method | SetLinkOverrides | Sets the graphic overrides of a RevitLinkType or RevitLinkInstance in the view. (Inherited from View.)
Public method | SetNonControlledTemplateParameterIds | Sets the parameters that will not be included when this view is used as a template. (Inherited from View.)
Public method | SetSketchyLines | Sets the sketchy lines settings for the view. (Inherited from View.)
Public method | SetUnderlayBaseLevel | Sets the level whose elevation will determine the bottom of the underlay range. The elevation of the next highest level will be used to determine the top of the underlay range.
Public method | SetUnderlayOrientation | Sets the underlay orientation for this view.
Public method | SetUnderlayRange | Sets the underlay base and underlay top to the specified levels.
Public method | SetViewDisplayModel | Sets the view display model settings for the view. (Inherited from View.)
Public method | SetViewRange | Sets the view range.
Public method | SetWorksetVisibility | Sets visibility for a workset in this view. (Inherited from View.)
Public method | SetWorksharingDisplayMode | Sets the worksharing display mode for this view. (Inherited from View.)
Public method | ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View.)
Public method | SupportedColorFillCategoryIds | Returns collection of all category ids that correspond to elements that can potentially be colored in this view according to a color fill scheme. The set may be different depending on the view type. (Inherited from View.)
Public method | SupportsRevealConstraints | Checks that the view can have the Reveal Constraints mode activated. (Inherited from View.)
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode. (Inherited from View.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

See Also

ViewPlan Class


CheckPlanViewRangeValidity Method

[image]

Revit 2024 API
ViewPlan..::..CheckPlanViewRangeValidity Method
ViewPlan Class See Also Send Feedback
Checks if the plan view range is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public IList<PlanViewRangeError> CheckPlanViewRangeValidity(
    PlanViewRange planViewRange
)
Visual Basic
Public Function CheckPlanViewRangeValidity ( _
    planViewRange As PlanViewRange _
) As IList(Of PlanViewRangeError)
Visual C++
public:
IList<PlanViewRangeError>^ CheckPlanViewRangeValidity(
    PlanViewRange^ planViewRange
)

Parameters

planViewRange
Type: Autodesk.Revit.DB..::..PlanViewRange
The view range to validate.

Return Value

List of enums describing any errors in the plan view range.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ViewPlan Class


Create Method

[image]

Revit 2024 API
ViewPlan..::..Create Method
ViewPlan Class Example See Also Send Feedback
Creates a new ViewPlan.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static ViewPlan Create(
    Document document,
    ElementId viewFamilyTypeId,
    ElementId levelId
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    viewFamilyTypeId As ElementId, _
    levelId As ElementId _
) As ViewPlan
Visual C++
public:
static ViewPlan^ Create(
    Document^ document,
    ElementId^ viewFamilyTypeId,
    ElementId^ levelId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the ViewPlan will be added.
viewFamilyTypeId
Type: Autodesk.Revit.DB..::..ElementId
The id of the ViewFamilyType which will be used by the new ViewPlan. The type needs to be a FloorPlan, CeilingPlan, AreaPlan, or StructuralPlan ViewType.
levelId
Type: Autodesk.Revit.DB..::..ElementId
The id of the Level to associate with the new plan view.

Return Value

The new ViewPlan.

Examples

CopyC#
// Create a Level and a Floor Plan based on it
double elevation = 10.0;
Level level1 = Level.Create(document, elevation);
ViewPlan floorView = ViewPlan.Create(document, floorPlanId, level1.Id);

// Create another Level and a Ceiling Plan based on it
elevation += 10.0;
Level level2 = Level.Create(document, elevation);
ViewPlan ceilingView = ViewPlan.Create(document, ceilingPlanId, level2.Id);
CopyVB.NET
   ' Create a Level and a Floor Plan based on it
   Dim elevation As Double = 10.0
Dim level1 As Level = Level.Create(document, elevation)
   Dim floorView As ViewPlan = ViewPlan.Create(document, floorPlanId, level1.Id)

   ' Create another Level and a Ceiling Plan based on it
   elevation += 10.0
Dim level2 As Level = Level.Create(document, elevation)
   Dim ceilingView As ViewPlan = ViewPlan.Create(document, ceilingPlanId, level2.Id)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This view family type is not a plan view type. -or- The ElementId levelId does not correspond to a Level. -or- StructuralPlans can only be created when the structural discipline is enabled whereas FloorPlans and CeilingPlans can only be created when architecture or MEP disciplines are enabled. -or- Plan view creation is not allowed in this family.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

ViewPlan Class


GetUnderlayBaseLevel Method

[image]

Revit 2024 API
ViewPlan..::..GetUnderlayBaseLevel Method
ViewPlan Class See Also Send Feedback
Returns the element id of the level that defines the bottom of the underlay range.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public ElementId GetUnderlayBaseLevel()
Visual Basic
Public Function GetUnderlayBaseLevel As ElementId
Visual C++
public:
ElementId^ GetUnderlayBaseLevel()

Return Value

If InvalidElementId is returned, then the underlay base level is not set and no elements will be displayed as underlay.

See Also

ViewPlan Class


GetUnderlayOrientation Method

[image]

Revit 2024 API
ViewPlan..::..GetUnderlayOrientation Method
ViewPlan Class See Also Send Feedback
Returns the underlay orientation of this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public UnderlayOrientation GetUnderlayOrientation()
Visual Basic
Public Function GetUnderlayOrientation As UnderlayOrientation
Visual C++
public:
UnderlayOrientation GetUnderlayOrientation()

Return Value

The underlay orientation for this view.

See Also

ViewPlan Class


GetUnderlayTopLevel Method

[image]

Revit 2024 API
ViewPlan..::..GetUnderlayTopLevel Method
ViewPlan Class See Also Send Feedback
Returns the element id of the level that defines the top of the underlay range.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public ElementId GetUnderlayTopLevel()
Visual Basic
Public Function GetUnderlayTopLevel As ElementId
Visual C++
public:
ElementId^ GetUnderlayTopLevel()

Return Value

If the underlay base level is a valid level, and this method returns InvalidElementId, then the underlay range is unbounded, and consists of everything above the underlay base level.

See Also

ViewPlan Class


GetViewRange Method

[image]

Revit 2024 API
ViewPlan..::..GetViewRange Method
ViewPlan Class See Also Send Feedback
Gets the view range.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public PlanViewRange GetViewRange()
Visual Basic
Public Function GetViewRange As PlanViewRange
Visual C++
public:
PlanViewRange^ GetViewRange()

Return Value

The view range.

See Also

ViewPlan Class


Print Method

[image] [image]

Revit 2024 API
ViewPlan..::..Print Method
ViewPlan Class See Also Send Feedback
Print this view.

Overload List

 | Name | Description
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)

See Also

ViewPlan Class
ViewPlan Members


SetUnderlayBaseLevel Method

[image]

Revit 2024 API
ViewPlan..::..SetUnderlayBaseLevel Method
ViewPlan Class See Also Send Feedback
Sets the level whose elevation will determine the bottom of the underlay range. The elevation of the next highest level will be used to determine the top of the underlay range.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public void SetUnderlayBaseLevel(
    ElementId levelId
)
Visual Basic
Public Sub SetUnderlayBaseLevel ( _
    levelId As ElementId _
)
Visual C++
public:
void SetUnderlayBaseLevel(
    ElementId^ levelId
)

Parameters

levelId
Type: Autodesk.Revit.DB..::..ElementId
The element id of a level in the project or else InvalidElementId.

Remarks

If the level specified is the highest level, the underlay range will be unbounded. The underlay range will consist of everything above the specified level.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId levelId does not correspond to a Level in the project.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ViewPlan Class


SetUnderlayRange Method

[image]

Revit 2024 API
ViewPlan..::..SetUnderlayRange Method
ViewPlan Class Example See Also Send Feedback
Sets the underlay base and underlay top to the specified levels.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public void SetUnderlayRange(
    ElementId baseLevelId,
    ElementId topLevelId
)
Visual Basic
Public Sub SetUnderlayRange ( _
    baseLevelId As ElementId, _
    topLevelId As ElementId _
)
Visual C++
public:
void SetUnderlayRange(
    ElementId^ baseLevelId,
    ElementId^ topLevelId
)

Parameters

baseLevelId
Type: Autodesk.Revit.DB..::..ElementId
The element id of a level in the project or InvalidElementId. If InvalidElementId, then the underlay base level is not set and no elements will be displayed as underlay.
topLevelId
Type: Autodesk.Revit.DB..::..ElementId
The element id of a level in the project or InvalidElementId. If InvalidElementId, then the underlay range is unbounded.

Examples

CopyC#
private void ViewUnderlay(ViewPlan planView, ElementId topLevelId, ElementId baseLevelId)
{
    if (planView.GetUnderlayOrientation() == UnderlayOrientation.LookingDown)
    {
        if (planView.GetUnderlayTopLevel() != topLevelId)
        {
            planView.SetUnderlayRange(baseLevelId, topLevelId);
        }

        planView.SetUnderlayOrientation(UnderlayOrientation.LookingUp);
    }
}
CopyVB.NET
Private Sub ViewUnderlay(planView As ViewPlan, topLevelId As ElementId, baseLevelId As ElementId)
    If planView.GetUnderlayOrientation() = UnderlayOrientation.LookingDown Then
        If planView.GetUnderlayTopLevel() <> topLevelId Then
            planView.SetUnderlayRange(baseLevelId, topLevelId)
        End If

        planView.SetUnderlayOrientation(UnderlayOrientation.LookingUp)
    End If
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId baseLevelId does not correspond to a Level in the project. -or- The ElementId topLevelId does not correspond to a Level in the project. -or- The elevation of level topLevelId must be greater than the elevation of level baseLevelId.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ViewPlan Class


SetViewRange Method

[image]

Revit 2024 API
ViewPlan..::..SetViewRange Method
ViewPlan Class See Also Send Feedback
Sets the view range.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void SetViewRange(
    PlanViewRange planViewRange
)
Visual Basic
Public Sub SetViewRange ( _
    planViewRange As PlanViewRange _
)
Visual C++
public:
void SetViewRange(
    PlanViewRange^ planViewRange
)

Parameters

planViewRange
Type: Autodesk.Revit.DB..::..PlanViewRange
The view range.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Plan view range is not valid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ViewPlan Class


ViewPlan Properties

[image] [image]

Revit 2024 API
ViewPlan Properties
ViewPlan Class See Also Send Feedback

The ViewPlan type exposes the following members.

Properties

 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View.)
Public property | AreAnalyticalModelCategoriesHidden | Indicates if analytical model categories are currently hidden in the view. (Inherited from View.)
Public property | AreAnnotationCategoriesHidden | Indicates if annotation categories are currently hidden in the view. (Inherited from View.)
Public property | AreaScheme | The area scheme.
Public property | AreCoordinationModelHandlesHidden | Indicates if Coordination Model handles are currently hidden in the view. (Inherited from View.)
Public property | AreImportCategoriesHidden | Indicates if import categories are currently hidden in the view. (Inherited from View.)
Public property | AreModelCategoriesHidden | Indicates if model categories are currently hidden in the view. (Inherited from View.)
Public property | ArePointCloudsHidden | Indicates if point clouds are currently hidden in the view. (Inherited from View.)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view. (Inherited from View.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CropBox | The Crop Box applied to the view, or an outline encompassing the crop region applied to the view. (Inherited from View.)
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View.)
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DetailLevel | The detail level of this view. (Inherited from View.)
Public property | Discipline | The Discipline of the view. (Inherited from View.)
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style. (Inherited from View.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | GenLevel | The level for the view. (Inherited from View.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsAssemblyView | Indicates if the view is assembly view. (Inherited from View.)
Public property | IsCallout | Indicates if the view is a callout view. (Inherited from View.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTemplate | Test whether the view is a view template. (Inherited from View.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Origin | Returns the origin of the screen. (Inherited from View.)
Public property | Outline | The bounds of the view in paper space (in feet). (Inherited from View.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PartsVisibility | The visibility setting for parts in this view. (Inherited from View.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RevealConstraintsMode | Indicates whether the Reveal Constraints mode is activated in the view. (Inherited from View.)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Public property | Scale | The scale of the view. (Inherited from View.)
Public property | ShadowIntensity | The intesity of cast shadows - 0 = no shadows, 100 = black. (Inherited from View.)
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View.)
Public property | SunlightIntensity | The intensity of the simulated (directional) sunlight. 0 = no directional light; maximum value is 100. (Inherited from View.)
Public property | TemporaryViewModes | Data of temporary view modes associated with this view. (Inherited from View.)
Public property | Title | The view title. This consists of the view name plus other modifiers, such as the view type, sheet number, area scheme, and/or assembly type, depending on the specifics of the view. (Inherited from View.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | ViewTemplateId | The id of the template view that controls this view's parameters. (Inherited from View.)
Public property | ViewType | The type of the view. (Inherited from View.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ViewPlan Class


AreaScheme Property

[image]

Revit 2024 API
ViewPlan..::..AreaScheme Property
ViewPlan Class See Also Send Feedback
The area scheme.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public AreaScheme AreaScheme { get; }
Visual Basic
Public ReadOnly Property AreaScheme As AreaScheme
    Get
Visual C++
public:
property AreaScheme^ AreaScheme {
    AreaScheme^ get ();
}

Field Value

Returns nullNothingnullptra null reference (Nothing in Visual Basic) if this plan view is not an area plan.

See Also

ViewPlan Class


Parameter Property

[image] [image]

Revit 2024 API
ViewPlan..::..Parameter Property
ViewPlan Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ViewPlan Class
ViewPlan Members


ViewPlanType Enumeration

[image]

Revit 2024 API
ViewPlanType Enumeration
See Also Send Feedback
An enumerated type listing plan view types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum ViewPlanType
Visual Basic
Public Enumeration ViewPlanType
Visual C++
public enum class ViewPlanType

Members

Member name | Description
FloorPlan | Floor plan view.
CeilingPlan | Reflected ceiling plan view.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


Viewport Class

[image]

Revit 2024 API
Viewport Class
Members See Also Send Feedback
An element that establishes the placement of a view on a sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public class Viewport : Element
Visual Basic
Public Class Viewport _
    Inherits Element
Visual C++
public ref class Viewport : public Element

Remarks

Viewports are used in Revit for purposes other than placement of views on sheets. Thus iteration of viewport elements in the model may locate viewports which are not assigned to sheets; you can use the SheetId property to filter these out.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..Viewport

See Also

Viewport Members


Viewport Members

[image] [image]

Revit 2024 API
Viewport Members
Viewport Class Methods Properties See Also Send Feedback

The Viewport type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
 | CanAddViewToSheet | Verifies that the view can be added to the ViewSheet.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create | Creates a new Viewport at a given location on a sheet.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetBoxCenter | Returns the center of the outline of the viewport on the sheet, excluding the viewport label.
Public method | GetBoxOutline | Returns the outline of the viewport on the sheet, excluding the viewport label.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLabelOutline | Gets the outline viewport's label on the sheet.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetProjectionToSheetTransform | Returns the transform from the view's projection space to the sheet space.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasViewportTransforms | Indicates if the viewport has transforms.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | IsViewIdValidForViewport | Verifies that the Viewport can change it's view id to the input %viewId%.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetBoxCenter | Moves this viewport so that the center of the box outline (excluding the viewport label) is at a given point.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LabelLineLength | The length of the viewport label line in sheet space, measured in feet.
Public property | LabelOffset | The offset is a two-dimensional vector from left bottom corner of the viewport with Rotation set to None to the left end of the viewport label line. The Z coordinate is ignored.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Rotation | The rotation of the viewport on the sheet.
Public property | SheetId | The element id of the ViewSheet on which the viewport appears, or InvalidElementId if this viewport does not associate a view with placement onto a sheet.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewId | The element id of the associated View.
Public property | ViewportPositioning | Specifies the method the viewport will be positioned on the sheet when swapped to another view. Default is set to ViewportPositioning::ViewportCenter.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Viewport Class


Viewport Methods

[image] [image]

Revit 2024 API
Viewport Methods
Viewport Class See Also Send Feedback

The Viewport type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
 | CanAddViewToSheet | Verifies that the view can be added to the ViewSheet.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
 | Create | Creates a new Viewport at a given location on a sheet.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetBoxCenter | Returns the center of the outline of the viewport on the sheet, excluding the viewport label.
Public method | GetBoxOutline | Returns the outline of the viewport on the sheet, excluding the viewport label.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLabelOutline | Gets the outline viewport's label on the sheet.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetProjectionToSheetTransform | Returns the transform from the view's projection space to the sheet space.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasViewportTransforms | Indicates if the viewport has transforms.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | IsViewIdValidForViewport | Verifies that the Viewport can change it's view id to the input %viewId%.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetBoxCenter | Moves this viewport so that the center of the box outline (excluding the viewport label) is at a given point.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Viewport Class


CanAddViewToSheet Method

[image]

Revit 2024 API
Viewport..::..CanAddViewToSheet Method
Viewport Class See Also Send Feedback
Verifies that the view can be added to the ViewSheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static bool CanAddViewToSheet(
    Document document,
    ElementId viewSheetId,
    ElementId viewId
)
Visual Basic
Public Shared Function CanAddViewToSheet ( _
    document As Document, _
    viewSheetId As ElementId, _
    viewId As ElementId _
) As Boolean
Visual C++
public:
static bool CanAddViewToSheet(
    Document^ document,
    ElementId^ viewSheetId,
    ElementId^ viewId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which the views reside.
viewSheetId
Type: Autodesk.Revit.DB..::..ElementId
The ViewSheet on which the view will be placed.
viewId
Type: Autodesk.Revit.DB..::..ElementId
The view which will be checked to see if it can be placed on the sheet.

Return Value

True if the view can be added to the ViewSheet, false otherwise.

Remarks

Schedule views are not handled by the Viewport class. Refer to [!:Autodesk::Revit::DB::ScheduleSheetInstance::Create()] for information about adding schedules to sheets.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Viewport Class


Create Method

[image]

Revit 2024 API
Viewport..::..Create Method
Viewport Class See Also Send Feedback
Creates a new Viewport at a given location on a sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static Viewport Create(
    Document document,
    ElementId viewSheetId,
    ElementId viewId,
    XYZ point
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    viewSheetId As ElementId, _
    viewId As ElementId, _
    point As XYZ _
) As Viewport
Visual C++
public:
static Viewport^ Create(
    Document^ document,
    ElementId^ viewSheetId,
    ElementId^ viewId,
    XYZ^ point
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new Viewport will be added.
viewSheetId
Type: Autodesk.Revit.DB..::..ElementId
The ViewSheet on which the new Viewport will be placed.
viewId
Type: Autodesk.Revit.DB..::..ElementId
The view shown in the Viewport.
point
Type: Autodesk.Revit.DB..::..XYZ
The new Viewport will be centered on this point.

Return Value

The new Viewport.

Remarks

Use [!:Autodesk::Revit::DB::ScheduleSheetInstance::Create()] to add schedules to sheets.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | viewSheetId is not a ViewSheet. -or- viewId cannot be added to the ViewSheet. -or- Plan view creation is not allowed in this family.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | This method may not be called during dynamic update.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

Viewport Class


GetBoxCenter Method

[image]

Revit 2024 API
Viewport..::..GetBoxCenter Method
Viewport Class See Also Send Feedback
Returns the center of the outline of the viewport on the sheet, excluding the viewport label.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public XYZ GetBoxCenter()
Visual Basic
Public Function GetBoxCenter As XYZ
Visual C++
public:
XYZ^ GetBoxCenter()

Return Value

The center of the outline of the viewport on the sheet.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The viewport is not on a sheet.

See Also

Viewport Class


GetBoxOutline Method

[image]

Revit 2024 API
Viewport..::..GetBoxOutline Method
Viewport Class See Also Send Feedback
Returns the outline of the viewport on the sheet, excluding the viewport label.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public Outline GetBoxOutline()
Visual Basic
Public Function GetBoxOutline As Outline
Visual C++
public:
Outline^ GetBoxOutline()

Return Value

The outline of the viewport on the sheet.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The viewport is not on a sheet.

See Also

Viewport Class


GetProjectionToSheetTransform Method

[image]

Revit 2024 API
Viewport..::..GetProjectionToSheetTransform Method
Viewport Class See Also Send Feedback
Returns the transform from the view's projection space to the sheet space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public Transform GetProjectionToSheetTransform()
Visual Basic
Public Function GetProjectionToSheetTransform As Transform
Visual C++
public:
Transform^ GetProjectionToSheetTransform()

Return Value

The transform from the view's projection space to the sheet space.

Remarks

This transform accounts for the position and rotation of a viewport on a sheet.

The transforms from the model space to the view projection space are returned by [!:View.GetModelToProjectionTransforms()].

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The viewport is not on a sheet. -or- The viewport does not have transforms.

See Also

Viewport Class


HasViewportTransforms Method

[image]

Revit 2024 API
Viewport..::..HasViewportTransforms Method
Viewport Class See Also Send Feedback
Indicates if the viewport has transforms.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public bool HasViewportTransforms()
Visual Basic
Public Function HasViewportTransforms As Boolean
Visual C++
public:
bool HasViewportTransforms()

Return Value

True if the viewport has transforms, false otherwise.

Remarks

Not all viewports have transforms. For example, viewports for schedules and legends do not have transforms.

See Also

Viewport Class


IsViewIdValidForViewport Method

[image]

Revit 2024 API
Viewport..::..IsViewIdValidForViewport Method
Viewport Class See Also Send Feedback
Verifies that the Viewport can change it's view id to the input %viewId%.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public bool IsViewIdValidForViewport(
    ElementId viewId
)
Visual Basic
Public Function IsViewIdValidForViewport ( _
    viewId As ElementId _
) As Boolean
Visual C++
public:
bool IsViewIdValidForViewport(
    ElementId^ viewId
)

Parameters

viewId
Type: Autodesk.Revit.DB..::..ElementId
The view which will be checked to see if it can be applied to Viewport.

Return Value

True if the %viewId% is valid for the viewport, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

Viewport Class


SetBoxCenter Method

[image]

Revit 2024 API
Viewport..::..SetBoxCenter Method
Viewport Class Example See Also Send Feedback
Moves this viewport so that the center of the box outline (excluding the viewport label) is at a given point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void SetBoxCenter(
    XYZ newCenterPoint
)
Visual Basic
Public Sub SetBoxCenter ( _
    newCenterPoint As XYZ _
)
Visual C++
public:
void SetBoxCenter(
    XYZ^ newCenterPoint
)

Parameters

newCenterPoint
Type: Autodesk.Revit.DB..::..XYZ
The desired center for the box outline.

Examples

CopyC#
public static void PlaceAlignedViewsAtLeftCorner(Document doc)
{
    FilteredElementCollector fec = new FilteredElementCollector(doc);
    fec.OfClass(typeof(ViewPlan));
    var viewPlans = fec.Cast<ViewPlan>().Where<ViewPlan>(vp => !vp.IsTemplate && vp.ViewType == ViewType.CeilingPlan);

    ViewPlan vp1 = viewPlans.ElementAt(0);
    ViewPlan vp2 = viewPlans.ElementAt(1);

    using (Transaction t = new Transaction(doc, "Place on sheet"))
    {
        t.Start();

        // Add two viewports distinct from one another
        ViewSheet vs = ViewSheet.Create(doc, ElementId.InvalidElementId);
        Viewport viewport1 = Viewport.Create(doc, vs.Id, vp1.Id, new XYZ(0, 0, 0));
        Viewport viewport2 = Viewport.Create(doc, vs.Id, vp2.Id, new XYZ(0, 5, 0));

        doc.Regenerate();

        // Calculate the necessary move vector to align the lower left corner
        Outline outline1 = viewport1.GetBoxOutline();
        Outline outline2 = viewport2.GetBoxOutline();
        XYZ boxCenter = viewport2.GetBoxCenter();
        XYZ vectorToCenter = boxCenter - outline2.MinimumPoint;
        XYZ newCenter = outline1.MinimumPoint + vectorToCenter;

        // Move the viewport to the new location
        viewport2.SetBoxCenter(newCenter);

        t.Commit();
    }
}
CopyVB.NET
Public Shared Sub PlaceAlignedViewsAtLeftCorner(doc As Document)
    Dim fec As New FilteredElementCollector(doc)
    fec.OfClass(GetType(ViewPlan))
    Dim viewPlans = fec.Cast(Of ViewPlan)().Where(Function(vp) Not vp.IsTemplate AndAlso vp.ViewType = ViewType.CeilingPlan)

    Dim vp1 As ViewPlan = viewPlans.ElementAt(0)
    Dim vp2 As ViewPlan = viewPlans.ElementAt(1)

    Using t As New Transaction(doc, "Place on sheet")
        t.Start()

        ' Add two viewports distinct from one another
        Dim vs As ViewSheet = ViewSheet.Create(doc, ElementId.InvalidElementId)
        Dim viewport1 As Viewport = Viewport.Create(doc, vs.Id, vp1.Id, New XYZ(0, 0, 0))
        Dim viewport2 As Viewport = Viewport.Create(doc, vs.Id, vp2.Id, New XYZ(0, 5, 0))

        doc.Regenerate()

        ' Calculate the necessary move vector to align the lower left corner
        Dim outline1 As Outline = viewport1.GetBoxOutline()
        Dim outline2 As Outline = viewport2.GetBoxOutline()
        Dim boxCenter As XYZ = viewport2.GetBoxCenter()
        Dim vectorToCenter As XYZ = boxCenter - outline2.MinimumPoint
        Dim newCenter As XYZ = outline1.MinimumPoint + vectorToCenter

        ' Move the viewport to the new location
        viewport2.SetBoxCenter(newCenter)

        t.Commit()
    End Using
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | The viewport is not on a sheet.

See Also

Viewport Class


Viewport Properties

[image] [image]

Revit 2024 API
Viewport Properties
Viewport Class See Also Send Feedback

The Viewport type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LabelLineLength | The length of the viewport label line in sheet space, measured in feet.
Public property | LabelOffset | The offset is a two-dimensional vector from left bottom corner of the viewport with Rotation set to None to the left end of the viewport label line. The Z coordinate is ignored.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Rotation | The rotation of the viewport on the sheet.
Public property | SheetId | The element id of the ViewSheet on which the viewport appears, or InvalidElementId if this viewport does not associate a view with placement onto a sheet.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewId | The element id of the associated View.
Public property | ViewportPositioning | Specifies the method the viewport will be positioned on the sheet when swapped to another view. Default is set to ViewportPositioning::ViewportCenter.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Viewport Class


LabelLineLength Property

[image]

Revit 2024 API
Viewport..::..LabelLineLength Property
Viewport Class See Also Send Feedback
The length of the viewport label line in sheet space, measured in feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public double LabelLineLength { get; set; }
Visual Basic
Public Property LabelLineLength As Double
    Get
    Set
Visual C++
public:
property double LabelLineLength {
    double get ();
    void set (double value);
}

Remarks

It can be negative. The sign depends on the direction of the label line.

See Also

Viewport Class


Rotation Property

[image]

Revit 2024 API
Viewport..::..Rotation Property
Viewport Class See Also Send Feedback
The rotation of the viewport on the sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ViewportRotation Rotation { get; set; }
Visual Basic
Public Property Rotation As ViewportRotation
    Get
    Set
Visual C++
public:
property ViewportRotation Rotation {
    ViewportRotation get ();
    void set (ViewportRotation value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

Viewport Class


SheetId Property

[image]

Revit 2024 API
Viewport..::..SheetId Property
Viewport Class See Also Send Feedback
The element id of the ViewSheet on which the viewport appears, or InvalidElementId if this viewport does not associate a view with placement onto a sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ElementId SheetId { get; }
Visual Basic
Public ReadOnly Property SheetId As ElementId
    Get
Visual C++
public:
property ElementId^ SheetId {
    ElementId^ get ();
}

See Also

Viewport Class


ViewportRotation Enumeration

[image]

Revit 2024 API
ViewportRotation Enumeration
See Also Send Feedback
Rotation of the viewport

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public enum ViewportRotation
Visual Basic
Public Enumeration ViewportRotation
Visual C++
public enum class ViewportRotation

Members

Member name | Description
None | Viewport is not rotated.
Clockwise | Viewport is rotated 90 degrees clockwise.
Counterclockwise | Viewport is rotated 90 degrees counterclockwise.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


ViewSchedule Class

[image]

Revit 2024 API
ViewSchedule Class
Members See Also Send Feedback
A schedule view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public class ViewSchedule : TableView
Visual Basic
Public Class ViewSchedule _
    Inherits TableView
Visual C++
public ref class ViewSchedule : public TableView

Remarks

The ViewSchedule class represents schedules and other schedule-like views, including single-category and multi-category schedules, key schedules, material takeoffs, view lists, sheet lists, keynote legends, revision schedules, and note blocks. The ViewSchedule class is not used for panel schedules (see PanelScheduleView) or graphical column schedules.

A schedule is a tabular representation of data. A typical schedule shows all elements of a category (doors, rooms, etc.) with each row representing an element and each column representing a parameter. This basic structure can be modified using filters, sorting, grouping, totals, formulas, and other features.

The ScheduleDefinition class contains most settings that determine the contents of a schedule, including category, fields, filters, and sorting.

A graphical representation of a schedule can be placed on a sheet using the ScheduleSheetInstance class.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..View
Autodesk.Revit.DB..::..TableView
Autodesk.Revit.DB..::..ViewSchedule

See Also

ViewSchedule Members


ViewSchedule Members

[image] [image]

Revit 2024 API
ViewSchedule Members
ViewSchedule Class Methods Properties See Also Send Feedback

The ViewSchedule type exposes the following members.

Methods

 | Name | Description
Public method | AddFilter | Adds a filter to the view. (Inherited from View.)
Public method | AllowsAnalysisDisplay | Identifies if this view allows display of Analysis results. (Inherited from View.)
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of the input view that are not controlled by the current view template. (Inherited from View.)
Public method | AreGraphicsOverridesAllowed | Determines if Visibility/Graphics Overriddes can be applied to the view. (Inherited from View.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanApplyColorFillScheme | Checks if the id can be applied as the scheme id of specified category to this view. (Inherited from View.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanCategoryBeHidden | Checks whether the category can be hidden in the view. (Inherited from View.)
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view. (Inherited from View.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanEnableTemporaryViewPropertiesMode | Indicates if Temporary View Properties mode can be applied for view in current state. (Inherited from View.)
Public method | CanGroupHeaders | Indicates if selected headers can be grouped for this schedule.
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified. (Inherited from View.)
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified. (Inherited from View.)
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified (Inherited from View.)
Public method | CanUngroupHeaders | Indicates if selected headers can be ungrouped.
Public method | CanUseDepthCueing | Indicates if view can use Depth Cueing (Inherited from View.)
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes (Inherited from View.)
Public method | CanViewBeDuplicated | Identifies if this view can be duplicated. (Inherited from View.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view. (Inherited from View.)
Public method | ConvertToIndependent | Convert the dependent view to independent. (Inherited from View.)
 | CreateKeynoteLegend | Creates a keynote legend.
 | CreateKeySchedule | Create a key schedule.
 | CreateMaterialTakeoff | Creates a material takeoff.
 | CreateNoteBlock | Creates a note block.
 | CreateRevisionSchedule | Creates a revision schedule.
 | CreateSchedule(Document, ElementId) | Creates a regular schedule.
 | CreateSchedule(Document, ElementId, ElementId) | Creates a regular schedule that can relate to a specific area scheme.
 | CreateSheetList | Creates a sheet list.
 | CreateViewList | Creates a view list.
Public method | CreateViewTemplate | Creates a new view template instance from this view instance. (Inherited from View.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSegment | Deletes a schedule segment.
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode. (Inherited from View.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates this view. (Inherited from View.)
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode. (Inherited from View.)
Public method | EnableTemporaryViewPropertiesMode | Turns Temporary View Properties mode on or off. In this mode, any changes made to the view are temporary and will be discarded once the mode is disabled. (Inherited from View.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | Export | Exports the schedule data to a text file.
Public method | GetAvailableParameterCategories | Get all available parameter categories. (Inherited from TableView.)
Public method | GetBackground | Returns the current background set for the view. (Inherited from View.)
Public method | GetCalculatedValueName | Gets the calculated value name for a cell from the template view. (Inherited from TableView.)
Public method | GetCalculatedValueText | Gets the calculated value text for a cell from the instance view. (Inherited from TableView.)
Public method | GetCalloutParentId | Gets ID of the callout parent view. (Inherited from View.)
Public method | GetCategoryHidden | Checks if elements of the given category are set to be invisible (hidden) in this view. (Inherited from View.)
Public method | GetCategoryOverrides | Gets graphic overrides for a category in view. (Inherited from View.)
Public method | GetCellText | Gets the cell's text based on its type (Inherited from TableView.)
Public method | GetColorFillSchemeId | Returns id of the color fill scheme element applied to the view. (Inherited from View.)
Public method | GetCropRegionShapeManager | Returns an object for managing view crop region shape. (Inherited from View.)
 | GetDefaultNameForKeynoteLegend | Gets the default view name that will be used when creating a keynote legend.
 | GetDefaultNameForKeySchedule | Gets the default view name that will be used when creating a key schedule.
 | GetDefaultNameForMaterialTakeoff | Gets the default view name that will be used when creating a material takeoff.
 | GetDefaultNameForNoteBlock | Gets the default view name that will be used when creating a note block.
 | GetDefaultNameForRevisionSchedule | Gets the default view name that will be used when creating a revision schedule.
 | GetDefaultNameForSchedule(Document, ElementId) | Gets the default view name that will be used when creating a regular schedule.
 | GetDefaultNameForSchedule(Document, ElementId, ElementId) | Gets the default view name that will be used when creating a schedule.
 | GetDefaultNameForSheetList | Gets the default view name that will be used when creating a sheet list.
 | GetDefaultNameForViewList | Gets the default view name that will be used when creating a view list.
 | GetDefaultParameterNameForKeySchedule | Gets the default parameter name that will be used when creating a key schedule.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetDependentViewIds | Get the ids of dependent views. (Inherited from View.)
Public method | GetDepthCueing | Returns the current depth cueing settings for the view. (Inherited from View.)
Public method | GetDirectContext3DHandleOverrides | Returns DirectContext3D handle overrides object for the view. (Inherited from View.)
Public method | GetElementOverrides | Gets graphic overrides for an element in the view. (Inherited from View.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetFilterOverrides | Gets graphic overrides that a filter applies to the view. (Inherited from View.)
Public method | GetFilters | Gets the filters applied to the view. (Inherited from View.)
Public method | GetFilterVisibility | Gets the visibility of the elements associated with a filter. (Inherited from View.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIsFilterEnabled | Identifies if the filter is enabled in this view. (Inherited from View.)
Public method | GetLinkOverrides | Gets the graphic overrides of a RevitLinkType or RevitLinkInstance in view. (Inherited from View.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetModelToProjectionTransforms | Gets the transforms from the model space to the view projection space. (Inherited from View.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetNonControlledTemplateParameterIds | Returns a list of parameters that are not marked as included when this view is used as a template. (Inherited from View.)
Public method | GetOrderedFilters | Gets the filters applied to the view in the order they are applied. (Inherited from View.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPlacementOnSheetStatus | Determines if this view placed on a sheet completely or partially. (Inherited from View.)
Public method | GetPointCloudOverrides | Returns point cloud overrides object for the view. (Inherited from View.)
Public method | GetPrimaryViewId | Get the id of the primary view. (Inherited from View.)
Public method | GetReferenceCallouts | Returns element ids of all reference callouts in the view. (Inherited from View.)
Public method | GetReferenceElevations | Returns element ids of all reference elevations in the view. (Inherited from View.)
Public method | GetReferenceSections | Returns element ids of all reference sections in the view. (Inherited from View.)
Public method | GetScheduleHeightsOnSheet | Gets the heights of schedule title, column header and each schedule body row.
Public method | GetScheduleInstances | Gets the instances ids of schedule or schedule segment.
Public method | GetSegmentCount | Gets the total count of schedule segments.
Public method | GetSegmentHeight | Gets the segment height.
Public method | GetSketchyLines | Returns the current sketchy lines settings for the view. (Inherited from View.)
Public method | GetStripedRowsColor | Gets the color applied to part of the pattern for a schedule with striped rows.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetTableData | Gets the writable table data object.
Public method | GetTemplateParameterIds | Returns a list of parameter ids that may be controlled when this view is assigned as a template. (Inherited from View.)
Public method | GetTemporaryViewPropertiesId | When Temporary View Properties mode is in progress it provides view id that overrode settings for current view. Outside Temporary View Properties mode InvalidElementId will be returned. (Inherited from View.)
Public method | GetTemporaryViewPropertiesName | When Temporary View Properties mode is in progress, name of applied template is returned. Outside Temporary View Properties mode, empty string will be returned. (Inherited from View.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
 | GetValidCategoriesForKeySchedule | Gets a list of categories that can be used for a key schedule.
 | GetValidCategoriesForMaterialTakeoff | Gets a list of categories that can be used for a material takeoff.
 | GetValidCategoriesForSchedule | Gets a list of categories that can be used for a regular schedule.
 | GetValidFamiliesForNoteBlock | Gets a list of families that can be used for a note block.
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetViewDisplayModel | Returns the current view display model settings for the view. (Inherited from View.)
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view. (Inherited from View.)
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view. (Inherited from View.)
Public method | GroupHeaders | Groups schedule header cells.
Public method | HasDetailLevel | Check if the view has a Detail Level property (Inherited from View.)
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property (Inherited from View.)
Public method | HasImageField | Checks whether the schedule definition includes any image-related fields and if any elements in the schedule actually have images in those fields.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property (Inherited from View.)
Public method | HasViewTransforms | Returns true if the view reports model space to view projection space transforms. (Inherited from View.)
Public method | HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View.)
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view. (Inherited from View.)
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view. (Inherited from View.)
Public method | HideElements | Sets the elements to be hidden in the view. (Inherited from View.)
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View.)
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View.)
Public method | IsCategoryOverridable | Checks whether the category can have graphic overrides in this view. (Inherited from View.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDataOutOfDate | Indicates whether the schedule data is out of date.
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view. (Inherited from View.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsFilterApplied | Indicates if a filter is applied to the view. (Inherited from View.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode. (Inherited from View.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View.)
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSplit | Checks if the schedule is split.
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories. (Inherited from View.)
Public method | IsTemporaryViewPropertiesModeEnabled | Returns true when Temporary View Properties mode is in progress, false otherwise. (Inherited from View.)
 | IsValidCategoryForKeySchedule | Checks whether a category can be used for a key schedule.
 | IsValidCategoryForMaterialTakeoff | Checks whether a category can be used for a material takeoff.
 | IsValidCategoryForSchedule | Checks whether a category can be used for a regular schedule.
 | IsValidFamilyForNoteBlock | Checks whether a family can be used for a note block.
Public method | IsValidSectionType | Identifies if the section type is valid for this view. (Inherited from TableView.)
Public method | IsValidTextTypeId | Identifies if the input id represents a valid text type id for use in the schedule properties.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | IsValidViewTemplate | Verifies that the view represented by templateId can be set as the controlling view template for this view. (Inherited from View.)
Public method | IsViewValidForTemplateCreation | Verifies that the view is valid for template creation. (Inherited from View.)
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view. (Inherited from View.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | MergeSegments | Merges two adjacent segments into one.
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | RefreshData | Rebuilds the schedule data if it is out of date.
Public method | RemoveCalloutParent | Replaces callout parent ID with InvalidElementId. (Inherited from View.)
Public method | RemoveFilter | Removes a filter from the view. (Inherited from View.)
Public method | RemoveLinkOverrides | Deletes the graphical link overrides in the current view. (Inherited from View.)
Public method | RestoreCalloutParent | Restores callout parent ID to the original view ID if that view is still available. (Inherited from View.)
Public method | RestoreImageSize | Restores all images to their original sizes.
Public method | SetBackground | Sets the background for the view. Background can only be set for 3d views and for Sections/Elevations. (Inherited from View.)
Public method | SetCategoryHidden | Sets if elements of the given category will be visible in this view. (Inherited from View.)
Public method | SetCategoryOverrides | Sets graphic overrides for a category in view. (Inherited from View.)
Public method | SetColorFillSchemeId | Applies color fill scheme to this view. (Inherited from View.)
Public method | SetDepthCueing | Sets the depth cueing settings for the view. (Inherited from View.)
Public method | SetElementOverrides | Sets graphic overrides for an element in the view. (Inherited from View.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetFilterOverrides | Sets the overrides associated with a filter. (Inherited from View.)
Public method | SetFilterVisibility | Sets the visibility of the elements associated with a filter. (Inherited from View.)
Public method | SetIsFilterEnabled | Sets the filter enabled flag. (Inherited from View.)
Public method | SetLinkOverrides | Sets the graphic overrides of a RevitLinkType or RevitLinkInstance in the view. (Inherited from View.)
Public method | SetNonControlledTemplateParameterIds | Sets the parameters that will not be included when this view is used as a template. (Inherited from View.)
Public method | SetSegmentHeight | Sets the segment height.
Public method | SetSketchyLines | Sets the sketchy lines settings for the view. (Inherited from View.)
Public method | SetStripedRowsColor | Sets the color applied to part of the pattern for a schedule with striped rows.
Public method | SetViewDisplayModel | Sets the view display model settings for the view. (Inherited from View.)
Public method | SetWorksetVisibility | Sets visibility for a workset in this view. (Inherited from View.)
Public method | SetWorksharingDisplayMode | Sets the worksharing display mode for this view. (Inherited from View.)
Public method | ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View.)
Public method | Split(IList<(Of <<'(Double>)>>)) | Splits the schedule into several segments by given height of each segment.
Public method | Split(Int32) | Splits the schedule into several segments by given segment number.
Public method | SplitSegment | Splits the schedule segment by the given heights of new segments.
Public method | SupportedColorFillCategoryIds | Returns collection of all category ids that correspond to elements that can potentially be colored in this view according to a color fill scheme. The set may be different depending on the view type. (Inherited from View.)
Public method | SupportsRevealConstraints | Checks that the view can have the Reveal Constraints mode activated. (Inherited from View.)
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode. (Inherited from View.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UngroupHeaders | Ungroups selected headers of schedule.
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

Properties

 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View.)
Public property | AreAnalyticalModelCategoriesHidden | Indicates if analytical model categories are currently hidden in the view. (Inherited from View.)
Public property | AreAnnotationCategoriesHidden | Indicates if annotation categories are currently hidden in the view. (Inherited from View.)
Public property | AreCoordinationModelHandlesHidden | Indicates if Coordination Model handles are currently hidden in the view. (Inherited from View.)
Public property | AreImportCategoriesHidden | Indicates if import categories are currently hidden in the view. (Inherited from View.)
Public property | AreModelCategoriesHidden | Indicates if model categories are currently hidden in the view. (Inherited from View.)
Public property | ArePointCloudsHidden | Indicates if point clouds are currently hidden in the view. (Inherited from View.)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view. (Inherited from View.)
Public property | BodyTextTypeId | Defines the default text style used for the data section of the schedule.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CropBox | The Crop Box applied to the view, or an outline encompassing the crop region applied to the view. (Inherited from View.)
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View.)
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
Public property | Definition | The primary ScheduleDefinition.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DetailLevel | The detail level of this view. (Inherited from View.)
Public property | Discipline | The Discipline of the view. (Inherited from View.)
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style. (Inherited from View.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EmbeddedDefinition | The embedded ScheduleDefinition.
Public property | GenLevel | The level for the view. (Inherited from View.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | HasStripedRows | Indicates whether this schedule has striped rows.
Public property | HeaderTextTypeId | Defines the default text style used in the column headers in the body section of the schedule.
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | ImageRowHeight | Obsolete. Defines the image row height in the schedule.
Public property | IsAssemblyView | Indicates if the view is assembly view. (Inherited from View.)
Public property | IsCallout | Indicates if the view is a callout view. (Inherited from View.)
 | IsHeaderFrozen | A static property defining if the schedule header frozen setting is turned on or off in current Revit Application Session.
Public property | IsInternalKeynoteSchedule | Identifies if this ViewSchedule is an internal schedule used when keynotes are filtered based on the elements that are shown on a sheet.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTemplate | Test whether the view is a view template. (Inherited from View.)
Public property | IsTitleblockRevisionSchedule | Identifies if this ViewSchedule is an internal schedule used to display revision schedules as part of a titleblock.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | KeyScheduleParameterName | In a key schedule, the name of the parameter for choosing one of the keys.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MaximumColumnWidth | Gets the maximum column width (Inherited from TableView.)
Public property | MaximumGridWidth | Gets the allowed maximum grid width (Inherited from TableView.)
Public property | MaximumRowHeight | Gets the maximum row height (Inherited from TableView.)
Public property | MinimumColumnWidth | Gets the minimum column width (Inherited from TableView.)
Public property | MinimumRowHeight | Gets the minimum row height (Inherited from TableView.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Origin | Returns the origin of the screen. (Inherited from View.)
Public property | Outline | The bounds of the view in paper space (in feet). (Inherited from View.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PartsVisibility | The visibility setting for parts in this view. (Inherited from View.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RevealConstraintsMode | Indicates whether the Reveal Constraints mode is activated in the view. (Inherited from View.)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Public property | RowHeight | Defines the schedule body rows height.
Public property | RowHeightOverride | Defines the override that is applied to the row height.
Public property | Scale | The scale of the view. (Inherited from View.)
Public property | ShadowIntensity | The intesity of cast shadows - 0 = no shadows, 100 = black. (Inherited from View.)
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View.)
Public property | SunlightIntensity | The intensity of the simulated (directional) sunlight. 0 = no directional light; maximum value is 100. (Inherited from View.)
Public property | TargetId | the element id of the element that is being viewed (Inherited from TableView.)
Public property | TemporaryViewModes | Data of temporary view modes associated with this view. (Inherited from View.)
Public property | Title | The view title. This consists of the view name plus other modifiers, such as the view type, sheet number, area scheme, and/or assembly type, depending on the specifics of the view. (Inherited from View.)
Public property | TitleTextTypeId | Defines the default text style used in the header section of the schedule.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View.)
Public property | UseStripedRowsOnSheets | Indicates whether a property setting of true will also change the display of this schedule to show striped rows on a sheet. If true, setting that property to true will also change the display. If false, striped rows will not display for this schedule on a sheet no matter what value is set for HasStripedRows.
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | ViewTemplateId | The id of the template view that controls this view's parameters. (Inherited from View.)
Public property | ViewType | The type of the view. (Inherited from View.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ViewSchedule Class


ViewSchedule Methods

[image] [image]

Revit 2024 API
ViewSchedule Methods
ViewSchedule Class See Also Send Feedback

The ViewSchedule type exposes the following members.

Methods

 | Name | Description
Public method | AddFilter | Adds a filter to the view. (Inherited from View.)
Public method | AllowsAnalysisDisplay | Identifies if this view allows display of Analysis results. (Inherited from View.)
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of the input view that are not controlled by the current view template. (Inherited from View.)
Public method | AreGraphicsOverridesAllowed | Determines if Visibility/Graphics Overriddes can be applied to the view. (Inherited from View.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanApplyColorFillScheme | Checks if the id can be applied as the scheme id of specified category to this view. (Inherited from View.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanCategoryBeHidden | Checks whether the category can be hidden in the view. (Inherited from View.)
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view. (Inherited from View.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanEnableTemporaryViewPropertiesMode | Indicates if Temporary View Properties mode can be applied for view in current state. (Inherited from View.)
Public method | CanGroupHeaders | Indicates if selected headers can be grouped for this schedule.
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified. (Inherited from View.)
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified. (Inherited from View.)
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified (Inherited from View.)
Public method | CanUngroupHeaders | Indicates if selected headers can be ungrouped.
Public method | CanUseDepthCueing | Indicates if view can use Depth Cueing (Inherited from View.)
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes (Inherited from View.)
Public method | CanViewBeDuplicated | Identifies if this view can be duplicated. (Inherited from View.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view. (Inherited from View.)
Public method | ConvertToIndependent | Convert the dependent view to independent. (Inherited from View.)
 | CreateKeynoteLegend | Creates a keynote legend.
 | CreateKeySchedule | Create a key schedule.
 | CreateMaterialTakeoff | Creates a material takeoff.
 | CreateNoteBlock | Creates a note block.
 | CreateRevisionSchedule | Creates a revision schedule.
 | CreateSchedule(Document, ElementId) | Creates a regular schedule.
 | CreateSchedule(Document, ElementId, ElementId) | Creates a regular schedule that can relate to a specific area scheme.
 | CreateSheetList | Creates a sheet list.
 | CreateViewList | Creates a view list.
Public method | CreateViewTemplate | Creates a new view template instance from this view instance. (Inherited from View.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSegment | Deletes a schedule segment.
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode. (Inherited from View.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates this view. (Inherited from View.)
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode. (Inherited from View.)
Public method | EnableTemporaryViewPropertiesMode | Turns Temporary View Properties mode on or off. In this mode, any changes made to the view are temporary and will be discarded once the mode is disabled. (Inherited from View.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | Export | Exports the schedule data to a text file.
Public method | GetAvailableParameterCategories | Get all available parameter categories. (Inherited from TableView.)
Public method | GetBackground | Returns the current background set for the view. (Inherited from View.)
Public method | GetCalculatedValueName | Gets the calculated value name for a cell from the template view. (Inherited from TableView.)
Public method | GetCalculatedValueText | Gets the calculated value text for a cell from the instance view. (Inherited from TableView.)
Public method | GetCalloutParentId | Gets ID of the callout parent view. (Inherited from View.)
Public method | GetCategoryHidden | Checks if elements of the given category are set to be invisible (hidden) in this view. (Inherited from View.)
Public method | GetCategoryOverrides | Gets graphic overrides for a category in view. (Inherited from View.)
Public method | GetCellText | Gets the cell's text based on its type (Inherited from TableView.)
Public method | GetColorFillSchemeId | Returns id of the color fill scheme element applied to the view. (Inherited from View.)
Public method | GetCropRegionShapeManager | Returns an object for managing view crop region shape. (Inherited from View.)
 | GetDefaultNameForKeynoteLegend | Gets the default view name that will be used when creating a keynote legend.
 | GetDefaultNameForKeySchedule | Gets the default view name that will be used when creating a key schedule.
 | GetDefaultNameForMaterialTakeoff | Gets the default view name that will be used when creating a material takeoff.
 | GetDefaultNameForNoteBlock | Gets the default view name that will be used when creating a note block.
 | GetDefaultNameForRevisionSchedule | Gets the default view name that will be used when creating a revision schedule.
 | GetDefaultNameForSchedule(Document, ElementId) | Gets the default view name that will be used when creating a regular schedule.
 | GetDefaultNameForSchedule(Document, ElementId, ElementId) | Gets the default view name that will be used when creating a schedule.
 | GetDefaultNameForSheetList | Gets the default view name that will be used when creating a sheet list.
 | GetDefaultNameForViewList | Gets the default view name that will be used when creating a view list.
 | GetDefaultParameterNameForKeySchedule | Gets the default parameter name that will be used when creating a key schedule.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetDependentViewIds | Get the ids of dependent views. (Inherited from View.)
Public method | GetDepthCueing | Returns the current depth cueing settings for the view. (Inherited from View.)
Public method | GetDirectContext3DHandleOverrides | Returns DirectContext3D handle overrides object for the view. (Inherited from View.)
Public method | GetElementOverrides | Gets graphic overrides for an element in the view. (Inherited from View.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetFilterOverrides | Gets graphic overrides that a filter applies to the view. (Inherited from View.)
Public method | GetFilters | Gets the filters applied to the view. (Inherited from View.)
Public method | GetFilterVisibility | Gets the visibility of the elements associated with a filter. (Inherited from View.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIsFilterEnabled | Identifies if the filter is enabled in this view. (Inherited from View.)
Public method | GetLinkOverrides | Gets the graphic overrides of a RevitLinkType or RevitLinkInstance in view. (Inherited from View.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetModelToProjectionTransforms | Gets the transforms from the model space to the view projection space. (Inherited from View.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetNonControlledTemplateParameterIds | Returns a list of parameters that are not marked as included when this view is used as a template. (Inherited from View.)
Public method | GetOrderedFilters | Gets the filters applied to the view in the order they are applied. (Inherited from View.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPlacementOnSheetStatus | Determines if this view placed on a sheet completely or partially. (Inherited from View.)
Public method | GetPointCloudOverrides | Returns point cloud overrides object for the view. (Inherited from View.)
Public method | GetPrimaryViewId | Get the id of the primary view. (Inherited from View.)
Public method | GetReferenceCallouts | Returns element ids of all reference callouts in the view. (Inherited from View.)
Public method | GetReferenceElevations | Returns element ids of all reference elevations in the view. (Inherited from View.)
Public method | GetReferenceSections | Returns element ids of all reference sections in the view. (Inherited from View.)
Public method | GetScheduleHeightsOnSheet | Gets the heights of schedule title, column header and each schedule body row.
Public method | GetScheduleInstances | Gets the instances ids of schedule or schedule segment.
Public method | GetSegmentCount | Gets the total count of schedule segments.
Public method | GetSegmentHeight | Gets the segment height.
Public method | GetSketchyLines | Returns the current sketchy lines settings for the view. (Inherited from View.)
Public method | GetStripedRowsColor | Gets the color applied to part of the pattern for a schedule with striped rows.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetTableData | Gets the writable table data object.
Public method | GetTemplateParameterIds | Returns a list of parameter ids that may be controlled when this view is assigned as a template. (Inherited from View.)
Public method | GetTemporaryViewPropertiesId | When Temporary View Properties mode is in progress it provides view id that overrode settings for current view. Outside Temporary View Properties mode InvalidElementId will be returned. (Inherited from View.)
Public method | GetTemporaryViewPropertiesName | When Temporary View Properties mode is in progress, name of applied template is returned. Outside Temporary View Properties mode, empty string will be returned. (Inherited from View.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
 | GetValidCategoriesForKeySchedule | Gets a list of categories that can be used for a key schedule.
 | GetValidCategoriesForMaterialTakeoff | Gets a list of categories that can be used for a material takeoff.
 | GetValidCategoriesForSchedule | Gets a list of categories that can be used for a regular schedule.
 | GetValidFamiliesForNoteBlock | Gets a list of families that can be used for a note block.
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetViewDisplayModel | Returns the current view display model settings for the view. (Inherited from View.)
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view. (Inherited from View.)
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view. (Inherited from View.)
Public method | GroupHeaders | Groups schedule header cells.
Public method | HasDetailLevel | Check if the view has a Detail Level property (Inherited from View.)
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property (Inherited from View.)
Public method | HasImageField | Checks whether the schedule definition includes any image-related fields and if any elements in the schedule actually have images in those fields.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property (Inherited from View.)
Public method | HasViewTransforms | Returns true if the view reports model space to view projection space transforms. (Inherited from View.)
Public method | HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View.)
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view. (Inherited from View.)
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view. (Inherited from View.)
Public method | HideElements | Sets the elements to be hidden in the view. (Inherited from View.)
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View.)
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View.)
Public method | IsCategoryOverridable | Checks whether the category can have graphic overrides in this view. (Inherited from View.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDataOutOfDate | Indicates whether the schedule data is out of date.
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view. (Inherited from View.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsFilterApplied | Indicates if a filter is applied to the view. (Inherited from View.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode. (Inherited from View.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View.)
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSplit | Checks if the schedule is split.
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories. (Inherited from View.)
Public method | IsTemporaryViewPropertiesModeEnabled | Returns true when Temporary View Properties mode is in progress, false otherwise. (Inherited from View.)
 | IsValidCategoryForKeySchedule | Checks whether a category can be used for a key schedule.
 | IsValidCategoryForMaterialTakeoff | Checks whether a category can be used for a material takeoff.
 | IsValidCategoryForSchedule | Checks whether a category can be used for a regular schedule.
 | IsValidFamilyForNoteBlock | Checks whether a family can be used for a note block.
Public method | IsValidSectionType | Identifies if the section type is valid for this view. (Inherited from TableView.)
Public method | IsValidTextTypeId | Identifies if the input id represents a valid text type id for use in the schedule properties.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | IsValidViewTemplate | Verifies that the view represented by templateId can be set as the controlling view template for this view. (Inherited from View.)
Public method | IsViewValidForTemplateCreation | Verifies that the view is valid for template creation. (Inherited from View.)
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view. (Inherited from View.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | MergeSegments | Merges two adjacent segments into one.
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | RefreshData | Rebuilds the schedule data if it is out of date.
Public method | RemoveCalloutParent | Replaces callout parent ID with InvalidElementId. (Inherited from View.)
Public method | RemoveFilter | Removes a filter from the view. (Inherited from View.)
Public method | RemoveLinkOverrides | Deletes the graphical link overrides in the current view. (Inherited from View.)
Public method | RestoreCalloutParent | Restores callout parent ID to the original view ID if that view is still available. (Inherited from View.)
Public method | RestoreImageSize | Restores all images to their original sizes.
Public method | SetBackground | Sets the background for the view. Background can only be set for 3d views and for Sections/Elevations. (Inherited from View.)
Public method | SetCategoryHidden | Sets if elements of the given category will be visible in this view. (Inherited from View.)
Public method | SetCategoryOverrides | Sets graphic overrides for a category in view. (Inherited from View.)
Public method | SetColorFillSchemeId | Applies color fill scheme to this view. (Inherited from View.)
Public method | SetDepthCueing | Sets the depth cueing settings for the view. (Inherited from View.)
Public method | SetElementOverrides | Sets graphic overrides for an element in the view. (Inherited from View.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetFilterOverrides | Sets the overrides associated with a filter. (Inherited from View.)
Public method | SetFilterVisibility | Sets the visibility of the elements associated with a filter. (Inherited from View.)
Public method | SetIsFilterEnabled | Sets the filter enabled flag. (Inherited from View.)
Public method | SetLinkOverrides | Sets the graphic overrides of a RevitLinkType or RevitLinkInstance in the view. (Inherited from View.)
Public method | SetNonControlledTemplateParameterIds | Sets the parameters that will not be included when this view is used as a template. (Inherited from View.)
Public method | SetSegmentHeight | Sets the segment height.
Public method | SetSketchyLines | Sets the sketchy lines settings for the view. (Inherited from View.)
Public method | SetStripedRowsColor | Sets the color applied to part of the pattern for a schedule with striped rows.
Public method | SetViewDisplayModel | Sets the view display model settings for the view. (Inherited from View.)
Public method | SetWorksetVisibility | Sets visibility for a workset in this view. (Inherited from View.)
Public method | SetWorksharingDisplayMode | Sets the worksharing display mode for this view. (Inherited from View.)
Public method | ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View.)
Public method | Split(IList<(Of <<'(Double>)>>)) | Splits the schedule into several segments by given height of each segment.
Public method | Split(Int32) | Splits the schedule into several segments by given segment number.
Public method | SplitSegment | Splits the schedule segment by the given heights of new segments.
Public method | SupportedColorFillCategoryIds | Returns collection of all category ids that correspond to elements that can potentially be colored in this view according to a color fill scheme. The set may be different depending on the view type. (Inherited from View.)
Public method | SupportsRevealConstraints | Checks that the view can have the Reveal Constraints mode activated. (Inherited from View.)
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode. (Inherited from View.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UngroupHeaders | Ungroups selected headers of schedule.
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

See Also

ViewSchedule Class


CanGroupHeaders Method

[image]

Revit 2024 API
ViewSchedule..::..CanGroupHeaders Method
ViewSchedule Class See Also Send Feedback
Indicates if selected headers can be grouped for this schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool CanGroupHeaders(
    int top,
    int left,
    int bottom,
    int right
)
Visual Basic
Public Function CanGroupHeaders ( _
    top As Integer, _
    left As Integer, _
    bottom As Integer, _
    right As Integer _
) As Boolean
Visual C++
public:
bool CanGroupHeaders(
    int top,
    int left,
    int bottom,
    int right
)

Parameters

top
Type: System..::..Int32
The index of the top row of the selected headers.
left
Type: System..::..Int32
The index of the left column of the selected headers.
bottom
Type: System..::..Int32
The index of the bottom row of the selected headers.
right
Type: System..::..Int32
The index of the right column of the selected headers.

Return Value

True if the selected headers can be grouped, false otherwise.

See Also

ViewSchedule Class


CanUngroupHeaders Method

[image]

Revit 2024 API
ViewSchedule..::..CanUngroupHeaders Method
ViewSchedule Class See Also Send Feedback
Indicates if selected headers can be ungrouped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool CanUngroupHeaders(
    int top,
    int left,
    int bottom,
    int right
)
Visual Basic
Public Function CanUngroupHeaders ( _
    top As Integer, _
    left As Integer, _
    bottom As Integer, _
    right As Integer _
) As Boolean
Visual C++
public:
bool CanUngroupHeaders(
    int top,
    int left,
    int bottom,
    int right
)

Parameters

top
Type: System..::..Int32
The index of the top row of the selected headers.
left
Type: System..::..Int32
The index of the left column of the selected headers.
bottom
Type: System..::..Int32
The index of the bottom row of the selected headers.
right
Type: System..::..Int32
The index of the right column of the selected headers.

Return Value

True if the selected headers can be grouped, false otherwise.

See Also

ViewSchedule Class


CreateKeynoteLegend Method

[image]

Revit 2024 API
ViewSchedule..::..CreateKeynoteLegend Method
ViewSchedule Class See Also Send Feedback
Creates a keynote legend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static ViewSchedule CreateKeynoteLegend(
    Document document
)
Visual Basic
Public Shared Function CreateKeynoteLegend ( _
    document As Document _
) As ViewSchedule
Visual C++
public:
static ViewSchedule^ CreateKeynoteLegend(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new schedule will be added.

Return Value

The newly created schedule.

Remarks

A keynote legend is a schedule of the Keynote Tags category.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

ViewSchedule Class


CreateKeySchedule Method

[image]

Revit 2024 API
ViewSchedule..::..CreateKeySchedule Method
ViewSchedule Class See Also Send Feedback
Create a key schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static ViewSchedule CreateKeySchedule(
    Document document,
    ElementId categoryId
)
Visual Basic
Public Shared Function CreateKeySchedule ( _
    document As Document, _
    categoryId As ElementId _
) As ViewSchedule
Visual C++
public:
static ViewSchedule^ CreateKeySchedule(
    Document^ document,
    ElementId^ categoryId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new schedule will be added.
categoryId
Type: Autodesk.Revit.DB..::..ElementId
The ID of the category of elements that the schedule's keys will be associated with.

Return Value

The newly created schedule.

Remarks

A key schedule displays abstract "key" elements that can be used to populate parameters of ordinary model elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- categoryId is not a valid category for a key schedule.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

ViewSchedule Class


CreateRevisionSchedule Method

[image]

Revit 2024 API
ViewSchedule..::..CreateRevisionSchedule Method
ViewSchedule Class See Also Send Feedback
Creates a revision schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static ViewSchedule CreateRevisionSchedule(
    Document document
)
Visual Basic
Public Shared Function CreateRevisionSchedule ( _
    document As Document _
) As ViewSchedule
Visual C++
public:
static ViewSchedule^ CreateRevisionSchedule(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The titleblock family document to which the new schedule will be added.

Return Value

The newly created schedule.

Remarks

Revision schedules are added to titleblock families and become visible as part of titleblocks on sheets.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a titleblock family.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

ViewSchedule Class


CreateSchedule Method (Document, ElementId)

[image]

Revit 2024 API
ViewSchedule..::..CreateSchedule Method (Document, ElementId)
ViewSchedule Class See Also Send Feedback
Creates a regular schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static ViewSchedule CreateSchedule(
    Document document,
    ElementId categoryId
)
Visual Basic
Public Shared Function CreateSchedule ( _
    document As Document, _
    categoryId As ElementId _
) As ViewSchedule
Visual C++
public:
static ViewSchedule^ CreateSchedule(
    Document^ document,
    ElementId^ categoryId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new schedule will be added.
categoryId
Type: Autodesk.Revit.DB..::..ElementId
The ID of the category whose elements will be included in the schedule, or InvalidElementId for a multi-category schedule.

Return Value

The newly created schedule.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- categoryId is not a valid category for a regular schedule. -or- The Areas category was specified but an area scheme ID was not provided.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

ViewSchedule Class
CreateSchedule Overload


CreateSchedule Method (Document, ElementId, ElementId)

[image]

Revit 2024 API
ViewSchedule..::..CreateSchedule Method (Document, ElementId, ElementId)
ViewSchedule Class Example See Also Send Feedback
Creates a regular schedule that can relate to a specific area scheme.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static ViewSchedule CreateSchedule(
    Document document,
    ElementId categoryId,
    ElementId areaSchemeId
)
Visual Basic
Public Shared Function CreateSchedule ( _
    document As Document, _
    categoryId As ElementId, _
    areaSchemeId As ElementId _
) As ViewSchedule
Visual C++
public:
static ViewSchedule^ CreateSchedule(
    Document^ document,
    ElementId^ categoryId,
    ElementId^ areaSchemeId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new schedule will be added.
categoryId
Type: Autodesk.Revit.DB..::..ElementId
The ID of the category whose elements will be included in the schedule, or InvalidElementId for a multi-category schedule.
areaSchemeId
Type: Autodesk.Revit.DB..::..ElementId
The ID of an area scheme in an area schedule, InvalidElementId otherwise.

Return Value

The newly created schedule.

Examples

CopyC#
ViewSchedule areaSchedule = null;

using (Transaction transaction = new Transaction(doc, "Creating Schedule"))
{
    transaction.Start();

    FilteredElementCollector collector = new FilteredElementCollector(doc);
    collector.OfCategory(BuiltInCategory.OST_AreaSchemes);
    //Get first ElementId of AreaScheme.
    ElementId areaSchemeId = collector.FirstElementId();
    if (areaSchemeId != null && areaSchemeId != ElementId.InvalidElementId)
    {
        // If you want to create an area schedule, you must use CreateSchedule method with three arguments.
        // The value of the second argument must be ElementId of BuiltInCategory.OST_Areas category
        // and the value of third argument must be ElementId of an AreaScheme.
        areaSchedule = Autodesk.Revit.DB.ViewSchedule.CreateSchedule(doc, new ElementId(BuiltInCategory.OST_Areas), areaSchemeId);
    }
    if (null != areaSchedule)
    {
        transaction.Commit();
    }
    else
    {
        transaction.RollBack();
    }
}
CopyVB.NET
Dim areaSchedule As ViewSchedule = Nothing

Using transaction As New Transaction(doc, "Creating Schedule")
    transaction.Start()

    Dim collector As New FilteredElementCollector(doc)
    collector.OfCategory(BuiltInCategory.OST_AreaSchemes)
    'Get first ElementId of AreaScheme.
    Dim areaSchemeId As ElementId = collector.FirstElementId()
    If areaSchemeId IsNot Nothing AndAlso areaSchemeId <> ElementId.InvalidElementId Then
        ' If you want to create an area schedule, you must use CreateSchedule method with three arguments.
        ' The value of the second argument must be ElementId of BuiltInCategory.OST_Areas category
        ' and the value of third argument must be ElementId of an AreaScheme.
        areaSchedule = Autodesk.Revit.DB.ViewSchedule.CreateSchedule(doc, New ElementId(BuiltInCategory.OST_Areas), areaSchemeId)
    End If
    If areaSchedule IsNot Nothing Then
        transaction.Commit()
    Else
        transaction.RollBack()
    End If
End Using

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- categoryId is not a valid category for a regular schedule. -or- In a non-area schedule, areaSchemeId is not InvalidElementId. -or- In an area schedule, areaSchemeId is not the ID of an area scheme.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

ViewSchedule Class
CreateSchedule Overload


CreateSheetList Method

[image]

Revit 2024 API
ViewSchedule..::..CreateSheetList Method
ViewSchedule Class See Also Send Feedback
Creates a sheet list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static ViewSchedule CreateSheetList(
    Document document
)
Visual Basic
Public Shared Function CreateSheetList ( _
    document As Document _
) As ViewSchedule
Visual C++
public:
static ViewSchedule^ CreateSheetList(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new schedule will be added.

Return Value

The newly created schedule.

Remarks

A sheet list is a schedule of sheets in the project. It is a schedule of the Sheets category.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

ViewSchedule Class


CreateViewList Method

[image]

Revit 2024 API
ViewSchedule..::..CreateViewList Method
ViewSchedule Class See Also Send Feedback
Creates a view list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static ViewSchedule CreateViewList(
    Document document
)
Visual Basic
Public Shared Function CreateViewList ( _
    document As Document _
) As ViewSchedule
Visual C++
public:
static ViewSchedule^ CreateViewList(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new schedule will be added.

Return Value

The newly created schedule.

Remarks

A view list is a schedule of views in the project. It is a schedule of the Views category.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

ViewSchedule Class


DeleteSegment Method

[image]

Revit 2024 API
ViewSchedule..::..DeleteSegment Method
ViewSchedule Class See Also Send Feedback
Deletes a schedule segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022.1

Syntax

C#
public void DeleteSegment(
    int segmentIndex
)
Visual Basic
Public Sub DeleteSegment ( _
    segmentIndex As Integer _
)
Visual C++
public:
void DeleteSegment(
    int segmentIndex
)

Parameters

segmentIndex
Type: System..::..Int32
Zero-based index of the segment.

Remarks

If the last segment is deleted, the previous one will be the last one and its height will be modified to unlimited. If one segment is deleted when there are only two segments, all the instances will be deleted and the schedule will become unsplit again.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The segment index should start from 0 and be less than the total segment count.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This ViewSchedule is not split yet.

See Also

ViewSchedule Class


Export Method

[image]

Revit 2024 API
ViewSchedule..::..Export Method
ViewSchedule Class See Also Send Feedback
Exports the schedule data to a text file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void Export(
    string folder,
    string name,
    ViewScheduleExportOptions options
)
Visual Basic
Public Sub Export ( _
    folder As String, _
    name As String, _
    options As ViewScheduleExportOptions _
)
Visual C++
public:
void Export(
    String^ folder,
    String^ name,
    ViewScheduleExportOptions^ options
)

Parameters

folder
Type: System..::..String
Path to the location where the file will be saved.
name
Type: System..::..String
Name of file.
options
Type: Autodesk.Revit.DB..::..ViewScheduleExportOptions
Options that relate to schedule export.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | NullOrEmpty -or- Contains invalid characters.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..FileAccessException | The path indicated could not be accessed.
Autodesk.Revit.Exceptions..::..InvalidPathArgumentException | The folder does not exist.

See Also

ViewSchedule Class


GetDefaultNameForKeynoteLegend Method

[image]

Revit 2024 API
ViewSchedule..::..GetDefaultNameForKeynoteLegend Method
ViewSchedule Class See Also Send Feedback
Gets the default view name that will be used when creating a keynote legend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static string GetDefaultNameForKeynoteLegend(
    Document document
)
Visual Basic
Public Shared Function GetDefaultNameForKeynoteLegend ( _
    document As Document _
) As String
Visual C++
public:
static String^ GetDefaultNameForKeynoteLegend(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new schedule will be added.

Return Value

The default view name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ViewSchedule Class


GetDefaultNameForKeySchedule Method

[image]

Revit 2024 API
ViewSchedule..::..GetDefaultNameForKeySchedule Method
ViewSchedule Class See Also Send Feedback
Gets the default view name that will be used when creating a key schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static string GetDefaultNameForKeySchedule(
    Document document,
    ElementId categoryId
)
Visual Basic
Public Shared Function GetDefaultNameForKeySchedule ( _
    document As Document, _
    categoryId As ElementId _
) As String
Visual C++
public:
static String^ GetDefaultNameForKeySchedule(
    Document^ document,
    ElementId^ categoryId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new schedule will be added.
categoryId
Type: Autodesk.Revit.DB..::..ElementId
The ID of the category of elements that the schedule's keys will be associated with.

Return Value

The default view name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- categoryId is not a valid category for a key schedule.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ViewSchedule Class


GetDefaultNameForMaterialTakeoff Method

[image]

Revit 2024 API
ViewSchedule..::..GetDefaultNameForMaterialTakeoff Method
ViewSchedule Class See Also Send Feedback
Gets the default view name that will be used when creating a material takeoff.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static string GetDefaultNameForMaterialTakeoff(
    Document document,
    ElementId categoryId
)
Visual Basic
Public Shared Function GetDefaultNameForMaterialTakeoff ( _
    document As Document, _
    categoryId As ElementId _
) As String
Visual C++
public:
static String^ GetDefaultNameForMaterialTakeoff(
    Document^ document,
    ElementId^ categoryId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new schedule will be added.
categoryId
Type: Autodesk.Revit.DB..::..ElementId
The ID of the category whose elements will be included in the schedule, or InvalidElementId for a multi-category schedule.

Return Value

The default view name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- categoryId is not a valid category for a material takeoff.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ViewSchedule Class


GetDefaultNameForNoteBlock Method

[image]

Revit 2024 API
ViewSchedule..::..GetDefaultNameForNoteBlock Method
ViewSchedule Class See Also Send Feedback
Gets the default view name that will be used when creating a note block.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static string GetDefaultNameForNoteBlock(
    Document document
)
Visual Basic
Public Shared Function GetDefaultNameForNoteBlock ( _
    document As Document _
) As String
Visual C++
public:
static String^ GetDefaultNameForNoteBlock(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new schedule will be added.

Return Value

The default view name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ViewSchedule Class


GetDefaultNameForRevisionSchedule Method

[image]

Revit 2024 API
ViewSchedule..::..GetDefaultNameForRevisionSchedule Method
ViewSchedule Class See Also Send Feedback
Gets the default view name that will be used when creating a revision schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static string GetDefaultNameForRevisionSchedule(
    Document document
)
Visual Basic
Public Shared Function GetDefaultNameForRevisionSchedule ( _
    document As Document _
) As String
Visual C++
public:
static String^ GetDefaultNameForRevisionSchedule(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The titleblock family document to which the new schedule will be added.

Return Value

The default view name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a titleblock family.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ViewSchedule Class


GetDefaultNameForSchedule Method (Document, ElementId, ElementId)

[image]

Revit 2024 API
ViewSchedule..::..GetDefaultNameForSchedule Method (Document, ElementId, ElementId)
ViewSchedule Class See Also Send Feedback
Gets the default view name that will be used when creating a schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static string GetDefaultNameForSchedule(
    Document document,
    ElementId categoryId,
    ElementId areaSchemeId
)
Visual Basic
Public Shared Function GetDefaultNameForSchedule ( _
    document As Document, _
    categoryId As ElementId, _
    areaSchemeId As ElementId _
) As String
Visual C++
public:
static String^ GetDefaultNameForSchedule(
    Document^ document,
    ElementId^ categoryId,
    ElementId^ areaSchemeId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new schedule will be added.
categoryId
Type: Autodesk.Revit.DB..::..ElementId
The ID of the category whose elements will be included in the schedule, or InvalidElementId for a multi-category schedule.
areaSchemeId
Type: Autodesk.Revit.DB..::..ElementId
The ID of an area scheme in an area schedule, InvalidElementId otherwise.

Return Value

The default view name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- categoryId is not a valid category for a regular schedule. -or- In a non-area schedule, areaSchemeId is not InvalidElementId. -or- In an area schedule, areaSchemeId is not the ID of an area scheme.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ViewSchedule Class
GetDefaultNameForSchedule Overload


GetDefaultNameForSheetList Method

[image]

Revit 2024 API
ViewSchedule..::..GetDefaultNameForSheetList Method
ViewSchedule Class See Also Send Feedback
Gets the default view name that will be used when creating a sheet list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static string GetDefaultNameForSheetList(
    Document document
)
Visual Basic
Public Shared Function GetDefaultNameForSheetList ( _
    document As Document _
) As String
Visual C++
public:
static String^ GetDefaultNameForSheetList(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new schedule will be added.

Return Value

The default view name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ViewSchedule Class


GetDefaultNameForViewList Method

[image]

Revit 2024 API
ViewSchedule..::..GetDefaultNameForViewList Method
ViewSchedule Class See Also Send Feedback
Gets the default view name that will be used when creating a view list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static string GetDefaultNameForViewList(
    Document document
)
Visual Basic
Public Shared Function GetDefaultNameForViewList ( _
    document As Document _
) As String
Visual C++
public:
static String^ GetDefaultNameForViewList(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new schedule will be added.

Return Value

The default view name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ViewSchedule Class


GetDefaultParameterNameForKeySchedule Method

[image]

Revit 2024 API
ViewSchedule..::..GetDefaultParameterNameForKeySchedule Method
ViewSchedule Class See Also Send Feedback
Gets the default parameter name that will be used when creating a key schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static string GetDefaultParameterNameForKeySchedule(
    Document document,
    ElementId categoryId
)
Visual Basic
Public Shared Function GetDefaultParameterNameForKeySchedule ( _
    document As Document, _
    categoryId As ElementId _
) As String
Visual C++
public:
static String^ GetDefaultParameterNameForKeySchedule(
    Document^ document,
    ElementId^ categoryId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new schedule will be added.
categoryId
Type: Autodesk.Revit.DB..::..ElementId
The ID of the category of elements that the schedule's keys will be associated with.

Return Value

The default parameter name.

Remarks

See ViewSchedule.KeyScheduleParameterName for details.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- categoryId is not a valid category for a key schedule.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ViewSchedule Class


GetScheduleHeightsOnSheet Method

[image]

Revit 2024 API
ViewSchedule..::..GetScheduleHeightsOnSheet Method
ViewSchedule Class See Also Send Feedback
Gets the heights of schedule title, column header and each schedule body row.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022.1

Syntax

C#
public ScheduleHeightsOnSheet GetScheduleHeightsOnSheet()
Visual Basic
Public Function GetScheduleHeightsOnSheet As ScheduleHeightsOnSheet
Visual C++
public:
ScheduleHeightsOnSheet^ GetScheduleHeightsOnSheet()

Return Value

The ScheduleHeightsOnSheet which contains heights information of a schedule on sheet.

Remarks

The height is Revit's internal units value.

See Also

ViewSchedule Class


GetScheduleInstances Method

[image]

Revit 2024 API
ViewSchedule..::..GetScheduleInstances Method
ViewSchedule Class See Also Send Feedback
Gets the instances ids of schedule or schedule segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022.1

Syntax

C#
public IList<ElementId> GetScheduleInstances(
    int segmentIndex
)
Visual Basic
Public Function GetScheduleInstances ( _
    segmentIndex As Integer _
) As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetScheduleInstances(
    int segmentIndex
)

Parameters

segmentIndex
Type: System..::..Int32
Index of the segment.

Return Value

The array of schedule sheet instance element ids of schedule or schedule segment.

Remarks

The segment index value could be -1, it means to get schedule instances for the entire schedule.

When a (primary) schedule is set to filter by sheet and placed on a sheet, it will create a new schedule with elements visible in the Viewport(s) on that sheet. The instance created belongs to the newly created schedule. Calls to GetScheduleInstances() will return instances of the newly created schedule but no instances of the primary schedule.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The segment index should start from -1 and be less than the total segment count.

See Also

ViewSchedule Class


GetSegmentCount Method

[image]

Revit 2024 API
ViewSchedule..::..GetSegmentCount Method
ViewSchedule Class See Also Send Feedback
Gets the total count of schedule segments.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022.1

Syntax

C#
public int GetSegmentCount()
Visual Basic
Public Function GetSegmentCount As Integer
Visual C++
public:
int GetSegmentCount()

Return Value

The total count of schedule segments. 1 means the schedule is not split yet.

Remarks

There will be at least one segment for a schedule.

See Also

ViewSchedule Class


GetSegmentHeight Method

[image]

Revit 2024 API
ViewSchedule..::..GetSegmentHeight Method
ViewSchedule Class See Also Send Feedback
Gets the segment height.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022.1

Syntax

C#
public double GetSegmentHeight(
    int segmentIndex
)
Visual Basic
Public Function GetSegmentHeight ( _
    segmentIndex As Integer _
) As Double
Visual C++
public:
double GetSegmentHeight(
    int segmentIndex
)

Parameters

segmentIndex
Type: System..::..Int32
Zero-based index of the segment.

Return Value

The segment height value.

Remarks

The height is Revit's internal units value of schedule header and segment body. The real height of segment on sheet may be less than the segment height get here. It is the border height of segment instance on sheet. The last segment height get here is the max value of double as the last segment height is not set to a fix value. It will be determined by whole schedule height and other segments' heights. And the border for it is max value of double.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The segment index should start from 0 and be less than the total segment count.

See Also

ViewSchedule Class


GetValidCategoriesForKeySchedule Method

[image]

Revit 2024 API
ViewSchedule..::..GetValidCategoriesForKeySchedule Method
ViewSchedule Class See Also Send Feedback
Gets a list of categories that can be used for a key schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static ICollection<ElementId> GetValidCategoriesForKeySchedule()
Visual Basic
Public Shared Function GetValidCategoriesForKeySchedule As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetValidCategoriesForKeySchedule()

Return Value

The IDs of all valid categories.

See Also

ViewSchedule Class


GetValidCategoriesForMaterialTakeoff Method

[image]

Revit 2024 API
ViewSchedule..::..GetValidCategoriesForMaterialTakeoff Method
ViewSchedule Class See Also Send Feedback
Gets a list of categories that can be used for a material takeoff.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static ICollection<ElementId> GetValidCategoriesForMaterialTakeoff()
Visual Basic
Public Shared Function GetValidCategoriesForMaterialTakeoff As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetValidCategoriesForMaterialTakeoff()

Return Value

The IDs of all valid categories.

See Also

ViewSchedule Class


GetValidCategoriesForSchedule Method

[image]

Revit 2024 API
ViewSchedule..::..GetValidCategoriesForSchedule Method
ViewSchedule Class See Also Send Feedback
Gets a list of categories that can be used for a regular schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static ICollection<ElementId> GetValidCategoriesForSchedule()
Visual Basic
Public Shared Function GetValidCategoriesForSchedule As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetValidCategoriesForSchedule()

Return Value

The IDs of all valid categories.

See Also

ViewSchedule Class


GetValidFamiliesForNoteBlock Method

[image]

Revit 2024 API
ViewSchedule..::..GetValidFamiliesForNoteBlock Method
ViewSchedule Class See Also Send Feedback
Gets a list of families that can be used for a note block.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static ICollection<ElementId> GetValidFamiliesForNoteBlock(
    Document document
)
Visual Basic
Public Shared Function GetValidFamiliesForNoteBlock ( _
    document As Document _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetValidFamiliesForNoteBlock(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.

Return Value

The IDs of all valid families.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ViewSchedule Class


GroupHeaders Method

[image]

Revit 2024 API
ViewSchedule..::..GroupHeaders Method
ViewSchedule Class Example See Also Send Feedback
Groups schedule header cells.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void GroupHeaders(
    int top,
    int left,
    int bottom,
    int right,
    string caption
)
Visual Basic
Public Sub GroupHeaders ( _
    top As Integer, _
    left As Integer, _
    bottom As Integer, _
    right As Integer, _
    caption As String _
)
Visual C++
public:
void GroupHeaders(
    int top,
    int left,
    int bottom,
    int right,
    String^ caption
)

Parameters

top
Type: System..::..Int32
The index of the top row of the selected headers.
left
Type: System..::..Int32
The index of the left column of the selected headers.
bottom
Type: System..::..Int32
The index of the bottom row of the selected headers.
right
Type: System..::..Int32
The index of the right column of the selected headers.
caption
Type: System..::..String
The header caption.

Examples

CopyC#
public static void CreateSingleCategoryScheduleWithGroupedColumnHeaders(Document doc)
{
    using (Transaction t = new Transaction(doc, "Create single-category with grouped column headers"))
    {
        // Build the schedule
        t.Start();
        ViewSchedule vs = ViewSchedule.CreateSchedule(doc, new ElementId(BuiltInCategory.OST_Windows));

        AddRegularFieldToSchedule(vs, new ElementId(BuiltInParameter.WINDOW_HEIGHT));
        AddRegularFieldToSchedule(vs, new ElementId(BuiltInParameter.WINDOW_WIDTH));
        AddRegularFieldToSchedule(vs, new ElementId(BuiltInParameter.ALL_MODEL_MARK));
        AddRegularFieldToSchedule(vs, new ElementId(BuiltInParameter.ALL_MODEL_COST));

        doc.Regenerate();

        // Group the headers in the body section using ViewSchedule methods
        vs.GroupHeaders(0, 0, 0, 1, "Size");
        vs.GroupHeaders(0, 2, 0, 3, "Other");
        vs.GroupHeaders(0, 0, 0, 3, "All");

        t.Commit();
    }
}

/// <summary>
/// Adds a single parameter field to the schedule
/// </summary>
public static void AddRegularFieldToSchedule(ViewSchedule schedule, ElementId paramId)
{
    ScheduleDefinition definition = schedule.Definition;

    // Find a matching SchedulableField
    SchedulableField schedulableField =
        definition.GetSchedulableFields().FirstOrDefault<SchedulableField>(sf => sf.ParameterId == paramId);

    if (schedulableField != null)
    {
        // Add the found field
        definition.AddField(schedulableField);
    }
}
CopyVB.NET
Public Shared Sub CreateSingleCategoryScheduleWithGroupedColumnHeaders(doc As Document)
    Using t As New Transaction(doc, "Create single-category with grouped column headers")
        ' Build the schedule
        t.Start()
        Dim vs As ViewSchedule = ViewSchedule.CreateSchedule(doc, New ElementId(BuiltInCategory.OST_Windows))

        AddRegularFieldToSchedule(vs, New ElementId(BuiltInParameter.WINDOW_HEIGHT))
        AddRegularFieldToSchedule(vs, New ElementId(BuiltInParameter.WINDOW_WIDTH))
        AddRegularFieldToSchedule(vs, New ElementId(BuiltInParameter.ALL_MODEL_MARK))
        AddRegularFieldToSchedule(vs, New ElementId(BuiltInParameter.ALL_MODEL_COST))

        doc.Regenerate()

        ' Group the headers in the body section using ViewSchedule methods
        vs.GroupHeaders(0, 0, 0, 1, "Size")
        vs.GroupHeaders(0, 2, 0, 3, "Other")
        vs.GroupHeaders(0, 0, 0, 3, "All")

        t.Commit()
    End Using
End Sub

' <summary>
' Adds a single parameter field to the schedule
' </summary>
Public Shared Sub AddRegularFieldToSchedule(schedule As ViewSchedule, paramId As ElementId)
    Dim definition As ScheduleDefinition = schedule.Definition

    ' Find a matching SchedulableField
    Dim schedulableField As SchedulableField = definition.GetSchedulableFields().FirstOrDefault(Function(sf) sf.ParameterId = paramId)

    If schedulableField IsNot Nothing Then
        ' Add the found field
        definition.AddField(schedulableField)
    End If
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Headers could not be grouped.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ViewSchedule Class


HasImageField Method

[image]

Revit 2024 API
ViewSchedule..::..HasImageField Method
ViewSchedule Class See Also Send Feedback
Checks whether the schedule definition includes any image-related fields and if any elements in the schedule actually have images in those fields.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool HasImageField()
Visual Basic
Public Function HasImageField As Boolean
Visual C++
public:
bool HasImageField()

Return Value

True if the schedule has at least one image field showing at least one image, false otherwise.

Remarks

This method may return an incorrect value if the data of the schedule view is out of date. Check [!:IsDataOutOfData()], and call RefreshData()()()() to ensure that the return value is correct.

See Also

ViewSchedule Class


IsDataOutOfDate Method

[image]

Revit 2024 API
ViewSchedule..::..IsDataOutOfDate Method
ViewSchedule Class See Also Send Feedback
Indicates whether the schedule data is out of date.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsDataOutOfDate()
Visual Basic
Public Function IsDataOutOfDate As Boolean
Visual C++
public:
bool IsDataOutOfDate()

Return Value

True if the schedule data is out of date, false otherwise.

Remarks

To improve performance, the ViewSchedule may contain TableSections that are only updated on demand. For example, the body section of a schedule is not updated when the ViewSchedule is closed. In this case, you need to call RefreshData to avoid getting the stale data.

See Also

ViewSchedule Class


IsSplit Method

[image]

Revit 2024 API
ViewSchedule..::..IsSplit Method
ViewSchedule Class See Also Send Feedback
Checks if the schedule is split.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022.1

Syntax

C#
public bool IsSplit()
Visual Basic
Public Function IsSplit As Boolean
Visual C++
public:
bool IsSplit()

Return Value

True if the schedule is split. Otherwise false.

See Also

ViewSchedule Class


IsValidCategoryForKeySchedule Method

[image]

Revit 2024 API
ViewSchedule..::..IsValidCategoryForKeySchedule Method
ViewSchedule Class See Also Send Feedback
Checks whether a category can be used for a key schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static bool IsValidCategoryForKeySchedule(
    ElementId categoryId
)
Visual Basic
Public Shared Function IsValidCategoryForKeySchedule ( _
    categoryId As ElementId _
) As Boolean
Visual C++
public:
static bool IsValidCategoryForKeySchedule(
    ElementId^ categoryId
)

Parameters

categoryId
Type: Autodesk.Revit.DB..::..ElementId
The category ID to check.

Return Value

True if the category can be used for a key schedule, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ViewSchedule Class


IsValidCategoryForSchedule Method

[image]

Revit 2024 API
ViewSchedule..::..IsValidCategoryForSchedule Method
ViewSchedule Class See Also Send Feedback
Checks whether a category can be used for a regular schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static bool IsValidCategoryForSchedule(
    ElementId categoryId
)
Visual Basic
Public Shared Function IsValidCategoryForSchedule ( _
    categoryId As ElementId _
) As Boolean
Visual C++
public:
static bool IsValidCategoryForSchedule(
    ElementId^ categoryId
)

Parameters

categoryId
Type: Autodesk.Revit.DB..::..ElementId
The category ID to check.

Return Value

True if the category can be used for a regular schedule, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ViewSchedule Class


IsValidFamilyForNoteBlock Method

[image]

Revit 2024 API
ViewSchedule..::..IsValidFamilyForNoteBlock Method
ViewSchedule Class See Also Send Feedback
Checks whether a family can be used for a note block.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static bool IsValidFamilyForNoteBlock(
    Document document,
    ElementId familyId
)
Visual Basic
Public Shared Function IsValidFamilyForNoteBlock ( _
    document As Document, _
    familyId As ElementId _
) As Boolean
Visual C++
public:
static bool IsValidFamilyForNoteBlock(
    Document^ document,
    ElementId^ familyId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
familyId
Type: Autodesk.Revit.DB..::..ElementId
The family ID to check.

Return Value

True if the family can be used for a note block, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ViewSchedule Class


IsValidTextTypeId Method

[image]

Revit 2024 API
ViewSchedule..::..IsValidTextTypeId Method
ViewSchedule Class See Also Send Feedback
Identifies if the input id represents a valid text type id for use in the schedule properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool IsValidTextTypeId(
    ElementId textTypeId
)
Visual Basic
Public Function IsValidTextTypeId ( _
    textTypeId As ElementId _
) As Boolean
Visual C++
public:
bool IsValidTextTypeId(
    ElementId^ textTypeId
)

Parameters

textTypeId
Type: Autodesk.Revit.DB..::..ElementId
The element id of the text type.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ViewSchedule Class


MergeSegments Method

[image]

Revit 2024 API
ViewSchedule..::..MergeSegments Method
ViewSchedule Class See Also Send Feedback
Merges two adjacent segments into one.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022.1

Syntax

C#
public void MergeSegments(
    int movedSegmentIndex,
    int targetSegmentIndex
)
Visual Basic
Public Sub MergeSegments ( _
    movedSegmentIndex As Integer, _
    targetSegmentIndex As Integer _
)
Visual C++
public:
void MergeSegments(
    int movedSegmentIndex,
    int targetSegmentIndex
)

Parameters

movedSegmentIndex
Type: System..::..Int32
The index of the moved segment.
targetSegmentIndex
Type: System..::..Int32
The index of the target segment.

Remarks

Only adjacent segments can be merged. The moved segment will be deleted with all its instances on sheet and all the data will be merged into the target segment with height expanded.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Only two adjacent segments can be merged. -or- The segment index should start from 0 and be less than the total segment count.

See Also

ViewSchedule Class


Print Method

[image] [image]

Revit 2024 API
ViewSchedule..::..Print Method
ViewSchedule Class See Also Send Feedback
Print this view.

Overload List

 | Name | Description
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)

See Also

ViewSchedule Class
ViewSchedule Members


SetSegmentHeight Method

[image]

Revit 2024 API
ViewSchedule..::..SetSegmentHeight Method
ViewSchedule Class See Also Send Feedback
Sets the segment height.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022.1

Syntax

C#
public void SetSegmentHeight(
    int segmentIndex,
    double height
)
Visual Basic
Public Sub SetSegmentHeight ( _
    segmentIndex As Integer, _
    height As Double _
)
Visual C++
public:
void SetSegmentHeight(
    int segmentIndex,
    double height
)

Parameters

segmentIndex
Type: System..::..Int32
Index of the segment.
height
Type: System..::..Double
New height for the segment.

Remarks

The height is Revit's internal units value of schedule header and segment body. The last segment can not set height. Its height will be determined by whole schedule height and other segments' heights. The height will not be the exact segment height on sheet. It will be the border height of the instance. The real height will be determined by the segment content. If the row cannot be shown within the instance boder, it will flow to the next segment.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | segmentIndex must be between 0 and the last second of all segments.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given value for height must be greater than 0 and no more than 30000 feet.

See Also

ViewSchedule Class


SetStripedRowsColor Method

[image]

Revit 2024 API
ViewSchedule..::..SetStripedRowsColor Method
ViewSchedule Class See Also Send Feedback
Sets the color applied to part of the pattern for a schedule with striped rows.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public void SetStripedRowsColor(
    StripedRowPattern index,
    Color color
)
Visual Basic
Public Sub SetStripedRowsColor ( _
    index As StripedRowPattern, _
    color As Color _
)
Visual C++
public:
void SetStripedRowsColor(
    StripedRowPattern index,
    Color^ color
)

Parameters

index
Type: Autodesk.Revit.DB..::..StripedRowPattern
The part of the striped row pattern.
color
Type: Autodesk.Revit.DB..::..Color
The color which will be used in striped row pattern.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

ViewSchedule Class


Split Method

[image] [image]

Revit 2024 API
ViewSchedule..::..Split Method
ViewSchedule Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Split(IList<(Of <<'(Double>)>>)) | Splits the schedule into several segments by given height of each segment.
Public method | Split(Int32) | Splits the schedule into several segments by given segment number.

See Also

ViewSchedule Class
ViewSchedule Members


Split Method (IList(Double))

[image]

Revit 2024 API
ViewSchedule..::..Split Method (IList<(Of <(<'Double>)>)>)
ViewSchedule Class See Also Send Feedback
Splits the schedule into several segments by given height of each segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022.1

Syntax

C#
public void Split(
    IList<double> segmentHeights
)
Visual Basic
Public Sub Split ( _
    segmentHeights As IList(Of Double) _
)
Visual C++
public:
void Split(
    IList<double>^ segmentHeights
)

Parameters

segmentHeights
Type: System.Collections.Generic..::..IList<(Of <(<'Double>)>)>
An array contains the height limit of each segment except the last segment. The height is the value for segment body. The height is Revit's internal units value.

Remarks

  • A schedule can be split only when it is not split yet.
  • A titleblock revision schedule cannot be split.
  • Once a sheet specific schedule, i.e., the schedule is filtered by sheet, is split, the segments will be placed on its sheet view immediately.
  • The height values are used to set the height limits of the schedule instances of each segment except the last segment shown on the sheet view.
  • The height limit of the last segment cannot be set, because the height of the schedule instances of the last segment will be determined by the schedule instances of previous segments and the height of the whole schedule.
  • All height values must be greater than 0.
  • Also check [!:setSegmentHeight].

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The height of a schedule segment must be greater than 0 and no more than 30000 feet. The total segment count must be greater than 0 and less than 10000.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | Revision schedules cannot be split. -or- A schedule filtered by sheet can't be split. -or- This ViewSchedule is split.

See Also

ViewSchedule Class
Split Overload


Split Method (Int32)

[image]

Revit 2024 API
ViewSchedule..::..Split Method (Int32)
ViewSchedule Class See Also Send Feedback
Splits the schedule into several segments by given segment number.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022.1

Syntax

C#
public void Split(
    int segmentNumber
)
Visual Basic
Public Sub Split ( _
    segmentNumber As Integer _
)
Visual C++
public:
void Split(
    int segmentNumber
)

Parameters

segmentNumber
Type: System..::..Int32
The segment number.

Remarks

  • The segment number must be greater than 0.
  • A schedule can be split only when it is not split yet.
  • A titleblock revision schedule cannot be split.
  • Once a sheet specific schedule, i.e., the schedule is filtered by sheet, is split, the segments will be placed on its sheet view immediately.
  • After split, all segments will have even height limits based on the schedule height and segment number except the last segment shown on the sheet view.
  • The height limit of the last segment cannot be set, because the height of the schedule instances of the last segment will be determined by the schedule instances of previous segments and the height of the whole schedule.
  • Check SetSegmentHeight(Int32, Double) to see more about segment height.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The segment number must be greater than 1.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Revision schedules cannot be split. -or- A schedule filtered by sheet can't be split. -or- This ViewSchedule is split.

See Also

ViewSchedule Class
Split Overload


SplitSegment Method

[image]

Revit 2024 API
ViewSchedule..::..SplitSegment Method
ViewSchedule Class See Also Send Feedback
Splits the schedule segment by the given heights of new segments.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022.1

Syntax

C#
public void SplitSegment(
    int segmentIndex,
    IList<double> segmentHeights
)
Visual Basic
Public Sub SplitSegment ( _
    segmentIndex As Integer, _
    segmentHeights As IList(Of Double) _
)
Visual C++
public:
void SplitSegment(
    int segmentIndex,
    IList<double>^ segmentHeights
)

Parameters

segmentIndex
Type: System..::..Int32
The index of segment, starting with 0.
segmentHeights
Type: System.Collections.Generic..::..IList<(Of <(<'Double>)>)>
An array contains the height for each new segment except the last segment. The height of the last segment will be determined by the height of previous new segments and the height of the split segment.

Remarks

The height values are used to set the height of schedule instance for each segment shown on sheet view. Each input height must be greater than 0 and the total height must be less than the height of the split segment.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The height of a schedule segment must be greater than 0. The total height must be less than the split segment height. The total segment count must be greater than 0 and less than 10000. -or- The segment index should start from 0 and be less than the total segment count.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This ViewSchedule is not split yet.

See Also

ViewSchedule Class


UngroupHeaders Method

[image]

Revit 2024 API
ViewSchedule..::..UngroupHeaders Method
ViewSchedule Class See Also Send Feedback
Ungroups selected headers of schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public void UngroupHeaders(
    int top,
    int left,
    int bottom,
    int right
)
Visual Basic
Public Sub UngroupHeaders ( _
    top As Integer, _
    left As Integer, _
    bottom As Integer, _
    right As Integer _
)
Visual C++
public:
void UngroupHeaders(
    int top,
    int left,
    int bottom,
    int right
)

Parameters

top
Type: System..::..Int32
The index of the top row of the selected headers.
left
Type: System..::..Int32
The index of the left column of the selected headers.
bottom
Type: System..::..Int32
The index of the bottom row of the selected headers.
right
Type: System..::..Int32
The index of the right column of the selected headers.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Headers could not be ungrouped.

See Also

ViewSchedule Class


ViewSchedule Properties

[image] [image]

Revit 2024 API
ViewSchedule Properties
ViewSchedule Class See Also Send Feedback

The ViewSchedule type exposes the following members.

Properties

 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View.)
Public property | AreAnalyticalModelCategoriesHidden | Indicates if analytical model categories are currently hidden in the view. (Inherited from View.)
Public property | AreAnnotationCategoriesHidden | Indicates if annotation categories are currently hidden in the view. (Inherited from View.)
Public property | AreCoordinationModelHandlesHidden | Indicates if Coordination Model handles are currently hidden in the view. (Inherited from View.)
Public property | AreImportCategoriesHidden | Indicates if import categories are currently hidden in the view. (Inherited from View.)
Public property | AreModelCategoriesHidden | Indicates if model categories are currently hidden in the view. (Inherited from View.)
Public property | ArePointCloudsHidden | Indicates if point clouds are currently hidden in the view. (Inherited from View.)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view. (Inherited from View.)
Public property | BodyTextTypeId | Defines the default text style used for the data section of the schedule.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CropBox | The Crop Box applied to the view, or an outline encompassing the crop region applied to the view. (Inherited from View.)
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View.)
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
Public property | Definition | The primary ScheduleDefinition.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DetailLevel | The detail level of this view. (Inherited from View.)
Public property | Discipline | The Discipline of the view. (Inherited from View.)
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style. (Inherited from View.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EmbeddedDefinition | The embedded ScheduleDefinition.
Public property | GenLevel | The level for the view. (Inherited from View.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | HasStripedRows | Indicates whether this schedule has striped rows.
Public property | HeaderTextTypeId | Defines the default text style used in the column headers in the body section of the schedule.
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | ImageRowHeight | Obsolete. Defines the image row height in the schedule.
Public property | IsAssemblyView | Indicates if the view is assembly view. (Inherited from View.)
Public property | IsCallout | Indicates if the view is a callout view. (Inherited from View.)
 | IsHeaderFrozen | A static property defining if the schedule header frozen setting is turned on or off in current Revit Application Session.
Public property | IsInternalKeynoteSchedule | Identifies if this ViewSchedule is an internal schedule used when keynotes are filtered based on the elements that are shown on a sheet.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTemplate | Test whether the view is a view template. (Inherited from View.)
Public property | IsTitleblockRevisionSchedule | Identifies if this ViewSchedule is an internal schedule used to display revision schedules as part of a titleblock.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | KeyScheduleParameterName | In a key schedule, the name of the parameter for choosing one of the keys.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MaximumColumnWidth | Gets the maximum column width (Inherited from TableView.)
Public property | MaximumGridWidth | Gets the allowed maximum grid width (Inherited from TableView.)
Public property | MaximumRowHeight | Gets the maximum row height (Inherited from TableView.)
Public property | MinimumColumnWidth | Gets the minimum column width (Inherited from TableView.)
Public property | MinimumRowHeight | Gets the minimum row height (Inherited from TableView.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Origin | Returns the origin of the screen. (Inherited from View.)
Public property | Outline | The bounds of the view in paper space (in feet). (Inherited from View.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PartsVisibility | The visibility setting for parts in this view. (Inherited from View.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RevealConstraintsMode | Indicates whether the Reveal Constraints mode is activated in the view. (Inherited from View.)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Public property | RowHeight | Defines the schedule body rows height.
Public property | RowHeightOverride | Defines the override that is applied to the row height.
Public property | Scale | The scale of the view. (Inherited from View.)
Public property | ShadowIntensity | The intesity of cast shadows - 0 = no shadows, 100 = black. (Inherited from View.)
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View.)
Public property | SunlightIntensity | The intensity of the simulated (directional) sunlight. 0 = no directional light; maximum value is 100. (Inherited from View.)
Public property | TargetId | the element id of the element that is being viewed (Inherited from TableView.)
Public property | TemporaryViewModes | Data of temporary view modes associated with this view. (Inherited from View.)
Public property | Title | The view title. This consists of the view name plus other modifiers, such as the view type, sheet number, area scheme, and/or assembly type, depending on the specifics of the view. (Inherited from View.)
Public property | TitleTextTypeId | Defines the default text style used in the header section of the schedule.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View.)
Public property | UseStripedRowsOnSheets | Indicates whether a property setting of true will also change the display of this schedule to show striped rows on a sheet. If true, setting that property to true will also change the display. If false, striped rows will not display for this schedule on a sheet no matter what value is set for HasStripedRows.
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | ViewTemplateId | The id of the template view that controls this view's parameters. (Inherited from View.)
Public property | ViewType | The type of the view. (Inherited from View.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ViewSchedule Class


BodyTextTypeId Property

[image]

Revit 2024 API
ViewSchedule..::..BodyTextTypeId Property
ViewSchedule Class See Also Send Feedback
Defines the default text style used for the data section of the schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ElementId BodyTextTypeId { get; set; }
Visual Basic
Public Property BodyTextTypeId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ BodyTextTypeId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Remarks

Columns may override the default style.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The text type id doesn't represent a valid text type element.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ViewSchedule Class


HasStripedRows Property

[image]

Revit 2024 API
ViewSchedule..::..HasStripedRows Property
ViewSchedule Class See Also Send Feedback
Indicates whether this schedule has striped rows.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020.1

Syntax

C#
public bool HasStripedRows { get; set; }
Visual Basic
Public Property HasStripedRows As Boolean
    Get
    Set
Visual C++
public:
property bool HasStripedRows {
    bool get ();
    void set (bool value);
}

Remarks

Striped rows can be overridden by shading or conditional formatting.

See Also

ViewSchedule Class


HeaderTextTypeId Property

[image]

Revit 2024 API
ViewSchedule..::..HeaderTextTypeId Property
ViewSchedule Class See Also Send Feedback
Defines the default text style used in the column headers in the body section of the schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ElementId HeaderTextTypeId { get; set; }
Visual Basic
Public Property HeaderTextTypeId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ HeaderTextTypeId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The text type id doesn't represent a valid text type element.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ViewSchedule Class


IsInternalKeynoteSchedule Property

[image]

Revit 2024 API
ViewSchedule..::..IsInternalKeynoteSchedule Property
ViewSchedule Class See Also Send Feedback
Identifies if this ViewSchedule is an internal schedule used when keynotes are filtered based on the elements that are shown on a sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool IsInternalKeynoteSchedule { get; }
Visual Basic
Public ReadOnly Property IsInternalKeynoteSchedule As Boolean
    Get
Visual C++
public:
property bool IsInternalKeynoteSchedule {
    bool get ();
}

Remarks

These schedules cannot be modified by the user or placed on sheets.

See Also

ViewSchedule Class


IsTitleblockRevisionSchedule Property

[image]

Revit 2024 API
ViewSchedule..::..IsTitleblockRevisionSchedule Property
ViewSchedule Class See Also Send Feedback
Identifies if this ViewSchedule is an internal schedule used to display revision schedules as part of a titleblock.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool IsTitleblockRevisionSchedule { get; }
Visual Basic
Public ReadOnly Property IsTitleblockRevisionSchedule As Boolean
    Get
Visual C++
public:
property bool IsTitleblockRevisionSchedule {
    bool get ();
}

Remarks

These schedules cannot be modified by the user or placed on sheets.

See Also

ViewSchedule Class


KeyScheduleParameterName Property

[image]

Revit 2024 API
ViewSchedule..::..KeyScheduleParameterName Property
ViewSchedule Class See Also Send Feedback
In a key schedule, the name of the parameter for choosing one of the keys.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public string KeyScheduleParameterName { get; set; }
Visual Basic
Public Property KeyScheduleParameterName As String
    Get
    Set
Visual C++
public:
property String^ KeyScheduleParameterName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the key schedule parameter.

Remarks

When a key schedule is created, elements of the schedule's category receive a new parameter for choosing one of the keys defined in the key schedule. This is the name of that parameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | This ViewSchedule is not key schedule.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | When setting this property: The document containing this ViewSchedule is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- When setting this property: The document containing this ViewSchedule is being loaded, or is in the midst of another sensitive process. -or- When setting this property: This ViewSchedule is an internal element, such as a component of a loaded family or a group type. -or- When setting this property: The document containing this ViewSchedule is in Group Edit Mode, Sketch Edit Mode, or Paste Mode, and the element is not a member of the group, sketch, or clipboard. -or- When setting this property: This ViewSchedule is a member of a group or sketch, and the document is not currently editing the group or sketch.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | When setting this property: The document containing this ViewSchedule has no open transaction.

See Also

ViewSchedule Class


Parameter Property

[image] [image]

Revit 2024 API
ViewSchedule..::..Parameter Property
ViewSchedule Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ViewSchedule Class
ViewSchedule Members


RowHeight Property

[image]

Revit 2024 API
ViewSchedule..::..RowHeight Property
ViewSchedule Class See Also Send Feedback
Defines the schedule body rows height.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public double RowHeight { get; set; }
Visual Basic
Public Property RowHeight As Double
    Get
    Set
Visual C++
public:
property double RowHeight {
    double get ();
    void set (double value);
}

Field Value

The row height for any body rows in the schedule.

Remarks

Setting this property will force all or image only (depending on how RowHeightOverride is defined) schedule body rows to be resized to the indicated height value (when viewed as a ScheduleSheetInstance on a ViewSheet). If the value that is set is smaller than the height of the text (single or multi line), then that value is not taken into account. To access or set this property the RowHeightOverride property should not be None

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for rowHeight must be between 0 and 30000 feet.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The RowHeightOverride property is set to RowHeightOverrideOptions.None.

See Also

ViewSchedule Class


RowHeightOverride Property

[image]

Revit 2024 API
ViewSchedule..::..RowHeightOverride Property
ViewSchedule Class See Also Send Feedback
Defines the override that is applied to the row height.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public RowHeightOverrideOptions RowHeightOverride { get; set; }
Visual Basic
Public Property RowHeightOverride As RowHeightOverrideOptions
    Get
    Set
Visual C++
public:
property RowHeightOverrideOptions RowHeightOverride {
    RowHeightOverrideOptions get ();
    void set (RowHeightOverrideOptions value);
}

Field Value

  • None to disable row height override.
  • All enables row height override for all the body rows in the schedule.
  • ImageRows enables row height override for all the schedule body rows that contains images or custom graphics.

Remarks

Setting this property to anything but None will allow setting the RowHeight property. This is taken into account when the schedule is viewed as a ScheduleSheetInstance on a ViewSheet.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

ViewSchedule Class


TitleTextTypeId Property

[image]

Revit 2024 API
ViewSchedule..::..TitleTextTypeId Property
ViewSchedule Class See Also Send Feedback
Defines the default text style used in the header section of the schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public ElementId TitleTextTypeId { get; set; }
Visual Basic
Public Property TitleTextTypeId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ TitleTextTypeId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Remarks

Cells may override the default style.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The text type id doesn't represent a valid text type element.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ViewSchedule Class


UseStripedRowsOnSheets Property

[image]

Revit 2024 API
ViewSchedule..::..UseStripedRowsOnSheets Property
ViewSchedule Class See Also Send Feedback
Indicates whether a property setting of true will also change the display of this schedule to show striped rows on a sheet. If true, setting that property to true will also change the display. If false, striped rows will not display for this schedule on a sheet no matter what value is set for HasStripedRows.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public bool UseStripedRowsOnSheets { get; set; }
Visual Basic
Public Property UseStripedRowsOnSheets As Boolean
    Get
    Set
Visual C++
public:
property bool UseStripedRowsOnSheets {
    bool get ();
    void set (bool value);
}

Remarks

Striped rows on sheets can be overidden by shading or conditional formatting.

See Also

ViewSchedule Class


ViewScheduleExportOptions Members

[image] [image]

Revit 2024 API
ViewScheduleExportOptions Members
ViewScheduleExportOptions Class Constructors Methods Properties See Also Send Feedback

The ViewScheduleExportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | ViewScheduleExportOptions()()()() | Constructs a new instance of the ViewScheduleExportOptions class
Public method | ViewScheduleExportOptions(ViewScheduleExportOptions) | Constructs a new copy of the input ViewScheduleExportOptions object.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ViewScheduleExportOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ColumnHeaders | How to export column headers. Default is MultipleRows.
Public property | FieldDelimiter | How to delimit fields. Default is Tab.
Public property | HeadersFootersBlanks | Whether to export group headers, footers, and blank lines. Default is true.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | TextQualifier | How to qualify text fields. Default is DoubleQuote.
Public property | Title | Whether or not to export the schedule title. Default is true.

See Also

ViewScheduleExportOptions Class


ViewScheduleExportOptions Constructor

[image] [image]

Revit 2024 API
ViewScheduleExportOptions Constructor
ViewScheduleExportOptions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ViewScheduleExportOptions()()()() | Constructs a new instance of the ViewScheduleExportOptions class
Public method | ViewScheduleExportOptions(ViewScheduleExportOptions) | Constructs a new copy of the input ViewScheduleExportOptions object.

See Also

ViewScheduleExportOptions Class
ViewScheduleExportOptions Members


ViewScheduleExportOptions Constructor

[image]

Revit 2024 API
ViewScheduleExportOptions Constructor
ViewScheduleExportOptions Class See Also Send Feedback
Constructs a new instance of the ViewScheduleExportOptions class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ViewScheduleExportOptions()
Visual Basic
Public Sub New
Visual C++
public:
ViewScheduleExportOptions()

See Also

ViewScheduleExportOptions Class
ViewScheduleExportOptions Overload


ViewScheduleExportOptions Constructor (ViewScheduleExportOptions)

[image]

Revit 2024 API
ViewScheduleExportOptions Constructor (ViewScheduleExportOptions)
ViewScheduleExportOptions Class See Also Send Feedback
Constructs a new copy of the input ViewScheduleExportOptions object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ViewScheduleExportOptions(
    ViewScheduleExportOptions other
)
Visual Basic
Public Sub New ( _
    other As ViewScheduleExportOptions _
)
Visual C++
public:
ViewScheduleExportOptions(
    ViewScheduleExportOptions^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..ViewScheduleExportOptions

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ViewScheduleExportOptions Class
ViewScheduleExportOptions Overload


ViewScheduleExportOptions Methods

[image] [image]

Revit 2024 API
ViewScheduleExportOptions Methods
ViewScheduleExportOptions Class See Also Send Feedback

The ViewScheduleExportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ViewScheduleExportOptions Class


Dispose Method

[image]

Revit 2024 API
ViewScheduleExportOptions..::..Dispose Method
ViewScheduleExportOptions Class See Also Send Feedback
Releases all resources used by the ViewScheduleExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ViewScheduleExportOptions Class


ViewScheduleExportOptions Properties

[image] [image]

Revit 2024 API
ViewScheduleExportOptions Properties
ViewScheduleExportOptions Class See Also Send Feedback

The ViewScheduleExportOptions type exposes the following members.

Properties

 | Name | Description
Public property | ColumnHeaders | How to export column headers. Default is MultipleRows.
Public property | FieldDelimiter | How to delimit fields. Default is Tab.
Public property | HeadersFootersBlanks | Whether to export group headers, footers, and blank lines. Default is true.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | TextQualifier | How to qualify text fields. Default is DoubleQuote.
Public property | Title | Whether or not to export the schedule title. Default is true.

See Also

ViewScheduleExportOptions Class


ColumnHeaders Property

[image]

Revit 2024 API
ViewScheduleExportOptions..::..ColumnHeaders Property
ViewScheduleExportOptions Class See Also Send Feedback
How to export column headers. Default is MultipleRows.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ExportColumnHeaders ColumnHeaders { get; set; }
Visual Basic
Public Property ColumnHeaders As ExportColumnHeaders
    Get
    Set
Visual C++
public:
property ExportColumnHeaders ColumnHeaders {
    ExportColumnHeaders get ();
    void set (ExportColumnHeaders value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

ViewScheduleExportOptions Class


FieldDelimiter Property

[image]

Revit 2024 API
ViewScheduleExportOptions..::..FieldDelimiter Property
ViewScheduleExportOptions Class See Also Send Feedback
How to delimit fields. Default is Tab.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public string FieldDelimiter { get; set; }
Visual Basic
Public Property FieldDelimiter As String
    Get
    Set
Visual C++
public:
property String^ FieldDelimiter {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ViewScheduleExportOptions Class


HeadersFootersBlanks Property

[image]

Revit 2024 API
ViewScheduleExportOptions..::..HeadersFootersBlanks Property
ViewScheduleExportOptions Class See Also Send Feedback
Whether to export group headers, footers, and blank lines. Default is true.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public bool HeadersFootersBlanks { get; set; }
Visual Basic
Public Property HeadersFootersBlanks As Boolean
    Get
    Set
Visual C++
public:
property bool HeadersFootersBlanks {
    bool get ();
    void set (bool value);
}

See Also

ViewScheduleExportOptions Class


TextQualifier Property

[image]

Revit 2024 API
ViewScheduleExportOptions..::..TextQualifier Property
ViewScheduleExportOptions Class See Also Send Feedback
How to qualify text fields. Default is DoubleQuote.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ExportTextQualifier TextQualifier { get; set; }
Visual Basic
Public Property TextQualifier As ExportTextQualifier
    Get
    Set
Visual C++
public:
property ExportTextQualifier TextQualifier {
    ExportTextQualifier get ();
    void set (ExportTextQualifier value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

ViewScheduleExportOptions Class


Title Property

[image]

Revit 2024 API
ViewScheduleExportOptions..::..Title Property
ViewScheduleExportOptions Class See Also Send Feedback
Whether or not to export the schedule title. Default is true.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014

Syntax

C#
public bool Title { get; set; }
Visual Basic
Public Property Title As Boolean
    Get
    Set
Visual C++
public:
property bool Title {
    bool get ();
    void set (bool value);
}

See Also

ViewScheduleExportOptions Class


ViewSection Members

[image] [image]

Revit 2024 API
ViewSection Members
ViewSection Class Methods Properties See Also Send Feedback

The ViewSection type exposes the following members.

Methods

 | Name | Description
Public method | AddFilter | Adds a filter to the view. (Inherited from View.)
Public method | AllowsAnalysisDisplay | Identifies if this view allows display of Analysis results. (Inherited from View.)
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of the input view that are not controlled by the current view template. (Inherited from View.)
Public method | AreGraphicsOverridesAllowed | Determines if Visibility/Graphics Overriddes can be applied to the view. (Inherited from View.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanApplyColorFillScheme | Checks if the id can be applied as the scheme id of specified category to this view. (Inherited from View.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanCategoryBeHidden | Checks whether the category can be hidden in the view. (Inherited from View.)
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view. (Inherited from View.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanEnableTemporaryViewPropertiesMode | Indicates if Temporary View Properties mode can be applied for view in current state. (Inherited from View.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified. (Inherited from View.)
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified. (Inherited from View.)
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified (Inherited from View.)
Public method | CanUseDepthCueing | Indicates if view can use Depth Cueing (Inherited from View.)
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes (Inherited from View.)
Public method | CanViewBeDuplicated | Identifies if this view can be duplicated. (Inherited from View.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view. (Inherited from View.)
Public method | ConvertToIndependent | Convert the dependent view to independent. (Inherited from View.)
 | CreateCallout | Creates a new callout view.
 | CreateDetail | Returns a new detail ViewSection.
 | CreateReferenceCallout | Creates a new reference callout.
 | CreateReferenceSection | Creates a new reference section.
 | CreateSection | Returns a new section ViewSection.
Public method | CreateViewTemplate | Creates a new view template instance from this view instance. (Inherited from View.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode. (Inherited from View.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates this view. (Inherited from View.)
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode. (Inherited from View.)
Public method | EnableTemporaryViewPropertiesMode | Turns Temporary View Properties mode on or off. In this mode, any changes made to the view are temporary and will be discarded once the mode is disabled. (Inherited from View.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetBackground | Returns the current background set for the view. (Inherited from View.)
Public method | GetCalloutParentId | Gets ID of the callout parent view. (Inherited from View.)
Public method | GetCategoryHidden | Checks if elements of the given category are set to be invisible (hidden) in this view. (Inherited from View.)
Public method | GetCategoryOverrides | Gets graphic overrides for a category in view. (Inherited from View.)
Public method | GetColorFillSchemeId | Returns id of the color fill scheme element applied to the view. (Inherited from View.)
Public method | GetCropRegionShapeManager | Returns an object for managing view crop region shape. (Inherited from View.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetDependentViewIds | Get the ids of dependent views. (Inherited from View.)
Public method | GetDepthCueing | Returns the current depth cueing settings for the view. (Inherited from View.)
Public method | GetDirectContext3DHandleOverrides | Returns DirectContext3D handle overrides object for the view. (Inherited from View.)
Public method | GetElementOverrides | Gets graphic overrides for an element in the view. (Inherited from View.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetFilterOverrides | Gets graphic overrides that a filter applies to the view. (Inherited from View.)
Public method | GetFilters | Gets the filters applied to the view. (Inherited from View.)
Public method | GetFilterVisibility | Gets the visibility of the elements associated with a filter. (Inherited from View.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIsFilterEnabled | Identifies if the filter is enabled in this view. (Inherited from View.)
Public method | GetLinkOverrides | Gets the graphic overrides of a RevitLinkType or RevitLinkInstance in view. (Inherited from View.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetModelToProjectionTransforms | Gets the transforms from the model space to the view projection space. (Inherited from View.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetNonControlledTemplateParameterIds | Returns a list of parameters that are not marked as included when this view is used as a template. (Inherited from View.)
Public method | GetOrderedFilters | Gets the filters applied to the view in the order they are applied. (Inherited from View.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPlacementOnSheetStatus | Determines if this view placed on a sheet completely or partially. (Inherited from View.)
Public method | GetPointCloudOverrides | Returns point cloud overrides object for the view. (Inherited from View.)
Public method | GetPrimaryViewId | Get the id of the primary view. (Inherited from View.)
Public method | GetReferenceCallouts | Returns element ids of all reference callouts in the view. (Inherited from View.)
Public method | GetReferenceElevations | Returns element ids of all reference elevations in the view. (Inherited from View.)
Public method | GetReferenceSections | Returns element ids of all reference sections in the view. (Inherited from View.)
Public method | GetSketchyLines | Returns the current sketchy lines settings for the view. (Inherited from View.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetTemplateParameterIds | Returns a list of parameter ids that may be controlled when this view is assigned as a template. (Inherited from View.)
Public method | GetTemporaryViewPropertiesId | When Temporary View Properties mode is in progress it provides view id that overrode settings for current view. Outside Temporary View Properties mode InvalidElementId will be returned. (Inherited from View.)
Public method | GetTemporaryViewPropertiesName | When Temporary View Properties mode is in progress, name of applied template is returned. Outside Temporary View Properties mode, empty string will be returned. (Inherited from View.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetViewDisplayModel | Returns the current view display model settings for the view. (Inherited from View.)
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view. (Inherited from View.)
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view. (Inherited from View.)
Public method | HasDetailLevel | Check if the view has a Detail Level property (Inherited from View.)
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property (Inherited from View.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property (Inherited from View.)
Public method | HasViewTransforms | Returns true if the view reports model space to view projection space transforms. (Inherited from View.)
Public method | HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View.)
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view. (Inherited from View.)
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view. (Inherited from View.)
Public method | HideElements | Sets the elements to be hidden in the view. (Inherited from View.)
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View.)
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View.)
Public method | IsCategoryOverridable | Checks whether the category can have graphic overrides in this view. (Inherited from View.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view. (Inherited from View.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsFilterApplied | Indicates if a filter is applied to the view. (Inherited from View.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode. (Inherited from View.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View.)
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View.)
 | IsParentViewValidForCallout | This validator checks that the parent view is appropriate for callout views.
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSplitSection | Sections can be split (jog) so that they cut at >1 plane.
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories. (Inherited from View.)
Public method | IsTemporaryViewPropertiesModeEnabled | Returns true when Temporary View Properties mode is in progress, false otherwise. (Inherited from View.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | IsValidViewTemplate | Verifies that the view represented by templateId can be set as the controlling view template for this view. (Inherited from View.)
 | IsViewFamilyTypeValidForCallout | This validator checks that the ViewFamilyType is appropriate for callout views in the input parent view.
Public method | IsViewValidForTemplateCreation | Verifies that the view is valid for template creation. (Inherited from View.)
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view. (Inherited from View.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | RemoveCalloutParent | Replaces callout parent ID with InvalidElementId. (Inherited from View.)
Public method | RemoveFilter | Removes a filter from the view. (Inherited from View.)
Public method | RemoveLinkOverrides | Deletes the graphical link overrides in the current view. (Inherited from View.)
Public method | RestoreCalloutParent | Restores callout parent ID to the original view ID if that view is still available. (Inherited from View.)
Public method | SetBackground | Sets the background for the view. Background can only be set for 3d views and for Sections/Elevations. (Inherited from View.)
Public method | SetCategoryHidden | Sets if elements of the given category will be visible in this view. (Inherited from View.)
Public method | SetCategoryOverrides | Sets graphic overrides for a category in view. (Inherited from View.)
Public method | SetColorFillSchemeId | Applies color fill scheme to this view. (Inherited from View.)
Public method | SetDepthCueing | Sets the depth cueing settings for the view. (Inherited from View.)
Public method | SetElementOverrides | Sets graphic overrides for an element in the view. (Inherited from View.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetFilterOverrides | Sets the overrides associated with a filter. (Inherited from View.)
Public method | SetFilterVisibility | Sets the visibility of the elements associated with a filter. (Inherited from View.)
Public method | SetIsFilterEnabled | Sets the filter enabled flag. (Inherited from View.)
Public method | SetLinkOverrides | Sets the graphic overrides of a RevitLinkType or RevitLinkInstance in the view. (Inherited from View.)
Public method | SetNonControlledTemplateParameterIds | Sets the parameters that will not be included when this view is used as a template. (Inherited from View.)
Public method | SetSketchyLines | Sets the sketchy lines settings for the view. (Inherited from View.)
Public method | SetViewDisplayModel | Sets the view display model settings for the view. (Inherited from View.)
Public method | SetWorksetVisibility | Sets visibility for a workset in this view. (Inherited from View.)
Public method | SetWorksharingDisplayMode | Sets the worksharing display mode for this view. (Inherited from View.)
Public method | ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View.)
Public method | SupportedColorFillCategoryIds | Returns collection of all category ids that correspond to elements that can potentially be colored in this view according to a color fill scheme. The set may be different depending on the view type. (Inherited from View.)
Public method | SupportsRevealConstraints | Checks that the view can have the Reveal Constraints mode activated. (Inherited from View.)
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode. (Inherited from View.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

Properties

 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View.)
Public property | AreAnalyticalModelCategoriesHidden | Indicates if analytical model categories are currently hidden in the view. (Inherited from View.)
Public property | AreAnnotationCategoriesHidden | Indicates if annotation categories are currently hidden in the view. (Inherited from View.)
Public property | AreCoordinationModelHandlesHidden | Indicates if Coordination Model handles are currently hidden in the view. (Inherited from View.)
Public property | AreImportCategoriesHidden | Indicates if import categories are currently hidden in the view. (Inherited from View.)
Public property | AreModelCategoriesHidden | Indicates if model categories are currently hidden in the view. (Inherited from View.)
Public property | ArePointCloudsHidden | Indicates if point clouds are currently hidden in the view. (Inherited from View.)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view. (Inherited from View.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CropBox | The Crop Box applied to the view, or an outline encompassing the crop region applied to the view. (Inherited from View.)
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View.)
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DetailLevel | The detail level of this view. (Inherited from View.)
Public property | Discipline | The Discipline of the view. (Inherited from View.)
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style. (Inherited from View.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | GenLevel | The level for the view. (Inherited from View.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsAssemblyView | Indicates if the view is assembly view. (Inherited from View.)
Public property | IsCallout | Indicates if the view is a callout view. (Inherited from View.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTemplate | Test whether the view is a view template. (Inherited from View.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Origin | Returns the origin of the screen. (Inherited from View.)
Public property | Outline | The bounds of the view in paper space (in feet). (Inherited from View.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PartsVisibility | The visibility setting for parts in this view. (Inherited from View.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RevealConstraintsMode | Indicates whether the Reveal Constraints mode is activated in the view. (Inherited from View.)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Public property | Scale | The scale of the view. (Inherited from View.)
Public property | ShadowIntensity | The intesity of cast shadows - 0 = no shadows, 100 = black. (Inherited from View.)
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View.)
Public property | SunlightIntensity | The intensity of the simulated (directional) sunlight. 0 = no directional light; maximum value is 100. (Inherited from View.)
Public property | TemporaryViewModes | Data of temporary view modes associated with this view. (Inherited from View.)
Public property | Title | The view title. This consists of the view name plus other modifiers, such as the view type, sheet number, area scheme, and/or assembly type, depending on the specifics of the view. (Inherited from View.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | ViewTemplateId | The id of the template view that controls this view's parameters. (Inherited from View.)
Public property | ViewType | The type of the view. (Inherited from View.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ViewSection Class


ViewSection Methods

[image] [image]

Revit 2024 API
ViewSection Methods
ViewSection Class See Also Send Feedback

The ViewSection type exposes the following members.

Methods

 | Name | Description
Public method | AddFilter | Adds a filter to the view. (Inherited from View.)
Public method | AllowsAnalysisDisplay | Identifies if this view allows display of Analysis results. (Inherited from View.)
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of the input view that are not controlled by the current view template. (Inherited from View.)
Public method | AreGraphicsOverridesAllowed | Determines if Visibility/Graphics Overriddes can be applied to the view. (Inherited from View.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanApplyColorFillScheme | Checks if the id can be applied as the scheme id of specified category to this view. (Inherited from View.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanCategoryBeHidden | Checks whether the category can be hidden in the view. (Inherited from View.)
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view. (Inherited from View.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanEnableTemporaryViewPropertiesMode | Indicates if Temporary View Properties mode can be applied for view in current state. (Inherited from View.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified. (Inherited from View.)
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified. (Inherited from View.)
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified (Inherited from View.)
Public method | CanUseDepthCueing | Indicates if view can use Depth Cueing (Inherited from View.)
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes (Inherited from View.)
Public method | CanViewBeDuplicated | Identifies if this view can be duplicated. (Inherited from View.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view. (Inherited from View.)
Public method | ConvertToIndependent | Convert the dependent view to independent. (Inherited from View.)
 | CreateCallout | Creates a new callout view.
 | CreateDetail | Returns a new detail ViewSection.
 | CreateReferenceCallout | Creates a new reference callout.
 | CreateReferenceSection | Creates a new reference section.
 | CreateSection | Returns a new section ViewSection.
Public method | CreateViewTemplate | Creates a new view template instance from this view instance. (Inherited from View.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode. (Inherited from View.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates this view. (Inherited from View.)
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode. (Inherited from View.)
Public method | EnableTemporaryViewPropertiesMode | Turns Temporary View Properties mode on or off. In this mode, any changes made to the view are temporary and will be discarded once the mode is disabled. (Inherited from View.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetBackground | Returns the current background set for the view. (Inherited from View.)
Public method | GetCalloutParentId | Gets ID of the callout parent view. (Inherited from View.)
Public method | GetCategoryHidden | Checks if elements of the given category are set to be invisible (hidden) in this view. (Inherited from View.)
Public method | GetCategoryOverrides | Gets graphic overrides for a category in view. (Inherited from View.)
Public method | GetColorFillSchemeId | Returns id of the color fill scheme element applied to the view. (Inherited from View.)
Public method | GetCropRegionShapeManager | Returns an object for managing view crop region shape. (Inherited from View.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetDependentViewIds | Get the ids of dependent views. (Inherited from View.)
Public method | GetDepthCueing | Returns the current depth cueing settings for the view. (Inherited from View.)
Public method | GetDirectContext3DHandleOverrides | Returns DirectContext3D handle overrides object for the view. (Inherited from View.)
Public method | GetElementOverrides | Gets graphic overrides for an element in the view. (Inherited from View.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetFilterOverrides | Gets graphic overrides that a filter applies to the view. (Inherited from View.)
Public method | GetFilters | Gets the filters applied to the view. (Inherited from View.)
Public method | GetFilterVisibility | Gets the visibility of the elements associated with a filter. (Inherited from View.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIsFilterEnabled | Identifies if the filter is enabled in this view. (Inherited from View.)
Public method | GetLinkOverrides | Gets the graphic overrides of a RevitLinkType or RevitLinkInstance in view. (Inherited from View.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetModelToProjectionTransforms | Gets the transforms from the model space to the view projection space. (Inherited from View.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetNonControlledTemplateParameterIds | Returns a list of parameters that are not marked as included when this view is used as a template. (Inherited from View.)
Public method | GetOrderedFilters | Gets the filters applied to the view in the order they are applied. (Inherited from View.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPlacementOnSheetStatus | Determines if this view placed on a sheet completely or partially. (Inherited from View.)
Public method | GetPointCloudOverrides | Returns point cloud overrides object for the view. (Inherited from View.)
Public method | GetPrimaryViewId | Get the id of the primary view. (Inherited from View.)
Public method | GetReferenceCallouts | Returns element ids of all reference callouts in the view. (Inherited from View.)
Public method | GetReferenceElevations | Returns element ids of all reference elevations in the view. (Inherited from View.)
Public method | GetReferenceSections | Returns element ids of all reference sections in the view. (Inherited from View.)
Public method | GetSketchyLines | Returns the current sketchy lines settings for the view. (Inherited from View.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetTemplateParameterIds | Returns a list of parameter ids that may be controlled when this view is assigned as a template. (Inherited from View.)
Public method | GetTemporaryViewPropertiesId | When Temporary View Properties mode is in progress it provides view id that overrode settings for current view. Outside Temporary View Properties mode InvalidElementId will be returned. (Inherited from View.)
Public method | GetTemporaryViewPropertiesName | When Temporary View Properties mode is in progress, name of applied template is returned. Outside Temporary View Properties mode, empty string will be returned. (Inherited from View.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetViewDisplayModel | Returns the current view display model settings for the view. (Inherited from View.)
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view. (Inherited from View.)
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view. (Inherited from View.)
Public method | HasDetailLevel | Check if the view has a Detail Level property (Inherited from View.)
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property (Inherited from View.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property (Inherited from View.)
Public method | HasViewTransforms | Returns true if the view reports model space to view projection space transforms. (Inherited from View.)
Public method | HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View.)
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view. (Inherited from View.)
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view. (Inherited from View.)
Public method | HideElements | Sets the elements to be hidden in the view. (Inherited from View.)
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View.)
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View.)
Public method | IsCategoryOverridable | Checks whether the category can have graphic overrides in this view. (Inherited from View.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view. (Inherited from View.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsFilterApplied | Indicates if a filter is applied to the view. (Inherited from View.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode. (Inherited from View.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View.)
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View.)
 | IsParentViewValidForCallout | This validator checks that the parent view is appropriate for callout views.
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSplitSection | Sections can be split (jog) so that they cut at >1 plane.
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories. (Inherited from View.)
Public method | IsTemporaryViewPropertiesModeEnabled | Returns true when Temporary View Properties mode is in progress, false otherwise. (Inherited from View.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | IsValidViewTemplate | Verifies that the view represented by templateId can be set as the controlling view template for this view. (Inherited from View.)
 | IsViewFamilyTypeValidForCallout | This validator checks that the ViewFamilyType is appropriate for callout views in the input parent view.
Public method | IsViewValidForTemplateCreation | Verifies that the view is valid for template creation. (Inherited from View.)
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view. (Inherited from View.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | RemoveCalloutParent | Replaces callout parent ID with InvalidElementId. (Inherited from View.)
Public method | RemoveFilter | Removes a filter from the view. (Inherited from View.)
Public method | RemoveLinkOverrides | Deletes the graphical link overrides in the current view. (Inherited from View.)
Public method | RestoreCalloutParent | Restores callout parent ID to the original view ID if that view is still available. (Inherited from View.)
Public method | SetBackground | Sets the background for the view. Background can only be set for 3d views and for Sections/Elevations. (Inherited from View.)
Public method | SetCategoryHidden | Sets if elements of the given category will be visible in this view. (Inherited from View.)
Public method | SetCategoryOverrides | Sets graphic overrides for a category in view. (Inherited from View.)
Public method | SetColorFillSchemeId | Applies color fill scheme to this view. (Inherited from View.)
Public method | SetDepthCueing | Sets the depth cueing settings for the view. (Inherited from View.)
Public method | SetElementOverrides | Sets graphic overrides for an element in the view. (Inherited from View.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetFilterOverrides | Sets the overrides associated with a filter. (Inherited from View.)
Public method | SetFilterVisibility | Sets the visibility of the elements associated with a filter. (Inherited from View.)
Public method | SetIsFilterEnabled | Sets the filter enabled flag. (Inherited from View.)
Public method | SetLinkOverrides | Sets the graphic overrides of a RevitLinkType or RevitLinkInstance in the view. (Inherited from View.)
Public method | SetNonControlledTemplateParameterIds | Sets the parameters that will not be included when this view is used as a template. (Inherited from View.)
Public method | SetSketchyLines | Sets the sketchy lines settings for the view. (Inherited from View.)
Public method | SetViewDisplayModel | Sets the view display model settings for the view. (Inherited from View.)
Public method | SetWorksetVisibility | Sets visibility for a workset in this view. (Inherited from View.)
Public method | SetWorksharingDisplayMode | Sets the worksharing display mode for this view. (Inherited from View.)
Public method | ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View.)
Public method | SupportedColorFillCategoryIds | Returns collection of all category ids that correspond to elements that can potentially be colored in this view according to a color fill scheme. The set may be different depending on the view type. (Inherited from View.)
Public method | SupportsRevealConstraints | Checks that the view can have the Reveal Constraints mode activated. (Inherited from View.)
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode. (Inherited from View.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

See Also

ViewSection Class


CreateCallout Method

[image]

Revit 2024 API
ViewSection..::..CreateCallout Method
ViewSection Class See Also Send Feedback
Creates a new callout view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static View CreateCallout(
    Document document,
    ElementId parentViewId,
    ElementId viewFamilyTypeId,
    XYZ point1,
    XYZ point2
)
Visual Basic
Public Shared Function CreateCallout ( _
    document As Document, _
    parentViewId As ElementId, _
    viewFamilyTypeId As ElementId, _
    point1 As XYZ, _
    point2 As XYZ _
) As View
Visual C++
public:
static View^ CreateCallout(
    Document^ document,
    ElementId^ parentViewId,
    ElementId^ viewFamilyTypeId,
    XYZ^ point1,
    XYZ^ point2
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new callout will be added.
parentViewId
Type: Autodesk.Revit.DB..::..ElementId
The view in which the callout appears. Callouts can be created in FloorPlan, CeilingPlan, StructuralPlan, Section, Elevation, and Detail views.
viewFamilyTypeId
Type: Autodesk.Revit.DB..::..ElementId
The id of the ViewFamilyType which will be used by the new callout ViewSection. Detail ViewFamilyTypes can be used in all parent views except for CeilingPlan and Drafting views. FloorPlan, CeilingPlan, StructuralPlan, Section, and Elevation ViewFamilyTypes may be be used in parent views that also use a type with the same ViewFamily enum value. For example, in StructuralPlan parent views both StructuralPlan and Detail ViewFamilyTypes are allowed.
point1
Type: Autodesk.Revit.DB..::..XYZ
Determines the extents of the callout symbol in the parent view.
point2
Type: Autodesk.Revit.DB..::..XYZ
Determine the extents of the callout symbol in the parent view.

Return Value

The new callout view. The view will be either a ViewSection, ViewPlan or ViewDetail.

Remarks

The extents of new callout are determined by using the two argument points as the opposing corners of a rectangle which is aligned to the directions of the parent view. The callout's near and far cut planes will match those of the parent view. The new view will receive a unique name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Non-reference callouts are not allowed in parent views of this type. -or- Callouts of the supplied ViewFamilyType are not allowed in the parent view. -or- point1 and point2 do not differ when projected onto a plane perpendicular to the view direction. -or- Callout view creation is not allowed in this family.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

ViewSection Class


CreateDetail Method

[image]

Revit 2024 API
ViewSection..::..CreateDetail Method
ViewSection Class Example See Also Send Feedback
Returns a new detail ViewSection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static ViewSection CreateDetail(
    Document document,
    ElementId viewFamilyTypeId,
    BoundingBoxXYZ sectionBox
)
Visual Basic
Public Shared Function CreateDetail ( _
    document As Document, _
    viewFamilyTypeId As ElementId, _
    sectionBox As BoundingBoxXYZ _
) As ViewSection
Visual C++
public:
static ViewSection^ CreateDetail(
    Document^ document,
    ElementId^ viewFamilyTypeId,
    BoundingBoxXYZ^ sectionBox
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new detail ViewSection will be added.
viewFamilyTypeId
Type: Autodesk.Revit.DB..::..ElementId
The id of the ViewFamilyType which will be used by the new detail ViewSection. The type needs to be a Detail ViewFamily.
sectionBox
Type: Autodesk.Revit.DB..::..BoundingBoxXYZ
The BoundingBoxXYZ which specifies the new ViewSection's view direction and extents.

Return Value

The new detail ViewSection.

Remarks

Create a detail ViewSection whose view volume corresponds geometrically with the specified sectionBox. The view direction of the resulting section will be sectionBox.Transform.BasisZ and the up direction will be sectionBox.Transform.BasisY. The right hand direction will be computed so that (right, up, view direction) form a left handed coordinate system. The resulting view will be cropped, and far clipping will be active. The crop region will correspond to the projections of BoundingBoxXYZ.Min and BoundingBoxXYZ.Max onto the view's cut plane. The far clip distance will be equal to the difference of the z-coordinates of BoundingBoxXYZ.Min and BoundingBoxXYZ.Max. The new detail ViewSection will receive a unique view name.

Examples

CopyC#
// Get a BoundingBoxXYZ instance from Revit
BoundingBoxXYZ box = document.ActiveView.CropBox;
if (null == box)
{
    throw new Exception("No BoundingBoxXYZ instance found.");
}

// Create a new view section.
ElementId DetailViewId = ElementId.InvalidElementId;
IList<Element> elems = new FilteredElementCollector(document).OfClass(typeof(ViewFamilyType)).ToElements();
foreach (Element e in elems)
{
    ViewFamilyType v = e as ViewFamilyType;

    if (v != null && v.ViewFamily == ViewFamily.Detail)
    {
        DetailViewId = e.Id;
        break;
    }
}
ViewSection viewSection = ViewSection.CreateDetail(document, DetailViewId, box);
CopyVB.NET
' Get a BoundingBoxXYZ instance from Revit
Dim box As BoundingBoxXYZ = document.ActiveView.CropBox
If box Is Nothing Then
    Throw New Exception("No BoundingBoxXYZ instance found.")
End If

' Create a new view section.
Dim DetailViewId As ElementId = ElementId.InvalidElementId
Dim elems As IList(Of Element) = New FilteredElementCollector(document).OfClass(GetType(ViewFamilyType)).ToElements()
For Each e As Element In elems
    Dim v As ViewFamilyType = TryCast(e, ViewFamilyType)

    If v IsNot Nothing AndAlso v.ViewFamily = ViewFamily.Detail Then
        DetailViewId = e.Id
        Exit For
    End If
Next
Dim viewSection__1 As ViewSection = ViewSection.CreateDetail(document, DetailViewId, box)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ViewFamilyType must be a Detail ViewFamily. -or- The BoundingBoxXYZ is not appropriate for detail views. The basis vectors of must be unit length and orthonormal. The near and far bound offsets cannot be reversed or too close to each other. MinEnabled and MaxEnabled must be set to true for all three directions. -or- Detail section view creation is not allowed in this family.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

ViewSection Class


CreateReferenceSection Method

[image]

Revit 2024 API
ViewSection..::..CreateReferenceSection Method
ViewSection Class See Also Send Feedback
Creates a new reference section.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static void CreateReferenceSection(
    Document document,
    ElementId parentViewId,
    ElementId viewIdToReference,
    XYZ headPoint,
    XYZ tailPoint
)
Visual Basic
Public Shared Sub CreateReferenceSection ( _
    document As Document, _
    parentViewId As ElementId, _
    viewIdToReference As ElementId, _
    headPoint As XYZ, _
    tailPoint As XYZ _
)
Visual C++
public:
static void CreateReferenceSection(
    Document^ document,
    ElementId^ parentViewId,
    ElementId^ viewIdToReference,
    XYZ^ headPoint,
    XYZ^ tailPoint
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the reference section will be added.
parentViewId
Type: Autodesk.Revit.DB..::..ElementId
The view in which the new reference section marker will appear. Reference sections can be created in FloorPlan, CeilingPlan, StructuralPlan, Section, Elevation, Drafting, and Detail views.
viewIdToReference
Type: Autodesk.Revit.DB..::..ElementId
Detail, Drafting and Section views can be referenced. The ViewFamilyType of the referenced view will be used by the new reference section.
headPoint
Type: Autodesk.Revit.DB..::..XYZ
Determines the location of the section marker's head in the parent view.
tailPoint
Type: Autodesk.Revit.DB..::..XYZ
Determines the location of the section marker's tail in the parent view.

Remarks

The reference section will assume the ViewFamilyType of the view it references.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId viewIdToReference does not correspond to a View. -or- The ElementId parentViewId does not correspond to a View. -or- The parent view and the referenced view must be different views. -or- Can't create a new reference sections in parentViewId. Parent views must be FloorPlan, CeilingPlan, StructuralPlan, Section, Elevation, Drafting, or Detail views. -or- The viewIdToReference cannot be referenced by reference sections. Only Detail, Drafting and Section views can be referenced. -or- headPoint and tailPoint do not differ when projected onto a plane perpendicular to the view direction. -or- Reference section view creation is not allowed in this family.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

ViewSection Class


IsParentViewValidForCallout Method

[image]

Revit 2024 API
ViewSection..::..IsParentViewValidForCallout Method
ViewSection Class See Also Send Feedback
This validator checks that the parent view is appropriate for callout views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static bool IsParentViewValidForCallout(
    Document document,
    ElementId parentViewId
)
Visual Basic
Public Shared Function IsParentViewValidForCallout ( _
    document As Document, _
    parentViewId As ElementId _
) As Boolean
Visual C++
public:
static bool IsParentViewValidForCallout(
    Document^ document,
    ElementId^ parentViewId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document which contains the ViewFamilyType and parent view.
parentViewId
Type: Autodesk.Revit.DB..::..ElementId
The view in which the new callout will appear. Callouts can be created in FloorPlan, CeilingPlan, StructuralPlan, Section, Elevation, and Detail views.

Return Value

True if the ViewFamilyType can be used for callout views in the parent view, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ViewSection Class


IsSplitSection Method

[image]

Revit 2024 API
ViewSection..::..IsSplitSection Method
ViewSection Class See Also Send Feedback
Sections can be split (jog) so that they cut at >1 plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public bool IsSplitSection()
Visual Basic
Public Function IsSplitSection As Boolean
Visual C++
public:
bool IsSplitSection()

Return Value

True if the section is split.

See Also

ViewSection Class


IsViewFamilyTypeValidForCallout Method

[image]

Revit 2024 API
ViewSection..::..IsViewFamilyTypeValidForCallout Method
ViewSection Class See Also Send Feedback
This validator checks that the ViewFamilyType is appropriate for callout views in the input parent view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static bool IsViewFamilyTypeValidForCallout(
    Document document,
    ElementId viewFamilyTypeId,
    ElementId parentViewId
)
Visual Basic
Public Shared Function IsViewFamilyTypeValidForCallout ( _
    document As Document, _
    viewFamilyTypeId As ElementId, _
    parentViewId As ElementId _
) As Boolean
Visual C++
public:
static bool IsViewFamilyTypeValidForCallout(
    Document^ document,
    ElementId^ viewFamilyTypeId,
    ElementId^ parentViewId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document which contains the ViewFamilyType and parent view.
viewFamilyTypeId
Type: Autodesk.Revit.DB..::..ElementId
The id of the ViewFamilyType which will be used by the new callout ViewSection. Detail ViewFamilyTypes can be used in all parent views except for CeilingPlan and Drafting views. FloorPlan, CeilingPlan, StructuralPlan, Section, Elevation, and Detail ViewFamilyTypes may be be used in parent views that also use a type with the same ViewFamily enum value. For example, in StructuralPlan views both StructuralPlan and Detail ViewFamilyTypes are allowed.
parentViewId
Type: Autodesk.Revit.DB..::..ElementId
The view in which the new callout will appear. Callouts can be created in FloorPlan, CeilingPlan, StructuralPlan, Section, Elevation, and Detail views.

Return Value

True if the ViewFamilyType can be used for callout views in the parent view, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ViewSection Class


ViewSection Properties

[image] [image]

Revit 2024 API
ViewSection Properties
ViewSection Class See Also Send Feedback

The ViewSection type exposes the following members.

Properties

 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View.)
Public property | AreAnalyticalModelCategoriesHidden | Indicates if analytical model categories are currently hidden in the view. (Inherited from View.)
Public property | AreAnnotationCategoriesHidden | Indicates if annotation categories are currently hidden in the view. (Inherited from View.)
Public property | AreCoordinationModelHandlesHidden | Indicates if Coordination Model handles are currently hidden in the view. (Inherited from View.)
Public property | AreImportCategoriesHidden | Indicates if import categories are currently hidden in the view. (Inherited from View.)
Public property | AreModelCategoriesHidden | Indicates if model categories are currently hidden in the view. (Inherited from View.)
Public property | ArePointCloudsHidden | Indicates if point clouds are currently hidden in the view. (Inherited from View.)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view. (Inherited from View.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CropBox | The Crop Box applied to the view, or an outline encompassing the crop region applied to the view. (Inherited from View.)
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View.)
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DetailLevel | The detail level of this view. (Inherited from View.)
Public property | Discipline | The Discipline of the view. (Inherited from View.)
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style. (Inherited from View.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | GenLevel | The level for the view. (Inherited from View.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsAssemblyView | Indicates if the view is assembly view. (Inherited from View.)
Public property | IsCallout | Indicates if the view is a callout view. (Inherited from View.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTemplate | Test whether the view is a view template. (Inherited from View.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Origin | Returns the origin of the screen. (Inherited from View.)
Public property | Outline | The bounds of the view in paper space (in feet). (Inherited from View.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PartsVisibility | The visibility setting for parts in this view. (Inherited from View.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RevealConstraintsMode | Indicates whether the Reveal Constraints mode is activated in the view. (Inherited from View.)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Public property | Scale | The scale of the view. (Inherited from View.)
Public property | ShadowIntensity | The intesity of cast shadows - 0 = no shadows, 100 = black. (Inherited from View.)
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View.)
Public property | SunlightIntensity | The intensity of the simulated (directional) sunlight. 0 = no directional light; maximum value is 100. (Inherited from View.)
Public property | TemporaryViewModes | Data of temporary view modes associated with this view. (Inherited from View.)
Public property | Title | The view title. This consists of the view name plus other modifiers, such as the view type, sheet number, area scheme, and/or assembly type, depending on the specifics of the view. (Inherited from View.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | ViewTemplateId | The id of the template view that controls this view's parameters. (Inherited from View.)
Public property | ViewType | The type of the view. (Inherited from View.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ViewSection Class


ViewSet Class

[image]

Revit 2024 API
ViewSet Class
Members See Also Send Feedback
A set that contains views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class ViewSet : APIObject, IEnumerable
Visual Basic
Public Class ViewSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ViewSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..ViewSet

See Also

ViewSet Members


ViewSet Members

[image] [image]

Revit 2024 API
ViewSet Members
ViewSet Class Constructors Methods Properties See Also Send Feedback

The ViewSet type exposes the following members.

Constructors

 | Name | Description
Public method | ViewSet | Initializes a new instance of the ViewSet class

Methods

 | Name | Description
Public method | Clear | Removes every view from the set, rendering it empty.
Public method | Contains | Tests for the existence of a view within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified view from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified view into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of views that are in the set.

See Also

ViewSet Class


Clear Method

[image]

Revit 2024 API
ViewSet..::..Clear Method
ViewSet Class See Also Send Feedback
Removes every view from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ViewSet Class


Contains Method

[image]

Revit 2024 API
ViewSet..::..Contains Method
ViewSet Class See Also Send Feedback
Tests for the existence of a view within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool Contains(
    View item
)
Visual Basic
Public Overridable Function Contains ( _
    item As View _
) As Boolean
Visual C++
public:
virtual bool Contains(
    View^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..View
The view to be searched for.

Return Value

The Contains method returns True if the view is within the set, otherwise False.

See Also

ViewSet Class


Erase Method

[image]

Revit 2024 API
ViewSet..::..Erase Method
ViewSet Class See Also Send Feedback
Removes a specified view from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Erase(
    View item
)
Visual Basic
Public Overridable Function Erase ( _
    item As View _
) As Integer
Visual C++
public:
virtual int Erase(
    View^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..View
The view to be erased.

Return Value

The number of views that were erased from the set.

See Also

ViewSet Class


ForwardIterator Method

[image]

Revit 2024 API
ViewSet..::..ForwardIterator Method
ViewSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual ViewSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As ViewSetIterator
Visual C++
public:
virtual ViewSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

ViewSet Class


Insert Method

[image]

Revit 2024 API
ViewSet..::..Insert Method
ViewSet Class See Also Send Feedback
Insert the specified view into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool Insert(
    View item
)
Visual Basic
Public Overridable Function Insert ( _
    item As View _
) As Boolean
Visual C++
public:
virtual bool Insert(
    View^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..View
The view to be inserted into the set.

Return Value

Returns whether the view was inserted into the set.

See Also

ViewSet Class


ReverseIterator Method

[image]

Revit 2024 API
ViewSet..::..ReverseIterator Method
ViewSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual ViewSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As ViewSetIterator
Visual C++
public:
virtual ViewSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

ViewSet Class


ViewSet Properties

[image] [image]

Revit 2024 API
ViewSet Properties
ViewSet Class See Also Send Feedback

The ViewSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of views that are in the set.

See Also

ViewSet Class


IsEmpty Property

[image]

Revit 2024 API
ViewSet..::..IsEmpty Property
ViewSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

ViewSet Class


Size Property

[image]

Revit 2024 API
ViewSet..::..Size Property
ViewSet Class See Also Send Feedback
Returns the number of views that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ViewSet Class


MoveNext Method

[image]

Revit 2024 API
ViewSetIterator..::..MoveNext Method
ViewSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ViewSetIterator Class


Reset Method

[image]

Revit 2024 API
ViewSetIterator..::..Reset Method
ViewSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ViewSetIterator Class


ViewSetIterator Properties

[image] [image]

Revit 2024 API
ViewSetIterator Properties
ViewSetIterator Class See Also Send Feedback

The ViewSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ViewSetIterator Class


Current Property

[image]

Revit 2024 API
ViewSetIterator..::..Current Property
ViewSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ViewSetIterator Class


ViewShapeBuilder Members

[image] [image]

Revit 2024 API
ViewShapeBuilder Members
ViewShapeBuilder Class Constructors Methods Properties See Also Send Feedback

The ViewShapeBuilder type exposes the following members.

Constructors

 | Name | Description
Public method | ViewShapeBuilder()()()() | Default constructor for an ViewShapeBuilder object.
Public method | ViewShapeBuilder(DirectShapeTargetViewType) | A constructor for an ViewShapeBuilder object that takes a view type. It will infer the view normal from view type. View normal and view type are used to validate the geometry to be stored as a view-specific shape representation of a DirectShape object.

Methods

 | Name | Description
Public method | AddCurve | Add a curve to the GRep associated to this ViewShapeBuilder.
Public method | Dispose | (Inherited from ShapeBuilder.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Reset | Clears the accumulated geometry and resets other ViewShapeBuilder parameters to invalid values.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValidateCurve(Curve) | Validates curve to be added to the view-specific shape being constructed. Called by AddCurve() to validate input. Expects a valid view normal to be set prior to the call.
 | ValidateCurve(Curve, DirectShapeTargetViewType) | Validates curve to be added to the view-specific shape being constructed. Called by AddCurve() to validate input. This function may be used to pre-validate the geometry being added to avoid AddCurve() throwing an InvalidArgumentException
 | ValidateShape | Validates a shape represented as a collection of geometry objects for use as a view-specific shape. The objects are expected to be either points, curves or polylines. Curves are expected to be flat and lie in a plane perpendicular to view normal as defined by view type.
 | ValidateViewType | Validates the incoming view type. As of today, the only allowed view type is Plan.

Properties

 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ShapeBuilder.)
Public property | ViewNormal | Normal of the view that will display the shape being built. Must be set explicitly before adding any geometry. Must be a unit vector. This is used to validate incoming geometry - it must be orthogonal to the viewNormal.
Public property | ViewType | View type where the view-specific shape currently being built will be used

See Also

ViewShapeBuilder Class


ViewShapeBuilder Constructor

[image]

Revit 2024 API
ViewShapeBuilder Constructor
ViewShapeBuilder Class See Also Send Feedback
Default constructor for an ViewShapeBuilder object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public ViewShapeBuilder()
Visual Basic
Public Sub New
Visual C++
public:
ViewShapeBuilder()

See Also

ViewShapeBuilder Class
ViewShapeBuilder Overload


ViewShapeBuilder Constructor (DirectShapeTargetViewType)

[image]

Revit 2024 API
ViewShapeBuilder Constructor (DirectShapeTargetViewType)
ViewShapeBuilder Class See Also Send Feedback
A constructor for an ViewShapeBuilder object that takes a view type. It will infer the view normal from view type. View normal and view type are used to validate the geometry to be stored as a view-specific shape representation of a DirectShape object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public ViewShapeBuilder(
    DirectShapeTargetViewType targetViewType
)
Visual Basic
Public Sub New ( _
    targetViewType As DirectShapeTargetViewType _
)
Visual C++
public:
ViewShapeBuilder(
    DirectShapeTargetViewType targetViewType
)

Parameters

targetViewType
Type: Autodesk.Revit.DB..::..DirectShapeTargetViewType
View type for which this shape representation is intended. Currently limited to Plan Views.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | targetViewType is not DirectShapeTargetViewType::Plan
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

ViewShapeBuilder Class
ViewShapeBuilder Overload


ViewShapeBuilder Methods

[image] [image]

Revit 2024 API
ViewShapeBuilder Methods
ViewShapeBuilder Class See Also Send Feedback

The ViewShapeBuilder type exposes the following members.

Methods

 | Name | Description
Public method | AddCurve | Add a curve to the GRep associated to this ViewShapeBuilder.
Public method | Dispose | (Inherited from ShapeBuilder.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Reset | Clears the accumulated geometry and resets other ViewShapeBuilder parameters to invalid values.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValidateCurve(Curve) | Validates curve to be added to the view-specific shape being constructed. Called by AddCurve() to validate input. Expects a valid view normal to be set prior to the call.
 | ValidateCurve(Curve, DirectShapeTargetViewType) | Validates curve to be added to the view-specific shape being constructed. Called by AddCurve() to validate input. This function may be used to pre-validate the geometry being added to avoid AddCurve() throwing an InvalidArgumentException
 | ValidateShape | Validates a shape represented as a collection of geometry objects for use as a view-specific shape. The objects are expected to be either points, curves or polylines. Curves are expected to be flat and lie in a plane perpendicular to view normal as defined by view type.
 | ValidateViewType | Validates the incoming view type. As of today, the only allowed view type is Plan.

See Also

ViewShapeBuilder Class


Reset Method

[image]

Revit 2024 API
ViewShapeBuilder..::..Reset Method
ViewShapeBuilder Class See Also Send Feedback
Clears the accumulated geometry and resets other ViewShapeBuilder parameters to invalid values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset
Visual C++
public:
void Reset()

See Also

ViewShapeBuilder Class


ValidateCurve Method

[image] [image]

Revit 2024 API
ViewShapeBuilder..::..ValidateCurve Method
ViewShapeBuilder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ValidateCurve(Curve) | Validates curve to be added to the view-specific shape being constructed. Called by AddCurve() to validate input. Expects a valid view normal to be set prior to the call.
 | ValidateCurve(Curve, DirectShapeTargetViewType) | Validates curve to be added to the view-specific shape being constructed. Called by AddCurve() to validate input. This function may be used to pre-validate the geometry being added to avoid AddCurve() throwing an InvalidArgumentException

See Also

ViewShapeBuilder Class
ViewShapeBuilder Members


ValidateCurve Method (Curve)

[image]

Revit 2024 API
ViewShapeBuilder..::..ValidateCurve Method (Curve)
ViewShapeBuilder Class See Also Send Feedback
Validates curve to be added to the view-specific shape being constructed. Called by AddCurve() to validate input. Expects a valid view normal to be set prior to the call.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool ValidateCurve(
    Curve GCurve
)
Visual Basic
Public Function ValidateCurve ( _
    GCurve As Curve _
) As Boolean
Visual C++
public:
bool ValidateCurve(
    Curve^ GCurve
)

Parameters

GCurve
Type: Autodesk.Revit.DB..::..Curve
Curve object to be validated.

Return Value

True is %GCurve% is acceptable as a part of view-specific shape representation being built.

Remarks

This function may be used to pre-validate the geometry being added to avoid AddCurve() throwing an InvalidArgumentException Validation conditions depend on the type of view for which the shape representation is intended. For plan views, a curve is expected to be planar and non-degenerate (e.g., NOT a circle of zero radius).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ViewShapeBuilder Class
ValidateCurve Overload


ValidateCurve Method (Curve, DirectShapeTargetViewType)

[image]

Revit 2024 API
ViewShapeBuilder..::..ValidateCurve Method (Curve, DirectShapeTargetViewType)
ViewShapeBuilder Class See Also Send Feedback
Validates curve to be added to the view-specific shape being constructed. Called by AddCurve() to validate input. This function may be used to pre-validate the geometry being added to avoid AddCurve() throwing an InvalidArgumentException

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public static bool ValidateCurve(
    Curve GCurve,
    DirectShapeTargetViewType targetViewType
)
Visual Basic
Public Shared Function ValidateCurve ( _
    GCurve As Curve, _
    targetViewType As DirectShapeTargetViewType _
) As Boolean
Visual C++
public:
static bool ValidateCurve(
    Curve^ GCurve,
    DirectShapeTargetViewType targetViewType
)

Parameters

GCurve
Type: Autodesk.Revit.DB..::..Curve
Curve object to be validated.
targetViewType
Type: Autodesk.Revit.DB..::..DirectShapeTargetViewType
View type for which this curve is intended.

Return Value

True is %GCurve% is acceptable as a part of view-specific shape representation.

Remarks

Validation conditions depend on the type of view for which the shape representation is intended. For plan views, a curve is expected to be planar and non-degenerate (e.g., NOT a circle of zero radius).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

ViewShapeBuilder Class
ValidateCurve Overload


ValidateShape Method

[image]

Revit 2024 API
ViewShapeBuilder..::..ValidateShape Method
ViewShapeBuilder Class See Also Send Feedback
Validates a shape represented as a collection of geometry objects for use as a view-specific shape. The objects are expected to be either points, curves or polylines. Curves are expected to be flat and lie in a plane perpendicular to view normal as defined by view type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017

Syntax

C#
public static bool ValidateShape(
    IList<GeometryObject> shape,
    DirectShapeTargetViewType targetViewType
)
Visual Basic
Public Shared Function ValidateShape ( _
    shape As IList(Of GeometryObject), _
    targetViewType As DirectShapeTargetViewType _
) As Boolean
Visual C++
public:
static bool ValidateShape(
    IList<GeometryObject^>^ shape,
    DirectShapeTargetViewType targetViewType
)

Parameters

shape
Type: System.Collections.Generic..::..IList<(Of <(<' GeometryObject >)>)>
targetViewType
Type: Autodesk.Revit.DB..::..DirectShapeTargetViewType

Return Value

Returns true if %shape% may be used as a view-specific shape representation, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | targetViewType is not DirectShapeTargetViewType::Plan
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

ViewShapeBuilder Class


ValidateViewType Method

[image]

Revit 2024 API
ViewShapeBuilder..::..ValidateViewType Method
ViewShapeBuilder Class See Also Send Feedback
Validates the incoming view type. As of today, the only allowed view type is Plan.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public static bool ValidateViewType(
    DirectShapeTargetViewType targetViewType
)
Visual Basic
Public Shared Function ValidateViewType ( _
    targetViewType As DirectShapeTargetViewType _
) As Boolean
Visual C++
public:
static bool ValidateViewType(
    DirectShapeTargetViewType targetViewType
)

Parameters

targetViewType
Type: Autodesk.Revit.DB..::..DirectShapeTargetViewType

Return Value

True if %targetViewType% is DirectShapeTargetViewType::Plan

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

ViewShapeBuilder Class


ViewNormal Property

[image]

Revit 2024 API
ViewShapeBuilder..::..ViewNormal Property
ViewShapeBuilder Class See Also Send Feedback
Normal of the view that will display the shape being built. Must be set explicitly before adding any geometry. Must be a unit vector. This is used to validate incoming geometry - it must be orthogonal to the viewNormal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public XYZ ViewNormal { get; set; }
Visual Basic
Public Property ViewNormal As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ ViewNormal {
    XYZ^ get ();
    void set (XYZ^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: viewNormal is not length 1.0.

See Also

ViewShapeBuilder Class


ViewType Property

[image]

Revit 2024 API
ViewShapeBuilder..::..ViewType Property
ViewShapeBuilder Class See Also Send Feedback
View type where the view-specific shape currently being built will be used

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public DirectShapeTargetViewType ViewType { get; set; }
Visual Basic
Public Property ViewType As DirectShapeTargetViewType
    Get
    Set
Visual C++
public:
property DirectShapeTargetViewType ViewType {
    DirectShapeTargetViewType get ();
    void set (DirectShapeTargetViewType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

ViewShapeBuilder Class


ViewSheet Class

[image]

Revit 2024 API
ViewSheet Class
Members Example See Also Send Feedback
Class for ViewSheet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class ViewSheet : View
Visual Basic
Public Class ViewSheet _
    Inherits View
Visual C++
public ref class ViewSheet : public View

Examples

CopyC#
private void Getinfo_ViewSheet(ViewSheet viewSheet)
{
    string message = "ViewSheet: ";
    //Get the number of the Sheet
    string sheetNumber = viewSheet.SheetNumber;
    message += "\nSheet Number: " + sheetNumber;

    //Exception occurs when set SheetNumber to a number that isn't unique
    string TestSheetNumber = "My sheet";
    viewSheet.SheetNumber = TestSheetNumber;
    message += "\nSheet Number after set: " + sheetNumber;

    ICollection<ElementId> views = viewSheet.GetAllPlacedViews();
    message += "\nNumber of views in the sheet : " + views.Count;

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Private Sub Getinfo_ViewSheet(viewSheet As ViewSheet)
    Dim message As String = "ViewSheet: "
    'Get the number of the Sheet
    Dim sheetNumber As String = viewSheet.SheetNumber
    message += vbLf & "Sheet Number: " & sheetNumber

    'Exception occurs when set SheetNumber to a number that isn't unique
    Dim TestSheetNumber As String = "My sheet"
    viewSheet.SheetNumber = TestSheetNumber
    message += vbLf & "Sheet Number after set: " & sheetNumber

    Dim views As ICollection(Of ElementId) = viewSheet.GetAllPlacedViews()
    message += vbLf & "Number of views in the sheet : " & views.Count

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..View
Autodesk.Revit.DB..::..ViewSheet

See Also

ViewSheet Members


ViewSheet Members

[image] [image]

Revit 2024 API
ViewSheet Members
ViewSheet Class Methods Properties See Also Send Feedback

The ViewSheet type exposes the following members.

Methods

 | Name | Description
Public method | AddFilter | Adds a filter to the view. (Inherited from View.)
Public method | AllowsAnalysisDisplay | Identifies if this view allows display of Analysis results. (Inherited from View.)
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of the input view that are not controlled by the current view template. (Inherited from View.)
Public method | AreGraphicsOverridesAllowed | Determines if Visibility/Graphics Overriddes can be applied to the view. (Inherited from View.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanApplyColorFillScheme | Checks if the id can be applied as the scheme id of specified category to this view. (Inherited from View.)
Public method | CanBeDuplicated | Identifies if this sheet can be duplicated.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanCategoryBeHidden | Checks whether the category can be hidden in the view. (Inherited from View.)
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view. (Inherited from View.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanEnableTemporaryViewPropertiesMode | Indicates if Temporary View Properties mode can be applied for view in current state. (Inherited from View.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified. (Inherited from View.)
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified. (Inherited from View.)
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified (Inherited from View.)
Public method | CanUseDepthCueing | Indicates if view can use Depth Cueing (Inherited from View.)
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes (Inherited from View.)
Public method | CanViewBeDuplicated | Identifies if this view can be duplicated. (Inherited from View.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view. (Inherited from View.)
Public method | ConvertToIndependent | Convert the dependent view to independent. (Inherited from View.)
Public method | ConvertToRealSheet | Converts a placeholder sheet to a real one with an optional titleblock.
 | Create | Creates a new ViewSheet.
 | CreatePlaceholder | Creates a placeholder sheet in a document.
Public method | CreateViewTemplate | Creates a new view template instance from this view instance. (Inherited from View.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | DeleteViewport | Removes a viewport from the sheet by deleting it from the document.
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode. (Inherited from View.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate(SheetDuplicateOption) | Duplicates this sheet to generate a new one.
Public method | Duplicate(ViewDuplicateOption) | Duplicates this view. (Inherited from View.)
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode. (Inherited from View.)
Public method | EnableTemporaryViewPropertiesMode | Turns Temporary View Properties mode on or off. In this mode, any changes made to the view are temporary and will be discarded once the mode is disabled. (Inherited from View.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetAdditionalRevisionIds | Gets the Revisions that are additionally included in the sheet's revision schedules.
Public method | GetAllPlacedViews | Returns the ElementIds of Views placed on this sheet.
Public method | GetAllRevisionCloudIds | Gets the ids of the revision clouds which appear on the sheet's revision schedules.
Public method | GetAllRevisionIds | Gets the ordered array of Revisions which participate in the sheet's revision schedules.
Public method | GetAllViewports | Returns the ElementIds of Viewports on this sheet.
Public method | GetBackground | Returns the current background set for the view. (Inherited from View.)
Public method | GetCalloutParentId | Gets ID of the callout parent view. (Inherited from View.)
Public method | GetCategoryHidden | Checks if elements of the given category are set to be invisible (hidden) in this view. (Inherited from View.)
Public method | GetCategoryOverrides | Gets graphic overrides for a category in view. (Inherited from View.)
Public method | GetColorFillSchemeId | Returns id of the color fill scheme element applied to the view. (Inherited from View.)
Public method | GetCropRegionShapeManager | Returns an object for managing view crop region shape. (Inherited from View.)
Public method | GetCurrentRevision | Returns the most recent numbered Revision shown on this ViewSheet.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetDependentViewIds | Get the ids of dependent views. (Inherited from View.)
Public method | GetDepthCueing | Returns the current depth cueing settings for the view. (Inherited from View.)
Public method | GetDirectContext3DHandleOverrides | Returns DirectContext3D handle overrides object for the view. (Inherited from View.)
Public method | GetElementOverrides | Gets graphic overrides for an element in the view. (Inherited from View.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetFilterOverrides | Gets graphic overrides that a filter applies to the view. (Inherited from View.)
Public method | GetFilters | Gets the filters applied to the view. (Inherited from View.)
Public method | GetFilterVisibility | Gets the visibility of the elements associated with a filter. (Inherited from View.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIsFilterEnabled | Identifies if the filter is enabled in this view. (Inherited from View.)
Public method | GetLinkOverrides | Gets the graphic overrides of a RevitLinkType or RevitLinkInstance in view. (Inherited from View.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetModelToProjectionTransforms | Gets the transforms from the model space to the view projection space. (Inherited from View.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetNonControlledTemplateParameterIds | Returns a list of parameters that are not marked as included when this view is used as a template. (Inherited from View.)
Public method | GetOrderedFilters | Gets the filters applied to the view in the order they are applied. (Inherited from View.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetPlacementOnSheetStatus | Determines if this view placed on a sheet completely or partially. (Inherited from View.)
Public method | GetPointCloudOverrides | Returns point cloud overrides object for the view. (Inherited from View.)
Public method | GetPrimaryViewId | Get the id of the primary view. (Inherited from View.)
Public method | GetReferenceCallouts | Returns element ids of all reference callouts in the view. (Inherited from View.)
Public method | GetReferenceElevations | Returns element ids of all reference elevations in the view. (Inherited from View.)
Public method | GetReferenceSections | Returns element ids of all reference sections in the view. (Inherited from View.)
Public method | GetRevisionCloudNumberOnSheet | Gets the Revision Number for a RevisionCloud on this sheet.
Public method | GetRevisionNumberOnSheet | Gets the Revision Number for a particular Revision as it will appear on this sheet.
Public method | GetSketchyLines | Returns the current sketchy lines settings for the view. (Inherited from View.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetTemplateParameterIds | Returns a list of parameter ids that may be controlled when this view is assigned as a template. (Inherited from View.)
Public method | GetTemporaryViewPropertiesId | When Temporary View Properties mode is in progress it provides view id that overrode settings for current view. Outside Temporary View Properties mode InvalidElementId will be returned. (Inherited from View.)
Public method | GetTemporaryViewPropertiesName | When Temporary View Properties mode is in progress, name of applied template is returned. Outside Temporary View Properties mode, empty string will be returned. (Inherited from View.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetViewDisplayModel | Returns the current view display model settings for the view. (Inherited from View.)
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view. (Inherited from View.)
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view. (Inherited from View.)
Public method | HasDetailLevel | Check if the view has a Detail Level property (Inherited from View.)
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property (Inherited from View.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property (Inherited from View.)
Public method | HasViewTransforms | Returns true if the view reports model space to view projection space transforms. (Inherited from View.)
Public method | HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View.)
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view. (Inherited from View.)
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view. (Inherited from View.)
Public method | HideElements | Sets the elements to be hidden in the view. (Inherited from View.)
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View.)
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View.)
Public method | IsCategoryOverridable | Checks whether the category can have graphic overrides in this view. (Inherited from View.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view. (Inherited from View.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsFilterApplied | Indicates if a filter is applied to the view. (Inherited from View.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode. (Inherited from View.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View.)
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories. (Inherited from View.)
Public method | IsTemporaryViewPropertiesModeEnabled | Returns true when Temporary View Properties mode is in progress, false otherwise. (Inherited from View.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | IsValidViewTemplate | Verifies that the view represented by templateId can be set as the controlling view template for this view. (Inherited from View.)
Public method | IsViewValidForTemplateCreation | Verifies that the view is valid for template creation. (Inherited from View.)
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view. (Inherited from View.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | RemoveCalloutParent | Replaces callout parent ID with InvalidElementId. (Inherited from View.)
Public method | RemoveFilter | Removes a filter from the view. (Inherited from View.)
Public method | RemoveLinkOverrides | Deletes the graphical link overrides in the current view. (Inherited from View.)
Public method | RestoreCalloutParent | Restores callout parent ID to the original view ID if that view is still available. (Inherited from View.)
Public method | SetAdditionalRevisionIds | Sets the Revisions to additionally include in the sheet's revision schedules.
Public method | SetBackground | Sets the background for the view. Background can only be set for 3d views and for Sections/Elevations. (Inherited from View.)
Public method | SetCategoryHidden | Sets if elements of the given category will be visible in this view. (Inherited from View.)
Public method | SetCategoryOverrides | Sets graphic overrides for a category in view. (Inherited from View.)
Public method | SetColorFillSchemeId | Applies color fill scheme to this view. (Inherited from View.)
Public method | SetDepthCueing | Sets the depth cueing settings for the view. (Inherited from View.)
Public method | SetElementOverrides | Sets graphic overrides for an element in the view. (Inherited from View.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetFilterOverrides | Sets the overrides associated with a filter. (Inherited from View.)
Public method | SetFilterVisibility | Sets the visibility of the elements associated with a filter. (Inherited from View.)
Public method | SetIsFilterEnabled | Sets the filter enabled flag. (Inherited from View.)
Public method | SetLinkOverrides | Sets the graphic overrides of a RevitLinkType or RevitLinkInstance in the view. (Inherited from View.)
Public method | SetNonControlledTemplateParameterIds | Sets the parameters that will not be included when this view is used as a template. (Inherited from View.)
Public method | SetSketchyLines | Sets the sketchy lines settings for the view. (Inherited from View.)
Public method | SetViewDisplayModel | Sets the view display model settings for the view. (Inherited from View.)
Public method | SetWorksetVisibility | Sets visibility for a workset in this view. (Inherited from View.)
Public method | SetWorksharingDisplayMode | Sets the worksharing display mode for this view. (Inherited from View.)
Public method | ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View.)
Public method | SupportedColorFillCategoryIds | Returns collection of all category ids that correspond to elements that can potentially be colored in this view according to a color fill scheme. The set may be different depending on the view type. (Inherited from View.)
Public method | SupportsRevealConstraints | Checks that the view can have the Reveal Constraints mode activated. (Inherited from View.)
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode. (Inherited from View.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

Properties

 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View.)
Public property | AreAnalyticalModelCategoriesHidden | Indicates if analytical model categories are currently hidden in the view. (Inherited from View.)
Public property | AreAnnotationCategoriesHidden | Indicates if annotation categories are currently hidden in the view. (Inherited from View.)
Public property | AreCoordinationModelHandlesHidden | Indicates if Coordination Model handles are currently hidden in the view. (Inherited from View.)
Public property | AreImportCategoriesHidden | Indicates if import categories are currently hidden in the view. (Inherited from View.)
Public property | AreModelCategoriesHidden | Indicates if model categories are currently hidden in the view. (Inherited from View.)
Public property | ArePointCloudsHidden | Indicates if point clouds are currently hidden in the view. (Inherited from View.)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view. (Inherited from View.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CropBox | The Crop Box applied to the view, or an outline encompassing the crop region applied to the view. (Inherited from View.)
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View.)
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DetailLevel | The detail level of this view. (Inherited from View.)
Public property | Discipline | The Discipline of the view. (Inherited from View.)
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style. (Inherited from View.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | GenLevel | The level for the view. (Inherited from View.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsAssemblyView | Indicates if the view is assembly view. (Inherited from View.)
Public property | IsCallout | Indicates if the view is a callout view. (Inherited from View.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsPlaceholder | Identifies whether or not the view sheet represents a placeholder sheet.
Public property | IsTemplate | Test whether the view is a view template. (Inherited from View.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Origin | Returns the origin of the screen. (Inherited from View.)
Public property | Outline | The bounds of the view in paper space (in feet). (Inherited from View.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PartsVisibility | The visibility setting for parts in this view. (Inherited from View.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RevealConstraintsMode | Indicates whether the Reveal Constraints mode is activated in the view. (Inherited from View.)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Public property | Scale | The scale of the view. (Inherited from View.)
Public property | ShadowIntensity | The intesity of cast shadows - 0 = no shadows, 100 = black. (Inherited from View.)
Public property | SheetNumber | The sheet number of the document.
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View.)
Public property | SunlightIntensity | The intensity of the simulated (directional) sunlight. 0 = no directional light; maximum value is 100. (Inherited from View.)
Public property | TemporaryViewModes | Data of temporary view modes associated with this view. (Inherited from View.)
Public property | Title | The view title. This consists of the view name plus other modifiers, such as the view type, sheet number, area scheme, and/or assembly type, depending on the specifics of the view. (Inherited from View.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | ViewTemplateId | The id of the template view that controls this view's parameters. (Inherited from View.)
Public property | ViewType | The type of the view. (Inherited from View.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ViewSheet Class


CanBeDuplicated Method

[image]

Revit 2024 API
ViewSheet..::..CanBeDuplicated Method
ViewSheet Class See Also Send Feedback
Identifies if this sheet can be duplicated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public bool CanBeDuplicated(
    SheetDuplicateOption duplicateOption
)
Visual Basic
Public Function CanBeDuplicated ( _
    duplicateOption As SheetDuplicateOption _
) As Boolean
Visual C++
public:
bool CanBeDuplicated(
    SheetDuplicateOption duplicateOption
)

Parameters

duplicateOption
Type: Autodesk.Revit.DB..::..SheetDuplicateOption
The option to use when duplicating the sheet.

Return Value

True if the sheet can be duplicated, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

ViewSheet Class


Create Method

[image]

Revit 2024 API
ViewSheet..::..Create Method
ViewSheet Class Example See Also Send Feedback
Creates a new ViewSheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public static ViewSheet Create(
    Document document,
    ElementId titleBlockTypeId
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    titleBlockTypeId As ElementId _
) As ViewSheet
Visual C++
public:
static ViewSheet^ Create(
    Document^ document,
    ElementId^ titleBlockTypeId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the ViewSheet will be added.
titleBlockTypeId
Type: Autodesk.Revit.DB..::..ElementId
The type id of the TitleBlock type which will be used by the new ViewSheet. For no TitleBlock, pass invalid element ID.

Return Value

The new ViewSheet.

Examples

CopyC#
private void CreateSheetView(Autodesk.Revit.DB.Document document, View3D view3D)
{

    // Get an available title block from document
    FilteredElementCollector collector = new FilteredElementCollector(document);
    collector.OfClass(typeof(FamilySymbol));
    collector.OfCategory(BuiltInCategory.OST_TitleBlocks);

    FamilySymbol fs = collector.FirstElement() as FamilySymbol;
    if (fs != null)
    {
        using (Transaction t = new Transaction(document, "Create a new ViewSheet"))
        {
            t.Start();
            try
            {
                // Create a sheet view
                ViewSheet viewSheet = ViewSheet.Create(document, fs.Id);
                if (null == viewSheet)
                {
                    throw new Exception("Failed to create new ViewSheet.");
                }

                // Add passed in view onto the center of the sheet
                UV location = new UV((viewSheet.Outline.Max.U - viewSheet.Outline.Min.U) / 2,
                                     (viewSheet.Outline.Max.V - viewSheet.Outline.Min.V) / 2);

                //viewSheet.AddView(view3D, location);
                Viewport.Create(document, viewSheet.Id, view3D.Id, new XYZ(location.U, location.V, 0));

                // Print the sheet out
                if (viewSheet.CanBePrinted)
                {
                    TaskDialog taskDialog = new TaskDialog("Revit");
                    taskDialog.MainContent = "Print the sheet?";
                    TaskDialogCommonButtons buttons = TaskDialogCommonButtons.Yes | TaskDialogCommonButtons.No;
                    taskDialog.CommonButtons = buttons;
                    TaskDialogResult result = taskDialog.Show();

                    if (result == TaskDialogResult.Yes)
                    {
                        viewSheet.Print();
                    }
                }

                t.Commit();
            }
            catch
            {
                t.RollBack();
            }
        }
    }
}
CopyC#
private void CreateSheetView(Autodesk.Revit.DB.Document document, View3D view3D)
{

    // Get an available title block from document
    IEnumerable<FamilySymbol>�familyList =�from�elem�in�new�FilteredElementCollector(document)
                                               .OfClass(typeof(FamilySymbol))
                                               .OfCategory(BuiltInCategory.OST_TitleBlocks)�
                                           let�type = elem�as�FamilySymbol    �
                                           where�type.Name.Contains("E1")�
                                           select�type;

    // Create a sheet view
    ViewSheet viewSheet = ViewSheet.Create(document, familyList.First().Id);
    if (null == viewSheet)
    {
        throw new Exception("Failed to create new ViewSheet.");
    }

    // Add passed in view onto the center of the sheet
    if (Viewport.CanAddViewToSheet(document, viewSheet.Id, view3D.Id))
    {
        BoundingBoxUV sheetBox = viewSheet.Outline;
        double yPosition = (sheetBox.Max.V - sheetBox.Min.V) / 2 + sheetBox.Min.V;
        double xPosition = (sheetBox.Max.U - sheetBox.Min.U) / 2 + sheetBox.Min.U;

        XYZ origin = new XYZ(xPosition, yPosition, 0);
        Viewport viewport = Viewport.Create(document, viewSheet.Id, view3D.Id, origin);
    }

    // Print the sheet out
    if (viewSheet.CanBePrinted)
    {
       TaskDialog taskDialog = new TaskDialog("Revit");
       taskDialog.MainContent = "Print the sheet?";
       TaskDialogCommonButtons buttons = TaskDialogCommonButtons.Yes | TaskDialogCommonButtons.No;
       taskDialog.CommonButtons = buttons;
       TaskDialogResult result = taskDialog.Show();

        if (result == TaskDialogResult.Yes)
        {
            viewSheet.Print();
        }
    }
}
CopyVB.NET
Private Sub CreateSheetView(document As Autodesk.Revit.DB.Document, view3D As View3D)

    ' Get an available title block from document
    Dim collector As New FilteredElementCollector(document)
    collector.OfClass(GetType(FamilySymbol))
    collector.OfCategory(BuiltInCategory.OST_TitleBlocks)

    Dim fs As FamilySymbol = TryCast(collector.FirstElement(), FamilySymbol)
    If fs IsNot Nothing Then
        Using t As New Transaction(document, "Create a new ViewSheet")
            t.Start()
            Try
                ' Create a sheet view
                Dim viewSheet__1 As ViewSheet = ViewSheet.Create(document, fs.Id)
                If viewSheet__1 Is Nothing Then
                    Throw New Exception("Failed to create new ViewSheet.")
                End If

                ' Add passed in view onto the center of the sheet
                Dim location As New UV((viewSheet__1.Outline.Max.U - viewSheet__1.Outline.Min.U) / 2, (viewSheet__1.Outline.Max.V - viewSheet__1.Outline.Min.V) / 2)

                'viewSheet.AddView(view3D, location);
                Viewport.Create(document, viewSheet__1.Id, view3D.Id, New XYZ(location.U, location.V, 0))

                ' Print the sheet out
                If viewSheet__1.CanBePrinted Then
                    Dim taskDialog As New TaskDialog("Revit")
                    taskDialog.MainContent = "Print the sheet?"
                    Dim buttons As TaskDialogCommonButtons = TaskDialogCommonButtons.Yes Or TaskDialogCommonButtons.No
                    taskDialog.CommonButtons = buttons
                    Dim result As TaskDialogResult = taskDialog.Show()

                    If result = TaskDialogResult.Yes Then
                        viewSheet__1.Print()
                    End If
                End If

                t.Commit()
            Catch
                t.RollBack()
            End Try
        End Using
    End If
End Sub
CopyVB.NET
Private Sub CreateSheetView(document As Autodesk.Revit.DB.Document, view3D As View3D)

    ' Get an available title block from document
    Dim collector1 As New FilteredElementCollector(document)
    collector1 = collector1.OfClass(GetType(FamilySymbol)).OfCategory(BuiltInCategory.OST_TitleBlocks)
    Dim familyList As IEnumerable(Of FamilySymbol)

    familyList = From elem In collector1
                 Let fstype = TryCast(elem, FamilySymbol)
                 Where fstype.Name.Contains("E1")
                 Select fstype

    ' Create a sheet view
    Dim viewSheet__1 As ViewSheet = ViewSheet.Create(document, familyList.First().Id)
    If viewSheet__1 Is Nothing Then
        Throw New Exception("Failed to create new ViewSheet.")
    End If

    ' Add passed in view onto the center of the sheet
    If Viewport.CanAddViewToSheet(document, viewSheet__1.Id, view3D.Id) Then
        Dim sheetBox As BoundingBoxUV = viewSheet__1.Outline
        Dim yPosition As Double = (sheetBox.Max.V - sheetBox.Min.V) / 2 + sheetBox.Min.V
        Dim xPosition As Double = (sheetBox.Max.U - sheetBox.Min.U) / 2 + sheetBox.Min.U

        Dim origin As New XYZ(xPosition, yPosition, 0)
        Dim viewport__2 As Viewport = Viewport.Create(document, viewSheet__1.Id, view3D.Id, origin)
    End If

    ' Print the sheet out
    If viewSheet__1.CanBePrinted Then
        Dim taskDialog As New TaskDialog("Revit")
        taskDialog.MainContent = "Print the sheet?"
        Dim buttons As TaskDialogCommonButtons = TaskDialogCommonButtons.Yes Or TaskDialogCommonButtons.No
        taskDialog.CommonButtons = buttons
        Dim result As TaskDialogResult = taskDialog.Show()

        If result = TaskDialogResult.Yes Then
            viewSheet__1.Print()
        End If
    End If
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId titleBlockTypeId does not correspond to a TitleBlock type. -or- document is not a project document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

ViewSheet Class


CreatePlaceholder Method

[image]

Revit 2024 API
ViewSheet..::..CreatePlaceholder Method
ViewSheet Class See Also Send Feedback
Creates a placeholder sheet in a document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public static ViewSheet CreatePlaceholder(
    Document aDoc
)
Visual Basic
Public Shared Function CreatePlaceholder ( _
    aDoc As Document _
) As ViewSheet
Visual C++
public:
static ViewSheet^ CreatePlaceholder(
    Document^ aDoc
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
The document.

Return Value

The placeholder sheet.

Remarks

Placeholder sheets represent sheets stored outside of the Revit model, but which should be organized along with the Revit sheets.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ViewSheet Class


DeleteViewport Method

[image]

Revit 2024 API
ViewSheet..::..DeleteViewport Method
ViewSheet Class See Also Send Feedback
Removes a viewport from the sheet by deleting it from the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void DeleteViewport(
    Viewport viewport
)
Visual Basic
Public Sub DeleteViewport ( _
    viewport As Viewport _
)
Visual C++
public:
void DeleteViewport(
    Viewport^ viewport
)

Parameters

viewport
Type: Autodesk.Revit.DB..::..Viewport
The viewport that will be deleted and removed from the sheet.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ViewSheet Class


Duplicate Method

[image] [image]

Revit 2024 API
ViewSheet..::..Duplicate Method
ViewSheet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Duplicate(SheetDuplicateOption) | Duplicates this sheet to generate a new one.
Public method | Duplicate(ViewDuplicateOption) | Duplicates this view. (Inherited from View.)

See Also

ViewSheet Class
ViewSheet Members


Duplicate Method (SheetDuplicateOption)

[image]

Revit 2024 API
ViewSheet..::..Duplicate Method (SheetDuplicateOption)
ViewSheet Class See Also Send Feedback
Duplicates this sheet to generate a new one.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023

Syntax

C#
public ElementId Duplicate(
    SheetDuplicateOption duplicateOption
)
Visual Basic
Public Function Duplicate ( _
    duplicateOption As SheetDuplicateOption _
) As ElementId
Visual C++
public:
ElementId^ Duplicate(
    SheetDuplicateOption duplicateOption
)

Parameters

duplicateOption
Type: Autodesk.Revit.DB..::..SheetDuplicateOption
The option to use when duplicating the sheet.

Return Value

The id of the newly created sheet.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException | Sheet cannot be duplicated

See Also

ViewSheet Class
Duplicate Overload


GetAdditionalRevisionIds Method

[image]

Revit 2024 API
ViewSheet..::..GetAdditionalRevisionIds Method
ViewSheet Class See Also Send Feedback
Gets the Revisions that are additionally included in the sheet's revision schedules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public ICollection<ElementId> GetAdditionalRevisionIds()
Visual Basic
Public Function GetAdditionalRevisionIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetAdditionalRevisionIds()

Return Value

The additionally included Revisions for the sheet's revision schedules.

Remarks

Revisions in the sheet's additional project revisions set will appear in revisions schedules even if no RevisionCloud belonging to that Revision is visible on the sheet. These ids correspond to the Revisions that are explicitly included on the sheet via the Revisions On Sheet parameter.

See Also

ViewSheet Class


GetAllPlacedViews Method

[image]

Revit 2024 API
ViewSheet..::..GetAllPlacedViews Method
ViewSheet Class See Also Send Feedback
Returns the ElementIds of Views placed on this sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public ISet<ElementId> GetAllPlacedViews()
Visual Basic
Public Function GetAllPlacedViews As ISet(Of ElementId)
Visual C++
public:
ISet<ElementId^>^ GetAllPlacedViews()

Return Value

The ids of the views on this sheet.

Remarks

Schedules on the sheet are not returned by this method. Use ScheduleSheetInstance.OwnerViewId to find the sheet on which a schedule is placed.

See Also

ViewSheet Class


GetAllViewports Method

[image]

Revit 2024 API
ViewSheet..::..GetAllViewports Method
ViewSheet Class See Also Send Feedback
Returns the ElementIds of Viewports on this sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public ICollection<ElementId> GetAllViewports()
Visual Basic
Public Function GetAllViewports As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetAllViewports()

Return Value

The Viewports on this sheet.

Remarks

Schedules on the sheet are not returned by this method. Use ScheduleSheetInstance.OwnerViewId to find the sheet on which a schedule is placed.

See Also

ViewSheet Class


GetCurrentRevision Method

[image]

Revit 2024 API
ViewSheet..::..GetCurrentRevision Method
ViewSheet Class See Also Send Feedback
Returns the most recent numbered Revision shown on this ViewSheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public ElementId GetCurrentRevision()
Visual Basic
Public Function GetCurrentRevision As ElementId
Visual C++
public:
ElementId^ GetCurrentRevision()

Return Value

The Id of the most recent numbered Revision shown on this ViewSheet or InvalidElementId if none are shown.

Remarks

If the most recent Revision is not issued, Revit will typically use it as the default Revision for RevisionClouds placed on this ViewSheet. InvalidElementId will be returned if no Revisions are present. Revisions with RevisionNumberType.None will not be returned.

See Also

ViewSheet Class


GetRevisionCloudNumberOnSheet Method

[image]

Revit 2024 API
ViewSheet..::..GetRevisionCloudNumberOnSheet Method
ViewSheet Class See Also Send Feedback
Gets the Revision Number for a RevisionCloud on this sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public string GetRevisionCloudNumberOnSheet(
    ElementId revisionCloudId
)
Visual Basic
Public Function GetRevisionCloudNumberOnSheet ( _
    revisionCloudId As ElementId _
) As String
Visual C++
public:
String^ GetRevisionCloudNumberOnSheet(
    ElementId^ revisionCloudId
)

Parameters

revisionCloudId
Type: Autodesk.Revit.DB..::..ElementId
The id of the RevisionCLoud.

Return Value

Returns the Revision Number as it will appear on this sheet or nullNothingnullptra null reference (Nothing in Visual Basic) if there is no Revision Number assigned on this sheet.

Remarks

Returns nullNothingnullptra null reference (Nothing in Visual Basic) if the RevisionCloud or its associated Revision do not appear on this sheet. The Revision Number for a RevisionCloud will always be the same as the Revision Number of the associated Revision.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | revisionCloudId is not the Id of a RevisionCloud.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ViewSheet Class


Print Method

[image] [image]

Revit 2024 API
ViewSheet..::..Print Method
ViewSheet Class See Also Send Feedback
Print this view.

Overload List

 | Name | Description
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)

See Also

ViewSheet Class
ViewSheet Members


SetAdditionalRevisionIds Method

[image]

Revit 2024 API
ViewSheet..::..SetAdditionalRevisionIds Method
ViewSheet Class Example See Also Send Feedback
Sets the Revisions to additionally include in the sheet's revision schedules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public void SetAdditionalRevisionIds(
    ICollection<ElementId> projectRevisionIds
)
Visual Basic
Public Sub SetAdditionalRevisionIds ( _
    projectRevisionIds As ICollection(Of ElementId) _
)
Visual C++
public:
void SetAdditionalRevisionIds(
    ICollection<ElementId^>^ projectRevisionIds
)

Parameters

projectRevisionIds
Type: System.Collections.Generic..::..ICollection<(Of <(<' ElementId >)>)>
The ids of Revisions to explicitly include in the sheet's revision schedules.

Remarks

Additionally included Revisions will always participate in the sheet's revision schedules. Normally a Revision is scheduled in the revision schedule because one of its associated RevisionClouds is present on the sheet.

The additional project revision ids setting corresponds to the sheet's Revisions On Sheet parameter.

Examples

CopyC#
public static void AddAdditionalRevisionsToSheet(ViewSheet viewSheet, String toMatch)
{
    Document doc = viewSheet.Document;

    ICollection<ElementId> revisions = viewSheet.GetAdditionalRevisionIds();

    // Find revisions whose description matches input string
    FilteredElementCollector collector = new FilteredElementCollector(doc);
    collector.OfCategory(BuiltInCategory.OST_Revisions);
    collector.WhereElementIsNotElementType();
    if (revisions.Count > 0)
        collector.Excluding(revisions);

    // Check if revision should be added
    foreach (Element revision in collector)
    {
        Parameter descriptionParam = revision.get_Parameter(BuiltInParameter.PROJECT_REVISION_REVISION_DESCRIPTION);
        String description = descriptionParam.AsString();
        if (description.Contains(toMatch))
            revisions.Add(revision.Id);
    }

    if (revisions.Count > 0)
    {
        // Apply the new list of revisions
        using (Transaction t = new Transaction(doc, "Add revisions to sheet"))
        {
            t.Start();
            viewSheet.SetAdditionalRevisionIds(revisions);
            t.Commit();
        }
    }
}
CopyVB.NET
Public Shared Sub AddAdditionalRevisionsToSheet(viewSheet As ViewSheet, toMatch As [String])
    Dim doc As Document = viewSheet.Document

    Dim revisions As ICollection(Of ElementId) = viewSheet.GetAdditionalRevisionIds()

    ' Find revisions whose description matches input string
    Dim collector As New FilteredElementCollector(doc)
    collector.OfCategory(BuiltInCategory.OST_Revisions)
    collector.WhereElementIsNotElementType()
    If revisions.Count > 0 Then
        collector.Excluding(revisions)
    End If

    ' Check if revision should be added
    For Each revision As Element In collector
        Dim descriptionParam As Parameter = revision.Parameter(BuiltInParameter.PROJECT_REVISION_REVISION_DESCRIPTION)
        Dim description As [String] = descriptionParam.AsString()
        If description.Contains(toMatch) Then
            revisions.Add(revision.Id)
        End If
    Next

    If revisions.Count > 0 Then
        ' Apply the new list of revisions
        Using t As New Transaction(doc, "Add revisions to sheet")
            t.Start()
            viewSheet.SetAdditionalRevisionIds(revisions)
            t.Commit()
        End Using
    End If
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | One or more ElementIds in projectRevisionIds do not correspond to a Revision element.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

ViewSheet Class


IsPlaceholder Property

[image]

Revit 2024 API
ViewSheet..::..IsPlaceholder Property
ViewSheet Class See Also Send Feedback
Identifies whether or not the view sheet represents a placeholder sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public bool IsPlaceholder { get; }
Visual Basic
Public ReadOnly Property IsPlaceholder As Boolean
    Get
Visual C++
public:
property bool IsPlaceholder {
    bool get ();
}

See Also

ViewSheet Class


SheetNumber Property

[image]

Revit 2024 API
ViewSheet..::..SheetNumber Property
ViewSheet Class See Also Send Feedback
The sheet number of the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string SheetNumber { get; set; }
Visual Basic
Public Property SheetNumber As String
    Get
    Set
Visual C++
public:
property String^ SheetNumber {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: sheetNumber is an empty string or contains only whitespace. -or- When setting this property: sheetNumber cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- When setting this property: Sheet number is already in use.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null

See Also

ViewSheet Class


ViewSheetSet Class

[image]

Revit 2024 API
ViewSheetSet Class
Members See Also Send Feedback
Represents ViewSheetSets stored in a document. ViewSheetSets can be stored so that the same printing task can be executed multiple times.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class ViewSheetSet : Element,
    IViewSheetSet
Visual Basic
Public Class ViewSheetSet _
    Inherits Element _
    Implements IViewSheetSet
Visual C++
public ref class ViewSheetSet : public Element,
    IViewSheetSet

Remarks

For the in-session ViewSheetSet, see the class InSessionViewSheetSet. Changes of ViewSheetSet would be effiective after [!:Autodesk::Revit::DB::ViewSheetSetting::Save]

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ViewSheetSet

See Also

ViewSheetSet Members


ViewSheetSet Members

[image] [image]

Revit 2024 API
ViewSheetSet Members
ViewSheetSet Class Methods Properties See Also Send Feedback

The ViewSheetSet type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element.)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element.)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element.)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element.)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element.)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element.)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element.)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element.)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element.)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element.)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element.)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element.)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element.)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element.)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsAutomatic | Automatic order or manual order.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | The view sheet set name. (Overrides Element..::..Name.)
Public property | OrderedViewList | Ordered views.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SheetOrganizationId | ElementId to the BrowserOrganization for sheets.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewOrganizationId | ElementId to the BrowserOrganization for non-sheet views.
Public property | Views | The views.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ViewSheetSet Class


ViewSheetSet Properties

[image] [image]

Revit 2024 API
ViewSheetSet Properties
ViewSheetSet Class See Also Send Feedback

The ViewSheetSet type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsAutomatic | Automatic order or manual order.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | The view sheet set name. (Overrides Element..::..Name.)
Public property | OrderedViewList | Ordered views.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SheetOrganizationId | ElementId to the BrowserOrganization for sheets.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewOrganizationId | ElementId to the BrowserOrganization for non-sheet views.
Public property | Views | The views.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ViewSheetSet Class


IsAutomatic Property

[image]

Revit 2024 API
ViewSheetSet..::..IsAutomatic Property
ViewSheetSet Class See Also Send Feedback
Automatic order or manual order.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual bool IsAutomatic { get; set; }
Visual Basic
Public Overridable Property IsAutomatic As Boolean
    Get
    Set
Visual C++
public:
virtual property bool IsAutomatic {
    bool get ();
    void set (bool value);
}

Implements

IViewSheetSet..::..IsAutomatic

See Also

ViewSheetSet Class


Name Property

[image]

Revit 2024 API
ViewSheetSet..::..Name Property
ViewSheetSet Class See Also Send Feedback
The view sheet set name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public override string Name { get; set; }
Visual Basic
Public Overrides Property Name As String
    Get
    Set
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when trying to set the name. Instead, set the name with the Rename(String) method.

See Also

ViewSheetSet Class


OrderedViewList Property

[image]

Revit 2024 API
ViewSheetSet..::..OrderedViewList Property
ViewSheetSet Class See Also Send Feedback
Ordered views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual IReadOnlyList<View> OrderedViewList { get; set; }
Visual Basic
Public Overridable Property OrderedViewList As IReadOnlyList(Of View)
    Get
    Set
Visual C++
public:
virtual property IReadOnlyList<View^>^ OrderedViewList {
    IReadOnlyList<View^>^ get ();
    void set (IReadOnlyList<View^>^ value);
}

Implements

IViewSheetSet..::..OrderedViewList

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input ordered view list is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the set operation failed due to invalid view which cannot be printed.

See Also

ViewSheetSet Class


Parameter Property

[image] [image]

Revit 2024 API
ViewSheetSet..::..Parameter Property
ViewSheetSet Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ViewSheetSet Class
ViewSheetSet Members


SheetOrganizationId Property

[image]

Revit 2024 API
ViewSheetSet..::..SheetOrganizationId Property
ViewSheetSet Class See Also Send Feedback
ElementId to the BrowserOrganization for sheets.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual ElementId SheetOrganizationId { get; set; }
Visual Basic
Public Overridable Property SheetOrganizationId As ElementId
    Get
    Set
Visual C++
public:
virtual property ElementId^ SheetOrganizationId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Implements

IViewSheetSet..::..SheetOrganizationId

Remarks

Ignored when [!:Autodesk::Revit::DB::PrintSetup::IsAutomatic] is falseFalsefalsefalse (False in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the ElementId does not reference to BrowserOrganization, or the target type of BrowserOrganization is incompatible.

See Also

ViewSheetSet Class


Views Property

[image]

Revit 2024 API
ViewSheetSet..::..Views Property
ViewSheetSet Class See Also Send Feedback
The views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual ViewSet Views { get; set; }
Visual Basic
Public Overridable Property Views As ViewSet
    Get
    Set
Visual C++
public:
virtual property ViewSet^ Views {
    ViewSet^ get ();
    void set (ViewSet^ value);
}

Implements

IViewSheetSet..::..Views

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input views is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the set operation failed due to invalid view which cannot be printed.

See Also

ViewSheetSet Class


ViewSheetSetting Members

[image] [image]

Revit 2024 API
ViewSheetSetting Members
ViewSheetSetting Class Methods Properties See Also Send Feedback

The ViewSheetSetting type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Delete the current view sheet set, and make the In-Session set as the current one.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Rename | Rename the current view sheet set.
Public method | Revert | Revert the current view sheet set.
Public method | Save | Save the changes for the current view sheet set.
Public method | SaveAs | Save the current view sheet set to another view sheet set with the specified name.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AvailableViews | All views that can be printed.
Public property | CurrentViewSheetSet | The current view sheet set of PrintSetup.
Public property | InSession | The in-session view sheet set of Print Setup.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ViewSheetSetting Class


ViewSheetSetting Methods

[image] [image]

Revit 2024 API
ViewSheetSetting Methods
ViewSheetSetting Class See Also Send Feedback

The ViewSheetSetting type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Delete the current view sheet set, and make the In-Session set as the current one.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Rename | Rename the current view sheet set.
Public method | Revert | Revert the current view sheet set.
Public method | Save | Save the changes for the current view sheet set.
Public method | SaveAs | Save the current view sheet set to another view sheet set with the specified name.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ViewSheetSetting Class


Delete Method

[image]

Revit 2024 API
ViewSheetSetting..::..Delete Method
ViewSheetSetting Class See Also Send Feedback
Delete the current view sheet set, and make the In-Session set as the current one.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool Delete()
Visual Basic
Public Function Delete As Boolean
Visual C++
public:
bool Delete()

Return Value

False if Delete operation fails, otherwise True.

Remarks

If the current view sheet set is In-Session, an InvalidOperationException will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the current view sheet set is In-Session.

See Also

ViewSheetSetting Class


Rename Method

[image]

Revit 2024 API
ViewSheetSetting..::..Rename Method
ViewSheetSetting Class See Also Send Feedback
Rename the current view sheet set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool Rename(
    string newName
)
Visual Basic
Public Function Rename ( _
    newName As String _
) As Boolean
Visual C++
public:
bool Rename(
    String^ newName
)

Parameters

newName
Type: System..::..String
View sheet set name to be renamed as.

Return Value

False if Rename operation fails, otherwise True.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the input name is already existed in current view sheet set list.

See Also

ViewSheetSetting Class


Revert Method

[image]

Revit 2024 API
ViewSheetSetting..::..Revert Method
ViewSheetSetting Class See Also Send Feedback
Revert the current view sheet set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Revert()
Visual Basic
Public Sub Revert
Visual C++
public:
void Revert()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the current view sheet set is In-Session.

See Also

ViewSheetSetting Class


Save Method

[image]

Revit 2024 API
ViewSheetSetting..::..Save Method
ViewSheetSetting Class See Also Send Feedback
Save the changes for the current view sheet set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool Save()
Visual Basic
Public Function Save As Boolean
Visual C++
public:
bool Save()

Return Value

False if save operation fails, otherwise True.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the current view sheet set is In-Session or the current view sheet set is unchanged.

See Also

ViewSheetSetting Class


SaveAs Method

[image]

Revit 2024 API
ViewSheetSetting..::..SaveAs Method
ViewSheetSetting Class See Also Send Feedback
Save the current view sheet set to another view sheet set with the specified name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool SaveAs(
    string newName
)
Visual Basic
Public Function SaveAs ( _
    newName As String _
) As Boolean
Visual C++
public:
bool SaveAs(
    String^ newName
)

Parameters

newName
Type: System..::..String
View sheet set name to be saved as.

Return Value

False if Save As operation fails, otherwise True.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the input name is already existed in current view sheet set list.

See Also

ViewSheetSetting Class


ViewSheetSetting Properties

[image] [image]

Revit 2024 API
ViewSheetSetting Properties
ViewSheetSetting Class See Also Send Feedback

The ViewSheetSetting type exposes the following members.

Properties

 | Name | Description
Public property | AvailableViews | All views that can be printed.
Public property | CurrentViewSheetSet | The current view sheet set of PrintSetup.
Public property | InSession | The in-session view sheet set of Print Setup.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ViewSheetSetting Class


AvailableViews Property

[image]

Revit 2024 API
ViewSheetSetting..::..AvailableViews Property
ViewSheetSetting Class See Also Send Feedback
All views that can be printed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ViewSet AvailableViews { get; }
Visual Basic
Public ReadOnly Property AvailableViews As ViewSet
    Get
Visual C++
public:
property ViewSet^ AvailableViews {
    ViewSet^ get ();
}

Remarks

Users can select the view/sheet from this view set to printing.

See Also

ViewSheetSetting Class


InSession Property

[image]

Revit 2024 API
ViewSheetSetting..::..InSession Property
ViewSheetSetting Class See Also Send Feedback
The in-session view sheet set of Print Setup.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public InSessionViewSheetSet InSession { get; }
Visual Basic
Public ReadOnly Property InSession As InSessionViewSheetSet
    Get
Visual C++
public:
property InSessionViewSheetSet^ InSession {
    InSessionViewSheetSet^ get ();
}

See Also

ViewSheetSetting Class


ViewType Enumeration

[image]

Revit 2024 API
ViewType Enumeration
See Also Send Feedback
An enumerated type listing available view types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum ViewType
Visual Basic
Public Enumeration ViewType
Visual C++
public enum class ViewType

Members

Member name | Description
Undefined | Undefined/unspecified type of view.
FloorPlan | Floor plan type of view.
CeilingPlan | Reflected ceiling plan type of view.
Elevation | Elevation type of view.
ThreeD | 3-D type of view.
Schedule | Schedule type of view.
DrawingSheet | Drawing sheet type of view.
ProjectBrowser | The project browser view.
Report | Report type of view.
DraftingView | Drafting type of view.
Legend | Legend type of view.
SystemBrowser | The MEP system browser view.
EngineeringPlan | Structural plan or Engineering plan type of view.
AreaPlan | Area plan type of view.
Section | Cross section type of view.
Detail | Detail type of view.
CostReport | Cost Report view.
LoadsReport | Loads Report view.
PresureLossReport | Pressure Loss Report view.
ColumnSchedule | Column Schedule type of view.
PanelSchedule | Panel Schedule Report view.
Walkthrough | Walk-Through type of 3D view.
Rendering | Rendering type of view.
SystemsAnalysisReport | Systems analysis report view.
Internal | Revit's internal type of view

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


VirtualPrinterType Enumeration

[image]

Revit 2024 API
VirtualPrinterType Enumeration
See Also Send Feedback
An enumerated to list Virtual Printer Types in Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum VirtualPrinterType
Visual Basic
Public Enumeration VirtualPrinterType
Visual C++
public enum class VirtualPrinterType

Members

Member name | Description
None | None.
AdobePDF | AdobePDF.
DWFWriter | DWFWriter.
XPSWriter | Microsoft XPS Document Writer.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


Visibility Enumeration

[image]

Revit 2024 API
Visibility Enumeration
See Also Send Feedback
Describes the visibility of a particular geometry object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public enum Visibility
Visual Basic
Public Enumeration Visibility
Visual C++
public enum class Visibility

Members

Member name | Description
Visible | The geometry object is always visible. This type of geometry is always returned by Geometry[([( Options])])
Highlight | The geometry object is visible, but is affected by highlight or prehighlight special coloration. This type of geometry is returned by Geometry[([( Options])]) if IncludeNonVisibleObjects is true.
Contextual | The geometry object is visible in some contexts, but not in others. This type of geometry is always returned by Geometry[([( Options])]) , even when Revit is in a context where the geometry should not be visible, but only if IncludeNonVisibleObjects is true. Examples of geometry of this class include Solids representing insulation and lining for MEP ducts and pipes.
Invisible | The geometry object is never visible. This type of geometry is never returned by Geometry[([( Options])]) but may be obtained by other API operations.

See Also

Autodesk.Revit.DB Namespace

Send comments on this topic to Autodesk


VisibleInViewFilter Class

[image]

Revit 2024 API
VisibleInViewFilter Class
Members See Also Send Feedback
A quick filter that passes elements that are most likely visible in the given view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public class VisibleInViewFilter : ElementQuickFilter
Visual Basic
Public Class VisibleInViewFilter _
    Inherits ElementQuickFilter
Visual C++
public ref class VisibleInViewFilter : public ElementQuickFilter

Remarks

This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory. In some situations (for example, when the element geometry is not yet calculated for the input view) this filter may return true even though the element may not actually be visible when geometry is calculated.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementQuickFilter
Autodesk.Revit.DB..::..VisibleInViewFilter

See Also

VisibleInViewFilter Members


VisibleInViewFilter Members

[image] [image]

Revit 2024 API
VisibleInViewFilter Members
VisibleInViewFilter Class Constructors Methods Properties See Also Send Feedback

The VisibleInViewFilter type exposes the following members.

Constructors

 | Name | Description
Public method | VisibleInViewFilter(Document, ElementId) | Constructs a new instance of a VisibleInViewFilter.
Public method | VisibleInViewFilter(Document, ElementId, Boolean) | Constructs a new instance of a VisibleInViewFilter, with the option to pass all non-visible elements.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)

See Also

VisibleInViewFilter Class


VisibleInViewFilter Constructor (Document, ElementId, Boolean)

[image]

Revit 2024 API
VisibleInViewFilter Constructor (Document, ElementId, Boolean)
VisibleInViewFilter Class See Also Send Feedback
Constructs a new instance of a VisibleInViewFilter, with the option to pass all non-visible elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021

Syntax

C#
public VisibleInViewFilter(
    Document document,
    ElementId viewId,
    bool inverted
)
Visual Basic
Public Sub New ( _
    document As Document, _
    viewId As ElementId, _
    inverted As Boolean _
)
Visual C++
public:
VisibleInViewFilter(
    Document^ document,
    ElementId^ viewId,
    bool inverted
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document that owns the view.
viewId
Type: Autodesk.Revit.DB..::..ElementId
The view id.
inverted
Type: System..::..Boolean
True if the filter should match all elements not visible in the given view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | viewId is not a view. -or- viewId is not valid for element iteration, because it has no way of representing drawn elements. Many view templates will fail this check.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null

See Also

VisibleInViewFilter Class
VisibleInViewFilter Overload


VisibleInViewFilter Methods

[image] [image]

Revit 2024 API
VisibleInViewFilter Methods
VisibleInViewFilter Class See Also Send Feedback

The VisibleInViewFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

VisibleInViewFilter Class


PassesFilter Method

[image] [image]

Revit 2024 API
VisibleInViewFilter..::..PassesFilter Method
VisibleInViewFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

VisibleInViewFilter Class
VisibleInViewFilter Members


VisibleInViewFilter Properties

[image] [image]

Revit 2024 API
VisibleInViewFilter Properties
VisibleInViewFilter Class See Also Send Feedback

The VisibleInViewFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter.)

See Also

VisibleInViewFilter Class


Wall Class

[image]

Revit 2024 API
Wall Class
Members Example See Also Send Feedback
Represents a wall in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class Wall : HostObject
Visual Basic
Public Class Wall _
    Inherits HostObject
Visual C++
public ref class Wall : public HostObject

Remarks

The wall object represents all the different kinds of walls in Revit.

Examples

CopyC#
public void GetInfo_Wall(Wall wall)
{
    string message = "Wall : ";

    wall.Flip();
    message += "\nIf wall Flipped : " + wall.Flipped;
    // Get curve start point
    message += "\nWall orientation point is :(" + wall.Orientation.X + ", "
        + wall.Orientation.Y + ", " + wall.Orientation.Z + ")";
    // Get wall StructuralUsage
    message += "\nWall StructuralUsage is : " + wall.StructuralUsage;
    // Get wall type name
    message += "\nWall type name is : " + wall.WallType.Name;
    // Get wall width
    message += "\nWall width is : " + wall.Width;

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetInfo_Wall(wall As Wall)
 Dim message As String = "Wall : "
 wall.Flip()
    message += vbLf & "If wall Flipped : " & Convert.ToString(wall.Flipped)
    ' Get curve start point
    message += vbLf & "Wall orientation point is :(" & Convert.ToString(wall.Orientation.X) & ", " & Convert.ToString(wall.Orientation.Y) & ", " & Convert.ToString(wall.Orientation.Z) & ")"
    ' Get wall StructuralUsage
    message += vbLf & "Wall StructuralUsage is : " & Convert.ToString(wall.StructuralUsage)
    ' Get wall type name
    message += vbLf & "Wall type name is : " & Convert.ToString(wall.WallType.Name)
    ' Get wall width
    message += vbLf & "Wall width is : " & Convert.ToString(wall.Width)

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB..::..Wall

See Also

Wall Members


CanHaveProfileSketch Method

[image]

Revit 2024 API
Wall..::..CanHaveProfileSketch Method
Wall Class See Also Send Feedback
Checks whether this wall has or can have a profile sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public bool CanHaveProfileSketch()
Visual Basic
Public Function CanHaveProfileSketch As Boolean
Visual C++
public:
bool CanHaveProfileSketch()

Return Value

True if wall supports profile sketch, false otherwise.

Remarks

Wall does not support profile if it is not a straight wall; or wall is tapered; or it is an old curtain wall; or it is an infill wall; or it is a replacement curtain panel.

See Also

Wall Class


Create Method

[image] [image]

Revit 2024 API
Wall..::..Create Method
Wall Class See Also Send Feedback

Overload List

Name | Description
Create(Document, IList<(Of <<'(Curve>)>>), Boolean) | Creates a non rectangular profile wall within the project using the default wall type.
Create(Document, Curve, ElementId, Boolean) | Creates a new rectangular profile wall within the project using the default wall style.
Create(Document, IList<(Of <<'(Curve>)>>), ElementId, ElementId, Boolean) | Creates a non rectangular profile wall within the project using the specified wall type.
Create(Document, IList<(Of <<'(Curve>)>>), ElementId, ElementId, Boolean, XYZ) | Creates a non rectangular profile wall within the project using the specified wall type and normal vector.
Create(Document, Curve, ElementId, ElementId, Double, Double, Boolean, Boolean) | Creates a new rectangular profile wall within the project using the specified wall type, height, and offset.

See Also

Wall Class
Wall Members


Create Method (Document, Curve, ElementId, Boolean)

[image]

Revit 2024 API
Wall..::..Create Method (Document, Curve, ElementId, Boolean)
Wall Class Example See Also Send Feedback
Creates a new rectangular profile wall within the project using the default wall style.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static Wall Create(
    Document document,
    Curve curve,
    ElementId levelId,
    bool structural
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    curve As Curve, _
    levelId As ElementId, _
    structural As Boolean _
) As Wall
Visual C++
public:
static Wall^ Create(
    Document^ document,
    Curve^ curve,
    ElementId^ levelId,
    bool structural
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which the new wall is created.
curve
Type: Autodesk.Revit.DB..::..Curve
A curve representing the base line of the wall.
levelId
Type: Autodesk.Revit.DB..::..ElementId
Id of the level on which the wall is to be placed.
structural
Type: System..::..Boolean
If set, specifies that the wall is structural in nature.

Return Value

If successful a new wall object within the project.

Examples

CopyC#
public Wall CreateWallUsingCurve1(Autodesk.Revit.DB.Document document, Level level)
{
    // Build a location line for the wall creation
    XYZ start = new XYZ(0, 0, 0);
    XYZ end = new XYZ(10, 10, 0);
    Line geomLine = Line.CreateBound(start, end);

    // Create a wall using the location line
    return Wall.Create(document, geomLine, level.Id, true);
}
CopyVB.NET
Public Function CreateWallUsingCurve1(document As Autodesk.Revit.DB.Document, level As Level) As Wall
    ' Build a location line for the wall creation
    Dim start As New XYZ(0, 0, 0)
    Dim [end] As New XYZ(10, 10, 0)
    Dim geomLine As Line = Line.CreateBound(start, [end])

    ' Create a wall using the location line
    Return Wall.Create(document, geomLine, level.Id, True)
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The curve argument is not valid for wall creation.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

Wall Class
Create Overload


Create Method (Document, IList(Curve), ElementId, ElementId, Boolean)

[image]

Revit 2024 API
Wall..::..Create Method (Document, IList<(Of <(<'Curve>)>)>, ElementId, ElementId, Boolean)
Wall Class See Also Send Feedback
Creates a non rectangular profile wall within the project using the specified wall type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static Wall Create(
    Document document,
    IList<Curve> profile,
    ElementId wallTypeId,
    ElementId levelId,
    bool structural
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    profile As IList(Of Curve), _
    wallTypeId As ElementId, _
    levelId As ElementId, _
    structural As Boolean _
) As Wall
Visual C++
public:
static Wall^ Create(
    Document^ document,
    IList<Curve^>^ profile,
    ElementId^ wallTypeId,
    ElementId^ levelId,
    bool structural
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which the new wall is created.
profile
Type: System.Collections.Generic..::..IList<(Of <(<' Curve >)>)>
An array of planar curves that represent the vertical profile of the wall.
wallTypeId
Type: Autodesk.Revit.DB..::..ElementId
Id of the wall type to be used by the new wall instead of the default type.
levelId
Type: Autodesk.Revit.DB..::..ElementId
Id of the level on which the wall is to be placed.
structural
Type: System..::..Boolean
If set, specifies that the wall is structural in nature.

Return Value

If successful a new wall object within the project.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input profile contains at least one helical curve and is not supported for this operation.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | Failed to create the wall.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

Wall Class
Create Overload


Create Method (Document, IList(Curve), ElementId, ElementId, Boolean, XYZ)

[image]

Revit 2024 API
Wall..::..Create Method (Document, IList<(Of <(<'Curve>)>)>, ElementId, ElementId, Boolean, XYZ)
Wall Class Example See Also Send Feedback
Creates a non rectangular profile wall within the project using the specified wall type and normal vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static Wall Create(
    Document document,
    IList<Curve> profile,
    ElementId wallTypeId,
    ElementId levelId,
    bool structural,
    XYZ normal
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    profile As IList(Of Curve), _
    wallTypeId As ElementId, _
    levelId As ElementId, _
    structural As Boolean, _
    normal As XYZ _
) As Wall
Visual C++
public:
static Wall^ Create(
    Document^ document,
    IList<Curve^>^ profile,
    ElementId^ wallTypeId,
    ElementId^ levelId,
    bool structural,
    XYZ^ normal
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which the new wall is created.
profile
Type: System.Collections.Generic..::..IList<(Of <(<' Curve >)>)>
An array of planar curves that represent the vertical profile of the wall.
wallTypeId
Type: Autodesk.Revit.DB..::..ElementId
Id of the wall type to be used by the new wall instead of the default type.
levelId
Type: Autodesk.Revit.DB..::..ElementId
Id of the level on which the wall is to be placed.
structural
Type: System..::..Boolean
If set, specifies that the wall is structural in nature.
normal
Type: Autodesk.Revit.DB..::..XYZ
A vector that must be perpendicular to the profile which dictates which side of the wall is considered to be inside and outside.

Return Value

If successful a new wall object within the project.

Examples

CopyC#
public Wall CreateWallUsingProfile(Autodesk.Revit.DB.Document document, Level level, WallType wallType)
{
    // Build a wall profile for the wall creation
    XYZ first = new XYZ(0, 0, 0);
    XYZ second = new XYZ(20, 0, 0);
    XYZ third = new XYZ(20, 0, 15);
    XYZ fourth = new XYZ(0, 0, 15);
    IList<Curve> profile = new List<Curve>();

    // Get application creation object
    Autodesk.Revit.Creation.Application appCreation = document.Application.Create;

    profile.Add(Line.CreateBound(first, second));
    profile.Add(Line.CreateBound(second, third));
    profile.Add(Line.CreateBound(third, fourth));
    profile.Add(Line.CreateBound(fourth, first));

    XYZ normal = new XYZ(0, 1, 0);

    // Create a wall
    return Wall.Create(document, profile, wallType.Id, level.Id, true, normal);
}
CopyVB.NET
Public Function CreateWallUsingProfile(document As Autodesk.Revit.DB.Document, level As Level, wallType As WallType) As Wall
    ' Build a wall profile for the wall creation
    Dim first As New XYZ(0, 0, 0)
    Dim second As New XYZ(20, 0, 0)
    Dim third As New XYZ(20, 0, 15)
    Dim fourth As New XYZ(0, 0, 15)
    Dim profile As IList(Of Curve) = New List(Of Curve)()

    ' Get application creation object
    Dim appCreation As Autodesk.Revit.Creation.Application = document.Application.Create

    profile.Add(Line.CreateBound(first, second))
    profile.Add(Line.CreateBound(second, third))
    profile.Add(Line.CreateBound(third, fourth))
    profile.Add(Line.CreateBound(fourth, first))

    Dim normal As New XYZ(0, 1, 0)

    ' Create a wall
    Return Wall.Create(document, profile, wallType.Id, level.Id, True, normal)
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input profile contains at least one helical curve and is not supported for this operation.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..InvalidOperationException | Failed to create the wall.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

Wall Class
Create Overload


Create Method (Document, Curve, ElementId, ElementId, Double, Double, Boolean, Boolean)

[image]

Revit 2024 API
Wall..::..Create Method (Document, Curve, ElementId, ElementId, Double, Double, Boolean, Boolean)
Wall Class Example See Also Send Feedback
Creates a new rectangular profile wall within the project using the specified wall type, height, and offset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static Wall Create(
    Document document,
    Curve curve,
    ElementId wallTypeId,
    ElementId levelId,
    double height,
    double offset,
    bool flip,
    bool structural
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    curve As Curve, _
    wallTypeId As ElementId, _
    levelId As ElementId, _
    height As Double, _
    offset As Double, _
    flip As Boolean, _
    structural As Boolean _
) As Wall
Visual C++
public:
static Wall^ Create(
    Document^ document,
    Curve^ curve,
    ElementId^ wallTypeId,
    ElementId^ levelId,
    double height,
    double offset,
    bool flip,
    bool structural
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which the new wall is created.
curve
Type: Autodesk.Revit.DB..::..Curve
A curve representing the base line of the wall.
wallTypeId
Type: Autodesk.Revit.DB..::..ElementId
Id of the wall type to be used by the new wall instead of the default type.
levelId
Type: Autodesk.Revit.DB..::..ElementId
Id of the level on which the wall is to be placed.
height
Type: System..::..Double
The height of the wall other than the default height.
offset
Type: System..::..Double
Modifies the wall's Base Offset parameter to determine its vertical placement.
flip
Type: System..::..Boolean
Change which side of the wall is considered to be the inside and outside of the wall.
structural
Type: System..::..Boolean
If set, specifies that the wall is structural in nature.

Return Value

If successful a new wall object within the project.

Examples

CopyC#
public Wall CreateWallUsingCurve2(Autodesk.Revit.DB.Document document, Level level, WallType wallType)
{
    // Build a location line for the wall creation
    XYZ start = new XYZ(0, 0, 0);
    XYZ end = new XYZ(10, 10, 0);
    Line geomLine = Line.CreateBound(start, end);

    // Determine the other parameters
    double height = 15;
    double offset = 3;

    // Create a wall using the location line and wall type
    return Wall.Create(document, geomLine, wallType.Id, level.Id, height, offset, true, true);
}
CopyVB.NET
Public Function CreateWallUsingCurve2(document As Autodesk.Revit.DB.Document, level As Level, wallType As WallType) As Wall
    ' Build a location line for the wall creation
    Dim start As New XYZ(0, 0, 0)
    Dim [end] As New XYZ(10, 10, 0)
    Dim geomLine As Line = Line.CreateBound(start, [end])

    ' Determine the other parameters
    Dim height As Double = 15
    Dim offset As Double = 3

    ' Create a wall using the location line and wall type
    Return Wall.Create(document, geomLine, wallType.Id, level.Id, height, offset, _
        True, True)
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The curve argument is not valid for wall creation.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given value for height must be greater than 0 and no more than 30000 feet. -or- The given value for offset must be no more than 30000 feet in absolute value.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

Wall Class
Create Overload


Flip Method

[image]

Revit 2024 API
Wall..::..Flip Method
Wall Class See Also Send Feedback
The wall orientation will be flipped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Flip()
Visual Basic
Public Sub Flip
Visual C++
public:
void Flip()

See Also

Wall Class


GetStackedWallMemberIds Method

[image]

Revit 2024 API
Wall..::..GetStackedWallMemberIds Method
Wall Class See Also Send Feedback
Get the sub walls which belongs to the wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public IList<ElementId> GetStackedWallMemberIds()
Visual Basic
Public Function GetStackedWallMemberIds As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetStackedWallMemberIds()

Return Value

If the wall is a stacked wall, the Ids of the sub will be returned in bottom-top order.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This wall isn't a consistent stacked wall.

See Also

Wall Class


IsWallCrossSectionValid Method

[image]

Revit 2024 API
Wall..::..IsWallCrossSectionValid Method
Wall Class See Also Send Feedback
Checks whether the desired cross section is valid for the current wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public bool IsWallCrossSectionValid(
    WallCrossSection wallCrossSection
)
Visual Basic
Public Function IsWallCrossSectionValid ( _
    wallCrossSection As WallCrossSection _
) As Boolean
Visual C++
public:
bool IsWallCrossSectionValid(
    WallCrossSection wallCrossSection
)

Parameters

wallCrossSection
Type: Autodesk.Revit.DB..::..WallCrossSection
The desired cross section.

Return Value

True if the wall can be set to the desired cross section.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration

See Also

Wall Class


RemoveProfileSketch Method

[image]

Revit 2024 API
Wall..::..RemoveProfileSketch Method
Wall Class See Also Send Feedback
Reverts an edited wall to its original shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public void RemoveProfileSketch()
Visual Basic
Public Sub RemoveProfileSketch
Visual C++
public:
void RemoveProfileSketch()

Remarks

The wall profile is changed back to its original rectangular profile. All profile changes made in the sketch mode are discarded. To check if wall sketch can be removed call SketchId.

See Also

Wall Class


Wall Properties

[image] [image]

Revit 2024 API
Wall Properties
Wall Class See Also Send Feedback

The Wall type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CrossSection | Obtain the Wall Cross-section for this wall.
Public property | CurtainGrid | Get the grid object of a curtain wall
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Flipped | Property to test whether the wall orientation is flipped.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element.)
Public property | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element.)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element.)
Public property | IsStackedWall | Identifies if the wall is a stacked wall.
Public property | IsStackedWallMember | Identifies if the wall is a member of a stacked wall.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element.)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Orientation | The normal vector projected from the exterior side of the wall.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchId | Returns id of the profile sketch, or invalidElementId if sketch does not exist.
Public property | StackedWallOwnerId | Gets the stacked wall which contains this stacked wall member.
Public property | StructuralUsage | Retrieves or changes the wall's designated structural usage.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WallType | Retrieves or changes the type of the wall.
Public property | Width | Get the overall thickness of the wall.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Wall Class


CrossSection Property

[image]

Revit 2024 API
Wall..::..CrossSection Property
Wall Class See Also Send Feedback
Obtain the Wall Cross-section for this wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022

Syntax

C#
public WallCrossSection CrossSection { get; set; }
Visual Basic
Public Property CrossSection As WallCrossSection
    Get
    Set
Visual C++
public:
property WallCrossSection CrossSection {
    WallCrossSection get ();
    void set (WallCrossSection value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The current wall does not support the cross section wallCrossSection.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also

Wall Class